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Revit Interoperability with CAD
Autodesk®  Revit®  is a complete architectural design and documentation solution, supporting all phases of design 

and all architectural drawings and schedules required for a building project. From massing and conceptual studies 

through the most detailed construction drawings and schedules, Autodesk Revit has tools for delivering productiv-

ity, coordination, and quality to the building team.

Autodesk Revit can be used alone or in conjunction with AutoCAD® . This guide will help those who are familiar 

with AutoCAD to understand how Autodesk Revit works, introducing some of the main features and concepts of 

Autodesk Revit and comparing them with similar features of AutoCAD. 

This guide also demonstrates how you can use Autodesk Revit with AutoCAD to manage a project and its deliver-

ables. You'll learn how to integrate existing AutoCAD projects with Autodesk Revit to produce construction docu-

ments. The process relies on the export compatibility of Autodesk Revit and the external referencing capabilities of 

AutoCAD.

Autodesk Revit provides DWG compatibility using the Autodesk ObjectDBX™  toolkit, and works with AutoCAD to 

ensure clear communication of design data among project teams.
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Features of Autodesk Revit 

True 3D Design

Using Autodesk Revit, you work with architectural models rather than geometry. With Autodesk Revit, you 
can switch among views and schedules as you like. Because you create a parametric building model, depen-
dencies are automatically updated as you make changes.

Parametric Objects 

Autodesk Revit contains 3D parametric building elements, which carry information about their relationships 
to other objects in the building, in contrast with the blocks and solids used in AutoCAD. For example, in 
Autodesk Revit, the properties of a wall can state that it should rise to the next level or roof. After you specify 
this property, the wall retains its relationship to the next level or roof regardless of other changes you may 
make in the building.

Dimensions correspond to the actual size of building elements. Updating a dimension updates the paramet-
ric components and their relationships to other components. Locking a dimension allows you to embed your 
design intent. After a dimension is locked, the dimensioned relationship is maintained. Dimensions in 
schedules behave in the same way: if you change width and height values in a schedule, the revised size is 
reflected in the elements of the model. Coordination of dimensions and graphics is assured throughout the 
project.

Families vs. Blocks

AutoCAD users are accustomed to storing symbols in individual DWG files. With Autodesk Revit, you store 
similar parametric components in family files. Family files can contain many styles of components, provid-
ing easy organization and data sharing, and offer numerous placement options. You can customize family 
files; for example, you can modify alignment planes or add subcategories to objects. You can also create intel-
ligent parametric objects or customize the ones included with Autodesk Revit.

Alignment vs. Osnaps

Autodesk Revit offers sketching tools such as temporary dimensions and alignment guides. Alignment guides 
are similar to the object snap features in AutoCAD. Temporary line and arc extensions, and snap points rel-
ative to your current position, aid you as you design. With Autodesk Revit, you can place components and 
modify the design later. Doors open in the desired direction and windows are placed at the correct height on 
the wall. You can place components in either two-dimensional (2D) or three-dimensional (3D) views.

Multiple Design Views

With Autodesk Revit you can work with components in any view, including schedules. Multiple views can 
be open at the same time, and changes made in one view are immediately updated in the others, making 
Autodesk Revit a valuable tool for experimenting with design changes. You can open plan and 3D views side 
by side, so that you can verify whether modifying a component on one level interferes with any design intent 
on another level.

No Command Line or Layers

AutoCAD users will notice the absence of a command line and the layer control feature. In Autodesk Revit, 
building tools and components are presented on a Design Bar. The software is designed to look and work like 
other familiar Microsoft®  Windows®  applications. Visibility of components is controlled through the Visi-
bility/Graphic Overrides feature, which works on a per-view basis (comparable to the AutoCAD Freeze/Thaw 
by viewport feature). Color and linetype are also controlled by category. The display of components depends 
on the view in which they are seen. For example, components display only a footprint in plan view, while 
displaying all geometry in a 3D isometric view.

Single File, Multi-User Projects

In Autodesk Revit, project data is stored in a single file, eliminating the need to work with external blocks 
and xrefs. Architects work in teams, with each assigned a specific functional area. This involves simulta-
neously working on and saving different portions of the project. Autodesk Revit projects can be subdivided 
into worksets. A workset is a collection of elements in the building that can be edited by one architect at a 
time.
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Parametric Relationships

By using the dimensioning and alignment locking features in Autodesk Revit, you can place building com-
ponents in relation to others and keep them that way throughout the design. You can lock components 
together in more than one place to preserve wall alignments, room areas, or door and window placements, 
even as the model is being altered in other areas. Component relationships may be constrained or overridden 
at your discretion. Dimensions may be locked or editable while the parent objects behave accordingly. 
Because objects can be aligned and locked into place, repetitive editing commands are eliminated, allowing 
for faster work and fewer errors.

Read/Write DWG

Autodesk Revit provides DWG compatibility using the Autodesk ObjectDBXTM toolkit. You can import and 
export models to DXF TM and DWG formats. When exporting, Autodesk Revit matches its components and 
their subcategories from the current view to AIA or user-defined layer names. You can also import these for-
mats into 2D or 3D views, allowing for smooth coordination and exchange of information among team 
members. 

Producing Paper Drawings

All drawings are produced from the single parametric building model used to create the design. Any changes 
to the design are updated in the drawing sheet views. Changes to elevations, sections, and callouts are imme-
diately updated in all reflected views. Any view that you create can be added to a sheet and scaled. After you 
place the drawing on a sheet, you can perform last-minute placements just as easily in a sheet view as in a 
model view. Scale-dependent line weight and scale-independent annotation size allow you to reuse informa-
tion in views without complex reformatting. The WYSIWYG display lets you see the final result before out-
put, reducing plotting errors. Plotter hardware support in Autodesk Revit is limited only by the operating sys-
tem. Autodesk Revit can use any Microsoft®  Windows®  driver available for your plotter. 

Using Autodesk Revit with AutoCAD

Here are the basic steps for using an Autodesk Revit project with AutoCAD:

1. Create the building model in Autodesk Revit.

2. Set up sheets for the project in Autodesk Revit.

3. Export selected views or sheets to DXF/DWG format for AutoCAD users.

4. Annotate the exported DXF/DWG files in AutoCAD by referencing the files.

5. Link any data created externally into Autodesk Revit as external reference files to keep data consistent.

Following is a workflow summary of tasks you'll perform as you work through a project using Autodesk Revit 
and AutoCAD:

At Project Startup

■ Set up the project in Autodesk Revit.
■ Create any necessary building scale views.
■ Define appropriate worksets.
■ Begin modeling the building.
■ Set up preliminary sheets in Autodesk Revit.

During Design Phases

■ Create any necessary enlarged scale views.
■ Continue modeling the building.

Conceptual Design Development Construction Documentation 

Draw and Annotate 

Revit:

AutoCAD:
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■ Create a "cartoon set" of sheets in Autodesk Revit.
■ Set up folders for linked files to be exported to AutoCAD.

At Start of Construction Documents

■ Create any necessary detail views.
■ Begin detailing the building.
■ Determine what details to reuse from an existing library.
■ Revise the cartoon set of sheets to include any additional sheets.
■ Create a list of sheets to be worked on in AutoCAD.
■ Export this list of sheets.
■ Link any AutoCAD data into the appropriate Autodesk Revit views.

At Conclusion of Construction Documents

■ Archive the files created.

Preparing for Data Export

When preparing to export an Autodesk Revit model, you need to consider export methods, file naming con-
ventions, data export options, and layering standards.

Exporting Views or Sheets

You can export either views or sheets, depending on the scope of work to be done in AutoCAD, as well as the 
progress of construction documentation in Autodesk Revit.

Exporting a view creates a DWG or DXF file of the currently selected Autodesk Revit view. All external data 
linked to the view will be embedded as a block in DWG or DXF format. Use this method when you intend 
to annotate only selected views in AutoCAD.

Exporting an entire sheet from Autodesk Revit produces a set of DWG or DXF files. One file contains sheet 
information (borders, title block) with a viewport for each view. Each Autodesk Revit view becomes an indi-
vidual file referenced into the sheet file and displayed in the appropriate viewport. All files are located in the 
same directory to facilitate tracking and management. 

Naming Conventions

To keep file names consistent throughout the project, use the Autodesk Revit default naming convention, as 
shown here:

Exported Sheets

[Project Filename]-[View Category]-[Sheet Number]-[Sheet Name].[Extension]
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Exported Views (on sheets)

[Project Filename]-[Extension]-[View Category]-[Sheet Number]-[Sheet Name]--[View Identifier].[Extension]

■ Project Filename: Name of the Autodesk Revit file
■ Extension: Standard Autodesk Revit file extension (rvt, rft, rfa), depending on the file open in Autodesk 

Revit
■ View Category: Floor Plan, 3D View, Elevation, Section, Drafting View, or Drawing Sheet
■ Sheet Number: Standard sheet number
■ Sheet Name: Standard sheet name
■ View Identifier: Standard view name
■ Extension: Exported DWG or DXF, depending on user selection

Data Export Options

The following options are available in the Export dialog box:

Export Range: Select either the current view or a set of views/sheets. The latter facilitates a batch-like export 
of a range of views.

Export Layers File: The file displayed by default is the current export layer standard. You can select a different 
export standard if you wish.

Layering Standards

In the Export Layers dialog box, categories and subcategories of Autodesk Revit host components are mapped 
to a layer name and color number for use in a DWG or DXF file, using settings specified in special text files 
in the Revit\Data directory. By default, Autodesk Revit uses the last-specified export layer standard. The soft-
ware supplies files for the AIA, BS1192, ISO 13567, and CP 83 standards. You can select from these or create 
custom standards.



6 | Revit Interoperability with CAD

You can incorporate custom office-dependent layering standards into the workflow and apply them to exter-
nal files. This helps to ensure data consistency within a multi-platform environment.

Drafting in AutoCAD

The following techniques will facilitate a smooth workflow in a multi-platform project environment.

Linking Files 

Rather than drafting directly in DWG or DXF files exported from Autodesk Revit, you should use the 
AutoCAD external reference (xref) functionality. Open an empty drawing in AutoCAD and, using the Xref 
Manager, attach the exported Autodesk Revit view as an Overlay for Reference Type. 

Referencing Views and External Data

Because Autodesk Revit does not require the use of coordinates, the guidelines given here ensure precise 
alignment between externally created data and the building model. These methods prevent offsets from 
occurring when exported DWG or DXF data is referenced into AutoCAD, as well as when externally created 
data is re-imported into Autodesk Revit.

In AutoCAD, use 0,0,0 as the insertion point when using xrefs. Do not change the insertion point to Specify 
On-screen. Specifying a user coordinate system or using wblocks can introduce new origins and offsets when 
re-importing AutoCAD data into Autodesk Revit. 

Try to maintain a form of visual proof or a reference point for externally created data. Building features often 
give the best visual feedback to ensure precise alignment. You might also locate points or other reference 
marks at grid intersections. 

Externally created data can be aligned precisely using the Autodesk Revit snapping, alignment, and locking 
functions.

Naming Drawings

Using the default Autodesk Revit naming convention is highly recommended. For more information, see 
“Naming Conventions” on page 4.
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If new drawings created outside Autodesk Revit use data exported from Revit as the external reference, appro-
priate file names are required. Use the name of the existing DWG or DXF file and add a prefix or suffix to 
create the new file name. 

For example, a drawing might use the following file as an external reference:

Hotel ProdEx-MT Copy-rvt-Floor Plan-Level 16-Mechanical.dwg 

When the drawing is re-imported into the Autodesk Revit view 'Level 16 - Mechanical,' it could have this 
name:

Hotel ProdEx-MT Copy-rvt-Floor Plan-Level 16-Mechanical-ANNO.dwg

Referencing Data into Autodesk Revit

Finally, data created in the external system is referenced into Autodesk Revit to ensure consistency through-
out the design and documentation phases.

Preparing for Referencing

In AutoCAD, unload the external references that were exported from Autodesk Revit to avoid redundant dis-
play of information (unless such display is desired for temporary referencing purposes). 

File Linking Options

On the Autodesk Revit File menu, click Import/Link ➤ DWG, DXF, DGN to bring in external data.

The Import/Link dialog box in Autodesk Revit offers options for linking a document created externally.

Import or Link

You can reference DWG or DXF data created in AutoCAD into the current Autodesk Revit project.

■ Link (instead of import): Select Link if you want data to automatically update when the external file is 
changed.

■ Current view only: Select Current view only to ensure linked files are visible only in the current view. It 
also ensures correct display of annotations and dimensions. 

Scaling
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In most cases, use Auto-Detect to generate correct scaling of linked data. 

Layer/Level Colors

These three options control the appearance of the file linked into Autodesk Revit.

■ Black and White: Ignores color information in the external file and displays linked data as black and white 
vectors.

■ Preserve Colors: Preserves the layer or level color settings in the external file.

■ Invert Colors: Inverts the colors in the linked file, making them easier to see. If you use a black background 
in AutoCAD, colors may not be appropriate on a white background in Autodesk Revit.
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Positioning 

If you followed the guidelines in “Referencing Views and External Data” on page 6, correct alignment is best 
assured by selecting Automatically place in the Import/Link dialog box.

■ Automatically place: Select one of these options for automatic placement:

■ Center-to-center:  Aligns the center of the linked or imported file to the center of the Autodesk Revit 
view. Use this option when external data is offset from the origin of the drawing.

■ Origin to origin:  Aligns the origin of the imported or linked file to the origin of the Autodesk Revit view. 
Use this option when relinking DWG files originally created in Autodesk Revit.

■ By shared coordinates:  Acquires origin for use with Autodesk Revit files. Use this option when linking 
multiple buildings together that need to maintain a relationship to each other, or when linking a num-
ber of building files together with a site plan.

■ Manually place: If offsets and dislocations were introduced during the process, or if you want to link a 
detail into a drafting view, these options help position the data that is externally linked:

■ Cursor at origin: The linked file appears attached to the Autodesk Revit cursor at its origin. This is the 
typical option to manually place data.

■ Cursor at base point: The linked file appears attached to the Autodesk Revit cursor at its base point.
■ Cursor at center: The linked file appears attached to the Autodesk Revit cursor at its graphic center 

point. This option is helpful when handling widely displaced data.
■ Place at level: The linked file appears attached to the designated Autodesk Revit level.

Controlling the Appearance of Linked Data

The appearance of imported or linked data is managed using the Imported Objects tab in the Object Styles 
dialog box. On the Settings menu, click Object Styles. You can control the line weight, line color, line pattern, 
and the material for each layer or level in the linked file.
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Specifying Line Weights in Linked or Imported Drawings

You can specify line weights in imported files. On the File menu, click Import/Export Settings, and then click 
Import Line Weights DWG/DXF. This dialog box coordinates color mapping in linked files to Autodesk Revit 
line weights. The mapping can be saved to or loaded from an external text file. 

You can review Autodesk Revit line weight settings by clicking Line Weights on the Settings menu. Because 
Autodesk Revit line weights have different widths at different scales, many imported colors may map to a 
single line weight.
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Controlling the Visibility of Entities in Linked Files

You control visibility of entities in imported files in the Visibility/Graphic Overrides dialog box. On the 
DWG/DXF/DGN Categories tab, you can specify visibility by layer for entire imported files or for all imports 
as a whole.
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Step by Step: Exporting to AutoCAD and Relinking to Autodesk 
Revit

This graphic illustrates the process of exporting a view from Autodesk Revit into an empty DWG file. After 
you edit the file in AutoCAD, you link it back into the Autodesk Revit project. 

Using a floor plan view as an example, the following steps show you how to use AutoCAD to annotate build-
ing model data created in Autodesk Revit. 

Step 1: Export the Data

In Autodesk Revit, you can export either single views or entire sheets. When exporting entire sheets, you 
export the files into different subdirectories, giving each directory the same name as the sheet itself to ensure 
consistent naming throughout the project.

Autodesk Revit 

Revit DWG 

New DWG AutoCAD 
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Step 2: Draft and Annotate in AutoCAD

For each Autodesk Revit view to be annotated in AutoCAD, open a new DWG file using either a template file 
or Start from Scratch.

Use Attach in the Xref Manager to externally reference the exported views created in Step 1. 
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Be sure to use 0,0,0, not Specify On-screen, as the insertion point in AutoCAD. Select Overlay for Reference 
Type. (Unlike Attachment, an overlaid xref is not included when the host drawing is itself attached or over-
laid as an xref in another drawing.)

You can now begin drafting and annotating in AutoCAD.
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Step 3: Save the Drawing 

Save the drawing in the same directory as the linked DWG file. Create the file name by adding a suffix to the 
name of the linked file. For example, when the linked DWG name is

Floor Plan-Level 1.dwg,

 the annotated DWG file should be

Floor Plan-Level 1-ANNO.dwg.

Step 4: Link the Edited DWG File into Autodesk Revit

There are two ways to link edited DWG files. You can link the newly created DWG file with or without the 
underlying AutoCAD xref attached. Both methods are discussed here.
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Linking the File with the Underlying Xref Attached
This method ensures that the data created in the DWG file is precisely inserted into Autodesk Revit, because 
the originally exported file is still visible. This method is recommended for concurrent use of AutoCAD and 
Autodesk Revit while annotating views in Autodesk Revit is still underway.

On the Autodesk Revit File menu, click Import/Link ➤ DWG, DXF, DGN, and select the newly-created DWG 
file in the Import/Link dialog box. Select the Link (instead of import) and the Current view only options. 
Under Positioning, select Automatically Place, and then select Origin to origin.

After the file is linked, suppress display of the Autodesk Revit-generated elements. In AutoCAD, unload the 
Autodesk Revit exported file. Return to Autodesk Revit and click Manage Links from the File menu. Select the 
linked file, and click Reload.



Step by Step: Exporting to AutoCAD and Relinking to Autodesk Revit | 17

As an alternative, you can turn off layers that were generated by the original export on the DWG/DXF/DGN 
Categories tab in the Visibility/Graphics Override dialog box. Either method removes display of redundant 
entities.

Linking the File Without the Underlying Xref 
Use this method if you do not need to see the original Autodesk Revit-derived data in the AutoCAD xref. After 
you annotate the DWG file, you unload the xref , and then save the file before linking it back into Autodesk 
Revit. In AutoCAD, you now see only the annotation that you created.

When you link the file in Autodesk Revit, the annotation you added externally displays without the redun-
dant display of AutoCAD entitities.

If you need to reference the Autodesk Revit data in AutoCAD in the future, reload the xref in Xref Manager 
and save the file. It remains visible in AutoCAD, but is not visible when the edited DWG is linked into 
Autodesk Revit.
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Step by Step: Linking DWG Details to Autodesk Revit 

The steps in this section show you how to link existing DWG details to an Autodesk Revit project.

Step 1: Create Drafting Views for the DWG Files 

For each detail you want to import or link, create and name new drafting views in Autodesk Revit, as shown 
here.

Step 2: Import or Link the DWG Files

After the drafting view has been created, you either import or link the external file. Open the new drafting 
view, and on the File menu, click Import/Link ➤ DWG, DXF, DGN. Select the Preserve colors and the Center-
to-center options for the best performance.

If you import the file, the data is embedded in the Autodesk Revit project. If you link the files, the result is a 
smaller Autodesk Revit file that can be further modified in AutoCAD. Autodesk Revit automatically gets the 
most current version of the linked file whenever the project is opened or the link is reloaded. It is best to use 
Link if you plan to develop details in AutoCAD. Import is recommended if you plan to modify your details 
using Autodesk Revit.
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Step 3: Place the Details on a Sheet

After arranging the individual detail files in drafting views, open an existing sheet or create a new sheet for 
the details. On the View menu, click New ➤ Sheet. In the Select a Titleblock dialog box, select the desired 
titleblock.

After you have created the sheet, place the drafting views. EPlace drafting views in the same way you would 
place any view created in Autodesk Revit. Either drag the desired views from the Project Browser onto the 
sheet or, on the View menu, click New ➤ Add View, and then select the desired view.

Place drafting views in the same way you would place any view created in Autodesk Revit. After you have 
placed the view, the DWG details are part of your Autodesk Revit set.



20 | Revit Interoperability with CAD


