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Introduction

Autodesk 3ds Max Design 2011 is a 3D modeling, animation, and rendering solution for
design visualization, games, film, and television.

B Delto Tracing

MARTHASHOF Residential Project, Berlin
Delta Tracing
Copyright © 2008

http://www.deltatracing.com/
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Tim Wilbers, University of Dayton
Copyright © 2008
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Jeff Patton
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www.jeffpatton.net

What's New in Autodesk 3ds Max Design 2011

Autodesk 3ds Max Design 2011 offers compelling new techniques for creating
and texturing models, animating characters, and producing high-quality
images. Incorporating tools that accelerate everyday workflows, Autodesk 3ds
Max Design 2011 software helps significantly increase productivity for both
individuals and collaborating teams working on games, visual effects, and
television productions. Artists can focus on creativity, and have the freedom
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to iteratively refine their work to maximize the quality of their final output
in the least amount of time.

NOTE This topic lists all significant new features, but does not include every change
in 3ds Max Design. As you proceed through the documentation, keep an eye out

for the D icon, which indicates a new feature.

You can also use the index in this help to find topics that contain information
about new features. For topics that describe new program features, check the
index entry "new feature." For changes in existing features, check the index entry
"changed feature."

Following are lists (high-level, then detailed) of major new features with brief
descriptions and links to the relevant reference topic:

New Quicksilver hardware rendering on page 10

New local edits to containers on page 7

New Viewport Canvas features on page 10

New 3ds Max Composite on page 6

New Slate Material Editor on page 9

Enhanced viewport material display on page 9
Simplified material/map browsing on page 9

New CAT character-animation toolset on page 10
New FBX File Link for Revit files on page 8

Better Inventor importing on page 8

SAT Import/Export and solid-model support on page 8
New Caddy interface on page 7

New ribbon customization on page 7

New Autodesk Materials library and workflow on page 9
New Save to 3ds Max Design 2010 on page 8

New mental ray 2011 on page 11

SketchUp file support on page 8
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Improved OpenEXR support on page 8
Enhanced SGI file support on page 9

New and changed online resources on page 5
Improved interactive selection on page 7
Better snapping on page 7

Bitmap pager changes on page 10
Animation-preview changes on page 10

Windows 7 Support on page 6

Online Resources

The following Web-based resources have changed or are new:

All tutorials and associated files are available online only, here:
http://www.autodesk.com/3dsmaxdesign-tutorials-v2011

An HTML version of the help is available here:
http://www.autodesk.com/3dsmaxdesign-help-v2011

Access the Student Community at Help menu » 3ds Max Design on the
Web » Student Community

Access the new Vegetation Library, a downloadable collection of free
vegetation scene files, at Help menu » 3ds Max Design on the Web »
Download Vegetation Library. This launches the Autodesk Seek page in
your default Web browser.

TIP To get a plant model and all associated files, including variations and maps,
click the ZIP icon for the plant and then download the 3ds Max version of the
Zip file.
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General Improvements

3ds Max Composite

You can install the 32- or 64-bit version of 3ds Max Composite to use with
Autodesk 3ds Max Design 2011 from the Tools and Utilities section of the
installer. 3ds Max Composite includes:

Raster and Vector Paint

Image Processing

Color Correction

Keying and Rotoscoping
Stereoscopic Production Support
Motion Blur

Advanced 2D Tracking

Camera Mapping

Depth of Field

Node and Layer-based Compositing Options
Spline-Based Warping

Enhanced Render Passes

Data Managing and Collaborating

Refer to the Installation Guide for complete details on specifications for this
release (Click Documentation in the bottom-left corner of the Installer).

Windows 7 Support

Windows® 7 is a supported OS for Autodesk 3ds Max Design 2011. Refer to
the Installation Guide for complete details on specifications for this release (Click
Documentation in the bottom-left corner of the Installer).
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Modeling

Modeling Ribbon

The modeling ribbon boasts a new Object Paint on page 2146 toolset, a significant
new customization utility on page 2165, and a number of refinements that
streamline modeling workflow. These include:

B A command to switch the ribbon between horizontal and vertical
orientation is available from the ribbon right-click menu.

B You can now minimize the ribbon to panel buttons, each of which includes
a descriptive icon.

B A number of ribbon tooltips include new ToolClips: short videos that show
how to use the tool.

Caddy Settings Controls

Most editable poly settings now use the caddy on page 2340, a new “in-canvas”
interface that comprises a label and a set of buttons superimposed on the
viewport. The caddy replaces the old settings dialogs, leaving a greater portion
of the model visible and accessible.

Control-key Behavior

In versions of 3ds Max Design prior to Autodesk 3ds Max Design 2011, holding
down the Ctrl toggled an object’s selection state. That is no longer the case.
To add an object to a selection, use Ctrl. To remove an object from a selection,
use Alt. See Basics of Selecting Objects on page 155.

Snap Improvements for the Move Tool

A new snap handle located at the axis center gives you more accurate control
over snapping when you move an object, with better visual feedback. See Snap
Handle When Moving an Object on page 2836 for details.

Scene and Project Management

Container Expansion

The Container feature has been significantly expanded with new rules and
locking tools, proxy containers, and more. For details, see What's New in
Containers on page 7893.
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File Link for Revit FBX Files

With the File Link Manager on page 8051, you can now link FBX files exported
from Revit 2009 and Revit 2010. File Link lets you create high-quality
renderings in 3ds Max Design while maintaining a single design database in
another application such as Revit, AutoCAD, or AutoCAD Architecture.

For details about how to link Revit FBX files, see File Link Settings: FBX Files
Dialog on page 8061.

Save As Previous Feature

The Save As Previous on page 7996 feature allows you to save Autodesk 3ds Max
Design 2011 scenes as 3ds Max Design 2010 scenes. You can also save
Container (MAXC) files in 3ds Max Design 2010 format.

Not all features supported in Autodesk 3ds Max Design 2011 are supported in
3ds Max Design 2010. See Save As Previous on page 7996 for details.

Improved Inventor File Support

You can now import Autodesk Inventor files (IAM and IPT) without needing
to have Inventor installed, and you can keep the data in ACIS-solids format
by importing as Body Objects. See Importing Autodesk Inventor Files on page
8262.

SAT File Import and Export

Import and export solid models in the SAT format supported by Autodesk
Inventor and Revit as well as applications from other vendors. Imported
geometry takes the form of Body Objects, which you can modify and render
just like standard objects; you can even combine Body Objects with 3D Boolean
operations. You can also convert standard objects to Body Objects and export
them as ACIS solids. See SAT Files on page 8348.

SketchUp File Import

You can now import 3D data in the Google SketchUp format (SKP), including
cameras and materials. Imported objects take the form of editable polys. See
SketchUp Importer on page 8394.

Improved OpenEXR Support

The OpenEXR plug-in on page 8466 from previous releases has been replaced
by a plug-in that offers improved performance and feature support.
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The improvements include:

Better performance

Unlimited number of layers in one EXR file
Ability to save Render Elements

Ability to save G-buffer data

Available to MAXScript applications

Improved Support for SGI Image Files

The SGI Image File plug-in on page 8495 has been updated to support all formats.
It now includes an option to turn off Compression when you save an SGI
Image File. The new plug-in is compatible with SGI Image files used by
OpenFlight (FLT) files, and the option to use a special RGB file loader has been
removed from the Flight Studio utility on page 8283.

Materials and Mapping

Slate Material Editor

The Slate Material Editor on page 6117 is an alternative Material Editor that
provides a visual, node-based interface for creating and editing materials with
complex networks of maps and shaders. It includes aids for managing the
large numbers of materials required by today’s productions.

MetaSL Shaders

Autodesk 3ds Max Design 2011 provides a number of MetaSL shaders on page
6894 you can use in the Slate Material Editor to create shader trees. In addition,
with the Map To Material Conversion material node on page 6412 MetaSL shader
trees can be visible in viewports and renderings.

Material/Map Browser

The Material/Map Browser on page 6201 has been redesigned to feature a simpler
and more accessible interface that is also an integral part of the Slate Material
Editor.

Autodesk Materials and the Autodesk Material Library

Autodesk Materials on page 6258 replace ProMaterials, using a new interface
that allows you to share materials with models from AutoCAD, Autodesk Revit,
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and Autodesk Inventor. (Scenes from earrlier 3ds Max Design versions that
use ProMaterials continue to render in Autodesk 3ds Max Design 2011.)

In addition, the Autodesk Materials form the basis for the Autodesk Material
Library, which provides 700 ready-made materials you can use in your scenes.

Viewport Canvas Expansion

Viewport Canvas on page 6913 has been significantly enhanced and improved
to the point that it is, in effect, an entirely new feature. For example, you can
now paint directly onto any 3D object with any map in any material. And
new painting tools include Blur, Sharpen, Dodge, and Burn. But perhaps most
important, you can now paint in multiple layers that can interact with one
another the same way as in Adobe Photoshop.

Rendering

Quicksilver Hardware Renderer

The Quicksilver Hardware renderer on page 7294 is an extremely fast renderer
that uses your system’s graphics hardware (GPU) to produce high-quality
images.

Bitmap Pager Changes

In Autodesk 3ds Max Design 2011, you can disable or enable bitmap paging
from the Asset Tracking dialog on page 8153 » Bitmap Performance And
Memory menu, or the Global Settings And Defaults For Bitmap Proxies dialog
on page 8169.

Preview Animations

“Preview” has been renamed “Animated Sequence File,” and the commands
for preview animations are now grouped with Create Still Image File on page
7392 in the Grab Viewport Group on the Tools menu on page 8629. See Create
Animated Sequence File on page 7394.

Character-Animation Improvements

CAT

CAT provides a complete toolset ideally suited for rigging and animating
multi-legged characters as well as humanoids. It includes numerous built-in
rigs such as a dragon with four legs and two wings, a spider, and a centipede
with 18 legs. These can easily be animated along paths with no foot sliding
using the graph-based CATMotion editor. CAT’s easy-to-use layering system
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supports color-coding of layers so you can see which layer is contributing to
the motion at any given moment. See CAT on page 4508, and for a comparison
of CAT and character studio, see Character Animation on page 4507.

mental ray Improvements

mental ray 2011

mental ray 2011 is supported with 3ds Max Design. For further information
about mental ray 2011, view the help file from Help > Additional Help.

3ds Max Design Documentation Set

The documentation set for 3ds Max Design® comprises online material only.
Most documents are available from the Start menu > Programs > Autodesk >
[program folder] > Help folder, as well as from the Help menu within 3ds Max
Design or the Additional Help dialog.

B Autodesk 3ds Max 2011 and Autodesk 3ds Max Design 2011 Installation
Guide: Contains complete installation, configuration, and troubleshooting
instructions, including system requirements. Also includes information
on uninstalling and maintaining 3ds Max Design, as well as descriptions
of the full install documentation set. Also find information about network
deployment in this guide. View the Installation Guide in the Installation
Wizard.

NOTE The complete installation documentation set is found on your install
DVD in the \en-US\Docs folder at the root of the DVD.

B Autodesk 3ds Max Design 2011 Readme (3ds_Max_Readme.htm): Contains
the latest information about 3ds Max Design. This file is displayed when
you finish installing 3ds Max Design.

B Autodesk 3ds Max Design 2011 Help: This document covers fundamental
concepts and strategies for using the product, as well as details about the
features of 3ds Max Design.

Access the reference by choosing Help > Autodesk 3ds Max Design Help.

B Autodesk 3ds Max Design 2011 Tutorials: Contains tutorial information
and detailed procedures to walk you through increasingly complex
operations. This is the best source for learning 3ds Max Design.

Access the tutorials by choosing Help > Tutorials.
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NOTE Note that these tutorials reside on the web so an internet connection
is required. To access the tutorial scene files, go to
http://www.autodesk.com/3dsmaxdesign-tutorials-scene-files-v2011.

B MAXScript Help: Describes the MAXScript scripting language on page 14.
Check out the “Learning MAXScript” chapter there if you're new to
MAXScript.

Access the MAXScript Help by choosing Help > MAXScript Help.

B Additional mental ray® Help Files: Documentation from mental images®
is available from Help menu > Additional Help. There, you'll find the mental
ray Reference, comprising the mental ray Manual, mental ray Shader Reference,
and LumeTools Collection. You'll also find PDF files documentating various
mental ray shader libraries.

NOTE The Autodesk 3ds Max Design 2011 Help documents most mental ray
components available in the 3ds Max Design user interface. This includes
documentation for lights for mental ray and specific shadow types, controls
for adding mental ray shaders to lights and cameras, mental ray materials,
custom shaders for 3ds Max Design, and the mental ray renderer controls.

B Additional Backburner Files: Procedures for using Backburner from inside
3ds Max Design are documented in this Autodesk 3ds Max Help File. For
further information on using and configuring Backburner, refer to the
additional Backburner documentation available from Additional Help as
well as from the Start menu location described in the introduction of this
topic. The two documents related to Autodesk Backburner are called:

B Backburner Installation Guide

B Backburner User’s Guide

NOTE For information on installing Autodesk Backburner, see the Autodesk
3ds Max 2010 and Autodesk 3ds Max Design 2010 Installation Guide.

B FBX Plug-in Help: Access the FBX Plug-in Help from the Additional Help
menu. You can also click the ? (Help) button on the FBX Importer/Exporter
dialog.

The FBX plug-in changes often, with the result that Autodesk updates it
more frequently than it does this program. Be sure to check regularly for
updated versions by clicking the Web Updates button on the dialog.
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How to Print from the Online Help

If your computer is connected to a printer, you can print single help topics
or entire chapters.

To print a topic or chapter, highlight the topic or chapter title and click the
Print button at the top of the help display. A dialog opens.

Print Topics EI

“'ou can prnt the zelected topic or all the topics in the
zelected heading. 'What would you like to do’?

£+ Frint the selected topic
" Print the gelected heading and all subtopics

k. I Cancel

Choose to print only the selected topic, or to print all topics in that chapter.
After you make your selection, another dialog appears where you can choose
your printer and other options.
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The tabs available at the top of the dialog depend on the selected printer.
Choose options for the print job, and click OK to begin printing.

How to Contact Us

We are also interested in hearing your views about 3ds Max Design. We’d like
to hear ways you think we can improve our program, features you're interested
in, as well as your views on the documentation set.

Please send us email about the documentation set at:
me.documentation@autodesk.com

About MAXScript

MAXScript is the built-in scripting language for 3ds Max Design.

14 | Chapter 1 Introduction


me.documentation@autodesk.com

With MAXScript, you have the ability to:

W Script all aspects of 3ds Max Design use, such as modeling, animation,
materials, rendering, and so on.

B Control 3ds Max Design interactively through a command-line shell
window.

W Package scripts within custom utility panel rollouts or modeless windows,
giving them a standard 3ds Max Design user interface.

B Build custom import/export tools using the built-in file I/O.

B Write procedural controllers that can access the entire state of the scene.
Build batch-processing tools, such as batch-rendering scripts.

B Set up live interfaces to external system using OLE Automation.

The MAXScript language is specifically designed to complement 3ds Max
Design. It is object-oriented, and has several special features and constructs
that mirror high-level concepts in the 3ds Max Design user interface. These
include coordinate-system contexts, an animation mode with automatic

keyframing, and access to scene objects using hierarchical path names that
match the 3ds Max Design object hierarchy.

The syntax is simple enough for non-programmers to use, with minimal
punctuation and formatting rules.

Visual MAXScript

Visual MAXScript is a powerful addition to MAXScript, making the MAXScript
feature easier to learn and use. With Visual MAXScript, you can quickly create
Ul elements and layouts for scripting.

For detailed information about Visual MAXScript, open the MAXScript Help,
available from Help menu > MAXScript Help.

See also:

B MAXScript Menu on page 8659

Procedures

To access MAXScript, do one of the following:

1 On the menu bar, choose MAXScript. The MAXScript menu appears.
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2 Choose Utilities panel > MAXScript.

From here, you can either write new scripts, edit or run existing scripts,
open the MAXScript Listener, or use the Macro Recorder.

To access the MAXScript Listener, you can also right-click in the Mini
Listener and choose Open Listener Window from the right-click menu.

For detailed information about the MAXScript utility, open the MAXScript
Help, available from Help menu > MAXScript Help.
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Getting Started with 3ds
Max Design

You use 3ds Max Design to quickly create professional-quality 3D models, photorealistic still
images, and film-quality animation on your PC.

Before using this reference material, we highly recommend you get to know 3ds Max Design
firsthand by following the included tutorials. You can access the tutorials using the Help
menu » Tutorials command.
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See also:
B Working with AutoCAD, AutoCAD Architecture, and Revit Files on page 8099

B Quad Menu on page 8679
B Customize Display Right-Click Menu on page 8867

Project Workflow

Once you've installed 3ds Max Design (see the Installation Guide included with
your software package), you open it from the Start menu, or use any other
Windows method. The figure below shows the application window with a

scene file loaded.
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NOTE If you open 3ds Max Design from a Command Prompt window or batch
file, you can add command-line switches. See Starting 3ds Max Design from the

Command Line on page 8613.
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NOTE 3ds Max Design is a single-document application, meaning you can work
on only one scene at a time. You can run 3ds Max Design several times and open
a different scene in each instance, but doing so requires a lot of RAM. For best
performance, open only one instance and work on one scene at a time.

Modeling Objects

You model and animate objects in the viewports, whose layout is configurable.
You can start with a variety of 3D geometric primitives. You can also use 2D

shapes as the basis for lofted or extruded objects. You can convert objects to

a variety of editable surface types, which you can then model further by pulling
vertices and using other tools.

Another modeling tool is to apply modifiers to objects. Modifiers can change
object geometry. Bend and Twist are examples of modifiers.

Modeling, editing, and animation tools are available in the command panels
and toolbar. See Modeling Objects on page 25.

Material Design

You design materials using the Material Editor, which appears in its own
window. You use the Material Editor to create realistic materials by defining
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hierarchies of surface characteristics. The surface characteristics can represent
static materials, or be animated. See Material Editor on page 6053.

Lights and Cameras

You create lights with various properties to illuminate your scene. The lights
can cast shadows, project images, and create volumetric effects for atmospheric
lighting. Physically-based lights let you use real-world lighting data in your
scenes and Radiosity on page 7104 provides incredibly accurate light simulation
in renderings. See Lights on page 5676.
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The cameras you create have real-world controls for lens length, field of view,
and motion control such as truck, dolly, and pan. See Cameras on page 5941.

Animation

You can begin animating your scene at any time by turning on the Auto Key
button. Turn the button off to return to modeling. You can also perform
animated modeling effects by animating the parameters of objects in your
scene. You can learn more about animating in Animating Your Scene topic
on page 32.
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When the Auto Key button is on, 3ds Max Design automatically records the
movement, rotation, and scale changes you make, not as changes to a static
scene, but as keys on certain frames that represent time. You can also animate
many parameters to make lights and cameras change over time, and preview
your animation directly in the 3ds Max Design viewports.

You use Track View on page 3831 to control animation. Track View is a floating
window where you edit animation keys, set up animation controllers, or edit
motion curves for your animated effects.

Rendering

Rendering adds color and shading to your scene. The renderers available with
3ds Max Design include features such as selective ray tracing, analytical
antialiasing, motion blur, volumetric lighting, and environmental effects. See
Rendering Your Scene on page 32.
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When you use the default scanline renderer, a radiosity solution on page 7104
can provide accurate light simulation in renderings, including the ambient
lighting that results from reflected light. When you use the mental ray renderer,

a comparable effect is provided by global illumination on page 7196.

If your workstation is part of a network, network rendering can distribute
rendering jobs over multiple workstations. See Network Rendering on page
7404.

With Video Post on page 7743, you can also composite the scene with animations
stored on disk.

A Typical Project Workflow

These topics explain the basic procedures for creating scenes:

Setting Up Your Scene on page 24

Modeling Objects on page 25

Using Materials on page 26

Placing Lights and Cameras on page 28

Animating Your Scene on page 32
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Rendering Your Scene on page 32

Setting Up Your Scene

You start with a new unnamed scene when you open 3ds Max Design. You
can also start a new scene at any time by choosing New or Reset from the
Application menu on page 8617.

Choosing a Unit Display

You choose a system of unit display on the Units Setup dialog on page 8996.
Choose from Metric, Standard US, and Generic methods, or design a custom
measuring system. You can switch between different systems of unit display
at any time.

NOTE For best results, use consistent units when you are going to:
B Merge scenes and objects on page 8138.

B Use XRef objects on page 8008 or XRef scenes on page 8036.

Setting the System Unit

The System Unit setting, in the Units Setup dialog on page 8996, determines
how 3ds Max Design relates to distance information you input to your scene.
The setting also determines the range for round-off error. Consider changing
the system unit value only when you model very large or very small scenes.

Setting Grid Spacing

Set spacing for the visible grid in the Grid And Snap Settings dialog » Home
Grid panel on page 2865. You can change grid spacing at any time.

See Precision and Drawing Aids on page 2809 for information about the system
unit, unit display, and grid spacing.
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Setting the Viewport Display

Viewport layout options

The default four viewports in 3ds Max Design represent an efficient and popular
screen layout. Set options in the Viewport Configuration dialog on page 9005
to change viewport layout and display properties.

See Viewing and Navigating 3D Space on page 47 for more information.

Saving Scenes

Save your scene frequently to protect yourself from mistakes and loss of work.
See Backing Up and Archiving Scenes on page 44.

Modeling Objects

You model objects in your scene by creating standard objects, such as 3D
geometry and 2D shapes, and then applying modifiers to those objects. 3ds
Max Design includes a wide range of standard objects and modifiers.

1
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Creating Objects

You create objects by clicking an object category and type on the Create panel
and then clicking or dragging in a viewport to define the object's creation
parameters. 3ds Max Design organizes the Create panel into these basic
categories: Geometry, Shapes, Lights, Cameras, Helpers, Space Warps, and
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Systems. Each category contains multiple subcategories from which you can
choose.

You can also create objects from the Create menu by choosing an object
category and type and then clicking or dragging in a viewport to define the
object's creation parameters. 3ds Max Design organizes the Create menu into
these basic categories: Standard Primitives, Extended Primitives, AEC Objects,
Compound, Particles, Patch Grids, NURBS, Dynamics, Shapes, Lights, Cameras,
Helpers, Space Warps, and Systems.

See Basics of Creating and Modifying Objects on page 290.

Selecting and Positioning Objects

You select objects by clicking or dragging a region around them. You can also
select objects by name or other properties such as color or object category.

After selecting objects, you position them in your scene using the transform
tools Move, Rotate, and Scale. Use alignment tools to precisely position objects.

See Selecting Objects on page 149, Moving, Rotating, and Scaling Objects on
page 821, and Precision and Drawing Aids on page 2809.
Modifying Objects

You sculpt and edit objects into their final form by applying modifiers from
the Modify panel. The modifiers you apply to an object are stored in a stack.
You can go back at any time and change the effect of the modifier, or remove
it from the object.

See Basics of Creating and Modifying Objects on page 290.

Using Materials

You use the Material Editor to design materials and maps to control the
appearance of object surfaces. Maps can also be used to control the appearance
of environmental effects such as lighting, fog, and the background.
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Room on left uses the a neutral, gray material.

Room on right uses a realistic materials, including transparent glass and a snowfall..

Basic Material Properties

You set basic material properties to control such surface characteristics as
default color, shininess, and level of opacity. You can create realistic,
single-color materials using just the basic properties.
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Using Maps

You extend the realism of materials by applying maps to control surface
properties such as texture, bumpiness, opacity, and reflection. Most of the
basic properties can be enhanced with a map. Any image file, such as one you
might create in a paint program, can be used as a map, or you can choose
procedural maps that create patterns based on parameters you set.

3ds Max Design also includes a raytrace material and map for creating accurate
reflections and refraction.
Viewing Materials in the Scene

You can view the effect of materials on objects in a shaded viewport, but the
display is just an approximation of the final effect. Render your scene to view
materials accurately.

See Designing Materials on page 6015.

Placing Lights and Cameras

You place lights and cameras to complete your scene in much the same way
lights and cameras are placed on a movie set prior to filming.
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Lights and cameras placed to compose a scene
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The resulting scene

Default Lighting

Default lighting evenly illuminates the entire scene. Such lighting is useful
while modeling, but it is not especially artistic or realistic.

Placing Lights

You create and place lights from the Lights category of the Create panel or
menu when you are ready to get more specific about the lighting in your
scene.

3ds Max Design includes the following standard light types: omni, spot, and
directional lights. You can set a light to any color and even animate the color
to simulate dimming or color-shifting lights. All of these lights can cast
shadows, project maps, and use volumetric effects.

See Guidelines for Lighting on page 5692.

Photometric Lights

Photometric lights on page 5711 provide you with the ability to work more
accurately and intuitively using real-world lighting units (lumens and candelas).
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Photometric lights also support industry-standard photometric file formats

(IES on page 5739, CIBSE on page 9160, LTLI on page 9253) so that you can model
the characteristics of real-world manufactured luminaires, or even drag
ready-to-use luminaires from the Web. Used in conjunction with the 3ds Max
Design radiosity solution on page 7104, photometric lights let you evaluate more
accurately (both physically and quantitatively) the lighting performance of

your scene.

Photometric lights are available from the Create panel » Lights drop-down
list.

Daylight System

The Daylight system on page 5856 combines sunlight on page 9365 and skylight
on page 9353 to create a unified system that follows the geographically correct
angle and movement of the sun over the earth at a given location. You can
choose location, date, time, and compass orientation. You can also animate

the date and time. This system is suitable for shadow studies of proposed and
existing structures.

Viewing Lighting Effects in the Scene

When you place lights in a scene, the default lighting turns off and the scene
is illuminated only by the lights you create. The illumination you see in a
viewport is just an approximation of the true lighting. Render your scene to
view lighting accurately.

TIP If the Daylight system appears to wash out the scene, try using the Logarithmic
exposure control on page 7709.

Placing Cameras

You create and place cameras from the Cameras category of the Create panel.
Cameras define viewpoints for rendering, and you can animate cameras to
produce cinematic effects such as dollies and truck shots.

You can also create a camera automatically from a Perspective viewport by
using the Create Camera from View command on page 129 found on the Views
menu. Just adjust your Perspective viewport until you like it, and then choose
Views » Create Camera From View. 3ds Max Design creates a camera and
replaces the Perspective viewport with a Camera viewport showing the same
perspective.

See Common Camera Parameters on page 5966.
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Animating Your Scene

You can animate almost anything in your scene. Click the Auto Key button
to enable automatic animation creation, drag the time slider, and make changes
in your scene to create animated effects.

Iﬁutu h’.ey'|

Controlling Time

3ds Max Design starts each new scene with 100 frames for animation. Frames
are a way of measuring time, and you move through time by dragging the
time slider on page 8695. You can also open the Time Configuration dialog on
page 8735 to set the number of frames used by your scene and the speed at which
the frames are displayed.

Animating Transforms and Parameters

While the Auto Key button is on, 3ds Max Design creates an animation key
on page 9244 whenever you transform an object or change a parameter. To
animate a parameter over a range of frames, specify the values at the first and
last frames of the range. 3ds Max Design calculates the values for all of the
frames in between.

See Animation Concepts and Methods on page 3402.

Editing Animation

You edit your animation by opening the Track View window or by changing
options on the Motion panel. Track View is like a spreadsheet that displays
animation keys along a time line. You edit the animation by changing the
keys.

Track View has two modes. You can display the animation as a series of
function curves that graphically show how a value changes over time in the
Curve Editor mode. Alternatively, you can display your animation as a
sequence of keys or ranges on a grid in the Dope Sheet mode.

See Track View on page 3831.

Rendering Your Scene

Use the rendering features to define an environment and to produce the final
output from your scene.
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Rendering "fills in" geometry with color, shadow, lighting effects, and so on.

Defining Environments and Backgrounds

Rarely do you want to render your scene against the default background color.
Open the Environment And Effects dialog » Environment panel on page
7657 to define a background for your scene, or to set up effects such as fog.

Setting Rendering Options

To set the size and quality of your final output, you can choose from many
options on the Render Setup dialog on page 6992. You have full control over
professional grade film and video properties as well as effects such as reflection,
antialiasing, shadow properties, and motion blur.

Rendering Images and Animation

You render a single image by setting the renderer to render one frame of your
animation. You specify what type of image file to produce and where 3ds Max
Design stores the file.

Rendering an animation is the same as rendering a single image except that
you set the renderer to render a sequence of frames. You can choose to render
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an animation to multiple single frame files or to popular animation formats

such as AVI or MOV.

See Render Setup Dialog on page 6992.

The 3ds Max Design Interface

The 3ds Max Design window is the entry point to most of the features of this

application.
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3ds Max Design window, showing viewports, controls, and a rendered frame

See The 3ds Max Design Window on page 8602 for an introduction to the

components of this interface. See Special Controls on page 8605 for descriptions
of some of the special controls that 3ds Max Design uses. Becoming familiar
with these controls is especially useful if you are new to using 3ds Max Design.
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Managing Files

3ds Max Design supports many types of files for working with plug-ins, image
maps, models from other programs, rendering images and animations, and
of course saving and opening your scene files.
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File-management dialogs

File dialogs (such as Open, Save, Save As) uniformly remember the previous
path you used, and default to that location.

See also:

B Managing Scenes and Projects on page 7887

Configuring File Paths

The locations that 3ds Max Design searches to locate all file types are specified
on the Customize menu » Configure Paths dialogs on page 8911.

Managing Files | 35



File 140 | External Files | ®Fefs |

Project Folder

IE:\mypraiecthIdet
Animations Ssoceneassetzhanimations “ Fdadify..
Archives Marchives

AutoBackup Sautoback

BitrmapProsies hprowies ’
Downloads SAdownloads MaheRelalive
Expart esport I ake sbsolute
Exprezsions express =
Images Asceneaszetz\images

Import Simport

I aterials materiallibraries

b amStart Sscenes

Photarnetric Asceneaszets\phaotometnic LI

Pravisme \nrEss AL

Save az.. Load... Merge...

Cancel

You can choose to open and save files in any path location. The Configure
Paths dialog contains four panels for the general categories of support files.

Setting General File Paths

The File I/O panel on page 8915 contains paths for most of the standard support
files. You can specify one path for each of file types 3ds Max Design uses.

Setting Plug-In File Paths

Many features of 3ds Max Design are implemented as plug-ins. This means
you can change and extend 3ds Max Design functionality by adding new
plug-ins from Autodesk Media and Entertainment or from third-party
developers.

You tell 3ds Max Design where to find additional plug-in files by adding path
entries on the 3rd Party Plug-Ins panel on page 8924. If you place all of your
plug-ins in a single directory, plug-in file management can become messy.
That's why 3ds Max Design supports multiple entries on the 3rd Party Plug-Ins
panel.
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Setting Bitmap, FX, and Download File Paths

The External Files panel on page 8918 contains multiple path entries that 3ds
Max Design searches for image files on page 8448, downloaded files (via i-drop
on page 8211), and FX files on page 9216. Image files are used for many purposes,
such as material and map definition, light projections, and environment
effects.

Setting XRefs File Paths

The XRefs panel on page 8920 contains multiple path entries that 3ds Max
Design uses to search for externally referenced files. These are used for sharing
files in a workgroup situation.

Importing, Merging, Replacing, and Externally
Referencing Scenes

You can realize great productivity gains when you reuse work by combining
geometry from scenes or other programs. 3ds Max Design supports this
technique with the Import, Merge, and Replace commands. You can also share
scenes and objects with others working on the same project using XRef
functionality.
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Gear model imported to become part of another scene

Importing Geometry from Other Programs

Use Application menu on page 8617 » Import on page 8005 to bring objects from
other programs into a scene. The types of files that you can import are listed
in the Files Of Type list in the Select File To Import dialog.

Depending on the file type you choose, you might have options available for
that import plug-in.
Merging Scenes Together

Use Merge on page 8138 to combine multiple scenes into a single large scene.
When you merge a file, you can select which objects to merge. If objects being
merged have the same name as objects in your scene, you have the option to
rename or skip over the merged objects.
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Pipe and ashtray models merged into one scene
Merging Animation into Scenes

Use Merge Animation on page 4167 to merge the animation from one scene
into another with the same (or similar) geometry.
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Replacing Scene Objects

Use Replace on page 8144 to replace objects in your scene with objects in another
scene that have duplicate names. Replace is useful when you want to set up
and animate your scene with simplified objects, and then replace the simple
objects with detailed objects before rendering.

The Replace dialog looks and functions the same as Merge, except that it lists
only objects that have the same name as objects in your current scene.

Using External References

Use XRef Objects on page 8008 and XRef Scenes on page 8036 to use objects and
scene setups in your scene that are actually referenced from external MAX

files. These functions allow sharing files with others in your workgroup, with
options for updating and protecting external files.

Using the Asset Browser

The Asset Browser provides access from your desktop to design content on
the World Wide Web. From within 3ds Max Design you can browse the
Internet for texture samples and product models. This includes bitmap textures
(BMP, JPG, GIF, TIF, and TGA) and geometry files (MAX, 3DS, and so on).
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Left: Dragging geometry into the scene
Right: Dragging a bitmap onto the geometry

You can drag these samples and models into your scene for immediate
visualization and presentation. You can snap geometry into predefined
locations, or drag and drop them interactively in your scene.

You can also use the Asset Browser to browse thumbnail displays of bitmap
textures and geometry files on your hard disk or shared network drives. Then
you can either view them or drag and drop them into your scene or into valid
map buttons or slots.

NOTE The thumbnail display of a geometry file is a bitmap representation of a
view of the geometry. Since the thumbnail display is not a vector-based
representation, you can't rotate it or perform zooms on it.

You can drag and drop most graphic images that are embedded in a Web page
into your scene. The exception is images or regions of a Web page that are
tagged as hyperlinks or other HTML controls (such as when a bitmap is tagged
as a button).
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IMPORTANT Downloaded content might be subject to use restrictions or the
license of the site owner. You are responsible for obtaining all content license
rights.

For complete details, see Asset Browser on page 8182.

Startup Files and Defaults

When you start 3ds Max Design, several auxiliary files load, setting things like
program defaults and Ul layout. You can even create a scene, named
maxstart.max, that automatically loads when you start or reset 3ds Max Design.
In some cases, 3ds Max Design updates files when you change settings and
when you quit 3ds Max Design.

NOTE 3ds Max Design comes with several different market-specific defaults on
page 8874. These set different program defaults on startup, based on the type of
files you expect to work on most often. You can load the preset defaults that come
with 3ds Max Design, or you can create your own.

In general, you don't need to work directly with the auxiliary files, but it's
good to know about them. Among the auxiliary files 3ds Max Design uses are:

B 3dsmax.ini on page 43 : This file gets updated when you start and exit 3ds
Max Design, as well as when you change most Preferences settings. It
contains values relating to program defaults, including the graphics driver,
directories used to access external files such as sounds and images, preset
render sizes, dialog positions, snap settings, and other preferences and
default settings. If you edit this file, be sure to make a copy first, so you
can return to the original if anything goes wrong.

NOTE Many program defaults are set in currentdefaults.ini, found within the
\defaults directory. For more information on this file, see Market-Specific
Defaults on page 8874.

B maxstart.max: At startup and when you reset 3ds Max Design, 3ds Max
Design looks for this file in the MaxStart folder specified in Configure User
Paths » File I/O panel on page 8915, and if found, loads it. This allows you
to specify the default state of the workspace whenever you start or reset
3ds Max Design. For example, if you always use a ground plane, you can
make it the default setup by creating one, and then saving it as
maxstart.max.
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If you save a different file over maxstart.max, you can return to program
defaults by deleting the maxstart.max file, and then resetting 3ds Max
Design.

B maxstart.cui: This is the default custom user interface file. You can load
and save CUI files, and set 3ds Max Design to use a different default CUI
file. See Customize Menu on page 8657.

B plugin.ini: This file contains directory paths for plug-ins. Most other paths
are kept in 3ds Max Design INI file, but plugin.ini is maintained as a separate
file because third-party plug-ins often add entries to the list at installation.

NOTE It is possible to use multiple plug-in configuration files by nesting
additional paths in your plugin.ini file. This can be very useful for allowing an
entire network of users to share one plugin.inifile, making the system easier to
maintain for the network administrator. For more information, see Network
Plug-In Configuration on page 8925.

B startup.ms: A MAXScript file that automatically executes at startup time.
For more information, see Startup Script on page 9360.

The Initialization File

The file 3ds Max Design uses to store settings between sessions is named
3dsmax.ini. In most cases, you don’t need to access this file directly. To find
it, if necessary, use the Windows Search function.

You can make changes to 3ds Max Design startup conditions by editing the
3dsmax.ini file in a text editor such as Notepad. If you do edit the file, be sure
to maintain the structure and syntax of the original file.

TIP If you encounter unusual and unexplained user-interface problems using 3ds
Max Design, try deleting the 3dsmax.ini file and restarting. 3ds Max Design writes
a new INI file to replace the deleted one. Often this fixes problems related to the
state of the user interface.

NOTE Startup scene conditions are defined by the maxstart.max file. To save a
particular startup condition, such as a Plane object representing the ground, create
a scene file with the condition present and then save it as maxstart.max. 3ds Max
Design automatically opens this file when you start 3ds Max Design.

The 3dsmax.ini file includes the following categories of settings:

[Directories] Defines the default paths for various file operations.

The Initialization File | 43



[Performance] Controls that speed up viewport performance.
[PlugInKeys] Turns on or off the keyboard shortcuts for plug-ins.
[Renderer] Controls for rendering alpha and filter backgrounds.
[RenderPresets] Defines the paths for Rendering Preset files.

[BitmapDirs] Defines the default map paths for bitmaps used by materials.
[Modstack] Controls modifier stack button sets and icon display.
[WindowState] Settings for software display, OpenGL, or Direct3D drivers.
[CustomMenus] Defines path for the .mnu file.

[CustomColors] Defines the path for the .cIr file.

[KeyboardFile] Defines the path for the .kbd file.

[Material Editor] Material Editor settings.

[ObjectSnapSettings] Settings associated with snaps.

[CommandPanel] Sets number of columns, and controls rollout display in
multiple columns.

Backing Up and Archiving Scenes

You should regularly back up and archive your work. One convenient method
is to save incremental copies of your scenes. This method creates a history of
your work process.

Saving Incremental Files

If you turn on the Increment On Save option on the Files panel on page 8933
of the Preferences dialog, the current scene is renamed by appending a
two-digit number to the end of the file and incrementing the number each
time you save. For example, if you open a file named myfile.max and then save
it, the saved file is named myfile0T.max. Each time you save the file its name
is incremented, producing the files myfile02.max, myfile03.max, and so on.

You can also use Save As on page 7994 to increment the file name manually
with a two-digit number by clicking the increment button (+) on the Save As
dialog.
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Using Auto Backup

You can automatically save backup files at regular intervals by setting the Auto
Backup options on page 8936 on the Preferences dialog (see File Preferences on
page 8933). The backup files are named AutoBackupN.max, where N is a number
from 1 to 99, and stored, by default, in the \autoback folder. You can load a
backup file like any other scene file.

Archiving a Scene

3ds Max Design scenes can make use of many different files. When you want
to exchange scenes with other users or store scenes for archival purposes, you
often need to save more than just the scene file.

Use the Application menu on page 8617 » Archive command on page 8004 to
pass the scene file and any bitmap files used in the scene to an archiving
program compatible with PKZIP: software.

Crash Recovery System

If 3ds Max Design encounters an unexpected crash, it attempts to recover and
save the file currently in memory. This is fairly reliable, but it does not always
work: the recovered scene could be damaged during the crash. The recovered
file is stored in the configured Auto Backup path. It is saved as
"<filename>_recover.max" in this path. It is also placed in the INI file as the
most recently used file in the Application menu on page 8617. This makes it
easy to return to the file, if you choose to do so.

The crash recovery system identifies when something in an object's modifier
stack is corrupt. In these cases, the corrupt object is replaced with a red dummy
object to maintain the object's position and any linked object hierarchy.
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NOTE We recommend that you not rely on this file-recovery mechanism as an
alternative to good data backup practices:

W Save your work frequently.

B Take advantage of automatic incremental file naming: Go to Customize
menu » Preferences » Files panel on page 8933 » File Handling group,
and turn on Increment On Save.

B Use Application menu on page 8617 » Save » Save As, and click the
Increment button (+) to save incremental copies of work in progress.

W If you are forgetful about saving, use the Auto Backup feature. Go to
Customize menu » Preferences » Files tab » Auto Backup group, and
turn on Enable.
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Viewing and Navigating 3D
Space

Everything in 3ds Max Design is located in a three-dimensional world. You have a variety of
options for viewing this enormous stage-like space, from the tiniest details to the full extent
of your scene.

b d

Different viewports can display different angles; on the right, the largest viewport
shows a camera view.

Using the view options discussed in this section you move from one view to another, as your
work and imagination require. You can fill your screen with a single, large viewport, or set
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multiple viewports to track various aspects of your scene. For exact positioning, flat drawing
views are available, as are 3D perspective on page 9308 and axonometric views on page 9144.

You navigate 3D space by adjusting the position, rotation and magnification of your views.
You have full control over how objects are rendered and displayed on the screen.

You can also use the Grab Viewport command on page 7392 to create snapshots of your work
as you go.

This section presents brief topics designed to help you quickly start learning how to organize
viewports and navigate through 3D space. For details about viewport commands, see Viewport
Controls on page 8742.

General Viewport Concepts

Viewports are openings into the three-dimensional space of your scene, like

windows looking into an enclosed garden or atrium. But viewports are more
than passive observation points. While creating a scene, you can use them as
dynamic and flexible tools to understand the 3D relationships among objects.
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The 3ds Max Design main window, with a docked toolbar and viewport layout
displaying multiple views.

At times you might want to look at your scene through a large, undivided
viewport, giving you a "picture-window" view of the world you're creating.
Often you use multiple viewports, each set to a different orientation.

If you want to move an object horizontally in the world space, you might do
this in a top viewport, looking directly down on the object as you move it. At
the same time, you could be watching a shaded perspective viewport to see
when the object you're moving slides behind another. Using the two windows
together, you can get exactly the position and alignment you want.

You also have pan and zoom features available in either view, as well as grid
alignment. With a few mouse clicks or keystrokes, you can reach any level of
detail you need for the next step in your work.

Another way to use viewports is to place a camera in your scene and set a
viewport to look through its lens. When you move the camera, the viewport
tracks the change. You can do the same thing with spotlights.
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In addition to geometry, viewports can display other views such as Track View
and Schematic View, which display the structure of the scene and the
animation. Viewports can be extended to display other tools such as the
MAXScript Listener and the Asset Browser. For interactive rendering, the
viewport can display the ActiveShade window.

Active Viewport

One viewport, marked with a highlighted border, is always active. The active
viewport is where commands and other actions take effect. Only one viewport
can be in the active state at a time. If other viewports are visible, they are set
for observation only; unless disabled, they simultaneously track actions taken
in the active viewport.

Saving the Active Viewport

You can save the view in any active viewport and later restore it with the
Views menu's Save Active View on page 107 and Restore Active View on page
108 commands. One view can be saved for each of the following view types:
Top, Bottom, Left, Right, Front, Back, Orthographic, Perspective.

For example, while in the Front view, you choose Save Active Front View, and
then zoom and pan that view. You then activate the Top viewport, choose
Save Active Top View, and then click Zoom Extents. You return to the Front
view, and choose Restore Active Front View to return to its original zoom and
pan. At any time, you can activate the Top viewport, and then choose Restore
Active Top View to restore its saved view.

Home Grid: Views Based on the World Coordinate

AXxes

The grid you see in each viewport represents one of three planes that intersect
atright angles to one another at a common point called the origin. Intersection
occurs along three lines (the world coordinate axes: X, Y, and Z) familiar from
geometry as the basis of the Cartesian coordinate system.
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Home Grid

Using the home grid to position houses
The three planes based on the world coordinate axes are called the home grid;
this is the basic reference system of the 3D world.

To simplify the positioning of objects, only one plane of the home grid is
visible in each viewport. The figure shows all three planes as they would appear
if you could see them in a single perspective viewport.
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Axes, Planes, and Views

Home grid axes and planes

Two axes define each plane of the home grid. In the default Perspective
viewport, you are looking across the XY plane (ground plane), with the X axis
running left-to-right, and the Y axis running front-to-back. The third axis, Z,
runs vertically through this plane at the origin.
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Home Grid and Grid Objects

Above: Inactive grid object in a scene

Below: Activated grid object

The home grid is aligned with the world coordinate axes. You can turn it on
and off for any viewport, but you can’t change its orientation.

For flexibility, the home grid is supplemented by grid objects: independent
grids you can place anywhere, at any angle, aligned with any object or surface.
They function as "construction planes" you can use once and discard or save
for reuse. See Precision and Drawing Aids on page 2809.
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é AutoGrid

The AutoGrid feature lets you create and activate temporary grid objects on
the fly. This lets you create geometry off the face of any object by first creating
the temporary grid, then the object. You also have the option to make the
temporary grids permanent. See AutoGrid on page 2821.

Understanding Views

Each viewport can be set to display either of two types of views: axonometric
or perspective.

B Axonometric views on page 9144 show the scene without perspective. All
lines in the model are parallel to one another. The Top, Front, Left, and
Orthographic viewports are axonometric views.
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Axonometric view of a scene
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B Perspective views on page 9308 show the scene with lines that converge at
the horizon. The Perspective and Camera viewports are examples of
perspective views.

Perspective view of the same model

Perspective views most closely resemble human vision, where objects appear
to recede into the distance, creating a sense of depth and space. Axonometric
views provide an undistorted view of the scene for accurate scaling and
placement. A common workflow is to use axonometric views to create the
scene, then use a perspective view to render the final output.

Axonometric Views

There are two types of axonometric views you can use in viewports: head-on
and rotated.

An orthographic view on page 9295 is often a head-on view of the scene, such
as the view shown in the Top, Front, and Left viewports. You can set a viewport

to a specific orthographic view using the Point-Of-View (POV) viewport label
menu on page 8751, keyboard shortcuts on page 9049, or the ViewCube on page
68. For example, to set an active viewport to Left view, press L.
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You can also rotate an orthographic view to see the scene from an angle while
retaining parallel projection. However, when viewing the scene from an angle,
it’s often more helpful to use a perspective view.

Perspective Views

A perspective viewport, labeled Perspective, is one of the startup viewports in
3ds Max Design. You can change any active viewport to this "eye-like" point
of view by pressing P.

Camera View

Once you create a camera object in your scene, you can change the active
viewport to a camera view by pressing C and then selecting from a list of
cameras in your scene. You can also create a camera view directly from a
perspective viewport, using the Create Camera from View on page 129
command.

A camera viewport tracks the view through the lens of the selected camera.
As you move the camera (or target) in another viewport, you see the scene
move accordingly. This is the advantage of the Camera view over the
Perspective view, which can't be animated over time.

If you turn on Orthographic Projection on a camera’s Parameters rollout, that
camera produces an axonometric view on page 9144. See Cameras on page 5941.
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The viewport on the right is seen through a camera in the scene.

Two and Three-Point Perspective and the Camera Correction Modifier

By default, camera views use three-point perspective, in which vertical lines
appear to converge with height (in traditional photography this is known as
keystoning). The Camera Correction modifier on page 6003 applies two-point
perspective to a camera view. In two-point perspective, vertical lines remain
vertical. A similar effect can be attained by putting a Skew modifier on a
camera.

Light View

Light view works much like a targeted camera view. You first create a spotlight
or directional light and then set the active viewport to that spotlight. The
easiest way is to press the keyboard shortcut $. See Lights on page 5676.
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The viewport on the right looks through the lens of a spotlight in the scene.

Setting Viewport Layout

3ds Max Design defaults to a 2 x 2 arrangement of viewports. Thirteen other
layouts are available, but the maximum number of viewports on the screen
remains four.

Using the Layout panel on page 9010 of the Viewport Configuration dialog, you
can pick from the different layouts and customize the viewports in each. The
viewport configuration is saved with your work.
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Resizing the Viewport

After choosing a layout you can resize the viewports so they have different
proportions by moving the splitter bars that separate the viewports. This is
available only when multiple viewports are displayed.

Resized viewport
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Changing the View Type

As you work, you can change the view in any viewport quickly. For example,
you can switch from front view to back view. You can use either of two
methods: menu or keyboard shortcut.

B Click or right-click the Point-Of-View (POV) viewport label of the viewport
you want to change. Then from the POV viewport label menu on page 8751,
click the view type that you want.

B Click the viewport you want to change, and then press one of the keyboard
shortcuts in the following table.

Key View type

T Top view

B Bottom view

F Front view

L Left view

C Camera view. If your scene has only one

camera, or you select a camera before using
this keyboard shortcut, that camera supplies
the view. If your scene has more than one
camera, and none are selected, a list of
cameras appears.

P Perspective view. Retains viewing angle of
previous view.

u Orthographic User view. Retains viewing
angle of previous view. Allows use of Zoom
Region on page 8777.

none Right view. Use the POV viewport label
menu on page 8751.

none Shape view. Use the POV viewport label
menu on page 8751. Automatically aligns view
to the extents of a selected shape and its
local XY axes.
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See also:

Viewport Layout on page 9010

Camera Viewport Controls on page 8781
Spotlight Parameters on page 5803
Precision and Drawing Aids on page 2809

Track View on page 3831

Controlling Viewport Rendering

You can choose from multiple options to display your scene. You can display
objects as simple boxes, or render them with smooth shading and texture
mapping. If you want, you can choose a different display method for each
viewport.

Box display, wireframe display, and smooth shading
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TIP If you want to display and render an individual object as wireframe, you can
use a Standard or Raytrace material and set its shader to Wire on page 6425. Or, to
display an individual object to display as a box, select the object and choose Display
as Box on page 145 on the Display properties rollout on the display panel.

Using Viewport Rendering Controls

Viewport rendering options are found on the Shading viewport label menu

on page 8758 and on the Rendering Method panel on page 9005 of the Viewport
Configuration dialog. Using these controls you can set a rendering level and

any options associated with that level. The viewport label menu settings apply

to the active viewport only, but the Rendering Method panel lets you apply
settings to the active viewport, all viewports, or to all but the active viewport.

The rendering level you choose is determined by your need for realistic display,
accuracy, and speed. For example, Bounding Box display level can be much
faster than Smooth + Highlights, depending on scene complexity. The more
realistic the rendering level, the slower the display speed.

After choosing a rendering level, you can set rendering options. Different
options are available for different rendering levels.

You can also use ActiveShade on page 7045 in a viewport. This feature helps you
quickly preview changes you make to lighting and materials.

Viewport rendering has no effect on final renderings produced by clicking
Render Scene.
Rendering Methods and Display Speed

The rendering methods not only affect the quality of your view display, they
can also have a profound effect on display performance. Using higher quality
rendering levels and realistic options slows display performance.

After setting a rendering method, you can choose additional options that
adjust display performance. One of these controls, Adaptive Degradation,
speeds up display performance when you use realistic rendering levels.

See Rendering Method on page 9005.

Controlling Display Performance

3ds Max Design contains controls to help you adjust display performance:
the balance between quality and time in displaying objects.
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Depending on your needs, you might give up some display speed to work at
higher levels of rendering quality, or you might choose to maximize display
speed by using Wireframe or Bounding Box display. Which method you choose
depends on your preferences and the requirements of your work.

Display Performance Controls

You use display performance controls to determine how objects are rendered
and displayed.

Viewport Preferences

The Customize » Preferences dialog's Viewports panel contains options for
fine-tuning the performance of the viewport display software. See Viewport
Preferences on page 8937.

How Objects Are Displayed

To see and modify an object's display properties, right-click the object, select
Properties, and go to the Display Properties group box; see Object Properties
on page 221. These options affect display performance much the same way as
viewport rendering options. For example, turning on Vertex Ticks for an object
with a lot of vertices will slow performance.

NOTE Display Properties are only available when the By Object/By Layer toggle
is set to By Object.

To see and modify how objects are displayed, you can use layers on page 8571.
You can then quickly control the visibility and editability of similar objects
from the quad menu.

Which Objects Are Displayed

One way to increase display speed is not to display something. You can use
the Hide and Freeze functions on the Display panel, quad menu, Manage
Layers Dialog on page 8574, and Scene Explorer on page 8506 to change the display
state of objects in your scene. The Hide and Freeze features also affect final
Rendering and Video Post output. See Hide Rollout on page 140 and Freeze
Rollout on page 142.

Setting Adaptive Degradation

Adaptive Degradation dynamically adjusts viewport rendering levels to
maintain a desired level of display speed. You have direct control over how
much "degradation" occurs and when it occurs.
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The active levels determine which rendering levels 3ds Max Design falls back
to when it cannot maintain the desired display speed. You can choose as many
levels as you want but you are advised to choose only one or two levels for
each type of degradation.

See Adaptive Degradation on page 9128.

Using Standard View Navigation

To navigate through your scene, use the view navigation buttons located at
the lower-right corner of the 3ds Max Design window. All view types, except
Camera and Light views, use a standard set of view navigation buttons.

F B gl
=5

The standard navigation
controls

Button Operation

Clicking standard view navigation buttons produces one of two results:
B Executes the command and returns to your previous action.

B Activates a view navigation mode.

You can tell that you are in a navigation mode because the button remains
highlighted (orange background). This mode remains active until you
right-click or choose another command.

While in a navigation mode, you can activate other viewports of the same
type, without exiting the mode, by clicking in any viewport. See Viewport
Controls on page 8742.

Undoing Standard View Navigation Commands

Use the Undo View Change and Redo View Change commands on page 106
on the Views menu to reset standard view navigation commands without
affecting other viewports or the geometry in your scene. Undo View Change
also appears on the Point-Of-View (POV) viewport label menu on page 8751. Or
you can use the keyboard shortcuts: Shift+Z for Undo View Change and Shift+Y
for Redo View Change.
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Views menu » Undo View Change and Views menu » Redo View Change
are different from Undo and Redo commands on the Edit menu and main
toolbar. 3ds Max Design maintains separate Undo/Redo buffers for scene
editing and for each viewport.

The View Change Undo/Redo buffer stores your last 20 view navigation
commands for each viewport. You can step back through the Undo View/Redo
View buffer until you have undone all of the stored view-navigation
commands.

Zooming, Panning, and Rotating Views

When you click one of the view navigation buttons, you can change these
basic view properties: zooming, panning, and rotating.

NOTE You can also navigate the viewport with the ViewCube on page 68 and
SteeringWheels on page 75 toolsets.

qi

Zoom Controls zooming in and out.

Pan View Controls panning in any direction.

"l:b" Orbit Controls rotating in any direction

Before and after zooming a viewport
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Before and after rotating a viewport

Zooming a View

+
q E Click Zoom on page 8769 or Zoom All on page 8771 and drag in a
viewport to change the view magnification. Zoom changes only the active
view, while Zoom All simultaneously changes all non-camera views.

1
:}- If a perspective view is active, you can also click Field of View (FOV) on
page 8774. The effect of changing FOV is similar to changing the lens on a
camera. As FOV gets larger you see more of your scene and perspective becomes
distorted, similar to using a wide-angle lens. As FOV gets smaller you see less
of your scene and the perspective flattens, similar to using a telephoto lens.

WARNING Be cautious using extreme Field of View settings. These can produce
unexpected results.

Zooming a Region

"a Click Zoom Region on page 8777 to drag a rectangular region within the
active viewport and magnify that region to fill the viewport. Zoom Region is
available for all standard views.

1
:}- In a perspective viewport, Zoom Region mode is available from the Field
of View flyout on page 8774.
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Zooming to Extents

r -1

'-I:I-'a O s+ Click the Zoom Extents or Zoom Extents All flyout buttons to
change the magnification and position of your view to display the extents of
objects in your scene. Your view is centered on the objects and the
magnification changed so the objects fill the viewport.

r 1

B “ - The Zoom Extents, Zoom Extents Selected buttons on page 8765 zoom
the active viewport to the extents of all visible or selected objects in the
scene.

] &l « The Zoom Extents All, Zoom Extents All Selected buttons on page
8765 zoom all viewports to the extents of all objects or the current selection.

Panning a View

Click Pan View on page 8778 and drag in a viewport to move your view parallel
to the viewport plane. You can also pan a viewport by dragging with the
middle mouse button held down while any tool is active.

Rotating a View

"I:b" Click Orbit, Orbit Selection, or Orbit Sub-Object on page 8779 to rotate
your view around the view center, the selection, or the current sub-object
selection respectively. When you rotate a head-on viewport, such as a Top
view, it is converted to an Orthographic view, as reflected by the viewport
label.

With Orbit, objects near the edges of the viewport can rotate out of view.

"It = With Orbit Selected, selected objects remain at the same position in the
viewport while the view rotates around them. If no objects are selected, the
function reverts to the standard Orbit function.

‘I:Ehﬂ With Orbit Sub-Object, selected sub-objects or objects remain at the
same position in the viewport while the view rotates around them.
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NOTE You can rotate a view by holding down the Alt key while you drag in a
viewport using middle-button. This uses the current Orbit mode, whether or not
the Orbit button is active. You can also activate Orbit by pressing Ctrl+R.

ViewCube

The ViewCube® 3D navigation control provides visual feedback of the current
orientation of a viewport, lets you adjust the view orientation, and also switch
between standard and isometric views.

Once the ViewCube is displayed, it appears by default in the upper-right corner
of the active viewport, superimposed over the scene in an inactive state. It
does not appear in camera, light, or shape viewports, or in other types of views
such as ActiveShade or Schematic. While the ViewCube is inactive, its primary
function is to show the orientation of the scene based on the North direction
of the model.

When you position the cursor over the ViewCube, it becomes active. Using
the left mouse button, you can switch to one of the available preset views,
rotate the current view, or change to the Home view of the model.
Right-clicking opens a context menu with additional options.

N

S

NOTE If you are using the software display driver on page 8946, the ViewCube
doesn’t appear.

Control the Appearance of the ViewCube

The ViewCube is displayed in one of two states: inactive and active. When
the ViewCube is inactive, it appears transparent over the viewport by default
so as not to completely obscure the view of the model. When the ViewCube
is active, it is opaque and might obscure the view of objects in the scene.

You can control the opacity level of the ViewCube when it is inactive as well
as its size, the viewports it appears in, and the display of the compass. These
settings are located on the ViewCube panel on page 9030 of the Viewport
Configuration dialog.
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Using the Compass

The ViewCube compass indicates the North direction for the scene. You can
toggle the compass display below the ViewCube and specify its orientation
with the Compass settings on page 9032.

Procedures

To display or hide the ViewCube:

>

Do one of the following:
B DPress the default keyboard shortcut: Alt+Ctrl+V.

B Open the Viewport Configuration dialog to the ViewCube panel on
page 9030 and toggle the Show The ViewCube check box.

B Click or right-click the General (+) viewport label menu on page 8746
and choose ViewCube » Show The ViewCube.

To control the size and inactive opacity of the ViewCube:

1 Open the Viewport Configuration dialog to the ViewCube panel on page
9030.

2 In the Display Options group, click the ViewCube Size drop-down list
and choose a size. The choices are Large, Normal, Small, and Tiny.

3 Also in the Display Options group, click the Inactive Opacity drop-down
list and choose an opacity value. The choices range from 0% (invisible
when inactive) to 100% (always fully opaque).

4 Click OK.

To display the compass for the ViewCube

1

Open the Viewport Configuration dialog to the ViewCube panel on page
9030.

In the Compass group, turn on Show Compass Below The ViewCube.

The compass is displayed below the ViewCube and indicates the North
direction in the scene.

Click OK.
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ViewCube Menu

Right-click the ViewCube.

The ViewCube menu provides options to define the orientation of the
ViewCube, switch between orthographic and perspective projection, define
the Home and Front views for the model, and control the appearance of the
ViewCube.

The following options can be found on the shortcut menu of the ViewCube:
HomeRestores the Home view saved with the model.
OrthographicSwitches the current view to orthographic projection.

Perspective Switches the current view to perspective projection.

Set Current View as Home Defines the Home view of the model based on
the current view.

B Set Current View as FrontDefines the Front view of the model based on
the current view.

B Reset FrontResets the Front view of the scene to its default orientation.

B ConfigureOpens the Viewport Configuration dialog to the ViewCube panel
on page 9030, where you can adjust the appearance and behavior of the
ViewCube.

B Help Launches the online Help system and displays the topic on the
ViewCube.

Procedure

To display the ViewCube menu:

B Right-click the compass, Home icon, or the main area of the ViewCube.

Change the View of the Scene with the ViewCube

You can change the view of a model by choosing a preset view or dragging
the ViewCube, roll the current view 90 degrees, switch to an adjacent face
view, define and restore the Front and Home views, and switch between
projection modes.
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Change the Current View

You can change the current view of a model by clicking predefined areas on
the ViewCube or dragging the ViewCube.

The ViewCube provides 26 defined areas you can click to change the current
view of a model. The defined areas are categorized into three groups: corner,
edge, and face. Of the 26 defined areas, six represent standard orthographic
views of a model: top, bottom, front, back, left, and right. You set an
orthographic view by clicking one of the faces on the ViewCube.

You access angled views of the scene with the other 20 defined areas. Clicking
one of the corners of the ViewCube changes the current view of the model to
a three-fourths view, based on a viewpoint defined by three sides of the model.
Clicking one of the edges changes the view of the model to a three-fourths
view based on two sides of the model.
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In addition, you can click and drag the ViewCube to change the view of the
scene to a custom angled viewpoint other than one of the predefined
viewpoints.

Roll a Face View

When you view a model from one of the face views such as Front, two
additional icons, called roll arrows, are displayed near the ViewCube. To roll
or rotate the current view 90 degrees in the positive or negative directions
around the center of the view, click one of the roll arrows.
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Change the View of the Scene with the ViewCube | 71



Switch to an Adjacent Face

While viewing a model from one of the face views, you can use the ViewCube
to switch to one of the adjacent face views without first changing the view of
the model, in order to see the adjacent view. When the ViewCube is active
and a face view is current, four triangles are displayed, one on each side of
the ViewCube. To rotate the current view to display the face view indicated
by one of the triangles, click the triangle.

— —niy 0P 1\(.) | LEFT |

Front View

You can define the Front view of a model. The Front view is used to define
the direction of the face views on the ViewCube. Along with the Front view,
the Up direction of a model is also used to define the direction of the face
views on the ViewCube.

Procedures

To change the current view to a preset view:
1 Activate the ViewCube.

2 Click one of the faces, edges or corners on the ViewCube.

To view an adjacent face:

1 Activate the ViewCube.

NOTE Make sure a face view is current.

2 Click one of the triangles displayed near the edges of the ViewCube.

To roll a face view:

1 Activate the ViewCube.

NOTE Make sure a face view is current.

2 Click one of the roll arrows displayed above and to the right of the
ViewCube.
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Click the left roll arrow to rotate the view 90 degrees in a counterclockwise
direction or click the right roll arrow to rotate the view 90 degrees in a
clockwise direction.

To change the view interactively:

B Click the ViewCube, hold down the button on your pointing device and
drag to orbit the model.
Drag in the direction that you want to orbit the model.

To define the Front view:

B Right-click on the ViewCube and click Set Current View as Front.

NOTE You first need to orient the view using a view tool so that you are looking
at what you consider to be the Front of the model with its Top facing upward and
then choose Set Current View as Front.

To restore the default Front view:

B Right-click the ViewCube and click Reset Front.

Set the View Projection Mode
View projection produces realistic visual effects of a model.

The ViewCube supports two different view projections:

B PerspectivePerspective projected views involve foreshortening (closer
objects appear larger than more distant ones) and are calculated based on
the distance between a theoretical camera and target point. The shorter
the distance between the camera and the target point, the more severe the
perspective effect appears; greater distances produce less severe affects on
the model.

B OrthographicOrthographic projected views display all the points of a model
being projected parallel to the screen.

The following illustration shows the same model viewed from the same viewing
direction, but with different view projections.
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When you change the view for a scene, the view is updated using the current
projection mode.

Procedure

To change the view projection mode:

» Right-click the ViewCube and click one of the following options:
B Orthographic

B Perspective

Define the Home View

You can define a Home view for a model so you can restore a familiar view
when using the navigation tools.

The Home view is a special view of the model. The default Home position is
the same as that of the Perspective viewport. You can also define a view of
the scene as the Home view so you can easily return to the familiar view by
clicking the Home icon or by choosing Home from the shortcut menu.

Procedure

To define the Home view, do one of the following:
B Right-click the ViewCube and click Set Current View as Home.

B Click or right-click the General (+) viewport label menu on page 8746 and
choose ViewCube » Set Current View As Home.
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To restore the Home view:

Use one of the following methods to restore the Home view:

m Click (the Home icon) located near the active ViewCube.

B Right-click the ViewCube and then choose Home.

SteeringWheels

The SteeringWheels® 3D navigation controls are tracking menus that allow
you to access different 2D and 3D navigation tools from a single tool.

SteeringWheels are divided into different sections known as wedges. Each
wedge on a wheel represents a single navigation tool. You can pan, zoom, or
manipulate the current view of a scene in different ways.

SteeringWheels, also known as wheels, can save you time by combining many
of the common navigation tools into a single interface. Wheels are specific
to the context that a scene is being viewed in.
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The Full Navigation wheel

NOTE If you are using the software display driver on page 8946, SteeringWheels
don’t appear.

First Contact Balloon

By default, the wheel is “pinned” at startup to the lower-left corner of the
Perspective viewport. It does not follow the cursor and, when you position
the cursor over the wheel, the First Contact balloon for the SteeringWheels
opens. The First Contact balloon serves as an introduction to the purpose of
the wheels and how you can use them.
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Display and Use Wheels

To toggle display of a wheel, use the Views menu » SteeringWheels »
Toggle SteeringWheels command or the keyboard shortcut (Shift+W, by
default). When a wheel is displayed, you can activate its navigation tools
either by clicking one of the wedges on the wheel or clicking and holding
down the button on the pointing device. While the button is held down,
dragging over the viewport causes the current view to change. Releasing the
button returns you to the wheel, and right-clicking at any time closes the
wheel.

Not all navigation tools on a wheel support click actions. The following
navigation tools support click actions:

B Zoom - Adjusts the magnification of the view.

B Center - Centers the view based on the position of the cursor over the
wheel.

B Rewind - Restores the previous view.

B Forward - Increases the magnification of the view.

Control the Appearance of Wheels

You can control the appearance of the wheels by changing the current mode,
or by adjusting the size and opacity. Wheels are available in two different
modes: big and mini. To use a different wheel, choose it from the Wheel menu
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on a full-size wheel (click the lower-right button on the wheel) or from the
Views menu » SteeringWheels submenu.

In addition to changing the current mode, you can adjust the opacity and

size for the wheels. The size of a wheel controls how large or small the wedges
and labels appear on the wheel; the opacity level controls the visibility of the
objects in the viewport behind the wheel. The settings used to control the
appearance of the wheels are on the SteeringWheels panel on page 9032 of the
Viewport Configuration dialog.

Control Tooltips for Wheels and Messages for Tools

Tooltips are displayed for each wedge and button on a wheel as the cursor
hovers over them. The tooltips appear below the wheel and identify the action
that is performed if the wedge or button is clicked. You can toggle the display
of tooltips on the SteeringWheels panel on page 9032 of the Viewport
Configuration dialog.

Similar to tooltips, tool messages are displayed when you use one of the
navigation tools from a wheel. Tool messages are displayed over the viewport
and provide instructions for using the active navigation tool. Like tooltips,
you can turn tool messages on or off on the SteeringWheels panel on page
9032 of the Viewport Configuration dialog. Disabling tool messages affects only
messages that are displayed when using the Full Navigation wheel.

Procedures

To close a wheel:
Use one of the following methods to close a wheel:

B Press the Esc key.
B Press Shift+W (this toggles the wheel).

B Click the Close button (the small x in the upper right-hand corner of
the wheel).

B Right-click the wheel.

To change the size of the wheels:
1 Display a wheel, if necessary (press Shift+W).

2 Open the SteeringWheels panel on page 9032 of the Viewport Configuration
dialog.
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3 In the Display Options group, under Big Wheels or Mini Wheels, drag
the Wheel Size slider left or right.

Dragging the slider to the left decreases the size of the wheel, while sliding
the slider to the right increases the size of the wheel.

4 Click OK.

To change the opacity of the wheels:
1 Display a wheel, if necessary (press Shift+W).
2 Open the SteeringWheels panel on page 9032 of the Viewport Configuration
dialog.
3 In the Display Options group, under Big Wheels or Mini Wheels, drag

the Wheel Opacity slider left or right.

Dragging the slider to the left increases the transparency of the wheel,
while sliding the slider to the right decreases the transparency of the
wheel.

4 Click OK.

To control the startup display of the wheels:
1 Open the SteeringWheels panel on page 9032 of the Viewport Configuration
dialog.
2 In the Display Options group, toggle the Always Show Pinned Wheel On
Start check box.

When on, the wheel appears at the cursor position (pinned) whenever
you start 3ds Max Design. When off, you must invoke the wheel explicitly
(press Shift+W).

3 Click OK.

Wheel Menu

From the Wheel menu, you can switch among different wheels and change
the behavior of some of the navigation tools on the current wheel.

Use the Wheel menu, which is available from the down arrow in the
lower-right corner of the wheel, to switch among the big and mini wheels
that are available, go to the Home view, change the wheels configuration, and
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control the behavior of the walk navigation tool. The availability of some
items on the Wheel menu depends on the current wheel.

The Wheel menu has the following options:

Mini View Object Wheel Displays the mini version of the View Object
wheel.

Mini Tour Building Wheel Displays the mini version of the Tour Building
wheel.

Mini Full Navigation Wheel Displays the mini version of the Full Navigation
wheel.

Full Navigation Wheel Displays the big version of the Full Navigation
wheel.

Basic Wheels Displays the big version of the View Object or Tour Building
wheel.

Go Home Restores the Home view saved with the scene.

Restore Original Center Pans the view to the world center (0,0,0).
Increase Walk Speed Doubles the walk speed used for the Walk tool.
Decrease Walk Speed Halves the walk speed used for the Walk tool.

Help Launches the online Help system and displays the topic about the
wheels.

Configure Displays the dialog box where you can adjust the preferences
for the wheels.

Procedure

To display the wheel menu

Click the down arrow in the lower-right corner of the wheel.

Navigation Wheels

You can choose from several different wheels. Each has its own drafting theme,
and is designed for a different type of 3D navigation.
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Wheels are available in two sizes: big and mini. The big wheel is larger than
the cursor. A label is on each wedge in the wheel. The mini wheel is about
the same size as the cursor. Labels are not displayed on the wheel wedges.

You can choose from the following wheels:
B View Obiject
® Tour Building

B Full Navigation

View Object Wheels

The View Object wheel is for general 3D navigation; it includes the orbit 3D
navigation tool. Use the View Object wheel to examine 3D objects from the
outside.

CENTER

\ % REWIND

The big View Object wheel is divided into the following wedges:

B Center on page 84 Specifies a point on a model to adjust the center of the
current view or change the target point used for some of the navigation
tools.

B Zoom on page 94 Adjusts the magnification of the current view.

B Rewind on page 90 Restores the most recent view. You can move backward
or forward through previous views.

B Orbit on page 87 Rotates the current view around a fixed pivot point.

The mini View Object wheel is divided into the following wedges:

B Zoom (Top wedge) on page 94 Adjusts the magnification of the current
view.

B Rewind (Right wedge) on page 90 Restores the most recent view. You can
move backward or forward through previous views.

H Pan (Bottom wedge) on page 89 Repositions the current view by panning.
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B Orbit (Left wedge) on page 87 Rotates the current view around a fixed
pivot point.

Procedures

To switch to the big View Objects wheel:
Use one of the following methods:

B From the Views menu, choose SteeringWheels » View Object Wheel.

B Click the wheel menu button at the lower-right corner of a big wheel and
choose Basic Wheels » View Object Wheel.

To switch to the mini View Objects wheel:
Use one of the following methods:

B Click the wheel menu button at the lower-right corner of a big wheel and
choose Mini View Object Wheel.

B From the Views menu, choose SteeringWheels » Mini View Object Wheel.

Tour Building Wheels

The Tour Building wheels are designed for 3D navigation within the interior
of a model.

FORWARD \\i(

REWIND

The big Tour Building wheel is divided into the following wedges:

B Forward on page 85 Adjusts the distance between the current point of
view and the defined pivot point of the model.

B Look on page 86 Swivels the current view.

B Rewind on page 90 Restores the most recent view. You can move backward
or forward through previous views.

H Up/Down on page 92 Moves the view on the vertical axis of the screen.
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The mini Tour Building wheel is divided into the following wedges:
m Walk (Top wedge) on page 93 Simulates walking through a model.

B Rewind (Right wedge) on page 90 Restores the most recent view. You can
move backward or forward through previous views.

B Up/Down (Bottom wedge) on page 92Moves the view on the vertical axis
of the screen.

B Look (Left wedge) on page 86 Swivels the view.

Procedures

To switch to the big Tour Building wheel:

B From the Views menu, choose SteeringWheels » Tour Building Wheel.

B Click the wheel menu button at the lower-right corner of a big wheel and
choose Basic Wheels » Tour Building Wheel.

To switch to the mini Tour Building wheel:

B Click the wheel menu button at the lower-right corner of a big wheel and
choose Mini Tour Building Wheel.

B From the Views menu, choose SteeringWheels » Mini Tour Building
Wheel.

Full Navigation Wheels

The Full Navigation wheel combines navigation tools found on the View
Object and Tour Building wheels.

The big Full Navigation wheel is divided into the following wedges:

B Zoom on page 94. Adjusts the magnification of the current view.
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Rewind on page 90. Restores the most recent view. You can move backward
or forward through previous views.

Pan on page 89. Repositions the current view by panning.
Orbit on page 87. Rotates the current view around a fixed pivot point.

Center on page 84. Specifies a point on a model to adjust the center of
the current view or change the target point used for some of the navigation
tools.

Walk on page 93 Simulates walking through the scene.
Look on page 86 Swivels the view.

Up/Down on page 92 Moves the view on the vertical axis of the screen.

The mini Full Navigation wheel is divided into the following wedges:

Zoom (Top wedge) on page 94 Adjusts the magnification of the view.
Walk (Upper-right wedge) on page 93 Simulates walking through a model.

Rewind (Right wedge) on page 90 Restores the most recent view. You can
move backward or forward through previous views.

Up/Down (Lower-right wedge) on page 92 Moves the view on the vertical
axis of the screen.

Pan (Bottom wedge) on page 89 Repositions the current view by panning.
Look (Lower-left wedge) on page 86 Swivels the current view.

Orbit (Left wedge) on page 87 Rotates the current view around a fixed
pivot point.

Center (Upper-left wedge) on page 84 Specifies a point on a model to
adjust the center of the current view or change the target point used for
some of the navigation tools.

Procedures

To switch to the big Full Navigation wheel:

Use one of the following methods:

From the Views menu, choose SteeringWheels » Full Navigation Wheel.
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B Click the wheel menu button at the lower-right corner of a big wheel and
choose Full Navigation Wheel.

To switch to the mini Full Navigation wheel:
Use one of the following methods:

B Click the wheel menu button at the lower-right corner of a big wheel and
choose Mini Full Navigation Wheel.

B From the Views menu, choose SteeringWheels » Mini Full Navigation
Wheel.

Navigation Tools

The navigation tools change the current view of the scene.

The availability of a navigation tool depends on the current wheel mode.

Center Tool

The Center tool specifies a point on an object as the center of the current
view. It also changes the target point used for some of the navigation tools.

When using the Center tool, you adjust the location of the center of the
current view by clicking and dragging. As you do so, the cursor changes to a
sphere, indicating where the new center of the view will be established when
you release the button on the pointing device. Releasing the button pans the
model until the sphere is centered in the view and you are returned to the
wheel.

L

The center point defined by the Center tool is used to constrain the Zoom
tool and define the pivot point for the Orbit tool. The Zoom tool is only
constrained to the center point when used from the View Object wheel unless
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the Ctrl key is held down when using the Zoom tool on the Full Navigation
wheel.

Procedure

To specify a point on an object as the center of a view:
1 Display a wheel that has the Center tool.

2 Click the Center wedge. Hold down the button on your pointing device
and drag the cursor to the object.

3 When the cursor changes to an arrow with a sphere at the tip, release the
button on your pointing device.

The viewport is panned until the sphere is centered.

NOTE This also sets the pivot point for the Orbit tool on page 87. Also, in
the context of the View Object wheel on page 80, it sets the pivot point for
the Zoom tool on page 94.

4 To exit the wheel, right-click.

Forward Tool

The Forward tool adjusts the distance between the current point of view and
the defined pivot point of the model.

With the Forward tool, you can change the magnification of the model by
increasing or decreasing the distance between the current point of view and
the pivot point. The distance that you can move forward or backward is limited
by the position of the pivot point.
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To adjust the distance between the current point of view and the pivot point,
you drag the cursor up or down after the pivot point is defined. As you drag
the cursor, the current distance from the pivot point is displayed on a graphical
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element called the Drag Distance indicator. The Drag Distance indicator has
two marks on it that show the start and ending distances from the current
point of view. While changing the distance with the Drag Distance indicator,
the current distance is shown by the bright orange indicator.
To change a view by moving towards or away from the model

1 Display a wheel that has the Forward tool.

2 Click the Forward wedge. Hold down the button on your pointing device.

3 When the Drag Distance indicator is displayed, drag the cursor up or
down to change the distance from which you view the model.

4 Release the button on your pointing device to return to the wheel.

5 To exit the wheel, right-click.

Look Tool

The Look tool rotates the view horizontally and vertically from a fixed point.

With the Look tool, you can rotate the current view vertically and horizontally.
When rotating the view, the Look tool rotates your line of sight about the
current eye position, like turning your head. Look is comparable to standing
in a fixed location while looking up, down, left, and right.

When using the Look tool, you adjust the view of the model by dragging the
cursor. As you drag the cursor, the cursor icon changes to the Look cursor and
the model rotates around the location of the current view.

Walking through a Model

When using the Look tool, you can walk through a model by using the arrow
keys on the keyboard. You can adjust the walk speed with the Walk tool
settings on page 9034.
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Invert Vertical Axis

By default, when you drag the cursor upward, the target point of the view
raises; dragging the cursor downward lowers the target point of the view. If
you prefer, you can reverse this behavior by turning on the Invert Vertical
Axis on page 9034 option.

Procedures

To look around the scene:
1 Display a wheel that has the Look tool.
2 Click the Look wedge. Hold down the button on your pointing device.

3 When the Look cursor is displayed, drag the cursor up, down, left, and
right to change the direction in which you are looking.

4 Release the button on your pointing device to return to the wheel.

5 To exit the wheel, right-click.

To look around the view and walk through the model
1 Display the Full Navigation wheel.
2 Click the Look wedge. Hold down the button on your pointing device.

3 When the Look cursor is displayed, drag the cursor up, down, left, and
right to change the direction in which you are looking.

4 While holding down the button on your pointing device, press the arrow
keys to walk in the model.

5 Release the button on your pointing device to return to the wheel.

6 To exit the wheel, right-click.

Orbit Tool

The Orbit tool rotates the current view around a model based on a fixed pivot
point.

You use the Orbit tool to change the orientation of a model. The cursor changes
to the Orbit cursor. As you drag the cursor, the model rotates around a pivot
point while the view remains fixed.
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Specify the Pivot Point

The pivot point is the base point used when rotating the model with the Orbit
tool. You can specify the pivot point in the following ways:

B Default pivot point When you first open a model, the target point of the
current view is used as the pivot point for orbiting the model.

B Select objects With Selection Sensitivity on page 9035 enabled, you can select
objects before using the Orbit tool to calculate the pivot point. The pivot
point is calculated based on the center of the extents of the selected objects.

B Center tool. You can specify a point on the model to use as the pivot point
for orbiting with the Center tool on page 84.

Maintain Up Direction

You can control how the model orbits around the pivot point by choosing to
maintain the Up direction of the model. When the Up direction is maintained,
orbiting is constrained to the XY plane and along the Z axis. If you drag the
cursor horizontally, the camera moves parallel to the XY plane. If you drag
the cursor vertically, the camera moves along the Z axis. To control if the Up
direction is maintained for the Orbit tool, use the Keep the Scene Upright on
page 9034 option.

Procedures

To orbit around the center of the view:
1 Display a wheel that has the Orbit tool.
2 Click the Orbit wedge. Hold down the button on your pointing device.

3 When the cursor changes to the Orbit cursor, drag the cursor to rotate
the model.

NOTE If you need to change the part of the model that is displayed in the
center of the view, use the Center tool.
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4 Release the button on your pointing device to return to the wheel.

5 To exit the wheel, right-click.

To orbit around a selection set:
1 Press Esc to make sure no commands are active.
Make sure Selection Sensitivity on page 9035 is on.
Select the objects in the scene that are to define the pivot point location.
Display a wheel that has the Orbit tool.

Click the Orbit wedge. Hold down the button on your pointing device.
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When the cursor changes to the Orbit cursor, drag the cursor to rotate
the model.

N

Release the button on your pointing device to return to the wheel.

8 To exit the wheel, right-click.

To maintain the up direction for the Orbit tool:
1 Display a wheel that has the Orbit tool.

2 On the SteeringWheels panel on page 9032 of the Viewport Configuration
dialog, make sure the Orbit Tool » Keep the Scene Upright on page
9034check box is on.

Orbiting the model is constrained to the XY plane and Z axis.

3 Click OK.

Pan Tool

The Pan tool adjusts the viewpoint of the model by moving it within the
screen plane.

When the pan tool is active, the cursor changes to a four-sided arrow. As you
drag the cursor, the direction you drag moves the scene in the same direction.
For example, dragging upward moves the scene up while dragging the cursor
downward moves the scene down.
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TIP If the cursor reaches the edge of the screen, you can continue panning by
dragging the cursor further to force it to wrap around the screen.

Procedure

To pan the view with the wheel Pan tool:
1 Display a wheel that has the Pan tool.

2 Click the Pan wedge. Hold down the button on your pointing device and
drag to reposition the model.

3 Release the button on your pointing device to return to the wheel.

4 To exit the wheel, right-click.

Rewind Tool

The Rewind tool restores the most recent view. You can also move backward
and forward through a series of saved views.

As you pan, zoom, orbit, and use the other navigation tools (including the
ViewCube) to change the view of a scene, each previous view is saved
automatically to the navigation history. The navigation history holds the
previous views along with a thumbnail image for each. A separate navigation
history is maintained for each viewport; the histories are not saved with the
scene.

With the Rewind tool, you can retrieve the navigation history of a model.
You can restore the previous view or you can scroll through any of the views
saved to the navigation history.

When you hold down the button on the pointing device over the Rewind
tool on the wheel, the Rewind interface is displayed as a horizontal strip of
thumbnails showing each stored view. You can scroll through the navigation
history. To restore one of the previous views in the navigation history, drag
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the bracket horizontally in the Rewind interface. Dragging to the left goes to
previous views, and if you’ve rewound but haven’t changed the view, you can
restore later stored views by “unwinding” to the right.

If you rewind to a previous view and then use a navigation tool, 3ds Max
Design deletes the history after the current frame. However, it still remembers
all saved views prior to the current frame.

"

Procedures

To restore the previous view:
1 Display a wheel.
2 Click the Rewind wedge.

3 Click Close to exit the wheel.

To restore a previous view with the Rewind interface:
1 Display a wheel.

2 Click the Rewind wedge. Hold down the button on your pointing device.
The Rewind interface is displayed.

3 While holding down the button on your pointing device, drag to the left
or to the right to restore a previous view.

Dragging to the left restores an older previous view. Dragging to the right
restores one of the more-recent previous views.The current position in
the navigation history is indicated by the orange box that is dragged
along the Rewind UI.

4 To exit the wheel, click Close.
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Up/Down Tool

The Up/Down tool slides the current view of a model along the vertical screen
axis.

Unlike the Pan tool, the Up/Down tool does not significantly displace the
model being viewed because the view is sliding along the vertical axis of the
screen. You can think of the Up/Down tool as similar to looking in a fixed
direction while riding in a glass elevator.

BOTTOM

To adjust the vertical elevation of the current view, drag the cursor up or
down. As you drag, the current elevation and the allowed range of motion
are shown on a graphical element called the Vertical Distance indicator. This
indicator has two marks that show the highest (Top) and lowest (Bottom)
elevation the view can have. While changing the elevation with the Vertical
Distance indicator, the current elevation is shown by the bright orange
indicator while the previous elevation is shown by the dim orange indicator.

Procedure

To change the elevation of a view:
1 Display a wheel that has the Up/Down tool.

2 Click the Up/Down wedge. Hold down the button on your pointing
device.

3 When the Vertical Distance indicator is displayed, drag the cursor up or
down to change the elevation of the view.

4 Release the button on your pointing device to return to the wheel.

5 To exit the wheel, click Close.
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Walk Tool

The Walk tool simulates walking through a model.

With the Walk tool, you can navigate through a model as if you were walking
through it. Once you start the Walk tool, the Center Circle icon is displayed
near the center of the view and the cursor changes to display a series of arrows.
To walk through the model, you drag the cursor in the direction that you
want to move in.
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Constrain the Walk Angle

When walking through a model, you can constrain the movement angle to
the ground plane. If the Constrain Walk Movement Angle to Ground Plane
on page 9034 option is on (the default setting), you can look around freely while
the current view moves parallel to the ground plane. If the walk angle is not
constrained, you “fly” in the direction you are looking.

Movement Speed

As you walk or “fly” through a model, you can control the movement speed.
You control the walk speed by the distance you move the cursor from the
Center Circle icon. To set the base movement speed, you use the Speed Factor
on page 9034 setting or the Increase Walk Speed and Decrease Walk Speed
options on the Wheel menu.

Change the Elevation of the View

As you use the Walk tool, you can adjust the elevation of the view by holding
down the Shift key. You switch temporarily to the Up/Down tool on page 92.
To change the current elevation of the view for the model, you drag up and
down.
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Procedure

To use the Walk tool to move through the model:
1 Display a wheel that has the Walk tool.
2 Click the Walk wedge. Hold down the button on your pointing device.

3 When the Center Circle icon is displayed, drag the cursor in the direction
that you want to walk.

4 Release the button on your pointing device to return to the wheel.

5 Click Close to exit the wheel.

Zoom Tool
The Zoom tool adjusts the magnification of the current view of a model.

With the Zoom tool, you can change the zoom magnification of a model in
the following ways:

B Click If you click the Zoom tool on a wheel, the current view is zoomed in
by a factor of 25 percent. If you are using the Full Navigation wheel,
Incremental Zoom-in on page 9034 must be enabled on the SteeringWheels
panel of the Viewport Configuration dialog.

B Shift + click If you hold down the Shift key before you click the Zoom tool
on a wheel, the current view is zoomed out by a factor of 25 percent.

B Ctrl+click If you hold down the Ctrl key before you click the Zoom tool on
a wheel, the current view is zoomed in by a factor of 25 percent.

B Click and drag If you click the Zoom tool and hold down the button on
your pointing device, you can adjust the magnification of the model by
dragging up and down.

B Ctrl+click and drag When using the Full Navigation wheel, you can control
the target point used by the Zoom tool. By holding down Ctrl, the Zoom
tool uses the center point defined by the Center tool.

NOTE When you invoke the Zoom tool from the Full Navigation Wheel, Ctrl+click
causes zooming to occur about the current pivot point rather than the current
cursor position. Click and Shift+click perform incremental zooming only if
Incremental Zoom-in on page 9034 is enabled on the SteeringWheels panel of the
Viewport Configuration dialog.
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Zoom Constraints

When changing the magnification of a model with the Zoom tool, you cannot
zoom in any further than the focus point or out past the extents of the model.
The direction you can zoom in and out is controlled by the center point set
by the Center tool.

NOTE Unlike the Zoom tool on the View Object wheels, the Zoom tool on the
Full Navigation wheels is not constrained.

Procedures

To zoom the view with a single click:

To use this function with the Full Navigation wheel, you must enable the
Incremental Zoom-in option on page 9034.

1 Display a wheel that has the Zoom tool.

2 Click the Zoom wedge.

The magnification of the model is increased and you are zoomed in closer
to the model. If you hold down the Shift key while clicking the Zoom
wedge, the model is zoomed out or you can hold down the Ctrl key to
zoom in.

3 Click Close to exit the wheel.

To zoom a view in and out by dragging:
1 Display a wheel that has the Zoom tool.

2 Click the Zoom wedge. Hold down the button on your pointing device
and drag vertically to zoom in and out.

3 Release the button on your pointing device to return to the wheel.

4 To exit the wheel, right-click.
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Using Walkthrough Navigation

Walkthrough navigation lets you move through a viewport by pressing a set
of shortcut keys, including the arrow keys, much as you can navigate a 3D
world in many video games.

When you enter the walkthrough navigation mode, the cursor changes to a
hollow circle that shows a directional arrow while you are pressing one of the
directional keys (forward, back, left, or right).

This feature is available for perspective and camera viewports. It is not available
for orthographic views or for spotlight viewports.

Animating a Walkthrough

When you use walkthrough navigation in a Camera viewport, you can animate
the camera walkthrough using either Auto Key on page 8718 or Set Key on page
3410. In either case, to get an animated camera you have to change the frame
number manually (the easiest way is to use the Time Slider on page 8695), and
in the case of Set Key, you have to change the frame number and click Set
Keys.

TIP Select the camera before you animate it. If the camera isn't selected, its keys
won't appear in the Track Bar on page 8698.

Procedures

To begin using walkthrough navigation, do one of the following:

1 Press the Up Arrow key.

2 - Click the Walk Through button on page 8768 to turn it on.

This button is found on the Pan/Truck And Walkthrough flyout on page
8767.

To stop using walkthrough navigation, do one of the following:
1 Right-click.

Activate a different viewport.

Change the active viewport to a different type.

Turn on a different viewport navigation tool (such as Zoom or Pan).
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Turn on Select Object or one of the transform tools.
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NOTE You do not exit walkthrough mode when you select an object or change
the viewport shading type (between shaded and wireframe, for example).

Interface

The Walk Through button is the only graphical element of the interface to
walkthrough navigation. The other features are provided by mouse actions or
by keyboard shortcuts. The following table shows the keyboard actions:

Command

Shortcut

Accelerate Toggle

Q

Back

S, Down Arrow

Decelerate Toggle

z

Decrease Rotation Sensitivity

Decrease Step Size

Down

C, Shift+Down Arrow

Forward

W, Up Arrow

Increase Rotation Sensitivity

Increase Step Size

Invert Vertical Rotation Toggle

Left A, Left Arrow
Level Shift+Spacebar
Lock Horizontal Rotation

Lock Vertical Rotation Spacebar
Reset Step Size Alt+[

Right

D, Right Arrow

Up

E, Shift+Up Arrow
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If nothing appears in the Shortcut column, no default key is assigned to this
command. You can set custom keystrokes using the Keyboard panel on page
8877 of the Customize User Interface dialog.

Forward, Backward, and Sideways Movement

For movement, you can use either the arrow keys, or letters at the left of the
keyboard pad.

TIP When you are in a Perspective viewport, you can use Undo View Change and
Redo View Change (Shift+Z, Shift+Y) to undo or redo your navigation. However,
when you are in a Camera viewport, walkthrough animation transforms the camera
object, so you must use Edit » Undo and Edit » Redo (Ctrl+Z and Ctrl+Y).

Holding down any of these keys causes the motion to be continuous.

Forward W or the Up Arrow. Moves the camera or the viewpoint forward.

NOTE If you are not already in walkthrough navigation mode, pressing Up Arrow
enters it.

Back S or Down Arrow. Moves the camera or the viewpoint backward.
When you are in a camera viewport, Forward and Back are equivalent to
dollying in or out.

Left A or Left Arrow. Moves the camera or the viewpoint to the left.

Right D or Right Arrow. Moves the camera or the viewpoint to the right.
When you are in a camera viewport, Left and Right are equivalent to trucking
left or right.

Up E or Shift+Up Arrow. Moves the camera or the viewpoint up.

Down C or Shift+Down Arrow. Moves the camera or the viewpoint down.

Acceleration and Deceleration

Accelerate Toggle and Decelerate Toggle Pressing Accelerate (Q) causes
motion to be quicker. Pressing Decelerate (Z) causes movement to be slower.
These controls are toggles: pressing the key a second time restores the default
motion rate (and pressing the alternate key turns off the first). They are
especially useful when you are navigating by holding down keys.

The acceleration and deceleration toggles are independent of the step size.
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Adjusting Step Size

Increase Step Size and Decrease Step Size Pressing Increase Step Size (])
increases the motion increments when you move the camera or viewpoint.
Pressing Decrease Step Size ([) reduces them. You can press either of these
shortcuts repeatedly, to increase the effect. Changing the step size is apparent
when you navigate either by single clicks, or by holding down keys. Step size
changes are useful for adjusting movement to the scale of the scene. They are
saved with the MAX file.

Reset Step Size Pressing Reset Step Size (Alt+[) restores the step size to its
default value.

The step size is independent of acceleration or deceleration.

Rotation (Tilting)
Tilt View Click+drag to tilt the camera or viewpoint.

When you are in a camera viewport, Tilt View is equivalent to panning the
camera.

Increase Rotation Sensitivity and Decrease Rotation Sensitivity Pressing
Increase Rotation Sensitivity (no default key) increases the motion increments
when you use Tilt View. Pressing Decrease Rotation Sensitivity (no default
key) decreases them. You can press either of these shortcuts repeatedly, to
increase the effect. They are useful for adjusting movement to the scale of the
scene. They are saved with the MAX file.

Lock Horizontal Rotation Pressing Lock Horizontal Rotation (no default key)
locks the horizontal axis, so the camera or viewpoint tilts only vertically.

Lock Vertical Rotation Pressing Lock Vertical Rotation (Spacebar) locks the
vertical axis, so the camera or viewpoint tilts only horizontally.

Invert Vertical Rotation Toggle Pressing Invert Vertical Rotation (no default
key) inverts the tilt direction when you drag the mouse. When this toggle is
off, dragging up causes scene objects to descend in the view, and dragging
down causes them to rise (this is like tilting a physical camera). When this
toggle is on, objects in the view move in the same direction you are dragging
the mouse.

Level Pressing Level (Shift+Spacebar) removes any tilt or roll the camera or
viewpoint might have, making the view both level and vertical.
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Navigating Camera and Light Views

The Camera and Light view navigation buttons are the same with a few
exceptions. The buttons are visible when a viewport with a Camera or Light
view is active. The Camera and Light view navigation buttons do more than
adjust your view. They transform and change the parameters of the associated
camera or light object.
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The camera navigation
buttons

Light views treat the light (spotlight or directional light) as if it were a camera.
The light falloff is treated the same as the camera field of view.

Keep in mind the following:

B Using the Camera and Light viewport navigation buttons is the same as
moving or rotating the camera or Light, or changing their base parameters.

B Changes made with Camera or Light view navigation buttons can be
animated the same as other object changes.
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Zooming a Camera or Light View

Zooming a camera

:D:- You zoom a camera view by clicking FOV on page 8774 and then dragging
in the Camera viewport.

The field of view defines the width of your view as an angle with its apex at
eye level and the ends at the sides of the view. The effect of changing FOV is
exactly like changing the lens on a camera. As the FOV gets larger you see
more of your scene and the perspective becomes distorted, similar to using a
wide-angle lens. As the FOV gets smaller you see less of your scene and the
perspective flattens, similar to using a telephoto lens. See Cameras on page
5941.

@ Click Light Hotspot on page 8797 for a light viewport to achieve the same
effect as zooming.

The hotspot is the inner of the two circles or rectangles visible in a light
viewport. Objects inside the hotspot are illuminated with the full intensity of
the light. Objects between the hotspot and falloff are illuminated with

Navigating Camera and Light Views | 101



decreasing intensity as objects approach the falloff boundary. See Using Lights
on page 5680.
Moving a Camera or Light View

You move a camera or light view by clicking one of the following buttons and
dragging in the camera or light viewport.

e
m . (Dolly on page 8783) moves the camera or light along its line of sight.
Y
1
[ ] (Truck on page 8788) moves the camera or light and its target parallel
to the view plane.
H
| 4 (Pan on page 8789) moves the target in a circle around the camera
or light. This button is a flyout that shares the same location with Orbit.
| * (Orbit on page 8789) moves the camera or light in a circle around

the target. The effect is similar to Orbit for non-camera viewports.
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Rolling a Camera or Light View

Rolling a camera

-

Click Roll on page 8786, and drag in a camera or a light viewport to
rotate the camera or light about its line of sight. The line of sight is defined
as the line drawn from the camera or light to its target. The line of sight is
also the same as the camera’s or the light's local Z axis.
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Changing Camera Perspective

Changing perspective

@ Click Perspective on page 8785, and drag in a camera viewport to change
the Field of View (FOV) and dolly the camera simultaneously. The effect is to
change the amount of perspective flare while maintaining the composition
of the view.

Adaptive Degradation st

Status bar » (Adaptive Degradation)
Views menu » Adaptive Degradation
Keyboard » O (the letter O)

Adaptive degradation can improve viewport performance when you transform
geometry, change the view, or play back an animation. It does so by decreasing
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the visual fidelity of certain objects temporarily; for example, by drawing
larger objects or those closer to the camera as bounding boxes instead of
wireframes.

Without adaptive degradation, the geometry is displayed as usual, even if that
slows down viewport display and animation playback. Animation playback
might drop frames if the graphics card cannot display the animation in real
time.

Turn on adaptive degradation if you have large models you need to navigate
around and if you are finding performance sluggish.

The Adaptive Degradation button on the status bar has three states:

&

] Off: No degradation occurs.

| On: Degradation can occur under the specified conditions. This is

the default setting.

] Active: Degradation is being applied currently.

You can change the display options and set other adaptive degradation
parameters, on the Viewport Configuration dialog (Customize menu »
Viewport Configuration » Adaptive Degradation panel on page 9014). Also,
you can toggle adaptive degradation for individual objects with the Object
Properties » Never Degrade setting on page 228.

Procedures

To toggle adaptive degradation, do one of the following:
B Choose Views menu » Adaptive Degradation.

B Press O (the letter O).

To change the level of adaptive degradation in the viewports:

1 Click or right-click the General viewport label (“[ +]”). On the General
viewport label menu on page 8746, choose Configure.

3ds Max Design opens the Viewport Configuration dialog.

Adaptive Degradation | 105



TIP You can also open this dialog by choosing Main menu » Customize
» Viewport Configuration.

2 On the Viewport Configuration dialog, open the Adaptive Degradation
panel and adjust the settings.

View-Handling Commands

Most viewport-handling commands are found on the Views menu on page
8634 and on the viewport label menus on page 8746.

See also:
B Viewing and Navigating 3D Space on page 47

B Quad Menu on page 8679

Undo View Change / Redo View Change

Views menu » Undo View Change or Redo View Change
Keyboard » Shift+Z (Undo) or Shift+Y (Redo)

Undo View Change cancels the last change made to the current viewport.
Redo View Change cancels the last Undo in the current viewport.

These commands act like Undo and Redo on the main toolbar and Edit menu,
but operate on a different list of events. They affect changes made to the
viewport, rather than changes made to objects in the viewport.

Use Undo View Change and Redo View Change when you have inadvertently
made a view unusable by zooming in too close, or rotating the wrong way.
You can keep stepping back until a useful view appears. The keyboard shortcuts
are handy for multiple commands.

You can also access Undo View Change by right-clicking the Point-Of-View
viewport label and choosing Undo View Change from the POV viewport label
menu on page 8751. This menu choice shows the last change you made in that
viewport: for example, “Undo View Zoom.” Each viewport has its own
independent undo/redo stack.
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Camera and Spotlight viewports use object-based Undo and Redo, because
the viewport change is actually a change to the camera or spotlight object. In
these viewports, use Edit » Undo (Ctrl+Z) or Edit » Redo (Ctrl+Y).

Interface

Undo View Change Cancels viewport changes. The name of the change you're
undoing is displayed in the View menu beside the command.

Undo is useful when you are working with a background image in the viewport.

You can zoom into the geometry to adjust it, then use Undo Viewport Zoom
to restore the original alignment of the geometry with the background.

Redo View Change Cancels the previous Undo View Change. The name of
the change you're redoing appears in the View menu beside the command.

Save Active View

Views menu » Save Active View (the name of the active viewport is part of
the command)

Save Active View stores the active view to an internal buffer. If you have framed
a shot in any view other than a camera, use Save Active View to preserve the
viewport’s appearance. The saved active view is saved with the scene file. Once
saved, you can retrieve it using Restore Active View on page 108.

The viewport that will be restored is displayed in the menu item (for example,
"Save Active Perspective View"). You can save and restore up to eight different
views (Top, Bottom, Left, Right, Front, Back, Orthographic, Perspective).

Viewport changes that are saved include viewport shading type and point of
view (POV): perspective or orthographic, zoom and rotations, and field-of-view
(FOV).

Show Safe Frames and Viewport Clipping settings are not saved. If these settings
are important to the view, make a note of what they are so you can reset them
after restoring the view.

Procedures

To save an active view:
1 Activate the viewport with the view you want to save.

2 Choose Views menu » Save Active View. The view is now saved and
can be recalled using Restore Active View.
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Restore Active View

Views menu » Restore Active View (the name of the active viewport is part
of the command.)

Restore Active View displays the view previously stored with Save Active View
on page 107.

The viewport to be restored is displayed in the menu item (for example,
"Restore Active Perspective View").

The active view is restored if the same viewport and layout are active.
If an active view won'’t restore with this command, check the following:
B Be sure the viewport is active.

B Make sure the layout is the same as before. Use Viewport Configuration
(right-click any viewport label and choose Configure) and choose Layout.

m If the layout and active viewport are the same, be sure Viewport Clipping
on the Point-Of-View (POV) viewport label menu on page 8751is set the same
as it was when the viewport was saved.

Procedures

To restore a saved view:
1 Activate the viewport where you saved the view.

2 Choose Views menu » Restore Active View. This option is available
only in a viewport with a saved view.

3 The viewport returns to the saved view.

If you're not sure whether a viewport has a saved view, check the Views
menu. Restore Active View is unavailable unless a view is saved in the
active viewport.

Viewport Background Dialog

Views menu » Viewport Background » Viewport Background » Viewport
Background dialog
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Click or right-click the Shading viewport label. » Shading viewport label
menu on page 8758 » Viewport Background » Viewport Background »
Viewport Background dialog

Keyboard » Alt+B

The Viewport Background dialog controls display of an image or animation
as the background for one or all viewports. You can use this for modeling, for
example, by placing front, top or side view sketches in the corresponding
viewports. Or use Viewport background to match 3D elements with digitized
camera footage, or for rotoscoping on page 9328.

You select the image or animation to display in the active viewport, set the
frame synchronization between the animated image file and the current scene,
and turn the assigned image on and off. These changes do not affect the
rendered scene.

To place an image in the background of the rendered scene, use the
Environment And Effects dialog » Environment panel on page 7656, accessed
from the Rendering menu.

NOTE When safe frames are displayed in a viewport, and the Aspect Ratio options
are set to either Match Viewport or Match Rendering Output, the assigned viewport
background image is confined to the Live area of the safe frames and will correctly
match the rendered background bitmap.

TIP If you are using a viewport driver with hardware acceleration (OpenGL or
Direct3D), the viewport background might not appear. If this happens, choose
Customize » Preferences. In the Viewports preferences on page 8937, click
Configure Driver. Then in the Configure OpenGL dialog on page 8948 or the
Configure Direct3D dialog on page 8953, go to the Background Texture Size group
and turn on Match Bitmap Size As Closely As Possible (do not change the numeric
setting). Click OK in both dialogs to accept your change.

See also:
B Select Background Image Dialog on page 117
B Update Background Image on page 122

B Reset Background Transform on page 123
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Procedures

To assign an image to one or all viewports:

1
2

Activate the viewport that is to display the background image.

Choose Views menu » Viewport Background » Viewport Background
or press Alt+B.

This opens the Viewport Background dialog.

In the Background Source group, click the Files button.
This opens the Select Background Image dialog.

Use the dialog to open the image or animation to use.
To display the image in all viewports, choose All Views in the Apply
Source And Display To group.

|—,&pp|_|,| Source and Digplay to——

ﬁ'D;}ﬁ.II Yiews O Active Only

Click OK.

The image is displayed in a single viewport or all viewports.

To update the image or map in the viewport:

Because of the time it takes to render the image or map in the viewport, the
map is not automatically updated when you alter the bitmap or assign a new
bitmap.

B Choose Views menu » Viewport Background » Update Background

Image.
The revised image or map is displayed in the viewport.

To display the environment map in a viewport:

1

In the Environment dialog, assign an environment map. (See the
procedure “To choose an environment map.” on page 7657)

In the Environment dialog » Background group, be sure Use Map is
turned on (the default).

Activate the viewport where you want the map displayed.
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Choose Views menu » Viewport Background » Viewport Background.

In the Viewport Background dialog » Background Source group, turn
on Use Environment Background.

Click OK.
The map is displayed in the viewport.

To display an animated background:

1

Assign an animation file (AVI, MOV, or IFL file) as the viewport
background.

Turn on Animate Background.

Choose Customize » Preferences. On the Viewports panel, turn on
Update Background While Playing.

Now the background plays when you click Play, or when you drag the
time slider.

TIP If you follow these steps and the background still doesn't appear to
animate, open the Time Configuration dialog on page 8735 and in the Playback
group, turn off Real Time.

To use the environment map with animation controls:

This procedure is useful if you've assigned an animated environment map
and want access to the animation controls on the Viewport Background dialog.

1

v A W N

In the Viewport Background dialog » Background Source group, turn
off Use Environment Background.

In the same group, click File.
Choose the same map you're using as the environment map.
Set parameters in the Animation Synchronization group.

Click OK.
The environment map appears in the viewport. The image is renderable.

To match the viewport background with the rendered background:

1

Activate the viewport to render.
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2 Click or right-click the General viewport label (“[ +]”). On the General
viewport label menu on page 8746. choose Show Safe Frame.

This turns on Safe Frames on page 9011 in the viewport.

NOTE You can also use Views menu » Configure » Safe Frame tab. In
the Application group, turn on Show Safe Frames In Active View.

3 In the Material Editor, create a material that contains the bitmap for your
rendered background.

4 At the bitmap level of the Material Editor, on the Coordinates rollout,
choose Environ.

The Mapping control is automatically set to Screen. This is the only
mapping type that works for this purpose.

5 On the main menu, choose Rendering » Environment.

6 Drag the map from the Material Editor » Maps rollout to the
Environment Map button on the Environment dialog. Click OK on the
Instance (Copy) Map dialog.

7 In the Viewport Background dialog » Background Source group, click
Files to assign the same bitmap.

8 In the Aspect Ratio group, turn on either Match Viewport or Match
Rendering Output. Click OK.
9 Render the viewport.

The background displayed in the rendered scene should exactly match
the background displayed in the Live area of the safe frames.

NOTE When you use the Match Bitmap option, the bitmap reverts to its
original aspect ratio and does not match the rendered scene, unless you're
rendering to the same aspect ratio.

To remove a background image:
1 Activate the viewport in which the background image is visible.

2 On the Views menu, choose Viewport Background » Viewport
Background.

Notice that the name and path of the background file is displayed in the
Current field in the Background Source group
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In the Background Source group, click Devices.

On the Select Image Input Device dialog, choose No I/O Handlers from
the drop-down list, then click OK.
On the Bitmap Manager Error dialog, click OK.

The current field no longer displays the background file name. Instead
No I/O Handler is listed in the Current field.

Click OK to close the Viewport Background dialog.

Next time you open up the Viewport Background dialog, no file name
will be displayed in the Current field.

TIP This technique will work only on systems that don't have any other Image
Input Devices installed.
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Interface
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Background Source group

Options let you select the background image, either from a bitmap image file
on page 9152, a video file, or from a device such as a video recorder.

Files Displays the Select Background Image dialog on page 117, which lets you
select a file or sequence of files for your background.
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Devices Displays the Select Image Input Device dialog. This lets you use a
background from a digital device. (No device is supported by the default 3ds
Max Design installation.)

Use Environment Background Lets you display in the viewports the map
you've assigned as your environment background. If no environment map
has been assigned in the Environment dialog, or Use Map in that dialog is off,
then the Use Environment Background check box is not available.

Animation Synchronization group

Controls how sequences of images (for example, from IFL on page 8457, AVI on
page 8449, or MOV on page 8465 files) are synchronized to the viewport for
rotoscoping on page 9328.

Use Frame The first field sets the first frame of the incoming sequence that
you want to use, and the second field sets the last one.

Step Sets the interval between the frames you want to use. For example, if
this spinner is set to 7, 3ds Max Design uses every seventh frame.

Start At Specifies the frame number at which you want the first input frame
to appear. What happens in the viewport before the start frame depends on
the option you choose for "Start Processing," below.

Sync Start To Frame Determines which frame from your incoming sequence
is displayed at the Start At frame. For example, you could have a 30-frame IFL
sequence that starts in your scene at frame 10, but you could use the 5th frame
from the IFL on frame 10 by setting Sync Start to 5.

Start Processing group

Determines what happens in the viewport background before the start frame.

Blank Before Start Makes the viewport background blank before the start
frame.

Hold Before Start Specifies that the viewport background will contain the
start frame.
End Processing group

Determines what happens in the viewport background after the last input
frame.

Blank After End Makes the viewport background blank after the last input
frame.
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Hold After End Specifies that the viewport background will contain the last
input frame until the last frame in the animation.

Loop After End Specifies that the viewport background will loop from the
end frame back to the start frame, ad infinitum.
Aspect Ratio group

Controls the proportions of the viewport background by matching it to the
bitmap, rendering output, or to the viewport itself.

Match Viewport Changes the aspect ratio on page 9140 of the image to match
the aspect ratio of the viewport.

Match Bitmap Locks the aspect ratio of the image to the native aspect ratio
of the bitmap.

Match Rendering Output Changes the aspect ratio of the image to match
the aspect ratio of the currently chosen rendering output device.

NOTE When the Match Bitmap or Match Rendering Output option is chosen, 3ds
Max Design centers the image and clears the edges of the viewport to the
background color.

Display Background

Turns on display of the background image or animation in the viewport.

Lock Zoom/Pan

Locks the background to the geometry during zoom and pan operations in
orthographic or user viewports. When you Zoom or Pan the viewport, the
background zooms and pans along with it. When Lock Zoom/Pan is turned
off, the background stays where it is, and the geometry moves independently
of it. Use Match Bitmap or Match Rendering Output to enable Lock Zoom/Pan.
This control is disabled if you choose Match Viewport.

Keyboard shortcut: Ctrl+Alt+B

WARNING If you zoom in too far, you can exceed the limit of virtual memory,
and crash 3ds Max Design. When you perform a zoom that requires more than
16 megabytes of virtual memory, an alert asks if you want to display the
background during the zoom. Choose No to perform the zoom and turn off the
background. Choose Yes to zoom with the background image. Your machine
might run out of memory as a result.
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Animate Background
Turns on animation of the background. Shows the appropriate frame of the

background video in the scene.

Apply Source And Display To group
All Views Assigns the background image to all viewports.

Active Only Assigns the background image to only the active viewport.

Viewport

The name of the currently active viewport appears in a list to the left of the
OK and Cancel buttons. This reminds you which viewport you're working
with and lets you change the active viewport by selecting its name from the
list.

NOTE When you use different images for different viewports, the settings for each
viewport are stored separately. Each time you display the Viewport Background
dialog, the settings of the currently active viewport are displayed. If you switch
the viewport using the list, the settings remain the same. This is useful for copying
settings from one viewport to another.

Select Background Image Dialog

Views menu » Viewport Background » Viewport Background » Viewport

Background dialog » Background Source group » Files » Select Background
Image dialog

The Select Background Image dialog allows you to choose a file or sequence
of files for a viewport background.
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Cityscape model with a sky image used as the viewport background

You can also convert a set of sequentially numbered files to an Image File List
(IFL) on page 8457. This is the same process used by the IFL Manager Utility on
page 8461.

Procedures

To select a background image for a viewport:

1

2
3
4

Activate the viewport where you want the image.
Choose Views menu » Viewport Background » Viewport Background.
Under Background Source in the dialog that displays, click Files.

In the Look In field, navigate to the directory containing the file you
want to use for the background.

NOTE The Select Background Image File dialog uses the last location where
a bitmap was chosen, rather than the default bitmap path defined on the
Configure User Paths dialog on page 8912.

Highlight the file name in the file list window.

Click Open to select the image and close the dialog.
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7 Click OK to close the Viewport Background dialog and display the
background image.
To select a set of still images as a viewport background:
1 Activate the viewport where you want the image.
2 Choose Views menu » Viewport Background » Viewport Background.
3 Under Background Source, click Files.

4 In the Look In field, navigate to the directory containing the sequence
of files.

The files must be sequentially numbered (for example, image01.bmp,
image02.bmp, image03.bmp).

TIP If necessary, change Files Of Type to match the file extension of the
sequence, or choose All Formats.

5 Turn on Sequence, and choose the name of the first sequential file (for
example, image01.bmp).

TIP Click the Setup button to display the Image File List Control dialog on
page 8460.

6 In the Image File List Control dialog, use the Browse button to set the
Target Path to a directory on your hard disk. Do not set this path to a
CD-ROM drive, because you cannot save the file there.

7 Choose the options you want, and then click OK.
The Image File List (IFL) file is saved to the target directory.
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Interface

|&] Select Background Image.

History: [C:\Users‘\ \Documents!3ds Max 2010 Tutorials'sceneassetsiimages

Look in: | images - @ ? » [~

Name‘ Date taken Tags Size Rating

mABB-

pooltop.jpg  Proj-Plane.. Proj-Plane.. Proj-Plane.. ps-signjpg Quadruped_
Walk_Cycle_F
l.png

File name: Quadruped_Walk_Cyde_F1.png

Files of type: | All Formats

Gamma

Devices... .
(@) Use image's own gamma

Setup... Use system default gamma

Override =
D !

Statistics: 400x300, RGBA Color 8 Bits/Channel - Single Image
Location: C:Users) \Documents\3ds Max 2...\Quadruped_Walk_Cyde_F1.png

History Displays a list of the directories most recently searched.

Look In Opens a navigation window to move to other directories or drives.

&. Go to Last Folder Visited Click to return to the folder you previously
browsed to.

¥

]

Up One Level Move up a level in the directory structure.

Create New Folder Lets you create a new folder while in this dialog.

g

list.

View Menu Lets you choose the level of detail to display in the file
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List Window When Details is on, the contents of the directory are displayed
with Name, Size, Type, Date Modified, and Attributes. You can sort the files
by clicking the label of each parameter.

File Name Displays the name of the file selected in the list.

Files of Type Displays all the file types that can be displayed. This serves as
a filter for the list.

Open Selects the highlighted file and closes the dialog.
Cancel Cancels the selection and closes the dialog.

Devices Lets you select a background image from a digital device. (No device
is supported by the default 3ds Max Design installation.)

Setup Displays the Image File List Control dialog on page 8460 to create an IFL
file. Available only when Sequence is on and there are sequentially numbered
files in the displayed directory.

Info Displays expanded information about the file, such as frame rate,
compression quality, file size, and resolution. The information here is
dependent on the type of information that is saved with the file type.

View Displays the file at its actual resolution. If the file is a movie, the Media
Player is opened to play the file.
Gamma group

Selects the type of gamma to be used for the selected file. Available only when
Enable Gamma Selection is turned on in the Gamma panel on page 8958.

Use Image’s Own Gamma Uses the gamma of the incoming bitmap.

Use System Default Gamma Ignores the image’s own gamma and uses the
system default gamma instead, as set in the Gamma panel on page 8958.

Override Defines a new gamma for the bitmap that is neither the image’s
own, nor the system default.

Sequence Creates an "Image File List" to your specifications. Each selected
image is checked to see if a valid IFL sequence can be created. If the selected
image doesn’t yield a list, this option is still available, but doesn’t do anything.

Preview Displays the image as a thumbnail in the Image Window.

Image Window Displays a thumbnail of the selected file if Preview is on.
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Statistics Displays the resolution, color depth, file type and number of frames
of the selected file.

Location Displays the full path for the file. With this information at the
bottom of the dialog, you always know exactly where you are.

Update Background Image

Views menu » Viewport Background » Update Background Image (available
only when a viewport background is displayed)

This command updates the background image displayed in the active viewport.
If the active viewport is not displaying a background image, this command
is unavailable.

Use this command to update the background for changes that are not updated
automatically, such as the following:

B Reassigning the map, or changing any parameters affecting the map in
the Materials Editor, the Environment dialog, or the Viewport Background
dialog.

B Changing the rendering resolution and aspect ratio.
The following changes update the viewport background image
automatically:

Changing the camera view.

Undo (for views).

Undo (for objects).

Assigning a different view type.
Toggling Safe Frames display on or off.

Changing the rendering parameters.

Moving the time slider when the viewport contains an animated
background image.

NOTE Viewports can use the current Environment Map (set on the Environment
panel on page 7657 of the Environment and Effects dialog) as the background image.
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Procedures

To update the background image displayed in a viewport:
1 Activate a viewport that contains a background image.

2 Choose Views menu » Update Background Image.

Reset Background Transform

Views menu » Reset Background Transform (available only when a viewport
background image is displayed and Lock Zoom/Pan is turned on)

Reset Background Transform rescales and recenters the current background
to fit an orthographic or user viewport. Use this command when you want to
reset the background to the new position of your geometry. See Procedure for
detailed requirements.

Procedures

To reset the background to fit the viewport:
1 Activate an orthographic or user viewport that has a background image.
2 DPress Alt+B.

3 Turn on either Match Bitmap or Match Rendering Output, and then turn
on Lock Zoom/Pan.

4 Click OK.

5 Choose Views menu » Reset Background Transform.
The background image readjusts in the viewport.

Show Transform Gizmo

Views menu » Show Transform Gizmo
Keyboard » X

Show Transform Gizmo toggles the display of the Transform gizmo axis tripod
on page 841 for all viewports when objects are selected and a transform is active.

Additional controls for the Transform gizmo are found on the Gizmo
Preferences settings on page 8982.
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When the Transform gizmo is turned off, Show Transform Gizmo controls
the display of the axis tripod on selected objects.

The state of Transform gizmo is saved in 3dsmax.ini, so it's maintained between
scenes and sessions.

The related entries in the 3dsmax.ini file are:

B INI: Transformgizmo=1 (for Transform Gizmo visibility, controlled by
Preferences)

B INI: ShowAxisIcon=1 (for Axis Icon visibility, controlled in Views menu)

The visibility of the Axis tripod overrides the visibility of the Transform Gizmo.
If you turn off the Transform Gizmo in Preferences, the Axis tripod remains
on the selected object. If you then turn off the Show Transform Gizmo in the
Views menu, it actually turns off the Axis tripod. When the Axis tripod is
disabled, the Transform Gizmo is also hidden.

TIP The converse is not true. If the transform gizmo is turned off, turning on the
axis tripod visibility does not display the transform gizmo.

Procedures

To scale the transform gizmo, do one of the following:
1 Press — (hyphen) to shrink the Transform gizmo.

2 Press = (equal sign) to enlarge the Transform gizmo.

Show Ghosting

Views menu » Show Ghosting

Ghosting is a method of displaying wireframe "ghost copies" of an animated
object at a number of frames before or after the current frame. Use it to analyze
and adjust your animation. Ghosts that overlap indicate slower motion; ghosts
that are spread further apart show faster motion.

When this command is active, ghosting is displayed for selected objects in
the scene. Only currently selected objects display the ghosting.
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Ghosting helps to visualize animation.

To change Ghosting parameters choose Customize » Preferences. On the
Viewport panel of the Preferences dialog you can determine the number of
ghosting frames, whether to ghost before or after the current frame, or both,
and you can also show frame numbers with the ghosts.

Procedures

To show wireframe ghost copies of an animated object:

B Choose Views menu » Show Ghosting.

Show Key Times

Select an object with animation. » Views menu » Show Key Times

Key Times shows the frame numbers along a displayed animation trajectory

on page 3444. Key times correspond to the settings in Time Configuration on
page 8735 for Frames or SMPTE on page 9355. By default, key times are shown as
frame numbers.
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Procedures

To display trajectory time values in the viewport:

1 Select an object with animation.

2 On the EI

Trajectory.

Display panel » Display Properties rollout, turn on

TIP If the rollout controls are unavailable, right-click the object in the active
viewport, choose Object Properties, and in the Display Properties group, click
By Layer to change to By Object. This will make the Trajectory option become
available.

3 Choose Views menu » Show Key Times.

The time values are displayed as white numbers along the trajectory.
They remain displayed in red when the animated object is deselected.

Keyframes with frame number shown on a trajectory.
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Shade Selected

Select an object to be shaded. » Views menu » Shade Selected

Shade Selected shades only the selected objects in the scene when the viewport
is set to Wireframe or Other. When Smooth + Highlights is on, all objects are
shaded whether they are selected or not.

Shade Selected lets you work with a wireframe scene and shade only the
selected objects when you want to visualize them more clearly. All other
objects in the scene will appear in wireframe.

Selected objects shaded in a wireframe viewport.

Procedures

To shade only selected objects in a scene:
1 Choose Views menu » Shade Selected.

2 Click or right-click the Shading viewport label and choose Wireframe
from the Shading viewport label menu on page 8758.

3 Select the object.
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Only the selected object is shaded.

Show Dependencies

Views menu » Show Dependencies

While you are using the Modify panel, this command toggles viewport
highlighting of objects dependent on the currently selected object.

When Show Dependencies is on and the Modify panel is active, any object
that is dependent upon the currently selected object in any way appears
magenta. This includes instances on page 9239, references on page 9326, and
shared modifiers on page 9271. Default=off.

You can also see similar dependencies in Schematic View on page 8540.

Procedures

To show dependencies between objects:

1 Select an object with an instanced modifier on page 1002.
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2 Onthe @ Modify panel, choose the instanced modifier in the modifier
stack.

3 Choose Views menu » Show Dependencies

Other objects with instances of the same modifier appear in a different
color.

Example: To use Show Dependencies when animating with Linked XForm:

1 Select the sub-object geometry you want to animate, and apply a Linked
XForm modifier on page 1430.

2 On the Parameters rollout, click Pick Control Object.

3 Click an object to be the control object. Choose a dummy object if you
want to keep the control hidden in final rendering.

4 The chosen object is now linked as parent to the sub-object selection and
its name is listed on the Parameters rollout.

5 Choose Views menu » Show Dependencies to make the link visible
when the control object is selected.

6 Use any of the transforms to animate the control object.
The selection is animated in parallel with the control object.

Create Camera From View

Activate a Perspective viewport. » Views menu » Create Camera From View

Activate a Perspective viewport. » Create menu » Cameras » Create
Camera From View

Activate a Perspective viewport. » Keyboard » Ctrl+C

Create Camera From View creates a Target camera on page 5952 whose field of
view matches an active Perspective viewport. At the same time, it changes the
viewport to a Camera viewport on page 8781 for the new camera object, and
makes the new camera the current selection.
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Alternatively, if the scene already contains a camera and the camera is selected,
then Create Camera From View does not create a new camera from the view.
Instead, it simply matches the selected camera to the active, Perspective
viewport. This functionality was adopted from the Match Camera to View
command, which is now available only as an assignable main user interface
shortcut (see Keyboard Shortcuts on page 9049).

NOTE Create Camera From View is available only when a Perspective viewport is
active.

To create a camera from a view, assuming any existing cameras are unselected:
1 Activate a Perspective viewport.

2 If necessary, adjust the viewport using Pan, Zoom, and Orbit, or the
ViewCube, until you have a view you like.

3 Leaving the viewport active, on the Views menu choose Create Camera
From View or press Ctrl+C.

3ds Max Design creates a new camera, matching its view to that of the
Perspective viewport, and then switches the Perspective viewport to a
Camera viewport, showing the view from the new camera.
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Add Default Lights to Scene

Click or right-click the General viewport label (“[ +]”). » General viewport
label menu on page 8746 » Configure » Viewport Configuration dialog »
Lighting And Shadows panel » Illuminate Scene With group » Choose
Default Lighting and then choose 2 Lights (to activate the Add Default Lights
To Scene menu item) » Click OK. » Create menu » Lights » Standard
Lights » Add Default Lights To Scene

This command opens the Add Default Lights To Scene dialog, which provides
options that let you convert the default scene lighting into actual light objects
on page 5676.

The default lighting for viewports consists of a key light, positioned in front
and to the left of the scene, which behaves as an omni light on page 5774..

This command is unavailable unless you use the Viewport Configuration
dialog on page 9005 to configure the active viewport to use two lights. When
viewports use two lights, and you invoke this command, the lights are added
to the scene as omni lights. You can add either the key light, the fill light, or
both.

Two default lights are placed opposite to each other.
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A, the key light is in front of the object, on the upper left side, while B, the fill light is
behind on the lower right side.

You can add either the key light, the fill light, or both. The omni light objects
have the names DefaultKeyLight and DefaultFillLight.

If you have already added one or both default lights, a warning prompts you
to rename or delete the previous default light object before you add another.

Procedures

To add the default lights as objects:

1

Click or right-click the General viewport label (“[ +]”).
3ds Max Design opens the General viewport label menu on page 8746.

Choose Configure.

On the Viewport Configuration dialog » Rendering Method tab, in the
Rendering Options group, turn on Default Lighting and choose 2 Lights.
Click OK to close the dialog.

Choose Create menu » Lights » Standard Lights » Add Default Lights
To Scene.

On the Add Default Lights To Scene dialog, toggle Add Default Key Light,
Add Default Fill Light, or both. Click OK.
r n |

Activate the Top viewport, and on the status bar, click = - (Zoom
Extents).

The lights are now visible in the viewport.
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Interface

Add Default Lights E x|
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Add Default Key Light When on, adds the default key light to the scene. The
key light is in front of the scene and to the left. The key light becomes an
omni light on page 5774 with the name, DefaultKeyLight. Default=on.

Add Default Fill Light When on, adds the default fill light to the scene. The
fill light is behind the scene and to the right. The fill light becomes an omni
light on page 5774 with the name, DefaultFillLight. Default=on.

Distance Scaling Affects how far the lights are placed from the origin (0,0,0).
The default value leaves the scene's lighting unchanged. Larger values move
the lights farther away, dimming the scene, and smaller values move them
closer, brightening the scene. Default=1.0. Range=0.0 to 1000.0.

Redraw All Views

Views menu » Redraw All Views
Keyboard » ° (accent grave)

Redraw All Views refreshes the display in all viewports. When you move,
rotate, scale, or otherwise manipulate geometry, the viewports may display
the scene with some irregularities, or with objects or parts of objects missing.
Use Redraw All Views to redisplay your scene with all lines and shading
restored.
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Show Materials in Viewport As

Views menu » Show Materials in Viewport As » Standard Display / Standard
Display with Maps / Hardware Display / Hardware Display with Maps

Compact Material Editor » Material menu » Show Materials in Viewport
As » Standard Display / Standard Display with Maps / Hardware Display /
Hardware Display with Maps

Slate Material Editor toolbar » Show Map in Viewport on page 6189 flyout

These commands turn on and off display of all maps in the viewports, using
software or hardware rendering. Software rendering applies to all maps and
materials, but tends to be less accurate. Hardware rendering is highly accurate,
showing highlights very close to the way they render, but applies primarily
to the Arch & Design material on page 6303, although it also supports the
Standard material on page 6416.

NOTE Hardware viewport rendering is not available on computers with older
graphics systems. Also, hardware viewport rendering is supported only by the
Direct3D display driver on page 8953.

NOTE These commands do not apply to XRef materials on page 6639, including
materials from XRef objects on page 8008 and XRef scenes on page 8036.

See also:

B Showing Maps in Viewports on page 6040

Interface

Standard Display Uses the legacy software shader, which works on a per-face
basis, and turns off viewport display of all maps at the material level. This
applies only to materials used in the scene.

Standard Display with Maps Uses the legacy software shader, which works
on a per-face basis, and turns on viewport display of all maps.

Hardware Display Uses the hardware viewport shader, which works on a
per-pixel basis, and turns off viewport display of all maps at the material level.

The hardware shader applies only to the Standard on page 6416 and Arch &
Design on page 6303 materials; when it’s active, 3ds Max Design still uses the
software shader to display all other materials.
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Hardware Display with Maps Uses the hardware viewport shader, which
works on a per-pixel basis, and turns on viewport display of all maps at the
material level.

This switch applies only to the Standard on page 6416 and Arch & Design on
page 6303 materials; when it’s active, 3ds Max Design still uses the software
shader to display all other materials. Also, it doesn't affect viewport display
of maps for materials other than those two.

Update During Spinner Drag

Views menu » Update During Spinner Drag

When Update During Spinner Drag is on, dragging a spinner (such as a Radius
spinner for a sphere) updates the effects in real time in the viewports.
Default=on.

When Update During Spinner Drag is off, the effect is updated after the drag,
when you release the mouse. Use this option when you're adjusting
processor-intensive controls.

Diagnose Video Hardware

Help menu » Diagnose Video Hardware

This command runs a MAXScript script that displays information about your
system’s graphic display configuration. This can be useful for telling you
whether some interactive viewport features such as shadows on page 5696 are
supported.

MAXScript Listener g@

File Edit Search MacroRecorder Debugger Help

Seript included successfully: Ci\Program Files‘\Autodesky3ds Max Z010%scripts)automes) &
—-- 'automxs' struct is defined D |
F NSNSy NSNS ISR N RN
AdiAi4) Rewview GPU Feature Support /A0S0 00 0000000808000 00000 8000000400
FEEEEEER TSRS R R i i T i idiid i i s i i i i diidiiidiriiiddiddidsidsiddiidiiiiinis

Graphics Vendor Information: Direct3D 9.0 (ATI MOBEILITY FireGL V52Z50)

GPU 3hader Model Support: 3M3.0

Maximum pixel shader instruction count: 512

Viewport Shading Quality: EBest

Real-time 3un and Sky: Supported

Feal-time Architectural Material: 3Supported

Visit http://wmnr. autodesk. con/max-hardware for a list of certified graphics cards
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Expert Mode

Views menu » Expert Mode
Keyboard » Ctrl+X

When Expert mode is on, the title bar, toolbar, command panel, status bar,
and all of the viewport navigation buttons are removed from the display,
leaving only the menu bar, time slider, and viewports. Use Expert mode when
you need to view your composition alone without the rest of the interface.

With the ability to customize the user interface in 3ds Max Design, you can
create your own versions of Expert mode by hiding whatever you want
item-by-item. Expert mode is only a quick way to hide everything that can
be hidden at once.

You can assign keyboard shortcuts to hide and unhide the command panel,
toolbars, and so on and then use these while in Expert mode. You can also
use the quad menu to access tools quickly in Expert mode as well.

Procedures

To turn on Expert mode, do one of the following:
B Choose Views menu » Expert Mode.

B Press Ctrl+X.

To turn off Expert mode and return to full display, do one of the following:
m Click the Cancel Expert Mode button to the right of the time slider.
B Press Ctrl+X.

B Choose Views menu » Expert Mode.

Controlling Object Display

You use the Display panel, layers on page 8571, and Scene Explorer on page 8506
to control how objects are displayed in viewports, and to hide or freeze objects.
This section covers usage of the Display panel controls.

TIP You can also use the Isolate Selection command on page 176 to hide everything
except your selection set.

136 | Chapter 3 Viewing and Navigating 3D Space



See also:

B Object Display Properties on page 225

Display Color Rollout =

Display panel » Display Color rollout

The Display Color rollout specifies whether 3ds Max Design displays objects
using their wireframe colors (also known as object colors) or their diffuse
material colors on page 9181, when the objects have their display properties on
page 221 set to By Object. If the display properties of an object is set to By
Layer, the layer color is used for viewport display. You can choose one method
for wireframe display and a different one for shaded display. In each shading
mode you can specify whether the material or the object color is used.

By default, all new objects have their display properties set to By Object. You
can change this default by turning on Default to By Layer for New Nodes on
page 8932. When this switch is off (the default), all new objects created in 3ds
Max Design display in the viewports using the settings on the Display Color
rollout. A toggle for switching individual objects between By Object and By
Layer is available in the Object Properties dialog » Display Properties group
on page 225.

If the object color box displays black and white rectangles, this indicates that
the object has its display properties set to By Layer.

Interface

|- Dizplay Color |

"Wirefrarme: ® Object Calar
= Material Colar

Shaded: ¢ Object Calor
& M aterial Colar

Wireframe Controls the color of objects when the viewport is in wireframe
display mode.

B Object ColorDisplays the wireframes in object color.
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B Material ColorDisplays the wireframes using the material color.
Shaded Controls the color of the object when the viewport is in any shaded

display mode.
B Object ColorDisplays the shaded objects using the object color.

B Material ColorDisplays the shaded objects using the material color.

Hide By Category Rollout

(D]

The Hide By Category rollout toggles the display of objects by category (objects,
cameras, lights, and so on).

Display panel » Hide By Category rollout

By default, 3ds Max Design displays all objects in the scene. Objects hidden
by category aren’t evaluated in the scene, so hiding objects by category
improves performance.

You can use any of the default display filters provided, or add new display
filters for fast selection of objects to hide.
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Interface

[= HidebyCategoy |
[ Geometmy Al

[~ Shapes MHone
™ Lights T

[ Cameras

[~ Helpers

[7 Space'warps
[ Particle Systems
[ Bone Objects

Baone _ . Add
gﬁuﬁ};am Ohject Frerove
MHoare

Turn on the check boxes to hide objects of that category. You can use the All,
None, and Invert buttons to quickly change the settings of the check boxes.

The Display Filter box gives you finer control in creating categories to hide.
Click the Add button to display a list of display filters. Hold down the Ctrl key
and click the filter name to select whatever category you'd like to hide.

Geometry Hides all geometry in the scene.

Shapes Hides all shapes in the scene.

Lights Hides all lights in the scene.

Cameras Hides all cameras in the scene.

Helpers Hides all helpers in the scene.

Space Warps Hides all space warps in the scene.
Particle Systems Hides all particle systems in the scene.
Bone Objects Hides all bones in the scene.

Bones Hides all bones in the scene.
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IK Chain Hides all IK chains in the scene.
Point Hides all points in the scene.

All Hides everything in the scene.

None Unhides everything in the scene

Invert Hides everything that is visible and unhides everything currently
hidden.

Add Adds a display filter category to the list.
Remove Removes a display filter category.

None Deselects all highlighted display filters in the list.

Hide Rollout

Display panel » Hide rollout

The Hide rollout provides controls that let you hide and unhide individual
objects by selecting them, regardless of their category.

You can also hide and unhide objects using the Display Floater on page 8844.

See also:

m Hide By Category Rollout on page 138
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Interface

| - Hide |
Hide Selected

|
Hide Unzelected |
Hide by MHame... |
Hide by Hit |

Unhide Al |
Unhide by Mame. .. |

™ Hide Frozen Objects

Hide Selected Hides the selected objects.

Hide Unselected Hides all visible objects except the selected ones. Use this
to hide all objects except the one you're working on. Objects hidden by
category aren't affected.

Hide by Name Displays a dialog you use to hide objects you choose from a
list. SeeSelect From Scene on page 184, which describes nearly identical controls.

Hide by Hit Hides any object you click in the viewport. If you hold the Ctrl
key while selecting an object, that object and all of its children are hidden.
To exit Hide by Hit mode, right-click, press Esc, or select a different function.
This mode is automatically turned off if you hide all objects in the scene.

Unhide All Unhides all hidden objects. The unhide buttons are available only
when you have specifically hidden one or more objects. They won't unhide
objects hidden by category.

NOTE If you click Unhide All in a scene with hidden layers, a dialog will pop up
prompting you to unhide all layers. You cannot unhide an object on a hidden
layer.

Unhide by Name Displays a dialog you use to unhide objects you choose
from a list. See Select From Scene on page 184, which describes nearly identical
controls.

NOTE If you select an object on a hidden layer, a dialog will pop up prompting
you to unhide the object's layer. You cannot unhide an object on a hidden layer.

Hide Rollout | 141



Hide Frozen Objects Hides any frozen objects. Turn it off to display hidden
frozen objects.

Freeze Rollout

(D]

Display panel » Freeze rollout

The Freeze rollout provides controls that let you freeze or unfreeze on page
9215 individual objects by selecting them, regardless of their category.

Frozen objects remain on the screen, but you can't select, transform, or modify
them. By default, frozen objects turn dark gray. Frozen lights and cameras,
and their associated viewports, continue to work as they normally do.

You can choose to have frozen objects retain their usual color or texture in
viewports. Use the Show Frozen In Gray toggle in the Object Properties dialog
on page 221.

Interface

| - Freeze |

Freeze Selected

Freeze Unzelected

Freeze by Mame. ..

Freeze by Hit

Urfreeze All |

Unfreeze by Mame. . |

Infreeze by Hit |

Freeze Selected Freezes the selected object(s).

Freeze Unselected Freezes all visible objects except the selected ones. Use this
to quickly freeze all the objects except the one you're working on.

Freeze by Name Displays a dialog that lets you choose objects to freeze from
a list. See Select From Scene on page 184, which describes nearly identical
controls.
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Freeze by Hit Freezes any object you click in a viewport. If you press Ctrl while
selecting an object, that object and all of its children are frozen. To exit Freeze
by Hit mode, right-click, press Esc, or select a different function. This mode
is automatically turned off if you freeze all objects in the scene.

Unfreeze All Unfreezes all frozen objects.

NOTE If you click Unfreeze All in a scene with frozen layers, a dialog opens
prompting you to unfreeze all layers. You cannot unfreeze an object on a frozen
layer.

Unfreeze by Name Displays a dialog that lets you choose objects to unfreeze
from a list. See Select From Scene on page 184, which describes nearly identical
controls.

NOTE If you unfreeze by name an object on a frozen layer, a dialog opens
prompting you to unfreeze the object's layer. You cannot unfreeze an object on
a frozen layer.

Unfreeze by Hit Unfreezes any object you click in the viewport. If you press
Ctrl while selecting an object, that object and all of its children are unfrozen.

If you select an object on a frozen layer, a dialog will pop up prompting you
to unfreeze the object's layer. You cannot unfreeze an object on a frozen layer.

Display Properties Rollout

Display panel » Display Properties rollout

The Display Properties rollout provides controls for altering the display of
selected objects.

See also:

B Link Display Rollout on page 148

Procedures

To display trajectories using the Display panel:
1 Select one or more animated objects.

2 Right-click the selection, and choose Properties.
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3 In the Display properties group, click By Layer to change it to By Object,
and then click OK.

4 Expand the Display Properties rollout in the Display panel.

5 Turn on Trajectory.
By default, object trajectories appear with the following properties:

B The trajectory curve is drawn in red.
B Frame increments display as white dots on the curve.

B DPosition keys display as red boxes surrounding the appropriate frame
dot on the curve. The boxes are white when the object is selected.

B If Views » Show Key Times is turned on, the keyframe numbers are
displayed along side the keys on the trajectory.
Trajectories can also be displayed through Object Properties. Right-click
any object and choose Properties, then in the Display properties group
change By Layer to By Object. Turn on Trajectories when it becomes
available in the Display Properties group.

You can change the colors for these items on the Colors panel on page
8900 of the Customize User Interface dialog.

You can also use object properties to display trajectories: right-click any object
and choose Properties, then turn on Trajectory.

Interface

|- Dizplay Properties
[ Dizplay as Box
[ Backface Cul
v Edges Only
[ Wertex Ticks
[ Trajectory
™ See-Through
™ lgnore Extents

¥ Show Frozen in Gray
™ Mever Degrade

[~ Werter Colors Shaded
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The first three options reduce the displayed geometric complexity of selected
objects in a scene, resulting in faster response time because the computer has
less to calculate. These options are also available in the Display Properties
group of the Object Properties dialog » General panel on page 221 and the
Display floater on page 8844.

Display as Box Toggles the display of selected objects, including 3D objects
and 2D shapes, as bounding boxes on page 9157. Produces minimum geometric
complexity.

Particle systems appear as bounding boxes when adaptive degradation takes
effect. Because particle systems exist in world space, their bounding box is
always oriented parallel to the world planes.
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Backface Cull Toggles the display of faces, edges, and vertices with normals
on page 9281 pointing away from the point of view. When off, all entities are
visible. Default=off.

Edges Only Toggles the display of hidden edges and polygon diagonals on
page 9180. When on, only outside edges appear. When off, all mesh geometry
appears. Applies to Wireframe viewport display mode, as well as other modes
with Edged Faces turned on.
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Vertex Ticks Displays the vertices in the selected geometry as tick marks.

If the current selection has no displayed tick marks, the check box is clear. If
some of the vertices in the current selection display tick marks, the check box
contains a gray X. If all vertices in the current selection display tick marks,
the check box contains a black X.

Trajectory Toggles trajectory on page 9376 display for the selected object so its
trajectory is visible in viewports.
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See-Through Makes the object or selection translucent in viewports. This
setting has no effect on rendering: it simply lets you see what’s behind or
inside an object in a crowded scene, and is especially useful in adjusting the
position of objects behind or inside the See-Through object. This is very handy
when you have objects within other objects in your scene.

This option is also available from Object Properties dialog on page 221 and the
Tools » Display Floater on page 8844.

You can customize the color of see-through objects by using the Colors panel
on page 8900 of the Customize » Customize User Interface dialog on page 8877.

Keyboard shortcut (default): Alt+X

Ignore Extents When turned on, the object is ignored when you use the
display control Zoom Extents. Use this on distant lights.

Show Frozen in Gray When on, the object turns gray in viewports when you
freeze it. When off, viewports display the object with its usual color or texture
even when it is frozen. Default=on.

Never Degrade When on, the object is not subject to adaptive degradation
on page 9128.

Vertex Colors Displays the effect of assigned vertex colors. You assign vertex
colors using the Assign Vertex Color utility, or the VertexPaint modifier. Once
vertex colors have been assigned they can also be edited in the Vertex
Properties rollout in the editable mesh or editable poly in vertex or face
sub-object level.

The Shaded button determines whether the object with the assigned vertex
colors appears shaded in the viewport. When this button is off, the colors are
unshaded and appear in their pure RGB values, looking a little like
self-illuminated materials. When the Shaded button is on, the colors appear
like any other assigned color in the viewports.
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Link Display Rollout

Display panel » Link Display rollout

The Link Display rollout provides controls that alter the display of hierarchical
linkages on page 9227.

Interface

[ - Link. Dizplay |

™ Display Links
[ Lirk Replaces Object

Display Links Displays a wireframe representation of any hierarchical links
affecting the selected object.

NOTE Display Links must be turned on in order to see Joint Limits on a inverse
kinematics chain.

Link Replaces Object Replaces the selected object with the wireframe
representation of the hierarchical link. This option offers another way to
reduce the geometric complexity of selected objects in a scene. See also Display
Properties rollout on page 143.

The Draw Links As Lines option on the Viewports panel on page 8937 of the
Preference Settings dialog further reduces the display of links to a single line.
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Selecting Objects

In most cases, before you can perform an action on an object or objects in your scene, you
must first select them. Thus, the act of selection is an essential part of the modeling and
animation process.

A battlefield scene

Below: Different selections in a wireframe viewport
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3ds Max Design provides you with a variety of selection tools, which are covered in this
chapter. Besides the basic techniques of selecting single and multiple objects using mouse
and keyboard, the topics here discuss the use of named selection sets and other features
that help you manage object selection, such as hiding and freezing objects and layers. Also
included is an introduction to sub-object selection, essential to working with an object’s
underlying geometry.

Lastly, a technique for grouping objects is presented. Grouping lets you create more
permanent selections that have many of the characteristics of independent objects.

Introducing Object Selection

3ds Max Design is an object-oriented program. This means that each object
in the 3D scene carries instructions that tell 3ds Max Design what you can do
with it. These instructions vary with the type of object. Because each object
can respond to a different set of commands, you apply commands by first
selecting the object and then selecting the command. This is known as a
noun-verb interface, because you first select the object (the noun) and then
select the command (the verb).

Identifying the Selection Interface

In the user interface, selection commands or functions appear in the following
areas:

B Main toolbar

B Edit menu

B Quad menu (while objects are selected)
m Tools menu

B Track View

m Display panel

B Modify panel

B Modeling ribbon

B Schematic View

|

Scene Explorer
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The buttons on the main toolbar provide a direct means of selection. The
Select From Scene dialog on page 184 is easy to use, while the Edit menu
provides more general selection commands, plus methods of selecting objects
by property. Perhaps the most powerful selection tool is Scene Explorer on
page 8506, which lets you select objects by various methods, and also edit object
hierarchies and properties. Track View and Schematic View let you select
objects from a hierarchical list.

Selecting From the Quad Menu

The quickest way to select an object is from the Transform quadrant of the
quad menu, where you can easily switch among the Move, Rotate, Scale, and
Select modes. Choose any of these and click the object you want to select in
the viewport.

Selecting by Name

Another quick way to select an object is to use the keyboard shortcut for the
Select By Name command. Press H on the keyboard to open the Select From
Scene dialog on page 184 and then select the object by name from the list. This
is a foolproof way to ensure you select the correct object when the scene
contains many overlapping objects.

Selection Buttons

Another way to select an object is to click one of these buttons, and then click
the object.

2=l

Select Object

H

Select by Name

+
o+
+

+

Select And Move

Select And Rotate

& C

- Select And Scale
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The main toolbar has several selection-mode buttons. When any of the
selection buttons is active, 3ds Max Design is in a state where you can select
objects by clicking them.

Select And Manipulate

Of the selection buttons, you use Select Object when you want selection only.
The remaining buttons let you both select and transform or manipulate your
selection. Use transforms to move, rotate, and scale your selection. See Moving,
Rotating, and Scaling Objects on page 821 and Select and Manipulate on page
2871.

Crossing Versus Window Selection

| O
""" One way to select multiple objects simultaneously is to drag a region,
such as a rectangle, around them. The main toolbar » Window/Crossing
toggle switches between Window and Crossing modes when you select by
region. In Window mode, you select only the objects within the selection. In
Crossing mode, you select all objects within the region, plus any objects

crossing the boundaries of the region.

152 | Chapter 4 Selecting Objects



Above: Window selection selects the trash can and bench, but not the streetlight.

Below: Crossing selection selects all three: trash can, bench, and streetlight.
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Edit Menu Commands

The Edit menu contains selection commands that operate globally on your
objects.

Edit menu selection commands include:

Select All on page 214

Select None on page 214

Select Invert on page 215

Select Similar on page 215

Select By > Color on page 216

Select By > Name on page 216 (also a toolbar button)

Select By > Layer on page 216

Selection Region > Rectangular Region on page 192

Selection Region > Circular Region on page 193

Selection Region > Fence Region on page 194

Selection Region > Lasso Region on page 195

Selection Region > Paint Selection Region on page 195
Selection Region > Window on page 199 (also a toolbar button)
Selection Region > Crossing on page 197 (also a toolbar button)

Edit Named Selection Sets on page 206

Tools Menu Commands

The Tools menu provides the Scene Explorer commands as well as access to
modeless on page 9268 selection dialogs or "floaters." You can place them
anywhere on the screen, or minimize them by right-clicking the title bar and
choosing Minimize:

B New Scene Explorer (and related commands)See Scene Explorer on page
155.

m Display FloaterProvides options for hiding and freezing selections as well
as some display options. See Display Floater on page 8844.

B Layer ManagerThis modeless dialog lets you select objects individually and
by layer, and change display properties such as Hide and Freeze. See Manage
Layers Dialog on page 8574.
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Scene Explorer

Scene Explorer on page 8506 gives you a modeless dialog for selecting and linking
objects as well as changing object properties such as the name and display
characteristics. You can manipulate hierarchical relationships via drag-and-drop
techniques, and use various search methods including a powerful Boolean
editor to fine-tune your selection. You can also edit properties for multiple
objects at once simply by selecting them and then changing one of them.

Track/Schematic View Selection

Track View on page 3831 is primarily designed as an animation tool, but you
can also use its Hierarchy List window as an alternative method of selecting
objects by name and hierarchy. This works in both the Curve Editor and Dope
Sheet modes of Track View.

Schematic View on page 8540 is specifically designed to let you navigate your
scene efficiently, presenting a hierarchical view and letting you select objects
and their properties by name.

Display Panel Selection

—

1+ Display Color |
[| + Hide by Categary |]
T+ Hide |
1+ Freeze |
[| + Display Properties |]
i+ Link Display [i

The Display panel provides options for hiding and freezing objects. These
techniques exclude objects from other selection methods, and are useful in
simplifying complex scenes. Frozen objects are still visible, but hidden objects
are not.

Basics of Selecting Objects

The most basic selection techniques use either the mouse, or the mouse in
conjunction with a keystroke.
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Bed selected in wireframe

Bed selected in smooth and shaded view
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Procedures

To select an object in the viewport:

1 Click one of the selection buttons on the toolbar: (Select Object),
+
O -
(Select And Move), (Select And Rotate), * (Select
And Scale), or (Select And Manipulate).

Alternatively, right-click in a viewport to open the quad menu, and from
the Transform menu choose Move, Rotate, Scale, or Select.

2 In any viewport, move the cursor over the object you want to select.

The cursor changes to a small cross when it’s positioned over an object
that can be selected.

The valid selection zones of an object depend on the type of object and
the display mode in the viewport. In shaded mode, any visible surface
of an object is valid. In wireframe mode, any edge or segment of an object
is valid, including hidden lines.

3 While the cursor displays the selection cross, click to select the object
(and to deselect any previously selected object).

A selected wireframe object turns white. A selected shaded object displays
white brackets at the corners of its bounding box.

NOTE When you use the mouse to select overlapping objects or sub-objects, the
first click selects the object under the mouse curosr closest to your point of view;
the second click selects the next-closest object, and so on. If you move the mouse
more than five pixels at any point in the sequence, the next click begins again
with the closest object. And with the farthest object selected, clicking selects the
closest object again.

To select all objects do one of the following:

B Choose Edit menu » Select All.
This selects all objects in your scene.

B On the keyboard press Ctrl+A.
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To invert the current selection do one of the following:

B Choose Edit menu » Select Invert.
This reverses the current selection pattern. For example, assume you begin
with five objects in your scene, and two of them are selected. After choosing
Invert, the two are deselected, and the remaining objects are selected.

B On the keyboard press Ctrl+l.

@ To extend a selection:

B Hold down Ctrl while you click to make selections.
This adds the objects you click to the current selection. For example, if
you have two objects selected and Ctrl+click to select a third, the third
object is added to the selection.

Holding down Ctrl also works with Selecting by Region on page 159.

NOTE @:‘ In versions of 3ds Max Design prior to Autodesk 3ds Max
Design 2011, holding down the Ctrl toggled an object’s selection state. That
is no longer the case. To add an object to a selection, use Ctrl. To remove an
object from a selection, use Alt.

I:E:I To reduce a selection:

B Hold down Alt while you click objects.
This removes the objects you click from the current selection. For example,
if you have three objects selected and Alt+click one of them, the third
object is removed from the selection.

Holding down Alt also works with Selecting by Region on page 159.

To lock a selection:

1 Select an object.

2 Click (Selection Lock Toggle on page 8706) on the status bar to turn

on locked selection mode.

While your selection is locked, you can drag the mouse anywhere on the
screen without losing the selection. The cursor displays the current
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selection icon. When you want to deselect or alter your selection, click
the Lock button again to turn off locked selection mode. The keyboard
toggle for locked selection mode is Spacebar.

To deselect an object, do one of the following:

B Hold down the Alt key, and either click an object, or drag a region around
the object to deselect it.

B To deselect all objects in the scene, choose Edit menu » Select None, or
click an empty area of a viewport anywhere outside the current selection.

Selecting by Region
The region-selection tools let you use the mouse to select one or more objects
by defining an outline or area.
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Top Left: Selecting face sub-objects with a rectangular region

Top Right: Selecting vertex sub-objects with a circular region
Center: Selecting face sub-objects with a painted region
Bottom Left: Selecting edge sub-objects with a fence region

Bottom Right: Selecting edge sub-objects with a lasso region

Region Selection

By default, when you drag the mouse a rectangular region is created. When
you release the mouse all objects within and touched by the region are selected.
The remainder of this topic describes how you can change each of these
settings.

NOTE If you hold down Ctrl while specifying a region, the affected objects are
added to the current selection. Conversely, if you hold down Alt while specifying
a region, the affected objects are removed from the current selection.
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Setting Region Type

The type of region you define when you drag the mouse is set by the Region
flyout button to the right of the Select By Name button. You can use any of
five types of region selection:

B Rectangular RegionDragging the mouse selects a rectangular region. See
Rectangular Selection Region on page 192.

m Circular RegionDragging the mouse selects a circular region. See Circular
Selection Region on page 193.

B Fence RegionDraw an irregular selection-region outline by alternating
between moving the mouse and clicking (begin with a drag). See Fence
Selection Region on page 194.

B Lasso RegionDragging the mouse outlines an irregular selection region.
See Lasso Selection Region on page 195.

B Paint RegionDrag the mouse over objects or sub-objects to be included in
the selection. See Paint Selection Region on page 195

Setting Region Inclusion

This option lets you specify whether to include objects touched by the region
border. It applies to all region methods.

Choose Edit menu » Region to display a submenu of the following two
items. Only one can be active at a time. The Window/Crossing toggle on page
197 on the main toolbar also switches between these two modes.

B Crossing (The default.) Selects all objects that are within the region and
crossing the boundaries of the region. See Crossing Selection on page 197.

Selecting by Region | 161



B WindowSelects only objects that are completely within the region. See
Window Selection on page 199.

You can set up a preference to switch automatically between Window and
crossing based on the direction of your cursor movement. See Auto
Window/Crossing by Direction on page 8931 in General Preferences.

Procedure

To make a region selection using defaults:

1 Click (Select Object on page 183).

2 Drag the mouse to define a region.

A rubber-band rectangle appears.

3 Release the mouse button to select all objects within or touching the
region.
The selected objects turn white.

You can also use the Select And Transform buttons on the main toolbar to
select by region. You must start defining the region over an unselectable area
of the viewport. Otherwise, you'll transform the object beneath your mouse
when you begin to drag.

Using Select By Name

The Select By Name command opens the Select From Scene dialog, which lets
you select objects by their assigned names without having to click in the
viewports.

Procedures

To select objects by name:

1 Do one of the following:

s

B Choose Edit menu » Select By » Name.

B On the main toolbar, click (Select By Name).
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B Press H.
The Select From Scene dialog opens. By default, this dialog lists all
objects in the scene. Any selected objects are highlighted in the list.

2 Use the mouse to highlight one or more objects in the list. To select
multiple objects, drag vertically in the list or use Ctrl to add to the
selection.

3 Click OK to make the selection.
The dialog closes and the objects are selected.

4 Alternatively, to select a single object and close the dialog at the same
time, double-click the object name.

For more information, see Select From Scene on page 184.

Using Named Selection Sets

You can assign a name to the current selection, and then later reselect those
objects by choosing their selection name from a list.

b

barracks
fence
House
sentrybox
transport
Utilities

Named Selection Sets

{ ¥
ABL .
You can also edit the contents of named sets from the Named
Selection Sets dialog on page 206.

Editing Named Selections

As you model and create a scene, you're likely to rearrange the objects making
up your named selection sets. If you do, you'll need to edit the contents of
those sets.
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Procedures

To assign a name to a selection set:

1 Select one or more objects or sub-objects using any combination of
selection methods.

2 Click in the Named Selection field on the main toolbar.

3 Enter a name for your set. The name can contain any standard ASCII
characters, including letters, numerals, symbols, punctuation, and spaces.

NOTE Names are case-sensitive.

4 Press Enter to complete the selection set.

You can now select another combination of objects or sub-objects and repeat
the process to create another named selection set.

To retrieve a named selection set:

1 In the Named Selection field, click the arrow.

NOTE If you're working with a sub-object selection set, you must be at the
same level at which you created the selection set (for example, editable mesh
> vertex) for it to appear on the list.

2 On the list, click a name.

To edit named selection sets:

17
m “®°  Onthe main toolbar, click Edit Named Selection Sets to open the
Named Selection Sets dialog.

Using Selection Filters

You can use the Selection Filter list on the main toolbar to deactivate selection
for all but a specific category of object. By default, all categories can be selected,
but you can set the Selection Filter so that only one category, such as lights,

can be selected. You can also create combinations of filters to add to the list.
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all LY

All
Geometry
Shapes
Lights
Cameras
Helpers
Warps

Bone
1K, Chain Cbject
Point

For greater ease of use while working with animations, you can choose filters
that let you select only Bones, objects in IK chains, or Points.

Using Combos

The Combos feature allows you to combine two or more categories into a
single filter category.

Procedures

To use the selection filter:

B Click the Selection Filter arrow and click a category from the Selection

Filter list.
Selection is now limited to objects defined in this category. The category
remains in effect until you change it.

The following categories are available:
All
All categories can be selected. This is the default setting.

Geometry
Only geometric objects can be selected. This includes meshes, patches,
and other kinds of objects not specifically included in this list.

Shapes
Only shapes can be selected.

Lights
Only lights (and their targets) can be selected.
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Cameras
Only cameras (and their targets) can be selected.

Helpers
Only helper objects can be selected.

Warps
Only space warps can be selected.

Combos
Displays a Filter Combinations dialog on page 201 that lets you create
custom filters.

Bone
Only bones objects can be selected.

IK Chain
Only objects in IK chains can be selected.

Point
Only point objects can be selected.

To create a combination category:
1 From the drop-down list, choose Combos to display the Filter
Combinations dialog on page 201.
All single categories are listed.

2 Select the categories you want to combine.

3 Click Add.
The combination appears in a list to the right, abbreviated by the first
letter of each category. Click OK.

For example, if you selected Geometry, Lights, and Cameras, the Combo
would be named GLC. This name appears below Combo on the drop-down
list. For more information, see Selection Filters List on page 200.

Selecting with Track View

Track View provides sophisticated methods to edit your animation tracks. In
addition, its Hierarchy list displays all objects in the scene by name and
hierarchy. Using Track View, you can select any object in the scene by clicking
its object icon in the Hierarchy list.
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You can use Track View selection functionality in both the Curve Editor
Introduction on page 3845 and the Dope Sheet on page 3846. This procedure
illustrates usage of the Curve Editor; the same methods work in the Dope

Sheet.

To open Track View and display and select objects:

1 On the main toolbar, click Curve Editor (Open).

2 Click any cube icon in the list to select the named object.
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You can make the following kinds of selections:

B Select several adjacent objects in the list. Click the first object, hold down
Shift, and click another object elsewhere in the list.

B Modify the selection by pressing Ctrl while clicking. Ctrl lets you toggle
individual items on and off without deselecting others in the list.

B Select an object and all its descendants. Press and hold Alt, right-click the
object's cube icon (keep the right mouse button held down), and choose
Select Children from the menu.

You can open a Track View window for the sole purpose of selecting objects
by name. Shrink the window until only a portion of the Hierarchy appears,
and then move the window to a convenient area on your screen.

Selecting with Schematic View

Schematic view is a window that displays the objects in your scene in a
hierarchical view. It gives you an alternate way to select and choose the objects
in your scene and navigate to them.

When the Modify panel is open, double-clicking an object modifier in
Schematic view navigates the modifier stack to that modifier for quick access
to its parameters.

Procedures

To open Schematic View and display and select objects:

2 Click the rectangle containing the name of your object.

1 On the main toolbar, click (Open Schematic View).

You can select any number of objects in Schematic View using standard
methods, including dragging a region. For more information, see Using
Schematic View on page 8544.

Freezing and Unfreezing Objects

You can freeze any selection of objects in your scene. By default, frozen objects,
whether wireframe or rendered, turn a dark gray. They remain visible, but
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can’t be selected, and therefore can’t be directly transformed or modified.
Freezing lets you protect objects from accidental editing and speeds up redraws.

Above: No layers frozen

Below: Trash can and streetlight are frozen, and displayed in gray

You can choose to have frozen objects retain their usual color or texture in
viewports. Use the Object Properties dialog » General panel » Display
Properties » Show Frozen In Gray toggle on page 228.

Frozen objects are similar to hidden objects. Linked, instanced, and referenced
objects behave when frozen just as they would if unfrozen. Frozen lights and
cameras and any associated viewports continue to work as they normally do.

For more information, see Freeze Rollout on page 142.

Freezing Objects

You can freeze one or more selected objects. This is the usual method to put
objects "on hold."
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You can also freeze all objects that are not selected. This method lets you keep
only the selected object active, useful in a cluttered scene, for example, where
you want to be sure no other objects are affected.

IMPORTANT Obijects on a frozen layer cannot be unfrozen. If you try to unfreeze
an object on a frozen layer (with Unfreeze All or Unfreeze By Name), you are
prompted (by default on page 8932) to unfreeze the object's layer.

Procedures

To access Freeze options, select one or more objects and then do one of the
following:

B Open a scene explorer on page 8506 and use the check boxes in the Frozen
column to freeze and unfreeze objects.

B~ Open the Display panel and then expand the Freeze rollout.

B Choose Tools menu » Display Floater. This modeless dialog has the same
options as the Freeze rollout. It also contains Hide options.

B Access the Object Properties dialog on page 221 from either the right-click
(quad) menu or the Edit menu. Turn on Hide and/or Freeze.

B [n the Layer Manager, click in the Freeze column to freeze/unfreeze each
layer in the list.

B Right-click in the active viewport and choose a Freeze or Unfreeze command
from the quad menu » Display quadrant.

Hiding and Unhiding Objects by Selection

You can hide any selection of individual objects in your scene. They disappear
from view, making it easier to select remaining objects. Hiding objects also
speeds up redraws. You can then unhide all objects at once or by individual
object name. You can also filter the list contents by category, so only hidden
objects of a certain type are listed.

NOTE Hiding a light source doesn't alter its effect; it still illuminates the scene.
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Original scene

Scene with bed hidden

Hiding objects is similar to freezing objects. Linked, instanced, and referenced
objects behave when hidden just as they would if unhidden. Hidden lights
and cameras and any associated viewports continue to work normally.

For more information, see Hide Rollout on page 140.

Hiding Objects

Hiding objects is similar to freezing objects. See Freezing and Unfreezing
Objects on page 168. You can hide one or more selected objects. You can also
hide all objects that are not selected.

Another option is to hide objects by category. See Hiding and Unhiding Objects
by Category on page 173.
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Unhiding Objects

You can unhide objects in either of two ways:

Use Unhide All to unhide all objects at the same time.
Use All On to display all objects at the same time.

Use Unhide By Name to unhide object selectively. When you click Unhide
By Name, the same dialog is displayed as for hiding, now called Unhide
Obijects.

The Unhide buttons are unavailable when no object in the scene is hidden.

Objects that were first hidden by selection and then hidden by category do
not reappear. Although they are unhidden at the selection level, they are still
hidden at the category level. For details, see Hiding and Unhiding Objects by
Category on page 173.

IMPORTANT Obijects on a hidden layer cannot be unhidden. If you try to unhide
an object on a hidden layer (with Unhide All or Unhide By Name), you are
prompted (by default on page 8932) to unhide the object's layer.

Procedures

To access Hide options, do one of the following:

Open a scene explorer on page 8506 and use the check boxes in the Hidden
column to hide and unhide objects.

Open the Layer Manager on page 8574.
In the Layer Manager, you can easily hide groups of objects or layers.

— Open the Display panel. Click Hide, if necessary, to expand the
rollout.

Choose Tools menu » Display Floater. This modeless dialog has the same
options as the Hide rollout. It also contains Freeze options.

Access the Object Properties dialog on page 221 from either the right-click
(quad) menu or the Edit menu. Turn on Hide, Freeze, or both. If the button
is unavailable because By Layer is turned on, click By Layer to change it
to By Obiject.

Right-click in the active viewport and choose a Hide or Unhide command
from the quad menu » Display quadrant.
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Hiding and Unhiding Objects by Category
You can hide objects by category, the basic types of objects. For example, you
can hide all lights in your scene at one time, or all shapes, or any combination
of categories. By hiding all categories, your scene appears empty. Hidden
objects, while not displayed, continue to exist as part of the geometry of your
scene but cannot be selected.
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Above: All objects displayed
Below: Lights and shapes are hidden
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Hiding Geometry and Particle Systems

Geometry and particle systems have separate categories, even though particle
systems are also geometry.

Selecting Geometry hides all geometry in the scene, including particle
systems. The option for particle systems becomes unavailable.

Selecting Particle Systems hides only these objects, leaving the other
geometry unaffected.

Effects of Hiding by Category

If you create an object in a category that is hidden, 3ds Max Design turns
off hiding for that category and unhides the objects within the category.

Unhiding by category has no effect on objects hidden with the controls
on the Hide rollout (see Hiding and Unhiding Objects by Selection on page
170). These objects remain hidden. You need to use the controls on that
rollout to unhide them.

Unhiding by category has no effect on objects that are on a layer that is
turned off. These objects remain invisible. You need to turn on their layer
to display them.

Unhiding by selection does not return a hidden object to the scene if the
category of the object is hidden. The Unhide All and Unhide By Name
controls continue to work, but the effect is not seen until the category is
cleared.

Lights hidden by category continue to shine. Views through cameras and
targeted lights are still active.

Linked, instanced, and referenced objects behave when hidden just as they
would if visible.

Procedures

To hide a category of objects:

— Open the Display panel.

2 Click Hide by Category, if necessary, to expand the rollout. By default,

all categories are off (unhidden) on this rollout.
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3 Choose the category you want to hide. All objects of that category
disappear from your scene as soon as you make the choice.

The same Hide By Category options appear on the Object Level panel of the
Display Floater (Tools menu » Display Floater).

To unhide a category of objects:

B Deselect the category.
All objects in the category reappear, unless some have been hidden by
selection. See Effects of Hiding by Category on page 175.

Isolate Selection

Tools menu » Isolate Selection

Right-click to open the quad menu. » Display (upper-right) quadrant »
Isolate Selection

Keyboard » Alt+Q

The Isolate Selection tool lets you edit a single object or selection set of objects
while hiding the rest of the scene on a temporary basis. This guards against
selecting other objects while working on a single selection. It allows you to
focus on the objects you need to see, without the visual distraction of the
surroundings. It also reduces the performance overhead that can come from
displaying other objects in the viewports.

When you turn on Isolate Selection, the active viewport (Perspective and
axonometric on page 9144 only) performs the Zoom Extents on page 8765 action
on the isolated objects. When you exit Isolate Selection mode, Perspective
viewports return to the previous zoom level, but axonometric viewports do
not.

When an isolated selection includes multiple objects, you can select a subset
of these, and choose Isolate Selection once again. This isolates the subset.
However, clicking Exit Isolation unhides the entire scene. You can’t “step
back” through individual levels of isolation.

NOTE Isolate Selection works only at the object level. You can’t choose it while
at the sub-object level. If you go to a sub-object level while working with an isolated
object, you can click Exit Isolation, but you can’t isolate sub-objects.
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Interface

While the Isolate tool is active, a dialog labeled Warning: Isolated Selection
appears.

Warning: Isolated 5 |

‘ Exit |zalation Made

Exit Isolation Mode Click to end isolation, close the dialog, and unhide the
rest of the scene.

The views are restored to what they showed before you chose Isolate Selection.

Introduction to Sub-Object Selection

This is a general introduction to sub-object selection. For specific information,
see Editable Mesh on page 2192, Editable Patch on page 2376, Editable Poly on
page 2242, and Editable Spline on page 554; for a discussion of NURBS sub-object
selection, see Sub-Obiject Selection on page 2447.

When you model an object, often you edit a portion of its underlying
geometry, such as a set of its faces or vertices. Or when you are working with
a model, you may want to apply mapping coordinates to a portion of its
underlying geometry. Use the methods described in this topic to make
sub-object selections.
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Left: A selection of face sub-objects
Middle: A selection of edge sub-objects

Right: A selection of vertex sub-objects

You can access sub-object geometry through a variety of methods. The most
common technique is to convert an object into "editable" geometry such as
amesh, spline, patch, NURBS, or poly object. These object types let you select
and edit geometry at the sub-object level.

If you have a primitive object and want to retain control of its creation
parameters, you can apply a modifier such as Edit Mesh on page 1265, Edit Poly
on page 1276, Edit Spline on page 1370, Edit Patch on page 1273, or Mesh Select on
page 1447.

The Line Spline on page 518 and NURBS curves and surfaces are the exception:
you can edit their sub-objects as soon as you create these kinds of objects.

You choose a sub-object level in the stack display. Click the plus sign that
appears next to the name of an object that has sub-objects. This expands the
hierarchy, showing the available sub-object levels. Click a level to choose it.
The name of the sub-object level highlights in yellow, and the icon for that
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sub-object level appears to the right of both its name and the name of the
top-level object.

ISpherED 1 .

IMDdiﬁer List -

Bl Editable Poly <7

&

é ........ Edge

E -------- Border
E -------- Folygaon
b Element

Stack display shows the sub-object
hierarchy, letting you choose a sub-object
level.

Editing at the Sub-Object Level

When you edit an object at the sub-object level, you can select only
components at that level: vertices, edges, polygons, and so on. You can’t
deselect the current object, nor can you select other objects. To leave sub-object
editing and return to object-level editing, click the top-level name of the object
in the modifier stack, or click the highlighted sub-object level.

Introduction to Sub-Object Selection | 179



ISpherED 1 .

Modifier List |v

........ EdgE
........ Border
........ PDI}'QDI’I
b Element

Click the top-level object name to exit

sub-object editing.

TIP You can also access sub-object levels from the buttons at the top of the
Selection rollout on the Modify panel.

Procedures

To make a sub-object selection:

These methods assume the object has sub-object levels. If the object has no
sub-object levels (for example, a primitive such as a sphere), the + icon is not
present. In that case, you need to collapse the object or apply an Edit modifier
before you can edit its sub-object geometry.

TIP When working with an editable poly or Edit Poly object, we highly recommend
that you use the Graphite Modeling tools on page 1980 instead of the Modify panel.

1
2
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Select the object you want to edit.

If the object doesn't already have sub-object levels, apply an Edit ...
modifier such as Edit Mesh.

Open the E Modify panel.

In the modifier stack, click (the + icon) to expand the object's
hierarchy.

On the stack display, click a sub-object level such as Vertex, Edge, or Face.

Selecting Objects



TIP For a detailed selection, you might want to zoom in on the object.

6 Click one of the toolbar selection buttons, and then use the same selection
methods you’d use on objects to select the sub-object components. Or
from the quad menu » Transform quadrant, choose one of the selection
methods and select the sub-object components.

There are two alternative ways to go to a sub-object level:

] I[E Select the object and go to the Modify panel. Then right-click the
object, and use the quad menu » Tools 1 (upper-left) quadrant »
Sub-objects submenu.

| I[E Choose the selection level using buttons on the Modify panel's
Selection rollout, if one is present for the type of object you're editing.

TIP Once you're at a sub-object level, the Insert key cycles through the levels of
other kinds of sub-objects.

To exit a sub-object level, do one of the following:

B In the stack display, click the highlighted sub-object name or the top-level
name of the object.

W [f the object has a Selection rollout, click the button of the active sub-object
level to turn it off.

B Right-click the object, and then in the Tools 1 (upper-left) quadrant of the
quad menu, choose Top-level.

B Access a different command panel. This turns off sub-object editing.

If you think you've turned off sub-object editing but top-level object selection
is still not restored, it might be due to the following reasons:

| | Your selection is locked. Click the Lock Selection Set button on

the prompt line to turn it off.
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B You've set the Selection Filter on page 164 on the main toolbar to a specific
category of object, so you can't select any of the other categories. To fix
this, select All in the Selection Filter list.

Selection Commands

Selection commands appear on the quad menu, on the main toolbar, on the
Edit menu, and on the status bar.

Main toolbar By default, important selection commands appear on the main
toolbar.

Edit menu The Edit menu contains selection commands that operate globally
on your objects.

Status bar The Selection Lock Toggle on page 8706 is located on the status bar.
Locking a selection is useful when you are doing a lot of editing on a selection,
and don't want to select something else by mistake.

The simplest method of selection is to turn on Select Object mode on page
183, and then click an object in a viewport (or drag to surround the object).
While the method is simple, it is not effective for selecting multiple objects,
especially in a crowded scene. Other tools let you select objects by name, filter
out the kinds of objects you want to select, and to create named selection sets
you can select repeatedly.

See also:

B Transform Commands on page 850

B Select And Manipulate on page 2871

B Introducing Object Selection on page 150
B Basics of Selecting Objects on page 155

B [solate Selection on page 176

B Scene Explorer on page 8506
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Select Object Lk

C

Right-click to open quad menu. » Transform quadrant » Select

Main toolbar » (Select Object)

Select Object lets you select an objects and sub-objects for manipulation.

Object selection is affected by several other controls:

B The active Selection Region type: Rectangular on page 192, Circular on page
193, Fence on page 194, Lasso on page 195, or Paint on page 193.

B The active selection filter on page 200 (All, Geometry, Shapes, Lights, and
so forth).

B The state of the crossing selection tool (which determines whether
completely surrounded objects or surrounded and crossing objects are
selected).

You can also select objects by name with the Select From Scene dialogSelect
From Scene on page 184 list; press the H key to access the dialog.

A number of objects selected together is called a selection set on page 163. You
can name selection sets in the Named Selection Sets field on the main toolbar
and then recall them for later use.

NOTE The Smart Select command activates the Select Object function and, with
repeated invocations, cycles through the available Selection Region methods. By
default, Smart Select is assigned to the Q key; you can use Customize User Interface
on page 8877 to assign it to a different keyboard shortcut, a menu, etc.

Procedures

NOTE @ In versions of 3ds Max Design prior to Autodesk 3ds Max Design
2011, holding down the Ctrl toggled an object’s selection state. That is no longer
the case. To add an object to a selection, use Ctrl. To remove an object from a
selection, use Alt.
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@ To add objects to a selection set:

» Hold down the Ctrl key and select the objects to add.

NOTE Adding objects doesn't change a named selection set.

I:E:I To remove individual objects from a selection set:

» Hold down the Alt key and select the objects to remove.

NOTE Removing objects doesn't change a named selection set.

To select objects and move, rotate, or scale them:

s O
O D
| + » Use Select And Move, Select And Rotate, or Select

And Scale, available from the main toolbar and the quad menu »
Transform quadrant.

When you rotate a selection set, the pivot of rotation depends on which
option is selected on the Use Center flyout on page 867 on the toolbar.

These tools are restricted to a specific axis or plane, which you can choose
from the Axis Constraints toolbar on page 8666 or specify with the transform
gizmo on page 825.

Select From Scene by

b

Main toolbar » (Select By Name)
Keyboard » H
Edit menu » Select By » Name

This dialog, named Select From Scene or Select Objects in most contexts, lets
you select or designate objects by choosing them from a list of all objects
currently in the scene. Select From Scene is a modal on page 9268, read-only
version of Scene Explorer on page 8506; you can’t use it to change object
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properties such as name and color. Other differences between Select From
Scene and Scene Explorer include:

B No hierarchy manipulation; you can’t link or unlink objects.
Hidden and frozen objects don’t appear in the list.
Because the dialog is modal, you must close it before continuing.

To select an object and close the dialog, double-click the object’s list entry.

All toggle settings such as Select Dependents, Display » Children, and
the Display buttons persist. That means they survive Reset operations and
even quitting and restarting 3ds Max Design. This also applies to the
position and size of the dialog. To return all dialog settings to their defaults,
delete this file: [program folder]\plugcfg\DefaultModalSceneExplorer.ini.

Select From Scene g@

Select  Display  Customize
O&|9 f&eERie>GE G BOBE W
Find: Selection Set: @ I:[§ E[!} %’
Name 4 I
O Back_drop
g@ Camerall
ga Cameral2
g@ Cameral2.Target
{?_‘!] Light_horizontal
{F{j] Light_large-overhead
{?_‘!] Light_vertical
O Object_stand
-7 studio_building

O StlJljilj_ﬂI:ujI'-
)| Text01

oK Cancel
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NOTE The Select From Scene dialog name and functionality are context dependent.
When a transform such as Select And Move is active, the dialog lets you choose
from all objects in the scene. But when certain modes are active, the choices in
the dialog are more limited. For example, when Select and Link on page 3670 is
active, the dialog is entitled Select Parent, and shows linkable objects but not the
child object already selected. Similarly, if Group » Attach is active, the dialog is
named Attach To Group and lists groups but not solitary objects.

TIP If you prefer to use the legacy Select Objects dialog instead of Select From
Scene, it's available as an option. Open the CurrentDefaults.ini file (see
Market-Specific Defaults on page 8874), find the [Scene Explorer] section, and change
SelectByNameUsesSceneExplorer setting. If set to 1, then Select By Name and
related commands use the Select From Scene dialog. If set to 0, thenSelect By
Name and related commands use the legacy Select Objects dialog. The latter’s
functionality is essentially the same as the Selection Floater on page 187, except
that it’s modal, not modeless.

See also:

B Selection Floater on page 187

Procedures

To select objects by name:

1 Do one of the following:

s

B Choose Edit menu » Select By » Name.

B On the main toolbar, click (Select By Name).

W Press H.
The Select From Scene dialog opens. By default, it lists all objects in
the scene, displaying any hierarchies as collapsible branches. Currently
selected objects are highlighted in the list.

2 Choose one or more objects in the list by doing one of the following:

B To select a single object and close the dialog, double-click the object
name.

B Drag, or click and then Shift+click to select a contiguous range of
objects and Ctrl+click to select noncontiguous objects.
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B In the field above the list, type a search phrase. As you type, all
matches for the current phrase are highlighted in the list. To highlight
only objects whose case matches the search phrase exactly, turn on
Find Case Sensitive (from the Select menu) .

NOTE In some cases, such as when linking objects, you can select only one
object.

3 Click Select.
The selection is made as the dialog closes.

To highlight a single item from among multiple highlighted items:

Clicking one list item among several highlighted items does not unhlighlight
the rest. When several items are highlighted, but you want to highlight only
one of them, do either of the following:

B If any items are not highlighted, click one of them to remove highlighting
from the rest, and then highlight the one you want.

E} If all items are highlighted, the preceding method isn’t practical.
In that case, on the upper toolbar click Select None, and then highlight
the one you want.

Selection Floater

[Available only as a CUI action]

This modeless dialog lets you select objects in the scene. You can keep the
dialog open while you work in your scene, making it easier to select objects.

IMPORTANT The Selection Floater command is available only as a Customize
User Interface on page 8877 action; to use it you must first add it explicitly to the
user interface.

See also:

B Scene Explorer on page 8506
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[select objects field] Enter a name to highlight objects in the list whose names

begin with the text you specify.

Find Case Sensitive When on, the select objects field above the list is
case-sensitive. For example, if the list contains objects named apple and Apple
and Find Case Sensitive is on, typing “a” will highlight only the apple entry.
Also, sorts the list so uppercase names come before lowercase.

[objects list] Lists objects according to the current Sort and List Types choices.
Does not display hidden and frozen objects.
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To highlight an object name in the list, click with the mouse. To highlight
multiple object names, drag, or click and then Ctrl+click or Shift+click, or use
the search field above the list. To select highlighted objects, click the Select
button.

Alternatively, you can highlight and select a single object in the list by
double-clicking its name.

After selecting objects, the dialog remains open until you close it explicitly.

All/None/Invert These buttons alter the pattern of selection in the list
window.

Influences When you highlight an object in the list window and then click
the Influences button, the selected object's influences on page 9237 are
highlighted as well.

Display Subtree Displays each item in the list so that its hierarchical branch
on page 9227 is included (for example, Thigh/Shin/Foot). Hierarchical branches
are indented.

Display Influences When this is on and you select an item in the list window,
all of its influences are shown in blue. If you want to highlight these influences,
click Influences.

Select Subtree When this is on and you select an item in the list window, all
of its hierarchical children are selected as well.

Select Dependents When this is on and you select an item in the list window,
all of its dependent on page 9178 objects are selected as well. Dependents include
instances, references, and objects sharing a common modifier (the same objects
that appear green when Show Dependencies is on in the View menu).

When both Select Subtree and Select Dependents are on, the subtree of any
newly selected node is first selected, and then the dependents are selected. In
other words, dependents of the subtree are selected, but not the subtrees of
all dependents.

Sort group

Lets you choose the sort order of the items displayed in the list. This option
is unavailable when Display Subtree is on; in that case, sorting is always
alphabetical.

Alphabetical Sorts from numeric characters at the top, then A to Z at the
bottom. When Find Case Sensitive is on, all upper-case names come before
lower-case names.
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By Type Sorts by category, using the same order as the check boxes in the List
Types group.

By Color Sorts by object wireframe color. The sorting order is arbitrary; the
value of this option is that objects of the same color are grouped together.

By Size Sorts based on the number of faces in each object. The object with
the least number of faces is listed first, followed by objects with successively
greater number of faces.

List Types group

Determines the types of objects to display in the list.

All/None/Invert These buttons alter the pattern of activation of the List Types
options.

Selection Sets group

Lists any named selection sets on page 204 that you have defined in the scene.
When you choose a selection set from the drop-down list, 3ds Max Design
highlights its component objects in the main list.

Selection Region Flyout

Main toolbar » Selection Region flyout
Edit menu » Selection Region

The Selection Region flyout gives you five different ways to select objects
within a particular area or volume. Clicking and holding on the Selection
Region button opens a flyout containing the Rectangle on page 192, Circular
on page 193, Fence on page 194, Lasso on page 195, and Paint on page 195
Selection Region buttons, from top to bottom.
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Selection
Region
flyout

For the first four methods, you can select either objects that are completely
within the selection region (window method), or objects that are within or
touched by the selection shape (crossing method). Toggle between the window
and crossing selection methods by using the Window/Crossing toggle on page
197 on the main toolbar.

NOTE If you hold down Ctrl while specifying a region, the affected objects are
added to the current selection. Conversely, if you hold down Alt while specifying
a region, the affected objects are removed from the current selection.

NOTE The Smart Select command activates the Select Object on page 183 function
and, with repeated invocations, cycles through the available Selection Region
methods. By default, Smart Select is assigned to the Q key; you can use Customize
User Interface on page 8877 to assign it to a different keyboard shortcut, a menu,
etc.

Procedures

To select using a region (general method):
1 Choose a Selection Region method from the flyout.

2 Drag in a viewport, then release the mouse. The first location you click
is one corner of the rectangle, and where you release the mouse is the
opposite corner.
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IMPORTANT If you're using Select Object on page 183, you can start dragging
anywhere to select a region: on an object or off. However, if you're using one
of the transform tools, such as Select and Move on page 851, start the drag
operation away from an object; that is, in an empty part of the viewport.
Otherwise, if you start dragging on an object, most likely 3ds Max Design
will assume you intend to select where you click and will begin the transform
operation immediately.

To cancel the selection, right-click before you release the mouse.

Main toolbar »
Region flyout

+ (Rectangular Selection Region), on the Selection

Edit menu » Selection Region » Rectangular Region
Selects objects within a rectangular area.

You can use Rectangular to select either objects that are completely within
the selection region (window method), or objects that are either within or
touched by the selection shape (crossing method). Toggle between the window
and crossing selection methods by using the Window/Crossing toggle on page
197 on the main toolbar.

NOTE If you hold down Ctrl while specifying a region, the affected objects are
added to the current selection. Conversely, if you hold down Alt while specifying
a region, the affected objects are removed from the current selection.

Procedures

To select using a rectangle:

1 Click » (Rectangular Selection Region).
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2 Drag in a viewport, then release the mouse. The first location you click
is one corner of the rectangle, and where you release the mouse is the
opposite corner.

To cancel the selection, right-click before you release the mouse.

Circular Selection Region --'.

Main toolbar » “=". (Circular Selection Region), on the Selection Region
flyout

Edit menu » Selection Region » Circular Region
Selects objects within a circular area.

You can use Circular to select either objects that are completely within the
selection region (window method), or objects that are either within or touched
by the selection shape (crossing method). Toggle between the window and
crossing selection methods by using the Window/Crossing toggle on page 197
on the main toolbar.

NOTE If you hold down Ctrl while specifying a region, the affected objects are
added to the current selection. Conversely, if you hold down Alt while specifying
a region, the affected objects are removed from the current selection.

Procedures

To select using a circle:

fl &
1 |

1 Click “-* - (Circular Selection Region).

2 Drag in a viewport, then release the mouse. The first location you click
is the center of the circle, where you release the mouse defines the circle's
radius.

To cancel the selection, right-click before you release the mouse.
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Main toolbar » « (Fence Selection Region), on the Selection Region
flyout

Edit menu » Selection Region » Fence Region
Selects objects within an irregular “fence” shape.

You can use Fence to select either objects that are completely within the
selection region (window method), or objects that are either within or touched
by the selection shape (crossing method). Toggle between the window and
crossing selection methods by using the Window/Crossing toggle on page 197
on the main toolbar.

NOTE If you hold down Ctrl while specifying a region, the affected objects are
added to the current selection. Conversely, if you hold down Alt while specifying
a region, the affected objects are removed from the current selection.

Procedures

To select using a fence:

====g
-

-
'l

1 Click = « (Fence Selection Region).

2 Drag to draw the first segment of a polygon, then release the mouse
button.
A "rubber-band line" is now attached to the cursor, anchored at the point
of release.

3 Move the mouse and click to define the next segment of the fence. You
can make as many steps as you want.
4 To complete the fence, either click the first point, or double-click.

A pair of cross hairs appears when you're near enough to click the first
point. This creates a closed fence.

Double-clicking creates an open fence, which can select objects only by
the crossing method.

To cancel the selection, right-click before you release the mouse.
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Lasso Selection Region """

Main toolbar » . (Lasso Selection Region), on the Selection Region
flyout

Edit menu » Selection Region » Lasso Region
Selects objects within a complex or irregular region with a single mouse action.

You can use Lasso to select either objects that are completely within the
selection region (window method), or objects that are either within or touched
by the selection shape (crossing method). Toggle between the window and
crossing selection methods by using the Window/Crossing toggle on page 197
on the main toolbar.

NOTE If you hold down Ctrl while specifying a region, the affected objects are
added to the current selection. Conversely, if you hold down Alt while specifying
a region, the affected objects are removed from the current selection.

Procedures
To select using a lasso:

1 Click """ (Lasso Selection Region).
2 Drag to draw a shape around the objects that should be selected, then
release the mouse button.

NOTE To cancel the selection, right-click before you release the mouse.

Paint Selection Region .
Main toolbar » ﬁ (Paint Selection Region), on the Selection Region
flyout
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Edit menu » Selection Region » Paint Region
Lets you select objects by dragging the mouse over them.

To change the brush size, right-click the Paint Selection Region button, and
then, on the Preference Settings dialog » General tab » Scene Selection
group, change the Paint Selection Brush Size value on page 8932.

If you hold down Ctrl while specifying a region, the affected objects are added
to the current selection. Conversely, if you hold down Alt while specifying a
region, the affected objects are removed from the current selection.

TIP You can also create custom tools for changing the brush size; choose Customize
menu » Customize User Interface and set keyboard shortcuts or other user
interface items for the actions Paint Selection Size Up and Paint Selection Size
Down.

NOTE Paint Selection Region respects the Window/Crossing toggle on page 197.
If the toggle is set to Window on page 199 and the brush is smaller than an object
or sub-object to be selected, you won't be able to select the item. To resolve this,
enlarge the brush or choose Crossing on page 197.

NOTE With editable poly on page 2242 and Edit Poly on page 1276 objects, you can
also paint soft selections on page 1975 and deformation on page 2247.

Procedures

To select by painting a region:

1 Choose = (Paint Selection Region) from the flyout.

2 Drag over the objects to select, then release the mouse button. As you
drag, a circle showing the brush radius appears attached to the mouse.

NOTE To cancel the selection, right-click before you release the mouse.

3 To change the brush size, right-click the Paint Selection Region button,
and then, on the Preference Settings dialog » General tab » Scene
Selection group, change the Paint Selection Brush Size value on page 8932.
You can also set keyboard shortcuts for changing the brush size. To do
so, use the Paint Selection Size Up and Paint Selection Size Down action
items. See Keyboard Panel on page 8877.
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Window/Crossing Selection Toggle @

Main toolbar » """ Crossing selection or E Window selection

(Window/Crossing toggle)

Edit menu » Region » Window or Crossing

The Window/Crossing Selection toggle switches between window and crossing
modes when you select by region.

B In Crossing mode, you select all objects or sub-objects within the region,
plus any objects or sub-objects crossing the boundaries of the region.

B In Window mode, you select only the objects or sub-objectswithin the
selection.

TIP If you're making sub-object selections of faces and you select more faces than
you want, make sure you're in Window mode.

The Selection Region flyout on page 190 on the toolbar allows you to create
different-shaped selection boundaries.

3ds Max Design automatically saves the Window/Crossing setting in the
3dsmax.ini on page 43 file.

NOTE You can automatically switch between Window and Crossing Region
Selection based on cursor movement direction. To set this up, choose Customize
» Preferences and on the General tab in the Scene Selection group turn on Auto
Window/Crossing Selection by Direction.

Crossing Selection

The default Crossing option selects objects within the selection region or
crossed by the border of the region.
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Select Region Crossing selects objects within the window and also objects it crosses:
the trash can, bench, and streetlight.

To select objects within and crossed by a selection region:

1 Do one of the following:
B Choose Edit » Selection Region » Crossing.

=

B Click the Window/Crossing selection toggle to display the
Crossing icon.

2 On the main toolbar, click the Selection Region flyout on page 190 and

. —— [ —
H # & 1 "
| ] ] |

1 1 L]

I -

choose a method: + (Rectangular), “=" 4 (Circular), " 2

(Fence), or ' + (Lasso).
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NOTE This setting also applies to « (Paint Selection Region), but in
this case the boundary is that of the brush, not the region. In other words,

when painting a region in Crossing mode, the brush selects every object or
sub-object it touches or encompasses.

3 Drag to specify the region and select the objects.

Window Selection

The Window option selects objects entirely within the selection region.

Select Region Window selects only those objects completely inside the window: the
trash can and bench.
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To select objects within a selection region:

1 Do one of the following:
B Choose Edit » Selection Region » Window.

B Click the Window/Crossing selection toggle to display the E
Window icon.

2 On the main toolbar, click the Selection Region flyout on page 190 and

[{EEEEEE L R [P

H H ] W ] “

H H I i i -::

: : » . - F l————ﬂ-
choose a method: "~ + (Rectangular), ~ 4 (Circular), E

il

(Fence), or T (Lasso).
NOTE This setting also applies to + (Paint Selection Region), but in

this case the boundary is that of the brush, not the region. In other words,
when painting a selection region, the brush must completely encompass an
object or sub-object to select it.

3 Drag to specify the region and select the objects.

Selection Filter List

Main toolbar » Selection Filter

The Selection Filter list lets you restrict to specific types and combinations of
objects that can be selected by the selection tools. For example, if you choose
Cameras, you can select only cameras with the selection tools. Other objects
do not respond. When you need to select objects of a certain type, this is
useful as a quick method of freezing all other objects.
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1K, Chain Cbject
Point

Use the drop-down list to select a single filter. Choose Combos from the
drop-down list to use multiple filters from the Filter Combinations dialog on

page 201.

Filter Combinations Dialog

Main toolbar » Selection Filter list » Combos » Filter Combinations
dialog

Use the Filter Combinations dialog to create your own custom combinations
of categories to add to the Selection Filters list on page 200.

You can also add specific types of objects, or Class IDs, to the list. For example,
you can set a filter that lets you select only Sphere primitives.

Procedures

To create a combination filter:

1 Open the Selection Filter list and choose Combos.
The Filter Combinations dialog appears.

2 Turn on one or more of the check boxes in the Create Combination
group.
3 Click the Add button.

The specified combination appears in the Current Combinations list to
the right as a combination of the first letters of each selected category.
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4 Click OK.
The new combo item appears at the bottom of the Select Filter list.

Combos are stored in the 3dsmax.ini on page 43 file, so they remain in
effect for all scenes through all sessions.

To delete a combination filter:

1 Open the Selection Filter list and choose Combos.

The Filter Combinations dialog appears.
2 Choose one or more of the combos in the Current Combinations list.
3 Click the Delete button.

4 Click OK.
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Create Combination group
Geometry, Shapes, Lights, Cameras, Helpers, Space Warps Choose the
category or categories you want included in the combination.

Add After choosing the categories to include in a combination, click this
button to place the categories, labeled with the categories' initials, in the
Current Combinations list, as well as at the bottom of the Selection Filter list.

Current Combinations group
Current Combinations list Lists current combinations. To delete one or more
combinations, choose them, and then click Delete.

Delete After choosing one or more combinations in the Current Combinations
list, click this button to delete them.

All Class ID group
Class ID list Lists all the available categories that can be added to custom
filters for display and selection. Highlight a category to add, then click Add.

Add After choosing a class to include in the filter list, click this button to place
the class in the Current Class ID Filter list, as well as at the bottom of the
Selection Filter list.

Current Class ID Filter group

Class ID list Lists current classes to filter. To delete a class, choose it, and then
click Delete.

Delete After choosing a class in the Current Class ID Filter list, click this button
to delete the class.

{ ¥
Named Selection Sets “F
{¥
Main toolbar » AEt (Edit Named Selection Sets) and the Named Selection
Sets text field and drop-down list

The Named Selection Sets list allows you to name a selection set and recall
the selection for later use. It supports selection sets both at the object level
and at sub-object levels. You edit named object-level selection sets with the
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Named Selections Sets dialog on page 206 and sub-object level sets with the
Edit Named Selections dialog on page 211.

Create Selection Se | w

A named selection set is removed from the list if all of its objects have been
deleted from the scene, or if all of its objects have been removed from the
named set in the Named Selections Sets dialog.

Selection set names are case sensitive at both the object level and at sub-object
levels.

You can transfer sub-object named selections from one level in the stack to
another. The Copy and Paste buttons let you copy named selections from one
modifier to another.

While at a specific sub-object level, such as Vertex, you can make selections
and name those selections in the Named Selection Sets field of the toolbar.
The named sets are specific to both the selection level and the level on the
stack.

Keep in mind the following restrictions:

B You can transfer named selections only between the same type of sub-object
level. In other words, you can transfer named selections from vertex
sub-object to another vertex sub-object, but you can't transfer it to face or
edge sub-object level.

B You must transfer the selection between modifiers that handle like
geometry. You can copy and paste between an editable mesh and a mesh
select modifier, but you can't copy and paste between a mesh select modifier
and an editable spline.

B You can copy and paste between two modifiers in two different objects,
as long as you're at the same level and both modifiers handle the same
type of geometry.

B If you change the topology of a mesh after creating a named selection
(such as deleting some vertices), the named selections will probably no
longer select the same geometry.

Procedures

To create a named selection set:

1 Select the objects you want to be in a set.
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2 Type the name of the set in the Named Selection Sets field, and then
press Enter.

3 Whenever you want to access the selection, choose its name from the
Named Selection Sets drop-down list.

To select a named selection set, do one of the following:
1 To select a single item, click it in the list.

2 To select more than one item in the list, select one, and then select others
while holding down the Ctrl key.

3 To deselect single items after you've selected multiple items, hold down
the Alt key.

¥
Named Selection Sets Dialog **

Edit menu » Manage Selection Sets

17
) AE! . .

Main toolbar » (Edit Named Selection Sets)

The Named Selection Sets dialog, available from the Edit menu and the toolbar,

is a modeless dialog on page 9268 that lets you create named selection sets or

select objects to add to (or remove from) a selection set, directly from the

viewport. The dialog also lets you organize your current named selection sets,

browse their members, delete or create new sets, or identify which named

selection sets a particular object belongs to.

NOTE This dialog applies to objects only. For editing sub-object named selection
sets, see Edit Named Selections Dialog on page 211.

See also:
B Named Selection Sets on page 204
B Using Named Selection Sets on page 163

B [Edit Named Selections Dialog on page 211
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Procedures

To create a named selection:

1 In the viewport, select the objects you want to gather as a selection set.

4
2 On the main toolbar, click e (Edit Named Selection Sets), or from
the main menu, choose Edit » Manage Selection Sets.

)

i

3 On the Named Selection Sets dialog, click (Create New Set).
4 Enter a name for the new selection set.
To add objects to a named selection set:
17
1 On the main toolbar, click ABE (Edit Named Selection Sets), or on the

main menu, choose Edit » Manage Selection Sets.
2 Choose the named selection set in the dialog.

3 Select one or more objects in the viewport.

4 In the dialog, click lﬁ] (Add Selected Obijects).

To remove objects from a named selection set:

14

1 On the main toolbar, click AEE (Edit Named Selection Sets), or on the
main menu, choose Edit » Manage Selection Sets.

2 Choose the named selection set in the dialog.

3 In the viewport, select the objects you want to remove.

—
4 In the dialog, click LJ (Subtract Selected Objects).
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NOTE You can also remove objects by selecting them in the Named Selection

Sets dialog, then clicking @ (Remove or pressing Delete.

To move an object from one set to another:

17
1 On the main toolbar, click AEE (Edit Named Selection Sets), or on the
main menu, choose Edit » Manage Selection Sets.

2 In the Named Selection Sets dialog, expand the selection sets.

3 Drag an object from one set to another.

The object is moved into the second set. If you use Ctrl+drag, the object
will be copied into the second set.

TIP You can also copy the contents of an entire set into another, by dragging
them into the desired selection set.

To select objects in a set:

1 Highlight the set in the Named Selection Sets dialog.

o
2 Click |u| (Select Objects In Set) to select all of the objects in the
highlighted set.
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Interface

Mamed Selection Sets =
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=-{ } House
67 Door
B House

B House-Roof
B Windows
{} sentrybox
{} transport
={ } Utilities
67 Ammo
6 Generatord1
B Generatord2
B OilTanko1
B OilTanko2
B OilTanko3

{House} - Selected: 0

In the Named Selection Sets dialog, all of the current named selection sets are
displayed. By clicking the plus (+) or minus (-) icon, you can expand or collapse
(respectively) the object list for each set.

The buttons along the top of the dialog let you create or delete sets, add or
remove objects from a set, select objects (independently or as a selection set),
and see which named selection set(s) a particular object belongs to.

i

L Create New Set Creates a new selection set, including any currently
selected objects as members.

NOTE If no objects are selected, an empty set is created.
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lﬁ Remove Removes the selected object or selection set.

NOTE Deleting an object or its selection set does not delete the object; it only
destroys the named set.

b

——' Add Selected Objects Adds the currently selected objects to the selected
named selection set.

—
! Subtract Selected Objects Removes currently selected objects from the
selected named selection set.

&

Select Objects in Set Selects all members of the current named selection.

= |

Select Objects by Name Opens the Select From Scene dialog on page
184, where you can select a group of objects. The selected objects can then be
added to or removed from any named selection set.

i
|—};3| Highlight Selected Objects Highlights all of the named selection sets
that contain the current scene selection.

{fencet - Selected: 0 Status Bar Displays the current named selection
set, as well as what'’s currently selected in the scene. If more than one object
is selected, the number of selected objects is displayed.

Right-click menu

Additional commands are available when you right-click in the Named
Selection Sets dialog.

Rename Lets you rename the selected set or object.

TIP You can rename objects or sets by pressing F2.

Cut Removes the selected object or set and stores it in a buffer for reuse with
the Paste command, similar to the Cut command in Windows.

TIP You can cut an object or set by pressing Ctrl+X.
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Copy Copies the selected object or set and stores it in a buffer for reuse with
the Paste command, similar to the Copy command in Windows.

TIP You can copy an object or set by pressing Ctrl+C.

Paste Adds a Cut or Copied object or set into another set.

TIP You can paste an object or set by pressing Ctrl+V.

Collapse All Collapses all expanded selection sets.
Expand All Expands all collapsed selection sets.

Create New Set Creates a new selection set, including any currently selected
objects as members.

Remove Removes the selected object or selection set.

Add Selected Objects Adds currently selected objects to the selected named
selection set.

Subtract Selected Objects Removes currently selected objects from the selected
named selection set.

Select Objects in Set Selects all members of the current named selection.

Select Objects by Name Opens the Select Objects dialog on page 184, and adds
all objects selected there to the current named selection set.

Highlight Selected Objects Highlights all of the named selection sets that
contain the current scene selection.

Find Next Toggles through selection sets containing the selected object, when
used in collaboration with the Highlight Selected Objects command.

TIP You can use Ctrl+G to toggle through the sets.

Edit Named Selections Dialog

Make a sub-object selection. » Edit menu » Manage Selection Sets
¥
Make a sub-object selection. » Main toolbar » AEC (Edit Named
Selection Sets)
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Edit Named Selections displays the Edit Named Selections dialog, letting you
manage named selection sets of sub-objects on page 177. Unlike the Named
Selection Sets dialog on page 206, which applies to objects only, it is a modal
dialog, which means that you must close it in order to work in other areas of
3ds Max Design. Also, you can work only with existing named sub-object
selections; you cannot use the dialog to create new selections.

Procedures

To edit named sub-object selections:

1 At a sub-object level, create one or more named selection sets on page
204.

14

2 On the main toolbar, click e (Edit Named Selection Sets), or on the
main menu, choose Edit » Manage Selection Sets.
The Edit Named Selections dialog opens, listing all named selection sets
for the current sub-object level.

3 Use the dialog controls to edit the named selection sets.
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Edit Hamed Selections E m |

Mamed Selections:

Foot werts

| hand verts

[math verts

LCormbine Delete

Subtract [A-B] | Subtract [B-4)

|ntersection

Ok Caticel

The dialog window lists all named selections at the current sub-object level.
The buttons beneath the windows let you delete, merge, and edit the listed
items. Use standard mouse-plus-keyboard methods (using Ctrl or Shift) to
highlight list items and designate them for subsequent operations.
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To rename a set, click it in the list, and then edit its name in the one-line
window immediately below the list.

Combine Merges all objects from the highlighted selection sets into a single,
new selection set. Select two or more selection sets, and then click Combine
and enter a new name for the selection set. Use Delete to delete the original
sets.

Delete Deletes all highlighted items from the Named Selections window. This
affects only selection sets, not the sub-objects they refer to.

Subtract (A-B) Removes the sub-objects contained in one selection set from
another. Select one item in the Named Selections window, and then select
the other. The top highlighted item in the window is operand A, and the
bottom is operand B (regardless of the order of their selection). Click Subtract
(A-B) to subtract the sub-objects in the bottom item from those in the top
item. There must be some overlap between the two selection sets for this
command to have any effect.

Subtract (B-A) Subtracts the sub-objects in the top selected item from those
in the bottom item.

Intersection Creates a selection set that consists only of sub-objects that all
highlighted selection sets have in common. Highlight two or more items in
the Named Selections window, and then click Intersection. In the dialog that
appears, enter a new set name and click OK.

Select All

Edit menu » Select All
Keyboard » Ctrl+A

This command selects all objects in the scene matching the current selection
filter type on page 200 on the main toolbar.

Select None

Edit menu » Select None
Keyboard » Ctrl+D

This command deselects all objects in the scene conforming to the current
selection filter type on page 200 on the main toolbar.
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Select Invert

Edit menu » Select Invert
Keyboard » Ctrl+l

This command inverts the current selection set. All objects not currently
selected are selected, and all objects currently selected are deselected, respecting
the current selection filter type on page 200 on the main toolbar.

Select Similar

Select one or more objects. » Edit menu » Select Similar

Select one or more objects. » Right-click » quad menu » Transform
quadrant » Select Similar

Select one or more objects. » Ctrl+Q

Select Similar automatically selects all items that are “similar” to the current
selection. In general, this means that the objects must be on the same layer,
and have the same material (or no material) applied. The specific functionality
depends on the objects’ source:

B Selects all items imported in the DWG format in the selected object's or
objects' layer that have the same style(s) on page 8132 or categories as defined
in AutoCAD Architecture (formerly known as ADT, or Architectural
Desktop), or the same families and types as defined in Revit. For example,
if you've imported or linked to a DWG file that contains walls in several
different styles, such as CMU-8, Concrete-8, and Stud-4, you could select
all CMU-8 wall segments in the same layer by selecting one and then
invoking Select Similar.

If you start by selecting multiple objects with different styles, Select Similar
will select all objects with those styles.

B This command also applies to objects native to 3ds Max Design. It selects
all objects of the same type. This includes primitives and editable object
types. For example, if you add some boxes and cylinders, select one of the
cylinders, and then invoke Select Similar, all of the cylinders will be
selected, but not the boxes. If you then convert all of the objects to Editable
Poly format and repeat the test, all of the objects will be selected. If you
then apply a material to one of the objects or move it to a different layer,
it’s no longer “similar” to the rest and won't be selected by Select Similar.
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Select By

Edit menu » Select By

The Select By submenu on the Edit menu provides commands for selecting
objects in the scene by color, name, and other characteristics. It also gives
quick access to the various Region selection options.

See also:

B Selection Tab on page 2134

Select By Color

Edit menu » Select By » Color

Select By Color lets you select all objects having the same color as the selected
object. Selection is made by wireframe color (see Object Color Dialog on page
300), rather than by any materials associated with the objects.

After you choose this command, click any object in the scene to determine
the color for the selection set.

TIP To select objects by material, use Schematic View on page 8544.

Select By Name (Edit Menu)

Edit menu » Select By » Name

Keyboard » H

Select By Name lets you select objects by choosing them from a list of all
objects in the scene.

For a full description of the Select By Name function, see Select From Scene
on page 184.

TIP To select objects by material, use Select By Material on page 6098.

Select By Layer

Edit menu » Select By » Select By Layer
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Select By Layer lets you select all objects in one or more layers by picking them
from a list of all layers in the scene. Choosing this command opens the Select
By Layer dialog; use standard methods to highlight one or more layers, and
then click OK. The dialog closes, and all objects in the highlighted layer or
layers are selected.

Edit Commands

These commands on the Edit menu on page 8627 are for basic edit manipulations
of selections.

Undo and Redo work as in standard Windows applications. These commands
are available on the default main toolbar as well. 3ds Max Design also provides
a history of commands. Right-clicking the Undo or Redo buttons displays a
list of commands you can undo or redo. Not all operations are reversible using
Undo.

NOTE Viewport changes such as panning and zooming have a separate Undo
and Redo. See View-Handling Commands on page 106.

The Hold and Fetch command pair serves as an alternative to Undo and Redo.
Hold saves the current state of the scene. After using Hold, you can restore
that state at a later point by using Fetch. Sometimes, when you are about to
perform a risky operation, an alert prompts you to first use Hold.

3ds Max Design does not have the Cut or Paste functions found in many
Windows applications. The Delete command simply removes the selection
from the scene.

Undo/Redo N Al

Quick Access toolbar on page 8623 » (Undo) or (Redo)
Edit menu » Undo or Redo
Keyboard » Ctrl+Z (Undo) or Ctrl+Y (Redo)

The Undo command reverses the last operation, including selection actions
and those performed on selected objects. Redo reverses the last Undo operation.

Some actions cannot be undone: for example, applying the Collapse utility
or Reset Transform utility, or saving a file, which overwrites the previous
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version. When you know an action cannot be undone, use Hold on page 219
first. Then if you want to undo it, use Fetch. Hold and Fetch are also commands
on the Edit menu on page 8627.

Afer you perform an action that is undoable, the Undo command on the Edit
menu shows the name of the function to be undone. After you undo an action,
the Redo command Edit menu shows the name of the function you can redo.

Undo and Redo are also available as buttons on the Quick Access toolbar. You
can click the Undo or Redo down-arrow to display a drop-down list that shows
the last operations performed. You can highlight and reverse any number of
these operations in sequence with the respective Undo or Redo command. By
default, there are 20 levels of Undo. You can change the number of levels with
the Customize » Preferences » General tab on page 8927 » Scene Undo
group.

Undo/Redo and Object Creation

When you create an object, the Create operation is recorded by 3ds Max Design
and displayed next to the activated Undo command in the Edit menu. If you
undo the Create operation, the Create operation appears next to the activated
Redo command in the Edit menu. The Undo and Redo commands in the Edit
menu are unavailable when no valid operation was performed or recorded.

Procedures

To undo the most recent action:

Do one of the following:

-

B Click (Undo)..
B Choose Edit menu » Undo.

W Press Ctrl+Z.
To undo several actions:

-

1 Click the (Undo) drop-down arrow.

2 From the list, select the level where you want to return. You must choose
a continuous selection; you can'’t skip over items in the list.

3 Click the Undo button.

218 | Chapter 4 Selecting Objects



To exit the list without performing an action, click the Cancel button,
or click somewhere outside of the list.

To redo an action, do one of the following:
&
1 Click (Redo).

2 Edit menu » Redo.

3 DPress Ctrl+Y.
To redo several actions:

™
1 Click the (Redo) drop-down arrow.
2 From the list, click the action to return to.

Your selection must be continuous: you can't skip over any items in the
list.

3 Click the Redo button.

To exit the list without performing an action, click the Cancel button or
click somewhere outside of the list.

Hold/Fetch

Edit menu » Hold or Fetch

Hold saves the scene and its settings to a disk-based buffer. Fetch restores the
contents of the buffer stored by the previous Hold command. The information
stored includes geometry, lights, cameras, the viewport configuration, and
selection sets.

Use Hold before you perform an operation that might not work as expected,
that is new or unfamiliar to you, or that cannot be undone. If the results aren't
as expected, you can use Fetch to return to the point where you chose Hold.

TIP Also use Save or Save As before you perform an operation that cannot be
undone: for example, applying the Reset Transform utility.
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If you experience an unexpected end of operation or crash after you perform
Hold, you can retrieve your scene from the buffer with the Fetch command
after you restart 3ds Max Design.

Additional Details

B The Hold buffer is a temporary file (maxhold.mx) in the directory specified
by the AutoBackup path on the Configure User Paths dialog » File I/O
panel on page 8915.

B Fetch also deletes all operations recorded in the Undo and Redo History
lists.

Delete

Make a selection. » Edit menu » Delete
Make a selection. » Keyboard » Delete
The Delete command deletes the current selection from the model.

The Undo command on page 217 can restore the deleted selection to the model.
(Undo is also available as a button on the Quick Access toolbar on page 8623.)

NOTE Actively file-linked objects on page 8051 cannot be deleted.
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Object Properties

The Object Properties dialog, available from the Edit and right-click menus, lets you view and
edit parameters for how selected objects behave in viewports and renderings. Note that you
cannot necessarily edit all properties; parameters that apply to renderable geometry are
unavailable for non-renderable objects. However, parameters that apply to any object, such
as Hide/Unhide, Freeze/Unfreeze, Trajectory, and so on, remain available for these
non-renderable objects.

With the Object Properties dialog you can specify settings per object or by layer on page 9158.
Object settings affect only the object or objects selected. When an object is set to By Layer,
itinherits its properties from the layer settings, which you set with the Layer Properties dialog
on page 8585.

The Object Properties dialog panels are:

B General Panel (Object Properties Dialog) on page 221

B Advanced Lighting Panel (Object Properties Dialog) on page 232
B mental ray Panel (Object Properties Dialog) on page 236
|

User Defined Panel (Object Properties Dialog) on page 240

Object Properties Dialog Panels

The Object Properties dialog has four panels for managing properties.

General Panel (Object Properties Dialog)

Edit menu » Object Properties » Object Properties dialog » General panel
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Select object or objects. » Right-click. » Transform (lower-right) quadrant
of the quad menu » Object Properties » Object Properties dialog » General
panel

Layer manager » Click the icon next to an object's name. » Object
Properties dialog » General panel

This panel of the Object Properties dialog displays general object information,
as well as controls for rendering the object and displaying it in viewports.

222 | Chapter 5 Object Properties



Interface

Object Properties 7| x|

]

[y 1

By et
T

A A R R i R B

Werkex Color R |
rap Lharmel: |:

General Panel (Object Properties Dialog) | 223



Object Information group

This group displays information about the selected object, including the
following:

Name Shows the name of the object. When a single object is selected, you
can edit this field to give the object a new name. When multiple objects are
selected, this field shows "Multiple Selected," and cannot be edited.

Color The color swatch shows the object's color. You can click it to display
the Object Color dialog on page 300 and select a different color.

Dimensions Displays the X, Y, and Z dimensions of the object's extents on
page 9193.

Vertices and Faces Display the number of vertices and faces in the object.
For shapes on page 506, these values are the values used if you have made the
shape renderable. Faces for renderable shapes are generated only at rendering
time.

Shape Vertices and Shape Curves Appear only for shape objects. Shape
Vertices is the number of vertices in the shape, and Shape Curves is the number
of polygons. (Shape Curves is the value that appeared as "Polygons" in previous
releases.)

These values can change over time: they are valid only for the current frame
and the current view.

Parent Displays the name of the object's parent in a hierarchy. Shows "Scene
Root" if the object has no hierarchical parent.

Material Name Displays the name of the material assigned to the object.
Displays "None" if no material is assigned.

Num. Children Displays the number of children hierarchically linked to the
object.

In Group/Assembly Displays the name of the group or assembly to which
the object belongs. Displays "None" if the object is not part of a group.

Layer Displays the name of the layer which the object is assigned to.

Interactivity Group
Hide Hides the selected object or objects.

Hidden objects exist in the scene, but do not appear in the viewports or
rendered images. To unhide hidden objects, use the Display panel on page
8844 or choose Tools » Display Floater on page 8844.
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NOTE Objects residing on a hidden layer are automatically hidden, regardless of
this setting.

TIP The Layer Manager on page 8574 is the easiest way to hide groups of objects
or layers.

Freeze Freezes the selected object or objects.

Frozen objects appear in the viewports, but cannot be manipulated. To unfreeze
frozen objects, use the Display panel on page 8844 or choose Tools » Display
Floater on page 8844.

NOTE Objects residing on a frozen layer are automatically frozen, regardless of
this setting.

TIP The Layer Manager on page 8574 is the easiest way to freeze groups of objects
or layers.

Display Properties group

NOTE Most of these options are also available on the Display panel on page 8844
and by choosing Tools » Display Floater on page 8844.

By Object/By Layer Toggles between setting display properties on a per-object
basis and at the layer level. When set to By Layer, the object display properties
are unavailable; set the layer properties on the Layer Properties dialog on page
8585.

NOTE If multiple objects are selected and have different values for this setting,
this button reads “Mixed.”

See-Through Makes the object or selection translucent in viewports. This
setting has no effect on rendering: it simply lets you see what is behind an
object in a crowded scene, and especially to adjust the position of objects
behind the see-through object. Default=off.

You can customize the color of see-through objects by using the Colors panel
on page 8900 of the Customize » Customize User Interface dialog on page 8877.

Keyboard shortcut (default): Alt+X
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Display as Box Toggles the display of selected objects, both 3D objects and
2D shapes, as bounding boxes on page 9157. Produces minimum geometric
complexity for rapid display in viewports. Default=off.

Backface Cull Toggles the display of faces with normals on page 9281 that point
away from the view. When on, you see through the wireframe to the backfaces.
Applies only to wireframe viewports. Default=off.

Edges Only Toggles the display of hidden edges and polygon diagonals on
page 9180. When on, only outside edges appear. When off, all mesh geometry
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appears. Applies to Wireframe viewport display mode, as well as other modes
with Edged Faces turned on.

NOTE This option is also available in the Display panel on page 8844 and by choosing
Tools » D isplay Floater on page 8844.
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Trajectory Displays the object's trajectory on page 9376. Default=off.
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Ignore Extents When on, this object is ignored when you use the display
controls Zoom Extents on page 8772 and Zoom Extents All on page 8765.

Keyboard shortcut: No default, but you can customize it using the Keyboard
panel on page 8877 of the Customize » Customize User Interface dialog on
page 8877.

Show Frozen in Gray When on, the object turns gray in viewports when you
freeze it. When off, viewports display the object with its usual color or texture
even when it is frozen. Default=on.

Never Degrade When on, the object is not subject to adaptive degradation
on page 9128.

Vertex Channel Display For editable mesh on page 2192, editable poly on page
2242, and editable patch on page 2376 objects, displays the assigned vertex colors
in viewports. The drop-down list lets you choose to display Vertex Color,
Vertex Illumination, Vertex Alpha, Map Channel Color, or Soft Selection
Color. Default=off.

You can assign vertex colors at all sub-object levels except Edge.

Map Channel Sets the map channel for the vertex color. Available only when
the Map Channel Color option is active.

Shaded When on, shaded viewports add shading to the vertex coloring. When
off, colors are unshaded. Default=off.

Rendering Control group

By Object/By Layer Toggles between setting rendering controls on a per-object
basis and at the layer level. When set to By Layer, the object rendering control
settings are unavailable; set the layer properties on the Layer Properties dialog
on page 8583.

NOTE If multiple objects are selected and have different values for this setting,
this button reads “Mixed.”
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Visibility Controls the rendered visibility of the object. At 1.0, the object is
fully visible. At 0.0, the object is completely invisible when rendered.
Default=1.0.

You can animate this parameter. Animating Visibility assigns a visibility
controller to the object. By default this is a Bezier float controller on page 3466.

Renderable Makes an object or selected objects appear or disappear from
rendered output. Nonrenderable objects don't cast shadows or affect the visual
component of the rendered scene. Like dummy objects, nonrenderable objects
can manipulate other objects in the scene.

For lights, this is the only available control in the Rendering Controls group.
Making a light non-renderable effectively turns it off.

Shape on page 506 objects have the Renderable option turned on by default.
In addition, each shape has an Enable In Renderer parameter. When both
check boxes are on, the shape appears in rendered output. If the Renderable
object properties setting is off, the shape is not renderable, regardless of the
state of its local Enable In Renderer check box.

If you apply a modifier that converts the shape into a mesh object, such as a
Lathe modifier on page 1420 or Extrude modifier on page 1371, the shape
automatically becomes renderable regardless of the state of its local Enable In
Renderer setting.

Inherit Visibility Causes the object to inherit a percentage of the visibility
of its parent (as determined by the parent's Visibility track in Track View).
When a group parent is assigned a visibility track, Inherit Visibility is
automatically turned on for all children in the group. The children will have
the maximum visibility of the parent. Transparent materials and hidden objects
have no effect on this function.

Visible to Camera When on, the object is visible to cameras in the scene.
When off, cameras do not view this object; however, its shadows and
reflections are rendered. Default=on.

Visible to Reflection/Refraction When on, the object has “secondary”
visibility: it appears in rendered reflections and refractions. When off, the
object does not appear in rendered reflections or refractions. Default=on.

NOTE An object can have Visible To Camera on but Visible To Reflection/Refraction
off, in which case the object renders in the scene but does not appear in reflections
or refractions.

Receive Shadows When on, the object can receive shadows. Default=on.

Cast Shadows When on, the object can cast shadows. Default=on.
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Apply Atmospherics When on, atmospheric effects are applied to the object.
When off, atmospheric effects do not change the rendered appearance of this
object. Default=on.

Render Occluded Obijects Allows special effects to affect objects in the scene
that are occluded by this object. The special effects, typically applied by

plug-ins on page 9314 such as Glow on page 7567, use G-buffer on page 9217 layers

to access occluded objects. Turning on this control makes the object

transparent for the purposes of special effects. This makes no difference when

you render to most image files. When you render to either the RLA on page
8490 or RPF on page 8492 file format, however, occluded objects appear with the
effect applied on their designated G-buffer layer. Default=off.

G-Buffer group

Allows you to tag an object as a target for a render effect on page 7551 based on
the G-buffer on page 9217 channel. Assigning the object a nonzero ID creates a
G-buffer channel that can be associated with a render effect.

The Obiject ID property is also used with the Multi/Sub-Map shader on page
6870, and can be displayed in the Rendered Frame Window when rendering to
RLA on page 8490 and RPF on page 8492 formats.

WARNING The mental ray renderer on page 7165 does not recognize Z-depth with
G-buffers. G-buffer data is saved on a single layer. Also, the mental ray renderer
does not support the following effects:

B Glow lens effect on page 7567 (rendering effect)
B Ring lens effect on page 7574 (rendering effect)

B Lens effects Focus filter on page 7837 (Video Post)

Object ID Setting Object ID to a nonzero value means that the object will
receive the rendering effects associated with that channel in Render Effects
and the post-processing effects associated with that channel in Video Post.

To save the channel data with the rendering, render to either the RLA on page
8490 or RPF on page 8492 file format.

Motion Blur group

By Object/By Layer Toggles between setting motion blur properties on a
per-object basis and at the layer level. When set to By Layer, the motion blur
settings are unavailable; set the layer properties on the Layer Properties dialog
on page 8585.
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NOTE If multiple objects are selected and have different values for this setting,
this button reads “Mixed.”

Multiplier Affects the length of the motion-blur streak.

If you choose either form of motion blur here in the Object Properties dialog,
you must also choose to apply that type of blur in the Render Setup dialog on
page 6992.

The rendering speed of object motion blur depends on the complexity of the
geometry to which it's assigned. The rendering speed of image motion blur
depends on the amount of rendered screen space taken up by the blurring
object. In most cases image motion blur renders more quickly. Object motion
blur renders more quickly when applied to very simple objects, and image
motion blur renders more slowly when the object takes up a lot of screen
space, and moves all the way across the screen in a single frame.

0.5 10 20

Changing the Object Blur Multiplier value.

Enabled When on, enables motion blur for this object. When off, motion
blur is disabled regardless of the other blur settings. Default=on.

You can animate the Enabled check box. The main use of animating Enable
is to apply motion blur over only a limited range of frames. This can save a
tremendous amount of time when you are rendering an animation.

You can enable motion blur for lights and cameras. With the mental ray
renderer, moving lights and cameras can generate motion blur. However, they
do not generate motion blur with the default scanline renderer.

B NoneTurns off the state of motion blur for the object.
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B ObjectObject motion blur on page 9286 provides a time-slice blur effect.

B Imagelmage motion blur on page 9234 blurs the object's image based on the
velocity of each pixel.

Advanced Lighting Panel (Object Properties Dialog)

Select object or objects. » Edit menu » Object Properties » Object
Properties dialog » Advanced Lighting panel

Select object or objects. » Right-click. » Transform (lower-right) quadrant
of the quad menu » Object Properties » Object Properties dialog »
Advanced Lighting panel

Layer manager » Click the icon next to an object's name. » Object
Properties dialog » Advanced Lighting panel

This panel of the Object Properties dialog lets you customize how objects
behave under advanced lighting (the Light Tracer on page 7091 or radiosity on
page 7104).
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Selection Information rollout

Num. Geometric Objects The number of geometric objects present in the
current selection.

Num. Light Objects The number of lights present in the current selection.

Geometric Object Radiosity Properties rollout

Exclude from Adv. Lighting Calculations When on, the current selection
is excluded from advanced lighting (radiosity or light tracing). Objects excluded
from advanced lighting will not contribute to indirect illumination.

By Object/By Layer Toggles between object settings and object layer settings.
Object settings affect only the object or objects selected. Object layer settings
affect all objects on the same layer as the selected object. Most settings on this
rollout are available only when this toggle is set to By Object. Default=By
Object.

NOTE If multiple objects with different settings are selected, this button will read
“Mixed.”

Adv. Lighting General Properties group

Cast Shadows Determines whether objects will cast shadows in the radiosity
solution.

NOTE When disabling Cast Shadows, you should also turn off Diffuse (reflective &
translucent) and Specular (transparent) in the Radiosity-only Properties group. If
these switches are left turned on, objects will still generate light that can produce
artifacts in the solution.

Receive Illumination Determines whether objects will receive indirect
illumination.

Num. Regathering Rays Multiplier Lets you adjust the number of rays cast
by this object, per pixel. If an object looks “blotchy” after rendering, Increasing
this value can improve its appearance. Default=1.0.

TIP Increasing this setting is most useful for objects with large, smooth surfaces.
More complex geometry tends not to show advanced lighting artifacts as much
as smooth surfaces do.

Radiosity-only Properties group
Diffuse (reflective & translucent) When on, the radiosity solution will process
diffuse reflection and translucency on page 9381 of the selected objects.
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Specular (transparent) When on, radiosity will process transparency of the
selected objects.

Exclude from Regathering When on, objects are excluded from the
regathering process when rendering.

For more information on the Radiosity-only Properties group, see Radiosity
Control Panel on page 7123.

Object Subdivision Properties group

Use Global Subdivision Settings When on, the object's meshing settings
correspond to the global subdivision settings on the Radiosity Control Panel.
When off, you can change the meshing settings for each object. Default=on.

B SubdivideWhen on, a radiosity mesh is created for the objects regardless
of the global meshing state. The subdivision that is performed is determined
by the Use Adaptive Subdivision switch. When off, the settings in the Mesh
Settings group are unavailable. Default=on.

B Use Adaptive SubdivisionToggles adaptive subdivision. Default=on.

TIP Adaptive meshing is computed for an object only if Shoot Direct Lights is
turned on in the Radiosity Meshing Parameters rollout on page 7135.

NOTE The Mesh Settings group parameters Contrast Threshold, Min Mesh
Size, and Initial Mesh Size are available only when Use Adaptive Subdivision is
turned on.

Mesh Settings group
Max Mesh Size The size of the largest faces after adaptive subdivision.
Default=36" for imperial units and 100cm for metric units.

When Use Adaptive Subdivision is off, Max Mesh Size sets the size of the
radiosity mesh in world units.

Min Mesh Size Faces are not divided smaller than the minimum mesh size.
Default=3 inches for Imperial units and 10cm for metric units.

Contrast Threshold Faces that have vertex illuminations that differ by more
than the Contrast Threshold setting are subdivided. Default=75.0.

Initial Mesh Size When improving the face shape, faces that are smaller than
the Initial Mesh Size are not subdivided. The threshold for deciding whether
a face is poorly shaped also gets larger as the face size is closer to the Initial
Mesh Size. Default=12 inches for Imperial units and 30cm for metric units.

Advanced Lighting Panel (Object Properties Dialog) | 235



Radiosity Refine Iterations The number of refine iterations in the radiosity
process for the current selection.

Iterations Done The number of refine iterations performed on the current
selection.

Light Object Radiosity Properties rollout
These options are available only for light objects.

Exclude from Radiosity Processing When on, the current selection is excluded
from the radiosity solution. When lights are excluded from radiosity, their
direct contribution is only used for rendering. This option is available only
when By Object is selected.

By Object/By Layer Toggles between object settings or object layer settings.
Object settings affect only the object or objects selected. Object layer settings
affect all objects on the same layer as the selected object.

NOTE If multiple objects are selected and have different settings, this button reads
“Mixed.”

Store Direct Illumination in Mesh When on, the light’s direct illumination
is added to the radiosity mesh, even if the global rendering mode is Render
Direct Illumination. This is comparable to the Re-Use Direct Illumination
option when rendering radiosity, but only for this particular light.

When off, the light's direct illumination is used only when you render the
scene. This is comparable to the Render Direct Illumination option.

for more information about the Re-Use Direct Illumination and Render Direct
[Mlumination options, see Rendering Parameters Rollout (Radiosity) on page
7143. In general, re-using direct illumination stored in the radiosity mesh
improves render time, but shadows appear coarse and inaccurate unless the
mesh is very fine. Rendering direct illumination and shadows (using the
radiosity mesh to provide only indirect light) takes more time but gives you
a more finished and accurate image.

mental ray Panel (Object Properties Dialog)

Edit menu » Object Properties » Object Properties dialog » mental ray
panel
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Select object or objects. » Right-click. » Transform (lower-right) quadrant
of the quad menu » Object Properties » Object Properties dialog » mental
ray panel

Layer manager » Click the icon next to an object's name. » Object
Properties dialog » mental ray panel

This panel of the Object Properties dialog supports mental ray rendering;
specifically, the indirect illumination features caustics on page 7190 and global
illumination on page 7196. They control whether objects generate or receive
caustics or global illumination.

These settings are ignored where they aren't appropriate. For example, lights
can be set to generate caustics, but for a light, the Receive Caustics setting has
no effect, as lights aren't renderable. Similarly, these settings have no meaning
for cameras.

Also available on this panel are controls for setting displacement parameters
on a per-object basis.

TIP Most of these settings, as well as additional rendering-related settings, are
also available on the quad menu that opens when you Alt+Ctrl+right-click a selected
object.
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The mental ray panel contains object properties for the mental ray renderer.

Final Gather group

These settings let you specify how an object interacts with the final gather
process.

When Obiject is Hit by a Final Gather Ray

B Return Object Color (Physically Correct)Returns the object’s material color
at the point that the final gather ray intersects it, and contributes to final
gather illumination. This is the default mode.

B Return BlackBlocks final gather rays, returning no color, thus not shading
the object at all.
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B Pass through (Invisible to FG)Prevents the final gather process from seeing
the object during ray casting. This is useful for ignoring the light
contribution from small, complex objects like blades of grass. The final
gather rays pass through and strike the underlying object, such as a ground
plane that is easier to shade.

Receive Illumination from Final Gather When on, the object is subject to
illumination from final gather rays. When off, the object is not illuminated
by final gather rays. Default=on.

Caustics and lllumination group

These settings determine whether and how the object participates in the
simulation of caustics and global illumination (photons). To use these
capabilities, the respective check boxes must also be enabled on the Render
Setup dialog's Caustics And Global [llumination rollout on page 7260.

Exclude from Caustics When on, the object does not participate in the
caustics solution. When off, the additional caustics-related object properties
are available. Default=off.

Generate Caustics When on, the object can generate caustics. When off, the
object does not generate caustics. Default=off.

Receive Caustics When on, the object can receive caustics. That is, caustic
effects are cast onto this object. When off, the object does not receive caustics.
Default=on.

Exclude from GI When on, the object does not participate in the
global-illumination solution. When off, the additional
global-illumination-related object properties are available. Default=off.

Generate Global Illumination When on, the object can generate global
illumination. When off, the object does not generate global illumination.
Default=off.

Receive Global Illumination When on, the object can receive global
illumination. That is, reflected light is cast onto this object. When off, the
object does not receive global illumination. Default=on.

Displacement group

These settings let you apply displacement parameters on a per-object basis.

Use Global Settings When on, applies to all objects the Displacement settings
on the Render Setup dialog » Renderer panel » Shadows and Displacement
rollout on page 7245. Turn off to make settings on a per-object basis. Default=on.
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View-Dependent Defines the space for displacement. When View-Dependent
is on, the Edge Length setting specifies the length in pixels. When off, Edge
Length is specified in world-space units. Default=on.

Smoothing Turn off to have the mental ray renderer correctly render height
maps. Height maps can be generated by normal mapping; see Creating and
Using Normal Bump Maps on page 7356.

When on, mental ray simply smoothes the geometry using the interpolated
normals, making the geometry look better. This result, however, cannot be
used for height map displacement because smoothing affects geometry in a
way that is incompatible with height mapping.

Edge Length Defines the smallest allowable edge length. The mental ray
renderer will stop subdividing an edge once it reaches this size. Default=2.0
pixels.

Max. Displace Controls the maximum offset, in world units, that can be
given to a vertex when displacing it. This value can affect the bounding box
of an object. Default=20.0.

TIP If displaced geometry appears to be “clipped,” try increasing the value of
Maximum Displace.

NOTE When using placeholders (see the Translator Options rollout on page 7276),
if this value is larger than it needs to be, it can reduce performance. If you
experience slow times while displaced objects when Use Placeholder Objects is
on, try lowering the Max. Displace value.

Max. Level Controls how many times a triangle can be subdivided. Default=6.

User Defined Panel (Object Properties Dialog)

Edit menu » Object Properties » Object Properties dialog » User Defined
panel

Select object or objects. » Right-click. » Transform (lower-right) quadrant
of the quad menu » Object Properties » Object Properties dialog » User
Defined panel

Layer manager » Click the icon next to an object's name. » Object
Properties dialog » User Defined panel

This panel of the Object Properties dialog lets you enter properties or comments
that you define yourself.
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Interface

Object Properties
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User Defined Properties In this text box, you can enter properties for the
object, or comments about it, that you define yourself. 3ds Max Design doesn't
use these properties, but it saves them with the scene, and they reappear
whenever you view the Object Properties dialog for the object.

Rename Objects Tool

Tools menu » Rename Objects

The Rename Obijects tool helps you rename several objects at once.

Interface

It Rename Dbjects |

#® Selected ¢ Pick

|v Base Mame: |

[~ Prefis: |
I Remove First: |E| ﬂ Drigits

[~ Suffix: |
I™ Remove Last: |EI ﬂ Drigits

™ Mumbered

Baze Mumber: | N ﬂ
Step: | 1 ﬂ

RHename

Selected When chosen, renaming affects currently selected objects.
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Pick Click to open the Pick Objects To Rename dialog, which lets you choose
the objects to rename. This dialog has the same controls as Select From Scene
on page 184.

Base Name Enter a base name for all objects. The toggle enables or disables
this name.

Prefix When on, lets you enter a string that will be a prefix to the name of
all renamed objects.

Remove First N Digits When on, the first N characters in the base name are
removed from object names. The spinner sets the value of N.

Suffix When on, lets you enter a string that will be a suffix to the name of all
renamed objects.

Remove Last N Digits When on, the last N characters in the base name are
removed from object names. The spinner sets the value of N.

Numbered When on, lets you number object names incrementally.

B Base NumberThe base number appended to the name of the first renamed
object.

B StepThe step by which the base number is incremented in succeeding
renamed objects.

Rename Click to rename the affected objects and have your changes take
effect.

Custom Attributes

Animation menu » Parameter Editor
Keyboard » Alt+1

Use the Parameter Editor to assign custom attributes to objects, modifiers,
materials, and animation tracks. A custom attribute is an additional, abstract
parameter; abstract in the sense that it does not directly extend the
functionality of the object by default. It affects an object only after wire
parameters on page 3649, reaction controllers on page 3563, or expression
controllers on page 3490 are set up to connect the custom attribute to another
parameter in the scene. You can also use custom attributes to store job-specific
notes and data.
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Custom attributes behave like other object parameters in several ways:
B They are saved and loaded in the scene file along with the object.
B They can be animated and keyframed.

B They are displayed in Track View along with the base parameters.

Each custom attribute parameter can be one of a number of different data
types, including integers, floating numbers, Booleans, arrays, nodes, colors,
and texture maps. Parameters added to an object or modifier appear on a
Custom Attributes rollout on the Modify panel. For each custom attribute
parameter you create, you can specify the name, layout, value range, default
value, and Ul type: spinner or slider for floats and integers, check box for
Booleans, etc.

As you customize an attribute, the result is displayed on the Testing Attribute
rollout at the bottom of the dialog.

NOTE If an object with custom attributes is placed in a container on page 7891,
those attributes are retained in the inherited container. The inheritor of the
container can unlock attribute values and edit them locally, but any locally added
attributes to the same definition will be lost upon updating on page 7925 the
container.

See also:
B Parameter Collector on page 260

B Attribute Holder Modifier on page 1104

Custom Attributes Special Features

The Custom Attributes feature offers an array of workflow-enhancing
functionality, including:

the ability to add custom attributes to specific animation tracks.
the ability to edit existing custom attributes.

13 available data types.

a variety of available UI options, such as ComboBox and ListBox for the
Array data type.

B the ability to position Ul elements precisely with X and Y Offset controls.
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B the ability to preserve custom attributes on page 8832 when collapsing the
stack.

B A special Attribute Holder modifier on page 1104 that lets you collect
attributes from different entities and access them in one place on the
Modify panel.

Procedures

To add a parameter to an object:
1 Select the object.

2 Choose Animation menu » Parameter Editor.
The Parameter Editor opens.

3 Change settings as desired.

4 Click Add.

The parameter is added to the level specified in the Add To Type list. If
an object has no custom attributes, Parameter Editor first adds a Custom
Attributes entry to the current Add To Type level, and then adds the
parameter to the Custom Attributes entry. If an object has more than
one Custom Attributes entry as a result of collapsing its stack, the
parameter is added to the first Custom Attributes entry.

If a custom attribute parameter is assigned to an object or modifier, you
can see and edit its value on the Modify panel after adding it by activating
the entity to which the attribute is assigned. If the custom attribute is
assigned to a material, it's available for that material in the Material Editor,
on the Custom Attributes rollout. To access a parameter that's assigned
to an animation track, open Track View, highlight the track's Custom
Attributes entry, and then right-click and choose View Attribute Dialog.

To edit a parameter or custom attribute:
1 Select the object.

2 Choose Animation menu » Parameter Editor.

The Parameter Editor opens.
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{€) Parameter Editor =10 x|

|- Attribute |
—Add to Type:
ISelected Object's Base Level j

Ej Pick Ex=plicit Track

- Bdd/Edit/Delete
Add Edit/Delete... |

— Parameter Type:
Float j

— Ul Type

S pinner j

Mame: |Param1

I+ Float Ul Options I
| - Testing Attribute !

Faram: | 0.0

l4r

3 From the Add To Type drop-down list, choose the type of parameter to
edit, and then click Edit/Delete.

The Edit Attributes/Parameters dialog opens.
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Edit Attributes/Parame x|

Attributes /Parameters:

==== Cuztam Attributes - 1 ====

Spinner - zphFParam
==== [Cuztom Attibutes - 2 ====
Spinner ---- modParam

4 | ¥ | ficcept Parameter Changes |

Delete Parameter| Delete All Parameters |

Apply Changes Rezet | Cancel |

NOTE If you chose Add To Type » Picked Track, the Track View Pick dialog
might open first to prompt you to choose the animation track whose attribute
to edit.

In the Edit Attributes/Parameters dialog, highlight the parameter to edit.
Its settings appear in the Parameter Editor.

Change the settings in the Parameter editor, and then click Accept
Parameter changes.

With multiple parameters or custom attributes, to change the ordering,
click the entity to move, and then use the up and down arrow buttons
to move the entity in the list. Moving a Custom Attributes entry also
moves its parameters.

NOTE You cannot rename a Custom Attributes entry.
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7 When finished editing, click Apply Changes, and then exit the dialog by
clicking the Close or Cancel button.
To delete a custom attribute or parameter:
1 Select the object.

2 Choose Animation menu » Parameter Editor.
The Parameter Editor opens.

3 From the Add To Type drop-down list, choose the type of parameter to
delete, and then click Edit/Delete.
The Edit Attributes/Parameters dialog opens.

NOTE If you chose Add To Type » Picked Track, the Track View Pick dialog
might open first to prompt you to choose the animation track from which
to delete the attribute.

4 In the Edit Attributes/Parameters dialog, highlight the parameter to delete,
and then click Delete Parameter. Alternatively, to delete all parameters
under the same Custom Attributes heading as the highlighted parameter,
click Delete All Parameters.

To delete one or more custom attributes instead, click a Custom Attributes
heading, and then click Delete Attribute or Delete All Attributes. Multiple
attributes can result from collapsing an object's stack with Preserve Custom
Attributes on. For example, one set of custom attributes might be applied
to an object and a second set of attributes assigned to one of its modifiers.
Collapsing such an object results in two sets of custom attributes.

5 Click Apply Changes, and then close the dialog by clicking its Close box
or the Cancel button.

Interface

The Parameter Editor takes the form of a dialog with several rollouts: The first
rollout sets general options for the attribute; the central rollout sets options
for the current parameter type; and the third lets you preview the attribute
user interface (UI).
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=101

|- Attribute |
—add to Type:
ISeIected Object's Baze Level j

H] Fick E=plicit Track,

- Add/Edit/Delete
Add Edit/Delete. . |

— Parameter Type:

Float j
— Ul Type

Spinner j

Mame: |Pararn

|+ Float Ul Options li
| - T esting Attnbute

FParam: | 0.0

[4r

Attribute rollout

Add to Type group

Add to Type list Choose whether the custom attribute is assigned to the
selected object, its active modifier (as highlighted in the modifier stack), its
material, or a picked track. Also use this drop-down list to choose the attribute
type to delete or edit.
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If the text “Pick Explicit Track” appears in the box below the drop-down list
before you choose Picked Track , the Track View Pick dialog appears showing
the Track View hierarchy. Expand the hierarchy as necessary, click the track
to add the attribute to, and then click OK.

NOTE If you choose Selected Object's Current Modifier and multiple modifiers
are highlighted in the stack when you click Add, Parameter Editor applies the
custom attribute to the first modifier you highlighted and removes the highlighting
from the other modifiers.

Pick Explicit Track Click this button to open a Track View hierarchy
window from which to choose an animation track. Navigate the hierarchy to
find the desired track, highlight the track, and then click OK. The controller
information for the track then appears in the text box to the right of the
button, and the Parameter Editor will then use this track for adding or editing
custom attributes and parameters.

Track Yiew Pick 2] x|
............ eﬁj Spherem :I I:IK
..o fz] Transform : Position/Fotation/Goal |
o2 [foe] Provzition : Pozition 2 Caricel

----- #+f-]* Position : Bezier Float

----------- [i]" Position : Bezier Float

[[-]< Position : Bezier Float _I
----- =+jc] Ratation : Euler Y2

----------- [.-]* Rotation : Bezier Float

----------- [[]" Rotation : Bezier Float

----------- [[--]< Rotation : Bezier Float

..... =+fa] Scale : Bezier Scale
- — Custor_Attibutes

-i2gf2 Object [Editable Paly]
........... [ Falloff
........... [ Finch
........... [ EBubble
........... [ lterations

........... B Surface Smoathness -
B B 4
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Add/Edit/Delete group

Add Applies the custom attribute parameter to the current object, modifier,
material, or track, depending on the current choice in the Add To Type list.

If a custom attribute parameter is assigned to an object or modifier, you can
see and edit its value on the Modify panel after adding it by activating the
entity to which the attribute is assigned. If the custom attribute is assigned to
a material, it's available for that material in the Material Editor. To access a
parameter that's assigned to an animation track, open Track View, highlight
the track's Custom Attributes entry, and then right-click and choose View
Attribute Dialog.

Edit/Delete Opens the Edit Attributes/Parameters dialog.

This dialog displays a list of all of the custom attribute parameters assigned
to the currently object at the current level. Dialog behavior is described in
these two procedures: To edit a parameter or custom attribute: on page 245
and To delete a custom attribute or parameter: on page 248.

Parameter Type group

Parameter Type Use the drop-down list to choose the data type for the current
parameter. The following list includes links to the sections describing the Ul
settings for each parameter's data type:

B Angle: Spinner on page 252 or Slider on page 253
Array on page 255

Boolean: CheckBox on page 254 or CheckButton on page 254
Color on page 257

Float: Spinner on page 252 or Slider on page 253
fRGBA on page 257

Integer: Spinner on page 252 or Slider on page 253
Material on page 258

Node on page 257

Percent: Spinner on page 252 or Slider on page 253
String on page 259

TextureMap on page 258

WorldUnits: Spinner on page 252 or Slider on page 253
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Ul Type group

UI Type Selects the type of Ul element that controls the parameter.

The UI types available depend on which parameter type you specify. For
example, float and integer values are controlled by spinners or sliders, and
Boolean values by check boxes or check buttons. Array values are always
controlled by drop-down lists, node values by pick buttons, color values by
color pickers, and texture map values by map buttons.

Full descriptions of each UI Options rollout follow, and the list of parameter
types, above, includes links to the respective UI Options rollout descriptions.

Name The name of the parameter. Parameter Editor gives the parameter the
default name Param#, with # being a number. Change the name by editing
this field.

Angle/Float/Integer/Percent/WorldUnits Ul Options rollout: Spinner

This is a numeric value that the user can set with a standard 3ds Max Design

spinner.
|- Float Ul Options
—Size
width: [T60 —
—Ranage

From:[00 2| Tei000 3
Default:lﬂ.ﬂ—ﬂ

—dlignment
£ Left " Right & Center
Offzets: K:|E| ﬂ Y:|D ﬂ

— Orientation and Ticks

I ertical Ticks: I 1] ﬂ

Size group
Width Sets the width of the spinner.

Range group
From Sets the minimum value of the spinner.

To Sets the maximum value of the spinner.
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Default Sets the default value of the spinner.

Alignment group

Left/Right/Center Sets the alignment of the spinner in the rollout.
Offsets X/Y Fine-tune the position of the spinner on the horizontal and
vertical axes.

Angle/Float/Integer/Percent/WorldUnits Ul Options rollout: Slider

This is a numeric value that the user can set with a standard 3ds Max Design
slider.

| - Float Ul Optionz |

—Size

wiidth: [TE0 H

—FRange

From [00 2| Te[T000 2]
Default:l[l.[l—ﬂ

— Alignment

° Left Right ® Center

Offsets: [0 2| V[0 2]

— Orientation and Ticks

[~ Wertical Ticks: | 1] ﬂ

Size group
Width Sets the width of the slider.

Range group

From Sets the minimum value of the slider.
To Sets the maximum value of the slider.
Default Sets the default value of the slider.

Alignment group
Left/Right/Center Sets the alignment of the slider in the rollout.
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Offsets X/Y Fine-tune the position of the slider on the horizontal and vertical
axes.

Orientation And Ticks group

Vertical When on, the slider will be displayed vertically. When off, the slider
is displayed horizontally.

Ticks Sets the number of ticks along the slider. The ticks are distributed evenly
along the length of the slider.
Boolean Ul Options rollout: Check Box

This is a standard 3ds Max Design check box that the user can turn on and
off by clicking it with the mouse.

| - Boolean Ul Options |

— Size
width: [70 3| Height [T5 3]
— Alignmment

£ Left " Right & Certer
Offsets: =:[0 2 [0 2]

— Check Button Options

Highlight Calar |:|

Size group
Width Sets the width of the check box.

Height Sets the height of the check box.
Alignment group
Left/Right/Center Sets the alignment of the check box in the rollout.

Offsets X/Y Fine-tune the position of the check box on the horizontal and
vertical axes.

Boolean Ul Options rollout: Check Button

This is a standard 3ds Max Design check button that the user can turn on and
off by clicking it with the mouse.
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| - Boolean Ul Options |

— Size
Wwidth: [70 2| Height[25 2]
—Alignment

£ Left " Right & Center
Offzets: K:|E| ﬂ Y:|D ﬂ

— Check Button Options

Highlight Calar: |:|

Size group
Width Sets the width of the check button.

Height Sets the height of the check button.
Alignment group
Left/Right/Center Sets the alignment of the check button in the rollout.

Offsets X/Y Fine-tune the position of the check button on the horizontal and
vertical axes.

Check Button Options group
Highlight Color Sets the color of the button when it is pressed.

Array Ul Options rollout: Drop-Down List/ComboBox/ListBox

This lets the user of the custom attribute choose a named option from a list.
The options for the three Array Ul types are the same; they differ in how they
appear on the Custom Attributes rollout. The types are:

B Drop-Down List: Only the current choice is visible by default. The user
clicks the field to open the list and then clicks to choose a different item.

B ComboBox: Displays an editable field above a list box. The user clicks to
choose from the list, or edits the field.

B ListBox: Displays a list. The user clicks the desired item; the highlighting
indicates the current choice.
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| - Array Ul Optiong |

—Size
width: [T50° 3| Height[5 2]
—Alignment

 Left ¢ Right % Center
Difsets: »:[0 2| [0 2]

— Array

|term name: |

Add [tem | Deleteltem| Clear .-’-\.rra_l,l|

|item 1

Size group
Width Sets the width of the list.

Height Sets the height of the list.

Alignment group
Left/Right/Center Sets the alignment of the drop-down list in the rollout.

Offsets X/Y Fine-tune the position of the array list on the horizontal and
vertical axes.

Array group
Item name Lets you enter a name into the list.

Click Add Item to add the name to the array list. To remove an item, highlight
its name and click Delete Item. Click Clear Array to remove all items from the
list.

[array list] Displays the contents of the list.
The item at the top of the array list is the default selection.
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Node Ul Options rollout: Pick Button

A node is any object in the 3ds Max Design scene. The Node UI element creates
a button that, when clicked, lets the user pick a scene node other than the
one to which the attribute is attached. After selecting the node, its name
appears on the button.

| - Mode Ul Options |

—Size
width: [T50° 3| Height [25 2]
— Alignment

° Left Right ® Center
Offsets: [0 2| [0 2]

Size group
Width Sets the width of the pick button.

Height Sets the height of the pick button.
Alignment group
Left/Right/Center Sets the alignment of the pick button in the rollout.

Offsets X/Y Fine-tune the position of the pick button on the horizontal and
vertical axes.

Color Ul Options rollout: Color Picker

This creates a color swatch that displays the current color and lets the user
click it to choose a new color with the Color Selector dialog.
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IE Colar Ul Options |

~ Size
Width: [T00” 3| Height [25 3
— Alignrnent

 Left ¢ Right % Center
Offsets: 2:J0 2| [0 2]

— ColorPicker Default Caolor

Default Color: I:I

Size group
Width Sets the width of the color picker.

Height Sets the height of the color picker.

Alignment group
Left/Right/Center Sets the alignment of color picker in the rollout.

Offsets X/Y Fine-tune the position of the color picker on the horizontal and
vertical axes.

ColorPicker Default Color group
Default Color Sets the default color of the color picker.

Material/TextureMap Options rollout: MaterialButton/MapButton

The options for the Material Ul type (MaterialButton) and TextureMap UI
type (MapButton) are the same. The difference is that, when the user clicks
the resulting button to open the Material/Map Browser, the former displays
only materials and the latter displays only maps.

| = b aterial Ul Dptions |

—Size
width: [T50° 3| Height [25 3
— Alighment

 Left ¢ Right & Center
Offsets: [0 2| [0 2]
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Size group
Width Sets the width of the material/map button.

Height Sets the height of the material/map button.

Alignment group

Left/Right/Center Sets the alignment of the material/map button in the
rollout.

Offsets X/Y Fine-tune the position of the material/map button on the
horizontal and vertical axes.

String Options rollout: EditText

The String parameter type creates a text box that the user can edit with the
keyboard, with optional default text.

Size group

Width Sets the width of the material/map button.

Height Sets the height of the material/map button.

Alignment group

Left/Right/Center Sets the alignment of the text box in the rollout.
Offsets X/Y Fine-tune the position of the text box on the horizontal and

vertical axes.

Label group

Label above text box When off, the label (parameter name) appears to the
left of the text box. When on, the label appears above the text box.

EditText Default Text group

Default Text Enter any default text that should appear in the box before the
user edits it.

Testing Attribute rollout

| - Testing Attribute l
Param1]0.0 ﬂ
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This rollout displays the Ul layout for the custom attribute that you are working
on. It updates continuously so that you can see how different settings in the
various rollouts affect the Ul display of the attribute.

The Ul element is operational in this rollout in the sense that it can be moved,
clicked, toggled, and so on.

Parameter Collector

Animation menu » Parameter Collector
Keyboard » Alt+2

Parameter Collector lets you sort and present animatable parameters so that
you can access and key selected parameter sets with a click or two. It takes the
form of a resizable dialog that regenerates dynamically as parameters change.
The dialog supports drag-and-drop rollout reordering. Collections are saved
with their scenes and can be merged into other scenes.

One of Parameter Collector's most powerful features is the ability to change
all parameters in a collection simultaneously, in an absolute or relative mode.
For example, if you're animating a character's hand, you can use Parameter
Collector to easily make all the fingers curl up together to form a fist.

NOTE Parameter Collector does not support parameters of externally referenced
objects on page 8008 or objects in externally referenced scenes on page 8036.

See also:
B Custom Attributes on page 243

B Attribute Holder Modifier on page 1104

Procedures

Example: To use Parameter Collector:
This exercise demonstrates some basic Parameter Collector functions.

In general, start with a scene containing one or more objects whose parameters
you'll collect. Ideally, they should be animated, but it's not absolutely
necessary.

1 For this example, reset 3ds Max Design and then add a sphere.

2 Open Parameter Collector from the Animation menu, or press Alt+2.
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On the Parameter Collector toolbar, click Eﬂ: (Add To New Rollout).
The Track View Pick dialog opens. This lets you specify parameters to
collect.

On the Track View Pick dialog, expand Objects » Sphere01 »
Transform: Position/Rotation/Scale » Position: Position XYZ.
Click X Position: Bezier Float.

The parameter highlights.

Click OK to close the dialog.

A new rollout named Parameters 1 appears, containing the X Position
parameter.

NOTE A parameter in Parameter Collector can contain only a single value
(for example: float, integer, color), so 3ds Max Design doesn't let you add
parameters such as Position: Position XYZ, which contains three distinct
values.

Click I:I"' (Add To Selected Rollout), and then use the same method to
add the Y Position and Z Position parameters: Highlight both parameters
on the Track View Pick dialog and then click Add To Selected Rollout to
add both at once to the Parameters 1 rollout.

Drag each spinner in turn to move the sphere on the respective axis.

As you change each parameter value, the sphere moves in real time in
the viewports.

Set all three parameters to 0.0.

Click the check button next to each parameter to select all three.

|- Pararmeters 1 |

| % Pasitian IU-U ﬂ%l
| ¥ Pasitian IU-U ﬂ%
| ZPasitian IU-U ﬂ%
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On the toolbar, turn on g (Multiple Edits).

Drag one of the spinners.

All three change by the same amount, so that the sphere moves diagonally
in the scene.

Use the keyboard to change the Y Position value to 30.0.
Again, the other two change.

Click @

All the values display 0.0, as with Offset mode on the status bar coordinate
display.

(Absolute/Relative) to turn on Relative mode.

Use the spinner to set Y Position to 0.65.

The three change in unison, and then reset back to 0.0 when you release
the mouse button. This has added the value you set to each of the three
positions, as you'll see in the next step.

Click the Absolute/Relative button to return to Absolute mode.

The values are all set to 30.65, reflecting the relative change that you
made.

Next, you'll try a few Edit commands.
Click the Y Position check button to deselect the parameter.

From the Edit menu, choose Select Invert.

The Y Position parameter is now selected, and the other two are
deselected.

Click ﬂ (Move Parameters Up).
The Y Position parameter now sits above the X Position parameter.

Click El' (Move Parameters Down).
The Y Position returns to its position below the X Position parameter.

Choose Edit » Edit Notes.

The Notes dialog opens. Here you can change the parameter name, set a
URL or file location with further information about the parameter, and
enter comments.
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In the box below Parameter Name, type Sphere Y Loc., and then press
Enter.

The new name replaces the old one on the rollout. You can see the
original name by hovering the mouse cursor over the parameter name;
it appears on a tooltip.

To conclude this exercise, you'll use Parameter Collector to set and edit
animation keyframes.

On the Collection menu, turn on Show Keys In Track Bar if necessary.

On the 3ds Max Design status bar, turn on Ml (Auto Key).

Change the Sphere Y Loc. (the old Y Position) parameter value to 20.0.
Because you're at frame 0, no key is set. This is the same way Auto Key
works normally.

Go to frame 20 and then set Sphere Y Loc. to 30.0.

This sets animation keys at frames 0 and 20.

Right-click the key at frame 20.

The menu shows that a key exists at frame 20 only for Y Position.
Normally, 3ds Max Design would create keys for all three axes, even if
you moved the sphere only on one axis.

Parameter Collector can set keys for unselected objects as well.

Click in an empty area of the active viewport to deselect the sphere, and
then go to frame 30 and change the Sphere Y Loc. value to 40.0.

This sets another key for Y Position at frame 30.

In Parameter Collector, select the X Position and Z Position parameters,
and then click D (Key Selected).

This button is available only when Auto Key is on.

Check the track bar key again. Now there are keys for all three parameters,
as demonstrated by the red brackets on the spinners in Parameter
Collector.

Click (Properties), to the right of the Sphere Y Loc. parameter.

This opens a Key Info dialog on page 3451 for the parameter, with the ability
to edit the key time and value as well as interpolation with other keys.
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The dialog is also available from the track bar right-click menu, but it's
much easier to access the data for a specific key from Parameter Collector.

Interface

Callecktion  Edit  Parameters Rallouk

Parameter Collector takes the form of a dialog with a menu bar, a toolbar, and
rollouts that you create and modify using the dialog tools. You can resize the
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dialog horizontally and vertically; expanding it lets you see all rollouts
simultaneously.

Menu Bar

The menu bar provides a range of functions for using Parameter Collector.
See Parameter Collector Menu Bar on page 268 for details. Also, you can open
the Spinner Right-Click menu on page 3415 by right-clicking a numeric field in
Parameter Collector.

Toolbar

Irighthand v [ l_él @
0F o OC & EL O F Ceisg

The Parameter Collector toolbar provides button access to the most commonly
used functions.

[collection name] If empty, enter a name for the current collection, or choose
a different collection from the drop-down list. If a name appears and you edit
it, pressing Enter duplicates the current collection with the new name.

5

New Collection Creates a new, empty collection, clearing the current
collection name and the rollout area. You can restore any existing collection
by choosing it from the drop-down list.

This button is unavailable if you have not entered a name for the collection.

5 Duplicate Collection Creates a new, unnamed collection containing
the same data as the current collection. Enter a name for the duplicate selection
in the editable field.

This button is unavailable if you have not entered a name for the collection.

TIP You can also duplicate a collection and name it at the same time by editing
the name of an existing collection and then pressing Enter.

&)

This button is unavailable if you have not entered a name for the collection.

Delete Collection Removes the current collection from memory.
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DB Multiple Edits Enables multiple editing, in which changing the value
of any selected parameter simultaneously changes all selected parameters of
the same type by the same amount. This applies to both Absolute and Relative
modes (see following).

IEI Absolute/Relative Works the same way as the Absolute/Offset mode
toggle on the Coordinate Display on page 8708. When Absolute is chosen,
modifying a value changes it to the exact amount you specify. When Relative
is chosen, the displayed value is 0, and modifying the parameter adds the
specified change to the original value. The actual value appears only in
Absolute mode.

This applies to numeric values only; any changes to other values, such as
color, are always absolute.

NOTE With multiple parameters selected, and Multiple Edits on, changing the
value of a selected parameter changes the other selected parameter values by the
same amount, not to the same amount. This happens in both Absolute and Relative
modes.

|:| Key Selected Sets keys on page 9244 for selected parameters only at the
current frame. Available only when Auto Key on page 8718 is on.

I:I“-" Reset Selected Sets all selected numeric parameters to 0. Has no effect
on other parameter types.

El' Move Parameters Down Moves each selected parameter down one
position within its rollout, if possible.

ﬂ Move Parameters Up Moves each selected parameter up one position
within its rollout, if possible.

I:I"' Add to Selected Rollout Lets you add new parameters to the selected
rollout. Click this button to open the Track View Pick dialog, and then choose
the parameters from the dialog.

NOTE You can add several parameters at once by highlighting them in the dialog
before clicking OK.
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e']: Add to New Rollout Lets you add new parameters to a new rollout.
Click this button to open the Track View Pick dialog, and then choose the
parameter from the dialog. Parameter Collector creates a new rollout to hold
the parameters.

NOTE You can add several parameters at once by highlighting them in the dialog
before clicking OK.

& Delete Selected Deletes all selected parameters.

3

Delete All Deletes all parameters and rollouts.

Rollouts

Rollouts work the same way in Parameter Collector as they do on the command
panel on page 8607. You can expand and collapse a rollout by clicking its title
bar, and move it to another location by dragging the title bar. You can resize
the dialog to be able to see all rollouts at once.

Only one rollout can be selected at a time. You select a rollout by clicking the
horizontal bar beneath the title; when selected, this bar is orange-yellow in
color, and angle brackets surround the rollout title (for example, “> Hand
Parameters <”).

The interface for each parameter on a rollout is as follows:

[Select Parameter]| A small check button on the left side of the rollout. Click
it to toggle the parameter's selection status. When selected, the button appears
pressed in and is colored yellow-orange.

[parameter name] By default, the parameter has the same name as is shown
in Track View, but you can change it with the Edit menu » Edit Notes
command. You can see the default name for a parameter as well as the object
it controls, if any, by hovering the mouse over the parameter name; the
information appears on a tooltip.

[parameter value] Shows the current value of the parameter. The parameter
type determines how this appears: numeric field/spinner, color swatch, etc.
You can edit the value the same way as on the command panel or a dialog.

If a key exists for the value at the current frame, the spinner or swatch appears
with red brackets at the corners.
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[Properties] Opens a Key Info dialog on page 3451 for the parameter.
Available only if the parameter has an animation controller.

Use the Key Info dialog to edit an animation key's value, time, and
interpolation methods.

Parameter Collector Menu Bar

Animation menu » Parameter Collector » Parameter Collector menu bar
Keyboard » Alt+2 » Parameter Collector menu bar

The Parameter Collector dialog menu bar provides access to a number of
important commands. Some of these commands are replicated on the dialog
toolbar; others, such as the Select tools, are available only from the menus.
Also, you can open the Spinner Right-Click menu on page 3415 by right-clicking
a numeric field in Parameter Collector.

Interface

Collection menu

The first three items in this menu are unavailable until you enter a name for
the current collection in the editable field (drop-down list) just below the
menu bar.

New Collection Creates a new, empty collection, clearing the current
collection name and the rollout area. You can restore any existing collection
by choosing it from the drop-down list.

Duplicate Collection Creates a new, unnamed collection containing the same
data as the current collection. Enter a name for the duplicate selection in the
editable field.

Delete Collection Removes the current collection from memory.

Show Keys in Track Bar Displays in the track bar on page 8698 animation keys
for all objects with parameters in the current collection, whether or not the
objects are selected in the scene.

Isolate Keys in Track Bar The track bar displays only keys for parameters in
the Parameter Collector.

Show Selected Keys in Track Bar Displays in the track bar on page 8698
animation keys for all objects with selected parameters in the current
collection, whether or not the objects are selected in the scene.
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Isolate Selected Keys in Track Bar The track bar displays only keys for selected
parameters in the Parameter Collector.

Put to Object Stores the current collection as part of an object in the scene.
Opens the Put To Object dialog; highlight an object in the list, and then click
Pick.

Although parameter collections are stored with the scene in which they're
created, you can use this function to transfer a collection to a different scene.
After putting the collection to an object, save the scene. Open or create another
scene, merge the object from the saved scene to the new one, and then use
Get from Object.

You can also back up, organize and streamline parameter collections by putting
and getting different collections to and from various objects in your scene.
Just remember that if you add, reorder, or remove parameters or rollouts to a
collection that has been put to an object, you must then put it to the object
again so the changes are saved to the collection.

Link to Object Stores the current collection using a live link as part of an object
in the scene. Any change to the collection instantly updates the version of
the collection stored in the object. Opens the Link To Object dialog; highlight
an object in the list, and then click Pick.

Link to Object has basically the same function as Put To Object (see previous
entry), except that it guarantees an up-to-date stored version of the collection,
especially when merging the object into another scene that is a common
production workflow.

NOTE Only one “linked-to” object can be active in a scene, but you can use Put
To Object on any number of objects at a time.

Get from Object Retrieves a collection that you stored with Put To Object or
Link To Obiject.

Remove from Object Deletes a collection that you stored with Put To Object
or Link To Obiject.
Edit menu

Parameter Collector lets you select parameters in any combination, but you
can select no more than one rollout at a time. To select or deselect a parameter,
click the small button on its left side. To select or deselect a rollout, click the
wide horizontal button just below the rollout title. Selecting a rollout deselects
any other selected rollout.

Select All Selects all parameters and rollouts.
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Select All Rollout Selects all parameters on the current rollout. Unavailable
if no rollout is selected.

Select None Deselects all parameters.

Select Invert Inverts the current selection of parameters.
Delete Selected Deletes all selected parameters.

Delete All Deletes all parameters and rollouts.

Multiple Edits Enables multiple editing, in which changing any parameter
simultaneously changes all selected parameters of the same or similar type.

NOTE The changed parameter need not be selected.

Absolute/Relative This works the same as the Absolute/Offset mode toggle
on the Coordinate Display on page 8708. When Absolute is chosen, modifying
a value changes it to the exact amount you specify. When Relative is chosen,
the displayed value shows 0, and modifying the parameter adds the specified
change to the original value. This applies to numeric values only; changes to
any other value types such as color are always absolute.

Edit Notes Opens a single Notes dialog on page 271 for all selected parameters.

You can open the Notes dialog for a single parameter by right-clicking its
Select Parameter button.

Parameters menu
Add to Selected Lets you add new parameters to the selected rollout.

Add to New Rollout Lets you add new parameters to a new rollout.

Move Up Moves selected parameters up one position within their rollout, if
possible.

Move Down Moves selected parameters down one position within their
rollout, if possible.

Move Up By Rollout Moves selected parameters to the rollout above, if
possible. If the same parameter already exists in the rollout above, the selected
parameter is simply deleted.

Move Down By Rollout Moves selected parameters to the next rollout, if
possible. If the same parameter already exists in the next rollout, the selected
parameter is simply deleted.

Key All Sets keys on page 9244 for all parameters at the current frame. Available
only when Auto Key on page 8718 is on.
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Key Selected Sets keys on page 9244 for selected parameters only at the current
frame. Available only when Auto Key on page 8718 is on.

Reset All Sets all numeric parameters to 0. Has no effect on other parameter
types.

Reset Selected Sets all selected numeric parameters to 0. Has no effect on
other parameter types.

Rollout menu

NOTE While there are no menu commands for moving rollouts, you can do so
simply by dragging the rollout title bar to a new location.

New Rollout Creates a new, empty rollout.

New Rollout Selected Parameters Creates a new rollout and populates it with
copies of any selected parameters.

Rename Rollout Opens a small dialog that lets you rename the selected rollout.
Delete Rollout Deletes the selected rollout.

Delete Rollout Move Up Deletes the selected rollout and moves its parameters
to the rollout above.

Delete Rollout Move Down Deletes the selected rollout and moves its
parameters to the rollout below.

Notes Dialog (Parameter Collector)

Parameter Collector » Select one or more parameters. » Parameter Collector
menu bar » Edit menu » Notes

Parameter Collector » Right-click a Parameter Select button.

The Notes dialog lets you enter a name, URL, and comments for one or more
selected parameters in Parameter Collector.

Choosing Notes from the Edit menu with multiple parameters selected opens
a single dialog common to all selected parameters. Right-clicking a Parameter
Select button opens a dialog for that parameter only.

When you open Notes from the Edit menu with multiple parameters selected,
if the text contents for a box in all selected parameters are the same (or null),
its check box is on, indicating that changes to the text will apply to all selected
parameters. If a text box has different contents for different selected parameters,
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the check box is off, and the corresponding text box is empty and unavailable,
preventing any changes. If you turn on a check box, you can edit the text,
and changes will be applied to all selected parameters.

Interface
Notes x|
¥ Parameter Mame:
I
¥ URL:
o |
v Motes:
QFE. Delete Cancel

The Notes dialog interface comprises three text boxes, each with its respective
check box, and a button. By default, the text boxes are empty; you can enter
any text into each box, although each has a specific purpose, as described
below.

Parameter Name Lets you change the parameter name shown in Parameter
Collector.

By default, the parameter name displayed in Parameter Collector is the same
as the name that appeared in the Track View Pick dialog when you added it
to Parameter Collector. If you enter a different name in the Notes dialog,
Parameter Collector then displays that name. The changed name is used only
in Parameter Collector; elsewhere, such as the Modify panel, it remains the
same as before.
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You can see the original parameter name, as well as the object to which it's
attached, by hovering the mouse over the parameter name in Parameter
Collector; the information appears in a tooltip.

URL Lets you enter a URL, such as www.discreet.com.

This could be a link to a Web or intranet page, or even a network location or
file pertaining to the selected parameter. To access the link, click the Go button.

Go If the URL text box contains a valid URL, clicking Go opens the URL in a
separate browser window.

Notes Contains any comments on the parameters. This field is strictly for
informational purposes.

Expression Techniques

In 3ds Max Design, you can use mathematical expressions (rather than constant
numbers) to express parameter values. For example, you could use the
expression 24*6 to represent the number 144.

You can use mathematical expressions to control the following object
properties:

B Object parameters, such as length, width, and height
B Transform and modifier values, such as an object's position coordinates
Parameter wiring on page 3649, the expression controller on page 3490, and the

numerical expression evaluator on page 8608 all use expressions, which are
described in this topic.

An expression is a mathematical function that returns a value. You can use
expressions to control the following scene elements:

Scene ele- Calculatable property
ment

Creation para-  Any numeric creation parameter

meters

Transforms Position [X, Y, Z]
X Rotation
Y Rotation
Z Rotation

Scale [X%, Y%, Z%]
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Scene ele- Calculatable property
ment

Modifiers Any numeric modifier parameter
(including creation parameters)

Materials Colors [R, G, B]
Any numeric material parameter

NOTE Expressions work only with the individual XYZ components of Euler rotation.
You can't assign an expression to TCB rotation or other kinds of rotation controllers.

The following links jump to sections within this topic:
B Expression Return Types on page 274

B Operators on page 275

W Variables on page 277
|

Functions on page 279

See also:
B Trigonometric Functions on page 282
B Vectors on page 285

B Expression Controller Techniques on page 3496

Expression Return Types

The type of value returned by an expression depends on the kind of controller:

B Float expressions return a floating-point scalar value (For example, 5.617).
Scalars are used in the animation controllers of numeric parameters.
If the parameter has an integer value, the expression rounds the float value
to the nearest integer.

B Position, Scale, and Point3 expressions return a three-component vector.
For example, [5, 18, 24]. The vector can represent an object's X,Y,Z location,
percent scaling in X, Y, and Z, or a color (RGB values) in a material.
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Operators

In the following tables, p and q are any scalar value or expression, V and W
are any vector value or expression. (The character "x" is used as the vector
cross-product operator.)

Scalar Operators
These are the arithmetic operators for scalar values:

Operator Use Meaning

+ p+q Addition

- p-q Subtraction

- -p Additive inverse

* p*q Multiplication

/ p/q Division

A prq power (p to the power of q)

*x p**q A and ** are the same operation

You can also use logical (Boolean) operators with scalar values. These operators
all return 1 if true, O otherwise:

Operator Use Meaning

= p=q equal to

< p<q less than

> p>q Greater than

<= p<=q less than or equal to

>= p>=q Greater than or equal to

| plq Logical OR, returns 1 if either p or g is

nonzero; otherwise, returns 0
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Operator Use Meaning

& p&q Logical AND, returns 1 if p and q are both
nonzero; otherwise, returns 0

TIP Logical operators are useful with the "if" function.

Vector Operators

For vectors that have a variable name, you can use a special component
operator (.) to refer to the three scalar components of the vector:

Use Meaning

V.x first component (X)

Vy second component (Y)

V.z third component (Z)

These are the operators for vector arithmetic:

Operator Use Meaning

+ V+W Addition

- V-W subtraction

* p*V scalar multiplication
* V*p scalar multiplication
* V*W dot product

X VxW cross product

/ V/p scalar division
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Operator Precedence

Expressions have eight levels of precedence. The higher the operator is on the
list, the earlier it is evaluated.

Operator Level of Precedence

-+ as unary operators, as in -8, +25

the component operator, as in V.x

*% A

X cross product

Parentheses are a special case. They are a grouping or subexpression operator
that is provided so you can override the precedence order of the other
operators.

Variables

In expressions you write for expression controllers on page 3490, variables are
represented by symbolic names. You create them to contain constant or
variable values in your expressions. Several predefined variables are also
provided. Some of these have a constant value, others can vary.

In expressions used for parameter wiring on page 3649 and the numerical
expression evaluator on page 8608, you can use predefined variables with
constant values.
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Predefined Variables with Constant Values

These are the predefined variables that have a constant value (variable names
are case-sensitive):

Variable Constant Use

Name Value

pi 3.14159 Ratio of a circle's circumfer-
ence to its diameter.

e 2.71828 Base of natural logarithms.

TPS 4800 Ticks per second. The tick

is the basic time unit of
3ds Max Design anima-
tion.

Predefined Variables with Variable Values

These are the predefined variables that have a variable, time-based value
(variable names are case-sensitive).

Variable  Meaning

Name

F Frame number. For each frame, F equals
the current frame number, counting
from zero. The range of frames can vary
depending on the number of frames in
the active time segment.

NT Normalized time. By definition, normal-

ized time (NT) ranges from 0 to 1 over
the active time segment, regardless of
how many frames are in the segment.
If you base an expression on NT, its ef-
fect happens exactly once over the
range. You can also multiply NT by a
factor for the expression's effect to occur
a certain number of times (for example,
2*NT causes the expression's effect to
occur twice). Expressions based on NT
speed up or slow down if you change
the length of the time segment.
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Variable  Meaning

Name

S Seconds (elapsed time in seconds).
Elapsed time is measured from the first
frame to the current frame. The range
of seconds can vary depending on the
total time of the active time segment.

T Ticks (elapsed time in ticks). There are

4800 ticks per second. Elapsed time is
measured from the first frame to the
current frame. The range of ticks can
vary depending on the total time of the
active time segment.

Rules for Variable Names

B Variable names can contain as many alphanumeric characters as you like.
Their length is not limited.

B Variable names cannot contain spaces.

B The variable name must begin with a letter. Numbers are valid within a
variable name (as in "Pos1" or "M23").

B Variable names are case-sensitive. For example, "pos", "Pos", and "POS"
designate three different variables.

B You can't create a variable with a name that duplicates another name,
including the variable names that are predefined.

Functions

Following is a list of the functions provided for expressions. In this list, p, q,
and r represent scalar values or scalar expressions. V and W represent vector
values or vector expressions.

To use a function in an expression, enter the name of the function and
appropriate arguments to it.
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Trigonometric Functions

The sine, cosine, and tangent functions take an angle in degrees and return
a floating-point value. The arc functions take a floating-point value and return
a value in degrees.

Function Meaning
sin(p) sine

cos(p) cosine
tan(p) tangent
asin(p) arc sine
acos(p) arc cosine
atan(p) arc tangent

Hyperbolic Functions

Hyperbolic functions take a floating-point value and return a floating-point

value.

Function Meaning

sinh(p) hyperbolic sine
cosh(p) hyperbolic cosine
tanh(p) hyperbolic tangent

Conversion Between Radians and Degrees

Function Meaning

radToDeg(p) takes p in radians and returns the same
angle in degrees

degToRad(p) takes p in degrees and returns the same
angle in radians
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Rounding Functions

Function Meaning
ceil(p) smallest integer greater than or equal to p
floor(p) largest integer less than or equal to p

Standard Calculations

Function Meaning

In(p) natural (base e) logarithm

log(p) common (base 10) logarithm

exp(p) exponential function exp(p)=e”p

pow(p,q) p to the power of q (p”q)

sqrt(p) square root

abs(p) absolute value

min(p,q) minimum returns p or g, depending on
which is smaller

max(p,q) maximum returns p or g, depending on
which is greater

mod(p,q) remainder of p divided by q

Conditional Functions

Function

Meaning

if(p then q else if r then s)

uses the standard “if/then/else if” structure.
For example:

if (X_Position<0) then 0 else if (X_Posi-
tion>=0 and X_Position<=10) then X_Posi-
tion*3 else 100

This returns O if the X position is less than
0, or the X position times 3 if the X posi-
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Function Meaning

tion is between 0 and 10 inclusive, or 100
if the X position is greater than 10.

The “else if” part is optional, and can be
repeated to specify several different condi-
tions if necessary.

vif(c,V1,V2) "Vector If" (Value is V1 if c is true, else V2.)

Vector Handling Functions

Function Meaning
length(V) length of V
comp(V,i) i'th component (1=0,1,2):

comp([5,6,7],1)=6

unit(V) returns a unit vector in the same direction
asV

NOTE The comp function is an alternative to the notation V.x, V.y, V.z.

Special Animation Function

Function Meaning
noise(p,q,r) 3D noise: returns a randomly generated
position

The arbitrary values p, q and r, are used as a random-generation seed. You can
reuse these values to ensure that noise() returns the same value.

Trigonometric Functions

This topic is a quick review for readers who need a reminder about this area
of mathematics. If you're familiar with trigonometry, you can skip this topic.
If you find this topic difficult to follow, you might consult a more basic
reference on mathematics.

Trigonometric functions are principally used to model or describe:

B The relation between angles in a triangle (hence the name).
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B Rotations about a circle, including locations given in polar coordinates.

B Cyclical or periodic values, such as sound waves.

The three basic trigonometric functions are derived from an angle rotating
about a unit circle.

¥

Trigonometric functions based on the unit circle

sinf = ¥ cogB = ® tane = £
T T i

The tangent function is undefined for x=0. Another way to define the tangent
is:

6 = sinf
ansh

tan

Because XYR defines a right-angled triangle, the relation between the sine and
cosine is:

(cos®) 4 (sin®)% = 1

The graphs of the basic trigonometric functions illustrate their cyclical nature.
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Graphs of basic trigonometric functions
The sine and cosine functions yield the same values, but the phase differs
along the X axis by /2: in other words, 90 degrees.

The inverse functions for the trigonometric functions are the arc functions;
the inverse only applies to values of x restricted by —-/2 X /2. The graphs for
these functions appear like the basic trigonometric function graphs, but turned
on their sides.
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Graphs of basic arc functions
The hyperbolic functions are based on the exponential constant e instead of

on circular measurement. However, they behave similarly to the trigonometric
functions and are named for them. The basic hyperbolic functions are:
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Graphs of basic hyperbolic functions

Vectors

This topic is a quick review for readers who need a reminder about vector

arithmetic. If you're familiar with vectors and vector calculations, you can
skip this topic. If this topic is difficult to follow, you might consult a more
basic reference on mathematics.

A vector expresses a length and a direction in a particular space. The vector
is expressed as a point; for example, [5, 5, 7]. The length is the distance from

the origin to that point, and the direction is similarly from the origin to (and
through) the point.

In 3ds Max Design, vectors have three values and describe positions in
three-dimensional space. They can also represent percent scaling in X, Y, and
Z; and (more abstractly) describe locations in RGB color space.
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Unit Vectors and Basic Vectors

A unit vector has a length of one. Unit vectors are often used to express
direction only. The three basic vectors are unit vectors that describe the three
axes (X, Y, and Z) of 3D space.

z y
(0,1,0)

(0,0,1)
(1,0,0)

Basic vectors and the XYZ axes

Adding and Subtracting Vectors

Adding two vectors creates a new vector that combines the length and direction
of the original two. Vector addition is commutative: V+W=W+V.

".r-'

1
|

"'\-f_."’fﬂ:y"! |'II
e (
L !
[
i -

Py

L W

Adding two vectors

VAW = [¥+ WL Vat+ W Vot Wa]
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Subtracting two vectors gives the vector between the two points.

C

V=2
\/2 /B
o
V1

A

Subtracting two vectors

V- = [?l—wl,?z—WE,va—Wa]

Scalar Multiplication and Division

Multiplying a vector by a scalar changes the vector’s length, as does dividing
the vector by a scalar.

FW = V¥ = [¥V, ¥V, ¥¥;]
VA = [V, T8y ]

Vector Length and Direction

The length of a vector is obtained from the Pythagorean theorem.

In 3ds Max Design expressions, the length() function returns this value.

The direction of the vector is the vector divided by its length; this gives you
a unit vector with the same direction.
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ki
V]
The distance between two points is the length of the vector between them.
W] = W -V

Subtracting vectors to
obtain a distance
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Creating Geometry W

The solid 3D objects in the scene, and the objects used to create them, are known as geometry.
Usually, geometry comprises the subject of your scene and the objects that you render.

Villa with a swimming pool was created using a variety of geometry.

This section describes the types of geometry you can create using the Create panel on page
8810.

See also:

B Surface Modeling on page 1967
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B Space Warps and Particle Systems on page 2923
B SAT Files on page 8348

Basics of Creating and Modifying Objects

This section provides an introduction to techniques for creating and modeling
objects.

The Create panel on page 8810 contains controls for creating new objects, the
first step in building a scene. Despite the variety of object types, the creation
process is consistent for most objects.

The Modify panel on page 8812 provides controls to complete the modeling
process. You can rework any object, from its creation parameters to its internal
geometry. Both object-space and world-space modifiers let you apply a wide
range of effects to objects in your scene. The modifier stack allows editing of
the modifier sequence.

In 3ds Max Design, you model basic parametric on page 9302 objects into more
complex ones by:

B Changing parameters on page 9302
B Applying modifiers

B Directly manipulating sub-object geometry

Varying the Parameters

Unlike physical objects, with a fixed shape and size, you can change the
creation parameters of objects and shapes to dramatically alter topology. Here
are some examples of changes you can make:

B Turn a cone into a four-sided pyramid by reducing the number of sides
and turning the Smooth option off.

B Slice any circular object as if it were a pie.

B Animate almost all creation parameters, and interactively change their
settings during animation playback.

B Render splines directly at any assigned width.

B Break, detach, and divide wall segments.
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B Change the number of risers without affecting the overall rise of the stairs.

Collapsing Primitives to Base Geometry

You can collapse a geometric primitive or shape to one of a variety of base
geometric types once you no longer need access to its creation parameters.

For example, you can convert any standard primitive to an editable mesh on

page 2192, editable poly on page 2242, editable patch on page 2376, or NURBS on
page 2459 object, and you can convert a spline shape to an editable mesh,
editable spline on page 554, or NURBS object. The easiest way to collapse an
object is to select it, right-click it, and choose a "Convert to" option from the

quad menu » Transform quadrant. This lets you use explicit editing methods

with the object, such as transforming vertices. You can also use the Modify

panel to collapse a primitive.

Mapping Coordinates

Most Geometry objects have an option for generating mapping coordinates.
Objects need these mapping coordinates if you plan to apply a mapped material
to them. Mapped materials include a wide range of rendered effects, from 2D
bitmaps to reflections and refractions. See Mapping Coordinates on page 6039
and Using Maps to Enhance a Material on page 6024. If mapping coordinates
have already been applied to an object, the check box for this feature is turned
on.

See also:

Using the Modify Panel on page 981

Using the Modifier Stack on page 985

Editing the Stack on page 989

Modifying at the Sub-Object Level on page 993
Using the Stack at the Sub-Object Level on page 996
Modifying Multiple Objects on page 998

How Instanced Modifiers Work on page 1002

Transforms, Modifiers, and Object Data Flow on page 973
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Using the Create Panel

The Create panel provides the controls for creating objects and adjusting their
parameters.

To access the Create panel:

o

1 Click " (Create tab) on the command panels on page 8809.

By default, this panel is open when you start 3ds Max Design. If the
command panel isn't visible, choose it from the Customize Display
right-click menu on page 8867.

2 Click an object type to display its Parameters rollout.

The Creation Process

The actual creation of objects is accomplished with a single click of the mouse,
a drag, or some combination, depending on the object type. This is the general
sequence:

B Choose an object type.

B Click or drag in a viewport to create an object of approximate size and
location.

B Adjust the object’s parameters and position, either immediately or later.
See Creating an Object on page 296.

Create Panel Interface

Controls in the Create panel vary depending on the kind of object you are
creating. However, certain controls are always present, and others are shared
by nearly all object types.

Category Buttons at the top of the panel access the seven main categories of
objects. Geometry is the default category.

Subcategory A list lets you select subcategories. For example, subcategories
under Geometry include Standard Primitives, Extended Primitives, Compound
Objects, Particle Systems, Patch Grids, NURBS Surfaces, and Dynamics Objects.

Object Type A rollout contains labeled buttons for creating objects in a
particular subcategory, plus the AutoGrid on page 2821 check box.
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Name and Color The Name shows the automatically assigned name of the
object. You can edit this name or replace it with another. (Different objects
can have the same name, though this is not recommended.) Clicking the
square color swatch brings up an Object Color dialog on page 300 to change
the color of the object as it appears in viewports (the wireframe color).

Creation Method This rollout provides a choice of how you use the mouse
to create an object. For example, you can use either the center (radius) or edge
(diameter) to define the size of a Circle shape.

A default creation method is always selected when you access the tool. If you
want to use an alternate method, choose the option before you create the
object. The creation method has no effect on a finished object; the options
are for your convenience during creation.

Keyboard Entry This rollout lets you enter creation parameters from the
keyboard for geometric primitive and shape objects.

Parameters This rollout shows creation parameters: the defining values for
an object. Some parameters can be preset, while others are only for adjustment
after an object has been created.

Other rollouts Additional rollouts can appear on the Create panel, depending
on what kind of object you create.

Identifying the Basic Building Blocks

On the Create panel, the categories for Geometry and Shapes supply the
"building blocks" to combine and modify into more sophisticated objects.
These parametric on page 9302 objects are ready to use. By adjusting values and
turning some buttons on or off, you can create dozens of "new" building blocks
from the ones listed here.

You can choose these types from the sub-categories list on the Create panel.

Geometry Types

Standard Primitives Relatively simple 3D objects such as Box, Sphere, and
Cylinder, as well as Torus, Plane, Cone, GeoSphere, Tube, Teapot, and Pyramid.

Extended Primitives More complex 3D objects such as Capsule, OilTank,
Spindle, Hedra, Torus Knot, and Prism.

Compound Objects Compound objects include Scatter, Connect, ShapeMerge,
Booleans, Morph, BlobMesh, Terrain, and Loft. Booleans combine the geometry
of two objects using union, intersection, and difference operations. Morphs

are animated objects that change one geometric shape into other shapes over
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time. ShapeMerge lets you embed a spline shape into a geometric mesh. Loft
on page 674 uses shapes as cross sections along a path to produce a 3D object.

Particle Systems Animated objects that simulate spray, snow, blizzard, and
similar collections of small objects.

Patch Grids Simple 2D surfaces ready for modeling or repairing existing
meshes.

NURBS Surfaces Analytically generated surfaces especially suited for modeling
surfaces with complicated curves.

AEC Extended Elements useful for AEC design, including Terrain, Foliage
(plants and trees), Railing, for creating custom railings, and Wall, for the
production of Wall objects.

Stairs Four types of stairs: Spiral, L-Type, Straight, and U-Type.
Doors Parametric door styles include Pivot, BiFold, and Sliding.

Windows Parametric window styles include Awning, Fixed, Projected,
Casement, Pivoted, and Sliding.

NOTE Default materials are automatically applied to Foliage, as well as to the
following object types: Railing, Stairs, Doors, and Windows.

Dynamics Objects Objects designed for use in dynamics simulations.

Shape Types

Splines Common 2D shapes such as a Line, Rectangle, Circle, Ellipse, Arc,
Donut, NGon, and Star. Text shapes support TrueType fonts. Section creates
a spline from the cross-section of an object. Helix is a 3D shape.

NURBS Curves A Point Curve and CV Curve provide the starting points for
complex surfaces. See Introduction to NURBS Modeling on page 2435.

Extended Splines More complex 2D shapes including Walled Rectangle,
Channel Spline, Angle Spline, Tee Spline, and Wide Flange Spline. Extended
splines can be used in architectural and similar applications.
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Varying the Parameters

Unlike physical building blocks, with fixed shape and size, you can change
the parameters of objects and shapes to dramatically alter topology. Here are
some examples of changes you can make:

B Turn a cone into a four-sided pyramid by reducing the number of sides
and turning the Smooth option off.

W Slice any circular object as if it were a pie.

B Animate almost all creation parameters, and interactively change their
settings during animation playback.

B Render splines directly at any assigned width.
B Break, detach, and divide wall segments.

B Change the number of risers without affecting the overall rise of the stairs.

Collapsing Primitives to Base Geometry

You can collapse a building-block object to one of a variety of base geometric
types once you no longer need access to its creation parameters. For example,

you can convert any standard primitive to an editable mesh on page 2192,
editable poly on page 2242, editable patch on page 2376, or NURBS on page 2459
object, and you can convert a spline shape to an editable mesh, editable spline

on page 554, or NURBS object. The easiest way to collapse an object is to select

it, right-click it, and choose a "Convert to" option from the quad menu »
Transform quadrant. This lets you use explicit editing methods with the object,

such as transforming vertices. You can also use the Modify panel to collapse

a primitive.

Mapping Coordinates

Most Geometry objects have an option for generating mapping coordinates.
Objects need these mapping coordinates if you plan to apply a mapped material
to them. Mapped materials include a wide range of rendered effects, from 2D
bitmaps to reflections and refractions. See Mapping Coordinates on page 6039
and Using Maps to Enhance a Material on page 6024. If mapping coordinates
have already been applied to an object, the check box for this feature is turned
on.
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Creating an Object

With some variations, the steps shown in the following images apply to
creating any type of object on the Create panel. For specific examples, see the
Procedures section in any object's topic.

1. Radius defined
2. Height defined
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3. Sides increased

4. Height Segments increased

To choose an object category:

1 Click .ﬁ

2 Click one of the buttons at the top of the Create panel. For example,

O

3 Choose the subcategory Standard Primitives from the list.

(Create tab) to view the Create panel.

(Geometry).

A number of buttons appear on the Object Type rollout.

To choose an object type:

B Click the button for the type of object you want to create.
The button highlights, showing that it is active. Four rollouts appear: Name
and Color, Creation Method, Keyboard Entry, and Parameters.

Creating an Object | 297



To choose a creation method (optional):
You can accept the default method and skip this step.
B Choose a method in the Creation Method rollout.

To preset the creation parameters (optional):
You can adjust all creation parameters after you create an object. Skip this step
if you prefer.

B [n the Parameters rollout, you can set parameters before you create an
object. However, the values of parameters you set by dragging the mouse
(for example, the Radius and Height of a cylinder) have no effect until
after you create the object.

To create the object:

1 Put the cursor at a point in any viewport where you want to place the
object, and hold the mouse button down (do not release the button).

2 Drag the mouse to define the first parameter of the object; for example,
the circular base of a cylinder.
3 Release the mouse button. The first parameter is set with this release.

In some cases, such as Sphere, Teapot, and Plane, this completes the
object. You can skip the remaining steps.

4 Move up or down without touching the mouse button. This sets the next
parameter; for example, the height of a cylinder.

If you want to cancel: Until you complete the next step, you can cancel the
creation process with a right-click.
5 Click when the second parameter has the value you want, and so on.

The number of times you press or release the mouse button depends on
how many spatial dimensions are required to define the object. (For some
kinds of objects, such as Line and Bones, the number is open-ended.)

When the object is complete, it is in a selected state and ready for adjustments.

To name the object (optional):

3ds Max Design gives each new object a default name based on the primitive
type and the order of creation. For example: Box001, Sphere030. You can
change the name to anything you like using the method described following.
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Also, to change the number of digits appended to the default object name,
edit the 3dsmax.ini on page 43 file as follows: add (if necessary) a section
named [Preferences| and in that section add the setting NameSuffixLength=#,
where # is the number of digits. For example, to use default names like
Box00123, add this:

[Preferences]

NameSuffixLength=5

B To rename an object, highlight the object name in the Name And Color
rollout, and then enter a name. This option is available only when a single
object is selected.

Naming objects is a good practice for organizing your scenes. To name a
set of selected objects, see Named Selection Sets on page 163.

To change the object’s display color (optional):

B The color swatch next to the object name field displays the selected object's
color and lets you select a new one. The color is the one used to display
the object in viewports. Click the color swatch to display the Object Color
dialog on page 300.

You can also change object colors with Layers on page 8574.

To adjust the object's parameters:

B You can change the creation parameters immediately after you complete
an object, while it’s still selected. Or, you can select the object later and
adjust its creation parameters on the Modify panel.

While making adjustments, you can use viewport navigation controls like
Zoom, Pan, and Orbit to change your view of the selected object. You can also
adjust the time slider.

To end the creation process:

While the object type button remains active, you can continue creating objects
of the same type until you do one of the following:

1 Select an object other than the one you created most recently.
2 Transform an object.

3 Change to another command panel.

4

Use commands other than viewport navigation or the time slider.
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After you end the creation process, changing parameters on the Create panel
will have no effect on the object; you must go to the Modify panel to adjust
the object’s parameters. See Using the Modify Panel on page 981.

Assigning Colors to Objects

3ds Max Design is a truecolor on page 9382 program. When you pick a color in
3ds Max Design, you are specifying 24 bits of color data, which provide a
range of over 16 million colors.

Object wireframe colors are used primarily as an organizational tool. Object
naming strategies, named selection sets, and object wireframe color strategies
provide a rich set of tools for organizing even the most complex scenes.

You can use two dialogs to specify colors:

B The Object Color dialog on page 300 contains two preset palettes of colors
that you use to set an object’s wireframe color. This is also the surface color
you see in a rendered viewport. The two color palettes are Default palette
and AutoCAD ACI palette.

m The Color Selector on page 304 is a generic dialog that you use to define
any color in the 24-bit color range. For the purpose of defining colors to
assign to objects, it is available only through the Default palette.

The Layers functionality lets you organize your scene and can also be used for
assigning object colors. For more information, see Manage Layers Dialog on
page 8574.

Object Color Dialog

Click the color swatch by the object's name in any command panel.

The Object Color dialog contains two preset palettes of colors that you use to
set an object’s wireframe color. This is also the surface color you see in a shaded
viewport.

Using Random Color Assignment

By default, 3ds Max Design assigns colors randomly as objects are created.
The colors are chosen from the current palette in the Object Color dialog. If
you turn on Customize » Preferences » General panel on page 8927 »
Default to By Layer for New Nodes, new objects are assigned the color set by
the layer.
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For individual objects, you can click the By Layer/By Object button on the
Obiject Color dialog to change the method used to set the object color.

Defining Custom Colors

When using the 3ds Max palette, the Object Color dialog contains a palette
of 16 custom color swatches. You can define any color for each of the 16 color
swatches by selecting a swatch from the Custom Colors group, then clicking
Add Custom Colors.

Switching Between Palettes

You can alternate between two versions of the Object Color dialog at any time
by clicking the appropriate Basic Colors toggle:

B 3ds Max palette: Contains a fixed palette of 64 colors, plus a custom palette
of 16 user-defined custom colors.
Use this version when you want to work with a smaller palette of colors
or when you want to define custom object wireframe colors.

B AutoCAD-compatible version: Contains a fixed palette of 256 colors
matching the colors in the AutoCAD Color Index (ACI).
Use this version when you want to assign object colors that match the
AutoCAD Color Index. Using ACI colors is useful if you plan to export
objects to AutoCAD and want to organize them by object color, or when
you want a wide selection of colors to choose from.

Procedures

To set object color:
This is the general procedure for selecting object color.
1 Select one or more objects.

2 On any command panel, click the color swatch to the right of the Object
Name field to display the Object Color dialog.

3 On the Object Color dialog, click the By Layer / By Object toggle to set
it to By Object.

4 Click a color swatch from the palette, and then click OK to apply the
color to the selection.
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To create objects of the same color:

B Choose the color you want to use and turn off Assign Random Colors.
Newly created objects appear in this color until you change the setting.

To define a custom color:

1 With the 3ds Max palette option active, click one of the 16 custom color
swatches.

2 Click Add Custom Colors to display the Color Selector on page 304.

3 Define a custom color and click Add Color.

The custom color is stored in the selected color swatch of the Object
Color dialog and is set as the current color.

To copy a custom color from an object in your scene to one of your custom
color swatches:

B Drag the Active Color swatch up to one of the custom color swatches.
The Active Color swatch is in the Object Color dialog, to the left of the
OK button.

To select objects by color:

s
[ Inl
m Click l—kl (Select By Color). This displays the Select Objects dialog on
page 184. All objects that have the same color as the current object are
highlighted in the list. Click Select.
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Interface
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Palette Choose one of these:

B 3ds Max paletteWhen chosen, the dialog displays Basic Colors and Custom
Colors groups, and you have the option to add custom colors.

B AutoCAD ACI paletteWhen chosen, the AutoCAD ACI palette is shown.
When you click a color, its ACI# is displayed at the bottom of the dialog.

Basic Colors A set of 64 default colors, available only when 3ds Max Palette
is active.

Custom Colors Displays 16 custom colors when 3ds Max Palette is active. To
choose a custom color, click its swatch. To define or change a custom color,
click its swatch and then click Add Custom Colors.

Add Custom Colors Available only when 3ds Max Palette is active. Clicking
this option displays the Color Selector on page 304, which allows you to modify
the currently selected custom color. If you click Add Custom Colors with a
basic color chosen, the dialog switches to the first custom color before opening
the Color Selector.

By Layer/By Obiject Sets the object's color by layer or by object. If color is set
by object, choosing a new color on the Object Color dialog changes the object's
wireframe color in viewports.

Assigning Colors to Objects | 303



ACI# Displays the ACI number for the selected color. Available only when
AutoCAD ACI palette is active.

(] ]
Er

k Select by Color Opens the Select Objects dialog on page 184 listing all
objects that use the current color as their wireframe color.

NOTE This button is available only if at least one object in the scene has the
Current Color as its wireframe color.

Assign Random Colors When on, 3ds Max Design will assign a random color
to each object created. When off, 3ds Max Design will assign the same color
to every object created until the color swatch is changed. This setting affects
wireframe colors only when By Object is turned on as the color method.

Active/Current Color Displays the active color (if no object is selected) or
current color. When you click the color swatch, the Color Selector dialog on
page 304 opens, where you can mix a custom color.

Color Selector Dialog

Any command panel » Name and Color fields » Click color swatch. »
Object Color dialog » Add Custom Colors button or Current Color swatch.

i
Material Editor » Click any color swatch.
Select or add a light object. » 1 Modify panel »

Intensity/Color/(Distribution/Attenuation) rollout » Click color or Filter
Color swatch.

Rendering menu » Environment » Environment and Effects dialog »
Click color swatch for Background, Tint, and Ambient components of Global
Lighting, and various components of atmospheric effects such as Fire, Fog,
and so on..

The Color Selector dialog lets you specify a custom color parameter in 3ds
Max Design. You can work simultaneously with three different color models
to help you zero in on the exact color you want.

You can use the Color Selector to specify many color parameters, such as light
colors, material colors, background colors, and custom object colors. (Another
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way to choose an object's viewport color is to use the predefined colors in the
Obiject Color dialog on page 300.)

In most contexts, the Color Selector is modeless on page 9268; that is, it remains
on the screen until you dismiss it, and you can use other controls or work in
a viewport while the dialog is still visible. In other contexts, the Color Selector
is modal, and you must close the dialog before proceeding.

The dialog is divided into three different color selection models. You can use
the controls for any model to define a color. The three color models are:

B Hue/Blackness/Whiteness (HBW)
The most prominently displayed and intuitive color model is the HBW
model. This model represents a natural, pigment-based way of mixing
color by starting with a pure color (hue) and then making it darker by
adding black, or lighter by adding white.

The main feature of the HBW model is a large square box displaying the
color spectrum. Across the top of this box you have the spectrum of pure
colors, or hue. Down the side of the box you see increasing levels of
blackness, making the color dark as you approach the bottom.

To the right of the color spectrum box is the Whiteness box, which controls
the amount of white in the color. Use higher positions to decrease the
whiteness, or lower positions to increase the whiteness.

B Red/Blue/Green (RGB)
The RGB model adjusts the mix of Red, Green, and Blue to define a color.
This model represents the way colored light can be mixed. This is additive
color mixing, as opposed to the subtractive color mixing for paint and
other pigments. You can adjust values using the color sliders, the numeric
fields to their right (via the keyboard), or the spinners to the right of the
numeric fields.

B Hue/Saturation/Value (HSV)
The HSV color model adjusts Hue, Saturation, and Value. Hue sets the
color; Saturation (labeled "Sat") sets the color's purity; and Value sets the
color's brightness, or intensity. You can adjust values using the color sliders,
the numeric fields to their right (via the keyboard), or the spinners to the
right of the numeric fields.

As you adjust the controls of one color model, the controls of the other two
models change to match. The color defined by the color model is displayed
in the right half of the Color Output box. The original color, before you began
making changes, is displayed in the left half.
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Procedures

To display the Color Selector:

1

3

Click the color swatch of a color parameter such as the color of a light
or of a material component.

NOTE The object color displayed next to an object's name on command
panels uses the Object Color dialog on page 300. On the Object Color dialog,
clicking the Active (or Current) Color swatch or the Add Custom Colors button
displays a Color Selector.

Make a color selection and click OK or Cancel, or the Close button (X).

If using the Add Color version of the Color Selector, be sure to click Add
Color first.

To revert to the original color, click Reset.

To choose the hue of a color, do one of the following:

1

2
3
4
5

Click anywhere in the Hue rainbow (the large, multicolored square).
Drag the Hue slider at the top of the rainbow.

Drag the Red, Green, and Blue sliders.

Drag the Hue slider.

Use the Red, Green, Blue, or Hue spinners.

To make a color lighter, do one of the following:

1

A L A W N
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Drag the vertical Whiteness slider (at the right of the Hue rainbow)
downward.

Drag the vertical Blackness slider (at the left of the Hue rainbow) upward.
Drag the Saturation (Sat.) slider to the left.

Use the Saturation spinner to decrease saturation.

Drag the Value slider to the right.

Use the Value spinner to increase the value.
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To make a color darker, do one of the following:

1 Drag the vertical Whiteness slider (at the right of the Hue rainbow)
upward.

2 Drag the vertical Blackness slider (at the left of the Hue rainbow)
downward.

Drag the Saturation (Sat.) slider to the right.
Use the Saturation spinner to increase saturation.

Drag the Value slider to the left.

A »n AW

Use the Value spinner to decrease the value.

To return to the original color:

B Click Reset.
The new color is replaced by the original color, and all parameter values
are reset.
To dismiss the Color Selector, do one of the following:
1 Click Close.
2 Click OK or Cancel.
3 Click the dialog's Close (X) button.

Interface
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Hue Define a pure color by dragging the hue pointer across the top of the
box.

Blackness Drag the blackness pointer down the side to darken the pure color
by adding black. You can also click or drag inside the box to change hue and
blackness at the same time.

Whiteness The vertical bar to the right controls the amount of whiteness.
The color set by the hue and blackness pointers is displayed at the top of the
bar and pure white at the bottom. Drag the whiteness pointer down to lighten
the color by adding white.

Red, Green, and Blue When a red, green, or blue slider is all the way to the
left, its numeric field contains 0; none of the color controlled by that slider
isused. If the slider is all the way to the right, the field reads 255; the maximum
amount of that color is being used.

The spinners to the right of each slider are another way of setting the red,
blue, or green component.

The colors in the sliders change to show an approximation of what the color
result will be if you move the slider to that location, without adjusting any
other color parameter.

Hue Sets the pure color. Locating the slider all the way to the left gives you
pure red. As you drag the slider to the right you move through the spectrum
of Red, Yellow, Green, Cyan, Blue, Magenta, and back to Red again. Hue is
more accurately represented as a color wheel rather than a linear slider. That
is why the Hue slider is red at both ends. Think of the hue range from O to
255 as being points on a circle where the numbers 0 and 255 are right next
to each other.

Saturation ("Sat") Sets the purity or strength of the color. A weak color, with
a saturation near 0, is dull and gray. A strong color, with a saturation near 255
is very bright and pure.

Value Sets the lightness or darkness of a color. Low values darken the color
toward black. High values lighten the color toward white. A value in the
middle, at a setting of 127, gives you the color defined only by hue and
saturation.

Color Output This pair of color swatches, below the Value slider, lets you
compare the new color, shown on the right, to the original color, shown on
the left.
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j Sample Screen Color Lets you pick a new color from anywhere on the
screen. After clicking this button, the mouse cursor changes to the eyedropper
icon shown on the button. While this cursor appears, use any of these methods:

B Click anywhere on the screen to replace the current color with the color
of the pixel under the lower-right corner of the cursor.

B Drag to continually update the current color with the color of the pixel
under the lower-right corner of the cursor. This makes it easier to make
sure you get the right color if the desired color area is small (say, a
one-pixel-thick line).

B At any time, press and hold Shift to average the current color with colors
the cursor moves over.
Instead of replacing the current color with the new sampled color,
smoothed sampling gradually mixes the sampled color with the current
color, giving a smoothed color transition during sampling. This is useful
for sampling noisy areas, where the variations in colors are accumulated
to provide a representative general color.

Unlike the other methods, releasing the left mouse button only does not
exit the sampler mode; you can move the mouse elsewhere (without
sampling) and then start dragging again to continue smoothed sampling
in other areas. Releasing Shift only returns to regular sampling. Releasing
both Shift and the left mouse button exits the sampler mode, returning
the mouse cursor and behavior to normal.

Sampling can occur under any conditions anywhere within any windows that
belong to the current instance of 3ds Max Design. To sample anywhere outside
of 3ds Max Design (for example, the desktop), drag the mouse from within
one of these 3ds Max Design windows.

The color sampler tool compensates for any gamma applied to the color
selector using the Customize » Preferences » Gamma And LUT on page
8958 » Affect Color Selectors option. This means that the color-corrected,
displayed sampled visual color in the color selector always matches the
on-screen visual color of the sampled location. If the gamma of the color
selector does not match the gamma of the sampled location, the true color
values (RGB/HSV) of the sampled color will differ from the true color values
of the sampled location. This behavior applies to both regular gamma and
Autodesk LUT gamma correction modes.

Reset Click to restore color settings to the original color.

OK Accepts any changes and closes the dialog.
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NOTE If you opened the dialog by clicking Add Custom Colors on the Object
Color dialog, the button label reads “Add Color.”

Cancel Restores the original color and closes the dialog.

Color Selector for mental ray Materials and Shaders

When you click a color swatch in the interface for a mental ray material on
page 6258 or mental ray shader on page 6842, or a DirectX material on page 6631,
you see a variant of the Color Selector.

Color Selector: k_a
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This dialog differs from the standard Color Selector in two ways:

B The RGB and HSV values appear as normalized values between 0.0 and
1.0, rather than as 8-bit integers (0-2535).

B An additional Alpha slider and spinner let you explicitly set the alpha
value for this color. This value is also normalized, where 0.0 represents
fully transparent, and 1.0 represents fully opaque.

This version of the Color Selector also appears when you use the DirectX
Shader material on page 6631 and the mental ray renderer's Sampling Quality
rollout on page 7225.

Color Clipboard Utility

Tools menu » Color Clipboard
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Utilities panel » Utilities rollout » Color Clipboard button

The Color Clipboard utility stores color swatches for copying from one map
or material to another.

For example, if in the Material Editor, you want to copy a color from a swatch
in one level of a material to a swatch in another level (or from another
material), there would be no way to do it with drag and drop. This is because
you can't have two materials/maps visible at the same time. However, you
can drag the color from one material to the color clipboard, switch to the
other material, and then drag the color from the clipboard to the swatch in
the new material.

You can save and load color clipboard files. The saved file, which is given a
.ccb (color clip board) extension, is an ASCII file that contains a palette
description. The first 12 lines of the file consist of three RGB numbers, so you
can easily edit or create your own clipboard files. This file format is also used
by the VertexPaint modifier on page 1913.

Procedures

To copy a color from a swatch to the color clipboard:
1 On the Utilities panel, click Color Clipboard.
2 Open the Material Editor.
3 Select a color from any swatch in a material.
4 Drag the color to a swatch in the color clipboard.
5

A dialog appears asking if you want to copy or swap the material. Choose
copy to replace the swatch in the color clipboard with the swatch from
the material you selected. Choose swap to swap colors on the Color
Clipboard swatch and material swatch.

Assigning Colors to Objects | 311



Interface

'E Color Clipboard |

I
_ /.

MHew Floater |
Cloze

Color swatches Click a color swatch to edit its value with the Color Selector.

NOTE The Color Selector invoked by this utility uses decimal numbers in the range
0.0 to 1.0, instead of integers in the range 0 to 255 as with other color-selection
dialogs in 3ds Max Design.

New Floater Displays a floating clipboard with 12 slots, plus buttons for
opening and saving color clipboard files. You can open up as many of these
floaters as you want and you can minimize them. If you exit the Utilities panel
or select the Close button to exit the Color Clipboard utility, any visible floaters
remain open. When you close a floater, any changed values are lost.

Color Clipboard - 0] x|

Open... | Save |Sa\-'e.-’-'-.s...|

Close Exits the Clipboard utility.

Adjusting Normals and Smoothing

In general, you adjust normals and smoothing to prepare objects for rendering.
A normal on page 9281 is a unit vector that defines which way a face or vertex
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is pointing. Smoothing groups define whether a surface is rendered with sharp
edges or smooth surfaces.

The direction in which a normal points represents the front, or outer surface
of a face or vertex, which is the side of the surface that is normally displayed
and rendered. You can manually flip or unify face normals to fix surface errors
caused by modeling operations or by importing meshes from other programs.

Smoothing groups are numbers assigned to the faces of an object. Each face
can carry any number of smoothing groups, up to the maximum of 32. If two
faces share an edge and share the same smoothing group, they render as a
smooth surface. If they don’t share the same smoothing group, the edge
between them renders as a corner. You can change and animate smoothing
group assignments manually. Changing smoothing groups does not alter
geometry in any way: it simply changes the way faces and edges are shaded.

Viewing and Changing Normals

When you create an object, normals on page 9281 are generated automatically.
Usually objects render correctly using these default normals. Sometimes,
however, you need to adjust the normals.

Left: The normals shown as spikes indicate the orientation of faces on the pyramid.
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Right: Flipping normals can make faces invisible (or visible) in shaded viewports and
renderings.

Undesired normals can appear in these objects:
B Meshes imported from other applications.

B Geometry generated by complex operations such as Boolean objects, lathe
objects, or lofts.

Normals are used to define which side of a face or vertex is considered the
"out" side. The out side of a face or vertex is the side that gets rendered unless
you are using two-sided materials, or turn on the Force 2-Sided option in the
Render Setup dialog » Common panel » Common Parameters rollout on
page 7056.

Do one of the following to view or change face normals:

B Apply a Normal modifier on page 1499. If a Face sub-object selection is active,
Normal applies to the selected faces. If no faces are selected, Normal applies
to the entire object.

B Apply an Edit Mesh modifier on page 1265, enable Face, Polygon or Element
sub-object mode, and then use the features on the Surface Properties rollout
to change the directions in which normals point.

m Convert the object to an editable mesh on page 2192, enable Face, Polygon
or Element sub-object mode, and use the features on the Surface Properties
rollout

Viewing Normals

The easiest way to view normals is to look at an object in a shaded viewport.
In this case, you are not viewing the normal arrows themselves, but rather

their effects on the shaded surface. If the object looks as if it is inside-out, or
has holes, then some of the normals might be pointing in the wrong direction.

You can display the normal vectors for selected faces or vertices by enabling
Show Normals on the Selection rollout of an editable mesh object or the Edit
Mesh modifier.

Unifying Normals

Use Unify Normals to make normals point in a consistent direction. If an
object has normals that are inconsistent (some point outward and others
inward) the object will appear to have holes in its surface.
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Unify Normals is found on the Surface Properties rollout and on the Normal
modifier.

If you are animating the creation of a complex object such as a nested Boolean
or a loft, and you think the operation might result in inconsistent faces, apply
a Normal modifier on page 1499 to the result, and turn on Unify Normals.

Flipping Normals

Use Flip Normals to reverse the direction of all selected faces. Flipping the
normals of an object turns it inside-out.

Flip Normals is found on the Surface Properties rollout and on the Normal
modifier.

The Lathe modifier on page 1420 sometimes creates an object with normals
pointing inward. Use the Flip Normals check box on the Lathe modifier's
Parameters rollout to adjust the normals. You can also use the Normal modifier
with both Unify and Flip turned on to fix inside-out lathed objects.

Viewing and Changing Smoothing

Smoothing blends the shading at the edges between faces to produce the
appearance of a smooth, curved surface. You can control how smoothing is
applied to a surface so your objects can have both smooth surfaces and sharp,
faceted edges where appropriate.
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The face labeled “1-2” shares smoothing groups with adjacent faces, so the edges
between them are smoothed over in renderings.

The face labeled “3” does not share a smoothing group, so its edge is visible in
renderings.

Smoothing does not affect geometry. It affects only the way geometry is colored
when rendered.

Smoothing is controlled by smoothing groups, which are numbered groups
ranging from 1 to 32. You can assign each face to one or more smoothing
groups. When a scene is rendered, the renderer checks each adjacent pair of
faces to see if they share a smoothing group, and renders the object as follows:

W [f faces have no smoothing groups in common, the faces are rendered with
a sharp edge between them.

B If faces have at least one smoothing group in common, the edge between
the faces is “smoothed”, meaning it is shaded in such a way that the area
where the faces meet appears smooth.

Because each face has three edges, only three smoothing groups can be in
effect for any face. Extra smoothing groups assigned to a face are ignored.
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Do one of the following to view or change smoothing group assignments:

B Turn on the Smooth check box on the Parameters rollout of a parametric
object to set default smoothing for the object.

B Turn on the Auto Smooth check box on the Rendering rollout of a spline
shape to turn on smoothing.

B Apply a Smooth modifier on page 1685. If a Face sub-object selection is active,
Smooth applies to the selected faces. If no faces are selected, Smooth applies
to the entire object.

B Convert the object to editable poly on page 2242 format or apply the Edit
Poly modifier on page 1276, access the Polygon or E