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Introduction

1

Welcome, and congratulations! You’ve just bought a ticket to the world of Autodesk® 3ds
Max Design®. Hang on and get ready for the ride of a lifetime! With 3ds Max Design, you can
create 3D places and characters, objects and subjects of any type. You can arrange them in
settings and environments to build the scenes for your movie or game or visualization. You
can animate the characters, set them in motion, make them speak, sing and dance, or kick
and fight. And then you can shoot movies of the whole virtual thing.

Vitruvio 3D
Carlos Mario Vivares Arias

You can use 3ds Max Design to visualize designs of real things that will actually be built, such
as buildings and machines. The File Link feature of 3ds Max Design lets you base visualizations

1

on designs created in AutoCAD® or Autodesk Revit® Architecture: When the design changes
in these other applications, the revisions can be automatically updated in your 3ds Max
Design scene. Add lighting and materials, then render to still image or movie formats.
These tutorials teach 3ds Max Design through a series of hands-on exercises. Prepare to be
entertained and fascinated by the awesome power at your fingertips.

Acknowledgements
Special thanks are due to a number of hardworking and talented individuals who helped
create this volume of tutorials. A tip of the virtual hat to:
■

All those customers and users who have allowed us to showcase their artwork, whether
in the User Showcase on page 5 section or elsewhere in the help and tutorials.

■

All those who have contributed models and methods used in these tutorials, including
Mark Gerhard (Revolving Door and Set Key animation), Jon McFarland (CAD model),
Amer Yassine (models, methods, and artwork too numerous to list). There are other
contributors whose names aren’t available: We apologize for omitting them, and thank
you for your help as well.

Where to Find the Tutorials
The Tutorials link on the Help menu takes you to the HTML tutorials. These
are located on the Web at www.autodesk.com/3dsmaxdesign-tutorials-v2011.

Where to Find Tutorial Files
To access the scenes and other resource files you need to complete the 3ds
Max Design tutorials, go to
www.autodesk.com/3dsmaxdesign-tutorials-scene-files-v2011.

How to Learn 3ds Max Design
Besides the tutorials found in this collection, a number of other resources are
available to help you learn 3ds Max Design. In particular, consider the online
Help file an important adjunct to the tutorials; if you encounter a feature
you'd like to learn more about, look it up in the 3ds Max Design Help. There
you'll find general descriptions, detailed descriptions of all the controls, usage
notes and tips, and procedures for accomplishing various tasks.

2 | Chapter 1 Introduction

Yesterday, The Lost Time
Zhelong Xu

Autodesk 3ds Max Design 2011 Documentation Set
■

Autodesk 3ds Max Design 2011 Help: The online help covers fundamental
concepts and strategies for using the product, as well as details about the
features of 3ds Max Design.
Access the reference online by choosing Help > Autodesk 3ds Max Design
Help.

■

Additional Resources: A number of additional help files are installed with
the software and are available from the Help > Additional Help menu.

3ds Max Design on the Web
Links to the following Web sites are available from the Help menu within 3ds
Max Design. These pages provide access to a wide range of product information
and support resources: searchable Knowledgebase, FAQs, technical bulletins,
tested hardware information, and product downloads.
■

Online Support

■

Updates

■

Resources

■

Partners

■

Training

How to Learn 3ds Max Design | 3

Autodesk Training Information and Resources
■

Learning Path: Autodesk provides you with a single access point to an
interface overview, discussion groups, essential skills movies, technical
support, training resources and more. To access the this site, go to:
http://www.autodesk.com/3dsmaxdesign-learningpath.

■

Training Resources on the Web: You’ll find additional training resources
for 3ds Max Design at http://www.autodesk.com/3dsmaxdesign-training.

■

Other Resources: There is a wealth of information written about using 3ds
Max Design. There are third-party books that specialize in teaching the
software for various industries. There are magazines devoted to 3D design
and animation, as well as user groups and mail lists. Communities of users
trade secrets daily, and if you ask a question, you're likely to get answers
from experts all around the world.

Some of the above programs or contact details might not be available or
applicable in your country. Please check with your local Autodesk Authorized
Reseller or Autodesk office for details.

Browsing the HTML Tutorials
The title bar of each tutorial page contains both browse buttons and contextual
links.
You can use the three buttons in the upper-right corner of the page to browse
the tutorials. The button with the left arrow goes to the previous page, and
the button with the right arrow goes to the next page. The upward-pointing
arrow goes to the parent page; if there is no parent, this button is blank.

When you move your cursor over one of these buttons, the browser displays
the name of the page that the button points to.

4 | Chapter 1 Introduction

The other three buttons at the upper right of the title bar provide additional
controls:

■

Show in ContentsUpdates the Contents panel at the left to show
the page you are reading.

■

Add to FavoritesCreates a bookmark to this page on the Favorites
panel at the left.

■

Home: Autodesk 3ds Max Design TutorialsGoes to the graphic
Welcome page.

In addition, a series of links appear above the topic title. These show the path
of the topic within the 3ds Max Design tutorials.

The first link on the left is the chapter (top-level page) that contains the page
you are reading. If there are additional container pages, these appear in order
after the chapter link. Click any one of these links to go directly to the topic
it names.

User Showcase
In the 3ds Max Design tutorials, we teach you the tools to use the software.
Put those tools in the hands of talented artists and magic happens.
Here is a gallery of images by creative individuals from around the world using
this software. We hope you find these images inspiring before you set out on
your journey of learning 3ds Max Design.

User Showcase | 5

ando
Chen Qinfeng
www.chen3d.com

Vancouver Airport (YVR) Pier Expansion –View from New Arrivals / Departures Gate
37 toward existing Domestic Terminal Building
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Michael W. Sullivan, CTech c/o Bush, Bohlman & Partners, Consulting Structural
Engineers, Vancouver, B.C., Canada (www.bushbohlman.com)

Kings Cross Atrium, “The Great Hall”
Jamie Cardoso, GMJ Design Ltd

User Showcase | 7

Office Floor
Jamie Cardoso, GMJ Design Ltd

Vitruvio 3D
Carlos Mario Vivares Arias
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Malaval Habitations, Marseille
Annie-Claude Sauvé and Éa Sauvé-Brown

User Showcase | 9

Image credit: Marc Heesterbeek
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Image credit: Juan Altieri
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Image credit: Akihiko Tarutani
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Castle – Residential Project
Delta Tracing
Copyright © 2008
www.deltatracing.com
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Image credit: Juan Altieri
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Image credit: Michael Munson
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Image credit: Chen Qingfeng
www.chen3d.com
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Image credit: Yoshimasa Shimizu
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Ice Cubes
José Manuel Elizardo, Autodesk, Inc.
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A Living Room
Frances Gainer Davey
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Old Courtyard
Pradipta Seth
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Student Breakfast
Jean-Yves Arboit, Belgium
www.cgitrainer.com
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by Ben Paine

Environment
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Thilan Harshadhamma

Sommar Torp: "Summer House"
Sören Larsson, Sweden

Yesterday, The Lost Time
Zhelong Xu
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All images are copyright. Reproduction and distribution is not permitted
without the owner's permission.
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Getting Started: Modeling
a Revolving Door

2

In this tutorial, you will learn how to model and animate in 3ds Max Design. You’ll construct
an animated revolving door for a hotel lobby. In the course of doing so, you'll learn about
creating objects and transforming them. You'll learn about using snaps and pivot points for
alignment, as well as general user-interface navigation skills. You'll learn to instance objects
and link them into an animated hierarchy. You'll also learn to merge files together.

25

After completing this tutorial, you will be able to:
■

Have a working knowledge of the 3ds Max Design user interface.

■

Create a revolving door by using primitive and AEC objects.

■

Apply materials to objects and sub-objects.

■

Animate the doors in the scene using rotation transforms and parametric animation.

■

Merge objects from another file into your scene.

Skill Level: Beginner
Time to complete: 1 hour

Setting Up Units and Snaps
Before you start to build your revolving door, you will set the display unit
scale to feet and inches. You'll also make some changes to the snap options
before you create the geometry.
Set up the display unit scale:
NOTE If you're using the product outside of the United States, you can choose
to use metric display unit scale in the following steps. What's important is that the
scale be a real-world measurement, rather than the default Generic Units setting
in 3ds Max Design.

1 From the
Design.

Application menu, choose Reset to reset 3ds Max

This tutorial does not require you to load any particular file to begin. As
you work through it, if you get lost you can open a “snapshot” scene, so
you can complete the tutorial.
2 On the menu bar, choose Customize ➤ Units Setup.
The Units Setup dialog appears.
3 In the Display Unit Scale group, choose US Standard, if necessary.
Set the scale to Feet w/Decimal inches, if necessary.
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NOTE Leave the System Unit Setup as it is. This should be changed only to
reset the system unit to the default setting (inches) after loading a file that
uses a different system unit, or if you are working on files that are so huge or
so tiny that values don't appear correctly in the numeric entry fields.
4 Click OK to accept the change.
Now, when you make something, its measurements are displayed in the
command panels in familiar real-world terms.
Next you'll make some additions to the grid and snap settings.
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Set up snaps:

1 On the main toolbar, right-click

(3D Snaps Toggle).

3ds Max Design opens the Grid And Snap Settings dialog.
2 On the Snaps panel, turn on Grid Points, Vertex, Edge/Segment, and
Endpoint. Make sure all the other snaps are turned off.

3

Close the dialog.
Now, when Snap is on, you'll be able to snap to vertices, grid points, and
edges.
You're ready to create a cylinder to serve as the central pole that rotates
the revolving door.

Save your work:

■

On the Quick Access toolbar, click
as my_revolving_door_units.max.

(Save File), and save your file
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Creating the Hub
Using the Cylinder object, you will create a central pole that will act as the
hub for the revolving door. First you will create a new layer for the revolving
door.
Set up the lesson:
■

Continue with the scene from the previous lesson, or on the Quick Access

toolbar, click
(Open File), navigate to the the startup folder, and
open revolving_door_hub.max. If you do start with this file, be sure to set
up the snaps as described in the previous lesson.
NOTE If a dialog asks whether you want to use the scene’s Gamma And LUT
settings, accept the scene Gamma settings, and click OK. If a dialog asks
whether to use the scene’s units, accept the scene units, and click OK.

Create a layer:
You can use the layer-management system for display and rendering purposes.
Here you will create a new layer for the revolving door.
1 By default, the Layers toolbar is hidden when you start 3ds Max Design.
If it is not currently open, right-click a blank space on the main toolbar
and choose Layers from the pop-up menu.

2 On the Layers toolbar, click

(Create New Layer).

This creates a new layer and opens the Create New Layer dialog.
3 Use the Create New Layer dialog to name the Layer Revolving Door, and
then click OK.

The Revolving door layer is now current and visible in the Layers toolbar.
Whatever you create now will be on this layer.
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Create the hub:
Before creating the hub, you will adjust your viewport so you have a better
view of the objects you will make.
1 In the viewport navigation controls at the lower-right corner of the 3ds

Max Design window, click
(Orbit). In the Perspective viewport,
drag within the navigation orb to change the view of the home grid so
you have a view that is closer to ground level. When you are done,
right-click the viewport to turn off Orbit.

Orbit navigation orb

2 On the main toolbar, click

(3D Snap Toggle) to turn it on.

3 On the
Create panel, click
(Geometry). Make sure
Standard Primitives is chosen in the drop-down list, then on the Object
Type rollout, click Cylinder.
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The Cylinder button highlights to indicate it is active and ready for use.

4 Now move your cursor over the grid in the viewport.
The cursor displays a blue snap icon and jumps to the grid points.
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5 Position the cursor over the center of the grid and then click and drag.
As you move the mouse away from the center, a flat shaded circle grows
from your cursor. You are defining the radius of the cylinder as you move
the mouse.
Notice that as you move away from the center of the grid the mouse will
snap to grid points.

6 Turn off the snap by pressing the S on the keyboard while you are still
moving the cursor.
The snap has been turned off, while you are still in the middle of creating
the cylinder. Now as you move your mouse, you are free from the snap
control.
7 Lift the mouse button, and you have set the radius of the cylinder. The
radius is displayed on the Parameters rollout.
8 Now move your cursor upward in the viewport.

32 | Chapter 2 Getting Started: Modeling a Revolving Door

9 The cylinder grows as you move the cursor upward. When you click again
you have set the height.
Make the cylinder any size you like. You're going to change the size in
the next step.
Adjust the hub:
Immediately after creating an object, you can modify its parameters such as
size and shape by changing its values on the Parameters rollout on the Create
panel.
TIP If while changing these values you accidentally exit create mode (say, by
right-clicking the viewport), the object remains selected but its parameters are no
longer available on the Create panel. At this (or any) point you can go to the

Modify panel and adjust the parameters there, or you can simply
undo the new object (Ctrl+Z) and start over. If that happens during this tutorial,
we recommend the latter.
1 On the Parameters rollout change the Radius value to 0' 3.0".
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2 Change the Height to 7' 0.0".

3 In the Navigation controls, click

(Zoom Extents).

The viewport zooms so you can see the entire cylinder.

Zoom extents to see it all

4 Click the Perspective viewport Shading menu (at present labeled “Smooth
+ Highlights”), and choose Edged Faces.
The Edged Faces option lets you see the edges that 3ds Max Design uses
to create the surfaces of your model.
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Edged faces show the underlying geometry

5 On the Parameters rollout, change Height Segments to 1.
6 Change Sides to 4.
The Cylinder changes into a tall box with four sides; this will make it
easier to create the door. Later you'll change the pole back to a cylinder.

Creating the Hub | 35

Reduce the segments

Next you'll rotate the cylinder so the four sides line up with the grid.
Rotate the hub:

1 Click
(Zoom) in the viewport navigation controls. Position the
cursor over the bottom of the cylinder and then press I (the letter “I”) on
the keyboard to center the viewport on the cursor position.
2 Zoom in so you can see the bottom of the cylinder up close. Use Orbit
to rotate the view if you like.
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Zoom in and rotate the view.

3 On the toolbar, click

(Select And Rotate).

The transform gizmo appears in the viewport.
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4 In the coordinate display below the Perspective viewport, click in the Z
entry field and enter 45. Press Enter to confirm the entry.
The cylinder rotates around the Z axis so the sides line up with the grid.
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Cylinder rotated

This will be the pole that revolves to turn the revolving door. You'll snap
to its sides when you create an initial Pivot door object. After the other
doors are cloned, you can increase the number of sides so it will look like
a cylinder again.
Next you will create a tube object to make the door enclosure.
Save your work:

■

From the
Application menu, choose Save As, and save your
scene as my_revolving_door_hub.max.
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Creating the Enclosure
You will use the primitive Tube object with the Slice option to create an
enclosure for the revolving door.
Set up the lesson:

1 Continue with your scene from the previous lesson, or
revolving_door_enclosure.max from the startup folder.

open

2 Right-click the Perspective viewport to activate it, and then click
(Maximize Viewport Toggle). This button is at the extreme lower right
of the 3ds Max Design window.
Create another layer:

1 On the Layers toolbar, click

(Create New Layer).

This creates a new layer.
2 Name the Layer Enclosure.
The Move Selection To New Layer setting should be off. If you leave this
on, the hub will be moved from the previous layer to the new layer.
Click OK.
The Enclosure layer is now visible in the Layer Properties field.
Create the tube:

1 On the navigation controls, click
(Zoom Extents) to zoom back
so you can see the area around the cylinder.

2 On the

Create panel ➤ Object Type rollout, click Tube.

The Tube button highlights, indicating it is active and ready for use.
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3 Drag out a tube anywhere in the viewport.
The size doesn't matter; you'll be changing it in a moment.

Make a tube.
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4 In the Parameters rollout on the Create panel, change Radius 1 to 6' 0.0".
5 Change Radius 2 to 5' 11.0"
6 Change Height to 7' 0.0".

Change the radius and height of the tube.

7 If necessary, zoom out so you can see both the tube and the cylinder.
Align the tube:
Next, you'll center the tube over the cylinder.

1 On the toolbar, click

Align.

The tube is already selected, so you'll align it to the cylinder.
2 Click the cylinder in the viewport.
3 In the Align Selection (Cylinder01) dialog ➤ Align Position (World)
group, turn on X Position, Y Position, and Z Position. Choose Pivot Point
for both Current Object and Target Object. Click OK.
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The tube is centered over the cylinder.
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On the
Create panel, in the Name And Color group, rename the
Tube object left enclosure panels.
Slice the tube:

1 Go to the

Modify panel.

2 On the Parameters rollout, turn on Slice On.
3 Adjust the Slice From and Slice To values so you have a half of a tube
visible in the viewport, resembling the illustration. Start with 90.0 and
–90.0, and adjust if necessary. The difference between the two values
should be 180.
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Slice the tube

4 Change Sides to 6. The enclosure will be created out of flat panels, rather
than curved glass.
5 Change Height Segments to 1.
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Lower the number of faces.

Next you'll clone the tube to create the other side of the enclosure.
Clone the tube:

1 On the main toolbar, click

(Select And Rotate).

2 On the keyboard, press A to turn on Angle Snap.
3 Hold down the Shift key and rotate the left enclosure 180 degrees about
the Z axis.
A copy of the tube rotates into place on the other side of the enclosure.
4 When the copy of the tube is in the proper position, release the mouse
button.
3ds Max Design opens the Clone Options dialog.
5 On the dialog, set the Object option to Copy and name the clone right
enclosure panels. Click OK.
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6 Adjust the Slice values so the tube resembles the illustration below. Try
setting Slice From = 45 and Slice To = –45.0.
Depending how you constructed the initial tube, you might have different
values. The difference between the two should be a multiple of 90.
7 Change the Sides value to 3.
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Left and right enclosures

You'll do some more work on the enclosures in a while, but first you'll
construct the revolving door.
Save your work:
■

Save the scene as my_enclosure.max.

Creating the Revolving Door
To create the revolving door, you will rotate the right enclosure panel
temporarily into a different position, then you will create a pivot door using
snaps between the hub and the right enclosure panels. You edit the material
on the door, then instance the door to create a wheel of four doors.

■

Continue from the previous lesson, or
\startup folder.

open add_door.max in the
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Rotate the right enclosure:

1

Select the right enclosure panels object in the viewport.

2 On the main toolbar, click
(Select And Rotate), and then move
your mouse over the Transform gizmo tripod in the viewport. When the
Z axis (the horizontal blue circle) is highlighted, click and drag to rotate
the right enclosure panels object 45 degrees about the Z axis until it touches
the left enclosure panels object, as shown below.
As you rotate, you can see the rotation amount in yellow text in the
viewport, just over the transform gizmo. To get the desired result, it
should read (0.00, 0.00, 45.00).

Rotate the right enclosure.

This rotation is temporary, for the purpose of modeling only.
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Create a new layer:
1 On the Layers toolbar, click Create New Layer.
2 Turn off Move Selection To New Layer and name the layer Doors.
3 Click OK.
The Doors layer is now visible in the Layer Properties field on the Layers
toolbar.

Create a door:
1 Right-click any of the Snap buttons on the main toolbar, or from the
menu bar choose Tools ➤ Grids And Snaps ➤ Grid And Snap Settings.
3ds Max Design opens the Grids And Snap Settings dialog.
2 On the Snaps panel, click Clear All, then turn on Vertex, Edge/Segment,
and Midpoint.

Close the dialog.
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NOTE Even though you've changed the snap settings, you still need to turn
on snapping.
3 Press S to turn on snapping.
On the main toolbar, the 3D Snap button highlights.

4 On the
Create panel, click the arrow on the drop-down list and
choose Doors. On the Object Type rollout, click Pivot.

On the Create panel, the Pivot button highlights, and the pivot door
Parameters rollouts appear.
5 In the Perspective viewport, move your cursor over the cylinder in the
center.
You can see the blue snap icon that follows the edges of the cylinder as
you move.
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6 Position your cursor so you are snapping to the bottom-right edge of the
cylinder.
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7 Drag to the right, away from the cylinder, keeping the mouse button
depressed. Snap to the front of the right enclosure object. Release the
mouse button to set the width of the door.
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Snap to the right enclosure.

8 Press S to turn snaps off.
9 Without moving the mouse, click to set the depth of the door, and then
move the mouse upward to adjust the height of the door. Click to set the
height.
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Set the Height last.

Adjust the door parameters:
Immediately after clicking to set the height, make the following parameter
adjustments, watching the effects in the viewport. You can adjust these
parameters at any time in the future using the Modify panel.
1 In the Frame group, turn off Create Frame.

The frame disappears from the door.
2 On the Leaf Parameters rollout, increase the Stiles/Top Rail value to 0'
5.0”.
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3 Set the Bottom Rail parameter to 1' 6.0".
4 Adjust the width of the door so it fits inside the enclosure. If necessary,
adjust the height and depth as well.

Rotate the enclosure:

1

Select the right enclosure panels object: the one you rotated earlier
in this lesson.

2

Rotate the sliced tube back into place; that is, –45 degrees on
the Z axis.
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TIP If you prefer, you can enter the rotation in the coordinate display on the
status bar.

3 If the pivot door is sticking through the enclosure after you rotate it,

select the pivot door, and on the
so it fits within the space properly.

Modify panel, reduce its width

Add struts to the enclosure:
You'll use a Lattice modifier to add struts to the enclosure. The glass panels
will be held up by stout uprights that you will create next.
1 On the Layers toolbar, choose the Enclosure layer from the drop-down
list.

2 On the Layers toolbar, click

(Select Objects In Current Layer).
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This selects both enclosure objects and deselects any other objects.
3 On the menu bar, choose Edit ➤ Clone.
4 Choose Object group ➤ Copy, and click OK.
3ds Max Design makes copies of the two enclosure objects and selects
the copies.
5 On the menu bar, choose Modifiers ➤ Parametric Deformers ➤ Lattice.
3ds Max Design applies the Lattice modifier to the enclosures.
6 In the Parameters rollout ➤ Geometry group, choose Struts Only From
Edges.
The right and left enclosure panels now are held up by struts.
7 Adjust the Struts parameters so that:
■

Radius=0' 1.0"

■

Segments=3

■

Sides=4 (the default)

8 In the Parameters rollout ➤ Struts group, turn on End Caps.
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One of the objects with the Lattice modifier is named left enclosure
panel001, and the other is named right enclosure panel001. You'll rename
both now.
9 Select the right enclosure panel001 object, then type Struts right in the
Name And Color field. Also rename the left enclosure panel001 object Struts
left.
Next you'll create, apply, and edit materials for the revolving door.
Save your work:
■

Save the scene as my_add_door.max.

Applying Materials to the Revolving Door
You'll add some materials to help visualize your revolving door. You'll add a
shiny black finish for the struts and a green glass material for the glazing in
the door and the enclosures. You'll also edit the material that already exists
on the revolving door, so it matches your own green glass.
Set up the lesson:
■

Continue from the previous lesson, or on the Quick Access toolbar, click

(Open File) and open add_door_materials.max in the \startup folder.
Open the material editor:

➤

On the main toolbar, choose
(Material Editor) from the Material
Editor flyout to open the Compact Material Editor.
The Material Editor opens as a floating window.
The Compact Material Editor is usually more convenient when you want
simply to assign materials that have already been designed. The Slate
Material Editor, which takes up more screen space, is more convenient
and versatile for designing materials.
NOTE If you open the large Slate Material Editor by mistake, then from the
Material Editor toolbar choose Modes ➤ Compact Material Editor.
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Apply a door material:
You can choose materials from a material library and apply them to the
revolving door so the panel is transparent.

1 On the Material Editor toolbar, below the sample spheres, click
(Get Material).
3ds Max Design opens the Material/Map Browser.

2 On the Material/Map Browser, click
(Material/Map Browser Options)
(or right-click an empty area of the dialog), and from the pop-up menu,
choose Open Material Library.
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3ds Max Design opens a file dialog.
3 Highlight the file aectemplates.mat, and then click Open.
This library is located in the \materiallibraries subfolder of your current
Project. If it doesn’t appear in the file dialog when you click Open, browse
to this directory, then open the library.
NOTE The filename extension for 3ds Max Design material library files is
MAT.
A section for the library now appears in the Browser.

4 In the Browser, double–click the material name Door-Template.
The door material appears in the first sample slot of the Compact Material
Editor.
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5

Close the Material/Map Browser.

6 Drag the material from the sample sphere to the door object in the
viewport.
The door now displays with transparent glass. Also, in the Material Editor,
the sample sphere is now marked with corners showing that this material
has been applied to an object in the scene.
TIP If you loaded the provided scene file, you might get a message that asks
you to Replace or Rename the material. Choose Replace and continue.

Create and apply a green glass material:
1 Click any unused sample slot in the Material Editor to activate that slot.
By default, materials in the Material Editor are of the Arch & Design type.
You'll change this material to the Standard type.
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2 Click the Material Type button button to the right of the material name
(its label now says “Arch & Design”).

3ds Max Design opens the Material/Map Browser again.
3 In the Material/Map Browser, locate Materials ➤ Standard ➤ Standard,
then double-click the entry Standard.
In the Compact Material Editor, the material type changes from Arch &
Design to Standard.
4 Drag the material onto the left enclosure panels object. Drag from the
material sample sphere to the viewport, and read the tooltip to be sure
you have the left enclosure object (left enclosure panels) as the target.
The glass panels of the left enclosure change their appearance in the
viewport.
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5 On the Blinn Basic Parameters rollout, change the color of this material
by clicking the Diffuse color swatch. When the Color Selector opens, pick
a green color.

“Blinn,” named after computer-graphics pioneer James Blinn, is the
default shader type used by the Standard material. A shader determines
how the material interacts with light. And “Diffuse” refers to the basic
material color. You'll find more information about these and about
materials in general in the User Reference.
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Watch in the viewport; each time you click a different color, the material
updates in the viewport. When you've decided on a color, click the Close
button.
6 On the Blinn Basic Parameters rollout, change the Opacity value to 66.
7 Rename the current material to Green Glass. Highlight the name and
then enter the new name.
8 Drag the Green Glass material from the sample sphere in the material
editor to the right enclosure panels objects in the viewport.

Now the glass on the right enclosure matches the color and transparency
of the left enclosure.
Create a black metal finish:
1 In the Material Editor, activate a different unused sample sphere by
clicking it.
2 Name the material Black Metal Finish and change it to the Standard type,
as you did before.
3 On the Shader Basic Parameters rollout, click the drop-down arrow next
to Blinn and choose Metal.
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This shader is more appropriate for metallic materials.
4 On the Metal Basic Parameters rollout, click the Ambient color swatch.
In the Color Selector, choose a dark color close to black. You can use the
Whiteness slider to darken the color.
NOTE The Diffuse color changes to the same dark color, since the Diffuse
and Ambient values are locked together by default.
“Ambient” refers to the lighting that spreads out within a scene without
being cast directly by a light source. Typically it's reflected off surfaces
such as walls.
5 Set Specular Level to 128 and Glossiness to 85.
These two settings determine the brightness and size of shiny highlights,
respectively.

All of these settings combine to produce a black, shiny surface treatment.
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6 Press H on the keyboard, then select the Struts objects by name. Hold
down the Ctrl key and highlight the names, and then click OK to select
both objects and close the dialog.

7 In the Compact Material Editor, click
to apply the material to the struts.

(Assign Material To Selection)
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8 Drag this material onto the central hub object (Cylinder01).
Edit the material:
After you created the pivot door, you assigned a Multi/Sub-Object material
from a material library to the door. When you have a single object, such as
this door, with different, distinct components (such as glazing, frame, and so
on), you can use a Multi/Sub-Object material to apply different materials to
its various parts.
You will use the eyedropper to get the material from the door into the Material
Editor. This will give you a second copy of the material to edit, leaving the
original available for use.
1 Click another sample sphere, to make it active.

2 In the Material Editor, click
(Pick Material From Object) to activate
it, and then in the viewport click the pivot door.
The sample sphere is replaced with a sphere that shows five stripes of
different materials. This indicates that the selected material is a
Multi/Sub-Object material.
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On the Multi/Sub-Object Basic Parameters rollout, you can click and
access each individual material.
3 Drag the Green Glass sample sphere to the button labeled “Inner Bevel
(Standard).” On the Instance (Copy) Material dialog choose Instance,
then click OK.
When you copy something using the Instance option, changing one
instance changes all of them. For example, if you then made the glass a
neutral color, all the instances would reflect that change.
This is the material that is applied to the glazing. The glass on the
revolving door turns green in the viewport.
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4 Drag the Black Metal Finish material to the other material slots of the
Multi/Sub-Object material. In each case, choose Instance.

Change the material:
Now make changes to the material and watch them update on the objects in
the viewport.
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Change the Black Metal Finish to a shiny gold instead. Do the following:
1 Click the Black Metal Finish sample sphere.
2 Click the Diffuse color swatch, and then change the black material to a
gold material. Use RGB values of approximately 176, 157, and 52,
respectively, to achieve a nice gold tone.
3 Rename the Black Metal Finish material to Burnished Gold.
4 Click the Perspective viewport Shading menu (now labeled “Smooth +
Highlights + Edged Faces”), and turn off Edged Faces.

Close the Material Editor when you're done.
Save your work:
■

Save the scene as my_add_door_materials.max.
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Cloning the Door
There will be four doors revolving around the central hub. You have one door
so far, and you will make three instances of the door to complete the wheel.
Set up the lesson:

Continue from the previous lesson, or
in the \startup folder.

■

open start_door_clone.max

Adjust the door position and rotation:
1 Activate the Top viewport.
2 Make sure the viewport is set to Wireframe shading mode.

3

Zoom in and

select the pivot door.

4 If you need to,
move the pivot door so it is centered on the edge
of the hub, as illustrated. Rotate the door, if necessary, so it is square to

the hub: Click
(Select And Rotate), and then on the status bar,
set the Z coordinate to 0.0 (right-click the spinner arrows to reset to zero).
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5 Activate the Perspective viewport by right-clicking it (the door should
still be selected).
Create the cloned doors:
1 Right-click the viewport and choose Rotate from the menu.
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This right-click menu is called the quad menu. You can use it to access
tools from the toolbar and command panel for quicker workflow. You
can even customize it to keep your favorite tools right under your
fingertips.
2 On the toolbar, click the drop-down arrow for the Reference Coordinate
System (View is the default). Choose Pick, then click the Cylinder01 object
(the hub) in the viewport.
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3 On the toolbar, directly next to the Reference Coordinate system

drop-down list, choose
the Use Center flyout.

(Use Transform Coordinate Center) from

This allows you to rotate the pivot door around the cylinder's pivot point,
rather than the door’s own pivot.

4 Press A on the keyboard to turn on
already.

(Angle Snap), if it isn’t on

On the toolbar, the Angle Snap button highlights.
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5 Hold down the Shift key and position your cursor over the Z axis in the
transform gizmo in the viewport until the axis turns yellow. Then click
and drag slowly to rotate the door until Z= 90 degrees in the Coordinate
display. Release the mouse button.
Holding down Shift as you transform an object serves as a quick way to
clone the object.
6 On the Clone Options dialog, set Number Of Copies to 3, choose Instance
(if necessary), and click OK.

Now there are four doors within the enclosure.
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Clone the door to create a wheel of doors.

Change the hub back into a cylinder:

■

Select the hub (Cylinder01), and then on the
panel, change its Sides value to 12.
The hub now resembles a cylinder rather than a box.

Modify

Save your work:
■

Save the scene as my_fourdoor.max.

Animating the Revolving Door
To make the revolving door spin, first you'll link the four doors to the hub.
Then, using the time slider, you'll animate the rotation of the hub to spin the
doors.
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Set up the lesson:

■

Continue from the previous lesson, or
the \startup folder.

open start_door_link.max in

NOTE If you see the File Load: Units Mismatch dialog, choose the default
option: Adopt The File's Unit Scale.

Link the doors to the hub:

1 In the Perspective viewport,

zoom so you have a close-up view of

the hub and the four doors. It might help to
the view, as well.
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pan and

orbit

2 On the toolbar, click

(Select And Link).

3 In the viewport, drag from one of the pivot door objects to the hub. You
will see a dotted line drawn between your cursor and the original door
as you drag. Release the mouse over Cylinder01. It should highlight briefly
to show it has been linked.
4 Repeat step 3 for each of the other three doors.

5 Click

(Select Object) to deactivate Select And Link.

6 To verify that you correctly linked the four doors to the hub, do the
following:

1 Click

(Select By Name), or press H on the keyboard.

2 On the Select From Scene dialog, choose Display ➤ Display
Children, and then

expand the Cylinder01 object node.
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In the list, all four Pivot Door objects should be indented as children
of the Cylinder01 object.

If the list doesn’t appear like this, link the doors that are missing to
the hub again.
Now you are ready to animate the revolving door.

Replace the rotation controller
3ds Max Design performs animation by means of software devices called
controllers that are assigned to individual objects. Typically an object has three
types of controllers assigned: for position, rotation, and scale. The default
rotation controller is good for character animation, but you'll replace it with
a controller that is better for design-visualization animation.

1

Select the hub, Cylinder01.

2 Open the
rollout.

Motion panel, and expand the Assign Controller

3 In the Assign Controller window, highlight the Rotation: Euler XYZ item.
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Click

(Assign Controller).

4 In the Assign Controller dialog, click TCB Rotation, then click OK.
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The rotation controller listed in the Assign Controller rollout changes to
TCB Rotation.

5 Scroll down to the bottom of the Key Info rollout and turn on Rotation
Windup. This will allow you to set rotation keys greater than 180 degrees.
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IMPORTANT You must turn on Rotation Windup, or the animation won't
work correctly.

Animate the hub:

1 Turn on

(Auto Key).

2 Drag the time slider to frame 100.

3 Click

(Select And Rotate), then click the hub.

4 Rotate the hub 360 degrees about the Z axis. Watch the coordinate display
to get the correct rotation.
TIP To make setting rotations easier, turn on Angle Snap by pressing the A
key.
The Time Slider now shows keyframes as small squares at the beginning
and at the end of the time segment.
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Rotation key at frame 100

5 Turn off

(Auto Key).

6 In the animation playback controls, rewind the animation by clicking

(Go To Start), and then click

(Play Animation).

Watch your revolving door rotate in the viewport.

7 Click
(Stop, in the same location as the Play button) when you
are done watching the animation.
Slow down the animation:
To slow down the rotation of the revolving door, do the following:

1 Click

(Time Configuration).

2 In the Animation group, click Re-scale Time.

3 On the Re-scale Time dialog, change End Time to 200, then click OK.
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4 Click OK to close the Time Configuration dialog.
The Time Slider now displays 200 frames, with a key at frame 0 and frame
200.

5 Click

(Play Animation) and watch the revolving door go around.

The animation plays more slowly than before.

6

Stop the playback.

Save your work:
■

Save the scene as as my_revolving_door_animated.max.
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Merging Geometry
The revolving door seems lonely, spinning by itself in the viewport. You can
use the Merge command to put this revolving door into context, by merging
in a scene of an entranceway.

You'll also learn to animate the opening of parametric doors.
Set up the lesson:

■

Continue from the previous lesson, or
\startup\revolving_door.max.

open
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Merge a scene:

1 From the
Application menu, choose Import ➤ Merge, browse
to \startup\entranceway.max, and click Open.
After you click the file name, the Merge File dialog displays a thumbnail
of the scene.

2 In the Merge dialog, click the All button to select all the objects in the
scene, and then click OK.

Merging Geometry | 87

3 If the Duplicate Name dialog appears, click Skip for any duplicate objects.
The revolving door is now in the middle of the entranceway.
NOTE If you've been modeling in metric units you might need to scale the
revolving door so it matches the new scene. You can use the Rescale World
Units utility if you need to accomplish this.

4

Click an empty area of the Perspective viewport to deselect all
objects.

88 | Chapter 2 Getting Started: Modeling a Revolving Door

5 In the Perspective viewport, click
so you can see the double doors.

(Zoom), and then zoom back

Animate the double doors:

1 Turn on

(Auto Key).

2 Drag the Time Slider to frame 100.

3

Select the Double doors object. In the Perspective viewport, these
doors are to the right of the revolving door.

4 On the
degrees.

Modify panel ➤ Parameters rollout, set Open to 70.0

The spinner arrows are now outlined in red, indicating that Open is an
animated parameter that has a key on the current frame.
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5 Drag the Time Slider to frame 200.
6 On the Modify panel, set Open back to 0.0 degrees (you can just right-click
the spinner arrows).

7 Turn off

8 Go to the

(Auto Key).

first frame, then

Play the animation.

The revolving doors go around and the double doors swing open.

Fine-tune the animation:
You can use the track bar to make the double doors open and close faster.
1 Make sure the double doors are selected, and then on the track bar, drag
the key at frame 100 to frame 25. Watch in the status bar for the frame
number.

2 Similarly, move the key at frame 200 to frame 50, and then
the animation.
The doors open and close more quickly.
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play

You can make the doors open and close repeatedly throughout the
animation by using Track View.

3 On the
Modify panel, find the animated Open parameter, and
right-click within the numeric field. From the menu that appears, choose
Show In Track View.

A Track View – Curve Editor window opens with the Double doors Open
parameter highlighted.
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4 On the Track View toolbar, click
Types).

(Parameter Curve Out-Of-Range

5 On the Parameter Curve Out-Of-Range Types dialog, click the Ping Pong
graph to make it active (the buttons below it highlight).

Click OK to accept the change and close the dialog, and then
close the Selected track view dialog.

6

Play the animation again.
Now the doors open and shut throughout the animation.

Save your work:
■

Save the scene as my_entryway_completed.max.
You can find a finished version of the scene in revolving_door_final.max.
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Summary
In this tutorial you learned to get around the 3ds Max Design user interface,
and to do some simple modeling and animation. You learned to work with
primitive objects and apply and edit materials. You created a door object,
made clones of it, and linked the doors to a parent object in order to make
an animation. Lastly, you learned to merge files together to create a more
complex scene.

Merging Geometry | 93

94

Modeling Tutorials

3

This section shows you a variety of modeling techniques in 3ds Max Design.
■

The two tutorials on modeling buildings show ways to quickly create and render an
architectural design; for example, to create a proof-of-concept model in a hurry.

■

The tutorial on modeling kitchen cabinets shows how to create detailed scale models using
Editable Polygon objects and the Graphite Modeling Tools.

■

The tutorial on modeling façades shows a different use of Editable Polygon objects: this
time, to produce realistic architecural models based on photographs.

95

Building models created with 3ds Max Design

Features Covered in This Section
■

Creating primitive objects.

■

Using modifiers to alter an object's shape

■

Clone objects to build complex geometry

■

Align objects to each other
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■

Create an array of objects

■

Use Boolean operators to change the shape of an object

■

Select and edit polygons and edges

■

Apply materials to polygons by their assigned material ID number

■

Use loops to create new polygon faces

■

Extend polygons using various extrusion techniques

■

Create beveled and inset shapes

■

Use the Symmetry modifier to produce a mirrored duplication of an object

Modeling Buildings Using Modifiers
In this tutorial, you will model a building with a distinctly organic design.
Specially developed modifiers in 3ds Max Design make this task far easier than
if you were to attempt it in a conventional CAD program.
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In this tutorial, you will learn how to:
■

Create simple geometry.

■

Use the Twist, Taper, and FFD modifiers to alter geometry.

■

Use polygon selection and editing techniques.

■

Clone objects.

■

Chamfer edges.

■

Assign materials to objects.

Skill level: Beginner
Time to complete: 1 hour

Creating the Tower
In this lesson, you will create the basic geometry of the model, then use 3ds
Max Design modifiers to give the object a distinctive shape.
Set up the lesson:

■

On the Quick Access toolbar, click
(Open File), navigate to the
\scenes\modeling\highrise folder, and open building1_start.max.
NOTE If a dialog asks whether you want to use the scene’s Gamma And LUT
settings, accept the scene Gamma settings, and click OK. If a dialog asks
whether to use the scene’s units, accept the scene units, and click OK.
A daylight system has already been set up, so you can start building your
model right away.

Create the tower object:

1 On the
Create panel, click
Type rollout, click Box.

(Geometry), then in the Object

2 In the Perspective view, click and drag diagonally at the center of the
ground object to set the width and depth of the box. Release the mouse
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button and drag upwards to set the height. Click a final time to complete
the box.
Do not worry about dragging the box to an exact width, depth, or height.
You will set these parameters in the next step.

3 On the
Modify panel ➤ Parameters rollout, set the parameters
of the box as follows:
■

Length=70.0m

■

Width=70.0m

■

Height=300.0m

■

Length Segs=7

■

Width Segs=7
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■

Height Segs=50

The segments are necessary to define the tower floor and window
grid.
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NOTE Normally, a building 300 meters in height would be divided into 100
height segments to create floors of three meters each, but in this tutorial the
value is halved to make for easier polygon selection.
4 On the Name And Color rollout, change the name of the object to
Building 1 - Glazing.

This name change is appropriate, since you will later be applying a glazing
material to this object.
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5 From the Modifier List ➤ Object-Space Modifiers section, choose Taper.
6 On the Parameters rollout, set Amount to –0.45 and Curve to –0.9.

The negative Amount value tapers the building inwards at the top. The
negative Curve value pulls the sides of the building in, as shown in the
next illustration.

Next, you want to give the tower a twist.
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7 From the Modifier List ➤ Object-Space Modifiers section, choose Twist.
8 On the Parameters rollout ➤ Twist group, set Angle to 90.0 and Bias to
45.0.

The 90-degree Twist value creates a quarter turn of the building. The Bias
value of 45 causes the twist to start part-way up the side of the building,
rather than immediately at its base.
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9 To give the building a serpent-like quality, from the Modifier List, choose
FFD(Box). FFD modifiers surround the selected geometry with an
adjustable lattice box.
10 On the FFD Parameters rollout ➤ Dimensions group, click Set Number
Of Points.
11 In the Set FFD Dimensions dialog, set the parameters as follows to set the
number of control points for the lattice used to deform the structure:
■

Length=2

■

Width=2

■

Height=7

12 In the modifier stack, click the
plus-sign icon to expand the
FFD(Box) modifier hierarchy. Click to choose Control Points.
This lets you select and manipulate the lattice control points you defined
in the previous step.
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13 In the Front view, create the serpent effect by
dragging a box
to select the top row of control points, then holding down Ctrl and
dragging another box to select the fourth row of control points.

14 Click
(Select And Move), then drag right slightly, as shown in
the next illustration.

15 Exit the FFD Control Point sub-object level by clicking the main modifier
entry: FFD (Box) 2x2x7 in the Modifier stack.
Now you are ready to create the mullions.
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Save your work:
Save the scene as my_building_shaped.max.

■

Adding the Mullions
You will start by cloning the object you created in the previous lesson. You
will then take the clone, which retains twist, taper, and FFD modifiers, and
use polygon editing techniques to create the structure’s mullions.
Set up the lesson:

Continue working on your scene from the previous lesson, or
\modeling\highrise\building1_glazing.max.

■

open

Create the mullions for the building:

1

Select the glazing object (the tower). From the menu bar, choose
Edit ➤ Clone. In the Clone Options dialog ➤ Object group choose
Reference. Change the name of the object to Building 1 - Mullions, then
click OK.
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As a reference, the newly created mullions object behaves in a specific
way. Any subsequent edits to the mullions object will not affect the
glazing object. However, if you modify the glazing object, the mullions
object will be affected. This way, any changes to the modifiers that affect
the tower structure, which were created in the glazing object, can be
carried forward to the mullions. But any polygon edits intended to affect
the mullions only, will not affect geometry in the glazing object.
2 If the mullions object was cloned as a copy instead of a reference, it would
be completely independent of the original.
If the mullions object was cloned as an instance, it would be completely
dependent on the original, and vice versa: Any subsequent edits made
to either object would affect the other.
3 With the Building 1 - Mullions object selected, right-click the viewport, and
from the quad menu, choose Isolate Selection.

Isolation mode ensures you are working on the correct object.
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You now want to take the polygons that form the window grid and
modify them to take on the characteristics of mullions. You will do so
using the Edit Poly modifier.
4 From the Modifier List, choose Edit Poly.

Notice how a gray bar is inserted between the newly added Edit Poly
modifier and all other modifiers. The bar indicates that all modifiers
above the bar affect the reference object only and will not affect the
original object. This way, you can keep on modifying the mullions object
without affecting the glazing object.
Next, you will remove some unneeded polygons.

5 Activate the Perspective viewport.
Zoom,
orbit, and
pan until the roof of the tower is clearly visible, and then on the Selection
rollout, click the Polygon button.

6

Select the middle polygon on the roof. On the Selection rollout,
click Grow repeatedly until you have selected the entire roof. Press Delete
to remove all the selected polygons.
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7 Repeat the previous two steps to remove the polygons that make up the
bottom of the building.
Now you will create insets out of the remaining polygons, which you
will use as the window mullions.
Turn the mullion object into a lattice:
1 Press Shift+Z repeatedly to undo the viewport changes, so you can see
the entire building in the Perspective viewport, again.
2 Press Ctrl+A to select all the polygons in the building.
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3 On the Edit Polygons rollout, click the
Settings button next to the
Inset button (just to the right of the main button).

3ds Max Design displays the caddy controls for the Inset tool.

4 On the first control of the caddy, choose By Polygon from the drop-down
list.
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5 On the second control, Amount, change the value to 0.3m, then click

(OK).
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The By Polygon option applies the inset poly edit to each polygon in the
selection.
6 Press Delete to remove the selected polygons and keep their insets.

7 On the Selection rollout, click
Polygon selection mode.

8 In the Perspective viewport,
created.

(Polygon) to turn it off and exit

zoom in to the mullions you just

The mullions appear as thin, two-dimensional faces. You need to give
them some thickness.

112 | Chapter 3 Modeling Tutorials

Make the mullions thicker:
➤

From the Modifier List ➤ Object-Space Modifiers section, choose Shell.
On the Parameters rollout, set Outer Amount to 0.3m.

Now the mullions are thick enough to show up when you render the
scene.
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Unhide the glazing structure:
■

In the Warning: Isolated Selection dialog, click Exit Isolation Mode to view
the glazing and mullion objects together.
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Now you are ready to create the structure’s metallic shell.
Save your work:
■

Save the scene as my_building_mullions.max.

Creating the Metallic Shell
In this lesson, you will create another reference object and apply additional
polygon editing techniques that will cloak the building in a metallic shell.
Set up the lesson:

■

Continue working on your scene from the previous lesson, or
\modeling\highrise\building1_mullions.max.

open
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You will start by temporarily deactivating the modifiers on the glazing
object, so you can work with the polygons of the shell object more easily.
Create a metallic shell for the building:
1 Press H and use the Select From Scene dialog to select the Building 1 -

Glazing object. On the

Modify Panel, in the modifier stack, click

the
(light-bulb icon) to the left of each modifier to turn off the
effect of the modifier.

2 From the menu bar, choose Edit ➤ Clone. In the Clone Options dialog
➤ Object group, choose Reference and change the name of the object
to Building 1 - Metallic Shell.
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3 With the shell object selected, right-click the active viewport and from
the quad menu, choose Isolate Selection.
4 From the Modifier List, choose Edit Poly.

5 Right-click the Perspective viewport if it is not already active.

Zoom,
orbit, and
clearly visible.

pan until the bottom of the building is

6 On the Selection rollout, click

7

(Polygon) to turn it on.

Select the middle polygon on the bottom of the building. On
the Selection rollout, click Grow repeatedly until you have the entire
bottom selected. Press Delete to remove the polygons.
You now need to remove additional polygons to create the window
pattern on the building exterior.

Create openings for the front and back of the building shell:
1 Press Shift+Z repeatedly to undo viewport changes until you can see the
entire building again.
2 In the Perspective view, click Front on the ViewCube.
NOTE If the ViewCube is not visible in your viewports, from the General
viewport label menu (“[+]”) choose ViewCube ➤ Show The ViewCube.
3 Press Alt+W to maximize the viewport.

4 Turn on
(Select Object). Ctrl+click+drag to select a 5x15 grid of
polygons in the upper portion of the model, leaving one row of polygons
unselected at each edge of the building.
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This selects polygons on both the front and back faces of the model.
5 Alt+click to remove each corner polygon from the selection, as shown in
the illustration. This removes the selected polygons on the front and back
faces of the model.
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6 Ctrl+click+drag to select the remaining polygons, as shown in the next
illustration. Use the Alt+drag technique to remove polygons from the
corners of the window patterns, and the archway of the entrance.
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7 Press Delete to delete all of the selected polygons on the front and back
of the building.

Next, you will remove polygons from the sides of the building, using a
slightly different pattern.
Create openings for the sides of the building shell:
1 Use the ViewCube to change to a Left view of the building.
2 Select polygons in a pattern of 5x7, 5x15, 5x15, and 5x8, with the corners
removed, as shown in the illustration.
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3 Press Delete to delete the polygons.
4 Press Shift+Z until the viewport shows a perspective view again.

Next, you will edit the building edges to make them rounded.
Chamfer the corners of the shell:

1 On the Selection rollout, click

(Edge).
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2 In the Perspective view, zoom in to see the shell more closely. Use the
ViewCube to rotate the view so you can see all four corners of the shell,
whether inside or out.

3 At one level of the shell,
click and Ctrl+click to select the four
vertical edges at each corner of the building.

4 On the Selection rollout, click the Loop button. This selects all four edges
of the building in their entirety.
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5 On the Edit Edges rollout, click the
Settings button next to the
Chamfer button (just to the right of the main button).

3ds Max Design displays the caddy controls for the Chamfer tool.

6 On the Chamfer caddy, set the first control, Amount, to 2.0m. This sets
the width of the bevel created by the chamfer operation. Set the second
control, Segments, to 4. This divides the chamfered region into four
segments. The more segments you set, the more rounded the edge will

be. Click

(OK).
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7 Click

(Edge) again to exit the Edge sub-object level.

Give thickness to the shell, and inspect the result:
1 From the Modifier List, add a Shell modifier and on the Parameters rollout,
set the value of Outer Amount to 2.0m.
This gives the metallic shell a thickness of two meters.
Now, let’s look at the building with the modifiers applied.
2 Exit Isolation Mode.
3 Click Alt+W to view all four viewports again.
4 On the Modifier Stack, turn on the three modifiers you turned off earlier:
FFD, Twist, and Taper.
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5 In the Perspective view, click

6

(Zoom Extents Selected).

Click an empty area of the viewport to deselect the building.
The modeling phase of the building is now complete. Next, you will add
materials to the building exterior.

Apply materials to the building:
1 Press H and on the Select From Scene dialog, highlight the Building 1 Glazing object, and then click OK.

2 On the main toolbar, click
Material Editor.

(Material Editor) to open the Slate

3 On the Material Editor menu bar, open the Options menu and turn off
Propagate Materials To Instances.
4 In the Sample Slots section of the Material Editor Browser (on the left),
locate the Glass material, then drag it to the View1 window (in the center).
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3ds Max Design asks whether to make this a copy or an instance. Choose
Instance, then click OK.
TIP To navigate conveniently in the Slate Material Editor, enlarge the window
from its default size. It also helps to drag the width of the Browser panel to
make it wider.

5 On the Material Editor toolbar, click
(Assign Material To Selection)
to apply the Glass material to the glazing object.
3ds Max Design applies the glazing material to the glazing. In the Scene
Materials section of the Browser panel, now you can see a Glass entry,
and the object name.
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NOTE If Propagate Materials To Instances is on when you do this step, then
all of the buildingl is assigned the Glass material.
6 Press H again, and select the Building 1 - Metallic Shell object.
7 In the View1 panel, click the Glass material to highlight it, then press
Delete.
This removes the Glass material from the active material view, but doesn’t
remove it from the scene.
8 In the Sample Slots section of the Browser panel, locate the Metal material,
and drag it to the View1 panel.
9 This time drag from the Metal material node’s output socket, the round
control at the right,
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Dragging from a material’s output socket

... and in the viewport, drop the wire on the metal shell object.
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... and dropping onto an object

Dragging and dropping is another way to assign a material.
NOTE You won’t see the wire as it crosses the panel at the right of the Slate
Material Editor, or in the viewport.
10 Press H again, and select the Building 1 - Mullions object.
11 In the Sample Slots section on the Browser panel, locate the Mullions
material (you’ll have to scroll down), then apply it to the mullions object
using the methods described in the previous steps.
The Mullions material is a matte gray, not shiny like the metallic shell.
12

Close the Slate Material Editor.
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Render the building:

■

Make sure the Perspective viewport is active, then click
Production) to check your work.
Your scene should look something like this:

(Render

Save your work:
■

Save your file as mybuilding1_final.max.
You can use this scene file as your starting point in the next tutorial,
Modeling Buildings Using Boolean Operations on page 130.

Modeling Buildings Using Boolean Operations
Boolean operations are an effective way to create complex shapes out of simple
geometric objects. In the case of 3ds Max Design, the Boolean operators are
Subtraction, Union, Intersection, and Merge.
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In this tutorial, you will learn how to use two Boolean operators, Subtraction
and Union, to create a model of a sky scraper.
This tutorial also shows you how to use the Align tool to accurately move
objects into position, and how to use material ID numbers to assign assign
different materials to different portions of a model.

In this tutorial, you will learn how to:
■

Create simple geometry.
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■

Align objects.

■

Move objects using their XYZ coordinate values.

■

Create an array of objects.

■

Use Boolean operators to change the shape of an object.

■

Make changes to the Boolean operators.

■

Select multiple polygons and edges.

■

Edit polygons to create beveled and extruded shapes.

■

Assign materials IDs to object polygons.

■

Apply materials to object polygons by material ID number.

Skill level: Beginner
Time to complete: 1 1/2 hours

Creating the Floors
In this lesson, you will create the basic geometry of the model, then create an
array of objects that you will use in a Boolean subtraction operation to create
a set of floors in the building midsection.
Set up the lesson:

■

On the Quick Access toolbar, click
(Open File), navigate to the
\scenes\modeling\highrise folder, and open building2_start.max.
Alternatively, continue working on your completed scene from the
“Modeling Buildings Using Modifiers” tutorial.
NOTE If a dialog asks whether you want to use the scene’s Gamma And LUT
settings, accept the scene Gamma settings, and click OK. If a dialog asks
whether to use the scene’s units, accept the scene units, and click OK.

Create the floors for the building:
1 Press Alt+W to maximize the Perspective viewport if it is not already
maximized.
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2 Use
(Select And Move) to select the three objects that comprise
the architectural model and move them to the right on the Ground object.

3 On the
Create panel, click
Type rollout, click Box.

(Geometry), then in the Object

4 At the center of the ground object, click and drag diagonally to set the
width and depth of the box. Release the mouse button and drag upwards
to set the height. Click a final time complete the box.
Do not worry about dragging the box to an exact width, depth, or height.
You set these values in the next step.
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5 On the
Modify panel ➤ Parameters rollout, set the parameters
of the box as follows:
■

Length = 30.0m

■

Width = 30.0m

■

Height = 200.0m

Make sure the Length Segs, Width Segs, and Height Segs fields are all set
to 1 (the default).

Now that you have defined the footprint of your tower model, you are
ready to define the floors in the mid-section of the structure.

6 Press Alt+W to see all four viewports, and in the Top viewport,
zoom in to the top of the Box001 object (the tower object you just created).

7 Go to the
Create panel, click
(Geometry), then drag out
a second box so that it is larger on three sides than the Box01 object, as
shown in the next illustration.
The height of the box object is not important.
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8 This object, Box002, will be used to define the tower floors. You now need
to align its right side with the right side of the tower object.

9 With the Box002 object selected, click
Box001 object.

(Align), then click the

10 In the Align Selection dialog ➤ Align Position group, turn on X Position
and turn off Y Position and Z Position, so that only the left-right
positioning of the two objects is set for alignment.
11 In the Current Object group, choose Maximum and in the Target Object
group choose Maximum as well. (Choosing Minimum for both Current
and Target objects would align the two boxes on their left sides.) Click
OK.
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12 Next, you need to
move the aligned side of Box02 to the left by
six meters. To do so, you should first switch the coordinate display from
absolute values to local values. Absolute values display the scene in world
space, a universal coordinate system for all objects in the scene. World
space is constant and immovable. Local values use the coordinate system
of the selected object.

On the status bar, click
(Absolute Mode Transform Type-In) to
switch the display from Absolute Mode Transform to Offset Mode
Transform.
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In Offset Mode, the XYZ coordinate values reset to local values. Initially,
each equals 0.
13 Select the Box02 object, then type –6 in the X coordinate display box and
press Enter. 3ds Max Design moves the box six meters to the left.

14 On the
Modify panel ➤ Parameters rollout, set the height of
the box to 3.0m, the standard height for a typical floor of a building.
15 You want the first floor to start at an elevation of 40 meters, so in the Z
coordinates display box, type 40. This will become the first floor of a total
of 15 that will form the midsection of the model.
Now you will create an array of boxes that you will use later in a Boolean
operation to create all floors above the current one.
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16 Right-click the Perspective viewport, press Alt+W to maximize it, and from
the main menu, choose Tools ➤ Array.
TIP In the Array dialog ➤ Preview group, turn on the Preview button before
you adjust array parameters. That way, you can see a preview of the array in
the viewport.
17 In the Array dialog ➤ Array Dimensions group, type 16 in the 1D Count
field.

This creates an array of 16 objects to be spread out in one dimension.
You want to build your array vertically.
18 In the Array Transformation World Coordinates group ➤ Incremental
column go to the Move row, find the Z-axis spinner, and type 6.0.
19 A distance of six meters in Z space is inserted between each object in the
array. This corresponds to the height differential you want to establish
between each floor in the building.

20 In the Type Of Object group, choose Copy. Use Copy instead of Instance
because one of the array objects will be resized to a height different to
the others.
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21 Click OK to create the array.
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22 The top array object is already selected and ready for editing. On the
Parameters rollout, set Height to 30.0m. In the next lesson, you use this
box to create a gap in the top segment of the tower.
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Save your work:
■

Save the scene as my_building2_begin.max.
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Adding Detail to the Upper Floors
Now that all the array objects have been created, you can use them in Boolean
operations to define the tower contours.
Set up the lesson:

■

Continue working on your scene from the previous lesson, or
\modeling\highrise\building2_floors.max.

open

Add detail to the upper floors:
1 Maximize the Perspective viewport (if it isn’t maximized already), select
the Box01 object, and on the Name And Color rollout, rename it Tower.

2 On the
Create panel, click
(Geometry), then choose
Compound Objects from the drop-down list.

3 On the Object Type rollout, click ProBoolean.
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4 On the Parameters rollout ➤ Operation group, choose Subtraction, if it
is not already chosen.

5 On the Pick Boolean rollout, click Start Picking, then click the large array
box at the top of the tower.

The Boolean subtraction operation subtracts the common area shared by
the array box and the Tower object.
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Later you will add a design element in the gap you just created.
6 Press H to open the Pick Object dialog. In the list, select all the Box objects,
and then click Pick.
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The subtraction operation creates gaps for all the selected array boxes.
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7 On the Pick Boolean rollout, exit pick mode by clicking the Start Picking
button again to turn it off.
Next, you need to introduce recessed glazing to the first 15 floors created
by the Boolean subtraction.
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Add glazing to the floors:

1 On the
Create panel, click
(Geometry), then choose
Standard Primitives from the drop-down list. On the Object Type rollout,
click Box.

2

Minimize the Perspective viewport, activate the Top viewport,
and drag out a box within the tower. Exact dimensions are not important
at this point.

3 Click
(Align), then click the Tower object to display the Align
Selection dialog.
4 In the Align Position group, turn on X Position and Y Position, then
choose Center in both the Current Object and Target Object groups.
This aligns the box you just created to the center of the Tower object, as
shown in the next illustration.
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5 Click OK to exit the Align Selection dialog.

6 On the
Modify panel ➤ Parameters rollout, set the dimensions
of the box as follows:
■

Length = 28.0m

■

Width = 28.0m

■

Height = 128.0m

This creates a box object that is two meters inset from the outer walls of
the tower, with a height that stops just short of the gap in the tower’s
upper structure.
7 Click the color swatch next to the name of the box, and assign the box
a distinctive color.
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The next Boolean operation will join the newly-created box object to the
Tower object.

8

Select the Tower object and in the Parameters rollout ➤
Operations group choose Union.

9 On the Pick Boolean rollout, click the Start Picking button, then click
the box you just created. The box is now incorporated into the Tower
object.
10 Click the Start Picking button again to turn it off.
Save your work:
■

Save the scene as my_building2_floors.max.

Defining the Atrium and Entrance
In this lesson, you will use the subtraction Boolean operation to add an open
atrium in front of the entrance to the building.
Set up the lesson:
■

Continue working from the previous lesson.
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Add an opening to the building entrance:

1 On the
Create panel, click
Type rollout, click Box.

(Geometry), then on the Object

This box will be used in a subtraction operation to create an opening for
the left and right sides of the building.
2 Activate the Top view, drag to create a box as shown in the following
illustration, with the upper and lower ends of the box protruding from
the top and bottom sides of the Tower object. Exact dimensions are not
important at this point.

3 On the Parameters rollout, set the dimensions of the box as follows:
■

Length=50.0m
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■

Width=18.0m

■

Height=36.0m

4 Click
(Align), then select the Tower object to display the Align
Selection dialog.
5 In the Align Position group, turn on X Position and Y Position, then
choose Center in both the Current Object and Target Object groups. Click
OK.
This aligns the box you just created to the center of the Tower object.
Next, you need to create a second box that will be used in a subtraction
operation to create an opening for the front of the building.

6 On the
Create panel, click
Type rollout, click Box.

(Geometry), then on the Object

7 Activate the Top view, drag to create a box as shown in the following
illustration, with the ends of the box protruding from the left and right
sides of the Tower object.
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8 Set the dimensions of the box as follows:
■

Length = 18.0m

■

Width = 41.0m

■

Height = 36.0m

9 Click

(Align), then click the Tower object.

10 On the Align Selection dialog ➤ Align Position group, turn on X Position
and Y Position, then choose Center in both the Current Object and Target
Object groups. Click OK.
This aligns the box you just created to the center of the tower.
Next, you need to align the right side of the new box with the right side
of the first box object, to create a back wall for the model.
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11 Click
in step 2.

(Align) once again, then click the Box001 object you created

12 In the Align Selection dialog ➤ Align Position group, turn off Y Position
so only X Position is on, then choose Maximum in both the Current
Object and Target Object groups. Click OK.
This aligns the box to the right-most edge of the first box object.
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Subtract the geometry from the tower:

1

Select the Tower object and in the
Modify panel ➤
Parameters rollout ➤ Operation group, choose Subtraction.

2 On the Pick Boolean rollout, click the Start Picking button, then click
the two boxes you created in the previous procedure. The subtraction
operation creates the gap for the entry area.
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3 Click the Start Picking button again to turn it off.
Save your work:
■

Save the scene as my_building2_atrium.max.

Next
Adding Cylindrical Elements on page 155

Adding Cylindrical Elements
In this lesson, you will create two cylindrical objects, shape them using polygon
edits, then use a union Boolean operation to add them to the Tower object.
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Set up the lesson:

Continue working on your scene from the previous lesson, or
\modeling\highrise\building2_tower_contour.max.

■

open

Change the size of the upper gap in the highrise:

1

Maximize the Perspective viewport and zoom in to the gap in the
upper section of the tower, as shown in the illustration.

You will bring the back face of the Tower object forward to the midpoint
of the structure. To accomplish this, you need to edit the operand that
was used to expose the back face.
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2

Select the Tower object, and in the
Modify panel ➤
Parameters rollout ➤ Display group, choose Operands.

This displays all the box objects, or operands, that were used to modify
the Tower object.

3 In the list of operands on the Parameters rollout, click to highlight the

entry “1: Subtr - Box17”, then turn on

(Select And Move).

The box named Box17 (in building2_tower_contour.max) is the box that
was used to make the topmost gap in the tower.
Repositioning the box to the midpoint of the tower involves a simple
calculation: at a depth of 30 meters, the tower’s midpoint is 15 meters.
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Earlier, you offset the box from the back of the tower by six meters, so it
needs to be repositioned to the left a further nine meters.

4 Make sure the coordinate display is set to
relative units (X, Y, and
Z spinners all display 0), then in the X field, type –9 , and press Enter.

3ds Max Design moves the box to the left by nine meters.

5 On the Parameters rollout ➤ Display group, turn on Result. The back
face is now where you want it to be, at the midpoint of the tower.
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The next step is to place a cylinder object in the gap between the floors.
But rather than create this object at the ground plane as you did with all
other objects in this tutorial, you will create this object directly on the
upper platform.
Add the first cylinder to the building:

1 On the
Create panel, click
(Geometry), then on the Object
Type rollout, click Cylinder. Also, turn on AutoGrid.
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With AutoGrid on, you can create the object on top of an object in the
scene.
2 Click on the center of the upper platform and drag diagonally to set the
cylinder radius. Release the mouse button and drag upwards to set the
height, as shown in the next illustration. Click a final time to complete
the object. For now, the exact dimensions are not important.

3 Turn off Autogrid.
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4 Click
(Align), then click the Tower object to display the Align
Selection dialog.
5 In the Align Position group, turn on X Position and Y Position; make
sure Z Position is off. Then choose Center in both the Current Object
and Target Object groups. Click OK.
This aligns the cylinder you just created to the center of the Tower object.

6 On the
Modify panel ➤ Parameters rollout, set the parameters
of the cylinder as follows:
■

Radius = 13.0m

■

Height = 30.0m

■

Height Segments = 8

■

Sides = 20
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7 Click
(Select And Uniform Scale), and drag the X axis of the
gizmo to the right. As you drag the gizmo, the X coordinate spinner
updates dynamically. When the spinner displays a value of 70, stop
dragging.
The cylinder shape should now resemble that shown in the next
illustration.

Next, you will use some polygon editing techniques to add architectural
detail to the cylinder object.
Detail the cylinder: Add windows:

1 Click

(Select Object).

2 Right-click the cylinder object and choose Isolate Selection from the quad
menu.
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3 Right-click the cylinder object again, and from the quad menu choose
Transform ➤ Convert To ➤ Convert To Editable Poly.

4 On the Selection rollout, click
(Edge),
select any
horizontal edge on the cylinder, then click the Ring button.

All horizontal edges above and below the selected edge are also selected.

5 Alt+click the top- and bottom-most edges to deselect them.
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6 Click Loop to select all horizontal edges, excluding the top and bottom
rows.
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7 On the Edit Edges rollout, click the
the Chamfer button.

Settings button to the right of

3ds Max Design displays the caddy controls for the Chamfer tool.
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8 On the Chamfer caddy, change the first control, Edge Chamfer Amount,

to 0.6m, then click

(OK).

3ds Max Design changes each horizontal edge loop into a pair of loops
0.6 meters apart.
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Detail the cylinder: Bevel the windows:

1 On the Selection rollout, click

(Polygon).

2 Display the ViewCube if it is not already visible, choose the Left face of
the ViewCube, then right-click and choose Orthographic.
NOTE If the ViewCube is not visible in your viewports, from the General
viewport label menu (“[+]”) choose ViewCube ➤ Show The ViewCube.

3 If the orthographic view zooms in too closely, click
Extents).

4

(Zoom

Hold down the Ctrl key, click just outside the cylinder object,
and drag across each band created by the chamfer operation, as shown
in the next illustration.
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5 On the ViewCube, click Home to exit Orthographic view.

6 Click

(Zoom Extents) again.

7 On the Edit Polygons rollout, click the
of the Bevel button.

Settings button to the right

3ds Max Design displays the caddy controls for the Bevel tool.
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8 On the Bevel caddy, in the first control, choose Local Normal from the
drop-down list. In the second control, Height, enter –1.0, and in the third
control, Outline, enter –0.1 to give the edges of the bevel a very slight

slope. Click

(OK).
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9 Click Exit Isolation Mode to redisplay all the scene elements, and on the

Selection rollout, click
level.

(Polygon) to exit the Polygon sub-object

Place a copy of the cylinder at ground level, and position it:
1 Minimize the Perspective viewport to see all four views.
2 Zoom so you can see all of the tower.

3 Turn on

(Select And Move).

4 In the Front viewport, hold down Shift and drag the cylinder on its Y axis
to the bottom of the tower.
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5 In the Clone Options dialog ➤ Object group, turn on Copy, then click
OK.
This way, any changes you make to the newly copied object will not
affect the upper cylinder.

6 Switch the coordinates display to
Absolute Mode and right-click
the Z coordinates spinner arrows to position the object at ground level
(0.0m).

7

Move the cylinder to the right on its X axis, until it straddles
the back portion of the Tower object, as shown in the next illustration.
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TIP If you press F3 to turn on shading and F4 to turn on edged faces, it’s
easier to see this.

Scale the new cylinder, and merge the cylinders with the tower:
1 Press F3 again to turn off shading.

2 Click
(Select And Uniform Scale) and drag the Y axis gizmo
upward until the cylinder slightly penetrates the ceiling of the atrium of
the Tower object.
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3

Select the Tower object. On the
Modify panel ➤
Parameters rollout ➤ Operation group, choose Union.

4 From the Pick Boolean rollout, click the Start Picking button and select
the two cylinder objects to join them to the tower.
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5 Click the Start Picking button again to turn it off.
Save your work:
■

Save the scene as my_building2_cylinders.max.

Next
Shaping the Roof on page 175
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Shaping the Roof
In this lesson, you will use polygon editing techniques to create and add detail
to a sloped roof.
Set up the lesson:

Continue working on your scene from the previous lesson, or
open
\modeling\highrise\building2_boolean_complete.max.
At this point, you could create another box object on top of the Tower
object, rotate it by 45 degrees, and use it in yet another Boolean operation
to create a sloped roof.

■

In this case however, a simpler approach is to create the roof line by editing
the tower as an Editable Poly object.
Change the tower to an Editable Poly object:
1 Activate the Perspective viewport.

2

Select the Tower object, right-click it, and from the quad menu
choose Transform ➤ Convert To ➤ Convert To Editable Poly.

Add a slope to the roofline:

1

Zoom,
orbit, and
pan the Perspective viewport
until you can see the roof of the building.
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2 On the Selection rollout, turn on
(Edge), and then use
(Select And Move) to select the edge at the back of the tower roof, as
shown in the next illustration.
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3 In the Z coordinates spinner, change the value from 200 to 160.
This sets the slope of the roof.
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Add an inset to the roof:
1 Use the ViewCube to change the view so you have a better view of the
back of the roof.
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2 On the Selection rollout, click
roof polygon.

(Polygon), then

select the
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3 On the Edit Polygons rollout, click the

Settings button next to Inset.

3ds Max Design displays the caddy controls for the Inset tool.
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4 On the Inset caddy, change the second control, Amount, to 2.0m, then

click

(OK).
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The inset operation creates a polygon two meters smaller in the X and Y
dimensions, centered on the original polygon. You can now extrude this
newly created polygon.

5 On the Edit Polygons rollout, click the
Extrude.

Settings button next to

3ds Max Design displays the caddy controls for the Extrude tool.
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6 On the Extrude caddy, set the second control, Height, to –2.0m, then

click

(OK).

A closer look at the top of the building in the Front viewport shows that
the extrusion needs to be fine tuned.
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7 Click
(Select And Move), then choose Local from the Reference
Coordinate System drop-down list.

8 In the Front viewport, move the roof polygon along its local Y axis until
the top and bottom edges are at a 90-degree angle to the ground plane,
as shown in the next illustration.
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9 Click

(Polygon) to exit the Polygon sub-object level.

Your roof should look like this:
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Save your work:
■

Save the scene as my_building2_roof.max.

Next
Assigning Materials to the Building on page 186

Assigning Materials to the Building
In this final lesson, you will assign a material identification number to each
polygon in the model. You can then use these ID numbers to assign materials
to specific parts of the model.
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Set up the lesson:
Continue working from the previous lesson.

■

Check the default Material ID:

1

Select the Tower object,

maximize the Front viewport

and click
(Zoom Extents Selected). Make sure the view is in
Wireframe mode.
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2 On the
Modify panel ➤ Selection rollout, turn on
(Polygon), then press Ctrl+A to select all the polygons in the Tower object.

3 On the Modify panel, scroll down to the Polygon: Material IDs rollout,
and verify that Set ID has a value of 1.
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At this point, if you were to assign a material to the Tower object, all its
polygons would receive the same material, because they all have the same
material ID number.
Assign a new Material ID to the glazing:

1

Click anywhere outside the Tower object to deselect the polygons.

2

Zoom in to the upper section of the tower and begin to
Ctrl+click the polygons that represent the glazing in the cylinder, as shown
in the next illustration.
Start your selection by clicking outside the tower and dragging right,
across all the glazing polygons. Starting your selection outside the tower
ensures that all glazing polygons on the other side of the Tower object
are also selected.
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3

Zoom out and continue to Ctrl+click all the glazing in the lower
floors, using the same selection technique described in the previous step.
Be sure to include the glazing polygons in the bottom cylinder. The result
is shown in the next illustration.
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4 On the Polygon: Material IDs rollout, click the Set ID spinner up-arrow
once, to change the value to 2.

Now you can assign the Tower object two different materials.
Apply materials to the tower:
1 On the Polygon: Material IDs rollout ➤ Select ID spinner, type 1, then
click Select ID.
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All the material 1 polygons are now selected.

2 On the main toolbar, choose the button for the
Material Editor.

192 | Chapter 3 Modeling Tutorials

Compact

3 In the sample slots, locate the Concrete material. Click the slot to make

the material active, and then click

(Assign Material To Selection).

3ds Max Design applies the Concrete material to all polygons that have
ID 1 assigned to them.
4 On the Polygons: Material IDs rollout, change the Select ID value to 2,
then click Select ID.
5 In the Material Editor sample slots, locate the Glass material, and click

the slot to make the material active. Then click
To Selection).

(Assign Material

3ds Max Design applies the Glass material to all polygons that have ID 2
assigned to them.
6

Close the Compact Material Editor.

7 On the Selection rollout, click
sub-object level.

(Polygon) to exit the Polygon
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Render the scene:
➤

Adjust the Perspective viewport so that the two tower models are clearly

visible, then click

(Render Production) to view the result.

Your rendered image should look something like this:
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Save your work:
■

Save the scene as my_building2_completed.max.

Summary
This tutorial introduced you to the concept of Boolean operations and how
they can be used to produce complex shapes from simple geometry. You also
learned some polygon editing techniques, and how to apply materials to
multiple surfaces by assigning material ID numbers to different sets of
polygons.

Modeling Cabinets Using the Ribbon
The Graphite Modeling Tools ribbon, referred to in this tutorial simply as “the
ribbon,” is a customizable toolbar that provides you with all the tools you
need to edit Editable Poly surfaces.
The lessons in this tutorial show how to use the tools available on the ribbon
to create a set of kitchen cabinets.
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In this tutorial, you will learn how to:
■

Create loops by connecting polygon edges.

■

Extend polygons using various extrusion techniques.

■

Create beveled and inset shapes.

■

Use the Symmetry modifier to produce a mirrored duplication of an object.

Skill level: Intermediate
Time to complete: 2 hours

Using Basic Polygon Editing to Create a Base Cabinet
The kitchen cabinets you will create in this tutorial are based on the
dimensions provided in the next diagram. In North America, the standard for
kitchen cabinet height and width is inches, in increments of three. This
diagram therefore uses feet and inches rather than metric units of measure.
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Line diagram showing kitchen cabinet dimensions

The diagram includes variable dimensions to account for varying cabinet
width and height.
Possible cabinet width starts at 9 inches and increases incrementally by 3
inches to a total of 36 inches per cabinet.
The height of wall cabinets can be as little as 12 inches, increasing by 3 inches
up to 30 inches, with one more dimension possible at 39 inches.
The standard height of a base cabinet is 34.5 inches, plus 1.5 inches for the
countertop.
For most structures, 93 inches is the maximum height from the top of a
variable-sized wall cabinet to the floor.
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With the diagram as a guide, you will use modeling tools from the ribbon to
create a group of cabinets of various sizes.
To start, you will build a base cabinet 18 inches wide.
Set up the lesson:

1 On the Quick Access toolbar, click
(Open File), navigate to the
\scenes\modeling\kitchen_cabinets folder, and open kitcab_start.max.
NOTE If a dialog asks whether you want to use the scene’s Gamma And LUT
settings, accept the scene Gamma settings, and click OK. If a dialog asks
whether to use the scene’s units, accept the scene units, and click OK.
The scene contains no geometry, but its units have been set up to use
U.S. Standard feet and fractional inches measured in 1/32 of an inch. The
scene also contains materials for the cabinets.
By default, a minimized version of the Graphite Modeling ribbon displays
directly below the main toolbar.

NOTE This lesson provides descriptions for workstations using a default ribbon
toolbar display. The ribbon on your workstation might display differently if
you customized it in a previous 3ds Max Design session.

2 Click the
displays.

expand/minimize icon a few times until the full ribbon
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The Polygon Modeling tab displays with deactivated tools, since no
polygon model exists in the scene.
Create the left cabinet board:
1 Activate the Perspective viewport, then press Alt+W to maximize it.

2 On the
Create panel, click
Type rollout, click Box.

(Geometry), then on the Object

3 In a viewport, drag out a box of any size.
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4 Go to the
Modify panel, and on the Parameters rollout, set Length
to 21.0, Width to 0.75, and Height to 34.5.
As soon as you type in the values, they are converted to inches and
fractions of 1/32 inch, based on the unit setup specified in the scene file.
TIP As you go through these lessons, it might help to remember that 0.75”
= 24/32”.

5 On the main toolbar, click
(Select And Move), then on the status
bar, right-click the X and Y transform spinners to set each of them to 0.0.
(The Z value should already be 0.0: Make sure that it is.)

The center of the box is now at the center of the world coordinates.
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6 Go to the
Hierarchy panel, and in the Adjust Pivot rollout ➤
Move/Rotate/Scale group, click Affect Object Only.

Now, if you move the object, its geometry moves but its pivot point
remains unchanged at the center of the world.
7 In the Y transform box, type –10.5, which is equal to half the length of
the box. Press Enter.
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Box with pivot point repositioned to center of world
coordinates (0,0,0)

The back face of the box and the pivot point are now both at the center
of the world. The cabinet you are about to create from this object will
now be much easier to manipulate.
8 Click Affect Object Only again to turn it off.
Add polygon edges:
Next, you’ll add edges to your object. These edges will create the polygon faces
you will need for extrusions later in the modeling.
1 Make sure the box is selected, right-click it, and choose Convert To ➤
Convert To Editable Poly.
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The ribbon updates to display a range of polygon-editing tools.

2 On the ribbon ➤ Polygon Modeling panel, click

(Edge).
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3

Drag a selection region across the center of the box to select all
its vertical edges.
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4 On the ribbon ➤ Loops panel, click

(Connect).
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This connects all selected edges by drawing a loop around them through
their midpoints.
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Loop created from selected edges

5 On the main toolbar, click
(Select And Move), and in the Z
transform field, type 4.5, then press Enter.
This moves the new connecting edges closer to the floor.
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6 On the ribbon ➤ Polygon Modeling panel, click

7

(Polygon).

Click to select the upper face on the front of the panel.
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8 On the ribbon ➤ Polygons panel, Shift+click
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(Extrude).

(When you Shift+click one of these tools, 3ds Max Design displays the
caddy controls for that tool.)
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9 On the second control of the Extrude caddy, Height, set the value to 2.5,

then click

(OK).
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Now you need to add more detail to the side of the box so you can later
connect this panel to the rest of the model.
Add detail to the left board:
You continue by adding an edge toward the rear of the box to allow for the
inclusion of a back panel to the cabinet that is 0.75 inches thick.

1 On the ribbon ➤ Polygon Modeling panel, click
more.

2 On the ribbon ➤ Edit panel, click

(Edge) once

(SwiftLoop).
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Now, as you position your cursor near an edge, a green virtual loop
displays. This helps you visualize the placement of the loop.

3 In the viewport, click a horizontal polygon edge.
3ds Max Design creates a loop perpendicular to the edge you clicked.
This method is a fast way to create and position a loop on a model.
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Based on the diagram, you want the loop to be positioned 0.75 inches
from the back edge of the box.

4 On the main toolbar, click
transform field, type –0.75.

(Select And Move), then in the Y
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NOTE Activating Select And Move turns off SwiftLoop.
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5 On the ribbon ➤ Edit panel, click

(SwiftLoop) to turn it on again.

6 In the viewport, click a vertical edge anywhere in the upper part of the
panel.

7 On the main toolbar, click
transform field, type 5.25.

(Select And Move), then in the Z

This value represents the height of the toe space created by the extrusion
in step 7, plus the thickness of the cabinet floor board you will soon
create.

8 On the ribbon ➤ Edit panel, click

(SwiftLoop) again.

9 In the viewport, click a vertical edge anywhere in the upper part of the
panel.
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10 On the main toolbar, click
transform field, type 33.75.

(Select And Move), then in the Z

This value represents the height of the base cabinet, less the 0.75-inch
thickness of the four-inch support boards you will soon create.

11 On the ribbon ➤ Edit panel, click
(SwiftLoop), then click a
horizontal edge anywhere around the midpoint of the panel.

12 On the main toolbar, click
transform field, type –4.75.
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(Select And Move), then in the Y

This represents the width of the support board, plus the thickness of the
rear cabinet board.
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13

Place another vertical loop, then on the main toolbar, click

(Select And Move), and in the Y transform field, type –19.5.
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This represents the width of the support board, less the length of the side
cabinet board.
Now you have all the subdivisions required to build upon this cabinet
component.
Create the opposite side of the cabinet:

1 On the ribbon ➤ Polygon Modeling panel, turn off
exit the Edge sub-object level.

(Edge) to

2 From the Edit menu, choose Clone. In the Clone Options dialog ➤
Object group, turn on Copy, and then click OK.

3 Turn on

(Select And Move). On the X transform box, type 17.25.

The width of the cabinet you are building is 18 inches, measured from
the outside left of the cabinet to the outside right. Therefore, the value
of 17.25 represents the full 18 inches, less half the width of the left and
half the width of the right cabinet boards (which combined, equal 0.75
inches).

4 In the viewport,

select the original cabinet board, on the left,

and on the ribbon ➤ Geometry panel, click
on.

(Attach) to turn it

5 In the viewport, click the right (cloned) cabinet board.
This combines both boards into a single object.
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Create the counter supports:

1 On the ribbon ➤ Polygon Modeling panel, click

(Polygon),

then
click an empty part of the viewport to make sure no
polygons are selected.

2

3

Click and Ctrl+click the two polygons at the upper-right corner
of the panel on the right. This is where the front counter support will be
attached.

Orbit so you can see the corresponding corner polygons on the

inside of the left panel, then
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Ctrl+click to select these as well.

4 On the ribbon ➤ Polygons panel, click

(Bridge).

3ds Max Design connects the selected polygons to one another.
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Front support created from selected polygons

5 Press Shift+Z to undo the view change.

224 | Chapter 3 Modeling Tutorials

6

7

Click to select the single polygon where the other counter
support will be attached. Don’t select the small face at the very rear of
the cabinet.

Orbit again so you can see the corresponding face on the inside

of the panel on the left, then
Ctrl+click to select this polygon
as well. (Once again, don’t select the small polygon at the very rear of
the cabinet.)
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8 Click

(Bridge) again.

3ds Max Design creates the rear counter support.
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9

Click an empty area of the viewport to deselect the polygons
from the previous step.

Create the back of the cabinet:

1

Orbit,
zoom, and
pan the view so you can see the
rear of the cabinet and the inside of the panel on the right.
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2 On the ribbon ➤ Modify Selection panel ➤ drop-down portion, click

(Step Mode) to turn it on.
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When Step mode is on, selecting two sub-objects (in this case, polygons)
also selects the polygons along the shortest path between the two
sub-objects.

3

Click to select the inside top-left polygon at the back of the
cabinet, then Ctrl+click the inside bottom-left polygon.
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4

Orbit, then
Ctrl+click to select the vertical loop of
corresponding polygons on the opposite side of the back of the cabinet.
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5 Click

(Bridge).

232 | Chapter 3 Modeling Tutorials

Back panel created from selected polygons

6

Deselect the back cabinet board you just created, then
orbit so you can see the front of the cabinet again (or press Shift+Z a
number of times to undo your view changes).
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Create the bottom shelf and base board:

1

Click and to select the leading polygon at the bottom of the
overhanging portion of the panel, as shown in the next illustration.

2

Orbit, then
Ctrl+click to select the corresponding polygon
on the other side of the cabinet.
3ds Max Design selects a loop of polygons that runs around the inside
of the bottom of the cabinet.
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3

Alt+click to deselect the polygon on the inside of the back cabinet
board.
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4 Click

(Bridge).

3ds Max Design creates the bottom shelf.

The only task that remains to complete the cabinet body is the base board
or “kick plate.”

5 Click

6

(Step Mode) again to turn it off.

Click and Ctrl+click to select the left and right polygons at the
base of the cabinet.
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7 On the ribbon ➤ Polygons panel, Shift+click

(Extrude).

8 On the second caddy control for the Extrude tool, Height, set the value

to 0.75 and then click

(OK).
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9

Click an empty area of the viewport to deselect all polygons.

10

Orbit so you can see the inner faces at the bottom of the cabinet.

11 Click and Ctrl+click the inside faces of the left and right polygon
extrusions you just created.
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12 On the ribbon ➤ Polygons panel, click

(Bridge).

Next, you will remove a number of edges that, while important to this
point for polygon creation, are no longer needed.
Remove excess edges:

1 On the ViewCube, click the Home icon, then
zoom and
pan so you have a good perspective view of the cabinet.
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2 On the ribbon ➤ Polygon Modeling panel, click

3 On the Modify Selection panel, click

(Edge).

(Loop Mode).

Any edge you now select, will also select all the other edges in the loop
it is part of.

4

Click the edge shown in the next illustration.
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5 On the ribbon ➤ Loops panel, Ctrl+click

(Remove Loop).

By Ctrl+clicking, you are removing both the loop, and any vertices created
by the loop.
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6 Continue to select edge loops on the side of the cabinet and Ctrl+click

(Remove Loop) until the side panel appears to be a single piece
of wood again, as shown in the next illustration.
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Left side of cabinet with all extra edges removed

7 Using the same technique,
of the other panel of the cabinet.

remove the edge loops on the inside
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8

Click and Ctrl+click the edges on each side of the kick plate,

then Ctrl+click

(Remove Loop).
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9

Orbit the cabinet to see its opposite side, then
delete the loop toward the back of the board.
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select and

10 On the ribbon ➤ Polygon Modeling panel, click
the Edge sub-object mode.

(Edge) to exit
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Reposition the pivot point:
Now you will move the pivot point from its current position at the bottom-left
corner of the cabinet to the bottom midpoint of its backboard. By doing this,
you will make it easier to attach the cabinet to its required position in a scene.

1 Go to the
Hierarchy panel, and in the Adjust Pivot rollout ➤
Move/Rotate/Scale group, click Affect Pivot Only to turn it on.

2 On the main toolbar, click
the cabinet.

(Align), then in the viewport, click

3 In the Align Selection dialog ➤ Align Position (World) group, make sure
X Position is on and Y Position and Z Position are off. In the Current
Object group, choose Pivot Point and in the Target Object group, choose
Center, then click OK.
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4 Click Affect Pivot Only again to exit pivot-translation mode.

5 With
Move active, in the status bar ➤ transform fields,
right-click the X spinner arrows to move the cabinet back to the world
origin coordinates (0,0,0).
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Create a shelf:

1 On the
Create panel, click
Type rollout, click Box.

(Geometry), then on the Object

2 In the viewport, drag out a box of any size.
3 In the Parameters rollout, set Length to 12.0, which will be the depth of
the shelf. Set Width to 16 3/8, and Height to 0.75, which is the thickness
of the cabinet boards.
The Width is based on the full width of the cabinet (18 inches), less the
3/4 inch width of each side board, less another 1/8 inch space to provide
room to remove the shelf, if needed.

4 On the main toolbar, click
the cabinet.

(Align), then in the viewport, click

5 In the Align Selection dialog ➤ Align Position (World) group, turn on
X Position, Y Position, and Z Position. In the Current Object and Target
Object groups, choose Center, then click OK.

6 On the main toolbar, click
(Select And Move), then move the
shelf on its Y axis until it is touching the backboard.
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7

Select the cabinet.

8 On the ribbon ➤ Polygon Modeling panel, click Modify Mode.
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When active, Modify Mode makes the entire array of Graphite Modeling
Tools available.

9 On the Geometry panel, click
the shelf.

(Attach), then in the viewport, click

This makes the shelf and the cabinet both part of a single object.
Assign material IDs:
Now you will assign material IDs to the cabinet polygons so they can receive
different types of materials.

1 On the main toolbar, click
Material Editor.

(Material Editor) to open the Compact

NOTE There are two versions of the Material Editor: the Compact interface,
and the Slate interface. The Slate version is more versatile when you are
designing materials, while the Compact version is a bit more convenient
when you just need to assign existing materials.
2 Click the top-left sample slot to make it active. The material in this slot
is named Cabinets.
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3 In the Material Editor, click
4

(Assign Material To Selection).

Close the Compact Material Editor.

5 On the ribbon ➤ Polygon Modeling panel, click

(Polygon).

6 Press Ctrl+A to select all the polygons in the cabinet.
7 On the ribbon ➤ Properties panel ➤ drop-down portion, click

(MatIDs).

3ds Max Design opens a Set ID dialog.
8 On the Set ID dialog, type 1 in the Set ID field, then press Enter.
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9

Close the Set ID dialog.

10 Click an empty part of the viewport to deselect all polygons, then
click and Ctrl+click to select the polygons that face forward, as shown in
the next illustration.
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11 On the ribbon ➤ Properties panel ➤ drop-down portion, click

(MatIDs) once more.
12 On the Set ID dialog, type 2 in the Set ID field, then press Enter.

Using Basic Polygon Editing to Create a Base Cabinet | 259

13

Close the Set ID dialog.

14 Click an empty part of the viewport to deselect the polygons.

The front faces of the cabinet change color, indicating
they are set to a different material ID number than
the rest of the cabinet.
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The front faces of the cabinet now have a sub-material that is distinct
from the sub-material on the rest of the cabinet.

15 On the ribbon ➤ Polygon Modeling panel, turn off
to exit the Polygon sub-object level.

(Polygon)

Using Basic Polygon Editing to Create an Upper Cabinet
Now you will use many of the techniques from the previous lesson to create
an upper cabinet.
Set up the lesson:

■

Continue working from the previous section, or

open kitcab_1.max.

Create the upper left cabinet board:

1 In the viewport,
select the base cabinet and on the
Modify panel, rename the object LoCab_18.

2 On the
Create panel, click
Type rollout, click Box.

(Geometry), then on the Object

3 In a viewport, drag out a box of any size.
Referring to our diagram, you can see that the length of the board you
will specify in the next step should be 11 3/4”.
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The height for upper cabinets of this design is variable, to account for
the presence of appliances, sinks, windows, and so on. In this case, the
upper cabinet will be installed on a wall with nothing between it and the
base cabinet, so you will give it a height of 39”. You will specify this
height as a negative value, so you can better position the cabinet as part
of the total 93” allowable space.

4 Go to the
Modify panel, and on the Parameters rollout, set Length
to 11.75, Width to 0.75, and Height to –39.0.
Keep in mind that as soon as you type in the values, 3ds Max Design
converts the decimal portions to multiples of 1/32”.
NOTE It might seem odd to use a negative height for the board. The top of
kitchen cabinets is always a fixed height of 84 inches or 93 inches (93 inches
in the case of this model). The lower portion can vary in increments of 3
inches, as we mentioned before, so it makes sense to measure the upper
cabinet from the top down.

5 On the main toolbar, click
transform value to 93.0.

(Select And Move), then set the Z

The top of the box is now above the base cabinet at the proper height.
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6 Click

(Zoom Extents).

Now you need to align the box with the left side of the lower cabinet.

7 On the main toolbar, click
the lower cabinet.

(Align), then in the viewport, click

8 In the Align Selection dialog ➤ Align Position (World) group, make sure
X Position is on and Y Position and Z Position are off. In the Current
Object group, choose Minimum and in the Target Object choose
Minimum, then click Apply.
9 Turn on Y Position and in the Current Object group and Target Object
group, choose Maximum, then click OK.
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Left panel of upper cabinet aligned with left panel
of lower cabinet
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Add polygon edges:
1 In the viewport, right-click the box and choose Convert To ➤ Convert
To Editable Poly.

2 On the ribbon ➤ Polygon Modeling panel, turn on

3 On the ribbon ➤ Edit panel, click

(Edge).

(Swift Loop) to turn it on.

A green virtual loop will now display as you position your cursor near an
edge, to help you visualize loop placement.
4 In the viewport, click a vertical polygon edge.
3ds Max Design creates an edge loop that is perpendicular to the edge
you clicked.

5 On the main toolbar, click
transform spinner to 92.25.

(Select And Move), then set the Z

Using Basic Polygon Editing to Create an Upper Cabinet | 265

6 On the Edit panel, click

(Swift Loop) again.

7 Click a vertical edge to place another horizontal loop, using the green
virtual loop as a guide.

8 On the main toolbar, click
transform spinner to 54.75.

(Select And Move), then set the Z

This value represents the distance from the floor to the top of the board,
(93”), less the height of the board itself (39”), plus the width of the board
cut line you want to create (–0.75”).
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9 On the Edit panel, click

(Swift Loop) again.

10 Click a horizontal edge.

11 On the main toolbar, click
transform spinner to –0.75.

(Select And Move), then set the Y

This value represents the cut line for the 0.75-inch back board you will
soon create.
You now have all the divisions required to build upon this cabinet
component.
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12 On the ribbon ➤ Polygon Modeling panel, turn off
exit sub-object selection.
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(Edge) to

Create a second cabinet board:
1 On the Edit menu, choose Clone. In the Clone Options dialog ➤ Object
group, choose Copy, and then click OK.

2

Move the cloned board on its X axis slightly to the right.

Using Basic Polygon Editing to Create an Upper Cabinet | 269

3 On the main toolbar, click
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(Align).

4 In the viewport, click the lower cabinet. In the Align Selection dialog ➤
Align Position (World) group, make sure X Position is on and Y Position
and Z Position are off. In the Current Object group, choose Maximum,
and in the Target Object group, choose Maximum, then click OK.

5

Select the upper left-hand cabinet board (the original board),

and on the ribbon ➤ Geometry panel, click
the cloned board.

(Attach), then click

Create the top, bottom, and back boards:

1 On the ribbon ➤ Polygon Modeling panel, click

2

(Polygon).

Click and Ctrl+click to select the polygons that form the
attachment points for the right-hand board.
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3

Orbit the view, then
polygons on the left panel.

Ctrl+click to select the corresponding

4 On the ribbon ➤ Polygons panel, click
3ds Max Design connects the selected polygons.
5 Press Shift+Z to undo the orbit.
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(Bridge).

Bottom, top, and back panels created from selected polygons

6

Orbit a little more to get a better view of the side of the cabinet.
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7 On the ribbon ➤ Polygon Modeling panel, click

8 On the ribbon ➤ Modify Selection panel, click

9 One by one,

(Loop Mode).

select the loops shown in the following illustrations,

and on the ribbon ➤ Loops panel, Ctrl+click
remove the loops and their vertices.
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(Edge).

(Remove Loop) to
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10 Repeat the preceding step for the other side of the cabinet.

11 Click

(Edge) again to exit the Vertex sub-object level.

Create shelves:

1

Orbit the scene until you can see the front of the cabinet.
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2 On the
Create panel, click
Type rollout, click Box.

(Geometry), then on the Object

3 In the viewport, drag out a box of any size.
4 In the Parameters rollout, set Width to 16 3/8.
Like the shelf you created for the base cabinet, this value represents the
full width of the cabinet (18 inches), less a 3/4 inch width of each side
board, less another 1/8 inch space to provide room to remove the shelf,
if needed.
Set Length to 10.5, which will be the depth of the shelf, and Height to
0.75, which is the thickness of the cabinet boards.

5 On the main toolbar, click
the upper cabinet.

(Align), then in the viewport, click

6 In the Align Selection dialog ➤ Align Position (World) group, turn on
X Position, Y Position, and Z Position, and in the Current Object and
Target Object groups, choose Center, then click OK.

7

Move the shelf on its Y axis until it touches the backboard. This
adjustment is easiest in the Top viewport.
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8

Shift+move the shelf upward on its Z axis, and in the Clone
Options dialog ➤ Objects group, make sure Copy is on, then click OK.

9

Adjust the height of the two shelves until they are spaced apart
equally.
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10

Select the cabinet.

11 On the ribbon ➤ Polygon Modeling panel, click Modify Mode to turn

it on. On the Geometry panel, click
shelves.

(Attach), then click the two

12 Right-click to turn off the Attach tool.
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Next, you will assign material IDs to the polygons so they can receive
different sub-materials.
Assign Material IDs:

1 On the main toolbar, click
Material Editor.

(Material Editor) to open the Compact

2 Click the top-left sample slot to make it active. The material in this slot
is named Cabinets.

3 Drag from the Cabinets sample slot and release the mouse over the upper
cabinet to apply this material.
Dragging and dropping is an alternative way of applying materials.
4

Close the Compact Material Editor.
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5 On the ribbon ➤ Polygon Selection panel, activate

(Polygon).

6 Press Ctrl+A to select all the polygons in the upper cabinet.
7 On the ribbon ➤ Properties panel ➤ drop-down portion, click

(MatIDs).
8 On the Set ID dialog, type 1 in the Set ID field, then press Enter.

9

Close the Set ID dialog.

10 In the viewport,
click and Ctrl+click to select the polygons that
face forward, as shown in the next illustration.

Using Basic Polygon Editing to Create an Upper Cabinet | 283

11 On the Properties panel ➤ drop-down portion, click
(MatIDs)
once more, and on the Set ID dialog, type 2 in the Set ID field, then press
Enter.

12

Close the Set ID dialog.

13 Click an empty part of the viewport to deselect the polygons.
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14 On the ribbon ➤ Polygon Selection panel, click
exit the Polygon sub-object level.

(Polygon) to

Adjust the pivot:
Finally, modify the upper cabinet so that its local coordinates, represented by
its pivot point, are the same as those of the lower cabinet. This way, the next
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time you want to place the upper cabinet in the scene, it will be positioned
at the correct height in relation to the floor and in line with the lower cabinet.

1 Go to the
Hierarchy panel, and in the Adjust Pivot rollout ➤
Move/Rotate/Scale group, click to turn on Affect Pivot Only.

2 On the main toolbar, click

(Align), then click the lower cabinet.

3 In the Align Selection dialog ➤ Align Position (World) group, turn on
X Position, Y Position, and Z Position and in the Current Object and
Target Object groups, choose Pivot Point, then click OK.

Left: Upper cabinet before pivot alignment
Right: Upper cabinet after pivot alignment
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4 On the
Hierarchy panel ➤ Adjust Pivot rollout ➤
Move/Rotate/Scale group, click to turn off Affect Pivot Only.

5

Select the upper cabinet and on the
rename the object HiCab_18_39.

Modify panel,

Save your work:
Save your scene as my_kitcab_2.max.

■

Using Extrusions and Bevel Profiling to Create Cabinet
Doors
If your cabinet doors require flat, uniform surfaces, you can create them using
the polygon modeling techniques covered so far in this tutorial. However, if
you need to add more detail, you can use extrusions and bevel profiling as
this lesson shows.
Set up the lesson:

Continue working on your scene from the previous lesson, or
kitcab_2.max.

■

open

Create a basic door:
1 In the viewport, switch to Front view in Wireframe mode.

2

Zoom in to the base cabinet and on the main toolbar, click to

turn on
(3D Snaps Toggle), then right-click the same button to
display the Grid And Snap Settings dialog.
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3 Activate the Snaps tab, click Clear All, turn on Vertex, then
close the dialog.

4 On the
Create panel, click
Type rollout, click Box.

(Geometry), then on the Object

5 In the viewport, drag out a box until it covers the front of the cabinet.
Be sure not to cover the kick plate area as you create the box.
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First corner
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Second corner

6 On the Parameters rollout, set Height to 0.5.
This is slightly less than the 0.75-inch board thickness we’ve used
elsewhere in the cabinet. You will increase the door thickness later on
when you use extrusion to add detail to the door surface.

7 On the main toolbar, click

mode, then click

(3D Snaps Toggle) again to exit snap

(Select And Move).

8 In the viewport, switch to a Top view with Smooth + Highlights, and
move the door on its Y axis so that it is slightly separated from the cabinet.
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Top view, with door slightly separated from cabinet

Use an extrusion to create a simple inset:
1 Right-click the door and choose Convert To ➤ Convert To Editable Poly.
2 Use the ViewCube to switch to the Home (Perspective) view, and on the
ribbon ➤ Polygon Modeling panel, turn on

3 In the viewport,

(Polygon).

select the front face of the door and on the

ribbon ➤ Polygons panel, Shift+click

(Inset).
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3ds Max Design displays the caddy controls for the Inset tool.

4 On the second control of the Inset caddy, Amount, set the value to 3.0,

and then click
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(OK).

This creates a three-inch inset for the selected polygon.

5

Click an empty area of the viewport to deselect all polygons,
then click and Ctrl+click to select the polygons that surround the inset.

On the ribbon ➤ Polygon panel, Shift+click

(Extrude).

6 On caddy for the Extrude Polygons tool, set the second control, Height,

to 0.25, and then click

(OK).
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This creates a simple door with a center panel that is recessed by one
quarter inch.

7 On the ribbon ➤ Polygon Modeling panel, click

8 On the ribbon ➤ Modify Selection panel, click

9

(Edge).

(Loop Mode).

Click one of the edges that surround the inset panel.
3ds Max Design selects a loop around the perimeter of the panel inset.
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10 On the ribbon ➤ Edges panel, Shift+click

(Chamfer).

11 On the first control of the caddy for the Chamfer tool, Edge Chamfer

Amount, change the value to 0 2/32, and then click

(OK).
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The inside edge of the raised panel now has a slight bevel to it.

12

Select the outside edge of the door and click
(Chamfer)
to bevel the edge of the cabinet door. (You don’t need to Shift+click this
time: The Chamfer tool will use the same value as the last time you used
it.)
A combination of extrusion and chamfering is an effective way to produce
a straightforward door. If you prefer to add even more detail, you can do
so by means of a beveled profile.
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Use bevel profiling to add detail:
In this procedure, you will backtrack and create an entirely new cabinet door
using the Bevel Profile modifier and two 2D splines.

1 On the ribbon ➤ Polygon Modeling panel, turn off

exit the Edge sub-object level, then in the viewport,
cabinet door you created in this lesson and press Delete.

2 Switch to a Front view and

3 On the
Create panel, click
Type rollout, click Rectangle.

4 On the main toolbar, turn on

(Edge) to

select the

zoom in on the lower cabinet.

(Shapes), then on the Object

(3D Snaps Toggle).

5 In the viewport, drag out a rectangle so it covers the front of the cabinet,
then right-click to end object creation. As you draw the rectangle, be sure
not to cover the kick plate area.
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You will use this rectangle as one of the two splines you’ll need to create
the bevel profile. This spline will define the bevel area.

6 On the main toolbar, turn off

(3D Snaps Toggle).

7 In the viewport, use the ViewCube to return to the Home (Perspective)
view.

8 Go to the
Modify panel, and on the Parameters rollout, set Length
to 29 7/8 and Width to 17 7/8.
You now need to add a second spline, one that will define the shape of
the bevel itself. You can draw the spline yourself, or use the line tool to
trace over images of existing molding profiles, as shown in the next
illustration.
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Cross section of sample cabinet door panels, with spline (red) traced over a portion
of their profiles

Your kitcab_2.max scene file already contains three splines, ready for you
to use.
9 Right-click an empty area of the main toolbar and choose Layers.
10 On the Layers toolbar, open the Layers list, and click the light-bulb icon
for the Profiles layer to unhide the profile splines.

The three splines appear at floor level, off to the right of the cabinets.
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11 If you need to,

12

zoom out until the profile splines are visible.

Close the Layers toolbar.

13 In the viewport, make sure the rectangle you created earlier is still selected,

and from the

Modify panel ➤ Modifier List, choose Bevel Profile.

14 On the parameters rollout, click Pick Profile.
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15 Click a profile spline and view the result on the cabinet door.

Cabinet (left) with spline profiles (right)

16 Continue to click Pick Profile and then different splines to see their effect
on the door. Stop at Profile B.
Create a bevelled door for the upper cabinet:

1 Switch to a Front view and

zoom in on the upper cabinet.
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2 On the
Create panel, click
Type rollout, click Rectangle.

3 On the main toolbar, turn on

(Shapes), then on the Object

(3D Snaps Toggle).

4 In the viewport, drag out a rectangle so it covers the front of the upper
cabinet.
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5 On the main toolbar, turn off

(3D Snaps Toggle).

6 In the viewport, use the ViewCube to return to the Home (Perspective)

view, then

pan down so you can see all of the upper cabinet.
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7 Go to the
Modify panel. On the Parameters rollout, set Length
to 38 7/8 and Width to 17 7/8.
8 From the Modifier List, choose Bevel Profile.
9 On the parameters rollout, turn Pick Profile, and in the viewport, click
Profile B.
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Cabinets with spline profile B applied to their doors
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Next, you will adjust the pivot points so you will be able to open the
doors properly.
Adjust the door pivot points:

1 Switch to a Front view, go to the
Hierarchy panel, and in the
Adjust Pivot rollout ➤ Move/Rotate/Scale group, turn on Affect Pivot
Only.
2 Right-click the upper cabinet door and choose Transform ➤ Move.
3 Drag the pivot on its X axis to the far left side of the door.

Pivot repositioned to the left side of the cabinet door
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4 Click Affect Pivot Only again to turn it off, and on the main toolbar,
right-click the upper cabinet door again and choose Transform ➤ Rotate.
5 In Perspective view, rotate the door on its Y axis to see the result.

6 Repeat steps 1 to 5 for the lower cabinet door.
7 Return the doors to their closed positions.
To this point, you have adjusted the pivots so the doors appear to move
on hinges. Next, you’ll modify the cabinets for situations when you don’t
need to open the doors.
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Make the doors fixed:
1 Right-click the lower cabinet door, then choose Convert To ➤ Convert
To Editable Poly.

select the lower cabinet. On the ribbon ➤

2 In the viewport,

Geometry panel, click

(Attach), then click the lower door.

This attaches the lower door to the rest of the cabinet.
3 Repeat steps 1 and 2 for the upper door.
Set the material properties for the doors:

1 Turn on

2

(Polygon).

Region-select all the polygons in the lower door.
(If the region chooses faces not part of the door, use Alt+click to remove
those faces from the selection.)

3 On the ribbon Properties panel drop-down protion, click
MatIDs, and on the Set ID dialog, change the Set ID field to 2. Press Enter.
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4 Repeat steps 1 to 3 for the upper cabinet.
In the lessons that follow, you will learn how to produce other kitchen
cabinets based on these two cabinets, the upper and the lower. The variant
cabinets will have different dimensions or symmetry.
Save your work:
■

Save your scene as my_kitcab_3.max.

Creating Cabinets of Various Sizes
In this lesson, you will use a combination of cloning and vertex editing
techniques to quickly create more cabinets of various heights and widths.
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Set up the lesson:

■

Continue working on your scene from the previous lesson, or
kitcab_3.max.

open

Create a 24 inch-wide lower cabinet:

1 On the main menu, click

(Select And Move).

2 In Perspective view, select the lower cabinet and Shift+drag the object on
its X axis to the left.
3 In the Clone Options dialog ➤ Object group, make sure Copy is turned
on.
4 In the Name field, type LoCab_24 and click OK.

You are specifying the value 24, because the cabinet you are about to
create will be 24 inches wide.

5 In the viewport, switch to Front view, then
cabinets.
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zoom in on the lower

6 On the ribbon ➤ Polygon Modeling panel, click Modify Mode.

7 On the ribbon ➤ Polygon Modeling panel, activate

(Vertex).
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8

Region-select the left side of the new cabinet so all its vertices
are selected.
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9 On the main toolbar, click

(Select And Move).

10 On the status bar, click
(Absolute Mode Transform Type-In) to
change to Offset transform mode.
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11 In the X transform field, enter –3.0, the press Enter.

12

Region-select the right side of the cabinet so that all its vertices
are selected, and in the X transform field, enter 3.0.
You are enlarging the cabinet equally on either side to ensure that the
cabinet’s pivot point remains in the center of the object.

Create double doors for the new cabinet:
Cabinets that are 24 inches wide generally have double doors rather than a
single one.

1 On the ribbon ➤ Polygon Modeling panel, click

the viewport,

(Element). In

select the cabinet door.

2 On the Polygon Modeling panel, Ctrl+click
vertex selection.

(Vertex) to activate

Holding down Ctrl while you click this button selects all the vertices that
were in the previous Element selection.
3 Alt+region-drag around all the vertices on the left side of the door, to
remove them from the selection.

4 On the main menu, activate

(Select And Move).

5 Set the X transform field to –12.0.
By moving the remaining selected vertices to the left by 12 inches, you
just created a 12-inch door.
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6 On the ribbon ➤ Polygon Modeling panel, click

7

(Element).

Shift+drag the door to the right until it is in position over the
opposite side of the cabinet.

8 On the Clone Part Of Mesh dialog, check that Clone To Element is on,
then click OK.
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9 Click

(Element) again to exit sub-object selection.
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Create a 21-inch-high upper cabinet:

1 Select the upper cabinet and
to the right.

Shift+drag the object on its X axis

2 In the Clone Options dialog ➤ Object group, choose Copy, and in the
Name field, type HiCab_18_21, then click OK.
You are specifying the value 21, because the cabinet you are about to
create will be 21 inches high.
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3 On the ribbon ➤ Polygon Modeling panel, click

(Vertex).

4 In the viewport,
region-select the bottom of the cabinet so that
all its vertices are selected.

5 Set the Y transform box to 18.0.
This value represents the full height of the 39-inch upper cabinet, less
18 inches, to give you a 21-inch high cabinet.
Now that you have resized the cabinet, you will discover that its lower
shelf is now exposed.

6 On the ribbon ➤ Polygon panel, click

7 In the viewport,

(Element).

select the exposed shelf, then press Delete.

8 In the Perspective viewport, switch to Wireframe mode.

Region-select the remaining shelf, then
Z axis.

move it upward on its

(It is hard to select the shelf by clicking the cabinet.)
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9 On the ribbon ➤ Polygon panel, click
Element sub-object level.

(Element) to exit the

10 Switch to Smooth + Highlights display mode, then save your scene as
my_kitcab_4.max.

Using Symmetry To Create a Corner Cabinet
In this lesson, you will use the Symmetry modifier to create a corner cabinet.
Set up the lesson:

■

Continue working on your scene from the previous lesson, or
kitcab_4.max.

open
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Create a corner cabinet:
1 In the viewport, make sure you are in Perspective view.

2

Region-select all the cabinets in the scene, except for the 24
inch cabinet with the double doors.

3 Right-click and choose Display ➤ Hide Selection, so only the 24-inch
cabinet is visible.
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4 Select the cabinet and
right.

Shift+drag the object on its X axis to the

5 In the Clone Options dialog ➤ Object group, choose Copy, and in the
Name field, type LoCab_Corner, then click OK.
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6

Select, then hide the first 24-inch cabinet as you hid the others
in step 3.

7

Select the cloned cabinet.

8 On the status bar, click
(Absolute Mode Transform Type-In) to
change to Offset transform mode.

(If you continued working from the previous lesson, Offset mode is already
active.)

9 Go to the
Hierarchy panel and in the Adjust Pivot rollout ➤
Move/Rotate/Scale group, click Affect Object Only.
This lets you move the object but not its pivot. In the next step, you will
move the object so that its pivot point is at the cabinet’s back right corner.
10 In the X transform field, type –12.0, then turn off Affect Object Only.
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11 On the ribbon ➤ Polygon Modeling panel, click Modify Mode, then
click

(Element).

12 In the viewport, select the right-hand cabinet door, then press Delete.
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A corner cabinet is typically 36 inches wide, so next you will expand the
width of the cabinet.
Widen the cabinet and add the Symmetry modifier:

1 In the viewport, switch to Top view, then

zoom in on the cabinet.

2 On the ribbon ➤ Polygon Modeling panel, click
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(Vertex).

3 Region-select all the vertices on the left side of the cabinet, including the
entire door.

Top view of cabinet with all left vertices selected

4 On the main menu, click

(Select And Move).

5 On the status bar, make sure the transform mode is
set the X transform field to –12.0.

Offset, then
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Top view of cabinet after resizing

6 On the ribbon ➤ Polygon Modeling panel, click
to exit the Vertex sub-object level.

(Vertex) again

7 Use the ViewCube to return to the Home (Perspective) view. Change the
view to Smooth + Highlights + Edged Faces.
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8 Go to the

Modify panel. On the Modifier List, choose Symmetry.

The modifier gizmo displays in the viewport, oriented in the direction
of the cabinet’s pivot point.
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Symmetry gizmo displayed

9 In the Parameters rollout ➤ Mirror Axis group, turn on Flip.

3ds Max Design flips the cabinet about its X axis.
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10 In the modifier stack,
highlight Mirror.

expand the Symmetry modifier, and click to

11 On the main toolbar, turn on

(Angle Snap Toggle), then click

(Select And Rotate).
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12

Rotate the mirrored portion of the cabinet on its Z axis, and
stop when you reach –45 degrees.

Save your work:
■

Save your scene as my_kitcab_5.max.
To see how cabinets modeled using the ribbon can look in a completed

scene,

open kitchen_sample.max.
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Kitchen cabinets in a completed scene, with shading

Summary
Throughout this tutorial, you used a number of modeling tools on the Graphite
Modeling Tools ribbon to create a set of kitchen cabinets. While these tools
are also available from the Command panel, the ribbon gives you faster access,
in context, as you need them.
This tutorial only scratched the surface of the many ways in which the ribbon
can be used for editing mesh and polygonal objects. For a full description of
the ribbon tools, consult the 3ds Max Design help.

Using Photos to Model Façades
With a photo of a building, you can create a remarkably realistic model. This
tutorial shows you how to do so.

Using Photos to Model Façades | 331

Model of house fronts on a plaza

In this tutorial, you will model two house fronts, based on photos of buildings
in the plaza of Monpazier, a 13th-century bastide (fortified town) in Dordogne.
The illlustration shows these houses, along with two others (in the actual
plaza, the houses occupy different positions).
You use each photo both to construct the façade and to texture it. In a way,
you are “reverse engineering” the original architecture. Each house is
constructed as an Editable Poly object: You will use various polygon-editing
tools to give the façade depth so it can cast realistic shadows, and then use
the Unwrap UVW modifier to adjust the texture and improve the model’s
appearance.
TIP If you are not familiar with using the Material Editor and texture-mapping
modifiers, you might want to go through the Materials And Mapping tutorials on
page 581 first, then return to this tutorial.
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WARNING The techniques used in this tutorial are suitable for modeling
architecture and other stationary objects. They aren’t suitable for modeling organic
meshes, especially ones that you want to animate by using a feature such as the
Skin modifier or Physique. In this tutorial, we create irregular meshes that include
multisided polygons. A deformable mesh, by contrast, should contain only square
or triangular polygons of fairly uniform size (if you plan to turn the mesh into a
subdivision surface by using the HSDS modifier, then it should contain only square
polygons before you apply HSDS).
Skill level: Intermediate
Time to complete: 3 hours

Some Pointers: Preparing a Photo Before You Use It to Build a Model
This section explains how to prepare photos for use in the kind of façade
modeling the tutorial demonstrates. You might want to read it if you plan to
take your own photos (or scans) to use in a similar way. Or you might want
to skip this section, do the tutorial itself, and then read this material later.
In a photograph, as in the human eye, parallel lines appear to converge. But
to create a façade in 3ds Max Design, horizontal lines should be horizontal,
and vertical lines should be vertical. So you will almost always need to use a
graphic editing program, such as Photoshop, to adjust the photo before you
use it as a texture.
For example, here is the original photo used to create “Façade 4,” the second
building you construct in the tutorial:
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Superimposing guidelines on the house, shows that the groundline is
horizontal, and the left side is close to vertical, but that the right side needs
adjusting:
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Using a perspective-correction or “distortion” tool, lets you align the sides of
the house to the guides:
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NOTE Perspective-correction or “perspective-control” lenses are available to
eliminate the vertical, or “third” vanishing point, and make the vertical sides of a
building appear parallel. But such a lens is a specialized, expensive piece of
equipment.
A view camera, which uses a bellows for the body, can be set to accomplish
perspective correction, too. But view cameras are not in widespread use, these
days.
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A photo editor has other uses. In this example, we wanted to remove the little
girl standing in the archway:

... Which is easy to do with most such programs:
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The final step is to crop the image to the dimensions of the house itself:
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This final image becomes the bitmap used to construct and to texture the
house in Modeling the Second House on page 417.

Creating the First House
The first house, which we will call Facade1, is based on a single photograph,
adjusted in the way described in Some Pointers: Preparing a Photo Before You
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Use It to Build a Model on page 333. In this lesson, you take several steps to
set up the scene and the modifier stack, so that modeling will go more easily
when you add detail to the façade.

Begin Building the Model
The house begins as a simple plane.
Set up the scene:

■

On the Quick Access toolbar, click
(Open File), navigate to the
\scenes\modeling\facades folder, and open facade_modeling_start.max.
NOTE If a dialog asks whether you want to use the scene’s Gamma And LUT
settings, accept the scene Gamma settings, and click OK. If a dialog asks
whether to use the scene’s units, accept the scene units, and click OK.
The scene contains a plane to model the pavement, a Daylight system with
a sky dome, and a few cameras that are hidden.

Optimize bitmap display in viewports:
1 On the main toolbar, choose Customize ➤ Preferences.
2 Go to the Viewports tab, then click Display Drivers ➤ Configure Driver.
3ds Max Design opens the configuration dialog for the graphics driver
you are using (Software, OpenGL, or Direct3D).
3 Depending on the driver, there are either one or two check boxes labeled
Match Bitmap Size As Closely As Possible. If there is one, turn it on. If
there are two, turn on both of them.
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Configuration dialog for the Direct3D driver

4 Click OK to close the driver configuration dialog, and OK again to close
the Preferences dialog.
5 If you had to turn on Match Bitmap Size As Closely As Possible, then exit
3ds Max Design. Restart 3ds Max Design before you continue with this
tutorial.
Bitmap configuration changes do not take effect immediately: You always
have to restart 3ds Max Design.
If you did not have to change the Match Bitmap Size setting, you can
continue without restarting 3ds Max Design.
Make sure Use Real-World Texture Coordinates is turned off:
1 From the main toolbar, choose Customize ➤ Preferences.
2 On the Preference Settings dialog, go to the General tab.
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3 In the Texture Coordinates group, make sure Use Real-World Texture
Coordinates is off, then click OK.

The dimensions of the scene will actually be close to the real-world
dimensions, but 3ds Max Design doesn’t need to enforce that: This option
would just add complications to your work.
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View the reference/texture bitmap, and note its dimensions:
1 On the main menu, choose Rendering ➤ View Image File. In the View
File dialog, navigate to the \sceneassets\images folder, and highlight
fac1.jpg.
In the lower-left corner of the View File dialog, a status line shows the
dimensions of the image, which are 1200 x 1533 pixels. This will become
the aspect ratio of the façade.

2 Click Open to view the image at full size.
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3

Close the image window after you have looked at the photo.
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Construct the plane that will become the façade:

1 On the
Create panel, click
the Object Type rollout, click Plane.

(Geometry) active, then on

2 Near the center of the Front viewport, drag to create a plane.
3 On the Parameters rollout, enter 8.7m for the Length (the height), and
6.8m for the Width.
These dimensions roughly correspond to the aspect ratio of the photo:
1533:1200 pixels, or 0.78.
4 Also on the Parameters rollout, change Length Segs and Width Segs to
1.
(After you convert the plane to an Editable Poly surface, you will subdivide
it by using the polygon tools.)
5 Change the name of the plane to Facade1.

6 Go to the

Hierarchy panel. On the Adjust Pivot rollout, turn on

Affect Pivot Only, then
base of the Facade1 plane.
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move the pivot vertically so it is at the

Pivot moved to the base of the plane

7 Turn off Affect Pivot Only. With
(Select And Move) still active,
on the status bar, right-click the X, Y, and Z spinner arrows so the pivot
of the plane is now located at the origin (0,0,0).
Setting the Z axis to 0.0 aligns the façade with the Ground object. Setting
X and Y to 0.0 simply makes navigation easier, while you are editing the
plane.
8 Right-click the Facade1 plane, and from the Transform (lower-right)
quadrant of the quad menu, choose Convert To ➤ Convert To Editable
Poly.
Texture the plane:

1

Open the Slate Material Editor.
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2 On the Material/Map Browser panel, locate Materials ➤ mental ray, then
drag the Arch & Design entry to the active View (the large panel labeled
View1 in the center of the Editor).

3ds Max Design displays the Arch & Design material node in the active
View.
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3 Double-click the Arch & Design material node to display the material
parameters in the Parameter Editor panel on the right.
4 Name the material Facade 1.

5 On the Templates rollout, choose Matte Finish from the drop-down list
of templates.

6 On the Material/Map Browser panel, locate Maps ➤ Standard, and drag
the Bitmap entry into the active View.
3ds Max Design opens a file dialog.
7 On the file dialog, choose fac1.jpg, turn off Sequence, and then click
Open.
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IMPORTANT In the Select Bitmap Image File dialog, be sure to turn off the
Sequence toggle.

When Sequence is on, 3ds Max Design attempts to create an IFL animation,
and we want to open only the single image.
3ds Max Design adds a Bitmap node to the active View.
8 Drag from the Bitmap node’s output socket (the small circle at the right).
A wire appears in the View. Drop the end of the wire on the Arch & Design
material’s Diffuse Color Map input socket (the small circle at the left).
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9 Drag from the Bitmap node’s output socket again, and this time connect
the wire to the Arch & Design material’s Bump Map component.
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10 Click the Facade 1 material node again to make it active, then on the Slate

Material Editor toolbar, click

then turn on
11

(Assign Material To Selection), and

(Show Map In Viewport).

Close the Slate Material Editor.

12 Activate the Front viewport, and press F3 to turn on shading.

352 | Chapter 3 Modeling Tutorials

Shaded plane in Front viewport

Save your work:
■

Save the scene as facade1_begin.max.

Set Up the Stack so 3ds Max Design Preserves the Photo Projection
You are almost ready to add detail to the façade. But first, you need to set up
3ds Max Design so it displays the façade texture consistently, without
distortion, and so it clearly highlights selected polygons.
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Set up the scene:

■

Continue working on your scene from the previous section, or
open \modeling\facades\facade_modeling_01.max.

The goal of the steps in this section is to be able to edit the Facade1 poly surface
without distorting the texture projected onto it. Editable Poly objects have a
toggle, Edit Geometry rollout ➤ Preserve UVs, that does a good job of
preserving the projection in most cases.

Moving an edge while Preserve UVs is off
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Moving an edge while Preserve UVs is on

The stack setup used in this section is an alternative method that works for
surfaces other than Editable Poly.
Add a UVW Map modifier:

1

Select Facade1, then go to the

Modify panel.

2 From the Modifier List, choose UVW Map.
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The UVW Map modifier has no visible effect: It merely provides more
explicit mapping control than the implicit mapping provided by the
Facade1 object’s texture coordinates.

3 In the modifier stack controls, make sure that
On/Off Toggle) is on.

(Show End Result

Add a Poly Select modifier:
1 In the modifier stack, go down one level to the Editable Poly object
(Facade1).
2 From the Modifier List, choose Poly Select.
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3 In the modifier stack controls, make sure that
is on for Poly Select as well.

(Show End Result)

4 In the modifier stack, go to the Editable Poly level. Make sure that
(Show End Result On/Off Toggle) is on for the Editable Poly object
(Facade1) as well as for the modifiers.
Turning on Show End Result for all three levels of the stack causes the
viewports to always display the full bitmap in its final placement, even
while you edit the underlying geometry.
NOTE Depending on your 3ds Max Design configuration, when you go to
the Editable Poly level, you might see this warning:

For the edits you are doing in this tutorial, it is safe to click Yes and proceed
with your work. You also have the choice of turning on Do Not Show This
Message Again before you click Yes: That disables display of this warning,
but it does so not only for this tutorial, but for all future 3ds Max Design
sessions. The choice is up to you, but for the remainder of this tutorial, we
won’t mention the warning dialog again.
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Now you have set up the stack so you can see the undistorted bitmap
projection, even while you edit the geometry of Facade1.

Stack setup for editing a poly surface
with a bitmap
Show End Result must be on for all
three levels.

One further adjustment corrects for the situation that highlighted polys are
hard to see with the default color scheme.
Change the color of selected faces:

1 On the
Modify panel, with the Editable Poly level active in the
stack, scroll down to the Subdivision Surface rollout, and open it if it isn’t
already open.
2 On the Subdivision Surface rollout, make sure Show Cage is on.
3 Click the second of the color swatches that follow Show Cage.

This color is the color of highlighted polygons.
4 On the Color Selector, choose a bright red as the highlight color, and
then click OK.
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In the next lesson, you will turn Facade1 into a three-dimensional façade.
Save your work:
■

Save the scene as facade1_stack.max.

Next
Begin Adding Detail to the Façade: Modeling the Windows on page 359

Begin Adding Detail to the Façade: Modeling the
Windows
Now that you have set up the stack and the color of selected polygons, you
are ready to turn the plane of the façade into a three-dimensional model.
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Set up the lesson:

Continue working on your scene from the previous lesson, or
\modeling\facades\facade_modeling_02.max.

■

If you open the file,

select the façade, go to the

panel, and make sure that
levels of the stack.
■

open

Modify

(Show End Result) is on for all three

If you continue from the previous lesson, do the following:
1 Activate the Front viewport.

2 Click
(Maximize Viewport Toggle) (or click Alt+W) to maximize
the Front viewport.
3 Press F4 to make sure Edged Faces are displayed.

Adjust the line of the eaves:

1 Go to the
Modify panel. In the modifier stack, click to activate
the Editable Poly level.
TIP You will use the Graphite Modeling Tools ribbon, but the ribbon doesn’t
display all options unless the Modify panel is active, and the geometry is
chosen in the stack.
2 If the Graphite Modeling Tools ribbon is not displayed, then on the main

toolbar, click
click the ribbon’s
panels display.
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(Graphite Modeling Tools (Open)). If you need to,
expand/collapse icon until the full-size ribbon

3 On the Graphite Modeling tools tab, click
Edge sub-object level.

4 Select the top edge of Facade1, then
the roof.

(Edge) to turn on the

move it downward to hide

You will restore the roof later, in a following lesson.
Add edges for the windows:

1

Zoom the viewport so you have a good view of the three windows
in the upper portion of the wall.

2 On the Graphite Modeling tools tab ➤ Edit panel, click to turn on
(SwiftLoop).

Begin Adding Detail to the Façade: Modeling the Windows | 361

The SwiftLoop tool adds edges to the Editable Poly surface by drawing a
“loop” from one edge to another.
NOTE In this tutorial, you use only a handful of tools to create the façade
geometry. The ribbon has many other options that aren’t demonstrated here.
See Modeling Cabinets Using the Ribbon on page 195 for further uses of the
ribbon.
3 Drag over the façade near the top edge. 3ds Max Design constructs a
vertical edge, which you can move.

4 Click to set a vertical loop at the left edge of the small window in the
upper left of the façade.
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5 Add additional vertical loops for the other window edges.

6 Add horizontal loops to define the tops and bottoms of the windows.
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Add edges for the lintel beam and the doorways:

1

Pan down to get a good view of the doorway area.

2 Add loops to outline the lintel.

NOTE The lintel beam is not perfectly rectangular. You will adjust its outline
in a later procedure.
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3 Add a vertical loop for the edge of the right-hand doorway. (The other
vertical door edges match edges you already created for the windows.)

4 Also add vertical loops to the left of each dark area, where the wall angles
into the doorway.

Loop for the angle of the left doorway’s left-hand doorjamb
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Loop for the angle of the right doorway’s left-hand doorjamb

5 Finally, add a horizontal loop to define the elevation of the doorstep.

6 Right-click to turn off the SwiftLoop tool.
Now you have most of the edges you need to add 3D detail to the façade.
Add depth to the top center window:

1 Turn off

Edge to return to the top, object level.
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2 Drag the left edge of the ViewCube to get a view of the façade that shows
some depth.

3 In the viewport,
click to select the Ground object in the
background, then right-click and from the quad menu, choose Hide
Selection.

4

Zoom and
pan to get a good view of the windows in the
upper portion of the wall.
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5

Select Facade1 again.

6 Go to the Editable Poly level.
TIP On the Graphic Modeling Tools ribbon, you can navigate the stack by

using the buttons
(Next Modifier) and
(Previous Modifier).
These move to the geometry level as well as to modifiers.

7 On the ribbon, click
level.

8

Polygon to go to the Polygon sub-object

Click and Ctrl+click to select the three faces of the top center
window.
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9 On the ribbon ➤ Polygons panel, click the drop-down arrow next to

the

Extrude button, and choose Extrude Settings.

3ds Max Design displays an interactive manipulator called a “caddy.”
10 Drag the arrows by the Height control, and extrude the window back by
about –0.05m.

TIP You can also simply type –0.05 in the Height field, and then press Enter.

11 Click
(OK: the check-mark icon at the bottom of the caddy) to
complete the extrusion.
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Add depth to the other two windows:

1

Click and Ctrl+click to select the two polygons of the small
window at the upper left.

2 On the ribbon, Shift+click

(Extrude).

Shift+click is a shortcut way to display the caddy for a modeling tool.
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3 The caddy defaults to the previous value you used for Extrude Polygons,

so just click

4

(OK) so the small window matches its larger neighbor.

Click and Ctrl+click to select the four polygons of the main
window in the center of the wall.
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5 On the ribbon, Shift+click

(Extrude).

6 This window should have more depth than the smaller windows, so in
the Height field, enter –0.1m, then press Enter.
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7 On the caddy, click

(OK).

Now the windows for Facade1 are done.
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This completes the modeling of the upper portion of the wall.

Next
Detailing the Doorways on page 374

Detailing the Doorways
Modeling the lintel is a bit more complicated than modeling the windows.
On the other hand, the doorways themselves are a simple extrusion as the
windows are.
Set up the lesson:
■

Continue working from the previous lesson.
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Correct the outline of the lintel beam:
1 Click the Front face of the ViewCube to return to a Front view.

2

Pan and
the lintel beam.

Zoom to get a good view of the faces that show

As you can see in the bitmap, the lintel has an irregular outline. You will
edit the faces so they correspond to the outline of the wooden beam.

3 On the ribbon, click

(Vertex) to go to the Vertex sub-object level.

4 At the left end of the lintel,
move the three lower vertices so
they follow the outline of the beam.
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TIP To do these edits and the ones that follow, it might help to

in more closely, then

zoom

pan as you work on other parts of the lintel.

5 Where the lintel passes over the central pillar between the two doorways,

click to turn on
(SwiftLoop), then add a new vertical loop where
the stones of the pillar form an angle into the beam.
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This new loop of edges is so you can add a vertex at the angle point
without creating a free-standing vertex. Free-standing vertices are never
a good idea.
6 Right-click to close the SwiftLoop tool.

7 On the ribbon ➤ Edit panel, click to turn on

(Cut).

8 Use the Cut tool to draw new edges that follow the top of the pillar and
the bottom of the beam.

TIP The cursor for the Cut tool has three different forms:

■

■

■

when the cursor is at a vertex

when the cursor is on an edge

when the cursor is on a face

To avoid creating free-standing vertices, do not click the mouse while the

cursor shows that it is

on a face.
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9 Right-click to close the Cut tool.

10 At the right end of the lintel, click to turn on
(SwiftLoop), then
add two new vertical loops where the stones rise into the beam.

11 Right-click to close the SwiftLoop tool.

12 Click to turn on

(Cut).

13 Cut new edges to follow the outline of the beam.

14 Right-click to close the Cut tool.
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15

Move the two upper vertices at the right end of the beam, to
better follow the beam contour.

16 Click to turn on

(Select Object) and turn off Move.

Now the faces over the lintel are a fair approximation of the shape of the
beam.
Add depth to the lintel:

1 If you zoomed in to perform the edits in the previous procedure,

zoom out and

2 On the ribbon, click
level.

pan so you can see the entire lintel.

(Polygon) to go to the Polygon sub-object
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3

Click and Ctrl+click to select all of the lintel faces.

4 Drag the left side of the ViewCube to get a view that shows some depth,
again.

5 Do the extrusion interactively this time: On the ribbon, click
(Extrude) to turn it on, then drag in the viewport so the lintel extends
above the doorways.

6 Right-click, and from the quad menu, choose Scale.
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7 Use the scale gizmo to scale the size of the front faces of the lintel down
a bit along the X and Z axes.

NOTE In the original building, the lintel doesn’t appear to extrude this far;
but for our model, we want to have geometry that casts a decent shadow.

Add depth to the doors:

1

Zoom,
pan, and
get a better view of the doorways.

orbit (or use the ViewCube) to

2

Click and Ctrl+click to select the doorway faces. Include the
portion with stone to the left of each door. (The left-hand doorway has
an extra sliver of face that the right-hand doorway does not have.)
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3 On the ribbon, Shift+click
(Extrude), then use the caddy’s Weight
field to extrude the doorways inward by a value of –0.6m.

382 | Chapter 3 Modeling Tutorials

4 Click

5

(OK) to accept the extrusion.

Orbit (or use the ViewCube) to see the doorways from the other
side.
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6 On the ribbon, click

7

(Edge) to turn on the Edge sub-object level.

Click and Ctrl+click to select the four vertical edges that are part
of the doorways, but whose faces show stonework.
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8

Move these edges to the right along the X-axis until the faces
show only the shadows beyond the door.
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Incidentally, the perspective captured by the camera helps with the texture
projection onto the left-hand doorjambs: These now look good. The
right-hand doorjambs don’t look as good. This is a problem that you will
fix in a later lesson.

9 Click

(Edge) to exit the Edge sub-object level.

Next
Completing the Façade: Detailing the Roof on page 386

Completing the Façade: Detailing the Roof
The last step in modeling Facade1 is to add the roof.
Set up the lesson:
■

Continue working from the previous lesson.
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Begin to model the roof:

1 Click

(Zoom Extents Selected) to see the entire façade.

2 On the ViewCube, click Front to return to a Front view.

3 On the ribbon, click
once more.

(Edge) to turn on the Edge sub-object level

4 On the ribbon ➤ Modify Selection panel, click
to turn it on.

(Loop Mode)

5 With
(Select Object) active, click one of the edges along the top
of the façade.
Loop Mode selects all edges along the top of the façade.

6 Drag the left edge of the ViewCube to see the façade in depth once more.
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7 Turn on

8

(Select And Move).

Shift+move the top of the façade forward a bit along the Y-axis.

Reminder: Holding down Shift while you move, clones the edges to create
new edges.

9

Shift+move the top of the façade upward a bit along the Z-axis,
until you can see the ends of the roofing tiles.
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Before you finish the roof, you will add depth to the entire façade.
Add depth to the entire façade:

1 Click

(Select Object) to turn it on and turn off Move.

2 On the ribbon, click
level.

3

(Border) to turn on the Border sub-object

Click an edge along the top of the façade.
3ds Max Design selects the entire border.
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4 Turn on

5

(Select And Move).

Shift+move the border back about 0.75m along the Y-axis.
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Now that the façade, including its roof area, has some depth to it, you can
complete the roof.
Finish the roof:
1 Click the Front portion of the ViewCube to return to a Front view.
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2 Drag the top edge of the ViewCube to tilt the view a little, so you can see
the rear edge of the roof.

3

Zoom to get a better view of the roof area.

4 On the ribbon, click

then
the roof.

5 Turn on

6

(Edge) to go to the Edge sub-object level,

drag a selection box to select all the edges at the rear of

(Select And Move).

Move the selected edges up along the Z-axis until you can see
the peak of the roof.
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If you
orbit the view, you can see that raising the rear edge also
gives a slope to the roof.

7 Return to a Front view.
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On the ribbon, click

(Vertex) to turn on Vertex sub-object mode.

8 One at a time,
move vertices at the rear roofline down vertically
to match the bitmap of the roof.
TIP At the extreme left and right of the roof, you might also want to move
the front roofline vertices slightly downward.

After moving all existing vertices, you can see there are two areas on
either side of the peak, where the sagging of the medieval roof still shows
some sky.

9 On the ribbon ➤ Edit panel, turn on
(SwiftLoop), then in the
viewport, add two vertical edge loops. Each loop should be near the
middle of the sky area, on either side of the peak of the roof.
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10 Right-click to close SwiftLoop.

11

Move the new vertices at the rear roofline down vertically to
hide the sky-blue (or cloudy) areas of the façade texture.

12 Turn off

(Vertex) to exit the Vertex sub-object level.

Save your work:
■

Save the scene as facade1_modeled.max.

Now you’ve completed the modeling of the façade: You have a convincingly
three-dimensional house front with a realistic texture.
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The only flaw, is that there is a good deal of streaking on those faces that are
perpendicular to the projection of fac1.jpg. The next lesson shows how to
correct the texture in these portions of the model.

Next
Correcting the Texture on page 396

Correcting the Texture
To correct the texture on selected faces, you add additional mapping
information for those faces. There are a number of ways to do this, but the
Unwrap UVW modifier is the most versatile and interactive way: This lesson
shows how to use Unwrap UVW.
Adding texture detail is a matter of how much time you want to spend, and
how you plan to use the model. If the model will appear only in a long shot,
you might be able to dispense with texture correction. If the model will appear
in a medium shot or a close-up, you might have to go through these steps.
For the purposes of this lesson, we use the final rendering as a guide:
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This is a medium shot. Facade1, on the left, is in shadow: But at another time
of day, you would be able to see the right sides of the doorways. So we will
show how to correct the sides of the doorway, and the doorstep.
The windows are too far away to see detail; the roof is seen only from below;
and the sides of the house are obscured by other houses. So we won’t go
through the steps for correcting these details, but at the end of this lesson, we
show how the details might be corrected. (The completed model,
facade_modeling_completed.max, has many texture corrections that these lessons
don’t describe.)
Set up the lesson:

1 Continue working on your scene from the previous lesson, or
open \modeling\facades\facade_modeling_03.max.
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2 If you open the file,

panel, and make sure that
levels of the stack.

select the façade, go to the

Modify

(Show End Result) is on for all three

Add an Unwrap UVW modifier:

1

Select Facade1.

2 Go to the
Modify panel. In the modifier stack, click the UVW
Mapping entry to make this modifier active.
3 From the Modifier List, choose Unwrap UVW.

4 In the modifier stack, click
(the plus-sign icon) by the Unwrap
UVW entry to expand the Unwrap UVW sub-levels, then click the Face
sub-object level to make it active.
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Correct the texture on the left-hand doorjamb:

1

Orbit (or use the ViewCube),
zoom, and
pan the
viewport so you have a good view of the right side of the doorways.
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The sides appear streaked, because they are at right angles to the texture
projection of the UVW Map modifier.

2

Click and Ctrl+click to select both doorjamb faces.

NOTE You can adjust some settings for both doorjambs at once, because
they are parallel to each other.

3 On the
Modify panel ➤ Map Parameters rollout, click to turn
on Planar, then click Align X.
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Now the doorjambs are correctly aligned with the fac1.jpg texture.
However, they show the entire façade, which is not quite what we want.

4 Click Planar again to turn it off.
IMPORTANT If you forget to turn off Planar, later you won’t be able to use
controls in the Edit UVWs dialog.
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5

Click to select only the left-hand doorjamb.

6 On the

Modify panel ➤ Parameters rollout, click Edit.

3ds Max Design opens the Edit UVWs dialog.
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7 On the Edit UVWs dialog toolbar, choose “Map #11 (fac1.jpg)” from the
background pattern drop-down list.
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Now the main window of the dialog displays fac1.jpg.

8 On the lower toolbar, click to turn on

(Filter Selected Faces).

Now the geometry shown in the Edit UVWs dialog (the red mesh)
represents only the left-hand doorjamb face.

9 On the Edit UVWs dialog toolbar, click to turn on
Mode).

(Freeform

The face mesh now shows handles at its edges and corners. With Freeform
Mode, you can scale the face by dragging a corner handle, rotate the face
by dragging a side handle, and move the face by dragging from the interior
of the face.
10 Drag a corner to scale the face so it is roughly the size of a doorjamb in
the bitmap.
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TIP Move the Edit UVWs dialog so you can also see the left doorjamb in the
viewport. That way, you can see your texture-mapping changes interactively,
as you make changes in the dialog.
11 In the Edit UVWs dialog, drag the face to the right, so it covers the right
side of the central pillar.

12 On the Edit UVWs dialog toolbar, click

(Mirror Horizontal).

In the viewport, you can see how the correction looks.
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This is the pattern for using Unwrap UVW to correct textures on faces with
poor texture projection: Essentially, you “fake” the texture by choosing some
part of the original texture that looks well when applied to the surface that
needs correcting.
Correct the texture for the right-hand doorjamb:

1 With the Edit UVWs dialog still open,
right-hand doorjamb.
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click to select the

2 On the Edit UVWs dialog ➤ lower toolbar, click to turn Filter Selected

Faces

off and then

on.

IMPORTANT Toggling Filter Selected Faces ensures that the Edit UVWs dialog
display is updated correctly.

3 On the Edit UVWs dialog toolbar, turn on
(Freeform Mode), then
drag the upper-right corner of the doorjamb face to scale it so it is roughly
the size of a doorjamb in the bitmap.
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4 Drag the face a bit to the right, so you can see the edge of the shrub.

5 On the Edit UVWs dialog toolbar, click

(Mirror Horizontal).

Once again, you can see the correction in the viewport.
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6

Close the Edit UVWs dialog.

7 Deselecting the faces makes it easier to see the corrections you made.
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Correct the texture on the doorsteps:
The doorsteps are a little tricky, because the photo has no information about
that portion of the building. To compensate, we use the lintel texture:
Although the lintel is wood, when scaled up in size it can pass for stone.

1

Click and Ctrl+click to select the doorstep faces (there are four
faces on the left, and three on the right).
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2 On the
Modify panel ➤ Map Parameters rollout, click to turn
on Planar, then click Align Z.

Now the doorsteps are correctly aligned with the fac1.jpg texture.
3 Click Planar again to turn it off.

4 On the
Modify panel ➤ Parameters rollout, click Edit to open
the Edit UVWs dialog.
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5 In the Edit UVWs dialog, scale and move the doorstep faces so they are
on top of the lintel beam in the bitmap.

6

Close the Edit UVWs dialog.

A close-up rendering of the doorways shows your texture corrections better
than the viewport can.
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Save your work:
■

Save the scene as facade1_textured.max.

Extra Credit: Mapping the Windowsills, Window Jambs, and Sides of the
House
As we mentioned at the beginning of this lesson, it isn’t necessary to correct
the texture for the windows or the sides of the house. But if you want to try
using Unwrap UVW to do so, or if you are simply curious how it was done
for the completed model, here are the mappings used.
NOTE The completed model has some additional mapping corrections not shown
here: the bottom of the lintel and the bottom of the eaves. You can investigate
these, if you wish, by looking at facade_modeling_04.max or
facade_modeling_completed.max.
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Windows

Mapping for the windowsills
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Mapping for the window jambs
(The same texture is used for both sides of the windows.)
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House Sides

Left side
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Right side

Next
Modeling the Second House on page 417

Modeling the Second House
The second house front has a peaked roofline and an arched entry. We will
concentrate on modeling these, as you already know how to model windows.
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Set up the lesson:

■

Continue working on your scene from the previous lesson, or
\modeling\facades\facade_modeling_04.max.

open

View the bitmap for the second house, and note its dimensions:
1 On the main menu, choose Rendering ➤ View Image File. In the View
File dialog, navigate to the \sceneassets\images folder, and highlight
fac4.jpg.
In the lower-left corner of the View File dialog, a status line shows the
dimensions of the image, which are 1200 x 1740 pixels.

2 Click Open to view the image at full size.
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3

Close the image window after you have looked at the photo.
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Create the plane for the house:

1 Click
layout.

(Maximize Viewport Toggle) to display a four-viewport

2 Change the upper-right viewport to a Front viewport, and activate it.

3

4

Select Facade1, and then click

(Zoom Extents Selected).

Pan the viewport so Facade1 is at the left.

5 On the
Create panel, click
Type rollout, click Plane.

(Geometry), then on the Object

6 In the Front viewport, drag to create a plane. Change the Length (height)
value to 10.0m and the Width value to 6.8m. Change Length Segs = Width
Segs = 1.

NOTE The aspect ratio of the new house is 1200:1740, which equals 0.69,
so the dimensions of 10m x 6.8m are close to the real-world dimensions.
(Most of the houses in Monpazier are 6.8m wide.)

7

Move the new plane so it is level with Facade1, then move it to
the right so it is to the right of the previous house, with bit of distance
between them.
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8 Name the new plane Facade4.

9 Go to the

Hierarchy panel. On the Adjust Pivot rollout, turn on

Affect Pivot Only, then
base of the Facade4 plane.

move the pivot vertically so it is at the

10 Right-click the Facade4 plane, and from the Transform (lower-right)
quadrant of the quad menu, choose Convert To ➤ Convert To Editable
Poly.
Texture the plane:

1

Open the Slate Material Editor.
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2 In the Material/Map Browser panel, locate Materials ➤ mental ray, and
drag the Arch & Design entry to the active View.
3 Double-click the Arch & Design material node to display its parameters.
4 Name the material Facade 4.
5 On the Templates rollout, choose Matte Finish from the drop-down list
of templates.
6 On the Material/Map Browser panel, locate Maps ➤ Standard, and drag
the Bitmap entry to the active View.
7 In the file dialog that opens, choose fac4.jpg as the bitmap, turn off
Sequence, and then click Open.
IMPORTANT In the Select Bitmap Image File dialog, be sure to turn off the
Sequence toggle.

When Sequence is on, 3ds Max Design attempts to create an IFL animation,
and we want to open only the single image.

8 Wire the Bitmap to the Arch & Design material’s Diffuse Color Map and
Bump Map components.
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9 Click the Facade 4 material node to make it active, then turn on
(Show Map In Viewport).
10 Drag from the Arch & Design material node’s output socket (the small
circle on the right), and drop the material on the Facade 4 plane in a
viewport.
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Dragging and dropping is another way to apply a material.
NOTE You won’t see the wire as it crosses the panel at the right of the Slate
Material Editor, or in the viewport.
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Shaded plane in Front viewport

11

Close the Slate Material Editor.

Set up the stack and face-selection color:

1 Go to the

Modify panel.
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2 From the Modifier List, add a UVW Map modifier. Click the Editable Poly
entry again, then add a Poly Select modifier.

3 Make sure that
(Show End Result) is on for all three levels of the
stack (the two modifiers and the Editable Poly object itself).
4 Click the Editable Poly level again to make it active. Scroll down to the
Subdivision Surface rollout, and open it if it isn’t already open.
5 On the Subdivision Surface rollout, make sure Show Cage is on.
6 Click the second of the color swatches that follow Show Cage.

This color is the color of highlighted polygons.
7 On the Color Selector, choose a bright red as the highlight color, and
then click OK.
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Adjust the roofline:

1 On the ribbon, click

On the Edit panel, click

(Edge) to go to the Edge sub-object level.

(SwiftLoop) to turn it on.

2 Make sure the viewport displays Edged Faces (F4).
3 Create a vertical edge that is centered on the peak of the roof.
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4 On the ribbon, click

(Vertex) to go to the Vertex sub-object level.

Move the upper-left and upper-right vertices down to match
the roofline.

5 On the ribbon, click

(Edge) to go to the Edge sub-object level.

Click and Ctrl+click to select the two roof edges, then
move them down vertically a bit to hide the cornice.

As you did for Facade1, you will add detail for the roof later in this tutorial.
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Add edges for the windows:
Although we won’t go into detail about creating the windows, you will add
their construction edges, as these can help you construct the arch.

1 On the ribbon ➤ Edit panel, click

(SwiftLoop) to turn it on again.

2 Add vertical edges for the two windows.

3 Also add vertical cuts for the center dividers of the two windows.
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As you work with SwiftLoop, you will notice that the “horizontal” loops
are now chevron-shaped, because of the peaked roof. To get true
horizontal edges, you need to use a different tool at first.

4 On the ribbon ➤ Edit panel, turn on

(QuickSlice).

5 Position the cursor at the horizontal top of the upper window, then click
the mouse once.
3ds Max Design creates a single horizontal slice.
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6 Click the mouse a second time to “set” the quick slice. (If you drag the
mouse, 3ds Max Design rotates the slice, which we don’t need here.)

7 Use
window.

(QuickSlice) again to create the lower edge of the upper

8 Once you’ve used QuickSlice to finish creating horizontal edges for the

upper window, you can use
(SwiftLoop) again to create the
horizontal edges for the lower window.
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NOTE Although we don’t go through the steps in this tutorial, we use three
horizontal loops for the lower windowsill, because in the final model it has
two levels of extrusion. You can see this in facade_modeling_completed.max.

Now you have some of the grid on which you will base the actual arch contour.

Next
Add Detail to the Arch on page 432

Add Detail to the Arch
The arch is the distinctive feature of Facade4. It calls for more complex
modeling than the doorways of the previous façade.
Set up the lesson:
■

Continue working from the previous lesson.

432 | Chapter 3 Modeling Tutorials

Add edges for the arch:
The window edges give you a starting point, but to model the arch well, you
need to add some further edges for reference and for making cuts.

1

Pan and

zoom so you have a good view of the arch.

2 On the ribbon ➤ Edit panel, turn on

(SwiftLoop) again.

3 Add a horizontal loop at the top of the arch.

4 Add a vertical loop at each side of the arch.
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5 Subdivide the arch area with four horizontal loops. Make them a little
closer together at the top, and more widely spaced toward the bottom.

6 Add one more horizontal loop for the doorstep or sidewalk.

7 Subdivide the arch area further with vertical loops: Add two on the left,
and three on the right.
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Outline the arch:

1 On the ribbon ➤ Edit panel, turn on

(Cut).

2 Cut edges to define the archway.
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Reminder: Don’t click the mouse when the cursor shows it’s
a face. The cuts should always join edges or vertices.

on

3 Right-click to close the Cut tool.

4 If you want to adjust the cuts, turn on
(Vertex), then
move the new vertices in X or Y (try not to deform the horizontal and
vertical lines of the grid).
When the cuts for the archway are done, you’re ready to extrude the arch.
Extrude the arch:

1 On the ribbon, click
level.
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(Polygon) to go to the Polygon sub-object

2

Click and Ctrl+click to select the faces in the archway. Don’t
neglect the small triangular faces that you might have created along the
upper edge of the arch.

3 Drag the left edge of the ViewCube so the view shows some depth.

4 On the ribbon ➤ Polygons panel, Shift+click
the extrusion caddy.

(Extrude) to display
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You will extrude the arch in two stages: The first stage gives depth to the
wall, and the second represents part of the interior of the arcade behind
the arch.
5 In the caddy’s Height field, enter –0.3m for the first extrusion (the width
of the wall).
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6 Instead of clicking OK, click

(Apply And Continue).
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3ds Max Design creates the extrusion and begins another.
7 In the Height field, enter –0.4 for the second extrusion (the arcade
interior).
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8 Click

(OK) to accept the value and close the caddy.

Next
Add Detail to the Cornice on page 441

Add Detail to the Cornice
The cornice, with its peak, is slightly different from the roof for Facade1.
Set up the lesson:
■

Continue working from the previous lesson.
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Model the cornice:

1

Pan so you can see the roofline.

2 On the ribbon, click

3

(Edge) to turn on the Edge sub-object level.

Select the edges along the top of the façade.

TIP It can be hard to select the very small edges near the peak: Make sure

the Window/Crossing toggle is set to
(Window), and drag a box
around them. Ctrl+click to add the longer edges to the selection.

4

Shift+move the edges forward a bit along the Y-axis.
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5

Shift+move the edges up a bit along the Z-axis.
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6

Shift+move the edges forward along the Y-axis, and then
Shift+move them up along the Z-axis once again, to complete the cornice.

7 Click

(Edge) to exit the Edge sub-object level.

At this point, if you wish, you can add depth to the windows and to the façade
as a whole, as we did for Facade1. But that work has been done for you in the
sample file for the next lesson. This completes the modeling work on Facade4.
What remains is to correct the texture mapping with Unwrap UVW. Because
the arch is curved, you will use a new method to map its inner faces.
Save your work:
■

Save the scene as facade4_modeled.max.

Next
Texturing the Arch on page 445
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Texturing the Arch
As for Facade1, you use Unwrap UVW to texture the entryway faces of Facade4.
Because of the arrangement of these faces, you use different Unwrap UVW
techniques.
Set up the lesson:

1 Continue working on your scene from the previous lesson, or
open \modeling\facades\facade_modeling_05.max.

2 If you open the file,

panel, and make sure that
levels of the stack.

select the façade, go to the

Modify

(Show End Result) is on for all three

Texture the pavement:

1

Select Facade4.

2 Make sure the viewport displays Edged Faces (F4).

3

Orbit (or use the ViewCube),
get a good view of the arch geometry.

zoom, and

pan to
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4 Go to the
Modify panel. In the modifier stack, make sure UVW
Mapping is the active level.
5 From the Modifier List, choose Unwrap UVW.

6 In the modifier stack, click
(the plus-sign icon) by the Unwrap
UVW entry to expand the Unwrap UVW sub-levels, then click the Face
sub-object level to make it active.
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7

Click and Ctrl+click to select the upper faces of the doorstep or
sidewalk.

8 On the
Modify panel ➤ Map Parameters rollout, click to turn
on Planar, then click Align Z.
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Now the pavement is correctly aligned with the fac4.jpg texture.

9 Click Planar again to turn it off.

10 On the
Modify panel ➤ Parameters rollout, click Edit to open
the Edit UVWs dialog.
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11 On the Edit UVWs dialog, choose “Map #13 (fac4.jpg)” from the
background pattern drop-down list.

12 On the Edit UVWs dialog lower toolbar, click to turn on
Selected Faces).

13 On the Edit UVWs dialog main toolbar, click to turn on
Mode).

(Filter

(Freeform

14 Use the handles to move and scale the pavement faces so they are on top
of the larger window’s windowsill.

The idea is to map the pavement to a dark area of stone.
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TIP Move the Edit UVWs dialog so you can also see the texture display in the
viewport.

15

Close the Edit UVWs dialog.

Set up texturing for the wall portion of the arch:
1 Use the ViewCube to orbit the scene so you can see all the interior faces
of the archway.

450 | Chapter 3 Modeling Tutorials

2

Click and Ctrl+click to select the outer faces along the inside of
the archway: These are the faces that correspond to the width of the stone
wall.

TIP You can press F2 to toggle the shading of selected faces. Turning on face
shading makes it easier to see your selection.
3 Press Shift+Z to return to your previous view of the archway, looking at
it from the side and slightly downward.

4 On the
Modify panel ➤ Map Parameters rollout, click Cylindrical
to turn it on, then click Align Y.
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3ds Max Design displays a cylindrical gizmo for the Unwrap UVW
projection.
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5

Move the cylinder gizmo forward a bit, so you can see all of it,
and it is not hidden by the wall.

TIP As the illustration shows, you might want to
orbit (or use the
ViewCube) to see the wall and the cylinder gizmo more obliquely.
The cylinder gizmo has one height segment displayed in green. This
indicates where the seam of the cylindrical mapping will be. At present,
the green segment is near the right side of the arch.

6 Turn on

(Select And Rotate).
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7

Rotate the cylinder gizmo about the Y-axis until the seam
segment is at the bottom of the scene.

Since the arch isn’t a full circle, putting the seam at the bottom ensures
there won’t be a seam on the façade geometry.
8 On the Map Parameters rollout, click Fit.
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3ds Max Design fits the cylinder gizmo to the geometry of the arch.

9 Click Cylindrical again to turn it off.
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IMPORTANT Like the Planar button, the Cylindrical button enters a mode:
If you forget to turn it off, later you won’t be able to use controls in the Edit
UVWs dialog.

Use the Edit UVWs dialog to position the wall texture:

1 On the
Modify panel ➤ Parameters rollout, click Edit to display
the Edit UVWs dialog.

2 If you need to, on the Edit UVWs dialog, choose “Map #13 (fac4.jpg)”
from the background pattern drop-down list, and on the lower toolbar,

turn on

(Filter Selected Faces).

3 On the Edit UVWs dialog main toolbar, turn on

(Freeform Mode).

4 Use the handles to scale the wall faces so they cover a strip of stone above
the arch. The placement doesn’t matter much, as you will be changing
it soon.
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5 On the Edit UVWs dialog main toolbar, click

(Mirror Horizontal).

6 On the options panel below the main Edit UVWs dialog, click to turn on

(Vertex Sub-Object Mode).

7 On the Edit UVWs dialog menu bar, choose Tools ➤ Sketch Vertices.
3ds Max Design opens a Sketch Tool dialog.
8 On the Sketch Tool dialog, choose Free Form from the Align To drop-down
list.
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Also in the Sketch Tool dialog, click to turn on Interactive Mode, and
then click OK.

After you have set up the Sketch Tool to use Free Form drawing, you work
in a two-step manner: First, drag to select the vertices you want to
reposition; Second, draw a freehand stroke to show Edit UVWs where to
place the selected vertices.
9 In one continuous motion, drag to select vertices along the lower-left edge
of the arch faces: Begin at the center of the lower edge, and move the
cursor to the left.
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NOTE If your grid of edges matches the grid shown in the previous lesson,
there are 11 vertices on each side of the arch. 3ds Max Design numbers these
from 0 to 10.
10 With the pencil cursor, sketch along the lower-left edge of the arch that
the bitmap shows.
3ds Max Design moves the vertices you selected to follow the line as you
draw.

You don’t have to worry about being too precise: You can adjust your
work later.
11 Repeat the previous two steps for the upper edge of the arch faces.
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12 And then repeat the same steps for the right side of the arch.
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13 After you have used Sketch Vertices to rough out the arch faces in this

way, on the Edit UVWs dialog toolbar, turn on
move vertices to arrange them more regularly.
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(Move), and then

Map the inner, arcade faces:
We’ll let you decide whether you want to go through the steps for mapping
the inner, arcade faces. The steps to follow are the just same as the steps you
followed for the stone wall faces, with these changes:
■

Select the inner faces instead of the outer ones.

■

Map the faces to the dark, arcade area of the bitmap. Avoid lighter areas
of the bitmap (except the reflected lights, which will look OK); and of
course, avoid the bicyclist.

A close-up rendering of the façade shows the result of mapping the arch.
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Save your work:
■

Save the scene as facade4_textured.max.

The completed scene is facade_modeling_completed.max. This scene contains
two other façades. If you want to try modeling them, you should now know
the tools you can use to do so.
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Façade 2
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Façade3

Summary
With a photograph of a building’s façade, you can create a convincing model
of that façade. The overall steps are as follows:
1 Use a photo-editing program to correct the photograph’s perspective, so
that vertical and horizontal lines are parallel.
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2 In 3ds Max Design, create a plane that has the same aspect ratio as the
photograph, and the same dimensions as the original building.
3 Create a material that uses the photo as both a Diffuse and a Bump map,
and apply it to the plane.
4 Make the plane an Editable Poly object.
5 Set up the stack with UVW Map and Poly Select, so you can see the end
result while you edit the geometry.
6 Use Editable Poly tools to create edges that correspond to features of the
façade.
7 Use the Extrude tool to make features three dimensional, having them
recess or protude so the building will cast realistic shadows.
8 Use Unwrap UVW to correct the mapping of faces that aren’t parallel to
the main UVW Map projection.

Learning to Use Containers
This tutorial introduces methods for working with the Container feature. The
container provides various project-management functions, including
organizing scene components and sharing tasks among team members, along
with locking files and restricting access to specific scene components.
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Use containers to organize scene contents and build scenes.

In this tutorial, you will learn how to:
■

Use containers to organize and share scene contents.

■

Inherit a container.

■

Restrict access to specific object parameters from other users.

■

Use the locking feature so that only one person can edit a container’s
contents at a time.

■

Build a complex scene using nested containers.

Skill level: Beginner
Time to complete: 2 to 3 hours

Getting Started
Set up the scene:

■

On the Quick Access toolbar, click
(Open File), navigate to the
\scenes\modeling\container folder, and open container_start.max.
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NOTE If a dialog asks whether you want to use the scene’s Gamma And LUT
settings, accept the scene Gamma settings, and click OK. If a dialog asks
whether to use the scene’s units, accept the scene units, and click OK.
The scene contains a table, a chair, and two place settings: one for eating
a meal and another for attending a meeting at work.

Get acquainted with container tools:
1 Each scene component has a named selection set. From the Named
Selection Sets drop-down list on the main toolbar, choose the dinner setting
item.
This selects all the objects in the dinnerware set.
2 Right-click in the active viewport, choose Hide Unselected, and then click

(Zoom Extents All).
The dinnerware set is maximized in all viewports.
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3ds Max Design provides various ways of accessing container-related
commands, but one of the handiest is the Containers toolbar.
3 Right-click an empty area on the main toolbar and, from the context
menu that opens, choose Containers. Then right-click the Containers
toolbar title bar, and choose Dock ➤ Right.
The toolbar docks on the right side of the interface, next to the command
panel.

4 On the toolbar, click

(Create Container From Selection).

This command adds a new container to the scene and then places the
selected objects in the container. The container appears in the viewports
as a wireframe box with the lid flaps open. The box’s position is calculated
from the average of the selected objects’ locations.
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Alternatively, you could create a new container and then add objects to
it, but if you already know which objects you want in the container,
using Create Container From Selection is the easiest method.
NOTE The container is a helper object, and as such does not render.
Because the container starts out in an open state, you can manipulate it
and its contents freely.

5

Move the container and note that its contents move along with
it. Then move some of the contained items and note that their movement
doesn’t affect other objects.
In effect, the objects in the container are children of the container. But
there’s much more to the Container feature than a simple hierarchical
relationship.

6 Undo any movements from the previous step, and then select the
container.

7 Go to the
Modify panel and on the Manage Container rollout,
click the Close button.
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A file dialog titled Container Definition File opens, with the default file
name container_start_Container001, based on the scene-file name and the
container name. The file name extension .maxc is added when you save
the file.
NOTE .maxc stands for “Max container,” and is actually a standard 3ds Max
Design scene file with a special file name extension. If you ever have problems
opening a container file, you can load it as a regular scene by changing the
extension to .max.
8 Navigate to the \scenes\modeling\container folder and click Save to store
a copy on disk using the default name.
After you close the container, its appearance in the viewport changes to
indicate that it’s now closed.

9 Move the container and then try to select an object within it.
Moving the container works as before, but you can no longer select the
contents. This behavior mimics the real world; if you put stuff in a box
or other container and then close it, the contents are no longer directly
accessible.
10 On the Manage Container rollout, click Open.
The box returns to its previous status, with one difference: On the Local
Content rollout, the Saved Local Definition field contains the name of
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the saved container. When a container has a local definition, that
effectively means you’re the container’s owner, although it doesn’t
necessarily mean you have full control of its contents; this will become
clearer later in the tutorial.

TIP The entire path and file name probably don’t fit in the Saved Local
Definition field, but you can see them, along with a tooltip, by positioning
the mouse cursor over the field. In fact, most controls on the container rollouts
offer helpful tooltips.

Share the container with yourself:
Henceforth this tutorial will refer to Session 1 and Session 2 of 3ds Max Design.
The best way to learn how the Container feature works without getting mixed
up is by working in two different sessions of the program. In effect, you’re
simulating two users: one who originates a container in Session 1, and another
who inherits it in Session 2. When you inherit a container, you can still use
it, but only within the limits set by the originator.
One way to work in two different sessions of 3ds Max Design is by saving your
work, resetting the program, and then reloading your work from the other
session. As you can imagine, however, going back and forth this way is slow
and cumbersome. Much better is to run 3ds Max Design twice, thus having
two different sessions running concurrently on the same machine. We
recommend this method if your machine has at least 2GB of system memory
and 512MB or more of graphics memory. If you’re not sure whether you have
enough memory, the best way to tell is just to try it.
Or, if you have two networked machines, run 3ds Max Design on both and
switch back and forth. This latter method is closer to a typical studio setup

Getting Started | 473

with multiple users on the same team sharing data, but the single-machine
approach works fine as well.
1 Save Session 1 as my_container1.max.
2 In Session 2, add the Containers toolbar as before, if necessary, and then

click
(Inherit Container). Using the Inherit Container file dialog,
navigate to the folder in which you saved the container file
(container_start_Container001) in the previous section, and then open the
file.
The container and its contents appear in the viewports, in the same
location from which you saved them. The container is closed and selected.

Click

(Zoom Extents All).

3 Move the container and then try to open it.
You can move the container, but you cannot open it because the Open
button on the Manage Container rollout is unavailable. Also note that
the Edit In Place button is unavailable. To see one reason for this, return
to Session 1.
4 In Session 1, take a look at the Rules rollout.
The When Inherited, Allow option is set to No Access (Closed), which
means that the inheritor can work with the container, but not its contents.
This capability is useful for a team in which one member creates the
content and another simply arranges that content to set up a scene, such
as a game level.

Next
Using Rules on page 475
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Using Rules
Change the rules:
Besides No Access, the container provides three other rules that allow various
levels of access to other users. In this procedure you’ll look at Only Edit In
Place.
1 In Session 1, on the Rules rollout, choose Only Edit In Place and then
close the container.

This resaves the container with the rule change applied.
2 Return to Session 2.
On the Manage Container rollout, a
icon appears next to the Update
button. This indicates that an update is needed to keep in sync with the
source container; the one created by the originator.
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3 Click the Update button.
The container looks the same, but now the
icon appears next to
the Update button, indicating that the container definition is current.
Also, while the Open button is still unavailable, the Edit In Place button
is available.
4 Click Edit In Place.
The inherited container opens in Edit In Place mode. Edit In Place is a
mode that you enter and exit by clicking this toggle button.
5 In Session 1, try to open the container.
The Open button is available, but when you try to use it you get a message
that the container’s definition is currently being edited by you in another
instance of 3ds Max Design.
This demonstrates two important Container features:
■

When a container is set to Only Edit In Place, it can be edited by only
one person at a time. This is thanks to a locking mechanism in the
form of a file with the same name as the container, appended with
.lock, which 3ds Max Design creates when Edit In Place is active. If
you ever have trouble accessing a container, it might be due to the
presence of this file, possibly as a result of exiting or resetting 3ds Max
Design while Edit In Place is active. A warning is displayed when you
attempt to do so, but you can ignore it if you choose. If this happens,
simply delete the .lock file.

■

When someone else is editing a container, 3ds Max Design can
determine that person’s user name and tell you what that is.
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6 In Session 2, select the wine glass and move it upward a short distance.
Then select the container and click Edit In Place.
This exits Edit In Place mode, saving any changes to the container
contents and unlocking the container file.
7 In Session 1, open the container.
The wine glass changes position, reflecting the edit from Session 2.
NOTE At no time does the Update button become available in Session 1,
because the container is local to Session 1 and the Update function applies
to inherited containers only.
8 Still in Session 1, close the container without changing its contents.

9 In Session 2, the
icon is again visible next to the Update button,
even though the container definition hasn’t changed.
The Update function doesn’t look at the container definition; it simply
compares the date and time stamp on the file with the version you
inherited, and if it’s newer, advises you to update.
Lock an object’s transforms:
Say the originator is now happy with the wine glass’s position and doesn’t
want it change any more. The ability to lock specific parameters of a container
definition is an important Container feature.
1 In Session 1, open the container, then, on the Rules rollout, click the Edit
button.
Track View opens showing the container hierarchy.
2 Scroll down to the wineglass item and click the Transform entry to
highlight it.

TIP As long as
(Filter - Selected Objects Toggle) is on in Track View,
you can find the object faster in the list by selecting it.
3 Right-click the Transform entry, and from the quad menu ➤ top-left
quadrant, choose Lock.
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The Transform entry and all its children (branches and leaves) now show
“(Locked)” after their names in the Track View hierarchy.

4

Exit Track View and then close the container.

5 In Session 2, click Update and then click Edit In Place to open the
container.
6 Move the objects in the container, including the wine glass.
You can move everything except the wine glass.
7 Undo any changes from the previous step, and then select the container
and click Edit on the Rules rollout.
8 In Track View, find the wine glass item and then its Transform track.
Click the Transform track to highlight it.
9 Right-click the Transform track and choose Unlock.
The Transform track is no longer locked, but its child tracks still are. Lock
affects child tracks, but Unlock affects only highlighted tracks.
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10 Undo (Ctrl+Z) to restore the the Transform track to Locked status.
11 Right-click the Transform track and choose Unlock Leaves.
This unlocks the Transform track as well as all of its child tracks. Now
you can transform the wine glass if you want.
12 Undo the Unlock Leaves command and any other changes from the
previous step, then select the container and click Edit In Place to close
it.
Change the rules again:
As you’ve seen, you can lock specific tracks for objects in a container, but if
you use the Only Edit In Place rule, the inheritor can easily defeat your locks.
If you use a different rule, however, the inheritor must abide by your locks
unless you revise them.
1 In Session 1, open the container and on the Rules rollout, choose
Anything Unlocked.
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With Anything Unlocked enabled, you can use the four icon buttons at
the bottom of the Rules rollout to quickly lock all modifiers, materials,
transforms, and objects, and you can also use the Edit button to lock
specific tracks, as before. For the sake of convenience, in this exercise
you’ll just use the existing locked transform tracks for the wine glass.
2 Close the container, then go to Session 2 and click Update.
This time something different happens: The container opens, and Edit
In Place is unavailable.
3 Go to Session 1 and open the container.
No problem opening it this time. Edit In Place is the best rule for passing
a single container back and forth between team members while preventing
accidental overwriting; the remaining rules are better suited for one-way
transfer of containers, as you’ll see in the following steps.
4 Return to Session 2 and click the Close button.
Instead of simply closing the container, 3ds Max Design prompts you for
a file name.
5 Enter the name DinnerSetting and click Save.
This saves a local definition of the container, although it still has a
connection to the source definition, as indicated by the source file name
under Source Definition on the Inherited Content rollout.
NOTE When any user has this local container open, it is locked, just like an
Edit In Place container.
6 Open the container again.
Now you can see the name of the container file you saved under Saved
Local Definition on the Local Content rollout.
Depending on whether the inherited container is open or closed, the
Modify panel shows either the Local Content or Inherited Content rollout;
never both.
7 If Track View isn’t open, click Edit on the Rules rollout and find the
Transform section of the wineglass hierarchy.
Now the “(Locked)” text is in italics, indicating that you, as the inheritor
of this data, cannot unlock those tracks. Try to unlock them; you can’t,
even if you change the rule. You’re limited by the rules set in the container
you inherited.
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8 Return to Session 1 and try to move the wine glass; you can’t because its

Transform tracks are locked. On the Containers toolbar, click
(Override All Locks).
The toggle button stays highlighted to indicate that this condition is
active.
9 Move the wine glass and then close the container.
10 In Session 2, select the container and then update it.
The glass moves to reflect its new position from the source container.
11 Check the glass’s Transform tracks in Session 2; they’re still irrevocably
locked.
The overridden transforms are inherited in Session 2, but the overrides
themselves are not. Thus, using the Anything Unlocked rule, the
originator of the container can keep a firm grasp on which changes the
inheritor can make, but can override her own rules at will.
12 Create a sphere or any other object primitive in Session 2. On the

Containers toolbar, click
(Add Selected To Container). Use the
Select dialog that opens to highlight the container and then click the
Add button.
NOTE You can add objects only to open containers.
13 Close the container in Session 2 and then return to Session 1 and close
and reopen the container.
The new object from Session 2 doesn’t appear. Source containers set to
Anything Unlocked (or Only Add New Objects) move data in one direction
only: from the originator to the inheritor. If you like, add an object in
Session 1, close the container, and then update in Session 2; the object
is added to that container, even though it has a local definition. In a
sense, the container in Session 2 is a hybrid of of a source and local
container.
14 In both sessions, close the containers and then reset 3ds Max Design.
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Next
Assembling Containers on page 482

Assembling Containers
As mentioned, the Container feature is intended primarily for use by teams
working together on projects. In this last exercise, you’ll simulate a team of
three: one person creating content, another one using a subset of that content
to assemble a dinner-table scene, and a third using a different subset to put
together a conference-room scene at an office or convention. You’ll do so
using the remaining rule: Only Add New Objects.
Use the Only Add rule:
1 In Session 1, open container_start.max.
2 From the Named Selection Sets drop-down list on the main toolbar,

choose each named selection set in turn and use
(Create Container
From Selection) to add the objects to containers. After you create each
container, rename it to reflect its contents: dinner_setting, office_setting,
table, and chair.
You should end up with four containers, each set to the default No Access
rule.
3 Close the two table-settings containers and give them the file names
dinner_setting and office_setting (3ds Max Design automatically adds
the .maxc extension).
4 Select the container with the table, set its rule to Only Add New Objects,
close it and save it as table. Do the same with the chair container, saving
it as chair.
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5 In Session 2,
inherit the chair.maxc container file; it comes in
open. Also inherit the dinner_setting.maxc container file, which comes in
closed and can’t be opened or edited.
6 Try to select the chair object; you can’t.
That’s because the object is locked as a consequence of using the Only
Add New Objects rule. When an object is locked, you can’t select it, so
of course you can’t transform it directly. However, you can transform it
via its container.

7 Select the dinner_setting container, then click
(Add Selected To
Container). Use the Select dialog that opens to highlight the chair
container and then click the Add button.
You now have a nested container setup: The chair container contains the
chair object as well as the dinner_setting container and its contents.
8 Inherit the table.maxc container; like the chair container, it comes in open,
but with the contents locked.
9 Select the chair container and use Shift+Move to create three copies.
Cloning the chair container also clones its contents; the chair object and
the dinner_setting container and contents.
10 Position the copies around the table in any arrangement you like. As long
as you move them horizontally only, the chairs and place settings remain
at the correct heights for the table.
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You now have a basic setup for four people eating dinner at a table. You
could then add other objects such as wine bottles, flowers, and so on.

11 Select all four chair containers and then
container.

add them to the table

Now when you move the table container, all four place settings and chairs
move along with it.
12 Close the table container and give it the file name dinner_table.
Because you’re prompted to create a new local container definition when
closing an inherited container set to Only Add New Objects, this helps
prevent inadvertently overwriting the original container definition.
NOTE When any user has this local container open, it is locked, just like an
Edit In Place container.
13 Make a few copies of the table container and arrange them to create a
restaurant dining-room setup.
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14 Save the scene as my_dining_room.max.
Set up the conference table:
1 Reset 3ds Max Design, then inherit the chair, table, and office_setting
containers.
Because the office setting is offset from the chair, you need to position
them closer together.
2 Select the office_setting container, then move it horizontally and rotate it
a half-turn so it’s positioned correctly with respect to the chair.
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3 As before, add the office_setting container to the chair container.
4 Make three copies of the chair container, and then add all four chair
containers to the table container.
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5 Close the table container and give it the file name conference_table.
6 Make some copies of the table to populate a conference room. Position
and rotate each conference table to create a natural-looking arrangement.

Summary
In this tutorial you learned how to create containers from selected objects,
how to save and inherit containers, and how to restrict access to certain
parameters from other users. You also learned how to combine containers for
easy setup of complex scenes containing repetitive elements.
There’s much more to the Container feature than we’ve shown here; for
example, you can merge contained elements into your scene and use
low-resolution proxies to set up complex geometry quickly. To learn more,
consult the Container section of the 3ds Max Design Help.
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488

Animation Tutorials

4

The tutorials in this chapter show you the fundamentals of creating animation with 3ds Max
Design.

Different kinds of balls have different bounces.

Features Covered in This Chapter
■

Auto Key animation

■

Set Key animation

■

Ghosting and trajectories

■

Track View: The Curve Editor

■

The Walkthrough Assistant

489

Animating with Auto Key: Bouncing Balls
A bouncing ball is a common first project for new animators. This classic
example is an excellent tool for explaining basic animation methods in 3ds
Max Design.

Different kinds of balls have different bounces.

Skill level: Beginner
Time to complete: 1 1/2 hours

Bouncing a Ball
To create a bouncing ball, first you use Auto Key to block out the motion, and
then use the Curve Editor and other tools to make the motion more realistic.
(This is a very typical workflow for animators.)
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Open the starting scene and set the start frame to frame 0:

1 On the Quick Access toolbar, click
(Open File), navigate to the
\scenes\animation\auto_key folder, and open bouncing_ball_start.max.
NOTE If a dialog asks whether you want to use the scene’s Gamma And LUT
settings, accept the scene Gamma settings, and click OK. If a dialog asks
whether to use the scene’s units, accept the scene units, and click OK.
The scene contains a basketball and a plane that will act as the floor. It
isn't animated yet.
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2 Look at the start frame, at the left of the time bar and time slider.

If the first frame shows frame 1 instead of frame 0, click
(Time
Configuration), among the animation controls near the lower right of
the 3ds Max Design window, then in the Time Configuration dialog,
change the Start Time value to 0.
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Make sure the Length of the animation is 100 frames, then click OK.
For some purposes, frame 1 is a useful start frame (for example, a character
animator might want to reserve frame 0 for a “reference pose”), but the
exercises in this tutorial will start at frame 0.

Use Auto Key to Block Out the Bounce
Auto Key provides an easy way to block initial animation.
A simple diagram illustrates the path of a bouncing ball.

The shape of the curve that the ball follows, its trajectory, affects the realism
of the animation. So does the shape of the ball itself, which we’ll get to later
in this lesson.
The default frame rate for 3ds Max Design is the NTSC (National Television
System Committee) standard of 30 frames per second. If we want a single
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bounce of the ball to last one second, then it will fall for the first 15 frames,
and rebound for the next 15 frames.
Set up the scene:
■

Continue from the previous lesson.

Use Auto Key to animate the ball falling:

1 Click

(Auto Key) to turn it on.

The Auto Key button turns red to show that you are now animating.

The time slider background and the border of the active viewport also
turn red. Now when you move, rotate, or scale an object, 3ds Max Design
creates keyframes that control the object’s motion.

The time slider background and active viewport border turn red while you are
animating.

494 | Chapter 4 Animation Tutorials

2 Make sure that
basketball to select it.

(Select Object) is turned on, then click the

3 Drag the time slider to frame 15.

4 In the Perspective viewport, right-click the basketball. Choose Move from
the quad menu.
5 Move the basketball vertically so it touches the floor, and even drops a
little bit through the floor.

The ball touches the floor at frame 15.
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(You will correct the intesection with the floor in a later procedure.)
If you drag the time slider between frame 0 and frame 15, you will see
that 3ds Max Design has animated the fall of the basketball. Red boxes
appear on the timeline at both frame 0 and frame 15: these represent
keys that 3ds Max Design created when you moved the ball.

Keys appear on the timeline at frame 0 and frame 15.

Clone a key to complete the bounce:
You could drag the time slider to frame 30, and then move the ball upward
so it approximately returns to its original position, but 3ds Max Design lets
you position the ball more accurately than that.
1 On the timeline, click the key at frame 0 to select it.
The key turns white.

2 Hold down the Shift key, then drag the key from frame 0 to frame 30.

Shift+drag is a general method for cloning keys on the timeline. (Dragging
a key without holding down Shift simply moves the key.) Now at frame
30, the ball is in precisely the position it was in at frame 1.

3 Click

(Auto Key) to turn it off.

4 Drag the time slider to see the complete animated bounce.
In the animation you’ve just created, the ball moves down and then up, but
the motion isn’t very bouncy: It looks stiff and computer generated. In the
next section, you adjust key timing to make the bounce more realistic.
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Next
Use the Curve Editor to Improve the Motion on page 497

Use the Curve Editor to Improve the Motion
The Curve Editor is part of the Track View feature, which is a general-purpose
tool for managing and adjusting animation.
Set up the scene:
■

Continue from the previous lesson.

Open the Curve Editor:
■

Right-click the basketball, and choose Curve Editor from the quad menu.
3ds Max Design opens the Curve editor. The tracks you just created for
the ball should be visible on the left, and the curves themselves should
appear in the curve window to the right.

TIP If the tracks and curves don’t appear when the Curve Editor opens, pan
in the controller window at the left until you see the position tracks, then click
and Ctrl+click to highlight them.
The Z track, in blue, clearly shows the up-and-down movement of the ball.
The X and Y tracks are both flat, which indicates no change in these
dimensions. In fact, the ball should travel along the X-axis, as if it were
given some forward momentum when it was dropped.
NOTE The track curves are color-coded like the axes on transform gizmos: X
is red, Y is green, and Z is blue.
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Add movement along the X-axis:

1 Drag the time slider to frame 30. Turn on
(Auto Key) once
again, then in the Left viewport, move the ball to the right along its
X-axis.

The curves in the Curve Editor also update to show the change you made.
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That doesn’t look quite right: As you can see if you scrub the time slider,
the ball drops vertically, and then travels forward. Instead, the effect we
want is a smooth forward motion, as in the diagram at the beginning of
this lesson. The culprit is the Y Position key at frame 15, which pins the
ball to the same Y position it has at frame 1.

2 Turn off

(Auto Key).

3 In the Curve Editor, click the Y Position key, along the green curve, to
select it.

The key turns white when you select it. It also shows some tangent
handles.
4 Press Delete to delete the Y Position key at frame 15.

Now the basketball moves forward from frame 0 to frame 30, as you can
see if you scrub the time slider. The animation still looks too mechanical,
but you’ll improve that soon.
NOTE The X Position track is still flat, indicating no change along that axis.
You could delete all the keys in the X track without affecting the animation.
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Add a trajectory and ghosting to improve animation display in the viewports:
You can display the trajectory of an object in viewports, and also “ghost”
images of the moving object. Both these options help you visualize your
animation.
1 In a viewport, right-click the basketball, and choose Object Properties
from the quad menu.
3ds Max Design opens the Object Properties dialog.
2 In the Object Properties dialog ➤ Display Properties group, click
Trajectory to turn it on, and then click OK.
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Now viewports show a trajectory for the basketball, in red, with white
tick marks along its length. Each tick represents a frame.

Basketball trajectory in a viewport

The ticks are more closely spaced at the beginning and end of the
trajectory (this is easiest to see in the Left viewport). This is a timing effect
known as “ease in, ease out” (or “slow in and slow out”). However, the
ticks are evenly spaced around frame 15, where the ball bounces off the
floor. This is one reason the bounce doesn’t appear realistic, yet.
3 From the menu bar, choose Views ➤ Show Ghosting to turn it on.
Now when you drag the time slider, viewports show ghost images of
where the ball has traveled.
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The default ghosts are closely spaced, and a little hard to read. You can
improve this by changing the default settings.
4 From the menu bar, choose Customize ➤ Preferences. Go to the
Viewports tab.
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5 In the Ghosting group, change the value of Ghosting Frames to 4, and
change the value of Every Nth Frame to 2. Click OK.
Now when you scrub the time slider, you see fewer ghosts, spaced two
frames apart. This makes it a bit easier to see how the animation is
progressing.
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Adjust the timing of the bounce, in the Z dimension:
1 In the Curve Editor ➤ Controller window (the list of objects and tracks
at the left), click the Z Position track to display the curve for just that
track.

2 Click the “floor” key at frame 15 to select it (you also can select the key
by dragging a box around it).
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3 On the Track View - Curve Editor toolbar, click
To Fast).

(Set Tangents

4 Scrub the time slider.
NOTE As you might notice, the trajectory display in viewports doesn’t update
until you move the time slider.
Now the bounce has a snap to it that makes it look more like a real
bounce.
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Adjust the basketball’s forward motion:
As it did for the ball’s up-and-down motion, Auto Key applied ease in, ease
out to the ball’s forward motion. But this isn’t necessary, and in fact would
give strange results when you repeat the bounce, as you do in the next section.
1 In the Curve Editor ➤ Controller window, click the Y Position track to
display the curve for that track.

2 Drag to select both the starting and the ending key in this track.

Bouncing a Ball | 507

3 On the Track View - Curve Editor toolbar, click
To Linear).

(Set Tangents

3ds Max Design removes the ease curves from this track, making the
forward movement uniform.

Save your work:
■

Save the scene as my_bouncing_basketball_adjusted.max.

Next
Repeat the Bounce on page 508

Repeat the Bounce
Typically, a bouncing ball does not bounce once. The Curve Editor gives you
the means of repeating the initial bounce.
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Set up the scene:
■

Continue from the previous lesson.

Remove the X Position keys:
The X Position track has keys that don’t change, so you can safely delete them.
1 In the Curve Editor ➤ Controller window, click the X Position track to
display the curve for that track.

2 Drag to select all the keys in this curve.

Dragging to select the X Position keys
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All X Position Keys selected

3 Press Delete to delete the X Position keys.
Repeat the animation:
1 In the Curve Editor ➤ Controller window, click the Z Position track,
then hold down Ctrl and click the Y Position track so both curves are
visible.

2 On the Track View - Curve Editor toolbar, click
Out-Of-Range Types).

(Parameter Curve

3ds Max Design opens the Param Curve Out-Of-Range Types dialog.
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This dialog presents various options for how to continue a portion of
animation outside the range of the keys you’ve created. Each option is
represented by a graphic button. In the graphic, the original animation
is represented by a solid trace, and the effect of continuing the animation
is represented by dotted traces.
NOTE You don’t need to select keys before you open this dialog: Parameter
Curve Out-Of-Range Types operates on whatever keys are present in the
tracks you select.
You can click a graphic button to choose the same type for both incoming
and outgoing animation, or use the smaller buttons to choose incoming
and outgoing types individually.
At first glance, Loop seems the obvious choice, but while this option
successfully loops the bounce, it also loops the forward motion of the
basketball, which is not what we want. You can see this effect in both
the Curve Editor and the viewports.
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The Z Position track repeats successfully, but the sawtooth shape of the Y Position
track shows that the ball keeps returning to its starting position.

In viewports, the trajectory shows the same effect: Loop
creates a closed loop for the ball, instead of forward
motion.

3 In the Param Curve Out-Of-Range Types dialog, click the outgoing button
for the Releative Repeat option, then click OK.
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(You can leave the incoming animation set to Constant, because the
bounce begins at the start of the scene animation.)
Now the ball bounces as before, but at each continuation of the bounce,
the forward motion begins where it ended. You can see the difference in
the Curve Editor, if you zoom out in the curve window: The Z Position
track goes up and down, but the Y Position track continues in a straight
line.

4

Zoom out in the Perspective viewport so you can see the full
trajectory of the basketball.

Bouncing a Ball | 513

Save your work:
Save the scene as my_bouncing_basketball_continuous.max.

■

Next
Add Rotation on page 514

Add Rotation
The bounce is beginning to look good, but as it bounces forward, the basketball
remains perfectly level, and that is not realistic.
Set up the scene:

Continue from the previous section, or

■

open bouncing_ball_02.max.

Turn off ghosting:
The rotation of the textured ball is easier to see if you turn off ghosting.

1

Select the basketball, if it is not already selected.
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2 From the menu bar, choose Views ➤ Show Ghosting to turn off this
option.
If you were to use Auto Key to set rotation keys for the ball, without any
preparation, you would run into trouble. The reason is that 3ds Max Design
uses Euler XYZ as the default rotation controller. For continuous animation,
there are a couple of problems with this controller: It is not good at handling
rotation greater than 180 degrees, and it sets keys for all three tracks, even
when you animate only a single axis. These problems are exaggerated when
you set the Out-Of-Range type; for example:

Out-of-range curves with Euler XYZ rotation

In this example, 3ds Max Design has generated extraneous and unrealistic
sideways rotation for the ball.
When you want rotation greater than 180 degrees, or continuous rotation
about a single axis, the solution is to use a TCB rotation controller.
Change the controller type:
1 In the Curve Editor, click to select the main Rotation track (not one of
the subordinate X, Y, or Z Rotation tracks).
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The main Rotation track

2 Right-click the main Rotation track. From the quad menu, choose Assign
Controller.
3ds Max Design opens an Assign Controller dialog.
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3 In the Assign Rotation Controller dialog, click to choose TCB rotation,
then click OK.
Now the basketball has a single Rotation track, with no subordinate X,
Y, and Z Rotation tracks.
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4 On the Track View - Curve Editor toolbar, click
3ds Max Design opens the Track View ➤ Filters dialog.
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(Filters).

5 In the Filters dialog ➤ Show group (on the left), click to turn on
Controller Types, and then click OK.
Now the controller window lists controller types.

TIP Although by default, 3ds Max Design does not display controller types
in the controller window, turning on their display can help you keep track of
the animation you are creating.

Now you are ready to create rotation keys for the basketball.
Add rotation to the basketball:

1 Turn on

(Auto Key).

2 On the main toolbar, turn on

(Angle Snap).

3 Drag the time slider to frame 15. In the Perspective viewport,
rotate the basketball 90 degrees forward in the X-axis. Watch the X field
in the status bar to check the value.
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Forward rotation at frame 15

4 Drag the time slider to frame 30.
another 90 degrees along the X-axis.

5 Turn off

Rotate the basketball forward

(Auto Key).

Make the rotation continuous:
1 In the Curve Editor, click the Rotation : TCB Rotation track to highlight
it.
NOTE No curves appear in the curve window: The TCB family of controllers
uses dialogs to manage animation, rather than editable curves.
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2 On the Track View - Curve Editor toolbar, click
Out-Of-Range Types).

(Parameter Curve

3 In the Param Curve Out-Of-Range Types dialog, click the outgoing button
for the Releative Repeat option, then click OK.

(As before, you can leave the incoming animation set to Constant, because
the bounce begins at the start of the scene animation.)
4 Scrub the time slider to see the animation. The texture of the basketball
makes it easy to see the rolling motion.
Save your work:
■

Save the scene as my_bouncing_basketball_rolling.max.

Next
Add Squash and Stretch on page 521

Add Squash and Stretch
Squash and Stretch enhances the effect of animation.
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Objects deform as they move or collide. In the real world, this effect is
sometimes obvious (think of a soap bubble), and sometimes subtle. In
animation, it pays to exaggerate this effect: Although the exaggeration might
go beyond realism, it reinforces the illusion of realism when we watch the
animation. This effect is known as “squash and stretch.”
It is worth looking again at the diagram of a bouncing ball:

The ball should stretch as it falls, squash when it collides with the floor, and
then stretch again as it rebounds.
The Stretch modifier in 3ds Max Design provides a convenient way to animate
squash and stretch.
Set up the scene:

Continue from the previous lesson, or

■

open bouncing_ball_03.max.

Apply a Stretch modifier to the basketball:

1

Select the basketball, if it is not already selected.
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2 Go to the

Modify panel. From the Modifier List, choose Stretch.

TIP While the Modifier List is open, you can press the S key multiple times
to find modifiers whose name begins with “S.”
3 On the Parameters rollout for the Stretch modifier, change the value of
Amplification to –30.

Positive amplification tends to squeeze an object in the middle as it
stretches, while negative amplification makes the middle of the object
fatter, which is the effect we’re looking for.
We also want the basketball to stretch along the Z-axis: As it happens,
that is already the default.
Animate stretching and squashing:

1 Turn on

(Auto Key).

2 Drag the time slider to frame 6.
3 On the Parameters rollout for the Stretch modifier, change the Stretch
value to 0.1.
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The Stretch field’s spinner arrows now show red brackets, indicating that
3ds Max Design has created an animation key for this parameter. In the
viewports, you can see that the basketball is elongated along its direction
of travel.

524 | Chapter 4 Animation Tutorials

4 Drag the time slider to frame 15, where the basketball collides with the
floor.
5 On the Parameters rollout for the Stretch modifier, change the Stretch
value to –0.2.
This squashes the basketball at the point of impact. Incidentally, it also
corrects the way the basketball used to sink into the floor!

6 Drag the time slider to frame 30, and change the Stretch value back to
0.0.
TIP Just right-click the spinner arrows to set the value back to zero. In 3ds
Max Design, this is a standard shortcut for setting a numeric field to its
minimum nonnegative value.

7 Turn off

(Auto Key).

8 You need to “bracket” the squash so it doesn’t begin before impact, and
goes away when the ball rebounds.
Shift+copy the key at frame 6 key to the following frames:
■

Frame 14

■

Frame 16

■

Frame 24
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Repeat the stretch and squash:
1 In the Curve Editor ➤ controller window, locate the track for the Stretch
parameter.
The hierarchy looks like Basketball ➤ Modified Object ➤ Stretch ➤
Stretch : Bezier Float. You have to scroll down to get past several position,
rotation, and scale tracks that you arent using in this exercise.

2 On the Track View - Curve Editor toolbar, click
Out-Of-Range Types).

(Parameter Curve

3 In the Param Curve Out-Of-Range Types dialog, click the outgoing button
for the Cycle option, and then click OK.
Now the squash and stretch pattern repeats indefinitely.
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Play the animation:

■

Click
(Play) to play the animation.
Animation controls, including playback controls, are in the lower-right
corner of the 3ds Max Design window, just to the left of the viewport
navigation controls.

Click
(Stop) when you are done. (This is the same button as the
Play button, while playback is active.)
This completes the animation of bouncing a basketball.
Save your work:
■

Save the scene as my_bouncing_basketball_completed.max.

To see a completed version of the basketball animation, you can
open bouncing_ball_completed.max.

Next
Different Types of Balls: Mass, Elasticity, and Friction on page 527

Different Types of Balls: Mass, Elasticity, and Friction
Not all balls are equal. Mass and elasticity affect how high the ball will bounce,
and how far it will travel. So does the friction of the surface on which the ball
lands. This lesson compares the bouncing of a bocce ball, a tennis ball, and a
golf ball.
Even a hard rubber ball won’t bounce, if you drop it onto the dry part of a
sandy beach. In this lesson, we assume that the balls are bouncing on a hard,
uniform surface such as smooth concrete or a hardwood floor. An uneven
surface can cause unexpected motion: That is the subject of the lesson that
follows.
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The friction of air (air resistance or “drag”) can affect a ball’s motion as well.
Usually this is a subtle effect. On the other hand, even a lightweight, highly
elastic ball such as a golf ball eventually loses momentum and comes to a
stop. So unlike the indefinitely bouncing basketball in the previous lesson,
the balls in this lesson bounce for a limited time only, and with decreasing
energy.

Bouncing a Bocce Ball
We’ll start with a heavy ball that doesn’t have much bounce to it, at all. Bocce
balls weigh from 31 ounces to 42 ounces (900 to 1200 grams): on the average,
a bit over 2 pounds (about 1 kilogram).
Here is the graph of a bocce ball dropped onto a hard, smooth floor from a
height of just over 25 feet (7.6 meters):

As the graph shows, the ball bounces only twice, and does not have much
forward momentum, either.
NOTE This chart, as well as the charts for the tennis and golf balls, is based on
real-world values. It was created by videotaping the actual bounce of the ball, and
then rotoscoping the height and forward distances.
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Open the starting scene:

■

On the Quick Access toolbar, click
(Open File), navigate to the
\scenes\animation\auto_key folder, and open compare_bocce_start.max.
NOTE If a dialog asks whether you want to use the scene’s Gamma And LUT
settings, accept the scene Gamma settings, and click OK. If a dialog asks
whether to use the scene’s units, accept the scene units, and click OK.
The scene contains a bocce ball and a plane that will act as the floor. It
isn't animated yet.

Keyframe the bounces and adjust the keys:

1 Turn on
(Auto Key), and then in the Front viewport,
move the ball to create the following keyframes:
■

Frame 12: Down to floor level, and forward about 20 units.
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Don’t sink the ball through the floor as you did with the basketball:
Bocce balls are typically metal or wood, so squash and stretch is not
an issue in this exercise!

TIP After you key the first contact with the floor, you can click
(Zoom Extents Selected) to get a better view of the ball and its trajectory.
■

Frame 19: In the air again, to a height of about 60 units, and forward
about 20 units.

■

Frame 26: Back to floor level, and forward about another 20 units.

■

Frame 28: In the air again, to a height of about 10 units and forward
about 10 units.

■

Frame 30: Back to the floor, and forward about 10 units.

■

Frame 60: At floor level, forward about 100 units. At this point, the
ball is just rolling, so you all you need to do is move it to the right
along its X-axis.

2 Turn off

(Auto Key).

The bounce is now blocked out.
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As with the basketball, the keys where the ball strikes the floor are not
crisp enough, yet.
3 Right-click the bocce ball, and choose Curve Editor from the quad menu.
TIP If the tracks and curves don’t appear when the Curve Editor opens, pan
in the controller window at the left until you see the position tracks, then
click and Ctrl+click to highlight them.
4 In the Curve Editor, click the Z Position track to highlight it. Then click
and Ctrl+click the three keys where the ball strikes the floor.
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The three Z Position floor keys selected

5 On the Curve Editor toolbar, click

(Set Tangents To Fast).

The Z Position bounce keys corrected

6 Click to highlight the X Position track. In the curve window, drag a box

to select all the keys along the X Position curve, and then click
(Set Tangents To Linear).
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X Position rolling keys corrected

NOTE The ball is actually rolling as well as bouncing, but because (unlike
the basketball) it has a uniform texture, we don’t need to worry about rotating
it: In viewports, it would look just the same.

Trajectory of the bocce ball after adjusting the keys
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7

Play the animation.
The keys you created give a convincing animation of a heavy, solid ball.

Save your work:
■

Save the scene as my_bouncing_bocce_ball_completed.max.

Bouncing a Tennis Ball
As you might expect, a tennis ball bounces more often than a bocce ball, and
travels farther while it does so.

A tennis ball is hollow rubber, coated with felt. The standard weight of a tennis
ball is 22 ounces (624 grams).
In this section, we won’t make you enter keyframes by hand again. Instead,
we demonstrate a shortcut way to model the diminishing energy and magnitute
of bounces: This is a technique that you could apply to an out-of-range,
repetitious bounce such as you created for the basketball in the previous
lessons.
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Open the starting scene:

■

On the Quick Access toolbar, click
(Open File), navigate to the
\scenes\animation\auto_key folder, and open compare_tennis_start.max.
The scene contains a tennis ball and a plane that will act as the floor. The
ball is animated, but it keeps bouncing back to approximately the same
height: the scene doesn’t yet model a normal loss of energy. (As the ball
travels, its bounces do grow closer together: The spacing of the keyframes
is based on the real-world chart shown above, but the height of the bounces
isn’t adjusted, yet.)

Adjust the Z Position curve by using a multiplier curve:

1 In any viewport,
select the tennis ball, right-click it, and choose
Curve Editor from the quad menu.
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TIP If the tracks and curves don’t appear when the Curve Editor opens, pan
in the controller window at the left until you see them, then click to highlight
the position tracks.
2 In the Curve Editor ➤ controller window, click the Z Position track to
display this curve in the curve window.

3 From the Curve Editor menu bar, choose Curves ➤ Apply - Multiplier
Curve.
3ds Max Design adds a multiplier curve to the Z Position track. It also
changes the curve window display so all curves are visible.

4 Click
(the plus-sign icon that now appears next to the Z Position
entry in the controller window). Then click the Multiplier Curve track
to highlight it.

As you can see, the default value of the multiplier curve is completely
flat.
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5 Ctrl+click the Z Position track so you can see both the Z Position track
and its multiplier.

6 Click to highlight the key at the right of the multiplier curve.

This key is close to the final key for the tennis ball itself, but is slightly
above it, overlapping.
7 A transform curve is extremely sensitive to changes in the multiplier curve
you apply to it. Because of this, adjusting the multiplier by dragging in
the curve window is not the best method: You can get wild results.
Instead, type in the value.
The Key Stats toolbar is the status bar at the lower left of the Curve Editor.
The first field shows the current frame number, and the second field is
the key value. In this field, initially set to 1.000, enter –0.01.
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Now the multiplier curve “damps” the bounce of the tennis ball,
simulating the loss of energy as it travels and strikes the floor.

Are the new values realistic? Comparing the results obtained from the
multiplier curve with the chart for an actual tennis ball, it appears that
in real life, the tennis ball loses energy, and bounce height, even more
quickly than our simulation. If realism is a concern, consider keyframing
each bounce, as you did for the bocce ball. But if your main concern is
creating a general impression, then the multiplier curve is a useful
shortcut.
Save your work:
■

Save the scene as my_bouncing_tennis_ball_completed.max.

Comparing the Golf Ball
In this section, you simply compare the path of a bouncing golf ball to the
other two balls in this example.
A golf ball typically weighs 1.62 ounces (45 grams), and is made of rubber (or
a comparably elastic plastic) wound around a core, then encased in a plastic
shell. Its extreme elasticity means that it bounces a lot: So much so, that to
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animate it requires more than the default 100 frames of a 3ds Max Design
scene.

Open the scene with all three balls:

■

On the Quick Access toolbar, click
(Open File), navigate to the
\scenes\animation\auto_key folder, and open compare_completed.max.
The scene contains the bocce ball, the tennis ball, and the golf ball. They
are animated already. All are dropped from the same height at the same
time.
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Compare the balls and how they bounce:

■

Play the animation.
The balls bounce according to their mass and elasticity.
Incidentally, the golf ball hits the floor slightly before the tennis ball,
which precedes the bocce ball: So our real-world measurements account
for air resistance, as well as mass and elasticity.

Click

(Stop) when you are done observing the animation.

You can also play the movie compare.avi to see a rendered version of this
animation.

Next
Using a Helper to Control Changes in Direction on page 541
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Using a Helper to Control Changes in Direction
Bouncing a ball on an uneven surface can cause changes of direction. In this
lesson, you use a point helper to control those changes, making the animation
easy to edit.
Open the scene:

■

On the Quick Access toolbar, click
(Open File), navigate to the
\scenes\animation\auto_key folder, and open bouncing_chaos_start.max.
NOTE If a dialog asks whether you want to use the scene’s Gamma And LUT
settings, accept the scene Gamma settings, and click OK. If a dialog asks
whether to use the scene’s units, accept the scene units, and click OK.
The scene is the bouncing golf ball from the previous lesson. The plane
has a texture that suggests a tile floor with recessed grooves for the grout.
Uneven surfaces such as asphalt, tiles with grout, and so on, can make a
bounce take off in unexpected directions.
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You will retain the bounces, but remove the forward motion and replace
that with changes of direction in X and Y.
Remove the motion in X and Y:

1

Select the ball, right-click it, and choose Curve Editor from the
quad menu.
TIP If the tracks and curves don’t appear when the Curve Editor opens, pan
in the controller window at the left until you see them, then click to highlight
the position tracks.

2 Highlight the X Position track. Drag to select all keys in the curve window,
and then press Delete.
Now the ball bounces in place, with no forward motion.

3 Highlight the Y Position track, and delete all its keys as well.
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4

Close the Curve Editor.

Now you want to add more “chaotic” motion to the ball: When it strikes the
face of a tile, it should continue in the same direction, but when it strikes a
groove with grout, it should change its direction.
You could animate this lateral motion using the ball itself, but a better method
is to use a helper object: With this method, the helper animation is
independent of the ball and its bounce track, so if you later need to change
the lateral motion, you can do so without affecting the bounce.
Create a Point helper to control the ball:

1 On the
Create panel, turn on
Type rollout, click to turn on Point.

(Helpers), then in the Object

NOTE Many animators use the Dummy helper instead of Point. The advantage
of using a Point helper is that you can adjust its size without having to scale
it. Scaling a helper in a hierarchy will affect its children objects: This is an
effect that usually you want to avoid.

2 Click

(Maximize Viewport Toggle) to display all four viewports.
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3 If you are not at frame 0, click

(Go To Start).

4 In the Top viewport, click near the golf ball to create the Point helper.
5 On the Point helper’s Parameters rollout, click Box to turn it on, and
then change the size of the box to 40.

6 On the main toolbar, click

(Align), and then click the ball.

7 In the Align Selection dialog ➤ Align Position (Screen) group, turn on
X Position, Y Position, and Z Position. Then choose Center for both
Current Object (the Point helper) and Target Object (the golf ball).
8 Click OK to close the Align dialog.
Link the ball to the Point helper:

1 In the Top viewport,
the helper.

zoom in to get a better view of the ball and

2 On the main toolbar, turn on
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(Select And Link).

3 Select the ball, then drag to the box of the Point helper, and release the
mouse.

Now the ball is a child of the Point helper: When you move the point,
the ball will follow along.

4

Move the Point helper.
The ball and its trajectory both follow the Point.

5

Undo the Point helper movement.

Animate the changes in direction:
To make the ball move erratically, you want to give it lateral motion (via the
Point helper) every time the ball hits the ground. If the ball hits a tile, it should
continue forward. If the ball hits grout, it should change direction.
It’s easiest to move the Point in the Top viewport, while you watch the effect
in the Perspective viewport.

1 In the Top viewport, click
the floor, once again.

2 Turn on

(Zoom Extents) so you can see all of

(Auto Key).

3 Drag the time slider to frame 10. This is the first frame where the ball
touches down.
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4 In the Top viewport, move the Point along its X-axis, forward about one
tile. The ball should land on a tile.
5 Drag the time slider to frame 37. Move the point along its X-axis again,
about one and a half tiles. This time, the ball should land on grout.

At frame 37, the ball lands on grout.

6 Drag the time slider to frame 59. At this frame, move the ball in both X
and Y, to the right and onto grout again.
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At frame 59, the ball has veered to the right, only to land on grout once again.

7 At frame 81, change the ball’s direction once more, so it moves to the
left.
8 By now, you should have the general idea. Move the time slider from
one floor-contact frame to the next. After frame 81, these frames are 101,
117, 134, 147, 160, 173, 183, 193, 202, 219, 226, and 230.
Keep the ball moving laterally in the same direction if it lands on a tile,
and change the lateral direction if it lands on grout.
Here is how the completed scene looks, after animating the helper:
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Save your work:
■

Save your completed scene as my_chaotic_bounce.max.

To see a completed version of the chaotic bounce, you can
the scene, bouncing_chaos_completed.max.

open

You can also play the movie chaosbounce.avi to see a rendered version of
this animation.

Summary
This tutorial introduced several basic techniques of animating with Auto Key:
■

You can use Auto Key to block out animation.

■

You can use ghosting or trajectory display (or both) to help visualize an
animation.

■

You can use the Curve Editor to refine initial animation; for example, by
changing the tangency and thus the speed of a key, or by deleting
unwanted keys.
The Curve Editor also lets you create “out of range” repetition of an
animation, and adjust amplitude by using a multiplier curve.

■

The TCB Rotation controller is better than the default Euler XYZ Rotation
controller when you want to have continuous rotation.

■

A helper object such as Point can be useful for “separating” animation into
multiple tracks, such as bouncing versus lateral motion.

This tutorial also introduced you to some of the general principles of
animation:
■

Mass Making an object behave as if it has weight, perhaps based on
real-world observation, greatly increases the realism of an animation.

■

Ease In, Ease Out Having a motion begin a bit slowly, then slow again
when it comes to an end, in many cases also increases realism. Auto Key
creates ease-in/ease-out timing by default. In some cases, as you saw, this
isn’t the best solution. When a ball rebounds from a hard surface, the
motion should be fast.

■

Squash and Stretch Objects stretch out as they travel, and squash when
they are stopped. You can exaggerate this effect, whether for a ball or a
character, and still have a successful animation.
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Animating with Set Key
Set Key mode is an animation mode in 3ds Max Design that allows you to try
out different poses on a character or hierarchy, and then use those poses to
create keys on selected tracks.
It differs from Auto Key mode, where every transform and each change to an
object’s animatable parameters will result in animation. In Set Key mode, you
have to take an action (clicking the Set Keys button) in order to set a key.
Nothing happens automatically.
Mechanical, forensic, and industrial animators might find that Set Key
animation provides a precise and deliberate workflow to use instead of Auto
Key mode.
This example uses a simple chess set and the quickest possible checkmate, a
four-move game, to illustrate a typical Set Key workflow.
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The moves you will animate are:
■

White king-side knight’s pawn moves ahead two squares.

■

Black queen’s pawn moves ahead two squares.

■

White king-side bishop’s pawn moves ahead two squares.

■

Black queen moves diagonally to checkmate White king.

In this tutorial you will learn how to:
■

Turn on Set Key mode.

■

Use keyable icons in Track View.

■

Use key filters.

■

Create keys using Set Keys, and use its keyboard shortcut.

■

Move a pose in time.

Skill Level: Beginner
Time to complete: 20 minutes
Set up the scene:

■

On the Quick Access toolbar, click
(Open File), navigate to the
\scenes\animation\set_key folder, and open wood_chess_set.max.
NOTE If a dialog asks whether you want to use the scene’s Gamma And LUT
settings, accept the scene Gamma settings, and click OK. If a dialog asks
whether to use the scene’s units, accept the scene units, and click OK.
This scene is a wooden chess set. It isn't animated yet.

TIP You might want to

zoom in more closely on the chessboard in

the Perspective viewport, and
pan a bit, to see it better. It is shown
this way in the illustrations that follow.
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Use Set Key mode to move your pawns:

1 Turn on

(Toggle Set Key Mode).

The Set Key Mode toggle turns red, as does the time slider background
and the active viewport outline.

2 In the Perspective viewport,
select the pawn in front of the white
knight at the lower-right corner. If the transform gizmo isn't already

displayed, right-click and choose

Move from the quad menu.
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Pawn selected and Set Key mode turned on

First, you will set a key to keep the pawn in place at frame 0.

3 Click

(Set Keys).

The button turns red for a moment. A key appears at frame 0 on the track
bar.
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NOTE The Set Keys button also works in Auto Key mode.
4 Drag the time slider to frame 10.

5 Using the transform gizmo,

move the pawn ahead two squares.

Pawn position at frame 10

6 Click

(Set Keys) to set a key at frame 10.

A key appears in the track bar at frame 10.
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Now you'll animate the first move by the Black side.
Animate the Black king's pawn:
1 Go to frame 20.

2

Select the Black king's pawn.

3 Press K on the keyboard. This is the shortcut for the Set Keys button.
A key appears in the track bar for the Black pawn.
4 Drag the time slider to frame 30.
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5

Move the pawn ahead two squares.

6 Drag the time slider to frame 35.
The pawn jumps back.
The reason the pose was discarded is because you didn't set a key at frame
30. This is an important difference between Set Key and Auto Key. By
doing this lesson, you just learned that if you don't set keys while using
Set Key, you cannot retrieve your work.

7 Drag the time slider back to frame 30 and
place again.

move the pawn into

Animation at frame 30

Press K again to set the key.
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8

Play the animation.
The White pawn moves, and then the Black pawn moves.

Animate the bishop's pawn:

1

Select the White king-side bishop’s pawn and go to frame 40.

Select this pawn at frame 40.

2 Press K to set a key.

3 Go to frame 50. Now
press K again.
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move the pawn two squares ahead and

Animation at frame 50

Move a pose in time:
You might get a pose completely set up, only to discover that you are on the
wrong frame. There’s a simple trick that lets you move the pose to another
frame in time.

1 At frame 50,

select the Black queen, and press K to set a key.

2 Drag the time slider to frame 55.

3

Move the queen diagonally four squares. Use the corners of the
transform gizmo to move in both X and Y at the same time.
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Move the queen using the corners of the XY transform gizmo.

TIP Before moving the queen, arc rotate the viewport so you can see the
transform gizmo corners. You can also press + on the keyboard to enlarge
the gizmo.
Let’s say you realize you need this pose to happen at frame 60, not frame
55. Here’s what you do.
4 Right-click the time slider frame indicator (it reads 55/100) and drag to
frame 60.
Now you are at frame 60, and the queen hasn’t jumped back to the
previous position.

5 Click

(Set Keys) or press K to set a key.
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Set keyable tracks and key filters:
You’ve seen how to use Set Key in its simplest form. Now you’ll add a level of
complexity by selectively determining which tracks will be keyed.
The Black queen has the White king in checkmate. Traditionally the king is
knocked over to end the game.
You’ll set the Keyable tracks so that you can animate the rotation of the king,
along with its X and Y positions, but not its Z position. You don't want the
king dropping through the board.
NOTE When using Set Key animation, it’s useful first to determine which tracks
will be keyed and which won’t. In simple transforms this isn’t crucial, but if you’re
using Set Key to keyframe materials or object parameters, this is extremely
important. If you don’t define which tracks are keyable, all the animatable material
or object parameters will receive keys when you click Set Keys.

1

Select the White king, then right-click and choose Curve Editor
from the quad menu.
The Curve Editor dialog is displayed, with the King’s tracks displayed at
the top of the controller window at the left of the dialog.

2 On the Track View toolbar, click

(Show Keyable Icons).

The tracks for the White king show red “keyable” icons in the controller
window.
3 Click the red icons next to the Z position track and the Scale track.
The icons turn black to show they are inactive.
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Keyable tracks turned off for Z position
and scale

Now you will not be able to key the Z position or the scale of the king.
You can still key the rotation and the XY position tracks for the king.
If you want to key the rotation and the position tracks individually, you
can use the Key Filters.
4 Go to frame 75 and with the White king selected, press K.
This creates a position and rotation key at frame 75.
5 Go to frame 90, then click
is to the right of the Set Key button.

(Key Filters). This button

6 On the Set Key Filters dialog, turn off everything except Position.
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7

Close the Set Key Filters dialog.

8 Go to frame 100, then move the White king off the board to the left.

Rotate the king so it is on its side, then click
Keys) to create a key.

9

(Set

Play the animation. The White king moves off the board, but
doesn’t rotate, since Key Filters did not allow the rotation track to be
keyed.

10 Click

(Key Filters) and turn Rotation back on, then
close the dialog again.

11 Go to frame 100,

rotate the White king, and then set a key.
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TIP If you want to replace a key with a different one, delete the key in the

track bar, then use
(Set Keys) again to set a new key. Set Keys
doesn’t automatically replace a key that has already been set.

12

Play the animation. Now the rotation has been keyframed.

Checkmate!

13 Save your file as mycheckmate.max.

You can

open quickest_checkmate.max to compare with your file.
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Summary
In this tutorial, you have learned to use Set Key animation. You've learned
how to create keyframes with the Set Keys button, set Key Filters, and make
tracks keyable in Track View. You will find it useful to apply these lessons to
animating complex structures.

Working with the Walkthrough Assistant
Instead of manually manipulating the camera, you can make animating much
easier by using the Walkthrough Assistant. The Walkthrough Assistant allows
you to “fly” your camera to explore your virtual designs. Although the tool's
name implies interior usage, the Walkthrough Assistant is actually suitable
for both interior and exterior scenes.
In essence, it simplifies the tasks of creating a camera, constraining that camera
to a path of your choice, and then makes it easy to edit and animate various
aspects of the camera such as tilt, pan and lens values. All manipulation is
centralized in the same dialog so you do not have to browse through various
panels to make changes to camera parameters.

In this tutorial, you will learn how to:
■

Create a target camera

■

Adjust camera head tilt and angle
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■

Use Set Key to animate a camera

■

Render an animation to a sequence of still image files

■

Create a movie file of your animation

Skill level: Beginner
Time to complete: 1+ hours (includes rendering time to create an animation.)

Camera Setup with the Walkthrough Assistant
In this lesson, you'll use the Walkthrough Assistant to animate a camera,
simulating a walk or run along the Great Wall of China. The scene contains
a camera path ready for constraining the camera, but you will first need to
create a sufficient number of frames to hold your animation.
Set up this lesson:

■

On the Quick Access toolbar, click
(Open File) and from the
\animation\walkthrough_asst folder, open great_wall_start.max.
NOTE If a dialog asks whether you want to use the scene’s Gamma And LUT
settings, accept the scene Gamma settings, and click OK. If a dialog asks
whether to use the scene’s units, accept the scene units, and click OK.

Calculate the number of frames:
1 In the right viewport, select the blue spline that represents the camera
path. Alternatively, press H to open the Select From Scene dialog, and
double-click Camera Path.

2 On the

Utility panel, click the Measure tool.

This tool reports the length of the camera path is roughly 900 feet.
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NOTE For a comfortable walking pace, which is useful in architectural
walkthroughs, you'll need about a second for every 3 feet of distance. For a
jog or a fast run, you can go as far as 9 feet for a second. In NTSC format,
that translates into 30 frames for every 9 feet of distance traveled, or 3000
frames for 900 feet.

3 Click

(Time Configuration), next to the Current Frame Field).

4 In the Animation group in the Time Configuration dialog, change Start
Time to 1. Change End Time to 3000 to increase the number for frames
in the animation, and then click OK.
This will provide sufficient frames for your walkthrough animation.
The time slider frame indicator now displays 3000 frames.
Creating a basic setup using Walkthrough Assistant:
1 From the Animation menu, choose Walkthrough Assistant.
A modeless dialog displays.
2 In the Camera Creation group in the Main Controls rollout, ensure the
Free Camera option is chosen, and then click Create New Camera.
A new camera is created in the scene. The camera name,
Walkthrough_Cam01, displays in the Cameras group.
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3 In the Path Control group, click Pick Path and then in the Right viewport,
click the blue spline named Camera Path.
The Pick Path button label changes to reflect the name of the selected
spline. This constrains the Camera Position to the path. It also aligns it
to follow the direction of the path.

NOTE By default, the camera will travel at a constant speed and will always
point in the direction of travel. This is shown in the Advanced Controls rollout
at the bottom of the dialog where both these options are enabled.

4 Right-click the lower-right Perspective viewport to activate it. In the Main
Controls rollout, click the Set Viewport To Camera button to switch the
viewport to the Camera view.

5 Click

(Play Animation) to view the results in the Camera view.

The camera travels along the path but the motion seems unnatural, almost
robotic. This is because the aim or target of the camera is controlled by
the path constraint. It is far better to control the target manually, and
choose the direction you want to look at any given time. As an analogy,
as you walk in a straight line down a museum hallway, you would turn
your head to look at the paintings on the wall instead of keeping your
head pointed in the direction of your feet as you walk.
Save your work:
■

Save the scene as my_walkthrough_camera.max.
In the next lesson, you learn how to animate the camera using the
Walkthrough Assistant.
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Animating Camera Rotation
Now that the camera is constrained to the path, you'll animate the camera
rotation so that it is aimed in a more natural position at points of interest in
the scene.
Set up the lesson:
■

Continue from the previous lesson, or on the Quick Access toolbar, click

(Open File) and in the \animation\walkthrough_asst folder, open
great_wall_head.max.
TIP If the Units Mismatch dialog displays, choose Adopt The File's Unit Scale
and then click OK.
This is the same scene from the previous lesson. The camera is now in
place, but you will use Walkthrough Assistant to animate the Turn Head
parameters.

Turning off Follow Path:
1 If the Walkthrough Assistant dialog is not visible, go to the Animation
menu and choose Walkthrough Assistant.
2 In the Advanced Controls rollout, in the Path Controls group, disable
the Follow Path option. You will not need it because you will control the
head rotation manually.

NOTE Disabling the Follow Path option resets the camera orientation to its
default value (positive Y). You will fix that as you start animating the head
rotation from the Walkthrough Assistant dialog.

3 Make sure you are at frame 1, then turn on

(Auto Key).
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4 In the View Controls rollout, move the Turn Head slider to the left and
adjust the Head Tilt Angle to 16.4 in order get a better viewing angle of
the brick path in the Camera viewport.

5 Drag the time slider to frame 206. You are now at the other side of the
hilltop. Adjust the Head Tilt Angle to –3.3 to level the camera head, then
slide the Turn Head slider to the right to adjust the rotation.
The goal is to adjust the camera head rotation so that it looks towards
the tower as if it has suddenly caught your attention.
6 Drag the time slider ahead to frame 408. Adjust the Head Tilt Angle to
–13.5 so that you are looking at the paving stones in front of you.
Although it's nice to look at the scenery, it’s also important to create a
walkthrough that “feels” comfortable; in other words, to make it so that
the viewer doesn’t feel off balance while doing the a virtual walkthrough
of your scene.
7 Drag the time slider to frame 615. Change the Head Tilt Angle to –0.8
and drag the Turn Head slider a little to the right so the camera is looking
at the tower again.
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8 Drag the time slider to frame 800. Change the Head Tilt Angle to 5.6.
Move the Turn Head slider to the right until the tower opening is centered
in the camera view.

9 Scrub the time slider to frame 1050. Change the Head Tilt Angle to –0.8.
Move the Turn Head slider a little to the left so that the camera is tilted
in anticipation of turning left after exiting the tower.
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10 Drag the time slider to frame 1150. Change the Head Tilt Angle to 6.6.
Move the Turn Head slider slightly to the left so that you're looking the
second tower in the distance.

11 Drag the time slider to frame 1280. This time change the Head Tilt Angle
to –10.4 so that the camera head is tilted downwards to match the slope
of the path.
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12 Drag the time slider to frame 1420. Change the Head Tilt Angle to –11.9
to tilt the camera head further down.
13 Drag the time slider to frame 1680. You're now looking up again towards
the tower ahead of you. Adjust the Head Tilt Angle to 24.7. Slide the Turn
Head slider a little to the left so that is aimed at the second tower.

14 Drag the time slider to frame 1860. Change the Head Tilt Angle to 29.4.
Move the Turn Head slider slightly to the right so until you’re looking
at the second tower opening.
15 Drag the time slider to frame 2030. Change the Head Tilt Angle to –12.6.
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16 Drag the time slider to frame 2125. At this point in the walkthrough, you
are going downhill again. Change the Head Tilt Angle to about –23.3.
You want the camera head tilted downward toward the path instead of
out towarde the scenery, because you want the animation to feel as if
you're watching your step.

17 Drag the time slider to frame 2250. You are still looking at the path in
front of you. Change the Head Tilt Angle to –12.5. Adjust the Head turn
and tilt to that purpose.
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18 Drag the time slider to frame 2550. You are now going up the path.
Change the Head Tilt Angle to 22.7, and move the Turn Head slider
slightly to the right so that you’re looking toward the end of the pathway.

19 Turn off

20

(Auto Key).

Play the animation in the camera viewport to see the results.
Notice that the camera motion is far more natural than it was in the
previous lesson.
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NOTE The camera path will not be visible when you render the animation.

Save your work:
■

Save the scene as my_walkthrough_animated.max.

Summary
In this lesson, you have created a camera walkthrough animation using the
Walkthrough Assistant. You have learned to calculate the number of frames
needed for the animation and you have learned to automate the creation of
the camera and how to constrain it to a path. Finally, you have learned how
to manually animate the head turn and tilt of the camera to create realistic
camera motion.

Rendering Your Walkthrough Animation
There are some specific techniques to learn for rendering your animation into
a movie file. You can render directly to a movie format such as AVI, or you
can render a sequence of still image files to file formats such as TGA and then
use the RAM Player to save them into a movie. The latter method is the
recommended choice. It requires doing a few more steps than rendering
directly to a movie format, but it gives you more control over the file size and
quality of the output. In addition, if you have frames that have artifacts or
other errors, you can repair or remove them.
This animation will take some time to render. Depending on the speed of
your computer, the rendering can take a from a few minutes to several hours.
Set up the lesson:

■

From the \animation\walkthrough_asst folder,
great_wall_render.max.

open

TIP If the Units Mismatch dialog displays, choose Adopt The File's Unit Scale
and then click OK.
This file is similar to the one you created in the previous lesson. A bobbing
motion has been added to the camera to simulate the up-and-down effect
of someone jogging along the path. Two Omni lights have been added to
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create additional lighting, but to decrease rendering time, there is no Global
Illumination.
Rendering an image sequence:
1 If the Camera viewport isn't active, right-click it to activate it.

2 From the Rendering menu, choose

(Render Setup).

Next, you'll define the animation range and output size.
3 On the Common tab of the Render Setup dialog, in the Time Output
group, choose Active Time Segment. The range of frames is from 1 to
3000.
4 In the Output Size group, change the output resolution to 320x240.
5 In the Render Output group, click the Files button.
3ds Max Design opens the Render Output File dialog.
6 Navigate to a directory where there is enough disk space to save the
rendered files. You can use the Create New Folder button to establish a
new location, if necessary.
Next you'll define the type of still image file to render.
7 In the Save As Type field, click the drop-down arrow and choose JPEG
File (*.jpg).
NOTE In a production environment, probably you would want to use a
high-quality, lossless format such as TGA or TIF. For the purposes of this
tutorial, you will use the JPG format to keep the size of the output files small.
8 In the File name field, type my_jog.jpg, then click Save.
After you click Save, a format-specific dialog asks you to specify attribute
and information settings. Accept the default values, and then click OK.
When you render a still-image sequence, as in this case, 3ds Max Design
automatically appends a four-digit frame number to the first part of the
file name. So the first frame will be my_jog0000.jpg, the second
my_jog0001.jpg, and so on.
9 Make sure Save File is turned on in the Render Output group. Also, check
that the Viewport field at the bottom of the Render Scene dialog is set to
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Walkthrough_Cam01 (not Top, Front, or Left), then click
Production).

(Render

NOTE A sky background is rendered. A dome object represents the sky.
10 The Rendering Progress dialog displays. Wait for a short while as the first
frame is rendered. You will see the Last Frame Time, Elapsed Time, and
Time Remaining values change after the first frame finishes.
Allow at least four frames to render.
At this point, you can work on something else while 3ds Max Design
renders your animation.
TIP You can also watch the rendering for errors or observe to see where you
want to make changes. This is generally a good practice so that you can study
the scene as it is rendered.
After the rendering has completed, you will have 3,000 JPG files in the
folder you specified.
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Convert an image sequence into a movie:
The RAM Player loads still image sequences into memory and plays them so
you can watch them as a movie. It actually lets you load two different
sequences and then compare them visually, but you won’t use that
functionality here. You'll simply use the RAM Player to save the files into an
AVI file.
1 From the Rendering menu, choose RAM Player.
2 On the RAM Player toolbar, click Open Channel A.

3 In the Open File, Channel A dialog, navigate to the sequence of JPG image
files. Highlight the name of the first file in the sequence and then ensure
the Sequence option is turned on. Click Open.
The RAM Player will now load the image files in sequential order starting
with the first file you selected. The Image File List dialog appears. Here
you can use the Every Nth and Multiplier fields if you need to speed up
or slow down your animation. If your animation is too slow, change
Every Nth to 2 or 3. If your animation is too fast, increase the Multiplier.
4 Click OK.
The RAM Player Configuration dialog appears. Here you can observe and
adjust your memory usage. There are also tools here to resize your
animation, specify a range of frames to use, and split the alpha
(transparency) information into a separate file.
NOTE In order to use transparency, the image file specified has to be able
to process an alpha channel. JPG files do not contain any transparency
information the way TGA, TIF and PNG images often do.
5 Increase the Memory Usage to its maximum for your system, and then
click OK
The RAM Player loads the rendered files into memory. In the Loading
dialog, observe how much memory is being used and remains available.
If it looks like you are about to run out memory, click Stop Loading. If
you have a low-memory system, reduce the number of frames to load
and try again.
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6 On the RAM Player toolbar, click
the movie play.

(Playback Forward) and watch

7 On the RAM Player toolbar, click

(Save Channel A).

A Save File, Channel A dialog appears.
8 Choose AVI as the file type, and name the animation my_jog.avi. Click
Save.
The AVI File Compression Setup dialog appears. Here you can choose a
codec (compression/decompression type) and adjust the quality of the
file. Choose the default Cinepak Codec. To reduce file size, lower the
quality to 75%.

9 Click OK to continue.
Save your work:
■

Save the scene as my_walkthrough_renderable.max.
You can find a finished rendering of the animation as
walkthrough_asst_great_wall.avi in the project folder \sceneassets\renderassets.
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Summary
You have learned how to render your animation to a sequence of still image
files. This allows you better control for later correction of your animation.
You also learned how to assemble a still image sequence into a movie file,
such as AVI or QuickTime using the RAM Player.
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580

Materials and Mapping
Tutorials

5

Materials are like paint. With materials, you make apples red and oranges orange. You put
the shine in chrome and the polish on glass. By applying maps, you can add images, patterns,
and even surface texture to objects. Materials are what make your scenes look real.
Mapping is a method of projecting pictorial information (materials) onto surfaces. It is a lot
like wrapping a present with wrapping paper, except the pattern is projected mathematically,
with modifiers, rather than being taped to the surface.
This tutorial introduces the Material Editor, the master design studio for materials and maps.
In the following tutorials, you will learn how to assign materials to objects, how to create
basic materials, and how to apply textures.

581

Features Covered in This Section
■

Using the 3ds Max Design Material Editor to create, edit and apply materials.

■

How mapping coordinates work, and how to manipulate them using 3ds Max Design
modifiers.

■

How to layer multiple texture maps onto a surface to create a composite image.

■

How to map textures onto curved surfaces.

■

How to apply multiple sub-maps similar objects to give each their own unique identity.
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Introduction to Materials and Mapping
In this tutorial, you will use a model of a Mediterranean villa to learn more
about materials and how they can improve the realism of a scene.

A rendering of the villa after you have completed the tutorial

In this tutorial, you learn how to:
■

Create simple materials and apply them to objects

■

Create a multi-sub/object material for more complex objects

■

Apply texture maps to model real-world surfaces such as wood, foliage,
and stone

■

Apply bump maps to improve the realism of texture maps

■

Use the Propagate option when you work with instanced objects

Skill level: Beginner
Time to complete: 1 1/2 hours
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Creating Simple Materials
For many surfaces, you can obtain good results by choosing a simple but
appropriate material and changing just a few settings. In this lesson, you will
use this approach to add surface detail to a railing, the walls of a house, and
the water for a swimming pool and for the sea itself.
Set up the lesson:

■

On the Quick Access toolbar, click
(Open File), navigate to the
\scenes\materials_and_mapping\med_villa folder, and open the scene file
med_villa_mat_start.max.
NOTE If a dialog asks whether you want to use the scene’s Gamma And LUT
settings, accept the scene Gamma settings, and click OK. If a dialog asks
whether to use the scene’s units, accept the scene units, and click OK.

The villa before applying materials
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Although the villa scene is set up with lighting and cameras, it has no materials.
The effect is rather featureless and unrealistic: This is typical of newly created
geometry in 3ds Max Design.
Create a material for the railings:

1 On the main toolbar, click
Material Editor.

(Material Editor) to open the Slate

TIP If this is the first time you are using the Slate Material Editor, you might
need to resize it so you can easily see all three of the columns in its interface.
Also, to see changes in the viewport, it will help to minimize the Slate Material
Editor while you work, and then restore it when you need to work on materials
some more.
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The Material Editor is a sort of workbench for creating, adjusting,
managing, and applying materials to objects. The main portions of its
interface are:
■

On the left, a Material/Map Browser panel where you can choose
material and map types (or ready-made materials) to add to the scene.

■

In the middle, a View panel where materials and maps appear as nodes
that you can wire together.

■

On the lower right, a Parameter Editor where you can edit the material
and map controls.

TIP If the Compact Material Editor opens instead, then on the Material Editor
menu bar, choose Modes ➤ Slate Material Editor. The Compact Material
Editor has a smaller window, with conspicuous sample slots near the top of
its interface.
2 On the Material/Map Browser panel to the left, locate Materials ➤ mental
ray ➤ Arch & Design, and drag the Arch & Design entry from the Browser
to the active View.
3ds Max Design displays an Arch & Design material node in the active
view.
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In 3ds Max Design, Arch & Design is the default material type. It is an
extremely versatile material interface, but it has a large number of
controls, as you can see. In this tutorial, we will use both the Arch &
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Design material and Autodesk Materials. Autodesk Materials are based
on Arch & Design. Like Arch & Design, they are physically accurate, but
they have simplified interfaces based on real-world material settings.
3 Double-click the Arch & Design material node.
The parameters for the Arch & Design material appear in the Parameter
Editor on the right side of the Slate Material Editor. They are grouped
into rollouts.
4 In the Name field, at the top of the Parameter Editor, change the material
name to Blue Railings.

It is good to get in the habit of naming a material as soon as you create
it. In a complex scene, intelligible material names are useful.
Notice that as you change the name, the name in the title bar of the
material node in the active View updates as well.
Change the color of the railings:
1 On the Templates rollout, open the drop-down list of templates and
choose Glossy Finish.
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2 In the Main Material Parameters rollout ➤ Diffuse group, click the color
swatch.
3ds Max Design opens a Color Selector dialog.

3 In the Color Selector, choose a medium-dark blue color.
There are a few ways to do this, but probably it is easiest to click the large
spectrum on the left side of the Color Selector. If the color seems too
washed out, drag the Saturation slider to the right, near 100 percent.
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4 Click OK to close the Color Selector.
The preview in the title bar of the Blue Railings material node now shows
the blue color.
5 Double-click the preview to make it larger.

TIP To make the preview smaller, you can double-click it again.
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6 The material is a little too glossy. In the Main Material Parameters rollout
➤ Reflection group, change the value of Reflectivity to 0.3.

Apply the material to the railings:
1 If the Layers toolbar isn’t visible, right-click the gray area to the right of
the main toolbar, and choose Layers to display this toolbar.

2 From the drop-down list of layers on the toolbar, choose Railings.

3 On the toolbar, click

(Select Objects In Current Layer).

This selects the railings in the scene: both the railings along the deck,
overlooking the ocean, and the railings on the balcony of the house.

4 On the Slate Material Editor toolbar, click
Selection).

(Assign Material To

In the scene, the railings turn blue.
Look at the material preview: It now has angled corners.
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Angled corners on a preview mean that the material has been applied to
at least one object in the scene. When the angled corners are solid white,
as they are in this case, the material is said to be hot. When you make
changes to a hot material, the scene changes immediately, and usually
the viewport display shows the material changes you have made.
5 In the Slate Material Editor active View, double-click the Blue Railings
preview to make the preview smaller, then click the minus-sign icon (–)
to collapse the node display, and drag the node to the upper left of the
View so it is out of the way.
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Create a material for the house:
1 On the Layers toolbar, choose exterior walls from the list of layers, and

then click

(Select Objects In Current Layer).

This selects the exterior walls of the house.
2 In the Slate Material Editor, drag another Arch & Design material from
the Browser panel into the active View. Double-click the new material
node to see its parameters.
3 Name this new material White Concrete.
4 On the Templates rollout, open the drop-down list of templates and
choose Matte Finish.
5 In the Main Material Parameters rollout ➤ Diffuse group, click the color
swatch.
6 On the Color Selector, change the Value to 0.9 so the color is very slightly
gray, or “off-white.” Click OK.
These settings handle the finish and color of the white concrete house,
but concrete often has a texture to it, as well.
7 On the White Concrete material node, drag a wire away from the Bump
Map input socket, and then release the mouse.
3ds Max Design opens a pop-up menu so you can complete the
connection.
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8 From the pop-up menu, choose Standard ➤ Bitmap.
3ds Max Design opens a file dialog.
9 On the file dialog, choose simple_concrete_mtl_broomcurved_pattern.jpg,
and then click Open.
10 Double-click the White Concrete material node so you can see its
parameters.
11 On the Special Purpose Maps rollout, change the Bump map amount
value to 1.0.
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12 On the Slate Material Editor toolbar, click
Selection).

(Assign Material To

In the shaded viewports, the house turns to a light gray color.
Use a rendering to see the White Concrete texture:
The distant views of the house won’t show the concrete texture clearly, but
if you render a close-up of the house, the texture will be apparent.
1 Minimize the Slate Material Editor.
2 Click the POV viewport label of the Camera-Terrace viewport, and choose
Cameras ➤ Camera_house_closeup.

3 With the Camera_house_closeup viewport active, click
Production).

(Render
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The close-up view of the porch of the house shows the concrete texture
well.
4

Close the rendered frame window.

5 Change the viewport back to Cameras ➤ Camera-Terrace.
6 In the Slate Material Editor, click the minus-sign icon to minimize the
White Concrete material node. Move the Bitmap node so it is not far away

from its parent, then on the toolbar, click
(Move Children), and
drag the White Concrete node to move both nodes out of the way, near
the Blue Railings node.

7 Click

(Move Children) again to turn it off.
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Create a material for the interior walls:
1 On the Layers toolbar, choose interior walls from the list of layers, and

then click

(Select Objects In Current Layer).

In the views that are active now, you can’t really see the interior.
2 Right-click a viewport, and choose Isolate Selection from the Display
(upper-right) quadrant of the quad menu.
Now you can see the interior wall selection even in the shaded camera
viewports.
TIP You might have to move the Warning: Isolated Selection dialog to see
the geometry clearly.

3 In the Slate Material Editor, drag an Autodesk Wall Paint material from
the Browser into the active View. (Like the Arch & Design material,
Autodesk Wall Paint is also in the Materials ➤ mental ray group.)
4 Double-click the new material node so you can see its parameters.
5 Name this material Interior Walls.
6 On the Wall Paint rollout, click the Color swatch. In the Color Selector,
choose a light cream color: Red=0.9, Green=0.8, Blue=0.5. Click OK to
close the Color Selector.
7 Also on the Wall Paint rollout, open the Finish drop-down list and choose
Platinum. Leave Application set to its default value of Roller.
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8 On the Slate Material Editor toolbar, click
Selection).

(Assign Material To

In the shaded viewports, the interior walls now have a light cream color.

9 On the Warning: Isolated Selection dialog, click Exit Isolation Mode so
you can see the entire scene once again.
10 In the Slate Material Editor, move the Interior Walls node near the nodes
of the other materials you’ve already designed.
Create a water material for the swimming pool:
1 Drag an Autodesk Water material from the Browser into the active View.
Double-click the node so you can see its parameters, and name this
material Water - Pool.
2 Click the Material Type button. In the Browser, choose Autodesk Water
from the list of materials, and then click OK.
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The default setting for the Autodesk Water material is Swimming Pool,
which has its own custom color. This is appropriate for this scene, so
don’t change the Type setting.
3 Drag the Wave Height slider so the value is about 0.4.

The swimming pool doesn’t need large waves.
4 Move the Slate Material Editor window so you can see at least one of the
shaded viewports. Drag from the output socket (the circle at the right)
of the Water - Pool material node, and release the mouse (“drop” the
material) over the pool-water object.
The water turns transparent.
Dragging and dropping from the output of a material node is a shortcut
way to assign a material. It is useful when you apply the material to a
single object, such as the water in the pool.
5 In the active View, minimize the Water - Pool node and move it near the
other nodes you’ve created already.
Create a different water material for the ocean:
1 Move the Slate Material Editor window so you can see the Left viewport.
Click the POV viewport label of the Left viewport, and change it to a Top

viewport. If you need to, click
the objects in the scene.

(Zoom Extents) so you can see all

2 Drag another Autodesk Water material from the Browser into the active
View. Double-click the node so you can see its parameters, and name this
material Water - Sea.
3 On the Water rollout, change the Type to Generic Sea/Ocean and the
Color to Generic Sea/Ocean.
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4 Drag from the output socket of the Water - Sea material node, and in the
Top viewport, drop the material on the Sea object.

5 On the main 3ds Max Design toolbar, click

(Render Production).

Rendering of the villa with simple materials applied

Even simple materials greatly improve the realism of the scene.
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NOTE At this point, the shadows at the end of the pool look a bit strange,
but don’t worry about that: When you apply a material to the bottom of the
pool, this problem will go away.

Save your work:
■

Save the scene as my_villa_simple_mtls.max.

Next
Using a Multi/Sub-Object Material for the Doors and Windows on page 601

Using a Multi/Sub-Object Material for the Doors and
Windows
The villa includes doors and windows. These objects use multiple material IDs
to enable you to apply different materials to different surfaces of the object.
(Some other architectural objects, and even some primitives, use the same
method.)
A material ID is simply an ID number associated with certain surfaces on an
object. It works with the Multi/Sub-Object material. The Multi/Sub-Object
material contains multiple sub-materials, each of them linked by material ID
to the object that uses the Multi/Sub-Object material.
Doors and windows use material IDs in the same general way, as shown in
the following illustration.
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Material IDs for a door or window
1. Front of door
2. Back of door
3. Inner bevel
4. Door frame
5. Inner door

In this lesson, although doors and windows employ five different ID values,
you use only two sub-materials: a solid color for the wooden parts, and a
transparent material for the glazing or glass panel, which corresponds to the
“inner bevel” ID.
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Set up the lesson:

■

Continue from the previous lesson, or
med_villa_mat_multisub.max.

open

Create the top-level multi/sub-object material:

1 In the
Slate Material Editor, drag a Multi/Sub-Object material
from the Browser into the active View. Drop it a good deal to the right
of the nodes that are already in the View, so its sub-materials don’t overlap
the older nodes.
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NOTE Unlike the Arch & Design and Autodesk materials, the Multi/Sub-Object
material is in the Materials ➤ Standard group.
By default, the Multi/Sub-Object material comes with ten Standard
materials wired to it. It looks a little overwhelming, but we don’t need
all those materials.
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2 In the Slate Material Editor, click
nodes in the View.

(Zoom Extents) to see all the

3 Drag a selection box to select all the Standard sub-material nodes and
their wires, then press Delete.
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Dragging a box to select the sub-materials

606 | Chapter 5 Materials and Mapping Tutorials

Sub-materials deleted

4 Move the new Multi/Sub-Object material node just to the right of the
other nodes, and then click

(Zoom Extents) again.
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5 Double-click the Multi/Sub-Object material node so you can see its
parameters. Name this material Doors & Windows.
6 On the Multi/Sub-Object Basic Parameters rollout, click Set Number.
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In the small dialog that opens, reduce the number of sub-materials to 5,
and then click OK.

Now the rollout shows only five sub-materials, and so does the material
node, which now looks more manageable.
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Add the solid sub-materials:
For the solid parts of the doors and windows, you can use the same blue
material you used for the railings of the deck and the house.
■

Wire the Blue Railings material node to sub-materials (1), (2), (4), and (5)
of the Doors & Windows material.

That leaves only ID 3, the inner bevel, which requires glazing.
Add the glazing sub-material:
For the glazed parts of the doors and windows, you need a different
sub-material that is transparent.
1 From the Browser, drag an Autodesk Glazing material (Materials ➤
mental ray group) into the active View, and wire it to sub-material (3) of
the Doors & Windows material.
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2 Double-click the new Glazing node so you can see its parameters.

The default color is Clear, which is what we want, so leave these settings
unchanged.
Select the doors and windows, and apply the material:
1 If the Layers toolbar isn’t visible, right-click the gray area to the right of
the main toolbar, and choose Layers to display this toolbar.
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2 On the Layers toolbar, open the drop-down list of layers and choose Doors

& Windows, then click

(Select Objects In Current Layer).

This selects all the doors and windows in the house.

3 On the Slate Material Editor toolbar, click
Selection).

(Assign Material To

This applies the Multi/Sub-Object material to doors and windows: The
frames turn blue, while the glazed parts (“inner bevels”) turn transparent.
4 Right-click the Camera-Terrace viewport to make it active, and then click

(Render Production).
3ds Max Design renders the scene.

Incidentally, in this rendering you can see a small amount of the interior
wall paint that you created in the previous lesson.
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Save your work:
■

Save the scene as my_villa_doors_and_windows.max.

Next
Add Materials to the Deck: Texture Mapping and Bump Mapping on page 613

Add Materials to the Deck: Texture Mapping and Bump
Mapping
Bitmaps are a simple but versatile way to add visual detail to scenes. When a
bitmap is used to provide an object’s color, it is also known as a texture map.
In this lesson and the ones that follow, you apply bitmaps to various parts of
the scene (the deck, the terrain, the vase, the bottom of the swimming pool,
and the arbor trellis on the upper porch of the house) to achieve realistic
effects. Different kinds of geometry require different techniques of mapping,
as these lessons will show.
Set up the lesson:

■

Continue from the previous lesson, or
med_villa_mat_mapped.max.

open

Create the wooden deck material and apply it:

1 In the Camera-Hi-Point viewport,
object.

click to select the Wood-Deck

The Wood-Deck overlies the Terrace object, so you might have to move
the mouse around till you see the name Wood-Deck in a tooltip. Don’t
select the Terrace at this point. If you have trouble finding Wood-Deck
with the mouse, press H and select Wood-Deck in the Select From Scene
dialog.
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2 In the
Slate Material Editor, drag another Arch & Design material
from the Browser to the active View. Double-click the new node so you
can see its parameters, and name this material Wood - Deck.
3 On the Templates rollout, open the drop-down list of templates, and
choose Glossy Finish.
The default Glossy Finish is a bit too glossy, so you will tone it down.
4 In the Main Material Parameters rollout ➤ Reflection group, change the
value of Reflectivity to 0.3 and the value of Glossiness to 0.7.

5 Drag a Bitmap from the Browser into the active View. (The Material/Map
Browser is the panel at the left of the Slate Material Editor, and you can
find Bitmap in the Maps ➤ Standard group.)
3ds Max Design opens a file dialog.
6 In the file dialog, browse to the \sceneassets\images folder. Choose the
file cedfence.jpg, and then click Open.
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Cedar texture for the wooden deck

7 Wire the new Bitmap node to the Diffuse Color Map component of the
Wood - Deck material node.

8 Click

(Assign Material To Selection).

In the shaded viewports, the Wood-Deck object turns brown.

9 Make sure the Wood - Deck node is active, then click
Standard Map In Viewport) to turn it on.

(Show
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Now the Wood-Deck object shows a pattern in the shaded viewports.
However, the pattern is rather scrambled and is not quite the effect we’re
looking for. To improve the appearance of the wooden deck, you’ll adjust
how the material is mapped.
10 Double-click the new Bitmap node so you can see its parameters. On the
Coordinates rollout, make sure Use Real-World Scale is turned on, then
change the value of Width ➤ Size to 3.0m (meters) and the value of
Height ➤ Size to 2.0m (meters).
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Now the cedar flooring is scaled to the scene correctly.

This completes the wooden portion of the terrace.

11 In the Slate Material Editor, turn on
(Move Children), line the
Wood - Deck nodes up with the other materials you’ve already created,
then minimize the material node.
Create the tiled terrace material:
For the tiled portion of the terrace, you also use a texture map, this time in
conjunction with a bump map.
1 Drag a new Arch & Design material from the Browser to the active View.
Double-click the new material node so you can see its parameters, and
name this material Terrace.
2 On the Templates rollout, open the drop-down list of templates, and
choose Glossy Finish.
Once again, the default Glossy Finish is a bit too glossy, so you will tone
it down.
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3 In the Main Material Parameters rollout ➤ Reflection group, change the
value of Reflectivity to 0.3 and the value of Glossiness to 0.5.

4 Drag a Bitmap from the Browser into the active View.
3ds Max Design opens a file dialog.
5 In the file dialog, browse to the \sceneassets\images folder. Choose the
file tile-cast.jpg, and then click Open.

Left: Pattern bitmap for the deck tiles
Right: Bump map for the deck tiles (see below)

For the tiling on the terrace, you will use both a texture map, tile-cast.jpg,
and later add a bump map, tile-cast-bump.jpg. But the first thing to do is
to apply the material and adjust its mapping.
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6 Wire the new Bitmap node to the Diffuse Color component of the Terrace
material node.
7 Move the Slate Material Editor window so you can see the Terrace object
in the shaded viewports, then drag from the output socket of the Terrace
material node, and drop the material on the Terrace object.

8 On the Slate Material Editor toolbar, click
In Viewport) to turn it on.

(Show Standard Map

In the shaded viewports, the terrace turns gray, but it doesn’t display the
tile map the way the deck displayed the wood grain. This is an indication
that there is another step you must take.
The Wood-Deck object is a Box object. Like other boxes and all other
standard primitives, it already has default mapping coordinates. The
Terrace object, on the other hand, is an editable mesh. Editable surfaces
such as mesh, patch, and poly do not have default mapping coordinates,
so you must add a modifier that supplies these coordinates. This is the
subject of the next procedure.
Set up mapping for the tiles:

1

Select the Terrace object, then go to the

Modify panel.

2 Open the Modifier List, and choose UVW Map.
TIP While the Modifier List is open, you can press the U key until UVW Map
is chosen.
The Modify Panel now displays controls for the UVW Map modifier. Also,
a version of the tile texture map is now visible in shaded viewports.
3 In the Modify panel ➤ Parameters rollout ➤ Mapping group, make
sure Real-World Map Size is turned on.
4 In the Slate Material Editor, double-click the Bitmap node so you can see
its parameters. On the Coordinates rollout, make sure Use Real-World
Scale is turned on.
Real-World Map Size in the map coordinate settings and Use Real-World
Scale in the UVW Map modifier settings should either both be on or both
be off at the same time.
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The viewports now show tiling on the terrace, but the pattern is muddled.
This is because you need to set the size of the tiles.
5 As you did for the cedar deck, change the value of Width ➤ Size to 3.0m
and the value of Height ➤ Size to 2.0m.

Now the tiling pattern on the terrace is nicely matched to the rest of the
scene.
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There is one small problem, however: The edges of the tiles don’t match
the edge of the swimming pool. You can fix this by adjusting the tiling
offset.
6 On Coordinates rollout, set Width Offset to –0.2m, and Height Offset to
0.2m.

Now the tiles are aligned with the pool.
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Add bump mapping to the terrace tiles:
1 Drag from the Bump Map socket of the Terrace material node, and release
the mouse. From the pop-up menu, choose Standard ➤ Bitmap.
3ds Max Design opens a file dialog.
2 In the file dialog, browse to the \sceneassets\images folder. Choose the
file tile-cast-bump.jpg and click Open.
NOTE As in this case (see the illustration above), an effective bump map is
often simply a black-and-white version of the texture map.
The UVW Map modifier belongs to the object: It affects both the texture
map and this new bump map equally. However, you must also make sure
that the bump map’s own mapping coordinates are the same as the texture
map’s: Otherwise, the bump effect will be “out of phase” with the texture,
and won’t appear correctly.
3 Double-click the new Bitmap node so you can see its parameters.
4 On the Coordinates rollout, make sure that the bump map settings are
the same as the texture map settings:
■

Use Real-World Scale turned on

■

Width Offset = –0.2m

■

Height Offset = 0.2m

■

Width Size = 3.0m

■

Height Size = 2.0m

The bump effect is subtle, and it doesn’t appear in viewports, so to see
it, use a preview.
5 Right-click the Terrace material node, and choose Open Preview Window.
3ds Max Design opens a preview of the material.
6 Drag a corner of the preview window to make it larger.
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7 Close the preview window.

8 Activate the Camera-Terrace viewport, then

render the scene.
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9 In the Slate Material Editor, line the Terrace nodes up with the other
materials you’ve already created, then minimize the material node.
Save your work:
■

Save the scene as my_villa_deck.max.

Next
Create a Material for the Bottom of the Swimming Pool: Using Box Projection
on page 624

Create a Material for the Bottom of the Swimming Pool:
Using Box Projection
The floor and sides of the swimming pool are also made of ceramic tiles, but
in this case the tiles are small, and might better be described as terrazzo or
mosaic.
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Set up the lesson:
■

Continue from the previous lesson.

Select the swimming pool:
1 On the Layers toolbar, choose the layer called Swimming Pool, and then

click

(Select Objects In Current Layer).

2 Right-click a viewport and choose Isolate Selection.
Now only the swimming pool is selected and visible in all viewports.
Create the mosaic material:
1 In the Slate Material Editor, drag a new Arch & Design material from the
Browser into the active View, and double-click the new material node so
you can see its parameters. Name this material Swimming Pool.
2 On the Templates rollout, open the drop-down list of templates and
choose Glossy Finish.
3 On the Reflection rollout, change the value of Reflectivity to 0.6 and the
value of Glossiness to 1.0.

4 Drag a Bitmap node from the Browser into the active View.
3ds Max Design opens a file dialog.
5 In the file dialog, browse to the \sceneassets\images folder. Choose the
file mosaic.jpg and click Open.
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Mosaic map for the sides and bottom of the swimming
pool

6 Wire the new Bitmap node to the Diffuse Color Map component of the
Swimming Pool material node.
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7 Double-click the new Bitmap node so you can see its parameters.
8 On the Coordinates rollout, make sure Use Real-World Scale is turned
on, and then set Width ➤ Size = Length ➤ Size = 3.0m (meters).

Create a Material for the Bottom of the Swimming Pool: Using Box Projection | 627

9 On the Slate Material Editor toolbar, click
In Viewport) to turn it on.

(Show Standard Map

10 Click the Swimming Pool material node to make it active, then on the Slate

Material Editor toolbar, click

(Assign Material To Selection).

The swimming pool is an editable mesh, so as with the terrace, you need
to apply a mapping modifier.

11 Go to the
Modify panel, and choose UVW Map from the Modifier
List drop-down list.
Make sure the UVW Map modifier’s Real-World Map Size toggle is turned
on. (It should be on by default.)
12 Examine the mapping in the Camera-Hi-Point viewport.

The bottom of the pool doesn’t look bad, but the sides are streaked.
Unlike the wooden deck and the tiled terrace, which are flat surfaces, the
swimming pool has both flat (or nearly flat) surfaces and vertical ones,
so the default Planar mapping doesn’t work.
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13 On the
Modify panel ➤ Parameters rollout, change the map
projection from Planar to Box.
The radio buttons at the top of the UVW Map Parameters rollout control
how a map is “projected” onto the surface of an object. For the pool, Box
projection works better than Planar.

Now the pool has a fine-grained mosaic tile texture of the correct size.
It’s a little too fine-grained to show up well in viewports, but when you
render it, it looks correct, and it interacts nicely with the Water - Pool
material above it.
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14 In the Slate Material Editor, line the Swimming Pool nodes up with the
other materials you’ve already created, then minimize the material node.
Save your work:
■

Save the scene as my_villa_pool.max.

Next
Create a Material for the Terrain: Cropping a Texture on page 630

Create a Material for the Terrain: Cropping a Texture
The terrain is an oblong of undeveloped land behind the terrace. The house
rests partly on the terrace, and partly on the terrain.
Set up the lesson:
■

Continue from the previous lesson.
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Create the terrain material:
1 Drag a new Arch & Design material from the Browser into the active
View, and double-click the new material node so you can see its
parameters. Name this material Terrain.
2 On the Templates rollout, open the drop-down list of templates, and
choose Matte Finish.
3 Assign a Bitmap to the Diffuse Color Map component of the Terrain
material node.
3ds Max Design opens a file dialog.
4 In the file dialog, browse to the \sceneassets\images folder. Choose the
file terrain.jpg and click Open.

The terrain texture

5 In the Top viewport,

click to select the terrain object.

The terrain is easiest to see if the viewport is shaded. If it isn’t, press F3
to turn on shading.
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Terrain object selected in the Top viewport

6 On the Slate Material Editor toolbar, click
In Viewport) to turn it on.

(Show Standard Map

7 Click the Terrain material node to make it active, then on the Slate Material

Editor toolbar, click

(Assign Material To Selection).

The map doesn’t appear in viewports yet because the terrain object is also
an editable mesh, and requires a mapping modifier.
Adjust the mapping:

1 On the
Modify panel, choose UVW Map from the Modifier List
drop-down list.
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The map is now visible in shaded viewports.

Planar mapping is appropriate again, in the case of the terrain. Turn off
Real-World Map Size for UVW Map.
2 Double-click the Bitmap node so you can see its parameters.
3 On the Coordinates rollout, turn off Use Real-World Scale.
The map still appears to be squashed: This is because the original texture
is square, while the terrain object is oblong. You can fix this by cropping
the map.
4 In the Bitmap Parameters rollout ➤ Cropping/Placement group, click
the View Image button.
3ds Max Design opens a Specify Cropping/Placement dialog. It displays
the map, surrounded by a red box with square handles. You can move
the box, or use the handles to resize it.
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5 In the Specify Cropping/Placement dialog, drag the handle in the middle
of the lower edge upward, until the cropping box encloses only about
the upper quarter of the texture.
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6

Close the Specify Cropping/Placement dialog.

7 In the Material Editor, in the Bitmap Parameters rollout ➤
Cropping/Placement group, click Apply to turn it on and apply the
cropping. (Make sure Crop and not Place is the option chosen just below
the Apply toggle.)
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Now the terrain map fits the terrain object.
8 In the Slate Material Editor, line the Terrain nodes up with the other
materials you’ve already created, then minimize the material node.
Save your work:
■

Save the scene as my_villa_terrain.max.

Next
Create a Material for the Vase: Using Cylindrical Projection on page 636

Create a Material for the Vase: Using Cylindrical
Projection
For the outdoor vase, you will use a stone material and a slightly different
mapping.
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Set up the lesson:
■

Continue from the previous lesson.

Select the vase and isolate it:

1 In the Camera-Terrace viewport,
object.

click to select the Plant-Pot

2 Right-click to display the quad menu, and choose Isolate Selection.
3 Click the Point Of View (POV) viewport label (it now shows
“Camera-Terrace”), and choose Perspective.
This helps you get a better view of the vase.
TIP You might have to move the Warning: Isolated Selection dialog to see
the viewport labels.

4 Click

(Zoom Extents All).

You can find this button among the navigation buttons at the lower right
corner of the 3ds Max Design window.
Now the viewports show a closeup of the vase (except for
Camera-Hi-Point, which retains the camera’s point of view).
Create the stone material:
1 Drag a new Arch & Design material from the Browser into the active
View, and double-click the new material node so you can see its
parameters. Name this material Plant Pot.
2 On the Templates rollout, open the drop-down list of templates, and
choose Matte Finish.
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3 Assign a Bitmap to the Diffuse Color Map component of the Plant Pot
material node.
3ds Max Design opens a file dialog. In the file dialog, navigate to the
\sceneassets\images folder, choose the file travertn.jpg, then click Open.

Travertine texture for the vase

4 Click the Bitmap node to make it active.

5 On the Slate Material Editor toolbar, click
In Viewport) to turn it on.

(Show Standard Map

6 Click the Plant Pot material node to make it active, then on the Slate

Material Editor toolbar, click

(Assign Material To Selection).

In viewports, the vase turns brown, but doesn’t show the map. The vase
is an Editable Poly object, and like Editable Mesh, this object type requires
a mapping modifier.
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Map the vase and adjust the map settings:

1 On the

Modify panel, apply a UVW Map modifier to the vase.

2 For the UVW Map modifier, turn off Real-World Map Size. Also
double-click the Bitmap node and on the Coordinates rollout, turn off
Use Real-World Scale.

If you shade the Front viewport the mapping looks all right, but in the
Perspective viewport you can see that the sides appear to be smeared.

3

Orbit the Perspective viewport to see how the map is smeared
along the sides of the vase. When you’re done, press Shift+Z to undo the
rotation.
Planar mapping isn’t appropriate for the vase.

4 On the UVW Map Parameters rollout, change the map projection to
cylindrical.
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A brown cylindrical “gizmo” shows the cylinder used to project the map.
Unfortunately, the default orientation of the cylinder isn’t aligned with
the vase, so you need to fix that.
5 In the Parameters rollout ➤ Alignment group, change the axis to X.
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Now the projection cylinder (gizmo) is aligned with the vase.
6 Also in the Alignment group, click Fit.
This fits the gizmo to the vase geometry, so there’s no chance of tiling.
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Change the surface finish of the vase:
1 In the Slate Material Editor, assign a Bitmap to the Bump Map component
of the Plant Pot material node.
3ds Max Design opens a file dialog.
2 In the file dialog, browse to the \sceneassets\images folder. Choose the
file simple_stone_mtl_granite_bump.jpg and click Open.
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Granite texture to use as a bump map for the vase

3 Double-click the Plant Pot material node so you can see its parameters.
Scroll down to the Special Purpose Maps rollout, and change the value
for the Bump map to –0.5.

This gives the vase a weathered look when you render it.
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As with the bump map you applied to the terrace tiles, the detailed vase
texture won’t be apparent in long shots, but it might come in useful if
you render the vase close up.
4 On the Warning: Isolated Selection dialog, click Exit Isolation Mode.
5 If a Select Camera dialog appears, choose Camera-Terrace, and then click
OK; otherwise, click the Point Of View (POV) viewport label, and choose
Cameras ➤ Camera-Terrace to restore the long camera view.
6 In the Slate Material Editor, line the Plant Pot nodes up with the other
materials you’ve already created, then minimize the material node.
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Save your work:
■

Save the scene as my_villa_vase.max.

Next
Create a Material for the Trellis: Using MapScaler on page 645

Create a Material for the Trellis: Using MapScaler
The next object to texture is the arbor trellis on the balcony of the house. Its
geometry is complicated, and requires a new mapping technique.
Set up the lesson:
■

Continue from the previous lesson.

Create the weathered wood material:
1 Drag an Arch & Design material from the Browser into the active View,
and double-click the new material node so you can see its parameters.
Name this material Trellis.
2 On the Templates rollout, open the drop-down list of templates, and
choose Matte Finish.
3 Assign a Bitmap to the Diffuse Color Map node of the Trellis material.
3ds Max Design opens a file dialog. In the file dialog, navigate to the
\sceneassets\images folder, choose the file oldwood.jpg, then click Open.

Weathered wood texture for the trellis
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4 Click the Bitmap node to make it active, then on the Slate Material Editor

toolbar, click

(Show Standard Map In Viewport) to turn it on.

Apply the material:
1 If the Layers toolbar isn’t visible, right-click the gray area to the right of
the main toolbar, and choose Layers to display this toolbar.
2 From the drop-down list of layers on the toolbar, choose Vine, and then

click

(Select Objects In Current Layer).

This selects the arbor trellis that can support a grapevine.
3 In the Slate Material Editor, click the Trellis material node to make it active,

then on the toolbar, click

(Assign Material To Selection).

You can’t see the texture in viewports yet, because the trellis is made of
editable meshes.
4 Right-click to display the quad menu, and choose Isolate Selection.
5 Click the Point Of View (POV) viewport label (it now shows
“Camera-Terrace”) and choose Perspective.

6 In the Perspective viewport, use
(Zoom),
(Pan), and
(Orbit) to adjust the viewport so it shows a closer view of the trellis.
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Map the trellis:
The trellis requires a mapping modifier, but UVW Map won’t work. If you
were to try (you don’t have to go through the steps), you could see that none
of the projection options work, because of the crosswise configuration of the
trellis beams.

Create a Material for the Trellis: Using MapScaler | 647

Trellis close-up: Poor mapping with UV Map

The solution is to use a Mapscaler modifier instead of UVW Map.

1 On the
Modify panel, choose Mapscaler from the Modifier List
drop-down list.
NOTE Be sure to choose “MapScaler” from the list, and not “MapScaler
(WSM)”. The world-space (WSM) version of MapScaler has a similar effect,
but is not quite the same.
The MapScaler modifier maintains the map scale relative to each object
(in this case, the cylindrical beams), and by default it wraps the texture
so the wood grain wraps around each beam.
2 On the Mapscaler Parameters rollout, change the Scale to 1.0m (meter).

648 | Chapter 5 Materials and Mapping Tutorials

This effect is already good, but the grain should actually follow each
beam. Adjusting the Mapscaler and map settings can fix this.
3 In the Slate Material Editor, double-click the Bitmap node so you can see
its parameters, then on the Coordinates rollout, change the W angle to
90.0 degrees.

Now the beams in the trellis look the way they should.
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The effect of the Mapscaler modifier shows up even better if you
render the close-up.
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4 On the Warning: Isolated Selection dialog, click Exit Isolation Mode.
5 If a Select Camera dialog appears, choose Camera-Terrace, and then click
OK; otherwise, click the Point Of View (POV) viewport label (it now shows
“Perspective”), and choose Cameras ➤ Camera-Terrace to restore the
long camera view.
6 In the Slate Material Editor, line the Trellis nodes up with the other
materials you’ve already created, then minimize the material node.
Save your work:
■

Save the scene as my_villa_trellis.max.

Next
Add Materials to the Chairs: Propagating Materials to Instanced Objects on
page 652
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Add Materials to the Chairs: Propagating Materials to
Instanced Objects
Many architectural models include instanced objects, such as furniture or
lighting fixtures. This lesson demonstrates a Material Editor option that
improves ease of use when you texture instanced objects.
Set up the lesson:

■

Open med_villa_mat_propagate.max.
This is the same scene you have been working on, but the Material Editor
option Propagate Materials To Instances has been turned off.

Unhide the lounge chairs:
1 If the Layers toolbar isn’t visible, right-click the gray area to the right of
the main toolbar, and choose Layers to display this toolbar.

2 Open the drop-down list of layers on the toolbar, and click
Hidden icon) by the Chairs layer to unhide the Chairs layer.

(the

Six lounge chairs are now visible on the terrace of the villa.
Apply the railings material to the chair piping:
The chairs are instances. They contain two elements: a yellow frame and a
red set of cushions (these colors are just 3ds Max Design object colors: the
chairs don’t have materials yet).
1 In the Camera-Terrace viewport, click to select the frame of the nearest
chair, Chair Struc02.

2 In the
Slate Material Editor, click the Blue Railings material node
to make it active (you might have to navigate in the active View so you

can see this node again), and then click
Selection).

(Assign Material To

The chair’s frame turns blue, but the other chairs are not affected.
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3 Press Ctrl+Z to undo the material assignment.
4 From the Slate Material Editor menu, choose Options ➤ Propagate
Materials To Instances.

5 Click

(Assign Material To Selection) once again.

This time, all the chair frames turn blue at once.
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If you work with instanced objects, you want to make sure that Propagate
Materials To Instances is turned on. (When it is on, there is a check mark
next to it on the menu.)
Create a material for the chair fabric:
1 Drag an Arch & Design material from the Browser into the active View,
and double-click the new material node so you can see its parameters.
Name this material Fabric.
2 On the Templates rollout, open the drop-down list of templates, and
choose Matte Finish.
3 Assign a Bitmap to the Diffuse Color Map component of the Fabric material
node.
3ds Max Design opens a file dialog. In the dialog, navigate to the
\sceneassets\images folder, choose the file fabric-stripes.jpg, then click
Open.
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Fabric pattern for the chairs

4 Click the new Bitmap node to make it active, then on the Slate Material

Editor toolbar, click

(Show Map In Viewport) to turn it on.

5 In the Camera-Terrace viewport, click to select the fabric of the nearest
chair, Chair Fab02.
6 In the Slate Material Editor, click the Fabric material node to make it

active, then on the toolbar click

(Assign Material To Selection).

All the chairs now have the fabric material applied.

7 On the
Modify panel, choose UVW Map from the Modifier List
drop-down list.
Turn off Real-World Map Size.
8 In the UVW Map modifier Parameters rollout ➤ Alignment group, choose
Y as the active axis.
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9 In the Slate Material Editor, double-click the Bitmap node so you can see
its parameters. On the Coordinates rollout, turn off Use Real-World scale,
then change the W angle to 90.0 (degrees).
Now the all the chairs are striped lengthwise.

Save your work:
■

Save the scene as my_villa_deck_furniture.max.

Summary
You can see a final version of the scene by opening med-villa-mat_done.max.
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A rendering of the villa after you have completed the tutorial

This tutorial has shown you how to:
■

Apply simple Autodesk Materials and adjust their settings

■

Apply a Multi/Sub-Object material and use its material IDs to apply
sub-materials to objects that have multiple material IDs

■

Add maps to Arch & Design materials

■

Use the UVW Map or MapScaler modifiers to set mapping coordinates for
objects that don’t have default coordinates

■

Use the Propagate Materials To Instances option when assigning materials
to instanced objects

The final rendering for this tutorial still lacks a little drama, but you will correct
that when you use this villa model again in some of the lessons on lighting,
which follow. Some of the rendering tutorials also use the villa model to
demonstrate how you can further enhance the realism of a scene.
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Composite Mapping
A composite map layers two or more texture maps onto one another, in order
to produce a more detailed image.
The end result is determined by the level of transparency defined for each
layer. Transparency can be global (applied to the entire surface of the layer),
derived from the layer’s alpha channel, or based on a mask. To fine-tune the
image, the pixels of each layer can also be blended with one another in a
number of different ways.
In this tutorial, you will create a complex texture map of a steel shutter for a
pawn shop. The map will consist of five layers of images composited together
using various transparency settings and blending techniques.

A render of the steel shutter composite map after completing this tutorial

In this tutorial, you will learn how to:
■

Create a composite layer
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■

Color correct a layer

■

Define layer transparency and contrast

■

Create a layer defined by a mask

■

Rearrange the order of layers

■

Blend layers

■

Add bump information to layers

Skill level: Intermediate
Time to complete: 45 minutes

Creating a Composite Map with Alpha Values
You will create the base layer of the composite map by choosing a bitmap of
a steel shutter, then assigning its diffuse, or color, values to an Arch & Design
material. You will then add two more image layers, using alpha values to
define how each are superimposed over the base layer.
Set up the lesson:

1 On the Quick Access toolbar, click
(Open File), navigate to
\scenes\materials_and_mapping\composite_mapping\ and open
composite_start.max.
NOTE If a dialog asks whether you want to use the scene’s Gamma And LUT
settings, accept the scene Gamma settings, and click OK. If a dialog asks
whether to use the scene’s units, accept the scene units, and click OK.
The scene consists of a pawnshop located in a rough part of town. The
storefront is missing one important element: a steel shutter that protects
a plate-glass window. Your task is to create a convincing composite map
of the shutter.
2 From the main menu, chose Customize ➤ Preferences ➤ General panel
➤ Texture Coordinates group and turn off Use Real-World Texture
Coordinates, if it is not already off. Click OK.
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Create a base layer and color correct it:

1 Open the

Slate Material Editor.

2 In the Material/Map Browser panel on the left, locate the Sample Slots
group.
The first sample slot contains an Arch & Design material called Shop-Door.
This material has already been applied to the roll-up shutter object
(door-sec).
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3 Drag the Shop-Door material from the Browser into the active View. In
the Copy/Instance map dialog, make sure Instance is chosen, then click
OK.

4 On the Slate Material Editor toolbar, click
(Show Map In Viewport)
so that later you will be able to view the Composite map in the viewports.
Now you will add a composite map to the material’s diffuse color
component.
5 Drag a Composite map from the Browser into the active View (in the
default groups, Composite is a Standard map), then wire the Composite
map node to the Diffuse Color component of the Shop-Door material.
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6 Double-click the Composite map node to see its parameters.
Initially, the Composite map contains a single layer.
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Specify the first layer of the Composite map:
1 Drag a Bitmap from the Browser into the active View.
3ds Max Design opens a file dialog.
On the file dialog, choose shutters.jpg, and then click Open.
2 Wire the new Bitmap node to the Layer 1 component of the Composite
map.
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On the Layers 1 rollout for the Composite map, the Texture button now
shows the shutters.jpg texture. This texture will be the base layer of the
Composite map.

3 Right-click the title bar of the Shop Door material node, and choose Open
Preview Window.

The preview helps you monitor the appearance of the map as you add
more layers and make further adjustments.
NOTE A preview window takes more time to render than the small preview
in the title bar of the material node.
4 Right-click the title bar of the Shop Door material node, and choose Preview
Object Type ➤ Box.
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3ds Max Design changes the sample sphere to a cube, which is a better
preview of the shutter geometry.
5 Drag a corner of the preview window to make it larger.
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6 Move this preview so you can see all of the Shop Door node and the
controls in the Parameter Editor.
Add a rust tone to the first layer:
The shutter door material is uniformly gray in color. Let’s add a little rust to
give the shutter a more run-down appearance.

1 On the Layer 1 rollout, click
(Color Correct This Texture). This
button is at the left of the rollout.
3ds Max Design displays Color-Correction controls in the Parameter
Editor, and it inserts a Color Correction map node between the Bitmap
and the Composite map.
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TIP In the active View, press L to rearrange the layout and see this node more
clearly. Use other navigation tools to move among nodes in the View.
2 On the Color rollout, click the Hue Tint color swatch.

3ds Max Design opens a Color Selector.
3 Enter the following values in the RGB fields:
■

R = 0.25

■

G = 0.15

■

B = 0.075

Click OK to close the Color Selector.
4 On the Color rollout, drag the Saturation slider to about 17.0, then in
the Strength field, enter 100.0.
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Now the Shop Door material shows a brownish tint.

Use alpha values to add a layer of graffiti:
Next, you will add a second layer to your composite map, one that contains
the bold strokes of a graffiti artist (or more than one).
1 Double-click the Composite map node to see its parameters again.
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2 At the top of the Composite Layers rollout, click
Layer).

(Add A New

3ds Max Design adds a new Layer rollout to the display of the Composite
map parameters.

Also, in the active View, the Composite map node now shows a new
Layer 2 component.

3 Drag a Bitmap from the Browser to the active View, just below the Bitmap
node for Layer 1.
3ds Max Design opens a file dialog.
On the file dialog, make sure Files Of Type is set to All Formats, choose
graffiti.png, and then click View.
3ds Max Design opens a file viewer that shows the graffiti.png texture.
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Graffiti bitmap used as the second layer in the composite map

In addition to red, green, and blue (RGB) information, the bitmap includes
alpha channel information in its .png file format. This channel provides
the level of opacity needed to superimpose the graffiti image over the
base image.

4 On the file viewer toolbar, click

(Display Alpha Channel).

The viewer displays a black-and-white version of the image, showing the
file’s alpha information.
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Alpha channel of the graffiti bitmap

Black regions of the bitmap will be completely transparent in the
composite map. White regions, representing the graffiti strokes, will be
completely opaque and fully visible in the composite map. Gray regions
will be semi-transparent and provide partial visibility, giving a blurred
edge to the graffiti.
NOTE Other bitmap formats that can contain alpha channel information
include .tif, .tga, and .exr.
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5

Close the graffiti.png viewer, then on the file dialog, click
Open.
3ds Max Design adds the Bitmap node to the active View.

6 Wire the new graffiti Bitmap to the Layer 2 component of the Composite
map.

The Layer 2 rollout now shows the graffiti.png texture, and the material
preview shows the composited graffiti.
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Composite map with the graffiti layer composited on the
shutter layer

Adjust the alpha and color levels:
If you look at the Shop Door material in a viewport (you will have to move or
minimize the Slate Material Editor), you can see that the default values for
compositing graffiti.png make the graffiti appear to float above the corrugated
texture of the door.
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You will fix this by adjusting some of the alpha settings for this layer.
1 On the Layer 2 rollout, change the value of Opacity 90.0, then press Enter.

This slightly increases the overall transparency of Layer 2, so that a small
portion of Layer 1 is visible beneath it. The result is a more convincing
blending of the graffiti onto the shutter surface.
The graffiti layer still needs to stand out a little more: you will use the
color correction tools to achieve this effect.
2 Drag a Color Correction map from the Browser to the active View, and
drop it on the wire between the Bitmap and the Composite map, when
the cursor shows you can insert a map.
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3ds Max Design inserts a Color Correction node between the graffiti
bitmap and the Composite map. This is another way to add a Color
Correction map.
3 Double-click the new Color Correction node so you can see its parameters.
4 On the Lightness rollout, drag the Brightness slider to the right until the
Brightness field shows a value of about 15.0.

The graffiti colors are now brighter. On the other hand, the change in
Brightness affects the semitransparent portion of the alpha channel as
well, creating a halo effect around the graffiti strokes, which we don’t
want.
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Halo surrounding graffiti
strokes

You will correct this problem by increasing the contrast level.
5 Drag the Contrast slider to the right until the box displays a value of
about 25.0.

Now the graffiti looks more like it is painted on the door.
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Use a mask to add a sticker:
Now you will add a third layer to your composite map, one that features a
sticker.
1 Double-click the Composite map node to see its parameters once more.

2 At the top of the Composite Layers rollout, click
Layer).

(Add A New

3ds Max Design adds a new Layer rollout to the Composite map
parameters, and a new Layer 3 component to the Composite map node
in the active View.
3 Drag a Bitmap from the Browser to the active View.
3ds Max Design opens a file dialog.
On the file dialog, choose c-sign.jpg, and then click Open.
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4 Wire the new Bitmap node to the Layer 3 component of the Composite
map.

3ds Max Design displays the new Bitmap on the Layer 3 rollout and in
the preview window.
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The c-sign bitmap applied as a top layer in the composite
map

Bitmaps saved in .jpg format have no alpha channel information. By
applying the c-sign.jpg image directly as a top layer, you have completely
obscured all layers beneath it. You can correct this by adding a mask.
(You could easily create your mask in a paint program, but a mask image
has already been prepared for you.)
5 Drag a another Bitmap from the Browser to the active View.
3ds Max Design opens a file dialog.
On the file dialog, choose c-sign-msk.jpg, and then click Open.
6 Wire the new mask Bitmap node to the Layer 3 (Mask) component of
the Composite map.
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The mask is a black-and-white image that acts as a “custom” alpha channel
to the color map.. Black areas of the mask allow the underlying layers to
show through, white areas are opaque, and gray areas are partially
transparent.

680 | Chapter 5 Materials and Mapping Tutorials

Bitmap used to create a cutout of the poster for layer 3

Now on the Layer 3 rollout, the texture with the sticker appears at the
left, and the mask bitmap appears at the right.

In the preview, the “CAUTION” sticker appears by itself, with the rest of
the door now visible.
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Layer 3 with the mask applied

One small problem remains. You want the graffiti to cover the sticker,
not the other way around.
7 Drag the label of the Layer 2 rollout to a point just above the new Layer
3 rollout. Release the mouse when 3ds Max Design displays a blue line
just above the Layer 3 rollout label.
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3ds Max Design reorders and renumbers the layers accordingly. (Layer 3
becomes Layer 2, and vice versa.)
Now the graffiti appears on top of the sticker about closure.
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NOTE In the active View, 3ds Max Design rewires the nodes to reflect the
change in the order of the layers, so you might want to press L in the active
View to update the layout of the nodes.

Save your work:
■

Save the scene as my_shop_door_3layers.max.

Blending Layers
In the previous lesson, you added layers to the Composite map while in Normal
mode. In this mode, no blending between layers takes place: Visibility is
determined solely by each layer’s alpha channel.
With the blending modes, you can produce interesting composite effects by
choosing how pixels in the top layer interact with those underneath. In this
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lesson, you will use two blending techniques to add more layers to the
composite map.
Set up the lesson:
■

Continue from the previous scene.

Add dirt to the bottom of the door with Multiply blending:
1 Double-click the Composite map node so you can see its parameters.

2 At the top of the Composite Layers rollout, click
Layer).

(Add A New

3 Drag a Bitmap node from the Browser to the active View.
3ds Max Design opens a file dialog.
On the file dialog, choose dirt-bottom.jpg, and then click Open.
This file shows dirt at the bottom of the door.
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Bitmap used in the first blend operation

4 Wire the new Bitmap node to the Layer 4 component of the Composite
map.
This file is a .jpg image that has no alpha channel. It completely obscures
all layers beneath it.
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5 On the Layer 4 rollout, open the Blending Mode drop-down list.

Blending Layers | 687

In addition to Normal mode, which we have been using so far, there are
a variety of other methods for blending layers.
6 Experiment with blending techniques by choosing a few options from
the list.
The options resemble those available in such paint programs as PhotoShop
and Combustion. Refer to the 3ds Max Design Help for a description of
what each blending option does.
7 Choose Multiply from the list.
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First blend operation using Multiply

This option multiplies the color value of all layers in the composite. The
non-white color channels have a value of less than 1.0, so the
multiplication tends to produce darker colors, a condition you will now
correct.
8 On the Layer 4 rollout, change the Opacity value to 80.0, and then press
Enter.

The reduced opacity of the top layer results in a lighter overlay of grime.
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Add dirt to the top of the door with Linear Burn blending:

1 At the top of the Composite Layers rollout, click
Layer).

(Add A New

2 Drag a Bitmap node from the Browser to the active View.
3ds Max Design opens a file dialog.
On the file dialog, choose dirt-top.jpg, and then click Open.
This file shows dirt at the top of the door.
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Bitmap used in the second blend operation

3 Wire the new Bitmap node to the Layer 5 component of the Composite
map.
This file is also a .jpg image that completely obscures all layers beneath
it.
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4 On the Layer 5 rollout, choose Linear Burn from the Blending Mode
drop-down list.
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Linear Burn blending combines the new dirt map with underlying layers.
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Second blend operation using Linear Burn

Linear Burn combines the color of pixels in the top layer with colors from
the underlying layers. The darker the Layer 5 color, the greater the effect:
As a result, the default blending is too dark.
5 On the Layer 5 rollout, change the Opacity value to 70.0, and then press
Enter.

Now the dirt at the top of the door, like the dirt at the bottom, blends
well with the other textures.
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Add bump information to the composite:
1 Minimize the Slate Material Editor.

2 Activate the Camera01 view, then on the main toolbar, click
(Render Production).
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The shutter shows good detail, but in a rendering with shadows, its
corrugated surface lacks depth. You will correct this by adding bump
information from the shutters.jpg map.

3 On the rendered frame window, click
Window).

(Clone Rendered Frame

4 Restore the Slate Material Editor (press M).

5 In the Slate Material Editor, click
(Zoom Extents) to display the
entire material tree, and press L to arrange the layout.

696 | Chapter 5 Materials and Mapping Tutorials

6 Wire the original Bitmap node, the one that contains shutters.jpg (it is at
the upper left), to the Bump Map component of the Shop Door material
node.
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7 Double-click the Shop Door material node so you can see its parameters.
8 Expand the Special Purpose Maps rollout. The buttom for Bump mapping
should show that shutters.jpg has been assigned. Change the amount
value (the numeric field just to the right of the Bump toggle) to 3.0.

The effect in the preview is rather exaggerated.
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9

Render the Camera01 viewport again and compare the result
with the cloned rendered frame.
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The fully composited shutter door, rendered with bump mapping

The shutter has lost its flat look and appears more three dimensional.
Save your work:
1 Save the scene as my_pawnshop_composite.max.

If you like, you can
open composite_completed.max and compare
your work with a completed scene file of this tutorial.
2 If you turned off the Use Real-World Texture Coordinates option at the
beginning of this tutorial, then from the main menu, go to the Customize
➤ Preferences ➤ General panel ➤ Texture Coordinates group and
turn the option back on.
Save your work:
■

Save the scene as my_shop_door_completed.max.
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Summary
In this tutorial, you learned how to create a composite map consisting of
multiple layers of images. You used alpha channel information and a mask
to control image transparency, then you used blending modes as an alternate
way to specify how layers are composited.

Spline Mapping
This tutorial shows you how to map a material to a curved surface, such as a
road or a garden hose.
You will start with the same pawnshop model featured in the Composite Map
tutorial, and use a spline to map a brick-like material onto the building’s
arched entrance.

In this tutorial, you will learn how to:
■

Choose a mapping method for an object

■

Create a spline and use it as a guide when mapping a texture to the object

■

Adjust the mapping through manipulation of the object’s UVW coordinates
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Skill level: Intermediate
Time to complete: 1 hour

Prepare the Scene
In this lesson, you choose a brick material to map to the building arch, and
specify the Unwrap UVW modifier as the mapping method. Then you create
a spline object and use it as a guide to the mapping process.
Set up the lesson:

On the Quick Access toolbar, click
(Open File), navigate to
\scenes\materials_and_mapping\spline_mapping\ and open
splinemap_start.max.

■

NOTE If a dialog asks whether you want to use the scene’s Gamma And LUT
settings, accept the scene Gamma settings, and click OK. If a dialog asks
whether to use the scene’s units, accept the scene units, and click OK.

Choose the material and apply the mapping method:

1

Maximize the Orthographic viewport and
Arch-Door object.
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select the

Arch door object with no material applied

2 Open the

Slate Material Editor. Locate the Sample Slots group.

A material called brick-soldier has already been prepared for the arch object.
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3 Drag the brick-soldier material from the Browser ➤ Sample Slots group
into the active View. In the Instance (Copy) Material dialog, make sure
Instance is chosen, and then click OK.

4 In the active View, make sure the brick-soldier node is selected, then on

the Slate Material Editor toolbar, click

Selection). Also click to turn on

(Assign Material To

(Show Map In Viewport).

The arch turns a dark gray. It shows no further detail because no mapping
coordinates have yet been specified for the Arch-Door object.
5

Close the Slate Material Editor.

Assign mapping coordinates (a first approximation):
The common way to assign mapping coordinates is to use a UVW Map
modifier, but if you look at the various options this modifier has for orienting
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a map (Planar, Cylindrical, Spherical, Shrink Wrap, Box, Face, and XYZ To
UVW), you can see that none of them corresponds to the curved shape of the
arch.

1 Go to the
UVW.

Modify panel. From the Modifier List, choose Unwrap

Unwrap UVW is often used to map images onto complex objects. Unwrap
UVW is better equipped to handle mapping of complex geometry, because
it breaks that geometry into sections, and applies planar mapping to each
section.
2 Right-click the arch object in the viewport and from the quad menu,
choose Hide Unselected to isolate the object.
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Arch object with brick material mapped to its surface

3 On the modifier stack, click the plus-sign icon (+) next to the Unwrap
UVW modifier to expand its hierarchy, then click to go to the Face
sub-object level.
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At this level, you can map the brick material onto each selected face of
an object.

4 In the viewport,

select a face on the arch object.

A yellow gizmo displays, representing a planar projection of brick material
onto the selected face.
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Planar projection of brick material onto an arch face

5

Select another face on the arch object.
Notice how the yellow gizmo resets onto the newly selected face.
On the Map Parameters rollout, there are a number of controls available
that can help you use Unwrap UVW to map specific types of objects.
Some of these are similar to the UVW Map options. The Cylinder button,
for example, displays controls used to map materials onto cylindrical
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objects, such as a human arm or a lamp post. Others have more special
purposes: You can use the Pelt button to map a material onto fabric such
as a pair of trousers, or a curtain.
In this scene, you will use the Spline option, which is useful for mapping
curved objects with a cylindrical or square cross-section such as a snake,
or a ventilation duct.
Before you use this option, you will create the spline object itself.
Create the spline shape to use as a map path:
1 On the modifier stack, click Face to exit the Face sub-object level.
The spline you create needs to be centered in the arch object. You could
use the Line tool or the Rectangle tool to draw the spline, but you would
need to enter the precise arch object coordinate values to do so. A more
convenient alternative is to derive the spline from the existing object
geometry.
2 On the stack, click the Editable Poly entry. Click Yes to dismiss the
warning message that 3ds Max Design displays.

3 On the Selection rollout, click
level.

4

(Edge) to go to the Edge sub-object

Click and Ctrl+click to select all the outer edges of the arch
object.
Be sure to leave the bottom and inside edges unselected.
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Arch object with all outer edges selected

5 On the Edit Edges rollout, click Create Shape From Selection.
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6 On the Create Shape dialog ➤ Curve Name box, name the shape
Arch-Door-Spline, make sure Shape Type is set to Smooth, then click OK.

7 Click
(Edge) again to exit the Edge sub-object level, then press H
to open the Select From Scene dialog.
8 Choose Arch-Door-Spline from the list to select the newly created spline.
Click OK.
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9 Press F3 to switch to wireframe mode.
10 From the Modifier List, expand the Editable Spline modifier, then and
click Spline.

11 On the Geometry rollout, scroll down so you can see the Outline button,
and then click it.
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12 In the viewport, click the original spline and drag inward so the outline
spline is positioned roughly at the midpoint between the outer and inner
edges of the front face of the arch.
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Outline spline centered on the front face of the arch object

The outline spline position does not have to be perfectly centered: You
will align it more precisely in a moment.
13 On the modifier stack, click Segment.
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14

Click and Ctrl+click to select the line segments at the base of
the arch (they connect the original spline to the outline spline), then
press Delete.
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Spline segments at the base of each arch column

15 On the modifier stack, click Spline again, select the outer, original spline,
then press Delete.
16 On the modifier stack, click Spline again to exit the Spline sub-object
level.
Align the spline with the arch:
1 On the main toolbar, choose the Local coordinate system.
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2 Make sure the spline is selected, then on the main toolbar click
(Align), and then click the Arch-Door object.
3 In the Align Selection dialog ➤ Align Position (Local) group, turn off X
Position and Y Position, turn on Z Position, and in both the Current
Object and Target Object subgroups, choose Center. Click OK.

The spline is now properly placed in the center of the Arch-Door object,
ready to be used as a guide to map the brick material.
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Apply the spline as a guide for the mapping:
1 Press F3 to return to a shaded view.

2

Select the Arch-Door object.

3 On the modifier stack, in the Unwrap UVW modifier hierarchy, click
Face to go to the Face sub-object level.
4 On the Selection Parameters rollout, turn off Ignore Backfacing.

If you leave Ignore Backfacing turned on, only the polygons facing you
in the viewport will be included in a selection. Polygons hidden on the
other side of the model will remain unselected.
5 Starting just above the base column to the left, click and drag diagonally
upward across the arch object to region-select all the faces except for
those on the underside of each column base.
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Arch faces selected

6 On the Modify panel, scroll down to the Map Parameters rollout and
click Spline.
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7 On the Spline Map Parameters dialog, click Pick Spline.
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For now, leave the Spline Map Parameters dialog open.
8 Press H and on the Pick Object dialog, choose Arch-Door-Spline from the
list, then click Pick.
The arch object is enveloped by a cage gizmo, which shows the outline
and cross sections of the mapping.

Arch object enveloped by the cage gizmo

Now you need to correct the base of the cage gizmo, which is too narrow for
the arch geometry.
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Adjust the mapping gizmo:

1

Orbit the viewport until you can see the two unselected faces at
the base of the arch.

Bottom of arch, showing that the cage gizmo is too narrow

2 On the main toolbar, click
(Select And Uniform Scale), For each
base of the arch, click to select the base of the gizmo, then drag the Scale
gizmo along its Y axis until the cage is at least as wide as each face at the
base of the arch.
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Cage gizmo after resizing each base

You do not need to be precise at this point: In the next lesson, you will
specify the cage more precisely by using the Unwrap UVW controls.
3 On the Spline Map Parameters dialog, click Commit to accept the changes
made to the spline mapping so far.
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Save your work:
■

Save the scene as my_arch_spline_mapping.max.

Fine-Tune the Mapping
With the introduction of the spline as a guide, now the brick material can
properly follow the contours of the arch object. However, in the present state
of mapping, the bricks are too large and they are mapped vertically up the
arch columns instead of horizontally across them. In this lesson, you use the
Edit UVWs dialog to adjust the mapping visually so that the bricks map
properly.
Set up the lesson:
■

Continue from the previous lesson.
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Set up the Edit UVWs dialog, and inspect the brick map:
1 On the Parameters rollout, click Edit.
3ds Max Design opens the Edit UVWs dialog.

Arch object displayed as grid of UVW faces and vertices

The window in the Edit UVWs dialog shows a flattened representation
of the arch object. There are four red vertical panels made up of UVW
faces and vertices. The panels represent the inner, outer, left, and right
face of the arch.
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2 Move the Edit UVWs window so you can see the arch object in the
Orthogonal and Perspective viewports. If you need to, adjust the size of
the Edit UVWs dialog so you can see all of the arch faces. Use the Edit

UVWs window

zoom tool to zoom out slightly.

The surface of the arch object is currently mapped to a single tile of the
brick-soldier material.
The square occupied by the flattened arch object corresponds to the dark
square in the next diagram, which shows the coordinate system of the
Edit UVWs window.

The texture you apply to the arch object will be mapped to this area,
whose coordinate system ranges from 0, 0 to 1, 1.
3 On the main menu, choose Rendering ➤ View Image File, and on the
View File dialog, navigate to the folder \sceneassets\images\, click to
highlight brick_soldier-diff.jpg and click Open.
3ds Max Design opens an image file viewer, showing that
brick-soldier-diff.jpg is a square image. At present, it is mapped on a
one-to-one basis using UVW coordinates that range from 0 to 1. Outside
of the square bounded by the 0 to 1 values, the same image is tiled two
more times in each direction.
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4

Close the image file viewer.

5 In the Edit UVWs window, open the texture drop-down list at the right
of the toolbar, and choose the entry for “(brick_soldier-diff.jpg)” to display
the map itself in the window.

6 In the Selection Modes group at the lower right of the Edit UVWs dialog,
click Options.

3ds Max Design opens a further Bitmap Options group that appears below
the Soft Selection group.
7 In the Bitmap Options group, change the value of Brightness to 0.75,
then press Enter .

The bitmap in the Edit UVWs window becomes brighter and easier to
see.
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Correct vertical distortion:

1 In the Selection Modes group, click

(Vertex Sub-Object Mode).

By switching to the Vertex sub-object mode, you can see how the Unwrap
UVW modifier has slightly warped the contours of the arch object. You
need to straighten out these contours.
NOTE The contours in your unwrapped arch object might be slightly different
to the one shown in the next illustration, depending on how you resized the
cage gizmo in the previous lesson.
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Warped contours of the unwrapped arch object

2 On the Unwrap UVWs toolbar, click
all the vertices of the left outside edge.

(Move), and region-select
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UVW vertices of left outside edge selected

For these vertices to be properly aligned with the image map, they must
all have the same U value of zero.
3 In the U coordinate field (on the toolbar at the lower left of the main
dialog), type 0.0, then press Enter.

This gives the the horizontal map coordinate for each selected vertex a
U value of 0, thereby aligning all the vertices vertically at their origin (0)
as shown in the next diagram.
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4 Region-select all the vertices at the right outside edge of the arch object.
5 In the U coordinate field, type 1.0, then press Enter.
This aligns each selected vertex vertically at a horizontal value of 1.
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6 Select in turn, from left to right, the remaining columns of vertices for
each inside edge. Give each inner edge a U value of 0.25, 0.5, and 0.75
respectively.
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UVW vertices after alignment

The UVW map now covers the surface of the arch object much better.
But as you can see in the window, there remains an obvious problem.
The bricks are mapped vertically, whereas they need to be mapped
horizontally. To make this change, you need to rotate the mapping by
90 degrees.
Correct the orientation of the bricks:
1 Press Ctrl+A to select all the vertices.

2 On the Edit UVWs toolbar, click

(Freeform Mode).
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3 Position your cursor over a vertex at the midpoint of any side, and drag
the whole UVW grid until the rotation indicator displays 90.

UVW grid after rotation

Now the bricks on the arch are oriented horizontally. Notice, however,
that the bricks are still too large for the area they cover.
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Arch object with bricks oriented horizontally

You need to resize the UVW grid over the map so that the bricks are better
distributed.
Align the edges of the bricks and the arch:
Specifically, the current vertical scaling of the bricks means that the edges of
bricks are not aligned with the edges of the arch: The UVW grid spans five
bricks, when it should span only four.
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Edges of bricks not aligned with the vertical edges
of the arch

➤

Hold down the Shift key to constrain scaling to a single axis, then click
on the left or right corner of the UVW grid and drag down until the grid
is resized vertically (along the V axis) to fit over four rows of bricks.
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UVW grid resized vertically to cover four rows of bricks, one row per face

Now the edges of the bricks and the edges of the arch line up.
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Along the U axis, the bricks are still too large.
Increase the number of bricks along the length of the arch:

1 In the Edit UVWs window,
zoom out and
see all of the brick-soldier-diff.jpg image.

pan so you can

2 In the Bitmap Options group, change the value of Tiles to 2.
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Now the brick-soldier-diff.jpg is tiled twice in each direction.
NOTE The Tiling value affects the display of the map in the Edit UVWs
window. It does not affect the mapping of the object, which is managed by
the Bitmap controls. When Tiling=0, the map appears only in the unit square;
when Tiling=1 (the default), the map is tiled 3 times in both U and V; when
Tiling=2 (as you just set it), the map is tiled 5 times in both U and V.

3

Zoom out and
brick-soldier-diff.jpg tiles.

pan again so you can see all of the
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Two image tiles surround the UVW grid in every direction

4

Region zoom in again so you can clearly see the UVW grid and
the right edge of the bricks map.
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5 On the Edit UVWs dialog main toolbar, turn on
(Freeform Mode).
Make sure all the vertices are still selected, then Shift+drag the top-right
corner vertex all the way to the right-most edge of the map.
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Shift+drag the top right corner of the UVW grid to resize it horizontally

Because the UVW guides have been stretched horizontally to cover three
map tiles (from 0 to 3 along the U axis), now three times as many bricks
are mapped along the length of the arch.
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Correct the bulging appearance of bricks at the top of the arch:
If you look closely at the top of the arch, you can see that the bricks appear
to bulge out.
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Bricks in arch show deformation

This deformation is because the number of divisions in the arch object’s
polygon mesh does not match the number of bricks mapped onto them.

1 On the Edit UVWs dialog, click

(Zoom Extents) to zoom in to the

UVW guides, then
select only those vertices in the center that
correspond to the top of the arch.

UVW grid with arch vertices selected

There are 14 divisions in the polygon mesh that define the arch, but there
are 16 bricks in the underlying map. You need to resize the UVW guides
so that the mesh divisions match the number of bricks in the map.
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2 With the
Freeform tool still active, Shift+drag the top-left corner
vertex of the selection to the right by one brick.
3 Shift+drag the top-right corner vertex of the selection to the left by one
brick.

The number of arch polygons now matches the number of bricks in the map.

Bricks at the top of the arch no longer appear to bulge.

Correct the scaling of bricks in the column:
If you look at the whole archway, you can see that the fix you just made to
the top of the arch, makes the bricks at the top appear larger than the bricks
in the two columns.
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Arch bricks are larger than the column bricks.

1 In the Edit UVWs window,
select only the vertices that correspond
to the left-hand column of the arch (which is on the right in the Edit
UVWs window and the viewport).
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Left column vertices

2 Shift+drag the top-right corner vertex of the selection to the left by two
bricks.

Left column after being resized two bricks to the left

3 Repeat the previous two steps for the arch object’s right-hand column,
dragging the UVW guides to the right by two bricks.
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All bricks mapped to the arch object, both on the columns and the arch,
now appear to be equal in size. The result is a properly mapped archway,
with the bitmap convincingly following the contours of the object’s
geometry.
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Arch object with bricks of equal size

Render the arch:
1

2

Close the Edit UVWs dialog and on the modifier stack, click
Vertex to exit the Vertex sub-object level, then click any empty part of
the viewport to deselect the arch.

Minimize the Orthographic viewport.
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3 Right-click the Camera01 viewport and from the quad menu, choose
Unhide All.

4 On the main toolbar, click
work.

(Render Production) to render your

Rendered view of brick material mapped to the pawnshop entrance

Now your brick material is mapped to the archway properly.
Save your work:
■

Save the scene as my_arch_spline_mapping_completed.max.

Summary
In this tutorial, you learned how to use the Unwrap UVW modifier combined
with a spline object to map a material onto a curved object. You also learned
how to manipulate the object’s UVW lattice in the Edit UVWs dialog to specify
how the material’s bitmap image is projected onto the target surface.

750 | Chapter 5 Materials and Mapping Tutorials

Using the Multi/Sub-Map
You can apply multiple Multi/Sub-Maps to objects in a scene whenever you
need to give similar objects in a group their own unique identity.
In this tutorial, you will assign an assembly of stadium seats a common
material, then use a variety of Multi/Sub-Maps to assign each seat its own set
of stains and discolorations.

You can distribute Multi/Sub-Maps among objects randomly, by object, or by
material ID. Each sub-map can be based on a color, a bump map, or an image,
among other components. You can distribute sub-maps individually, or
composited with other maps to produce a more nuanced effect.
Multiple sub-mapping differs from mapping at a sub-object level, where you
apply a material on a one a one-to-one basis to individual components of a
single object.
The next illustration provides an example of sub-object mapping where five
materials have been mapped to a door consisting of five sub-objects. In this
technique, you select the polygon of each component, assign it a material ID,
and apply a unique material to each ID.
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The next illustration provides an example of multi/sub-mapping where
multiple sub-maps have been applied to a material. The jeep surfaces are a
composite of two layers: a layer of army green material and a layer of three
sub-maps. Each sub-map is a bitmap image of a serial number, and is assigned
to a jeep according to the vehicle’s object ID number.
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You can use any map channel in a sub-map. The next illustration shows three
objects whose materials share the same diffuse color and specular highlights,
but a sub-map with a slight variation of the bump channel has been assigned
to each material to give each urn a unique surface texture.
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In this tutorial, you will learn how to:
■

Assign ID numbers to objects in a scene

■

Create sub-maps based on multiple diffuse values

■

Create sub-maps based on multiple bitmap images

■

Create a material from two composited layers of sub-maps

NOTE In this tutorial, you will be creating composite maps. If you are not familiar
with this technique, it is recommended that you complete the Composite Mapping
tutorial on page 658 first.
Skill level: Intermediate
Time to complete: 30 minutes
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Create the Multi/Sub-Map Material
In this lesson, your objective is to divide the seating in the stadium scene into
four distinct groups, and use multi/sub-mapping to assign each group its own
color, with red representing the most expensive seats and green the cheapest.
Set up the lesson:

On the Quick Access toolbar, click
(Open File), navigate to
\scenes\materials_and_mapping\multi_maps\ and open multi_maps_start.max.

■

NOTE If a dialog asks whether you want to use the scene’s Gamma And LUT
settings, accept the scene Gamma settings, and click OK. If a dialog asks
whether to use the scene’s units, accept the scene units, and click OK. If a
Missing External Files dialog opens, click Continue.

Choose mental ray and group objects by ID number:

1 On the main toolbar, click

(Render Setup).

2 On the Render Setup dialog ➤ Common tab ➤ Assign Renderer rollout,
make sure the Production field is set to mental ray Renderer.

The Multi/Sub-Map is a mental ray feature. It is available only when you
choose mental ray or the Quicksilver Hardware renderer as your renderer.
3

Close the Render Setup dialog.
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4 Right-click an empty area of the main toolbar and from the pop-up menu,
choose Layers.

3ds Max Design opens the Layers toolbar.

5 On the Layers toolbar, open the layers list and click to hide all layers
except Seats.
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Now only the seats objects are visible, making their selection much easier.

6 Close the Layers toolbar and

7

maximize the Top viewport.

Select any seat object, right-click and from the quad menu,
choose Object Properties.
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Notice that in the Object Properties dialog ➤ General tab ➤ G-Buffer
group, the Object ID displays as 0. All objects when they are first created
are assigned an ID of 0. Later on, you will change this number in order
to assign certain groups of seat objects their own material variations.
8 Click Cancel to close the dialog, then on the main toolbar, choose the
Lasso tool from the Select Object flyout.

9 Use the Lasso tool to select the seats shown in white in the next
illustration.
Be sure to hold down the Ctrl key when you select additional seats.
TIP If you select unwanted seats, use the Alt key to deselect them.

Create the Multi/Sub-Map Material | 759

10 Right-click, choose Object Properties from the quad menu, and in the
Object Properties dialog ➤ General tab ➤ G-Buffer group, change the
Object ID to 1. Click OK.
11 Use the Lasso tool to select the seats shown in the next illustration.
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Be sure to hold down the Ctrl key when you select additional seats.
12 Right-click, choose Object Properties from the quad menu, and in the
Object Properties dialog ➤ General tab ➤ G-Buffer group, change the
Object ID to 2. Click OK.
13 Select the seats shown in the next illustration.
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14 Right-click , choose Object Properties, and in the Object Properties dialog
➤ General tab ➤ G-Buffer group, change the Object ID to 3. Click OK.
15 Select the seats shown in the next illustration, and give them an object
ID of 4.
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Now all the stadium seats have an object ID of 1, 2, 3, or 4. With this in
place, each seat is ready to receive its own material variation and
sub-object maps.
Create a material for the seats:
1 Continue from the previous procedure, or open the file
multi_maps_01.max.
2 Press M to open the Slate Material Editor.
TIP If the Compact Material Editor opens instead, then on the Material Editor
menu bar, choose Modes ➤ Slate Material Editor.
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3 From the Material/Map Browser panel on the left, drag an Arch & Design
material into the active View (View1), the empty area in the center of the
Slate Material Editor window.
In the Browser, the Arch & Design material is in the Materials ➤ mental
ray group.
A node for the Arch & Design material appears in the active View.
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4 Double-click the Arch & Design material node to display its parameters
in the Parameter Editor panel on the right.
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5 Change the name of the material to seats.

6 On the Templates rollout, open the drop-down list and choose Matte
Finish.

7 In the Top viewport,

select all the seats, then on the Slate

Material Editor toolbar, click

(Assign Material To Selection).

The matte-finish seats material is assigned to all the seats.
Now you will add multiple sub-object maps to the seat material’s diffuse
color channel.
Define a multi/sub map for the seats:
1 On the Slate Material Editor, drag a Multi/Sub-Map from the Material/Map
Browser panel to the active View.
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You can find the Multi/Sub-Map entry in the Maps ➤ mental ray group.
A node for the Multi/Sub map appears in the active View.

2 Drag from the output socket of the Multi/Sub-Map node (the round
control at the right of the node). 3ds Max Design creates a wire. Drop
the end of the wire on the input socket for the Diffuse Color Map
component of the seats material node.
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3 Double-click the Multi/Sub map node to display its parameters.
4 On the Multi/Sub-Map Parameters rollout, set the Number Of Colors/Maps
To Use to 4.
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By default, Switch Color/Map Based On is set to Object ID, meaning that
the sub-maps will be distributed among the objects by their ID number.
You have already set up the object IDs.
The Default/Out-Of-Range Color is set to red. This means the material of
any object in the scene with an ID other than 1 to 4 will display in red.
Red is one of the seat colors we are using, so click this color swatch and
use the Color Selector to change this color to a neutral gray.
NOTE If you were to turn on the Repeat option, all objects with IDs higher
than 4 would display the color sequence assigned to objects with IDs 1 to 4.
5 Click the color swatch labeled Color/Map #1.

Create the Multi/Sub-Map Material | 769

6 On the Color Selector, change the color to a bright red: Red = 0.8, Green
= 0.0, Blue = 0.0, then click OK.
7 Click the color swatch labeled Color #2 and change the color to a blue:
Red = 0.275, Green = 0.534, Blue = 0.814, then click OK.
8 Click the color swatch labeled Color #3 and change the color to a yellow:
Red = 0.867, Green = 0.808, Blue = 0.231, then click OK.
9 Click the color swatch labeled Color #4 and change the color to a green:
Red = 0.158, Green = 0.583, Blue = 0.141, then click OK.
These colors will not show up in the viewports, but they will be visible
when you render the image.
10 Make sure the Top viewport is active, then on the main toolbar, click

(Render Production) to render the scene. Keep the rendered
frame window open.
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The rendered image shows seats with their sub-map material clearly
visible. Seats with an object ID of 1 show the red sub-map applied, seats
with an object ID of 2 show the blue sub-map applied, and so on.
11 Activate the Camera-Seats viewport.
12 In the rendered frame window’s Viewport list, make sure Camera-Seats
is chosen, then click Render to render the scene again.
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13

Close the rendered frame window.

Save your work:
■

Save the scene as my_stadium_submaps.max.

Next
Composite Sub-Maps Onto Objects on page 772

Composite Sub-Maps Onto Objects
The seats you mapped in the previous lesson appear too uniform: They lack
individual signs of wear and tear. Now you will introduce another level of
randomness to the seat material by adding sub-maps that contain blemishes
and other discolorations.
To accomplish this, you will composite two layers of sub-maps onto one
another. One layer will contain the four diffuse colors you specified in the
previous lesson, the other layer will contain sub-maps with a mixture of image
maps of dirt patterns.
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Set up the lesson:

■

Continue from the previous lesson, or

open multi_maps_02.max.

Create the composite layers:
1 If the Material Editor is not already open, press M to open it.

2 In the Slate Material Editor active View, click
(Zoom Extents) so
you can see both the material node and the Multi/Sub map node.
3 Drag a Composite map (Maps ➤ Standard ➤ Composite) from the
Browser. In the active View, drop the map on the wire that connects the
Multi/Sub map and the seats material.
3ds Max Design displays a cursor that indicates you are inserting the map
into the wire. Release the mouse when this cursor appears.
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4 After you release the mouse, 3ds Max Design displays a pop-up menu.
On the pop-up menu, click Layer 1.
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This incorporates the Multi/Sub map as the base layer of the composite.
5 On the Slate Material Editor, press L to arrange the layout of the material
tree.
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Add a Multi/Sub map to Layer 2:
1 Double-click the Composite map node to display its parameters.
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2 On the Composite Layers rollout, click

(Add A New Layer).

3 Drag a second Multi/Sub-Map (Maps ➤ mental ray ➤ Multi/Sub-Map)
from the Browser into the active View, then wire the new Multi/Sub map
to the Layer 2 component of the Composite map.
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TIP Pressing L again can help you see all the nodes. So can the other Slate
Material Editor navigation tools. After you’ve used a navigation tool such as
Zoom or Pan, right-click an empty area of the active View so you can select
material and map nodes once again.
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4 Double-click the new Multi/Sub map node to display its parameters.
5 On the Multi/Sub-Map Parameters rollout, set Number Of Colors/Maps
To Use to 6.
This time, rather than change colors, you will add six bitmap images to
the sub-map.
Add the first dirt bitmap to the Multi/Sub map:
1 Drag a Bitmap from the Browser into the active View.
3ds Max Design opens a file dialog.
2 On the Select Bitmap Image File dialog, highlight dirt1.jpg and turn off
Sequence (otherwise, 3ds Max Design opens all the dirt files as an
animated sequence!). Click Open.
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The thumbnail at the bottom right of the dialog gives you an idea of
what the dirt1.jpg image looks like.
3 Wire the new Bitmap node to the Color/Map #1 component of the new
Multi/Sub map.

4 Double-click the new Bitmap node so you can see its parameters.
5 On the Coordinates rollout, make sure Use Real-World Scale is turned
off.
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Add the other bitmaps to the Multi/Sub map:
➤

Repeat the previous procedure for the remaining bitmaps, dirt2.jpg through
dirt6.jpg. Wire the Bitmap node for dirt2.jpg to the Color/Map #2
component, dirt3.jpg to the Color/Map #3 component, and so on.
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All six bitmaps wired to the second Multi/Sub map

Define how the two layers composite together:
1 Double-click the Composite map node to see its parameters.

The Operations drop-down list for each layer is set to Normal, which
means that the layer with the highest number obscures all layers beneath
it. You need to add an operation that will blend the layers together.
2 On the Layer 2 rollout, click to open the Operations drop-down list, and
choose Multiply.
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Now the Composite map combines the color and dirt map layers.
3 Make sure the Camera-Seats viewport is active, then press F9 to render
the scene (leave the rendered frame window open).

Notice how each group of seats shows the same dirt map. The dirt1.jpg
map is applied to all objects in the scene with an ID of 1. The dirt2.jpg
map is applied to all objects in the scene with an ID of 2, and so on. You
now need to distribute a random mix of all six dirt maps for all seats
groups in the stadium.
Define the sub-map distribution method and fine tune the composite image:
1 Double-click the Multi/Sub map node that contains the dirt bitmaps, so
you can see its parameters. On the Multi/Sub-Map Parameters rollout,
open the Switch Color/Map Based On drop-down list, and choose
Random.
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2 Click Render to render the scene again (still leaving the rendered frame
window open).

Now, all six dirt maps appear at random for all seats groups in the
stadium. The dirt patterns, however, stand out too clearly.
3 Double-click the Composite map node to see its parameters.
4 On the Layer 2 rollout, change the Opacity setting to 35.0.

The dirt layer is reduced in visibility to 35 percent of its full opacity.
5 Click Render to render the scene once more.
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The dirt maps appear more faded, giving the seats a subtle variation that
appear more realistic.
Save your work:
1 Save the scene as my_stadium_submaps_completed.max.
2 If you wish, open the file multi-maps_completed.max and render the
Camera-Seats viewport to see a finished version of the stadium scene.
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Summary
In this tutorial, you learned how to give similar objects individual character
by adding sub-maps to their base material.
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Lighting Tutorials

6

The tutorials in this section show you how to set the mood and create dramatic lighting effects
for scenes built in 3ds Max Design.
There is also a tutorial on how to analyze the lighting of a model by using the Lighting Analysis
Assistant.

A nighttime scene with artificial lighting

Features Covered in This Section
■

Creation of a Daylight system to illuminate a scene with geographic accuracy.

■

Daylight illumination of building interiors using the Sky Portal.

787

■

Exposure control.

■

Shadow creation and definition.

■

Nighttime illumination using adjustable photometric lights.

■

How to use the Lighting Analysis Assistant.

Lighting and Rendering the Villa in Daylight
In this tutorial, the scene of the Mediterranean villa requires lighting
conditions for early, mid, and late-day illumination.
To accomplish this task, you will create a Daylight system and customize it
to match a specific location and time. Then you’ll set proper exposure and
combine the Daylight system with Sky Portal objects that channel light into
the interior of the villa. You will fine-tune the late-day illumination by
adjusting the aperture setting.

After completing this tutorial, you will see how easy it is to use mental ray
lighting options to create realistic daytime lighting conditions.
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In this tutorial, you will learn how to:
■

Use a Daylight system to illuminate a scene based on its geographic
location, orientation, and time of day.

■

Use Sky Portal objects to gather skylight and cast it into the interior of
buildings.

■

Adjust exposure to suit different times of the day.

Skill level: Intermediate
Time to complete: 1 hour

Adding Daylight Illumination
You will begin by looking at how the scene appears without any light objects.
You’ll then add daylight to the scene.
Set up the lesson:

■

On the Quick Access toolbar, click
(Open File), navigate to the
\scenes\lighting_and_rendering\med_villa folder, then open
med_villa_lighting_start.max.
NOTE If a dialog asks whether you want to use the scene’s Gamma And LUT
settings, accept the scene Gamma settings, and click OK. If a dialog asks
whether to use the scene’s units, accept the scene units, and click OK.

Set up exposure control:
1 From the main menu, choose Rendering ➤ Exposure Control.
3ds Max Design opens an Environment And Effects dialog.
2 On the Exposure Control rollout, if the active exposure control is set to
“mr Photographic Exposure Control” (mr is short for mental ray), then
open the drop-down list and choose <no exposure control>.
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3 Make sure the Camera-Terrace viewport is active, then
the scene.

render

TIP You can press F9 as a shortcut for clicking Render Production.
With the exposure settings removed, you can now see the scene in a very
basic way through default lighting.
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The rendering appears flat and not very realistic. You need to add either
man-made light sources or daylight to properly illuminate the scene. In
this tutorial, you will create daylight by generating two mental ray
photometric light sources:
■

mr Sun, which simulates direct light from the sun.

■

mr Sky, which simulates indirect light created by the scattering of
sunlight in the atmosphere.

These two light sources will be accompanied by the “mr Physical Sky”
environment shader, which establishes the physical representation of
the sun and sky.
Create the Daylight system:
1

Close the Rendered Frame Window and the Environment And
Effects dialog.

2 On the
Create panel, click
rollout, click Daylight to turn it on.

(Systems). On the Object Type

3ds Max Design opens the Daylight System Creation dialog,
recommending an optimum exposure value for mental ray.
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3 Click Yes to accept the settings.
4 In the Top viewport, click anywhere over the scene and drag slightly in
any direction to create a compass rose.

5 Release the mouse button.
As soon as you release the mouse button, the Daylight system is created
and 3ds Max Design opens the “mental ray Sky” dialog, which asks if
you want to create an mr Physical Sky environment map.
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Click Yes to add the environment map.
The mr Physical Sky environment map is based on a gradient, whose
appearance in the background of a scene will change depending on the
position of the sun at any given time of day.
6 Move the mouse upward to position the sun object in the sky. You can
use the Left viewport to see the sun object’s vertical positioning. The
exact height of the sun object in the sky is not important.

7 Click once to set the position of the sun, then right-click to end Daylight
creation.
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Set the time and location of the daylight:
Now you will reposition the sun object so its position in the sky corresponds
to the geographic location of the scene.

1 With the Daylight system (the sun object) still selected, go to the
Modify panel. In the Daylight Parameters rollout ➤ Position group, click
Setup.

3ds Max Design opens the

Motion panel.

2 In the Control Parameters rollout ➤ Location group, click Get Location.
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3 On the Geographic Location dialog, choose Europe from the Map
drop-down list.
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4 On the map, click on the country of Greece, or choose Athens Greece
from the City list displayed at the left.

After you click OK, 3ds Max Design positions the Daylight sun object to
model the real-world latitude and longitude of Athens, Greece.
The Control Parameters ➤ Time group displays controls that let you
modify the date and time of day, settings that also affect sun position.
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The scene you will illuminate and render is mid afternoon at 3 PM, or
1500 hours.
5 In the Time group ➤ Hours spinner, change the time to 15.

6 In the Location group, set the North Direction to 345.0 degrees.

This adjustment orients the north-south position of the scene so the sun
disc will appear over the sea as it prepares to set in the west.
Set exposure:
1 Choose Rendering ➤ Exposure Control to display the Environment And
Effects dialog.
2 Make sure the Camera-Terrace viewport is active, then on the Exposure
Control rollout, click Render Preview to quickly view the result in a
thumbnail.
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3 The scene appears to be acceptable, so
viewport to get a better look.

render the Camera-Terrace

The result is good, but the indoor regions, behind the windows and
doorways of the villa, are darker than they should be. In the next lesson,
you will learn how to solve this problem by taking some of the outdoor
light and directing it into the building.
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Save your work:
■

Save the scene as my_villa_daylight.max.

Using Sky Portals and Photographic Exposure Control
A Sky Portal is a 3ds Max Design light object that gathers the sky light (as
opposed to direct sunlight) generated by the Daylight system. It then directs
the light flow through selected objects, such as doors, glass doors, and
windows, so the interior of buildings can be illuminated.
Set up the lesson:

■

Continue working on your own scene file, or
med_villa_lighting_skyportals.max.

open the scene file

Render the scene for later comparison:

1 Activate the Camera-Terrace viewport,

and render the scene.
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2 On the Rendered Frame Window, make a

clone of the image.

3 Minimize the two Rendered Frame Windows.
Isolate the windows and doors:
1 On an empty area of the main toolbar, right-click and choose Layers from
the pop-up menu.
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3ds Max Design opens the Layers toolbar.
2 Choose Doors & Windows from the drop-down list of layers.
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3 Click
windows.

(Select Objects In Current Layer) to select the doors and

4 Right-click any viewport and on the quad menu, choose Isolate Selection
to display only the selected objects.
5 Activate the Camera-Terrace viewport, press P to switch to Perspective

view, then navigate with
(Pan) and
all the windows are clearly in view.

6

(Field-Of-View) until

Orbit the view so that the windows and doors face you, as shown
in the next illustration.

7 Press Alt + W to maximize the Perspective view, then press F4 to view
Edged Faces.
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TIP Move the Isolated Selection dialog and the Layers toolbar to a corner of
the viewport where they don’t obscure any geometry.

Add the Sky Portals:

1 On the
Create panel, click
(Lights). On the Object Type
rollout, click “mr Sky Portal” to turn it on, then turn on AutoGrid.

2 In the Perspective view, create the first Sky Portal by dragging diagonally
from the lower-left corner of any window to the upper-right corner, until
the entire opening is covered.
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TIP When you create a Sky Portal, make sure that the Z axis of the AutoGrid
grid is perpendicular to the glass pane of the window or door, as shown in
the illustration.
3 Repeat the previous step for every door and window object in the scene,
except for the PivotDoor02 object (it is second from the right in the
upper-right corner of the viewport).

4

Orbit the Perspective view so that the windows and doors are
visible from their sides, as shown in the next illustration.
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The yellow arrow for each SkyPortal object indicates the direction of the
light flow, or flux. Because you used AutoGrid to place the SkyPortal
object on the exterior face of the doors and windows, the light flux arrows
point in the proper direction, into the building. (If you created the Sky
Portal from the inside of the building, you would have to reverse the
light flux either by rotating the window/door, or turning on Flip Light
Flux Direction on the “mr Skylight Portal Parameters” rollout.)

5

Orbit the scene again until the PivotDoor02 object is facing you.
Create another Sky Portal object by dragging across this door.
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6

Orbit the scene one last time so that the sides of the doors and
windows are visible, as shown in the next illustration. The PivotDoor02
object should have its light flux direction pointed in the correct direction:
into the room from the opposite side of the building.
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Adjust the Sky Portal settings:

1

Select any Sky Portal object you created by clicking its yellow
light-flux arrow.

2 Go to the

Modify panel.

Each Sky Portal has an “mr Skylight Portal Parameters” rollout. The
Multiplier control on this rollout lets you boost the amount of light
transmitted by the Sky Portal. For now however, leave the Multiplier set
to 1.0.
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You do not need interior shadows for an exterior shot when viewed from
a distance. Also, turning off Shadows helps to reduce render time. If you
had created a single Sky Portal, you could turn off the Shadows toggle
here; but since you’ve created several Sky Portal objects, it is easier to use
the Light Lister.
3 From the main menu choose Tools ➤ Light Lister. In the Light Lister
dialog ➤ Shadows column, turn off Shadows for each mr Sky Portal
object in the scene.

4

Close the Light Lister.

5 Click Exit Isolation Mode.
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If 3ds Max Design opens a Select Camera dialog, choose Camera-Terrace
and then click OK. Otherwise, click the Perspective viewport POV label
and choose Cameras ➤ Camera-Terrace.
6 Press F4 to return to regular shading mode.
Render the terrace to see the effect of the Sky Portals:

➤

Render the Camera-Terrace viewport and compare the result
with the rendered frame you cloned earlier in this lesson.
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The result is subtle, but improved. The window and door openings are
slightly lighter because now the Sky Portals are channeling sky light into
the villa.
You can understand the effects of the Sky Portals better by looking at the
villa from the inside.
View the sky portal effect from the interior of the villa:
1 Switch the Camera-Terrace viewport to a Camera-Interior view, then

render the scene.

Because scene exposure is set to outdoor conditions, the outside portion
of the scene is properly exposed, but the interior is too dark. You need
to adjust the exposure setting to compensate for the lower light of the
building interior.
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2 On the Rendered Frame Window, click
(Environment And Effects
Dialog (Exposure Controls)) to display the Environment And Effects
dialog.
3 On the mr Photographic Exposure Control rollout ➤ Exposure group,
make sure Photographic Exposure is chosen, then set Shutter Speed to
125.0 (1/125 Sec.).

Keep the Environment And Effects dialog open for now.

4 Make a
clone of the rendered frame, then click Render to render
the scene again.
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The slower shutter speed is now permitting more light to enter the camera,
resulting in a better inside exposure.
You can further improve the interior lighting by increasing the number
of bounces to each ray of light entering the interior.

5

Clone the current rendered frame. In the Rendered Frame window
mental ray controls, change the Final Gather Precision to Low, and
increase the value of FG Bounces to 2.
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6

Render the interior view again and compare the result with the
cloned frame.

7

Close the earlier cloned frames, then
of the most recent rendering.

make a new clone

If you wish, you can take things further by dragging the Final Gather
Precision and Image Precision slider bars to the right. Keep in mind that
the greater the precision, the slower the rendering time.
For this interior scene, it is appropriate for the door’s Sky Portal to cast
shadows. This is because room illumination would ordinarily be affected
by shadows cast by the door frame.

8

Select the Sky Portal object by clicking its gizmo in the center
of the door. On the “mr Skylight Portal Parameters” rollout, turn Shadows
on.
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9

Render the scene again.
If you compare the result with the cloned rendering, you can see that
the shadows where the walls meet each other, and where they meet the
ceiling, are wider and darker than they were before.

10 For the selected Sky Portal, turn Shadows off again.
11 Change the view back to Camera-Terrace.
12 On the Environment And Effects dialog, set the Shutter Speed back to a
proper exposure for the outdoor scene, which is 512 (1/512 Sec.).
Save your work:
■

Save the scene as my_villa_skyportals.max.

Next
Time of Day Illumination on page 815
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Time of Day Illumination
In this lesson, you set the scene for late-day illumination, and adjust the
exposure accordingly.
Set up the lesson:
Continue from the previous lesson.

■

Change the time of day to late afternoon:

1

Render the scene and make a

clone of the result.

2 Minimize the Rendered Frame Windows.

3 In the Front viewport

select the Daylight object (the sun object,

not the compass rose), then go to the

Motion panel.

4 In the Control Parameters rollout ➤ Time group, set the Hours to 18
and Mins. (Minutes) to 30 (6:30 PM, or 1830 hours).

5

Render the Camera-Terrace view again.
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The scene is fairly dim, but you can improve this by adjusting the
exposure to a setting more appropriate for this time of day.

6 Click
(Environment And Effects Dialog (Exposure Controls)) to
display the Environment And Effects dialog.
7 On the mr Photographic Exposure Control ➤ Exposure group, Shutter
Speed is set to a proper exposure for a camera angle facing the sun. But
you can increase the amount of light entering the scene by adjusting the
camera lens aperture.
8 In the Exposure group, set Aperture to 5.6.

9

Render the scene and make a

816 | Chapter 6 Lighting Tutorials

clone of the result.

The overall illumination is much improved, although the outline of the
sun disc is lost.
Create a sunset exposure:
Here, you will adjust scene exposure so that objects are convincingly
illuminated by the setting sun.

1 In the
Motion panel ➤ Control Parameters rollout ➤ Time
group, set the Hours to 19 and the Mins. (Minutes) to 40 (7:40 PM, or
1940 hours).

2

Render the Camera-Terrace view again.
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The scene is extremely dark because the exposure is still set for an earlier
time of day.
3 On the Environment And Effects dialog, set Shutter Speed to 100.0 (1/100
Sec.).

4

Render the Camera-Terrace view again.

818 | Chapter 6 Lighting Tutorials

The “mr Physical Sky shader” produces a vivid sky gradient, and details
around the pool are much more apparent.
5 Take a look at the two other rendered frames representing the same scene
at 3 PM and 6:30 PM to see how you have used mental ray exposure
controls to create three distinctive moods.
Save your work:
■

Save the scene as my_villa_twilight.max.

Summary
You can create a Daylight system to simulate real-world outdoor lighting
conditions at any time of day, at any location on the planet. mental ray offers
a range of presets that define proper exposure settings for specific lighting
conditions, which you can adjust manually as needed. You can also add Sky
Portal objects to channel sky light into doorways and windows of structures,
to enhance their interior illumination.
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Lighting and Rendering the Villa at Night
In this tutorial, you will illuminate the mediterranean villa by night.
First, you create photometric lights that mimic real-world lighting systems.
After that, you add a photograph of the sky to use as a background.

In this tutorial, you will learn how to:
■

Place photometric lights in a scene and adjust light color.

■

Set shadow parameters so lights cast shadows properly.

■

Set the exposure for a nighttime scene.

■

Use a bitmap image as the scene background and adjust its output for
nighttime lighting conditions.

Skill level: Intermediate
Time to complete: 1 hour
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Adding Photometric Lights
You will start by adding incandescent, halogen, and fluorescent lights, whose
real-world properties will illuminate the night scene.
Set up the lesson:

On the Quick Access toolbar, click
(Open File), navigate to the
\scenes\lighting_and_rendering\med_villa folder, then open
med_villa_lighting_start.max.

■

NOTE If a dialog asks whether you want to use the scene’s Gamma And LUT
settings, accept the scene Gamma settings, and click OK. If a dialog asks
whether to use the scene’s units, accept the scene units, and click OK.

Create a recessed light for the porch:

1 Activate the Top viewport and
zoom in to the forward portion of
the trellis, as shown in the next illustration.

There are three light fixtures in the ceiling of the lower porch. These
appear as small circles in the wireframe view.

2

Zoom in farther to the fixture on the left.
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3 On the

Create panel, click

(Lights).

The lights panel is automatically set to Photometric, meaning that any
light you create in this category will exhibit real-world behavior in terms
of light attenuation, distribution, color, and so on.
On the Object Type rollout, click Free Light to turn it on.

3ds Max Design opens a dialog that asks whether to add an “mr
Photographic Exposure Control” to the scene.
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4 Click Yes to add the exposure control.
5 Click in the center of the light fixture to add the Free Light to the scene.

By default, the light object is created on the surface plane of the scene.
6 Right-click to end object creation.
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7 Right-click the Front viewport, zoom in so you can see the light fixture

socket and the new light object, and use
(Select And Move) to
move the light object on its Y axis until it is positioned inside the fixture.

Set the properties of the light:

➤

Go to the
Modify panel. From the Templates rollout ➤ Select
A Template drop-down list, choose Recessed 75W Lamp (Web).
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3ds Max Design updates values in the rollouts below the Templates rollout
to match the real-world properties of a 75W incandescent light with
uneven (web) distribution. You can adjust these properties, but for the
present scene, we will use the template values.
Add the other porch lights:

1 In the Front viewport,
pan and
zoom out until you can
see the porch light fixtures to the right of the light you just created.
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2 Activate
(Select And Move), then Shift+drag a copy of the Free
Light along its X axis until it is inside the neighboring socket, as shown
in the next illustration.
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3ds Max Design opens a Clone Options dialog. In the dialog ➤ Object
group, choose Instance. Set the Number Of Copies to 2, and then click
OK.
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3ds Max Design adds the other two porch lights. The third light has the
same spacing you gave to the scond, so it lines up with the socket at the
right.
Set the exposure and render the scene:

1 Activate the Camera-Terrace viewport and

render the scene.

Considering that the scene has only three fairly low-power lights in it,
the result is not bad.
2 Minimize the Rendered Frame Window.
Add an interior light:

1 Activate the Top viewport, then
see the plan of the house.
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zoom and

pan so you can

2 On the
Create panel, click
rollout, click Free Light to turn it on.

(Lights). On the Object Type

3 Click once to create a light behind the door frame, as shown in the
illustration, then right-click to end object creation.
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4 Activate the Front viewport, then use
(Select And Move) to move
the light object on its Y axis until it is positioned just above the
lower-story doorway.
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Adjust the interior light:

➤

Go to the
Modify panel. On the Templates rollout, open the
drop-down list and choose 100W Bulb.

You will accept the default settings for this photometric light.
Add another instance of the interior light:

1 Use
(Select And Move) to Shift+drag the light object to the area
of the kitchen window on the left, as shown in the next illustration.

Adding Photometric Lights | 831

In the Clone Options dialog, make sure Instance is chosen, then click
OK.
2 The kitchen is on the top floor, so activate the Front viewport and move
the light object so it is positioned just above the window.
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Add lights to the balcony:

1 Active the Top viewport again and
area.

zoom in closely on the balcony

There are two blue light fixtures over the balcony: ConeLightBulb01 and
ConeLightBulb02.

2 On the
Create panel, click
rollout, click Free Light to turn it on.

(Lights). On the Object Type

3 Click in the neighborhood of ConeLightBulb01 to place the light. The exact
position is not important.
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4 On the main toolbar, click

(Align), then click ConeLightBulb01.

5 In the Align Selection dialog ➤ Align Selection (Screen) group, turn on
X, Y, and Z Position, then choose Center for both Current Object and
Target Object. Click OK.
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This aligns the center of the light object with the light fixture.
Keep in mind that because the light is set to cast shadows, the object it
is placed in must have a material transparent enough for light to pass
through. Otherwise, rays from the light object will strike the inside of
the object it is enclosed in, and travel no farther.
6 Go to the Modify panel ➤ Templates rollout and choose 100W Bulb.
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Keep in mind that the light you choose in this list possesses the same
properties as a real-world light, and must therefore be appropriate for the
area it is intended to illuminate. In terms of light attenuation, for example,
for every 10 meters distance travelled, light intensity from this 100-Watt
bulb will drop off to 1/100th of its initial strength.
7 On the Intensity/Color/Attenuation rollout, choose the Kelvin (color
temperature) option to change the light color to a soft yellow (2800K).
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8 Activate
(Select And Move), Shift+drag to copy the light to a
position near ConeLightBulb02.

In the Clone Options dialog, make sure Instance is chosen, then click
OK.
9 Align the cloned light object just as you did the first light object.
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Render the scene again to see the result:

1 Restore the Rendered Frame Window, then make a
currently rendered frame.

2 Activate the Camera-Terrace viewport, then

clone of the

render the scene.

Compare the two rendered images.
Because you used a yellow color (2800K) for the 100W bulb light objects,
the upper balcony is bathed in a yellowish light. Also, now light is visible
from the door and windows of the two rooms that have lights inside
them.
3 Minimize the Rendered Frame Window.
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Add halogen lights to the pool:

1 Activate the Top viewport, then
zoom and
pan so you can
see the swimming pool, as shown in the next illustration.

2 On the
Create panel, click
rollout, click Free Light to turn it on.

(Lights). On the Object Type

3 Click once to place a light object at the inner edge of the pool on the
upper-left side, as shown in the next illustration. Right-click to end object
creation.
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Be sure to position the light so it is slightly away from the pool wall.

4 Activate the Front viewport,

pan so you can see the swimming

pool, then use
(Select And Move) to move the light object on
its Y axis until it is positioned at the midpoint between the floor of the
pool and the waterline.
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5 Go to the
Modify panel. On the Templates rollout, open the
drop-down list and choose 80W Halogen Bulb.

The default color for this type of light is 2900 degrees Kelvin, which
produces a yellowish hue. A whitish-blue color is preferable, so now you
will modify the light’s Kelvin value accordingly.
6 In the Intensity/Color/Attenuation rollout ➤ Color group, make sure
Kelvin is chosen, then set the Kelvin value to 8000.0.
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7 In the Front viewport,
Shift+move the light to place the new
light about halfway along the length of the pool.

In the Clone Options dialog, make sure Instance is chosen, then increase
the Number Of Copies to 2. Click OK.
3ds Max Design adds two new lights, spaced equally apart.

842 | Chapter 6 Lighting Tutorials

8 Activate the Top viewport.

Ctrl+click to select all three light

objects, then
Shift+move them to place copies at the opposite
side of the pool (leave a bit of distance between the lights and the side
of the pool).
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In the Clone Options dialog, make sure Instance is chosen and Number
Of Copies equals 1, then click OK.
Render the villa with pool lighting:

1 Restore the Rendered Frame Window, then make a
currently rendered frame.

2 Activate the Camera-Terrace viewport,
compare the two renderings.

clone of the

render the scene, then

The scene is starting to take shape. Your next task will be to add light
objects to the lamp posts that surround the pool.
Save your work:
■

Save the scene as my_villa_nighttime.max.
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Next
Adding Lights to the Deck Area on page 845

Adding Lights to the Deck Area
The lights for the deck area are mounted in six lamp posts around the pool.
Setting them up is not much different from setting up the other lights, except
that these are fluorescent lamps that cast shadows from a rectangular area, so
the orientation of the light objects becomes important. Also, because of the
large fixture size, you will use a self-illuminating material, and later a Glare
shader, to improve the realism of the rendered scene.
Set up the lesson:
■

Continue from the previous lesson.

Add fluorescent lights for the deck around the pool area:

1 Activate the Top viewport, and
zoom out around the swimming
pool so you can see all six lamp post objects, as shown in the next
illustration.

2 Press H to open a Select From Scene dialog, click to highlight LampPost01,
then click OK.
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NOTE If the dialog highlights all six lamp posts, choose Select ➤ Select
Dependents to turn off this option.
3 Right-click the viewport and choose Isolate Selection from the quad menu.
4 Activate the Camera-Terrace viewport and press P to change to a
Perspective view.
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5 Click
(Zoom Extents) to get a closer look at the lamp post.
Continue to zoom in until the light panel is clearly in view.

6 Change the Camera-Hi-Point viewport to Left viewport.

7

Zoom in to the top of the lamp post object in the Front and Left
viewports as well.

8 On the
Create panel, click
(Lights). On the Object Type
rollout, click Free Light to turn it on, and turn on AutoGrid.
9 In the Perspective viewport, click once in the center of the light panel to
place the light object on its surface. Turn off AutoGrid when you’re done.
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Set the light properties:
1 Go to the Modify panel. On the Templates rollout, open the drop-down
list and choose 4ft Cove Fluorescent (Web).

848 | Chapter 6 Lighting Tutorials

By default, this type of object emits light as a point. However, you want
the object to emit light in a rectangular area that corresponds to the
geometry of the panel on the lamp post.
2 In the Shape/Area Shadows rollout ➤ Emit Light From (Shape) group,
choose Rectangle from the drop-down list.
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3 Drag the Length and Width spinner arrows until the rectangular bounding
box matches the dimensions of the lamp post light panel.

Use the Top and Left viewports to check your work. Use
(Select
And Move) to adjust the position of the light object if you need to.
Before you move the light, go to the main toolbar and choose Local as
the reference coordinate system.

4 Activate the Front viewport and use
(Select And Move) to move
the light object downward slightly, toward the lower surface of the fixture.
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5 Click Exit Isolation Mode, click the Perspective viewport label and choose
Cameras ➤ Camera-Terrace.
Clone the original fluorescent light:
1 Activate the Top viewport, press Shift+Z to return to the view of all six

lamp posts, then use
(Select And Move) to Shift+clone the light
object to the neighboring lamp post, as shown in the next illustration.
(If you changed the reference coordinate system to Local, change it back
to View before you Shift+clone.) Make the cloned light an instance of the
original.
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2 In the Top viewport, Ctrl+click to select the first light (both deck lights

should be selected), and then on the main toolbar, click

(Mirror).

3 In the Mirror dialog ➤ Mirror Axis group, make sure X is chosen. In the
Clone Selection group, choose Instance.
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4 In the Top viewport,
move the cloned light objects to the lamp
posts on the opposite side of the pool.
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5 Activate the Front viewport, and
posts.

zoom in to the top of the lamp

6 Drag the two new lights along X axis until they approach the lower surface
of the fixture.

Add the lights on the lower side of the pool:

1 In the Top viewport,
Shift+clone the light objects to the mid
point between the two remaining lamp posts, as shown in the next
illustration. Make the clones instances, again.
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2 On the main toolbar, turn on

3

(Angle Snap Toggle).

Rotate the lights’ position by –90 degrees about the Z axis.
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4

Move the lights on their Y axis until they are in line with the
two remaining lamp posts, as shown in the next illustration.

5

Move each light individually on its X axis until the light is
repositioned inside the corresponding lamp post.
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6 In the Left viewport,
repositioned.

zoom in to the light objects you just

7 If you need to,
move both lights along the X axis until they are
near the front edge of the fixture.
8 Change the Left viewport back to a Camera-Hi-Point view.
Render the scene to check the illumination:

1 Activate the Camera-Terrace viewport and

render the scene.
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With the addition of these latest light objects, the time it takes to render
the scene has increased considerably.
The area around the pool is now illuminated, but the scene remains
under-lit. The intensity of the fluorescent light objects needs some
adjustment.
2 Minimize the Rendered Frame Window.
Fine-tune the fluorescent illumination:
The fluorescent light objects you created for the pool deck emit a light intensity
that corresponds to their product specifications. However, you have the option
of overriding this setting. Here, you will increase the intensity to provide
added illumination.

1

Select one of the fluorescent light objects.
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2 Go to the
Modify panel. In the Intensity/Color/Attenuation
rollout ➤ Dimming group, double the value of Resulting Intensity from
100 to 200.0 percent.

3 Activate the Camera-Terrace viewport and

render the scene.

Because the light objects were cloned as instances, all lights are affected
by the change to the Resulting Intensity setting. The amount of available
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light in the scene has greatly increased, rendering the shadows cast by
the floor vase and diving board in greater detail.
The scene is almost complete, but one flaw remains. The frosted glass
panels that cover the lamp posts are not glowing as they should,
considering that the lamps are the major source of your outdoor
illumination.
Make the lamp post fixtures self illuminating:

1

Open the Slate Material Editor.
A lot of materials are already in the active View1 view, so you’ll create a
new view for editing the Glow material.

2 Right-click the blank area next to the View1 tab, and choose Create New
View. Name the new view Glow Editing, then click OK.
Glow Editing becomes the active View.
3 In the Material/Map Browser panel at the left, open the Scene Materials
group, locate the Glow material, and drag this entry into the Glow Editing
view. When 3ds Max Design prompts you to create either a Copy or an
Instance, make sure Instance is chosen, then click OK.
Glow is a mental ray Arch & Design material. It is used by the shades for
the balcony lights, and also by the glass panels in the lamp posts around
the swimming pool.
4 Double-click the Glow material node so you can see its parameters in the
Parameter Editor at the right.
5 On the Self Illumination (Glow) rollout, turn on Self Illumination (Glow).

The controls in the Color group lets you specify the color of the glow
material, but leave default filter color of white unchanged.
In the Luminance group, choose Physical Units (cd/m2). If you later
choose to add lighting effects such as Glare, you can adjust this value to
fine-tune the result. For now, leave the setting unchanged, at 1500
candelas per square meter.
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6 In the Glow Options group, turn off Visible In Reflections.

Since the rendered image already shows some reflectance of the lamp
posts, you don’t need this option. The other option in this group,
Illuminates The Scene (When Using FG), turns a self-illuminating material
into its own light source. But the lamps already have their light objects
in place, so any additional illumination from the Glow material is
unnecessary.
7 Render the Camera-Terrace viewport.
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The light sources in the lamp posts now look illuminated. On the other
hand, their edges look too precise for light sources: They should have the
glare that you see on streetlights and other nighttime outdoor lighting.
You can correct this with the mental ray Glare shader.
Add a Glare effect:
mental ray provides a number of special effects designed to give light objects
added realism. Here, you will add a Glare effect to the lights in the villa, to
simulate their interaction with dust particles and ambient humidity.

1 Click
(Render Setup). On the Render Setup dialog, go to the
Renderer tab. In the Camera Effects rollout ➤ Camera Shaders group,
turn on the Output shader toggle.

As the shader button shows, mental ray provides a Glare shader as a
default shader for camera output, but by default this shader is turned off,
so you have to enable it “by hand.”

2 Open the
dialogs.

Slate Material Editor, and move it so you can see both

3 In the Material/Map Browser panel on the left, navigate to the Sample
Slots group.
4 Drag the Camera Shaders ➤ Output button from the Render Setup dialog
and drop it onto an unused sample slot. The sample slot shows a red bar
across it when you are able to drop the map.
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3ds Max Design asks if this should be an instance or a copy. Make sure
Instance is selected, and then click OK.
5

Close the Render Setup dialog.

6 Drag the sample slot with the Glare shader into the active View.
Once again, 3ds Max Design asks if this should be an instance or a copy.
Make sure Instance is selected, and then click OK.
7 In the active View, double-click the Glare node so you can see its
parameters in the Parameter Editor panel to the right.
8 On the Glare Parameters rollout, change the value of Spread from 2.0 to
0.25.

9

Close the Slate Material Editor.
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10 Make a
the scene.

clone of the existing rendered frame, then

render

Rendered scene with Glare effect added to light sources

Compare the two images to see the Glare effect. This effect is most
pronounced on the lamp posts for the deck, but it is also noticeable on
the balcony light that is not hidden by the pillar.
11

Close the Rendered Frame Windows.

Save your work:
■

Save the scene as my_villa_nighttime_pool_and_deck.max.

Next
Improving the Background on page 865
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Improving the Background
In the previous lessons, you used photometric lights to illuminate the
foreground of your mediterranean night scene. In this lesson, you will complete
the picture by changing the color of the sea and using a bitmap image of a
sky as a backdrop.
Set up the lesson:

■

Continue working on your own scene file, or
med_villa_lighting_env.max.

open the scene file

Correct the color of the sea:
First, you will change the sea to a more realistic color.
1 Press H To open the Select From Scene dialog. Click the the Sea object to
highlight it, then click OK.
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2 Activate the Camera-Terrace viewport, then on the main toolbar, click

(Rendered Frame Window) to display the rendered frame.
3 On the Rendered Frame window ➤ Area To Render drop-down list choose
Selected, then click the Render button.
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This rendering takes some time, so feel free to cancel the rendering once
you get an idea of the result.
The color of the sea water is suitable for a day scene but not for nighttime.

4 Open the

Slate Material Editor.

5 In the Material/Map Browser, scroll to the Scene Materials group, and
locate the the Water - Sea entry. Drag this entry into the active View, and
when 3ds Max Design asks whether to use an instance or a copy, make
sure Instance is chosen, then click OK.
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6 Double-click the Water - Sea material node so you can see its parameters
in the Parameter Editor panel at the right.
7 On the Water rollout, open the Color drop down list, and choose Custom.

8 Click the Custom Color swatch and on the Color Selector that opens,
pick a deep blue color: Red=0.005, Green=0.025, Blue=0.1.
9 Render the sea again. Again, you can cancel the rendering once you get
an idea of the result.

868 | Chapter 6 Lighting Tutorials

10 On the Area To Render drop-down list, choose View so that the next time
you render, the entire scene will be included.
11 Minimize the Rendered Frame Window.
Add a background image:
1 Open the Rendering menu and choose Environment to open the
Environment And Effects dialog. On the Common Parameters rollout,
click the Environment Map button (at present, the text on the button
says (“None”).
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3ds Max Design opens the Material/Map Browser.
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2 On the Material/Map Browser, double-click the Bitmap map type. (Bitmap
is in the Maps ➤ Standard group.)
3ds Max Design opens a file dialog.
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3 In the file dialog, navigate to the \sceneassets\images folder, click desert.jpg
to highlight it, then click Open.
The image is a desert landscape, taken during the day.
4 On the Exposure Control rollout make sure Process Background And
Environment Maps is off.

When this option is turned on, 3ds Max Design applies the exposure
control to the background map itself. For most bitmaps (those that don’t
save a high dynamic range), in effect this makes the background and
other environment maps invisible.
5 Make sure no object is selected, right-click a viewport, and from the quad
menu, choose Hide Unselected.

6

Render the Camera01 viewport.
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With all objects hidden, 3ds Max Design has rendered only the
background image. It is apparent that you will need to make the image
darker so it suits the nighttime scene.
Leave the Environment And Effects dialog open for now.
Adjust the background image:

1 Open the

Slate Material Editor.

2 In the Material/Map Browser panel on the left, navigate to the Sample
Slots group.
3 Drag the Environment Map button from the Environment And Effects
dialog and drop it onto an unused sample slot. The sample slot shows a
red bar across it when you are able to drop the map.
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3ds Max Design asks if this should be an instance or a copy. Make sure
Instance is selected, and then click OK.
4

Close the Environment And Effects dialog.

5 Drag the sample slot with the environment map into the active View.
Once again, 3ds Max Design asks if this should be an instance or a copy.
Make sure Instance is selected, and then click OK.
6 In the active View, double-click the Bitmap node so you can see its
parameters in the Parameter Editor panel to the right.
7 On the Output rollout, decrease the Output Amount to 0.033.

8

Render the Camera01 viewport again.
The result is a heavily underexposed image, resembling a night sky: a
digital version of filming “day for night.”
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Background bitmap heavily underexposed to suit night scene

9

Close the Slate Material Editor.

Render the scene to see the background changes:
➤

Right-click any viewport, select Unhide All from the quad menu, then

render the Camera-Terrace viewport.
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The darker ocean is more realistic, and the background of a cloudy sky
gives depth to the scene.
This completes the rendering of the villa at night. If you wanted to further
reduce the amount of antialiasing in the rendering, you could move the
Rendered Frame Window ➤ Image Precision and Final Gather Precision
sliders one notch to the right. However, increasing these settings greatly
increases the rendering time.
Save your work:
■

Save the scene as my_villa_nighttime_completed.max.

Summary
In this tutorial, you learned how to use photometric lights to illuminate a
scene at night. You specified the color of light sources and defined how
shadows were cast. You used self-illumination and a Glare shader to improve
the appearance of light sources. You also learned how to take a background
image and reduce its output level to make suitable for a nighttime scene.
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Indoor Lighting Analysis
The 3ds Max Design Lighting Analysis feature can help you evaluate how
interior or exterior space is illuminated at different times of the day, or how
interiors are affected by various man-made lighting systems.
In this tutorial, you will use a 3ds Max Design Light Meter object to evaluate
how light intensity from a daylight source affects the lighting of an indoor
tennis court. You’ll render the scene and export the Light Meter data to an
Excel file, making it available for analysis by third parties. Also, you will overlay
the image with a layer of Light Meter readings for a more visual representation
of lighting intensity.

In this tutorial, you will learn how to:
■

Use the Lighting Analysis Assistant to prepare a scene for lighting analysis

■

Create a Daylight system

■

Use a weather data file to set daylight system light intensity

■

Create a Light Meter and adjust its sampling point density

■

Adjust the range of color feedback from the Light Meter
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■

Convert Light Meter data to spreadsheet format

■

Overlay Light Meter data onto a rendered image of the scene

Skill level: Intermediate
Time to complete: 1 hour

Preparing the Scene
First, you will create a Daylight system. (If the model were linked or imported
from Autodesk Revit, a Daylight system would already be present.) Then you
will perform a test rendering to check image quality.
Set up the lesson:

■

On the Quick Access toolbar, click
(Open File), navigate to the
\scenes\lighting_and_rendering\lighting_analysis folder, then open
arena_start.max.
NOTE If a dialog asks whether you want to use the scene’s Gamma And LUT
settings, accept the scene Gamma settings, and click OK. If a dialog asks
whether to use the scene’s units, accept the scene units, and click OK.
The scene consists of an indoor tennis court. Materials have already been
applied to its surfaces.

Create a daylight system:

1 On the
Create panel, click
rollout, click Daylight to turn it on.
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(Systems). On the Object Type

3ds Max Design opens the Daylight System Creation dialog, which
recommends an optimum exposure control setting for mental ray.

Exposure Control is comparable to the shutter and aperture settings of a
camera. It adjusts the brightness and contrast in a rendered image. It does
not affect the actual amount of lighting in a scene.
2 Click Yes to accept the “mr Photographic Exposure Control”.
3 In the Top viewport, click anywhere over the scene and drag slightly in
any direction to create a compass rose.
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4 Release the mouse.
3ds Max Design opens the “mental ray Sky” dialog, asking if you want
to add an “mr Physical Sky” environment map for the background of
your scene.
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NOTE 3ds Max Design displays this dialog only if you are using the default
set of tool options. If the dialog doesn’t appear, open the Environment And
Effects dialog, and in the Environment panel ➤ Common Parameters rollout
➤ Background group, click the Environment Map button and assign the
shader yourself.
To revert to this default tools settings, from the Customize menu choose
Custom UI And Defaults Switcher, and on the Choose Initial Settings dialog
➤ Initial Settings For Tools Options, choose DesignVIZ.mentalray.

5 Click Yes.
The sky map is cosmetic, and while it will create a nicely shaded
background to the scene exterior, it will not affect the interior lighting
levels in any way.
6 Move the mouse upward to position the sun object in the sky. The exact
height of the sun in the sky is not important, as long as it is above the
model. Sun height has no effect on scene lighting or rendering.

7 Click once to set the position of the sun.
8 In the Top viewport, right-click to end Daylight creation.

9 Go to the
Modify panel, scroll down to the “mr Sky Advanced
Parameters” rollout, and make sure Aerial Perspective is turned off.
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This option, which simulates atmospheric haze and reduces the visibility
of distant objects, can interfere with lighting analysis.
Do a test rendering:
1 Activate the Camera01 viewport.
NOTE Lighting analysis is always performed from a camera’s perspective,
and therefore it requires a camera object in the scene.
2 From the Rendering menu, choose Exposure Control to open the
Environment And Effects dialog.
3 On the Exposure Control rollout, click Render Preview.
The preview thumbnail takes a moment or two to render. The resulting
image is quite dark because the default Exposure Value of 15 is not suitable
for an indoor scene.
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Render preview with
Exposure Value set to 15.

4 From the “mr Photographic Exposure Control” rollout ➤ Exposure group
➤ Preset drop-down list, choose Physically Based Lighting, Indoor
Daylight.

The Exposure Value changes from 15 to 10 and the render preview
thumbnail appears somewhat lighter.
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5 Change the Exposure Value (EV) from 10.0 to 9.0.
The preview updates to show the effect of the new setting.

Specifying even lower exposure values causes the scene to appear brighter.
Now you will enhance the illumination of the scene by using Final Gather
to increase light bounces.

6 On the main toolbar, click

(Rendered Frame Window).

7 On the Rendered Frame Window, in the Trace/Bounces Limits group
(below the image area), set the number of FG Bounces to 4.
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This increases the number of times a ray of light bounces on object
surfaces in a scene. Values of 4 through 7 are the most effective. Values
under 4 produce less noticeable results, while values over 7 require a great
deal of render time, with limited added benefit.
8 On the Environment And Effects dialog ➤ Exposure Control rollout,
click Render Preview again to see how the added bounces have brightened
up the interior of the model.

9 Click the Render button (or press F9) to render a full-size frame.
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Artifacts present in the scene

The model renders well, but the shadows on the back wall, especially at
the left, are too dark. There are also some dark patches on the floor of
the court, to the left, that look like shadows but don’t have anything to
do with the geometry of the scene.
You could improve the render quality by adjusting the Image Precision
and Final Gather Precision sliders on the Rendered Frame Window. Each
slider position represents a preset group of Final Gather settings. In this
lesson, however, you will perform your adjustments manually.
Use custom Final Gather settings to improve the quality of the rendering:

1 On the Rendered Frame Window, click

(Render Setup).

2 In the Render Setup dialog ➤ Indirect Illumination tab ➤ Final Gather
rollout ➤ Basic group, set Initial FG Point Density to 0.2, Rays Per FG
Point to 150, and Interpolate Over Num FG Points to 50.
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These values will eliminate most of the noise artifacts in the scene while
ensuring a reasonably fast calculation time.
To learn more about Final Gather and each of its settings, refer to the 3ds
Max Design Help.

3 On the Rendered Frame Window, make a
image, then render the scene again.

clone of the rendered

This time, your image will take two to three times as long to render.
4 Compare the two images to see how your edits to Final Gather have
affected image quality.
Some artifacts remain, but the overall image is much improved.
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Artifacts reduced after adjustments made to Final Gather

5

Close the Rendered Frame Windows and all other dialogs.

Save your work:
■

Save the scene as my_tennis_court_with_daylight.max.

Adding a Light Meter
In this lesson, you will use the Lighting Analysis Assistant to check your scene’s
render settings, then make the needed adjustments so that lighting analysis
can take place.
Next, you’ll create an invisible Light Meter object. Light Meters perform
lighting analysis by calculating luminance over a specific area in a scene. Light
Meters can calculate direct luminance, indirect luminance, or a combination
of the two.
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Set up the lesson:

■

Continue working with the scene from the previous lesson, or
open arena_01.max.

Open the Lighting Analysis Assistant and check the status of the scene:
1 From the main menu, choose Lighting Analysis ➤ Lighting Analysis
Assistant.
3ds Max Design opens the Lighting Analysis Assistant dialog. This is
where you activate and edit the tools used to analyze lighting in a scene.
NOTE The Lighting Analysis Assistant is available in 3ds Max Design only.
The status line at the bottom of the dialog indicates the number of invalid
settings, if any, that you must correct.

2 Go to the Materials tab.
The Lighting Analysis tool requires that all objects in the scene use
physically correct surface materials. Only objects assigned the mental ray
Arch & Design material or one of the Autodesk Materials (including
materials from the Autodesk Material Library) are permitted. All other
materials are considered invalid. Objects with no material assigned are
also treated as invalid.
The Materials rollout ➤ Total Objects With Invalid Materials box
indicates the presence of 875 invalid objects in the scene, which you
must now correct.
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Locate the objects with invalid materials:

1 Click the
Materials.

selection button next to Total Objects With Invalid

This selects all objects in the scene that have an invalid material. As you
can see in the viewports, most of the problem objects are the arena seats.
2 Right-click an empty gray area of the main toolbar and choose Layers.
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3ds Max Design opens the Layers toolbar. A layer called Seats has already
been created for you.
3 Open the layer list and choose Seats from the list.

4 On the Layers toolbar, click

(Select Objects In Current Layer).
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All seat objects are selected. On the Modify panel, you can see that 874
objects are selected: This is just one object short of the 875 total number
of objects with invalid materials.

Update the material for the arena seats:

1 Open the

Slate Material Editor.

2 In the Material/Map Browser panel on the left, locate the Seats material.
Drag this entry into the active View. When 3ds Max Design prompts you
to use a copy or an instance, make sure Instance is chosen, then click
OK.
The Seats material is a Standard material, which is not physically-based,
as the Lighting Analysis Assistant requires.
3 Double-click the Seats material node so you can see the material’s
parameters in the Parameter Editor panel on the right.
4 On the Blinn Basic Parameters rollout, right-click the Diffuse color swatch
and choose Copy.

This saves the color for use in the new material you will now apply to
the seats.
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5 In the Material/Map Browser panel, navigate to the Materials ➤ mental
ray group. Drag an Arch & Design entry from the Browser into the active
View.
6 Double-click the Arch & Design material node so you can see its
parameters.
7 Name this new material Arena Seats.

8 On the Templates rollout, choose Matte Finish from the list.
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This gives the material a neutral reflectivity.
9 In the Main Material Parameters rollout ➤ Diffuse group, right-click the
Color swatch and choose Paste.

This copies the color from the Standard material to the Arch & Design
material.

10 On the Slate Material Editor toolbar, click
Selection).

(Assign Material To

11 Minimize the Slate Material Editor.
Apply a material to the Ground object:
1 On the Lighting Analysis Assistant dialog, click Update Status.
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On the Materials rollout, the Total Objects With Invalid Materials field
updates to show only one remaining object with an invalid material.
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2 Click the

selection button.

3ds Max Design selects the Ground object, which is the ground on which
the indoor arena stands.

3 To see the Ground object, minimize the Lighting Analysis Assistant,

activate the Top viewport, and click
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(Zoom Extents).

Top view of scene with Ground object selected

4 Restore the Slate Material Editor window, and move it or resize it so you
can see most of the Top viewport.

5 On the Slate Material Editor toolbar, click
(Pick Material From
Object) and position the eyedropper cursor over a grid line of the Ground
object.
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The eyedropper barrel is empty, indicating that no material exists. If you
position the eyedropper over another object in the arena model it appears
full, indicating that a material is present.

Because the ground object has no material applied to it, it is considered
to have an invalid material.
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6 Drag an Arch & Design entry from the Browser into the active View.
7 Double-click the new material node so you can see its parameters.
8 Change the name of the new material to Ground - Neutral.
9 On the Templates rollout, choose Matte Finish from the list.
This gives the material a neutral reflectivity.
10 In the Main Material Parameters rollout ➤ Diffuse group, click the Color
swatch.
11 On the Color Selector, change the HSV Value to 0.2.

This gives the material low reflectivity.

12 On the Slate Material Editor toolbar, click
(Assign Material To
Selection) to apply the material to the Ground object.
13

Close the Slate Material Editor.

Check the Lighting Analysis status again:
■

On the Lighting Analysis Assistant, click Update Status.
Now the status line should display “Status: 0 Invalid Settings.”
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Now that you have set up the scene properly, you can create a Light Meter.
For lighting analysis to take place, at least one Light Meter must be present
in the scene.
Create a Light Meter:
1 From the Layers toolbar ➤ Layers list, choose Light Meters.

Any Light Meter you now create will be added to this layer for easy
selection later on.
2 Activate the Top viewport, and press Alt+W to maximize it.

3

Zoom in so you can see the floor plan of the arena.
Now you will create a Light Meter for the tennis court area.

4 On the Lighting Analysis Assistant dialog, go to the Analysis Output panel
and on the Light Meters rollout, click Create A Light Meter.
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5 In the Top viewport, create the Light Meter by clicking the bottom left
corner of the tennis court, then dragging diagonally until the Light Meter
gizmo covers the entire surface of the court. Release the mouse.

Tennis court surface to receive lighting analysis

6 Right-click to end creation of the Light Meter helper object.
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By default, 3ds Max Design creates a 3 x 3 grid of light sampling points.
You need to increase the sampling density.
Adjust the Light Meter settings and position:

1 Press Alt+W to return to a four-viewport view, and in the
Modify
panel ➤ Parameters rollout ➤ Dimensions group, set Length Segs to 9
and Width Segs to 11.

In the viewports, you can see each light sampling point as a vertical arrow.
Because Light Meters are helper objects, you can move them around like
any other object in a scene.
2 In the Camera01 viewport, notice how the Light Meter sample points
appear slightly embedded in the court surface. This might hinder their
ability to analyze light, so you need to raise them slightly upward.
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Light Meter helper object with sampling points embedded in court surface

3 On the main toolbar, click
(Select And Move), then in the Z-axis
transform field, type 0.055 and press Enter.
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Light Meter helper object after adjustment of its Z-axis position

The ground object is five centimeters thick, so the 0.055 value places the
sampling points a half centimeter above it.
Save your work:
■

Save the scene as my_tennis_court_light_meter.max.

Analyzing the Lighting
Now that you have created a Light Meter and adjusted the distribution of its
sampling points in your model, you are ready to use the points to calculate
the lighting intensity.
You will process the Light Meter for midday, then take another reading for a
period later that day to see how the change in sun position affects light
distribution in the model interior.

904 | Chapter 6 Lighting Tutorials

Set up the lesson:

■

Continue working with the scene from the previous lesson, or
open arena_02.max.

Choose a sky model:
Sky models are a set of luminance distributions that model the sky under a
range of conditions, from overcast to clear sky. 3ds Max Design comes with
three available sky models: Haze-Driven, Perez All-Weather, and CIE.
Perez All Weather and CIE are the models best suited to lighting analysis.

1 In any viewport,

select the Daylight system sun object, then go

to the
Modify panel. In the “mr Sky Parameters rollout” ➤ Sky
Model group, open the drop-down list and choose CIE.

CIE stands for Commission Internationale de l’Éclairage, which is a body
responsible for the international coordination of lighting-related technical
standards. This sky model uses the CIE-based standard of luminance
distribution.
2 Scroll down to the “mr Sky: CIE Parameters” rollout.
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By default, Overcast Sky is chosen. This ensures that the lighting analysis
can evaluate light when its intensity is at its lowest.
The Diffuse Horiz (Horizon) control is set to 10,000 lux. This value
establishes the distribution of daylight along the horizon, with no direct
sunlight taken into account.
This value corresponds to the light intensity for the geographic location
of your model. Light intensity increases, the closer you are to the equator,
approximately by the values provided in the next illustration.

Global daylight intensity levels

The Direct Normal Illuminance control beneath Diffuse Horiz lets you
set sun intensity, as if the light meter was pointed directly at the sun.
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3 Set the Direct Normal Illuminance to 0.0 (just right-click the spinner
arrows), because you are using the Overcast Sky option.

Process the Light Meter:

1 In the Camera01 viewport,

select the Light Meter Helper object.

If you prefer, press H and from the Select From Scene dialog, select
LightMeter Helper001.

2 Go to the
All Light Meters.

Modify panel ➤ Display rollout and click Calculate
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A progress bar appears in the status-bar area of the 3ds Max Design
window. After a few moments, the viewports update to display the
readings calculated by each sample point, based on the lighting data you
defined for the CIE sky model.
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Camera viewport shows light meter readings based on luminance from the CIE sky
model

3 Press Alt+W to maximize the Camera01 viewport.
Sample point data is more clearly visible, with combined direct and
indirect luminance values ranging from nearly 2,000 for points next to
the window to less than 120 for points farther in the model interior.
It is generally recognized that for everyday use, interior spaces should
not fall below 250 lux. This means the tennis court interior, under overcast
conditions, would require artificial, man-made lighting systems to provide
added illumination.

4 Go to the
Modify panel and in the Display rollout ➤ Values To
Display group, choose Direct Illuminance.
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The sample points all return a value of 0 because, being an overcast day,
there is no direct sunlight to record.
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Light meter readings detect no direct luminance

5 Choose Indirect Illuminance.
The values are identical to those of step 2, because Total Illuminance
measured no direct sunlight.
6 Choose Daylight Factor.
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Light meter readings showing Daylight Factor

The values show the percent of outdoor sun striking the area occupied
by each sample point. The values from 5.2 to 6.5 returned by the sample
points at the lower right of the viewport equal roughly five to six and a
half percent of the 10,000 lux value of estimated outdoor horizontal
diffuse light intensity you set earlier. If you choose the Total Illuminance
option again, that percentage value is expressed in lux units.
NOTE 3ds Max Design displays Daylight Factor values only when you are
using the Overcast Sky model.
The next graphic illustrates how light can be cast differently in a scene,
depending on which CIE sky model you choose. On the left, the sky
dome shows a light gradient generated by the Overcast Sky model; on
the the right, the sky dome shows a gradient under the Clear Sky model.
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Left: Light gradient of an Overcast Sky model
Right: Light gradient of a Clear Sky model

A problem exists, however, when you use either the Overcast Sky or Clear
Sky option. For the Light Meter to return accurate values that correspond
to the geographic location of your model, you need to make a sometimes
arbitrary decision to set the scene for clear or overcast conditions. You
also need to specify a corresponding lux value in the Direct Normal
Illuminance spinner box based on the geographic location of the model.
You might not always know this value.
A better alternative is to use a weather file, one that takes into account
weather variations on an hourly or monthly basis based on real-life
meteorological observations.
Set daylight parameters from a weather data file:
1 Press Alt+W to return to a four-viewport view, then in any viewport,

select the Daylight system sun object, go to the
Modify
panel, and in the “mr Sky Parameters” rollout ➤ Sky Model group, open
the drop-down list and choose Perez All Weather.
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Unlike the CIE Sky Model, Perez All Weather does not include the Overcast
Sky and Clear Sky options. This information is provided by the weather
data file you will use to define the sky illumination gradient.
2 Open a Web browser and type
www.eere.energy.gov/buildings/energyplus/cfm/weather_data.cfm.
The U.S. Department of Energy Web site opens to the EnergyPlus Energy
Simulation Software Weather Data Web page.
3 Click the North and Central America hyperlink, then click the Canada
hyperlink.
The weather data might take a moment or two to display.
4 Scroll down to the Quebec section, locate the Montreal Intl AP weather
site, right-click the blue EPW file icon, and choose Save Target As.
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The EPW file contains all the data you need to perform the lighting
analysis.
5 On the Save As dialog, specify where you want to save the EPW file, click
OK, then close the Web browser.
NOTE A copy of this file is saved in the \sceneassets\photometric folder. You
can use this version if you have difficulty accessing the weather data from
the Web.

6 In the
Modify panel ➤ Daylight Parameters rollout ➤ Position
group, choose Weather Data File, then click Setup.

7 On the Configure Weather Data dialog, click Load Weather Data.
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8 On the Open Weather File dialog, choose the weather file you just saved
from the Web, then click Open.
9 In the Configure Weather Data dialog ➤ Use Weather Data group, click
Change Time Period.
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By default, the weather data is set to January 1st, 1966, at noon, but you
will choose a summer date.
10 On the Select A Time Period From Weather Data dialog, drag the Time
Period slider until the Selected Time Period box displays Wednesday, July
27, 1977; 14:00:00.

Use the Increment Period Selector controls to narrow down the selection
if you need to. Click OK.
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TIP If you wish to use a date that is unavailable from the weather data files,
you can contact the U.S. Department of Energy via its Web site.
11 On the Configure Weather Data dialog, click OK to add the weather data
to the scene.
Now the “mr Sky: Perez Parameters” rollout Diffuse Horizontal and Direct
Normal Illuminance fields display the diffuse lighting and direct lighting
applied to the Perez model by the weather data file.

NOTE Luminance values can change considerably between one data file and
another, depending on whether the readings were taken under clear or cloudy
conditions. To obtain a more representative set of luminance values for your
model, it is a good idea to review weather data from several different dates
at a given time of year, and choose the data file with the median luminance
values.
Next, you will extract a range of weather data to see how the illuminance
values change over a six-hour period of time, ranging from mid-morning
to mid-afternoon.
Choose a range of weather data:

1 With the Daylight sun object selected, go to the
Modify panel
and in the Daylight Parameters rollout ➤ Position group, click Setup.
2 In the Use Weather Data group, choose Display Data As Animation.
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3 For the Start value, click Change Time Period and in the Select A Time
Period From Weather Data dialog, use the slider and spinner controls to
set the date and time to Wednesday, July 27, 1977; 9:00:00, then click
OK.
4 Repeat the previous step for the End value and set the time to 15:00:00.
The Use Weather Data group indicates a total of seven frames created as
a result of the selection range.

5 Click Match Timeline, then click OK.
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The timeline updates to show seven frames.

6 On the
Modify panel, scroll to the “mr Sky: Perez Parameters”
rollout and see how the illumination values now reflect the 9 AM
sampling time.

The Diffuse Horiz value is not that high, indicating low ambient
luminance, but the high value in the Direct Normal Illuminance box
suggests exposure to a great deal of direct sunlight for that particular
morning in 1977.
7 Drag the time slider to frame 3, which is noon, and look at the
illumination values again.
The light is more evenly distributed between direct and indirect
illumination.
As you can see, by specifying a range of sampling times, you can get an
idea of how daylight illumination can affect a model at different times
of the day.
8 Drag the time slider to the last frame in the sequence, frame 7, then in

any viewport,

select the Light Meter object.

9 On the
Modify panel ➤ Display rollout, make sure Total
Illuminance is chosen, and then click Calculate All Light Meters.
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Light meter readings based on direct suinlight conditions

The level of illumination is much higher than that detected using the
CIE Sky Model, even in the areas farthest from the windows. This is
because the scene illumination is based not on an overcast day, but on
a day of direct sunlight.
The Light Meter object uses color coding to help you visualize the lighting
intensity in a scene. Lower intensities are displayed in cool colors such
as blue and green, while higher intensities are shown in orange and red.
The tennis court interior displays cool blue to the left, with even the
lowest values in the acceptable illumination range, greater than 250 lux.
To the right, by the windows, the color ramps up to pure white. White
areas indicate that the illumination values are outside the color-coding
range. You now need to adjust the color coding to obtain a more even
gradient, so you can evaluate better the areas of high illumination.
Adjust lighting analysis color feedback:
1 From the main menu, choose Lighting Analysis ➤ Lighting Analysis
Assistant, and go to the General panel.
The Analysis Value Color Coding rollout displays a color ramp. The ramp
intensity range is currently set between 0.0 and 10000.0 units. The units
are in lux (lx), the international unit of measure. If you prefer, you can
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switch to the American unit of measure, foot-candles (fc) on the Units
Setup dialog.
Given that the scene illumination is over 42,000 lux in places, the color
range is currently too narrow. You need to widen the color ramp range.
2 Change the value of the Max spinner to 45000.0, and press Enter.

In the viewport, the color range now shows light intensity much more
effectively.

Light meter readings showing improved color coded feedback
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The orange areas of the tennis court interior show direct sunlight for this
time of day, while the blue areas show indirect sunlight.
3 From the ➤ Scale drop-down list, choose Logarithmic.

The color-coded areas update to provide a different visualization of the
light intensity, but the intensity values themselves remain unchanged.

4 From the Scale list, choose Linear again.

Analyzing the Lighting | 923

5 Activate the Camera01 viewport, then

render the scene.

Computers with average processing capabilities will typically take five
minutes or so to complete this task.

Rendered interior scene showing mid-afternoon illumination

The Perez All-Weather Sky model and weather data provide bright scene
illumination. Some image detail near the windows is washed out, but the
interior shows up in good detail.
NOTE The Perez model is suitable for daytime, but not for twilight or night
scenes. For scenes where the sun is low or absent, use the CIE model if you
are concerned with photometric accuracy.

Save your work:
■

Save the scene as my_tennis_court_lighting_analysis.max.
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Exporting Light Meter Data and Rendering Light Meter
Data
In this lesson, you will learn how to export your Light Meter readings so that
others can view them either in an Excel spreadsheet, or as a rendered image
overlayed with Light Meter data.
Set up the lesson:

■

Continue working with the scene from the previous lesson, or
open arena_03.max.

Export the Light Meter data in spreadsheet format:

1 In the Camera01 viewport,

2 Go to the
CSV File.

select the Light Meter helper object.

Modify panel ➤ Display rollout and click Export To
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3 On the Save Light Meter Output As CSV File dialog, enter my_arena.csv
as the file name, then click Save.
NOTE A prepared CSV file, arena.csv, has been saved to the \export folder
as well.
3ds Max Design saves the data generated by the Light Meter object in
CSV format to the \export folder of your project directory.
4 Navigate to your \export folder and open the newly saved file.
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The file opens in an Excel spreadsheet, showing light data gathered by
each point in the Light Meter helper. This data, formulated for technical
specialists such as lighting engineers, is described in detail in the following
table.
Column

Definition

A: Name

Name of the Light Meter helper.

B: ID

Number of the Light Meter helper sampling point.

c: Frame

Number of the frame in an animated sequence where the
light source was sampled. (A value of 0 indicates no animation.)

D: Location

Geographic location of the scene.

E: Date

Time and date on which weather data used by the lighting
source was recorded.

F: Direct

Value of direct illumination detected by the Light Meter
sampling point.

G: Indirect

Value of indirect illumination detected by the Light Meter
sampling point.

H: Total

Combined value of direct and indirect illumination detected by the Light Meter sampling point.

I: Illum. Units

Unit of measurement used to display light illumination
values in columns F through H (lx = lux, fc = foot-candles).
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5

Column

Definition

J: Daylight Factor

Value of daylight detected by the Light Meter sampling
point, excluding direct or indirect luminance.

K-M: Pos X/PosY/Pos Z

Position coordinates of the Light Meter sampling point.

Unit

Unit of measure used to display the Light Meter sampling
point position in columns K through M.

O-Q: Orient X - Z

Rotation coordinates of the Light Meter sampling point.

Close the Excel spreadsheet.

Create an image overlay:
1 Drag the time slider to frame 7. From the main menu, choose Lighting
Analysis ➤ Lighting Analysis Assistant to open the Lighting Analysis
Assistant dialog.
2 Go to the Analysis Output panel if it is not already open, and on the
Image Overlay rollout, click Create Image Overlay Render Effect.

3ds Max Design opens the Environment And Effects dialog ➤ Effects
panel.
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3 On Effects rollout, click Lighting Analysis Image Overlay to highlight it,
and then in the Parameters rollout ➤ Display Options group, make sure
all the options are turned on. Keep the dialog open.
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4 In the Effects rollout ➤ Preview group, turn on Interactive.

3ds Max Design renders the scene.
As soon as the calculation is complete, two rendered frames display.
The first frame renders entirely in yellow. It is used to create the overlay
image but contains no usable information. Close this window.
The second rendered frame includes a layer of luminance data derived
from the lighting analysis. The numbers are dense and not easy to read
because they include lighting values in a grid, as well as values generated
by the Light Meter sample points.
NOTE If your rendering displays only luminance data without the tennis
court image, render the scene a second time.
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Overlay shows combination of grid and sample point light meter data

5 Keep the Rendered Frame Window open for now.
Adjust the display of Light Meter data:
1 In the Environment And Effects dialog ➤ Parameters rollout ➤ Display
Options group, turn off Show Numbers On Entire Image (Screen Grid).

Now only the luminance values returned by the sampling points of the
Light Meter you created for the court surface are displayed.
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The rendering updates instantly after you make your choice because you
turned on Interactive in the Effects rollout ➤ Preview group.
Notice how the maximum luminance values display in the lower-right
corner of the rendered frame.

Overlay shows sample point light meter data only

2 In the Environment And Effects dialog ➤ Effects panel ➤ Parameters
rollout ➤ Type And Range group, change the value of Max to 42927.0,
and then press Enter.
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By lowering the maximum range, the sample values display in their full
color-coded range, from blue (low luminance) to red (high luminance).
This is most noticeable near the windows.

3 In the Display Options group, turn off Fade Background Image.
The scene shows the actual light intensity of the rendered image. This,
however, makes the Light Meter data harder to read.
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4 Turn the Fade Background Image option back on.
5 In the Display Options group, turn off Show Numbers From Light
Metering Helper Objects and turn on Show Numbers On Entire Image.
The Light Meter luminance data is now sampled from 2D points on the
image surface. You can set the density of sampling points on the surface
plane.
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Overlay shows light meter data arranged in a 40 by 40 grid

6 In the Screen Grid Layout Options group, change the Vertical Spacing
and Horizontal Spacing values to see how the overlay is affected.

Increasing the spacing decreases the density of the grid.
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7 In the Effects rollout ➤ Preview group, click Show Original to view the
scene without the lighting data. Click Show Effects to redisplay the data.

8 On the Rendered Frame Window toolbar, click

(Save Image).

With the Save Image dialog, you can save the rendered image in a number
of formats to a location of your choosing.
Save your work:
■

Save the scene as my_tennis_court_light_level_overlay.max.
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If you like, you can view a completed version of this lesson by opening
the scene file arena_completed.max.

Summary
In this tutorial, you learned how to create a Daylight system and set the
exposure to effectively illuminate an indoor scene. You then opened the
Lighting Analysis Assistant and prepared the scene for lighting analysis using
a helper object called a Light Meter, which evaluates the amount of direct and
indirect illumination that enter a scene.
You also learned how to introduce realistic lighting conditions by downloading
weather data containing real-world meteorological observations, and applying
these luminance values to your Daylight system. You then took the Light
Meter readings generated by the new luminance values, and converted them
into spreadsheets and rendered overlays for subsequent analysis.
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938

Rendering Tutorials

7

The lighting tutorials showed you ways in which to render your scene. The tutorials in this
section cover additional aspects of rendering: Rendering an animation, how to use
Depth-of-Field, and rendering large numbers of low-poly objects and proxies to reduce scene
calculation time.

Features Covered in This Section
■

Render animations.

■

Create a depth-of-field rendering effect.

■

Use a particle system to simulate large numbers of similar objects in a scene

939

■

Create mental ray proxy objects and use the Scatter utility to instance, then distribute
them across a scene

Creating a Shadow Study
You can animate a Daylight system's time of day. This is a good way to create
a shadow study.

In this tutorial, you will learn how to:
■

Use a Daylight system to create animated shadows.

■

Use viewport shadow settings to investigate the shadows cast by the
buildings in a single city block.

■

Use mr Sky (mental ray Sky) to provide sky color.

■

Render selected frames for later inspection or presentation.
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IMPORTANT This tutorial demonstrates hardware shading. In order to see
hardware-shaded shadows and other effects, your graphics hardware must support
Shader Model 3.0 (SM3.0) or a later version.
If you aren’t sure what graphics hardware you have, in 3ds Max Design choose
Help ➤ Diagnose Video Hardware. This displays a dialog with details about your
graphics configuration, including GPU Model Shader Support, which shows the
Shader Model version number.
If your graphics hardware doesn’t support SM3.0, or you are using the Software
driver rather than OpenGL or Direct3D, you can skip this tutorial. Or you can do
the first procedure, where you animate the daylight, then skip to the last procedure,
which uses the mental ray renderer.
Skill level: Beginner
Time to complete: 30 minutes
Set up the scene:

■

On the Quick Access toolbar, click
(Open File), navigate to the
\scenes\rendering\cityscape folder, and open cityscape.max.
NOTE If a dialog asks whether you want to use the scene’s Gamma And LUT
settings, accept the scene Gamma settings, and click OK. If a dialog asks
whether to use the scene’s units, accept the scene units, and click OK.
The scene consists of a city block, with a skyscraper at the center. The scene
also contains a Daylight system. The system is set to position the scene at
the latitude of San Francisco, California, with sun position set at 0700
hours, about the time of dawn on a winter day.
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Animate the daylight:

1 On the main toolbar, turn on

(Select Object).

2 In the Top viewport, click the sun object to select it.
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Daylight01 appears in the name field on the command panel.

3 Go to the

4 Turn on

Motion panel.

(Auto Key).

The button, the track bar, and the border of the active viewport all turn
red.

5 Drag the time slider to frame 60 (or click
(Go To End)), and then
on the Control Parameters rollout, change the Hours value to 19.
The spinner arrows of the Hours, Minutes, and Seconds fields are now
bracketed in red, indicating that you have set a key to animate the time
of day.
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When you use Auto Key to set a key at frame 60, 3ds Max Design also
sets a key at the start frame, frame 0. So the sun is now animated to range
from 0700 to 1900 hours, or 7 A.M. to 7 P.M. Because there are 61 frames
in the animation, the sun reaches the top of the hour every five frames.

6 Turn off

(Auto Key).

7 Drag the time slider.
You can see the movement of the sun.

8 Click

(Go To Start) to return to frame 0.

Use viewport lighting to view the scene:

1 Activate the Camera02 viewport, and

maximize it.

2 Click the Shading viewport label menu (the one that now reads “[ Smooth
+ Highlights ]”), and choose Lighting And Shadows ➤ Illuminate With
Scene Lights.
Now the scene is illuminated by the mr Sun light that is part of the
daylight system, and the Camera02 viewport shows the lighting early on
a winter morning.
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3 Click the Shading viewport label again, and choose Lighting And Shadows
➤ Enable Hardware Shading.
With hardware shading, the scene is considerably darker, which is
probably more realistic for this time of year. In any case, hardware shading
allows you to see shadows in the viewports.
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4 Click the Shading viewport label menu again, and choose Lighting And
Shadows ➤ Enable Shadows.
At 0700 hours, there is no visible change in the viewport.
5 Drag the time slider.
As the sun progresses across the sky, shadows in the viewport move across
the cityscape.
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0900h
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1200h
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1500h

Reduce the shadow density:
1 Drag the time slider to frame 40 (1500 hours).
2 Click the Shading viewport label menu, and choose Lighting And Shadows
➤ Configure.
3ds Max Design opens the Viewport Configuration dialog, opened to the
Lighting And Shadows panel.
3 In the Viewport Shadows And Ambient Occlusion group. change the
value of Viewport Shadow Intensity to 0.8, then click OK.
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Now the shadows have a density of 80 percent, and look somewhat softer.

Reducing shadow intensity can be a pleasant effect. It can also be more
realistic for a site such as this, in San Francisco, where there is often cloud
cover and the lighting is more diffuse than direct sunlight.
NOTE With hardware shading, you also have the option of generating
soft-edged shadows. These can improve the realism of a display, but in
general, they aren’t as useful for shadow studies.
Next, you will improve shadow quality by adding Ambient Occlusion.
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Add Ambient Occlusion:
Ambient Occlusion (AO) is a technique for improving the appearance and
density of shadows. Rather than tracing light rays, it takes into account the
proximity of objects in the scene.
1 Click the Shading viewport label menu, and choose Lighting And Shadows
➤ Enable Ambient Occlusion.
3ds Max Design updates the viewport shadows.

With Ambient Occlusion, shadows are denser and have more detail.
2 Click the Shading viewport label menu, and choose Lighting And Shadows
➤ Configure.
3 On the Viewport Configuration dialog, change the Ambient Occlustion
quality slider from Medium to High. Click OK.
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The difference is subtle, but there is an improvement.
View the effects of mr Sky:
One advantage of using mr Sky as the sky light for the Daylight system, is that
this light changes color depending on the time of day.
The angle of Camera02 is too high to get a good view of the sky, so first you
change views.
1 Click the Point-Of-View (POV) viewport label (which currently reads “[
Camera02 ]”), and choose Cameras ➤ Camera01.
This is a more oblique view of the city block.
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2 Click the Shading viewport label menu, and choose Viewport Background
➤ Show Background.
3ds Max Design shows the sky and horizon. The sky is colored according
to the time of day.
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0900h

1200h
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1500h

1648h
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Save your work:

■

From the
Application menu, choose Save As. In the file dialog,
name the file my_shadows.max, then click Save.
TIP Always save your scene file before you render.

(Optional.) Render snapshots of the shadow study:
A hardware-shaded viewport is great for interactive display. But hardware
shading doesn’t include the full detail of a rendering. Also, sometimes hardware
shading generates artifacts, as you can see in the previous graphic of the
viewport with noontime lighting. For further study, or to make a presentation,
you might want to render the shadows.
You can turn the shadow study into an animation, but for this tutorial, you
will render only selected frames.
At 0700 hours, when the animation begins, and 1900 hours, when it ends,
the scene is too dark to be interesting. So you will render selected frames from
a smaller range.

1 On the main toolbar, click

(Render Setup).

3ds Max Design opens the Render Setup dialog. The Common panel is
active.
2 In the Common Parameters rollout ➤ Time Output group, set the range
from frame 5 to frame 45 (0800 to 1600 hours). Also set Every Nth Frame
to 5.
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You will render nine snapshot frames over the course of the main daylight
hours.
3 In the Output Size group, click the 800 x 600 button.
Smaller sizes render more quickly, but the shadows don't show up as well.
4 Scroll down to the Render Output group. Click the Files button.
3ds Max Design opens a Render Output File dialog. By default, 3ds Max
Design saves renderings in the \renderoutput folder for the tutorials. You
can change this location if you like.
Choose JPEG as the output type, and enter thirdstreetblock as the file
name, then click Save.
Accept the defaults for the JPEG file format.
TIP Even when you create an animation, rendering to sequentially numbered
still image frames can be a good idea. If you need to correct mistakes, you
can correct individual frames without having to re-render the entire animation.
5 Make sure Camera01 is the active viewport, then click Render.
3ds Max Design renders the individual frames. Each frame has the file
name you entered, followed by a sequence number that equals the frame
number.
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Fully rendered frame from the snapshot set

You might want to experiment. For example, changing the Daylight
system’s month to a month in summer will show more hours of daylight,
and shadows that have a different orientation.
A completed version of this scene is saved as cityscape_animated.max.
Save your work:
■

Save the scene as my_cityscape_shadows.max.

Summary
To create a shadow study you can use Auto Key to animate a Daylight system’s
time of day. With hardware viewport shading, you can view shadows. Turning
on Ambient Occlusion improves the shadow quality. The sky light mr Sky
provides sky color. You can also use the renderer to create fully detailed frames,
or an animation.
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Using the Depth-of-Field Camera Effect
This tutorial shows how to use the mental ray Depth-of-Field render effect to
increase the realism of your renderings.
Depth of field is a technique used to focus on a fixed point in a scene, called
a focal plane. The area of the focal plane remains in focus, while objects closer
than the focal plane, and farther from it, are blurred. This is how real-world
cameras work, and using Depth of Field can make it appear as if the rendering
were a photograph.
Skill level: Intermediate
Time to complete: 45 minutes
Set up the lesson:

■

On the Quick Access toolbar, click
(Open File), navigate to the
\scenes\rendering\rendering_effects folder, and open
med_villa_rendering_dof.max.
NOTE If a dialog asks whether you want to use the scene’s Gamma And LUT
settings, accept the scene Gamma settings, and click OK. If a dialog asks
whether to use the scene’s units, accept the scene units, and click OK.

Measure distances:
1 Activate the Top viewport and press Alt + W.
2 Locate the Camera-Chair camera.
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3 On the
Create panel, click
rollout, click Tape.

(Helpers). On the Object type

You will use the Tape helper to determine the distance between the
camera and three objects in the scene: a chair, a flower pot, and a corner
of the building. The location of each object will become a focal plane, or
region where the scene is in the sharpest focus.
4 Click on the center of the camera object and drag to the closest chair, as
shown in the next illustration.
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On the Parameters rollout, the Length field displays the distance between
the two objects as roughly 2.3 meters.

5 Press Delete to delete the Tape helper.
6 Click on the camera again, then drag to the flower pot across the pool.
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The Length field displays a length of about 20 meters.
7 Press Delete to delete the Tape helper.
8 Click on the camera, then drag to the lower-left corner of the villa.

The Length field displays a length of about 28 meters.
9 Press Delete to delete the Tape helper, and then right-click to exit Helper
creation mode.
Now that you know the distances, you will use the chair in the foreground as
the focal plane for the first rendering.
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Adjust the f-stop and focus plane:
1 Press Alt + W to return to a four-viewport layout, then activate the
Camera-Chair viewport.

2 On the main menu, click
the rendered frame window.

(Rendered Frame Window) to display

3 On the Rendered Frame Window, click

(Render Setup).

4 In the Render Setup dialog ➤ Renderer tab ➤ Camera Effects rollout
➤ Depth of Field group, turn on Enable.

The depth-of-field render effect works only in Perspective viewports, so
now you need to change the viewport view.
5 Press P to switch the Camera-Chair viewport to a Perspective view.
6 In the Render Setup dialog ➤ Camera Effects rollout ➤ Depth of Field
group, leave the drop-down list set to F-Stop (the aperture setting). This
lets you specify the degree of blurriness of objects that are not in focus.
7 In the Focus Plane spinner, set the distance you measured from the camera
to the chair, 2.3m, and in the f-Stop spinner, set the aperture to 2.8.

The lower the aperture, or f-stop setting, the larger the aperture and the
more blurred the out-of-focus regions become.
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Leave the Render Setup dialog open for now (move it if it obscures the
Rendered Frame Window).
8 On the Rendered Frame window, click the Render button to render the
scene.

The focal plane, which is set to the chair in the foreground, is in the
sharpest focus, while the background becomes progressively more blurred.
Use the other two focal planes to create renderings:
1 On the Render Setup dialog, change the Focus Plane to 20.0m, then render
the Perspective viewport again.
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The area in sharpest focus is now the flower pot and the plant in it. All
objects in the foreground and, to a lesser extent, the background are
blurred.
2 Change the Focus Plane to 28.0m, then render the Perspective viewport
again.
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All objects in the foreground are blurred, while the house is mainly in
focus.
One last adjustment remains. You will now adjust the f-Stop to make the
foreground less out of focus.
Use the f-stop setting to control the depth-of-field effect:
■

Set the f-Stop to 5.6, then render the Perspective viewport again.
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The foreground is much more defined than in the previous rendering.
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Above: f2.8 creates a narrow focal range
Below: f5.6 creates a deeper focal range

NOTE You can also sharpen the foreground image by dragging the Image
Precision (Antialiasing) slider in the Rendered Frame Window to the right, but
this option greatly increases render time.

Save your work:
■

Save the scene as my_villa_focal_planes.max.

Summary
The Depth-of-Field camera effect is an easy way to make it appear as if your
rendering was taken by a real-world camera.
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Reducing Complexity in Your Renderings
When you render a scene, the number of faces in the scene model directly
affects rendering time: The greater the number of faces, the longer the
rendering takes.
The tutorials in this section use trees as an example of objects with a high face
count. They show you to ways to reduce that count: By turning trees into
particles, a method you can use with either renderer; and by turning trees into
mr Proxy objects, a method that applies to the mental ray renderer.

Trees set up as “particles” to render a wooded area in a short amount of time

Particle Trees
In this tutorial, you learn how to use particles behaving as “billboards”: Each
particle shows a bitmap tree image that can render quickly, while a twinned
particle casts the shadow of the tree.
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Trees modeled using conventional 3D techniques can produce authentic
results, but a single tree typically can include 20,000 polygon faces or more.
If you need to duplicate the tree many times, to create a forest for example,
you can be faced with a lengthy render involving millions of polygons.
However, there is a way to populate your scene with many life-like trees
without sacrificing render speed. You can do this by using a particle system
to generate a number of particles in the shape of two-dimensional planes, or
“billboards.” A map of a tree is then projected onto each billboard.
This particle method permits the mapping of different sizes and shapes of
trees and is very economical to render. But it also raises several important
issues.
Because the tree image is two-dimensional, it can be seen properly only when
it directly faces the camera. If seen from an angle, it loses its realism.
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Left: Particle tree facing camera
Right: Particle tree at oblique camera angle

For this reason, the flat plane on which the image is mapped must be
continuously re-oriented toward the camera as the camera moves around the
scene.

Particle tree continuously faces the camera

Another consideration is how your two-dimensional particle trees cast shadows.
If the light source (usually the sun) does not directly face the billboard plane,
the tree will cast an unrealistic oblique shadow, as shown in the next
illustration.
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Light source causes the particle tree to cast a shadow at an oblique angle

Therefore, you must generate a second set of particle tree planes. The first set
should show the tree and no shadow, while the second set should show a
shadow and no tree.

Left: Second particle tree oriented toward the light source, with its shadow visible
Right: Second particle tree hidden, with only its shadow visible
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The visible tree planes are oriented to continually face the camera, while the
shadow-only tree planes continually face the light source. You define the tree
and shadow orientation in the particle system parameter settings.
You should also introduce a degree of self illumination to the particle-based
trees you generate. Otherwise, if the light source is behind the object in camera
view, as shown in the next illustration, the object can appear darker that it
should.

Left: Camera view of backlit particle tree with no self-illumination
Right: Camera view of particle tree illuminated directly by light source

In this tutorial, you will learn how to:
■

Create tree objects and modify their material

■

Create a particle system

■

Use operators to shape particle system events

■

Map images to generated particles

■

Set particle visibility

■

Assign sub-materials to generated particles

■

Rearrange particle placement in a scene

■

Use polygon selection to define the area in which to render the particles.

Skill level: Intermediate
Time to complete: 1 1/2 hours

Creating Billboard Tree Maps
In this lesson, you will choose a tree from the 3ds Max Design library of
ready-made plant objects and edit its material to resemble an elm in spring.
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You will save this object as a .tif image, ready to be projected onto the billboards
of your particle system.
NOTE In addition to the tree objects available in 3ds Max Design, there are a
number of commercially available plug-ins, such as Forest from Itoo Software, or
RPC from ArchVision, that offer a wide range of alternative tree species.
Create a tree:

1 On the main toolbar, click

(Render Setup).

2 In the Render Setup dialog ➤ Common panel ➤ Common Parameters
rollout ➤ Output Size group, set Width and Height to 512.
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Each particle, or billboard, you generate from the particle system will be
perfectly square, so the resolution of the map you want to use for the
tree must be square as well.
A value of 1024 x 1024 or even higher is permissible, but the higher the
resolution, the longer it will take to render the particle trees.
3

Close the Render Setup dialog.

4 On the
Create panel, click
(Geometry). Open the Objects
drop-down list, and choose AEC Extended.

5 On the Object Type rollout, click Foliage and on the Favorite Plants rollout
click American Elm.
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6 Click anywhere in the Perspective viewport to place the tree.
7 Right-click to exit object creation mode.
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Position the tree so it will render as a well-behaved billboard:
1 Activate the Front viewport and press P to switch to a Perspective view.

2 Click

(Zoom Extents).

3 Click the Point-of-View (POV) viewport label and choose Show Safe
Frames. Change the viewport shading mode to Smooth + Highlights (you
can press F3).
The safe frame displays as a yellow square, indicating the extent of the
rendering area.

Perspective view with the safe frame displayed
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4 Use
(Pan) and
occupies the safe area.

(Zoom) to reposition the tree until it fully

Tree repositioned to fill the safe area

Now you need to make sure the base of the tree trunk is centered precisely
at the bottom midpoint of the frame. In doing so, you ensure that the
trunk of this tree will be aligned with the tree shadow that you’ll derive
from this image.
5 Click the Perspective viewport’s General label (“[+]”) and choose
Configure.
6 In the Viewport Configuration dialog ➤ Safe Frames panel ➤ Setup
group, turn off User Safe Lock, then turn on User Safe.

Particle Trees | 979

7 Set the User Safe Horizontal spinner to 100.0, the Vertical spinner to 0.0,
then click OK.
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A purple vertical guide line displays in the viewport safe area. (This guide
line is actually a rectangular safe-frame area that has no width.)

User safe area that acts as a guideline for centering the tree in the frame

8

Move the tree along its X axis until the center of the trunk base
is aligned with the purple line.
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The next procedure shows how to replace the tree with another one that
might be more to your liking.
Find a tree configuration that you like:

1 Go to the
Modify panel. On the Parameters rollout, click the
New button to the left of Seed until you see a tree you prefer.
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2 If 3ds Max Design displaces the tree trunk,
move the base of the
tree along its X axis until it is aligned with the center line of the safe
frame again.
This time, also make sure the tree base extends slightly below the bottom
edge of the safe area. This will cause the particle tree to slightly sink in
to the emitter object and form a solid connection with the ground. Also,
make sure no leaves or tree branches extend beyond the safe area.
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Base of the tree repositioned so it extends slightly into the safe area

Render the tree:
1 On the main menu, choose Rendering ➤ Gamma/LUT Setup.
2 3ds Max Design opens the Preferences dialog to the Gamma And LUT
tab. Turn on Enable Gamma/LUT correction. Make sure that Gamma is
chosen, and that the gamma value is set to 2.2.
Turn on both options in the Materials and Colors group as well: Affect
Color Selectors and Affect Material Editor.
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Adding gamma correction improves the appearance of renderings.

3 On the main toolbar, click

(Render Production).
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3ds Max Design renders the tree using the default render settings. The
trunk color is not realistic, and the leaves are too uniform in color. To
correct this problem, you will change their material diffuse values.
4 Minimize the Rendered Frame Window.
Change the material of the trunk:

1 Open the

Slate Material Editor.
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2 On the Slate Material Editor toolbar, click
(Pick Material From
Object), then in a viewport, click any part of the tree.
3ds Max Design displays the BasicElm material in the Slate Material Editor
active View.

3 In the Slate Material Editor, click

(Zoom Extents).
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The material tree looks complicated because BasicElm is a Multi/Sub-Object
material, but it really is not as complicated as it looks.
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4 Double-click the main BasicElm material node, the node at the right of
the tree, so you can see the material parameters in the Parameter Editor
panel at the right of the Slate Material Editor.

The Multi/Sub-Object Basic Parameters rollout shows how the BasicElm
material contains five sub-materials, assigned separately to the trunk,
branches, and leaves.
NOTE The Canopy sub-material is the material shown in viewports when the
tree object is not selected.
Now you will change the Diffuse values of the Trunk sub-material to
improve the appearance of the tree trunk.
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5 In the active View, click to select the first sub-material at the top of the
View, which is the node for the Trunk sub-material.

6 Click
(Zoom Extents Selected), and then
pan out in the
View a bit so you can see the Trunk material node and the map and
controller already assigned to it. When you’re done, right-click an empty
area of the View to return to selection mode.

7 In the Material/Map Browser panel at the left, locate the Noise map (it
is in the Maps ➤ Standard group), drag this entry into the active View,
and then wire it to the Trunk sub-materials Diffuse Color socket.
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8 Double-click the Noise map node so you can see its parameters.
9 On the Noise Parameters rollout, choose Fractal for the noise type, and
set the Size spinner to 5.0.
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10 Click the Color #1 color swatch and choose a medium-dark brown color,
(such as R=77, G=41, B=5), then click the Color #2 color swatch and
choose a light tan or beige color (such as R=146, G=124, B=102).

Render the tree to see the result:
1 Minimize the Slate Material Editor.
2 Render the Perspective viewport to see the new diffuse values you set for
the Trunk sub-material. If you are not satisfied with the result, feel free to
make further changes to the material color.
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With lighter, noise-mapped colors, the trunk looks more convincing and
also more elm-like.
Next, you will copy the diffuse values of the trunk to the branches.
Use the new Trunk submaterial for the branches:
1 Restore the Slate Material Editor window.

2 In the active View,
Pan downward in the View so you can see the
Branch0 and Branch1 nodes. When you have finished panning, right-click
an empty area of the View to return to selection mode.
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3 Click the Branch0 sub-material node, then press Delete.
4 Delete the Branch1 sub-material node as well.
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5 Wire the Trunk sub-material node to the main BasicElm (2) and (3)
sub-material sockets that used to contain the Branch0 and Branch1
sub-materials.
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6 With your cursor in the active View, press L to rearrange the layout of
the material tree.
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With only three sub-materials, the material tree is simpler than it was.
Now all the branches match the trunk, as you can see if you render the
Perspective viewport again.
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Change the material of the leaves:
1 Double-click the Leaves sub-material node (now the second sub-material
from the top) so you can see its parameters.
2 Drag another Noise map from the Browser into the active View, and wire
the Noise map node to the Diffuse Color socket of the Leaves sub-material.
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TIP After you add and wire the new Noise node, press L again to clean up
the layout of the active View.
3 Double-click the new Noise map node so you can see its parameters.
4 On the Noise Parameters rollout, choose Fractal for the noise type, and
set the Size spinner to 3.0.
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5 Also on the Noise Parameters rollout, set the Noise Threshold ➤ High
value to 0.7 and the Low value to 0.3.

These values will increase the level of sharpness between the two colors
you are about to choose.
6 Click the Color #1 color swatch and choose a medium-dark green color,
(such as R=0, G=73, B=0), then click the Color #2 color swatch and choose
a light green color (such as R= 175, G=189, B=171).

7 Minimize the Slate Material Editor.
8 Render the tree to see the new diffuse values for the leaf material.
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Notice how the two-color combination makes for more realistic leaves.
Check the alpha channel:

1 On the Rendered Frame Window, click
(Display Alpha Channel)
to view the alpha channel of the tree object in the rendering.
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Alpha channel of the tree object rendering

The alpha information provides the shape of the cutout for the particle
trees you will generate later.
Now you now need to save the tree to an image file format that includes
alpha information.

2 Turn off

(Display Alpha Channel).
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Save the “billboard” image of the tree in spring foliage:

1 On the Rendered Frame Window, click

(Save Image).

2 In the Save Image dialog File Name field, type my_elm_spring.tif, then
click Save.
3ds Max Design opens the TIF Image Control dialog. In the Image Type
group, make sure that 8-Bit Color is chosen, and Store Alpha Channel is
on.

NOTE You can save your file in a format other than .tif, but be sure to choose
a format that stores alpha information. Formats such as .png and .tga can
include alpha, whereas .jpg and .bmp cannot.
The particle system you create in the next lesson can use this tree image
to populate a forest. To introduce some variation to the scene, you will
create a second tree image to be referenced by the particle system as well.
Create fall foliage for the tree, and save that image:

1 In the Perspective viewport, select the tree object and on the
Modify panel ➤ Parameters rollout, click the New button to the left of
Seed.
2 Continue clicking the button until you obtain a tree you like.
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3 Set the Density spinner to 0.75 and press Enter.

This value reduces the number of leaves on the tree.

4 If you need to,
move the tree trunk along its X axis again so it
is properly centered on the vertical midpoint of the safe area.
5 Restore the Slate Material Editor window.
6 On the Noise Parameters rollout, change Color #1 and Color #2 for the
Leaves sub-material to red and orange respectively.

7 Render the Perspective viewport.
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Tree object with fall-like parameters

By reducing the number of leaves and adjusting the leaf colors, you have
created a tree that is suited to a fall scene.
8 On the Rendered Frame Window, click Save Image, then on the Save
Image dialog File Name field, type my_elm_fall.tif and click Save. Be sure
to specify the 8-bit and alpha channel options.
At this point, you could create as many different sizes, leaf density,
pruning level, colors, and species of trees as you like to be referenced by
the particle system. In this tutorial, however, you already have a dozen
tree types made for you, sufficient to create a convincing-looking forest.
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Save the scene:
■

For future reference and adjustments, save the scene as my_elmtree.max.

Creating a Particle System
Now that you have set up the images you want to manage using a particle
system, it is time to create the particle system itself.
Set up the lesson:

■

On the Quick Access toolbar, click
(Open File), navigate to the
\scenes\rendering\particle_trees folder, then open ptrees_basics.max.
NOTE If a dialog asks whether you want to use the scene’s Gamma And LUT
settings, accept the scene Gamma settings, and click OK. If a dialog asks
whether to use the scene’s units, accept the scene units, and click OK.

The scene consists of a simple plane on which you will place the
particle-based trees. It also includes a Daylight system for outdoor
illumination, and a camera.
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Create a particle system:

1 On the
Create panel, click
(Geometry). Open the Objects
drop-down list, and choose Particle Systems.

2 On the Object Type rollout, click PF Source to turn it on. In the Top
viewport, drag anywhere outside the plane to place the Particle Flow
source icon.
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The size and location of the source icon is not important, since the
particles will be generated from the plane object.
3 Right-click to end object creation.

4 Go to the
Modify panel. In the Emission rollout ➤ Quantity
Multiplier group set the Viewport % spinner to 100.0.
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When the Viewport Quantity is 100 percent, the viewports display every
particle in the system. For an effect such as smoke or fluid, this could
slow down 3ds Max Design performance, but for the particle-tree forest,
there are not that many particles, and you want to be able to see all of
them.
5 On the Setup rollout, click Particle View.
TIP You can also display Particle View by pressing 6 on your keyboard.
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Particle View manages a particle system and helps you visualize the
particle source and parameters, as well as events that influence a particle’s
appearance and behavior during its life span.
Initially, the system contains two events: the source that you just created,
and a default Event 001.
6 In Event 001, click the Birth 001 operator to highlight it.

On the right of Particle View, the Birth 001 rollout displays parameters
that relate to particle creation. The Emit Start and Emit Stop spinners
indicate that particle generation will start at frame 0 and end at frame
30. The Amount spinner indicates that 200 particles will be generated by
the system.
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7 Drag the time slider to see how the default particles are generated.

Particles emanating from the emitter object
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By default, there are a large number of particles that fall downward from
the Particle Source icon. You need to modify the Birth 001 parameters so
that the system generates only six particles that remain stationary at all
times.
Change the particle settings so particles are stationary, with visible geometry:
1 On the Birth 001 rollout, set Emit Stop to 0 (this ensures that the particles
do not pop up over time) and set the Amount spinner to 6, so that only
six particle trees are created.

2 In Particle View, click the Speed 001 operator to highlight it, then
right-click and choose Delete, since you do not want the particle trees to
move.
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3 Delete the Rotation 001 operator as well, since the orientation of the
particles will be driven by the camera position.
4 The “depot” is the list of operators and tests that appears at the bottom
of the Particle View window. Drag a Position Object operator from the
depot and in Event 001, drop it directly over the Position Icon 001 operator.
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3ds Max Design displays a red line to indicate you are replacing the
original operator with the new one.
5 Click the new Position Object 001 operator to highlight it. In the Position
Object 001 rollout ➤ Emitter Objects group, click Add. In any viewport,
click the Plane01object.
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Before, particles were emitted from the particle source icon. Now, particles
are emitted from the Plane01 object: You can see them scattered about
the plane’s surface.
6 Click the Display 001 operator to highlight it. On the Display 001 rollout,
open the Type drop-down list, and choose Geometry.

It is now easier to visualize the particles, although soon you will be
replacing these shapes with tree images.
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7 Click the Position Object 001 operator again and on the Parameters panel,
scroll down to the Uniqueness group. Click New to change the positioning
of the particles. Continue clicking the button until you get a grouping
you like.

Change the particles to shapes that face the camera:
1 From the depot, drag a Shape Facing operator directly over the Shape 001
operator to replace it.
2 Click the Shape Facing 001 operator to highlight it. In the Size/Width
group, make sure In World Space is chosen, then change the value of
Units to 40.0, and press Enter.
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This value increases the size of the particles.
3 In the Look At Camera/Object group, click the button labeled “None”
and in any viewport, click the Camera01 object.
The particles, which previously lay flat on the plane emitter, now face
the direction of the Camera01 object.
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NOTE To refresh the scene properly, you might need to adjust your view in
the Camera01 viewport, using any viewport navigation control.
4 On the Shape Facing rollout, open the Pivot At list, and choose Bottom.

5 At the bottom of the Size/Width group, change the value of Variation %
to 25.0.

This creates a range of particle sizes. The tree images mapped onto each
particle will also vary in size.
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Next, you will map the tree images onto the particles. You will do so
using the Material Static operator, the best choice for a material that is
not animated.
Map tree images to the particles:
1 From the depot, drag a Material Static operator to the PF Source 001 event.
Drop it just below the Render 001 operator. A blue line indicates the point
of insertion.

NOTE You are defining the material at the PF Source 001 level because you
want all the trees to share the same material throughout the particle life span.
If you wanted to assign the trees different materials based on a specific particle
event, you would have dragged the Material Static operator to the appropriate
event box.
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2 Open the

Slate Material Editor.

3 Drag an Arch & Design entry from the Material/Map Browser into the
active View.
4 Double-click the Arch & Design material node to display its parameters.
5 Name the new material Trees.
6 On the Templates rollout, open the drop-down list and choose Matte
Finish.
With Matte Finish, the trees will not pick up any reflection from
neighboring objects.
7 Drag a Bitmap entry from the Browser into the active View.
3ds Max Design opens a file dialog. Navigate to \sceneassets\images and
choose elm_summer.tif.
8 Wire the new Bitmap node to the Diffuse Color socket of the Trees
material.

9 Double-click the Bitmap node so you can see its parameters.
10 On the Coordinates rollout, turn off Use Real-World Scale if it is on, and
make sure Tiling is set to 1.0 for U and V.
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This step ensures that the image area matches the size of the particle.
11 Click the Trees material node to make it active, then on the Slate Material

Editor toolbar, click

(Show Map In Viewport) to turn it on.

12 Move Particle View and the Slate Material Editor so you can see both
windows. In Particle View, highlight the Material Static 001 operator, then
drag from the output socket of the Trees material node, and in Particle
View, drop the material on the Assign Material button (initially labeled
“None”). When 3ds Max Design asks whether to use a copy or an instance,
make sure Instance is chosen, then click OK.
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TIP If the tree maps don’t appear in the shaded viewport right away, turn
off Assign Material and then turn it back on.
Now the tree map is now applied to all particles in the scene. Their
background remains visible: You still need to make them cutouts by using
the alpha-channel information.

Tree map applied to all particles in the scene
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Use cutout mapping for the tree particles:
1 In the Slate Material Editor, Shift+drag the Bitmap node to make a copy
of it.

2 Wire the new Bitmap copy to the Cutout Map socket of the Trees material
node.
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3 Double-click the new Bitmap node so you can see its parameters.
4 On the Bitmap Parameters rollout, in the Mono Channel Output group,
choose Alpha, and then in the RGB Channel Output group, choose Alpha
As Gray.
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Now the background of the tree bitmap no longer appears.

Next, you will boost the amount of self-illumination so that all parts of
the tree can still be visible even when the leaves and branches are not in
direct sunlight.
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Set particle tree self-illumination:
1 In the Slate Material Editor, wire the original Bitmap node (the one you
are using for colors, not for the alpha channel) to the Self-Illumination
Map socket of the Trees material node.
2 Double-click the Trees material node so you can see its parameters.
3 On the Self Illumination (Glow) rollout, turn on Self Illumination.

At this point, the self-illumination has no real effect, because the default
Luminance values are overpowered by the Daylight system exposure
value set for your exterior scene.
4 In the Luminance group, leave Unitless chosen, and enter a value of
5000.0.
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5

Close the Slate Material Editor.

6 Render the Camera01 viewport.
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Particle trees with self illumination added

Now the self-illumination of the trees is apparent.
Save your work:
■

Save the scene as mytrees.max.

Defining Tree Shadows
In this lesson, you will instruct the particle system to generate a second set of
trees, with only its shadows visible. You will then orient the shadows so they
continually face the light source in the scene. As a result, the shadows will
appear to belong to the first set of visible trees.

1028 | Chapter 7 Rendering Tutorials

Set up the lesson:
■

Continue working on the scene file you saved in the previous lesson, or

open ptrees.max.
Generate a second set of tree particles:
1 Press 6 to display Particle View, drag a Spawn operator from the depot
to Event 001, and drop it at the bottom of the event, below the Display
001 operator.

The Spawn operator will generate a new set of particles from the ones
you defined in Event 001.
2 Highlight the Spawn 001 operator to display its parameters.
In the Spawn 001 rollout ➤ Spawn Rate And Amount group, the Once
option should be chosen, indicating that only one set of particles will be
created.
Set the particles to follow the sun:
1 In Event 001, click to highlight the Shape Facing 001 operator, then
right-click it and from the pop-up menu, choose Copy.
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2 Right-click an empty area of the event-display area below Event 001, and
from the pop-up menu, choose Paste.

3ds Max Design creates a new event, called Event 002, with an operator
that also instructs the particles to face the camera. Now you will modify
this operator so that the particles will face the scene light source instead
of the camera.
3 Click the new Shape Facing 002 operator so you can see its parameters. In
the Shape Facing 002 rollout ➤ Look At Camera/Object group, click the
Pick button (which at first is labeled Camera01), then in any viewport,
click the [Daylight01] Sun01 object.
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4 In Event 002, click the Display 002 operator. On the Display 002 rollout,
click the color swatch and use the Color Selector controls to choose a red
color.

This color is used to display the shapes of the second set of particles in
wireframe views. It will not be visible in renderings. The red color will
help you better identify the second set of particles.
5 Open the Type drop-down list and choose Geometry.
6 In Event 001, click the Display 01 operator and choose a dark blue color,
to better see the first set of particles in wireframe view.
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7 Click the blue handle to the left of the Spawn operator and drag it to the
Event 002 input (the empty circle that protrudes from the top of Event
002).

With this connection, Event 001 spawns a set of particles once and sends
them to Event 002, where they are instructed to face the sun.
8 In the Front viewport, select the camera. On the main toolbar, click

(Select And Move). In the Top viewport, move the camera about
the scene.
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Top: Camera position 1
Bottom: Camera position 2
Billboard trees (shown in blue) follow the camera position, while the shadow
particles (shown in red) do not

9 Press Ctrl+Z to undo the camera movement.
Do a test rendering:

■

Render the Camera01 viewport.
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Rendered scene showing two sets of particle tree shadows

There are now two sets of particle trees, each of which cast shadows. You
need to hide the shadows of the particle trees that face the camera, then
hide the particle trees that face the sun but keep their shadows visible.
Fix the visibility of shadows:
1 Highlight the header of Event 001, then right-click it and from the pop-up
menu, choose Properties.
Remember that in Particle View, Event 001 represents the particle trees
that face the camera, while Event 002 represents the particle trees that
face the sun.
2 In the Object Properties dialog ➤ General panel ➤ Rendering Control
group, click By Layer (if By Object is not already active) and turn off
Receive Shadows, Cast Shadows and Apply Atmospherics. Click OK.
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3 Highlight the header of Event 002, then right-click it and from the pop-up
menu, choose Properties.
4 In the Object Properties dialog ➤ General panel ➤ Rendering Control
group, click By Layer (if By Object is not already active) and turn off
Inherit Visibility, Visible to Camera, Visible to Reflection/Refraction,
Receive Shadows and Apply Atmospherics. Click OK.
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5

Render the Camera01 viewport again.

Particle trees with only one set of shadows visible

The rendering shows one visible set of particle trees, and shadows cast
by the second set of trees, which are otherwise hidden.
Save your work:
■

Save the scene as my_ptrees_shadows.max.

Introducing Variety
The trees in your scene are casting shadows properly, but while they vary in
size, they are all identical in shape and color. To make a convincing forest,
you need to add a few more tree varieties into the mix.
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Set up the lesson:
■

Continue working on the scene file you saved in the previous lesson, or

open ptrees_shadows.max.
Adjust the camera view:

1 On the main toolbar, click
(Select And Move). In the Front
viewport, move the Camera01 object until it is closer to the ground.

2 Activate the Camera01 viewport, and
are in full view.
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dolly forward until the trees

Increase the number of tree particles:
1 In Particle View, in Event 01, click the Birth 01 operator to highlight it.
2 On the Birth 01 rollout, change the Amount value to 25.

3

Close the Particle View window.
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Now the particle system generates 25 trees. Each particle uses the same
image of the elm tree you selected earlier. Next, you will change the
particles to reference three different types of trees.
Create a Multi/Sub-Object material to contain multiple tree maps:

1 Open the

2

Slate Material Editor.

Zoom out in the active View, then drag a Multi/Sub-Object from
the Browser into the active View, and drop it to the right of the Trees
material.
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By default, the Multi/Sub-Object material contains 10 entries, each of
which allows you to specify a sub-material. Fortunately, you don’t need
all of these.
3 Drag box to select all of the submaterial nodes, then press Delete.
4 In the Slate Material Editor, click (Zoom Extents), then move the
Multi/Sub-Object material node closer to the main Trees material node.
5 Double-click the Multi/Sub-Object material node so you can see its
parameters.
6 Name this material Elm Trees.
7 On the Multi/Sub-Object Basic Parametrers rollout, click Set Number. On
the Set Number Of Materials dialog, change the value to 3.
You will specify three different tree types to use on the particles.
8 Wire the Trees material node to the (1) sub-material socket of the Elm Trees
node.

Now you need to create the other two sub-materials.
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Create a fall sub-material, and then another for winter:
1 Click the minus-sign (-) icon on the title bar of the Trees material node
to collapse this node display, then hold down the Shift key and drag the
Trees node to make a copy of it.

2 Click the plus-sign (+) icon on the title bar of the new material node to
open the node display again, then drag away from the input sockets to
disconnect the wired bitmaps.
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3 Click the minus-sign (-) icon to collapse the new material node again,
then Shift+drag to make another copy.
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4 Double-click the Trees material node so you can see its parameters. Change
the name of this sub-material to Elm - Summer.
5 Double-click the second material node, and change its name to Elm - Fall.

On the Slate Material Editor toolbar, turn on
In Viewport).

(Show Standard Map

6 Double-click the third material node, and change its name to Elm - Winter.

On the Slate Material Editor toolbar, turn on
In Viewport).

(Show Standard Map

7 Wire the second and third material nodes to the (2) and (3) sockets of
the Elm Trees material node to make them sub-materials as well.

Add the bitmaps for the new sub-materials:
1 Click the plus-sign (+) icon of the Elm - Fall sub-material node to open the
node, then press L so you can see all of the material tree.
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2 Drag a wire from the Diffuse Color Map socket of the Elm - Fall sub-material
node, then release the mouse. From the pop-up menu, choose Standard
➤ Bitmap.
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3ds Max Design opens a file dialog. Choose the elm tree with autumn
foliage you rendered in the previous lesson, or navigate to
\sceneassets\images and choose elm_fall.tif.
3 Wire the new Bitmap node to the Self Illumination Map socket as well.
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4 Shift+drag the new Bitmap node to make a copy of it, then wire the copy
to the Cutout Map socket of the Elm - Fall sub-material.
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5 Double-click the Bitmap node that is wired to the Cutout Map socket.
On the Bitmap Parameters rollout, change Mono Channel Output to
Alpha, and RGB Channel Output to Alpha As Gray.
6 Repeat steps 1 through 5 for the third sub-material node, this time using
\sceneassets\images\elm_winter as the bitmap.
Change the particle system to use randomly chosen trees:
1 Press 6 to display the Particle View window. Arrange the windows so you
can see both the Material Static 001 rollout on Particle View, and the
output socket of the Elm Trees material in the Slate Material Editor.
2 In Particle View ➤ PF Source 001, click Material Static 001 to highlight it.
Drag a wire from the output socket of the new Elm Trees Multi/Sub-Object
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material node, and drop it on the Material Static 001 rollout ➤ Assign
Material button.
3 On the Material Static 001 rollout, turn on Assign Material ID and Show
In Viewport.

4 Change the Material ID value from 1 to 2 and 3 to display one of the
three different tree sub-materials you set up earlier.
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Elm trees with fall colors: Material ID=2

Elm trees in winter: Material ID=3

5 To get a mix of all three tree types, choose Random.
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The Camera01 viewport updates to show a random selection of all three
tree types.

Random assortment of particle trees

6 In the Material Static 001 rollout ➤ Uniqueness group, click New
repeatedly until you obtain a mix of tree types that you like.
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7

Render the Camera01 viewport to see the result.

Save your work:
■

Save the scene as my_ptrees_various.max.

Placing the Particle Trees
In this lesson you use polygon selection to define the area in which tree
particles appear.
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Set up the lesson:

Open ptrees_placement.max.
The scene consists of an undulating terrain bisected by a riverbed and
populated by a number of particle-based trees.

■

Use polygon selection to define where trees will appear:

1

2

Maximize the Top viewport and set viewport shading mode to
Smooth + Highlights (you can press F3).

Zoom in to the river.

Notice how a few particle trees stand in or on the very edge of the river
bed.
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3

Zoom out again and select the Camera01 object.
The light blue guidelines show the camera’s field of view. Assume for the
moment that you want only a static shot, or plan to have the camera
move toward the upper-left corner of the terrain. This means there are
many particle trees elsewhere on the plane that will never be seen and
consequently do not need to be generated.

Camera field of view

Now you will use polygon selection to indicate where to place the particle
trees (within the field of view and not in or near the river).
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4

Switch back to a four-viewport layout,

object, then go to the

5 On the Selection rollout, click

6

select the Plane01

Modify panel.

(Polygon).

Click just outside the top left corner of the Plane01 object and
drag toward its center.
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7 On the main toolbar, choose

(Paint Selection Region) from the

Selection Region flyout (initially it shows
Region)).

(Rectangular Selection

8 In the Camera01 viewport, hold down Ctrl and start painting over the
polygons adjacent to the riverbank.
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Selected polygons near riverbank
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Top view, showing selection of polygons near the riverbank.

9 In the Top view, hold down the Alt key and deselect polygons at the
periphery of the camera’s field of view, as shown in the next illustration.
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Top view, with polygons beyond periphery of camera view deselected

10 On the Selection rollout, click
sub-object level.

(Polygon) again to exit the polygon

Set the particle system to use the sub-object selection:

1

Click an empty area of the Top viewport to deselect the Plane01
terrain object, then press 6 to open the Particle View window.
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2 In Event 01, click the Position Object 01 operator to highlight it (if it is not
highlighted already).
3 In the Position Object rollout ➤ Location group, open the Location
drop-down list and choose Selected Faces.

Previously, particles were generated across the entire plane. Now, the
same number of particles are generated only on the polygon faces you
just selected.
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Particle generation restricted to top left region of plane object

Because the generation area is reduced, you can reduce the total number
of particles generated.
4 Click the Birth 01 operator to highlight it. On the Birth 01 rollout, set the
Amount spinner to 50 and press Enter.
5 If you like, adjust tree placement in the Position Object 01 rollout ➤
Uniqueness group by clicking New until you see a grouping you prefer.
6 In PF Source 01, click the Material Static 01 operator to highlight it. In the
Material Static rollout ➤ Uniqueness group click New until the Camera01
viewport displays a mix of trees that looks good to you.
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7

Render your scene.

Rendered 50-tree view of the particle forest

The 50 particle trees should take just a minute or two to render. If, on
the other hand, the scene were made up of 3D trees at 30,000 polygons
each, 3ds Max Design would need to process over a million polygons:
This would require a great deal more time to render.
There is one aspect to watch out for when using particle systems to create
trees with shadows. As the next illustration demonstrates, the base of the
tree on the left does not quite match the base of its shadow.
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Tree trunk not aligned with particle
tree shadow

Recall that you created two sets of particle trees: One set oriented to face
the camera and another, hidden set that faces the sun. Depending on
the respective positions of the light source and the camera, a hidden tree
might cast a shadow that is out of alignment with the visible tree.
To solve this problem, you can rearrange tree placement by changing the
particle trees’ Seed value, or you can add objects such as rocks to obscure
unwanted detail.
Save your work:
■

Save the scene as my_ptrees_forest.max.
You can find a completed version of this scene in the
\scenes\dynamics_and_effects\particle_trees folder, called ptrees_completed.max.

Summary
Particle systems offer a fast, effective way to populate scenes with multiple
objects.
In this tutorial you used images of trees and mapped them onto billboard-sized
particles. But you could just as easily have mapped other types of images; for
example, you could use photographs of people to create a crowd scene.
When using this particle-creation technique, make sure your particles are set
to face the camera. If you need to cast shadows, generate a second set of
particles and make sure their shadows continually face the light source.
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mr Proxies
In this tutorial, you will learn how to use mr Proxy objects to create a scene
of a forest that, despite its large size, can render quickly.
You will convert trees to mr Proxy format, then give each proxy a material
you saved in a material library. Finally, you will use the Object Paint feature
to instance the proxies multiple times and distribute them across the scene.

In this tutorial, you will learn how to:
■

Save materials to a material library

■

Save objects in mr Proxy file format

■

Create mr Proxies and associate them with imported proxy files

■

Add materials to mr Proxies

■

Use Object Paint to instance and distribute mr Proxies in a scene

Skill level: Intermediate
Time to complete: 1 hour

1064 | Chapter 7 Rendering Tutorials

Creating mr Proxy Objects
mr Proxies are useful when you want to fill a scene with instances of objects
that have a high polygon count, such as 3D trees. Proxy objects save you time
and free up memory because they do not need to be converted to mental ray
format and their source objects do not need to be present during render time.
In this lesson, you convert trees to .mib format so they can be used as mr Proxy
objects.
Set up the lesson:

Click
(Open File), navigate to the \scenes\rendering\mr_proxies folder,
and open trees.max.

■

NOTE If a dialog asks whether you want to use the scene’s Gamma And LUT
settings, accept the scene Gamma settings, and click OK. If a dialog asks
whether to use the scene’s units, accept the scene units, and click OK.

Render the scene:

1

2

Zoom and

pan so the tree objects fill the viewport.

Render the scene.

mr Proxies | 1065

The eight trees in the scene show foliage from four different seasons:
winter, spring, summer, and fall. The trees in the front row are oaks, and
the trees in the back row are elms.
These trees were created and textured using the methods described in
the lesson Creating Billboard Tree Maps on page 974. The only difference
is that there was no need to center each trees in a viewport and render
it: The mr Proxy method works with referenced geometry instead of with
rendered bitmaps.
3

Close the Rendered Frame Window.

Save the materials to a library:
The tree materials that you saw in the rendering will need to be reused for the
mr Proxy objects. The best way to do this is to save the materials in a library,
so you can access them for use in various scenes and situations.

1

Open the Slate Material Editor.
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2 On the Material/Map Browser panel at the left, scroll down so you can
see the Scene Materials group. (It helps to drag the edge of the Browser
panel to make the Browser wider, too.)

The four Tree materials are the ones you want to save.
3 Right-click the Tree-Fall entry and from the pop-up menu, choose Copy
To ➤ Temporary Library.

3ds Max Design creates a Temporary Library group that appears at the
bottom of the Browser panel. The Temporary Library has a copy of the
Tree-Fall material in it.

IMPORTANT A Temporary Library such as this one lasts only as long as the
current 3ds Max Design session.
4 Right-click the Temporary Library label, and from the pop-up menu,
choose Save As.
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3ds Max Design opens a file dialog. On the file dialog, navigate if you
need to to the \materiallibraries subfolder of your Project Folder, then
enter mytrees as the library name (the file name extension for a material
library is MAT), and then click Save.

5 At the top of the Browser panel, click
(Material/Map Browser
Options). This opens a pop-up menu. On the pop-up menu, choose Open
Material Library.
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3ds Max Design opens another file dialog. In the \materiallibraries
subfolder, choose the library you just created, mytrees.mat, and then click
Open.
3ds Max Design opens a group for mytrees.mat at the very top of the
Browser panel. (The Temporary Library remains visible at the bottom of
the panel.)
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6 In the mytrees.mat group, right-click the Material #0 entry and from the
pop-up menu, choose Rename.

3ds Max Design opens a Rename dialog. Change the material name back
to Tree-Fall, then click OK.

7 In the Scene Materials group, right-click the Tree-Spring material entry.
On the pop-up menu, choose Copy To ➤ mytrees.mat.

8 In the mytrees.mat group, use Rename to name this material Tree-Spring
once again.
9 Copy Tree-Summer and Tree-Winter to mytrees.mat as well. Each time, change
the name of the material back to its original name.
10 Right-click the mytrees.mat label, and on the pop-up menu, choose the
first entry, C:\Users\...\mytrees.mat ➤ Save.
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11

Close the Slate Material Editor.
Now you have a library of materials to use for the proxy objects. The next
task is to create those proxies.

Save source objects in mr Proxy file format:

1 On the
Create panel, click
(Geometry), then open the
Objects drop-down list and choose “mental ray.”
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2 On the Object Type rollout, click “mr Proxy” to turn it on.

3 Drag in the viewport to create an mr Proxy object.
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4 Go to the
Modify panel. On the Parameters rollout, in the Source
Object group, click the Source Object button (initially labeled “None”).

In the viewport, click the Elm-Winter tree object.
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5 In the Parameters rollout ➤ Source Object group, click Write Object To
File.

3ds Max Design opens a file dialog. If you need to, navigate to the
\sceneassets\renderassets folder. Name the file My_Elm_Winter (it has a
file name extension of MIB), and then click Save.
3ds Max Design opens an “mr Proxy Creation” dialog. On this dialog,
click OK to accept the default values.

NOTE If your tree object were animated, you would use the “mr Proxy
Creation” dialog to save the object as a sequence of frames, with one .mib
file created per frame. You specify the time segment to save in the Geometry
To Write group.
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3ds Max Design briefly displays a small Rendered Frame Window while
it renders the proxy geometry.

In the viewport, 3ds Max Design displays the mr Proxy object as a point
cloud.
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6 In the Parameters rollout ➤ Display group, change the Viewport Verts
value from 128 to 512, and press Enter.
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The object outline becomes more apparent as more points are displayed,
but a denser point cloud can affect viewport performance.
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7 Change the Viewport Verts value back to 128, then turn on Show
Bounding Box to display the extents of the tree proxy.
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3ds Max Design displays the proxy surrounded by a complete bounding
box.
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8 With the proxy object selected, repeat steps 4 through 7 for the Elm-Spring
tree object.
When you’re done, you should have an .mib file for Elm-Spring.
If you were working from scratch, you would repeat the steps for every
tree in the scene, but to speed things up a little, we have created .mib files
for all the tree types. These are saved in the \sceneassets\renderassets folder.
You will use these proxies in the next lesson.
9 Do not save the current scene file.
The work you needed to save is contained in the MIB files and their
associated bitmaps.
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Loading Proxy Files Into a Scene
In this lesson, you create a group of mr Proxy objects, and associate each proxy
with an .mib file such as the ones you saved in the previous lesson. Then you
assign each proxy a material from your mytrees material library.
Set up the lesson:
1 If you have a scene open from the previous lesson, do not save it.

2

Open proxy_trees_start.max.
The new scene features a rolling terrain intersected by a riverbed.

Create an mr Proxy object and associate it with an .mib file:

1 Go to the
Create panel and click
(Geometry). Open the
Objects drop-down list, and choose “mental ray.” On the Object Type
rollout, click “mr Proxy.”
2 In the Top viewport, click and drag anywhere to the right of the plane
object.
The proxy object you create can be of any size.
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3 Go to the

Modify panel and rename the object Elm-Winter.

4 Inthe Display group, turn on Show Bounding Box.

5 In the Parameters rollout ➤ Proxy File group, click the
button.
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browse

3ds Max Design opens a file dialog. Go to the \sceneassets\renderassets
folder, choose elm1_winter.mib, then click Open.

The scale of the imported proxy file is too large.
6 In the Parameters rollout ➤ Proxy File group, set the Scale spinner to
0.1 to reduce the proxy to one-tenth its default size.
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Copy the original proxy and change the tree types:

1 In the Top viewport,
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Shift +move the proxy to the right.

2 In the Clone Options dialog ➤ Object group, make sure Copy is chosen,
then set Number of Copies to 3. Click OK.
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3

Select a copied proxy and on the
it Elm-Spring.

Modify panel, name

4 In the Parameters rollout ➤ Proxy File group, click the
button and use the file dialog to choose elm2_spring.mib.

browse

5 Repeat steps 3 and 4 for each of the two remaining proxies, rename them
Elm-Summer and Elm-Fall, and associate them with their corresponding
.mib files.

6

Select all four proxy objects and Shift+move them once,
downward. In the Clone Options dialog, make sure Copy is chosen, then
click OK.

7 Repeat steps 3 and 4 for each of the new proxies. Rename them
Oak-Winter, Oak-Spring, Oak-Summer, and Oak-Fall, and associate them
with their corresponding .mib files.
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Render the result:
1 Activate the Camera01 viewport. Press P to make it a Perspective view.

Zoom,

pan, and

all eight tree proxies, then

orbit so you have a good view of

render the Perspective viewport.

Tree proxies with the same material

The tree proxies have different shapes and leaf densities, but their leaves
and trunks are all the same color. In the next procedure, you will associate
each proxy with a material you saved earlier in the material library.
2 Minimize the Rendered Frame Window.
Assign materials to the tree proxies:
1 From the main menu, choose Rendering ➤ Material/Map Browser.
2 In the Top viewport, Click and Ctrl+click to select Elm-Winter and
Oak-Winter, then drag the Tree-Winter material from the Material/Map
Browser ➤ mytrees.mat group, and drop this material on your selection.
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3ds Max Design opens an Assign material dialog. On the dialog, make
sure Assign To Selection is chosen, then click OK.

3 Repeat the previous step for each of the spring, summer, and fall pairs of
tree proxies, using the appropriate library material.
4

5

Close the Material/Map Browser.

Render the Perspective viewport once again.
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Tree proxies after receiving materials from the material library

Now you have eight different types of trees that are ready to be multiplied
and distributed across your scene.
6

Close the Rendered Frame Window.

7 Change the Perspective viewport back to the Camera01 view.
Save your work:
■

Save your file as my8_trees.max.

Next
Using Object Paint to Distribute the Trees on page 1089

Using Object Paint to Distribute the Trees
Now that you have your tree proxies properly defined, you need a way to
instance them multiple times and distribute them across your terrain. You
can do this by using the Object Paint feature, which is new to Autodesk 3ds
Max Design 2011. Object Paint lets you paint objects onto other objects: In
this lesson, you will paint proxy trees onto the terrain object, Plane01.
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Set up the lesson:

■

Continue from the previous lesson or

open 8_trees.max.

Choose the trees with which you will paint:

1 If the ribbon isn’t already open, then on the main toolbar click
(Graphite Modeling Tools). Click the
you can see the full height of the ribbon.

expand/collapse icon until

2 On the ribbon, click the Object Paint tab.

3 On the Paint Objects panel, click

(Edit Object List).

3ds Max Design opens a Paint Objects dialog.
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4 On the dialog, click Add.
3ds Max Design opens a Select Objects dialog.
5 Click and Shift+click to select all eight tree objects, and then click Add.

mr Proxies | 1091

The grove you paint in this lesson will be an eclectic one. Another time,
you might want to choose only spring trees, for example, or fall ones.
6

Close the Paint Objects dialog.
Now you are able to paint the trees onto the terrain. By default, the Paint
Objects tool uses the first object in the set you selected.
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Set up the Object Paint tool:
1 On the Paint Objects panel, choose All, Randomly from the drop-down
list.

When you paint, the trees will appear in random order.
2 Also on the Paint Objects panel, open the Paint On drop-down list and
choose Selected Objects.

3 On the Brush Settings panel, set Spacing to 40.00 units.

4 Also on the Brush Settings panel, open the Align drop-down list, and
turn off Align To Normal.
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We want the trees to grow vertically, not to lean wherever the terrain is
not flat.
5 The right-hand side of the Brush Settings panel has three groups of
controls: Scatter, Rotate, and Scale. In this tutorial, we don’t use the
Scatter tools, but do make adjustments to the other two groups.
In the Brush Settings panel ➤ Rotate group, click the drop-down arrow
next to the Z coordinate field, and in the drop-down list, turn on Random
Z.

When you paint, the trees will have a random amount of rotation about
their vertical (Z) axis.

6 In the Brush Settings panel ➤ Scale group, make sure
(Uniform Scale)) is turned on, then open the
drop-down list, and choose Random.
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axis Lock
Scale Type

After you choose Random, the Scale group shows a range of values for
the axes; because Axis Lock is on, you can change only the X axis values.
7 Also in the Scale group, set the minimum X value (on the left) to 60 and
the maximum X value (on the right) to 160.

The trees will vary in height and girth from 60 units to 160.
Now you are ready to begin painting trees.
Paint the proxy trees:

1

Select the terrain object, Plane01.
Remember that Object Paint is set to paint onto the currently selected
object.

2

Maximize the Top viewport, and click
Selected).

3 On the Paint Objects panel, click to turn on

(Zoom Extents

(Paint).
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4 Hold down the mouse button as you drag over the terrain object. 3ds
Max Design adds copies of trees to the scene. The trees are at least 40
units apart.

You can paint the trees densely together, but on the near bank of the
stream, avoid painting directly in front of the camera’s line of sight.

1096 | Chapter 7 Rendering Tutorials

5

Minimize the Top viewport, then activate the Camera01 viewport,

and

render the scene.
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TIP If any of the trees appear to be floating above ground level, then on the
Paint Objects panel, set the Offset value to a negative value; for example,
–3.0.
6 One good feature of Object Paint, is that you can preview the scene with
renderings before you commit.

■

If you are not happy with the results, click
(Cancel).
3ds Max Design removes the trees you painted, allowing you to start
over.

■

When you are happy with the results, click
(Commit).
3ds Max Design adds the trees to the scene, as copies of the original
tree proxy objects.
If you like, experiment with other options, such as painting with only
trees from a certain season, as we suggested earlier, or changing the
range of Scale X to paint a greater (or lesser) range of variation in size.

Save your work:
■

Save the scene as my_forest_painted.max.
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You can compare your work with a finished version of this scene,
proxy_trees_final.max.

Summary
When you render with the mental ray renderer, mr Proxies are a useful way
to create a large scene with many instances of a similar object. While mr Proxy
objects cannot be edited directly, they offer the advantage of freeing up
memory and speeding up render time.
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1100

Interoperability Tutorials

8

One of the strengths of 3ds Max Design is its ability to share data with other Autodesk products.
The FBX data format is one of these solutions; so are the AutoCAD DWG/DXF formats, and
the SAT format for ACIS solids. In this chapter, you learn how 3ds Max Design can share data
with Autodesk Revit Architecture, AutoCAD, and Autodesk Inventor.

Revit model rendered with 3ds Max Design

1101

Using Autodesk Revit
This tutorial is intended for those who want to take designs created in Autodesk
Revit and add professional rendering effects in 3ds Max Design.
To share it with 3ds Max Design, you export Revit data as an FBX file. This
format is preferable to others (such as DWG), because it can include scene
metadata as well as geometry, material, and lighting information.
In 3ds Max Design, you can either import the FBX file, or
use File
Link Manager to maintain a live link with the project in Revit. This gives you
the opportunity to update the scene in 3ds Max Design after you use Revit to
edit the scene. This tutorial demonstrates the File Link technique.

The beach house in a Revit view

In 3ds Max Design, you can use materials, lighting tools, and cameras to create
photorealistic renderings based on the Revit model.
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Interior of the beach house rendered in 3ds Max Design

In this tutorial, you will learn how to:
■

Prepare scene files created in Autodesk Revit for export to 3ds Max Design.

■

Link the Revit FBX to 3ds Max Design, carry out test renders and make
required adjustments.

■

Add a Sky Portal to improve the interior daylight illumination of an
enclosed structure.

■

Edit the linked scene in Revit and see the results in 3ds Max Design.

■

Use the Scene Explorer to organize objects created in Revit.

■

Edit properties of Revit objects in 3ds Max Design.

Skill level: Intermediate
Time to complete: 1 1/2 hours
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NOTE The time to complete estimate does not take into account the time required
to render the images of scenes you develop in this tutorial. If you wish to render
the suggested images, add approximately six hours to the estimate.

Preparing the Scene in Revit
In this lesson, you use Revit to adjust some settings before enhancing the
scene in 3ds Max Design.
To complete this lesson, you must have Revit installed on your workstation.
If you do not have Revit installed, proceed directly to the next lesson, Linking
a 3ds Max Design Scene to the FBX File on page 1127.
Set up the lesson:

1

Open the Revit application and navigate to the
\scenes\interoperability\using_autodesk_revit_files folder. Highlight
beachhouse.rvt and click Open.
NOTE You can open this RVT file with a version of Revit that is earlier than
Revit 2010, but be aware that the user interface has changed (in particular,
the ribbon controls), and won’t exactly match the steps that are shown this
lesson.
The beachhouse.rvt project features the model of a bungalow situated on
a beach. In the procedure that follows, you will use options in Revit to
change the model’s roof material, in preparation for exporting the scene.
NOTE Even though you can modify materials in 3ds Max Design, it is a good
idea to make your changes in Revit if this is the application you are the most
comfortable using.

2 Use the SteeringWheels controls to zoom in on the beach house.
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Change the roof material in Revit:

1 Click to select the roof object, then on the ribbon, click
Properties).

(Element

2 On the Element Properties dialog, click Edit Type.

3 On the Type Properties dialog ➤ Type Parameters group ➤ Construction
rollout ➤ Structure item, click Edit.
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4 On the Edit Assembly dialog, click << Preview.
Revit displays a panel to the left, showing a detailed cross-section of the
roof.
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5 In the Layers group ➤ Material column, click the top item in the list,
Roofing - Asphalt.

After you click the Roofing - Asphalt entry, a
Click this icon.

browser icon appears.

Revit opens a Materials dialog.
6 On the Materials dialog, click the Render Appearance tab to display a
thumbnail of the roof shingle material.
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7 In the Materials group, scroll down in the list and choose Roofing - Slate.
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NOTE If this material is not available on your system, click Replace and choose
an alternate material from the Render Appearance Library.
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8 Click OK on all the open dialogs to exit the material edit controls.
The texture and mapping coordinates of your selected material will be
properly transferred to 3ds Max Design, with no further intervention
required on your part.
Check light-object properties in Revit:
Like materials, all light-object properties in the Revit scene are accurately
transferred to 3ds Max Design. Therefore, it is best to make sure that the lights
you have in the current scene possess the properties you want to use in 3ds
Max Design.
1 In the Project Browser panel at the left, under Views ➤ Ceiling Plans,
double-click Level 1.
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Revit displays the plan of the ceiling.

2

Zoom in to get a closer view of the ceiling plan for the main part
of the house.

Preparing the Scene in Revit | 1111

There are seven ceiling lights inside the house, and three outside on the
porch.
3 Click to select any ceiling light object in the scene.
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Revit displays a description of the light object in the Element panel on
the ribbon.

4 On the ribbon, click
(Element Properties) and on the Instance
Properties dialog, click Edit Type.
5 On the Type Properties dialog ➤ Type Parameters group, scroll down to
the Photometrics rollout and review the parameters displayed.
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These values, particularly Initial Intensity and Color, will affect the
rendered result in 3ds Max Design, so be sure these parameters contain
the result you are looking for. (You can later update these values in 3ds
Max Design, if you need to.)
6 Click the Initial Intensity button to view more detail on light intensity.

NOTE 3ds Max Design uses Lumens rather than Watts to measure light
intensity. When a Revit scene is imported into 3ds Max Design, all wattage
is converted into Lumens, but intensity of the light object is not affected.
7 Click OK to exit the dialogs.
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8 Back in the Level 1 view, click to select the Pendant Light object. This is
the light at the lower right of the ceiling plan, in the dining area.

9 On the ribbon, click
Properties dialog.

(Element Properties) to open the Instance

10 Click Edit Type and review the Photometric properties, as you did for the
ceiling light object.
11 Click OK to exit the dialogs.
Create a camera:
By default, the 3D view in Revit uses an isometric perspective, but an FBX file
has to contain a single camera view. Therefore, you must create at least one
camera view in Revit before you export the scene. In this procedure, you create
a camera for an exterior viewpoint.
NOTE Although you can create multiple cameras in Revit, you can export only
one camera view to the FBX file.
1 In the Project Browser panel, navigate to Views ➤ Floor Plans and
double-click Level 1.
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2

Zoom so you have a view of the house and the area around it.
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3 On the ribbon, go to the View tab.

4 On the Create panel, open the
choose Camera.

3D View drop-down list, and
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5 Place the camera by clicking below the reference object at the left of the
scene, then click a point along the front wall of the house, to the left of
the double doors.
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Revit creates a camera view. This is the view you will initially use to render
your image in 3ds Max Design. It also changes the ribbon to show the
Modify Cameras tab.
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6 Click
(Element Properties) and in the Element Properties dialog
➤ Identity Data rollout ➤ View Name field, change the name of the
camera to Exterior.

7 Scroll down to the Extents rollout, turn off Far Clip Active, then click
OK.
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With Far Clip Active turned off, the camera will be able to detect the
scene terrain beyond the bungalow model. As with light and material
properties, you can also modify clipping parameters in 3ds Max Design
if you need to.

Camera view with clipping turned off, showing scene background

TIP If you want to adjust how the house is framed in the camera view, use
the SteeringWheels Look and Walk tools to move the camera.
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Set up rendering and the sun position:

1 Below the view, click

(Show Rendering Dialog).

Revit opens a Rendering dialog.
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Most of the rendering values do not need to be changed, since the actual
rendering of the scene will take place in 3ds Max Design. The Scheme
setting in the Lighting group is one possible exception.
If you choose Exterior: Sun Only from the Lighting group ➤ Scheme
drop-down list, then in the 3ds Max Design scene only the Daylight
system will be turned on and all the man-made light objects will be turned
off. Conversely, if you choose Interior: Artificial Only, only the interior
man-made light objects will be used in the scene and the Daylight system
will be turned off.
2 For this tutorial, we do not want to use the interior lights yet, so leave
Scheme set to the default value, Exterior: Sun Only. (You will turn the
man-made lights back on in 3ds Max Design, when you need them.)
3 For the Lighting group ➤ Sun setting, open the Sun drop-down menu
and choose Edit/New from the list of presets.

Revit opens a Sun And Shadows Settings dialog, where you will set the
geographic location and time of day for the position of the sun created
by the daylight system.
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4 On the Sun And Shadows Settings dialog ➤ Still tab, Sunlight From Top
Right is automatically selected from the list of single-position presets.
(The Single Day and Multi-Day tabs let you choose presets that animate
the position of the sun over the course of one or more days.)
5 With Sunlight From Top Right selected, click Duplicate.
Revit opens a Name dialog for the new preset.
6 In the Name dialog, type East Coast, then click OK.

This name is appropriate because you want the Daylight system to show
the actual sun position at Cape Cod in mid-afternoon.
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7 In the Sun And Shadow Settings dialog ➤ Settings group, choose By
Date, Time and Place.
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8 Leave Place set to Boston, MA since this city is in geographic proximity
to Cape Cod. Leave the Date field set to 5/10 and change the Time field
to 3:17 PM, then click OK.
9

Close the Rendering dialog.
Now you are ready to export the scene file in FBX format.

Export the scene:
To export from Revit to the FBX format, you need to be in a 3D view, such as
the Exterior camera view you have just created.

1 Open the

Application menu and choose Export ➤ FBX.

NOTE At this point, Revit might prompt you to save the project. You don’t
need to save the project to proceed with this tutorial.
2 Revit opens an Export 3ds Max (FBX) dialog. In the File Name/Prefix
field, change the name of the file to beachhouse. If you need to, navigate
to the \import\Revit_files folder (not one of the subfolders), then click
Save to export the scene.
3 Minimize Revit but don’t close it, as you will use it again later in this
tutorial.

Next
Linking a 3ds Max Design Scene to the FBX File on page 1127

Linking a 3ds Max Design Scene to the FBX File
In this lesson, you link the beach house model to 3ds Max Design, adjust the
daylight, and add more materials to the scene.
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Set up the lesson:

1

Start 3ds Max Design.

2 If you did not complete the previous lesson, or you skipped it because
you don’t have Revit installed, do the following:
■

Use Windows Explorer to copy the beachhouse.fbx file from the
\import\revit_files\original_fbx subfolder to the main \import\Revit_files
folder. This file has been set up for you.

Adjust the system units:
1 On the main menu, choose Customize ➤ Units Setup.
3ds Max Design opens the Units Setup dialog.
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2 On the Units Setup dialog, click System Unit Setup.
3ds Max Design opens the System Unit Setup dialog.
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Typically you don’t need to use the System Unit Setup dialog. The
exception is when you are importing or opening scenes with a known
scale that is different from the typical scale of a 3ds Max Design scene.
That is the situation here: Revit always exports FBX files with feet as the
unit, so to avoid having 3ds Max Design rescale the FBX model when
you import it or link it, you need to set the scale of 3ds Max Design to
match that of the FBX file.
3 In the System Unit Scale group, open the drop-down list and choose Feet.

4 Click OK.
5 On the main Units Setup dialog, in the Display Unit Scale group, choose
Metric.
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Unlike the System Unit Scale, display units affect only how units are
displayed in the 3ds Max Design interface. For this scene, we will work
with metric values.
Link the FBX file:

1 From the
Manager.

Application menu, choose References ➤ File Link

3ds Max Design opens the File Link Manager dialog.
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2 On the File Link Manager dialog ➤ Attach tab, click File.
3ds Max Design opens a file dialog.
3 Navigate to the \import\Revit_files folder and choose beachhouse.fbx. This
is the file you exported from Revit in the previous lesson (or if you skipped
the Revit lesson, it is the file you copied from the \original_fbx folder).
Click Open.
3ds Max Design sets up beachhouse.fbx as the file to attach.
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4 On the File Link Manager dialog, click the Presets tab.

The Presets tab lists a number of presets for linking both FBX and DWG
files. On the main Attach tab, you can choose a preset from the Preset
drop-down list. You use the Presets tab to edit presets or add a new one.
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5 On the Presets tab, scroll to the right so you can see the entry for Autodesk
Revit FBX - Combine By Revit Family Type. Click to highlight this entry,
and then click Copy.

6 In the New Settings Preset dialog that appears, name the new preset Revit
Family Type With Materials.

7 On the Presets tab, click to highlight the preset you just created, and then
click Modify.

1134 | Chapter 8 Interoperability Tutorials

8 On the File Link Settings: FBX Files dialog, click to turn on both the
options in the Material group, and then click Save.
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These options ensure that 3ds Max Design materials are preserved when
you link a scene or reload a linked scene.
9 Go back to the Attach panel, and choose Revit Family Type With Materials
from the Preset drop-down list.
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10 Click Attach This File.

While 3ds Max Design links the FBX file, a progress bar appears in the
status-bar area of the 3ds Max Design window, and after some processing
the FBX scene appears in the viewports.
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11 On the File Link Manager dialog, go to the Files tab.

The Files tab shows that beachhouse.fbx is linked to the 3ds Max Design
scene. You will use this tab again after making changes to the scene in
Revit; for now, you are done with the File Link Manager.
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12

Close the File Link Manager dialog.

Adjust the daylight illumination:
1 In the Perspective viewport, click the Point-Of-View (POV) viewport label
(at first, it’s labeled “Perspective”), and choose Cameras ➤ 3D View:
Exterior.
The viewport switches to the viewpoint of the camera you set up in Revit.

The light objects are visible in the bungalow, but they are turned off
because you specified a sun-only export format.
2 Press H. In the Select From Scene dialog, highlight the SunAndSky-002
object, then click OK.

3 Go to the
Motion panel. On the Control Parameters rollout,
notice the settings.
The Location is properly set to Boston and the Time group ➤ Month,
Day, Hours, and Mins fields all show the daylight values you set in Revit.
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The only change you need to make to the sun is to correct its orientation
in the sky, so its rays will be directed onto the terrace and into the living
room.
4 In the Location group ➤ North Direction field, type 300.
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Set the gamma level and add an exposure control:
1 Make sure the 3D View: Exterior viewport is active, then on the main

toolbar, click

(Rendered Frame Window).

2 On the Rendered Frame Window, click
(Environment And Effects
Dialog (Exposure Controls)) to open the Environment And Effects dialog.
Here, you will set the proper exposure for the scene.
3 On the Exposure Control rollout, choose “mr Photographic Exposure
Control” from the drop-down list.
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4 On the “mr Photographic Exposure Control” rollout, scroll down so you
can see the Gamma / LUT Settings group at the bottom of the rollout.
Click Setup.

5 3ds Max Design opens the Preferences dialog to the Gamma And LUT
tab. Turn on Enable Gamma/LUT correction. Make sure that Gamma is
chosen, and that the gamma value is set to 2.2.
Turn on both options in the Materials and Colors group as well: Affect
Color Selectors and Affect Material Editor.
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Adding gamma correction improves the appearance of renderings.
6 Click OK to close the Preferences dialog.
7 Near the top of the “mr Photographic Exposure Control” rollout ➤
Exposure group ➤ Preset drop-down list, choose Physically Based
Lighting Outdoor Daylight, Clear Sky.

8 Also on the “mr Photographic Exposure Control” rollout, set the value
of Shutter Speed to 250.0 (1/250 Sec.) and the value of Aperture (f-Stop)
to 5.6.

These settings correspond to those you would use with a film camera in
comparable lighting conditions.
9 On the Exposure Control rollout, make sure Active is turned on, then
click the Render Preview button to quickly check how your exposure
preset will affect the scene.
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10 The result seems fine, so in the Rendered Frame window, click Render.

The house looks good but the terrain appears too regular because it was
not optimized in Revit. In the procedures that follow, you will replace
the terrain material with a material you create in 3ds Max Design.
11

Close the Rendered Frame Window and
Environment And Effects dialog as well.
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close the

Set up the terrain object:

1

Switch to a four-viewport layout, activate the Top viewport, and

select the object that represents the terrain.

2 The terrain object is named Unknown, so go to the
and in the Name field, change the name to Terrain.

Modify panel

As the Modify panel shows, from the 3ds Max Design point of view the
Terrain object is simply a linked object from another file.

For the terrain to show a mapped texture in viewports, it needs a UVW
Map modifier.
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3 Also on the Modify panel, open the Modifier List and apply a UVW Map
modifier to the Terrain object.
4 In the UVW Map modifier Parameters rollout ➤ Mapping group, leave
the projection type set to Planar, and turn off Real-World Map Size.
Add a material to the terrain:

1 On the main toolbar, click
Material Editor.

(Material Editor) to open the Slate

TIP If you open the Compact Material Editor instead, you can change to the
Slate interface by choosing Modes ➤ Slate Material Editor.
2 Drag an Autodesk Generic material from the Material/Map Browser panel
at the left, into the active View in the center of the Slate Material Editor.
(Autodesk Generic is in the Materials ➤ mental ray group.)
3ds Max Design displays a node for the Generic material in the active
View.
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3 Double-click the new Generic material node.
The parameters for the Generic material appear in the Parameter Editor
panel at the right of the Slate Material Editor.
4 Change the name of the material to Terrain.

As you update the name in the Name field, the name in the title bar of
the material node also updates.
5 In the active View, drag a wire away from the Generic_Image component
of the Terrain material node.
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Release the mouse. 3ds Max Design opens a pop-up menu.
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On the pop-up menu, choose Standard ➤ Bitmap.
3ds Max Design opens a file dialog.
6 In the file dialog, make sure that Files Of Type is set to All Formats.
Navigate to the \sceneassets\images folder, choose terrain.jpg, then click
Open.
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Bitmap used for the seaside terrain

7 Double-click the new Bitmap node so you can see its parameters.
8 On the Coordinates rollout, turn off Use Real-World Scale.
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You need to turn off Use Real-World Scale so you can fit the map to the
surface object on a one-to-one ratio. For the same reason, leave the Tiling
values set to their default values of 1.0 in U and 1.0 in V.

9 On the Slate Material Editor toolbar, click to turn on
In Viewport).

(Show Map

NOTE If a pop-up menu appears, choose the first of the Show Map options,
Show On Terrain ( Autodesk Generic ).
10 Click the Terrain material node to make it active. On the Slate Material

Editor toolbar, click

(Assign Material To Selection).

Now the texture is visible on the Terrain object in shaded viewports.
11 Minimize the Slate Material Editor, activate the Top viewport, and press
F3 to turn on shading and see how the texture has been applied to the
Terrain object.

Add bump mapping to the terrain:
1 Press M to restore the Slate Material Editor window.
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2 In the active View, drag a wire from the output socket of the Bitmap node
(the circular control at the right of the node), and connect the wire to
the Bump_Image component of the Terrain material node.

3 Double-click the Terrain material node so you can see its parameters. Scroll
down to the Bump rollout, and click to turn on Enable.

4 Drag the Amount slider so the bump Amount has a value close to 1.0.
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The bump mapping doesn’t appear in viewports, but it will be apparent
when you render the scene.
5 Minimize the Slate Material Editor.

6 Activate the 3D View: Exterior viewport, then

render the scene.

Now the beach house is in the middle of a dry terrain that might be sand
dunes.
Next, you will add an object to the scene that represents a body of water.
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Create a surface that will become the ocean:
1 In the Top viewport, zoom out and pan so the terrain area is smaller, and
the house is at the top of the viewport.

2 Go to the
Create panel, click
Object Type rollout, click Plane.

(Geometry), and on the

3 In the Top viewport, drag to create a plane that overlaps the lower portion
of the Terrain object.
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4 Press G to turn off the grid display in the Top viewport.

5 On the main toolbar, click
(Select And Move) to make it active.
Activate the Front viewport. In the Front viewport, move the plane
vertically on the Y axis while you watch the Top viewport. Stop moving
the plane when it intersects the Terrain in a way that suggests a shoreline.
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Next, you will resize the plane so it extends out into the horizon.

6 Go to the
to Ocean.

Modify panel. Change the name of the plane object

7 On the Parameters rollout ➤ Render Multipliers group ➤ Scale field,
type 50.
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This multiplies the surface of the plane by a factor of 50 each time the
scene is rendered. Using the Scale factor can be more convenient than
typing object dimensions in the Length and Width fields.
Add a material to the ocean:
1 Press M to restore the Slate Material Editor.
2 Drag an Autodesk Water material from the Browser into the active View.
(Like the Autodesk Generic material, Autodesk Water is in the Materials
➤ mental ray group.)
3 Double-click the Water material node so you can see its parameters.
4 On the Water rollout, set Type to Generic Sea/Ocean and Color to Generic
Sea/Ocean.
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5 Move the Slate Material Editor window so you can see both the active
View and the Top viewport. Drag from the output socket of the Water
material node and drop the material onto the Ocean plane you just
created.
Now you have a water surface for the ocean in your scene. Before you
can see the ocean in a rendering, however, you need a new point of view.
6

Close the Slate Material Editor.

Add another camera:
1 Activate the Top viewport, and press F3 to turn off shading.

2 Use
(Pan) and
bungalow.

(Zoom Region) to get a close-up view of the

3 Go to the
Create panel, turn on
Object type rollout, click Target.

(Cameras), and on the

4 Click to place the camera on the terrace just in front of the double doors,
then drag downward to point its target in the direction of the ocean.
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The camera is created at ground level. Now you will raise the camera
object to eye level.
5 Activate the existing camera viewport, 3D View: Exterior, and press C to
display the viewport from the perspective of the newly created camera.

6 Go to the
Modify panel ➤ Clipping Planes group, and make
sure that Clip Manually is turned off.

7 Click
(Pan) and drag downward, causing the camera and its target
(the horizon) to rise from ground level simultaneously.
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8 Drag the Pan tool to the right slightly until you have a column in the
foreground.
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9

Render the scene.

➤

From the porch, you can see the beach and the ocean. The water is
pale in the shallows, and shades of blue where there is no underlying
terrain.

Adjust the time of day and sun position:
To see the beach at sunset, you adjust the time of day and the position of the
sun.

1 Activate the Front viewport, click
select the daylight object.

(Zoom Extents), then
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2 Go to the
Motion panel ➤ Control Parameters rollout, and in
the Time group, change the Hours value to 19, or 7 PM.
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3 In the Control Parameters rollout ➤ Location group ➤ North Direction
field, type 260.0.

Now the sun is visible in the view from the porch in the Camera001
viewport.

4 Activate the Camera001 viewport and click
Window).

(Rendered Frame
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5 On the Rendered Frame window, click
(Environment And Effects
Dialog (Exposure Controls)) to open the Environment And Effects dialog.
6 Click the Render Preview button to quickly check the rendering.

The result is too dark, because the exposure is set for full daylight.
7 In the “mr Photographic Exposure Control” rollout ➤ Exposure group,
change the Shutter Speed value to 125.0 (1/125 Sec.).

The render preview thumbnail dynamically updates and shows more
detail.
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8 On the Rendered Frame Window, click Render.

The sun, your repositioned Daylight object, is in full view and the Surface
object and plane you created show interesting detail from the materials
applied to them.
Restore the time of day and the exterior view:
1 With the Daylight object still selected, in the Control Parameters rollout
➤ Time group change the Hours back to 15, and in the Location group
change the North Direction field back to 300.
2 Switch the Camera001 viewport back to 3D View: Exterior, and on the
Environment And Effects dialog ➤ mr Photographic Exposure Control
rollout ➤ Exposure group, change the Shutter Speed back to 250 (1/250
Sec.).
3

Close the Environment And Effects Dialog.
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4 In the 3D View: Exterior viewport,
all of the carport.

dolly back until you can see

5 On the Rendered Frame Window, click Render to render the new exterior
view.
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The result is similar to your earlier rendering. In the next lesson, you will
change the size of the carport.

Next
Using Revit to Improve the Carport on page 1167

Using Revit to Improve the Carport
In this lesson, you use Revit to change the carport so it can accommodate two
cars instead of one. This gives us a chance to demonstrate the dynamic
capability of the File Link Manager.
Use Revit to edit the carport:
To complete this procedure, you must have Revit installed on your workstation.
If you do not have Revit installed, proceed directly to the next procedure,
Reload the FBX file on page 1174.
1 Open the Revit window once again.
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2 On the Project Browser panel at the left, double-click Floor Plans ➤
Carport.

Revit displays the carport floor plan.

3

Zoom in to get a good view of the carport area.
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4 Click to select axis 1, the left side of the carport.
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5 Drag axis 1 to the left, to a point near the axis A and B markers.
Revit expands the size of the carport.
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NOTE The upright posts are constrainted to the roof of the carport, so when
you increase the size of the roof, the posts move along with it.
6 In the Project Browser panel, double-click 3D Views ➤ Exterior.
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7 If you adjust the 3D view, you can see that the carport is now big enough
for two cars.
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8 Open the

Application menu and choose Export ➤ FBX.

NOTE At this point, Revit might prompt you to save the project. You don’t
need to save the project to proceed with this tutorial.
Revit opens a file dialog.
9 In the file dialog, choose the same beachhouse.fbx that you created earlier,
then click Save.
Revit warns you that you are about to overwrite beachhouse.fbx.
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10 Click Yes.
11 Exit Revit.
You won’t be using Revit any further in this tutorial.
NOTE You don’t need to save changes to beachhouse.rvt.

In 3ds Max Design, reload the FBX file:
1 Open the 3ds Max Design window once again.
2 If you skipped the Revit procedure, do the following:
■

Use Windows Explorer to copy the beachhouse.fbx file from the
\import\revit_files\updated_fbx subfolder to the main \import\Revit_files
folder. This file has been set up for you. Overwrite the previous version
of beachhouse.fbx.

3 From the
Manager.

Application menu, choose References ➤ File Link

3ds Max Design opens the File Link Manager dialog.
4 On the File Link Manager dialog, go to the Files panel.
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5 The entry for beachhouse.fbx now shows a red flag icon: This indicates
that the FBX file has changed.
6 Click Reload.
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3ds Max Design opens a File Link Settings: FBX Files dialog.

7 Accept the default options for reloading the FBX file, and click OK.
3ds Max Design displays a progress bar while it reloads the FBX file. Leave
the File Link Manager dialog open for now.

8

Select the SunAndSky-002 Daylight object, and go to the
Motion panel.

9 On the Motion panel, verify that the Daylight settings are as they were
before: Hours=15, Minutes=17, Month=5, Day=10, Location = Boston,
MA. Correct these values if you need to, then in the Location group,
change the value of North Direction back to 300.0.
You need to reset the North Direction because the Daylight values were
saved in the FBX file.
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10 Activate the 3D View: Exterior viewport, and

render the scene.

Now the beach house has a double-wide carport in 3ds Max Design as
well as in Revit.
Bind the FBX geometry to 3ds Max Design:
We don’t plan to revise the beach house model further in Revit, so at this
point, you will bind the model to 3ds Max Design. This has the advantage of
making the beach house geometry into full-fledged mesh objects that you can
edit with the 3ds Max Design tools.
1 On the File Link Manager dialog ➤ Files panel, click Bind.
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3ds Max Design displays a warning that you are about to break the live
link.

2 Click Proceed With Bind.
3ds Max Design binds the geometry and converts it to Mesh objects.
3

Close the File Link Manager dialog.
From this point on in this tutorial, you will work exclusively with 3ds
Max Design geometry and lighting.
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In the next lesson, you use an “mr Sky Portal” object to take some of the
daylight and channel it into the beach house, to give its interior more
ambient illumination.

Next
Sky Portal Illumination on page 1179

Sky Portal Illumination
An “mr Sky Portal” is a 3ds Max Design light object that gathers sky light (as
opposed to direct sunlight) generated by a Daylight system. When a Sky Portal
is applied to objects such as glass doors and windows, these objects become
light sources. The objects in turn cause adjacent areas, specifically the interior
of buildings, to be illuminated.
In this lesson, you will add a Sky Portal to the beach house curtain window
to boost the amount of daylight that enters the interior of the house.
Set up the lesson:

1

Continue from the previous scene or open
beachhouse_skyportals.max. This file is in the folder
\scenes\interoperability\Autodesk_Revit.
NOTE If a dialog asks whether you want to use the scene’s Gamma And LUT
settings, accept the scene Gamma settings, and click OK. If a dialog asks
whether to use the scene’s units, accept the scene units, and click OK.

2 If you continue from the previous scene, then in the 3D View: Exterior

viewport,
dolly the camera forward so you have a closer view of
the front of the beach house.
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Add the Sky Portal and adjust scene exposure:

1

Render the scene.
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The rendered image is illuminated solely by the Daylight system, with
indirect illumination evident on the underside of the terrace canopy as
well as on the shaded surfaces of the columns and exterior walls.
Some sunlight is also penetrating the interior of the bungalow, but not
enough to show much detail. You will correct this problem by adding a
Sky Portal to the curtain window.

2 On the Rendered Frame Window, make a
clone of the image. You
will compare this clone with image you will render a little later on.

3 On the
Create panel, click
(Lights). On the Object Type
rollout, click “mr Sky Portal,” then turn on AutoGrid.
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AutoGrid lets you create objects directly on surfaces in the scene.
In the camera viewport, move the mouse over several objects in the scene
and notice how AutoGrid changes the orientation of the axis tripod,
depending on the cursor location.

Creation axes oriented to the floor of the porch

Creation axes oriented to the front window
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When you position the “mr Sky Portal” on an object, your objective is
to position the cursor so its Z axis is perpendicular to the surface.
4 Position the cursor at the bottom-right corner of the bungalow curtain
window (the object name is Glazed), making sure the Z axis indicator is
perpendicular to the surface.
5 Create the Sky Portal by dragging diagonally from the lower-left corner
to the upper-right corner, until the portal covers the entire area, then
release the mouse. Right-click to complete Sky Portal creation.

For a building with more and smaller windows, you would create a Sky
Portal for every window and glass door in the model. In this case however,
a single large portal is sufficient.

6

Render the scene again, then compare the result with the
rendered image you cloned earlier.
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The differences are subtle. But the furniture inside the house is lit better,
and you can see father into the interior.
Turn off the Sky Portal temporarily:

■

Make sure the Sky Portal is still selected, and on the
Modify panel
➤ mr Skylight Portal Parameters rollout, turn off the On toggle.

This temporarily turns off the Sky Portal.
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Create an interior view:
The benefits of a Sky Portal become most apparent when you adjust the interior
daylight settings. You will do so soon, but first you need to create another
camera to view the interior of the bungalow.

1 Activate the Top viewport and
house.

2 On the
Create panel, click
rollout, click to turn on Target.

zoom in to the floor plan of the

(Cameras). On the Object type

3 Click above the sofa at the bottom-left of the living room, then drag the
target across the room to a point to the left of the dining-room table.
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4 Right-click to end camera creation.
5 In the 3D View: Exterior viewport, click the Point Of View (POV) viewport
label and choose Cameras ➤ Camera002 to switch to the viewpoint of
the camera you just created.
6 The Camera02 object was positioned on the floor when it was created, so

use
(Pan) in the new camera view to raise both the camera and
its target until the camera captures a better view of the interior of the
house.

Adjust the exposure and render the interior:

1 On the main toolbar, click
the Rendered Frame Window.

(Rendered Frame Window) to display

2 On the Rendered Frame Window, click
(Environment And Effects
Dialog (Exposure Controls)) to display the Environment And Effects
dialog.

1186 | Chapter 8 Interoperability Tutorials

3 On the Exposure Control rollout, click Render Preview.

The scene is too dark. To improve the rendering, you need to adjust the
scene’s exposure settings.
4 On the mr Photographic Exposure Control rollout ➤ Exposure group,
change Shutter Speed to 125 (1/125 Sec.).
The preview thumbnail updates dynamically to reflect your change.

5 The result looks much improved, so on the Rendered Frame Window,
click Render.
TIP The interior renderings in this tutorial typically take from about 10 minutes

to 25 minutes to render. To reduce render time, you can use the
Render Setup Dialog to change the rendered frame to a resolution smaller
than the size of 640 x 480 that we have provided as the default for these
scenes.
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With the Sky Portal turned off, you can see how poorly the daylight is
illuminating the room. One way to improve illumination without using
the Sky Portal is by increasing the number of light ray bounces.
Add Final Gather to improve the lighting:
1 On the lower panel of the Rendered Frame Window, increase the number
of FG Bounces to 2.
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2 Render the scene again.

The interior is brighter now. However, the kitchen area remains
unnaturally dark. This is where the Sky Portal comes in.
Restore the “mr Sky Portal”:

1

Open the Select From Scene dialog and select the mr Sky Portal001
object. Click OK.

2 Go to the
Modify panel and on the mr Sky Portal Parameters
rollout, turn the Sky Portal back on.
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3 On the Rendered Frame Window, make a
rendering, then click Render.

clone of the previous

In the latest rendering, notice the detail now visible in the kitchen counter
and cabinets. Also, the overall scene color has taken on a bluish tint from
the skylight channeled by the Sky Portal.
A certain amount of graininess is also apparent, but this can easily be
eliminated by adjusting the number of shadow samples taken by the Sky
Portal.
Increase the number of shadow samples:
■

With the Sky Portal still selected, in the mr Skylight Portal parameters
rollout ➤ Shadows group, change the value of Shadow Samples to 64.
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Before you render the scene again, you will make a slight adjustment to
the light object in the kitchen.

The light appears to be on, but it provides no illumination. This is because,
while the light object is turned off like all others in the scene, its material
is set to glow. This is a characteristic you will require later when you render
the scene with artificial lights turned on.
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For now, you need to adjust the light’s material.
Correct the self-illuminating kitchen light for a daylight scene:
1 Minimize the Rendered Frame Window.

2 Open the

Slate Material Editor.

3 Move the Slate Material Editor window so you also can see the Camera002
viewport.

4 On the Slate Material Editor Toolbar, click
(Pick Material From
Object), and then in the Camera002 viewport, click the lower side of the
Pendant Light object.

3ds Max Design displays the material nodes in the active View.
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The material for the light assembly is a Multi/Sub-Object material with
two sub-materials.
5 Double-click the second sub-material node, Glass - White, High Luminance,
to display its parameters.
6 Open the Self Illumination rollout, and set the Luminance value to 0.0
(just right-click the spinner arrows).

The material reverts to a transparent appearance.
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7 Minimize the Slate Material Editor.
Make a final rendering of the interior scene:

➤

Restore the Rendered Frame Window.
Make another clone of the
rendered frame, then render the image again.

The kitchen light fixture is now dark and the graininess of the rendering
is reduced.
The next illustration shows a rendered frame with even less grain, truer
colors, and sharper shadows.
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This image was produced with shadow samples set to 512 and the
following render frame settings:
■

Image Precision (Antialiasing) slider bar: High

■

Final Gather Precision slider bar: Medium

The image is improved, but typically it requires nearly 3 hours to render!
Restore self-illumination to the kitchen light:
■

Restore the Slate Material Editor. Make sure the Glass - White, High Luminance
material is active, then on the Self Illumination rollout, reset the Luminance
value for the kitchen light back to 2500.0.

Sky Portal Illumination | 1195

You need to do this step because in the next lesson, you will illuminate
the bungalow using the man-made lights you imported from the Revit
scene.
Save your work:
■

Save the scene as my_beachhouse_sky_portal.

Next
Scene Management and Nighttime Lighting on page 1196

Scene Management and Nighttime Lighting
In this lesson, first you use Layers and the Scene Explorer to organize the
objects created in Revit, then you illuminate the beach house with artificial
light so you can create nighttime renderings.
Set up the lesson:

■

Continue working on your own scene file or
beachhouse_scene_management.max.

open

Prepare the scene for artificial illumination:
1 Press H and on the Select From Scene dialog, select the mr Sky Portal001
object.

2 On the
Modify panel ➤ mr Skylight Portal Parameters rollout,
turn off the Sky Portal.
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3

Select the SunAndSky-002 object.

4 On the Daylight Parameters rollout, turn off the two Active toggles for
Sunlight and Skylight.

5 From the main menu, choose Rendering ➤ Environment. On the
Environment And Effects dialog ➤ Common Parameters rollout, turn
off Use Map.

6

Close the Environment And Effects Dialog.
Now the scene has no daylight illumination, and is ready to be lit by
artificial lights.

Set up the Scene Explorer to reorganize Revit objects:
Now that you have bound the beach house geometry to the 3ds Max Design
scene, you can use 3ds Max Design tools to organize it. First, you will place
the furniture on a separate layer, so you can hide or unhide the furniture
easily.
1 Right-click an empty area of the main toolbar, and from the drop-down
menu, choose Layers.

Scene Management and Nighttime Lighting | 1197

3ds Max Design opens the Layers toolbar. However, layer information is
not included for geometry imported from an FBX file, so at present there
are only two layers in the scene: the default, 0 layer, and a beachhouse
layer that contains all the geometry, including lights, cameras, furniture,
and the terrain and the building itself.

You will use the 3ds Max Design Scene Explorer to improve this
organization.
2 Keep the Layers toolbar open for now.
3 From the main menu, choose Tools ➤ New Scene Explorer.
4 In the Scene Explorer View field, rename the view Revit Data.
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In this view, you will reorganize data elements so you can work on the
scene more easily. First, you add some columns so you can see more
information about objects.
5 Right-click the column header and from the drop-down menu, choose
Configure Columns.

3ds Max Design opens a Configure Columns dialog.

6 Move the Configure Columns dialog to the right of the Scene Explorer
window.
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TIP If you resize the Configure Columns dialog to make it taller vertically, it
is easier to find the columns you want to add to the Scene Explorer.
7 Drag the Color column from the Column Chooser dialog, and drop it on
column header to the right of the Name column.

3ds Max Design adds the Color column to the Scene Explorer.
8 Drag the right edge of the Scene Explorer window so you can see the new
Color column. Move the Column Chooser dialog so you can see it, too.
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TIP You can resize individual columns by dragging their divider edges in the
header.
9 In order, drag the following columns from the Configure Columns dialog
to the column header. Drop each new column on top of the last one you
added, so they line up in order from last to first.
■

Shadow On

■

Light On

■

Hidden

■

Revit Category

■

Type
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TIP After you add a column, you also can move its position by dragging and
dropping.

10

Close the Configure Columns dialog.

Move the furniture onto a separate layer:
1 On the Scene Explorer, click the Revit Category column header.
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Now all the objects that were imported from the Revit scene file are
organized by category. Scroll so you can see the objects in the Furniture
category.
2 Select the first furniture object in the list, hold down the Shift key, and
then select the last furniture object to select it and all furniture objects
in between.
3 Click the Hidden check box of the furniture object with the yellow
highlight (the one you Shift+clicked). 3ds Max Design hides all the
furniture objects. Click the Hidden check box again to unhide the
furniture.

4 On the Layers toolbar, click

(Create New Layer).

3ds Max Design opens a Create New Layer dialog.

5 Name the new layer Furniture, leave Move Selection To New Layer turned
on, then click OK.
6 On the Layers toolbar, open the Layers drop-down list.

1204 | Chapter 8 Interoperability Tutorials

Now the furniture is on a Furniture layer of its own, apart from the other
beachhouse objects. You can use Show/Hide, Select and other layer controls
for these Revit objects, just as you can with objects created in 3ds Max
Design.

7

Close the Layers toolbar.

Select the lights for artificial illumination:
You imported the Revit scene with its photometric lights turned off because
you did not need them for daylight rendering. Now you can use the Scene
Explorer to turn the lights back on with a simple click of the mouse.
1 On the Scene Explorer, click the Type column header so the light objects
appear at the top of the objects list.
2 Click and Shift+click to select all the lights except for mr Sky Portal001 and
SunAndSky-002 (which is actually a group).

3 Click the Light On check box for the entry with the yellow highlight (the
one you Shift+clicked).
3ds Max Design turns on all the lights you selected.
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TIP You can also use the Light Lister to turn lights on and off, but in the
Scene Explorer it is easier to select multiple light objects.

4

Close the Scene Explorer.
NOTE You can redisplay any customized Scene Explorers, such as Revit Data,
by choosing main menu ➤ Tools menu ➤ Saved Scene Explorers. A list of
saved explorers appears as a submenu.

Render the interior at nighttime:

1 Activate the Camera002 viewport and click
Window) to display the Rendered Frame window.

(Rendered Frame

2 Click
(Environment And Effects Dialog (Exposure Controls)) to
display the Environment And Effects dialog.
3 On the mr Photographic Exposure Control rollout ➤ Exposure group,
set Shutter Speed to 1.5 (1/1.5 = 2/3 Sec.) and Aperture to 2.8, a slower
speed more suitable for nighttime lighting conditions.
4 On the Exposure Control rollout, click Render Preview.
WARNING This preview takes about four minutes to render.
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NOTE If the mental ray renderer displays warning messages while you render
this preview or the interior views that follow, you can disregard it: The
warnings are not critical, and the renderings should still give the results shown
in these illustrations.
5 On the Rendered Frame Window, click Render to render your night scene.
It takes a long time to render this scene, in the neighborhood of 2 hours,
so if you do not wish to complete the rendering, click the Cancel button
on the Rendering progress dialog, and view the result in the next
illustration.
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The rendered result shows that while most of the light sources are
illuminating the interior quite nicely, the kitchen light is too bright,
washing out detail in the cabinets and appliances. But rather than go
back and adjust the light intensity in Revit, you can use controls in 3ds
Max Design to accomplish the same task.

6

Select the kitchen light, Pendant Light - Linear - 2 Lamp 48” - 120V
0, and in the Modify panel ➤ Dimming group, set the Resulting Intensity
to 50 % (percent).

This reduces light intensity from 5280 lumens to 2640.

7 On the Rendered Frame Window,
then render the image again.
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clone the rendered frame, and

A comparison of the results shows the effect of dimming the kitchen
light. The details of the cabinets are easier to see, and there is less glare
on the kitchen floor.
Save your work:
■

Save the scene as my_beachhouse_nighttime.

Summary
You have learned how to take models created in Revit and bring them into
3ds Max Design to create professional-looking renderings.
If you wish, you can test your knowledge of the camera, lighting, and exposure
techniques you followed in this tutorial by creating, then rendering the
following views of the bungalow model.
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Bedroom
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Living room
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Kitchen
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The Exterior view at night

All these views are set up and ready to render in the scene beachhouse_final.max.

Creating a Walkthrough from an AutoCAD
Drawing
A key feature of 3ds Max Design is its ability to let you work with drawings
and models you've created with AutoCAD and AutoCAD Architecture, or
drawings you've exported from Autodesk Revit. 3ds Max Design gives you the
advantage of being able to improve on sound, precise drawings by letting you
create realistic design visualization presentations.
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In this tutorial, you use AutoCAD and 3ds Max Design to create a virtual visit
to a room in a house. In it, you will learn production techniques used for
creating a photorealistic animation sequence from a 2D house plan.
Skill Level: Beginner
Time to Complete: 1 1/2 to 2 hours

Features Covered in This Tutorial
■

Link an AutoCAD file to 3ds Max Design

■

Quickly create walls, ceilings, and floors in 3D

■

Set up a camera for a walkthrough
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■

Create natural exterior light

■

Use mental ray to create photorealistic rendering

■

Prepare the scene for animation

Preparing and Exporting the DWG File
In this lesson, you prepare a 2D DWG file as the basis for the 3D house model.
NOTE If you don't have a running version of AutoCAD, skip ahead to the next
lesson, Importing the DWG File on page 1226. A DWG file with the necessary
preparation is available in the \import\AutoCAD files folder.
Open the file:

1 Start

AutoCAD 2010.

NOTE You can open this DWG file with a version as early as AutoCAD 2007,
but be aware that the user interface has changed (in particular, for Layers),
and won’t exactly match the steps in this lesson.

2 From the
Application menu, choose Open. In the file dialog,
browse to the \3ds max design 2011 tutorials\import\AutoCAD_files\ folder.
Open wt_start.dwg.

Preparing and Exporting the DWG File | 1215

The file is the ground plan of a house.
NOTE You might see a message that tells you to resave the file. Close the
dialog, but don’t resave.

Freeze the layers:
This file contains a lot of elements that aren't necessary for the 3D
walkthrough. Using the Layer Manager, you can hide all the elements that
you will not use. The only layers that are required for this tutorial are 01-Walls
and 02-Windows.

1 On the ribbon ➤ Home tab ➤ Layers panel, click
Properties).

(Layer

AutoCAD opens the Layer Properties Manager dialog.
2 On the Layer Properties Manager, click to select the layer 01-Walls.
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3 On the Layer Properties Manager toolbar, click
make this layer current.

(Set Current) to

4 In the left pane, right-click All Used Layers, then choose Visibility ➤
Frozen to freeze all the layers. A dialog appears to inform you that the
current layer cannot be frozen. Click OK.

5 Click the

icon to unfreeze the 02-Windows layer as well.
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6 Click
(New Layer). Name this new layer 3DWalls. Use the square
color icon in the Color column to change its color to a dark blue.

7 Highlight the new layer (3DWalls) and click

(Set Current).

8 Close the Layer Manager.
The drawing should now show walls, windows, and doors.
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Create polylines:
In order to create 3D walls in 3ds Max Design efficiently, you need to create
Polylines using the wall lines and the Bpoly command. This command draws
a closed polyline around the boundary of a selected field, leaving the original
wall lines untouched. Using polylines instead of lines greatly simplifies the
creation of walls later on in 3ds Max Design.
1 Make sure Snap is turned off. (Pressing F9 toggles Snap)
2 In the viewport, zoom out until you see all the wall lines. This is required
for the Bpoly command to work.
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3 Type bpoly and then press Enter.
AutoCAD opens a Boundary Creation dialog.

4 In the Boundary Creation dialog, click

(Pick Points).

5 Click inside the wall shown in the following illustration, and then press
Enter.
AutoCAD creates a polyline.
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6 Retype bpoly. Click Pick Points once again, then click inside the wall
shown in the following illustration. Press Enter. This time the polyline
wasn't created properly. Press Ctrl+Z to undo this last operation.
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The polyline was not created because the wall is not continuous. You
must close the gap before you can create a polyline.
7 Press Esc to exit the Bpoly command.
8 Zoom in until you get a better view of the gap between the walls.
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9 Fix the gap by extending the line on the left to the endpoint of the next
wall. Click the line to select it, then drag from its endpoint to the endpoint
of the other wall.
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10 Zoom out until you see all the wall lines again, then repeat the Bpoly
command.
This time, a polyline is created.
11 Use Bpoly to create polylines from all the walls in the drawing file. Don't
forget the small lines between the windows.
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If you see a warning that says “Valid Hatch Boundary not found,” zoom
out so all the wall lines are visible in the viewport, and then use the Bpoly
command again.
NOTE The new polylines should have the dark blue color of the 3DWalls
layer.
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Save the DWG file:
■

Your work in AutoCAD is now done. Save the file as my_wt_2dplan.dwg,
and then exit AutoCAD.

Importing the DWG File
You are now ready to import the AutoCAD file into 3ds Max Design and use
it to create the general structure of the 3D room.
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Set up the units:
The AutoCAD file you are importing is measured in feet and inches. It is best
to use the same units setting in 3ds Max Design.

1 Start

3ds Max Design.

2 From the Customize menu, choose Units Setup.
3 In the Units Setup dialog, choose US Standard ➤ Feet With Fractional
Inches. Leave the other values set to their defaults, and then click OK.
Import the DWG file:

1 From the

Application menu, choose Import.

3ds Max Design opens a Select File To Import dialog.
2 Browse to the folder \import\AutoCAD_files\ and choose the file
wt_2dplan.dwg, or use the one you created yourself in the first lesson.
After a pause, an AutoCAD DWG/DXF Import Options dialog appears. If
you get a warning about proxy objects, just click Yes.
Adjust the import options:
1 On the Geometry tab of the AutoCAD DWG/DXF Import Options dialog,
leave the settings at their defaults. (These are shown in the following
illustration.) Before you click OK, you must change settings on the Layers
tab.
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2 Click to go to the Layers tab.
3 Choose Select From List to enable individual layer selection.
At first, all the layers are selected.
4 Click Invert.
Now none of the layers is selected.
5 Click the 3Dwalls layer to select it, and then click OK.
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3ds Max Design imports the floor plan, which should appear similar to
the following illustration.

Save the scene file:

■

From the
Application menu choose Save As, and save the scene
as my_wt_floorplan.max.

Constructing the Walls
To construct the walls, you simply extrude the floor plan polyline that you
just imported.
Set up the scene:
■

Continue from the previous lesson.
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Extrude the polyline:

1

Click the polyline object to select it.

2 Go to the
drop-down list.

Modify panel. Choose Extrude from the Modifier

TIP While the Modifier list is open, you can press E a few times to find the
Extrude modifier more quickly.

3 On the Extrude modifier's Parameters rollout, set the Amount to 8' 0”.
3ds Max Design extrudes the polyline to create walls that are eight feet
high.
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Save the scene:
■

Choose File ➤ Save As, and name the new scene my_wt_walls.max.

Establishing the Camera Shot
Now that the walls are built, you will establish the camera angles and position.
In the film and electronic media industry, this is described as “camera
blocking.” This is an important step, as it defines what you need to do
afterward, and prevents unnecessary work (for example, creating objects in
locations that the camera will never see).
For this camera shot, you will use a target camera that follows a path. A target
camera points toward a target object, which makes the camera's orientation
easy to control. The path helps create smooth and easy-to-control motion for
the camera.
Set up the scene:
■

Continue from the previous lesson, or go to the folder
\scenes\interoperability\AutoCAD\ and open the file wt_walls.max.
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NOTE If a dialog asks whether you want to use the scene’s Gamma And LUT
settings, accept the scene Gamma settings, and click OK. If a dialog asks
whether to use the scene’s units, accept the scene units, and click OK.

Create the target camera:

1 Go to the
Create panel. Turn on
Type rollout, click Target to turn it on.

(Cameras). On the Object

Now you can create a target camera.
2 In a viewport, click and drag to create a camera with a target. Release the
mouse, then right-click to finish camera creation.
The position of the camera and the target don't matter, as you will change
these later.
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3 On the Name And Color rollout, change the camera's name to
CameraDen.
The walkthrough shows part of the den of the house, not the entire house,
which would take considerable time to generate.
Zoom in to the area you will edit:
1 Click the Point-Of-View (POV) viewport label and choose Top (or press
T).
The viewport changes to a top view, but it appears empty.

2 Click

(Zoom Extents).

Now you should see the floor plan and the camera.
Press F3 to switch to Wireframe display mode, if necessary, and if the Top
viewport shows a grid, press G to turn off grid display.
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3 Click
(Zoom Region), and in the viewport, drag a rectangle to
zoom in closer on the area where the hall approaches the den (the den
is the room at the upper left of the house).
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Now you are ready to create the path.
Create the path:

1 Go to the
Create panel. Turn on
(Shapes). On the Object
Type rollout, click the Line button to turn it on.
Now you are ready to create a polyline.
2 On the Creation Method rollout, set both the Initial Type and the Drag
Type to Smooth.
3 In the viewport, click to the right of the room to begin creating a polyline
(see the arrow in the illustration), move to the left, and click as you move
to set additional vertices. After the fourth vertex, right-click to complete
the line. It should appear something like the following illustration.
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Once you have created the curve, you can edit it by selecting it, going to
the Modify panel, and then clicking Vertex to go to the Vertex sub-object
level. Move individual vertices until the line appears the way you want
it, and then turn off Vertex.
4 With the line still selected, use the Name And Color rollout to change
its name to CameraPath.

If you deselected the line,
select it again, go to the
Modify panel, and then use the name field at the top of the panel to
rename the line.
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Elevate the path:
The path was created at a height of zero. If you moved the camera along it,
the camera would be moving at ground level! You need to move the path
upward.
1 Cick the POV viewport label and choose Left (or press L).

2 Click

(Zoom Extents).

3 If the CameraPath spline is not selected, press H to display a Select From
Scene dialog, and then select the CameraPath object.
4 Right-click the viewport, and choose Move from the quad menu.

5

Drag the path upward along the Y axis until it's a little over five
feet high (watch the Y coordinate display on the status bar while you're
dragging the path).

6 Click an empty part of the viewport to deselect the path.
Attach the camera to the path:
1 Click the viewport label and choose Top (or press T).

2 Click

(Zoom Extents).
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3

Click the camera object to select it.

4 Choose Animation ➤ Constraints ➤ Path Constraint.
A rubber band line appears, leading from the camera to the cursor
location.
5 Click the CameraPath spline.
3ds Max Design repositions the camera so it is located on the path.

6 Click
(Play Animation) to view the animation generated by the
Path constraint.
The camera moves along the path. However, the target, which is
stationary, is not in the proper location. You will fix this in the following
procedure.
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7 Click

(Stop Animation) to stop playback.

Orient the camera:
1 In viewports, the camera's target is represented as a small cube. Click this
cube to select it, and then move it to a position inside the den.
As you move the target, the camera rotates to remain aimed in the target's
direction.
2 Click the viewport label and choose Left (or press L).

3 If the walls and camera aren't visible, click

(Zoom Extents).

The target is still at ground level (Y=0), so the camera is aimed at the
floor.

4

Move the target upward along its Y axis until it is about the
same height as the path.

Now both the camera and its target (point of view) are at approximately
human height.
Preview the animation:
1 Click the Point-Of-View (POV) viewport label and choose Cameras ➤
CameraDen (or press C).
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This view corresponds to what the camera sees. If the view isn’t already
shaded, press F3 to display the view in shaded mode.

2 Click

(Play Animation) to preview the walkthrough.

As the animation plays, the camera moves into the room.

3 Click

(Stop) to stop playback.

Set the camera's field of view:
The room is fairly small. Decreasing the camera's focal length and increasing
its field of view (FOV) lets the camera show more of the room.
1 Press H to display a Select Objects dialog, then choose the CameraDen
object.
2 Go to the Modify panel. On the Parameters rollout, set the Lens value to
18.0 mm and the FOV value to 90.0 degrees.

Now the camera viewport shows more of the house.
TIP FOV values greater than 90 degrees tend to give a distorted view of
objects.

Save your work:
■

Choose File ➤ Save As, and save the file as my_wt_camera.max.
If you want to do additional editing of the camera position, move the path
to which it is attached, or the vertices of that path. You can't move the
camera itself, because it is constrained to this path. You can move the
camera’s target, if you want to.
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Adjusting the Camera's Timing
Camera timing is important. If the camera moves too fast, viewers will miss
important elements of the animation (and might become dizzy). On the other
hand, if the camera moves too slowly, viewers will lose interest. When you
attach a camera to a path, the start and end frames of the timeline are used
for the camera path animation; here, the camera starts moving at frame 0 and
stops at frame 100. You'll adjust these values for the walkthrough animation
so it is slow enough for viewers to see the details of the room. To modify the
duration of the camera animation, you will use Track View, the 3ds Max
Design animation editor.
Set up the scene:
■

Continue from the previous lesson.

Use the Curve Editor to increase the animation length:
1 Press H to display a Select Objects dialog, then select the CameraDen
camera.

2 On the toolbar, click

(Curve Editor (Open)).

Track View opens in Curve Editor mode.
3 In the Controller Window (on the left side), open these tracks: Objects
➤ CameraDen ➤ Transform ➤ Position ➤ Path Constraint ➤ Percent.
You should now see a linear position graph, or “function curve” in the
Curve Window on the right.
The function curve represents a space-time relationship for the position
of CameraDen. It starts at frame 0, 0 percent of the path, and it ends at
frame 100, 100 percent of the path (which also is the end of the spline).
To change the length of the camera animation, you need to edit the time
value of the last keyframe.
4 Click the key at frame 100 to select it.
The key is represented by a gray square. When you select it, it turns white
with a black border.
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TIP

Move Keys must be on to select the key.

5 In the Key Time field at the bottom of the Curve Editor (the text field at
the lower left), change the key's time from 100 to 200.
The duration of the animation is now set to 200 frames, and the curve
now goes off the right end of the window.

6 Click
(Zoom) to turn it on, and drag downward in the Curve
Window until you see the entire curve once again.
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7 Click

(Zoom) again to turn it off.

Use the Curve Editor to adjust the camera's speed:
Right now, the camera has a constant speed between frames 0 and 200. This
is indicated by the linear “curve” in the curve window. The camera starts
suddenly and stops suddenly, which is not typical for real-world movement.
It would be more realistic, and more pleasant to viewers' eyes, if the camera
began moving slowly, speeded up a bit, and then slowed down before coming
to a stop. In animation, the expression for this type of motion is “slow in,
slow out.”
1 In the Controller Window, right-click the Percent track. Choose Assign
Controller from the quad menu that pops up.
An Assign Float Controller dialog appears.
2 Choose Bezier Float, and then click OK.
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The Bezier Float controller changes the key tangents so the camera speeds
up a bit when it begins to move, and slows down a bit before it stops.
The shape of the curve is now a real curve, and indicates the changes in
acceleration.
3

Close the Curve Editor.

Change the time configuration:
You have changed the keys for the camera to indicate a 200-frame animation,
but 3ds Max Design is still set to render only 100 frames. You also need to
change this setting.

1 Click
(Time Configuration) in the animation controls at the lower
right of the 3ds Max Design window.
3ds Max Design opens a Time Configuration dialog.
2 In the Animation group, change the End Time value to 200, and then
click OK.
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Show safe frames:
■

Click the POV viewport label, and choose Show Safe Frames.

Three rectangles appear in the camera viewport. The outer rectangle is the
area and aspect ratio of your current display. The middle rectangle is the
zone that is safe for action: outside this rectangle, the image might be cut
off when displayed on a video screen. The inner rectangle is the zone that
is safe for displaying “titles” such as credits.
View the adjusted animation:

1 Click

(Play Animation) to view the animation.

The camera begins to move slowly, speeds up, and then slows down
before coming to a stop.

2 Click

(Stop Animation) to stop playback.
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Save your work:
■

Choose File ➤ Save As, and save the scene as
my_wt_camera_animated.max.

Constructing the Ceiling
To construct the ceiling, you create a polyline shape, and then convert it to
a surface.
Set up the scene:
■

Continue from the previous lesson, or go to the
\scenes\interoperability\AutoCAD\ folder and open the file wt_camera.max.

Change the view:
1 Click the POV viewport label and choose Top (or press T).
2 Press Shift+F to turn off safe frame display, if it is still on.

3 Click

(Zoom Extents).

Set up snaps:
Snaps ensure that the line you create will align with the geometry of the walls.

1 On the main toolbar, make sure the 3D version of the
Toggle) is chosen, then right-click this button.

(Snaps

3ds Max Design opens the Grid And Snap Settings dialog.
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2 On the Grid And Snap Settings dialog ➤ Snaps panel, click Clear All,
and then click Vertex to turn it on.
3

4 Click

Close the Grid And Snap Settings dialog.

(3D Snaps Toggle) to turn it on.

Create a ceiling shape for the den:

1 Go to the
Create panel and click
Type rollout, click Line to turn it on.

(Shapes). On the Object

2 On the Creation Method rollout, make sure that Corner is chosen as both
the Initial Type and the Drag Type.
3 Starting at the upper-left corner of the den, draw a Line shape that
connects the interior vertices of the walls of this room, as shown in the
illustration that follows. Proceed in a clockwise direction.
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Complete the line by clicking the vertex with which you began the Line.
When 3ds Max Design asks if it should close the spline, click Yes.

4 On the main toolbar, click
off.

(3D Snaps Toggle) again to turn it

5 While the line is still selected, use the Name And Color rollout to rename
it Ceiling.
Convert the shape to a polygon surface:
■

Right-click the Line object, then from the Transform (lower-right) quadrant
of the quad menu, choose Convert To ➤ Convert To Editable Poly.
This converts the Ceiling line into a polygonal surface.
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Correct the normal of the ceiling surface:

1 Go to the

Modify panel.

2 Make sure the ceiling is still selected, and then choose Normal from the
Modifier List drop-down.
3 Make sure Flip Normals is on (it should be on by default).
4 Click the Point-Of-View viewport label, and choose Cameras ➤
CameraDen.

5

Render the view.
TIP You can press F9 as a shortcut for clicking Render Production.
The rendering should show the ceiling geometry.

If the rendering doesn’t show the ceiling, use the Normal modifier to
change the state of Flip Normals.
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Save your work:
■

Choose File ➤ Save As, and save the scene as my_wt_ceiling.max.

Constructing the Floor
To construct the floor, you simply copy the ceiling geometry.
Set up the scene:
1 Continue from the previous lesson, or go to the

\scenes\interoperability\AutoCAD\ folder and
wt_ceiling.max.

open the file

2 If you are continuing from the previous lesson and have only a single

viewport open, click
(Maximize Viewport Toggle) or press Alt+W
to display all four viewports.
Construct the floor by cloning the ceiling:
1 Activate the Left viewport.

2 Click

(Zoom Extents).

3 If the ceiling is not still selected, click
(Select By Name) (or press
H), and use the Select From Scene dialog to select the ceiling.

4 On the main toolbar, click

(Select And Move) to turn it on.

5 Hold down a Shift key while you drag the ceiling down to floor level.
Shift+move creates a copy of the ceiling object, and when you release the
mouse, a Clone Options dialog appears.
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6 In the Clone Options dialog, choose Copy. Change the name of the
cloned object to Floor, and then click OK.
Fix the floor's normal:
The floor faces upward, so it doesn't need the Normal modifier.

1 Go to the

Modify panel.

2 On the modifier stack, make sure the Normal modifier is highlighted,

and then click

(Remove Modifier From The Stack).

Correct the floor's alignment:

1 Click
viewports.

(Maximize Viewport Toggle)) (or press Alt+W) to see four

2 Activate the CameraDen viewport by right-clicking it.
3 Make sure the floor is still selected, and then on the main toolbar, click

(Align). Then click one of the walls.
3ds Max Design opens the Align Selection dialog.
4 In the Align Selection dialog, turn off X Position and Y Position. Turn
on Z Position. For Current Object choose Center, and for Target Object
choose Minimum.
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This aligns the floor with the bottom of the walls, along the floor's local
Z axis.
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5 In the Align Selection dialog, click OK.
Preview the floor:

1 Activate the CameraDen viewport and

render the view.

Now the rendering shows both a floor and a ceiling.
2

Close the rendering by clicking the X button in the upper-right
corner.

Save the scene:
■

Choose File ➤ Save As, and save the scene as my_wt_floor.max.

Texturing the Walls, Ceiling, and Floor
So far, preview renderings of the scene have shown simple color tones. To
give an object a more interesting and more realistic look, you need to apply
a material to it. Material attributes give an object its color and describe what
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type of surface the object has. By adjusting material attributes, you can make
a surface look hard and shiny like a billiard ball or soft and bumpy like a piece
of cloth made of wool. To create materials, you use the Material Editor.
Set up the scene:
■

Continue from your previous scene, or go to the

\scenes\interoperability\AutoCAD\ folder and
wt_floor.max.

open the file

Create a material for the walls and ceiling:

1 On the main toolbar, click
Material Editor.

(Material Editor) to open the Slate

TIP If you open the Compact Material Editor instead, you can change to the
Slate interface by choosing Modes ➤ Slate Material Editor.
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NOTE The scene wt_floor.max has been set up to use the mental ray renderer:
This is necessary to see the mental ray materials in the Material/Map Browser
panel at the left side of the Slate Material Editor.
2 Drag an Autodesk Wall Paint material entry from the Material/Map
Browser (Materials ➤ mental ray group) into the active View at the center
of the Slate Material Editor.
3ds Max Design displays a node for this material type in the active View.

3 Double-click the Wall Paint material node.
3ds Max Design displays the Wall Paint material parameters in the
Parameter Editor at the right side of the Slate Material Editor.
NOTE The Autodesk Materials are based on the Arch & Design material, but
with simplified controls based on real-world material attributes. Autodesk
Materials are compatible with AutoCAD, Autodesk Revit, and Autodesk
Inventor.
4 Change the name of the material to Wall Ceiling Material.

As you change the name in the Parameter editor, the name updates in
the title bar of the node display, as well.
5 On the Parameter Editor ➤ Wall Paint rollout, click the color swatch.
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3ds Max Design opens a Color Selector.
6 In the Color Selector, assign these values to the color:
■

Hue: 0.19

■

Sat (saturation): 0.2

■

Value: 1.0

Now the paint color is a pale yellow.
7 Click OK to close the Color Selector.
Leave the paint Finish set to Flat/Matte and the Application set to Roller.
Apply the material to the walls and ceiling:

1 On the 3ds Max Design main toolbar, click
(Select By Name) to
display a Select From Scene dialog. In the list, click and Ctrl+click to select
the wall and ceiling objects, and then click OK.
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2 On the Slate Material Editor toolbar, click
Selection).

(Assign Material To

3ds Max Design applies the material to the selected objects.
NOTE The material preview in the title bar of the material node now shows
white triangles in each corner: These indicate that the material is being used
in the scene.

Create a material for the floor:
The floor material is slightly more complex: You will use a map to display a
wooden floor effect.
1 Move the Wall Ceiling Material material node to the upper-left corner of
the active View.
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TIP If you remove a material node from the active View and want to edit the

material later, you can get it by using the
(Pick Material From Object)
tool. You can also find the material in the Material/Map Browser ➤ Scene
Materials group, which always includes all materials used in the scene.
2 Drag an Autodesk Hardwood entry from the Material/Map Browser to
the active View. (This is also in the Materials ➤ mental ray group.)
The Autodesk Hardwood material has two bitmaps built into it. In the
Slate Material Editor, click (Zoom Extents) to see the main material node
and the two bitmap nodes.

You will use the first bitmap, which contains the wood grain texture.
You won’t use the second bitmap.
WARNING In 3ds Max Design, it’s possible to disconnect a bitmap from an
Autodesk Material, or to replace it with some other kind of map. However,
if you do that other Autodesk applications such as AutoCAD won’t be able
to read the Autodesk Material, so we recommend that you always leave the
Autodesk Material bitmap nodes as they are. You can change the texture file
that they call, or adjust their settings, but don’t disconnect them or replace
them with a map type that is supported only by 3ds Max Design.
3 Double-click the Autodesk Hardwood material node to display its
parameters in the Parameter Editor.
4 Change the name of this material to Floor Material.
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5 On the Relief Pattern rollout, turn off the Enabled check box.

You could use the second bitmap as a bump map for the Hardwood
material, but in this scene, the floor is smoothly polished, so this isn’t
necessary.
6 On the Wood rollout, change the value of Finish to Satin Varnish.
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7 Double-click the first Bitmap node (the one wired to the Wood Image
component) to see its parameters.
8 On the Parameters rollout, click the Source button (at present, the button
has the label of the default wood grain map).

3ds Max Design opens a Select Bitmap Image File dialog.
9 In the file dialog, choose Files Of Type ➤ All Formats. Navigate to the
folder \3ds max 2011 tutorials\sceneassets\images\. Choose cherry.jpg, and
then click Open.
10 After you change the bitmap, the preview in the title bar of the Floor
Material node shows the new wood grain.
TIP You can enlarge the preview by double-clicking it.
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11 Click the main Floor Material node to make it active, then on the Slate

Material Editor toolbar, turn on
(Show Map In Viewport) so you
can see the wood-grain map in shaded views.
3ds Max Design displays the material with a red angle shape to show that
Show Map In Viewport is active. This red flag appears in the heading of
the material node, in the Material/Map Browser ➤ Scene Materials group,
and in the Navigator window at the upper right of the Slate Material
Editor.

Apply the material to the floor:

1 On the 3ds Max Design main toolbar, click
(Select By Name) to
display a Select From Scene dialog. In the list, click to highlight the floor
object, and then click OK.
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2 On the Slate Material Editor toolbar, click
Selection).

(Assign Material To

In shaded viewports, the floor turns brown, but it doesn’t show the wood
grain. This is because the floor is an Editable Poly object. By default, object
primitives have mapping coordinates assigned to them, but editable
surfaces do not. You have to assign mapping coordinates explicitly.

3 Make sure the Floor object is still selected, and go to the
panel. Choose UVW Map from the modifier list.

Modify

3ds Max Design applies mapping coordinates to the floor.
4 In the Parameters rollout ➤ Mapping group, make sure that Planar is
chosen, and that Real-World Map Size is turned on.
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NOTE For Autodesk Materials that use bitmaps, Real-World Map Size must
always be on for correct rendering results. The global setting for this, which
includes default settings for primitive objects, is on the Customize menu ➤
Preferences dialog ➤ General panel.

The floor grain appears in shaded viewports after you apply UVW Map.

5 Make sure the CameraDen viewport is active, then on the main 3ds Max

Design toolbar, click

(Render Production).

3ds Max Design renders the scene with painted walls and a wood-grain
floor. (The lighting is uninteresting, but you'll fix that in a later lesson.)
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6

Close the Slate Material Editor.

Save your scene:
■

Choose File ➤ Save As, and save your scene as my_wt_material.max.

Adding the Furniture and Decorative Elements
To complete the room, now you will merge some pre-built elements into the
scene. These are the windows, a fireplace, and a door. They include the wall
portions that are above and underneath them. The file also includes floors
and ceilings for the hallway and kitchen. Another scene file provides the
furniture.
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Set up the scene:
■

Continue from the previous lesson, or go to the

\scenes\interoperability\AutoCAD\ folder and
wt_material.max.

open the file

Add the windows, fireplace, and door:

1 From the
Application menu, choose Import ➤ Merge. Browse
to the \scenes\interoperability\AutoCAD\ folder, choose the file
wt_door_windows.max, and then click Open.
3ds Max Design opens a Merge dialog.
2 On the Merge dialog, click the All button beneath the list of objects, and
then click OK.
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Merge adds the door, windows, and fireplace to the scene.
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Add the furniture:

1 Choose
Import ➤ Merge once again. In the
\scenes\interoperability\AutoCAD\ folder, choose wt_furniture.max, and click
Open.
3ds Max Design opens the Merge dialog.
2 In the Merge dialog, click the All button beneath the list of objects, and
then click OK.
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3ds Max Design merges chairs and some decorative elements into the
scene. (The merged scene also includes a sky dome, which supports distant
scenery and snow falling, seen through the windows.)
Save your work:
■

Choose File ➤ Save As, and save the scene as my_wt_furnishings.max.
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Adding and Adjusting a Daylight System
To simulate natural sunlight coming from the outside, you will use a Daylight
system. A Daylight system uses lights in a setup that follows the geographically
correct angle and movement of the sun over the earth at a given location.
Set up the scene:
■

Continue from your previous scene.

Add the daylight system:
1 Right-click the Perspective viewport to make it active, and then click

(Maximize Viewport Toggle), or press Alt+W.
TIP If a Perspective viewport is not visible, you can change one of the
orthographic views to a Perspective view, but then you will have to navigate
in the viewport to get a good overhead view of the house, with some empty
space around it.

2 Press F3 to switch to wireframe display.
Zoom out in the viewport
so you can see a blank area outside the sky dome.

3 Go to the
Create panel, and click
(Systems). On the Object
Type rollout, click the Daylight button to turn it on.
3ds Max Design displays a dialog that asks if you want to add a
Logarithmic exposure control to the scene.

1272 | Chapter 8 Interoperability Tutorials

4 Click Yes to add the exposure control.
5 Drag in an empty area of the Perspective viewport. A compass rose appears.
Release the mouse.
3ds Max Design displays a dialog that asks if you want to add an “mr
Physical Sky” environment map.

6 Click Yes to accept the environment map creation and dismiss the dialog.
7 Back in the Perspective viewport, drag to set the height of the Daylight
light. Click to complete creation of the Daylight system.
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NOTE The scene position of the compass and the height of the light don't
really matter: 3ds Max Design will calculate correct values for daylight. Later,
you will adjust the orientation of the compass to reflect the geographic
orientation of your model.

Adjust the daylight values:

1 With Daylight still selected, go to the

Modify panel.

2 On the Daylight Parameters rollout, in the Position group, click Setup.

3ds Max Design goes to the
Parameters rollout.

Motion panel and displays a Control

3 On the Control Parameters rollout, in the Time group, change the Hours
value to 16.
4 In the Location group, click Get Location.
3ds Max Design opens a Geographic Location dialog.
5 Use the City list or a map to choose your present location, and then click
OK.
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For example, Montreal QB Canada was used for the sample scenes.
6 In the Location group, change the North Direction to 112.0.
This value corresponds to Montreal. It also ensures that the living room
is oriented to the southwest, toward the setting sun.
If you chose a different city, you might want to use its local value for
north.
3ds Max Design changes the orientation of the compass to point to the
north you entered.
Save the scene:
■

Choose File ➤ Save As, and save your scene as my_wt_daylight.max.

Adjusting the Environment
Before you do any renderings, some environment parameters that control the
image results should be set correctly for the current scene.
Set up the scene:
■

Continue from the previous lesson, or go to the

\scenes\interoperability\AutoCAD\ folder and
wt_daylight.max.

open the file

Set the exposure control:
1 Drag the time slider to frame 120.
This gives you a better view of the room.
2 Activate the CameraDen viewport.
3 Choose Rendering ➤ Environment.
3ds Max Design opens an Environment And Effects dialog.
4 On the Exposure Control rollout, make sure the exposure control type is
Logarithmic Exposure Control.
5 On the Logarithmic Exposure Control Parameters rollout, turn off Exterior
Daylight, if it is not already off.
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6 On the Exposure Control rollout, make sure Active is turned on, and then
click Render Preview.

The scene appears to be ready for rendering.
7

Close the Environment And Effects dialog.
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Using the mental ray Renderer
You can use the mental ray renderer to generate indirect lighting, using
bounced daylight to improve the illumination of th scene.
Set up the scene:
■

Continue from the previous lesson.

Preview the room:

➤

Make sure the CameraDen viewport is still active, and then click
(Render Production) or press F9.

3ds Max Design renders the scene, but it is too dim, and the “photons”
illuminating surfaces apppear as large blobs. Sunlight enters through the
window, but it doesn't spread through the room the way real-life sunlight
does.
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Turn on final gathering:
Final Gather causes light to bounce off surfaces as it does in real life.
1 At the bottom of the rendered frame window, drag the Final Gather
Precision slider one notch to the right, so the status changes from “Draft”
to “Low.”
2 In the Trace/Bounces Limits group, set FG Bounces to 2.

3 Click Render.

Now the room is clearly lit by daylight. It is actually a little too well lit.
Also, there are some patchy areas on the ceiling and behind the couch
that are caused by inaccuracies at the Low level of Final Gather. These
are easy to fix.
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Adjust the exposure and final gather settings:

1 On the Rendered Frame Window, click
(Environment And Effects
Dialog (Exposure Controls)) to open the Environment And Effects dialog.
On the Logarithmic Exposure Control Parameters rollout, reduce the
value of Brightness to 45.0.

2 Open the
Render Setup dialog. Go to the Indirect Illumination
panel, and on the Final Gather rollout, change the value of Interpolate
Over Num. FG Points to 100.
3 Click Render again.

Now the room is well and realistically lit.
(You might notice that on the Rendered Frame Window dialog, the status
of Final Gather changes from “Draft” to “Custom,” because of your Render
Setup change.)
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Save your work:
■

Choose File ➤ Save As, and save the scene as my_wt_fg.max.

Rendering the Walkthrough Animation
At a resolution of 640 x 480, it can take 1 minute or more to render each
frame, depending on the speed of your computer, so you probably don't want
to render the entire animation: At 200 frames, that would take a few hours
on a standalone system. This lesson describes some ways to check your work
and preview what the final result would be.
Set up the scene:
■

Continue from the previous lesson, or go to the

\scenes\interoperability\AutoCAD\ folder and
wt_finalgather.max.

open the file

Render a preview animation:
A preview renders at low resolution, with shading but no rendering effects. It
is a good way to check the animation you've created.
1 From the main menu, choose Tools ➤ Grab Viewport ➤ Create
Animated Sequence File.
3ds Max Design opens a Make Preview dialog.
2 Click Create.
3 Click OK to accept the default Cinepak codec.
3ds Max Design renders the animation as an AVI movie file. As it creates
the preview, 3ds Max Design displays a progress bar at the bottom of the
3ds Max Design window. When the preview is done, it launches the
Windows Media Player and plays the preview animation.
You can replay the preview in the Media Player by clicking Play once
more, or launch the Media Player from 3ds Max Design again by choosing
Tools ➤ Grab Viewport ➤ View Animated Sequence File.
The preview gives you a precise idea of the speed and rhythm of the
animation, and lets you see if there is anything you need to fix. At this
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point, you might want to make adjustments by changing the camera's
target position or the shape of the path.
Render sample frames:
While the preview shows the animation's speed and rhythm, it doesn't show
how frames look when fully rendered. To get a better idea of the look of the
animation, you can render sample frames.

1 Click

(Render Setup) or press F10.

2 On the Render Setup Dialog ➤ Common panel, on the Common
Parameters rollout, find the Time Output group. Change the output from
Single to Active Time segment, and then change Every Nth Frame to 50.

This will render five frames that are sampled along the duration of the
animation, from frame 0 to frame 200. (Rendering five frames will take
probably 5 to 10 minutes: Adjust the Every Nth Frame value to suit the
time you want to spend on this lesson.)
For animations or multiple frames, you need to specify a file or files where
the renderings will be saved.
3 Scroll down to the Render Output group (also on the Common Parameters
rollout). Click the Files button.
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A Render Output File dialog appears.
4 In the file dialog, enter wt_samples as the File Name, and then choose
“JPEG File (*.jpg,*.jpe,*.jpeg)” from the Save As Type drop-down list.
When you render an animation to a still-image file type such as JPEG,
3ds Max Design creates a sequence of image files. Each has the file name
you chose (wt_samples) followed by a sequence number (for example,
wt_samples0000.jpg).
TIP Leave the folder name set to \renderoutput. The \renderoutput folder is
a sub-folder of the 3ds Max Design tutorials project folder.
5 Click Save.
3ds Max Design opens a JPEG Image Control dialog.

6 Change the Quality value to 100 percent, and then click OK.
7 On the Render Setup dialog, click Render.
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As each image is rendered, it is stored in the \renderoutput folder. When
a frame is completed, view it to see if there is a problem with it. If
something seems wrong, stop the rendering by clicking Cancel in the
Rendering dialog or by pressing Esc. Correct the problem, and then render
sample frames once more. This sampling process should help you spot
problems before you take the time to render the full animation.
When you are ready to render a full animation, you can change the output
file type to a movie format. AVI and MOV are both available options. 3ds Max
Design prompts you to choose a compressor/decompressor (codec) for the
movie. Change Every Nth Frame back to 1, and then render the complete
animation.
You can view a sample AVI movie of the walkthrough by choosing Rendering
➤ View Image File, and from the tutorials folder opening
\sceneassets\renderassets\wt.avi.
A final version of the scene is in the \using_autocad_files\walkthrough\ folder,
saved as wt_final.max.

Summary
In this tutorial, you learned about basing a model and animation on imported
AutoCAD geometry.

Using the SAT Format to Share a Model with
Autodesk Inventor
In Autodesk 3ds Max Design 2011, you can use the SAT format to share files
with Autodesk Inventor. This tutorial shows how to do so.
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3ds Max Design can import the Inventor part (IPT) and assembly (IAM) file
formats. However, there are some disadvantages to this method; in particular:
■

Autodesk Inventor Server 8, or a later version, must be installed on the
same system that is running 3ds Max Design.

■

The IPT or IAM model is imported as 3ds Max Design editable mesh objects.
If you modify the model in 3ds Max Design, then you can’t use it in
Inventor any more.

Using the SAT format solves both these problems: You can import the SAT
file into 3ds Max Design on a system that doesn’t have Inventor Server
installed, and you can edit the model in 3ds Max Design, then import the
modified SAT model back into Inventor.
This tutorial uses a small part model to demonstrate these features.
Skill level: Intermediate
Time to complete: 45 minutes

Export the Model from Inventor
First, you use Inventor to export the model as an SAT file.
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Open Autodesk Inventor and export the part to SAT format:
If you don’t have Autodesk Inventor installed on your system, you can skip
ahead to the next lesson, Import the Model into 3ds Max Design on page 1286.

1 Start

Autodesk Inventor.

2 On the ribbon ➤ Launch panel, click
(Open). Browse to the
\import\Inventor_import folder in your 3ds Max Design tutorials project,
and open the file blade_clamp.ipt.
This model is of a small blade clamp mounted on a pin.

3 From the

Application menu, choose Export ➤ CAD Format.

Inventor opens a Save Copy As dialog.
4 From the Save As Type drop-down list, choose “SAT Files (*.sat).” Change
the file name to my_blade_clamp.sat, and then click Save.
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Inventor saves my_blade_clamp.sat in the same folder as blade_clamp.ipt.
5 Exit Autodesk Inventor.

Next
Import the Model into 3ds Max Design on page 1286

Import the Model into 3ds Max Design
Now you have a model that you can import into 3ds Max Design.
Import the SAT model into 3ds Max Design:

1 Start

3ds Max Design.

2 On the Quick Access toolbar, click
Project Folder and set your
current project to Autodesk 3ds Max Design 2011 Tutorials.
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3 Choose Customize ➤ Units Setup. On the Units Setup dialog, choose
Metric, and then choose Millimeters from the drop-down list. Click OK.

4 From the
Application menu, choose Import. In the Select File
To Import dialog, navigate to the \import\Inventor_files folder, highlight
my_blade_clamp.sat, and then click Open.
NOTE If you skipped the procedure with Inventor, import blade_clamp.sat.
3ds Max Design opens the SAT Import dialog.
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5 On the SAT Import dialog, turn on Convert SAT Y Axis to Z Axis.

In Inventor, the up-axis is Y, rather than Z as it is in 3ds Max Design. So
when you move a file from one product to the other, you have to be
careful to make this adjustment.
6 Click OK.
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3ds Max Design now shows the blade clamp as geometry in the viewports.

There are two objects: blade_clamp_01 is the mounting pin, and
blade_clamp_02 is the clamp itself.
Examine the geometry:

1

Select the clamp, blade_clamp_02, and go to the

Modify

panel.
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SAT objects appear in 3ds Max Design as the Body Object type. Body
Objects model solids.
2 Change the Perspective viewport to Edged Faces display (press F4). On
the Modify panel, look at the Viewport Display Settings rollout.

By default, the display is set to Both and Medium.
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3 Choose Mesh to see the 3ds Max Design mesh approximation of the
clamp.
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In viewports, 3ds Max Design approximates Body Objects as meshes. Try
choosing Coarse and then Fine as the mesh types.
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Coarse mesh
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Fine mesh

NOTE The Curves display option displays only the curves that outline Body
Object geometry, even when the viewport is a shaded view.
If you plan to deform the Body Object geometry, as in this tutorial, then
it helps to set the Max Edge Len[gth] % value explicitly.
4 Change the Mesh Quality Presets back to Medium.
5 In the Mesh Display group, set Max Edge Len. % to 3.0.
3ds Max Design subdivides the mesh approximation.
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This fine-grained subdivision gives 3ds Max Design modifiers adequate
geometry to modify.
When Max Edge Len. % is set to 0.0, the parameter is inactive. Values
between 2.0 and 5.0 are good for deforming geometry in 3ds Max Design.
6 Change the Display Options back to Both.

Next
Edit the Model in 3ds Max Design on page 1295

Edit the Model in 3ds Max Design
You will use a 3ds Max Design modifier to alter the shape of the solid part.
Edit the shape of the part:
The goal in this procedure is to add more curvature to the blades of the clamp.
1 From the Modifier List, choose Bend.
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2 Set the Bend parameters as follows:
■

Axis = X

■

Angle = 70 degrees

■

Direction = –90

The results are not quite what we want.
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All of the object is bent, and the base has moved away from the pivot
pin. What we want is to limit the bend so that the blades of the clamp
are bent, but the base remains unchanged and in the same place.
3 In the Bend Parameters rollout ➤ Limits group, turn on Limit Effect,
then change the value of Upper Limit to 70mm.

Now only the ends of the clamp blades are bent.

This is easier to see in the Top viewport.
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NOTE The modifiers that you can apply to Body Objects and successfully
export back to Inventor, are the modifiers grouped as Modify menu ➤
Parametric Deformers. These deform the original geometry without changing
the nature of that geometry. You could not apply an Edit Mesh or Edit Poly
modifier, for example, and export back to Inventor, because these replace
the Body Object geometry with mesh or poly structures that do not retain
the Body Object information that Inventor needs to construct the part as a
solid.

Next
Use 3ds Max Design to Add a New Part on page 1298

Use 3ds Max Design to Add a New Part
The next step is to add a new part using 3ds Max Design.
Add a new part:
Now you will construct a stirrup-like part to control the motion of the clamp.
1 Activate the Front viewport.
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2 On the
Create panel, click
(Geometry). Choose Standard
Primitives from the drop-down list, and on the Object Type rollout, click
Box to turn it on.
3 In the Front viewport, drag out a box near the end of the clamp blades.

4 On the Parameters rollout, give the box these dimensions:
■

Length = 20mm

■

Width = 15mm

■

Height = 3mm
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New box in Perspective view

5 Also on the Parameters rollout, change the value of Length Segs to 3.
6 Right-click the new box, and from the quad menu, choose Convert To
➤ Convert To Editable Poly.
7 On the ribbon ➤ Graphite Modeling Tools tab ➤ Polygon Modeling
panel, click

(Vertex).

8 In the Front viewport,
region-select the vertices that define the
top segment of the box (the second row of vertices from the top), and

move them up along the Y axis so they are above the level of
the upper blade.

1300 | Chapter 8 Interoperability Tutorials

9 Region-select the vertices that define the bottom segment of the box (the

second row of vertices from the bottom), and
move them down
along the Y axis so they are below the level of the lower blade.
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Extrude the stirrup:

1 On the ribbon ➤ Polygon Modeling panel, click

2

(Polygon).

Orbit the Perspective viewport so you can see the inner side of
the box.
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3

Click and Ctrl+click to select the two inner faces of the box that
correspond to the upper and lower segments.
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4 On the ribbon ➤ Polygons panel, click
(Extrude), then drag in
a viewport to extrude these faces over the end of the blade clamp.
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Add a pivot pin for the stirrup:

1 On the
Create panel, click
(Geometry). Select Standard
Primitives from the drop-down list, then on the Object Type rollout, turn
on Cylinder.
2 In the Top viewport, drag to create a cylinder.
3 Give the cylinder a Radius of 1.2mm and a Height of 22mm.

4

Move the pin horizontally and vertically so it straddles the
“jaws” of the stirrup, and is inside the perforation of the clamp blades.
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Top view
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Front view

Perspective view
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Export the Model to SAT Format
To send the model back to Inventor, first you have to convert the new
geometry to the Body Object type.
Convert the new parts to body objects:

1

Select the U-shaped portion of the new stirrup part: That is, the
box with extrusions, but not the pin.

2 Go to the
Create panel and click
Body Objects from the drop-down list.

(Geometry). Choose

3 On the Object Type rollout, click Body Object, then in a viewport,
right-click.
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3ds Max Design converts the part to a solid Body Object.

4

Select the new pin cylinder, and repeat step 3 to convert it to a
Body Object as well.

Export the modified assembly as a SAT file:

1 From the

Application menu, choose Export.
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2 On the Select File To Export dialog, choose ACIS SAT (*.SAT) from the
Save As Type drop-down list.

3 Enter the file name as mymaxclamp, and then click Save.
4 In the SAT Export dialog, turn on Convert 3ds Max Z Axis To Y Axis, and
then click OK.
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NOTE As the second group in the dialog shows, you can import other kinds
of 3ds Max Design objects to the SAT format. The trouble is that you can’t
do much with these object types in Inventor.
3ds Max Design reports that the objects were exported successfully.

5 Exit 3ds Max Design.
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Import the Model back into Inventor, and Edit It Further
After you have imported the model back into Inventor, you have a solid model
that you can edit further using Inventor tools.
Import the assembly into Inventor:

1 Start

Autodesk Inventor.

2 On the ribbon ➤ Launch panel, click
(Open). Browse to the
\export\ folder in your 3ds Max Design tutorials project, change the file
type to SAT, then open the file mymaxclamp.sat.
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The modified blade clamp appears in Inventor, along with the new
connecting parts you created.

Use Inventor to edit the new parts:

1

Orbit the view so you can see the inside of the stirrup.
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2 On the ribbon, click the Model tab. On the Modify Assembly panel, click

(Fillet).
Inventor opens the Fillet dialog. Leave the settings unchanged to accept
the defaults, but set up filleting by clicking the rear edges of the U, both
inside and outside. Click the front corner edges of the U-clamp as well.
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3 On the Fillet dialog, click OK.
Inventor fillets the edges you clicked.
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If you want to experiment, you can fillet edges, or make other edits, to
the original blade clamp object as well.
Save your work:

■

Choose
Application menu ➤ Save As, and save the assembly
as mymaxclamp.iam. Click OK to save all components.
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Summary
In this tutorial, you saw how you can use the SAT format to share objects
between 3ds Max Design and Autodesk Inventor, and edit them in either
application.
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