
AUTODESK® 
3DS MAX®  
8 

Tutorial Guide
Volume III 

Date: 

09.09.05

Autodesk Part No.: 

 12811-050000-5000A

Colors: Black

K

Description:

3dsMax8_TutGd_BW_Mcvr.ai

Dimensions:
7" x 9" or
177.8mm x 228.6mm
front only



Copyright © 2005 Autodesk, Inc. All rights reserved.
This publication, or parts thereof, may not be reproduced in any form, by any method, for any purpose.

AUTODESK, INC., MAKES NO WARRANTY, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO ANY IMPLIED
WARRANTIES OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE REGARDING THESE MATERIALS, AND MAKES
SUCH MATERIALS AVAILABLE SOLELY ON AN "AS-IS" BASIS.

IN NO EVENT SHALL AUTODESK, INC., BE LIABLE TO ANYONE FOR SPECIAL, COLLATERAL, INCIDENTAL, OR CONSEQUENTIAL
DAMAGES IN CONNECTION WITH OR ARISING OUT OF PURCHASE OR USE OF THESE MATERIALS. THE SOLE AND EXCLUSIVE
LIABILITY TO AUTODESK, INC., REGARDLESS OF THE FORM OF ACTION, SHALL NOT EXCEED THE PURCHASE PRICE OF THE
MATERIALS DESCRIBED HEREIN.

Autodesk, Inc., reserves the right to revise and improve its products as it sees fit. This publication describes the state of this product at the time of its
publication, and may not reflect the product at all times in the future.

Autodesk Trademarks
The following are registered trademarks of Autodesk, Inc., in the USA and other countries: 3D Studio, 3D Studio MAX, 3D Studio VIZ, 3ds Max,
ActiveShapes, Actrix, ADI, AEC-X, ATC, AUGI, AutoCAD, AutoCAD LT, Autodesk, Autodesk Envision, Autodesk Inventor, Autodesk Map, Autodesk
MapGuide, Autodesk Streamline, Autodesk WalkThrough, Autodesk World, AutoLISP, AutoSketch, Backdraft, Biped, Bringing information down to
earth, Buzzsaw, CAD Overlay, Character Studio, Cinepak, Cinepak (logo), Civil 3D, Cleaner, Codec Central, Combustion, Design Your World, Design
Your World (logo), EditDV, Education by Design, Gmax, Heidi, HOOPS, Hyperwire, i-drop, IntroDV, Lustre, Mechanical Desktop, ObjectARX,
Physique, Powered with Autodesk Technology (logo), ProjectPoint, RadioRay, Reactor, Revit, VISION*, Visual, Visual Construction, Visual Drainage,
Visual Hydro, Visual Landscape, Visual Roads, Visual Survey, Visual Toolbox, Visual Tugboat, Visual LISP, Volo, WHIP!, and WHIP! (logo).

The following are trademarks of Autodesk, Inc., in the USA and other countries: AutoCAD Learning Assistance, AutoCAD Simulator, AutoCAD
SQL Extension, AutoCAD SQL Interface, AutoSnap, AutoTrack, Built with ObjectARX (logo), Burn, Buzzsaw.com, CAiCE, Cinestream, Cleaner
Central, ClearScale, Colour Warper, Content Explorer, Dancing Baby (image), DesignCenter, Design Doctor, Designer’s Toolkit, DesignKids,
DesignProf, DesignServer, Design Web Format, DWF, DWFit, DWG Linking, DXF, Extending the Design Team, GDX Driver, Gmax (logo), Gmax
ready (logo), Heads-up Design, Incinerator, jobnet, ObjectDBX, Plasma, PolarSnap, Productstream, Real-time Roto, Render Queue, Topobase,
Toxik, Visual Bridge, and Visual Syllabus.

Autodesk Canada Co. Trademarks
The following are registered trademarks of Autodesk Canada Co. in the USA and/or Canada and other countries: Discreet, Fire, Flame, Flint, Flint
RT, Frost, Glass, Inferno, MountStone, Riot, River, Smoke, Sparks, Stone, Stream, Vapour, Wire.

The following are trademarks of Autodesk Canada Co., in the USA, Canada, and/or other countries: Backburner, Multi-Master Editing.

Third-Party Trademarks
All other brand names, product names or trademarks belong to their respective holders.

Third-Party Software Program Credits
© 2005 Microsoft Corporation. All rights reserved.
ACIS © 1989–2005, Spatial Corp.
AddFlow Copyright © 1997–2005 Lassalle Technologies.
Certain patents licensed from Viewpoint Corporation.
clothfx is a trademark of Size8 Software, Inc.
OpenEXR Bitmap I/O Plugin © 2003–2005 SplutterFish, LLC
OpenEXR © 2003 Industrial Light and Magic a division of Lucas Digital Ltd. LLC

Portions Copyrighted © 2000-2005 Joseph Alter, Inc.
Licensing Technology Copyright © Macrovision Corp. 1996–2005.
Portions Copyrighted © 1989–2005 mental images GmbH & Co. KG Berlin, Germany.
Portions Copyrighted © 2000–2005 Telekinesys Research Limited.
Portions Copyrighted © 2005 Blur Studio, Inc.
Portions Copyrighted © 2005 Intel Corporation.
Portions developed by Digimation, Inc. for the exclusive use of Autodesk, Inc.
Portions developed by Lyric Media, Inc. for the exclusive use of Autodesk, Inc.
Portions of this software are based on the copyrighted work of the Independent JPEG Group.
JSR-184 Exporter Copyright (c) 2004 Digital Element, Inc.
QuickTime © 1992–2005, Apple Computer, Inc.
REALVIZ Copyright © 2005 REALVIZ S.A. All rights reserved.
ZLib © 1995–2003 Jean-loup Gaily and Mark Adler
This product includes Radiance software (http://radsite.lbl.gov/radiance) developed by the Lawrence Berkeley National Laboratory
(http://www.lbl.gov). Copyright © 1990–2005 The Regents of the University of California, through Lawrence Berkeley National Laboratory. All
rights reserved.
Wise Installation System for Windows Installer © 2004 Wise Solutions, Inc. All rights reserved.

GOVERNMENT USE
Use, duplication, or disclosure by the U.S. Government is subject to restrictions as set forth in FAR 12.212 (Commercial Computer Software-Restricted
Rights) and DFAR 227.7202 (Rights in Technical Data and Computer Software), as applicable.

http://radsite.lbl.gov/radiance
http://www.lbl.gov


toc

14 Basic.............................................................. 1
Creating and Animating a Flying Logo ................... 1
Creating and Animating a Flying Logo ...................... 1
Creating the Earth Using Textures .............................. 1
Animating the Rotation of the Globe.......................... 3
Adding the Text for the Logo ...................................... 4
Adding a Background and a Material ......................... 7
Adding a Spotlight....................................................... 8
Adding a Volume Light and Volume Fog .................. 10
Adding a Flare Effect ................................................. 14
Animating Still Life ................................................. 16
Animated Still Life..................................................... 16
Navigating a Scene .................................................... 17
Creating an Orange ................................................... 20
Adding a Material to the Orange............................... 22
Animating the Still Life Objects ................................ 23
Rendering the Animation ......................................... 26
Modeling a Space Scene ........................................ 28
Modeling a Space Scene ............................................ 28
Modeling the Planets................................................. 29
Creating an Asteroid ................................................. 33
Creating a Realistic Hourglass ............................... 35
Creating a Realistic Hourglass .................................. 35
Creating a Tapered Cylinder ..................................... 35
Adding a Free-Form Deformation............................ 38
Adding the Caps Using Auto Grid ............................ 41
Adding the Posts Using Hose Objects....................... 43
Adding Materials ....................................................... 44
Creating Glass and Sand Materials ........................... 46
Animating the Sand Level with Slice Modifiers........ 48
Animating the Falling Sand ...................................... 50
Creating the Sand Build-Up ...................................... 53
Adding a Camera....................................................... 55
Adding Default Lights to the Scene........................... 57

Rendering Your Work................................................ 58

15 Advanced.................................................... 61
Scene Management ................................................ 61
Scene Management.................................................... 61
Using the Sweep Modifier ......................................... 62
Creating Real-World Materials and Mapping........... 65
Using Radiosity Adaptive Subdivision ..................... 68
Saving Scene States .................................................... 70
Using Batch Render Tool........................................... 72
Creating Explosions ............................................... 74
Creating Explosions .................................................. 74
Animating the Laser Blast ......................................... 74
Creating a Material for the Laser Blast ...................... 75
Animating the Asteroid............................................. 75
Creating a Plane for the Explosion............................ 76
Creating a Material for the Explosion ....................... 78
Adding an Opacity Map............................................ 79
Synchronizing the Animated Maps .......................... 80
Cloning the Explosion Plane..................................... 80
Breaking the Asteroid into Flying Pieces with

Particle Array.......................................................... 82
Adding Materials to the Particles .............................. 83
Controlling Particle Animation ................................ 84
Setting Visibility Keys to Make the Asteroid

Disappear................................................................ 85
Adding Motion Blur .................................................. 86
Putting a Light Inside the Asteroid ........................... 87
Adding Render Effects to the Laser Blast .................. 88
Adding a Second Glow to the Explosion................... 89
Animating the Explosion’s Glow............................... 90
Adding Streaks with Radial Blur ............................... 92
Modeling a Revolving Door ................................... 93
Modeling a Revolving Door ...................................... 93

Contents



iv Contents

Setting Up Units and Snaps....................................... 94
Creating the Hub ....................................................... 95
Creating the Enclosure .............................................. 98
Creating the Revolving Door .................................. 101
Applying Materials to the Revolving Door ............. 104
Cloning the Door .................................................... 107
Animating the Revolving Door............................... 108
Merging Files ........................................................... 111
Camera Matching & Camera Map........................ 114
Using Camera Match............................................... 114
Preparing the Scene................................................. 115
Placing 3D Camera Points....................................... 116
Setting Up a Rendering Background ...................... 118
Checking the Rendering Resolution ....................... 119
Displaying the Background in the Viewport .......... 120
Using Different Files to Display the Same

Background .......................................................... 120
Installing the Software Driver ................................. 121
Assigning 2D Camera Screen Points....................... 121
Troubleshooting Camera Match ............................. 124
Matching Camera to View....................................... 124
Adding Effects with Camera Map ........................... 125
Adding Time Tags.................................................... 126
Animating a Cue Ball .............................................. 127
Creating a Matte Object .......................................... 129
Creating and Applying a Matte/Shadow Material .. 130
Creating the Pool Table Surface .............................. 132
Animating with Camera Map ................................. 133
Using Camera Tracker............................................. 136
How Camera Tracking Works................................. 136
Loading the Background Movie ............................. 137
Creating Camera Match Points ............................... 139
Loading the Movie into Camera Tracker ................ 141
Tracking the Features .............................................. 144
Match Moving the Camera ..................................... 146
Move Smoothing and Compositing........................ 147

Index ......................................................... 149



Creating and Animating a
Flying Logo
In this tutorial, you’ll learn to create a flying
logo for a fictitious company named Worldwide
Designs. Using shapes, modifiers, lighting effects
and Video Post, you produce an animated logo.

Skill Level: Beginner

Time to complete: 15 minutes

Features Covered in This Tutorial

• Creating and rotating a globe.

• Bending 3D text.

• Setting up a volume light.

• Creating fog.

Time to complete: 1 hour

Files for This Tutorial

The files for this tutorial are in the
\tutorials\worldwide_designs folder.

Note: All the necessary files to do the tutorials can
be found on the Tutorial Files CD that ships with
3ds Max 8. Before doing the tutorials, copy the
\tutorials directory from the CD to your \3dsmax8
local installation.

Creating the Earth Using Textures

You will create a sphere and apply a texture map to
create the illusion of a globe.

Create the earth object:

1. Start or Reset 3ds Max.

2. Open the Create panel and click Sphere.

3. In the Perspective viewport, move your cursor
over the center of the grid, then drag out a
sphere.

Basic
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4. On the Parameters rollout of the Modify panel,
change Radius to 5.0.

5. In the Viewport Navigation Controls, click
Zoom Extents Selected.

6. On the Name and Color rollout, change the
name of the sphere to Planet Earth.

Create the earth material:

1. On the toolbar, click the Material Editor
button or press M on the keyboard to open the
Material Editor.

The Material Editor opens in a floating window.
The first material is active, highlighted in white.

2. Rename the material Planet Earth.

3. Click the Assign Material To Selection
button.

4. In the Material Editor, open the Maps Rollout,
then in the Maps column, click the Diffuse Map
labeled None.

5. In the Material/Map Browser, on the right hand
column double-click Bitmap. In the Select
Bitmap Image dialog, navigate to and open
\tutorials\worldwide_designs\earthmap.bmp.

Bitmap texture for the planet

The material in the Material Editor now
displays the earth map on a sphere.

Texture displayed on material sample

6. Double-click the sample sphere if you want to
see the material in a larger window.

7. On the Material Editor toolbar, click the
Show Map In Viewport button.
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Texture map displayed in the viewport

8. Save your scene as wwdesigns.max.

Animating the Rotation of the
Globe

You’ll only have to set one rotational key to create
the illusion of the earth spinning. You build the
animation over a hundred frames and rotate the
sphere a full 360 degrees using a TCB Rotation
controller and the Rotation Windup command.
This creates the effect of an endless looping
animation.

Setup:

• Continue from the previous lesson, or open
\tutorials\worldwide_designs\tut_wwdesigns_
globe.max.

Keyframe the earth rotation:

1. Select the sphere and open the Motion panel.
In the Assign Controller rollout, select Rotation
: Euler XYZ in the Transform Rotation list.

Note: Euler XYZ rotation controllers are the
default, but here you will switch to a different
rotation controller that lets you use the rotation
windup command.

2. Click the Assign Controller button to open
the Assign Rotation Controller dialog. Select
TCB Rotation from the list

3. At the bottom of the Key Info rollout, turn on
Rotation windup

Important: You must turn on Rotation Windup or

else the animation won’t work correctly.

4. Turn the Auto Key button on.

The Auto Key button turns red and the active
viewport is outlined in red to remind you that
now you are in Auto Key Animation mode.

5. Move the time slider to frame 100.

6. Press the A on the keyboard to turn on Angle
Snap.

This will make it easy to rotation an exact
amount.

7. On the toolbar, turn on Select And
Rotate.

The rotate gizmo displays on the sphere in the
viewport.

Tip: Press the + key on the keyboard to increase
the size of the transform gizmo.

The rotation gizmo displays on the sphere
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8. Move your mouse over the blue Z axis ring of
the Rotate gizmo in the viewport. Rotate the
planet about the Z axis, watching the value
change in the coordinate onscreen readout in
the viewport. Stop when you see 360.

9. Turn off the Auto Key button.

10. Play the animation.

The sphere rotates smoothly in a
counterclockwise direction.

The next step is to rotate the earth’s axis to give
it a realistic tilt.

11.While Select And Rotate is still active, move
your cursor over the rotate gizmo in the
viewport. When the Y axis turns yellow, rotate
the earth approximately –15 degrees about the
Y axis so the earth is tilted.

Because the Auto Key button is off, this rotation
affects the entire animation.

12.Save your work as mywwdesigns02.max.

Tilted earth

You’ll notice the square selection brackets are tilted
along with the texture, but the transform gizmo
remains the same. That is because it is displaying
the View Coordinate system.

Adding the Text for the Logo

You’ll now create the flying logo by modeling
the three dimensional text using spline objects.
Later, you’ll add an extrude modifier and a Bend
modifier to create the desired text effect.

Setup:

• Continue from the previous lesson, or open
\tutorials\worldwide_designs\tut_wwdesigns_
glode_rotating.max.

Create a text object:

1. Activate the Front viewport, then right-click
the viewport label and choose Smooth +
Highlights to see the earth in shaded mode.

2. Zoom back in the viewport so the globe is
small but visible.

3. Open the Create panel > Shapes and in the
object type rollout, click Text. Click above the
earth in the viewport to place the default text.

4. In the Parameters rollout, go to the Text field
and type Worldwide Designs.

Tip: You can also copy and paste text into this
field.

5. Click the Font drop-down arrow, and change
the font to something boxy like SansSerif Bold.
If you don’t have that font, use anything else
that’s not too narrow.

Tip: You can type the first letter of the font to
quickly find it in the list.

6. Change the Text Size from 100 to 5.0.
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Worldwide Designs Text

7. Click the Zoom Extents to zoom in the
Front viewport.

Add extrude and bend modifiers:

Now add Extrude and Bend modifiers.

1. With the Text selected, choose Modifiers >
Object–Space Modifiers > Extrude. In the
Parameters rollout, set the Extrude amount to
0.5.

2. Click the color swatch next to the name of the
text, Text01. In the Color Selector, choose
white.

The text turns white in the viewport.

3. In the Front viewport, move the text down so
that it intersects with the sphere (globe). The
text still looks too big, so select the Text in the
modifier stack, and then change Size to 3.0.

The text moved to bisect the earth sphere

4. Click Extrude in the modifier stack and apply
a Bend modifier from the Modifier List >
Object-Space Modifiers.

You’ll use this to bend the text around the earth.

5. In the Parameters rollout, change the Bend Axis
to X, then set the Bend Angle to 180.

6. Activate the Top viewport. Zoom in on the
earth and text if necessary.

7. Move the text down in the Top viewport, as
shown in the illustration.

The text is moved down in the Top viewport

8. Right-click the Top viewport label and choose
Smooth + Highlights.

9. Save the scene as mywwdesigns03.max.
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Adjust the pivot point:

1. With the text selected, open the Hierarchy
panel, then in the Adjust Pivot rollout, turn on
Affect Pivot Only.

The pivot point of the text object is displayed
as a tripod.

2. On the Tools menu, choose Align, then click
the earth sphere object in the viewport. This
displays the Align Selection dialog.

3. In the Align Position (Screen) group, turn on
X, Y, and Z.

4. Set both the Current Object and Target Object
to Pivot Point. Click OK.

The pivot point is aligned to the center of the
earth sphere object.

Pivot point of text object aligned to planet earth object

5. Turn off Affect Pivot Only.

6. In the Front viewport, rotate the text about the
Y axis so that it matches the tilt of the planet.

As you rotate the text, you can refer to the
onscreen coordinate readout in the viewport.

7. On the toolbar, set the Reference Coordinate
System to Local.

Rotated text matches the tilt of the earth

Now you can finally animate the text rotating
around the planet. You’ll set it going in the
opposite direction from the way the earth spins.

Animate the text:

1. Make sure Text01 is still selected,
then open the Motion panel. In the Assign
Controller rollout, select Rotation in the
Transform Position list.

2. Click the Assign Controller button to open
the Assign Rotation Controller dialog. Select
TCB Rotation from the list

3. At the bottom of the Key Info rollout, turn on
Rotation Windup.

4. At frame 0, turn on the Auto Key
button and rotate the text around the Y axis
until the text is behind the sphere.

No key will be created, yet.
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Rotation for text at frame 0

5. Move the time slider to frame 100, then rotate
the text around the Y axis-360 degrees.

Notice that you have keys at frame 0 and frame
100 now.

6. On the Key Info rollout, set Continuity to 0.

If Continuity is not displayed in the Key Info
rollout, click the Rotation button in the PRS
Parameters rollout.

This allows the text to rotate around the earth
at a continuous rate of speed.

7. On the Key Info rollout, move to key number 1
using the arrows, then set Continuity to 0.

8. Turn off the Auto Key and play
the animation. The rotation of the text and
earth sphere should be smooth and loop
continuously.

You can now add a couple of lights for dramatic
effect.

9. Activate the Top viewport and Zoom out
so you see some empty space around the Earth.

10. In the Create panel, choose Lights
and click Omni. Then in the Top viewport, set

a light in front of and another light behind the
planet.

Add lights for drama.

11. Save your work as mywwdesign04.max.

Adding a Background and a
Material

You’ll make the scene more interesting by simply
adding a background that makes the earth sphere
appear to be in outer space. You’ll then add a shiny
gold material to the logo text for more impact.

Set up the scene:

• Continue from before, or open
tut_wwdesigns_globe_text_rotating.max.

Add a background:

1. Open the Rendering menu > Environment.

2. Click the Environment Map button. In the
Material/Map Browser, double-click Bitmap.
Navigate to \tutorials\worldwide_designs and
choose stars10.jpg.

This is a large high resolution starfield
background.

3. Move the time slider to frame 50.
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4. Activate the Perspective viewport and
click the Quick Render button.

The image renders with the Earth in front of
the stars.

Warning: If you’ve set your rendering resolution to

something too small you won’t see the stars in the

rendering. You need to render at 640 x 480 to really

see the stars in this background image file.

The next step is to make the logo text more
interesting.

Add a material to the text:

1. On the main toolbar, click the Material
Editor button. Click an unused sample sphere.

2. Click the Get Material button. In the
Browse From group, click Mtl Library, then
double-click Metal_Dark_Gold [Standard] .

The sample sphere displays a shiny gold
material.

3. Make sure Text01 is selected, click the
Assign Material to Selection button.

4. Click the Show Map in Viewport button.

The text is now gold.

5. Render the scene.

Golden text

6. Save your work to an incremental file
name. Choose File > Save As. Click the
incremental save button.

Now, you’ll add a spotlight that will illuminate
each letter of the logo as it rotates.

Adding a Spotlight

• Continue from before or open
tut_wwdesigns_globe_text_bground.max.

Create a spotlight:

You’ll add a target spotlight that casts a focused
beam of light onto each letter of the logo as it
rotates. The target in this case is the earth so that
you can easily align the beam of light to the logo
text.

1. In the Top viewport, slide the time slider to
frame 50 so that the logo text is rotated around
the lower half of the earth sphere.

Note: The illustrations display the text in white,
not gold.

2. Go to the Create panel > Lights and click
Target Spot.
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3. In the Top viewport, click below the logo text
and drag upwards until the light cone touches
the edge of the sphere.

4. Go to the Modify Panel. The Spotlight name
appears at the top of the panel. On the Spotlight
Parameters rollout use the Falloff/Field spinner
to narrow the beam of light. Try changing the
Field to 7.0.

5. Select the spotlight target.

Tip: If it’s difficult to select the spotlight target,
type H on the keyboard. In the Select Objects
dialog, select Spot01.Target.

6. Select Tools menu > Align and click the earth
sphere.

7. In the Align Position (Local) group, click X, Y
and Z Positions. For Current Object and Target
Object, click Center. Click OK.

The spotlight target is now aligned to the center
of the sphere so that the light shines on the text
logo.

8. Select the spotlight source, Spot01. Open
the Modify panel and click Exclude from the
General parameters rollout.

9. Select the object Planet Earth from the Scene
Objects list, then click the >> button. Click OK.

This prevents the spotlight from illuminating
the earth sphere.

10.Right-click the Perspective viewport label and
select Views > ActiveShade to see how the light
illuminates the text.

It’s quite likely that further adjustment needs to
be made so that the spotlight target illuminates
only one letter at a time.

11.Right-click in an empty place in the viewport
and select Close from the upper–left quadrant
menu.

12. With the Modify panel still active, scroll
the rollouts until you can see the Spotlight
Parameters rollout. In the Light Cone group,
make sure Circle is turned on.

13.Experiment with different values for
Hotspot/Beam and Falloff/Field until the size of
the light beam is focused on only one letter.
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Target spot illuminating the letter R

14.In the Perspective viewport, play the animation.

If you prefer that the logo text scroll more
slowly, you’ll add an additional 100 frames to
the animation.

Add frames to the animation:

1. Click the Time Configuration button.

2. In the Time Configuration dialog, set Length
to 200.

3. On the toolbar, click the Select by Name
button. In the Select Objects dialog, select
Planet Earth and Text01.

The keys appear in the track bar.

4. On the track bar, select the key at frame 100
and slide it to frame 200.

5. Play the animation again. The logo text and the
earth sphere rotate more slowly.

6. Save your work to an incremental file name.
Choose File > Save As. Click the + button.

Adding a Volume Light and
Volume Fog

You’ll now add a fog effect to the spotlight and
create a light foggy haze around the planet.
Volume Light provides light effects based on the
interaction of lights with atmosphere, such as fog.

Set up:

• Continue from before or open
tut_wwdesigns_globe_add_vol_lite.max.

Create a Camera from View

If you’re continuing from before, you’ll notice that
there is no camera in the scene yet. You can create
one by doing the following:

1. Activate the Perspective Viewport. Adjust it as
you like to frame your shot.

2. On the Views menu, click Create Camera from
View.

The Perspective viewport label changes to
Camera01.

Add another spotlight

Now you’ll create another spotlight shining from
underneath the globe.

1. Activate the Front Viewport, and zoom back so
you have more room.

2. On the Create panel click the Lights
button. Turn on Target Spot and drag out
a Spotlight below the planet. Set the target
slightly above the planet object in the Front
Viewport.

3. Adjust the hotspot so it is wider than the planet,
but not a wide as the ring of text.
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You’ll use this spotlight to creating a halo of
light beams behind the planet. You’ll turn on a
few options for the lights to give a good result
for the effect.

On the Modify panel turn on Shadows On.

4. On the Intensity/Color/Attenuation rollout,
increase the Multiplier to 4.0.

Add a volume light:

You can assign the volume light directly in the
modify panel, or you can assign it using Rendering
menu > Environment.

1. Activate the camera viewport.

2. Go to the Rendering menu > Environment.

The Environment and Effects dialog appears.

3. In the Atmosphere rollout, click Add.

4. In the Add Atmospheric Effect dialog, select
Volume Light and click OK.

5. In the Volume Light Parameters rollout, click
Pick Light.

6. Click on the Spot02 light in the viewport or
press the H key and pick the Spot02 object from
the list.

Spot02 appears in the field next to the Remove
Light button.

7. Press F10 to do a test render.

Tip: As you repeat the process of entering values
and rendering, you will find that the field
cannot be active for the rendering keyboard
shortcut to work.

When you enter something in a field, press
enter and click outside the field, then press F9
to render last.

By playing individual values you can adjust the
effect.

8. In the Volume group change the Density to 20.
Press F9 to Render Last.

Turn on Exponential and press F9
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9. You can also see the changes you’ve made, in
the Exposure Control rollout, by clicking the
Render Preview button.

10.Press H on the keyboard and select Spot02, if
it isn’t selected already. On the Modify panel,
open the Advanced Effects rollout.

11.In the Projector Map group click the button
marked None. Double-click Bitmap in the
Material Map Browser and then choose
Droplets.tga.

Adding a projector map will dramatically add
detail to the volume effect.

12.Press F10 to Render.

13.On the Modify panel turn on Decay, setting it
to Inverse.

In the Near Attenuation group turn on Use and
Show. Set the Start to 11.0 and the End to 32.0

In the Far Attenuation group turn on Use and
Show. Set the Start to 33.0 and the End to 43.0

Note: These are suggested values, yours may
vary.

14.Press F9 to render again.

15.For a more dramatic effect you can exclude
the globe from the Spotlight. On the General
Parameters rollout, click Exclude. In the
Include/Exclude dialog, highlight the Planet
object name and use the right-pointing arrow
to move it to the right window, then click OK.
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16.On the Intensity/Color/Attenuation rollout
adjust the Near and Far Attenuation values so
the effect tapers off within the viewport.

17.If you’d to hide the effect below the globe,
reposition the Spotlight and Spotlight target.
Move it in small increments and repeatedly
render until you have found a location you
like. By tilting the spotlight slightly, rather
than using it straight up, you can get a more
interesting effect.

18.Save you work as mywwdesign07.max

Add volume fog:

You’ll now create an additional fog effect around
the earth. But first, you need to create a type of
helper object called an Atmospheric Apparatus
that will serve as a container for the fog.

1. On the Create panel, click Helpers, and select
Atmospheric Apparatus from the drop-down
list.

2. Click SphereGizmo.

3. In the Top viewport, select the center of
the earth and drag outwards to create the
SphereGizmo. Make it a little bit larger that the
size of the earth.

4. With the SphereGizmo still selected, click
the Modify tab. In the Atmospheres and Effects

rollout, click Add. In the Add Atmosphere
dialog, highlight Volume Fog and click OK.

Now you need to setup the volume fog
parameters.

5. In the Atmospheres and Effects rollout window,
select Volume Fog. Click Setup.

6. In the Volume Fog Parameters rollout, click
Pick Gizmo. Select the SphereGizmo, if it
doesn’t already appear in the dialog.

SphereGizmo01 appears in the field next to the
Remove Gizmo button.

7. In the Volume group, click the white color
swatch. In the Color Selector, dialog, pick a
light bluish purple color. Drag the whiteness
selector to lighten the color. Click OK.

The color you selected is now displayed in the
Color swatch.

8. In the Volume group turn on Exponential and
increase the Density to 100.0.

9. In the Noise group, select Fractal. This gives the
fog a less uniform appearance.

10.In the Noise group change the High Threshold
to 0.1.

Change the Levels to 6.0.

Change the Size to 1.0.

11.Press F9 to render

12.Make more adjustments to get the look of a
cloud cover.
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13.On the toolbar click Select and Link. Link the
SphereGizmo to the globe. Play the animation.

The fog spins with the globe.

14.Save your work as mywwdesigns08.max

Adding a Flare Effect

Using Video Post, you can add events that occur in
a finished video. In this case, you are using Video
Post to add a flare effect that simulates a bright
star behind the earth sphere to give the animation
more of an outer space look.

Create a dummy object:

You’ll first need to create a dummy object that will
serve as the “placeholder” for the flare effect.

1. Proceed with the file you saved in the last lesson
or open tut_wwdesigns_globe_fog.max from
the \tutorials\worldwide_designs directory.

2. On the Create panel, click Helpers >
Dummy.

3. In the Top viewport, drag out a square above the
earth sphere. Position the dummy so it is visible
behind the globe in the Camera viewport.

4. In the Name and Color rollout, name the
dummy Flare Dummy.

Add a flare effect:

You’ll now use Video Post to easily create an effect
that will add interest to your animation.

1. Choose Rendering menu > Video Post.

The Video Post dialog appears.

2. From the Video Post toolbar, click Add
Scene Event. In the View group, name the Label
Camera01. Click OK.

The animation will be created using the
Camera01 viewport.

3. Click Add Image Filter Event. . Select
Lens Effects Flare from the drop-down list.
Click OK.

For the Label, enter Flare Effect

4. Click Add Image Output Event. Enter
wwdesigns with flare effect. Click the
Files button. For the output file name,
enter wwdesigns0000.tga. In the Targa
Image Control dialog turn on 24 bit in the
Bits-per-pixel option.

By naming the file with four zeros at the end of
the name, the program knows that you want
to render an ordered sequence. Setting up
your work this way will let you render a high
resolution still image sequence.
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The Video Post now lists all the events you just
created in a queue.

5. In the Video Post Queue, double-click Flare
Effect. In the Edit Filter Event, click Setup.

You’ll now set some settings in the Lens Effects
Flare dialog that will create a bright star with
rays behind the earth.

6. Click Preview.

A generic preview window displays a flare
effect.

You can change this to display your scene.

7. Click VP Queue to see the earth and the logo
text.

Tip: If the logo text is behind the earth, move the
time slider in 3ds Max to a frame where the logo
text is in front of the earth. Click Update in the
Lens Effects Flare dialog to update the preview.

8. In the Lens Flare Properties group, click Node
Source.

9. In the Select Flare Objects list, choose Flare
Dummy. Click OK.

Now that the dummy object is set as the source,
you can now make changes to some settings.

10.To better see each effect, go to the Prefs panel
and in the Render column, turn off all the
effects. Now turn each one separately and look
in the preview to see the effect by itself.

11.To create the appearance of a bright star in the
background, turn on Rays and Star.

You’ll change a few settings to make the distant
star a little more noticeable.

12.Go to the Rays panel. Set these values:

• Size=450

• Angle=45

• Num=300

Click Update to see the changes.

If you cannot see any effects, move the Flare
dummy object in the viewport and then click
Update in the preview window again until the
rays are in the desired location.

13.Go to the Stars panel. Set these values:

• Size=100

• Sharp=10
Turn on Random. Click Update.

14.Turn on Glow on the Prefs panel.
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You’re now ready to render your animation.
Click OK to exit the dialog.

15. On the Video Post toolbar, click Execute
Sequence.

16.In the Time Output group, turn on Range.
Enter 1 in the first field and 200 in the second
field. In the Nth Frame field enter 2. Click
Render.

Video Post now renders every other frames of
your animation and adds the effects you created
in a post-production video. Since you’ve
selected every second frame, the rendering
will go faster and the animation will play more
quickly.

Depending on the speed of your computer,
the rendering may take some time. While you
wait, you can watch the animation progress in
the frame buffer window and in the Video Post
rendering progress dialog.

17.In 3ds Max, go to Render menu > RAM Player.

The RAM player lets you load high resolution
still image sequences into memory and play
them back.

18.On the RAM player toolbar, click Open
Channel A. Navigate to the image sequence
you rendered, and select the filename of the 1st
image. At the bottom of the dialog, turn on
Sequence, then Open.

The files load into the RAM Player.

19.When the files are loaded, play the animation
using the Play controls on the RAM player
toolbar.

Once the files are loaded into the RAM player,
you can save them out as a movie file. Choose
Save Channel A, and then select the file type
and file name you want.

Summary

In this tutorial, you have created a flying logo. You
have created a globe using primitive objects and
texture maps. You have created and animated text
to develop the logo treatment, and added gold
metal material and spotlights for dramatic effect.
You have added atmospheric and volume light
effects, as well as a lens flare using Video Post.
Finally you have rendered your animation to a still
image sequence and assembled it into a movie
using the RAM player.

Animating Still Life
This tutorial, intended for those new to 3ds Max,
offers a quick introduction to the world of 3D
while you play with some traditional elements of
art. Using basic features of the program, you’ll
create a composition of an orange and an apple, a
windowsill and wall, a bottle and a knife. You’ll
also add lights and a camera, and view the scene
from different angles. The final steps introduce
you to some basic animation.
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Animated still life

When you learn to paint, you start with a still
life, perhaps a bottle and some fruit arranged on
a table. In this tutorial, you’ll make a “not-so-still
life” that is animated.

The idea for this tutorial was taken from the
Salvador Dali painting “Nature Morte Vivante,”
in which the traditional elements of a still life are
painted flying through the air. You’ll use the same
idea for your first animation project in 3ds Max.

Skill Level: Beginner

Time to complete: 20 minutes

Features Covered in This Tutorial

As you do this tutorial, you’ll be learning a number
of things at once:

• How to open a scene

• How to model objects and apply realistic
materials

• How to navigate the viewports and interface
of 3ds Max

• How to move and animate objects

• How to render

Tutorial Files

All the necessary files for this tutorial can be found
on the Tutorial Files CD in the \tutorials\still_life
directory. Before starting the tutorials, copy the
\tutorials folder to your local\3dsmax8 installation.

Navigating a Scene

In this lesson, you’ll open an existing scene of a
still life and learn to adjust the view and navigate
the viewports.

Navigating the scene

1. Choose File menu > Open.

Find the \3dsmax8\tutorials\still_life
directory on your hard drive and highlight
still_life_start.max, then click Open.

Note: The files for this tutorial can also be found
in the \tutorials\still_life folder of the Tutorial
Files CD. Copy that directory to your hard drive
to open local copies, rather than opening the
files directly from the CD.

Perspective viewport

The Perspective viewport should be active,
indicated by a yellow border. If it’s not,
right-click to activate this viewport.
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2. Click the Zoom button in the viewport
navigation controls at the lower-right corner
of the screen.

The button turns yellow to show it’s active.

3. Press and drag downwards in the viewport.

Your view zooms back so you can see the corner
in the scene.

Zooming back reveals the corner.

4. Click Arc Rotate in the viewport
navigation controls at the lower-right corner of
the screen. It highlights when active.

A yellow navigation orb appears in the
viewport.

5. Move the cursor inside the yellow circle. Press
the left mouse button and move the mouse.

The viewport arc rotates, changing the
perspective view.

Rotating the viewport

Tip: Avoid pressing outside the yellow
navigation orb, unless you want to roll the
entire viewport.

6. Use the orb to spin your view so you can see the
scene from every angle.

You’ll notice that the backside of the corner is
dark. This is because there are already hidden
lights in this scene prepared to cast shadows in
your rendering.

7. Right-click in the viewport to dismiss the
yellow circle.

8. Click Pan in the viewport navigation
controls and move the mouse in the viewport.

The viewport pans with your movement.

Note: You can also start a pan operation by
holding down the middle mouse button or
wheel as you pan. If the middle mouse button
doesn’t pan the viewport, check your mouse
driver settings.

9. To return the viewport to its original
orientation, press SHIFT+Z repeatedly to undo
the viewport changes all the way back to the
beginning.

Next you will create a camera and a Camera
viewport. The Camera viewport is similar to the
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Perspective viewport, but with more functionality.
It can be animated, and effects can be added to it.

Creating a camera

1. Right-click the Top viewport to activate it.

The Top viewport is outlined in yellow.

2. Right-click the Top viewport label (the word
Top at the upper left corner of the viewport).
On the menu that appears, choose Smooth +
Highlight.

The viewport display changes from wireframe
to shaded.

Tip: You can press F3 to turn a wireframe
viewport display into shaded display.

3. On the Create panel, click the Cameras
tab, then click Target.

4. In the Top Viewport, on the lower left-hand
corner of the wooden shelf, press and drag to
create a camera pointing toward the knife (see
the following illustration).

Camera created in Top viewport

Press CTRL+D to make sure the new camera is
not selected.

To see what the camera sees, you need to change
one of the viewports into a Camera viewport.
You’ll replace the Front viewport with a Camera
viewport.

5. Right-click the Front viewport to activate it.
Then press C on the keyboard.

The Select Camera dialog appears.

Click Camera02, then OK.

The camera you created is Camera02. There
was already a Camera01 hidden in this file.

Tip: When a scene contains more than one
camera and none of the cameras is selected,
pressing C will cause the Select Camera dialog
to appear. If there is just one camera in the
scene, or if just one camera is selected, pressing
C will change the active viewport to the
indicated camera.

6. Press F3 to change the wireframe display into
Smooth + Highlight shading.

The view from Camera 02

If you look at the navigation controls, you’ll
see they have changed. Tools and controls
are context-sensitive, so the active Camera
viewport has shifted the navigation controls.

7. Experiment with the various camera navigation
controls, to zoom, pan, arc-rotate, and so on in
the Camera viewport.

Tip: To undo Camera viewport changes, press
CTRL+Z, or click Undo at the left end of the
Main toolbar. Unlike the Perspective viewport,
Camera viewport changes are based on the
movement of the camera.

Next you will render the scene.
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Rendering the scene

You’ve looked at the scene from many different
angles now. But the viewport only tells part of the
story. You need to render the viewport to an image
to see the full effect.

1. On the toolbar, press the Render Scene
button.

The Render dialog appears.

2. Look at the very bottom of the dialog. Make
sure the Viewport: field says Camera02, then
click Render.

The virtual frame buffer appears, and the
rendering takes place line-by-line from the top
to the bottom of the image.

Rendering from Camera02 zoomed in

3. Change the Camera viewport to Camera01.
Make sure the Camera viewport is active and
no cameras are selected, then press C and select
Camera01 from the list.

4. Render again.

Observe the rendering. You’ll see shadows
on the wall, reflections in the knife blade and
bottle, and transparency on the leaf objects.
None of these were visible in the viewport
display.

Rendering from Camera01

5. Right-click the Camera viewport label, and
choose Views > Front to change the Camera
viewport back to a Front viewport.

Next, you’ll create an orange to add to the scene.
Then you’ll animate the objects so they fly into
place.

Creating an Orange

Here you’ll create a sphere primitive, color it
orange, and name it. Then you’ll add a realistic
orange peel material to it, so the rendering will
have the speckled appearance of fruit skin.

Create a sphere:

1. On the Create panel, click the
Geometry tab, then in the Object Type rollout,
click Sphere.

The button highlights to show that it is active
and ready to use. Before you make the sphere,
you’ll make two changes in the Create panel.

2. At the bottom of the Parameters rollout, turn
on Base To Pivot.

Base To Pivot lets you create a sphere with its
pivot point at its bottom.
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To create the sphere so the orange is resting on
the wooden slab, like the rest of the objects in
the scene, you’ll use the AutoGrid function.

3. On the Create panel, directly below Object
Type and above the primitive object names,
turn on AutoGrid.

AutoGrid creates a grid on the surface of any
object, so you can create another object directly
in contact with the surface.

4. In the Perspective viewport, move your cursor
between the apple, the bottle, and the knife
blade.

After a moment, a tooltip will appear showing
you what object you are over. The tooltip
should say wooden board.

5. Create a sphere by pressing down on the left
mouse button and dragging away from where
you started. As long as you hold the mouse
button down, you can adjust the size of the
sphere. When you release the mouse button,
the sphere is complete.

Tip: Don’t worry if your object is a different
color from the one in the illustration.

Create a sphere using AutoGrid

6. In the Create panel > Parameters rollout,
change the Radius field to 20 and press ENTER.

The sphere changes size in the viewport. In
3ds Max, it’s typical practice to rough out an

object with the mouse, then reset one or more
of its parameters to your specific requirements.

Change the color and name of the sphere:

By default, 3ds Max chooses colors at random for
new objects, so the sphere is probably not orange.
You can change the color of the sphere in the
viewport to simulate an orange.

1. In the Create panel > Name And Color rollout,
click the small, colored square next to the
default name, Sphere01.

The Object Color dialog is displayed.

2. Select an orange color and click OK.

The sphere in the viewport turns orange.

3. Double-click the name Sphere01 to highlight it.

4. Type in orange to change the name of the
sphere. Press ENTER to set the new name.

Note: Pressing ENTER is the explicit way
to make a change to a parameter. 3ds Max
also accepts the change as soon as you click
anywhere on the screen.

Move the orange:

You might want to move the orange so it is slightly
in front of the apple. To do that, you’ll use the
Transform gizmo.

1. On the main toolbar, click the Select And
Move button.

A tripod of red, blue, and green arrows appears.
This is the transform gizmo. As you move
your cursor over the arrowheads, the axis label
and arrow stem will turn yellow. When they
are yellow, you can press and drag to move the
object in one direction only. If you move your
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cursor over the inner corners of the transform
gizmo, the plane turns yellow. This lets you
move in only one plane at a time.

2. Using the transform gizmo, move the orange so
it is in front of the apple.

Transform gizmo used to move the orange

The rendering looked so interesting because of the
materials that have been applied to the geometry.
Next, you will apply a material to the orange using
the Material editor.

Adding a Material to the Orange

Materials use bitmap images to texture objects
in your scene. The bottle label, the leaves, and
apple all get their appearance from bitmap texture
mapping on the objects in the still life scene.
Bitmaps can also be used as other kinds of maps,
such as opacity maps (on the leaves, for example).

Bottle-label texture

Apple texture

Add an orange material:

1. On the toolbar, click the Material Editor
button.

Tip: You can also press M on the keyboard to
launch the Material Editor.

The Material Editor opens as a floating window.
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Material Editor displays materials.

2. Locate the material that looks orange in the
Material Editor.

It should already be selected, surrounded by
a white outline to show it is active. If it isn’t
active, click it to select it.

Notice that the name of the material orange
appears in the Material Name field.

This orange material has already been
constructed for you. It uses a bitmap as a
texture and as a bump map.

Orange texture map

3. Drag the orange material from the Material
Editor sample onto the orange in the viewport.

The orange in the viewport now displays with
a speckled fruit skin.

4. Press F9 on the keyboard to render again. If you
like, you can zoom in on the orange, render,
then undo the viewport change by pressing
SHIFT+Z.

Rendered close-up of orange

You can find more information on Modeling
and Materials in the Modeling and Materials
chapters of the online tutorials.

Next you will see how easy it is to create
animation using the Auto Key method in
3ds Max 8.

Animating the Still Life Objects

In this lesson, you will animate the objects. You
learn how to make objects fly off screen, much like
the network logos you see on television.

You’ll do this with keyframe animation, using Auto
Key mode. You set the important or key positions
for the objects in the scene at different points
in time. 3ds Max figures out all the in-between
positions.
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The procedure consists of three steps. At frame 50,
you will rotate the bottle and the knife to create
rotation keys for them. You will then position the
apple and the orange so they are floating in the air.
Then, using the track bar, you will shift the keys
around to reverse the animation.

There are three ways to create keyframes. One is
to turn on the Auto Key button, move to any point
in time, and transform (move, rotate, or scale)
the object. A second method of setting keyframes
is to right-click the time slider, and then set keys
using the Create Key dialog. There is also a Set
Key animation mode designed for professional
character animators.

You’ll use the Auto Key button in this exercise.

Animate the position of the orange:

1. Continue with your own scene, or open
still_life_with_orange.max.

2. Click the Auto Key button.

The button turns red. You are now in
automatic animation mode.

Tip: The time slider also turns red, and the
viewport is outlined in red to remind you that
you are in Auto Key mode.

3. In the Perspective viewport, move your mouse
over the orange.

After a moment a tooltip appears that says
Orange.

4. On the toolbar, click the Select Object
button, if it isn’t already active, then click to
select the orange.

5. The Time Slider is the bar located directly above
the Time Scale display below the viewports.
Move the time slider to frame 50.

6. Right-click the orange and choose Move from
the transform quad menu

In all viewports, you see the transform gizmo.

7. As you move your mouse over the Transform
gizmo, the different axes highlight one at a time.
When the Z-axis highlights, click and hold the
left mouse button, and drag the orange straight
up in the Perspective viewport until it is almost
out of view. Release the mouse button.

Because you’re working in animation mode,
you have now set a key for the orange. Notice
that the key appears as a red square in the line
below the time slider.

8. Move the time slider back and forth from frame
0 to frame 50, and watch the orange rise up
from the wooden counter.

Note: If you still have one of the viewports set
to Camera01, you will see the animated view
of Camera01.

Animate the rotation of the bottle:

1. Return to frame 50.

2. In the Perspective viewport, click the bottle
to select it, or press H and select the bottle by
name.

3. Right-click the bottle in the viewport and
choose Rotate from the transform quad.

The transform gizmo appears over the bottle.
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As you move your cursor over the transform
gizmo, different axes display as yellow. The axes
are color-coordinated (red, green, and blue
equals X, Y, and Z, respectively).

4. Rotate about the Y-axis approximately 127
degrees so the bottle is upside down, with the
bottle bottom up in the left-hand corner of the
viewport. (See illustration).

You can see the X,Y,Z values displayed in
yellow above the transform gizmo as you rotate
the bottle. These values also appear in the
Coordinate Display below the viewport.

Tip: You can enter values directly in the
coordinate fields for precision in your work.

Bottle rotated 127 degrees about Y-axis

5. Again move the time slider back and forth from
frame 0 to frame 50 to observe the animated
effect.

You’ll repeat this for the knife and the apple.

6. Return the time slider to frame 50. Then select
the handle of the knife in the viewport, or press
H and select the object namehandle from the
list.

The knife blade is linked to the handle, so when
you animate the handle, you’ll be animating the
knife blade as well.

7. Rotate should still be in effect. If it isn’t, click
Rotate on the Transform toolbar. Use the
transform gizmo to rotate the knife handle
around in the viewport. Then right-click and
choose Move from the quad menu. Move the
handle in Z, then in X, and then in Y so the
knife is closer and larger than before in the
viewport.

8. Repeat for the apple.

Rotated still life objects

9. In the animation playback controls,
press the Go To Start button, then press the Play
Animation button.

Watch the animated objects fly up in the air.

10.Turn off Auto Key.
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Develop the habit of turning Auto Key off after
animating, otherwise you might accidentally
create unwanted animation.

Reverse the animation:

It’s a simple procedure to reverse this animation.
You’ll move keys in the track bar to accomplish
this.

1. Press H on the keyboard.

The Select object dialog appears.

2. Hold down the CTRL key and click the bottle,
apple, orange, and handle in the list. Then click
Select.

The objects are displayed with selection
brackets in the viewport. The keys for all the
animated objects are displayed on the track bar.

3. In the track bar, drag a selection rectangle
around the keys at frame 0.

The keys turn white on the track bar to show
they are selected.

4. Hold down the SHIFT key and drag the keys
from their position at frame 0 to frame 100

This creates a copy of the keys from frame 0 to
frame 100.

5. Press the Play Animation button in the
VCR controls to see the animation you’ve
created

The still life objects fly up and around at frame
50 and then return to their positions at frame
100. The animation loops because the position
and rotations at frame 0 and 100 are the same.

6. Save your scene as my_still_life_animated_
loop.max to your folder on your local drive.

Experiment with changing the animation:

You can change the animation so the objects fly
in from off screen.

1. With all four objects still selected, select the
keys at frame 0 as before. Delete with the DEL
key.

An animation range bar appears below the keys
in the track bar. If you do not see an animation
range bar appear, place the cursor over the Scale
Time button and right-click. Choose Configure
from the menu and then choose Show Selection
Range.

2. Click and drag the range bar to the left, so the
animation starts at frame 0 and ends at frame
50.

Again play the animation.

Tip: Depending on how you rotated your
objects, you might need to recreate the rotation
keys if the objects no longer spin the way you
want them to. To do this, go to frame 0 and,
with the Auto Key button on, rotate the objects
again.

3. Again save your scene to your local folder, this
time as my_still_life_animated_flyin.max.

Rendering the Animation

Rendering multiple frames for a complete
animation is time consuming, even on fast
machines. Each frame is individually processed.
Realistic materials, shadow casting, and other
factors can slow the process as well. When
you’re ready to take a break, you can render this
animation, then come back after a short time and
see the results.

Render your animation:

To complete this tutorial, render the animation
you made earlier. The rendering time is probably
under 15 minutes, depending on the speed of your
machine.

1. On the menu bar, do the following:
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• Choose File > Open to load
your saved animations, either
my_still_life_animated_loop.max or
my_still_life_animated_flyin.max. Or you
can open still_life_animated.max.

• Choose Rendering menu > Render to
display the Render Scene dialog.

2. If you did not save the completed files back to
the same tutorial directory, when you select
one of your files to open you might encounter
a Missing Map / Photometric Files dialog. If
you do run into this problem, press the Browse
button. The Configure Bitmap / Photometric
Paths dialog will appear. Click the Add button.
In the Choose New Bitmap Path dialog,
navigate to the directory where you loaded the
original file. Click the Use Path button. On the
Configure Bitmap / Photometric Paths dialog,
click OK. On the Missing Map/Photometric
Files dialog, click Continue.

3. In the Render Scene dialog > Output Size
group, change the default (640 x 480) to 320 x
240.

This smaller size has only one-quarter the area
of the default, making it much faster to render.

4. In the Time Output group, turn on Active Time
Segment.

5. In the Render Output group, click the Files
button. In the Render Output File dialog, name
your animation mystill_life_animated.avi.
Click Save to save the animation to the \images
subdirectory.

Warning: You must either add the extension .avi in

the file name, or else select AVI as the file type. If you

don’t tell the program what type of animation format

to save in, the rendering won’t work.

Tip: When working professionally it is better
practice to not render directly to a movie file
format. You should instead render to a sequence
of still image files such as TGA or TIF and then

assemble them into a movie using Video Post
or the Ram Player. For more information on
this method see the Rendering chapters in the
online tutorials.

6. In the Video Compression dialog, do the
following:

• If necessary, change the compressor to
Cinepak Codec. There are lots of different
codecs to choose from. Cinepak generally
gives satisfactory results.

• Set the Compression Quality high, between
90 and 100.

• When you’re done, click OK.

7. On the Render Scene dialog, notice that the
field next to the Files button now shows the
location of mystill_life_animated.avi.

8. At the bottom of the Render Scene dialog, from
the list labeled Viewport, select Perspective.

You always want to be sure you’re rendering the
right viewport.

Tip: Usually you will use a camera viewport,
rather than rendering the Perspective viewport.
In this case, since the animation was created in
the Perspective viewport, you’ll use that.

9. Click Render to begin the rendering process.

Watch a few frames to make sure nothing is
terribly wrong. The Time Remaining estimate
will give you an idea of how long the rendering
will take.

Play the rendered animation:

1. When your animation is finished rendering,
chose File menu > View Image File.

By default, the View File dialog opens in the
\images subdirectory.

2. Highlight mystill_life_animated.avi and click
Open to display the Media Player.

3. Play your animation from the Media Player.
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4. If you like the animation, you can render it
again at 640 x 480. This will take 4 times as long
as the smaller resolution, probably around 30
minutes. Or you can load the other animation
file and render that one.

You’ll find finished AVI files of both
animations (the fly-in and the loop) in the
\tutorials\still_life folders if you want to skip
the rendering entirely.

Summary

You have created an animated still life and learned
to find your way around the 3ds Max user interface.
You’ve learned viewport navigation, created an
orange using primitives, and assigned materials.
You’ve also learned to move objects, animate and
render your animation.

Modeling a Space Scene
In this tutorial, you will create a planet and its
moons, and an asteroid.

Skill Level: Beginner

Time to complete: 45 minutes

Features Covered in This Tutorial

• Creating primitive objects

• Moving objects in the scene

• Using a modifier to alter an object’s shape

Tutorial Files

All the necessary files to do the tutorials can
be found on the Tutorial Files CD in the
\tutorials\intro_to_modeling folder. Before
starting any tutorials, copy the \tutorials folder
from the CD to your \3dsmax8 local installation.
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Modeling the Planets

In this lesson, you will create the planet Mars and
its moons. You will also make changes to the
objects in the Create panel.

If at any point the object parameters disappear,
choose the Select Object tool from the main
toolbar and reselect the object. Then open the
Modify panel and make your changes there.

Create the planet:

1. Choose File > Reset. Click Yes in the dialog to
reset.

2. Open the Create panel. Make sure the
Geometry button is on, and click Sphere in the
Object Type rollout.

3. In the center of the Perspective viewport, drag
to create a sphere of any size.

4. In the Name And Color rollout, change the
name of the object from Sphere01 to Mars.

5. In the Parameters rollout, change the Radius to
100 and set the Segments to 64.

Increasing the number of segments makes
the planet look smoother. This is especially
important for close-up shots, where every detail
is revealed.

6. Click Zoom Extents Selected from the
Zoom Extents flyout.

The sphere moves back and to the center of the
viewport.

Note: The grid is no longer visible because the
size of the grid is fixed and is too small to be
displayed after the zoom was performed.

Create the moons:

Mars has two moons named Deimos and Phobos.
Instead of making additional spheres, you can
create the objects by cloning.

1. Right-click in the Top viewport and click
Zoom. Place the zoom cursor on the X axis,
just to the right of the sphere.

2. Drag downward to zoom out. Stop when Mars
looks half its previous size.

Tip: If necessary, click Pan to move the
scene so that you can see Mars in its entirety.

3. Click Select and Move from the toolbar.

The Transform gizmo appears in the viewport.

Note: If the transform gizmo does not appear,
press the keyboard shortcut, X, to make it
appear.

4. Hold down Shift on the keyboard and drag the
gizmo’s X axis to the left and then release the
mouse button.
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5. In the Clone Options dialog, leave Copy
selected and change the name of the new object
from Mars01 to Deimos. Click OK.

6. Open the Modify panel and change the
Radius parameter of Deimos to 22. Since this
object is smaller than Mars, reduce its segments
to 24.

7. Shift-clone the second moon from the Deimos
moon using the same process, only this time
position the clone closer to Mars. When the
Clone Options dialog appears, name this
second moon Phobos.

8. Set the radius of Phobos to 11 so that it is half
the size of Deimos.

9. Right-click in the Front viewport and
pick Select and Rotate from the toolbar.

10.Click Mars and rotate it around the Z axis by
moving the mouse over the blue transform
gizmo ring until it turns yellow. Drag down
the left side of Mars until it’s rotated about 15
degrees.

Tip: Watch the shaded rotation indicator in the
gizmo as you rotate or watch the Z axis field in
the coordinate readout below the time bar.

Mars tilted in a shaded viewport

11. Click Zoom Extents All so each viewport
displays the planet Mars and its moons, Deimos
and Phobos.

12.Save the file as my_mars.max.

To see Mars and the planets with texture
maps, open mars_texturemapped.max in the
\tutorials\intro_to_modeling folder.

To learn more about materials and mapping, refer
to Introduction to Materials and Mapping (page
1–114).

Map the planet Mars:

To create the illusion of physical texture, you’ll
build a new material, assign an image as a diffuse
map, and then use the same image as a bump map.
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1. Continue from the previous lesson.

If you opened mars_texturemapped.max
from the \tutorials\intro_to_modeling folder,
click File > Open and reload your scene,
my_mars.max.

2. Press M on the keyboard to open the Material
Editor.

3. Select the upper left sample sphere. In the name
field, highlight the text then change the name of
the material to Mars.

The selected sample sphere and new material name.

4. In the Shader Basic Parameters rollout, change
the shader from Blinn to Oren-Nayar-Blinn.

This gives the sphere a softer look.

5. In the Oren-Nayar-Blinn Basic Parameters
rollout, click the blank square button next to
the Diffuse color swatch to select a map for
the diffuse component. In the Material/Map
Browser, choose Bitmap and click OK.

The Select Bitmap Image File dialog opens.

6. Select the map mars.jpg from the
tutorials\intro_to_modeling folder and
click Open.

The map appears on the sample sphere.

7. Drag the Mars material to the planet Mars.

8. Right-click the Front viewport label and choose
Smooth + Highlights, if it’s not already set.

The planet turns gray. In the Material Editor,
the corners of the material sample slot turn
white, indicating that the material is being used
in the scene.

9. Click the Show Map In Viewport button
in the Material Editor.

The Mars map appears on the surface of the
planet in the scene.

10.Highlight the text in the name field and
rename the new map in the drop down list to
Mars-Bitmap.

11. Click Go To Parent.

The Material Editor navigates up the material
hierarchy from the map level to the material
level.

12.Close the Oren-Nayer-Blinn Basic Parameters
rollout by clicking its title bar. Then click
the Maps rollout to expand it. The button
next to Diffuse bears the label "Mars-Bitmap
(mars.jpg)."

13.Drag the map button from the Diffuse
component to the Bump component. When
the Copy/Instance Map dialog appears, choose
Instance and click OK.
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By choosing Instance, any change you make
to the bitmap parameters of one map, will
automatically be reflected in the other.

14.Set the Bump amount to 50.

15. Render the scene.

The surface of Mars appears bumpy.

Map the moons:

1. Click and drag the Mars material sample in
the Material Editor to an unused sample slot.
Rename the new material to Deimos.

2. In the Maps rollout, click the button labeled
"Mars-Bitmap (mars.jpg)" to navigate to the
maps hierarchy.

3. Rename the Mars-Bitmap in the list to
Deimos-Bitmap.

4. In the Bitmap Parameters rollout, click the
Bitmap button to replace the mars.jpg image
with a new one. In the Select Bitmap Image File
dialog, find and select deimos.jpg , then click
Open.

5. Click the Go to Parent button, or select
Deimos in the List drop-down, to navigate back
up the maps hierarchy.

In the Maps rollout, notice that the Bump map
uses the deimos.jpg file. This is due to the
Instance you made when building the Mars
material.

6. Click and drag the Deimos material to the
Deimos object in the scene.

Tip: If you’re not sure which sphere is Deimos,
watch for the object label to appear when you
drag your cursor over an object.

The object label confirms you’re about to apply the
material to Deimos.

7. Repeat these steps for the moon, Phobos. Use
the phobos.jpg file as the new diffuse map.

8. Right-click the Perspective viewport and use
the view navigation tools to arrange your scene.

9. Render the scene.
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10.Save your scene as my_mars_and_
moons.max.

Creating an Asteroid

Modifiers can be used to alter the shape of a
primitive object. In this lesson, you will use a
modifier to distort a sphere into an irregular shape
to form an asteroid.

Set up the lesson:

1. Open asteroid1.max from the \tutorials\intro_
to_modeling folder.

In a single viewport, you see two spheres, one
large and one small.

2. Click the Min/Max Toggle in the viewport
controls to show four viewports.

Tip: You can also toggle the Min/Max view by
means of the keyboard shortcut, ALT+W.

Create an asteroid using the Noise modifier:

1. Select the larger sphere.

2. In the Name And Color rollout, change the
name from Sphere01 to Moon.

3. Select the smaller sphere and rename it
Asteroid. Press ENTER.

4. Press P to switch the Camera viewport to a
Perspective viewport.
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5. Make sure the Asteroid object is still
selected. On the Zoom Extents flyout, choose
Zoom Extents Selected.

The asteroid is zoomed in to fill the Perspective
viewport.

6. Open the Modify panel. In the Modifier
List, choose Noise from the Modifier List.

The Noise modifier creates random distortion
on an object’s surface.

7. In the Noise Parameters rollout, turn on Fractal
and set the Scale to 30. Then set these values for
Strength: X to 25, Y to 10, and Z to 20.

The object deforms to look like an asteroid.

Experiment with the asteroid:

1. Change the Seed value.

This changes the random displacement of the
surface, giving you a totally different shape.

Changing the Seed yields different shapes.

2. Try applying some other modifiers to the
object, such as Bend, Taper, Twist, and Stretch.
Experiment with the parameters to see the
variety of shapes you can make.

3. Save your file as my_asteroid.max.
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Summary

In this tutorial, you learned how to model a scene
using primitives and modifiers. You also learned
how to add materials to the objects. These tools
are the building blocks for any scene in 3ds Max.

Creating a Realistic
Hourglass
In this tutorial you will learn to model a realistic
hourglass using primitive objects and modifiers.
You’ll use cylinders and hose objects combined
with Free-Form Deformation (FFD), Taper, and
Slice modifiers. You’ll even create the flow of sand
using a particle system.

Skill Level: Beginner

Time to Complete: 40 minutes

Features Covered in This Tutorial

• Using Taper, and FFD modifiers to shape the
hourglass.

• Using an animated Slice modifier to create the
shifting sand level, in the upper globe of the
hourglass.

• Using a Particle system to create the falling sand
in the lower globe of the hourglass.

• Using an animated hemisphere to create the
sand piling up.

Tutorial Files

All the necessary files to do the tutorials can
be found on the Tutorial Files CD, in the
\tutorials\hourglass folder. Before doing the
tutorials, copy the \tutorials directory from the CD
to your \3dsmax8 local installation.

In This Tutorial

Creating a Tapered Cylinder (page 3–35)

Adding a Free-Form Deformation (page 3–38)

Adding the Caps Using Auto Grid (page 3–41)

Adding the Posts Using Hose Objects (page 3–43)

Adding Materials (page 3–44)

Creating Glass and Sand Materials (page 3–46)

Animating the Sand Level with Slice Modifiers
(page 3–48)

Animating the Falling Sand (page 3–50)

Creating the Sand Build-Up (page 3–53)

Adding a Camera (page 3–55)

Adding Default Lights to the Scene (page 3–57)

Rendering Your Work (page 3–58)

Creating a Tapered Cylinder

You’ll start by building the chamber that will
contain the sand using a cylinder and then add a
taper modifier. Using the symmetry and curve
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parameters, you’ll create the approximate shape of
an hourglass.

1. Restart 3ds Max by choosing File > Reset.

2. Click the Min/Max Toggle button found
in the view navigation tools at the lower right
corner of the user interface. This switches from
a display of four, small viewports to a single,
large one. The currently active viewport is the
one that is enlarged, in this case the Perspective
viewport.

3. On the Create panel click Cylinder.

4. Right-click the Snap Toggle button to
open the Grid and Snap Settings dialog and
make sure the Grid Points snap setting is active
and all other snap settings are turned off. Close
the Grid and Snap Settings dialog.

5. Press S on the keyboard to turn on Snaps. As
you move your cursor in the viewport you will
see the blue snaps icon displayed as you pass
over the grid points.

Snap Cursor.

6. When your cursor is snapped to the center
of the grid, click the mouse button and drag
outward to begin creating a cylinder. Press S
again while you are dragging to toggle snap off.

Using Snap in this fashion lets you create the
cylinder exactly in the center of the grid, but
you can make the radius any amount you want
by turning snap off in the middle of the action.

Drag outward to set the cylinder’s radius.

7. Drag out any radius you want, then release the
mouse button and drag upward. Now you are
setting the height. Click to finish.

Drag upwards to set the cylinder’s height

It doesn’t matter what radius and height you
create now because you will later change them.

8. Click the Zoom Extents button to center
the scene in the viewport.

9. On the Modify panel, in the Parameters
rollout, change the Cylinder Radius to 20 and
the Height to 60. You can either type the values
or use the spinner.

Tip: Use the Tab key to move from field to field
as you type the values.
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10.Right-click the Perspective viewport label and
choose Edged Faces from the menu. You should
see the height segments as well as the shaded
faces.

Edged Face display

11.Increase the cylinder’s Height Segments to 10.

Additional height segments displayed on the cylinder.

12.From the Modifiers menu, select Parametric
Deformers > Taper. The Parameters rollout
shows the default Amount setting of 1.

The cylinder tapers in the viewport.

13. In the modifier stack, click the plus button
to expand the stack, then click Center.

The Center tripod is visible in the viewport, as
well as the orange taper gizmo.

Taper center

14.On the Parameters rollout, in the Taper Axis
group turn on Symmetry, then move the
center gizmo upwards in the viewport. Use the
transform gizmo to move in the Z direction.
Move your cursor over the transform gizmo.
When the blue Z axis turns yellow, drag
upwards to move the taper center about halfway
up the height of the cylinder. Release the mouse
button to place the gizmo center.
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Move the Taper center.

15.Type 30 in the Z field of the Coordinate Display
at the bottom, just to the left of the Set Keys
button. This places the gizmo precisely at the
center of the cylinder’s height.

16.In the modifier stack, select Cylinder. This
lets you make changes to the original cylinder
parameters.

On the Parameters rollout of the Modify panel,
reduce the radius of the cylinder to 3.

17.Click Taper in the modifier stack, then on the
Parameters rollout increase the Taper Amount
to 10 and set the Curve amount to 10.

Increased taper and maximum curve amount.

Two more adjustments will make this look
more like an hourglass.

Tip: If you don’t see the taper when you
highlight the Cylinder, turn on the Show End
Result on/off toggle button at the bottom of the
modifier stack display.

18.Select Cylinder from the modifier stack and
increase the Height Segments to 29.

By creating an odd number of height segments,
you create a small band around the center of
the hourglass.

19.Select Taper from the modifier stack and reduce
the amount of Taper to 5.

The chamber is taking shape.

20.Save your work. Choose File > Save and save
your scene as MyHourglass.max.

Although the object is beginning to look more like
an hourglass, it still needs some refinement. In the
next lesson, you’ll add an FFD modifier that will
allow you to narrow the passage where the sand
will flow from the upper chamber to the lower one.

Adding a Free-Form Deformation

The Free-Form Deformation (FFD) modifier
provides a lattice of control points that let you
deform geometry.
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Continue from the previous lesson or
load sands_of_time1.max found in the
\tutorials\hourglass directory.

1. On the Modify panel, open the Modifier List
and choose FFD(cyl).

Tip: To quickly locate FFD(cyl), press F from
the keyboard to cycle through all the modifiers
that begin with the letter ’F’.

The FFD gizmo is applied to the tapered
cylinder.

Free-Form Deformation Lattice enclosing the cylinder.

2. On the FFD Parameters rollout, in the
Dimensions group, click Set Number Of Points.
On the Set Dimensions dialog, increase the
Height to 15 and click OK.

Now there are many more lattice control points
to work with.

3. Click the Min/Max Toggle to reset the
display to four viewports. Then right-click the
Front view.

Note: Activating a viewport by right-clicking
in it will not deselect any selected objects.
Left-clicking will activate the desired viewport
but deselect any objects.

4. Right-click the Front viewport label and turn
on Smooth + Highlights and Edged Faces.

5. From the view navigation tools, click
Zoom Extents so that you can zoom in on the
FFD Lattice.

Front view of lattice.

6. On the modifier stack, click the plus button
next to FFD(cyl) to expand it. Select Control
Points.

Tip: If the modifier stack is blank, click
the Select Object button on the toolbar, and
select the cylinder.

7. From the view navigation tools, turn on
Arc Rotate, then rotate the perspective viewport
so you can see the grid behind the hourglass.

View grid behind the hourglass.
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It’s important to use a 3/4 view so that you will
be able to see the transform corners when they
appear.

Now, you’ll select the vertices in the Front view,
so you’re sure to get horizontal rows, then scale
the vertices using the transform gizmo in the
Perspective view.

8. In the Front viewport, drag a selection rectangle
around the middle horizontal row of control
points.

The control points become outlined in yellow
to show they are selected. You are selecting the
points in the Front viewport

Select the middle row of FFD control points.

9. On the toolbar, turn on Select and
Uniform Scale. Right-click in the Perspective
viewport to activate it without losing the
selection you made in the Front viewport.

10.Press the plus key on the keyboard three times
to increase the size of the transform gizmo.
Now you can see the three sets of transform
corners and plane handles.

Scale the transform gizmo display.

11.To scale the vertices of the lattice in the
Perspective viewport, move your mouse over
the inner set of triangular plane handles.
When the scale cursor appears, click and drag
downward. As you move the cursor, watch the
coordinate display change. Release the mouse
button when the X, Y, Z fields display 30.

Scale cursor appears over the inner plane handle.
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Drag downward to deform the center.

To refine the shape of the hourglass, you’ll need
to repeat this process on all the horizontal rows
of control points, scaling two rows at a time.
This is a two-step process:

• Selecting the rows of vertices in the Front
viewport.

• Scaling in the Perspective viewport.

To select the control points, drag a selection
rectangle around a row, then press the CTRL
key and select the corresponding row in the
opposite half of the hourglass. Select each pair
of rows then scale them in varying amounts to
create the hourglass shape.

Here is the shape you are trying to achieve.

FFD lattice scaled from the front.

12.When you are finished, turn off the Control
Points level in the modifier stack left-click in
the Perspective viewport to deselect the object.

13. Turn on Arc Rotate, click inside the yellow
circle, then drag the cursor around to view the
object from different angles. It’s good to look at
objects from all sides while you work.

Sculpted object.

14.Save your work as MyHourglass1.max.

The next stage in transforming the hourglass
involves adding the caps and posts.

Tip: You could more easily create an hourglass by
drawing a shape and then using a Lathe modifier to
make it 3D. Because the purpose of this tutorial is
to learn about modeling with primitive objects and
using FFDs, we have taken a different approach.

Adding the Caps Using Auto Grid

The Auto Grid tool lets you create an object
aligned to the surface of another one. For this part
of the exercise, you’ll use Auto Grid to create a cap
for the top of the hourglass.

1. Turn on Arc Rotate, then drag the cursor
around to view the object so that the top part of
the hourglass is clearly visible.



42 Chapter 14: Basic

2. On the main menu, choose Create > Extended
Primitives > Chamfer Cylinder.

3. At the top of Object Type rollout on the Create
panel, turn on the Auto Grid Toggle.

4. Move your cursor over the top of the hourglass.
A small tripod should appear, which follows
your mouse. Press and drag outward to set the
radius of the Chamfer Cylinder, then release the
mouse button and continue dragging upward
to set the height and chamfer.

Use Auto Grid to create one object on the surface of
another.

5. In the Parameters rollout, set Fillet to 1.

Next, you need to align the Chamfer Cylinder
so that it is centered over the hourglass.

6. Make sure the Chamfer Cylinder is still selected.
From the Tools menu choose Align, then click
the Cylinder (the hourglass object) in the
Perspective viewport.

7. In the Align Selection dialog, turn on X
Position and Y Position, then click OK.

The Cylinder Cap is now centered over the top
of the hourglass shape.

8. In the Parameters rollout, adjust the radius so
there is room for the posts. Try a Radius of
26. Depending on how you scaled the FFD
controls, you might need to change the radius.

Add the cap of the hourglass using Chamfer Cylinder.

Although you can repeat the process to create
the bottom cap, we’ll use a simpler method.

9. Select the Chamfer cylinder, then on the Tools
menu, choose Mirror.

10.On the Mirror dialog, in the Clone Selection
group, turn on Instance. Set the Mirror Axis
to Z, and use the spinner to adjust the Offset
to –60. Click OK.

Create a clone by using Mirror with Offset.

11.Choose File > Save As to save your work as
MyHourglass2.max.
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Adding the Posts Using Hose
Objects

You can build the posts using an extended
primitive called a Hose object. This makes it
simple to create nice looking posts.

1. On the menu bar choose Create > Extended
Primitives > Hose.

2. From the Create panel > Object Type rollout,
turn on the Auto Grid Toggle, if it’s not already
on.

3. Move your cursor over the bottom chamfer
cylinder. The Auto Grid tripod displays. Press
and drag to set the radius of the hose.

4. Release the mouse button and drag upward to
set the height of the post.

Now you can adjust the hose parameters to
modify its appearance.

5. In the Common Hose Parameters, set the
following values:

• Starts: 37

• Ends: 64

• Cycles: 2

• Diameter: –36

6. In the rollout, scroll down to the Hose Shape
group. Make sure Round Hose is turned on,
and then set the following values:

• Diameter: 3.5

• Sides: 6

Hose object used to create a post.

With the post created, you can now clone it
using one of several ways. Here you will align
the hose object’s pivot point to match the pivot
point of the chamfer cylinder. Then you’ll use
SHIFT+Rotate to create the other posts.

7. On the Hierarchy panel, in the Adjust Pivot
rollout, click to turn on Affect Pivot Only.

8. On the menu bar choose Tools > Align, then
click the bottom chamfer cylinder.

9. In the Align Selection dialog, turn on X
Position and Y Position in the Align Position
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group. Click OK. The pivot is now positioned
as shown in the illustration.

Align the hose pivot with the chamfer cylinder.

10.In the Adjust Pivot rollout, turn off Affect Pivot
Only.

11. On the toolbar, turn on Select and
Rotate. Hold down the SHIFT key and move
your cursor over the Transform gizmo for
the post (displayed where the new pivot is
located). When the Z axis ring turns yellow,
rotate the post. As you move the mouse, watch
the coordinate display until it reads 90 degrees,
then release the mouse button.

Rotate the hose 90 degrees.

Tip: To increase precision, you can turn on
the Angle Snap by pressing the A keyboard
shortcut.

12.In the Clone Options dialog, make sure
Instance is turned on, then set the number of
copies to 3. Click OK.

There are now four posts displayed in the
viewport.

Clone using SHIFT+Rotate.

13.Save your work. On the menu bar choose
File > Save As, and save the model as
MyHourglass3.max.

Now that you’ve built a basic hourglass, you’ll
add some materials to give it some realism.
After making the glass chamber transparent,
you’ll create the sand contained within the
chamber.

Adding Materials

You can create your own materials or open
materials that exist in another file. You’ll do both
in this next section.

Continue from the previous lesson or open
sands_of_time2.max from the \tutorials\hourglass
folder.
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Open existing materials from a library:

1. On the toolbar, click the Material Editor
button.

You can also open the Material Editor by typing
to keyboard shortcut, M.

2. Click the Get Material button in the
Material Editor.

The Material/Map Browser appears.

3. In the Material/Map Browser, in the Browse
From group, choose Mtl Library, then click File
> Open at the bottom.

4. In the Open Material Library dialog, navigate
to the \matlibs folder and choose 3dsmax.mat.
Click Open.

The Material/Map Browser fills with materials.

Large icons in the Material/Map Browser.

There are many interesting textured materials
in this library. When you have time, look
through them so that you can learn about these
materials. For this exercise, you’ll open two
materials that you’ll apply to the hourglass.

5. Scroll through the materials until you see
Metal_Dark_Gold. Double-click that material
so that you can see it in the Material Editor.
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Get Metal_Dark_Gold material from a file.

Next you’ll locate a Wood material.

6. In the Material Editor, click the top-middle
sample sphere to activate it. Then click Get
Material and scroll through the materials until
you find Wood_Burloak. Double-click that
material to transfer it to the Material Editor.

The Wood_Burloak material is added to the Material
Editor.

7. Close the Material/Map Browser.

You’ll now find out how easy it is to add these
materials to the objects in the scene.

Add the materials:

1. In the viewport, select either the top or bottom
cap of the hourglass.

2. In the Material Editor, click the Assign
Material To Selection button. The Wood

material appears on the cap in the viewport.
Repeat the process for the other cap.

You can also drag materials from the Material
Editor and drop them onto the objects in the
viewport. The objects don’t even have to be
selected first; just drag right onto them.

3. In the Material Editor, click the sample slot that
contains the Metal_Dark_Gold material, and
drag the material to all of the posts.

4. Right-click the Perspective viewport label and
turn off Edged Faces.

The Wood_Burloak and Metal_Dark_Gold materials
applied to the hourglass.

You’ve opened some pre-made materials for gold
and wood. Now you’ll make your own materials
for glass and sand.

Creating Glass and Sand Materials

In this lesson, you’ll make a transparent material
to simulate glass and a new solid material to
represent sand. For the glass materials, you’ll add
transparency falloff and increase the glossiness,
then make the material two-sided so you can see
through to the inside of the glass.

1. Click the upper-right material sample slot in
the Material Editor to activate it.
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2. In the Material name field, name the material
Glass.

Giving your materials logical names helps you
keep track of what you’ve made. Any materials
that you make can be stored in custom material
libraries so you can reuse them in the future.

3. Drag the material onto the hourglass in the
viewport.

The hourglass should turn gray; the same as
the sample sphere.

4. In the Material Editor, click the
Background button (right side of sample
spheres). A checkered background displays
behind the purple sphere. This background is
helpful in seeing transparencies in materials.

There are four options you need to adjust
before the material will start to look like glass.
You’ll change the opacity, the color, the specular
values, and set it to be two-sided.

5. In the Blinn Basic Parameters rollout, set the
Opacity value to 22.

6. In the same rollout, click the Diffuse color
swatch. In the Color Selector dialog, choose
a light blue color. If you prefer, you can type
these values into the Red/Green/Blue (RGB)
fields at the right, then click Close:

• Red: 112

• Green: 211

• Blue: 243

Changes to the material are automatically reflected on
the model.

7. In the Specular Highlights group, increase the
Specular Level to 88, and the Glossiness to 33.

Glass material.

In the Options rollout, turn on 2–Sided.

This option controls the visibility of the inside
of the hourglass so that it displays.

Note: There is one additional setting for this
glass, but it won’t be visible until you render the
file to a bitmap image.

8. In the Material Editor, open the Extended
Parameters rollout. Set the Falloff value to In,
and Amount to 88.

You’ll now create the sand material, which is
easy to do because it doesn’t require as many
settings as the glass material.
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9. Click the sample slot in the lower-left corner to
activate it. In the Material name field, type the
name Sand.

10.Click the Diffuse color swatch. In the Color
Selector, choose a light brown color or enter
these RGB values:

• Red: 216

• Green: 185

• Blue: 137

The Red/Green/Blue settings for sand.

11.Save your scene as MyHourglass4.max.

Now that the Glass and Sand materials are created,
you’ll create the sand in the hourglass. Once you’ve
created it, you’ll apply the sand material.

Animating the Sand Level with
Slice Modifiers

The Slice modifier is a handy tool for creating the
sand in the upper chamber of the hourglass. You’ll
use two Slice modifiers, and then animate the Slice
gizmo to create the effect of the sand level sinking
in the glass.

1. Select the tapered cylinder object in the
viewport.

2. On the menu bar, choose Edit > Clone.

The Clone Options dialog appears.

3. In the Clone Options dialog, click Copy, and
then name the clone Sand in upper globe.
Click OK.

4. Right-click the Perspective viewport and
choose Hide Unselected. Everything should be
hidden in the viewport except for the Sand in
upper globe object.

5. In the Material Editor, click the Assign
Material To Selection button.

The object in the viewport is assigned the sand
material.

Sand material on object in viewport.

6. Go to the Modify panel. In the modifier
stack, click to highlight the FFD(cyl) modifier,
then on the menu bar, choose Modifiers >
Parametric Deformers > Slice.

The Slice plane is displayed in the viewport.

7. In the stack display, expand the Slice modifier’s
hierarchy, and highlight Slice Plane.

8. In the Slice Parameters rollout, turn on Remove
Bottom.

9. On the toolbar, click to turn on the Select
and Move button.

10.In the viewport, select the Z arrow of the
Transform gizmo and move the mouse upward
so that the Slice plane causes the lower half to
disappear entirely from view.
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Slice plane with remove bottom turned on.

Tip: If Necessary, watch the other viewports to
gauge how much slicing occurs.

11.In the modifier stack, click Slice again to
deselect the Slice Plane. Now right-click the
stack display, choose Copy, right-click again
and choose Paste.

A second Slice modifier appears in the Stack
above the original.

12.Expand the Slice modifier’s hierarchy, and
highlight Slice Plane.

13.Move the Slice plane two-thirds up the globe,
and then in the Slice Parameters rollout change
Slice Type to Remove Top.

Second Slice plane removes top.

14.Select the Slice at the top of the modifier stack,
and then on the menu bar, choose Modifiers >
Mesh Editing > Cap Holes.

15.In the Parameters rollout, turn on Smooth With
Old Faces.

16.Scroll down to the bottom of the modifier stack
and select Cylinder, then reduce the Radius to
2.8.

This will make the sand look like as if it’s inside
the glass.

17.Right-click in the viewport and choose Unhide
All.

18. On the toolbar, click Select and Rotate. In
the modifier stack, select the uppermost Slice
Plane. Rotate the Y axis of the gizmo so that the
level of the sand looks a little uneven.

Sand made using Slice Plane and Cap Holes modifier.

19. Click to turn on the Auto Key button.

20.Move the time slider to frame 100. In the
modifier stack, highlight the top Slice Plane.

21. On the toolbar, click Select and Move
button. Then move the Slice Plane downward
along the Z axis of the Transform gizmo in the
viewport until the sand completely disappears.
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The sand has disappeared.

22. Turn off the Auto Key button,
then click the Play button.

The sand level in the upper globe slowly
descends.

23.Save your work. Choose File > Save As and save
your file as MyHourglass5.max.

Next, you’ll create the illusion of the falling sand by
using the Snow particle system.

Animating the Falling Sand

Particle systems create effects that would be too
laborious to make using geometry.

Create the particle system:

1. Continue from the previous lesson or
open sands_of_time3.max found in the
\tutorials\hourglass directory.

2. Select the sand in upper globe object in the
viewport. Make sure you see its name in the
Name field, then right-click and choose Hide
Selection.

This hides the sand.

3. On the menu bar, choose Create > Particles >
Snow.

4. In a blank area of the perspective viewport,
click and drag outward to create a Snow emitter.

An emitter specifies where in the scene particles
are generated.

Snow emitter.

5. Play the animation and watch the snow particles
in the viewport.

Play the snow system animation.

6. On the toolbar, click Select and Move
button. Then type in the Coordinate Display X:
0, Y: 0 Z: 30.

The snow emitter moves to the correct location
at the neck separating the top and bottom
chambers of the hourglass.
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Tip: To quickly set the X and Y axis coordinates
to zero, right-click the spinner arrows. Any
current value is set to zero.

7. On the Modify panel, in the Parameters rollout,
in the Emitter group, change the width and
length of the emitter to 1.5.

Snow particle system falling through the neck.

Create space warps:

The particle system interacts with space warp
objects so that the particles can be controlled in
various ways. You’ll create two different space
warps, Gravity and UDeflector. The Gravity space
warp will force the particles to move downward,
and the UDeflector space warp will keep the
particles from passing through the bottom of the
hourglass.

1. On the menu bar, choose Create > Space Warps
> Forces > Gravity.

2. In an empty area of the viewport, click and drag
outward to create a Gravity space warp.

The placement of the space warps are not
important, you can put them anywhere in the
scene.

3. On the menu bar, choose Create > Space Warps
> Deflectors > UDeflector. In an empty area of
the viewport, click and drag outward to create
a UDeflector.

4. In the Basic Parameters rollout, in the
Object-Based Deflector group, click Pick
Object, then in the viewport click the bottom
plate (ChamferCyl02) of the hourglass.

5. In the Particle Bounce group, set Bounce to 0.
This will allow the particles to “collect” on the
UDeflector.

6. Select the Snow Emitter in the viewport.

7. On the toolbar, click the Bind to Space
Warp button. Then click and drag from the
Snow emitter to the Gravity space warp.

Binding the Snow emitter to the Gravity Space Warp

8. Repeat the process for the UDeflector, binding
the Snow emitter to the UDeflector.

Adjust the appearance:

1. Now click the Play button to play the
animation.

You’ll change the appearance of the snowflakes
so that they look like falling sand.

2. Stop the animation. Select the Snow emitter
in the Modify stack, then in the Parameters
rollout, enter these settings in the Particles
group:

• Viewport Count: 375
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• Render Count 888

• Flake Size:0.8

• Speed:0.5

• Variation:0.5

Warning: In general, it is not a good idea to

increase the Viewport Count very much. This can

seriously slow down 3ds Max. If you do increase

the Viewport Count, don’t use the spinner to do

so. If you inadvertently set the spinner to a very

high amount, you could incur a long wait. Always

enter the values using the keyboard or number

keys.

Now you need to make an adjustment in the
Timing group.

3. In the Timing group, turn off Constant. Set Life
to 60 and Birth Rate to 1.0.

The snow is under control.

Animate the falling sand:

1. With the Snow selected, open the Material
Editor (if it isn’t already open), and select the
Sand material, then click Assign Material To
Selection.

2. Right-click the viewport and choose Unhide
All and Play the animation.

Sand made from particles and animated Slice modifier.

To make the effect of the particles disappearing,
you’ll animate the Birth Rate of the particles.

3. Click the Time Configuration button.
In the Time Configuration dialog, in the
Animation group, set the Length to 120. Click
OK.

4. Click to turn on the Auto Key button,
then with the Snow selected, move the time
slider to frame 102.

In the Parameters rollout, change the Birth Rate
to 0.0. This will stop the particles emitting at
frame 102, since the birth will stop.

The particles that were already emitted will
continue to fall.

Now move backwards in time to where the sand
in the upper chamber is getting smaller and
the stream in the lower chamber needs to be
stronger.

5. Move the time slider to Frame 86, and set the
Birth rate to 6.0.

This will ensure a solid fall of sand at this frame.

6. Move backwards to Frame 78, and set the Birth
rate to 5.9.

This keeps the falling sand falling.
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7. Move backwards to Frame 15, and set the Birth
rate to 6.9

This adds momentum to the falling sand.

8. Move backwards to Frame 0, and set the Birth
rate to 5.0.

This keyframe starts the fall of the sand while
the sand level drops in the upper chamber.

9. Move the time slider forward in time to frame
106 and set the Birth rate to 1.

This will allow you to set a key at frame 106.
Once the key is set you’ll change it’s values
using the time bar right-click menu.

10.On the time bar, select the key at frame 106,
right-click and choose Snow01: Birth Rate
from the list.

11.In the Snow01 Birth Rate dialog, change the
Value to –52 and set the In and Out tangents
to Smooth.

This works to end the stream of falling sand.

12. Turn off the Auto Key button
and then play the animation.

The sand descends, the stream falls in concert
with the sand in the upper chamber.

Sand falling at frames 15, 86 and 120.

If you had any trouble, you can open
sands_of_time4.max to see the file with the
correct settings. It’s easy to miss a step or make
a mistake and not get the correct results.

13.Save your work as MyHourglass6.max.

Next you’ll use an animated hemisphere to create
the sand building up in the bottom of the lower
chamber.

Creating the Sand Build-Up

The ability to animate object parameters gives
great power and flexibility to 3ds Max. In this
lesson, you will create a hemisphere with a pivot
point at its base, then animate the hemisphere
percentage to achieve the illusion that the particles
are forming a mound with volume.

Continue from the previous lesson or open
sands_of_time4.max from the \tutorials\hourglass
directory.

1. Hide the Snow particle system. Select it in the
viewport, then right-click and choose Hide
Selection from the quad menu. Select the
Hourglass object (Cylinder01 unless you’ve
renamed it) and again choose Hide Selection.

2. With the Perspective viewport active, click
the Arc Rotate button to display the navigation
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icon. Rotate the view so that the bottom of the
hourglass is clearly visible.

3. From the main menu, choose Create >
Standard Primitives > Sphere.

At the top of the Create panel > Object Type
rollout, click to turn on the Auto Grid Toggle.

4. Drag out a Sphere object until the radius is
approximately 17. A sphere should be created
at the bottom of the hourglass plate.

Tip: Look at the Radius spinner in the
Parameters rollout as you drag the sphere.

Right-click and select Unhide By Name and
unhide the Hourglass object.

Assign the Sand material to the new sphere.
(Open the Material Editor if necessary.)

Sand mound made using a Sphere.

5. On the Parameters rollout, turn on Base To
Pivot.

The sphere changes position in the viewport.

The sphere now rests on the bottom plate.

6. Turn on the Auto Key button and
then go to frame 0.

7. On the Parameters rollout, change the
Hemisphere value using the spinner. Set the
Hemisphere setting to .99.

8. Move the time slider to frame 25 and set
the Hemisphere to .98. This will keep the
hemisphere very small for the first 25 frames.

9. Move to frame 57 and set the Hemisphere to .9.

10.Move to frame 67 and set the Hemisphere to .8
and Play the animation.

Note: You may first need to change the rotation
of the view before playing the animation if you
previously rotated the hourglass when creating
the sphere object.
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The hourglass at frame 57.

11.Move to frame 96 and set the Hemisphere to
.6 or so.

The hourglass at frame 96.

12. Turn off Auto Key and play the
animation. After stopping the animation,
right-click the viewport and choose Unhide All
from the quad menu

The sand level goes down in the upper globe as
a stream of sand falls and collects into a mound
in the bottom globe.

Tip: For a more realistic mound of sand, select
the hemisphere and add a Taper Modifier. Set
the taper Amount to -.75 and the Curve to -.5,
so the hemisphere turns into a rounded cone.

13.From the main menu, choose Tools > Align and
pick the bottom plate. In the Align Selection
dialog, tun on X Position and Y Position then
click OK.

The finished falling sand effect.

14.Save your work. On the File menu, choose Save
As, then name your scene MyHourglass7.max.

If you want, load the file sands_of_time_
finished.max to see the finished model.

Adding a Camera

So far you have defined everything in the
Perspective viewport without considering lighting
or cameras. As you prepare to produce output
from your 3D scene, you will want to add cameras
and lights to achieve a more realistic effect.
Lights can cast shadows or add shiny highlights.
Cameras can be animated so that they change your
perspective and add emphasis and motion.

1. Continue from the last lesson, or load the
sands_of_time_finished.max file from the
\tutorials\hourglass directory.

2. Right-click to activate the Top view.

3. On the main menu, click Create > Cameras
> Target Camera.
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4. In the Top viewport, move your cursor to the
lower-right quadrant of the viewport. Click
and drag toward the center where the hourglass
is situated. Release the mouse button when it
is over the hourglass.

Target camera from Top viewport

5. Press C on the keyboard, to change the
viewport to display the view from the Camera.

If necessary, right-click the Camera01 viewport
label and turn on Smooth + Highlights.

Target camera is created on the ground plane.

6. From the view navigation tools, use the
Truck Camera to move the camera so the
hourglass is no longer cut off in the viewport.

Truck and Dolly the camera to bring the hourglass into
view.

7. Turn on Orbit Camerafrom the view
navigation tools. Click and drag downward in
the viewport to orbit the camera so you have a
better view of the top of the sand.

Orbiting the camera.

8. Turn on Dolly Camera. Click and drag in
the viewport to zoom back so the hourglass is
a bit smaller.

9. Right-click the Camera viewport label and
choose Show Safe Frame. You use the Show Safe
Frame tool to verify that objects you want to
render will not get cut off. Show Safe Frame will



Adding Default Lights to the Scene 57

display the edges of your output resolution as
yellow, cyan, and orange lines in the viewport.

Show Safe Frame helps you frame your shot.

10.To improve the authenticity of the hourglass,
open the Modify panel and select either
Chamfer Cylinders that make up the top or
bottom caps. Increase the number of Sides to
33.

Because one cap is an instance of the other,
changing the number of sides on one cap
automatically affects the other.

11.Save your scene as MyHourglass8.max.

Adding Default Lights to the Scene

You can create your own lights, or you can let
3ds Max do it for you. In this section you’ll add a
key light and a fill light using an automatic process.

Continue from the previous lesson.

Add lights to the scene:

1. Right-click the Camera viewport label, and
then choose Configure.

2. On the Rendering Method panel, in the
Rendering Options group, turn on Default
Lighting, and choose 2 Lights. Click OK.

3. On the main menu, choose Views > Add
Default Lights To Scene.

4. In the Add Default Lights To Scene dialog, set
Distance Scaling to 0.2, then click OK.

This hourglass is relatively small, so you use
Distance Scaling to set the lights closer to the
object.

View the new lights:

Follow these steps to see the new lights.

1. Press T on the keyboard to change the Camera
viewport to a Top view. Also right-click the
viewport label and turn off Show Safe Frame.

2. From the view navigation tools, click
Zoom Extents.

The Top viewport without lights displayed.



58 Chapter 14: Basic

Top viewport zoomed back to include added default
lights.

Now you’ll add your own light to create a specular
highlight on the glass.

Add your own light to create a specular highlight:

1. On the main menu, click Create > Lights >
Standard Lights > Omni. Zoom in the Top
viewport and click in the lower-left quadrant
(as shown in the illustration).

Create an omni light close to the hourglass.

2. Set the Top viewport back to the Camera view
by pressing C then move the Omni light up so it
is just above the height of the sand level. When
you render the image this light will create a
specular highlight on the glass.

Move the omni light along the Z axis so it is level with
the sand.

3. Open the Modify panel for the light you just
created. Locate the Multiplier field and change
it to 1.33. You can turn up the multiplier to give
a larger specular highlight on the glass, or you
can move the light closer to the glass.

Rendered image shows omni-generated highlight.

Save your work:

• Choose File > Save As, and name your file
MyHourglass_with_Lights.max.

Rendering Your Work

So far, everything you’ve done has been displayed
in the viewport only: you haven’t actually tried to
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create any output. You essentially have two output
types from which to choose:

• Raster—Raster formats, such as QuickTime
MOV and Windows AVI, are flip books of still
images, which means they can be rather large in
size but very rich visually.

• 3D geometry—3D output, such as VRML,
MAX, DWG, 3DS, DXF or AI, allows you
to choose your own viewpoint, as well as
providing animation and behaviors through
proximity triggers.

Since the hourglass has both transparency and
particles, you’ll choose the only output type which
supports both, which is raster. You’ll create a
QuickTime movie that you can play on a Web site.
First you’ll render some still frames.

1. Activate the Camera viewport. If you do not
have the Camera viewport visible, press C on
the keyboard.

2. On the main menu, choose Rendering >
Render.

In the Output Size group of the Common
parameters rollout, click the 640x480 preset
button.

3. Click Render.

Rendered image shows off the highlights.

4. To change the background, choose Rendering
> Environment. In the Background group,

click the Background Color swatch. In the
Color Selector, type these RGB values:

• Red: 120

• Green: 194

• Blue: 252

This should produce a pale blue.

5. Close the Environment dialog, and press F9 to
render again automatically.

Changing the background color.

Next you’ll render to an animation file.

6. In the Render Scene dialog, in the Common
Parameters rollout in the Time Output group,
change from Single to Active Time Segment.
This renders the entire animation.

7. Reduce the size to 320x240. That’s a better size
animation for Web playback.

8. In the Render Output group, click the Files
button and name the file you’re about to create
myhourglass.avi (for a Video for Windows
animation) or myhourglass.mov, (for a
QuickTime animation). Make a note of where
you are saving this file.

• If you are rendering to AVI, click OK in
the Video Compression window, then click
Save. To start the rendering, click Render.

• If you are rendering to MOV, make
adjustments as you like in the Compression
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Settings dialog, then click OK. To start the
rendering, click Render.

A Rendering dialog appears. As each frame is
rendered, a bar shows the progress. You can
see all types of information updating in the
Rendering Progress group as your rendering
advances.

9. When your rendering is finished, close the
Rendering dialog. On the File menu, choose
View Image File, navigate to where you saved
the file, and open it. The appropriate player
program will play your animation.

Tip: If you like, you can play sands_of_time.avi
or sands_of_time.mov to see a finished
rendering of the animation.

QuickTime MOV output

Summary

From this tutorial, you can see that modeling
and animating particle effects doesn’t always
mean that all particles have to be created with a
particle system. In the hourglass animation, you
used a particle system only for the falling sand.
The effects of sand at the top and bottom of the

hourglass were created with various modeling
tools.
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Scene Management

This tutorial touches on a number of the new
features you’ll find in 3ds Max. The scene you’ll
work on shows a covered porch or balcony that
needs some detailing by means of the Sweep
modifier and real-world materials. You’ll become
familiar with scene states and how they can help
you store various conditions that can be recalled
at a later time for visualization and rendering
purposes. Radiosity adaptive subdivision will be
used for preliminary rendering so you can create
more accurate and realistic images. Finally, you’ll
get to experience the batch rendering tool and how
it can help you increase efficiency when you’re
ready to generate renderings for clients.

You’ll then learn how to save two versions of your
scene using scene states. As a bonus step, the
tutorial also shows how to use the batch rendering
tool, which will render two scenes to file.

Skill Level: Beginner

Time to Complete: 2 hours

Features Covered in This Tutorial

After completing this tutorial, you should be able
to:

• Use the Sweep modifier to create a baseboard
from a spline

• Create materials that use real-world map scaling

• Generate a radiosity adaptive solution for more
accurate lighting

• Set up and save two different scene states

• Use the batch render tool to render two scenes

Advanced
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Tutorial Files

All the necessary files to do the tutorials can be
found on the Tutorial, Samples, And Partners CD,
in the \tutorials\scene_management folder, unless
otherwise specified. Before doing the tutorials,
copy the \tutorials directory from the CD to your
local installation.

Lessons In This Tutorial

Using the Sweep Modifier (page 3–62)

Creating Real-World Materials and Mapping (page
3–65)

Using Radiosity Adaptive Subdivision (page 3–68)

Saving Scene States (page 3–70)

Using Batch Render Tool (page 3–72)

Using the Sweep Modifier

In this lesson, you learn how to use the Sweep
modifier to extrude a shape along a path. This
can be very useful for creating baseboards, piping
layouts and duct work. Although these examples
sound like typical cases for the Loft tool, the Sweep
modifier achieves the same results with an easier
workflow, especially if you do not need all the
functionality that the Loft tool has to offer.

Set up the lesson:

• From the \tutorials\scene_management folder,
open balcony_sweep.max.

The scene is of a covered balcony. You will use
the Sweep modifier to add a baseboard and a
wooden ledge to the balcony wall.

Creating the wooden ledge on the balcony wall:

1. Right-click in the User viewport to activate it.

2. Click the Maximize Viewport Toggle
button to maximize the User viewport.

3. On the main toolbar, click the Snaps
Toggle button to activate it.

4. Right-click the Snaps Toggle button to access
the Grid and Snaps Settings dialog. Activate the
Midpoint option and disable all others. Close
the dialog when done.

5. From the Create panel, click the Shapes button,
and then click on Line.

6. Draw a line on top of the wall by snapping to the
midpoints of the three segments that define the
thickness of the wall, going from left to right.

7. With the line still selected, go to the
Modify panel.
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8. From the Modifier drop-down list, choose
Sweep.

The spline is replaced by an object that has an
L-shaped cross section.

9. Zoom on the new object in the Left
viewport.

10.On the Modify panel, in the Section Type
rollout, select each of the presets from the
Built-in Section list.

11.Choose the Bar preset. It is simply a rectangular
cross-section that defaults to a square.

12.In the Sweep Parameters rollout, click the
bottom center alignment point to properly
align the rail on top of the wall. If you want,

experiment with the other alignment points to
see their effect.

13.In the Parameters rollout, set Length to 2”,
Width to 10” and Corner Radius to 0.2”.

14.Press M to open the Material Editor.

15. Select the material named Oak Moldings
and assign it to the bar cross-section.

If a warning appears, click OK to replace the
existing material.

Creating the baseboard:

1. Make sure the User viewport is active and then
press ALT+W to maximize the User viewport.

2. On the main toolbar, right-click the
Snaps Toggle button. In the Grid and Snap
Settings dialog, turn on Endpoint and turn off
Midpoint. Close the dialog when done.

3. From the Create panel, click the Shapes button,
and then click on Line.

4. Create a line at the base of the wall, snapping
the three endpoints along the inside perimeter,
going from left to right.
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5. With the line still selected, go to the Modify
panel.

6. From the Modifier drop-down list, choose
Sweep. The spline is replaced by an object
that has a square cross section as before. The
Alignment point is also retained from the last
Sweep object you created (mid-center).

7. Press ALT+W to toggle back to a four-viewport
layout.

8. Zoom on the new object in the left view. On
the Modify panel, in the Section Type rollout,
choose the Use Custom Section option.

The square cross-section disappears in the
viewport.

9. In the Custom Section Types group, choose
Pick.

10.In the Left viewport, select the object that is
shaped like the profile of a baseboard.

A new sweep is performed but the baseboard is
oriented the wrong way and its alignment is off.

11.In the Sweep Parameters rollout, enable
the Mirror on XZ Plane option and set the
Alignment point to the bottom right corner.

12.In the Material Editor apply the Oak Moldings
material to the newly created object.

Next

Creating Real-World Materials and Mapping (page
3–65)
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Creating Real-World Materials and
Mapping

In this lesson, you learn how to use
real-world-based materials and mapping.
This is a feature that simplifies the application of
2D textures onto 3D geometry so that it always
appears in the correct size. This is useful when
you need to apply textures that you can measure,
such as bricks or ceramic tiles. For textures that
are more irregular, such as grass or stucco, these
may require a traditional approach that needs a bit
more adjustment at the UVW Map level.

Set up the lesson:

• Continue working on your file from
the previous lesson or from the File
menu, choose Open and navigate to the
\tutorials\scene_management folder. Highlight
balcony_RWmapping.max and click Open. The
scene shows the resulting file from the previous
lesson.

Setting 3ds Max to work in Real-World Texture
Coordinates:

1. From the Customize menu, choose Preferences

2. On the General tab in the Texture Coordinates
group, make sure the Use Real-World Texture
Coordinates option is active.

Note: If you are a new user, you may find
Real-World Texture Coordinates easier to work
with. If you are already experienced with
3ds Max, you may elect to use the traditional
approach. Either way, you can turn Real-World
Texture Coordinates mode on or off in the
Preferences dialog to suit your needs. For the
purposes of this lesson though, make sure this
option is active.

3. Click OK to exit the dialog.

Creating a brick material for the wall:

1. Press M to open them Material Editor.

2. Choose an empty slot (represented by a gray
sphere). All unused materials in this scene have
been set to Architectural type.

3. Name the new material Brick Wall.

4. In the Templates rollout, choose the Masonry
option from the drop-down menu.

5. Click the None button for the Diffuse Map.
From the Material/Map browser that appears,
choose Bitmap, and then click OK.

6. In the Select Bitmap Image File dialog, browse
to the \tutorials\scene_management\VIZ\
folder and click once on brick_red.jpg.

7. Click the View button to see an enlarged view
of the brick texture.

The texture is square and shows a layout
measuring two bricks across by six rows of
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brick down. Typically, a standard brick size is
8” in width, including the joint. This makes the
texture’s horizontal size 16” in the real-world
because it holds two bricks horizontally.
Because the texture is square, it measures 16” x
16” in Real-World coordinates.

8. Close the window showing the texture, and
then click Open to use it as a Diffuse map.

9. In the Coordinates rollout, notice Use
Real-World Scale is active. Set the Width and
Height sizes both to 16”. This automatically
translates into 1’4.0”.

Note: The Use Real-World Scale option is active
because this option has been enabled by default
in the Preferences dialog. You can still enable or
disable it for individual maps.

10. On the Material Editor’s toolbar, turn on
Show Map in Viewport.

11.Drag the newly created material onto the wall
that has the window in the Camera viewport.

At this point you still don’t see the brick layout
because you need to apply mapping coordinates
to the wall.

12. With the wall selected, go to the Modify
panel.

13.From the Modifier drop-down list, choose
UVW Map.

14.Set the mapping type to Box mode if it is not
selected already.

The bricks appear on the wall in their proper
size.

Notice how by default, some of the UVW
Mapping parameters in the Parameters rollout
are disabled, and how the Real-World Map Size
option is active by default. You can disable
this option at any time to revert to a more
traditional mapping method.

Note: If you see distorted bitmaps in the
viewport, right-click on the viewport label, and
select Texture Correction. This is only for the
software display driver. If you are using the
OpenGL or Direct3D display mode, this option
is always on.

Adding a bump map:

1. In the Material Editor, click Go to Parent
to go back one step in the material hierarchy.

2. Expand the Special Effects rollout.

3. Click the None button associated with the
Bump control.

4. From the Material/Map browser, choose
Bitmap, and then click OK

5. In the Select Bitmap Image File dialog,
double-click brick_BUMP.jpg file to select it.

6. In the Coordinates rollout, set the Width and
Height sizes to 1’4.0” (16”) as you did earlier
so that the bump map size matches that of the
diffuse map you set up before.

Creating a wood material for the floor:

1. In the Material Editor, choose an empty slot.

2. Name the new material Wood Floor.

3. In the Templates rollout, choose Wood
Unfinished.

4. Click the None button for the Diffuse Map .

5. From the Material/Map browser, choose
Bitmap.
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6. From the \tutorials\scene_management\VIZ\,
click once on the Wood_Boards.jpg file, and
then click View to display the bitmap.

Note: The texture is square and shows 7 planks
running vertically. Typically, these planks each
measure 4” wide, which means this texture
measures 28” x 28” in Real-World coordinates.

7. Close the window showing the texture, and
then click Open to open this file as a Diffuse
map.

8. In the Coordinates rollout, make sure Use
Real-World Scale is active. Set the Width and
Height sizes both to 28”. This automatically
translates into 2’4.0”.

9. On the Material Editor’s toolbar, turn on
Show Map in Viewport, then select the floor
group in the scene (Floor).

10. Apply the newly created material to
the selected object. The texture appears on
the balcony floor with the right size and
proportions, but in the wrong orientation.

Note: The floor has already been set up with two
Real-World-based UVW Maps running at a 90
degree angle.

11.In the Coordinates rollout, set the W Angle to
90 degrees to fix the orientation of the planks.

Adding a bump map:

1. In the Material Editor, click Go to Parent
to go back one step in the material hierarchy.

2. Expand the Special Effects rollout.

3. Click the None button associated with the
Bump control.

4. From the Material/Map browser, choose
Bitmap, and then click OK
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5. Double-click wood_Boards_bump.jpg file to
select it.

6. In the Coordinates rollout, set the Width and
Height sizes to 2’4.0” (28”) as you did earlier
so that the bump map size matches that of the
diffuse map you set up before.

7. Change the W Angle to 90 degrees to match
the diffuse map.

Next

Using Radiosity Adaptive Subdivision (page 3–68)

Using Radiosity Adaptive
Subdivision

In this lesson, you learn how to use Adaptive
Subdivision to calculate radiosity solutions. This
option divides the geometry based on the light
that falls on the faces and helps capture shadow
boundaries and complex lighting changes more
efficiently.

Set up the lesson:

• Continue working on your file from
the previous lesson or go to the File
menu, choose Open and navigate to the
\tutorials\scene_management folder. Highlight
balcony_radiosity.max and click Open. The
scene shows the resulting file from the previous
lesson.

Setting the radiosity engine:

1. From the Rendering menu, choose Advanced
Lighting > Radiosity. Ensure Radiosity
is selected in drop-down list in the Select
Advanced Lighting rollout.

2. In the Radiosity Processing Parameters rollout,
set the Initial quality value to 50%.

This will make the calculation faster but less
accurate.

3. In the Interactive Tools group, set both Indirect
and Direct light filtering to 2.

This will smooth any noise patterns in the
shadow areas.

4. Expand the Radiosity Meshing Parameters
rollout.

The scene is mostly made of simple geometry
for the walls, floor, roof, etc. which needs
to be subdivided because radiosity works
by vertex-coloring the geometry. The more
vertices in the scene, the better the solution.

5. In the Global Subdivision Settings group,
turn on Enabled, and turn off Use Adaptive
Subdivision. You will first experiment the effect
of subdivision in global mode.

6. In the Camera viewport, right-click the
Camera01 label and choose Edged Faces.
This will make it easier to see the effect of
subdivision in the viewport.

7. In the Radiosity Processing Parameters rollout,
click Start to begin the radiosity calculation.
Once the solution is calculated, you can see its
effect in the viewports.
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Note: Notice how the subdivisions are
fairly equal in size. In this case, the default
subdivision size of 3 feet is not enough to catch
the subtle effects of hotspots and shadows
created by the sun’s rays. You could, of course,
decrease the subdivision value globally, but
it’s better to use an Adaptive subdivision that
would divide the geometry in a finer grid only
where it is needed.

8. In the Radiosity Meshing Parameters rollout,
turn on the Use Adaptive Subdivision option.

9. In the Mesh Settings group, set the Maximum
Mesh Size to 2’0.0” and the Minimum Mesh
Size to 0’4.0”.

In the Radiosity Processing Parameters of the
Advanced Lighting dialog, notice the message
that the solution is now invalid and needs to be
recalculated.

10.Click Reset All. If a warning dialog appears,
click Yes to dismiss it, and then click Start to
begin the radiosity calculation again.

Once the solution is calculated, you can see
that the divisions are more irregular, and relate
mostly to the shifts in lighting, such as where
the sun’s rays hit the surfaces of the walls and
floor.

11.With the Camera viewport active, press F4
to toggle off Edged Faces mode. Notice that
even in the viewport, you can see the effects of
Adaptive Subdivision on the floor as it shows
the effects of the sun’s hotspot.

12.Render the Camera viewport to see the results.



70 Chapter 15: Advanced

Next

Saving Scene States (page 3–70)

Saving Scene States

Once you have built a 3D environment with
materials, lights and cameras, you can save various
scene states so that you can later recall stored
parameters. In this lesson, you adjust material
and light values to effortlessly switch between a
daytime and nighttime scene.

Set up the lesson:

Continue working on your file from the previous
lesson or go to the File menu, choose Open and
navigate to the \tutorials\scene_management
folder. Highlight balcony_scene-states.max and
click Open. The scene shows the resulting file from
the previous lesson.

Switching global illumination engines:

Before beginning this lesson, you will first disable
Radiosity and use the mental ray renderer to
simulate global illumination. It will speed up
rendering in this case because it’s not necessary
to recalculate the solution every time you make a
change.

1. From the Rendering menu, choose Advanced
Lighting > Radiosity.

2. From the Select Advanced Lighting drop-down
menu, choose <no lighting plug-in>. Click Yes
to dismiss the warning that displays.

3. Open the Common tab. In the Assign Renderer
rollout, click the button next to Production.

4. Choose the mental ray Renderer, and then click
OK.

5. Open the Indirect Illumination panel.

6. In the Caustics and Global Illumination rollout,
in the Global Illumination group, turn on the

Enable option. Leave all other parameters to
their default settings.

7. Render the Camera01 viewport to test the
results.

Saving scene states:

1. Right-click in the Camera viewport.

2. From the quad menu that displays, choose Save
Scene State.

3. In the Save Scene State dialog, select all the
scene parts so that cameras, environment,
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layers, lights, materials and object properties
will be saved with the scene state.

4. Name the scene state DAY.

5. Click Save to exit the dialog.

Changing scene parameters:

1. Go to the Display panel.

2. In the Hide by Category rollout, remove the
check mark next to Lights.

Three lights appear in the scene: one that
simulates the sun (Sun01), one that simulates
global ambient lighting (Sky01), and a simple
bulb (FPoint01).

3. In the Top viewport, select the Sun01 object.

Tip: It may be easier to select Sun01 by pressing
H to open the Select Objects dialog.

4. On the Modify panel, in the Sun Parameters
rollout, turn the light off.

5. Press H to open the Select Objects dialog.

6. Double-click the object named FPoint01 to
select it.

This represents the bulb that will light the scene
at night.

7. On the Modify panel, in the General Parameters
rollout, turn the FPoint01 light on.

Note: You do not need to change the state of the
IES Sky object since skylight objects are not
recognized by the Mental Ray Renderer.

8. Render the Camera viewport.

The scene is very dark, and the background still
displays daytime lighting.

9. From the Rendering menu, choose
Environment. In the Logarithmic Exposure
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Control Parameters rollout, turn off the
Exterior Daylight option.

10.Press M to open the Material Editor. Locate the
material named Background, and select it.

11.At the bottom of the Material Editor, expand
the Output rollout. Set the RGB Level value to
0.2.

This will make the background image much
darker to simulate a scene at night.

12.Render the Camera viewport again and notice
the changes.

13.Right-click in the Camera viewport. From the
quad menu, choose Save Scene State.

14.In the Save Scene State dialog, select all the
scene parts.

15.Name the scene state NIGHT.

16.Click Save to exit the dialog.

Restore scene states to render:

1. Right-click in the Camera viewport, and choose
Restore Scene State from the quad menu.

Notice the cascading menu lists the two scene
states you previously saved.

2. Choose DAY to restore the daytime scene.

Notice in the Top viewport that the point light
is displayed in black, which means it’s inactive.
Sunlight is displayed in yellow, which means
it is enabled.

3. Render the Camera viewport to see that
all scene parts such as light effects and
environment backgrounds have been restored
to their original states.

Next

Using Batch Render Tool (page 3–72)

Using Batch Render Tool

Batch Render is a tool that allows you to
sequentially render any or all of the views in your
project. It is especially useful in conjunction with
the scene states tool shown in the last lesson to
render different aspects of the scene with very little
or no interaction on your part.

In this lesson, you use Batch Render to automate
the rendering of both the day and night scenes
created in the previous lesson.

Set up the lesson:

• Continue working on your file from
the previous lesson or from the File
menu, choose Open and navigate to the
\tutorials\scene_management folder. Highlight
balcony_batch-render.max, and click Open.
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The scene shows the resulting file from the
previous lesson.

Accessing and setting up the Batch Render dialog:

1. From the Rendering menu, choose Batch
Render.

The Batch Render dialog displays.

2. Click the Add button in the top left corner of
the dialog. A new entry named View01 is added
to the list.

3. In the Name field, rename the view:
CamViewDay.

4. From the Camera drop-down list, choose
Camera01. The view is now assigned to what
this particular camera is pointed at.

5. Click the Output Path button and name the
output file DAY.JPG, and then click Save.

6. Accept the JPEG Image Control defaults, and
then click OK.

7. From the Scene State drop-down menu, choose
DAY.

Note: This setup ensures the Camera01
viewport will be used for rendering, and that
the DAY scene state with an output file named
DAY.JPG is saved to disk.

8. Click the Add button at the top of the dialog to
add another entry to the batch list. Rename the
new entry: CamViewNight.

9. Assign Camera01 to this newly created view.

10.Make sure the new entry CamViewNight is
displayed in the Name field, and create an
output file for it named NIGHT.JPG.

11.Accept the JPEG Image Control defaults, and
then click OK.

12.In the Scene State drop-down menu, choose
the NIGHT scene state.
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13.Click the Render button in the bottom right
corner.

Both the day and night scenes are rendered and
saved to disk.

Summary

In these lessons, you worked on various aspects
of scene creation and management. You learned
how to add detail using simple 2D splines that
you turned into 3D objects with the help of the
Sweep Modifier. You have also learned how to
adjust texture maps using Real-World values,
and to adjust radiosity solutions by subdividing
the geometry only where needed. Finally, you
learned how to save scene states to record different
scenarios like daytime and nighttime lighting, and
to automate the rendering of those scene states
using Batch Render.

Creating Explosions
In this tutorial, you’ll hit an asteroid with a glowing
laser blast, blowing the asteroid to bits and creating
a fiery explosion.

Skill Level: Intermediate

Time to complete: 2+ hours

Features covered in this tutorial

Doing this tutorial you will learn to:

• Use material effects channel ID’s.

• Use animated opacity mapped plane objects to
simulate an explosion.

• Use particle array fragmentation.

• Set visibility keys.

• Add motion blur.

• Use render effects glows and blurs.

Tutorial Files

All the necessary files to do the tutorials can
be found on the Tutorial Files CD, in the
\tutorials\space folder, unless otherwise specified.
Before doing the tutorials, copy the \tutorials
directory from the CD to your \3dsmax8 local
installation.

Animating the Laser Blast

You’ll find the files for this tutorial in the
\tutorials\space directory.

Animate the laser blast:

1. Open exploding_asteroid1.max.

This scene already has an asteroid as well as a
thin box object named laserblast.

2. Press H on the keyboard to Select By Name.
Highlight laserblast in the list and click Select.

Now the laserblast object is selected. It’s not
very easy to see it in the viewport.

3. Turn on Auto Key and move the time
slider to frame 10.
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4. In the Top viewport, move the laserblast
along the Y axis until it comes in contact with
the asteroid.

5. Turn off Auto Key.

A dotted line in the viewport shows the laser
blast’s trajectory.

Move the time slider to frame 0, then play the
animation in the camera viewport.

The laserblast moves to the asteroid and stops.

Creating a Material for the Laser
Blast

Now you’ll create a glowing material for your laser
blast.

Create a material for the blast:

1. Open the Material Editor and move it so
you can see the camera viewport.

2. Move to frame 8 so you can see the laserblast
clearly in the camera viewport.

3. In the Material Editor, select an unused sample
sphere and name its material laserblast
material.

4. Click Assign Material To Selection.

Tip: If the laserblast object is no longer selected,
you can drag the material from the sample slot
into the viewport and onto laserblast.

5. In the Blinn Basic Parameters rollout >
Self-Illumination group, turn off the Color
check box. Set Self-Illumination to 100.

Self-illumination makes a material appear to
glow. Self-illuminated materials have a flat,
unshaded look.

6. Click the Diffuse color swatch.

The Color Selector dialog is displayed.

Adjust the color to R:255, G:114, B:0, and click
Close.

The color of the material is a pumpkin orange.

Set up an effects channel:

1. On the Material Editor toolbar, click the
Material Effects Channel flyout, and choose
channel 1.

Later in this tutorial, you’ll use the channel
number to create a glow.

2. Close the Material Editor.

Animating the Asteroid

Now you’ll animate the asteroid so it tumbles
before it’s hit by the laserblast.
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Animate the asteroid:

1. Turn on Auto Key.

2. Activate the Camera viewport and move the
time slider to frame 0.

3. Select And Move the asteroid down in
the Z axis approximately 135 units, or until it
is positioned just inside the camera’s view.

Frame 0

4. Right-click and choose Rotate from the quad
menu. Rotate the asteroid at frame 0 on both
the Y and Z axes approximately 30 degrees.

5. Go to frame 10. Reposition the asteroid so
it is in contact with the laserblast. Rotate the
asteroid on both the Y and Z axes approximately
–30 degrees.

6. Turn off Auto Key.

7. Play the animation.

The asteroid now tumbles until it’s hit by the
laser blast.

Frame 10

8. Save your work as myrotating_asteriod1.max.

Creating a Plane for the Explosion

Now that the asteroid and laserblast are animated,
it’s time to create the explosion that will blow it up.

There are several different ways you can create an
explosion in 3ds Max. One technique is to use an
animated map. This allows you to apply a movie of
a real explosion to a simple planar object.

Setup:

• Continue working with the previous file or
open rotating_asteroid.max.

Create a plane:

1. Move the time slider to frame 10 if it’s not
already there.

2. Right-click to activate the Front viewport,
and then press ALT+W on the keyboard to
maximize the viewport.

3. Use Zoom and Pan to navigate the
viewport so the asteroid is in or near the center
of the view.



Creating a Plane for the Explosion 77

4. Go to the Create panel > Geometry
> Standard Primitives category. On the Object
Type rollout, click Plane.

5. In the Front viewport, drag a plane over the
asteroid.

6. In the Name And Color rollout, change the
name to Explosion Plane01.

7. In the Parameters rollout, set the Length and
Width of the plane to 300.0. Set the Length and
Width Segs (segments) to 1.

The size and complexity of the Plane update
in the viewport.

8. Right-click in the viewport, and press ALT+W
to return to four viewports.

9. Right-click the Top viewport to activate
it, and move the plane along its Y axis so it’s
behind the asteroid.

Moving the plane in the top viewport

Tip: You can turn off snaps by pressing the
S key. This is handy for toggling the snaps
settings when you are in the process of moving
an object.

10.Right-click the Camera viewport to activate it
without losing the selection of the plane.
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Plane in camera viewport

11.In the Tools menu, choose Align To View.

12.In the Align To View dialog, make sure Align Z
is chosen, and click OK.

The plane is now aligned to the Camera view.

Plane aligned to view

Creating a Material for the
Explosion

Next, you’ll create a material for the explosion.

Create a material for the explosion:

1. Open the Material Editor.

2. Select an unused sample sphere and name the
material Explosion.

3. Click Assign Material To Selection.

Tip: If the plane is no longer selected, you
can drag the material from the sample slot to
Explosion Plane01.

4. In the Blinn Basic Parameters rollout, click the
blank button to the right of the Diffuse color
swatch.

The Material/Map Browser dialog is displayed.

5. Click Bitmap in the dialog, and then click OK.

The Select Bitmap Image File dialog is
displayed.

6. Use the Select Bitmap Image File dialog to find
and choose hercules.avi.

The Preview window displays the first frame of
the animation, which is solid black.

7. Click Open.

The animation is incorporated in the material
as a Diffuse map.

8. On the Material Editor toolbar, click to
turn on Show Map In Viewport.

You can now see the frames of the animation on
the plane object in the viewport.

Tip: To see the animation in the viewport, drag
the time slider forward. (The first frame of the
animation, which displays at frame 0, is black.)
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The material sample is currently a sphere.
You can change that to a box to give you an
undistorted view of the animated map.

9. On the Material Editor vertical toolbar (to
the right of the sample slots), choose the Box
from the Sample Type flyout.

The Material sample is now a box, not a sphere.

10.Move the time slider and watch the explosion
play on the plane in the viewport.

Adding an Opacity Map

Now the explosion appears on the plane. The next
step is to make the plane invisible so all you see in
the scene is the explosion.

Add an opacity map:

1. In the Material Editor toolbar, click Go To
Parent.

2. In the Material Editor, open the Maps rollout.

3. Click the Opacity map button (it is initially
labeled “None”), and in the Material/Map
Browser, choose Bitmap.

4. Use the Select Bitmap Image File dialog to
choose herculesm.avi. Click Open.

The file herculesm.avi is a black-and-white
mask of the animated explosion. Using the
map’s alpha channel, the Opacity map makes
the plane invisible and allows only the explosion
to appear in the scene.

View the opacity map’s effect:

1. On the Material Editor toolbar, click Go
To Parent. Close the Maps rollout.

2. On the Material Editor toolbar, click to
turn on Show Map In Viewport.

The plane is now invisible in the viewport.

Tip: If the transparency is not apparent in the
viewport, right-click the viewport’s label,
choose Configure, and then in the Viewport
Configuration dialog > Rendering Method
panel, change Transparency to Best.

3. On the Material Editor vertical toolbar,
click to turn on Background.
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This turns on a checkered background that
helps you visualize the opacity mapping.

Adjust the material settings:

• In the Blinn Basic Parameters rollout > Specular
Highlights group, set both Specular Level and
Glossiness to 0.

This removes any shininess from the plane.

Tip: To set a numeric field to 0, right-click the
spinner next to the field.

Adjust the plane properties:

When using this mapping technique, you don’t
want the invisible plane to cast or receive shadows,
so you’ll turn those attributes off.

1. Select the plane in a viewport, then right-click
and choose Properties from the quad menu.

2. In the Properties dialog that is displayed, in
the Rendering Control group, turn off Receive
Shadows and Cast Shadows. Click OK.

View the results:

• Play your animation.

The plane doesn’t move with the asteroid.
That’s okay, because you need the plane only at
the point where the explosion occurs.

Synchronizing the Animated Maps

Here you’ll set the timing so the animated
explosion doesn’t start until impact at frame 10.

Set the timing:

1. Go to Material Editor > Maps rollout, and
select the Diffuse map button, which is now
identified as hercules.avi.

2. Scroll down and open the Time rollout.

3. Change the Start Frame setting to 10.

4. In the End Condition group, choose Hold.

5. In the Material Editor toolbar, click Go
Forward To Sibling to navigate to the next map
in the material. In this case, it’s the Opacity
map.

6. Repeat steps 2 through 4 for the herculesm.avi
opacity map.

7. Close the Material Editor.

8. Save your scene as myexplosion1.max.

Cloning the Explosion Plane

In this topic, you’ll make a copy of the explosion
plane, and set the copy in front of the asteroid.
With two planes, the asteroid appears to be in the
middle of the explosion, rather than in front of it.

Clone the explosion plane:

1. If it’s not already selected, select Explosion
Plane01. Press the SPACEBAR to lock your
selection.



Cloning the Explosion Plane 81

2. On the toolbar, open the Reference Coordinates
System list, and choose Local.

This will let you move the plane parallel to itself.

3. In the Top viewport, right-click the plane and
choose Move from the quad menu.

4. Hold down SHIFT and drag a copy of Explosion
Plane01 in the Z axis. Position the plane so it is
in front of the asteroid.

Planes as seen in Top Viewport

5. A Clone options dialog is displayed. The
program has automatically named the new
plane Explosion Plane02. Leave the settings at
their default, and click OK.

Note: The copy of the plane is now selected, and
the Selection Lock Toggle automatically turns
off.

Set the new plane’s properties, and make a named
selection set:

1. Right-click the new plane and choose
Properties. In the Display Properties group
turn on See-Through. Click OK.

The cloned explosion plane now lets you see
through it in the viewport. This doesn’t affect
the rendering.

See-through plane in camera viewport

2. Select the two plane objects. In the Named
Selection Sets window on the toolbar, type the
name Explosions and press ENTER.

You can now reselect the two planes at any
time by choosing this name from the Named
Selection Sets drop-down list.

3. Right-click the selected planes and choose Hide
Selection from the quad menu.

The two planes are hidden from view.

4. Save your scene as myexplosion2.max.
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Breaking the Asteroid into Flying
Pieces with Particle Array

At this point, the asteroid, laserblast, and explosion
are all animated. Next, you’ll add particles to
simulate the asteroid breaking up as it explodes.

Setup:

• Continue working with the previous file or
open exploding_asteroid_with_2planes.max.

Create a particle system in the scene:

1. Go to Create panel > Geometry
and choose Particle Systems from the
drop-down list.

2. In the Object Type rollout, click PArray.

3. Click and drag to create a PArray particle gizmo
in the Top viewport.

Perspective viewport view of the PArray gizmo

4. In the Basic Parameters rollout, click Pick
Object, and then click the asteroid in a
viewport.

The name of the asteroid, in this case Sphere01,
is displayed below the Pick Object button to
show that the particle system has been linked to
the asteroid.

Expand the command panel and adjust the PArray
settings:

Next, you’ll expand the command panel so you
can see more of the particle system rollouts.

1. Move the cursor to the left edge of the
command panel.

The cursor changes to a double arrow.

2. Click and drag the edge of the panel to the left.

A second column of the command panel
appears.

3. Click the Particle Type rollout to open it.

The Particle Type rollout is now displayed in
the second column.
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4. In the Particle Type rollout > Particle Types
group, choose Object Fragments.

5. Scroll down to the Object Fragment Controls
group.

6. Set Thickness to 11.0.

7. Choose Number Of Chunks and set Minimum
to 75.

8. In the Basic Parameters rollout > Viewport
Display group, choose Mesh.

Move the time slider to see asteroid chunks
appear in the viewport.

Adding Materials to the Particles
Add materials:

1. In the Particle Type rollout > Material Mapping
And Source group, choose Picked Emitter.

2. Click the Get Material From button.

The asteroid’s materials appear on the particles
in the viewport.
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Expand the control panel again:

1. Move the cursor over the far-left edge of the
command panel.

The cursor once again changes to a double
arrow.

2. Click and drag the cursor to the left to open a
third column.

Now the Basic Parameters rollout appears in
the first column, the Particles Type rollout in
the second, and most additional rollouts in the
new third column.

Tip: To close the additional columns, drag the
left edge of the command panel to the right.

Controlling Particle Animation

Next, you’ll add some control to the animated
particles.

Control the animated particles:

1. Open the Rotation And Collision rollout. In the
Spin Speed Controls group, set Spin Time to 50.

This will give some rotation to the chunks.

2. Open the Object Motion Inheritance rollout
and set Influence to 0.0.

This will keep the asteroid’s movement and
rotation from influencing the movement of the
particles.

By default, the particle animation will begin on
frame 0. Because the asteroid doesn’t blow up
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until frame 10, you’ll have to adjust the timing
of the particle animation.

3. Right-click an open rollout in the first column.
Choose Particle Generation from the list.

The Particle Generation rollout is now
displayed.

Tip: This right-click menu lets you navigate to a
particular rollout quickly.

4. In the Particle Timing group, set Emit Start to
11 and Life to 90.

The particles don’t appear until frame 11,
and they persist until the last frame of the
animation.

5. Move the time slider or play the animation in
the viewport to see the effect.

Now the asteroid starts to break into pieces
after reaching the center of the viewport.

6. Drag the left edge of the command panel to the
right to restore it to a single column.

7. Save your work as myexplosion_w_
particles.max.

Setting Visibility Keys to Make the
Asteroid Disappear

The asteroid particle system explodes into pieces;
however, the original asteroid object is still visible

in the scene. To make the explosion seem more
realistic, the original object needs to disappear as
it explodes.

Setup:

• Continue working with the previous file, or
open exploding_asteroid_with_particles.max.

Create a visibility key:

1. Go to frame 11 and turn on Auto Key.

2. To select the asteroid, press H to open the Select
Objects dialog, and select Sphere01. Click
Select. Then right-click and choose Properties
from the quad menu.

3. In the Object Properties dialog > Rendering
Control group, right-click the Visibility spinner
arrows to set this value to 0.0.

A red outline appears around the spinner
arrows to indicate an animation key has been
set.

4. Click OK to close the Object Properties dialog.

5. Turn off Auto Key.

Adjust the new visibility keys:

1. In the track bar, under the time slider,
right-click the key at frame 0. Choose Sphere01:
Visibility.



86 Chapter 15: Advanced

2. If necessary, set the Value to 1.0.

3. Change the Out interpolation to Stairstep.

This will make the object visible until the next
key.

4. Drag the time slider and observe the animation
in the viewport.

The asteroid disappears and the fragments fly
outward.

5. Close the key dialog by clicking the X button
in its title bar.

Render a frame to preview the explosion effect:

1. Right-click a viewport and choose Unhide All.

The planes are now visible again.

2. Go to frame 21.

3. On the toolbar, click Quick Render.

The single image shows you what the effect
will look like so far. Verify that the asteroid is
invisible, and that only the particle fragments
and the explosion planes are rendering.

Adding Motion Blur

To help create the illusion of fast movement in
your explosion, you’ll add motion blur to your
animation.

Setup:

• Close the virtual frame buffer, if it is still open.

Add motion blur:

1. At frame 0 select the asteroid, then right-click it
and choose Properties on the quad menu.

2. In the Motion Blur group, make sure that
Enabled is on, and choose Object. Click OK.

Object motion blur will blur the asteroid, but
not the entire scene.

3. Move the time slider to frame 7.

4. Activate the Camera viewport and click
Render Scene on the main toolbar.

The Render Scene dialog is displayed.

5. Click the Renderer tab. On the Default Scanline
Renderer rollout, In the Object Motion Blur
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group, make sure that Apply is on, and that
Duration (Frames) is set to 0.5.

This will create a motion blur that is not too
blurry.

6. At the bottom of the dialog, click Render to test
the result.

Motion blur on asteroid

7. Save your scene as myexplosion3.max.

Putting a Light Inside the Asteroid

Creating fiery explosions with mapping techniques
is effective, but it doesn’t actually illuminate your
scene. Adding a light inside the exploding asteroid
illuminates its fragments and creates a more
dramatic effect.

Setup:

• Continue working with the previous file or open
exploding_asteroid_with_motionblur.max.

Put a light inside the asteroid:

1. Move the time slider to frame 10.

This puts the asteroid in the center of the frame.

2. Go to Create panel > Lights >
Object Type rollout, and click Omni.

3. Activate the Top viewport, then click the center
of the asteroid to create an Omni light.

Because the asteroid is positioned at the
center of the scene, the light appears inside the
asteroid.

4. Change the name of the light you just created to
inside asteroid light.

5. Go to the Modify panel and click the white
color swatch in the Intensity/Color/Attenuation
rollout.

The Color Selector is displayed.

6. Change the color to orange (R: 255, G: 111,
B:56). Then close the Color Selector.

7. Set the Multiplier to 4.0.

Note: You don’t need to animate the light. It will
illuminate only the particles, and they appear
when the explosion begins.

8. On the toolbar, turn on Select And Link.
Then press the H key to select the parent object.
Choose Sphere01 from the list, and then click
Link.

Now the light will move along with the
animated asteroid.

9. On the toolbar, click the Select button to
turn off Select And Link.

10.Save your work as myexplosion_w_light.max.
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Adding Render Effects to the Laser
Blast

To give your scene some finishing touches, you’ll
add render effects to make the laser blast and the
explosion glow.

Setup:

• Continue working with the previous file or
open exploding_asteroid_with_lights.max.

Add a render effect:

1. Choose Rendering menu > Effects.

The Environment and Effects dialog is
displayed, with the Effects tab active.

2. Click Add. In the Add Effect dialog, choose
Lens Effects from the list, and click OK.

3. In the Lens Effects Parameters rollout, highlight
Glow and then click the right-pointing arrow to
move it into the list on the right.

Adjust the glow settings:

1. Scroll down to the Glow Element rollout, and
in the Name window, rename the glow effect
laser glow.

2. Change Size to 0.1 and Intensity to 250.

3. In the Radial Color group, click the white color
swatch and change the color to orange (R: 235,
G: 120, B: 60).

4. Click the Options tab.
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5. In the Apply Element To group, make sure
Lights and Image Centers is off.

6. In the Image Sources group, turn on Effects ID.
It should be set to 1 by default.

7. Scroll up to the Effects rollout > Preview group.
Make sure the Camera01 viewport is active,
then click the Update Scene button.

The frame renders, and then the glow is applied
to the laser blast.

8. Save your scene as myexplosion4.max.

Adding a Second Glow to the
Explosion

Next, you’ll add a glowing effect to the light inside
the asteroid to give the blast added realism.

Setup:

• Continue working from the previous lesson, or
open exploding_asteroid_with_laserglow.max.

Add a glow effect:

1. Choose Rendering > Effects, and highlight
Lens Effects in the Effects list.

2. On the Lens Effects Parameters rollout, choose
Glow once again in the list window on the left
and click the right-pointing arrow.

3. Highlight the second Glow in the right-hand
window and scroll down to the Glow Element
rollout.

4. Name this glow effect blast.

Adjust the glow settings:

1. In the Lens Effects Globals rollout, turn on Pick
Light.

2. Press H, and use the dialog to select inside
asteroid light.

The light’s name is now displayed in the text
field.

3. On the Glow Element rollout, open the Options
panel.

4. In the Apply Element To group, turn on Lights.
Turn off Image and Image Centers, if activated.

5. Go to the Parameters panel, and set Occlusion
to 0.0.

This allows you to see the glow through the
explosion planes in the scene.
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6. Turn off Glow Behind.

7. In the Radial Color group, change the swatch on
the right to an orange color (R:242, G:150, B:0).

8. In the Glow Elements Parameters panel, set the
Size to 30.0.

9. Set the Intensity to 50.

Preview the effect:

1. Go to frame 25 and activate the Camera01
viewport.

2. Scroll up to the Effects area. Click Update Scene
to see the results.

3. Close the virtual frame buffer and the
Rendering Effects dialog.

Animating the Explosion’s Glow

The glow will be more realistic if it changes over
time.

Animate the explosion’s glow:

1. On the toolbar, click Curve Editor
(Open).

The Track View - Curve Editor is displayed.

2. Go to the Modes menu and choose Dope Sheet.

3. In the Controller window on the left, pan down
until you can see the label Render Effects. This
is near the top of the scene hierarchy.

4. Click the plus icon to the left of Render Effects
to expand the render effects tracks.

Tip: Clicking a plus icon in this window expands
tracks. When the tracks have been expanded,
the icon changes to a minus icon. If you want
the tracks collapsed, click the minus icon. The
tracks will no longer be visible.

5. Click to expand the Lens Effects tracks.

With the Lens Effects tracks open, you can see
both glow effect tracks.

6. Scroll down and click to open the blast tracks.
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All the glow attributes in the Rendering Effects
dialog are listed here. You can set keys for any
attribute to animate its effect.

7. Click the Intensity track to select it, then
right-click and select Assign Controller. Select
Bezier Float, and then click OK.

8. With the Intensity track selected, turn on
Add Keys on the Track View toolbar.

9. In the Key window on the right, click the
Intensity track to add a key at frame 0 and
another key at frame 9.

10.Right-click the first key and set its value to 0.
Move to the second key and set it to 0 as well.

11.Set the Out interpolation value of the first key
to Stairstep. This will lock the glow between
the first two keys.

12.Add another key at frame 12. Right-click the
key and set its value to 75.0.

13.Add another key at frame 30. Right-click the
key and set its value to 0.

14.Set the interpolation to Linear for the Out value
keys at frame 9, the In and Out values for frame
12, and the In value for frame 30.



92 Chapter 15: Advanced

Adding Streaks with Radial Blur

You can get a nice streaking effect using the Blur
render effect. Adding a blur is just like adding a
lens effect.

Add a blur effect:

1. In the Camera01 viewport, select the PArray
gizmo, right-click it, and choose Properties
from the quad menu.

2. In the G-Buffer group, use the spinner to set the
Object Channel to 2. Click OK.

3. Choose Rendering menu > Effects.

4. Click the Add button, choose Blur, and click
OK.

Set up the blur effect:

1. In the Blur Type panel, choose Radial.

2. On the Pixel Selections panel, turn off Whole
Image, and turn on Object ID.

3. In the Object ID controls, use the spinner to
change the ID to 2, then click the Add button.

The number 2 appears in the Object ID list.

4. Activate the Camera01 viewport and drag the
time slider to frame 33.

5. In the Effects rollout, click Update Scene to
preview the result.

The radial blur is added to the image.

Animate the blur effect:

Finally, you will keyframe the values and
interpolation of the Blur Radial Pixel radius, so the
particles fade out as they slow down toward the
end of the animation.

1. Open the Dope Sheet Editor again and in the
Controller window, navigate to the Blur entry.
Expand its tracks, and click to highlight Blur
Radial Pixel Radius.

2. Turn on Add Keys on the Track View
toolbar. In the Key window, click to add keys at
frames 0 and 11.

3. Right-click a Blur Radial Pixel Radius key. Give
both these keys a value of 0.0, and use stairstep
interpolation between them.

4. Click to create a key at frame 18. Give it a value
of 7.0,. Leave the interpolation set to the default
of Bezier.

5. Set another key at frame 100 with a value of 1.0.

6. Save your scene as myexplosion5.max. You
can open exploding_asteroid_final.max for
comparison

Render the animation:

1. On the Rendering menu, choose Render. Make
sure the Common tab is displayed, click it if it
isn’t.
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2. On the Common Parameters rollout, in the
Time Output group, turn on Active Time
Segment: 0 to 100.

3. In the Render Output group, click the Files
button. Name the output file of the finished
explosion myexplosion2.avi, and press
ENTER.

4. In the Video Compression dialog, click OK.

5. Then click Render at the bottom of the Render
Scene dialog.

Or you can just play the provided movie
exploding_asteroid_final.avi.

Tip: When doing high-quality work, render to
a still image sequence of TGA files. Then you
can use the Ram Player or other methods to
turn these files into a movie sequence such as
AVI or MOV.

Summary

In this tutorial, you have created an exploding
asteroid. You have learned to combine the use of
many tools to create this effect. You have learned
to use material effects ids with glows, and have
created explosion planes with animated opacity
mapping. You’ve created exploding fragments
using PArray objects, and learned to set visibility
keys. Finally you’ve used Render effects and
motion blur to complete the shot.

Modeling a Revolving Door
In this tutorial, you learn how to model and
animate in 3ds Max. You will construct an
animated revolving door for a hotel lobby. In the
course of doing so, you’ll learn about creating and
transforming primitive and parametric objects.
You’ll learn about using snaps and pivot points
for alignment, as well as general user interface

navigation skills. You’ll learn to instance objects
and link them into an animated hierarchy. You’ll
also learn to merge files together.

Skill Level: Beginner

Time to complete: 25 minutes

Features Covered in This Tutorial

After completing this tutorial, you should be able
to:

• Have a working knowledge of the 3ds Max user
interface.

• Create a revolving door by using primitive and
AEC objects.

• Apply materials to objects and sub-objects.

• Animate the doors in the scene using rotation
transforms and parametric animation.

• Merge objects from another file into your scene.

Tutorial Files

All the necessary files to do the tutorials can
be found on the Tutorial Files CD, in the
\tutorials\intro_to_design_visualization\ folder,
unless otherwise specified. Before beginning the
tutorials, copy the \tutorials directory from the CD
to your \3dsmax8 local installation.
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Setting Up Units and Snaps

Before you start to build your revolving door, you
will set the display unit scale to feet and inches.
You’ll also make some changes to the snap options
before you create the geometry.

Set up the display unit scale:

Note: If you’re using the product outside of the
United States, you can choose to use metric display
unit scale in the following steps. What’s important
is that the scale is a real-world measurement, rather
than the default Generic Units setting in 3ds Max.

1. On the menu bar choose File > Reset to reset
3ds Max.

This tutorial does not require you to load any
particular file to begin. As you work through it,
if you get lost you can open a snapshot file, so
you can complete the tutorial.

The files for this tutorial are on the Tutorial
Files CD in the \tutorials\intro_to_design_
visualization directory.

2. On the menu bar, choose Customize > Units
Setup.

The Units Setup dialog appears.

3. In the Display Unit Scale group, choose US
Standard.

Leave the scale set to the default Feet w/Decimal
inches.

The Display Unit Scale is now set to Feet and
Decimal Inches.

Leave the System Unit Setup as it is. This should
be changed only to reset the system unit to
the default setting (inches) after loading a file
that uses a different system unit, or if you are
working on files that are so huge or so tiny that
values don’t appear correctly in the numeric
entry fields.

4. Click OK to accept the change.

Now, when you make something, its
measurements are displayed in the command
panels in familiar real-world terms.

Next, you will make some additions to the grid
and snap settings.

Set up snaps:

1. On the menu bar, choose Customize > Grid
And Snap Settings.

The Grids And Snap Settings dialog appears.
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2. On the Snaps panel, turn on Grid Points,
Vertex, and Edge/Segment. Make sure all the
other snaps are turned off.

3. Close the dialog by clicking the X button at the
upper right of the dialog.

Now, when Snap is on, you’ll be able to snap to
vertices, grid points and edges.

You’re ready to create a cylinder to serve as the
central pole that rotates the revolving door.

4. Save your file as my_revolving_door_
units.max.

Creating the Hub

Using the Cylinder object, you will create a central
pole that will act as the hub for the revolving door.
First you will create a new layer for the revolving
door.

Set up the lesson:

• Continue with the scene from the previous
lesson, or open revolving_door_hub.max to
begin.

Create a layer:

You can use the layer management system for
display and rendering purposes. Here you will
create a new layer for the revolving door.

1. By default, the Layers toolbar is hidden when
you start 3ds Max. If it is not currently open,
right-click a blank space on the main toolbar
and choose Layers from the pop-up menu.

2. On the Layers Toolbar, click the Create
New Layer button.

This creates a new layer and opens the Create
New Layer dialog.

3. Use the Create New Layer dialog to name the
Layer Revolving Door, and then click OK.

The Revolving door layer is now current and
visible in the Layers toolbar. Whatever you
create now will be on this layer.

Create the hub:

Before creating the hub, you will adjust your
viewport so you have a better view of the objects
you will make.

1. In the viewport navigation controls at the
lower right corner of the user interface, click the
Arc Rotate button. In the Perspective viewport
press and drag within the navigation orb to
change the view of the home grid. When you
are done, right-click in the viewport to turn off
Arc Rotate.

2. Click the 3D Snap Toggle on the toolbar.

3. On the Create panel > Standard Primitives >
Object Type rollout, click Cylinder.

The Cylinder button turns yellow, indicating it
is active and ready for use.

4. Now move your cursor over the grid in the
viewport.
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The cursor displays a blue snap icon and jumps
to the grid points.

5. Position the cursor over the center of the grid
and then press and drag.

As you move the mouse away from the center, a
flat shaded circle grows from your cursor. You
are defining the radius of the cylinder as you
move the mouse.

Notice that as you move away from the center
of the grid the mouse will snap to grid points.

6. Turn off the snap by pressing the S on the
keyboard while you are still moving the cursor.

The snap has been turned off, while you are still
in the middle of creating the cylinder. Now as
you move your mouse, you are free from the
snap control.

7. Lift the mouse button, and you have set the
radius of the cylinder. The radius is displayed
on the Parameters rollout.

8. Now move your cursor upward in the viewport.

9. The cylinder grows as you move the cursor
upward. When you click again you have set the
height.

Make the cylinder any size you like. You’re
going to change the size in the next step.

Adjust the hub:

1. On the Parameters rollout change Radius to 0’
3.0".

2. Change the Height to 7’0.0".

3. In the Navigation controls, click the Zoom
Extents button.

The viewport zooms out so you can see the
cylinder.
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Zoom extents to see it all

4. Right-click the Perspective viewport label and
choose Edged Faces.

The Edged Faces option lets you see the edges
that the software uses to create the surfaces of
your model.

Edged faces show the underlying geometry

5. On the Parameters rollout, change Height
Segments to 1.

6. Change Sides to 4.

The Cylinder changes into a tall box with four
sides; this will make it easier to create the door.
Later you’ll change the pole back to a cylinder.

Reduce the segments

Next you’ll rotate the cylinder so the four sides
line up with the grid.

Rotate the hub:

1. Click the Zoom button in the viewport
navigation controls. Position the cursor over
the bottom of the cylinder and then press i on
the keyboard to center the viewport on the
cursor position.

2. Zoom in so you can see the bottom of the
cylinder up close. Use Arc Rotate to rotate the
view if you like.

Zoom in and rotate the view.

3. On the toolbar, click Rotate.

The transform gizmo appears in the viewport.
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4. In the coordinate display below the Perspective
viewport, click in the Z entry field and enter 45.
Click OK to confirm the entry.

The cylinder rotates around the Z axis so the
sides line up with the grid.

Cylinder rotated

This will be the pole that revolves to turn the
revolving door. You’ll snap to its sides when
you create an initial Pivot door object. After the
other doors are cloned, you can increase the
number of sides so it will look like a cylinder
again.

Next you will create a tube object to make the
door enclosure.

5. Save your scene as My_revolving_door_
hub.max.

Creating the Enclosure

You will use the primitive Tube object with the
Slice option to create an enclosure for the revolving
door.

Set up the lesson:

1. Continue with your scene from the previous
lesson, or open revolving_door_enclosure.max
to continue.

2. Right-click in the Perspective viewport
to activate it, and then click the Maximum
Viewport Toggle button at the lower right
extreme of the 3ds Max interface to maximize
the Perspective viewport.

Create another layer:

1. On the Layers toolbar, click the Create
New Layer button.

This creates a new layer.

2. Name the Layer Enclosure.

The Move Selection to New Layer setting should
be off. If you leave this on, the hub will be
moved from the previous layer to the new layer.

Click OK.

The Enclosure layer is now visible in the Layer
Properties field.

Create the tube:

1. On the navigation controls, click the Zoom
Extents button to zoom back so you can see the
area around the cylinder.

2. On the Create panel, on the Object Type rollout,
click Tube.

The Tube button turns yellow, indicating it is
active and ready for use.

3. Drag out a tube anywhere in the viewport.
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The size doesn’t matter; you’ll be changing it
in a moment.

Make a tube.

4. In the Parameters rollout on the Create panel,
change Radius 1 to 6’0.0".

5. Change Radius 2 to 5’11.0"

6. Change Height to 7’0.0".

Increase the radius and height of the tube

7. If necessary, zoom out so you can see both the
tube and the cylinder.

Align the tube:

Next, you’ll center the tube over the cylinder.

1. On the toolbar, click the Align button.

Since the tube is selected you will align it to
the cylinder.

2. Click the cylinder in the viewport.

3. On the Align Selection (Cylinder01) dialog,
turn on X Position, Y Position, and Z Position.
Choose Pivot Point for both Current Object
and Target Object. Click OK.

The tube is centered over the cylinder.

On the Create panel, in the Name And Color
group, rename the Tube object left enclosure
panels.

Slice the tube:

1. Click the Modify panel.

2. On the Parameters rollout, turn on Slice On.

3. Adjust the Slice From and Slice To values so you
have a half of a tube visible in the viewport,
resembling the illustration. The difference
between the two values should be 180.
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Slice the tube

4. Change Sides to 6. The enclosure will be created
out of flat panels, rather than curved glass.

5. Change Height Segments to 1.

Lower the geometry values

Next you will clone the tube to create the other
side of the enclosure.

Clone the tube:

1. On the toolbar, click Rotate, if it isn’t
already active.

2. Press the A key on the keyboard to turn on
Angle Snap.

3. Hold down the SHIFT key and rotate the left
enclosure 180 degrees about the Z-axis.

A copy of the tube rotates into place on the
other side of the enclosure.

4. When the copy of the tube is in the proper
position, release the mouse button.

The Clone Options dialog is displayed.

5. On the dialog, set the Object option to Copy
and name the clone right enclosure panels.
Click OK.

6. Adjust the Slice values so the tube resembles the
illustration below. Try setting Slice From=45
and Slice To=–45.0

Depending how you constructed the initial
tube, you may have different values. The
difference between the two should be a multiple
of 90.

7. Change the Sides value to 3.



Creating the Revolving Door 101

Left and right enclosures

You’ll do some more work on the enclosures in
a while, but first you’ll construct the revolving
door.

8. Save your work as my_enclosure.max.

Creating the Revolving Door

To create the revolving door, you will rotate the
right enclosure panel temporarily into a different
position, then you will create a pivot door using
snaps between the hub and the right enclosure
panels. You can edit the material on the door, then
instance the door to create a wheel of four doors.

• Continue from before or open \tutorials\intro_
to_design_visualization\add_door.max.

Rotate the right enclosure:

1. Select the right enclosure panels object in the
viewport.

2. On the toolbar, click the Rotate button.
Rotate the right enclosure panels object 45
degrees until it touches the left enclosure panels
object, as shown below.

Rotate the right enclosure.

This rotation is temporary, for the purpose of
modeling only.

Create a new layer:

1. On the Layers toolbar, click Create New Layer.

2. Turn off Move Selection To New Layer and
name the layer Doors.

3. Click OK.

The Doors layer is now visible in the Layer
Properties field on the Layers toolbar.

Create a door:

1. Right-click any of the Snap buttons on the
Main toolbar, or from the menu bar choose
Customize > Grid And Snap Settings.

The Grids And Snap Settings dialog appears.

2. On the Snaps panel, turn off Grid Points and
turn on Midpoint. Make sure Vertex and
Edge/Segment are still on, and then close the
dialog.

Note: Even though you have selected new snap
settings, you still need to turn on Snaps.

3. Press S on the keyboard to turn on snaps.
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The 3D Snap button is highlighted on
the Snaps area.

4. On the Create panel click the arrow on
the drop-down list and choose Doors. On the
Object Type rollout, click Pivot.

On the Create panel, the Pivot button turns
yellow, and the pivot door Parameters rollouts
appear.

5. In the Perspective viewport, move your cursor
over the cylinder in the center.

You can see the blue snap icon that follows the
edges of the cylinder as you move.

6. Position your cursor so you are snapping to the
bottom-right edge of the cylinder.

7. Drag to the right, away from the cylinder,
keeping the mouse button depressed. Snap to
the front of the right enclosure object. Release
the mouse button to set the width of the door.

Snap to the right enclosure.

8. Press S to turn snaps off.

9. Without moving the mouse, click to set the
depth of the door, and then move the mouse
upward to adjust the height of the door. Click
to set the height.

Set the Height last.

Adjust the door parameters:

Immediately after clicking to set the height, make
the following parameter adjustments, watching
the effects in the viewport. You can adjust these
parameters at any time in the future using the
Modify panel.
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1. In the Frame group, turn off Create Frame.

The frame disappears from the door.

2. In the Leaf Parameters rollout, increase the
Stiles/Top Rail value to about 0’5.0”.

3. Set the Bottom Rail parameter to 1’6.0".

4. Adjust the width of the door so it fits inside the
enclosure. If necessary, adjust the height and
depth as well.

Rotate the enclosure:

1. Select the right enclosure.

2. On the toolbar, click Rotate, and then
move your mouse over the Transform gizmo
tripod in the viewport. When the Z-axis is
highlighted, move your mouse to rotate the
sliced tube back into place.

Tip: If you prefer, you can enter the rotation in
the coordinate display on the status bar.

3. If the pivot door is sticking through the
enclosure after you rotate it, select the pivot
door, and in the Modify panel, change its width
so it fits within the space properly.

Add struts to the enclosure:

You’ll use a Lattice modifier to add struts to the
enclosure. The glass panels will be held up by stout
uprights that you will create next.

1. On the Layers toolbar, choose the Enclosure
layer from the drop-down list.

2. On the Layers toolbar, click Select
Objects In Current Layer.

This selects both Enclosure objects and
deselects any other objects.

3. On the menu bar, choose Edit > Clone.

4. Choose Object group > Copy, and click OK.

The software clones the two enclosure objects
and selects the copies.

5. On the menu bar, choose Modifiers >
Parametric Deformers > Lattice.
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The software applies the Lattice modifier to the
selected objects.

6. In the Geometry group of the Parameters
rollout, choose Struts Only From Edges.

The right and left enclosure panels now are held
up by struts.

7. Adjust the Struts parameters so that:

• Radius=0’1.0"

• Segments=3

• Sides=4

8. In the Struts group of the Parameters rollout,
turn on End Caps.

One of the objects with the Lattice modifier
is named left enclosure panel01, the other is
named right enclosure panel01. You’ll rename
both now.

9. Select the right enclosure panel01object, then
type Struts right in the Name and Color field.
Also rename the left enclosure panel01 object
Struts left.

Next, you will create, apply, and edit some
materials for the revolving door.

10.Save your file as my_add_door.max.

Applying Materials to the
Revolving Door

You’ll add some quick materials to help visualize
your revolving door. You’ll add a shiny black
finish for the struts and a green glass material for
the glazing in the door and the enclosures. You’ll
also edit the material that already exists on the
revolving door, so it matches your own green glass.

Open the material editor:

1. Continue from the previous exercise,
or choose File > Open and load
\tutorials\intro_to_design_visualization\
add_door_materials.max.

2. Open the Material Editor. You can press M
on the keyboard, or click the Material Editor
button on the toolbar.

The Material Editor appears in its own dialog.

Apply a door material:

You can choose materials from a material library
and apply them to the revolving door so the panel
is transparent.

1. On the Material Editor toolbar, below the
sample spheres, click the Get Material button.

The Material/Map Browser opens.

2. In the Browse From group, choose Mtl Library.

“Mtl” is an abbreviation for “Material.”

3. In the File group, click Open.

4. Open the AecTemplates.mat file

5. In the list of materials that appears double–click
the material name Door-Template.

The door material appears in the material
editor.

6. Drag the material from the sample sphere to the
door object in the viewport.
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The door now displays with transparent glass.

Tip: If you loaded the provided scene file, you
might get a message that asks you to Replace
or Rename the material. Choose Replace and
continue.

Create and apply a green glass material:

1. Click any unused sample sphere in the Material
Editor to activate the material.

2. Drag the material onto the left enclosure panels
object. Drag from the material sample sphere
to the viewport, and read the tooltip to be sure
you have the left enclosure object (left enclosure
panels) as the target.

The glass panels of the left enclosure change
their appearance in the viewport. Also, in
the Material Editor, the sample sphere is now
marked with corners showing that this material
has been applied to an object in the scene.

3. On the Blinn Basic Parameters rollout, change
the color of this material by clicking the Diffuse
color swatch. When the Color Selector opens,
pick a green color.

Watch in the viewport; each time you click
a different color, the material updates in the
viewport. When you’ve decided on a color,
click the Close button.

4. On the Blinn Basic Parameters rollout, change
the Opacity value to 66.

5. Rename the current material to Green Glass.
Highlight the name and then enter the new
name.

6. Drag the Green Glass material from the sample
sphere in the material editor to the right
enclosure panels object in the viewport.

The glass on the right enclosure matches the
color and transparency of the left enclosure.



106 Chapter 15: Advanced

Create a black metal finish:

1. In the Material Editor, activate a different
sample sphere by clicking it.

2. Name the material Black Metal Finish.

3. On the Shader Basic Parameters rollout, click
the drop-down arrow next to Blinn and choose
Metal.

4. On the Metal Basic Parameters rollout, click the
Ambient color swatch. In the Color Selector,
choose a dark color close to black. You can use
the Whiteness slider to darken the color.

Note: The Diffuse color changes to the same
dark color, since the Diffuse and Ambient
values are locked together by default.

5. Set Specular Level to 128 and Glossiness to 37.

This will produce a black, shiny surface
treatment.

6. Press H on the keyboard, then select the Struts
objects by name. Hold down the CTRL key and
highlight the names, and then click Select to
select both objects and close the dialog.

7. Click the Assign Material To Selection
button to apply the material to the selection.

8. Drag this material onto the central hub object
(Cylinder01).

Edit the material:

After you created the pivot door, you assigned a
Multi/Sub-Object material from a material library
to the door. When you have a single object, such
as this door, with different, distinct components
(such as glazing, frame, and so on), you can use
this type of material to apply different materials
to the parts.

You will use the eyedropper to get the material
from the door into the material editor. This will
give you a second copy of the material to edit,
leaving the original available for use.

1. Click another sample sphere, to make it active.

2. In the Material Editor, click the eyedropper
button to activate it, and then in the viewport
click the pivot door.

The sample sphere is replaced with a sphere
that shows five stripes of different materials.
This indicates that the selected material is a
Multi/Sub-Object material.

On the Multi/Sub-Object Basic Parameters
rollout you can click and access each individual
material.

3. Drag the Green Glass sample sphere to the
Inner Bevel (Standard) button. On the Instance
(Copy) Material dialog choose Instance, if
necessary, and click OK.

This is the material that is applied to the glazing.
The glass on the revolving door turns green in
the viewport.
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4. Drag the Black Metal Finish material to the
other material slots in the Multi/Sub-Object
material. In each case choose Instance.

Change the material:

Now make changes to the material and watch them
update on the objects in the viewport.

Change the Black Metal Finish to a shiny gold
instead. Do the following:

1. Click the Black Metal Finish sample sphere.

2. Click the Diffuse color swatch, and then change
the black material to a gold material. Use RGB
values of approximately 176, 157, and 52,
respectively, to achieve a nice gold tone.

3. Rename the Black Metal Finish material to
Burnished Gold.

4. Right-click the Perspective label in the
viewport, and turn off Edged Faces.

Close the Material Editor when you’re done.

5. Save your file as my_add_door_
materials.max.

Cloning the Door

There will be four doors revolving around the
central hub. You have one door so far, and you
will make three instances of the door to complete
the wheel.

• Continue from before, or load
\tutorials\intro_to_design_visualization\
start_door_clone.max.

Adjust the door position and rotation:

1. Activate the Top viewport or press T on the
keyboard to change to a Top viewport.

2. Right-click the viewport label and make sure
the viewport is set to Wireframe shading mode.

3. Zoom in and select the pivot door.

4. Move the pivot door, if necessary, so it is
centered on the edge of the hub, as illustrated.
Rotate the door, if necessary, so it is square to
the hub. One way to accomplish the latter is to
click the Select And Rotate button, and then set
the Z coordinate under the viewport to 0.0.
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5. Press P on the keyboard to return to the
Perspective viewport, or right–click anywhere
within the Perspective viewport to activate it
without changing the selection.

Create the cloned doors:

1. Right-click in the viewport and choose Rotate
from the menu.

This right-click menu is called the quad menu.
You can use it to access tools from the toolbar
and command panel for quicker workflow. You
can even customize it to keep your favorite
tools right under your fingertips.

2. On the toolbar, click the drop-down arrow
for the Reference Coordinate System (View
is the default). Choose Pick, then click the
Cylinder01 object (the hub) in the viewport.

3. On the toolbar, directly next to the
Reference Coordinate system drop-down,
choose Use Transform Coordinate Center.

This allows you to rotate the pivot door around
the cylinder’s pivot point, rather than its own.

4. Press A on the keyboard to turn Angle Snap
on, if it isn’t already.

The Angle Snap button activates on the toolbar.

5. Hold down the SHIFT key and position your
cursor over the blue circle (Z axis) in the Rotate
gizmo until the circle turns yellow. Then click
and drag slowly to rotate the door until Z= 90
degrees in the Coordinate display. Release the
mouse button.

6. On the Clone Options dialog, set Number Of
Copies to 3, choose Instance (if necessary), and
click OK.

Now there are four doors within the enclosure.

Clone the door to create a wheel of doors

7. Select the hub in the viewport, and then on the
Modify panel, change its Sides value to 12.

The hub now resembles a cylinder rather than a
box.

8. Save your work as my_fourdoor.max.

Animating the Revolving Door

To make the revolving door spin, you will first link
the four doors to the hub. Then using the Time
slider, you will animate the rotation of the hub to
spin the doors.
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• Continue from before or load \tutorials\intro_
to_design_visualization\start_door_link.max.

Link the doors to the hub:

1. Zoom in the viewport so you have a close-up
view of the hub and the four doors.

2. On the toolbar, click the Select And Link
button.

3. In the viewport, drag from one of the pivot door
objects to the hub. You will see a dotted line
drawn between your cursor and the original
door as you move.

4. Repeat the operation for each of the other three
doors.

5. To verify that you correctly linked the four
doors to the hub, do the following:

• On the toolbar, click the Select button.

• Click Select by Name, or press H on
the keyboard.

• On the Select Objects dialog, turn on
Display Subtree if necessary.

All four Pivot Door objects should be
indented below the Cylinder01 object in the
list. If any aren’t, re-link them to the hub.

Now you are ready to animate the revolving
door.

Replace the rotation controller

First you will replace the rotation controller on the
hub. The default controller is good for character
animation, but you’ll replace it with a controller
that is better for design visualization animation.

1. Select the hub in the viewport.

2. Open the Motion panel, and expand the
Assign Controller rollout if necessary.

3. In the Assign Controller window, highlight the
Rotation: Euler XYZ item.

Click the Assign Controller button.
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4. In the Assign Controller dialog click TCB
Rotation, and click OK.

The rotation controller listed in the Assign
Controller rollout changes to TCB Rotation.

5. Scroll down to the bottom of the Key Info
rollout and turn on Rotation Windup. This will
allow you to set rotation keys greater than 180
degrees.

Important: You must turn on Rotation Windup, or

the animation won’t work correctly.

Animate the hub:

1. Turn on the Auto Key button.

2. Move the time slider to frame 100.

3. Click the hub in the viewport to select it.

4. Right-click and choose Rotate, then rotate the
hub 360 degrees about the Z axis. Watch the
coordinate display to get the correct rotation.

Tip: To make setting even rotations easier, turn
on Angle Snap by pressing the A key on the
keyboard.

The Time Slider now shows keyframes as small
squares at the beginning and at the end of the
time segment.

5. On the VCR controls, rewind the
animation by clicking the Go To Start button,
and then click the Play button.

Watch your revolving door rotate in the
viewport.

Save your work:

• On the menu bar, choose File > Save As and
save your work as myrevolvingdoor01.max.

You can use the plus button (+) to increment
the file name.

Slow down the animation:

To slow down the rotation of the revolving door,
do the following:

1. Click the Time Configuration button.

2. In the Animation group, click Re-scale Time.

3. On the Re-scale Time dialog, change End Time
to 200, then click OK.

4. Click OK to close the Time Configuration
dialog.

The Time Slider now displays 200 frames, with
a key at frame 0 and frame 200.

5. Click the Play button and watch the revolving
door go around.

The animation plays slower than before.

6. Stop the playback in the viewport, and click the
Auto Key button to turn it off.
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7. Save your work as myrevolvingdoor02.max.

Merging Files

The revolving door seems lonely, spinning by
itself in the viewport. You can use the Merge File
function to put this revolving door into context, by
merging in another scene of an entranceway.

You’ll also learn to animate the opening of
parametric doors.

• On the File menu, choose Open and browse
to \tutorials\intro_to_design_visualization\
revolving_door.max. Click Open to load this
file.

Merge a scene:

1. On the File menu choose Merge and browse
to \tutorials\intro_to_design_visualization\
entranceway.max, and click Open.

After you click the file name, the Merge File
dialog displays a thumbnail of the scene.

2. In the Merge File dialog, click the All button
to select all the objects in the scene, and then
click OK.

3. If the Duplicate Name dialog appears, click
Skip for any duplicate objects.

The revolving door is now in the middle of the
entranceway.

Note: If you’ve been modeling in metric units
you might need to scale the revolving door so it
matches the new scene. You can use the Rescale
World Units utility if you need to accomplish
this.

4. Click the Zoom button in the viewport
navigation controls, then zoom back so you can
see the double doors.

Animate the double doors:

1. Turn on the Auto Key button.

2. Move the Time Slider to frame 100.

3. Select the Double doors object in the viewport.

4. On the Modify panel, in the Parameters rollout,
set Open to 75.0 degrees.

Note: The spinner is now outlined in red,
indicating it is an animated parameter that has
a key on the current frame.

5. Move the Time Slider to frame 200.

6. On the Modify panel, set Open back to 0.0
degrees.

7. Play the animation using the Play button
in the VCR controls.

The revolving doors go around and the double
doors swing open.

3dsmax.chm::/Rescale_World_Units_Utility.html
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Fine-tune the animation:

You can use the track bar to make the double doors
open and close faster.

1. Make sure the double doors are selected, and
then on the track bar, drag the key at frame 100
to frame 25. Watch in the status bar for the
frame number.

2. Similarly, move the key at frame 200 to frame
50, and then play the animation.

The doors open and close more quickly.

You can make the doors open and close
repeatedly throughout the rest of the animation
by using Track View.

3. On the Modify panel find the animated Open
parameter, and right-click within the numeric
field. From the menu that appears choose Show
In Track View.

A Track View – Curve Editor window opens
with the Double doors Open parameter
highlighted.

4. On the Track View toolbar click the
Parameter Curve Out of Range Types button.

5. On the Parameter Curve Out of Range Types
dialog, click Ping Pong.

Click OK to accept the change and dismiss the
dialog, and click OK in the Selected track view
dialog to dismiss it.

6. Play the animation again.

Now the doors open and shut throughout the
animation.

7. Turn off Auto Key before continuing.

The glass on the revolving doors is going to get
covered with fingerprints from all the people
pushing on the glass. You’ll add a push bar to the
doors. You can easily make a single push bar out of
a torus and attach it to the door.

Isolate the doors:

1. On the Layers toolbar, click the Layer
Manager button.

2. In the Layer dialog, click the gray box next to
the Doors layer to make it the active layer.

3. In the Layer Manager click in the Hide column
next to each layer except Doors. Close the Layer
Manager.

The doors are isolated. Everything else in
the scene goes away and only the doors are
displayed.
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Create the push bar:

1. Zoom in on the doors, if necessary.

2. Make sure the Doors layer is active.

3. On the Create panel, in the Standard Primitives
category, click Torus.

4. On the Object Type rollout, turn on AutoGrid.

5. Turn off Auto Key and go to frame 0, if
necessary.

6. Move your cursor over the front of the door
facing you and drag out a Torus.

A Torus is created on the plane of the door.

7. Right-click in the viewport to exit Create mode.

8. Go to the Modify panel, and on the Parameters
rollout:

• Set Radius 1 to 0’8.0” and Radius 2 to 0’1.5”.

• Change the Rotation setting to 45.0.

Now the geometry will work for the push
bar.

• Change Segments to 3.

• Change Sides to 4.

• Set Smooth to None.

• Turn on Slice On.

• Set Slice From to 180.0 and Slice To to 0.0.

9. Right-click and choose Move from the quad
menu, then move the push-bar object using the
transform gizmo to the right center of the door,
as shown below. Rotate it if necessary.

Attach the push bar:

1. In the viewport, click the door to select it.

The name PivotDoor01 appears at the top of
the Modify panel.

2. From the Modifier List choose Edit Mesh.

An Edit Mesh modifier is added to the Modify
stack.

3. On the Edit Geometry rollout, click Attach,
then click the push bar in the viewport.

The push bar changes color in the viewport.
Click the Attach button again to turn it off.

4. Press the Play button on the VCR controls.
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The revolving door spins around. There are
four push bars, one on each door. Since the
other three doors are instances of the first,
adding geometry to one adds geometry to all.

5. Open the Layer Manager and unhide all layers.

The entire scene is visible now. You can
find an example of the finished scene in
\tutorials\intro_to_design_visualization\
revolving_door_final.max for comparison
purposes.

Summary

In this tutorial you learned to get around the
3ds Max user interface, and to do some simple
modeling and animation. You learned to work
with primitive objects and apply and edit materials.
You created a door object, made clones of it, and
linked the doors to a parent object in order to
make an animation. Lastly, you learned to merge
files together to create a more complex scene.

Camera Matching & Camera
Map
Mixing video and computer generated graphics is
accomplished here using the Camera Match utility.

The storyboard involves a pool game between two
characters.

The animation of the cue ball is synchronized to
the character’s actions in the video.

The guy in the blue shirt is a magic guy who makes
the cue ball move by using the pool stick as a
remote control. The cue ball in the illustration is
computer-generated. The video was shot with no
actual cue ball.

3D Pool Ball animation integrated with background video

The magic guy can also create a wave in the table
top. You’ll accomplish this in the next tutorial,
Adding Effects with Camera Map (page 3–125).
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Camera Mapping and Affect Region modifier

To create these effects you’ll use Camera Match to
create a camera that closely emulates the actual
camera used to take the video. Then anything you
create will be in the proper perspective and will
appear to be in the scene.

Camera Match relies on using accurate
measurements of points in space that are visible
in the video.

In this tutorial, you place 3D camera points
onto box primitives, which match the shape and
size of two overhead lamps in a pool hall. You
then specify both a rendering background and a
background for the viewport. Finally, you place
2D camera helper objects on the background and
create a camera to match your background.

Tutorial Files

The files for this tutorial are on the Tutorial Files
CD in the \tutorials\camera_match folder.

Time to complete: 1 hour

This is an intermediate level tutorial.

Preparing the Scene

Proper use of Camera Match requires some
planning and preparation. In this tutorial, the
planning work has been done for you. The
following guidelines help you understand the
planning involved, and what to do on your own
Camera Match projects.

Basic Steps

This topic introduces the first two steps. The rest
of the tutorial concentrates on the details of the
third step.

• Identify five or more reference points on the
background video to use with Camera Match.
The points cannot all be on a single plane. It’s
also wise to pick points spread throughout the
scene, some near, some far, some high, some
low. Sometimes a match isn’t accurate because
the points are too close together.

• Obtain accurate measurements of these points
during the shoot. This is a critical step. Errors
in measurement show up in the final match.

• Create CamPoint Helper objects and accurately
position them in your 3ds Max scene to match
the point measurements taken during the shoot.

• Camera Match uses these points to calculate
the position and viewing angle of a software
camera whose view is the same as the hardware
camera that took the photograph.

• It is possible to work with stock footage, and
other video without accurate measurements, if
you can find other techniques to estimate the
distance between the points. However, you
might not get as accurate a match.

Practical Advice for Best Results

The following recommendations will generally
produce the best results.
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• Work directly with the cinematographer. Let
the cameraperson know that you are camera
matching this scene, and that the points you’ll
be matching will be visible in the scene. If
the point is deep in a shadow, it might not be
distinguishable.

• Measure the points yourself. Have an assistant
hold the other end of the tape measure. Make
sure to get the camera height and the distance
from the camera to the nearest and farthest
points in the scene.

• Make a sketch with dimensions showing the
relationships between the points you will
match. Make copies of the sketches. Everyone
loses the paper with the measurements.

• If possible try to pick points that will still be
there the next day. You may want to come back
and confirm the accuracy of the measurements.
Try to avoid picking points that will be hidden
by the actors.

Choosing Good Reference Points

Selection of good reference points is the key to
success with Camera Matching. Here are some
guidelines:

• Choose points to match that are not all in one
section of the scene. Select points that are
widely separated.

• Choose points whose measurements are easy to
obtain. These have a higher likelihood of being
accurate.

• Choose points to maximize depth. More depth
results in a more accurate match.

• A minimum of five points is needed for Camera
Match to work correctly. In practice, you
can’t be sure all the points you choose will be
accurate or appropriate, so it’s a good idea to
measure additional ones. If you have trouble
with a match, you can substitute one of these
points for a suspect one.

With a movie or photograph and a set of
measured points, you can now input those
points to begin Camera Match.

Placing 3D Camera Points

In this topic, the reference points that were
measured on-site and identified in the background
movie are converted to special helper objects
called CamPoints. CamPoints represent the
scene locations of the points you match in the
background photograph.

The pool hall movie has been composed so that
you can use the two lamps hanging over the pool
tables behind the actors to do the camera match.
The lamps over the pool table were measured
while shooting the pool hall video. The pool table
surface was used as the ground plane to measure
from.

Creating Stand-in Geometry

In general, it’s helpful to model and position
simple geometry to represent the outer dimensions
of the objects you’re matching. For example, the
lamps above the pool table are 48.0" x 20.5" x
2.676". The opening scene contains two wireframe
boxes of these dimensions, positioned to the
measured height and spacing above the 3ds Max
ground plane, which represents the pool table
surface.

Set up the lesson:

Tutorial files are on the Tutorials Files CD in the
\tutorials\camera_match directory.

1. Open match1.max.

Two boxes named leftlamp and rightlamp are
already in place.
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These two boxes represent the two overhead
lights in the background video directly behind
the pool player.

The boxes match the dimensions of the lights in
the actual pool hall. You’ll use the corners of the
lights for the camera match point positions.

2. In the Perspective viewport, select leftlamp
and click Zoom Extents Selected.

The Perspective viewport zooms to a close-up
of the left lamp.

3. Right-click 3D Snap Toggle to display
the Grid And Snap Settings dialog.

4. Turn off Grid Points and turn on Vertex, if they
are not set this way already.

5. Close the Grid And Snap Settings dialog,
then click 3D Snap Toggle to turn on the snaps
you’ve set.

Note: Choosing the setting for Grid and Snaps
doesn’t automatically turn on Snaps.

6. Maximize the Perspective viewport by
clicking Min/Max Toggle or pressing ALT+W.

Place CamPoints:

1. On the Create panel click the Helpers tab.
Click the drop-down arrow and choose Camera
Match from the list.

2. On the Object Type rollout click CamPoint
Object.

The CamPoint button highlights in the Create
panel.

3. On the leftlamp box, position the cursor over
the top corner that is closest to the front of the
viewport. When the cursor is close to a vertex,
a blue cross shows the snap activity.

4. Click the corner to create a camera point.
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5. On the Name And Color rollout, change the
name of the camera point you just created to
leftlamp center top.

It’s good practice to rename CamPoints as you
create them.

You’re calling this leftlamp center top because
in the background video this point is in the
center and at the top of the points you’ll use.

6. Create the second point on the bottom corner
of the lamp directly beneath the first point.
Name it leftlamp center bottom.

7. Use Arc Rotate to change the view slightly
so you can easily place each point. Or hold
down ALT+middle mouse button and drag to
rotate the view.

8. Create two more points on the leftlamp, naming
them as follows:

• leftlamp rear top

• leftlamp rear bottom

Four CamPoint Helper objects snapped to vertices

9. Add two CamPoints to the rightlamp, repeating
the process described for the leftlamp. Note

that they are on the right side of the right lamp.
Name them as follows:

• rightlamp center top

• rightlamp rear top

Six Camera points in position

Save your work:

• When all points are in place, save your file as
mymatch1.max.

Next, you will add the video to the scene: first
as a rendering background, then as a viewport
background.

Setting Up a Rendering
Background

This topic sets up the background image used
for rendering. In this case, the image is a bitmap
taken from an AVI file. The rendering background
will not be visible in the viewports. You set up a
viewport background in a later topic.

Set up the lesson:

• To start at this point, continue from the
previous sequence, or open your saved file
mymatch1.max, or reset 3ds Max and open
match2.max.

The scene displays the two boxes with their
CamPoints.
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Set up a rendering background:

1. On the menu bar choose Rendering >
Environment.

2. On the Common Parameters rollout, click the
Environment Map button marked None.

The Material/Map Browser is displayed.

3. In the browser, pick Bitmap from the list and
click OK.

The Select Bitmap Image File dialog is
displayed.

4. In the dialog, select joystik.avi from the
tutorials/camera_match folder, and click Open.

Thumbnail of joystik.avi

The Environment and Effects dialog now shows
joystick.avi as the environment map. The Use
Map box is automatically selected.

5. Close the Environment and Effects dialog.

The background image is now set up as your
rendering background. You won’t see the image
in the viewports.

6. Activate the Perspective viewport.

7. On the menu bar, choose Rendering > Render.
Render the Perspective viewport at 320 x 240.

The two lamps are displayed with the pool-hall
image as the background.

Checking the Rendering
Resolution

Camera Match requires correct synchronization
between the rendering background resolution,
the final rendering resolution, and the viewport
background. Without this synchronization,
Camera Match produces incorrect results.

Tip: To simplify synchronization, use the same
resolution throughout.

In this topic, you simply check the resolution of
the background image file. In your own projects,
you would use this information to set the other
resolutions before performing the camera match.
The resolution of any image file can be checked
in this way.

Check the resolution of the image file:

1. On the menu bar, choose File > View Image
File.

2. On the View File dialog, do the following:

• Select joystik.avi.

• At the bottom of the dialog, the Statistics
line shows the resolution of the file to be 320
x 240.

• Click Cancel to dismiss the View File dialog.
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Displaying the Background in the
Viewport

At this point, you’re ready to display the
background image in a viewport.

Note: Each viewport can display a different
background, which can be independent of the
background used by the renderer. This is most
useful when modeling.

Set up the lesson:

• To start at this point, continue from the
previous step, or reset 3ds Max and open
match3.max.

Display a viewport background:

1. Right-click anywhere on the Perspective
viewport to activate it.

2. On the menu bar, choose Views > Viewport
Background to display the Viewport
Background dialog.

3. In this dialog, in the Background Source group,
click Files.

4. Choose joystik.avi. If necessary, navigate to the
directory containing this file. Click Open.

5. In the Aspect Ratio group, choose Match
Bitmap so your bitmap is not distorted. (As
an alternative, in the Background Source
group, you could turn on Use Environment
Background, but this limits the options for
controlling display.)

6. In the Viewport Background dialog, click OK.

In the Perspective viewport, you now see a
frame from the background pool-hall movie.

Viewport display of Background Image

7. Save the file as mymatch2.max.

Using Different Files to Display the
Same Background

Although you want to use the same image for both
the viewport and rendering backgrounds, you
don’t have to use the same file.

The following procedure makes matching the
perspective background easier. Using a paint
program, you first mark up a copy of the file to
emphasize CamPoints. You then make this file the
viewport background. The procedure is optional
here, but you might want to try it in your own
project.

Optional procedure to make Camera Match easier:

1. Open mymatch2.max.

2. Hide the geometry, and then render this frame
as a TGA still image.

3. Unhide the geometry.

4. In the Windows Explorer, make a copy of
the background image TGA file to use as the
viewport background.

5. Open this file in a paint program. Highlight the
CamPoint locations and prominent edges in
the image. This will make them easier to see
when you do Camera Match.
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Paint arrows to show CamPoint object locations

6. Save this altered image under another name.

7. In 3ds Max, activate the Perspective viewport.

8. Choose Views > Viewport Background to open
the Viewport Background dialog.

9. In this dialog, click Files and select the file you
just saved. Click OK.

Up to this point, you’ve placed CamPoints
in real-world locations in your scene, and
synchronized the display of the rendering and
viewport backgrounds. In the lessons that follow,
you use the Camera Match utility to assign 2D
screen points and create the camera.

Installing the Software Driver

In general, it’s better to use the Software driver
when learning to use Camera Match. Some video
cards have a problem with Camera Match when
using the OpenGL or Direct 3D drivers.

• If you’ve already installed the Software driver
(the default choice when you first started
3ds Max), you can skip this procedure, or use it
to double-check what driver you have installed.

• If you have an OpenGL video card, you
should definitely follow this procedure. After
Camera Match is complete, you can repeat the

procedure to switch back to your OpenGL
driver.

Not all OpenGL cards have this problem. You
might opt to wait until you experience it in the
next topic. If the red pluses don’t appear, press ‘ to
redraw the screen. If you still have no red pluses,
it’s time to change your driver.

Install the Software driver:

1. On the Customize menu, choose Preferences to
display the Preference Settings dialog.

2. Click the Viewports tab.

The currently installed driver is shown in the
Display Drivers group.

3. Do one of the following:

• If your driver is Software , as shown in the
illustration, close the dialog and continue
to the next topic.

• If OpenGL or Direct3D is currently selected,
click Choose Driver. On the dialog, select
Software and then click OK.

4. Restart the program to initialize the new driver.

Assigning 2D Camera Screen
Points

You assign 2D camera screen points to identify
how the 3D CamPoints are matched to the
background image. You can assign camera screen
points in either a User or Perspective viewport.
These procedures use a Perspective viewport.

Set up the lesson:

1. To start at this point, continue from the previous
topic, or open your saved file mymatch2.max,
or reset 3ds Max and open match4.max.
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2. If the background is not already displayed,
right-click the Perspective viewport label and
select Show Background. If you encounter
an error message saying the program can’t
find the background, browse for it in the
\tutorials\camera_match directory on the
Tutorials Files CD.

3. Click Min/Max Toggle, or press ALT+W
to maximize the Perspective viewport.

4. If home grid is on, press G to turn it off.

The grid is not needed here.

Next, you’ll assign positions on the bitmap
background in the viewport to represent the
CamPoints.

Assign the first screen point:

1. Open the Utility panel. Choose Camera
Match to display the CamPoint Info rollout.

2. On the toolbar, in the Selection Filters list,
choose Helpers.

This prevents you from selecting any other kind
of object in the scene.

Tip: This is very useful, but don’t forget to turn it
off when you’re finished. Otherwise you won’t
be able to select anything but helpers.

3. On the CamPoint Info rollout, select leftlamp
center top.

4. Click the Assign Position button to turn it on.

5. On the background video itself, move the
cursor over the top-center corner of the real
leftlamp in the bitmap image (not the corner of
the stand-in box geometry).

6. Click the top-center corner of the left lamp.

The following warning message is displayed:

7. Click Yes to close the dialog. A red plus sign is
displayed on the bitmap.

Warning: If a red plus does not appear, you might be

using an OpenGL driver. Press ‘ to redraw the viewport.

If the red plus doesn’t appear, follow the procedure for

Installing the Software Driver (page 3–121), then repeat

this procedure.

Reposition screen points:

Use this technique if you need to adjust the
position of the red plus sign after you first assign
a screen point.
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• On the CamPoint Info dialog, click the X and Y
spinner arrows (Input Screen Coordinates) to
change the position of the red plus. The Input
screen Coordinates Y position is inverted,
increasing the Y value moves the point down.

Note: You can always reassign a screen point.
Only the last position is saved.

Assign more screen points:

1. From the CamPoint Info list, choose leftlamp
center bottom. Assign its position.

2. Toggle between the leftlamp center top and
leftlamp center bottom and adjust the X values
so they are the same.

This establishes a vertical relative to the scene.

The first two CamPoints

3. Click leftlamp rear top in the CamPoint Info
list. Assign its position.

4. Repeat this process for leftlamp rear bottom.

The first four CamPoints

Create a camera to test Camera Match:

1. On the Camera Match rollout, click Create
Camera.

A message is displayed that says you don’t have
enough active points to make a meaningful
estimate. You need to assign one more point.

2. Choose rightlamp center top and assign its
position.

3. On the menu bar, choose Views > Save Active
Perspective View so you can return to this view
if necessary.

4. Click Create Camera. This time, you can
see that the camera has been created in the
viewport.

5. Right-click the Perspective viewport label, and
choose Views > Camera01.

The viewport switches to the camera created
by Camera Match.

Modify the camera position:

1. Right-click the label of the Camera01 viewport
and choose Wireframe.

2. In the CamPoint Info list, select rightlamp rear
top and assign its position.

3. Click Modify Camera.

The camera moves slightly, based on the
addition of the new point.

4. Click the Assign Position button again to turn
it off.
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5. Using the X and Y spinners, try nudging the
rightlamp rear top a bit. Then click Modify
Camera again.

On the Camera Match rollout, notice the
readout for Current Camera Error. You want
this number as small as you can get it, but
there are diminishing returns in trying to
establish zero error. If the match looks good,
it’s probably as close as you’ll need.

Save your work:

• When Camera Match is complete, save your
scene as mymatch3.max.

Troubleshooting Camera Match

Camera Match depends on how accurately you
measured the geometry, and how accurately
you assigned the CamPoints to the bitmap
background.

You might get the following error message:

Check for problems:

If you get an error message, there are a number of
possible causes. The following are some general
approaches for troubleshooting. When you think
you’ve corrected the problem, click Create Camera
to test the solution.

1. Try disabling one or more points, maintaining
a minimum of five points.

• You do this on the CamPoint Info dialog by
selecting a point in the list and then turning
off Use This Point.

2. Check the coordinates of each CamPoint.

• Turn on Select and Move and
right-click the button to display the
Transform Type-In dialog.

• Use Select By Name to select each point.

• Check the coordinates and revise as needed.

3. Check for coplanar CamPoints.

• Hide the viewport background and rotate
the viewport. If the points all line up at some
point during the rotation, they are coplanar.
You might have inadvertently snapped the
points to a grid. Use the previous method
to reposition them.

Next

Matching Camera to View (page 3–124)

Matching Camera to View

If the camera fails to match perfectly, here are a
few possible reasons:

• Measurements of the physical 3D points are not
accurate enough, particularly elevations.

• Distortions in the lens, or from the digital
scanning and processing of the photo.

• The points are too close together and are not
spread sufficiently throughout the scene. This
is sometimes the case when your camera match
is slightly off.

• User error. You have incorrectly assigned a
position to a point. This is usually the case
when your camera match is way off.

Regardless of the source of the problem, you
can manually adjust a match that is less than
perfect. You use Perspective navigation tools to
adjust the scene visually, then use a command
to move the camera to match that perspective.
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Adjust the match:

1. Right-click the Camera01 viewport to activate
it.

2. Press P on the keyboard to change the viewport
to Perspective.

3. Activate Arc Rotate and roll the
Perspective viewport by clicking outside the
yellow circle in the viewport.

4. Use Pan and Arc Rotate tools repeatedly
until the stand-in geometry lines up more
closely.

In this example, a slight rotation of the
Perspective viewport to the right might
improve the match.

5. Select Camera01. Because cameras are
often hard to locate, use Select By Name on the
toolbar for ease and precision.

6. Right-click the Perspective viewport label to
display the flyout menu. On the menu bar,
choose Views > Create Camera From View.

Camera01 moves to match the view in the
Perspective viewport.

Note: The Create Camera From View command
will create a new camera if no camera is
selected. If a camera is already selected, that
camera will be matched to the view.

7. Press C to switch the viewport to the camera.

Camera Match is now complete.

Save your work:

• Save your scene as mymatch4.max.

Summary

This tutorial has demonstrated:

• Placing 3D CamPoint helpers to match a scene’s
geometry.

• Using a background for rendering and for a
viewport.

• Placing 2D camera screen points that
correspond to the CamPoint helpers.

• Using Camera Match and the camera screen
points to generate a camera position that
matches the background.

Using the Camera Map modifier and other
techniques, this tutorial adds some special effects
to a camera-matched scene. You will animate a
cue ball and synchronize it with the movement of
actors in the pool hall video. You’ll create a matte
object so the cue ball can move behind the bitmap
of the player’s hand, and you’ll use the Camera
Map modifier to create a wave in the table.

Features Covered in This Tutorial

• Adding time tags to aid in synchronizing
animation.

• Creating a matte object and material.

• Animating a 3D object to match video footage.

Tutorial Files

The files for this tutorial are in the
\tutorials\camera_map folder.

Time to complete: 45 minutes
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Adding Time Tags

In the next three lessons, you will set up the
synchronization, then create and animate a cue
ball. Finally, you’ll create a matte object to make
the ball appear behind the player’s hand.

In this lesson, you’ll add time tags to three
locations in the joystik.avi video. The tags coincide
with the motion of the dark-haired pool player in
the video, who will use magic to interfere with his
opponent’s shot. When you animate the surface
of the table and the cue ball, you use these tags to
place keyframes.

Set up the lesson:

Files for this tutorial are located on the Tutorial
Files CD in the \tutorials\camera_map folder.

1. To start from this point, do one of the following:

• Start or reset 3ds Max and open match6.max.

• Open mymatch4.max, if you saved this file
at the end of the tutorial Using Camera
Match (page 3–114).

2. On the menu bar, choose Customize >
Preferences, and click the Viewports tab.

3. In the Viewport Parameters group, turn on
Update Background While Playing, then click
OK.

Now the movie will update in the viewport
background when you play the animation or
drag the time slider.

Display a viewport background:

1. Activate the Camera viewport.

2. Choose Views > Viewport Background to
display the Viewport Background dialog.

3. Make sure the background file is joystik.avi,
and not joystik.tga.

4. Turn on Animate Background and click OK.

5. Click the Play Animation button.

The video plays in the viewport. Depending on
the speed of your computer, the timing might
be off, not playing in real time. If so you can
play the movie using Windows Media Player.

View the video in real time:

You need to see the actual timing of the video to
determine where to add time tags.

1. On the menu bar, choose File > View Image
File.

2. Choose joystik.avi, and then click Open.

The Media Player window is displayed.

Note: You may have a variety of Media Players,
depending on the version of your operating
system. Some steps might not apply to your
player program.

3. Click the Play button and watch the video play
in real time.

Notice that the timing of the cue stick
movement. First it is slow, then fast.

4. Close the Media Player.

5. Click the Play Animation button in 3ds Max.

You can see the movie updating in the viewport
background.

6. Use the greater than and less than keys ( <
and >) to shuffle through the movie a frame
at a time. Determine at which frame the stick
movement shifts direction.

The stick movement stops at frame 64.

Add time tags:

1. In 3ds Max, move the time slider to frame 64.

2. On the status line, right-click in the Add Time
Tag field to the left of the Set Keys button.

3. Choose Add Tag from the menu to display the
Add Time Tag dialog.
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The Add Time Tab dialog appears.

Add Time Tag dialog

4. In the Add Time Tag dialog, add the Tag Name
extreme right, and click OK.

5. Maximize the Media Player and scrub its time
slider to determine where the dark-haired
player’s cue stick stops near the middle of the
video. Minimize the Media Player when you’re
done.

The actor holds the cue stick almost stationary
for a moment between frames 39 and 43.

6. Move the time slider to frame 39 and add a time
tag named start hold.

7. Add a time tag at frame 43 named end hold.

8. Drag the time slider to see these named tags
appear in the Add Time Tag field.

You can jump to any of these named frames
now by right-clicking Add Time Tag and
choosing the name from the list.

Match the number of frames:

In this procedure, you first determine the exact
last frame of the video.

1. Use the > key on the keyboard to shuffle
through the movie one frame at a time.

Note that the length of the video is 84 frames.
The current 3ds Max file is set to play 100
frames, so the movie disappears from the
viewport background after frame 84.. You need
to make the file match the background movie.

2. In the Animation Controls area, click Time
Configuration.

3. In the Time Configuration dialog, change End
Time from 100 to 84. Click OK.

4. In 3ds Max, move the time slider to the end.

The slider reads 84/84. The animation is now
the correct length.

Animating a Cue Ball

In this step, you create and animate a cue ball to
follow the movement of the pool player shooting
with the cue stick.

Continue using the file created in the previous
lesson.

Position the cue ball:

1. Go to frame 0, and activate the Camera
viewport.

Make sure the Snaps Toggle is turned off.

2. Create a sphere in front of the hand. Give the
sphere a Radius of 1.8 units.

3. In the Name And Color rollout, click the color
swatch.

4. Change the color of the cue ball to white.

5. Turn on the Auto Key button.
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6. At frame 0, position the cue ball in front of the
hand. Use the Transform gizmo to move the
ball. Don’t move the ball in the Z axis.

Note: If you’re continuing from the previous
tutorial in the same session and have trouble
selecting the cue ball, try the following. On
the toolbar, change the Selection Filter from
Helpers to All.

7. Right-click the Time Tag slot and select 39 start
hold.

8. Reposition the cue ball in front of the hand
so you can add a keyframe at 39. Use the
Transform gizmo and move the ball in the X
axis.

9. Right-click the time slider. In the Create Key
dialog, do the following:

• Set Source Time to 39 (default)

• Set Destination Time to 43

• Turn off Rotation and Scale, and click OK.

You have just created position keys at frames
0, 39, and 43. You see squares representing
these keys in the line below the time slider.

Keys in track bar

Add more position keys:

1. Go to Frame 64 by right-clicking the Time Tag
slot and selecting the tag named 64 extreme
right. Reposition the cue ball to the right of
the hand.

2. Go to Frame 84 and reposition the cue ball to
the left of the hand.

3. You need to add a key between 0 and 39 to more
closely control the ball movement. Add a key at
frame 13 by moving the ball.
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Tip: Instead of dragging the Time Slider each
time you want to move to a different frame,
enter the frame number in the Keyframe
window.

4. Click Play Animation to play the
animation in the Camera viewport.

Depending on how you repositioned the ball,
you may see the ball passing in front of the arm
of the pool player who is trying to shoot the
ball. You now need to create a matte object to
maintain the illusion that the shooter’s arm is
in front of the ball.

The interpolation may cause your ball to
move in unexpected ways. In the case of
this animation, this could be a serendipitous
situation. If it looks bad however, right-click
the cue ball position keys and change the
interpolation to linear.

5. Turn off the Auto Key button.

6. Save your file as mymatch5.max.

Creating a Matte Object

The arm needs to pass in front of the cue ball to
make the cue ball look like it’s actually part of the
scene. To accomplish this, you draw and extrude a
matte object the same size as the arm in the video.
First, however, you need to position a grid aligned
with the Camera viewport, to act as a drawing
surface.

Set up the lesson:

1. Continue from the previous sequence, or
reset 3ds Max and open match6b.max. If you
open the provided file, reassign the viewport
background, if necessary.

2. Files for this tutorial are located in the
\tutorials\camera_map folder.

Set up a grid:

1. Go to Create panel > Helpers > Object Type
rollout and click the Grid button.

2. In the Front viewport, drag from upper-right to
lower-left to create a grid.

3. Activate Grid01 by using Views menu > Grids
> Activate Grid Object.

4. To align the grid to the Camera viewport, first
right-click the Camera Viewport to activate it
without losing the grid selection.

5. On the menu bar, Choose Views > Grids >
Align Grid To View.

The grid aligns to the camera view.

6. In the Top viewport, zoom out so you can see
the grid and the cue ball.

7. Move the grid along the Y axis so it is between
the camera icon and the cue ball.

Create a matte object for the arm:

In this procedure, you use the Line tool to create
a spline around the arm, and then an Extrude
modifier to make the shape a 3D object.

1. Advance to the last frame of the animation
(frame 84). The arm comes fully into view.

2. Right-click the Camera viewport to activate it,
if necessary.

3. Press ALT W key to maximize the Camera
viewport.
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4. On the Display panel choose Hide By Hit.

5. Click the ball in the viewport to hide the ball.

6. Go to Create panel > Shapes > Object Type
rollout and click the Line button.

7. In the Creation Method rollout, do the
following:

• Make sure Initial Type is set to Corner.

• Set Drag Type to Corner.

8. Starting in the upper left corner of the arm,
where the arm enters the frame, click to place
points around the outline of the arm, watch,
and cue stick.

• Take your time and draw in small
increments.

• Trace along the bottom of the frame and
around the left-hand corner.

• When you get close to the original point,
double-click to close the shape.

Drawing a matte object using a grid aligned to the
Camera viewport

9. On the Modify panel, open the Modifier List
and click Extrude to convert the 2D shape to
3D geometry.

This is the arm matte. It’s not necessary to
change the Amount setting.

10.Save your files as mymatch6.max, then
continue on to the next procedure.

Creating and Applying a
Matte/Shadow Material

In this lesson, you apply a matte/shadow material
to the matte object you just created. You then

animate the matte object to follow the arm in the
video.

When rendered, the matte/shadow material is
transparent, but blocks objects behind it. At the
end of this procedure, you see the arm move with
the cue ball behind it.

Set up the lesson:

• Continue from the previous lesson, Creating a
Matte Object (page 3–129).

Create and apply the material:

1. Open the Material Editor, and select the
third sample sphere.

2. Click the Type button, which reads Standard
by default.

The Material/Map browser is displayed.

3. In the Browse From group, select New.

4. Double-click Matte/Shadow in the list to apply
this material type to the sample slot.

The Type button now reads Matte/Shadow.

5. Rename the material matte arm.

6. Make sure the arm matte is selected, then
click Assign Material To Selection to apply the
material to the arm matte. When you’re done,
close the Material Editor.

7. Right-click in the active viewport and, in the
quad menu > Display quadrant, choose Unhide
All to unhide the cue ball.

Render the arm to check the matte object:

1. Go to frame 80 and move the cue ball behind
the arm matte.
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2. On the toolbar, click Render Scene, or
from the Rendering menu choose Render.

3. In the Render Scene dialog, do the following:

• Under Time Output, choose Single.

• Under Output Size, choose 320 x 240.

• Turn off Save File if it’s on.

• Click Render to render the image.

The arm now appears to be in front of the
cue ball.

The sphere is behind the matte object

Keyframe the matte object:

In this procedure, you’ll keyframe the matte object
so it moves as the arm moves when you play the
video.

1. Go to the first frame of the animation
and turn on the Auto Key button.

2. Right-click the Camera02 viewport label and
select Wireframe.

3. On the toolbar, under Reference Coordinate
system, choose Grid.

Now any movement of the matte object will
take place aligned to the grid.

4. Move the wireframe outline of the matte arm
object to match the background. Position the
wireframe outline so that the knuckles are
covered up. The rest of it probably won’t matter.

If the transform gizmo is off screen, lock the
selection and choose restrict to X or Y in the
main toolbar to move the arm. Remember you
only really care about the frames in which the
ball passes behind the knuckles of the hand.

5. Go to the last frame of the animation (84).
Move the arm wireframe to the correct location.

6. Slowly move backward through the frames
by clicking the left arrow of the time slider.
Every time the hand and arm move out of sync,
reposition the geometry to align with the video
of the arm.

7. Using the > key on the keyboard, advance the
time slider frame by frame. When you see the
hand reposition itself, move the matte object
so it covers the hand.

This is tedious, and is reminiscent of how all
animation used to be created. If you create a
key on every frame, your interpolation won’t
matter.

8. When you’re done, press ALT W to minimize
the Camera viewport.

9. Turn off the Auto Key button.

10. Click Play Animation.

The animation plays in the Camera viewport.
The matte object moves with the hand and pool
cue.

If the arm changes shape, you could also
animate the vertices on the matte object. You
might notice that the cue stick is visible sticking
out of the hand at frame 0, but then disappears
from sight by around frame 54. If you’re a
perfectionist, you’ll want to have extra vertices
for the cue stick and animate those vertices to
change the shape of the matte object.
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Save your work:

• Save your scene as mymatch7.max.

It’s always a good practice to save the scene file
after completing a labor-intensive procedure,
such as setting keys frame by frame. In any
long session, save frequently (CTRL+S) or use
Auto Backup.

You can render to an AVI file if you like, or
continue learning and render later. Or you can
play matte3e.avi to see the results.

In matte3e.avi the cue ball is casting a shadow on
the pool table. In the next lesson, you’ll create a
box that will be capable of receiving the shadows.

The shadow is created using a spotlight that follows
the cue ball’s movement. The spotlight has a
negative multiplier to create a dark spot, and the
ball is excluded from the spotlight.

You won’t go through the exercise of setting up the
spotlight. For information on how to work with
lights, see Introduction to Lighting (page 1–409).

Creating the Pool Table Surface

In the next two lessons, you’ll use Camera Map
to create mapping coordinates aligned to the
camera’s view. This will enable you to paste video
onto objects regardless of their orientations. You’ll
create a box to serve as the pool table surface, then
map the video to the surface of the box. Finally,
using an Affect Region Modifier to smoothly pull
the geometry of the box, you’ll animate the surface
so it rises up and follows the motions of the pool
player at the far end of the table.

In this lesson, you’ll create a box to serve as the
pool table surface, and then map the video to the
surface of the box.

Set up the lesson:

• Continue from the previous lesson, or reset
3ds Max and open match8.max.

Files for this tutorial are in the
\tutorials\camera_map folder.

Create a box for the surface:

If you’re continuing from the previous lesson,
begin with step 1. Otherwise, begin with step 2.

1. Choose Views menu > Grids > Activate Home
Grid.

Now if you create something, it will use the
home grid, which happens to coincide with the
surface of the pool table.

Note: You might also want to turn off home grid
display (Views menu > Grids > Show Home
Grid) in the Camera02 viewport, as this makes
the display more cluttered and obscures the
viewport background.

2. Go to Display panel > Hide By Category
rollout. Click Helpers to hide all helper objects,
including the grid.

3. Go to Create panel > Geometry > Standard
Primitives > Object Type rollout and click the
Box button.

4. In the Camera viewport, starting at the far
left-corner pocket, drag diagonally in the
direction of the right corner pocket to create a
box. Cover about ¾ of the table with the box.

5. On the Parameters rollout, give the box a
negative height of approximately -1.

6. Use Select And Rotate to rotate the box slightly
around the Z axis, so the perspective is correct.
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7. Rotate the box until the right side of the box
matches the angle of the bumpers.

8. Select Sphere01 and go to Modify panel >
Parameters rollout. Turn on Base To Pivot.

9. Select the box.

10.Right-click the box and choose Move.

11.Use the Transform gizmo to move the surface
along the XY axes until you have a best fit. The
fit does not have to be perfect.

12.On the Modify panel, rename the box pool
table surface.

Color the pool table surface:

1. Open the Material Editor and select any
available material sample slot

2. Replace the default material name (e.g., 7 -
Default) with pool table surface color.

3. In the scene, make sure that the box of the pool
table surface is selected.

4. In the Material Editor, click the Assign
Material To Selection button.

5. Press F3 to turn on Smooth + Highlights
shading mode.

6. Right-click the viewport label and choose
Configure.

7. In Rendering Options, turn on Default Lighting
and 2 Lights.

Using 2 default lights will give you a well lit view
to work with.

The Box appears to be in the perspective of the scene

Save your work:

• Save your scene as mymatch8.max.

Animating with Camera Map

In this procedure, you create and then animate a
bulge in the pool table surface. The objective is
to make the bulge look as through it’s controlled
by the pool player at the far end of the table. You
do this by applying an Object-Space Camera Map
modifier, and then an Affect Region modifier.

Before you begin, you should understand the two
kinds of Camera Map modifiers.

Understanding Camera Map modifiers

Camera mapping lets you create mapping
coordinates aligned to a camera’s view, so you
can paste video onto objects regardless of their
orientation. There are two versions of the Camera
Map modifier. One is an object-space modifier
(OSM), the other is a world-space modifier
(WSM).

The WSM modifier continually updates the
mapping coordinates according to the movement
of the camera.

The OSM modifier is "sticky," because it doesn’t
update with camera movement. It lets you distort
geometry from frame to frame. You’ll use this
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version for animating the bulge in the surface of
the table.

When animation is involved, you should not use
a matte/shadow material. Because it pastes the
background onto every frame, a matte/shadow
material doesn’t let you distort or animate the
surface, making any effects you create invisible.
Instead of using a matte/shadow material, you’ll
use a diffuse map.

Set up the lesson:

Files for this tutorial are located in the
\tutorials\camera_map folder.

• Choose File > Reset and open match9.max.
Reassign the viewport background as you did
earlier in the tutorial.

The pool table surface is displayed with the
default mapping coordinates.

Apply a material to the pool table surface:

1. Open the Material Editor by pressing M.

2. In the second slot of the first row, select
pooltable material.

This material uses matte3e.avi as a diffuse map.
This file has the animation of the pool ball
already rendered. This way you can concentrate
on animating the bulge.

3. Drag the material to the pool table surface in
the viewport. A tooltip will tell you when you’re
on the right object.

4. If the pool table doesn’t show up in the
viewport, go to the Material Editor and click
the Show Map In Viewport button.

This version of the pool table appears out of
alignment on the surface. We can fix the display
of the matte3e.avi texture on the pool table
surface with the Object Space Camera Map
modifier.

5. Close the Material Editor.

Apply a Camera Map modifier:

1. Press H to display the Select Objects dialog.
Highlight pool table surface in the list, then
click Select.

2. Go to the Modify panel.

3. Change the Length and Width Segs (segments)
of the pool table surface to 33.

Tip: To view the increased segmentation of
the pool table surface, press F3 to toggle the
viewport to wireframe mode.

4. On the Modify panel, open the Modifier List.

5. Under Object–Space Modifiers, choose Camera
Map.

Warning: Do not choose Camera Map (WSM). That

modifier is a world-space modifier, which is not used

in this tutorial.

6. On the Camera Mapping rollout, click the
Pick Camera button. Press H again to pick
Camera02.

The viewport display corrects itself.

Camera Map modifier perfectly aligns the mapping
coordinate

Apply an Affect Region modifier:

The pool table surface should still be selected.

1. On the modifier stack display, make sure the
Camera Map modifier is selected in the stack
list.
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If you ignore this, you’ll be placing the Affect
Region modifier before the Camera Map and
the effect won’t work.

2. On the Modify panel, open the Modifier List.

3. Under Object-Space Modifiers, select Affect
Region.

A large bulge appears in the center of the pool
table.

Preview the result:

The result of this workflow is a short video clip.
Look at a finished version first so you can see the
intended effect.

• Choose Files > View Image Files and play the
animation cammap.avi.

Animate the mound:

The following procedure uses frames identified
earlier in the background video.

1. In the Affect Region Parameters, change the
Falloff to 10 instead of the default value of 20.

2. In the modifier stack display, click the + button
to display the Points sub-object level (the only
sub-object selection level in the Affect Region
modifier). Click the Points level to highlight it.

3. Zoom in to the Front viewport.

In the Front viewport, notice that there are two
points, one at the top and one at the bottom of
the mound.

4. Move the time slider to frame 13 and
turn on the Auto Key button.

5. In the Front viewport, select both points and
move them slightly to the right. Move the
top point down to more closely match the
animation you just viewed.

This adds an animation key to both points at
frame 13.

6. Go to frame 39 and move both points a short
distance to the right.

7. Go to frame 43 and move the top point to the
left to create some secondary movement. Move
the bottom point slightly to add a key.

8. Go to frame 64 and move both points to the
extreme left.

9. Go to frame 84. Select the top point and move
it down to the surface of the table.

The bulge flattens into the table.

10.Go to frame 0 and flatten the mound there, too.

Tip: There’s a reason for going frame 0 last.
If you began at frame 0 and moved the top
point to 0, the two points would be coincident,
making them hard to work with on later frames.

11. Turn off the Auto Key button.
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12.If you get unexpected results, adjust the
interpolation on the position keyframes to
linear.

That’s it. All that remains is to save your work and
render.

Save your work:

• Save your file as mymatch9.max and render to
an AVI file. Compare it with cammap.avi.

Summary

In this tutorial, you have learned to create camera
effects. You have learned to use camera matching
to synchronize real-world footage with your
virtual shot. You have used matte shadow materials
to cast shadows onto the background footage, and
have used the Camera Map modifier to create the
illusion of an animated bulge in the pool table.

The Camera Tracker utility lets you animate
the movement of a scene camera to match the
movement of the real camera that was used
to shoot a background movie or video. Once
the 3ds Max camera is correctly matched, you
can render animated, matched footage of your
computer-modeled scene combined in perspective
with the background video.

This tutorial shows you in detail how to use the
Camera Tracker to track some background video
and animate a camera so it matches the footage.

Tutorial Files

The files for this tutorial are on the Tutorial Files
CD in the \tutorials\camera_tracker folder.

Warning: This particular tutorial requires that you work

from the hard drive, not directly from the CD. Make a

folder with the same name on your hard drive, and then

copy the files there from the CD.

Time to complete: 1 hour

How Camera Tracking Works

Camera Tracker works by tracking a selected set of
features in the movie. The features can be markers
that you place in your movie during filming or any
point of contrast with a distinct position, such as
the corner of a window or the top of a pole. The
feature needs to stay visible within the range of
frames to be tracked, and should not drastically
change color or shape.

A critical, preparatory step is making accurate,
real-world measurements of the positions of these
features from some zero point in the filmed scene.
You use these measurements to create CamPoints
(camera point helpers) in the your 3ds Max scene.
You place these CamPoints at the 3D positions of
the tracking features and assign tracker gizmos
to them. Camera Tracker uses the combined
information to track the camera from frame to
frame.

Workflow for Camera Tracker

Here are the general steps followed in this tutorial.
You can use them as a checklist for your own work
with Camera Tracker.

1. Make accurate measurements of tracking
features in the filmed scene. These
measurements are supplied for this tutorial.
See Preparing the Scene (page 3–115) in the
Using Camera Match (page 3–114) tutorial for
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practical advice on taking these measurements
for your own projects.

The camera-matching algorithm requires
at least six features to be visible at any one
time, and of those, at least two must be out of
the plane of the others. The features should
be spread throughout the scene as much as
possible. If all the features are too close together,
the match accuracy will be diminished.

2. Load the movie as a viewport background and
a rendering background.

3. Position CamPoint helper objects in the
3ds Max scene. These correspond to the
real-world positions of features to be tracked
in the movie.

4. Load the movie to be tracked with Camera
Tracker. Set up feature tracking by placing
motion tracker gizmos on each of the features to
be tracked. Set feature visibility frame ranges.

5. Perform movie-feature tracking with Camera
Tracker. This generates a set of data for the
position of each feature in the image over all
the frames tracked.

6. Review the tracking to make sure Camera
Tracker has correctly tracked all the features.

Camera Tracker provides several tools for
reviewing, tracking, and fixing any problems
that occur. For example, if a feature changes
shape substantially over the tracking frames,
Camera Tracker may not be able to follow it
completely. You can make manual corrections
to the tracking at any frame, and then have
Camera Tracker complete the tracking.

7. Perform a match move with the Camera
Tracker when you get a good set of tracking
data. You set this up by selecting the camera
to be animated, then choosing the parameters
of the camera to be estimated, the range of
movie frames to match, and the range of

animation frames where you want to place
camera animation keyframes.

8. Review the match move by generating a preview
animation, or by inspecting the camera’s Track
View curves.

In some cases, depending on the accuracy of
your field measurements, the movie resolution,
the accuracy of the feature tracking, and other
factors, the generated camera animation may be
“noisy.” You can use tools on the Camera Move
Smoothing rollout to filter selected camera
parameters to achieve smoother match moves.

Loading the Background Movie

To begin this lesson, you create an Image File List
file, table.ifl, in order to use a sequence of still
images as a movie. Then you will use the IFL file
as both a rendering environment and viewport
background. You’ll skip the steps of shooting the
footage and taking the measurements, instead
you’ll use images and measurements provided for
you.

Camera Tracker works with any movie file format
that 3ds Max supports. You’ll use an IFL file here.
IFL files are ASCII text files that contain a list of
sequential still image files.

You can generate an IFL file automatically using
the Sequence button of the file selector. Or you
can use the IFL Manager utility, to create an IFL
file. For this example, you’ll create an IFL file using
242 JPEG files originally recorded on a hand-held
camcorder, captured at 640x427 resolution.

Set up the lesson:

1. Start a new session of 3ds Max. If you are
running the program, choose File > Reset.

2. Choose File > View Image File and navigate to
\tutorials\camera_tracker\rinodesk.avi on your
hard drive.
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3. Play rinodesk.avi.

This is an animation of a rhino tossing his
head, using camera-matched footage. This is
where you will end up when you’ve finished
this tutorial.

Use the RAM Player to generate an IFL:

You can use the RAM Player to generate an IFL file
and play the background video at full resolution.

1. Choose Rendering > RAM Player.

2. Click Open Channel A on the
RAM Player toolbar.

3. In the Open File, Channel A dialog, choose
tabl0000.jpg.

This file selector dialog lets you generate an IFL
file if you use the Sequence button.

4. Turn on Sequence, to the right of the View
button, then click Open.

The Image File List Control dialog is displayed.
Here, you can define the target path and name
for the IFL file.

Warning: Because this IFL file is about to be created,

don’t select a CD ROM drive

.

5. Name the IFL file table.ifl . Turn on Include
Image Path and click OK.

After generating the IFL file, the RAM Player
Configuration dialog is displayed. Here you can
limit the amount of memory the RAM Player
will use.

6. In the Memory Usage group, check the
Maximum memory setting (you can increase
this if you know you have lots of memory), then
click OK.

The RAM Player loads the sequence of still
images into memory.

7. Watch the Available Memory value. Click Stop
Loading if you don’t have enough memory.

8. Click Play on the RAM Player toolbar to
play the sequence of still images from memory.

The background sequence should play
smoothly.

9. Clear the sequence from memory by
clicking Close Channel A.

10.Close the RAM Player.

Next, you will define the IFL file as a rendering
background.

Render the background:

1. On the menu bar, choose Rendering >
Environment.

2. Under Environment Map, click the gray button
marked None.

The Material/Map Browser is displayed.

3. Choose Bitmap, and then click OK.

The Select Bitmap Image File appears.

4. Change the Files of type field to IFL Image File
List.

5. Navigate to the directory where you created
table.ifl, choose it, and then click Open.

The Environment Map now displays Map #1
(table.ifl). Use Map has been automatically
turned on.

6. Close the Environment and Effects dialog and
activate the Perspective viewport.

7. Choose Rendering > Render.

8. In the Render Scene dialog, in the Output Size
group, adjust the Height to 427.

This is the resolution of the background video
sequence. You can leave the default Width set
to 640.

9. Render a single frame to ensure the background
video is being rendered correctly.
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10.Close the rendered image window.

Add the background to a viewport:

Now you load the movie into the background of
the Perspective viewport, so you can see it as you
work. It’s not strictly necessary to do this, but it
can help later when you check the generated match
move.

1. Close any dialogs that are open. The Perspective
viewport should still be active.

2. From the Views menu, choose Viewport
Background.

3. On the Viewport Background dialog, do the
following, beginning from the top of the dialog:

• Turn on Use Environment Background.
(Most options become unavailable.)

• Turn on Display Background.

• Make sure that Viewport shows Perspective.

• Click OK.

The first frame of the movie is displayed in
the background of the Perspective viewport,
along with the home grid.

The home grid is distracting and can be
turned off.

4. In the Perspective viewport, press G to turn off
Show Grid.

There is one more problem to correct. The IFL
file is 243 frames long, but the animation length
is only 100 frames right now.

5. Click Time Configuration.

The Time Configuration dialog appears.

6. Set the Animation End time to 242 and close
the dialog.

Since the first frame is 0 and the last frame is
242, that creates 243 frames of animation.

7. Scrub the time slider and watch the viewport
background update.

8. Return to frame 0.

About the movie

The first frame of the movie shows a tabletop with
two markers standing on end. There are also four
small red stickers on the surface of the wood. The
tops and bottoms of these markers and the red
stickers will serve as tracking features. You’ll use
the four small red marks, plus the ends of the
markers to serve as locations for CamPoints.

The camera-matching algorithm requires at least
six features to be visible at any one time, and of
those, at least two must be out of the plane of
the others. If a point moves out of frame, it can
no longer be tracked until it returns into view,
and then an additional tracker gizmo will need to
be created with a new range assignment. In this
example, the points remain visible throughout the
tracking, so you won’t have to set the ranges.

Creating Camera Match Points

In this lesson, the goal is to place the camera points
helper objects (called CamPoints) in the 3ds Max
scene at positions corresponding to the movie
positions of the four red stickers on the tabletop
and the tops and bottoms of the markers standing
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on end. We supply measurements for you to work
with.

Make the CamPoints:

Each CamPoint can be created, positioned, and
named one at a time. However, an alternate
method, used here, is to make all the CamPoints
first (a total of eight, all at 0,0,0), then select each
one, rename it, and reposition it.

1. On the Create>Helper object panel choose
CameraMatch from the drop-down list

2. On the Object Type rollout, click CamPoint

The CamPoint button highlights in the Create
panel.

3. Click the Keyboard Entry rollout to open it.

The default entry is 0,0,0.

4. Click the Create button at the bottom of the
rollout.

A point object appears in the middle of the
viewports. On the Name And Color rollout,
you see its name listed as CamPoint01.

5. Click the Create button seven more times to
complete the series from CamPoint01 through
CamPoint08.

All the CamPoints are on top of each other.
This is what you want. Next, you’ll reposition
the points.

Rename and reposition the CamPoints:

Here you use the keyboard shortcut H to select
each CamPoint object. You then rename it and
use Select and Move with the Type-in Transform
dialog to reposition it.

1. Choose Customize > Units Setup.

2. Turn on US Standard, and select Feet w/
Fractional Inches from the list, then close the
dialog.

This file was created in the United States, and
the measurements are in feet and inches.

3. On the toolbar, click Select And Move.
When it highlights, right-click Select And Move
to display the Transform Type-In dialog. .

There are two columns of XYZ values. For
CamPoints, you only want to enter values on
the left side, under Absolute:World.

The Transform Type-In dialog is invaluable for
entering exact locations. Many modelers use it
continuously in their work. You can also type
in transform values in the coordinate display
fields below the viewports.

4. Click outside of the Transform Type-In dialog,
and then press H to display the Select Objects
dialog. In the list, double-click CamPoint01 to
select it.

5. On the Name And Color rollout, change the
name of CamPoint01 to 1 Left Front.

In the following table, 1 Left Front is supposed
to be the zero point (0,0,0). This position is the
default in the Transform Type-In dialog, so this
first point is already, located where it should be.

Here is a table with the XYZ positions of the
CamPoints. The CamPoints are set one each
at the bottoms of the six markers, and two
CamPoints are set at the tops.

Point Number X Y Z

1 Left
Front

1 0” 0” 0

2 Left
Middle

2 0 0’6” 0

3 Left
Back

3 0 1’4” 0

4 Left Up 4 2/8” 1’4” 0’5 3/8”

5 Right
Front

5 1’1 6/8” -1/8” 0

6 Right
Middle

6 1’1 4/8” 0’6” 0
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Point Number X Y Z

7 Right
Back

7 1’1 2/8” 1’4” 0

8 Right
Up

8 1’1 4/8” 1’4 2/8” 0’4 6/8”

6. Click outside of the Transform Type-In dialog.

7. Press H. Select CamPoint02.

8. Rename this point 2 Left Middle.

9. On the Transform Type-In dialog, under
Absolute:World, enter the X, Y, and Z values for
this point (listed in the table as 0, 0’6”, 0). Press
TAB to move between fields. Use a hyphen for
a minus sign. When you’ve entered the values,
click outside the dialog.

The point moves to the location you’ve entered
and becomes deselected. This is how you can
create and position all the CamPoints in the
scene.

Since this is tedious and time consuming task,
you’ll delete these points and merge in the
correct CamPoints from a prepared MAX file.

Merge in the correct CamPoints:

1. Select the points you’ve created and delete
them.

2. Choose File > Merge. Open merge_points.max.

3. On the Merge dialog, click All to select the eight
points.

4. Click OK.

The new set of points appears in the viewports,
all selected.

5. Arc rotate the Perspective viewport, so you
can see the points. Zoom in so the points are
distinct.

CamPoints in the viewport

If you review the position of the points you will
discover the Left Front point is in fact 1/8,
-1/8, 0 slightly off from 0,0,0. Don’t worry, this
is how it should be. Careful measurements of
the scene revealed this error, so the correction
was required.

Save your work:

• Choose File > Save As. Save your work to this
point as mycamtrack1.max.

Loading the Movie into Camera
Tracker

In this step, you load the background movie into
the Camera Tracker utility. You then create and
set up a motion tracker for each of the features
in the movie. This establishes the connection
between the feature in the background movie and
the associated CamPoint you placed in 3D space
to correspond to that marker’s position in the real
world.

Load the movie:

1. On the Utilities panel, click More.
Choose Camera Tracker from the list (choose
More), and then click OK.
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2. On the Movie rollout, click the Movie File
button labeled None.

3. In the Browse Images for Input dialog, select
table.ifl, and then click Open.

The first frame of the movie appears in a
separate movie window.

Note: The movie window displays the IFL file at
a resolution of 640 x 427. In your own projects,
you’re likely to use Camera Tracker at video
resolution (720 x 486 for NTSC, larger for
PAL). In this tutorial, you use a slightly lower
resolution for faster performance.

Fade the screen:

Tip: You’ll definitely want to keep the screen faded
when you’re working with trackers.

• On the Movie rollout, turn on Fade Display.

The background is lightened but still visible.
This will make the tracker gizmos easy to see
when you add them.

Set up a motion tracker:

1. On the Motion Trackers rollout, click the New
Tracker button.

A new tracker gizmo appears at the center of
the movie window and in the Tracker list.

2. In the movie window, drag the Tracker gizmo
over the left-front red sticker.

3. On the Motion Trackers rollout, in the Tracker
Setup group, click the button below Scene
Object.

This activates object selection mode.

4. Press H and choose the CamPoint named 1 Left
Front. Choose Pick.

In the Motion Trackers list, the tracker gizmo,
now named 1 Left Front, is associated with the
CamPoint of the same name.

Work in the movie window:

• When working in the movie window in the
next procedure, select the gizmo, then use
the following keyboard shortcuts to produce
zooms centered on the selected tracker gizmo.

• Press I repeatedly to zoom in.

• Press O repeatedly to zoom out.

• Press R to reset the zoom level to 100%.

Adjust the position of the motion trackers:

The accuracy of a match move (the alignment of
a 3ds Max camera with the background scene
at each frame) is determined, in part, by the
accuracy of feature tracking. Camera Tracker
provides controls for subpixel motion tracking,
allowing you to position tracker gizmos very
accurately against the feature markers in the
background movie. This can improve a match
move substantially.

When subpixel tracking is enabled, a tracker
gizmo can be positioned within a single pixel. You
need to zoom in sufficiently so that you can see
the slight changes in position corresponding to the
subpixel tracking level you set.

1. On the Motion Trackers rollout, set Subpixel
Tracking to 1/4.

2. In the movie window, the tracker gizmo you
just created should be roughly centered over
the front left red sticker. Zoom in repeatedly
by pressing I.

3. Reposition the gizmo so it is centered over the
feature.
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The center of the gizmo snaps to the increment
of subpixel tracking. With a setting of 1/4 of a
pixel, these are very small motions.

A tracker gizmo is made up of two boxes and a
cross hair. The inner box is called the feature
bounds box. This defines the feature to be
tracked frame-to-frame by Camera Tracker.

4. Drag the corners of the feature bounds box of
the tracker gizmo until the box encompasses
the red sticker and a small border of tabletop.

5. Press O repeatedly to zoom out to see the outer
box.

The outer box of the Tracker gizmo is called
the motion search bounds box. The size of
this box determines the frame-to-frame search
area for that feature within the movie. Because
the motion search box moves with the feature
bounds box, it defines a relative search area on
each frame.

• Adjust the motion search bounds box to at
least twice the size of the inner box.

Tip: The bigger the motion search bounds
box, the slower the tracking operation.
However, if this box is too small, the feature
might jump outside this box in one or
more frames, causing an error. If you have
extreme patience, you can review the movie
watching each camera point’s movement,
looking for large frame to frame jumps. If
you find these, you can actually animate the
size of the motion search bounds box on
those frames. As a general practice, it’s more
practical to keep the box on the large side.

Save tracker information:

Motion tracking data, such as the position and
size of the tracking gizmos, is saved in a separate
MOT file, not the MAX scene file. When you load
the movie file in the Camera Tracker and there
is a MOT file of the same name as the movie file
in the same directory, it will load automatically.
Otherwise, you will have to load the MOT file
manually.

After you position the first gizmo, start a MOT file
for this data.

• On the Movie rollout, click Save As. In
the Camtracker File dialog, name the file
mycamtrack.mot and save it to disk.
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Assign and size the other tracker gizmos:

• Repeat this process for the other trackers,
setting up each motion tracker, adjusting its
position, associating with a CamPoint in the
scene and saving the tracker information.

As a practical matter, you can create the tracker
gizmos first, associating each with a CamPoint,
then do a separate pass to adjust the gizmo
boxes. This illustration shows the final size and
placement of tracker gizmos.

Make a final check:

After you finished setting up the motion trackers,
do a final check.

1. Zoom in on one tracker so you can see both its
boxes. Then press TAB to jump from tracker
to tracker. You’ll quickly find out if there any
boxes you forgot to resize.

2. Be sure to save a final version of
mycamtrack.mot.

3. Save the scene file as mycamtrack02.max.

Set Motion Tracker Ranges:

The next step in the process of camera tracking is
to set the ranges for the trackers. In this example all
the trackers stay in view for the entire animation,
so there is no need to change the ranges for any
of them.

When you do your own project you may find
trackers that disappear from view. Here are the
steps you need to follow to set the tracker ranges

1. Review the sequence using the RAM Player, or
by rendering and playing an AVI file.

Carefully examine the file for trackers that
disappear from view. Jot down the frame
number where they disappear.

2. On the Motion Trackers rollout, click None to
turn off all the trackers.

3. Select the tracker that disappears, and click On
to enable this one tracker.

4. Open the Movie Stepper rollout. Set the Movie
Frame field to the last frame number in which
the tracker is visible.

5. On the Motion Tracker rollout, in the Tracker
Setup group, click Set Stop.

In the Motion Tracker list, the tracker now has
a range set correctly.

6. If a feature disappears and reappears, create
an additional tracker gizmo and assign it to
the feature with a new range, starting when the
feature reappears in the scene. Thus, there will
be two tracker gizmos with different ranges
associated with the one feature.

Tracking the Features

In this step, you use Movie Stepper controls, much
like VCR buttons, to track the features individually.

Track the first feature:

1. On the Motion Trackers rollout, click None to
turn off all the motion tracker gizmos.

2. Highlight the second motion tracker in the list,
and then click On.

We chose the second tracker to start because the
first tracker changes color around frame 200.
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3. On the Movie Stepper rollout, click the Feature
Tracking Off button.

The Off button turns bright red and switches
its name to On. Feature tracking is now
operational.

4. Click the button marked >10 to advance the
movie 10 frames, one frame at a time.

The selected tracker follows its feature in the
movie. A red trail line is gradually displayed
showing the movement of the feature in the
movie.

5. Track the feature 10 frames at a time. Or you
can click the button marked >> to track all the
way to the end at once.

If you do 10 frames at a time, you can see if
errors occur as the Tracker progresses.

The movie window may become hidden during
the tracking and then redisplay. If you track a
single frame at a time, it should stay visible.

When you finish tracking the feature, it’s time
to check for errors.

Check status:

1. Open the Batch Track rollout.

2. In the Tracking Status group, click Check
Status.

An error detector identifies possible instances
of incorrect tracking, and also reports any
features that have not been completely tracked.

Potential errors are listed in the Tracking Error
Review window. The list displays the tracker
number that failed, the frame number in which
the error occurs, and the type of error.

An error with the code “jd” represents a
jump delta error. This means that the camera
has moved a greater distance than the jump
threshold allows. You probably have errors
displayed with this code.

Fix tracking errors:

1. In the Error Thresholds rollout, increase the
Jump Delta to 10.

2. If there is an error, in the Tracking error review
window, highlight the error and then click
Clear.

The error disappears from the list.

3. In the Movie Stepper, go to the frame the error
occurred.

The movie advances to that frame, centering
the tracker gizmo in the movie window.

4. Zoom in on the tracker using the I key. Adjust
the gizmo to position it properly over the red
sticker.

The keyframe is automatically revised for the
tracker.

5. In the Movie Stepper rollout, click Clear
Tracking To End.

6. Repeat the tracking from that frame to the
end using the >> button in the Movie Stepper
rollout.

Note: If you move or resize the tracker gizmo at
any frame, you set a keyframe for the change in
the gizmo itself. This keyframe is indicated as a
green box on the trail of the tracker gizmo.
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Recheck status:

• On the Batch Track rollout, click Check Status.

There should be no errors for tracker number
2. The others are listed as incomplete.

There are two ways to proceed.

• You can select the next tracker and repeat the
process tracking each tracker individually.
This is time-consuming, but lets you watch
what is happening, and spot any problems
as they occur.

• You can track all the remaining trackers
using Batch Tracking > Complete Tracking.
If sufficient errors are encountered, however,
the tracking halts, and you must correct the
problems for each tracker individually.

• We also provide a finished MOT file if you
don’t want to do all the tracking yourself at
this time.

If you get a tracker with many errors, you
should track it one frame at a time, allowing
the tracker to remain visible in the movie
window. If you see it is off, you can simply
move it into place to correct it. This is
tedious, but effective.

Camera errors are based on the Error
Threshold settings. You can also reduce
errors by raising these settings. If there
is extreme camera movement you should
increase the Jump Delta threshold, which
will eliminate errors preceded with a jd code.
For this example the Jump Delta works best
at about 9.5.

The other error threshold settings, Match
Error and Variance Delta flag frames in
which the shape or the color of the feature
changes. If you find “me” and “vd” errors,
go to those frames and manually reposition
the tracker gizmo, then click Clear Tracking
To End and track again.

Clear and start over:

1. If you want clear all trackers and start over,
open the Position Data rollout.

2. In the Apply To group, turn on All, and then
click Clear All.

Save your work:

Once you have feature tracking completed,
you should save the tracker setup and the
feature-tracking data.

• On the Movie rollout, click the Save button.

This saves your current MOT file, for example,
mycamtrack.mot.

If you’re starting fresh, clicking Save creates a
file in the same directory as the movie file being
tracked. The file is the name of the movie with
the extension MOT.

Load a correctly tracked file:

Rather than spending your time slowly tracking
all eight trackers in this scene, you can load a
completed MOT file, table_correct.mot.

1. On the Movie rollout, click Load.

2. In the dialog that appears, answer Yes to save
the tracker state.

3. On the Camtracker File dialog that appears,
select table_correct.mot.

Match Moving the Camera

Once you’ve completed feature tracking and
reviewed the tracking for errors, you’re ready to
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match the movement of the real camera. This is
the payoff for the Camera Tracking feature: the
animated camera that results should match the
movements of the real camera that shot the movie.

Create the matching camera:

1. Create a Free Camera in any viewport. Name it
something distinctive such as matchcam.

2. In the Camera Tracker, scroll down and open
the Match Move rollout.

3. Click the button at the top of the Match Move
rollout in the Camera group.

4. Press H and select the camera you just created.

5. At the bottom of the Match Move rollout, click
the Match Move button to animate the camera.

If everything goes well, the camera tracking is
now complete. The match-move camera has
been keyframed to follow the movements of the
original movie camera.

Frequently you will experience problems at this
point. If you have a problem at the initial frame
of the animation, you should use the Camera
Match utility to create a camera. This will allow
you to verify that your CamPoints positions
are correct to begin with. If the Camera Match
utility cannot create the camera, you know
you’ve made a mistake either in positioning the
CamPoints or in your initial measurements.

If you experience a problem after the initial
frame, the problem is not with the CamPoint
positioning, but with the tracking. In some
cases, the tracking needs manual correction at a
particular frame because the appearance of the
feature in the video has changed. In other cases
errors are induced because there the trackers in
the scene are not spread out enough to give a
good match.

Check the results:

• To see the effect of camera tracking, change
the Perspective viewport to a Camera viewport
assigned to the matched camera. Then advance
through the frames by scrubbing the time slider
or playing the animation.

Limit the match:

• Match options are on the Match Move rollout,
in the Match group. By default, all options are
turned on, but you don’t necessarily need them
all. For example, if the camera was always on a
tripod and only panned, you could try turning
off everything in the Match group but the Pan
option. Limiting options should help to reduce
errors in the camera match.

Move Smoothing and Compositing

Match move estimates the correct camera motion
based on feature tracking and field measurements.
Errors in these factors can sometimes cause errors
or noise in the generated match move. Under
certain conditions, you can use move smoothing
to reduce the noise.

For example, if your real camera moved smoothly,
or was fixed in one location, you can use controls
on the Move Smoothing rollout to clean up the
generated match move. In the video used in this
tutorial, the camera was hand-held, so the motion
is inherently noisy and would not improve with
smoothing. But the lens was zoomed smoothly in
and out, so you can smooth Field-of-View.

When a particular camera parameter is smoothed,
Camera Tracker can make a further, compensating
match-move pass that re-estimates all the other
parameters using the smoothed parameter. This
often results in a better overall match. In the case
of a camera on a tripod making a pan, for example,
you could have the Camera Tracker estimate all
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the camera motions and then smooth the results
to better match the real camera moves.

Use move smoothing:

1. Open the Move Smoothing rollout.

2. In the Channel To Smooth group, turn on FOV.

3. On the Smooth Type rollout, turn on Low Pass
Filter and Re-match After Smooth.

4. At the bottom of the rollout, turn on Smooth.

The tracker first smooths the FOV, and then
rematches the position and rotation moves of
the camera.

Composite:

You are now ready to composite 3D models into
the filmed scene.

1. On the File menu, choose Merge, and then
deskrino.max.

2. From the Merge list, choose RINIRHINO3.

The rhino appears in the scene. You can rotate,
scale, or move the rhino on the table top as you
like.

If you had any trouble getting the camera to
match, you can also merge in the animated
Camera, named Camera01 matched.

If you want the rhino to cast shadows on the
tabletop, or reflect in the tabletop, merge in

the lights found in deskrino.max. Or you can
create your own.

3. Change the Perspective viewport to the
matched camera, if you haven’t already.

4. Scrub the time slider and see the match.

5. If you like, you can render the animation, or
play back rinodesk.avi to see the finished result.

Summary

In this tutorial, you have learned to use the Camera
Tracker to match the movement of the virtual
camera to real-world footage. You have learned to
create camera match points and track the movie,
then make corrections and use move smoothing.
Finally you have composited the tracked shot with
3D geometry using the Merge command and then
rendering your animation.
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using a shader as a map 2–846
water surface shader 2–871
wraparound shader 2–849

mental ray connection rollout 2–856
mental ray material

mental ray 2–863
mental ray materials 2–862
mental ray renderer

area lights 2–838
depth of field (DOF) 2–822
final gathering 2–835
global illumination 2–835
motion blur 2–818
reflections 2–810
reflective caustics 2–826
refraction 2–814
refractive caustics 2–831
sampling 2–806
trace depth 2–810

mental ray shaders 2–867, 2–871

merging content into a scene 2–272
merging files 3–111
mesh select modifier 1–108, 1–110
metal shader 1–119
mirror

skin settings 2–426
mirroring 1–102, 2–335
modeling

a bishop 1–29
a chess set 1–21, 1–29
a pawn 1–21
a rook 1–31
airplane 1–46
align 1–255
bones 2–361, 2–377, 2–379
dummy object 1–255
ear 1–101
editable poly 2–199
eye 1–98
facial expression 2–481
head 1–92 to 1–93, 1–97, 1–102, 1–105
improvements 1–78
level design 2–264
move/rotate/scale 1–255
planets 3–29
space scene 3–28 to 3–29

modes
in place 2–546
motion flow 2–607

modifiers 1–78
bend 3–4
cloth 2–793
editable patch 2–475
extrude 3–4
FFD 2–475 to 2–476
garment maker 2–793
hsds 1–89
mesh select 1–106, 1–108
morpher 2–475
parametric deformers 1–107
skin 2–426
spline IK control 2–330
surface 1–35
unwrap uvw 1–192
vertex weld 1–79

modifying
biped structure in figure mode 1–386
footsteps 1–312

monkey head 1–92
moon - creating for close-up shot 1–144
morph

morph objects and topology change 1–212
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morph targets
lip sync 2–481

morpher modifier - creating lip sync and facial
expression 2–481

morphing animation 1–204
motion

copy 2–614
random 2–617
transfer 2–614

motion blur 3–86
mental ray renderer 2–818

motion capture
importing data 2–621
layers 2–626

motion flow
add clip 2–607
clip creation 2–607
editing 2–606
loop 2–612
script 2–608
shared 2–614, 2–617
tutorial 2–606 to 2–608, 2–612, 2–614, 2–617

motion flow script
create 2–608

motion mixer 2–547
motion-capture

working with 2–621
mound on pool table surface - animating 3–133
mouth-shape targets for speech 2–481
move transform, animating a ball with 1–223
multi-layer shader 1–119
multi/sub-object materials - applying to a label and

bottle 1–136
multilegged

character 2–576
multiple booleans 2–171
multiple delegates and behaviors 2–641
multiple materials to one object 1–162
multiplier curves 1–223

N
naming

a sphere 3–20
selections 1–108

new feature in v8
animation tracks 1–270
asset tracking 2–937
biped retargeting 2–493
cloth modifier 2–793
euler rotations 2–502
function curves on bipeds 2–502
garment maker modifier 2–793
Inventor interoperability 2–125
Limit Controller 2–187

pelt mapping 2–243
twist links 2–498
vertex selection tools 2–442
Weight tool 2–435

night shader
mental ray 2–852

noise controller 1–223
noise controller, adjusting 1–237
nonlinear animation 1–223, 1–237
normal bump maps 2–251
normals 1–90
NURBS

creating contours 1–93
creating ear 1–101
creating eye 1–98
head - completing 1–105
head - mirroring and lofting 1–102
head - previewing 1–97
modeling with 1–92

O
object painter script 2–282
object space mapscaler 1–181, 1–186
object-space camera map modifier (OSM) 3–133
objects

assigning materials to 1–118
available for modeling 3–16
matte objects 3–126, 3–129 to 3–130
parametric objects 3–16
primitive objects 3–16
unselected - hiding 1–106, 1–112

ocean shader
mental ray 2–871

online support 1–3
online tutorials 1–4
opacity value of basic materials - changing 1–119
orange

applying basic materials to 1–119
creating orange 3–20
creating orange peel 3–20

oren-nayar-blinn shader 1–119
orientation constraint

character rigging 2–371

P
painting - vertex color 2–283
painting - with vertex color 2–280
panorama exporter 1–455
parameter collector 2–189

animating parameters 2–194
organizing 2–190
selecting parameters 2–190

parameter out of range curves 1–223
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parameter wiring
character rig 2–317, 2–321, 2–349
character rigging 2–371, 2–391

parametric objects - types of 3–16
parent overlap 1–400
particle flow

with blobmesh 1–473
particle systems

and explosions 1–464, 3–82, 3–84
and materials 3–83
creating cigarette smoke 1–457

path constraint 1–276, 2–330
paths 1–242
pelt mapping 2–243
Perforce 2–937
performance, rendering 1–441
phoneme targets for speech 2–481
phong shader 1–119
physique

applying 1–396
getting started 1–382
problem areas 1–404

ping-pong ball
adding squash and stretch to 1–240

pivot points
character rigging 2–311
joining 1–112
repositioning 1–230

pivots 2–67
plane 3–76
planets

modeling 3–28
player

ram 3–138
pool table surface

animating 3–133
applying a material to 3–133
applying an affect region modifier to 3–133
creating 3–132
creating and animating 3–132

pose
biped 1–386

position constraint
wiring weights 2–371

position list controller 1–223, 1–237
pratfall 1–332
preview window 2–691
previewing NURBS head 1–97
previewing reactor 2–683
primitive objects 3–16

move/rotate/scale 3–29
props

biped using 2–506

prow and the spire 2–172
proxy geometry 2–685

Q
quadruped

animation 2–576
character 2–576

quaternion rotation 2–383
quick render 1–107

R
radial blur 3–92
radial scale 1–400
radiosity 1–437

advanced lighting override material 1–446
and camera animation 1–440
creating a radiosity solution 1–438
glowing objects 1–446
improving quality 1–443
radiosity mesh 1–440
speeding up 1–443

radiosity adaptive subdivision 3–61
advanced lighting 3–68

rag doll tutorial 2–700
creating the animation 2–718
hinge constraint 2–706, 2–708
making objects physical 2–702
rag doll constraints 2–712
setting up hips back neck and shoulders 2–716
setting up knees elbows ankles and wrists 2–708

ram player 1–432, 3–138
random motion 2–617
raytrace map type 1–139
raytrace materials - applying to a bottle and knife 1–139
reaction manager 2–467
reactor

accuracy 2–691
assigning physical properties 2–682
compound rigid bodies 2–686
create animation 2–695
creating a deforming mesh 2–737
creating animation 2–683
creating cloth 2–719
creating ropes 2–728
creating soft bodies 2–731
deformable bodies tutorial 2–719
display proxies 2–689
fracture 2–696
hand animation 2–694
introduction to 2–681
keyframing 2–695
preview window 2–691
previewing animation 2–683
proxy geometry 2–685
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rag doll tutorial 2–700
reducing file size 2–695
rigid bodies 2–682
rigid body collections 2–683
simulating mass distribution 2–688
simulation accuracy 2–691
simulation geometry 2–684
simulations 2–683
substeps 2–691
unyielding rigid bodies 2–694
updating 3ds Max 2–691
using proxies 2–685

real-world map scale 2–135
real-world map size 3–65
real-world mapping 3–61
reduce mesh memory footprint 1–204
reducing keys 2–628
reference points for use with camera match 3–114 to 3–115
reflected light

global illumination 2–835
reflections

mental ray renderer 2–810
trace depth 2–810

refraction
mental ray renderer 2–814

region-select technique 1–108
relax tool 1–202
Reload 2–137
rename objects 2–337
render effects 1–477, 1–479 to 1–481, 3–88 to 3–90, 3–92
render to texture 2–80, 2–293
rendering 1–224

an arm 3–130
and antialiasing 1–440 to 1–441
animations - using render scene 3–26
checking resolution of background - for camera

match 3–119
creating a rendering 1–438
improving 1–441
introduction to 1–424
rendering daylight 1–448
setting up background - for camera match 3–118
speeding up 1–441
using environment 3–118

requirements for lip sync 2–481
resources 1–3
revit 2–133
Revit 2–132, 2–137
revit material 2–135
revolving door 3–95, 3–98, 3–101, 3–104, 3–107 to 3–108
rig

animation controllers 2–321
arms 2–371

custom attributes 2–317, 2–349
IK solver 2–305
legs and feet 2–349
pivot points 2–311
script controller 2–383
shapes 2–311
shoulder 2–391
skin modifier 2–325
wiring 2–317, 2–321, 2–349
wrist twist 2–383

rig - character 2–349
rigging

introduction 2–299
rigid body collections 2–683
rigid body properties 2–682
rigid vertices 1–400
ring effect 1–479
roof 2–165
roof, creating for museum 2–2
rotation - animating rotation changes 3–23
rotation boosting 2–628
rotation list 2–321
rotation smoothing 2–628
rotation windup 3–3
running

and jumping 1–312

S
sample files 1–3
sampling

mental ray renderer 2–806
scale operator (particle flow) 2–916
scaling maps in object space 1–181, 1–186
scaling maps in world space 1–186
scene state 3–61
scene states

restore 3–70
save 3–70

scenes, saving 1–282
schematic view 2–411

frozen objects 2–337
screen points - assigning in camera match 3–121
script

create 2–608
motion flow 2–608
use of 2–608

script controller
character rigging 2–383

scripting
camera manager 2–925
effects 2–925
unhide 2–930

secondary motion 2–444
seeking targets 2–904
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select region
circular 2–47
rectangular 2–47

selections - naming 1–108
self-illumination value of basic materials - changing 1–119
set key 2–452
shader

mental ray 2–846
shaders 1–119, 1–125, 1–221
shadow study 1–434, 2–18
shadows

choosing a shadow type 1–422
shape operators (particle flow)

shape facing 2–915
shapes

character rigging 2–311
shared

motion flow 2–614, 2–617
shock wave effect 2–892
shoulders

envelopes 1–404
simulating fractures with reactor 2–696
simulation accuracy 2–691
simulation geometry 2–684
site planning, conceptual modeling 2–162
site-specific design 2–153
skateboard

biped interacting with 2–506
skeleton

create 1–383
skin

applying to an apple 1–106
material 1–151

skin modifier 2–425 to 2–426
angle deformer 2–439
character rigging 2–325

skinning 1–396, 2–325
character 2–425

smoke trails effect 2–900, 2–912
smoothing

and compositing (camera tracker) 3–147
snaps 3–94
soft selection 1–29, 1–85, 1–108, 1–110

with flex modifier 2–444
software driver - installing 3–121
SourceSafe 2–937
spacing tool 2–12
spawning particles 2–912 to 2–913
special effects 2–925, 3–1
specular color - changing 1–119
speech target requirements 2–481
sphere 1–107

spheres
changing color of 3–20
creating 1–106, 3–20
naming 3–20
tapering 1–106
viewing 3–20

spline IK 2–330, 2–337, 2–342
spline IK solver 2–330

splines
placing around an arm 3–129

splines, drawing 1–21
split tests (particle flow) 2–893
sponsons - airplane 1–61
squash - adding to a ball 1–240
squash and stretch 1–223
stabilizer and rudders - airplane 1–57
standard lights 1–452
standard materials 1–155
standard primitives 3–16
star effect 1–480
stars 1–148
stem

adding to an apple 1–112
positioning with 3D Snap 1–112

still life
animating 3–26
creating 3–16

stop and start walking 1–317
strauss shader 1–119
streetlight using xrefs 2–274
strength parameter spinners - adjusting 1–110
stretch - adding to a ball 1–240
sub-object selections 1–108, 1–110
sub-surface scattering

fast skin shader 2–874
submerge shader

mental ray 2–871
substeps 2–691
substitute modifier 2–139

creating a substitute 2–141
support files 1–3
surface properties and displacement mapping 1–144
surface tools 1–35
sweep modifier 3–61 to 3–62
symmetry modifier 2–199
synchronizing animation with video 3–126

T
taper modifier 1–107

applying to a cylinder 1–112
applying to a sphere 1–106

targets for lip sync 2–481
TCB rotation 3–3



162 Index

terrain
adding materials to 2–158
creating 2–156

text 3–4
text - bending 3–1
texture coordinates

managing 1–192
texture mapping 1–202
textures

texture baking 2–293
texture coordinates 1–193
texture mapping 1–193

time tags - adding to video 3–126
topology changes and morph objects 1–212
trace depth

mental ray renderer 2–810
Track View 1–223, 1–230

and setting lip sync keys 2–481
training centers 1–3
trajectories 1–223
transfer

motion 2–614
transitions

use of 2–612
translucent shader 1–221
transparency (materials) 1–119, 1–123
trees 2–282
troubleshooting - camera match 3–124
troubleshooting drawing files 2–112 to 2–113, 2–117
tutorial

motion flow 2–606 to 2–608, 2–612, 2–614, 2–617
tutorial files cd 1–3
tutorials 2–766

audiences 1–1
introductory 1–1
sample files 1–3
where installed 1–3

twist links 2–498
adding 2–499
setting twist poses 2–499

U
unhide

scripting 2–930
uniform textures 1–181, 1–186
units 3–94
unwrap UVW 1–193, 1–202

mapping a character 2–236
unyielding rigid bodies 2–694
updates 1–3
use of

layers 2–612
script 2–608
transitions 2–612

users
beginning with 3D 1–1
familiar with other 3D programs 1–2

using
freeform animation 1–343

using filters 2–628
using in place mode 2–546
UVW

mapping characters 2–236
UVW map modifier, using to adjust floor tiles 1–180
UVW mapping 1–193

V
vaults

adding files 2–942
checking in files 2–944
creating 2–940
logging in 2–941
working folders 2–942

vertex color 2–283
vertex tangent handles - shaping a facial expression target

and 2–481
vertex weights 2–426
vertices

rigid 1–400
video

adding time tags to 3–126
synchronizing animation with 3–126

video post 3–1, 3–14
viewport background

setting up 1–48
viewport image 2–1
viewports

navigating 3–17
setting up background for camera match 3–120

visibility keys 3–85
volume fog 3–1
volume light 3–1

W
walk

creating 1–303
walk cycle 2–446
walking

stop and start 1–317
walkthrough 1–276
water surface shader

mental ray 2–871
weight

giving biped illusion of 2–506
weighted list controllers 1–223, 1–237
wings, airplane 1–51
wireframe material controls 1–119
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wiring 1–464
character rig 2–317, 2–321, 2–349
character rigging 2–391
particle systems 1–464

workbench 2–627
working online 1–4
world space mapscaler 1–186
world-space camera map modifier (WSM) 3–133
wraparound shader

mental ray 2–849
wrist

automatic twist 2–383
twist bones 2–345
twist rig 2–371

X
XML files 2–182
xrefs

and animating a spaceship 1–259
and merging 2–446




