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 MotionBuilder
Interoperability

Part of your development pipeline might take you to MotionBuilder, a powerful 3D
character-animation suite. With MotionBuilder, you can quickly and easily rig characters,
then set up their animation using a full-body FK/IK manipulation rig. You can also retarget
animation data between characters, as well as blend, edit, and sequence tracks in a timeline
editor, combining animation with cameras, digital video, and audio.

As you build your animation, MotionBuilder provides real-time playback of character
performance. There is no need to preview or render your work.

This tutorial shows you how to import a character to MotionBuilder, add animation using
both the FK/IK manipulation rig as well as data from a motion-capture file, then export your
work back to 3ds Max as a fully editable animated character.
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In this tutorial, you will learn how to:

■ Label 3ds Max biped skeletons for easy conversion to MotionBuilder

■ Export a 3ds Max biped as an FBX file, then import to MotionBuilder

■ Characterize skeletons in MotionBuilder for animation as a full FK/IK rig

■ Use naming templates and scripts to quickly characterize skeletons

■ Animate a character in MotionBuilder based on motion-capture data

■ Use keyframes to fine-tune character movement

■ Export character animation as an FBX file from MotionBuilder, then import to 3ds Max
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■ Fine-tune character animation in 3ds Max.

Skill level: Intermediate

Time to complete: 2 hours

Preparation for This Tutorial

■  On the Quick Access toolbar, click Project
Folder and set your current project to 3ds Max 2010 Tutorials.

Preparing 3ds Max Scenes for Export
This lesson shows you how to take characters created in 3ds Max and prepare
them for import to MotionBuilder.

View skeleton bone hierarchy and naming conventions:

1  On the Quick Access toolbar, click the Open File button, navigate
to \scenes\interoperability\motionbuilder and open basics.max.

NOTE If your system units are set to anything other than Centimeters, a File
Load: Units Mismatch dialog opens, prompting you to choose which unit
scale to use. Turn on Adopt the File’s Unit Scale and click OK.

The scene contains, from left to right, a mesh character and three
skeletons that can be used to drive the mesh.
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Mesh and three skeletons

Left: Mesh

Second from left: Skeleton A

Third from left: Skeleton B

Fourth from left: Skeleton C

Skeleton A is made up of a conventional bone system. Skeletons B and
C are 3ds Max Biped systems.

Before MotionBuilder can recognize a model as a character that can be
animated, its skeleton bones must be characterized. A model can be
characterized only if its bones are labeled in a specific way. You can
rename character bones in MotionBuilder, but it is a good idea to rename
them properly in 3ds Max whenever you can.

2  Region-select Skeleton A, then right-click and from the quad
menu, choose Isolate Selection.
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Skeleton created from a conventional bone system

3  On the main toolbar, click Select By Name.

4 On the Select From Scene dialog, choose Display > Children and then
Display > Expand All. Scroll the list to view the skeleton hierarchy and
see how each bone is named.
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This is the naming convention recognized by MotionBuilder. If you name
the skeleton bones this way, you can later characterize them in
MotionBuilder with a simple click of the mouse.

5 Click Cancel to close the Select From Scene dialog, and then click Exit
Isolation Mode to display the whole scene again.
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6  Region-select Skeleton B, then right-click and from the quad
menu, choose Isolate Selection.

7  On the main toolbar, click Select By Name.

The Select From Scene dialog opens, showing the bone hierarchy of the
Skeleton B and its identifying names. This naming convention is the
default for Biped. While it is different from the convention used by
Skeleton A, MotionBuilder also recognizes it, and it can be used to quickly
convert skeletons for animation.
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8 Repeat steps 5 through 7 to isolate Skeleton C and view its skeleton
hierarchy.

Even though the suffix of each bone name in Skeleton C is identical to
the name suffixes in Skeleton B, the prefix to each bone name, “MIA,”
is different. MotionBuilder doesn’t recognize this name prefix, so it can’t
characterize the bones automatically. Characterization is still possible,
and you will carry this task out later on, but it will require more effort.

The next few steps provide a quick review on how to create and rename
a biped. If you already know how to create and rename bipeds, proceed
directly to the next lesson on page 1809.

9 Click Cancel to close the Select From Scene dialog, and then click Exit
Isolation Mode to display the whole scene again.
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Create a biped and rename it:

1  On the Quick Access toolbar, click New Scene. In the New Scene
dialog, chose New All, and then click OK.

2  On the Create panel, click Systems and on the Object
type rollout, click Biped.

3 Click the viewport and drag to create the Biped. Continue dragging until
you reach the desired body height.

The Create Biped rollout > Root Name field displays the name of the new
biped. This field is where you rename your Biped, if you need to.

NOTE Each time you create a Biped in a scene, its number increments by
one (Bip01, Bip02, Bip03, and so on).
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4  On the main toolbar, click Select Object, then select any bone
on the new Biped.

The Name And Color rollout displays the bone’s name and its Bip prefix.

Remember, if the Biped has any prefix other than Bip01, more effort is
required to characterize its bones in MotionBuilder.

If you wanted to rename a Biped any time after its creation, you can do
the following.

5  Go to the Motion panel. On the Biped rollout expand the Modes
And Display section. Type BOB in the Name field, and then press Enter.

6  On the main toolbar, click Select By Name.

The Select From Scene dialog opens, showing the bone hierarchy of your
Biped. Each bone now displays the BOB prefix you specified in the previous
step.
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Exporting Scenes to MotionBuilder
This lesson shows you how to export 3ds Max scene data in .fbx format to
MotionBuilder. You can export an entire scene, or only a portion of the scene
containing selected elements.

Export skeleton A in FBX format:

1  If you are continuing from the previous lesson, from the
Application menu choose Reset, do not save any changes, then reopen
basics.max.

2 Region-select all of skeleton A.

Notice that the skeleton has been positioned in a “T” pose, the stance
commonly used by animators for skinning. You should always place your
characters in this position before you export them to MotionBuilder.

Also, skeletons must be oriented in the minus Y axis direction. (All 3ds
Max Biped systems are oriented this way when you create them.)
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Skeleton A oriented in a minus Y direction

3  From the Application menu, choose Export > Export Selected.

4 In the Select File To Export dialog > File Name field, type mybone-skeleton
and click Save.

The file is automatically saved in Fbx format to your project’s Export
folder. The FBX Export dialog opens. Here, you specify how to convert
the 3ds Max scene information.

NOTE For conversion to take place properly, you must have the latest FBX
driver installed. Installation instructions are provided at the beginning of this
tutorial.

5 On the FBX Export dialog > Include rollout, turn off Animation.
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This option should be turned on only when the scene you want to export
has animation.

6 Make sure Embed Media is also turned off.

If you were exporting a mesh with a character, the Embed Media option
would embed in the FBX file any texture maps associated with the
character. But since you are exporting a skeleton only, this option is not
needed.

7 On the Advanced Options > Axis Conversion rollout, make sure Up Axis
displays the Y-up option.

This setting assigns the exported character a Y-up axis, the orientation
used by objects in MotionBuilder. This setting is required because objects
created in 3ds Max use a Z-up orientation.

8 Click OK to export Skeleton A as an FBX file to your designated folder.
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NOTE Typically, you would also export a mesh, properly skinned onto a
skeleton.

Export the Pepe character:

1  On the Quick Access toolbar, click Open File.

2 Do not save your scene file when prompted, and from the Open File
dialog, choose Pepe_biped.max.

Scene consists of a biped skeleton inside a mesh
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3  On the main menu, click Select By Name.

The Select From Scene dialog opens, showing both the mesh and the
Biped. The Biped hierarchy uses a naming convention recognized by
MotionBuilder.

4  Click Cancel to close the dialog. On the main menu click Select
And Move.
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5 Select Pepe’s right foot bone and move it in any direction to see how the
skinning controls the character behavior.

6  From the Application menu, choose Export, and in the File
Name field, type my_pepe_biped01.

7 On the FBX Export dialog > Include rollout, turn on Embed Media, then
click OK.

The Pepe character is exported as an .fbx file to the same folder as the
biped skeleton you saved earlier.

8 In the viewport, select any bone in the Pepe skeleton.
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9  Go to the Motion panel > Biped rollout, expand the Modes And
Display group, and on the Name box, type PEPE.

10  On the main toolbar, click Select By Name.

The Select From Scene dialog displays the modified names of the character
parts. Each bone is now identified by the PEPE prefix.

11 Export this modified scene as you did in step 6, but name the exported
file my_pepe_named.

In the next lesson, you will use this FBX file to learn how to import
custom-named characters into MotionBuilder.

12 Save your scene in 3ds Max as my_pepe.max.
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Importing Scenes to MotionBuilder
This lesson shows you how to import an FBX file to MotionBuilder and
characterize the bones of the skeleton you need to animate. You will then
assign the skeleton a control rig.

Import a Biped skeleton and assign it a control rig:

1 Open MotionBuilder and on the Asset Browser explorer panel, right click
a blank area and choose Add Favorite Path.

2 On the Open Directory dialog, navigate to the 3dsMax 2010
Tutorials\export folder. Highlight the folder and click OK.

The folder displays as a shortcut in the Asset Browser

3 Click the folder name to expand it.
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Now, you have fast access to the material you want to import to
MotionBuilder. The folder contents display in the Asset Browser to the
right.

If you had saved your material in MotionBuilder instead of 3ds Max, you
could have accessed them by simply dragging their file icon from the
Asset Browser into the viewport.

Dragging the icons of files created in external applications, however,
launches a series of dialoges that prompt you for more information. It is
therefore preferable to import files created in 3ds Max through an Fbx
Plug-in Import dialog.

4 From the main menu, choose File > Fbx Plug-in Import.

5 On the Open File dialog, navigate to the 3dsMax 2010 Tutorials\export
folder, highlight bone-skeleton.fbx and click Open.

6 On the Fbx Plug-in Import Options dialog, leave the default settings
unchanged and click Open.
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A skeleton displays in the viewport

Pause now and take a moment to try a few MotionBuilder navigation
techniques.

7 Press Ctrl+Shift and drag to orbit around the scene.

8 Ctrl+click and drag to zoom in and out of the scene.

9 Shift+click and drag to pan the scene.

The skeleton bones now need to be characterized before it can take on
animation. Characterization is the way you rig a skeleton in
MotionBuilder.

10 On the Asset Browser, click Templates > Characters.

11 Click and drag the Character tool to the skeleton’s center of mass.
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12 Click Characterize.

13 On the Character dialog, click Biped to indicate the type of rigging to
apply to the character.

The dialog reminds you that the character must be in a “T” pose and be
facing in the positive Z axis (the equivalent of the negative Y axis that
you converted when exporting the .max file into .fbx format).

14 On the Character Controls window, choose Edit > Control Rig Input.

You must choose this setting if you intend to keyframe your character.
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15 On the Create Control Rig dialog, click FK/IK.

FK/IK is the method commonly used to animate characters.

16 In the Character Controls window > Active group, turn on Ctrl Rig In.

This setting activates the Character Controls gizmo to the left. The gizmo
is an image of the biped skeleton and contains all the effectors you need
to animate its control rig.

Your character is now rigged and ready to receive animation.

Because your character bones were properly labeled, it took just six steps
to successfully rig your character. In 3ds Max, rigging a character using
regular FK/IK constraints would have taken a great deal more effort.

17 On the Character Controls gizmo, select the skeleton’s right hand effector.

18 Click anywhere in the viewport, press T (translate), and move the hand
down. As you continue to move the hand, the arm extends, and the rest
of the body reacts in a natural movement.
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Use a naming template to characterize a biped skeleton with a Bip01 prefix:

1 From the main menu, choose File > New. Do not save changes to your
existing file.

2 Choose File > Fbx Plug-in Import.

3 On the Open File dialog, navigate to your Import > Motionbuilder Files
folder, highlight Pepe_biped-Bip01.fbx and click Open. On the Fbx Plug-in
Import dialog, leave the default settings unchanged and click Open.

The Pepe character mesh displays in the viewport.
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4 Place the cursor anywhere inside the viewport and press A.

Pressing A is the equivalent of using Zoom Extents in 3ds Max. It zooms
in to all visible objects in the viewport.

5 With your cursor still in the viewport, press Ctrl+A to obtain a skin-only
view. Press Ctrl+A again to switch to X-ray mode.
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Pepe character in X-ray mode

In this mode, you can view and select both the character mesh as well
as the bones, either individually or by region selection.

6 Drag drag the Character icon from the Asset Browser into the viewport,
then release the icon over the skeleton’s center of mass, as shown in the
next illustration.
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Pepe character center of mass

7 Click Characterize.

An error message displays, indicating that the characterization of the
bones could not be completed. This is because MotionBuilder could not
recognize the names that identify the Pepe character bone system.

8 Click OK.

A list displays all the bones MotionBuilder could not find.
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9 Click Close, then go to the Navigator window, expand Characters, and
double-click on Character.
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10 Click the Character Definition tab if it is not already active and from the
left-hand column, expand Base (Required).

The Character Definition window mapping table shows all the skeleton
components whose mapping conversion was not recognized by the
MotionBuilder naming template.

11 On the Navigator window, highlight, then right-click the Character entry
and click Delete.

12 On the Asset Browser, click the 3ds Max Biped Template and drag it to
the Pepe character center of mass in the viewport.

This tool is similar to the Character tool you used earlier to characterize
the bones of the model. It is designed to recognize the bones of a biped
object created in 3ds Max (bones that have Bip01 as a prefix and a the
regular Biped link-naming convention for their suffix).

13 Click Characterize, then Biped.

14 On the Character Controls window, choose Edit > Control Rig Input.

15 On the Create Control Rig dialog, click FK/IK.

16 On the Active group, turn on Ctrl Rig In.

17 On the Character Control group gizmo, select Pepe’s right hand effector,
then click anywhere in the viewport, press T, and move the hand.

The Pepe skeleton is fully rigged.
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18 Go to the Navigator window, double-click on 3ds Max Biped Template,
and on the Character Definition window, expand Base (Required).
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The Naming Template column (on the right) shows how the 3ds Max
Biped Template tool has characterized the bones by mapping their
conventional Biped names onto the default MotionBuilder naming
convention, shown in the left-hand column.

Use a naming template to characterize a biped skeleton with another prefix:

1 From the main menu, choose File > New. Do not save changes to your
existing file.

2 Choose File > Fbx Plug-in Import.

3 On the Open File dialog, navigate to your Export folder and double-click
Pepe_biped-PEPE.fbx. On the Fbx Plug-in Import dialog, leave the default
settings unchanged and click Open.

The Pepe character mesh displays in the viewport.

4 With your cursor in the viewport, press A to zoom in and press Ctrl+A
until you see the skeleton in the viewport.

5 Drag the 3ds Max Biped Template from the Asset Browser to the viewport,
and drop it on the Pepe character’s center of mass.

6 Click Characterize.

An error message displays, indicating that the characterization of the
bones could not be completed. This is because MotionBuilder could not
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recognize the PEPE prefix that precedes each name in the Pepe character’s
bone system.

7 Click OK.

All the bones MotionBuilder could not find on the character displays in
a list.

8 Click Close, go to the Navigator window, choose Characters and
double-click on 3ds Max Biped Template.

The mapping table shows that MotionBuilder could not recognize the
character’s bones, based on the 3ds Max naming template (Bip01 L Thigh,
and so on) listed in the right-hand column.

One way to solve this problem is to Alt+drag each bone from the character
to the corresponding row in the Mapping List column. However, this is
quite time-consuming. It is better to create a new naming template to
suit any new characters you need to import to MotionBuilder. You will
learn how to do this in the next lesson.

Creating Naming Templates
This lesson shows you how to create templates that let you take custom-named
character bones and have them characterized automatically for use in
MotionBuilder.

Creating Naming Templates | 1829



Create a biped in 3ds Max and export it to MotionBuilder:

1  In 3ds Max, from the Application menu, choose Reset.

2  On the Create panel, click Systems.

3 On the Object type rollout, click Biped.

4 In the Perspective viewport, click and drag to create a biped object.

The size of the biped is not important.

5 On the Create Biped rollout > Root Name group, type MyBiped: as the
character name.
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Be sure to add the colon (:) after the Biped name. This character instructs
MotionBuilder to ignore all characters that precede it, thereby creating
a template whose bone labels have no prefix.

If for any reason you forget to add the colon, you can add it later by going
to the Motion panel > Biped rollout, expanding the Modes And Display
section, and adding the colon in the Name box.

NOTE Because you are creating this Biped to extract its naming information
only, you do not need to give it a T-pose or position it in a negative Y axis.

6  Go to the Motion panel > Biped rollout, select any
bone in the Biped, and click Figure Mode.

7 In the Structure rollout > Body Type group > Neck Links spinner, type
10 and press Enter.
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Biped with 10 neck links

The biped starts to look more like a giraffe, but the appearance of the
model is not important. Because MotionBuilder has channels that provide
for ten neck links, it is simply good practice to make them available when
you create your biped.
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8 Change other Figure Mode settings for the Biped as follows:

■ Spine Links = 10

■ Fingers = 5

■ Finger Links = 3

■ Toes = 5

■ Make sure Toe Links = 3 (the default).

Press Enter after you change each value.
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9  Click Figure Mode again to turn it off.

Export the geometry:

1  From the Application menu, choose Export.

2 In the Select File To Export dialog > File Name field, type
my_biped_for_template and then click Save.

3 On the FBX Export dialog > Include rollout, turn off Embed Media, then
click OK.

Import the Biped to MotionBuilder:

1 In MotionBuilder, create a new scene. If you still have Pepe_biped-Bip01.fbx
open, do not save your changes.

2 From the main menu, choose File > FBX Plug-in Import.

3 On the Open File dialog, choose the Biped file you just created in 3ds
Max, my_biped_for_template.fbx, click Open, then on the FBX Plug-in
Import Options dialog, click Open again.

4 Place your cursor anywhere in the viewport and press A to zoom in to
the Biped skeleton.
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Next, you will create a naming template that you can reuse later on to
automate the skeleton characterization process.

Begin to create the naming template by assigning nodes to the Mapping List:

1 On the Asset Browser, highlight Templates > Characters and click the
Character tool.

2 Drag the Character tool to an empty area in the viewport.

3 On the Navigator panel, expand Characters and highlight Character.

4 Right-click, choose Rename, and type BIP_CS, then press Enter.
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This is the name of the template you are about to create for your biped.

5 On the Character Definition tab > Character group, expand Base
(Required) if it is not already displayed.

The left column lists all bones required to form a complete skeleton.

6 In the viewport, click to select the Biped’s left upper thigh, and then
Alt+drag it to the Mapping List column, next to the row called LeftUpLeg.
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Alt+drag skeleton left upper thigh to the Mapping List.

This maps the bone label created in 3ds Max to the naming convention
recognized by MotionBuilder.

7 Click to select the Biped’s left calf, then Alt+drag it from the viewport to
the Mapping List cell to the right of LeftLeg.
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8 Click to select the Biped’s left foot, then Alt+drag it from the viewport to
the Mapping List cell to the right of LeftFoot.

9 Repeat steps 6 through 8 for the Biped’s right leg.

Use Schematic view to locate nodes:

1 Click an empty area in the viewport and press Ctrl+W to switch to
Schematic view.

It is often easier to locate bones in this view.

2 Press A to zoom out to view all the nodes in the biped skeleton.

You can pan, zoom and navigate the viewport using the same navigation
key combinations you tried earlier in Perspective view: Ctrl+drag to zoom,
and Shift+drag to pan.

3 Locate the MyBiped:Spine node in the viewport.
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TIP You can also select one or more nodes and press F (fit) to instantly zoom
in to your selection.

4 Click the MyBiped: Spine node to select it, then Alt+drag it to the Mapping
List cell to the right of Spine.

5 Navigate the bone hierarchy until you locate the MyBiped: L UpperArm
node. Click to select it, then Alt+drag it to the to the Mapping List cell
to the right of LeftArm.

6 Repeat the previous step for the Biped’s forearm and hand, then move
on to do the same for the right arm, forearm, and hand.

7 Locate the MyBiped: Head node. Click to select it, then Alt+drag it to the
bottom of the Mapping List, next to Head.

Map the Hip node:

 ➤ In the Schematic view, locate the MyBiped: node, at the top of the bone
hierarchy, click to select it, then Alt+drag it to the Base (required) Mapping
List cell to the right of Hips.

Creating Naming Templates | 1839



Intuitively, you might expect to drag the MyBiped: Pelvis node to the Hips
entry instead. But because of the way bones are characterized in
MotionBuilder, the Biped Center of Mass (COM) is the node you need to
specify for hip bones of characters exported from 3ds Max.

The bones you have so far mapped to the naming template are required
to successfully characterize a character skeleton. The bones you will map
in the next procedure are optional, but they give you more control over
the character.

Map optional nodes:

1 On the Character group > left column, expand the Spine group. Alt+drag
MyBiped: Spine 1 from the viewport to the Mapping List cell to the right
of Spine1.
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2 Repeat the previous step for spine links 2 to 9.

3 On the Character group > left column, expand the Neck group. Alt+drag
MyBiped: Neck from the viewport to the Mapping List cell to the right of
Neck.

4 Repeat the previous step for neck links 1 to 9.

5 On the Character group > left column, expand the Auxiliary group.
Alt+drag MyBiped: L Clavicle from the viewport to the Mapping List cell to
the right of LeftShoulder.

6 Repeat the previous step for the right shoulder.

This completes the base subset of bones required for characterization.
You are now ready to extract the template so it can be used to characterize
the bones of future skeletons.

Extract the template:

1 In the Character Definition window > Character group, click Extract
Naming Template, then click OK to clear the message box.

The names of the bones you dropped into the Mapping List column are
transferred to the Naming Template column. Because you added the
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colon to the Biped skeleton names, only the suffix is transferred. This is
the naming convention recognized by MotionBuilder.

The only bone not properly labeled at this point is Hips. You must set the
Hips name manually each time you characterize a Biped with this template.

2 Click Clear Mapping List and then click OK.

You need to clear the Mapping List column because this is where you
drop the bones of future skeletons to be characterized.

3 On the Navigator window scene explorer, highlight BIP_CS. From the
main menu, choose File > Save Selection.

This saves the BIP_CS characterization template only, and not the biped
skeleton you used as its reference.

4 On the Save File dialog, navigate to the Export folder and in the File name
field, type univ_bip_template. Click Save, then click Save again.

With this template created, it is now much easier to characterize a Biped
whose bones do not start with the prefix Bip01.

Import the Pepe biped and use the BIP_CS naming template to characterize
its skeleton:

1 Click an empty area in the viewport, and press Ctrl+E to return to
Perspective view.

2 From the main menu, choose File > New. Do not save changes to the
existing file.

3 Choose File > Fbx Plug-in Import, navigate to the export folder and open
the file called Pepe_biped-PEPE.fbx.

As you saw earlier, this file contains a biped with a PEPE prefix for each
of its bones. Conversion with the 3ds Max Biped template is not possible,
since it can only handle skeletons whose bones have Bip01 prefixes.
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4 Zoom in to the Pepe character and press Ctrl+A until you reach X-ray
mode.

5 On the Asset Browser, highlight the export folder in which you saved
univ_bip_template. Select the folder, then right-click and choose Refresh
Directory.

6 Drag and drop univ_bip_template from the Asset Browser to an empty area
in the viewport. Choose FBX Merge > <No Animation>.

The BIP_CS template displays in the navigator tab scene explorer, under
Characters.

7 Double-click BIP_CS to display the Naming Template at the far right.

8 Region-select the Pepe character to select all his bones, then Alt+drag to
the Mapping List column.

Each bone suffix is matched to the suffixes of the Naming Template,
ready for characterization. The only step remaining is to manually specify
the hips, since they could not be provided in the Naming Template.
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9 Click an empty area of the viewport and press Ctrl+W to return to
Schematic view.

10 Locate the Pepe character’s center of mass node, called PEPE. Alt+drag it
to the Mapping List cell to the right of the Hips entry.

11 In the Character Definition window > Character group, turn on
Characterize, and then click Biped.

12 Press Ctrl+E to return to Perspective view.

13 From the Character Controls window > Character Controls tab > Edit
menu, choose Control Rig Input.

14 On the Create Control Rig dialog, click FK/IK.

15 On the Character Controls window > Active group, turn on Ctrl Rig In.

16 On the Character Control gizmo, select Pepe’s right hand, then click
anywhere in the viewport, press T, and move the hand.
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Fully-rigged Pepe character

The character is properly rigged, ready for keyframe animation.

Now you can import to MotionBuilder any biped character created in
3ds Max with any prefix name. If you choose the univ_bip_template as the
characterization tool, characterization is virtually automatic. The only
bone you need to manually specify is the hip bone.

You can accomplish this task faster using a Python script, but it is
important to understand the template creation process in case you need
to perform the characterization manually.

17 Close the scene file and do not save your work.
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Import the Pepe biped using a Python script to characterize its skeleton:

1 From the main menu, choose File > New.

2 Choose File > Fbx Plug-in Import and open the file called
Pepe_biped-PEPE.fbx.

3 Zoom in to the Pepe character and press Ctrl+A until you reach X-ray
mode.

4 On the Asset Browser, open the Scripts folder.

5 Drag and drop the BipedToCharacter icon from the Asset Browser to an
empty area in the viewport.

6 From the menu, choose Add To Scene.

7 Select the character’s center of mass.
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8 On the Navigator tab, expand Scripts, right-click BipedToCharacter and
choose Execute.

9 From the Character Controls window > Character Controls tab > Edit
menu, choose Control Rig Input.

10 On the Create Control Rig dialog, click FK/IK.

11 On the Character Controls window > Active group, turn on Ctrl Rig In.

12 On the Character Control gizmo, select Pepe’s right hand, then click
anywhere in the viewport, press T, and move the hand.
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Fully-rigged Pepe character

The character is properly rigged, ready for keyframe animation.

Animating Characters In MotionBuilder
In MotionBuilder, you can animate characters by setting keyframes manually
or by using motion-capture data. This lesson shows you how to do both.

NOTE If you already know how to animate characters in MotionBuilder, you can
skip this lesson and go to the next lesson on page 1857.
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Animate the Pepe character using motion-capture data

1 In MotionBuilder, from the main menu, choose File > New. If you are
continuing from the previous lesson, do not save your existing scene.

2 From the Asset Browser > Export folder, choose Pepe_biped_characterized.fbx.

This file contains the Pepe character you worked on in the last few lessons.
To speed things up, he has already been characterized and saved in
MotionBuilder, so he is ready to receive animation.

3 Drag the file to the viewport.

4 Choose FBX Open > <All Takes>.

MotionBuilder has the ability to store multiple animation “takes” or
sequences within the same project, and this option would open all of
them if they existed. Alternatively, you could choose No Animation or
Take 001 as well.

5 Click an empty area in the viewport and press A to zoom in to the Pepe
character.

6 Press Ctrl+Shift and drag to orbit until the right side of the character is in
view.
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Pepe is ready to accept keyframe animation using control rig input from
the Character Controls window. But in this case, you will retarget
animation to Pepe from one of the motion-capture files that ship with
MotionBuilder.

7 From the Asset Browser > Export folder, choose IceSlip and drag it to the
viewport.

8 Choose FBX Merge > IceSlip, and zoom out until the yellow skeleton that
represents the motion capture animation is visible.
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NOTE If you do not see the yellow skeleton, place your cursor in the viewport
and press Ctrl+A to exit Models Only mode.

Pepe with skeleton containing motion-capture information

9 On the Transport Controls, click Play to view the animation.

You will now assign this movement to the Pepe character. This task is
very easy to accomplish in MotionBuilder.

10 On the Character Controls panel > Character Controls tab, make sure
PEPE is displayed in the character list.
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11 Choose Edit > Input > Skeleton2, which is the yellow skeleton containing
the motion-capture animation.

12 Scrub the animation either by dragging the animation slider bar, or by
holding down the J key and dragging left or right in the viewport.

The skeleton’s animation now drives the Pepe character.

13 Press Ctrl+A and repeat until only Pepe is visible, then go to frame 92 and
zoom in on the Pepe character.
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If you look carefully, you will see how one of Pepe’s hands seems to pass
though his face. You might need to rotate the character and scrub the
animation a few times to see the problem.

Unwanted hand movement inherited from motion capture

This behavior occurred because the animation driving Pepe’s bone
movement is based on the skeleton, which has a very different physiology.
(Pepe’s head, hands and feet, for example, are much larger than the
skeleton’s, while his shoulders are much smaller.)

In the next procedure, you will correct Pepe’s hand movement.

Fine-tune the animation:

1 On the Character Controls gizmo, click the left hand effector, then press
T and try to move Pepe’s hand in the viewport.

Nothing happens because Pepe’s animation is controlled by the skeleton,
not the control rig. Before you can go any farther, you need to bake the
skeleton animation onto the Pepe character control rig.

2 On the Character Control panel > Character Controls tab > Edit menu,
choose Plot Character.

3 On the Character dialog, click Control Rig, then on the second Character
dialog, leave the default values unchanged and click Plot.
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You can now edit the Pepe character using his control rig.

The Plot command creates a key at every frame at the base layer of the
animation track, making edits difficult. You will therefore edit the
keyframing on a different layer.

4 On the Key Controls panel, click the Base Layer list and choose Layer 1.

The keyframes are hidden on the timeline, clearing your workspace.

5 Go to frame 80, which is the start of the problem hand movement. On
the Character Control gizmo, click the right wrist effector, then on the
Key Controls panel, click Key.

NOTE You can also create a key by placing your cursor anywhere in the
viewport and pressing K.

6 Go to frame 105, the end of the problem hand movement, and click Key
again.

All character movement before the first key and after the second will
remain unchanged. Only the character movement between frames 80 to
105 will be modified.

7 Go to frame 94, the mid point between the two keyframes you set.
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8 In the viewport, press T, move the hand away from Pepe’s face on its X
and Z axes, and create another key.

Left hand repositioned away from character’s face

9 Press J, then drag back and forth to see how the hand reacts to the keys
you just created.

10 Make any further adjustments to the hand movement as required, making
sure you create a key after each adjustment.

11 Advance to the last frame of the animation and adjust your viewpoint
until you can see the right side of Pepe’s body.
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Right hand too close to character head

12 Move the hand away from the body and create a key.

13 Press R and use the rotate gizmo to modify the hand’s position until it
rests flat on the ground, then create another key.
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Rotate gizmo used to reposition right hand

14 Go to frame 114 and position the right hand farther away from the head
and create another key.

15 Play back the animation to see the result.

16 Make any further adjustments to the character’s body position.

When you are satisfied with the animation, proceed to the next lesson.
There, you will save your work and prepare it for import back to 3ds Max.

Preparing Animation for Export to 3ds Max
3ds Max cannot read the control rig information that defines character
animation in MotionBuilder. For 3ds Max to recognize this animation, you
need to plot, or “bake,” the keyframe data into the character’s skeleton.
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Bake animation onto the Pepe character skeleton:

1 In MotionBuilder, continue from the previous lesson, or from the main
menu, choose File > New and from the Asset Browser > Export folder,
open the file Pepe_biped_unplotted.fbx.

2 On the Character Controls panel > Character Controls tab > Edit menu,
choose Plot Character.

3 On the Character dialog, click Skeleton; then on the second Character
dialog, leave the default values unchanged and click Plot.
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The character control rig is deactivated, but the Pepe character retains
all animation information.

TIP If you need to edit the character’s movement after its animation has been
plotted, simply go back to the Character Control panel > Character Controls
tab > Edit menu, and choose Plot Character > Control Rig again. When you
are done, repeat steps 2 to 3 to bake the animation back onto the character
skeleton.

Note that when you save your file, you will have not only the animated
character Pepe in your scene, but the reference skeleton as well. You could
delete the skeleton from the scene or select the Pepe character and save
it to another file for import to 3ds Max, but this is not mandatory. As
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you will see, you can just as easily strip out the skeleton during the import
process to 3ds Max.

4 From the main menu, choose File > Save As, navigate to the MotionBuilder
Files folder, then in the Save File dialog, type Pepe_biped_plotted and
click Save.

Importing Animation to 3ds Max
You can choose to import the entire contents of scenes saved in MotionBuilder,
or only those elements whose names match elements in your 3ds Max scene.

The animation you import from MotionBuilder is fully editable in 3ds Max.

Import the animated character to 3ds Max:

1  Start 3ds Max. On the Quick Access toolbar, click Open File. If the
scene from the Creating Naming Templates lesson is still open, do not
save your work.

2 Open the scene file called Pepe_biped-PEPE.max.

3  On the main toolbar, click Select By Name.

The skeleton bones have the same PEPE prefix as the character you
exported to MotionBuilder.

4  Close the dialog. From the Application menu, choose Import.

5 On the Select File To Import dialog, navigate to the MotionBuilder Files
folder and open Pepe_biped_plotted.fbx.
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6 On the FBX Import dialog, scroll down to the Include rollout.

The File Content list displays Add And Update Scene Elements by default.
If left as is, this setting would import not only the Pepe character, but
the yellow reference skeleton as well.

7 From the File Content list, choose Update Scene Elements.

This option updates only the scene elements in 3ds Max that share the
same name as those in the imported file. No new elements are imported.
If you were importing animation from MotionBuilder to a new 3ds Max
scene, you would instead choose the Add To Scene option.

8 Click OK, then OK again to clear the message informing you that the
rotation limits of the characters in MotionBuilder and 3ds Max differ.

This disparity will not affect the animation.

9 Scrub the timeline to see how the MotionBuilder animation has been
baked into the Pepe character bones.
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Fine-tune the animation in 3ds Max:

1 Go to frame 0 and zoom in and rotate around Pepe’s hands.
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Character fingers are too close to the thighs

2  Expand the Motion Panel > Layers rollout and click Create
Layer to create a new layer of animation.

3  On the main toolbar, click Select By Name and select the PEPE R
Hand bone.

4 Right-click in the viewport, and from the quad menu, choose Move.
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5 Drag the hand away from Pepe’s body on its X and Z axis.

6 Expand the Key Info rollout and click Set Key.

7 Expand the Track Selection rollout and click Opposite to select Pepe’s
right hand.

8 Repeat steps 5 and 6, then replay the animation to see the result of your
edits.

Summary

In this series of lessons, you took a biped skeleton with a mesh called Pepe
and exported it to MotionBuilder as an FBX file. There, you characterized the
biped bones using templates and scripts, and animated the Pepe skeleton by
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plotting it to another skeleton whose own movements were derived from
motion capture. Then you baked the animation back to Pepe’s control rig,
made a few adjustments so that the motion better fit his cartoon-like
dimensions, and baked the animation back into Pepe’s skeleton for export to
3ds Max. Finally, you fine-tuned Pepe’s body motion using the fully-preserved
Biped edit functionality.
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