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Chapter 1

Installing Maya FBX 
Plugins 
Overview
FBX plugins are used by Maya to import, export, and 
convert files using the .fbx file format. This document 
describes how to install Maya FBX plugins on 
Windows® and Mac® OS X systems.

Plugins for Maya are available for use with Windows 
2000/XP and Mac OS X. 

Manual Installation
In order for your 3D software to use these plugins, you 
must manually move these files into the proper 
directories.

This section describes the naming conventions, 
supported software versions, and the installation 
process for manually installing, disabling, and 
removing the FBX Plugin for Maya.

! Note:
Maya FBX plugins are available for Windows, 
Mac OS X and Linux.

Maya FBX Plugin Naming Conventions

Maya FBX plugins conform to the following naming 
conventions:

Windows: 
fbxmaya60.mll
Mac: 
fbxmaya60.lib
Linux: 
fbxmaya60.so

You can change a plugin’s name as long as the 
extension (for example .mll, .so, or .lib) stays the 
same.

Supported Maya Versions

The FBX Plugins are only available for Maya 6.0. 
These plugins will not run correctly on other versions 
of Maya.

Windows: 
fbxmaya60.mll
Mac: 
fbxmaya60.lib
Linux: 
fbxmaya60.so

Installing the Maya FBX Plugin on 
Windows
1. Locate the fbxmaya60.mll file.

By default, the plugin files are copied to 
C:\Alais\FBXPlugins<fbxver>\Maya60 folder.

2. Verify that the version number of the plugins 
matches the version of Maya installed on your 
computer. Plugins run correctly only on the version of 
Maya for which they were created.

3. Copy the file fbxmaya60.mll into the 
Maya60\bin\plug-ins\ directory.

4. Start Maya and navigate to 
Window>Settings/Preferences>Plug-in Manager.

5. Activate the Loaded column on the fbxmaya60.mll 
to load it.

6. Activate Autoload to have Maya load the FBX plugin 
automatically at start-up.
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Disabling the Maya FBX Plugin in Windows

1. Launch Maya.

2. Select Windows>Settings/Preferences>Plug-in 
Manager.

3. Locate the fbxmaya60.mll, fbxmaya60.so, or 
fbxmaya60.lib plugin in the list and disable it.

4. Exit Maya.

Removing the Maya FBX Plugin from 
Windows
1. Exit Maya.

2. Go to the FBX Install shield.

3. Locate the Maya FBX plugin.

4. Disable the Maya option.

Installing the Maya FBX Plugin on 
Mac OS X
5. Double-click the package icon to start the 
installation.

6. Enter your login password to continue the 
installation when prompted.

! Note:
You must obtain administrator privileges to 
continue installation.

The Welcome window appears.

7. Click Continue to start the installation process.

8. Select a destination disk for your application to be 
installed and click Continue.

9. Click Install (or Upgrade). A progress bar indicates 
the time remaining of the installation; when the 
progress reaches 100%, the Finish button is 
activated. 

10. Click Finish to exit the installation program.

! Note:
The plugin is installed in the following directory: 
<Macintosh 
Drive>/User/Shared/Alias/maya/6.0/plug-ins

11. Start Maya and navigate to 
Window>Settings/Preferences>Plug-in Manager.

12. Activate the Loaded column on the fbxmaya60.lib 
to load it.

13. Activate Autoload to have Maya load the FBX 
plugin automatically on start-up.

Removing the Maya FBX Plugin from 
Mac OS X
1. Exit Maya

2. Locate the fbxmaya<ver>.mll plugin. This file is 
found in the <Macintosh 
Drive>/User/Shared/Alias/maya/6.0/plug-ins 
directory.

3. Delete the fbxmaya<ver>.mll file

Installing the Maya FBX Plugin on 
Linux
1. Type the following command to install the 
distribution:
% rpm -U fbxmaya60-5.2.0.i386.rpm
The plugin is installed to the following directory:

/usr/aw/maya60/bin/plug-ins/

! Note:
You must obtain administrator privileges to 
continue installation.

2. Start Maya and navigate to 
Window>Settings/Preferences>Plug-in Manager

3. Activate the Loaded column on fbxmaya60.so to 
load it.

4. Activate Autoload to load the FBX plugin in Maya 
automatically at start-up.

Removing the Maya FBX Plugin from Linux

1. Log into your system as root

2. Uninstall the distribution by entering the following 
command:
% rpm -e fbxmaya60
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Renaming Plugins
Renaming Plugins
All plugins can be renamed as long as you do not 
change the file extension. However, it is only 
advisable to rename files when you want to keep more 
than one version of the FBX Plugins in the same 
directory.

If you choose to backup your files, all files with the 
same name as those you are installing should be 
renamed with the extension .FBX_BAK.

! Note:
It is recommended that you always remove old 
versions of FBX plugins before installing newer 
versions.
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Chapter 2

Maya Plugin
Overview
This document shows you how to export .fbx files 
from Maya, and how to import .fbx files into Maya.

This document includes important information 
regarding the Maya features supported by this version 
of the FBX plugin and MotionBuilder software.

! Note:
For information on supported features between 
Maya and other 3D software (cross-package 
support), consult the Alias website 
(www.Alias.com).

This document also includes tips on the Maya 
workflow and a section on scripting using the Maya 
MEL commands.

Using the Maya Plugin
This section describes how to export models from 
Maya using the .fbx file format, and how to import .fbx 
files into Maya.

! Note:
Activating more than one .fbx import/export 
plugin at a time confuses Maya, producing 
undetermined results. To correct this problem 
you should restart Maya, making sure that only 
one plugin is loaded at the beginning of your 
next Maya session.

Exporting from Maya

! Note:
MotionBuilder software does not support 
negative and non-uniform scaling.

To export from Maya:

1. Select File>Export All. A file browser appears.

2. Select FBX as the file type.

3. Use the file browser to locate where you want to 
export your .fbx file.

4. Type the name of the .fbx file in the file name field, 
and click Ok. The FBX Exporter window appears (fig 
2-1). 

5. Activate the Constant key reducer filtering option, 
if applicable.

6. Activate the Export rotate axis and joint orients as 
pivot nodes option, if applicable.

fig 2-1: FBX Exporter window



! Note:
We recommend that your hips joint have only 
rotate attributes values. Any values in the joint 
orientation cause the creation of pre- bones in 
MotionBuilder software. The 
auto-characterization of this joint is dropped into 
the Character Special node (hips translation). 
This creates a smooth transition back to Maya.

7. Enter the desired frames per second (fps) in the 
Resampling frame rate field.

8. Activate the Export Hard Edges option if 
applicable.

9. Activate the Embed Textures option if you want to 
embed your textures with the file.

! Note:
When creating Blend Shapes, always set the 
Timeline to the first frame, especially if there is 
animation. The Blend Shapes must stay at zero 
before export.

Importing .fbx Files into Maya

To import .fbx files into Maya:

1. Select File>Import. A file browser appears.

2. Select FBX as the file type.

3. Use the file browser to locate the .fbx file that you 
want to import. The FBX Importer window appears (fig 
2-2).

4. Choose whether the .fbx scene is to be merged in 
the current scene or imported in an empty scene by 
activating/disabling the Merge option.

5. Activate any of the options that apply to your 
scene.

! Note:
We recommend that your hips joint have only 
rotate attributes values. Any values that are in 
the joint orientation causes pre- bone creation in 
MotionBuilder. The auto-characterization of this 
joint is dropped into the Character Special node 
(hips translation). This creates a smooth 
transition back to Maya.

6. Enter the desired frames per second (fps) in the 
Resampling frame rate field.

7. Click Import.

fig 2-2: FBX Importer window
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Maya Workflow Tips
The following sections contain information to help 
streamline the workflow between Maya and 
MotionBuilder software.

General Process

Follow this general workflow:

1. Create the model, textures (UV file texture), and 
skeleton in Maya. 

2. Bind the model and edit the weight of the CVs or 
Vertices in Maya.

3. Export all (FBX). 

4. Open the file in your MotionBuilder software. 

5. Animate the character. 

6. Transfer all the animations (plot animation) to the 
character bones. 

7. Import this new file back into the ORIGINAL Maya 
scene.

Creating Models in Maya

MotionBuilder software supports the following:

MotionBuilder software does not support the 
following:

• Verify that the Normals are pointing outward. 
MotionBuilder software does not support reverse 
normals.

• Curves show up as nulls (locators) in MotionBuilder 
software.

• If the rotation or scaling pivots are changed in the 
original Maya scene between the time of the .fbx 
import and export, the animation curves applied are 
resampled.

! Note:
Avoid using groups. Instead, parent the 
geometries. Groups create nulls (locators).

Creating Textures in Maya

Use File Textures and Polygon projections. Bake 
(Hypergraph>Convert to File Textures) any native 
Maya textures (Grid, Ramp…), Layer Shaders and any 
File textures that have a UV rotation (Place 2D texture 
node). 

NURBS and 
Polygons

Supported. Hard and smooth 
edges supported as well.

Blend Shapes Do not delete the targets until the 
file is transferred into your 
software. 

Note that the plugin only support 
BlendShapes that have a 
"Deformation Order" that is 
upstream, that is, Before, 
FrontOfChain or Default

Pivots Supported.

Lights Intensity value scaling is 
supported, as well as import 
support for intensity animation 
and color curves.

Export support for intensity 
animation.

Cameras Default export specs, curves, 
and FOV are supported.

Import for squeeze ratio, near/far 
plane value, aperture width, 
height, FOV, and focus length are 
supported.

Trims or NURBS 
Booleans

Converts them into Polygons 
(Modify > Convert > NURBS to 
Polygons).

Subdiv to 
Polygons (Maya 
3.0)

If you are using Subdiv Surfaces, 
use the Extract Vertices 
command (> Subdiv. Surfaces), 
not the Tessellate command (> 
Subdiv. Surfaces), to convert 
Subdivs into Polygons.

Subdiv to 
Polygons (Maya 
4.0)

Use the Subdiv to Polygons 
command (Modify > Convert).

Deformers 
(Lattices, 
Sculpt...)

Only Clusters are supported. 
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In MotionBuilder software, the UV rotation has a 
‘corner’ pivot instead of Maya’s ‘center’ pivot. 

Textures Appear “Stretched”: If you see stretched 
textures in your software, set the following line to ‘No’ 
in the configuration text file:
UseStripForMesh = No ; Available option 
Yes, No. 

Creating and Binding Skeletons in Maya
MotionBuilder software supports the following:

MotionBuilder software does not support the 
following:

Animating in Maya
MotionBuilder software supports the following:

FCurves with unsupported interpolation or 
Transformation FCurves on an object using rotate 
axes or joint orientation (whose values are located in 
the Attributes editor) are resampled at the rate set in 
the Export dialog box.

Exporting Files in Maya
Export all (>File) commands using the .fbx format. 
This also saves an .mb or .ma file as a backup file.

Opening Maya Files in MotionBuilder 
Software
Animate your character using your MotionBuilder 
software (Control Sets, Constraints, motion capture 
data, and so on). Transfer all the animations 
(character>plot animation) to the character’s bones.

Saving Maya Scenes in .fbx Format.
Import this new file in the original Maya scene (Merge 
Back). 

! Note:
During exclusive merge, the .fbx import does not 
duplicate any elements that already exist; it only 
transfers the animations on these nodes. 

New nodes are created new nodes if they do not exist 
already in the original Maya scene. 

MotionBuilder software does not support the 
following:

! Note:
During the Merge Back of a node, TRS animation 
is resampled when rotation pivot, scale pivot, 
rotate axis or joint orientation occurs.

Smooth/Rigid 
binding

Supported.

Modified 
Weighting

Supported.

IK Spline and 
Handle

To transfer IK animations, 
transfer the IK animation to the 
joints in Maya, using the Bake 
Simulations (Edit > Keys).

Expressions, 
Driven Keys and 
Constraints

If you wish to transfer animations 
created by these tools, transfer 
the animations in Maya to the 
proper node using the Bake 
Simulations command 
(Edit>Keys).

Flexor 
deformations

Do not appear.

Joint scaling Do not scale any bones.

Character Set Do not use Character Set in 
Maya.

FCurves 
(channels)

For the clamped interpolation and 
weighted tangents, FCurves are 
resampled at the rate set in the 
Export dialog box.

Pivots Supported.You can only retain the 
current scene’s pivot information.

Cubic 
interpolation 
with TCB 
tangents

These curves are resampled at 
the frame rate selected in the 
Import dialog box.
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If you are merging back Blend Shape animations, you 
must not have a keyframe on the Blend Shape Input 
attribute of the Blend Shape base node at any time 
point on the timeline in Maya before importing the .fbx 
file.

Flexors and Other ‘Unsupported’ 
Features
Working with Lattices: If the binding of your character 
is done through Lattices, only export/import the 
skeleton of your character. 

Start with an ‘extreme motion’ take to cover most of 
the deformations so you do not have to verify the 
deformations on every take. This lets you to work only 
with a skeleton import/export.

Supported Maya Features
The following table lists the Maya import and export 
features supported by MotionBuilder software:

Additional Features and 
Enhancements
This section lists the additional features and 
enhancements found in version 6.0 of the FBX 
plugins for Maya.

General

Fixed the problem with FCurve behavior when tangent 
types are set to clamped.

Known Limitations
This section lists the fixed bugs and the known 
limitations in the 6.0 version of the Maya FBX plugin.

Constant Key Reducer
In versions prior to 5.2, the Constant Key Reducer 
option was active regardless of whether it was 
activated or disabled in the Export dialog. 

Whenever you exported, the keys in the Maya 
animation would be reduced.

This option has been fixed in v6.0 of the FBX Maya 
Plugin. You may now disable the Constant Key 
Reducer in the Export dialog.

Other Limitations
The following are other known limitations of the Maya 
plugin:

The Visibility FCurve adjusts itself to contain only 0 or 
1 values. Also the FCurve is converted to Constant 
(step) interpolation. Therefore, any value above 0 is 
considered as 1 (visible) and any value below or equal 
0 is considered 0 (invisible).

Exporting .fbx files 
for MotionBuilder 
software

Meshes, NURBs, and 
skeletons. Cluster 
deformations and skeleton 
cluster deformations are 
supported.

Only simple materials are 
supported: Phong. Texture 
mapping is converted as UV 
Maps. Placement and 
Rotation is supported. 
Procedural textures are not 
supported. Blend Shape 
deformations are supported, 
provided that the target is 
not deleted.

Blend Shape channels must 
already have at least one key 
when an .fbx file is merged 
back. 

Rotation pivot and scaling 
pivot of models must be 
exactly the same before 
exporting.

User attributes are 
supported.

Importing .fbx files 
into Maya

Meshes, NURBs, and 
Skeletons created by Maya 
are supported, as well as 
Material, Textures, and 
animations. 

User attributes are 
supported.

Same Node Names Supported.
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When exporting, if the Tangent type is Slow or Fast, 
the plugin resamples objects. Objects are also 
resample if the OutTangent is Linear and the 
InTangent is different, or the OutTangent is Flat, 
Smooth, or Fixed and the InTangent is not Flat, 
Smooth or Fixed.

Nurbs display precision is supported and exported as 
StepU and StepV parameters in MotionBuilder 
software. Both U and V are assigned the same value; 
as in Maya, its value is unique. Values of the Precision 
parameters are clamped to a maximum of 15 (The 
software’s limit).

When importing, the maximum value between the 
StepU and StepV is used.

When Shape objects (used in the Blend Shape) have 
the same name as other objects in the scene, the 
name clashing solver can behave erratically. Avoid 
this by using different names for models.

Maya's AMBIENT lights are not supported for now and 
are exported as NULL objects. Area lights are 
exported as a Point light.

The Maya plugin is only capable of processing 
upstream Blend Shape deformers. It processes the 
Default, Front of Chain, and Before modes. 

Added the import of materials assigned by Control 
point and Polygon vertex. Maya allows coloring of the 
Vertices but does not assign them full materials. 
Also, the material shaders created when importing 
are always the Phong type.

The material is propagated to the polygon sharing a 
given point. The algorithm used has its own 
limitations:

• It can be very slow, as each polygon has to be 
scanned for each material defined. 

• The assigned material is not necessarily the right 
one since the material that is used the most is taken 
from among the vertices of the polygon. However, if 
there is no majority, the material of the first control 
point is used for the whole face. 

• There is no interpolation across the surface. 

The renaming strategy is used for two scenarios:

• Multiple instances have the same name. A 
symbolic code is used to keep coherence between 
the two algorithms. Although the plug-in cannot write 
names in the form name (x), it still able to read them. 

The new suffix is then:  _ncl1_X, where X is the 
instance number. 

• Upper/lower case conflicts. In this case the suffix 
is more complex since it must keep track of which 
character was/is upper/lower case in order to be 
able to convert back on import/merge. 

The following suffixes are used to indicate the case:

Indicates case _ncl2 

Marks 
characters that 
were originally 
upper case and 
have become 
lower case

_ulXXXX 

Marks 
characters that 
were originally 
lower case and 
have become 
upper case:

_luXXXX Where XXXX is an integer 
number that represents the 
character position in the string 
(bitwise). For example, _ul5 
indicates that the first and third 
characters in the string have 
been changed from upper to 
lower case. A suffix can be made 
of the combination of _ul and _lu 
sub-suffixes.
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Chapter 3

Maya MEL Scripting
Overview
This chapter contains the command required for 
scripting with Maya Mel commands.

All of the plugin’s MEL commands begin with the FBX 
prefix. They display error messages on the script 
console when they are used incorrectly. The MEL 
commands that are registered by the plugin are listed 
in the Plugin Manager information dialog box.

Maya MEL Scripting
To take advantage of the following MEL commands, 
you must have the Maya plugin installed on your 
computer.

FBXBatchDialog Box
Display the Batch dialog box. The Batch dialog box 
contains all import controls and export controls 
displayed by the Import dialog box and the Export 
dialog box, plus a check box to enable or disable 
those user interfaces. 

The Batch Dialog box must be opened from the script 
editor. Since you must use this MEL command to 
disable the import/export user interfaces, you can 
call it again when it's time to re-enable the 
import/export user interfaces. 

FBXResamplingRate -v [float]
Set the rate at which the exporter produces 
keyframes when it needs to resample data. 

Resampling is needed when:

• Non-XYZ rotation orders are present.

• The interpolation of the Maya animation curve 
cannot be perfectly represented by curves in 
MotionBuilder, MotionBuilder Professional, Alias 
MoCap, and Alias OnLine. 

FBXExport -f [filename]
Export the specified file. If FBXExportShowUI is true, 
the Export dialog box is shown.

FBXExportShowUI -v [true|false]

FBXImport -f [filename] -t [take 
index]
Import the specified file. If FBXImportShowUI is true, 
the Import dialog box is shown. The file imported is 
the one accessible for take querying after the 
execution of the command.

True Displays the Export dialog box 
each time user clicks File > 
Export or uses the FBXExport 
MEL command.

False Never displays the Export dialog 
box. The only way to have the 
Export dialog box displayed again 
is to set this flag to “true” by 
using this MEL command or by 
checking the appropriate check 
box in the Batch dialog box.
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FBXExportApplyConstantKeyReducer 
-v [true|false]

FBXImportMode -v 
[exmerge|add|merge]
There are three possible states:

FBXImportMergeBackNullsPivots -v 
[true|false]

! Note:
When the import mode is set to exmerge or 
merge this option is automatically set to True.

FBXImportShowUI -v [true|false] 
In the Import dialog box, there is no check box for this 
flag. It is important to understand that once 
FBXImportShowUI is turned off (false), the user 
interface does not appear until FBXImportShowUI is 
set to true. There are two possible states:

True FBX animation FCurves are 
filtered through a Constant Key 
reducer. This eliminates constant 
keys on a FCurve and helps to 
reduce the size of resampled 
FCurves, especially Scale.

False If you want keys to occur at a 
defined time, even if they are 
constant and appear to be 
unnecessary, set the flag to 
False. This ensures that the 
animation data is not filtered.

Exmerge Merges the imported .fbx file to 
the current scene in the following 
way: 

Nodes of the same name and 
nature will have only their 
animation curve replaced. No 
new nodes are created.

Add A new scene is created prior to 
the file import. 

Merge Merges the imported .fbx file to 
the current scene in the following 
way: any node without its 
equivalent in the scene is 
created. Nodes with the same 
name but not of the same nature, 
for example, sphere and bone, 
are replaced. Nodes with the 
same name and nature only have 
their animation replaced.

True The rotation transformation of 
the null (or joints) elements in the 
hierarchy that are used as pre 
rotation and post rotation are 
respectively assigned to the joint 
orient and the rotate axis of the 
original node. 

The pre rotation and post rotation 
node are then deleted.

The look-up is done on a name 
basis since the pre rotation 
node's name contains the __Pre_ 
suffix while the post rotation 
node's name will have a __Post_ 
suffix.

This function should be used 
when the scene was exported 
using the 
FBXExportReplacePivotsByNulls 
script set as True.

True Displays the Import dialog box 
each time user clicks File > 
Import or uses the FBXImport 
MEL command.

False Never display the Import dialog 
box. The only way to have the 
Import dialog box displayed again 
is to set this flag to “true” by 
using this MEL command or by 
checking the appropriate check 
box in the Batch dialog box.
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FBXRead -f [filename]
Read the specified .fbx file without actually importing 
anything into Maya. Instead, the file is stored in a 
buffer. Use this command for take querying. 

Once read or imported, you can use the commands 
FBXGetTakeCount, FBXGetTakeName, 
FBXGetTakeIndex for take querying.

Make sure the file you are reading matches an 
existing file name. The file in the buffer is destroyed 
if a user attempts to read or import a non-existent file. 

FBXGetTakeCount
Returns the number of takes saved in the file stored 
in the file buffer. You can load a file into the file buffer 
using the FBXRead command.

FBXGetTakeIndex [take name]
Returns the index of the first take named as the 
parameter in the take array. This command works on 
the file stored in the file buffer. You can load a file into 
the file buffer using the FBXRead command.

FBXGetTakeName [index]
Returns the name of the take at the specified index 
in the take array. This command works on the file 
stored in the file buffer. You can load a file into the file 
buffer using the FBXRead command.

FBXGetTakeComment [index]
Returns the comment attached to the take at the 
specified index in the take array. This command works 
on the file stored in the file buffer. You can load a file 
into the file buffer using the FBXRead command.

FBXGetTakeLocalTimeSpan [index]
Returns the local start and local stop time of the take 
at the specified index in the take array. This command 
works on the file stored in the file buffer. You can load 
a file into the file buffer using the FBXRead command.

FBXGetTakeReferenceTime Span 
[index]
Returns the reference start and reference stop time 
of the take at the specified index in the take array. 
This command works on the file stored in the file 
buffer. You can load a file into the file buffer using the 
FBXRead command.

FBXImportConvertDeformingNullsToJ
oint -v [true|false]
As Maya does not support null elements in a bone 
hierarchy, when this option is set to true, all faulty 
nulls elements found are transformed into joints 
nodes.

FBXImportHardEdges -v [true|false]
When set to true, all vertices located at the same 
exact position are merged back as a unique vertex. 
The plug-in then finds out if the edges connected to 
each vertex are hard edges or smooth edges, 
depending on their normals.

This function should be used when 
FBXExportHardEdges was set to True on export.

FBXExportReplacePivotsByNulls-v 
[true|false]
When set to true, all joint orient and joint rotation axis 
transformation are converted to null (or joints) 
elements in the hierarchy. The joint orient becomes a 
pre- rotation node and will have the suffix __Pre_ in its 
name. The rotation axis becomes a post rotation 
node and has the suffix __Post_ in its name.

For example, if you set a joint orient value and a rotate 
axis value other than zero, the resulting hierarchy 
contains a new node taking the joint orient 
transformation. The joint and new node then take the 
rotate axis transformation. 

When exporting your skeleton hierarchy using this 
mode, and importing back your animated hierarchy 
with the "FBXImportMode -v exmerge" option, your IK 
setup is unchanged.

This function works properly for skeleton hierarchy 
only.
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FBXExportEmbeddedTextures -v 
true|false
When The value is set to true all textures are saved 
in the FBX file. This is the same as activating the 
Embed Textures option in the FBX Exporter window.

FBXExportHardEdges -v [true|false]
When set to true, all vertices in the scene's meshes 
are duplicated for each polygon connected to them. 
The vertices’ normals are set accordingly, depending 
on whether they are connected to a hard or smooth 
edge.

This function allows MotionBuilder to display hard 
edges.

A warning is issued if two vertices are located exactly 
at the same position as this may cause unpredictable 
results when FBXImportHardEdges is set to true.
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