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Welcome to Autodesk
Navisworks Freedom 2010

Autodesk Navisworks Freedom 2010 software is the free viewer for NWD files.
Autodesk Navisworks products can combine design data created with a variety of
design tools, and then publish the entire model to NWD format including
properties, comments, viewpoints and 4D playback. Navisworks Freedom and the
compact, secure, and streamable NWD file format give all project stakeholders
access to the whole-project view. Quality is improved by enabling widespread
real-time experience of entire design projects before they are real.
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What Is New in This
Release?

Autodesk Navisworks Freedom 2010 contains many new features and
enhancements.

User Interface

Changes to the Autodesk Navisworks Freedom 2010 interface more closely align
the product with Autodesk standard interface and navigation toolsets.

B ViewCube. The ViewCube is an on-screen widget, shaped like a cube, that
rotates as you orbit your 3D scene and provides you with feedback about your

current camera viewing angle in relation to the model world. See “ViewCube”
on page 73.

B SteeringWheels. SteeringWheels are task-based floating tool palettes that travel
with the cursor to minimize tool access time. SteeringWheels provide access
to different navigation tools grouped into various wheels depending on the
navigation task and user skill level. See “SteeringWheels” on page 56.

=

ZOOM

£

o LA
kS e,
& *

ot

PAMN

ORBIT

f\

AMIMIY

(4}

B Button menus. In Autodesk Navisworks, some toolbar buttons exist in
mutually-exclusive groups of which only one at a time can be selected. These

buttons are now grouped under drop-down menus to improve accessibility
and decrease screen clutter.

B Artificial horizon. You can now place your model against a fixed artificial
horizon so that it appears more realistic and does not float in mid air. The
background of the 3D scene is split across the horizontal plane giving the
effect of a sky and the ground. The resulting artificial horizon gives you an
indication of your orientation in the 3D world. See “Select Background Effect”
on page 92.



Communication Center

The Communication Center @ allows the Autodesk Navisworks and Autodesk team to notify you of product-related updates
and announcements.

See “Use Communication Center” on page 5.

Miscellaneous Enhancements

B Autodesk Navisworks Freedom 2010 is available for full 64-bit installation.

B Manual override option allows you to specify the distance of Near and Far Clipping Planes. See “Use Culling” on page 96.
B When entering invalid values in the Options Editor, you are notified of the error.
|

Upgrades to the Autodesk Navisworks rendering engine (LADS) provide improved support for PNG transparencies and
improved rendering consistency.
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How to Get Assistance

There are various ways to find information about how to use this program, and
multiple resources are available.

Use Communication Center

Communication Center provides up-to-date product information,
software updates, product support announcements, and other
product-related announcements.

Overview of Communication Center

Communication Center provides up-to-date product information,
software updates, product support announcements, and other
product-related announcements.

Communication Center is an interactive feature that must be
connected to the Internet in order to deliver content and
information.

Each time Communication Center is connected, it sends your
information to Autodesk so that you receive the correct information.
All information is sent anonymously to Autodesk to maintain your
privacy.

The following information is sent to Autodesk:

Product name (in which you are using Communication Center)
Product release number

Product language

Country/region (specified in the Communication Center settings)

Your subscription contract number (if you're a subscription
customer)

Autodesk compiles statistics using the information sent from
Communication Center to monitor how it is being used and how
it can be improved. Autodesk maintains information provided by
or collected from you in accordance with the company's published
privacy policy, which is available on http://www.autodesk.com/privacy.

Whenever new information is available, Communication Center
notifies you by displaying a balloon message below the
Communication Center button on the InfoCenter box.


http://www.autodesk.com/privacy

Communication Center provides the following kinds of announcements:

B Product Support Information. Get breaking news from the Product Support team at Autodesk, including
when Live Update maintenance patches are released.

B Subscription Announcements. Receive subscription announcements and subscription program news, as well
as links to e-Learning Lessons, if you are an Autodesk subscription member (available in countries/regions
where Autodesk subscriptions are offered).

B Articles and Tips. Be notified when new articles and tips are available on Autodesk websites.

B Live Update Maintenance Patches. Receive automatic notifications whenever new maintenance patches are
released from Autodesk.

B Featured Technologies and Content. Learn more about third-party developer applications and content.

You can customize the items that display on the Communication Center panel. For more information, see
“Specify Communication Center Settings” on page 6.

To open Communication Center

B Click the Communication Center =" | button on the Standard toolbar in the upper right-side of the application.

£ Menu: Help » Communication Center

To receive new information notifications

-
B Click the link in the balloon message below the notification = icon on the Status bar.

To turn off Balloon Notifications

-
B Right-click the notification = jcon on the Status bar, and click Disable Balloon Notifications.

Specify Communication Center Settings
You can specify Communication Center settings in the Options Editor.

In the Options Editor, you can specify the following settings:

B General. Your current locations, how often to check for new online content, and maximum age of the
displayed articles.

B Autodesk Channels. Channels to display in the Communication Center panel as well as the number of articles
to display for each channel.

B Balloon Notification. Notifications for new product information, software updates, and product support
announcements. Also, you can customize the display time of the balloon.

To specify general settings for Communication Center
1 Open the Communication Center panel, and click Options.
2 In the Options Editor, expand the General node, and click the Communication Center option.

3 On the Communication Center page, select the country in which you are working. This is used for tailoring
location-specific Communication Center content.

4 Use the Check for New Online Content drop-down list to specify the desired frequency. By default,
Communication Center checks for new content every 4 hours.

5 To remove old content, select the Hide Old Content check box, and use the After box to set the number of
days after which old content is hidden. The default value is 14 days.

6 Click OK.
6 | Chapter 2 How to Get Assistance



To specify the channels to display in the Communication Center panel

1
2

Open the Communication Center panel, and click Options.

In the Options Editor, expand the General node, expand the Communication Center node, and click the
Autodesk Channels option.

On the Autodesk Channels page, select the Subscribed check boxes for all channels you want to display.
Click OK.

To specify balloon notification settings

1
2

Open the Communication Center panel, and click Options.

In the Options Editor, expand the General node, expand the Communication Center node, and click the
Balloon Notifications option.

On the Balloon Notifications page, use the Enable Balloon Notifications check box to turn balloon notification
on/off.

In the Display Duration box, enter the number of seconds to set the length of time for balloon notifications
to display.
The default value for the balloon display time is 5 seconds.

Click OK.

Use the Help System

You can get much more benefit from the Help system when you learn how to use it efficiently.

The Help system contains complete information about using this program. In the Help window, you use the left
pane to locate information. The tabs above the left pane give you several ways for finding the topics you want
to view. The right pane displays the topics you select.

Find Information in Help

The tabs on the left side of the Help window provide different methods for finding information.

To locate a specific word or phrase in the current topic, click in the topic text and press the CTRL+F keys.

Contents Tab

Presents an overview of the available documentation in a list of topics and subtopics.
Allows you to browse by selecting and expanding topics.

Provides a structure so you can always see where you are in Help and quickly jump to other topics.

Index Tab

Displays an alphabetical list of keywords related to the topics listed on the Contents tab.

Accesses information quickly when you already know the name of a feature, command, or operation, or
when you know what action you want the program to perform.

Search Tab

Provides a keyword search of all the topics listed on the Contents tab.
Accepts the Boolean operators AND (+), OR, NOT (-), and NEAR.
Accepts the wild cards *, ?, and ~.

Allows you to perform a search for a phrase when the phrase is enclosed in double quotes.

Use the Help System | 7



B Displays a ranked list of topics that contain the word or words entered in the keyword field.

B Arranges the results alphabetically by title or by location if you click on the Title and Location column
headings.

Use Searches
Use the Search tab to find relevant topics based on keywords that you enter.
The basic search rules are as follows:
B Type your keywords in uppercase or lowercase characters; searches are not case-sensitive.
B Search for any combination of letters (a-z) and numbers (0-9).

B Do not use punctuation marks such as a period, colon, semicolon, comma, hyphen, and single quotation
marks; they are ignored during a search.

B Group the elements of your search using double quotation marks or parentheses to set each element apart.

Use Wild Card Characters
You can use the following wild card characters in any keyword:

Symbol Description

* Replaces one or more characters when
used at the beginning, middle, or end of
a word. For example, “*lish”, “p*lish”, and
“pub*” will all find “publish”. Also, “an-

" ou

no*” will find “annotative”, “annotation”,

" ou

“annoupdate”, “annoreset”, and so on.

? Replaces a single character. For example,
“cop?” will find “copy”, but not “copy-
base”.

~ Expands the tense of the word at the be-
ginning or end of a word. For example,
“plotting~" will find “plots”, “plotted”,
and so on. Also, “~plot” will find “preplot”,
“replot”, and so on.

Search for Phrases

When searching for a phrase, use double quotation marks (" ") to enclose words that must appear next to each
other in the specified sequence. For example, enter "specifying units of measurement" to find only topics with
all those words in that order. If you don't use the quotation marks around that text, Help finds all topics containing
any one of the listed words, that is, all topics containing "specifying", all topics containing "units", all topics
containing "of", and all topics containing "measurement".

TIP If you can’t find the information you need through a search, try using the Contents tab.

Use Boolean Operators

With the AND, OR, NOT, and NEAR operators, you can precisely define your search by creating a relationship
between search terms. The following table shows how you can use each of these operators. If no operator is
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specified, AND is used. For example, the query spacing border printing is equivalent to spacing AND border AND
printing.

Search for Example Results

Both terms in the same  "tree view" AND “palette”  Topics containing both the
topic words "tree view" and "palette"

Either term in a topic viewpoint OR animation  Topics containing either the
word "viewpoint" or the word
"animation" or both

The first term without ~ nwd NOT nwc Topics containing the word
the second term "NWD," but not the word "NWC"
Both terms in the same  user NEAR menu Topics containing the word
topic, close together "user" within eight words of the

word "menu"

NOTE The |, &, and ! characters do not work as Boolean operators. You must use AND (also +), OR, and NOT (also
).

How Help Topics Are Organized

Most topics in this Help system have three tabs above the right pane of the Help window. The tabs display
different types of information.

B Concept tab. Describes a feature or function. When you click the Concept tab, the Help Contents list in the
left pane of the Help window expands and highlights the current topic. The Contents tab displays the structure
of the Help on that topic. You can easily display nearby topics by clicking them in the list.

B Procedure tab. Provides step-by-step instructions for common procedures related to the current topic. After
displaying a procedure, you can click the Procedure tab to redisplay the current list of procedures.

B Quick Reference tab. Lists reference information related to the current topic.

When you click a different tab, the topic remains the same. Only the type of information displayed—concept,
procedures, or quick reference links—is different.

Concept Tab Organization

In a Concept tab, there are two types of information that may be displayed: navigation text and destination text.
Navigation text displays links with short descriptions. The purpose of navigation text is to guide you step-by-step
to the information that you need. The links on navigation pages lead to additional navigation pages deeper in
the Help structure until you come to a destination page. Each link is designed to provide you with more detailed
information.

Procedure Tab and Quick Reference Tab Organization

As you navigate deeper into the Help structure on the Contents tab, the corresponding information on the
Procedure tab and on the Quick Reference tab becomes more specific, and the number of entries displayed on
each of these two tabs decreases.

Print Help Topics
The quickest way to print the current topic is to right-click within the topic and click Print.
The Print button on the Help toolbar provides these print options:
B Print the selected topic (recommended)

B Print the selected heading and all subtopics
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NOTE When you select the second option, you may get numerous printed pages, depending on how many subtopics
the currently selected topic contains.

To print a Help topic
1 Display the topic you want to print.
2 Right-click in the topic pane. Click Print.
3 In the Print dialog box, click Print.

To print a selected heading and all subtopics

—

Display the topic you want to print and make sure that the Contents tab is displayed.
2 On the Help toolbar, click Print.

3 In the Print Topics dialog box, click Print the Selected Heading and All Subtopics.

4 Click OK.

Show and Hide the Contents Pane

Use the Hide button on the Help toolbar to shrink the Help window to a compact size by hiding the pane that
contains the Contents, Index, and Search tabs.

The compact window size is best for displaying procedures while you work.

1]

Hide

Use the Show button to expand the Help window to display the pane that contains Contents, Index, and Search
tabs. The expanded window size is best for locating and displaying conceptual and reference information.

Shiow

Get More Help

You can access several additional sources of help.

B On the Standard toolbar, use Communication Center. Display the Communication Center panel for product
updates and announcements.

B Press F1. Displays context-sensitive reference information.
B Click the Help button in many dialog boxes. Displays reference information for the dialog box.

B View the product Readme. Displays late-breaking information about this product.

Other resources help you get information about Autodesk products and assistance with your questions about
this program.

B Autodesk website. Access http://www.autodesk.com.

B Local support. Check with your dealer or Autodesk country/region office.

Learn the Product

Training programs and products from Autodesk help you learn the key technical features and improve your
productivity. For the latest information about Autodesk training, visit http://www.autodesk.com/training or contact
your local Autodesk office.
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Autodesk Authorized Training Centers

The Autodesk® Authorized Training Center (ATC®) network delivers Autodesk-authorized, instructor-led training
to design professionals who use Autodesk software. Autodesk Authorized Training Centers use experienced and
knowledgeable instructors. More than 1,200 ATC sites are available worldwide to meet your needs for
discipline-specific, locally based training.

To find a training center near you, contact your local Autodesk office or visit http://www.autodesk.com/atc.

Autodesk Official Training Courseware

Autodesk Official Training Courseware (AOTC) is technical training material developed by Autodesk. Designed
for traditional 1/2-day to 5-day, instructor-led classroom training and used by Authorized Training Centers and
other Autodesk partners, AOTC is well-suited for self-paced, stand-alone learning. The manuals cover key concepts
and software functionality with hands-on, step-by-step, real-world exercises. You can purchase AOTC from your
local reseller or distributor, or you can order it online from the Autodesk Store at http://www.autodesk.com/aotc.

e-Learning

Autodesk e-Learning for Autodesk Subscription customers features interactive lessons organized into product
catalogs. Each lesson is 20-40 minutes in length and features hands-on exercises, with an option to use a simulation
of the product or the actual application. You can also use an online evaluation tool that identifies gaps in skills,
determines what lessons will be most helpful, and gauges learning progress.

If you are a member of Autodesk subscription, you can access e-Learning and other subscription services from
within your Autodesk product.

For more information about Autodesk subscription resources, visit http://www.autodesk.com/subscriptioncenter.

Autodesk Developer Network

The Autodesk Developer (ADN) program for ADN members provides support for full-time, professional developers
who want to build software based on Autodesk products. As an ADN member, you will receive the business,
software, support, and training you need to be successful. If you are a developer, visit http://www.autodesk.com/adn.

Autodesk Consulting

Autodesk Consulting provides services that help set up processes and provide critical training that will help
increase productivity so you can capitalize on the power of your products. For more information on general
consulting, systems integration, or custom training services, visit http://www.autodesk.com/consulting.

Partner Products and Services

Autodesk works together with thousands of software partners around the world. These partners provide products
and services that enhance Autodesk products for design professionals. Visit the Partner Products & Services page
at http://www.autodesk.com/partnerproducts for a list of resources available for your Autodesk product and your
industry.

View the Product Readme

You can find late-breaking information about this software in the Readme.

It is suggested that you read through the Autodesk Navisworks Readme for information about recommended
hardware, updated installation instructions, and known software problems.

Join the Customer Involvement Program

You are invited to participate in helping guide the direction of Autodesk design software.

If you participate in the Customer Involvement Program (CIP), specific information about how you use AutoCAD
is forwarded to Autodesk. This information includes what features you use the most, problems that you encounter,
and other information helpful to the future direction of the product.
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Here is a list of the information that is automatically sent to Autodesk:

Name and version of the Autodesk product

Number of minutes you are running the software

Number of sessions that end due to stability issues

Menu actions triggered

Error conditions encountered, fatal, and non-fatal

Import/export actions (including file extension used)

Scene statistics after a load or import (number of objects, faces, vertices etc.)
Operating system name and version

System configuration information such as processor, amount of memory, and graphics card
Other Autodesk products installed

Plug-in (DLLS) installed with Autodesk Navisworks

IP address, used to identify your country or region

What the Customer Involvement Program Cannot Do
The Customer Involvement Program is committed to protecting your privacy. It cannot do any of the following:

B Collect any drawing or design data

B Collect any identity information such as name, address, or phone number

B Send you email or contact you in any other way

For additional information, click the links in the Customer Involvement Program dialog box.
Why You Should Consider Participating

The Customer Involvement Program involves you directly in telling Autodesk

B The commands and features that Autodesk should focus on

B The commands and features that are hardly ever used

B The most common problem areas
|

The hardware typically used with Autodesk Navisworks

NOTE You can start or stop your participation in this program at any time. Access to the controls is available from the
Autodesk Navisworks Help menu. In network installations, your system administrator can choose whether to make the
CIP program available or not.

To turn the CIP on or off

1 Click Help » Customer Involvement Program.

2 In the Customer Involvement Program dialog box, click a level of participation, and then click OK.
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Installation

This chapter provides information about installing and activating Autodesk
Navisworks on a workstation, as well as deploying Autodesk Navisworks from a
network location.

Quick Start to Stand-Alone Installation

This section provides step-by-step instructions about how to prepare,
and then install Autodesk Navisworks.

Prepare for Installation

To prepare for installation, you should review the system
requirements, understand administrative permission requirements,
and close all running applications.

Complete these tasks, and you are ready to begin installing Autodesk
Navisworks Freedom 2010.

System Requirements for Stand-Alone
Installation

The first task you need to complete is to make sure that your
computer meets the minimum system requirements. If your system
does not meet these requirements, problems can occur, both within
Autodesk Navisworks and at the operating system level.

Whether your Windows operating system is the 32-bit or the 64-bit
version, the version is automatically detected during installation.

See the following table for hardware and software requirements.

Hardware and software requirements

Hardware/Software Requirement

Operating system 32-Bit

Windows® XP® Professional, SP 2 or SP 3;
Windows XP Home, SP 2 or SP 3; Windows
Vista Ultimate, SP 1; Windows Vista Enter-
prise, SP 1; Windows Vista Business, SP 1;
Windows Vista Home Premium, SP 1;
Windows Vista Home Basic, SP 1
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Hardware and software requirements

64-Bit

Windows® XP® Professional, SP 1; Win-
dows Vista Enterprise, SP 1; Windows Vista
Business, SP 1; Windows Vista Ultimate, SP
1, Windows Vista Home Premium, SP 1

Web browser 32-Bit

Microsoft® Internet Explorer 6.0, SP 1 or
later

64-Bit

Internet Explorer 7.0 or later

Processor 32-Bit

AMD® Athlon®, 3.0 GHz or faster (minim-
um); Intel® Pentium® 1V, 3.0 GHz or faster
(recommended)

64-Bit

AMD or Intel EM64T

RAM 32-Bit

512 MB (minimum) 2 GB or greater (re-
commended)

64-Bit

2GB

Graphics card 128 MB, 1024 x 768 VGA, True Color
(minimum); 256 MB or greater - 1280 x
1024 32-bit color video display adapter,
True Color (recommended)

Hard disk Installation 800 MB

Pointing device MS-Mouse compliant

DVD-ROM Any speed (for installation only)
Optional hardware Open GL®-compatible 3D video card;

Printer or plotter; Modem or access to an
Internet connection; Network interface
card

Understand Administrative Permission Requirements
To install Autodesk Navisworks, you must have administrator permissions.

You do not need to have domain administrative permissions. See your system administrator for information
about administrative permissions.
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To run Autodesk Navisworks, you do not need administrator permissions. You can run the program as a limited
user.

Avoid Data Loss During Installation

The Autodesk Navisworks installation process may stop if some applications (such as Microsoft® Outlook® or
virus-checking programs) are running.

Close all running applications to avoid possible data loss.

Choose a Language

You can select a different language for installation instructions, and a language for individual product installations
in the same install process.

When you start the installation process, the installer automatically determines your operating system language.
If a supported language is detected, your install pages are displayed in that language. If you want to change that
language, you select a different one from the Installer Language list on the first page of the Installation wizard.

English (English) hd

Change the language of the installation
instructions here.

NOTE Some products may not have multi-language support at the time of product release. Additional language
support may be available later. Check http://autodesk.com/servicesandsupport for the availability of additional language
packs.

Using Language Packs

Language packs (.msi) support use of different languages in each Autodesk Navisworks product, including
exporters. Pack names start with NAVFREE_, NAVREV_, NAVSIM_, NAVMAN_, and exporters_ respectively.

NOTE You must install at least one language pack for each product.

It is possible to add additional language packs to Autodesk Navisworks products later. You can manually install
the required language packs by double-clicking on the language pack .misi file.

Language packs are located on the installation DVD and unpacked downloaded media under the x86 folder for
32-bit products and under the x64 folder for 64-bit products.

B Language packs for specific products are included in the NAVFREE, NAVREV, NAVSIM, NAVMAN, and
NWEXPORT subfolders of x86 and x64 folders.

B Language packs for specific languages are included in the en-US (English), de-DE (German), es-ES (Spanish),
fr-FR (French), it-IT (Italian), ja-JP (Japanese), ko-KR (Korean), pt-BR (Brazilian Portuguese), ru-RU (Russian)
and zh-CN (Chinese PRC) subfolders of the product folders.

So, for example, to install the 32-bit French language pack for Autodesk Navisworks Freedom, double-click

x86/NAVFREE/fr-FR/NAVFREE_LP.msi.

Configure Button

During the installation process, you choose either a typical installation (install the product with default settings),
or a customized installation. If you choose to customize, you start that process in the Review - Configure - Install
dialog box. Select the appropriate product from the drop-down list, and click the Configure button.

Prepare for Installation | 15


http://usa.autodesk.com/adsk/servlet/index?siteID=123112&id=1068444

After you click the Configure button, the following dialog boxes and options are displayed:

B Project and Site Folders - These settings can be shared across an entire project site, or across a specific project
group depending on the required level of granularity. Refer to “Why should I specify the Project Folder and
Site Folder?” on page 23.

B Select the Installation Type - Typical or Custom. If you choose a Typical installation (default settings), the
product installs the most common application features. To see which features are included in a Typical
installation, refer to “When performing a Typical installation, what gets installed?” on page 23. If you choose
Custom, you select specific features to install.

B Include a Service Pack - If a service pack is available for your installation, you can include it.
When you have completed your choices, click the Configuration Complete button. This takes you back to the

Review - Configure - Create dialog box, where you can review your selections and complete the installation
process.

ack Insta |ConﬁguraﬁonCompIete| | Cancel |

If you do not wish to make configuration changes on the Review - Configure - Install page, click Install.

Install Multiple or Bundled Products

Some Autodesk packages are comprised of multiple products or are part of multi-product bundles.

The Installation wizard for packages that are comprised of multiple products gives you the option to choose
which products you want to install.

In the Installation wizard, for packages containing multiple products, you can choose which products and
languages you want to install. During the install process, you are informed whether a copy of the software is
already installed. You are also warned if your system does not meet the minimum system requirements for the
product. Each product name is displayed on its own tabbed panel; you can configure them individually.

If you purchased a package that is a multi-product bundle, such as an educational or institutional package, you
may have a package that includes several Autodesk products. For these bundled packages, an Installer disc contains
information for all the products in the package. The Installer disc helps you install all of the products.

Install and Run Autodesk Navisworks Freedom 2010

You must have administrative permissions to install Autodesk Navisworks.

This section provides instructions for installing and activating Autodesk Navisworks for an individual user on a
stand-alone computer.

NOTE Autodesk does not recommend or support the distribution of an Autodesk product using imaging software.

Install Autodesk Navisworks

The Autodesk Navisworks Installation wizard contains all installation-related material in one place.

From the Installation wizard, you can access user documentation, change the installer language, select a
language-specific product, install supplemental tools, view support solutions, and learn about deploying your
product on a network.

B Review installation documentation before you install. It is recommended that you take the time to familiarize
yourself with the complete installation process before you install Autodesk Navisworks. You can access PDF
versions of the licensing manuals and CHM versions of the installation manuals from the product's Installation
wizard by selecting the Read this Documentation selection, or the Documentation link at the bottom, left
pane of the install pages.

You can also access PDFs from the product disc. For late-breaking information, it is also recommended that
you review the product Readme.
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NOTE To view or print PDF (.pdf) files, Adobe® Reader must be installed on your computer. If you do not have
Adobe Reader, you can download the latest version at http://www.adobe.com.

B Install Autodesk Navisworks Freedom 2010. From the Installation wizard, click Install Products. Follow the
on-screen instructions to complete the installation.

Install Autodesk Navisworks Using Default Values

This is the fastest means of installing Autodesk Navisworks on your system.

Only default values are used which means it is a typical installation being installed to c:\program
Files\Autodesk\Navisworks Freedom 2010.

To install Autodesk Navisworks using default values on a stand-alone computer

1 Insert the Autodesk Navisworks Freedom 2010 DVD into your computer's DVD drive.

The Autodesk Navisworks Freedom 2010 Installation wizard launches in the language that best matches the
settings on your computer.

If the Installation wizard does not start automatically, double-click setup.exe at the root of the Autodesk
Navisworks DVD.

2 In the Installation wizard, select a language for the install instructions or accept the default language. Click
Install Products.

Engiish (English) -

Ch the language of the installation
instructions here.

3 Select the products and the languages for the products you want to install:

B On a 64-bit version of Windows, you can install both 32-bit and 64-bit versions of Autodesk Navisworks,
64-bit version of Autodesk Navisworks Freedom, and both 32-bit and 64-bit versions of exporter plugins.

B On a 32-bit version of Windows, you can install 32-bit version of Autodesk Navisworks, 32-bit version
of Autodesk Navisworks Freedom, and 32-bit version of exporter plugins.

Click Next.

In order to choose a language for an individual product, you first must click the Select Language for Individual
Products check box, then select the language from the drop-down list. In some cases, additional languages
may not be available for the products you choose to install.

4 Review the Autodesk software license agreement for your country or region. You must accept this agreement
to proceed with the installation. Choose your country or region, click I Accept, and then click Next.

NOTE If you do not agree to the terms of the license and want to terminate the installation, click Cancel.

5 On the Product and User Information page, enter your user information. Review the Privacy Policy from the
link at the bottom of the dialog box. After reviewing, click Next.

IMPORTANT The information you enter here is permanent and is displayed in the Autodesk Navisworks Freedom
2010 window (accessed by Help » About) on your computer. Because you can't change this information later
without uninstalling the product, make sure you enter the correct information now.

6 On the Review - Configure - Install page, click Install to begin installing.
The wizard does the following:

B Uses a Typical installation, which installs the most common application features. To see which features
are included in a Typical installation, refer to “Typically Installed Features” on page 23.
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B Installs Autodesk Navisworks to the default install path of c:\Program Files\Autodesk\Navisworks
Freedom 2010.

B Installs the products you selected in Step 3.

NOTE By default, the Installation wizard automatically enables the exporter plugins for all 3rd party products
already installed on your PC.

7 On the Installation Complete page, choose from the following:
B View the installation log file - to view the installation log file.

B View the Autodesk Navisworks Freedom 2010 Readme - to open the Readme file with the information
that was not available when the Autodesk Navisworks Freedom 2010 documentation was prepared.

NOTE If you do not want to view the Readme file now, clear the check box.

8 Click Finish.

Install Autodesk Navisworks Using Configured Values
With this installation method, you can fine-tune exactly what gets installed by using the Configure option.

You can alter the installation type, the install path, the license type, and specify the location of the Project and
Site folders.

To install Autodesk Navisworks using configured values on a stand-alone computer

1 Insert the Autodesk Navisworks Freedom 2010 DVD into your computer's DVD drive.

The Autodesk Navisworks Freedom 2010 Installation wizard launches in the language that best matches the
settings on your computer.

If the Installation wizard does not start automatically, double-click setup.exe at the root of the Autodesk
Navisworks DVD.

2 In the Installation wizard, select a language for the install instructions or accept the default language. Click
Install Products.
3 Select the products and the languages for the products you want to install:

B On a 64-bit version of Windows, you can install both 32-bit and 64-bit versions of Autodesk Navisworks,
64-bit version of Autodesk Navisworks Freedom, and both 32-bit and 64-bit versions of exporter plugins.

B On a 32-bit version of Windows, you can install 32-bit version of Autodesk Navisworks, 32-bit version
of Autodesk Navisworks Freedom, and 32-bit version of exporter plugins.

Click Next.

In order to choose a language for an individual product, you first must click the Select Language for Individual
Products check box, then select the language from the drop-down list. In some cases, additional languages
may not be available for the products you choose to install.

4 Review the Autodesk software license agreement for your country or region. You must accept this agreement
to proceed with the installation. Choose your country or region, click I Accept, and then click Next.

NOTE If you do not agree to the terms of the license and want to terminate the installation, click Cancel.

5 On the Review - Configure - Install page, click Configure to make configuration changes. Each of the products
you selected in Step 3 has its own tab:

B For each of the selected products you can change the license type, installation type, installation path,
and the project and site folder paths.

B For Navisworks exporter plugins, you can change which plugins are installed.
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NOTE At any time you can click Next and then Configuration Complete to return to the Review-Configure-Install
page.

6 To configure a product installation:
a On the Select License Type page, you can choose to install a Stand-Alone License or Network license.
Click Next.
b On the Project and Site Folder Paths page, you can specify:
B Project Folder - use the Browse button to select the directory that contains the product settings
specific to a project group.

m Site Folder - use the Browse button to select the directory that contains the product settings standard
across the entire project site.

¢ On the Select the Installation Type page, you can choose to make the following configuration changes:
B Typical - installs the most common application features.

B Custom - installs only the application features that you select from the Select Features To Install

list:

ActiveX Lite Control Contains Navisworks ActiveX Lite control.

API Contains the Component Object Model
interface for customizing and extending
the Navisworks functionality.

Example NWD files Contains various feature sample files.

PDF Manual Contains the Autodesk Navisworks User
Guide in PDF format.

Product Contains full set of Autodesk Navisworks
files.

Sample RPCs Contains several Rich Photorealistic Con-
tent files.

B Product Install Path - use the Browse button to select the drive and location where product will be
installed. Click Next.

7 To configure Navisworks exporter plugins, click the product tab. The Select the Installation Type page, shows
a list of all exporter plugins:

m & - indicates plugins with the 3rd party software already installed on your PC.

B ¥ -indicates plugins for the 3rd party software, which is either not installed on your PC or has not been
detected by the Installation wizard.

Select the check boxes next to all required plugins. If the 3rd party software has not been detected by the
wizard, you can manually enable the plugins for it. Selecting the check box automatically opens the dialog
box, which enables you to browse for the correct software installation directory.

8 Click another product tab to configure another product, or click Next and then Configuration Complete
to return to the Review-Configure-Install page. Then, click Install.

NOTE If you want a copy of your configuration summary information, click the Copy to Clipboard button.

9 On the Installation Complete page, choose from the following:
B View the installation log file - to view the installation log file.
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B View the Autodesk Navisworks Freedom 2010 Readme - to open the Readme file with the information
that was not available when the Autodesk Navisworks Freedom 2010 documentation was prepared.

NOTE If you do not want to view the Readme file now, clear the check box.

10 Click Finish.

Launch Autodesk Navisworks

Assuming that you've followed all of the previous steps outlined in this Quick Start section, you can launch
Autodesk Navisworks and start taking advantage of its new and updated features.

You can start Autodesk Navisworks in the following ways:

B Desktop shortcut icon. When you install Autodesk Navisworks, a shortcut icon is placed on your desktop.
Double-click the Autodesk Navisworks icon to start the program.

B Start menu. On the Start menu, click All Programs (or Programs) » Autodesk » Navisworks Freedom 2010 »
Autodesk Navisworks Freedom 2010.

B Location where Autodesk Navisworks is installed. If you have administrative permissions, you can run Autodesk
Navisworks in the location where you installed it. If you are a limited-rights user, you must run Autodesk
Navisworks from the Start menu or from the desktop shortcut icon. If you want to create a custom shortcut,
make sure that the Start In directory for the shortcut points to a directory where you have write permissions.

NOTE When the product is started, by default, it uses the language that best matches the settings on your computer.
You can also launch Autodesk Navisworks in another of the supported languages.

How to Launch Autodesk Navisworks in Another Language

To run Autodesk Navisworks in another of the installed languages, you need to add one of the language selector
arguments to the desktop shortcut.

To run Autodesk Navisworks in another language

1 Right-click the Autodesk Navisworks desktop shortcut, and click Properties on the shortcut menu to open
the Autodesk Navisworks Properties dialog box.

2 On the Shortcut tab, enter a space in the Target field after .. \roamer.exe, and then enter one of the following
arguments:
-lang en-US for English localization

-lang de-DE for German localization

-lang es-ES for Spanish localization

-lang fr-FR for French localization

-lang it-IT for Italian localization

-lang ja-JP for Japanese localization

-lang ko-KR for Korean localization

-lang pt-BR for Brazilian Portuguese localization
-lang ru-RU for Russian localization

-lang zh-CN for Chinese (PRC) localization

3 Click OK to save the changes.
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Add or Remove Features

You can add or remove Autodesk Navisworks Freedom 2010 features at any time. For example, you may have
chosen a Custom installation option when you first installed Autodesk Navisworks, but now you want to add
features that you did not install originally. Or you may no longer need to use all of the features that were installed
originally.

You can add or remove features by using the Add or Remove Programs dialog box.
To add or remove features
1 In the Control Panel, double-click Add or Remove Programs.

2 In the Add or Remove Programs dialog box, click Autodesk Navisworks Freedom 2010, and then click
Change/Remove in Windows XP or Uninstall/Change in Vista.

The Autodesk Navisworks Freedom 2010 Installation wizard re-opens in Maintenance Mode.

3 Click Add or Remove Features. On the Add/Remove Features page, select a feature to install or uninstall.
The icons to the left of the selections give you an indication of the action that will be taken.

o
*= Indicates a feature that was marked for installation will be in a typical installation.
X Indicates a feature that is not currently scheduled for installation.

)|
. Indicates a feature that was not originally marked for installation, but was added to the installed feature
list.

i Indicates an installed feature that is chosen for removal.

NOTE If you need to revert to the Autodesk Navisworks Freedom 2010 features that you selected in your original
installation, click Cancel.

Click Next.

4 On the Update Autodesk Navisworks Freedom 2010 Installation page, click Next.

5 On the Update Complete page, you are informed when the updates have been performed. Click Finish.

Reinstall or Repair Autodesk Navisworks Freedom 2010

If you accidentally delete or alter files that are required by Autodesk Navisworks Freedom 2010, Autodesk
Navisworks might not perform correctly, and you might receive error messages when you try to execute a
command or find a file. You can attempt to fix this problem by reinstalling or repairing Autodesk Navisworks
Freedom 2010.

The reinstallation or repair uses the features that were part of the installation type you chose when you initially
installed the program.

To reinstall or repair Autodesk Navisworks Freedom 2010
1 In the Control Panel, double-click Add or Remove Programs.

2 In the Add or Remove Programs dialog box, click Autodesk Navisworks Freedom 2010, and then click
Change/Remove in Windows XP or Uninstall/Change in Vista.

The Autodesk Navisworks Freedom 2010 Installation wizard re-opens in Maintenance Mode.
3 Click Repair Autodesk Navisworks Freedom 2010.

4 On the Select Repair or Reinstall page, click one of the following, and then click Next.

B Repair My Autodesk Navisworks Freedom 2010 Installation. This option replaces all registry entries that
Autodesk Navisworks initially installed and restores Autodesk Navisworks Freedom 2010 to its default
state.
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B Reinstall My Autodesk Navisworks Freedom 2010 Installation. This option repairs the registry and
reinstalls all files from the original installation. Use this option if the Repair My Autodesk Navisworks
Freedom 2010 Installation option does not solve the problem.

On the Repair Autodesk Navisworks Freedom 2010 page, click Next to start the process.

On the Repair Complete page, you are informed when the repairs have been performed. Click Finish.

Uninstall Autodesk Autodesk Navisworks Freedom 2010

When you uninstall Autodesk Navisworks Freedom 2010, all components are removed. This means that even if
you've previously added or removed components, or if you've reinstalled or repaired Autodesk Navisworks
Freedom 2010, the uninstall removes all Autodesk Navisworks installation files from your system.

To uninstall Autodesk Navisworks Freedom 2010

1
2

In the Control Panel, double-click Add or Remove Programs.

In the Add or Remove Programs dialog box, click Autodesk Navisworks Freedom 2010, and then click
Change/Remove in Windows XP or Uninstall/Change in Vista.

The Autodesk Navisworks Freedom 2010 Installation wizard re-opens in Maintenance Mode.

Click Uninstall.

On the Autodesk Navisworks Freedom 2010 page, click Next to remove Autodesk Navisworks from the
system.

When informed that the product has been successfully uninstalled, click Finish.

NOTE Even though Autodesk Navisworks Freedom 2010 is removed from your system, the software license
remains. If you reinstall Autodesk Navisworks Freedom 2010 at some future time, you will not have to register
and re-activate the program.

Installation Troubleshooting

This section provides solutions to installation issues and answers to commonly asked questions that may arise
while installing your products.

Additional troubleshooting information and support is also available at http://autodesk.com/support.

General Installation Issues

This section provides solutions to installation issues and answers to commonly asked questions that may arise
while installing your products.

How can | check my graphics card driver to see if it needs to be updated?

It is recommended that you verify and update your graphics card driver to optimize your program. Use the
following procedure to identify your current graphics card driver.

To identify your graphics card driver

1
2

Start Autodesk Navisworks Freedom 2010.

Click Help » System Info.
The Autodesk Navisworks Freedom 2010 information dialog box opens.

Review the information about your system including the graphics card driver and driver version, and click
OK to close the dialog.
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When performing a Typical installation, what gets installed?

A Typical installation includes the following features:

Autodesk Navisworks Freedom 2010 Contains full set of Autodesk Navisworks
Freedom 2010 files

API Contains the Component Object Model
interface for customizing and extending
the Autodesk Navisworks functionality

Sample RPC's Contains several Rich Photorealistic Con-
tent files for the Presenter tool

Example NWD files Contains various feature sample files

PDF manual Contains the Autodesk Navisworks Free-
dom 2010 user guide in PDF format

Why should I specify the Project Folder and Site Folder?

You can share global Autodesk Navisworks settings, workspaces, datatools, avatars, Clash Detective rules, Presenter
archives, custom Clash Detective tests, object animation scripts, and so on, with other users.

These settings can be shared across an entire project site, or across a specific project group depending on the
required level of granularity.

Autodesk Navisworks examines the current user profile and the all users profile on the local machine, and then
checks the settings in the Project Directory and the Site Directory. The files in the Project Directory take precedence.

How do | share the Autodesk Navisworks settings on a site and project basis?

To install Autodesk Navisworks with the pre-configured settings, such as a site-wide set of global options or
project-specific set of workspaces, you need to:

1 Configure and export required settings (such as workspaces, global options, clash tests and so on) in an
XML file format.

When you configure global options, you can lock some of the options to prevent users from editing them
later on local machines.

TIP If you want to create a locked global options file, run the stand-alone Options Editor from the command line
by typing “drive:pathname\OptionsEditor.exe” -1. The Options Editor opens with the locking facility.

2 Set up the Site and Project directory structure.

Typically, you need to place the Site and Project directories on a central server, so that they can be used for
centralized access by Autodesk Navisworks users.

The Site and Project Directories should contain the following subfolders:

=1 1) My Sike
) Awatars
|Z) custom_clash_tests
) DataTools
I global_options
I Lavout
| Presenter
1) Workspaces
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= |} My Project
) Avatars
) custom_clash_tests
) DataTaoals
) global_options

) Layout
) Presenter
) Workspaces

3 Place the exported settings inside the appropriate subfolders.

The centralized workspace files should go into the Workspaces subfolder, the centralized global options files
should go into the global_options subfolder, and so on.

Where are my product manuals?

All documentation created for Autodesk products are built in two different formats: PDF and CHM.

B CHM files are made available during installation; click the Documentation link in the Installation wizard.
To access CHM files after the product is installed, use the Help system in the product.

B PDF files are available after the product is installed; they are located in the Autodesk\Autodesk Navisworks

2010\<locale>\Manuals folder.

CHM files are installed to the \Autodesk\Autodesk Navisworks 2010\<locale> folder.

Uninstall and Maintenance Issues

This section outlines common issues and their solutions with regards to adding and removing features, reinstalling
or repairing your installation, and uninstalling products.

When adding or removing features, how can | tell what features get installed
by default?

To quickly see what gets installed during a typical, default installation, click the Restore Defaults button on the
Add/Remove Features page.

Is it possible to change the installation folder when adding or removing
features?

Once your product is installed, you cannot change the installation path from the Add/Remove Features page.
Changing the path while adding features results in program corruption, so it is not an option.

When should I reinstall the product instead of a repair?

You should reinstall your product if you accidentally delete or alter files that are required by the program. Missing
or altered files adversely affect the performance of your product and cause error messages when you try to execute
a command or find a file.

If an attempt to repair an installation fails, reinstalling is the next best option.

Do | need my original disk to reinstall my software?

When performing a reinstall of the product, you do not need to have the original DVD on hand.

Installation data is cached locally on your drive and that data is reused when reinstalling.
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When | uninstall my software, what files are left on my system?
If you uninstall the product, some files remain on your system such as files you created or edited.

Your license file also stays on your workstation when you uninstall your product. If you reinstall on the same
workstation, the license information remains valid and you do not have to reactivate the product.

Uninstall and Maintenance Issues | 25



26 | Chapter 3 Installation



Quick Start

This chapter helps you get up-to-speed with the Autodesk Navisworks interface.

Start and Quit Autodesk Navisworks

Once you've installed Autodesk Navisworks Freedom 2010, you can
start it from the Windows desktop or from the command line.

To start Autodesk Navisworks, do one of the following from the
Windows desktop:

B Double-click the Autodesk Navisworks icon, or
B Go to Start » All Programs (or Programs) » Autodesk »

Navisworks Freedom 2010 » Autodesk Navisworks Freedom
2010.

Autodesk Navisworks starts in the language that best matches the
settings on your computer. You can also start Autodesk Navisworks
in another of the installed languages.

To quit Autodesk Navisworks, on the File menu, click Exit.

The User Interface

The Autodesk Navisworks interface contains a number of traditional
Windows elements, such as toolbars, dockable windows, dialog
boxes and shortcut menus in which you complete tasks.

Parts of Autodesk Navisworks Interface

This section briefly describes the main interface components.
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The Autodesk Navisworks interface is intuitive and easy to learn and use. You can adjust the application interface
to match the way you work. For example, you can hide toolbars that you rarely use, so they do not clutter the
interface. You can add and remove buttons from toolbars. You can also create your own toolbars.

Menu Bar

The Menu bar contains all commands available in Autodesk Navisworks, grouped together by similar or 'like'
functionality.

For example, all commands related to review functionality are located under the Review menu, all commands
related to user assistance are located under the Help menu and so on.

When a menu has a right-pointing arrow, such as [ navigation oge '] , there is a submenu associated with that
choice.
When a menu item is followed by a series of dots, such as [ ek current vewpoint. .| , there is a dialog box associated

with that choice.

Quick Reference

File Menu
This menu contains commands for managing files.

Option Description

New Resets the program, and closes the cur-
rently open Navisworks file.

Open Displays the Open dialog box.

Open URL Displays the Open URL dialog box.

Print Displays the Print dialog box.

Print Preview Enables print preview mode.

Print Setup Displays the Print Setup dialog box.

Recent Files Displays shortcuts to the most recently
opened files.
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Option Description

Exit Exits the program.

Edit Menu
This menu contains commands for locating, selecting and editing geometry in your model.

Option Description
Undo Reverses the last performed operation.
Redo Reverses the last operation performed by

the Undo command.

Select Gives you access to selection functionality.
Hidden Toggles hidden mode for selected items.
Required Toggles required mode for selected items.
Unselected Hidden Toggles hidden mode for unselected items.
Reset All Enables you to reset all overridden items

back to their original state.

Viewpoint Menu

This menu contains a set of commands that affect the current viewpoint, including model appearance and
navigation.

Option Description

Look From Enables you to look from a preset view-
point.

Set Viewpoint Up Sets the viewpoint up vector to align with

the selected orientation.

Rendering Enables you to select rendering mode.
Lighting Enables you to select lighting mode.
Display Enables you to display primitives.
Navigation Mode Enables you to select navigation mode.
Navigation Tools Enables you to control the camera during

interactive navigation.

Edit Current Viewpoint Displays the Edit Viewpoint dialog box for
the current viewpoint.

Tools Menu

This menu contains commands for advanced model analysis and reviewing, and also commands for customizing
Autodesk Navisworks.

Option Description

TimeLiner Playback Toggles the TimeLiner Playback window.
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Option Description

Hyperlinks Toggles the display of hyperlinks.
Smart Tags Toggles the display of smart tags.
Animation Enables you to control animation playback.
Background Enables you to select a background color

for the Scene Area.

File Options Displays the File Options dialog box.

Global Options Displays the Options Editor.

Help Menu

This menu provides access to the Autodesk Navisworks online reference system.
Option Description

Help Topics Opens the Help system.

Communication Center Opens the Communication Center

dockable window.

What's This Opens the context-sensitive help.

Navisworks on the Web Displays the Autodesk Navisworks
product page.

Customer Involvement Program  Displays the Customer Involvement dia-

log box.
System Info Displays detailed information about your
system.
About Autodesk Navisworks Displays copyright and license informa-
Freedom 2010 tion about your copy of Autodesk Navis-

works, and enables you to access the
Product Information dialog box.

Toolbars
Autodesk Navisworks toolbars provide quick access to frequently used commands.

Every button on a toolbar includes a tooltip, which describes the function the button activates. Placing the
mouse over a button displays a brief instruction on how to use this feature in the Status bar.

You can rearrange, open and close toolbars:
B To move a toolbar, click the dotted line at the edge of the toolbar, and drag it to a different location.

B To open or close toolbars, right-click an empty area next to the last toolbar on the screen, and choose from
the list of available toolbars on the shortcut menu.

When a Autodesk Navisworks toolbar button has a down-pointing arrow, such as , a submenu toolbar is
associated with that choice. Click the triangle to open the menu, and select a specific option. As you move
through the menu, additional help is displayed in the Status bar. When the option is selected, it becomes the
current command and is displayed as a button in the toolbar. To repeat the command, click the button in the
toolbar. To choose a different command, click the triangle again.

30 | Chapter 4 Quick Start



Some toolbar buttons enable you to choose a program mode. For example, to look around your model, you need
to be in look around mode. To rotate the model, you need to be in examine mode and so on. Autodesk Navisworks
remains in the selected mode until instructed otherwise. To identify the mode you are in, look at the buttons.
If a button is highlighted and has a dark blue boarder around it, the corresponding mode is currently active.

@o%6iQ Q06 o 0o B

To leave the mode, either click the same button again or choose a different mode.

Some buttons are used to toggle the display of dialog boxes, and dockable windows (for example, the Presenter
window, the Animator window etc.). Again, if a button is highlighted and has a dark blue boarder around it, it
means that the corresponding display element is currently open.

As you open more toolbars on the screen, or resize the Autodesk Navisworks window, the toolbars may get
overlapped with each other to reduce the screen clutter. When this happens, some buttons will be hidden under

the overlaps. To quickly access the entire set of commands on a toolbar, click the chevron ** button at the right
end of the toolbar. The remaining commands available for that toolbar will appear.

Quick Reference

In this section, you will find a complete list of Navisworks toolbars and associated buttons.

NOTE The actual toolbar content can differ from this reference depending on the workspace you use.

Standard Toolbar
HEN=ENER=Y 7RG

This toolbar provides quick access to file management commands. It also enables you to undo/redo your actions,
and open the Help system.

Button Description

Resets the program, and closes the cur-
rently open Navisworks file.

l

Displays the Open dialog box.

Displays the Open URL dialog box.

Saves the currently open Navisworks file.

Reverses the last performed operation.

E]

Reverses the last operation performed by
the Undo command.

[x]

Displays the Print dialog box.

Displays copyright and license information
about your copy of Autodesk Navisworks.

€]

Opens the Help system.

€

Opens the Communication Center.

=

Selection Tools Toolbar
=S
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This toolbar provides access to the selection commands, plus enables you to hide geometry objects.

Button

Description

Turns on select mode.

]

Toggles required mode for selected items.

=

Toggles hidden mode for selected items.

Toggles hidden mode for unselected items.

Navigation Mode Toolbar

(@)% A 4 e b o B

This toolbar includes nine modes and six SteeringWheels for interactive navigation around your 3D models.

Description

Selects the wheel.

Turns on walk mode.

Turns on look around mode.

Turns on zoom mode.

Turns on zoom box mode.

Turns on pan mode.

Turns on orbit mode.

Turns on examine mode.

Turns on fly mode.

(1 7 I = 7= R = =4 S O
-+
o
=}

Turns on turntable mode.

Rendering Style Toolbar

s @Sl TR

This toolbar controls the model appearance in Navisworks.

Button

Description

o

Selects lighting mode.

€14

Selects rendering mode.

Toggles the rendering of surfaces.
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Button Description

Toggles the rendering of lines.

Toggles the rendering of points.

Toggles the rendering of snap points.

-
A

Toggles the rendering of 3D text.

Workspace Toolbar
o B[E[ee]) o

This toolbar gives you quick access to the Navisworks review and analysis tools.

Button Description

Toggles the display of hyperlinks.

Toggles the display of smart tags.

b

Toggles the Viewpoints control bar.

E

Toggles the Selection Tree control bar.

Toggles the Comments control bar.

Toggles the Properties control bar.

€]

Toggles the TimeLiner Playback window.

Controls workspaces.

Animation Toolbar

0 Y = Ll Walkabout vl

This toolbar allows you to play back object and viewpoint animations, and toggle the scripting functionality.

Button Description

Rewinds the current animation back to the
beginning.

Steps back a single animation frame or
keyframe.

Plays the current animation backwards.

Pauses the animation.

Stops playing the current animation, and
rewinds it back to the beginning.

]
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Button

Description

Plays the currently selected animation.

E

Steps one frame or keyframe forwards.

E]

Fast forwards the current animation to the
end.

[y

Toggles the Scripter engine on and off in
the Navisworks file.

Navigation Tools Toolbar

PR eI =R

This toolbar enables you to control the camera during interactive navigation.

Button

Description

Dollies and pans the camera so that the
entire model is in the Scene View.

Zooms the camera so that the selected
item fills the Scene View.

[

Puts the Scene View into focus mode.

[l

Holds the selected items. As you move
around the model, these objects will move
with you.

Uses a perspective camera.

Uses an orthographic camera.

]

Toggles collision.

Toggles gravity.

fic]

Toggles crouching.

=]

Toggles third person view.

5]

Aligns the current viewpoint with the X
axis.

5]

Aligns the current viewpoint with the Y
axis.

]

Aligns the current viewpoint with the Z
axis.

2]

Straightens the camera.
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Scene Area

This is the area where you view and interact with your 3D models.

Dockable Windows

Most Navisworks features are accessible from the dockable windows.

There are two types of dockable windows:
m Control bars

m Tool windows

To display a control bar, click View » Control Bars on the Menu bar, and then choose from the list of available
control bars.

To display a tool window, click Tools on the Menu bar, and then choose from the list of available tool windows.
Alternatively, click the desired button on the Workspace toolbar.

Both types of windows can be moved and resized, and either floated in the Scene Area or docked. A docked
window shares one or more edges with adjacent windows and toolbars. If a shared edge is moved, the windows
change shape to compensate. You can also float windows anywhere on the screen, if necessary.

To undock and relocate a window, click and drag the title bars at the top or side of the window.

To prevent a window from automatically docking while you drag it, hold down the CTRL key.

NOTE You can quickly dock and undock a window by double-clicking the window's title bar.

Use the Docking Tool

When you drag a dockable window from its current location towards a new destination on the interface, a
docking tool appears.

The docking stickers point towards the four edges of the interface.

When the window you are dragging is close to the place where you want it to dock, move the mouse over the
corresponding area of the docking tool. You will see an outline of the window appear on the interface. To dock
the window there, release the mouse button.

Tile Windows

You can tile dockable windows on the interface. To do this, drag a window you want to tile over the window
where you want it to be placed. When a rectangular outline appears, release the mouse button.

Auto Hide Windows

You can auto hide dockable windows; this keeps the windows active while maximizing the amount of available
screen space. If auto-hide is active, the body of the window disappears when you move the cursor out of it,
leaving only the title bar visible. Move the cursor over the title bar to display the entire window again.

To switch auto-hide on, click H on the title bar. To switch auto-hide off, click on the title bar.
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The Shortcut Menu

Right-clicking a dockable window displays a shortcut menu of available commands. If you right-click a single
item, or select one or more items and right-click, this menu contains commands related to the items. If you
right-click an area that contains no items or data, the menu contains commands related to the dockable window,
if appropriate.

Status Bar

The Status bar appears at the bottom of the Autodesk Navisworks screen. As this is not a toolbar, it cannot be
customized or moved around.

The left-hand corner of the Status bar is used to display short instructions on how to use the Autodesk Navisworks
features.

In the right-hand corner of the Status bar there are four performance indicators that give you constant feedback
as to how well Autodesk Navisworks is performing on your machine, and the notification icon.

O i e 18 ME

Notification Icon

Notification icon indicates whether any new information is available. Balloon notifications appear over this icon
whenever new Communication Center content is available. You can right-click this icon to turn off the
notifications, or to customize the Communication Center options.

Pencil Progress Bar

The progress bar under the left hand icon (pencil) indicates how much of the current view is drawn, that is how
much drop-out there is in the current viewpoint. When the progress bar is at 100%, the scene is completely
drawn, with no drop-out. The icon changes color when a redraw is in progress. Whilst the scene is being drawn,
the pencil will change to yellow. If there is too much data to handle and your machine cannot process this
quickly enough for Autodesk Navisworks, then the pencil changes to red, indicating a bottleneck.

Disk Progress Bar

The progress bar under the central icon (disk) indicates how much of the current model is loaded from disk, that
is how much is loaded into memory. When the progress bar is at 100%, the entire model, including geometry
and property information, is loaded into memory. The icon changes color when a file load is in progress. Whilst
data is being read, the disk changes to yellow. If there is too much data to handle and your machine cannot
process this quickly enough for Autodesk Navisworks, then the disk changes to red, indicating a bottleneck.

Web Server Progress Bar

The progress bar under the right hand icon (web server) indicates how much of the current model is downloaded,
that is how much has been downloaded from a web server. When the progress bar is at 100%, the entire model
has been downloaded. The icon changes color when a file load is in progress. Whilst data is being downloaded,
the web server changes to yellow. If there is too much data to handle and your machine cannot process this
quickly enough for Autodesk Navisworks, then the web server changes to red, indicating a bottleneck.

Memory Bar

The field to the right of the icons reports the amount of memory currently being used by Autodesk Navisworks.
This is reported in Megabytes (MB).

Undo/Redo Commands

You can undo or redo your actions in Autodesk Navisworks.

The default settings are adequate for regular Autodesk Navisworks usage, but you can adjust the amount of space
allocated to the undo/redo buffer, if necessary.

The Edit » Undo and Edit » Redo menu items state what type of action you can undo/redo.

File | Edit | Wiew Wiewpoint Review Tc

|—..| |Er Undo Current View  Chrl+Z | ]
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To undo an action

B Click Edit » Undo on the Menu bar.

E: Command entry: CTRL + Z
£ Toolbar: Standard » Undo

To redo an action

B Click Edit » Redo on the Menu bar.

E: Command entry: CTRL+Y
¥ Toolbar: Standard » Redo

Default Keyboard Shortcuts

Keyboard shortcuts are keyboard alternatives you can use to initiate commands normally accessed with the
mouse.

For example, to open the Selection Tree, you can press CTRL + F12. Keyboard shortcuts offer a means to let you
work faster and more efficiently. Some dialog boxes or dockable windows can be closed with the same command
used to open it.

Many keyboard shortcuts are already set for most commonly used actions. You can modify the default shortcuts
or add new shortcuts, if necessary.

Quick Reference

Default Keyboard Shortcut Description

ALT + F4 Closes the currently active dockable win-
dow when it is undocked, or exits the ap-
plication if the main application window
is active.

ALT + F6 Switches between the dockable windows
when they are undocked.

CTRL+0 Turns on turntable mode.
CTRL +1 Turns on select mode.

CTRL + 2 Turns on walk mode.

CTRL + 3 Turns on look around mode.
CTRL + 4 Turns on zoom mode.
CTRL+ 5 Turns on zoom box mode.
CTRL+ 6 Turns on pan mode.
CTRL+7 Turns on orbit mode.
CTRL+ 8 Turns on examine mode.
CTRL+9 Turns on fly mode.
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Default Keyboard Shortcut

Description

CTRL+ D Toggles collision mode. You must be in
appropriate navigation mode (that is, Walk
or Fly) for this keyboard shortcut to work.

CTRL+ G Toggles gravity mode.

CTRL+H Toggles hidden mode for selected items.

CTRL+ N Resets the program, and closes the cur-
rently open Navisworks file.

CTRL+ O Displays the Open dialog box.

CTRL + P Displays the Print dialog box.

CTRL+R Toggles required mode for selected items.

CTRL+T Toggles third person mode.

CTRL+Y Reverses the last operation performed by
the Undo command.

CTRL+Z Reverses the last performed operation.

CTRL + F1 Opens the Help system.

Toggles the Section Thumbnail control bar.

CTRL + F11 Toggles the Viewpoints control bar.

CTRL + F12 Toggles the Selection Tree control bar.

CTRL + HOME Dollies and pans the camera so that the
entire model is in view.

HOME Enables view selected mode. This keyboard
shortcut only applies to the Scene Area
windows. This means it will only work
when this window has focus.

ESC Deselects everything.

F1 Opens the Help system.

F11 Toggles full screen mode.

Shift + W Opens the last used SteeringWheel.

SHIFT + F1 Enables you to get context-sensitive help.

SHIFT + F6 Toggles the Comments control bar.

SHIFT + F7 Toggles the Properties control bar.

SHIFT + F10 Opens a shortcut menu for the active

dockable window.
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Autodesk Navisworks Options

There are two types of options: File Options and Global Options.

File Options

For each Autodesk Navisworks file (NWF and .NWD), you can adjust the model appearance and the speed of
navigation around it. File options are stored with Autodesk Navisworks files (.nwf or .nwd), and reloaded each
time you open these files.

The File Options dialog box is used to customize various file options, and can be accessed from the Tools menu.

File Options

Culling | Orientation | Speed | Head Light | Scene Lights

Area Backface
Enable Salid ™
Murnber of
pixels below
which objects
are culled:

Clipping Planes

Mear Far
@ Autaornatic @ Autaornatic
O Constrained O Constrained
(O Fixed (O Fixed
Reset To Defaulks
I QK I [ Cancel ] [ Help

Global Options

Global options, on the other hand, are set for all Autodesk Navisworks sessions. The Options Editor can be
accessed from the Tools menu, or it can be launched as a separate application. To do this, click Start » Programs
» Autodesk » Navisworks Freedom 2010 » Options Editor. The options are grouped together, and presented
in a tree structure, making it quicker to find and change them.

COptions Editor
+- General IMemory Lirnit i
= Madel

[
Performance FD
MWD
MW

+- Interface

Merge Duplicates
+-File Readers

+I- Tools On Convert
On Append
On Load
On Save NWF
on Load

Collapse on Conwvert | Composite Objects v

Close NWCMWD files on load O

"reate Parametric Primitivec |7| .v.

[ Export... ][ Import... ] [ OF H Cancel ][ Help ]

Global options can be exported and imported, making it quick and easy for project managers, or systems
administrators, to ensure the Autodesk Navisworks settings on all machines are identical.

To configure file options

1 Click Tools » File Options.
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2 Use the File Options dialog box to customize various file settings.

3 Click OK to save the changes.

See also:

m “File Options Dialog Box” on page 135

To configure global options

1 Click Tools » Global Options.
2 In the Options Editor, expand the desired node, and click the option you want to configure.

3 Click OK to save the changes.

See also:

B “Options Editor” on page 138

To export global options
1 Click Tools » Global Options.
2 In the Options Editor, click the Export button.

3 In the Select Options to Export dialog box, select the check boxes for all options you want to be exported
(or 'serialized'). If an option cannot be exported, it is greyed out.

Select options to export...

= General N
= Undo (7]
Buffer Size
D Locations
= Environment
+ Files
#- [ Communication Center
+ D Auko-Save
= Model
= Performance
+ Merge Duplicates
+ on Load
+ Memory Limit
+ Temparary File Lacation
= MWD
+ Geamekry Compression
- mwe
= Interface
Display Units
Selection
Measure
Snapping v

m

T

TIP To quickly select/deselect all options for a given category, use the top-level check boxes. For example, selecting
the General check box, instantly selects all options under this node.

4 Click OK to export the selected settings.

5 In the Save As dialog box, enter a name for the settings file. You can also select the name of an existing
settings file to overwrite it with your modified configuration.
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Save As

Save in: |L'f)\:\u"orkspaces [V] 0 ? ! '

<ai ’
| LastSession. xml

<ai "

| RoamerLastSession, xml

My Recent
Documents

m

Desklop

My Documents

5

My Computer

File name: | Globald ptiohsG roupd, sl [V] | Save |

Save as type: |DataTooIs Files [*.uml] [v] [ Cancel ]

by Metwork,

6 Click Save.
7 Click OK to close the Options Editor.

To import global options
1 Click Tools » Global Options.
2 In the Options Editor, click the Import button.
3 In the Open dialog box, browse to the folder containing the settings file, select it, and click Open.

Cpen

Look in: |L'f)\:\u"orkspaces [V] ] ¥ £ E-

baloptionsGroups, xml:
| || LastSession, xml

My Recent || RoamerLastSession, xml

Documerts

=

Desklop

3

2>

My Documents

=

b=

s
2Er
=

=

@

File name: |GIObaIDptionsGroup&.xml [V] [ Open ]

My Metwork Files of type: | DataT ools Files [ xml) [v] [ Cancel ]

4 Click OK to close the Options Editor.

Environment Options

You can adjust the number of recent file shortcuts stored by Autodesk Navisworks.

To configure environment options
1 Click Tools » Global Options.

2 In the Options Editor, expand the General node, and click the Environment option.
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3 Onthe Environment page, enter the desired number into the Maximum Recently Used Files box. By default,
shortcuts to the four most recently opened files can be displayed.

Options Editor

= General Files
Unda
Locations
Environment

+- Comrunication Center
Auto-Save

Model

Interface

File Readers

Tools

Maximum Recently Used Files |4 £

- -

Defaults

[ Export... ][ Import... OF H Cancel ][ Help ]

4 Click OK.

Location Options

These options enable centralized sharing of global Autodesk Navisworks settings, workspaces, datatools, avatars,
Clash Detective rules, Presenter archives, custom Clash Detective tests, object animation scripts, and so on, with
other users.

The settings can be shared across an entire project site, or across a specific project group depending on the
required level of granularity.

To configure location options
1 Click Tools » Global Options.

2 Expand the General node in the Options Editor, and click the Locations option.

COptions Editor
= General
j i E:\Team &
Undo Project Directary ! E]
Lacations
Enwironment Site Direckory | D:\Project 3 E]
+- Carmrunication Center
Auto-Save
+- Model
+- Interface
+-File Readers
+- Tools
Defaults
[ Export... ][ Import... ] I OF H Cancel ][ Help ]

3 Inthe Project Directory box, browse to the directory that contains the Autodesk Navisworks settings specific
to your project group.

4 In the Site Directory box, browse to the directory that contains the Autodesk Navisworks settings standard
across the entire project site.
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5 Click OK.

NOTE When you run Autodesk Navisworks for the first time, the settings are picked up from the installation directory.
Subsequently, Autodesk Navisworks examines the current user profile and the all users profile on the local machine,
and then checks the settings in the Project Directory and the Site Directory. The files in the Project Directory take
precedence.

Display Units
Display units determine the scale of your model in Navisworks.

Display units are used to measure geometry in your scene, align appended models, set tolerances for clash
detection, set texture sizes and so on.

When you open CAD and laser scan files, Autodesk Navisworks reads the file units directly from the files. If this
is not possible (for example, the file is unitless), Autodesk Navisworks uses the default file units configured for
that file type in the Global Options whenever possible. Loaded files are scaled appropriately to the configured
display units.

It is possible to rescale the file units, if they are found to be incorrect for the scene.
To customize display units
1 Click Tools » Global Options.
2 Expand the Interface node in the Options Editor, and click the Display Units option.

COptions Editor

#- General Linear Units | Meters 4
+- Model —
= Interface Angular Units | Degrees Nl

Display Units
Selection
Measure
Snapping
Wiewpoint Defaults
Hyperlinks
SmartTags
Developer
Display
SpaceBall
ViewCube
SteeringWwheels
+-File Readers

+- Tools

[+

Decimal Places: 2

m

m

Defaults

[ Export... ][ Import... ] [ OF H Cancel ][ Help ]

3 Select the Linear Units from the drop-down list. Be sure to choose the exact format required.
4 Select the Angular Units from the drop-down list.

5 Enter the number of decimal places you want to see throughout the interface for your units in the Decimal
Places box. If the unit chosen is a fractional unit, rather than a decimal unit, then you have the choice of
what level of fraction to display the units from the Fractional Display Precision drop-down list.

6 Click OK.

Profiles

Autodesk Navisworks can be adjusted to your level of CAD technical knowledge.

By default, a standard profile is used. If necessary, you can use a developer profile to display additional object
properties.
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To use a developer profile
1 Click Tools » Global Options.

2 Expand the Interface node, and click the Developer option.

COptions Editor

- General Show internal properties
+- Model
= Interface
Display Units
Selection
Measure
Snapping
Wiewpoint Defaults
4 Hypetlinks
+- SmartTags
Developer
Display
SpaceBall
ViewCube
Steeringwheels
+-File Readers
+- Tools

Defaults

[ Export... ][ Import... ] I OF H Cancel ][ Help ]

3 Select the Show Internal Properties check box to add additional object properties to the Properties control
bar.

4 Click OK.

Search Directories

Autodesk Navisworks searches for a variety of configuration files in subdirectories of three standard directories.

These files can be overridden on a per user, all users or per installation basis. The search directories are:

B Application Data\ Autodesk Navisworks Freedom 2010 within the current user profile. For example, C:\Documents
and Settings \user\ Application Data\ Autodesk Navisworks Freedom 2010 where user is the name of the current
user.

B Application Data\Autodesk Navisworks Freedom 2010 within the all users default profile. For example,
C:\Documents and Settings\ All Users\ Application Data\Autodesk Navisworks Freedom 2010.

m  Within the Navisworks install directory. For example, C:\Program Files\Autodesk Navisworks Freedom 2010.

44 | Chapter 4 Quick Start



Get a Whole-Project View
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Work with Files

In Autodesk Navisworks you can open nwd files (published data), and .dwf files.

Use File Readers

NWD Files

An NWD file is a file created with Autodesk Navisworks publisher
tool, and contains all model geometry together with review markups.
You can think of an NWD file as a snapshot of the current state of
the model.

NWD files are very small, as they compress the CAD data by up to
80% of the original size.

DWEF Files

Autodesk DWF was specifically developed by Autodesk as a file
format for architects, engineers, and GIS professionals to share design
data. The DWF file reader reads all 3D geometry, as well as textures
and properties.

Supported Entities
All 3D geometry

Texture maps
Texture coordinates

|
|
|
B Colors (per-vertex, per-face)
B Property fields

|

Categories

Unsupported Entities
B 2D lines/plot sections

B Thumbnails
B Marked-up sketches
|

More than one 3D section per file (any others are ignored)
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B NURBS surfaces

H Cameras

See also:

B “DWEF File Reader Options” on page 150

Manage Files

Open Files

To open files in Autodesk Navisworks, you can either use a standard Open dialog box or drag and drop files
directly to the Selection Tree control bar.

NOTE If the chosen file is a CAD or laser scan file, Autodesk Navisworks automatically uses an appropriate file reader
to open it, provided this file format is supported.

Autodesk Navisworks keeps a list of recently opened files (by default, up to 4 files are shown). You can open any
of these files by clicking Files » Recent Files. If you want to modify the size of this list, use the Options Editor.

You can use the SHIFT and CTRL keys to open several files at the same time. This automatically creates a new
‘Untitled’ Navisworks file with the selected files appended together.

For NWD files, it is possible to publish them to a web server, and then open them directly from within Navisworks.
You can start navigating the model even before the file has been fully downloaded. 10 - 50% is usually sufficient
for this. The greater the hierarchical structure of the model, the closer to 50% download is required. Similarly,
the lesser the hierarchical structure of the model, the sooner you can begin the navigation.

To open a file
1 Click File » Open.

2 In the Open dialog box, use the Files of Type box to select the appropriate file type, and navigate to the
folder where your file is located.

3 Select the file, and click Open.

£ Toolbar: Standard » Open
EE Command entry: CTRL + O

To open NWD files located on a web server

1 Click File » Open URL.
2 Enter the file address, and click OK.
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Explore Your Model

Autodesk Navisworks Freedom 2010 enables you to walk through a scene in real

time.

Navigate a Scene

In Autodesk Navisworks, you have a variety of options for navigating
your scene.

You can directly manipulate your position in 3D space with nine
navigation modes on the Navigation Modes toolbar. You can also
use StreeringWheels that travel with the cursor, and can save you
time by combining many of the common navigation tools into a
single interface.

You can change the orientation and view of your model by using
the preset views available from the Viewpoint » Navigation Tools
menu. Alternatively, you can use the ViewCube, a 3D navigational
tool that enables you to reorient the view of a model by clicking
predefined areas on the cube. For example, clicking the front of the
ViewCube turns the view until the camera is facing the front of the
scene. You can also click the ViewCube and drag it to rotate the
view freely.

You can use the options on the Navigation Tools toolbar to control
the realism of your navigation. So, for example, you can walk down
stairs or follow terrain, crouch under objects, use an avatar to
represent yourself within the 3D model.

Animating Navigation

As you navigate in Autodesk Navisworks, you can record viewpoint
animations, and then play them back. For more information, see
“Record and Play Animations” on page 123.

Orientation in 3D Space

Although Autodesk Navisworks uses the X, Y, Z coordinate system,
there is no hard-and-fast rule as to which way each of these particular
axes actually 'points'.

Autodesk Navisworks reads the data necessary to map which way
is ‘up’ and which way is ‘north’ directly from the files loaded into
your scene. If this is not possible, by default, Z is treated as ‘up’ and
Y is treated as ‘north’.
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It is possible to change the ‘up’ and ‘north’ directions for the entire model (world orientation), and the “up’
direction for the current viewpoint (viewpoint up vector).

NOTE Changing the viewpoint up vector affects navigation in modes that rely on the ‘up’ direction of the current
viewpoint, such as walk, turntable, and orbit. It also has an impact on section views.

To align the viewpoint up vector to the current view

» Click Viewpoint » Set Viewpoint Up » Set Up.

To align the viewpoint up vector to one of the preset axes

1 Click Viewpoint » Set Viewpoint Up.

2 Click one of the preset axis. Choose from:
B SetUp+X

Set Up-X
SetUp+Y
SetUp-Y
SetUp+Z

Set Up -Z

To change the world orientation
1 Click Tools » File Options.

2 In the File Options dialog box, Orientation tab, enter the required values to adjust the model orientation.

File Options

Culling | Orientation | Speed | Head Light | Scene Lights | DataTools

p
% |0 vy 0 211
Morth
%0 o1 Zlo

| Defaults |

QK ][ Cancel ][ Help

3 Click OK.

Navigation Modes

There are nine navigation modes available from the Navigation Mode toolbar to control how you move around
the Scene Area- six camera-centric modes and three model-centric modes.

@Sl A Oe e el
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In a camera-centric mode, the camera moves within the scene, whereas in a model-centric mode, model moves
inside the scene. For example, orbit and examine modes essentially do the same thing, except that orbit mode
moves the camera around the focal point and examine mode moves the model around the focal point.

NOTE Navigation modes and SteeringWheels are mutually exclusive, so activating navigation mode deactivates the
current SteeringWheel menu.

Movement in each mode is based on the keyboard arrow keys, the Shift and Control keys, and mouse drags. The
mouse wheel is also supported, allowing quick and easy zooming or tilting, depending on the current navigation
mode.

TIP Dragging with the left mouse button while holding down the Control key performs the same actions as dragging
with the middle mouse button, which is useful if you only have a two-button mouse.

The Shift and Control keys modify the movement, for example holding down Shift in walk mode speeds up
movement, and holding down Control in this mode, glides the camera left/right and up/down.

NOTE Gliding the camera is opposite to panning the model. Gliding is a camera-centric motion and panning is a
model-centric motion.

Quick Reference

Mode Description

Walk. Enables you to walk through the
model on a horizontal plane ensuring that
“up” is always “up”.

< Look Around. Enables you to look around
the model from the current camera posi-
tion and gives the effect that you are
moving your head around.

@ Zoom. Enables you to zoom into and out
of the model. Cursor up zooms in and
cursor down zooms out.

Zoom to a Box. Enables you to drag a box
so that the contents of the box fill the view.

V] Pan. Enables you to pan the model rather
than the camera.

e Orbit. Enables you to orbit the camera
around the model, ensuring that “up” is
always “up”. The camera always orbits
around the focal point of the model.

Examine. Enables you to rotate the model
about.
) Fly. Enables you to fly around the model

like in a flight simulator.

Turntable. Enables you to spin the model
around the up vector. This navigation
mode behaves as though the model is sit-
ting on a turntable, ensuring that “up” is
always “up”.
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Walk Mode

In walk mode, you can navigate through a model as if you were walking through it. In this mode, the up direction
is always maintained.

Once you start walk mode, the cursor changes to the walk cursor. To walk through the model, you drag in the
direction in which you want to move in.

To use walk mode to move through the model

1 Click Walk on the Navigation Mode toolbar.

2 To move, hold down the left mouse button as you drag in the direction you want to walk, or use the cursor
keys. The camera spins left and right, and moves forwards and backwards.

NOTE Holding down the SHIFT key speeds up this movement.

3 To glide, hold down the CTRL key as you drag the mouse. The camera glides left and right and up and
down.

As walk mode is camera-centric, this mode differs from the normal pan mode in that the camera is moved
rather than the model.

4 To tilt the camera up and down, spin the mouse wheel.

£ Menu: Viewpoint » Navigation Mode » Walk
E2 Command entry: CTRL + 2

Look Around Mode

In look around mode, you can rotate the current view vertically and horizontally. When rotating the view, your
line of sight rotates about the current eye position, like turning your head.

To look around a view

1 Click Look Around [Z2] on the Navigation Mode toolbar.

2 Tolook around, drag the left mouse button, or use the cursor keys. The camera looks left, right, up or down.

NOTE Holding down the SHIFT key speeds up this movement.

3 To rotate the camera around its viewing axis, hold down the CTRL key.
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£ Menu: Viewpoint » Navigation Mode » Look Around
E Command entry: CTRL + 3

Zoom Mode

In zoom mode, you can zoom into and out of the model.

To zoom the view

1 Click Zoom @ on the Navigation Mode toolbar.

2 Drag the left mouse button up and down, or use the up and down cursor keys, to zoom in and out
respectively.

£ Menu: Viewpoint » Navigation Mode » Zoom
E Command entry: CTRL + 4

Zoom Box Mode

In zoom box mode, you can zoom in to an area of the model by dragging a rectangular box around the area you
want to fit in the Scene Area.

To zoom in to an area of the model by specifying box

1 Click Zoom Box =] on the Navigation Mode toolbar.

2 Drag a box with the left mouse button over the Scene Area to fill the view with the contents of the box.

NOTE Holding down the Shift or Control keys, or spinning the mouse wheel, temporarily enables normal zoom
mode.

£ Menu: Viewpoint » Navigation Mode » Zoom Box
EE Command entry: CTRL + 5

Pan Mode

In pan mode, you can move the model, rather than the camera. For example, dragging upward moves the model
up while dragging downward moves the model down.
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To pan a model

1 Click Pan l'“| on the Navigation Mode toolbar.

2 Drag the left mouse button to pan the model up, down, left and right.

NOTE Holding down the SHIFT or CTRL keys, or spinning the mouse wheel, temporarily enables normal zoom
mode.

£ Menu: Viewpoint » Navigation Mode » Pan
E Command entry: CTRL + 6

Orbit Mode

In orbit mode, the camera moves around the focal point of the model. In this mode, the up direction is always
maintained.

To orbit a model

1 Click Orbit on the Navigation Mode toolbar.

2 To rotate the camera around the model, drag the left mouse button, or using the cursor keys.

NOTE Holding down the SHIFT key, or spinning the mouse wheel, temporarily enables normal zoom mode.

3 To glide the camera, hold down the CTRL key as you drag the mouse. The camera glides left and right and
up and down.

As orbit mode is camera-centric, this mode differs from normal pan mode in that the camera is moved
rather than the model.

£ Menu: Viewpoint » Navigation Mode » Orbit
E Command entry: CTRL + 7

Examine Mode

In examine mode, you can rotate the model around the focal point.
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To examine a model

1 Click Examine on the Navigation Mode toolbar.

2 To rotate the model around the focal point, drag the left mouse button, or using the cursor keys. If the
mouse is moving when you let go of the button, the model keeps spinning. Clicking on the model stops
this.

NOTE Holding down the Shift key, or spinning the mouse wheel, temporarily enables normal zoom mode. Holding
down the CTRL key, temporarily enables normal pan mode.

£ Menu: Viewpoint » Navigation Mode » Examine
E Command entry: CTRL + 8

Fly Mode

In fly mode, you can move around the model like in a flight simulator.

To use fly mode to move through the model

1 Click Fly on the Navigation Mode toolbar.

2 Hold down the left mouse button to move the camera forward. As in a flight simulator, the left mouse
button banks left/right when dragged left or right and tilts up/down when dragged up or down.

NOTE Holding down the SHIFT key speeds up this movement.

3 Use the up and down cursor keys to zoom the camera in and out respectively; use the left and right cursor
keys to spin the camera left and right respectively.

NOTE Holding down the CTRL key rotates the camera around its viewing axis, while still moving forward.

¥ Menu: Viewpoint » Navigation Mode » Fly
E2 Command entry: CTRL + 9

Turntable Mode

In turntable mode, you can spin the model around the up vector as though the model is sitting on a turntable.
In this mode, the up direction is always maintained.
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To spin model on a turntable

1 Click Turntable on the Navigation Mode toolbar.

2 Drag the left mouse button left and right, or use the left and right cursor keys, to spin the turntable left and
right respectively.

NOTE Holding down the SHIFT key or spinning the mouse wheel, temporarily enables normal zoom mode.
Holding down the CTRL key, temporarily enables normal pan mode.

3 To tilt the the turntable up and down, spin the mouse wheel, or use the up and down cursor keys.

£ Menu: Viewpoint » Navigation Mode » Turntable
E Command entry: CTRL + 0

SteeringWheels

SteeringWheels™ are tracking menus that follow your cursor, and from which you can access diferent 3D
navigation tools from a single tool.

Overview of SteeringWheels

SteeringWheels, also known as wheels, can save you time by combining many of the common navigation tools
into a single interface. Wheels are specific to the context from which a model is being viewed.

ORBIT
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NOTE SteeringWheels and navigation modes are mutually exclusive, so activating a SteeringWheel deactivates the
currently selected navigation mode.

First Contact Balloon

At startup, the SteeringWheel is pinned. When you move the cursor over the SteeringWheel, the First Contact
balloon is displayed. The First Contact balloon serves as an introduction to the purpose of the wheels and how
you can use them.

56 | Chapter 6 Explore Your Model



Z00OM

L
A% Y
Sl G

% |

ORBIT

New to3D ( Familiar with 3D |

SteeringWheels™ travel with you

- B “zoom _\._\x\
to provide quick access to common < DS l& Wheel
. - A5
navigation controls. Fie s %o | follows
[ El ] 12 | cursor
\ol . Z |
CA 5
\ & ‘,,/<
X mn &

Choose awheel ...

= 8 ® ®
T Full Nav Full Nav View Object Tour Building
Large Wheel Mini Wheel Mini Wheel Mini Wheel
y ® | I
) ‘9‘4& | Try Me | Try Me J | Try Me J | Try Me J
| &¢ |
o\e ~—7 -
\ G/
B | °/

_._PAN__ E -
Display and Use Wheels

Pressing and dragging on a wedge of a wheel is the primary mode of interaction. After a wheel is displayed, click
one of the wedges and hold down the button on the pointing device to activate the navigation tool. Drag to
reorient the current view. Releasing the button returns you to the wheel.

Control the Appearance of Wheels

You can control the appearance of the wheels by switching between the different styles of wheels that are
available, or by adjusting the size and opacity. Wheels are available in two different styles: big and mini. The
big wheel is larger than the cursor, and labels are shown on the wheel wedges. The mini wheel is about the same
size as the cursor, and labels are not displayed on the wheel wedges.
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Pan
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Mini
Full
Navig-
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Big Full Naviga-

tion Wheel

The size of a wheel controls how large or small the wedges and labels appear on the wheel; the opacity level
controls the visibility of the objects in the model behind the wheel.

Control Tooltips for Wheels and Messages for Tools

Tooltips are displayed for each button on a wheel as the cursor is moved over them. The tooltips appear below
the wheel and identify what action will be performed if the wedge or button is clicked.

Similar to tooltips, tool messages and cursor text are displayed when you use one of the navigation tools from
a wheel. Tool messages are displayed when a navigation tool is active; they provide basic instructions about
using the tool. Tool cursor text displays the name of the active navigation tool near the cursor. Disabling tool
messages and cursor text only affects the messages that are displayed when using the mini wheels or the big Full
Navigation wheel.

To display a wheel
1 Click View » SteeringWheels.

2 Click the wheel you want to display, for example Full Navigation Wheel.

£ Toolbar: Navigation Mode » SteeringWheels
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To close a wheel

Use one of the following methods to close a wheel:

B DPress SHIFT+W

B Click the Close button.

B Right-click the wheel, and click Close Wheel.

To change the size of a wheel

1
2
3

Display a wheel.
Right-click the wheel, and click SteeringWheels Options.

In the Options Editor, the SteeringWheels page under the Interface node, select an option from the Size
drop-down list in the Big Wheels or Mini Wheels area.

Click OK.

To change the opacity of a wheel

1
2
3

Display a wheel.
Right-click the wheel, and click SteeringWheels Options.

In the Options Editor, the SteeringWheels page under the Interface node, select an option from the Opacity
drop-down list in the Big Wheels or Mini Wheels area.

Click OK.

To control the startup placement of a wheel

1
2
3

Display a wheel.
Right-click the wheel, and click SteeringWheels Options.

In the Options Editor, the SteeringWheels page under the Interface node, select the Always Show the Pinned
Wheel on Startup check box.

When this option is selected, the wheel is pinned to the window at startup. When this check box is clear,
the wheel follows the position of the cursor at startup.

Click OK.

To enable tooltips for wheels

1
2
3

Display a wheel.
Right-click the wheel, and click SteeringWheels Options.

In the Options Editor, the SteeringWheels page under the Interface node, select the Show Tooltips check
box.

Tooltips are displayed for each wedge and button on a wheel when the cursor moves over the wheel.

Click OK.

To enable tool messages for wheels

1
2
3

4

Display a wheel.
Right-click the wheel, and click SteeringWheels Options.

In the Options Editor, the SteeringWheels page under the Interface node, select the Show Tool Messages
check box.

Messages are displayed when you use the navigation tools.

Click OK.
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To enable tool cursor text for wheels

Display a wheel.
Right-click the wheel, and click SteeringWheels Options.

In the Options Editor, the SteeringWheels page under the Interface node, select the Show Tool Cursor Text
check box.

The name of the active tool is displayed near the cursor when the tool is in use.

Click OK.

Wheel Menu

From the Wheel menu, you can switch between different wheels and change the behavior of some of the
navigation tools on the current wheel.

Use the Wheel menu to switch between the big and mini wheels that are available, go to the Home view, change
the preferences of the current wheel, and control the behavior of the orbit, look, and walk 3D navigation tools.
The menu items available on the Wheel menu are dependent on the current wheel and program.

To display the Wheel menu

Click the down arrow in the lower-right corner of the wheel or right-click on the wheel.

Quick Reference

The Wheel menu has the following options:

View Object Wheel. Displays the big View Object wheel.
Tour Building Wheel. Displays the big Tour Building wheel.
Full Navigation Wheel. Displays the big Full Navigation wheel.

Advanced Wheels. Displays the mini View Object, Tour Building, or Full Navigation wheel.

Go Home. Goes to the Home view saved with the model.

NOTE This is the Home view as set using the ViewCube.

Fit to Window. Resizes and centers the current view to display all objects in the Scene Area. This is equivallent
to clicking View All [<] on the Navigation Tools toolbar.

Restore Original Center. Restores the center point of the view to the extents of the model.

Level Camera. Orients the camera such that it is level with the 'ground'. That is to say, resets the camera 'up'
vector to the world up vector as set in File Options » Orientation, and sets the roll of the camera to 0.

Increase Walk Speed. Increases the walk speed for the Walk tool to double its current setting in the Options
Editor.

NOTE This does not affect the viewpoint linear speed for Navisworks walk navigation mode. The navigation tool
used by SteeringWheels and Navisworks navigation modes are independent.

Decrease Walk Speed. Decreases the walk speed for the Walk tool to half its current setting in the Options
Editor.
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NOTE This does not affect the viewpoint linear speed for Navisworks walk navigation mode. The navigation tool
used by SteeringWheels and Navisworks navigation modes are independent.

B SteeringWheels Options. Displays the Options Editor where you can adjust the appearance and behavior of
SteeringWheels.

B Help. Launches the online Help system and displays the topic for SteeringWheels.

B Close Wheel. Closes the wheel.

View Object Wheels

With the View Object wheels (big and mini), you can view individual objects or features in a model. The big
View Object wheel is optimized for new 3D users while the mini View Object wheel is optimized for experienced
3D users.

CENTER

I\.
\ ®

Big View Object Wheel
The big View Object wheel wedges have the following options:

B Center. Specifies a point on a model to adjust the center of the current view or change the target point used
for some of the navigation tools.

B Zoom. Adjusts the magnification of the current view.

B Rewind. Restores the most recent view orientation. You can move backward or forward by clicking and
dragging left or right.

B Orbit. Rotates the current view around a fixed pivot point.

Mini View Object Wheel
The mini View Object wheel wedges have the following options:

B Zoom (Top wedge). Adjusts the magnification of the current view.

B Rewind (Right wedge). Restores the most recent view. You can move backward or forward by clicking and
dragging left or right.

B Pan (Bottom wedge). Repositions the current view by panning.

B Orbit (Left wedge). Rotates the current view around a fixed pivot point.

NOTE When the mini wheel is displayed, you can press and hold the middle mouse button to pan, scroll the wheel
button to zoom in and out, and hold the SHIFT key while pressing and holding the middle mouse button to orbit the
model.

To switch to the mini View Object wheel

B Right-click the wheel, and click Advanced Wheels » Mini View Object Wheel.

£ Menu: View » SteeringWheels » Mini View Object Wheel
£ Toolbar: Navigation Mode » Mini View Object Wheel
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NavSWheelCenterTool.htm
NavSWheelZoomTool.htm
NavSWheelRewindTool.htm
NavSWheelOrbitTool.htm
NavSWheelZoomTool.htm
NavSWheelRewindTool.htm
NavSWheelPanTool.htm
NavSWheelOrbitTool.htm

To switch to the big View Object wheel

B Right-click the wheel, and click View Object Wheel.

£ Menu: View » SteeringWheels » View Object Wheel
£ Toolbar: Navigation Mode » View Object Wheel (Ol

Tour Building Wheels

With the Tour Building wheels (big and mini), you can move through a model, such as a building, an assembly
line, ship, or oil rig. You can also walk through and navigate around a model. The big Tour Building wheel is
optimized for new 3D users while the mini Tour Building wheel is optimized for experienced 3D users.

FORWARD \\i(

REWIND

Big Tour Building Wheel
The big Tour Building wheel wedges have the following options:

B Forward. Adjusts the distance between the current point of view and the defined pivot point of the model.
Clicking once moves forward half the distance as far as the object you clicked.

B Look. Swivels the current view.

B Rewind. Restores the most recent view. You can move backward or forward by clicking and dragging left or
right.

B Up/DownTool. Slides the current view of a model along the Z axis of the model.

Mini Tour Building Wheel
The mini Tour Building wheel wedges have the following options:

B  Walk (Top wedge). Simulates walking through a model.

B Rewind (Right wedge). Restores the most recent view. You can move backward or forward by clicking and
dragging left or right.

B Up/Down (Bottom wedge). Slides the current view of a model along the Z axis of the model.

B Look (Left wedge). Swivels the current view.

NOTE When the mini wheel is displayed, you can press and hold the middle mouse button to pan, scroll the wheel
button to zoom in and out, and hold the SHIFT key while pressing and holding the middle mouse button to orbit the
model.

To switch to the mini Tour Building wheel

B Right-click the wheel, and click Advanced Wheels » Mini Tour Building Wheel.

£ Menu: View » SteeringWheels » Mini Tour Building Wheel
£ Toolbar: Navigation Mode » Mini Tour Building Wheel

To switch to the big Tour Building wheel

B Right-click the wheel, and click Tour Building Wheel.
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£ Menu: View » SteeringWheels » Tour Building Wheel
> Toolbar: Navigation Mode » Tour Building Wheel Ol

Full Navigation Wheels

The Full Navigation wheels (big and mini) combine the 3D navigation tools found on the View Object and Tour
Building wheels. You can view individual objects, and walk through and around a model. The big and mini Full
Navigation wheels are optimized for experienced 3D users.

NOTE When one of the Full Navigation wheels is displayed, you can press and hold the middle mouse button to pan,
scroll the wheel button to zoom in and out, and hold the SHIFT key while pressing and holding the middle mouse
button to orbit the model.

Big Full Navigation Wheel
The big Full Navigation wheel wedges have the following options:

B Zoom. Adjusts the magnification of the current view.

B Rewind. Restores the most recent view. You can move backward or forward by clicking and dragging left or
right.

B Pan. Repositions the current view by panning.
B Orbit. Rotates the current view around a fixed pivot point.

B Center. Specifies a point on a model to adjust the center of the current view or change the target point used
for some of the navigation tools.

B Walk. Simulates walking through a model.
B Look. Swivels the current view.

B Up/Down. Slides the current view of a model along the Z axis of the model.

Mini Full Navigation Wheel

The mini Full Navigation wheel wedges have the following options:

B Zoom (Top wedge). Adjusts the magnification of the current view.
Walk (Upper right wedge). Simulates walking through a model.

Rewind (Right wedge). Restores the most recent view. You can move backward or forward by clicking and
dragging left or right.

Up/Down (Lower right wedge). Slides the current view of a model along the Z axis of the model.
Pan (Bottom wedge). Repositions the current view by panning.
Look (Lower left wedge). Swivels the current view.

Orbit (Left wedge). Rotates the current view around a fixed pivot point.

Center (Upper left wedge). Specifies a point on a model to adjust the center of the current view or change
the target point used for some of the navigation tools.
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To switch to the mini Full Navigation wheel

B Right-click the wheel, and click Advanced Wheels » Mini Full Navigation Wheel.

£ Menu: View » SteeringWheels » Mini Full Navigation Wheel
£ Toolbar: Navigation Mode » Mini Full Navigation Wheel

To switch to the big Full Navigation wheel

B Right-click the wheel, and click Full Navigation Wheel.

£ Menu: View » SteeringWheels » Full Navigation Wheel
£ Toolbar: Navigation Mode » Full Navigation Wheel

Navigation Tools

Each wheel is divided into different wedges. Each wedge contains a navigation tool that you can be uses to
reorient the current view of a model. Which navigation tools are available depends on which wheel is active.

Control Navigation Realism

You can use collision, gravity, and crouching with the Walk tool. This allows you, for example, to walk up and
down stairs and walk under low objects.

You can also use the third person view with SteeringWheels to enhance your navigation experience. However,
the avatar is only shown when you use the Walk tool, and the Pan tool to prevent cluttering of the screen.

Center Tool

With the Center tool, you can define the center of the current view of a model. To define the center, you drag
the cursor over your model. A sphere is displayed in addition to the cursor. The sphere indicates that the point
below the cursor in the model will be the center of the current view when you release the mouse button, the
model is centered on the sphere.

NOTE If a center point on a model cannot be identified, then a prohibited icon (a circle with a diagonal line) is displayed
instead of the sphere.

Center Tool

The point defined by the Center tool provides a focal point for the Zoom tool and a pivot point for the Orbit
tool.

NOTE If you want to zoom from the Full Navigation wheels from your defined center point, hold down CTRL before
zooming.

To specify a point on a model as the center of a view
1 Display one of the Full Navigation wheels or the big View Object wheel.
2 Click and hold down the Center wedge.
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3 Drag the cursor to the desired location of the model.

4 Release the button on your pointing device when the sphere is displayed.

The model is panned until the sphere is centered.

To specify the target point for the Zoom and Orbit tools
1 Display one of the Full Navigation wheels or the big View Object wheel.
2 Click and hold down the Center wedge.
3 Drag the cursor over the desired location of the model.
4

Release the button on your pointing device when the sphere is displayed.

The model is panned until the sphere is centered.

5 Use the Zoom or Orbit tool to reorient the view of the model.
If you are using one of the Full Navigation wheels, hold down the CTRL key before using the Zoom tool.

Forward Tool

You use the Forward tool to change the magnification of the model by increasing or decreasing the distance
between the current point of view and the pivot point. The distance that you can move forward or backward is
limited by the position of the pivot point.

NOTE In orthographic views, the Forward tool is limited to the distance between the current position and the pivot
point. In perspective views, it is not limited, so you can move the cursor through the pivot point.

To adjust the distance between the current point of view and the pivot point you use the Drag Distance indicator.
The Drag Distance indicator has two marks on it that show the start and destination distances from the current
point of view. The current traveled distance is shown by the orange position indicator. Slide the indicator forward
or backwards to decrease or increase the distance towards the pivot point.

To reorient a view by moving towards or away from the model
1 Display the big Tour Building wheel.

2 Click and hold down the Forward wedge.
The Drag Distance indicator is displayed.

NOTE If you click the Forward wedge once, the model moves forward 50% of the distance between the current
location and the pivot point.

3 Drag the cursor up or down to change the distance from which you view the model.

4 Release the button on your pointing device to return to the wheel.
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Look Tool

With the Look tool, you can rotate the current view vertically and horizontally. When rotating the view, your
line of sight rotates about the current eye position, like turning your head. The Look tool can be compared to
you standing in a fixed location, and looking up or down while turning your head left or right.

When using the Look tool, you adjust the view of the model by dragging the cursor. As you drag, the cursor
changes to the Look cursor and the model rotates around the location of the current view.

In addition to using the Look tool to look around a model, you can also use the tool to pan the current view to
a specific face on the model. Press and hold the SHIFT key before selecting the Look tool on one of the Full
Navigation wheels.

Walking Through a Model

When using the Look tool from the big Full Navigation wheel, you can walk through a model by using the arrow
keys on the keyboard. To adjust the walk speed, use the Options Editor.

Invert Vertical Axis

When you drag the cursor upward, the target point of the view raises; dragging the cursor downward lowers the
target point of the view. To invert the vertical axis for the Look tool, use the Options Editor.

To look around a view with the Look tool
1 Display one of the Full Navigation wheels or the mini Tour Building wheel.

2 Click and hold down the Look wedge.

The cursor changes to the Look cursor.
3 Drag the pointing device to change the direction in which you are looking.

4 Release the button on your pointing device to return to the wheel.

To look at a face in the model with the Look tool

—

Display one of the Full Navigation wheels.
2 Press and hold down the SHIFT key.

3 Click and hold down the Look wedge.
The cursor changes to the Look At cursor.

4 Drag over the objects in the model until the face highlights that you want to look at.

5 Release the button on your pointing device to return to the wheel.

To look around and walk through a model with the Look tool
1 Display the big Full Navigation wheel.
2 Click and hold down the Look wedge.

The cursor changes to the Look cursor.
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Drag to change the direction in which you are looking.
While holding down the button on your pointing device, press the arrow keys to walk in the model.

Release the button on your pointing device to return to the wheel.

A »n A~ W

Click Close to exit the wheel.

To invert the vertical axis for the Look tool
1 Display a wheel.
2 Right-click the wheel, and click SteeringWheels Options.

3 In the Options Editor, the SteeringWheels page under the Interface node, select the Invert Vertical Axis
check box.

Dragging downward and upward lowers and raises the target point of the current view.

4 Click OK.

Orbit Tool

You use the Orbit tool to change the orientation of a model. The cursor changes to the Orbit cursor. As you drag
the cursor, the model rotates around a pivot point while the view remains fixed.

Specify the Pivot Point

The pivot point is the base point used when rotating the model with the Orbit tool. You can specify the pivot
point in the following ways:

B Default pivot point. When you first open a model, the target point of the current view is used as the pivot
point for orbiting the model.

B Select objects. You can select objects before the Orbit tool is used to calculate the pivot point. The pivot
point is calculated based on the center of the extents of the selected objects.

B Center tool. You can specify a point on the model to use as the pivot point for orbiting with the Center tool.

B CTRL+Click and drag. Press and hold down the CTRL key before clicking the Orbit wedge or while the Orbit
tool is active; then drag to the point on the model you want to use as the pivot point. This option is only
available when using the big and mini Full Navigation wheels or the mini View Object wheel.

NOTE While the Orbit tool is active, you can be press and hold the CTRL key at anytime to move the pivot point
used by the Orbit tool.

Maintain Up Direction

You can control how the model orbits around the pivot point by choosing to maintain the up direction of the
model. When the up direction is maintained, orbiting is constrained along the XY axis and in the Z direction. If
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you drag horizontally, the camera moves parallel to the XY plane. If you drag vertically, the camera moves along
the Z axis.

If the up direction is not maintained, you can roll the model using the roll ring which is centered around the
pivot point. Use the properties dialog box for the SteeringWheels to control whether the up direction is maintained
or not for the Orbit tool.

To orbit a model with the Orbit tool
1 Display one of the View Object or Full Navigation wheels.
2 Click and hold down the Orbit wedge.

The cursor changes to the Orbit cursor.

3 Drag to rotate the model.

NOTE Use the Center tool to re-center the model in the current view, if you are using one of the Full Navigation
or View Object wheels.

4 Release the button on your pointing device to return to the wheel.

To orbit around an object with the Orbit tool

1 Press ESC to make sure no commands are active and to clear any previously selected objects.
2 Select the objects in the model for which you want to define the pivot point.
3 Display one of the View Object or Full Navigation wheels.
4 Click and hold down the Orbit wedge.
The cursor changes to the Orbit cursor.
5 Drag to rotate the model.

6 Release the button on your pointing device to return to the wheel.

To turn on selection sensitivity for the Orbit tool
1 Display one of the View Object or Full Navigation wheels.
2 Right-click the wheel, and click SteeringWheels Options.

3 In the Options Editor, the SteeringWheels page under the Interface node, select the Enable Selection
Sensitivity check box.

4 Click OK.

The extents of any objects that are selected before the wheel is displayed are used to define the pivot point
for the Orbit tool. If no objects are selected, the pivot point used by the Orbit is the one defined by the
Center tool.
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To maintain the up direction for the Orbit tool

—

Display the mini View Object wheel or one of the Full Navigation wheels.
Right-click the wheel, and click SteeringWheels Options.

In the Options Editor, the SteeringWheels page under the Interface node, select the Keep Scene Upright
check box.

Click OK.
Orbiting the model is constrained along the XY plane and Z directions.

To roll the model around the pivot point with the Orbit tool

1
2
3

Display the mini View Object Wheel or one of the Full Navigation wheels.
Right-click the wheel, and click SteeringWheels Options.

In the Options Editor, the SteeringWheels page under the Interface node, clear the Keep Scene Upright
check box.

Click OK.

Click and hold the Orbit wedge.
The cursor changes to the Orbit cursor.

Press and hold the SHIFT key to display the roll ring. Drag to roll the model.

Release the button on your pointing device to return to the wheel.

To start the Orbit tool with the middle mouse button

—

HOW N

Display one of the wheels other than the big View Object or Tour Building wheels.
Press and hold down the SHIFT key.
Press and hold down the scroll wheel or middle button on your pointing device and drag to orbit the model.

Release the button on your pointing device to return to the wheel.

Pan Tool

When the pan tool is active, the Pan cursor (a four-sided arrow) is displayed. Dragging the pointing device moves
the model in the same direction. For example, dragging upward moves the model up while dragging downward
moves the model down.

TIP If the cursor reaches the edge of the screen, you can continue panning by dragging further to force it to wrap
around the screen.
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To pan the view with the Pan tool
1 Display one of the Full Navigation wheels, or the mini View Object wheel.

2 Click and hold the Pan wedge.

The cursor changes to the Pan cursor.
3 Drag to reposition the model.

4 Release the button on your pointing device to return to the wheel.

To start the Pan tool with the middle mouse button
1 Display one of the Full Navigation wheels, or the mini View Object wheel.

2 Press and hold down the scroll wheel or middle button.
The cursor changes to the Pan cursor.

3 Drag to reposition the model.

4 Release the wheel or button on your pointing device to return to the wheel.

Rewind Tool

As you use the navigation tools to reorient the view of a model, the previous view is saved to the navigation
history. The navigation history holds a representation of the previous views of the model along with a thumbnail.
A separate navigation history is maintained for each window; it is not maintained after the window is closed.
Rewind navigation history is view-specific.

With the Rewind tool, you can retrieve previous views from the navigation history. From the navigation history,
you can restore a previous view or scroll through all of the saved views.

When you hold down the button on the pointing device over the Rewind tool on the wheel, the Rewind History
panel is displayed. You can scroll through the navigation history. To restore one of the previous views in the
navigation history, drag the bracket to the left in the Rewind History panel.

NOTE Rewind history is not saved between sessions.

To restore the previous view
1 Display a wheel.
2 Click the Rewind wedge.

To restore a previous view with the Rewind History panel
1 Display a wheel.

2 Click and hold the Rewind wedge.
The Rewind History panel is displayed.
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3 While holding down the button on your pointing device, drag to the left or to the right to restore a previous
view.
Dragging to the left restores an older previous view. Dragging to the right restores a view that is newer than
the one you are currently viewing. You must have previously used the Rewind tool to see views available
on the right. The current position in the navigation history is indicated by the orange box that is dragged
along the Rewind History panel.

Up/Down Tool

Unlike the Pan tool, you use the UP/Down tool to adjust the height of the current viewpoint along the model's
Z axis. To adjust the vertical elevation of the current view, you drag up or down. As you drag, the current elevation
and the allowed range of motion is displayed on a graphical element called the Vertical Distance indicator.

The Vertical Distance indicator has two marks that show the highest (Top) and lowest (Bottom) elevation the
view can have. While changing the elevation with the Vertical Distance indicator, the current elevation is shown
by the bright orange indicator, while the previous elevation is shown by the dim orange indicator.

. BOTTOM

To change the elevation of a view
1 Display one of the Full Navigation wheels or the Tour Building wheels.

2 Click and hold down the Up/Down wedge.
The Vertical Distance indicator is displayed.

3 Drag up or down to change the elevation of the view.

4 Release the button on your pointing device to return to the wheel.

Walk Tool

With the Walk tool, you can navigate through a model as if you were walking through it. Once you start the
Walk tool, the Center Circle icon is displayed near the center of the view and the cursor changes to display a
series of arrows. To walk through the model, you drag in the direction in which you want to move in.
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Constrain the Walk Angle

When walking through a model, you can constrain the movement angle to the world up vector. If the Constrain
Walk Angle option is enabled, you can freely walk around while maintaining a constant camera viewpoint
elevation; if the walk angle is not constrained, you will “fly” in the direction you are looking. Use the Options
Editor to constrain the movement angle to the world up vector for the Walk tool.

Movement Speed

As you walk or “fly” through a model, you can control the movement speed. Movement speed is controlled by
the distance in which the cursor is moved from the Center Circle icon and the current movement speed setting.
You can adjust the movement speed setting permanently and temporarily as you use the Walk tool. To
permanently adjust the movement speed, use the Options Editor or the < and > keys when the Walk tool is
active. To temporarily increase movement speed, press and hold the + (plus) key while using the Walk tool.

Change the Elevation

As you use the Walk tool, you can adjust the camera elevation by holding down the SHIFT key. This temporarily
activates the Up/Down tool. With the Up/Down tool active, drag up or down to adjust the elevation of the
camera. You can also use the UP ARROW and DOWN ARROW keys as you walk to adjust the height of the view.

To use the Walk tool to move through the model
1 Display one of the Full Navigation wheels or the mini Tour Building wheel.

2 Click and hold down the Walk wedge.
The cursor changes to the Walk cursor and the Center Circle icon is displayed.

3 Drag in the direction you want to walk.

NOTE While walking, press and hold down the + (plus) key to temporarily increase your movement speed.

4 Release the button on your pointing device to return to the wheel.

To change the movement speed for the Walk tool
1 Display a wheel.
2 Right-click the wheel, and click SteeringWheels Options.

3 In the Options Editor, the SteeringWheels page under the Interface node, use the Walk Speed slider.

Dragging the slider to the left decreases the walking speed; dragging the slider to the right increases the
walking speed.

4 Click OK.

To constraint the Walk tool to the world up vector
1 Display a wheel.
2 Right-click the wheel, and click SteeringWheels Options.

3 In the Options Editor, the SteeringWheels page under the Interface node, select the Constrain Walk Angle
check box.

4 Click OK.
Movement when walking is done parallel to the world up of the model.

To adjust the height of the current view from the Walk tool
1 Display one of the Full Navigation wheels or the mini Tour Building wheel.

2 Click and hold down the Walk wedge.
The cursor changes to the Walk cursor and the Center Circle icon is displayed.

SteeringWheels | 71



3 Do one of the following:
B Press and hold down the SHIFT key to enable the Up/Down tool; drag up or down.

B Press and hold down the UP ARROW or DOWN ARROW key.

4 Release the button on your pointing device to return to the wheel.

Zoom Tool

You use the Zoom tool to change the zoom magnification of a model.

NOTE When you start the Zoom tool from the Full Navigation wheel, incremental zooming must be enabled in the
Options Editor in order to use CTRL+click and SHIFT+click.

Zoom Constraints

When changing the magnification of a model with the Zoom tool, you cannot zoom in any further than the
focus point or out past the extents of the model. The direction you can zoom in and out is controlled by the
center point set by the Center tool.

NOTE Unlike the Zoom tool on the big View Object wheel, the Zoom tool on the mini View Object wheel and the
Full Navigation wheels are not constrained.

To zoom the view with a single click

NOTE You must enable incremental zoom when using the Full Navigation wheels, or a mini View Object wheel. For
the big View Object wheel, the incremental zoom is always enabled.

1 Do the following to make sure the Enable Single-Click Incremental Zoom In option is selected:
a Display the Full Navigation Wheel.

b Right-click the wheel, and click SteeringWheel Options.

c Inthe Options Editor, the SteeringWheels page under the Interface node, select the Enable Single-Click
Incremental Zoom In check box.

d Click OK.

2 Display a wheel that has the Zoom tool.

3 Click the Zoom wedge.

The magnification of the model is increased and you are zoomed in closer to the model. If you hold down
the SHIFT key while clicking the Zoom wedge, the model is zoomed out; you can hold down the CTRL key
to zoom in.

To zoom a view in and out by dragging

1 Display one of the Full Navigation wheels, or one of the View Object wheels.

2 Click and hold down the Zoom wedge.
The cursor changes to the Zoom cursor.
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3
4

Drag vertically to zoom in or out.

Release the button on your pointing device to return to the wheel.

To zoom in to an area of the model by specifying window

1
2
3

Display one of the Full Navigation wheels or the mini View Object wheel.
Press and hold down the SHIFT key.

Click and hold down the Zoom wedge.
The cursor changes to the Zoom cursor.

Drag the pointing device to define the opposite corner of the window that defines the area in which you
want to zoom.

NOTE Holding down the CTRL key while defining the second point of the window determines if the first point
of the window is used as the corner or center of the window being dragged. When the CTRL key is held down,
the first point defines the center of the window.

Release the button on your pointing device to return to the wheel.

To zoom in and out by scrolling the mouse wheel when a SteeringWheel is displayed

1
2
3

Display one of the wheels other than the big Tour Building wheel.
Scroll the wheel forward or backward to zoom in or out.

Release the button on your pointing device to return to the wheel.

Quick Reference

You use the Zoom tool to change the zoom magnification of a model. The following mouse click and key
combinations are available to control how the Zoom tool behaves:

Click. If you click the Zoom tool on a wheel, the current view is zoomed in by a factor of 25 percent. If you
are using the Full Navigation wheel, incremental zoom must be enabled in the Options Editor.

SHIFT+click. If you hold down the SHIFT key before you click the Zoom tool on a wheel, the current view is
zoomed in by a factor of 25 percent. Zooming is performed from the current pivot point, and not the location
of the cursor.

CTRL+click. If you hold down the CTRL key before you click the Zoom tool on a wheel, the current view is
zoomed in by a factor of 25 percent. Zooming is performed from the current pivot point, and not the location
of the cursor.

Click and drag. If you click the Zoom tool and hold down the button on your pointing device, you can adjust
the magnification of the model by dragging up and down.

CTRL+click and drag. When using the Full Navigation wheels or the mini View Object wheel, you can control
the target point used by the Zoom tool. By holding down the CTRL key, the Zoom tool uses the location of
the previous pivot point defined by the Zoom, Orbit, or Center tool.

SHIFT+click and drag. When using the Full Navigation wheels or the mini View Object wheel, you can zoom
in to an area of the model by dragging a rectangular window around the area you want to fit in the window.
Hold down the SHIFT key and then click and drag a window around the area in which you want to zoom.

NOTE If you hold down the CTRL key along with the SHIFT key, you can zoom in to an area of a model using a
center-based window instead of one defined by opposite corners.

Mouse wheel. When a wheel is displayed, scroll the mouse wheel up or down to zoom the view of the model
in or out.
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Camera

NOTE When you use the Zoom tool from the Full Navigation wheel or the View Object wheel, the point in the view
where you click to zoom becomes the Center point for future Orbit operations until you either use the Zoom tool again
or use the Center tool. If you press CTRL before you click the Zoom wedge, the Center point does not change.

Autodesk Navisworks offers you a number of prefixed options to control the camera position and orientation
during navigation.

Camera Projection

You can choose to use a perspective camera or an orthographic camera during navigation.

NOTE Orthographic cameras are not available with walk and fly navigation modes.

To use a perspective camera

» Click Perspective on the Navigation Tools toolbar.

£ Menu: Viewpoint » Navigation Tools » Perspective
To use an orthographic camera

» Click Orthographic on the Navigation Tools toolbar.

£ Menu: Viewpoint » Navigation Tools » Orthographic

Straighten Camera
You can straighten the camera to align with the viewpoint up vector.

When the camera position is close to the viewpoint up vector (within 13 degrees), you can use this function to
snap the camera to the appropriate axis.

TIP The same effect can be achieved by typing 0 at the base of the Camera Tilt control bar.

To straighten camera

» Click Viewpoint » Navigation Tools » Straighten.

Predefined Camera Views

In Autodesk Navisworks, you can align a camera to one of the axis, or select one of six predefined face views to
instantly change the camera’s position and orientation in the scene.

When you align the camera position along one of the axis:
B Aligning with X axis toggles between front and back face views.
B Aligning with Y axis toggles between left and right face views.

W Aligning with Z axis toggles between top and bottom face views.

NOTE In previous versions of Autodesk Navisworks, the front face view was fixed and linked to the ‘up’ direction of
the current viewpoint by default. In Autodesk Navisworks Freedom 2010 you can customize the location of the front
face by using the ViewCube. This change is global, and affects all viewpoints.
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To align with X-axis

» Click Align X on the Navigation Tools toolbar.

£ Menu: Viewpoint » Navigation Tools » Align X
To align with Y-axis

» Click Align'Y on the Navigation Tools toolbar.

£ Menu: Viewpoint » Navigation Tools » Align Y
To align with Z-axis

» Click Align Z [&%] on the Navigation Tools toolbar.

£ Menu: Viewpoint » Navigation Tools » Align Z

To look from a preset face view
1 Click Viewpoint » Look From.

2 Click one of the face views. Choose from:
m Top

Bottom

Front

|

|

B Back
B Left
|

Right

ViewCube

Autodesk® ViewCube® navigation tool provides visual feedback of the current orientation of a model. You can
use the ViewCube tool to adjust the viewpoint of your model.

Overview of the ViewCube

The ViewCube tool is a persistent, clickable, and draggable interface that you use to switch between views of
your model.

When you display the ViewCube, it is shown in the top- right corner of the Scene Area over the model in an
inactive state. While the ViewCube tool is inactive, it provides visual feedback about the current viewpoint of

the model as view changes occur. When the cursor is positioned over the ViewCube tool, it becomes active; you
can switch to one of the available preset views, roll the current view, or change to the Home view of the model.

doL o
LEFT

Control the Appearance of the ViewCube

The ViewCube tool is displayed in one of two states: inactive and active. When the ViewCube tool is inactive,
it appears partially transparent by default so that it does not obscure the view of the model. When active, it is
opaque and may obscure the view of the objects in the current view of the model.
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In addition to controlling the opacity level of the ViewCube when it is inactive, you can also control its size,
and the display of the compass. The settings used to control the appearance of the ViewCube are located in the
Options Editor.

Use the Compass

The compass is displayed below the ViewCube tool and indicates which direction North is defined for the model.
You can click a cardinal direction letter on the compass to rotate the model, or you can click and drag one of
the cardinal direction letters or the compass ring to interactively rotate the model around the center of the view.

N

S

To display or hide the ViewCube

B Click View » Head-Up Display » ViewCube.

To control the size of the ViewCube
1 Right-click the ViewCube tool, and click ViewCube Options.

2 Inthe Options Editor, the ViewCube page under the Interface node, select an option from the Size drop-down

list.
COptions Editor
+- General Show the ViewCube
+- Model ) - —
o Interface Size | Mediom ||
Display Urits Inactive opacity | 25% .v.
Selection —
Measure Keep scene upright
Snapping When dragging on the YiewCube
Wigwpaint Defaults
- Hyperlinks Snap ko the closest view
+- SmartTags
Developer ‘Wwhen clicking on the ViewCube
Display Fit-to-view on change
SpaceBall
ViewCube Use animated transitions when switching views
SteeringWwheels
+- File Readers Show the compass below the YiewCube
+- Tools
Defaults
[ Export... ] [ Import, .. OF ] [ Cancel ] [ Help ]
3 Click OK.

To control the inactive opacity of the ViewCube
1 Right-click the ViewCube tool, and click ViewCube Options.

2 In the Options Editor, the ViewCube page under the Interface node, select an option from the Inactive
Opacity drop-down list.
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COptions Editor
+- General Show the ViewCube
+- Model y
5 Interface Size | Aukomatic hdl
Display Urits Inactive opacity | 50% v.
Selection —
Measure Keep scene upright
Snapping When dragging on the YiewCube
Wiewpoint Defaults
- Hyperlinks Snap ko the closest view
+- SmartTags
Developer ‘Wwhen clicking on the ViewCube
Display Fit-to-view on change
SpaceBall
i Use animated transitions when switching views
YigwCube
SteeringWwheels
+/-File Readers Show the compass below the ViewCube
+- Tools
Defaults
[ Export... ] [ Import, .. OF ] [ Cancel ] [ Help ]
3 Click OK.

To display the compass for the ViewCube
1 Right-click the ViewCube tool, and click ViewCube Options.

2 In the Options Editor, the ViewCube page under the Interface node, select Show Compass Below the
ViewCube.

3 Click OK.

The compass is displayed below the ViewCube tool and indicates the direction of North for the model.

ViewCube Menu

Use the ViewCube menu to restore and define the Home view of a model, switch between view projection modes,
and change the interactive behavior and appearance of the ViewCube tool.

To display the ViewCube menu
To display the ViewCube menu, do one of the following:

B Right-click on the compass, Home icon, or the main area of the ViewCube tool.

B Click the context menu button located below the ViewCube tool.

Quick Reference

The ViewCube menu has the following options:

B Home. Restores the Home view saved with the model.

B Orthographic. Switches the current view to orthographic projection.
B Perspective. Switches the current view to perspective projection.
|

Lock to Selection. Uses the selected objects to define the center of the view when a view orientation change
occurs with the ViewCube tool.

NOTE If you click Home on the ViewCube tool, the view returns to the Home view even if Lock to Current Selection
is selected.
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Set Current View as Home. Defines the Home view of the model based on the current view.
Set Current View as Front. Defines the Front view of the model based on the current view.

Reset Front. Resets the Front view of the model to its default orientation.

ViewCube Options. Displays the Options Editor where you can adjust the appearance and behavior of the
ViewCube tool.

B Help. Launches the online Help system and displays the topic for the ViewCube tool.

Reorient the Current View

ViewCube is used to reorient the current view of a model. You can reorient the view of a model with the ViewCube
tool by clicking pre-defined areas to set a preset view current, click and drag to freely change the view angle of
the model, and define and restore the Home view.

TIP When the cursor is over one of the clickable areas of the ViewCube tool, the cursor changes to an arrow with a
small cube to indicate that it is over the ViewCube tool.

You use the other twenty defined areas to access angled views of a model. Clicking one of the corners on the
ViewCube tool reorients the current view of the model to a three-quarter view, based on a viewpoint defined by
three sides of the model. Clicking one of the edges reorients the view of the model to a half view based on two
sides of the model.

SRR

You can also click and drag the ViewCube tool to reorient the view of a model to a custom viewpoint other than
one of the twenty-six predefined viewpoints. As you drag, the cursor changes to indicate that you are reorienting
the current view of the model. If you drag the ViewCube tool close to one of the preset orientations and it is set
to snap to the closest view, the ViewCube tool rotates to the closest preset orientation.

The outline of the ViewCube tool helps you identify the form of orientation it is in: freeform or constrained.
When the ViewCube tool is in freeform orientation, not orientated to one of the twenty-six predefined views,
its outline is displayed as dashed. The ViewCube tool is outlined in a solid continuous line when it is constrained
to one of the predefined views.

Roll a Face View

When you view a model from one of the face views, two roll arrow buttons are displayed near the ViewCube
tool. Use the roll arrows to rotate the current view 90 degrees clockwise or counterclockwise around the center
of the view.
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Switch to an Adjacent Face

When the ViewCube tool is active while viewing a model from one of the face views, four orthogonal triangles
are displayed near the ViewCube tool. You use these triangles to switch to one of the adjacent face views.

Front View

You can define the Front view of a model to define the direction of the face views on the ViewCube tool. Along
with the Front view, the up direction of a model is also used to define the direction of the face views on the
ViewCube tool.

NOTE Front view is a global setting and will be the same for viewpoints.

To reorient the current view to a preset orientation

B Click one of the faces, edges, or corners on the ViewCube tool.

To view an adjacent face

NOTE Make sure a face view is current.

B Click one of the triangles displayed near the edges of the ViewCube tool.

=
0| senr ([

——

To interactively reorient the view

B Click the ViewCube tool, hold down the left mouse button, and drag in the direction that you want to orbit
the model.

To use animated transitions when reorienting a view to a preset orientation
1 Right-click the ViewCube tool, and click ViewCube Options.

2 In the Options Editor, the ViewCube page under the Interface node, select Use Animated Transitions When
Switching Views.
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COptions Editor

+- General Show the ViewCube
+- Model —
o Interface Size  |Mediom ||
Display Urits Inactive opacity | 25% .v.
Selection —
Measure Keep scene upright
Snapping When dragging on the YiewCube
Wiewpoint Defaults
- Hyperlinks Snap ko the closest view
+- SmartTags
Developer ‘when clicking on the YiewZube
Display Fit-to-view on change
SpaceBall
ViewCube Use animated transitions when switching views
SteeringWwheels
+/-File Readers Show the compass below the YiewCube
+- Tools
Defaults
[ Export... ] [ Import... OF ] [ Cancel ] [ Help ]

3 Click OK.

To automatically fit the model after a view orientation
1 Right-click the ViewCube tool, and click ViewCube Options.

2 In the Options Editor, the ViewCube page under the Interface node, select Fit-to-View on Change.

COptions Editor
+- General Show the ViewCube
+- Model ) - —
o Interface Size |Medium ||
Display Urits Inactive opacity | 25% .v.
Selection —
Measure Keep scene upright
Snapping When dragging on the YiewCube
Wiewpoint Defaults
- Hyperlinks Snap ko the closest view
+- SmartTags
Developer ‘when clicking on the ViewCube
Display Fit-to-view on change
SpaceBall
ViewCube Use animated transitions when switching views
SteeringWwheels
+/-File Readers Show the compass below the ViewCube
+- Tools
Defaults
[ Export... ] [ Import... OF ] [ Cancel ] [ Help ]

3 Click OK.

To roll a face view

NOTE Make sure a face view is displayed.

B Click one of the roll arrows displayed above and to the right of the ViewCube tool.
The left roll arrow rotates the view 90 degrees counterclockwise; the right roll arrow rotates the view 90
degrees clockwise.

To define the front view

B Right-click the ViewCube tool, and click Set Current View as Front.
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To restore the Front view

B Right-click the ViewCube tool, and click Reset Front.

Set the View Projection Mode

The ViewCube tool supports two different view projections: perspective and orthographic. Orthographic projection
is also referred to as parallel projection. Perspective projected views are calculated based on the distance from a
theoretical camera and target point. The shorter the distance between the camera and the target point, the more
distorted the perspective effect appears; greater distances produce less distorted affects on the model. Orthographic
projected views display all the points of a model being projected parallel to the screen.

Orthographic projection mode makes it easier to work with a model due to all the edges of the model appearing
as the same size, regardless of the distance from the camera. Orthographic projection mode though, is not how
you commonly see objects in the real world. Objects in the real world are seen in perspective projection. So when
you want to generate a rendering or hidden line view of a model, using perspective projection will give the model
a more realistic look.

The following illustration shows the same model viewed from the same viewing direction, but with different
view projections.

Orthographic Perspective

To change the view projection mode

B Right-click the ViewCube tool, and click one of the following options:
m Orthographic

W Perspective

Home View

The Home view is a special view stored with a model that makes it easy to return to a known or familiar view.
You can define any view of the model as the Home view. The saved Home view can be applied to the current
view by clicking the Home button above the ViewCube tool or from the ViewCube menu.

To define the Home view

B Right-click the ViewCube tool, and click Set Current View as Home.

To reorient the model to the Home view
B Click the Home button ( ) located near the ViewCube tool.

Examine Individual Objects with ViewCube

You can lock the ViewCube tool to a set of selected objects. Locking a selection of objects to the ViewCube tool
defines the center of the current view and the distance from center for the view based on the selected objects.
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Selecting and deselecting objects after Lock to Selection is turned on has no effect on the center or distance from
the center of the view when a view orientation changes. You cannot zoom to the extents of a model when Lock
to Selection is on, even if the ViewCube tool is set to zoom to extents after each view orientation change.

To lock to the current selection

B Right-click the ViewCube tool, and click Lock to Selection.
If Lock to Selection is checked when a view orientation change occurs, the selected objects are used to calculate
the center of the view and the view zooms to the extents of the selected objects. When cleared, the selected
objects are used to calculate the center of the view and the view zooms to the extents of the model.

To examine an individual object with ViewCube
1 In the model, select one or more objects to define the centerpoint of the view.

2 Click one of the preset locations on the ViewCube tool, or click and drag the ViewCube tool to reorient the
view of the model.

The ViewCube tool reorients the view of the model based on the centerpoint of the selected objects.

Navigation Aids

View All

SpaceBall

NOTE The term SpaceBall is used as a generic term for all 3D motion controllers from 3Dconnexion™, including the
SpaceBall, SpaceMouse and SpaceTraveler.

A SpaceBall can be used as an alternative to the mouse to move around the Scene Area.

The behavior of the SpaceBall corresponds to the currently selected navigation mode. This enables you to navigate
with the SpaceBall whilst performing other operations with the mouse.

If no mode is selected on the Navigation Mode toolbar or if the selected mode is not a valid mode for the SpaceBall,
then a default navigation mode will be used.

The speed of navigation is sensitive to the amount of force applied to the SpaceBall. You can adjust the SpaceBall
settings by using the Control Panel for the device which is supplied by the SpaceBall manufacturer with the
installation.

The default navigation mode and the speed of translation and rotation can be adjusted in the Options Editor.

Makes the complete model fit into the Scene Area.

Using this function dollies and pans the camera so that the entire model is shown in the current view, which is
very useful if you get lost inside a model or lose it completely.

Occasionally, you may get a blank view. This is usually because there are items that are very small in comparison
to the main model, or items that are located a long way away from the main model. In these cases, right-click
an item in the Selection Tree and click View Selected to find your way back to the model before trying to figure
out which items are "lost".

To view everything

>  Click View All [ on the Navigation Tools toolbar.

£ Menu: Viewpoint » Navigation Tools » View All
Shortcut menu: Scene » View All
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View Selected

Focus

Hold

Control

Gravity

Zooms the camera so that the selected items fill the Scene Area.

To view selected items

» Click View Selected on the Navigation Tools toolbar.

£ Menu: Viewpoint » Navigation Tools » View Selected
Shortcut menu: Scene » View Selected

You can put the Scene View into focus mode until the next click.

When you are in focus mode, clicking on an item swivels the camera so that the point clicked is in the center
of the view. This point becomes the focal point for examine, orbit, and turntable navigation modes.

To focus

» Click Focus ¥ on the Navigation Tools toolbar.

£ Menu: Viewpoint » Navigation Tools » Focus
Shortcut menu: Scene » Focus

When you navigate around a model in Autodesk Navisworks, it is possible to "pick up" or hold selected items
and move around with them in the model.

For example you may be viewing a plan for a factory and would like to see different configurations of machine
layouts.

To hold and release objects

1 Select the objects you want to hold either in the Scene Area or in the Selection Tree.

2 Click Hold on the Navigation Tools toolbar.

The selected objects are now held and will move with you through the model when you use navigation
modes, such as walk, pan and so on.

3 To release the held objects, click Hold on the Navigation Tools toolbar again.

4 If you want to reset the objects to their original position, click Edit » Reset All » Reset Transforms.

£ Menu: Viewpoint » Navigation Tools » Hold

the Realism of Your Navigation

NOTE This function only works in connection with collision.

Where collision gives you mass, gravity gives you weight. As such, you (as the collision volume) will be pulled
downwards whilst walking through the scene.

NOTE Gravity can only be used in walk navigation mode, and with the Walk tool for SteeringWheels.
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This allows you to walk down stairs, for example, or follow terrain.
To toggle gravity

» In walk navigation mode, click Gravity |2 on the Navigation Tools toolbar.

£ Menu: Viewpoint » Navigation Tools » Gravity
E Command entry: CTRL + G

Crouching

Collision

NOTE This function only works in connection with collision.

When walking or flying around the model with collision activated, you may encounter object that are too low
to walk under, a low pipe for example. This function enables you to crouch under any such objects.

With crouching activated, you will automatically crouch under any objects that you cannot walk under at your
specified height, thereby not impeding your navigation around the model.

TIP To temporarily crouch under a low object, hold down the Space bar to allow navigation to proceed.

To toggle crouching

» In walk or fly navigation mode, click Crouch [=il on the Navigation Tools toolbar.

£ Menu: Viewpoint » Navigation Tools » Crouch

This function defines you as a collision volume - a 3D object that can navigate around and interact with the
model, obeying certain physical rules that confine you within the model itself. In other words, you have a mass
and as such, cannot pass through other objects, points or lines in the scene.

You can walk over, or climb over objects in the scene that are up to half the height of the collision volume, thus
allowing you to walk up stairs, for example.

The collision volume, in its basic form, is a sphere (with radius = r), that can be extruded to give it height (with
height = h >=1). See diagram below:

3

2

The dimensions of the collision volume can be customized for the current viewpoint or as a global option.

L 2

NOTE Collision can only be used in walk and fly navigation modes, and with the Walk tool for SteeringWheels.

When collision is turned on, rendering prioritization is changed so that objects around the camera or avatar are
displayed with much higher detail than normal. The size of the region of high detail is based on collision volume
radius and speed of movement (needing to see what is about to be walked into).
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To toggle collision

» In walk or fly navigation mode, click Collision =] on the Navigation Tools toolbar.

£ Menu: Viewpoint » Navigation Tools » Collision
EE Command entry: CTRL + D

Third Person View

This function allows you to navigate scene from a third person perspective.

When third person is activated, you will be able to see an avatar which is a representation of yourself within the
3D model. Whilst navigating you will be controlling the avatar's interaction with the current scene.

Wiew1 & X

Using third person in connection with collision and gravity makes this a very powerful function, allowing you
to visualize exactly how a person would interact with the intended design.

NOTE When you use third person with SteeringWheels, the avatar is only shown with the Walk and Pan tools, to
prevent the screen clatter.

You can customize settings, such as avatar selection, dimention, and positioning, for the current viewpoint or
as a global option.

When third person view is turned on, rendering prioritization is changed so that objects around the camera or
avatar are displayed with much higher detail than normal. The size of the region of high detail is based on
collision volume radius, speed of movement (needing to see what is about to be walked into) and the distance
of the camera behind the avatar (in order to see what the avatar is interacting with).

To toggle third person view

» Click Third Person L% ] on the Navigation Tools toolbar.

£ Menu: Viewpoint » Navigation Tools » Third Person
E2 Command entry: CTRL + T

To add and use a custom avatar

IMPORTANT Autodesk does not recommend or support usage of the custom avatars.

1 Open the file you want to use as your avatar (.dwg, .skp etc.) in Autodesk Navisworks.
2 Click File » Save As.

3 In the Save As dialog box, select .nwd in the Save as Type box.
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4 Browse to the Autodesk Navisworks installation directory, for example: c:\Program

Files\Autodesk\Navisworks Freedom 2010\avatars\my new folder name.
5 Type in the new name for your avatar file, and click Save.
6 Restart Autodesk Navisworks, and open any file.
7 Click Tools » Global Options.
8 In the Options Editor, expand the Interface node, and click the Viewpoint Defaults option.
9 Click the Settings button.
0 In the Default Collision dialog box, slect the Enable check box in the Third Person area.
11 Select your avatar in the Avatar drop-down list.
12 Click OK to return to the Options Editor.
13 You can also change the size of the avatar by changing the Height and the Radius values in the Viewer area.
14 Click OK.

15 Restart Autodesk Navisworks.

Head-Up Display
Head-up display elements are on-screen displays that provide information about your location and orientation
in the 3D world.

In Autodesk Navisworks, you can use the following head-up display (HUD) elements:

B XYZ Axes - shows the X, Y, Z orientation of the camera (or the avatar’s eye if the avatar is visible). The XYZ
Axes indicator is located at the bottom-left of the Scene Area.

B Position Readout - shows the absolute X, Y, Z position of the camera (or the avatar's eye position if the avatar
is visible). The Position Readout is located at the bottom-left of the Scene Area.

B ViewCube - provides visual feedback about the current camera viewing angle in relation to the model world.
The ViewCube is located at the top-right of the Scene Area.

N

To toggle XYZ Axes

» Click View » Head-Up Display » XYZ Axes.

To toggle Position Readout

» Click View » Head-Up Display » Position Readout.
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To toggle ViewCube

» Click View » Head-Up Display » ViewCube.
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Control Model Appearance
and Render Quality

You can control both the appearance of the model in the Scene Area and the
quality of rendering in real time.

Control Model Appearance

You can use the Rendering Styles toolbar to control how your model
is displayed in the Scene Area.

FEMI M IR

You have a choice of one of four interactive lighting modes (full
lights, scene lights, head light, or no lights), four rendering modes
(full render, shaded render, wireframe or hidden line) and you can
individually turn each of the five primitive types (surfaces, lines,
points, snap points and text) on and off.

Select Render Mode

Rendering shades the scene's geometry using the lighting you've set
up, and the materials and environmental settings (such as
background) you've applied.

In Autodesk Navisworks, you can use four render modes to control
how the items are rendered in the Scene Area. The spheres below
demonstrate the effect that the render modes have on model
appearance. In order from the left, these are full render, shaded,
wireframe and hidden line.
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Full Render

In full render mode, the model is rendered with smooth shading including any materials that have been applied
using the Presenter tool, or have been brought through from the native CAD file.

NOTE Autodesk Navisworks does not convert all native CAD file's textures. For more details, see “Use File Readers”
and “Use File Exporters”.

To select full render mode

m Click Full Render on the Rendering Style toolbar.

£ Menu: Viewpoint » Rendering » Full Render

Shaded

In shaded mode, the model is rendered with smooth shading and without textures.
To select shaded mode

m Click Shaded |/ on the Rendering Style toolbar.

£ Menu: Viewpoint » Rendering » Shaded

Wireframe

In wireframe mode, the model is rendered in wireframe. As Autodesk Navisworks uses triangles to represent
surfaces and solids, all triangle edges are visible in this mode.

To select wireframe mode

B Click Wireframe on the Rendering Style toolbar.

£ Menu: Viewpoint » Rendering » Wireframe

Hidden Line

In hidden line mode, the model is rendered in wireframe, but only the outline and facet edges of surfaces that
are visible to the camera are displayed.

NOTE Unlike wireframe mode, where surfaces are rendered transparent, hidden line mode renders surfaces opaque.

To select hidden line mode

m Click Hidden Line on the Rendering Style toolbar.
£ Menu: Viewpoint » Rendering » Hidden Line
Add Lighting

In Autodesk Navisworks, you can use four lighting modes to control how the 3D scene is lit.

The spheres below demonstrate the effect the lighting styles have on them. In order from the left, these are full
lights, scene lights, head light and no lights.
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No Lights
This mode switches off all lights. The scene is shaded with flat rendering.

To turn off all lights

B Click No Lights on the Rendering Style toolbar.

£ Menu: Viewpoint » Lighting » No Lights

Head Light

This mode uses a single directional light located at the camera that always points in the same direction as the

camera.

You can customize the head light properties in the File Options dialog box.
To use head light mode

B Click Head Light on the Rendering Style toolbar.

£ Menu: Viewpoint » Lighting » Head Light

To adjust head light intensity
1 Click Tools » File Options.
2 In the File Options dialog box, click the Headlight tab.

File Options

| Culling || Orientation || Speed| Head Light | Scene Lights || DataTooIs|

Ambient: —ji

Headlight: 7]

[ aK |[ Cancel ][ Help ]

3 Move the Ambient slider to adjust the brightness of the scene, and the Headlight slider to adjust the brightness

of the directional light.
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TIP Turning on head light mode before following this procedure lets you instantly see the effect your changes
have on the scene rendering.

4 Click OK.

Scene Lights

This mode uses the lights that have been brought through from the native CAD file. If no lights are available,
two default opposing lights are used instead.

You can customize the intensity of scene lights in the File Options dialog box.
To use lights defined with the model

B Click Scene Lights on the Rendering Style toolbar.

£ Menu: Viewpoint » Lighting » Scene Lights

To adjust scene lights intensity
1 Click Tools » File Options.
2 In the File Options dialog box, click the Scene Lights tab.

3 Move the Ambient slider to adjust the brightness of the scene.

TIP Turning on scene lights mode before following this procedure lets you instantly see the effect your changes
have on the scene rendering.

4 Click OK.

Full Lights

This mode uses lights that have been defined with the Presenter tool.
To use lights defined with the Presenter tool

B Click Full Lights on the Rendering Style toolbar.

£ Menu: Viewpoint » Lighting » Full Lights

Select Background Effect

In Autodesk Navisworks, you can choose a background effect to use in the Scene Area.
Currently, the following options are available:

B Plain - the background of the 3D scene is filled with the selected color. This is the default background style.
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Plain background

B Graduated - the background of the 3D scene is filled with a smooth gradient between the two selected colors.

Graduated background

B Horizon - the background of the 3D scene is split across the horizontal plane giving the effect of a sky and
the ground. The resulting artificial horizon gives you an indication of your orientation in the 3D world. By
default, the artificial horizon respects the world up vector as set in File Options » Orientation.

NOTE The artificial horizon is a background effect, and does not include a physical ground plane. So, for example,
if you navigate ‘under the ground’ and look up, you will not see the back of a ground plane, instead you will see
the model from beneath, and a background filled with the sky color.

Horizon background

To set a plain background

1 Click Tools » Background.

2 In the Background Settings dialog box, select Plain in the Mode drop-down list.
3 Select the required color from the Color palette.
4

Review the new background effect in the preview box, and click OK.

To set a graduated background
1 Click Tools » Background.
2 In the Background Settings dialog box, select Graduated in the Mode drop-down list.

3 Select the first color from the Top Color palette.
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4 Select the second color from the Bottom Color palette.

5 Review the new background effect in the preview box, and click OK.

To set an artificial horizon background
1 Click Tools » Background.
2 In the Background Settings dialog box, select Horizon in the Mode drop-down list.
3 To set a graduated sky color, use the Sky Color and Horizon Sky Color palettes.
4 To set a graduated ground color, use the Horizon Ground Color and Ground Color palettes.
5

Review the new background effect in the preview box, and click OK.

Adjust Displaying of Primitives
You can enable and disable the drawing of surfaces, lines, points, snap points, and 3D text in the Scene Area.

Points are ‘real’ points in the model, whereas snap points mark locations on other primitives, for example the
center of a circle, and are useful for snapping to when measuring.

Surfaces

Surfaces are the triangles that make up the 2D and 3D items in the scene. You can toggle the rendering of surfaces
in the model.

To toggle the rendering of surfaces

B Click Surfaces on the Rendering Style toolbar.

£ Menu: Viewpoint » Display » Surfaces

Lines

You can toggle the rendering of lines in the model. You can also change the width of the drawn lines by using
the Options Editor.

To toggle the rendering of lines

m Click Lines on the Rendering Style toolbar.

£ Menu: Viewpoint » Display » Lines

To change the line width
1 Click Tools » Global Options.
2 In the Options Editor, expand the Interface node, and click the Display options.

3 On the Display page, Primitives area, enter a number between 1 and 9 in the Line Size box.
This sets the width in pixels for lines drawn in the Scene Area.

4 Click OK.
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Points

Points are real points in the model, for example, the points in a point cloud in a laser scan file. You can toggle
the rendering of points in the model. You can also change the size of drawn points by using the Options Editor.

To toggle the rendering of points

m Click Points on the Rendering Style toolbar.

£ Menu: Viewpoint » Display » Points

To change the size of points
1 Click Tools » Global Options.
2 In the Options Editor, expand the Interface node, and click the Display option.

3 On the Display page, Primitives area, enter a number between 1 and 9 in the Point Size box.

This sets the size in pixels for points drawn in the Scene Area.

4 Click OK.

Snap Points

Snap points are implied points in the model, for example, the center point of a sphere or end points of a pipe.
You can toggle the rendering of snap point in the model. You can also change the size of the drawn snap points
by using the Options Editor.

To toggle the rendering of snap points
B Click Snap Points on the Rendering Style toolbar.

To change the size of snap points

1 Click Tools » Global Options.
2 In the Options Editor, expand the Interface node, and click the Display option.

3 On the Display page, Primitives area, enter a number between 1 and 9 in the Snap Size box.
This sets the size in pixels of snap points drawn in the Scene Area.

4 Click OK.

Text

You can toggle the rendering of 3D text in the model.

To toggle the rendering of 3D text

B Click Text on the Rendering Style toolbar.

£ Menu: Viewpoint » Display » Text
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Control Render Quality

Use Culling

Culling lets you navigate and manipulate large and complex scenes at interactive rates by intelligently hiding
less-important objects as you work.

In Autodesk Navisworks, you can use the following methods of culling objects:

B Area - the objects’ size in pixels determines whether the objects are rendered or not. By default, any objects
smaller than 1x1 pixels in size are discarded.

B Backface - by default, only the front face of every polygon is drawn in Autodesk Navisworks. Sometimes,
during the conversion process the front and back face of polygons get mixed, in which case, you need to
adjust the Backface option.

B Near and Far Clipping Planes (frustum culling) - objects closer to the camera than the near clipping plane or
beyond the far clipping plane are not drawn. You can let Autodesk Navisworks automatically constrain the
location of the clipping planes, or you can constrain their location manually.

To set area culling

1 Click Tools » File Options.
2 In the File Options dialog box, Culling tab, select the Enable check box in the Area section.

3 Enter a value for the screen area in pixels below which geometry objects are culled. For example, setting
this value to 100 pixels means that any object within the model that would be drawn less than 10x10 pixels
in size are discarded.

4 Click OK.

To turn on backface culling for all objects
1 Click Tools » File Options.
2 In the File Options dialog box, Culling tab, select On in the Backface area.
3 Click OK.

To turn off backface culling for all objects
1 Click Tools » File Options.
2 In the File Options dialog box, Culling tab, select Off in the Backface area.
3 Click OK.

To turn on backface culling only for solid objects
1 Click Tools » File Options.
2 In the File Options dialog box, Culling tab, select Solid in the Backface area.
3 Click OK.

To constrain the position of the clipping planes automatically

—

Click Tools » File Options.

2 In the File Options dialog box, click the Culling tab.
3 Select Automatic for the Near clipping plane.
4

Select Automatic for the Far clipping plane.
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5

Click OK.

Autodesk Navisworks automatically controls the position of near and far clipping planes to give you the
best view of the model.

To constrain the position of the clipping planes manually

1

2
3
4
5

Click Tools » File Options.

In the File Options dialog box, click the Culling tab.

Select Constrained for the Near clipping plane, and enter the desired value in the Distance box.
Select Constrained for the Far clipping plane, and enter the desired value in the Distance box.

Click OK.

Autodesk Navisworks uses the provided values unless doing so affects the system performance (for example,
makes the whole model invisible), in which case it adjusts the position of the clipping planes as necessary.

To fix the position of the clipping planes

1
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Click Tools » File Options.

In the File Options dialog box, click the Culling tab.

Select Fixed for the Near clipping plane, and enter the desired value in the Distance box.
Select Fixed for the Far clipping plane, and enter the desired value in the Distance box.

Click OK.

IMPORTANT Autodesk Navisworks uses the provided values even if doing so affects the system performance (for
example, makes the whole model invisible).

Make Objects Required

Although Autodesk Navisworks intelligently prioritizes objects for culling in the scene, sometimes it drops out
geometry that needs to remain visible while navigating.

You can make sure the objects are always rendered during interactive navigation by making them required.

To make objects required

1

2

Select geometry items that you want to remain visible during navigation in the Selection Tree.

Click Required 2] on the Selection Tools toolbar.
In the Selection Tree, the object appear red when required.

TIP Clicking Required again makes the selected objects unrequired.

£ Menu: Edit » Required
E Command entry: CTRL + R

Shortcut menu: Required

To make all objects unrequired

B Click Edit » Reset All » Unrequire All.

Shortcut menu: Scene » Reset All » Unrequire All
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Control Rendering of Objects

Adjust Scene Rendering During Navigation

Your models can range in size from small models to complex supermodels. As you navigate a scene in real time,
Autodesk Navisworks automatically calculates which items to render first, based on the size of items, distance
from the camera, and the specified frame rate. This customizable frame rate is guaranteed by default, but can be
turned off, if necessary. Items that Autodesk Navisworks does not have time to render are dropped out. These
dropped items are rendered when navigation stops.

The amount of drop-out depends on several factors, such as your hardware performance (graphics card and
driver), the size of the Scene Area, and the size of the model. When working with truly large supermodels in
Autodesk Navisworks, you will require a sufficient amount of RAM to load and review the data.

Autodesk Navisworks employs JetStream technology which optimizes the usage of the available RAM. Before
running out of memory, Autodesk Navisworks pages unnecessary data to the hard disk, freeing up space for
loading to continue. JetStream technology also enables you to start navigating the supermodel, before it has
been completely loaded into memory. Autodesk Navisworks is large address aware, and utilizes any additional
memory assignment following the 3GB switch available on Windows XP systems.

TIP You can reduce the amount of drop-out during navigation by reducing frame rate, or switching off the Guarantee
Frame Rate option.

To set the target frame rate
1 Click Tools » File Options.

2 In the File Options dialog box, Speed tab, select the number of frames per second to be applied to the
rendered display of the model.

3 Click OK.

To set the level of detail

1 Click Tools » Global Options.
2 In the Options Editor, expand the Interface node, and click the Display option.

3 On the Display page, Detail area, select the Guarantee Frame Rate check box to maintain the target frame
rate during navigation. If this check box is clear, the complete model is rendered during navigation, no
matter how long it takes.

4 Select the Fill in Detail check box to render a complete model when navigation stops. If this check box is
clear, the items dropped out during navigation are not filled in when it stops.

5 Select the Batch Fill check box if you want the dropped out items to be rendered in chunks rather than
gradually.

NOTE This check box is clear by default, as gradual rendering gives better results for most video cards.

6 Click OK.

To render transparent items

NOTE If your video card supports hardware accelerated OpenGL, you can turn on the rendering of transparent items
during interactive navigation. By default, transparent items are only drawn when interaction has ceased to prevent
problems with display performance.

1 Click Tools » Global Options.
2 In the Options Editor, expand the Interface node, and click the Display option.

3 On the Display page, Transparency area, select the Interactive Transparency check box.
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4 Click OK.

To render parametric primitives

NOTE Modifying this option requires a restart of Autodesk Navisworks to take effect.

1 Click Tools » Global Options.

2 In the Options Editor, expand the Interface node, and click the Display option.

3 On the Display page, Primitives area, select the Enable Parametric Primitives check box. The level of detail
changes during navigation depending on the distance from the camera.

If you want to use the default representations of primitives, clear this check box. The level of detail stays
the same during navigation.

Click OK.

Accelerate Display Performance

If your video card supports OpenGL, you can improve the graphical performance by turning on hardware
acceleration and occlusion culling.

Using the hardware acceleration usually gives you better and faster rendering. However, some graphics cards
may not function well in this mode in which case switching this option off is recommended.

Occlusion culling can significantly improve performance in situations when much of the model is not visible.
For example, when you walk down the corridor of a building, the walls occlude most geometry outside the
corridor. Other rooms are only visible through doorways or windows. Turning on occlusion culling dramatically
reduces the rendering load in such cases.

To use hardware acceleration

NOTE If your video card does not support OpenGL hardware acceleration, this option is not available.

1 Click Tools » Global Options.
2 In the Options Editor, expand the Interface node, and click the Display option.

3 On the Display page, Acceleration area, select the Hardware Acceleration check box. This allows Autodesk
Navisworks to utilize any available OpenGL hardware acceleration on your video card.

NOTE If your video card drivers do not function well with Autodesk Navisworks, clear this check box.

4 Click OK.

To use occlusion culling
1 Click Tools » Global Options.
2 In the Options Editor, expand the Interface node, and click the Display option.
3 On the Display page, Acceleration area, select the Occlusion Culling check box.
4 Click OK.

NOTE Occlusion culling can only be used on a machine with an OpenGL 1.5 compliant graphics card.

Adjust Presenter Materials

You can adjust the appearance of Presenter materials in the Scene Area to get optimum performance from your
graphics card when navigating around heavily textured scenes.
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See also:

B “Presenter Page” on page 150
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Review Your Model

Select Objects

Autodesk Navisworks provides several methods to interactively select
items.

Interactive Geometry Selection

In Autodesk Navisworks, there is a concept of an active selection
set (the currently selected items, or the current selection) and saved
selections sets. You cannot save any selection or search sets yourself,
but you can use the selection or search sets saved in the model (the
Sets tab on the Selection Tree).

Selecting items makes them part of the current selection, so you
can hide them or override their colors.

You can use several methods to interactively select items into the
current selection. You can use the tabs in the Selection Tree, select
items directly in the Scene Area with select mode, and you can select
other items with similar properties to an existing selection using
the selection commands.

You can also customize the level at which you select items (selection
resolution), and modify the highlighting method for the items
selected in the Scene Area.

Selection Tree Window

The Selection Tree is a dockable window, which displays a variety
of hierarchical views of the structure of the model, as defined by
the CAD application in which the model was created.
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Selection Tree S

E| Conference Center.nwd
E| Structural Model.nwc
@4 15T FLOOR
@4 B1 BASEMENT
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@£ 4TH FLOOR
@4 7TH FLOOR
®2¥ 5TH FLOOR. EXHIBITION
HE <No level>
MEP Model.nwc
Architectural Model.nwc
Architectural Model - Columns Construct
Architectural Slabs - Construction.nwc

<] B

Standard | Compact | Properties | Sets

Autodesk Navisworks uses this hierarchical structure to identify object-specific paths (from the file name down
to a particular object).

By default there are four tabs:
B Standard. Displays the default tree hierarchy, including all instancing.

B Compact. Displays a simplified version of the hierarchy on the Standard tab, omitting various items. You
can customize the level of complexity of this tree in the Options Editor.

B Properties. Displays the hierarchy based on the items' properties. This enables simple manual searching of
the model by item property.

B Sets. Displays a list of selection and search sets. If no selection and search sets have been created, this tab is
not shown.

Naming of items reflects the names from the original CAD application, wherever possible. There are different
tree icons representing the types of geometry making up the structure of the model. Each of these item types
can be marked as hidden (gray), unhidden (dark blue) or required (red).

NOTE If a group is marked as hidden or required, then all instances of that group are marked as hidden or required.
If you want to operate on a single occurrence of an item, then you should mark the instanced group (the level above,
or the “parent”, in the hierarchy) hidden or required.

To toggle the Selection Tree

B Click Selection Tree on the Workspace toolbar.

£ Menu: View » Control Bars » Selection Tree
E2 Command entry: CTRL + F12

To use the Selection Tree to select objects
1 Open the Selection Tree, and click the Standard tab.

2 Click an object in the Selection tree to select the corresponding geometry in the Scene Area.

NOTE When you select an item in the tree, individual geometry or a group of geometry is selected in the Scene
Area depending on chosen selection resolution.

3 To select several items at the same time, use the SHIFT and CTRL keys. CTRL allows multiple selection item
by item, and SHIFT allows multiple selection between the first and last items selected.
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4 To remove selection from an object in the Selection Tree press ESC.

To customize the contents of the Compact tab
1 Click Tools » Global Options.
2 In the Options Editor, expand the Interface node, and click the Selection option.

3 On the Selection page, select the required level of detail in the Compact Tree box. Choose from the following
options:

B Models - the tree is restricted to displaying model files only.
B Layers - the tree can be expanded down to the layer level.

B Objects - can be expanded down to the objects level, but without the levels of instancing shown on the
Standard tab.

4 Click OK.

Quick Reference

Icon Description

A model, such as a drawing file or design
file.

= A layer or level.

& A group, such as a block definition from
AutoCAD or cell definition from MicroSta-
tion.

& An instanced group, such as an inserted

block from AutoCAD or cell from MicroSta-
tion. If in the imported file the instance
was unnamed, Autodesk Navisworks names
the instance to match its child's name.

& An item of geometry, such as a polygon.

& An instanced item of geometry, such as an
instance from 3D Studio.

& A composite object. A single CAD object
that is represented in Autodesk Navisworks
by a group of geometry items.

h Saved selection set.

L] Saved search set.

Selection Modes

There are two selection modes available from the Selection Tools toolbar to control how you select geometry.

IREX=ES

As standard, selection modes are mutually exclusive to navigation modes, and SteeringWheels, so that when
you are selecting you cannot navigate and vice versa.
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NOTE When using a SpaceBall in conjunction with the standard mouse control, the SpaceBall can be configured for
navigation and the mouse for selecting. See “SpaceBall” on page 82 for more information.

Selecting geometry in the Scene Area automatically selects the corresponding objects in the Selection Tree.

Holding the SHIFT key whilst selecting items in the Scene Area cycles through the selection resolution, allowing
you to get more specific with your selections.

You can use the Options Editor to customize the distance from an item you have to be for it to be selected (pick
radius). This is useful when you select lines and points.

Select Mode

In select mode, you can click an item in the Scene Area to select it. Once a single item is selected, its properties
are shown in the Properties window.

To use select mode to select geometry

1 Click 2] on the Selection Tools toolbar.

2 Click an item in the Scene Area to select it.

3 To select multiple geometry, press and hold down the CTRL key while clicking items in the scene.

4 Toremove items from the current selection, hold down the CTRL key while clicking them again. Alternatively,

press the ESC key to to remove all items from the current selection.

£ Menu: Edit » Select » Select
E: Command entry: CTRL + 1

To set the pick radius
1 Click Tools » Global Options.
2 In the Options Editor, expand the Interface node, and click the Selection option.

3 On the Selection page, enter the radius in pixels that an item has to be within in order to be selected. The
valid values are between 1 and 9.

4 Click OK.

Selection Commands

Selection commands enable you to quickly alter the current selection using logic. You can select multiple items
based on the currently selected items' properties, or quickly invert the set, select everything or nothing.

To select items with selection commands
1 Click Edit » Select.

2 Click the required selection command.

Quick Reference

The selection commands are as follows:
Select All. Selects all items contained within the model.
Select None. Deselects everything in the model.

Invert Selection. Currently selected items become deselected and vice versa.

Selection Sets. Provides you with options to save and recall selection and search sets.
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B Select Multiple Instances. Selects all instances (sometimes called insertions) of the currently selected geometry
group that occur in the model.

B Select Same Name. Selects all items in the model that have the same name as the currently selected item.
B Select Same Type. Selects all items in the model that have the same type as the currently selected item.

B Select Same <Property>. Selects all items with the same property as the currently selected item. This property
can be any searchable property currently attached to the item, for example material or hyperlink.

NOTE Using the Select Same <Property> command works by comparing items' properties. If you have multiple
items selected when you perform a selection command of same name or type and so on, all the types, names and
properties of the items in the current selection are compared with all items’ properties in the scene. The items with
properties matching any properties of the currently selected items are selected.

Set Selection Resolution

When you click an item in the Scene View, Autodesk Navisworks doesn't know what level of item to start selecting
at - do you mean the whole model, or the layer, or the instance, or group, or just the geometry? The default
selection resolution specifies a starting point for the object path in the Selection Tree so that Autodesk Navisworks
can locate and select the item.

You can customize the default selection resolution in the Options Editor. Or you can use a quicker way, by
right-clicking any item in the Selection Tree and clicking Set Selection Resolution to X, where X is one of the
available selection resolutions.

If you find you have selected the wrong level of item, you can interactively cycle through the selection resolution,
without having to go to the Options Editor or the Selection Tree. You can do this by holding down the SHIFT
key when clicking an item. This selects an item one level more specific each time you click the item until the
resolution gets to "geometry", at which point it reverts back to "model". Clicking on a different item reverts the
selection resolution back to default (as set in the Options Editor).

To set the default selection resolution
1 Click Tools » Global Options.
2 In the Options Editor, expand the Interface node, and click the Selection option.
3 On the Selection page, select the required starting point for the object path in the Resolution box.
4 Click OK.

Quick Reference

The available options for selection resolution are as follows:
Model. Makes the object path start at the model node; as a result, all objects in the model are selected.
Layer. Makes the object path start at the layer node; as a result all objects within a layer are selected.

First Object. Makes the object path start at the highest level of objects below the layer node, if applicable.

Last Object. Makes the object path start at the lowest level of objects in the Selection Tree. Autodesk Navisworks
looks for composite objects first, and if none are found, the geometry level is used instead. This is the default
option.

B Last Unique. Makes the object path start at the first unique level of objects (not multiple-instanced) in the
Selection Tree.

B Geometry. Makes the object path start from the geometry level in the Selection Tree.

Set Selection Resolution | 105



Set Highlighting Method

You can use the Options Editor to customize color and method of highlighting geometry selected in the Scene
Area.

There are three types of highlighting:
B Shaded

B Wireframe

W Tinted

To toggle highlighting of selected objects
1 Click Tools » Global Options.
2 In the Options Editor, expand the Interface node, and click the Selection option.

3 On the Selection page, Highlight area, select the Enabled check box, if you want the selected items to be
highlighed in the Scene Area. Clear this check box, if you don’t want any highlighting.

4 Click OK.

To customize the way objects are highlighted

—

Click Tools » Global Options.
In the Options Editor, expand the Interface node, and click the Selection option.
Make sure the Enabled check box is selected.

Use the Method drop-down list to select the type of highlighting you want (Shaded, Wireframe or Tinted).

©n A W N

Click the Color palette to select the highlight color.
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6 If you selected Tinted in the Method box, use the slider to adjust the Tint Level.
7 Click OK.

Hide Objects

Autodesk Navisworks provides tools that can be used to hide and display objects or groups of objects. Hidden
objects are not drawn in the Scene Area.

Hide Selected Objects

You can hide the objects in the current selection so that they are not drawn in the Scene Area. This is useful
when you want to remove specific parts of the model. For example, when you walk down the corridow of
building, you may want to hide a wall that occlude your view of the next room.

Hide Unselected Objects

You can hide all items except those currently selected so that they are not drawn in the Scene Area. This is useful
when you only want to see specific parts of the model.

NOTE In the Selection Tree, the items appear gray when marked as hidden.

To make selected objects hidden

1 In the Scene Area, select all items you want to hide.

2 Click Hidden on the Selection Tools toolbar.
The selected objects are now invisible.

TIP Clicking Hidden =21 again displays the invisible objects.

£ Menu: Edit » Hidden
E: Command entry: CTRL + H

Shortcut menu: Hidden
To make unselected items hidden

1 In the Scene Area, select all items you want to review.

2 Click Unselected Hidden on the Selection Tools toolbar.
Only the selected geometry remains visible.

TIP Clicking Unselected Hidden =] again displays the invisible objects.

£ Menu: Edit » Unselected Hidden
Shortcut menu: Unselected Hidden

To reveal all hidden objects

B Click Edit » Reset All » Unhide All.

Shortcut menu: Scene » Reset All » Unhide All
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Find Objects

You can run simple manual searches of the model by item property. To do this:

B On the Selection Tree, click the Properties tab, and click the saved property search in the list.
The corresponding model geometry is selected in the Scene Area.

Use Sets of Objects

In Autodesk Navisworks, you cannot save any selection or search sets yourself, but you can use the selection or
search sets saved in the model.

Selection sets store a group of items for later retrieval. There is no intelligence behind this set - if the model
changes at all, the same items will be selected (assuming they are still available in the model) when recalling the
selection set.

Search sets work in a similar way, except that they save search criteria instead of the results of a selection. So, if
there are any search sets saved in the model, then you use them in Autodesk Navisworks to run the search and
select the resulting objects.

Selection and search sets can be named and contain comments. They can also be highlighted with icons in the
main navigation window, so that when you click on one, the selection set is restored to the active set and all
the items within it are re-selected.

To reselect items from a selection or search set
1 Open the Selection Tree window, and click the Sets tab.

2 Click the saved selection or search set from the list.

On recalling a selection set, all the items that were selected when the set was saved are re-selected into the
current selection.

On recalling a search set, the search that was saved into the set is re-run and any items matching the
specification are selected into the current selection.

Object Properties

Properties Window

The Properties window is a floating window, which has a dedicated tab for each property category associated
with the currently selected object.

Properties =

Ttem | Element | Level | Phase Created | 1.41% |

Froperty Walue

Mame Generic - 6"

Type Floors: Generic - B

Internal Type LcRevitComposite

lcon Composite Object

Hidden Mo

Fequired Mo

I aterial

Source File Architectural Slabs - Constru..
Layer B2 BASEMENMT

Internal file properties, such as transform and geometry properties, are not shown by default. The Options Editor
enables you to switch this on.
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To toggle the Properties window

B Click Properties ] on the Workspace toolbar.

£ Menu: View » Control Bars » Properties
E: Command entry: SHIFT + F7

To examine object’s properties

1
2

Select the object of interest in the Selection Tree, or in the Scene Area.

Open the Properties window, and use the tabs to navigate between the available property categories.

NOTE If more than one object is selected, the Properties window only shows the number of selected items, and
doesn’t show any property information.

To add tabs with internal properties to the Properties window

1

2
3
4

Comments

Click Tools » Global Options.
In the Options Editor, expand the Interface node, and click the Developer option.
On the Developer page, select the Show Internal Properties check box.

Click OK.

Add Comments

You cannot record any comments in Autodesk Navisworks, but you can view comments attatched to viewpoints,
viewpoint animations, selection and search sets in the model.

Comments Window

The Comments window is a dockable window that enables you to view comments.

Commernts *
Comment Date Authar () Status
(11 Comment £:23:06 4., Admin 2 Hew

Comment

The Comments window shows the name, time and date, author, ID, status, and subject (or first line) of each
comment. There are different icons helping you to identify the source of each comment at a glance.

To toggle the Comments window

m Click Comments on the Workspace toolbar.
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To view comments
1 Open the Comments window.
2 Go the source of your comments. For example, open the Saved Viewpoints window.

3 Asyou click the source items, for example, viewpoints, the associated comments are displayed in the
Comments window.

Quick Reference

Icon Description

] Viewpoint (orthographic camera)
) Viewpoint (perspective camera)
[m] Viewpoint animation

B Viewpoint animation cut

ol Redline tag

Links

There are several sources of links in Autodesk Navisworks: original links that have been converted from the native
CAD files, links that have been added by Autodesk Navisworks users, and links that have been automatically
generated by the program (for example, viewpoint links).

The links converted from the native CAD files, and the links added by Autodesk Navisworks users are treated as
object properties. This means, you can examine them in the Properties window.

All links are saved with Autodesk Navisworks files so that as the model changes, the links remain there for you
and others to view.

Link Categories
There are two types of links: standard and user-defined.
Standard links are split into the following categories:
B Hyperlink
m Tag
B Viewpoints
|

Redline tags

By default, all links except tags, are drawn as icons in the Scene Area. Tags are drawn as text.
If available, User-defined links are drawn as icons in the Scene Area by default.

You can use the Options Editor to toggle the display of each of the link categories, and also to control their
appearance.

Display Links
You can switch links in the Scene Area on and off. You can also toggle the display of each of the link categories.
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When links are switched on, you can reduce the screen clutter by restricting a number of links can be shown in
the Scene Area, hiding colliding icons, and using culling. Finally, as some standard link categories can have
comments associated with them, you can choose to only draw links with attached comments.

To toggle the display of links

m Click Hyperlinks on the Workspace toolbar.

£ Menu: Tools » Hyperlinks

To control the display of standard links

1 Click Tools » Global Options.

2 In the Options Editor, expand the Interface node, expand the Hyperlinks node, and click the Standard
Categories option.

3 On the Standard Categories page, select the Visible check box to display the corresponding link category.
Clearing the check box hides the corresponding link category in the Scene Area.

By default, all standard link categories are visible.

4 Click OK.

To control the display of user-defined links

1 Click Tools » Global Options.

2 In the Options Editor, expand the Interface node, expand the Hyperlinks node, and click the User-Defined
Categories option.

3 On the User-Defined Categories page, select the Visible check box to display the corresponding link category.
Clearing the check box hides the corresponding link category in the Scene Area.

By default, all user-defined link categories are visible.

NOTE If no user-defined categories have been added, this page is empty.

4 Click OK.

To reduce the screen clutter

1 Click Tools » Global Options.
2 In the Options Editor, expand the Interface node, and click the Hyperlinks option.

3 On the Hyperlinks page, enter the number of links into the Max Icons box. By default, up to 25 links can
be visible.

4 To hide links that appear overlapped in the Scene Area, select the Hide Colliding Icons check box.

5 In the Cull Radius box enter the desired value. Only the links located within the specified distance from
the camera are drawn in the Scene Area. The default value of O means that all links are drawn.

6 Click OK.

To hide links without comments

1 Click Tools » Global Options.

2 In the Options Editor, expand the Interface node, expand the Hyperlinks node, and click the Standard
Categories option.

3 On the Standard Categories page, select the Hide Icons Without Comments check box for all required link
categories.

By default, links without comments are also displayed.
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4 Click OK.

Customize Links
You can customize the default appearance of links in Autodesk Navisworks. In particular, you can draw them in
3D, and you can add leader lines (arrows) pointing to the attachment point on the items. You can also choose

how to represent each link category (as an icon or as text).

To draw links in 3D mode

NOTE In 3D mode links can become hidden by other objects in the scene when you are navigating.

1 Click Tools » Global Options.
2 In the Options Editor, expand the Interface node, and click the Hyperlinks option.

3 On the Hyperlinks page, select the In 3D check box.
Links now float in 3D space just in front of their attachment points to the items.

4 Click OK.

To show leader lines
1 Click Tools » Global Options.
2 In the Options Editor, expand the Interface node, and click the Hyperlinks option.

3 On the Hyperlinks page, Enter the X- and Y- distance in Leader Offset for the number of pixels to the right
and up that these leader lines will use. The default angle is 0. The recommended angle is 45.

Links in the Scene Area have now leader lines pointing to the attachment point on the items.

4 Click OK.

To customize appearance of standard links
1 Click Tools » Global Options.

2 In the Options Editor, expand the Interface node, expand the Hyperlinks node, and click the Standard
Categories option.

3 On the Standard Categories page, use the Icon Type box to specify how you want a link to be drawn for
each of the available categories. You can choose between an icon and text.

By default, tag links are shown as text, and the rest of the link categories are shown as icons.

4 Click OK.

To customize appearance of user-defined links

1 Click Tools » Global Options.
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2 In the Options Editor, expand the Interface node, expand the Hyperlinks node, and click the User-Defined
Categories option.

3 On the User-Defined Categories page, use the Icon Type box to specify how you want a link to be drawn
for each of the available categories. You can choose between an icon and text. By default, links with
user-defined categories are shown as icons.

NOTE If no user-defined categories have been added, this page is empty.

4 Click OK.

Quick Reference

The table below shows the icons that can be used to represent different link categories in the Scene Area.

Icon Description
Represents links that have hyperlink, tag,

or any user-defined category (and points
to a web address).

Represents links that have hyperlink, tag,
or any user-defined category (and points
to an external file).

Represents links with viewpoints category
(perspective camera mode).

Represents links with viewpoints category
(orthographic camera mode).

Represents links with redline tags category.

Find and Follow Links

Links are an extremely useful review tool to allow you to access non-graphical information through the graphical
interface of Autodesk Navisworks.

The links converted from the native CAD files, and the links added by Autodesk Navisworks users are treated as
object properties. This means, you can examine them in the Properties window.

To follow a default link

1 Make sure links are switched on. If not, click Hyperlinks [=2| on the Workspace toolbar.

2 Click the desired link in the Scene Area to open the attached data source.

Shortcut menu: Follow Link

To follow one of the non-default links

1 Make sure links are switched on. If not, click Hyperlinks on the Workspace toolbar.

2 Right-click the default link, and click the Select [tem Containing Hyperlink option. This option is only
available for multiple hyperlinks attached to the same item.

3 Click Review » Hyperlinks, and click the link that you want to follow.
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Smart Tags

Smart tags display property information in a tooltip style window as you move your cursor over objects in the
Scene Area. You don't need to select objects first. The smart tags disappear after a few seconds.

By default, smart tags show the name and type of the object, but you can use the Options Editor to define which
properties are shown. Each definition that you configure enables you to display an additional category/property
combination in smart tags. You can choose whether to hide caterory names in smart tags or not.

NOTE When you move your mouse over an object that doesn't have the requested property, Autodesk Navisworks
searches up the selection tree for a parent object that contains that information, and displays it instead, thus maximising
the useful information you get.

To toggle the display of smart tags

B Click Smart Tags on the Workspace toolbar.

£ Menu: Tools » Smart Tags

To add a smart tag definition
1 Click Tools » Global Options.
2 In the Options Editor, expand the Interface node, expand the SmartTags node, and click the Definitions
option.

3 On the Definitions page, click Grid View to display smart tag definitions as table rows.

4 Click Add Element . A new row is added to the top of the table.

5 Click the Category column, and select the property category from the drop-down list, for example ‘Item.’
The options available depend on the property categories in your model.

6 Click the Property column, and select the property name from the drop-down list, for example, ‘Material’.
The options available depend on the selected property category.

7 Click OK.

NOTE You can add as many definitions to your smart tags as you like.

To delete a smart tag definition
1 Click Tools » Global Options.

2 In the Options Editor, expand the Interface node, expand the SmartTags node, and click the Definitions
option.

3 On the Definitions page, click Grid View = to display smart tag definitions as table rows.
4 Click the Category or Property for the definition that you want to delete.
5 Click Remove Element © .
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6 Click OK.

To hide category names
1 Click Tools » Global Options.
2 In the Options Editor, expand the Interface node, and click the SmartTags option.
3 Select the Hide Category check box.
4 Click OK.
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Use Viewpoints and
Sectioning Modes

Viewpoints are snapshots taken of the model as it is displayed in the scene.
Viewpoints may include a variety of comments and redline tags, which have been
previously added to a viewpoint. You cannot create viewpoints in Autodesk
Navisworks, but you can use any of the viewpoints and viewpoint animations
saved in the model. Viewpoint animation typically contains both the user
movement through the model and views of the model.

Create and Modify Viewpoints

Saved Viewpoints Window

The Saved Viewpoints window is a floating window that enables
you to jump to preset viewpoints without having to navigate each
time to reach an item.

Saved Yiewpaints =

[]1 plan section
(1 long section
cross section
[]1 external 374
(3 kitchen sink
= slide Show
ED Street
S Cutl
ED Front R.oom
S Cutz
(]2 kitchen
S Cut3
(] office

Viewpoint animations are also saved with the viewpoints, as they
are simply a list of viewpoints treated as keyframes.

Icons are used to represent different elements:

represents a folder which may contain all other elements
(including other folders).
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represents a viewpoint saved in orthographic mode.

=

represents a viewpoint saved in perspective mode.

IN]

represents a viewpoint animation clip.

represents a cut inserted into a viewpoint animation clip.

You can select more than one viewpoint by either holding down the Control key and left-clicking, or by
left-clicking the first item, and then clicking the last item while holding down the Shift key.

You can drag viewpoints around the Saved Viewpoints window, but you cannot save any changes.

There are no buttons on this window, and commands are actioned through shortcut menus.

To toggle the Saved Viewpoints window

o

» Click Saved Viewpoints on the Workspace toolbar.

£ Menu: View » Control Bars » Saved Viewpoints
E Command entry: CTRL + F11

Quick Reference

You get a different shortcut menu, depending on what element you right-click in the Saved Viewpoints window.
All shortcut menus share the Sort option, which sorts the contents of the window alphabetically, including
folders and their contents.

IMPORTANT Any changes that you make cannot be saved, and will apply for the duration of your Autodesk Navisworks
session.

Blank Space
Save Viewpoint Saves the current viewpoint, and adds it to the Saved Viewpoints window.

New Folder Adds a folder to the Saved Viewpoints window.
Add Animation Adds a new empty viewpoint animation, ready for dragging viewpoints onto.

Add Cut Adds an animation cut. Cuts are used as pauses in the viewpoint animations, and are 1 second long
by default.

Sort Sorts the contents of the Saved Viewpoints window alphabetically.

Help Opens the Help system.

Saved Viewpoint

Save Viewpoint Creates a copy of the selected viewpoint in the Saved Viewpoints window.
New Folder Adds a folder above the selected viewpoint.

Add Animation Adds a new empty viewpoint animation above the selected viewpoint.

Add Cut Adds an animation cut above the selected viewpoint. Cuts are used as pauses in the viewpoint animations,
and are 1 second long by default.

Add Copy Creates a copy of the selected viewpoint in the Saved Viewpoints window. The copy is named the
same as the selected viewpoint, but includes the version number in brackets. For example, View1(1), View1(2)
and so on.
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Edit Opens the Edit Viewpoint dialog box, and enables you to manually edit the viewpoint’s attributes.
Update Makes the selected viewpoint the same as the current viewpoint in the Scene Area.

Transform Opens the Transform dialog box. It enables you to transform the camera position.

Delete Deletes the selected viewpoint from the Saved Viewpoints window.

Rename Enables you to rename the selected viewpoint.

Sort Sorts the contents of the Saved Viewpoints window alphabetically.

Help Opens the Help system.

Viewpoint Animation

Save Viewpoint Saves the current viewpoint, and adds it as the last keyframe in the selected viewpoint animation.
New Folder Adds a folder as the last keyframe in the selected viewpoint animation.

Add Animation Adds a new empty viewpoint animation as the last keyframe in the selected viewpoint animation.

Add Cut Adds an animation cut to the end of viewpoint animation. Cuts are used as pauses in the viewpoint
animations, and are 1 second long by default. You can drag the created cut into a different position.

Add Copy Creates a copy of the selected viewpoint animation in the Saved Viewpoints window. The copy is
named the same as the selected viewpoint animation, but includes the version number in brackets. For example,
View1(1), View1(2) and so on.

Edit Opens the Edit Animation dialog box, and enables you to set the duration of the selected viewpoint
animation, the type of smoothing, and whether it loops or not.

NOTE Clicking Edit over an animation keyframe, opens the Edit Viewpoint dialog box; and clicking Edit over an
animation cut, opens the Edit Animation Cut dialog box.

Update Updates all keyframes in the viewpoint animation with the current render style, lighting, and navigation
mode.

NOTE Clicking Update over a single keyframe will only update that frame with the current modes.

Delete Deletes the selected viewpoint animation from the Saved Viewpoints window.

NOTE Clicking Delete over a keyframe or a cut, removes the keyframe or cut from the viewpoint animation.

Rename Enables you to rename the selected viewpoint animation, keyframe, or cut.
Sort Sorts the contents of the Saved Viewpoints window alphabetically.

Help Opens the Help system.

Folder

Save Viewpoint Saves the current viewpoint, and adds it to the selected folder.
New Folder Adds a subfolder to the selected folder.
Add Animation Adds a new empty viewpoint animation to the selected folder.

Add Cut Adds an animation cut to the selected folder. Cuts are used as pauses in the viewpoint animations, and
are 1 second long by default. You can drag the created cut into a different position.

Add Copy Creates a copy of the selected folder in the Saved Viewpoints window. The copy is named the same
as the selected folder, but includes the version number in brackets. For example, View1(1), View1(2) and so on.

Update Updates all viewpoints in the folder with the current render style, lighting and navigation mode. Choosing
Update for a single viewpoint will only update that viewpoint with the current modes.

Delete Removes the selected folder and all of its contents from the Saved Viewpoints window.
Rename Enables you to rename the selected folder.

Sort Sorts the contents of the Saved Viewpoints window alphabetically.
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Help Opens the Help system.

Recall Viewpoints
You can return to any of previously saved viewpoints. On recalling viewpoints the navigation mode that was
active when the viewpoint was created will be re-selected. Any redlines and comments associated with the

viewpoint will also be reinstated.

To recall a viewpoint from the Saved Viewpoints window

(i

1 If the Saved Viewpoints window is not displayed, click Saved Viewpoints on the Workspace toolbar.

2 Click the desired viewpoint in the list. It is now displayed in the Scene Area.

Organize Viewpoints
Viewpoints can be organized into folders, if necessary.

To organize viewpoints into folders

(i

1 If the Saved Viewpoints window is not displayed, click Saved Viewpoints on the Workspace toolbar.
2 Right-click an empty space in the Saved Viewpoints window, and click New Folder.

3 Type in a new name, and press Enter.

4 Drag the required viewpoints into your new folder.

Edit Viewpoints

You can edit any viewpoints attributes, including camera position, field of view, speed of motion and saved
attributes. All entries are measured in Display Units.

To edit a viewpoint

1 If the Saved Viewpoints window is not displayed, click Saved Viewpoints on the Workspace toolbar.
2 Right-click the viewpoint you want to modify, and click Edit.

3 Use the Edit Viewpoint dialog box to adjust the viewpoint’s attributes.
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Edit Viewpoint - Front Entrance

Camera

" i Z
Position (i 41.57 43.11 7.02
Look At (m): 31,00 34,50 2.73
Yertical Field OF Yiew (=) 4.2z
Horizontal Field OF Yiew (2} 100.03
IMation
Linear Speed (mjsec): 1.08
Angular Speed (*/sec): 45.00
Saved Attributes Callision
Hide/Required

Settings. ..
Override Matetial
I Ok I [ Cancel Help ]
4 Click OK.

To delete a viewpoint

1

2 Right-click the viewpoint you want to remove, and click Delete.

If the Saved Viewpoints window is not displayed, click Saved Viewpoints

on the Workspace toolbar.
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Play Back Animations

In Autodesk Navisworks there are two types of animation: viewpoint animation
and object animation.

Viewpoint animation contains pre-recorded user and camera movements in the
model. Object animation contains pre-recorded object movements in the model.
You cannot record any animation in Autodesk Navisworks, but you can play back
animations saved with the model. If there are any animation scripts, you can
switch them on and interact with animated objects.

Play Animations

You can play back both pre-recorded object animation and viewpoint
animation in the Scene Area.

The viewpoint animations play in real time; this means that the
Autodesk Navisworks engine is still attempting to maintain the
guaranteed frame rate so some drop-out may still occur, just as in
real-time navigation.

To play back an animation

1 Select the animation you want to play back from either the
Saved Viewpoints window, or from the Available Animations
drop-down list on the Animation toolbar.

2 You can use the Animation Position slider to quickly move
forwards and backwards through the animation. Full left is at
the beginning and full right is at the end. The text box next to
the slider shows the point in time (in seconds) through the
animation that the camera is. You can type a number into this
box to set the camera at a certain point in the animation and
play back from that point.

3 For viewpoint animations, you may notice that the frame in
the animation in the Saved Viewpoints window is highlighted
when the animation is playing. You can click on any frame to
set the camera to that point in time in the viewpoint animation
and continue playing back from there.

4 Use the VCR buttons on the “Animation Toolbar” on page 33
to step and play forwards and backwards through the
animation.
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To enable scripting

You can now interact with your model. For example, if there is a script to open a door on pressing a specific
key on the keyboard, pressing this key will open the door.

button on the Animation toolbar.

» To enable animation scripts in your file, click the Toggle Scripts
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Work Within a Team

Autodesk Navisworks Freedom 2010 enables multiple users to participate in a
single design review session across a Local Area Network (LAN). This utilizes the
shared program features of Windows NetMeeting, available to all Windows users.

Collaborate Toolbar

The Collaborate toolbar contains the collaboration tools necessary
to run collaboration sessions.

b @

-

If the Collaborate toolbar is not displayed, right-click anywhere in

the toolbar area of the screen, and click Collaborate Bar on the
shortcut menu.

Collaboration Session

All meeting participants require access to a Autodesk Navisworks
.nwf or .nwd file, in a shared location. One of the participants will
'host' the meeting and place a call to invite the others to join the
meeting. Any of the participants who have joined the meeting can
take control and drive the session. All navigation performed by the
driver will be displayed in the Scene Area on each of the participants’
machines. Any viewpoints or redlines (for example) added during
the session can be updated on all participants’ machines at the click
of a button.

NOTE If a collaborative review session, as outlined here, is not
conducted in single room, then additional teleconferencing provisions
could be necessary. This may be using the NetMeeting Whiteboard, or
your own telephone system.

To start a collaboration session

1 Open the Autodesk Navisworks file that you want to collaborate
on from a shared directory.

2

2 Click the Collaborate button on the Collaborate toolbar.
This initializes Windows NetMeeting.
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NOTE The first time Windows NetMeeting initializes, a Setup wizard will take you through the setup process.
You will need to enter your name and email address. When using NetMeeting on a LAN you do not need to log
onto a directory server, as these will not be available to you.

To place a call, inviting attendees to join
_E
1 Having initialized Windows NetMeeting, click the Call button in the NetMeeting dialog box.

2 In the Place a Call dialog box, enter the machine name or IP address of the machine you wish to join the
meeting into the To box.

Place A Call

Enter the address of the person to call,

To: | v|

sing: |Autnmatic “ |

] Require security for this call [data only)

@

3 Click the Call button to send the invite.

Once the person receiving the invite accepts this, both their name and yours will be listed in the NetMeeting
dialog box.

4 Repeat this procedure to invite all required participants.
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To accept an invitation

1 When you are invited to join a meeting, the Incoming Call dialog box is displayed.

NetMeeting - Incoming Call
@ Incoming call from Mavisworks Suppart... Accept I lgnore |

2 Click the Accept button to join the meeting, or Ignore to decline the invitation.

=3

NOTE Once you have accepted a call, you will need to click the Collaborate button on the Collaborate toolbar
to start your own collaboration session.

To become the driver

During a collaboration meeting, anyone in the call can take control of the session and become the 'driver'. The
driver will control navigation of the shared model on all machines in the call.

-y

1 Click the Drive - button on the Collaborate toolbar.

2 Upon clicking the drive button, all other users in the call will receive a message advising that you are
requesting control. They will have to answer Yes to this message if you are to drive Autodesk Navisworks
on their machine.

To refresh all attendees machines

Although real-time navigation in Autodesk Navisworks can be performed on all machines in a call by one user,
it is not possible for review data such as saved viewpoints, comments and redlines, to be automatically updated
on all users' machines. This information can, however, be updated on their machines by refreshing the model.
This refresh process can be performed on one users machine and refresh all machines in the call.

=4
» Click the Refresh Re button on the Collaborate toolbar.
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Share Data

Print

You can print a hard copy of the current viewpoint to any printer
or plotter.

Print Preview

Before you print out a copy of the model you are working on, you
may wish to see how it will appear.

To preview model before printing

1
2

Print Setup

Click File » Print Preview.

Use the Zoom In and Zoom Out buttons to do just that with
the preview image.

Click Print.
In the Print dialog box, click OK.

This option enables you to the set up paper size and orientation
options.

To change the print setup

1
2

Click File » Print Setup.

In the Print Setup dialog box, make changes as required to the
paper and orientation.

Click the Properties button if you want to change
printer-specific settings.

Return to the Print dialog box, and click OK to print the image.
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Print Current Viewpoint

When the print option is selected, Autodesk Navisworks prints the current viewpoint scaled to fit and centered
on the page.

To print the current viewpoint
1 Click File » Print.

2 Check the printer settings are as required, and click OK.

NOTE The maximum image size is 2048x2048 pixels.

The Properties button controls printer-specific ink and paper settings.

¥ Toolbar: Standard » Print é
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TimeLiner Playback

TimeLiner playback enables you to play back a TimeLiner construction sequence.
In this section, you will learn how to simulate your TimeLiner sequence throughout
the duration of the project schedule.

Overview of TimeLiner Tool

The TimeLiner tool adds 4D schedule simulation to Autodesk
Navisworks files.

In Autodesk Navisworks Freedom 2010, TimeLiner has a
playback-only option, allowing any externally created project data
to be simulated, but no changes to be made to that data.

TimeLiner Playback Window

The TimeLiner dockable window enables you to to set up and play
simulations.

To toggle the TimeLiner Playback window
B Click TimeLiner Playback on the Workspace toolbar.

£ Menu: Tools » TimeLiner Playback

Simulate Tab

The Simulate tab enables you to simulate your TimeLiner sequence
throughout the duration of the project schedule.
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Simulate
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The Status Icons

Each task has its own Status identified by an icon, representing planned against actual relationships. Each icon
shows two bars. The top bar represents the Planned dates, and the bottom bar represents the Actual dates. If the
Actual Start and Finish dates are the same as the Planned Start and Finish dates, the bars are displayed in green.
Any variations between Planned and Actual dates are displayed in red. Missing Planned or Actual dates are shown

in grey.

& Actual Start and End dates equal Planned Start and End dates.

= Actual End date before Planned Start date.
e Actual Start date after Planned End date.

Ll Actual Start date before Planned Start date and Actual End date after Planned End date.

o

== Actual Start date before Planned Start date and Actual End date equals Planned End date.

=3 Actual Start date equals Planned Start date and Actual End date after Planned End date.

&  Actual Start date equals Planned Start date and Actual End date before Planned End date.
®  Actual Start date after Planned Start date and Actual End date equals Planned End date.
@5 Actual Start date before Planned Start date and Actual End date before Planned End date.
=

== Actual Start date after Planned Start date and Actual End date after Planned End date.
=3 Actual Start and End dates only.

Planned Start and End dates only.

The Playback Controls
Use the standard VCR buttons to step and play forwards and backwards through the simulation:

Rewind will rewind the simulation back to the beginning.
Step Back will step back a single step size.
Reverse Play will play the simulation backwards.

Pause will pause the simulation at the time you press it at. You can then look around and interrogate the

model, or step forwards and backwards through the simulation. To continue playing from where you paused,
just press Play again.
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Stop will stop the simulation playing and rewind back to the beginning.
Play will play the simulation from the currently selected time.
Step Forwards will step forwards a single step size.

Forward will fast forward the simulation to the end.

You can use the Simulation Position slider to quickly move forwards and backwards through the simulation. Full
left is at the beginning and full right is at the end.

J

000000 09:35:10
28/07 2003 250212005

The Date/Time box below the VCR buttons shows the point in time through the simulation. You can click on
the drop-down icon to the right of the date to display a calendar, from which you can select a date to 'jump' to.

The Active Tasks
All Active Tasks are show in a multi-column table. You can move and resize table columns, if necessary.

You can view the current simulation time for each of the active tasks, and how close to completion they are

(Progress is displayed as a percentage). The Status of each active task is also displayed as an icon. For simulations
where Planned and Actual dates are available, the status provides a visual representation as to whether there is
any variance between the planned and actual dates. See “The Status Icons” on page 132 for more information.

Play Simulations

To play a simulation
1 If the TimeLiner Playback window is not already open, click Tools » TimeLiner Playback.
2 Click the Play button on the Simulate tab.

The TimeLiner Playback window displays the tasks as they are carried out, and the Scene Area shows the
sections of the model added or removed over time, in accordance with the task types.
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Autodesk Navisworks
Reference

File Options Dialog Box

Use this dialog box to control the appearance of the model and the
speed of navigation around it.

When you modify any of the options in this dialog box, your
changes are saved in the currently opened Autodesk Navisworks
file, and apply to this file only.

£ Menu: Tools » File Options.

Culling Tab

Use this tab to adjust geometry culling in the opened Autodesk
Navisworks file.

Area
Enable Specifies whether area culling is used.

Number of Pixels Below Which Objects are Culled Specifies a
value for the screen area in pixels below which objects are culled.
For example, setting the value to 100 pixels means that any object
within the model that would be drawn less than 10x10 pixels in
size are discarded.

Clipping Planes

Near

Automatic Select this radio button to make Autodesk Navisworks
automatically control the near clip plane position to give you the
best view of the model. The Distance box becomes unavailable.

Constrained Select this radio button to constrain the near clipping
plane to the value set in the Distance box.

Autodesk Navisworks uses the provided value unless doing so affects
performance (for example, makes the whole model invisible), in
which case it adjusts the near clip plane position as necessary.

Fixed Select this radio button to set the near clipping plane to the
value provided in the Distance box.
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Distance Specifies the farthest distance between the camera and the near clipping plane position in constrained
mode.

Specifies the exact distance between the camera and the near clipping plane position in fixed mode.

NOTE Nothing is drawn between the camera and the near clipping plane; when you override automatic mode, make
this value small enough to display your data. Also, overriding automatic mode with values under 1 can produce
unpredictable results.

Far

Automatic Select this radio button to make Autodesk Navisworks automatically control the far clipping plane
position to give you the best view of the model. The Distance box becomes unavailable.

Constrained Select this radio button to constrain the far clipping plane to the value set in the Distance box.
Autodesk Navisworks uses the provided value unless doing so affects performance (for example, makes the whole
model invisible), in which case it adjusts the far clip plane position as necessary.

Fixed Select this radio button to set the far clipping plane to the value provided in the Distance box.

Distance Specifies the closest distance between the camera and the far clipping plane position in constrained
mode.

Specifies the exact distance between the camera and the far clipping plane position in fixed mode.

NOTE Nothing is drawn beyond this plane; when you override automatic mode, make this value large enough to
include your data. Additionally, using the ratio of the far clipping plane to near clipping plane in excess of 10000 can
produce unwanted effects.

Backface
Turns on backface culling for all objects. Select from the following options:
B On - turns on backface culling for all objects.

W Off - turns off backface culling

B Solid - turns on backface culling for solid objects only. This is the default option.

TIP If you can see through some objects, or some object parts are missing, turn off backface culling.

TIP If you want to restore the default values, click the Defaults button.

Orientation Tab

Use this tab to adjust the real-world orientation of your model.

Up
X, Y, Z Specify the X, Y, and Z coordinate values. By default, Autodesk Navisworks takes the positive Z-axis as
Up.

North

X, Y, Z Specify the X, Y, and Z coordinate values. By default, Autodesk Navisworks takes the positive Y-axis as
North.

TIP If you want to restore the default values, click the Defaults button.

Speed Tab

Use this tab to adjust the frame rate speed to reduce the amount of drop-out during navigation.

TIP If this does not improve navigation, try switching off the Guarantee Frame Rate option.

Frame Rate Specifies the number of frames per second (FPS) that are rendered in the Scene View.
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The default setting is 6. You can set the frame rate from 1 through 60 frames per second. Reducing the value
reduces drop-out, but can cause jerky movement during navigation. Increasing the value ensures a smoother
navigation, but increases drop-out.

TIP If you want to restore the default values, click the Defaults button.

Head Light Tab

Use this tab to change the intensity of the scene's ambient light and headlight for Head Light mode.
Ambient Use the slider to control the overall brightness of the scene.

Headlight Use the slider to control the brightness of the light located at the camera.

NOTE To see the effect your changes have on the model in the Scene View, apply Head Light mode.

Scene Lights Tab

Use this tab to change the intensity of the scene's ambient light for Scene Lights mode.

Ambient Use the slider to control the overall brightness of the scene.

NOTE To see the effect your changes have on the model in the Scene View, apply Scene Lights mode

Edit Viewpoint Dialog Box

Use this dialog box to edit viewpoint atributes.

Camera
Position Enter the X, Y, and Z coordinate values to move the camera into this position.

Look At Enter the X, Y, and Z coordinate values to change the focal point for the camera.

Vertical Field of View, Horizontal Field of View Defines the area of the scene that can be viewed through the
camera. You can adjust the values for both vertical and horizontal angles of view. If the display units are set to
degrees, then these numbers should be between 0.1 and 90; and if in radians, between 0.002 and 3.124.

A larger value produces a wider angle of view and a smaller value produces a narrower, or more tightly focused,
angle of view.

NOTE When you modify the Vertical Field of View, the Horizontal Field of View is automatically adjusted, and vice
versa to match the aspect ratio in Autodesk Navisworks.

Roll Rotates the camera around its front-to-back axis. A positive value rotates the camera anticlockwise, and a
negative value rotates it clockwise.

NOTE This value is not editable where the viewpoint up vector stays upright (that is, in walk, orbit and turntable
modes).

Motion

Linear Speed The speed of motion in a straight line for the viewpoint. The minimum value is 0 and the maximum
is based on the size of the scene's bounding box.

Angular Speed The speed at which the camera turns.

Saved Attributes
This area applies to saved viewpoints only. If you are editing a current viewpoint, this area is not greyed out.
Hide/Required Select this check box to save hidden/required markup information about objects in your model

with the viewpoint. When you use a viewpoint again, the hidden/required markups set when the viewpoint was
saved are reapplied.

NOTE Saving the state information with each viewpoint requires a relatively large amount of memory.
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Override Material Select this check box to save material override information with the viewpoint. When you
use a viewpoint again, the material overrides set when the viewpoint was saved are reapplied.

NOTE Saving the state information with each viewpoint requires a relatively large amount of memory.

Collision
Settings Opens the Collision dialog box.

Options Editor

Use the Options Editor to adjust program settings for Autodesk Navisworks sessions.

The settings that you set up in the Options Editor are persistent across all Autodesk Navisworks sessions. You
also share the modified settings with other members of your team.

The options are presented in a hierarchical tree structure. Clicking + expands the nodes, clicking g collapses
the nodes.

£ Menu: Tools » Global Options

Buttons

Export Displays the Select Options to Export dialog box, where you can select the global options you want to
export (or ‘serialize’). If an option cannot be exported, it is grayed out.

Import Displays the Open dialog box, where you can browse to the file with the required global option settings.
OK Saves the changes, and closes the Options Editor.
Cancel Discards the changes, and closes the Options Editor.

Help Displays the context-sensitive help.

General Node

Use the settings in this node to adjust the buffer size, file locations, number of recent file shortcuts you want
Autodesk Navisworks to store, and the auto-save options.

TIP If you want to restore the default values, click the Defaults button.

Undo Page
Use the settings on this page to adjust the buffer size.

Buffer Size (kB) Specifies the amount of space Autodesk Navisworks allocates for saving undo/redo actions.

Locations Page

Use the options on this page to share global Autodesk Navisworks settings, workspaces, datatools, avatars, Clash
Detective rules, Presenter archives, custom Clash Detective tests, object animation scripts, and so on, with other
users.

The settings can be shared across an entire project site, or across a specific project group depending on the
required level of granularity.

When you run Autodesk Navisworks for the first time, the settings are picked up from the installation directory.
Subsequently, Autodesk Navisworks examines the current user profile and the all users profile on the local
machine, and then checks the settings in the Project Directory and the Site Directory. The files in the Project
Directory take precedence.

Project Directory Click I_J to open the Browse for Folder dialog box, and locate the directory that contains
the Autodesk Navisworks settings specific to a project group.
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Site Directory Click u to open the Browse for Folder dialog box, and locate the directory that contains the
Autodesk Navisworks settings standard across the entire project site.

Environment Page

Use the settings on this page to adjust the number of recent file shortcuts stored by Autodesk Navisworks.

Maximum Recently Used Files Specifies how many file shortcuts Autodesk Navisworks can remember. By
default, shortcuts to the four most recently opened files can be displayed.

Communication Center Page
Use the settings on this page to adjust the settings for Communication Center.

Please Indicate the Country/Region Nearest to Your Current Location Set the country in which Autodesk
Navisworks users work. This is used for tailoring location-specific Communication Center content.

Check for New Online Content Specifies how often Communication Center checks for new content.

Content Filtering
Hide Old Content Indicates whether old content in Communication Center is hidden from view.

After Sets the number of days after which content is considered to be old.

Autodesk Channels Page

Use the settings on this page to select which channels you want to display in the Communication Center list.

By default, all available channels are selected. You cannot add or remove channels from the grid, and you cannot
edit data in the grid.

Balloon Notifications Page
Use the settings on this page to adjust balloon notifications.

Enable Balloon Notifications Indicates whether balloon notifications are turned on.

Display Duration Sets the length of time (in seconds) the balloon notifications are shown in the Status bar
before automatically disappearing.

Model Node

Use the settings in this node to optimize Autodesk Navisworks performance, and customize parameters for NWD
and NWC files.

TIP If you want to restore the default values, click the Defaults button.

Performance Page

Use the options on this page to optimize Autodesk Navisworks performance.

Memory Limit

Auto Indicates whether Autodesk Navisworks automatically determines the maximum memory that can be used.
Selecting this check box sets the memory limit to the lowest of your available physical memory or address space,
less that required for your operating system.

Limit (MB) Specifies the maximum memory that Autodesk Navisworks can use.
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Merge Duplicates

These options improve performance by multiply instancing matching items. Rather than storing every item in
memory, if any items are the same, Autodesk Navisworks can store one instance of them and 'copy' that instance
into other positions. This is of particular benefit on larger models, where there are significant numbers of these
duplicate geometries.

On Convert Select this check box to merge duplicates when a CAD file is converted into the Autodesk Navisworks
format.

On Append Select this check box to merge duplicates when a new file is appended to the currently opened
Autodesk Navisworks file.

On Load Select this check box to merge duplicates when a file is loaded into Autodesk Navisworks.
On Save NWF Select this check box to merge duplicates when the current scene is saved in the NWF file format.

On Load

Collapse on Convert Collapses the tree structure on the Selection Tree to the specified level when native CAD
files are converted into Autodesk Navisworks. Select from the following options:

B None - the tree is fully expanded.

B Composite Objects - the tree is collapsed up to the level of composite objects.
B All Objects - the tree is collapsed up to the level of objects.

B Layers - the tree is collapsed up to the level of layers.

B Files - the tree is collapsed up to the level of files.

This enables performance to be prioritized over structure/properties and has the added benefit of improving
streaming by cutting down the logical structure.

NOTE Although Autodesk Navisworks tries to collapse items to the fewest number possible, it may be necessary to
prevent collapsing in some cases to preserve model fidelity. For example, if an item has properties or materials unique
to itself, then collapsing would endanger this information, and therefore it will not be collapsed.

Close NWC/NWD files on Load Indicates whether NWC and NWD files are closed once they’ve been loaded
into memory.

When you open NWC/NWD files, Autodesk Navisworks locks them for editing. By selecting this check box, you
instruct Autodesk Navisworks to close NWC or NWD files as soon as they’ve been loaded into memory. This
means that the files can be opened and edited by other users while you are viewing them.

Create Parametric Primitives Select this check box to enable creation of parametric models (models described
by formulae not vertices).

Using this option allows you to get better looking visuals, faster rendering, smaller memory footprint (especially,
when loading DGN and RVM files with significant amounts of parametric data that no longer need to be converted
into vertices in Autodesk Navisworks).

NOTE Modifying this option takes effect when you next load or refresh file.

Create Presenter Materials Select this check box to enable creation of Presenter materials when NWC files are
loaded.

Clearing this check box turns off creation of Presenter materials. Use this option if you’ve only got Autodesk
Navisworks Review installed.

Temporary File Location
Auto Indicates whether Autodesk Navisworks automatically selects your user Temp folder.

Location Click l_J to open the Browse for Folder dialog box, and select the desired Temp folder.
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NWD Page

Use the options on this page to enable and disable geometry compression and select whether the precision of
certain options is reduced when saving or publishing NWD files.

Geometry Compression
Enable Select this check box to enable geometry compression when NWD files are saved.
Geometry compression results in less memory being required and therefore smaller NWD files.

Reduce Precision

Coordinates Select this check box to reduce the precision of coordinates.

Precision Specifies the precision value for coordinates. The larger the value, the less precise coordinates are.
Normals Select this check box to reduce the precision of normals.

Colors Select this check box to reduce the precision of colors.

Texture Coordinates Select this check box to reduce the precision of texture coordinates.

NWC Page
Use the options on this page to manage reading and writing of cache files (NWC).

By default, when Autodesk Navisworks opens a native CAD file (for example, AutoCAD or MicroStation), it first
checks in the same directory whether there is a cache file present with the same name as the CAD file but with
an .nwc extension. If there is, and this cache file is newer than the native CAD file, then Autodesk Navisworks
opens this file instead as it has already been converted to Autodesk Navisworks format and, therefore, opens
much quicker. If, however, there is no cache file present, or the cache file is older than the native CAD file, then
Autodesk Navisworks has to open the CAD file and convert it. By default, it writes a cache file in the same
directory and with the same name as the CAD file, but with the .nwc extension, for speeding up the opening of
this file in future.

Caching
Read Cache Select this check box to use cache files when Autodesk Navisworks opens native CAD files.

Clear this check box if you don’t want to use cache files. This ensures that Autodesk Navisworks converts native
CAD files each time they are opened.

Write Cache Select this check box to save cache files when native CAD files are converted. Generally, cache files
are much smaller than original CAD files, therefore, selecting this option does not take up too much disk space.

Clear this check box if you don’t want to save cache files.

Geometry Compression
Enable Select this check box to enable geometry compression when NWC files are saved.

Geometry compression results in less memory being required and therefore smaller NWC files.

Reduce Precision

Coordinates Select this check box to reduce the precision of coordinates.

Precision Specifies the precision value for coordinates. The larger the value, the less precise coordinates are.
Normals Select this check box to reduce the precision of normals.

Colors Select this check box to reduce the precision of colors.

Texture Coordinates Select this check box to reduce the precision of texture coordinates.

Interface Node

Use the settings in this node to customize Autodesk Navisworks interface.
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TIP If you want to restore the default values, click the Defaults button.

Display Units Page

Use this page to customize the units used by Autodesk Navisworks.

Linear Units Use the drop-down list to select the desired linear value. Meters are used by default.
Angular Units Use the drop-down list to select the desired angular value. Degrees are used by default.
Decimal Places Specifies the number of decimal places used by units.

Fractional Display Precision Specifies the level of fraction used by units. This box is enabled for fractional units
only.

Selection Page
Use the options on this page to configure the way geometry objects are selected, and highlighted.

Pick Radius Specifies the radius, in pixels, that an item has to be within in order for it to be selected.

Resolution Specifies the level of selection used by default.

When you click in the Scene View, Autodesk Navisworks requires a starting point for the object path in the
Selection Tree box to identify the selected item. You can choose one of the following options:

B Model - the object path starts at the model node; as a result, all objects in the model are selected.

B Layer - the object path starts at the layer node; as a result all objects within a layer are selected.

B First Object - the object path starts at the highest level of objects below the layer node, if applicable.
|

Last Object - the object path starts at the lowest level of objects in the Selection Tree. Autodesk Navisworks
looks for composite objects first, and if none are found, the geometry level is used instead. This is the default
option.

B Last Unique - the object path starts at the first unique level of objects (not multiple-instanced) in the Selection
Tree.

B Geometry - the object path starts from the geometry level in the Selection Tree.

Compact Tree Specifies the level of detail shown on the Compact tab of the Selection Tree.

Use one of the following options:

B Models - the tree is restricted to displaying model files only.
B Layers - the tree can be expanded down to the layer level.

B Objects - can be expanded down to the objects level, but without the levels of instancing shown on the
Standard tab.

Highlight
Enabled Indicates whether Autodesk Navisworks highlights the selected items in the Scene View.
Clear this check box if you don’t want to highlight selected items.

Method Specifies how the objects are highlighted. Select one of the following options:
B Shaded

B Wireframe

Hm Tinted

Color Click . to specify the highlight color.
Tint Level (%) Use the slider to adjust the tint level.
142 | Chapter 14 Autodesk Navisworks Reference



Measure Page
Use the options on this page to adjust the appearance and style of the measure lines.

Line Thickness Specifies the thickness of the measure lines.

Color Click to specify the color of the measure lines.

In 3D Select this check box to draw the measure lines in 3D.
If the measure lines become obscured by other geometry, clear this check box to draw the lines in 2D over the
top of geometry.

Show Measurement Values in Scene View Select this check box if you want to display the dimension labels in
the Scene Area.

Use Center Lines When this check box is selected, the shortest distance measurements snap to the center lines
of parametric objects.

When this check box is clear, the surface of the parametric objects is used for the shortest distance measurement
instead.

NOTE Changing this option does not affect any measurement currently in place. To see any changes, clear the
measurement, and start again.

Snapping Page

Use the options on this page to adjust the cursor snapping.

Picking
Snap to Vertex Select this check box to snap the cursor to the nearest vertex.
Snap to Edge Select this check box to snap the cursor to the nearest triangle edge.

Snap to Line Vertex Select this check box to snap the cursor to the nearest line end.

Tolerance Defines the snapping tolerance. The smaller the value, the closer the cursor must be to a feature in
the model before it snaps to it.

Rotation
Angles Specifies the multiplier for the snapping angle.

Angle Sensitivity Defines the snapping tolerance. The value you enter here determines how close to the snapping
angle the cursor must be for snap to take effect.

Viewpoint Defaults Page
Use the options on this page to define attributes that are saved with viewpoints when you create them.

When you modify default viewpoint settings, your changes do not affect the currently opened Autodesk
Navisworks file. They are used as soon as you open a new Autodesk Navisworks file, or start a new Autodesk
Navisworks session.

Save Hide/Required Attributes Select this check box to save viewpoints with hidden/required markup information
about objects in your model. When you use a viewpoint again, the hidden/required markups set when the
viewpoint was saved are reapplied.

By default, this check box is clear, as saving the state information with each viewpoint requires a relatively large
amount of memory.

Override Material Select this check box to save viewpoints with material override information. When you use
a viewpoint again, the material overrides set when the viewpoint was saved are reapplied.

By default, this check box is clear, as saving the state information with each viewpoint requires a relatively large
amount of memory.
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Override Linear Speed By default, the linear navigation speed is directly related to the size of your model. Select
this check box, if you want to set a specific navigation speed manually.

Default Linear Speed Specifies the default linear speed value.
Default Angular Speed Specifies the default speed at which the camera turns.

Collision

Settings Opens the Default Collision dialog box where you can adjust the collision, gravity, crouching and third
person view settings.

Hyperlinks Page

Use the options on this page to customize the way hyperlinks are displayed in the Scene View.

TIP If you want to restore the default values, click the Defaults button.

In 3D Indicates whether the hyperlink icons are drawn in 3D in the Scene View.

Select this box if you want the hyperlink items to float in 3D space just in front of their attachment points to
the geometry.

If the hyperlink items become obscured by other geometry, clear this check box to draw the hyperlink icons in
2D over the top of geometry.

Max Icons Specifies the maximum number of icons to draw in the Scene View.

Hide Colliding Icons Select this check box to hide the hyperlink icons that appear overlapped in the Scene
View.

Cull Radius Specifies how close to the camera hyperlinks have to be before they are drawn in the Scene View.
Any hyperlinks further away than this distance are not drawn. The default value of O means that all hyperlinks
are drawn.

X Leader Offset, Y Leader Offset Hyperlinks can be drawn with leader lines (arrows) pointing to the attachment
point on the geometry that the hyperlink is attached to. Enter the X- and Y- values to specify the number of
pixels to the right and up that these leader lines use.

Standard Categories Page
Use the settings on this page to switch the displaying of hyperlinks based on their categories.

Hyperlink
Icon Type Specifies how to display this hyperlink category.

Select one of the following options:

B Icon - hyperlinks are represented by default icons E and in the Scene View.

B Text - hyperlinks are represented by text boxes with hyperlink descriptions in the Scene View.
Visible Select this check box to display this hyperlink category in the Scene View.

Tag
Icon Type Specifies how to display this hyperlink category.

Select one of the following options:

B Icon - hyperlinks are represented by default icons @ and in the Scene View.

B Text - hyperlinks are represented by text boxes with hyperlink descriptions in the Scene View.

Visible Select this check box to display this hyperlink category in the Scene View.
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Viewpoints
Icon Type Specifies how to display this hyperlink category.

Select one of the following options:

B lcon - hyperlinks are represented by default icons in the Scene View:

[:D - hyperlinks to viewpoints saved in perspective mode

ﬁj - hyperlinks to viewpoints saved in orthographic mode

B Text - hyperlinks are represented by text boxes with hyperlink descriptions in the Scene View.

Visible Select this check box to display this hyperlink category in the Scene View.

Hide Icons without Comments Select this check box to display only the hyperlinks that have comments in
the Scene View.

Redline Tags
Icon Type Specifies how to display this hyperlink category.
Select one of the following options:

E

B Icon - hyperlinks are represented by default icons in the Scene View.

B Text - hyperlinks are represented by text boxes with hyperlink descriptions in the Scene View.

Visible Select this check box to display this hyperlink category in the Scene View.

Hide Icons without Comments Select this check box to display only the hyperlinks that have comments in
the Scene View.

User-Defined Categories Page

Use this page to view custom hyperlink categories.

The padlock H icon indicates that you cannot add or remove categories directly from here.
Buttons

Grid View Click EJ to display custom hyperlink categories in a tabular format.

List View Click IE] to display custom hyperlink categories in a list format (the same way as the standard
hyperlink categories are shown).

@]
Records View Click EJ to display hyperlink categories as records.

Previous and Next Element Use l_lj and 2 to navigate between hyperlink categories. If you clicked the Records
View button, this is the only way to move between the records.

Visible Select this check box to display the corresponding hyperlink category in the Scene View.

Icon Type Select one of the following options:

B Icon - hyperlinks are represented by default icons E and in the Scene View.

B Text - hyperlinks are represented by text boxes with hyperlink descriptions in the Scene View.
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Smart Tags Page

Use the options on this page to customize the way smart tags are displayed in the Scene View.

TIP If you want to restore the default values, click the Defaults button.

Hide Category Clear this check box to include category names in the smart tag tooltips.
If you don’t want to see category names in the smart tag tooltips, select this check box.

Definitions Page

Use the options on this page to set up the smart tag categories.
Buttons

Add Element Click @ to add a smart tag definition.

Remove Element Click @] to delete the selected smart tag definitions.

Grid View Click lé] to display smart tag definitions in a tabular format.

List View Click [f] to display smart tag definitions in a list format.
@)
Records View Click = to display smart tag definitions as records.

Previous and Next Element Use I_lj and l_>l to navigate between smart tag definitions.

If you clicked the Records View button, this is the only way to move between the records.
Category Specifies the smart tag category that you want to customize.

Property Specifies the property that is displayed in the tooltips for the selected category.

Developer Page
Use the options on this page to adjust the display of object properties.

Show Internal Properties Indicates whether additional object properties are displayed in Autodesk Navisworks.

Select this check box if you want to get access to the Geometry tab and the Transform tab in the Properties
control bar.

Display Page

Use the options on this page to adjust the display performance.

Acceleration

Hardware Acceleration Select this check box to utilize any available OpenGL hardware acceleration on your
video card.

If your video card drivers do not function well with Autodesk Navisworks, clear this check box.

NOTE If your video card does not support OpenGL hardware acceleration, this check box is not available.

Occlusion Culling Select this check box to enable occlusion culling. This means that Autodesk Navisworks only
draws visible objects and ignores any objects located behind other objects.

Selecting this check box improves the display performance when much of the model is not visible. For example,
when you're walking down the corridor of a building.
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IMPORTANT Occlusion culling can only be used on a machine with an OpenGL 1.5 compliant graphics card.

Transparency

Interactive Transparency Select this check box to render transparent items dynamically during interactive
navigation.

By default, this check box is clear, therefore, transparent items are only drawn when interaction has stopped.

NOTE If your video card does not support hardware accelerated OpenGL, selecting this check box can affect display
performance.

Detail

Guarantee Frame Rate Indicates whether the Autodesk Navisworks engine maintains the frame rate specified
on the Speed tab of the File Options dialog box.

By default, this check box is selected, and the target rate is maintained while moving. When movement stops
the complete model is rendered.

If this check box is clear, the complete model is always rendered during navigation, no matter how long it takes.
Fill In Detail Indicates whether Autodesk Navisworks fills in any discarded detail when navigation has stopped.

Batch Fill Select this check box to render detail in chunks (batches) rather than gradually.
NOTE This check box is clear by default, as gradual rendering gives better results for most video cards.

Primitives

Point Size Enter a number from 1 through 9 to set the size (in pixels) of points drawn in the Scene View.
Line Size Enter a number from 1 through 9 to set the width (in pixels) of lines drawn in the Scene View.
Snap Size Enter a number from 1 through 9 to set the size (in pixels) of snap points drawn in the Scene View.

Enable Parametric Primitives Indicates whether Autodesk Navisworks dynamically renders parametric primitives
during interactive navigation.

Selecting this check box means the level of detail changes during navigation depending on the distance from
the camera.

Clear this check box to use the default representations of primitives; the level of detail stays the same during
navigation.

SpaceBall Page

Use the options on this page to customize the SpaceBall behavior.

These options are offered in addition to the adjustments that can be made using the Control Panel for the device
which is supplied by the SpaceBall manufacturer with the installation.

Scale Translation By Enter the value that is used to adjust the speed of translation.
Scale Rotation By Enter the value that is used to adjust the speed of rotation.

Navigation Mode Use the drop-down list to specify a default navigation mode for the SpaceBall. It is used when
no valid navigation mode is currently selected.

ViewCube Page

Use the options on this page to customize the ViewCube behavior.

Show the ViewCube Indicates whether or not the ViewCube is displayed in the top-right corner of the Scene
Area.

TIP You can also toggle the ViewCube by clicking View » Head-Up Display » ViewCube.
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Size Specifies the size of the ViewCube. You can choose from the following options:
B Automatic

Tiny
Small

Medium

Large

NOTE In automatic mode, the size of the ViewCube is relative to the size of the Scene Area, and ranges between
medium and tiny.

Inactive Opacity When the ViewCube is inactive, that is your cursor is distant from the ViewCube, it appears
transparent. To control the opacity level, choose from the following options:

| 0%

" 25%
B 50%
m 75%
m 100%

Keep Scene Upright Indicates whether the upside-down orientations of the scene is allowed when you use the
ViewCube.

When this check box is selected, dragging the ViewCube produces a turntable effect.

When Dragging on the ViewCube

While being dragged, the ViewCube and the scene rotate in an arcball like fashion, unless the Keep Scene Upright
check box is selected.

Snap to the Closest View Indicates whether the ViewCube snaps to one of the fixed views when it is angularly
close to one of the fixed views.

When Clicking on the ViewCube

Fit-to-View on Change When this check box is selected, clicking the ViewCube rotates around the center of
the scene and zooms out to fit the scene into the Scene Area. When dragging the ViewCube, prior to the drag,
the view changes to look at the scene center (but does not zoom) and continues to use that as the pivot point
while dragging.

If this check box is clear, clicking or dragging the ViewCube rotates around the current pivot point and does not
zoom in or out.

Use Animated Transitions When Switching Views If this check box is selected, an animated transition displays
when you click on a section of the ViewCube to help you visualize the spatial relationship between the current
viewpoint and the selected viewpoint.

NOTE When navigating about 3D scenes that contain vast amounts of geometry, the application frame rate may drop
and make it difficult for the system to smoothly animate a viewpoint transition.

Show the Compass Below the ViewCube Indicates whether the compass is displayed below the ViewCube tool.

SteeringWheels

Use the options on this page to customize the SteeringWheels menus.

Big Wheels
Size Specifies the size of big wheels. You can choose from the following options:
B Small (64x64)
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B Normal (128x128)
B Large (256x256).

Normal is the default option.

Opacity Controls the opacity level of big wheels. The default value is 50%. You can choose from the following
options:
B 25% (mostly transparent)

B 50%
m 75%
|

90% (mostly opaque)

Mini Wheels
Size Specifies the size of mini wheels. You can choose from the following options:
B Small (16x16)

B Normal (32x32)
B Large (64x64).
|

Extra Large (256x256)

Normal is the default option.

Opacity Controls the opacity level of mini wheels. The default value is 50%. You can choose from the following
options:
B 25% (mostly transparent)

m 50%
m 75%
B 90% (mostly opaque)

Always Show the Pinned Wheel on Startup When this check box is selected, the ‘pinned’ SteeringWheel and
the First Contact dialog box are always shown when Autodesk Navisworks is started.

On-Screen Messages

Show Tool Messages Toggles the display of tooltips for navigation tools. When this check box is selected, the
tooltips are shown below the cursor as you use the tools.

NOTE This setting is always on for View Object and Tour Building wheels, and cannot be turned off.

Show Tooltips Toggles the display of wheel tooltips. When this check box is selected, the tooltips are shown
when you hover over wedges on the wheels.

NOTE This setting is always on for View Object and Tour Building wheels, and cannot be turned off.

Show Tool Cursor Text Toggles the display of tool label below the cursor.

NOTE This setting is always on for View Object and Tour Building wheels, and cannot be turned off.

Look Tool

Invert Vertical Axis Selecting this check box swaps the up-down axis for the Look tool; that is pushing the
mouse forward looks down, and pulling the mouse backward looks up.

Walk Tool

Constrain Walk Angle Selecting this check box makes the Walk Tool respect the world up vector (as set in File
Options » Orientation). As a result, using the Walk tool causes the camera to snap to the current up vector.
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When this check box is clear, the Walk tool disregards the world up vector, and the camera is walked with its
current up orientation unaffected.

Walk Speed Sets the speed of the Walk tool from 0.1 (very slow) to 10 (very fast).

Zoom Tool

Enable Single-Click Incremental Zoom In When this check box is selected, single clicking over the Zoom
wedge increases the magnification of the model. When this check box is clear, nothing happens when you single
click over the Zoom wedge.

Orbit Tool

Keep Scene Upright When this check box is selected, the Orbit tool behaves similarly to orbit navigation mode,
with orbiting constrained along the XY axis and in the Z direction.

When this check box is clear, the Orbit tool behaves similarly to examine navigation mode, and you can roll
the model around the pivot point.

Enable Selection Sensitivity When this check box is selected, the objects selected before the Orbit tool are used
to calculate the pivot point to use for orbiting. The pivot point is calculated based on the center of the extents
of the selected objects.

File Readers Node

DWF Page

Use this page to adjust the options for the DWF file reader.

Faceting Factor Enter the required value to control the level of faceting that takes place.

The faceting factor must be greater or equal to 0, where O results in the faceting factor being turned off. The
default value is 1. To get twice the number of facets, double the value. To get half as many facets, halve the value.
Larger faceting factors result in more polygons to a model and larger Autodesk Navisworks files.

Max Facet Deviation This setting controls the greatest distance between the edge of a facet and the actual
geometry.
If this distance is greater than the Max Facet Deviation value, Autodesk Navisworks adds more facets.

If the Max Facet Deviation is set to 0, then this function is ignored.

Extract Textures Select this check box to extract textures and environment maps associated with the file.

NOTE Environment maps are not set in the scene by default, and must be configured in Presenter manually.

When this check box is clear, the file reader ignores maps and textures.

See also:

B “DWTF File Reader”

Tools Node

Use the settings in this node to adjust the options for Presenter, Scripter, and Animator.

Presenter Page

Use this page to adjust the Presenter options.

Profile You can adjust Presenter to your level of knowledge.

150 | Chapter 14 Autodesk Navisworks Reference



Select from the following options:

W Basic - gives you access to the basic Presenter features, with a limited editing functionality. This is the default
option.

B Standard - gives you access to some of the advanced Presenter features.

B Advanced - gives you access to the advanced Presenter features, such as extra materials, lights, render styles.

Smoothed Textures Select this check box if you want textures to look smooth; this takes longer to render.
When this check box is clear, the textures render faster, but appear pixelated.

Filtered Textures Select this check box to turn on mipmapping. Using this option improves the appearance of
textures in the distance.

Interactive Materials Indicates whether the applied Presenter materials are shown during navigation. By default,
this check box is selected.

When this check box is clear, textures are not displayed during navigation. Using this option reduces the load
on graphics cards, and gives less drop-out in heavily textured scenes. The materials reappear automatically when
navigation stops, provided Autodesk Navisworks uses full render mode.

Interactive Lighting Indicates whether the applied Presenter lights are shown during navigation. By default,
this check box is selected.

When this check box is clear, lights are not displayed during navigation. Using this option reduces the load on
graphics cards, and gives less drop-out in heavily lit scenes. The lights reappear automatically when navigation
stops, provided Autodesk Navisworks uses full lights mode.

Max Texture Size This option affects the visual details of the textures applied to geometry. Enter the desired
value in pixels. For example, a value of 128 means the maximum texture size of 128 pixels x 128 pixels.

The higher the value, the higher the load on your graphics card, as more MB in memory is required to render
textures.

Max Image Texture Size Specifies the maximum size for texture images in pixels. For example, a value of 256
means the maximum texture size of 256 pixels x 256 pixels.

The higher the value, the higher the load on your graphics card, as more MB in memory is required to render
textures.

Max Background Texture Specifies the maximum size for background textures in pixels. For example, a value
of 256 means the maximum texture size of 256 pixels x 256 pixels.

The higher the value, the higher the load on your graphics card, as more MB in memory is required to render
textures.

Blend Transparent Textures Select this check box to use partially transparent objects. This option improves
overall quality, but takes longer to render.

When this check box is clear, items with transparency of more than 50% are treated as completely transparent,
and are not rendered.

Use Texture Anti-Aliasing Indicates whether antialiasing is used for procedural textures. Selecting this check
box improves quality, but takes longer to render.

A procedural texture is a mathematically- generated image that represents natural elements such as wood, marble,
granite, metal, stone, and so on. In Presenter, procedural textures have ball-style preview icons.

Hardware Shading Selects the hardware-accelerated shading.

NOTE This option can only be used on machines with OpenGL 1.5 compliant graphics cards.

Choose from the following options:

B Off - turns off hardware-accelerated shading.
B Lighting - only lights are shown.

B Passive Shadows - both lights and shadows are turned off during navigation, and automatically reappear
when navigation stops.
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B Interactive Shadows - both lights and shadows are shown during navigation.

Hardware Bump Maps Select this check box to display bump map textures during navigation. To use this option,
enable Hardware Shading first.

NOTE This option can only be used on machines with OpenGL 1.5 compliant graphics cards.

Hardware Marble Select this check box to display hardware-rendered marble materials during navigation. To
use this option, enable Hardware Shading first.

NOTE This option can only be used on machines with OpenGL 1.5 compliant graphics cards.

Scripter Page
Use the settings in this node to customize the Scripter options.

Message Level Selects the contents of the message file.

Choose from the following options:

B User - the message file only contains user messages (that is, messages generated by message actions in scripts).

B Debug - the message file contains both user messages and debug messages (that is, messages generated
internally by Scripter). Debugging enables you to see what is going on in more complex scripts.

Path to Message File Use this box to enter the location of the message file. If a message file doesn't exist yet,
Autodesk Navisworks attempts to create one for you.

NOTE You can't use variables in the file path.

Animator Page
Use the settings in this node to customize the Animator options.

Display Manual Entry Indicates whether the Manual Entry bar is shown in the Animator window. By default,
this check box is selected.

Default Collision Dialog Box

Use this dialog box to specify and save your preferred collision settings.

By default, collision, gravity, crouching, and third person view are switched off. When you modify default
collision settings, your changes do not affect the currently opened Autodesk Navisworks file. They are used as
soon as you open a new Autodesk Navisworks file, or start a new Autodesk Navisworks session.

TIP If you want to restore the default values, click the Defaults button.

Pointing device: Global Options dialog box » Interface node » Viewpoint Defaults option » Settings
button

Collision Select this check box to define a viewer as a collision volume in walk and fly modes. As a result, a
viewer acquires some mass, and cannot pass through other objects, points, or lines in the Scene View.

NOTE Selecting this check box changes the rendering prioritization so that objects around the viewer are displayed
with much higher detail than normal. The size of the region of high detail is based on collision volume radius and
speed of movement.

Gravity Select this check box to give a viewer some weight in walk mode. This option works in conjunction
with Collision.

Auto Crouch Select this check box to enable a viewer crouch under objects that are too low to pass under in
walk mode. This option works in conjunction with Collision.
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Viewer
Radius Specifies the radius of the collision volume.

Height Specifies the height of the collision volume.
Eye Offset Specifies the distance below the top of the collision volume, where the camera will focus upon if

Auto Zoom check box is selected.

Third Person

Enable Select this check box to use third person view. In third person view, an avatar is shown in the Scene
View to represent the viewer.

Selecting this check box changes rendering prioritization so that objects around the avatar are displayed with
much higher detail than normal. The size of the region of high detail is based on collision volume radius, speed
of movement, and the distance of the camera behind the avatar.

Auto Zoom Select this check box to automatically switch from third person view to first person view whenever
the line of vision becomes obscured by an item.

Avatar Specifies the avatar that is used in third person view.

Angle Specifies the angle at which the camera looks at the avatar.

For example, zero degrees positions the camera directly behind the avatar; 15 degrees makes the camera look
down on the avatar at a 15 degree angle.

Distance Specifies the distance between the camera and the avatar.

Collision Dialog Box

Use this dialog box to adjust the collision settings for the selected viewpoint.

By default, collision, gravity, crouching, and third person view are switched off.

TIP If you want to restore the default values, click the Defaults button.

Pointing device: Edit Viewpoint dialog box » Settings button
Collision Select this check box to define a viewer as a collision volume in walk and fly modes. As a result, a
viewer acquires some mass, and cannot pass through other objects, points, or lines in the Scene View.

NOTE Selecting this check box changes the rendering prioritization so that objects around the viewer are displayed
with much higher detail than normal. The size of the region of high detail is based on collision volume radius and
speed of movement.

Gravity Select this check box to give a viewer some weight in walk mode. This option works in conjunction
with Collision.

Auto Crouch Select this check box to enable a viewer crouch under objects that are too low to pass under in
walk mode. This option works in conjunction with Collision.

Viewer

Radius Specifies the radius of the collision volume.
Height Specifies the height of the collision volume.

Eye Offset Specifies the distance below the top of the collision volume, where the camera will focus upon if
Auto Zoom check box is selected.

Third Person

Enable Select this check box to use third person view. In third person view, an avatar is shown in the Scene
View to represent the viewer.

Selecting this check box changes rendering prioritization so that objects around the avatar are displayed with
much higher detail than normal. The size of the region of high detail is based on collision volume radius, speed
of movement, and the distance of the camera behind the avatar.
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Auto Zoom Select this check box to automatically switch from third person view to first person view whenever
the line of vision becomes obscured by an item.

Avatar Specifies the avatar that is used in third person view.

Angle Specifies the angle at which the camera looks at the avatar.

For example, zero degrees positions the camera directly behind the avatar; 15 degrees makes the camera look
down on the avatar at a 15 degree angle.

Distance Specifies the distance between the camera and the avatar.

Background Settings Dialog Box

Use this dialog box to choose a background effect to use in the Scene Area.

£ Menu: Tools » Background
Mode Selects the type of background effect. Choose from:

m Plain
B Graduated

B Horizon

Color Sets the color for a plain background.

Top Color Sets the top color in a graduated background.

Bottom Color Sets the bottom color in the graduated background.

Sky Color Sets the sky color (top) in a horizon background.

Horizon Sky Color Sets the sky color (bottom) in a horizon background.
Horizon Ground Color Sets the ground color (top) in a horizon background.

Ground Color Sets the ground color (bottom) in a horizon background.
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Glossary

Glossary of technical terms relating to Autodesk Navisworks Freedom 2010.

Display Terminology
average frame rate This shows the current measured frame rate, averaged over the last second.

average frame time This shows the time taken to render the last frame.

average triangle rate This shows the rate at which triangles are being rendered and is a measure of how well
your graphics card is working.

culling Culling is a process for determining items not to draw during the render of a scene. Autodesk Navisworks
does a level of prioritized culling with the drop-out method of rendering interactive scenes, but you have a
certain level of control over other aspects of culling such as backface, near and far planes.

drop-out In order to maintain interactivity and guarantee a user-defined frame rate, Autodesk Navisworks only
renders what it can in the fraction of a second it has. The remainder is "dropped out", or not rendered.

Autodesk Navisworks prioritizes what is rendered and what is dropped out based on size of the item's bounding
box, distance from viewer and size on screen, so only the less significant items in the scene are dropped out.

Once navigation has ceased, the scene continues rendering until all items are visible.

frame rate The frame rate is the number of frames per second (FPS) that are rendered in the main navigation
window. Autodesk Navisworks guarantees a user-defined frame rate in order to maintain interactivity.

File Terminology

published data files (nwd ) Published NWD files are useful when wanting to take a snapshot of the model at
a certain time. All the geometry and review information is saved into the .nwd file and cannot then be changed.
Published NWD files can also contain information about the file, as well as being able to be password protected
and time-bombed for security. These files are also very small, compressing the CAD data by up to 80% of the
original size.

Published NWD files are useful when issuing models for viewing by others with the Autodesk Navisworks Freedom
2010 free viewer, as well as being appendable themselves into Autodesk Navisworks to build up a larger scene.
Selection Terminology

These are terms specific to Autodesk Navisworks that are used in relation to selecting items.

composite objects A composite object is a group of geometry that is considered a single object in the selection
tree. For example, a window object might be made up of a frame and a pane. If a composite object, the window
object would be both the frame and the pane and be selected all at once.

instances An instance is a single object, which is referred to several times within a model, for example a tree.
This has the advantage of cutting down on file size by not unnecessarily repeating an object.

item name The original CAD or Autodesk Navisworks assigned identifier. Any item can have a name and this
name will usually come from the original CAD package that the model was created in.
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item type Every item in Autodesk Navisworks has a type. Examples of types are reference files, layers, instances
(sometimes called inserts) and groups. Every CAD package also has a number of geometry types, for example,
polygons, 3D Solids and so on.

selection resolution The selection resolution is the level in the selection tree you start selecting at. You can
cycle through items in the tree by holding down the shift key during a selection.

user name and internal name Each category and property name has two parts - a user visible string which is
localized and an internal string which isn't and is mainly used by the API. By default when matching names in
the Smart Tags and Find Items dialog boxes, both parts must be the same, but you can use the flags to match
only on one part. You might use Ignore User Name if you wanted to match something irrespective of which
localized version was being used.

Viewpoint Terminology

angular speed The speed that the camera moves when turning right and left in any navigation mode.

anti-aliasing Anti-aliasing improves image quality by softening the jagged edge appearance of sharp lines. 2x
to 64x refers to the extra number of frames that are required for the anti-aliasing process. The greater the number
of frames, the finer the effect, (with the consequent increase in rendering time).

aspect ratio Aspect ratio is the proportion of X-axis to Y-axis size. For example, in exporting a bitmap of a
viewpoint, maintaining the aspect ratio would keep the proportion of the view even if the number of pixels was
different.

camera-centric Navigation modes in which the camera is moved around the model.

field of view The field of view of a camera is the angle that the camera can see. A large field of view will fit more
into the view, but will look distorted and a small field of view will tend to make the view more flat, tending
towards an orthographic view. There are two fields of view in Autodesk Navisworks - vertical and horizontal.
Editing one will change the other and the two are related by the viewpoint's aspect ratio.

focal point The focal point is the position in 3D space that the camera will rotate around or zoom into in
examine, orbit, turntable and zoom modes.

model centric Navigation modes in which the model is moved in front of the camera.

roll The roll of the camera is its angle around the viewing axis. This cannot be edited in a navigation mode
where the world up vector stays upright (walk, orbit and turntable).

saved attributes Each viewpoint can optionally save the state of its hidden and "required" items, as well as any
material (color and transparency) overrides. Then, on recalling the viewpoint, those same items are re-hidden,
re-made required, and the materials reinstated. This can be useful in the creation of animations when dragging
on viewpoints onto an empty animation.

tilt angle This is indicated in the scene's units below (negative) or above (positive) horizontal (0) at the base of
the tilt bar.

viewpoint up vector The direction that Autodesk Navisworks considers "up" is called the "viewpoint up vector".
This is maintained in the walk, orbit and turntable modes. This may be also referred to as ‘world up vector’.
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