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Autodesk Asset Locator

Autodesk® Asset Locator (AAL) is an updated version of Autodesk Product Manager. AAL
searches a network and reports information about each Autodesk product installed, including
programs, service packs, extensions, and object enablers. You can save the results of the search
in a file for use in a spreadsheet or database application.

Supported Operating Systems

Autodesk Asset Locator, is supported on the following 32 and 64-bit operating

systems.
Platform Operating System
Windows XP 32-bit B  Windows® XP Home

B  Windows XP Professional
Windows XP 64-bit B Windows XP Home

B  Windows XP Professional
Vista 32-bit B Windows Vista Enterprise

B  Windows Vista Business

B Windows Vista Ultimate

B Windows Vista Home Basic

B  Windows Vista Home Premium
Vista 64-bit B Windows Vista Enterprise



Platform Operating System

B Windows Vista Business
B Windows Vista Ultimate

B Windows Vista Home Premium

Windows 7 32-bit Windows 7 Starter
Windows 7 Home Basic
Windows 7 Home Premium
Windows 7 Professional

Windows 7 Ultimate

Windows 7 Enterprise

Windows 7 64-bit Windows 7 Home Premium
Windows 7 Professional

Windows 7 Ultimate

Windows 7 Enterprise

Browser Internet Explorer® 6.0 or later

Installing Autodesk Asset Locator

Autodesk Asset Locator can be installed using either of the two methods
described below.

To install AAL using the executable file

NOTE The Autodesk Product Manager is no longer supported by Autodesk. It is
recommended you manually uninstall APM before running AAL.

1 Download and copy the self-extracting AALT.0_Installer.exe file to a
destination folder on your computer.

2 In that folder, double-click the AALT.0_Installer.exe file.
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In the WinRAR self-extracting archive dialog, click Install to start the
extraction process to your destination folder, or use the Browse button
to select a different destination folder. You can also enter the folder name
manually.

If you select a folder that does not exist, the folder will be created
automatically before the extraction process begins.

When the extraction process ends, the Autodesk Asset Locator Installation
wizard is displayed, click Install Products.

Review the Autodesk software license agreement. Click I Accept, and then
click Next.

In the Begin Installation page, select Install, then select Yes to the
configuration warning message.

If you wish to change the installation folder location, click the Configure
button. Enter a new install path, or Browse to a different location. After
making your changes, click Configuration Complete, then click Install.

NOTE Changing the installation folder location is the only configuration
option available for AAL.

In the Installation Complete page, click Finish.

Toinstall AAL from the Install Tools and Utilities option from product media

NOTE The Autodesk Product Manager is no longer supported by Autodesk. It is
recommended you manually uninstall APM before running AAL.

1

In the product installation wizard, select a language for the install
instructions. Click Install Tools and Utilities.

Select Autodesk Asset Locator. Click Next.

Review the Autodesk software license agreement. Click I Accept, and then
click Next.

In the Begin Installation page, select Install, then select Yes to the
configuration warning message.

If you wish to change the installation folder location, click the Configure
button. Enter a new install path, or Browse to a different location. After
making your changes, click Configuration Complete, then click Install.
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NOTE Changing the installation folder location is the only configuration
option available for AAL.

5 In the Installation Complete page, click Finish.

Define a Search

You use a search definition to specify the Autodesk products to look for and
the computers to search. You can create as many search definitions as you
need and save them to be run later.

The products to search for are listed in groups, and you can select one or more
groups or all groups. A list of all products that Autodesk Asset Locator can
search for is available on the Help menu, or when you create a new search.

When you create a search definition, you specify the computers to be searched.
You can select a network name or a domain name, or you can select individual
computers. You can also add a computer to the search definition by name.
Autodesk Asset Locator works by searching the registry of each computer.

NOTE In order to complete a network search you must have domain administrative
privileges. Insufficient privileges will return incomplete search data.

The Available Network Computers list can display only the names of computers
that are currently available. An available computer is a computer that is
currently logged on to the network or a computer that is started and at a login
screen or locked. Whether or not the computer is currently available, you can
add it by name to the Computers Added to Search list. At the time you run
the search, if the computer is not available, Autodesk Asset Locator reports
that it was not searched.

To create and save a search definition

1 To use AAL go to Start » All Programs or Programs » Autodesk »
Tools and Utilities » Autodesk Asset Locator.

2 Click File menu » New Search, or click the New Search button.

[ Mew Search

3 In the Product Search Definition dialog box, enter a name for the search
definition, or use the default name.
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Under Products to Locate, select the product group you want to search
for, or select All Products.

NOTE To display a list of all products in a group, click the plus sign to the
left of the group name.

Under Computers to Search, select networks, subnetworks, domains, or
individual computers in Available Network Computers. Then click the
double, right-facing arrow button to add them to Computers Added to
Search. To remove a name, select the name you want to remove and click
the left arrow button.

In addition to using the arrow buttons, you can add computer names,
refresh or browse a list, or remove and enter computer names in the
Available Network Computers and Computers Added to Search areas, by
right-clicking in those areas, and then choosing your action. If you are
listing the names from a text file, make sure you separate the names by
a comma.

Add to 5earch Remaove from Search
Refresh Computers List Enter Computer Name
Browse Computer List.. Browse Computer List..

To select more than one item in either list, hold down the CTRL key
while you select items. To select consecutive items, hold down the SHIFT
key and select the first and last items.

Click OK to save the search definition.

To modify an existing search definition

1
2

Click File menu » Modify Search.

In the Modify Search Definition dialog box, select a search definition
and click Modity.

In the Product Search Definition dialog box, enter a new name for the
search definition, or use the existing name.

Under Products to Locate, select the product group you want to search
for, or select All Products.

To display a list of all products in a group, click the plus sign to the left
of the group name.

Under Computers to Search, select networks, subnetworks, domains, or
individual computers in Available Network Computers. Then click the
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double, right-facing arrow to add them to Computers Added to Search.
To remove a name, select the name you want to remove and click the
left arrow.

6 Click OK to save the modified search definition.

To refresh the Available Network Computers list

1 In the Product Search Definition dialog box, select any item in the
Available Network Computers list.

2 Right-click the selected item, and then click Refresh Computers List. Or
click the Refresh button located beside Available Network Computers:

().

The list is updated to display computers that are currently available to be
searched. An available computer is a computer that is currently logged on to
the network or a computer that is started and at a login screen or locked.

Run or Resume a Search

You can run a defined search multiple times. Each time, you can either generate
a new report or add to the results from an earlier search. The Report View in
the Autodesk Asset Locator window displays the columns you specify.

The options you set before you run the search control how many times
Autodesk Asset Locator attempts to search computers that were unavailable
during the initial run.

You can also control which data columns are displayed in the Report View.
The Columns to Display list can be reordered.

Autodesk Asset Locator works by searching the registry of each available
computer. An available computer is a computer that is currently logged on to
the network or a computer that is started and at a login screen or locked. If
you entered a computer in the search definition by either selecting it
individually or entering its name, and it is not available at the time the search
is run, Autodesk Asset Locator reports that it was not searched.

To obtain the most complete results, it is recommended that you run a search
at a time when most of the computers on the network are available. You can
also select individual computers or enter them by name to ensure that any
computers that are not available at the time the search is run are reported as
not searched.
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NOTE In order to complete a network search you must have domain administrative
privileges. Insufficient privileges will return incomplete search data.

If you pause a search while it is running and then run it again, the new results
are added to the results from the original search. To start the search from the
beginning again, clear the results from the Report View.

The report lists results for every computer that was included in the search
definition. If you want a report that lists only the computers that match the
search criteria, select the filter option.

You can specify which columns to display in the Report View from the Product
View Options or License Server View Options tabs. You can also display labels
next to the toolbar buttons and restore display of warnings and alerts.

&, Search and Viewer Options @Iﬂ_hj
Performance Options
(@) Run search once
() Retry missing computers 1 times
Product View Options License Server Wiew Options
Columns to display: Columns to display:
[l fields - [Z]All fields
[¥]Domain a []License Server
[#]PC Name - [#]Product Name -
[¥] butodesk Products [7]5erial Mumber
[#]version hd []5eats hd
[#]Installation Location i [¥]Query Status
Ly o O 1Y DY Sy
[T Filter computers that don't match search
Display toolbar button text
[|Restore default messages and alert boxes
o) Comw )
Y
\

To specify how many times to run the search

1 Click Options menu » Search and Viewer Options.

2 In the Search and Viewer Options dialog box, under Performance Options,
select one of the following options:
B Run Search Once The search goes through the list of computers in
the search definition only once.

B Retry Missing Computers x Times The search goes through the list of
computers in the search definition once and then attempts to search
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the computers that were unavailable during the first run. You specify
how many times to try before stopping.

3 Click OK.

To specify which columns to display in the search results

1 Click Options menu » Search and Viewer Options.

2 Inthe Search and Viewer Options dialog box, under Columns to Display,
select All Fields or select the columns you want to be displayed in the
Report View.

3 To move a column name up or down in the list, select the column name
and click the Move Up or Move Down buttons to move it one position.

4 Click OK.

To display only the computers that match the search criteria

1 Click Options menu » Search and Viewer Options.

2 In the Search and Viewer Options dialog box, select Filter Computers
That Don't Match Search.

If you do not select this option, results are displayed for all computers
that were included in the search definition.

3 Click OK.

To display labels next to toolbar buttons

1 Click Options menu » Search and Viewer Options.

2 In the Search and Viewer Options dialog box, select or clear the Display
Toolbar Button Text option.

3 Click OK.

To restore default messages and alert boxes
1 Click Options menu » Search and Viewer Options.

2 In the Search and Viewer Options dialog box, select Restore Default
Messages and Alert Boxes.

3 Click OK.
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To run a defined search

1 Click File menu » Open Search or use the Open Search button.

= Open Search

2 In the Open Search Definition dialog box, select the search to run and
click OK.

If the search definition you select has search results that have not been
saved, you can save or discard them before you run the search again.

3 Click Options menu » Search and Viewer Options.

4 In the Search and Viewer Options dialog box, under Performance Options,
select the number of times to run the search.

5 Under Columns to Display (Product View and License Server View
Options), select All Fields or select the columns you want to be displayed
in the Report Views.

6 Click OK to close the dialog box.

7 Click the Search menu » Run Search.

To resume a search that is stopped and add new data to the results

B Click the Search menu » Run Search or use the Run Search button.

[= Run Search

To clear partial results and restart a search that is stopped
1 Click the Search menu » Clear Search.

2 Click the Search menu » Run Search.

Print or Export the Report View

You can print the Report View from the Autodesk Asset Locator window or
export the results to a file for use in a spreadsheet or database program.

You can use the filter option in the Search and Viewer Options Dialog Box
on page 17 to display only the computers that match the search criteria.
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Autodesk Asset Locator reports the following information for each Autodesk
product found installed on a computer. In the Report View, if more than one
product is found installed on a computer, the computer is listed in a new row
and the information is provided for the additional product.

Product Information tab
B The name of the domain and computer searched

B The name and version or release number of the Autodesk product found
on the computer

B The location of the Autodesk product found
B The serial number and language of the Autodesk product found

B The personalization information: user name, organization, dealer name,
and dealer telephone number

B The service pack name

B How the product is installed: stand-alone, network-server, network-client,
or network-shared (thin client)

B The status of the search of the computer, including whether Autodesk
Asset Locator was unable to access the computer or was denied access

B The date and time the computer was searched

License Server Information tab
The name of the license server searched
The name of the Autodesk product found, and the product’s serial number

The number of Autodesk licenses (seats)

The status of the search

You can use standard Microsoft Windows procedures in the Report View to
change the width of columns, hide columns, and move columns. You can
also sort the results by column (for example, by product found). Use CTRL+C
to copy data to the Clipboard in CSV (comma-delimited) file format.

For other formatting options, export the results to a file to be used in a
spreadsheet or database program.
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The Subscription button provides access to the Autodesk Software Subscription
Coverage Report. The subscription report contains the following information:

Contract number

Contract coordinator (the purchasing agent or financial decision maker)
Contract validity dates

Reseller (if available)

Licenses

Serial number(s)

Seats

Fulfillment coordinator for the contract (usually the CAD manager)
Technical coordinator for the contract

Support

Deployment

Total for the product group

To change the width of a column

1 Move the cursor over the line that separates the column you want to

change from the column on its right.

The cursor changes to a double-headed horizontal arrow.
Drag left to decrease the width, or drag right to increase the width.
Double-click to expand the column to accommodate display of its longest

content.

The column heading is not affected when you expand the column to
accommodate its contents. Use the dragging method for the column
heading.

To sort search results by column in the Report View

Click a column heading to sort the list by that column. Click again to sort
the list in reverse.
Shortcut Right-click and then click Sort Ascending or Sort Descending.
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To hide a column

1 Move the cursor over the line that separates the column you want to
change from the column on its right.

The cursor changes to a double-headed horizontal arrow.

2 Drag the column separator at the right of the column heading to the left
until the column heading disappears. To restore a hidden column, drag
right.

Shortcut Right-click and click Hide Column. To restore all hidden
columns, click Show All Columns.

To move a column

B Drag the column heading of the column that you want to move into the
column heading that you want to directly precede that column.

To print the results from the Report View

B Click File menu » Print Report or use the Print Report button.

(=1 Print Report

The printed report includes all columns and rows, not just visible columns
and rows. The printed reports contain results from the Product Information
tab first with the pages numbered Xof Y, followed by search results from
the License Server Information tab. Page numbering for the License Server
Information report restarts at 1.

To export the results from the Report View

1 Click File menu » Export Report or use the Export Report button.
T Export Report
2 In the Export Report dialog box, enter a file name for the report file in
the File Name box, or use the default name.

3 Specify a location for the exported report file in the Folders list. If the list
is not showing, click the Browse Folders button.

4 In Save As Type, select a file format:
B Microsoft Excel® 2000 Workbook (*.xIs)

B Microsoft Access™ 2000 Database (*.mdb)
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B Comma Delimited Text (*.csv)
The default format is *.xIs.

5 Click Save to export the file.

NOTE If you export search data to an Excel spreadsheet, results are saved in
separate Autodesk Products and License Server Details tabs.

Autodesk Asset Locator Window

£ Menu: Start menu (Windows) » All Programs » Autodesk » Tools and
Utilities » Autodesk Asset Locator

Provides menus for creating search definitions and searching for Autodesk
stand-alone and network products. The results are displayed in table format
in the same window, which is referred to in Help as the Autodesk Asset Locator
Report View on page 19.

The Subscription button on the Autodesk Asset Locator toolbar provides access
to the Autodesk Software Subscription Coverage Report.

il Autodesk Asset Locatoe

£ [ MewSeaech (2 Open Search (R Expont Report | 5 Print Repert | |15 Run Search 7 Setserption [F] Help

Product Information | License Server Information

Domsn  PCMame Bestocdesk Prodcts Version Instalaton Locaton  Serialfumber  Languege  User Mame

a0 C¥ropamFlesliat.. NO-09995  Engheh
fest 009 o CProgramFlesliat,.,  TOAOS  Engheh
Sastoddesk Design Review 2010 10.0.0.108 C:Program Flesiut

File Menu
Controls the search definition and the report of results.

New Search Displays the Product Search Definition Dialog Box on page 15,
where you create a new search definition.
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Open Search Displays the Open Search Definition Dialog Box on page 16,
where you can open a saved search definition that you want to run.

Modity Search Displays the Modify Search Definition Dialog Box on page
17, where you can open, copy, rename, or delete saved search definitions.

Export Report Displays the Export Report Dialog Box on page 20, where you
can export the results of a search to a file in one of three file formats.

Print Report Prints the results displayed in the Autodesk Asset Locator Report
View on page 19.

Exit Closes Autodesk Asset Locator.

Search Menu
Runs, pauses, and clears searches.

Run Search Runs the currently specified search. The results are displayed in
the Autodesk Asset Locator window while the search is running. If you pause
a search and then run it again without first clearing the search, the results are
appended to the results that are already displayed.

Pause Search Stops a search before it is complete. You can resume the search
or clear the results so far and start the search again.

Clear Search Clears any search data for the current search definition.

Options Menu
Specifies how many times to run the search and how to display the results.

Search and Viewer Options Displays the Search and Viewer Options Dialog
Box on page 17, where you can control how the search is run and how the
results are displayed. You can also control the display of toolbars and messages.
Help Menu

Provides access to Help and a complete list of products that Autodesk Asset
Locator can search for.

Help Displays Help.

Products Searched Lists the products that Autodesk Asset Locator can search
for.

About Displays version and copyright information.
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Product Search Definition Dialog Box

¥ Toolbar: Toolbar » LI New Search
£ Menu: File » New Search

Defines, names, and saves a search definition.

o
&, Product Search Definition |@—2@|
Search name:
Search 4
Products to locate Computers to search
Autodesk products: Available network computers: Computers added to search:
[Z]all Products R [B My Computer (CCN12375636)

[¥]AutoCaD

Autodesk Architectural Stur =
Autodesk Raster Design
AutoCAD Express Tools
AutoCAD LT

AutoCAD Map

Autodesk Topobase Client
Autodesk Topobase Admini:
Autodesk Topobase web
Autodesk Utility Design
AutoCAD Mechanical
Autodesk Inventor

[-[W] Architectural Desktop o
'l 1n 3

g"’ Microsoft Windows Network

[ oK ][ Cancel ][ Help ]

A

- A

Search Name Names the search definition. If you do not enter a name, the
search is automatically named Search 1, Search 2, and so on.

Autodesk Products Lists the group of products to find. To display a list of all
products in a group, click the plus sign to the left of the group name.

Available Network Computers Lists the computers currently available on
the network. An available computer is a computer that is currently logged on
to the network or a computer that is started and at a login screen or locked.

Computers Added to Search Lists the computers to search. To add a computer
by name, right-click in the Computers Added to Search list and click Enter
Computer Name on the shortcut menu. Enter the name of the computer in
the new box in the list and press ENTER. You can enter a domain name as
follows: domainname\\.

4
Refresh button Refreshes the Available Network Computers list to
include computers that have become available since the dialog box was opened.
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Add to Search, Refresh Computers List, Browse Computer List (Shortcut
menu) Adds a computer, refreshes an existing list to include computers that
have become available since the dialog box was opened, or allows you to
browse for a computer in the Available Network Computers list.

Add to Search
Refresh Computers List

Browse Computer List.,

Remove from Search, Enter Computer Name, Browse Computer List
(Shortcut Menu) Removes a computer, network, or domain that is selected
in the Computers Added to Search list from the search, adds a computer name,
or allows you to browse for a computer in the Computers Added to Search
list.

Remove from Search
Enter Computer Name

Browse Computer List..

Open Search Definition Dialog Box

) Toolbar: Toolbar » [ Open Search
£ Menu: File » Open Search

Opens a saved search definition so that you can run the search.

&, Open Search Definition |@—88|
Search definition:
Search 1
Search 2
I QK I I Cancel I l Help J
4

A

Search Definition Lists saved search definitions.
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Modify Search Definition Dialog Box
£ Menu: File » Modify Search

Copies, renames, deletes, or modifies a saved search definition.

&, Modify Search Definition

Search definition:

Modify

Search 2
Copy

Rename

i

Delete

[ Close ]

Help

V

e

Modify Closes the Modify Search Definition dialog box and opens the Product
Search Definition dialog box, where you can make changes to the selected
search definition.

Copy Copies the selected search and adds it to the list with Copy of added to
the search name. If you make more than one copy, a number is added to the
name, for example, Copy of Basic 1.

Rename Places a box around the selected search definition so that you can
enter a new name.

Delete Deletes the selected search definition.

Search and Viewer Options Dialog Box
£ Menu: Options » Search and Viewer Options

Controls how the search is run and how the results are displayed; also controls
the display of toolbars and messages.

Modify Search Definition Dialog Box | 17



&, Search and Viewer Options Liléj

Performance Options

(@) Run search once

() Retry missing computers 1 times
Product View Options License Server View Options
Columns to display: Columns to display:
[] Al fields - [Z] Al fields
[¥]Domain E [/]License Server
[¥]PC Name - [¥]Product Name -
[¥] dutodesk Products [7]5erial Mumber
[#]version A [7]seats A
nstallation Location i [¥]Query Status
e U N S

[T Filter computers that don't match search

Display toolbar button text

[|restore default messages and alert boxes

o) Com )

L= A

[

Run Search Once Runs the search once through the list of computers in the
search definition.

Retry Missing Computers x Times Searches for computers that were not
available to be searched, and repeats this process the number of times you
specify or until all computers in the search definition have been searched.

Product View Options/Columns to Display Controls the columns that are
displayed in the AAL window’s Product Information tab.

Move Up Moves the column name selected in the Columns to Display list up
one position.

Move Down Moves the column name selected in the Columns to Display list
down one position.

Filter Computers That Don't Match Criteria Displays in the search results
only the computers that match the search criteria.

Display Toolbar Button Text Controls the display of toolbar buttons. When
this option is selected, the name of the toolbar button is displayed beside the
button icon. When the option is not selected, only the toolbar button icon
is displayed.

Restore Default Messages and Alert Boxes Restores the display of messages
that you turned off.
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License Server View Options/Columns to Display Controls the columns
that are displayed in the AAL window’s License Server Information tab.

Autodesk Asset Locator Report View

£ Menu: Start menu (Windows) » All Programs » Autodesk » Tools and
Utilities » Autodesk Asset Locator

Product Information tab

Reports the results of a search in the form of a table. Information is displayed
in the following columns:

Domain Displays the domain name.

PC Name The name of the computer that was searched. If the computer was
not searched, the icon that precedes its name appears gray.

Autodesk Products The name of an Autodesk product found on the computer.
If no products are found, the entry is None.

Version The version or release number of the product found. If no products
are found, the entry is blank.

Installation Location The location of the Autodesk product found. If no
products are found, the entry is blank.

Serial Number The serial number of the Autodesk product found. If no
products are found, the entry is blank.

Language The language of the product found.

User Name The user name from the personalization information (if any) for
the product found.

Organization The company name from the personalization information (if
any) for the product found.

Dealer Name The name of the dealer from the personalization information
(if any) for the product found.

Dealer Phone The telephone number of the dealer from the personalization
information (if any) for the product found.

Service Pack Name The name of the service pack (if any) installed for the
product found.
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Installation Type The installation type for the product found. Installation
types are stand-alone, network-server, network-client, and network-shared
(thin client).

Query Status The status of the search for this computer. Status messages are
OK, Computer Not Found, Access to the Computer Is Denied, and Unknown
Error While Searching the Machine.

Query Date The date and time the computer was searched.
License Server Information tab

Reports the results of a network search in the form of a table. Information is
displayed in the following columns:

License Server Displays the License Server name.

Product Name The name of an Autodesk product found on the computer. If
no products are found, the entry is None.

Serial Number The serial number of the Autodesk product found. If no
products are found, the entry is blank.

Seats Displays the number of users for a specific product.

Query Status Displays the current status of the search.

Export Report Dialog Box

£ Toolbar: Toolbar » = Export Report
£ Menu: File » Export Report

Exports the results of a search to a file in one of three file formats.

File Name Specifies the file name for the exported search results. If you do
not enter a file name, the name of the search is used and the file extension
.xls is added to export the results in Microsoft Excel 2000 format.

Save As Type Specifies the file format for the report file. The file formats are
B Microsoft Excel 2000 Workbook (*.xIs)

B Microsoft Access 2000 Database (*.mdb)

B Comma Delimited Text (*.csv)

The default format is *.x/s.
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Browse Folders/Folders Specifies the folder in which to save the file. You can
create a new folder from this location.

Autodesk Asset Locator at the DOS Prompt

At the DOS prompt, in the Autodesk Asset Locator directory, you can enter AAL
to run Autodesk Asset Locator. To run a search that has already been defined
and export the results to a file, use the following syntax, all on one line.

AAL [ Search Definition ] [/mf][/mb /R ReportFile][/*][/?]

If you do not enter a search definition, the whole network is searched for all
products. You can use the following switches:

/mf Switch Displays the Autodesk Asset Locator window. You run the search
in the dialog boxes provided. The /R switch and the report file name, even if
specified, are ignored.

/mb Switch Displays a dialog box that shows the progress of the search and
provides a button you can use to cancel the search. When you use this switch,
the /R switch and the report file name are required.

/R Switch Creates a report of the search results. The file extension of the file
name you enter determines the file format. The file extensions are .x/s
(Microsoft Excel 2000 Workbook), .mdb (Microsoft Access 2000 Database),
and .csv (Comma-Delimited Text).

ReportFile The report file name with the path to write the search results.
/* Switch Lists the saved search definitions.
/? Switch Shows command line Help.

When you press ENTER, Autodesk Asset Locator runs the search in the DOS
window until the search is complete or canceled. You cannot pause the search
and resume it. To stop a search, press CTRL+C. The results of the partial search
are saved.
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