# Contents

**AutoCAD Electrical Environment** ........................................... 1  

**Chapter 1**  
**Introduction** ................................................................. 3  
About Standards  ................................................................. 3  
Performing Exercises ............................................................. 3  
Prerequisites ............................................................................ 4  
Help ......................................................................................... 4  
Command Summary ................................................................. 5  

**Chapter 2**  
**Projects** ................................................................................ 7  
Working with Projects .............................................................. 7  
Working with Drawings .............................................................. 10  

**Ladder Style Diagrams** ......................................................... 17  

**Chapter 3**  
**Wires** .................................................................................... 19  
About Wires .............................................................................. 19  
Inserting Wires ........................................................................ 20  
Trimming Wires ........................................................................ 21  

**Chapter 4**  
**Schematic Components** ....................................................... 23  

**iii**
About Schematic Components ........................................... 23
Inserting Components .................................................... 23
  Relocating Components ............................................. 28
  Aligning Components ............................................... 32
  Inserting Components .............................................. 33
Editing Components ...................................................... 36
Linking Components ..................................................... 40
Editing Catalog Information .......................................... 42
Moving Between Symbols ............................................... 46
Swapping Components .................................................. 48
Creating Custom Symbols ............................................. 50
  Adding Attribute Symbols ......................................... 51
  Adding Wire Connection Points ................................. 54
  Saving Symbols ...................................................... 57

Chapter 5 Circuitry .................................................... 59
  Moving an Existing Circuit ......................................... 59
  Creating a New Motor Circuit ...................................... 64
  Saving and Inserting Standard Circuits ........................ 81
  Inserting Saved Circuits Using WBlock ......................... 91
  Inserting a One-line Motor Circuit .............................. 93
  Inserting a Dual One-line Power Feed Circuit ............... 98
  Referencing an Existing Circuit ................................ 101

Chapter 6 PLC .......................................................... 105
  Inserting Ladders into Drawings .................................. 105
  Inserting PLC Modules ............................................ 107
  Using Multiple Insert Component ................................ 111
  Annotating PLC I/O Descriptions ............................... 116
  Inserting I/O Based Wire Numbers .............................. 118
  Resequencing Ladders ............................................. 121

Chapter 7 Wire Numbers ............................................ 123
  About Wire Numbers .............................................. 123
  Attaching Source Signal Arrows .................................. 123
  Attaching Destination Signal Arrows ............................ 125
  Inserting Wire Numbers .......................................... 131
  Working with Wire Layers ....................................... 134

Chapter 8 Panel Layouts ........................................... 137
  About Panel Layouts .............................................. 137
  Inserting Panel Components .................................... 137
  Modifying Attributes ............................................ 149
  Adding Nameplate Footprints ................................. 153
AutoCAD Electrical Environment

Part 1 of this manual provides information about access to AutoCAD® Electrical commands and how to set up a project.
Introduction

AutoCAD® Electrical software extends the capabilities of AutoCAD® so that you can quickly build and manage an electrical controls drawing set.

This manual provides concepts and exercises to help you get started with AutoCAD Electrical.

About Standards

AutoCAD Electrical currently supports the following industry standards: JIC (US), IEC (Europe), JIS (Japan), GB (China) and AS (Australia). Although AutoCAD Electrical supports many standards, the Getting Started manual follows the JIC standard and sample drawing set.

Since the workflow for both JIC and IEC are nearly identical, you can perform the following exercises using the IEC demo drawing set, however your components and wire numbering will display differently.

Performing Exercises

All of the AutoCAD commands and features are available while working on AutoCAD Electrical drawings. All intelligence is carried directly on the drawing using AutoCAD blocks with attributes and XDATA. AutoCAD Electrical does not require any underlying database.

Backup exercise files are found at Documents and Settings\{username}\My Documents\Acade {version}\Aedata\Tutorial\Aegs or Users\{username\}\Documents\Acade {version}\Aedata\Tutorial\Aegs on a Windows Vista® installation. If you make a mistake while working through the exercises in this manual, simply browse to and copy the demo file(s) to your project folder.
The exercises in this manual must be performed in order. It is advised to turn off the AutoCAD Dynamic Input feature (found on the status bar) before starting the exercises.

The Getting Started manual uses two manufacturers: Allen Bradley and Siemens. You must install both manufacturers in order to have the same results that are shown here. If you need to install content from these manufacturers, follow these steps.

1. Open the Add or Remove Programs tool in your Control Panel.
2. Select AutoCAD Electrical.
3. Click Change/Remove.
4. Click Add/Remove Features.
5. Click Next on the first screen.
6. Select AB and Siemens on the Manufacturer Contents Selection screen.
7. Click Next on the Symbol Libraries screen.
8. Click Next to continue.

Prerequisites

It is assumed that you have a working knowledge of the AutoCAD interface and tools. If you do not, review the AutoCAD online documentation.

It is recommended that you have a working knowledge of Microsoft® Windows® 2000 or Windows® XP, and a working knowledge of electrical design and schematic ladder wiring diagrams.

Help

The AutoCAD Electrical Help system provides detailed concepts, procedures, and reference information about every product feature. To access the Help system:

- Select the Help icon in the upper right to display a menu of help options.
- Select Help ➤ Electrical Help Topics from the menu.
Click the Help button or press F1 within a dialog box or at a command prompt.

Be more productive with Autodesk® software. Get trained at an Autodesk Authorized Training Center (ATC®) with hands-on, instructor-led classes to help you get the most from your Autodesk products. Enhance your productivity with proven training from over 1,400 ATC sites in more than 75 countries. For more information about Autodesk Authorized Training Centers, contact atc.program@autodesk.com or visit the online ATC locator at www.autodesk.com/atc.

**Command Summary**

You can access commands in AutoCAD Electrical through the command line, the ribbon, and toolbars.

AutoCAD Electrical provides three predefined workspaces.

- **ACADE & 2D Drafting & Annotation** - ribbons that provide the AutoCAD Electrical tools, and the AutoCAD 2D Drafting and Annotation tools.

- **ACADE & 3D Modeling** - ribbons that provide the AutoCAD Electrical tools, and the AutoCAD 3D Modeling tools.

- **AutoCAD Electrical Classic** - toolbars and pull down menus that provide the AutoCAD Electrical tools and AutoCAD tools.

You can switch to another workspace whenever you need to by selecting the Workspace icon on the status bar.

It is recommended to use the ACADE & 2D Drafting & Annotation workspace for these exercises.
This chapter contains information about AutoCAD® Electrical projects and how to work with them.

**Working with Projects**

AutoCAD Electrical is a project-based system. An ASCII text with a `.wdp` extension defines each project. This project file contains a list of project information, default project settings, drawing properties, and drawing file names. You can have an unlimited number of projects; however, only one project can be active at a time.

**NOTE** Install the JIC symbol library for these exercises to function properly.

Use the Project Manager to add new drawings, reorder drawing files, and change project settings. You cannot have two projects open in the Project Manager with the same project name. By default, the Project Manager is open and docked on the left-hand side of your screen. You can dock the Project Manager into a specific location on the screen or hide it until you want to use the project tools. Right-click the properties icon to display options to move, size, close, dock, hide, or set the transparency for the Project Manager.
Create an AutoCAD Electrical project

1. Click Project tab ➤ Project Tools panel ➤ Manager.

2. In the Project Manager, click the New Project tool.

   **NOTE** You can also use the Project Manager to open an existing project. In the Project Manager, click the project selection arrow and select Open Project.

3. In the Create New Project dialog box, specify:
   
   **Name:** AEGS
   
   A name must be entered to define any of the project properties. The .wdp extension is not required in the edit box.
   
4. Make sure *wddemo.wdp* is specified in the Copy Settings from Project File edit box.
5 Click OK-Properties.

Your new project is added to the current projects list and automatically becomes the active project.

The Project Properties dialog box displays, where you can modify your project default settings. All information defined on these tabs are saved to the project definition file as project defaults and settings.

**Set project properties**

1 In the Project Properties dialog box, click the Components tab.

2 In the Component Tag Format section, verify that Line Reference is selected.
   This selection creates unique reference-based tags when multiple components of the same family are located at the same reference location. When reference-based tagging is used, a suffix variable is required to keep components of the same family type unique. For example, three push buttons on line reference 101 could be labeled PB101, PB101A, and PB101B. Click Suffix Setup to change the suffix variable.

3 Click the Wire Numbers tab.

4 In the Wire Number Format section, verify that Line Reference is selected.
   This selection creates unique reference-based wire number tags for multiple wire networks beginning at the same reference location. When reference-based numbering is used, a suffix variable is required to keep wires on the same reference line or in the same reference zone unique. Click Suffix Setup to change the suffix variable.
5 Review the various options on the different tabs of the Project Properties dialog box.

**NOTE** In the Project Properties dialog box, icons indicate whether the settings apply to project settings or drawing defaults. Settings that apply to project settings have the project icon next to them and are saved inside the project definition file (*.wdp). Settings that are saved in the project file as drawing defaults have the drawing icon next to them. Drawing related data to add to the project when running the Add Drawing command is saved as Drawing Custom Properties.

6 Click OK.

**Working with Drawings**

A single project file can have drawings located in many different directories. There is no limit to the number of drawings in a project. You can add drawings to your project at any time. When you create a drawing, using the New Drawing tool, it is automatically added to the active project.

Many of the drawing settings used by AutoCAD Electrical are stored in a smart block on the drawing named WD_M.dwg. Each AutoCAD Electrical drawing should contain only one copy of the WD_M block. If multiple WD_M blocks are present, the settings cannot be stored and read consistently.
Create a drawing

1. In the Project Manager, click the New Drawing tool.

2. In the Create New Drawing dialog box, specify:
   - Name: AEGS11
   - Description 1: Bill of Materials Report

3. Click Browse next to the Template edit box.
   A set of templates (*.dwt files) installed with AutoCAD Electrical contain settings for various kinds of drawings, such as acad.dwt and ACAD_ELECTRICAL.dwt.
   You can create your own templates, or use any drawing as a template. You can save a drawing at any stage of completion as a template file. When you use a drawing as a template, the settings in that drawing are used in the new drawing. The changes you make to a drawing that is based on a template do not affect the template file.
   AutoCAD Electrical fully supports the use of AutoCAD template files. To make an AutoCAD drawing compatible with AutoCAD Electrical, select an AutoCAD Electrical command to modify the drawing.

4. In the Select template dialog box, select ACAD_ELECTRICAL.dwt, and click Open.

5. In the Create New Drawing dialog box, click OK.
NOTE You could click OK-Properties to display the Drawing Properties dialog box. This dialog box has options like the options found in the Project Properties dialog box. It defines drawing-specific settings that are maintained inside the WD_M block of the drawing.

6 In the Project Manager, double-click the project name (AEGS) to display the drawing files. AEGS11 should be the only file in the list.

Add drawings to the project

1 In the Project Manager, right-click AEGS, and select Add Drawings.

2 In the Select Files to Add dialog box, select drawings AEGS01.dwg to AEGS10.dwg and click Add.

3 When asked whether to apply the project default values to the drawing settings, click Yes.

The Project Manager lists the files under the AEGS folder. New drawings that you add from this point on are added at the end of the drawing order. You now have access to the files required for the exercises in this book.

NOTE Two projects can reference the same drawing file. However it can lead to conflicts if both projects try to modify the same drawing with a project-wide tagging or cross-referencing function.

The drawing order in the Project Manager determines how AutoCAD Electrical processes the drawings during project-wide operations such as resequencing and wire numbering.

4 In the Project Manager, right-click the project name, and select Reorder Drawings.
5 In the Reorder Drawings dialog box, select AEGS10.dwg and AEGS11.dwg and click Move Down until the drawings are at the bottom of the list.

6 Click OK. 

AEGS11.dwg is now at the bottom of the project drawing file list in the Project Manager.

**NOTE** The active drawing displays in bold text in the project drawing list. You can easily see which file you are working in.

---

You can add descriptions for each drawing to the project file. You can reuse drawing descriptions in title block attributes and associate them with AutoCAD Electrical reports.

**Add the description of a drawing you add**

1 In the Project Manager, right-click AEGS10.dwg, and select Properties ➤ Drawing Properties.

2 In the Drawing Properties ➤ Drawing Settings dialog box, Drawing File section, specify:
   - Description 1: Connector Drawing

3 Click OK.

4 In the Project Manager, select AEGS10.dwg.
5 In the Project Manager, Details section, review the drawing descriptions. The drawing details update when you highlight a drawing file and remain visible until a new drawing file is selected. Displayed information includes the status, file name, file location, file size, last saved date, and the name of the last user who modified the file.

Use the Project Manager to preview drawings easily. Moving among drawings using the up and down keys does not open the drawing. It changes the preview or details display in the Project Manager.

**View drawings in a project**

1 In the Project Manager, select `AEGS04.dwg`.

2 In the Project Manager, Details section, click Preview.

3 Continue to click the drawing name you want to preview or use the up and down arrow keys to scroll through the drawing files.

4 When you finish viewing the drawings, click Details to return to the drawing details view.

If a project drawing is currently open and you want to move to the previous or next drawing in the list of the project, use the Previous Project Drawing and Next Project Drawing tools. When you move among drawings, any unsaved changes to the current drawing are saved, the drawing is closed, and the requested drawing is opened.

**View project drawings when a drawing is open**

1 In the Project Manager, double-click `AEGS04.dwg`. 
2. To view the drawings, Click Project tab ➤ Other Tools panel ➤ Previous DWG.

or Click Project tab ➤ Other Tools panel ➤ Next DWG.

A new window opens and the original window closes when you click the navigation tools unless you hold the Shift key while clicking the tools.
Ladder Style Diagrams

Part 2 of this manual provides information about how to set up and work with ladder style diagrams.
This chapter contains information about wires and how they are used in AutoCAD® Electrical.

**About Wires**

AutoCAD Electrical treats AutoCAD® line entities as wires when the lines are placed on an AutoCAD Electrical defined wire layer. The number of wire layers available in AutoCAD Electrical is unlimited. These lines get tagged with wire numbers and show up in various wire connection reports.

Two wire segments connect if the end of one wire segment touches or falls within a small trap distance of any part of the other wire segment. This connection can be at the end of the other wire or anywhere along the length of the other wire.

AutoCAD Electrical considers a wire connected to a component if the wire end falls within a trap distance from the wire connection-point attribute of a component.

The wire layer for a new wire segment is determined by:

- Wires that begin or end in space, or begin and end at a component connection point. They are put on the current layer (if it is a wire layer), or on the first wire layer AutoCAD Electrical finds in a layer name search.

- Wires that begin at an existing wire are put on the same layer as the beginning wire.

- Wires that begin in space or at a component and end at an existing wire take on the layer of the ending wire.
**Inserting Wires**

You can start or end a wire segment in empty space, from an existing wire segment, or from an existing component. If you start from a component, the wire segment snaps to the wire connection terminal closest to your pick point on that symbol. If the wire segment ends at another wire segment, a DOT (block name *wddot.dwg*) is applied if appropriate. If it ends at another component, the segment connects to the wire connection terminal closest to your pick point on that symbol.

**NOTE** When inserting wires, if a wire already occupies a wire connection point, the new wire is drawn as an angled wire connection.

**Insert wiring**

1. In the Project Manager, Project Drawing List, double-click *AEGS04.dwg*.
2. Zoom in on the upper left corner of the drawing. Make sure the hot and neutral vertical wires are displayed.
3. Click Schematic tab ➤ Edit Wires/Wire Numbers panel ➤ Modify Ladder drop-down ➤ Add Rung.
4. Respond to the prompts as follows:

   Add rung passing through this location or [wiretype (T)]:
   Select a location between the two vertical bus wires beside line reference 403 (1)
   Add rung passing through this location or [wiretype (T)]:
   Select a location between the two vertical bus wires beside line reference 404, underneath the newly created rung (2), press ENTER

Two horizontal wires are created automatically between the vertical bus wires at the closest line reference location.
Create two vertical wires between two horizontal wires

1  Click Schematic tab ➤ Insert Wires/Wire Numbers panel ➤ Insert Wires drop-down ➤ Wire.

2  Respond to the prompts as follows:
   Specify wire start or [wireType/X-show connections]:
   Select the top wire at line reference 403(1)
   Specify wire end or [V=start Vertical/H=start Horizontal/Continue]: Select the lower wire at line reference 404 (2)

   The color of temporary graphics changes for a new wire when AutoCAD Electrical can connect the wire to an existing wire.

   Each component wire connection point is displayed as a green x at the wire connection when you enter X + ENTER during wire insertion. If you pan or zoom, repeat the command to view the wire connection points.

3  Insert another wire to the right of the new wire.

4  Press ENTER to exit the command.

   The inserted wires resemble the following image.

Trimming Wires

After you insert wires, you can trim them. The Trim Wire tool removes wire segments. You can trim single or multiple wires.
Trim a wire

1. Click Schematic tab ➤ Edit Wires/Wire Numbers panel ➤ Trim Wire.

2. Respond to the prompts as follows:

_Fence/Crossing/Zext/<Select wire to TRIM>:_

_Specify the wire segment at line reference 404 between the two vertical wires (1), right-click_

Wire segments are trimmed back to a connecting dot, a component, or completely if neither is encountered along the segment. Any connection dots that are no longer needed are removed.

The trimmed wire resembles the following image.
Schematic Components

This chapter contains information about schematic components in AutoCAD® Electrical and inserting them into drawings.

About Schematic Components

An AutoCAD Electrical schematic component is an AutoCAD® block with certain expected attributes. When inserting components, use AutoCAD Electrical tools to break wires, assign unique component tags, cross reference related components, and enter values for catalog information, component descriptions, and location codes.

AutoCAD Electrical supplies a schematic symbol dialog box for finding and inserting schematic components. It also triggers some additional features.

■ Automatic wire breaks
■ Component tagging
■ Real-time cross-referencing
■ Component annotation

Inserting Components

AutoCAD Electrical employs a parent/child relationship for schematic components. A relay coil with a certain number of contacts is represented by the parent coil symbol and the child contact symbols. When the parent coil symbol is inserted, it is assigned a unique component tag. When the child contact symbols are inserted, the child is related to the parent and the parent tag is assigned to the child symbol.
In this exercise, you insert components on the wires previously defined in AEGS04.dwg.

**Insert a parent component**

1. **Zoom in on the upper left corner of the drawing.**
2. Click Schematic tab ➤ Insert Components panel ➤ Insert Components drop-down ➤ Icon Menu.
3. In the Insert Component: JIC Schematic Symbols dialog box, click Relays/Contacts.
4. In the JIC: Relays and Contacts dialog box, click Relay Coil.
5. Respond to the prompts as follows:

   **Specify insertion point:**

   *Position the component on the wire at line reference 403 near the neutral wire and click (1)*

   ![Diagram of wire with coils](image)

   The coil symbol breaks the underlying ladder wire and reconnects if you select directly on the wire or near to it. You did not select close enough to the wire if the underlying wire did not break. To try again, click Cancel on the Insert/Edit Component dialog box. Right-click or press ENTER to repeat the command. Turning on Snap helps (0.125 is a good setting to use).

   This tool inserts components into alignment with underlying wires, it does not align components side-to-side. If you want to insert components in neat columns, you have three options: use AutoCAD Snap when inserting components; use the Scoot command to move components and connected wires in place; or use the Align Component tool.

6. In the Insert/Edit Component dialog box, verify that the Component Tag is set to CR403.
AutoCAD Electrical automatically determines the unique tag name for the new relay based on the line reference location that you inserted the symbol on. “CR” indicates that it is a control relay and “403” indicates that the symbol is on line reference 403. If you inserted this symbol on line reference 404 then the tag name would be “CR404.”

You can assign a catalog number to the component that can be extracted into reports. There are two pieces of BOM catalog information: manufacturer code and catalog number. These values are carried as invisible attributes on the symbol. You can type in values for each or select the BOM information from an on-line catalog database file.

7 In the Catalog Data section, click Lookup.

There are three search criteria pull-down lists across the top of the Parts Catalog dialog box. You can easily change the search criteria to get a different set of valid catalog numbers. Each time you make a selection from one of these lists, the catalog selection is filtered.

8 In the Parts catalog dialog box, select the following search criteria:

   MANUFACTURER: AB
   TYPE: TYPE P

9 Change the catalog assignment to 700-P200A1.
10 Click Catalog Check.

11 In the Bill Of Material Check dialog box, review the BOM information associated with the selected part number.
   Click Close.

12 In the Parts catalog dialog box, click OK.
   The selected manufacturer code and catalog number display in the Insert/Edit Component dialog box. When you click OK on the dialog box, the values transfer to the symbol.

   **NOTE** Sample catalog information is provided with AutoCAD Electrical in Access Database format (.mdb). If your company uses its own internal coding system instead of manufacturer catalog numbers, substitute those numbers into catalog database files of AutoCAD Electrical. If you use your own system and reference a number of a vendor, extra user fields are available in all the sample database files.

13 In the Insert/Edit Component dialog box, Description section, specify:
Line 1:  MASTER CONTROL
Line 2:  RELAY

Up to three lines of description text can be entered as a description for components. If the third description line is unavailable, the symbol does not carry an attribute for a third line of description.

**NOTE**  You can specify a description by entering text or by clicking Defaults to select from a list of standard component descriptions.

14  In the Insert/Edit Component dialog box, Location code section, click Drawing.
AutoCAD Electrical does a quick read of the drawing file and returns a list of all location codes used so far.

15  In the All Locations - Drawing dialog box, select MCAB5 and click OK.

**NOTE**  You can also include an external “LOC” location list in the project “LOC” list to help with consistency. To use this feature, create a file called default.loc and put it in an AutoCAD Electrical search directory. The format for this text file is each location on its own line in the file with no leading spaces. You can also create a project-specific file by naming it the same as your project but with a .loc extension.

16  In the Insert/Edit Component dialog box, the pin values are inserted based on the selected catalog number:

Pins: 1:  K1
Pins: 2:  K2
In the Insert/Edit Component dialog box, click OK.
Any values entered here are saved as attribute values on the symbol itself.

Relocating Components

You might need to scoot the component if it was not inserted in the correct location. Use the Scoot tool to select a component or wire number and slide it back and forth along the wire while keeping everything connected. You can select a wire or a whole rung of circuitry and scoot it to a new position. If there are any parent components among the scooted items, you are asked if you want to retag the scooted components.

The Scoot tool works on wire numbers, components, terminals, PLC I/O modules, jogs in dashed link lines, signal arrows, wires, and wires with wire-crossing loops.
Scoot a component

1. Click Schematic tab ➤ Edit Components panel ➤ Modify Components drop-down ➤ Scoot.

2. Respond to the prompts as follows:
   - Select component, wire, or wire number for SCOOT: Select the component that was just inserted at line reference 403
   - The cursor changes to a box.
   - Select component, wire, or wire number for SCOOT: to Move the cursor to the right and click, right-click to exit the command
   - The component moves to its new location.

You can use the Scoot tool to grab a component or a wire number and slide it back and forth along a wire. You can grab a wire or a whole rung of circuitry and scoot it to a new position, while keeping everything connected.

The steps to insert a parent component and a child component are the same, except when you annotate the symbol.

Insert a child component

1. Click Schematic tab ➤ Insert Components panel ➤ Insert Components drop-down ➤ Icon Menu.
2 In the Insert Component: JIC Schematic Symbols dialog box, click Relays/Contacts.

3 In the JIC: Relays and Contacts dialog box, click Relay NO Contact.

4 Respond to the prompts as follows:
   Specify insertion point:
   
   *Position the cursor on the wire at line reference 404 near the hot wire and click (1)*

   The Insert/Edit Child Component dialog box displays. Notice that AutoCAD Electrical did not automatically assign a tag name for the relay contact; there is just a generic “CR” in the edit box. Determine the relay contact tag name. A relay contact is a child component that must link to a parent relay coil on a drawing in the active project. The child gets the same tag name that is found on the parent relay coil.

   Assign the tag name by clicking Parent/Sibling and picking the parent in the drawing. Or, click Drawing or Project to select from a list of components with the same family name.

5 In the Insert/Edit Child Component dialog box, Component Tag section, click Drawing.

6 In the Active Drawing list for FAMILY=“CR” dialog box, select: MCAB5 CR403 MASTER CONTROL RELAY
7 Click OK. The values of the parent are immediately transferred to the contact.

8 In the Insert/Edit Child Component dialog box, verify that the following options are specified:
   
   - **Component Tag:** CR403
   - **Description:** Line 1: MASTER CONTROL
   - **Description:** Line 2: RELAY
   - **Cross-reference:** 403
   - **Location code:** MCAB5
   - **Pins:** Pin 1: A1X
   - **Pins:** Pin 2: A1Y
In the Insert/Edit Child Component dialog box, click OK. The child component is inserted. It is cross-referenced in real time. The coil is annotated with the line reference number of the new child contact and the child contact gets annotated with the line reference location of the parent coil.

Aligning Components

Align the normally open relay contact with an existing component. After you insert a component, you can align or edit it as necessary.

Align a component

1. Click Schematic tab ➤ Edit Components panel ➤ Modify Components drop-down ➤ Align.
2 Respond to the prompts as follows:

Pick component to align with (Horizontal/<Vertical>):

Select the normally open limit switch component near the hot wire at line reference 406 (1)

A dashed line is displayed.

Select objects:

Select the previously inserted child contact component near the hot wire at line reference 404 (2), right-click

The aligned component is placed.

Inserting Components

Now you insert a system reset push button, pilot light, and an emergency stop push button to make up the circuit.

Insert a system reset button

1 Click Schematic tab ➤ Insert Components panel ➤ Insert Components drop-down ➤ Icon Menu.

2 In the Insert Component: JIC Schematic Symbols dialog box, click Push Buttons.

3 In the JIC: Push Buttons dialog box, click Push Button NO.

4 Respond to the prompts as follows:

Specify insertion point:
Position the push button on the wire at line reference 403 near the hot wire and click (1)

5 In the Insert/Edit Component dialog box, verify the following:
   Component Tag: PB403
   AutoCAD Electrical automatically assigned the tag name based on the line reference.

6 In the Descriptions section, specify:
   Line 1: SYSTEM
   Line 2: RESET

7 In the Location code section, click Drawing.

8 In the All Locations - Drawing dialog box, select OPSTA3 and click OK.

9 In the Insert/Edit Component dialog box, click OK.

Insert a pilot light

1 Click Schematic tab ➤ Insert Components panel ➤ Insert Components drop-down ➤ Icon Menu.

2 In the Insert Component: JIC Schematic Symbols dialog box, click Pilot Lights.

3 In the JIC: Pilot Lights dialog box, click Green Press to Test.

4 Respond to the prompts as follows:
   Specify insertion point:
Position the pilot light on the wire at line reference 404 near the neutral wire and click (2).

**TIP** Having Snap turned on makes positioning the pilot light easier.

5. In the Insert/Edit Component dialog box, verify:
   - Component Tag: LT404

6. In the Descriptions section, specify:
   - Line 1: CONVEYOR
   - Line 2: ON

7. In the Location code section, click Drawing.

8. In the All Locations - Drawing dialog box, select OPSTA3 and click OK.

9. In the Insert/Edit Component dialog box, click OK.

**Insert a push button for emergency stop**

1. Click Schematic tab ➔ Insert Components panel ➔ Insert Components drop-down ➔ Icon Menu.

2. In the Insert Component: JIC Schematic Symbols dialog box, click Push Buttons.

3. In the JIC: Push Buttons dialog box, click Mushroom Head NC.

4. Respond to the prompts as follows:
   - Specify insertion point:
Position the push button on the middle of the wire at line reference 403 and click (3)

5 In the Insert/Edit Component dialog box, verify:
   Component Tag: PB403A
   AutoCAD Electrical automatically assigned the tag name based on the line reference. It added the “A” suffix since it is your second push button on this line reference.

6 In the Descriptions section, specify:
   Line 1: EMERGENCY STOP

7 In the Location code section, click Drawing.

8 In the All Locations - Drawing dialog box, select OPSTA3 and click OK.

9 In the Insert/Edit Component dialog box, click OK.
   Your finished schematic should resemble the following:

Editing Components

You can go back to a component at any time and make changes. You can change description, tag, catalog number, location code, terminal numbers, and rating values using the Edit Component tool.

Insert a child contact

1 Zoom in on the blank ladder rung at line reference 410.
2 Press F9 to turn on SNAP.
3 Click Schematic tab ➤ Insert Components panel ➤ Insert Components drop-down ➤ Icon Menu.

4 In the Insert Component: JIC Schematic Symbols dialog box, click Selector Switches.

5 In the JIC: Selector Switches dialog box, click 2nd+ NC Contact.

6 Respond to the prompts as follows:
   Specify insertion point:
   Position the selector switch at line reference 410 near the left side of the ladder and click (1)

7 In the Insert/Edit Child Component dialog box, click OK.

Insert a pilot light

1 Click Schematic tab ➤ Insert Components panel ➤ Insert Components drop-down ➤ Icon Menu.

2 In the Insert Component: JIC Schematic Symbols dialog box, click Pilot Lights.

3 In the JIC: Pilot Lights dialog box, click Blue Press to Test.

4 Respond to the prompts as follows:
Specify insertion point:

*Position the pilot light at line reference 410 near the neutral wire but exactly in line with the selector switch and click (2)*

5 In the Insert/Edit Component dialog box, verify:
   Component Tag: LT410

6 In the Descriptions section, specify:
   Line 1: MAINT
   Line 2: MODE

7 In the Insert/Edit Component dialog box, click OK.

**Edit a child contact**

1 Press F9 to turn off SNAP.

2 Click Schematic tab ➤ Edit Components panel ➤ Edit Components drop-down ➤ Edit.

*NOTE You can also right-click on a component and select Edit Component from the context menu.*

3 Respond to the prompts as follows:
   Select component/cable/location box to EDIT:
   *Select the selector switch on line reference 410*

4 In the Insert/Edit Child Component dialog box, Component Tag section, click Parent/Sibling.
5 Respond to the prompts as follows:

Select component:

*Select the bottom sibling contact (3) of the existing switch on line reference 408*

AutoCAD Electrical reads the sibling contact and transfers the appropriate annotation to your new switch contact.
6 In the Insert/Edit Child Component dialog box, click OK. The sibling contact information is displayed on the drawing.

**Linking Components**

In this exercise, you link the selector switch you inserted to the existing RAM MODE selector switch residing on line reference 406 through 408 using dashed link lines.

**Connect components using wires**

1. Click Schematic tab ➤ Insert Wires/Wire Numbers panel ➤ Insert Wires drop-down ➤ Wire.
2 Respond to the prompts as follows:
Specify wire start or [wireType/X=show connections]:

*Click the wire connection point on the right-hand side of the switch contact (4)*
Specify wire end or [Continue]:

*Drag the wire to the right and click the wire connection point on the left-hand side of the blue pilot light (5)*

```plaintext
410
  410
  410
```

Specify wire start or [Scout/wireType/X=show connections]:

*Click the left-hand side of the switch contact*
Specify wire end or [Continue]:

*Drag the wire to the left and click the left-hand vertical bus wire*

The wire automatically ends on the bus and inserts a wire connection dot.

3 Repeat the process to connect the right-hand side of the blue pilot light to the vertical bus wire.

4 Right-click and select Enter to finish creating the wire connections.

```plaintext
410
  410
  410
```

If you lay a wire over the top of a series of components, AutoCAD Electrical automatically breaks and reconnects to the underlying wire connection points.

**Link components**

1 Click Schematic tab ➤ Insert Components panel ➤ Dashed Link Line drop-down ➤ Link Components with Dashed Line.

2 Respond to the prompts as follows:

*Component to link from:*

*Click the contact of the switch on line reference 408 (6)*
Click anywhere on your new switch contact (7), right-click

The annotation of the contact is changed to invisible and a dashed link line is drawn from the bottom of the upper contact to the top of your new contact.

Your finished schematic should resemble the following:

NOTE The Scoot command is fully compatible with dashed line links. Scooting one contact left or right causes both links to update automatically. You can even scoot the horizontal “jog” in the dashed link line up or down.

Editing Catalog Information

Sample catalog information is supplied with AutoCAD Electrical. The information is held in tables in an Access Database file (.mdb) that is populated with sample vendor data.

You can use filter criteria in the catalog lookup to display catalog numbers selectively for a component type.

Filter catalog data

1. Right-click LT410 and select Edit Component.

2. In the Insert/Edit Component dialog box, Catalog Data section, click Lookup.
3 In the Parts Catalog dialog box, select:
   Manufacturer: AB
   Type: 30.5mm
   Voltage: 120VAC XFMR

4 Change the catalog assignment to 800T-PT16E.

Add a catalog entry

1 In the Parts Catalog dialog box, click Add.
The entries are prefilled with the information for the currently assigned catalog part number. It is easy to add a new entry with similar information.

2 In the Add Catalog Record dialog box, specify:
   
   Catalog: BOG-123B
   
   Manufacturer: BOGUS
   
   The catalog lookup works most efficiently when field values that are meant to be the same are the same in both spelling and capitalization. The list box beside each field helps you maintain consistency as you add new catalog items.

3 Click List next to the Description field.
   
   AutoCAD Electrical does a quick scan of the existing catalog file. It collects and displays a list of all the different description field values found in the catalog.

4 In the Field Description existing values dialog box, select BLUE PILOT LIGHT - PRESS TO TEST, NEMA 4/13 and click OK.
In the Add Catalog Record dialog box, click List next to the Type, Voltage and Miscellaneous fields. Select the values shown in the following image if not already selected.

AutoCAD Electrical provides three blank user fields for your own internal use. Each can be a maximum of 24 characters wide and are extracted into BOM reports along with all the other fields.

**NOTE** You can add catalog entries with a subassembly. To link a subassembly with the main, the catalog part numbers share the same codes. In the Edit Catalog Record dialog box, select As main->sub, enter the ASSYCODE, and click OK. The ASSYCODE must be unique since it links the main catalog item with subassembly items. To add the subassembly item, in the Add Catalog Record dialog box, create a catalog entry, select As sub, enter an ASSEMBLYLIST code, and click OK.

In the Add Catalog Record dialog box, click OK.

As the new entry is being added to the file, the Part Catalog dialog box displays.
7 In the Parts Catalog dialog box, select the BOG-123B catalog entry and click OK.

8 In the Insert/Edit Component dialog box, click OK.

Moving Between Symbols

Use the AutoCAD Electrical Surf utility to move from component reference to reference across the project drawing set quickly.

1 Zoom on the upper left-hand portion of the first ladder column.

2 Click Projects tab ➤ Other Tools panel ➤ Surfer drop-down ➤ Surfer.

3 Click anywhere on relay coil CR407.
All instances of CR407 appear in the Surf dialog box.

4 Select the reference on sheet 6.
5 Click Go To.

The instance of CR407 on sheet 6 is surfed to and displayed in the drawing next to the Surf dialog box.
6 Select the reference on sheet 9.
7 Click Go To.
   You can edit or delete the component using options in the Surf dialog box.
8 Double-click the first entry in the Surf dialog box to return to the original AEGS04.dwg drawing.
9 Click Close.

**NOTE** Drawing files are saved while surfing if AutoCAD Electrical senses that a change has been made to the drawing.

### Swapping Components

Use the Swap Block tool to swap one component for another (such as swapping a proximity switch with a limit switch) in a single drawing or project-wide.

**Swap switches while keeping wire connections**

1 Zoom in on the limit switch on line reference 406.
2 Click Schematic tab ➤ Edit Components panel ➤ Swap/Update Block.

3 In the Swap Block/ Update Block/ Library Swap dialog box, specify:
   - Option A: Swap a Block - drawing wide
   - Pick new block from icon menu
   - Retain old block scale
   - Auto re tag if parent swap causes FAMILY change
   - Attribute Mapping: Use Same Attribute Names (default)
   - Click OK.

4 In the Insert Component: JIC Schematic Symbols dialog box, click Miscellaneous Switches.

5 In the JIC: Other Switch Types dialog box, click Proximity Switch NO.

6 Respond to the prompts as follows:
   - Select component type to swap out: Select the limit switch, LS406
   - The limit switch symbol disappears and the proximity switch symbol inserts. All existing text annotation transfers to the new symbols and the wires reconnect.
Creating Custom Symbols

You can use the Symbol Builder to create an AutoCAD Electrical symbol easily. This utility builds a smart schematic symbol by either adding AutoCAD Electrical attributes to the geometry of the symbol, or by converting text entities to AutoCAD Electrical attributes. You can also use AutoCAD attribute definition and editing commands to do the same thing. This tool makes the task easier because you quickly pick and place attributes. It tracks what attributes are present and checks your work to make sure that any required attributes are not omitted.

NOTE If you exit out of the Symbol Builder, restart it. On the Select Symbol/Objects dialog box, click Select objects and select any graphics and attributes you added so far. You can then start from where you left off.

Create a parent schematic symbol

1 Open AEGS03.dwg.
2 Draw a rectangle anywhere on the drawing.

TIP It is easiest to draw it in the white space on the left-hand side of the drawing.
3 Click Schematic tab ➤ Other Tools panel ➤ Symbol Builder drop-down ➤ Symbol Builder.

4 In the Select Symbol/Objects dialog box, Attribute template section, browse to the Library path `C:\Documents and Settings\All Users\Documents\Autodesk\Acade {version}\jic125` (or `C:\Users\Public\Documents\Autodesk\Acade {version}\jic125` on a Windows Vista installation).

5 In the Attribute template section, select Symbol: Horizontal Parent, Type: Generic.

6 In the Select from drawing section, click Select objects, select the rectangle, and press ENTER.

7 Select OK.

Adding Attribute Symbols

In this example, you add the attributes: TAG1, DESC1, LOC, INST, FAMILY, MFG, CAT, and ASSYCODE. You are not limited to these attributes and you can include your own user-defined attributes on the AutoCAD Electrical block files.

**NOTE** The TAG1 attribute is the only one required for a parent schematic symbol. The other attributes in the Required section are expected on a parent schematic symbol, however the symbol is recognized as a parent symbol without them.

Add attributes

1 If the Symbol Builder Attribute Editor is not visible,
Click Symbol Builder tab ➤ Edit panel ➤ Palette Visibility Toggle.

Use this palette to assign attributes to the rectangle as well as set the height and justification for each attribute. The palette displays the AutoCAD Electrical attributes that you can insert and define as part of the symbol. Once an attribute is inserted on the symbol a check mark is displayed next to it and you cannot insert it again. AutoCAD Electrical allows only one insertion of each attribute.

2 In the Symbol Builder Attribute Editor, select TAG1 and click the Properties tool.

Enter:

**Value:** PS

It is the default code used as the %F value of the tag format (such as “CR”, “PB”, “LT”)

**Height:** 0.125
3 Click the Insert Attribute tool. Insert the attribute above the rectangle.
In the Symbol Builder Attribute Editor, notice the check mark next to the TAG1 attribute. Continue placing the rest of the attributes.

4 In the Symbol Builder Attribute Editor select DESC1.

Click the Insert Attribute tool.

5 Insert the attribute below TAG1.

6 Insert the LOC and INST attributes as indicated.

7 Insert the FAMILY attribute near the center of the rectangle.

8 With FAMILY still highlighted in the Symbol Builder Attribute Editor, select the Properties tool.
Enter:
Value: PS
Click OK.
Click OK.
This assigns the %F value to the FAMILY attribute inserted.
Adding Wire Connection Points

If a X?TERMxx of the component (for example, "X2TERM01") wire connection-point attribute lies within the small trap distance of the end of a wire, then AutoCAD Electrical interprets the component connected to the wire. The only time the trap distance changes is when you change the Feature Scale Multiplier in the Drawing (or Project) Properties ➔ Drawing Format dialog box.

NOTE Components with closely spaced wire connection points may not be processed properly if the connection points fall within the AutoCAD Electrical trap distance of one another.

A wire connection attribute can have a related terminal text attribute, TERMxx, and terminal description attribute, TERMDESCxx. The "xx" is a two-digit number (starting at 01) that is used to match up with the corresponding X?TERMxx wire connection attribute.

Insert connection points

1. In the Symbol Builder Attribute Editor, expand the Wire Connection section.
2. In the Direction / Style list, select Others.
3 On the Insert Wire Connection dialog box select Terminal Style: Screw. This terminal style inserts both the graphic to represent the screw and the wire connection points.

4 Check Use this configuration as default. It directs Symbol Builder to use the current Terminal Style and Scale as the default in the Symbol Builder Attribute Editor.

5 Select Connection direction: Left & Top. It determines the direction the wire attaches to the component.

6 Enter “L” as the value for TERM01 in Pin Information.

7 Select X2TERMDESC01 in Pin Information and click Delete.

8 Click Insert.

9 Select the Insert Wire Connection tool and insert the terminal in the upper left-hand corner as shown.

NOTE Always use AutoCAD Snap to insert the wire connection point.

10 Back on the Symbol Builder Attribute Editor, expand the Wire Connection Direction / Style list and select Right & Top / Screw.
11 Select the Insert Wire Connection tool and insert the terminal in the upper right-hand corner.

You can continue to insert wire connections until you press ENTER by entering the characters indicated in the command line prompt followed by a space. You can also select from the Direction / Style list.

12 Insert the rest of the terminals as follows:
   TERM03: Right
     Insertion Point: below TERM02
   TERM04: Bottom
     Insertion Point: in the lower right-hand corner
   TERM05: Bottom
     Insertion Point: to the left of TERM04
   TERM06: Bottom
     Insertion Point: to the left of TERM05
   TERM07: Bottom
     Insertion Point: to the left of TERM06

13 Press Enter if necessary to return to the command prompt.

14 On the Symbol Builder Attribute Editor, expand the Pins section. Enter the Pin values as follows:
   TERM02: N
   TERM03: GND
   TERM04: -
   TERM05: -
   TERM06: +
   TERM07: +
Your drawing should look like the following image:

![Pins Table]

**Saving Symbols**

You have two options for saving the symbol: WBlock or Block. WBlock creates the symbol `.dwg` file while Block creates the symbol for this drawing file only.

**Save and insert the symbol onto a drawing**

1. Click Symbol Builder tab ➤ Edit panel ➤ Done.
2. On the Close Block Editor: Save Symbol dialog box, in the Base point section, click Pick point. Select a point in-line with the top terminals so that it is easy to place on a wire later.
3. Select WBlock.
4. Enter a file name or accept the default.
5 Click OK.

6 When asked to insert the symbol, click Yes.

7 Place the symbol on the empty wire on the left-hand side of the drawing.

The wire breaks, the component tag inserts, and the wires connect to the symbol.

**NOTE** New symbols you create can also be inserted with the AutoCAD Electrical Insert Component command. You can add your new symbol to the icon menu. Or, you can select it from the Type it or Browse dialog box file selection options in the icon menu.

8 In the Insert/Edit Component dialog box, click OK.
Circuitry

This chapter provides information about working with collections of interconnected components, or circuits. Circuits can be simple or complex, single or multiple, and with or without interconnecting wiring. Reusing circuits can both speed up drawing creation and reduce errors.

Moving an Existing Circuit

When you move a circuit, most of the parent components contained in the circuit automatically retag since the drawing is set up for reference-based component tagging. In the process of moving the circuit, you change the reference locations of the moved components. Related child components update to match the new parent tags, including references on other drawings in the project.

NOTE Tagging updates vary depending on your default tagging configurations.

Move the location of a circuit

1. In the Project Manager, Project Drawing List, double-click AEGS02.dwg.
2. Zoom in on the lower left corner of the drawing. Make sure the 3-phase motor circuit at line reference 215 is visible.
This circuit has component tags:
- “FU215” on the 3-pole fuse
- “215CBL” on the multi-conductor cable
- “DS215” on the disconnect switch
- “MOT216” on the motor

3 Click Schematic tab ➤ Edit Components panel ➤ Circuit drop-down ➤ Move Circuit.

4 Respond to the prompts as follows:
   Select Objects:
   Window select the circuit on line reference 215 to capture the connection wire and dots that tie in to the vertical bus, right-click

Press F9 to turn on SNAP.
   Specify base point or displacement:
   Select a base point and then select a point on line reference 214

The circuitry is moved, the affected components are retagged, and cross-references are updated based on the new line reference. Each of the listed parent component tags decrement by one. For example, fuse FU215 became FU 214.

5 In the Update Related Components dialog box, click Yes-Update.
Related child references on the active drawing update to match the newly retagged parent components.

6 In the Update other drawings dialog box, click OK.
   Related child components and panel layout references on other drawings update to match the parent components on the moved circuit.

7 If asked to save the drawing, click OK.

8 Click Project tab ➤ Other Tools panel ➤ Surfer drop-down ➤ Surfer.

9 Select FU214 on the drawing.
   The Surf dialog box displays three references on sheet 2 and one reference on sheet 9.

10 Double-click the reference on Sheet 9.
   Surfer goes to the panel layout drawing and zooms in on the physical representation of this 3-pole fuse. Notice that the physical representation of the fuse block tag updated because the circuit was moved.

11 Double-click the first entry in the dialog box to return to the original AEGS02.dwg drawing.

12 Click Close.

Moving the motor circuit up one line reference spacing opened up a bit more room to add a new circuit below it. The next step is to extend the 3-phase bus down to line reference 218 and over to the right to begin building a new motor circuit.
Extending the 3-phase bus

1 Click Schematic tab ➤ Edit Wires/Wire Numbers panel ➤ Trim Wire.

2 Respond to the prompts as follows:
   Fence/Crossing/Zext/<Select wire to TRIM>:
   Click the bottom ends of the three dangling wires, right-click

You can insert vertical or horizontal 3-phase wiring. Three-phase wiring automatically breaks and reconnects to any underlying components that it finds in its path. If it crosses any existing wiring, wire-crossing gaps are inserted.

3 Click Schematic tab ➤ Insert Wires/Wire Numbers panel ➤ Multiple Bus.

4 In the Multiple Wire Bus dialog box, select:
   Horizontal Spacing: 0.5
   Vertical Spacing: 0.5
   Starting at: Another Bus (Multiple Wires)
   Number of Wires: 3
5 Click OK.

6 Respond to the prompts as follows:

Select existing wire to begin multi-phase bus connection:

Select the bottom corner of the left-most vertical bus on line reference 214 as shown

Select existing wire to begin multi-phase bus connection: to

Pull the cursor down to line reference 218.

Temporary graphics show the proposed routing of the extended bus.
7 Click to create the wires.
8 Right-click to exit the command.

The 3-phase bus and wire connection dot symbols are inserted on the drawing.

Creating a New Motor Circuit

You now construct a new motor circuit on the extended 3-phase bus.

Insert and configure the circuit

1 Click Schematic tab ➤ Insert Components panel ➤ Circuit Builder drop-down ➤ Circuit Builder.

2 The Circuit Selection dialog box displays.
3. Expand 3ph Motor Circuit.

4. Select **Horizontal - FVNR - non reversing**.

5. Change the Rung Spacing: Horizontal to **0.5**.

6. Select Configure.

7. Specify insertion point at rung 217.
**Circuit Configuration**

A circuit is made up of individual circuit elements and the wiring that connects them. Circuit Builder inserts a template drawing. This template contains the base wiring for the circuit and strategically positioned “marker blocks”.

The “marker blocks” control what circuit elements are presented in the Circuit Configuration dialog box. For example, a “marker block” indicates the need for a Disconnecting Means in the circuit. Various options for the Disconnecting Means are presented in the dialog box. The option selected for this circuit element is inserted at the location of the “marker block”. Circuit Builder dynamically builds the complete circuit based on the selections you make on this dialog box.

1. In the Circuit Elements section, select **Motor symbol**. In the Select section, select Motor: **3ph motor**, Ground/PE wire connection: **No**.

2. In the Circuit Elements section, select **Disconnecting Means**. In the Select section, select Main Disconnect: **Fuses**, Include N.O. auxiliary contact: **No**.
Setup & Annotation section: The options within this section change according to your selections in the Circuit Elements and Select sections.

Type in values or select the Browse button to access a lookup table. Select an entry from the lookup table to obtain values for the individual settings. The catalog lookup is opened if the circuit option is a component.

3 In the Circuit Elements section, select Control transformer and circuit - non-reversing.

In the Select section, select Include control circuit: None.
4 In the Circuit Elements section, select **Power Factor correction**.
In the Select section, select Include power factor correction capacitor: **None**.
5 In the Circuit Elements section, select **Overloads**.
In the Select section, select Overload elements: **Thermal**, Include N.O. auxiliary contact: **No**.
6 In the Circuit Elements section, select **Motor terminal connections**. In the Select section, select Motor connection terminals: **Round**.
In the Circuit Elements section, select **Cable marker**.

In the Select section, select Cable: **None**.
8 In the Circuit Elements section, select **Safety disconnect at the load**.
In the Select section, select Safety disconnect: **Disconnect switch**, Include N.O. auxiliary contact: **No**.
9 Select the Insert all circuit elements tool. Circuit Builder inserts each of the selected circuit elements.

10 Select Done.

NOTE See the Circuit Builder topics later in this section for more examples.

Multi-level terminals

1 In the Project Manager, Project Drawing List, double-click AEGS02.dwg.
2 Click Schematic tab ➤ Edit Components panel ➤ Edit Components drop-down ➤ Edit.

3 Select the round terminal on rung 217. The Insert/Edit Terminal Symbol dialog box displays, where you can annotate the terminal properties and associations.

4 In the Insert/Edit Terminal Symbol dialog box, Project List section, select Tag Strip TB.

5 Enter Location: MCAB5 and Number: 10.

6 Click Details >>.

7 In the Catalog Data section, click Catalog Lookup.

8 On the Parts Catalog dialog box, select:
   Manufacturer: SIEMENS
   Type: MULTI-LEVEL
   Rating: 20 AMPS

9 Select part 8WA1 011-3JF16 and click OK.
The Manufacturer and Catalog information for the selected part displays in the Catalog Data section of the Insert/Edit Terminal Symbol dialog box.

10 On the Insert/Edit Terminal Symbol dialog box, click OK.

11 Click Schematic tab ➤ Edit Components panel ➤ Edit Components drop-down ➤ Edit.

12 Select the middle terminal between rungs 217 and 218. The Insert/Edit Terminal Symbol dialog box displays.

13 In the Insert/Edit Terminal Symbol dialog box, Project List section, select Tag Strip TB.

14 Enter Location: MCAB5 and Number: 11.

Modify multi-level terminal associations

1 On the Insert/Edit Terminal Symbol dialog box, Modify Properties/Associations section, click Add/Modify.

2 On the Add/Modify Association dialog box, Select Association section, expand the active project node. The active node is bold in the list.
3 Select the terminal block node you inserted on line reference 217 (10, , (3)).

The terminal numbers defined on the block are listed, separated by commas. The number of levels defined in the block properties displays at the end of the node string in parenthesis. For example, 1,21,GND (3). If a level is not represented on the schematic, it is represented by empty space: 1, , GND (3). If a terminal has been assigned to the level, but the terminal does not have a number assignment, it is represented by ‘???’: 1,???,GND (3).

**NOTE** The grid to the right populates with the definition for the selected terminal: Level 1 has Label = TOP, Number = 10, Reference = 2,217.

4 Select Level 2 in the grid and click Associate.
Once you click Associate, the middle level updates with the terminal number in the grid in the Active Association section of the dialog box.

5 Click OK.

The level assignments display in the Properties/Associations section of the Insert/Edit Terminal Symbol dialog box. Notice that the terminal is three levels and levels 1 and 2 are now assigned.

6 On the Insert/Edit Terminal Symbol dialog box, click OK.
Click Schematic tab ➤ Edit Components panel ➤ Edit Components drop-down ➤ Edit.

Select the bottom terminal on rung 218. The Insert/Edit Terminal Symbol dialog box displays.

In the Insert/Edit Terminal Symbol dialog box, Project List section, select Tag Strip TB.

Enter Location: MCAB5 and Number: 12.

On the Insert/Edit Terminal Symbol dialog box, Modify Properties/Associations section, click Add/Modify.

On the Add/Modify Association dialog box, Select Association section, expand the active project node.

Select the terminal block node you inserted on line reference 217 (10,11, (3)). Notice that the node properties updated to reflect that levels 1 and 2 are assigned and that level 3 is still blank/available.

Select Level 3 in the grid and click Associate.

Once you click Associate, the bottom level updates with the terminal number in the grid in the Active Association section of the dialog box. You can rearrange the levels by selecting a level and clicking Move Up or Move Down.
15 Click OK.

The level assignments display in the Properties/Associations section of the Insert/Edit Terminal Symbol dialog box. Notice that levels 1, 2, and 3 are now assigned.

16 On the Insert/Edit Terminal Symbol dialog box, click OK.
Insert a ground

1. Click Schematic tab ➤ Insert Wires/Wire Numbers panel ➤ Wire.

2. Respond to the prompts as follows:
   Specify wire start or [wireType/ X-show connections]:
   Select a point on the motor symbol near its 5 o’clock position
   Specify wire end or [Continue]:
   Move the cursor down past the bottom pole, left-click, pull the wire to the left and down, then left-click to insert the wire, press ESC to exit the command

3. Click Schematic tab ➤ Insert Components panel ➤ Copy Component.

4. Respond to the prompts as follows:
   Select component to copy:
   Select the ground symbol from the circuit on line reference 214
   Specify insertion point: Select the end of the motor ground wire
Saving and Inserting Standard Circuits

AutoCAD® Electrical makes saving and inserting pre-drawn circuits easy and convenient. You can save and insert from a user circuits page on the Insert Component icon menu or you can use the normal AutoCAD® WBlock command to save selected circuitry to disk and an Insert Circuit command to insert WBlocked circuits into the active drawing.

Save your circuit for use in the future

1. Zoom around the circuit so that it fills your screen.
2. Click Schematic tab ➤ Edit Components panel ➤ Circuit drop-down ➤ Save Circuit To Icon Menu.
3. On the Save Circuit to Icon Menu dialog box, click Add ➤ New circuit.
4. On the Create New Circuit dialog box, specify:
   - Name: Motor Circ - Fusible DS
   - Image file: Active and Create PNG from current screen image
   - File name: UserCirc1

5. Click OK.
6. Respond to the prompts as follows:
Base point:

Select the left-most wire connection point where the circuit ties into the left-hand vertical bus wire

Select objects:

Window around the circuit from left to right to capture all the components and wiring, but exclude the vertical bus, press ENTER

7 On the Save Circuit to Icon Menu dialog box, click OK.

The circuit is saved to your AutoCAD Electrical user folder and can be quickly accessed from the Insert Component icon menu or from the Insert Saved Circuit tool.

The new motor has a 3-pole motor contactor child reference but there is not a parent motor starter relay coil to operate it. The motor start coil circuit must be added on a control schematic in the project drawing set and linked back to the new motor circuit.

**Insert motor start coil circuit to control schematic**

1 Open AEGS04.dwg.

2 Zoom on the upper-right hand ladder column so the full circuit on line reference 422-423 is displayed.
3 Click Schematic tab ➤ Edit Components panel ➤ Circuit drop-down ➤ Save Circuit To Icon Menu.

4 On the Save Circuit to Icon Menu dialog box, click Add ➤ New circuit.

5 On the Create New Circuit dialog box, specify:
   Name: Motor starter circ
   Image file: Active and Create PNG from current screen image
   File name: UserCirc2
   Click OK.

6 Respond to the prompts as follows:
   Base point: Select the left-most wire connection point at line reference 422
   Select objects: Window around the circuit from left to right to capture all the components and wiring, but exclude the vertical bus, press ENTER

7 On the Save Circuit to Icon Menu dialog box, click OK.

Insert a circuit you saved for re-use

1 Pan to display the blank area between line references 426 - 432.
2 Click Schematic tab ➤ Insert Components panel ➤ Circuit drop-down ➤ Insert Saved Circuit.

3 In the JIC: Saved User Circuits dialog box, select the Motor starter circ button.

4 In the Circuit Scale dialog box, click OK.

5 Respond to the prompts as follows:
   Specify insertion point:
   Place the circuit insertion point on the vertical bus wire at line reference 427, left-click to insert the circuit.

The circuit inserts and updates. Tags automatically update to reflect the new line reference number, and parent/child relationships defined inside of the circuit update accordingly.

6 Right-click the M427 coil symbol and select Edit Component.

7 In the Insert/Edit Component dialog box, specify:
   Description Line 2: MOTOR NO. 2
   Click OK.

8 In the Update Related Components dialog box, click Yes-Update.

**Linking the parent coil to the child contactor**

1 Open AEGS02.dwg and zoom on the untagged 3-pole motor contact/overloads on line reference 217.

2 Right-click the “M” contact and select Edit Component.
   The Insert/Edit Child Component is displayed. Enter the exact parent coil tag into the Component Tag box to establish the link between the parent and the child contacts. Currently the Component Tag is M.
3 In the Insert/Edit Child Component dialog box, Component Tag section, click Project.

4 In the Complete Project list for Family="M" dialog box, select M427 HYDRAULIC MOTOR NO. 2 and click OK.

The tag M427 is now displayed in the Component Tag edit box. Notice that the description, cross-reference, and location code boxes have also updated.

5 In the Insert/Edit Child Component dialog box, click OK.

6 In the Update linked components dialog box, click OK.

The components are now linked. If you go back to drawing AEGS04.dwg and look at the motor starter coil, it shows references to these three child contacts (plus one seal contact around PB427).
Using the icon menu to add a motor

1. Reopen drawing AEGS04.dwg and zoom to the blank area at line references 430-431.

2. Repeat the steps for inserting the saved Motor starter circ circuit.

3. In the Circuit Scale dialog box, click OK.

4. Insert the circuit at line reference 430.

5. Right-click the M430 coil symbol, and select Edit Component.

6. In the Insert/Edit Component dialog box, specify:
   - Description Line 2: MOTOR NO. 3
   - Click OK.

7. In the Update related components dialog box, click Yes-Update.

8. Open drawing AEGS02.dwg and zoom to the blank area at line references 204-206.

9. Repeat the steps for inserting a saved circuit, but this time insert the Motor Circ - Fusible DS circuit.

10. In the Circuit Scale dialog box, click OK.

11. Respond to the prompts as follows:
   - Specify insertion point:
     - Position the motor circuit so that the insertion point lands on the left-hand vertical bus at line reference 204, left-click to insert the circuit.

12. Right-click the M child motor contact symbol, and select Edit Component.

13. In the Insert/Edit Child Component dialog box, Component Tag section, click Project.

Notice that the fuse, disconnect, and motor automatically retag based on their reference locations.
14 In the Complete Project list for Family="M" dialog box, select M430 HYDRAULIC MOTOR NO. 3 and click OK. The tag M430 is now displayed in the Component Tag edit box. Notice that the description, cross-reference, and location code boxes have also updated.

15 In the Insert/Edit Child Component dialog box, click OK.

16 In the Update linked components dialog box, click OK.

You can now renumber your terminals manually or project-wide.

**Renumber terminals**

1 Enter AETERMRENUN at the command prompt.

2 On the Project-wide Schematic Terminal Renumber dialog box, select:
   - Include Installation/Location in terminal strip Tag-ID match
   - Starting Terminal Number = 1

3 In the Tag-ID section, click Drawing.

4 On the Terminal Tag-ID List dialog box, select Tag-ID = TB and click OK.

5 On the Project-wide Schematic Terminal Renumber dialog box, click OK.

6 On the Select Drawings to Process dialog box, click Do All and click OK.

7 If asked to save the drawing, click OK.

You can modify an existing terminal to make it a multi-level terminal block and then associate terminals to the master terminal block.

**Modify terminal properties**

1 Right-click terminal 4 on line reference 211 and select Edit Component.

2 On the Insert/Edit Terminal Symbol dialog box, Catalog Data section, delete the Manufacturer and Catalog information.
3 In the Modify Properties/Associations section, click Block Properties.

4 On the Terminal Block Properties dialog box, specify:

   Levels: 3

   Level 1
   Level Description: Top
   Wires Per Connection: 2
   PinL: 1
   PinR: 2

   Level 2
   Level Description: Middle
   Wires Per Connection: 2
   PinL: 3
   PinR: 4

   Level 3
   Level Description: Bottom
   Wires Per Connection: 2
   PinL: 5
   PinR: 6

Click OK.
Notice on the Insert/Edit Terminal Symbol dialog box, Properties/Associations section that the block now has three levels. Terminal 4 is assigned to the top level of the block.

5 On the Insert/Edit Terminal Symbol dialog box, click OK.

6 On the Update other drawings dialog box, click OK.

7 If asked to save the drawing, click OK.

Associate terminals

1 Click Schematic tab ➤ Edit Components panel ➤ Associate Terminals.

2 Respond to the prompts as follows:
   Select "Master" terminal: Select terminal 4 on line reference 211
   Pick terminal: Select terminal 5
   Pick terminal: Select terminal 6, right-click
NOTE The command prompt area indicates that the terminal was added as level 02 or level 03 once you pick the terminal.

3 Right-click terminal 6 and select Edit Component.
On the Insert/Edit Terminal Symbol dialog box, Properties/Associations section, all three levels have been assigned. You can now move a terminal to another level using the Add/Modify Association dialog box.

4 On the Insert/Edit Terminal Symbol dialog box, Modify Properties/Associations section, click Add/Modify.

5 On the Add/Modify Association dialog box, Active Association section, highlight level 3 in the grid and click Move Up.
The grid updates to reflect the move. Notice that terminal 6 is now assigned to level 2.

6 Click OK.

7 On the Insert/Edit Terminal Symbol dialog box, click OK.

8 If asked to update related components, click Yes-Update.

Add wire tee markers to your circuits

1 Pan your view so the circuit on line reference 204 is visible.

2 Click Schematic tab ➤ Insert Wires/Wire Numbers panel ➤ Insert Dot, Tee Markers drop-down ➤ Insert Dot Tee Markers.

3 Respond to the prompts as follows:

Specify insertion point:

Select the connection points at the vertical 3-phase bus for each wire

4 Insert dot tee markers for the circuit on line reference 204.

5 Right-click to exit the command.

Inserting Saved Circuits Using WBlock

Another method for saving and inserting circuits is to use the AutoCAD WBlock command to save the circuit to disk. A separate Insert Circuit command is used to browse to a selected saved circuit and insert it into the active drawing. This method allows unlimited circuits to be constructed and saved to disk. They can be arranged into a set of shared subfolders for easy browsing and retrieval using the Insert Circuit command.
Saving a circuit using WBlock

1. Pan to display the 3-phase motor circuit at line references 207 - 209.
2. Enter `wblock` at the command line and press ENTER.
3. In the Write Block dialog box, click Pick point.
4. Respond to the prompts as follows:
   - Specify insertion base point:
   - *Select the intersection of the left vertical bus with the upper horizontal wire at line reference 207*
5. In the Write Block dialog box, click Select objects.
6. Respond to the prompts as follows:
   - *Select objects: Window from left to right around the full circuit, right-click*
7. In the Write Block dialog box, enter a name for the saved circuit. Take note of the location where the drawing file is being saved.
8. Click OK.

Inserting a WBlocked circuit

1. Click Schematic tab ➤ Insert Components panel ➤ Circuit drop-down ➤ Insert WBlocked Circuit.
In the Insert Wblocked Circuit dialog box, browse to the folder containing the circuit you saved.

3 Select the WBlocked motor circuit, and click Open.

4 In the Circuit Scale dialog box, select:
   Move all lines to wire layers
   Keep all source arrows
   Update circuit's text layers as required
   Click OK.

5 Respond to the prompts as follows:
   Specify insertion point: Select any blank spot on your drawing
   The parent component tags that are not set to Fixed automatically retag based on the insertion point. It is like the behavior when inserting a circuit using the icon menu method.

6 Delete the circuit.

Inserting a One-line Motor Circuit

In this exercise, you insert and configure a one-line motor control circuit using Circuit Builder.

1 Start a new blank drawing and save it as One-Line.dwg.

2 In Project Manager, right-click on the project name and select Add Active Drawing.

3 Using the Insert Wire tool, add a horizontal one-line bus.

Insert the one-line circuit

1 Click Schematic tab ➤ Insert Components panel ➤ Circuit Builder ➤ Circuit Builder.
   The Circuit Selection dialog box displays.

2 Expand One-line Motor Circuit.

3 Select Vertical - FVNR - non reversing.
Click Configure.

Specify an insertion point on the one-line bus.

The Circuit Configuration dialog box displays.

In the Circuit Elements section, select Motor Setup.
In the Setup & Annotations: Motor Setup section, select the Browse button.

The Motor Table Not Found dialog box displays. The sample project is set up to use the NEC standard. However, a MOTOR_NEC table is not supplied, only a default MOTOR table.

Select Use default table.

The Select Motor dialog box displays.

Select Type: Induction, Voltage (V): 480, and Frequency (HZ): 60.

Select the row that shows Load: 15, Units: HP, Phase: 3, Speed (RPM): 3600, FLA (A) 18.6.

**NOTE** The values used to populate this dialog box are defined in the MOTOR* tables in the electrical standards database file, ace_electrical_standards.mdb.

Click OK.
The values are entered in the Motor Setup section. A default wire size, based on the load for the motor, is selected and shown in the Wire Setup section.

12 In the Setup & Annotations: Wire Setup section, select the Browse button.
The Wire Size Lookup dialog box displays. The minimum wire size is preselected. The size is based on the load for the selected motor.

**NOTE** When Show all is on, wires where the %Ampacity value is greater than 100% and less than 300%, are shown in red.

The values in the Load section are populated with the values from the Motor Setup. The options available within this dialog box are defined in the electrical standards database file, *ace_electrical_standards.mdb*.

13 In the Wire section, select Wire standard: **AWG**, Type/method: **CU**, Insulation: **THWN / 75C**.

14 In the De-rating factors section, select the **Ambient temperature correction** option.
This option directs Circuit Builder to use a de-rating factor for an elevated ambient temperature. These values are defined in the electrical standards database file.

15 Select **36~40C** from the drop-down list.
The de-rating factor is extracted from the electrical standards database file and entered in the dialog box. The wire size grid is adjusted based on the new total de-rating factor. Based on this de-rating factor the minimum wire size can change.

16 Select the **Run distance** option.
This option directs Circuit Builder to consider the length of the wire run in the voltage drop calculation. Additional columns display in the wire selection grid showing Voltage drop, wire KW loss, and wire loss cost estimate.

17 Select **200** from the drop-down list.
Circuit Builder displays parallel energy loss calculations to allow you to make better green design decisions. For example, you can oversize the conductors for a motor to reduce conductor heating losses. It results in a higher initial cost, material, and installation labor, which is recovered.
many times over in reduced energy losses in the wiring during the life of
the motor.

18 Select a wire size in the grid based on the values shown.
19 Select a Grounding conductor size. The minimum size is preselected based
on the load of the motor.
20 Click OK.
21 Select Circuit Elements: Motor Symbol.

22 In the Setup & Annotations: Motor section, select the Browse
button.
The Parts catalog dialog box displays.
23 Select a catalog value and click OK.

**NOTE** Circuit Builder does not preselect the catalog based on the parameters
entered previously.

24 Continue selecting Circuit Elements:
Disconnecting means: **Disconnect switch and fuses**
Motor starter: **Yes**
Power factor correction: **No**
Overloads: **None**
Terminal strip or connector: **None**
Cable marker: **Yes**
Safety disconnect at the load: **None**

25 Click to insert all circuit elements.
26 Click Done.
27 Click Schematic tab ➤ Edit Components panel ➤ Edit Components drop-down ➤ Edit.

28 Select the motor symbol.

29 On the Insert/Edit Component dialog box, enter FIELD for the Location code and MY MOTOR for Description Line 1.

30 Save the drawing.

Inserting a Dual One-line Power Feed Circuit

In this part of the exercise, you insert a dual power feed circuit. A dual circuit has two distinct circuits running off the same bus-tap. Each circuit can be independently configured.
1. Click Schematic tab ➤ Insert Components panel ➤ Circuit Builder drop-down ➤ Circuit Builder.

2. The Circuit Selection dialog box displays.

3. Select **One-line Power Feed: Vertical - Dual feed**.

4. Click Configure.

5. Specify an insertion point on the one-line bus.

The Circuit Configuration dialog box displays. Notice that some circuit elements have a “(2)” prefix. These elements make up the second circuit in the dual circuit.

6. In the Circuit Elements section, select **Load Setup**.

7. In the Setup & Annotations: Load Setup section, select the Browse button.
   The Select Load dialog box displays.

Inserting a Dual One-line Power Feed Circuit | 99
Select Type: **Transformer**, Voltage (V): **480**, and Phase: **3**.

Select an entry from the grid and click OK.

Continue selecting Circuit Elements for the first circuit:
- **Load**: *Generic box*
- Disconnecting means: **None**
- Terminal strip or connector: **Square**
- Cable marker: **None**

In the Circuit Elements section, select **(2) Load Setup**.

In the Setup & Annotations: Load Setup section, select the Browse button.
The Select Load dialog box displays.

Select Type: **Transformer**, Voltage (V): **480**, and Phase: **3**.

Select an entry from the grid and click OK.

Continue selecting Circuit Elements for the second circuit:
- **Load**: *Source arrow*
- **(2) Disconnecting means**: **Disconnect switch and fuses**
- **(2) Terminal strip or connector**: **None**
- **(2) Cable marker**: **None**

Click to insert all circuit elements.

Click Done.
18 Save the drawing.

**Referencing an Existing Circuit**

When a new circuit is inserted, you can reference an existing circuit picked from a list of circuits pulled from the active project. The components, values, descriptions, and tag assignments from the selected circuit, become defaults for the new circuit. Tags are recalculated if the option “Retag new components” is selected.

In this exercise, you insert a 3-phase motor control circuit referencing the one-line motor control circuit inserted earlier.

1 Start a new blank drawing and save it as *Three-Line.dwg*.

2 In Project Manager, right-click on the project name and select Add Active Drawing.
3 Click Yes to apply the project default values to the drawing settings.

4 Click Schematic tab ➤ Insert Wires/Wire Numbers panel ➤ Insert Ladder drop-down ➤ Insert Ladder.

5 Insert a 3-phase ladder.

6 Click Schematic tab ➤ Insert Components panel ➤ Circuit Builder drop-down ➤ Circuit Builder.

7 The Circuit Selection dialog box displays.

8 Select 3ph Motor Circuit: Horizontal - FVNR - non reversing.

9 Select Reference Existing Circuit.

10 Select the List button.

The Existing Circuits dialog box displays.

11 Select the one-line motor control circuit inserted on One-Line.dwg, MOT1.

12 Click OK.

The default circuit element options are controlled by both the CODE value and the UI_VAL from the circuit codes sheet of the circuit builder spreadsheet. For example, the one-line circuit used the Disconnect switch and fuses option with a UI_VAL of “4”. When the 3-phase circuit references this one-line circuit, the disconnecting means option with a UI_VAL of “4” becomes the default. If a matching UI_VAL is not found for a particular marker block CODE value, the default as defined by the “X” in the UI_DEF column is used.

When the new circuit is built, component values from the referenced circuit are applied to components in the new circuit only if the marker block code matches.

13 Turn off the Retag new components check box.
It directs Circuit Builder to use the tags from the one-line circuit for the components with matching marker block code values.

14 Select Configure.

15 Select an insertion point on the bus for the new circuit.

16 Verify that the same circuit elements as the referenced one-line motor circuit are selected. The default options are based on the referenced circuit.

Circuit Elements | Select
--- | ---
Motor symbol | Motor: 3ph motor
Ground/PE wire connection: No

Disconnecting means | Main Disconnect: Disconnect switch and Fuses
Include N.O. Auxiliary contact: No

Control transformer and circuit - non-reversing | Include control circuit: None
The circuit is inserted and the component values from the one-line circuit are applied. The motor symbol receives the same catalog value and horsepower rating. The main disconnect switch receives the same rating values for the switch and the fuses. The motor symbol receives the values modified on the one-line circuit after it was inserted.
Programmable Logic Controller (PLC) modules are built dynamically when selected from the menu. From a small set of library symbols, hundreds of PLC modules can be built on request. This method allows the module to conform to the underlying ladder rung spacing, so you can add spacers and break the module at insertion time.

Inserting Ladders into Drawings

You can insert a ladder into a drawing at any time. A drawing can have multiple ladders, as well as single-phase and three-phase ladders. The ladders can have different parameters, such as rung spacing, number of rungs, and ladder width.

Insert a single-phase ladder

1. Open AEGS05.dwg.
2. Click Schematic tab ➤ Insert Wires/Wire Numbers panel ➤ Insert Ladder drop-down ➤ Insert Ladder.
3. In the Insert Ladder dialog box, specify:
   - Width: 9.000
   - Spacing: 1.0000
   - 1st Reference: 519
   - Index: 1
   - Rungs: 18
   - Phase: 1 Phase
   - Draw Rungs: Yes
Skip: 0
You do not need to specify the Length since it is automatically calculated once the first Reference, Index, and Rungs are specified.

NOTE Reference 519 represents Page 5, Reference 19.

4 Click OK.

5 Respond to the prompts as follows:
   Specify start position of first rung or [wireType]:
   Enter 16, 21 press ENTER

NOTE You can also specify the start position of the first rung by left-clicking a location on the drawing with your mouse.

A single phase ladder is inserted in the drawing.
Inserting PLC Modules

AutoCAD Electrical generates any of hundreds of different PLC I/O modules on demand, in various different graphical styles, all without a single, complete I/O module library symbol resident on the system. Modules adapt to the underlying ladder rung spacing, whatever that value might be. They can be stretched or broken into two or more pieces at insertion time.

To insert a PLC module, you select the module and pick a location. AutoCAD Electrical builds and inserts the module, using a small set of library symbols.

Insert a PLC module

1. Click Schematic tab ➤ Insert Components panel ➤ Insert PLC drop-down ➤ Insert PLC (Parametric).

2. In the PLC Parametric Selection dialog box, select:
   - Manufacturer: Allen-Bradley
   - Series: 1746
   - Type: Discrete Input
   - Part Number: 1746-IA16
   - Graphics Style: 2, Vertical Module
3  Click OK.

4  Respond to the prompts as follows:

   Specify PLC module insertion point or [Z=zoom, P=pan]:

   Pick a point on wire line reference S20 closer to the right side, ensure the X is near the horizontal wire, click
5 In the Module Layout dialog box, verify the default settings:
   Spacing: 1.0000
   I/O Points: Insert all
   Click OK.
   AutoCAD Electrical reads the vertical rung spacing of your ladder and calculates how long the module is going to be. It multiplies the rung spacing by the number of wire connections specified by the module you selected.
   Temporary graphics display a representation of the module (with the spacing defined) to help position the module on the ladder.

6 In the I/O Point dialog box, specify:
   Rack Number: 1
   Slot Number: 1

   **NOTE** Specify the values by either entering text into the edit boxes or by clicking the arrows.

7 Click OK.
8 In the I/O Address dialog box, specify:

Beginning address: I:11/00

**NOTE** You can also select the beginning address from the Quick picks list.

9 Click OK.

10 In the I/O Addressing dialog box, click Decimal.

The PLC module is inserted into your drawing with incremental address numbers already annotated as the module goes in, it breaks and reconnects to underlying wires.

You can break an I/O module into as many pieces as you want at insertion time. It is great for high-density modules that do not fit into a single ladder column. Use the Allow spacers/breakers option in the Module Layout dialog box at insertion time to do it.

You can also add extra space between adjacent I/O points using the Stretch Block tool. This feature leaves extra room when you know ahead of time that a certain I/O point will have additional components wired tied to a single I/O point after a PLC module is inserted.

**NOTE** It can be used on any block, not just a PLC module.
Remove ladder rungs

1. Click Schematic tab ➤ Edit Wires/Wire Numbers panel ➤ Trim Wire.

2. Respond to the prompts as follows:
   Fence/Crossing/Zext/<Select wire to TRIM>:
   Select the ladder rung at line reference 519, right-click
   The ladder rung is removed from your drawing.

Using Multiple Insert Component

You can insert components into wires that are tied to the PLC module. Use the Multiple Insert Component tool to insert a string of normally open limit switches.

Insert a limit switch

1. Click Schematic tab ➤ Insert Components panel ➤ Multiple Insert drop-down ➤ Multiple Insert (Icon Menu).

2. In the Insert Component: JIC Schematic Symbols dialog box, click Limit Switches.

3. In the JIC: Limit Switches dialog box, select Limit Switch, NO.
4 Respond to the prompts as follows:

Component Fence, From Point:

Select above the wire at line reference 520 (1)

Component Fence, From Point: to:

Drag below the wire at line reference 522, click the point (2), right-click

5 In the Keep dialog box, select:

Keep this one
Show edit dialog box after each
Click OK

6 In the Insert/Edit Component dialog box, specify:

Component Tag: LS520
Description: Line 1: PALLET ENTERING
Description: Line 2: STATION
Location code: MACHINE
Click OK.

NOTE In the Insert/Edit Component dialog box, Component Tag section, you can use the Use PLC Address button to add the I/O Address as the component tag.

7 In the Keep dialog box, select:

Keep this one
Show edit dialog box after each
Click OK

8 In the Insert/Edit Component dialog box, specify:

Component Tag: LS521
Description: Line 1: PALLET INSIDE
9 In the Keep dialog box, select:
   Keep this one
   Show edit dialog box after each
   Click OK

10 In the Insert/Edit Component dialog box, specify:
   Component Tag: LS522
   Description: Line 1: PALLET LEAVING
   Description: Line 2: STATION
   Location code: MACHINE
   Click OK.

The normally open limit switches are inserted into the drawing.

Insert terminals

1 Click Schematic tab ➤ Insert Components panel ➤ Multiple Insert drop-down ➤ Multiple Insert (Icon Menu).

2 In the Insert Component: JIC Schematic Symbols dialog box, click Terminals/Connectors.
3 In the JIC: Terminals and Connectors dialog box, click Round with Terminal Number.

4 Respond to the prompts as follows:
   Component Fence, From Point: Select above wire at line reference 520 (1)
   Component Fence, From Point: to: Select below wire at line reference 535 (2), left click to end command, right-click to add terminal

5 In the Keep dialog box, select Keep this one. Click OK.

6 In the Insert/Edit Terminal Symbol dialog box, Terminal section, specify:
   Location: MCAB5
   Tag Strip: TS1
   Number: 1
7 Click OK.

8 In the Keep dialog box, select:
   Keep all, don’t ask
   Clear Show edit dialog box after each
   Click OK
   The terminals are automatically added to your drawing.
Annotating PLC I/O Descriptions

You can add description text to a PLC module using the Edit Component tool. You can change the descriptions at any time. However, edit each split PLC piece separately.

Add description text

1. Click Schematic tab ➤ Edit Components panel ➤ Edit Components drop-down ➤ Edit.

2. Respond to the prompts as follows:

Select component/cable/location box to EDIT:

Select anywhere on the top portion of the PLC module
The Edit PLC Module dialog box displays.

This dialog box provides spaces for you to enter description text for each I/O point. Assume that the descriptions already assigned to the connected limit switches are like what you want to use for the PLC I/O point descriptions.

3 In the Edit PLC Module dialog box, click Wired Devices. AutoCAD Electrical immediately follows each I/O point’s connected wire backwards. If it finds a connected component, the component description text is retrieved. Each description is displayed in a dialog box list.

4 For the first I/O address (I:11/00), select the first description (PALLET ENTERING STATION) in the extracted device list. The Confirmation dialog box displays.
5 Make sure that the correct description is specified and click OK.
6 Click Next to highlight I/O address 1:11/01 in the Addressing list. The corresponding device description highlights automatically.
7 Select the highlighted description, PALLET INSIDE STATION, and click OK.
8 Repeat this process for the remaining I/O point.

**NOTE** Alternately you can use Pick to capture existing description text from a connected device. To do so, in the Edit PLC Module dialog box, click Pick, and then select the component whose text you want to copy. AutoCAD Electrical reads the existing DESC text values on the component and transfers a copy to the DESC boxes in the Edit PLC Module dialog box.

9 In the Edit PLC Module dialog box, click OK. Your descriptions appear on the module.

**NOTE** If your PLC description is not where you want it, use the Scoot tool to scoot the description to a new location.

### Inserting I/O Based Wire Numbers

You can insert wire numbers based on the I/O address that each PLC connected wire touches. The wire numbers insert with your specified format as fixed wire numbers, so they do not change if a wire number retag is run later on.
NOTE If you want PLC I/O based wire numbering to be the automatic default for a drawing, set it up in the Drawing Properties dialog box. Select the Search for PLC I/O address on insert toggle.

Insert PLC I/O wire numbers

1. Open AEGS05.dwg.
2. Click Schematic tab ➤ Insert Wires/Wire Numbers panel ➤ Insert Wire Numbers drop-down ➤ PLC I/O.

The PLC I/O Wire Numbers dialog box displays.

The default format is %N, the address number. The wire number is the same as its connected I/O address number.

3. Click I:%n to change the wire number format.
   It adds an ‘I’ prefix to each wire number that ties to the input module.
4. Click OK.
5. Respond to the prompts as follows:
   Select I/O module to process: Select anywhere on the PLC module
   Select objects: Select all the connected wires to process, right-click
The wire numbers are inserted with the specified format. If some of the I/O points short-circuit to other I/O points, the last point wire number prevails for that common wire network.
Resequencing Ladders

AutoCAD Electrical drawings can be easily renumbered and retagged with a minimum of manual clean-up. You can resequence line reference numbers, component tags, and wire numbers. It is useful when a drawing has been copied from a previous project and the line reference numbers and tagging format of the drawing do not conform to the project requirements.

Resequence ladder line reference numbers

1  Click Schematic tab ➤ Edit Wires/Wire Numbers panel ➤ Modify Ladder drop-down ➤ Revise Ladder. The Modify Line Reference Numbers dialog box displays a list of ladders in the drawing.

2  Change the beginning line reference numbers for each ladder. Change the first ladder to 101 (column 1, line 01) and the second ladder to 201 (column 2, line 01).

3  Click OK.

The reference numbers update along each ladder.
Wire Numbers

This chapter provides information about working with wire numbers in drawings and across projects.

About Wire Numbers

Wire numbers can be assigned to any existing wires on an individual selection, an entire drawing, selected drawings in a project, or an entire project.

AutoCAD® Electrical assigns a unique wire number to each wire network. A wire network consists of one or more wires that are electrically connected.

Attaching Source Signal Arrows

AutoCAD Electrical uses a named source/destination concept. You identify a wire network to be the source, insert a source arrow on that network, and assigning a source code name to it. On the wire network that is to be a continuation of the same wire number (whether on the same drawing or a different drawing in the project), insert a destination arrow. Give it the same code name that you gave to its source. AutoCAD Electrical reprocesses your drawing set for wire numbering update, It matches source code names with destination names and copies source wire numbers over to the destination wire networks.

You can attach a source signal to a wire segment of a wire network. It enables the wire number assigned to the network to jump and continue to another network on the current drawing or on one or more drawings in the project. The source and destination are also helpful with the Wire From/To reports and connection information.
Attach a source signal arrow

1. Open AEGS03.dwg.

2. Click Schematic tab ➤ Insert Wires/Wire Numbers panel ➤ Signal Arrows drop-down ➤ Source Arrow.

3. Respond to the prompts as follows:
   
   Select wire end for Source:

   Select the end of the hot wire on the schematic on the right side of the drawing at line reference 332 (1)

4. In the Signal - Source Code dialog box, specify:
   
   Code: 24 VDC

   Signal Arrow Style: 1
AutoCAD Electrical allows one description line on a source arrow. This description can then be carried over to the associated destination arrow. You can define some default description lines to make them easier to enter without typing them in each time. AutoCAD Electrical looks for a file called `WDSRCDST.WDD`. This file is a simple text file with each line being read as a separate description. If this file exists, the Defaults button is available on the Signal - Source Code and Insert Destination Code dialog boxes.

5 Click OK.

6 In the Source/Destination Signal Arrows dialog box, click No.

**NOTE** Click No to insert the signal arrows on the next drawing. Click OK to insert the signal arrows on the current drawing.

7 To access `AEGS04.dwg`

   Click Project tab ➤ Other Tools panel ➤ Next DWG.
   Now you are ready to insert a destination signal arrow.

**Attaching Destination Signal Arrows**

After the source signal arrow is attached to a wire in the drawing, you can attach a destination signal to a wire segment of a wire network. It enables the wire number assigned to another source wire network to carry over to the current network automatically.
Attach a destination signal

1. Click Schematic tab ➤ Insert Wires/Wire Numbers panel ➤ Signal Arrows drop-down ➤ Destination Arrow.

2. Respond to the prompts as follows:
   Select wire end for Destination:
   Select the top of the hot wire on the schematic on the left side of the drawing at line reference 402 (2)

3. In the Insert Destination Code dialog box, click Project.

4. In the Signal codes -- Project-wide Source dialog box, select the following:
5 Click OK.

6 In the Insert Destination Code dialog box, verify:
   
   **Code:** 24 VDC
   
   **Signal Arrow Style:** 1
   
   Click OK + Update Source.
   
   The cross-references for your signal insert into the drawing above the hot wire.

   ![Diagram](image)

   **Attach source and destination signals to the neutral wires.**

   1 To return to *AEG03.dwg*

   Click Project tab ➤ Other Tools panel ➤ Previous DWG.
2 Click Schematic tab ➤ Insert Wires/Wire Numbers panel ➤ Signal Arrows drop-down ➤ Source Arrow.

3 Respond to the prompts as follows:

Select wire end for Source:

Select the bottom of the neutral wire at line reference 332 (3)

4 In the Signal - Source Code dialog box, specify:

Code: 24 VDC NEUTRAL

Click OK.

5 In the Source/Destination Signal Arrows dialog box, click No.

NOTE Click No to insert the signal arrows on the next drawing. Click OK to insert the signal arrows on the current drawing.

6 To open AEGS04.dwg
Click Project tab ➤ Other Tools panel ➤ Next DWG.

7 Click Schematic tab ➤ Insert Wires/Wire Numbers panel ➤ Signal Arrows drop-down ➤ Destination Arrow.

8 Respond to the prompts as follows:
Select wire end for Destination:
Select the top of the neutral wire at line reference 402 (4)

9 In the Insert Destination Code dialog box, click Project.

10 In the Signal codes -- Project-wide Source dialog box, select the following:
11 Click OK.

12 In the Insert Destination Code dialog box, verify:
   Code: 24 VDC NEUTRAL
   Signal Arrow Style: 1
   Click OK + Update Source.

   **NOTE** If asked to change the destination wire layer, click Yes.

   The cross-references for your signal insert into the drawing above the neutral wire.
Click Schematic tab ➤ Edit Wires/Wire Numbers panel ➤ Show

Signal Paths.
Temporary graphics illustrate the flow of the signals on your drawings.

NOTE There is no limit to the number of source and destination links you can set up. One source network can jump to multiple destinations on one or many drawings. A wire can carry both a destination signal and a source signal pointing to the next daisy-chained destination.

Inserting Wire Numbers

You can process and tag wires with sequential wire numbers or with wire numbers based upon the line reference location start of the wire network. When wire numbers are automatically inserted into a drawing, the numbers are not duplicated if they are defined on another network.
AutoCAD Electrical works from left to right, top to bottom as it processes wire networks by default. You can change the direction of wire numbering using the Project Properties ➤ Wire Numbers dialog box (in the Project Manager. Right-click the project name, and select Properties. In the Project Properties dialog box, click the Wire Numbers tab).

**Insert wire numbers automatically**

1. Zoom in on the top portion of the wire network on the left side of the drawing.
2. Click Schematic tab ➤ Insert Wires/Wire Numbers panel ➤ Insert Wire Numbers drop-down ➤ Wire Numbers.
3. In the Sheet 4 - Wire Tagging dialog box, click Pick Individual Wires.
4. Respond to the prompts as follows:
   
   Select objects:
   
   Select the wire segment between the two push buttons on line reference 403 (1), right-click

   The wire number is placed.
Add wire numbers to the entire drawing

1. Click Schematic tab ➤ Insert Wires/Wire Numbers panel ➤ Insert Wire Numbers drop-down ➤ Wire Numbers.

2. In the Sheet 4 - Wire Tagging dialog box, click Drawing-wide. Wire numbers are assigned to each segment in your drawing.

Add wire numbers project-wide

1. Click Schematic tab ➤ Insert Wires/Wire Numbers panel ➤ Insert Wire Numbers drop-down ➤ Wire Numbers.

2. In the Sheet 4 - Wire Tagging dialog box, click Project-wide.

3. In the Wire Tagging (Project-wide) dialog box, verify:
   - Wire tag mode: Reference-based tags
   - To do: Tag/retag all
   - Freshen database (for Signals)

4. Click OK.

Inserting Wire Numbers | 133
5 In the Select Drawings to Process dialog box, Project Drawing List section, press SHIFT as you select AEGS03.dwg and AEGS04.dwg. Click Process.

6 Verify AEGS03.dwg and AEGS04.dwg are listed as the drawings to process and click OK.

7 If asked to save the drawing, click OK.
   Wire numbers are processed for the selected drawings.

You can use the Delete Wire Numbers tool to select a wire number or to pick on any wire of the network.

**Delete a wire number**

1 Click Schematic tab ➤ Edit Wires/Wire Numbers panel ➤ Delete Wire Numbers.

2 Respond the prompts as follows:
   Select objects: Enter all, press ENTER
   The wires in the network change to dashed lines, representing the wires from which the wire numbers will be erased.

3 Press ENTER again to erase the wire numbers.

**Working with Wire Layers**

When a wire is inserted, the wire ends up on the first valid wire layer as defined in the Drawing Properties dialog box. It may be more appropriate to place some wires on different wire layers. You can use the AutoCAD® PROPERTIES command to move a wire to the correct layer or you can use the Wire Layer utility.

**Change wire layer assignments**

1 Zoom in on the upper left corner of the drawing.

2 Click Schematic tab ➤ Edit Wires/Wire Numbers panel ➤ Modify Wire Type drop-down ➤ Change/Convert Wire Type.
The Change/Convert Wire Type dialog box lists all the valid wire layers that are defined for the active drawing. The wire layer name and the wire properties like color, size, and user-defined properties are listed in the grid. An “X” in the Used column indicates the layer name is currently being used.

3 Select RED_18AWG.

The wire type highlights in blue in the dialog box indicating that it is the wire type to change.

<table>
<thead>
<tr>
<th>Used</th>
<th>Wire Color</th>
<th>Size</th>
<th>Layer Name</th>
<th>USER1</th>
<th>USER2</th>
<th>USER3</th>
</tr>
</thead>
<tbody>
<tr>
<td>X</td>
<td>BLK</td>
<td>14AWG</td>
<td>BLK_14AWG</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>X</td>
<td>RED</td>
<td>18AWG</td>
<td>RED_18AWG</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>X</td>
<td>WHT</td>
<td>18AWG</td>
<td>WHT_18AWG</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

4 Click OK.

5 Respond to the prompts as follows:

Select Objects:

Window from left to right around the wires as shown and press ENTER

Before you press ENTER, the wires display as dashed lines to indicate that they have been selected. Once you press ENTER the lines display in red indicating that they have been moved to the RED_18AWG wire layer.

6 Repeat to move any other wiring onto another wire layer.
Panel Layouts

This chapter provides information about working with tools that insert footprint components into panel layouts in AutoCAD® Electrical.

About Panel Layouts

AutoCAD Electrical provides tools to create intelligent panel layout drawings. You can drive layouts from information on the AutoCAD Electrical schematic drawings or you can construct them independently of the schematics.

AutoCAD Electrical places no special naming or attribute requirements on mechanical footprint symbols. You can use footprint symbols supplied by vendors in AutoCAD® format with AutoCAD Electrical.

Inserting Panel Components

Using the AutoCAD Electrical Panel Layout tools, you can select from a list of schematic components. Place the footprint component directly into a panel layout. The footprint remains linked to the original schematic component, so you can perform bidirectional updating between schematic components and the associated footprint blocks.

Select schematic component footprints

1. Open AEGS08.dwg.
2. Click Panel tab ➤ Insert Component Footprints panel ➤ Insert Footprints drop-down ➤ Schematic List.
In the Schematic Component List -- Panel Layout Insert dialog box, verify:

Extract component list for: Project
Location Codes to extract: All

4 Click OK.

5 In the Select Drawings to Process dialog box, select AEGS04.dwg and click Process.

6 Verify that AEGS04.dwg is listed in the Drawing to Process section and click OK.

7 In the Schematic Components (active project) dialog box, click Mark Existing. An x marks the footprints that are already placed in the project. You cannot insert the same component multiple times. If you select an item with an x, the Insert button is disabled.

**NOTE** An o next to a component in the list indicates that a panel component with a matching component tag was found, but the catalog information does not match.
8 In the Schematic Components (active project) dialog box, Display section, select Hide Existing.

The schematic component footprints not yet inserted into the panel layout are displayed.
Now you can begin to insert schematic component footprints manually on the panel layout.

**Insert the system reset footprint manually**

1. In the Schematics Components (active project) dialog box, select PB403 OPSTA3 SYSTEM RESET.
2 Click Manual.

**NOTE** The Manual button is used when schematic component footprints do not have a manufacturer and catalog number defined.

The next step is to make a catalog assignment for the automatic footprint.

3 In the Footprint dialog box, Choice A section, click Catalog lookup.

**NOTE** Use Choice B to enter a graphic without selecting a catalog number.

4 In the Parts Catalog dialog box, select:

- **MANUFACTURER**: AB
- **TYPE**: 30.5mm FLUSH
- **STYLE**: *ALL*

5 Change the catalog assignment to 800T-A2A 1 NO 1 NC BLACK PUSH BUTTON - MOMENTARY, NEMA 4/13 and click OK.
6 In the Footprint dialog box, Choice A section, verify:
Manufacturer: AB
Catalog: 800T-A2A
Click OK.

7 Respond to the prompts as follows:
Select Location for PB403: Select to the left of PB414A (1)
Select Location for PB403: <Ortho on> select ROTATION:
Right-click to place the push button
The component may already have an Item Number assigned. If AutoCAD Electrical finds a component with the same catalog information, it automatically assigns the same item number to this new component. If no item number is assigned, and you think a matching component was already inserted, use one of the Find buttons to look through the drawing or project. If no matching component is found, click Next to assign an item number to this footprint. This button updates each time you insert a footprint and assign an item number. This item or detail number is used for BOM and component reporting and can be referenced by optional balloon labels tied to the footprint.
NOTE The Panel Layout - Component Insert/Edit dialog box displays each time you insert a panel footprint. Information from the schematic representation is automatically carried over to the panel footprint representation.

8 In the Panel Layout - Component Insert/Edit dialog box, click OK. The Schematics Component (active project) dialog box redisplays. You can continue inserting components from the schematic list of the project.

Insert the emergency stop footprint manually

1 In the Schematic Components (active project) dialog box, select: PB403A OPSTA3 EMERGENCY STOP.
2 Click Manual.

3 In the Footprint dialog box, Choice A section, click Catalog lookup.

4 In the Parts Catalog dialog box, select:
   Manufacturer: AB
   Type: 30.5mm
   Style: Red

5 Change the catalog assignment to 800T-D6A 1NO-1NC PUSH BUTTON-MUSHROOM, NEMA 4/13 and click OK.

6 In the Footprint dialog box, Choice A section, verify:
   Manufacturer: AB
   Catalog: 800T-D6A
   Click OK.

7 Respond to the prompts as follows:
   Select Location for PB403A: Select to the left of Conveyor Motor Start (2)
   Select Location for PB403A: <Ortho on> select ROTATION:
Right-click to place the push button

8 In the Panel Layout - Component Insert/Edit dialog box, click OK.

**Insert the light footprint manually**

1 In the Schematic Components (active project) dialog box, select LT404 OPTSTA3 CONVEYOR ON.
2 Click Manual.

3 In the Footprint dialog box, Choice A section, click Catalog lookup.

4 In the Parts Catalog dialog box, select:
   MANUFACTURER: AB
   TYPE: 30.5mm
   VOLTAGE: *ALL*

5 Change the catalog assignment to 800H-QRT24G PLASTIC LENS 24VAC/VDC FULL VOLT GREEN PILOT and click OK.

NOTE To sort the Catalog list easily, select Show list sorted by catalog part number in the Parts catalog dialog box.
6 In the Footprint dialog box, Choice A section, verify:

   Manufacturer: AB
   Catalog: 800H-QRT24G
   Click OK.

7 Respond to the prompts:

   Select Location for LT404:
   Select to the left of the Conveyor Running light (3)
   Select Location for LT404: <Ortho on> select ROTATION:
   Right-click to place the pilot light
8 In the Panel Layout - Component Insert/Edit dialog box, click OK. In the Schematics Components (active project) dialog box, notice the master control relay must still be placed.

9 In the Schematic Components (active project) dialog box, click Close.

**NOTE** You can modify a footprint at any time using the Edit Footprint tool. Since there is bidirectional update capabilities between the schematics and the panel layout drawings, it is possible to introduce some inconsistencies between the two during edit. AutoCAD Electrical alerts you to check other drawings first, and then update any affected drawings.

10 In the Update other drawings dialog box, click OK.

11 If asked to save the drawing, click OK.

### Modifying Attributes

You can align the inserted footprints with existing footprints. Temporary lines indicate the direction in which the alignment is being defined as you select components for the alignment.
Align footprints vertically

1. Click Schematic tab ➤ Edit Components panel ➤ Align.

2. Respond to the prompts as follows:
   Select component to align with (Horizontal/<Vertical>):
   Enter V, press ENTER
   Select component to align with (Horizontal/<Vertical>):
   Select the power on button on the top, left of the layout (1)
   Select objects:
   Select the three components that were just inserted (2-4), right-click

   ![Diagram of components aligned vertically]

   The components are aligned vertically.

Align footprints horizontally

1. Click Schematic tab ➤ Edit Components panel ➤ Align.

2. Respond to the prompts as follows:
   Select component to align with (Horizontal/<Vertical>):
Enter H, press ENTER

Select component to align with {Horizontal/<Vertical>}: 

Select the conveyor running button (1)

Select objects: Select LT404 (2), right-click

3  Follow steps 1 and 2 to align the remaining footprints horizontally.

Move an attribute

1  Click Schematic tab ➤ Edit Components panel ➤ Move/Show Attribute.

2  Respond to the prompts as follows:

Select attribute to Move or pick on block graphics for list
(W=Window move): Select tag LT404 (1)

Select object: Right-click to select

Base point: Select the base point (2), drag to the new location, right-click

The attribute is placed.

3  Repeat for PB403 and PB403A, then right-click to exit the command.

Very little of the information held on panel footprints is visible since only specific attributes are used when assigning catalog information. If an attribute is not found, the information is saved as standard AutoCAD extended entity data (Xdata).
AutoCAD Electrical provides a way to change the extended entity data manually into visible attributes tied to an inserted footprint block.

**Change Xdata to attributes**

1. Click Panel tab ➤ Other Tools panel ➤ Make Xdata Visible.

2. Respond to the prompts as follows:
   - **Select footprint**: *Select LT404*
   - The Select XData to Change to a Block Attribute dialog box displays. All Xdata related to LT 404 are shown.

3. Select DESC1 and click Insert.

4. Respond to the prompts as follows:
   - **Specify location for attribute (DESC1):**
   - *Select the location for the attribute*
   - The attribute is displayed on the drawing and the dialog box reopens.

5. Select DESC2 and click Insert.

6. Respond to the prompts as follows:
   - **Specify location for attribute (DESC2):**
   - *Select the location for the attribute*

7. Click Done.
Adding Nameplate Footprints

You can add nameplates to the panel layout. Nameplates are associated with existing component footprints. Nameplates can be inserted from the main panel icon menu or from a vendor menu.

Insert an automotive type nameplate

1. Click Panel tab ➤ Insert Component Footprints panel ➤ Insert Footprints drop-down ➤ Icon Menu.

2. In the Insert Footprint: Panel Layout Symbols dialog box, click Nameplates.

3. In the Panel: Nameplates dialog box, click Nameplate, Catalog Lookup.

4. In the Nameplate dialog box, Choice A section, click Catalog Lookup.

5. In the Parts Catalog dialog box, select:
   - Manufacturer: AB
   - Type: 800T Automotive
   - Color And_: *ALL*

6. Change the catalog assignment to 800T-X701 Red Blank Name Plate and click OK.

7. In the Nameplate dialog box, Choice A section, verify:
   - Manufacturer: AB
   - Catalog: 800T-X701
   - Click OK.

8. Respond to the prompts as follows:
   - Select objects: Select PB403 (1), right-click to the place the nameplate.
As you select each footprint to insert, the nameplate block inserts and the Panel Layout - Nameplate Insert/Edit dialog box displays where you can annotate the nameplate and assign a BOM item number if needed.

9. In the Panel Layout - Nameplate Insert/Edit dialog box, click OK.

NOTE A tag name links the data on the nameplate a tag name to the footprint and to the schematic component of the same name. Changing the tag name of any of these three representations triggers a prompt for permission to update the other related instances.

Insert a half round nameplate

1. Click Panel tab ➤ Insert Component Footprints panel ➤ Insert Footprints drop-down ➤ Icon Menu.

2. In the Insert Footprint: Panel Layout Symbols dialog box, click Nameplates.

3. In the Panel: Nameplates dialog box, click Nameplate, Catalog Lookup.

4. In the Nameplate dialog box, Choice A section, click Catalog Lookup.

5. In the Parts Catalog dialog box, select:
   - MANUFACTURER: AB
   - TYPE: 800T Half Round
   - COLOR_AND_: "ALL"
6 Change the catalog assignment to 800T-X59E Gray Custom Text Name Plate and click OK.

7 In the Nameplate dialog box, Choice A section, verify:
   Manufacturer: AB
   Catalog: 800T-X59E
   Click OK.

8 Respond to the prompts as follows:
   Select objects: Select PB403A (2), right-click to place the nameplate
In the Panel Layout - Nameplate Insert/Edit dialog box, click OK. The nameplate is inserted.

Editing Terminal Strips

Terminal blocks connect devices that require quick disconnect or disassembly during product shipment, while at other times they can be used to distribute power to other devices. The Terminal Strip Editor easily and quickly defines the locations for these connected devices during the system design process. Terminal strip editing is primarily used towards the end of the control system design cycle to expedite the labeling, numbering, and rearranging of terminals on a terminal strip.

Copy and paste terminal properties

1 Open AEGS09.dwg.

The terminal strip to edit, “TB”, is already placed on the drawing. Zoom in on terminal strip “TB” to see what the terminal strip currently looks like.
2 Click Panel tab ➤ Terminal Footprints panel ➤ Editor.

3 On the Terminal Strip Selection dialog box, select Terminal Strip “TB” and click Edit.

4 On the Terminal Strip Editor dialog box, Terminal Strip tab, select terminal 1 in the grid.
In the Terminal section, click the Move Terminal button.

In the Move Terminal dialog box, click Pick Above. In the Terminal Strip Editor grid, select terminal 4.

**NOTE** You can also use the Move Up tool to move terminal 1 to the top of the grid.

Click Done.

Select terminal 4 in the grid.

In the Properties section, click the Copy Terminal Block Properties button.

Notice that when you click Copy Terminal Block Properties, terminals 5 and 6 also highlight. It is because terminals 4, 5, and 6 are associated. If you copy the properties from one of these terminals, you also copy the properties from the associated terminals. The Copy Terminal Block Properties tool then copies the properties from the terminals to one or many terminals within the same terminal strip.

Select terminal 7 and 10 in the grid by holding down the CTRL key while you select the terminals.
10 In the Properties section, click the Paste Terminal Block Properties button.

The properties you copied from terminal 4 are pasted to terminals 7 and 10. Notice that both terminals are now 3-tiered terminals with level 1 assigned for both.

Associate terminals
1 Select terminals 8 and 9 in the grid.

2 In the Multi-Level section, click the Associate Terminals button.
3 On the Associate Terminals dialog box, select terminal 7, , (3) and click Associate.
Click OK.

4 In the Spare section, click Delete Spare Terminals/Accessories to remove the blank terminals resulting from the Associate.

5 On the Terminal Strip Editor dialog box, select terminals 11 and 12 in the grid.

6 In the Multi-Level section, click the Associate Terminals button.

7 On the Associate Terminals dialog box, select terminal 10, , (3) and click Associate.

Click OK.
8  In the Spare section, click Delete Spare Terminals/Accessories to remove
the blank terminals resulting from the Associate.

Insert spare terminals and accessories

1  Select terminal 7 in the grid.

2  In the Spare section, click the Insert Spare Terminal button.

3  On the Insert Spare Terminal dialog box, specify:
   Number:  SPARE
   Quantity:  1

   NOTE   You can also assign catalog information for the spare terminal from
   the Insert Spare Terminal dialog box by clicking Catalog Lookup. You can
   then select the part from the Parts Catalog dialog box if needed.

   Click Insert Above.

   Now you insert accessories (end barriers) into the terminal strip - one at
   the top and one at the bottom of the terminal strip.

4  Select terminal 1 in the grid.

5  In the Spare section, click the Insert Accessory button.

6  On the Insert Accessory dialog box, specify:
   Number:  EB1
   Quantity:  1

   NOTE   You can also assign catalog information for the accessory from the
   Insert Accessory dialog box by clicking Catalog Lookup. You can then select
   the part from the Parts Catalog dialog box.

   Click Insert Above.
7 Select terminal 15 in the grid.

8 In the Spare section, click the Insert Accessory button.

9 On the Insert Accessory dialog box, specify:
   - Number: EB2
   - Quantity: 1
   - Click Insert Below.

**Insert the terminal strip into the drawing**

1 On the Terminal Strip Editor dialog box, click the Layout Preview tab.

2 Select Graphical Terminal Strip as the terminal type to insert into the drawing.

3 Enter 2.0 in Scale on Insert.

4 Click Rebuild.
5 On the Terminal Strip Editor dialog box, click OK.
6 On the Terminal Strip Selection dialog box, click OK.
Point-to-Point
Diagramming

Part 3 of this manual provides information on creating point-to-point diagrams using connector tools. You can also create drawings for hydraulic, pneumatic, and P&ID style diagrams.
This chapter provides information about working with point-to-point style wiring schematics.

About Connector Diagrams

The connector wiring tools help you more easily create and work with point-to-point style wiring schematics (as opposed to ladder-style schematics). Although some of these tools are useful for ladder-style schematics, they are tuned to work well with drawings that are heavy on point-to-point connector diagrams. Instead of creating and maintaining a large library of schematic connector symbols, each symbol is generated parametrically, on the fly, per user input and at user-defined orientation. A connector toolbar contains tools for creating and editing connectors.

Inserting Connectors

The Insert Connector tool generates a connector symbol from user-defined parameters. The symbol is created on the fly and inserted as a block insert into your active drawing file. Since they are created on an as needed basis, it eliminates the need for you to create and maintain a library of connector symbols.

Change drawing properties

1. Open AEGS10.dwg.
2. Click Schematic tab ➤ Other Tools panel ➤ Drawing Properties drop-down ➤ Drawing Properties.
3 On the Drawing Properties ➤ Components dialog box, select Sequential.

4 On the Drawing Properties ➤ Wire Numbers dialog box, New Wire Number Placement section, select In-Line.

5 Click OK.

Add connectors to the drawing

1 Click Schematic tab ➤ Insert Components panel ➤ Insert Connector drop-down ➤ Insert Connector.

2 On the Insert Connector dialog box, specify:
   - Pin Spacing: 1.0
   - Pin Count: 15
   - Fixed Spacing
   - Pin List: 1
   - Insert All

3 Click the Flip button to flip the connector about its long axis.  
The preview should look like the following image.
4 Click Insert.
A preview outline of the connector displays for placement on the drawing.
It shows rounded corners for the plug side of the connector. An “x” indicates the insertion point of the connector. An arrow indicates the plug side wire connection direction for plug/receptacle or plug-only connector inserts or shows the wire connection direction for a receptacle-only connector insert.

**NOTE** Before committing the connector outline to the drawing, press TAB to flip the connector through four different orientations. Or, press the V key to switch between vertical and horizontal orientations.

5 Respond to the prompts as follows:

Specify insertion point or [Z=zoom, P=pan, X=wire crossing, V=horizontal/vertical, TAB=flip]:

Select to place the connector in the middle of the right-hand border of Black Box 1

![Diagram of connector placement](image)

The connector was automatically assigned a component tag of PJ1.

6 Click Schematic tab ➤ Insert Components panel ➤ Insert Connector drop-down ➤ Insert Connector.

7 On the Insert Connector dialog box, specify:
Pin Spacing: 0.75
Pin Count: 4
Fixed Spacing
Pin List: A
Insert All

8 Click the Flip button to flip the connector.
The preview should look like the following image.

9 Click Insert.
10 Respond to the prompts as follows:
   Specify insertion point or [Z=zoom, P=pan, X=wire crossing, V=horizontal/vertical, TAB=flip]:
   Select to place the connector in the middle of the left-hand border of Black Box 2

The connector was automatically assigned a component tag of PJ2.

11 Repeat steps 6 - 10 to place connectors on Black Box 3 and Black Box 4. The connectors are assigned tags PJ3 and PJ4 respectively.
Wiring Connectors

Black Box 1 is associated to a larger component such as a power box. Black Box 2 - Black Box 4 are smaller components that are part of the power box. The components must be wired together. The easiest way to do it is to use the Insert Wire and Multiple Wire Bus tools.

Wire the connectors together

1. Click Schematic tab ➤ Insert Wires/Wire Numbers panel ➤ Insert Wires drop-down ➤ Wire.

2. Respond to the prompts as follows:

Specify wire start or [wireType/X=show connections]:

**Click PJ1 at pin 1 on Black Box 1**

Specify wire end or [Continue]: Click PJ2 at pin A on Black Box 2
3 Repeat to connect PJ1 (Pin 2) to PJ3 (Pin A) and PJ1 (Pin 3) to PJ4 (Pin A). Right-click to exit the command.

Notice that the Insert Wire tool drew the wire between the connectors while avoiding any existing geometry on the screen.

4 Click Schematic tab ➤ Insert Wires/Wire Numbers panel ➤ Multiple Bus.

5 On the Multiple Wire Bus dialog box, specify:
   Horizontal Spacing: 0.75
   Vertical Spacing: 0.50
   Starting at: Component (Multiple Wires)
6 Click OK.

7 Respond to the prompts as follows:

Window select starting wire connection points

Select pins 5-7 on Black Box 1 (1) and right-click

to (T= wiretype):

Drag the wires to the right past the three wires you inserted,
to Point (Continue/Flip):

Drag the wires up towards PJ2 on Black Box 2, enter C and press ENTER (to continue and lock the drag)
to (Continue/Flip):

Drag the wires to the right and connect to pins B-D on PJ2 (2)
8. Click Schematic tab ➤ Insert Wires/Wire Numbers panel ➤ Multiple Bus.

9. On the Multiple Wire Bus dialog box, click OK to use the previous settings.

10. Respond to the prompts as follows:

   Window select starting wire connection points:

   *Select pins 9-11 on Black Box 1 and right-click*

   to (T= wiretype):

   Drag the wires to the right,

   to Point (Continue/Flip):

   *Drag the wires up towards PJ3 on Black Box 3, enter C, and press ENTER (to continue and lock the drag)*

   to (Continue/Flip):

   Drag the wires to the right and connect to pins B-D on PJ3
11 Click Schematic tab ➤ Insert Wires/Wire Numbers panel ➤ Multiple Bus.

12 On the Multiple Wire Bus dialog box, click OK to use the previous settings.

13 Respond to the prompts as follows:

Window select starting wire connection points:
Select pins 13-15 on Black Box 1 and press ENTER
to (T= wiretype):
Drag the wires to the right,
to Point (Continue/Flip):
Drag the wires down towards PJ4 on Black Box 4, press C, and press ENTER (to continue and lock the drag)
to (Continue/Flip):
Drag the wires to the right and connect to pins B-D on PJ4
Grouping Wires

Now that you wired the connectors together, you insert in-line connectors to group the wires.

**Insert in-line connectors**

1. Click Schematic tab ➤ Insert Components panel ➤ Insert Connector drop-down ➤ Insert Connector.

2. On the Insert Connector dialog box, specify:
   - **Pin Spacing**: 1.0
   - **Pin Count**: 3
   - **At Wire Crossing**
     - **Pin List**: 1
     - **Insert All**

3. Click Details.

4. On the Type section, clear the Add Divider Line box.

5. On the Display section, set Plug to Right and Pins to Both Sides.

6. On the Size section, set the Plug to 0.325.
7 Click Insert.

8 Respond to the prompts as follows:

Specify insertion point or [Z=zoom, P=pan, X=wire crossing,
V=horizontal/vertical, TAB=flip]:

Select to place the connector on the wires connected to PJ1, Pins 1-3

9 Click Schematic tab ➤ Insert Components panel ➤ Insert Connector

drop-down ➤ Insert Connector.

10 On the Insert Connector dialog box, specify:

   Pin Spacing: 1.0
   Pin Count: 9
   At Wire Crossing
   Pin List: 1
   Allow Spacers/Breaks

11 Click Insert.

12 Respond to the prompts as follows:

Specify insertion point or [Z=zoom, P=pan, X=wire crossing,
V=horizontal/vertical, TAB=flip]:

Select to place the connector starting on the line at PJ1, Pin 5

Notice how the connector expands when you cross the wires.

13 On the Custom Pin Spaces/Breaks dialog box, click Insert Next Connection.

The dialog box displays which connector pin has been inserted so far.
Keep clicking Insert Next Connection until you place six of the nine connections.
14 When the Custom Pin Spaces/Breaks dialog box says “Inserted So Far: 6 of 9,” click Break Symbol Now.

15 Respond to the prompts as follows:
   Specify insertion point or [Z=zoom, P=pan, X=wire crossing, 
   V=horizontal/vertical, TAB=flip]:
   Select to place the connector starting on the line at PJ1, Pin 13

16 On the Connector Layout dialog box, select Insert All.

17 Click OK.
NOTE Another method is to insert the entire connector and then use the Split Connector tool to break the existing connector.

18 Click Schematic tab ➤ Insert Components panel ➤ Dashed Link Line drop-down ➤ Link Components with Dashed Line.

19 Respond to the prompts as follows:
Component to link from: Select the bottom portion of PJ6 (1)
component to link to: Select the top portion of PJ6 (2), right-click
Modifying Connectors

The Insert Connector toolbar has tools for modifying connectors and connector pins. You can also add, remove, or move the pins found inside of the connector.

**Stretch existing connectors**

1. Click Schematic tab ➤ Edit Components panel ➤ Modify Connectors drop-down ➤ Stretch Connector.

2. Respond to the prompts as follows:
   - Specify which end of connector to stretch: *Select the bottom of PJ1*
   - Specify second point of displacement:
     *Pull the connector down towards the bottom of Black Box 1*
Repeat for PJ6, pulling the bottom of the connector down so that it is even with PJ1.

Add connector pins

1. Click Schematic tab ➤ Edit Components panel ➤ Modify Connectors drop-down ➤ Add Connector Pins.

2. Respond to the prompts as follows:
   - Select connector: Select PJ1
   - Specify where to insert new pin or [Reset]<16>:
     Select 4 spaces down from pin 15 on PJ1, right-click, and select Enter
     The next available pin number (16) inserts at the selected point.
3 Click Schematic tab ➤ Edit Components panel ➤ Modify Connectors drop-down ➤ Add Connector Pins.

4 Respond to the prompts as follows:

Select connector: Select PJ6

Specify where to insert new pin or [Reset]<10>:

Select the new pin 16 on PJ1 to insert pin 10 in-line with it, right-click and select Enter

NOTE You can delete pins using the Delete Connector Pins tool. Select the pin you want to delete and it is automatically removed from the connector.

Modify connector pins

1 Click Schematic tab ➤ Edit Components panel ➤ Modify Connectors drop-down ➤ Move Connector Pins.

2 Respond to the prompts as follows:
Select connector pin to move: *Select pin 16 on PJ1*
Specify new location for pin 16: *Select 2 spaces up on PJ1*
Select connector pin to move: *Select pin 10 on PJ6*
Specify new location for pin 10:
*Select pin 16 on PJ1 to move pin 10 in-line with it, right-click*

3 Click Schematic tab ➤ Edit Components panel ➤ Modify Connectors drop-down ➤ Swap Connector Pins.

4 Respond to the prompts as follows:
   - Select connector pin: *Select pin 16 on PJ1*
   - Select connector pin: swap with: *Select pin 12 on PJ1, right-click*

5 Click Schematic tab ➤ Edit Components panel ➤ Modify Connectors drop-down ➤ Reverse Connector.

6 Respond to the prompts as follows:
   - Select connector to Reverse: *Select the top in-line connector, right-click*
7 Click Schematic tab ➤ Insert Components panel ➤ Insert Connector drop-down ➤ Insert Connector.

8 On the Insert Connector dialog box, specify:
   - Pin Spacing: 1.0
   - Pin Count: 2
   - Fixed Spacing
   - Pin List: 1
   - Insert All

9 Click Details.

10 On the Type section, select Add Divider Line.

11 On the Display section, set Pins to Plug Side.

12 Click Insert.

13 Respond to the prompts as follows:
   Specify insertion point or [Z=zoom, P=pan, X=wire crossing, V=horizontal/vertical, TAB=flip]:
   
   Select to place the connector on the top of Black Box 1

14 Click Schematic tab ➤ Edit Components panel ➤ Modify Connectors drop-down ➤ Rotate Connector.

15 Respond to the prompts as follows:
   Select connector to Rotate or [Hold]:
   
   Select the new connector, right-click and select Enter
Adding Wire Numbers

Wire numbers are blocks or attributes inserted on a line wire entity. AutoCAD® Electrical assigns each wire number type to its own layer. You can assign a different color to each of these layers so you can easily tell them apart. The wire number placement is set to in-line as defined on the Drawing Properties ➤ Wire Numbers dialog box.

Insert wire numbers

1. Click Schematic tab ➤ Insert Wires/Wire Numbers panel ➤ Insert Wire Numbers drop-down ➤ Wire Numbers.

2. On the Wire Tagging dialog box, specify:
   Wire Tag Mode: Sequential
   Start: 100

3. Click Drawing-Wide.
   The wire numbers are automatically inserted into the drawing starting with number 100.

4. Click Schematic tab ➤ Edit Wires/Wire Numbers panel ➤ Move Wire Number.

5. Respond to the prompts as follows:
   Specify new Wire Number location (select on wire):
   Select each wire closest to Black Box 1, right-click

   NOTE: You can align the wire numbers using the Align tool.
Adding Connector Descriptions

AutoCAD Electrical supports two lines of description text on each connector: one for the plug and one for the receptacle side of the connector.

Add descriptions

1. Right-click connector PJ1 and select Edit Component.
2. On the Insert/Edit Component dialog box, Pins section, click List.
3. On the Connector Pin Numbers In Use dialog box, connector pin grid, click in the Description column for Pin 1.
4. On the Pin Descriptions section, enter $POWER\ B2$ for the Receptacle.
5. On the connector pin grid, click in the Description column for Pin 2.
6. On the Pin Descriptions section, enter $POWER\ B3$ for the Receptacle.
7. On the connector pin grid, click in the Description column for Pin 3.
8. On the Pin Descriptions section, enter $POWER\ B4$ for the Receptacle.
9 Click OK.

10 On the Insert/Edit Component dialog box, click OK.

11 Repeat to add the description POWER IN for Pins A on Black Box 2, Black Box 3 and Black Box 4.

Your finished point-to-point diagram should look like the following image.
Pneumatic, Hydraulic, and P&ID Diagrams

This chapter goes through the steps for creating Piping & Instrumentation (P&ID) and Hydraulic drawings. The same workflow can be applied for Pneumatics. Once your drawing is created, you can use the regular tools in the AutoCAD® Electrical software to modify your drawing.

Setting Up Hydraulic Drawings

Use the Project Manager to manage your hydraulic drawings. From here you can create a new drawing and modify any drawing properties.

Create a new drawing

1. Click Project tab ➤ Project Tools panel ➤ Manager.
2. In the Project Manager, right-click the project name, and select Properties.
3. In the Project Properties ➤ Project Settings dialog box, click Default to switch on all paths for pneumatic, hydraulic and P&ID schematic libraries.
4. Click OK.
5. In the Project Manager, click the New Drawing tool.
6. In the Create New Drawing dialog box, specify:
   Name: AEGS12
7 Enter DSETTINGS at the command prompt.

8 In the Drafting Settings ➤ Snap and Grid dialog box, turn on Snap and Grid and set the size of both to 0.125.

9 Click OK.

10 Click Schematic tab ➤ Other Tools panel ➤ Drawing Properties.

11 In the Drawing Properties ➤ Drawing Format dialog box, Scale section, make sure that the feature scale multiplier is set to 1.0 inch.

12 Click OK.

NOTE For metric unit, the following settings are recommended so that the wire connection points will be placed on the grids for easier drafting. Grid and Snap Size = 2.5mm; Feature scale multiplier =20 (scale factor = 20).

Inserting Hydraulic Schematic Symbols

The hydraulic symbol library in AutoCAD Electrical includes filters, valves, cylinders, pressure switches, motors, pumps, meters, restrictors, quick disconnects, flow arrows and more. The hydraulic symbol library consists of all the hydraulic symbols and is found at \Documents and Settings\All Users\Documents\Autodesk\Acade {version}\Libs\hyd_iso125 or \Users\Public\Documents\Autodesk\Acade {version}\Libs\hyd_iso125 on a Windows Vista® installation.
Insert hydraulic symbols

1. Click Schematic tab ➤ Insert Components panel ➤ Insert Hydraulic Components.

2. In the Insert Component: Hydraulic Symbol dialog box, select the check box for Vertical.

3. In the Insert Component: Hydraulic Symbol dialog box, click the General Valves icon.

4. In the Hydraulic: General Valves dialog box, click Shut Off Valve Open.

5. Respond to the prompts as follows:
   Specify insertion point:
   Select to place the valve in the upper left corner of your drawing

6. In the Insert/Edit Component dialog box, specify:
   Component Tag: VAL2
   Click OK.

7. Repeat steps 1 - 3.

8. In the Hydraulic: General Valves dialog box, click Checkvalve Flow Left.

9. Respond to the prompts as follows:
   Specify insertion point:
   Select to place the check valve below the shut off valve

10. In the Insert/Edit Component dialog box, click OK.
11 Click Schematic tab ➤ Insert Components panel ➤ Insert Hydraulic Components.

12 In the Insert Component: Hydraulic Symbol dialog box, click Motors & Pumps.

13 In the Hydraulic: Motors and Pumps dialog box, click Fixed Displacement.

14 In the Hydraulic: Fixed Displacement dialog box, click Uni-Directional Pump.

15 Respond to the prompts as follows:
Specify insertion point: Select to place the pump below the check valve

16 In the Insert/Edit Component dialog box, specify:
Component Tag: Hydraulic Oil Pump
Click OK.

17 Insert another Shut Off Valve Open below the Hydraulic Oil Pump.
18 Click Schematic tab ➤ Insert Components panel ➤ Insert Hydraulic Components.

19 In the Insert Component: Hydraulic Symbol dialog box, click Filters.

20 In the Hydraulic: Filters dialog box, click Filter.

21 Respond to the prompts as follows:
   Specify insertion point: *Select to place the filter below the shut off valve*

22 In the Insert/Edit Component dialog box, specify:
   Component Tag: FI2
   Description: Line 1: Filter
   Click OK.

23 Click Schematic tab ➤ Insert Components panel ➤ Insert Hydraulic Components.

24 In the Insert Component: Hydraulic Symbol dialog box, click Miscellaneous.

25 In the Hydraulic: Miscellaneous dialog box, click Reservoir.

26 Respond to the prompts as follows:
   Specify insertion point: *Select to place the reservoir below the filter*
In the Insert/Edit Component dialog box, click OK.

Creating Pipes

In the AutoCAD Electrical application, we use different types of wires to represent the type of running pipes that allows water or oil flows from one instrument to another. Let's start by setting up the type of wires for pipe runs.

Insert wires as pipes

1. Click Schematic tab ➤ Edit Wires/Wire Numbers panel ➤ Create/Edit Wire Type.

2. In the Create/Edit Wire Type dialog box, specify:
   Wire Color: RED

27 In the Insert/Edit Component dialog box, click OK.
The Layer Name is automatically created. The name RED_20 is assigned to the wire layer you are creating.

3 Click Color.
4 In the Select Color dialog box, select red and click OK.
5 Click Linetype.
6 In the Select Linetype dialog box, select Continuous and click OK.
7 In the Create/Edit Wire Type dialog box, specify:
   Wire Color: GREEN
   Size: 10
   Color: Green
   Linetype: Hidden2
8 Select RED_20 in the grid and click Mark Selected as Default.

9 Click OK.
10 Click Schematic tab ➤ Insert Wires/Wire Numbers panel ➤ Wire.

11 Respond to the prompts as follows:

Specify wire start or [wireType/X=show connections]:

*Enter X and press ENTER*

[Diagram of a schematic drawing with wires connecting components]

Specify wire start or [wireType/X=show connections]:

*Select the bottom of the shut off valve*

Specify wire end or [Scoot/T=wiretype, X=show connections]:

*Select the top of the check valve*

12 Continue inserting wires connecting the components together. Right-click to exit the command.

Your drawing should look like the following:
NOTE You can also insert the vertical or horizontal pipes first and then insert the components onto the pipe, one at a time.

13 Click Schematic tab ➤ Insert Components panel ➤ Insert Hydraulic Components.

14 In the Insert Component: Hydraulic Symbol dialog box, select the check box for Vertical.

15 In the Insert Component: Hydraulic Symbol dialog box, click Pressure Relief Valves.
16 In the Hydraulic: Pressure Relief Valves dialog box, click N.C. Pressure Relief Valve with Preset -1.

17 Respond to the prompts as follows:
Specify insertion point: Select to place the valve to the right of the pump

In the Insert/Edit Component dialog box, specify:
Component Tag: VAL4
Description: Line 1: Pressure Relief
Click OK.

19 Click Schematic tab ➤ Insert Wires/Wire Numbers panel ➤ Wire.

20 Respond to the prompts as follows:
Specify wire start or [wireType/X=show connections]:
Enter X, press ENTER
Specify wire start or [wireType/X=show connections]:
Press SHIFT + right-click and select Midpoint from the menu, then select the midpoint on the pipe between the pump and the shut off valve above it
Specify wire end or [V=start Vertical/H =start Horizontal/Continue):
Drag the pipe to the right so that it is directly above the pressure relief valve, drag the pipe down and click the top connection point on the pressure relief valve
You now need to insert a pipe that connects the end of the valve back to the pump.

**TIP** Make sure that Snap is turned off and that the Wire Layer is set to GREEN_10.

Specify wire start or [wireType/X-show connections]:

Select the bottom connection point on the pressure relief valve

Specify wire end or [V=start Vertical/H=start Horizontal/Continue):

Drag the pipe down and to the left, click the connection point at the bottom of the pump, right-click

---

**Completing the Hydraulic Drawing**

The rest of the hydraulic drawing consists of inserting a Pressure Gauge and Check Valve at the left side of the pump and then inserting devices (Cylinder; Restrictors; Filter; Check valve and 2-ways valve) along the top of the drawing.

**NOTE** During insertion, clear the Vertical option in the Insert Component: Hydraulic Symbols dialog box.
**Insert components**

1. Click Schematic tab ➤ Insert Components panel ➤ Insert Hydraulic Components.

2. In the Insert Component: Hydraulic Symbol dialog box, click Meters.

3. In the Hydraulic: Meters dialog box, click Pressure Gauge.

4. Respond to the prompts as follows:
   - Specify insertion point:
     *Select to place the pressure gauge to the far left and slightly above of the pump*

5. In the Insert/Edit Component dialog box, specify:
   - Component Tag: MTR1
   - Description: Line 1: Pressure Gauge
   - Click OK.

6. Click Schematic tab ➤ Insert Components panel ➤ Insert Hydraulic Components.


8. In the Hydraulic: General Valves dialog box, click Shut Off Valve Open.

9. Respond to the prompts as follows:
   - Specify insertion point:
Select to place the valve to the right of the pressure gauge

10 In the Insert/Edit Component dialog box, click OK.

11 Set the wire layer to RED_20.

12 Click Schematic tab ➤ Insert Wires/Wire Numbers panel ➤ Wire.

13 Respond to the prompts as follows:
   Specify wire start or [wireType/X-show connections]:
   Select the right connection point on the pressure gauge
   Specify wire end or [Continue]:
   Drag the pipe to the right and click the left connection point on the valve
   Specify wire start or [Scot/wireType/X-show connections]:
   Select the right connection point on the valve
   Specify wire end or [Continue]:
   Drag the pipe to the right and click the vertical pipe, right-click
14 Click Schematic tab ➤ Insert Components panel ➤ Insert

Hydraulic Components.

15 Insert and place the devices listed below as shown in the following illustration. In the Insert/Edit Component dialog box, click OK after each insertion.

NOTE You can also insert the vertical or horizontal pipes first and then insert the components onto the pipe, one by one.

<table>
<thead>
<tr>
<th>Icon</th>
<th>Symbol to Insert</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>2 Way Valves ➤ Solenoid Spring Return -1 (insert as Vertical symbol)</td>
</tr>
<tr>
<td>Icon</td>
<td>Symbol to Insert</td>
</tr>
<tr>
<td>------</td>
<td>------------------</td>
</tr>
<tr>
<td><img src="image1" alt="General Valves Icon" /></td>
<td>General Valves ➤ Checkvalve Flow Left (insert as a Vertical symbol)</td>
</tr>
<tr>
<td><img src="image2" alt="Filters Icon" /></td>
<td>Filters ➤ Filter (insert as a Vertical symbol)</td>
</tr>
<tr>
<td><img src="image3" alt="Restrictors Icon" /></td>
<td>Restrictors ➤ Restrictor with Variable Output Flow</td>
</tr>
<tr>
<td><img src="image4" alt="Restrictors Icon" /></td>
<td>Restrictors ➤ By-Pass Flow Regulator with Variable Output Flow</td>
</tr>
<tr>
<td><img src="image5" alt="Cylinders Icon" /></td>
<td>Cylinders ➤ Single Acting Single Ended Piston Rod</td>
</tr>
</tbody>
</table>

Completing the Hydraulic Drawing | 203
**TIP** Align the components horizontally and vertically using the Align tool to make inserting the pipes easier.

16 Click Schematic tab ➤ Insert Wires/Wire Numbers panel ➤ Wire.

17 Connect the pipes from one control device to another as illustrated.

18 Click Schematic tab ➤ Insert Components panel ➤ Insert Hydraulic Components.

19 In the Insert Component: Hydraulic Symbol dialog box, click General Valves.
20 In the Hydraulic: General Valves dialog box, click Checkvalve Flow Left.

21 Respond to the prompts as follows:
   Specify insertion point: *Select to place the valve below the restrictor*

22 In the Insert/Edit Component dialog box, click OK.

23 Click Schematic tab ➤ Insert Wires/Wire Numbers panel ➤ Wire.

24 Connect the pipes as shown.
The hydraulic schematic diagram is complete.

If you want to create a pneumatic drawing, use the Insert Pneumatic Components tool on the Schematic tab ➤ Insert Components panel. Refer to the pneumatic demo drawing file (Demo03.dwg) in the Extra Library Demo project.

**Setting Up P&ID Drawings**

Use the Project Manager to manage your P&ID drawings. From here you can create a new drawing and modify any drawing properties.

**Create a new drawing**

1. Click Project tab ➤ Project Tools panel ➤ Manager.

2. In the Project Manager, click the New Drawing tool.
3 In the Create New Drawing dialog box, specify:
   Name: AEGS13
   Template: Mouse over the edit box to verify AutoCAD_Electrical.dwt is specified
   Description 1: P&ID Example
   Click OK.

   NOTE You can also Click OK-Properties to proceed to Drawing Properties dialog box if you want to set the component, wire number, cross-reference, style and drawing format settings.

4 Enter DSETTINGS at the command prompt.

5 In the Drafting Settings ➤ Snap and Grid dialog box, turn on Snap and Grid and set the size of both to 0.125.

6 Click OK.

7 Click Schematic tab ➤ Other Tools panel ➤ Drawing Properties.

8 In the Drawing Properties ➤ Drawing Format dialog box, Scale section, make sure that the feature scale multiplier is set to 1.0 inch.

9 Click OK.

   NOTE For metric unit, the following settings are recommended so that the wire connection points will be placed on the grids for easier drafting. Grid and Snap Size = 2.5mm; Feature scale multiplier =20 (scale factor = 20).

Set up wire layers

1 Click Schematic tab ➤ Edit Wires/Wire Numbers panel ➤ Create/Edit Wire Type.

2 In the Create/Edit Wire Type dialog box, click in the Wire Type #2 row and specify:
   Wire Color: RED
Size: 25
The Layer Name is automatically created. The name RED_25 is assigned to the wire layer you are creating.

3 Click Color.
4 In the Select Color dialog box, select red and click OK.
5 Click Linetype.
6 In the Select Linetype dialog box, select Continuous and click OK.
7 Click Lineweight.
8 In the Select Lineweight dialog box, select 0.30 and click OK.
For this example, you need to create three more wire types (two yellow wire layers and one green wire layer) using the Create/Edit Wire Type dialog box.

9 In the Create/Edit Wire Type dialog box, specify:
   Wire Type #3
   Wire Color: YELLOW
   Size: 15
   Color: Yellow
   Linetype: Continuous
   Lineweight: default
   Wire Type #4
   Wire Color: YELLOW
   Size: 10
   Color: Yellow
   Wire Type #5
   Wire Color: GREEN
   Size: 10
   Color: Green
NOTE For pipe runs in P&ID drawings, you must include the different linetypes from the *acade.lin* file. You can set up the wire types for pipes at the beginning of the drawing or before creating the pipes.

10 To set the Linetype for the GREEN_10 wire layer, click Linetype.

11 In the Select Linetype dialog box, click Load.

12 In the Load or Reload Linetypes dialog box, click File.

13 In the Select Linetype File dialog box, select acade.lin and click Open.

NOTE The default location for the *acade.lin* file is \Documents and Settings\{username\}\Application Data\Autodesk\AutoCAD Electrical {version}\{release number\}\country code\Support or \Users\{username\}\AppData\Roaming\Autodesk\AutoCAD Electrical {version}\{release number\}\country code\Support on a Windows Vista® installation.

14 In the Load or Reload Linetypes dialog box, select Pneumatic Signal and click OK.
In the Select Linetype dialog box, select Pneumatic Signal and click OK.

In the Create/Edit Wire Type dialog box, click OK.

### Inserting P&ID Schematic Symbols

The P&ID symbol library in AutoCAD electrical includes equipment, tanks, nozzles, pumps, fittings, valves, actuators, logic functions, instrumentation, flow, and flow arrows. The P&ID symbol library consists of all the piping and instrumentation symbols and is found at `Documents and Settings\All Users\Documents\Autodesk\Acad*\version\Libs\Pid` or `Users\Public\Documents\Autodesk\Acad*\version\Libs\Pid` on a Windows Vista installation.

**Insert P&ID Symbols**

1. Click Schematic tab ➤ Insert Components panel ➤ Insert P&ID Components.

2. In the Insert Component: Piping and Instrumentation Symbols dialog box, click Equipment.
3 In the PID: Equipment dialog box, click Ball Mill.

4 Respond to the prompts as follows:
   Specify insertion point:
   Select to place the ball mill in the upper left corner of your drawing

5 In the Insert/Edit Component dialog box, specify:
   Component Tag: C-100
   Description: Line 1: BALL MILL
   Click OK.

6 Follow steps 1-2 above.

7 In the PID: Equipment dialog box, click Conveyors.

8 In the PID: Conveyors dialog box, click Conveyor 1.

9 Respond to the prompts as follows:
   Specify insertion point:
   Select to place the conveyor to the right and diagonally below the ball mill

10 In the Insert/Edit Component dialog box, specify:
    Component Tag: N-100
    Description: Line 1: CONVEYOR
    Click OK.

11 Follow steps 1-2 above.
12 In the PID: Equipment dialog box, click Mixer 2.

13 Respond to the prompts as follows:
   Specify insertion point:
   Select to place the mixer to the right and diagonally below the conveyor

14 In the Insert/Edit Component dialog box, specify:
   Component Tag: A-100
   Description: Line 1: MIXER
   Click OK.

15 Click Schematic tab ➤ Insert Components panel ➤ Insert P&ID Components.

16 Insert and place the devices listed below as shown in the following illustration. In the Insert/Edit Component dialog box, click OK after each insertion.

<table>
<thead>
<tr>
<th>Icon</th>
<th>Symbol to Insert</th>
</tr>
</thead>
<tbody>
<tr>
<td>![Valves Icon]</td>
<td>Gate Valve</td>
</tr>
</tbody>
</table>

In the Insert/Edit Component dialog box, clear the Component Tag

<table>
<thead>
<tr>
<th>![Equipment Icon]</th>
<th>Dryer</th>
</tr>
</thead>
<tbody>
<tr>
<td>Component Tag = C-200; Description Line 1 = DRYER</td>
<td></td>
</tr>
</tbody>
</table>
Creating Pipes

In AutoCAD Electrical, we use different types of wires to represent the type of running pipes that allow water or oil flows from one instrument to another.

Insert wires as pipes

1. In the AutoCAD Layers toolbar, change the wire layer to RED_25.

2. Click Schematic tab ➤ Insert Wires/Wire Numbers panel ➤ Wire.

3. Connect the pipes as shown. Right-click to exit the command.

TIP Align the components horizontally and vertically using the Align tool to make inserting the pipes easier.
4 In the AutoCAD Layers toolbar, change the wire layer to POS and the linetype to HIDDEN2.

5 Click Schematic tab ➤ Insert Wires/Wire Numbers panel ➤ Wire.

6 Respond to the prompts as follows:
   
   **Specify wire start or [wireType/X=show connections]:**
   
   **Select the bottom of the discrete instrument**
   
   **Specify wire end or [Continue]:**
   
   **Drag the wire down a few spaces, press ENTER**

7 Click Schematic tab ➤ Insert Components panel ➤ Insert P&ID Components.
8 In the Insert Component: Piping and Instrumentation Symbols dialog box, click Flow Arrows.

9 In the PID: Equipment dialog box, click Flow Arrow Down.

10 Respond to the prompts as follows:
   
   Specify insertion point:
   
   Select to place the flow arrow at the bottom of the new wire

   ![Diagram showing flow arrow placement]

The P&ID diagram is complete.

If you want to see how to expand the P&ID drawing, refer to the P&ID demo drawing file (Demo01.dwg) in the Extra Library Demo project.
Generating Reports

Part 4 of this manual includes information on generating reports, modifying the format of the reports, and inserting report tables.
AutoCAD® Electrical provides a number of reports as well as great flexibility in each report format. This chapter provides information about generating a report and then using various methods to manipulate the report format in AutoCAD Electrical.

Generating Bill of Material Reports

Using AutoCAD Electrical, you can perform a project-wide extract of all BOM data found on your project drawing set. The data is extracted from the project database, matched with standard entries in the catalog database, and then additional fields are pulled from the catalog files. You can format this data into various report configurations and output to report files, export to a spreadsheet or database program, or place in an AutoCAD Electrical drawing.

Generate a bill of material (BOM) report

1. Open AEGS11.dwg.

2. Click Reports tab ➤ Schematic panel ➤ Reports.

3. In the Schematic Reports dialog box, select:
   - Report Name: Bill of Material
   - Bill of Material: Project
   - Verify that the following options are specified:
     - Include options: All the above
     - Display option: Normal Tallied Format
     - Installation Codes to extract: All
Location Codes to extract: All
Click OK.

4 In the Select Drawings to Process dialog box, select AEGS03.DWG, and click Process.

5 Verify that AEGS03.DWG is displayed in the Drawings to Process section of the dialog box and click OK.

The generated report is displayed in the Report Generator dialog box.

Table: BOM Report

<table>
<thead>
<tr>
<th>TAGS</th>
<th>QTY</th>
<th>SUB</th>
<th>CATALOG</th>
<th>MFG</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>CD322</td>
<td>5</td>
<td></td>
<td>ECK9015FFG</td>
<td>EATON</td>
<td>CIRCUIT BREAKER - E125 FRAME 3-POLE CIRCUIT BREAKER 15AMP S</td>
</tr>
<tr>
<td>CB32a</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>TYPE E125H, FIXED THERMAL &amp; MAGNETIC 600M, 25AMP, 15AMP S</td>
</tr>
<tr>
<td>CD520</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>150A LOAD SWITCH 3 POLE 19AE - LOAD SWITCH 25AMP S</td>
</tr>
<tr>
<td>CD540</td>
<td>1</td>
<td>19AE-025-1753</td>
<td>AB</td>
<td></td>
<td>DUAL ELEMENT FUSE - CLASS RB5 TIME DELAY, CURRENT LIMITING 600M</td>
</tr>
</tbody>
</table>

6 In the Report Generator dialog box, select:
Header: Time/Date
Header: Column Labels
Add blanks between entries

Inserting BOM Tables into Drawings

Insert a BOM into the drawing in tabular format

1 With the BOM report displayed in the dialog box, click Put on Drawing.

2 In the Table Generation Setup dialog box, select:
   - Column Labels: Include column labels
   - Title: Include time/date
   - Column Width: Calculate automatically
   - Borders: All Borders
Click OK.
NOTE  The extents of the BOM table are displayed in temporary graphics. Press Z to zoom down, or R to flip into real-time pan and zoom mode, if necessary.

3  The table outline moves with your cursor. Position the table, and then click to place the table. The BOM table is built where you placed it.

4  In the Report Generator, click Close.

Editing BOM Tables on Drawings

You can use the Edit Component tool together with the Report Generator’s Edit Mode to modify a report that has already been placed on a drawing.

Edit the BOM report

1  Click Schematic tab ➤ Edit Components panel ➤ Edit.

2  Select the report on the drawing.
The report is displayed using the current report settings.

3. In the Report Generator dialog box, click Edit Mode.


5. Click Move Up.
   The lines that make up a single BOM entry are kept together and moved up one space in the report dialog box.
NOTE You can also edit report data, delete BOM entries and add new catalog items to the report.

6 Click OK - Return to Report.

7 In the Report Generator dialog box, click Put on Drawing.
The report on the drawing updates to reflect the changes you made.

8 In the Table Generation Setup dialog box, click OK.

9 In the Report Generator dialog box, click Close.
Changing Formats of BOMs

Each AutoCAD Electrical report is customizable, from which data fields are reported and the order in which they appear to the justification of any column and the column labels.

Remove the TAGS columns from the BOM

1. Erase the table, or UNDO, and rerun the BOM extract for AEGS03.DWG.

2. In the Report Generator dialog box, click Change Report Format.
   In the Bill of Materials Data Fields to Report dialog box, Fields to report section, the fields that format the BOM are displayed.

3. Select TAGS in the Fields to report list.

4. Click <<Remove.

The TAGS field is moved out of Fields to report and into Available fields.

**NOTE** You can also select a field in the Available fields list to add it to the report or rearrange columns using the Move Up and Move Down buttons. Clicking Ok-Save As saves these settings to a file for later use.

5. Click OK.
NOTE This new format becomes the default the next time you extract a BOM report.

The BOM data in the Report Generator dialog box is reformatted and displayed.

6 Scroll down the report to verify that the component tags column is removed.

7 Insert the new version of the BOM table into the drawing.

Exporting BOMs to Spreadsheets

You can move your BOM to a spreadsheet, database, or any other application that can read data in a comma-delimited or Microsoft® Access® format.

Export the BOM to an Excel® spreadsheet

1 In the Report Generator dialog box, click Save to File.

2 In the Save Report to File dialog box, select Excel spreadsheet format (.xls) and click OK.

3 In the Select file for report dialog box, enter an output file name or click OK to accept the default name BOM.xls. Click Save.

4 In the Optional Script File dialog box, click Close - No Script.

5 In Excel, click File ➤ Open.

6 Browse to the location where you saved the spreadsheet. The default is C:\Documents and Settings\{username}\My Documents or C:\Users\{username}\My Documents on a Windows Vista installation. Select the spreadsheet.

7 Click Open.

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>QTY</td>
<td>SUB</td>
<td>CATALOG</td>
<td>MFG</td>
</tr>
<tr>
<td>2</td>
<td>6</td>
<td>1</td>
<td>EGH0105100</td>
<td>EATON</td>
</tr>
<tr>
<td>3</td>
<td>1</td>
<td>1</td>
<td>1S4E-1SR-1/28 AB</td>
<td>E5 LOAD SWITCH 3 POLE</td>
</tr>
<tr>
<td>4</td>
<td>1</td>
<td>1</td>
<td>FR3-R-16</td>
<td>Bussmann</td>
</tr>
<tr>
<td>5</td>
<td>2</td>
<td>1</td>
<td>FR3-R-8</td>
<td>Bussmann</td>
</tr>
<tr>
<td>6</td>
<td>10</td>
<td>1</td>
<td>DIN-T10</td>
<td>AUTOMATION/DIRECT</td>
</tr>
<tr>
<td>7</td>
<td>1</td>
<td>1</td>
<td>3560F</td>
<td>SGB</td>
</tr>
</tbody>
</table>
Your BOM data is displayed in spreadsheet format. You can slide the column borders to expose the full column of text for each field. The first six columns of the spreadsheet are shown in the previous image. The first column is the tallied quantity, followed by subassembly quantity, catalog number, and manufacturer code. The remaining fields are the fields extracted from the mfg/cat combo query on the external catalog look-up file.
Migrating AutoCAD Data

Part 5 of this manual includes information on migrating AutoCAD® data to make it AutoCAD® Electrical smart.
Migration of AutoCAD Data

This chapter describes using the tagging and linking tools in AutoCAD® Electrical to convert non blocked geometry and text to a fully functional AutoCAD Electrical-aware block insert.

About Tagging and Linking Tools

AutoCAD Electrical has tagging and linking tools that enable non blocked geometry to be made aware of AutoCAD Electrical. The existing geometry stays in place and is unblocked, but key text entities are converted to attributes with user picks and are linked into a generic, non graphical block insert. Wire connection attributes can also be merged into this generic block insert. The process to convert it from dumb text, circle, and line entities takes only moments to complete and the result appears as a fully functional AutoCAD Electrical-aware block insert.

Exploding Block and Attributes

The Special Explode tool in AutoCAD Electrical explodes attributes and blocks to geometry and text entities while maintaining the value previously defined in the attributes. You can take advantage of the tagging tools to modify the text entities to attributes and the linking tools to make various blocks.

1. Click Project tab ➤ Project Tools panel ➤ Manager.
2 In the Project Manager, right-click the project name (AEGS), and select Add Drawings.

3 In the Select Files to Add dialog box, double-click the CONVERT subfolder.

4 Select files Convert-01.dwg through Convert-04.dwg and click Add.

5 When asked to apply the project defaults to the drawing settings, click Yes.

6 Open Convert-03.dwg.

7 Zoom in on the components in the upper left-hand corner of the drawing.

8 Click Conversion Tools tab ➤ Tools panel ➤ Special Explode. Use the Special Explode tool to explode attributes and blocks to geometry and text entities while maintaining the value previously defined in the attributes. You can take advantage of the tagging tools to modify the text entities to attributes and the linking tools to make various blocks.

9 Respond to the prompts as follows:

Select objects:
Select push button lights A - D (including all graphics and text) on lines 401 - 407 (use either single picks or window-select), right-click

The blocks explode into separate text entities and geometry.

**Tagging Schematic Components**

Use the AutoCAD Electrical Tagging tools to convert text entities into an attributed block. Through the insertion of a template block, you have control over which attributes are inserted and visible. All necessary attribute definitions are automatically placed. During the tagging process, the text entity is removed and replaced with a template block file that contains multiple attributes used in AutoCAD Electrical.

**Tagging Results:**

- The selected text entities are replaced with a template block file.
- The TAG attribute takes on the value of the converted text.
- The TAG attribute is set to fixed.
- The TAG attribute takes on the same ACAD properties as the tagged text.
Tag schematic components

1. Click Conversion Tools tab ➤ Schematic panel ➤ Tag Component.

2. Respond to the prompts as follows:
   Select objects: Select 9PB, 10PB, 11PB, and 12 PB, right-click

   **NOTE** You may have to right-click several times to exit the command.

   The text changes color to indicate that it has been tagged. The color of
   the TAG attribute is by layer. The attribute is the same layer as defined
   on the WD_M block. You can now link the descriptions and wire numbers.

3. Click Reports tab ➤ Schematic panel ➤ Reports.

4. In the Schematic Report dialog box, specify:
   - Report Name: Component
   - Active Drawing
   - Click OK.

5. If asked to save the drawing, click Yes.
   - In the Report Generator dialog box, notice that 9PB-12PB are listed in
     the TAGNAME column of the report

6. In the Report Generator dialog box, click Close.

**Linking Schematic Attributes**

Use the AutoCAD Electrical Linking tools to associate non blocked text to
previously placed template blocks. Through the modification of a template
block, you have control over which attributes are inserted and visible. All
necessary attribute definitions are placed using the properties of the existing
text entities, such as justification, height, and location. If multiple template
block files are selected, the value of the text is added to the previously defined
template block attributes as hidden attributes and the text is not removed.
Linking Results:

- The selected text entities are replaced with an AutoCAD Electrical attribute.
- Colors change to visually distinguish what has been already converted as defined in the WD_M block.
- Temporary lines display the link.
  The Link Descriptions tool links simple text as Description 1-3 attributes on an AutoCAD Electrical block file. You can link them as description attributes to one or more existing template block definitions. During the conversion process, the text entity is removed and replaced with the next available description attribute, up to 3.

Link descriptions

1. Click Conversion Tools tab ➤ Attributes panel ➤ Link Descriptions.

2. Respond to the prompts as follows:
   Select objects:  Select 9PB, right-click
   Select text to fill in next available DESC attribute:
   Select LIGHT A, right-click
   Select objects:  Select 10PB, right-click
   Select text to fill in next available DESC attribute:
   Select LIGHT B, right-click
   Select objects:  Select 11PB, right-click
   Select text to fill in next available DESC attribute:
   Select LIGHT C, right-click
   Select objects:  Select 12PB, right-click
   Select text to fill in next available DESC attribute:
   Select LIGHT D, right-click

   NOTE  You may have to right-click several times to exit the command.
Colors change to visually distinguish what has been converted and temporary lines display the link.

3 Click Reports tab ➤ Schematic panel ➤ Reports.

4 In the Schematic Report dialog box, specify:
   Report Name: Component
   Active Drawing
   Click OK.

5 If asked to QSave the drawing, click Yes.
   In the Report Generator dialog box, notice that 9PB-12PB are still listed in the TAGNAME column of the report.

6 In the Report Generator dialog box, click Change Report Format.

7 In the Component Data Fields to Report dialog box, select Desc1 from the Available Fields list.
   Desc1 moves into the Fields to report list. These are the fields that will display in the Component report.
8 Click OK.
The Report Generator dialog box now lists the TAGNAME and DESC1 values from the active drawing.

9 In the Report Generator dialog box, click Close.

Adding Wire Connections

Wire connection attributes can also be merged into the new generic block insert. The Add Wire Connections tool in AutoCAD Electrical adds wire connection attributes to the existing tagged block file. Select line endpoints or geometry to add the appropriate wire connection attributes to. A new block definition is created with the newly added wire connections. You can subsequently create a new block file if the block is exploded.

Wire Connection Results:

- Visual indicators (x) appear where the wire connection attributes have already been applied.
- Wire connection attributes, terminal attributes, and terminal description attributes are added.
- The block definition is automatically modified during the attribute addition process.
Terminal attribute colors change to visually distinguish what has been already converted as defined in the WD_M block.

**Convert device pins to wire connection attributes**

1. Click Conversion Tools tab ➤ Tools panel ➤ Add Wire Connections.

2. Respond to the prompts as follows:
   - Select block TAG or PLC Address: Select 9PB
   - Select end of wire (P=Pick Location): Enter P and press ENTER
   - Select location (W=Wire):
     - Press SHIFT + right-click to select Endpoint from the Snap options, select the end point of the first wire on line 401
     - In the Wire Direction dialog box, select from left.
   - Select TERM01 text object: Select 22 (underneath 9PB TAG)

   **NOTE** Visual indicators (x) appear where the wire connection attributes have been applied.

   - Select location (W=Wire):
     - Press SHIFT + right-click to select Endpoint from the Snap options, select the end point of the second wire on line 401
     - In the Wire Direction dialog box, select from right.
   - Select TERM02 text object: Select 55 (underneath line 401), right-click

   ![Diagram](image)

   You should be back at the prompt to Select block TAG or PLC Address.

3. Repeat for 10PB - 12PB.

   **NOTE** You may have to right-click several times to exit the command.
Pause the mouse over 9PB - 12 PB. The text, wire connection attributes, and description text should all highlight. We still must convert the wire number text and add the geometry to our block.

4 Click Schematic tab ➤ Edit Wires/Wire Numbers panel ➤ Create/Edit Wire Type.

5 In the Create/Edit Wire Type dialog box, select Make all Lines Valid Wires and click OK.

6 Click Conversion Tools tab ➤ Tools panel ➤ Convert Text to Wire Number.

7 Respond to the prompts as follows:

Select LINE near wire number text:

Select the left endpoint of the wire with the text 13 above it (line 401)

Select existing wire number text to convert: Select text 13

8 While you are still in the command, repeat for text 14 - 16 on lines 403 - 407.
Adding Geometry

The Add Geometry tool in AutoCAD Electrical adds AutoCAD geometry to a template block file to be created as part of a unique block instance. It creates a new block definition with the newly added geometry. You can subsequently create a new block file if the block is exploded.

Add Geometry Results:

- TAG1, TAG2, PLC TAG, and TAGSTRIP attributes are defined and selected first.
- The block definition is automatically modified.
- The geometry's color changes by layer to visually distinguish what has been already converted as defined in the WD_M block.

Add geometry to the block

1. Click Conversion Tools tab ➤ Tools panel ➤ Add Geometry.
2. Respond to the prompts as follows:
   
   Select block for additional geometry: Select 9PB
   Select objects: Select the graphics for the push button, right-click

   Specify insertion point: Select the middle of the push button

   The geometry is associated to the template block files. Check that everything has been tied to the block by mousing-over 9PB. The text, wire connection attributes, description text and geometry highlights.
Repeat steps 1 - 2 for 10PB, 11PB, and 12 PB. Your blocks are now AutoCAD Electrical-smart.

Tagging and Linking Panel Components

The AutoCAD Electrical Tagging and Linking tools work on panel components the same way they work on schematic components.

Tag and link panel components

1. Open Convert-04.dwg.
2. Zoom in on the components in the middle of the drawing.
3. Click Conversion Tools tab ➤ Tools panel ➤ Special Explode.
4. Respond to the prompts as follows:
   Select objects:
   Select push button lights A - D (including all graphics and text) (use either single picks or window-select), right-click
The blocks explode into separate text entities and geometry. The Tag Panel Component tool makes selected text entities an attributed block file with the P_TAG1 attribute visible. The template block file (ACE_P_TAG1_CONVERT.DWG) contains attributes for a panel component.

5 Click Conversion Tools tab ➤ Panel panel ➤ Tag Footprint.

6 Respond to the prompts as follows:
   Select objects: Select 9PB, 10PB, 11PB, and 12 PB, right-click

   **NOTE** You may have to right-click several times to exit the command.

   The text changes color to indicate that it has been tagged. The color of the PTAG attribute is by layer. The attribute is the same layer as defined on the WD_M block.

7 Click Conversion Tools tab ➤ Attributes panel ➤ Link Descriptions.

8 Respond to the prompts as follows:
   Select objects: Select 9PB, right-click
   Select text to fill in next available DESC attribute:
   Select LIGHT A, right-click

   **NOTE** You may have to right-click several times to exit the command.
Updating Panel or Schematic Components

Once a panel component has a component tag assigned, it is automatically linked to the related schematic component. Updates to either the schematic or panel component prompt an update to the related component.

**Surf to the related schematic component**

1. Click Project tab ➤ Other Tools tab ➤ Surfer.
2. Respond to the prompts as follows:
   Select tag for “Surfer” trace (or <Enter> to type it): **Select 9PB**
3. In the Surf dialog box, double-click the component marked with type “p.”

![Surf dialog box](image)
Surfer goes to the schematic drawing and zooms on the schematic component.

4 If asked to save the drawing, click Yes.

5 In the Surf dialog box, click Edit.

6 In the Component Insert/Edit dialog box, change the description to LIGHT 1 and click OK.

The Update Other Drawings dialog box displays. This dialog alerts that other drawings in the project set may include child components or related panel components.

7 If asked to save the drawing, click Yes.

8 In the Update Other Drawings dialog box, click OK.

9 Click Project tab ➤ Other Tools tab ➤ Surfer.

10 Respond to the prompts as follows:

Select tag for “Surfer” trace (or <Enter> to type it): Select 9PB
11 In the Surf dialog box, double-click the component marked with type "#." Surfer goes to the panel layout drawing and zooms on the physical representation of the push button. Notice that the description for 9PB updated to reflect the change you made to the schematic component.

12 In the Surf dialog box, click Close.
Index

A
add connector pins 181
add geometry 238
Add Rung tool 20
align components 32
All Locations-Drawing dialog box 27, 34
attributes
add 52
DESC1 53
FAMILY 53
INST 53
link panel descriptions 240
link schematics 233
LOC 53
move 151
wire connections 235
AutoCAD Electrical Help 4

B
bill of material reports 219
Bill of Materials Data Fields to Report dialog box 224

C
catalog assignments 141
add 43
catalog lookup 44
catalog numbers 25
Change/Convert Wire Type dialog box 135
Circuit Builder 64, 93, 98, 101
configuration 66
referencing existing circuit 101
circuits
Circuit Builder 64
insert saved circuits 84
insert WBlocked circuits 92
save 81
save to icon menu 83
command summary 5
Component Data Fields to Report dialog box 234
component fence 112
component tag 24
components
aligning 32
child 29
parent 24
scooting 29
swap 48
Connector Layout dialog box 178
connector pin descriptions 186
connector pins
add 181
move 182
swap 183
connectors
insertion 167
pin descriptions 186
placement 169
reverse 183
rotate 184
split 179
stretch 180
convert text to wire numbers 237
Create New Drawing dialog box 11, 189, 207
Create New Project dialog box 8
Create/Edit Wire Type dialog box 195, 207, 237
Custom Pin Spaces/Breaks dialog box 177

D
dashed link lines 40–41, 179
destination signals 125
dialog boxes
All Locations-Drawing 27, 34–36
Bill of Materials Data Fields to Report 224
Change/Convert Wire Type 135
Component Data Fields to Report 234
Connector Layout 178
Create New Drawing 189, 207
Create/Edit Wire Type 195
Custom Pin Spaces/Breaks 177
Edit PLC Module 117
Edit Report 222
I/O Address 110
I/O Point 109
Insert Connector 168–169, 176–177
Insert New Ladder 105
Insert/Edit Child Component 38
Insert/Edit Component 27
Insert/Edit Contact 31
Keep 112–115
Modify Line Reference Numbers 121
Module Layout 109
Multiple Wire Bus 62, 172, 174–175
Panel Layout-Component
   Insert/Edit 144, 146
Parts Catalog 25
PLC I/O Module
   Selection/Insert 107
   PLC I/O Wire Numbers 119
Report Generator 220
Save Report to File 225
Schematic Component List - Panel Layout Insert 138
Schematic Components 138
Schematic Reports 219
Select Template 11
Sheet 4-Insert Destination
   Code 126, 129
Signal Codes-Proj-wide Source 126
Signal-Source Code 124
Source/Destination Signal
   Arrows 125, 128
Surf 241
Symbol Builder 51
Table Generation Setup 220
Terminals 114
Wire Tagging 132

Wire Tagging (Project-wide) 133
dot tee markers 91
drafting settings 190, 207
drawing details 14
drawing properties 13
drawings
   add 12
descriptions 13
   in projects 12
   next 14
   previous 14
   reorder 12
   viewing within projects 14
dual circuit 98

e
edit components 38
Edit PLC Module dialog box 117
Edit Report dialog box 222
exercises 3
explode blocks 230

F
Footprint dialog box 141
footprints
   manual insertion 144

H
Help systems, AutoCAD Electrical 4
hydraulic symbols 190
   by-pass flow regulator 203
   check valve flow left 191, 203, 205
   filters 193, 203
   fixed displacement pump 192
   general valves 191, 200, 204
   insertion 191–193, 197, 200, 202,
   204
   meters 200
   motors and pumps 192
   pressure gauge 200
   pressure relief valves 197
   reservoir 193
restrictor with variable output
flow 203
shut off valve open 191, 200
single ended piston rod 203
solenoid spring return 202
uni-directional pump 192

I
I/O Address dialog box 110
I/O Point dialog box 109
Insert Connector dialog box 168–169, 176–177, 184
Insert New Ladder dialog box 105
Insert Pneumatic Component tool 206
Insert Wire tool 21
Insert/Edit Child Component dialog box 38
Insert/Edit Component dialog box 27
Insert/Edit Contact dialog box 31
item numbers 143

K
Keep dialog box 112–115

L
ladder rungs, removing 111
ladders, single-phase 105
linking tools 229
Load or Reload Linetypes dialog box 209

M
Modify Line Reference Numbers dialog box 121
Module Layout dialog box 109
move connector pins 182
multi-level terminals 74–75, 78
multiple wire bus 62
Multiple Wire Bus dialog box 62, 172, 174–175

N
name plates 153
insertion 153–154
New Drawing tool 11
New Project tool 8

O
one-line circuit 93, 98

P
P&ID drawing 206
p&id symbols 210
ball mill 211
dryer 212
field mounted instruments 213
flow arrow down 215
flow arrows 215
gate valve 212
mixer2 212
Panel Layout-Component Insert/Edit dialog box 144, 146
parent/child relationships 23, 30, 84
Parts Catalog dialog box 25, 43
pin descriptions 186
pipes 194, 213
piping & instrumentation 206
PLC I/O Module Selection/Insert dialog box 107
PLC I/O point descriptions 117
PLC I/O Wire Numbers dialog box 119
PLC modules 107
point-to-point tools 167
prerequisites for exercises 4
Project Manager 7–8, 189, 206, 229
project properties 9
Project Properties dialog box 10
projects 8, 189, 206, 229
R
reference-based tags 9
renumber terminals 87
reorder drawings 12
Report Generator dialog box 220
reports 219
change format 224
edit 221
export to spreadsheet 225
reverse connectors 183
rotate connectors 184

S
Save Report to File dialog box 225
schematic bill of material reports 219
schematic component 23
Schematic Component List - Panel Layout
   Insert dialog box 138
Schematic Components dialog box 138
Schematic Report dialog box 232, 234
Schematic Reports dialog box 219
schematic symbols
   blue press to test pilot lights 37
green press to test pilot lights 34
limit switch buttons 111
miscellaneous switches 49
normally open limit switches 111
normally open push buttons 33
normally open relays 30
pilot lights 34, 37
proximity switches 49
push buttons 33, 35
relays buttons 24, 30
selector switches 37
standard coils 24
terms and connectors 113
scooting components 29
Select Color dialog box 195, 208
Select Linetype dialog box 195, 208
Select Linetypes File dialog box 209
Select Lineweight dialog box 208
Select Template dialog boxes 11
Sheet 4-Insert Destination Code dialog box 126, 129
Signal Codes-Proj-wide Source dialog box 126
Signal-Source Code dialog box 124
signals
destination 125
show 131
source 123
Source/Destination Signal Arrows dialog box 125, 128
stretch connectors 180
Surf dialog box 241
surf symbols 46
swap components 48
swap connector pins 183
symbol builder 50
   add attributes 51
   add wire connection points 54
   saving the symbol 57

T
Table Generation Setup dialog box 220
tag panel components 239
tagging tools 229
templates 11
terminal strips 156
terminal styles 55
terminals
   associations 75, 87
   multi-level 75, 87
   properties 87
   renumber 87
Terminals dialog box 114
terms and connectors 113
Trim Wire tool 22

W
WBlock 57, 81, 91
WD_M block 10
wire connection points 21, 54
wire connections
   add 236
   wire layers 19, 134
wire numbers
   convert text 237
move 185
projects 133
Wire Tagging (Project-wide) dialog box 133
Wire Tagging dialog box 132, 185
wires 19
multiple wire bus 62

single-phase 20, 59, 73
trimming 21, 62

xdata 152