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Stand-Alone Licensing

A stand-alone license allows you to run an Autodesk® product on a single workstation.

Introduction

Stand-alone licensing allows you to use your Autodesk product in trial mode
for a given number of days from the first time you launch the product. The
number of days that a trial mode is active differs between Autodesk products.
You can activate your license at any time before the trial period expires.

When you activate your product, you receive an activation code. If you activate
online, your activation code is automatically retrieved from Autodesk and the
product starts. Activations are also available through email, fax, phone, or the
Autodesk website.

NOTE If you are installing and using an Autodesk product on both operating systems
of a dual-boot operating system, you must obtain a separate activation code for
each operating system.

The license file stays on your workstation when you uninstall your product. If
you reinstall your Autodesk product on the same workstation, the license
information is still valid. You do not have to reactivate the product.

Multi-Seat Stand-Alone License

A multi-seat stand-alone license allows you to install, register, and activate an
Autodesk product on several workstations using a single serial number. Multi-seat
licenses can be purchased through your Authorized Autodesk Reseller.

The Create Deployment feature in the provided installer simplifies deployment
by creating a server image that you can access to install the software on your



workstation. The software activates automatically when it is started for the
first time and if an Internet connection is available.

NOTE To avoid activation failures, it is recommended that you use the provided
installer to create the deployment server image.

For more information about multi-seat stand-alone install, see your product’s
installation documentation.

Activate Your Product

You can activate your Autodesk product either on startup or while you are
running the product. If you cannot activate online, offline activation is
available.

Register Your Product

Depending on your product, registration is optional or required. If required,
you are asked to create a user Autodesk ID and associate this ID with an
individual or company account. If registration is optional, you can choose to
postpone it, and you will be reminded periodically to register.

Manage Your Stand-Alone License

This section provides information about advanced stand-alone licensing tasks
such as license types and behaviors, viewing product information, saving your
license file as a text file, updating your serial number, and transferring a license.

Check Product Information

You can view detailed information about your Autodesk product and your
product license (such as the license usage type and the license behavior), and
then save this information as a text file.

License usage types

NOTE All license types are available as stand-alone and network except for the
Student Portfolio license, which is available as stand-alone only.

Commercial A license for a product that was purchased commercially.
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Not for Resale A license for a product that is not sold commercially.

Educational (EDU)/Institution A license designed specifically for educational
institutions.

Student Portfolio A license for students who are using an Autodesk product
as part of their curriculum.

License behaviors

Trial A license that allows individuals to try the product in trial mode for a
specified number of days. The trial period starts the first time you launch your
product. When the trial period expires, the product must be registered and
activated to continue use.

Permanent Allows permanent use of an Autodesk product.

Term Extendable Allows access to an Autodesk product for a limited time.
The term can be extended at any time.

Term Non-Extendable Allows access to an Autodesk product for a limited
time. The term cannot be extended.

View Product Information

You can view detailed information about your Autodesk product and your
product license, such as the license usage type and the license behavior.

To view product information

1 Launch your Autodesk product.
2 On the Help menu, click About.
3 In the About [Autodesk Product] window, click Product Information.

4 In the Product Information dialog box, view details about your product
and the product license.

5 In the Product Information dialog box, click Close.

Save License Information as a Text File

You can save your product license information as a text file.
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To save license information as a text file

1 Launch your Autodesk product.

2 On the Help menu, click About.

3 In the About [Autodesk Product] window, click Product Information.
4 In the Product Information dialog box, click Save As.
5

In the Save As dialog box, name the file, choose a location where you
want to save the file, and then click Save.

6 In the Product Information dialog box, click Close.

Update Your Serial Number

Your valid serial number is located on the outside of the product packaging
or in the Autodesk Upgrade and Licensing Information email you received if you
downloaded your product.

When you register and activate your product, you are asked for the product
serial number, which is automatically entered upon completion of the
activation process.

If you have a multi-product bundle of software that uses a single serial number,
only the first product you register and activate displays the updated serial
number. For other products to display the serial number, you must update it
from the Help menu.

NOTE For the updated serial number to display, you must be logged into the
system with Administrator rights.

To update your serial number

1 Launch your Autodesk product.
2 On the Help menu, click About.
3 In the About [Autodesk Product] window, click Product Information.
4 In the Product Information dialog box, click Update.
5

In the Update the Serial Number dialog box, enter your product serial
number.
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The serial number is located on the outside of the product packaging or
in the Autodesk Upgrade and Licensing Information email you received if you
downloaded your product.

NOTE If you have lost your serial number, contact the Autodesk Business
Center (ABC) at 800-538-6401 for assistance.

6 Click OK. You can now see the updated serial number.

Transfer Your Stand-Alone License

You can use an Autodesk product on more than one computer without
purchasing a separate license for each computer. License transfers are only
supported on products that require the creation of an Autodesk ID as part of
the registration and activation process.

About the License Transfer Utility

The License Transfer Utility transfers a product license online from one
computer to another, and ensures that the product works only on the computer
that contains the license. The License Transfer Utility is a custom stand-alone
installation option. During installation, a shortcut is created. A shortcut is
installed once per product, per workstation.

You may want to transfer a license to a computer temporarily (if you want to
use an Autodesk product on your laptop, for example) or permanently (if the
computer where you originally activated your Autodesk product is being
replaced). You can leave the license on the secondary computer indefinitely,
or you can move the license between computers as needed.

License transfers rely on the product’s serial number. Before an Autodesk
product can be exported, it must be activated with the serial number and
product key. During license import, a previously activated and exported license
is imported to a product or product suite installed with the same serial number.
The activation is transferred to the import computer, completing the license
transfer.

Transfer Your Stand-Alone License | 5



NOTE The number of concurrent exports you can have, is equal to the number
of seats you own. For example, if you own one seat you can have one export in
progress at a time. You cannot complete another export until the one in progress
has been imported. Similarly, if you have five seats, you can have up to five
concurrent exports in progress at one time.

NOTE When you upgrade your Autodesk product (non-subscription), you can no
longer perform online license transfers of the previous license.

NOTE Although the License Transfer Utility allows you to transfer your product
license between computers, your license agreement may not allow the installation
of an Autodesk product on more than one computer. Read your license agreement
to find out whether your product license permits the use of the License Transfer
Utility.

To transfer a license you must have an Internet connection, have an Autodesk
product installed on both computers, and perform an online export and import
of the license.

Install the Autodesk Product

Before you can use the License Transfer Utility to transfer licenses, you must
have an Autodesk product installed on all computers involved in the transfer.

To install the Autodesk product
1 Install and activate the Autodesk product on a computer.

See your product's installation instructions for complete details.

2 Install the Autodesk product on any other computer that will be using
the License Transfer Utility. You do not have to register or activate the
product on this computer.

See your product's installation instructions for complete details.

Export a License

A license is exported when the License Transfer Utility moves a product license
from a computer to the online Autodesk server.

The license can be exported as public or private. Exporting a license as public
means that you are not reserving the license and anyone using the same serial
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number and their own user ID and password can import that license. Exporting
a license as private means that you are reserving that license for yourself and
the license can only be imported with the same serial number, your user ID,
and your password.

NOTE An Internet connection is required to export a license.

To export a license

1 On the computer where you want to export the license, do the following:

B (Windows XP/Windows 7/Windows Vista) Click Start » All Programs
» Autodesk » [Autodesk Product] » License Transfer Utility.

The Export the License dialog box displays the Autodesk product name
and serial number.

2 In the Export the License dialog box, click Sign In.

3 On the Log In page, enter your Autodesk user ID and password and click
Log In.

4 On the License Export page, confirm the export information.

5 [If you want to make the license available as a public import, click Make
the license available as a public import.

6 Click Export.

7 On the License Export Confirmation page, click Finish.

Import a License

A license is imported when the License Transfer Utility moves a previously
exported product license from the online Autodesk server to a computer.

When you have exported a product license from a computer, you complete
the license transfer process by importing that license onto a computer. A
license is imported when the License Transfer Utility creates an active license
on a computer, allowing your Autodesk product to run on this computer.

When you use the License Transfer Utility to import a license to a computer,
you are not activating the product on the computer; you are simply transferring
your activation to this machine.

NOTE An Internet connection is required to import a license.
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To import a license

1

On the computer where you want to import the license, do the following:

B (Windows XP/Windows 7/Windows Vista) Click Start » All Programs
> Autodesk » [Autodesk Product] » License Transfer Utility.

The Import the License dialog box displays the Autodesk product name
and serial number.

In the Import the License dialog box, click Sign In.

On the Log In page, enter your Autodesk user ID and password and click
Log In.

On the License Import Confirmation page, click Finish.

The license is now imported to the computer and you can run your
Autodesk product on this computer. If you want to transfer the license
to another computer, repeat the export and import procedures.

To import a license to replace a trial license

1

On the computer where you want to import the license, do the following:

B (Windows XP/Windows 7/Windows Vista) Click Start » All Programs
» Autodesk » [Autodesk Product] » License Transfer Utility.

The Update the Serial Number and Product Key dialog box displays the
Autodesk product name and serial number.

In the Update the Serial Number and Product Key dialog box, enter the
serial number and product key to update your Autodesk product. Click
Update.

The Import the License dialog box displays the Autodesk product name
and updated serial number.

In the Import the License dialog box, click Sign In.

On the Log In page, enter your Autodesk user ID and password and click
Log In.

On the License Import Confirmation page, click Finish.

The license is now imported to the computer and you can run your
Autodesk product on this computer. If you want to transfer the license
to another computer, repeat the export and import procedures.
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Troubleshoot a Stand-Alone License Error

When you activate your Autodesk product, only the computer that you used
to activate the product is licensed to run the product. If you make certain
changes to your computer, your stand-alone license might fail. You will receive
a license error and you will not be able to use your product. This section
discusses ways in which you can troubleshoot a license error.

Some license errors require you to reactivate your product. If you need to
reactivate your product, the Product Activation wizard is displayed when you
try to run the product. To reactivate your product, follow the instructions in
the Product Activation wizard.

The following topics offer more details regarding specific errors.

Hardware Changes

If you replace or reconfigure hardware on the computer where your Autodesk
product license resides, the stand-alone license might fail. You will not be able
to use your product.

To prevent damage to your product license, use the License Transfer Utility
to export your license file. After you make the hardware change, you can
import the license file back. For instructions about using the License Transfer
Utility, see Transfer Your Stand-Alone License on page 5.

NOTE If you get a license error when you change your hardware, you may have
to reactivate your license. See Activate Your Product on page 2.

Reinstalling an Operating System

If you reinstall your operating system on the computer where your Autodesk
license resides, the license might fail. You will not be able to use your product.

To resolve a license error in this case, you must reactivate your product. See
Activate Your Product on page 2.

To prevent a license error when you reinstall an operating system

NOTE If using Norton Ghost™ or another image utility, do not include the Master
Boot Record.
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1 Locate one of the following folders and make a backup copy:

B (Windows XP) C:\Documents And Settings\All Users\Application
Data\FLEXnet

B (Windows 7/Windows Vista) C:\ProgramData\FLEXnet

2 Reinstall the operating system and reinstall the Autodesk product.

3 Paste the license folder to the same location from which you originally
copied the folder in step 1.

You can now run your Autodesk product.

Changing the System Date and Time

Your product license allows for time changes to the system clock within two
days of the current time. If you set your system clock back more than two
days, the next time you start your product, you will receive a message that
gives you the option of correcting the system clock. If you do not correct the
system clock, you receive a license error.

To prevent a license error due to a change in system date and time

B Make sure that your computer's system date and time are accurate when
you install and activate your Autodesk product.

Distributing Software Image to Multiple Computers

You can use the Deployment Wizard’s Stand-alone option to create a software
installation image on your server. You can distribute this image by making it
available on your computer network. During creation of this image, you are
prompted for registration information, which is stored with the image and
deployed to all installations.

Additionally, you can manually distribute the software using the installation
CD that comes with your Autodesk product. However, if your computers do
not have an Internet connection, make sure the registration data for each
computer matches exactly. Inconsistent registration data can cause activation
failures.
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To prevent a license error when distributing software image to multiple
computers

B The distribution of applications using “ghosting” is not recommended,
and can result in incomplete installations and activation problems.

Preserving Licenses on Re-Imaged Computers

On a network license server, licenses are maintained on the server. No
additional steps are needed to preserve network licenses.

For stand-alone licenses, you need to export the licenses to a safe place before
re-imaging the computers. You can use the License Transfer Utility to export
the licenses. After the re-imaging, import the licenses to the correct computer.
Each license only works on the computer for which it was created.

Preserving Licenses on Re-Imaged Computers | 11
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Network Licensing

A network license allows you to run an Autodesk product on a network. Network licenses can
be purchased through your Authorized Autodesk Reseller.

Setting up network licenses for an Autodesk product requires careful planning and execution.
This section gives you instructions about how to set up a network licensed environment, and
assumes that you are familiar with the terminology and processes required to set up an
Autodesk product to run on a network.

Plan Your Network Licensing

This section contains information that you need to know before you set up a
network license server. The section includes information about supported license
server models, license operation and availability, network license file definitions
and parameters, license file examples, license types and behaviors, and the
license server heartbeat signal.

System Requirements for the Network License Manager
(Windows)

Make sure that your network license server meets the minimum recommended
requirements. See the following tables for hardware and software requirements.

13



NOTE The Network License Manager supports Ethernet network configurations
only.

Hardware and software requirements for the network license server (Windows)

Hardware/Software Requirement

Operating System Windows® 7® 32-bit
Windows 7 64-bit
Windows 7 Starter (32-bit)

Windows 7 Home Basic (32-bit)
Windows 7 Home Premium
Windows 7 Professional

Windows 7 Ultimate

Windows 7 Enterprise

Windows Vista 32-bit SP2 or later
Windows Vista 64-bit SP2 or later

B Windows Vista Enterprise
B Windows Vista Business

B Windows Vista Ultimate

B Windows Vista Home Premium and Basic (32-bit)
|

Windows Vista Home Premium (64-bit)

Windows XP 32-bit SP2 or later
Windows XP 64-bit SP2 or later
B Windows XP Home

B Windows XP Professional

Windows Server 32-bit SP1 or later
Windows Server 64-bit SP1 or later
B  Windows 2008 Server R2

B  Windows 2008 Server
B  Windows 2003 Server R2
B  Windows 2003 Server
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Hardware and software requirements for the network license server (Windows)

Hardware/Software

Requirement

Computer/processor

Intel® Pentium® IIl or higher
450 Mhz (minimum)

Network interface card

Compatible with existing Ethernet network infrastructure

NOTE The Network License Manager supports multiple network interface
cards, but at least one must be an Ethernet card.

Communication protocol

TCP/IP

NOTE The Network License Manager uses TCP packet types.

Browsers Internet Explorer® 6
Internet Explorer 7
Internet Explorer 8
FLEXnet 11.7.0.0

Virtual Machine Support (Windows)

Hardware

Virtualizer

Virtual OS

Intel PC 64

Windows 2008 or Windows
2003R2 servers running on VM-
ware® ESX3.5 Update 3 (License
Manager Only)

Vista 64-bit, Vista 32-bit, Windows XP
32-bit, Windows 7 32-bit (Home
Premium, Professional, Ultimate, and
Enterprise), Windows 7 64-bit, Win-
dows Server 32-bit, Windows Server
64-bit

Plan Your License Server Configuration

You must decide which license server model to use for managing your Autodesk
product licenses on a server. Autodesk supports the following network license
server models:

W Single license server model

B Distributed license server model

B Redundant license server model

Plan Your License Server Configuration | 15



Single License Server Model

In the single license server model, the Network License Manager is installed
on a single server, so license management and activity is restricted to this
server. A single license file represents the total number of licenses available
on the server.

Advantages of the Single License Server Model

B Because all license management takes place on a single server, you have
just one point of administration and one point of failure.

B Of the three license server models, this configuration requires the least
amount of maintenance.
Disadvantage of the Single License Server Model

W If the single license server fails, the Autodesk product cannot run until the
server is back online.

Distributed License Server Model

In the distributed license server model, licenses are distributed across more
than one server. A unique license file is required for each server. To create a
distributed license server, you must run the Network License Manager on each
server that is part of the distributed server pool.

Advantages of the Distributed License Server Model

B Servers can be distributed across a wide area network (WAN); they do not
need to exist on the same subnet.

B If one server in the distributed server pool fails, the licenses on the
remaining servers are still available.

B If you need to replace a server in the distributed server pool, you do not
need to rebuild the entire pool.

B Server replacement is easier than in a redundant server pool, where you
must reactivate the entire pool.

Disadvantage of the Distributed License Server Model

B If a server in the distributed server pool fails, the licenses on that server
are unavailable.
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Redundant License Server Model

In the redundant license server model, you use three servers to authenticate
a single license file. One server acts as the master, while the other two provide
backup if the master server fails. With this configuration, licenses continue
to be monitored and issued as long as at least two servers are still functional.
The license file on all three servers is the same. You must install the Network
License Manager on each server.

In the redundant license server model, all servers must reside on the same
subnet and have consistent network communications. (Slow, erratic, or dial-up
connections are not supported.)

Advantage of the Redundant License Server Model

B If one of the three servers fails, all licenses that are managed in the server
pool are still available.

Disadvantages of the Redundant License Server Model

B If more than one server fails, no licenses are available.

B All three servers must reside on the same subnet and have reliable network
communications. The redundant server pool does not provide network
fault tolerance.

B If one of the three servers is replaced, the complete redundant server pool
must be rebuilt.

B If your Autodesk product supports license borrowing and licenses are
borrowed from a redundant license server pool, you must restart the license
server after you stop the Network License Manager.

Learn About Your License

In this section, you learn about license operation and availability, the license
file, license types and behaviors, and the heartbeat signal.

License Operation and Availability

When you start an Autodesk product, the product determines the server from
which it should try to obtain a license. The product then requests a license
through the TCP/IP network protocol to the license server.
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If the number of available licenses has not been exceeded on the license server,
the Network License Manager assigns a license to the workstation. A product
session then starts on the workstation, and the number of available licenses

on the license server is reduced by one.

Likewise, when you exit a product, the Network License Manager frees a license
for another user. If you run multiple sessions of an Autodesk product on an
individual workstation, only one license is used. When the last session is
closed, the license is freed.

The following three processes manage the distribution and availability of
licenses:

B License manager daemon (Imgrd.exe). Handles the original contact with
the application, and then passes the connection to the vendor daemon.
The Imgrd.exe daemon is used to communicate with the vendor daemon
only; Imgrd.exe does not authenticate or dispense licenses, but rather passes
user requests to the vendor daemon. By using this approach, a single
Imgrd.exe daemon can be used by multiple software vendors to provide
license authentication. The Imgrd.exe daemon starts and restarts the vendor
daemons as needed.

B Autodesk vendor daemon (adskflex.exe). Tracks the licenses that are checked
out and the workstations that are using them. Each software vendor has
a unique vendor daemon to manage vendor-specific licensing. As its name
implies, the adskflex.exe vendor daemon is specific to Autodesk products.

NOTE If the adskflex.exe vendor daemon terminates for any reason, all users lose
their licenses until Imgrd.exe restarts the vendor daemon or the problem causing
the termination is resolved.

B License file. A text file that has vendor-specific license information.

License Files

The network license file you receive from Autodesk contains licensing
information required for a network installation. You obtain license file data
when you register your Autodesk product.

The license file contains information about network server nodes and vendor
daemons. It also contains an encrypted digital signature that is created when
Autodesk generates the file.
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The license file is located in a network location that you specify in the

Deployment wizard. That network location must be accessible to every user

who runs the product from a network installation.

The following table defines each license file parameter.

Definitions of license file parameters

Line Parameter Definition Example
SERVER Host Name Host name of the server where the LABSERVER
Network License Manager resides
Host ID Ethernet address of the server where  03D054C0149B
the Network License Manager resides
USE_SERVER  [None]
VENDOR Vendor Daemon Name of the server-side Autodesk adskflex.exe
vendor daemon
Port Number Network port number reserved and  port=2080
assigned for use only by Autodesk
products running the Autodesk
vendor daemon
PACKAGE Name Name of feature code group SERIES_1
Version Internal version number reference 1.000
COMPONENTS List of feature codes supported inthe ~ COMPONENTS=
package "526000REVIT_9_OF\
51200ACD_2007_OF\
513001IN-
VBUN_11_OF"
OPTIONS OPTIONS=SUITE
SUPERSEDE Replacement for any existing Incre- ~ SUPERSEDE

ment line of the same feature code
from any license files on the same li-
cense server that have a date earlier
than the defined Issue Date

Learn About Your License | 19



Definitions of license file parameters

Line Parameter Definition Example
SIGN Encrypted signature used to authen- ~ SIGN=0 SIGN2=0
ticate the attributes of the license file
INCREMENT  Feature Code Product supported by the license file ~ 51200ACD_2007_OF
Expiration Date Amount of time the licenses are permanent
available
Number of Licenses Number of licenses supported by the 25
license file
VENDOR_STRING License usage type and license beha- COMMERCIAL

vior of the product that is supported
by the license file

BORROW

Definition of the license borrowing
period for the licenses defined under
the same increment line.

In this example, the maximum peri-
od that licenses can be borrowed is
4320 hours (180 days), unless other-
wise noted (for example, BOR-
ROW=2880 means that licenses can
be borrowed for a maximum of
2880 hours, or 120 days).

License borrowing is disabled when
this parameter is absent in the li-
cense file.

BORROW=4320

DUP_GROUP

Definition of multiple license re-
quests when the same user and same
host share the same license

DUP_GROUP=UH

ISSUED

Date that the license file was gener-
ated by Autodesk

15-jul-2006

Serial Number

Serial number of the Autodesk
product

123-12345678
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Definitions of license file parameters

Line

Parameter Definition Example

SIGN Encrypted signature used to authen- ~ SIGN=6E88EFA8D44C
ticate the attributes of the license file

License File Examples

License file examples are provided in this document to help you understand
how the license files work for your particular network setup. Autodesk provides
a standard license file for individual products and a license file with additional
parameters for products that are sold both individually and as part of a product
set.

B Standard License File. If you purchase one or more individual products
that are not offered as part of a suite of products, you receive a standard
license file.

B Standard License File with Additional Parameters. If you purchase Autodesk
products that are included in a product set and are also sold as an individual
product, you receive a standard license file with additional parameters
included in the license file. The additional parameters define the sequence
for license usage so that the individual product license is used before the
license for the product set.

Autodesk license file examples include a license file not specific to a product,
completed license files for single, distributed, and redundant server models,
a combined product version license file, and an example of additional
parameters added to a standard license file.

Example of a License File Not Specific to a Product

Here is an example of the contents of a license file and the parameters
associated with each line:
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SERVER ServerName HostID

USE_SERVER

VENDOR adskflex port=portnumber
INCREMENT feature code Adskflex Version ExpDate NumberofLicenses

\

VENDOR_STRING=UsageType:Behavior BORROW=4320 SUPERSEDE \
DUP_GROUP=DupGrp ISSUED=IssueDate SN=SerialNumber SIGN= \

Example of a License File for a Single or Distributed

Server

Here is an example of a completed license file for a single or distributed license

server model:

SERVER XXHP0528 0019bbd68993

USE_SERVER

VENDOR adskflex port=2080
INCREMENT 57600ACD_ 2009 OF adskflex 1.000 permanent 5 \
VENDOR_STRING=commercial:permanent BORROW=4320 SUPERSEDE \

DUP_GROUP=

E368 816E
7D79 BEEL
057C A579

D821 BD37
62CD FA35

UH ISSUED=09-Jan-2008 SN=123-12345678 SIGN="1393 \

D417 C1CD 7DBD 7B90 1354 D6FO0 48FE EBB8 9C84 C3AF \
0181 0655 76FF 996C B707 14B5 D4DE A3FE 0B2D 2D36 \
7866 26BF 44E2" SIGN2="1280 943B 53A7 9B93 EOOB D967

BE6D B78A F074 B223 88AA 242C DDOA 1292 D56F 4108 \
E365 0736 A011 7833 8B35 7BFF DAD8 34A8 452F 2EB4"

Example of a License File for a Redundant Server

Here is an example of a completed license file for a redundant license server

model:
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SERVER CCN12378042 001cc4874b03 27005

SERVER XXHP0528 00190bd68993 27005

SERVER CCN12378043 001cc4874b10 27005

USE_SERVER

VENDOR adskflex port=2080

INCREMENT 57600ACD 2009 OF adskflex 1.000 permanent 5 \
VENDOR_STRING=commercial:permanent BORROW=4320 SUPERSEDE \
DUP_GROUP=UH ISSUED=10-Jan-2008 SN=123-12345678 SIGN="11C4 \
CA79 07FC 7ADO 409A 6E04 6E98 D76C 197C 0416 076C B211 1CDD \
DOAB 698B 16BF 7AQE D4F8 1CFE 2985 644F 64CD CECE 0ODDB 5951 \
3262 7C31 13A8 FO8F 55B2" SIGN2="19A6 FDA3 2ED5 5301 8675 7B81

1BOE 451B 19F1 1A99 C8E9 CBA6 8CB3 6AC3 8B38 1519 13F2 2373 \
82AE 55E5 1A25 4952 4458 F3A2 6F28 D25D 1DCO EO66 209B 0953"

NOTE The redundant server model requires the addition of a port number (the
default is 27005) for each server.

Example of a License File for Combined Autodesk
Product Versions

You can combine a license file for different releases of the same Autodesk
product or for different Autodesk products, and run all products from one
license server. For example, you can combine a license file for AutoCAD 2009
with license files for Autodesk Maya® 2009 and AutoCAD Map.

Here is an example of the contents of a combined license file for AutoCAD 2008
and AutoCAD 2009:
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SERVER XXHP0528 0019bbd68993

USE_SERVER

VENDOR adskflex port=2080

INCREMENT 57600ACD 2009 OF adskflex 1.000 permanent 5 \
VENDOR_STRING=commercial:permanent BORROW=4320 SUPERSEDE \
DUP_GROUP=UH ISSUED=09-Jan-2008 SN=123-12345678 SIGN="1393 \
E368 816E D417 CICD 7DBD 7B90 1354 D6F0 48FE EBB8 9C84 C3AF \
7D79 BEEl 0181 0655 76FF 996C B707 14B5 D4DE A3FE 0B2D 2D36 \
057C A579 7866 26BF 44E2" SIGN2="1280 943B 53A7 9B93 E00B D967

D821 BD37 BE6D B78A F074 B223 88AA 242C DDOA 1292 D56F 4108 \
62CD FA35 E365 0736 A011 7833 8B35 7BFF DAD8 34A8 452F 2EB4"
INCREMENT 54600ACD 2008 OF adskflex 1.000 permanent 3 \

VENDOR_STRING=commercial:permanent BORROW=4320 SUPERSEDE \
DUP_GROUP=UH ISSUED=09-Jan-2008 SN=123-12345678 SIGN="1E6E \
4B61 5712 4766 92A0 6782 9EF4 3F47 56A1 1F38 6DE8 COC7 90AC \
7289 152E OEA2 CCOD 3F10 577A 0489 CEB6 10D5 FBCC B552 0CO9D \
5966 91A6 59F0 2788 FACE" SIGN2="1DDF 3B9D 3392 71D5 ABO8 7E05

8497 111E 092F OE54 8DC2 2BED 17C2 2CCl 981B 0EC2 BC15 8F00 \
C79A ABFD 2136 BABA 2EDF E941 EA53 32C6 597F F805 5A8A 599A"

Example of Additional Parameters in a License File

For Autodesk products that are included in a product set and are also sold as
an individual product, licenses are allocated based on a sequence of priorities
defined in the license file. For those products, information similar to the
following example appears in a license file:

SERVER Serverl 1a34567c90d2

USE_SERVER

VENDOR adskflex port=2080

INCREMENT 54600ACD 2008 OF adskflex 1.000 permanent 5 \
VENDOR_STRING=commercial:permanent BORROW=4320 SUPERSEDE \
DUP_GROUP=UH ISSUED=09-Jan-2007 SN=123-12345678 SIGN="0247 \
45D6 87C4 27A5 T7F9E F24A ED3D 61E4 6B3B CC5C AD77 B865 9EA8 \
3D62 0792 0F67 19E7 57E7 FAFA A48B D582 335A EC1l6 1FE5 B70D \
76AB 6488 61CC DESE F5B7" SIGN2="09FD 0850 7CF1l F447 9F05 9FA3

2A0A 38D6 83FC 1746 F3F5 5A72 6250 E002 DEOB OE6E F88C AC95 \
136F 87F2 A945 E4C4 A9TF 44BS 74EE 83F3 3F3E 1579 B981 8994"
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Package License File Examples

Autodesk offers a package license file option, which allows you use of a set of
products that are packaged and sold together. The package license file contains
a set number of licenses for four different versions of your software. Running
an instance of any one of the versions uses one license in the package. Packaged
license files support prior versioning for subscription users. Package license
files operate under the following guidelines:

B Package license files come with the current version of the software and
three previous versions of the same product.

B License files may be combined with license files for different products. For
more information about combining license files, see Example of a Package
License File for Combined Autodesk Product Versions on page 27.

B Package license files cannot be combined with non-package license files
for product versions contained in the package. For example, you cannot
combine a Autodesk Product 2009 package license file with a regular license
file for Autodesk Product 2008, 2007, or 2006.

B Both the PACKAGE and INCREMENT sections of the license are required
for licensing to work properly. When you combine license files, be sure to
include both of these sections.

B License borrowing, option files, and licensing cascading work the same
for package licenses as they do for regular license files.

B A new license file will supersede an older license file.

The following sections provide package license file examples for single,
distributed, and redundant license servers, and combined Autodesk product
versions.

Example of a Package License File for a Single or
Distributed Server

Here is an example of a completed license file for a single or distributed license
server model:
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SERVER Serverl 1a34567c90d2

USE_SERVER

VENDOR adskflex port=2080

PACKAGE SERIES 1 adskflex 1.000 COMPONENTS="54700REVIT 2009 OF \
54600ACD_2009 OF 51300INVBUN 11 OF" OPTIONS=SUITE SUPERSEDE \
ISSUED=09-Jan-2008 SIGN="1707 9EAC CBCB 2405 692E 4A89 \
AA26 30CC 2AC2 D6B3 A61B ABSE 492E 3EBD 0B48 4E75 193A DA82" \
FC45 C009 E360 944A 14BA E99C 9B24 5A1B 4A44 083A BESF 3827 \
SIGN2="004A FC90 AB47 3F6B 59BC 0OE6D 6681 6971 A76A BA52 98E2

5671 26B3 0E78 791B 109F 0591 7DC3 FO9F 4D8D 4FB7 E341 4A03 \
CD68 1D77 27F8 8555 9CF7 DEDD 9380"
INCREMENT SERIES 1 adskflex 1.000 permanent 100 \

VENDOR STRING=commercial:permanent BORROW=4320 DUP_GROUP=UH \
SUITE DUP GROUP=UHV SN=123-12345678 SIGN="1707 9EAC CBCB \
692E 4A89 FC45 C009 E360 944A 14BA E99C 9B24 5A1B 4A44 BESF \
3827 AA26 30CC 2AC2 D6B3 A61B ABSE 492E 3EBD 0B48 DA82" \
SIGN2="004A FC90 AB47 3F6B 59BC 0E6D 6681 6971 A76A BA52 \
5671 26B3 0E78 791B 109F 0591 7DC3 FO9F 4D8D 4FB7 E341 4A03 \
CD68 1D77 27F8 8555 9CF7 DEDD 9380"

Example of a Package License File for a Redundant
Server

Here is an example of a completed license file for a redundant license server
model:
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SERVER 1a34567c90d2 27005

SERVER 2a34567c90d2 27005

SERVER 3a34567c90d2 27005

USE_SERVER

VENDOR adskflex port=2080

PACKAGE 64300ACD _F adskflex 1.000 COMPONENTS="57600ACD 2009 OF \
54600ACD 2008 OF 51200ACD 2007 OF 48800ACD 2006 _OF" \
OPTIONS=SUITE SUPERSEDE ISSUED=27-May-2008 SIGN="1092 05D8 \
A206 276B 2C84 EFAD ACAS5 C54B 68A4 653E C61F 31DE C8CE B532 \
CFBB 0006 5388 347B FDD6 A3F4 B361 7FD4 CDE4 4AAC 0D11 BOEF \
4B44 BFD6 3426 97DD" SIGN2="0670 BO1lA D060 0069 FF25 F1CD DO6B

314E E7C9 3552 5FFA 4AC7 28A7 C897 F56A 19BB FBIC 754E 6704 \
DEEA AC4E F859 2E9B 64B6 0DDO 9CCE 9556 269F EACO 2326"
INCREMENT 64300ACD_F adskflex 1.000 permanent 50 \
VENDOR_STRING=commercial:permanent BORROW=4320 SUPERSEDE \
DUP_GROUP=UH SUITE DUP GROUP=UHV ISSUED=27-May-2008 \
SN=399-99999999 SIGN="1B5B 8D70 4CAD 32E5 9CA2 82E0 5C47 291C

35AB
9D1E

31F5
9033
2EFE

9B9C 5B3E
63AB BC23

2951 4500
2018 0C3B
DFAE 027F

5067 F61B 4139 1B32 0716 1FD3 5105 A991 B78E \
OD1E B70C 2A05 EI1C1 F605 ABBl 2EA8" SIGN2="01D6

ES5C8 058F 7490 9789 9EF4 CBED DA27 5F06 6780 \
E1EO0 3580 E60E C2BB B4AB 8D6A 4245 3059 8CA6 \
2ABE 3F2B"

Example of a Package License File for Combined
Autodesk Product Versions

Here is an example of a completed license file for combined Autodesk product

versions:
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SERVER servername 123456789111
USE_SERVER
VENDOR adskflex port=2080

PACKAGE

64300ACD_F adskflex 1.000 COMPONENTS="57600ACD 2009 OF \

54600ACD 2008 0F 51200ACD 2007 OF 48800ACD 2006 OF" \
OPTIONS=SUITE SUPERSEDE ISSUED=25-Jun-2008 SIGN="03EF DE18 \

8046
B43B
E6E3

2F76
8811

0124 4EA4 6953 F82D 3169 7C24 DODE ES58E 8168 FFA3 D891 \
08D8 7E7F C6ED CBCC FE2A BBOA 4566 C2AE F1Cl D373 8348 \
884A E398 1C78" SIGN2="07AC D696 8844 D19F ABOO 8B75 53A3

91DF AEDO 3231 1506 OE6B ADC6 C3B8 1797 93B5 9756 8COF \
56E6 B2BA 0523 FE2E 82B7 1628 076F 173B F37C 7240"

INCREMENT 64300ACD_F adskflex 1.000 permanent 2 \
VENDOR_STRING=commercial:permanent BORROW=4320 SUPERSEDE \
DUP_GROUP=UH SUITE DUP_GROUP=UHV ISSUED=25-Jun-2008 \
SN=399-99999999 SIGN="1CCB E88D B819 8604 06FA 9AEE 42F1 CBEA

37B9
D5DD

FAGFE
7024
6916
PACKAGE

3CFA AOA8 697F 9CB1l 8354 6256 05ED 69D4 D2FF D512 6A2E \
B722 EF5B 3172 BA95 4625 F8D3 DD24 BB39 6A58" SIGN2="O0ODFF

C378 20EQ0 2622 BE52 B434 F99F 2681 2B93 64F2 CEOC 7F4A \
B3D1 051A 6920 72BD DE35 8920 E6Al C8D6 AF23 7BE7 CC91 \
70B1 9EB0 ABO7 1644"

64800INVPRO_F adskflex 1.000 \

COMPONENTS="59600INVPRO_2009 OF \
55300INVPRO_2008 OF 51400INVPRO 11 OF 49000INVPRO_10 OF" \
OPTIONS=SUITE SUPERSEDE ISSUED=25-Jun-2008 SIGN="1306 5990 \

F8Al
4AAA
3849

3001
AC81

56FB 1D8A 9DA7 D6AE 8EO9E F6EC 2862 367A 36E2 C5FB E6EL \
0128 8C2D 95FD 09B2 ABAl 6F98 AOA3 70DE 3220 6835 7E51 \
9D81 8BDC 9DC1" SIGN2="0021 AAO08 F2E7 8AEB 5345 341A T7E42

B8C5 DFC2 6EB8 87C5 CO4A AE43 AlQF 1DA1l EF8A FOFA 10F5 \
1E22 789F Al8D 650F 6BBB 563A BDAS5 DD1C 82EC 27F6"

INCREMENT 64800INVPRO_F adskflex 1.000 permanent 2 \
VENDOR_STRING=commercial:permanent BORROW=4320 SUPERSEDE \
DUP_GROUP=UH SUITE DUP_ GROUP=UHV ISSUED=25-Jun-2008 \
SN=399-99999966 SIGN="0BE4 51F4 570C DC48 5E66 F952 629E EDFO

019C
E655

3E37
205D

6FF7 0509 1FF0 D4FB 3B16 1981 073F 31EC A241 8CB3 8782 \
00C6 E097 DSEF BOD8 67D3 199D 699D 2E09 Bl6F" SIGN2="1254

0CE4 F42D B7CD 858C 92FC A963 5274 770F 9354 FE29 E117 \
C632 0C4E AECO 7501 9D9E FFEB D84D F154 16A1 E120 339A \
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License Types and Behaviors

Autodesk supports dynamic product usage and license behaviors. This means
that you can purchase a specific type of behavior with a specific license and
change that license at a later date without having to uninstall and reinstall
the Autodesk product.

NOTE All license types are available as stand-alone and network except for the
Student Portfolio license, which is available as stand-alone only.

License types include the following:
B Commercial. A license for a product that was purchased commercially.

B Not for Resale. A license for a product that is not sold commercially. Not
for Resale products are for evaluation or demonstration purposes only and
may not be used for commercial or production use.

B Educational (EDU)/Institution. A license designed specifically for
educational institutions.

B Student Portfolio. A license for students who are using an Autodesk product
as part of their curriculum.

License behaviors are as follows:
B Permanent. Enables permanent use of an Autodesk product.

B Term Extendable. Enables access to an Autodesk product for a limited time.
The term can be extended at any time.

B Term Non-Extendable. Enables an Autodesk product for a limited time.
The term cannot be extended.

Heartbeat Signal

When an Autodesk product is running, it communicates with the license
server at regular intervals using a communication method known as the
“heartbeat” signal. If the heartbeat signal is lost, the server tries to reconnect.
If the server cannot reconnect, the user receives a license error.
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If the product stops working because it has lost a connection to the server,
you must shut down the product, and then restart it. If the problem causing
the original loss of the heartbeat signal is resolved and there are available
licenses on the server, the program can be restarted.

Network License Manager

The Network License Manager is used to configure and manage the license
servers. When creating a deployment, the Installation wizard prompts you
for information about the license manager, such as license server model and
server name.

For more information about deploying an Autodesk product from a network
location, see your product’s installation documentation.

Install the Network License Manager

You can install the Network License Manager before or after you use the
Installation wizard. The order in which you install the network applications
does not matter, as long as you install everything you need and you provide
consistent license server information across the network applications.

If an earlier version of the Network License Manager is already installed on
the computer, you should upgrade by installing the Autodesk Network License
Manager into the folder where the older version was located.

To install your Network License Manager

1 In the Autodesk Installation wizard, click Install Tools and Utilities.

2 On the Select the Products to Install page, select Autodesk Network License
Manager and click Next.

3 Review the Autodesk software license agreement for your country or
region. You must accept this agreement to proceed with the installation.
Choose your country or region, click I Accept, and then click Next.

NOTE If you do not agree to the terms of the license and want to terminate
the installation, click Cancel.

4 On the Begin Installation page, review your product selection and the
current settings. If you do not want to change anything, click Install. If
you want to change the install type or installation path, click Configure.
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5 On the Select the Installation Location page, accept the default installation
path (C:\Program Files\Autodesk Network License Manager) or Browse to
specify a different path. If you enter a path that does not exist, a new
folder is created using the name and location you provide. Click Next.

WARNING Do not install the Network License Manager on a remote drive.
When you install the Network License Manager files, you must provide a path
to a local drive. You must specify the drive letter; the universal naming
convention (UNC) is not permitted.

6 On the Configuration Complete page, click Configuration Complete to
return to the confirmation page.

7 On the Begin Installation page, click Install.

8 When the Installation Complete page displays, click Finish.

Obtain a License Through autodesk.com

You can register and activate your network license by going to
https://registeronce.autodesk.com and following the on-screen instructions.

Obtain the Server Host Name and Host ID Manually
Autodesk uses the server host name, host ID, and product serial number to

generate a license file.

To obtain the information manually, you can use the command prompt or
you can run the Imtools.exe utility. If you use Imtools.exe, do not run it on a
remote workstation.

To obtain the host name and ID using the Windows command prompt

1 Do the following:

B (Windows XP/Windows Vista) Click Start » All Programs »
Autodesk » [Autodesk Product] » License Transfer Utility.

2 At the Windows command prompt, enter the following command, and
then press ENTER:

ipconfig /all

3 Locate the Host Name line, and write down the host name.
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4 Locate the Physical Address line. Write down the physical address without
the dashes. This is your twelve-character host ID.

NOTE If your server has more than one network adapter, select the one that
corresponds to a physical network adapter. To determine which adapters are
physical: in the Windows command prompt, enter ipconfig /all, and then
view the Description field above each physical address. If there is more than
one physical network adapter, it does not matter which one you use. Devices
such as VPN adapters, PPP adapters, and modems are not valid.

5 Close the Windows command prompt.

To obtain the host name and ID using Imtools.exe

You should be logged in with Administrator rights when working with the
LMTOOLS utility.

1 Click Start » All Programs » Autodesk » Network License Manager
» LMTOOLS Utility.

2 In the LMTOOLS program, click the Systems Settings tab.

3 On the Systems Settings tab, locate the Computer/Hostname box. Copy
the host name and paste the information into a text editor.

4 Locate the Ethernet Address box. The Ethernet address is the host ID. It
consists of twelve characters. Write down the information. If your Ethernet
address is more than twelve characters, write down the first twelve
characters only.

NOTE If your server has more than one Ethernet adapter, select one that
corresponds to a physical network adapter.

5 Close Imtools.exe.

Configure a License Server (Windows)

You configure a license server so that you can manage your Autodesk product
licenses. Configure the license server with the Imtools.exe utility.
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To configure your license server

You should be logged in with Administrator rights when working with the
LMTOOLS utility.

1 Click Start » All Programs » Autodesk » Network License Manager
» LMTOOLS Utility.

2 Inthe LMTOOLS program, on the Service/License File tab, make sure the
Configure Using Services option is active.

3 Click the Config Services tab.

4 In the Service Name list, select the service name you want to use to
manage licenses.
By default, the service name is Flexim Service 1. If FLEXnet® is managing
other software on your computer in addition to Autodesk, you can change
the service name to avoid confusion. For example, you can rename FlexIm
Service 1 to Autodesk Serverl.

NOTE If you have more than one software vendor using FLEXnet for license
management, the Service Name list contains more than one option. Make
sure that only one Autodesk service is listed.

5 Inthe Path to Lmgrd.exe File field, enter the path to the Network License
Manager daemon (Imgrd.exe), or click Browse to locate the file.

By default, this daemon is installed in the C:\Program Files\ Autodesk
Network License Manager folder.

6 In the Path to the License File box, enter the path to your license file, or
click Browse to locate the file.

This is the path to the license file obtained through autodesk.com or the
location where you placed the license file if you obtained it offline.

7 In the Path to the Debug Log File box, enter a path to create a debug log,
or click Browse to locate an existing log file.

It is recommended that you save to the C:\Program Files\ Autodesk Network
License Manager folder. The log file must have a .log file extension. For
new log files, you must enter the .log extension manually.

8 To run Imgrd.exe as a service, select Use Services.

9 To start Imgrd.exe automatically when the system starts, select Start Server
at Power Up.
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10 Click Save Service to save the new configuration under the service name
you selected in step 4. Click Yes when prompted if you would like to save
the settings to the service.

11 Click the Start/Stop/Reread tab and do one of the following:

B If a service has not yet been defined for Autodesk, click Start Server
to start the license server.

B If a service for Autodesk is already defined and running, click ReRead
License File to refresh the Network License Manager with any changes
made to the license file or Options file.

The license server starts running and is ready to respond to client requests.

12 Close Imtools.exe.

NOTE Before performing any system maintenance on your license server,
see Stop and Restart the License Server on page 36.

Install SAMreport-Lite (Optional)

SAMreport-Lite is a reporting tool that helps you track network license usage.
With SAMreport-Lite technology from Acresso™ Software, you can monitor
client usage for Autodesk network licensed products.

To learn more about installing and using SAMreport-Lite, see the SAMreport-Lite
User’s Guide.

Uninstall the Network License Manager

You can uninstall the Network License Manager from the license server. When
you uninstall the Network License Manager, licenses are no longer available
to your users.

To uninstall the Network License Manager

1 Click Start » All Programs » Autodesk » Network License Manager
>» LMTOOLS Utility.

2 In the LMTOOLS program, click the Start/Stop/Reread tab.
3 On the Start/Stop/Reread tab, click Stop Server.
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4 Close Imtools.exe.

5 In the Windows Control Panel, do one of the following:
B (Windows XP) Double-click Add/Remove Programs.
B (Windows 7/Windows Vista) Double-click Programs and Features.

Do one of the following:

B (Windows XP) In the Add/Remove Programs window, click Autodesk
Network License Manager. Click Remove.

B (Windows 7/Windows Vista) In the Programs and Features window,
click Autodesk Network License Manager. Click Remove.

6 If prompted, restart your computer.

NOTE You must manually delete files that you created for use with the Network
License Manager (such as log files, license files, and the Options file). They are not
automatically deleted when you uninstall the Network License Manager.

Network Licensing Tools

Autodesk Network licensing tools include FLEXnet configuration tools, license
borrowing, and SAMreport-Lite. Each tool is described in the sections that
follow.

This section also includes information for updating FLEXnet and installing
and configuring the Autodesk Network License Manager on a network.

FLEXnet Configuration Tools

The Network License Manager uses FLEXnet® license management technology
from Acresso Software. FLEXnet provides administrative tools that help to
simplify management of network licenses. You can use FLEXnet tools to
monitor network license status, reset licenses lost to a system failure,
troubleshoot license servers, and update existing license files on the fly.

Utilities for License Server Management

FLEXnet provides two utilities for managing the license server. These tools
are located in the C:\Program Files\ Autodesk Network License Manager folder.
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Imtools.exe Provides a Microsoft® Windows graphical user interface for
managing the license server.

Imutil.exe Provides a set of command line options for managing the license
server.

You can use Imtools.exe or Imutil.exe to perform the following server
management tasks:

Start, stop, and restart the server.
Configure, update, and reread the license file.

Diagnose system or license problems.

View server status, including active license status.

Stop and Restart the License Server

Before you can perform any system maintenance on your license server, you
must stop the license server. When you have completed maintenance, you
can restart the license server.

To stop the license server (Windows)

You should be logged in with Administrator rights when working with the
LMTOOLS utility.

1 Click Start » All Programs » Autodesk » Network License Manager
» LMTOOLS Utility.

2 In the LMTOOLS program, on the Service/License File tab, select the
Configure Using Services option.

Select the service name for the license server you want to stop manually.
Click the Start/Stop/Reread tab.

On the Start/Stop/Reread tab, click Stop Server.

A »n A~ W

Close Imtools.exe.
To restart the license server (Windows)

You should be logged in with Administrator rights when working with the
LMTOOLS utility.
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1 Click Start » All Programs » Autodesk » Network License Manager
>» LMTOOLS Utility.

2 In the LMTOOLS program, on the Service/License File tab, select the
Configure Using Services option.

3 Select the service name for the license server you want to start manually.
4 Click the Start/Stop/Reread tab.

5 On the Start/Stop/Reread tab, click Start Server to restart the license server.

Update FLEXnet from a Previous Version

This release of Autodesk products and later require FLEXnet version 11.7.0.0
or later. If you are currently using a version of FLEXnet that is earlier than
11.7.0.0, you need to upgrade to version 11.7.0.0 or later.

NOTE If the server where you plan to install the Autodesk Network License
Manager has FLEXnet installed for another product, make sure that the version of
Imgrd.exe is the most current version.

To determine what version of FLEXnet is installed, you need to verify the
version of the following files:

Windows

B [mgrd.exe
B [mtools.exe
B [mutil.exe
|

adskflex.exe

To verify the version of Imutil.exe, Imtools.exe, or adskflex.exe (Windows)

You should be logged in with Administrator rights when working with the
LMTOOLS utility.

1 Click Start » All Programs » Autodesk » Network License Manager
» LMTOOLS Utility.

2 In Imtools.exe, click the Utilities tab.
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3

On the Utilities tab, enter the location of the file, or click the Browse
button to locate the file and click Open. The file location should look
something like this:

C:\Program Files\ Autodesk Network License Manager\Imutil.exe

On the Utilities tab, click Find Version.

The version number of the file you selected is displayed. If necessary, use
the following procedure to update your version of FLEXnet.

To update FLEXnet (Windows)

You should be logged in with Administrator rights when working with the
LMTOOLS utility.

1
2

AN U A~ W

10
11

Back up your license files.

Click Start » All Programs » Autodesk » Network License Manager
» LMTOOLS Utility.

In the LMTOOLS program, click the Start/Stop/Reread tab.
On the Start/Stop/Reread tab, click Stop Server.
Close Imtools.exe.

Note the location where the Network License Manager is installed and
then uninstall the Network License Manager. For details about uninstalling
the Network License Manager, see Uninstall the Network License Manager
on page 34.

Install the Network License Manager. For details about installing the
Network License Manager to the same location as the previous version,
see Install the Network License Manager on page 30.

Do one of the following:

B (Windows XP) Click Start » Programs » Autodesk » Network
License Manager » LMTOOLS.

B (Windows Vista) Double-click the LMTOOLS icon on the desktop.

In the LMTOOLS program, click the Start/Stop/Reread tab.
On the Start/Stop/Reread tab, click Start Server.

Close Imtools.exe.
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Set Up and Use an Options File

With an Options file, you set configuration options for managing licenses on
each license server that you set up. An Options file sets parameters that the
license file reads and the Imgrd program executes.

If you want to have the same license behavior on some or all of your license
servers, you must save the same Options file to each of those license servers.
If you want to specify different license behavior on different license servers,

you must create an Options file for each license behavior. You must save each
Options file to the server where you want specific license behavior.

NOTE For Options file changes to take effect on a license server, you must save
the Options file, and then use Imtools.exe to reread the license file.

Use the Options file to set parameters for the following server-related features:

Report log file A compressed, encrypted file is created that generates accurate
usage reports on license activity for use by SAMreport-Lite. See Create a Report
Log on page 40.

License borrowing If your Autodesk product supports the license borrowing
feature, you can allow users to borrow an Autodesk product license from a
network license server so that they can use the product without being
connected to the license server. A license can be borrowed for a limited time.
See Configure License Borrowing with the Options File on page 41.

License timeout With license timeout, you can set a timeout period on your
license server for one Autodesk product at a time. When set, license timeout
returns a license to the license server when a connection with the workstation
is lost, or if a license is checked out but the Autodesk product is idle on a
workstation for longer than the timeout period you define. See Set Up License
Timeout on page 42.

License timeoutall With license timeoutall, you can set a timeout period on
your license server that applies to all Autodesk products installed on your
computer. When set, license timeout returns a license to the license server
when a connection with the workstation is lost, or if a license is checked out
but the Autodesk product is idle on a workstation for longer than the timeout
period you define. See Set Up License Timeout on page 42.

Here is an example of the contents of an Options file:
REPORTLOG=c:\test\report.rl

BORROW_LOWWATER Autodesk f1 3
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TIMEOUT Autodesk f1 7200

You can also set up advanced license parameters, such as reserving a license,
restricting license usage, or defining groups of users. To learn more about
setting advanced Options file parameters, see the FLEXnet documentation in
the C:\Program Files\ Autodesk Network License Manager\ LicenseAdministration.pdf
file.

Create an Options file

You should be logged in with Administrator rights when working with the
LMTOOLS utility.

To create an options file

1 Open a text editor, enter the parameters you want, and then save the
document as a file named adskflex.opt to the same location where you
saved the license file.

NOTE Make sure you save the file with the extension .opt. The default
extension .txt is not recognized by the Network License Manager.

2 Do one of the following:

B (Windows) Click Start » All Programs » Autodesk » Network
License Manager » LMTOOLS Utility.

3 In the LMTOOLS program, on the Start/Stop/Reread tab.
4 On the Start/Stop/Reread tab, click ReRead License File.

5 Close Imtools.exe.

Create a Report Log

In the Options file, you can create a report log file that is used with
SAMreport-Lite.

To create a report log

1 In a text editor, open the Options file, adskflex.opt.

2 In the Options file, enter the following syntax on its own line (with
REPORTLOG entered in uppercase, as shown):
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REPORTLOG [+]report_log_path

For example (Windows), the syntax REPORTLOG +"c:\My
Documents\report.rl" means that a report log named report.rl is located
in the folder c:\My Documents.

NOTE Path names that contain spaces must be enclosed in quotation marks.

In the REPORTLOG syntax, “[+]” means that entries to the log file you
create are appended rather than replaced each time the Network License
Manager is restarted. (It is recommended that you use this option so that
you retain a history of log entries.)

Configure License Borrowing with the Options File

If your Autodesk product supports the license borrowing feature, you can use
the Options file to configure license borrowing options. For example, you can
define the maximum number of licenses that cannot be borrowed from your
network at any one time. In addition, you can define which users can borrow
an Autodesk product license. Licenses are borrowed per user, not per machine.

NOTE If your Autodesk product supports license borrowing, and licenses are
borrowed from a redundant license server pool, you must restart the license server
after you stop the Network License Manager.

At the end of a borrow period, the borrowed license is automatically disabled
on the user's computer and becomes available again on the license server.
Users can also return a license before a borrow period has ended.

To set license borrowing parameters

1 In the Options file, enter the following syntax on its own line (with
BORROW_LOWWATER entered in uppercase, as shown):

BORROW_LOWWATER feature_code n

In the BORROW syntax, “feature_code” is the name of the product in
the license file, and “n” is the number of licenses that cannot be borrowed.

For example, the syntax BORROW_LOWWATER Autodesk_f1 3 means
that for the product Autodesk_£1, three licenses cannot be borrowed from
the license server.

2 Enter the following syntax on the next line (with MAX_BORROW_HOURS
entered in uppercase, as shown):
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MAX_BORROW_HOURS feature code n
In this syntax, “n” is the number of hours that a license can be borrowed.

For example, the syntax MAX_BORROW_HOURS Autodesk_f1 360 means
that for product Autodesk_f1, licenses can be borrowed for 360 hours, or
15 days.

NOTE Licenses are borrowed in increments of 24 hours only. Any number
that is more than a 24-hour increment is not used. For example, the number
365 would be rounded down to 360 hours, or 15 days.

For more information about setting up the license borrowing feature, see the
FLEXnet documentation in the C:\Program Files\Autodesk Network License
Manager folder.

NOTE To borrow a license in an Autodesk product, click Help menu » About
» Product Information. Alternatively, enter borrowlicense on the product
command line. Help for this feature is available in the Borrow a License for [Autodesk
Product] window and in C:\Program Files\[Autodesk Product]\Help \adsk_brw.chm.

Set Up License Timeout

License timeout is set in the Options file to determine how long a product
session can be idle before the license is reclaimed by the license server. When
you set this flag in the Options file, a user's license is reclaimed by the license
server if the product is idle on a workstation for more than the timeout period
you define.

If a user's license is lost because of the idle timeout, the product attempts to
claim a new license once the user uses the product again. If no license is
available, the user can save work before the product shuts down.

You can set individual license timeouts for each Autodesk product on your
computer by using the TIMEOUT parameter or you can set one license timeout
for all Autodesk products on your computer by using the TIMEOUTALL
parameter.

To set license timeout parameters

m For individual Autodesk products: In the Options file, enter the following
syntax on its own line (with TIMEOUT entered in uppercase, as shown):
TIMEOUT feature_code n
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In the TIMEOUT syntax, “feature_code” is the name of the product (referred
to in the INCREMENT line in the license file), and “n” is the number of
seconds before an inactive license is reclaimed by the license server.

For example, the syntax TIMEOUT Autodesk_f1 7200 means that for the

product Autodesk_f1, the license timeout period is set for 7200 seconds,
or two hours.

B For all Autodesk products: In the Options file, enter the following syntax
on its own line (with TIMEOUTALL entered in uppercase, as shown):
TIMEOUTALL n

In the TIMEOUTALL syntax, “n” is the number of seconds before an
inactive license is reclaimed by the license server.

For example, the syntax TIMEOUTALL 7200 means that for all Autodesk
products, the license timeout period is set for 7200 seconds, or two hours.

For more information about using the license timeout feature, see the FLEXnet
documentation in the C:\Program Files\ Autodesk Network License Manager
folder.

License Borrowing

If you are running a network-licensed version of the program, you can borrow
a license from a license server to use the program for a specified time when
your computer is not connected to the network.

NOTE If you have a stand-alone version of the program, you cannot borrow a
license. To check your license type, click Help menu » About » Product
Information. In the Product Information dialog box, view your product license

type.

Overview

If you are using a network-licensed version of your Autodesk product and your
network administrator supports the license borrowing feature, you can borrow
a product license from your network license server to use the program when
your computer is not connected to the network. Your license is automatically
returned to the license server at the end of the day on the return date you set
when you borrowed the license. You can also return a license early.
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NOTE There is a limit to the number of licenses available for borrowing. If you try
to borrow a license and are notified that no licenses are available, all network
licenses may already be borrowed by other users. If you are unable to borrow a
license, see your network administrator for help.

Borrow a License

You can run the program when your computer is not connected to the network
until your license-borrowing period ends. If you don't remember the date that
a license expires, you can check the date by placing your cursor over the
Borrowing icon in the program's status tray or by clicking Help » About and
using the Product Information dialog box.

When the license-borrowing period expires, the borrowed license is
automatically returned to the license server. Once your computer is
reconnected to the network, you can run the program from the network or
borrow a license again.

Interaction with Other License-Borrowing Tools

Using the license borrowing feature in the program is the recommended way
to borrow a license; however, some third-party borrowing tools may also be
available to you. These tools are not supported or compatible with the license
borrowing feature in the program. Other third-party or legacy
license-borrowing tools that may be available to you are the Autodesk License
Borrowing utility (shipped with Autodesk products) and the borrowing feature
in Imtools.exe, a component of the Autodesk Network License Manager.

If another license-borrowing tool is active when you attempt to use the license
borrowing feature, you should proceed as follows to borrow a license for the
program:

B If you run the Autodesk License Borrowing utility that shipped with your
Autodesk product and then turn on the borrowing flag for the Adskflex
option or the All option, a license can be borrowed when you start the
program. However, you cannot return a license until you exit and then
restart the program.

B [f borrowing is set in Imtools.exe for all products, you can either (a) use the
other tool to borrow licenses for the program or (b) stop the borrowing
process in Imtools.exe and then use the license borrowing feature in the
program.
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If borrowing is set in Imtools.exe for non-Autodesk products only, you must
stop the borrowing process in Imtools.exe. You can then use the license
borrowing feature to borrow licenses for your Autodesk product. If you do
not stop the borrowing process in Imtools.exe, the license borrowing feature
will not function.

To borrow a license using the Tools menu

1
2

Click Tools menu » License Borrowing » Borrow License.

In the Borrow a License window, on the calendar, click the date when
you want to return the license.

This date must be within the valid date range set by your network
administrator. The valid date range is displayed in this window.

Click Borrow License.

In the License Borrowed message, click OK. The license is borrowed, and
you can now use the program while your computer is disconnected from
the network.

NOTE You can verify that your license is borrowed by placing your cursor
over the Borrowing icon in the status tray, which is in the lower-right corner
of the program.

To borrow a license using the Help menu

1
2
3

Click Help menu » About.
In the About product window, click Product Information.
In the Product Information window, click Borrow License.

In the Borrow a License window, on the calendar, click the date when
you want to return the license.

This date must be within the valid date range set by your network
administrator. The valid date range is displayed in this window.

Click Borrow License.

In the License Borrowed message, click OK. The license is borrowed, and
you can now use the program while your computer is disconnected from
the network.
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BORROWLICENSE Command

Borrows a product license so that you can run the product outside the network
environment.

Tools menu: License Borrowing » Borrow License
Help menu: About » Product Information » Borrow License
Command line: borrowlicense

The Borrow a License Window on page 46 is displayed.

Borrow a License Window

Tools menu: License Borrowing » Borrow License
Help menu: About » Product Information » Borrow License
Command line: borrowlicense

Using the license borrowing feature, you can borrow a license from your
network license server, and then use the license when your computer is
disconnected from the license server; for example, when you are traveling for
work.

The Borrow a License window has the following options:

Calendar Sets the date when you plan to return a borrowed license. The return
date must be within the range specified by your network administrator.

Borrow a License Borrows the license from the network license server based
on the return date that you specified.

Cancel Cancels the borrowing action; no license is borrowed.

Return a License

Your network license is automatically returned to the network license server
on the day that the license expires. You can also return a license earlier than
the date you originally selected, as long as your computer is connected to the
network license server when you attempt to return the borrowed license.

Once a borrowed license is returned, you can borrow a license again as long
as your computer is connected to the network license server and a license is
available on the server.

46 | Chapter 2 Network Licensing



To return a borrowed license early, do one of the following:

B Click Tools menu » License Borrowing » Return License Early.

B Click Help menu » About » Product Information. In the Product
Information dialog box, click Return License, and then click Yes.

B [n the status tray, right-click the License Borrowing icon. Click Return
License Early.

NOTE To use the status tray to return a borrowed license early, the display settings
for the status tray must be turned on. To turn on the display settings, right-click
an empty area on the status bar. Click Tray Settings.

Your license is returned to the network license server. After you return the
borrowed license, you can borrow a license again immediately as long as a
license for that product is available on the network.

To check the license return date, do one of the following:

B In the status tray, right-click the License Borrowing icon. View the
expiration date for the borrowed license.

B Click Help menu » About » Product Information. In the Product
Information dialog box, under License Expiration Date, view the license
return date.

RETURNLICENSE Command

Returns a borrowed Autodesk product license earlier than the original return
date that you specified when you borrowed the license.

Tools menu: License Borrowing » Return License
Help menu: About » Product Information » Return License
Status tray: Right-click the License Borrowing icon. Click Return License Early.

Command line: returnlicense

Network Licensing FAQs

This section outlines some common questions and their solutions with regards
to software licenses and licensing your product(s).

Network Licensing FAQs | 47



What is the difference between a stand-alone license
and a network license?

Stand-alone licensed products are registered and activated to an individual
workstation. While the software can be installed on multiple systems in your
facility, the license only allows one system to be operational. If you need to
run more systems, you need to purchase more stand-alone licensed products,
or consider converting to network licenses.

Network licensed products rely on the Network License Manager to keep track
of software licenses. The software can be installed and run on multiple systems,
up to the maximum number of licenses you've purchased. The Network License
Manager “checks out” licenses until they are all in use. No further systems
can run the program until a license is “checked in.” If you need to run more
systems, you can purchase additional licenses for the Network License Manager
to maintain.

What is the benefit of using a network licensed version
of the software?

Network licensed products are recommended for large drafting/design facilities,
classrooms, and lab environments. The main advantage is that you can install
products on more systems than the number of licenses you have purchased
(for example, purchasing 25 licenses but installing on 40 workstations). At
any one time, products will run on the maximum number of systems for
which you have licenses. This means you get a true floating license. If software
needs to be run on more systems, additional licenses can be purchased.

Registration and activation occurs only once and the licenses are maintained
on your Network License Server.

What is Internet Explorer used for?

After installing your product, you can operate in trial mode for a given number
of days. Whenever you launch the program, you are prompted to activate the
software. When you choose to activate the software, Internet Explorer makes
this process much faster. Once you entered your registration data and submit
it to Autodesk, an activation code is returned and you are not prompted again
during startup.
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Glossary

adskflex.exe The Autodesk vendor daemon used with the FLEXnet license
technology. This daemon keeps track of the Autodesk licenses that are checked
out and the workstations that are using the licenses.

ADSKFLEX_LICENSE_FILE In a distributed license server configuration, the
environment variable used to point a workstation to the distributed license
servers.

borrowed license A license that allows you to use an Autodesk product for
a limited period of time without having to buy a separate license or have
network access to the license server.

daemon A program that runs continuously in the background of a computer.
The daemon handles requests from the computer and then forwards the
requests to other programs or processes. The Network License Manager uses
two daemons: the vendor daemon (adskflex.exe) and the license manager
daemon (Imgrd.exe).

debug log file A file used with FLEXnet to log connection activity (such as
license failure or starting and stopping) between the Network License Manager
and the workstation.

deployment The files and folders created on a server and used by workstations
to install Autodesk programs.

distributed server A license server configuration option in which several
servers are used to manage license distribution. Each distributed license server
has a unique license file and a fixed number of licenses. If one distributed
license server fails, the other servers are still able to distribute their licenses.

Ethernet address See host ID.

feature code A license file parameter that represents the product that is
supported by that license file.

FLEXnet The Acresso Software license management technology implemented
in the Autodesk family of products.
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heartbeat signal The communication signal between the Network License
Manager and the workstation to verify that the workstation is accessible and
has an active Autodesk product session running.

host ID The unique hardware address of a network adapter. Also known as
Ethernet address or physical address.

host name The TCP/IP name associated with a computer. FLEXnet technology
uses the host name as a parameter; the host name must be distinguished from
the NetBIOS (server) name.

idle A state of inactivity in your product that prompts a network license server
to reclaim a license. Inactivity is due to no mouse or keyboard activity and
no commands, LISP expressions, menu macros, or scripts in progress for the
period of time that is defined in the Options file. See also license timeout.

JRE (Java Runtime Environment) A program that is required to run Java
programs. This program must be installed with SAMreport-Lite.

license file A file used with FLEXnet that controls the number of available
seats. This file must be in ASCII plain text format.

license server A server that contains the Network License Manager.

license timeout A feature that allows you to set up a timeout period on your
license server to automatically return an idle license to the server so that it is
available for use again.

licpath.lic In both single and redundant server configurations, the file used to
point the workstation to the FLEXnet license server. Licpath.lic is located in
the root installation folder.

Imgrd.exe The license manager daemon. This daemon handles the original
contact with the program, and then passes the connection to the vendor
daemon, adskflex.exe.

Imtools.exe A graphical user interface utility used to administer the FLEXnet
license technology. (Lmutil.exe is the command line version of this utility.)

Imutil.exe A command line utility used to administer the FLEXnet license
technology. (Lmtools.exe is the graphical user interface version of this utility.)

master daemon See Imgrd.exe.

network license installation A type of installation that requires you to install
and run the Network License Manager from a network server. You must install
and configure the Network License Manager before clients can run the
Autodesk product.
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Network License Manager The technology used by Autodesk for network
license management.

Options file The file used by FLEXnet to control license manager parameters,
such as reserving licenses and creating report logs used with SAMreport-Lite.

physical address See host ID.

redundant server A license server configuration option in which three servers
are used to administer licenses. The redundant servers share a license file and
a pool of licenses. The redundant server pool remains functional as long as
two of the three servers are running and communicating with each other.

report log file A file used with FLEXnet and SAMreport-Lite. This log file
provides information about network license usage. The Options file creates
the report log.

SAMreport-Lite A version of Acresso Software's SAMreport tool. SAMreport-Lite
is included on the Autodesk product discs.

vendor daemon See adskflex.exe.

workstation A desktop computer used by an individual user on a network.
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