# Contents

<table>
<thead>
<tr>
<th>Chapter 1</th>
<th>Introduction to AutoCAD Raster Design 2012</th>
<th>1</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>What is New in AutoCAD Raster Design 2012</td>
<td>1</td>
</tr>
<tr>
<td></td>
<td>Accessing the Raster Design Home Page</td>
<td>6</td>
</tr>
<tr>
<td></td>
<td>About AutoCAD Raster Design dialog box</td>
<td>6</td>
</tr>
<tr>
<td></td>
<td>Installation Requirements</td>
<td>7</td>
</tr>
<tr>
<td></td>
<td>Supported Image Formats</td>
<td>7</td>
</tr>
<tr>
<td></td>
<td>Image Portability</td>
<td>8</td>
</tr>
<tr>
<td></td>
<td>AutoCAD Raster Design History</td>
<td>9</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Chapter 2</th>
<th>Inserting and Correlating Images</th>
<th>11</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Inserting Images</td>
<td>11</td>
</tr>
<tr>
<td></td>
<td>Inserting Local Images Using the Insert Image Dialog Box</td>
<td>12</td>
</tr>
<tr>
<td></td>
<td>Inserting an Image from the Internet Using the Insert Image Dialog Box</td>
<td>14</td>
</tr>
<tr>
<td></td>
<td>Inserting an Image from an FTP Site Using the Insert Image Dialog Box</td>
<td>16</td>
</tr>
<tr>
<td></td>
<td>Inserting an Image Using the Command Line</td>
<td>18</td>
</tr>
<tr>
<td></td>
<td>Adding Image Sources to Favorites</td>
<td>20</td>
</tr>
<tr>
<td></td>
<td>Assigning a Color Map to an Image</td>
<td>20</td>
</tr>
<tr>
<td></td>
<td>Creating New Images</td>
<td>22</td>
</tr>
<tr>
<td></td>
<td>Correlating Images</td>
<td>23</td>
</tr>
<tr>
<td></td>
<td>Correlating an Image During Insertion</td>
<td>23</td>
</tr>
<tr>
<td></td>
<td>Using Quick Insert</td>
<td>24</td>
</tr>
</tbody>
</table>
### Specifying Correlation Settings

- Page 25

### Adjusting the Image Frame Before Insertion

- Page 29

### Correlating an Image After Insertion

- Page 30

### Matching Image Points

- Page 30

### Moving an Image

- Page 31

### Scaling an Image

- Page 32

### Rubbersheeting an Image

- Page 33

### Chapter 3 Saving Images

- Page 41

#### Saving an Image

- Page 41

#### Saving Images with AutoCAD Save

- Page 43

#### Embedding Images in a Drawing

- Page 44

#### Saving an Image to Another File Name, Type, or Location

- Page 45

#### Saving an Image to an FTP Site

- Page 47

#### Capturing an Image

- Page 49

#### Exporting Images

- Page 50

##### Exporting an Image

- Page 51

##### Exporting an Image to an FTP Site

- Page 53

##### Exporting a World File

- Page 54

##### Correlation Output Types

- Page 56

#### Encoding and Data Organization Methods

- Page 56

### Chapter 4 Changing Image Properties

- Page 59

#### AutoCAD Properties

- Page 59

#### Image Display Properties

- Page 60

#### Image Display Quality

- Page 60

#### Image Frame Display

- Page 61

#### Image Layer

- Page 62

#### Linetype of an Image Frame

- Page 63

#### Foreground Color of a Bitonal Image

- Page 63

#### Transparent Color of an Image

- Page 64

#### Unused Color for Transparent Color

- Page 65

### Chapter 5 Managing Images and Insertions

- Page 67

#### Controlling the Image Manager Toolspace

- Page 67

#### Modifying the Item View Layout

- Page 67

#### Copying Information to the Clipboard

- Page 68

#### Managing Image Display and Data

- Page 69

#### Zooming to an Image

- Page 69

#### Changing the Color Map of an Image

- Page 70

#### Adding a Visual Elevation Key to a DEM Image

- Page 71

#### Creating Another Insertion of an Image

- Page 72

#### Displaying Point Data

- Page 73

#### Showing and Hiding Images

- Page 74
Chapter 6  Modifying Images  .............................................. 81

Selecting an Image ..................................................... 81
Controlling Image Frames .............................................. 83
Undoing Edits to an Image ............................................. 83
Snapping to COGO Points ............................................. 84
Cleaning Up Images ..................................................... 84
Deskewing an Image ................................................... 85
Removing Speckles from an Image .............................. 86
Adjusting the Image Bias .............................................. 88
Reversing the Light and Dark Shades in an Image ........ 90
Mirroring an Image ..................................................... 90
Touching Up an Image ................................................ 91
Image Processing ....................................................... 92

Adjusting Images with the Histogram ................................. 94
  Adjusting the Brightness and Contrast of an Image ....... 94
  Maximizing Details in an Image ................................ 98
Converting a Color Image to Grayscale ........................... 100
Converting a Grayscale or Color Image to Bitonal .............. 102
Making Tonal Adjustments to an Image ............. 103
Convolving an Image .................................................. 107
  Reducing Harshness and Noise in an Image ............... 107
  Median Filter ....................................................... 108
  Making Differences in Shading More Distinct ............. 109
  Lowpass Filtering .................................................. 110
  Highpass Filters .................................................. 111
Edge Enhancements Filters ........................................... 112
  Shift and Difference Edge Enhancements Filters ........... 112
  Laplace Edge Enhancements Filters ............................ 112
  Gradient Directional Edge Enhancements Filters .......... 113
  Matched Filter Edge Enhancements Filters ................. 113
  Using Bitonal Filters .............................................. 114
  Changing Image Density ....................................... 117
  Setting the Color Depth for an Image .......... 118
Using the Palette Manager ............................................ 120

Manipulating the Color Table ....................................... 120
  Changing Selected Colors in the Image Palette ............ 120
  Combining Selected Colors in the Image Palette ........ 122
  Designating a Transparent Color ............................... 123
  Selecting a Color Directly from the Image ............. 124
Grid Parameters Dialog Box ........................................ 317
Histogram Dialog Box ................................................ 318
  Brightness/Contrast Tab (Histogram Dialog Box) ............. 318
  Equalize Tab (Histogram Dialog Box) ........................ 320
  Threshold Tab (Histogram Dialog Box) ...................... 322
  Color to Grayscale Tab (Histogram Dialog Box) ........... 323
  Tonal Adjustment Tab (Histogram Dialog Box) ............. 324
Image Data Properties Dialog Box ................................. 326
Image Filters Dialog Box ........................................... 326
Image Insertion Dialog Box ......................................... 327
  Assign Color Map Tab (Image Insertion Dialog Box) ....... 327
  Source Tab (Image Insertion Dialog Box) ................... 328
  Modify Tab (Image Insertion Dialog Box) .................. 329
  Insertion Tab (Image Insertion Dialog Box) ............... 330
  Transform Tab (Image Insertion Dialog Box) ............... 331
Image Manager Toolspace ........................................... 332
  Image Insertions View (Image Manager Toolspace) ......... 333
  Image Data View (Image Manager Toolspace) ............... 334
Image Select Dialog Box ........................................... 337
Import Data Dialog Box ............................................. 338
Import Palette Dialog Box ......................................... 339
Insert Image Dialog Box ............................................ 340
Median Filter Dialog Box .......................................... 342
Mirror Dialog Box ................................................... 343
Multi-frame Select Dialog Box ................................... 343
New Image Dialog Box .............................................. 344
New Image Mask Dialog Box ....................................... 345
New Palette Color Insertion Dialog Box ......................... 346
Palette Assignment Color Map Dialog Box ....................... 347
Palette Color Map Definition Dialog Box ....................... 347
Palette Information Dialog Box ................................ 350
Palette Manager Dialog Box ....................................... 350
Raster Data Query Dialog Box .................................... 352
Raster Design Options Dialog Box ................................. 353
  Image Defaults Tab (Raster Design Options Dialog Box) . 353
  Feature Settings Tab (Raster Design Options Dialog Box) . 354
  Image Mask Tab (Raster Design Options Dialog Box) .... 355
  New Image Tab (Raster Design Options Dialog Box) ....... 356
  Paths Tab (Raster Design Options Dialog Box) .......... 357
  REM Tab (Raster Design Options Dialog Box) .............. 359
  Raster Entity Detection Tab (Raster Design Options Dialog Box) .... 359
  User Preferences Tab (Raster Design Options Dialog Box) . 360
  Vector Merge Tab (Raster Design Options Dialog Box) .... 361
  VTools Follower Tab (Raster Design Options Dialog Box) ... 362
  VTools General Tab (Raster Design Options Dialog Box) ... 364
Raster Pen Settings Dialog Box .................................................. 366
Recognition Character Sets Dialog Box ........................................ 366
Rubbersheet - Set Control Points Dialog Box .............................. 367
Save As Dialog Box .................................................................... 369
Select a Lock File Directory Dialog Box ...................................... 370
Select Coordinate System (Export) Dialog Box ........................... 371
Select Coordinate System (Insert) Dialog Box ............................... 371
Select Global Coordinate System Dialog Box .............................. 371
Select Working Coordinate System Dialog Box .......................... 372
Target Color Dialog Box ............................................................. 372
Temporary File Location Dialog Box ........................................... 373
Text Recognition Setup Dialog Box ............................................ 373
Transparent Color Dialog Box ..................................................... 375
Vector Separation Options Dialog Box ......................................... 376
  General Tab (Vector Separation Options Dialog Box) ............... 376
  Contour Tab (Vector Separation Options Dialog Box) ............. 377
Verify Text/Table Dialog Box ...................................................... 378
VText Edit Dialog Box ............................................................... 381

Glossary ...................................................................................... 383

Index ........................................................................................... 405
Introduction to AutoCAD Raster Design 2012

The AutoCAD Raster Design User’s Guide includes conceptual, procedural, and reference details about the tools and features found in AutoCAD Raster Design 2012.

This chapter provides information to help you get acquainted with Raster Design requirements, capabilities, and history.

What is New in AutoCAD Raster Design 2012


<table>
<thead>
<tr>
<th>New in AutoCAD Raster Design 2012</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Function</strong></td>
</tr>
<tr>
<td>The following have been updated in the AutoCAD Raster Design 2012 Tutorials and Getting Started Guide</td>
</tr>
<tr>
<td>Menu name change</td>
</tr>
<tr>
<td>Menubar name change</td>
</tr>
<tr>
<td>Ribbon name change</td>
</tr>
<tr>
<td>Transparency property name change</td>
</tr>
</tbody>
</table>
## New in AutoCAD Raster Design 2012

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Transparency Color property name change</td>
<td>The Transparency Color property is now called Transparent Color.</td>
</tr>
<tr>
<td>Command name change</td>
<td>The showts command is now called showrd.</td>
</tr>
<tr>
<td>Command name change</td>
<td>The dockts command is now called dockrd.</td>
</tr>
<tr>
<td>Command name change</td>
<td>The hidets command is now called hiderd.</td>
</tr>
<tr>
<td>Command name change</td>
<td>The floatts command is now called floatrd.</td>
</tr>
</tbody>
</table>

## New in Raster Design 2011

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Menu name change</td>
<td>The Image menu is now called Raster.</td>
</tr>
<tr>
<td>Menubar name change</td>
<td>The Image menubar is now called Raster.</td>
</tr>
<tr>
<td>Ribbon name change</td>
<td>The Image ribbon tab is now called Raster Tools.</td>
</tr>
<tr>
<td>Transparency property name change</td>
<td>The Transparency property is now called Background Transparency.</td>
</tr>
<tr>
<td>Transparency Color property name change</td>
<td>The Transparency Color property is now called Transparent Color.</td>
</tr>
<tr>
<td>Command name change</td>
<td>The showts command is now called showrd.</td>
</tr>
<tr>
<td>Command name change</td>
<td>The dockts command is now called dockrd.</td>
</tr>
<tr>
<td>Command name change</td>
<td>The hidets command is now called hiderd.</td>
</tr>
</tbody>
</table>
## New in Raster Design 2011

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Command name change</td>
<td>The <code>floatts</code> command is now called <code>floatrd</code>.</td>
</tr>
</tbody>
</table>

## New in Raster Design 2010

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Citrix support</td>
<td>AutoCAD Raster Design 2010 is now available for use on Citrix XenApp v4.5 and 5.0 for use with AutoCAD Map 3D 2010.</td>
</tr>
<tr>
<td>Additional Autodesk product support</td>
<td>AutoCAD Raster Design 2010 can now be used with AutoCAD P&amp;ID 2010 and Autodesk Topobase 2010.</td>
</tr>
<tr>
<td>Improved image format support</td>
<td>Support for TIFF and BIL image formats had been improved. In addition, AutoCAD Raster Design 2010 now includes 64-bit MsSID Codec support.</td>
</tr>
<tr>
<td>Updated ribbon</td>
<td>The ribbon interface has been updated to be even easier to use.</td>
</tr>
</tbody>
</table>

## New in Raster Design 2009

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>64-bit support</td>
<td>AutoCAD Raster Design 2009 supports both the 32-bit and 64-bit environments of its hosting Autodesk products. This will allow you to easily and confidently install AutoCAD Raster Design 2009 on any supporting application, using any of its supported operating systems.</td>
</tr>
</tbody>
</table>
| Discrete-themed data handling      | Discrete-themed data is a form of raster data commonly used to represent such things as land cover, zoning, and any other classified data. Coupled with the continuous-themed data handling required for working with elevations, this provides a
## New in Raster Design 2009

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>much more robust environment for accurately using raster grid data.</td>
<td>Vista ribbon-style interface</td>
</tr>
<tr>
<td>This interface presents command options in a concise visual format, enabling you to quickly select commands based on the work you are doing. Moving between applications is now quick and intuitive. The ribbon is both customizable and expandable, so it can be optimized for each user and to meet each company’s standards.</td>
<td></td>
</tr>
</tbody>
</table>

## New in Raster Design 2008

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Support for additional image formats</td>
<td>Read images in these formats:</td>
</tr>
<tr>
<td>■ QuickBird TIFF</td>
<td>Prompts during vectorization operations can display conveniently near the cursor, using AutoCAD Dynamic Input. Grips appear on previously vectorized segments to facilitate editing.</td>
</tr>
<tr>
<td>■ Landsat FAST</td>
<td>Edit multi-resolution images</td>
</tr>
<tr>
<td>■ NITF (National Image Transmission Format)</td>
<td>Edit MrSID, ECW, and JPEG2000 images, then save changes in JPEG2000 format.</td>
</tr>
<tr>
<td>Vectorization improvements</td>
<td>Image embedding</td>
</tr>
<tr>
<td>Prompts during vectorization operations can display conveniently near the cursor, using AutoCAD Dynamic Input. Grips appear on previously vectorized segments to facilitate editing.</td>
<td>Embed one or more bitonal images inside the drawing for convenience of image transfer and management.</td>
</tr>
<tr>
<td>Improved insert options</td>
<td>Improved insert options</td>
</tr>
<tr>
<td>The insert process has been improved with better image preview handling, support for multi-frame images, better indication when default settings are being applied,</td>
<td></td>
</tr>
</tbody>
</table>
## New in Raster Design 2008

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Enhanced image capture</td>
<td>When used with AutoCAD Map 3D, Raster Design can capture FDO (Feature Data Object) data, either in source format, or as stylized by Display Manager.</td>
</tr>
<tr>
<td>Improved Despeckle</td>
<td>Procedures are streamlined to make despeckle operations easier and more effective.</td>
</tr>
</tbody>
</table>

## New in Raster Design 2007

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>DTED format support</td>
<td>Read images in this format.</td>
</tr>
<tr>
<td>ESRI Grid format support</td>
<td>Read images in both ASCII and binary versions of this format.</td>
</tr>
<tr>
<td>Coordinate system transformation</td>
<td>Automatic assignment of the Autodesk Map coordinate system code when inserting a GeoTIFF or DEM file. Also, automatic assignment of the correct EPSG code when exporting to GeoTIFF format.</td>
</tr>
</tbody>
</table>

## New in Raster Design 2006

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Touchup tools for bitonal images</td>
<td>Edit images at the pixel level.</td>
</tr>
<tr>
<td>REM Operations tools</td>
<td>Extend and trim raster lines to intersections, add corner fillets, and offset lines.</td>
</tr>
<tr>
<td>Raster Data Query dialog box</td>
<td>Display data about the pixel under the cursor, such as color value, elevation, and coordinates in the specified coordinate system.</td>
</tr>
</tbody>
</table>
**New in Raster Design 2006**

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Transform and edit complex image data</td>
<td>When using Autodesk Map 3D, transform the coordinate system of 16-bit, multispectral or digital elevation models (DEM) to match a drawing coordinate system.</td>
</tr>
<tr>
<td>Write to more image formats</td>
<td>Save images to JPG 2000 format, and write DEM data to GeoTIFF or DEM format</td>
</tr>
<tr>
<td>Image Capture</td>
<td>Save displayed images from satellite data, digital elevation models, and other data types that cannot be otherwise saved.</td>
</tr>
<tr>
<td>Default file name formats</td>
<td>Names now reflect the image source and sequence number.</td>
</tr>
</tbody>
</table>

**Accessing the Raster Design Home Page**

If you have an Internet connection, then you can access the Raster Design home page for information about product updates.

**To access the Raster Design home page**
- On the **Raster** menu, select **AutoCAD Raster Design Home Page** or click in the Raster Design toolbar.

**About AutoCAD Raster Design dialog box**

This dialog box provides you with the following information about Raster Design:
- Name of the licensed owner
- Serial number
- Source of the licence
Installation Requirements

For hardware and software system requirements, refer to the System Requirements page of the *Stand-Alone Installation Guide* or the *Network Administrator's Guide*, depending on your installation type.

If your computer does not meet the minimum requirements, you must upgrade your computer before installing Raster Design.

Supported Image Formats

Raster Design can support most single-image and multispectral file formats. For multispectral files, Raster Design can read most common formats, but can best interpret metadata for the formats listed in the following table.

<table>
<thead>
<tr>
<th>Image Formats Supported by Raster Design</th>
<th>Read-Write</th>
<th>Read Only</th>
</tr>
</thead>
<tbody>
<tr>
<td>bitmap (BMP) on page 384</td>
<td>CALS on page 385</td>
<td>DOQ on page 390</td>
</tr>
<tr>
<td>DEM on page 389</td>
<td>GeoTIFF on page 392</td>
<td>ECW on page 390</td>
</tr>
<tr>
<td>GIF on page 392</td>
<td>JFIF - JPEG on page 393</td>
<td>FLIC on page 391</td>
</tr>
<tr>
<td>JPEG 2000 on page 393</td>
<td>PCX on page 396</td>
<td>GeoSPOT on page 392</td>
</tr>
<tr>
<td>PNG on page 396</td>
<td>TARGA on page 401</td>
<td>IG4 on page 393</td>
</tr>
<tr>
<td>TIFF on page 401</td>
<td>Landsat FAST L7A on page 394</td>
<td>NITF on page 395</td>
</tr>
<tr>
<td>PICT on page 396</td>
<td>QuickBird TIFF on page 396</td>
<td></td>
</tr>
<tr>
<td>RLC on page 397</td>
<td>SID (MrSID) on page 398</td>
<td></td>
</tr>
</tbody>
</table>

Installation Requirements | 7
Image Portability

Whether you can open a Raster Design drawing in another Autodesk application depends on the type of image included in the drawing:

AutoCAD image objects can be displayed in the standard version of other Autodesk products such as AutoCAD 2008 and AutoCAD Map 3D. The format of this image type can be:

- 1-bit bitonal
- 4- or 8-bit grayscale
- 8-bit index color
- 24-bit true color

Raster Design image objects can be displayed in other Autodesk products that include the Raster Design Object Enabler. The format of this image type can be:

- single-band floating-point digital elevation model (DEM)
- 16- or 32-bit single-band integer
- 8- or 16-bit multiband multispectral

The following Autodesk products include the Raster Design Object Enabler:

- AutoCAD® 2012
- AutoCAD® Architecture 2012
- AutoCAD® Civil 3D® 2012
- AutoCAD® Electrical 2012
- AutoCAD® ecscad 2012
- AutoCAD® Map 3D 2012
- AutoCAD® Mechanical 2012
- AutoCAD® MEP 2012
- AutoCAD® P&ID 2012
- AutoCAD® Plant 3D 2012
AutoCAD Raster Design History

AutoCAD Raster Design was formerly known as CAD Overlay.

Raster Design History

CAD Overlay 1.0 was introduced in 1988 for AutoCAD Release 2.6. CAD Overlay was the first application to display raster in AutoCAD for “heads up digitizing” of scanned drawings.

CAD Overlay ESP, introduced in 1989, allowed editing and plotting of scanned images. This release was the first to be available in French, German and Italian versions. A Japanese version followed in 1991.

CAD Overlay GS, introduced in 1991, supported grayscale imagery in AutoCAD.

CAD Overlay ESP 4.0 was introduced in 1992 for AutoCAD Release 12.

CAD Overlay GSX was introduced in 1993, and in 1994 the LFX (line following extension) function broke new ground in raster to vector conversion.

CAD Overlay S7.5 shipped in 1996, the first ObjectARX application that supported AutoCAD Release 13c4. This release combined the functionality of ESP, LFX, and GSX.

CAD Overlay S8 and Autodesk CAD Overlay Release 14 were introduced worldwide in 1997.

CAD Overlay 14.01, introduced in 1998, was the first AEC Product to become Object ARX compliant, and also introduced the first ActiveX interface in CAD Overlay, which adds the ability to customize CAD Overlay through the AutoCAD Visual Basic Editor.

CAD Overlay 2000, introduced in 1999 as part of the Design 2000 family, focused on raster editing enhancements.

CAD Overlay 2000i, introduced in 2000, focused on vectorization enhancements. Powerful “VTools” enhancements increased the speed and accuracy of converting raster geometry to vector.

CAD Overlay 2002, introduced in 2001, was an AutoCAD 2002-enabled version of CAD Overlay 2000i.

Raster Design 3, introduced in 2002, focused on improving the appearance and standardizing the use of color images, and enabling the interactive conversion of scanned text to AutoCAD text. Improved features also enabled the correction of distortions in images with greater accuracy.
Raster Design 2004, introduced in 2003, was an AutoCAD 2004-enabled version, including improved installation and licensing features, as well as True Color support.

Raster Design 2005, introduced in 2004, was based on AutoCAD 2005 and supports a larger range of image types, including digital elevation models (DEM) and multispectral datatypes. Image analysis and display capabilities were improved.

Raster Design 2006, introduced in 2005, was based on AutoCAD 2006 and included new image capture functionality and new raster editing tools. New write formats introduced in this release were GeoTIFF and JPEG 2000.

Raster Design 2007, introduced in 2006, was based on AutoCAD 2007 and designed for greater interoperability with Autodesk Map 3D. This release included support for new file formats ESRI GRID and DTED.

Raster Design 2008, introduced in 2007, was based on AutoCAD 2008.

Raster Design 2009, introduced in 2008, was based on AutoCAD 2009.

Raster Design 2010, introduced in 2009, was based on AutoCAD 2010.

Raster Design 2011, introduced in 2010, is based on AutoCAD 2011.

Raster Design 2012, introduced in 2011, is based on AutoCAD 2012.
Inserting and Correlating Images

Use the Raster Design insertion tools to insert images into AutoCAD drawings and assign color maps; use correlation tools to precisely position, scale, and rotate images.

Inserting Images

You can use Raster Design to insert images for many different supported image types on page 401 and formats into an AutoCAD drawing.

You can insert images from local folders, network locations, or from the Internet.

Raster Design provides three ways to insert an image:

- Use the Insert Image on page 340 dialog box to select the image, assign a color map, and specify a correlation method. In this dialog box, you can also preview the image and information such as file type, color depth, density, and size. Shortcuts are provided to various file locations, including Buzzsaw.com and a History folder, which displays the locations you have used most recently.

- Use the Image Data on page 334 view of the Image Manager toolspace to create another insertion of an image that is already in the drawing. For more information, see Creating Another Insertion of an Image on page 72.

- Bypass the Insert Image dialog box by setting the AutoCAD FILEDIA variable to 0, which allows you to insert an image by typing an image file name on the command line. This method is useful if you already have correlation data stored with your images, or if you want to use an AutoLISP routine to automatically insert images into your drawing.
When you use Raster Design to open image files from the Internet, the image file you specify is downloaded to your computer and inserted into your drawing using the correlation method you select. Images downloaded from an HTTP site are opened as read-only files. You can edit the image and save it locally. Images opened from FTP sites can be saved back to their original locations.

**NOTE** When you insert a bitonal image, Raster Design looks for the foreground color in the correlation source selected. If it cannot find the color information, then the foreground color defaults to the current color.

See also:
- Correlating an Image During Insertion on page 23
- Inserting Images From GSX or ESP on page 258
- Assigning a Color Map to an Image on page 20

### Inserting Local Images Using the Insert Image Dialog Box

Use the Insert Image dialog box to insert images from a folder on your computer or from a source on the local area network.

After selecting the image, you can view information about the image, and specify a correlation method.

See also:
- Selecting an Image on page 81
- Assigning a Color Map to an Image on page 20
- Correlating an Image During Insertion on page 23
- Image Insertion Dialog Box on page 327

To insert images from local sources

1. Click Raster menu ➤ Insert.
2 In the Insert Image on page 340 dialog box, navigate to the folder where the image is located using one of the following methods:
   ■ Choose the drive and folder using standard Windows navigation procedures.
   ■ Click an icon on the Places List on the left side of the dialog box to navigate directly to a location such as My Documents, the Desktop, or the Favorites folder.

3 In the Files of Type box, choose the file format of the images you want to insert.
   **NOTE** If you want to insert more than one image type at a time, select All Images.

4 From the list of images, choose the image(s) you want to insert. You can use standard Windows selection methods to select more than one image at a time, or Click the Favorites button to choose a shortcut to an image in a familiar location.

5 To view information about an image, such as file type and creation date, before you insert it, click Views ➤ Information.

6 To display a preview of the image, click Views ➤ Preview. Click Open. This preview setting is especially useful if you are inserting a multi-frame image, as it enables you to preview each frame of the image set.
   **NOTE** When you insert more than one image at a time, the default correlation information is used for the images. The images are inserted automatically into the drawing and the Correlation Wizard is not displayed.

7 In the Insert Options section, choose a correlation method:
   ■ Quick Insert automatically inserts the image using correlation values embedded in the image file, correlation data stored in a separate file, or using default correlation values.
   ■ Insertion Wizard divides the insertion process into a series of steps that can vary depending on image type: assigning a color map, specifying a correlation source, setting various positioning values, and transforming coordinate systems. This method is recommended for new or intermediate users.
   ■ Insertion Dialog provides the same functions as the Insertion Wizard, but without the step-by-step process. You can change settings on the
tabs of the dialog box in any order, then apply them to the image. This method is recommended for advanced users.

8 If you want to display only the frame on page 391 of the image you insert, select the Show Frames Only check box.

9 If you are inserting multiple images that you want to view as a multispectral set, select Treat as Multispectral.

10 To zoom to the extents of the image(s) you insert after correlation, select Zoom to Image(s).

11 After configuring the insert options, select the image or images to insert.

12 If you are inserting a multi-frame image, under Multi-frame Options, specify whether to insert only the first frame, all frames, or a selection of frames. If you choose the latter, you will see the Multi-frame Select Dialog Box on page 343 after you click Open.

13 Click Open to insert the image or images.

Quick Reference

Menu
Raster ➤ Insert
Raster Design Toolbar

Command Line
insert

Dialog Box
Insert Image Dialog Box on page 340

Inserting an Image from the Internet Using the Insert Image Dialog Box

Use the Insert Image dialog box to insert an image file from the Internet.
Many Internet connections require you to enter a valid user name and password before accessing the Internet. Raster Design prompts you to enter this information.

Some of the Raster Design custom image formats may not be insertable from an internet connection.

**NOTE** Images inserted from an HTTP site are opened as read-only images.

See also:

- Assigning a Color Map to an Image on page 20
- Correlating an Image During Insertion on page 23
- Image Insertion Dialog Box on page 327

**To insert an image file from the Internet**

1. Click Raster menu ➤ Insert.

2. In the Insert Image dialog box, do one of the following:
   - Click the Search the Web icon at the top of the dialog box to navigate the Internet using AutoCAD's Browse the Web-Open dialog box.
   - Click the History icon in the Places List at the left of the dialog box to navigate to Internet locations where you've recently downloaded or stored images.
   - Click the Buzzsaw icon in the Places List at the left of the dialog box to navigate to Buzzsaw.com where you can view current construction projects in Internet Explorer.

3. If you selected Search the Web in step 2, enter the complete URL of the file in the File Name text box, then click Open.

4. Click Open.

**NOTE** Include the Transfer Protocol (i.e., http:// or ftp://) and the extension (i.e., .jpg or .tif) of the file you want to open.
Quick Reference

Menu

Raster ➤ Insert

Raster Design Toolbar

Command Line

iinsert

Dialog Box

Insert Image Dialog Box on page 340

Inserting an Image from an FTP Site Using the Insert Image Dialog Box

Use the Insert Image dialog box to insert an image file from an FTP site on the Internet.

Unlike images from HTTP sites, images inserted from FTP sites can be saved back to their original location.

See also:

- Assigning a Color Map to an Image on page 20
- Correlating an Image During Insertion on page 23
- Image Insertion Dialog Box on page 327

To insert an image file from an FTP site

1. Click Raster menu ➤ Insert.
2. In the Insert Image on page 340 dialog box, click the FTP icon in the Places List.
3. Click Tools menu ➤ Add/Modify FTP Locations. The Add/Modify FTP Locations dialog box appears.
4. In the Name of FTP Site text box, type the name of the FTP server.
In the Log On As section, choose either Anonymous or User. If you select the User option, enter a username in the combo box.

Enter a password in the Password text box.

Click Add.

Click OK to return to the Insert Image dialog box.

Navigate to the FTP site using standard Windows navigation methods.

On the list of images, choose the image(s) that you want to insert. You can use standard Windows selection methods to select more than one image at a time. The selected image(s) are listed in the File Name box.

**NOTE** If more than one kind of file with the same name is present in the folder, do not type in a filename with no extension.

In the Insert Options section, choose a correlation method:

- Quick Insert automatically inserts the image using correlation values embedded in the image file, correlation data stored in a separate file, or using default correlation values.

- Insertion Wizard divides the insertion process into a series of steps that can vary depending on image type: assigning a color map, specifying a correlation source, setting various positioning values, and transforming coordinate systems. This method is recommended for new or intermediate users.

- Insertion Wizard divides the insertion process into a series of steps that can vary depending on image type: specifying a correlation source, setting various positioning values. This method is recommended for new or intermediate users.

- Insertion Dialog provides the same functions as the Insertion Wizard, but without the step-by-step process. You can change settings on the tabs of the dialog box in any order, then apply them to the image. This method is recommended for advanced users.

If you want to display only the frame of the image you insert, select the Show Frames Only check box.

To zoom to the extents of the image(s) you insert after correlation, select the Zoom to Image(s) check box.
To view information about an image before you insert it, choose Views Information to view information such as file type and creation date.

To display a preview of the image, click Views ➤ Preview. Click Open.

**NOTE** When you insert more than one image at a time, the default correlation information is used for the images. The images are inserted automatically into the drawing and the Insertion Wizard is not displayed.

### Quick Reference

**Menu**

Raster ➤ Insert

**Raster Design Toolbar**

**Command Line**

`iinsert`

**Dialog Box**

*Insert Image Dialog Box* on page 340

### Inserting an Image Using the Command Line

You can bypass the Insert Image dialog box by using the command line.

Setting the AutoCAD FILEDIA variable to 0 allows you to insert an image by typing an image file name on the command line. This method is useful if you already have correlation data stored with your images, or if you want to use an AutoLISP routine to automatically insert images into your drawing.

When Raster Design locates the image, it inserts it into your drawing using correlation data stored with the image. If Raster Design cannot find a correlation file, the image is inserted using the information you defined in the Raster Design Options dialog box. For more information, see *Image Defaults Tab (Raster Design Options Dialog Box)* on page 353. Raster Design searches for a correlation source using the following order:

- Resource file
World file
Tab file
Image file

For more information about the AutoCAD FILEDIA variable, see the AutoCAD online Help or printed User’s Guide.

See also:
- Assigning a Color Map to an Image on page 20
- Correlating an Image During Insertion on page 23
- Image Insertion Dialog Box on page 327

To insert an image when FILEDIA is <0>

1. Click Raster menu ➤ Insert.
2. Do one of the following:

   - Type the name of the image you want to insert and its file extension. Example: `contour.rlc`
     If you do not specify a path to the image, Raster Design searches for the image using the Project Files Search Path configured in the AutoCAD Preferences dialog box. For more information, open the main Help window for Autodesk Civil 3D or Land Desktop, then select AutoCAD Help ➤ User’s Guide ➤ The User Interface ➤ Customize the Drawing Environment ➤ Set Interface Options.

   - Type the path name of the image, the image name, and the file extension. Example: `c:\AutoCAD 2000\co\sample\contour.rlc`
     Raster Design searches for the image in the path that you specify. If Raster Design cannot locate the image in this path, it searches for the image using the AutoCAD Project Files Search Path.

   NOTE When FILEDIA is set to 0, you can type a tilde (~) to display the Insert Image dialog box if needed.
Adding Image Sources to Favorites

You can create shortcuts to provide quick access to the files or folders that contain your images.

When you select a folder, drawing, or other file and choose Add to Favorites, a shortcut to that item is added to the Favorites folder in the Windows system. The original file or folder doesn't move. The shortcuts you create using AutoCAD DesignCenter can also be stored in Favorites.

A shortcut relies on a specific path, so it fails if the destination file or folder is moved or renamed. In that case, you need to create a new shortcut.

To add image sources to Favorites

1. Click Raster menu ➤ Insert. The Insert Image on page 340 dialog box is displayed.

2. Do one of the following:
   - If the source is a file, folder, or Internet location, in the Insert Image dialog box, select the item, then click Tools menu ➤ Add to Favorites.
   - If the source consists of DesignCenter palette contents, right-click the palette background and choose Add to Favorites. The container of the palette contents is added to the Favorites folder.

Quick Reference

Menu
   Tools ➤ Add to Favorites

Dialog Box
   Insert Image Dialog Box on page 340

Assigning a Color Map to an Image

You typically assign a color map to an image at the time of insertion, but you can change the color map at any time, using the Image Manager toolspace.

Color maps apply primarily to digital elevation models (DEM) and multispectral images. Raster Design automatically assigns color maps to traditional bitmaps, tagged image files (TIFF) and other displayed images at the time of insertion.
When a DEM or multispectral image is inserted, Raster Design displays the appropriate dialog for configuring a color map.

DEM files use a palette color map, which has multiple settings that are configured in the Palette Color Map Definition Dialog Box on page 347. Palette color maps can be saved for reuse with other files.

**NOTE** To remove all unused color maps from a drawing, type ipurgecm at the command line.

Multispectral files use a band assignment color map, which simply assigns data bands to color channels. This type of color map is not saved, as it is quite easy to configure in the process of image insertion.

**See also:**
- Assign Color Map Tab (Image Insertion Dialog Box) on page 327

**To assign a color map to an image**

- On the Color Map Assignment dialog box, do one of the following:
  - For a palette color map, use the drop-down list to select a color map. If you want to edit, copy, or create a new color map, click the appropriate button to the right of the list, then use the Palette Color Map Definition on page 347 dialog box to make changes. If you do not want to insert the image into the display, clear the Insert Into Display check box.
  - For a band assignment color map, use the three drop-down lists to specify a data band for each color channel. If you want to turn off one or more of the colors, clear the appropriate check boxes. If you do not want to insert the image into the display, clear the Insert Into Display check box.

**Quick Reference**

**Menu**

Click Raster ➤ Insert. Then select Insertion Wizard or Insertion Dialog

**Command Line**

iinsert
Creating New Images

You can create a new blank image for use with the image merge and vector merge tools.

When you create a new image, you begin by defining an image frame in the New Image dialog box. After you have created a new image, you must save it to create a link between the drawing and the image file.

To create a new image

1. Click Raster menu ➤ New.
   The New Image dialog box is displayed.

   **NOTE** If the Show New Image Dialog check box is cleared in the Raster Design Options dialog box, on the New Image tab, then you can access the command line interface. For more information, see New Image Tab (Raster Design Options Dialog Box) on page 356.

2. Do one of the following to choose the AutoCAD properties of your image:
   - Type the X, Y, and Z coordinates of the lower left corner of the image, and values for scale and rotation.
   - Click Pick to select two points on the AutoCAD screen that are used to define these properties.

3. In the Color Type area, select the color type of your new image, either Bitonal, Grayscale, Indexed Color, or True Color.

4. In the Image Properties area, review the values for width, height, and density and modify them if required.
   Specify width and height values using either image units (pixels) or surface units (meters, feet, etc.). You can use the Dots Per drop-down list to change surface units.

5. Click OK to close the dialog box and create the new image.
Quick Reference

Menu
Raster ➤ New

Raster Design Toolbar

Command Line

indow

ew

Dialog Box

New Image Dialog Box on page 344

Correlating Images

Use correlation procedures to precisely position, scale, and rotate an image within an AutoCAD drawing.

You can correlate an image during or after insertion. For instance, when using the Insertion Wizard, correlation data can be read from the image or from a file associated with the image. After you have inserted the image, you may want to rubbersheet the image to correct distortions that interfere with precise alignment of the image. Once you’ve aligned the image precisely, you can export correlation data for use in other drawings.

See also:

■ Exporting Images on page 50
■ Correlation Output Types on page 56

Correlating an Image During Insertion

You can choose from three methods to provide correlation data during insertion.

■ Quick Insert automatically inserts the image using correlation values embedded in the image file, correlation data stored in a separate file, or using default correlation values.
Insertion Wizard divides the insertion process into a series of steps that can vary depending on image type: assigning a color map, specifying a correlation source, setting various positioning values, and transforming coordinate systems. This method is recommended for new or intermediate users.

Insertion Wizard divides the insertion process into a series of steps that can vary depending on image type: specifying a correlation source, setting various positioning values. This method is recommended for new or intermediate users.

Insertion Dialog provides the same functions as the Insertion Wizard, but without the step-by-step process. You can change settings on the tabs of the dialog box in any order, then apply them to the image. This method is recommended for advanced users.

Using Quick Insert

You can use Quick Insert to perform automatic correlation during image insertion.

The Quick Insert option uses the correlation data stored with the image or in an associated file. Raster Design searches for a correlation data source using the following order:

1. Resource file
2. World file
3. Tab file
4. Image file

The highest order source is used to correlate the image after you click Open on the Insert Image dialog box. If Raster Design cannot find correlation data stored with the image, the image is inserted using the settings defined on the Image Defaults on page 353 tab of the Raster Design Options dialog box. For example, geographical maps are often used not in true scale, but in 1:1 scale. With Raster Design you can set the default value of the insertion point to 0,0, the scale to 1:1, and the rotation to 0, then use the Quick Insert method to make insertion quicker and more efficient.
To insert an image using Quick Insert

- In the Insert Options section of the Insert Image on page 340 dialog box, choose Quick Insert.

Quick Reference

Menu
- Raster ➤ Insert

Raster Design Toolbar

Command Line
- iinsert

Dialog Box
- Insert Image Dialog Box on page 340

Specifying Correlation Settings

You can use either the Insertion Wizard or the Image Insertion on page 327 dialog box to provide correlation settings at the time of image insertion.

The Insertion Wizard is recommended for new or intermediate Raster Design users, as it walks you through the correlation settings in a logical sequence. The Image Insertion dialog box presents the same settings on several tabs so you can review and modify the settings in any order.

The tabs are as follows, though you may see only three or four of them, depending on image type and application environment:

- The Assign Color Map on page 327 tab is presented when inserting digital elevation model (DEM) files or multispectral images, as you can choose various color map options before insertion.

- The Source on page 328 tab displays correlation data from the current correlation source for the image.

- The Modify on page 329 tab displays the correlation values in fields that you can modify to correlate the image.
The Transform on page 331 tab is presented only if Raster Design is running on a geographic application such as AutoCAD Map 3D. This tab is used to transform the coordinate system of an image.

The Insertion on page 330 tab displays the revised correlation values, reflecting any changes you made on the Modify and Transform tabs. Use this tab to review the settings before insertion and to select a color for the image frame or the foreground of a bitonal image.

To use the Insertion Wizard

1. In the Insert Options section of the Insert Image dialog box, choose Insertion Wizard.
2. After you have chosen your insert option and image file name, click Open.
3. If applicable, choose a color map for the image.
4. On the Pick Correlation Source panel, select a correlation source and review the displayed correlation settings.
   For correlation sources other than Image Default and Image File, the full path for the listed source is displayed for you to verify that the proper correlation file is being read. If you find that the desired correlation source is not available, you should cancel the insertion process and set the correlation path in the Raster Design Options on page 353 dialog box, or copy the correlation file to a new folder.
5. Click Next. The Modify Correlation Values panel is displayed.
   Modify correlation values
6. On the Modify on page 329 tab, in the Modify Correlation Values area, enter any required changes to the location of the insertion point, rotation, or scale.
   The insertion point is the lower left corner of the image in the drawing.
   The scale value represents the ratio of AutoCAD units to the scanned image units. A scale factor greater than 1 enlarges the image; a value less than 1 shrinks the image.
7. Optionally choose new units of measurement from the Image Units list.
   For example, if your image was scanned at 300 dpi, choose Inch as the density units. If density information was stored with the correlation source you selected, you cannot change this value.
8. Click Next.
If the Transform panel is displayed, complete step 9 to 14; otherwise go to step 15.

**Transform coordinate system**

9 Compare the coordinate systems of the image and of the current drawing, as displayed on the Transform on page 331 panel. If the two coordinate systems do not match, you should perform a coordinate transformation on the image to position it properly in the drawing.

10 To convert the image coordinate system, select the Transform to Drawing’s Coordinate System check box; otherwise, go to step 14. If you are transforming the image, select the appropriate Transform Type:
   - True (pixel by pixel): produces the most accurate results.
   - 4-Point Rubbersheet: approximate transformation, most accurate near the control points.
   - 3-Point Affine: replicates the transformation performed by FDO Connect.

11 If known, enter the code for the image coordinate system, then go to step 14.

12 Choose the coordinate system category used in your image from the list at the top of the dialog box.

13 Choose the coordinate system used in your image from the Coordinate Systems in Category list.

14 Click Next. The Insertion panel is displayed.

**Change AutoCAD insertion values**

15 Optionally, to change correlation values, do one of the following:
   - To specify numeric values, type coordinates in the X, Y, and Z boxes to identify the insertion point in the drawing, and type any required changes to the rotation and scale values.
   - to specify the insertion point (lower left corner), rotation, and scale on the screen, click the Pick button. The Pick button is dimmed if a coordinate transformation has been applied. For more information, go to Adjusting the Image Frame Before Insertion on page 29.

The Raster Design Insertion Wizard is modeless, which means you can leave the wizard open on your desktop and continue to grip-edit the image frame during correlation. Any grip editing changes that
you make to the image frame are reflected immediately in the Insertion Values dialog box.

16 Optionally, to change the color of the image frame, under Color, click Select.

**NOTE** Inserting a bitonal image on page 384 changes the foreground color. When you insert a bitonal image, Raster Design first looks for the foreground color in the correlation source specified. If it cannot find the color information, the foreground color defaults to current color.

17 Click Finish. The image is inserted into the drawing.

**To use the Insertion dialog box**

1 In the Insert Options section of the Insert Image dialog box, choose Insertion dialog box.

2 After you have chosen your insert option and image file name, click Open.

3 In the Image Insertion dialog box, review and modify correlation data on the available tabs.
   It is recommended that you review and modify data on the tabs from left to right: Assign Color Map, Source, Modify, Transform, then Insertion. Use the Source tab to see settings linked to the image, then modify the settings as required on the Modify and Transform tabs, finally review the results on the Insertion tab before inserting the image into the drawing. For more information about the settings on each tab, click the Help button on the tab or use the following links:
   - **Assign Color Map tab** on page 327
   - **Source tab** on page 328
   - **Modify tab** on page 329
   - **Transform tab** on page 331
   - **Insertion tab** on page 330

4 On the Insertion tab, click Finish. The image is inserted into the drawing.
Adjusting the Image Frame Before Insertion

You can manually or numerically adjust the frame size, scale, and rotation before inserting an image into a drawing.

This procedure is useful if you do not know the exact coordinates for the image, but you have a general idea of the image location, size, and rotation angle.

As you draw the frame on screen, its size changes proportionally to retain the aspect ratio of the image.

To adjust the frame for the image you want to insert

1 On the **Insertion Tab (Image Insertion Dialog Box)** on page 330, click Pick. The dialog box closes so you can select points on the screen.

2 Specify an insertion point.
   You can also enter coordinates on the command line, or, if correlation data is already specified, you can press Enter to accept the existing coordinates.
   An outline of the frame is displayed, reflecting the aspect ratio of the image you are inserting.

3 Enter the rotation angle or move the cursor to define the rotation angle.
   The Insertion tab displays the new coordinates, scale, and rotation.

4 Specify the second corner point to define the size of the frame.
   **NOTE** You can type UNDO to undo each point, and then specify the points again.

5 If you are using the Insertion dialog box, click Apply; if you are using the Insertion Wizard, click Finish.
   The image is inserted onto the current AutoCAD layer, and its correlation data is saved in the AutoCAD drawing. The next time you open the drawing, the image is displayed.
   **NOTE** You can select the frame and use grip(s) on page 392 or AutoCAD commands to size, move, or rotate the image while the Insertion Wizard is open.
Correlating an Image After Insertion

You can adjust the size and location of an image at any time after inserting it into a drawing.

For instance, you may need to correct distortions caused by scanning errors. There are several ways to ensure precise correlation of an inserted image:

- Match points on an image to points in your drawing in order to scale or rotate a raster image.
- Displace an image, to move it in reference to existing raster or vector entities without scaling or rotating it.
- Scale a raster image without rotating it.
- Rubbersheet an image to eliminate distortion and stretch or shrink a portion of your image to align with selected control points.

Matching Image Points

You can match points between two images or between an image and a vector drawing to change the image scale and position.

The image size and orientation change to align the selected match points.

To match image points

1. Click Raster menu ➤ Correlate ➤ Match.
2. Select one or more images to scale and rotate by clicking the image frames, then press Enter.
3. Specify the first source point on the selected image.
   
   **NOTE** You can select a point on the image frame by using object snaps, or you can select points on specific raster entities by using raster snaps.

4. Specify the destination point where you want the first source point to move to.
5. Specify the second source point on the selected image.
6. Specify the destination point where you want the second source point to move to.
NOTE If you are using AutoCAD Land Desktop, you can substitute COGO points by typing .p, .g, or .n when Raster Design prompts you to enter destination points. For more information, see Snapping to COGO Points on page 84.

Quick Reference

Menu
Raster ➤ Correlate ➤ Match

Raster Design Toolbar

Command Line
imatch

Moving an Image

You can move an image without rotating or scaling it so that a base point on the image matches with a destination point on an existing vector entity or raster image.

To move an image

1 Click Raster menu ➤ Correlate ➤ Displace.
2 Select an image to move by clicking its image frame.
3 Select the base point on the image you want to move.

NOTE You can select a point on the image frame by using object snaps, or you can select points on specific raster entities by using raster snaps.

4 Select the destination point for the image. This can be any AutoCAD point, a point on an existing vector, or a point on a raster image.
Quick Reference

Menu

Raster ➤ Correlate ➤ Displace

Raster Design Toolbar

Command Line

idisplace

Scaling an Image

You can match the scale of an image to the scale of a vector drawing or another image.

To scale an image

1. Click Raster menu ➤ Correlate ➤ Scale.
2. Select an image to scale by clicking its image frame.
3. Select a base point for the scale. This point acts as an anchor point for the image as its dimensions are scaled.

**NOTE** You can select a point on the image frame by using object snaps, or you can select points on specific raster entities by using raster snaps.

4. Define the source distance factor by typing a value or by selecting two points to define the distance.
   For example, if you want to match the scale of one image to another image, select two points on the source image that you want to match with points on the image that is correctly scaled.

5. Define the destination distance by typing a value or by picking two points to define the distance.
   For example, select two points on the correctly scaled image that you want the source image to align with. If the source and destination distance factors are the same value, then the image will not be scaled.
NOTE If you want to match the image rotation, use the Deskew option. If you want to move or scale the image as well as rotate the image, use the Match option. For more information, see Snapping to COGO Points on page 84 and Correlating an Image After Insertion on page 30.

Quick Reference

Menu
Raster ➤ Correlate ➤ Scale

Raster Design Toolbar

Command Line
iscale

Rubbersheeting an Image

You can transform an image to correct distortions in distance and shape. Image distortions can sometimes prevent you from aligning an image in your drawing. For example, correlation by scanning or matching may not work on aerial photographs that include distortions caused by parallax, unevenness of terrain, or lens distortion. In these cases, you can use rubbersheeting to permanently correct most of the distortions in an image.

Rubbersheeting uses a set of matched control points, consisting of source points in the image and destination points in the drawing. You can specify these points by picking them directly in the drawing, or by establishing a grid of destination points, to which you match source points. Once these control points are established, the image is transformed so that the points align as closely as possible.

NOTE If you are using AutoCAD Land Desktop, you can substitute COGO points by typing .p, .g, or .n when Raster Design prompts you to enter destination points. For more information, see Snapping to COGO Points on page 84.
There are two transformation methods you can use to correct your image:

■ The Triangular method draws a series of triangles between the control points, then applies the transformation to those areas. This process uses the Delaunay triangulation method in which no point lies inside the circle that includes the vertices of any triangle. Each triangular area is transformed separately, so this method is much more accurate than the polynomial method, but can result in the loss of some image data. The area to be transformed, called the convex hull, is defined by the outermost destination points. Image data outside the convex hull is discarded. You can see which portion of the image will be transformed using the Preview. If you want to preserve more of the image data, place control points near the extents of the image.

■ The Polynomial method transforms the entire image to match, as nearly as possible, the control points you specify. Unlike the triangular method, however, the actual destination points are not always located at the destination points you specified. The resulting positional error is expressed as a numerical value in the Rubbersheet dialog box, and is displayed graphically on the image after the control points have been entered. As shown in the following figure, the error for each point is measured as a distance from the intended destination point to the actual destination point.

The error is calculated using the following distance formula:

\[ e = \sqrt{\Delta x^2 + \Delta y^2} \]

The total RMS (Root Mean Square) error of the image is calculated using the following formula:

\[ RMS = \sqrt{\frac{e_1^2 + e_2^2 + e_3^2 \ldots + e_n^2}{n}} \]
By adjusting the polynomial degree, you can increase the accuracy of the matching points. However, reducing the error can create a higher degree of warping in the image as it is transformed to match the control points. Therefore, you should use the lowest possible polynomial degree that will still give you an acceptable result. Higher polynomial degrees result in smaller errors at the control points, but more warping at locations away from the control points.

The following table lists the maximum polynomial degrees possible for ranges of control points. For example, if you select 12 control points, the maximum polynomial degree you can select is 3. When the minimum number of control points is used for a particular polynomial degree, the reported errors at the control points will be zero.

<table>
<thead>
<tr>
<th>Number of Control Points</th>
<th>Maximum Polynomial Degree</th>
</tr>
</thead>
<tbody>
<tr>
<td>3-5</td>
<td>1</td>
</tr>
<tr>
<td>6-9</td>
<td>2</td>
</tr>
<tr>
<td>10-14</td>
<td>3</td>
</tr>
<tr>
<td>15-20</td>
<td>4</td>
</tr>
<tr>
<td>21-27</td>
<td>5</td>
</tr>
</tbody>
</table>

Raster Design does not limit the number of control points you can use.

The Preview tool allows you to see the extents of the transformed image before you actually apply the changes. The convex hull of destination points is displayed in red, while the convex hull of source points is shown in blue.

Using four points to rubbersheet (e.g., four corners of an image) usually results in error at these points. In some applications, such as when rubbersheeted images will be tiled, this error may be unacceptable. To eliminate this error, you can change the polynomial equation so that a zero error condition results from the use of four points rather than three points. This change is made in the system registry. For complete instructions, go to the Raster Design Support website (http://www.autodesk.com/rasterdesign-support) and search on the term “4 point rubbersheet”.
NOTE Rubbersheeting is best suited for making minor transformations to an image. For best results, start with a comprehensive and accurate network of survey control points, then use match and scale before rubbersheeting to get the image as close to the desired results as possible. It is also helpful to get a good spread of the control points over the entire image. Where you don’t have control points, you can specify anchor points.

TIP If you prefer to use the command line to rubbersheet your images, type -isheet.

NOTE Use the match feature to get the image as close as possible to the desired result before you begin rubbersheeting.

To rubbersheet an image

1. Click Raster menu ➤ Correlate ➤ Rubbersheet.
2. Select the image to rubbersheet.
3. On the Rubbersheet dialog box, select a method: Triangular or Polynomial.
4. Choose one of the following rubbersheeting methods:
   - Manually add control points by picking directly from the image. Follow steps 5 to 8.
   - Create a grid of destination points to which you can match source points. Follow steps 9 to 15.
   - Import a list of saved control points by clicking the Import button and choosing the .txt file from the Open dialog box.

NOTE When you click OK, Rubbersheet automatically saves the last control points you enter to a file named LASTRS.txt in your Temp folder.

The Rubbersheet dialog box displays the exact coordinates of each source point and destination point, and the amount of error (if any).

Pick control points

5. Click the Add Points button.
The Rubbersheet dialog box disappears and Raster Design prompts you to select the first source point. You must select at least three pairs of source points and destination points.

6 Select the first source point for the first control point on the image.

**NOTE** You can select points on specific raster entities by using raster snaps.

7 Do one of the following:
   - Specify the destination point to which the source point should be moved.
   - Type a to anchor the selected point where it is.
   - Type u to undo the point and select the point again.

**NOTE** If you are using AutoCAD Land Desktop, you can substitute COGO points by typing .p, .g, or .n when Raster Design prompts you to enter destination points. For more information, see Snapping to COGO Points on page 84.

8 Select at least three more pairs of source and destination points, and then press Enter to return to the Rubbersheet dialog box. Go to step 16.

9 Click the Grid Points button.
   The Rubbersheet dialog box disappears and the Grid Parameters dialog box appears.

10 In the Points section, choose how many rows and columns of points you want to comprise the grid.
   The total number of points in the grid is displayed at the bottom of the Points section.

11 In the Grid section, enter the X and Y origins of the grid, or click the Pick button to choose the grid origin directly from the drawing (pressing Enter to return to the Grid Parameters dialog box).

12 In the Cell section, enter the X and Y sizes to determine the distance between columns and rows (respectively), or click the Pick button to draw a two-point rectangle representing the cell size directly in the drawing (pressing Enter to return to the Grid Parameters dialog box).

13 Click the Preview button to see a representation of the grid in the drawing (pressing Enter to return to the Grid Parameters dialog box).
14 Click the Add Points button to match source points to the grid of destination points.
   The Grid Parameters dialog box disappears and Raster Design automatically pans to the first destination point.

   **NOTE** You can select points on specific raster entities by using raster snaps.

15 Do one of the following:
   - Click to enter a corresponding source point for the current destination point.
   - Type a to anchor the selected point where it is.
   - Type s to skip to the next destination point. Raster Design will return to this point when the other destination points have been matched to source points.
   - Type u to undo the point and select the point again. Raster Design automatically pans to the next point until all of the destination points have been matched to source points.

16 If you selected Polynomial as the transformation method, and you entered six or more control points, you can adjust the polynomial Degree value. This decreases error by increasing the degree to which an image can be transformed in order to match control points.

   **NOTE** It is a good idea to use the lowest possible polynomial degree that will still give you an acceptable result. Higher polynomial degrees result in smaller errors at the control points, but also result in more warping at places where there are no control points.

17 If you want to view a specific point, select that point from the list of control points, and then click the Zoom To button to view the point in the drawing.

18 If you want to adjust a specific point, select that point from the list of control points, and then click the Repick button to enter a new control point.

   **NOTE** Select the Auto Zoom check box if you want AutoCAD to zoom in to the selected control point when you use Repick.
19 If you want to remove a specific control point from the list, select that point from the list of control points, and then click the Delete button.

20 Click the Preview button to see the extents of the transformed image before you actually apply the changes. The convex hull of destination points is displayed in red, while the convex hull of source points is shown in blue. Press Enter to return to the Rubbersheet dialog box.

21 Click the Export button to save your control point set to a .txt file for later use.

NOTE You can import the saved control points to rubbersheet other images, such as superimposed images for the same drawing.

22 Click OK to perform the rubbersheet.

If you do not get the results you want, use the UNDO command and try again. Use the match feature to get the image as close as possible to the desired result. For more information, see Undoing Edits to an Image on page 83.

Quick Reference

Menu
Raster ➤ Correlate ➤ Rubbersheet

Raster Design Toolbar

Command Line
irsheet

Dialog Box

Grid Parameters Dialog Box on page 317
Saving Images

Images are saved and managed separate from the drawings that contain them.

There are several ways to save images in Raster Design:

- Click File ➤ Save/Save As. You are prompted to save each image that has changes, and then you are prompted to save the drawing. You can click Save As to save the image with a new name, location, or file format.

- Click Raster menu ➤ Save. This command saves an image without saving the drawing. You can save more than one image at a time using this command.

- Click Raster menu ➤ Save As. This command saves an image to another file name, file format, or location, without saving the drawing.

- Click Raster menu ➤ Capture. This command saves a displayed image or image set as a standard AutoCAD image, for use with Raster Design or other programs.

- Click Raster menu ➤ Image Embed. This command saves a bitonal image within the host drawing, making it easier to manage for transmission and storage.

- Click Raster menu ➤ Export ➤ Image. This command saves an image to a different file format and allows you to save correlation data separately in resource files and world files, for use with Raster Design or other programs. For more information, see Correlation Output Types on page 56. Export is the only way to save images displayed from digital elevation models (DEM) and multispectral data.

Saving an Image

After you edit an image, you can save it without saving your drawing.

You can save more than one image at a time using this method. The image will be saved using the current name and format.
To save an image without saving your drawing

1. Click Raster menu ➤ Save.
2. Select the image(s) you want to save.

   **NOTE** You can also select the image first, and then right-click to display the shortcut menu where you can select Image ➤ Write ➤ Save.

3. Press Enter to complete the selection set.
   The image(s) you selected are saved.
   If any of the images you select are unnamed, then the Save As dialog box is displayed so you can give the image a name, location, and file type. For more information, see Saving an Image to Another File Name, Type, or Location on page 45.
   If your image does not save correctly, verify the following
   - No copies of the image exist in other drawings.
   - The URL address you specified is correct.
   - The read-only attribute is not set on your disk.

   **NOTE** Raster Design uses Single Image Optimization on page 398 to speed up the editing commands.

**Quick Reference**

Menu
- Raster ➤ Save

Toolspace Shortcut Menu
- Image Insertions view, image ➤ Write ➤ Save

Object Shortcut Menu
- Image ➤ Write ➤ Save

Raster Design Toolbar
Saving Images with AutoCAD Save

You can use the AutoCAD Save option to save the changes to your images.

The AutoCAD Save option is standard for most Autodesk products that use Raster Design. When you save in this way, the correlation data for the images is stored in the drawing. The next time you open the drawing, the images are displayed.

**NOTE** You can use the AutoCAD UNDO command to undo each edit that you make, back to the last time you saved your drawing. The information pertaining to these edits is saved in a buffer file that can become quite large and reduce the performance of your system. Saving your drawing and images clears this buffer.

To save an image using the AutoCAD Save command

1. Click File menu ➤ Save. Or exit AutoCAD.
   
   You are prompted to save your drawing, and then you are prompted separately for each image that has changed. The name of the image to be saved is specified in the Save dialog box.

   **NOTE** You are only prompted to save your image files if you have modified image data. If you have changed only correlation information, then AutoCAD saves the correlation information but does not prompt you to save your image files.

2. Click one of the following:
   - **Save** saves the specified image and be prompted for the next image. This option saves the image using the same path, name, and format.
   - **Save All** saves all images with no further prompts.
   - **Skip** continues without saving the specified image and be prompted for the next image.
   - **Skip All** continues without saving any more images.
   - **Save As** saves the specified image to another path, name, or file format.
   - **Information** displays information about the image before you save it.
For certain file formats, such as TIFF, you are prompted for the encoding and data organization methods you want to use. For more information, see Encoding and Data Organization Methods on page 56.

Quick Reference

Menu
File ➤ Save

AutoCAD Toolbar

Dialog Box
Save As Dialog Box on page 369

Embedding Images in a Drawing

You can save bitonal images within a drawing to simplify file management. The regular Save operations save drawings and their associated images as separate files, often in different directories. This structure can be difficult to manage if you need to transfer drawings and images to other locations and retain the file relationships. Image embedding (iembed command) provides an alternative for bitonal images by saving them within the host drawing.

An embedded image can be removed from its host drawing and saved as an separate file by using the Un-embed (iunembed) or Save As (isaveas) commands.

To save an image using the Image Embed command

1 In the drawing window, select the image or images you want to embed.
2 Click Raster menu ➤ Image Embed.
3 Verify that the images are embedded in the drawing.
   In Image Manager, “_EMBED” is added to the end of the image name for each embedded image. If you need to open Image Manager, click Raster menu ➤ Manage.
To un-embed an image

1. In Image Manager, select the image you want to un-embed.
2. Right-click and click Un-embed.
3. In the Save As dialog box, specify the name, location, and format for the image.

Quick Reference

Menu
- Raster ➤ Image Embed

Command Line
- iembed, iunembed

Image Manager
- Right-click image ➤ Embed or Un-embed

Dialog Box
- Save As

Saving an Image to Another File Name, Type, or Location

You can save an image to another file name, file type, or location, without saving the drawing file.

For example, if you have edited an image and you do not want to modify the original image file, then you can save the edited image to a different file name.

If you have access to an FTP site, you can save your images to the Internet. For more information, see Saving an Image to an FTP Site on page 47.

The Save As option is also useful if you inserted a non-editable image file that you want to edit. This situation may occur if you inserted an image from a CD-ROM, for example, or if you inserted an image that has a file format that Raster Design cannot write to.

NOTE Raster Design uses Single Image Optimization on page 398 to speed up the editing commands.
To save an image to a different file name, file type, or location

1. Click Raster menu ➤ Save As.
2. Select the image to save. You can save only one image at a time using this command.
   The Save As on page 369 dialog box is displayed.
   
   **NOTE** You can also select the image first, and then right-click to display the shortcut menu where you can select Image ➤ Write ➤ Save As.

3. You can enter a different file name in the File Name box.
4. There are two methods you can use to navigate to a new location to which to save the image:
   - Choose the drive and folder using standard Windows navigation procedures.
   - Choose a location from the Places List on the left side of the dialog box to navigate directly to the My Documents folder (or the Personal folder, depending on which operating system you are using), the Desktop, or the Favorites folder.

5. You can save the image to a different file type by selecting a file type from the Save File as Type list.
   
   **NOTE** AutoCAD works best with certain image types. To optimize performance, export or save your images as tiled, compressed TIFFs whenever possible.

6. Click OK when you are ready to save the image.
   For certain file formats, such as TIFF, you are prompted for the encoding and data organization methods you want to use. For more information, see Encoding and Data Organization Methods on page 56
   
   **NOTE** If you have saved using the save as command, multiple copies of the image now exist, but all copies point to the new filename. For more information, see Save As Dialog Box on page 369.
Quick Reference

Menu
- Raster ➤ Save As

Toolspace Shortcut Menu
- Raster ➤ Write ➤ Save As

Object Shortcut Menu
- Raster ➤ Write ➤ Save As

REM Toolbar

Command Line
- isaveas

Dialog Box
- Save As Dialog Box on page 369

Saving an Image to an FTP Site

If you have access to an FTP site, you can save your images to the Internet.

To save an image to an FTP site

1. Click Raster menu ➤ Save As.
2. Select the image to save. You can only save one image at a time using this command.
   The Save As on page 369 dialog box is displayed.
3. Click the FTP icon in the Places List.
4. Click Tools menu ➤ Add/Modify FTP Locations.
   The Post to FTP Locations dialog box is displayed.
5. In the Name of FTP Site text box, enter the name of the FTP server.
6. In the Log On As section, select either Anonymous or User.
   If you select the User option, enter a username in the combo box.
Enter a password in the Password text box.

Click Add.

Click OK to return to the Save As dialog box.

Navigate the FTP site using standard Windows navigation methods.

You can enter a different file name in the File Name box.

You can save the image to a different file type by selecting a file type from the Save File as Type list.

Click OK when you are ready to save the image.

For certain file formats, such as TIFF, you are prompted for the encoding and data organization methods you want to use. For more information, see Encoding and Data Organization Methods on page 56.

NOTE If you have saved using the save as command, multiple copies of the image now exist, but all copies point to the new filename. For more information, see Save As Dialog Box on page 369.

Quick Reference

Menu

Raster ➤ Save As

Toolspace Shortcut Menu

Image Insertions view, Insertion object ➤ Write ➤ Save As

Object Shortcut Menu

Raster ➤ Write ➤ Save As

Raster Design Toolbar

Command Line

isaveas

Dialog Box

Save As Dialog Box on page 369
Capturing an Image

You can capture an image if it cannot be saved in the usual way, or if you want to preserve a specific display for later use.

An image capture is like a photograph of the displayed image on your screen. It is particularly useful when you want to prepare images for a presentation or a report. For example, you can capture several displays of satellite data with different color maps. Then you can edit these static images with regular Autodesk tools, and save them in a simpler format such as JPEG or TIFF.

The transparency setting in the source image is preserved in the capture. For complex images from digital elevation models (DEM) or multispectral data, the capture is simplified to a true color image with an Image Adjust color map.

When used with AutoCAD Map 3D, Raster Design can capture data from a layer in Display Manager, which can include Feature Data Objects (FDO) and other imported data. In this type of capture, you have several options for the capture, such as capturing the stylized display or the source data, selecting the capture area, resolution, and type of coordinate transformation, if applicable.

To capture an image

1. Click Raster menu ➤ Capture.
   If you are using AutoCAD Map 3D and capturing a raster layer, the Display Manager Raster Layer Capture Dialog Box on page 309 is displayed for you to specify capture parameters such as the data type, area, resolution, and type of coordinate transformation.
   The current image is captured and inserted into the display, directly on top of the source image. The capture is also added to the top of the Image Manager tree.

2. If you want to save the capture with a different name, format, or location, select the capture, right-click and click Raster menu ➤ Write ➤ Save As.

Quick Reference

Menu

Raster ➤ Capture
Exporting Images

Use Export commands to save an image to a different file format or to save correlation files for the image.

Exporting is the only way to save images displayed from digital elevation models (DEM) and multispectral data. These images are saved in GeoTIFF format.

Use the options in the Export Options on page 315 dialog box to handle image correlation data and rotation values, if applicable.

**NOTE** If you want to save an image to another file format, name, or location, without saving correlation information, then do not select a correlation output type, or use the Save As option instead. For more information, see Save As Dialog Box on page 369.

Correlation files store insertion point, scale on page 398, rotation angle on page 397, and density on page 389 information for the image. GeoTIFF files can also include coordinate system data. Depending on the file format you select, you can save the correlation information to a resource file on page 397, a world file on page 402, or to the image file. Normally, these files are saved to the same location as the image file. However, you can control this path on the Paths tab on page 357 of the Raster Design options dialog box. For more information, see Correlation Search Paths on page 249.
Correlation files store insertion point, *scale* on page 398, *rotation angle* on page 397, and *density* on page 389 information for the image. Depending on the file format you select, you can save the correlation information to a *resource file* on page 397, a *world file* on page 402, or to the image file. Normally, these files are saved to the same location as the image file. However, you can control this path on the *Paths tab* on page 357 of the Raster Design options dialog box. For more information, see *Correlation Search Paths* on page 249.

If you want to export correlation as a world file without exporting the associated image, you can use the iworldout command.

**NOTE** Raster Design uses *Single Image Optimization* on page 398 to speed up the editing commands.

For certain file formats, such as TIFF, you are prompted for the encoding and data organization methods you want to use. For more information, see *Encoding and Data Organization Methods* on page 56.

### Exporting an Image

You can export images in order to save them to new locations, file names, or file types.

You can also save image correlation data as a separate file.

#### To export an image

1. Click Raster menu ➤ Export ➤ Image.
2. Click the frame of the image you want to export. The *Export* on page 313 dialog box is displayed.
3. In the Files Of Type box, select the desired format for the new image. If you are exporting a DEM or multispectral image the type must be GeoTIFF.

**NOTE** AutoCAD works best with certain image types. To optimize performance, export or save your images in tiled compressed TIFF format whenever possible.

4. Optionally, to navigate to a new location to which to export the image, do one of the following:
   - Select the drive and folder using standard Windows navigation procedures.
Select a location from the Places List on the left side of the dialog box to navigate directly to the My Documents folder (or the Personal folder, depending on which operating system you are using), the Desktop, or the Favorites folder.

5 In either the File Name or Base Name box, enter a name for the image file or select a file name from the list.

**NOTE** You cannot export an image to a file name that is locked. For example, if one person loads image1.tif and locks the raster image file, then another person can not export image2.tif to image1.tif because the first person has a raster file lock for image1.tif. For more information about locking image files, see Locking Method for Image Files on page 260.

6 Click Export.

7 In the **Encoding Method** on page 313 dialog box, specify whether to compress the image, and if so, which encoding method to use. Click Next.

8 In the **Data Organization** on page 309 dialog box, specify Tiled, Stripped, or Monolithic. Click Next.

9 In the **Export Options** on page 315 dialog box, specify the relationship between the exported image and the drawing. Specify how to handle image rotation, if applicable, and correlation data.

10 Do one of the following:

   ■ If a Finish button is displayed at the bottom of the screen, click the button to export the image.

   ■ If a Next button is displayed at the bottom of the screen, click the button to open the Coordinate System Assignment on page 307 dialog box, where you can select a GeoTIFF coordinate system for the exported image.

**Quick Reference**

Menu

Raster ➤ Export ➤ Image
Exporting an Image to an FTP Site

If you have access to an FTP site, you can export your images to the Internet.

To export an image to an FTP site

1. Click Raster ➤ Export ➤ Image.
2. Select the image to export. You can export only one image at a time using this command.

   **NOTE** You can also select the image first, and then right-click to display the shortcut menu where you can select Image ➤ Write ➤ Export.

3. In the Export Data on page 313 dialog box, click the FTP icon in the Places List.
4. Click Tools menu ➤ Add/Modify FTP Locations. The Post To FTP Locations dialog box is displayed.
5. In the Name Of FTP Site text box, enter the name of the FTP server.
6. In the Log On As section, select either Anonymous or User. If you select the User option, enter a username in the combo box.
7. Enter a password in the Password text box.
8. Click Add.
9. Click OK to return to the Export dialog box.
Navigate the FTP site using standard Windows navigation methods.

You can enter a different file name in the File Name box.

You can export the image to a different file type by selecting a file type from the Save File as Type list.

Click OK when you are ready to export the image.

For certain file formats, such as TIFF, you are prompted for the encoding and data organization methods you want to use. For more information, see Encoding and Data Organization Methods on page 56.

**NOTE** If you have saved using the Save As option, multiple copies of the image now exist, but all copies point to the new filename. For more information, see Save As Dialog Box on page 369.

### Quick Reference

**Menu**

Raster ➤ Export ➤ Image

**Toolspace Shortcut Menu**

Image Insertions view, Insertion object ➤ Write ➤ Export

**REM Toolbar**

**Command Line**

iexport

**Dialog Box**

Export Dialog Box on page 313

### Exporting a World File

You can export the image correlation without exporting the entire image by using the iworldout command to create a world file on page 402.
The resulting world file shares the same file name as the associated image, but the extension ends in a “w” (for example, the world file for lakshor.tif is lakshor.tfw).

**NOTE** Raster Design exports world files based on World coordinates and imports them based on the current UCS.

**To export a World File**

1. Click Raster menu ➤ Export ➤ World File.
2. Type a path to which to save the file, or press Enter to accept the default path.

**NOTE** By default this command saves the world file to the same location as the image file. However, you can control this path on the Paths tab of the Raster Design Options dialog box. For more information, see Correlation Search Paths on page 249.

**Quick Reference**

**Menu**

Raster ➤ Export ➤ World File

**Toolspace Shortcut Menu**

Image Insertions view, Insertion object ➤ Write ➤ Export

**Raster Design Toolbar**

[Image icon]

**Command Line**

iexport

**Dialog Box**

Export Dialog Box on page 313
Correlation Output Types

Depending on what type of image you are exporting, you can choose from among some of the following correlation output file types:

■ Bitonal Images. Use to creates resource files compatible with Raster Design ESP version 7 (or higher).

■ Color or Grayscale Images. Use to creates resource files compatible with Raster Design 7.5 (or higher). You can save the correlation data externally, rather than in the drawing, so that you can use the same correlation data in another drawing.

■ World File. Use if you need to transfer the image to another program that can use a world file on page 402, such as a mapping program. You can use the iworldout command to export a world file without exporting the associated image.

■ Resource File. Use to share images with other Raster Design users, or for inserting the image into another drawing. A resource file has a .RES extension. You can create resource files for all image types.

■ Image File. Use with file types that can store correlation information within the image file. Image File is also a correlation output type option when you are saving an RLC image.

■ GeoTIFF. Use with TIFF files to store correlation information within the image file.

NOTE Both Resource files and World files are saved to the path specified in the Raster Design Options dialog box. If no correlation search path is designated, Raster Design uses the folder where the image file is stored. For more information, see Correlation Search Paths on page 249.

Encoding and Data Organization Methods

When you export certain file formats, such as TIFF, you are prompted for the encoding and data organization methods you want to use. If you are uncertain about which method to choose, then accept the default, which reflects how the image was saved previously.

NOTE AutoCAD works best with certain image types. To optimize performance, export or save your images in tiled compressed TIFF format whenever possible.
To choose a method of data encoding (compression) and data organization

1 In the Encoding Method dialog box, choose an encoding method to reduce the image file size. If file size is not an issue, then select the Uncompressed option.

**NOTE** If you are unsure which method to choose, then accept the default, which reflects how the image was saved previously.

2 Click Next to display the Data Organization dialog box. The data organization method affects how your image data is stored, regardless of the encoding method. Choose one of the following methods:

- Monolithic stores all image data together (not recommended for large images).
- Stripped stores the image data in strips.
- Tiled stores the image data in tiles.

3 Click Finish to complete the process, or click Back to return to the Encoding Method page.
Changing Image Properties

You can use the AutoCAD Properties window to specify image properties.

**AutoCAD Properties**

In the AutoCAD Properties window, you can specify image properties.

The properties are as follows:

- Layer
- Color
- Linetype
- Display options, including image transparency, visibility, brightness, contrast, and fade values
- Geometry settings, such as X, Y, and Z position, rotation, width, height, and scale

When an image mask is selected, you can turn the mask on or off, turn image frames on or off, and set properties of the images outside the mask.

You can also use the Properties window to obtain the following information about the image:

- Name
- Path (saved path)
- File type and size
- Dates when the image was created and last modified
- Color depth and type
If the image contains raster entity manipulation (REM) objects, you can use the Properties window to see detailed specifications of these objects.

**Image Display Properties**

You can choose to hide or display images in your drawing to improve the system redraw time.

You can also hide/show and unload/reload images from the Image Manager Toolspace on page 332.

**To change image display properties**

1. Click the frame of the image(s) you want to change, then right-click ➤ Properties.

   **TIP** If you are zoomed in and cannot see the image frames, press Shift + left-click to select the image(s).

2. Click the Show Image property, then select Yes or No from the list.

3. Click the Show Clipped property, then select Yes or No from the list.

4. Close the Properties dialog box.

   For more information on the Properties window, see the AutoCAD Command Reference in the AutoCAD Help or Users Guide.

**Image Display Quality**

You can display your images in high quality or draft quality.

High quality involves dithering the pixels so that the transitions between pixels appear more gradual. Draft quality can speed up the performance of your system, but may reduce the quality of some color and grayscale images on screen.

**To change the image display quality**

1. Select an Image, then right-click ➤ Properties.
2 Click the Quality Setting property, then select a new setting from the list:
- High dithers the pixels. Color and shade differences between pixels are blended for a more realistic appearance.
- Draft does not dither the pixels. This setting is recommended for bitonal images, or whenever you want to see the pixel size.

*NOTE* The display quality setting affects only how the image is displayed on screen. It does not alter in any way the contents of the image file.

3 Close the Properties dialog box.

**Image Frame Display**

You can choose to display the image frame on page 393 above the images, behind the images, or you can turn off the frames.

When frames are behind the images, you can still select an image by selecting the frame. However, when you turn frames off, you cannot select an image frame.

**To change how image frames are displayed**

1 Click the frame of the image(s) you want to change, then right-click ➤ Properties.

*NOTE* If you are zoomed in and cannot see the image frames, press Shift + left-click to select the image(s).

2 Click the Frame Setting property, then select a setting from the list:
- Frame above displays the frame above the image.
- Frame below hides the frame behind the image, but you can still select the image by selecting the frame.
- Frames off turns off the frames. If frames are turned off, you must use the Shift + left-click select method to select an image.

*NOTE* If you use the Toggle Frames option to turn the frames off and then turn them on again, the frames reappear above the image. For more information, see Changing the Image Frame Visibility on page 244.
Close the Properties dialog box.

**Image Layer**

When you insert an image, it is inserted onto the current AutoCAD layer. However, you can move the image to another layer. The following layer properties allow you to control image display, image editing, and image saving.

<table>
<thead>
<tr>
<th>Layer Properties</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>On/Off</td>
<td>Turns images on and off. Images that are off are still regenerated.</td>
</tr>
<tr>
<td></td>
<td>When a layer is off, you can save an image to the layer, but you cannot edit an image on that layer.</td>
</tr>
<tr>
<td>Thaw/Freeze</td>
<td>Saves the image. You cannot display or edit an image on a frozen layer. The system does not update a frozen layer.</td>
</tr>
<tr>
<td>Unlocked/Locked</td>
<td>Displays and saves an image on a locked layer. You cannot edit a locked layer.</td>
</tr>
<tr>
<td>Color</td>
<td>A bitonal image can use the color of the layer. For more information, see Foreground Color of a Bitonal Image on page 63.</td>
</tr>
</tbody>
</table>

**TIP** If you have multiple images on top of each other, and you do not want to rub, crop, or mask all of the images, you can lock a layer containing an image you do not want modified.

**To move an image to a different layer**

1. Click the frame of the image(s) you want to move to a different layer, then right-click ➤ Properties.

   **TIP** If you are zoomed in and cannot see the image frames, press Shift + left-click to select the image(s).

2. Click the Layer property, then select a new layer from the list.

3. Close the Properties dialog box.
Linetype of an Image Frame
You can select a different AutoCAD linetype for an image frame.

To change the linetype of an image frame
1  Click the frame of the image(s) whose linetype you want to change, then right-click ➤ Properties.
2  Click the Linetype property, then select a new linetype from the list.
3  Close the Properties dialog box.

For more information on the Properties window, see the AutoCAD Command Reference in the AutoCAD Help or Users Guide.

Foreground Color of a Bitonal Image
The foreground color is used for the raster entities in a bitonal image.

The foreground color is also known as the color map of a bitonal image. It can be changed from the Image Manager toolspace, just like color maps for other image types.

You can select a color for the image from the current palette or have the image use the color of the AutoCAD layer it is on.

To change the foreground color of a bitonal image
1  Click the frame of the bitonal image(s) you want to change.

TIP  If you are zoomed in and cannot see the image frames, press Shift + left-click to select the image(s).

2  Right-click, then choose Properties from the short-cut menu.
3  Click the Color property, then select a new color from the drop-down list.
4  Close the Properties dialog box.

For more information on the Properties window, see the AutoCAD Command Reference in the AutoCAD Help or Users Guide.
Quick Reference

Toolspace Shortcut Menu
- From color map object ➤ Edit Color Map

Object Shortcut Menu
- Properties, Color

Command Line
- properties

Transparent Color of an Image

You can make one color in each image transparent.

Making a color transparent is helpful if you want to see information that is displayed behind the image. In a bitonal image, the transparent color is always the background color of the image. For grayscale and color images, you can choose the transparent color.

The transparent color is also used to replace data that is removed when you edit an image using the rub or crop commands. If background transparency is turned on for the image, the rubbed areas (or the slack space in a cropped image) become transparent. For more information, see Cropping Images on page 147 and Removing (Rubbing) Images on page 151.

If you merge two images, the transparent color that is used to fill the space between the two images depends upon the display order you specify in the Image Manager Toolspace on page 332. To use the transparent color of the first image in the list for the fill color, click Raster menu ➤ Merge ➤ Images.

Sometimes you may want to designate an unused color as the transparent color. For instance, when merging images, turning on background transparency may make some desirable pixels transparent. The background command allows you to designate an unused color in a grayscale image as the transparent color. Pixels with a value of 255 (white) are changed to a value of 254 (near white), then the transparent color is set to a value of 255. The resulting image will have no pixels with a value of 255.

NOTE Changing the transparent color does not affect the color of the existing rubs and crops.
To change the transparent color

1. Zoom in on the image so you can accurately select the color.
2. Select the image, then right-click ➤ Properties.

   **NOTE** If you are zoomed so you cannot see the image frames, press Shift + left-click to select the image.

3. Click the Transparent Color property, then click the button in the property field.
   The Transparent Color dialog box is displayed.

   **NOTE** Selecting a color is necessary only for color and grayscale images. To make a bitonal image transparent, skip to step 7.

4. Click Select.
   The cursor changes shape and the dialog box temporarily disappears so that you can choose a color from the image.

5. Pick the desired color on the image, and click OK.

6. Click the Background Transparency property, then select Yes from the list to make the color you just selected transparent.
   If you want to use the color for rubbing and cropping but you also want the color displayed in the image, select No for Background Transparency.

   **NOTE** Changing the transparent color does not affect the color of the existing rubs and crops.

7. Close the Properties dialog box.

**Unused Color for Transparent Color**

The `background` command allows you to designate an unused color as the transparent color.

This is especially useful for merging images in which the designated transparent color in one image may cause valuable pixels in the other image to become transparent.
To designate an unused color as the transparent color

1. On the command line, enter rbackground.
2. Select the image or images that you want to change, and then press Enter.

**NOTE** You can also select your image or images before you use the rbackground command.
Managing Images and Insertions

Each instance of an image that you insert into a drawing is called an insertion. Each insertion is based on an image data definition. Changing the attributes of an insertion does not affect the image data definition.

The Raster Design Image Manager on page 332 provides two views of the image data in a drawing:

- The Image Insertions on page 333 view focuses mainly on the screen display; the object tree shows only image insertions and color maps.
- The Image Data on page 334 view is more detailed, showing the data elements associated with an image.

Each view provides different shortcut menus for object types, and an item view that shows properties of the insertions and data in tabular form. In the Image Insertions view, a button at the top of the toolspace toggles between the item view and the image preview.

Controlling the Image Manager Toolspace

You should understand several controls to make the Image Manager work best for you.

For more information on the toolspace controls, see Image Manager on page 332.

Modifying the Item View Layout

For some image data, you can choose which columns to display and change the order of columns in the table.
The Image Manager item view is editable for object types such as the drawing, where the data display is a table of three or more columns. This format is more common in the Image Data view than in the Image Insertions view. Some object types, such as the color map show a two-column item view (Properties and Value) that is not editable.

To modify the layout of the Item View table

1. To display the Image Manager on page 332 toolspace, click Raster menu ➤ Manage..

2. Choose either the Image Insertions or Image Data view, then click the drawing name at the top of the tree.

3. In the tabular item view, click a column-head and drag it left or right in the list to change the order of the columns.

4. Right-click a column head to see a menu where you can show or hide columns in the table.
   Displayed column headings are checked. If you want to remove a column from the display, clear the check mark for the column name.

5. Click a column head to sort the information in the table by that column.

6. Click and drag the edge of the dialog box to resize it.

   **NOTE** You can also change the width of the columns. Just click on the line between column headings and drag it left or right. When you click Close, your changes to the column widths are saved and used the next time you open the dialog box.

### Copying Information to the Clipboard

You can transfer reference information about raster insertions or images to other applications.

Both views of the Image Manager toolspace display data about the images in the drawing. Where this data is displayed in a table of three or more columns, you can transfer the data to other applications by copying the contents of one or more selected rows to the Clipboard, then pasting it into the other application window.
To copy item view data to the Clipboard

1. To display the Image Manager on page 332 toolspace, click Raster menu ➤ Manage.
2. Choose the row(s) you want to copy from the toolspace item view.
3. Right-click and click Copy to Clipboard.
4. Click Close.

Managing Image Display and Data

You can arrange the images within a drawing, removing or restoring them, and changing their saved location.

Multiple insertions of an image can show different views of the data.

This is especially useful with multispectral and digital elevation model (DEM) data. For example, you could have one DEM insertion with a color map that shows elevation bands and another insertion that shows ground slopes.

The Image Insertions on page 333 view of the Image Manager toolspace is especially useful for zooming to an image, changing image display order, and editing color maps. You can change the attributes of an insertion, without affecting the image source data.

The Image Data on page 334 view is useful for creating new image insertions and managing the image data in your drawing.

See also:

- Embedding Images in a Drawing on page 44

Zooming to an Image

You can use the Image Manager toolspace to zoom to the extents of one or more insertions.

If you can see the frame of an image, you can also zoom to it by right-clicking the frame and selecting Image ➤ Zoom To. This is especially useful if you are zoomed in close and want to zoom out to see the complete image.
To zoom to an image

1 To display the Image Manager on page 332 toolspace, click Raster menu ➤ Manage..

2 Click the Image Insertions on page 333 view.

3 Click the name of the insertion or insertions you want to see, then right-click and click Zoom To.

Quick Reference

Toolspace Shortcut Menu

Image Insertions view: right-click image name ➤ Zoom To

Object Shortcut Menu

Right-click image frame ➤ Image ➤ Zoom To

Changing the Color Map of an Image

You can change the color map to modify the appearance and the type of data displayed in the image.

The complexity of this procedure varies with color map type, as detailed in the following table.

<table>
<thead>
<tr>
<th>Color Map Type</th>
<th>Color Map Editing Process</th>
</tr>
</thead>
<tbody>
<tr>
<td>Bitonal</td>
<td>Use AutoCAD Select Color dialog to choose foreground color</td>
</tr>
<tr>
<td>Image Adjust</td>
<td>Use AutoCAD Image Adjust dialog to set image brightness, contrast, and fade levels</td>
</tr>
<tr>
<td>Palette</td>
<td>Use Palette Assignment Color Map on page 347 dialog to choose or edit a palette color map</td>
</tr>
<tr>
<td>Band Assignment</td>
<td>Use Band Assignment Color Map on page 303 dialog to assign image bands to color channels</td>
</tr>
</tbody>
</table>

NOTE To remove all unused color maps from a drawing, type ipurgecm at the command line.
To change the color map of an image

1. To display the Image Manager on page 332 toolspace, click Raster menu ► Manage..
2. Click the Image Insertions on page 333 view.
3. Click the image insertion for which you want to change the color map, right-click and click Edit Color Map. Depending on image type, the applicable dialog box opens.

**NOTE** If you edit an existing palette color map that is used by several images in the drawing, the changes will affect all of the images. To affect only one image, you can assign the color map that is closest to what you want, then copy that color map and rename it.

4. Make changes as required.

---

**Adding a Visual Elevation Key to a DEM Image**

You can add a small image that displays how colors are mapped to elevation ranges from lowest to highest on a digital elevation model.

![Sample elevation key](image)

To make the elevation key more useful, add elevation values to the color bands.
To add a visual elevation key

1. Click Raster menu ➤ Insert. Navigate to Raster Design\Samples, and insert the image elev_small.dem into your current drawing.

2. In the Image Manager toolspace, expand the object tree under the image elev_small, right-click the color map, and click Edit Color Map.

3. In the Palette Assignment Color Map dialog, select the color map that is used in your primary image.

4. Adjust the size and location of the elevation key in relation to the primary DEM image.

Creating Another Insertion of an Image

You can insert another copy of an image when you want to use a different type of color map or make other display changes.

When you create another insertion of an AutoCAD image object (bitonal, grayscale, index color or true color), you use the same type of color map, which you can edit later.

Some of the custom image types that Raster Design handles can use two or three different types of color maps, and the only place where these options are presented is on the Image Data on page 334 view of the Image Manager toolspace, when you right-click the image data definition. If you right-click an existing color map, you can create a new image insertion using the same color map type.

When the image data definition is in single-band integer format, such as IKONOS 16-bit, a new insertion can use either a grayscale or palette color map.

When the image data definition is multispectral, a new insertion can use a grayscale, palette color, or false color map.

To create another insertion of an image

1. To display the Image Manager on page 332 toolspace, click Raster menu ➤ Manage..
2 Right-click the image data definition for which you want a new insertion and click New Insertion.

If the image is of single-band integer or multiband multispectral format, you see a submenu with two or three color band types to choose from. As shown in the following table, some of these choices invoke another dialog box where you configure the color map to your needs.

<table>
<thead>
<tr>
<th>Image Data Type</th>
<th>Color Map Type</th>
<th>Dialog Box</th>
</tr>
</thead>
<tbody>
<tr>
<td>Single-band integer</td>
<td>Palette color</td>
<td>Palette Assignment Color Map Dialog Box on page 347</td>
</tr>
<tr>
<td>Multiband Multispectral</td>
<td>Grayscale</td>
<td>Assign Multispectral Band Dialog Box on page 303</td>
</tr>
<tr>
<td></td>
<td>Palette color</td>
<td>New Palette Color Insertion Dialog Box on page 346</td>
</tr>
<tr>
<td></td>
<td>False color</td>
<td>Band Assignment Color Map Dialog Box on page 303</td>
</tr>
</tbody>
</table>

The new insertion is added to the drawing.

**Displaying Point Data**

Interactively display the cursor location and data about the image pixel at that location.

The Raster Data Query dialog box always tracks the cursor location and displays the color values of the image pixel at that location. Other data values associated with the pixel are displayed, subject to image type.

For example, if the image is displayed from a digital elevation model (DEM) with a color map that interprets elevation values, the elevation of the pixel at the cursor location is displayed. If Raster Design is running on Autodesk Map, the working coordinate system is also displayed.
To query pixel data in an image

1. Click Raster menu ➤ Raster Data Query. The Raster Data Query dialog box is displayed.
2. Optionally, resize the dialog box or dock it in the left pane.

Quick Reference

Menu

Raster ➤ Raster Data Query

Raster Design Toolbar

Dialog Box

Raster Data Query Dialog Box on page 352

Showing and Hiding Images

You can use the Image Insertions view of the Image Manager toolspace to show or hide an image.

The Hide operation causes the least change to an displayed image, as compared to unload on page 402, erase on page 391, or detach on page 389. A hidden image is removed from the display, but the frame remains visible and the image data remains in the toolspace tree.

Use Show to restore a hidden image to the display. If an image has been unloaded, a show operation reloads it.

To show or hide an image

1. To display the Image Manager on page 332 toolspace, click Raster menu ➤ Manage..
2. Click the Image Insertions on page 333 view.
3. Click the insertion whose display status you want to change, then do one of the following:
   - If the image is hidden, right-click and click Show.
   - If the image is displayed, right-click and click Hide.
Quick Reference

Toolspace Shortcut Menu
Image Insertions view: right-click insertion ➤ Hide/Show

Object Shortcut Menu
Click image frame, right-click Image ➤ Hide/Show

Command Line
ihideimage, ishowimage

Dialog Box
Image Insertions View (Image Manager Toolspace) on page 333

Changing the Display Order of Images

You can change the order in which images are stacked for display in the drawing.

The Image Insertions view of the Image Manager toolspace shows the display order of inserted images. Insertions at the top of the tree are at the top of the display order. New image insertions are placed at the top of the tree, but you can manually move them.

Display order is especially important if you want to layer a transparent bitonal image directly above another image.

NOTE When you perform an editing command on an image, the display order changes so that the image you modified is displayed on top of the other images. To correct this, type REGEN on the command line. You do not need to change the image order using the method described here. For more information, see Correcting Image Display Order using REGEN on page 275.

To change the order in which your images are displayed

1. To display the Image Manager on page 332 toolspace, click Raster menu ➤ Manage..
2. Select the Image Insertions on page 333 view.
3. Click the insertion you want to move, then right-click and select the type of move: Move Forward, Move Back, Bring to Front, Send to Back.
Erasing an Image

You can erase an image from the AutoCAD drawing when you no longer need it.

When you erase on page 391 an image, you can also detach on page 389 it, subject to the Image Detach Options set on the User Preferences Tab (Raster Design Options Dialog Box) on page 360. If you want to simply remove the image from the display, without having to reconstruct it later, consider using the hide on page 392 or unload on page 402 operations.

To erase an image

1 To display the Image Manager on page 332 toolspace, click Raster menu ➤ Manage..
2 Click the Image Insertions on page 333 view.
3 Click the insertion you want to erase, right-click and click Erase.

If no more insertions from this image data definition remain in your drawing, you may be asked if you want to detach the image. Detaching removes the image data definition from the drawing.

NOTE If you want to restore the images, click Edit ➤ Undo.

Detaching an Image

Use the Detach operation to completely remove from a drawing an image data definition and all its insertions.

The detach on page 389 operation is the most complete image removal method. If you want to simply remove the image from the display, without having to insert it later, consider using the hide on page 392 or unload on page 402 operations.

To detach an image

1 To display the Image Manager on page 332 toolspace, click Raster menu ➤ Manage..
2 Click the Image Data on page 334 view.

3 Click the image data definition you want to detach, then right-click and click Detach.

Unloading/Reloading an Image

Unloading an image removes the image data from working memory without erasing the image objects from the drawing.

To improve application performance, you can unload images you no longer need. An unloaded image cannot be displayed or plotted. The unload on page 402 operation is just one of several image removal methods. For temporary removal, consider the hide on page 392 operation. For more complete removal, consider the erase on page 391 and detach on page 389 operations.

Reloading puts the image back into working memory and redisplays it.

To unload or reload an image

1 To display the Image Manager on page 332 toolspace, click Raster menu ➤ Manage..

2 Select the Image Data on page 334 view.

3 Click the data definition for the image you want to change, then do one of the following:
   ■ If the image is loaded, right-click and click Unload.
   ■ If the image is unloaded, right-click and click Reload.

Changing the Active Path

The active path is the current location of the inserted image file.

Compare the definitions for active path on page 383 and saved path on page 398. The current active path is visible in the list view of Image Manager when you select the image. This is also where any changes to the image are saved if you click Raster menu ➤ Save..

If you want to edit an image without changing the original version, you should save a copy in a different location and file format. To do this, click Raster menu ➤ Save As. Doing this also directs the active path to the copy. For more
information, see Saving an Image to Another File Name, Type, or Location on page 45.

To change the active path

1 To display the Image Manager on page 332 toolspacce, click Raster menu ➤ Manage..

2 Click the Image Data on page 334 view.

3 Select the image data definition whose active path you want to change, then right-click and click Browse Path.

4 In the Insert Image dialog box, navigate to the correct image data location, then choose the image file and click Open.

The active path is updated to reflect the new location of the image.

Changing the Saved Path

The saved path is where Raster Design looks first for the image.

Usually, the active path on page 383 and saved path on page 398 are identical. If the saved path file name is not found, Raster Design searches other paths until it finds the image. The search order of paths is as follows:

1 Saved path
2 Current folder (usually the AutoCAD folder)
3 Folder where the current drawing is stored
4 The AutoCAD current project search paths are searched in the order listed on the Files tab of the AutoCAD Options dialog box.

Raster Design searches for the file name and extension (if there is one). If the file name is not found, Raster Design searches the same path for the file name with every other valid extension.

If you want to decrease the time Raster Design spends searching for the image, you can designate the active path as the saved path.

TIP If you are saving the image in the same directory as the drawing, you can use the Clear Path option to save only the image name, without a full path. This can be useful when you are preparing sets of drawings and images that will reside in the same directory.
To designate the active path as the saved path

1  To display the Image Manager on page 332 toolspace, click Raster menu ➤ Manage..

2  Select the Image Data on page 334 view.

3  Choose the image data definition whose saved path you want to change, then right-click and click Save Path.

To clear the saved path

1  To display the Image Manager on page 332 toolspace, click Raster menu ➤ Manage..

2  Select the Image Data on page 334 view.

3  Choose the image data definition whose saved path you want to delete, then right-click and click Clear Path.
Modifying Images

Raster Design provides several tools for modifying images.

- **Cleanup.** Correct scanning errors or minor imperfections in bitonal images. You can deskew, despeckle, touchup, adjust the bias, invert, or mirror an image.

- **Image Processing.** Adjust the appearance of an image. For example, you can use the convolve filter to reduce harshness or noise in an image.

- **Raster Entity Manipulation (REM).** Edit raster entities in bitonal, color, and grayscale images. For example, you can adjust the radius of a raster circle, remove dimension lines on a mechanical drawing, or use REM to copy electrical symbols from one image to another.

- **Mask.** Clip images inside the mask boundary and hide or unload images outside the mask boundary. A mask does not permanently alter an image.

- **Crop.** Delete data outside a selected area. The image frame size is adjusted automatically. A crop permanently alters an image.

- **Remove.** Rub raster data within an image or across multiple images. The only images affected are those within, or partly within, the selected entity or area.

- **Merge.** Merge images, merge vectors into raster data, and select raster pen widths.

- **Properties.** Adjust the attributes of an image such as position or transparent color.

Selecting an Image

This topic explains how to select an image if you have more than one in a drawing.
If your drawing contains only one image, Raster Design automatically selects it when you run a command that requires a selection set. Otherwise, you can use one of two methods to select a specific image.

- Click on the frame (if it is visible), or draw a crossing window around a frame edge. When you do this, grip(s) on page 392 are displayed, and the image is marked with a hatch pattern to indicate that it has been selected. If you do not want to display the hatch pattern, click Tools menu ➤ Options ➤ Display. Then select Highlight Raster Image Frame Only.

- Place your cursor over the image, then press Shift + left-click. This feature is useful when you cannot see the image frame. When you do this, the image grips are displayed but the image is not marked with a hatch pattern. To use this feature, you must enable it in the Raster Design Options Dialog Box on page 353. For more information, see Mouse Settings on page 262.

When you select an image by selecting the image frame, the image rises to the top of the display order, obscuring any vectors intersecting it. However, you can use the Shift left-click method to select an image without bringing it to the top and highlighting it. This allows you to select the image and keep the vectors on top so that you can manipulate the frame with the vectors still visible. However, when the frame operation is complete, the image rises to the top of the display order. Use the AutoCAD REGEN command to restore the proper display order. For more information, see Correcting Image Display Order using REGEN on page 275.

To select an image using Shift + left-click

1. Position your pointer so it is over the image(s) you want to select.
2. Press Shift and click the left button of your mouse.
   - If you clicked on more than one image, the Image Select Dialog Box on page 337 is displayed. This dialog box displays the names of all the images that are inserted into your drawing. The image(s) that are already selected are highlighted (not just the images that you selected using the Shift + left-click method).
3. Click one of the following:
   - OK to select the image(s) that are highlighted.
   - An image to select it.
   - Select All to select all the images in your drawing.
Controlling Image Frames

An image frame encloses each image you insert.

If you select an image frame, grip(s) appear and hatch marks are drawn over the image to indicate that it is selected. You can select the frame using standard AutoCAD methods. For more informational, see Selecting an Image on page 81.

After you select an image frame, you have several choices:

■ Use an editing command from the Raster menu.
■ Right-click to display the Raster Design shortcut menu.
■ Select a grip and then right-click to display the AutoCAD shortcut menu.
■ Manipulate the image using the AutoCAD commands. For more information, see AutoCAD Commands for Images on page 287.

You can turn off the frames in your drawing or you can choose to place them behind the images.

You can change the color of an image frame using AutoCAD Properties. If the image is a bitonal image, the frame color and the bitonal objects are always drawn in the same color. For more information, see AutoCAD Properties on page 59.

An image frame is usually rectangular. However, a frame may be irregularly shaped if the image is clipped.

See also:

■ Image Frame Display on page 61

Undoing Edits to an Image

You can use the AutoCAD UNDO command to undo the changes you made to an image.

However, for each image, only your last ten edits can be undone. This limit does not include display-only changes, such as changing the scale, rotation, or position of an image. There is no limit for undoing display-only changes.
The limit of ten edits applies to operations that change the image data, such as Rubbersheet, Remove, Crop, Histogram, using a vectorization tool with the REM setting, and so on.

**NOTE** If you try to undo more than ten edits, then the eleventh undo undoes every edit you made to the image since you last saved it.

### Snapping to COGO Points

Coordinate geography points, or COGO points, can store information such as a point node, point number, northing and easting values, and elevation.

COGO points are the foundation for any civil engineering or surveying project. When you use Raster Design with a geographic application, you can substitute COGO points anytime Raster Design asks you to enter a point. This is especially useful for rubbersheeting or matching operations.

There are three ways to specify a COGO point in Raster Design:

- Enter .p when prompted to enter a point, then enter a COGO point number.
- Enter .g to select a COGO point using the mouse.
- Enter .n when prompted to enter a point, then enter northing and easting values that correspond to a COGO point.

### Cleaning Up Images

Use cleanup commands to correct errors that occur during the scanning process.

Misaligned drawings, dust on the scanning bed, and mistakes with scanning software can all be corrected using the following Cleanup commands:

- **Deskew.** Rotate an image so that it matches the rotation angle of a vector drawing or another image.
- **Despeckle.** Remove speckles or stray pixels that can appear in an image when you scan drawings or blueprints that are dirty or wrinkled.
- **Bias.** Correct distortions in an image aspect ratio on page 383. If, for instance, the image is distorted due to paper shrinkage or optical distortions in the scanning process, the Bias tool can correct the aspect ratio by resizing the image in one or two dimensions.
Invert. Reverse the light and dark shades of an image. You can invert bitonal, color, and grayscale images. Inversion reverses the dark and light areas of an image.

Mirror. Flip an image along either the horizontal or vertical axis to correct problems that occur when scanning software reverses drawings, or when the back of the drawing is scanned by mistake.

Touchup. Edit lines at the pixel level, using a square, circular, or diagonal shaped brush tool that you can resize.

NOTE Raster Design uses Single Image Optimization on page 398 to speed up the editing commands.

Deskewing an Image

You can rotate an image so that it matches the rotation angle of a vector drawing or another image.

If you want to match the scale of the image with another image or vector you can use the Scale command. If you want to move or scale the image as well as rotate the image, you can use the Match command.

For more information, see Correlating an Image After Insertion on page 30.

To deskew an image

1. Click Raster menu ➤ Cleanup ➤ Deskew.
2. Select the image you want to correct.
3. Select the base point you want to rotate the image around.
4. Define the source angle by entering a value or by picking two points on the raster image that you want to rotate.
   For example, select two points you want to match up with two other points on an image that is already rotated correctly.
5. Define the destination angle by typing a value or by picking two points to define the angle.
Quick Reference

Menu
- Raster ➤ Cleanup ➤ Deskew

Raster Design Toolbar

Object Shortcut Menu
- Right-click ➤ Image ➤ Rotate

Command Line
- ideskew

Removing Speckles from an Image

You can remove speckles or stray pixels from your bitonal image.

Speckles can appear in an image when you scan drawings or blueprints that are dirty or wrinkled, or when the scanner itself is dirty. The process consists of three main actions:

1. Specify the area to be cleaned. Draw a rectangle around the region, despeckle the entire image, or define a smaller region by means of a polygon, clip region, or an existing vector entity.

2. Specify the maximum size of pixel to delete. Click an existing speckle for this purpose, or define the size by drawing a small rectangle or entering a numeric value in drawing units or number of pixels. Raster Design then searches the image to identify speckles that are equal to or smaller than the defined speckle size, highlighting those that meet your criteria.

3. Inspect the identified speckles, then press Enter to delete them, or respecify the speckle size, or deselect any speckles you want to keep.

**NOTE** Raster Design uses Single Image Optimization on page 398 to speed up the editing commands.

To remove speckles from a bitonal image

1. Click Raster menu ➤ Cleanup ➤ Despeckle.
2 Select the image or images you want to remove speckles from, and then press Enter.

The following prompt appears:

Specify first corner point of window or [entire Image/Clip region/Polygon/Existing] <entire Image>:

3 To define the region to despeckle, do one of the following:
   ■ Press Enter to despeckle the entire image(s).
   ■ In the drawing, define a rectangular sub-region.
   ■ Enter c to use an existing image clip.
   ■ Enter p, then enter several points to define a polygonal sub-region.
   ■ Enter e, then click an existing closed vector entity to define the region.

The following prompt appears:

4 Pick a speckle to set size or [Window/size in piXels/size in Units] <Window>:

5 To define the maximum size of speckle to delete, do one of the following:
   ■ In the drawing, click a speckle.
   ■ Enter w and then draw a window that defines the maximum speckle size.
   ■ Enter x and then enter a numeric speckle size in AutoCAD units.
   ■ Enter u and then enter a numeric speckle size in pixels.

TIP When determining the best size to use, note that a size too large can remove parts of text, such as periods or dots.

The speckles to be deleted are highlighted, and the following prompt appears:

Press enter to proceed, pick a speckle to deselect or specify deselection option [Window/Polygon/Respecify size]:

6 Review the highlighted speckles to determine if you want them all deleted, then do one of the following:
   ■ Press Enter to delete the speckles.
   ■ Click any speckles that you want to keep.
Enter w and then draw a window around any group or groups of speckles that you want to keep.

Enter p and then draw a polygon around a group of speckles that you want to keep.

Enter r and then repeat step 4 to respecify the speckle size and see a different set of speckles highlighted for deletion.

Quick Reference

Menu
Raster ➤ Cleanup ➤ Despeckle

Raster Design Toolbar

Command Line
idespeckle

Adjusting the Image Bias

You can use the Bias tool to correct distortions in the aspect ratio of an image. Normally, this ratio is maintained when scaling an image in AutoCAD. However, if the image is distorted due to paper shrinkage or optical distortions in the scanning process, the Bias tool can correct the aspect ratio by resizing the image in one or two dimensions, using either existing vector geometry or a distance you specify.

When you use the Bias tool, Raster Design prompts you to enter calibration (existing) distances and desired distances in the X and Y directions. The application stretches or shrinks the entire image to correspond to the ratio of the distances you specified. The X and Y directions are relative to the image and not its position in the drawing. In each case, you can select two points (or enter a distance) to specify the calibration distance, then select two corresponding points (or enter a new distance) to specify the desired distance. You can also use existing geometry to define the desired distance; for instance, by selecting the endpoints of a line.
Raster Design maintains the current base point location for the image unless you specify a new base point. You can enter a new base point with numeric values or by clicking the point in the image.

**NOTE** The ibias command can only operate on a single image at a time.

**To adjust image bias**

1. Click Raster menu ➤ Cleanup ➤ Bias.

2. If you have not already selected an image, select the image you want to correct, and then press Enter.

   **NOTE** You can select your image or images before you select the Bias command.

3. Click a point in the drawing to use as a base point, or press Enter to use the origin as the base point.

4. Enter a calibration distance for the X direction by selecting two points to represent the distance, or enter the distance in AutoCAD units on the command line. Then enter a desired distance for the X direction using one of the two methods, or Press Enter to leave the X direction unchanged.

5. Enter a calibration distance for the Y direction by selecting two points to represent the distance, or enter the distance in AutoCAD units on the command line. Then enter a desired distance for the Y direction using one of the two methods, or press Enter to leave the Y direction unchanged.

**Quick Reference**

**Menu**

- Raster ➤ Cleanup ➤ Bias

**Raster Design Toolbar**

**Command Line**

- ibias
Reversing the Light and Dark Shades in an Image

You can use the Invert filter to reverse the light and dark shades of any image.

You can invert bitonal, color, and grayscale images.

Raster Design uses Single Image Optimization on page 398 to speed up the editing commands.

To reverse the light or dark shades in an image

1. Click Raster menu ➤ Cleanup ➤ Invert.
2. Select the image or images you want to invert, and then press Enter.

   NOTE You can select your image or images before you select the Invert command.

3. Press Enter to start the inversion process.

   If you are not satisfied with the results, then you can use the AutoCAD UNDO command to restore the image to its original settings.

   NOTE Because the Invert operation changes the colors in an image, you may need to select a different transparent color after you invert the image. For more information, see Transparent Color of an Image on page 64.

Quick Reference

Menu

Raster ➤ Cleanup ➤ Invert

Raster Design Toolbar

Command Line

iinvert

Mirroring an Image

You can mirror or flip an image along either the horizontal or vertical axis.
Scanning software might mirror drawings, or you might occasionally scan the back of the drawing by mistake. You can correct these problems by mirroring the image.

**IMPORTANT** The axes for mirror operations are always relative to the image. If the image has been rotated or repositioned in the drawing, the mirror axes are also moved, so they may not appear horizontal or vertical in the display.

Raster Design uses [Single Image Optimization](page 398) to speed up the editing commands.

**To mirror an image along the horizontal or vertical axis**

1. Click Raster menu ➤ Cleanup ➤ Mirror.
2. Select the image or images that you want to mirror, then press Enter.
3. Do one of the following:
   - To mirror the image along the horizontal axis, select Top To Bottom.
   - To mirror the image along the vertical axis, select Side To Side.
4. Click OK to mirror the image.
5. If you are not satisfied with the results, you can use the AutoCAD UNDO command to restore the image to its original settings.

**Quick Reference**

Menu
- Raster ➤ Cleanup ➤ Mirror

Raster Design Toolbar

Command Line
- imirror

**Touching Up an Image**

Edit bitonal images at the pixel level using resizable brushes and automated line-drawing functions.
Touchup tools are provided on the Touchup toolbar.

The touchup brush can be square, round, or diagonal rectangular in shape. You can resize it to match the line weight in your drawing. The brush size remains constant in relation to the pixels, so it varies with your zoom level.

Using a toggle control, you can switch from foreground to background color, in effect switching from drawing pixels to erasing them.

The Shift key provides two automated line-drawing controls. You can restrict the line direction to horizontal, vertical, or 45-degree angle. You can also create lines or polylines.

Raster Design uses Single Image Optimization on page 398 to speed up the editing commands.

To touch up an image

1. Zoom in to your image so the pixels you want to touch up are clearly visible.

2. Click Raster menu ➤ Cleanup ➤ Touchup.
   The Touchup toolbar is displayed.

3. Click the touchup tool shape you want to use:
   - Square
   - Round
   - Diagonal

4. Optionally, use the controls on the Touchup toolbar to modify your brush, adjust the display, and undo or redo lines during your editing session.

   **Tip** If Dynamic Input is active, you may see a tooltip area that moves with your cursor. Click DYN at the bottom of the main window to turn this feature off or on.

5. If you are satisfied with the touchup, click ✔️ to end the session and save the results; otherwise, click ❌ to erase the touchup and start again.
To draw a fixed angle line

1. Click and drag the cursor slowly in the desired direction.
2. Hold down the Shift key.
   The line continues horizontal, vertical, or at a 45-degree angle, whichever is closest to the direction of cursor movement. If the direction is not what you intended, click (Undo) and start again.

To draw a line or polyline

1. Draw a short first segment freehand, then release the mouse button. This establishes a known endpoint from which to start the series.
2. Hold down the Shift key, move the cursor to the next desired vertex, then click.
   A straight line is drawn between the two points.
3. If you want to add more lines to the series, repeat step 2 for each one.

Quick Reference

Menu
   Raster ➤ Cleanup ➤ Touchup
Raster Design Toolbar
   ![Raster Design Toolbar]
Command Line
   itouchup

Image Processing

Use Image Processing tools to adjust the appearance of an image.
These tools filter the image, resulting in permanent changes to the image pixels.

- Histogram. Adjust the tone of an image in many ways, including conversion of color images to grayscale and color or grayscale images to bitonal.
■ Convolve. Use smoothing filters on page 400 and sharpening filters on page 398 to improve the appearance of your image. Smoothing filters reduce harshness and noise in your image. Sharpening filters make differences in shading more distinct.

■ Bitonal Filters. Smooth the appearance of raster lines or separate partially merged raster lines.

■ Change Density. Increase or decrease the resolution of an image.

■ Change Color Depth. Increase or decrease the color depth of an image. For instance, you can change an 8-bit grayscale image to a bitonal image.

■ Palette Manager. Change colors or shades of gray in an 8-bit image, import and export palettes.

NOTE Raster Design uses Single Image Optimization on page 398 to speed up the editing commands.

Adjusting Images with the Histogram

You can use the Histogram to adjust the brightness and contrast of an image, to maximize detail, to convert color or grayscale images to bitonal, and to convert color images to grayscale.

The Histogram changes the image data definition, so all future insertions of the image include these changes. If you want to just change brightness and contrast of a particular insertion, you can change the color map. For more information, see Changing the Color Map of an Image on page 70.

You can adjust a whole image or a sub-region. You can define a sub-region using one of four methods:

■ Use an existing closed vector entity to define the sub-region.

■ Use an existing image clip.

■ Define a rectangular sub-region by clicking two-points.

■ Define a polygonal sub-region by clicking several points.

Adjusting the Brightness and Contrast of an Image

You can permanently change the tone and visibility of images.
Increasing the **brightness** on page 385 lightens the image and can bring out image detail in the shadow areas, although increasing brightness too much can wash out the light areas. Decreasing the brightness darkens the image and can bring out details in the light areas. Likewise, decreasing brightness too much can cause the dark areas can become almost black.

Increasing the contrast makes the differences between dark and light areas more distinct. You can increase contrast in a grayscale image to the point where the image becomes black and white. Decreasing the contrast makes an image that consists mostly of mid-level grays.

In color images, you can adjust the brightness and contrast for individual color channels (red, green, blue, or RGB, which is a combination of the colors). For example, if you choose red and then increase the brightness, you see more reds. In grayscale images, you can adjust only the single channel that represents gray.

You can limit the effect of brightness or contrast changes to a portion of the image called a sub-region. If the image palette is **Index Color (8-bit)** on page 393 you can alter the palette of the image to include the new colors.

**NOTE** Raster Design uses **Single Image Optimization** on page 398 to speed up the editing commands.

**To adjust brightness or contrast for a selected image**

1. Click Raster menu ➤ Image Processing ➤ Histogram.
   
   The following prompt appears:
   
   Press Enter for entire image or specify sub-region option [Existing/Clip region/Window/Polygon]:

2. Do one of the following:
   
   ■ Press Enter to use the histogram on the entire image.
   
   ■ Enter e, then click a closed vector entity to use an existing entity to define the region.
   
   ■ Enter c to use an existing image clip.
   
   ■ Enter w, then enter two points to define a rectangular sub-region.
   
   ■ Enter p, then enter several points to define a polygonal sub-region.

   The **Histogram** on page 318 dialog box is displayed.

3. Click the Brightness/Contrast tab.
A preview of the image is displayed. If you selected more than one image, the histogram displays a composite of the images’ values. You can view each image by clicking its name in the list.

**NOTE** The preview reflects the image as it was read from the disk. If you have made any display-only adjustments to the image using the Image Adjust color map or the AutoCAD IMAGEADJUST command, then those adjustments are not displayed in the image preview. If you make adjustments to the image using the Histogram, the adjustments made with IMAGEADJUST are no longer applied to the image; instead the new settings are applied.

4 If you selected a color image, then choose a color channel from the RGB box.

5 Do one of the following to manipulate the image:
   - To make the image lighter, drag the Brightness slider to the right.
   - To make the image darker, drag the Brightness slider to the left.
   - To increase the distinction between the light and dark, drag the Contrast slider to the right.
   - To decrease the distinction between the light and dark, drag the Contrast slider to the left.

6 To adjust the scale in the histogram window, move the slider up and down. Moving the slider up increases the scale such that low frequency values become more visible and the highest frequency values become truncated by the top of the window.

7 Click Apply to change the color values in the image file and generate a new histogram that reflects the changes.

**NOTE** After you click Apply and generate the new histogram, the Brightness and Contrast sliders are reset to 0.

8 If you specified a sub-region in step 2, select an option from the Apply Changes To section:
   - Sub-Region applies the changes to the sub-region only.
   - Entire Image applies the changes to the selected image.
If you selected sub-region in step 6, and if the sub-region is associated with an 8-bit color image, select a palette option from the drop-down list:

- **Retain Current Palette** applies your changes to the sub-region by mapping to the closest colors from the current palette. This option maintains the current palette and will not affect pixels outside the selected region.

- **Rebuild Palette With All Colors** creates a new palette to best accommodate all colors in the entire image. Because this image changes the palette, pixels inside and outside the sub-region may be affected by this option.

- **Rebuild Palette With New Colors** also creates a new palette, but this option guarantees that colors in the sub-region are included in the palette by giving preference to those pixels over pixels outside the sub-region. Because this image changes the palette, pixels outside the sub-region may be affected by this option.

Click Close to exit the Histogram dialog box.

If you are not satisfied with the results, you can use the AutoCAD UNDO command to restore the image to the original settings.

**NOTE** You can reset the brightness and contrast to zero for all color channels by clicking Reset Controls. This does not undo any edits you have already applied to the image.

**Quick Reference**

Menu

- Raster ➤ Image Processing ➤ Histogram

Raster Design Toolbar

- 

Command Line

- ihistogram

Dialog Box

- Histogram Dialog Box on page 318

Adjusting Images with the Histogram | 97
Maximizing Details in an Image

If an image has many pixels that are approximately the same color or shade, you can equalize the image to bring out more detail.

Equalization makes the darkest pixels darker and the lightest pixels lighter, then reassigns the remaining pixels to the colors in between. This is also known as a non-linear contrast stretch.

You can limit the effect of brightness or contrast changes to a portion of the image called a sub-region. If the image palette is Index Color (8-bit) on page 393, you can alter the palette of the image to include the new colors.

NOTE  Raster Design uses Single Image Optimization on page 398 to speed up the editing commands.

To maximize details on a selected image

1. Click Raster menu ➤ Image Processing ➤ Histogram. The following prompt appears:
   Press Enter for entire image or specify sub-region option [Existing/Clip region/Window/Polygon]:

2. Do one of the following:
   ■ Press Enter to use the histogram on the entire image.
   ■ Enter e, then click a closed vector entity to use an existing entity to define the region.
   ■ Enter c to use an existing image clip.
   ■ Enter w, then enter two points to define a rectangular sub-region.
   ■ Enter p, then enter several points to define a polygonal sub-region.

   The Histogram on page 318 dialog box is displayed.

3. Click the Equalize tab. A preview of the image is displayed. If you selected more than one image, the histogram displays a composite of the images' values. You can view each image by clicking its name in the list.
NOTE The preview reflects the image as it was read from the disk. If you have made any display-only adjustments to the image using the AutoCAD IMAGEADJUST command, then those adjustments are not displayed in the image preview. If you make adjustments to the image using the Histogram, the adjustments made with IMAGEADJUST are no longer applied to the image; instead the new settings are applied.

4 If you selected a color image, then select a color channel to equalize. You can equalize the combined RGB channels, or you can select a single channel (Red, Green, or Blue).

5 To adjust the scale in the histogram window, move the slider up and down. Moving the slider up increases the scale such that low frequency values become more visible and the highest frequency values become truncated by the top of the window.

6 Click Apply to equalize the image(s).

7 If you specified a sub-region in step 2, select an option from the Apply Changes To section:
   ■ Sub-Region applies the changes to the sub-region only.
   ■ Entire Image applies the changes to the selected image.

8 If the sub-region is associated with an 8-bit color image, select a palette option from the Sub-Region Options drop-down list:
   ■ Retain Current Palette applies your changes to the sub-region by mapping to the closest colors from the current palette. This option maintains the current palette and will not affect pixels outside the selected region.
   ■ Rebuild Palette With All Colors creates a new palette to best accommodate all colors in the entire image. Because this image changes the palette, pixels inside and outside the sub-region may be affected by this option.
   ■ Rebuild Palette With New Colors also creates a new palette, but this option guarantees that colors in the sub-region are included in the palette by giving preference to those pixels over pixels outside the sub-region. Because this image changes the palette, pixels outside the sub-region may be affected by this option.

9 Click Close to exit the Histogram dialog box.
If you are not satisfied with the results, then you can use the AutoCAD UNDO command to restore the image to the original settings.

Quick Reference

Menu
Raster ➤ Image Processing ➤ Histogram

Raster Design Toolbar

Command Line
ihistogram

Dialog Box
Histogram Dialog Box on page 318

Converting a Color Image to Grayscale

You can convert a color image to a grayscale image using the Histogram on page 318 dialog box.

Converting a color image to an 8-bit grayscale image can reduce the image file size. You can also use the smoothing filters on page 400 or the sharpening filters on page 398 to enhance the details of an image. These editing filters work only on grayscale images.

Raster Design uses Single Image Optimization on page 398 to speed up the editing commands.

To convert a selected color image to a grayscale image

1. Click Raster menu ➤ Image Processing ➤ Histogram.
   The Histogram on page 318 dialog box is displayed.

2. Select the Color to Grayscale tab.
   A preview of the image is displayed. If you selected more than one image, the histogram displays a composite of the images' values. You can view each image by clicking its name in the list.
NOTE The preview reflects the image as it was read from the disk. If you have made any display-only adjustments to the image using the AutoCAD IMAGEADJUST command, then those adjustments are not displayed in the image preview. If you make adjustments to the image using the Histogram, the adjustments made with IMAGEADJUST are no longer applied to the image; instead the new settings are applied.

3 Select a channel from which to apply the conversion values. You can select RGB, or you can select a single channel (Red, Green, or Blue). If you select RGB, then the values for red, green, and blue pixels in the image are added together and divided by three to achieve the grayscale value. If you select one channel, then the Color to Grayscale operation takes the value for that channel and uses it for the grayscale value.

4 To adjust the scale in the histogram window, move the slider up and down. Moving the slider up increases the scale such that low frequency values become more visible and the highest frequency values become truncated by the top of the window.

5 Select Apply to convert the color image(s) to grayscale.

6 Select Close to exit the Histogram dialog box.

If you are not satisfied with the results, you can use the AutoCAD UNDO command to restore the original settings.

Quick Reference

Menu

Raster ➤ Image Processing ➤ Histogram

Raster Design Toolbar

Command Line

ihistogram

Dialog Box

Histogram Dialog Box on page 318
Converting a Grayscale or Color Image to Bitonal

You can convert a grayscale image on page 392 or color image to a bitonal image on page 384.

Converting an image to bitonal can help isolate features in an image, such as the contour lines in a USGS map. After the image is converted to a bitonal image, you can use the vectorization tools to convert the raster objects to vectors.

You use a threshold value to determine which pixels become black and which pixels become white. Raster Design uses Single Image Optimization on page 398 to speed up the editing commands.

NOTE When you use the Threshold option on an image, the foreground color of the image is BYLAYER.

To convert a grayscale or color image to a bitonal image

1. Click Raster menu ➤ Image Processing ➤ Histogram. The Histogram on page 318 dialog box is displayed.

2. Click the Threshold tab. A preview of the image is displayed. If you selected more than one image, the histogram displays a composite of the images' values. You can view each image by clicking its name in the list.

NOTE The preview reflects the image as it was read from the disk. If you have made any display-only adjustments to the image using the AutoCAD IMAGEADJUST command, then those adjustments are not displayed in the image preview. If you make adjustments to the image using the Histogram, the adjustments made with IMAGEADJUST are no longer applied to the image; instead the new settings are applied.

3. Drag the Threshold slider to determine which pixels are black and which pixels are white. All of the pixels to the left of the slider are black and all pixels to the right of the slider are white.

4. To adjust the scale in the histogram window, move the slider up and down. Moving the slider up increases the scale such that low frequency values are more visible and the highest frequency values are truncated by the top of the window.

5. Click Apply to convert the image(s) to bitonal image(s).
Click Close to exit the Histogram dialog box.

If you are not satisfied with the results, you can use the AutoCAD UNDO command to restore the image to the original settings.

NOTE When you use the Threshold command on a color image, Raster Design first converts the image to grayscale, and then uses the grayscale value to create the bitonal image. This grayscale value is obtained by adding the values of the red, green, and blue channels in an image and dividing the value by three. If you want to have more control over which grayscale value Raster Design uses to create the grayscale, then you can convert the color image to grayscale first, and then use the Threshold command on the grayscale image. For more information, see Converting a Color Image to Grayscale on page 100.

Quick Reference

Menu

Raster ➤ Image Processing ➤ Histogram

Raster Design Toolbar

Command Line

ihistogram

Dialog Box

Histogram Dialog Box on page 318

Making Tonal Adjustments to an Image

You can adjust the contrast selectively along the spectrum of dark and light shades.

Many digital images, particularly those produced on a scanner, display less detail in darker or shadowed regions of the image. Adjusting brightness and contrast for the entire image can improve the level of detail in the darker regions, but usually does so at the expense of the midtones and lighter colors. Controls on the Tonal Adjustment tab of the Histogram dialog box can adjust the contrast more selectively. You can, for example, increase the contrast in the darker tones, while maintaining the current level of contrast among midtones and lighter colors.
Three types of contrast curve are available:

- A Gamma correction curve is exponential. You can either specify the single exponent (gamma) value or use an interactive slider to determine the gamma value.
- A Fitted curve is drawn smoothly through points you specify. You can add or remove points from the curve, and drag them to modify the shape of the curve.
- A Piecewise Linear curve is constructed of straight-line segments between points you specify.

You can use a grid as a visual reference for constructing the curve. You can turn the grid on and off by right-clicking in the curve window and selecting Grid on the shortcut menu.

Two sliders under the curve control the lower and upper cut-off points for the curves. Input values below the lower cutoff point are displayed as 0, while input values above the upper cutoff point are displayed as 255. Curves can be saved and imported as Gamma Point List (*.gpl) files.

Like the other histogram functions, when you are operating on a true color image, you can choose to manipulate a single color channel, or all three channels together.

**NOTE** The Tonal Adjustment feature does not apply to bitonal images.

Above the curve window, the histogram window displays input and output histograms. The input histogram is a graph, shown in gray, representing the number of pixels in the original image containing each of the given colors. Similarly, the output histogram previews the number of pixels present for each of the given colors in the image after the curve is applied

By default, the histogram window adjusts the vertical scale of the histograms such that the entry with the highest frequency extends to the top of the histogram window. You can use the vertical scale slider to effectively zoom in on the histogram. As you move the slider upward, the scale is increased so that low frequency values are more visible and high frequency values are truncated by the top of the window.

**To adjust the image contrast curve**

1. Click Raster menu ➤ Image Processing ➤ Histogram.
   The following prompt appears:
Press Enter for entire image or specify sub-region option [Existing/Clip region/Window/Polygon]:

2 Do one of the following:
   ■ Press Enter to use the histogram on the entire image.
   ■ Enter e, then click a closed vector entity to use an existing entity to define the region.
   ■ Enter c to use an existing image clip.
   ■ Enter w, then enter two points to define a rectangular sub-region.
   ■ Enter p, then enter several points to define a polygonal sub-region.

The Histogram on page 318 dialog box is displayed.

3 Click the Tonal Adjustment tab.
A preview of the image is displayed. If you selected more than one image, the histogram displays a composite of the images' values. You can view each image by clicking its name in the list.

NOTE The preview reflects the image as it was read from the disk. If you have made any display-only adjustments to the image using the AutoCAD IMAGEADJUST command, then those adjustments are not displayed in the image preview. If you make adjustments to the image using the Histogram, the adjustments made with IMAGEADJUST are no longer applied to the image; instead the new settings are applied.

4 If you selected a color image, then select a color channel to manipulate. You can manipulate the contrast curve for the combined RGB channels, or you can select a single channel (red, green, or blue).

5 Select a curve type from the Select Curve Type list:
   ■ Choose Gamma correction to create an exponential curve by defining either the single exponent (gamma) value or using an interactive slider which determines the gamma value.
   ■ Choose Fitted to draw a curve smoothly through points you specify by clicking and dragging on curve segments or on existing points.
   ■ Choose Piecewise Linear to draw straight segments between points you specify. You can create or modify points by clicking and dragging on curve segments or on existing points.
6. To delete a point on a Piecewise Linear or Fitted curve, select the point, and press Delete, or right-click and click Delete Point.

7. To import a curve, click the Import button, or right-click in the contrast curve window and click Import. In the Import on page 338 dialog box, simply navigate to the Gamma Point List (*.gpl) file and click Open.

8. To export a curve, click the Export button, or right-click in the contrast curve window and click Export. In the Export on page 313 dialog box, navigate to the folder where you want to save the Gamma Point List (*.gpl) file and click Save.

9. To adjust the scale in the histogram window, move the slider up and down. Moving the slider up increases the scale such that low frequency values are more visible and the highest frequency values are truncated by the top of the window.

10. To restore the default settings for the curve, click the Reset button, or right-click in the contrast curve window and click Reset.

11. Click Apply.

12. If you specified a sub-region in step 2, select an option from the Apply Changes To section:
   - Sub-Region applies the changes to the sub-region only.
   - Entire Image applies the changes to the selected image.

13. If the sub-region is associated with an 8-bit color image, select a palette option from the Sub-Region Options list:
   - Retain Current Palette applies your changes to the sub-region by mapping to the closest colors from the current palette. This option maintains the current palette and will not affect pixels outside the selected region.
   - Rebuild Palette With All Colors creates a new palette to best accommodate all colors in the entire image. Because this image changes the palette, pixels inside and outside the sub-region may be affected by this option.
   - Rebuild Palette With New Colors also creates a new palette, but this option guarantees that colors in the sub-region are included in the palette by giving preference to the pixels inside the sub-region over pixels outside the sub-region. Because this image changes the palette, pixels outside the sub-region may be affected by this option.
Click Close to exit the Histogram dialog box.
If you are not satisfied with the results, then you can use the AutoCAD UNDO command to restore the image to the original settings.

Quick Reference

Menu
Raster ➤ Image Processing ➤ Histogram
Raster Design Toolbar
Command Line
ihistogram
Dialog Box
Histogram Dialog Box on page 318

Convolving an Image

Convolve uses smoothing filters on page 400 and sharpening filters on page 398 to improve the appearance of grayscale images.

Smoothing filters reduce harshness and noise in your image. Sharpening filters make differences in shading more distinct.

Reducing Harshness and Noise in an Image

You can use the smoothing filters on page 400 to reduce the harshness and visual noise on page 395 in a grayscale image.

If an image contains small details that are noise rather than useful data, you can use the smoothing filters to remove these details. For example, a smoothing filter can improve the appearance of scans of half-toned originals.

There are two types of smoothing filters, Low Pass and Median. For more information, see Lowpass Filtering on page 110 and Median Filter on page 108.

Raster Design uses Single Image Optimization on page 398 to speed up the editing commands.
**To reduce harshness and visual noise in a selected image**

1. Click Raster menu ➤ Image Processing ➤ Convolve.
2. Select the image or images you want to filter, then press Enter.
3. Click Expand All to expand the filter list.
4. Choose the smoothing filter you want to use. A description of the selected filter is displayed in the Image Filters on page 326 dialog box.
5. Click Run Filter to filter the image(s)
   If you are not satisfied with the results, then you can use the AutoCAD UNDO command to restore the image to its original settings.

**Quick Reference**

**Menu**
- Raster ➤ Image Processing ➤ Convolve, Smoothing Filters

**Raster Design Toolbar**

**Command Line**
- `iconvolve`

**Dialog Box**
- Image Filters Dialog Box on page 326

**Median Filter**

You can use this filter to remove random visual noise on page 395 in the image. The median filter changes each pixel value to match the average value of the neighboring pixels.

**To use the median filter on a selected image**

1. Click Raster menu ➤ Image Processing ➤ Convolve.
2. Click Smoothing Filters.
3. Click Expand All to expand the filter list.
4 Click Median Filter.

5 Click Run Filter to filter the image(s).

6 Enter a filter (or matrix) size. This filter uses a matrix for smoothing the pixels. For example, a filter size of 3 would filter each pixel by averaging the values of the 8 surrounding pixels.

**NOTE** The filter size must be an odd number.

7 Click OK to apply the filter.

---

**Quick Reference**

Menu

Raster ➤ Image Processing ➤ Convolve, Smoothing Filters

Raster Design Toolbar

Command Line

iconvolve

Dialog Box

Image Filters Dialog Box on page 326

---

**Making Differences in Shading More Distinct**

You can use the sharpening filters on grayscale images to make differences in shading more distinct.

Sharpening filters can enhance edges in the image. It may be necessary to use these filters to extract the highest amount of useful data from a low resolution scan.

For more information on the two types of sharpening filters on page 398, see Highpass Filters on page 111 and Edge Enhancements Filters on page 112.

Raster Design uses Single Image Optimization on page 398 to speed up the editing commands.
To make differences in shading more distinct for a selected image

1 Click Raster menu ➤ Image Processing ➤ Convolve.
2 Select the image or images you want to filter, then press Enter.
3 Click Expand All to expand the filter list.
4 Select the sharpening filter you want to use. A description of the selected filter is displayed in the Image Filters on page 326 dialog box.
5 Click Run Filter to filter the image(s).

See also:
- Reducing Harshness and Noise in an Image on page 107

Quick Reference

Menu
- Raster ➤ Image Processing ➤ Convolve, Smoothing Filters

Raster Design Toolbar

Command Line
- iconvolve

Dialog Box
- Image Filters Dialog Box on page 326

Lowpass Filtering

Lowpass filtering can lessen the severity of tone change by reducing high-frequency detail in an image in areas where pixel intensities change rapidly.

The result is a slightly blurred image.
Raster Design uses the following lowpass filters:

- Lowpass Filter #1 averages differences between the target pixel value and its side to side and top and bottom neighbors. Diagonally adjacent pixels are ignored.
- Lowpass Filter #2 evenly weights all pixels in the kernel including the target.
- Lowpass Filter #3 evenly weights all pixels surrounding the target while providing extra weight to the target pixel. This tends to reduce the blurring effect to the image.
- Lowpass Filter #4 heavily weighs the target pixel while weighing adjacent side to side and top and bottom pixels more heavily than diagonally connected pixels. Heavy weighting on the target pixel tends to reduce blurring effects and less weighting on the diagonal pixels acknowledges that their centers are further away than side adjacent pixels.
- Blurring evenly weights all pixels in the kernel including the target. This filter, while similar to Lowpass Filter #2, gives slightly brighter results.

On a low resolution scan, you can also use the sharpening filters on page 398 to make differences in shading more distinct and enhance edges in the image. For more information on sharpening filters, see Highpass Filters on page 111 and Edge Enhancements Filters on page 112.

Raster Design uses Single Image Optimization on page 398 to speed up the editing commands.

**Highpass Filters**

Highpass filters can enhance the edges and sharpen details in a grayscale image.

Raster Design uses the following highpass filters:

- Highpass Filter #1 picks up differences between the target pixel and its neighbor's side to side and top and bottom. Diagonally connected pixels are ignored.
- Highpass Filter #2 evenly weights all the surrounding pixels in the kernel but places an especially high weight on the target pixel. Thus, if the target pixel differs significantly from its neighbors, the dimming effect of the neighboring pixels negligible.
Highpass Filter #3 weighs side to side and top and bottom neighbors more heavily than diagonal neighbors.

**Edge Enhancements Filters**

You can use these filters to enhance edges so you can easily identify boundaries and property lines. You can also use them for object extraction or object recognition by higher-level algorithms.

Raster Design supports the following edge enhancements filters:

- **Shift and Difference Edge Enhancements Filters** on page 112
- **Laplace Edge Enhancements Filters** on page 112
- **Gradient Directional Edge Enhancements Filters** on page 113
- **Matched Filter Edge Enhancements Filters** on page 113

**Shift and Difference Edge Enhancements Filters**

You can use these filters to shift the image by one pixel and subtract the shifted image from the original.

Raster Design uses the following shift and difference edge enhancements filters:

- Vertical enhances vertical edges composed of black-to-white transitions.
- Horizontal enhances horizontal edges composed of black-to-white transitions.
- Vertical and Horizontal combines operation of both vertical and horizontal edge enhancements.

**Laplace Edge Enhancements Filters**

You can use these filters to enhance the image in all directions. These filters enhance all edges that are composed of black-to-white transitions by making them white.
Raster Design uses the following Laplace edge enhancements filters:

- #1 uses the target pixel and its horizontal and vertical neighbors. Diagonally adjacent pixels are ignored.
- #2 uses a uniform kernel with a high weighting on the target pixel.
- #3 uses a uniform kernel with the highest weighting on the target pixel.
- #4 weighs adjacent horizontal and vertical pixels more heavily than diagonally adjacent pixels.

**Gradient Directional Edge Enhancements Filters**

You can use these filters in any one of the eight compass directions. Using these directional filters results in a black background with white outlines of the objects in the original image.

Each filter enhances the edges composed of black-to-white transitions in a specific direction, making these edges white. Raster Design uses the following gradient directional edge enhancements filters:

- North
- Northeast
- East
- Southeast
- South
- Southwest
- West
- Northwest

**Matched Filter Edge Enhancements Filters**

You can use these filters to search for features in images that are obscured by noise on page 395. These filters use a directional 3x5 or 5x3 pixel kernel.

Raster Design uses the following matched filter edge enhancements filters:

Horizontal searches for horizontal lines in a noisy image.
Vertical searches for vertical lines in a noisy image.

**Using Bitonal Filters**

You can use these filters to clean up bitonal images. Bitonal filters can be used in conjunction with other clean up commands, such as despeckle and deskew. For more information, see Removing Speckles from an Image on page 86 and Deskewing an Image on page 85.

You can use bitonal filters on an entire image, or on a portion of an image called a sub-region. You can define a sub-region using one of four methods:

- Use an existing closed vector entity to define the region.
- Use an existing image clip.
- Define a rectangular sub-region by clicking two-points.
- Define a polygonal sub-region by clicking several points.

The smooth filter removes unnecessary pixels from the edges of raster objects, fills holes in raster lines, and removes speckles from the raster image.

*Click here to see sample raster objects before and after using a smooth filter.*

![Sample raster objects before and after using a smooth filter](image)

**NOTE** The smooth filter can eliminate small details in the image.
The thin filter trims raster objects by one pixel (per pass) in all directions. Thinning reduces the number of pixels while maintaining the basic shape of the feature.

Click here to see sample raster objects before and after using a thin filter.

The thickening filter thickens the edges of raster objects by one pixel (per pass) in the directions you specify.

Click here to see sample raster objects before and after using a thickening filter.

A separate filter separates partially merged lines to prevent Raster Design from converting them to one thick line.

Click here to see sample raster objects before and after using a separate filter.

A skeletonize filter thins all raster data to a one pixel thickness. You can use a skeletonize filter to thin your entire raster image down, then run the thicken filter to make all of your Raster data one consistent width.

To use bitonal filters for a selected image

1 Click Raster menu ➤ Image Processing ➤ Bitonal Filters.

The following prompt appears:
Press Enter for entire image or specify sub-region option [Existing/Clip region/Window/Polygon]:

2 Do one of the following:
   ■ Press Enter to use the filter on the entire image.
   ■ Enter e, then click a closed vector entity to use an existing entity to define the region.
   ■ Enter c to use an existing image clip.
   ■ Enter w, then enter two points to define a rectangular sub-region.
   ■ Enter p, then enter several points to define a polygonal sub-region.

The Bitonal Filters on page 304 dialog box is displayed.

3 Choose the Filter Type you would like to run on your image.

4 Choose the Number of Passes.
   For example, a pass value of 3 means running the operation 3 times.

5 Choose the Direction(s) in which you would like the filter to run.

6 Click OK to apply the filter.

See also:
   ■ Bitonal Filters Dialog Box on page 304

Quick Reference

Menu
   Raster ➤ Image Processing ➤ Bitonal Filters

Raster Design Toolbar

Command Line
   ibfilter

Dialog Box
   Bitonal Filters Dialog Box on page 304
Changing Image Density

For editable image types, you can change the pixel density value, density units, or both.

Common reasons for changing density are as follows:

- Decrease the image density to reduce the file size of the image or of the drawing.
- Increase the image density to make more pixels available in your image. For instance, circles and other curves look smoother at higher densities.

You can adjust the density of multiple images simultaneously if all selected images have the same density and units.

The Change Density Dialog Box on page 305 displays the current pixel density (using the current image units) and prompts you to enter a new density. After you enter the new density value, you see what the image dimensions will be if you apply the change.

You can select one of five resampling methods: bicubic on page 384, bilinear on page 384, Lanczos on page 393, Mitchell on page 394, or nearest neighbor on page 395.

NOTE Changing the density of an 8-bit image using bilinear or bicubic resampling may replace some existing colors in your palette. If you would like the image to retain all of its colors you should increase the pixel depth before using bilinear or bicubic resampling. For more information, see Setting the Color Depth for an Image on page 118.

Adjusting the density of an image can change the image file size, but it does not change the image correlation, scale, or (in most cases) the image size in AutoCAD units.

To change the density of a selected image

1. Click Raster menu ➤ Image Processing ➤ Change Density.
2. Select the image or images you want to change, and then press Enter.

   NOTE You can also select your image or images before you select the Change Density command.

3. In the Change Density dialog box, enter a new density value or pixel size. Optionally note the resulting change to image dimensions.
Select an image resampling method.

Click OK to change image density.

**Quick Reference**

**Menu**

Raster ➤ Image Processing ➤ Change Density

**Raster Design Toolbar**

**Command Line**

idensity

**Dialog Box**

[Change Density Dialog Box on page 305]

**Setting the Color Depth for an Image**

You can alter the color depth of an image.

Each pixel in a raster image stores color information. The amount of information within each pixel is called depth and is measured in bits. Pixels with more depth can store more information and therefore display more colors. For instance, an 8-bit pixel can display one of 256 indexed colors (or, in the case of grayscale images, shades of gray), while a 24-bit pixel can display one of 16.7 million colors.

The following table shows the color depths supported by Raster Design and the number of colors each depth can display.

<table>
<thead>
<tr>
<th>Type of Image</th>
<th>Color Depth</th>
<th>Available Color(s)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Bitonal</td>
<td>1-Bit</td>
<td>1 color</td>
</tr>
<tr>
<td>Grayscale</td>
<td>8-Bit</td>
<td>256 shades of gray</td>
</tr>
<tr>
<td>Indexed Color</td>
<td>8-Bit</td>
<td>256 colors</td>
</tr>
<tr>
<td>True Color</td>
<td>24-Bit</td>
<td>16.7 million colors</td>
</tr>
</tbody>
</table>
Changing the pixel depth is useful because it allows you to manipulate file size or add colors to the palette. Decreasing pixel depth decreases the number of colors that can be displayed, and decreases the file size of the image. Likewise, increasing pixel depth increases the number of colors that can be displayed and increases the file size.

The following table shows the depth conversions supported by the `idepth` command:

<table>
<thead>
<tr>
<th>Type of Image</th>
<th>Bitonal</th>
<th>Color</th>
<th>Grayscale</th>
<th>True Color</th>
</tr>
</thead>
<tbody>
<tr>
<td>Bitonal</td>
<td>N/A</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Indexed Color</td>
<td>Yes</td>
<td>N/A</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Grayscale</td>
<td>Yes</td>
<td>N/A</td>
<td>N/A</td>
<td>Yes</td>
</tr>
<tr>
<td>True Color</td>
<td>Yes</td>
<td>N/A</td>
<td>True Color</td>
<td>Yes</td>
</tr>
</tbody>
</table>

In most cases, when you convert an image for which you have already specified a transparent color, the transparent color is maintained. However, there are two exceptions:

- When converting to a bitonal image, transparent pixels are OFF if background transparency is enabled. If background transparency is disabled, transparent pixels are treated the same as other pixels.
- When converting to grayscale, a transparent color is mapped to its corresponding gray value, whether background transparency is ON or OFF.

To change the color depth of an image

1. Click Raster menu ➤ Image Processing ➤ Change Color Depth.
2. Select the image or images you want to change, and then press Enter.
   
   **NOTE** You can also select your image or images before you select the Change Color Depth command.

3. Choose a color depth and press Enter.
   
   **NOTE** You can adjust the pixel depth of multiple images if all selected images have the same pixel depth.
Quick Reference

Menu
- Raster ➤ Image Processing ➤ Change Color Depth

Raster Design Toolbar

Command Line
- idepth

Dialog Box
- Bitonal Filters Dialog Box on page 304

Using the Palette Manager

Raster Design allows you to manipulate individual colors and entire palettes for 8-bit images.

The Palette Manager can determine which colors are actually being used, change an existing color to a different color, combine several color indices into a single mapped color, compress the palette, and even import and export palettes.

Manipulating the Color Table

The Palette Manager on page 350 dialog box displays color tables representing the values in the image palette.

These color tables are displayed both as an array of color buttons, and a list window. You can select individual colors in the color table to get information on their color values, frequency, and index values. By selecting one or more colors from the color table, you can also change their color values, combine colors, assign background transparency, and delete colors from the palette.

Changing Selected Colors in the Image Palette

In a paletted image, when you select a color from the color table or the list view, the Change button becomes active.
Clicking the Change button gives you the option to change the selected color. In the Target Color dialog box, you can select a color from the current palette, or from a standard palette, such as the AutoCAD palette or a spectrum palette. You can also select a custom color.

As with most changes in the Palette Manager dialog box, the changes you make to the palette are not permanent until you click the Apply button.

To replace a color from the color table

1. Click Raster menu ➤ Image Processing ➤ Palette Manager. The Palette Manager dialog box is displayed.
2. Select one or more colors from the color table or list view, or use the Select Color button to pick a color directly from the image. For more information, see Selecting a Color Directly from the Image on page 124.
3. Click the Change button, or right-click and click Change on the shortcut menu. The Target Color dialog box appears.
4. Do one of the following:
   - Replace the selected color with a color from the current palette by selecting a replacement color from the color table in the Target Color dialog box.
   - Replace the selected color with a color from another palette by selecting a new palette from the Palette list. The color table changes to reflect the new palette. You can also select a replacement color from the color table in the Target Color dialog box.
   - Replace the selected color with a custom color by clicking the Custom Color button. The Select Custom Color dialog box appears. You can also define a custom color by clicking a color from the matrix, using the luminosity slider, or entering values in the Red, Green, Blue, Hue, Saturation, or Luminosity text boxes.
5. Click OK to close the Target Color dialog box.
6. In the Palette Manager dialog box, click Apply.
7. Click OK to close the Palette Manager dialog box.
Quick Reference

Menu
Raster ➤ Image Processing ➤ Palette Manager

Raster Design Toolbar

Command Line
ipal

Dialog Box
Palette Manager Dialog Box on page 350

Combining Selected Colors in the Image Palette

When you select two or more color values from the color table, you can use the Combine button to consolidate the selected values into a single value you choose from the Target Color on page 372 dialog box.

Combining values is a good way to control the number of colors used in the palette.

As with most changes in the Palette Manager on page 350 dialog box, the changes you make to the palette are not permanent until you click the Apply button.

To combine two or more values from the color table

1 Click Raster menu ➤ Image Processing ➤ Palette Manager. The Palette Manager on page 350 dialog box is displayed.

2 Select two or more values from the color table:
   ■ Press Ctrl and click to select multiple values individually.
   ■ Press Shift and click to select a series of multiple values.
   ■ Click and drag in the color table to select the values within a rectangular window.
   ■ Click the Select Color button to pick a color directly from the image. For more information, see Selecting a Color Directly from the Image on page 124.
3 Click the Combine button, or right-click and click Combine on the shortcut menu. The Target Color on page 372 dialog box appears.

4 Select a new color from the color table in the Target Color dialog box.

**NOTE** The last selected color is selected by default in the Target Color dialog box.

5 Click OK to close the Target Color dialog box.

6 In the Palette Manager dialog box, click Apply.

7 Click OK to close the Palette Manager dialog box.

**Quick Reference**

**Menu**

Raster ➤ Image Processing ➤ Palette Manager

**Raster Design Toolbar**

![Palette Manager](image)

**Command Line**

ipel

**Dialog Box**

Palette Manager Dialog Box on page 350

**Designating a Transparent Color**

You can use the Palette Manager to designate a transparent color in an image. Making a color transparent is helpful if you want to see information that is displayed behind the image. The transparent color is also used to replace the data that is removed when you edit an image using the rub or crop commands. If background transparency is also turned on for the image, the rubbed areas (or the slack space in a cropped image) become transparent.

As with most changes in the Palette Manager on page 350 dialog box, the changes you make to the palette are not permanent until you click the Apply button.
For more information, see Transparent Color of an Image on page 64.

**To specify a transparent color from the color table**

1. Click Raster menu ➤ Image Processing ➤ Palette Manager. The *Palette Manager* on page 350 dialog box is displayed.

2. Select a color from the color table or use the Select Color button to pick a color directly from the image. For more information, see *Selecting a Color Directly from the Image* on page 124.

3. Click the Background Transparent button, or right-click and select Set Background Transparency on the shortcut menu.

4. To turn on background transparency in the image, select the Background Transparency check box and click Apply.

5. Click OK to close the Palette Manager dialog box.

**NOTE** If the Background Transparency check box is cleared, the background transparency will not appear.

**Quick Reference**

Menu
- Raster ➤ Image Processing ➤ Palette Manager

Raster Design Toolbar

Command Line
- ipal

Dialog Box
- *Palette Manager Dialog Box* on page 350

**Selecting a Color Directly from the Image**

Use the Select Color tool to pick colors directly from the selected image.
A single click will add one color to the selection set, or you can select all of the colors within a rectangular or polygonal window.

**To select palette colors directly from the image**

1. Click Raster menu ➤ Image Processing ➤ Palette Manager.
   The Palette Manager on page 350 dialog box is displayed.

2. Click the Select Color button.
   The following prompt is displayed:
   Select point or [Window/Polygon]:

3. Do one of the following:
   - Select a single color by picking a point in the image.
   - Enter w, then click two points to define a rectangular selection window in the image. The colors within the window are selected.
   - Enter p, then select several points to define a polygonal selection window in the image. The colors within the window are selected.

   The Palette Manager dialog box reappears and the colors you picked from the image are added to the selection set in the color table.

**Quick Reference**

Menu

Raster ➤ Image Processing ➤ Palette Manager

Raster Design Toolbar

Command Line

ipal

Dialog Box

Palette Manager Dialog Box on page 350
Removing Duplicate Entries from the Image Palette

The Palette Manager can compress the palette to remove duplicate entries from a paletted image.

Duplicate entries are two or more indexed entries that share the same RGB values. The unused entries are changed to black (0,0,0) and the color table is resorted according to the current sorting scheme. Transparent colors are not compressed.

The Compress button is not available for grayscale images.

As with most changes in the Palette Manager on page 350 dialog box, the changes you make to the palette are not permanent until you click the Apply button.

To remove duplicate entries from the Image Palette

1. Click Raster menu ➤ Image Processing ➤ Palette Manager. The Palette Manager on page 350 dialog box is displayed.
2. Click the Compress button.
3. Click Apply.
4. Click OK to close the Palette Manager dialog box.

Quick Reference

Menu
- Raster ➤ Image Processing ➤ Palette Manager

Raster Design Toolbar

Command Line
- ipal

Dialog Box
- Palette Manager Dialog Box on page 350
Resetting the Image Palette

You can remove unwanted changes to the palette by using the Reset button.
Resetting restores the palette to its original state, or to its state before you last clicked Apply.

To remove unwanted palette changes

- On the Palette Manager on page 350 dialog box, click the Reset button.

The palette is restored to its original state, or to its state just after the last Apply.

Quick Reference

Menu
- Raster ➤ Image Processing ➤ Palette Manager
- Raster Design Toolbar

Command Line
- ipal

Dialog Box
- Palette Manager Dialog Box on page 350

Importing and Exporting Image Palettes

You can apply the same palette changes to multiple images by using the import and export tools.
The Palette Manager also allows you to view information about the palette file and convert grayscale images to paletted images.

Importing an Image Palette

You can apply a saved palette to your color image (or paletted grayscale image) using the Import command.
The Import Palette dialog box allows you to navigate to any palette file (*.pf) and displays a preview of the palette, as well as a title.

The Import Palette dialog box gives you three options for applying the imported palette to your image:

- **Substitute** simply replaces the current palette with the imported palette. Indexed colors are not changed, they are mapped to the new colors in the imported palette.

- **Match** replaces the current palette with the imported palette by remapping the indexed colors to the closest colors in the imported palette. Matching is especially useful for synthetic images with areas of nearly-uniform color. A scanned USGS map, for instance, can be matched to an imported web-safe palette.

- **Dither** is similar to Match because the current indexed colors are usually re-mapped to the closest colors in the imported palette. Unlike matching, however, dithering attempts to reduce color banding by using groups of pixels displaying the target colors. The combination of these colors is perceived as a single color. Because dithering sacrifices spatial resolution in order to match the appearance of the original color, the dither option is best suited for continuous tone images such as photographs.

**NOTE** Unlike many other actions in the Palette Manager, importing a palette effects the image without clicking the Apply button. To restore the image palette, you should exit the Palette Manager and use the AutoCAD UNDO command.

### To import a saved palette

1. Click Raster menu ➤ Image Processing ➤ Palette Manager. The Palette Manager dialog box is displayed.

2. To display the Import Palette dialog box, click Palette menu ➤ Import.

   **NOTE** Grayscale images must be converted to color before you can import a palette. For more information, see Converting Grayscale Images to Paletted Images on page 132.

3. Navigate to the folder where the palette is located using one of the following methods:

   - Choose the drive and folder using standard Windows navigation procedures.
Choose a location from the Places List on the left side of the dialog box to navigate directly to the My Documents folder (or the Personal folder, depending on which operating system you are using), the Desktop, or the Favorites folder.

In the Files Of Type box, choose the file format of the palette you want to import.

**NOTE** If more than one kind of file with the same name is present in the folder, do not enter in a filename with no extension.

From the list of palettes, select the palette you want to import. The selected palette is listed in the File Name box. Alternatively, click the Favorites button to choose a shortcut to palette in a local or network location, or on the Internet.

To change the way Raster Design applies the new palette to the image, select one of the following options in the Palette Application section:

- Substitute to replace the current palette with the imported palette.
- Match to replace the current palette with the imported palette by re-mapping the indexed colors to the closest colors in the imported palette.
- Dither to replace the current palette with the imported palette by remapping the indexed colors to the closest colors in the imported palette.

To view information about a palette, such as the palette title, before you insert it, click Views ➤ Information.

To display a preview of the palette, click Views ➤ Preview.

Click Open to import the palette file and return to the Palette Manager dialog box.

**Quick Reference**

Menu

Raster ➤ Image Processing ➤ Palette Manager
Exporting an Image Palette

You can save the changes you make in the Palette Manager and export those changes for use with other images.

The Export Palette on page 316 dialog box allows you to create a palette file (*.pf) with a title and to save that palette file to a local, network, or Internet location.

To export a saved palette

1. Click Raster menu ➤ Image Processing ➤ Palette Manager. The Palette Manager on page 350 dialog box is displayed.
2. To display the Export Palette on page 316 dialog box, click Palette menu ➤ Export.
3. In the Files Of Type box, choose the desired file format for the new image.
4. There are two methods you can use to navigate to a new location to which to export the palette file:

   **NOTE** The default file extension for Raster Design palette files is .pf. However, you can specify another file extension if you wish.

   ▪ Select the drive and folder using standard Windows navigation procedures.
   ▪ Select a location from the Places List on the left side of the dialog box to navigate directly to the My Documents folder (or the Personal folder, depending on which operating system you are using), the Desktop, or the Favorites folder.
5 In the File Name box, enter a name for the palette file or choose a file name from the list.

6 In the Palette Title box, enter a title for the palette file. This name is displayed in the preview window when a palette file is imported.

7 Click Save to export the palette file and return to the Palette Manager dialog box.

Quick Reference

Menu

Raster ➤ Image Processing ➤ Palette Manager

Raster Design Toolbar

Command Line

ipal

Dialog Box

Export Palette Dialog Box on page 316

Displaying Image Palette Information

The Information option allows you to view basic information about the palette as a whole.

The Palette Information dialog box displays the following information:

■ Palette Type: Grayscale or Color Palette
■ Used: number of colors used in the image
■ Unused: number of colors not used in the image (256 – Used)
■ Palette Status: Modified or Unmodified
■ Image Status: Modified or Unmodified
■ Background Transparency: ON or OFF
To view information about the current palette

1  Click Raster menu ➤ Image Processing ➤ Palette Manager. The Palette Manager on page 350 dialog box is displayed.

2  To display the Palette Information dialog box, click Palette menu ➤ Information.

3  Click OK to return to the Palette Manager dialog box.

Quick Reference

Menu
Raster ➤ Image Processing ➤ Palette Manager

Raster Design Toolbar

Command Line
ipal

Dialog Box
Palette Manager Dialog Box on page 350

Converting Grayscale Images to Paletted Images

The Palette Manager can convert a grayscale image to a paletted image by creating an indexed palette of gray values.

One reason for doing this would be to apply spot color to a grayscale image that uses a small range of gray values. After you convert the image to a paletted image, you can change a particular gray value to a color.

NOTE If you make no changes, the image is restored to grayscale when you exit the Palette Manager.

To convert a grayscale image to a paletted image

1  Click Raster menu ➤ Image Processing ➤ Palette Manager. The Palette Manager on page 350 dialog box is displayed.
2 Click the Convert to Color button.
3 Make any desired changes to the palette.
4 Click Apply.
5 Click OK to close the Palette Manager dialog box.

Quick Reference

Menu

Raster ➤ Image Processing ➤ Palette Manager

Raster Design Toolbar

Command Line

ipal

Dialog Box

Palette Manager Dialog Box on page 350

Controlling Palette Views

The Palette Manager features a number of ways to control the appearance and contents of the color table.

Commands on the View menu allow you to display indicators for unused and transparent colors in the color table. You can also choose to display a selected color's Red, Green, Blue values (RGB) or Hue, Saturation, Luminance values (HSL) on the status bar. The Sort By list allows you to sort the colors in the color table according to Index, Frequency, Background Transparency, Dominant Color, Luminance, and so on. Grayscale images can be sorted by Index and Frequency.

Controlling the Display of Unused Colors

The Palette Manager can help you differentiate between used and unused colors in the color table by displaying unused colors with an X-shaped indicator.
To change the display of unused colors

1. Click Raster menu ➤ Image Processing ➤ Palette Manager. The Palette Manager on page 350 dialog box is displayed.

2. Click View menu ➤ Show Unused. Or with no colors selected in the color table, right-click and click Show Unused on the shortcut menu. A check mark means that unused colors will be displayed with an X indicator.

Quick Reference

Menu

Raster ➤ Image Processing ➤ Palette Manager

Raster Design Toolbar

Command Line

ipal

Dialog Box

Palette Manager Dialog Box on page 350

Controlling the Display of Transparent Colors

The Palette Manager can help you identify the transparent color in the color table by displaying the transparent color with a “+” indicator.

If there are multiple entries in the palette with the same color as the transparent color, then they are all shown with a + indicator.

To change the display of transparent colors

1. Click Raster menu ➤ Image Processing ➤ Palette Manager. The Palette Manager on page 350 dialog box is displayed.

2. Click View menu ➤ Show Transparent. Or with no colors selected in the color table, right-click and click Show Transparent on the shortcut menu. A check mark means that transparent colors will be displayed with a “+” indicator.
Quick Reference

Menu

Raster ➤ Image Processing ➤ Palette Manager

Raster Design Toolbar

Command Line

ipal

Dialog Box

Palette Manager Dialog Box on page 350

Controlling the Display of Color Values

The Palette Manager features a status bar that displays information about selected colors in the color table.

In addition to the index and frequency (which are always presence) the Palette Manager can display the selected color’s Red, Green, Blue values (RGB) or Hue, Saturation, Luminance values (HSL) on the status bar.

To change the display of color values

1. Click Raster menu ➤ Image Processing ➤ Palette Manager. The Palette Manager on page 350 dialog box is displayed.

2. Click View menu ➤ RGB. Or click View menu ➤ HSL. Or with no colors selected in the color table, right-click and click RGB or HSL on the shortcut menu. A check mark means that corresponding color values are displayed on the status bar.
Quick Reference

Menu
- Raster ➤ Image Processing ➤ Palette Manager

Raster Design Toolbar

Command Line
- ipal

Dialog Box
- Palette Manager Dialog Box on page 350

Sorting the Color Table

The Palette Manager gives you several criteria by which to sort the color table and list window.

Use the Sort By list, or click a corresponding column in the list window to sort the colors according to one of the following criteria:

- Index
- Frequency
- Background Transparency
- Color
- Red
- Green
- Blue
- Hue
- Saturation
- Luminance

To sort the color table or list window

1. Click Raster menu ➤ Image Processing ➤ Palette Manager.
The Palette Manager on page 350 dialog box is displayed.

2 In the Sort By list, select a sort method, or click one of the columns in the list window. The color table and list window are re-arranged to reflect the new order.

**Quick Reference**

Menu

Raster ➤ Image Processing ➤ Palette Manager

Raster Design Toolbar

Command Line

ipal

Dialog Box

Palette Manager Dialog Box on page 350

**Adding and Removing Columns from the List Window**

The Palette Manager features a list window as an alternative view of the color table.

By default, the list window displays the following columns:

- Index
- Frequency
- Transparent
- Color
- Red
- Green
- Blue
- Hue
- Saturation
Luminance

You can show or hide a column simply by right-clicking on any of the columns, then selecting the column name. A check mark next to the column name indicates that it is displayed.

To show or hide a column in the list window

1. Click Raster menu ➤ Image Processing ➤ Palette Manager. The Palette Manager on page 350 dialog box is displayed.
2. In the list window, right-click on one of the column headings to display the shortcut menu.
3. Click one of the column names to toggle the display status. A check mark next to the column name indicates that is displayed.

Quick Reference

Menu
    Raster ➤ Image Processing ➤ Palette Manager
Raster Design Toolbar

Command Line
    ipal
Dialog Box
    Palette Manager Dialog Box on page 350

Masking Images

To display and plot a subset of the images in your drawing, you can create a mask.

A mask clips the images that are inside the mask boundary and hides or unloads the images that are completely outside the mask boundary.

A mask is similar to an image clip, but a mask can affect more than one image at a time. Like a clip, a mask does not permanently modify the images. You
can disable the mask to redisplay all of the images and you can also convert a mask to image clips. For more information, see Enabling or Disabling a Mask on page 143, Clipping an Image on page 144, and Converting a Mask to Image Clips on page 146.

You can mask images using a rectangular or polygonal mask boundary. The mask boundary is an AutoCAD object that you can move, stretch, scale, and erase like any other AutoCAD object.

Creating a New Mask

To display and plot a subset of the images in your drawing, you can create a mask on page 394.

NOTE When drawing a mask, set the color of the current layer to a color you can easily distinguish from the AutoCAD background and your images.

To create a new mask

1. Click Raster menu ➤ Mask ➤ Create.
   The New Image Mask on page 345 dialog box is displayed.

2. Define the mask properties. For more information, see Changing the Image Mask Properties on page 141.

3. Click either Rectangular or Polygonal to draw the mask boundary. You must select at least three points to define a polygonal mask. Once you have selected all the points, right-click and click Enter on the shortcut menu.
   The mask clips the images that are inside the mask boundary. Depending on the properties you set for the mask, the images that are completely outside the mask boundary are hidden, unloaded, or unaffected.

NOTE You can have two enabled masks per drawing: one in model space and one in paper space. If you create more than one mask in model space or paper space, then the most recently created mask is enabled, and all other masks in that space are disabled automatically. For more information, see Enabling or Disabling a Mask on page 143.
Quick Reference

Menu
- Raster ➤ Mask ➤ Create

Raster Design Toolbar

Command Line
- imask

Dialog Box
- New Image Mask Dialog Box on page 345

Creating a New Mask Using the Command Line

You can bypass the New Image Mask dialog box by typing -imask on the command line.

To create a new mask using the command line

1. Enter -imask to display the following prompt:
   New or [Select Image Mask]:

2. Enter n to create a new mask. The following prompt is displayed:
   Enter an option [Polygon/Rectangular/prOperties/eXit]<eXit>:

3. Enter p to define a polygonal mask or enter r to define a rectangular mask.
   You must select at least three points to define a polygonal mask. Once you have selected all the points, right-click and click Enter on the shortcut menu.
   The default mask properties are used to create the mask. For more information, see Changing the Image Mask Properties on page 141.

See also:

- Changing an Existing Mask Using the Command Line on page 143
Quick Reference

Command Line
-imask

Dialog Box
New Image Mask Dialog Box on page 345

Changing an Existing Mask
You can edit the vertices of a mask by selecting and moving them using AutoCAD grips.

You can add vertices to the boundary of an existing mask by selecting and moving a midpoint of a mask boundary segment.

NOTE If you cannot see the image mask boundary, then enter REGEN to refresh the AutoCAD display order.

You can use AutoCAD editing commands to move, rotate, stretch, erase, or scale a mask.

If you want to change how the mask affects the images that are outside the mask boundary, then you can change the mask properties, disable the mask, or convert a mask to image clips.

Changing the Image Mask Properties
By changing the image mask properties, you can control what happens to the images that are outside the mask boundary.

For example, you can:

■ Unload the images from memory to enhance performance.
■ Display image frames when you use a mask so you can easily see where the image(s) you masked are located.
■ Convert an existing mask to image clips.
■ Disable and enable a mask.
To change the image mask properties for a new mask

1. Click Raster menu ➤ Mask ➤ Create.

2. You can clear the Enable Mask check box if you want to disable (turn off) a mask. When the mask is disabled, you can still edit the mask boundary, but the images are not affected until you enable the mask again. Only one mask in model space or paper space can be enabled at a time. For more information, see Enabling or Disabling a Mask on page 143.

3. Choose one of the following mask options:
   - Do Not Affect
   - Hide Image(s)
   - Unload Images

4. Select the Show Image Frame(s) check box if you want to show the frames of the images that are outside the mask object. This option is available only if the Hide Image(s) or Unload Image(s) option is selected.

   **NOTE** If you used the AutoCAD IMAGEFRAME command to turn off image frames in your drawing, then the Show Image Frame(s) check box is unavailable and you cannot show the image frames.

5. Click Close to save your changes.

**Quick Reference**

**Menu**

- Raster ➤ Mask ➤ Create

**Raster Design Toolbar**

**Command Line**

- imask
Changing an Existing Mask Using the Command Line

You can bypass the New Image Mask on page 345 dialog box by typing -imask at the command line.

To edit an existing mask using the command line

1. Enter -imask to display the following prompt:
   New or [Select Image Mask]:

2. Select an existing mask from the drawing. The following prompt is displayed:
   Enter an option [Polygonal/Rectangular/Convert/prOperties/eXit]<eXit>:

3. Do one of the following
   - Enter p to redefine the mask using a polygon.
   - Enter r to redefine the mask using a rectangle.
   - Enter c to convert the mask to image clips.
   - Enter o to redefine mask properties. For more information, see Changing the Image Mask Properties on page 141.
   - Enter x to exit the command.

Quick Reference

Command Line
- -imask

Enabling or Disabling a Mask

You can have two enabled masks per drawing: one in model space and one in paper space.

If you create more than one mask in model space or paper space, the most recently created mask is enabled; all other masks in that space are disabled automatically.
Effects of disabling a mask
The mask boundary is still visible in the drawing, but the images that cross the mask boundary are not clipped. You can edit the mask boundary when the mask is disabled, but the affected images are not clipped until the mask is enabled again.

If you used the Hide Image(s) option for the mask, then the images that were affected by the mask are shown when you disable the mask.

If you used the Unload Image(s) option for the mask, then the images are reloaded when you disable the mask.

Effects of enabling a mask
The images are clipped and the mask properties control the display of the images that are outside the mask boundary.

Only one mask in model space or paper space can be enabled. If you create more than one mask, the most recently created mask is enabled automatically; all other masks in that space are disabled. If you manually enable a mask, then all other masks are disabled automatically.

To enable or disable a mask
1 Select the mask boundary, then right-click to open the Properties dialog box.
2 In the Properties dialog box, click Enabled in the Misc category.
3 Click Yes from the list to enable the mask, or No to disable the mask.

Quick Reference
Menu
Raster ➤ Mask ➤ Create
Command Line
imask

Clipping an Image
You can use the AutoCAD IMAGECLIP command to display a subregion of one image.
A clip is a display-only feature that you can use for viewing and plotting purposes. It does not permanently change image data.

The subregion is defined by a clip boundary. When you clip an image, parts of the image outside the clip boundary are hidden from view. You can turn off the clip to redisplay the entire image. You can grip edit the clip boundaries to display more or less of the image. If the clip boundary encloses multiple images, each one is handled as a separate clip.

The IMAGECLIP command works on AutoCAD images (bitonal, grayscale, index color or true color) and on Raster Design custom images (digital elevation models, single-band integer data, or multiband multispectral data).

The IMAGECLIP command works on AutoCAD images (bitonal, grayscale, index color or true color) and on Raster Design custom images.

NOTE To display a polygonal sub-region of more than one image, use the Raster Design Mask command. For more information, see Creating a New Mask on page 139. To permanently trim one or more images, use the Raster Design Crop command. For more information, see Cropping Images on page 147.

**To clip an image**

1. Enter IMAGECLIP.
2. Select the image you want to clip. You can only clip one image at a time.
   The following prompt is displayed:
   Enter image clipping option [ON/OFF/Delete/New boundary] <New>:
3. Press Enter to create a new clip boundary.
4. Enter r to create a rectangular boundary, or enter p to create a polygonal boundary. You must select at least three points to define a polygonal mask. Once you have selected all the points, right-click and click Enter on the menu.
   To restore the image, you can use the IMAGECLIP OFF command or Delete option. For more information, see the AutoCAD online Help.

You can also choose to show or hide clips by changing the image display properties in the Image Properties dialog box. For more information, see Image Display Properties on page 60.
**Quick Reference**

Command Line

imageclip

Object Shortcut Menu

Image ➤ Clip

---

**Converting a Mask to Image Clips**

A mask is essentially a clip that can affect more than one image at a time.

If you want to remove a mask but preserve the clipping effect on the images, you can convert a mask to image clips.

**To convert a mask to image clips**

- Click Raster menu ➤ Mask ➤ Convert to Image Clip. Then select the mask boundary.

  The mask is removed but the clips on the image(s) are preserved. After you convert a mask to image clips, you may need to manually show or reload any images that were hidden or unloaded by the mask. To show images that are hidden, you can select the image frame, then right-click and click Show Image on the shortcut menu.

  You can then use the AutoCAD IMAGECLIP command to turn off the clips and change the clip boundary if desired. Any image that you insert into the drawing after converting a mask is visible.

**NOTE** If you want to remove a mask boundary and restore all clipped images to their extents, then use the AutoCAD ERASE command to erase the mask boundary.

---

**Quick Reference**

Menu

Raster ➤ Mask ➤ Convert to Image Clip

Raster Design Toolbar

---

146 | Chapter 6   Modifying Images
Cropping Images

You can crop raster data within an image or across multiple images.

The only images that are affected are those that are within or partly within the selected entity or area. When you crop an image, the image frame size changes to compensate for any removed border data.

Crops use the current transparent color. For example, if you perform a circular crop on an image, then the area outside of the circle is filled with the transparent color. If you later change the transparent color, the color of the cropped area remains the same, but any subsequent crops are drawn in the new color. For more information, see Transparent Color of an Image on page 64.

Line Cropping

Remove all raster data except for a specific line segment by selecting a point on each end of the raster line. You must set an appropriate line width for the crop. For more information, see Rub and Crop Line Width on page 268.

To crop a raster line

1. Set an appropriate line width for the crop.
2. Click Raster menu ➤ Crop ➤ Line.
3. Select the first point on the line.
4. Select the second point on the line to remove all the raster data except for the selected line.

After the data is cropped, the image frame changes to reflect the new size of the image.

Quick Reference

Menu

Raster ➤ Crop ➤ Line
Circular Cropping
Remove all the raster data outside a defined circular region. The area outside the circle is filled with the transparent color. For more information, see, Transparent Color of an Image on page 64.

To crop raster data outside a circle
1. Click Raster menu ➤ Crop ➤ Circular Region.
2. Select three points to define the circle around the raster data you want to preserve.

Quick Reference
Menu
   Raster ➤ Crop ➤ Circular Region

Rectangular Cropping
Remove all the raster data outside a defined rectangular region, which can be rotated at any angle.
To remove raster data outside a rectangle

1. Click Raster menu ➤ Crop ➤ Rectangular Region.
2. Select a point that represents one corner of the rectangular crop region. A rubber-band line is displayed to help you establish the angle.
3. Pick a point at one corner of the raster data you want to preserve.
4. Pick a third point to define the final size of the rectangular region to preserve. The image is cropped to this region, and the image frame follows the edge of the cropped region.

Quick Reference

Menu
fol
Raster ➤ Crop ➤ Rectangular Region
Raster Design Toolbar

Command Line
icroprect

Diagonal Cropping

Remove all the raster data outside a parallelogram.

To remove raster data outside a diagonal region

1. Click Raster menu ➤ Crop ➤ Diagonal Region.
2. Select a starting point for the diagonal crop region. This point can be any corner of the area that you want to preserve.
3. Select a second point to define one of the edges of the area you want to preserve.
   A bounding parallelogram is displayed to help you select the next point.
4. Select the third point to complete the selection of the diagonal crop region.
Quick Reference

Menu

Raster ➤ Crop ➤ Diagonal Region

Raster Design Toolbar

Command Line

icropdiag

Polygonal Cropping

Remove all the raster data outside a defined polygonal region.

To crop raster data outside a polygon

1. Click Raster menu ➤ Crop ➤ Polygonal Region.
2. Pick a minimum of three points around the raster data you want to preserve.
3. Right-click and click Enter to close the polygon.

Quick Reference

Menu

Raster ➤ Crop ➤ Polygonal Region

Raster Design Toolbar

Command Line

icroppoly

Aligned Rectangular Cropping

Remove all the raster data outside a rectangular region that is aligned at any angle, while preserving the rotation angle of the original image.
To crop raster data outside an aligned rectangle

1. Click Raster menu ➤ Crop ➤ Aligned Rectangular Region.
2. Pick a point at one corner of the raster data you want to preserve.
3. To define the baseline, pick a second point or enter a numeric angle in relation to horizontal.
4. Pick a third point to define the final size of the rectangular region to preserve. The image is cropped to this region, but the image frame retains the angle of the original image at the time the crop was made.

Quick Reference

Menu
Raster ➤ Crop ➤ Aligned Rectangular Region

Command Line
icropalign

Removing (Rubbing) Images

You can rub raster data within an image or across multiple images.

Only the images that are within or partly within the selected entity or area affected.

Rubs use the current transparent color. For example, if the color for background transparency is blue, then the rub is drawn in blue. If you later change the transparent color, the color of the rubbed area remains blue, but subsequent rubs are drawn in the new color. For more information, see, Transparent Color of an Image on page 64.

You can also remove raster entities (lines, arcs, and circles) by using REM delete commands or by using existing vector geometry. For more information, see Removing Raster Entities Using REM Commands on page 159.

NOTE Rubs permanently change the raster data in the image; they do not temporarily remove raster data from the display. To reverse a rub, use the AutoCAD UNDO command.
Rubbing a Raster Line

You can remove a raster line by picking a point on each end of the raster line. You must set an appropriate line width. For more information, see Rub and Crop Line Width on page 268.

**NOTE** Unlike previous versions of Raster Design, rubs permanently change the raster data after you have saved the image. They do not temporarily remove raster data from the display. To reverse a rub, use the AutoCAD UNDO command.

To rub a raster line

1. Set an appropriate line width for the rub.
2. Click Raster menu ➤ Remove ➤ Line.
3. Select the first point on the raster line you want to remove.
4. Select the second point on the raster line to remove the line.

**Quick Reference**

Menu

Raster ➤ Remove ➤ Line

Raster Design Toolbar

Command Line

irubline

Rubbing a Raster Arc

You can remove a raster arc by picking the start, center, and end points of the raster arc. You must set an appropriate line width. For more information, see Rub and Crop Line Width on page 268.

**NOTE** Unlike previous versions of Raster Design, rubs permanently change the raster data after you have saved the image. They do not temporarily remove raster data from the display. To reverse a rub, use the AutoCAD UNDO command.
To rub a raster arc

1. Set an appropriate line width for the rub.
2. Click Raster menu ➤ Remove ➤ Arc.
3. Select the start point of the raster arc you want to remove.
4. Select the center point of the raster arc.
5. Select the end point of the raster arc to remove the raster arc.

Quick Reference

Menu
Raster ➤ Remove ➤ Arc

Raster Design Toolbar

Command Line
irubarc

Rubbing a Raster Circle

You can remove a raster circle that has a width (sometimes called a donut) by picking three points on the circle. You must set an appropriate line width. For more information, see Rub and Crop Line Width on page 268.

NOTE Unlike previous versions of Raster Design, rubs permanently change the raster data after you have saved the image. They do not temporarily remove raster data from the display. To reverse a rub, use the AutoCAD UNDO command.

To rub a raster circle

1. Set an appropriate line width for the rub.
2. Click Raster menu ➤ Remove ➤ Circle.
3. Select the center point of the raster circle you want to remove.
4. Select the second point to define the radius of the raster circle.
Rubbing Multiple Line Segments

You can remove more than one raster line segment at a time by using the Rub Polyline command. You must set an appropriate line width. For more information, see Rub and Crop Line Width on page 268.

NOTE Unlike previous versions of Raster Design, rubs permanently change the raster data after you have saved the image. They do not temporarily remove raster data from the display. To reverse a rub, use the AutoCAD UNDO command.

To rub multiple line segments

1. Set an appropriate line width for the rub.
2. Click Raster menu ➤ Remove ➤ Polyline.
3. Select the first point of the line segment you want to rub.
4. Select the second point of the line segment you want to rub.
5. Do one of the following:
   - Select additional points to rub more line segments.
   - Right-click and click Enter to end the polyline and rub the raster underneath it.
   - Enter c when you have selected at least three vertices to draw a closed polyline and rub the raster beneath it.
Quick Reference

Menu

Raster ➤ Remove ➤ Polyline

Raster Design Toolbar

Command Line

irubpline

Rubbing Raster Data Within a Circular Region

You can remove a circular area of your raster image.

NOTE Unlike previous versions of Raster Design, rubs permanently change the raster data after you have saved the image. They do not temporarily remove raster data from the display. To reverse a rub, use the AutoCAD UNDO command.

To remove the raster data within a circular region

1. Click Raster menu ➤ Remove ➤ Circular Region.
2. Select the center point of the raster circle you want to remove.
3. Select the second point to define the radius of the raster circle.

Quick Reference

Menu

Raster ➤ Remove ➤ Circular Region

Raster Design Toolbar

Command Line

irubcirc
Rubbing Raster Data Within a Diagonal Region

You can rub raster data within a diagonal parallelogram.

**NOTE** Unlike previous versions of Raster Design, rubs permanently change the raster data after you have saved the image. They do not temporarily remove raster data from the display. To reverse a rub, use the AutoCAD UNDO command.

To rub the raster data within a diagonal region

1. Click Raster menu ➤ Remove ➤ Diagonal Region.
2. Select a starting point for the diagonal region. This point can be any corner of the area you want to remove.
3. Select a second point to define one of the edges of the region you want to remove.
4. A bounding parallelogram is displayed to help you select the next point.
5. Select the third point to remove data within the diagonal rectangle or parallelogram.

Quick Reference

Menu

Raster ➤ Remove ➤ Diagonal Region

Raster Design Toolbar

Command Line

irubdiag

Rubbing Raster Data Within a Polygonal Region

You can remove raster data by defining a polygon around the data you want to remove.

**NOTE** Unlike previous versions of Raster Design, rubs permanently change the raster data after you have saved the image. They do not temporarily remove raster data from the display. To reverse a rub, use the AutoCAD UNDO command.
To remove the raster data within a polygonal region

1. Click Raster menu ➤ Remove ➤ Polygonal Region.
2. Select a minimum of three points around the raster data you want to remove.
3. Right-click to close the polygon and remove the data within the polygon.

Quick Reference

Menu
Raster ➤ Remove ➤ Polygonal Region

Raster Design Toolbar

Command Line
irubpoly

Rubbing Raster Data Within a Rectangular Region

You can rub raster data within a rectangular region.

NOTE Unlike previous versions of Raster Design, rubs permanently change the raster data after you have saved the image. They do not temporarily remove raster data from the display. To reverse a rub, use the AutoCAD UNDO command.

To rub the raster data within a rectangular region

1. Click Raster menu ➤ Remove ➤ Rectangular Region.
2. Select a starting point for the rectangle.
3. Select the opposite corner of the rectangle to remove data within the rectangle.
Remove Raster Under Vector Tool

The Remove Raster Under Vector tool allows you to use existing vector geometry to remove portions of the underlying raster image.

For instance, you could use AutoCAD tools to trace a complex spline in your image, then use the Remove Raster Under Vector tool to remove the traced raster.

Depending on the settings in the Raster Design Options dialog box, the removal is accomplished using either "rub" or raster entity manipulation (REM) methods. If you choose the REM removal method, raster intersections are preserved. For more information, see Remove Under Method on page 270.

**NOTE** The Remove Raster Under Vector tool does not remove raster data within the selected vector, only around the selected vector. For instance, using a vector polygon will only remove the raster around the polygon segments, ignoring the raster data within the interior of the polygon.

**To remove raster data using existing vector geometry**

1. Click Raster menu ➤ Remove ➤ Raster Under Vector.
2. Select the vector geometry to remove that portion of the underlying raster image.

**NOTE** A faster way to use the Remove Raster Under Vector tool is to select the vector entity, then right-click and click Remove Raster Underneath.
Removing Raster Entities Using REM Commands

You can remove raster lines, arcs, and circles from bitonal images using raster entity manipulation (REM) delete commands.

When you remove raster entities using these commands, Raster Design automatically cleans up intersections with other raster entities. For example, if you remove a line that bisects a circle, no gap is left in the circle where the line was removed.

In the following illustration, the left displays REM primitive line (shown in red). The illustration on the right shows how the image appears after the primitive line is deleted. The intersections with the circles and vertical line are preserved.

Removing a Line, Arc, or Circle Using Smart Pick

You can delete a raster line, arc, or circle that you define as a primitive object.

Raster Design automatically detects the geometry of the selected raster entity (line, arc, or circle) and immediately deletes the entity. When you remove the
entity, Raster Design automatically cleans up intersections with other raster entities.

You can use raster snaps to assist in selecting the raster entity. For more information, see Raster Snapping on page 239.

NOTE This command is available only for bitonal images.

To remove a REM primitive using Smart Pick

1. Click Raster menu ➤ Remove ➤ Smart Pick.
2. Select the raster line, arc, or circle.

Quick Reference

Menu

Raster ➤ Remove ➤ Smart Pick

Raster Design Toolbar

Command Line

idelsmart

Removing a REM Line Primitive

You can delete a raster line that you define as a primitive object.

When you remove the line, Raster Design automatically cleans up the intersections of the line with other raster entities.

You can use raster snaps to assist in selecting the raster line. For more information, see Raster Snapping on page 239.

NOTE This command is available only for bitonal images.

To remove a REM line primitive

1. Click Raster menu ➤ Remove ➤ Line Entity.
2 Select the raster line using one of the following methods
   ■ Select a single point on the line.
   ■ Enter 2p and select the start and end points of the raster line.

Quick Reference

Menu
   Raster ➤ Remove ➤ Line Entity

Raster Design Toolbar

Command Line
   idelline

Removing a REM Arc Primitive

You can delete a raster arc that you define as a primitive object.

When you remove the arc, Raster Design automatically cleans up the
intersections of the arc with other raster entities.

You can use raster snaps to assist in selecting the raster arc. For more
information, see Raster Snapping on page 239.

NOTE This command is available only for bitonal images.

To remove a REM arc primitive
1 Click Raster menu ➤ Remove ➤ Arc Entity.
2 Select the raster arc using one of the following methods
   ■ Select a single point on the arc.
   ■ Enter c and then select the center point, the start point, and the end
     point. Instead of selecting the end point, you can also enter a and
     specify the angle, or you can enter l (lowercase L) and specify the
     chord length.
Enter 3p and select the start point, the second point, and the end point of the arc.

**Quick Reference**

**Menu**

Raster ➤ Remove ➤ Arc Entity

**Raster Design Toolbar**

Command Line

idelarc

**Removing a REM Circle Primitive**

You can delete a raster circle that you define as a primitive object.

When you remove the circle, Raster Design automatically cleans up the intersections of the circle with other raster entities.

You can use raster snaps to assist in selecting the raster circle. For more information, see Raster Snapping on page 239.

**NOTE** This command is available only for bitonal images.

**To remove a REM circle primitive**

1. Click Raster menu ➤ Remove ➤ Circle Entity.
2. Select the raster circle using one of the following methods
   - Select a single point on the circle.
   - Enter 2p and select two points to define the diameter of the circle.
   - Enter 3p and select three points on the circumference.
Quick Reference

Menu
Raster ➤ Remove ➤ Circle Entity

Raster Design Toolbar

Command Line
idelcircle

Merging Objects

You can use Raster Design to merge objects in the following ways:

- Merge any number of images together.
- Merge vector into a new or existing raster image.

Merging Images

You can merge images by selecting the destination image you want to merge source images into.

Raster Design merges your source images into a single destination image. The properties of your destination image, such as dpi and color depth will not change as a result of the merge. The merge will also respect any polygonal clip boundaries you have set, as well as brightness and contrast resolutions.

For example, if your source image has a value of 200 dpi, and your destination image has the value of 400 dpi, the destination image will retain the value of 400 dpi after you have performed a merge.

The destination image is expanded to encompass your source image(s). The background will be filled with the transparent color. You can change the transparent color in your image. For more information, see Transparent Color of an Image on page 64.

To merge images together

1  Click Raster menu ➤ Merge ➤ Images.
2 Select your source images.
3 Select your destination image.
   You are prompted whether to remove the source images after the merge.
4 Click Yes to start the merge process.

Quick Reference

Menu
Raster ➤ Merge ➤ Images

Raster Design Toolbar

Command Line
iimage

Merging Vectors into a Raster Image

Merging vectors creates a raster equivalent of a vector entity.

When working with a hybrid on page 393 drawing you can merge vectors into an existing image or a new raster image. Vector merge allows you to make precise changes to your raster image with AutoCAD, while keeping your data in a raster format.

NOTE  Vector merge can only operate on a single image at a time.

To merge vectors into a raster image

1 To display the Select objects prompt at the command line, click Raster menu ➤ Merge ➤ Vector into Raster.
2 Select the vectors and image you want to merge.
   You are prompted to delete vectors if the Prompt to Delete Vectors check box is selected on the Vector Merge tab in the Raster Design Options on page 353 dialog box. For more information, see Vector Merge Settings on page 270.
3 Press Enter to start the vectors merge operation
A quick way of merging vector into raster using the default merge settings is to right-click the selected vector entities, then click Merge Vector to Raster Image on the shortcut menu. However, you should ensure the Prompt to Delete Vectors check box is not selected on the Vector Merge tab in the Raster Design Options dialog box.

Quick Reference

Menu
Raster ➤ Merge ➤ Vector into Raster

Command Line
ivmerge

Selecting Pen Widths for Vector Merge

You can select widths for Raster Pen for vector merge by specifying pen thickness in the Raster Pen Settings on page 366 dialog box.

To select raster pen widths for vector merge

1. Click Raster menu ➤ Merge ➤ Configure Raster Pens. The Raster Pen Settings on page 366 dialog box is displayed.

   NOTE Enter -rpens to access the command line interface.

2. On the Color Index list, select the color(s) for which you want to modify the line width.

3. Enter the width you want in the Pen Width edit box, or select the Use Fixed Width check box, then enter the width you want to apply to all of the raster pens in the Pen Width edit box.

4. Click OK to close the dialog and apply the raster pen settings.
See also:
- Raster Pen Settings Dialog Box on page 366

Quick Reference

Menu
- Raster ➤ Merge ➤ Configure Raster Pens

Raster Design Toolbar

Command Line
- rpens

Dialog Box
- Raster Pen Settings Dialog Box on page 366
You can use Raster Entity Manipulation (REM) to edit raster entities in bitonal, color, and grayscale images.

For example, you can adjust the radius of a raster circle, remove some dimension lines on a mechanical drawing, or copy electrical symbols from one image to another.

You use REM commands to define raster entities as REM objects. After defining the REM objects, you can use either AutoCAD commands or Raster Design commands to operate on the objects in the same way you work with vector objects. You can merge the modified raster data into the existing image or create a new image from the data.

**Types of REM Objects**

There are three types of REM objects:

- **Region.** Use a region object to select all of the pixels within the given geometry, whether or not the pixels make up individual raster entities. You can define region objects for all image types (bitonal image on page 384, grayscale image on page 392, and clipped image on page 385). A region can be rectangular, polygonal, diagonal, or circular.

- **Enhanced Bitonal Region.** On bitonal images, use an enhanced bitonal region to automatically select complete raster entities.

- **Primitive.** Use a primitive object to select individual raster lines, circles, or arcs. Primitives are more intelligent than regions and enhanced bitonal regions because their dimensions can be changed. For example, you can change the diameter of a circle and still have it maintain its original line width. You can also use grips or the Properties dialog box to change the dimensions of a primitive object. For more information, see *AutoCAD Properties of REM Objects* on page 169.
Characteristics of REM Objects

In most respects, REM objects are similar to other AutoCAD objects. However, some behavior and characteristics of REM objects are specific to their function in Raster Design.

How REM Objects Are Associated with an Image

When you create a REM object, it is associated with an image. Any AutoCAD command that changes the geometry or location of a REM object causes the REM object to dissociate from the image. Such commands include MOVE, SCALE, ROTATE, and ERASE. REM Smooth also causes a dissociation. For more information, see Smoothing REM Linework on page 196.

If the geometry or location of your source image changes, the associated REM objects adjust accordingly. For example, if you move an image to a new location, all the REM objects associated with the image move with it and are not deleted. If an image is erased or unloaded, all the REM objects associated with it are also erased.

If you define a rectangular region as a REM object and then move it, the original raster data in the source image is deleted.

If your REM primitive or enhanced bitonal region is defined over an intersection, the intersection is preserved even after you MOVE the primitive object.

NOTE REM region and primitive objects that are dissociated from an image cannot be refined.

In order to save your changes to your REM objects, you must either merge the objects into an image, or create a new raster image from the objects. For more information, see Merging REM Objects into an Image on page 200 and Converting REM Objects to a New Raster Image on page 201.

REM objects cannot be plotted.

Deciding Which Image to Use REM Commands On

There are only two conditions under which REM cannot automatically determine what image to acquire data from:

- Overlapping images: One image overlaps the other, and the geometry for the REM object is within or touching both images.
Adjacent images: One image is tiled next to another, and the geometry for the REM object is within or touching both images.

Raster Design prompts you to select one or more images to operate on. If you are defining a region object, you can select multiple images and a REM object is created for each image. If you are defining an enhanced bitonal region object or a primitive object, you can select only one image when prompted.

**AutoCAD Properties of REM Objects**

Some AutoCAD properties apply differently to REM objects than to other AutoCAD objects:

- **Color**: REM objects do not respond to the AutoCAD Properties color setting. Instead, you can use the Raster Design Options on page 353 dialog box to select the color of all REM objects. For more information, see AutoCAD Properties on page 59 and REM Settings on page 267.

- **Layer**: REM objects are created on the current AutoCAD layer by default. However, you can specify any layer.

- **Linetype**: The vector boundary of a REM object is always displayed with the current AutoCAD linetype. You can, however, change the linetype of the raster data of a REM primitive object. For more information, see Changing the Linetype of a Primitive Object on page 188.

- **Width**: Allows you to change the line width of the raster entity.

**REM Objects and Non-REM Edits**

You cannot use Raster Design commands that apply to an entire image if REM objects are associated with the image. Such commands include Despeckle, Mirror, Invert, Histogram, and Crop. Commands that operate on a sub-region of an image are allowed only if the bounding box of the edit operation does not overlap any REM objects.

When you create REM objects in an image, you must finish all REM edits and merge, convert, or remove all REM objects before you can do any raster editing.

If you attempt to perform a non-REM edit that overlaps a REM object, the Raster Design Edit Status on page 312 dialog box is displayed. Clear the REM objects or merge the objects into the image before editing the entire image.
Defining REM Region Objects

Define a REM region object when you want to work with the pixels inside the specified area, such as the pixels within a polygon.

You can define the region using the Raster Entity Manipulation submenu on the Raster menu, the REM Regions toolbar, or the command line.

You can define the following region objects: polygon, rectangle, diagonal, and circular. In addition, you can define a region object from an existing vector object.

After you define a region object, you can edit it, then merge it into an existing image, or create a new image from the region object.

See also:

- Resizing a REM Object on page 191
- Editing REM Objects on page 189
- Merging REM Objects into an Image on page 200
- Converting REM Objects to a New Raster Image on page 201

As shown in the following example, you can define a housing development within an aerial photograph as a region object. You can then convert the region object to a new image as a base for a street drawing.
Grip Behavior

Each vertex of a polygonal, rectangular, or diagonal region object has a grip you can use to select the object. Moving a grip moves the object.

A circular region object has five grips: one at the center of the circle and four grips on the circumference.

If you stretch either the start or end grip point of a line, Raster Design redraws the line with the new start or end point, respecting the original line width. When the line is redrawn, Raster Design uses the current AutoCAD linetype.

If you stretch any of the grip points of an arc, Raster Design redraws the arc's start, end, and radius, respecting the original line width. When the arc is redrawn, Raster Design uses the current AutoCAD linetype.

NOTE This grip behavior does not apply when you are in REM define mode.

Defining a REM Rectangular Region

A rectangular region object includes all the pixels within the rectangle you define.

Click here to see an illustration of raster data selected within a rectangle.

All of the raster data within the defined rectangle is selected.

See also:

- Resizing a REM Object on page 191
- Editing REM Objects on page 189
- Merging REM Objects into an Image on page 200
- Converting REM Objects to a New Raster Image on page 201
To define a rectangular region object

1. Click Raster menu ➤ Raster Entity Manipulation ➤ Create Region ➤ Rectangular.
2. Select two points to define the rectangle.

Quick Reference

Menu
Raster ➤ Raster Entity Manipulation ➤ Create Region ➤ Rectangular

REM Toolbar

Command Line
isrectreg

Defining a REM Polygonal Region
A polygonal region object includes all the pixels within the polygon you define.

Click here to see an illustration of raster data selected within a polygon.

All of the raster data within the defined polygon is selected.

See also:
- Resizing a REM Object on page 191
- Editing REM Objects on page 189
To define a polygonal region object

1. Click Raster menu ➤ Raster Entity Manipulation ➤ Create Region ➤ Polygonal.
2. Select points to define the polygon and then press Enter to close it.

Quick Reference

Menu
- Raster ➤ Raster Entity Manipulation ➤ Create Region ➤ Polygonal

REM Toolbar

Command Line
- ispolyreg

Defining a REM Diagonal Region

A diagonal region object includes all of the pixels within the diagonal area you define.

The diagonal region is a parallelogram that you define with three points. You can move the third point to control the final shape of the region.

Click here to see an illustration of raster data selected within a diagonal region.
All of the raster data within the defined diagonal region is selected.

See also:
- Resizing a REM Object on page 191
- Editing REM Objects on page 189
- Merging REM Objects into an Image on page 200
- Converting REM Objects to a New Raster Image on page 201

To define a diagonal region object
1. Click Raster menu ➤ Raster Entity Manipulation ➤ Create Region ➤ Diagonal.
2. Select points for the first corner point, the adjacent corner point, and the last corner point.

Quick Reference

Menu
- Raster ➤ Raster Entity Manipulation ➤ Create Region ➤ Diagonal

REM Toolbar

Object Shortcut Menu
- Right-click image ➤ REM ➤ Create ➤ Diagonal Region

Command Line
- isdiagreg

Defining a REM Circular Region
A circular region object includes all of the pixels within the circle you define.
Click here to see an illustration of raster data selected within a circular region.

All of the raster data within the defined circular region is selected.

See also:

- Resizing a REM Object on page 191
- Editing REM Objects on page 189
- Merging REM Objects into an Image on page 200
- Converting REM Objects to a New Raster Image on page 201

To define a circular region object

1. Click Raster menu ➤ Raster Entity Manipulation ➤ Create Region ➤ Circular.
2. Do one of the following:
   - Select the center point and one point on the circumference.
   - Type 3P and select three points on the circumference.

Quick Reference

Menu
Raster ➤ Raster Entity Manipulation ➤ Create Region ➤ Circular

REM Toolbar

Defining a REM Circular Region | 175
Defining a Region From an Existing Vector Object

You can define a region object using the geometry of an existing vector object, such as a polyline, rectangle, circle, or ellipse.

For example, you may have a vector circle corresponding to a 5-mile radius where an all-vegetation area will be affected by a contamination spill. You can select the vector circle to define a circular region object corresponding to all the raster data within the circle.

See also:

- Resizing a REM Object on page 191
- Editing REM Objects on page 189
- Merging REM Objects into an Image on page 200
- Converting REM Objects to a New Raster Image on page 201

To define a region from an existing vector object

1. Click Raster menu ➤ Raster Entity Manipulation ➤ Create Region ➤ From Existing Vector.
2. Select the closed vector object.

Quick Reference

Menu

Raster ➤ Raster Entity Manipulation ➤ Create Region ➤ From Existing Vector

REM Toolbar

176 | Chapter 7  Raster Entity Manipulation
Removing Part of a Region Object

You can remove part of a selected region object using a variety of methods that specify subregions, individual entities, or a series of connected entities.

For example, you may have selected a shaft as a circular region object and would like to remove a drill hole from that shaft before moving the shaft. You can do this by defining a REM circular region to remove the drill hole from the region object.

The removal process is the same for all REM region objects, including enhanced bitonal regions.

**NOTE** You cannot remove an enhanced bitonal region object or a primitive object from a REM object in a grayscale or color image.

Removing has two main purposes:

- If a region is associated, it deselects raster data in the REM object so that when the object is dissociated, the deselected data remains in the original image.

- If a region is dissociated, it removes raster data so that when the object is merged into an image or converted to a raster image, the removed data will not be present.

**Removal Methods**

You can use the following methods to specify what to remove from the REM region:

- Select an individual raster entity for removal, using menu selections Line, Circle, Arc, or Smart Pick. Smart Pick is recommended if the entity is not specifically a line, circle, or arc.

- Define a subregion using one of the menu selections Rectangle, Polygon, Diagonal, or Circle. This method works with pixels rather than raster entities, and removes all pixels within the area you define.
Create an enhanced bitonal region object to select one or more raster entities. For more information, see Defining REM Enhanced Bitonal Regions on page 178.

To remove part of a region object

1. Select the region object you want to modify.
2. Right-click, click Remove, and select a removal method. For more information on the methods, see Defining REM Enhanced Bitonal Regions on page 178.
3. Define the area that you want to remove from the first REM object.

Quick Reference

Menu
Raster ➤ Raster Entity Manipulation ➤ Remove Data From Region

REM Toolbar

Object Shortcut Menu
Right-click REM region ➤ Remove ➤ (select removal method)

Command Line
iremove

Defining REM Enhanced Bitonal Regions

Define a REM enhanced bitonal region when you want to select complete raster entities within a bitonal image.

For example, you might be working with an image of a mechanical drawing that contains a plan view of a cylinder. You want to scale the size of the cylinder hole to make it larger. You can accomplish this by selecting the cylinder as an enhanced bitonal region object. You can then use this object to quickly scale the size of the cylinder, without touching any other part of the image.
See also:

■ Editing REM Objects on page 189
■ Merging REM Objects into an Image on page 200
■ Converting REM Objects to a New Raster Image on page 201

NOTE You can define enhanced bitonal region objects only in bitonal images.

An enhanced bitonal region is defined by the selection method you choose, based either on smart objects or connected objects.

**Smart Objects**

Use this type of object to select complete raster entities such as lines, arcs, circles, polygons, or text characters in a region. You can define the region by drawing a rectangular window or a polygon. Use a crossing window or polygon if you want to include entities that cross the region boundary. You can also draw a smart polyline or fence to select entities that touch the fence. For further information, including illustrated examples of smart object selection, see the following Glossary links: smart crossing polygon, smart crossing window, smart fence on page 399, smart window on page 399, smart window polygon.

**Connected Objects**

Use this type of object to select complete raster entities based on how they are connected to each other. This approach makes it easier to either select or exclude a connected series of entities. You can select entities that are connected to an entity you select or to a region you define. You can define the region by drawing a rectangular window or a polygon. Use a crossing window or polygon if you want to include entities that cross the region boundary or are connected to such entities. You can also draw a connected polyline or fence to select entities that touch the fence and all entities connected to these entities. For further information, including illustrated examples of connected object selection, see the following Glossary links: connected crossing polygon, connected crossing window, connected entity on page 387, connected fence on page 387, connected window on page 388, connected window polygon.

**Grip Behavior**

A REM enhanced bitonal region object has four grips, one at each vertex. Select a grip to move the object.
To define a REM enhanced bitonal region

1. From the Menu Browser, click Raster menu ➤ Raster Entity Manipulation ➤ Create Enhanced Bitonal Region. Then click the selection method. For more information on the methods, see Smart Objects on page 179 and Connected Objects on page 179.

2. Select one or more points to define the set of entities in the region.

Quick Reference

Menu

From the Menu Browser, click Raster ➤ Raster Entity Manipulation ➤ Create Enhanced Bitonal Region. (Then click Smart Window or other selection method.)

Object Shortcut Menu

Right-click image ➤ REM ➤ Create. (Then click Smart Window or other selection method.)

Command Line

isebrsmart (for smart object)
isebrcron (for connected object)
then one of the following selection methods:
w (for window)
c (for crossing window)
wp (for window polygon)
cp (for crossing polygon)
f (for fence)
e (for connected entities, used only with isebrcron)

Defining REM Primitive Objects

You can define a REM primitive object (line, arc, or circle) whenever you need to edit or move a raster entity.

For example, you may need to move a lot line in a parcel map. You can select the lot line as a primitive object, and use the AutoCAD MOVE command to move the line to a new location.
See also:

- Resizing a REM Object on page 191
- Editing REM Objects on page 189
- Merging REM Objects into an Image on page 200
- Converting REM Objects to a New Raster Image on page 201

NOTE Using an AutoCAD command such as MOVE causes the primitive object to be different from the original image. Raster Design erases the original raster data from the source image. For more information, see How REM Objects Are Associated with an Image on page 168.

You can define three primitive objects: lines, arcs, and circles. You can also use two other methods:

- The Smart Pick command automatically detects the geometry of the selected raster entity and defines the entity as a primitive line, arc, or circle.
- Define a primitive object using the geometry of an existing vector line, arc, or circle.

If your REM primitive is defined over an intersection, the intersection is preserved even after you move the primitive object.

Click here to see an illustration of a lot line (shown in red) defined as a REM primitive line.

NOTE You cannot remove subsections of a primitive object.

Grip behavior depends on the primitive object you define:

- A line has three grips: one at the start, one at the end, and one in the center of the line. Grip editing a REM line is the same as editing an AutoCAD
line. If you stretch an end grip point, Raster Design redraws the line with the new endpoint, respecting the original width. If the line is redrawn, Raster Design uses the current linetype. If you move the center grip, the entire object moves.

- A circle has five grips: one at the center of the circle and four on the circumference. Grip editing a REM circle is the same as editing an AutoCAD circle. If you move the center grip, the entire circle moves. If you move one of the grips on the circumference, the radius changes. If you change the radius of the circle, Raster Design redraws the circle using the current linetype but preserving the original width.

- An arc has three grips: at the start, end, and midpoint of the arc. Grip editing a REM arc is the same as editing an AutoCAD arc. If you stretch a grip point, the arc is redrawn with its new start, end, and radius, respecting the original width. If the arc is redrawn, Raster Design uses the current linetype.

### Defining a REM Line Primitive

You can define a line primitive when you need to edit or move a raster line entity.

You can use raster snaps to select the raster line. For more information, see Raster Snapping on page 239.

See also:

- Resizing a REM Object on page 191
- Editing REM Objects on page 189
- Merging REM Objects into an Image on page 200
- Converting REM Objects to a New Raster Image on page 201
Click here to see an illustration of selecting a raster line (shown in red).

![Illustration of selecting a raster line](image)

To define a REM line primitive

1. Click Raster menu ➤ Raster Entity Manipulation ➤ Create Primitive ➤ Line.
2. Select the raster line using one of the following methods:
   - Select a single point on the line.
   - Type 2p, and select the start and end points of the raster line.

Quick Reference

Menu

Raster ➤ Raster Entity Manipulation ➤ Create Primitive ➤ Line

REM Toolbar

Object Shortcut Menu

Right-click image ➤ REM ➤ Create ➤ Line

Command Line

isline

Defining a REM Circle Primitive

You can define a circle primitive when you need to edit or move a raster circle entity.
You can use raster snaps to select the raster circle. For more information, see Raster Snappping on page 239.

See also:

■ Resizing a REM Object on page 191
■ Editing REM Objects on page 189
■ Merging REM Objects into an Image on page 200
■ Converting REM Objects to a New Raster Image on page 201

Click here to see an illustration of selecting a raster circle (shown in red).

To define a REM circle primitive

1  Click Raster menu ➤ Raster Entity Manipulation ➤ Create Primitive ➤ Circle.

2  Define the raster circle using one of the following methods:
   ■  Select a single point on the circle.
   ■  Type c and select a center point.
   ■  Type 2p and select two points to define the diameter.
   ■  Type 3p and select three points on the circumference.

Quick Reference

Menu

Raster ➤ Raster Entity Manipulation ➤ Create Primitive ➤ Circle
Defining a REM Arc Primitive

You can define an arc primitive when you need to edit or move a raster arc entity.

You can use raster snaps to select the raster arc. For more information, see Raster Snapping on page 239.

See also:

- Resizing a REM Object on page 191
- Editing REM Objects on page 189
- Merging REM Objects into an Image on page 200
- Converting REM Objects to a New Raster Image on page 201

Click here to see an illustration of a selected raster arc (shown in red).
To define a REM arc primitive

1. Click Raster menu ➤ Raster Entity Manipulation ➤ Create Primitive ➤ Arc.

2. Select the raster arc using one of the following methods:
   - Select a single point on the arc.
   - Type c and then select the center point, the start point, and the end point. Instead of selecting the end point, you can also type a and specify the angle, or you can type l (lowercase L) and specify the chord length.
   - Type 3p and select the start point, a second point, and the end point of the arc.

Quick Reference

Menu

Raster ➤ Raster Entity Manipulation ➤ Create Primitive ➤ Arc

REM Toolbar

Object Shortcut Menu

Right-click image ➤ REM ➤ Create ➤ Arc

Command Line

isarc

Defining a REM Primitive Using Smart Pick

When you use Smart Pick to define a primitive object, Raster Design automatically detects the geometry of the selected raster entity and defines the entity as a primitive line, arc, or circle.

Results of using Smart Pick can be unpredictable where pixels do not clearly define raster entities. For example, Smart Pick may detect an arc instead of a full circle, or a line length may differ from what you expect.
You can use raster snaps to select the raster line, circle, or arc. For more information, see Raster Snapping on page 239.

See also:

■ Resizing a REM Object on page 191
■ Editing REM Objects on page 189
■ Merging REM Objects into an Image on page 200
■ Converting REM Objects to a New Raster Image on page 201

To define a primitive object using Smart Pick

1  Click Raster menu ➤ Raster Entity Manipulation ➤ Create Primitive ➤ Smart Pick.
2  Select the raster entity to be converted.

Quick Reference

Menu

Raster ➤ Raster Entity Manipulation ➤ Create Primitive ➤ Smart Pick

REM Toolbar

Defining a REM Primitive From Existing Vectors

You can define a primitive object using the geometry of an existing line, polyline, arc, or circle.

For example, if a vector line is drawn over a raster line and you want to move the raster line, you can use the vector line to define a primitive line object and then move the raster.
To define a REM primitive object from existing vectors

1. Click Raster menu ➤ Raster Entity Manipulation ➤ Create Primitive ➤ From Existing Vector.
2. Select the vector object.

Quick Reference

Menu
Raster ➤ Raster Entity Manipulation ➤ Create Primitive ➤ From Existing Vector

REM Toolbar

Object Shortcut Menu
Right-click image ➤ REM ➤ Create ➤ From Existing Vector

Command Line
iprimfromvec

Changing the Linetype of a Primitive Object

You can change the linetype of a primitive object using the Properties Window. For more information, see AutoCAD Properties on page 59.

If a raster entity has a dashed line or other non-continuous linetype when you define it as a primitive object, Raster Design changes the linetype to continuous if you edit the object, such as by stretching or smoothing it. You can then apply a linetype other than continuous to the object before merging it into the image.
For example, you want to extend a gas line, shown as a dashed line. You define the line as a REM primitive object and use grips to stretch the line to a new position. Raster Design redraws this line as a continuous line. You use AutoCAD Properties dialog box to reapply the original linetype to the line before merging it into the image.

To change the linetype of a primitive object

1. Select the primitive object.
2. Apply the linetype to the object.
   The raster line is redrawn using the new linetype.

Manipulating REM Objects

After you define a region object or primitive object, you can manipulate the REM objects to modify the raster data.

You work with REM objects much as you work with other AutoCAD objects, although REM objects have special characteristics.

See also:

- Defining REM Region Objects on page 170
- Defining REM Enhanced Bitonal Regions on page 178
- Defining REM Primitive Objects on page 180
- Characteristics of REM Objects on page 168

Editing REM Objects

After defining a region object or a primitive object, you can use a variety of commands to modify the raster data.

You can use the Merge To Raster command on a modified REM object to make it part of the raster image. For more information, see Merging REM Objects into an Image on page 200.

NOTE REM objects are not automatically saved with the drawing. You must either merge the REM objects back into the original raster image or create a new image from the REM objects.
The Edit Mode menu appears when you select one or more REM objects and right-click. This menu provides a mixture of AutoCAD commands and REM commands.

**AutoCAD Commands**

The following AutoCAD commands can operate on one or more REM objects:

- COPY
- COPYCLIP (copy to clipboard)
- ERASE
- MIRROR
- MODIFY
- MOVE
- ROTATE
- SCALE
- STRETCH
- UNDO

---

**NOTE** AutoCAD commands that cannot be used on REM objects are BLOCK, WBLOCK, TRIM, EXTEND, and EXPLODE.

When an AutoCAD command causes a REM object to become out of sync with the original image, Raster Design erases the corresponding raster data from the source image. For example, you can define a region object and then move it. After you move the region object, the raster data is deleted from the original image. If you want to delete a REM object immediately after defining it, use the AutoCAD ERASE command.

For detailed instructions on using AutoCAD commands, see AutoCAD online Help.

**REM Commands**

To access the full list of REM commands, from the Menu Browser, click Raster menu ➤ Raster Entity Manipulation. You can clear (delete) the REM objects, select all REM objects in the image, refine the selection that you used to create the entity, remove sub-components of the object, toggle background transparency or merge the object into a raster image.
If you have multiple REM objects selected, only those options that are valid for all of the objects are enabled. For example, if you select three REM objects and only two of them are in refine mode, the Refine Mode option is unavailable on the menu.

You can perform the following tasks from the edit mode menu:

- **Resizing a REM Object** on page 191
- **Removing Part of a Region Object** on page 177
- **Merging REM Objects into an Image** on page 200
- **Converting REM Objects to a New Raster Image** on page 201
- **Using REM Background Transparency** on page 202
- **Smoothing REM Linework** on page 196

**NOTE** These options are also available on the Raster Entity Manipulation Toolbar and the Raster Entity Manipulation submenu on the Raster menu.

---

**Resizing a REM Object**

Use REM Refine Mode to modify the geometry of a REM region or primitive object.

When a REM object is in Refine Mode, only the vector image of the object is displayed, which makes it easier to correct the geometry.

**NOTE** Enhanced bitonal region objects cannot be refined.

Some typical situations for using Refine Mode:

- After you define a region object, you realize that the boundary of the region needs some adjustment to include the right pixels.

- You define a primitive object and it does not end where you expected. For example, you selected a line, and the primitive crosses an intersection when you want it to end at the intersection.

**Grip Behavior**

Region objects and primitive objects have different grips to use for resizing.

---

Resizing a REM Object | 191
Region Objects

- REM polygonal, rectangular, and diagonal region objects have grips on each vertex and midpoint. You can reposition each vertex independently of the others. If you reposition a midpoint grip, the affected segment is broken into two segments. This operates like the Raster Design Image Mask object. All other grip operations, such as scale and stretch, use AutoCAD polyline grip behavior.

- A circular region object has five grips: one grip at the center of the circle and four on the circumference. REM circular region objects behave like AutoCAD circles. If you move the center grip, the entire circle moves. If you move one of the grips on the circumference, the radius changes.

Primitive Objects

- A line primitive has three grips: one at each endpoint, and one in the center. If you move the center grip, the entire object moves. Grip editing a REM line is the same as editing an AutoCAD line.

- A circle primitive has five grips: one grip at the center of the circle and four on the circumference. Grip editing a REM circle is the same as editing an AutoCAD circle. If you move the center grip, the entire circle moves. If you move one of the grips on the circumference, the radius changes.

- An arc primitive has three grips: one at each endpoint, and one at the midpoint of the arc. Grip editing a REM arc is the same as editing an AutoCAD arc.

To use REM refine mode

1. Select the region object or primitive object you want to refine.
2. Right-click and click Refine Mode.
3. Use the grips to modify the geometry of the object to include or exclude raster data.
4. Right-click and click Refine Mode to exit from refine mode.

   **NOTE** You can only switch to Refine Mode if the REM object is still associated with the image.
Quick Reference

Menu
Raster ➤ Raster Entity Manipulation ➤ Refine Mode
REM Toolbar

Object Shortcut Menu
Right-click REM object ➤ Refine Mode
Command Line
irefinemode

Using REM Operations

Use REM operations to trim or extend raster lines, to add offset lines, to add corner fillets, or to smooth raster linework.

The REM operation commands are designed to function like the related AutoCAD commands for vector lines. Where possible, the REM commands use the same options as the AutoCAD commands.

The underlying raster is rubbed by REM operations.

Trimming and Extending REM Lines

You can trim or extend raster lines so that they intersect other lines correctly.

Use either a REM line or a vector line to mark the boundary edge (intended length) of the modified line. After a trim or extend operation, the REM line is automatically smoothed.

You can trim or extend several lines within the same command by using a Shift-click option to switch between trim and extend operations.

To trim a REM line

1. Ensure that the boundary edge of the REM line is marked with an intersecting REM or vector line.
2. Click Raster menu ➤ Raster Entity Manipulation ➤ REM Operations ➤ Trim.
3. Click the boundary edge, then right-click.
4. Click anywhere on the part of the line that you want to remove.
The line is trimmed to the boundary edge.

To extend a REM line
1. Ensure that the boundary edge of the REM line is marked with an intersecting REM or vector line.
2. Click Raster menu ➜ Raster Entity Manipulation ➜ REM Operations ➜ Extend.
3. Click the boundary edge, then right-click.
4. Click anywhere on the line that you want to extend.
The line is extended to the boundary edge.

Quick Reference

Menu
- Raster ➜ Raster Entity Manipulation ➜ REM Operations ➜ Trim. (Or Extend)

REM Toolbar
- Trim
- Extend

Command Line
- trim, iextend

Filleting REM Lines
Create a fillet wherever you want two raster lines to meet at a rounded or square corner.
You can specify a radius for the corner arc by drawing a line or entering a numeric value. This radius is used as the default value for the next use of the fillet command in this editing session. If you specify no radius value, the two lines are extended to intersect.

If you want to leave a small gap between the fillet and one of the lines, set the Trim option to No Trim.

**To add a fillet between two REM lines**

1. Click Raster menu ➤ Raster Entity Manipulation ➤ REM Operations ➤ Fillet.
2. Optionally, to specify a radius, enter r, then enter a value.
3. Optionally, to check or change the trim option, enter t.
4. Click one of the REM lines, then click the other. The fillet is drawn between the two lines.
5. Click anywhere on the part of the line that you want to remove.

**Quick Reference**

**Menu**

Raster ➤ Raster Entity Manipulation ➤ REM Operations ➤ Fillet

**REM Toolbar**

**Command Line**

ifillet

**Offsetting REM Objects**

Create a new REM object that is offset a specified distance from an existing REM line, circle, or arc.

Offsets are especially useful for creating accurate parallel lines and concentric circles. When you offset a line, the new line is the same length as the original.
You can specify the offset distance by clicking a through point, drawing a line segment, or entering a numeric offset value. This offset distance is used as the default value for the next use of the offset command in this editing session.

To create an offset from a REM object

1. Click Raster menu ➤ Raster Entity Manipulation ➤ REM Operations ➤ Offset.
2. Specify the offset distance by entering a number, drawing a line, or entering t then picking a through point.
3. Click the REM object to offset.
4. Optionally, click the side of the object where you want the offset, or click the through point.
   The offset object is drawn.

Quick Reference

Menu
   Raster ➤ Raster Entity Manipulation ➤ REM Operations ➤ Offset
REM Toolbar

Command Line
   ioffset

Smoothing REM Linework

Runs a series of thinning and thickening filters on the raster linework of one or more REM objects.

**NOTE** If you are editing REM lines by trimming, extending, or other operations, you should finish all such editing before smoothing. After smoothing, you can get unpredictable results with other editing operations.

The Smooth operation applies only to the REM objects you select. By contrast, the smoothing filter available in the bitonal filters applies to the entire image. For more information, see Using Bitonal Filters on page 114.
If you made the object's linetype dashed, Raster Design redraws a dashed line after you execute the Smooth command. If an object's linetype has not been set, the object is redrawn as continuous.

If you are working with a REM primitive, Raster Design completely redraws the raster primitive. The linetype setting is maintained.

**To smooth the linework of REM objects**

1. Click Raster ➤ Raster Entity Manipulation ➤ REM Operations ➤ Smooth.
2. Select the REM objects and press Enter.

**Quick Reference**

**Menu**

Raster ➤ Raster Entity Manipulation ➤ REM Operations ➤ Smooth

**REM Toolbar**

Command Line

ismooth

**Defining REM Objects Partially Outside the Image**

Define a REM region object to be partly outside the image.

For example, if you want to select a semi-circular raster object along the outside edge of the image, you can create a circular region object with only half of the circle touching the image. Raster Design ignores any part of the REM object that does not contain raster data. Only the true extents of the raster data defined by the region are merged into the image.

**NOTE** Enhanced bitonal regions and primitives automatically clip themselves against the raster image.

**Using REM to Delete Raster Data**

You can use REM objects to delete raster data from your image.
First, transform the raster data to REM objects, using one of three methods:

- Convert individual line, arc, and circle entities to REM primitives. For more information, see Defining REM Primitive Objects on page 180.

- If the raster data can be defined with a rectangle, circle, or polygon, create a REM region. For more information, see Defining REM Region Objects on page 170.

- If you want to remove a set of raster entities (lines, circles, arcs, or polygons) in an area, or entities that are connected to each other, create a REM enhanced bitonal region. For more information, see Defining REM Enhanced Bitonal Regions on page 178.

Then delete the REM objects.

If you have selected a primitive object or an enhanced bitonal region object, the object is removed and Raster Design cleans up the intersection.

In the following illustration, the left panel displays a REM primitive line in red. The illustration on the right shows how the image appears after the primitive line is deleted. The integrity of the circles and vertical line are preserved.

You can also use REM delete commands to delete raster primitives. For more information, see Removing Raster Entities Using REM Commands on page 159.

To use REM objects to delete raster data

1. Define the raster data you want to delete as a REM region, an enhanced bitonal region, or a primitive object.

2. To delete a REM object immediately after defining it, select the object and use the AutoCAD ERASE command.
Clearing REM Objects

Clearing a REM object has one of two effects, depending on whether the object is associated with an image:

- If the REM object is associated with an image, clearing the object merges the raster data defined by the object into the image.
- If the REM object is not associated with an image, clearing the object deletes the object.

For example, you can define a region object and copy it to another area of the image. Then if you clear all objects, the original object (still associated with the image) merges into the image, but the copy (not associated with the image) is deleted.

You cannot do non-REM raster editing operations such as Touchup while REM objects remain in the image. The clear commands are useful for removing such objects after a REM editing session.

To clear REM objects

- Click Raster menu ➤ Raster Entity Manipulation ➤ Clear Selected. Select the REM objects, and press Enter. or
- Click Raster menu ➤ Raster Entity Manipulation ➤ Clear All.

Quick Reference

Menu

Raster ➤ Raster Entity Manipulation ➤ Clear Selected (or Clear All)

REM Toolbar

- Clear Selected
- Clear All

Object Shortcut Menu

Select REM objects, then right-click ➤ Clear

Command Line

iclear (selected objects)
Merging REM Objects into an Image

You can use the Merge to Raster Image command to merge REM objects into the source image or into another image.

This command merges all selected REM objects into the image under them. If your REM objects are not over an image, a merge operation is not possible. If your REM objects are partly touching the image, the image expands to accommodate them. If your REM objects are below the image, the objects merge into the image above. Unlike vector merge, display order is not respected.

If the selected REM objects are over multiple images or span adjacent images, a dialog box prompts you to choose an image.

If you defined a REM object but did not modify the object, clear the object to merge it into the source image. If you want to create a new image from the REM object, use the Convert to Raster Image command.

See also:
- Clearing REM Objects on page 199
- Converting REM Objects to a New Raster Image on page 201

To merge REM objects into an image

1. Select the REM objects you want to merge into the image.
2. Click Raster menu ➤ Raster Entity Manipulation ➤ Merge to Raster Image.

Quick Reference

Menu

Raster ➤ Raster Entity Manipulation ➤ Merge to Raster Image

REM Toolbar

Reload all (all objects)
Object Shortcut Menu

Select REM objects, then right-click ➤ Merge to Raster Image

Command Line

imergetoimg

Converting REM Objects to a New Raster Image

You can convert one or more REM objects to a new raster image.

If you select more than one REM object, Raster Design merges all REM objects into one new image.

If the raster image was created from a REM polygonal or diagonal region, the image is clipped to match the geometry of the REM object. Raster data that falls outside the clip, but within the boundary of the image, is set to the transparent color.

Converting REM objects to a new image has one of two effects on the original image:

■ If a REM object is associated with the original image, the raster data defined by the object remains in the original image.

■ If a REM object is not associated with the original image, the raster data defined by the object is cleared from the original image.

If you select REM objects from images with different properties (for example, images with different color depths and densities) and convert the objects to a new image, the properties of the new image are determined by the first REM object you select.

To convert REM objects to new raster image

1 Select the REM objects you want to convert to a new image.

2 Click Raster menu ➤ Raster Entity Manipulation ➤ Convert to Raster Image.

Quick Reference

Menu

Raster ➤ Raster Entity Manipulation ➤ Convert to Raster Image
Using REM Background Transparency

REM objects respect the background transparency settings of the source image, including state and color.

You can change the background transparency of a region object or an enhanced bitonal region object. REM primitive objects are always transparent.

To turn the background transparency of a REM object off or on

1. Select the REM objects whose background transparency you want to change.
2. Click Raster menu ➤ Raster Entity Manipulation ➤ Background Transparency.

Quick Reference

Menu
- Raster ➤ Raster Entity Manipulation ➤ Background Transparency

Using REM Copy To Clipboard Command

Use this command to copy REM objects to the Windows Clipboard. You can then use the objects in an external application.
The Copy to Clipboard command has two options for data capture:

- Native Capture copies all the data of the REM object at its full resolution.
- Display Capture copies the data of the REM object at screen resolution.

You can specify the option for data capture on the REM tab on page 359 of the Raster Design Options dialog box.

If you select REM objects from images with different properties (for example, images with different color depths and densities) and convert the objects to a new image, the properties of the new image are determined by the first REM object you select.

**NOTE** You can also use Ctrl+C to run COPYCLIP. If the cursor is in the drawing area, Raster Design copies the selected objects to the Clipboard. If the cursor is on the command line or in the text window, Raster Design copies the selected text to the Clipboard.

**To copy REM objects to the clipboard**

1. Select the REM objects you want to copy to the Clipboard.
2. Click Raster menu ➤ Raster Entity Manipulation ➤ Copy to Clipboard.

**Quick Reference**

Menu

- Raster ➤ Raster Entity Manipulation ➤ Copy to Clipboard

REM Toolbar

![Image](image.png)

Command Line

icopyss

**Separating Raster Linework Using Knife**

Use the Knife command to separate raster linework by drawing a line that is one pixel wide through raster data.
Knife is useful for precisely separating raster entities in detailed areas of an image. For example, you can use Knife to separate a raster title block from a raster border so you can work with the title block and border as separate raster entities.

To separate raster linework using Knife

1. Click Raster ➤ Raster Entity Manipulation ➤ Knife.
2. Select the start and end points for the knife cut.
3. Continue selecting start and end points through each raster line you want to cut.
4. Press Enter to end the command.

Quick Reference

Menu
- Raster ➤ Raster Entity Manipulation ➤ Knife

REM Toolbar

Command Line
- iknife
Converting Raster Entities to Vector

Vectorization tools (VTools) can convert geometry and text in a bitonal raster image. With vectorization tools, you can:

- Use a one-pick method to accurately trace raster entities you select.
- Use a follower method to trace complex geometry, such as contours.
- Verify and adjust a vector entity's dimensions as it is drawn to make it more precise.
- Remove a raster entity automatically as you trace it.

In many cases, a vectorization command can convert a raster entity to vector with a single click. You can also define the raster entity by clicking two or more points on the image. Once a vectorization command is initiated, you can continue to vectorize additional raster entities using either selection method.

There are seven primary vectorization tools for converting raster entities to corresponding AutoCAD objects:

- Line tool
- Polyline tool
- Rectangle tool
- Circle tool
- Arc tool
- Text tool and Multiline Text tool

Follower VTools provide a semi-automatic method of tracing the raster polylines you want to vectorize. For example, the contour follower tool traces a selected contour line until it meets a decision point such as an endpoint or a contour label. At each decision point, you
can provide more information, change course, go back up to a previous vertex, or stop the follower.

Vector separation options can help you to manage new vectors by automatically assigning line weights (widths) or drawing layers based on vector attributes. For more information, see the Vector Separation Options on page 376 dialog box.

**NOTE** To make the most efficient use of vectorization tools, adjust the vectorization tools settings in the Raster Design Options dialog box. These settings are located on three tabs: VT00ls General, VT00ls Follower, and Raster Entity Detection.

Text recognition tools in Raster Design can automatically read raster text in an image, present it to you for correction, and convert it to a line or block of AutoCAD vector text.

## Configuring VTools

Use these settings to work most efficiently with vectorization tools.

VT00ls are controlled by a number of settings in the Raster Design Options dialog box. In addition, you can choose whether to use AutoCAD Dynamic Input prompts as you vectorize raster entities.

## Raster Design Options

The Raster Design Options dialog box includes three tabs with settings that affect vectorization:

- **Raster Entity Detection** on page 359 tab specifies how the VTools detect raster across gaps and in the vicinity of the cursor.

- **VT00ls General** on page 364 tab specifies general vectorization behavior, such as the removal of raster, line separation, and the rounding scheme for numeric values.

- **VT00ls Follower** on page 362 tab specifies the behavior of the tools for following contours and polylines.

## Dynamic Input Settings

If you enable AutoCAD Dynamic Input, you see on-screen prompts near your cursor as you vectorize. Vectorized lines, arcs, and figures also have grips that
you can use to edit the line work. This feature is particularly useful for providing numeric values for coordinates, line length, and angle. When Dynamic Input is disabled, the prompts appear only on the command line.

To configure the pointer input and the dimension input, use the AutoCAD command DSETTINGS to open the Drafting Settings dialog box.

To turn Dynamic Input on and off, use the AutoCAD system variable DYNMODE, which has four settings:

- 0 to turn off all Dynamic Input features
- 1 to turn on pointer input
- 2 to turn on dimensional input
- 3 to turn on both pointer and dimensional input

See AutoCAD Help for more information on Dynamic Input.

**Using SmartCorrect**

This one-pick selection method for Line and Polyline tools vectorizes a raster line with a single click.

Raster Design automatically corrects the resulting line to conform to current drafting settings. The following sequence of decisions applies:

- If AutoCAD SNAP is active, the start point and the endpoint are snapped to the grid. No other correction is performed.
- If AutoCAD SNAP is inactive but OSNAP is active, Raster Design adjusts points that are within the tolerance defined in the Correction Tolerance section on the VTools General tab of the Raster Design Options dialog box. If both ends of the line are osnapped, no further correction is performed.
If OSNAP is inactive, or at least one point was not osnapped, Raster Design determines if POLAR or ORTHO snap is active. If so, Raster Design aligns the line by moving the endpoint. If one point was snapped earlier, then the free end is automatically considered the endpoint. Raster Design adjusts the angle about the start point without changing the length. The angle snap occurs only if the new endpoint falls within the tolerance distance.

If Round Values is enabled, the line length is rounded to the precision specified on the VTools General tab of the Raster Design Options dialog box.

For more information about adjusting SmartCorrect settings, see General VTool Settings on page 252.

Vectorizing Raster Geometry

Raster Design provides separate vectorization tools to convert raster lines, polylines, rectangles, circles, and arcs.

Depending on which raster line type you select, Raster Design creates an AutoCAD line or polyline entity with the same position and dimensions as the raster original. Once Raster Design has vectorized a line segment, you can verify its geometry (including angle and length), switch the start point and endpoint, and trim or extend the line.

Settings on the VTools General tab of the Raster Design Options dialog box specify whether the Line tool removes the underlying raster when you exit the command, forces the vector lines to conform to current drafting settings, or assigns layers to the vectors based on the width of the underlying raster lines.

If Dynamic Input is active, prompts appear near the cursor during vectorization; otherwise, the prompts appear only on the command line.

When you use the Line or Polyline tool, you can select the raster line for vectorizing using one of the following two selection methods.

One Pick

This default method vectorizes a bitonal raster line with a single click. The one-pick method is especially useful when you want to quickly vectorize many separate lines, which can include polylines, circles, and arcs. The endpoint nearest the point you select is considered the start point (an arrow glyph points away from the start-point). Depending on which AutoCAD drafting settings are active, SmartCorrect automatically corrects the resulting line to
conform to current drafting settings. For more information, see Using SmartCorrect on page 207.

**Multi-pick**

This method vectorizes a raster line that you define by clicking two or more points. The multi-pick method provides you with more control over the vectorizing process. It is useful for creating vector polylines, rectangles, circles, and arcs.

After you select a raster line to vectorize, the AutoCAD command line displays several editing options that vary according to the line type. In general, you can select another entity to vectorize using the one-pick method, or you can edit the vector line by entering numeric attributes or picking additional points.

**NOTE** To make the most efficient use of vectorization tools, you should adjust the settings on the VTools General on page 364 tab on the Raster Design Options dialog box.

---

**Vectorizing Raster Lines and Polylines**

The Polyline tool converts raster lines to vector lines or polylines.

Raster Design creates an AutoCAD entity with the same position and dimensions as a raster line you select. Once Raster Design has vectorized a line, you can verify its geometry (including angle and length), switch the start point and endpoint, and trim or extend the line. Depending on the settings you specified on the VTools General on page 364 tab of the Raster Design Options dialog box, the Polyline tool can remove the underlying raster when you exit the command, force the vector polylines to conform to current drafting settings, or assign layers to the vectors based on the width of the underlying raster lines.

When you use the Polyline tool, you can select the raster line for vectorizing using one of two selection methods:

- The default, or one-pick method, vectorizes a bitonal raster line with a single click. The endpoint nearest the point you select is considered the start point (an arrow glyph points away from the start-point). Depending on which AutoCAD drafting settings are active, SmartCorrect automatically corrects the resulting polyline to conform to current drafting settings.

- The multi-pick method vectorizes any raster line that you define by clicking a start point and an endpoint. After you select the first start point, you are
prompted to enter subsequent endpoints to create a single polyline with multiple segments.

After you select a raster line to vectorize, the AutoCAD command line displays a number of choices. You can select another entity to vectorize using the one-pick method, or you can use any of the following options on the vector line segment you just created:

- 2P, to select another entity using the multi-pick method.
- Angle, to adjust the angle. You can enter an angular value, or match the angle of another vector line.
- Length, to adjust the length. You can enter a length value, or match the length of another vector line.
- Undo, to remove the line.

If you used the one-pick method to select the raster line, the following options are available to modify the vector line segment you just created:

- Start, to change the start point.
- End, to change the endpoint.
- Switch, to reverse the direction, moving the start point to the other end.
- Trim, to shorten the line by clicking an intersecting vector entity to trim to, or by clicking another entity that, if extended, would intersect the line you are trimming. Raster Design moves the endpoint to the apparent intersection.
- Extend, to lengthen the line by clicking an intersecting vector entity to extend to, or by clicking another entity that, if extended, would intersect the raster line you are extending. Raster Design moves the endpoint to the apparent intersection.

**NOTE** To make the most efficient use of vectorization tools, you should adjust the settings on the VTools General on page 364 tab on the Raster Design Options dialog box.

**TIP** Use raster snapping to make picking points on the raster entity you are converting easier. For more information, see Raster Snapping on page 239.
To convert a raster line to a vector line or polyline

1  For straight lines, click Raster menu ➤ Vectorization Tools ➤ Line. Or for polylines, click Raster menu ➤ Vectorization Tools ➤ Polyline.. The following prompt appears:

Specify one-pick point or [2P]:

**NOTE** When you use the one-pick method to select the raster entity, Raster Design corrects the point you picked according to the current drafting settings or rounding values. For more information, see Using SmartCorrect on page 207.

2  Do one of the following:
   ▪ Select a raster line by clicking near the beginning of the line. The endpoint nearest the point you select is considered the start point.
   ▪ Enter 2p, then enter two points to define the raster line you are vectorizing.

3  **NOTE** You can cancel the selection of a point by typing undo after you pick the point.

4  Select another raster line using the one-pick method, or do one of the following:
   ▪ Enter 2p to select another raster line to vectorize using the multi-pick selection method.
   ▪ Enter a (Angle) to verify the angle of the vector line segment you just created. See Options for Verifying an Angle on page 212.
   ▪ Enter l (Length) to verify the length of the vector line segment you just created. See Options for Verifying a Length on page 212.
   ▪ Enter u (Undo) to remove the last vector line segment you created.

If you used the one-pick method to select the raster line, the following options are available:
   ▪ Enter st (Start) to verify the start point of the vector line segment you just created. A rubber-band line appears from the current endpoint. Click to select a new start point.
Enter e (End) to verify the endpoint of the vector line segment you just created. A rubber-band line appears from the current start point. Click to select a new endpoint.

Enter sw (Switch) to make the current endpoint the start point, and the current start point the endpoint.

Enter t (Trim) to trim (shorten) the vector line segment you just created by clicking an intersecting vector entity. See Options for Trimming or Extending a Line on page 213.

Enter x (Extend) to lengthen the vector line segment you just created by clicking an intersecting vector entity. See Options for Trimming or Extending a Line on page 213.

5 Repeat step 3, or press Enter to exit the command.

Options for Verifying an Angle

When you select the Angle option of the Line tool, the following prompt is displayed:

Enter new angle or [Match]<“XdX‘X”>

NOTE Raster Design adjusts the angle about the start point.

Do one of the following:

■ To change the angle, enter a new angle.

■ To match the angle of an existing vector, enter m, then select the vector line.

■ To use an angle from the Most Recently Used or Most Frequently Used list (depending on your settings in the Raster Design Options dialog box), right-click, then click a value on the shortcut menu.

Options for Verifying a Length

When you select the Length option of the Line tool, the following prompt is displayed:

Enter new length or [Match]<XXX>:

Do one of the following:

■ To change the length, enter a new length.
■ To match the length of an existing vector line, enter m, then select the vector line.

■ To use a length from the Most Recently Used or Most Frequently Used list (depending on your settings in the Raster Design Options dialog box), right-click, then click a value on the shortcut menu.

**Options for Trimming or Extending a Line**

When you select the Trim option, the following prompt is displayed:

Select cutting edge or [Apparent]:

When you select the Extend option, the following prompt is displayed:

Select boundary edge or [Apparent]:

**NOTE** Raster Design trims or extends the line by moving the endpoint.

To either trim or extend the line, do one of the following:

■ To connect the current vector line to an intersecting vector entity, select the intersecting entity.

■ To end the current vector line at an apparent intersection with another vector entity, enter a (Apparent) and select YES, then select the other vector entity.

**Quick Reference**

**Menu**

Raster ➤ Vectorization Tools ➤ Line
Raster ➤ Vectorization Tools ➤ Polyline.

**Raster Design Toolbar**

- Vectorize Line
- Vectorize Polyline

**Command Line**

vline
vpline
Vectorizing Raster Rectangles

You can convert a raster rectangle to a vector rectangle by using the Rectangle tool.

**NOTE** To make the most efficient use of the Rectangle tool, you should first adjust the settings on the VTools General tab on the Raster Design Options dialog box. For more information, see VTools General tab on page 364.

To convert a raster rectangle to a vector rectangle

1. Click Raster menu ➤ Vectorization Tools ➤ Rectangle.
2. Click the first corner of the raster rectangle.

**NOTE** You can cancel the selection of a point by typing u (Undo) after you pick the point.

3. Select a point to define the angle of the rectangle, or press Enter to accept 0 (zero) as the angle.

The cursor now controls the size of the vector rectangle.

4. Expand the rectangle to the desired size, then click the location of the corner opposite the first corner.

5. Do one of the following

   - Press Enter or right-click to draw the rectangle with the current height, width, and angle.
   - Enter v (Verify) to see the rectangle’s current size and orientation angle. If you want to change one of these values, enter h (Height), w (Width), or a (Angle) and enter a numeric value or pick a point to define the new value.

**TIP** Use raster snapping to make it easier to pick points on the raster entity you are converting. For more information, see Specifying Raster Snap Settings on page 239.
Vectorizing Raster Circles

The Circle tool converts raster circles to vector circles. Select a raster circle and Raster Design creates vector that matches its geometry.

Depending on the settings you have specified on VTools General tab on the Raster Design Options dialog box, the Circle tool can even remove the underlying raster circle when you exit the command. For more information, see VTools General Tab (Raster Design Options Dialog Box) on page 364.

There are four methods of defining raster circles:

- One-pick method detects a bitonal raster circle with a single click.
- Center multi-pick method converts any type of raster circle by selecting the center point and any point on the circumference of the circle.
- 2P multi-pick method converts a raster circle by selecting two points to define the diameter of the circle.
- 3P multi-pick method converts a raster circle by selecting three points on the circle.

Once Raster Design has vectorized a circle, you can:

- Vectorize another circle using any of the four selection methods discussed above.
- Verify or edit the center, radius, or diameter of the circle. You can specify new values by numeric entry or by clicking another circle in the drawing that has an attribute you want to match. This matching operation is
particularly useful when you are vectorizing several circles of identical diameter, or a set of concentric circles.

To convert a raster circle to vector

1  Click Raster menu ➤ Vectorization Tools ➤ Circle.
   The following prompt is displayed:
   Specify one-pick point or [Center/2P/3P]:

2  Do one of the following:
   ■ Select a raster circle using the one-pick selection method.
   ■ Enter c (Center), then select the center point and a point along the circumference of the circle.
   ■ Enter 2p, then select two points to define the diameter of the raster circle.
   ■ Enter 3p, then select three points along the circumference to define the circle.
   The following prompt is displayed:
   Specify one-pick point or [Center/2P/3P/Verify center/Radius/Diameter/Undo]:

3  Do one of the following:
   ■ Select another circle to vectorize, using one of the methods described in step 2.
   ■ Enter v (Verify center) to verify the center. Select a new location for the center point, or type m and select another vector circle to match the center point.
   ■ Enter r (Radius) to verify the radius. Select a new radius, type a new radius at the command line, or type m and select another vector circle to match the radius. Depending on the setting you selected in the Raster Design Options dialog box, you can right click to select a radius from a Most Recently Used list or a Most Frequently Used list.
   ■ Enter d (Diameter) to verify the diameter. Select a new diameter, enter a new diameter at the command line, or enter m and select another vector circle to match the diameter. Depending on the setting you selected in the Raster Design Options dialog box, you can right-click to select a diameter from a Most Recently Used list or a Most Frequently Used list.
Enter u (Undo) to undo the last circle selected.

Press Enter to exit the command.

**TIP** Use raster snapping to make it easier to pick points on the raster entity you are converting. For more information, see **Specifying Raster Snap Settings** on page 239.

### Quick Reference

**Menu**

- Raster ➤ Vectorization Tools ➤ Circle

**Raster Design Toolbar**

- Command Line
  - vcircle

### Vectorizing Raster Arcs

The Arc tool converts raster arcs to vector arcs. Select a raster arc and Raster Design creates vector that matches its geometry.

Depending on the settings you have specified on the **VTools General** on page 364 tab on the Raster Design Options dialog box, the Arc tool can even remove the underlying raster when you exit the command.

There are three methods of defining raster arcs:

- One-pick method detects a bitonal raster arc with a single click.
- Center multi-pick method converts any type of raster arc by selecting a center point, a start point, and an end point.
- 3P multi-pick method converts a raster arc by selecting three points along the arc.
Once Raster Design has vectorized an arc, you can:

- Vectorize another arc using any of the three selection methods discussed above.
- Verify the center or radius of the arc. You can specify new values by numeric entry or by clicking another arc in the drawing that has an attribute you want to match. This matching operation is particularly useful when you are vectorizing several arcs of identical diameter, or a set of concentric arcs.

To convert a raster arc to vector

1. Click Raster menu ➤ Vectorization Tools ➤ Arc.
The following prompt is displayed:
Specify one-pick point or [Center/3P]:

2. Do one of the following:
   - Select a raster arc using the one-pick selection method.
     - Enter c (Center), then select a center point, a start point, and an end point to define the arc.
     - Enter 3p, then select three points along the radius to define the arc.
     The following prompt is displayed:
       Specify one-pick point or [Center/3P/Verify center/Radius/Undo]:

3. Do one of the following:
   - Select another arc to vectorize, using one of the methods described in step 2.
   - Enter v (Verify center) to verify the center point. Select a new location for the center point, or type m and select another vector arc to match the center point.
   - Enter r (Radius) to verify the radius. Select a new radius, type a new radius at the command line, or type m and select another vector arc to match the radius. Depending on the setting you selected in the Raster Design Options dialog box, you can right-click to select a radius from a Most Recently Used list or a Most Frequently Used list.
   - Enter u (Undo) to undo the last arc selected.
Press Enter to exit the command.

**TIP** Use raster snapping to make it easier to pick points on the raster entity you are converting. For more information, see *Specifying Raster Snap Settings* on page 239.

---

**Quick Reference**

**Menu**

- Raster ➤ Vectorization Tools ➤ Arc

**Raster Design Toolbar**

**Command Line**

`varc`

---

**Following Polylines**

The polyline follower tools can trace bitonal raster polylines and convert them to AutoCAD polyline entities or contours.

Separate tools are available for vectorizing 2D polylines, contour lines, and 3D polylines.

Follower tools trace or follow the selected polyline, pausing for input at any decision point where the follower can no longer proceed on its own. Decision points occur when the follower meets confusing geometry or reaches the end of a raster line. You can also use settings in the Raster Design Options dialog box to instruct the follower to stop at raster intersections.

The follower traces the polyline in both directions from the point you clicked, and always presents you with two decision points at the same time. If the current decision point is not on screen, Raster Design automatically pans to it. At each decision point, you can take one of the following actions:

- Manually add points. This is useful, for instance, to cross the gaps in dimension lines created for labels.
- Switch to the other decision point.
- Backup to the last vertex.
- Rollback to a previous vertex that you select with the pointer.
- Specify a direction for the follower to take. This option is useful when the follower pauses at a “T” intersection.

**NOTE** When you use the Direction option, it becomes the default option until another option is used or until the polyline is completed.

- Continue in the direction that seems most apparent to the follower. This option is useful when the follower has simply paused at a raster intersection.
- Follow a vector entity. This option is useful for following portions of an image that have already been vectorized.
- Close the polyline by drawing a single segment between the two decision points.
- Join the current polyline to an existing vector polyline.
- Cancel the current polyline and begin again by pressing Esc.

**NOTE** To make the most efficient use of the Polyline Follower, you should adjust the settings on the VTools Follower on page 362 tab on the Raster Design Options dialog box.

**Vector Separation Options**

You can use these options to automatically manage layers, linetypes, and polyline widths for lines created by vectorization tools. Specify a range of line widths for the raster entity on the General tab of the Vector Separation Options on page 376 dialog box, then assign layer and polyline width values to these ranges. When a vectorization command is executed, Raster Design examines the raster line width and assigns the values you specified for that width to the newly created polylines. You can access the Vector Separation Options dialog box by clicking the Vector Separation button on the VTools General tab of the Raster Design Options dialog box. For more information, see General Vector Separation Options on page 251.

**See also:**

- Configuring VTools on page 206
Using the Polyline Follower

This tool traces raster polylines and converts them to AutoCAD polyline entities.

See also:
■ Following Polylines on page 219

To convert a raster polyline to a vector

1 Click Raster menu ➤ Vectorization Tools ➤ Polyline Follower.
The following prompt appears:
Specify point to follow or [manually Add/Partial]:

2 Do one of the following:
■ Enter a (Add) to manually add a point.
■ Enter p (Partial) to add a partial polyline. Click two points on the polyline to mark the start and end of the section you want to convert, then click the polyline. The follower traces between those points, and prompts you as shown below.
■ Click a raster polyline to follow.
The following prompt appears:
Manually add point or [Add/Switch/Backup/Rollback/Direction/Continue/Vector/Close/Join]:

NOTE When you use the Direction option, it becomes the default option until the Add option is used or until the command is completed.

3 Do one of the following:
■ Click to manually add a point to the polyline. If Add is not the default, enter a (Add), then click to manually add a point to the polyline.
■ Enter s (Switch) to switch between decision points.
■ Enter b (Backup) to go back to the previous vertex.
■ Enter r (Rollback), then click the vertex to which you want to roll back.
Enter d (Direction), then click the direction you want the follower
togo. You do not have to click on the entity, only near it, to specify
the direction.

Enter o (Continue) to make the follower continue in the current
direction.

Enter v (Vector), then select the vector to follow. You must specify
the first and last vertices of the vector. Raster Design follows the vector
entity between these vertices.

Enter c (Close) to close the polyline by drawing a single segment
between the two decision points.

Enter j (Join), then click an existing vector polyline to join to the
current polyline.

Press Esc to cancel the current polyline and begin another.

Press Enter to accept the current polyline and begin another.

4 Repeat step 3, or press Enter to exit the command.

NOTE Use raster snapping to make it easier to pick points on the raster entity you
are converting. For more information, see Raster Snapping on page 239.

Quick Reference

Menu

Raster ➤ Vectorization Tools ➤ Polyline Follower

Raster Design Toolbar

Command Line

vfpline

Using the Contour Follower

This tool traces raster contour lines and converts them to AutoCAD polyline
entities or to contour objects if you are using Autodesk Land Desktop.
For general information on the use of polyline followers and operational settings, see Following Polylines on page 219.

After completing a contour, Raster Design prompts you to enter an elevation, depending on the settings you have specified on the VTools Follower tab of the Raster Design Options dialog box. These settings also allow you to automatically increment the elevation value. For more information, see VTools Follower Settings on page 272.

The Contours tab of the Vector Separation Options dialog box allows you to assign layer and polyline widths to contours based on their elevation interval. For instance, you might set the elevation interval for major contours to 50, and the elevation interval for minor contours to 10. If you then followed a contour and set the elevation value to 50, the resulting vector contour would be assigned to the major layer. Likewise, if you traced a contour and set the elevation value to 40, the resulting vector would be assigned to the minor layer. For more information, see General Vector Separation Options on page 251.

To convert a raster contour to a vector

1. Click Raster menu ➤ Vectorization Tools ➤ Contour Follower.

   The following prompt appears:
   
   Specify point to follow or [manually Add/Partial]:

2. Do one of the following:

   ■ Enter a (Add) to manually add a point.

   ■ Enter p (Partial) to add a partial contour. Click two points on the contour to mark the start and end of the section you want to convert, then click the contour. The follower traces between those points, and prompts you as shown below.

   ■ Click a raster contour to follow.

   The following prompt appears:
   
   Manually add point or [Add/Switch/Backup/Rollback/Direction/cOntinue/Vector/Close/Join]:

   **NOTE** When you use the Direction option, it becomes the default option until the Add option is used or until the command is completed.

3. Do one of the following:

   ■ Click to manually add a point to the contour. If Add is not the default, enter a, then click to manually add a point to the contour.
■ Enter s (Switch) to switch between decision points.

■ Enter b (Backup) to back up to the previous vertex.

■ Enter r (Rollback), then click the vertex to which you want to roll back.

■ Enter d (Direction), then click the direction you want the follower to proceed in. You do not have to click on the entity, only near it, to specify the direction.

■ Enter o (Continue) to make the follower continue in the current direction.

■ Enter v (Vector), then select the vector to follow. You must specify the first and last vertices of the vector. Raster Design follows the vector entity between those vertices.

■ Enter c (Close) to close the contour by drawing a single segment between the two decision points.

■ Enter j (Join), then click an existing vector polyline or contour to join to the current polyline.

■ Press Esc to cancel the current contour and begin another.

■ Press Enter to accept the current contour and begin another.

The following prompt appears:
Specify elevation for contour <X.XX>:

4 If the contour follower is set to prompt for elevation, do one of the following:
■ Enter a new elevation.
■ Press Enter to accept the current value.

NOTE You can control the amount Raster Design increments/decrements the suggested elevation for the contour follower by adjusting the Interval settings on the VTools Follower tab of the Raster Design Options dialog box. For more information, see VTools Follower Settings on page 272.

5 Repeat steps 3 and 4, or press Enter to exit the command.

NOTE Use raster snapping to make it easier to pick points on the raster entity you are converting. For more information, see Raster Snapping on page 239.
Quick Reference

Menu

Raster ➤ Vectorization Tools ➤ Contour Follower

Raster Design Toolbar

Command Line

vfcontour

Using the 3D Polyline Follower

This tool interacts with raster entities and existing vectors to create AutoCAD 3D polylines.

When using the 3D Polyline Follower, you can either draw a polyline fence that intersects raster contours, or you can select an existing polyline. Raster Design then follows the polyline, pausing at each intersection to prompt for elevation. At each such raster impact point on page 397, the follower automatically inserts a vertex and prompts you to enter elevation data. You can reference the elevation of existing vectors by using OSNAP to place the polyline vertices on these vectors. When the follower pauses at a vertex, Raster Design uses the elevation values of the intersecting vector entity as the default value when it prompts for elevation.

At each vertex, you can take one of the following actions:

■ Enter an elevation.
■ Press Enter to accept the current elevation value.
■ Interpolate the value based on the previous and next elevation.
■ Use the elevation value of an existing vector that you specify.
■ Undo the last elevation entered.
■ Skip the current raster impact point.
■ Insert another vertex, then enter an elevation value for it.
■ Move the current vertex.
NOTE To make the most efficient use of the 3D Polyline Follower, you should first adjust the settings on the VTools Follower on page 362 tab on the Raster Design Options dialog box.

To create a 3D Polyline

1 Click Raster menu ➤ Vectorization Tools ➤ 3D Polyline Follower. The following prompt appears: Specify first fence point or [follow Vector]:

2 Do one of the following:
   ■ Click several points to define a polyline fence that intersects several contours.
   ■ Enter v (Follow Vector) and press enter, then select an existing vector polyline for the follower to use.

   TIP If you have already vectorized a contour, use OSNAP to snap a polyline vertex to that contour. Raster Design uses its elevation as the default when the follower pauses at that vertex.

   The following prompt appears: Specify elevation, press Enter to accept or [Interpolate/Existing/Undo/Skip/iNsert/Move]:

3 Do one of the following:
   ■ Enter an elevation, then press Enter.
   ■ Press Enter to accept the current elevation value.
   ■ Enter i (Interpolate) to interpolate the value based on the previous elevation and the next elevation.
   ■ Enter e (Existing), then click a vector entity from which to copy the elevation.
   ■ Enter u (Undo) to undo the last elevation entered.
   ■ Enter s (Skip) to skip the current raster impact point.
   ■ Enter n (Insert), then click a point to insert another vertex for the polyline.
   ■ Enter m (Move), then click a point to move the current vertex.
4 Repeat step 3, or press Enter to exit the command.

**NOTE** When following an existing polyline, the 3D Polyline follower considers the end nearest the point you picked as the start point, regardless of the original start or endpoint for the polyline.

**TIP** Use raster snapping to make it easier to pick points on the raster entity you are converting. For more information, see *Raster Snapping* on page 239.

---

**Quick Reference**

Menu

- Raster ➤ Vectorization Tools ➤ 3D Polyline Follower

Raster Design Toolbar

Command Line

`vf3dpoly`

---

**Vectorizing Raster Text**

You can replace raster text with vector text either by retyping the text or by using automated text recognition tools.

When retyping the text, you have a choice of two tools:

- The Text tool can replace a single line of raster text with a single line of AutoCAD text. You control the height, baseline angle, and justification for the text entity.

- The Multiline Text tool can replace multiple lines of raster text with a block of AutoCAD multiline text (Mtext).

Once you have entered the text for the Text or Multiline text tools, Raster Design may prompt you to remove the original raster text. Use the `VTools General` on page 364 tab of the Raster Design Options dialog box to set the method of removing this text.
Text Recognition

Raster Design’s text recognition tools can recognize raster text in an image and convert it to AutoCAD vector text. These tools can recognize both machine-printed and hand-printed text displayed as plain text or text within a table.

NOTE The Recognize Text tool is optimized for images with a resolution of 300 dpi. If the image resolution is less than 150, or greater than 400, you may get undesirable results.

Creating Single-Line Vector Text

Use the Text vectorization tool to create a line of AutoCAD vector text as a replacement for raster text or as a new entity.

Each line of vector text created with this procedure is a separate entity that can be selected, edited, and moved. If you want to create a multiline text block, see Creating Multiline Vector Text on page 230.

NOTE To make the most efficient use of the Text tool, you should first adjust the settings on the VTools General on page 364 tab of the Raster Design Options dialog box.

To create a line of vector text

1. Click Raster menu ➤ Vectorization Tools ➤ Text.

2. The current style, height, and rotation are displayed and the following prompt appears.

   Specify insertion point or [Height/Angle/Baseline/Justify]:

   Do one of the following:

   - Enter h (Height) to set the text height in pixels. Enter a value on the command line or click two points in the drawing to specify the text height.

   - Enter a (Angle) to set the text angle. Enter a value in the current AutoCAD units on the command line or click two points in the drawing to indicate the start and endpoint of a line segment at the desired angle. You will then be prompted to specify the insertion point.
■ Enter b (Baseline) to set the text baseline by clicking two points in the drawing to indicate the start point and the direction of the baseline.

■ Enter j (Justify) to specify the justification method for the text.

■ The following prompt is displayed:
  Specify justification [Left/Center/Right/Align/Mid/Fit] <Left>: 
  For more information, see Justification Options on page 229.

3 In the drawing window, select an insertion point for the text, subject to the justification method.

For example, for left-justified text, select an insertion point that corresponds to the lower-left corner of the text block.

The VText Edit dialog box is displayed.

4 Enter the text you want to place on your image and click OK.

5 The text is placed at the location that you selected.

NOTE If want to change the text, type e (Edit) to edit the text in the VText Edit dialog box.

6 Do one of the following, depending on the VTools Removal Method you selected in the Raster Design Options dialog box:

■ If None, you can press Enter to end the command.

■ If Rub, see Rubbing Raster Data Within a Diagonal Region on page 156.

■ If REM, see Defining REM Enhanced Bitonal Regions on page 178.

7 You can continue to replace raster text with vector text, use the COPYLAST option, or press Enter to end the command.

NOTE The COPYLAST command displays the VText Edit dialog box where the last text string you placed in the drawing is displayed. You can edit this text string if necessary, then click OK and pick an insertion point for the copy.

Justification Options

■ You can justify text in the following ways:
- Left, to place the insertion point at the left side of the text baseline.
- Center, to place the insertion point at the center of the text baseline.
- Right, to place the insertion point at the lower-right corner of the text baseline.
- Align, to select two points to define the text baseline. This option does not stretch or compress the text like the Fit option; it maintains the aspect ratio of the text style and overrides any height setting you have specified. With this option, you do not need to specify an insertion point.
- Mid, to place the insertion point in the middle of the text block.
- Fit, to select two points to define the baseline for the text. This option uses the height that you specify and stretches or compresses the text to fit into the length specified. With this option, you do not need to specify an insertion point.

Quick Reference

Menu
- Raster ➤ Vectorization Tools ➤ Text

Raster Design Toolbar

Command Line
- vtext

Creating Multiline Vector Text

Use the Multiline Text vectorization tool to create a block of AutoCAD vector text (Mtext) as a replacement for raster text or as a new entity.

Each multiline block of vector text created with this procedure is a separate entity that can be selected, edited, and moved. If you want to create a single line of vector text, see Creating Single-Line Vector Text on page 228.

NOTE To make the most efficient use of the Mtext tool, adjust the Removal Method and other settings on the VTools General on page 364 tab of the Raster Design Options dialog box.
To create a block of multiline vector text

1. Click Raster menu ➤ Vectorization Tools ➤ Multiline Text.
2. Enter a point to specify the first corner of the text box.
3. Enter a second point to define the angle of the baseline.
4. Enter a third point to define the extents of the Mtext box.

The Text Formatting dialog box is displayed. This is formally known as the AutoCAD In-Place Text Editor.
5. Enter the replacement vector text in the In-Place Text Editor, and review text properties to ensure they are correct. For more information, click and click Learn About MTEXT.
6. Remove the original raster text. Do one of the following, depending on the VTools Removal Method specified in the Raster Design Options dialog box:
   - If None, press Enter to end the command.
   - If Rub, click points to create the removal region. For more information, see Rubbing Raster Data Within a Rectangular Region on page 157.
   - If REM, define a removal region around the raster text. For more information, see Defining REM Enhanced Bitonal Regions on page 178.

Quick Reference

Menu

Raster ➤ Vectorization Tools ➤ Multiline Text

Raster Design Toolbar

Command Line

vmtex
Using Text Recognition

Text Recognition tools can convert the raster text in your image to AutoCAD text or AutoCAD Mtext.

The recognition engine recognizes both machine-printed and hand-printed text displayed as text or as text in a table within the image. The text recognition commands can work on only one image at a time.

NOTE: The Recognize Text tool is optimized for images with a resolution of 300 dpi. If the image resolution is less than 150 or greater than 400, you may get undesirable results.

Entering Settings for Text Recognition

These settings control the behavior of the Text Recognition tools.

For initial settings, access the Text Recognition Setup on page 373 dialog box. During the text recognition process, if you want to review or modify settings, use the Setup button in the Verify Text or Verify Table dialog box to return to Text Recognition Setup.

The Text Recognition Setup settings determine the following output:

- Recognition parameters for the search engine
- Display values for the Verify Text or Verify Table dialogs
- Text entity output to the AutoCAD drawing file

By default the Verify Text and Verify Table dialogs have two equally sized panes, the Image pane (upper pane) that displays the original raster text and the Edit pane (lower pane) that displays the findings of the recognition engine.

For more information, see View Window Options on page 237 and Edit Pane Options on page 237.

To enter settings for text recognition

1. Click Raster menu ➤ Text Recognition ➤ Recognize Setup. The Text Recognition Setup on page 373 dialog box is displayed.

2. In the Input section, enter the following settings:
   - Text Format
   - Selection Shape
- Dictionaries for spell checking
- Language Character Set
- Character types for recognition

**NOTE** If you select multiple character sets, it increases the number of possible characters the system tries to recognize. As a result, the recognition process can be slower and produce more errors.

**TIP** Review the area of text you select for recognition and ensure that you check all boxes for each class in the text.

3 In the AutoCAD Output section enter the following settings:
   - Output Type
   - Text Height
   - Removal Method
   - AutoCAD Style

4 Under Verification Display enter any format settings for the text recognition engine to ignore.

5 If you want to display the original raster test in a small window above the text being verified in the Edit pane of the Verify Text dialog box, select Enable Verifier.

6 Click OK.

**Quick Reference**

**Menu**

- Raster ➤ Text Recognition ➤ Recognize Setup

**Raster Design Toolbar**

**Command Line**

irecsetup
Recognizing and Converting Text

Use the text recognition tools to select raster text in your drawing and convert it to AutoCAD text or multiline text (Mtext).

Separate tools exist for recognizing plain text and text within a table. They are very similar in operation, so both are described together in this topic.

Settings you enter in the Text Recognition Setup on page 373 dialog box determine the search parameters for the text recognition engine and the display of recognized text in the Verify Text window. Because no text recognition program is 100% accurate, you should carefully review not only the highlighted areas, but all text in the Edit window. For more information, see Using the Verify Text Window on page 236.

NOTE Depending on the results displayed in the Edit pane, you may want to modify search parameters. To return to the Text Recognition Setup dialog box click the Setup button in the Edit pane.

NOTE The Recognize Text feature is optimized for images with a resolution of 300 dpi. Images of resolution less than 150 or greater than 400, may return undesirable results.

NOTE This procedure assumes that you have adjusted text recognition settings for the drawing. For more information, see Entering Settings for Text Recognition on page 232.

To recognize and convert text in a drawing

1. Click Raster menu ➤ Text Recognition ➤ Recognize Text. Or, click Raster menu ➤ Text Recognition ➤ Recognize Table.

2. On the left side of the text or table that you want to convert, specify the first corner point for the rectangle or polygon that will enclose the text area.

3. Specify an angle at the command line. If the area of text to be recognized is horizontal, enter 0. If the area of text is angled, pick a second point to specify the angle in the drawing, or enter the numeric value at the command line.
The program maintains the angle you establish as a default, until you enter a new angle.

4 Click OK. The Verify Text window is displayed. A progress bar displays at the bottom of the window as the recognition is taking place.

5 Review the recognized raster text in the View window using options on the View window toolbar. For more information, see View Window Options on page 237.

6 Review the recognition results in the Edit pane using the options on the Edit pane toolbar. For more information, see Edit Pane Options on page 237.

7 Edit the recognized text in the Edit pane. Click the Find Next button to display suspect words or rejected characters. Rejected characters can be caused by speckles or badly formed letters in the text.

8 To replace a suspect word, select a word from the Change To list or type the correct word in the Change To box and click Replace.

NOTE Replacing a rejected character may require copying and pasting a special character from the Windows Character Map. From the Start button select Programs ➤ Accessories ➤ System Tools ➤ Character Map. Select a character and Click Copy. Paste the character from the map into the Edit pane in the Verify Text window.

TIP Click Add To Dictionary to add specific words or acronyms to the Recognition dictionary. At the end of the command you are prompted to save these words to the AutoCAD user dictionary.

9 Select the text style from the AutoCAD style list to be used when the text is inserted into the drawing.

10 Select Text or Mtext in the Output To list, to determine how the verified text is inserted into the drawing.

11 In the Justify list, select the justification (alignment) for the text when it is inserted into the drawing.

12 Optionally, click Setup to change settings in the Text Recognition Setup dialog box.

NOTE Use the UNDO command if you are not satisfied with the new text in the drawing.
13 Optionally, click Export to save the file as a text file.

TIP Printed copy of the recognized raster text can be useful for reviews and hard copy edits.

14 Click OK to insert the AutoCAD text or Mtext into the drawing.

Quick Reference

Menu

Raster ➤ Text Recognition ➤ Recognize Text
Image ➤ Text Recognition ➤ Recognize Table

Raster Design Toolbar

Recognize Text
Recognize Table

Command Line

irectext
irectable

Using the Verify Text Window

The Verify Text window has two panes; the View pane (upper pane) and the Edit pane (lower pane). You can control the ratio of the display size in these panes by clicking and dragging the divider bar at the bottom of the View pane. You can expand the Verify Text window by clicking and dragging a corner.

- The View pane displays the original raster text to be recognized. The raster text is shown deskewed and is horizontally aligned with the dialog box. You can use the toolbar to zoom and scroll within the pane and to print the results.

- The Edit pane displays the recognized text. Suspect words are highlighted in green, rejected characters are highlighted yellow and characters that were not recognized display as red tilde (~) characters.

You can make corrections directly in the Edit pane or you can use the Find Next button to highlight the suspect words and rejected characters. In each
case, you can select a replacement word or character from the Change To list or enter the correct word and click Replace. Any changes to a word or character removes the highlighting for that word. Rejected characters (displayed as red tildes) remain in place and highlighted until they are replaced. For some characters, you may want to copy special characters from the Windows Character Map into the Edit pane.

Using the options on the toolbar you can zoom and scroll within the Edit pane, change formatting and print the results. When you click in the Edit pane, the original raster text is also displayed for comparison purposes. By clicking the Add To Dictionary button you add words or abbreviations to the recognition dictionary.

**View Window Options**

- **Zoom Width**: the recognized raster text fills the width of the view window and there is no horizontal scroll bar.
- **Zoom Height**: the recognized raster text fills the height of the view window and there is no vertical scroll bar.
- **Zoom Extents**: the recognized raster text is completely contained in the view window at the greatest zoom possible.
- **Zoom In**: the recognized raster text expands in the view window by a factor of 10%.
- **Zoom Out**: the recognized raster text shrinks in the view window by a factor of 10%.
- **Print Image**: the recognized raster text can be printed at a 1:1 ratio that is determined by the DPI in the original image. When you click the Print icon the standard windows Print dialog box is displayed.

**Edit Pane Options**

- **Zoom Width**: the recognized raster text fills the width of the view window and there is no horizontal scroll bar.
Zoom Height: the recognized raster text fills the height of the view window and there is no vertical scroll bar.

Zoom Extents: the recognized raster text is completely contained in the view window at the greatest zoom possible.

Zoom In: expands the recognized raster text in the view window by a factor of 25% of its' normal size. The text may be zoomed in to a maximum factor of 300%.

Zoom Out: shrinks the recognized raster text by a factor of 25% of its' normal size. The raster may be zoomed out to a maximum factor of 25%.

Bold: toggles the bold attribute for selected text in the editor window.

Italic: toggles the italic attribute for selected text in the editor window.

Underline: toggles the underline attribute for selected text in the editor window.

Non-printing characters: specifies whether the non-printing characters such as TAB or NEW-LINE are to be displayed.

Undo: reverses the last editing action.

Print image: displays the standard Windows Print dialog box.

**NOTE** The Edit window supports standard editing functions from the keyboard.
Raster Snapping

Raster Snap makes it easy to select points on raster entities when you are using vectorization tools (VTools) or REM commands.

NOTE Raster Snapping works only with bitonal images.

You can use raster snapping to move your AutoCAD cursor precisely to the center, end, corner, intersection or edge of a bitonal raster entity. When raster snapping is on (active), Raster Design displays a snap window on page 400 around the AutoCAD cursor. This window moves with the AutoCAD cursor and displays the crosshairs over points you can snap to.

Raster snap modes are very similar to AutoCAD object snap modes (OSNAP), except that they snap to raster objects instead of to vector objects. Also, Raster Snap is active only when you are in a command and are being prompted for a point. Raster Snap settings are located on the Raster Snap tab of the AutoCAD Drafting Settings dialog box.

Conflicts can occur between raster snapping and other utilities that control the cursor, such as Mechanical Desktop’s “Ignore Z Coordinate” feature. When a conflict occurs, the application that cannot gain cursor control displays an error message such as “Unable to Register Input Point Filter.” If Raster Design’s Raster Snap interferes with a cursor control feature in another application, you can turn off Raster Snap. If another application is interfering with Raster Snap, consult that application’s documentation for details on how to disable the conflicting feature.

See also:

- Manipulating REM Objects on page 189
- Converting Raster Entities to Vector on page 205

Specifying Raster Snap Settings

You can configure raster snapping and toggle it on and off on the Raster Snaps tab of the Drafting Settings dialog box.
Raster Snap is active only when you are in a command and are being prompted for a point.

**To set the snap settings**

1. Click Click Raster menu ➤ Raster Snap..
2. On the Raster Snap on page 311 tab, under the Snap Modes section, select the snap mode or modes you want to use.
   If you choose more than one snap mode, then the cursor snaps to the closest of the possible snap points. For more information, see Snap Modes on page 240.
3. In the snap window on page 400 box, type the desired size (up to 300 pixels) for the snap window. The larger you make the snap window, the longer Raster Design takes to search for points.

---

**NOTE** Because the snap window is measured in image pixels, not screen pixels, the size of the snap window changes with the zoom level.

---

**Quick Reference**

**Menu**

- Raster ➤ Raster Snap.

**Raster Design Toolbar**

---

**Command Line**

- isnap

**Dialog Box**

- Raster Snap Tab (Drafting Settings Dialog Box) on page 311

---

**Snap Modes**

Several snap modes are available to snap to useful points on raster entities.

- Center snaps to the center of a raster line. The entire width of the line must be in the snap window.
- End snaps to the end of a raster line.

**NOTE** When a line ends because it intersects another line, this is considered an intersection, not an end point.

- Corner snaps to the intersection of 2 raster lines.
- Intersection snaps to the intersection of 3 or more raster lines. The entire intersection must be in the snap window.
- Edge snaps to the edge of a raster line. Any part of the raster line can be in the snap window.

**NOTE** Raster Snap is active only when you are in a command and are being prompted for a point.
Configuring Raster Design

You can configure the appearance and behavior of Raster Design using the Options dialog box and other tools.

Use toggle controls on the Raster menu to control image frames and the Raster Design Quick Bar. The Raster Design Options Dialog Box on page 353 allows you to change many default settings.

Changing the Quick Bar Visibility

You can use the Toggle Quick Bar command to turn the Raster Design Quick Bar on and off.

Use the Quick Bar to set raster snap modes and controls for the vectorization tools.

For more information, see Snap Modes on page 240 and The Quick Bar on page 300.

To make the Quick Bar invisible or visible

- Click Raster ➤ Toggle Quick Bar..

Quick Reference

Menu

Raster ➤ Toggle Quick Bar.Raster ➤ Toggle Quick Bar
Raster Design Toolbar
Command Line

iqbar

Changing the Image Frame Visibility

An image frame on page 393 encloses an image. You can make an image frame invisible while you continue to display the image.

To make frames invisible or visible

■ Click Raster menu ➤ Toggle Frames..

NOTE When frames are invisible, or when an image is on a locked or frozen layer or on a layer that is turned off, you cannot select the image by clicking the frame. However, if frames are not displayed but the image is on an editable layer, you can select the image using the Shift+ left-click method. For more information, see Selecting an Image on page 81.

See also:

■ Image Frame Display on page 61
■ Linetype of an Image Frame on page 63

Quick Reference

Menu

Raster ➤ Toggle Frames.Raster ➤ Toggle Frames

Raster Design Toolbar

Command Line

iframe

Setting the Default Internet Location for Images

You can specify an Internet location to start from when retrieving or saving images.
The default Internet location is loaded each time you click the Internet button to go to the Internet from either the Insert Image dialog box or the Save As dialog box. From this location, you can use standard Internet navigation methods to search or browse to another location as required.

**To set the default Internet location for browsing files**

1. Ensure that the Tools menu is visible in the application window. For example, if you are working in Land Desktop 2005 and the Tools menu is not displayed, click Projects ➤ Menu Palettes. Then choose Land Desktop 2005 Complete and click Load.

2. Click Tools menu ➤ Options.

3. On the Files tab, click + beside Menu, Help, and Miscellaneous Files Names to display its sub-list.

4. Click Default Internet Location, then click Browse.

5. In the Select a File dialog box, do one of the following:
   - Enter the URL to an Internet location, then choose Open.
   - Navigate to an Internet location, then click OK.

6. Click OK.

**Quick Reference**

Menu
Tools ➤ Options

Raster Design Toolbar

Command Line
options

Dialog Box
IOptions (standard AutoCAD dialog box)
Setting the Options

The Raster Design Options Dialog Box on page 353 provides many settings for the control of Raster Design tools and operations.

Any settings you specify here persist as default settings for the next session.

Contour Vector Separation Options

These settings are used in vectorization to specify vector line widths for contours based on their elevation interval.

For instance, you might set the elevation interval for major contours to 50, and the elevation interval for minor contours to 10. If you then followed a contour and set the elevation to 200, the resulting vector contour would be assigned to the major layer. Likewise, if you followed a contour and set the elevation value to 220, the resulting vector would be assigned to the minor layer.

TIP If you are using vector separation to control the layer and polyline width of vectors created from the Contour Follower, it is a good idea to use the same value for the Minor Interval and the Elevation Interval on the VTools Follower tab of the Raster Design Options dialog box. For more information, see VTools Follower Settings on page 272.

To change the Contour Vector Separation Options

1. Click Raster menu ➤ Options. The Raster Design Options on page 353 dialog box is displayed.
2. Click the VTools General tab.
3. Click the Vector Separation button.
4. Click the Contour on page 377 tab.
5. If you want to assign layer and polyline width values to contours based on their elevation interval, select Separate Contours By Elevation.
6. If you have Raster Design installed on Autodesk Land Desktop and you want to use its settings for minor and major layers and intervals, select Use Autodesk Land Development Desktop’s Settings.
7. In the Minor section, set the elevation Interval for minor contours, then select a default Layer and specify a Polyline Width for these contours.
NOTE Raster Design first checks to see if the elevation is a multiple of the Major Interval.

8 In the Major section, set the elevation interval for major contours, then select a default Layer and specify a Polyline Width for these contours.

9 If you want to import vector separation settings, click Import. Vector separation files have a .vs extension.

10 If you want to export the current vector separation settings, click Export.

11 If you want to make the current vector separation settings the default values, click Save As Default.

12 Click OK to exit the dialog box.

Quick Reference

Menu
- Raster ➤ Options

Raster Design Toolbar

Command Line
- ioptions

Dialog Box
- Contour Tab (Vector Separation Options Dialog Box) on page 377

Correlation Defaults

These settings specify default values for Raster Design to use whenever an image does not have correlation data.

The correlate on page 388 data for most images is stored in the image file header, or in a resource file, or in the drawing file. However, some images may not have correlation data.
NOTE  Setting the correlation defaults can save you time if you have multiple images that require the same insertion point, scale, rotation, and density on page 389.

To set the correlation defaults

1  Click Raster menu ➤ Options. The Raster Design Options on page 353 dialog box is displayed.

2  Click the Image Defaults tab.

3  Under Insertion Point, type default insertion point coordinates in the X and Y boxes. The precision of this point depends on the precision value in the AutoCAD Units Control dialog box.

4  If you want to set an elevation for the frame, then type the elevation in the Z box.

   NOTE  This value is useful if you want to establish the elevation of a floorplan image, for example.

5  In the Scale box, type a default scale. Image scale does not change the scale of the vector drawing.

6  In the Rotation box, type a default rotation angle. The unit of measurement depends on the selected value in the AutoCAD Units Control dialog box.

7  Under Density, in the Value box, type a default density. This is usually the scanned resolution on page 397. For example, if the majority of your images are scanned at 300 dots per inch, type 300 in this box.

8  Under Density, in the Units box, type a default density unit. For example, if the majority of your images are scanned at 300 dots per inch, set Inches as the default.

9  Under Vertical Units, select either Meters or US Survey Feet.

10  Click OK to accept the defaults.

Quick Reference

Menu

Raster ➤ Options
Correlation Search Paths

These paths specify the default location of image correlation data. Correlation files store data about an image insertion point, scale, rotation, and density on page 389. Correlation paths can specify a folder on a local or network drive or a location on the Internet. The read path specifies where Raster Design searches when loading correlation information. The write path specifies where Raster Design puts correlation information when exporting images.

Previous versions of Raster Design (CAD Overlay GSX and ESP) created resource files to store information about an image. Raster Design and CAD Overlay versions 7.5 and above store this information in the drawing file, and create resource files only when you export an image. For more information, see Exporting Images on page 50. If you insert an image with an associated resource file into another drawing, then Raster Design incorporates the correlation information from the resource file.

When you insert an image, Raster Design looks in the read path to see if a resource file or world file is associated with the image. If so, you can select this file as the source of correlation information. If you leave the read path blank, Raster Design searches only the folder where the image was stored.

To set the correlation search paths

1. Click Raster menu ➤ Options. The Raster Design Options on page 353 dialog box is displayed.
2. Click the Paths tab.
3. Under Correlation Search Paths, enter a path in the Read Path text box. or click Browse, then choose one of the following:
   - Local, to navigate to a folder on a local or network drive.
Web, to navigate to an http or ftp location.

**TIP** A quick method to copy a URL to the Read Path text box: Navigate to a page containing a link to the page you want, then right-click and choose Copy Shortcut on the shortcut menu to copy the URL to the Windows Clipboard. Paste the URL in the Read Path text box by pressing Ctrl+V.

4. Enter a path in the Write Path text box, or click Browse, then choose one of the following:
   - Local, to navigate to a folder on a local or network drive.
   - Web, to navigate to an http or ftp location.

5. Optionally, select Use Correlation Search Path before using image directory.

**NOTE** This path is respected when you are inserting images and exporting images.

6. Optionally, select Search for Correlation Files on the Internet.

**NOTE** If this check box is not selected, Raster Design does not search the Internet for correlation files and ignores any URLs listed in the Read Path.

7. Click OK to exit the dialog box.

**Quick Reference**

Menu

Raster ➤ Options

Raster Design Toolbar

Command Line

ioptions

Dialog Box

Paths Tab (Raster Design Options Dialog Box) on page 357
General Vector Separation Options

These settings are used in vectorization to specify vector line widths, layer assignments, and the handling of non-continuous lines.

You can use the Width Table to automatically assign layer and polyline width values to the vectors based on the width of the original raster. In this table, you specify how to handle lines of particular width ranges. Lines of a different width are assigned the default values for layer and polyline width. You can also specify default values for non-continuous entities, such as dashed lines, that override the values specified in the width table.

NOTE Vector Separation settings are not saved with the drawing. You can maintain the current settings by using the Save As Default button, or by exporting the settings to a separate file.

To change the General Vector Separation Options

1. Click Raster menu ➤ Options. The Raster Design Options dialog box is displayed.
2. Click the VTools General tab.
3. Click the Vector Separation button.
4. Click the General tab.
5. If you want to assign layer and polyline width values to vectors based on the width of the underlying raster, then in the Width Table section, select Use Width Table.
6. To insert a new row in the Width Table, click Insert Below or Insert Above, then enter values for the minimum width (in pixels), maximum width (in pixels), layer, and polyline width.

   TIP If you don't know the width of a given raster entity, click the Query Width button, then click the raster entity. The Entity Width Information dialog box appears and displays the raster entity's width in pixels and in AutoCAD units. If you want to use one of these values, you can use standard Windows techniques for copying and pasting information from the clipboard. Click OK to return to the Vector Separation dialog box.

7. If you want to assign different values to dashed lines and other non-continuous entities, then in the Non-Continuous Entities section, select Override Width Table for Non-Continuous Entities. Select default Layer and Polyl ine Width for these entities.

General Vector Separation Options | 251
8 In the Default section, select a default Layer and Polyline Width.

9 If you want to import vector separation settings, click Import. Vector separation files have a .vs extension.

10 If you want to export the current vector separation settings, click Export.

11 If you want to make the current vector separation settings the default values, click Save As Default.

12 Click OK to exit the dialog box.

**Quick Reference**

Menu

Raster ➤ Options

Raster Design Toolbar

Command Line

ioptions

Dialog Box

General Tab (Vector Separation Options Dialog Box) on page 376

**General VTool Settings**

These settings specify the behavior of line, circle, arc, and polyline vectorization tools.

**To change general settings for Line, Circle, Arc, and Polyline tools**

1 Click Raster menu ➤ Options. The Raster Design Options on page 353 dialog box is displayed.

2 Click the VTools General tab.

3 In the Removal Method section, click one of the following settings:
   - None does not delete the raster as you trace it.
   - Rub automatically rubs the underlying raster. This setting uses the Rub/ Crop Line Width setting to determine the width of the raster it
rubs. For more information, see Rub and Crop Line Width on page 268.

- REM deletes the underlying raster. However, unlike the Rub setting, this option recognizes raster line width and leaves raster intersections intact.

**NOTE** The 3D Polyline Follower always uses the None option.

4 If you want the line, polyline, and arc tools to stop at vector intersections during one-pick selection, then in the Line, Circle, Arc and Polyline Settings section, select Stop at Vector Intersection. This is useful if much of a drawing has been vectorized and the vectorization tools can depend on increasing amounts of vector data to make stopping decisions.

5 If you want the line and polyline tools to display a glyph that specifies the start point, select Display Start Point Glyph.

6 In the Verification List section, select the type of values to appear in the verification list:
   - Most Recently Used
   - Most Frequently Used

7 Specify the number of values to include in the verification list in the Length box.

8 If you want SmartCorrect to respect current AutoCAD drafting settings such as OSNAP, ORTHO, and POLAR, then in the SmartCorrect Settings section select Respect Drafting Settings.

9 In the Correction Tolerance section, select one of the following options:
   - AutoCAD APERTURE uses the aperture settings from the Drafting tab of the AutoCAD Options dialog box to determine how far (in screen pixels) the resulting vector is allowed to shift in an attempt to respect AutoCAD drafting settings.

   - AutoCAD Units allows you specify how far (in AutoCAD units) the resulting vector is allowed to shift in an attempt to respect AutoCAD drafting settings. If you select this option, enter the number of units in the text box.

10 If you want Raster Design to round the values for vector entities created using one-pick selection, select Round Values. Rounding applies to the
length and angle values for lines and polylines, and to the radius value for arcs and circles.

11 If Round Values is selected, select one of the following rounding options:
   ■ AutoCAD Precision (LUPREC/AUPREC) uses the precision value set in the Drawing Units dialog box.
   ■ Specified Precision uses the precision values you set in the associated Length and Angle text boxes. Specified Precision rounds to a multiple of the value you entered. For instance, if you specified a length precision of .03, Raster Design might round a line to 12.03, 12.06, 12.09, and so on.

12 Click OK to exit the dialog box.

Quick Reference

Menu
   Raster ➤ Options

Raster Design Toolbar

Command Line
   ioptions

Dialog Box
   VTools General Tab (Raster Design Options Dialog Box) on page 364

Image Detach Method

This setting specifies whether to detach on page 389 an image from the drawing when you erase all frames that reference the image.

To choose an image detach method

1 Click Raster menu ➤ Options. The Raster Design Options on page 353 dialog box is displayed.

2 Click the User Preferences tab.
3 Under Image Detach Options, select one of the following methods:
   ■ Ask Before Detach prompts you to before detaching an image.
   ■ Always Detach automatically detaches an image.
   ■ Never Detach does not detach an image.
4 Click OK to exit the dialog box.

**NOTE** If you select the Never Detach option, you can manually detach an image using the AutoCAD IMAGE command.

**Quick Reference**

Menu
   Raster ➤ Options
Raster Design Toolbar
   ![Icon]

Command Line
   ioptions
Dialog Box
   User Preferences Tab (Raster Design Options Dialog Box) on page 360

**Image Defaults**

These settings specify correlation data, density, and vertical units to use if these are not provided for an image.

To specify image default settings

1 Click Raster menu ➤ Options. The Raster Design Options on page 353 dialog box is displayed.
2 Click the Image Defaults tab.
3 Specify default values for Insertion Point, Scale/Rotation, Density (in pixels per linear unit) and Vertical Units.
4 Click OK to exit the dialog box.

**Quick Reference**

**Menu**
- Raster ➤ Options

**Raster Design Toolbar**

**Command Line**
- ioptions

**Dialog Box**
- [Image Defaults Tab (Raster Design Options Dialog Box) on page 353](#)

**Image Mask Options**

These settings specify whether masks are enabled, and the behavior of images outside a mask boundary.

**To change settings for mask options**

1 Click Raster menu ➤ Options. The [Raster Design Options on page 353](#) dialog box is displayed.

2 Click the Image Mask tab.

3 Select Enable Mask to enable an existing mask for display.

4 Choose a default behavior for any images outside the image mask:
   - Do Not Affect prevents modifications to images that are outside the mask boundary.
   - Hide Image(s) hides the images that are outside the mask boundary.
   - Unload Image(s) unloads from memory any images that are outside the mask boundary.
NOTE If you select Do Not Affect, any images that were previously unloaded by the mask must be manually reloaded if you want to view them. Any images that were previously hidden by the mask must be manually shown. To show a hidden image, select the image frame, then right-click and click Show Image.

If you select Hide Image(s) or Unload Image(s), you can select Show Image Frame(s) to show the frames of hidden or unloaded images.

Quick Reference

Menu
Raster ➤ Options
Raster Design Toolbar

Command Line
ioptions

Dialog Box
Image Mask Tab (Raster Design Options Dialog Box) on page 355

Image Thumbnails

This setting specifies whether to create an image thumbnail whenever you save an image.

Image thumbnails greatly increase the speed at which you can preview images in the Raster Design Insert Image dialog box, the Histogram dialog box, and the AutoCAD Image Adjust dialog box.

Saving an image thumbnail with each image increases the image file size only slightly. For more information, see Saving an Image on page 41.

To create thumbnails of images

1 Click Raster menu ➤ Options. The Raster Design Options on page 353 dialog box is displayed.
2 Click the Feature Settings tab.
3 In the Thumbnail Option section, select Save Thumbnail with Image.

4 Click OK to exit the dialog box.

**NOTE** This option is used only with file formats that support embedded previews.

---

**Quick Reference**

**Menu**

- Raster ➤ Options

**Raster Design Toolbar**

**Command Line**

- ioptions

**Dialog Box**

- Feature Settings Tab (Raster Design Options Dialog Box) on page 354

---

**Inserting Images From GSX or ESP**

These settings specify how to handle images imported from drawings created by CAD Overlay GSX or CAD Overlay ESP.

Raster Design handles images differently than CAD Overlay GSX and ESP did. With GSX and ESP, you could paste a main image and up to nine reference images into your drawing. The main image was given the same filename as your drawing.

**NOTE** There is no limit to the number of images you can insert into a drawing with CAD Overlay versions 7.5 and above.

If you want to open a drawing in Raster Design that you created with GSX or ESP, you can enable an AutoPaste feature that locates and automatically pastes the main image into your current drawing. When Raster Design pastes the main image into your drawing, it also pastes all of the reference images associated with the main image.
Raster Design searches along the AutoCAD project files search path for an image filename that matches the name of your drawing (the main image), but you can select which image types (file extensions) you want it to search for. For more information about setting the project files search path, see the AutoCAD online Help.

**To insert GSX or ESP images into your drawing**

1. Click Raster menu ➤ Options. The Raster Design Options on page 353 dialog box is displayed.

2. Click the Paths tab.


   **NOTE** If you try to open a drawing that you created in GSX or ESP but you do not enable AutoPaste, then your drawing loads but your images are not displayed. To manually insert them, click Raster menu ➤ Insert.

4. Select Prompt before AutoInsert if you want Raster Design to prompt you to insert the image it locates. Clear this check box if you want to insert the image automatically without prompting.

5. Specify which file types you want Raster Design to search for by choosing a file extension from the list, then add it to the Extension List. Raster Design searches for the image types in the order they appear in this list. After it locates an image of the type specified, it stops searching.

6. Click OK to accept your changes and exit the dialog box.

   **NOTE** Raster Design does not perform an AutoPaste if there are image references already saved in the drawing (for example, if it is a drawing containing images you saved using version 7.5 or above of Raster Design).

**Quick Reference**

**Menu**

Raster ➤ Options

**Raster Design Toolbar**

Inserting Images From GSX or ESP | 259
Locking Method for Image Files

This setting is for users on a network to specify whether and how to lock files that are in use.

Locking provides write access for the first person that opens the file. Anyone else who opens the file can read it but is denied write access until the first person closes the file.

An image file is locked when Raster Design creates a lock file using the image base name with a .l_k extension. The lock file is stored in the same directory as the image file or in the lock file directory if you specify one. When you insert an image, Raster Design searches the image directory (or the lock file directory) to see if a lock file already exists for that image. If a lock file exists, then you are prompted that the file is read-only.

If you store lock files in a lock file directory, all raster image files with the same base name as the inserted image are locked. For example, if you insert tutor.rlc, a tutor.l_k file is created in the lock directory. This locks the image that you inserted and any other files with the base name “tutor.” in any directory.

If you do not specify a lock file directory, the lock file is created in the directory where the image is saved. In this case, a lock file locks only images in that directory with the same base name.

**NOTE** For locking to work properly, everyone on the network must use the same locking method and directory.

To set the file locking method

1. Click Raster menu ➤ Options. The Raster Design Options on page 353 dialog box is displayed.
2. Click the Feature Settings tab.
3. Under Locking Settings, select one of the following options:
   - No Locking, if you are not working on a network with other users.
- Lock File, if you are on a network that does not support DOS File Sharing and if you are using more than one platform on the network.
- OS/Network Locking, if you are on a network that supports DOS File Sharing and you are using more than one platform.

**NOTE** You cannot lock files on the Internet.

4 If you choose a locking option, you can specify the Lock File Directory where lock files will be saved. If you do not specify a directory, lock files are stored in the same directory as the image file.

5 Click OK.

**Quick Reference**

**Menu**
- Raster ➤ Options

**Raster Design Toolbar**
- ![Raster Design Toolbar Icon]

**Command Line**
- ioptions

**Dialog Box**
- Feature Settings Tab (Raster Design Options Dialog Box) on page 354

**Message Display Method**

This setting specifies how Raster Design displays warnings during editing operations.

**To change the Message Display method**

1 Click Raster menu ➤ Options. The Raster Design Options on page 353 dialog box is displayed.

2 Click the User Preferences tab.
3 In the Message Display section, click one of these options:

- No Messages, to prevent Raster Design from displaying warnings while you are editing an image.
- Command Line, to display warnings on the command line only.
- Message Box, to display all warnings while you are editing an image.

4 Click OK to exit the dialog box.

**Quick Reference**

Menu

Raster ➤ Options

Raster Design Toolbar

![Command Line](ioptions)

Command Line

ioptions

Dialog Box

**User Preferences Tab (Raster Design Options Dialog Box)** on page 360

**Mouse Settings**

These settings specify the function of mouse buttons when you are using Raster Design.

**To set the mouse settings**

1 Click Raster menu ➤ Options. The **Raster Design Options** on page 353 dialog box is displayed.

2 Click the User Preferences tab.

3 Under Mouse Settings, select Shift + Left Click Image Select if you want to select an image by pressing shift and clicking your left mouse button. This feature is useful when you are zoomed in on the image and cannot see the image frame. For more information, see **Selecting an Image** on page 81.
4 Click OK to exit the dialog box.

Quick Reference

Menu
- Raster ➤ Options

Raster Design Toolbar

Command Line
- ioptions

Dialog Box
- User Preferences Tab (Raster Design Options Dialog Box) on page 360

New Image Defaults

These settings specify default properties for a new Raster Design image.

Setting these defaults can save you time if you have multiple images that require the same properties.

**NOTE** When you change the units of measurement, these units are applied to the other controls in the Default Image Properties section.

To set the new image defaults

1. Click Raster menu ➤ Options. The Raster Design Options on page 353 dialog box is displayed.

2. Click the New Image tab.

3. To change the default physical width of the image in pixels, enter a value in the Width box in the Default Image Properties section.

4. To change the default physical height of the image in pixels, enter a value in the Height box.

5. Type a default density (or resolution on page 397) for new images in the Density box.
   This defines both the horizontal and vertical density.
6 In the Default Color Type section, click a color type for the new image:

- Bitonal (1-bit), with two colors.
- Grayscale (8-bit), with 256 shades of gray.
- Indexed Color (8-bit), with 256 paletted colors.
- True Color (32-bit), with up to 16.7 million colors.

**NOTE** Selecting True Color uses more system resources.

7 If you want the New Image dialog box to appear when you create a new image, select Show New Image Dialog.

**NOTE** If this check box is not selected, Raster Design will default to the command line interface when you create a new image.

8 Click OK to accept the changes.

**Quick Reference**

**Menu**

Raster ➤ Options

**Raster Design Toolbar**

**Command Line**

ioptions

**Dialog Box**

New Image Tab (Raster Design Options Dialog Box) on page 356

**QSave Preference**

This setting specifies whether Raster Design prompts you to save the images you edited when you use the AutoCAD QSave command to save a drawing.
To set the QSave Preference

1. Click Raster menu ➤ Options. The Raster Design Options on page 353 dialog box is displayed.

2. Click the User Preferences tab.

3. If you want to be prompted to save your images when you use the AutoCAD QSave command, select Prompt during QSave.

4. Click OK to exit the dialog box.

Quick Reference

Menu
- Raster ➤ Options

Raster Design Toolbar

Command Line
- ioptions

Dialog Box
- User Preferences Tab (Raster Design Options Dialog Box) on page 360

Raster Design Startup Options

This setting specifies how Raster Design starts up in relation to AutoCAD.

To choose a Raster Design startup option

1. Click Raster menu ➤ Options. The Raster Design Options on page 353 dialog box is displayed.

2. Click the User Preferences tab.

3. If you want the Raster menu to appear each time you run Raster Design, select Load Menu on Raster Design Startup.

4. If you want Raster Design to start each time you run AutoCAD, select Load Raster Design on AutoCAD Startup.
5 Click OK to exit the dialog box.

Quick Reference

Menu
   Raster ➤ Options
Raster Design Toolbar
   ➤
Command Line
   ioptions
Dialog Box
   User Preferences Tab (Raster Design Options Dialog Box) on page 360

Raster Entity Detection Settings

These settings specify the way REM tools and vectorization tools detect and follow raster entities.

The settings are divided among three categories:

- Single pick options specify the maximum distance within which a raster entity can be initially selected.
- Multi-pick options specify the maximum distance within which raster can be selected along a line or other selection path.
- Non-continuous linetype detection settings specify the maximum lengths of dashes and blanks in a non-continuous or dashed line.

To change the default settings for Raster Entity Detection

1 Click Raster menu ➤ Options. The Raster Design Options on page 353 dialog box is displayed.

2 Click the Raster Entity Detection tab.

3 In the Single Pick Options section, enter a value in the Max Jump Length (Pixels) text box, or click Pick to select the jump length from an image.
4 Select Stop At Intersections to determine whether Raster Design detects segments or entire primitives.

5 Select Use Raster Pick Gravity check box to define the size of the area around the point you pick in which Raster Design can search for raster.

6 If you selected Use Raster Pick Gravity, enter a numerical pixel width value in the Pick Aperture (Pixels) text box to define a new aperture size.

7 Under Multi Pick Options, enter a value in the Float Tolerance (Pixels) box.

8 Under Non-Continuous Linetype Detection, enter a value in the Max Dash Length (Pixels) and the Max Blank Length (Pixels) box, or click Pick to select the length from an image.

9 Click OK to exit the dialog box.

Quick Reference

Menu

Raster ➤ Options

Raster Design Toolbar

Command Line

ioptions

Dialog Box

Raster Entity Detection Tab (Raster Design Options Dialog Box) on page 359

REM Settings

These settings specify the default color of REM objects, and the way REM objects are copied to the clipboard.

The default color of REM objects is red. If you define REM objects in color or grayscale images, only the vector boundary of the object is red. If you define REM objects in a bitonal image, the entire object is red. Enhanced bitonal region objects also have a red vector boundary.
To change default settings for REM objects

1. Click Raster menu ➤ Options. The Raster Design Options on page 353 dialog box is displayed.
2. Click the REM tab.
3. For Color of REM Objects, click Select to display the color palette.
4. Select a color and click OK.
5. Choose an option in the Clipboard Settings section. These options apply when you use the REM Copy to Clipboard command (icopyss):
   - Display Capture maintains the display scale and rotation of the objects in the REM selection set.
   - Native Capture copies the REM selection set data directly from the image file, disregarding the display scale and rotation.
6. Click OK again to exit the Raster Design Options dialog box.
   Any existing REM objects are now the color you selected.

Quick Reference

Menu
- Raster ➤ Options
Raster Design Toolbar

Command Line
- ioptions

Dialog Box
- REM Tab (Raster Design Options Dialog Box) on page 359

Rub and Crop Line Width

This setting specifies the line width to use with the Rub and Crop commands: Circle, Line, Polyline, Arc, and Crop Line.
This value is also used if you have Rub selected as your VTools Removal Method. As you trace your raster objects, the vectorization tools use the rub/crop line width to determine the width of the raster that is rubbed. For more information, see General VTool Settings on page 252.

Changes that you make to Autorub at the command line update the settings in the Raster Design Options dialog box:

- If you turn AutoRub off, None is selected as the VTools Removal Method in the Raster Design Options dialog box.
- If you turn AutoRub on, Rub is selected as the VTools Removal Method in the Raster Design Options dialog box.
- If you use the AutoRub command at the command line to change the rub/crop line width, the value is updated in the Raster Design Options dialog box.

**NOTE** You can type autorub to use the command transparently.

**To set the Rub and Crop line width**

1. Click Raster menu ➤ Options. The Raster Design Options on page 353 dialog box is displayed.
2. Click the Feature Settings tab.
3. Do one of the following:
   - Type a value (in AutoCAD units) in the Rub/Crop Line Width box.
   - Click Pick and then pick two points on your image to define the line width.
4. Click OK to exit the dialog box.

**Quick Reference**

Menu

Raster ➤ Options

Raster Design Toolbar

Rub and Crop Line Width | 269
Remove Under Method

This setting specifies how the Remove Raster Under Vector tool removes raster data during vectorization.

To change the removal method for Raster Under Vector

1. Click Raster menu ➤ Options. The Raster Design Options on page 353 dialog box is displayed.
2. Click the Feature Settings tab.
3. In the Removal Method section, select the Rub or REM option.
4. Click OK to exit the dialog box.

Quick Reference

Menu

Raster ➤ Options

Raster Design Toolbar

Command Line

ioptions

Dialog Box

Feature Settings Tab (Raster Design Options Dialog Box) on page 354

Vector Merge Settings

These settings specify the behavior of future vector merges.
To change the vector merge defaults

1. Click Raster menu ➤ Options. The Raster Design Options on page 353 dialog box is displayed.

2. Click the Vector Merge tab.

3. Under Prompting Options, select one of the following:
   - Select Prompt to Delete Vector if you want to be prompted to delete all selected vectors after the Vector Merge command is completed.
     
     NOTE Selecting this check box disables the Always Delete Vector and the Never Delete Vector options.

   - Click Always Delete Vector to delete all selected vectors after the vector merge command is completed.

   - Click Never Delete Vector to preserve selected vectors after the vector merge command is completed.

4. Under Merge Options, select any of the following options you want to incorporate in future vector merge operations:
   - Expand Image If Necessary, to expand your image to the extents of the vector.

     NOTE If a vector lies behind the image and Expand Image If Necessary is not selected, then the vector is not merged into the image unless the image is transparent. For more information, see Transparent Color of an Image on page 64.

   - Respect Display Order, to incorporate your current display order.

   - Create New Raster, to create a new image rather than merge the vectors into an existing image. This is useful if, for instance, you want to transmit your drawing information in raster format.

5. Click OK to accept the changes.
Quick Reference

Menu
Raster ➤ Options

Raster Design Toolbar

Command Line
ioptions

Dialog Box
Vector Merge Tab (Raster Design Options Dialog Box) on page 361

VTools Follower Settings

These settings specify the behavior of follower tools during vectorization. Some settings apply only to the contour follower and the 3D polyline follower.

TIP If you are using vector separation to control the layer and polyline width of vectors created from the Contour Follower, it is a good idea to use the same value for the Elevation Interval and the Minor Interval on the Contour tab of the Vector Separation Options dialog box. For more information, see Contour Vector Separation Options on page 246.

To change the VTools Follower Settings

1 Click Raster menu ➤ Options. The Raster Design Options on page 353 dialog box is displayed.

2 Click the VTools Follower tab.

3 If you want to change the color Raster Design uses to mark the progress of the follower, click Select and choose a new follower color.

4 If you want Raster Design to automatically pan to display the current decision point on screen, select Pan to Decision Point.

5 If you want Raster Design to automatically close polylines and contour objects where the endpoints are within a tolerance distance, select End Current Polyline If Closed Loop Detected. This setting is useful for closing loops across labels in contour lines.
6 If you selected End Current Polyline If Closed Loop Detected, specify the tolerance distance in one of two ways: enter a numeric value, or click Pick and click two points in the drawing. Polylines whose endpoints fall within this distance will be automatically closed.

7 If you want to control how Raster Design draws the polylines and contours produced by the follower, select Post Process Points. Optionally, move the Polyline Deviation slider to control how closely Raster Design imitates the raster polyline or contour.
   ■ High deviation creates a polyline with fewer points that is less faithful to the original raster. Such polylines use less system resources.
   ■ Low deviation creates a polyline with more points that more closely matches the raster path. Such polylines use more system resources.

8 In the Contour Settings section, select the type of entity the Contour Follower creates in the Contour Creates list.

   NOTE The follower can only create contour objects if Raster Design is running on Autodesk Land Desktop. If you are running on Autodesk Civil 3D, you can add the contour data to the definition of a TIN surface.

9 In the Elevation list, click one of the following:
   ■ ELEVATION assigns an elevation value based on the AutoCAD ELEVATION variable.
   ■ Zero assigns an elevation value of 0.
   ■ Preset assigns the value that you specify in the Preset Elevation text box to all polylines and contour objects created by the Contour Follower.
   ■ Prompt causes Raster Design to prompt you for elevation when the follower is finished.
   ■ Use Existing causes Raster Design to prompt you to select an existing contour or polyline to which the elevation value can be matched.

10 If you selected Prompt for Elevation, enter a value in Elevation Interval. Raster Design adds or subtracts this amount from the last elevation value you entered to create a suggested elevation value.

11 In the 3D Polyline Settings section, enter a value in Elevation Interval. Raster Design adds or subtracts this amount from the last elevation value you entered to create a suggested elevation value.
12 If you want the follower to pause only at raster intersections, ignoring other vertices, select Use Raster Impact Points Only.

13 If you want to prevent the follower from pausing at raster speckles, select Ignore Raster Speckles.

14 If you selected Ignore Raster Speckles, enter a pixel value in the Speckle Size (Pixels) text box, or click the Pick button to specify a speckle size by clicking a speckle in the image, or by clicking two points to define a rectangular window.

15 Click OK to exit the dialog box.

Quick Reference

Menu
   Raster ➤ Options

Raster Design Toolbar

Command Line
   ioptions

Dialog Box
   VTools Follower Tab (Raster Design Options Dialog Box) on page 362
This chapter includes troubleshooting information, and a reference guide to Raster Design menus, commands, and toolbars.

Troubleshooting

If the information you need cannot be readily found in the AutoCAD Raster Design User's Guide, the following troubleshooting topics may help you find the solution you're looking for.

Correcting Image Display Order using REGEN

If you find that the image display ordering seems incorrect when you open a drawing, select an image, or use an editing command, then you can use REGEN to restore the proper order. The image display order is affected by the following conditions:

Image Insertion Order

AutoCAD respects image insertion order first. For example, if you insert images A, B, C in that order, and then reorder them so that they are arranged as B, C, A, then you need to use REGEN to restore the B, C, A order when you open the drawing again. This is an optimization feature that AutoCAD applies to the display order of all objects, not just to images.
Image Editing

When you use an editing command on an image, that image may rise to the top of the display order. Use the AutoCAD REGEN command to restore the proper display order.

For more information, see Changing the Display Order of Images on page 75.

Raster Snap Troubleshooting

If you set a raster snap setting and you cannot see the snap window, then make sure your drawing VPOINT is set to 0,0,1.

If you still cannot see the snap window, then adjust the snap window size or try zooming into the image. The size of the snap window changes when you change the zoom level.

When you use raster snapping with AutoCAD OSNAPs, the OSNAPs take priority. You can press F3 to turn off any running OSNAPs if they are conflicting with the raster snaps.

For more information, see Raster Snapping on page 239.

Plotting Raster Images

AutoCAD allows you to plot color, grayscale, and bitonal images with color vector information in either landscape or portrait mode in both paper and model space.

For more information, see “Plot Drawings” in the AutoCAD online Help or printed Users Guide.

Images that are Not Editable

The following table lists the reasons why an image may not be editable and what you can do to make it editable.

<table>
<thead>
<tr>
<th>If you want to edit the image, and the image is</th>
<th>Then</th>
</tr>
</thead>
<tbody>
<tr>
<td>locked</td>
<td>Have the other user close the drawing that contains the locked image. For more information, see Locking Method for Image Files on page 260.</td>
</tr>
</tbody>
</table>

276 | Appendix A  Troubleshooting and Reference Guide
If you want to edit the image, and the image is

<table>
<thead>
<tr>
<th>Then</th>
</tr>
</thead>
<tbody>
<tr>
<td>NOTE</td>
</tr>
<tr>
<td>on an AutoCAD layer that is locked, frozen, or invisible</td>
</tr>
<tr>
<td>in a format that Raster Design can only read</td>
</tr>
<tr>
<td>stored on a read-only device (for example, a CD-ROM)</td>
</tr>
<tr>
<td>in perspective view</td>
</tr>
<tr>
<td>a read only file</td>
</tr>
</tbody>
</table>

To find out why an image is not editable, and what you can do to make it editable, you can click on the Edit Status dialog box.

**Problems Inserting Images from the Internet**

To use the Raster Design Internet feature, you must have Internet or Intranet access and an Internet browser installed on your system. You must also have certain components of Microsoft Internet Explorer installed on your system. These components are installed when you select the Full Install installation option in AutoCAD, or if you select the Internet Tools option during a custom AutoCAD installation.

If you connect to the Internet through your company's network, you may need to set up a proxy server configuration. Proxy servers act as security barriers by shielding information on your company's network from potential security risks due to external Internet access. See the Internet applet in the Windows Control Panel or contact your network administrator for details about how to configure a proxy server in your network environment.
Sharing Projects with Images from Different Locations

Often, two or more people work on a project together. If the images they're using are stored in different locations, problems can occur. For instance, two people are sharing a project in which the image is stored on CD while the AutoCAD drawings are stored on their respective hard drives. One person's CD drive is labeled E, and the other's is labeled H. Each time they send files back and forth they have to browse to each image's path.

Both users can get around this by setting their project paths to the different locations for the images. (To access the project paths, click Tools menu ➤ Options.) If they insert the image using IMAGEATTACH, they can choose to leave the path off the image. When the Raster Design tries to resolve this, it will search each of the following locations for the filename with extension (if there is one). If it is not found, every valid extension is tried:

- the saved path
- the current directory
- the directory of the drawing
- the AutoCAD “current project” files search paths

Command-Line Commands

The following table lists Raster Design commands in alphabetic order, with descriptions and related Help topic links.

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
<th>Related Help</th>
</tr>
</thead>
<tbody>
<tr>
<td>autorub</td>
<td>Sets the Rub/Crop line width.</td>
<td>Rub and Crop Line Width on page 268</td>
</tr>
<tr>
<td>dockrd</td>
<td>Docks the Image Manager toolspace.</td>
<td>Controlling the Image Manager Toolspace on page 67</td>
</tr>
<tr>
<td>floatrd</td>
<td>Floats the Image Manager toolspace.</td>
<td>Controlling the Image Manager Toolspace on page 67</td>
</tr>
<tr>
<td>hiderd</td>
<td>Hides the Image Manager toolspace.</td>
<td>Controlling the Image Manager Toolspace on page 67</td>
</tr>
</tbody>
</table>
iabout
Displays the Raster Design version number, serial number, and name of the registered owner.

ibfilter
Uses filters to smooth, thin, thicken, separate, or skeletonize bitonal images.
Related topic: Using Bitonal Filters on page 114

ibias
Changes an image's dimensions in the X or Y direction.
Related topic: Adjusting the Image Bias on page 88

icapture
Captures the current image.
Related topic: Capturing an Image on page 49

iclear
Clears the selected raster entity manipulation (REM) objects.
Related topic: Clearing REM Objects on page 199

iclearall
Clears all REM objects in the current drawing.
Related topic: Clearing REM Objects on page 199

iconvtoimg
Converts selected REM objects to a new raster image.
Related topic: Converting REM Objects to a New Raster Image on page 201

iconvolve
Makes differences in shading more distinct.
Related topic: Reducing Harshness and Noise in an Image on page 107

icopyss
Copies a raster entity to the clipboard.
Related topic: Using REM Copy To Clipboard Command on page 202

icropalign
Crops raster data outside a rectangle aligned at any angle, but image frame remains at the angle of the source image at the time the crop is made.
Related topic: Aligned Rectangular Cropping on page 150

icropcirc
Crops raster data outside a circular region.
Related topic: Circular Cropping on page 148

icropdiag
Crops raster data around a diagonal region.
Related topic: Diagonal Cropping on page 149

icropline
Crops raster data around a line.
Croppoly
Crops raster data outside a polygonal region.
Related topic: Polygonal Cropping on page 150

Croproct
Crops raster data outside a rectangular region. Image frame matches angle of crop.
Related topic: Rectangular Cropping on page 148

Delarc
Deletes a REM arc primitive.
Related topic: Removing Raster Entities Using REM Commands on page 159

Delcircle
Deletes a REM circle primitive.
Related topic: Removing a REM Circle Primitive on page 162

Delline
Deletes a REM line primitive.
Related topic: Removing a REM Line Primitive on page 160

Delsmart
Removes a line, arc, or circle using Smart Pick.
Related topic: Removing Raster Entities Using REM Commands on page 159

Density
Changes an image's density.
Related topic: Changing Image Density on page 117

Depth
Changes an images color depth.
Related topic: Setting the Color Depth for an Image on page 118

Deskew
Matches the rotation of an image to a reference image or vector.
Related topic: Deskewing an Image on page 85

Despeckle
Removes speckles from an image.
Related topic: Removing Speckles from an Image on page 86

Displace
Moves an image in reference to an image or vector.
Related topic: Correlating an Image After Insertion on page 30

Embed
Embeds one or more images in the current drawing.
ieraseinsertion  Erases the selected image.
Related topic: Erasing an Image on page 76

iexport  Saves an image by exporting it.
Related topic: Exporting Images on page 50

iframe  Changes the image frame visibility.
Related topic: Changing the Image Frame Visibility on page 244

ihelp  Opens Raster Design Help.

ihideimage  Hides the selected image(s) from view. To reverse this command, use ishowimage.
Related topic: Showing and Hiding Images on page 74

ihideinsertion  Hides the selected image.
Related topic: Showing and Hiding Images on page 74

ihistogram  Adjusts the brightness and contrast of image(s).
Related topic: Reversing the Light and Dark Shades in an Image on page 90

imerge  Merges images.
Related topic: Merging Images on page 163

insert  Inserts an image.
Related topic: Inserting Images on page 11

invert  Reverses the light and dark tones in an image.
Related topic: Reversing the Light and Dark Shades in an Image on page 90

iknife  Draws a line that is one pixel wide through raster data.
Related topic: Separating Raster Linework Using Knife on page 203

imanage  Opens the Image Manager toolspace.
Related topic: Controlling the Image Manager Toolspace on page 67
<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
<th>Related Topic</th>
</tr>
</thead>
<tbody>
<tr>
<td>imask</td>
<td>Creates a new image mask.</td>
<td>Creating a New Mask on page 139</td>
</tr>
<tr>
<td>imaskedit</td>
<td>Changes the image mask properties for the new mask.</td>
<td>Changing an Existing Mask on page 141</td>
</tr>
<tr>
<td>imaskconvert</td>
<td>Converts a mask to an image clip.</td>
<td>Converting a Mask to Image Clips on page 146</td>
</tr>
<tr>
<td>imatch</td>
<td>Aligns points on an image with those on another image or drawing.</td>
<td>Matching Image Points on page 30</td>
</tr>
<tr>
<td>imergetoimg</td>
<td>Converts selected REM objects into pixels in a specified image.</td>
<td>Merging REM Objects into an Image on page 200</td>
</tr>
<tr>
<td>imirror</td>
<td>Flips the image along the horizontal or vertical axis.</td>
<td>Mirroring an Image on page 90</td>
</tr>
<tr>
<td>inew</td>
<td>Creates a new image.</td>
<td>Creating New Images on page 22</td>
</tr>
<tr>
<td>ioptions</td>
<td>Configures Raster Design.</td>
<td>Setting the Options on page 246</td>
</tr>
<tr>
<td>ipal</td>
<td>Shows or hides a column in the list window.</td>
<td>Using the Palette Manager on page 120</td>
</tr>
<tr>
<td>iprimfromvec</td>
<td>Converts a vector entity (line, polyline, arc, or circle) to a REM primitive.</td>
<td>Defining a REM Primitive From Existing Vectors on page 187</td>
</tr>
<tr>
<td>ipurgecm</td>
<td>Removes all unused color maps from the drawing.</td>
<td>Assigning a Color Map to an Image on page 20</td>
</tr>
<tr>
<td>iqbar</td>
<td>Turns the Quick Bar on and off.</td>
<td>Changing the Quick Bar Visibility on page 243</td>
</tr>
</tbody>
</table>
iquery Opens the Raster Data Query dialog box. Related topic: Displaying Point Data on page 73


irectable Converts raster text in a table to AutoCAD text. Related topic: Recognizing and Converting Text on page 234

irectext Converts raster text to AutoCAD text. Related topic: Recognizing and Converting Text on page 234

irefinemode Uses raster entity manipulation (REM) refine mode to change the size and shape of a REM region or primitive object. Related topic: Resizing a REM Object on page 191

iregfromvec Defines a REM region from an existing vector object. Related topic: Defining a Region From an Existing Vector Object on page 176

iremove Removes pixels or raster entities from a defined REM region. Related topic: Using REM to Delete Raster Data on page 197

irmvexisting Removes raster data under existing vector geometry. Related topic: Remove Raster Using Existing Vector Geometry on page 158

irsheet Stretches an image in one or more directions to align it with another image. Related topic: Rubbersheeting an Image on page 33

irubarc Rubs a raster arc. Related topic: Rubbing a Raster Arc on page 152

irubcirc Removes raster data within a circular region. Related topic: Rubbing Raster Data Within a Circular Region on page 155

irubcircle Rubs a raster circle. Related topic: Rubbing a Raster Circle on page 153
irubdiag  Removes raster data within a diagonal region.
Related topic: Rubbing Raster Data Within a Diagonal Region on page 156

irubline  Rubs a raster line.
Related topic: Rubbing a Raster Line on page 152

irubpline  Rubs multiple line segments.
Related topic: Rubbing Multiple Line Segments on page 154

irubpoly  Removes raster data within a polygonal region.
Related topic: Rubbing Raster Data Within a Polygonal Region on page 156

irubrect  Removes raster data within a rectangular region.
Related topic: Rubbing Raster Data Within a Rectangular Region on page 157

isarc  Converts a raster arc entity to an arc primitive.
Related topic: Defining a REM Arc Primitive on page 185

isave  Saves an image without saving the drawing.
Related topic: Saving an Image on page 41

isaveas  Provides options for saving an image to a different name, file type, or location.
Related topic: Saving an Image to Another File Name, Type, or Location on page 45

iscircle  Convert a raster circle entity to a circle primitive.
Related topic: Defining a REM Circle Primitive on page 183

iscircreg  Selects all pixels within a defined circular region.
Related topic: Defining a REM Circular Region on page 174

isdiagreg  Selects all pixels within a specified diagonal (parallelogram) region.
Related topic: Defining a REM Diagonal Region on page 173
<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
<th>Related Topics</th>
</tr>
</thead>
<tbody>
<tr>
<td>isebrcon</td>
<td>Selects complete raster entities within a bitonal region.</td>
<td>Related topic: <em>Defining REM Enhanced Bitonal Regions</em> on page 178</td>
</tr>
<tr>
<td>isebrsmart</td>
<td>Selects complete raster entities within a bitonal region.</td>
<td>Related topic: <em>Defining REM Enhanced Bitonal Regions</em> on page 178</td>
</tr>
<tr>
<td>iselectall</td>
<td>Selects all raster entity manipulation (REM) objects in an image.</td>
<td>Related topic: <em>Editing REM Objects</em> on page 189</td>
</tr>
<tr>
<td>iselectallinsertions</td>
<td>Selects all the insertions.</td>
<td>Related topic: <em>Selecting an Image</em> on page 81</td>
</tr>
<tr>
<td>ishowimage</td>
<td>Displays an image that was hidden.</td>
<td>Related topic: <em>Showing and Hiding Images</em> on page 74</td>
</tr>
<tr>
<td>ishowinsertion</td>
<td>Shows the selected image.</td>
<td>Related topic: <em>Showing and Hiding Images</em> on page 74</td>
</tr>
<tr>
<td>isline</td>
<td>Converts a raster line entity to a line primitive.</td>
<td>Related topic: <em>Defining a REM Line Primitive</em> on page 182</td>
</tr>
<tr>
<td>issmooth</td>
<td>Smooths the raster linework of REM objects.</td>
<td>Related topic: <em>Smoothing REM Linework</em> on page 196</td>
</tr>
<tr>
<td>isnap</td>
<td>Specifies raster snap settings.</td>
<td>Related topic: <em>Raster Snapping</em> on page 239</td>
</tr>
<tr>
<td>ispolyreg</td>
<td>Selects all pixels within a defined polygonal region.</td>
<td>Related topic: <em>Defining a REM Polygonal Region</em> on page 172</td>
</tr>
<tr>
<td>isrectreg</td>
<td>Selects all pixels within a specified rectangular region.</td>
<td>Related topic: <em>Defining a REM Rectangular Region</em> on page 171</td>
</tr>
<tr>
<td>issmart</td>
<td>Converts a raster entity to the most applicable primitive type: line, arc, or circle.</td>
<td>Related topic: <em>Defining REM Primitive Objects</em> on page 180</td>
</tr>
<tr>
<td>itouchup</td>
<td>Opens the Touchup toolbar.</td>
<td>Related topic: <em>Touching Up an Image</em> on page 91</td>
</tr>
</tbody>
</table>
i transparent
Turns the background transparency on and off for REM objects.
Related topic: Using REM Background Transparency on page 202

i unembed
Un-embeds one or more images from the current drawing, asking you to specify where to save them.
Related topic: Embedding Images in a Drawing on page 44

i vmerge
Merges vectors into raster image.
Related topic: Merging Vectors into a Raster Image on page 164

i vseparation
Edits vector separation options.
Related topic: General Vector Separation Options on page 251

i worldout
Exports the correlation data for an image to a world file.
Related topic: Exporting a World File on page 54

i zoomtoinsertion
Zooms to the selected image.
Related topic: Zooming to an Image on page 69

r background
Selects an unused color for the transparent color.
Related topic: Unused Color for Transparent Color on page 65

r pens
Selects raster pen widths for vector merge.
Related topic: Selecting Pen Widths for Vector Merge on page 165

v arc
Creates a vector arc to match or replace a raster arc.
Related topic: Vectorizing Raster Arcs on page 217

v circle
Creates a vector circle to match or replace a raster circle.
Related topic: Vectorizing Raster Circles on page 215

v f3dpoly
Creates a 3D polyline
Related topic: Using the 3D Polyline Follower on page 225

v f contour
Converts a raster contour to a vector.
Related topic: Using the Contour Follower on page 222
vfpline  Converts a raster polyline to a vector.
Related topic: Following Polylines on page 219
vline    Converts raster lines to vector lines or polylines.
Related topic: Vectorizing Raster Lines and Polylines on page 209
vmtext   Creates a block of multiline vector text.
Related topic: Creating Multiline Vector Text on page 230
vpline   Converts raster lines to vector lines or polylines.
Related topic: Vectorizing Raster Lines and Polylines on page 209
vrect    Draws a vector rectangle to match or replace a raster rectangle.
Related topic: Vectorizing Raster Rectangles on page 214
vtext    Creates a line of vector text.
Related topic: Creating Single-Line Vector Text on page 228

**AutoCAD Commands for Images**

You can use standard AutoCAD commands to manage image frames. When you select a frame, you create an AutoCAD selection set that you can manipulate using any AutoCAD editing command, such as COPY, MOVE, or ROTATE.

When an AutoCAD command prompts you to select an object to edit, you can use any of the standard AutoCAD selection methods to select one or more image frames. When you select an image frame, **grip(s)** on page 392 are displayed on the image. Select one of the grips and right-click to display the AutoCAD shortcut menu, on which you can select a command. Or, you can use the grip editing commands to edit the image.

**NOTE** To select a command on the Raster Design shortcut menu, select an image (but do not select a grip) and then right-click.

AutoCAD also includes the following commands that you can use with Raster Design to adjust the display of your images:

- IMAGE. Attach, detach, load, unload, and save paths of images.
- IMAGEADJUST. Display the Image Adjust dialog box to modify the image brightness, contrast, and fade display qualities.

- IMAGEATTACH. Display the Image Attach dialog box, which you can use to insert an image.

- IMAGECLIP. Clip an image boundary to any polygonal shape. For more information, see Clipping an Image on page 144.

- IMAGEQUALITY. Specify whether to display the image in draft or high quality.

- IMAGEFRAME. Turn image frames off and on.

- BACKGROUND TRANSPARENCY. Turn background transparency off and on for an image.

For more information about AutoCAD commands, see the AutoCAD Help.

**Raster Menu**

The following table lists the commands on the Raster Design Raster menu, with descriptions and links to related dialog boxes or Help topics. This menu is only available when using the Map Classic Workspace.

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>New</td>
<td>Displays the New Image on page 344 dialog box.</td>
</tr>
<tr>
<td>Insert</td>
<td>Displays the Insert Image on page 340 dialog box that is used to insert images. See Inserting Images on page 11</td>
</tr>
<tr>
<td>Save</td>
<td>Saves an image without saving the drawing. See Saving an Image on page 41</td>
</tr>
<tr>
<td>Save As</td>
<td>Saves an image and allows you to change some attributes. See Saving an Image to Another File Name, Type, or Location on page 45</td>
</tr>
<tr>
<td>Export</td>
<td>Displays a submenu of commands used to export an image or a world file. See Exporting Images on page 50.</td>
</tr>
<tr>
<td>Manage</td>
<td>Displays the Image Manage toolspace that you use to access and manage image data. See Controlling the Image Manager Toolspace on page 67.</td>
</tr>
<tr>
<td>Menu Item</td>
<td>Description</td>
</tr>
<tr>
<td>----------------------</td>
<td>--------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Capture</td>
<td>Captures the current image. See Capturing an Image on page 49</td>
</tr>
<tr>
<td>Correlate</td>
<td>Displays a submenu of commands used to adjust an image by matching, moving, scaling, or rubbersheeting. See Correlating an Image After Insertion on page 30</td>
</tr>
<tr>
<td>Cleanup</td>
<td>Displays a submenu of commands used to clean up images and repair the effects of scanning mistakes and other imperfections. See Cleaning Up Images on page 84</td>
</tr>
<tr>
<td>Image Processing</td>
<td>Displays a submenu of commands used to enhance the appearance of your image or convert an image to a different image type. See Image Processing on page 93</td>
</tr>
<tr>
<td>Raster Entity Manipulation</td>
<td>Displays a submenu of commands used to define and manipulate raster objects. See Defining REM Region Objects on page 170</td>
</tr>
<tr>
<td>Mask</td>
<td>Displays a submenu of commands used to create, edit, and convert image masks. See Masking Images on page 138</td>
</tr>
<tr>
<td>Crop</td>
<td>Displays a submenu of commands used to crop images. Options are provided for cropping a line, a circular region, a rectangular region and a polygonal region. See Cropping Images on page 147</td>
</tr>
<tr>
<td>Remove</td>
<td>Displays a submenu of commands used to rub (remove) a raster line, multiple line segments, circles, arcs, or within a polygon, rectangle or diagonal region. See Removing (Rubbing) Images on page 151</td>
</tr>
<tr>
<td>Merge</td>
<td>Displays a submenu of commands used to merge images, merge vectors with raster data and select raster pen width. See Merging Objects on page 163.</td>
</tr>
<tr>
<td>Vectorization Tools</td>
<td>Displays a submenu of commands used to convert raster entities to vector. See Vectorizing Raster Geometry on page 208.</td>
</tr>
<tr>
<td>Text Recognition</td>
<td>Displays a submenu of commands used to convert raster text to vector text. See Recognizing and Converting Text on page 234.</td>
</tr>
</tbody>
</table>
Displays the Raster Snap tab where you can set the snapping mode. See Raster Snapping on page 239

**Toggle Frames**
Changes the visibility of the image frame. See Changing the Image Frame Visibility on page 244

**Toggle Quick Bar**
Changes the visibility of the Quick Bar. See Changing the Quick Bar Visibility on page 243

**Options**
Displays the Raster Design Options on page 353 dialog box used to Configure Raster Design.

**Raster Design Home Page**
Opens the Raster Design home page on the Internet if you have an Internet connection and browser.

**Help**
Displays the Raster Design Help.

**About Raster Design**
Displays Raster Design product and licensing information.

## Toolbars

Raster Design includes a number of toolbars. These toolbars are only available when using the Map Classic Workspace. To see the complete list of toolbars and to open any of them, right-click on an open toolbar and use the dropdown menu. This section describes the following toolbars:

- Raster Design Toolbar
- Raster Entity Manipulation Toolbar
- Raster Design Quick Bar

### Raster Design Toolbar

This toolbar is the largest one in Raster Design, and includes many drop-down menus of icons. This toolbar is only available when using the Map Classic...
Workspace. The following table shows the toolbar icons and their related commands and procedures.

<table>
<thead>
<tr>
<th>Toolbar Icon</th>
<th>Command-Line Command</th>
<th>Related Procedure</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>inew</td>
<td>Creating New Images on page 22</td>
</tr>
<tr>
<td></td>
<td>iinsert</td>
<td>Inserting Images on page 11</td>
</tr>
<tr>
<td>Save/Export</td>
<td>isave</td>
<td>Saving an Image on page 41</td>
</tr>
<tr>
<td></td>
<td>isaveas</td>
<td>Saving an Image on page 41</td>
</tr>
<tr>
<td></td>
<td>iexport</td>
<td>Exporting Images on page 50</td>
</tr>
<tr>
<td></td>
<td>iworldout</td>
<td>Exporting a World File on page 54</td>
</tr>
<tr>
<td></td>
<td>icapture</td>
<td>Capturing an Image on page 49</td>
</tr>
<tr>
<td>Correlate Tools</td>
<td>imatch</td>
<td>Correlating Images on page 23</td>
</tr>
<tr>
<td></td>
<td>idisplace</td>
<td>Matching Image Points on page 30</td>
</tr>
<tr>
<td></td>
<td>iscale</td>
<td>Correlating an Image After Insertion on page 30</td>
</tr>
<tr>
<td></td>
<td>irsheet</td>
<td>Scaling an Image on page 32</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Rubbersheeting an Image on page 33</td>
</tr>
<tr>
<td>Toolbar Icon</td>
<td>Command-Line Command</td>
<td>Related Procedure</td>
</tr>
<tr>
<td>--------------</td>
<td>----------------------</td>
<td>-------------------</td>
</tr>
<tr>
<td><img src="https://example.com/imanage.png" alt="imanage.png" /></td>
<td><code>imanage</code></td>
<td>Controlling the Image Manager Toolspace on page 67</td>
</tr>
<tr>
<td><img src="https://example.com/ideskew.png" alt="ideskew.png" /></td>
<td><code>ideskew</code></td>
<td>Deskewing an Image on page 85</td>
</tr>
<tr>
<td><img src="https://example.com/idespeckle.png" alt="idespeckle.png" /></td>
<td><code>idespeckle</code></td>
<td>Removing Speckles from an Image on page 86</td>
</tr>
<tr>
<td><img src="https://example.com/ibias.png" alt="ibias.png" /></td>
<td><code>ibias</code></td>
<td>Adjusting the Image Bias on page 88</td>
</tr>
<tr>
<td><img src="https://example.com/inverted.png" alt="inverted.png" /></td>
<td><code>inverted</code></td>
<td>Reversing the Light and Dark Shades in an Image on page 90</td>
</tr>
<tr>
<td><img src="https://example.com/imirror.png" alt="imirror.png" /></td>
<td><code>imirror</code></td>
<td>Mirroring an Image on page 90</td>
</tr>
<tr>
<td><img src="https://example.com/itouchup.png" alt="itouchup.png" /></td>
<td><code>itouchup</code></td>
<td>Touching Up an Image on page 91</td>
</tr>
<tr>
<td><img src="https://example.com/ihistogram.png" alt="ihistogram.png" /></td>
<td><code>ihistogram</code></td>
<td>Adjusting Images with the Histogram on page 94</td>
</tr>
<tr>
<td><img src="https://example.com/iconvolve.png" alt="iconvolve.png" /></td>
<td><code>iconvolve</code></td>
<td>Convolving an Image on page 107</td>
</tr>
<tr>
<td><img src="https://example.com/ibfilter.png" alt="ibfilter.png" /></td>
<td><code>ibfilter</code></td>
<td>Using Bitonal Filters on page 114</td>
</tr>
<tr>
<td><img src="https://example.com/idepth.png" alt="idepth.png" /></td>
<td><code>idepth</code></td>
<td>Setting the Color Depth for an Image on page 118</td>
</tr>
<tr>
<td>Toolbar Icon</td>
<td>Command-Line Command</td>
<td>Related Procedure</td>
</tr>
<tr>
<td>--------------</td>
<td>----------------------</td>
<td>-------------------</td>
</tr>
<tr>
<td></td>
<td>ipal</td>
<td>Using the Palette Manager on page 120</td>
</tr>
<tr>
<td></td>
<td>imask</td>
<td>Masking Images on page 138</td>
</tr>
<tr>
<td></td>
<td>imaskconvert</td>
<td>Converting a Mask to Image Clips on page 146</td>
</tr>
<tr>
<td></td>
<td>imaskedit</td>
<td>Changing an Existing Mask on page 141</td>
</tr>
<tr>
<td></td>
<td>icropline</td>
<td>Cropping Images on page 147</td>
</tr>
<tr>
<td></td>
<td>icropcirc</td>
<td>Line Cropping on page 147</td>
</tr>
<tr>
<td></td>
<td>icroprect</td>
<td>Circular Cropping on page 148</td>
</tr>
<tr>
<td></td>
<td>icropdiag</td>
<td>Rectangular Cropping on page 148</td>
</tr>
<tr>
<td></td>
<td>icroppoly</td>
<td>Polygonal Cropping on page 150</td>
</tr>
<tr>
<td></td>
<td>irubline</td>
<td>Removing (Rubbing) Images on page 151</td>
</tr>
<tr>
<td></td>
<td>irubcircle</td>
<td>Rubbing a Raster Circle on page 153</td>
</tr>
<tr>
<td>Toolbar Icon</td>
<td>Command-Line Command</td>
<td>Related Procedure</td>
</tr>
<tr>
<td>--------------</td>
<td>----------------------</td>
<td>--------------------</td>
</tr>
<tr>
<td><img src="image" alt="irubarc icon" /></td>
<td>irubarc</td>
<td>Rubbing a Raster Arc on page 152</td>
</tr>
<tr>
<td><img src="image" alt="irubpline icon" /></td>
<td>irubpline</td>
<td>Rubbing Multiple Line Segments on page 154</td>
</tr>
<tr>
<td><img src="image" alt="irubcirc icon" /></td>
<td>irubcirc</td>
<td>Rubbing Raster Data Within a Circular Region on page 155</td>
</tr>
<tr>
<td><img src="image" alt="irubrect icon" /></td>
<td>irubrect</td>
<td>Rubbing Raster Data Within a Rectangular Region on page 157</td>
</tr>
<tr>
<td><img src="image" alt="irubdiag icon" /></td>
<td>irubdiag</td>
<td>Rubbing Raster Data Within a Diagonal Region on page 156</td>
</tr>
<tr>
<td><img src="image" alt="irubpoly icon" /></td>
<td>irubpoly</td>
<td>Rubbing Raster Data Within a Polygonal Region on page 156</td>
</tr>
<tr>
<td><img src="image" alt="irmvexisting icon" /></td>
<td>irmvexisting</td>
<td>Remove Raster Using Existing Vector Geometry on page 158</td>
</tr>
<tr>
<td><img src="image" alt="idelsmart icon" /></td>
<td>idelsmart</td>
<td>Removing Raster Entities Using REM Commands on page 159</td>
</tr>
<tr>
<td><img src="image" alt="ideline icon" /></td>
<td>ideline</td>
<td>Removing a REM Line Primitive on page 160</td>
</tr>
<tr>
<td><img src="image" alt="idelcircle icon" /></td>
<td>idelcircle</td>
<td>Removing a REM Circle Primitive on page 162</td>
</tr>
<tr>
<td><img src="image" alt="idelarc icon" /></td>
<td>idelarc</td>
<td>Removing a REM Arc Primitive on page 161</td>
</tr>
</tbody>
</table>

Merge Tools
- ![iimerge icon](image) iimerge Merging Images on page 163
<table>
<thead>
<tr>
<th>Toolbar Icon</th>
<th>Command-Line Command</th>
<th>Related Procedure</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="ivmerge" /></td>
<td>ivmerge</td>
<td>Merging Vectors into a Raster Image on page 164</td>
</tr>
<tr>
<td><img src="image" alt="rpens" /></td>
<td>rpens</td>
<td>Selecting Pen Widths for Vector Merge on page 165</td>
</tr>
<tr>
<td><img src="image" alt="Vectorization Tools" /></td>
<td></td>
<td>Vectorizing Raster Geometry on page 208</td>
</tr>
<tr>
<td><img src="image" alt="vline" /></td>
<td>vline</td>
<td>Vectorizing Raster Lines and Polylines on page 209</td>
</tr>
<tr>
<td><img src="image" alt="vpline" /></td>
<td>vpline</td>
<td>Vectorizing Raster Lines and Polylines on page 209</td>
</tr>
<tr>
<td><img src="image" alt="vrect" /></td>
<td>vrect</td>
<td>Vectorizing Raster Rectangles on page 214</td>
</tr>
<tr>
<td><img src="image" alt="vcircle" /></td>
<td>vcircle</td>
<td>Vectorizing Raster Circles on page 215</td>
</tr>
<tr>
<td><img src="image" alt="varc" /></td>
<td>varc</td>
<td>Vectorizing Raster Arcs on page 217</td>
</tr>
<tr>
<td><img src="image" alt="vtext" /></td>
<td>vtext</td>
<td>Creating Single-Line Vector Text on page 228</td>
</tr>
<tr>
<td><img src="image" alt="vmtext" /></td>
<td>vmtext</td>
<td>Creating Multiline Vector Text on page 230</td>
</tr>
<tr>
<td><img src="image" alt="vfpline" /></td>
<td>vfpline</td>
<td>Following Polylines on page 219</td>
</tr>
<tr>
<td><img src="image" alt="vfcontour" /></td>
<td>vfcontour</td>
<td>Using the Contour Follower on page 222</td>
</tr>
<tr>
<td><img src="image" alt="vf3dpoly" /></td>
<td>vf3dpoly</td>
<td>Using the 3D Polyline Follower on page 225</td>
</tr>
</tbody>
</table>

**Recognize Text Tools**

<p>| | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Vectorizing Raster Text on page 227</td>
</tr>
<tr>
<td>Toolbar Icon</td>
<td>Command-Line Command</td>
</tr>
<tr>
<td>--------------</td>
<td>----------------------</td>
</tr>
<tr>
<td>icontext</td>
<td>icontext</td>
</tr>
<tr>
<td>icontable</td>
<td>icontable</td>
</tr>
<tr>
<td>icontsetup</td>
<td>icontsetup</td>
</tr>
<tr>
<td>icomap</td>
<td>icomap</td>
</tr>
<tr>
<td>icomal</td>
<td>icomal</td>
</tr>
<tr>
<td>icomq</td>
<td>icomq</td>
</tr>
<tr>
<td>icomv</td>
<td>icomv</td>
</tr>
<tr>
<td>icomx</td>
<td>icomx</td>
</tr>
<tr>
<td>icomh</td>
<td>icomh</td>
</tr>
</tbody>
</table>

**Raster Entity Manipulation Toolbars**

These toolbars are only available when using the Map Classic Workspace. For more information about raster entity manipulation, see Manipulating REM Objects on page 189.
## Raster Entity Manipulation Toolbar

<table>
<thead>
<tr>
<th>Toolbar Icon</th>
<th>Command-Line Command</th>
<th>Related Procedure</th>
</tr>
</thead>
<tbody>
<tr>
<td>ispolyreg</td>
<td></td>
<td>Defining a REM Polygonal Region on page 172</td>
</tr>
<tr>
<td>isebrsmart, w</td>
<td>smart</td>
<td>smart window on page 399</td>
</tr>
<tr>
<td>issmart</td>
<td></td>
<td>Defining REM Primitive Objects on page 180</td>
</tr>
<tr>
<td>iclear</td>
<td></td>
<td>Clearing REM Objects on page 199</td>
</tr>
<tr>
<td>iclearall</td>
<td></td>
<td>Clearing REM Objects on page 199</td>
</tr>
<tr>
<td>iseckall</td>
<td></td>
<td>Editing REM Objects on page 189</td>
</tr>
<tr>
<td>irefinemode</td>
<td></td>
<td>Resizing a REM Object on page 191</td>
</tr>
<tr>
<td>iremove</td>
<td></td>
<td>Using REM to Delete Raster Data on page 197</td>
</tr>
<tr>
<td>imergetoimg</td>
<td></td>
<td>Merging REM Objects into an Image on page 200</td>
</tr>
<tr>
<td>iconvtoimg</td>
<td></td>
<td>Converting REM Objects to a New Raster Image on page 201</td>
</tr>
<tr>
<td>itransparent</td>
<td></td>
<td>Using REM Background Transparency on page 202</td>
</tr>
<tr>
<td>ismooth</td>
<td></td>
<td>Smoothing REM Linework on page 196</td>
</tr>
<tr>
<td>Toolbar Icon</td>
<td>Command-Line Command</td>
<td>Related Procedure</td>
</tr>
<tr>
<td>--------------</td>
<td>----------------------</td>
<td>--------------------</td>
</tr>
<tr>
<td></td>
<td>icopyss</td>
<td>Using REM Copy To Clipboard Command on page 202</td>
</tr>
<tr>
<td></td>
<td>iknife</td>
<td>Separating Raster Linework Using Knife on page 203</td>
</tr>
</tbody>
</table>

**REM Regions Toolbar**

<table>
<thead>
<tr>
<th>Toolbar Icon</th>
<th>Command-Line Command</th>
<th>Related Procedure</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>REM Region Tools</td>
<td>Defining REM Region Objects on page 170</td>
</tr>
<tr>
<td></td>
<td>ispolyreg</td>
<td>Defining a REM Polygonal Region on page 172</td>
</tr>
<tr>
<td></td>
<td>isrectreg</td>
<td>Defining a REM Rectangular Region on page 171</td>
</tr>
<tr>
<td></td>
<td>isdiagreg</td>
<td>Defining a REM Diagonal Region on page 173</td>
</tr>
<tr>
<td></td>
<td>iscircreg</td>
<td>Defining a REM Circular Region on page 174</td>
</tr>
<tr>
<td></td>
<td>iregfromvec</td>
<td>Defining a Region From an Existing Vector Object on page 176</td>
</tr>
</tbody>
</table>

**REM Enhanced Bitonal Regions Toolbar**

<table>
<thead>
<tr>
<th>Toolbar Icon</th>
<th>Command-Line Command</th>
<th>Related Procedure</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>REM Enhanced Bitonal Region Tools</td>
<td>Defining REM Enhanced Bitonal Regions on page 178</td>
</tr>
<tr>
<td></td>
<td>isebrsmart, w</td>
<td>smart window on page 399</td>
</tr>
<tr>
<td>Toolbar Icon</td>
<td>Command-Line Command</td>
<td>Related Procedure</td>
</tr>
<tr>
<td>--------------</td>
<td>----------------------</td>
<td>----------------------------</td>
</tr>
<tr>
<td></td>
<td>isebrsmart, c</td>
<td>smart crossing window</td>
</tr>
<tr>
<td></td>
<td>isebrsmart, wp</td>
<td>smart window polygon</td>
</tr>
<tr>
<td></td>
<td>isebrsmart, cp</td>
<td>smart crossing polygon</td>
</tr>
<tr>
<td></td>
<td>isebrsmart, f</td>
<td>smart fence on page 399</td>
</tr>
<tr>
<td></td>
<td>isebrcon, e</td>
<td>connected entity on page 387</td>
</tr>
<tr>
<td></td>
<td>isebrcon, w</td>
<td>connected window on page 388</td>
</tr>
<tr>
<td></td>
<td>isebrcon, wp</td>
<td>connected window polygon</td>
</tr>
<tr>
<td></td>
<td>isebrcon, cp</td>
<td>connected crossing polygon</td>
</tr>
<tr>
<td></td>
<td>isebrcon, f</td>
<td>connected fence on page 387</td>
</tr>
</tbody>
</table>

**REM Primitives Toolbar**

<table>
<thead>
<tr>
<th>Toolbar Icon</th>
<th>Command-Line Command</th>
<th>Related Procedure</th>
</tr>
</thead>
<tbody>
<tr>
<td>REM Primitive Tools</td>
<td>issmart</td>
<td>Defining REM Primitive Objects on page 180</td>
</tr>
<tr>
<td></td>
<td>isline</td>
<td>Defining a REM Line Primitive on page 182</td>
</tr>
</tbody>
</table>

Raster Entity Manipulation Toolbars | 299
<table>
<thead>
<tr>
<th>Toolbar Icon</th>
<th>Command-Line Command</th>
<th>Related Procedure</th>
</tr>
</thead>
<tbody>
<tr>
<td>![iscircle icon]</td>
<td>iscircle</td>
<td>Defining a REM Circle Primitive on page 183</td>
</tr>
<tr>
<td>![isarc icon]</td>
<td>isarc</td>
<td>Defining a REM Arc Primitive on page 185</td>
</tr>
<tr>
<td>![iprimfromvec icon]</td>
<td>iprimfromvec</td>
<td>Defining a REM Primitive From Existing Vectors on page 187</td>
</tr>
</tbody>
</table>

### REM Operations Toolbar

<table>
<thead>
<tr>
<th>Toolbar Icon</th>
<th>Command-Line Command</th>
<th>Related Procedure</th>
</tr>
</thead>
<tbody>
<tr>
<td>![ismooth icon]</td>
<td>issmooth</td>
<td>Smoothing REM Linework on page 196</td>
</tr>
<tr>
<td>![itrim icon]</td>
<td>itrim</td>
<td>Trimming and Extending REM Lines on page 193</td>
</tr>
<tr>
<td>![iextend icon]</td>
<td>iextend</td>
<td>Trimming and Extending REM Lines on page 193</td>
</tr>
<tr>
<td>![ifillet icon]</td>
<td>ifillet</td>
<td>Filleting REM Lines on page 194</td>
</tr>
<tr>
<td>![ioffset icon]</td>
<td>ioffset</td>
<td>Offsetting REM Objects on page 195</td>
</tr>
</tbody>
</table>

### The Quick Bar

The Raster Design Quick Bar provides quick access to the settings you use most often while performing REM or VTools operations. This toolbar is only available when using the Map Classic Workspace.
The following settings can be toggled on and off on the Quick Bar:

<table>
<thead>
<tr>
<th>Toolbar Icon</th>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>🖼️</td>
<td>Raster Snap</td>
<td>Enables raster snap which allows you to snap to raster objects.</td>
</tr>
<tr>
<td>🕰️</td>
<td>Raster Snap Center</td>
<td>Snaps to the center of a raster line. The entire width of the line must be in the snap window.</td>
</tr>
<tr>
<td>✍️</td>
<td>Raster Snap End</td>
<td>Snaps to the end of a raster line. Note: When a line ends because it intersects with another line, this is considered an intersection, not an end point.</td>
</tr>
<tr>
<td>🪐</td>
<td>Raster Snap Corner</td>
<td>Snaps to the intersection of two raster lines.</td>
</tr>
<tr>
<td>🪔</td>
<td>Raster Snap Intersection</td>
<td>Snaps to the intersection of 3 or more raster lines. The entire intersection must be in the snap window.</td>
</tr>
<tr>
<td>🕯️</td>
<td>Raster Snap Edge</td>
<td>Snaps to the edge of a raster line. Any part of the raster line can be in the snap window.</td>
</tr>
<tr>
<td>🔸</td>
<td>Stop at Raster Intersections</td>
<td>When using one of the follower tools, such as the polyline follower or the contour follower, this setting causes the follower to stop at all raster intersections.</td>
</tr>
<tr>
<td>🔸</td>
<td>Stop at Vector Intersections</td>
<td>When using one of the follower tools, such as the polyline follower or the contour follower, this setting causes the follower to stop at all vector intersections.</td>
</tr>
</tbody>
</table>

For information on turning the Quick Bar on or off, see Changing the Quick Bar Visibility on page 243.
Use the following links to access information about the AutoCAD Raster Design dialog boxes.

**About AutoCAD Raster Design Box**
This dialog box displays information about AutoCAD Raster Design. Copyright information and product information is displayed. Product information includes the version number and service pack, serial number, license type and expiration date, and the text of the license agreement. You can save the product information as a text file.

**Assign Multispectral Band Dialog Box**
Use this dialog box to select a single band from a multispectral set to display as a grayscale image.
Use the dropdown list to select the data band.

**Band Assignment Color Map Dialog Box**
Use this dialog box to create or edit a color map for a multispectral image.
Use the lists for Red, Green, and Blue to specify a data band to display with each color channel.
If you want to turn off a color channel, clear the check box for that color.
If you do not want to display the image upon insertion, clear the Insert Into Display check box.
Related procedures:
- Assigning a Color Map to an Image on page 20

Bitonal Filters Dialog Box

Use this dialog box to access the different filter types.

You can use these filters in conjunction with other cleanup options, such as Despeckle and Deskew.

**Filter Type**

- **Smooth**
  - Removes unnecessary pixels from the edges of raster objects, fills holes in raster lines, and removes speckles from the raster image.

- **Thin**
  - Trims raster objects by one pixel (per pass) in the directions you specify.

- **Thicken**
  - Thickens the edges of raster objects by one pixel (per pass) in the directions you specify.

- **Separate**
  - Separates raster lines that are partially merged to prevent Raster Design from converting them into one thick line.

- **Skeletonize**
  - Thins all raster data to a thickness of one pixel.

**Number of Passes**

- Specifies the number of times the filter runs. For example, a pass value of 3 is equivalent to running the filter 3 times.

**Directions**

- **Horizontal**
  - Specifies that the filter follows in a horizontal direction.

- **Vertical**
  - Specifies that the filter follows in a vertical direction.

- **Diagonal**
  - Specifies that the filter follows in a diagonal direction.
Related procedures:

- Using Bitonal Filters on page 114

Change Density Dialog Box

Use this dialog box to change the pixel density of an image or change the resampling method.

Current Settings

- Displays existing pixel density, pixel size, and image dimensions

New Settings

Density

- Specifies the pixel density (pixels/inch) and pixel size (inches/pixel). You can change either one of these values, and it automatically changes the other value as well as the image dimensions.

Resampling Method

- Select the method to use for resampling image data when changing image density:
  - bicubic on page 384
  - bilinear on page 384
  - Lanczos on page 393
  - Mitchell on page 394
  - nearest neighbor on page 395

Related procedures:

- Changing Image Density on page 117

Choose a New Directory Dialog Box

Use this dialog box to specify a different directory path to the image.

You may want to do this if you know the location of a more suitable copy of the image. The location of the current image is specified as Active Path in the item view of Image Manager.

Look In

- Specifies the current directory path to the image. If you want to change it, use the arrow beside this field, in combination with the file list in the Name column, to navigate to a different directory.
Choose a Resource File Directory Dialog Box

Use this dialog box to specify a default directory for image correlation data. It is recommended that you specify the same default directory for both the read path and the write path. These paths are specified on the Paths tab on page 357 of the Raster Design Options dialog box.

Look In
Specifies the default directory for image correlation data. If you want to change it, use the arrow beside this field, in combination with the file list in the Name column, to navigate to a different directory.

Back
Returns to the previous folder.
Up One Level
Navigates up one level in the directory tree.

Search The Web
Displays the AutoCAD Web browser, with which you can specify an Internet location.

Delete
Deletes the selected file.

Create New Folder
Creates a new, unnamed folder.

Views
Specifies how files are displayed.

Tools
Provides options for finding files, adding or modifying an FTP site, or saving a shortcut to the current folder.

Places List
Displays shortcut icons to locations such as the desktop, FTP, and Buzzsaw.com.

Name
Specifies the directories and files within the directory in the Look In field.

Related procedures:
- Correlation Search Paths on page 249

Coordinate System Assignment Dialog Box
Use this dialog box to specify a coordinate system for an exported GeoTIFF image data file.

If the image was inserted with GeoTIFF correlation and no coordinate transformation, a default GeoTIFF code is displayed. Otherwise, you can choose whether or not to assign a coordinate system to the image.

If you want to specify no coordinate system, leave the Code field blank.

If Raster Design is running on AutoCAD Map, and a coordinate system is specified within the Map drawing, the applicable code and description are displayed to assist you in identifying the comparable GeoTIFF code.
**File Horizontal Coordinate System**

**Code**

The GeoTIFF code that identifies a coordinate system for the image.

**Select**

Opens the Select Coordinate System on page 371 dialog box where you can select a code by name, based on the region where it is used.

**Properties**

Opens the GeoTIFF Coordinate System Properties on page 317 dialog box to display the detailed properties of the coordinate system specified by the GeoTIFF code.

**Name**

Specifies the name of the coordinate system referenced by the GeoTIFF code.

**Area of Use**

Specifies the geographic region in which the coordinate system is used.

**Citation**

Specifies additional details about the coordinate system. You can add notes here.

**File Vertical Datum**

This section is displayed only if you are exporting a digital elevation model (DEM).

**Code**

Specifies the datum for elevation values in the DEM file.

**Vertical Units**

Specifies Feet or Meters as the unit of vertical measure. The current setting in the DEM is shown here. You can convert the exported file to the other unit by changing this setting.

**Drawing Coordinate System**

**Code**

The code used by AutoCAD Map 3D to identify the coordinate system for the drawing.

**Properties**

Displays additional technical details about the coordinate system.
Description
Specifies basic information about the coordinate system.

Data Organization Dialog Box
Use this dialog box to specify how to organize the data in an exported image.
Click Monolithic for small images, and either Tiled or Stripped for large images.

Despeckle Dialog Box
Use this dialog box to clean up a bitonal image by removing stray pixels, often called “speckles.”
In this dialog box, use AutoCAD units to specify the size of the speckles you want to remove.

Despeckle Options
Speckle Size
Specifies the speckle size (in AutoCAD units) you want to remove. When determining the best size to use, note that a size too large may remove parts of text, such as periods or the dots of the letter “i.”

Pick
Pick two points to draw a window around a speckle that is the largest size you want to remove.

Related procedures:
■ Removing Speckles from an Image on page 86

Display Manager Raster Layer Capture Dialog Box
Use this dialog box in AutoCAD Map 3D to capture image data from a layer in Display Manager.
In this dialog box, you can specify whether to capture the source data or the stylized version.
What to Capture
Specifies whether to capture the Stylized Display data as shown on the screen, or the Source Data, without stylization.
Area for Capture Defined By
   Specifies how the capture extents are defined:
   ■ Display – the extents of the current display
   ■ Layer Extents – the full extents of the layer in Display Manager including all available images
   ■ Window – the extents will be defined by a window that you draw on the screen

Capture Resolution
   Display
      Specifies that the capture will have the same resolution as the current display.
   Source
      Specifies that the capture will use the resolution, units, and scale of the source image. This option is unavailable if the layer includes images of different resolutions, or if the source has no set resolution.
   Custom
      Specifies that you will enter numeric resolution data in one of the boxes to the right.

Coordinate Transform
   Specifies the type of transformation:
   ■ Affine – the same correlation as displayed in AutoCAD Map 3D.
   ■ True – this option produces a more accurate result if coordinate transformation is performed in AutoCAD Map 3D; otherwise, produces the same results as Affine.
   ■ None – the correlation is the same as when using Raster Design Quick Insert with the source image.

Related procedures:
   ■ Capturing an Image on page 49

Drafting Settings Dialog Box
   Use this dialog box to set controls for Raster Snap, Object Snap, Polar Tracking, Snap and Grid, and AutoCAD Options.
The Raster Snap on page 311 tab is specific to Raster Design. Three other tabs (Object Snap, Polar Tracking, Snap and Grid) are AutoCAD standards and link to the AutoCAD Help system.

The Options button opens the AutoCAD Options dialog box where the Drafting tab lets you set the AutoSnap Marker Size and Aperture Size. All controls in this dialog box are explained in the AutoCAD Help system.

**Raster Snap Tab (Drafting Settings Dialog Box)**

Use this tab to turn Raster Snap on or off and to control its behavior.

You can use the raster snap modes to help you trace a bitonal raster entity with the vectorization tools, to help you select raster objects for rubbing and cropping, and to help you select raster objects for Raster Entity Manipulation.

**Raster Snap Modes**

Snap modes determine where your cursor will snap to as you move it around the image. If you choose more than one snap mode, then the crosshairs snap to the closest snap points. When the crosshairs snap to a point you want to select, pick the point.

**Center**

Snaps to the center of a raster line. The entire width of the line must be in the aperture (snap window).

**End**

Snaps to the end of a raster line.

**NOTE** When a line ends where it intersects another line, this is considered an intersection, not an end point.

**Corner**

Snaps to the intersection of two lines.

**Intersection**

Snaps to the intersection of three or more raster lines. The entire intersection must be in the snap window.

**Edge**

Snaps to the edge of a raster line. Any part of the raster line can be in the snap window.
Preferences

Show Aperture
Displays the aperture on page 383 while using raster snap.

Aperture Size
Specifies a size for the aperture in pixels. The maximum size is 300 pixels. Where raster entities are close together, a large aperture can make it difficult to select specific entities when several entities are inside the aperture.

**NOTE** Aperture is defined in image pixels, not screen pixels, so the size of the aperture changes with the zoom level. Therefore, if you are at the extents of an image and the aperture is 10 pixels, the window may appear small. However, if you zoom in, the same aperture appears larger.

Raster Snap Overrides
When Raster Snap is active, it takes priority over any cursor control mode selected here.

Snap
Raster Snap overrides the AutoCAD SNAP command.

Polar Tracking
Raster Snap overrides the AutoCAD Polar Tracking feature.

Ortho
Raster Snap overrides the AutoCAD ORTHO command.

Options
Displays the Drafting tab on the AutoCAD Options dialog box. In this dialog box, you can define your AutoSnap Marker Size and your Aperture Size.

See AutoCAD Help for further information about the AutoCAD Options dialog box.

Related procedures:
- Raster Snapping on page 239

Edit Status Dialog Box
Use this dialog box to see any restrictions on how an image can be edited and saved.
If you select an image that is not editable or that you cannot save to disk, then the Edit Status dialog box is displayed.

**Edit Status Options**

**Image Name**

Lists the name(s) of the image(s) you selected.

- ![Checkmark] Indicates that you can edit the image and the edits can be saved to the image file.
- ![No Entry] Indicates that you can edit the image, but the edits cannot be saved to the original image file. You need to save the image to another filename in order to save your edits. For more information, see Saving an Image to Another File Name, Type, or Location on page 45.
- ![Checkmark] Indicates that you cannot edit the image. You can click the Information>> button to find out how you can edit the image.
- ![No Entry] Indicates that you cannot edit or save the image. Click the Information>> button to find out how to edit and save the image.

**Image Status**

Describes why you can or cannot edit the image.

**Information>>**

Displays instructions for editing or saving the image.

---

**Encoding Method Dialog Box**

Use this dialog box to specify how to encode and compress an exported image.

A compressed file requires less storage space and less transmission time when sending across a network. Depending on file type, different encoding options can be presented here, including “uncompressed”. Click on each method to see a description of it.

**Export Dialog Box**

Use this dialog box to save a file and control the location, format, and name.
Exporting is the only way to save some file types, such as multispectral image data and digital elevation models (DEM). If you are exporting multispectral data, the dialog box is titled Multispectral Export, and the export process saves each band file as a separate GeoTIFF image.

**Save In**
- Specifies the folder where the exported file is saved.

**Back**
- Returns to the previous folder.

**Up One Level**
- Navigates up one level in the directory tree.

**Search the Web**
- Displays the AutoCAD Web browser, where you can specify an Internet location and select drawing content to display in the AutoCAD Design Center palette.

**Delete**
- Deletes the selected file.

**Create New Folder**
- Creates a new, unnamed folder.

**Views Menu**
- Switches between List, Detail, and Thumbnails views.

**Tools Menu**
- Finds files, adds or modifies FTP sites, or adds a shortcut to the current folder in the Favorites folder.

**Places List**
- Displays shortcut icons to locations such as the desktop and the Favorites folder.

**File Name/Base Name**
- Specifies the name of the exported file.
  - This field is called Base Name on the Multispectral Export dialog.

**Files of Type**
- Specifies the file format of the exported file.

**Related procedures:**
- [Exporting Images](#) on page 50
Export Options Dialog Box

Use this dialog box to control the format and metadata of an exported image.

When you export an image, you can create a resource file or a world file for the image. These correlation files store insertion point, scale, rotation, and density information for the image.

You can use the resource file option to share images with other people using Raster Design, or to use the image in another drawing. You can use the world file option to create a world file (which is an ASCII file you can view using Notepad) for use in Raster Design or other software programs.

Maintain Drawing Link To Image

Selected: The exported image replaces the original image in the drawing.
Cleared: Saves the exported image to disk and keep the original image in the drawing.

Image Rotation Handling

Burn Rotation Into Image

Saves the current image alignment and resets the rotation value to 0.

Include Rotation In Correlation

Saves the current image alignment as a rotation value.

Output Without Rotation

Saves no rotation value. This option is selected and unchangeable if the image is not rotated in the drawing.

Correlation

Select Correlation Output Type(s)

Specifies one or more types of correlation files to create. You can choose Resource File to create a resource file on page 397. You can also choose World File to save a world file on page 402. Both Resource files and World files are saved to the path you specify in the Raster Design Options on page 353 dialog box. If no correlation search path is designated, Raster Design uses the folder where the image is stored.

In two cases, an option here is preset and unchangeable. If you are exporting a multispectral image, GeoTIFF is specified. If you are exporting a DEM in DEM format, DEM File is specified.

Related procedures:

- Correlation Output Types on page 56
Export Palette Dialog Box

Use this dialog box to save your changes to the current palette for use with another image.

**Export Options**

- **Save In**
  - Specifies the folder where the exported palette is saved.

- **Back**
  - Returns to the previous folder.

- **Up One Level**
  - Navigates up one level in the directory tree.

- **Search The Web**
  - Displays the AutoCAD Web browser, where you can specify an Internet location to save the palette file.

- **Delete**
  - Deletes the selected file.

- **Create New Folder**
  - Creates a new, unnamed folder.

- **Views Menu**
  - Switches between List and Detail views.

- **Tools Menu**
  - Adds or modifies an FTP site or adds a shortcut to the current folder in the Favorites folder.

- **Places List**
  - Displays shortcut icons to locations such as the desktop, FTP, Buzzsaw.com, and so on.

- **File Name**
  - Specifies the name of the exported palette file.

- **Files Of Type**
  - Specifies the file format of the exported file.

- **Palette Title**
  - Adds a title to palette file header.
GeoTIFF Coordinate System Properties Dialog Box

Use this dialog box to see detailed properties of the GeoTIFF coordinate system specified in the Coordinate System Assignment dialog box.

The Projection properties are in one of two formats, depending on whether the coordinate system type is geographic or projected.

Grid Parameters Dialog Box

Use this dialog box when rubbersheeting to establish a grid of destination points, to which you match source points.

Once these control points are established, the image is transformed so that the points align as closely as possible.

**NOTE** When you pick points in the drawing, you can press Enter to return to the Grid Parameters dialog box.

**Points**

**Rows**

Specifies the number of rows to place in the grid.

**Columns**

Specifies the number of columns to place in the grid.

**Total**

Displays the total number of points in the grid.

**Grid**

**X Origin**

Specifies the X coordinate of the grid origin.

**Y Origin**

Specifies the Y coordinate of the grid origin.
Pick
  Specifies the grid origin directly in the drawing.

Cell
X Size
  Specifies the distance between columns.

Y Size
  Specifies the distance between rows.

Pick
  Specifies the cell size by clicking two points directly in the drawing.

Preview
  Displays a preview of the grid in the drawing.

Add Points
  Creates a grid of destinations according to the values you specify by matching source points to destination points.

Related procedures:
  ■ Rubbersheeting an Image on page 33

Histogram Dialog Box
  Use this dialog box to adjust image quality or to convert images to grayscale or bitonal format.

Brightness/Contrast Tab (Histogram Dialog Box)
  Use this tab to adjust the brightness and contrast of color and grayscale images.

Brightness
  You can move the slider to the right to increase the brightness or the left to decrease brightness.
  In color images, increasing brightness causes colors to become lighter shades. In grayscale images, increasing brightness causes more grays to become white.
  In color images, decreasing brightness causes colors to become darker. In grayscale images, decreasing brightness causes more grays to become black.
Contrast
You can move the slider to the right to decrease the tonal gradation or to the left to increase the tonal gradation between the highlights, midtones, and shadows in an image.
When contrast is increased to an extreme in a grayscale image, the shades of gray can be polarized to just black and white. In a color image, an extreme increase in contrast causes the selected color channel to become more prominent. For example, if the selected color channel is red, then more shades of red appear in the image.

RGB
Specifies the color channel to change in a color image. For a grayscale image, you can change only RGB, which represents the gray channel.

Index
Displays an index for a shade of the color channel that is currently selected. When you place your pointer over a bar in the histogram, the Index value displays the intensity of the shade that the bar represents (0 to 255).

Freq
Display a frequency value for a shade of the color channel that is currently selected. When you place your pointer over a bar in the histogram, the Freq value displays the number of pixels in the image that are the shade that the bar represents. If you selected a grayscale image, then this value represents the number of pixels that are the shade that corresponds to the bar. If you selected a color image, and you choose a color channel, then the frequency value represents the number of pixels that are the shade of the selected color channel.

Apply Changes To
- **Entire Image.** Applies the changes to the selected image.
- **Sub-Region.** Applies the changes to the sub-region only.

Sub-Region Options
Displays palette options for sub-regions associated with an Index Color (8-bit) on page 393 image:
- **Retain Current Palette.** Applies your changes to the sub-region by mapping to the closest colors from the current palette. This option maintains the current palette and does not affect pixels outside the selected region.
■ **Rebuild Palette With All Colors.** Creates a new palette to best accommodate all colors in the entire image. Because this image changes the palette, pixels inside and outside the sub-region may be affected by this option.

■ **Rebuild Palette With New Colors.** Also creates a new palette, but this option guarantees that colors in the sub-region are included in the palette by giving preference to those pixels over pixels outside the sub-region. Because this image changes the palette, pixels outside the sub-region may be affected by this option.

**Apply**
Changes the color values in the image file and generates a new histogram that reflects the changes.

**Reset Controls**
Resets the brightness and contrast on all of the color channels to zero.

**NOTE** If you have already clicked Apply, clicking Reset Controls does not undo your changes. To undo your changes, exit the dialog box and use the UNDO command.

**Preview**
Displays a preview of the image showing the modifications. Click an image name to view the preview for that image. Histogram changes apply to all images you have selected, not just to the image that is currently previewed. This preview does not show any display-only adjustments you may have made to the image using the AutoCAD IMAGEADJUST command. If you apply changes to the image using the Histogram, then all display-only adjustments are reset to the defaults.

**Related procedures:**
■ Adjusting Images with the Histogram on page 94

---

**Equalize Tab (Histogram Dialog Box)**

Use this tab to maximize the details in an image that has a large percentage of pixels that are approximately the same color. Equalization changes the darkest pixels to black and the lightest pixels to white and then reassigns the
remaining pixels to use all of the colors in between. This is also known as a non-linear contrast stretch.

You can equalize a grayscale image or a color image. When you equalize a color image, you have the option of selecting which color channel you want to equalize. For example, if you have an image that is composed of mostly red shades, then you can select the red channel and equalize only that channel, spreading out the red values so there is greater contrast.

**Equalize Tab Options**

**Index**
Displays the intensity of each shade on the histogram (0 to 255). For a grayscale image, all channels have the same values. If you select the Red, Green, or Blue channel when you are equalizing a color image, the index number is the intensity of that color within a pixel.

**Freq**
Displays the number of pixels within an image of a selected Index value.

**Apply Changes To**
- **Entire Image.** Applies the changes to the selected image.
- **Sub-Region.** Applies the changes to the sub-region only.

**Sub-Region Options**
Contains palette options for sub-regions associated with an Index Color (8-bit) on page 393
- **Retain Current Palette.** Applies your changes to the sub-region by mapping to the closest colors from the current palette. This option maintains the current palette and does not affect pixels outside the selected region.
- **Rebuild Palette With All Colors.** Creates a new palette to best accommodate all colors in the entire image. Because this image changes the palette, pixels inside and outside the sub-region may be affected by this option.
- **Rebuild Palette With New Colors.** Also creates a new palette, but this option guarantees that colors in the sub-region are included in the palette by giving preference to those pixels over pixels outside the sub-region. Because this image changes the palette, pixels outside the sub-region may be affected by this option.
Apply
Equalizes the image and creates a new histogram that reflects the changes.

RGB
Specifies the color image. You can select the Red, Green, or Blue channel, or the combined RGB channel. For a grayscale image, you can only select the RGB channel.

Preview
Displays a preview of the image showing the modifications. Click an image name to view the preview for that image. Histogram changes apply to all images you have selected, not just to the image that is currently previewed. This preview does not show any display-only adjustments you may have made to the image using the AutoCAD IMAGEADJUST command. If you apply changes to the image using the Histogram command, then all display-only adjustments are reset to the defaults.

Related procedures:
■ Maximizing Details in an Image on page 98

Threshold Tab (Histogram Dialog Box)

Use this tab to convert a grayscale or color image to a simpler black and white bitonal image. This operation can be used to isolate features in an image. For example, you can isolate the contour lines from a grayscale scan of a USGS map.

After the grayscale or color image is converted to a bitonal image, you can use the vectorization tools to convert the raster objects to vectors.

Threshold
Displays which pixels are black and which pixels are white. After you move the slider, all pixels to the left of the slider become black and all pixels to the right of the slider become white.

Apply
Converts the selected grayscale or color image to a black and white bitonal image.

Preview
Displays a preview of the image showing the modifications.
Click an image name to view the preview for that image. Histogram changes apply to all images you have selected, not just to the image that is currently previewed.

This preview does not show any display-only adjustments you may have made to the image using the AutoCAD IMAGEADJUST command. If you apply changes to the image using the Histogram, then all display-only adjustments are reset to the defaults.

Related procedures:

- Converting a Grayscale or Color Image to Bitonal on page 102

**Color to Grayscale Tab (Histogram Dialog Box)**

Use this tab to convert a color image to an 8-bit grayscale image. This is useful if you want to reduce the amount of disk space the image requires. By converting a color image to grayscale, you can also take advantage of the smoothing filters on page 400 or sharpening filters on page 398 to work on the image details.

**RGB**

Specify a channel from this list for the conversion value. You can select RGB, or you can select the Red, Green, or Blue channel.

If you select RGB, then the values for red, green, and blue components of each pixel in the image are added together and divided by three to achieve the grayscale value.

If you select Red, Green, or Blue, then the Color to Grayscale operation uses the value for just that channel to determine the grayscale value.

**Apply**

- Converts the selected color image(s) to grayscale.

**Preview**

Displays a preview of the image showing the modifications.

Click an image name to view the preview for that image. Histogram changes apply to all images you have selected, not just to the image that is currently previewed.

This preview does not show any display-only adjustments you may have made to the image using the AutoCAD IMAGEADJUST command. If you apply changes to the image using the Histogram, then all display-only adjustments are reset to the defaults.
Related procedures:
- Converting a Color Image to Grayscale on page 100

**Tonal Adjustment Tab (Histogram Dialog Box)**

Use this tab to increase the detail in one part of the contrast curve without changing the detail in other parts.

**RGB**
- Specifies the Red, Green, or Blue channel, or the combined RGB channel. For a grayscale image, you can only select the RGB channel.

**Vertical Scale slider**
- Zooms in on the histogram. As you move the slider upward, the scale is increased so that low frequency values become more visible and the highest frequency values become truncated by the top of the window.

**Contrast Curve Window**
- Displays the contrast curve. If you are using a fitted curve or piecewise linear curve, you can click and drag the curve's points and segments to edit the curve. You can also right-click to control the appearance of the grid, import and export curves, or reset the values. You can right-click on a point to delete the point.

**Select Curve Type**
- Specifies the contrast curve representation in three ways:
  - **Gamma** correction curves result in an exponential curve. It is defined by either specifying the single exponent (gamma) value or using an interactive slider.
  - **Fitted** curves are drawn smoothly through points you specify. Points can be added or removed from the curve, or dragged to modify the shape of the curve.
  - **Piecewise Linear** curves are constructed of points you add or modify. Each segment between points is a straight line instead of a curve.

**Black**
- Specify a value in the text box, or move the black clipping slider, to adjust the point below which color values are displayed as black.
Gamma
Specifies the gamma value for the curve. The maximum value of 10 is the equivalent of moving the Gamma slider to the far left. The minimum value of 0.1 is the equivalent of moving the Gamma slider to the far right.

White
Specify a value in the text box, or move the white clipping slider, to adjust the point above which color values are displayed as white.

Import
Imports a curve as a Gamma Point List (*.gpl) file.

Export
Exports a curve as a Gamma Point List (*.gpl) file.

Preview
Displays a preview of the image showing the modifications. Click an image name to view the preview for that image. Histogram changes apply to all images you have selected, not just to the image that is currently previewed. This preview does not show any display-only adjustments you may have made to the image using the AutoCAD IMAGEADJUST command. If you apply changes to the image using the Histogram, then all display-only adjustments are reset to the defaults.

Apply
Adjusts the contrast curve for the image and creates a new histogram that reflects the changes.

Apply Changes To
- **Entire Image.** Applies the changes to the selected image.
- **Sub-Region.** Applies the changes to the sub-region only.

Sub-Region Options
Contains palette options for sub-regions associated with an Index Color (8-bit) on page 393
- **Retain Current Palette.** Applies your changes to the sub-region by mapping to the closest colors from the current palette. This option maintains the current palette and does not affect pixels outside the selected region.
- **Rebuild Palette With All Colors.** Creates a new palette to best accommodate all colors in the entire image. Because this image changes
the palette, pixels inside and outside the sub-region may be affected by this option.

- **Rebuild Palette With New Colors.** Also creates a new palette, but this option guarantees that colors in the sub-region are included in the palette by giving preference to those pixels over pixels outside the sub-region. Because this image changes the palette, pixels outside the sub-region may be affected by this option.

**Related procedures:**
- **Making Tonal Adjustments to an Image** on page 103

### Image Data Properties Dialog Box

Use this dialog box to review and edit the properties of an image data definition, band group, or data band, depending on which object type you have selected.

For an image data definition, you can edit the reference name if it is a Raster Design custom image type (single-band integer, floating-point digital elevation model, or multiband multispectral).

For a data band group, you can edit the name of the band group.

For an individual data band, you cannot edit any of the data.

For multispectral bands that use 16- or 32-bit integer data, the original data is converted to 8-bit format for display purposes. Conversion uses the most significant bits (MSB) bit-mapping method, which discards the three least significant bits.

### Image Filters Dialog Box

Use this dialog box to improve the appearance of grayscale images by smoothing or sharpening the detail.

Raster Design provides smoothing filters on page 400 and sharpening filters on page 398.

**Image Filters Options**

- **Collapse All**
  
  Collapses the expanded list of filters.
Image Insertion Dialog Box

Use this dialog box to properly correlate (align) an image by specifying the insertion point, scale, and rotation.

Assign Color Map Tab (Image Insertion Dialog Box)

Use this tab to assign a color map to the image and to indicate whether to display the image.

Two versions of this tab are available: a Palette Color Map tab for digital elevation models (DEM), and a Band Assignment Color Map tab for multispectral images. Raster Design automatically displays the right one for the image file.

Palette Color Map

Color Map Name

On the drop-down list, click the name of the color map you want to use for the image.

Clicking one of the following three buttons takes you to the Palette Color Map Definition Dialog Box on page 347 to configure the color map:

Click to create a new color map.
Click to copy the selected color map; this is a good way to create a new color map based on an existing one.

Click to edit the selected color map.

Insert Into Display
Clear this check box if you do not want to display the image.

**Band Assignment Color Map**

Use the lists for Red, Green, and Blue to specify a data band to display with each color channel.

If you want to turn off a color channel, clear the check box for that color.

If you do not want to display the image, clear the Insert Into Display check box.

**Related procedures:**
- Assigning a Color Map to an Image on page 20

**Source Tab (Image Insertion Dialog Box)**

Use this tab to pick a source of correlation data for the image.

**Correlation Source**

When you select a correlation source from the list, the correlation values and other data on this tab is updated from the source.

---

**NOTE** Asterisks (*) are displayed beside numeric values that are the default values assigned in the Raster Design Options dialog box.

Depending on image type, up to four sources can be used:
- **Image File.** Correlation data can be saved as part of the image file if the file type is RLC, IG4, IGS, GeoTags in GeoTIFF, or HDR File in SPOT.
- **Default.** Refers to values set in the Raster Design Options Dialog Box on page 353.
Resource File. A file created by the Raster Design Export operation or previous versions of Raster Design. Resource files have a .RES file extension.

World File. A file created by the Raster Design Export operation for all image formats, or by other applications. World files have different file extensions, depending on file type.

Correlation Values
Displays the X and Y coordinates of the insertion point (bottom left corner), rotation angle, and scale of the image as recorded in the correlation source.

Density
Displays the pixel density of the image.

Units
Displays the linear units of measure for the image.

Coordinate System
Displays the coordinate system used in the image, if applicable.

Image File Name
Displays the coordinate system used in the image, if applicable.

Correlation File Name
Displays the coordinate system used in the image, if applicable.

Modify Tab (Image Insertion Dialog Box)

Use this tab to change correlation values for this image insertion, without modifying the values stored in the original correlation file.

Correlation Values
You can change the coordinates of the insertion point if you want to move bottom left corner of the image.
To rotate the image, enter an angle of clockwise rotation, using the format 0d 00' 00'.
To scale the image, enter the scaling factor. Use a number larger than 1 to enlarge the image, a number between 1 and 0 to reduce the image.

Density
Displays the pixel density for the image units. For example, if you change the image units to meters, the pixel density is displayed in pixels per meter.
Units
Displays the units of measure for the image. Image units are for horizontal measure; vertical units are for elevations, either US Survey Feet or Meters. If vertical units are not supplied by the image, this value defaults to the unit specified on Image Defaults Tab (Raster Design Options Dialog Box) on page 353. To avoid image distortion, this unit should match the unit used to capture the image. For example, if an image was scanned at a certain dots per inch (dpi) setting, the image units should remain as inch.

Insertion Tab (Image Insertion Dialog Box)
Use this tab if you are applying a coordinate system transformation and want to change the insertion point, rotation, or scale of the image, or want to change the size and color of the image frame.

Insertion Point
Specifies the insertion point in current AutoCAD units after any unit conversions or coordinate transforms have been applied. If a new insertion point is assigned with Pick <, these coordinates are shown here.

Rotation
Specifies the rotation in current AutoCAD units after any coordinate transform has been applied. Change this value by typing, pasting, or by assigning a new rotation value with Pick <.

Scale
Specifies the scale after any coordinate transform has been applied. Change this value by typing, pasting, or by assigning a new value with Pick <.

Color
Specifies the color of the image frame (and for bitonal images, the foreground color). Usually the color of the current layer. When you insert a bitonal image, Raster Design first looks for the foreground color in the correlation source. If it cannot find color information, the foreground color defaults to current color.

Pick <
Allows you to define a frame for the image you are inserting. You can define the frame size and rotation by drawing or by typing values.

Related procedures:
- Adjusting the Image Frame Before Insertion on page 29
Transform Tab (Image Insertion Dialog Box)

This tab is displayed only if Raster Design is installed on an Autodesk geographic application such as AutoCAD Map or AutoCAD Land Desktop.

Use this tab to transform the coordinate system of an image to match the coordinate system used in an AutoCAD Map drawing. In most cases, the system will select the correct code and related values for you.

Enter Code
Enter the coordinate system code, if available. Doing this updates the Category and Coordinate System lists to identify the coordinate system specified by the code. After a code is entered, you can also click Properties to see more details about the coordinate system.

Select Category From List
Displays the general category for the coordinate system, such as UTM or Lat Longs.

Coordinate Systems in Category
Displays the specific coordinate system for the image.

Transform To Drawing's Coordinate System
Select this option to transform the image to the coordinate system used in the drawing, which is displayed here for reference.

Transform Type
Select one of three options:
- True (pixel by pixel): produces the most accurate results.
- 4-Point Rubbersheet: approximate transformation, most accurate near the control points.
- 3-Point Affine: replicates the transformation performed on non-editable data types.

OK
Verifies the transformation and inserts the transformed image into the drawing.

Apply
Verifies the transformation and displays a preview of the transformed image.
**Image Manager Toolspace**

Use this toolspace to manage multiple image insertions, color maps, and related data.

When you select an image or other object, its properties appear in the item view at the bottom of the toolspace.

**Opening the toolspace**

Raster Design Toolbar:  
Main menu: Click Raster ➤ Manage.

**Command-line commands**

imanage to open the toolspace  
hiderd to close the toolspace  
dockrd to dock the toolspace on the left side of your screen  
floatrd to move the toolspace from a docked position to a floating window

**Using the auto-hide setting**

If you turn auto-hide on, the toolspace automatically expands when you mouse over it and contracts to just a vertical bar when you mouse away from it. This is convenient when you are working in a drawing window but want the toolspace readily available.

Click 🔊 to turn auto-hide on.

Click 🔊 to turn auto-hide off.

**Setting toolspace properties**

You can set several toolspace properties on a menu. For example, you can disable the docking feature, control the transparency of the toolspace, and turn auto-hide on or off.

Click 🗼 to see the Properties menu.

**Management toolbar**

This is a series of buttons across the top of the toolspace.
Click to collapse the tree view, showing only the drawing.

Click to expand the tree view, showing all objects in the hierarchy

Click to toggle between image preview and a tabular item view in the secondary pane of the Image Insertions view

See also:
- Controlling the Image Manager Toolspace on page 67

**Image Insertions View (Image Manager Toolspace)**

Use this view to manage inserted images and their color maps.

As shown in the following figure, the tree view displays two object types:

- Image insertion
- Color map

If you add two or more insertions of the same image, digits are appended to the image name, such as View:1, View:2.

Right-click on the drawing to insert another image or refresh the display. Insert opens the Insert Image on page 340 dialog box.

Right-click on an image insertion to see a menu with the following options:

- **Properties**. Shows the AutoCAD properties of the insertion.
- **Edit Color Map**. Opens the dialog box for editing the color map for this insertion, such as: Select Color for a bitonal image, Image Adjust for a grayscale or color image.
Other options include: Palette Assignment Color Map on page 347 dialog box for a DEM image or Band Assignment Color Map Dialog Box on page 303 dialog box for a multispectral image.

- **Zoom To.** Zooms your display to show the image at full extents.
- **Hide/Show.** A toggle control that hides or shows the image.
- **Erase.** Erases the insertion and its color map. For more information, see erase on page 391.
- **Write.** For eligible image types, displays a sub-menu where you can save or export the image.
- **Move Forward, Move Back, Bring To Front, Send To Back.** Moves the image within the display order if the drawing contains multiple images. You can also do this directly in the tree by clicking an image name and dragging it up or down the tree.
- **Refresh.** Rebuilds the tree to show any recent changes.

Right-click on a color map to edit it or refresh the display.

**Item View**

This secondary pane displays metadata for the object selected in the tree view. For some objects, you see a simple properties table. When you select a drawing, you see a multi-column table with an entry for each inserted image. You can change the displayed columns and their positions in this table. For more information, see Modifying the Item View Layout on page 67.

**Image Data View (Image Manager Toolspace)**

Use this view to work with image data definitions. This view is especially useful for creating new insertions and managing the display and analysis of complex raster data.

The tree view can display six object types:

- 📆 Image data definition
- 🗂 Band group
- 📄 Band group metadata

---

334 | Appendix B  Raster Design Dialog Boxes
Data band
Color map
Image insertion

As shown in the figure, each data definition includes one or more band groups (examples: Truecolor and Bitonal) with subordinate bands. At the same level as the band groups are color maps (examples: RGB and BIN). Image insertions are placed subordinate to the color maps that define them. The location of the image insertion on the tree is a major difference between the Image Insertions view and the Image Data view.

Image Data Definition

Defines the source for one or more images inserted in the drawing. Right-click a data definition to see a menu with the following options:

- **Properties**. Opens the Image Data Properties on page 326 dialog box to show basic information about the data definition.

- **New Insertion**. Creates a new insertion of the image, based on the data definition. This insertion method offers you more options than by using the Image Insertion on page 327 dialog box.
  
  For AutoCAD image data definitions (bitonal, grayscale, index color, or true color), the new insertion works like a quick insert, without further configuration.

  For single-band floating-point (DEM) data definitions, the Palette Assignment Color Map on page 347 dialog box opens for you to choose a color map.
For single-band integer (16- or 32-bit) data definitions, a submenu allows you to choose either a grayscale or palette color insertion. Choosing palette color opens the Palette Assignment Color Map dialog box.

For multispectral data definitions, a submenu allows you to choose a grayscale, palette color, or false color insertion. Choosing grayscale opens the Assign Multispectral Band on page 303 dialog box. Choosing palette color opens the New Palette Color Insertion on page 346 dialog box. Choosing false color opens the Band Assignment Color Map on page 303 dialog box.

- **Detach.** Completely removes the image and its data definition from the drawing and the toolspace tree.

- **Reload.** Loads and redisplays an image that was previously unloaded from the drawing.

- **Unload.** Removes an image from the display, but leaves the image frame visible, and leaves the image icon on the toolspace tree.

- **Browse Path.** Opens the Choose a New Directory on page 305 dialog box to show you the location of the source file for the image definition, also known as the active path. If necessary, you can navigate to a different source file and open it.

- **Save Path.** Saves the current browse path (Active Path in item view) as the saved path, which is where the image data definition is saved.

- **Clear Path.** Deletes the saved path. Typically you do this in order to use Browse Path to create a new active path, or to save the drawing without a saved path. In the latter case, when the drawing is reopened, Raster Design searches for the image using the prescribed search order set in AutoCAD Options dialog box. (To access the AutoCAD Options dialog box, click Tools menu ➤ Options.)

- **Refresh.** Updates the toolspace tree to show any recent changes.

**Band Group**

Right-click a band group to see the Image Data Properties on page 326 dialog box.

**Data Band**

Right-click a data band to see the Image Data Properties on page 326 dialog box.
Band Group Metadata
Conditional object, present only for multispectral image data.

Color Map
Right-click a color map to see a menu with the following options:

- **Edit Color Map.** Opens the dialog box for editing the color map for this insertion, such as: Select Color for a bitonal image, Image Adjust for a grayscale or color image. Other options include: Palette Assignment Color Map on page 347 dialog box for a DEM image, or Band Assignment Color Map on page 303 dialog box for a multispectral image.

- **New Insertion.** Inserts a new instance of the image, using the current color map.

- **Refresh.** Updates the toolspace tree to show any recent changes.

Image Insertion
Right-click an image insertion to see a menu with the following options:

- **Zoom To.** Zooms your display to show the image at full extents.

- **Hide/Show.** A toggle control that hides or shows the image.

- **Erase.** Erases the insertion. For more information, see erase on page 391.

- **Refresh.** Updates the toolspace tree to show any recent changes.

Image Data Definition Metadata
Conditional item. If present, it identifies the source file for the image metadata. Metadata is displayed in the item view.

Image Select Dialog Box
Use this dialog box when you select more than one image in a drawing.

Image Select Options
List of Images

- Lists all images in the drawing. Each image that is currently selected is highlighted. Click an image name to select or deselect it.
Select All
Selects all the images in your drawing.

Select None
Removes all selected images from the selection set.

**Import Data Dialog Box**

Use this dialog box to import files such control points and gamma point lists.

**Import Options**

Look In
Specifies the folder where the file is saved.

Back
Returns to the previous folder.

Up One Level
Navigates up one level in the directory tree.

Search The Web
Displays the AutoCAD Web browser, with which you can specify an Internet location and select drawing content for display in the AutoCAD Design Center palette.

Delete
Deletes the selected file.

Create New Folder
Creates a new, unnamed folder.

Views
Specifies how files are displayed.

Tools
Provides options for finding files, adding or modifying an FTP site, or saving a shortcut to the current folder.

Places List
Displays shortcut icons to locations such as the desktop, FTP, Buzzsaw.com, and so on.

File Name
Specifies the name of the file.
Files Of Type
Specifies the file format of the file to import.

**Import Palette Dialog Box**
Use this dialog box to apply a saved palette (*.pf) to the current image.

Look In
Specifies the folder or directory that contains the palette.

Back
Returns to the previous folder.

Up One Level
Navigates up one level in the directory tree.

Search The Web
Displays the AutoCAD Web browser, where you can specify an Internet location for the palette file.

Delete
Deletes the selected file.

Create New Folder
Creates a new, unnamed folder.

Views
Specifies how palette files are displayed.

Tools
Provides options for finding files, adding or modifying an FTP site, or saving a shortcut to the current folder.

Places List
Displays shortcut icons to locations such as the desktop, FTP, Buzzsaw.com, and so on.

File name
Specifies the palette file to insert.

Files Of Type
Displays the list of available palette formats. Choose the type of file that you want to display in the File name list.
Palette Application

Substitute
Replaces the current palette with the imported palette. Indexed colors are not changed, they are simply mapped to the new colors in the imported palette.

Match
Replaces the current palette with the imported palette by re-mapping the indexed colors to the closest colors in the imported palette.

Dither
Replaces the current palette with the imported palette by re-mapping the indexed colors to the closest colors in the imported palette. Unlike matching, dithering can have different results when an indexed color from the original image is equally similar to two or more colors from the imported palette. In this case, a pixel which once displayed a single color might be represented as a group of pixels displaying the target colors.

Related procedures:
- Importing an Image Palette on page 127

Insert Image Dialog Box

Use this dialog box to select one or more images to insert into a drawing.

You can view information about an image and preview the image before you insert it.

**NOTE** If the AutoCAD FILEDIA variable is set to <0>, this dialog box does not display, and you can type on the command line the name of the image that you want to insert.

Look In
Specifies the folder or directory that contains the image.

Back
Returns to the previous folder.

Up One Level
Navigates up one level in the directory tree.
Search The Web
Displays the AutoCAD Web browser, with which you can specify an Internet location and select drawing content for display in the AutoCAD Design Center palette.

Delete
Deletes the selected file.

Create New Folder
Creates a new, unnamed folder.

Views
Specifies how files are displayed.

Tools
Provides options for finding files, adding or modifying an FTP site, or saving a shortcut to the current folder.

Places List
Displays shortcut icons to locations such as the desktop, FTP, Buzzsaw.com, and so on.

File Name
Specifies the image to insert.

Files Of Type
Displays the list of available supported image types on page 401. Choose the type of file that you want to display in the File Name list.

**Insert Options**

Quick Insert
Inserts the image with no other decisions required. Correlation data (if required) is taken from the image file, a separate file, or default values are used.

Insertion Wizard
Inserts the image after walking you through a sequence of steps to supply and review correlation data. This is the default correlation method.

Insertion Dialog
Inserts the image after presenting you with the correlation data to review. This option is similar to the Insertion Wizard, but without the sequence. You can review and edit data in any order on separate tabs of a dialog box.
Show Frames Only
Displays only the frame on page 391 of the image you insert.

Zoom To Image(s)
Zooms to the extents of the image(s) you insert after correlation.

Treat As Multispectral
If two or more images are selected for insertion, this option verifies that they share the same image format, coordinate system, extents, and units. If they meet this criteria, the images can be handled as a multispectral dataset.

Multi-frame Options
These options are available only when a multi-frame image is selected for insertion.

Insert First Frame
Inserts the first frame in the multi-frame set.

Insert All Frames
Inserts all of the frames in the multi-frame set.

Select Frames
Opens the Multi-frame Select Dialog Box on page 343, where you can select which frames to insert.

Related procedures:

Inserting Local Images Using the Insert Image Dialog Box on page 12

Median Filter Dialog Box
Use this dialog box to remove visual “noise” or speckles from a grayscale image.

This filter adjusts the shade of gray for each pixel to create smoother transitions between shades and eliminate speckles. Enter an odd integer from 3 to 25 to specify the area to be evaluated around each pixel. A setting of 3 evaluates 8 pixels, processes an image very quickly, and retains most sharpness. A higher setting evaluates a larger area, takes more time, and produces a more blurry image.
Related procedures:
■ Median Filter on page 108

Mirror Dialog Box
Use this dialog box to choose the vertical or horizontal axis about which to mirror or flip an image.

IMPORTANT The axes for mirror operations are always relative to the image. If the image has been rotated or repositioned in the drawing, the mirror axes are also moved, so they may not appear horizontal or vertical in the display.

Top To Bottom
Mirrors the object about the horizontal axis of the image.

Side To Side
Mirrors the object about the vertical axis of the image.

Related procedures:
■ Mirroring an Image on page 90

Multi-frame Select Dialog Box
Use this dialog box to specify which image frames to insert from a multi-frame set.

Left pane
Click the frames to be inserted or clear check boxes for frames that you do not want inserted.

Select All
Selects all the frames.

Clear All
Clears the check boxes for all frames.

Treat As Multispectral
Select this option if the selected frames are part of a multispectral set, intended to be viewed together with a band assignment color map.
Hide Information
Closes the Information pane.

Hide Preview
Closes the Preview pane.

Preview
Displays thumbnail images of each frame in the set. You can review the images here and select the ones to be inserted. To review images, use the scroll bar or the keyboard arrow keys. To select images, use the mouse. Use the Shift key with the mouse to select a range of images; use the Ctrl key with the mouse to select several non-adjacent images.

Information
Displays metadata about the image set, such as image type, depth, density, width, and height.

**New Image Dialog Box**
Use this dialog box to define the properties of the image that you want to create.

**AutoCAD Properties**

X, Y, and Z Coordinates
Specifies the X, Y, and Z AutoCAD coordinates that define the lower-left corner of the new image.

Scale
Specifies a numeric scaling factor for the new image.

Rotation
Specifies a rotation for the new image.

Pick <
Draws a frame for the image you want to create. This automatically sets the X,Y, and Z values, scale, and rotation of your new image.

**Color Type**

Bitonal (1-bit)
Limits your image to two colors.

Grayscale (8-bit)
Limits your image to 256 shades of gray.
Indexed Color (8-bit)
Limits your image to 256 different colors.

True Color (32-bit)
Limits your image to 16.7 million colors.

**NOTE** True Color uses more system resources.

**Image Properties**

**Width**
Displays the physical width of the image in pixels and the current units. You can use the list to choose other units of measurement.

**Height**
Displays the physical height of the image in pixels and the current units. You can use the list to choose other units of measurement.

**Density**
Specifies a density (or resolution on page 397) for the image. This defines both the horizontal and vertical density.

**NOTE** You should set this to the density value at which your images are scanned.

**Show This Dialog**
Uses the command line interface for future new images instead of this dialog.

**Related procedures:**
- Creating New Images on page 22

**New Image Mask Dialog Box**
Use this dialog box to control what happens to image data outside the mask boundary.

**Enable Mask**
Enables an existing mask for display. Enabling allows you to view the image clip as defined by the image mask.
**Image(s) Outside The Image Mask**

Do Not Affect
   Specifies that the images outside the mask boundary are not modified.

Hide Image(s)
   Hides the images that are outside the mask boundary.

Unload Images
   Unloads from memory the images that are outside the mask boundary.

Show Image Frame(s)
   Specifies the visibility of image frames. If you choose Hide Image(s) or Unload Image(s), then you can select this check box to show the hidden or unloaded frames.

**Define Image Mask**

Rectangle
   Draws a rectangular mask.

Polygon
   Draws a polygonal mask.

**NOTE** Use the Options dialog box to specify the default mask properties.

Related procedures:
- Masking Images on page 138

**New Palette Color Insertion Dialog Box**

Use this dialog box to select a data band from a multispectral set and a color map to use for that band.

Band Association
   Click the band to display.

**Color Map Name**

On the drop-down list, click the color map you want to use for the image.

Clicking one of the following three buttons takes you to the Palette Color Map Definition on page 347 dialog box to configure the color map:
Click to create a new color map.

Click to copy the selected color map; this is a good way to create a new color map based on an existing one.

Click to edit the selected color map.

**Palette Assignment Color Map Dialog Box**

Use this dialog box to edit the color map of a digital elevation model (DEM) or other single-band image.

**Color Map Name**

On the list, click the color map you want to use for the image.

Clicking one of the following three buttons takes you to the Palette Color Map Definition on page 347 dialog box to configure the color map:

Click to create a new color map.

Click to copy the selected color map; this is a good way to create a new color map based on an existing one.

Click to edit the selected color map.

**Insert Into Display**

Clear this check box if you do not want to display the image.

**Palette Color Map Definition Dialog Box**

Use this dialog box to review and edit attributes for a palette color map, used with digital elevation models (DEM).
Data Interpretation
Select the type of data to display about the surface:

- **Height (Feet)**. Land elevation in feet
- **Height (Meters)**. Land elevation in meters
- **Value**. Land elevation in other units, or other data in the file
- **Slope (Percent)**. Ground slope expressed as a percentage
- **Slope (Angle)**. Ground slope expressed as an angle
- **Aspect**. Direction of ground slope

Value Distribution
This setting controls how the colors in the Range Table are distributed across the range of data values: Parametric or Custom.

**NOTE** A parametric distribution automatically adapts to the range of values in the file being displayed; a custom distribution uses fixed data values, regardless of the range of values in the file. This difference is important if you want to save the color map and use it on multiple data files.

If you want Raster Design to automatically set the ranges, choose Parametric, then one of these three options:

- **Equal**

Each color represents an equal range of values, regardless of how many actual data points occupy that range for a given source file.

- **Standard Deviation**

Six ranges are created, and the spread of each one is set to the standard deviation for the data. The upper limit of the third range is the arithmetic mean value. If the data has a normal distribution, the third and fourth ranges embrace about 68% of the data values; the second through fifth ranges embrace about 95% of the values.

- **Quantile**

Each range represents an equal number of data points in the source file. Where readings are clustered around a narrow range of values, colors in that range have a small range spread; where readings are sparse, the range spread is large.
If you want to manually set the range spreads, click Custom. You can also start by clicking Parametric to generate an initial set of ranges, then edit individual range values in the Range Table. When you start editing, the Value Distribution is reset to Custom.

Palette
The name of the current palette is displayed. An asterisk (*) before the name indicates that you have edited the palette in the Range Table.
Click Import to import an existing palette.
Click Export to export a palette; this option is available only after you have finished defining a color map.

Display Enhancements
You can use these effects to change the appearance of the displayed surface.
Select Hillshade if you want to cast light across the surface from the northwest direction, creating shadows around the hills and valleys.
Set a Vertical Exaggeration level (1 to 99) if you want to make the elevation changes more extreme and intensify the hillshading.
Select Blend if you want to create a smooth transition between colors in the display.

Range Table
This table shows the details of color ranges and accepts a wide range of edits to the number of ranges, range values, colors and visibility.

Index
This column provides a reference number for each color, with 0 for the lowest value range. An asterisk (*) indicates the highest assigned range and the place where a new range is added.
Use the Index column to highlight entire rows of the table for editing. By adding or deleting rows, you can set the number of ranges for the color map. When one or more rows are selected, you can right-click to insert rows, combine rows, or change their visibility.

Range Upper Value
This column shows the upper limit of data values for each range. You can edit the numbers, but they must remain in the correct sequence in relation to adjacent ranges. You can right-click in this column to delete, cut, copy, and paste one or more upper range values without affecting the other columns.

Range Spread
This column shows the size of the range, or the difference between the range upper value in the current row and the one above. You can right-click
in this column to edit values in the same way as in the range upper value column.

Color
Use this column to change the color assigned to each range. Double-click a single color to change it on the AutoCAD Select Color dialog. You can select one or more colors in this column, the right-click to cut, copy, paste, or assign a single color to the group.

Palette Information Dialog Box
This dialog box displays general information about the current image and its palette of colors or shades of gray.

Palette Manager Dialog Box
Use this dialog box to manipulate individual colors and entire palettes for 8-bit images.

Palette menu
Import
Imports a saved palette (*.pf).

Export
Displays the Export Palette dialog box, where you specify a name and save your changes to the current palette.

Information
Displays information about the current palette.

View menu
Show Unused
Displays or hides the “X” marks that indicate which colors in the palette are unused.

Show Transparent
Displays or hides the “+” marks that indicate which colors in the palette are transparent.

RGB
Displays the Red, Green, and Blue (RGB) values on the status bar for the selected color.
HSL
Displays the Hue, Saturation, and Luminosity (HSL) values on the status bar for the selected color.

Sort By
Specifies a sorting method for the color table and list view.

Select Color
Specifies a color (or colors) directly from the image.

Color Table
Specifies colors in the selection set. The color table is represented as a 32X8 grid of colors. You can select colors by clicking directly, or clicking and dragging. You can also right-click a selected color, then click Clear Selection to remove the current colors from the selection set, or click Invert Selection to select everything except the color you clicked.

Change
Replaces the selected color with a new color.

Combine
Condenses the selected colors into a single color.

Set Transparent
Specifies the selected color as transparent.

Compress
Removes duplicate entries from the palette. All unused entries that result from a compress operation are assigned a RGB value of 0,0,0.

Convert To Color
Converts a grayscale image to an image with a palette that consists of gray tones.

Reset
Restores the palette to the original state or to the state after the last Apply.

List View
Displays a table in which you can view and sort each color entry in the palette. Click on a column heading to sort the table by that column. Click again to reverse the sort order. Right-click on a column heading, then click the column names to show or hide the corresponding columns.

Image Transparency
Specifies whether the background transparency property is on or off in the image.
Apply

Saves your changes to the image palette without exiting the Palette Manager dialog box.

Related procedures:
- Manipulating the Color Table on page 120
- Importing and Exporting Image Palettes on page 127
- Controlling Palette Views on page 133

Raster Data Query Dialog Box

Use this dialog box to display pixel data values at the cursor location over an image.

This dialog box can be floated or docked in the left pane of the main window, similar to the Image Manager.

Coordinate System

When running on AutoCAD Map, specifies the coordinate system of the image, or “Not Set” if no coordinate system is assigned.

Choose Transform

Opens the Select Global Coordinate System Dialog Box on page 371 where you can select a coordinate system for the image.

Cursor Tracking

Specifies the X, Y location of the cursor. These are usually AutoCAD World coordinates, unless a coordinate transformation arrangement exists between the drawing coordinate system and the working coordinate system.

Move Cursor to Coordinates

Sends the cursor to the coordinates specified in Cursor Tracking. Right-click for additional options.

Image Data

Image Name

Specifies the name of the current image insertion.
**Select Image**
Queries a different image. Right-click for additional options.

**Pixel Display Color**
Specifies the displayed color values of the pixel under the cursor.

**Pixel Data Value**
Specifies other data values of the pixel under the cursor. Values depend on image type. For example, 0-255 for an indexed color or grayscale image. If the image is in 32-bit floating point format with a palette color map, the data here can be elevation, slope, or aspect, depending on the color map.

**Related procedures:**
- Displaying Point Data on page 73

---

**Raster Design Options Dialog Box**
Use this dialog box to configure the behavior of many features in Raster Design.

The dialog box consists of the following tabs:

**Image Defaults Tab (Raster Design Options Dialog Box)**

Use this tab to set correlation defaults. The values set on this tab are used on the Source tab of the Image Insertion dialog box and wizard. For more information, see Correlating Images on page 23. You can correlate on page 388 the image data that is stored in the image file header, in a resource file, or in the drawing file. However, some images may not have any correlation data. For those cases, you can specify default correlation data.

**NOTE** Setting the correlation defaults can save you time if you have multiple images that require the same insertion point, scale, rotation, and density.

**Insertion Point**
Specifies default X, Y, and Z AutoCAD coordinates to define the lower-left corner of images.

**Scale**
Specifies a default numeric scaling factor for images.
Rotation
Specifies a default angular rotation for images.

Density
Specifies the default image density value (or resolution on page 397), typically in dots per inch or per centimeter. For more information, see Changing Image Density on page 117. You should set the value to the most common density value at which your images are scanned.
If you insert images that include density value and density unit information, then these defaults are not used.

Vertical Units
Specifies the default unit of measure for elevations. Select either US Survey Feet, or Meters.

Feature Settings Tab (Raster Design Options Dialog Box)

Use this tab to configure global settings for the drawing, such as the method of locking image files, the width for the rub and crop lines, and the VTools rubber setting. You can also control mouse button actions.

Locking Settings

No Locking
Choose this option only if you are not working in a network environment or if it is unlikely that two people would access the same image at the same time from a network drive.

Lock File
Choose this option if you are using a network that does not support DOS File Sharing or if you are using more than one platform on the network. This option creates a lock file that denies write access to the image file until it is closed. This file is not locked by your operating system.
With this method of file locking, if a lock file is present and your system fails, then you will have to delete the lock file manually. Lock files have an .l_k extension and the same base name as the image. Lock files are either in the same directory as the image file or in the specified lock directory.
For more information, see Locking Method for Image Files on page 260.

NOTE You cannot lock files on the Internet.
OS/Network Locking
Choose this option if you are on a network that supports DOS File Sharing. This option creates a lock file that is marked as locked by your operating system or network software. This file denies write access to the image file until the file is closed. With this method, if a lock file is present and your system fails, then the lock file is released by the network when you restart your computer.

Lock File Directory
Specifies a directory to store lock files in.

Removal Method
Rub
Rubs the raster objects beneath the vector when you use Remove tools.

REM
Deletes the raster objects beneath the vector when you use Remove tools.

Display Option On Shortcut Menu
Makes the Remove Under Existing feature available from the shortcut menu.

Rub/Crop Line Width
Specifies a line width, in AutoCAD units, to be used for rub lines and crop lines. Or, you can click Pick and then pick two points on your raster image to define the line width.

NOTE You can also use the Autorub command to specify the Rub/Crop line width. For more information, see Rub and Crop Line Width on page 268.

Thumbnail Options
Instructs Raster Design to create thumbnails of your images when you save the image. Thumbnails are displayed much more quickly in image previews than if Raster Design has to read in the entire image file. This option only works for image formats that support thumbnails, such as TIFF, TARGA, and FLIC files. For more information, see Image Thumbnails on page 257.

Image Mask Tab (Raster Design Options Dialog Box)
Use this tab to control the properties for a future mask. This includes enabling and disabling the mask, determining how the mask affects the images in the drawing, and defining the mask boundary.
NOTE Setting the Image Mask defaults can save you time if you have multiple masks that require the same properties.

Enable Mask

Enables an existing mask for display. You can view the image clip as defined by the image mask.

Image(s) outside the Image Mask

Do Not Affect

Ignores the images that are outside the mask boundary.

Hide Image(s)

Hides the images that are outside the mask boundary.

Unload Image(s)

Unloads from memory the images that are outside the mask boundary.

Show Image Frame(s)

Shows the frames of the images that are hidden or unloaded.

New Image Tab (Raster Design Options Dialog Box)

Use this tab to control the properties for a new image. This includes defining image properties and setting a default color type.

NOTE Setting New Image defaults can save you time if you have multiple images that require the same properties.

Width

Displays the default physical width of the image in pixels and the current units. You can use the drop down arrow to choose other units of measurement.

Height

Displays the default physical height of the image in pixels and the current units. You can use the drop down arrow to choose other units of measurement.

Density

Specifies the default density (or resolution on page 397) for the new image(s) in pixels per linear unit (example: 300 pixels per inch). You can use the menu to choose other units of measurement.
NOTE You should set this value to the density at which your images are scanned.

**Default Color Type**

Bitonal (1-bit)
Sets a default for an image that consists of only two colors.

Grayscale (8-bit)
Sets a default for an image that contains 256 shades of gray.

Indexed Color (8-bit)
Sets a default color from the AutoCAD palette for an image that contains 256 different colors.

True Color (32-bit)
Sets a default for an image that contains up to 16.7 million colors.

NOTE Selecting True Color uses more system resources.

**Dialog Options**

Show New Image Dialog
Sets default access to the command line interface, when the check box is cleared.

**Paths Tab (Raster Design Options Dialog Box)**

Use this tab to set the correlation search paths and to select an AutoPaste option for inserting images from Raster Design GSX or Raster Design ESP.

**Correlation Search Paths**

Read Path
Specifies the default directory to search for a resource file on page 397 or world file on page 402 for an inserted image. This directory can be on a local or network drive, or at an Internet location. Click Browse ➤ Local to open the Choose a Resource File Directory Dialog Box on page 306, where you can navigate to and select a directory.

Write Path
Specifies the default directory in which to save or export resource files and world files. The possibilities for the location and the means of setting it are the same as for Read Path.
Use Correlation Search Path Before Using Image Directory
Instructs Raster Design to search for resource files using the read path for correlation before searching the image path stored in the drawing.

Search For Correlation Files On The Internet
Instructs Raster Design to search the Internet for associated correlation files.

AutoPaste (ESP and GSX Compatibility)
Use these options only if you are upgrading to Raster Design from CAD Overlay ESP or GSX.

AutoInsert
Instructs Raster Design to automatically insert images into a drawing that you created with ESP or GSX. For more information, see Inserting Images From GSX or ESP on page 258.

AutoReplace
Instructs Raster Design to search for an image sharing the same base name as the drawing. If found, this new image is inserted using the same insertion point, scale and rotation as the original reference. Raster Design automatically updates the saved image path.
For instance, in order to create a new version of a drawing-image hybrid pair (example.dwg and example.tif), both the drawing and the corresponding image may be renamed so they share new base names (example1.dwg and example1.tif). When the new drawing is opened, the image cannot be found because the drawing still references the old image (example.tif). If AutoReplace is enabled, the new image (example1.tif) is found and replaces the old image in the drawing.

Prompt Before AutoInsert
Instructs Raster Design to prompt you when it locates the image, before insertion.

Extension List
Lists the extensions Raster Design searches for when it searches for the image. Raster Design searches for images in the order that they appear in this list.

< Add
Adds your image type choice to the Extensions List.
REM Tab (Raster Design Options Dialog Box)

Use this tab to choose settings for REM commands. For more information, see REM Settings on page 267.

Color Of REM Objects
- Specifies the REM object default color, the color of all REM objects.
- If you change this setting and REM objects are already defined, REM objects change accordingly.

Clipboard Settings
- Display Capture
  - Instructs the Copy to Clipboard command (icopyss) to maintain the display scale and rotation of the objects in the REM selection set.
- Native Capture
  - Instructs the Copy to Clipboard command to copy the REM selection set data directly from the image file, disregarding the display scale and rotation.

Raster Entity Detection Tab (Raster Design Options Dialog Box)

Use this tab to determine how REM and vectorization tools detect raster entities. For more information see Raster Entity Detection Settings on page 266.

Single Pick Options
- Max Jump Length (Pixels)
  - Specifies the distance Raster Design can jump to extend a raster entity when selecting entities for the Smart option and one-picks for lines, circles, arcs, and polylines. Click Pick< to select the jump length directly from an image.
- Stop At Intersections
  - Specifies whether REM and vectorization tools detect segments or entire primitives.
- Use Raster Pick Gravity
  - Specifies whether to select raster that is within a pick aperture around the cursor.
When pick gravity is active, if you select a point that is not exactly on raster, Raster Design looks for the specified number of aperture pixels in each direction to find raster.

**Pick Aperture (Pixels)**

Specifies the size of the aperture for pick gravity. Enter a numerical pixel width to define a new aperture size.

**Multi-Pick Options**

**Float Tolerance (Pixels)**

Specifies the maximum pixel distance between raster and vector for the raster to be selected. The distance between the vector being followed and the underlying raster is constantly tested to ensure the raster falls within the float tolerance. For example, if your REM primitive arc selection is further from the raster at one endpoint than the float tolerance allows, only that portion of the raster within the float tolerance is selected.

**Non-Continuous Linetype Detection**

**Max Dash Length (Pixels)**

Specifies the maximum length of dash segments for Raster Design to consider an entity as a non-continuous line.

Click Pick < to select the dash length directly from an image.

**Max Blank Length (Pixels)**

Specifies the maximum distance between dashes for Raster Design to consider an entity as a non-continuous line.

Click Pick < to select the blank length directly from an image.

**User Preferences Tab (Raster Design Options Dialog Box)**

Use this tab to configure global settings for the drawing, such as the display quality of images, how frames are displayed, drawing units, and so on.

**Image Detach Options**

**Ask Before Detach**

Prompts you to detach an image if it is not referenced by any frames in the drawing.

**Always Detach**

Automatically detaches an image if its frame is erased.
Never Detach
Retains an attached image, even if the frame is erased.

**Message Display**

No Messages
Prevents Raster Design from displaying warnings while editing an image.

Command Line
Displays warnings on the command line only.

Message Box
Displays all warnings while you are editing an image.

**Mouse Settings**

Shift + Left-Click Image Select
Enables you to select images by placing your cursor over them and holding the Shift key down while clicking your left mouse button. This feature is useful when you are zoomed in to the image and cannot see the image frame. For more information, see Selecting an Image on page 81.

**NOTE** When you activate Shift+ Left-Click Image Select here, it overrides the AutoCAD Shift+ Left-Click to deselect entities for pickfirst and grip editing.

QSAVE Preference
Prompt during QSAVE
Prompts you to save your images when you type QSAVE at the command line.

**Startup Options**

Load Menu on Raster Design Startup
Instructs the Raster menu to appear each time you run Raster Design.

**Vector Merge Tab (Raster Design Options Dialog Box)**

Use this tab to set the behavior for future vector merge operations.

**Prompting Options**

Prompt To Delete Vector
Prompts you to delete all selected vectors after vector merge has completed.
NOTE This option disables the Always Delete Vector and the Never Delete Vector options.

Always Delete Vector
Delete all selected vectors after vector merge has completed.

Never Delete Vector
Preserves all selected vectors after vector merge has completed.

Expand Image If Necessary
Expands your image to the extents of the vector.

Respect Display Order
Incorporates your current display order.

NOTE If a vector lies behind the image and the Expand Image If Necessary box is not checked then the vector is not merged into the image unless the image is transparent. For more information, see Controlling the Display of Transparent Colors on page 134.

VTools Follower Tab (Raster Design Options Dialog Box)

Use this tab to control the behavior of the follower tools used for vectorization.

Follower Color
Displays the current color used to mark the progress of the follower. Click the Select button to display the color palette.

Pan To Decision Point
Pans automatically to ensure that the current decision point is always on screen.

End Current Polyline If Closed Loop Detected
Closes polylines and contour objects automatically when the endpoints are within the tolerance distance. This setting is useful for closing across labels in contour lines.

Close Tolerance In Pixels
Specifies the distance between endpoints within which polylines will be automatically closed. Use the Pick button to select the distance directly from an image.
Post Process Points
Specifies how Raster Design draws the polylines and contours produced by the follower.
Move the slider to control how closely Raster Design imitates the raster polyline or contour.
High deviation creates a polyline with fewer points that is less faithful to the original raster. Polylines with fewer points require less memory.
Low deviation creates a polyline with more points that more closely matches the raster path. Polylines with more points require more memory.

Contour Settings
Contour Creates
Specifies the type of entity the Contour Follower creates.

NOTE The follower can only create contour objects if Raster Design is running on AutoCAD Land Desktop.

Elevation
Specifies one of the following:
- **ELEVATION** assigns an elevation value based on the AutoCAD ELEVATION variable.
- **Zero** assigns an elevation value of 0.
- **Preset** assigns the value that you specify in the Preset Elevation text box to all polylines and contour objects created by the Contour Follower.
- **Prompt** causes Raster Design to prompt you for elevation when the follower is finished.
- **Use Existing** causes Raster Design to prompt you to select an existing contour or polyline to which the elevation value can be matched.

Elevation Interval
Specifies the amount Raster Design adds or subtracts from the last elevation value you entered to create a suggested elevation value.

3D Polyline Settings
Elevation Interval
Specifies the amount Raster Design adds or subtracts from the last elevation value you entered to create a suggested elevation value.
Use Raster Impact Points Only
- Instructs the follower to pause only at a raster impact point on page 397, ignoring other vertices.

Ignore Raster Speckles
- Prevents the follower from pausing at raster impact points involving raster speckles.

Speckle Size (Pixels)
- Specifies the maximum speckle size to ignore.
- Click the Pick button to select a speckle or speckle size directly from the image.

**VTools General Tab (Raster Design Options Dialog Box)**

Use this tab to control the general behavior of vectorization tools.

**Removal Method**

None
- Leaves the raster as you trace it.

Rub
- Rubs the underlying raster automatically. This setting uses the Rub/Crop Line Width setting to determine the width of the raster it rubs. For more information, see Rub and Crop Line Width on page 268.

REM
- Deletes the underlying raster. However, unlike the Rub setting, this option recognizes raster line width and leaves raster intersections intact.

Vector Separation
- Specifies values such as layer and polyline width to vectors based on the underlying raster. For more information, see General Vector Separation Options on page 251 and Contour Vector Separation Options on page 246.

**Line, Circle, Arc and Polyline Settings**

Stop At Vector Intersection
- Instructs vline, vpline, and varc to stop at vector intersections during one-pick selection. This is useful if much of a drawing has been vectorized and the VTools must now depend on increasing amounts of vector data to make stopping decisions.
Display Start Point Glyph
Instructs vline and vpline commands to display a glyph that specifies the start point.

Verification List
Most Recently Used
Populates the verification list with recently used values.

Most Frequently Used
Populates the verification list with frequently used values.

Length
Specifies the number of values to include in the verification list.

SmartCorrect Settings
Respect Drafting Settings
Instructs SmartCorrect to adhere to current AutoCAD drafting settings such as OSNAP, ORTHO, POLAR, and so on, for the Line and Polyline tools.

Correction Tolerance
AutoCAD APERTURE
Specifies the aperture settings from the Drafting Tab of the AutoCAD Options dialog box to determine how far (in screen pixels) the resulting vector is allowed to shift in an attempt to respect AutoCAD drafting settings.

AutoCAD Units
Specifies how far (in AutoCAD units) the resulting vector is allowed to shift in an attempt to respect AutoCAD drafting settings. If you select this option, enter the number of units in the text box.

Round Values
Rounds the values for vector entities created using one-pick selection for the Line, Polyline, Circle, and Arc tools. Rounding applies to the length and angle values for lines and polylines, and to the radius value for arcs and circles.

AutoCAD Precision (LUPREC/AUPREC)
Specifies the AutoCAD precision value that you set on the Units tab of the Drawing Setup dialog box. AutoCAD Precision rounds to the number of decimal places you specify.
Specified Precision

Specifies the precision values you set in the associated Length and Angle text boxes. Specified Precision rounds to a multiple of the value you entered. For instance, if you specified a length precision of .03, Raster Design might round a line to 12.03, 12.06, 12.09, and so on.

**Raster Pen Settings Dialog Box**

Use this dialog box to control the thickness of vector lines when you merge them into the image.

Thicknesses are assigned according to the specified entity color.

**Color Index Column**
- Lists color index and width of the raster pens.

**Width Column**
- Displays the selected pen width.

**Units**

**Pixels**
- Defines pen width in pixels.

**AutoCAD**
- Defines pen width in AutoCAD units.

**Use Fixed Width**
- Assigns the specified pen width to all raster pens.

**Related procedures:**
- **Merging Vectors into a Raster Image** on page 164

**Recognition Character Sets Dialog Box**

Use this dialog box to choose character sets for text recognition operations.

A Character Set is a group of 256 characters used by a specific language.

You can select multiple character sets, but each additional character set increases the number of possible characters the recognition engine searches.
for. Doing this slows the recognition process and increases the possibility of errors.

Related procedures:
- Vectorizing Raster Text on page 227

Rubbersheet - Set Control Points Dialog Box

Use this dialog box to set the locations of control points for use in a rubbersheeting operation.

Method

Use this area to select the rubbersheeting method that best suits your image. After setting the control points, you can switch from one method to the other and preview the results before making a final decision.

Triangular
- Specifies the use of the triangular method.

Polynomial
- Specifies the use of the polynomial method.

Degree
- Used only with the polynomial method, to specify the polynomial degree, which affects the accuracy of the rubbersheet operation.

Control Point Table

ID
- Specifies the control point number.

Error
- Used only with the polynomial method, to specify the distance from the intended to the actual destination point after the rubbersheet operation. This distance is also known as the root-mean-square (RMS) error for the control point.

Source Point
- Specifies the coordinates of the source point in the image.

Destination Point
- Specifies the coordinates of the intended destination point, after the rubbersheet operation.
Total RMS Error
Displays the total root-mean-square error for the set of control points.

Buttons
Add Points <
Click to add pairs of source and destination points.

Grid Points
Click to open the Grid Parameters Dialog Box on page 317 and create a grid to use in the rubbersheeting operation.

Delete
When a row is selected in the Control Point Table, click to delete the row.

Repick <
When a row is selected in the Control Point Table, click to repick a pair of points.

Zoom To <
When a row is selected in the Control Point Table, click to zoom in to the vicinity of the pair of control points.

Preview
Click to preview the effects of a rubbersheet operation using the current settings.

Import
Click to import a set of control points, saved in a text (.txt) file.

Export
Click to export the existing points from the Control Point Table to an external text file.

Auto Zoom
Specifies that the drawing window automatically zooms in to the vicinity of a particular pair of control points when they are selected in a repick operation.

Related procedures:
- Rubbersheeting an Image on page 33
Save As Dialog Box

Use this dialog box to save an image; in the process you can change the file name, format, and location.

**Save As Options**

Save In
Specifications the folder to store the saved image.

Back
Returns to the previous folder.

Up One Level
Navigates up one level in the directory tree.

Search The Web
Displays the AutoCAD Web browser, where you can specify an Internet location and select drawing content for display in the AutoCAD Design Center palette.

Delete
Deletes the selected file.

Create New Folder
Creates a new, unnamed folder.

Views
Specifies how files are displayed.

Tools
Provides options for finding files, adding or modifying an FTP site, or saving a shortcut to the current folder.

Places List
Displays shortcut icons to locations such as the Desktop, FTP sites, and Buzzsaw.com.

File Name
Specifies the name of the saved image.

Save As Type
Specifies the format of the saved file.
Select a Lock File Directory Dialog Box

Use this dialog box to specify a directory for image lock files.

**IMPORTANT** The use of a single directory for lock files affects how files are edited anywhere on the network, and requires all users to use the same directory setting. For more information, see Help topic Locking Method for Image Files on page 260.

**Look In**
Specifies the current directory for image lock files. If you want to change it, use the arrow beside this field, in combination with the file list in the Name column, to navigate to a different directory. If you delete the entry here, each lock file will be stored in the same directory as the image it locks.

**Back**
Returns to the previous folder.

**Up One Level**
Navigates up one level in the directory tree.

**Search The Web**
Displays the AutoCAD Web browser, with which you can specify an Internet location.

**Delete**
Deletes the selected file.

**Create New Folder**
Creates a new, unnamed folder.

**Views**
Specifies how files are displayed.

**Tools**
Provides options for finding files, adding or modifying an FTP site, or saving a shortcut to the current folder.

**Places List**
Displays shortcut icons to locations such as the desktop, FTP, and Buzzsaw.com.

**Name**
Specifies the directories and files within the directory in the Look In field.
Select Coordinate System (Export) Dialog Box

Use this dialog box to select a GeoTIFF coordinate system for an exported image, or to specify no coordinate system.

Drawing Coordinate System
Specifies the coordinate system used in the drawing that references the image.

Select GeoTIFF System
Specifies the available GeoTIFF coordinate systems in three categories:

- **None.** Click to specify no coordinate system.
- **Geographic.** Click to see the complete list of geographic coordinate systems.
- **Projected.** Click to see the complete list of projected coordinate systems.

Code
Specifies the GeoTIFF code for the selected coordinate system.

Area Of Use
Specifies the region of the world where the selected coordinate system is used.

Select Coordinate System (Insert) Dialog Box

Use this dialog box to select a coordinate system for an image during the insertion process.

Category
Specifications the type of coordinate system used in the image. Select the nation, state, UTM datum, Lat/Long, or other suitable category.

Coordinate Systems In Category
Specifies the available coordinate systems in the category.

Properties
Click to see detailed properties of the selected coordinate system and its projection.

Select Global Coordinate System Dialog Box

Use this dialog box to select a coordinate system for an image.
Category
Specifies the type of coordinate system used in the image. Select the nation,
state, UTM datum, Lat/Long, or other suitable category.

Coordinate Systems In Category
Specifies the available coordinate systems in the category.

Properties
Click to see detailed properties of the selected coordinate system and its
projection.

Select Working Coordinate System Dialog Box
Use this dialog box to select or clear a working coordinate system for an image.

Category
Specifies the type of coordinate system used in the image. Select the nation,
state, UTM datum, Lat/Long, or None.

Coordinate Systems In Category
Specifies the available coordinate systems in the category.

Properties
Click to see detailed properties of the selected coordinate system and its
projection.

Target Color Dialog Box
Use this dialog box to select a new color for Change and Combine operations.

Palette
Displays a list of standard palettes. This list box is not available for Combine
operations.

Color Table
Specifies a color from the color table that is represented as a 32X8 grid of
colors. You can select a new color by clicking one of the colors from the
color table.

Custom Color
Creates a custom color in the Select Custom Color dialog box. This button
is not available for Combine operations.
Related procedures:

- Manipulating the Color Table on page 120

**Temporary File Location Dialog Box**

Use this dialog box to select a storage location for Raster Design temporary swap files.

Standard Windows controls across the top of the dialog and down the left side provide several ways to navigate to a storage location on local networks or the Web.

**Look In**

Displays the current storage location. Click the arrow to select a different location on a local or network drive.

**Text Recognition Setup Dialog Box**

Use this dialog box to configure the settings for text recognition operations.

**INPUT**

**Text Format**

- Machine Printed
  - Specifies if the text to recognize was created by a computer or other machine.
- Hand Printed
  - Specifies if the text to recognize was created by hand.

**Selection Shape**

Specifies the shape you use to outline the text for recognition, either rectangular or polygonal. The shape you choose also defines the area that is erased when you place the new text in the drawing.

**Dictionaries**

- Spelling
  - Activates spell check during the recognition process.
- Spelling Language
  - Specify a language to use when checking spelling during the recognition process.
AutoCAD Custom

Specifies using the current AutoCAD user dictionary in the recognition process. You can use a combination of the language dictionary and the current AutoCAD custom dictionary, or they can be used independently.

Language Character Set

Specifies the character set(s) to use during the recognition process. A character set is a group of 256 characters used by a specific language.

**NOTE** You can select multiple character sets, but each additional character set increases the number of possible characters the recognition engine searches for. Doing this slows the recognition process and increases the possibility of errors.

**Recognize**

Specifies the types of text that the text recognition engine must recognize in the current passage: one or more of Uppercase, Lowercase, Numbers, Punctuation, and Miscellaneous. If you clear a check box, the recognition engine does not attempt to display characters of that class.

**AUTOCAD OUTPUT**

**Output Type**

The first two settings specify whether the new text is created as regular AutoCAD text or multiline text (Mtext). The Recognize Table operation places all recognized text in the drawing as AutoCAD text.

**AutoCAD Style**

Specifies an AutoCAD style for the text entity. By default the AutoCAD style reflects the last style used with the Recognize Text or Recognize Table operation.

**Text Height**

**Automatic**

Specifies that the text entity height will be close to the original raster text height.

**Style Height**

Specifies that the text entity height is defined by the AutoCAD text style.

**Specified Height**

Specifies a text height. The value you enter for the specified height is applied to all text entities for the session or until you specify a new height.
Removal Method

None
Displays the vector text over the original text.

Rub
Removes the original text in the drawing and replaces it with the new vector text.

VERIFICATION DISPLAY

Specifies whether bold, italic, and underlined formatting in the recognized text is displayed in the Verify Text or Verify Table window. Selected formats are ignored in the display. For example, if the area of text you are working with has Italic formatting that you want the recognition engine to ignore, then select the Italic check box.

NOTE By default Italic and Underline are selected, but not Bold, because the recognition engine tends to incorrectly recognize text in engineering drawings as bold. Formatting options are also available in the Verify Text or Verify Table window.

Enable Verifier
If selected, displays the original raster text in a small window above the text that is being verified in Edit pane of the Verify Text window. Click in the Verifier window to close it.

Reset
Restores the default values in the Text Recognition Setup dialog box.

Related procedures:
- Entering Settings for Text Recognition on page 232

Transparent Color Dialog Box

Use this dialog box to change the transparent color for a grayscale or color image.

Click Select, then click the color in the image that you want to designate as the new transparent color on page 401.

Related procedures:
- Transparent Color of an Image on page 64
Vector Separation Options Dialog Box

Use this dialog box to control how vectorization tools assign line widths and layers to vectors as they are created.

You can access the Vector Separation dialog box from the VTools General tab of the Raster Design Options dialog box.

General Tab (Vector Separation Options Dialog Box)

Use this tab to automatically assign layer and polyline width values to the vectors created by vectorization tools based on the pixel width of the underlying raster. For more information, see General Vector Separation Options on page 251.

Width Table

Use Width Table

Assigns layer and polyline width values to vectors based on the width of the underlying raster.

Insert Below

Inserts a new row below the selected row in the Width Table.

Insert Above

Inserts a new row above the selected row in the Width Table.

Delete

Deletes the selected row in the Width Table.

Query Width

Displays the width of an entity you select in pixels and AutoCAD units.

Non-Continuous Entities

Override Width Table For Non-Continuous Entities

Overrides the Width Table and assign default values to non-continuous lines.

Layer

Assigns a default layer value to non-continuous lines.
Polyline Width
Assigns a default polyline width value to non-continuous lines.

**Default**

**Layer**
Assigns a default layer value to entities that do not fall into ranges specified in the Width Table.

**Polyline Width**
Specifies a default polyline width value to entities that do not fall into ranges specified in the Width Table.

**Import**
Imports vector separation settings. Vector separation files have a .vs extension.

**Export**
Exports vector separation settings. Vector separation files have a .vs extension.

**Save As Default**
Assigns the current vector separation settings the default values. The Default.vs file is stored in your CO2000I folder if Raster Design is installed locally. If Raster Design is installed as a network deployment, the Default.vs file is stored in your local config folder.

**Contour Tab (Vector Separation Options Dialog Box)**

Use this tab to automatically assign layer and polyline width values to the vectors created by vectorization tools based on their elevation. For more information, see Contour Vector Separation Options on page 246.

**Separate Contours By Elevation**
Assigns layer and polyline width values to contours based on their elevation.

**Interval Separation Information**

Use AutoCAD Land Development Desktop’s Settings
Uses the settings in AutoCAD Land Development Desktop for minor and major layers and intervals.
Minor
Interval
Specifies the elevation interval for minor contours. Raster Design will automatically assign vector contours whose elevation is a multiple of this value to the layer and polyline width that you specify.

Layer
Specifies a default layer for minor contours.

Polyline Width
Specifies a default polyline width for minor contours.

Major
Interval
Specifies the elevation interval for major contours. Raster Design will automatically assign vector contours whose elevation is a multiple of this value to the layer and polyline width that you specify.

Layer
Specifies a default layer for major contours.

Polyline Width
Specifies a default polyline width for major contours.

Import
Imports vector separation settings. Vector separation files have a .vs extension.

Export
Exports vector separation settings. Vector separation files have a .vs extension.

Save As Default
Makes the current vector separation settings the default values. The Default.vs file is stored in your CO2000I folder if Raster Design is installed locally. If Raster Design is installed as a network deployment, the Default.vs file is stored in your local config folder.

Verify Text/Table Dialog Box
Use this dialog box in text recognition operations to examine the source text and control the format of the output text. The dialog is called Verify Text or Verify Table, depending on which option was selected.
**Viewer Pane Controls**

- ![Zoom icon] Zooms in so the text fills the width of the view window and there is no horizontal scroll bar.

- ![Zoom icon] Zooms in so the text fills the height of the view window and there is no vertical scroll bar.

- ![Zoom icon] Zooms in so the text is completely contained in the corresponding pane at the greatest zoom possible.

- ![Zoom icon] Zooms in to expand the recognized raster text in the pane by a factor of 25%. The text may be zoomed in to a maximum factor of 300%.

- ![Zoom icon] Zooms out to shrink the recognized raster text in the pane by a factor of 25%. The raster may be zoomed out to a maximum factor of 25%.

- ![Print icon] Prints the data from the pane.

**Editor Pane Controls**

- ![Zoom icon] Zooms in so the text fills the width of the view window and there is no horizontal scroll bar.

- ![Zoom icon] Zooms in so the text fills the height of the pane and there is no vertical scroll bar.
Zooms in so the text is completely contained in the pane at the greatest zoom possible.

Zooms in to expand the recognized raster text in the pane by a factor of 25%. The text may be zoomed in to a maximum factor of 300%.

Zooms out to shrink the recognized raster text in the pane by a factor of 25%. The raster may be zoomed out to a maximum factor of 25%.

Applies bold formatting to the selected text in the Editor pane.

Applies italic formatting to the selected text in the Editor pane.

Applies underline formatting to the selected text in the Editor pane.

Specifies the display of non-printing characters such as Tab and Space.

Reverses the last editing action.

Prints the data from the pane.

**Recognition and Output Controls**

**Suspect Word**
- Displays the unrecognized word.

**Rejected Character**
- Displays unrecognized characters or artifacts.
Change To
Specifies a replacement for the suspect word or rejected character from the drop-down list.

Find Next
Moves to the next suspect word or rejected character.

Replace
Replaces the suspect word or rejected character with the selection in the Change To box.

Add To Dictionary
Adds the suspect word or rejected character to the to the Recognition dictionary.

AutoCAD Style
Specifies an AutoCAD style.

Output To
Specifies the conversion of the raster text as either AutoCAD Text or AutoCAD MText.

Justify
Specifies the text alignment as right, left, or center.

Setup
Displays the Text Recognition Setup dialog box.

Export
Exports the text in the Edit pane for use in another application.

Related procedures:
- Using the Verify Text Window on page 236

VText Edit Dialog Box
Use this dialog box to enter and edit vector text.

Type the text string to be added, then press OK to insert it at the point you previously specified.

To edit existing vector text in the drawing, double-click the text. It appears in this dialog box, where you can change it as required.
Glossary

3-point affine transform A type of coordinate transformation that can be applied to images upon insertion. This option replicates the transform used on non-editable data types. This type of transform is a translate, rotate, independent x-y scale transform without shear.

4-point rubbersheet transform A type of coordinate transformation that can be applied to images upon insertion. This option provides an approximate transformation that is most accurate in the vicinity of the reference points, but contains some distortion in other regions of the image.

access key The key that corresponds to an underlined letter on a menu, command, or dialog box.

active path The location from which the current image file is actually being loaded. It can be a local path, a network path, or an Internet address.

Always Detach An option in the Raster Design Options dialog box. If you erase the image frames, this option automatically detaches the images.

aperture The square region, centered on the cursor crosshairs, where entity selection can occur when raster snap mode is active; also known as the snap window. You can also specify minimum and maximum pixel widths to snap to. See also snap window.

apparent intersection The point where two entities would intersect if one, or both, were extended.

aspect ratio The ratio of an image height to its width. See also bias.

attach When you insert an image into a frame, the image is attached to the drawing. You can use the AutoCAD IMAGEATTACH command to attach an image, or you can use the Raster Design insert command to attach an image. Attaching and inserting refer to the same process.

AutoInsert A Raster Design option for automatically inserting images in a drawing created with CAD Overlay ESP or GSX, which are earlier versions of Raster Design.
**AutoReplace** A Raster Design option that replaces the image path of a previously inserted image by matching the drawing name.

**Autorub** A Raster Design command that removes raster objects as you trace them with the vectorization tools. This option uses the Rub/Crop line width to determine the width of the raster that is removed.

**base point** A point used for relative distance and angle when moving, copying, or rotating objects. Example: On the image, select the base point that you want to move to the destination point.

**bias** The ratio of image width to image height, also called aspect ratio. You can change the bias of an image by using the Raster Design ibias command.

**bicubic** A pixel resampling method that computes the value for a new pixel based on interpolation of the values in a 4x4 block of surrounding pixels. This method provides a good compromise between accuracy and speed for most images.

**bilinear** A pixel resampling method that computes the value for a new pixel based on linear interpolation of the values in a 2x2 block of surrounding pixels.

**binary image** See bitonal image.

**bitmap (BMP)** An image format. It can be compressed or uncompressed. Uncompressed BMP files contain raw data on a boundary of 4 bytes per raster. Compressed files are similar to the run length encoded PCX files, with minor variations. Only 4- and 8-bit files can be compressed.

**bitonal image** A two-color, 1-bit image, usually a line drawing such as a floorplan or parcel map. This image type is also called binary. The background color of a bitonal image can be transparent or solid. The foreground color can be any color.

**blank distance** The distance between dashes in a dashed line.

**blurring** In Raster Design, a method for evenly weighing all pixels in the kernel, including the target. This filter, while similar to Low Pass #2, gives slightly brighter results.

**blurring artifacts** A loss of image detail that can occur with image compression and resampling techniques. The symptoms include excessive smoothness where different colors meet, color bleeding, and a loss of color texture.

**boundary** See frame, image frame.
bounding outline  The visible element (usually a dotted rectangle) that is displayed when you select a region. Also called bounding box.

brightness  The luminance of pixels in an image. A higher brightness value makes all the pixels lighter.

CAD Overlay GSX and CAD Overlay ESP  Previous releases of Raster Design.

CALS  Acronym for the raster image format Computer Aided Acquisition Logistics and Support. CALS files are black and white images used by the US Government as part of the transition to electronic media. CALS images are Fax Group IV compressed and are therefore a good way to store black and white line drawings and scans.

channel  A red, green, or blue color signal. Each Raster Design color image is composed of one or more color channels. In a single-band 8-bit image, the color palette translates the index triplet for each color into a value for each color channel, with a limit of 256 total colors for any pixel. In a true color, or 24-bit image, separate red, green, and blue data bands provide color values to each channel, and each pixel can represent a value from 0 through 255 in each of the three channels.

The Band Assignment color map for multispectral images assigns image bands to color channels.

clipped image  An image that has been cropped or reduced in area. The regions of the image that are outside the clip boundary are hidden from view. You can turn off the clip or you can delete the clip to redisplay all of the image. Unlike a crop, a clip is a display-only feature that you can use for viewing and plotting purposes. It does not permanently change image data.

color depth  The amount of information stored with each pixel to define its color or shade. Common color depths are as follows:

<table>
<thead>
<tr>
<th>Color Depth</th>
<th>Type of Image</th>
<th>Available Color(s)</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 bit</td>
<td>Bitonal</td>
<td>1 color</td>
</tr>
<tr>
<td>8 bit</td>
<td>Grayscale</td>
<td>256 shades of gray</td>
</tr>
<tr>
<td>4 bit</td>
<td>Color</td>
<td>16 colors</td>
</tr>
<tr>
<td>8 bit</td>
<td>Color</td>
<td>256 colors</td>
</tr>
<tr>
<td>16 bit</td>
<td>Grayscale</td>
<td>65,536 shades of gray</td>
</tr>
</tbody>
</table>
color map  An assignment of colors to data values for the purpose of displaying the contents of a file in a meaningful way.

Users work with two main types of color maps. A palette color map is used with digital elevation models (DEM) to specify whether to display surface elevations or slopes, and how to distribute the set of colors across the range of data values.

A band assignment color map is used with multispectral data to select the data bands to display and to assign each band to a color channel (red, blue, or green).

Raster Design automatically assigns a color map to image files that are inherently displayable, such as aerial photos and bitonal images.

color map  An assignment of colors to data values for the purpose of displaying the contents of a file in a meaningful way.

Users work with two main types of color maps. A palette color map is used with digital elevation models (DEM) to specify whether to display surface elevations or slopes, and how to distribute the set of colors across the range of data values.

A band assignment color map is used with multispectral data to select the data bands to display and to assign each band to a color channel (red, blue, or green).

Raster Design automatically assigns a color map to image files that are inherently displayable, such as aerial photos and bitonal images.

connected crossing polygon  A selection method for enhanced bitonal region objects. This method selects all raster entities that are within the polygon, crossing the polygon, or connected to entities that cross the polygon boundary. In the following example, note that the text in the upper right is not selected because it is the only entity not connected to entities that cross the polygon boundary.

connected crossing polygon  A selection method for enhanced bitonal region objects. This method selects all raster entities that are within the polygon, crossing the polygon, or connected to entities that cross the polygon boundary. In the following example, note that the text in the upper right is not selected because it is the only entity not connected to entities that cross the polygon boundary.
connected entity 1. An entity that is connected to an entity that is selected or otherwise referenced.
2. A selection method for enhanced bitonal region objects. This method selects a specified entity and all other entities connected to it. In the following example, note that a single click on the arrow in the upper right selects the entire connected structure except the two text entities, which are not connected to any other entity.

connected fence A selection method for enhanced bitonal region objects. This method selects all raster entities that are connected to an entity that touches the selection line (fence) you draw. Entities enclosed by the fence but not touching it are not selected. In the following example, the two text blocks are not selected because they do not touch the fence and are not connected to any entities that touch the fence.
**connected window** A selection method for enhanced bitonal region objects. This method selects only those raster entities that are entirely within the window you define and are not connected to any entity that extends outside the window. In the following example, note that the arrows are not selected because they are connected to lines that extend outside the window.

![Connected window](image)

**connected window polygon** A selection method for enhanced bitonal region objects. This method selects only those raster entities that are entirely within the polygon you define and are not connected to any entity that extends outside the polygon. In the following example, note that the arrows are not selected because they are connected to lines that extend outside the polygon.

![Connected window polygon](image)

**continuous tone** A shaded image, sometimes called halftone in traditional printing.

**convolve filter** A type of image processing filter that can be used with grayscale images for various operations, such as smoothing or sharpening the image details.

**copylast** An option that is available when vectorizing text. It displays the VText Edit dialog box, which contains the last text string you placed in the drawing. You can edit the text string if needed, and then click OK and pick an insertion point for the copy.

**correlate** The process of positioning an image within the AutoCAD coordinate system so that the image dimensions and coordinates match AutoCAD units and coordinates.
**crop** A selected area of a raster image. Pixel data outside the crop is deleted. The image frame size is adjusted automatically. A crop permanently alters an image.

**data organization** The method of organizing the image data when the image is saved. The data organization can be stripped, tiled, or monolithic.

**datum** A reference point, line, or surface.

**decrement** To decrease by one.

**DEM** Digital elevation model. A format for recording land elevations in a digital file. A regular grid of survey points is created over the surface, and the elevation of each point is recorded as a floating-point number.

**density** The number of dots per linear unit at which an image is scanned or created. The more dots per unit, the higher the density and clarity of detail. Also called resolution or pixel density. See also DPI.

**density units** The linear units on which the image density is based. Example: Inches are the density units of an image that was scanned at 300 dots per inch.

**density value** The number of dots per unit that make up the image density. Example: An image scanned at 300 dots per inch has a density value of 300.

**deskew** To rotate a raster image, usually for the purpose of aligning it orthogonally with the AutoCAD coordinate system.

**destination point** The location to which you move an image. To move an image, you must pick a source point and a destination point.

**detach** To completely remove an image from a drawing. To reverse a detach operation, you must insert the image from its source. Operations similar to detach but less permanent are erase, unload, and hide.

**displace** To move an image from a source point to a destination point.

**display** The visual output device and its technology, such as a CRT-based display, a flat-panel display, or the graphics portion of your monitor.

**display order** The order in which images are displayed in AutoCAD. This sequence determines which images are above or below other images, and affects image visibility.

**dither** The process of using a pattern of solid dots to simulate more colors than are actually available.

**donut** A circle with a specified linewidth.
DOQ Digital orthophoto quadrangle raster image format, used for aerial photos that are processed to remove distortion. A typical DOQ represents one quarter of a USGS topographic map at 1:24 000 scale.

DPI Dots per inch. A measure of image density. See also resolution, density, PPI.

Draft An option in the Raster Design Options dialog box that does not dither the pixels. This setting is recommended for bitonal images.

drawing image A raster file of a drawing, a photograph, a map, or a satellite image that you can edit, manipulate, and manage using Raster Design.

drawing unit The unit on which an AutoCAD drawing is based. Example: A common Imperial drawing unit is inches. A common Metric drawing unit is meters.

DTED Digital Terrain Elevation Data. A grid-based file of elevation points. This format was developed by the U.S. National Imagery and Mapping Agency (NIMA).

ECW Enhanced Compressed Wavelet. A highly-compressed multiresolution image format from ER Mapper, Inc.

edge enhancement filters Filters that improve the quality of an image by extracting individual elements, such as boundaries and property lines. You can also use these filters for object extraction or object recognition by higher-level algorithms.

EISA Extended Industry Standard Architecture

embed To store a raster image in a drawing, rather than as a file external to the drawing. Embedded images can be viewed in an AutoCAD-based application only if the application is installed with AutoCAD Raster Design or the Object Enabler for AutoCAD Raster Design.

Enable Mask A Raster Design option on the Image Mask Properties tab that enables an existing mask for display. Enabling allows you to view the image clip as defined by the image mask.

encoding Compression method that is applied to an image when the image is saved. An encoding method can compress the image file to save disk space.

enhanced bitonal region object A type of raster entity manipulation (REM) object that includes several lines, arcs, or circles within a bitonal raster image. For illustrated definitions of the types of enhanced bitonal region objects, see “connected” and “smart” in this Glossary.
equalization A function that brings out details in an image. Equalization changes the darkest pixels in an image to black and the lightest pixels to white, then reassigns the remaining pixels to use all of the colors in between. Also called non-linear contrast stretch.

erase To remove an image insertion from a drawing. This operation removes the image and frame from the drawing, removes the insertion object and its color map from the toolspase, but leaves an unreferenced data definition in the image data view. The color map is not erased from the image data view if it is used by other insertions. To reverse an erase operation, do a new insertion from the data definition object. Whether an erased image is also detached depends on how the Image Detach Options are set on the User Preferences tab of the Raster Design Options dialog box. See also detach.

ESRI Grid An image format used in ESRI GIS products. This format is available in ASCII and binary versions.

Export A Raster Design operation for saving an image to another file format and writing out correlation data for the image. The correlation data stores insertion point, scale, rotation, and density information for the image. When you export an image, you can save the correlation data to a resource file, a world file, or to the image file. The type of correlation data you can create depends on the type of image being exported.

fillet A rounded corner where two lines meet. Raster Design can apply fillets of specified radius to line intersections in bitonal images.

filter An editing tool that can be used to adjust the appearance of an image. Example: The Invert filter reverses light and dark areas on an image. Also called editing filter.

FLIC Acronym for the image format Animator FLIC.

follower A vectorization tool that traces raster lines in a bitonal image and creates vectors that AutoCAD recognizes as individual objects.

foreground color The color of the raster objects in a bitonal image. The other color in the image is the background color.

frame A rectangular vector object that encloses an image. You can select the image frame by clicking it, or by using any AutoCAD selection method. The image frame is an AutoCAD object that you can assign to a layer, reposition, or scale, using standard AutoCAD methods. A frame can become an irregular shape if the image is cropped or clipped. See also image frame.

freq value In a histogram image, the frequency value of a color or shade of gray: the number of pixels that use the indicated tone.
Gap Width A setting that defines the maximum gap (from 0 to 10 pixels) that Raster Design can ignore as it follows a raster line, polyline, or contour. Raster Design ignores any gap that is equal to or smaller than the Gap Width. This setting is useful for scanned images that have many disconnected raster lines or in which pixels are missing as a result of imperfect scans.

dgeo-referenced image An image that references real-world coordinates in its correlation source. Example: Geo-referenced images include GeoSPOT, GeoTIFF, and images that use world files as their correlation source.

GeoSPOT An image format from SPOT Image Corporation that supports georeferencing information.

GeoTIFF A type of tagged image file format (TIFF) that supports geo-referencing information.

GIF Graphics Interchange Format. A raster image format created by Compuserve.

GIS (Geographic Information Systems) Computerized decision support systems that integrate spatially referenced data. These systems capture, store, retrieve, analyze, and display such data.

global coordinate system A method for defining points on the earth in a Cartesian coordinate system, taking into account the curvature of the earth's surface.

gradient directional edge enhancement filters Filters that improve the quality of the line where an object begins or ends by extracting individual elements. These filters use the vector sum of the three coordinate variables X, Y, and Z, taking into account their direction in space. You can use the gradient directional edge enhancements filters in any one of the eight compass directions. Use of these filters results in a black background with white outlines of the objects in the image.

gray scale image An image usually created by a scanner in which continuous tones are represented as uniform shades of gray. Each pixel uses eight bits of information, producing 256 shades of gray.

grip(s) Small boxes displayed at various points on a selected object that can be used to edit the object. Select a grip and then specify a grip editing function.

hide To remove an image from the display while retaining it in active memory. The image frame remains visible. To reverse a hide operation, select the image frame or the toolspace object, then right-click and select Show. See also detach.

high pass filters A means for enhancing the edges of images. Images that do not appear clear may also be sharpened by high pass filtering.
**histogram** A bar graph that shows the number of pixels for each color in the selected image or images. An aid for image editing operations.

**hybrid** A type of drawing that includes both raster and vector data.

**IG4** Acronym for the image format Group 4 data with IST headers.

**IGS** Acronym for the image format Image Systems Gray Scale.

**image** A graphic that is composed of raster data. See also drawing image.

**image format** The method in which an image was created and saved, such as bitmap, CALS, RLC, or GIF. Some image formats, such as PICT, are read-only.

**image frame** A frame that encloses each image you insert (also called a boundary). If you select an image frame, grips appear and hatch marks are drawn over the image to indicate that you have selected it. See also frame.

**Image Properties** The properties of color, layer, and frame linetype settings of each image.

**image selection** A collection of data treated by Raster Design as a unit. Example: When you select an image by clicking its frame, the image moves to the top of the display order, obscuring any vectors that intersect with it.

**image unit** The unit at which an image was scanned or created. Example: If you scan an image at 300 dots per inch, the image unit is inches.

**Index Color (8-bit)** An image type that contains up to 256 colors.

**index value** The numeric identifier (0 to 255) of a color or shade of gray. These values are used in the Histogram and the Palette Manager.

**invert** A filter used to reverse position, order, or relationship. Example: You can invert the image to create a positive image. Use the Invert filter to reverse the dark and light areas of an image.

**JFIF - JPEG** Acronyms for image formats created by Joint Photographic Expert Group. JFIF is JPEG File Interchange Format. It uses a compression scheme that gives preference to compression rather than data preservation. Best suited for 24 bit images.

**JPEG 2000** An advanced raster image format from Joint Photographic Expert Group, featuring options for lossless compression, wavelet compression, incremental decompression, and support for up to 48-bit color.

**Lanczos** A pixel resampling method that computes the value for a new pixel by interpolating the value of a 6x6 block of surrounding pixels.
Landsat FAST L7A A multispectral image format used by Landsat 7 satellite, which was launched in 1999.

layout Management of images, to determine how they are displayed and in what order they are listed in the Image Management dialog box.

linetype The display style of a line, such as continuous or dashed.

low pass filter A means of extracting individual elements in areas where pixel intensities change rapidly, thereby reducing high-frequency detail. The effect is a slightly blurred image.

LZW A file compression algorithm, commonly used with TIFF and GIF files.

Maintain Drawing Link A Raster Design export option that, if selected, overrides the image you selected to export.

mask An object used to display and plot a subset of the images in your drawing. A mask clips the images inside the mask boundary and hides or unloads the images completely outside the mask boundary. The mask boundary is an AutoCAD object that you can move, stretch, scale, and erase, like any other AutoCAD object.

median filter A convolving filter that removes random visual speckles from an image by changing each pixel value to match the average value of the neighboring pixels.

merge commands Raster Design commands used to merge images, merge vectors into raster images, and select raster pen widths.

merge images To group two or more images into a single image file.

mirror To create a new version of an existing object by reflecting it in relation to a line or plane. Example: Scanning software might mirror a drawing, or you might scan the back of a drawing by mistake. You can correct these problems by mirroring the image.

Mitchell A pixel resampling method that uses a cubic spline technique. It is widely considered to provide a good compromise between ringing and blurring artifacts on most images. See also blurring artifacts, ringing artifacts.

monolithic Encoding method for TIFF files. Saves image data in one piece, and may result in slower processing time. See also data organization.

multiframe image data An image type that includes multiple related images within a single file. Each image is in a separate frame, and the images are usually related. For example, they could represent a series of drawings, pages from a document, an animation sequence.
Or they could represent a multispectral image set. Common multiframe file formats include GeoTIFF and NITF.

**multispectral image data** Data recorded in the form of multiple bands. Each band records the values in a specific range of the spectrum, such as infrared, visible, or ultraviolet. Data gathered by satellites is typically provided in multispectral format. A band assignment color map is used to create false color images from these bands. The color map can be configured to highlight surface features, such as vegetation and water.

**native capture** Copies a REM object using the image data directly from the image file, ignoring display scale and rotation of objects. Used only for the REM Copy To Clipboard command.

**nearest neighbor** A pixel resampling method that assigns to a new pixel the value of the closest pixel in the original image. This is the fastest resampling method, but it produces the crudest results.

**Never Detach** An option in the Raster Design Options dialog box that does not detach an image even if all image frames that reference the image are erased from the drawing.

**NITF** National Imaging Transmission Format. This multiframe image format is commonly used by US federal agencies and NATO.

**node** In v, a link end point that can be represented as a block or point object. Example: You can force the line follower to ignore the intermediate nodes and draw a single straight line between the start and end points of a line.

**noise** Random pixels that can result from poorly scanned images.

**non-georeferenced image** An image that does not include real-world coordinate information.

**non-linear contrast stretch** See equalization.

**non-orthogonal image** A graphic representation that intersects or lies at angles other than right angles. Also called non-ortho image.

**ortho-corrected image** An image that is corrected so all pixels represent their true locations on the face of the earth, making directions and distances accurate. Errors resulting from parallax, lens distortion, and other causes are corrected.

**orthogonal** Intersecting or lying at right angles (0, 90, 180, or 270 degrees).

**palette** The range of up to 256 colors used in an 8-bit image.
parallax The apparent displacement of position of an object, caused by a shift in the point of observation.

PCX A simple run-length encoded image format.

Pick A Raster Design device for selecting points on the screen.

PICT An image format created by Apple Computer.

pixel A single dot on the screen. Pixels are the building blocks of raster images, and are individually assigned different colors or shades of gray. Image pixel size varies depending on the resolution of the image. A 2X2 pixel in a 400 dpi image is one quarter the area of a 2X2 pixel in a 200 dpi image.

pixel size Image density expressed as the area of a pixel, typically used with aerial photography and satellite imagery.

PNG Portable Network Graphics. A raster image format.

positive image An image in which the light and shade areas correspond to the original image.

PPI Pixels per inch. Also called dpi, or dots per inch. See also DPI.

projection Data devised by cartographers and mathematicians to depict three-dimensional shapes (like the earth) on two-dimensional surfaces with known distortion.

quad sheet A device for reducing image file size. Many maps are broken up into quadrants, which are square and are called quad sheets. When a group of quad sheets is inserted into a drawing, the drawing is considered to be tiled.

QuickBird TIFF A multispectral image format produced by DigitalGlobe from its QuickBird satellite.

raster data A series of dots, or pixels that form an image. This type of data is produced when you scan a paper drawing, a blueprint, or a photograph. A raster image is composed of pixels.

raster entity A series of contiguous pixels that form a single entity such as a line, rectangle, or circle. Raster Design can recognize such entities and create vector entities or regions that can be more easily edited than the raster originals.

raster entity manipulation (REM) An object-oriented method of editing raster entities in bitonal, color, and grayscale images. REM handles raster entities much like vector objects. There are three types of REM objects: region objects, enhanced bitonal region objects, and primitive objects.
raster impact point  The point where a vector polyline intersects a raster entity.

raster object  A distinct line, circle, or arc in a bitonal raster image. Raster objects can be vectorized or edited using raster entity manipulation.

raster pen  A Raster Design tool that allows thickening of vector objects when you merge them into the image. Thicknesses are assigned according to the specified entity color.

raster snap  A setting that automatically places the cursor at the end, center, corner, intersection, or edge points on a bitonal raster entity. If you choose more than one snap mode, then the crosshairs snap to the closest of the possible snap points.

resolution  The number of dots per unit at which an image is scanned or created. Example: An image scanned at 600 dots/inch (dpi) has a higher resolution than one scanned at 300 dpi.

resource file  A file used by Raster Design to store image correlation data such as insertion point location, scale, and rotation. Resource files have a .res extension. They can be created by the Export command and can be read only by Raster Design. See also world file.

RFT  Revisable form text.

RGB  Red-green-blue color channels.

ringing artifacts  A loss of image detail that can occur with image compression and resampling techniques. The symptoms include ripples or similar interference along edges where two dissimilar colors meet. The sharpness of the edges is degraded.

RLC  Run-Length Coding raster image format. Raster Design can read RLC1 and RLC2. RLC1 is a plain RLC with no header. RLC2 is an RLC1 with IST headers. See also run-length coding.

RLC2  Run-Length Coding raster image format with IST headers. See also run-length coding.

rotation angle  The angle at which an image is being revolved about its axis.

RTF  Rich text format

rub  To remove a line or area from an image with a Raster Design Rub command (e.g., irubline, irubar). A rub changes the pixels in a selected area to the transparent color. When background transparency is turned on for the image, the rubbed area becomes transparent. Rub permanently alters your image.
rubbersheet To match points in an image to known reference points in a coordinate system by warping the image using a triangular or polynomial transformation.

run-length coding A data compression method that replaces a run or sequence of identical data units (such as pixels) with a single unit and the length of the run.

saved path The image file name saved in the drawing. It can be a simple file name, a local path, a network path, or an Internet address.

scale The defined dimensional relationship between units of linear measurement on the earth’s surface and those on a map or aerial photo.

scaling A method of proportionally changing the size of a raster image in reference to existing raster or vector entities without rotating it.

shading The use of marking made within outlines to suggest three-dimensionality, shadow, or degrees of light and dark in a picture or drawing. Example: You can use the sharpening filters on grayscale images to make differences in shading more distinct. It may be necessary to use sharpening filters to extract the highest amount of useful data from a low-resolution scan.

sharpening filters A device for enhancing details in images. Sharpening filters, with the exception of the matched filters, use spatial filtering with a 3x3-pixel kernel.

Show Image Frame(s) An option on the Image Mask tab of the Raster Design Options dialog box. Shows the frames of the images that are hidden or unloaded.

SID (MrSID) Multiresolution Seamless Image Database. A highly-compressed image format from LizardTech, Inc.

Single Image Optimization A Raster Design feature that automatically selects your image when you run a Raster Design command that requires an image to be selected. You are prompted to select an image only if you are working with multiple images.

smart crossing polygon A selection method for enhanced bitonal region objects. This method selects all raster entities that lie within or cross into the polygon you draw. If any part of the entity crosses the polygon boundary, the entire entity is selected. In the following example, note that the horizontal lines and the circle are selected because they cross the polygon boundary.
smart crossing polygon

A selection method for enhanced bitonal region objects. This method selects all raster entities that lie within or cross into the rectangular window that you draw. If any part of the entity crosses the window boundary, the entire entity is selected. In the following example, note that two horizontal lines that cross the window boundary are selected.

smart crossing window

A selection method for enhanced bitonal region objects. This method selects all raster entities that lie within or cross into the rectangular window that you draw. If any part of the entity crosses the window boundary, the entire entity is selected. In the following example, note that two horizontal lines that cross the window boundary are selected.

smart fence

A selection method for enhanced bitonal region objects. This method selects all raster entities that touch a selection polyline (fence) that you draw. Entities enclosed by the fence but not touching it are not selected. In the following example, the text 8.94 is not selected because it does not touch the fence.

smart window

A selection method for enhanced bitonal region objects. This method selects only the raster entities that lie entirely within the rectangular selection window. In the following example, the arrow and number within
the window are selected, but the horizontal lines that cross the window boundary are not selected.

**Smart window polygon** A selection method for enhanced bitonal region objects. This method selects only the raster entities that lie entirely within a polygon that you draw. In the following example, the circle and horizontal lines that cross the polygon boundary are not selected.

**smoothing filters** A device for removing details or unwanted speckles in images. Smoothing filters use spatial filtering with a 3x3-pixel kernel.

**snap window** The square region, centered on the cursor crosshairs, where entity selection can occur when raster snap mode is active; also known as the aperture.

You can also specify minimum and maximum pixel widths to snap to. The snap window snaps only to the bitonal objects that are between the minimum and maximum pixel widths.

**source point** The location from which you move an image. To move an image, you must select a source point and a destination point.
**spatial resolution** Image density expressed in pixels per unit, typically used with scanned images.

**speckle** An unwanted random spot in an image. Speckles or stray pixels can often appear in an image when you scan drawings or blueprints that are dirty or wrinkled. You can remove speckles from your bitonal images by using the Despeckle filter.

**stripped** Encoding method for TIFF files. Breaks up image data into strips for quicker processing. See also data organization.

**supported image types** Raster Design supports bitonal, grayscale, and up to 24-bit color images, along with digital elevation models (DEM), multispectral imagery, and generic integer data in 16- and 32-bit format.

**TARGA** A raster image format created by Truevision Inc. Usually 16-bit or 24-bit true color. Can be 8-bit grayscale or simple run-length coded.

**Threshold** A Raster Design operation for converting color or grayscale images to bitonal format. Within the range of grayscale values in an image, the threshold marks the upper limit of black pixel values and the lower limit of white pixel values. Raster Design can set the threshold value automatically, but you can manually adjust it before conversion, using the Threshold tab of the Histogram dialog box.

**thumbnail** A miniature representation or preview of an image. Thumbnails are used in the Raster Design Insert Image dialog box, the Histogram dialog box, and the AutoCAD Image Adjust dialog box.

**TIFF** Acronym for the tagged image file format.

**tiled** Encoding method for TIFF files. Breaks the image data into rectangular, tiled regions for quicker processing. See also data organization, quad sheet.

**toggle** To switch between two options of an electronic device, usually by pressing a single button. Example: The Raster Design Toggle command changes the visibility of the image frame.

**transparent color** A selected color that is transparent in a grayscale or color image. If background transparency is turned on for the image, all pixels of the transparent color become transparent. Any time you use a Rub command, the color of the rubbed area is changed to the transparent color.

**true color (24-bit) image** An image that can contain up to 16.7 million colors. This image type is composed from three 8-bit data bands: red, green, and blue.
true coordinate transform A type of coordinate transformation that can be applied to images upon insertion. This option applies to each pixel of the image, and produces the most accurate results. See also 3-point affine transform and 4-point rubbersheet transform.

unembed To remove an embedded image from a drawing. The unembedded image must be saved as an independent file. See also embed.

unload To remove image data from the display and the working memory of a drawing. The image frame remains visible, and the image object remains in the Image Manager toolspace tree. To reverse an unload operation, do a reload. See also detach.

vector A mathematical object with precise direction and length, but without specific location. Vector data is stored as XYZ coordinates that form points, lines, areas, and volumes.

vectorize Converting a bitonal raster image to vector data. You can use the Raster Design vectorization tools to vectorize a raster image. See also follower, VTools.

VTools Raster Design vectorization tools used to manually convert bitonal raster arcs, circles, lines, or rectangles to equivalent vector objects.

VTools Removal A setting on the VTools General tab of the Raster Design Options dialog box that controls what happens to the underlying raster entity when vectorization tools are used to vectorize the raster entity. Depending on the Removal Method setting you choose, the raster entity can be rubbed or REM deleted.

wavelet Multiple resolution image files compressed to a small fraction of their original size.

world file A file that stores correlation information for an image, consisting of scale, rotation, and insertion point. World files can be created by the Export command to correlate an image in another graphics application. The world file is in ASCII format that you can view using Notepad. World files are saved in the folder where the image is located. Their extensions vary, depending on file type, but always end in w. Examples:

- BMP - bpw
- GIF - gfw
- IG4 - i4w
- TIFF - tfw
X Y and Z coordinates Any of a set of numbers used to specify the location of a point on a line, on a surface, or in space.
Index

 pf (palette file) 127
 exporting 130

3-point affine transform 27
4-point rubbersheet transform 27

A
active path 77
arc
convert raster to vector 217
rub 152
assign coordinate system, dialog box 307
AutoCAD image objects 8
AutoPaste command 258
AutoRub command 268

B
bias 88
binary image. See bitonal image. 63
bitonal filters, types 304
bitonal filters, using 114
bitonal image
change foreground color 63
convert raster entities to vector 205
despeckle 86
mirror 90
touch up 91
black and white images 102
blurring filter 110
boundary 83
brightness and contrast adjustment 94

capture image 49
change display qualities 287
circle, rub 153
circular 155
circular, crop raster data 148
circular, rub 155
circular, region objects 174
cleanup
bias 88
deskew 85
despeckle 86
invert light and dark shades 90
mirror 90
overview 84
touchup 91
clear path 78–79
clear REM objects 199
COGO Points 84
color
between merged images 64
change foreground 63
REM objects 267
rub and crop 64
color depth 118
color image
brightness and contrast 94
convert to black and white 102
convert to grayscale 100
mirror 90
reverse light and dark shades 90
transparency color 64
commands
AutoCAD 287
command line 278
Raster Design 278
REM toolbar 298–300
toolbar 296
Vtools 205
compressing, image palette 120, 126
configure
CAD Overlay image importing 258
correlation defaults 247

CAD Overlay
importing images to Raster Design 258
program history 9
correlation search paths 249
default image settings 255
file locking method 260
frame display 61
image detach method 254
image display quality 60
image mask behavior 256
mask settings 141
message display method 261
mouse settings 262
new image default properties 263
polyline/contour follower 272
QSave 264
raster entity detection 266
raster removal method 270
REM objects 267
resource file directory 249
rub/crop line width 268
startup 265
thumbnails 257
vector merge 270
vector separation, contours 246
vector separation, general 251
vectorization tools 252
contour 221–222
contour, convert raster to vector 222
control points, rubbersheeting 33
convert
raster to vector 205
arc 217
circle 215
contour 222
pline 209, 219
polyline 209, 219
rectangle 214
text 227
REM objects to raster image 201
convolve filters, overview 107
coordinate system assignment 307
Copy to Clipboard command 202
copying, images to clipboard 68
correlate 23, 85, 247
image default settings 24
Insertion Wizard 25
matching angle 85
matching points 30
options 23
scale 32
set defaults 247, 353
correlation
during insertion 23
exporting world files 54
methods 30
rubbersheeting 33
crop
circular region 148
color 64
diagonal region 149
line 147
line width 268
polygonal region 150
raster data 147
rectangular region 148
curve
fitted 103
gamma 103
piecewise linear 103
D
default image settings 255
defaults 353
correlation 247
image 353
mask 355
density 117
and image scale 117
default 247
units 117
value 117
deskew, overview 84
despeckle 86
detach 76
detach image options 254
details in images 98
diagonal, crop 149
diagonal, rub 156
Dialogs 303
directory 260
correlation files 249
lock files 260
reading correlation files 249
resource files 249
Display Manager layer capture 49, 309
display order, changing 75
distortion
  correcting 88
drafting settings, dialog box 310
Dynamic Input, and vectorization 207
dynamic input, for vectorization 206
DYNMODE settings, and vectorization 207

E

edge enhancements filters 112
gradient directional 113
  Laplacian 112
matched filter 113
  shift and difference 112
edit
  bias 88
  cleanup commands 84
  despeckle 84
  invert 84
edit mode menu 189
edit raster using REM objects 189
edit status, dialog box 312
editing
  pixel touchup 91
editing filters
  bitonal 114
  brightness and contrast 94
  color images 100
  convolve 107–108
  despeckle 86
  grayscale 100
  grayscale to black and white 102
  harshness and noise 107
  light and dark shades 90
  maximizing details 98
  mirror an image 90
editing non-REM images 169
embed image 44
enhanced bitonal region objects 168, 178
erase image 76
erase image, options 254
export image 50
  FTP site 53
  World File 54
export options, dialog box 315
Export Palette dialog box 120
exporting 54

F

favorites 20
FDO data 49
feature settings in Raster Design 354
file formats (supported) 7
file locking 260
file locking, method 260
FILEDIA variable 18
filters
  adjust black and white edges 112
  bitonal 114
  blurring 110
  despeckle 86
  enhance black and white edges 112
  enhance edges 111
  gradient edges 113
  high pass 111
  low pass 110
  make edge transitions 112
  matched filter 113
  mirror 90
  noisy images 113
  reduce high-frequency detail 110
  reduce visual noise 107
  sharpen 111
  shift and difference 112
  filters, edge enhancement 112
frame
  adjust for inserting image 29
  bring to front of image 61
  changing linetype 63
  definition and purpose 83
  send behind image 61
  turn off and on 61
FTP site
  export image to 53
  inserting images from 16
save an image to 47

G
geo-referencing 23
gradient directional edge enhancements 113
grayscale
    converting to color 120, 132
grayscale image
    convert to black and white 102
    from color image 100
    mirror 90
    reduce harshness and noise 107
grid, rubber sheeting 33

H
hiding images 74
high pass filters 111
histogram
    adjusting images 94
    black and white 102
    brightness and contrast 94
    color to grayscale image 100
    contrast 103
    contrast curve 103
    grayscale 100
    grayscale to black and white 102
    maximizing details 98
    tonal adjustments 94, 103
histogram settings, dialog box 318

I
ibias command 88
icapture command 49
iconfig command 117
icons 296
REM 298–300
iconvolve 108
iconvolve command 107
icropcirc command 148
icropdiag command 149
icropline command 147
icroppoly command 150
icroprect command 148
ideskew command 85
idespeckle command 86
iembed command 44
iexport command 50
iframe command 244
iimerge command 163
iinsert command 18
image 18, 30
    boundary 83
    capture 49
    correlation methods 30
    density 117
    embed 44
    erase and detach options 254
    file size 117
    filters 107
    insert 11
    insertion dialog box 327
    move 30
    path problems 278
    preview 13
    resampling methods 305
    scale 30
    transform 27
    units 117
image default settings 255
image density, change 305
image detach options 254
image display
    brightness and contrast 94
    cleanup 84
    color to grayscale 100
    color transparency 64
    display properties 60
    high or draft display quality 60
    maximizing details 98
    mirror 90
    order problems 275
    problems 275
    reduce harshness and noise 107
    reverse light and dark shades 90
    smoothing 107
    turn frame on and off 244
    image display, enhance edges 112
image filters, bitonal 114
image formats (supported) 7
image management
  active path 77
  bitonal filters 114
  change layers 62, 169
  copying to clipboard 68
  detaching 76
  display order 75
  erase images 76
  histogram 94
  insertions 69
  layout of dialog box 67
  REM 167
  saved path 78
  showing and hiding 74
  unloading 77
  zoom to 69
Image Manager, controls 332
image mask options 256
Image menu description 288
image palette
  changing colors 120
  combining colors 122
  compressing 126
  converting to color 132
  custom colors 120
  displaying color values 133
  displaying information 131
  displaying transparency values 134
  displaying unused values 133
  exporting 127, 130
  importing 127
  manipulating 120
  overview 120
  pick color 124
  removing duplicate entries 126
  resetting 127
  selecting colors from the image 124
  transparent color 123
image portability 8
image processing 93
image properties, changing 59
image selection 337
IMAGEADJUST command 94, 288
IMAGEATTACH command 288
imageclip command 144
IMAGECLIP command 288
IMAGEFRAME command 288
IMAGEQUALITY command 288
imask command 141
imatch command 30
ImgAttributes 59, 167
imirror command 90
Import Palette dialog box 120
importing CAD Overlay images 258
inew command 22
insert image 12, 16
  adjust frame 29
  correlation 23
  dialog box options 305–306, 340, 370
  from an FTP site 16
  Insertion Wizard 25
  Quick Insert 24
  using command line 18
insertion point, default 247
insertions
  changing display order 75
  managing 69
  showing and hiding 74
  zoom to 69
installation requirements 7
Internet
  access Raster Design home page 6
  browsing files 244
  opening an image file 14
  problems inserting images from 277
  shortcuts to Favorites 20
invert light and dark shades 90
irubarc command 152
irucircle command 153
irudia command 156
irubline command 152
irubpline command 154
irupoly command 156
irurect command 157
isave command 41
iunembed command 44
K
K frame, turn off and on 244

L
Laplacian edge enhancements filters 112
layer, move image to different line 62, 169
crop 147
rub 152

locking images 260
low pass filters 110

M
Map 3D image capture 49
mask
change existing 141
change properties 141
convert mask to clips 146
create 140
defaults 355
defaults 355
ing editing 143
enable/disable 143
hide images 141
remove 146
unlock images 141
using command line 140
match 30
matched edge enhancement filters 113
median filter 108
merge images 163
merge objects 163
REM 200
select pen widths 165
vectors into raster image 164
message display method 261
mirror 90
dialog box options 343
overview 84
modifying images 81
mouse buttons 262
move an image 31
Multi Pick Options 266

N
new features in Raster Design 1
new image default properties 263
noise reduction 107
Non-Continuous Linetype Detection 266

O
objects associated with images 168
OCR
AutoCAD output settings 232
correlation search paths 249
default image settings 255
default image settings 255
dialog box 353
default image settings 255
dictionary 232
default image settings 255
input settings 232
language 232
setup 232
text 234
verification display settings 232
optical character recognition, dialog box controls 373
options
correlation defaults 247
correlation search paths 249
default image settings 249
default image settings 255
dialog box 353
default image settings 255
dictionary 232
default image settings 255
importing CAD Overlay images 258
locking images 260
message display method 261
mouse buttons 262
new image default properties 263
polyline/contour follower 272
QSave 264
raster entity detection 266
raster removal method 270
REM objects 267
rub/crop line width 268
startup 265
thumbnail images 257
user preferences 360
vector merge 270
vector separation, contours 246
vector separation, general 251
vectorization tools 252
order of images (restoring) 275

P

palette
  changing colors 120
  combining colors 122
  compressing 126
  converting to color 132
  displaying color values 133
  displaying information 131
  displaying transparent colors 134
  displaying unused colors 133
  editing 120, 124
  exporting 127, 130
  importing 127
  removing duplicate entries 126
  resetting 127
  selecting colors from the image 124
  transparent color 123

palette file
  exporting 130
  importing 127

Palette Manager, overview 120
path problems with images 278
paths
  correlation search 249
  read 249
  resource files 249, 357
  write 249
pixel data display 73
plot raster images 276
point data query 73
point selection with snaps 311
polygonal
  crop raster data 150
  region object 172
  rub 156
polyline
  3D 225
  convert raster to vector 209
  rub 154
polynomial rubbersheeting 33
preview image 13
preview rubbersheet 35

primitive objects 168
  changing linetypes 188
  defining 180
  from existing vector 187
  REM circle 183
  REM line 182
  remove 159
  smart pick 186
problems
  editing images 276
  image display order 275
  image paths 278
  inserting Internet images 277
  raster snap 276
properties
  display 60
  image frame 63
  layer 62, 169

Q

QSave preferences 264
Quick Bar 300
Quick Insert option 24

R

raster data
  cropping 147
  modifying with REM objects 189
raster data query 73
dialog 352
Raster Design
  home page on Web 6
  installing 7
  new features 1
  program history 9
  user preferences 360
  viewing information about 6
Raster Design image objects 8
Raster Design options, setting 246, 353
raster entity conversion to vector 205
arc 217
polyline 209
text 227
raster entity detection settings 266
raster entity manipulation. See REM 167
raster image, plotting 276
raster pens
  pen widths for vector merge 165
  settings 366
raster removal 158
raster snap
  modes 240
  options 311
  toggle QuickBar 243
  troubleshooting 276
rbackground command 64
read-only files 276
recognizing text 234
  AutoCAD output settings 232
  character set 232
  dictionary 232
  input settings 232
  language 232
  setup 232
  verification display settings 232
rectangular
  crop raster data 148
  region object 171
  rub 157
refine mode 191
REGEN command 275
region objects
  association with images 168
  circular region 174
  defining 178
  from existing vector 176
  polygonal region 172
  rectangular region 171
  remove subsections 177
REM
  defining primitive objects 180
  delete raster data 159
  editing non-REM images 169
  object editing 193
  operations 193
  settings 359
REM objects
  and transparency 202
  association with image 168
  change color 267
characteristics 168
  clearing 199
  converting to new raster image 201
  copying to clipboard 202
  delete raster data 197
  edit mode menu 189
  edit raster images 189
  manipulating 189
  merge into an image 200
  outside image 197
  refine mode 191
  resizing 191
  separate raster linework 203
  smooth raster linework 196
remove
diagonal region 156
  except raster line 147
image 76
  outside a circular region 148
  outside a diagonal region 149
  outside a polygonal region 150
  outside a rectangular region 148
polygonal region 156
raster arc 152, 161
raster circle 153, 155, 162
raster data with REM 197
raster entities using Smart Pick 159
raster line 152, 160
raster line segments 154
raster under vector 158, 270
rectangular region 157
  unwanted borders 148, 150
resetting image palette 127
resource file 50
resource file directory 249
reverse light and dark shades 90
RMS error, rubbersheeting 33
rotate image 30, 85
rounding 252
rpens 165
rub
  arc 152
  circle 153
  color 64
  diagonal region 156
  irubcirc command 155
Index | 413
vector merge options 361
raster pen widths 165
vector merge settings 270
vector separation options
  contours 246
  general 251
vector separation, dialog box
  controls 376
vector, merge into raster image 164
vectorization, and Dynamic Input
  prompts 207
vectorize
  raster arc 217
  raster circle 215
  raster contour 222
  raster entities, overview 205
  raster line 209
  raster polyline 209, 219, 221
  raster rectangle 214
  raster text 227
verification list 252
verify text/table, dialog box controls 378
vf3dpoly 225
vfcontour 221–222
vfcontour settings 272
vfline 219
vfpline command 209
vfline command 209
vfpline settings 272
vfpline settings 272
visual noise reduction 107
vline command 208
Vline, SmartCorrect 207
vmtext command 227
vtext command 227
Vtools
  follower 219, 222
  follower settings 272
  SmartCorrect 207
  varc 217
  vcircle 215
  vf3dpoly 225
  vfcontour 222
  vline 208
  vmtext 227
  vpline 209
  vrect 214
  vtext 227
VTools 205
  vfpline 219
W
  world file 50, 54
  world wide web 6, 14
    Raster Design home page 6
    set location for browsing files 244
    shortcuts to Favorites 20
Z
  zooming to images 69