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Welcome to the AutoCAD
Raster Design 2010
Tutorials

Use these tutorials to learn how to perform specific tasks with images from various sources,
such as scanned drawings, photographs, and satellite imagery.

Nine tutorials are included in the full installation of AutoCAD Raster Design:

■ Basic Tasks Tutorial (page 5)

■ Scanned Drawing Cleanup Tutorial (page 17)

■ Bitonal Image Tutorial (page 47)

■ Hybrid Image Tutorial (page 75)

■ Photograph and Map Tutorial (page 103)

■ Tonal Adjustment Tutorial (page 151)

■ Palette Manager Tutorial (page 171)

■ Vectorization Tutorial (page 183)

■ Text Recognition Tutorial (page 221)

Organization of the Tutorials

Each tutorial contains a set of exercises using images designed to explore the various features
of Raster Design. Each tutorial refers to a folder containing the images and drawings for the
exercises.

You should first complete Basic Tasks Tutorial (page 5) to learn some basic skills, then move
on to the other tutorials in any order you choose. However, the exercises within each tutorial
are organized in a logical sequence, and you should follow them in that order to avoid
confusion.

1
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Related Exercises

You can explore some features of Raster Design in more than one exercise. For example,
you can use several methods to insert images into drawings. When additional exercises are
available, the exercise introduction contains links to the related exercises.

Getting More Information

To obtain more detailed information about Raster Design features and commands, refer to
the following documentation:

■ AutoCAD Raster Design 2010 Getting Started manual (PDF or printed manual).

■ AutoCAD Raster Design 2010 User Guide (online Help).

Conventions Used in These Tutorials
The step-by-step procedures in each exercise use the following text
conventions:

■ Commands in all uppercase letters are AutoCAD commands. For example,
COPY refers to the AutoCAD copy command.

■ A red pointer in the left margin indicates a hidden illustration. Click the
red pointer to display the graphic.

Using the Tutorial Images and Drawings
When you install Raster Design using the Full Installation option, six folders
containing the images and drawings used in the tutorials are copied to the
..\Program Files\Raster Design\Tutorials folder on your system. Each folder
corresponds to a tutorial:

Folder NameTutorial Name

Tutorial1Basic Tasks Tutorial (page 5)

Tutorial2Scanned Drawing Cleanup Tutorial (page 17)

Tutorial3Bitonal Image Tutorial (page 47)

Tutorial4Hybrid Image Tutorial (page 75)
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Folder NameTutorial Name

Tutorial5Photograph and Map Tutorial (page 103)

Tutorial6Vectorization Tutorial (page 183)

Tutorial7Palette Manager Tutorial (page 171)

Tutorial8Tonal Adjustment Tutorial (page 151)

Tutorial9Text Recognition Tutorial (page 221)

If these folders are not installed in the ..\Program Files\Raster Design\Tutorials
folder on your system, use the AutoCAD Raster Design CD to perform a custom
installation and install the tutorial folders.

Create a Working Folder for the Tutorials

In order to experiment freely with the tutorial images and drawings, create a
working folder on your system and copy the tutorial folders to this folder. Use
these copies of the tutorial files to complete the exercises. Retain the original
tutorial folders in ..\Program Files\Raster Design\Tutorials.

Even if you intend to complete only certain exercises in a tutorial, it is a good
idea to copy the entire folder for that tutorial to your working folder. This
ensures that you have all the drawings, images, and related files, such as
correlation files, that you need to complete the exercises.

Starting the Exercises
Click one of the following links to begin:

■ Get started with Raster Design (recommended) (page 5)

■ Clean up images from scanned drawings (page 17)

■ Edit black and white (bitonal) images (page 47)

■ Work with hybrid images (containing raster and vector data) (page 75)

■ Work with photographs, maps, or satellite data (page 103)

■ Work with tonal adjustment (page 151)

■ Work with the Palette Manager  (page 171)

Starting the Exercises | 3



■ Create vector entities from raster images (page 183)

■ Work with text recognition (page 221)
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Basic Tasks Tutorial

This tutorial introduces the following Raster Design features:

■ Raster Design setup options

■ Image management features

■ Image properties

■ Methods of saving images

In these exercises, you set Raster Design options that control feature settings and learn how
to control image display. Also, you learn how to view and modify the properties of an image
or a group of images, and how to save modified images.

You should complete the exercises in this tutorial before continuing with the other Raster
Design tutorials. The subsequent tutorials assume that you are familiar with the features
covered in these exercises.

You can access Raster Design commands and features in the following ways:

■ Image menu

■ Shortcut menu

■ Raster Design Toolbar

Each of the tutorial exercises requires a specific drawing file from the \Tutorials folder where
Raster Design is installed. For information on these drawing files, see Using the Tutorial Images
and Drawings (page 2).

Exercise A1: Setting Raster Design Options
In this exercise, you use the Raster Design Options dialog box to control feature
settings.

2
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This dialog box contains settings that apply to all features, such as the image
detach options, and settings that apply to specific features, such as the raster
entity manipulation (REM) settings.

You can access the Raster Design Options dialog box using either of these
methods:

■ Click Image  ➤ Options.

■ On the Raster Design Toolbar, click Options  .

To Set Raster Design Options

1 NOTE An open drawing is not required for this exercise. Step 1 is optional.

In the Program Files\Raster Design\Tutorials\Tutorial1 folder, open the
drawing file GettingStarted_01.dwg.

2 To display the Raster Design Options dialog box, click Image  ➤ Options.

3 On the Paths tab, clear the checkbox for Use Correlation Search Path
Before Using Image Directory.

When this checkbox is cleared, Raster Design looks first in the same
directory as the image for resource correlation files.

4 On the User Preferences tab, specify the following settings:

■ Under Image Detach Options, select Always Detach.
When you erase an image, Raster Design automatically detaches the
image from the drawing.

■ Under Mouse Settings, select Shift + Left Click Image Select.
Using shift-click to select an image is particularly helpful when you
are zoomed in to the image and cannot see the image frame to select
it.

■ Under Qsave Preferences, select Prompt During QSAVE.
Raster Design prompts you to save edited images during quick saves.

■ Under Startup Options, select Load Menu on Raster Design Startup.
The Image menu is included with the AutoCAD menus when you
start Raster Design.

■ Under Message Display, select Message Box.
Raster Design displays warning messages in message boxes.

6 | Chapter 2   Basic Tasks Tutorial



5 On the Feature Settings tab, specify the following settings:

■ Under Locking Settings, select No Locking.
Image files are not locked while you are working with them.

■ Under Thumbnail Option, select Save Thumbnail With Image.
Thumbnails allow faster display of the image preview when you insert
an image.

6 On the Image Defaults tab, specify the following settings:

■ Under Insertion Point, specify 0 for X, Y, and Z values.

■ Under Scale/Rotation, specify 1 for Scale and 0 for Rotation.

■ Under Density, specify 300 for Value and select Inches for Units.

■ Under Vertical Units, select Meters.

7 Click OK to return to the drawing.

Access Raster Design Options from the shortcut menu

8 Right-click in the display area of the drawing window to open the shortcut
menu.

If you right-click when the pointer is positioned outside the drawing area,
a different shortcut menu is displayed.

9 Click Image ➤ Options on the shortcut menu to display the Raster Design
Options dialog box.

10 Click Cancel to return to the drawing.

11 Close the drawing, without saving changes.

Exercise A2: Managing Images in a Drawing
In this exercise you control the display of images inserted into a drawing.

Use the Image Manager toolspace to view and edit image insertions, color
maps, and other data associated with an image. The toolspace provides two
views of the image data, the Image Insertions view and the Image Data view.

Access the Image Manager toolspace using the following methods:

■ Click Image menu  ➤ Manage.

■ On the command line, enter imanage.
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■ Right-click in the drawing area and click Image ➤ Manage.

■ On the Raster Design Toolbar, click Image Management  .

Related Exercises

■ Exercise A3: Viewing and Changing Image Properties (page 13)

Before doing this exercise, ensure that Raster Design options are set as described
in the exercise Exercise A1: Setting ProductNameShort Options (page 5).

Open the drawing file for this exercise

1 In the \Tutorial1 folder, open the drawing file GettingStarted_02.dwg.

You should see a set of six images, with one on the right overlapping
three others. If you see only the rectangular frame for any image, select
the frame, then right-click and click Image ➤ Show. The image should
appear.

Explore the Image Insertions view of the toolspace

2 To display the toolspace, click Image menu  ➤ Manage. If necessary,
click the Images tab to display the Image Manager.

3 On the drop-down menu at the top of the toolspace, select the Image
Insertions view.

4 On the management toolbar above the drop-down menu, click  to
expand the object tree.

You can see an object for each image inserted into the drawing. Below
each image insertion is the color map: BIN for bitonal, CLR for color, etc.

5 Click the drawing name (GettingStarted_02) at the top of the tree.

Attributes for each image are displayed in the tabular item view.

6 Lower in the tree, click one of the image insertion names (Aerial, Arch,
etc.) to select it.

Properties for the selected insertion are displayed in the item view.

7 In the management toolbar, click  .

The item view is replaced by a preview of the selected image insertion.
You can resize the preview pane to change the size of previews.
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NOTE Image previews are available in the Image Insertions view of the Image
Manager toolspace, but not in the Image Data view.

8 Click other image insertion objects to see a preview of each one.

Use the standard toolspace controls

9 On the command line, enter dockts. The toolspace is moved to a docked
position on the left side of your drawing.

10 On the command line, enter floatts. The toolspace is floated over the
drawing.

Further exploration: You can also dock and float the toolspace with the
cursor. Click and drag the floating toolspace to the top or left side of the
window to dock it. Click and drag the handle of the docked toolspace to
float it. Other commands you can try are hidets to hide the toolspace,
and imanage or showts to show the toolspace.

11 On the floating toolspace colored control bar, click  to turn auto-hide
on.

Now, when you move your cursor off the toolspace, it retracts into the
control bar, giving you clear access to the drawing. To expand the
toolspace again, move your cursor over the control bar. Auto-hide is
convenient when you want to work in the drawing but retain quick access
to the Image Manager toolspace.

12 To turn auto-hide off, click  .

13 Click  to see the Properties menu for the toolspace.

You can use options on this menu to disable the docking feature, control
the transparency of the toolspace, and turn auto-hide on or off.

Show and hide images

14 Click any image insertion name in the tree, then right-click and click
Hide.

In the drawing, the image disappears, but the frame remains visible. Note
that the image object remains both in the tree and in the preview window.

15 To redisplay a hidden image, right-click the insertion name and click
Show.
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TIP Another way to hide and show images is to select the image frame, then
right-click and click Image ➤ Show (or Hide). When the frame is selected,
it changes to dotted lines with a blue square at each corner.

Using the Hide option is the simplest way to remove an image from the
display, creating minimal change in the drawing. Related commands are
as follows:

■ Unload deletes the image from working memory. This option is
available on the Image Data view when you right-click an image data
definition. Reverse this option with the Reload option on the same
shortcut menu.

■ Erase deletes the image and frame from the drawing and the object
tree, but leaves an unreferenced data definition in the Image Data
view, unless the Raster Design Options are set to always detach. The
erase option is available on the Image Insertions view when you
right-click an image insertion. If an image is erased but not detached,
you can reverse the erase operation by right-clicking the image in the
Image Data view and clicking New Insertion.

■ Detach is the most complete form of image removal, as it clears all of
the image data from the drawing. This option is available on the Image
Data view when you right-click an image data definition. Reverse this
option by creating a new image insertion.

Zoom to an image

16 Right-click an image insertion name and click Zoom To. The display
zooms to that image.

17 To return to the previous view, on the Edit menu, select Undo Group of
Commands.

Control image display order

In the drawing, notice that the image Aerial overlaps Pyrmd and Tractor.
This display order is reflected in the Image Insertions view, where you
see Aerial higher up the tree than either Pyrmd or Tractor. The order of
insertions in this tree corresponds directly to their display order within
the drawing.

18 In the Image Insertions tree, click and drag the Aerial image to a position
below Pyrmd. Notice how this changes the display.

19 Click and drag Aerial to a position below Tractor.

20 Right-click Aerial and click Bring To Front.
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TIP In some instances, the menu selections can provide more precise control
of image display order than the click-and-drag method.

Edit color maps

21 Right-click Arch and click Edit Color Map.

The Select Color dialog box opens. This is the color map control for all
bitonal images.

22 Use the cursor to select a different foreground color for the linework,
preferably a color that will be clearly visible against the background.

23 Click OK, then click in the drawing window to see the change.

Your color choice is applied to the linework and frame of the image, but
not the preview. Notice also that the RGB color values are listed in the
label of the color map.

24 Click the color map object  for any image insertion to see its color
properties in the tabular item view.

25 Right-click Tractor and click Edit Color Map.

The Image Adjust dialog box opens. This is the color map control for
single-band grayscale and color images.

26 Change the settings for brightness, contrast, and fade.

27 Click OK, then click in the drawing window to see the change.

Your settings are applied to the image. Notice also that the numeric values
of these settings are listed in the label of the color map.

Explore the Image Data view

28 On the drop-down menu in the upper part of the toolspace, select the
Image Data view.

29 In the management toolbar above the drop-down menu, click  to
expand the object tree.

Note the different object tree in this view. Each image is represented by
a branch of five or more objects. At the top of each branch is the image
data definition, followed by a band group (with subordinate bands), and
a color map with subordinate image insertion.

30 Click various data objects to see their properties in the item view.

Create new insertions
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31 Right-click the color map for Aerial and click Edit Color Map.

32 Change the values for brightness, contrast, and fade. Note that these
settings appear in the label for the color map object.

33 Right-click the color map for Aerial and click New Insertion.

A duplicate instance of the grayscale color map is created in the tree, with
a subordinate new insertion named Aerial:1.

34 Right-click the image data definition for Aerial and click New Insertion.
This action creates a new insertion, Aerial:2, with the default color map.

Unload an image

35 Right-click the image data definition for Tractor, then click Unload. The
image disappears, but the frame remains.

36 Click the drawing object at the top of the tree and notice the entry for
Tractor in the Status column of the item view.

37 Right-click the image data definition for Tractor, click Reload, then click
in the drawing window. The image reappears in the frame.

TIP Temporarily unload one or more images from a drawing to get faster
application performance. You can easily reload the images when you need
them.

Change the layout of item view columns

You can do this on either tab of the Image Manager toolspace.

38 Click the drawing name at the top of the tree.

In the item view, you see columns of information arranged using a default
layout.

39 Right-click anywhere in the column header area to see a complete list of
available columns to display.

Checked columns are those you see displayed in the table. Add and
remove check marks to control the data in the table. You can also select
Show All Columns, or hide a column by right-clicking its head row and
clicking Hide Column.

40 Add or clear check marks to change the columns in the table.

You can change the order of columns in the table by clicking and dragging
column head rows to a new location.
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41 Drag one or more columns to rearrange the table. Note that when you
drag a column, a blue line between columns indicates where the column
will go when you release the mouse button.

42 If you want to change the width of a column, click and drag the vertical
line between column head rows.

Turn image frames off or on

43 To turn off the frames around all the images, click Image  ➤ Toggle
Frames.

44 In the drawing window, right-click and click Repeat Toggle Frames to
turn on the image frames.

In the drawing window, you can also right-click and click Image ➤ Show
Image Frame(s) to turn on the image frames.

45 Close the drawing without saving changes.

Exercise A3: Viewing and Changing Image
Properties

In this exercise, you view and change properties of a selected image or of a
group of selected images.

Access the Properties window using the following methods:

■ Click Modify menu  ➤ Properties.

■ Select one or more images, right-click, then click Properties.

■ On the AutoCAD Standard toolbar, click Properties  .

Related Exercises

■ Exercise A2: Managing Images in a Drawing (page 7)

Before doing this exercise, ensure that Raster Design options are set as described
in the exercise Exercise A1: Setting ProductNameShort Options (page 5).

Open the drawing file for this exercise

1 In the \Tutorial1 folder, open the drawing file GettingStarted_03.dwg.

View image properties
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2 Select the image frame of the tractor image.

3 Right-click and click Properties to display the Properties window.

4 Scroll to the end of the properties list.

This example shows the appearance of the Properties window when an
image is selected. Raster Image is selected, and the image data appears at
the end of the properties list in the Information section.

View the edit status of an image

5 Click the Editable row, then click  at the end of the row.

The Edit Status dialog box indicates that this image can be edited and
saved. When an image cannot be edited or saved, you can open the Edit
Status dialog box to determine why.

6 Click Close.
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7 Press Esc to deselect the tractor image, but do not close the Properties
window.

Change image properties

8 Select the image frame of the USGS quad sheet in the lower left of the
drawing window.

9 In the Properties window, in the General section, change the layer to
TU_image_usgs.

View properties for multiple images

10 Select the image frame of the aerial photograph.

Raster Image (2) appears at the top of the Properties window, indicating
that two images are selected. Properties common to both images are
displayed.

11 Close the Properties window.

12 Close the drawing without saving changes.

Exercise A4: Saving Images
In this exercise you save images and set the file name, path, and format in
the process.

When you save an image, the image format that you select determines whether
Raster Design prompts you to specify additional parameters, such as the
encoding method for TIFF images.

You can access the Save and Save As dialog boxes using one of these methods:

■ Click Image menu  ➤ Save. Or click Save As.

■ In the Image Manager toolspace, Image Insertions view, select the image
insertion object, then right-click and click Write  ➤ Save or Save As from
the shortcut menu.

■ In the drawing window, select an image, then right-click and click Image
 ➤ Write  ➤ Save or Save As from the shortcut menu.

■ On the Raster Design Toolbar, click Save  or Save As  .
You can also export images, which enables you to save an image with a
correlation file that determines the position, rotation, and scale of the
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image when the image is inserted. Correlation files are helpful when you
intend to use an image in more than one drawing or in another system.

Related Exercises

Before doing this exercise, ensure that Raster Design options are set as described
in the exercise Exercise A1: Setting ProductNameShort Options (page 5).

Open the drawing file for this exercise

1 In the \Tutorial1 folder, open the drawing file GettingStarted_04.dwg.

Save the images

2 Click Image menu  ➤ Save.

3 Select the image frame of the USGS quad sheet and press Enter.

4 Click Image menu  ➤ Save As. Then select the image frame of the tractor
image.

5 Browse to your Tutorial1 directory, change the filename to farm and click
Save.

6 Select the image frame of the aerial photograph in the upper right of the
drawing area.

7 Right-click and click Repeat Save As from the shortcut menu.

8 Change the filename to Aerial_photo and click Save.

The aerial photograph is a TIFF image. Raster Design prompts you to
select an encoding method.

9 Select Uncompressed and click Next.

10 Select Tiled and click Finish.

The image is saved.

11 Close the drawing without saving changes.
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Scanned Drawing Cleanup
Tutorial

This tutorial shows you how to use Raster Design to clean up images of scanned paper drawings.

Several problems are frequently associated with images scanned from paper drawings:

■ Images scanned from negatives or blueprints have dark backgrounds and light line work
that is difficult to read.

■ Images may be reversed so that the text and the line work are upside down or backwards.

■ Images may show speckles from dirty or faded original drawings.

■ Documents may have been skewed or tilted as they were fed through the scanner.

■ Images may be distorted, reflecting distortion in the scanned document itself, perhaps
introduced through prior reproductive processes (for example, a copy of a copy).

■ Images may contain rough line work that is difficult to read.

■ Images may contain artifacts from creases, stains, and tears on the original drawing.

Raster Design cleanup utilities, image processing filters, and editing tools are intended to
address these problems. The exercises in this tutorial show you how to use these tools to
improve the quality of the raster images created from your scanned drawings.

Later tutorials show you how to update raster images by editing or removing raster entities
and by adding new raster or vector geometry.

Exercise S1: Inserting Images of Scanned Drawings
In this exercise you learn to use the Insertion Wizard to guide you through
inserting and positioning an image into a drawing.

3
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Related Help Topics

■ Inserting Images

■ Correlating Images

Related Exercises

Before doing this exercise, ensure that Raster Design options are set as described
in the exercise Exercise A1: Setting ProductNameShort Options (page 5).

Choose an image to insert

1 In the \Tutorial2 folder, open the drawing file Scanned_01.dwg.

2 To display the Insert Image dialog box, click Image  ➤ Insert.

3 From the Files of Type list, select All Image Files.

4 If necessary, navigate to the \Tutorial2 folder.

5 Select the image file FoundationDetail_01.tif.

6 Review the values shown for each parameter in the Information box.

This parameter list identifies important characteristics of the image.

The scanned drawing in the image is turned on its side (portrait
orientation). In addition, the image, which was scanned from a blueprint,
has a light background with line work that is difficult to see.

The values for Depth and Density are important for this image:

■ The depth of 1 bit per pixel indicates a bitonal image.

■ The density of 200 dots per inch (dpi) indicates that the image was
scanned at a low resolution. This low-quality scan may be responsible
for some of the problems with this image that you correct in later
exercises.

18 | Chapter 3   Scanned Drawing Cleanup Tutorial



Position and insert the image using the Insertion Wizard

7 Under Insert Options select the Insertion Wizard option.

Also under Insert Options, ensure that Show Frames Only is not selected.

8 Click Open to display the Pick Correlation Source dialog box.

This dialog box is the first dialog box of the Insertion Wizard. When you
choose a correlation source, the dialog box shows the insertion point,
rotation, and scale associated with the selected correlation source.

9 Accept the default correlation source, Image File, and click Next.

10 Change the rotation value to 90 and click Next.

11 Verify the AutoCAD values and click Apply.

12 Click Finish to insert the image.

13 Zoom to the drawing extents.

The image was rotated 90 degrees when it was inserted.
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14 Close the drawing without saving changes.

Exercise S2: Cleaning Up Images Using Despeckle
In this exercise you use Despeckle to clean up raster images and to remove
scanning artifacts from an image.

Despeckle removes speckles and spots on images scanned from dirty or faded
drawings. You can apply the Despeckle utility to the entire image or to a small
region.

Related Help Topics

■ Removing Speckles from an Image

■ Removing (Rubbing) Images

Related Exercises

Before doing this exercise, ensure that Raster Design options are set as described
in the exercise Exercise A1: Setting ProductNameShort Options (page 5).

Open the drawing file for this exercise

1 In the \Tutorial2 folder, open the drawing file Scanned_03.dwg.

Remove speckles from the image
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2 Click View menu  ➤ Named Views. Then select the view named
TU_speckles, click Set Current, and click OK.

This example shows an area of the image that contains many speckles.

3 Click Image menu  ➤ Cleanup  ➤ Despeckle. Note on the command
line that you can use various methods to define image sub-regions to
apply Despeckle. In this case, choose the option to despeckle the entire
image by pressing Enter.

A command prompt gives you options for determining the size of speckles
to remove.

4 Enter p for Pick and select a speckle that could represent the largest size
to be removed. Note the size detected is somewhat less than 0.50 AutoCAD
units. Enter r for Respecify and enter .01

A window size of 0.01 is suitable for this image. If the speckle size is too
large, Despeckle removes raster data that is actually part of the drawing,
such as decimal points in dimensions. However, the Despeckle process
also allows you to prevent such speckles from being removed.

5 Press Enter to continue.

A preview displays the highlighted speckles that are about to be removed.
If you want to prevent any of these from being removed (such as the
colon in 1:20), simply pick a speckle to de-select it. Note that you can
also use the Window or Polygon option to de-select speckles inside a
rectangle or polygon.
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6 Press Enter to remove the highlighted speckles.

7 Close the drawing without saving changes.

Exercise S3: Cleaning Up Images with Invert and
Mirror

In this exercise you use the Invert and Mirror utilities to improve the readability
of a raster image.

■ Invert reverses the light and dark shades of an image.

■ Mirror reverses an image in which the text and line work are backwards.

Related Help Topics

■ Reversing the Light and Dark Shades in an Image

■ Mirroring an Image

Related Exercises

Before doing this exercise, ensure that Raster Design options are set as described
in the exercise Exercise A1: Setting ProductNameShort Options (page 5).

Open the drawing file for this exercise
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1 In the \Tutorial2 folder, open the drawing file Scanned_02.dwg.

Depending on whether your AutoCAD background color is light or dark,
the image has a contrasting background, indicating it was scanned from
a blueprint. Invert changes this so the image background is the same as
the AutoCAD background.

Invert the image

2 Click Image menu  ➤ Cleanup  ➤ Invert.

Reverse the image

3 Zoom in so that you can clearly see the text in the drawing. Note that
the entire drawing is upside down.

4 Click Image menu  ➤ Cleanup  ➤ Mirror.

5 Select Top To Bottom and click OK.

Selecting the appropriate axis properly can help avoid unnecessary
rotations after performing the mirror.

After mirroring, the title block is at the bottom of the image, which is its
correct location.

6 Close the drawing, without saving changes.
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Exercise S4: Using REM Operations Tools
In this exercise you use REM Operations tools to correct imperfections in
scanned bitonal drawings.

Related Help Topic

■ Using REM Operations

Related Exercise

Before doing this exercise, ensure that Raster Design options are set as described
in the exercise Exercise A1: Setting ProductNameShort Options (page 5).

1 In the Tutorial2 folder, open the drawing file Scanned_07.dwg.

Note that several of the lines in the drawing overshoot (extend beyond)
their intersection and require trimming. Others undershoot and must be
extended to form a proper intersection.

Trim Lines

2 Click Image menu  ➤ Raster Entity Manipulation  ➤ Create Primitive
 ➤ Line.

3 Click a line that you want to trim (shorten). A REM line is created over
the raster line.

4 Right click and click Repeat Line. Click another line that you want to
trim.
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5 Use the Repeat Line command again to create a “cutting edge” for each
REM line to be trimmed. The cutting edge in this case is an intersecting
raster line where the trimmed line will end. In other contexts, you can
use a vector line as a cutting edge.

6 Click Image menu  ➤ Raster Entity Manipulation  ➤ REM Operations
 ➤ Trim.

7 Click one or more cutting edges, then right-click to end the selection
process.

8 Click the ends of the lines that you want to remove (trim). They are
deleted along with the underlying raster.
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9 Right-click and click Enter to end the command.

10 Click Image menu  ➤ Raster Entity Manipulation  ➤ Merge To Raster
Image.

11 Click the REM lines that you want to convert to raster data, then
right-click to end the selection process.

12 Right-click, then click REM ➤ Clear All. The REM lines are deleted, leaving
the edited raster data.

Extend Lines

13 Click Image menu  ➤ Raster Entity Manipulation  ➤ Create Primitive
 ➤ Line.

14 Click a line that you want to extend.
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15 Right click and click Repeat Line. Click another line that you want to
extend.

16 For each line that you want to extend, create a REM line on the other
side of the gap to act as a boundary edge (endpoint) for the extended
line.

17 Click Image menu  ➤ Raster Entity Manipulation  ➤ REM Operations
 ➤ Extend.

18 Click the boundary edge for the extended line, then right-click to end
the selection process.

19 Click the object that you want to extend. It is extended.

20 Right-click and click Enter to end the command.

21 Click Image menu  ➤ Raster Entity Manipulation  ➤ Merge To Raster
Image.

22 Click the REM lines that you want to convert to raster data, then
right-click to end the selection process.

23 Right-click, then click REM ➤ Clear All. The REM lines are deleted, leaving
the edited raster data.

Create a Corner Fillet

24 Click View menu  ➤ Named Views. Set the current view to Fillet View.
You see a corner fillet that needs repair.

25 Click Image menu  ➤ Raster Entity Manipulation  ➤ Create Primitive
 ➤ Line.

26 Click one of the lines that extends toward the corner fillet.

27 Right click and click Repeat Line. Click the other line that extends toward
the corner.

28 Click Image menu  ➤ Raster Entity Manipulation  ➤ REM Operations
 ➤ Fillet.

29 To create a rounded corner, enter r, then specify the radius by drawing
a line or entering a numeric value.
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30 Click one of the two lines that extend toward the corner.

31 Click the other line that extends toward the corner. The corner is created.

32 Click Image menu  ➤ Raster Entity Manipulation  ➤ Merge To Raster
Image.

33 Click the REM lines that you want to convert to raster data, then
right-click to end the selection process.

34 Right-click, then click REM ➤ Clear All. The REM lines are deleted, leaving
the edited raster data.

Offset a Line

35 Click Image menu  ➤ Raster Entity Manipulation  ➤ Create Primitive
 ➤ Line.

36 Click a line that you want to copy and offset. The line is converted to a
REM line.

37 Click Image menu  ➤ Raster Entity Manipulation  ➤ REM Operations
 ➤ Offset.

38 Click the REM line that you want to offset.

39 Click and drag a line perpendicular to the REM line to specify the offset
distance, then click to specify an endpoint.

40 Click the REM line to offset, then click on the side of the line where you
want the offset line. The offset line is drawn.
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41 Further exploration: Offset a circle. Select named view Circle-A and
convert the existing circle to a REM object, then use the Offset command
to create a larger concentric circle.

42 Keep the drawing open and continue with the next exercise, Exercise S5:
Using Touchup Tools (page 29), or close the drawing without saving
changes.

Exercise S5: Using Touchup Tools
In this exercise you learn to use touchup tools to correct imperfections in
scanned bitonal drawings.

Related Help Topic

■ Touching Up an Image

Related Exercise

Before doing this exercise, ensure that Raster Design options are set as described
in the exercise Exercise A1: Setting ProductNameShort Options (page 5).

1 In the Tutorial2 folder, open the drawing file Scanned_07.dwg.

2 You see diagonal lines of varying thickness that need repair. To work
more accurately, you should zoom in close.

Repair Diagonal Lines

3 Click Image menu  ➤ Cleanup  ➤ Touchup.

4 On the Touchup toolbar, click  to select a diagonal brush, then click

 to resize the brush.

5 Click on the edge of a line that you want to repair, click another point
along the same edge, then click a third point to specify a brush width
that is approximately equal to the width of the line.
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6 On the Touchup toolbar, ensure that the drawing color icon  shows
the white square in front, indicating that the brush will create white
pixels, rather than erasing them.

7 Use the brush to repair some gaps in the line. Note that this brush,
depending on its length, may be suitable for editing lines in only one
direction. To work on lines in another direction, you must resize the
brush.

8 Optionally, to draw a straight line with the brush, click to start the line,
then hold down the Shift key and click an endpoint for the line.

Use Round Brush

9 On the Touchup toolbar, click  to select a round brush.

10 Click  to resize the brush, so its diameter matches the width of a line.

11 Use this brush to repair some gaps in a line. Note that this brush is useful
for drawing in different directions and around curves.

12 Click the drawing color icon  to draw in the background color (black).
Use the brush to erase unwanted pixels along some of the lines.

13 Further exploration: Use the square brush in the same way as the round
brush to draw and erase. This brush shape is better suited to working with
vertical and horizontal lines. See the right side of the drawing for lines
of this type.

14 Close the drawing without saving changes.
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Exercise S6: Correcting Skewed Images
In this exercise you use Deskew to correct images that are skewed or tilted in
the image frame.

Related Help Topics

■ Deskewing an Image

Related Exercises

Before doing this exercise, ensure that Raster Design options are set as described
in the exercise Exercise A1: Setting ProductNameShort Options (page 5).

1 In the Tutorial2 folder, open the drawing file Scanned_04.dwg.

Move the image

2 Enter m for Move, select the image frame, and press Enter.

3 Zoom in and select the lower-left corner of the raster image for the base
point. Do not select the image frame.

4 Enter 0,0 for the second point (destination point).

The base point of the image moves to 0,0.

Deskew the image

5 Enter VIEW and restore the view named TU_extents_new.
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6 Click Image menu  ➤ Cleanup  ➤ Deskew.

7 Enter 0,0 for the base point.

8 Enter 0,0 for the source angle point.

9 Zoom in and select the lower-right corner of the raster image for the
second angle point. Do not select the image frame.

The baseline of the image has been specified as a reference line for the
deskew operation.

10 Accept 0 as the destination angle.

The image is aligned to the horizontal axis of the drawing.

11 Enter VIEW, restore the view named TU_extents_new, and examine the
deskewed image.

After deskewing, the image is no longer tilted in the image frame.
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12 Close the drawing without saving changes.

Exercise S7: Correcting Distortions Using
Triangular Rubbersheet

In this exercise you use Rubbersheet to correct a distorted image of a scanned
drawing.

The image in this exercise was distorted in the reproduction process and then
scanned. You draw a rectangle to represent the new border for the image and
then use Rubbersheet to stretch the image to fit the rectangle. You use the
Triangular rubbersheet method in order to have the points move exactly to
their desired locations.

Related Exercises

■ Exercise S8: Correcting Distortions Using Grid Points (page 38)

■ Exercise P3: Correcting Distortions in Photographic Images (page 110)

Before doing this exercise, ensure that Raster Design options are set as described
in the exercise Exercise A1: Setting ProductNameShort Options (page 5).

1 In the \Tutorial2 folder, open the drawing file Scanned_05.dwg.

Create a temporary vector border as a guide
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2 Draw a vector rectangle starting at 0,0 and extending to 805,565.

Set up viewports

In this lesson, you rubbersheet the image using four control points. A
four viewport configuration has been setup to show both the raster and
temporary vector border. Each of the four viewports is zoomed in so that
you can easily pick the four points.

3 Click View menu  ➤ Viewports  ➤ Named Viewports. Then select the
viewport named TU_rubbersheet.

4 To display the Rubbersheet - Set Control Points dialog box, click Image
 ➤ Correlate  ➤ Rubbersheet.

Select four control points

For this process you use four control points. Each control point consists
of a source and destination pair. The image was originally positioned so
that both the lower-left corner of the raster border and the new border
you drew, are located at (0,0). You can use the anchor to have the source
and destination points be the same for the corner at (0,0). When you
finish selecting the four control points they are listed in the Rubbersheet
- Set Control Points dialog box.

5 Click the Add Points button. At the command line you are prompted to
specify the first source point.

6 Enter 0,0 for the source point and enter a to anchor the destination point.

7 Click in the upper-left viewport to make it active. Select the corner of the
raster border as the second source point.

8 Click OSNAP on and select the upper-left corner of the vector border for
the second destination point.
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NOTE Click OSNAP off before selecting each source raster point, then click
OSNAP on to select the destination vector point.

9 Click in the upper-right viewport to make it active. Select the corner of
the raster border as the third source point.

10 Select the upper-right corner of the vector border for the destination
point.

11 Click in the lower-right viewport to make it active. Select the corner of
the raster border as the fourth source point.

12 Select the lower-right corner of the vector border for the destination
point.
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13 At the command line, enter d to end the selection process. The
Rubbersheet - Set Control Points dialog box redisplays and the points are
listed.

Set the rubbersheet method and preview the results

You use the Triangular rubbersheet method for this example. This method
causes the four corners to go exactly to the specified destination points.
You can verify the results using the Preview button. Since you are using
the Triangular method, areas outside the cluster of control points are
discarded after the rubbersheet.

NOTE If you want to maintain the original image size despite the changes
to the raster border in the image, additional control points can be anchored
at each corner of the image frame.

14 In the Method area, click Triangular.

15 Click the Preview button. A preview of the rubbersheet is shown. The
full preview is shown in the last active viewport and the other viewports
show the preview in their respective zoom levels.
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The preview shows the extents of the result in red and the extents of
what makes that area up in cyan. The hatched area between the cyan
extents and the original frame of the image are discarded in the final
result.

16 Right-click or press Enter to exit the preview.

Rubbersheet the image

17 Click the Export button to display the Export dialog box. Name the file
FoundationDetail_05.txt. Note where the file is being saved, then click
Export to finish the export. If you want to repeat the rubbersheet
operation with different settings you can use this file as a starting point.

18 Click OK. The rubbersheet processes and the Rubbersheet-Set Control
Points dialog box closes.

19 Click View menu  ➤ Viewports  ➤ Named Viewports. Then restore the
viewport named Rubbersheet Final Result.

20 Erase the vector border.
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21 Close the drawing without saving any changes to the drawing or image.

Exercise S8: Correcting Distortions Using Grid
Points

In this exercise you use rubbersheeting to correct distortions in maps and
scanned drawings that have a grid structure.

You can use the Grid Points feature in the Rubbersheet tool to create a regular
rectangular pattern of control points for an image. In this exercise, you
rubbersheet a map broken up into regular cells. After invoking Rubbersheet,
you use the Grid Points function to define the grid of destination points. Then
you use the Add Points function to pick source points for all of the destination
points in the grid. After the control points for the grid are specified, you can
rubbersheet the image using the Polynomial method.

Related Help Topic

■ Rubbersheeting an Image

Related Exercises

■ Exercise S7: Correcting Distortions Using Triangular Rubbersheet (page
33)

■ Exercise P3: Correcting Distortions in Photographic Images (page 110)

Before doing this exercise, ensure that Raster Design options are set as described
in the exercise Exercise A1: Setting ProductNameShort Options (page 5).
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1 In the \Tutorial2 folder, open the drawing file GridRubbersheet_01.dwg.
The drawing includes an image of a scanned map.

2 To display the Rubbersheet-Set Control Points dialog box, click Image
 ➤ Correlate  ➤ Rubbersheet.

3 In the Method area, select Polynomial.

4 Click the Grid Points button to display the Grid Parameters dialog box.

Set the grid parameters

In this box you set the parameters for the destination point grid. The
data to specify these parameters can be read from information in the
image.

5 Note that the image contains 6 rows and 5 columns of points that would
approximate the grid contained in the image. In the Points section, enter
6 rows and 5 columns. Note the total number of points in the grid is
shown so you know how many points can be used in the rubbersheet
operation.

This example shows the rows and columns in the image.
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6 In the image, note that the grid origin (lower left corner) should be at
the point labeled 10000. The coordinates of this point are (37,400, 10,000).
In the Grid section, specify 37400 for X Origin and 10000 for Y Origin.

7 Note the size of the grid cells in the image. They are 800 by 800. In the
Cell box, enter 800 for X Size and 800 for Y Size.

8 Click Preview to check the grid layout.

Note that each vertex of the new grid is close to the location of a vertex
in the image grid. In the next part of the rubbersheeting process, Raster
Design takes you to each grid point (vertex) where you specify the source
point in the image that will be stretched to the destination point on the
grid.

9 Right-click or press Enter to exit the preview window.

Add the source control points corresponding to the grid

10 In the Grid Parameters dialog box, click Add Points. The dialog box closes
and the screen zooms and pans to the grid origin. Because this point was
used to correlate the image, the source and destination points are correctly
aligned.

11 Enter a to anchor the origin point.

40 | Chapter 3   Scanned Drawing Cleanup Tutorial



The command line prompts for point (0,1) and the display moves to this
point, which is one cell over to the right.

TIP When adding source points, turn off OSNAP for better cursor control.

12 Pick the intersection of the dotted raster gridlines in the image as the
source point for (0,1).

NOTE You can change the zoom level for adding points. The new zoom level
is maintained for subsequent point selection until it is changed again.

13 Continue picking source points for every node in the grid. If any grid
points are correctly aligned with a source point, enter a to anchor the
point. You can also enter s to skip any point, or u to go back and
reposition one or more previous points.

Sometimes zooming out helps you position a source point when the
intersection in the image is not clear. After you specify all the points, the
Rubbersheet-Set Control Points dialog box displays to show the location
of corresponding source and destination points.

Further exploration: You can select any row of this table, then right-click
and zoom to that point to see how the current error level affects the
actual destination of the point. If you increase the Polynomial Degree
setting, the error level decreases for the control points, but this results in
greater warping of the image in areas away from control points.

Setup and preview the rubbersheet
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The preview indicates that areas outside the control point cluster are
discarded in the final image.

14 Select the Preview button to preview the rubbersheet results. The red
boundary shows the extents of the image after the rubbersheet, and the
cyan boundary shows the data included in these extents. The hatched
area is excluded from the new image.

15 Right-click or press Enter to exit the preview.

Perform the rubbersheet

Before performing the rubbersheet you export the control points in case
the rubbersheet needs to be repeated.

16 Click the Export button to display the Export dialog box. Name the file
Grid_01.txt in the Export dialog box and click Export to finish the export.

17 Click OK. The rubbersheet operation occurs and the Rubbersheet-Set
Control Points dialog box closes.
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18 Close the drawing without saving changes.

Exercise S9: Using Bitonal Filters and Editing Tools
In this exercise you use bitonal filters to improve raster line work and use
raster editing tools to remove unwanted spots from an image.

■ Bitonal filters improve the appearance of raster line work in a bitonal
image, often eliminating the need for redrawing.

■ Raster editing tools allow defects and scanning artifacts to be removed
from the image.

In this exercise, you improve existing line work by applying a line thickening
filter to a portion of the drawing. You also use the raster Remove tool to remove
unwanted raster pixels from the drawing.

Related Help Topics

■ Using Bitonal Filters
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■ Removing (Rubbing) Images

Related Exercise

■ Exercise S2: Cleaning Up Images Using Despeckle (page 20)

Before doing this exercise, ensure that Raster Design options are set as described
in the exercise Exercise A1: Setting ProductNameShort Options (page 5).

1 In the \Tutorial2 folder, open the drawing file Scanned_06.dwg.

Clean up jagged line work

2 Click View menu  ➤ Named Views. Set the current view to TU-pad.

Some of the raster lines are very thin. Some lines, such as the dimension
lines, have gaps due to poor scanning quality.

3 Click Image menu  ➤ Image Processing  ➤ Bitonal Filters. Then (as noted
on the command line) press Enter to select the whole image.

4 In the Bitonal Filters dialog box, select Thicken for the filter type, and
enter 2 for the number of passes. Verify that all directions are checked,
then click OK.

After you thicken the lines twice, some closely spaced parallel lines have
merged into a single line.

Undo the Bitonal Filter Thicken command
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5 Enter u to undo the Thicken command.

6 Click Image menu  ➤ Image Processing  ➤ Bitonal Filters. Then press
Enter to select the whole image.

7 Again select Thicken for the filter type, but select 1 for the number of
passes, then click OK.

With one pass, the gaps in dimension lines are repaired, but the closely
spaced lines remain separate. Some experimentation and iteration is often
necessary to achieve optimum results with filters.

8 Click View menu  ➤ Named Views. Set the current view to TU_extents.

Raster Design has applied the thickening filter to the entire image.

9 Use PAN and ZOOM to examine the line work in the image.

Remove spots

10 Click View menu  ➤ Named Views. Set the current view to TU_spots.

This area of the image contains spots (scanning artifacts) from small holes
in the original drawing.

11 Click Image menu  ➤ Remove  ➤ Circular Region.

12 Click the middle of a spot for the center point, then click a second point
to mark the radius of the circular area to be removed.
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13 Press Enter to repeat the command and draw a circle to remove another
artifact.

14 Close the drawing without saving changes.
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Bitonal Image Tutorial

This tutorial shows you how to use the raster entity manipulation (REM) commands to edit
bitonal (black and white) images of scanned drawings.

Using REM commands, you can define raster objects and manipulate them much as you do
AutoCAD vector objects. As a result, you can update raster images without having to convert
the raster entities into vectors.

You can use AutoCAD commands such as MOVE, COPY, and SCALE on REM objects to
manipulate the raster data. The REM objects can be merged into existing images or they can
be used to create new images.

Raster Design allows you to create three types of REM objects.

Image TypesDescriptionREM Object

Bitonal, grayscale, or colorContains all pixels within the region
geometry (for example, all pixels

Region ob-
ject

within a polygonal region), whether
or not the pixels comprise individual
entities.

Bitonal onlyFacilitates the selection of a group of
entities that intersect each other.

Enhanced
bitonal re-
gion object Standard AutoCAD object selection

criteria is enhanced with three meth-
ods:
Smart. Selects raster entities that inter-
sect with or cross a defined window
or polyline (fence).
Connected. Selects raster entities that
are connected to entities selected by
means of a window or fence.
Connected Entity. Selects all raster
entities connected to a specified
point.

Bitonal onlyIncludes a single raster line, arc, or
circle.

Primitive ob-
ject

4
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In this tutorial, you work with the three types of REM objects and observe their varying
behavior. You then use REM commands to modify a part in a mechanical drawing.

Exercise B1: Copying Raster Entities Using Region
Objects

In this exercise, you review REM settings, define REM region objects, and copy
raster entities from one image to another.

You can define region objects in bitonal, grayscale, and color images.

In this exercise, you work in a drawing that contains two bitonal images
scanned from mechanical drawings:

■ A detail drawing of a drill jig

■ An assembly drawing of the same drill jig

You use REM commands to select entities in each image and then copy the
entities to an empty image that is already in the drawing. In later exercises,
you modify these entities using REM commands.

Related Help Topics

■ Defining REM Region Objects

■ Resizing a REM Object

Related Exercises

■ Exercise A2: Managing Images in a Drawing (page 7)

Before doing this exercise, ensure that Raster Design options are set as described
in the exercise Exercise A1: Setting ProductNameShort Options (page 5).

1 In the \Tutorial3 folder, open the drawing REM_02.dwg.

Review the REM Settings

2 To display the Raster Design Options dialog box, click Image  ➤ Options.

3 Click the REM tab and ensure that the color of REM Objects is red.
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4 Click the Raster Entity Detection tab and ensure the following settings
are in effect:

■ Max Jump Length is 10.

■ Use Raster Pick Gravity is selected.

■ Pick Aperture is 4.

■ Float Tolerance is 2.

5 Click OK.

6 Right-click the AutoCAD toolbar or any open Raster Design toolbar and
click the Raster Entity Manipulation Toolbar to open it.

7 To display the Image Manager toolspace, click Image  ➤ Manage. Select
the Image Insertions view.

8 Click + beside REM_02.dwg, right-click Mech_02a, and click Zoom To to
see this image of 13 detail drawings.

Create a polygonal region object

9 On the Raster Entity Manipulation Toolbar, click Polygonal Region 
.

10 Draw a polygon that includes all of the detail drawings and their
annotations, along with part of the title block in the lower right corner,
then press Enter to end the process.
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The polygon and all the entities within it now are displayed in red, which
indicates they have been captured as part of the REM region object.

Refine the region object

11 Click the polygon boundary to select the REM region object.

12 Right-click and click Refine Mode. Only the region boundary is
highlighted.

13 Transparently pan and zoom to the lower-right corner of the image.

14 Select the region boundary. Select the midpoint grip in the title block,
and drag this grip to exclude the title block from the region object.

The following example shows how the image should appear after the
region object is refined to exclude the title block.
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15 Right-click and click Refine Mode from the shortcut menu. Refine Mode
is now de-activated.

Copy the region object to the empty image

16 Zoom out to the drawing extents.

17 Use the COPY command to copy the region object to the upper-left corner
of the empty image.
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Create a rectangular region object

18 In Image Manager, select Mech_02b, right-click and click Zoom To to see
this image.

19 Click Rectangular Region  on the Raster Entity Manipulation Toolbar.

20 Draw a rectangle that includes the entire image: all of the entities, the
title block, and the border.

The rectangle and all the entities within it are now red, which indicates
they have been included as part of the REM Region object.

Copy the region object

21 Zoom to the drawing extents.

22 Use COPY to copy the region object to the lower-left corner of the image
that contains the other region object.
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Merge the region objects into the image

23 Select the two region objects, right-click, and click Merge to Raster Image.

After you merge the region objects into the image, the objects are no
longer displayed in red because they are no longer region objects.
However, the objects in the original images are still defined as region
objects.
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24 Right-click and click REM ➤ Clear All from the shortcut menu.

The REM region objects are no longer defined in the original images. At
this point in a real project, you could save the new image (Mech_new_02)
and detach the original source images from the drawing.

25 Close the drawing without saving changes.

Exercise B2: Defining Enhanced Bitonal Region
Objects

In this exercise you create and work with REM enhanced bitonal region objects.

You can define an enhanced bitonal region by drawing a selection rectangle,
polygon, or polyline (fence). From this selection figure, you can select raster
entities within the figure, crossing the figure, or connected to such entities.

After you define the enhanced bitonal region object, you can modify the
object using AutoCAD commands and REM commands.

In this exercise, you move raster entities in an image of a drill jig drawing.
You also practice creating different types of enhanced bitonal region objects
to better understand the various rules Raster Design uses to construct such
objects.

Related Help Topics

■ Defining REM Enhanced Bitonal Regions

Related Exercises

Before doing this exercise, ensure that Raster Design options are set as described
in the exercise Exercise A1: Setting ProductNameShort Options (page 5).

Separate the title block and schedule from the border

1 In the \Tutorial3 folder, open the drawing file REM_03.dwg.

2 Right-click on an open toolbar and open the REM Enhanced Bitonal
Regions toolbar and the Raster Entity Manipulation Toolbar.

3 Click View menu  ➤ Named Views. Set the current view to
TU_assembled_jig.

4 Click Knife  on the Raster Entity Manipulation Toolbar.
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In the next few steps you will use this tool to separate the title block and
schedule from the border of this drawing.

5 Just above the title block and schedule, select a start point inside the
border, and an end point outside the border. These two points define a
knife cut across the border.

The crosshairs show where to draw the first knife cut.

6 On the lower left of the title block and schedule, define a vertical knife
cut across the border, then press Enter to end the command.

The crosshairs show where to draw the second knife cut.
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Remove the border from the drawing

7 Click View menu  ➤ Named Views. Set the current view to
TU_assembled_jig.

8 Click Smart Fence  on the REM Enhanced Bitonal Regions toolbar.

9 Draw the fence across the left vertical line of the border and press Enter.

The vertical line becomes a REM object.

Using a smart fence selects all raster primitives (lines, circles, and arcs)
that touch the fence. In this example, only one line touches the fence.
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10 Right-click and click REM ➤ Clear All.

The vertical line is no longer selected as a REM object.

11 Click Connected Fence  on the REM Enhanced Bitonal Regions
toolbar.

12 Draw the fence across the left vertical line of the border and press Enter.

The whole border becomes a REM object.

Using a connected fence selects all raster entities connected to the raster
entities that touch the fence. The border becomes a REM object when
you use a connected fence to select the vertical line because the vertical
and horizontal lines that make up the border are connected.

The title block and schedule, which you separated from the border using
the Knife command, are not included in REM object.
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13 Select the border and enter e (ERASE) to remove it, leaving the title block
and schedule in place.

Move the title block and schedule

14 Click Smart Window  on the REM Enhanced Bitonal Regions toolbar.

15 Draw a window around the title block and schedule.

The title block and schedule become a REM object.

16 Use the MOVE command to move the title block and schedule up and
to the right of the assembly.

17 Select the REM object, right-click, and click Merge to Raster Image.

Raster Design merges the REM object into the image. The title block and
schedule are no longer a REM object.

Define REM objects using smart and connected windows

18 Click View menu  ➤ Named Views. Set the current view to
TU_mandrel_rib_plate.

19 Click Smart Window  on the REM Enhanced Bitonal Regions toolbar.

20 Draw a window around the vertical leader line and the dimension text.
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The following example shows where to draw the window around the
leader line and the dimension text.

Using a smart window selects only the raster entities that are completely
within the window: the vertical leader line and dimension text.

The horizontal dimension lines that cross the window are not selected.

21 Right-click and click REM ➤ Clear All from the shortcut menu. The raster
entities are deselected.

22 Click Connected Window  on the REM Enhanced Bitonal Regions
toolbar.

23 Draw a window around the same vertical leader line and the dimension
text.

Using a connected window selects only the raster entities that are
completely within the window and not connected to entities outside the
window. In the following example, the leader lines are not selected
because they are connected to the dimension lines, which extend outside
the window.
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24 Right-click and click REM ➤ Clear All from the shortcut menu. The entities
are deselected.

Define REM objects using crossing windows

25 Select Smart Crossing  on the REM Enhanced Bitonal Regions toolbar.

26 Draw a crossing window around the same vertical leader line and
dimension text.

Using a smart crossing window selects all raster entities inside the window
or crossing the window:

■ The vertical leader line

■ The dimension text

■ The horizontal dimension lines
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27 Right-click and click REM  ➤ Clear All.

28 Click Connected Crossing  on the REM Enhanced Bitonal Regions
toolbar.

29 Draw a crossing window around the vertical leader line and the dimension
text.

Using a connected crossing window selects all raster entities that are
within the window, crossing the window, or connected to entities that
cross the window.

In the following example, only the dimension text to the right of the
part is not selected, because it is the only entity not connected to entities
that cross the selection window.
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30 Right-click and click REM ➤ Clear All from the shortcut menu.

31 Close the drawing without saving changes.

Exercise B3: Defining Primitive Objects
In this exercise you create REM primitive objects from raster data in bitonal
images.

You can create line, arc, or circle primitives. You can also use Smart Pick to
click a raster entity and let Raster Design determine whether to create a
primitive line, arc, or circle.

In this exercise, you create different primitive objects and operate on them
using various methods to better understand how Raster Design applies the
commands to different REM primitive entities.

Related Help Topics

■ Defining REM Primitive Objects

Related Exercises

Before doing this exercise, ensure that Raster Design options are set as described
in the exercise Exercise A1: Setting ProductNameShort Options (page 5).
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1 In the \Tutorial3 folder, open the drawing file REM_04.dwg.

2 Click View menu  ➤ Named Views. Set the current view to
TU_index_plate.

Define REM line, arc, and circle primitives

3 Right-click on an open toolbar and open the REM Primitives toolbar.

4 Click Line  on the REM Primitives toolbar.

5 Select the line that enters the circular part from the left.

Raster Design defines the line as a REM primitive.

6 Click Circle  on the REM Primitives toolbar.

7 Select the outer circle defined by a solid line.

Raster Design defines the circle as a REM primitive. The line you selected
in the previous step remains defined.
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8 Click Arc  on the REM Primitives toolbar.

9 Select an arc on the outer edge of the part.

Raster Design defines the arc as a REM primitive. The line and circle
primitives remain defined.

Define primitive objects using Smart Pick
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10 Click Smart  on the REM Primitives toolbar.

This option interprets the raster entities you select and creates REM lines,
circles, or arcs to represent them.

11 Select any line in the image.

Raster Design detects that you selected a line, and creates a REM line.

12 Press Enter to repeat the command.

You can also right-click and select Repeat Smart from the shortcut menu.

13 Select a circle defined by a solid line.

Raster Design creates a REM circle.

14 Press Enter to repeat the command.

15 Select an arc on the outer edge of the part.

Raster Design creates a REM arc.

This exercise demonstrates how you can use REM primitives to selectively
create REM objects as a basis for editing the image.

Clear the REM objects

16 Right-click and click REM ➤ Clear All to clear the REM objects from the
image.

17 Click View menu  ➤ Named Views. Set the current view to TU_extents.

18 Close the drawing without saving changes.

Exercise B4: Modifying a Part Using REM
Commands

In this exercise you learn how to use REM commands to modify a raster image.

You will modify a lock plate that is part of a drill jig, increasing the back plane
thickness of the lock plate, then updating the dimension text to reflect the
change in thickness.

Related Help Topics

■ Defining REM Region Objects

■ Defining REM Primitive Objects
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■ Vectorizing Raster Text

Related Exercises

Before doing this exercise, you should ensure that Raster Design options are
set as described in the exercise Exercise A1: Setting ProductNameShort Options
(page 5).

1 In the \Tutorial3 folder, open the drawing file REM_05.dwg.

2 Click View menu  ➤ Named Views. Set the current view to TU_lock_plate.

Separate the lock plate into two pieces

3 Open the REM toolbars, if necessary.

4 Click Polygonal Region  on the Raster Entity Manipulation Toolbar.

5 Draw a polygon with a vertical line that bisects the thinnest area of the
lock plate and includes the dimension text to the right of the part. Press
Enter.

6 Enter m and move the REM object exactly 0.25 inches to the right. To
do this, use the Displacement option and specify the displacement as
0.25,0,0.

This action creates a gap in the raster image. You must merge the region
object into the image before you can make other changes to the part.
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7 Select the region object, right-click, and click Merge to Raster Image from
the shortcut menu.

Close the top horizontal line

8 Click View menu  ➤ Named Views. Set the current view to TU_2.75.

9 Click Line  on the Raster Entity Manipulation Toolbar and select
the horizontal line at the top of the lock plate.

The line becomes a primitive object.

10 Select the primitive object, select its right grip, and stretch the line to
close the 0.25 inch gap.

11 Select the primitive object, right-click, and click Merge to Raster Image.

Close the bottom horizontal line

12 Click View menu  ➤ Named Views. Set the current view to TU_bottom.

13 Click Line  on the Raster Entity Manipulation Toolbar and select
the horizontal line at the bottom of the lock plate.

The line becomes a primitive object.

14 Select the primitive object, select its right grip, and stretch the line to
close the 0.25 inch gap.
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15 Select the primitive object, right-click, and click Merge to Raster Image.

Close the thread lines

16 Click View menu  ➤ Named Views. Set the current view to TU_thread.

17 Click Rectangular  on the Raster Entity Manipulation Toolbar.

18 Draw a narrow rectangle around some of the thread lines.

You can then copy this object to close the gap in the thread lines.
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19 Use COPY to copy the region object.

20 Place the copy of the region object so that it closes the gap in the thread
lines.

21 Select the copy of the region object, right-click, and click Merge to Raster
Image.
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22 Right-click and click REM  ➤ Clear All from the shortcut menu.

Replace the dimension text

You will now change the dimension text from 2.75 to 3.00 to indicate
the new thickness of the lock plate.

23 Click View menu  ➤ Named Views. Set the current view to TU_2.75.

24 Use the Layer Properties Manager to set TU_image_new as the current
layer.

25 Click Image menu  ➤ Vectorization Tools  ➤ Text. Then select a point
at the base of the numeral 2 on the left.

The crosshairs identify where to select a point for placing new dimension
text.

26 In the VText Edit dialog box, enter 3.00 and click OK.

Raster Design places the new dimension text at the point you selected.
On the command line, note that you are presented with a Smart Window
option for removing the raster text. You will next use this method to
remove the raster text 2.75.

27 Draw a window around the old dimension text. It does not matter if part
of the arrowheads are included within the window; they are excluded by
the smart selection method. Note that the text about to be removed is
highlighted. Press Enter to remove the selected text, then press Enter
again to end the command.
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28 Select the vector text, then right-click, click Properties, and change the
Width Factor of the text to 0.8.

29 Center the dimension text between the leader arrows if necessary.

30 To open the Raster Pen Settings dialog box, click Image  ➤ Merge  ➤ 

Configure Raster Pens.

31 Select Yellow, change the units to AutoCAD, and click Pick.

32 Select two points representing the width across the vertical dimension
line.

The following example shows where to select the two points that
determine the raster pen width for the new dimension text. When you
create raster text from the vector dimension text, the thickness of the
text should be comparable to the line work in the image.

33 Verify that Pen Width is set to approximately 0.10 and click OK.

34 Select the vector text, then right-click and click Merge Vector To Raster
Image.

35 Enter y (Yes) to delete the vector text after the merge.

The following example shows how the image should appear after you
replace the old dimension text with new raster text created from vector
dimension text.
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Review the Changes to the Lock Plate

36 Click View menu  ➤ Named Views. Set the current view to TU_lock_plate.

37 Review the changes to the part and its dimensions.

This example shows how the lock plate and its dimension text should
appear after you update them.
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38 Close the drawing without saving changes.
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Hybrid Image Tutorial

Drawings that combine raster and vector data are called hybrid drawings. This tutorial covers
some of the most common activities in hybrid drawings:

■ Scaling images and correlating images to vector objects in a drawing

■ Adding vector objects to images of scanned drawings

■ Editing raster geometry in the image

■ Converting raster geometry to vector

■ Converting vector objects to raster

■ Saving the modified image as a new image

When using Raster Design, you can decide which method to use to update an image based
on factors such as the following:

■ The quality and readability of the raster data in an image.

■ The complexity and amount of change required.

■ The anticipated use of an image.

■ The projected need for future updates.

The exercises in this tutorial use a scanned drawing of a floor plan for a school building. Your
objective is to update this image with the following revisions:

■ Create a new entrance to the building.

■ Add classrooms.

■ Replace a staircase with an access ramp for the physically disabled.

Other areas of the floor plan do not change. These areas can remain in raster format.

5
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Exercise H1: Inserting Images with Resource
Correlation Files

In this exercise, you use the Insertion Wizard to insert an image into a drawing.

The Insertion Wizard guides you through the process of inserting an image
and positioning the image relative to the other objects in the drawing.

Related Help Topics

■ Inserting Images

■ Specifying Correlation Settings

Related Exercises

Before doing this exercise, ensure that Raster Design options are set as described
in the exercise Exercise A1: Setting ProductNameShort Options (page 5).

1 In the \Tutorial4 folder, open the drawing file Hybrid_01.dwg.

2 View the vector linework in the drawing.

The magenta line represents the outline of the school building. The
dimensions of the outline were obtained from field taping measurements.
The other vector linework shows the proposed changes to the building.

Choose an image to insert

3 To display the Insert Image dialog box, click Image  ➤ Insert.

4 Click the Views menu to verify that Preview and Information are checked
on. This causes Raster Design to display a preview and a list of parameters
for each selected image.

5 From the Files of Type list, choose CALS Type 1.

6 If necessary, navigate to the \Tutorial4 folder.

7 Select the image file Floorplan_01.cal.

8 Review the values shown for each parameter.

This parameter list identifies important characteristics of the image.

Position and insert the image

9 In Insert Options, select Insertion Wizard.

10 In Insert Options ensure that Show Frames Only is not selected.
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11 Click Open to display the Pick Correlation Source dialog box.

This dialog box is the first dialog box of the Insertion Wizard. When you
choose a correlation source, the dialog box shows the insertion point,
rotation, and scale associated with the selected correlation source.

12 Select each of the options in the Correlation Source list, one after another,
and view the insertion parameters and image density associated with
each source.

The correlation sources are listed in descending order of priority. The
resource file has the highest priority as a correlation source.

13 Select Resource File for the correlation source and click Next.

14 Zoom out and notice that the inserted image is much bigger than the
rectangle enclosing the vector linework.

15 In the Modify Correlation Values dialog box, change the Scale value from
300 to 25. Click Apply to see the results.

The Modify Correlation Values dialog box gives you the opportunity to
alter correlation information before AutoCAD units are applied. Raster
Design shows where the image will appear in the drawing when the image
is inserted according to the specified correlation values.

16 Click Next.

17 The Insertion dialog box shows the correlation of the image in AutoCAD
units. Click Finish to accept the values shown here.

The image of the floor plan is inserted in the drawing, which already
contains some vector linework.

Exercise H1: Inserting Images with Resource Correlation Files | 77



18 Close the drawing without saving changes.

Exercise H2: Scaling and Matching Images
In this exercise, you use two of the correlation commands available in Raster
Design:

■ Scale. Makes an image larger or smaller by specifying a known distance
between two points on the image itself. Scale only performs the re-scaling
about a specified base point, no rotation is involved.

■ Match. Aligns an image to existing vector linework by specifying two source
points on the image and two destination points in the drawing. The image
is rotated, scaled, and moved as necessary to match the source points to
the destination points.
By correlating the image with the existing geometry before you make any
design changes, you avoid perpetuating inconsistencies in scale and
position when you modify the raster or vector data.

Related Help Topics

■ Scaling an Image

■ Correlating an Image After Insertion
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Related Exercises

Before doing this exercise, ensure that Raster Design options are set as described
in the exercise Exercise A1: Setting ProductNameShort Options (page 5).

1 In the \Tutorial4 folder, open the drawing file Hybrid_02.dwg.

Scale the image

2 View the current vector and raster linework in the drawing.

The linework in the image and in the drawing are not aligned.

3 Click View menu  ➤ Named Views. Then expand the Model Views list,
and set the current view to TU_scale.

4 Enter dist (DISTANCE command) to determine the width of the center
classroom, measuring from left to right.

The width of the classroom is approximately 34 feet (10.4 meters). It
needs to be shown in the drawing as 25 feet (7.5 meters) instead.

This example shows the two points you select to measure the width of
the center classroom.

5 Click Image menu  ➤ Correlate  ➤ Scale. Then select the intersection
of the outside wall and the left wall of the center classroom for the base
point.
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6 When prompted, enter 34 feet (10.4 meters) for the source distance, and
25 feet (7.6 meters) for the destination distance.

7 Use the DISTANCE command to verify the width of the center classroom
is now approximately 25 feet (7.6 meters).

Match the image to the vector linework

8 Click View menu  ➤ Named Views. Then set the current view to
TU_extents.

9 Click Image menu  ➤ Correlate  ➤ Match. Then select the intersection
of the outside walls at the upper-left corner of the building for the first
source point.

TIP Use Pan and Zoom to more clearly display this area of the drawing.
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10 Use an Endpoint OSNAP to select the first destination point at the
upper-left corner of the purple vector linework of the building.

11 For the second source point, select the intersection of the outside walls
at the upper-right corner of the building.
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12 For the second destination point, select the upper-right corner of the
purple vector linework of the building.

The image is aligned with the vector linework.

13 Close the drawing without saving changes.
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Exercise H3: Improving Existing Linework
In this exercise you learn about using bitonal image processing tools, REM
smoothing tools, and using vector to fill in for raster.

You work with an image of a floor plan. In areas where the raster linework is
jagged, you use bitonal smoothing filters to improve existing raster on a
regional basis. You also use REM smoothing tools to improve raster on an
entity-by-entity basis.

You use vector linework to fill in missing raster. Raster snaps, which operate
much as AutoCAD object snaps operate on vector objects, help to re-create
linework precisely and quickly.

Related Help Topics

■ Specifying Raster Snap Settings

■ Vectorizing Raster Lines and Polylines

■ Smoothing REM Linework

Related Exercises

Before doing this exercise, ensure that Raster Design options are set as described
in the exercise Exercise A1: Setting ProductNameShort Options (page 5).

1 In the\Tutorial4 folder, open the drawing file Hybrid_03.dwg.

View the image and the proposed vector changes

2 Click View menu  ➤ Named Views. Then expand the Model Views list,
and set the current view to TU_entry to see the vector linework for the
proposed new entrance to the building.

3 Set the view to TU_classroom to see the vector linework for the proposed
new classrooms.

4 Set the view to TU_ramp to see the vector linework for the ramp to the
stage.

5 Set the view to TU_storeroom to see an area of the image where the raster
linework needs improvement.

This example shows an area of the image where the linework is poor:
some raster lines are thin, while others overlap. Bitonal filters are one
option for enhancing the linework. However, these filters work best on
images where the line density is relatively uniform.
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Apply line smoothing to a region of the image

6 Click Image menu  ➤ Image Processing  ➤ Bitonal Filters. Then press
Enter to process the entire image.

7 In the Bitonal Filters dialog box, select Smooth for the filter type, 1 for
the number of passes, and click OK.

After applying one pass of the smoothing filter, the raster lines are more
accurate.
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Specify the raster snap settings

8 Set the view to TU_linework to see an area of the image where some raster
lines are missing.

This example shows where lines are missing in the image. New vector
lines need to be drawn in where indicated.

9 To display the AutoCAD Drafting Settings dialog box, click Image  ➤ 

Raster Snap.

10 Specify the following settings for the raster snaps:

■ Raster Snap: On

■ Raster Snap Modes: End

■ Aperture Size: 25

11 Click OK.

Create vector linework from the thin raster lines

12 Turn ORTHO Mode On.

13 Fill in the gaps in the raster lines with vector lines.

This example shows the vector lines filling in where the raster was missing.
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14 Turn ORTHO Mode Off.

In a later exercise, you merge the vector linework with the raster image.

Turn off raster snaps

15 Click Image  ➤ Raster Snap.

16 Clear Raster Snap On, and click OK.

Apply line smoothing to specific lines in the image

17 Set the view to TU_multi_purpose. Note the vertical wall lines are jagged
and of varying widths.

18 Click Image menu  ➤ Raster Entity Manipulation  ➤ Create Primitive
 ➤ Line.

19 Zoom in and select the four vertical lines that form the side walls of the
multi-purpose room, repeating the REM Line command as necessary. The
lines are now represented by REM entities.
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20 Select the four REM lines, then right-click and click Properties. The Object
Properties dialog box appears. Ensure that the selected objects are
identified as REM Line (4).

21 In the Properties dialog, in the Geometry section, set the Width to 3.

The four lines are redrawn to a uniform width and smoothed
automatically.

22 Close the Object Properties dialog box.

23 Ensure that the four lines are selected, then right-click and select Merge
To Raster Image. The modified lines are merged back into the image.

The following example shows the four lines smoothed with equal width
and merged back into the image.
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24 Close the drawing without saving changes.

Exercise H4: Removing Raster Entities
In this exercise you learn about using the Remove and Raster Entity
Manipulation (REM) commands to change raster geometry in images.

Use the Remove commands as follows:

■ Define a region, such as a rectangle, polygon, or circle, then remove the
raster data within that region.

■ Remove raster entities that have particular geometric shapes, such as lines,
arcs, circles, or polylines.

Use the REM commands to edit REM entities as if they were vector objects,
without actually changing the entities to vector. You create a selection set of
REM objects and then select an AutoCAD command. The selection set can be
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an area of an image, or, for bitonal images only, it can be lines, arcs, and
circles.

In this exercise, you focus on removing raster data to make room for new
vector objects in the floor plan of the school building.

Related Help Topics

■ Removing (Rubbing) Images

Related Exercises

Before doing this exercise, ensure that Raster Design options are set as described
in the exercise Exercise A1: Setting ProductNameShort Options (page 5).

1 In the\Tutorial4 folder, open the drawing file Hybrid_04.dwg.

Remove the raster entrance

2 Change the color of the TU_image_bitonal layer to yellow.

3 Click View menu  ➤ Named Views. Then expand the Model Views list,
and set the current view to TU_entry.

The vector linework in this view shows the proposed entrance. The raster
linework shows the old entrance.

4 Click Image menu  ➤ Remove  ➤ Polygonal Region.

5 Draw a polygon around the old entrance, including the outer wall.

The following example shows where to draw the polygon to remove the
old entrance to the building. Raster Design removes the raster data within
the polygon.
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6 Press Enter.

Raster Design removes the raster data within the polygon.

Remove the raster staircase

7 Set the current view to TU_ramp.

The vector linework in this view shows the proposed ramp. The raster
linework shows the staircase to be removed.
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8 Click Image menu  ➤ Remove  ➤ Line Entity.

9 Select the lowest of the four horizontal stair lines. Raster Design removes
the line as soon as you select it.

This example shows the line you select to begin removing the raster
linework of the staircase.

10 Right-click and select Repeat Line Entity from the shortcut menu to
remove the next two stair lines.

11 Right-click and click REM ➤ Create ➤ Smart Pick. Click the vertical line
to the right of the old staircase. In this case, Raster Design selects the line
but does not perform an action. The line is now part of a REM selection
set. You can now execute AutoCAD commands, such as ERASE, on the
selection set.
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12 Enter e for ERASE, select the highlighted line, then press Enter.

13 Click Image menu  ➤ Remove  ➤ Rectangular Region. Then remove the
remaining stair line.

14 Right-click and select Repeat Rectangular Region from the menu to remove
the portion of the lines that extend into the vertical vector wall.

Remove the raster walls near the new classrooms
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15 Set the current view to TU_classroom.

The vector linework in this view shows the proposed additional
classrooms. The raster linework shows the old classroom walls and exterior
walls.

16 Set the current view to TU_upper.

17 Click Image menu  ➤ Remove  ➤ Polygonal Region.

18 Draw a polygon around the old classrooms and the walls that define the
hallway to the left of the classrooms.

19 Press Enter.

Raster Design removes the raster data within the polygon.
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20 Change the color of the TU_image_bitonal layer to white.

21 Close the drawing without saving changes.

Exercise H5: Masking Images of Scanned Drawings
In this exercise you use Mask to exclude areas of an image from view without
deleting the raster data.

You create a mask to display a subset of the images in a drawing. A mask shows
the area of the image inside the mask boundary and hides areas of the image
outside the mask boundary.

If the drawing contains more than one image, Raster Design has settings to
control what happens with images that are completely outside the mask
boundary. Options for these images are to hide, unload, or leave them
unaffected. Unlike cropping and rubbing, masking does not permanently
modify images. Also, you can have multiple masks defined in a drawing and
can selectively turn them on and off to redisplay the images.

In this exercise, you create a mask to hide the title block in the image of a
floor plan of a school building. This raster title block contains old information
and cannot be updated readily. Using Mask, you can hide the old title block,
retaining the data for historical purposes. You can then insert a new vector
title block, annotate it for the revised floor plan, and plot the drawing.
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Related Help Topics

■ Masking Images

■ Changing an Existing Mask

Related Exercises

Before doing this exercise, ensure that Raster Design options are set as described
in the exercise Exercise A1: Setting ProductNameShort Options (page 5).

1 In the \Tutorial4 folder, open the drawing file Hybrid_05.dwg.

Select the image mask options

2 Click Image menu  ➤ Mask  ➤ Create.

3 In the New Image Mask dialog box, specify the following settings:

■ Select Enable Mask.

■ Under Image(s) Outside the Image Mask, select Hide Image(s).

■ Clear Show Image Frame(s).

Define the image mask

4 Click Rectangular.

5 Draw a rectangle around the floor plan excluding the title block and
border.

Raster Design hides areas of the image that are outside the rectangle.
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Turn the image mask off and on

The mask boundary is an AutoCAD object that you can move, stretch,
scale, and erase.

6 Select the rectangular mask boundary, then right-click and click Enable
from the shortcut menu to turn off the image mask.

Raster Design displays the entire image.
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7 Select the mask boundary, right-click, and click Enable to turn the image
mask back on.

Convert the image mask to a clip and hide the mask boundary

8 Click Image menu  ➤ Mask  ➤ Convert to Image Clip.

Converting the image mask to an image clip allows you to use the
IMAGECLIP command options to turn the clip off or on, change its
boundaries, and delete the clip.

9 Select the mask boundary and press Enter.

10 Right-click and click Image ➤ Show Image Frames to hide the clip
boundary.

Insert a vector title block

11 Set 0 as the current layer.

12 Use the INSERT command to open the Insert dialog box.

13 Browse to the \Tutorial4 folder, and insert the drawing file Title.dwg,
using the default insertion parameters, as follows:insert

■ Insertion Point: 0,0,0

■ Scale: 1,1,1

■ Rotation: 0

14 Freeze the layer named TU_border.

The following example shows how the drawing should appear after you
turn on the image mask and insert a vector title block.

You can annotate the floor plan, complete the title block, and plot the
drawing.
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15 Close the drawing without saving changes.

Exercise H6: Merging Vector Changes with Raster
Images

In this exercise you merge vector objects into a raster image.

By merging vector objects, you can make precise changes to your raster image
using the power of AutoCAD drawing tools yet keeping your data in raster
format.

In this exercise, you merge the following vector changes with the raster image
of the floor plan:

■ The new entrance

■ The ramp that replaced the staircase

■ The new classrooms

■ The vector lines you drew to replace missing raster linework
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When you merge vector objects into a raster image, you can control the
following parameters:

■ The line width of the raster linework created from the vector object(s),
based on the color of each object

■ Which vector objects to merge into the image

■ Whether or not or not to create a new image for the merged data

■ If display order should be respected when merging

■ If an existing image should be expanded if necessary to accommodate the
new data

Related Help Topics

■ Merging Vectors into a Raster Image

■ Selecting Pen Widths for Vector Merge

Related Exercises

Before doing this exercise, ensure that Raster Design options are set as described
in the exercise Exercise A1: Setting ProductNameShort Options (page 5).

1 In the \Tutorial4 folder, open the drawing file Hybrid_06.dwg.

Select the color and width of the new raster linework

2 To display the Raster Pen Settings dialog box, click Image  ➤ Merge  ➤ 

Configure Raster Pens.

3 Verify that the pen width for all colors is set to 3 pixels and click OK.

Merge the vector objects into the image

4 Click Image menu  ➤ Merge  ➤ Vector into Raster.

5 Draw a rectangle that includes all of the vector linework except the title
block and border then press Enter.

6 When prompted, enter y to delete the vector objects you selected.

If you want to keep the vector linework, you can enter n when prompted.
You can then freeze the layers that contain the vector linework so that
the vectors are not displayed.

The following example shows how the drawing should appear after you
merge the vector objects into the image.
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Review the raster entities created from the vector objects

7 Click View menu  ➤ Named Views. Then expand the Model Views list,
and set the current view to TU_entry to see the linework for the proposed
new entrance to the building.

8 Set the current view to TU_classroom to see the linework for the proposed
new classrooms.

9 Set the current view to TU_ramp to see the linework for the proposed
ramp.

10 Set the current view to TU_linework to see the area of the image where
you replaced some of the missing raster linework with vector lines.

The raster lines created from the vector lines are smooth and distinct.

11 Close the drawing without saving changes

Exercise H7: Exporting Images with Resource
Correlation Files

In this exercise you export an image with a resource correlation file.

A correlation file contains the parameters used to determine insertion point,
scale, and rotation for an image when you insert the image in a drawing.
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Having a correlation file enables you to use an image in other drawings or in
other applications at the correct insertion point, scale, and rotation.

In this exercise, you export an image that contains edits that were performed
by merging vector data into the image. Raster Design creates the resource
correlation file as part of the export process. You can also create a World
correlation file without saving the image. Click Image menu  ➤ Export  ➤ 

World File.

Related Help Topics

■ Exporting Images

Related Exercises

Before doing this exercise, ensure that Raster Design options are set as described
in the exercise Exercise A1: Setting ProductNameShort Options (page 5).

1 In the \Tutorial4 folder, open the drawing file Hybrid_07.dwg.

2 Click Image menu  ➤ Export  ➤ Image.

3 If necessary, change the location where the exported image will be saved.

4 Enter Floorplan_update.cal for the filename, select CALS1 for the file
type, and click Export.

5 In the Export Options dialog box, specify the following settings:

■ Select Maintain Drawing Link to Image.
This changes the saved path for the image in the drawing. The
exported image will be the one inserted into the drawing.

■ Select World File for the correlation output type.

6 Click Finish.

7 Close the drawing without saving changes.
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Photograph and Map
Tutorial

This tutorial shows you how to use Raster Design to work with images of photographs and
maps.

Use Raster Design to enhance the usefulness of aerial photographs, satellite images, and maps:

■ Correlate images to the vector geometry in your AutoCAD drawings.

■ Export images with correlation files so that they can be used in other drawings and
applications.

■ Correct image distortions.

■ Improve the readability of images.

■ Extract valuable information from map images, such as soils maps and US Geological
Survey (USGS) quad sheets.

■ Insert images from the Internet.

■ Create displayable maps from digital elevation models (DEM).

■ Use multispectral satellite images to display special features of a land surface.

■ Convert grayscale images to bitonal (black and white) to isolate features of interest.

■ Create vector objects by tracing raster entities such as soil boundaries, streams, and
contours.

■ Remove unneeded areas of images and make areas transparent.

■ Create image mosaics of multiple images to cover large areas.

■ Create new images by merging existing images together.

The lessons in this tutorial show you how to use Raster Design with the following images:

■ An aerial photograph showing current land use for a proposed development.

6
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■ A Natural Resources Conservation Service (NRCS) soils map showing soil boundaries
and soil types for the region around the development.

■ Two adjacent USGS quad sheets showing the physical characteristics of the region.

■ A digital elevation model.

■ A four-band set of multispectral satellite images.

Exercise P1: Inserting an Aerial Photograph from
the Internet

In this exercise you insert an image of an aerial photograph from the Internet.

The images used in this exercise are in highly compressed wavelet formats
making them particularly suitable for this purpose.

In this lesson, you insert an aerial photograph into a drawing that contains
a plan view of an undeveloped parcel of land. The photograph shows the
current land use for the site and the surrounding region.

NOTE The images you can insert in this exercise are available both on the AutoCAD
Raster Design Web site and in the \Tutorial5 folder.

Related Help Topics

■ Inserting an Image from the Internet Using the Insert Image Dialog Box

■ Specifying Correlation Settings

■ Saving an Image to Another File Name, Type, or Location

Related Exercises

Before doing this exercise, you should ensure that Raster Design options are
set as described in the exercise Exercise A1: Setting ProductNameShort Options
(page 5).

1 In the \Tutorial5 folder, open the drawing file Map_01.dwg.

Locate the image to insert

2 To display the Insert Image dialog box, click Image menu  ➤ Insert.
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3 Under Insert Options select the Insertion Dialog option. Ensure that Show
Frames Only and Zoom To Image(s) are cleared.

4 Click Search the Web  to display the Browse the Web - Open dialog
box.

5 In the Address field, enter http://www.autodesk.com/rasterdesign-tutorial
and press Enter.

This takes you to a page on the Autodesk website that contains an aerial
image available in two formats: .ecw and .sid.

6 Click the link for either the Downloadable .sid image or Downloadable
.ecw image.

In the Browse the Web - Open dialog box, the address of the file is
displayed in the Name or URL field.

7 Click Open.

Insert the image

8 In the Image Insertion dialog box, on the Insertion tab, click Pick.

You will be prompted to pick the location of the bottom left corner of
the image frame, then the rotation angle, then the size of the image.

9 Move the image frame to the right of the vector drawing, then click to
place the bottom left corner.

In later exercises of this tutorial, you correlate the image to the vector
drawing of the site using Match and Rubbersheet.

10 Press Enter to specify a rotation of 0.

11 Move your cursor to the upper right, then click a corner point that makes
the image frame about the same height as the existing drawing.

12 Click OK.
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Save the image as a TIFF file

13 Click Image menu  ➤ Save As.

You must save the wavelet compressed files (.sid or .ecw) as a format
Raster Design can write to.

14 If necessary, navigate to the \Tutorial5 folder.

15 Enter Aerial_01.tif for the filename, select TIF for the file type, and click
Save.

16 Choose Uncompressed for the Encoding Method and click Next.

17 Choose Tiled for the Data Organization and click Finish.

The image can now be modified, having been saved in an editable format.

18 Close the drawing without saving changes.

Exercise P2: Matching Images to Drawings
In this exercise you use Match to correlate an aerial photograph to a vector
drawing.

Match applies linear correlation, adjusting insertion point, scale, and rotation
as necessary, to align a raster image with known points in a vector drawing
or with another image.
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To match an image to a drawing, you select two source points on the image
and two corresponding destination points in the drawing. Raster Design uses
these points as a reference to reposition the image relative to the drawing.

Related Help Topics

■ Correlating an Image After Insertion

Related Exercises

Before doing this exercise, ensure that Raster Design options are set as described
in the exercise Exercise A1: Setting ProductNameShort Options (page 5).

1 In the \Tutorial5 folder, open the drawing file Map_02.dwg.

Restore the viewport TU_match

2 Click View menu  ➤ Viewports  ➤ Named Viewports. Click the viewport
TU_match, then click OK.

Match the first point

3 Click Image menu  ➤ Correlate  ➤ Match.

4 For the first source point, select the upper right viewport, then select the
source point on the image.
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5 For the first destination point, select the upper left viewport, then select
the intersection of the stone wall and the parcel boundary, at the center
of the X.

Match the second point

6 For the second source point, select the lower right viewport, then select
the source point on the image, at the lower right corner of the barn.
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7 For the second destination point, select the lower left viewport, then
select the center of the X.

When you click the second destination point, the image immediately
snaps into alignment with the drawing.

View the results of matching the points
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8 To set a single viewport, click View menu ➤ Viewports ➤ 1 Viewport.
Then zoom out to see the vector lines overlaid on the aerial photo.

9 Close the drawing without saving changes.

Exercise P3: Correcting Distortions in
Photographic Images

In this exercise you use rubbersheeting to correct distortions in aerial
photographs.

After the image is rubbersheeted, it can serve as a valuable reference for
engineering, facilities, and mapping projects. Rubbersheeting can be a low-cost
alternative to orthophotography if approximate accuracy is acceptable.

In this exercise, you use rubbersheeting to correct an image involved in a
parking lot project. Import control points, add additional points, explore
differences between Triangular and Polynomial methods, and learn how to
use the rubbersheet preview and check points to predict your results.

Related Exercises

■ Exercise S7: Correcting Distortions Using Triangular Rubbersheet (page
33)

■ Exercise S8: Correcting Distortions Using Grid Points (page 38)
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Before doing this exercise, ensure that Raster Design options are set as described
in the exercise Exercise A1: Setting ProductNameShort Options (page 5).

1 In the\Tutorial5 folder, open the drawing file Rsheet_01.dwg. A grayscale
image of a parking lot automatically inserts with the drawing.

Invoke rubbersheet and import a point file

For convenience, a point file has already been created for you to use as
a starting point for this exercise. In normal practice, you create pairs of
source and destination points to specify where the image must stretch
to align with the vector line work. It is recommended as a best practice
to export your points before executing the rubbersheet. Then if you want
to try the rubbersheet operation again with a different method or with
different points you have a good place to start.

2 To display the Rubbersheet-Set Control Points dialog box, click Image
 ➤ Correlate  ➤ Rubbersheet.

3 Click the Import button, choose the point file \Tutorial5\ Rsheet_01.txt
and click Open. The imported points display in the control point list box.
The OK and Preview buttons are available now that there are sufficient
points to perform a rubbersheet (at least 3 are required).

Preview the rubbersheet and re-pick a point

In the next few steps, you compare previews for both methods,
Polynomial and Triangular. Based on the previews you re-pick any points
that were incorrectly defined.

4 In the Rubbersheet-Set Control Points dialog box, under Method, select
Polynomial and leave the Degree at the default setting 1. The Error column
shows how much the actual location of destination points, after
rubbersheeting, will differ from the entered values.

5 Click the Preview button. The Rubbersheet-Set Control Points dialog box
closes and a preview of the rubbersheet is shown.

The red border previews the extents of the raster image after the
rubbersheet. The cyan border shows the extents of the original image.
The amount of variation in these extents indicates how much the image
must be distorted to match up with the control points. The upper left
and lower right corners are areas of considerable distortion.
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6 Right-click or press Enter to exit the preview.

7 Set the Method to Triangular. Select the Preview button.

The preview shows the extents of the result in red and previews the
extents of that area with a thin cyan line. The area between the cyan
extents and the original frame of the image is discarded in the final
triangular rubbersheeted result. The triangular algorithm can be applied
only over the area contained by the control points; the rest must be
discarded. Zoom into the upper left to see this more clearly. We can see
from this preview that point 1 apparently has been incorrectly defined.
The destination for this point should be at the corner of the parking lot,
not on the round island to the right.
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8 Right-click or press Enter to exit the preview.

9 Highlight the row for point 1 in the control point list box. Click the
Repick button. The Rubbersheet-Set Control Points dialog box is closed
temporarily and the screen is zoomed to the region of point 1.

10 At the command line you are prompted to specify a new Source point.
Press Enter to accept the current source point, which is the blue point
just above the corner of the yellow vector perimeter. You are now
prompted to specify the new Destination point. Pick the point at the
corner of the yellow perimeter. This action moves the destination point
from the round island to the corner of the parking lot.

The Rubbersheet-Set Control Points dialog box is displayed after you pick
the new destination point.

Add control points for triangular rubbersheet

As you saw in the Triangular rubbersheet preview, the final result includes
only that portion of the image contained by the control points. To get a
rubbersheeted image that covers the whole parking lot, you need to add
several control points.

11 Click Preview to see where control points need to be added. Note the
areas in the upper left, lower left, and lower right of the parking lot where
the wide red border deviates significantly from some parts of the parking
lot. You can add a control point in each of these areas to correct this
situation. Press Enter to exit the preview.
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12 Click Add Points. At the command line you are prompted to specify a
new Source point. Transparently zoom to the upper left corner of the
project. Pick the upper corner of the parking lot in the image. At the
command line you are prompted to specify the Destination point. Pick
the corresponding corner represented by the yellow border.

13 At the command line you are prompted to specify the next Source point.
Transparently pan and zoom to the lower left corner of the parking lot.
Similar to before, pick the corner of the parking lot in the image as the
Source point and the corner of the yellow border as the Destination point.
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14 At the command line you are prompted to specify another Source point.
Transparently pan and zoom to the lower right corner of the parking lot.
Locate the light pole labeled in the drawing. Notice the image and drawing
line up closely at this point so you can make this an anchor point where
the Source and Destination points are the same. Pick the light pole and
then enter a to anchor the point. Enter d to finish adding points and
return to the Rubbersheet-Set Control Points dialog box.

15 Click the Preview button. Notice that the whole parking lot is now
contained within the red image boundary as desired. Right-click or press
Enter to exit after examining the preview.
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Preview polynomial rubbersheet

Now that all the control points are in place, see how a Polynomial
rubbersheet would look. Often you find that the Triangular method gives
just the results desired but there may be other cases where the Polynomial
method would be the better choice. One case might be where you might
need to preserve the image data outside the area of known control points.

16 In the Rubbersheet-Select Control Points dialog box, under Method, select
Polynomial. Leave the Degree at 1. Click the Preview button to see the
projected results.

Note that the outline of the image would change very little from its
present form. This means the rubbersheet operation will introduce very
little distortion and the data outside the control points is reasonable.

17 Press Enter to close the preview window.

18 Note the errors reported for the individual control points in the Error
column of the Rubbersheet-Set Control Points dialog box. All are under
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2 feet and some are under a foot. Note the Total RMS Error which is a
form of an average error of all the points.

19 Raise the polynomial Degree to 4 to see how this affects the individual
and Total RMS Error as well as the preview. The individual errors and the
Total RMS Error drop significantly. Leave the degree at 4.

20 Click the Preview button to see how the higher degree affects the overall
image.

Significant warping is now present in the red new image outline. The
higher polynomial degree allows greater warping in order to match the
control points more closely. The result is dramatic warping in areas where
there are no control points. This degree of warping renders the image
useless for those areas outside the control points.

21 Right-click or enter Enter to exit the preview.

Add check points

You have seen that for the polynomial method there is an inverse
relationship between control point error and the amount of warping
present in the image. This relationship is affected by polynomial degree
as well as by the number and arrangement of control points.

Another tool for evaluating this relationship is the check point. A check
point is a control point that is disabled so it is not included in the
calculation of the image transformation. Instead, the distance that point
is moved, based on the control points used, is reported in the error
column. In this way, you can get a quantitative measure for the extent
that image warping occurs in a specific part of the image. While you
explore check points in the context of a Polynomial method rubbersheet,
they are equally useful for evaluating movement between control points
for Triangular method rubbersheets.
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22 Click the Add Points button and set anchor points at each corner of the
image frame. (Anchor points are not necessary for this use but are cleaner
and easier to define). Point numbers 17, 18, 19 and 20 are defined when
you are done. Type d when you are finished adding points. The
Rubbersheet-Set Control Points dialog box displays.

23 In the Rubbersheet-Set Control Points dialog box, clear the check boxes
for points 17, 18, 19, and 20 to disable them. These check points display
gray in the control point list box. The error calculation is dynamically
updated as you enable or disable control points.

24 With the four points now set as check points, the Error column values
for these points show exactly how far the corners of the image move in
order to accomplish the warp using the defined control points and the
polynomial Degree of 4. Change the Degree to 1 and note that the check
point movement is significantly less.

Perform the rubbersheet

You have explored the possibility through previews and check points of
performing this rubbersheet using the Triangular and Polynomial
methods. You have also seen the advantages of changing polynomial
degree and adding more control points. The Triangular method will be
used for the final rubbersheet because there are no errors at the defined
control points, and the image data outside the parking lot boundary (the
control point cluster) is not required.

25 In the Rubbersheet-Set Control Points dialog box, change the Method to
Triangular.

26 Export the control points in case you want to repeat the rubbersheet later
using different settings. Click the Export button, then in the Export dialog
box name the file Rsheet_01new.txt, and click Export.

27 Click OK. The rubbersheet processes and the Rubbersheet-Set Control
Points dialog box closes. Enter REGEN to correct the display order if
necessary.
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28 Close the drawing without saving any changes to the drawing or image.

Exercise P4: Enhancing Grayscale Images
In this exercise you use three image processing functions to improve the image
clarity of a grayscale aerial photograph.

Several editing filters are available in Raster Design. Those that use the
histogram include functions to convert color images to grayscale or bitonal
(black and white) images, and to convert grayscale images to bitonal images.

In this lesson, you experiment with the Brightness, Contrast, and Equalize
functions. You can observe the effects of each function on the image by using
both the preview and histogram display before you apply the changes.

In this exercise you process the whole image. Raster Design also allows only
a specified portion of the image to be processed.

Related Help Topics

■ Adjusting the Brightness and Contrast of an Image

■ Maximizing Details in an Image

Related Exercises

Before doing this exercise, ensure that Raster Design options are set as described
in the exercise Exercise A1: Setting ProductNameShort Options (page 5).

1 In the \Tutorial5 folder, open the drawing file Map_04.dwg.

2 If the vector line work is not displayed on top of the aerial photo, enter
REGEN to restore the display order.
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Adjust the contrast and the brightness

3 Click Image menu  ➤ Image Processing  ➤ Histogram. Press Enter for
the whole image. The Histogram dialog box appears.

Ensure that Brightness/Contrast is the active tab.

4 Move the pointer over the histogram display until the index value equals
69.

The frequency value identifies the number of pixels in the image assigned
to this shade of gray. In the next few steps, you will see the effects of the
contrast and brightness controls.

5 Move the Contrast slider to the right to increase the contrast, observing
the effect in the preview window.

Increasing the contrast displays mid-tone image values in more extreme
light and dark shades. Increasing the contrast to an extreme value in a
grayscale image polarizes the shades of gray to display in black and white.

6 Move the Contrast slider to the left to decrease the contrast, observing
the effect in the preview window.

Decreasing the contrast in a grayscale image displays more image values
in midrange shades. At extreme low contrast, all the image values display
as a single shade of gray.

7 Move the Brightness slider to 128 to increase the brightness, observing
the effect in the preview window.

In grayscale images, increasing the brightness displays gray image values
in lighter shades. At extreme brightness, all image values display as white.

8 Move the Brightness slider to the left to decrease the brightness, observing
the effect in the preview window.

In grayscale images, decreasing the brightness displays image values in
darker shades. In the extreme case, all image values display as black.

9 Click Reset. The Contrast and Brightness sliders return to center.

Equalize the grayscale of the image

10 Click the Equalize tab.

Equalization is useful for images in which a large percentage of pixels are
approximately the same color. In a grayscale image, equalization changes
the darkest pixels to black and the lightest pixels to white and then
reassigns the remaining pixels to use all shades in between.
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11 Click Apply to equalize the shades of gray across the full range of grays
and observe the effect in the preview window.

12 Click Close.

Note that image details are more visible in the equalized image.

13 Close the drawing without saving changes.

Exercise P5: Using a World Correlation File
In this exercise you use a world correlation file to insert an image of a soils
map.

Using a correlation file, such as a world file or a resource file, is one of several
options for specifying the insertion point, rotation, and scale when you insert
an image.

Also in this exercise, you work with the setting for image units in relation to
drawing units.

Related Help Topics

■ Specifying Correlation Settings

Related Exercises

■ Exercise S1: Inserting Images of Scanned Drawings (page 17)

Before doing this exercise, ensure that Raster Design options are set as described
in the exercise Exercise A1: Setting ProductNameShort Options (page 5).

1 In the \Tutorial5 folder, open the drawing file Map_05.dwg.

Choose an image to insert

2 To display the Insert Image dialog box, click Image menu  ➤ Insert.

3 From the Files of Type list, choose TIFF.

4 If necessary, navigate to the \Tutorial5 folder.

5 Select the image file Soilsmap_world_01.tif.

6 On the Views menu verify that Preview and Information are checked.
This displays a preview window and a list of information about the image.

7 Review the values shown for each parameter.

Exercise P5: Using a World Correlation File | 121



Insert the image using a world correlation file

8 Under Insert Options, select the Insertion Dialog option. Also make sure
that Show Frames Only and Zoom To Image(s) boxes are cleared.

9 Click Open to display the Image Correlation dialog box. Select the Source
tab.

Raster Design detects that a world correlation file (soilsmap_world_01.tfw)
is associated with this image. The dialog box shows the insertion point,
rotation, and scale specified in the correlation file.

10 Click the Insertion tab.

Note the Drawing Units are specified as Meters. The image must use the
same setting for proper correlation.

11 Click the Modify tab. Under Units, note that the Image Units can be
changed here.

12 Ensure that the image units are set to Meters to match the drawing units.

TIP In this step, you are setting the image units for this insertion only. In
your real work with images, if you ever want to change the default setting
for all insertions, click Image menu  ➤ Options. In the Raster Design Options
dialog box, click the Image Defaults tab. On this tab you can set both
horizontal units (under Density) and vertical units.

13 Click Apply to see the image displayed in the drawing, then click OK to
finish the insertion process.

14 If the vector line work is not displayed on top of the image, enter REGEN
to correct the display order.
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15 Close the drawing without saving changes.

Exercise P6: Converting Grayscale Images to
Bitonal Images

In this exercise you convert a grayscale image to bitonal (black and white)
images and clean up the converted image:

■ Threshold converts a grayscale image of a soils map to a bitonal image.

■ Invert reverses light and dark areas of the image to improve readability.
In the case of bitonal images, it also has the effect of reversing background
and foreground colors.

■ Despeckle removes undesired spots and speckles from the image.

By converting the grayscale image to a bitonal (black and white) image,
inverting the image, and removing speckles, you make the soil boundaries in
the image easier to identify. The resulting map can be readily converted to
vector using the Raster Design Vectorization Tools.

In this lesson, you also export the modified image with a world correlation
file.

Related Help Topics

■ Converting a Grayscale or Color Image to Bitonal
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■ Exporting Images

■ Reversing the Light and Dark Shades in an Image

■ Removing Speckles from an Image

Related Exercises

■ Exercise S3: Cleaning Up Images with Invert and Mirror (page 22)

■ Exercise V1: Setting Options and Creating Basic Vector Objects (page 183)

Before doing this exercise, ensure that Raster Design options are set as described
in the exercise Exercise A1: Setting ProductNameShort Options (page 5).

1 In the \Tutorial5 folder, open the drawing file Map_06.dwg. In the next
few steps, you will change the background color of the Model space to
black.

2 At the Command line, enter the OPTIONS command to open the Options
dialog box.

3 Click the Display tab.

4 Click the Colors button. The Drawing Window Colors dialog box opens.

5 In the Interface Element list, select Uniform Background.

6 In the Color list, select Black.

7 Click Apply & Close in the Drawing Window Colors dialog box, then
click OK in the Options dialog box.

Convert the grayscale image to bitonal

8 Click Image menu  ➤ Image Processing  ➤ Histogram. Press Enter to
edit the entire image. The Histogram dialog box is displayed.

On the Threshold tab, use the slider to determine which pixels will be
black and which will be white after you convert the image. The shades
of gray to the left of the slider become black, and those to the right
become white.

9 Move the slider to 82, observing the effect on the image in the preview
window.

This exercise uses one image. However, if you select multiple images, you
can select the image name below the preview to observe the effect of the
threshold value on that image. The selected images convert to black and
white when you click Apply and Close.
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10 Click Apply and Close to convert the image.

The following example shows how the image of the soils map should
appear after you convert it to a bitonal (black and white) image. The
image has a light background and dark line work that is difficult to read.
The image also contains large speckles.

Export the image

11 Click Image menu  ➤ Export  ➤ Image.

12 In the Export dialog box, enter Soilsmap_world_03.cal for the filename,
select CALS1 for the file type, and click Export.

13 In the Export Options dialog box, select Maintain Drawing Link to Image
and under Correlation, select World File.

14 Click Finish.

Invert the image

15 Click Image menu  ➤ Cleanup  ➤ Invert.

The following example shows how the image of the soils map should
appear after you invert the light and dark areas of the image. The image
still contains many large speckles.
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Remove speckles from the image

16 Under Insert Options, select the Insertion Dialog option. Also make sure
that Show Frames Only and Zoom To Image(s) boxes are cleared.

17 Click Open to display the Image Correlation dialog box. Select the Source
tab.

You are prompted to continue or to respecify the pixel size.

18 Click the Insertion tab and click OK.

The pixels about to be removed are highlighted. In a real project, this is
when you can zoom in to inspect the image and ensure that essential
data is not highlighted for removal. You can specify pixels to exclude
from the removal set in a variety of ways.

19 Press Enter to remove the highlighted speckles.

The following example shows how the image of the soils map should
appear after you remove the speckles.
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20 Close the drawing without saving changes.

Exercise P7: Inserting USGS Quad Sheets Using
Quick Insert

In this exercise you use the Quick Insert method to insert a color image of a
USGS quad sheet.

The Quick Insert method is one of several options for specifying the insertion
point, rotation, and scale when you insert an image. This method uses the
default correlation (World file, Resource file, Raster Design defaults etc.) to
insert the image, rather than prompting you to specify or modify values.

The Quick Insert method is useful when you want to insert images without
changing any of the correlation values.

Related Help Topics

■ Inserting Images

Related Exercises

Before doing this exercise, ensure that Raster Design options are set as described
in the exercise Exercise A1: Setting ProductNameShort Options (page 5).
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1 In the \Tutorial5 folder, open the drawing file Map_07.dwg.

Choose an image to insert

2 To display the Insert Image dialog box, click Image  ➤ Insert.

3 From the Files of Type list, choose TIFF.

4 If necessary, navigate to the \Tutorial5 folder.

5 Select the image file henniker_01.tif.

6 On the Views menu verify that Preview and Information are checked.
This displays a preview window and a list of information about the image.

7 Review the values shown for each parameter.

Insert the image

8 Under Insert Options select the Quick Insert option. Also verify that Show
Frames Only and Zoom To Image are not selected.

9 Click Open to insert the image.

This image is a GeoTIFF file that contains correlation data. Raster Design
uses these values when it inserts the image.

View the image

10 If the vector line work is not displayed on top of the image, enter REGEN
to restore the display order.

11 Click View menu  ➤ Named Views. Then set the current view to
TU_henniker.
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12 Close the drawing without saving changes.

Exercise P8: Making Part of an Image Transparent
In this exercise you learn about making an image color transparent.

You can specify one transparency color in each image. Then all parts of the
image with that color (or shade of gray) can be made opaque or transparent.
This is useful if you want to see information displayed behind the image. In
bitonal images, the transparency color is always the background color of the
image.

Related Help Topics

■ AutoCAD Properties

Related Exercises

Before doing this exercise, ensure that Raster Design options are set as described
in the exercise Exercise A1: Setting ProductNameShort Options (page 5).

1 In the \Tutorial5 folder, open the drawing file Map_08.dwg.

2 Select the image frame of the USGS quad sheet.

3 Right-click and select Properties to display the Properties window.
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The Properties window contains a long table; use the vertical slider to
scroll up and down. Note that near the bottom are two separate tabs
labeled Misc.

Specify the transparency properties for the image

4 On the upper Misc tab, click Transparency and change the value to Yes.

The transparency properties appear near the end of the properties list
under Misc.

5 On the lower Misc tab, click Transparency Color, then click the pick
button [...] to display the Transparency Color dialog box.

6 Click Select, click anywhere in the white border area of the USGS image,
then click OK.

Note that the white border becomes transparent, along with any white
areas within the map.
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7 Close the Properties window.

8 Close the drawing without saving changes.

Exercise P9: Cropping USGS Images
In this exercise, you use Crop to remove areas of an image.

Crop preserves a selected area of a raster image and removes the rest of the
image. Cropping an image permanently removes raster data outside the area
you select and adjusts the size of the image frame to fit the cropped area.

Other methods of removing raster data have different effects:

■ Remove commands erase raster data from an image without re-sizing the
image. You can also use these commands to remove raster data that is not
along the border of the image.
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■ Mask removes an area from view without deleting that area from the image.
A mask can affect multiple images, and can be converted to an AutoCAD
image clip for each image.

In this lesson, you crop the white border of a USGS quad sheet. This procedure
can be useful if you want to merge the images of adjacent quad sheets.

Related Help Topics

■ Cropping Images

Related Exercises

■ Exercise A4: Saving Images (page 15)

■ Exercise P11: Masking Images of Maps (page 134)
Before doing this exercise, ensure that Raster Design options are set as
described in the exercise Exercise A1: Setting ProductNameShort Options
(page 5).

1 In the \Tutorial5 folder, open the drawing file Map_09.dwg.

Crop the white border from the image

2 Click Image menu  ➤ Crop  ➤ Rectangular Region.

3 Use Endpoint OSNAP to select the upper-left corner of the image for the
first point.

4 Press Enter to accept the default 0 rotation for the crop region.

5 Select the lower-right corner of the map portion of the image for the
second point.

Raster Design automatically resizes the image frame to fit the cropped
image. The raster data that you cropped is removed from the image.
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6 Close the drawing without saving changes.

Exercise P10: Inserting Multiple Images
In this exercise you simultaneously insert two USGS quad sheets into a drawing.

The quad sheets are for adjacent areas and have correlation data that position
the images next to each other when they are inserted.

Related Help Topics

■ Inserting Images

Related Exercises

Before doing this exercise, ensure that Raster Design options are set as described
in the exercise Exercise A1: Setting ProductNameShort Options (page 5).

1 In the \Tutorial5 folder, open the drawing file Map_10.dwg.

Choose multiple images

2 To display the Insert Image dialog box, click Image  ➤ Insert.

3 From the Files of Type list, choose TIFF.

4 If necessary, navigate to the \Tutorial5 folder.
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5 Select the image file henniker_crop.tif, then hold down the Ctrl key and
select hopkinton_crop.tif.

6 On the Views menu verify that Preview and Information are checked.

Because you selected multiple images, a preview is not displayed and the
list of parameters contains no values.

Insert the images using the default correlation values

7 In the Insert Options area, click Quick Insert.

8 Click Open to insert the images.

Raster Design detects the presence of world correlation files for these
images and uses them to insert and position the images.

View the images

9 If necessary, use the REGEN command to restore the display order.

10 Close the drawing without saving changes.

Exercise P11: Masking Images of Maps
In this exercise you use Mask to exclude areas of map images from view without
deleting the raster data.

A mask shows the portions of images inside the mask boundary and hides or
unloads images that are completely outside the mask boundary.
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Unlike cropping and rubbing, masking does not permanently modify images.
You can turn off the mask to redisplay the complete images.

In this lesson, you create a mask for the two images of USGS quad sheets.
These quad sheets were inserted into a drawing of an undeveloped parcel of
land. However, the region shown in the quad sheets is much larger than the
area covered by the parcel. You mask out the areas in the images that are
unrelated to the parcel.

Related Help Topics

■ Changing the Image Mask Properties

Related Exercises

Before doing this exercise, ensure that Raster Design options are set as described
in the exercise Exercise A1: Setting ProductNameShort Options (page 5).

1 In the \Tutorial5 folder, open the drawing file Map_11.dwg.

Select the image mask options

2 To display the New Image Mask dialog box, click Image  ➤ Mask  ➤ 

Create.

3 Specify the following settings for the image mask options:

■ Select Enable Mask.

■ Under Image(s) Outside the Image Mask, select Hide Image(s).

■ Select Show Image Frame(s).

4 Click Rectangular.

5 Draw a rectangle around the undeveloped parcel and the adjacent
development.

Raster Design masks areas of the images that are outside the rectangle.
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Turn the image mask off and on

6 Select the mask boundary, which corresponds to the rectangle that you
drew.

The mask boundary is an AutoCAD object that you can move, stretch,
scale, and erase. Feel free to modify the mask region. Note that if you
move a midpoint along any side, more midpoints are added to the
polygon.

7 Right-click, and click Enable from the shortcut menu to turn off the image
mask.

Raster Design displays the original images, but the mask boundary remains
visible. You can select it and continue to modify the boundary while the
full images are visible.
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8 Select the mask boundary, right-click, and click Enable to turn the image
mask back on.

The areas outside the mask boundary are hidden.

9 Close the drawing without saving changes.

Exercise P12: Converting Color Images to Bitonal
Images

In this exercise you convert color images to bitonal (black and white) images.

You convert a color image of a USGS quad sheet to a bitonal image, preparing
to trace the contours with Raster Design Vectorization Tools.

Related Help Topics

■ Converting a Grayscale or Color Image to Bitonal

■ Reversing the Light and Dark Shades in an Image

Related Exercises

■ Exercise S3: Cleaning Up Images with Invert and Mirror (page 22)

■ Vectorization Tutorial (page 183)
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Before doing this exercise, ensure that Raster Design options are set as described
in the exercise Exercise A1: Setting ProductNameShort Options (page 5).

1 In the \Tutorial5 folder, open the drawing file Map_12.dwg.

Convert the image to bitonal

2 Isolate the TU_image_usgs layer. To do this, select this layer in the Layer
Properties Manager, right click and click Select All But Current, then
freeze all the selected layers, and click OK.

3 Click Image menu  ➤ Image Processing  ➤ Histogram. Press Enter for
entire image. The Histogram dialog box is displayed.

4 Click the Threshold tab.

Use the Threshold slider to determine which pixels will be black and
which will be white after you convert the image.

5 Move the slider as close as you can to 171, observing the effect on the
image in the preview window.

This exercise uses one image. However, if you select multiple images, you
can select the image name below the preview to observe the effect of the
threshold value on that image. The selected images convert to black and
white when you click Apply and Close.

6 Click Apply and Close to convert the image.

Save the image

7 Click Image menu  ➤ Save As.

8 Enter usgs.cal for the filename, select CALS1 for the file type, and click
Save.

Invert the image

9 Click Image menu  ➤ Cleanup  ➤ Invert.
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After you convert an image (and invert it, if necessary), you typically use
the editing filters, such as Despeckle and the bitonal filters, to eliminate
raster data that could interfere with tracing the contours.

10 Close the drawing without saving changes.

Exercise P13: Displaying a Digital Elevation Model
In this exercise you display data from a digital elevation model (DEM).

DEM files make use of a palette color map, which is very versatile. This type
of color map uses a palette of colors in which each color represents a range
of values. The values can be surface elevation, slope, or aspect (slope direction).
Each color can represent an equal range of values, or the ranges can be
calculated using a formula for quantile or standard deviation distribution.

A quantile distribution assigns an equal number of values to each range (color),
and adjusts the range spread accordingly. If your land surface has a majority
of data values clustered around a subset of the full range, the individual ranges
for that subset will be narrower to show that area in greater detail.

A standard deviation distribution sets the spread of each range equal to one
standard deviation for the full set of data values in the file. The center six
ranges of the palette cover the spread of values in the file. If the image has a
set of values that approximate a normal distribution, the third and fourth
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ranges together represent about 68% of the full range. The dividing line
between these two center ranges is the arithmetic mean value of the data set.

While palette color maps are complex, they can also be saved for ease of reuse
with other files, including DEM and 16-bit integer formats.

In this exercise you will import an existing palette, located in the folder
\Tutorials\Tutorial5.

The palette color map includes additional controls not covered in this exercise.
For more information, see Palette Color Map Definition Dialog Box.

Related Help Topics

■ Inserting Images

■ Assigning a Color Map to an Image

■ Changing the Color Map of an Image

Related Exercises

■ Exercise A2: Managing Images in a Drawing (page 7)

Before doing this exercise, you should ensure that Raster Design options are
set as described in the exercise Exercise A1: Setting ProductNameShort Options
(page 5).

1 Open a new drawing or use the default Drawing1.dwg.

Insert a DEM image

2 Click Image menu  ➤ Insert.

3 In the Insert Image Dialog Box, select
\Tutorial5\Manchester_North_map.dem.

4 In the Insert Options area, click Insertion Wizard, then click Open.

5 On the Assign Color Map tab, click Next, click Next on the other tabs,
then click Finish on the Insertion tab.

The DEM image is inserted in the drawing, using the default palette color
map.

6 If the Image Manager Toolspace is not open, to open it, click Image menu
 ➤ Manage.
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7 If the image is not clearly visible, then in the Image Manager toolspace,
Image Insertions view, right-click the image insertion name
(Manchester_North_map) and select Zoom To.

This view of the land surface shows elevations in shades of gray.

In the next few steps we will examine the information contained in this
color map and explore some other views of the same data file.
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Edit the color map

8 In the Image Manager toolspace, Image Insertions view, right-click the
image insertion name and select Edit Color Map.

9 On the Palette Assignment Color Map Dialog Box, click  to create a
new color map.

10 In the Palette Color Map Definition Dialog Box, examine the Range Table
to understand the current map display.

By using the scroll bar on the far right of the dialog box, you can see that
the palette has 256 color ranges defined. The Range Spread column shows
that each color represents an elevation range of about 2.4 feet. The Range
Upper Value column shows you that the elevations in the image range
from 732 feet down to 126 feet (128.3765 minus 2.3765).

NOTE You can verify the elevation units and range for this image on the
Image Data view of Image Manager: click Elevation, then click the image
data band (FLT:32-bit) to see its properties.

The Data Interpretation setting (on the left side of the Palette Color Map
Definition dialog box) shows you that the image displays Value rather
than surface height, slope, or aspect (slope direction). The Value
Distribution setting shows you that the palette colors represent equal
ranges that are calculated mathematically (parametric) rather than set
manually.

11 Change the Data Interpretation setting to Height (US survey feet). This
setting reflects the actual values in the image data, so the range values
do not change.

Further exploration: Change the Data Interpretation setting to Height
(meters), and you immediately see the values in the Range Table converted
to meters. Select other Data Interpretation options, and in each case, the
range values change to show the new interpretation.

In the next few steps we will create a new color map that uses a smaller
number of data ranges.

12 In the Palette area of the Palette Color Map Definition dialog box, click
Import.

13 In the Import Palette Dialog Box, browse to \Tutorials\Tutorial5.

14 Select the palette file USGS National Map.pf and click Open. The palette
is brought into the Palette Color Map Definition dialog box.
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The Range Table automatically adjusts to the new palette, so the elevation
range is spread equally across 22 colors.

15 In the Color Map Name field in the upper left of the dialog box, enter
the name USGS-E Color Map, then click OK to save the color map.

16 In the Palette Assignment Color Map dialog box, click Apply. The new
color map is applied to the display.
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In the next few steps we will change the color map to use a quantile
distribution of ranges.

Create a quantile color map

17 In the Palette Assignment Color Map dialog box, click  to create a
new color map.

18 In the Palette Color Map Definition dialog box, in the Value Distribution
area, click the menu and select Quantile.

The Range Table automatically adjusts to the elevation data, allocating
an equal number of data points to each range. As a result, the elevation
spread for each range is variable. Around elevations of 300–325 feet and
415–440 feet, we see narrow ranges, indicating a relatively large number
of readings in these ranges. Around 575–732 feet, the ranges are wide,
indicating fewer instances of these elevations.

19 In the Color Map Name field in the upper left of the dialog box, enter
the name USGS-Q Color Map, then click OK to save the color map.

20 In the Palette Assignment Color Map dialog box, click Apply. The new
color map is applied to the display.

21 In the Color Map Name area of this dialog box, select USGS-E Color Map
and click Apply to revert to the first color map you created.

The controls in this dialog box allow you to easily compare the effects
of different color maps.

Create a hillshading color map

22 In the Palette Assignment Color Map dialog box, click  to create a
new color map.

23 In the Palette Color Map Definition dialog box, in the Range Table area,
select the entire range as follows:

■ In the Index column, click 0 to select the bottom row

■ Use the scroll bar on the right to scroll to the top row

■ Hold down the Shift key and click index

24 Right-click within the range table and select Assign Color.

25 In the Select Color dialog box, on the True Color tab, ensure that the
Color Model setting is HSL.
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26 In the Color field in the lower left, enter 150,150,150, or use the vertical
Luminance slider to select a similar light gray tone.

27 Click OK to return to the Palette Color Map Definition dialog box.

In the Range Table, note that all of the ranges are set to the gray tone
you selected.

28 In the Display Enhancements area, select Hillshade, then set the Vertical
Exaggeration factor to 5.

29 In the Color Map Name field in the upper left of the dialog box, enter
the name Gray-5 Color Map, then click OK to save the color map.

30 In the Palette Assignment Color Map dialog box, click Apply.

This color map exaggerates the topographic relief of the surface and
simulates a light source in the upper left to cast shadows on the terrain.

Further exploration: Return to the Palette Color Map Definition dialog
box and create more color maps that

■ use Standard Deviation value distribution (import palette Std-Dev-6.pf
for this one)

■ display surface slope

■ display surface aspect

TIP If you want to discard all unused palette color maps from your drawing,
enter ipurgecm on the command line.

31 Save or discard your drawing, as you prefer.

Exercise P14: Displaying Multispectral Imagery
In this exercise you combine several image bands from a multispectral dataset
into a single displayed image.

While each band of a multispectral data set can be displayed individually as
a grayscale image, the real analytic value of this data type is revealed when
you assign two or three bands to different color channels and display them
as a “false color” image.

In this exercise, you will use color map controls to display a set of seven image
bands in different ways.
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Related Help Topics

■ Inserting Images

■ Assigning a Color Map to an Image

■ Changing the Color Map of an Image

Related Exercises

■ Exercise A2: Managing Images in a Drawing (page 7)

■ LiveView Exercise: Editing Color Maps in Getting Started, “Task-Specific
Concepts”

1 In the \Tutorial5 folder, open the drawing file Multispec_CA.dwg.

This drawing contains a multispectral set of seven satellite images, and
the color map is set to display a standard false color image.

2 If the Image Manager toolspace is not open, click Image  ➤ Manage.

Use a standard false color map

3 In Image Manager, expand the object tree under the drawing name so
you can see the color map (R:B40 G:B30 B:B20), which is configured as
follows:

■ Red channel – B40 (Visible Near Infrared)

■ Green channel – B30 (Red)

■ Blue channel – B20 (Green)

This color map produces an image in which different types of vegetation
and water are easier to see, so it is useful for analyzing water depths and
land cover. In the next few steps we will look at two examples.

4 Click View menu  ➤ Named Views. Then set the current view to Trees.

In this view, coniferous forest cover is dark red, and deciduous forest
cover is lighter red.
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5 Click View menu  ➤ Named Views. Then set the current view to Water.

In this view, clear water is dark blue, and shallow or sedimented water is
light blue. The underwater channels and shelves are clearly visible.

6 Click View menu  ➤ Named Views. Then set the current view to
Vegetation.

Create a natural color map

7 In Image Manager, right-click the image color map, click Edit Color Map,
and assign the color channels to image bands as follows:

■ Red channel – B30 (Red)

■ Green channel – B20 (Green)

■ Blue channel – B10 (Blue)
This color map shows the terrain in colors close to its natural
appearance. The gray urban area in the upper right is bordered by
light brown hills with green forest cover. By changing color maps, we
can see the features of this region in greater detail.

Create a color map for analysis of land cover
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8 In Image Manager, right-click the image color map, click Edit Color Map,
and assign the color channels to image bands as follows:

■ Red channel – B40 (Visible Near Infrared)

■ Green channel – B50 (Mid Infrared)

■ Blue channel – B30 (Red)
Band 5 (B50) is very sensitive to variations in moisture content of
plants and ground surface. As a result, this color map shows varying
amounts of green coloration for different types of land cover.

In this view, trees are reddish brown, but drier vegetation has more
green tones, so it appears orange or green. Natural grasslands in this
photo are dry and sparsely covered, so they appear light greenish blue.
Bare soil and urban areas appear blue and gray.

Create a color map for analysis of rock and soil

9 In Image Manager, right-click the image color map, click Edit Color Map,
and assign the color channels to image bands as follows:

■ Red channel – B70 (Far Infrared)

■ Green channel – B40 (Visible Near Infrared)
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■ Blue channel – B20 (Green)
Band 7 in this color map displays the moisture content of rocks and
soils as shades of red, with darker red indicating more moisture.
Because band 4 is assigned to the green channel, vegetation appears
in different shades of green.

10 Close your drawing without saving changes.
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Tonal Adjustment Tutorial

This tutorial shows you several ways to improve images by adjusting tone with histograms
and contrast curves.

Tonal adjustment in Raster Design uses a contrast curve to change image brightness and
contrast. Unlike the simpler Brightness and Contrast controls, the contrast curve can adjust
ranges of tones in an image independently of others. For example, dark shadowed areas can
be brightened without significantly affecting the brighter parts of the image. Curve definitions
can be exported and imported so the same curve can be applied to other images or other parts
of the same image.

The exercises in this tutorial use an aerial photo. Part of the photo appears washed out, possibly
due to cloud cover or ground fog when the photo was taken. You can use tonal adjustment
to enhance the photo, making it appear more uniform. The tutorial includes the following
activities:

■ Open the drawing and insert the pre-correlated image.

■ See how the histogram looks for a “normal” part of the image.

■ Select a problem area and create a piecewise linear contrast curve to correct it.

■ Select a roadway segment in the image to make it appear more uniform.

■ Switch to a fitted curve and adjust the tone. Export the curve.

■ Apply the curve to this and other roadway segments.

■ See the overall results of your tonal enhancement.

Exercise T1: Using the Histogram
In this exercise, you learn some basic controls for the Histogram to assist in
tonal adjustments.
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Tonal adjustment is one of several features that use the Histogram. The
Histogram is especially useful in identifying and correcting tonal problems
with images. The preview window shows the effects of making adjustments
and may be used in conjunction with or instead of the histogram.

Related Help Topics

■ Adjusting Images with the Histogram

Related Exercises

■ Exercise P4: Enhancing Grayscale Images (page 119)

Before doing this exercise, ensure that Raster Design options are set as described
in the exercise Exercise A1: Setting ProductNameShort Options (page 5).

1 In the \Tutorial8 folder, open the drawing file TonalAdjustment01.dwg.

2 View the vector line work in the drawing. The red lines represent the
footprints of existing buildings in the project. The yellow outline is the
building proposed for the project and is the reason the aerial photography
is being introduced. Light gray lines represent the edge of pavement,
cyan lines are boundaries of concrete walks, and green lines are parking
areas.

Choose an image to insert

3 To display the Insert Image dialog box, click Image  ➤ Insert.

4 From the Files of Type list, choose All Image Files.

5 If necessary, navigate to the \Tutorial8 folder.

6 Select the image file SiteAerial01.tif.

Insert the image using Quick Insert

7 In the Insert Options area, select Quick Insert. Ensure that Show Frames
Only and Zoom to Image are not selected.

8 Click Open to insert the image.

The image was pre-correlated and is properly scaled for the project.

If necessary, use REGEN to ensure the vector information is displayed on
top of the image.

Note the extreme difference in shading between the lower right and upper
left portions of the project. Leaving it this way would detract from the
project presentation, and obtaining replacement photographs may be
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cost prohibitive. Our goal is to use Tonal Adjustment to make the tone
as consistent as possible over the entire photo.

Compare histograms for the two areas

9 Click Image menu  ➤ Image Processing  ➤ Histogram. Enter e (Existing)
to indicate that you will use an existing closed vector entity to define a
sub-region for analysis.

10 Pick a point on the edge of pavement (light gray) line that completely
surrounds the buildings in the upper left. The histogram will evaluate
the image tone in this region.
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11 In the Histogram dialog box, click the Tonal Adjustment tab. Note the
appearance of the histogram for this area of the image.

The histogram graphically shows the number of pixels in the area that
have each level of gray. In this case, we see a high frequency of midrange
values, and a few at the right end that are very close to white. There are
not too many pixels in this area that are very light (washed out) or very
dark (shadowy). The visual appearance of this area is reasonably good.

12 Click Cancel to close the Histogram dialog box, making a mental note
of its general appearance.

13 Click Image menu  ➤ Image Processing  ➤ Histogram. Enter e (Existing).

14 Pick a point on the edge of pavement (light gray) line in the lower right
area to define another region for analysis.

The following example shows where to select the point at the edge of
the pavement.
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15 In the Histogram dialog box, select the Tonal Adjustment tab.

Note that the histogram is skewed, showing a high frequency of light
gray and white. In the next exercise, we will modify the tonal balance in
this part of the image, making it look as similar to the upper left section
as possible. This means we need to make adjustments that effectively
slide these high frequency values toward the left middle values. Note the
secondary peak on the right which is more pronounced than the one
contained on the upper left portion histogram. This peak represents the
lighter colors of the building fronts which show more in the lower right
portion of the project. We should perform the adjustment so that the
peak is preserved, although it may be modified in appearance.

16 Click Cancel to close the Histogram dialog box.

17 Close the drawing without saving changes.
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Exercise T2: Using a Contrast Curve for Tonal
Adjustment

In this exercise, you create and modify a contrast curve using control points.

With the piecewise linear contrast curve, you can place up to 64 control points
through which the curve is automatically drawn. You make the image
adjustments by dragging the control points to change the shape of the curve.
The curve is constrained so that for each possible input value in the selected
area, only one new output value is established. With this form of tonal
adjustment any image can be made more useful.

Related Help Topics

■ Making Tonal Adjustments to an Image

Related Exercises

■ Exercise P4: Enhancing Grayscale Images (page 119)

■ Exercise T1: Using the Histogram (page 151)

■ Exercise T3: Using the Fitted Contrast Curve (page 162)

Before doing this exercise, ensure that Raster Design options are set as described
in the exercise Exercise A1: Setting ProductNameShort Options (page 5).

1 In the\Tutorial8 folder, open the drawing file TonalAdjustment02.dwg.
If necessary, enter REGEN to see the vector data on top of the image.

Start tonal adjustment

2 Click Image menu  ➤ Image Processing  ➤ Histogram. Enter e (Existing)
to indicate that you will use an existing closed vector entity to define a
sub-region for analysis.

3 Pick a point on the edge of pavement (light gray) line for the lower right
area.
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NOTE In a real project, if you did not have an existing closed vector entity
around the region where you want to adjust tone, you could create a polygon
especially for this purpose.

4 In the Histogram dialog box, click the Tonal Adjustment tab.

5 In the Select Curve Type box, select Piecewise Linear.

The straight line in the contrast window indicates the initial linear
relationship between input tonal values from the image across the bottom
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(black on the left, white on the right) and their corresponding display
values on the vertical (black at the bottom, white at the top). Because of
this relationship, moving the line up and down uniformly tends to change
the brightness of all the values. Similarly, changing the slope of the line
tends to change the contrast for all the values. But if we make the graph
non-linear and manipulate several control points, we can change the
output brightness and contrast for different ranges of input tones in the
image.

6 Place your cursor over the control point in the middle of the line. Note
that the cursor turns into a move cursor. When you click and drag it, a
tooltip reports its current position. By dragging the point diagonally
between upper left and lower right corners you can see the effect on the
histogram of manipulating the resulting nonlinear curve.
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Moving the control point to the upper left makes the gray tones much
whiter; moving it to the lower right makes them much darker.

7 Move the control point to a spot near 225,150, stretching the histogram
to the left and separating the peaks. The left segment of the curve is
mostly lowering the brightness and increasing the contrast for the roof
and landscaping tones; the right segment is mostly lowering the contrast
for the lighter tones. In the histogram we see this in the left peak (roof
& landscaping tones) as a move to the left which is decreasing brightness
and some compression of the peak which is decreasing contrast. For the
right peak (representing the building facade and walkway tones) we see
a stretching effect which is increasing contrast and some movement to
the left which is decreasing brightness.
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8 To regain the original contrast in the roof and landscaping tones, put
the slope for that section back to a 45-degree angle by adjusting the left
(black) triangular slider at the bottom of the Contrast window. Move the
black slider in until the black cutoff is at about 84. The fact that the curve
is horizontal at 0 output value between input values of 0 and 80 is
immaterial, as there are few or no pixels within that range in the original
lower right area of the project.
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The curve is now quite nonlinear, applying different correction factors
to different tonal values in the area. The original idea was to make the
histogram curve look more like the one in the upper left area of the
project. Compare the current result for the upper left area with the one
for the lower right area.

The main histogram peak from the lower right area, while different in
shape than the peak from the upper left area, occupies the same basic
range of output values. The higher prevalence of elements to the right
of the main peak in the lower right area histogram is because more
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building sides and concrete work (both of which are fairly light) show in
that part of the project.

9 Save the curve for future use by exporting it to an external file. In the
Histogram dialog box, click Export to display the Export dialog box. Set
the directory to \Tutorial8. Enter Tutorial02 for the filename and leave
Gamma Point List (*.gpl) as the file type. Click Export.

10 In the Histogram dialog box, in the Apply Changes To area, click
Sub-region.

11 Click Apply to update the lower right part of the project image. Click
Close to exit the dialog box. The end result is an image where both upper
left part and the lower right part are similar in tone.

The only areas that still need correction are some parts of the roadway.
This is addressed in the next exercise, Exercise T3: Using the Fitted
Contrast Curve (page 162).

12 Close the drawing without saving changes.

Exercise T3: Using the Fitted Contrast Curve
In this exercise, you learn how to create a fitted contrast curve and apply it
to different parts of an image.

162 | Chapter 7   Tonal Adjustment Tutorial



The fitted contrast curve provides detailed control over tonal adjustment. You
can place up to 16 control points through which a smooth curve is
automatically drawn. You can adjust the image by moving, adding, or deleting
control points. The curve is constrained so that for each possible input value
in the selected area, only one new output value is established.

Related Help Topics

■ Making Tonal Adjustments to an Image

Related Exercises

■ Exercise P4: Enhancing Grayscale Images (page 119)

■ Exercise T2: Using a Contrast Curve for Tonal Adjustment (page 156)

Before doing this exercise, ensure that Raster Design options are set as described
in the exercise Exercise A1: Setting ProductNameShort Options (page 5).

1 In the \Tutorial8 folder, open the drawing file TonalAdjustment03.dwg.
The drawing automatically inserts the image properly correlated. If
necessary, enter REGEN to see the vector data on top of the image.

Start tonal adjustment

2 Click Image menu  ➤ Image Processing  ➤ Histogram. Enter e (Existing)
to indicate that you will use an existing closed vector entity to define a
sub-region for analysis.

3 The streets in the project are outlined in green. Pick on the green street
outline for Highland Way.
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4 In the Histogram dialog box, click the Tonal Adjustment tab.

5 In the Select Curve Type box, select Fitted.

The straight line in the contrast window indicates the initial linear
relationship between input tonal values from the image across the bottom
(black on the left, white on the right) and their corresponding display
values on the vertical (black at the bottom, white at the top). Because of
this relationship, moving the line up and down uniformly tends to change
the brightness of all the values. Similarly, changing the slope of the line
tends to change the contrast for all the values. But if we make the graph
non-linear and manipulate several control points, we can change the
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output brightness and contrast for different ranges of input tones in the
image.

Our goal is to even out the tones contained in the roadway. We can refer
to the preview display while making adjustments. We want to make the
curve flatter over the values of interest in order to decrease the contrast
between lighter and darker values. This is best accomplished by adding
another control point to the right of the middle one.

6 Click in the curve window above the existing middle control point,
between the graphed line and the right side of the window.

The roadway still shows too much contrast along its length. We need to
make the curve flatter for the higher whiter values.

7 Move the right control point up to a spot near 245,210. The double
inflection in the curve is not a critical factor for this type of enhancement.
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Export the curve to use in other road sections

8 Click Export to display the Export dialog box. Set the directory to
\Tutorial8. Enter Tutorial03 for the filename and leave Gamma Point
List (*.gpl) as the file type. Click Export.

9 Click Apply to update the imagery for Highland Way. Click Close.

10 Enter REGEN.

166 | Chapter 7   Tonal Adjustment Tutorial



Apply the curve to Wildwood Lane

11 Click Image menu  ➤ Image Processing  ➤ Histogram. Enter e (Existing).

12 Select Wildwood Lane as the connected entity in which to apply the
tonal adjustment.
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13 In the Histogram dialog box, click the Tonal Adjustment tab, and ensure
that the curve type is set to Fitted.

14 Click Import. Set the directory to Tutorial8 and select the file
Tutorial03.gpl. You should see the same curve we used for Highland Way.
Click Apply and then Close. The two streets Highland Way and Wildwood
Lane should appear very similar in tone in the resulting image.

Apply the curve to Prospect Street

15 Click Image menu  ➤ Image Processing  ➤ Histogram. Enter e (Existing).

16 Select Prospect Street as the connected entity in which to apply the tonal
adjustment.
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17

18 In the Histogram dialog box, click the Tonal Adjustment tab, and ensure
that the curve type is set to Fitted.

19 Click Import. Set the directory to Tutorial8 and select the file
Tutorial03.gpl. You should see the same curve we used for Highland Way
and Wildwood Lane. Click Apply and then Close. All the streets and
indeed the whole project should now appear with proper image tone.
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20 Close the drawing without saving changes.
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Palette Manager Tutorial

This tutorial shows you how to use the Palette Manager to alter the visual appearance of
images. When you complete this tutorial you should be able to:

■ Change colors in the image to new colors for better effect or to hide undesirable features.

■ Combine colors in a map to isolate features of interest.

■ Convert a grayscale image to color and add special effects for presentation purposes.

■ Assign a transparency color to an image.

■ Combine colors in an image to improve its appearance.

■ Compress the image palette to eliminate unused palette entries.

The Palette Manager works with grayscale and palette color images of 8-bit format (256 colors).
The image palette is shown graphically in the dialog box and can be sorted in different ways,
making it easier to work with. You can combine or change individual colors. Change operations
modify only the palette itself whereas Combine operations operate on the actual image data.
The Compress operation eliminates unused colors and cleans up the palette. Compressing an
image palette typically modifies both the palette as well as the image data.

This tutorial consists of three exercises. Each one uses a different image type and covers typical
palette operations for that image type:

■ Scanned USGS map. Modify a map from the United States Geological Survey using palette
controls to hide a feature by changing its color to match the background. Combine features
by changing them to a single color. Isolate a feature by changing the color of everything
else to match the background.

■ Grayscale aerial photo. Modify a photo for presentation purposes, using an external palette
in order to emphasize specific areas within the project boundary.

■ Color satellite image. Assign a transparency color, combine several colors to consolidate
the display of a feature, and compress the palette to eliminate unused entries.
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Exercise M1: Modifying a Scanned USGS Map
In this exercise you learn how to modify the colors in an existing scanned
USGS map.

First, you remove the green vegetation feature from the map in order to make
the map more printer friendly and to allow other features to show more clearly.
You can accomplish this by changing the green color in the map to the white
background color. Next, you change the purple revisions to black in order to
have them blend in with the rest of the map. Apply the same principle to
highlight features in the map by changing them to a contrasting color. Finally,
you isolate the contours by changing all other colors to the white background
color.

This prepares the map for a contour-following operation.

Related Help Topics

■ Manipulating the Color Table

Related Exercises

■ Setting Vectorization Tools Options

Before doing this exercise, you should ensure that Raster Design options are
set as described in the exercise Exercise A1: Setting ProductNameShort Options
(page 5).

1 In the \Tutorial7 folder, open the drawing file Palette Manager01.dwg.
The USGS topographic map image inserts with the drawing.

Eliminate vegetation features from the map

2 To display the Palette Manager dialog box, click Image  ➤ Image
Processing  ➤ Palette Manager.

Change green features to white

3 Click the green button in the color table, (Index 1). The color and index
are highlighted in the list view.
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4 When you select a color button, the Change button is available. Click
Change to display the Target Color dialog box. The Target Color dialog
box defaults to the last color picked, which in this exercise is green.

5 Click the white button in the color table (Index 0). White is the
background color of the map and by changing the green portion to white,
the green is eliminated. Notice that details of the current selection are
shown in the status bar just below the color buttons.

6 Click OK to return to the Palette Manager dialog box. The green button
has changed to white, reflecting the change you just made.

7 If necessary, move the Palette Manager dialog box aside to see the green
area of the map, then click Apply. The green vegetation feature is removed
from the map.

Consolidate revisions by combining colors

Next, you change the purple map revisions to black in order to give the
image a more uniform appearance. The purple revisions represent two
different shades so it is possible to use either Change or Combine to
consolidate them. In this part of the exercise you use Combine, which
changes the index values in the image file.

8 Click light purple (index 3), then press the Ctrl key and click dark purple
(index 7).
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9 When you select more than one color, the Combine button becomes
available. Click Combine. In the Target Color dialog box, click black
(index 4).

10 Click OK on the Target Color dialog box, then click OK on the Palette
Manager dialog box. The revision features that were purple are now black.

Isolate the contour information

One common use for scanned USGS topographical maps is to extract the
contour information to vector so it can be used for terrain modeling.
Using the Palette Manager, we can isolate the brown contour lines by
changing the color of all other features to the background color. Once
this is accomplished, we can convert the image to bitonal and use the
VContour tool to convert the raster contours to vector.

One common use for scanned USGS topographical maps is to extract the
contour information to vector so it can be used for terrain modeling.
Using the Palette Manager, we can isolate the brown contour lines by
changing the color of all other features to the background color.

11 To open the Palette Manager dialog box, click Image  ➤ Image Processing
 ➤ Palette Manager.

12 Select the two shades of brown (indices 8 & 9) to start the isolation
process. Since they are right next to each other you can window them
for selection.
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13 With the cursor within the color table, right-click and click Invert
Selection. All the color buttons with the exception of the two brown
buttons are selected.

14 Click Combine to display the Target Color dialog box. Click the white
button (index 0) for the target color and click OK.

15 Click OK in the Palette Manager dialog box. The result is an image that
shows only contours.

16 After inspecting the results, close the drawing without saving changes.

Exercise M2: Preparing an Image for Presentation
In this exercise, you use the Palette Manager to produce special effects on an
image by applying an external palette.

You use the Raster Entity Manipulation (REM) feature to isolate the project
extents from the original image. Then you create a new image from this REM
region, apply a colored palette, and overlay the new image on top of the
background. The effect you obtain can produce eye-catching graphics for
presentations.

Related Help Topics

■ Controlling Palette Views

■ Defining REM Region Objects

Related Exercises

■ Exercise H4: Removing Raster Entities (page 88)

Before doing this exercise, ensure that Raster Design options are set as described
in the exercise Exercise A1: Setting ProductNameShort Options (page 5).
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1 In the \Tutorial7 folder, open the drawing file Palette Manager02.dwg.
An aerial photo inserts with the drawing.

Extract project area using raster entity manipulation

You use the REM function to isolate the area within the project boundary,
then use the Palette Manager to tone the rest of the image which serves
as the background.

2 Click Image menu  ➤ Raster Entity Manipulation  ➤ Create Region  ➤ 

From Existing Vector.

3 At the command line you are prompted to select a closed vector object.
Select the magenta boundary of the project.

Picking this boundary creates the REM object. The boundary color changes
to red to signify that it is a REM object.

4 Select the REM object, right-click and click Convert to Raster Image.

The new image is given a default name of “Cingular Tutorial_1”, and it
appears in Image Manager.

Tone the background image using Palette Manager

5 Click Image menu  ➤ Image Processing  ➤ Palette Manager. In the
drawing select the frame of the large, main image (not the one just created
using REM).
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In the Palette Manager dialog box, you see some image data, but other
values are blank.

6 Click the Convert to Color button. This action creates a complete grayscale
palette as a basis for changes.

7 Click Palette menu ➤ Import. The Import Palette dialog box is displayed.

The Import Palette dialog box may point by default to the support
directory that contains several predefined palette files (.pf), including
Blue.pf. If you need to navigate to this file, it is in the Raster Design root
directory\UserDataCache\Support.

8 Select the Blue.pf file. At the bottom of the dialog box, click the Substitute
option for importing palette files. The option replaces the gray levels in
the original image, index by index, with the corresponding blue levels.

Import the palette

9 In the Import Palette dialog box click Open to apply the palette. The
Palette Manager dialog box is displayed and the results of the palette
substitution are automatically applied to the image. Click OK to close
the Palette Manager dialog box.

The project area is highlighted in gray tones, while the surrounding spatial
data is muted by the blue tones.

Change the display order

Since the project image is obscuring some of the vector data, it needs to
be moved back in the display. The easiest way to do this is to move both
images to the back so they retain their relative positions with the project
image over the background image.
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10 Select both images by pressing Shift+Left-click inside the gray project
image. Both images are highlighted in the Image Select dialog box. Click
OK.

11 Right-click and click Image ➤ Send to Back. The vector data now shows
over both images.

12 After inspecting the results, close the drawing without saving changes or
saving any images.

Exercise M3: Working with Satellite Images
In this exercise you use the Palette Manager to create a transparency color and
combine color usage in an image.

You can use the Palette Manager to customize existing images, either
commercial data or existing files, to fit your need. The number of colors used,
color assignments, and transparency can all be modified. In this exercise, you
look at the color usage in an image, create a transparency color, and combine
colors selected from the image to improve its appearance. Then you compress
the palette to eliminate unused colors and reorganize the palette.

Related Help Topics

■ Controlling Palette Views
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Related Exercises

Before doing this exercise, ensure that Raster Design options are set as described
in the exercise Exercise A1: Setting ProductNameShort Options (page 5).

1 In the \Tutorial7 folder, open the drawing file Palette Manager03.dwg.

A color satellite image inserts with the drawing.

Analyze the image palette

Using the Palette Manager you can see detailed information about the
image and the colors it uses.

2 Click Image menu  ➤ Image Processing  ➤ Palette Manager.

3 In the Palette Manager dialog box, click Palette menu ➤ Information.
The Palette Information dialog box shows that only 90 of the possible
256 colors are being used and that transparency is not activated for this
image. Click OK.

4 Click View menu ➤ Show Unused. The unused colors in the palette are
marked with an X through them.

5 Click the View menu again. Note that Show Transparency is unavailable,
indicating that a transparency color has not yet been defined.

Assign a transparency color

The transparency color is used as a background for future Remove or
Deskew operations. Black is a logical choice for the transparency color,
but before selecting it, you should check to see if it is already used in the
image. If it is used, you typically do not select it as the transparency color,
to avoid the appearance of holes in the image when transparency is turned
on.
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6 In the Sort By list, select Luminance. The palette display reorders with
the darker colors at the end.

7 Place the cursor over the last (darkest) button in the color table, with an
Index of 0. In the status bar , the Frequency is 0, indicating that this color
is not used in the image.

The color at Index 0 seems to be a good choice for the transparency color
but you should verify that there is not another index in the image that
uses this color.

8 Click the Index 0 button in the color table. Scroll to the bottom of the
list window. The Index 0 line is highlighted and none of the other dark
colors in the list exactly match the RGB and Frequency values. This
indicates that black is a “safe” color to use as the transparency color.

NOTE Even if there were other indices using the color black, it could still be
used as a transparency color as long as all the instances were unused.

9 Click Set Transparency. The display updates to show this as the assigned
transparency color.
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10 In the Sort By list, select Index to re-sort the colors to Index order.

11 Click Apply.

Consolidate colors in the image

When you look at the image, you see the water regions are made up of
several different colors. It would be more useful for our purpose if the
water was represented by a single color. You can use the Combine
operation to consolidate these colors.

12 Click Select Color. The Palette Manager dialog box closes temporarily so
you can pick color(s) from the image.

13 At the command line, enter w for the Window option. Select a window
that encompasses all the colors (there are about 6) that make up the water
region.

After you make the selection, the Palette Manager dialog box redisplays
and the selected colors show in the palette.

14 Click Combine. The Target Color dialog box is displayed. Choose a
medium shade of blue as the target color for consolidation, then click
OK.

The colors are combined in the image. Depending on your choice of
color, some or all of the original colors for water become unused colors
in the palette.

15 Click Apply to update the image and see the results of the consolidation.

Compress the palette

From the palette display, you can see a large number of unused colors.
By compressing the palette, you eliminate unused colors. Compress also
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changes the indices in the image so the used colors are grouped together
at the top of the palette.

16 Click Compress to eliminate the unused colors in the image.

17 Click OK to update the image and close the Palette Manager dialog box.

18 After inspecting your results, close the drawing without saving changes
to either the drawing or to the image.
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Vectorization Tutorial

This tutorial shows you how to use Raster Design to convert raster data into standard AutoCAD
vector entities. The following types of vector objects are created in these exercises:

■ Lines

■ Circles

■ Multiline text

■ Single Line text

■ 2D polylines

■ 2D polylines with elevation (contours)

■ 3D polylines

You also learn how to use Raster Design options and separation tables to control how the
vector objects are drawn and basic layer management.

NOTE Only bitonal images can be used for raster conversion. If you are using grayscale
or color images, please refer to Exercise P6: Converting Grayscale Images to Bitonal
Images (page 123) or Exercise P12: Converting Color Images to Bitonal Images (page 137).

Exercise V1: Setting Options and Creating Basic
Vector Objects

In this exercise you learn how to set options for vectorization tools and convert
basic raster geometry into vector entities.

The Vectorization Tools settings are contained in three of the tabs on the Raster
Design Options dialog box: Raster Entity Detection, VTools General, and VTools
Follower.

9
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The basic elements of any drawing include lines, arcs, circles, rectangles, and
polylines.

Related Help Topics

■ Setting the Options

■ Vectorizing Raster Geometry

Related Exercises

■ Basic Tasks Tutorial (page 5)

Before doing this exercise, ensure that Raster Design options are set as described
in the exercise Exercise A1: Setting ProductNameShort Options (page 5).

1 In the \Tutorial6 folder, open the drawing file VTools_02.dwg.

Access the Raster Design Options Dialog Box

2 To display the Raster Design Options dialog box, click Image  ➤ Options.

3 On the Raster Entity Detection tab, set the Max Jump Length option to
20.

This setting specifies the maximum length of a gap that Raster Design
will tolerate when following a raster polyline. It can be used to jump over
labels embedded in the line or to follow non-continuous lines such as
dashed lines.

4 On the VTools General tab, ensure that the Removal Method is set to
REM.

This option erases the underlying raster while preserving intersecting
raster data. To completely remove all raster data underneath the new
entity, you would use the Rub option.

5 Click the Round Values option, click Specified Precision, and set the
Length precision to 0.01.

This setting overrides the AutoCAD precision for distances when creating
vectors using single-pick options in vectorization tools. However, if you
are manually selecting the dimensions, (multi-picking), the chosen points
take precedence and the dimensions of the new entity use the AutoCAD
precision.

6 On the VTools Follower tab, click End Current Polyline If Closed Loop
Detected.
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This option causes new vector polyline entities to finish when a closed
boundary or loop is encountered.

7 Click OK to close the Raster Design Options dialog box.

Convert a raster circle to a vector using a single pick

8 To create a new circle, click Image menu  ➤ Vectorization Tools  ➤ 

Circle.

9 Click a point anywhere on the edge of the circle.

Verify the circle properties

10 Enter r to enter a new radius for the circle.

11 Enter 1.75 for the new radius.

This forces the new vector circle to match the labeled dimension (3.5
diameter).

12 Press Enter to exit the command.

The command removes the raster data below the new circle, but preserves
the intersecting raster dimension lines.
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Set a raster snap

13 To set a running raster snap, click Image  ➤ Raster Snap.

14 Select Raster Snap On, then click Clear All.

This activates the raster snaps, and clears the default selections. Raster
snaps select points on raster geometry in the same way an OSNAP selects
points on vector geometry.

15 Select Corner, then click OK.

This sets the raster snaps to select a corner where two raster lines connect.

Convert a raster line to a vector using two picks

16 To create a new line, click Image menu  ➤ Vectorization Tools  ➤ Line.

17 Enter 2p to draw the line by selecting two points.

18 Select the lower left corner of the base of the part, then the lower right
corner.
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Verify the line properties

19 Enter l (Length) to change the length of the line.

20 Enter 13.3 for the new length.

This forces the new vector line to match the labeled dimension.

21 Enter a (Angle) to change the direction of the line.

22 Enter 0 for the new angle.

This forces the new vector line to be orthogonal.

23 Press Enter to exit the command.

The command removes the raster information below the new line.

Exercise V1: Setting Options and Creating Basic Vector Objects | 187



24 Close the drawing without saving changes.

Exercise V2: Replacing Raster Text
In this exercise you learn how to replace multiline text paragraphs (e.g.,
construction notes), or single lines of text with vector versions.

Often when you try to use scanned drawings as part of a construction
document set, text must be modified or updated.

Related Help Topics

■ Vectorizing Raster Text

Related Exercises

■ Basic Tasks Tutorial (page 5)

188 | Chapter 9   Vectorization Tutorial



Before doing this exercise, ensure that Raster Design options are set as described
in the exercise Exercise A1: Setting ProductNameShort Options (page 5).

1 In the \Tutorial6 folder, open the drawing file VTools_03.dwg.

Turn off raster snaps

2 Click Image  ➤ Raster Snap.

3 Clear the Raster Snap On check box, then click OK.

This turns off any Raster Snaps so any point in the image can be selected.
You can also accomplish this by pressing Ctrl + F3 to toggle Raster Snap.

Convert raster notes to multiline text

4 To create a new, corrected block of text, click Image menu  ➤ 

Vectorization Tools  ➤ Multiline Text.

5 Select a point at the upper left corner of the existing note for the box.

6 Press Enter to accept the rotation angle of 0.

7 Drag a window around the existing four lines of text to specify the area
to be used by the multiline text.

8 In the multiline text frame, enter the following replacement text:

NOTE: LATCHES CAN BE LOCKED. BOX VENTILATED IN 4 PLACES.

9 In the Text Formatting toolbar, click OK to finish.

10 Select two points outside the new text to create a selection window for
removing the raster from behind the new text. The background raster is
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highlighted to show what will be removed. If the wrong area was selected,
you can enter r (Repick) and select a new area.

11 Press Enter to remove the raster and complete the command.

NOTE If you need to edit the vector text, select it, then right-click and click
MText Edit.

Convert a raster label to a single line of text

In the next few steps, you will replace a single line of text to correct an
alignment problem with the second line of the label for concentric
knockouts in the lower left region of the drawing.
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12 To create a new line of text, click Image menu  ➤ Vectorization Tools
 ➤ Text.

13 Select a point to mark the lower left corner of the inserted text, just above
the left edge of the line “OR 1.50 DIA. OUTPUT”.

The following example shows you where to select the starting point for
the new single line of text.

14 In the VText Edit dialog box, enter the following replacement text:

KNOCKOUTS FOR 1.25

15 Select two points outside the new text to create a selection window for
removing the raster text from behind the new vector text.

The background raster is highlighted to show what will be removed. If
the wrong area was selected, you can enter r (Repick) to re-select the
window.
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16 Press Enter to remove the raster. Press Enter a second time to complete
the command.

17 Close the drawing without saving changes.

Exercise V3: Converting Raster Polylines to 2D
Polylines

In this exercise you learn how to work with a follower command that
automatically follows a selected raster path.

Polylines can form a closed boundary or an open path. Raster Design can
automatically follow a selected raster path, stopping for your input when a
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decision point is reached. A decision point is typically an intersection,
endpoint, or location with confusing geometry.

Related Help Topics

■ Following Polylines

Related Exercises

■ Basic Tasks Tutorial (page 5)

Before doing this exercise, ensure that Raster Design options are set as described
in the exercise Exercise A1: Setting ProductNameShort Options (page 5) and
in the exercise Exercise V1: Setting Options and Creating Basic Vector Objects
(page 183).

1 In the \Tutorial6 folder, open the drawing file VTools_04.dwg.

2 Ensure that the Raster Design Quick Bar is visible. If it is not, click Image
 ➤ Toggle Quick Bar.

3 On the Raster Design Quick Bar, clear the Stop at Raster Intersections

button  . It is cleared when it is not outlined.

Convert raster polylines

4 To create a new polyline, click Image menu  ➤ Vectorization Tools  ➤ 

Polyline Follower.

5 Select a point on the edge of the cul-de-sac.
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6 Press Enter twice, first to draw the polyline and then to remove the raster
from behind the new vector.
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Convert closed raster polylines

7 On the Raster Design Quick Bar, select Stop at Raster Intersections.

This option enables you to direct the new vector entity when it reaches
an intersection.

8 To create a new polyline, click Image menu  ➤ Vectorization Tools  ➤ 

Polyline Follower.

9 Pick a point on the lot line between parcel (7) and (8).
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10 When the follower reaches the end of the lot line, enter d (Direction)
then pick a point along the back lot line to specify the direction to trace
the polyline around lot (8).

The Direction option is typically used at decision points.
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11 When the follower reaches the intersection between the back line and
the dashed lot line, enter d then pick a point near the beginning of the
dashed lot line to continue to trace the polyline around lot (8).
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12 When the follower reaches the cul-de-sac, enter v (Vector), then pick the
edge of the cul-de-sac to specify this as the vector line to follow.

The Vector option allows you to follow a vector polyline when lines or
boundaries overlap.

13 When prompted, select the beginning and end vertices of the curved
polyline. The beginning is the upper vertex; the end is the lower vertex,
where the polygon can be closed.

These points specify the direction and distance to follow on the vector
polyline. The AutoCAD Endpoint OSNAP is activated for these point
selections.
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14 Enter c to close the new polyline and remove the raster from behind the
new vector.

15 Press Enter twice to exit the command.

The lot lines for Lot 8 were converted to a single polyline.
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16 Close the drawing without saving changes.

Exercise V4: Using Dynamic Input Prompts
In this exercise you learn how to vectorize linework with great precision, using
AutoCAD Dynamic Input prompts.

Dynamic Input provides useful prompts of line lengths, angles, and command
options in the vicinity of the cursor. This exercise involves setting the options
for Dynamic Input, then vectorizing street edges and cul-de-sacs in a property
drawing.

Related Help Topics

■ Setting the Options

■ Dynamic Input Settings

Related Exercises

■ Basic Tasks Tutorial (page 5)
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■ Exercise V3: Converting Raster Polylines to 2D Polylines (page 192)

To configure Dynamic Input settings and vectorize linework

1 In the \Tutorial6 folder, open the drawing file VTools_Dyn.dwg.

After setting some tool options, you can start vectorizing the street edges
in this raster image.

2 On the command line, enter the AutoCAD command OPTIONS.

3 In the Options dialog box, on the Display tab, in the Window Elements
area, select Show ToolTips; on the Drafting tab, in the AutoSnap Settings
area, select Display AutoSnap Tooltip. Close the Options dialog box.

4 Along the bottom of your drawing window, right-click DYN and click
Settings. Alternatively, enter the AutoCAD command DSETTINGS.

5 In the Drafting Settings dialog box, on the Dynamic Input tab, select all
three options to enable Pointer Input, Dimension Input, and Dynamic
Prompts.

6 In the Pointer Input area, click Settings.

7 In the Pointer Input Settings dialog box, in the Format area, select Polar
Format and Absolute Coordinates; in the Visibility area, select Always.
Click OK to close the dialog box.

8 On the Dynamic Input tab, in the Dimension Input area, click Settings.
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9 In the Dimension Input Settings dialog box, click Show the Following
Dimension Input Fields Simultaneously, and select Resulting Dimension,
Absolute Angle, and Arc Radius. Click OK to close the dialog box.

10 In the Drafting Settings dialog box, click Drafting Tooltip Appearance.

11 In the Tooltip Appearance dialog box, click Colors.

12 In the Drawing Window Colors dialog box, in the Context area, select
2D Model Space; in the Interface Element area, click Crosshairs; in the
Color area, select a color such as Green that contrasts well with the white
lines in the image. Click Apply & Close.

13 In the Tooltip Appearance dialog box, click OK.

14 In the Drafting Settings dialog box, on the Object Snap tab, select Object
Snap On; in the Object Snap Modes area, select Endpoint and Intersection.

15 In the Drafting Settings dialog box, on the Raster Snap tab, select Raster
Snap On; in the Raster Snap Modes area, select Center, End, and Corner;
in the Preferences area, select Show Aperture and Snap. Click OK to close
the dialog box.

Now you are ready to start vectorizing lines, beginning with the left (west)
edge of Elmhurst Avenue. The following instructions use standard compass
directions, assuming that the top of the image is north.

16 Click Image menu  ➤ Vectorization Tools  ➤ Line. Or enter the command
vline.

17 Move the cursor to the west edge of Elmhurst Avenue, and snap to the
center of the raster line. You should see the Raster Snap symbol and Raster
Center tooltip to confirm this.

18 Click to vectorize the line.
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Tooltips show the line length and angle (252 degrees).

19 Right-click and click Enter to vectorize the line.

20 Move the cursor to the northeast side of Elmhurst Avenue, snap to the
centre of this line, then click.

21 Right-click and click Enter to vectorize the line, then right-click and click
Cancel to end the command.

Tooltips show that the angle of this line is also 252 degrees. The presence
of these two parallel vector lines provides a good base for vectorizing the
cul-de-sac.

22 Click Image menu  ➤ Vectorization Tools  ➤ Arc. Or enter varc.

The tooltip “Specify one-pick point or...” shows a Down Arrow icon.
When you press the keyboard Down Arrow once, you see the two other
options, Center and 3p; press again, and a black dot marks the first choice.

At this point, you can use the Up/Down Arrows to select an option. You
can also select an option with the cursor, or right-click the mouse to select
an option from the shortcut menu.

23 Select the 3p option, then, as prompted, select the start point. Use the
square Object Snap marker to select the end of the first vectorized line.

24 Select another point along the arc, then select the third point at the end
of the other street edge, using the Object Snap marker again. Press Enter
to end the command.
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In the next few steps, you will vectorize the rectangle bounded by
Elmhurst, Highland, Northside, and Elm Place.

25 Click Image menu  ➤ Vectorization Tools  ➤ Rectangle. Or enter vrect.

26 Click the north corner of the rectangle, where Elmhurst meets Northside,
and move the cursor a short distance to the southwest, along the east
side of Elmhurst Ave.

Notice that the angle prompt is highlighted. In this state, you can lock
the line to a specific angle by entering the numeric value.

27 Enter 252, the angle you used for other edges of Elmhurst Ave.

28 To specify the second corner point, click the diagonally opposite corner
of the rectangle, where Highland and Elm Place meet.

29 Right-click and click Enter, then right-click and click Cancel to end the
command.

Note that the east and west corners of the rectangle are displaced from
the raster corners. In a real project, you could decide at this point whether
it is more important to follow the raster lines or keep the vector lines
parallel.

Further exploration: To follow the raster lines, first click File
menu ➤ Undo. Do this one or more times to undo the vrect command,
then use the polyline vectorization tool (vpline), with the 2p option, to
vectorize the lines by clicking each corner point in a sequence around
the rectangle, using the Object Snap marker to ensure that the start and
end points join to form a closed figure.

In the next few steps, you will use the polyline vectorization tool to
vectorize along Northside.

30 Click Image menu  ➤ Vectorization Tools  ➤ Polyline. Or enter vpline.

31 Select the 2p option.

TIP When using the 2p option to vectorize a polyline, click the start point,
then click each vertex in sequence until you reach the endpoint.

32 Click the end of the vector line at the corner of Elmhurst and Northside,
and move the cursor a short distance east along Northside.
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Notice that when you have two numeric prompts, such as angle and
length, one of them is highlighted, indicating that you can enter a
numeric value.

33 Press the Tab key to switch the highlight from angle to length several
times, then stop on angle.

34 Enter 342, which is 90 degrees from the angle of Elmhurst (252 degrees),
then press Tab to switch the highlight to the length value.

Now the angle is locked at 342.

35 Slide the cursor east to the edge of Oak Place, click on the raster street
edge, then follow this edge north east toward the cul-de-sac.

36 At the Raster Corner prompt, click once to mark the endpoint, then
right-click and click Enter.

You have finished the steps of this exercise, and should feel comfortable
using the vectorization commands with Dynamic Input prompts.

Further exploration: Continue vectorizing more of the street edges in
this image, deciding whether to lock angles or follow raster lines. After
you vectorize both sides of Oak Place, use the Copy With Base Point
command to copy the cul-de-sac from Elmhurst to Oak Place. With one
of the arc endpoints as a base point, use Object Snap to attach the arc
precisely to one street edge.

37 Close the drawing without saving changes.

Exercise V5: Working with Separation Tables
In this exercise you learn how to use separation tables to control the
assignment of lines to layers when converting raster lines to vector.

The layer for the new vectors can be controlled by the raster line width or
linetype (continuous vs. non-continuous). These layer controls are generally
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used for basic vector objects, such as lines and circles, and the polyline follower.
When you are converting text or contours, other types of layer control can
apply.

Related Help Topics

■ Setting the Options

■ Changing the Quick Bar Visibility

Related Exercises

■ Basic Tasks Tutorial (page 5)

■ Exercise V3: Converting Raster Polylines to 2D Polylines (page 192)

1 In the \Tutorial6 folder, open the drawing file VTools_05.dwg.

Access the Raster Design Quick Bar

2 Ensure that the Raster Design Quick Bar is visible. If it is not, click Image
 ➤ Toggle Quick Bar.

3 On the Raster Design Quick Bar, clear the Stop At Raster Intersections

option  .

Change the raster entity detection settings

4 To display the Raster Design Options dialog box, click Image  ➤ Options.

5 Click the Raster Entity Detection tab and change the Max Jump Length
option to 70.

This setting specifies the maximum length of a gap that Raster Design
will tolerate when following a raster polyline. It can be used to jump over
labels embedded in the line or to follow non-continuous lines such as
dashed lines. This length is in pixels and can be selected on the screen
using the Pick button.

6 Change the Max Dash Length option to 50, and the Max Blank Length
to 20.

These settings control how Raster Design detects the presence of dashed
or non-continuous linetypes.

Change the vector separation settings

7 Click the VTools General tab, then click Vector Separation to display the
Vector Separation Options dialog box.
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8 Click the General tab and select Override Width Table For Non-continuous
Entities. In the Layer list, change the Layer to easement lines.

With this setting, lines detected as non-continuous will be placed on the
easement lines layer.

Add width table entries

9 Select the Use Width Table option.

This setting allows you to specify layers based on ranges of widths in
pixels for raster linework. When using the vectorization tools, the width
of the raster selected is compared to the width table, and the layer is
assigned based on these settings.

10 Click Insert Below to add a range.

11 Click Query Width and select a point in a utility line to determine its
width in pixels.

12 Click OK to exit the Entity Width Information dialog box. In the Width
Table, click on the new range once to activate it, then click on the
Maximum value, and change it to 4.

13 Click on the range once to activate it again, then click on the Layer
setting. Use the list to change the layer to s-util for thin raster lines.
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14 Click Insert Below to add another range.

Note that the new range is set to accept wider lines.

15 Click on the new range once to activate it, click on the Layer setting,
change the layer to *PROMPT*, and press Enter.

This setting forces the vectorization tools to prompt for a layer when
thick raster selections are encountered. This option is very useful when
several different types of lines have similar appearances in the raster file,
but should be separated on different layers in the vector file.

16 Click OK to exit the Vector Separation Options dialog box; click OK again
to exit the Raster Design Options dialog box.

Convert a dashed raster line to vector

17 To create a new polyline, click Image menu  ➤ Vectorization Tools  ➤ 

Polyline Follower.

18 Click the lower left end of the bottom easement line to convert it to a
polyline. The entire line is highlighted.

19 Press Enter to accept the polyline.

The new polyline is placed on the easement lines layer.

20 Press Enter to exit the command. The new polyline is displayed in the
green color assigned to the layer.
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Convert raster lines with differing widths to vector

21 To create a new polyline, click Image menu  ➤ Vectorization Tools  ➤ 

Polyline Follower.

22 Click the left end of the utility line inside the cul-de-sac to convert it to
a polyline.

23 Press Enter to accept the polyline and start another.

The new polyline is placed on the s-util layer.

24 Click on the bottom end of the short right-of-way line.
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25 When the follower reaches the end of the right-of-way, press Enter to
complete the polyline.

26 From the Select Layer dialog box, select the row layer, and then click OK.

27 Press Enter to exit the command.

28 From the Raster Design Quick Bar, select the Stop At Vector Intersections

option  .

29 To create a new line using the single pick option, click Image menu  ➤ 

Vectorization Tools  ➤ Line.

30 Click the line between lots 74 and 75 and zoom to the area.

The following example shows where to select the point on the lot line
to convert it to a vector.
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31 When prompted, select the lot lines layer for the new line.

32 Press Enter to exit the command.

The command removes the raster information below the new line.

The following example shows how the drawing should appear after the
various types of lines have been converted and placed on the appropriate
layers.
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33 Close the drawing without saving changes.

Exercise V6: Creating Contours from Scanned
Topo Maps

In this exercise you use the contour follower to convert a raster contour to a
vector polyline with elevation.

You can convert a raster contour to a vector polyline with elevation using
settings to control elevation assignment, layer management, and decision
point behavior. Elevation levels can represent ground elevation or another
attribute of the terrain, such as temperature or population density.

Related Help Topics

■ Setting the Options

■ Using the Contour Follower
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Related Exercises

■ Basic Tasks Tutorial (page 5)

■ Exercise V3: Converting Raster Polylines to 2D Polylines (page 192)

1 In the \Tutorial6 folder, open the drawing file VTools_06.dwg.

Access the Raster Design Options dialog box

2 To display the Raster Design Options dialog box, click Image  ➤ Options.

3 Select the Raster Entity Detection tab and change the Max Jump Length
option to 5.

This setting specifies the maximum length of a gap that Raster Design
will tolerate when following a raster polyline. It can be used to draw
through labels embedded in the line or to follow non-continuous lines
such as dashed lines.

This length is in pixels and can be selected on screen using the Pick
button. In this case, the jump length is set to 5 so that the follower does
not automatically draw through contour labels.

4 Click the VTools Follower tab. In the Contour Settings area, change
Elevation to Prompt, and set the Elevation Interval to 20.

This setting controls the default elevations displayed for contours as they
are converted.

5 Click the VTools General tab and click Vector Separation to display the
Vector Separation Options dialog box.

6 Click the Contour tab on the Vector Separation Options dialog box and
verify that the option Separate Contours By Elevation is selected.

This setting assigns contours to layers based on their elevation interval.

7 In the Minor section, set the Interval to 20 and Layer to contour20. In
the Major section, set the Interval to 100 and Layer to contour100. Set
the Polyline Width to Actual for both the Minor and Major polylines.

These settings ensure that all contours with an elevation divisible by 100
are placed on the contour100 layer automatically. All contours with an
elevation divisible by 20, but not by 100, are placed on the contour20
layer. All polylines use a width that matches the original raster data.

8 Click OK to exit the Vector Separation Options dialog box; click OK again
to exit the Raster Design Options dialog box.

Create a contour from raster information
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9 To create contours, click Image menu  ➤ Vectorization Tools  ➤ Contour
Follower.

10 Click on the upper half of the 7200 contour.

11 When the follower reaches the break where the label is located, manually
add one or two points across the label, then click on the contour line on
the other side of the label.
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12 Enter o (Continue) to continue following the contour to the far end.

13 Press Enter to stop the following process.

14 Enter 7200 to set the elevation for the new contour.

The new contour is placed on the contour100 layer and the polyline
width is set to match the original raster.
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15 Click on the 7220 contour, to the left of the 7200 contour. The entire
line is followed.
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16 Press Enter to stop the following process.

17 Press Enter to accept the default elevation of 7220 for the new contour.

The new contour is placed on the contour20 layer and the polyline width
is set to match the original raster.

18 Close the drawing without saving changes.

Exercise V7: Creating 3D Breaklines from Topo
Maps

In this exercise, you follow along a path defined by vector, stopping along
the way to enter elevations.

The 3D polyline follower differs from other followers in that it does not attempt
to digitize existing raster. The decision points for this follower can be either
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vertices in the path or raster impact points. At each decision point, elevation
information is requested. You can do this in three ways:

■ Enter the elevation explicitly

■ Assign the elevation automatically based on an increment or intersection
with vector data

■ Interpolate the elevation between known points

Related Help Topics

■ Setting the Options

■ Using the 3D Polyline Follower

Related Exercises

■ Basic Tasks Tutorial (page 5)

■ Exercise V3: Converting Raster Polylines to 2D Polylines (page 192)

1 In the \Tutorial6 folder, open the drawing file VTools_07.dwg.

Access the Raster Design Options dialog box

2 To display the Raster Design Options dialog box, click Image  ➤ Options.

3 Click the VTools Follower tab. In the 3D Polyline Settings area, change
the Elevation Interval to 20; ensure that the options Use Raster Impact
Points Only and Ignore Raster Speckles are both cleared.

These settings control how the new vector line is created and the default
elevations used when raster contours are encountered. All vertices and
raster impact points along the existing vector polyline will be used for
the new 3D breakline.

4 Click OK to exit the Raster Design Options dialog box.

Create a 3D breakline

5 To create a breakline of the stream bed, click Image menu  ➤ 

Vectorization Tools  ➤ 3D Polyline Follower.

6 Enter v (Vector) to use the existing vector 2D polyline.

7 Select the existing polyline near the right end.
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The cursor is positioned at the right end of the polyline, waiting for you
to specify an elevation.

8 Enter 7155 for the first elevation. The cursor moves to the next vertex of
the polyline.

9 Enter i (Interpolate) to interpolate the elevation of the polyline vertex.

10 Enter 7160 to set the elevation for the next point, near the intersection
with the raster contour.

11 For the rest of the vertices except the last endpoint, use i to interpolate
elevations where there is no raster data, and press Enter to accept the
elevation calculated by the program where raster and vector intersect.

Watch the command line to see the elevations being used by the routine.
If the elevation is zero, it is a polyline vertex and you should use the
interpolation option to calculate an elevation for that point. If there is
an elevation displayed at the command line, the point is an intersection
between raster and vector and the program is using the interval set in
the options to determine the elevation at that point. You can enter known
elevations at any time.

12 When you reach the end of the polyline, enter 7342 to specify the
elevation at the end of the breakline.
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There is a new 3D polyline drawn on the current layer. If you list this
polyline, you can see that each vertex has an elevation. Several of the
vertices have interpolated elevations, while the rest are even elevations
where the raster contours intersect the original polyline path.

13 Select the 3D polyline and enter the LIST command.

The system displays the coordinates of each vertex, with elevations shown
as Z values.

14 Close the drawing without saving changes.
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Text Recognition Tutorial

This tutorial shows you how to use the Text Recognition commands to change raster text to
AutoCAD text or multiline text (Mtext).

You begin by selecting an area of text or a table in your drawing, then entering the search
parameters for the recognition engine. You can view the results in the Verify Text dialog box
and make any changes in the Edit window before inserting the text into the drawing.

Exercise R1: Recognize Machine-Printed Text
In this exercise you change machine-printed raster text to AutoCAD text and
Mtext in your drawing.

The settings you select in the Text Recognition Setup dialog box define the
parameters for the search engine. The results from the search are displayed in
the Verify Text window where you can make the necessary corrections and then
enter the new text into the drawing.

In this exercise you:

■ Enter the parameters for the recognition engine.

■ Select a rectangular area of machine-printed raster text.

■ Make corrections to the recognized text using the tools in the Verify Text
window.

■ Insert the AutoCAD Mtext into the drawing.

Related Help Topics

■ Using Text Recognition
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Related Exercises

■ Exercise B4: Modifying a Part Using REM Commands (page 65)

Before doing this exercise, ensure that Raster Design options are set as described
in the exercise Exercise A1: Setting ProductNameShort Options (page 5).

1 In the \Tutorial9 folder, open the drawing file textrec_01.dwg.

Choose an image to insert

2 To display the Insert Image dialog box, click Image  ➤ Insert.

3 From the Files of Type list, choose All Image Files.

4 If necessary, navigate to the \Tutorial9 folder. Select the image file
text_rec_mach.tif.

5 In the Insert Options area, click Quick Insert and Zoom to Image. Click
Open.

The image is inserted.

Convert machine-printed raster text to AutoCAD Mtext

6 To display the Text Recognition Setup dialog box, click Image  ➤ Text
Recognition  ➤ Recognize Setup.

7 In the Input section, select the following settings:

■ Text Format is Machine Printed.

■ Selection Shape is Rectangular.

■ Select the Spelling dictionary.

■ Select English in the Spelling Language list.

■ Select the AutoCAD Custom dictionary.

■ Click Language Character Set and select English then click OK.

■ In the Recognize section, select only Uppercase and Punctuation,
clearing other check boxes.

8 In the AutoCAD Output section, select the following settings:

■ Output Type is MText.

■ AutoCAD Style is Standard.

■ Text Height is Automatic.
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■ Removal Method is Rub.

9 In the Verification Display section, select the Underline check box and
clear the check boxes for Bold, Italic and Enable Verifier.

10 Click OK.

11 Click Image menu  ➤ Text Recognition  ➤ Recognize Text.

12 Draw a rectangle around the word “NOTES” as follows: click the upper
left corner, press Enter to set the angle to 0, then click the bottom right
corner.

The Verify Text window displays the word NOTES: in both the View pane
(upper pane) and the Edit pane (lower pane). If the word NOTES: is not
underlined in the Edit pane, click and drag to select the word and click
the underline formatting option on the Edit toolbar. If the recognition
engine has inserted any unwanted characters, delete them from the Edit
pane.
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13 Click OK to insert the word NOTES: into the drawing as AutoCAD Mtext.

The following example shows how the Mtext displays in the drawing.

14 Enter s at the command line to display the Text Recognition Setup dialog
box.

15 Change the following settings:

■ In the Input section, select the check boxes for Uppercase, Numbers,
Punctuation, and Miscellaneous.
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■ In the AutoCAD Output section, set the Output Type to MText and
set AutoCAD Style to TR1.

■ In the Verification Display section, clear the formatting check boxes
and select Enable Verifier.

Click OK.

16 Draw a rectangle around steps 1 through 3 as follows: click the upper left
corner, press Enter to set the angle to 0, then click the bottom right corner.

The Verify Text window opens. The View pane displays the original raster
text; the Edit pane displays the output from the recognition engine.
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17 Review the areas of highlighted text in the Edit pane. Click Find Next to
display the first suspect word or rejected character in the Change To box.
Select a word from the Change To list or enter the correct word in the
box and click Replace. Click Add to Dictionary if you want to add the
word or acronym to the recognition dictionary. When you click OK, you
are prompted to add the word to the AutoCAD custom dictionary too.

IMPORTANT Because no recognition engine is 100% accurate, you should
carefully check the results in the Edit pane, not just the highlighted areas,
and make all necessary changes.

18 After making changes, click OK to insert the new AutoCAD text in the
image.

TIP You can use the AutoCAD MOVE command to align the text block. To
edit the text, select it, then right-click and click MText Edit.

19 Close the drawing without saving changes.

Exercise R2: Recognize Hand-Printed Text
In this exercise you change hand-printed raster text to AutoCAD text in your
drawing.

The general process is as follows:

■ Enter the parameters for the recognition engine.

■ Select a hand-printed note in raster text using the polygonal selection
method.
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■ Make corrections to the recognized text using the tools in the Verify Text
window.

■ Insert the AutoCAD text into the drawing at an angle.

Related Help Topics

■ Using Text Recognition

Related Exercises

■ Exercise R1: Recognize Machine-Printed Text (page 221)

Before doing this exercise, ensure that Raster Design options are set as described
in the exercise Exercise A1: Setting ProductNameShort Options (page 5).

Open the drawing file for this exercise

1 In the \Tutorial9 folder, open the drawing file textrec_03.dwg.

Choose an image to insert

2 To display the Insert Image dialog box, click Image  ➤ Insert.

3 From the Files of Type list, choose All Image Files.

4 If necessary, navigate to the \Tutorial9 folder. Select the image file
text_rec_hand.tif.

5 In the Insert Options area, click Quick Insert and Zoom to Image. Click
Open.

The image is inserted.

Convert hand-printed raster text to AutoCAD text

6 To display the Text Recognition Setup dialog box, click Image  ➤ Text
Recognition  ➤ Recognize Setup.

7 In the Input section, select the following settings:

■ Text Format is Hand Printed.

■ Selection Shape is Polygonal.

■ Select the Spelling dictionary.

■ Select English in the Spelling Language list.

■ Select the AutoCAD Custom dictionary.
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■ Click Language Character Set and select English.

■ In the Recognize section, select Uppercase, Numbers, Punctuation
and Miscellaneous.

8 In the AutoCAD Output section, select the following settings:

■ Output Type is MText.

■ Text Height is Style Height.

■ AutoCAD Style is Note.

■ Removal Method is Rub.

9 In the Verification Display section, clear the check boxes for Italic,
Underline, and Enable Verifier.

10 Click OK.

11 Click Image menu  ➤ Text Recognition  ➤ Recognize Text.

12 Zoom to the handwritten note in the upper right section of the drawing.

13 Enter a at the command line for angle and enter the rotation angle of
the text. You can do this either by selecting two points to draw a baseline
for the text (parallel to the long side of the enclosing rectangle) or by
entering 339. Press Enter.

14 Draw a polygon around the text within the border, then press Enter to
finish the polygon.

228 | Chapter 10   Text Recognition Tutorial



The Verify Text window opens.

15 Review the areas of highlighted text in the Edit pane (lower pane). You
can revise text directly in the Edit pane, or use the editing buttons. Click
Find Next to display the first suspect word or rejected character in the
Change To box. Select a word from the Change To list or enter the correct
word in the box and click Replace. Click Add to Dictionary if you want
to add the word or acronym to the recognition dictionary. When you
click OK, you are prompted to add the word to the AutoCAD custom
dictionary too.

IMPORTANT Because no recognition engine is 100% accurate, you should
carefully review the results in the Edit pane, not just the highlighted areas,
and make all necessary changes.

16 Click OK to insert the new note in the drawing, and then press Esc to
end the Text Recognition command.

TIP You can use the AutoCAD MOVE command to align the text block. To
edit the text, select it, then right-click and click MText Edit.

17 Close the drawing without saving changes.
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Exercise R3: Recognize a Table
In this exercise, you change text in a table from raster text to AutoCAD text
in your drawing.

The general process is as follows:

■ Enter the parameters for the recognition engine.

■ Select a table in your drawing using the rectangular selection method.

■ Make corrections to the recognized text using the tools in the Verify Table
window.

■ Insert the table into the drawing as AutoCAD text.

Related Help Topics

■ Using Text Recognition

Related Exercises

■ Exercise R1: Recognize Machine-Printed Text (page 221)

■ Exercise R2: Recognize Hand-Printed Text (page 226)

Before doing this exercise, ensure that Raster Design options are set as described
in the exercise Exercise A1: Setting ProductNameShort Options (page 5).

1 In the\Tutorial9 folder, open the drawing file textrec_02.dwg.

Choose an image to insert

2 To display the Insert Image dialog box, click Image  ➤ Insert.

3 From the Files of Type list, select All Image Files.

4 If necessary, navigate to the \Tutorial9 folder. Select the image file
text_rec_table.tif.

5 In the Insert Options area, click Quick Insert and Zoom to Image. Click
Open.

The image is inserted.

Convert raster text in a table to AutoCAD text

6 To display the Text Recognition Setup dialog box, click Image  ➤ Text
Recognition  ➤ Recognize Setup.
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7 In the Input section, select the following settings:

■ Text Format is Machine Printed.

■ Selection Shape is Rectangular.

■ Select the Spelling dictionary.

■ Select English in the Spelling Language list.

■ Select the AutoCAD Custom dictionary.

■ Click Language Character Set and select English.

■ In the Recognize section, select Uppercase, Numbers, Punctuation,
and Miscellaneous.

8 In the AutoCAD Output section, select the following settings:

■ Output Type is Text.

■ Text Height is Style Height.

■ AutoCAD Style is Table Text.

■ Removal Method is Rub.

9 In the Verification Display section, clear all the check boxes.

10 Click OK.

11 Click Image menu  ➤ Text Recognition  ➤ Recognize Table.

12 Draw a rectangle to enclose the table as follows: click the upper left corner,
press Enter to set the angle to 0, then click the bottom right corner.

13 The Verify Table window opens. The View pane (upper pane) displays
the original raster text; the Edit pane (lower pane) displays the output
from the recognition engine.
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The following example shows typical results for the Recognize Table
command.

14 Review the results in the Edit pane of the Verify Table window. In this
example you would change the $ characters in the first column to the
numeral 8 and correct the spacing for the word INCH.

IMPORTANT Because no recognition engine is 100% accurate, you should
carefully review the results in the Edit pane, not just the highlighted areas,
and make all necessary changes.

15 Click OK to insert the table as AutoCAD text in the drawing.

If necessary, you can use standard AutoCAD commands to move or edit
the text.

16 Close the drawing without saving changes.
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