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This document describes the fixes in  Autodesk® 3ds Max® 2012 and Autodesk® 3ds Max® Design 2012 

Service Pack 1 (SP1). It is strongly recommended that you read this entire document before installing the 

software. For future reference, you should save this readme to your hard drive. Note that the term 3ds 

Max refers to both 3ds Max and 3ds Max Design unless otherwise indicated. 

3ds Max 2012 Service Pack 1 is a cumulative update. It includes the following Hot Fix: 

Hot Fix 1 – Autodesk 3ds Max 2012 
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Additional Resources 

For complete instructions about uninstalling and installing 3ds Max 2012, see the Autodesk 3ds Max 

2012 and Autodesk 3ds Max Design 2012 Installation Guide. The complete installation documentation 

set is found on your install DVD in the \en-US\Docs folder at the root of the DVD.  

For troubleshooting or to report issues with this release, see: www.autodesk.com/3dsmax-support or 

www.autodesk.com/3dsmaxdesign-support. 

For more resources, see: http://www.autodesk.com/3dsmax-learningpath. 

What’s Fixed? 

The following table outlines fixes for Service Pack 1.  

Feature Description  

Animation  When using the Material setting in Set Key Filters, a program 
error would occur when using Set Key on an object with a 
Standard material. This has been fixed.  

 The Play Selected setting now plays only the selected objects 
and no longer plays all objects in the scene. 

 CAT  The core code of CAT has been rewritten. Much of the work was 
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Feature Description  

structural, but many defects were also addressed. 

 Digit presets were not loading correctly. Now they load as they 
should.  

 When Track View and Motion Layer were open, using Undo 
caused a program error. This has been fixed.  

 Collar bones now correctly stretch to adjust to the upper arm 
position.  

 RG3 rigs with Motion Layers now load without an error.  

 Undoing a change to Num Digits would cause a program error. 
This has been fixed. 

 Cloning rig elements no longer causes a program error.  

 Stretchy limbs now work correctly with the Ankle removed.  

 MAXScript: ExtraRigNodesInterface() is now available from 
CATParentTrans.  

 CAT now saves controller types for position and rotation even 
when these tracks are animated.  

 All operations should now work correctly when using Stretch 
and translating in Setup Mode.  

 Twisting bones now work correctly for both palms.  

 Bones now inherit correctly in Setup Mode.  

 Toe positions would move on a very small scale when you 
rotated them. This has been fixed.  

 In rigs with segmented limbs, the second bone in each limb was 
incorrectly parented to the first segment in the bone. Now the 
second bone is parented correctly to the last segment.  

 Tail links now scale correctly in Setup Mode.  

 The wrist would sometimes rotate incorrectly when setting the 
IK slider to zero in the Motion Panel. This has been fixed.  

 Changing rig structures no longer causes a program error.  

 A program error that occurred when loading legacy .max files 
with CAT has been fixed.  

 Retargeting motion-capture data would cause a MAXScript 
error. This has been fixed.  

 When cloning a CATRig with Shift+clone, a right-click would 
cause a program error. Right-click now cancels the clone and 
restores the previous scene state, as with other 3ds Max 
objects.  

 Now you can use the Manage Container feature with saved 
Containers that contain CATRigs.  

 Undoing animation on CATRigs would cause a program error. 
This has been fixed. 

 CAT no longer temporarily freezes when using the CATMotion 
Range group with the Globals dialog open.  

 The CAT Pin Bone feature now functions correctly.  

 When using CATRigs in Containers, saving, closing, or unloading 
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Feature Description  

the Container now works correctly.  

 Applying a Reaction controller to the ankle could cause a 
program error. This has been fixed. 

 When mirroring saved poses, the mirrored rig no longer 
deforms. Now it mirrors the rig correctly.  

 When creating Absolute Layers, inherit position/rotation would 
result in a 90 degree offset. Inherit now works correctly. 

 When loading the same Preset Rig (.rg3) into the same scene, 
the additional rigs now increment bone names so no names are 
duplicated. 

CivilView (3ds Max Design 
2012 only) 

Modifying Surface Parameters no longer causes a program error.  

Environment The Environment map On/Off setting now works correctly.  

Help The Download Vegetation link in the Help menu now loads the 
correct page. 

InfoCenter Balloon messages in the Communications Center now display 
correctly. 

Mirror Normals would not always display correctly when objects were 
mirrored. This has been fixed. 

Nitrous  Autodesk Metallic Paint now displays correctly in Nitrous 
viewports.  

 The Blur setting on the coordinates rollout generated too much 
blur in viewports with Realistic shading and in Quicksilver 
renderings. This has been fixed.  

 “mr Physical Sky” and “mr Photographic Exposure Control” now 
update immediately in Nitrous viewports.  

 Viewports with Realistic shading now reflect changes made to 
the W coordinate > Angle parameter (for UVW mapping 
coordinates). 

 Objects with a Standard material can now display the object 
backfaces.  

 Applying Unwrap UVW to an object no longer corrupts the 2D 
view in Viewport Canvas.  

 An Environment Map background now renders correctly on the 
ATI 4870 graphics card, instead of displaying as solid black.  

 When using Edit Triangulation / Turn button in Editable Poly, 
dotted lines now display correctly at Triangles of Polygons.  

 Imported FBX files no longer cause a program error when using 
NURMS Subdivision after converting to Editable Poly.  

 Maps now display correctly when using the Shell material.  

 Selection previews now work correctly with Editable Poly.  

 Vertex Channel Display in Object Properties now correctly 
displays the Vertex initial color setting.  

 Polygon Sub-Objects now display edges correctly when selected.  

 When deselecting Edges at the Editable Mesh > Edge sub-object 
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Feature Description  

level, the deselected Edges no longer display the background.  

 On the Viewport Configuration dialog > Visual Style & 
Appearance panel, Apply To All Views now works correctly with 
viewports that have non-photorealistic styles.  

 Choosing Display panel > Display Color rollout > Shaded > Object 
Color now displays the object’s color (rather than material 
color) in viewports with Realistic or Shaded shading.  

 If you set the Compact Material Editor to display a custom 
sample object in a sample slot, the object would appear in 
Nitrous viewports. This has been corrected.  

 The Frozen feature in the Display Panel now updates viewports 
correctly.  

 Normals now display with the Edit Mesh > Show Normals 
setting.  

 In Orthographic views, the default light direction is now 
correctly set to be slightly offset to the upper right. 

 The selection box marquee (the dotted line) is no longer drawn 
behind objects or on the active Grid.  

 The selection box marquee (the dotted line) would stop 
appearing after multiple selections. Now it always appears.  

 The background no longer displays as black when the Tone 
Mapper is enabled and an “mr Physical Sky” is assigned but not 
enabled.  

 The viewport background no longer toggles to off or flickers 
when switching to Wireframe or Bounding Box display.  

 Mirrored or negatively Scaled objects now display face edges 
correctly.  

 When using the Mirror tool, the original object would 
sometimes display with flipped normals. This has been fixed.  

 Progressive rendering now correctly draws unhidden faces.  

 When using the Ink ‘n Paint material, the Highlight parameter 
would cause the object to turn black if Ambient Occlusion was 
enabled. The material now displays correctly.  

 Artifacts would appear when using light shapes if the light was 
too close to an object surface. Light shapes now display 
correctly.  

 When you hide an object with a target, now both the object and 
its target are hidden: the target no longer remains visible. 

 Animated deformed Meshes would stop updating if parts of the 
Rig hierarchy were hidden. Deformed meshes now update 
correctly.  

 When entering Isolate mode in a scene that contains an XRef 
Scene, the XRef’d Scene no longer continues to be visible.  

 The Illuminate With Scene Lights and Illuminate With Default 
Lights entries now appear on the Shading viewport label menu 
when the viewport mode is set to Consistent Colors and Hidden 
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Feature Description  

Line. The Viewport menu also displays the state of the lighting 
correctly.  

 A performance improvement was made for large poly objects by 
improving system and video card memory management. 
Performance improvement is best with 2GB video memory or 
more.  

 The Transform Gizmo would not always update when switching 
between Move, Rotate, and Scale. Now it updates correctly in 
all viewports.  

 When scaling the viewport size, objects would also visually scale 
with the size of the viewport. This has been fixed.  

 In some cases, objects from previously loaded scenes would 
display when opening another scene. This has been fixed.  

 When using Viewport Ghosting on animated deforming meshes 
or using Set Key with Ghosting, a program error could occur. 
This has been fixed.  

 When using Ghosting, all objects were incorrectly showing 
edged faces. Now objects display correctly. 

 DirectX shaders have added support for customized lights, and 
now support multiple lights in viewports.  

 When using an environment background and activating Safe 
Frame, the background would fit to the viewport. Now it 
correctly fits to the Safe Frame.  

 Empty or invalid Loft objects would cause a program error. This 
has been fixed.  

 Extensive viewport screen flashing and refresh issues have been 
corrected.  

Quicksilver Hardware 
Renderer 

 Indirect Illumination now works correctly.  

 Render Region now renders the correct regions.  

 Depth Of Field no longer flickers in the blurred areas when 
rendering.  

 .xmsl files could be given the same key as .msl files in some 
cases. This caused a program error. Now .xmsl files are given a 
unique key, and the program error does not occur.  

 File parameter values were not respected when loading .xmsl 
files. Now all parameters load correctly.  

 The rendering was always overexposed when using Daylight 
Systems (Sunlight: mr Sun and Skylight: mr Sky). Exposure 
controls now work correctly.  

Ribbon The “Error Parsing XAML” error on start-up has been fixed.  

SDK (3ds Max 2012 only) NodeEventSystem now sends Node Added events when creating 
Nodes.  

Unwrap UVW  The Pixel Snap and Grid Snap icons were flipped and have been 
corrected.  

 Scaling tools have been refined to work more intuitively.  
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Feature Description  

 When creating Point To Point seams with the Peel tool, hidden 
faces no longer become visible.  

 Editable Poly tessellated geometry no longer causes a program 
error when opening the Edit UVWs dialog.  

 Three general-purpose optimizations have been implemented 
that greatly increase the performance of Unwrap UVW.  

 A program error no longer occurs when you Reset UVWs then 
click Quick Peel. 

Viewports  A program error could occur when switching between viewports 
or maximizing the active viewport. This has been fixed.  

 A memory leak that occurred with Nitrous and Direct3D when 
the Arch & Design material used large bitmaps has been 
identified and fixed.  

 Grid Spacing and the Grid Spacing Status were not updating 
correctly in viewports. This has been fixed.  

Viewport Canvas Viewport Canvas now supports the Composite material.  

Supported Operating Systems 

Use the following supported operating systems for the 32-bit or 64-bit version of the Autodesk 3ds Max 

2012 / Autodesk 3ds Max Design 2012 Service Pack 1: 

 Microsoft® Windows® XP Professional (SP2 or higher) operating system  

 Microsoft® Windows® XP Professional x64 (SP2 or higher) operating system  

 Microsoft® Windows Vista® Business (SP2 or higher) operating system  

 Microsoft® Windows Vista® Business x64 (SP2 or higher) operating system  

 Microsoft® Windows® 7 Professional operating system  

 Microsoft® Windows® 7 Professional x64 operating system  

 Mac® operating system: You can run 3ds Max 2012 / 3ds Max Design 2012 Service Pack 1 on a 

Mac® with either Boot Camp® or via Parallels Desktop for Mac, provided certain system 

requirements are met. Refer to the Autodesk 3ds Max 2011 and Autodesk 3ds Max Design 2011 

Installation Guide for further details (found on the product media).  

Autodesk is not responsible for errors or failures of Autodesk software arising from the installation of 

updates, extensions or new releases issued by third-party hardware or software vendors for the 

qualified software or hardware identified in this document (or for any other third-party software or 

hardware that you may use in connection with Autodesk products). 
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Versions of this Service Pack  

Autodesk 3ds Max 2012 32-bit  3dsMax2012_SP1_32-bit_EN.msp 

Autodesk 3ds Max 2012 64-bit  3dsMax2012_SP1_64-bit_EN.msp 

Autodesk 3ds Max Design 2012 32-bit  3dsMaxDesign2012_SP1_32-bit_EN.msp 

Autodesk 3ds Max Design 2012 64-bit  3dsMaxDesign2012_SP1_64-bit_EN.msp 

Install Instructions 

1. Download the appropriate file for your system. See Versions of this Service Pack.  

2. Double-click the corresponding MSP file to launch the installer.  

3. Click Next when prompted.  

4. Click Finish once completed.  

Uninstall Instructions 

Windows XP 

1. Open Start > Settings > Control Panel > Add Or Remove Programs dialog.  

2. Turn on Show Updates at the top of the Add Or Remove Programs dialog.  

3. Select Autodesk 3ds Max 2012 Service Pack 1 / Autodesk 3ds Max Design 2012 Service Pack 1.  

4. Click Remove.  

Windows Vista / Windows 7  

5. Open Start > Control Panel > Programs and Features.  

6. Click View Installed Updates.  

7. Select Autodesk 3ds Max 2012 Service Pack 1 / Autodesk 3ds Max Design 2012 Service Pack 1.  

8. Click Uninstall. 
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