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Overview
Welcome to the Autodesk Toxik 2009 Installation Guide for Windows. Toxik is Autodesk’s 
interactive solution for film compositing. It features a full High Dynamic Range (HDR) 
pipeline, next-generation 3D compositing, high performance interaction at extremely high 
resolutions and advanced rendering. It primarily features a databaseless workflow for data 
management, one Toxik seat, one scripting license, and unlimited rendering capabilities. 

The Toxik seat can be updated with extensions that add functionality to the product by the 
means of new tools and core fixes.

This edition of Toxik is supported on Windows 32 and 64 bit workstations. It uses Python® for 
scripting.

This guide explains how to install Toxik and its software components.

Audience
This document is intended for the person or artist that will be both installing and using the 
Toxik software.

To carry out the installation with ease, you should be familiar with network-ready software and 
network topology issues, license management technology, the Windows operating system, as 
well as the general principles of software installation.



Introduction1

2    

If you are not familiar with the above subjects, note that every effort has been made to ensure a 
smooth installation, whatever your level of experience. If you have difficulties, please contact 
Autodesk technical support.

Autodesk Toxik Components
A complete Toxik installation consists of a number of components.

Toxik Creative Application
The heart of Toxik is the creative application that permits the creation and playback of complex 
compositions, and supports manipulation of compositions in the media player itself.

Toxik License Server
The license server used in Toxik is FLEXnet™ 10.8.2.1. The license server keeps track of what 
components are running, and other licensing details. The license server is optional, and only 
needs to be installed on one machine on the network if needed.

Toxik Portable License Utility
The Portable License Utility is an Autodesk common component that allows a Macrovision, 
SafeCast ™ node-locked license to be transferred between machines or nodes, without 
requiring connection to a network. Effectively disabling the product on the original machine, 
and enabling the product on the destination machine.

Toxik Scripting
Toxik scripting provides Python-based access to Toxik through a command-line interface. 
Scripting provides an effective means of loading plug-ins, browsing the database, managing 
users, projects, media, assets, and so on. It also provides direct access to more sophisticated 
Toxik internals, including control and renderer. Scripts can be saved and executed.

Toxik Configuration
You will install Toxik on one workstation only.

System Requirements
Toxik can be supported by various CPU architectures and operating systems—see “System 
Requirements” on page 40.
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Playback speed in Toxik depends largely upon the ability of your local cache (attached storage) 
to deliver frame data at a high rate—see “Bandwidth Requirements” on page 42, and 
“Supported Graphics Cards” on page 41.

File Requirements
The Toxik Application executable file, and Release Notes.

• Autodesk Toxik 2009 Release Notes (pdf)

• Autodesk Toxik 2009 Installer: Autodesk_Toxik_2009_xxbit.exe

Install the creative application—see “Installing the Software” on page 21.

If you have a License Server you will need the file.

• Autodesk license server file: Autodesk_License_Server_10.8.2.1_xxbit.exe

Install the license server—see “Installing the License Server” on page 13.

NOTE: xx indicates either a 32 or 64 bit operating system.

Documentation and Training
Information and documents in PDF format are available at www.autodesk.com/toxik-
documentation.

Accessing Online Help
Autodesk provides documentation in an HTML help system displayed in a Web browser. The 
help is automatically installed with the software. 

To start help:

Do one of the following:

• From the Toxik menu, choose Help > Toxik Help.

• From the Windows taskbar, choose Start > Programs > Autodesk > Autodesk Toxik 2009 
> Toxik Documentation > Online Help.

The Help appears in a browser window.

Document PDF Online Help

Autodesk Toxik 2009 Release Notes Yes No

Autodesk Toxik 2009 User’s Guide Yes No

Training Format

Autodesk Toxik New Features Videos Macromedia Flash 

http://www.autodesk.com/toxik-documentation
http://www.autodesk.com/toxik-documentation
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Release Notes
Release notes contain important information, including late-breaking information on 
Autodesk Toxik. Be sure to read the release notes before installing or using Toxik.

Documentation Conventions
The following conventions are used in this guide.

Contacting Technical Support
If you need more information, contact Technical Support at: www.autodesk.com/
subscriptionlogin.

Notation Usage

c:\Program Files\Autodesk Commands, Windows file names, and directories 
are written in courier bold.

<version#> Variables, such as system-specific information, are 
enclosed in angle brackets and written in courier 
italics.

http://www.autodesk.com/subscriptionlogin
http://www.autodesk.com/subscriptionlogin
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Overview
This chapter describes what to do and where to find help after you have downloaded the 
distribution files from the Autodesk Subscription Center.

NOTE: It will be helpful to have a utility on-hand to verify that the files downloaded without 

corruption. The distribution provides message digest (.md5) files for this purpose. 

Downloading the Distribution
When you purchase Toxik 2009, you will be advised either on your invoice or by email of your 
account user name and password, which will allow you to login to the Autodesk Subscription 
Center at www.autodesk.com/subscriptionlogin.

Once you have entered the Autodesk Subscription Center, you can download the executable 
files; Toxik 2009 Creative Application, and License Server file. You can store the files in your 
<temp_dir> folder.

To download the distribution from the Autodesk Subscription Center:

1. To access the Autodesk Subscription Center go to this link, www.autodesk.com/
subscriptionlogin.

2. Login to the Autodesk Subscription Center.

http://www.autodesk.com/subscriptionlogin
http://www.autodesk.com/subscriptionlogin
http://www.autodesk.com/subscriptionlogin
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3. Locate the Toxik application, download the distribution and save it in a temporary folder. 

The distribution consists of the following files:

4. Using an appropriate utility, ensure data integrity by creating an MD5 “checksum” for each 
downloaded file and compare it to the message digest value in the corresponding file 
provided.

File Contents

Autodesk_Toxik_2009_xxbit.exe Interactive creative application where you create your 
compositions. 

Autodesk_License_Server_10.8.2.1
_xxbit.exe

License Server program (optional).

.md5 files Message Digest files. Ensures the.zip files were not 
corrupted during the download.
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Technical Assistance  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  8

Installing the Standalone License . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  10

Installing the License Server  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  13

Overview
This chapter explains the licensing methodology for Toxik. You need a Toxik License to 
activate the Toxik 2009 Creative Application. There are three types of licenses: Trial, 
Standalone, and Network.

Trial License
If you install a 30 day trial license, at the end of the trial, Toxik must be activated with a valid 
serial number or you must use a Network License Manger.

Standalone License
If you install a standalone license then you must enter a valid serial number to start Toxik. You 
will need to register your copy of Toxik. If your workflow is on a standalone workstation, then 
you will store the license on the same workstation as the Toxik Creative Application.
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Network License
Your license server must be properly setup before installing Toxik. However, the license server 
is optional, and usually installed on a dedicated network computer.

Technical Assistance
If you have any licensing questions or issues, please address them as follows:

Installing the Trial Mode

Running the trial
If you want to evaluate the Toxik Creative Application, then you may install the license for 30 
days. Once the 30 days are over you will not be able to run the Toxik Creative Application 
unless you purchase the product and provide a valid serial number. This procedure describes 
what you have to do.

1. During the installation of the Toxik Creative Application, a License Type dialog box will 
appear. Select the Trial radio button. Click Next to continue with the installation.

In North America Outside North America

Hours Monday to Friday 8 a.m.–8 p.m. EST (excluding certain holidays).

Phone Toll-free: 1.800.925.6442 
Direct dial: +1.514.954.7199

Direct dial: +1 514.954.7199

E-mail me.licensing@autodesk.com

Licensing Fax +1 514.954.7254
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2. Continue with the installation —see “Installing Toxik” on page 22.

3. When you have finished installing Toxik you will start the application for the first time. You 
will get a reminder screen advising you of how many days you have left for your trial. You 
may run the product until the 30 days has expired. Should you want to continue using 
Toxik you will need to activate it. Click Next.

4. You will be connected to Register Today where you must enter a valid serial number. This 
number will be provided to you when you purchase Toxik from your reseller or Autodesk 
Licensing Authority. Click Next.



Licensing3

10    

5. You will receive your confirmation dialog box informing you of your activation code. You 
may print the information for future reference. Click Finish to complete the license process.

Installing the Standalone License
If you install the standalone license on your computer, the following procedure describes what 
you have to do.
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To install the standalone license:

1. During the installation of the Toxik Creative Application a License Type dialog box will 
appear. Select the Standalone radio button, and enter your unique serial number. Click 
Next to continue with the installation.

2. Continue with the installation —see “Installing Toxik” on page 22.
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3. When you have finished installing Toxik you will start the application for the first time. You 
will get a reminder screen. By default Activate the product is selected. Click Next.

4. To obtain an activation code from Register Today, click Next.

If you already have an activation code provided by your reseller or Autodesk Licensing 
Authority click the Enter an activation code radio button to manually enter it., Click Next.
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5. You will receive a confirmation dialog that Toxik has been registered, click Finish.

Installing the License Server
If you are installing the Autodesk license server you should install it before you install the Toxik 
2009 application. This procedure describes what you have to do.

NOTE: To install the license server for Windows Vista, you will follow the steps below, but because 

of Vista’s new security feature, the license server service will not start automatically, even when the 

installation is successful. You can launch the license server manually by executing the following 

command prompt: Imgrd -z - c “<Path_To_License_Files>”

To install the license server:

1. Log on as System Administrator, and close all running programs.

2. Navigate to the temporary folder where you downloaded the Autodesk auto-extracting 
license file 
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(<temp_dir>\Autodesk_License_Server_10.8.2.1_xxbit.exe) and 
double-click the file.

The installation wizard is started and a welcome dialog appears. Click Next to continue with 
the installation.

3. You are asked to accept the non-disclosure agreement, click Agree, then Next to proceed 
with the installation.
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4. In the Choose Destination Location dialog, accept the default destination or use the Browse 
button to navigate to a new folder where the software will be installed. Click Next to 
continue with the installation.

By default, the Autodesk license server is installed in the following folder:

c:\Program Files\Autodesk\Autodesk License Server 10.8.2.1

5. When the confirmation dialog appears, click Install.
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6. When complete, the license information dialog appears. 

• If you don’t have a valid license file click Launch NLA (Network License Activation) to 
obtain a Network License file, then proceed with the Step 7.

• If you already have a license file you can Browse for it, click open in the browser to provide 
the file path, then click Next. You will go straight to Step 13 to Finish your license 
installation.
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7. If you have chosen to Launch NLA, you have a choice of two radio buttons.

•  Direct connect over the Internet is the default radio button. Click Next to obtain the 
Network License file.

• However, if you do not have an Internet connection you can obtain your network license 
by post, email, fax or phone. Click the radio button and follow the procedure.

8. Enter your unique serial number provided by either the reseller or the Autodesk licensing 
authority, followed by your server host name, then click Lookup to obtain your host ID. 
The Single Server radio button is set by default. Click Next to continue.
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9. The confirm server dialog box appears. Confirm that your information is correct, then click 
Next.

10. The dialog box confirms your license was activated. Click Browse to select the path where 
the license file will be saved. Click Next.

NOTE: Keep your license file in a safe place as you may need it to install or reinstall your license 

server.
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11. You will be informed that your license activation was successful. You can print your 
information for future reference. Click Done to proceed with the installation.

12. Browse for the license file you have just saved in Step 10, then click Next.
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13. The license server will now start. When complete, a confirmation dialog appears. Click 
Finish.

NOTE: The license is written to a file (toxik.lic). By default this is located in 

c:\Program Files\Autodesk\Autodesk License Server 

10.8.2.1\licenses. 
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Overview
You are now ready to install the Toxik 2009 creative application. This chapter describes each 
stage of the installation. It begins by presenting some decisions you must make during the 
installation, and helps you prepare for configuring the software. Next, it presents the step-by-
step procedure for installing the software.

Before You Begin
Before attempting to install the software, it is useful to have an overview of the installation 
process, and to know what will be required of you during the install. You must choose between 
one of two setup types, license type, and set the Media Cache size.

NOTE: You must have system administrator privileges to install Toxik 2009.

Installing the Software
When you run the installation wizard, you will be asked to choose from two main setup options. 
You can install the Toxik Creative Application, or Render Node.

Toxik Creative Application 
Installs the runtime application only. This includes the Toxik (core application), plug-ins 
(browsers, modules, tools, and views), Python scripting, and fonts.
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Toxik Render Node
Installs the rendering feature only which allows you to use a background rendering software like 
Autodesk Backburner to complete your workflow.

NOTE: It is strongly recommended that the Autodesk Toxik media cache have a separate partition, 

and that the partition resides on a disk other that the operating system, ideally on a RAID device. 

For each minute of footage at 2K RGB using 16 bits @ 24fps depth, you will require 40 GB of media 

cache space. The Toxik media cache requires a minimum of 10 GB, while an optimal media cache 

size is suggested at 200GB. However depending on the project, you may want to consider a media 

cache size of 1 terabyte for a high-performance configuration. 

Installing Toxik
Installation of the Toxik Creative Application is accomplished in just several steps using the 
installation wizard.

To install Toxik:

1. Log on as System Administrator and close all running programs.

2. Navigate to the folder where you downloaded the Toxik 2009 executable file 
(<temp_dir>\Autodesk_Toxik_2009_xxbit.exe) and double-click on the 
file.

The installation wizard is launched, and a welcome dialog appears. 

Click Next to continue with the installation.
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3. You are asked to accept the terms of the non-disclosure agreement, click Agree then Next to 
proceed with the installation.

4. In the Setup Type dialog select one of the following options:

• Toxik Creative Application. Installs the Toxik 2009 runtime application, including the 
Python Scripting components.

• Toxik Render Node. Installs the Toxik 2009 render node option on the workstation that will 
be used only as a render node.

Click Next to continue to install the Toxik Creative Application.



Installing Toxik4

24    

5. You are give a choice of three license type options, select the button of your choice.

To get more information about the three license types refer to the Licensing chapter.

• Trial License—see Chapter 3, “Installing the Trial Mode,” on page 8

• Standalone License—see Chapter 3, “Installing the Standalone License,” on page 10

• Network License—see Chapter 3, “Installing the License Server,” on page 13

Click Next to continue.
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6. In the Choose Destination Location dialog, accept the default directory or use the Browse 
button to navigate to a new directory where the software will be installed.

By default, Toxik is installed in the following directory:

c:\Program Files\Autodesk\Autodesk Toxik 2009

Click Next to continue.

7. You are prompted to install the Toxik 2009 Creative Application. Click Install to continue.

The installer will check the Setup Status for your workstation, then complete the 
installation.
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8. Toxik will install Microsoft Visual C++ 2005 Redistributable then direct you to the Ready to 
Install dialog box.

9. If you have selected the Trial or Standalone License Type, go to Step 15.

If you selected the Network option in Step 5, you are prompted to enter the name of the 
License Server in the License Server Information dialog. Enter the name of the machine 
where you installed the license server, for example, @machine_name. 

Be sure to prepend the machine name with the commercial at symbol (@).

Click Next to continue with the installation.
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10. The Media Cache Configuration dialog appears.

In the dialog, enter the location of the media cache.

You are prompted to specify the size or percent of drive dedicated to the media cache. 
Generally speaking, the larger the media cache the better, since this reduces the number of 
reads and writes to the external storage. For best results, put the media cache on the local 
disk with the most available space. Preferably on a different drive to where the Toxik 2009 
Creative Application is installed.

Click Next to continue.
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11. The information is processed and a dialog appears announcing the success and completion 
of the installation. 

Click Finish to complete the installation.

NOTE: Any settings are stored in the program file (toxik.ini) Configuration Setting. The location 

for this file is C:\Program Files\Autodesk\Autodesk Toxik 2009\etc.
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Starting Toxik
Before you can do any work using the Toxik 2009 application, you’ll have to create either a new 
project, choose an existing project or open a recent project. For detailed information on using 
Toxik, refer to the Toxik 2009 User’s Guide in the online help.

To start Toxik:

1. In the Windows Start menu, choose Programs > Autodesk > Autodesk Toxik 2009 > Toxik. 

OR

In Windows Explorer, navigate to Program Files > Autodesk > Autodesk Toxik 2009 > 
Program and double-click toxik.exe. 

The Toxik screen appears.
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2. In the Toxik screen, create a project, select an existing project, or open a recent project, and 
click Open.

3. To check the software version and build number, select Help > About from the menu bar. 

The software version and build number should be Autodesk Toxik 2009 Build #2218.

4. To exit the software, select File > Exit or press CTRL+Q. 
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Overview
This chapter describes what to do, if you decide to uninstall the Toxik 2009 Creative Application 
and its components, and the Autodesk License Server.

NOTE: If you already have another Autodesk product installed on your network that uses the same 

license management technology, you should not uninstall the Autodesk License Server.

Uninstalling Toxik
Uninstalling Toxik 2009 removes all of the Autodesk Toxik 2009 files in the Autodesk Program 
Folder. It also resets Toxik 2009 entries in the system registry, and uninstalls all Toxik 2009 
services. It does not remove user and project preferences, projects, compositions, or remove 
media. 

To uninstall Toxik:

1. Choose Start > Settings > Control Panel.

The Control Panel appears.

2. Double-click Add or Remove Programs.

The Add or Remove Programs dialog appears.
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3. Select Autodesk Toxik 2009, and click Remove.

A confirmation dialog appears. Confirm your choice by clicking Yes.

4. Toxik will be removed from your system.

NOTE: A message may appear asking if you would like to remove “private files” contained in 

the Toxik directory. This message refers to files that were not created by the installation wizard, 

such as log files. Click Yes to remove the files.
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5. Click Finish to uninstall the application.

The Toxik Creative Application has been uninstalled.

Uninstalling the License Server
Uninstalling the License Server removes all the files in the License Server program folder. You 
can optionally choose to leave the license file (toxik.lic) itself. It also resets the License 
Server entries in the system registry and uninstalls all License Server services.

To uninstall the License Server

1. Choose Start > Settings > Control Panel.

The Control Panel appears.

2. Double-click Add or Remove Programs.

The Add or Remove Programs dialog appears.
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3. Select Autodesk License Server 10.8.2.1 and click Remove.

A confirmation dialog appears.

Confirm your choice by clicking Yes.

4. A dialog appears asking if you want to remove the license file, or leave it. Confirm your 
choice by clicking Yes.

NOTE: If you have written your license file in a safe place, you can safely remove it; otherwise 

retain the file for future use.
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5. Once complete, click Finish to complete the uninstall procedure. You must restart your 
computer before reinstalling the Toxik License Server. 
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Overview
This chapter describes how to set up a broadcast monitor for Toxik 2009.

Setting Up a Broadcast Monitor
If your system has the appropriate hardware, you can preview your work on a broadcast video 
monitor. Video previewing is available for Toxik on Windows 32-bit. Autodesk Toxik 2009 
supports the AJA Xena 2K and 2Ke boards. You will need to obtain and install the Xena driver, 
and modify the toxik.ini file to enable video previewing. For more information on the Xena 
boards, see www.aja.com.

To install the Xena driver:

1. Open a web browser and go to: http://www.aja.com/html/support_xena2k_swd.html.

2. Download the appropriate driver for Windows XP 32-bit and follow the instructions for 
installing it.

To modify the toxik.ini file:

1. In a browser window, open the following folder: C:\Program Files\Autodesk\Autodesk 
Toxik 2009\etc.

2. In the \etc folder, double-click the toxik.ini file.

3. Enable the video previewing by removing the “#” symbol which appears in front of:

toxik::videoPreview::pluginsDir C:/Program Files/AJA/

Windows/Plugins/Combustion/4.0

http://www.aja.com/html/support_xena2k_swd.html
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4. Save the changes you made in the toxik.ini file.

For information on previewing your work, see the Managing Projects chapter in the Toxik 
online help.
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Overview
Appendix A contains the Toxik 2009 system requirements, supported graphics cards and 
drivers, and bandwidth requirements, allowed by Toxik.
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System Requirements
Toxik can be supported with the following system requirements.

Playback speed in Toxik depends largely upon the ability of your local cache (attached storage) 
to deliver frame data at a high rate—see “Bandwidth Requirements” on page 42 and 
“Supported Graphics Cards” on page 41.

CPU Architecture

Operating System

Autodesk Toxik Creative and Render Requirements
• 1 GB RAM minimum or more

• CPU 64 bit processor minimum requirement should support 64 bit SSE3 (Streaming SIMD 
Extensions 3)

CPU Autodesk 
License 
Server

Autodesk 
Toxik

Intel® Pentium IV™ single or 
dual processor

o o

Intel® Xeon® EMT-64 single 
or dual processor

o o

Intel Core™ Solo o o

Intel Core 2 Duo o o

AMD Athlon™ 64 FX o o

AMD Athlon 64 X2 Dual Core o o

AMD Athlon Multi-core o o

OS Autodesk 
License 
Server

Autodesk 
Toxik

Windows Vista 32 bits o o

Windows Vista 64bits o o

Windows® XP Pro o o

Windows XP 64 bits o o

Red Hat Enterprise Linux 5, 
64 bits

o o

Red Hat Enterprise Linux 
WS4, Update 6, 64 bits

o o

Fedora 8, 64 bits o o
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• Supported graphics cards—see “Supported Graphics Cards” on page 41

• Three-button mouse or tablet

• Full keyboard

• Monitor with minimum resolution of 1600 x 1200 (recommended resolution 1920 x 1200)

• Network interface

• Media cache requirements:

– 10 GB minimum, 200 GB recommended

– HDD: IDE, SATA, SATA 2, SAS, SCSI

• 375 MB disk space for Autodesk Toxik Creative application

• Web browser with JavaScript and frames enabled (for viewing online help), Firefox is not 
supported as this creates errors when registering

• Adobe® Acrobat Reader (for viewing and printing documentation)

NOTE: Autodesk Toxik does not offer a network installation option.

Supported Graphics Cards
Toxik supports all the high-end Nvidia Quadro FX series graphic cards.

Graphics Card Windows Driver Linux Driver

NVIDIA Quadro FX5600 169.96 173.14.12

NVIDIA Quadro FX4600 169.96 173.14.12

NVIDIA Quadro FX4500 169.96 173.14.12

NVIDIA Quadro FX4400 169.96 173.14.12

NVIDIA Quadro FX4000 169.96 173.14.12

NVIDIA Quadro FX3700 169.96 173.14.12

NVIDIA Quadro FX3500 169.96 173.14.12

NVIDIA Quadro FX3450 169.96 173.14.12

NVIDIA Quadro FX3400 169.96 173.14.12

NVIDIA Quadro FX3000 169.96 173.14.12

NVIDIA Quadro FX2000 169.96 173.14.12

NVIDIA Quadro FX1400 169.96 173.14.12

NVIDIA Quadro FX1300 169.96 173.14.12

NVIDIA Quadro FX1100 169.96 173.14.12

NVIDIA Quadro FX1000 169.96 173.14.12

NVIDIA Quadro FX700 169.96 173.14.12
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Bandwidth Requirements
The following chart shows the bandwidth requirements in megabytes per second (MB/s) for 
playback of media of different formats. To ensure fast playback in Toxik, your attached storage, 
the local cache, must meet or exceed the bandwidth requirements of the desired format. 
Otherwise, Toxik will not receive the frames quickly enough. In the chart, “2K” refers to a full-
aperture film image; that is, a 2048 x 1556 pixel RGB image.

NOTE: Toxik only stores images at three different pixel depths: 8-bit (int), 16-bit (half-float) and 32-

bit (float). Any other formats are converted to the optimal format without losing any precision.

To calculate the bandwidth requirements for other formats, use the following formula:

For example, a “2K” 16-bit, 35mm Full Aperture 2K image results in the following calculation:

NVIDIA Quadro FX500 169.96 173.14.12

ATI Fire GL V3600 8.443.1 ---

ATI Fire GL V7350 8.443.1 ---

ATI Fire GL V5600 8.443.1 ---

ATI Fire GL V7600 8.443.1 ---

ATI Fire GL V8600 8.443.1 ---

Graphics Card Windows Driver Linux Driver

horizontal res. x vert res. x frames/second x channels/pixel x bytes/channel

1024 x 1024
Bandwidth (MB/second) =
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2048 x 1556 x 24 x 3x 2

1024 x 1024
Bandwidth (MB/second) =  = 437.63
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