El uso del Activador de objeto de AutoCAD Civil para datos de objetos de Civil 3D 2009

Uso del Activador de objeto de Civil para datos de objetos de AutoCAD Civil 3D 2009

El Activador de objeto de AutoCAD Civil le permite acceder a los datos de objetos de Civil de AutoCAD Civil 3D 2009 y AutoCAD Land Desktop 2009 en aplicaciones basadas en AutoCAD 2009 sin tener los productos instalados en su equipo.

NotaEl Activador de objeto de AutoCAD Civil se puede utilizar con AutoCAD Civil 3D 2009 y AutoCAD Land Desktop 2009.

Los objetos de Civil se pueden activar en los siguientes productos de Autodesk:

  • AutoCAD 2009
  • AutoCAD Mechanical 2009
  • AutoCAD Architecture 2009
  • AutoCAD MEP 2009
  • AutoCAD Map 3D 2009
  • AutoCAD Electrical 2009
  • Autodesk 3ds Max Design 2009
  • Autodesk 3ds Max 2009
  • Autodesk NavisWorks Manage 2009
  • Autodesk NavisWorks Review 2009
  • Autodesk NavisWorks Simulate 2009
  • Autodesk Impression 2009

Para versiones anteriores de estos productos, consulte http://www.autodesk.com/aecobjenabler para saber cuál es la versión que debe descargar.

Temas de esta sección

  • Uso del Activador de objeto de Civil para datos de objetos de AutoCAD Civil 3D 2009

    El Activador de objeto de Civil es una aplicación gratuita que puede utilizar para acceder a los archivos de dibujo de AutoCAD Civil 3D 2009. Esta versión permite acceder a los datos de objeto creados en AutoCAD Civil 3D 2009 fuera del entorno de AutoCAD Civil 3D 2009.

  • Acceso e instalación del Activador de objeto de Civil

    El Activador de objeto de Civil está disponible en los medios del producto de AutoCAD Civil 3D 2009 y en el sitio Web de Autodesk.

  • Tipos de objetos creados con AutoCAD Civil 3D

    AutoCAD Civil 3D 2009 crea muchos tipos diferentes de objetos gráficos personalizados.

  • El uso del Administrador de propiedades de objeto en una sesión de AutoCAD 2008 activada

    Puede visualizar cierta información sobre los objetos de AutoCAD Civil 3D en la ventana Propiedades de objeto de AutoCAD.

  • Comandos de AutoCAD admitidos

    Todos los objetos de AutoCAD Civil 3D admiten los comandos LIST, DESCOMP y BORRA. La lista de comandos del Activador de objeto se comporta de la misma forma que la lista de comandos de AutoCAD Civil 3D.

  • Descomposición de objetos de AutoCAD Civil 3D

    Utilice el comando Exportar a AutoCAD para crear un nuevo dibujo en formato de AutoCAD 2004 o 2000 con todos los objetos de Civil descompuestos. El dibujo original no se ve afectado. Hay dos formas de descomponer: utilizar el comando DESCOMP o exportar como se describe abajo.

  • Preguntas más frecuentes

    En los temas siguientes se tratan las preguntas sobre la instalación y el uso del Activador de objeto.

Envíenos sus comentarios sobre esta página


Uso del Activador de objeto de Civil para datos de objetos de AutoCAD Civil 3D 2009

Acceso e instalación del Activador de objeto de Civil
Uso del Activador de objeto de Civil para datos de objetos de AutoCAD Civil 3D 2009

El Activador de objeto de Civil es una aplicación gratuita que puede utilizar para acceder a los archivos de dibujo de AutoCAD Civil 3D 2009. Esta versión permite acceder a los datos de objeto creados en AutoCAD Civil 3D 2009 fuera del entorno de AutoCAD Civil 3D 2009.

Por ejemplo, si la mitad de sus puestos de AutoCAD son de AutoCAD 2009 y la otra mitad son de AutoCAD Civil 3D 2009, aquellas personas que utilicen AutoCAD 2009 pueden instalar el Activador de objeto de Civil. Tras instalar el Activador de objeto de Civil, podrán abrir dibujos creados en AutoCAD Civil 3D 2009, así como ver, trazar, manipular y copiar los objetos personalizados.

Si no tiene este activador instalado, puede compartir dibujos utilizando gráficos proxy. Los gráficos proxy ofrecen un medio alternativo de visualización de objetos usando representaciones gráficas sencillas. Los objetos representados como gráficos proxy carecen de la ''inteligencia'' completa de los objetos reales. Los gráficos proxy también aumentan el tamaño del dibujo. AutoCAD usa este mecanismo para conseguir compatibilidad con archivos DWG si la aplicación personalizada no está cargada.

Establezca el parámetro de dibujo PROXYGRAPHICS en 1 para guardar los gráficos con el dibujo; de lo contrario se muestra un “cuadro delimitador” donde está situado el objeto cuando se abre con el Activador de objeto.

La instalación del Activador de objeto de Civil en cualquier producto basado en AutoCAD 2009 permite lo siguiente:

  • Compatibilidad de la lista de AutoCAD y borra comandos en objetos de Civil
  • Referencia a puntos en objetos de Civil (para poder usar referencias a objetos y rastreo a objetos)
  • Edición mediante pinzamientos de etiquetas
  • Compatibilidad con la visualización de ciertos tipos de objetos de Civil en la Paleta de propiedades de objetos de AutoCAD

Fidelidad visual

El aspecto de los objetos de Civil de AutoCAD Civil 3D se controla mediante estilos, que pueden tener distintos valores de configuración para ver los objetos en vistas 2D y 3D. El Activador de objeto de Civil respeta estos valores de configuración. Por ejemplo, una superficie configurada para mostrar únicamente curvas de nivel en 3D sólo mostrará dichas curvas cuando se visualice en 3D en una sesión de AutoCAD activada.

Fidelidad de las capas

Los estilos de objetos de Civil de AutoCAD Civil 3D se pueden configurar para que el aspecto de los objetos pueda controlarse mediante la manipulación de capas. Si la configuración de estilo de un objeto, como el color y el grosor de línea, está establecida en PORCAPA, puede hacer lo siguiente en una sesión de AutoCAD activada:

  • Cambiar la configuración de capa del objeto y de capa de subcomponentes del objeto para actualizar la visualización del objeto
  • Activar o desactivar las capas o inutilizarlas o reutilizarlas para cambiar la visibilidad del objeto

Si la configuración de capa del estilo del objeto está establecida en PORBLOQUE, el cambio de la capa del objeto en una sesión de AutoCAD activada cambiará la visualización del objeto y de sus subcomponentes de forma acorde.


Acceso e instalación del Activador de objeto de Civil

Uso del Activador de objeto de Civil para datos de objetos de AutoCAD Civil 3D 2009
El uso del Activador de objeto de AutoCAD Civil para datos de objetos de Civil 3D 2009
Tipos de objetos creados con AutoCAD Civil 3D
Acceso e instalación del Activador de objeto de Civil

El Activador de objeto de Civil está disponible en los medios del producto de AutoCAD Civil 3D 2009 y en el sitio Web de Autodesk.

Consulte las instrucciones que aparecen más abajo para instalar el Activador de objeto de Civil desde los medios del producto. Además, también puede descargar la versión más actual desde el sitio web de Autodesk, en http://www.autodesk.com/aecobjenabler

Instalación del Activador de objeto de Civil

  1. Inserte los medios de producto de AutoCAD Civil 3D 2009 en la unidad de medios del equipo.
  2. En el Asistente de instalación de AutoCAD Civil 3D 2009, haga clic en el vínculo Instalar.
  3. En la página Instalar, haga clic en Instalar las herramientas complementarias. A continuación, haga clic en Activador de objeto y siga las instrucciones de la pantalla.
  4. Si el programa se lo pide, reinicie el equipo.


Tipos de objetos creados con AutoCAD Civil 3D

Acceso e instalación del Activador de objeto de Civil
El uso del Administrador de propiedades de objeto en una sesión de AutoCAD 2008 activada
Tipos de objetos creados con AutoCAD Civil 3D

AutoCAD Civil 3D 2009 crea muchos tipos diferentes de objetos gráficos personalizados.

Entre ellos se incluyen los siguientes:

  • Superficie
  • Línea de etiqueta de curva de nivel
  • Punto
  • Grupo de puntos
  • Tablas
  • Alineación
  • Obra lineal
  • Ensamblaje
  • Subensamblaje
  • Estructura y tubería (plano)
  • Estructura y tubería (vista de perfil)
  • Estructura y tubería (vista en sección)
  • Interferencia de red de tuberías
  • Área de parcela
  • Segmentos de parcela
  • Emplazamiento
  • Explanación
  • Perfil
  • Visualización del perfil
  • Línea de muestreo
  • Sección de superficie
  • Sección de material
  • Vista en sección
  • Plano de vista en sección
  • Figura de topografía
  • Red de topografía
  • Marco de visualización
  • Línea de intersección
  • Etiquetas sencillas
  • Etiquetas de grupo
  • Línea de diagrama de masas
  • Vista de diagrama de masas

El Activador de objeto de Civil permite ver estos objetos y sus etiquetas asociadas en una sesión de AutoCAD 2009 activada.


El uso del Administrador de propiedades de objeto en una sesión de AutoCAD 2008 activada

Tipos de objetos creados con AutoCAD Civil 3D
Comandos de AutoCAD admitidos
El uso del Administrador de propiedades de objeto en una sesión de AutoCAD 2008 activada

Puede visualizar cierta información sobre los objetos de AutoCAD Civil 3D en la ventana Propiedades de objeto de AutoCAD.

Utilice el comando Modificar [image] Propiedades o haga clic con el botón derecho del ratón en un objeto y seleccione Propiedades para abrir la ventana Propiedades. Si usa la ventana Propiedades en una sesión de AutoCAD activada, podrá cambiar algunas propiedades de AutoCAD.


Comandos de AutoCAD admitidos

El uso del Administrador de propiedades de objeto en una sesión de AutoCAD 2008 activada
El uso del Activador de objeto de AutoCAD Civil para datos de objetos de Civil 3D 2009
Descomposición de objetos de AutoCAD Civil 3D
Comandos de AutoCAD admitidos

Todos los objetos de AutoCAD Civil 3D admiten los comandos LIST, DESCOMP y BORRA. La lista de comandos del Activador de objeto se comporta de la misma forma que la lista de comandos de AutoCAD Civil 3D.

La mayoría de objetos de AutoCAD Civil 3D admiten otros comandos. Estos comandos incluyen COPIA, DESPLAZA, SIMETRIA, DESFASE, ESCALA, BLOQUE/BLOQUEDISC, GIRA, RECORTA Y ALARGA.

La siguiente tabla enumera información adicional sobre la operación de comandos en algunos objetos y los resultados.

NotaSe puede obtener el comportamiento de “Copia” introduciendo COPIA en la línea de comando o mediante el comando Herramientas Modificar básicas [image] Copiar del menú contextual. Se puede obtener el comportamiento de “Bloque/Bloquedisc” mediante los comandos Portapapeles [image] Copiar o Portapapeles [image] Copiar con punto base del menú contextual, pulsando Ctrl+C o introduciendo BLOQUEDISC en la línea de comando.

Notas de comandos de AutoCAD admitidos

Superficie

Si se borra o se descompone la superficie, los perfiles y las secciones que hacen referencia a dicha superficie se convierten en estáticos.

SIMETRIA creará una copia pero no respetará la configuración de simetría.

Los grupos de puntos utilizados en la definición de la superficie se incluyen como parte del comando BLOQUEDISC.

Punto

Al ejecutar BLOQUEDISC en puntos e insertar o copiar puntos, aparece un cuadro de diálogo que permite resolver los conflictos de número.

Tabla

Al ejecutar BLOQUEDISC en una tabla también se copia la geometría necesaria. Por ejemplo, se copian los puntos de la tabla de puntos.

Alineación

Al descomponer o borrar una alineación, la acción se extiende a todos los objetos dependientes de la alineación (como perfiles, visualizaciones del perfil, líneas de muestreo, secciones y vistas en sección).

La copia de la alineación creará una alineación con un nombre nuevo en el mismo emplazamiento. Todos los objetos dependientes se copiarán e incluirán en la nueva alineación.

BLOQUEDISC/INSERT copiará la alineación y todos los objetos dependientes en un emplazamiento nuevo.

Parcela (seleccionar etiqueta de parcela)

Al ejecutar BLOQUEDISC en una parcela o copiarla, se incluyen los segmentos de parcela dependientes. Si los objetos se insertan en el mismo dibujo, se crea un nuevo emplazamiento.

Sólo se pueden desplazar las etiquetas de parcela.

Líneas de segmento de parcela

Al ejecutar BLOQUEDISC en líneas de segmento de parcela o insertar dichas líneas, se crean líneas de segmento en un emplazamiento nuevo.

Explanación

Sobre un objeto de explanación se pueden realizar dos operaciones de copia distintas. La copia de la línea característica de huella o línea de objetivo individual crea una línea característica nueva en un emplazamiento nuevo. Si se copia todo el objeto de explanación, también se copia la huella, el objetivo y los criterios.

La huella se puede desplazar. La línea de objetivo no se puede desplazar.

Si los criterios de explanación hacen referencia a una superficie, ésta se incluirá en las operaciones de BLOQUEDISC/INSERT.

Perfil

Al borrar un perfil o sección, también se borra de todas las visualizaciones de perfil o vistas en sección.

Los perfiles y las secciones sólo se pueden desplazar verticalmente en una vista.

Visualización del perfil

Si se ejecuta BLOQUEDISC en un perfil o visualización del perfil, se copiarán todos los objetos necesarios para el perfil o la visualización (como la superficie, la alineación, el perfil, las líneas de muestreo y las secciones). Si se copian los objetos en el mismo dibujo, se creará un emplazamiento nuevo.

Línea de muestreo

No se puede mover o copiar una línea de muestreo.

Sección

Al borrar un perfil o sección, también se borra de todas las visualizaciones de perfil o vistas en sección.

Los perfiles y las secciones sólo se pueden desplazar verticalmente en una vista.

Si se ejecuta BLOQUEDISC en la línea de muestreo, sección o vista en sección, se copiarán todos los objetos éstas requieran (como la superficie, la alineación, las secciones y las líneas de muestreo). Si se copian los objetos en el mismo dibujo, se creará un emplazamiento nuevo.

Ensamblaje

Los nombres de ensamblajes y subensamblajes muestran un incremento cuando se copian. Al copiar un ensamblaje se copia tanto ensamblaje como todos los subensamblajes dependientes.

SIMETRIA creará una copia pero no respetará la configuración de simetría.

Obra lineal

Al ejecutar BLOQUEDISC en una obra lineal o copiar dicha obra, también se copian todos los datos dependientes como ensamblajes, alineaciones y superficies.

Red de tuberías

Los objetos de red no son accesibles a través del entorno del Activador de objeto.

Tubería

Al copiar un perfil de pieza de la red se creará una copia de la pieza de la red principal (tubería o estructura).

Estructura

El crear copias, imágenes simétricas, matrices o desfases de tuberías y estructuras se actualizan las referencias de cualquier pieza conectada.

Las tuberías y estructuras copiadas se ubicarán en la misma red.

Al desplazar o girar una estructura también se desplazan las piezas conectadas (se mantienen las conexiones).

Al desplazar o girar una tubería se rompe la conexión con las piezas conectadas.

El ajuste de la escala de una tubería o estructura afecta a la posición pero no al tamaño.

Usar BLOQUEDISC con tuberías y estructuras copia todos los objetos dependientes.

Red de topografía

El uso del comando copiar en una red de topografía crea líneas característica. El comando mover desasocia la figura del modelo.

Figura de topografía

El uso del comando desfase en una figura de topografía genera un objeto de línea característica, no una figura de topografía.

El comando Desplaza anula la asociación de la figura al modelo.

Línea de diagrama de masas

El uso del comando descomponer conserva la configuración de capa y visualización, de modo que las entidades aparecen exactamente tal como estaban en el objeto, a excepción de los objetos a los que se ha asignado color “PorBloque”.

Con el comando Alarga, se puede seleccionar el objeto como un borde al que alargar, pero no se puede seleccionar para alargar.

Con el comando RECORTA, el objeto puede seleccionarse como arista de recorte, pero no puede recortarse.

Si el diagrama de masas es BLOQUEDISC, se copiarán todos los objetos necesarios para él. BLOQUEDISC/INSERT se utiliza cuando el usuario teclea ^C y ^V.

Vista de diagrama de masas

Se asigna automáticamente nombre a las vistas siguiendo el criterio “Nombre existente” (#), donde # es un número que se va incrementando. Si se detecta un conflicto, se utiliza el siguiente número.

El comando copiar o “Copiar selección” en el botón derecho crea una copia de la vista con un nombre de “Nombre existente” (#), donde # es un número que se va incrementando.

El comando descomponer conserva la configuración de capa y visualización, de modo que las entidades aparecen exactamente tal como estaban en el objeto, a excepción de los objetos a los que se ha asignado color "PorBloque". Cuando se descompone la vista no se descompone la línea del diagrama.

El comando simetría funciona bien en una visualización, pero no respeta la configuración de simetría. Obtendrá una copia adicional de la visualización del perfil.

Si se ha utilizado BLOQUEDISC en la vista, se copiarán todos los objetos necesarios para la vista. BLOQUEDISC/INSERT se utiliza cuando el usuario teclea ^C y ^V.


Descomposición de objetos de AutoCAD Civil 3D

Comandos de AutoCAD admitidos
Preguntas más frecuentes
Descomposición de objetos de AutoCAD Civil 3D

Utilice el comando Exportar a AutoCAD para crear un nuevo dibujo en formato de AutoCAD 2004 o 2000 con todos los objetos de Civil descompuestos. El dibujo original no se ve afectado. Hay dos formas de descomponer: utilizar el comando DESCOMP o exportar como se describe abajo.

Para descomponer objetos de AutoCAD Civil 3D en una sesión de AutoCAD activada

  1. Escriba -AecExportToAutoCAD en la línea de comando de una sesión de AutoCAD activada con el Activador de objeto. Se muestra la siguiente solicitud:

    Opciones de importación [Formato/Unir/Tipo de unión/Prefijo/Sufijo/?] <Intro para nombre de archivo>:

  2. Introduzca F para ver las opciones de formato y, a continuación, especifique el formato de archivo.
  3. Introduzca U para especificar si desea unir referencias externas. Introduzca Sí o No.
  4. Introduzca T para especificar el tipo de unión. Introduzca Unir o Insertar.

    El método Unir conserva las identidades de las referencias externas como, por ejemplo, los nombres de capa. El método Insertar une las referencias externas al dibujo actual de forma similar a lo que ocurre al desenlazar e insertar el dibujo de referencia.

  5. Introduzca P para especificar un prefijo de archivo y, a continuación, introduzca el prefijo.
  6. Introduzca S para especificar un sufijo de archivo y, a continuación, introduzca el sufijo.
  7. Introduzca ? para revisar la configuración que ha especificado.
  8. Una vez que haya terminado de especificar la configuración, pulse Intro en el mensaje <Intro para nombre de archivo>: y, a continuación, especifique un nombre de archivo con la ruta incluida. Introduzca, por ejemplo, C:\Mis documentos\ACAD-Drawing1.dwg.

    El archivo se guarda en la ubicación especificada.


Preguntas más frecuentes

Descomposición de objetos de AutoCAD Civil 3D
Preguntas más frecuentes

En los temas siguientes se tratan las preguntas sobre la instalación y el uso del Activador de objeto.

NotaLa información más reciente acerca de Activadores de objeto se encuentra en http://www.autodesk.com/aecobjenabler

¿Qué es el Activador de objeto de Civil?

El Activador de objeto de Civil es una utilidad que permite a los clientes de productos basados en AutoCAD 2009 ver y editar de forma limitada objetos de AutoCAD Civil 3D. Con el Activador de objeto de Civil, cualquier usuario de estos productos basados en AutoCAD 2009 puede disfrutar de una compatibilidad completa con objetos de AutoCAD Civil 3D.

¿Se puede instalar el Activador de objeto de Civil en una versión de AutoCAD anterior a la 2009?

No. El Activador de objeto de Civil sólo se puede instalar en productos basados en AutoCAD 2009.

¿Tengo que instalar el Activador de objeto de Civil para ver dibujos de AutoCAD Civil 3D en aplicaciones basadas en AutoCAD?

No. El mecanismo de gráficos proxy de AutoCAD (a partir de AutoCAD R13) permite ver objetos de AutoCAD Civil 3D en AutoCAD o en otros productos de Autodesk que puedan leer archivos de dibujo. Asegúrese de activar los gráficos proxy antes de guardar los dibujos en Civil 3D.

¿En qué se diferencia el Activador de objeto de Civil de los gráficos proxy?

El Activador de objeto de Civil no reemplaza el mecanismo de interoperabilidad de gráficos proxy. Los gráficos proxy siguen siendo un valioso "denominador común" de la interoperabilidad en toda la línea de productos de Autodesk. El Activador de objeto de Civil ofrece un nivel de compatibilidad más sólido para los usuarios de AutoCAD.

¿Cómo se utiliza el Activador de objeto de Civil?

Una vez instalado, el Activador de objeto de Civil funciona automáticamente con la configuración existente de AutoCAD. Si abre un archivo de dibujo que contenga objetos de AutoCAD Civil 3D, éstos estarán "activos" y podrá editarlos directamente usando comandos de AutoCAD. No hay menús, barras de herramientas ni características de la línea de comandos. La fortaleza del Activador de objeto de Civil reside en la capacidad de usar comandos de AutoCAD existentes y familiares para el usuario en objetos de AutoCAD Civil 3D sin tener que aprender ninguna funcionalidad nueva.

¿Puedo crear objetos inteligentes con el Activador de objeto de Civil en AutoCAD 2009?

No hay comandos para crear objetos nuevos mediante AutoCAD 2009 y el Activador de objeto de Civil. Sin embargo, la mayoría de objetos permite copiar objetos existentes y éstos mantienen su inteligencia.

¿Cómo se instala el Activador de objeto de Civil?

El Activador de objeto de Civil está disponible en los medios del producto. Además, puede descargar la versión más actual desde el sitio web de Autodesk, en http://www.autodesk.com/aecobjenabler

¿Cómo se puede distribuir la instalación del Activador de objeto de Civil?

El Activador de objeto de Civil es una aplicación gratuita que puede distribuir a cualquier persona que desee ver sus dibujos. No obstante, si sólo dispone del Activador de objeto de Civil, no puede visualizar los dibujos. Debe tener instalada una copia de AutoCAD 2009 o un producto basado en AutoCAD 2009.

¿Cómo se puede comprobar que el Activador de objeto de Civil está instalado correctamente?

Al instalar el Activador de objeto de Civil, éste se añade a la lista Agregar o quitar programas del Panel de control de Windows.

¿Hay alguna variable de AutoCAD que afecte al Activador de objeto de Civil?

Al utilizar el Activador de objeto de Civil, se recomienda usar la opción Detección de objeto y ejecución de comando en Opciones de AutoCAD.

Para seleccionar la opción Detección de objetos y ejecución de comandos

  1. Escriba OPCIONES en el símbolo del sistema de AutoCAD para mostrar el cuadro de diálogo Opciones de AutoCAD.
  2. Haga clic en la ficha Abrir y guardar.
  3. En Aplicaciones ObjectARX y Aplicaciones ObjectARX de carga a petición, seleccione Detección de objetos y ejecución de comandos.

Esta opción busca si hay objetos personalizados en un dibujo y carga la aplicación ARX/DBX principal.

NotaCuando quiera utilizar el Activador de objeto para ver objetos personalizados, establezca la opción Solicitar carga de aplic. ObjectARX en Detección personalizada de objetos (1) o Detección de objeto y ejecución de comando (3).


Comentarios

Mediante este formulario podrá enviar sus comentarios al grupo Autodesk Technical Publications, responsable de la publicación de esta documentación.

Título del tema y ubicación (sin modificar):
Nombre (opcional):
         Correo electrónico (opcional):
Comentarios:

Nota: este formulario no se ha creado para que usted reciba comentarios o asistencia técnica. La información que nos proporcione se utilizará para mejorar las próximas actualizaciones que se lleven a cabo en la documentación. ¡Gracias!