AutoCAD Civil 3D Object Enabler を使用して AutoCAD Civil 3D 2009 オブジェクト データにアクセスする

AutoCAD Civil 3D Object Enabler を使用すると、AutoCAD Civil 3D 2009 をインストールしなくても、AutoCAD 2009 ベースのアプリケーションで各製品の Civil オブジェクト データにアクセスすることができます。

注:AutoCAD Civil 3D Object Enabler は、AutoCAD Civil 3D 2009 と AutoCAD Land Desktop 2009 (日本語版未発売)のどちらでも使用できます。

Civil オブジェクトは、次のオートデスク製品で使用できるようになります。

  • AutoCAD 2009
  • AutoCAD Mechanical 2009
  • AutoCAD Architecture 2009
  • AutoCAD MEP 2009
  • AutoCAD Map 3D 2009
  • AutoCAD Electrical 2009
  • Autodesk 3ds Max Design 2009
  • Autodesk 3ds Max 2009
  • Autodesk NavisWorks Manage 2009
  • Autodesk NavisWorks Review 2009
  • Autodesk NavisWorks Simulate 2009
  • Autodesk Impression 2009

上記バージョン以前の製品については、Web サイト http://www.autodesk.co.jp/oe から Object Enabler の適切なバージョンをダウンロードしてください。

このセクションの内容

  • AutoCAD Civil 3D Object Enabler を使用して AutoCAD Civil 3D 2009 オブジェクト データにアクセスする

    AutoCAD Civil 3D Object Enabler はフリーウェアのアプリケーションで、これを使用して AutoCAD Civil 3D 2009 の図面ファイルにアクセスすることができます。 今回のリリースにより、AutoCAD Civil 3D 2009 で作成されたオブジェクト データに AutoCAD Civil 3D 2009 環境の以外でもアクセスできるようになります。

  • AutoCAD Civil 3D Object Enabler の入手とインストール

    AutoCAD Civil 3D Object Enabler は、AutoCAD Civil 3D 2009 製品のインストール メディアの他に、オートデスクの Web サイトから入手することもできます。

  • AutoCAD Civil 3D で作成されるオブジェクトの種類

    AutoCAD Civil 3D 2009 では、さまざまな種類のカスタム グラフィカル オブジェクトを作成できます。

  • 有効な AutoCAD セッションで[オブジェクト プロパティ管理]を使用する

    [AutoCAD オブジェクト プロパティ]ウィンドウで、AutoCAD Civil 3D オブジェクトの情報を表示することができます。

  • サポートされる AutoCAD コマンド

    AutoCAD Civil 3D のすべてのオブジェクトで、AutoCAD の[リスト]、[分解]、[削除]のコマンドを使用することができます。 AutoCAD Civil 3D Object Enabler の[リスト]コマンドは、 AutoCAD Civil 3D の[リスト]コマンドと同じ機能です。

  • AutoCAD Civil 3D オブジェクトを分解する

    [AutoCAD 2004 形式に書き出す]コマンドを使用すると、Civil オブジェクトが分解された状態で、新しい AutoCAD 2004 または 2000 形式の図面が作成されます。元の図面は影響を受けません。[分解]の方法には、(1)[分解]コマンドを使用する、(2)以下の方法で書き出しを行う、という 2 つの方法があります。

  • よくある質問

    AutoCAD Civil 3D Object Enabler のインストールと使用法に関する質問は、次のトピックで扱います。

このトピックについてのコメントをお送りください


AutoCAD Civil 3D Object Enabler の入手とインストール

AutoCAD Civil 3D Object Enabler はフリーウェアのアプリケーションで、これを使用して AutoCAD Civil 3D 2009 の図面ファイルにアクセスすることができます。 今回のリリースにより、AutoCAD Civil 3D 2009 で作成されたオブジェクト データに AutoCAD Civil 3D 2009 環境の以外でもアクセスできるようになります。

たとえば、AutoCAD のライセンス シートの半数が AutoCAD 2009 で、残り半分が AutoCAD Civil 3D 2009 の場合、AutoCAD 2009 を使用しているユーザは AutoCAD Civil 3D Object Enabler をインストールすることができます。 AutoCAD Civil 3D Object Enabler をインストールすると、AutoCAD Civil 3D 2009 で作成した図面を開くことが可能になり、カスタム オブジェクトの表示、印刷、操作、およびコピーが可能になります。

AutoCAD Civil 3D Object Enabler をインストールしていなくても、プロキシ グラフィックスを使用して図面を共有することができます。 プロキシ グラフィックスは簡単なグラフィックス表示を使用してオブジェクトを表示する代替手段を提供します。プロキシ グラフィックスとして表示されるオブジェクトは、実際のオブジェクトほど高度な情報は表示できません。さらに、プロキシ グラフィックスでは図面サイズが大きくなります。AutoCAD は、カスタム アプリケーションがロードされていない場合、DWG ファイル互換性のために、このメカニズムを使用します。

PROXYGRAPHICS 図面設定を 1 に設定すると、図面にグラフィックスを保存することができます。それ以外に設定すると、Object Enabler で開いた際、オブジェクトの位置に「境界ボックス」が表示されます。

AutoCAD Civil 3D Object Enabler を AutoCAD 2009 製品にインストールすると、次の機能が使用できるようになります。

  • Civil オブジェクトに対する AutoCAD の[リスト]、[削除]のコマンドをサポート
  • Civil オブジェクト上のポイントをスナップ([オブジェクト スナップ]および[オブジェクト トラッキング]が使用可能になる)
  • ラベルをグリップ編集
  • AutoCAD オブジェクト プロパティ パレットに特定の種類の Civil オブジェクトを表示する機能をサポート

外観の設定を重視

AutoCAD Civil 3D Civil オブジェクトの外観は、スタイルによって左右され、2D および 3D 表示でオブジェクトを表示する際の設定を複数持つことができます。AutoCAD Civil 3D Object Enabler ではこれらの設定が考慮されるため、たとえば、3D で輪郭だけを表示するように設定されたサーフェスは、有効な AutoCAD セッションで 3D 表示するとき、輪郭だけが表示されます。

レイヤの設定を重視

AutoCAD Civil 3D Civil オブジェクト スタイルは、オブジェクトの外観がレイヤ操作によってコントロールされるように設定することができます。色や線の太さなど、オブジェクトスタイル設定が BYLAYER に設定されている場合は、有効な AutoCAD セッションで次の操作を実行することができます。

  • オブジェクトのレイヤとオブジェクトのサブコンポーネントのレイヤ設定を変更してオブジェクト表示を更新
  • レイヤをオン/オフあるいはレイヤをフリーズ/フリーズ解除してオブジェクトの表示を変更

オブジェクト スタイルのレイヤ設定が BYBLOCK に設定されている場合、有効な AutoCAD セッションでオブジェクトのレイヤを変えると、オブジェクトの表示が変わり、それに応じてサブコンポーネントも変わります。


AutoCAD Civil 3D Object Enabler の入手とインストール

AutoCAD Civil 3D で作成されるオブジェクトの種類
AutoCAD Civil 3D Object Enabler の入手とインストール

AutoCAD Civil 3D Object Enabler は、AutoCAD Civil 3D 2009 製品のインストール メディアの他に、オートデスクの Web サイトから入手することもできます。

製品メディアから AutoCAD Civil 3D Object Enabler をインストールする場合は、次のインストール手順を参照してください。 最新のバージョンは、オートデスクの Web サイト http://www.autodesk.co.jp/oe からダウンロードできます。

AutoCAD Civil 3D Object Enabler をインストールするには

  1. AutoCAD Civil 3D 2009 メディアを、お使いのコンピュータの対応するドライブに挿入します。
  2. AutoCAD Civil 3D 2009 インストール ウィザードで、[ツールとユーティリティのインストール]をクリックします。
  3. [インストールする製品を選択]で AutoCAD Civil 3D Object Enabler を選択します。[次へ]をクリックし、画面の指示に従ってインストールを行います。
  4. 再起動のためのメッセージが表示された場合は、コンピュータを再起動してください。


AutoCAD Civil 3D で作成されるオブジェクトの種類

AutoCAD Civil 3D Object Enabler の入手とインストール
有効な AutoCAD セッションで[オブジェクト プロパティ管理]を使用する
AutoCAD Civil 3D で作成されるオブジェクトの種類

AutoCAD Civil 3D 2009 では、さまざまな種類のカスタム グラフィカル オブジェクトを作成できます。

次のようなものがあります。

  • サーフェス
  • 等高線ラベルの線
  • ポイント
  • ポイント グループ
  • テーブル
  • 線形
  • コリドー
  • アセンブリ
  • サブアセンブリ
  • パイプおよび構造物(平面)
  • パイプおよび構造物(縦断ビュー)
  • パイプおよび構造物(横断ビュー)
  • パイプ ネットワークの干渉
  • 区画面積
  • 区画セグメント
  • サイト
  • グレーディング
  • 縦断
  • 縦断ビュー
  • 横断抽出ライン
  • サーフェス横断
  • マテリアル横断
  • 横断ビュー
  • 横断ビュー シート
  • 測量図形
  • 測量ネットワーク
  • ビュー フレーム
  • マッチ ライン
  • シングル ラベル
  • グループ ラベル
  • マス カーブ ライン
  • マス カーブ ビュー

AutoCAD Civil 3D Object Enabler によって、これらのオブジェクトおよびその関連ラベルを、有効な AutoCAD 2009 セッションで表示することができます。


有効な AutoCAD セッションで[オブジェクト プロパティ管理]を使用する

AutoCAD Civil 3D で作成されるオブジェクトの種類
サポートされる AutoCAD コマンド
有効な AutoCAD セッションで[オブジェクト プロパティ管理]を使用する

[AutoCAD オブジェクト プロパティ]ウィンドウで、AutoCAD Civil 3D オブジェクトの情報を表示することができます。

[修正] [image] [プロパティ]コマンドを使用するか、オブジェクトを右クリックし[プロパティ]を選択して、[プロパティ]ウィンドウを開きます。 有効な AutoCAD セッションで[プロパティ]ウィンドウを使うと、AutoCAD プロパティを変更することができます。


サポートされる AutoCAD コマンド

有効な AutoCAD セッションで[オブジェクト プロパティ管理]を使用する
AutoCAD Civil 3D オブジェクトを分解する
サポートされる AutoCAD コマンド

AutoCAD Civil 3D のすべてのオブジェクトで、AutoCAD の[リスト]、[分解]、[削除]のコマンドを使用することができます。 AutoCAD Civil 3D Object Enabler の[リスト]コマンドは、 AutoCAD Civil 3D の[リスト]コマンドと同じ機能です。

他のコマンドも、ほとんどのAutoCAD Civil 3D オブジェクトでサポートされます（ただし機能が制限される場合があります）。該当するのは、[コピー]、[移動]、[鏡像]、[オフセット]、[尺度変更]、[ブロック/ブロック書き出し]、[回転]、[トリム]、[延長]などのコマンドです。

次の表は、各オブジェクトに対するコマンドの実行とその結果について、補足的な情報を一覧にしています。

注:「コピー」動作を実行するには、コマンド ラインで COPY と入力するか、ショートカット メニューの[基本修正ツール] [image] [コピー]コマンドを使用します。 「ブロック/ブロック書き出し」動作を実行するには、ショートカット メニューの[クリップボード] [image] [コピー]または[クリップボード] [image] [基点コピー]コマンドを使用するか、[Ctrl]+[C]を押すか、コマンド ラインに WBLOCK と入力します。

サポートされる AutoCAD コマンドに関する注記

サーフェス

サーフェスが削除または分解されると、そのサーフェスを参照している縦断および横断は固定されます。

ミラーによってコピーが作成されますが、ミラー設定が優先されるわけではありません。

サーフェス定義で使用される ポイント グループはブロック書き出しの一部として含まれます。

ポイント

ポイントのブロック書き出しおよびブロック挿入やポイントのコピー時にダイアログ ボックスが表示され、番号の競合を解決します。

テーブル

テーブルをブロック書き出しすると、必要なジオメトリもコピーされます。たとえば、ポイントをコピーすると、ポイント テーブルも一緒にコピーされます。

線形

線形を分解または削除すると、その線形に依存しているすべてのオブジェクト(縦断、縦断ビュー、横断抽出ライン、横断、横断ビューなど)は、分解または削除されます。

線形をコピーすると、同じサイト内に別の名前で線形が作成されます。依存オブジェクトはすべてコピーされ、新しい線形に含められます。

ブロック書き出しまたはブロック挿入を実行すると、線形および依存するすべてのオブジェクトが新しいサイトにコピーされます。

区画 (区画ラベルを選択)

区画をコピーまたはブロック書き出しすると、依存する区画セグメントも含まれます。オブジェクトが同じ図面に挿入される場合、新しいサイトが作成されます。

区画ラベルだけは移動できます。

区画セグメント ライン

区画セグメント ラインをブロック書き出しおよびブロック挿入すると、新しいサイトにセグメント ラインが作成されます。

グレーディング

グレーディング オブジェクト上では 2 種類のコピー操作ができます。計画線または個々のターゲット線をコピーすると、新しいサイトに新しい計画線が作成されます。グレーディング オブジェクト全体をコピーすると、計画線、ターゲット、および基準がコピーされます。

計画線は移動できます。ターゲット線は移動できません。

グレーディング基準がサーフェスを参照している場合、そのサーフェスもブロック書き出しまたはブロック挿入操作の対象となります。

縦断

縦断または横断を削除すると、それらはすべての縦断ビューまたは横断ビューから削除されます。

縦断および横断は、ビュー内で垂直方向にのみ移動できます。

縦断ビュー

縦断または縦断ビューがブロック書き出しされると、その縦断または縦断 ビューに必要なすべてのオブジェクト(サーフェス、線形、縦断、横断抽出ライン、横断など)がコピーされます。オブジェクトが同じ図面にコピーされる場合、新しいサイトが作成されます。

横断抽出ライン

横断抽出ラインは[コピー]および[移動]ができません。

横断

縦断または横断を削除すると、それらはすべての縦断ビューまたは横断ビューから削除されます。

縦断および横断は、ビュー内で垂直方向にのみ移動できます。

横断抽出ライン、横断、または横断ビューがブロック書き出しされると、その横断抽出ライン、横断、または横断ビューに必要なすべてのオブジェクト(サーフェス、線形、横断、横断抽出ラインなど)がコピーされます。オブジェクトが同じ図面にコピーされる場合、新しいサイトが作成されます。

アセンブリ

アセンブリとサブアセンブリは、コピーされるたびに名前に付けられる数字が増えます。アセンブリをコピーすると、アセンブリおよびすべての依存するサブアセンブリがコピーされます。

ミラーによってコピーが作成されますが、ミラー設定が優先されるわけではありません。

コリドー

コリドーをコピーまたはブロック書き出しすると、アセンブリ、線形、サーフェスなどのすべての依存データがコピーされます。

パイプ ネットワーク

AutoCAD Civil 3D Object Enabler 環境では、ネットワーク オブジェクトにアクセスできません。

パイプ

ネットワーク パーツ縦断をコピーすると、親ネットワーク パーツ(パイプまたは構造物)のコピーが作成されます。

構造物

パイプおよび構造物をコピー、鏡像化、配列、およびオフセットすると、接続するすべてのパーツの参照が更新されます。

パイプと構造物は、同じネットワークにコピーされます。

構造物を移動または回転すると、接続されているパーツも移動します。(接続は維持されます)。

一方、パイプを移動または回転すると、パーツとの接続が切れます。

パイプまたは構造物の尺度を変更するとそれらの位置は変わりますが、サイズは変わりません。

パイプおよび構造物のブロックを書き出すと、それらに依存するオブジェクトすべてがコピーされます。

測量ネットワーク

測量ネットワークで[コピー]コマンドを使用すると、計画線が作成されます。[移動]コマンドを使用すると、図形とモデルを切り離します。

測量図形

測量図形でオフセット コマンドを使用すると、測量図形ではなく計画線オブジェクトが生成されます。

移動コマンドを使用すると、図形とモデルを切り離します。

[マス カーブ ライン]

分解コマンドを使用すると、レイヤおよび表示設定が維持されます。したがって、図形の外観がオブジェクト内での外観と全く同じように表示されます。 だたし、「ByBlock」色に割り当てられたオブジェクトは例外です。

[延長]コマンドを使用すると、延長するエッジとしてオブジェクトを選択することができますが、オブジェクトを選択して延長することはできません。

[トリム]コマンドを使用すると、トリム エッジとしてオブジェクトを選択することができますが、オブジェクトをトリムすることはできません。

マス カーブがブロックされている場合、マス カーブに必要なすべてのオブジェクトがコピーされます。ブロック/挿入は、ユーザ キーが ^C および ^V の場合に使用されます。

マス カーブ ビュー

ビューは「既存の名前」(#)に基づき自動的に命名されます。# は増分を表します。衝突が見つかった場合は、次のカウンタが使用されます。

コピー コマンドまたは[選択をコピー]の右クリックによって、ビューのコピーが「既存の名前」(#)の名前で作成されます。# は増分を表します。

分解コマンドを使用すると、レイヤおよび表示設定が維持されます。したがって、図形の外観がオブジェクト内での外観と全く同じ状態に維持されます。 だたし、「ByBlock」色に割り当てられたオブジェクトは例外です。ビューを分解してもカーブ ラインは分解されません。

ミラー コマンドはビューに対して正しく実行されますが、ミラー設定が優先されるわけではありません。縦断ビューの追加コピーが作成されます。

ビューがブロックされている場合、ビューに必要なすべてのオブジェクトがコピーされます。ブロック/挿入は、ユーザ キーが ^C および ^V の場合に使用されます。


AutoCAD Civil 3D オブジェクトを分解する

サポートされる AutoCAD コマンド
よくある質問
AutoCAD Civil 3D オブジェクトを分解する

[AutoCAD 2004 形式に書き出す]コマンドを使用すると、Civil オブジェクトが分解された状態で、新しい AutoCAD 2004 または 2000 形式の図面が作成されます。元の図面は影響を受けません。[分解]の方法には、(1)[分解]コマンドを使用する、(2)以下の方法で書き出しを行う、という 2 つの方法があります。

有効な AutoCAD セッションで、AutoCAD Civil 3D オブジェクトを分解するには

  1. AutoCAD Civil 3D Object Enabler で有効にした AutoCAD のコマンド ラインで -AecExportToAutoCAD を入力します。次のプロンプトが表示されます。

    書き出しオプション [形式(F)/バインド(B)/バインド タイプ(T)/保持(M)/接頭表記(P)/末尾表記(S)/一覧(?)] <ファイル名を入力>

  2. F と入力して形式のオプションを表示し、目的のファイル形式を指定します。
  3. B と入力して、外部参照をバインドするかどうかを指定します。 Y(はい) または N(いいえ) と入力します。
  4. T と入力して、バインドのタイプを指定します。B(バインド) または I(挿入) と入力します。

    B (バインド)を選択すると、レイヤ名などの外部参照の識別情報が維持されます。I (挿入)を選択すると、参照図面をアタッチ解除して挿入する場合とほぼ同じ方法で、外部参照が現在の図面にバインドされます。

  5. M と入力して、カスタム ACE オブジェクト内のブロックの処理方法を指定します。 Y(はい) または N(いいえ) と入力します。
  6. P と入力して、書き出すファイルの接頭辞を指定し、接頭辞を入力します。
  7. S と入力して、書き出すファイルの接尾辞を指定し、接尾辞を入力します。
  8. ? と入力して、指定した設定を確認します。
  9. 設定の指定が完了したら、プロンプト「<ファイル名を入力>:」に対して、[Enter]を押します。次に、パスを含むファイル名を指定します。たとえば、C:¥My Documents¥ACAD-Drawing1.dwg と入力します。

    指定した場所にファイルが保存されます。


よくある質問

AutoCAD Civil 3D オブジェクトを分解する
よくある質問

AutoCAD Civil 3D Object Enabler のインストールと使用法に関する質問は、次のトピックで扱います。

注:Object Enabler の最新情報については、http://www.autodesk.co.jp/oe を参照してください。

AutoCAD Civil 3D Object Enabler について

AutoCAD Civil 3D Object Enabler は、AutoCAD 2009 ベースの製品のユーザが AutoCAD Civil 3D オブジェクトを表示したり、限定的に編集できるようにするためのユーティリティです。AutoCAD Civil 3D Object Enabler を使用することにより、AutoCAD 2009 ベースの製品のユーザは、AutoCAD Civil 3D オブジェクトとの完全な互換性が得られます。

AutoCAD Civil 3D Object Enabler は 2009 以前の AutoCAD のバージョンにインストールできますか?

いいえ。 AutoCAD Civil 3D Object Enabler をインストールできるのは AutoCAD 2009 ベースの製品のみです。

AutoCAD ベースのアプリケーションで AutoCAD Civil 3D の図面を表示するためには、AutoCAD Civil 3D Object Enabler をインストールする必要がありますか?

いいえ。 AutoCAD プロキシ グラフィック メカニズム(AutoCAD R13から)により、AutoCAD あるいは図面ファイルを読み込むことができるその他のオートデスク製品で、AutoCAD Civil 3D オブジェクトを表示することができます。必ずプロキシ グラフィックスをオンにしてから AutoCAD Civil 3D に図面を保存してください。

AutoCAD Civil 3D Object Enabler とプロキシ グラフィックスはどう違うのですか?

AutoCAD Civil 3D Object Enabler にはプロキシ グラフィックス メカニズムのような相互運用性はありません。 プロキシ グラフィックスは、オートデスクの全製品の間で相互にファイルを利用できるように使用される共通要素です。AutoCAD Civil 3D Object Enabler は、AutoCAD ユーザに、より強固な互換性を提供します。

AutoCAD Civil 3D Object Enabler の使い方は?

AutoCAD Civil 3D Object Enabler は一旦インストールすれば、既存の AutoCAD 構成に合わせて自動的に作動します。 AutoCAD Civil 3D のオブジェクトを含む図面ファイルを開くと、そのオブジェクトが「有効」になり、AutoCAD のコマンドを使用して直接編集することができます。メニュー、ツールバー、あるいはコマンドライン機能はありません。使い慣れた既存の AutoCAD コマンドを利用でき、新たに機能を覚える必要がない点が、AutoCAD Civil 3D Object Enabler の特長です。

AutoCAD 2009 で AutoCAD Civil 3D Object Enabler を使用してインテリジェント オブジェクトを作成することができますか?

AutoCAD 2009 と AutoCAD Civil 3D Object Enabler を使用して新しいオブジェクトを作成するコマンドはありません。 ただし、ほとんどの既存のオブジェクトをコピーすることが可能なため、そのインテリジェンスを保持することはできます。

AutoCAD Civil 3D Object Enabler のインストール方法は?

AutoCAD Civil 3D Object Enabler は、お使いの製品メディアからインストールできます。最新バージョンは、オートデスクの Web サイト http://www.autodesk.co.jp/oe からダウンロードできます。

AutoCAD Civil 3D Object Enabler を配布する方法は?

AutoCAD Civil 3D Object Enabler はフリーウェア アプリケーションですので、図面を表示する必要があるユーザに自由に配布することができます。 ただし、AutoCAD Civil 3D Object Enabler 単独では図面を表示することはできません。 AutoCAD 2009 あるいは AutoCAD 2009 ベースの製品がインストールされている必要があります。

AutoCAD Civil 3D Object Enabler が適切にインストールされていることを確認する方法は?

AutoCAD Civil 3D Object Enabler をインストールすると、Windows のコントロール パネルの[プログラムの追加と削除]に追加されます。

AutoCAD Civil 3D Object Enabler に影響する AutoCAD の変数はありますか?

AutoCAD Civil 3D Object Enabler を使用するときは、[オブジェクト検出時/発行時]オプションを使用することをお勧めします。

[オブジェクト検出時/発行時]オプションを使用するには

  1. AutoCAD のコマンド ラインで OPTIONS と入力して AutoCAD の[オプション]ダイアログを表示します。
  2. [開く/保存]タブをクリックします。
  3. [ObjectARX アプリケーション]領域の[ObjectARX アプリケーションのディマンド ロード]リストで、[オブジェクト検出時/コマンド発行時]を選択します。

このオプションは図面に存在するカスタム オブジェクトをチェックして、ARX/DBX アプリケーションをロードします。

注:AutoCAD Civil 3D Object Enabler を使用してカスタム オブジェクトを表示する場合は、[ObjectARX アプリケーションのディマンド ロード]オプションを[カスタム オブジェクト検出時](1)または[オブジェクト検出時およびコマンド発行時](3)に設定してください。


コメント?

このフォームを使用してお寄せいただいたコメントは, このドキュメントを管理している Autodesk Technical Publications グループに送られます。

トピックのタイトルと場所:
名前 (必須ではありません):
電子メール (必須ではありません):
コメント:

注: このフォームを使用してフィードバックまたはテクニカル サポートを受けることはできません。 お寄せいただいた情報は今後のドキュメントのアップデート時に反映させていただきます。 どうもありがとうございました。