Używanie programu AutoCAD Civil Object Enabler w celu uzyskania dostępu do danych obiektów utworzonych w programie AutoCAD Civil 3D 2009

Korzystanie z programu Civil Object Enabler w celu uzyskania dostępu do danych obiektów utworzonych w programie AutoCAD Civil 3D 2009

Program AutoCAD Civil Object Enabler umożliwia uzyskanie dostępu do danych obiektów budowlanych utworzonych w programach AutoCAD Civil 3D 2009 oraz AutoCAD Land Desktop 2009 w aplikacjach opartych na platformie AutoCAD 2009 bez konieczności instalowania tych produktów na komputerze.

UwagaProgram AutoCAD Civil Object Enabler możne współpracować zarówno z programem AutoCAD Civil 3D 2009, jak i AutoCAD Land Desktop 2009.

Obiekty budowlane mogą być udostępniane w następujących produktach Autodesk:

  • AutoCAD 2009
  • AutoCAD Mechanical 2009
  • AutoCAD Architecture 2009
  • AutoCAD MEP 2009
  • AutoCAD Map 3D 2009
  • AutoCAD Electrical 2009
  • Autodesk 3ds Max Design 2009
  • Autodesk 3ds Max 2009
  • Autodesk NavisWorks Manager 2009
  • Autodesk NavisWorks Review 2009
  • Autodesk NavisWorks Simulate 2009
  • Autodesk Impression 2009

W przypadku korzystania z wcześniejszych wersji tych produktów, na stronie http://www.autodesk.com/aecobjenabler podano informacje o właściwej, przeznaczonej do pobrania wersji programu.

Tematy w tej sekcji

  • Korzystanie z programu Civil Object Enabler w celu uzyskania dostępu do danych obiektów utworzonych w programie AutoCAD Civil 3D 2009

    Civil Object Enabler jest darmową aplikacją służącą do uzyskiwania dostępu do plików rysunków programu AutoCAD Civil 3D 2009. Niniejsza wersja umożliwia uzyskanie dostępu do danych obiektów utworzonych w programie AutoCAD Civil 3D 2009 poza środowiskiem tego programu.

  • Dostęp do programu Civil Object Enabler i jego instalacja

    Program Civil Object Enabler znajduje się na nośniku zawierającym program AutoCAD Civil 3D 2009 oraz jest dostępny w witrynie firmy Autodesk.

  • Typy obiektów tworzone za pomocą produktu AutoCAD Civil 3D

    W programie AutoCAD Civil 3D 2009 można utworzyć wiele różnych typów niestandardowych obiektów graficznych.

  • Korzystanie z Menedżera właściwości obiektu w sesji programu AutoCAD z uaktywnionymi obiektami budowlanymi

    Pewne informacje dotyczące obiektów AutoCAD Civil 3D można wyświetlić w oknie Właściwości obiektu programu AutoCAD.

  • Obsługiwane polecenia programu AutoCAD

    Wszystkie obiekty programu AutoCAD Civil 3D obsługują polecenia Lista, Rozbij i Wymaż programu AutoCAD. Polecenie listy programu Object Enabler działa tak samo, jak polecenie listy programu AutoCAD Civil 3D.

  • Rozbijanie obiektów programu AutoCAD Civil 3D

    Polecenie Eksportuj do AutoCAD umożliwia utworzenie nowego rysunku w formacie AutoCAD 2004 lub 2000 z rozbitymi wszystkimi obiektami budowlanymi. Oryginalny rysunek pozostaje niezmieniony. Dostępne są dwa sposoby rozbijania obiektów: użycie polecenia rozbicia lub wyeksportowanie obiektu w sposób opisany poniżej.

  • Często zadawane pytania

    Pytania dotyczące instalacji i używania programu Object Enabler zostały zestawione w następujące grupy.

Prześlij swoje uwagi na temat tej strony


Korzystanie z programu Civil Object Enabler w celu uzyskania dostępu do danych obiektów utworzonych w programie AutoCAD Civil 3D 2009

Dostęp do programu Civil Object Enabler i jego instalacja
Korzystanie z programu Civil Object Enabler w celu uzyskania dostępu do danych obiektów utworzonych w programie AutoCAD Civil 3D 2009

Civil Object Enabler jest darmową aplikacją służącą do uzyskiwania dostępu do plików rysunków programu AutoCAD Civil 3D 2009. Niniejsza wersja umożliwia uzyskanie dostępu do danych obiektów utworzonych w programie AutoCAD Civil 3D 2009 poza środowiskiem tego programu.

Na przykład, jeśli na połowie stanowisk zainstalowano program AutoCAD 2009, a na pozostałych stanowiskach program AutoCAD Civil 3D 2009, to osoby używające zwykłej wersji AutoCAD 2009 mogą zainstalować program Civil Object Enabler. Po zainstalowaniu programu Civil Object Enabler możliwe będzie otwieranie rysunków utworzonych w programie AutoCAD Civil 3D 2009 oraz wyświetlanie, drukowanie i kopiowanie obiektów niestandardowych oraz manipulowanie nimi.

Bez zainstalowanego programu rysunki można współużytkować wykorzystując grafikę zastępczą. Grafika zastępcza jest innym sposobem wyświetlania obiektów przy pomocy prostych reprezentacji graficznych. Obiekty przedstawiane jako grafiki zastępcze są pozbawione pełnej „inteligencji” prawdziwych obiektów. Grafiki zastępcze wpływają również na powiększenie rozmiarów rysunku. W programie AutoCAD ten mechanizm wykorzystywany jest w celu uzyskania zgodności z plikami DWG, jeśli aplikacja użytkownika nie jest uruchomiona.

Dla opcji rysunku PROXYGRAPHICS wybierz ustawienie 1, aby zapisać grafikę z rysunkiem. W przeciwnym razie po otwarciu obiektu za pomocą programu Object Enabler w miejscu położenia obiektu zostanie wyświetlona „ramka ograniczająca”.

Instalacja programu Civil Object Enabler w dowolnym z produktów AutoCAD 2009 uaktywnia:

  • obsługę programu AutoCAD List i usunięcie poleceń z obiektów budowlanych;
  • punkty charakterystyczne obiektów budowlanych (można więc używać funkcji lokalizacji Obiekt i funkcji śledzenia obiektów);
  • edycję uchwytów etykiet;
  • obsługę wyświetlania niektórych typów obiektów budowlanych w palecie Właściwości obiektu AutoCAD.

Wierność wyświetlania

Wygląd obiektów budowlanych programu AutoCAD Civil 3D jest zależny od stylów, mających różne ustawienia wyświetlania obiektów w widokach 2D i 3D. Te ustawienia są zachowane w programie Civil Object Enabler, dlatego np. powierzchnia skonfigurowana w taki sposób, że w trybie 3D są wyświetlane tylko jej warstwice, oglądana w 3D w sesji programu AutoCAD z uaktywnionymi obiektami budowlanymi, będzie widoczna w postaci warstwic.

Wierność warstw

Style obiektów budowlanych AutoCAD Civil 3D można tak skonfigurować, że wygląd obiektów będzie zależny od manipulacji przeprowadzonych na warstwach. Jeśli ustawienia stylu obiektu, takie jak kolor i szerokość linii, mają wartość JAKWARSTWA, można wykonać następujące operacje w sesji programu AutoCAD z uaktywnionymi obiektami budowlanymi:

  • Zmienić ustawienia warstwy obiektu i warstwy podkomponentu, aby uaktualnić wyświetlanie obiektu.
  • Włączyć/wyłączyć albo zablokować/odblokować warstwy, aby zmienić widoczność obiektu.

Jeśli ustawienia warstwy w stylu obiektu mają wartość JAKBLOK, zmiana warstwy obiektu w sesji AutoCAD z uaktywnionymi obiektami budowlanymi spowoduje odpowiednią zmianę sposobu wyświetlania obiektu i jego podkomponentów.


Dostęp do programu Civil Object Enabler i jego instalacja

Korzystanie z programu Civil Object Enabler w celu uzyskania dostępu do danych obiektów utworzonych w programie AutoCAD Civil 3D 2009
Używanie programu AutoCAD Civil Object Enabler w celu uzyskania dostępu do danych obiektów utworzonych w programie AutoCAD Civil 3D 2009
Typy obiektów tworzone za pomocą produktu AutoCAD Civil 3D
Dostęp do programu Civil Object Enabler i jego instalacja

Program Civil Object Enabler znajduje się na nośniku zawierającym program AutoCAD Civil 3D 2009 oraz jest dostępny w witrynie firmy Autodesk.

Instrukcje instalacji programu Civil Object Enabler z nośnika przedstawiono poniżej. Najnowszą wersję programu można pobrać z witryny firmy Autodesk http://www.autodesk.com/aecobjenabler.

Instalacja programu Civil Object Enabler

  1. Włóż dysk z programem AutoCAD Civil 3D 2009 do napędu nośników w komputerze.
  2. W Kreatorze instalacji programu AutoCAD Civil 3D 2009 kliknij łącze Zainstaluj.
  3. Na stronie Instalacja kliknij opcję Instaluj narzędzia dodatkowe. Kliknij nazwę Civil Object Enabler i postępuj zgodnie z wyświetlanymi poleceniami.
  4. Po wyświetleniu monitu uruchom ponownie komputer.


Typy obiektów tworzone za pomocą produktu AutoCAD Civil 3D

Dostęp do programu Civil Object Enabler i jego instalacja
Korzystanie z Menedżera właściwości obiektu w sesji programu AutoCAD z uaktywnionymi obiektami budowlanymi
Typy obiektów tworzone za pomocą produktu AutoCAD Civil 3D

W programie AutoCAD Civil 3D 2009 można utworzyć wiele różnych typów niestandardowych obiektów graficznych.

Należą do nich:

  • Powierzchnia
  • Linia etykiety warstwicy
  • Punkt
  • Grupa punktów
  • Tabele
  • Linia trasowania
  • Korytarz
  • Zespół
  • Podzespół
  • Rura i struktura (rzut)
  • Rura i struktura (widok profilu)
  • Rura i struktura (widok przekroju)
  • Przenikanie sieci rurociągów
  • Powierzchnia działki
  • Segmenty działki
  • Obszar
  • Profilowanie
  • Profil
  • Widok profilu
  • Linia próbkowania
  • Przekrój powierzchni
  • Przekrój materiału
  • Widok przekroju
  • Arkusz widoku przekroju
  • Figura miernicza
  • Sieć pomiarów
  • Ramka widoku
  • Linia rzutowania
  • Etykiety pojedyncze
  • Etykiety grupowe
  • Linia wykresu transportu robót ziemnych
  • Widok wykresu transportu robót ziemnych

Podczas sesji programu AutoCAD 2009 z uaktywnionymi obiektami program Civil Object Enabler umożliwia wyświetlanie tych obiektów i związanych z nimi etykiet.


Korzystanie z Menedżera właściwości obiektu w sesji programu AutoCAD z uaktywnionymi obiektami budowlanymi

Typy obiektów tworzone za pomocą produktu AutoCAD Civil 3D
Obsługiwane polecenia programu AutoCAD
Korzystanie z Menedżera właściwości obiektu w sesji programu AutoCAD z uaktywnionymi obiektami budowlanymi

Pewne informacje dotyczące obiektów AutoCAD Civil 3D można wyświetlić w oknie Właściwości obiektu programu AutoCAD.

Użyj polecenia Zmień [image] Właściwości lub kliknij obiekt prawym przyciskiem myszy i wybierz opcję Właściwości, aby wyświetlić okno Właściwości. Używając okna Właściwości w sesji AutoCAD z uaktywnionymi obiektami budowlanymi, można zmienić niektóre właściwości programu AutoCAD.


Obsługiwane polecenia programu AutoCAD

Korzystanie z Menedżera właściwości obiektu w sesji programu AutoCAD z uaktywnionymi obiektami budowlanymi
Używanie programu AutoCAD Civil Object Enabler w celu uzyskania dostępu do danych obiektów utworzonych w programie AutoCAD Civil 3D 2009
Rozbijanie obiektów programu AutoCAD Civil 3D
Obsługiwane polecenia programu AutoCAD

Wszystkie obiekty programu AutoCAD Civil 3D obsługują polecenia Lista, Rozbij i Wymaż programu AutoCAD. Polecenie listy programu Object Enabler działa tak samo, jak polecenie listy programu AutoCAD Civil 3D.

Większość obiektów AutoCAD Civil 3D obsługuje do pewnego stopnia inne polecenia. Wśród nich można wymienić: Kopiuj, Przesuń, Lustro, Odsunięcie, Skala, Blok/piszBlok, Obrót, Utnij i Wydłuż.

W poniższej tabeli przedstawiono dodatkowe informacje dotyczące działania i wyników poleceń w odniesieniu do określonych obiektów.

UwagaDziałanie „Kopiuj” można uzyskać, wprowadzając polecenie KOPIUJ w wierszu polecenia lub używając polecenia Podstawowe narzędzia zmian [image] Kopiuj w menu podręcznym. Można uzyskać działanie „Blok/PiszBlok”, korzystając z poleceń menu skrótów Schowek [image] Kopiuj lub Schowek [image] Kopiuj z punktem bazowym, naciskając klawisze Ctrl+C lub wprowadzając polecenie PiszBlok w wierszu polecenia.

Uwagi dotyczące obsługiwanych poleceń programu AutoCAD

Powierzchnia

Jeżeli powierzchnia zostanie usunięta lub rozbita, profile i przekroje, które odwołują się do tej powierzchni staną się statyczne.

Opcja Lustro tworzy kopię, ale nie uwzględnia ustawień lustra.

Grupy punktów, używane w definicji powierzchni, są dołączane jako część polecenia PiszBlok.

Punkt

Przy korzystaniu z opcji PiszBlok i Wstaw punkty, lub przy kopiowaniu punktów, w celu rozwiązania konfliktów numerów, zostanie wyświetlone okno dialogowe.

Tabela

Korzystając z opcji PiszBlok dla tabeli, wymagana geometria zostanie także skopiowana. Na przykład, punkty są kopiowane razem z tabelą punktów.

Linia trasowania

Rozbijanie lub wymazywanie rozbić linii trasowania lub wymazuje wszystkie obiekty, które są zależne od linii trasowania (takie jak profile, widoki profili, linie próbkowania, przekroje i widoki przekrojów).

Przy kopiowaniu linii trasowania, na tym samym miejscu, tworzona jest linia trasowania z nową nazwą. Wszystkie obiekty zależne zostaną skopiowane i uwzględnione w nowej linii trasowania.

Przy użyciu opcji PiszBlok/Wstaw, linia trasowania i wszystkie zależne obiekty zostaną skopiowane na nowe miejsce.

Działka (wybierz etykietę działki)

Korzystając z opcji PiszBlok lub Kopiuj dla działki, zależne segmenty działki zostaną załączone. Przy kopiowaniu obiektów w tym samym rysunku, utworzone zostaną nowe obszary.

Przesunięte mogą być tylko etykiety działki.

Linie segmentu działki

Korzystając z opcji PiszBlok/Wstaw dla segmentu działki, linia segmentu zostanie utworzona w nowym miejscu

Profilowanie

Do kopiowania obiektu profilowania można użyć dwóch różnych operacji. Przy kopiowaniu linii charakterystycznej zarysu lub osobnej linii docelowej, tworzona jest nowa linia charakterystyczna w nowym miejscu. Przy kopiowaniu całego profilowanego obiektu, kopiowany jest zarys, obiekt docelowy i kryteria.

Zarys może być przesunięty. Nie można przesuwać linii docelowej

Jeżeli kryterium profilowania odnosi się do powierzchni, powierzchnia zostanie włączona do operacji PiszBlok/Wstaw.

Profil

Wymazywanie profilu lub zostanie wymazany ze wszystkich profili lub widoków przekrojów, przez przekrój.

Profile i przekroje mogą być przesuwane pionowo w obrębie widoku.

Widok profilu

Jeżeli dla profilu lub dla widoku profilu została użyta opcja PiszBlok, wszystkie obiekty wymagane dla profilu lub widoku profilu (takie jak powierzchnia, linia trasowania, profil, linie próbkowania i przekroje) zostaną skopiowane. Przy kopiowaniu obiektów w tym samym rysunku, utworzone zostaną nowe obszary.

Linia próbkowania

Nie można kopiować ani przenosić linii próbkowania.

Przekrój

Wymazywanie profilu lub zostanie wymazany ze wszystkich profili lub widoków przekrojów, przez przekrój.

Profile i przekroje mogą być przesuwane pionowo w obrębie widoku.

Jeżeli dla linii próbkowania, przekroju lub widoku przekroju została użyta PiszBlok, wszystkie obiekty wymagane dla linii próbkowania, przekroju lub widoku przekroju (takie jak powierzchnia, linia trasowania, przekroje i linie próbkowania) zostaną skopiowane. Przy kopiowaniu obiektów w tym samym rysunku, utworzone zostaną nowe obszary.

Zespół

Przy kopiowaniu zespołów i podzespołów, ich nazwy są rozszerzane. Przy kopiowaniu zespołu, kopiowany jest zespół wraz z zależnymi podzespołami.

Opcja Lustro tworzy kopię, ale nie uwzględnia ustawień lustra.

Korytarz

Przy kopiowaniu lub korzystaniu z polecenia Piszblok dla korytarza, kopiowane są wszystkie zależne dane, takie jak zespoły, linie trasowania i powierzchnie.

Sieć rurociągów

Obiekty sieci nie są dostępne w środowisku programu Object Enabler.

Rura

Przy kopiowaniu profilu części sieci, tworzona jest kopia macierzystej części sieci (rura lub struktura).

Struktura

Korzystanie z opcji kopiowanie, lustro, szyk i odsuń dla rur i struktur, powoduje zaktualizowanie odnośników, każdej połączonej części.

Skopiowane rury i struktury, znajdą się w tej samej sieci.

Przesuwanie lub obracanie struktury powoduje, że połączone części przesuwają się razem z nią. (zachowano połączenia).

Przesuwanie lub obracanie rury przerywa połączenia do wszelkich połączonych części.

Skalowanie rury lub struktury dotyczy położenia, ale nie dotyczy rozmiaru.

Korzystając z opcji PiszBlok dla rur i struktur, wszystkie zależne obiekty zostaną skopiowane.

Sieć pomiarowa

Stosowanie polecenia kopiowania w sieci pomiarów powoduje utworzenie linii charakterystyki. Polecenie przeniesienia powoduje odłączenie figury od modelu.

Figura pomiarowa

Stosowanie polecenia odsunięcia w figurze pomiarowej powoduje utworzenie obiektu typu linia charakterystyczna, a nie figury pomiarowej.

Polecenie Przesuń powoduje odłączenie figury od modelu.

Linia wykresu transportu robót ziemnych

Użycie polecenia Rozbij umożliwia utrzymanie ustawień warstwy i wyświetlania, więc elementy będą wyglądać tak samo jako w obiekcie, z wyjątkiem obiektów z przypisanym kolorem „JakBlok”.

Za pomocą polecenia Wydłuż można wybrać obiekt jako krawędź, do której zostanie wydłużony, ale nie możne on zostać wybrany do wydłużenia

Polecenie przycinania umożliwia wybór obiektów jako krawędzi przycinania, jednak bez możliwości przycinania tych obiektów.

Jeśli wykresy transportu robót ziemnych są zapisywane jako bloki za pomocą polecenia Piszblok, zostaną skopiowane wszystkie wymagane obiekty. Polecenia Piszblok/Wstaw są używane po wpisaniu ^C i ^V.

Widok wykresu transportu robót ziemnych

Widoki są nazywane automatycznie zgodnie z konwencją „Istniejąca nazwa” (#), gdzie znak # oznacza przyrost. W przypadku wystąpienia konfliktu zostanie użyta kolejna liczba.

Wybór polecenia kopiowania lub kliknięcie prawym przyciskiem myszy i wybór opcji „Kopiuj wybrane” powoduje utworzenie kopii widoku o nazwie „Istniejąca nazwa” (#), gdzie znak # oznacza przyrost.

Polecenie Rozbij umożliwia utrzymanie ustawień warstwy i wyświetlania, więc elementy będą wyglądać tak samo jako w obiekcie, z wyjątkiem obiektów z przypisanym kolorem „JakBlok. Rozbicie widoku nie powoduje rozbicia linii wykresu transportu robót ziemnych.

Polecenie Lustro działa w przypadku widoku, ale ustawienia lustra nie są uwzględniane. Zostanie wygenerowana dodatkowa kopia widoku profilu.

Jeśli widok będzie zapisywany jako blok za pomocą polecenia Piszblok, zostaną skopiowane wszystkie wymagane obiekty. Polecenia Piszblok/Wstaw są używane po wpisaniu ^C i ^V.


Rozbijanie obiektów programu AutoCAD Civil 3D

Obsługiwane polecenia programu AutoCAD
Często zadawane pytania
Rozbijanie obiektów programu AutoCAD Civil 3D

Polecenie Eksportuj do AutoCAD umożliwia utworzenie nowego rysunku w formacie AutoCAD 2004 lub 2000 z rozbitymi wszystkimi obiektami budowlanymi. Oryginalny rysunek pozostaje niezmieniony. Dostępne są dwa sposoby rozbijania obiektów: użycie polecenia rozbicia lub wyeksportowanie obiektu w sposób opisany poniżej.

Rozbijanie obiektów programu AutoCAD Civil 3D w sesji programu AutoCAD z uaktywnionymi obiektami budowlanymi

  1. Wprowadź polecenie -AecExportToAutoCAD w wierszu polecenia programu AutoCAD z zainstalowanym programem Civil Object Enabler. Zostanie wyświetlony następujący monit:

    Opcje eksportu [Format/Ustal/Typ ustalenia/Przedrostek/Przyrostek/?] <Aby podać nazwę pliku, naciśnij Enter>:

  2. Wprowadź F, aby wyświetlić opcje formatu, a następnie określ format pliku.
  3. Wprowadź U, aby określić, czy ustalać odnośniki. Wprowadź Tak lub Nie.
  4. Wprowadź T, aby określić typ ustalenia odnośników. Wprowadź Ustal lub Wstaw.

    Metoda Ustal umożliwia zachowanie danych tożsamości odnośników, na przykład nazw warstw. Metoda Wstaw wiąże odnośniki z bieżącym rysunkiem w sposób podobny do odłączania i wstawiania rysunku referencyjnego.

  5. Wprowadź P, aby określić przedrostek pliku, a następnie wprowadź przedrostek.
  6. Wprowadź S, aby określić przyrostek pliku, a następnie wprowadź przyrostek.
  7. Wprowadź ?, aby obejrzeć wybrane ustawienia.
  8. Po zakończeniu wprowadzania ustawień naciśnij klawisz Enter po wyświetleniu monitu <Aby podać nazwę pliku, naciśnij Enter> i podaj nazwę pliku wraz ze ścieżką. Przykładowo, wprowadź C:\My Documents\ACAD-Drawing1.dwg.

    Plik zostanie zapisany we wskazanym miejscu.


Często zadawane pytania

Rozbijanie obiektów programu AutoCAD Civil 3D
Często zadawane pytania

Pytania dotyczące instalacji i używania programu Object Enabler zostały zestawione w następujące grupy.

UwagaNajnowsze informacje na temat programu Object Enabler można znaleźć na stronie http://www.autodesk.com/aecobjenabler.

Czym jest program Civil Object Enabler?

Program Civil Object Enabler jest narzędziem, które umożliwia użytkownikom produktów opartych na platformie AutoCAD 2009 wyświetlanie i wykonywanie niektórych operacji edycyjnych na obiektach programu AutoCAD Civil 3D. Dzięki programowi Civil Object Enabler użytkownicy korzystający z tych produktów opartych na platformie AutoCAD 2009 uzyskują pełną zgodność z obiektami programu AutoCAD Civil 3D.

Czy program Civil Object Enabler można zainstalować we wcześniejszej wersji programu AutoCAD niż wersja 2009?

Nie. Program Civil Object Enabler można zainstalować wyłącznie w produktach opartych na platformie AutoCAD 2009.

Czy muszę zainstalować program Civil Object Enabler, aby wyświetlać rysunki programu AutoCAD Civil 3D w aplikacjach opartych na platformie AutoCAD?

Nie. Mechanizm grafik zastępczych zastosowany w programie AutoCAD (począwszy od wersji AutoCAD 13) umożliwia wyświetlanie obiektów AutoCAD Civil 3D w programie AutoCAD oraz w pozostałych aplikacjach firmy Autodesk, które mogą odczytywać pliki rysunków. Przed zapisaniem rysunku w programie Civil 3D trzeba pamiętać o włączeniu grafik zastępczych.

Czym różni się program Civil Object Enabler od grafik zastępczych?

Program Civil Object Enabler nie zastępuje mechanizmu grafik zastępczych. Grafiki zastępcze nadal są cennym „wspólnym mianownikiem” zgodności operacyjnej różnych produktów firmy Autodesk. Program Civil Object Enabler udostępnia użytkownikom programu AutoCAD wyższy poziom zgodności.

Jak używać programu Civil Object Enabler?

Po zainstalowaniu program Civil Object Enabler działa automatycznie razem z istniejącą konfiguracją środowiska AutoCAD. Po otwarciu pliku rysunku zawierającego obiekty programu AutoCAD Civil 3D, te obiekty są aktywne i można je bezpośrednio edytować za pomocą poleceń programu AutoCAD. Nie ma menu, pasków narzędzi ani funkcji związanych z linią poleceń. Zaletą programu Civil Object Enabler jest możliwość używania istniejących, znanych poleceń AutoCAD w stosunku do obiektów programu AutoCAD Civil 3D bez konieczności poznawania nowych funkcji.

Czy w programie AutoCAD 2009 można tworzyć obiekty inteligentne, używając programu Civil Object Enabler?

W programie Civil Object Enabler zainstalowanym w programie AutoCAD 2009 nie ma poleceń, które służą do tworzenia nowych obiektów. W przypadku większości obiektów obsługiwane jest jednak kopiowanie istniejących obiektów, a obiekty zachowują inteligencję.

Jak można zainstalować program Civil Object Enabler?

Program Civil Object Enabler jest dostępny na nośniku z produktem. Najnowszą wersję programu można pobrać z witryny firmy Autodesk http://www.autodesk.com/aecobjenabler.

Jak można rozprowadzać wersję instalacyjną programu Civil Object Enabler?

Program Civil Object Enabler jest produktem udostępnianym bezpłatnie, który można udostępniać każdemu, kto chce przeglądać wykonane rysunki. Program Civil Object Enabler nie może samodzielnie wyświetlać rysunków. Użytkownik musi posiadać zainstalowaną kopię programu AutoCAD 2009 lub produktu opartego na platformie AutoCAD 2009.

Jak sprawdzić poprawność instalacji programu Civil Object Enabler?

Program Civil Object Enabler po instalacji zostanie dodany do listy programów Dodaj lub usuń programy w Panelu sterowania systemu Windows.

Czy istnieją zmienne AutoCAD, które wpływają na działanie programu Civil Object Enabler?

Podczas używania programu Civil Object Enabler zaleca się korzystanie z opcji Wykryto obiekt i przywołano polecenie, dostępnej w opcjach programu AutoCAD.

Włączenie opcji Wykryto obiekt i przywołano polecenie

  1. W wierszu polecenia programu AutoCAD wprowadź polecenie OPCJE, aby wyświetlić okno dialogowe Opcje AutoCAD.
  2. Kliknij kartę Otwórz i zapisz.
  3. W opcjach Aplikacji ObjectARX i Wczytaj na żądanie aplikacje ObjectARX zaznacz wartość Wykryto obiekt i przywołano polecenie.

Opcja ta służy do sprawdzenia występowania dowolnych obiektów użytkownika, istniejących w rysunku i wczytania macierzystej aplikacji ARX/DBX.

UwagaAby używać programu Civil Object Enabler do wyświetlania obiektów niestandardowych, w opcji Wczytaj na żądanie aplikacje ObjectARX należy wybrać ustawienie Wykryto obiekt niestandardowy (1) lub Wykryto obiekt i przywołano polecenie (3).


Komentarz?

Korzystanie z tej formuły powoduje wysłanie Twoich komentarzy do grupy Autodesk Technical Publications odpowiedzialnej za tę dokumentację.

Tytuł tematu i jego położenie (nie do edytowania):
Nazwa (opcjonalnie):
         Email (opcjonalnie):
Komentarz:

Uwaga: Ta forma kontaktu nie jest przeznaczona do odbierania przez Ciebie odpowiedzi zwrotnej lub wsparcia technicznego. Informacje, dostarczone przez Ciebie zostaną użyte do ulepszenia przyszłych aktualizacji dokumentacji. Dziękujemy!