Использование адаптера объектов AutoCAD Civil Object Enabler для данных объектов Civil 3D 2009

Использование адаптера объектов Civil Object Enabler для данных объектов AutoCAD Civil 3D 2009

Адаптер объектов AutoCAD Civil Object Enabler позволяет получить доступ к программе AutoCAD Civil 3D 2009 и к данным объектов Civil пакета AutoCAD Land Desktop 2009 в приложениях на основе AutoCAD 2009 без установки этих программных продуктов на компьютере пользователя.

ПримечаниеАдаптер объектов AutoCAD Object Enabler может быть использован и с AutoCAD Civil 3D 2009, и с AutoCAD Land Desktop 2009.

Объекты Civil могут использоваться в следующих продуктах Autodesk:

  • AutoCAD 2009
  • AutoCAD Mechanical 2009
  • AutoCAD Architecture 2009
  • AutoCAD MEP 2009
  • AutoCAD Map 3D 2009
  • AutoCAD Electrical 2009
  • Autodesk 3ds Max Design 2009
  • Autodesk 3ds Max 2009
  • Autodesk NavisWorks Manage 2009
  • Autodesk NavisWorks Review 2009
  • Autodesk NavisWorks Simulate 2009
  • Autodesk Impression 2009

Для более ранних версий этих продуктов подходящую версию приложения можно загрузить с веб-узлов http://www.autodesk.com/aecobjenabler.

Темы в этом разделе

  • Использование адаптера объектов Civil Object Enabler для данных объектов AutoCAD Civil 3D 2009

    Адаптер объектов Civil Object Enabler представляет собой свободно распространяемое программное приложение, которое можно использовать для просмотра файлов чертежей AutoCAD Civil 3D 2009. Эта версия программы позволяет получить доступ к данным объектов, созданных в AutoCAD Civil 3D 2009, без использования среды AutoCAD Civil 3D 2009.

  • Где найти и как установить адаптер объектов Civil Object Enabler

    Адаптер объектов Civil Object Enabler распространяется на дистрибутивном носителе AutoCAD Civil 3D 2009, это приложение также можно загрузить с веб-сайта Autodesk.

  • Типы объектов, создаваемые с помощью AutoCAD Civil 3D

    С помощью AutoCAD Civil 3D 2009 можно создавать различные типы пользовательских графических объектов.

  • Использование диспетчера свойств объекта при включенном сеансе AutoCAD

    Определенную информацию об объектах AutoCAD Civil 3D можно видеть в окне AutoCAD "Свойства объекта".

  • Поддерживаемые команды AutoCAD

    Все объекты AutoCAD Civil 3D поддерживают команды AutoCAD "Список", "Расчленить" и "Стереть". Команда "Список" адаптера объектов Object Enabler работает так же, как и команда "Список" AutoCAD Civil 3D.

  • Расчленение объектов AutoCAD Civil 3D

    Использование команды "Экспорт в AutoCAD" создает новый чертеж формата AutoCAD 2004 или 2000, в котором все объекты Civil расчленены. Оригинал чертежа не изменяется. Имеется два способа расчленения: использование команды "Расчленить" или экспорт, как описано ниже.

  • Часто задаваемые вопросы

    Ниже рассмотрены вопросы об установке адаптера объектов Object Enabler и его использовании

Отправьте ваши комментарии по поводу этой страницы


Использование адаптера объектов Civil Object Enabler для данных объектов AutoCAD Civil 3D 2009

Где найти и как установить адаптер объектов Civil Object Enabler
Использование адаптера объектов Civil Object Enabler для данных объектов AutoCAD Civil 3D 2009

Адаптер объектов Civil Object Enabler представляет собой свободно распространяемое программное приложение, которое можно использовать для просмотра файлов чертежей AutoCAD Civil 3D 2009. Эта версия программы позволяет получить доступ к данным объектов, созданных в AutoCAD Civil 3D 2009, без использования среды AutoCAD Civil 3D 2009.

Например, если в организации на половине рабочих мест установлена версия AutoCAD 2009, а на другой половине - AutoCAD Civil 3D 2009, то для персонала, использующего обычный пакет AutoCAD 2009, можно установить адаптер объектов Civil Object Enabler. После установки адаптера объектов Civil Object Enabler появляется возможность открывать чертежи, созданные в AutoCAD Civil 3D 2009, просматривать, печатать и копировать пользовательские объекты, а также манипулировать ими.

Без установки этого адаптера можно обеспечить только общий доступ к чертежам с использованием графических объектов заместителей. Графические объекты заместителей предоставляют альтернативные средства отображения объектов с использованием простых графических представлений. Объекты, представленные в виде графических объектов заместителей, не имеют полного набора "интеллектуальных" свойств фактических объектов. Графические объекты заместителей увеличивают размер файла чертежа. AutoCAD использует этот механизм для обеспечения совместимости файлов DWG, если пользовательское приложение не загружено.

Задайте для параметра чертежа PROXYGRAPHICS значение 1 для сохранения графики в чертеже, иначе при открытии файла с помощь адаптера объектов Object Enabler на месте расположения объекта будет отображаться ограничивающий параллелепипед.

Установка адаптера объектов Civil Object Enabler на любом программном продукте AutoCAD 2009 позволяет:

  • Обеспечить поддержку команд AutoCAD "Список", и "Стереть" для объектов civil
  • Включать точки привязки на объектах Civil (т.е. использовать привязку и отслеживание объектов)
  • Редактировать метки с помощью ручек
  • Поддерживать отображение некоторых типов объектов Civil в Палитре свойств объекта AutoCAD

Визуальная точность отображения

Отображением объектов Civil в AutoCAD Civil 3D управляют стили, которые могут иметь много разных параметров для отображения объектов в 2D и 3D видах. Адаптер объектов Civil Object Enabler соблюдает эти параметры; поэтому, например, поверхность, сконфигурированная для отображения только горизонталей в 3D виде, будет отображаться только горизонталями в 3D виде при включенном сеансе AutoCAD.

Точность представления слоя

Стили объектов Civil в AutoCAD Civil 3D можно сконфигурировать так, что управление отображением объекта может быть передано манипулирующим слоям. Если в стиле объекта установлен параметр "ПоСлою" (например, для цвета или веса линии), при включенном сеансе AutoCAD можно выполнять следующее:

  • Изменять параметры слоя объекта и слоя субкомпонента объекта для обновления отображения объекта
  • Включать/выключать слои или фиксировать/освобождать слои для изменения видимости объекта

Если в стиле объекта задан параметр слоя "ПоБлоку", в случае изменения слоя объекта при включенном сеансе AutoCAD соответствующим образом изменится отображение объекта и его субкомпонентов.


Где найти и как установить адаптер объектов Civil Object Enabler

Использование адаптера объектов Civil Object Enabler для данных объектов AutoCAD Civil 3D 2009
Использование адаптера объектов AutoCAD Civil Object Enabler для данных объектов Civil 3D 2009
Типы объектов, создаваемые с помощью AutoCAD Civil 3D
Где найти и как установить адаптер объектов Civil Object Enabler

Адаптер объектов Civil Object Enabler распространяется на дистрибутивном носителе AutoCAD Civil 3D 2009, это приложение также можно загрузить с веб-сайта Autodesk.

Ниже приведены инструкции по установке адаптера объектов Civil с дистрибутивного носителя программного продукта. Кроме того, можно загрузить самую последнюю версию приложения с веб-узла autodesk Http://www.autodesk.com/aecobjenabler.

Установка адаптера объектов Civil Object Enabler

  1. Вставьте установочный диск AutoCAD Civil 3D 2009 в дисковод компакт-дисков компьютера.
  2. В Мастере установки AutoCAD Civil 3D 2009 щелкните на ссылке "Установить".
  3. На странице "Установка" выберите вариант "Установить дополнительные инструменты". Затем выберите "Адаптер объектов Civil 2008 Object Enabler" и выполняйте появляющиеся на экране указания.
  4. После получения соответствующего запроса перезапустите компьютер.


Типы объектов, создаваемые с помощью AutoCAD Civil 3D

Где найти и как установить адаптер объектов Civil Object Enabler
Использование адаптера объектов AutoCAD Civil Object Enabler для данных объектов Civil 3D 2009
Использование диспетчера свойств объекта при включенном сеансе AutoCAD
Типы объектов, создаваемые с помощью AutoCAD Civil 3D

С помощью AutoCAD Civil 3D 2009 можно создавать различные типы пользовательских графических объектов.

К ним относятся следующие:

  • Поверхность
  • Линия меток горизонтали
  • Точка
  • Группа точек
  • Таблица
  • Трасса
  • Коридор
  • Конструкция (дорожного полотна)
  • Элемент конструкции
  • Труба и Колодец (план)
  • Труба и Колодец (вид профиля)
  • Труба и Колодец (вид сечения)
  • Трубопроводная сеть Взаимодействие
  • Площадь участка
  • Сегменты участка
  • Площадка
  • Объект профилирования
  • Профиль
  • Вид профиля
  • Ось сечения
  • Сечение поверхности
  • Сечение материала
  • Вид сечения
  • Лист Вида сечения
  • Фигура съемки
  • Съемочная сеть
  • Рамка вида
  • Линия соответствия
  • Одиночные метки
  • Групповые метки
  • Линия диаграммы земляных масс
  • Вид диаграммы земляных масс

Адаптер объектов Civil Object Enabler позволяет просматривать эти объекты и связанные с ними метки в сеансе AutoCAD 2009.


Использование диспетчера свойств объекта при включенном сеансе AutoCAD

Типы объектов, создаваемые с помощью AutoCAD Civil 3D
Поддерживаемые команды AutoCAD
Использование диспетчера свойств объекта при включенном сеансе AutoCAD

Определенную информацию об объектах AutoCAD Civil 3D можно видеть в окне AutoCAD "Свойства объекта".

Для доступа к окну свойств используйте команду "Свойства" [image] "Редактировать" или щелкните на объекте правой кнопкой мыши и выберите "Свойства". Используя окно "Свойства" при включенном сеансе AutoCAD, можно изменить ряд свойств AutoCAD.


Поддерживаемые команды AutoCAD

Использование диспетчера свойств объекта при включенном сеансе AutoCAD
Использование адаптера объектов AutoCAD Civil Object Enabler для данных объектов Civil 3D 2009
Расчленение объектов AutoCAD Civil 3D
Поддерживаемые команды AutoCAD

Все объекты AutoCAD Civil 3D поддерживают команды AutoCAD "Список", "Расчленить" и "Стереть". Команда "Список" адаптера объектов Object Enabler работает так же, как и команда "Список" AutoCAD Civil 3D.

Большинство объектов AutoCAD Civil 3D частично поддерживает и другие команды. К этим командам относятся "Копировать", "Перенести", "Зеркало", "Подобие", "Масштаб", "Блок/Пблок", "Повернуть", "Обрезать" и "Удлинить".

В следующей таблице перечислена дополнительная информация, относящаяся к работе команд с конкретными объектами, и результаты.

ПримечаниеЗапустить команду "Копировать" можно вводом КОПИРОВАТЬ в командной строке или используя команду контекстного меню "Основные преобразования" [image] "Копировать". Команды "Блок/ПБлок" можно запустить с помощью команд контекстного меню "Буфер обмена" [image] "Копировать" или "Буфер обмена" [image] "Копировать с базовой точкой", можно также нажать CTRL+C на клавиатуре или ввести ПБЛОК в командной строке.

Примечания к поддерживаемым командам AutoCAD

Поверхность

Если выполняется стирание или расчленение поверхности, то профили и сечения, имеющие ссылки на эту поверхность, становятся статическими.

С помощью команды "Зеркало" создается копия, но без учета параметров зеркала.

Команда "ПБлок" охватывает также группы точек, используемые в определении поверхности.

Точка

В случае применения команд "ПБлок" или "Вставка" к точкам или при копировании точек для разрешения конфликта номеров выводится диалоговое окно.

Таблица

Применение команды "ПБлок" к таблице создает также копию требуемой геометрии. Например, точки будут скопированы вместе с таблицей точек.

Трасса

С помощью команды "Расчленить" или "Стереть", примененной в отношении трассы, выполняется расчленение или стирание всех объектов, зависимых от трассы, (например, профилей, видов профилей, осей сечений, сечений и видов сечений).

Копирование трассы создает трассу с новым именем на той же площадке. Все зависимые объекты будут скопированы и включены в состав новой трассы.

С помощью команд "ПБлок"/"Вставка" копируется трасса и все зависимые объекты на новую площадку.

Участок (выбрать метку участка)

Копирование участка или применение к нему команды "ПБлок" действует и по отношению к зависимым сегментам участка. Если объекты вставляются в тот же чертеж, то создается новая площадка.

Переносить можно только метки участка.

Линии сегментов участка

Если команды "ПБлок"/"Вставка" применены к линиям сегментов участка, то линии сегментов создаются на новой площадке.

Объект профилирования

Существуют две разные операции копирования, которые можно выполнить в отношении объекта профилирования. Копирование характерной линии проекции объекта или отдельной целевой линии создает новую характерную линию на новой площадке. Применение команды "Копировать" ко всему объекту профилирования копирует проекцию объекта, цель и критерии.

Проекция объекта может быть перенесена. Целевая линия не может быть перенесена.

Если в критериях профилирования имеются ссылки на поверхность, то поверхность также участвует в операции "ПБлок"/"Вставка".

Профиль

Стирание профиля или сечения удаляет его из всех видов профилей или видов сечений.

Профили и сечения можно переносить только вертикально в пределах вида.

Вид профиля

Если в отношении профиля или вида профиля применена команда "ПБлок", то будут скопированы все объекты, требующиеся для этого профиля или вида профиля (например, поверхность, трасса, профиль, осей сечений и сечения). Если объекты вставляются в тот же чертеж, то создается новая площадка.

Ось сечения

Невозможно скопировать или перенести ось сечения

Сечение

Стирание профиля или сечения удаляет его из всех видов профилей или видов сечений.

Профили и сечения можно переносить только вертикально в пределах вида.

Если в отношении оси сечения, сечения или вида сечения применена команда "ПБлок", то будут скопированы все объекты, требующиеся для оси сечения, сечения или вида сечения (например, поверхность, трасса, сечения и оси сечений). Если объекты копируются в тот же чертеж, то создается новая площадка.

Конструкция

Имена конструкций и элементов конструкции при копировании получают приращение имени. Применение команды "Копировать" к конструкции копирует конструкцию и все зависимые элементы конструкции.

С помощью команды "Зеркало" создается копия, но без учета параметров зеркала.

Коридор

Применение команд "Копировать" или "ПБлок" к коридору создает копию всех зависимых данных, таких как конструкции, трассы и поверхности.

Трубопроводная сеть

Объекты трубопроводной сети недоступны в среде адаптера объектов Object Enabler.

Труба

Применение команды "Копировать" в отношении профиля части сети создаст копию родительской части сети (трубу или колодец).

Колодец

При копировании, зеркальном отображении, сведении в массивы и смещении труб и колодцев происходит обновление ссылок всех присоединенных частей.

Скопированные трубы и колодцы будут находиться в той же самой сети.

Перенос или поворот колодца вызывает перемещение вместе с ним всех присоединенных частей (соединения не разрываются).

Перемещение или поворот трубы разрывает все соединения с присоединенными частями.

Масштабирование трубы или колодца влияет на положение, но не влияет на размер.

Применение команды "ПБлок" к трубам и колодцам создает копию всех зависимых объектов.

Съемочная сеть

Применение команды "Копировать" к съемочной сети создает характерные линии. Команда "Перенести" отделяет фигуру от модели.

Фигура съемки

Использование команды "Подобие" на фигуре съемки формирует объект с характерной линией, а не фигуру съемки.

В результате применения команд перемещения разрывается связь фигуры с моделью.

Линия диаграммы земляных масс

Использование команд расчленения позволяет сохранить параметры слоя и отображения, поэтому элементы будут отображаться точно также, как они отображались в объекте, за исключением объектов, которым назначен цвет "ПоБлоку".

Команда удлинения позволяет выбрать объект в качестве кромки, до которой выполняется удлинение; выбрать объект непосредственно для удлинения невозможно.

При помощи Команды "Обрезать" выбираются объекты, по которым выполняется обрезка, а не те объекты, которые обрезаются.

Если к диаграммам земляных масс применена команда ПБЛОК, будут скопированы все объекты, необходимые для этой диаграммы. Команда ПБЛОК/ВСТАВИТЬ выполняется при нажатии сочетаний клавиш CTRL+C и CTRL+V.

Вид диаграммы земляных масс

Виды именуются автоматически как "Существующее имя" (#), где # - приращение. В случае конфликта используется следующее значение.

Команда копирования или команда контекстного меню "Копировать выбранные" создает копию вида с именем "Существующее имя" (#), где # - приращение.

Команда расчленения позволяет сохранить параметры слоя и отображения, поэтому элементы будут отображаться точно также, как и в объекте, за исключением объектов, которым назначен цвет "ПоБлоку". Расчленение вида не приводит к расчленению линии диаграммы.

Команду ЗЕРКАЛО можно применять к виду, но она не учитывает параметры зеркального отображения. Будет создана дополнительная копия вида профиля.

Если к виду применена команда ПБЛОК, будут копироваться все объекты, необходимые для вида. Команда ПБЛОК/ВСТАВИТЬ выполняется при нажатии сочетаний клавиш CTRL+C и CTRL+V.


Расчленение объектов AutoCAD Civil 3D

Поддерживаемые команды AutoCAD
Часто задаваемые вопросы
Расчленение объектов AutoCAD Civil 3D

Использование команды "Экспорт в AutoCAD" создает новый чертеж формата AutoCAD 2004 или 2000, в котором все объекты Civil расчленены. Оригинал чертежа не изменяется. Имеется два способа расчленения: использование команды "Расчленить" или экспорт, как описано ниже.

Чтобы расчленить объекты AutoCAD Civil 3D при включенном сеансе AutoCAD:

  1. В AutoCAD с включенным адаптером объектов Civil Object Enabler следует ввести в командной строке -AecExportToAutoCAD. Появится следующий запрос:

    Параметры экспорта [Формат/Внедрение/Тип внедрения/Префикс/Суффикс/?] <Нажмите ENTER для указания имени файла>:

  2. Введите Ф для отображения опции формата и затем введите формат.
  3. Введите В для указания внедрения внешних ссылок. Введите Да или Нет.
  4. Введите Т для указания типа привязки. Введите Внедрить или Вставить.

    Метод внедрения сохраняет идентификацию внешних ссылок, такую как имена слоев. Метод вставки привязывает внешние ссылки к текущему чертежу способом, похожим на разъединение и вставку связываемого чертежа.

  5. Введите П для указания префикса файла и затем вставьте префикс.
  6. Введите С для указания суффикса файла и затем вставьте суффикс.
  7. Введите ? для проверки указанных вами параметров.
  8. Когда вы полностью введете параметры, нажмите ENTER в запросе <Нажмите ENTER для указания имени файла>:, а затем укажите имя файла, включая путь. Например, введите C:\My Documents\ACAD-Drawing1.dwg.

    Файл будет сохранен в указанном месте.


Часто задаваемые вопросы

Расчленение объектов AutoCAD Civil 3D
Часто задаваемые вопросы

Ниже рассмотрены вопросы об установке адаптера объектов Object Enabler и его использовании

ПримечаниеКроме того, самую последнюю версию приложения можно загрузить с веб-узла Autodesk по адресу http://www.autodesk.com/aecobjenabler.

Что такое адаптер объектов Civil Object Enabler?

Адаптер объектов Civil Object Enabler - это утилита, которая позволяет пользователям программных продуктов на основе AutoCAD 2009 просматривать и выполнять ограниченное редактирование объектов AutoCAD Civil 3D. С помощью адаптера объектов Civil Object Enabler может быть достигнута полная совместимость программных продуктов на основе AutoCAD 2009 с объектами AutoCAD Civil 3D.

Можно ли установить адаптер объектов Civil Object Enabler с версией AutoCAD ранее 2009?

Нет. Адаптер объектов Civil Object Enabler можно установить только с программами на основе AutoCAD 2009.

Требуется ли устанавливать утилиту адаптер объектов Civil Object Enabler, чтобы просматривать чертежи AutoCAD Civil 3D в программных приложениях на основе AutoCAD?

Нет. Механизм графических объектов заместителей AutoCAD (начиная с версии AutoCAD R13) позволяет просматривать объекты AutoCAD Civil 3D в AutoCAD и в других программах Autodesk, которые могут считывать файлы чертежей. Перед сохранением чертежей в Civil 3D не забудьте включить графические объекты заместителей.

В чем отличие адаптера объектов Civil Object Enabler от графических объектов заместителей?

Адаптер объектов Civil Object Enabler не заменяет возможности механизма взаимодействия графических объектов заместителей. Графические объекты заместителей остаются ценным "средством" взаимодействия для всего комплекса программ Autodesk. Адаптер объектов Civil Object Enabler обеспечивает более высокий уровень совместимости для пользователей AutoCAD.

Как пользоваться адаптером объектов Civil Object Enabler?

После установки адаптер объектов Civil Object Enabler запускается автоматически в имеющейся у пользователя конфигурации AutoCAD. При открытии файла чертежа, содержащего объекты AutoCAD Civil 3D, появляется возможность редактирования этих объектов непосредственно с помощью команд AutoCAD. Отсутствуют какие-либо меню, инструментальные панели или функции командной строки. Основным преимуществом адаптера объектов Civil Object Enabler является возможность использования существующих и известных команд AutoCAD на объектах AutoCAD Civil 3D без необходимости изучения новых функциональных средств.

Можно ли создавать интеллектуальные объекты с помощью адаптера объектов Civil Object Enabler в AutoCAD 2009?

В AutoCAD 2009 отсутствуют какие-либо команды для создания новых объектов с использованием адаптера объектов Civil Object Enabler. Копирование существующих объектов, однако, поддерживается для большинства из них, при этом они сохраняют свои логические функции.

Как установить адаптер объектов Civil Object Enabler?

Адаптер объектов Civil Object Enabler находится на дистрибутивном носителе вашего основного программного продукта. Кроме того, самую последнюю версию приложения можно загрузить с веб-узла Autodesk по адресу http://www.autodesk.com/aecobjenabler.

Как можно распространять устанавливаемую версию адаптера объектов Civil Object Enabler?

Адаптер объектов Civil Object Enabler представляет собой свободно распространяемое программное приложение, которое можно передавать всем, кому нужно просматривать ваши чертежи. Однако сама по себе эта утилита не может отображать ваши чертежи. Необходимо установить копию AutoCAD 2009 или программного продукта на основе AutoCAD 2009.

Как проверить правильность установки адаптера объектов Civil Object Enabler?

После установки адаптер объектов Civil Object Enabler добавляется в перечень программ "Добавить/Удалить программы" на Панели управления Windows.

Существуют ли какие-нибудь переменные AutoCAD, влияющие на работу адаптера объектов Civil Object Enabler?

При использовании адаптера объектов Civil Object Enabler рекомендуется использовать настройку "Обнаружение объекта и вызов команды" в окне "Настройка" AutoCAD.

Чтобы выбрать параметр "Обнаружение объекта и вызов команды":

  1. В командной строке AutoCAD ведите команду НАСТРОЙКА, появится диалоговое окно AutoCAD "Настройка".
  2. Нажмите на вкладке "Открытие/Сохранение".
  3. Для параметра "Подгрузка ObjectARX-приложений" группы "Приложения ObjectARX" выберите значение "Обнаружение объекта и вызов команды".

Это значение параметра включает проверку на наличие в чертеже каких-либо пользовательских объектов и загрузку родительского приложения ARX/DBX.

ПримечаниеПри использовании адаптера объектов Object Enabler Civil для просмотра пользовательских объектов необходимо установить для параметра "Подгрузка ObjectARX-приложений" значение "Обнаружение сторонних объектов" (1) или "Обнаружение объекта и вызов команды" (3).


Комментарии пользователя

Данная форма предназначена для ввода замечаний и предложений, которые будут отправлены в группу технической документации компании Autodesk.

Заголовок и расположение раздела (не изменять):
Имя и фамилия (не обязательно):
         E-mail (не обязательно):
Текст комментария:

Замечание: Форма не может служить средством получения советов или технической поддержки. Информация из нее будет использована для улучшения документации по продукту. Благодарим Вас!