使用 AutoCAD Civil Object Enabler 處理 Civil 3D 2009 物件資料

使用 Civil Object Enabler 處理 AutoCAD Civil 3D 2009 物件資料

AutoCAD Civil Object Enabler 可讓您在 AutoCAD 2009 的應用程式中存取 AutoCAD Civil 3D 2009 和 AutoCAD Land Desktop 2009 土木物件資料，而無須將這些產品安裝在您的電腦上。

注意事項AutoCAD Civil Object Enabler 可與 AutoCAD Civil 3D 2009 和 AutoCAD Land Desktop 2009 配合使用。

可在以下 Autodesk 產品中啟用土木物件：

  • AutoCAD 2009
  • AutoCAD Mechanical 2009
  • AutoCAD Architecture 2009
  • AutoCAD MEP 2009
  • AutoCAD Map 3D 2009
  • AutoCAD Electrical 2009
  • Autodesk 3ds Max Design 2009
  • Autodesk 3ds Max 2009
  • Autodesk NavisWorks Manage 2009
  • Autodesk NavisWorks Review 2009
  • Autodesk NavisWorks Simulate 2009
  • Autodesk Impression 2009

若要存取上述產品的舊版本，請至 http://www.autodesk.com/aecobjenabler 下載正確的版本。

本節主題

  • 使用 Civil Object Enabler 處理 AutoCAD Civil 3D 2009 物件資料

    Civil Object Enabler 是一個免費軟體應用程式，可用於存取 AutoCAD Civil 3D 2009 圖檔。此版本允許在 AutoCAD Civil 3D 2009 環境之外存取於 AutoCAD Civil 3D 2009 中建立的物件資料。

  • 存取和安裝 Civil Object Enabler

    Civil Object Enabler 可從您的 AutoCAD Civil 3D 2009 產品媒體以及 Autodesk 網站獲得。

  • 使用 AutoCAD Civil 3D 建立之物件的類型

    AutoCAD Civil 3D 2009 可建立許多不同類型的自訂圖形物件。

  • 在啟用的 AutoCAD 作業期中使用物件性質管理員

    您可以在 AutoCAD 物件「性質」視窗中檢視某些與 AutoCAD Civil 3D 物件相關的資訊。

  • 支援的 AutoCAD 指令

    所有 AutoCAD Civil 3D 物件均支援 AutoCAD 列示、分解和刪除指令。Object Enabler 列示指令與 AutoCAD Civil 3D 列示指令作用相同。

  • 分解 AutoCAD Civil 3D 物件

    使用「匯出至 AutoCAD」指令建立所有土木物件均已分解的新 AutoCAD 2004 或 2000 格式圖面。原始圖面不會受到影響。有兩種分解方法：使用分解指令或以下列方法匯出。

  • 常見問題

    有關 Object Enabler 安裝和使用的問題在以下主題中進行解答。

請將您對此頁的意見寄給我們


使用 Civil Object Enabler 處理 AutoCAD Civil 3D 2009 物件資料

存取和安裝 Civil Object Enabler
使用 Civil Object Enabler 處理 AutoCAD Civil 3D 2009 物件資料

Civil Object Enabler 是一個免費軟體應用程式，可用於存取 AutoCAD Civil 3D 2009 圖檔。此版本允許在 AutoCAD Civil 3D 2009 環境之外存取於 AutoCAD Civil 3D 2009 中建立的物件資料。

例如，如果您的 AutoCAD 軟體中有一半為 AutoCAD 2009，另一半為 AutoCAD Civil 3D 2009，則使用純 AutoCAD 2009 的使用者可以安裝 Civil Object Enabler。安裝 Civil Object Enabler 之後，使用者便可開啟在 AutoCAD Civil 3D 2009 中建立的圖面，並可檢視、出圖、操控以及複製自訂物件。

如果未安裝此 Enabler ，您可以使用代理圖形共用圖面。代理圖形將提供另一種方法，以使用簡單的圖形表現法顯示物件。表現為代理圖形的物件缺少實際物件的完整「智能」。代理圖形還會增加圖面大小。如果未載入自訂應用程式，AutoCAD 會使用此機制獲得 DWG 檔案的相容性。

將 PROXYGRAPHICS 圖面設定設為 1 以將圖形與圖面一起儲存，否則使用 Object Enabler 開啟物件時會在物件處顯示「邊界框」。

在任何 AutoCAD 2009 產品上安裝 Civil Object Enabler 可啟用：

  • 對土木物件的 AutoCAD 列示和刪除指令的支援
  • 土木物件上的鎖點 (以便您可以使用物件鎖點和物件循跡)
  • 標示的掣點編輯
  • 對在「AutoCAD 物件性質」選項板中顯示某些類型的土木物件的支援

視覺保真度

AutoCAD Civil 3D 土木物件的外觀由型式控制，這些型式可以具有不同的設定，以便在 2D 和 3D 視圖中檢視這些物件。Civil Object Enabler 遵守這些設定，因此舉例來說，規劃為在 3D 中僅展示等高線的地形，在啟用的 AutoCAD 作業期中於 3D 內進行檢視時將僅展示等高線。

圖層保真度

AutoCAD Civil 3D 土木物件型式可以進行規劃，以便可以透過操控圖層控制物件外觀。如果物件型式設定 (例如顏色和線粗) 已設定為「依圖層」，則您可以在啟用的 AutoCAD 作業期中執行以下作業：

  • 變更物件圖層和物件子元件圖層設定，以更新物件顯示
  • 打開/關閉圖層，或凍結/解凍圖層，以變更物件可見性

如果物件型式中的圖層設定已設定為「依圖塊」，則在啟用的 AutoCAD 作業期中變更物件圖層會相應地變更物件及其子元件的顯示。


存取和安裝 Civil Object Enabler

使用 Civil Object Enabler 處理 AutoCAD Civil 3D 2009 物件資料
使用 AutoCAD Civil 3D 建立之物件的類型
存取和安裝 Civil Object Enabler

Civil Object Enabler 可從您的 AutoCAD Civil 3D 2009 產品媒體以及 Autodesk 網站獲得。

請參閱以下說明，以從產品媒體安裝 Civil Object Enabler。 此外，您也可以從 Autodesk 網站 http://www.autodesk.com/aecobjenabler 下載最新版本。

安裝 Civil Object Enabler

  1. 將 AutoCAD Civil 3D 2009 產品媒體插入您電腦的媒體光碟機。
  2. 在 AutoCAD Civil 3D 2009 安裝精靈中，按一下「安裝」連接。
  3. 在「安裝」頁面，按一下「安裝其他工具」。然後按一下「Civil Object Enabler」，並按照螢幕指示進行操作。
  4. 當系統提示時，請重新啟動電腦。


使用 AutoCAD Civil 3D 建立之物件的類型

存取和安裝 Civil Object Enabler
在啟用的 AutoCAD 作業期中使用物件性質管理員
使用 AutoCAD Civil 3D 建立之物件的類型

AutoCAD Civil 3D 2009 可建立許多不同類型的自訂圖形物件。

這些物件包括：

  • 曲面
  • 等高線標示線
  • 點
  • 點群組
  • 表格
  • 對齊
  • 廊道
  • 組合
  • 次組合
  • 管和結構 (平面)
  • 管和結構 (縱斷面視圖)
  • 管和結構 (剖面視圖)
  • 管網干涉
  • 宗地面積
  • 宗地邊界區段
  • 工址
  • 整地
  • 縱斷面
  • 縱斷面視圖
  • 取樣線
  • 曲面剖面
  • 材料剖面
  • 剖面視圖
  • 剖面視圖圖紙
  • 測量圖形
  • 測量控制網
  • 檢視框
  • 銜接線
  • 單一標示
  • 群組標示
  • 運土線
  • 運土視圖

Civil Object Enabler 可讓您在啟用的 AutoCAD 2009 作業期中檢視這些物件及其關聯的標示。


在啟用的 AutoCAD 作業期中使用物件性質管理員

使用 AutoCAD Civil 3D 建立之物件的類型
支援的 AutoCAD 指令
在啟用的 AutoCAD 作業期中使用物件性質管理員

您可以在 AutoCAD 物件「性質」視窗中檢視某些與 AutoCAD Civil 3D 物件相關的資訊。

使用「修改」 [image] 「性質」指令，或者在物件上按一下右鍵並選取「性質」，以開啟「性質」視窗。在啟用的 AutoCAD 作業期中使用「性質」視窗時，您可以變更某些 AutoCAD 性質。


支援的 AutoCAD 指令

在啟用的 AutoCAD 作業期中使用物件性質管理員
分解 AutoCAD Civil 3D 物件
支援的 AutoCAD 指令

所有 AutoCAD Civil 3D 物件均支援 AutoCAD 列示、分解和刪除指令。Object Enabler 列示指令與 AutoCAD Civil 3D 列示指令作用相同。

大多數 AutoCAD Civil 3D 物件都在某種程度上支援其他指令。這些指令包括「複製」、「移動」、「鏡射」、「偏移」、「比例」、「圖塊/寫入圖塊」、「旋轉」、「修剪」和「延伸」。

下表列示了有關對某些物件的指令作業及其結果的其他資訊。

注意事項透過在指令行上輸入 COPY，或使用快顯功能表上的「基本修改工具」 [image] 「複製」指令，便可進行「複製」操作。透過使用快顯功能表上的「剪貼簿」 [image] 「複製」或「剪貼簿」 [image] 「帶基準點複製」指令、按下 Ctrl+C，或在指令行上輸入 WBLOCK，便可進行「圖塊/寫出圖塊」操作。

支援的 AutoCAD 指令註記

曲面

如果地形被刪除或分解，那麼參考該地面的縱斷面和橫斷面都將變為靜態。

鏡射作業將建立複本但是不會遵循鏡射設定。

地形定義中使用的點群組將作為寫入圖塊的一部分包括在其中。

點

當寫入圖塊、插入或複製點時，將顯示一個對話方塊，用來解決編號衝突問題。

表格

寫入圖塊表格時也會複製必要的幾何圖形。例如，點會與點表格一起複製。

定線

分解或刪除定線時，也會分解或刪除從屬於該定線的所有物件 (例如縱斷面、縱斷面視圖、取樣線、橫斷面和橫斷面視圖)。

複製定線時，將在同一位置建立一條具有新名稱的定線。所有從屬物件將被複製並包含在新定線中。

寫入圖塊/插入作業將把定線及所有從屬物件複製到新工址。

宗地 (選取宗地標示)

當複製或寫入圖塊宗地時，也會包括從屬的宗地邊界區段。如果將物件插入到同一圖面中，將建立一個新工址。

只能移動宗地標示。

宗地邊界區段線

寫入圖塊/插入宗地邊界區段時將在一圖塊新工址中建立宗地邊界區段。

整地

整圖形件有兩種截然不同的複製作業。複製整地版形地勢線或單獨的目標線時，會在新的工址中建立新的地勢線。複製整個整地物件時，會複製整地版形、目標和準則。

可以移動整地版形。但不能移動目標線。

如果整地準則參考的是地形，則該地形將包含在寫入圖塊/插入作業中。

縱斷面

刪除縱斷面或橫斷面時，會從所有縱斷面視圖或橫斷面視圖中刪除它。

在視圖中，縱斷面和橫斷面只能垂直移動。

縱斷面視圖

如果縱斷面或縱斷面視圖被寫入圖塊，那麼該縱斷面或縱斷面視圖所需的所有物件 (例如地形、定線、縱斷面、取樣線和橫斷面) 都將被複製。如果將物件複製到同一圖面中，將建立一個新工址。

取樣線

您不能複製或移動取樣線。

剖面

刪除縱斷面或橫斷面時，會從所有縱斷面視圖或橫斷面視圖中刪除它。

在視圖中，縱斷面和橫斷面只能垂直移動。

如果取樣線、剖面或剖面視圖被寫入圖塊，那麼該取樣線、剖面或剖面視圖所需的所有物件 (例如地形、定線、剖面和取樣線) 都將被複製。如果將物件複製到同一圖面中，將建立一個新工址。

組合

複製時，組合和次組合的名稱中包含的數字將遞增。複製組合時，會複製該組合及其所有從屬次組合。

鏡射作業將建立複本但是不會遵循鏡射設定。

廊道

複製或寫入圖塊廊道時，會複製所有從屬資料，例如組合、定線和地形。

管網

透過 Object Enabler 環境無法存取管網物件。

管

複製管網零件縱斷面時，將建立父系管網零件 (管或結構) 的複本。

結構

複製、鏡射、陣列和偏移管和結構時，會更新所有連接的零件的參考。

複製的管和結構將位於同一管網中。

移動或旋轉結構時，會導致所有連接的零件隨其移動。(保持連接)。

移動或旋轉管時，會斷開與所有連接的零件的連接。

縮放管或結構會影響其位置，但不會影響其大小。

寫入圖塊管和結構會複製所有從屬物件。

測量管網

對測量控制網使用複製指令可以建立地勢線。移動指令可以取消圖形與模型的關聯。

測量圖形

使用測量圖形上的偏移指令將生成地勢線物件，而非測量圖形。

移動指令可取消圖形與模型的關聯。

運土線

使用分解指令可保留圖層和顯示設定，因此圖元的顯示將與其在物件 (指定為「依圖塊」色彩的物件除外) 中的顯示完全相同。

使用「延伸」指令，可以選取物件作為要延伸至的邊緣，但無法選取物件作為要延伸的對象

使用「修剪」指令，物件可做為修剪邊緣被選取，但無法被修剪。

如果運土線被寫入圖塊，則將複製它所需的所有物件。使用者鍵入 ^C 和 ^V 時會使用寫入圖塊/插入。

運土視圖

可以根據「既有名稱」(#) 自動命名視圖，其中 # 為增量。如果發現衝突，將使用下一個計數器。

「複製」指令或在「複製所選項」上按一下右鍵將建立名稱為「既有名稱」(#) 的視圖的複本，其中 # 為增量。

分解指令將保留圖層和顯示設定，因此圖元的顯示將與其在物件 (指定為「依圖塊」色彩的物件除外) 中的顯示完全相同。分解視圖不會分解運土線。

鏡射指令在視圖上很成功，但是它不會允準鏡射設定。您將取得附加的縱斷面視圖複本。

如果視圖被寫入圖塊，則將複製此視圖所需的所有物件。使用者鍵入 ^C 和 ^V 時會使用寫入圖塊/插入。


分解 AutoCAD Civil 3D 物件

支援的 AutoCAD 指令
常見問題
分解 AutoCAD Civil 3D 物件

使用「匯出至 AutoCAD」指令建立所有土木物件均已分解的新 AutoCAD 2004 或 2000 格式圖面。原始圖面不會受到影響。有兩種分解方法：使用分解指令或以下列方法匯出。

在啟用的 AutoCAD 作業期中分解 AutoCAD Civil 3D 物件的步驟

  1. 在使用 Civil Object Enabler 啟用的 AutoCAD 的指令行上輸入 -AecExportToAutoCAD。將顯示下列提示︰

    匯出選項 [格式(F)/併入(B)/併入類型(T)/字首(P)/字尾(S)/?] <輸入檔名>:

  2. 輸入 F 以顯示格式選項，然後指定檔案格式。
  3. 輸入 B 以指定是否併入外部參考。輸入是或否。
  4. 輸入 T 以指定併入類型。輸入併入或插入。

    「併入」方法可保留外部參考 ID (例如圖層名稱)。「插入」方法以類似於分離和插入參考圖面的方式，將外部參考併入至目前圖面。

  5. 輸入 P 以指定檔案字首，然後輸入字首。
  6. 輸入 S 以指定檔案字尾，然後輸入字尾。
  7. 輸入 ? 以審閱指定的設定。
  8. 指定完設定後，出現「<按 Enter 輸入檔名>:」提示時按 Enter，然後指定檔名 (包括路徑)。例如，輸入 C:\My Documents\ACAD-Drawing1.dwg。

    檔案會儲存至指定的位置。


常見問題

分解 AutoCAD Civil 3D 物件
常見問題

有關 Object Enabler 安裝和使用的問題在以下主題中進行解答。

注意事項您可以到 http://www.autodesk.com/aecobjenabler 取得關於 Object Enabler 的最新資訊。

何為 Civil Object Enabler？

Civil Object Enabler 是一種公用程式，它使基於 AutoCAD 2009 之產品的客戶可以檢視 AutoCAD Civil 3D 物件並可對其執行有限的編輯。透過 Civil Object Enabler，使用這些基於 AutoCAD 2009 之產品的任何使用者均可完全使用 AutoCAD Civil 3D 物件。

Civil Object Enabler 是否可安裝在 AutoCAD 2009 之前的版本上？

不是。Civil Object Enabler 僅可安裝在以 AutoCAD 2009 為基礎的產品上。

為在以 AutoCAD 為基礎的應用程式中檢視 AutoCAD Civil 3D 圖面，是否必須安裝 Civil Object Enabler？

不是。AutoCAD 代理圖形機制 (自 AutoCAD R13 開始) 允許在 AutoCAD 或其他可以讀取圖檔的 Autodesk 產品中檢視 AutoCAD Civil 3D 物件。在 Civil 3D 中儲存圖面之前，請確保開啟代理圖形。

Civil Object Enabler 與代理圖形的不同之處是什麼？

Civil Object Enabler 不取代代理圖形的互通性機制。代理圖形會在整個 Autodesk 產品系列中保留交互運作性的重要「公用特徵」。Civil Object Enabler 可為 AutoCAD 使用者提供更加健全的相容性層級。

如何使用 Civil Object Enabler？

安裝後，Civil Object Enabler 會自動配合既有的 AutoCAD 規劃進行工作。如果您開啟包含 AutoCAD Civil 3D 物件的圖檔，這些物件就會處於「作用中」，您可使用 AutoCAD 指令直接對其進行編輯。沒有功能表、工具列或指令行功能。Civil Object Enabler 的強大功能在於，其可在 AutoCAD Civil 3D 物件上使用既有並熟悉的 AutoCAD 指令，而無須學習新功能。

是否可在 AutoCAD 2009 上使用 Civil Object Enabler 建立智能物件？

沒有指令可使用 AutoCAD 2009 和 Civil Object Enabler 建立新物件。但是，針對大多數物件，支援複製既有物件，並且這些物件會保留其智能。

如何安裝 Civil Object Enabler？

您的產品媒體可提供 Civil Object Enabler。此外，您也可以從 Autodesk 網站 http://www.autodesk.com/aecobjenabler 下載最新版本。

如何分發 Civil Object Enabler 安裝？

Civil Object Enabler 是一個免費軟體應用程式，您可以將其分發至想要檢視您的圖面的任何人。但是，Civil Object Enabler 自身將無法顯示圖面。必須已安裝 AutoCAD 2009 或基於 AutoCAD 2009 的產品。

如何確認 Civil Object Enabler 已正確安裝？

安裝 Civil Object Enabler 後，會將其加入至 Windows「控制台」中的「新增/移除程式」清單中。

是否存在影響 Civil Object Enabler 的任何 AutoCAD 變數？

使用 Civil Object Enabler 時，建議您使用「AutoCAD 選項」中的「物件偵測與指令呼叫」選項。

選取「物件偵測與指令呼叫」選項的步驟

  1. 在 AutoCAD 指令行上輸入 OPTIONS，以顯示「AutoCAD 選項」對話方塊。
  2. 按一下「開啟並儲存」頁籤。
  3. 在「ObjectARX 應用程式」和「隨選載入 ObjectARX 應用程式」下，選取「物件偵測與指令呼叫」。

此選項會檢查圖面中存在的所有自訂物件，並載入父系 ARX/DBX 應用程式。

注意事項當您想使用 Civil Object Enabler 檢視自訂物件時，請將「隨選載入 ObjectARX 應用程式」選項設定為「自訂物件偵測 (1)」或「物件偵測與指令呼叫 (3)」。


註解？

利用此格式，將您的意見寄至負責此說明文件的 Autodesk 技術出版團體。

主題標題和位置 (請勿編輯)：
姓名 (可選擇的)：
         電子郵件 (可選擇的)：
註解：

注意： 此表單並不意味，您可以獲得回饋或技術支援。您提供的資訊將用來更新將來的文件。謝謝！