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1

New Features

AutoCAD Civil 3D 2011 contains many new features and enhancements.

New Alignments Features
Feature

Description

Location

Automatic curve
widening based
on rules

New widening features have been added to dynamic offset
alignments. Now you can automatically add widening around
horizontal curves based on a design standard (specified in a
design criteria file), or manually by setting numeric values.

Select an offset alignment.
Click Offset Alignment

■

New Widening Criteria tab has been added to the Create
Offset Alignment dialog box.

■

New Add Automatic Widening command provides the
ability to add automatic widening to existing offset alignments.

tab ➤ Modify panel ➤ Add
Automatic Widening

.

For more information, see Adding Automatic Widening to Dynamic Offset Alignments (page 966).
Segmented transitions around
curves for offset
alignments

New command settings improve the way that offset alignments
are drawn in curve conditions. Now you can specify the number
of segments, and the segment type (lines or arcs) used to distribute a widening transition linearly along curves. This enables
more realistic looking transitions on offset alignments. For more
information, see Setting Defaults for Linear Transitions Around
Curves in Widenings (page 969).

In Toolspace ➤ Settings

Improved station
locking behavior
on alignments

The station locking behavior on alignments has been enhanced.
Now design points, such as design speed locations and station
equation definitions, remain in relative geometric locations when
the alignment geometry is edited. Previously, these locations
would move to the new station location, losing their geometric
relevance.

When moving alignments,
you may notice that design
points, such as design speed
locations and station equation definitions, now remain
in relative geometric loca-

tab, expand Alignment ➤
Commands ➤ right-click
AddWidening ➤ Edit
Command Settings. The
new Linear Transition
Around Curves node contains the new command
settings.

3

Feature

Description

Location
tions when the alignment
geometry is edited.

New API Features
Feature

Description

.NET API

.NET API support has been added for the following objects:
■

Offset Alignments

■

Profile and Profile View Labels

■

Superelevation

NOTE AutoCAD Civil 3D 2011 also includes the API enhancements to styles, command settings,
and alignment labels that were included in AutoCAD Civil 3D - .NET API Extension R1 and
AutoCAD Civil 3D Update 2.
For more information, see AutoCAD Civil 3D Developer Help.

New Corridors Features
Feature

Description

Location

Corridor editing
enhancements

A variety of new, and some existing, corridor editing commands
are now available from the Corridor ribbon tab.
For example, now you can modify corridor regions using commands available from the ribbon. These commands are still
available from the Corridor Properties dialog box; however, accessing these commands from the ribbon often provides a more
streamlined workflow.
The following new panels have been added to the Corridor ribbon tab: Modify Corridor, Modify Region, Modify Corridor Section, Analyze. For more information, see Managing and Editing
Corridors (page 1478).

Select a corridor. On the
Corridor ribbon tab there
are new panels and commands.

Baselines in Prospector

The Corridors collection in Prospector now displays the baselines
associated with each corridor. Now you can view and select the
baselines associated with a corridor from the Prospector, as well
as from the Corridor Properties dialog box. For more information,
see Corridors Collection (Prospector Tab) (page 1474).

In the Toolspace, on the
Prospector tab, expand

A new setting automatically adds all geometry points of the offset
target objects and offset baseline alignments into the corridor
definition. This reduces the need for manual operations. Additional assembly insertion stations are automatically added to the
regions at these points. For more information, see Adding Assemblies At Offset Geometry Points (page 1485).

Select a corridor. Click Cor-

Add corridor stations based on
offset targets
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Corridors ➤ Corridor
name.

ridor tab ➤ Modify Region
panel ➤ Edit Frequency
. Select a region. In the Frequency To Apply Assemblies
dialog box, see the new At
Offset Target Geometry
Points option.

New Data Shortcut Features
Feature

Description

Location

Associate Project
To Current
Drawing

This command is used to associate a default Data Shortcut project
to current drawing. It can also be used to remove the drawing’s
association to a project. For more information, see Associating
a Drawing with a Data Shortcut Project (page 150).

In Toolspace, on the Prospector tab, right-click Data

Associate Project
To Multiple
Drawings

This command is used to associate a default Data Shortcut project
to multiple drawings contained in a specified folder on the file
system. It can also be used to remove the project association
from multiple drawings. For more information, see Associating
Multiple Drawings with a Data Shortcut Project (page 150).

In Toolspace, on the Prospector tab, right-click Data

Shortcuts ➤ Associate
Project To Current Drawing.

Shortcuts ➤ Associate
Project To Multiple Drawings.

New Database and Project Migration Features
Feature

Description

Location

Support for 64bit Operating
System requires
database migration

Due to the requirement to support a 64-bit operating system,
existing external project point databases and survey database
files must be migrated to Microsoft® SQL Server® Compact 3.5
format from Microsoft Access Database format.
The following AutoCAD Civil 3D project files created in AutoCAD
Civil 3D 2010 or earlier versions must be migrated to Microsoft
SQL Server Compact format before they can be accessed in
AutoCAD Civil 3D 2011.

On the Prospector and Survey tabs in Toolspace, an
item that requires migration
will display the “out-of-

■

PointsGeometry.mdb

■

PointsStatus.mdb

■

Survey.sdb

date” icon
to provide a
visual cue that it requires
migration.
To complete the migration,
right-click the item and select the migration command.

For more information, see Survey Databases (page 217).
Support for 64bit Operating
System requires
Vault project migration

Vault projects must also be migrated due to the requirement to
support a 64-bit operating system.
When you perform the migration, Vault checks the project out,
migrates the files, then checks them back in, and the version
number is incremented.
The migrated project files are not backwards-compatible with
previous versions of AutoCAD Civil 3D.
For more information, see Migrating Old Civil 3D Projects (page
176).

On the Prospector tab in
Toolspace, expand the Projects collection. An item
that requires migration will
display the “out-of-date”
icon
to provide a visual
cue that it requires migration.
To complete the migration,
right-click the item and select the migration command.
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New Labels Features
Feature

Description

Location

Decimal character and digit
grouping support

The following new label options are available:

Properties tab of the Text
Component Editor - Contents dialog box

■

Decimal Character: Use Operating System Setting is now
provided as an option in addition to the existing options
Period and Comma.

■

Digit Grouping Symbol: Select Period, Comma, or Use
Operating System Setting.

■

Digit Grouping: Select a digit grouping or Use Operating
System Setting.

NOTE To change the default Operating System setting click
Start ➤ Settings ➤ Control Panel ➤ Regional And Language
Options. Click the Customize button and make changes on the
Numbers tab.
Station Equation
ID as a label and
table property

Grid and geodetic line labels

The Station Equation ID property is useful in situations where
there are duplicate stations along an alignment because station
equations have been assigned. The new label property indicates
which station equation a specific station value (as shown in the
label) is associated with.
The Station Equation ID property is available for the following
types of label and table styles with station values:
■

Alignments

■

Profiles

■

Profile Views

■

Section Views

■

Mass Haul Line

■

Mass Haul View

■

Pipes

■

Structures

■

Intersections

■

Quantity Takeoff

■

View Frame

■

Match Line

In general line label styles the following grid and geodetic label
options have been added:
■

General Segment Grid Distance

■

General Segment Grid Direction

■

General Segment Geodetic Distance

■

General Segment Geodetic Forward Direction

■

General Segment Geodetic Reverse Direction
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Properties tab of the Text
Component Editor - Contents dialog box.

Properties tab of the Text
Component Editor - Contents dialog box.

Feature

Description

Location

Profile view band
style anchor control

Previously, profile labels within profile view bands were always
drawn at the midpoint of the segment drawn in the profile view,
regardless of whether this was the true midpoint. Now using
the Anchor Label To setting, you can specify whether you want
to keep this behavior (Segment In Band), or to create the label
at the true midpoint (True Geometry Location). For more information, see Band Details Tab (Profile Data Band Style Dialog Box)
(page 2414).

In Toolspace, on the Settings tab, expand Profile
View ➤ Band Styles, Horizontal Geometry or Vertical
Geometry types

New Pipe Network Features
Feature

Description

Location

Split Network

The new Split Network command enables you to split a pipe
network in to two pipe networks. The selected pipe network
parts do not move, however, they are associated with a new
pipe network name. For more information, see Splitting Pipe
Networks (page 1358).

Select a pipe network. Click

The new Merge Networks command enables you to merge two
pipe networks into a single pipe network. For more information,
see Merging Pipe Networks (page 1359).

Select a pipe network. Click

Now when you create a pipe network from an object, you can
specify the location on the part to use as a Vertex Elevation Reference. Instead of automatically assigning the elevation of the
object to the centerline of the pipe, you can now specify which
part of the pipe (Outside Top, Crown, Centerline, Invert, or
Outside Bottom) is used to specify the elevation of the part. For
more information, see Using Vertex Elevations (page 1336).

Home tab ➤ Create Design

Merge Networks

Vertex Elevation
Reference

Pipe Networks tab ➤ Modify
panel ➤ Split Network

.

Pipe Networks tab ➤ Modify
panel ➤ Merge Networks
.

panel ➤ Pipe Network dropdown ➤ Create Pipe Network From Object .

New Points Features
Feature

Description

Location

List Available
Point Numbers

A new command, List Available Point Numbers, is available to
help you determine which point numbers have already been
used in the drawing. It lists the points that are in use in the current drawing file, and the point numbers that are available to
be assigned for the creation of new COGO points.
Listing Available Point Numbers (page 541).

Select a COGO point. Click

The Point Groups dialog box now includes Move to Top and
Move to Bottom buttons to control the display order.
This dialog box also supports multiple selections of point groups,
using standard Windows selection methods. Use Shift + click to
select a contiguous group, and CTRL + click to select a noncontiguous group.
For more information, see Changing the Point Group Display
Order (page 558).

In Toolspace, on the Prospector tab, right-click the

Point group display order

COGO Point tab ➤ COGO
Point Tools panel ➤
➤ List Available Point
Numbers

.

Point Groups collection ➤
Properties.
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Feature

Description

Location

Geodetic inverse
reporting

Geodetic direction and distance information is now reported in
the Point Inverse inquiry type.
For more information, see Inquiry Types (page 1808).

Analyze tab ➤ Inquiry panel ➤ Inquiry Tool

.

New Point Cloud Features
Feature

Description

Location

Add point cloud
points to surface

The new Add Points To Surface command enables you to extract
points from a point cloud to add to a new or existing surface.
You can use the entire point cloud or points within a specified
region.
For more information, see Adding Point Cloud Points to Surfaces
(page 600).

Select a point cloud. Click
Point Cloud tab ➤ Point
Cloud Tools panel ➤ Add
Points To Surface

.

New Quantity Takeoff Features
Feature

Description

Location

QTO based on
pipe or structure
depth

A new parameter, Part Depth, is now available in the Pay Item
Formula dialog box.
Part Depth can currently be used for AutoCAD Civil 3D pipe and
structure entities. For pipes, Part Depth is defined as (maximum
cover + minimum cover) /2 + part outer diameter. This new
parameter can be used to compute trenching volume for pipes,
for example. For structures, Part Depth is equal to the structure's
height.
For more information, see Applying and Editing Formulas (page
1305).

Analyze tab ➤ QTO panel ➤ QTO Manager
. In
the QTO Manager vista,
click in the Formula cell of
a pay item.

New Reporting Features
Feature

Description

Location

Milling report

A new report, intended to be used with corridor surfaces created
by milling/overlay subassemblies, provides station and offset
data of the milling areas. This report also includes the total area
of milling for the specified corridor and baseline.
For more information, see Create Reports - Milling Report (page
2480).

In Toolspace, on the Toolbox tab, in the Reports

PDF output

Adobe PDF output is now provided for most report types. For
more information, see Generating a Report (page 1758).

Available in report dialog
boxes as a file type.

LandXML Reporting Settings

The settings for the LandXML reports are now exposed in the
Toolbox.
For example, the General Legal Description reports for alignments and parcels use the Legal Descriptions settings.
For more information, see Specifying Report Settings (page 1757).

In Toolspace, on the Toolbox tab, click the Report
Settings button.
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Manager ➤ Corridor collection

New Sections Features
Feature

Description

Location

Additional volumetric methods

The existing Compute Materials command and the Sample Line
Group Properties (Material List tab) have been enhanced to allow
the selection of the volume computation method: Average End
Area, Prismoidal, or Composite Volume. Previously, section
volumes were calculated using only the Average End Area
method.
For more information, see Sectional Volume Methods (page 1277).

Analyze tab ➤ Volumes And

A new gap definition capability has been added to the Sample
Line Group Properties (Material List tab). You can define gaps
in materials based on station ranges. In addition, you can define
Run Out Distance and Run In Distance properties for the gaps
to allow for better volume calculations in those areas.
For more information, see Defining Gaps and Pockets of Materials
(page 1283).

Select a sample line. Click

Create layouts
from section
views

The new Create Section Sheets command enables you to generate layouts for plotting cross sections. For more information, see
Section Sheet Production (page 1934).
Enhancements have been made to the Create Multiple Views
command to support the Create Section Sheets command. To
generate sheets, you must first generate multiple cross section
views using the new Production option and select a DWT with
a Section type viewport. For more information, see Section
Placement Page (Create Multiple Section Views Wizard) (page
2487).

Click Output tab ➤ Plan

Project objects to
multiple cross
sections in a
single operation

The new Project Objects To Multiple Section Views command
enables you to project objects to multiple section views based
on their proximity to the sample line.
For more information, see Projecting Objects to Multiple Section
Views (page 1265).

Click Home tab ➤ Profile &

Gap definitions

Materials panel ➤ Compute
Materials

.

Sample Line tab ➤ Modify
panel ➤ Group Properties
. Click the Material List
tab, and then click in the
Gap column.

Production panel ➤ Create
Section Sheets

.

Section Views panel ➤ Section Views dropdown ➤ Project Objects To
Multiple Section Views
.

New Superelevation Features
Feature

Description

Location

Calculate/Edit Superelevation
command

The new Calculate/Edit Superelevation command replaces the
Superelevation tab on the Alignment Properties dialog box and
enables you to use a wizard and an editor:

Select an alignment. Click

■

drop-down ➤ Calcu-

■

The Calculate Superelevation wizard walks you through the
calculation of superelevation for all curves or any given
curves in an alignment. The wizard also provides some new
options such as the ability to resolve overlap conditions. For
more information, see Calculating Superelevation Data Using
the Wizard (page 1098).

Alignment tab ➤ Modify
panel ➤ Superelevation

late/Edit Superelevation
.

Prior to calculating superelevation, the Superelevation Curve
Manager displays the details for each curve in the alignment
and the status of the superelevation. When you calculate
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Feature

Description

Location

the superelevation, the Superelevation Curve Manager displays details of each curve as well as the design criteria information that was used to calculate superelevation. Criteria
information includes the criteria file used, the superelevation
rate table, attainment table, and so on. The Superelevation
Curve Manager does not display the actual superelevation
data, just the criteria used for the calculations. Temporary
graphics in the drawing provide visual feedback when you
select a curve. For more information, see Using the Superelevation Curve Manager (page 1102).

Superelevation
Tabular Editor

Superelevation
views

Superelevation
bands on profile
views

The new Superelevation Tabular Editor provides a tabular interface where you can edit superelevation data after creation and
also add or delete critical stations in each region. The editor
displays all of the critical stations and calculated superelevation
data including the cross slopes for each lane.
For more information, see Editing Superelevation Data in the
Tabular Editor (page 1108).

Select an alignment. Click

The new Superelevation View command provides the ability to
create superelevation views, which show a graphical representation of the superelevation along the curves of an alignment.
The superelevation views provide grips for graphical editing.
You can use Ctrl + click to select a single station. Superelevation
Views collections are provided in Toolspace. For more information, see Using Superelevation Views (page 1105).

Select an alignment. Click

New options are provided to control the superelevation band
height and to specify a vertical exaggeration.
For more information, see Band Details Tab (Profile Data Band
Style Dialog Box) (page 2414).

On the Toolspace Settings

Alignment tab ➤ Modify
panel ➤ Superelevation
drop-down ➤ Calculate/Edit Superelevation
.
In the Superelevation Curve
Manager, click Open Tabular Editor.

Alignment tab ➤ Modify
panel ➤ Superelevation Editor drop-down ➤ Superelevation View
.

tab, expand Profile View ➤
Band Styles ➤ Superelevation Data.
Right-click a Superelevation
Data style ➤ Edit. Click the
Band Details tab.

New Surfaces Features
Feature

Description

Location

Bounded
Volumes command adds support for datum
elevation

The Bounded Volumes command has been enhanced to calculate surface-to-datum elevation volumes. Previously, for terrain
surfaces, the volume was calculated from the zero elevation to
the elevations in the bounded area. Now instead of defaulting
to zero, you can specify the datum elevation to use.
For more information, see Calculating Bounded Volumes (page
742).

Analyze tab ➤ Volumes And
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Materials panel ➤ Volumes
drop-down ➤ Bounded
Volumes

.

New Toolspace Features
Feature

Description

Location

Commands for
opening and
closingToolspace
tabs

The Toolspace window, and each Toolspace tab, can now be
opened and closed individually.
For more information, see Opening or Closing the Toolspace
Window (page 96).

Home tab ➤ Palettes panel

Survey Toolspace
commands

In the Survey Toolspace collections, the order and functionality
for some of the right-click commands has changed.
The panorama vista editor is displayed when you use the rightclick Edit command on an item in the Network collection.
The panorama vista editor is displayed when you use the rightclick Edit command from the Network Groups, Figure Groups,
and Survey Point Groups collections.
The right-click Edit command is no longer available from selected
items in the item list view in Survey Toolspace.

Survey tab of Toolspace

Survey Toolspace

The preview pane has been removed from the Survey tab and
is now shown in a separate window.

Survey tab of Toolspace

■

The preview window can be opened and closed by selecting
the Survey Preview button from the Survey tab toolbar.

■

The Survey Preview Settings can be accessed by selecting
the Survey Preview Settings button from the Survey tab
toolbar.

■

When the preview window is open, any item selected in the
Survey Toolspace (tree view or list view) that supports a
preview will be displayed in the preview window according
to its current Survey Preview Settings.

and View tab ➤ Palettes
panel.

Enhanced DGN Data Support
Feature

Description

Location

Attach a DGN
File as an Underlay

You can import MicroStation DGN drawing files into DWG files.
The import process translates basic DGN data into the corresponding DWG file data. The DGN data is placed into the DWG
as an underlay. Depending on the settings that you specify, the
DGN entities and their associated linetypes may be nested
within the DGN underlay, and then copied into the host drawing.
For more information, see Attaching a DGN File as an Underlay
(page 1897).

Insert tab ➤ Import pan-

Copy nested objects nested in a
DGN underlay

You can copy objects that are nested in a DGN underlay that
exists in the current drawing. The NCopy command copies
nested objects from DGN underlays, xrefs, or blocks into the
host drawing. For more information, see Copying Objects that
are Nested in a DGN Underlay (page 1898).

Home tab ➤ Modify pan-

el ➤
Import. Select a
DGN file. On the Import
DGN Settings dialog box,
select the Import Into Current Drawing check box.

el ➤ Copy Nested Objects
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Subscription Features
The Subscription Advantage Pack for AutoCAD Civil 3D 2010 has been integrated into AutoCAD Civil 3D
2011, as have the HEC-RAS and Stage Storage extensions.
HEC-RAS and Stage Storage Extensions
Feature

Description

Location

HEC-RAS Extension

The HEC-RAS Import and Export Tools Extension is now integrated intoAutoCAD Civil 3D. These tools enable you to analyze
flood data using the River Analysis System public domain software from the United States Army Corps of Engineers’ Hydrologic
Engineering Center. For more information, see HEC-RAS Import
and Export (page 1887).

Click Output tab ➤ Export
panel ➤ Export To HEC RAS
.
Click Insert tab ➤ Import
panel ➤
RAS

Stage Storage Extension

The Stage Storage Tool Extension is now integrated into AutoCAD Civil 3D. Using these tools, you can calculate incremental
and cumulative volumes of a basin from an AutoCAD Civil 3D
surface, using either a surface or polylines to define the basin.
For more information, see Calculating Stage Storage Volumes
from a Surface (page 743).

➤ Import HEC
.

Click Analyze tab ➤ Stage
Storage

.

Subscription Advantage Pack Features: Alignments
Feature

Description

Location

Create Alignment
From Existing
Alignment

Provides the ability to create a new alignment from all or part
of an existing horizontal alignment. For more information, see
Creating an Alignment from an Existing Alignment (page 957).

Click Home tab ➤ Create
Design panel ➤ Alignment
drop-down ➤ Create Alignment From Existing Alignment

Create Best Fit
Alignment

.

Provides the ability to create a new alignment using points surveyed along a roadway centerline. Input can also be polylines
or blocks. For more information, see Creating an Alignment by
Best Fit (page 960).

Click Home tab ➤ Create

Spiral By Swept
Angle

Provides the ability to draw a spiral by specifying the total angle
that the spiral sweeps through. The prompt for angle is added
to the existing prompt for A value or length. For more information, see To add a fixed spiral (page 1017).

Additional prompt added
to existing spiral creation
command.

Import Superelevation Data From
File

Provides the ability to import superelevation data from a Microsoft Excel CSV file. For more information, see Importing Superelevation Data (page 1100).

Select an alignment. Click

Design panel ➤ Alignment
drop-down ➤ Create Best
Fit Alignment

.

Alignment tab ➤ Modify
panel ➤ Superelevation
drop-down ➤ Calculate/Edit Superelevation
.
Select the Tabular Editor
button on the Superelevation Curve Manager dialog
box.
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Feature

Description

Location
Click the Import Superelevation Data From File button
.

Subscription Advantage Pack Features: Inquiry
Feature

Description

Location

Minimum Distance Between
Entities

Provides the ability to list the shortest 2D distance between two
entities and to optionally draw a persistent line to identify the
location of this distance. For more information, see Identifying
the Shortest Distance Between Two Entities (page 1811).

Click Analyze tab ➤ Inquiry

Provides the ability to list the minimum vertical distance between
two surfaces. For more information, see Identifying the Shortest
Distance Between Two Surfaces (page 770).

Click Analyze tab ➤ Ground

Minimum Distance Between
Surfaces

panel

Minimum Dis-

tance Between Entities
.

Data panel
Minimum
Distance Between Surfaces
.

Minimum Vertical Distance
Between Entities

Provides the ability to list the vertical distance between two entities at the point where they cross in plan view. For more information, see Identifying the Vertical Distance Between Two Entities
(page 1812).

Click Analyze tab ➤ Inquiry
panel
Minimum Vertical Distance Between Entities
.

Subscription Advantage Pack Features: Point Clouds
Feature

Description

Location

Create Point
Cloud

Provides the ability to create a point cloud object, which is a
collection of points scanned from a terrestrial or airborne laser
scanner. For more information, see Creating Point Cloud Objects
(page 596).
There are new collections in the Toolspace Settings and Prospector trees for managing point clouds.
For more information about point cloud settings, see Point Cloud
Settings dialog box (page 2379).

Click Home tab ➤ Create
Ground Data panel
Create Point Cloud

.

Subscription Advantage Pack Features: Points
Feature

Description

Location

Zoom To Point

Provides the ability to zoom to a COGO point, specified by
number or name. For more information, see Zooming to a Point
(page 1768).

Ribbon: Select a point. Click
COGO Point tab ➤ COGO
Point Tools panel
To Point

Zoom

.
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Feature

Description

Location
Transparent Commands
toolbar:

Subscription Advantage Pack Features: Profiles
Feature

Description

Location

Create Best Fit
Profile

Provides the ability to create a new profile using points surveyed
along a roadway centerline. Input can also be polylines or blocks.
For more information, see Creating a Profile by Best Fit (page
1154).

Click Home tab ➤ Create
Design panel ➤ Profile
drop-down ➤ Create Best
Fit Profile

.

Profile Grade Elevation

Provides the ability to create a point of vertical intersection (PVI)
at a specific elevation along a fixed grade line. For more information, see Using Elevation and Grade to Specify a Point Location
in a Profile View (page 1783).

Transparent Commands

Solve Tangent Intersection

Provides the ability to create a continuous profile of tangents
and PVIs from existing profile tangents that do not currently intersect. For more information, see Extending Profile Tangents
to a PVI (page 1165).

Available from the Profile

toolbar:

.

Layout Tools ➤ tangent
creation drop-down.

Subscription Advantage Pack Features: Roundabouts
Feature

Description

Location

Create Roundabout

Provides the ability to automatically draw a roundabout by selecting existing alignments. For more information, see Creating
Roundabouts (page 1631).

Click Home tab ➤ Create
Design panel ➤ Intersections drop-down ➤ Create
Roundabout

Edit Roundabout

Provides the ability to edit a roundabout that had been drawn
using the Create Roundabout feature. For more information, see
Editing Roundabouts (page 1634).

.

Select a roundabout alignment.Click Alignment
tab ➤ Modify Roundabout
panel ➤ Edit Roundabout
.

Delete Roundabout

Provides the ability to delete elements created using the Create
Roundabout feature. For more information, see Deleting
Roundabouts (page 1637).

Select a roundabout alignment.Click Alignment
tab ➤ Modify Roundabout
panel ➤ Delete Roundabout
.

Add Approach

Provides the ability to add an approach road to a roundabout
that has been created using the Create Roundabout feature. For
more information, see Adding Approach Roads (page 1632).

Click Home tab ➤ Create
Design panel ➤ Intersections drop-down ➤ Add
Approach

Add Turn Slip
Lane

Provides the ability to add a slip lane to a roundabout that has
been created using the Create Roundabout feature. For more
information, see Adding Slip Lanes (page 1633).
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.

Click Home tab ➤ Create
Design panel ➤ Intersec-

Feature

Description

Location
tions drop-down ➤ Add
Turn Slip Lane

.

Subscription Advantage Pack Features: Surfaces
Feature

Description

Location

Create Cropped
Surface

Provides the ability to crop a section of a large surface along
existing triangulation lines, and to put the cropped surface in a
new or existing drawing. For more information, see Cropping
Surfaces (page 716).

Click Home tab ➤ Create
Ground Data panel ➤ Surfaces drop-down ➤ Create
Cropped Surface

Create Surface
From GIS Data

Provides the ability to create a surface based on Arc Spatial Data
Engine (ArcSDE). For more information, see Creating Surfaces
from GIS Data (page 658).

.

Click Home tab ➤ Create
Ground Data panel ➤ Surfaces drop-down ➤ Create
Surface From GIS Data
.

Resolve Crossing
Breaklines

Provides the ability to identify and resolve crossing breaklines in
a surface or a survey database. For more information, see Finding
and Fixing Crossing Breaklines (page 771).

Click Analyze tab ➤ Ground
Data panel

Resolve

Crossing Breaklines
Breakline Reports

Provides reports to list crossing breaklines in a surface or a survey
database and to list invalid breakline conditions. For more information, see Creating Breakline Reports (page 772).

.

In Toolspace, on the Toolbox tab, expand Reports
Manager ➤ Breakline.

Subscription Advantage Pack Features: Survey
Feature

Description

Location

Creating new
survey figures

Create new survey figures by selecting COGO Points, Survey
Points, or other positions in the drawing. For more information,
see Creating a New Figure (page 347).

In Toolspace, on the Survey

Provides a new interface for editing survey figures. For more information, see Editing Survey Figure Vertices (page 366).

Select a figure in the drawing. Click Survey

Survey Figure
Properties

tab ➤ right-click Figures
collection ➤ New.

tab ➤ Modify panel ➤ Survey Figure Properties
Importing multiple point files

Import TSS File

Provides the ability to use control-click to select multiple point
files for import. For more information, see Importing Multiple
Point Files (page 262).

Click Home tab ➤ Create

Provides the ability to import TSS field survey data files. For more
information, see Importing Multiple Point Files (page 262).

Click Home tab ➤ Create

Ground Data panel ➤ Import Survey Data

Provides the ability to import point files using point file formats
that contain user-defined properties. For more information, see
Importing Point Files that Contain User-defined Properties (page
263)

.

Ground Data panel ➤ Import Survey Data

Importing point
files that contain
user-defined
properties

.

.

Click Home tab ➤ Create
Ground Data panel ➤ Import Survey Data

.
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Feature

Description

Location

Display Change
Report

Provides a report to show changes to the survey database. For
more information, see Survey Database Change Report (page
221).

In Toolspace, on the Survey
tab, right-click a survey
database ➤ Display
Change Report.

Subscription Advantage Pack Features: Visibility Checks
Feature

Description

Location

Drive

Displays a 3D visual perspective that simulates “driving” along
a roadway. For more information, see Using the Drive Command
(page 1842).

Click Analyze tab ➤ Design

Provides line of sight analysis between any two points in the
model with respect to one or more surfaces. For more information, see Checking Sight Distance Using Point to Point Line of
Sight (page 1845).

Click Analyze tab ➤ Design

Point To Point

panel ➤ Visibility Check
drop-down ➤ Drive

panel ➤ Visibility Check
drop-down ➤ Point To
Point

Check Sight Distance

Provides line of sight analysis at specified intervals along a corridor. For more information, see Calculating Sight Distance Along
a Corridor (page 1846).

Provides line of sight analysis 360 degrees around a single point
with respect to one or more surfaces. For more information, see
Checking Sight Distance Using a Zone of Visual Influence (page
1848).

.

Click Analyze tab ➤ Design
panel ➤ Visibility Check
drop-down ➤ Check Sight
Distance

Zone Of Visual
Influence

.

.

Click Analyze tab ➤ Design
panel ➤ Visibility Check
drop-down ➤ Zone Of
Visual Influence

.

Changes to Drawing Templates
Included Templates
Feature

Description

New templates for section sheet creation

New imperial and metric templates are provided for section
sheet creation. These templates have a viewport that is set to
“Section” type.
The following section templates are located in the Template\Plan
Production folder:
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■

Civil 3D (Imperial) Section.dwt

■

Civil 3D (Metric) Section.dwt

Feature

Description
For more information, see To prepare drawing templates for
using the plan production tools (page 1902).

Drawing Settings
Feature

Description

Drawing Settings dialog box, Object Layers
tab

Superelevation View layer: C-ROAD-SE-VIEW

General Settings
Feature

Description

General line label styles

Geodetic and grid direction and distance properties can be
labeled on line segments. The following new label styles are
provided as sample content to support these new direction and
distance properties.
■

Geodetic Azimuth Over Distance

■

Geodetic Bearing Over Distance

■

Grid Azimuth Over Distance

■

Grid Bearing Over Distance

Alignment Settings
Feature

Description

Feature Settings

Superelevation Options

Feature Settings

■

Number Of Lanes - Left: 1

■

Number Of Lanes - Right: 1

■

Normal Shoulder Width: 5.0000’, 1.500m

■

% On Tangent For Tangent - Curve: 66.67%

■

% On Spiral For Spiral - Curve: 100%

■

Design Speed Lookup Method: Use Nearest Higher Speed

■

Radius Lookup Method: Use Nearest Lower Radius

■

Curve Smoothing Length: 50.0000’, 20.000m

Automatic Widening Around Curves
■

Widening To Apply On: Inside Only

■

Wheelbase Length: 24.000’, 8.000m

■

Add Automatic Widening At Curves: No

■

Widening By: Through Design Standards

■

Manual Widening Width: 3.000’, 1.000m

NOTE The Manual Widening Width and Manual
Transition Length options are used when the Manual
option is selected for the Widening By setting.
■

Manual Transition Length: 60.000’, 20.000m
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Feature

Description

Command Settings: AddWidening

Linear Transition Around Curves
■

Number Of Segments: 3

■

Transition Segment Type: Lines

Corridor Settings
Feature

Description

Command Settings: CreateCorridor and
CreateSimpleCorridor

Assembly Insertion Defaults

Command Settings: MatchCorrRegionParams

■

Offset Target Geometry Points: True

■

Frequency settings changed to 20.000m (for metric templates only)

All new

Pipe Network Settings
Feature

Description

Feature Settings

Pipe Network Defaults
■

Label Styles

Use Size Name From Parts List As Description: Yes

Default names for Plan Profile labels are now consistent for imperial and metric templates (“Length Description and Slope”
and “Name Only”).

Point Cloud Object Settings
Feature

Description

Point cloud styles

■

True Color: Displays point cloud points in true color if the
point cloud database contains RGB data.

■

LIDAR Point Classification: Displays point cloud points by
LIDAR point classification if the point cloud database contains
LIDAR point classification data.

■

Elevation Ranges: Displays the point cloud points in elevation
ranges, at a specified number of ranges or range interval
and a color scheme.

■

Grayscale Intensity: Displays point cloud points in a grayscale
intensity if the point cloud database contains intensity data.

■

Scaled Color Intensity (Red, Green, Blue versions): Displays
point cloud points in either a red, green, or blue scaled color
intensity if the point cloud database contains intensity data.

■

Single Color: Displays the point cloud points in a single color.

Feature Settings

Command Settings: CreatePointCloud
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Default Styles
■

Point Cloud Default Style: Single Color

■

Layer: V-SITE-SCAN

Feature

Description
■

File Format: LAS

■

Point Cloud Default Style: Single Color

■

Point Cloud Name Template: Point Cloud - <Next Counter>

■

Surface Option: Add Points To A New Surface

■

Region Option: Point Cloud Extents

■

Mid-Ordinate Distance: 1.000’, 0.333m

■

Point Cloud Default Style: Single Color

■

Point Cloud Name Template: Point Cloud - <Next Counter>

Command Settings: AddPointCloudPoints

■

Default File Format: LAS

Point file formats

The following new point file formats are provided to support the
importing of point cloud data using the point cloud commands
CreatePointCloud and AddPointsToSurface.
Comma and space-delimited versions of the following:

Command Settings: AddPointsToSurface

System variables

■

XYZ_Intensity: Contains X, Y, Z coordinates and Intensity
data

■

XYZ_RGB: Contains X, Y, Z coordinates and RGB data

■

XYZ_LIDAR Classification: Contains X, Y, Z coordinates and
LiDAR point classification data

■

POINTCLOUDDENSITY: 50

■

POINTCLOUDRTDENSITY: 5

Quantity Takeoff Settings
Feature

Description

Command Settings: ComputeMaterials

Define Materials Options
■

Volume Computation Method: Average End Area

Sample Line Settings
Feature

Description

Command Settings: CreateSampleLines
(metric templates only)

■

Default Swath Widths: Widths are changed to 20.000m

■

Sampling Increments: Increments are changed to 20.000m

Section View Settings
Feature

Description

Feature Settings

Default Name Format
■

Cross Section Sheet Layout Name Template: Section Sheet
- <Next Counter>
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Feature

Description

Command Settings: CreateMultipleSectionView

Multiple Section View Creation

Command Settings

All new for the following new commands:

■

Placement Option: Production

■

ProjectObjectsToMultiSect

■

CreateSectionSheets

Superelevation View Settings
Feature

Description

Object Style

Basic style added to support new superelevation views.

Feature Settings

All new

Command Settings: CreateSuperelevationView

All new
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2

Workflows

Refer to this section for workflow information for common tasks you might perform when working with AutoCAD Civil
3D.

Moving Data from Land Desktop
Use this workflow to help you efficiently move existing data from AutoCAD Land Desktop to AutoCAD Civil
3D.

Prepare for the move

A clear understanding of your current workflows
----- and processes will help you implement AutoCAD
Civil 3D successfully and be better able to validate
results.

Map or setup styles and settings

Styles control the appearance and sometimes the
behavior of AutoCAD Civil 3D objects. By using
----- styles in AutoCAD Civil 3D, you have great
flexibility in the presentation of design elements,
including labels and tables.

Migrate the LDT data

----- There are various tools and methods for moving
Land Desktop data into AutoCAD Civil 3D.

Labels and Tables Workflow
You can use the workflow topics as a reference for the process of working with labels and tables.
Each topic contains a brief explanation of a stage in the development of labels or tables and provides links
to specific tasks in that stage.

21

Setting Up Label Settings and Styles
Specify settings for labels at various levels in the hierarchal Settings tree. In addition, you define specific
settings for individual labels in the label styles, which manage label content.
The highest levels of settings can serve as a general prototype model for settings that are lower in the
hierarchy. Those settings, if not locked at the drawing level, can be overridden in subordinate settings.
To set up label settings and styles

Define default settings for all labels
----- Right-click the drawing name in the Settings tree
in a drawing (page 1654)
and click Edit Label Style Defaults.

Define default settings for all labels
----- Right-click the feature name in the Settings tree
belonging to a feature (page 1655)
and click Edit Label Style Defaults.

Define default settings for a specific
label style type in a feature (page ----- Right-click the label style type name and click Edit
Label Style Defaults.
1655)

Define a label style (page 1656)

----- Define the settings for a new label style.

Manage label style properties
(page 1664)

----- Define label style layer, visibility, display mode,
and text style.

Inserting and Managing Labels
Follow these steps as a guide to efficiently insert and manage labels.
To insert and manage labels
You usually add labels to drawings when you
Add labels to a drawing (page 1701) ----- create objects such as points, alignments, or
parcels. You can also add labels after you create
the objects.
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Modify labels in a drawing (page
1712)

You can modify label object properties by
----- right-clicking a label and selecting Label Properties
or Properties to open the AutoCAD Properties
palette.

You can use the Layout tab of the Label Style
Add content to labels (page 1686) ----- Composer to define label components, which
define the content of labels.

Add expressions (page 1726)

----- Set up mathematical expressions to use in label
styles.

Manage layout properties (page
1671)

You use the Layout tab of the Label Style
----- Composer dialog box to control text and border
settings, display properties, and content.

Use the Dragged State tab of the Label Style
Manage dragged properties (page
----- Composer dialog box to define leader visibility
1681)
and properties for dragged label text.

Set up labels to be used as tags
(page 1664)

If a label style supports the use of tags and tables,
----- there are a few unique properties you can manage
in the style by changing settings in the Label Style
Composer.

Inserting and Managing Tables
Follow these steps as a guide to efficiently insert and manage tables.
To insert and manage tables

Set up table styles (page 1738)

----- Table styles define which data is displayed in the
table, and control the table appearance.
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Add tables to a drawing (page 1748) ----- Specify table data differently for each object type.

Add surface legend tables (page
1749)

----- Surface tables are created in a legend style and
do not use label styles or tags.

Modify tables (page 1750)

----- You can modify the appearance of a table, or add
or remove data.

Project Management Workflow
Determine whether the project uses data shortcuts or Autodesk Vault, then choose the appropriate workflow.

Standard Workflow
Use these steps as a guide to create an efficient network of drawings within a project.

Set up file access controls

Establish written procedures for project members
----- who will create or access project data. Make
communication between project members a
priority.

Create individual design objects

----- Create the basic surfaces, alignments, and other
object to be shared.

Combine objects into base
drawings

----- Use data references to share read-only copies of
objects across multiple design drawings.

Assemble data for production
drawings

Combine reference objects and external
----- references (xrefs) of entire drawings to produce
the final drawings.
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Data Shortcuts Workflow
Follow these steps for each new data shortcut project.

Set up the project data (page 146) ----- Select the appropriate project template, then
create a project folder within the working folder.

Set up the data shortcuts folder
(page 148)

Designate the new project folder as the active
----- data shortcuts folder. Save project drawings in
the appropriate subfolders of the project folder.

Create data shortcuts (page 151) ----- Open each design drawing and create shortcuts
for any objects to be shared with other drawings.

Create read-only references to specific objects in
Create object references (page 151) ----- other drawings, which are known as consumer
drawings.

Validate data shortcuts (page 155) ----- Periodically validate shortcuts and repair any
broken references.

Autodesk Vault Workflow
Follow these steps for each new Autodesk Vault project.

Designate a Vault Server and
database (page 158)

----- Designate a Vault server and database for the
project.

Create the project in the database
----- Create the project folder and subfolders, ideally
(page 171)
using a standard template.
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Create Vault user names and
groups (page 167)

----- Set appropriate access permissions for user groups
to protect the project data.

Identify and partition project
objects (page 165)

----- Identify project objects and develop a strategy
for partitioning project object data.

While adding source drawings to the project,
Add drawings to the project (page
----- designate which objects can be shared with other
177)
drawings.

Create references to source objects
----- Create read-only object references to save space
in other drawings (page 183)
in the consumer drawings.

Synchronize drawings with latest
project data (page 182)

Ensure that data references are regularly updated
----- with the latest versions of project objects as
designs change.

When a major milestone is reached, use the Vault
Label project milestones (page 174) ----- Labeling feature to tag the appropriate version
of each project file.

Survey Workflow
For information about project phases, see Survey Project Phases (page 210).

Prepare for Survey Data
Before adding survey data to a survey database and drawing, ensure that the styles and settings are set up.
There are several types of settings that you must specify before importing or creating survey data.

Verify Survey user settings (page
227)
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Survey user settings are specific to a Windows
----- user login account and affect only the survey
features including linework defaults.

Set or verify equipment properties
----- Equipment properties specify the values
(page 246)
associated with a specific surveying instrument.

The Survey Figure Prefix database contains
Create/verify Figure Prefix database
----- information on how figures are created and
(page 222)
stylized.

A survey database contains all the control points,
Create Survey database (page 217) ----- known directions, observation measurements,
traverse definitions, figures, and standard
deviations.

Import/edit Survey database
settings (page 238)

----- Survey database settings are specific to the survey
features of an AutoCAD Civil 3D survey database.

Verify Survey drawing settings
(page 247)

Survey drawing feature settings specify the default
----- styles for the survey network object and the figure
object.

Create/verify Survey styles (page
216)

----- Survey styles to control the way the survey
networks and figures are displayed in a drawing.

Obtain and Create Survey Data
Survey data can be brought into AutoCAD Civil 3D using several methods including importing from field
books and LandXML files as well as entering data manually.

Transfer and convert raw file to
.fbk files (page 266)

----- Use the Survey Data Collection Link to download
raw data and convert it to a field book file.
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Import survey data (page 261)

Use the Survey Data wizard, import field book
----- files, import survey LandXML data directly into
the survey database, import a point file, or import
points from a drawing.

Review/update import events
(page 274)

The import event provides a framework that you
----- can use to view and edit specific survey data that
is referenced within the import event.

Add/edit survey data (page 279)

Use AutoCAD Civil 3D to define and manage
----- survey data such as point, setups, directions,
traverses, and figures.

Create/edit survey figures (page
347)

Use the Survey Figure commands to create and
----- edit survey figures, as well as to perform figure
inquiries.

Adjust, Analyze, and Output Survey Data
After you have imported or created survey data, you can use several tools to adjust, analyze, and output it.
Perform a Mapcheck Analysis by selecting
AutoCAD Civil 3D line and curve labels to
Perform mapcheck analysis (page
----- determine values from label objects based on the
1795)
precision of the annotation of the label object, or
enter mapcheck data manually.

Analyze Survey Figures (page 382) ----- Obtain figure information using mapcheck and
inverse methods.

Analyze Survey Networks (page
389)

----- Perform Least Squares analysis.

Analyze Survey traverses (page 403) ----- Analyze traverse data to determine the error of
closure.
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Export survey data to a field book
----- Export survey data from an individual network,
(page 269)
individual figure, or collection of figures.

Create surface breaklines (page 349) ----- Use figures that you located in your survey as
surface breaklines.

Export data to LandXML (page 270) ----- Export survey LandXML data directly from the
survey database.

Points Workflow
Refer to this section for high-level descriptions of tasks you might perform when working with points in
AutoCAD Civil 3D.

Creating a Drawing Template for Points
Creating drawing templates that contain standard styles, settings, and other point-related information helps
you work more efficiently and ensures that final drawings conform to office standards.
To create a drawing template for points

Create a new drawing (page 132) ----- Open an existing drawing or create a new one.

Set the default point settings (page
----- Select the default point settings for the template.
439)

Create the point styles (page 450) ----- Create the point styles for the template.
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Create the point label styles (page
----- Create the point label styles for the template.
452)

Create the point table styles (page
----- Create the point table styles for the template.
1738)

Create the point groups (page 561) ----- Create the point groups for the template.

Create the description keys (page
----- Create the description keys for the template.
584)

Create the point file formats (page
----- Create the point file formats for the template.
529)

Save the drawing as a template
(.dwt)

----- Saving the drawing as template enables you to
leverage the styles and settings.

Creating a Project Point Database
Adding points to an AutoCAD Civil 3D project allows others to access the points.
For more information about AutoCAD Civil 3D projects, see Project Management (page 143).
To create a project point database

Create a new drawing (page 132) ----- Open an existing drawing or create a new one.
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Create points in the drawing (page
----- Use any method, including importing point data
456)
from a file.

Create an AutoCAD Civil 3D
project (page 171)

----- Create a new project in the project database.

Add the drawing points to the
project (page 189)

----- Use the Add To Project command to add points
to a project.

Protect the project points (page
192)

----- To prevent others from modifying the project
points, protect them.

Creating Points in a Drawing
Before creating points in a drawing, specify settings and options that control how points are created and
how they appear in a drawing.
Save time by saving commonly used styles, description keys, point groups, and point file formats in a drawing
template. For more information, see Creating a Drawing Template for Points (page 29).
To create points in a drawing
Use a drawing template that contains styles,
Create a new drawing (page 132) ----- description keys, point file formats, and point
groups you will use

Choose point creation settings
(page 444)

----- Using any method, including importing point
data from a file.

Select point identity settings (page
----- If you plan to create points by importing, select
443)
Point Identity settings.
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Specify description key matching
----- If you are using description key matching, specify
(page 582)
the order in which description keys are matched.

Create/import the points (page 456)
To create copies of project points, use either the
or create copies of project points ----- Get From Project command or the Check Out
(page 192)
command.

Changing the Appearance of Points in a Drawing
Before producing hard-copy drawings for a project, you can adjust the appearance of the points in the
AutoCAD Civil 3D drawing.
Use styles and point groups to change the appearance of the points in a drawing.
To change the appearance of points in a drawing
Use another style. For example, you can remove
Change the appearance of points
(page 449) or use point group
----- the point numbers from the display.
Use point group overrides to change the
overrides (page 555)
appearance of all the points in a point group.

Delete unwanted points (page 519) ----- You can delete unwanted points using the Point
Editor.

Use layers to control point visibility
----- If you prefer that some points are not displayed,
(page 454)
you can turn off or freeze the layer.

Surfaces Workflow
Refer to this section for high-level descriptions of tasks you can perform when working with surfaces in
AutoCAD Civil 3D.

Preparing for Surface Data
Before adding surface data to a drawing, ensure that the styles and settings are set up. Consider creating
drawing templates that contain standard styles and settings. It helps you work more efficiently and ensure
that your final drawings conform to your office standards.
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To create a drawing template for surfaces

Create a new drawing (page 132) ----- Open an existing drawing or create a new one.

Select the default surface settings
----- Specify the default behavior for surface-related
(page 737)
commands.

Create the surface styles (page 749) ----- Use the Toolspace Settings tab to create a surface
style.

Create the surface label styles
(page 752)

----- Use the Toolspace Settings tab to manage surface
label styles.

Create the surface table styles
(page 762)

----- Use the Toolspace Settings tab to manage surface
table styles.

Save the drawing as a template
(.dwt)

----- Saving the drawing as template enables you to
leverage the styles and settings.

Creating Surfaces in a Drawing
Before you create surfaces in a drawing, set up your environment to take advantage of the settings and
options AutoCAD Civil 3D offers for automatically labeling surfaces and surface objects.
To work even more effectively, save the styles in a drawing template. For more information, see Preparing
for Surface Data (page 32).
To create a surface

Create a new drawing (page 132) ----- Create a drawing based on the desired template.
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Select surface creation settings
(page 738)

----- Use surface settings to specify the default behavior
for surface-related commands.

Select default surface styles (page
----- Surface styles control the way a surface is
748)
displayed in a drawing.

Select surface label and table styles
----- Surface label and table styles control the way a
(page 752)
surface’s labels and tables are displayed.

Create a new surface or import a
surface (page 648)

----- Create Grid or TIN surface or import a surface
from a TIN or DEM file.

Adding and Managing Surface Data
When you create a surface, the surface may be empty and therefore is not visible in the drawing. However,
the surface name is displayed in the Prospector tree so you can perform other operations, such as adding
data.
To add and manage surface data

Review the surface editing
operations (page 699)

----- Expand the surface item in the Prospector tree to
display its data.

Add/edit surface data (page 660) ----- Edit operations are added to a surface definition.

Review the surface definition
(page 660)
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----- A surface definition is a collection of a surface’s
build, data, and edit properties.

Manage the surface (page 730)

----- View and change the surface and its data.

Changing the Appearance of Surfaces
As your design progresses, you can change the look of your drawing by changing the surface style or surface
label styles.
To change the appearance of surfaces in a drawing

Create a new style (page 749) or
edit an existing style (page 750)

----- Surface styles control the display of all surface
components.

Modify the label styles (page
762)or modify the table styles (page ----- Move and edit the label and table styles as
required.
762)

Analyzing Surface Information
You can create analysis of surface data and view surface information and statistics.
To analyze surface information

View the statistics for the surface
(page 739)

----- AutoCAD Civil 3D provides extensive statistics
based on the current state of the surface.

Create an analysis of the surface
(page 764)

----- You can analyze depressions, elevations, contours,
slopes, and watersheds.

Calculate volumes (page 740)

----- Query composite and bounded volume
differences between surface.
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Analyze waterdrop paths (page 767) ----- Trace the path that water takes across a surface.

Check for contour problems (page
----- Identify problems with contours that are drawn
766)
according to the surface style’s contour settings.

Analyzing Stage Storage Volumes
Use the Stage Storage Tool in AutoCAD Civil 3D 2011 to analyze the stage storage volumes of basins.

Determine the boundaries for a
basin to be analyzed (page 743)

Before you analyze a basin, use either surface
----- objects or polylines to create the basin
boundaries.

Edit display settings for contours
(page 744)

Before you can calculate basin volumes, you must
----- ensure the contours are displayed in the surface
style.

Set up a Stage Storage Volume
report (page 744)

In the Stage Storage Volume Analysis dialog box,
----- enter the administrative and calculation
information for the Stage Storage Volume
analysis.

Define the basin (page 744)

Define the basin by selecting surface objects or
----- polylines in the drawing, or by manually entering
surface object parameters for the basin.

Save and display the Stage Storage
----- Save the Stage Storage Volume Table, and display
Volume Table (page 747)
it in the drawing.

Save and display the Stage Storage
----- When you save the Stage Storage Volume report,
Volume report (page 747)
the report opens in your default text file viewer.
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Grading Workflow
Refer to this section for high-level descriptions of the most common grading tasks you might perform when
working with grading in AutoCAD Civil 3D.

Setting up Gradings
This section provides high-level descriptions of grading-related tasks you might perform during the early
stages of a project.
Before you begin, save time and effort in the design and drafting phase by doing some setup tasks. Establish
and save grading criteria as a collection of values for commonly used slope methods and projections. Then
apply saved criteria to any grading you create. The following is a list of setup tasks:
To set up for grading

Establish grading settings (page
801)

----- Define the units of measurement for all gradings.

Create grading styles (page 802)

----- Grading styles determine how gradings appear
in the drawing.

Grading criteria predefine the methods and
projections for grading.
Define grading criteria (page 804) ----Watch video: Create a Criteria Set and Criteria
(1 minute 35 seconds)

Designing and Creating Gradings
This section provides high-level descriptions of grading-related tasks you might perform during the design
phase of a project after completing the setup tasks (page 37).
To perform grading design tasks

Create feature lines (page 808)

Convert existing objects, draw parcel lot lines or
----- feature lines, or export feature lines from corridor
models.

Use grading groups to organize the base-line
Create grading groups (page 806) ----- geometry and to control the interaction of
grading objects.
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Create the grading (page 855)

----- Use the Grading Creation Tools.

Modify the grading as required
(page 858)

----- Use edit commands on the Grading menu or the
Grading Creation Tools.

Outputting Grading Information
This section provides high-level descriptions of grading-related tasks that you might perform during the
later stages of a project.
To create finished plans and generate reports from surfaces

Select grading group surface
creation (page 806)

----- Surfaces created from grading can be used to
generate surface analysis displays.

Edit grading styles (page 802)

----- Use styles to establish the display of the grading
and surface.

Plot gradings

----- Prepare and plot grading drawings.

Produce reports (page 1758)

----- Use the AutoCAD Civil 3D Reports feature to
produce reports that include cut and fill volumes.

Parcels Workflow
Refer to this section for high-level descriptions of how to work with parcels in AutoCAD Civil 3D.
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Setting up Parcels
To set up styles for a project with parcels

Determine the types of parcels to
----- Includes site parcels. Decide how to display the
use (page 880)
parcels and their associated labels and tables.

Create a new drawing (page 132) ----- Save as a drawing template if needed.

Create parcel styles (page 894)

----- Parcel styles control the way a parcel is displayed
in a drawing.

Create parcel label styles (page 900) ----- Parcel label styles control the way a parcel’s labels
are displayed.

Create parcel table styles (page 910) ----- Parcel table styles control the way a parcel’s tables
are displayed.

Save the drawing as a template
(.dwt)

----- Saving the drawing as template enables you to
leverage the styles and settings.

Designing and Creating Parcels
Create parcels by converting existing AutoCAD objects, or create parcels directly using the Parcel Layout
Tools toolbar.
AutoCAD objects that you can convert to parcels include closed polylines, and other closed sequences of
lines or arcs. If you are converting AutoCAD objects, they must be free of drawing errors. Use the drawing
cleanup tools in Autodesk Map to accomplish this before you convert the objects.
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To design and create parcels

Create parcels (page 879)

Create parcels from objects by importing
----- AutoCAD objects, by layout using the Parcel
layout toolbar, or subdivide existing parcels to
create new parcels.

Change parcel appearance (page
----- Control parcel display by changing parcel styles
885)
or their label styles.

Edit parcels (page 886)

----- Use the Parcel Layout Tools toolbar to edit parcels.

To merge two parcels, delete a shared segment.
Merge existing parcels (page 890) ----- When you delete a shared segment, you delete
the shared boundary. The two parcels become
one.

Alignments Workflow
Refer to this section for high-level descriptions of tasks you perform when creating, designing, and finishing
alignments in AutoCAD Civil 3D.

Setting Up Alignments
Establish different alignment and label styles for each design phase.
All objects have a default style that you can copy, edit, and then save with a new name. You may begin by
establishing styles for different design phases. For example, design styles might have details that would not
be necessary in plotting styles.
To set up alignments

Set up alignment styles (page 946) ----- Alignment styles control the visual display of each
alignment component.

Set up alignment label styles (page
----- Alignment label styles control the visual display
1043)
of each label component.
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Alignment label sets control the label styles that
Set up alignment label sets (page
----- are applied to the individual elements that you
1045)
want to label on the alignment.

The design criteria file contains minimum local
Set up the design criteria file (page
----- standards tables for design speed, radius, and
936)
length of individual alignment sub-entities.

Set up design checks and design
check sets (page 940)

----- Design checks verify design criteria for parameters
that are not included in the design criteria file.

Designing and Editing Alignments
Create alignments by layout, from polylines, from pipe networks, and from LandXML data.
To design and edit alignments

Create the alignment (page 948) ----- Draw an alignment, or create one from a polyline,
reference, pipe network, or LandXML file.

Edit alignment fixed, floating, or
free entities (page 970)

Use the constraint-based commands on the
Alignment Layout Tools toolbar, to add a fixed
----- entity, a free entity, or a floating entity (lines,
curves, spiral-curve-spiral groups and spirals) to
the alignment.

Use the Alignment Entities vista and Alignment
Edit alignment numeric parameter
----- Layout Parameters dialog box to display and edit
values (page 1066)
parameters of alignment entities that are part of
the solved alignment geometry.

Edit the alignment using grips
(page 1068)

----- Use grips to change the vertical curves and
tangents in an alignment graphically.
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Add final labels to the alignment
(page 1043)

Use the label and table styles to control the
----- appearance and behavior of alignment labels and
tables.

Assign a style for viewing and
plotting (page 946)

----- Use alignment styles to control the visual display
of each alignment component.

Create plan/profile sheets for
plotting (page 61)

----- Use plan production tools to quickly create
construction documents from drawings.

Superelevation Workflow
Refer to this section for high-level descriptions of tasks you might perform when working with superelevation
in AutoCAD Civil 3D.

Setting Up Superelevation
Before calculating superelevation data, you need to ensure that required settings and styles are specified
correctly.
Specify a design speed in the alignment
Specify a design speed (page 934) ----- properties. A design speed is necessary to
calculate superelevation.

Specify Superelevation label
defaults (page 83)

Review the superelevation critical point label
----- options on the Abbreviations tab in the Drawing
Settings.

Verify alignment feature settings
(page 930)

Review the alignment feature settings for
----- Superelevation Options and Dynamic Alignment
Highlight.

Verify default label abbreviations
(page 83)

Review the default label abbreviations for
----- geometry points and superelevation critical
points.
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Customize the criteria files using the Design
Customize criteria files (page 939) ----- Criteria Editor. Superelevation is calculated based
on these files.

Review Profile View band
properties (page 1215)

----- Specify the Profile View band properties for
superelevation data.

Create the alignment (page 948) ----- Create an alignment to use for superelevation
calculations.

Optionally, add user-defined
curves (page 1103)

Add user-defined curves from the Superelevation
Curve Manager. Add curves for situations where
a curve is not automatically created by the
----- program, for example where an alignment has
two compound spirals or a compound spiral in
between spirals. Curves can be added after
calculating superelevation data but you have to
re-calculate the superelevation.

Adding Superelevation Data
You can add superelevation data using the Superelevation wizard or import it from a CSV file.
After you calculate the superelevation, any
changes to the alignment geometry such as
adding, deleting, or moving a curve are reflected
in the Superelevation Tabular Editor. However,
changing the radius of a curve causes the
superelevation data to become out of date and
Calculate superelevation (page 1098)
you have to recalculate.
or
----- The CSV file must have a specific column
Import superelevation from a CSV
structure. The imported data is associated with
file (page 1101)
the alignment in the drawing. There is no design
criteria displayed in the Superelevation Curve
Manager and editing options are available in the
Superelevation Tabular Editor and Superelevation
View. Imported data in the Superelevation Tabular
Editor can be copied to the clipboard and pasted
into an Excel or Word document.
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Viewing and Editing Superelevation Data
Refer to this section for high-level descriptions of editing tasks you might perform when working with
superelevation data.
Change criteria that was used to create
Edit Superelevation Criteria (page
----- superelevation data. If criteria such as design
1104)
speed is changed, then superelevation needs to
be recalculated.

Edit cross slope values and location of critical
Edit superelevation data (page 1108) ----- stations and resolve overlap situations using the
Superelevation Tabular Editor.

Create the superelevation view
(page 1107)

Create a Superelevation View and use grips for
----- graphical editing. Use right-click edit options to
change the properties and display of the view.

Edits in the Superelevation View and the
Manipulate data in superelevation
----- Superelevation Tabular Editor are dynamic and
view (page 1107)
changes made in one are reflected in the other.

Resolve overlaps (page 1108)

Resolve overlap situations by clicking
in the
Overlap column in the Superelevation Tabular
----- Editor. The warning symbol displayed in the
Superelevation Tabular Editor and the
Superelevation View if there is an overlap
situation.

Display a Superelevation Band using the
Display the superelevation band in
----- Superelevation option on the Bands tab in the
a Profile View (page 1139)
Profile View Properties. Superelevation band is
used for plotting.

Create a corridor from the baseline alignment
that contains the superelevation data using the
appropriate subassembly.
Create a corridor (page 45)
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----- IMPORTANT Corridor modeling should not be
done until superelevation is finalized. Changes in
a corridor baseline alignment are not reflected in
Superelevation. Changing superelevation does
not update the corridor model.

Corridor Modeling Workflow
Refer to this section for high-level descriptions of tasks you might perform when working with corridors in
AutoCAD Civil 3D.

Preparing the Drawing for Corridor Creation
Creating drawing templates that contain standard styles and settings will help you work more efficiently
and ensure that your final drawings conform to your office standards.
Preparing the drawing template for corridor creation

Open a drawing (page 132)

----- Open an existing drawing or create a new one.

Select the default settings (page
1478)

----- Use corridor settings to specify the default
behavior for corridor-related commands.

Create the styles (page 1473)

----- Styles control the display and design
characteristics of drawing objects.

Create the label styles (page 1654) ----- You can define default label settings at three
different levels.

Use quantity takeoff settings to specify the default
Create the quantity takeoff criteria
----- style and name format settings for quantity
(page 1275)
takeoff.

Save the drawing as a template
(.dwt) (page 129)

----- By saving as a template, you can leverage the
style and setting changes.
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Setting Up Data for Corridor Creation
Before you create corridors, you must have existing data, such as existing ground surfaces, alignments
(centerlines), profiles (vertical alignments), and typical sections (assemblies).
To set up data for corridor creation

Build the existing ground surfaces
----- Surfaces are used to derive alignments and
(page 648)
profiles, and for corridor grading.

Design the horizontal alignments
----- Alignments are used by a corridor as its centerline.
(page 948)

Create the profiles (page 1141)

----- Use existing ground profiles and design finished
grade profiles (vertical alignments).

Calcualte superelevation for the curves on the
centerline alignment.
IMPORTANT Superelevation should be finalized
Calculate Superelevation (page 1098) ----- before it is applied to the Corridor model.
Changes in a corridor baseline alignment are not
reflected in Superelevation. Changing
superelevation does not update the corridor
model.

Plan the required assemblies (page
----- Use subassemblies to build the required
1548)
assemblies.

Create and maintain the required
----- Before creating an assembly, identify the different
assemblies (page 1557)
types of subassemblies you need,
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Corridor Design and Creation
This section provides the processes used to create corridors.

Create a corridor (page 1475)

----- Use the Create Corridor or Create Simple Corridor
commands.

Modify the corridor (page 1478)

----- Make any required customizations to settings or
styles for the corridor.

Modify or override individual
corridor stations (page 1523)

Override corridor and assembly parameters and
----- apply the overrides to a station or range of
stations.

Visualizing Corridors
After you have created a corridor, create corridor surfaces and boundaries to help you visualize the corridor.
To visualize a corridor

Create a corridor surface (page 1511) ----- When you create a corridor surface, it is added
to the Surfaces collection.

Use corridor surface boundaries to prevent
Create corridor boundaries (page
----- triangulation outside of the daylight lines of a
1511)
corridor surface.

You can use the View/Edit Corridor Section Tools
View corridor sections (page 1519) ----- to visually inspect how assemblies are applied at
various stations.

Render a corridor boundary region
----- Render corridor data using the AutoCAD Render
(page 1533)
command.
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Exporting Corridor Data
After creating a corridor, you can export several types of data.
To export corridor data

Export corridor feature lines (page
----- Export corridor feature lines as alignments,
1528)
grading feature lines, profiles, or polylines.

Export corridor points as COGO
points (page 1531)

Export all points from a selected corridor or
----- constrain the selection based on station ranges
or point code types.

Export corridor surfaces as
----- Exported surfaces are no longer part of the
disconnected surfaces (page 1532)
corridor.

Intersection and Roundabout Workflow
Refer to this section for high-level descriptions of tasks you might perform when working with intersections
and roundabouts in AutoCAD Civil 3D.

Intersection Design Workflow
Refer to this section for high-level descriptions of tasks you might perform when working with intersections
in AutoCAD Civil 3D.

Set up data required for the
intersection (page 1591)

You must have at least two alignments that
intersect each other only once in your drawing.
----- If you want to create a more realistic
intersectionmodel, you will need road geometry
and surface data.

Set the driving direction (page 1592) ----- The driving direction option determines how curb
returns are drawn when creating intersections.

Verify intersection settings (page
1598)
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----- Use intersection settings to specify the default
behavior for intersection-related commands.

Create the intersection (page 1592)----- Use the Create Intersection wizard.

Labeling Intersections (page 1618) ----- You can add labels to intersection objects.

Edit intersections (page 1601)

You can edit intersections using commands
----- available from the ribbon, from right-click
shortcut menus, or by editing the objects directly
in the drawing using grips.

Roundabout Design Workflow
Refer to this section for high-level descriptions of tasks you might perform when designing roundabouts.

Set the Driving Direction option
(page 1624)

Before you begin, set the Driving Direction option
----- in Drawing Settings to either Left Side of the Road
or Right Side of the Road, depending on your
project’s needs.

Create required alignment styles
and label styles. (page 1625)

Styles control the display and design
----- characteristics of drawing objects. You may also
want to create alignment labels that are
specifically designed for roundabouts.

Create the base geometry required to create the
Set up the data required to create
----- roundabout. You must have at least two
the roundabout (page 1625)
alignments.

Use the Create Roundabout command, follow
Create the roundabout (page 1631)----- the prompts, and configure the roundabout
dialog boxes.
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Edit the roundabout (page 1634) ----- You can add slip lanes, approach roads, or move
the roundabout.

After you have created a roundabout, the 2D layout can be continued to be designed in profile, and you can
also create a corridor using existing methods.

Profiles Workflow
Refer to this section for high-level descriptions of tasks you perform when working with profiles and profile
views.

Setting Up Profiles
Use standards to create a consistent format for the profiles in a drawing.
Standard format and content for profiles is often required to comply with your requirements or to make it
easier to compare several profiles. You can create these formats and content standards with styles and settings
for profiles, profile views, labels, and data bands. The following process helps you evaluate existing styles
and settings and to decide whether to change anything.
To set up profiles and profile views

Create a profile from an existing
alignment (page 1142)

----- Create a profile from an existing alignment and
display the profile on a profile view.

Add profile view labels (page 1132)----- Manually place a few profile view labels for station
elevation and depth.

Add data bands (page 1215)

Add data bands above or below the profile grid,
----- ensuring that you have one of each type that you
need.

Review profile styles (page 1122) ----- Review the standards for the graphed profile line.
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Review profile label styles (page
1129)

----- Review the standards for the automatic labels
along the profile line.

Review profile view label styles
(page 1131)

----- Review the standards for the manual labels in the
profile view.

Review profile view styles (page
1124)

----- Review the standards for the profile view title,
axes annotation, grid, and ticks.

Review profile view band styles
(page 1133)

----- Review the standards for the data bands above
or below the profile view grid.

Designing and Displaying Profiles
Follow this sequence to design and display profiles.
To design and display profiles

Ensure that your drawing contains
----- If necessary, add surfaces by importing their
all relevant surfaces (page 648)
DWG, XML, TIN, or text files.

Identify the horizontal alignment
(page 948)

----- The alignment specifies the centerline route along
which to sample elevations for the profile.

Optionally add offset profiles to the left and right
Create the surface profile and
offsets (page 1142) or Export feature ----- of the centerline profile.
If you have existing corridors, you can create
lines as profiles (page 1530)
profiles directly from the corridor feature lines.
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Create a profile view (page 1208) ----- Create a profile view to display and annotate the
profile and offsets for analysis purposes.

Design a layout profile (page 1143)----- Using the reference lines in the profile view,
design a layout profile on the profile view grid.

Create a superimposed profile
(page 1149)

If the profile view includes the profile of any linear
----- feature not parallel to the main alignment, create
a superimposed profile.

Create profile sheets for plotting
(page 61)

----- Use the Plan Production tools to create profile
sheets for plotting.

Sections Workflow
Refer to this section for high-level descriptions of tasks you might perform when working with sections in
AutoCAD Civil 3D.

Setting Up Sections
Use this information to determine a standard, consistent format for the sections in a drawing.
Standard format and content for sections is often required to comply with your requirements or to make it
easier to compare several sections. These standards are created by means of styles and settings for sample
lines, sections, section views, labels, and bands. Use the following workflow to help you evaluate existing
styles and settings and decide whether anything should be changed.
To set up standards for sample lines, sections, and section views

Create the sample lines and
sections (page 1246)

----- Create the sample line(s) and the section(s) from
an existing alignment.

Create the section view (page 1258) ----- Create a section view to display the section(s).
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Review the sample line styles (page
----- Review or modify the standards for the sample
1234)
line(s).

Review and modify the standards for the
Review the section labels (page 1241) ----- automatic labels for the sample line(s) and the
graphed section.

Review the section styles (page 1236) ----- Review and modify the standards for the section.

Review the section view styles
(page 1237)

----- Review and modify the standards for the section
view title, axes annotation, grid, and ticks.

Add section view labels (page 1243)----- Place a few section view labels for offset elevation
and grade.

Add section view bands (page 1246) ----- Add bands above or below the section grid for
the section data.

Review the section view band
styles (page 1245)

----- Review or modify the standards for the bands
above or below the section view grid.

Designing and Creating Sections
Before you create sample lines and sections, you must have existing data, including elevation (surface) data
as well as a horizontal alignment.
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To design and create sections

Ensure that the drawing contains
----- If necessary, create or add the surfaces.
the required surface (page 648)

Ensure that the drawing contains
----- Alignment properties and labels do not affect the
the necessary alignment (page 948)
sections.

Locate the sections (page 1226)

Decide where along the alignment you want the
----- sections and what ground distance they should
cover.

Create sample lines (page 1246)

----- Use appropriate sources, styles, and left and right
swath widths across of the alignment.

If required, edit the sample lines
(page 1250)

----- To re-sample from a different set of surfaces, use
the Sample Line Group Properties Dialog Box.

Create multiple section views
(page 1259)

Create views to display and annotate the sections
----- and offsets for analysis purposes. Use the
Production option and select a drawing template
if you want to create section sheets.

Create section sheets for plotting
----- Use the Plan Production tools to create section
(page 62)
sheets for plotting.

Material and Quantity Analysis Workflow
Refer to this section for high-level descriptions of tasks you might perform when performing material and
quantity analysis in AutoCAD Civil 3D
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Analyzing Sectional Volumes
Refer to this section for high-level descriptions of tasks used to set up quantity takeoff properties for sample
line groups and create quantity takeoff tables and reports in AutoCAD Civil 3D.
To create a quantity takeoff table or report

Editing quantity takeoff settings
(page 1276)

The settings include the default quantity takeoff
----- criteria used to create material lists and default
styles for tables.

Create quantity takeoff criteria
(page 1279)

Create a list of materials that specifies the surfaces
and shapes from which you want to generate
----- volume information. You will map the list entries
to actual surfaces and corridor shapes found in
the drawing later.

Create sample lines (page 1246)

Create sample lines for the alignment along which
----- you are going to generate quantity takeoff
information.

Select the sample line group and a quantity
Create a material list (page 1282) ----- takeoff criteria, and then map objects in the
drawing to the materials listed in the criteria.

Add gaps to the material
definitions (page 1284)

----- Add gaps if needed to limit volume calculations
to pockets of material.

Add subcriteria (page 1289)

----- Add subcriteria if needed to address more
complex material conditions.

Generate a quantity takeoff table
or report (page 1290)

Display the sectional volume information in a
----- standard AutoCAD Civil 3D table format, or view
and export the information in XML.
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Analyzing Material Quantities
Refer to this section for high-level descriptions of tasks used when analyzing quantites using pay item lists
in AutoCAD Civil 3D.
To analyze quantities using pay item lists

Import pay items and
categorization files (page 1294)

A pay item file contains the pay item codes,
----- descriptions, and units of measure for the master
pay item list.

You can filter the pay item list for individual pay
Filter and categorize pay item lists
----- items, either by Pay Item ID or by the text in the
(page 1295)
Description for the pay items.

You can assign pay items to objects or groups of
Tag objects with pay items (page
----- objects in your drawing. You can assign pay item
1298)
lists to corridors and pipe networks.

Use formulas with pay item lists
(page 1304)

----- Apply formulas to pay items, and edit the
formulas.

Compute quantities using pay item
----- Compute pay item quantities for drawings, view
lists (page 1306)
frames, and selection sets.

Report pay item quantities (page
1308)

----- Save quantity reports or place quantity tables in
your drawing.

Creating and Editing Mass Haul Diagrams
Refer to this section for high-level descriptions of tasks used to create mass haul diagrams in AutoCAD Civil
3D.
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To create a mass haul diagram

Specify mass haul settings (page
1319)

Specify settings, including the default styles for
----- mass haul lines and views, and for mass haul
commands.

Confirm that you have a baseline alignment, a
Confirm pre-requisite objects (page
----- sample line group, and a material list from which
1312)
you can create your mass haul diagram.

Create the mass haul diagram
(page 1315)

Specify source objects, materials, mass haul view
----- and mass haul line styles, and free haul distance,
using the Create Mass Haul Diagram wizard.

Edit mass haul styles (page 1317) ----- Edit mass haul line and view styles to improve
visibility of the mass haul diagram.

Specify mass haul line balancing
options (page 1316)

----- Add borrow pits and/or dump sites to balance
mass haul.

Pipe Networks Workflow
Refer to this section for high-level descriptions of tasks that you might perform when working with pipe
networks in AutoCAD Civil 3D.
You can use LandXML features to import existing pipe data into your drawing, or to export pipe data from
an AutoCAD Civil 3D drawing. For example, to bring pipe data into AutoCAD Civil 3D from an AutoCAD
Land Desktop project, you can export pipe data from AutoCAD Land Desktop using the Export LandXML
command, and then import it into AutoCAD Civil 3D using the Import LandXML command. For more
information, see LandXML Import and Export (page 1875).
If you need to perform hydraulic and or hydrology design and analysis tasks, you can use the hydraulics
and hydrology extensions that are provided with AutoCAD Civil 3D. They enable you to perform a variety
of hydraulics and hydrology tasks on AutoCAD Civil 3D pipe network models. For more information, see
Hydraulics and Hydrology Feature Overview (page 1331).

Preparing for Pipe Network Creation
Creating drawing templates that contain standard styles and settings helps you work more efficiently, and
ensures that your final drawings conform to your office standards.
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To prepare the drawing template for pipe network creation

Create a new drawing (page 132) ----- Open an existing drawing or create a new one.

Select the default settings (page
1343)

----- Use pipe network settings to specify the default
styles and behavior for pipe network commands.

Create the styles (page 66)

----- Styles control the display and design
characteristics of drawing objects.

Define the label settings (page 1654) ----- You can define default label settings at three
different levels.

Save the drawing as a template
(.dwt)

----- Saving the drawing as template enables you to
leverage the styles and settings.

Setting Up Data for Pipe Network Creation
Before you create a pipe network, it may be useful for you to have existing data, such as ground surfaces and
alignments, already in your drawing.
While it can be useful to have these items already set up in your drawing, you can create a pipe network
even if these components are not yet created.
To set up data for pipe network creation

Build the existing ground surfaces
----- Before you create a pipe network, it may be useful
(page 648)
for you to have existing surface data.

Create the horizontal alignments
(page 948)
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----- The pipe and structure objects in a pipe network
can be associated with a referenced alignment.

Creating, Modifying, and Analyzing Pipe Networks
This section summarizes the basic process for creating and analizing a pipe network.
To create, modify, and analyze a pipe network

Select a parts list (page 1380)

Pipe networks reference a part catalog and a parts
----- list that define the size, shape, and certain
behavior of the parts (pipes and structures) you
insert into drawings.

Create the pipe network (page 1332) ----- There are several ways you can create pipe
networks.

Interference checking lets you quickly identify
Check for interferences (page 1369)----- pipe network parts that may be in conflict with
each other.

Specify display styles for pipes and
structures in plan, profile, and
----- Styles enables you to customize the pipe network
view.
section views (page 1364)

Create pipe and structure tables
(page 1414)

----- Use Pipe tables to display information about pipes
in a drawing.

You can add labels to pipe network parts either
Add single pipe or pipe span labels
----- when you create the objects or after you create
(page 1404)
them.

Modify the pipe network as
required (page 1345)

----- Edit pipe networks using the Network Layout
Tools toolbar, pipe network vistas, or grips.
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The Hydraflow extensions enable you to perform
Perform hydraulic analysis on pipe
----- a variety of hydraulics and hydrology analysis
networks (page 1417)
tasks on pipe networks created with AutoCAD
Civil 3D or with the Hydraflow extensions.

File and Data Sharing Workflow
Refer to this section for high-level descriptions of tasks you can perform when sharing files and data in
AutoCAD Civil 3D.

Importing Architectural Data Workflow
Refer to this section for high-level descriptions of tasks you can perform when importing an architectural
data model to AutoCAD Civil 3D.

Create an architectural model
design package file (page 1891)

Apply all the required export settings, including
simplification, and publish the .adsk file to a
----- common network location.
See also Exporting Building Sites in the Autodesk
Revit Architecture 2010 User’s Guide

Import a building site model (page
----- After you create the design package file, you can
1892)
import the file into AutoCAD Civil 3D.

Create the building site style (page
----- Create the style for a new building site object.
1894)

Edit the building site style (page
1894)

----- If necessary, edit the style elements of the
building site object.

If the source architectural model has changed
Update the building site definition
----- and a new package file was posted in the shared
(page 1895)
location, modify the out-of-date building site
object.

60 | Chapter 2 Workflows

Exporting and Importing HEC-RAS Data
Use the HEC-RAS Tools in AutoCAD Civil 3D to export surface and alignment data in HEC-RAS format for
use in flood analysis.
In a drawing that contains an existing ground
surface that represents a river, define the stream
Prepare AutoCAD Civil 3D data for
----- centerline as an alignment, and create a sample
export (page 1887)
line group with stations at desired stream
locations.

Using the HEC-RAS Export Tool, enter the stream
Export the AutoCAD Civil 3D data
----- section data, and save a GEO file containing the
(page 1247)
AutoCAD Civil 3D information.

Import the GEO file into the HEC-RAS software
Analyze the flood information in
----- program, analyze the flood information, and save
the HEC-RAS software (page 1889)
an SDF file to import back into AutoCAD Civil 3D.

Import the flood analysis into
AutoCAD Civil 3D (page 1889)

In AutoCAD Civil 3D, use the HEC-RAS Import
----- Tool to import the SDF file you created in
HEC-RAS.

Plan Production Tools Workflow
Refer to this section for high-level descriptions of tasks you might perform when working with plan production
tools in AutoCAD Civil 3D.

Plan/Profile Sheet Production Workflow
Refer to this section for high-level descriptions of tasks used to create plan/profile sheets.

Prepare the template and
configure viewports (page 1902)

Before using plan production tools, make sure
----- the drawing templates have appropriately
configured viewports.

Set up plan production styles
(page 1929)
and labeling (page 1927)

Plan production styles and labels control the
----- display of all plan production components and
labeling.
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Create view frames (page 1905)

----- Use the Create View Frames wizard to quickly
create view frames along an alignment.

Create sheets (and sheet sets)
(page 1910)

----- Use the Create Sheets wizard to quickly create
sheets for construction documents (plans).

Manage the sheet sets

----- Use the Sheet Set Manager to organize drawing
layouts into named sheet sets.

Plot and publish the drawings

----- You prepare your drawing for plotting or
publishing by specifying page setup settings.

Section Sheet Production Workflow
Refer to this section for high-level descriptions of tasks used to create section sheets.

Prepare the template and
configure viewports (page 1902)

Before using plan production tools, make sure
----- the drawing templates have appropriately
configured viewports.

Use the Production option in the Create Multiple
Create section views (page 1259) ----- Section Views wizard to generate the section
views based on your drawing template.

Create layouts for section plotting
----- Use the Create Section Sheets wizard to create
(page 1934)
layouts in the current drawing.

Manage the sheet sets
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----- Use the Sheet Set Manager to organize drawing
layouts into named sheet sets.

Understanding Objects and
Styles

3

In AutoCAD Civil 3D, objects are the basic building blocks that enable you to create design drawings.
The underlying program code for AutoCAD Civil 3D uses an object-oriented architecture. As a result, design entities in
the drawing, such as points and surfaces, are intelligent objects that maintain relationships with other objects. For example,
if a horizontal alignment is modified, any profiles and sections based on that alignment are automatically changed.
The primary AutoCAD Civil 3D object types that enable you to create civil engineering design components, and the icons
that represent them, are as follows. For more information about the object, click the corresponding link.
Points (page 435)

Point Groups (page 553)

Point Clouds (page 594)

Parcels (page 873)

Surfaces (page 645)

Alignments (page 923)

Gradings (page 793)

Profile Views (page 1113)

Profiles (page 1113)

Feature Lines (page 808)

Sample Lines (page 1226)

Section Views (page 1228)

Sections (page 1225)

Mass Haul View (page 1312)

Mass Haul Line (page 1312)

Pipes (page 1325)

Pipe Networks (page 1325)

Pipe Interference Checks
(page 1369)

Structures (page 1327)

Assemblies (page 1537)

Corridors (page 1471)

Subassemblies (page 1555)

Intersections (page 1585)

Building Sites (page 1891)
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Sites (page 779)

Survey Figures (page 215)

Survey Networks (page 215)

View Frames (page 1931)

Match Lines (page 1932)

Superelevation View (page
1105)

These types of objects are sometimes referred to as graphical objects or drawing objects because when you use them, a
graphical object or shape, for example, a pipe network, surface, or corridor, is inserted into the drawing.
Use the Prospector and Settings tabs in Toolspace to access detailed object properties and settings. For more information,
see The Toolspace Window (page 96).
For information on basic object behavior, see the AutoCAD Help.

Object Relationships
AutoCAD Civil 3D objects automate the design process by interacting with other AutoCAD Civil 3D objects.
A design team typically spends many hours ensuring that revisions are transferred correctly between surfaces,
alignments, profiles, sections, and other design data. Redrafting, relabeling, and checking the work can be
time-consuming tasks. AutoCAD Civil 3D eliminates the need for most of these tasks by introducing dynamic
links between design objects. This system of links and dependencies derives from the object model within
the application design.
The following diagram illustrates how AutoCAD Civil 3D data objects are related to each other.
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Field data creates a set of points that are used to generate an existing ground surface. This surface is referenced
by other objects as indicated by the arrows.
Parcels, existing ground surfaces, pipe networks, and gradings can be created independently, or from data
sources not shown in the illustration. Such objects are usually linked to other objects during the design
process, if not at the beginning.
The object type with the most complex set of relationships is the corridor, as it requires data from a surface,
alignment, profile, and assembly (and typically multiple subassemblies).
Changes to any object flow downward along the arrows to dependent objects, with predictable results. For
example, if you correct the elevations of an existing ground surface, updates flow to any related grading
objects, pipe networks, corridors, and profiles. As a result, all values represented in labels and tables are also
updated.
In the design process, after you create an alignment you can create many profiles and sections. But the
display of these in profile views and section views is optional and apart from the flow of data required to
create the final surface. Similarly, the data from objects such as parcels and alignments can be output to a
table or report if desired.
In the object model, changes in one object can be passed on automatically to associated objects where
desired. For example, if you redesign an alignment curve, any grading using that alignment as a baseline
can be modified accordingly. In addition, all related stationing, labels, and other alignment-specific data is
updated.
The following table shows which objects can be updated when you edit each type of object:
When you edit this object
type...

These objects may be updated...

Points

Surfaces

Surfaces

Grading, Profiles, Pipe Networks, Corridors

Parcels

Grading, Corridors

Alignments

Grading, Parcels, Corridors, Profiles, Sections, Pipe
Networks, Intersections

Profiles

Intersections

Grading

Surfaces, Corridors

Subassemblies

Assemblies, Corridors

Assemblies

Corridors

Pipe Networks

Surfaces, Alignments

Feature Lines

Grading

Sample Lines

Sections, Mass Haul diagrams

Objects, Styles, and Labels
A relationship exists between drawing objects, the styles that control their display, and the labels that control
their annotation. These styles and labels are also managed as objects within AutoCAD Civil 3D.
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Object and Label Styles
Styles control the display and design characteristics of drawing objects.
You can use styles to efficiently manage object appearance. When you create a new object, you can apply
a predefined style for its display. Later, you can apply a different style. Also, you can create new styles to
suit the needs of different users and different project stages. If you change a style definition, the changes
are applied automatically to all objects using that style.
The object styles in AutoCAD Civil 3D have general attributes, such as object color, visibility of components,
linetypes, and fill patterns.
Similarly, label styles work with text format, data content, location, and graphic elements, such as leader
lines and bounding boxes.
Within your design process, object and label styles should be created with specific purposes in mind, such
as representing objects at different approval stages, or displaying the right information for different types
of users. Before you create object styles, experiment with editing styles for different objects to learn the
available controls.
Styles for each object type are managed on the Toolspace Settings tab. The General collection contains styles
that can be used by more than one object type (called Multipurpose styles) as well as shared label styles. All
AutoCAD Civil 3D objects have a Basic style that can be used as is, or as the basis for building new styles. If
you want to customize some attributes of a style, you can create a new style, or make changes to an existing
style and save it with a new name. Groups of styles can be collected and saved as a drawing template (.dwt)
file. All drawings created from a specific .dwt will share the same styles. The controls for creating styles are
standardized as much as possible across all features to make the process easier.
For objects, you can add labels by using the Annotate tab to access the Add Labels dialog box or feature-specific
label menus.
You can create sets of label styles for alignments, profiles, and sections in order to manage multiple labels
easily. After the set is defined, it can be applied to or removed from an object in a single operation.

Object styles for a surface, parcels, and an alignment, showing
stylization
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Label styles, including two alignment labels in a dragged state

Styles Best Practices

Working with Styles
Use the object shortcut menus tocreate new object styles or edit existing styles.
To create a new object style
■

On the Settings tab in Toolspace, right-click an object style collection ➤ New

To copy, edit, or delete an existing object style
■

On the Settings tab in Toolspace,expand an object style collection ➤ right-click object style ➤ Copy,
Edit, Delete.

NOTE You cannot delete a style that is referenced in the drawing.
For more information on styles, see the help topics for that object type:
Object Type

See ...

Dialog Box

Points

Point Styles (page 449)

Point Style Dialog Box (page 2354)

Point Clouds

Displaying and Stylizing Point
Clouds (page 598)

Point Cloud Style Dialog Box
(page 2381)

Surfaces

Surface Styles and Visualization
(page 748)

Surface Style Dialog Box (page
2644)

Parcels

Parcel Styles (page 894)

Parcel Styles Dialog Box (page
2253)

Profiles/Profile Views

Styles and Display of Profiles and
Profile Views (page 1122)

Profile Style Dialog Box (page
2426) and Profile View Style Dialog
Box (page 2435)
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Object Type

See ...

Dialog Box

Alignments

Alignment Styles (page 946)

Alignment Style Dialog Box
(page 1970)

Corridors

Corridor Styles and Display
(page 1473)

Corridor Style Dialog Box (page
2044)

Grading

Using Grading Styles (page 802)

Grading Style Dialog Box (page
2116)

Assemblies and Subassemblies

Subassembly Styles (page 1556)

Assembly Style Dialog Box (page
1997)

Pipe Networks

Pipe Network Styles and Display
(page 1328)

Pipe Style Dialog Box (page 2281)
and Structure Style Dialog Box
(page 2294)

Sample Lines/Sections/Section Views

Sample Line, Section, and Section View Styles and Display
(page 1233)

Section Style Dialog Box (page
2534)

Survey

Survey Styles and Display (page
216)

Survey Network Style Dialog Box
(page 2711) and Survey Figure
Style Dialog Box (page 2707)

View Frames

View Frame Styles and Display
(page 1931)

View Frame Style Dialog Box
(page 2336)

Match Lines

Match Lines Styles and Display
(page 1933)

Match Line Style Dialog Box
(page 2337)

Multipurpose Styles
Use the Multipurpose Styles collection to create specific styles that can be used by more than one object
type.
For example, Slope Pattern style can be shared by gradings and corridors and Marker Styles can be shared
by points and survey components.
For more information, see General Collection (Settings Tree) (page 112).

Label Styles
Label Styles are used to control and manage the display of labels and expressions for a class of objects.
Labels are associated with many objects, and their content is updated whenever the object itself is changed.
Labels are also controlled by styles. You can modify the label styles in the same way that you modify the
object styles: right-click a style name on the Toolspace Settings tab, and then click Edit.
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Parcel area labels appear in the drawing as they
appear in the preview of the Label Style Composer

You can create and save label sets for alignments, profiles, and sections, which allows you to apply multiple
label types in one operation. For example, an alignment label set could include labels for major stations,
minor stations, and geometry points.
Labels can include text, blocks, lines, ticks, and leaders. You can create labels and preview their appearance
in the Label Style Composer dialog box, as shown in the following illustration:

Previewing customized label style for parcel area

For more information about the Label Styles collections, see The Label Styles Collections (Settings Tree)
(page 113).
The General Label Styles are used by lines, curves, feature lines, and corridors. This collection also contains
Note label styles, which are not specific to an object.
For general information about labels, see Label Objects (page 1643).
For information about managing label styles, see Creating and Editing Label Styles (page 1656).
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Table Styles
Table Styles are used to control and manage the display for the tables associated with a class of objects.
AutoCAD Civil 3D provides automated data tables for points, surfaces, parcels, alignments, and quantity
takeoff. As shown in the following illustration, these tables provide a concise display of object data as an
alternative to using object labels. The table styles control the data properties and the displayed components
of the table.

Example data table for parcels

Data properties include the data format, order of columns, text style, and whether the table title and column
headers are repeated if the table is split. Display components include the borders, separators, fill, and text.
You can control the visibility, color, linetype, and scale of each component.
For information on the Table Styles collections, see The Table Styles Collections (Settings Tree) (page 113).
For general information about tables, see Tables (page 1737).

Changing Common Settings in Styles
The Styles dialog boxes for all object types include the Information (page 2017), Display (page 2017), and Summary
(page 2020) tabs. Other tabs are provided to record additional data specific to the object type.
To change Style settings
1 On the Settings tab in Toolspace, right-click an existing object style and click Edit.
2 Review and edit settings on the various tabs of the Style dialog box.

Quick Reference
Toolspace Shortcut Menu
Settings tab: right-click object style ➤ Edit
Dialog Box
Styles (page 2017)

Dragging Styles or Items Within or Between Drawings
Copy styles using the Settings tree drag-and-drop capability.
You can drag items from the Settings tree, including styles, description keys, and pipe rules, into the drawing
window to copy them, or you can drag them onto a drawing icon in the Settings tree.
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Dragging Items between Drawings or Templates
You can copy the following items by dragging them from one drawing or drawing template to another:
■

Styles, including label and table styles

■

Description keys

■

Pipe rules

Both the item you want to copy and the name of the destination drawing must be visible in the Settings
tree before you begin the drag-and-drop operation.
To drag an item from one drawing to another, click the item or collection you want to copy, hold down the
left mouse button, and drag the item to the name of destination drawing in the Settings tree. When the
cursor changes to
, release the mouse button to copy the item into the drawing. The item is automatically
added to the correct collection in the drawing.
If the drawing already contains an item with the name of the item being copied, the Duplicate Item Name
Dialog Box (page 2029) is displayed which allows you to decide how to handle the conflict.
If you drag a label style with one or more child styles from one drawing to another, only the selected style
is copied into the drawing; the child styles are not copied. If you copy a child style into another drawing,
the parent style is also copied.

Dragging Items within a Drawing
You can copy label styles by dragging them from one level in a label style collection to another within a
drawing, as follows:
You can drag and drop multiple styles from one drawing to another at the same time.
■

Drag a child label style (and its children) up to a higher level in the style collection to sever the parent/child
relationship.

■

Return the child label style to its original location in the tree to reinstate the parent/child relationship.

■

Drag a child label style to another label style collection. The child label style inherits the properties of
the new parent.

Both the label style you want to copy and the destination location of the style must be visible in the Settings
tree before you begin the drag-and-drop operation.
To drag a label style within a drawing, click the label style you want to copy, hold down the left mouse
button, and drag the label style to the destination collection. When the cursor changes to
mouse button to drop the style into the collection located at the tip of the cursor arrow.

, release the

When you copy a label style within a drawing, all child styles are copied with the parent style.

Transferring Styles to a New Version of AutoCAD Civil 3D
Transfer styles from a previous version of AutoCAD Civil 3D to the current version.
To transfer styles
1 On the Settings tab in Toolspace, expand the Points collection.
2 Expand Point Styles.
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3 Right-click the Standard style ➤ Edit.
4 On the Marker tab, select the option Use AutoCAD BLOCK Symbol For Marker.
5 Right-click in the white space and click Browse.
6 In the Browse To File window, change the File of Type to .dwt.
7 Browse to the template file that contains the styles you want and click Open.
8 Click OK to apply the changes.
All the styles are imported into the current drawing.

Object Properties
AutoCAD Civil 3D object properties can be modified using the civil object properties dialog boxes, the
Properties palette, and the Quick Properties palette.

Civil Object Properties
Each AutoCAD Civil 3D object has its own dialog box which contains most properties relevant to that object.
Use these dialog boxes as the primary interface for adjusting AutoCAD Civil 3D object properties.
For example, use the Alignment Properties dialog box to adjust properties for a selected alignment object in
a drawing.

Properties Palette
The Properties palette can be used as an alternate method of editing AutoCAD Civil 3D object properties.
In AutoCAD Civil 3D 2011, more civil object properties are exposed in the Properties palette than in previous
releases. Properties are now organized into four categories: Information, General, Data, and Geometry.
By exposing these properties in the Properties palette, they are now also available to be used with the QSELECT
command.
For more information, see Control the Properties of Objects in the AutoCAD Help.

Quick Properties Palette
For each civil object, the name, description, style, and layer are available for editing in the Quick Properties
palette. For more information, see Display and Change the Properties of Objects in the AutoCAD Help.
Also, you can easily customize the quick properties for any object in the Customize User Interface (CUI)
editor. For more information, see Quick Properties in the AutoCAD Customization Guide.

Matching Object Properties
The Match Properties command can be used with AutoCAD Civil 3D objects. When you use the Match
Properties command between civil objects, the style and object display properties of the selected source
object are applied to the selected destination objects. For more information, see Copy Properties Between
Objects in the AutoCAD Help.
To access comprehensive AutoCAD Civil 3D object properties
■

Select a AutoCAD Civil 3D object and click <Object Name> Properties on the Modify panel of the
contextual ribbon tab.
OR

■

Right-click an AutoCAD Civil 3D object and click <Object Name> Properties in the shortcut menu.
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To access AutoCAD Civil 3D object properties in the Properties Palette
■

Select an AutoCAD Civil 3D object and click Properties on the General Tools panel of the contextual
ribbon tab.
OR

■

Right-click an AutoCAD Civil 3D object and click Properties in the shortcut menu.

To access AutoCAD Civil 3D object properties in the Quick Properties Palette
1 Enable the Quick Properties mode by entering QPMODE at the command line and entering 1. Or click
the Quick Properties button on the Drawing Status Bar.
2 Select an AutoCAD Civil 3D object in the drawing.
3 In the Quick Properties Palette, edit the desired properties.

Layers
Each object in AutoCAD Civil 3D has a base layer on which the object physically resides, and component
layers that control the display of object components, such as surface triangles or contours.
The base layer is defined in the Drawing Settings or at creation time. The component layers are defined in
the object styles.

Object Base Layer
You specify the default base layers for objects on the Object Layers tab of the Drawing Settings dialog box.

When you create an object, you can accept the default or specify a new layer. The base layers are used only
for the main object types, such as surfaces and alignments.
Because the object physically resides on the base layer, you can control object visibility by changing the
layer state. For example, if you turn off the base layer for surfaces, all surfaces are turned off in the drawing.
TIP To append an object name to the layer name for that object, add an asterisk (*) as a prefix or suffix to the
base layer name.
For more information, see Object Layers Tab (Drawing Settings Dialog Box) (page 2076).

Object Component Layers
You specify component layers on the Display tab of the <object> Style dialog box. The following example
shows layers used for alignment components:
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The component layers, such as C-ROAD-LINE, allow you to work with objects as if parts of them are located
on different layers. For example, to turn off only the alignment lines, you can turn off the C-ROAD-LINE
layer in the drawing.
Objects are physically created on the base layer, but the display of components is governed by the associated
component layers. Each object component uses the visibility settings for the component layer (such as
on/off), as well as the color, linetype, lineweight, and plot style for the layer if the various Component
Display settings are set to ByLayer.
NOTE Layer 0 has a special meaning in the Component Display settings. When the layer is set to 0, the object
base layer is used for that component. For example, if the alignment base layer is C-ROAD, and the layer for the
Line component is set to 0, then the alignment lines behave as if they are located on layer C-ROAD (not layer 0).
For more information, see Display Tab (Style Dialog Box) (page 2017).

Setting Up Styles Using the ByLayer Setting or Specific Settings
If you are accustomed to controlling objects by manipulating layers, you may want to set the various object
style Component Display settings to ByLayer. Then you can simply change the layer settings using the
AutoCAD Layer command rather than editing separate styles to change the color, linetype, lineweight, or
plot style of an object component.
TIP Using the ByLayer settings provides more control over object display to people viewing AutoCAD Civil 3D
drawings in object-enabled AutoCAD.
However, if you want the object to always have the same settings regardless of component layer settings,
you can set specific Component Display settings.
For more information, see Using ByLayer and ByBlock to Assign Display Values (page 2019).

Naming Objects
AutoCAD Civil 3D objects use a name template to specify the object name.
A name template is a default name format that can be incremented for each new object of that type.
For example, when you create an alignment, you will see Alignment - (<[Next Counter(CP)]>) in the Create
Alignment dialog box. This is a name template. This default template will use the word “Alignment” and
then follow it with the next available number (the next counter), each time you create a new alignment.
For example, “Alignment - 1”, “Alignment - 2”, and so on.
Next to the object name field, you can click
to display the Name Template dialog box (page 2022), where
you can set up the default format you want to use.
Or, you can specify a name manually by clearing the name template format from the object name field, and
then typing a new name.
Object names are displayed in Toolspace. You can edit the object names by changing the object properties.
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See also:
■

Naming Constraints for Objects and Styles (page 75)

Naming Constraints for Objects and Styles
Object and style names restrict the use of certain characters.
When naming an object or style, do not use the following characters:
■

< (less than)

■

> (greater than)

■

/ (forward slash)

■

\ (backward slash)

■

+ (plus sign)

■

“ (double quotes)

■

: (colon)

■

; (semi colon)

■

= (equals)

■

| (vertical line)

■

, (comma)

■

* (asterisk)

■

? (question mark)

■

‘ (single quote)

See also:
■

Naming Objects (page 74)

Naming Constraints for Objects and Styles | 75

76

Understanding Settings

4

AutoCAD Civil 3D has drawing, object, and command settings. All three levels of settings in AutoCAD Civil 3D are saved
with the drawing, and they can be saved to a drawing template.
Settings in AutoCAD Civil 3D provide many preset values, ranging from values, such as drawing units, scale, and coordinate
system, to optional defaults, such as the layers that the different objects are created on, and the use of tooltips.You can
access the setting dialog box by right-clicking the appropriate collection on the Toolspace Settings tab, and then clicking
Edit Feature Settings.
You can work with three levels of settings:
■

Drawing settings establish values for the whole drawing. If you are creating a drawing template, ensure that these are
set correctly.

■

Feature settings control behavior for a particular feature, such as Parcels or Grading.

■

Command settings apply to individual commands within a feature, such as the CreateParcelByLayout command within
the Parcels feature.

Each lower level object in the settings hierarchy can either inherit or override settings in the level above it. The following
illustration shows an override set for area units at the Parcels feature level.

Feature settings can override drawing settings
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The arrow in the Child Override column of the Drawing Settings dialog box (upper drawing) indicates that an override
has been set at a lower level. The check mark in the Override column in the Parcel Settings dialog box (lower drawing)
indicates that the value set in this dialog box overrides the setting at a higher level.
At the drawing level you can cancel an override by clicking it. You can prevent overrides by locking a setting.

Working with the Standard Settings Dialog Box Controls
Use a standard dialog box, accessed at three different levels, to edit settings.
You modify each level of settings at a different location in the Settings tree, as shown in the following
illustration:

Drawing-Level Settings
There are two types of drawing-level settings:
■

Drawing-wide settings, which include units and zone, transformation settings, abbreviations, and object
layers.

■

Ambient settings, which affect a variety of AutoCAD Civil 3D behaviors. You can change ambient settings
at the drawing level, and you can also override ambient setting values at either the object level or the
command level.

You access drawing-level settings by right-clicking the drawing name in the Settings tree and clicking Edit
Drawing Settings.
At the drawing level, the Edit Settings dialog box contains only the ambient settings for the drawing:
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Object(Feature)-Level Settings
Use the object collection level in the Settings tree to control all settings that pertain to the object type.
Change the object settings at this level in the tree, and specify overrides for the drawing ambient settings.
Access the object- or feature-level settings by right-clicking the object collection in the Settings tree and
clicking Edit Feature Settings.
At the object level, this dialog box also contains object-specific settings, such as default styles, which are
listed below the General settings:

Command-Level Settings
Use the Commands collection level in the Settings tree to override both the object-level settings and drawing
ambient settings on a command-by-command basis. You can also specify command-specific settings.
Access the command-level settings by expanding the Commands collection for an object type in the Settings
tree, right-clicking the command, and clicking Edit Command Settings.
At the command level, this dialog box also contains command-specific settings, such as the Parcels and
Alignments settings that are used by the CreateSite command.

The following summarizes the controls in the Edit Settings dialog box:
■

Use the + or – boxes to display or hide the settings in the category.

■

Use the Value column to specify a value for a setting.

■

The Override column indicates that the default value has been changed for the setting.

■

The Child Override column indicates whether the setting has been overridden at a lower level in the
Settings tree.

■

Use the Lock column to control whether a setting can be changed at a lower level in the Settings tree.

For more information, see Edit Settings Dialog Box (page 2025).

Specifying Drawing Settings
Drawing Settings are the most generic settings. All commands use the drawing settings unless there is a
specific override at the feature or command level.
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Specifying Units and Zone Settings
Using the Units and Zone tab of the Drawing Settings dialog box, you can select linear and angular units, a
coordinate system, and scale for the drawing.

Coordinate Systems
Coordinates in AutoCAD Civil 3D are expressed using northings and eastings.
The AutoCAD Civil 3D coordinate system is always relative to the AutoCAD World Coordinate System
(WCS). Northing is equivalent to AutoCAD Y and Easting is equivalent to AutoCAD X.
AutoCAD Civil 3D object data is always presented in AutoCAD World Coordinate System coordinates. For
example, the alignment data in the Alignment Entities vista in the Panorama window is listed in world
coordinates. In addition, the AutoCAD Civil 3D transparent commands are based on the AutoCAD World
Coordinate System. However, when you create an object and have an AutoCAD User Coordinate System
(UCS) defined, the UCS is honored when you specify locations, which means that an insertion point or a
coordinate is interpreted relative to the UCS.
AutoCAD Civil 3D objects are not aligned with the UCS. For example, labels can be oriented relative either
to the current view, the World Coordinate System, or the labeled object, depending on the Orientation
Reference setting, but they cannot be oriented to the UCS.
Similarly, objects, such as profiles, sections, and tables, cannot be oriented to the current UCS.
For more information about AutoCAD World Coordinate Systems and AutoCAD User Coordinate Systems,
see the AutoCAD Help.
To specify Units and Zone settings
1 In Toolspace, on the Settings tab, right-click the drawing name
click Edit Drawing Settings.

at the top of the collection, and

2 In the Drawing Settings dialog box, click the Units and Zone tab (page 2073).
3 Under Drawing Units, select either Feet or Meters.
4 Under Angular Units, select an angle format.
5 Specify one of the following for the Imperial to Metric Conversion.
■

International Foot (1 foot = 0.3048 Meters)

■

US Survey Foot (39.37 Inches per Meter)

6 Select the Scale Objects Inserted From Other Drawings check box to scale objects inserted from another
drawing to match drawing units in the current drawing.
7 Select the Set AutoCAD Variables To Match check box to synchronize AutoCAD settings with AutoCAD
Civil 3D settings. If there are no equivalent AutoCAD settings, a message is displayed asking if you want
to match as closely as possible. The AutoCAD settings that are synchronized to theAutoCAD Civil 3D
settings include the AUNITS, DIMAUNIT, INSUNITS, and MEASUREMENT AutoCAD system variables
(sysvars).
8 Under Scale, select the intended plot scale in imperial or metric units.
9 Under Custom Scale select the plotted size of various annotation-related components, such as label
text, ticks, and band heights. If you change the scale, all annotation objects adjust accordingly.
10 Under Zone, select a category from the Categories list.
Categories include Lat/Longs, US states, and so on. When you select a category, the Available Coordinate
Systems list displays all the defined zones in that category.
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TIP If you know the coordinate system (CS) code for a zone, you can enter it in the CS Code text box and
click OK to select the zone.
11 Click OK.

Quick Reference
Toolspace Shortcut Menu
Settings tab: right-click the drawing name

➤ Edit Drawing Settings

Command Line
EditDrawingSettings
Dialog Box
Drawing Settings (page 2073)

Specifying Transformation Settings
Using the Transformation tab of the Drawing Settings dialog box, you can relate the local northing and local
easting coordinates of your drawing to the grid northing and grid easting coordinates for the current zone.
The zone transformation settings do the following:
■

Relate local coordinates to grid coordinates by transforming distances measured on the Earth (or geoid)
to distances on an ellipsoid.

■

Relate distances on the ellipsoid to the flat plane (projection) of the current zone’s grid coordinate system.

These transformations are accomplished through the use of scaling factors. First, a sea level scale factor is
applied to the local values measured on the geoid, and then a grid scale factor is applied, which relates the
ellipsoid values to the grid projection. The scaling factors can be defined in two ways:
■

The sea level scale factor relates the distances on the geoid to the distances on the ellipsoid.

■

The grid scale factor relates the distances on the ellipsoid to the distances on the grid projection.

You must also specify reference points in establishing transformation settings.
These reference points are the two points that tie the local and grid coordinates together. The reference
points can be defined in two ways:
■

By the grid and local coordinates of two known reference points in your drawing.

■

By the grid and local coordinates of one known point and a known rotation to grid north.

To specify transformation settings for a drawing
1 In Toolspace, on the Settings tab, right-click the drawing name
click Edit Drawing Settings.

at the top of the collection, and

2 In the Drawing Settings dialog box, click the Transformation tab (page 2074).
IMPORTANT You must specify the coordinate system on the Units and Zone tab (page 80) before you can
specify settings on the Transformation tab.

Specifying Transformation Settings | 81

3 Select the Apply Transform Settings check box to activate all the controls in the dialog box. Enter values
as specified in steps 4-10. If you clear this check box, then controls in the dialog box are disabled and
the AutoCAD X and Y coordinates match the coordinates in the specified zone.
4 Select Apply Sea Level Scale Factor.
TIP If you know the combined scale factor, then you can clear the Apply Sea Level Scale Factor check box,
select User Defined as the Grid Scale Factor, and enter a combined scale factor in the Grid Scale Factor box.
The combined scale factor is the combination of the scale factor for converting local to sea level and the scale
factor for converting sea level to grid.
5 Enter a default Elevation, such as the average elevation of your project site from sea level.
6 Optionally, change the Spheroid Radius, which is the radius of a mathematical figure close to the shape
of the Earth at sea level, approximately 6,370 km. The value shown in this box is initially derived from
the current zone's ellipsoid and can be changed if local observations differ. In most cases, the default
value shown is the accepted value.
7 For the Grid Scale Factor, select a method for Computation. For more information, see Transformation
tab (page 2074).
8 Specify the Reference Point values. The reference point could be a benchmark that was used in a survey.
It can be any point for which you know both the local coordinates and the grid coordinates. To specify
the Reference Point values, do one of the following:
■

Click the Select Point button and then select a point in the drawing, or use Transparent commands.

■

Enter a point number.

■

Enter the point's Grid Northing and Grid Easting values.

9 To define the rotation angle for the transformation, do one of the following:
■

Click the Select Point button and then select a point in the drawing.

■

Enter a point number.

■

Enter the point's Grid Northing and Grid Easting values.

10 Specify the grid rotation angle.
11 Click OK.

Quick Reference
Toolspace Shortcut Menu
Settings tab: right-click the drawing name

➤ Edit Drawing Settings

Command Line
EditDrawingSettings
Dialog Box
Drawing Settings (page 2073)

Specifying Object Layer Settings
Use the Object Layers tab of the Drawing Settings dialog box to preset default object layers.
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For more information about object layers, see Layers (page 73).
To specify object layer settings for a drawing
1 In Toolspace, on the Settings tab, right-click the drawing name
click Edit Drawing Settings.

at the top of the collection, and

2 In the Drawing Settings dialog box, click the Object Layers tab (page 2076).
3 For each object type, click in the Layer column to display the Layer Selection dialog box.
4 In the Select Layer (page 2222) dialog box, select the layer for that object type and click OK.
5 To add a modifier to the layer name, select Prefix or Suffix in the Modifier column and then enter the
text string for the modifier in the Value column.
TIP To include the object name in the layer prefix or suffix, enter an asterisk in the Value column.
6 Click OK.

Quick Reference
Toolspace Shortcut Menu
Settings tab: right-click the drawing name

➤ Edit Drawing Settings

Command Line
EditDrawingSettings
Dialog Box
Drawing Settings (page 2073)

Specifying Abbreviation Settings
Use the Abbreviations tab of the Drawing Settings dialog box to change the abbreviations used for the labels.
The Abbreviations tab controls various default abbreviations used in drawing labels and reports. For example,
the default abbreviation for Spiral-Tangent Intersect is TS, meaning any spiral-tangent intersections in a
drawing are labeled TS. If you need spiral-tangent intersection labels to be more detailed or different, you
can change the abbreviation by clicking in the value column and changing the TS value.
In the Alignment Geometry Point Entity Data section the values also contain format strings that describe
entity properties that will display in the label. For more information see, Property Field Modifiers (page 1692).
To specify abbreviation settings for a drawing
1 In Toolspace, on the Settings tab, right-click the drawing name
click Edit Drawing Settings.

at the top of the collection, and

2 In the Drawing Settings dialog box, click the Abbreviations tab (page 2077).
3 Specify the abbreviations for the properties by modifying the entries in the Value column.
NOTE For individual abbreviation definitions, see the Glossary (page 2767).
4 Click OK.
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Quick Reference
Toolspace Shortcut Menu
Settings tab: right-click the drawing name

➤ Edit Drawing Settings

Command Line
EditDrawingSettings
Dialog Box
Drawing Settings (page 2073)

Specifying Ambient Settings
Using the Ambient Settings tab of the Drawing Settings dialog box, you can specify default ambient
(background) settings for a variety of features, including some that affect units of measurement.
These settings control parameters such as angle, area, direction, elevation, and so on. There are also settings
that affect the Event Viewer, tooltips, and how curb returns are created for intersections.
To specify ambient settings for a drawing
1 In Toolspace, on the Settings tab, right-click the drawing name
click Edit Drawing Settings.

at the top of the collection, and

2 In the Drawing Settings dialog box, click the Ambient Settings tab (page 2078).
3 In the Property column, select a parameter in one of the categories.
As you select a parameter, the description in the lower part of the dialog box reflects the selection.
4 Change the settings in the Value column.
5 Click OK.

Quick Reference
Toolspace Shortcut Menu
Settings tab: right-click the drawing name

➤ Edit Drawing Settings

Command Line
EditDrawingSettings
Dialog Box
Drawing Settings (page 2073)

Specifying Feature-Level Settings
Specify object-specific settings and override drawing ambient settings at the object (feature) collection level
of the Settings tree.
To specify feature-level settings
1 In Toolspace, on the Settings tab, right-click the object collection and click Edit Feature Settings.
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2 To change an object-specific setting, do the following in the Edit Settings (page 2025) dialog box:
■

Expand the category that contains the setting.

■

Click the cell in the Value column. Enter the value or select a value from the list.

3 To override a drawing ambient setting, do the following:
■

Expand the category that contains the setting.

■

Click the cell in the Value column. Enter the value or select a value from the list.

After you change the value, the check box in the Override column is automatically selected, indicating
that the drawing ambient setting is overridden.
4 Click OK.

Quick Reference
Toolspace Shortcut Menu
Settings tab: right-click object collection ➤ Edit Feature Settings
Dialog Box
Edit Feature Settings (page 2025)

Specifying Command-Level Settings
Override the object-level settings or the drawing ambient settings for a specific command at the command
level of the Settings tree.
To specify command level settings
1 In Toolspace, on the Settings tab, expand the Commands collection that contains the command whose
settings you want to edit.
2 Right-click the command name and click Edit Command Settings.
3 To change a command-specific setting, do the following in the Edit Settings (page 2025) dialog box:
■

Expand the category that contains the setting.

■

Click the cell in the Value column. Enter the value or select a value from the list.

4 To override object-specific settings, including drawing ambient settings, do the following:
■

Expand the category that contains the setting.

■

Click the cell in the Value column. Enter the value or select a value from the list.
After you change the value, the check box in the Override column is automatically selected, indicating
that an object-level setting is overridden.

5 Click OK.

Quick Reference
Toolspace Shortcut Menu
Settings tab: right-click command name in object Commands collection ➤ Edit Command Settings
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Dialog Box
Edit Command Settings (page 2025)
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The User Interface

5

The AutoCAD Civil 3D user interface enhances the standard AutoCAD environment with additional tools for creating
and managing civil design information.
Standard AutoCAD features, such as the command line and the design space work the same way in AutoCAD Civil 3D as
they do in AutoCAD.

Ribbon
AutoCAD Civil 3D commands and features are available from the ribbon.

AutoCAD Civil 3D Ribbon Overview
The AutoCAD Civil 3D ribbon is the primary user interface for accessing commands and features.
Commands available from the ribbon are organized into tabs. Each tab is organized into a series of panels,
which are labeled by task.
The ribbon is typically turned on (displayed) by default, and can be displayed or removed using the Ribbon
and RibbonClose commands.
There are two basic types of ribbon tabs: static and contextual.

Static Ribbon Tabs
The AutoCAD Civil 3D static ribbon tabs include the Home, Insert, Annotate, Modify, Analyze, View, Output,
and Manage tabs. Static ribbon tabs are always displayed when the ribbon is turned on, and they contain
most of the functionality located on the menu bar drop-down menus and toolbars. Static ribbon tabs have
a gray background color.

Contextual Ribbon Tabs
Contextual ribbon tabs are displayed automatically when you select an object or invoke an object-specific
command. For example, when you select a pipe network object, the Pipe Network contextual tab is displayed.
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Contextual tabs contain commands that are related to the currently selected object. Most contextual tabs
can be closed simply be deselecting the object.
AutoCAD Civil 3D contains the following contextual tabs:
■

Alignment

■

Assembly

■

Cogo Point

■

Corridor

■

Feature Line

■

Grading

■

Intersection

■

Label

■

Mass Haul Line

■

Mass Haul View

■

Profile

■

Profile View

■

Parcel

■

Plan Production

■

Pipe Network

■

Point Cloud

■

Projected Object

■

Sample Line

■

Section

■

Section Sheet

■

Section View

■

Subassembly

■

Surface

■

Survey

■

Table

Multiple Object Select Ribbon Tabs
When multiple types of objects are selected simultaneously, the Multiple contextual tab is displayed in the
ribbon. For example, if you select both a pipe network object and an alignment object, the Multiple contextual
tab is displayed.
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Section Editor Ribbon Tab
The Section Editor tab includes some ribbon behavior that is slightly different than the other types of
contextual ribbon tabs just described. The Section Editor tab lets you perform a variety of corridor section
view editing functions. You can display the Section Editor tab by clicking Corridor Section Editor on the
Modify panel of the Corridor contextual tab, or by selecting View/Edit Corridor Section from the corridor
object shortcut menu. This tab remains active until you click the Close button to remove it.
NOTE To learn more about basic ribbon functionality, see The Ribbon in the AutoCAD User’s Guide Help.

Contextual Tab Colors
The background color of a contextual tab depends on the type of task being performed.

Object Select Contextual Tabs (Green)
Contextual tabs that are displayed when you select an object have a green background color. For example,
if you select an assembly object, the Assembly contextual tab is displayed. That tab is displayed with a green
background color.
The following illustration shows the assembly object select contextual tab.

Non-object Select Contextual Tabs (Purple)
Contextual tabs that are displayed when no objects are selected have a purple background color. For example,
if you click the Assembly button
on the Modify tab, the Assembly non-object select contextual tab
displays, and that tab has a purple background color. This provides access to all commands related to
assemblies without having to select an assembly in the drawing.
The following illustration shows an example of a contextual tab that is displayed when no objects are selected.

Non-object selection contextual tabs have a Close button at the end to dismiss them. If you select an object
while this tab is displayed, the non-object selection tab is automatically closed and replaced with the object
select contextual tab.

Section Editor Tab (Blue)
Because its ribbon behavior is slightly different than the previous two types just described, the Section Editor
tab has its own unique background color — light blue (teal).
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Launch Pad Panel
AutoCAD Civil 3D contextual ribbons include a Launch Pad panel that provides access to commands that
you might use next in your workflow.
For example, when you select an alignment object, the Alignment contextual tab is displayed. The Launch
Pad panel on the Alignment contextual tab provides a variety of commands that you may want to do next.
For example, you may want to create a corridor, intersection or data shortcut from the alignment.
Similarly, the Launch Pad on the Corridors contextual tab provides access to the variety of commands that
you may want to select while you have a corridor object selected. For example, you can access the Create
Sample Line command and the Create Feature Lines From Corridors command, among others, from this
Launch Pad.

Using the Where is My Command? Tool
Use the Where is My Command? tool to quickly locate AutoCAD Civil 3D 2009 menu commands on the
AutoCAD Civil 3D 2010 ribbon.
This tool lets you look up familiar AutoCAD Civil 3D 2009 menu commands and quickly determine where
these commands now exist on the AutoCAD Civil 3D 2011 ribbon. Access this tool from the Help drop-down
menu

.

The Where is My Command tool? contains only AutoCAD Civil 3D 2009 menu commands. It does not
identify ribbon locations for new AutoCAD Civil 3D 2011 commands and features that did not exist in
AutoCAD Civil 3D 2009.

Printing
It can be useful to print out some or all pages of the Where is My Command Tool? to quickly and easily
reference this information any time.
To print out all of the Where is My Command? Help topics, right-click the AutoCAD Civil 3D 2009 Menus
in the left pan Contents tab, and select Print. On the Print Topics dialog box, select Print the selected heading
and all subtopics.
To print out a single topic, right-click an item in the left pan, and select Print. On the Print Topics dialog
box, select Print the selected topic, or place your cursor in the right pane, and select Print from the right-click
shortcut menu.
To use the Where is My Command? tool
1 In the InfoCenter toolbar located at the top right side of the application window, click the drop-down
arrow next to the Help icon

.

2 Click Where is My Command?
3 In the left pane, on the Contents tab, expand AutoCAD Civil 3D 2009 Menus.
4 In the left pane, click a menu item. For example, click Pipes to display the choices that exist on the
AutoCAD Civil 3D 2009 Pipes menu.
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5 In the right pane, look up a menu command in the Menu column, and then use the Ribbon Location
column to find out where this command now exists on the ribbon.
Some AutoCAD Civil 3D 2009 menu commands do not exist on the ribbon, but instead are available from
the command line or other access method. For those commands, the Ribbon Location column lists the
appropriate access method.

Learning to Use the Ribbon
AutoCAD Civil 3D includes several resources for learning how to use the ribbon.
Refer to the following table for links to Help topics describing ribbon functionality.
For information
about ...

See....

basic ribbon functionality

The Ribbon in the AutoCAD User’s Guide Help (User’s Guide ➤

customizing the ribbon

Customize The Ribbon in the AutoCAD User’s Guide Help (User’s

The User Interface ➤ Tools in the Application Window ➤ The
Ribbon)

Guide ➤ The User Interface ➤ Tools in the Application Window ➤ The Ribbon ➤ Customize The Ribbon)

learning how to use
the ribbon

■

User Interface Overview in the AutoCAD Civil 3D User’s Guide
Help (Getting Started ➤ The User Interface ➤ User Interface Overview)

■

Tutorial: Understanding the AutoCAD Civil 3D User Interface
in AutoCAD Civil 3D Tutorials (Getting Started Tutorials ➤
Tools in the Application Window ➤ Understanding the
AutoCAD Civil 3D User Interface)

finding command
locations on the ribbon

Using the Where is My Command? Tool (page 90) (User’s Guide
Help ➤ Getting Started ➤ The User Interface ➤ Ribbon ➤
Using the Where Is My Command? Tool)

Quick Access Toolbar
The Quick Access toolbar displays frequently used tools.
You can add ribbon buttons to the Quick Access toolbar, by right-clicking the button on the ribbon and
then clicking Add to Quick Access toolbar. Buttons are added to the right of the default commands on the
Quick Access toolbar.
For more information on the Quick Access toolbar, see Quick Access Toolbar in the AutoCAD User’s Guide
Help.

Menus
While the ribbon is the primary access point for AutoCAD Civil 3D commands, many commands are also
available from the application menu and from shortcut menus that are displayed when you right-click an
object in Toolspace or in the drawing window.
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Application Menu
The application menu provides access to file-related commands. For example, it provides commands that
let you create, open, print, export, and publish a file.
Access the application menu by clicking the application menu icon at the top left of the application window
.
The application menu also provides a search tool which you can use to search for commands. Only those
commands that are available in the current workspace are shown and searched. For more information, see
The Application Menu in the AutoCAD User’s Guide Help.

Shortcut Menus
Shortcut menus are available throughout AutoCAD Civil 3D. To display a shortcut menu, right-click your
pointing device on items in the Toolspace, Panorama, or other window, or on objects in the drawing area.

Legacy Menu Bar
The menu bar is no longer displayed across the top of the AutoCAD Civil 3D 2011 program window by
default. You can display the menu bar by clicking the drop-down arrow on the Quick Access toolbar and
selecting Show Menu Bar, or by entering menubar at the command line. The Quick Access toolbar is located
at the top-left side of the application window by default.
NOTE The legacy menu bar contains only AutoCAD Civil 3D 2009 commands and has not been updated with
new AutoCAD Civil 3D 2011 commands and features. Therefore, if you display the menu bar, it is important to
understand that it does not provide access to all AutoCAD Civil 3D 2011 features.

Workspaces
AutoCAD Civil 3D 2011 comes with a default workspace for working with AutoCAD Civil 3D commands.
You can use this workspace as-is or modify it according to your requirements.
Workspaces are sets of user interface components, such as ribbon tabs and panels, toolbars, palettes, and
menu bars, that are grouped and organized so that you can work in a custom, task-oriented drawing
environment. When you select a workspace, only the user interface components specified in that workspace
are displayed. You can still access other commands by entering their command names at the command line.
You can switch to another workspace by using the Workspace Switching button
the application status bar.

, which is located in

Workspaces in AutoCAD Civil 3D 2011 include:
■

Civil 3D: This workspace displays user interface components related to civil engineering design and survey
features available in AutoCAD Civil 3D.

■

2D Drafting & Annotation: This workspace displays user interface components related to AutoCAD 2D
drafting and annotation features available in AutoCAD Civil 3D.

■

3D Modeling: This workspace displays user interface components related to AutoCAD 3D modeling
features available in AutoCAD Civil 3D.

■

Tool-based Geospatial: This workspace displays user interface components related to AutoCAD Map 3D
features available in AutoCAD Civil 3D. It is designed for those who are already familiar with the AutoCAD
ribbon.

■

Task-based Geospatial: This workspace displays user interface components related to AutoCAD Map 3D
features available in AutoCAD Civil 3D.
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For more information about using and customizing workspaces, see the AutoCAD User’s Guide and the AutoCAD
Customization Guide in the AutoCAD Help.
To set the workspace to the AutoCAD Civil 3D default
1 At the command line, enter Workspace.
2 At the Workspace Option prompt, enter C.
3 When prompted to enter the name of the workspace, enter:
Civil 3D.
To save the current menu and toolbar configuration to a new workspace
1 Configure your workspace. For example, you can close the Tool Palette if you do not want it to come
up every time you start AutoCAD Civil 3D.
NOTE You can also use the CUI command to edit the Workspace using a dialog box interface. For more
information, see Customer User Interface Dialog Box in the AutoCAD Command Reference.
2 At the Command prompt, enter WSSAVE.
3 In the Save Workspace dialog box, enter a name for the new workspace. You can also select the name
of an existing workspace to overwrite it with your modified configuration.
4 Click Save.

Quick Reference
Command Line
Workspace

Accessing AutoCAD Civil 3D Toolbars
AutoCAD Civil 3D provides toolbars you can use to quickly access the transparent commands.
The two transparent command toolbars are turned on (displayed) by default when using the Civil 3D
workspace.
Other toolbars that were in previous versions of AutoCAD Civil 3D are no longer available. The commands
on those toolbars are now available from the ribbon.
See also:
■

Transparent Commands (page 1767)

■

Quick Access Toolbar in the AutoCAD User’s Guide Help

To display the AutoCAD Civil 3D transparent command toolbars
1 Enter -toolbar at the command line.
2 Enter “transparent_commands”or “transparent_command_filters” and then press Enter.
3 Enter Show.
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Quick Reference
Command Line
-toolbar

Working with AutoCAD Civil 3D Windows
The Toolspace and the Panorama windows—the two main floating windows in AutoCAD Civil 3D — share
several features.

Tabs
The Toolspace window always displays at least two tabs, Prospector and Settings. The Panorama window
displays named tabs if you have more than one tool (vista) active in the window.

Shortcut Menus
Right-click in the Toolspace or the Panorama window to display a shortcut menu of available commands.
Right-click a single item, or select one or more items and right-click, to display a menu containing commands
related to the item(s). If you right-click an area that contains no items or data, the menu contains commands
related to the window.
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Auto-hide
This AutoCAD palette feature keeps the window active while maximizing the amount of available screen
space. If Auto-hide is active for a window, the body of the window disappears when you move the cursor
out of the window, leaving only the title bar visible. Move the cursor over the title bar to display the entire
window again.
The following illustration shows the Toolspace window both closed and open, with Auto-hide active:
Closed

Open

To activate Auto-hide for the Toolspace or the Panorama window, click

on the title bar. To deactivate

Auto-hide, click
on the title bar. You can also right-click the title bar and use the shortcut menu to
control Auto-hide. For more information about Auto-hide, see the AutoCAD Help.
NOTE Auto-hide is not available when a window is docked.

Moving and Docking
The Toolspace and the Panorama windows, like all AutoCAD palettes, can be moved and resized, and either
floated in the window or docked. A docked window shares one or more edges with adjacent windows and
toolbars. If a shared edge is moved, the windows change shape to compensate. To undock and relocate a
window, click and drag the control bars at the top or side of the window. To prevent a window from docking
while you drag it, hold down Ctrl.
TIP You can quickly undock a window by double-clicking the window’s control bars.
For more information about working with docked and floating windows, see the AutoCAD Help.
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The Toolspace Window
The Toolspace window is an integral component in the user interface for accessing commands, styles, and
data. Use it to access the Prospector, Settings, Survey, and Toolbox tabs. Right click each collection or item
on these tabs to access commands.

Use the Prospector tab to manage design objects, data shortcuts, and Vault projects. For more information,
see The Toolspace Prospector Tab (page 103).
Use the Settings tab to manage object settings, styles, and other drawing items, such as point file formats,
description key sets, and grading criteria sets. For more information, see The Toolspace Settings Tab (page
107).
Use the Survey tab to manage survey projects, data, and settings. For more information, see The Toolspace
Survey Tab (page 115).
Use the Toolbox tab to access reports and subscription extensions, and to add custom tools. For more
information, see The Toolspace Toolbox Tab (page 117).

Opening or Closing the Toolspace Window
You can control whether or not the Toolspace window is visible in the AutoCAD Civil 3D session.
If...

Then do this...

You cannot see the Toolspace
window.

Click Home or View tab ➤ Palettes panel
➤ Toolspace

.

NOTE At least one Toolspace tab must be in the
“open” state or the Toolspace button on the ribbon
is grayed out. In this case, click one of the tab display
buttons such as Prospector
The tab you want to use is not
open in the Toolspace window.
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to open the tab.

Use the buttons on the Palettes panel (on the Home
or View ribbon tab) to open the Toolspace tabs. The
buttons are used to both open and close the tabs.
When the Toolspace tabs are in the “open” state, the
ribbon buttons have a blue background.

If...

Then do this...

When the Toolspace tabs are in the “closed” state,
the ribbon buttons have a white background.

Only the Toolspace title bar is
displayed.

Move the cursor over the title bar to display the full
Toolspace window.
To disable Auto-hide, right-click the Toolspace title
bar and click Auto-hide to remove the check mark
next to it.

The contents of a tab are out of
date.

Right-click in the window and click Refresh.

You want to close the
Toolspace window.

Click

in the Toolspace window or click the

Toolspace

button on the ribbon.

To open or close the Toolspace window
1 Click Home or View tab ➤ Palettes panel ➤ Toolspace

.

NOTE At least one Toolspace tab must be in the “open” state or the Toolspace button is grayed out. In this
case, click one of the tab display buttons on the ribbon to open the tab.
2 If the tabs you want to use are not open in the Toolspace window, use the following ribbon buttons to
open them:
■

Prospector (page 104)

■

Settings (page 108)

■

Survey (page 116)

■

Toolbox (page 118)

BEST PRACTICE Closing the Toolspace window can help improve overall performance as well as save memory,
so it is recommended to close the Toolspace window when it is not necessary to have it open. Likewise, it is
recommended to close the Toolspace tabs (Prospector, Settings, Survey, or Toolbox) which you do not need
to have open.

Quick Reference
Ribbon
Home or View tab ➤ Palettes panel ➤ Toolspace
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Command Line
Toolspace

Functions Shared by the Prospector, Settings, and Survey Tabs
The Prospector tab, Settings tab, and Survey tab have several controls in common, including a tree structure,
shortcut menus, and object icons.

Tree Structure
The Toolspace trees display items in a hierarchical structure. Any item that can contain other items below
it in the tree is a collection. For example, in the illustration, Open Drawings, Points-2, and Sites are all
collections. The symbol displayed at the tree node, to the far left of each collection name gives you information
about the display of the items in the collection:
Symbol

Meaning and Possible Action
The collection contains items that are not displayed. Click
the tree and display the items.

to expand

The items contained in the collection are displayed. Click
the tree and hide the items.

to collapse

The collection contains items that cannot be displayed in the tree. Click
the collection name to list the items in a Toolspace item view. For more
information, see The Toolspace Item View (page 99).
The collection’s data needs to be refreshed. Right-click the collection
and click Refresh.
The item is a reference to an item located elsewhere in the tree. Doubleclick the reference to navigate to the actual item. For example, this icon
appears next to a drawing in the Projects node when that project
drawing is open. You can then double-click the icon to move to that
drawing in the Open Drawings node in the Prospector tree.
The collection contains no items.
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Shortcut Menus
Display a shortcut menu for any collection or item in the tree by right-clicking the item. The menu contains
commands that apply to the item you selected in the tree.

Icons
A row of icons appears at the top of each Toolspace tab. For more information about these, see The Prospector
Tab Icons (page 104), The Settings Tab Icons (page 108) and the The Survey Tab Icons (page 116).

Tree View
Use the drop-down list above the tree to control which items are displayed in the tree. For more information,
see Controlling the Items Displayed in the Settings Tree (page 108) and Controlling the Items Displayed in
the Prospector Tree (page 105).

Item Views
When you select items in the tree, additional information may be displayed in an item view, which is shown
in a pane next to or beneath the main tree. You can adjust the size of the item view by moving the bar that
separates the item view from the tree.
An item view is one of the following, depending on the item selected:
■

List view. Displays information in a list or table. In some cases, this information can be edited.

■

Graphical view. Displays an image of the item.

For more information, see The Toolspace Item View (page 99).

Copying Items in the Toolspace Trees
You can copy some items in the Toolspace trees by dragging them to another drawing or collection. For
information about using this feature in the Settings tree, see Dragging Items within the Settings Tree (page
115). You can use the Prospector tree drag-and-drop feature to add drawing points to drawing point groups.
For more information, see Changing Point Group Properties by Dragging Points into the Point Group (page
568).

The Toolspace Item View
Use the Toolspace item view to display information about an item or the contents of a collection.
The item view is a secondary pane displayed beside or below the tree. To display the item view, click the
item name.
When the Toolspace window is floating, you can change the orientation of the item view by clicking the
button at the top of the Toolspace.
NOTE To see the item view, you may need to increase the size of the Toolspace window or move the bar that
separates the item view from the Prospector, Settings, or Survey tree. To move the bar that separates the item
view from the Prospector, Settings, or Survey tree, you must first select a collection that displays an item view.
An item view takes one of the following forms, depending on the selected item:

List View
A list view is a table displayed by the Toolspace trees for some items. In some cases, this information can be
edited. The following illustration shows a Prospector list view of points:
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When the Toolspace is docked, the list view is displayed below the data tree. When the Toolspace is undocked,
you can display the item view either below the data tree or to one side of the data tree by clicking the item
view orientation button

.

Graphical View
A graphical view displays an image of the selected item. The following illustration shows a Prospector
graphical view of a parcel.

To view graphical item previews, you first click the Item Preview button
on the Prospector tab. Then
right-click the object or object collection and select Show Preview. Then click on the object name in the
Prospector tree.
Right-click in the graphical preview to display a shortcut menu that allows you to manipulate the image
using commands such as Pan and Zoom.
Not all items on the Prospector and Settings, or Survey trees have item views associated with them.

Selecting Items in a List View
You can select one or more items in a Toolspace list view.
To work with an item in the list view, you must first select it in the list view by clicking the icon at the far
left of the row. If you click within the row, you might select one cell but not the entire item.
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NOTE You can quickly scroll to the top of the list view by selecting an item, holding down Ctrl and pressing Home.
Scroll to the bottom of the list view by holding down Ctrl and pressing End.
To select items in a list view
1 In Toolspace, on the Prospector, Settings, or Survey tab, click an item that displays a list view.
NOTE Some items do not have list views associated with them.
2 In the list view, click the icon at the left of the row that contains the first item you want to select.
3 Do one of the following:
■

To select additional contiguous items, hold down Shift and click the row containing the last item
you want to select.

■

To select additional non-contiguous items, hold down Ctrl and click the items you want to select.

■

To select every item from the current item to the beginning of the list, hold down Shift and press
Home.

■

To select every item from the current item to the end of the list, hold down Shift and press End.

Customizing a List View
You can change the appearance of a list view by hiding columns, changing column positions, and changing
column widths.
Right-click any column heading in the list view to display a shortcut menu that shows all the available
columns. Checkmarks indicate which columns are currently displayed in the list view.
The value in a shaded column cannot be edited. If a displayed column is not in use, it contains a hatch
pattern instead of data.
To customize a list view
1 In Toolspace, on the Prospector, Settings, or Survey tab, click an item that displays a list view.
NOTE Some items do not have list views associated with them.
2 To show the names of all the columns that can be included in the list view, right-click any column
heading.
Check marks indicate which columns are currently displayed in the list view.
3 To show all the columns in the list view, click Show All Columns.
4 To hide a column, do one of the following:
■

Right-click the column heading of the column you wish to hide and click Hide Column.

■

Right-click any column heading to display the column heading shortcut menu, and clear the check
mark from the column you want to hide.

The list view is displayed without the column.
5 To show a hidden column, right-click over any column heading to display the column heading shortcut
menu, and select the column you want to show.
6 To change the position of a column in the list view, drag the column heading right or left.
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7 To adjust the width of a column, move the cursor to the margin of the column heading until it changes
to

. Drag the column margin right or left.

Changing the Contents of a Column in a List View
Use the column heading menu to change all the cells in a list view column to the same value.
For example, you can assign the same elevation to all the points in a list view.
To change the contents of a column in a list view
1 In Toolspace, on the Prospector, Settings, or Survey tab, click an item to display its list view.
NOTE Some items do not have list views associated with them.
2 If any items in the list view are selected, press Esc to clear the selection.
3 Right-click the column heading of the column you want to change and click Edit.
4 In the edit box that is activated, enter the new value and press Enter.

The List View Shortcut Menu
Right-click in a list view to display a shortcut menu.
Some commands apply only to items that you must select in the list view before right-clicking to display
the menu. For more information, see Selecting Items in a List View (page 100).
The list view menu contains commands that apply to the selected items, plus the following standard
commands if they are applicable:
Select this menu
item...

If you want to do this....

Zoom To

(Drawing items only) Zoom the drawing to the selected item
or items in the list view.

Pan To

(Drawing items only) Pan the drawing to the selected item or
items in the list view.

Line Shading

Display the list view with a shading guide every three rows.

Copy To Clipboard

Copy a tab-delimited copy of the selected information to the
clipboard so that you can paste it into a document for printing
or editing. For more information, see Copying Items from a List
View (page 103).

Copy Value To Clipboard

Copy the contents of the specific value in the cell. This command copies the contents of a selected cell as a raw text (floating point) value. For example, if you use this command to copy
station data displayed as 2+00.00 in the list view, the value is
copied to the clipboard as 200.00.
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Copying Items from a List View
Use the Copy To Clipboard or Copy Value To Clipboard commands on the list view shortcut menu to copy
the contents of an item view or single cell value to a file for editing or printing.
The Copy To Clipboard command copies a tab-delimited list of all the selected items in the list view, including
the column headers, to the Windows clipboard. You can then paste the information into an Excel spreadsheet
or a text file.
The Copy To Clipboard command copies all displayed columns, including columns without values. It does
not copy hidden columns.
The Copy Value To Clipboard command copies the contents of the cell that your mouse is currently hovering
over as a raw text (floating point) value.
For example, if you use this command to copy station data displayed as 2+00.00 in the list view, the value
is copied to the clipboard as 200.00.
Each value is copied with the same precision used to display the value in the list view. You can change the
precision of some values using the drawing and feature level settings. For more information, see Understanding
Settings (page 77).
To copy items from a list view
1 Select the items you want to copy. For more information, see Selecting Items in a List View (page 100).
2 Right-click to display the list view shortcut menu for the selected items.
3 Click Copy To Clipboard.
4 Open a prepared Excel spreadsheet or a text file and paste the clipboard contents into the file.

The Toolspace Prospector Tab
You can use the Prospector tab to manage project and drawing objects.
Right-click collections and objects to access commands.

On this tab, all of the objects in a drawing or project are arranged in a hierarchy that you navigate in standard,
Windows Explorer–like fashion.
The Prospector tab and the Settings tab share some basic functions. For more information, see Functions
Shared by the Prospector, Settings, and Survey Tabs (page 98).
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The Prospector tree contains the following top-level collections, which can be viewed using the Master View:
■

Open Drawings. For more information about this collection, see The Prospector Tree (page 105).

■

Projects. For more information about this collection, see Project Management (page 143).
NOTE The Projects collection in the Prospector tree is not visible if you have not installed Autodesk Vault client
and server applications. During a drawing session, the Projects collection lists the projects that are available
after you have logged into an Autodesk Vault server and Vault database. For more information, see Logging
in to a Vault Server (page 169).

■

Drawing Templates. For more information about this collection, see Drawing Templates (page 127).

To open or close the Prospector tab
■

Click Home or View tab ➤ Palettes panel ➤ Prospector

.

NOTE When the tab is in the “open” state, the button has a blue background
“closed” state, the button has a white background

. When the tab is in the

.

When running any of following commands, the Prospector tab is opened automatically.
■

Create Sheets

■

Edit In Storm Sewers

■

Export To LandXML

■

Point Group Properties

■

Clicking the

Pipe Network Vistas button on the Network Layout Tools toolbar

Quick Reference
Ribbon
Home or View tab ➤ Palettes panel ➤ Prospector
Command Line
Prospector

The Prospector Tab Icons
Use the icons at the top of the Prospector tab to control the display of icons within the Prospector tree, to
display the Panorama window, and to access Help.
Icon

Purpose
Toggles the Toolspace item preview display. Click to enable previews.
When item previews are disabled, the Show Preview menu item in
an item’s shortcut menu is disabled.
Switches the orientation of the item and list views. Available only
when the Toolspace is undocked.
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Icon

Purpose
Switches the display of the Panorama window. If the Panorama window doesn’t contain any active vistas, this button is not available.
For more information, see The Panorama Window (page 119).
Displays Help.

Controlling the Items Displayed in the Prospector Tree
Use the drop-down list at the top of the Prospector tab to control which items are displayed in the Prospector
tree.

■

Master View. Displays all project and drawing items, including drawing templates. The name of the
active drawing is highlighted.

■

Active Drawing View. Displays only items in the active drawing. If you switch to another drawing, the
tree is updated to reflect the new drawing.

The Prospector Tree
Use the Prospector tree to manage and access drawing and project objects.
The Prospector tree and the Settings tree share some basic functions. For more information about basic
Toolspace tree operations, see Functions Shared by the Prospector, Settings, and Survey Tabs (page 98).
The following illustration shows an expanded Prospector tree for a drawing:
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Refer to the following table for information about the drawing collections in the Prospector tree:
For information
about this item in
the tree...

See....

Points

Points Collection (Prospector Tab) (page 438)

Points Groups

Point Groups Collection (Prospector Tab) (page 554)

Point Clouds

Point Cloud Collection (Prospector Tab) (page 596)

Surfaces

Surfaces Collection (Prospector Tab) (page 647)

Alignments

Alignment Collection (Prospector Tab) (page 925)

Sites

Sites Collection (page 780)

Pipe Networks

Pipe Networks Collection (Prospector Tab) (page 1329)

Corridors

Corridors Collection (Prospector Tab) (page 1474)

Assemblies

Assemblies Collection (Prospector Tab) (page 1540)

Subassemblies

Subassemblies Collection (Prospector Tab) (page 1556)

Intersections

Intersection Collection (Prospector Tab) (page 1588)

Survey

Survey Collection (Prospector Tab) (page 214)

View Frame Groups

View Frame Groups Collection (Prospector Tab) (page 1930)

Feature Lines

Feature Lines Collection (Prospector Tab) (page 798)

Parcels

Assemblies Collection (Prospector Tab) (page 1540)

Profiles

Profiles Collection (Prospector Tab) (page 1117)

Profile Views

Profile Views Collection (Prospector Tab) (page 1117)

Sample Lines

Sample Line Groups Collection (Prospector Tab) (page 1228)

Sections

Sections Collection (Prospector Tab) (page 1229)

Section Views

Section View Groups Collection (Prospector Tab) (page 1229)

Grading Groups

Grading Groups Collection (Prospector Tab) (page 800)

Data Shortcuts

Using Data Shortcuts (page 145)

Standard shortcut menu commands are available for many Prospector tree items and collections. To display
the shortcut menu, right-click a collection or item in the Prospector tree. The following commands are
available on the Prospector shortcut menu whenever they are applicable to the selected item(s):
Select this shortcut If you want to do this....
menu command...
Properties

View or edit the properties of the selected item or items.
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Select this shortcut If you want to do this....
menu command...
Edit

Edit the selected item or items.

Delete

Delete the selected item or items.

Select

Selects the item or items in the drawing.

Zoom To

Zoom the drawing to the selected item or items contained in
the collection.

Pan To

Pan the drawing to the selected item or items contained in the
selected collection

Export LandXML

Export information using LandXML.

Refresh

Update the items displayed in the Prospector tree.

NOTE Some Prospector shortcut menus do not include all the commands in the preceding table. Also, a Prospector
shortcut menu can contain additional commands that are related to the selected collection or item, including
project management access control commands.
The Prospector tree contains collections for projects and drawing templates. For more information, see
Project and Drawing Items in the Prospector Tree (page 159).

The Toolspace Settings Tab
You can use the Settings tab to manage styles for AutoCAD Civil 3D objects and to control settings for
drawings and commands.
Right-click collections and items to access commands.

On this tab, styles are organized for different object types. Even in a blank drawing, most of these styles are
present in a standard hierarchy. You can create and modify styles in a drawing, then save it as a template.
Subsequent drawings based on the template will automatically have the same set of styles available. You
can modify object, label, and table styles. You can also control settings for drawings and commands.
The Prospector tab and the Settings tab share some basic functions. For more information about basic
Toolspace tree operations, see Functions Shared by the Prospector, Settings, and Survey Tabs (page 98).
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To open or close the Settings tab
■

Click Home or View tab ➤ Palettes panel ➤ Settings

.

NOTE When the tab is in the “open” state, the button has a blue background
“closed” state, the button has a white background

. When the tab is in the

.

Quick Reference
Ribbon
Home or View tab ➤ Palettes panel ➤ Settings
Command Line
Settings

The Settings Tab Icons
Use the icons at the top of the Settings tab to control the display of icons within the Settings tree, to display
the Panorama window, and to access Help.
Icon

Purpose
Toggles the orientation of the item view when the Toolspace window
is floating. For more information, see The Toolspace Item View (page
99).
Switches the display of the Panorama window. If the Panorama window doesn’t contain any vistas, this control is not active. For more
information, see The Panorama Window (page 119).
Displays Help.

Controlling the Items Displayed in the Settings Tree
Use the drop-down list at the top of the Settings tab to control which items are displayed in the Settings
tree.

Select one of the following tree views on the Settings tab:
■

Master View. Displays items for all open drawings. The name of the active drawing is shown in boldface.

■

Active Drawing Settings View. Displays only the items for the active drawing.

■

Active Drawing Labels Only View. Displays only label style collections and label styles items for the active
drawing.
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■

Labels Only View. Displays only label style collections and label style items for all drawings.

The Settings Tree
Use the Settings tree to manage object, label, and table styles and to control settings for drawings and
commands.
For more information about basic Toolspace tree operations, see Functions Shared by the Prospector, Settings,
and Survey Tabs (page 98).
The following illustration shows the top-level collections in the Settings tree:

For information about
this item in the tree...

See...

General

General Collection (Settings Tree) (page 112)

Point

Point Collection (Settings Tab) (page 438)

Surface

Surface Collection (Settings Tab) (page 648)

Parcel

Parcel Collection (Settings Tab) (page 879)

Grading

Grading Collection (Settings Tab) (page 800)

Alignment

Alignment Collection (Settings Tab) (page 927)

Profile

Profile Collection (Settings Tab) (page 1117)
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For information about
this item in the tree...

See...

Profile View

Profile View Collection (Settings Tab) (page 1118)

Superelevation View

Superelevation View Feature Settings (page 1105)

Sample Line

Sample Line Collection (Settings Tab) (page 1230)

Section

Section Collection (Settings Tab) (page 1230)

Section View

Section View Collection (Settings Tab) (page 1231)

Mass Haul Line

Editing Mass Haul Line Settings (page 1319)

Mass Haul View

Editing Mass Haul View Settings (page 1320)

Pipe Network

Pipe Network Collection (Settings Tab) (page 1329)

Pipe

Pipe Collection (Settings Tab) (page 1330)

Structure

Structure Collection (Settings Tab) (page 1330)

Corridor

Corridor Collection (Settings Tab) (page 1474)

Intersection

Intersection Collection (Settings Tab) (page 1590)

Assembly

Assembly Collection (Settings Tab) (page 1541)

Subassembly

Subassembly Collection (Settings Tab) (page 1557)

Quantity Takeoff

Editing Quantity Takeoff Settings (page 1275)

Survey

Survey Collection (Settings Tab) (page 215)

View Frame Group

View Frame Group Collection (Settings Tab) (page 1930)

View Frame

View Frame Collection (Settings Tab) (page 1932)

Match Line

Match Line Collection (Settings Tab) (page 1934)

Building Site

Edit Feature Settings - Building Site (page 2009)

Most of the object collections above conform to a standard layout and use a standard shortcut menu.

The Object Collection (Settings Tree)
Use the object collection in the Settings tree to access object styles, settings and drawing-related information
for a class of objects.
The following illustration shows an example of a Settings tree object collection:
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Right-click the object collection to display a shortcut menu with the following commands:
Select this command...

If you want to...

Edit Feature Settings

Modify the settings for all commands that pertain to the object.

Edit Label Style Defaults

Set default settings for all label styles belonging to the object.

Refresh

Update the Settings tree display.

For detailed information about the settings, click Help in the dialog box that is displayed when you select
the menu item.

The Object Style Collection (Settings Tree)
Use an object’s Styles collection in the Settings tree to manage styles for a class of objects.
The following illustration shows an example of a Settings tree object style collection:

Right-click the style collection to display a standard shortcut menu with the following commands:
Select this command... If you want to...
New

Create a new style.

Refresh

Update the Settings tree display.
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Right-click a style name to display a standard shortcut menu with the following commands:
Select this command... If you want to...
Edit

Change the properties of the selected style.

Copy

Create a new style based on an existing style.

Delete

Delete the selected style. This command is displayed only
when the style can be deleted.

Refresh

Update the Settings tree display.

General Collection (Settings Tree)
Use the General collection to create multipurpose and label styles that can be used by more than one object
type.
Pipes and Surface objects can share the Render styles in the General Multipurpose Styles collection, while
Corridors and Grading share the other styles in this folder.
The General Label Styles are used by lines, curves, feature lines, and corridors. This collection also contains
Note label styles, which are not specific to an object.
The following illustration shows an illustration of the General collection:

Right-click a style name to display a shortcut menu that contains the following commands:
Select this command...

If you want to...

Edit

Change the properties of the style.

Copy

Create a new style based on an existing style.
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Select this command...

If you want to...

Delete

Delete the selected style. This command is displayed only
when the style can be deleted.

Refresh

Update the Settings tree display.

For detailed information about the settings, click Help in the dialog box that is displayed when you select
the menu item.

The Label Styles Collections (Settings Tree)
Use the Label Styles collections in the Settings tree to create and manage label styles and expressions for a
class of objects.
Click the +/- box to expand the collection and see the label styles for the object. Some objects have multiple
levels of label styles.
The following illustration shows an example of a label style collection:

Right-click a label style name to display a shortcut menu that contains the following commands:
Select this command...

If you want to...

Edit

Change the properties of the label style.

Copy

Create a new label style based on an existing label style.

Delete

Delete the selected label style. This command is displayed
only when the style can be deleted.

Refresh

Update the Settings tree display.

For detailed information about the settings, click Help in the dialog box that is displayed when you select
the menu item.

The Table Styles Collections (Settings Tree)
Use the Table Styles collections in the Settings tree to create and manage table styles for a class of objects.
Click the +/- box to expand the collection and see the table styles for the object. Some objects have multiple
levels of table styles.
The following illustration shows an example of a Settings tree table style collection:
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Right-click a table styles collection to display a shortcut menu with the following commands:
Select this command...

If you want to...

New

Create a new table style.

Refresh

Update the Settings tree display.

For detailed information about the settings, click Help in the dialog box that is displayed when you select
the menu item.
Right-click a table style name to display a shortcut menu that contains the following commands:
Select this command...

If you want to...

Edit

Change the properties of the table style.

New

Create a new table style.

Copy

Create a new table style based on an existing table style.

Delete

Delete the table style. This command is displayed only when
the style can be deleted.

Refresh

Update the Settings tree display.

For detailed information about the settings, click Help in the dialog box that is displayed when you select
the menu item.

The Commands Collections (Settings Tree)
Use the Commands collections in the Settings tree to control the settings for a specific command at the
object (feature) level.
When you change settings using the Commands collections, the changes affect a single command only. For
more information, see Understanding Settings (page 77).
The following illustration shows an example of a Settings tree commands collection:
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Right-click a command name and click Edit Command Settings to display the Edit Command Settings dialog
box for the command. You can then change the settings.

Dragging Items within the Settings Tree
Copy styles, description keys, and pipe rules using the Settings tree drag-and-drop capability.
For more information on dragging items within or between drawings, see Dragging Styles or Items Within
or Between Drawings (page 70).

The Toolspace Survey Tab
You can use the Survey tab to manage survey user and system settings as well as survey data.
Survey data is managed on the Survey tab of Toolspace instead of on the Prospector tab like other objects.
Right-click collections and items to access commands.

This tab displays survey project data, organized within databases for survey projects, equipment, and figure
prefixes. The project databases record the survey points, networks, and figures. The equipment databases
record standard deviations and other operational parameters of individual pieces of survey equipment. The
figure prefix databases record the conversion routines that are applied when creating lots, buildings, or other
figures from survey points.
The contents of the Survey tab are not specific to a drawing. This tab reflects the survey data in your AutoCAD
Civil 3D Projects folder, so it facilitates access to survey data from multiple drawings.
The surveyed points and figures in a project can be converted to AutoCAD Civil 3D points and parcels.
The Survey tab and Prospector tab share some basic functions. For more information, see Functions Shared
by the Prospector, Settings, and Survey Tabs (page 98).
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The Survey tree provides access to survey data and settings.
To open or close the Survey tab
■

Click Home or View tab ➤ Palettes panel ➤ Survey

.

NOTE When the tab is in the “open” state, the button has a blue background
“closed” state, the button has a white background

. When the tab is in the

.

Quick Reference
Ribbon
Home or View tab ➤ Palettes panel ➤ Survey
Command Line
Survey

The Survey Tab Icons
Use the icons at the top of the Survey tab to control the display of icons within the Survey tree, to display
the Panorama window, and to access Help.
Icon

Purpose
Displays the Survey User Settings dialog box. User settings are
specific to a Windows user login account and affect the Survey
feature system, not database or drawing data.
Opens the Survey Preview Window.

Displays the Survey Preview Settings dialog box. Select the components that you want to display in the preview.
Switches the orientation of the item and list views. Available only
when the Toolspace is undocked.
Switches the display of the Panorama window. If the Panorama
window doesn’t contain any active vistas, this control is not
available. For more information, see The Panorama Window (page
119).
Displays Help.

The Survey Tree
Use the Survey tree to manage and access survey settings and data.
The Survey tree and the Prospector tree share some basic functions. For more information about basic Survey
tree operations, see Functions Shared by the Prospector, Settings, and Survey Tabs (page 98).
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The Survey tree provides access to survey data and settings:

■

Survey Databases. A survey database collection expands to display all the networks (page 224) (which
collect the control points (page 280), non-control points (page 283), known directions (page 309), observations
(page 289), setups (page 285), and traverse definitions (page 401)), figures (page 347), and survey points.

■

Equipment Databases. Expands to display available equipment database. For more information about
this collection, see Survey Equipment Database (page 221).

■

Figure Prefix Databases. Expands to display available figure prefix databases. Figure prefix databases
enable you to determine the layer that a figure is drawn on by creating a prefix for a group of figure
names. For more information about this collection, see Survey Figure Prefix Database (page 222).

■

Linework Code Sets. Expands to display available Linework Code Sets. Linework code sets are used to
interpret the syntax of the field codes that are entered into the data collector by the survey field crew.
For more information about this collection, see Linework Code Sets (page 252).

Standard shortcut menu commands are available for many Survey tree items and collections. To display the
shortcut menu, right-click a collection or item in the Survey tree.

The Toolspace Toolbox Tab
You can use the Toolbox tab to access the Reports Manager and subscription extensions and to add custom
tools.
Right-click collections and items to access commands.
The Toolbox tab of Toolspace is the primary interface for running reports and extensions. Like the Survey
tab, you can show or hide the Toolbox tab as needed.

Reports
The Toolbox tab organizes reports for each object type. The reports provide useful engineering data from a
drawing in a compact, portable format. Some are in LandXML format, with predefined or custom XSL style
sheets. Other reports are .NET format, with custom dialog boxes that allow you to select the data and various
options.
You can add your own reports to the Toolbox menu. These reports can be in a variety of formats, including
XML, VBA, COM, or .NET.
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Subscription Extensions
When you install subscription extensions, they are added to the Subscription Extension Manager collection
in the Toolbox.

See also:
■

Reports (page 1757)

To open or close the Toolbox tab
■

Click Home or View tab ➤ Palettes panel ➤ Toolbox

.

NOTE When the tab is in the “open” state, the button has a blue background
state, the button has a white background

.

Quick Reference
Ribbon
Home or View tab ➤ Palettes panel ➤ Toolbox
Menu
General menu ➤ Toolbox
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. When the tab is in the “closed”

Command Line
Toolbox

The Toolbox Tab Icons
Use the icons at the top of the Toolbox tab to edit report settings, to display the Toolbox Editor, to display
the Panorama window, and to access Help.
Icon

Purpose
Opens the Edit Report Settings (page 2464) dialog box, where you
can edit settings for all report types.
Opens the Toolbox Editor (page 2463), where you can add custom
reports. You can also add other custom tools.
Switches the display of the Panorama window. If the Panorama
window doesn’t contain any active vistas, this control is not
available. For more information, see The Panorama Window (page
119).
Displays Help.

Displays available report types. Expand the Reports Manager tree
and double-click a report type to run it. Both LandXML and VBA
reports are listed in this tree.

The Toolbox Tree
Use the Toolbox tree to access the reports available in the Reports Manager, to access Subscription Extensions,
and to access other custom tools.
The following commands are available on the Toolbox shortcut menu whenever they are applicable:
Select this shortcut If you want to do this....
menu command...
Execute

Run a selected report.

Refresh

Update the items displayed in the Toolbox tree.

The Panorama Window
Use the Panorama window to display horizontally oriented data, such as point data, in a grid.
The Panorama window can display many types of data, such as the Point Editor vista and the Alignment
Entities vista. To conserve screen space if more than one vista is active, the Panorama window displays a
tab for each one, as shown in the following illustration.
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Click the tab containing a vista’s name to bring it to the front of the window.
You control the display of some vistas, such as the Point Editor vista. You activate them when you want,
and they remain active until you dismiss them by clicking
. Other vistas, such as the Alignment Entities
vista, are controlled by a specific command. This type of vista can only be activated or closed when the
command is running, and its display is controlled from the command toolbar.
The active drawing controls the state of the Panorama window. When you switch between drawings, the
Panorama window either becomes inactive or shows only the vistas associated with the active drawing.
You can dock the Panorama window or use Auto-hide to reduce the amount of screen space it requires. For
more information, see The Toolspace Window (page 96).

Displaying the Panorama Window
Display of the Panorama window is affected by several factors, such as the active drawing and the active
vistas within that drawing.
If the Panorama window is not visible, refer to the following table for possible reasons and actions you can
take to display it:
Under these circumstances...
You cannot see the Panorama
window or the title bar.

Do this...

Click
at the top of the Toolspace window. If the
Panorama window contains active vistas, it is displayed.
If the button is disabled, the Panorama window contains
no active vistas.
In some cases, you can display the Panorama window
by clicking a toolbar icon.

The Panorama window is displayed, but the vista you
want to work with is not displayed.

If the Panorama window has a tab for the vista, click
the tab to display the vista. If the named tab is not visible, you must activate the vista.
For instructions about activating a specific vista, refer
to Help for that vista.

Only the Panorama title bar
is displayed (Auto-hide is active).

Move the cursor over the title bar to display the full
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Panorama window. To disable Auto-hide, click
the Panorama title bar.

on

Layout Toolbars
Layout toolbars let you create and or edit AutoCAD Civil 3D objects.
AutoCAD Civil 3D has the following layout toolbars:
■

Alignment Layout Toolbar

■

Grading Creation Toolbar

■

Parcel Layout Toolbar

■

Pipe Network Layout Toolbar

■

Point Object Creation Toolbar

■

Profile Layout Toolbar

The icons or commands available on an AutoCAD Civil 3D layout toolbar depend upon the toolbar in use.
Most AutoCAD Civil 3D layout toolbars include the following three icons in the upper right corner:
Icon

Purpose
Pins the toolbar, which places it in a fixed location and also shrinks
the toolbar down to a small placeholder when the cursor moves
outside the toolbar. To display the expanded toolbar, move the
cursor over the placeholder. To unpin the toolbar, click

.

Displays Help for the layout toolbar.

Closes the layout toolbar.

For information about the icons and commands that are available from a specific layout toolbar, refer to
the following table, or click the Help button on the toolbar.
For information on the...

see

Alignment Layout Toolbar

Alignment Layout Tools (page 1959)

Grading Object Creation Toolbar

Grading Creation Tools (page 2114)

Parcel Layout Toolbar

Parcel Layout Tools (page 2245)

Pipe Network Layout Toolbar

Network Layout Tools (page 2268)

Point Object Creation Toolbar

Create Points Dialog Box (page 2357)

Profile Layout Toolbar

Profile Layout Tools (page 2419)

Tool Palettes
Tool palettes provide convenient access to a variety of tools and content.
Tool palettes are a standard feature in AutoCAD. You can open tool palettes using the ToolPalettes command,
or from the ribbon.
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Tool palettes provide access to both AutoCAD and AutoCAD Civil 3D tools and content. For example, the
AutoCAD Civil 3D tool palettes provide access to subassemblies and assemblies that you can use in corridor
design. They also provide access to civil engineering related render materials and multi-view blocks.
The AutoCAD tool palettes provide access to items such as AutoCAD render materials, AutoCAD multi-view
blocks, and AutoCAD visual styles.
You can drag and drop an item from a Tool Palette into the drawing to insert it. Any prompts that are
required for inserting the item are displayed at the command line.
Tool palettes can be customized to suit your needs. For more information on working with tool palettes, see
Tool Palettesin AutoCAD Help.
For information about adding render materials to a drawing from a tool palette, see Adding Materials to
Drawings (page 1763).
For more information about working with the Content Browser and tool palettes, see Adding Content to a
Tool Catalog in the Content Browser Help.
To display the Tool Palettes Window and select a palette
1 Click Home tab ➤ Palettes panel ➤ Tool Palettes Window.
2 In the Tool Palettes Window, on the title bar, click the Properties icon

.

3 From the bottom of the menu, select the tool palette to display.
To add a subassembly or assembly to a tool palette
1 Click Home tab ➤ Palettes panel ➤ Tool Palettes Window.
2 Switch to the tool palette you want to add the subassembly or assembly to, or create a new tool palette.
3 Click View tab ➤ Palettes panel ➤ Content Browser

.

4 In the Content Browser, locate the subassembly or assembly you want to add to a tool palette.
5 Click the i-drop icon on the subassembly or assembly.

6 Hold down your pointing device and drag the subassembly or assembly to the location in the tool
palette where you want to place it.

Now you can use the procedure described in Creating a Subassembly from a Tool Palette (page 1557) to add
this subassembly to a drawing. For more information about working with the Content Browser and tool
palettes, see Adding Content to a Tool Catalog in the Content Browser Help.

Quick Reference
Ribbon
Click Home tab ➤ Palettes panel ➤ Tool Palettes Window.
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Menu
Click General menu ➤ Tool Palettes Window.
Command Line
ToolPalettes

Content Browser
The Content Browser is a library of tool catalogs containing tools, tool palettes, and tool packages. You can
publish catalogs so that multiple users have access to standard tools for projects.
Metric and imperial subassembly tool catalogs are included. You can drag and drop subassemblies from a
catalog onto a tool palette for easier access.
For more information, see Understanding the Content Browser in the Content Browser Help.
To display the Content Browser
■

Click View tab ➤ Palettes panel ➤ Content Browser

.

Quick Reference
Ribbon
Click View tab ➤ Palettes panel ➤ Content Browser

.

Menu
Click General menu ➤ Content Browser.
Command Line
ContentBrowser

Object Tooltips
Proximity and rollover tooltips are displayed for civil drawing objects. You can control the display of tooltips
for the drawing, for an object type, or for a specific object.
■

A rollover tooltip displays information about an object when you hover the cursor directly over it. If the
object highlighting setting is on, the object will be highlighted when this tooltip is displayed.

■

A proximity tooltip displays information about the current location of the cursor with respect to one or
more objects in the drawing. More specifically, it displays information about the proximity of the cursor
to the objects. These tooltips are displayed without having to hover the cursor over any specific entity
in the drawing.

The most important object information is displayed at the beginning of the tooltip. For alignments and
surfaces, the tooltip displays the station/offset information for the closest alignment to the cursor and the
elevation of the topmost surface.
If you keep your cursor in the same location, additional information is displayed in an expanded tooltip
that shows up to four more items. Which items are displayed depends upon the objects in the drawing and
whether tooltips are enabled for that object (page 124). If there are five alignments and five surfaces in the
drawing, for example, the proximity tooltip will display three alignments and three surfaces.
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Alignments are shown in order of proximity to the cursor. Surfaces are shown in order from highest elevation
first, to lowest elevation last.
To control the display of tooltips for the drawing
■

Click Application Menu ➤ Options. On the Display tab, select or clear the Show ToolTips and Show
Rollover ToolTips check boxes.
NOTE The Show ToolTips check box controls the display of tooltips for the ribbon and for dialog boxes, as
well as proximity tooltips. The Show Rollover ToolTips check box controls the display of AutoCAD and AutoCAD
Civil 3D rollover tooltips.

To control the display of tooltips for an object type
1 On the Toolspace Settings tab, right-click <object> ➤ Edit Feature Settings.
2 In the Edit Feature Settings dialog box, under General, edit the Show Tooltips value.
NOTE This setting can be overridden at the object level in the object properties dialog boxes.
■

Yes: Displays tooltips for all objects of the selected type by default.

■

No: Does not display tooltips for the selected object type.

3 Edit the New Entity Tooltip State.
■

On: Sets the default state of tooltips for new objects to be turned on.

■

Off: Sets the default state of tooltips for new objects to be turned off.

4 Click OK.
To control the display of tooltips for an object
■

In any civil object properties dialog box, on the Information tab, select or clear the Show Tooltips check
box.

User Interface Command Reference
This section provides brief descriptions of the user interface-related commands available from the command
line in AutoCAD Civil 3D.
Use the links in the following table to access more information about user interface commands available
from the command line in AutoCAD Civil 3D:
Command

Description

ContentBrowser

Displays the Content Browser (page 123).

DockPanorama

Docks the Panorama window (page 119).

DockTS

Docks the Toolspace window (page 96).

FloatPanorama

Changes the Panorama window from docked to floating
(page 119).
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Command

Description

FloatTS

Changes the Toolspace window from docked to floating
(page 96).

HidePanorama

Hides the Panorama window (page 120).

Menubar

Displays the legacy menu bar (page 92).

Prospector

Opens or closes the Toolspace Prospector tab (page 103).

Settings

Opens or closes the Toolspace Settings tab (page 107).

Survey

Opens or closes the Toolspace Survey tab (page 115).

Ribbon

Displays the ribbon (page 87).

RibbonClose

Hides the ribbon (page 87).

ShowPanorama

Displays the Panorama window (page 120).

Toolbox

Opens or closes the Toolspace Toolbox tab (page 117).

ToolPalettes

Displays the Tool Palettes window (page 121).

Toolspace

Opens or closes the Toolspace window (page 96).

WelcomeScreen

Displays the welcome screen where you can access
getting started videos, Help, and tutorials.
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Working with Drawings

6

AutoCAD Civil 3D objects are stored in drawings by default.
If you work in a multi-user environment or want to manage your drawings by having different objects in different drawings
you will want to use Project Management. For more information, see Project Management (page 143).

NOTE AutoCAD Civil 3D uses the standard AutoCAD drawing functionality. For more information, see the help
topics.
Use the list at the top of the Prospector tab to control whether only the active drawing is listed in the prospector tree or
all open drawings are listed.

Drawing Templates
Use drawing templates to eliminate duplication of effort and to help maintain consistency across drawings.
You start a new AutoCAD Civil 3D drawing using a template file. An AutoCAD Civil 3D drawing template
can contain standard AutoCAD information, such as AutoCAD settings and layers, and AutoCAD objects,
such as lines and text. In addition, it can include any AutoCAD Civil 3D drawing information that is listed
in either the Settings tree (including AutoCAD Civil 3D settings, styles, label styles, tables, description keys,
and point import/export formats) or the Prospector tree (including any AutoCAD Civil 3D object, such as
point groups).
Templates are listed under the Drawing Templates collection in the Prospector tree Master View.
The Drawing Template File Location path on the Files tab of the Options dialog box specifies where AutoCAD
Civil 3D templates are located.
To use drawing templates
1 In the Toolspace Prospector, click Master View from the drop-down list.
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2 Expand the Drawing Templates collection and right-click a template to:
■

Create a new drawing based on the template.

■

Open the template.

Out-of-the-box Templates
AutoCAD Civil 3D drawing templates are included in the product.
The AutoCAD Civil 3D drawing templates are based on the National CAD Standard version 3.1. The following
templates are included:
■

_AutoCAD Civil 3D (Imperial) NCS

■

_AutoCAD Civil 3D (Metric) NCS

These templates contain an extended set of styles and settings.
NOTE These templates do not contain styles named ‘Standard.’ If you base a new drawing on a non-Civil 3D
drawing template, such as acad.dwt, then styles named ‘Standard’ are created by default in the new drawing.
When you start a new drawing using the New command on the Application menu, you can choose which
template you want to use.
The QNEW command, which is available on the Quick Access Toolbar, automatically uses the template
specified in the AutoCAD Options dialog box. For more information, see “Use a Drawing Template File” in
AutoCAD Help.

Drawing Template Layer Naming Conventions
The layers created in the AutoCAD Civil 3D 2011 templates follow the National CAD Standards Rules (NCS).
For more information about the National CAD Standards layering settings, see
http://www.nationalcadstandard.org.
The layers follow the NCS standards as follows, with each element separated by a dash:
<Discipline Designator> - <Major Group> - <Minor Group> - <Status>
■

Discipline Designator: Required; the AutoCAD Civil 3D templates use the C and V discipline designators,
which stand for Civil and Survey/Mapping.

■

Major Group: Required; identifies elements such as roads, topographic elements, and storm sewers. To
adhere to the standards, custom Major Group fields are not allowed.

■

Minor Group: Optional; identifies sub-elements such as road profiles. You can include up to two minor
groups per layer name, and you can define your own custom Minor Groups. For example, the layer
C-ROAD-LINE-EXTN has two Minor Groups: “Line” and “Extn”.

■

Status: Optional; identifies phases of work.

For example, C-TOPO-MINR-N stands for Civil - Topographic element - Minor Contours - New.

Plan Production Drawing Templates
Drawing templates for Plan Production tools are inlcuded in the Plan Prodution directory.
For information on using the Plan Production tools, see Plan Production Tools (page 1901).
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Layer Standards in Templates
Maintaining a standard for the use of layers in your drawing is easier if you have a drawing template with
predefined layers, and styles that reference those layers when objects are created.
For consistency, save your template as an AutoCAD standards file (.dws format). Then, in the template, enter
the STANDARDS command and in the Configure Settings dialog box, link the standards file to the template.
If you want to enforce the standards, you can click the Settings button and activate notifications of standards
violations, or override such violations. See AutoCAD Help for more information about the use of standards
files.
For more information about layers, see Layers (page 73).

Object and Label Styles in Templates
Consider designing styles to reflect the information requirements at different times in the project.
For example, create styles for objects in the design phase, and other styles for their final presentation. Also,
you can create styles for different users of the drawings, showing object details and labels that present the
data each type of user needs.
The styles for labels are another template item that should be developed with a top-down approach, similar
to drawing settings and feature settings. At the drawing level, click Edit Label Style Defaults. In this context,
you can set global standards such as those for text font, size, and label behavior around curves. As with the
object styles, after setting label style defaults you can review the feature-level settings and apply any required
overrides.
Ideally, your drawing template will have the perfect set of styles for your projects, but this usually takes
some time to evolve. To assist the process, create a demonstration drawing that contains one or more surface,
alignment, and other object types. Or you can explore the Sample_styles.dwg, that is supplied with AutoCAD
Civil 3D. After a default installation, you can find this file at: C:\Program Files\AutoCAD Civil 3D
2010\Help\Civil Best Practices Guide\Sample_styles.dwg. This provides a good laboratory in which to
display and develop styles. Consider designing styles to reflect the information requirements at different
times in the project. For example, create styles for objects in the design phase, and other styles for their final
presentation. Also, you can create styles for different users of the drawings, showing object details and labels
that present the data each type of user needs.
For more information on styles, see Object and Label Styles (page 66).

Saving a Drawing as a Template
Create a new template from an existing drawing.
To create a drawing template file from an existing drawing

1 Click

➤ Open.

2 In the Select File dialog box, select the file you want to use as a template.
3 Click OK.

4 Click

➤ Save As.

5 In the Save Drawing As dialog box, under Files of Type, select the Drawing Template file type.
DWT files must be saved in the current drawing file format. To create a DWT file in a previous format,
save the file in the desired DWG format, and then rename the DWG file using a DWT extension.
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6 In the File Name box, enter a name for the template.
7 Click Save.
8 Enter a description of the template.
9 Click OK.

Quick Reference
Menu

➤ Save As
Command Line
SaveAs

Working with Drawing Settings
Use drawing templates to eliminate duplication of effort and to help maintain consistency across drawings.
As a basis for configuring your drawing settings, you can choose an existing template that is closest to your
needs. For more information about drawing templates, see Drawing Templates (page 127).
To see the available templates, click Application Menu ➤ New. If you want some preset object styles, the
templates that have names beginning with “_AutoCAD Civil 3D”, are recommended.
After choosing your initial template, the next logical step is to review and edit settings. On the Toolspace
Settings tab, right-click the drawing name and click Edit Drawing Settings. The Drawing Settings dialog box
includes five tabs and many settings.

Drawing Settings dialog box
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NOTE For detailed reference information about the Drawing Settings tabs, see Drawing Settings Dialog Box (page
2073).
■

The Units and Zones tab is used to set linear and angular units, intended plot scale, and coordinate zone
for the current drawing.

■

The Transformation tab provides functionality to transform the coordinate system specified on the Units
And Zones tab to local specifications.

■

The Object Layers tab provides a convenient table for assigning objects to layers, and creating or renaming
layers. Objects on the same layer are turned on and off together if you change the layer visibility. For
maximum display flexibility, spread objects and their components across several layers. The color of a
layer affects all objects assigned to that layer and drawn in a style that uses the ByLayer color setting. If
you set up styles this way, you can change the color of many objects by simply changing the layer color.

■

The Abbreviations tab is a central location in which to set the abbreviations used in object labels, especially
for alignment and profile geometry points.

■

The Ambient Settings tab provides global default settings, such as the precision of numeric values, and
the visibility of tooltips.
One setting on this tab often overlooked is the Save Command Changes To Settings under the General
setting group. If you set this to Yes, then whenever you change a setting, such as the radius of an alignment
curve, it is saved as the default value for next time.
Another important setting is Independent Layer On. Set it to No if you want to be able to control object
visibility by turning layers on and off.
The ambient settings you configured at the drawing level are available at the feature level in case you
want to override them.
On the Ambient Settings tab, you see an arrow in the Child Override column next to any setting that is
changed for one or more features (objects) in the drawing. You can cancel the override by clicking the
arrow, and you can click the lock icon to lock any setting and prevent overrides at the feature level.

Use Ambient Settings to cancel style overrides.
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After configuring the drawing settings, you should work down through Point, Surface, and other features
in the Settings tree, right-clicking each feature and selecting Edit Feature Settings. Doing this allows you to
examine the default styles for each feature and its labels, the feature name format, and other settings that
you may want to modify.
For more information about AutoCAD Civil 3D drawing settings, see Specifying Drawing Settings (page 79).

Creating a New Drawing
Create a new drawing using standard AutoCAD commands.
To create a new drawing

1 Click

➤ New.

2 In the Select Template dialog box, select a template on which the drawing will be based, and click Open.

Quick Reference
Menu

➤ New
Toolspace
Prospector (Master View): Drawing Templates ➤ right-click <template name> ➤ Create New Drawing
Command Line
New

Opening an Existing Drawing
Open an existing drawing using standard AutoCAD commands.
If more than one drawing is open, the name of the active drawing is displayed in boldface in the Prospector
tree.
NOTE You can change the active drawing by right-clicking a drawing name in the Prospector tree Master View
and clicking Switch To.
To open an existing drawing

1 Click

➤ Open.

2 In the Select File dialog box, browse to the folder containing the drawing, select the drawing, and click
Open.
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Quick Reference
Menu

➤ Open
Command Line
Open

Working with Drawing Data
AutoCAD Civil 3D provides many tools and features to make it easier to work with drawing data.
For information on other AutoCAD Civil 3D utilities, see Utilities (page 1791).

Specifying Locations in a Drawing
When you are prompted for a location in a drawing, you can use one of several methods to specify the
coordinates.

Select an Existing Point
Use the mouse to select an AutoCAD Civil 3D point in the active drawing.

Specify a Location in the Drawing
Enter X, Y (and Z, if prompted) coordinates at the command line, separated by a comma. Alternatively, click
a location in the drawing. You can use AutoCAD Object Snaps to select a point accurately.

Use Civil Transparent Commands
Some of the Civil transparent commands calculate point locations from angles, distances, and drawing
geometry. For more information, see Transparent Commands (page 1767).

Use the Coordinate Tracker
You can send drawing coordinate information to the command line based on cursor location and a specified
surface. For more information, see (page 1813).

Selecting Similar Objects
Use the Select Similar command to select all objects that have the same style and that are on the same layer.
To create a selection set of objects that have the same style and that are on the same layer
1 Select the first object in the selection set.
2 Right-click, and click Select Similar.

Quick Reference
Ribbon
Click <object name> tab ➤ General Tools panel ➤

➤

Select Similar
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Object Shortcut Menu
Edit menu ➤ Select Similar
Command Line
SelectSimilar

Isolating Objects
AutoCAD Civil 3D provides an easy-to-use feature for temporarily hiding and displaying selected objects in
your drawing.
Use this operation when you want to focus on individual areas of large drawings and need to display or hide
some of the objects.
Do the following:
■

Create an object selection set to hide or display.

■

Fine-tune the selection set by adding objects.

■

Save a drawing with the visibility settings you have selected.

Isolating Objects to Display
Isolate objects that you want to display in a drawing. This is preferable when you have a large drawing with
many objects and need to display only a small number of objects.
Run the Isolate Objects command either from the shortcut menu of an object or from the AutoCAD Civil
3D drawing window status bar.

Isolate Objects command on the drawing
window status bar

To isolate objects and display them in a drawing
1 Select the objects in the drawing that you want to isolate and display.
2 Right-click, and click Isolate Objects ➤ Isolate Selected Objects.
Alternatively, you can click
on the right side of the drawing window status bar, then click Isolate
Objects, and select the objects you want to isolate.
When you have isolated objects in your drawing, the light bulb in the drawing window status bar turns
red

.

3 If you want to isolate additional objects in your selection set, select one or more isolated objects, and
run the Isolate Objects command again.
Alternatively, you can click the red light bulb
Additional Objects.
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in the drawing window status bar and click Isolate

When you end the object isolation, as described in Ending Object Isolation in a Drawing (page 136), all
objects are displayed.

Quick Reference
Ribbon
Click <object name> tab ➤ General Tools panel ➤ Isolate Objects
Command Line
IsolateObjects

Isolating Objects to Hide
Isolate objects that you want to hide in a drawing. This is preferable when you want to display a large number
of objects and hide only a few of them.
To isolate objects and hide them in a drawing
1 Select the objects in the drawing that you want to hide.
2 Right-click, and click Isolate Objects ➤ Hide Selected Objects.
The objects you selected are now hidden in the drawing.
Alternatively, you can click the light bulb

in the drawing window status bar and click Hide Objects.

NOTE After isolating and hiding objects multiple times, it may be difficult to know whether any objects are hidden,
or whether all objects are displayed in the drawing. When you have isolated objects in your drawing, the light
bulb on the right side of the drawing window status bar is displayed in red

. When all objects are displayed

and none are isolated or hidden, the light bulb is displayed in yellow
. Alternatively, to ascertain that no objects
are hidden, select an object in the drawing, right-click, and click Isolate Objects. If the End Object Isolation
command is unavailable, all objects are displayed. If the shortcut menu command End Object Isolation is active,
there are hidden objects in the drawing. To display all objects, see Ending Object Isolation in a Drawing (page
136).

Quick Reference
Ribbon
Click <object name> tab ➤ General Tools panel ➤ Hide Objects
Command Line
HideObjects
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Ending Object Isolation in a Drawing
End the object isolation in a drawing and display all hidden objects.
To end object isolation in a drawing and display all hidden objects
1 Select an object in the drawing.
2 Right-click and click Isolate Objects ➤ End Object Isolation.
Alternatively, click

on the right side of the drawing window status bar. Click End Object Isolation.

NOTE If no objects have been isolated, the End Object Isolation command is unavailable and the light bulb in
the drawing window status bar is displayed in yellow

. In that case, no further action is necessary.

Quick Reference
Ribbon
Click <object name> tab ➤ General Tools panel ➤ End Isolation
Command Line
UnisolateObjects

Saving Isolated Objects
Save a drawing in which some objects are isolated for viewing while others are hidden. The next time you
open the drawing, it is displayed with the isolation settings you defined.
For example, you could save a specific view setting to distribute the file to a contractor who needs to see
only a specific part of the drawing. You could also save a specific view setting in a drawing that is used as
an external reference within another drawing.
To save a drawing with isolated objects, create the appropriate object selection set as described in Isolating
Objects to Display (page 134) and Isolating Objects to Hide (page 135). Save the drawing. The isolation settings
are saved in the drawing and are displayed accordingly when you reopen the drawing.
NOTE If you want to distribute a drawing with isolated objects, make sure that you and the recipient of the
drawing are working with the same version of AutoCAD Civil 3D. A recipient who is working with an earlier version
of AutoCAD Civil 3D, AutoCAD, or Object Enabler is not able to display the hidden objects. In this case, end the
object isolation before saving and distributing the drawing.

Isolating Objects in External References
When you are working with external references, you can hide and isolate objects. Consider the following
points:
■

You can isolate an external reference within a host drawing as a whole by selecting it and isolating at as
described in Isolating Objects to Display (page 134).

■

You can isolate individual objects within an external reference by opening the external reference, isolating
and hiding objects as needed, saving the external reference drawing, and then reloading the external
reference.
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■

You cannot isolate or hide objects in an external reference while editing it with REFEDIT in the host
drawing. You need to use XOPEN and save the desired Hide/Isolate settings within the external reference.

■

You cannot display hidden objects in an external reference while editing it with REFEDIT in the host
drawing. You need to use XOPEN and save the desired Hide/Isolate settings within the external reference.

Consistent Editing Methods
Object editing in AutoCAD Civil 3D uses an approach that is consistent for all objects. The main editing
tools are described here.

Item View
When you click an object or an object collection on the Prospector tab, for example, Points or Alignments,
an item view appears. An item view can be either a list view or a graphical view, depending on the object
selected.
The item view presents a table in which you can review and edit data for each object in the selected collection.
For example, if you select a point group, the item view table includes a row for each point in the group.

Item view showing a group of points

Grips
When you select an object in the drawing, grips appear on the object. You can use these grips to click and
drag the object to a new location.
For example, when editing alignments, you can use grips to move points of intersection or points of line-arc
tangency.

Alignment grips for manual editing
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When you use a grip to drag a label object to a new location, a round reset grip appears. You can click this
round grip to return the label to its original location. If there are multiple leader lines, click the round grip
once to restore the leader to its orignal state. Click the round grip twice to restore a dragged label to its
undragged state.

Use round grip to to restore label leader or to reset label

Panorama Window
Some object types, such as alignments and profiles, use the Panorama window to display a table of entities
that make up that object.
The Panorama window is a floating, dockable window that you can keep open as you work. It can include
several tables, called vistas, on different tabs. Panorama data shown in black text can be edited; data shown
in gray text cannot be edited.

Panorama window showing an alignment

Property Editors
When you right-click any object on the Prospector tab, and then click Properties, you can view all the
AutoCAD Civil 3D properties of that object, and edit some of them.
These properties typically include the styles, labels, related objects, and some structural details of the current
object.
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Properties editor showing surface properties

AutoCAD Properties Editor
When you right-click an object in the drawing, and then click Properties, the AutoCAD Properties dialog
box is displayed.
You can use this dialog box to review and edit AutoCAD properties, such as the layer on which the object
is drawn. You can view the style assigned to the object, and can also change it here. You can also edit an
object style on the Settings tab of Toolspace. Right-click the object style. Click Edit to open the <feature>
Style dialog box.

Editing AutoCAD properties for a pipe label
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Tracking Stations in Alignments, Profiles, and Sections
The Station Tracker provides visual cues to help you locate the stations that match your cursor position
when working with alignments, profiles and sections.
■

When the cursor is above a horizontal alignment, and one or more profile views for the same horizontal
alignment are in the drawing, a temporary line is drawn in each profile view at the station defined by
the orthogonal projection of the cursor onto the horizontal alignment. The temporary line is drawn to
the full height of the profile view, and moves as the cursor moves.

■

When the cursor is within a profile view, a temporary line is drawn orthogonal to the horizontal alignment
at the cursor's station. The line extends 200 world distance units to the left and right sides of the horizontal
alignment. As the cursor's position changes in the profile view, the temporary line's position is redrawn
at the new station location.

■

When the cursor is within a section view, a temporary line is drawn orthogonal to the horizontal alignment
at the station of the cross-section view. The line extends 200 world distance units to the left and right
sides of the horizontal alignment. Additionally, a vertical line is drawn in each associated profile view.
The vertical line is drawn at the station of the section view.

This setting is controlled per drawing.
For information on the use of the similar station tracker utility in corridor section views, see Tracking Corridor
Sections at Stations (page 1521).
To display the Station Tracker in the current viewport
➤

Click Analyze tab ➤ Inquiry panel ➤ Station Tracker drop-down ➤ Current Viewport

To display the Station Tracker in all viewports
➤

Click Analyze tab ➤ Inquiry panel ➤ Station Tracker drop-down ➤ All Viewports

To turn off the display of the Station Tracker
➤

Click Analyze tab ➤ Inquiry panel ➤ Station Tracker drop-down ➤ Off

.

Quick Reference
Ribbon
Analyze tab ➤ Inquiry panel ➤ Station Tracker drop-down ➤ Current Viewport
Analyze tab ➤ Inquiry panel ➤ Station Tracker drop-down ➤ All Viewports
Analyze tab ➤ Inquiry panel ➤ Station Tracker drop-down ➤ Off
Command Line
ShowDrawingTips
ShowDrawingTipsFull
HideDrawingTips
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AutoCAD Civil 3D 2011 Drawing Compatibility
The DWG file format changes from time to time, as newer technology or improvements are incorporated.
In general, newer product versions can always open all older DWG file format versions. However, when a
new DWG file format is introduced, prior versions will not be able to open it. For example, drawings in 2010
DWG format (which is a new file format) cannot be opened in AutoCAD Civil 3D 2009.
DWG file format type Created in which version(s)? Can be opened only by which versions?
2010

2010

2010

2007

2007, 2008, 2009

2007, 2008, 2009, 2010

2004

2004, 2005, 2006

2004, 2005, 2006, 2007, 2008, 2009,
2010

AECC Object Compatibility (Civil 3D)
■

In AutoCAD Civil 3D, the AECC objects in each release are not backward compatible. A drawing that is
created and saved in AutoCAD Civil 3D 2009 (DWG file format 2007) can be opened in AutoCAD Civil
3D 2008, but all AEC objects (points, alignments, surface, assemblies, corridors, grading, pipes) are
displayed as proxy objects, and all AutoCAD Civil 3D commands are disabled.

■

You cannot edit the proxy object or make changes to the design.

■

If you need to edit objects in a previous release of AutoCAD Civil 3D, your only option is to export the
Civil objects to a LandXML file, then import the LandXML data into the previous version. For more
information, see Supported LandXML Data for Drawing Import and Export (page 1876).

Country Kits
Autodesk provides country kits that make AutoCAD Civil 3D more applicable to local standards in many
places around the world. Each year these country kits are updated to the new formats and enhanced by new
features. Many country kits are available on the AutoCAD Civil 3D DVD, and others are provided at
www.autodesk.com/civil3d-countrykits. You should not have to do anything to migrate a country kit, except
if you derive company or project standards from the country kit. Install the new country kit and read the
documentation to learn about changes and additions and to determine how to apply the latest version.
Country kits are installed using the Content Pack mechanism. For more information about Content Packs,
see “What are Content Packs?” in the installation guide.

Compatibility of Civil 3D Drawings with AutoCAD and Other Software
Choose one of the following options to bring your AutoCAD Civil 3D 2011 drawing to AutoCAD or other
programs:
■

Save (AutoCAD Civil 3D 2011 to AutoCAD or other Autodesk products) If you save a drawing in AutoCAD
Civil 3D 2011 and open it in AutoCAD, all AutoCAD Civil 3D objects, are displayed as proxy objects. If
PROXYGRAPHICS was set to 1 at the time you saved the drawing in AutoCAD Civil 3D and PROXYSHOW
is set to 1 at the time you open the drawing in AutoCAD, the proxy objects display as graphic images
(you see your design correctly). If PROXYGRAPHICS and/or PROXYSHOW are not set to 1, you might
see only a bounding box, or the proxy may not be displayed.

■

Save with Object Enabler (AutoCAD Civil 3D to AutoCAD or other Autodesk products) If you have
installed the AutoCAD Civil 3D object enabler, additional information, such as surface statistics, corridor
and pipe network information is available to you in the AutoCAD property palette.

■

Export to AutoCAD - This command converts all AutoCAD Civil 3D objects (points, alignments, labels,
corridors) to plain AutoCAD objects (for example, blocks, lines, arcs, text) in order to best match the
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AutoCAD Civil 3D display at the time you export to AutoCAD. It is important to note that civil object
intelligence is not retained and is not displayed when you re-open the drawing in AutoCAD Civil 3D.
■

Export to other software - Export the AutoCAD Civil 3D design to LandXML and use a third party
application to import the LandXML.

■

AutoCAD Civil 3D Object Enabler - Installing the Object Enabler with another Autodesk product allows
you to see the AutoCAD Civil 3D objects regardless of the drawing settings. You can query the properties
of theAutoCAD Civil 3D objects and obtain extended information, but you cannot edit the objects.

There are other specific converters such as Bentley MX GENIO Extension, France PISTE Extension, German
ISYBAU, OKSTRA, UK Microdrainage
NOTE In situations where the previously suggested methods for converting files does not work, use the Export
to AutoCAD command and then save as DXF. The 3rd party software may be able to use the 2D or 3D graphical
and text information to construct a model.

Drawing Command Reference
You can use commands to quickly access drawing functionality.
Command

Description

EditDrawingSettings

Displays the Drawing Settings dialog box (page 130)

HideDrawingTips

Turns off the display of the Station Tracker (page 140)

HideObjects

Selects objects to hide in a drawing (page 135)

IsolateObjects

Selects objects to display in a drawing (page 134)

New

Creates a new drawing (page 132)

Open

Opens an existing drawing (page 132)

SelectSimilar

Selects all objects that have the same style and that
are on the same layer (page 133)

ShowDrawingTips

Displays the Station Tracker in the current viewport
(page 140)

ShowDrawingTipsFull

Displays the Station Tracker in all viewports (page
140)

UnisolateObjects

Ends object isolation in a drawing and displays all
hidden objects (page 136)
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Project Management

7

AutoCAD Civil 3D offers a range of options for managing engineering projects. Once you understand these options, you
can determine the best data structure for your projects.
For information on recommended workflows for project management, see Project Management Workflow (page 24).

Understanding Project Management
Depending on project complexity, your project management system can range from a few drawings in a
folder to large database with shared objects and security controls.
When deciding on a structure to use for managing your projects, consider these factors:
■

The number and complexity of drawings

■

The size of the project team and number of people requiring access to the files

■

The relative need for ease of use versus data security

For more information on project management options and the decision-making process, see Project
Management in the AutoCAD Civil 3D Best Practices Guide.

Object Sharing
Sharing design objects such as surfaces and alignments across drawings can provide major savings in project
time lines, if done correctly.
Three main methods are available for sharing data within a project. These are also known as data reference
types:
■

External references (xrefs), in which the contents of one drawing (DWG) is imported into another.

■

Data shortcuts between DWGs

■

Object references in Autodesk Vault

For a detailed description of each method, including advantages, limitations, and best practices, see Project
Management in the AutoCAD Civil 3D Best Practices Guide.
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A best practice common to all project structures is to organize individual design objects such as alignments
and surfaces in separate drawings. These objects are referenced into base drawings during the design process.
Complete engineering plans and final production drawings are prepared with a combination of object
references and drawing references.

Project Management on the Prospector Tree
Projects can be displayed and managed from collections on the Prospector tree.

Prospector collections for projects

The figure shows the collections for a Vault project named Trio and a data shortcut project named Arc. Both
project types are created from the default project template. As a result, they have identical collections of
surfaces, alignments, and other objects that can be referenced into multiple drawings.
You can store multiple projects in the same working folder. The default location of the working folder for
data shortcuts projects is C:\Civil 3D Projects, and for Vault projects is My Documents\Vault (Microsoft
Windows XP), or Documents\Vault (Microsoft Vista).
Several Vault projects can be displayed in the Projects collection. For data shortcut projects, you switch from
one to another by changing the data shortcuts folder.
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Most commands for managing projects are accessible by right-clicking specific objects in the project collections
on the Prospector tree.
See also:
■

Using Data Shortcuts (page 145)

■

Using Vault (page 158)

Transition from Land Desktop
Compared to the standard format used in AutoCAD Land Desktop, project structure within AutoCAD Civil
3D can be customized to suit your requirements.
AutoCAD Civil 3D includes an Import Data From Land Desktop command. This command uses the following
dialog box, which enables you to selectively bring objects into new drawings for use in AutoCAD Civil 3D.
For more information, see Using the Import Data From Land Desktop Command.

The recommended use of this Import function is to bring individual surfaces, alignments, or pipe runs into
new drawings for use in AutoCAD Civil 3D projects.

Using Data Shortcuts
This section explains the concepts and procedures for managing data shortcuts.
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Using data shortcuts involves two main processes:
■

Create data shortcuts from their source drawings.

■

Create data references in consumer drawings to source objects in source drawings.

Data shortcuts can be used for surfaces, alignments, profiles, pipe networks, and view frame groups.
If you create a reference to a profile data shortcut, a data shortcut to the parent alignment is also created.

Relationship Between Shortcuts and Data References
A data shortcut provides a direct path to the location of a shareable source object, either a surface, alignment,
profile, pipe network, or view frame group. In a single operation, you can create data shortcuts for multiple
objects in a source drawing. The data shortcut is used only for the creation of data references.
A data reference is a read-only copy of a source object, inserted into another drawing, often called a consumer
drawing. From the Prospector tab, you can select a shortcut for an object and create a reference to that object
in the active drawing. The data reference maintains an active link to the source object in the source drawing,
without relying on the data shortcut.
NOTE The term ‘project’ is used here for ease of reference, and to explain a sample data structure. Formal projects
and particular folder structures are not required with data shortcuts and references, but some form of structure
usually helps to keep related data organized.
On the Toolspace Prospector tab, the Data Shortcuts node displays the path to the active project, where data
shortcuts are stored. These data shortcuts can be created from any drawings associated with the active project.
The figure shows how the Data Shortcuts node appears if the active project is Arc.

Shortcut folders on the Prospector tree for sample
project Arc

If you change the active project, the new project name appears on the Data Shortcuts node, and the subfolders
contain only the shortcuts in the new active project. A particular consumer drawing can contain data
references from multiple projects.

Data Reference Attributes
The reference object has read-only geometry, but the user can apply a local object style, apply custom
annotation, do limited analysis, and access the source object's properties. The reference object takes up less
file space when the consumer drawing is saved. If the source object is edited, the synchronization process
ensures that changes are reflected in the reference object. Synchronization occurs when the consumer
drawing is opened, and can also be done manually by a user. You can promote a data reference to an
independent object that can be edited; after promotion it is no longer updated from its original source object.
Data Shortcut Best Practices

Project Setup
This section explains how to organize the data for a new project, including some configuration options to
consider.
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Setting a New Working Folder
Set a new working folder as the location to store data shortcut projects.
The default working folder for data shortcut projects is C:\Civil 3D Projects. The default working folder is
also used for Autodesk Vault projects and local (non-Vault) Survey projects.
If you work with Autodesk Vault, local Survey, and data shortcut projects, you should have separate working
folders for each project type, for ease of management.
To set a new working folder
1 In Toolspace, on the Prospector tab, right-click Data Shortcuts ➤ Set Working Folder.
2 Navigate to the desired folder and select it.

Quick Reference
Ribbon
Click Manage tab ➤ Data Shortcuts panel ➤ Set Working Folder
Command Line
SetWorkingFolder

Creating a Data Shortcut Project Template
Create a new template if the sample template is not suitable.
To create your own project template, copy the default template, _Sample Project and save it with a new
name. To maintain the automatic storage of new data shortcut XML files, do not change the _Shortcuts
folder and its subfolders. Your new project template appears on the list of templates when you create a new
data shortcut folder.
To create a new template for data shortcut projects
1 Navigate to the folder C:\Civil 3D Project Templates.
2 Copy the folder _Sample Project, then paste it in the same location and rename it. This is your new
template.
3 Open your new template and review the structure of folders and subfolders.
4 Do not change the top-level folder, _Shortcuts, or any folders inside it, but feel free to change the names
of other folders and their hierarchical structure.

Creating a New Shortcuts Folder
Create a new folder for storing a set of related project drawings and data shortcuts.
Create a folder name, which should reflect the project name, and specify whether to use a project template
to organize your data.
The figures show the structure created by the default project template.
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Shortcut project template: the Prospector tree
icons

Shortcut project template:
the working folder

Using a project template is a best practice that you will appreciate as your collection of projects and data
expands.
To create a new data shortcut folder
1 In Toolspace, on the Prospector tab, right-click Data Shortcuts ➤ New Data Shortcuts Folder.
2 In the New Data Shortcut Folder dialog box, specify a name, and optionally a text description of the
project folder.
3 Optionally, select Use Project Template, browse to another location for the project template folder, and
click the name of a project template.
4 Click OK. The new project folder is created in the working folder.

Quick Reference
Ribbon
Click Manage tab ➤ Data Shortcuts panel ➤ New Shortcuts Folder
Command Line
NewShortcutsFolder

Setting the Data Shortcuts Folder
Specify the project path for data shortcuts.
The path to the current data shortcuts folder (also known as the project folder) is specified on the Data
Shortcuts node in Toolspace, on the Prospector tab.
The project folder typically contains both the data shortcuts and the source objects for data references.
Data references that you create in the active drawing come from the active project folder.
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Setting or changing the data shortcuts folder reloads the shortcuts into all drawings in that folder. You can
reload the shortcuts to apply changes made in the Data Shortcut Editor window. See Editing Data Shortcuts
(page 157).
NOTE You can override the Data Shortcuts working folder by creating a Windows environment variable named
DSSYSVAR. This may be useful in situations where multiple users share a project, and the project directory is in
different locations on each user’s machine.
To set the data shortcuts folder
1 In Toolspace, on the Prospector tab, right-click Data Shortcuts and click Set Data Shortcuts Folder.
2 In the Set Data Shortcuts dialog box, click the name of the project you want to work with.
3 Check that the new project path is displayed on the Data Shortcuts node on the Prospector tab.

Quick Reference
Ribbon
Click Manage tab ➤ Data Shortcuts panel ➤ Set Shortcuts Folder
Command Line
SetShortcutsFolder
Toolspace Data Shortcut Collection
Prospector tab ➤ Data Shortcuts ➤ Set Data Shortcuts Folder
Dialog Box
Set Data Shortcuts Folder (page 2459)

Setting the Project Search Path
When a drawing is opened, data shortcuts to projects are resolved based on project information stored in
the current user’s (based on Windows login) ShortcutFolders.xml file, which contains working folders for the
project. This file should not be edited manually, as it is maintained by the system.
If the project is not found in this file, additional search paths can be provided in the Project Files Search
Path, defined on the Files tab of the Options dialog box. This may be useful in situations where multiple
users on different machines want to share data across a network. In this case, shortcut projects can be placed
in a server location, and search paths defined on each client machine to point to that location.
To define the project search paths

1 Click

➤ Options.

2 In the Options Dialog, select the Files tab.
3 Select the Project Files Search Path item, and click Add.
4 Select the newly added project, and click Add.
5 Enter the search path for the data shortcuts project. The path should be in Universal Naming Convention
(UNC) format.
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6 Click OK.

Associating a Drawing with a Data Shortcut Project
Make a data shortcut project the default for the current drawing.
NOTE This procedure explicitly creates an association. If the current drawing is not associated with a project, and
a data reference is inserted, an association is created implicitly.
To associate a data shortcut project with the current drawing
1 Open the drawing for which you want to set the default data shortcuts project.
2 In Toolspace, on the Prospector tab, right-click Data Shortcuts and click Associate Project to Current
Drawing.
3 In the Associate Project to Current Drawing dialog box, select the project to associate in the Select
Project drop-down.
NOTE To remove the associated project, set the Select Project dropdown to None.
4 Click OK. The project becomes the default data shortcut project for the drawing, and appears under
the drawing’s Data Shortcuts node in the Prospector.

Quick Reference
Toolspace Data Shortcut Collection
Prospector tab ➤ right-click Data Shortcuts ➤ Associate Project to Current Drawing
Command Line
AssociateShortcutProject
Dialog Box
Associate Project to Current Drawing Dialog Box (page 2447)

Associating Multiple Drawings with a Data Shortcut Project
Associate a data shortcuts project with all the drawings in a folder.
To associate a data shortcut project with the multiple drawings
1 In Toolspace, on the Prospector tab, right-click Data Shortcuts and click Associate Project to Multiple
Drawings.
2 In the Associate Project to Multiple Drawings dialog box, select the project to associate in the Select
Project dropdown.
NOTE To remove the associated project, set the Select Project dropdown to None.
3 Click OK. In the Browse for Folder dialog box, navigate to the folder on the filesystem that contains
the drawings to associate with the project.
4 Click OK. The project is associated with all drawings contained in the folder, and appears in each
drawing’s Data Shortcuts tree in the Prospector.
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Quick Reference
Toolspace Data Shortcut Collection
Prospector tab ➤ right-click Data Shortcuts ➤ Associate Project to Multiple Drawing
Command Line
AssociateProjectToDrawings
Dialog Box
Associate Project to Multiple Drawings Dialog Box (page 2447)

Creating Data Shortcuts
Create data shortcuts from the active drawing.
Data shortcuts are stored in the _Shortcuts folder for the active project and used to create data references to
the source objects in other drawings.
Each data shortcut is stored in a separate XML file.
NOTE The system will not allow you to create multiple shortcuts for a given object or to create a data shortcut
to a reference object from another drawing.
To create data shortcuts
1 In Toolspace, on the Prospector tab, right-click Data Shortcuts ➤ Create Data Shortcuts.
2 In the Create Data Shortcuts dialog box, click any objects to be referenced in other drawings, and then
click OK.

Quick Reference
Ribbon
Click Manage tab ➤ Data Shortcuts panel ➤ Create Data Shortcuts
Toolspace Data Shortcut Collection
Prospector tab ➤ Data Shortcuts ➤ Create Data Shortcuts
Menu
General ➤ Data Shortcuts ➤ Create Data Shortcuts
Command Line
CreateDataShortcuts
Dialog Box
Create Data Shortcuts (page 2451)

Referencing a Project Object
Import a reference object into the active drawing.
A project object can be referenced into the active drawing, which is called the consumer drawing.
Before referencing a project object, the current drawing must be saved.
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Only one copy of a reference object can be imported into a consumer drawing. If a reference copy exists,
the referencing menu option is not available.
Objects can be referenced only from the active project, which is listed in Toolspace, on the Prospector tab.
See also:
■

Setting the Data Shortcuts Folder (page 148)

To reference a data shortcut
1 In Toolspace, on the Prospector tab, expand the Data Shortcuts collection to find the object you want
to reference.
2 Right-click the object. Click Create Reference. A copy of the object is inserted into the active drawing.

Quick Reference
Toolspace Data Shortcut Collection
Prospector tab ➤ Data Shortcuts, Right-click object name ➤ Create Reference

Removing a Data Shortcut
Remove a data shortcut to make it unavailable for future data references.
You can remove a data shortcut from the Data Shortcuts collection in Toolspace, on the Prospector tab.
Doing this does not remove any data references to the source object that exist in drawings, but it prevents
anyone from creating more references to the object.
To remove a data shortcut
1 In Toolspace, on the Prospector tab, expand the Data Shortcuts collection to find the shortcut you want
to remove.
2 Right-click the object and click Remove.

Enabling and Disabling the Data Shortcuts Node
Control access to the use of data shortcuts.
You can remove the Data Shortcuts node from the Prospector tab of Toolspace. This can be useful if you
want to prevent the use of data shortcuts.
Use the ShortCutNode command to either hide (disable) or show (enable) the Data Shortcuts node.
To control access to the Data Shortcuts node
1 On the command line, enter shortcutnode.
2 Set the value to 0 to disable the Data Shortcuts node, or 1 to enable the node.

Synchronizing References
Synchronizing a data reference brings in any changes made to its source object.
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When a drawing contains references to data shortcuts, the
the window:

icon is displayed at the bottom-right side of

Data references are synchronized automatically when the drawing is opened. Otherwise, flags appear in the
Prospector tree and the status bar of the drawing window when a reference object is out of date.

When references become out of date with the data shortcuts, the

icon displays a message prompting you

to synchronize the references. Additionally, in the Prospector tree, the
objects that need to be synchronized.

icon is displayed next to reference

To synchronize a reference object
1 In Toolspace, on the Prospector tab, expand the drawing node. Expand the object collection (for example,
Surfaces).
2 Right-click the out-of-date reference object. Click Synchronize.
NOTE The Synchronize menu item is displayed only for reference objects that are out of date.

Quick Reference
Ribbon
Click Manage tab ➤ Data Shortcuts panel ➤ Synchronize References
Toolspace Shortcut Collection
Prospector tab: <drawing-name> ➤ <object-collection> ➤ Right-click <object-name> Synchronize
Command Line
SynchronizeReferences
Drawing
Right-click

➤ Synchronize

Saving a Data Shortcut Project to Vault
Copy an entire project to a new project in Autodesk Vault, preserving all object references.
You can use the Add to New Vault Project command on the Data Shortcuts node of the Toolspace Prospector
tab to copy a project to Vault. For an alternative method, see Importing a Project (page 175).

Usage Guidelines
■

Before using this command, you must be logged in to Vault, and the project you want to add to Vault
must appear on the Prospector Data Shortcuts node as the current project.

■

As a best practice, put all project drawings and files within a project folder, using a standard template.
The structure of folders will be replicated in Vault, including the paths to all source drawings.
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■

The name you assign to the Vault project cannot be the same as the data shortcut project folder name.

■

After being added to Vault, the data shortcut project remains in place and is usable.

To copy a project to Autodesk Vault
1 On the Toolspace Prospector tab, right-click Data Shortcuts ➤ Add To New Vault Project.
2 In the New Project dialog box, enter a project name, and optionally a Description. This project name
cannot be identical to the data shortcut project folder name.
3 Click OK. The Vault project is created, and appears on the Projects node on the Prospector tab.

Quick Reference
Toolspace
Right-click Data Shortcuts ➤ Add To New Vault Project

Promoting References
Promote references to independent objects.
A promoted reference becomes an independent object, and is no longer automatically updated if the original
source is edited.
To promote a reference
1 In Toolspace, on the Prospector tab, expand the Data Shortcuts collection to see the data shortcut of
interest.
2 Right-click the reference object and then click Promote.
To promote all references in a drawing
1 Manage tab ➤ Data Shortcuts panel ➤ Promote All Data References

.

2 In the Promote All Data References dialog box, click Promote All Referenced Objects Into The Current
File.

Quick Reference
Ribbon
Single object: Select the reference object. Click ➤ Name tab ➤ Modify panel ➤ Promote Data Reference
All objects in drawing: Click Manage tab ➤ Data Shortcuts panel ➤ Promote All Data References
Menu
Click General menu ➤ Data Shortcuts ➤ Promote All Data References
Command Line
PromoteAllReferences
PromoteReference (for surfaces, alignments, and profiles)
PromoteNetwork
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PromoteViewFrameGroup

Validating Data Shortcuts
Data shortcuts can become invalid if changes occur to the names or locations of drawings or reference
objects.
When a data shortcut reference is broken, the
Toolspace, on the Prospector tab.

icon is displayed next to the invalid data reference in

Validation reloads the data references if the drawing paths have not changed. Otherwise, you must repair
broken references.
To validate data shortcuts
■

In Toolspace, on the Prospector tab, right-click Data Shortcuts ➤ Validate Data Shortcuts.
The system checks data shortcut references. If any references are broken, the Event Viewer opens and
displays details that you can use to fix the problem.

Quick Reference
Ribbon
Click Manage tab ➤ Data Shortcuts panel ➤ Validate Data Shortcuts
Command Line
ValidateShortcuts

Repairing Broken References
You can recover from minor changes such as a moved or renamed drawing.
When a data shortcut reference is broken, the
icon is displayed next to the invalid data shortcut in
Toolspace, on the Prospector tab for the host or consumer drawing.
Broken references typically occur if a source drawing has been renamed or moved to a different folder. If
you can identify the new name or location, it is quite easy to repair the references. If the source drawing
contains multiple data shortcuts, once you identify the drawing you are prompted to repair all of the
references.
To repair broken references
1 In Toolspace, on the Prospector tab, right-click the object name of the broken reference, and then click
Repair Broken References.
2 In the Choose the File dialog box, navigate to the source drawing for the referenced object, and then
click Open.
If the source drawing contains other broken references, the Additional Broken References dialog is
displayed. You can click the Repair All Broken References button, or click Cancel to repair only the
broken reference you selected.
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Quick Reference
Toolspace
Right-click broken reference object ➤ Repair Broken References
Command Line
RepairBrokenReferences

Determining the Source Drawing for a Referenced Object
You view the full path to the source drawing for a data reference object.
To view the source drawing path and name
1 In Toolspace, on the Prospector tab, select the parent node for the object. For example, if the data
reference object is a centerline alignment, click Centerline Alignments.
2 In the Item List view, scroll until the Source Drawing column is visible.

Accessing the Data Reference Source Drawing
Open the source drawing for a data reference.
This is useful if the source object requires editing.
To access a data shortcut source drawing
1 In Toolspace, on the Prospector tab, expand the Data Shortcuts collection to see the data shortcut of
interest.
2 Right-click the data shortcut, and then click Open Source Drawing.
The source drawing for the data shortcuts is displayed in a new document window.

Quick Reference
Menu
In Toolspace, on the Prospector tab, right-click Data Shortcut ➤ Open Source Drawing.

Migrating Data Shortcuts
You can update data shortcuts to the current format or move them to a different folder.
Use the stand-alone Data Shortcuts Editor to save one or more data shortcuts to a specified folder. If the
shortcuts were created with a previous version of AutoCAD Civil 3D, they will be updated to the current
format in this process.
To migrate data shortcuts
1 From the Windows desktop, click the Start menu and navigate to your list of programs.
2 Open the AutoCAD Civil 3D 2011 folder and click Data Shortcuts Editor. The editor opens in a separate
window.
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3 In the Data Shortcuts Editor window, click File menu ➤ Open Data Shortcuts Folder, and navigate to
the shortcuts folder that contains the data shortcuts you want to edit. This folder is typically inside a
named project folder.
4 In the shortcut table, display the data shortcuts you want to migrate. Display all of them by clicking
the data shortcut folder at the top of the tree, or display a subset by clicking an object type such as
Surfaces or Alignments.
5 Click File menu ➤ Save As, then specify the folder where you want to save the data shortcuts.
6 Click OK to save and update the data shortcuts.

Editing Data Shortcuts
Use the Data Shortcuts Editor for bulk operations on data shortcuts.
The Data Shortcuts Editor is a stand-alone application that you can use to edit multiple shortcut XML files
safely and efficiently. For example, if you move an entire project from one working folder to another, you
can use the Data Shortcuts Editor to update the paths to the data shortcut objects.
In the data shortcut editor, the data tree on the left shows all the data shortcuts in the selected project folder.
To select a different folder, click File menu ➤ Open Data Shortcuts Folder.
The table grid on the right shows the properties of each data shortcut. You can change the object name or
path for each shortcut, and you can specify whether to use the handle (software ID) or name of the source
object to create a match with the data shortcut.

The Data Shortcuts Editor window

Precautions
Before editing data shortcuts, ensure that no one else is currently creating or editing the same set of data
shortcuts within AutoCAD Civil 3D. Otherwise, one user can overwrite changes made by the other.
Changes made in the Data Shortcut Editor window do not take effect until shortcuts are reloaded. To reload
the shortcuts, use the procedure Setting the Data Shortcuts Folder (page 148), or close AutoCAD Civil 3D and
restart it.

Best Practices
On the Edit menu in the Data Shortcut Editor, use the Find and Replace command to quickly change text
strings in the names of data shortcuts, paths, or source drawings.
In the shortcut table, set the Use to Match column to associate data shortcuts with their source objects by
means of the source object’s name or handle, or both. The object’s handle is its unique identifier used by
the system. Users cannot change the handle, so it can be the most reliable matching attribute if an object’s
name has changed.
One situation in which you would match by name is if you delete an object, then re-create it and apply the
same name. The new object has a different handle, but if you use the match-by-name option, the old data
shortcuts will automatically reference the new object.
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See also:
■

Migrating Data Shortcuts (page 156)

To access the Data Shortcuts Editor
1 From the Windows desktop, click the Start menu and navigate to your list of programs.
2 Open the AutoCAD Civil 3D 2011 folder and click Data Shortcuts Editor. The editor opens in a separate
window.
3 In the Data Shortcuts Editor window, click File menu ➤ Open Data Shortcuts Folder, and navigate to
the project folder that contains the data shortcuts you want to edit.
The data shortcuts are displayed in a table grid.

Using Vault
Autodesk Vault is a complete document management system for drawings, project objects, and project-related
files.
Autodesk Vault provides access control and version control for all project drawings. One master copy of
each project drawing is maintained in the project database. Other team members can reference the master
copy, and they are notified when the master copy is updated.
Most project team members can access all required Vault features using the Prospector tree. However, you
will need a knowledgeable system administrator who installs the server and client Vault software, uses ADMS
Console or the Autodesk Vault administration tool to customize Vault for your purposes, and regularly
performs system administration tasks such as data backups. Most of the topics in this section are geared
toward your system administrator.
TIP Some tasks, such as managing user accounts, can be done with either the Autodesk Vault tool or ADMS
Console. When Help suggests using the Vault tool to perform a task, you can often use ADMS Console instead.
For information about installing Autodesk Vault, see the Autodesk Data Management Server Installation
Guide.
Autodesk Vault provides access control and file version control. AutoCAD Civil 3D provides commands in
the Prospector tree to create and access project drawings and shared project data.
After you have logged in to Vault, each project visible to the Vault user is displayed as a collection on the
Projects node of the Prospector tree..

158 | Chapter 7 Project Management

Project Drawings
A project contains a collection of project drawings. You can use folders to organize the drawings within a
project. A master copy of a project drawing is maintained in a specified project within a Vault database, and
only one person can edit the master copy at a time. When the edited project drawing is updated in the Vault
database, a new version of the drawing is created. The icons displayed next to a drawing in the Prospector
tree indicate the status of your local copy of the drawing in relation to the master copy of the drawing in
the Vault database. For more information, see Project Item State Icons (page 160).

Project Objects and References
A project contains collections of project objects, including surfaces, alignments, profiles, pipe networks and
view frame groups, that can be shared with others. All shared project objects are listed in the project object
collections in the Prospector tree. Project members can create a read-only copy of a project object, called a
reference, in a drawing. This read-only copy of the project object’s geometry can be used to perform labeling,
design, analysis, or what-if tasks.
Multiple project members can create references to the same shared project object.

Project Points
When using Vault, project management for AutoCAD Civil 3D points is handled differently from project
management for other objects. For more information, see Working with Vault Project Points (page 187).

Project Management Commands
The project management commands that are listed on Prospector shortcut menus can vary depending upon
several factors, including the following:
■

Whether or not you have logged into Vault from the Prospector tree.

■

The state (for example, checked-in or checked-out) of the selected project item.

■

The location of the project item in the Prospector tree. For example, some drawing-related commands
are available at the Open Drawings collection level, some are available at the Projects collection level,
and some are available at both levels.

■

Whether or not the selected drawing has been saved.

■

Any circumstances that make the operation invalid for the selected item.

The user information that is defined for you on the current Vault server also affects the actions you are
permitted to perform. For example, you might have permission to get copies of project drawings, but not
create project drawings.
Vault Best Practices

Project and Drawing Items in the Prospector Tree
The Master View of the Prospector tree contains three collections related to drawings and projects: Open
Drawings, Projects, and Drawing Templates.
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NOTE To view all the collections in the Prospector tree, select Master View from the list at the top of the Prospector
tab.
■

Open Drawings. Lists open project and non-project drawings.

■

Projects. Lists the projects available to you after you have logged in to a Vault server and a Vault database.

■

Drawing Templates. Lists the available drawing templates. For more information, see Drawing Templates
(page 127).

Project Item State Icons
The project item state icons in the Prospector tree identify the state of a local project drawing in relation to
the master copy in the Vault database.
The icons are displayed next to drawings that have been added to the project, indicating the state of the
drawing on your system (your local copy) in relation to the latest version of the master copy of the drawing
in the Vault database.
An icon that is displayed next to a project object (in a project object collection, such as Surfaces or Alignments)
indicates the state of the project object’s source drawing.
The project item state icons are shown in the following table:
Icon

Meaning
If no icon is displayed, then the drawing has been added to the project,
but you do not have a local copy.
The drawing is available to be checked out, and the version of the
master copy in the Vault database matches your local copy.
The drawing is available to be checked out, but your local copy is
newer than the latest version in the Vault database. This usually means
that you changed the local copy without checking it out.
The drawing is available to be checked out, and your local copy is older
than the latest version in the Vault database.
The drawing is checked out to you, but you do not have a local copy
of the object.
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Icon

Meaning
The drawing is checked out to you, and the version of the drawing in
the Vault database matches your local copy.
The drawing is checked out to you, and your local copy is newer than
the latest version in the Vault database. This usually means that you
have changed the drawing since you checked it out.
The drawing is checked out to you, and your local copy is older than
the latest version in the Vault database.
The drawing is checked out to someone else, and you do not have a
local copy.
The drawing is checked out to someone else, and your local copy
matches the latest version in the Vault database.
The drawing is checked out to someone else, and your local copy is
newer than the latest version in the Vault database.
The drawing is checked out to someone else, and your local copy is
older than the latest version in the Vault database.

When your drawing contains a reference to a shared object, and the local copy of the source drawing becomes
out of date,
is displayed next to the drawing name in the Prospector project tree. This generally occurs
when someone adds a newer version of the project object’s source drawing to the project.

Drawing Item State Icons
The drawing item state icons in the Prospector and Settings trees identify whether an object is locked, is a
reference, or is being referenced, as shown in the following table:
Icon

Meaning
Object is locked.

Object is being referenced by another object.

Object is a reference to an object in another drawing.

Drawing Item Modifier Icons
The drawing item modifier icons in the Prospector tree identify an object that is out of date or violates
constraints, and also identifies the state of a local copy of a project object.
NOTE To display the drawing item modifier icons, click

at the top of the Prospector tab.
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The following table explains the meaning of the three individual drawing item modifier icons:
Icon

Meaning
The object is out of date or violates constraints.

The project object is more recent than the local copy.

The local copy of the project object no longer matches the project
version, which means that you have edited it.

The following table lists all combinations of the drawing item modifier icons:
Icon Displayed Object is Out of
in Drawing
Date or Violates
Constraints

Project Object is
More Recent than
Local Copy

Local Copy Has
Been Edited Relative to Project Object

No

No

No

Yes

No

No

No

Yes

No

Yes

Yes

No

No

No

Yes

Yes

No

Yes

No

Yes

Yes

Yes

Yes

Yes

NOTE Some of the above icons are displayed only in the Points list view.

The Project Collection List Views
Use the list views displayed in the Projects collection to obtain information about the drawings and shared
objects in the project.
NOTE To view the Projects collection in the Prospector tree, select Master View from the list at the top of the
Prospector tab.
Click a collection in the Prospector tree Projects collection to display a list view.
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If the selected item is a project, the following information is displayed in the list view:
■

Project name

■

Description

■

User name of the person who created the project

■

Date the project was created

If the selected item is a collection or folder containing drawing files, the following information is displayed
in the list view:
■

Name

■

Version

■

User name of the person who created this version

■

Date checked in

■

Comment

If the selected item is a collection containing shared objects, the following information is displayed in the
list view:
■

Object name

■

Source drawing name

■

Description

For more information about changing the list view display, see Customizing a List View (page 101).

Installing and Configuring Vault
The Autodesk Data Management Server Installation Guide contains detailed recommendations for configuring
your Vault installation.
A single-site configuration is recommended for most teams. The Autodesk Data Management Server (ADMS)
is installed on one system and the client component is installed on each computer that must communicate
with that server. The server stores all master copies of data files, and the clients can access the files stored
on the server. For best performance, a dedicated server is recommended for both the file store and the shared
metadata.

Vault single-site architecture
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You have flexibility within this model to choose a configuration that suits your requirements, based on
criteria such as the number of users who must share data, how your users are divided into design teams, and
the amount of project data you expect your users to generate. Refer to the Autodesk Data Management Server
Installation Guide for more details.
After Vault is installed, you can decide to create a single vault (database) or multiple vaults on the server.
User permissions apply within a single vault, and cannot be shared across vaults. For more information on
the difference between a single vault configuration and a multiple vault configuration, see Autodesk Data
Management Server Installation Guide.
Vault’s optional multi-site feature is designed to support geographically dispersed workgroups sharing vaults.
A single instance of remote SQL manages multiple servers, each with its own file store, at separate office
sites. Depending on their level of permissions, all users can see all files at all sites as if the system was a single
database.

Vault multi-site architecture

When a user checks out a file that is stored at another site, the system replicates that file at the user’s site.
As long as the file remains shared, the system remembers to update that copy with any changes. Vaults and
individual files are replicated only where they are really in use. Backup and restore operations can be managed
from any site that has all vaults enabled. For more information, see ADMS Console Help.

Project Folders
Any file (drawing or not) that is associated with a project, especially any file that would benefit from version
control, should be stored in the project. Temporary files, such as preliminary design drawings, do not need
to be stored in the project.
For ease of use, all projects should use consistent folder structure and folder names. A practical structure is
provided when you use the project template. You can easily create your own custom template if the default
version is not suitable.
NOTE In general, a user who creates a folder or project data can delete it using the Autodesk Vault tool. For this
reason, it is recommended that all new projects be created by a system administrator. This will prevent other users
from advertently deleting a project and associated files.
You do not need to create a folder for point database files or survey database. These are automatically stored
directly beneath the main project folder.
A project can also include files that are not drawings. Using the Autodesk Vault tool, create folders for such
files directly under the project folder. Possible folder names might include: Proposals, Client Correspondence,
and Contracts. You can store and access the files in non-drawing folders using the Vault tool.
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Working Folders
When you work on objects, you check associated drawings out of a vault and work with them from working
folders. The objects in a working folder are physically copied from a Vault file store. Other users can still get
read-only copies of the files, but they cannot edit them until you have checked them back in. In this way,
you maintain a single master version of each drawing.
When you check a file back into a vault, the revised version from your working folder is copied to the file
store on the server. The Vault database marks the file with the appropriate revision data and makes it available
to other users.
You can change your working folder without risk to the data in the Vault database, but you typically change
the working folder only if you need to work with projects in different Vault databases. To avoid confusion,
use a separate working folder for each Vault database.
The default working folder location is C:\Civil 3D Projects.
For more information on best practices with working folders, see Working Folder Configurations in the
AutoCAD Civil 3D Best Practices guide.

Controlling Access to Project Data
You can control who can access and edit project drawings and master copies of project objects.
To ensure a secure environment, define a separate Vault user account for each person who will be accessing
project data on the project server. Each account requires a unique user name and password. For more
information, see Creating Vault User Accounts (page 167).
Vault allows you to control access to project files at several levels: user names, groups, projects and folders.
With careful planning, you can minimize the amount of configuration required and create a flexible security
system. It is recommended that you control access to project files at the group level.
Create a different Vault group for each function performed by members of your organization. For example,
you could create a set of groups including: Surveyors, whose members would create and edit master copies
of data in a folder such as EG Surfaces; Civil Engineers, whose members would usually read (but not modify)
data in the EG Surfaces folder, and would create and edit master data in a folder such as Alignments; and
Drafters, whose members would generally read data but would not modify master copies of data. Access can
then be further restricted to individual groups or users, at the folder level.
In general, each team member should belong to only one group. To change how someone accesses project
files, move their user name from one group to another. For more information see Creating Vault Groups
(page 168).

Partitioning Project Data
You should divide your project data across multiple drawings using a strategy that both protects data integrity
and supports ease of access.
In AutoCAD Civil 3D, there is one master copy of each project object (such as a surface, alignment, profile,
or pipe network), and that master copy is stored in a source drawing that is stored in the project’s Vault
database. There are virtually no restrictions on how many project objects you can store in the same drawing,
but there are some factors you should consider.
A key determining factor in how you partition your project data is the ability of team members to create
and modify project data when they need to. Because only one person can edit a drawing at a time, placing
the master copy of every project object into the same drawing is too restrictive for a collaborative environment.
In general, spreading your project objects across many drawings makes more sense than crowding many
objects into fewer drawings.
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For each project object, create a separate drawing that contains the geometry of the project object and, if
needed, related project objects. Consider placing each surface in a separate drawing. At the very least, consider
placing a key surface, such as an existing ground surface, in its own drawing. You should avoid placing all
your project alignments in the same drawing.
The function of a drawing should match its content. If a drawing contains the master copy of a surface
object, that drawing shouldn’t also be a plan profile sheet. Keep project object geometry in its own drawing
and create separate drawings for viewing and annotating read-only copies of the geometry.
It is important to understand that a single project must contain all the data that is required for that project.
A drawing cannot contain references to more than one project at a time.
Adhering to a consistent naming convention will make the drawings that contain master copies of project
objects easy to identify. Name a drawing that contains a project surface with the same name as the surface;
name a drawing that contains a project alignment with the name of the alignment. Store project drawings
in appropriately named folders. For more information see Project Folders (page 164).
Develop procedures that minimize the number of shared project objects. Make sure that team members
understand that when adding or checking in a drawing, they should not share an object unless it is needed
by others.

Running the Autodesk Vault Tool from the Prospector Tree
You can access the Autodesk Vault tool from the Prospector tree.
You must log in to Vault from the Prospector tree before you can run the Vault tool from the Prospector
tree.
To run the Vault tool from the Prospector tree
1 In Toolspace, on the Prospector tab, right-click the Projects collection.
2 Click Autodesk Vault.
3 If the Welcome dialog box is displayed, click Log In.
4 In the Log In dialog box, enter your Vault user name.
5 Enter your password.
6 Select a Vault server.
7 Select a Vault database. Click

to list available databases.

8 Click OK.

Quick Reference
Toolspace Shortcut Menu
Prospector tab (Master View): right-click Projects collection ➤ Autodesk Vault

Running Vault from Microsoft Office Applications
The Microsoft Office add-in for Autodesk Vault enables direct access to Vault from Word, Excel or PowerPoint
documents.
However, the Office add-in is not installed by default when you install Vault.
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To install the Office add-in after Vault is installed
1 In Windows, from the Start menu, open the Control Panel. Depending on your system, the Control
Panel may be on a Settings submenu.
2 Click Add or Remove Programs, or in Vista, click Uninstall a Program.
3 In the list of programs, click Autodesk Vault.
4 Click Change/Remove, or Uninstall/Change.
5 In the Autodesk Vault Installation Wizard dialog box, click Add or Remove Features.
6 In the Select Features to Install field, select the MS Office Add-In. Click Next.
7 Click Next.
8 Click Finish.
To use Vault with a Microsoft Office application, click File menu ➤ Autodesk Vault and select one of the
Vault options.

Project Files Created in a Project Database
When an AutoCAD Civil 3D project is created, an initial set of empty or near-empty files is created in the
project database.
Data is added to these files as you add drawings and data to the project.

Project.xml
This file contains information about the project and the shared project objects. The presence of this file is
what indicates to AutoCAD Civil 3D that the folder containing this file is an AutoCAD Civil 3D project
folder. Do not delete, modify, or move this file.

PointsGeometry.db
This file contains the project’s point geometry. The points contained in the file are listed in the project’s
Points list in the Prospector tree. This file is not checked in and out directly as project drawing files are; it
is checked in and out indirectly when users use point access control commands.

PointsStatus.db
This file contains access control information about the points in PointsGeometry.mdb, including the status
(checked-in, checked-out, or protected) of individual points.

Survey.sdbx and Survey.sdxx
This file represents the project survey database. For more information, see Survey Database (page 217).

Creating Vault User Accounts
Each team member must have a user account on the project Vault server before using project management
commands.
To ensure a secure environment, define a separate Vault user account for each person who will be accessing
project data on the project server. Each account requires a unique user name and password.
NOTE Each instance of a Vault Data Management server has a separate set of user accounts. If a user requires
access to multiple servers, you must define an account for him on each server.
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Only a user with administrator privileges can add a user. When you add a new user to a server, you can
specify a role for the user, which defines how the user will access data on the server. AutoCAD Civil 3D Vault
project management supports administrator, editor, and consumer roles for user accounts.
In general, you will find managing access to project data easier to control at the group level, instead of at
the individual user level. When you create a user account, specify a role for each user that gives them the
highest level of access they require to any part of the database. For more information, see Creating Vault
Groups (page 168).
To add a new user in the Autodesk Vault administration tool
■

Click Tools ➤ Administration and then use the Security tab to add a new user.

For more information, see Add/Edit Users in Autodesk Vault help.

Creating Vault Groups
Use Vault groups to manage and control access to project files.
Use the Autodesk Vault tool to add a group to a Vault server. Only a user with administrator privileges can
add a group.
When you create a group, you specify generally how the group’s members should access project data by
assigning the group the role of data editor, which means that members of the group can add or edit data, or
data consumer, which means the group members can only read data, not edit it.
In general, a user should belong to only one group. To change someone’s access to project files, move their
user name from one group to another.
To add a group in the Vault tool, click Tools menu ➤ Administration ➤ Global Settings, and then use the
Security tab to add the group. You can also add users to a group here. For more information, see Managing
Groups in Autodesk Vault help.

Folder Permissions
With Autodesk Vault in AutoCAD Civil 3D, system administrators can extend permissions down to folders
and sub-folders in a vault.
Before setting folder permissions, you may want to manage specific Vault users, groups, or roles from the
Tools menu in the Autodesk Vault tool.
To set folder permissions
1 In the Vault tool window, expand the Vault Explorer ($) tree to the folder whose permissions you want
to set.
2 Right-click the folder. Click Properties.
3 To add a user or group to the Access Control List, in the Properties dialog box, Security tab, click Add.
4 In the Add Members dialog box, select the member(s) to add to the Access Control List. Click Add.
5 Click OK.
6 In the Properties dialog box, click OK.

Pack and Go
Use the Vault Pack and Go feature to hand off project data to someone else.
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Pack and Go resolves file dependencies for a drawing. This feature can be used to supply copies of project
files to someone. It is not intended for making copies of project files that you want to edit and then return
to the project.
For example, if your firm begins a project by doing a survey, creating the base map, and completing the
parcel layout, and then passes the drawing and associated data to a civil engineer who completes the job,
you could use Pack and Go in Autodesk Vault to assemble the information related to the drawing before
you hand it off.
For more information, see Packaging Files in Autodesk Vault help.

Working with Vault Projects
An AutoCAD Civil 3D project groups all the drawings and data for a single project in one place and controls
access to all project files.
After you log in to a Vault server and a Vault database, the Projects collection in the Prospector tree lists all
the projects that are available to you.
NOTE You must select Master View from the list at the top of the Prospector tab before you can view the Projects
collection.

Logging in to a Vault Server
Before you can create or access project data, you must log in to a Vault server and a Vault database from the
Prospector tree.
You must be an authorized user on the server before you can log in. The server and the database that you
select when you log in determines what projects you can access.
Before you log in, project management commands are not available on shortcut menus in the Prospector
tree. After you log in, the projects available in the specified server and Vault database are listed in the
Prospector tree, and applicable project management commands are displayed on the menus when you
right-click a project item in the Prospector tree.
To log in to Vault from Prospector
1 In Toolspace, on the Prospector tab, select Master View from the list at the top of the Prospector tab.
2 Right-click the Projects collection.
3 Click Log In.
4 In the Log In (page 2456) dialog box, enter your Vault user name.
5 Enter your password.
6 Select a Vault server.
7 Select a Vault database. Click

to list available databases.

8 Optionally, select Automatically Log In Next Session.
9 Click OK.
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Quick Reference
Toolspace Shortcut Menu
Prospector tab (Master View): right-click Projects collection ➤ Log In
Dialog Box
Log In Dialog Box (page 2456)

Logging Out of Vault
Logging out of Vault terminates your connection with the Vault server and the Vault database that you are
logged in to.
After you log out, you can no longer view or access project data in Prospector. When you end an AutoCAD
Civil 3D session, you are automatically logged out.
To log out of vault
1 In Toolspace, on the Prospector tab, right-click the Projects collection.
2 Click Log Out.

Quick Reference
Toolspace Shortcut Menu
Prospector tab (Master View) ➤ right-click Projects collection ➤ Log Out

Changing the Working Folder
The working folder maps your local copies of project files to the master copies of project files in the Vault
database.
The default working folder for Autodesk Vault projects is C:\Civil 3D Projects. This same default location is
also used for data shortcut projects. For ease of management, it is a best practice in most cases to use different
working folders for the two project types.
The working folder contains your local copies of files for all the projects stored in a Vault database. If all
your projects are stored in the same Vault database, you will use the same working folder for all projects. If
you work with projects that are stored in different Vault databases, you can prevent confusion by using a
different working folder for each Vault database.
In general, you should not change your working folder while you have any objects referenced or files checked
out from a Vault project. The working folder is used to determine the state of your local copies of files in
relation to the master copies in the project database.
To change the working folder
1 In Toolspace, on the Prospector tab, right-click the Projects collection.
2 Click Properties.
3 In the Properties - AutoCAD Civil 3D Projects (page 2458) dialog box, under Working Folder, click
4 In the Browse For Folder dialog box, browse to the folder and click OK.
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.

Quick Reference
Toolspace Shortcut Menu
Prospector tab (Master View): right-click Projects collection ➤ Properties
Dialog Box
Properties - AutoCAD Civil 3D Projects (page 2458)

Creating Projects
If you are logged in to Vault, you can use the Prospector tree to create a new project in the project database.
You create the project using either the default Sample Project template, or another template you have saved.
Project templates provide the capability to create a new project with a predetermined folder structure, where
each folder can also contain files of any type. The template folders are found in the AutoCAD Civil 3D Project
Templates folder on your local disk.
NOTE In general, a user who creates a folder or project data can delete it using the Autodesk Vault tool. For this
reason, it is recommended that all new projects be created by a system administrator. This will prevent other users
from inadvertently deleting a project and associated files.
To create a project
1 In Toolspace, on the Prospector tab, right-click the Projects collection.
2 Click New.
3 In the New Project (page 2457) dialog box, enter a project name.
4 If you want to create your new project from a template, select Use Project Template.
5 On the Project Template list, click the template you want to use.
6 Click OK.

Quick Reference
Toolspace Shortcut Menu
Prospector tab (Master View): right-click Projects collection ➤ New
Dialog Box
New Project Dialog Box (page 2457)

Project Administration
Your system administrator can use ADMS Console or the Autodesk Vault tool to customize Vault for your
purposes and to regularly perform project administration tasks on an on-going basis.
These tasks include the following:
■

Creating, modifying, or deleting folders in a project

■

Deleting a project

■

Modifying the state of a file, for example, checking in a file that for some reason cannot be checked in
by the person who originally checked it out
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■

Restoring a file back to a prior version

■

Backing up project files

For more information, see the ADMS Console Help and Administrative Tasks in Autodesk Vault help.

Changing the Active Project
The active project is displayed in bold type in the Prospector tree. It is the default project for the project
dialog boxes.
NOTE The active project is not displayed in the Select Projects To Display (page 2458) dialog box.
To change the active project
1 In Toolspace, on the Prospector tab, expand the Projects collection and right-click a project.
2 Click Set Active.

Quick Reference
Toolspace Shortcut Menu
Prospector tab (Master View): Projects collection ➤ right-click <project name> ➤ Set Active

Selecting Projects to Display
You can limit the number of projects that are listed in the Prospector tree.
The projects available to you are determined by the server and the database that you are logged in to. By
default, all projects available in the database are listed in the Prospector tree under the Projects collection.
Reducing the number of projects that are listed in the Prospector tree will not only reduce the amount of
data you will see, but also can reduce the time required to update the display of the tree.
You cannot turn off the display of the active project, and the name of the active project is not listed in the
dialog box.
To select projects to display
1 In Toolspace, on the Prospector tab, right-click the Projects collection.
2 Click Select Projects To Display.
3 In the Select Projects To Display (page 2458) dialog box, select the check box next to the name of any
project that you want listed in the Prospector Projects collection.
NOTE The name of the active project is not included in the list.

4 Click

to select all the projects in the list.

5 Click

to clear all the projects in the list.

6 Click OK.
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Quick Reference
Toolspace Shortcut Menu
Prospector tab (Master View): right-click Projects collection ➤ Select Projects To Display
Dialog Box
Select Projects To Display Dialog Box (page 2458)

Working When Disconnected
You can work with project files while you are disconnected from Vault.
If you are not connected to the network, in general, you can work with your local copies of project drawings
the way you normally do. However, you cannot perform project management functions (such as checking
in and checking out files), you cannot get updated versions of any project files, and you cannot create new
references to project objects while you are disconnected.
Before you disconnect, you should update your local copies of any project files by getting the latest versions
of any project files that you are working with, including the source drawings for any project objects that
your drawing references.

Deleting a Project
Delete a project from the project database using the Autodesk Vault tool.
A project can be deleted by a system administrator or by the user that created it. It is recommended that all
projects be created by a system administrator to protect projects from being inadvertently deleted by users
who are not system administrators.
To delete a project from the project database, delete the top-level project folder. You cannot delete a file
that is checked out.
After a project has been deleted from the Vault database, its name remains in the Projects collection in the
Prospector tree until you refresh the display of the tree.
After the project has been deleted from the Vault database, use Windows Explorer to delete local copies of
project files and folders from the working folder.

Converting a Project to Data Shortcuts
Change all data references from the Vault format to data shortcuts.
After getting the latest version of all files from the Vault project, use the Data Shortcut Editor to convert the
Vault project.xml file into a _Shortcuts folder. Doing this converts the Vault references into data shortcuts
between drawings.
To convert a Vault project
1 On the Windows Start menu, click Programs ➤ Autodesk ➤ AutoCAD Civil 3D 2011 ➤ Data Shortcuts
Editor.
2 In the Data Shortcuts Editor, click File menu ➤ Open Data Shortcuts Folder. In the Browse for Folder
dialog box, browse to the folder for the project that you want to convert. The default location is C:\Civil
3D Projects.
After you select the project folder, the Vault references are loaded into the table.
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3 In the Data Shortcuts Editor, click Edit menu ➤ Find and Replace. Replace each instance of $ with the
path to the local project folder (example: C:\Civil 3D Projects).
4 In the Data Shortcuts Editor, click File menu ➤ Save As, and then save the new Shortcuts folder in its
current location.
5 In the active project folder, delete the project.xml file.

Labeling Project Milestones
You can use the Vault labeling feature to identify the status of a set of project files, such as the project
milestone attained.
When a major project milestone is reached, you can label the files involved so they can be easily identified.
When you create a label, the most recently checked-in version of every file in the project is assigned that
label.
Labeling does more than just tag a set of files. If you later need to archive or retrieve the set of files, you can
do so. Labels do not include folder information; only the project files are labeled.
To create a label, in the Autodesk Vault tool, right-click a project folder and click New Label. For more
information on creating and viewing labels, see in the Autodesk Vault tool help.

Exporting a Project
Export a project to a ZIP file for storage, or to move the project to another vault.
When a project is exported, copies of the latest versions of all drawings and other documents are compressed
and saved in a ZIP archive. This archive can be reliably imported to a vault, retaining the data references
between drawings.
The export operation does not affect the original project documents. They remain in place for ongoing use.
TIP Label your project files, then export them to archive a copy of the files at a specific milestone.
See also:
■

Importing a Project (page 175)

■

Labeling Project Milestones (page 174)

To export a set of project files
1 In Toolspace, on the Prospector tab, in Master View, expand the Projects node to see the list of projects.
2 Right-click the project to export and click Export to ZIP File.
3 In the Browse for Folder dialog box, navigate to and select the folder where you want to save the ZIP
file, then click OK.
The system displays a progress bar while the files are compressed and saved.

Quick Reference
Toolspace Shortcut Menu
Prospector tab (Master View) ➤ right-click Project ➤ Export to ZIP File
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Importing a Project
You can import a Vault project or a project that uses data shortcuts.
Data shortcuts are converted to Vault references during import.
The project to be imported can be in a folder or a ZIP file. If you are importing a project that was previously
exported from a vault, it is in a ZIP file.
You cannot import a project if it has the same name as an existing project in the vault.
See also:
■

Exporting a Project (page 174)

To import a project
1 In Toolspace, on the Prospector tab, in Master View, right-click the Projects node ➤ Import From, and
click either ZIP File or Folder.
2 In the dialog box that opens (Import Project Archive or Browse for Folder, depending on project format),
navigate to and select the project container, and then click OK.
The system displays a progress bar and status messages during the import operation.

Quick Reference
Toolspace Shortcut Menu
Prospector tab (Master View) ➤ right-click Projects ➤ Import From

Managing File Status Prompts
You can control the use of prompts during file management events.
During file operations such as Check In, and Get Latest Version, prompts are available to advise you of
unsaved changes, newer versions in the vault, and other details. You can specify whether these prompts are
used always or never. You can also specify whether the default response to the prompt is Yes or No.
A new user can have all prompts displayed to guide them in file management. An experienced user can
suppress some unnecessary prompts and work more efficiently.
To manage file status prompts
1 In Toolspace, on the Prospector tab, in Master View, right-click the Projects node ➤ Manage Prompts.
2 In the Manage Prompts dialog box, review the Response and Frequency settings for each prompt, making
any required changes.

Quick Reference
Toolspace Shortcut Menu
Prospector tab (Master View) ➤ right-click Projects ➤ Manage Prompts
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Migrating Old Civil 3D Projects
You can easily migrate projects to AutoCAD Civil 3D 2011 from previous versions. Projects must be migrated
to AutoCAD Civil 3D 2011 before they can be opened.
You must log in to Vault from the Prospector tree before the project migration command is available. For
projects created in AutoCAD Civil 3D 2007 to 2010, both the project and associated Survey databases
(including equipment and figure databases) must be migrated before they can be opened. Projects containing

databases requiring migration are indicated with the out of date icon

.

To migrate a Civil 3D project from AutoCAD Civil 3D 2007-2010
1 In Toolspace, on the Prospector tab, right-click the Projects collection.
2 Projects that require migration are indicated with the out of data icon. Right-click on a project that
requires migration, and select Migrate.
3 A warning dialog displays and indicates that migrated projects are not backwards-compatible with
previous versions of AutoCAD Civil 3D 2011. Click Yes to continue.
The selected project and associated databases are checked out, migrated, then checked back in with an
incremented version.
TIP All projects requiring migration can be migrated at once by right-clicking on the Projects collection and
selecting Migrate.
To migrate a Civil 3D project from AutoCAD Civil 3D 2006 or earlier
1 In Toolspace, on the Prospector tab, right-click the Projects collection.
2 Click Migrate Pre-Civil 3D 2007 Project.
3 In the Select Civil 3D Project Folder To Migrate dialog box, browse to the project folder to be migrated.
4 Select the folder that contains the project and click Open.
The new project is created on the Vault server in the database that you are logged in to.

Quick Reference
Toolspace Shortcut Menu
Prospector tab (Master View) ➤ right-click Projects collection ➤ Migrate Pre-Civil 3D 2007 Project

Working with Vault Project Drawings
Use drawings to create and access project data.
There is a tight association between a project object, such as a surface, and its source drawing, which is the
drawing that contains the object. To create a project object, add the object’s source drawing to a project and
specify that you want to share the object with others. You can edit a project object by checking out the
source drawing, making the change, and checking the source drawing back in.
You can store any project drawing in the project database. You will find it easier to keep your project organized
if you use more than one folder to store your project drawings. For more information, see Project Folders
(page 164).
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The Drawings collection in the Prospector tree is not a folder and does not map to a folder in either the
project database or the working folder. However, the folders under the Drawings collection map directly to
folders in the project database and the working folder.

Adding a Drawing to a Project
You can add a drawing to a project to make the drawing available to others, to place it under version control,
and to create project objects from objects in the drawing.
TIP Before adding a drawing to a project, save the drawing in the most appropriate folder in the project working
folder. Doing this ensures that Vault can determine where to save the drawing in the database.
While adding a drawing to a project, specify which objects (if any) in the drawing you want to share with
others. Those objects are then added to the appropriate Prospector project object collection (such as Surfaces,
Alignments, or Pipe Networks) and can be referenced by others.
NOTE You should only share objects that are required by others. If you are unsure whether an object should be
shared, do not share it. You can share it later using the Check Out and Check In commands.
While adding a drawing to a project, you can specify that associated files, including surface data files, image
files, and xrefs, are added to the project. You can also specify whether a .dwf file is created and added to the
project for display in drawing item views and the Autodesk Vault tool.
NOTE Previews from .dwf files are not displayed in 64-bit versions of Vault and AutoCAD Civil 3D.
If a drawing containing a surface is added to a project, and the surface references external data files, a folder
is created under the drawing to hold those files. The files are placed in the folder, and the surface definition
in the drawing is updated to reflect the new (relative) location of the files.
An open drawing must be saved before you can add it to a project. A copy of the drawing is created in your
local working folder and the master copy is added to the project.
To add a drawing to a project
1 In Toolspace, on the Prospector tab, expand the Open Drawings collection.
2 Right-click the drawing you want to add to the project.
3 Click Add to Project.
4 On the Select A Project (page 2446) page of the Add To Project wizard, select the project to which you
want to add the drawing.
5 Click Next.
6 On the Select A Drawing Location (page 2446) page of the Add To Project wizard, specify the location of
the drawing within the project. Click

to create a new folder.

7 Click Next.
8 On the Drawing File Dependencies (page 2446) page of the Add To Project wizard, specify file dependencies
and .dwf creation options.
NOTE Previews from .dwf files are not displayed in the 64-bit versions of Vault and AutoCAD Civil 3D.
9 Click Next.
10 In the Share Data (page 2447) page of the Add To Project wizard, specify which objects in the drawing
you want to share with others.
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NOTE If the drawing does not contain objects that can be shared, this page is not displayed.
11 Click Finish.

Quick Reference
Toolspace Shortcut Menu
Prospector tab: Open Drawings collection ➤ right-click <drawing name> ➤ Add to Project
Add To Project Wizard
Select A Project Page (page 2446)
Select a Drawing Location Page (page 2446)
Drawing File Dependencies Page (page 2446)
Share Data Page (page 2447)

Checking a Drawing out from a Project
You can check out a project drawing to edit it.
Checking out a drawing prevents others from changing the drawing while you are working on it. When you
have completed your changes, check in the drawing.
Check out a drawing only if you intend to change it. If you do not need to change the drawing, get a read-only
copy using Get Latest Version. For more information, see Getting the Latest Version of a Drawing (page 180).
You can check out files that the drawing is dependent on when you check out the drawing. However, you
should only check out dependent files if you intend to change them.
When you check out a drawing, a local copy of the drawing is placed in your working folder, and the drawing
is opened.
To check a drawing out from a project
1 In Toolspace, on the Prospector tab, under the Projects collection, expand the project collection and
the project Drawings collection that contains the drawing you want to check out.
NOTE If a drawing is open under the Open Drawings collection, all right-click functions are transferred to
that location.
2 Right-click the drawing and click Check Out.
3 In the Check Out Drawing (page 2449) dialog box, specify whether dependent files should also be checked
out.
4 Specify whether you want the latest version of the file.
Getting the latest version overwrites your local copy of the file with the most recent version of the
master copy of the file. Most of the time, you should get the latest version of the file. However, if you
want to create a new version of the file from your existing local copy, do not get the latest version.
5 If Include File Dependencies is selected, specify which project files should be checked out.
6 Click OK.
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Quick Reference
Toolspace Shortcut Menu
Prospector tab (Master View): Projects collection ➤ project Drawings collection ➤ right-click <drawing
name> ➤ Check Out
Dialog Box
Check Out Drawing Dialog Box (page 2449)

Checking a Drawing in to a Project
After you check out a project drawing and change it, check in the drawing to make it available to others
and to update the version in the project database.
You can only check in a drawing that you have checked out. Checking in the drawing returns the file to its
original project database and folder, and updates the version. If the drawing is opened and has been changed,
it is automatically saved before it is checked in.
When checking in a project drawing, you can specify which objects in the drawing (if any) you want to
share with others. You can also specify whether a .dwf file is created, as a preview of the source drawing, for
display in drawing item views and the Autodesk Vault tool.
To check a drawing in to a project
1 In Toolspace, on the Prospector tab, under the Projects collection, expand the project collection and
the project Drawings collection that contains the drawing you want to check in.
NOTE If a drawing is open under the Open Drawings collection, all right-click functions are transferred to
that location.
2 Right-click the drawing and click Check In.
3 On the Drawing File Dependencies (page 2448) page of the Check In Drawing wizard, specify any file
dependencies, .dwf creations options, and comments.
4 Click Next.
5 On the Share Data (page 2449) page of the Check In Drawing wizard, specify which objects in the drawing
you want to share with others.
NOTE If the drawing does not contain objects that can be shared, this dialog box is not displayed. Objects
that were shared during the Add to Project command or a previous Check In command are not listed.
6 Click Finish.

Quick Reference
Toolspace Shortcut Menu
Prospector tab (Master view): Projects collection ➤ project Drawings collection ➤ right-click <drawing
name> ➤ Check In
OR
Prospector tab: Open Drawings collection ➤ right-click <drawing name> ➤ Check In
Check In Drawing Wizard
Drawing File Dependencies Page (page 2448)
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Share Data Page (page 2449)

Opening a Project Drawing
After a drawing has been added to a project, open it from the Projects collection in the Prospector tree.
If you want to open a project drawing and edit it, you must first check it out. If you do not have the project
drawing checked out, you can only open it in read-only mode.
You can tell whether the drawing is checked out to you by the icon displayed next to the drawing name in
the Prospector tree. For more information, see Project Item State Icons (page 160).
If the drawing you want to check out is a source drawing for a project object, you can open it from the
project object collection. For more information, see Viewing Project Object Source Drawings (page 185).
To open a project drawing
1 In Toolspace, on the Prospector tab, under the Projects collection, navigate to the folder that contains
the drawing you want to open.
2 Right-click the drawing.
3 Click Check Out or Open (read-only).
The command that is listed on the menu depends on whether or not you have the drawing checked
out.

Quick Reference
Toolspace Shortcut Menu
Prospector tab (Master View): Projects collection ➤ project Drawings collection ➤ right-click <drawing
name> ➤ Open

Getting the Latest Version of a Drawing
You can obtain a read-only copy of the latest version of any project drawing.
Use the Get Latest Version command to update your copy of a source drawing for a project object, a drawing
that contains a reference to shared project objects, or any other project drawing.
You can tell whether your local copy of a drawing is the latest version available in Vault by the icon displayed
next to it in the Prospector tree. For more information, see Project Item State Icons (page 160).
The Get Latest Version command is displayed in the shortcut menu of a Prospector tree item only when the
local copy of the file is out of date or does not exist. The command is not available for an open drawing.
When applicable, the Get Latest Version command is available at every level within the Projects collection
on the Prospector tab. If you select the command at a level that contains folders beneath it, you can choose
which folders you want to update.
To get the latest version of a drawing
1 In Toolspace, on the Prospector tab, under the Projects collection, right-click the drawing, collection,
or folder you want to update.
2 Click Get Latest Version.
3 In the Get Latest Version (page 2455) dialog box, select Include File Dependencies to display any dependent
files in the Project Files list.
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4 Clear the check boxes next to files and folders that you do not want updated.
5 Click OK.

Quick Reference
Toolspace Shortcut Menu
Prospector tab (Master View): Projects collection ➤ right-click collection, folder, or item ➤ Get Latest
Version
Dialog Box
Get Latest Version Dialog Box (page 2455)

Resetting a Checked out Drawing
If you have a project drawing checked out, you can reset it to a checked-in state without making any changes
to it.
A drawing must be checked out to you before you can reset its state. The Undo Check Out command resets
your local copy of the drawing back to the latest version of the file in the project database, which means
that any changes you made to the drawing are lost. You can preserve the changes you made to the drawing
by saving and renaming the drawing (using Save As) before using the Undo Check Out command.
The status of the drawing in the project database is reset to checked-in, and the file version is not updated.
To undo the checkout of a drawing
1 In Toolspace, on the Prospector tab, under the Projects collection, expand the project collection and
the project Drawings collection that contains the drawing you want to reset.
NOTE If a drawing is open under the Open Drawings collection, all right-click functions are transferred to
that location.
2 Right-click the checked-out drawing.
3 Click Undo Check Out.
4 In the Undo Check Out (page 2460) dialog box, select Include File Dependencies to display dependent
files.
5 If dependent files are displayed, clear the check boxes next to files that should remain checked-out.
6 Click OK.

Quick Reference
Toolspace Shortcut Menu
Prospector tab (Master View): Projects collection ➤ project Drawings collection ➤ right-click <drawing
name> ➤ Undo Check Out
OR
Prospector tab: Open Drawings collection ➤ right-click <drawing name> ➤ Undo Check Out
Dialog Box
Undo Check Out Dialog Box (page 2460)

Working with Vault Project Drawings | 181

Synchronizing Drawing Data with Project Data
You can update an open drawing with the latest versions of all project objects and point data.
The Sync To Project command updates out-of-date drawings that reference project objects. It also updates
any out-of-date project points contained in the drawing. The out-of-date condition can occur when someone
checks in a project object’s source drawing or checks in project points.
Local copies of out-of-date source drawings and project points are replaced with the latest version from the
project database.
To synchronize a drawing
1 In Toolspace, on the Prospector tab, under the Open Drawings collection, right-click the drawing you
want to synchronize.
2 Click Sync To Project.
3 In the Sync To Project (page 2459) dialog box, select the out-of-date project objects you want synchronized.
4 Click OK.

Quick Reference
Toolspace Shortcut Menu
Prospector tab: Open Drawings collection ➤ right-click <drawing name> ➤ Sync to Project
Dialog Box
Sync To Project Dialog Box (page 2459)

Detaching a Drawing from a Project
You can detach a drawing from a project to sever the connection between the drawing and all project data.
WARNING When you detach a drawing from a project, all links to project source drawings and project data are
severed and cannot be re-established.
A drawing must be open to be detached from a project. When you detach a drawing from a project, all
references in the drawing to shared project objects are replaced with object data that can be edited.
When a drawing contains a project object, such as a reference to a project surface, the project object is
promoted to a surface object that has no reference back to the original source drawing that its geometry it
based on. You can edit the promoted surface, but you cannot rebuild it based on the original source data.
To detach a drawing from a project
1 In Toolspace, on the Prospector tab, in the Open Drawings collection, right-click the drawing you want
to detach.
2 Click Detach Project.

Quick Reference
Toolspace Shortcut Menu
Prospector tab: Open Drawings collection ➤ right-click <drawing name> ➤ Detach Project
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Working with Vault Project Objects
You can create, manage, and reference project objects through their source drawings.
A project object is an object that is intended to be shared with others working on a project. A project object
is managed through its source drawing, which is the drawing that contains the object.
A project object becomes available to others when the source drawing containing the object is added to or
checked in to the project database and the object is selected to be shared.
To include a project object in another drawing, you create a reference to the object. A reference is a read-only
copy of the object that you can refer to as if it were the object itself.

Creating Project Objects
Create a project object by adding a source drawing to a project.
When you add or check in a drawing to a project, you can specify which objects (such as surfaces) in the
drawing are to be shared. For more information, see Adding a Drawing to a Project (page 177) and Checking
a Drawing in to a Project (page 179).
After a project object has been shared, it is listed in the project’s object collection (such as Surfaces,
Alignments, or Pipe Networks) in the Prospector tree.
You can access a project object’s data in another drawing by creating a read-only copy called a reference.
For more information, see Creating References to Project Objects (page 183).

Creating References to Project Objects
Include a read-only copy of a project object in a drawing by creating a reference to it.
All the available project objects in a project are listed in the project’s object collections, including Surfaces,
Alignments, and Pipe Networks, in the Prospector tree.
You access a project object’s data in a drawing by creating a reference to it. A reference is a read-only copy
of an object. When you create a reference to an object, you cannot modify the object’s geometry, but you
can access its properties and data, apply styles and annotation, and perform some types of analysis.
Creating a reference creates a local copy of the object’s source drawing in your working folder. If you already
have a local copy of the object’s source drawing, it is updated to the latest version, if necessary.
To create a reference to a project object
1 Open the drawing to which you want to add the reference, and make it the active drawing.
2 In Toolspace, on the Prospector tab, expand the Projects collection.
3 Expand the project and object collections that contain the project object.
4 Right-click the project object.
5 Click Create Reference.
6 In the Create Reference dialog box for the object, specify how the object’s geometry will be displayed
in the drawing.
7 Click OK.
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Quick Reference
Toolspace Shortcut Menu
Prospector tab (Master View): Projects collection ➤ <project> collection ➤ <object> collection ➤
right-click <object> ➤ Create Reference

Removing a Project Object
Make an object unavailable for referencing in other project drawings.
You can delete an object from the list of reference objects for a project. Any existing references to the object
remain intact, and continue to be updated from the source object.
To delete a project object
1 In Toolspace, on the Prospector tab, expand the Projects collection.
2 Expand the project and object collections that contain the project object.
3 Right-click the project object to be deleted.
4 Click Remove.

Quick Reference
Toolspace Shortcut Menu
Prospector tab (Master View): Projects collection ➤ <project> collection ➤ <object> collection ➤
right-click <object> ➤ Remove

Getting the Latest Version of Project Objects
If someone makes a change to a project object, you can easily update your local copy of the object’s source
drawing.
When someone creates a new version of a project object’s source drawing in the project database, your local
copy becomes out of date. You can determine the state of your local copy by the icon displayed next to
either the source drawing or the project object in the Prospector tree. For more information, see Project Item
State Icons (page 160).
NOTE The Get Latest Version command is available at all levels of a project in the Prospector tree, when applicable.
To get the latest version of a project object
1 In Toolspace, on the Prospector tab, expand the Projects collection.
2 Expand the project collection that contains the project object.
3 Expand the object collection that contains the project object.
4 Right-click the project object and click Get Latest Version.
5 In the Get Latest Version (page 2455) dialog box, select Include File Dependencies to display dependent
files in the Project Files list.
6 Clear the check boxes next to files and folders that you do not want updated.
7 Click OK.
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Quick Reference
Toolspace Shortcut Menu
Prospector tab (Master View): Projects collection ➤ <project> collection ➤ <object> collection ➤
right-click <object> ➤ Get Latest Version
Dialog Box
Get Latest Version Dialog Box (page 2455)

Viewing Project Object Source Drawings
You can quickly open or switch to a project object’s source drawing.
You can open a project object’s source drawing from the project object level in the Prospector tree. If the
drawing is already open, you can make it the active drawing.
NOTE If you do not have the drawing checked out, you can only open the drawing in read-only mode.
To access a source drawing for a project object
1 In Toolspace, on the Prospector tab, expand the Projects collection.
2 Expand the project collection that contains the project object.
3 Expand the object collection that contains the project object.
4 Right-click the project object and do one of the following:
■

If you have the source drawing checked out, click Open Source Drawing to open it.

■

If you do not have the source drawing checked out, click Open Source Drawing (Read-only) to open
it.

■

If the drawing is open, click Switch To Source Drawing to make it the active drawing.

Quick Reference
Toolspace Shortcut Menu
Prospector tab (Master View): Projects collection ➤ <project> collection ➤ <object> collection ➤
right-click <object> ➤ Open Source Drawing
OR
Prospector tab (Master View): Projects collection ➤ <project> collection ➤ <object> collection ➤
right-click <object> ➤ Open Source Drawing (Read-only)
OR
Prospector tab (Master View): Projects collection ➤ <project> collection ➤ <object> collection ➤
right-click <object> ➤ Switch To Source Drawing

Checking Out Project Object Source Drawings
You can check out a project object’s source drawing at the project object level in the Prospector tree.
When you check out a drawing, a local copy of the drawing is placed in your working folder, and the drawing
is opened.
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To check out a project object’s source drawing
1 In Toolspace, on the Prospector tab, expand the Projects collection.
2 Expand the project collection that contains the project object.
3 Expand the object collection that contains the project object.
4 Right-click the project object and click Check Out Source Drawing.
5 In the Check Out Drawing (page 2449) dialog box, specify whether file dependencies should be included.
6 Specify whether the latest version of the file is desired.
7 If Include File Dependencies is selected, specify which project files should be checked out with the
drawing file by selecting the check boxes next to them.
8 Click OK.

Quick Reference
Toolspace Shortcut Menu
Prospector tab (Master View): Projects collection ➤ <project> collection ➤ <object> collection ➤
right-click <object> ➤ Check Out Source Drawing
Dialog Box
Check Out Drawing Dialog Box (page 2449)

Resetting a Checked Out Source Drawing
You can undo the checkout of a project object’s source drawing at the project object level in the Prospector
tree.
To undo the checkout of a project object’s source drawing
1 In Toolspace, on the Prospector tab, expand the Projects collection.
2 Expand the project collection that contains the project object.
3 Expand the object collection that contains the project object.
4 Right-click the project object and click Undo Check Out Source Drawing.
5 In the Undo Check Out (page 2460) dialog box, select Include File Dependencies to display dependent
files.
6 If dependent files are displayed, clear the check boxes next to files that should remain checked out.
7 Click OK.

Quick Reference
Toolspace Shortcut Menu
Prospector tab (Master View): Projects collection ➤ <project> collection ➤ <object> collection ➤
right-click <object> ➤ Undo Check Out Source Drawing
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Dialog Box
Undo Check Out Dialog Box (page 2460)

Promoting Project Objects
You can replace a read-only object reference with an editable copy of the project object by promoting the
object reference.
WARNING Promoting an object reference severs all connections to project object source data. The connection
cannot be re-established.
You should promote an object reference only when you have no need to maintain the project object’s link
to its source drawing or data.
To promote a project object
1 In Toolspace, on the Prospector tab, under the Open Drawings collection, expand the drawing that
contains the project reference object you want to promote.
2 Expand the drawing object collection that contains the object reference you want to promote.
3 Right-click the object and click Promote.

Quick Reference
Toolspace Shortcut Menu
Prospector tab: Open Drawings collection ➤ <object> collection ➤ right-click <object> ➤ Promote
Command Line
PromoteAllReferences

Working with Vault Project Points
Project management for AutoCAD Civil 3D points differs from project management for other project objects.
Master copies of points are stored in a point database, not a source drawing, and points are checked out or
copied directly to a drawing. The project points in a drawing are usually a subset of the project database.
Individual points are not displayed in the project database, and they cannot be viewed using the Autodesk
Vault tool.
Project points are accessed and managed through two files that are stored in the project database with other
project files: PointsGeometry.mdb, which is the project point database, and PointsStatus.mdb, which contains
information about the status (for example, checked-in or checked-out) of individual points. You do not
explicitly check out or check in the project point database. Instead, you check out, modify, and check in
individual project points and the project point database is updated automatically.
The status of your local project points in relation to the latest version of the project point database in the
project’s Vault database is shown by the icon displayed next to the project Points node under the project
collection. The icons that can be displayed are shown in the following table:
Icon

Meaning
If no icon is displayed, the project point database exists in the project’s
Vault database, and you have not accessed it.
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Icon

Meaning
The local project point database matches the latest version of the project
point database in the project’s Vault database.
The local project point database is newer than the latest version of the
project point database in the project’s Vault database.
The local project point database is older than the latest version of the
project point database in the project’s Vault database.

Many of the project management operations (such as check-in and check-out) that can be performed on
points in a drawing can also be performed using point groups.

Project Point State Icons
Because Vault is not used for managing individual points, the icons indicating the state of individual points
(for example, checked-in or checked-out) are different from the icons used for other project objects.
The following table shows the project point state icons, which are displayed in the Points list view.:
Icon

Meaning
The point is checked in.

The point is checked out to your active drawing.

The point is checked out to a drawing other than your active drawing.
This could be a drawing that belongs to you or to someone else.
The point is protected and cannot be changed.

The Project Points List View
You can use the project points list view to obtain information about the state of project points.
NOTE To view project points in the Prospector tree, select Master View from the list at the top of the Prospector
tab.
In Prospector ➤ Projects, click the project Points collection to display a list view that lists all of the project
points. Project management information is listed, including:
■

Most recent version number

■

User who last modified the point and the date it was modified

■

Current state of the point (checked-in, checked-out, or protected) and the date the state was last changed

■

User who set the current state of the point

■

If checked-out, the drawing and host computer that the point is checked out to

Project point state icons are displayed next to each point. For more information, see Project Point State Icons
(page 188).
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For more information about changing the list view display, see Customizing a List View (page 101).

Working with Point-related Project Management Commands
You can perform point access control operations, such as checking in and checking out points, in several
locations in the Prospector tree.
When you select multiple points and perform a project management operation on them, the operation is
performed only on those points to which it applies. For example, if you select a list of points in the Points
list view and use the Check In command to check them in, only the points you checked out are checked
in.
In addition, Survey points that are created using the Prospector Survey tab are not included in project
management commands even if they are selected. For example, any Survey points included in the selection
list during the Add to Project command are not added to the project.
You can access point-related project commands using list view shortcut menus or using point groups, as
described below:
■

If you already have a copy of a project point in a drawing, use the shortcut menu in the Prospector
drawing Points list view to check in, check out, protect, or get a copy of the point.

■

If you do not have a copy of the point in a drawing, use the shortcut menu in the Prospector project
Points list view to check in, check out, protect, or get a copy of a point.

■

If you have point groups defined in the drawing, right-click a point group in the Prospector tree and use
the point group shortcut menu to check in, check out, protect, or get copies of project points.

In some cases, only valid project management commands are displayed on a shortcut menu. For example,
if a set of points are not available for check out, the Check Out command might not be displayed, but the
Get From Project command would be displayed so that you can get a read-only copy of the point. In some
cases, a drawing must be saved before project management commands are available.

Adding Points to a Project
You can use the Add To Project command to add points to a project so they can be accessed by others.
You can add some or all of the points in a drawing to a project. Before you can add drawing points to a
project, you must save the drawing. If the drawing has not been saved, the Add to Project command is not
available.
If the drawing contains one or more project objects, the points are added to the project that the existing
project objects belong to. If the drawing does not contain project objects, you are prompted to select a
project.
You can access the Add To Project command not only from the drawing’s Points list view, but also from a
drawing point group’s shortcut menu.
To add points to a project
1 In Toolspace, on the Prospector tab, under the Open Drawings collection, expand the drawing that
contains the points you want to add to the project.
2 Click the Points collection to display the Points list view.
3 In the list view, select the points, right-click, and click Add To Project.
Any Survey points included in the selection are not added to the project. Survey points are stored only
in the project’s Survey Point database.
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4 If you are prompted, select a project to add the points to.
5 In the Add To Project (page 2445) dialog box, enter a comment.
6 From the Check In Options list, select an option to specify the state of the points after you add them
to the project.
7 Click OK.

Quick Reference
Toolspace Shortcut Menu
Prospector tab: Open Drawings collection ➤ click Points collection ➤ right-click selected points in list
view ➤ Add To Project
OR
Prospector tab: Open Drawings collection ➤ Point Groups collection ➤ right-click <point group> ➤
Add Points To Project
Dialog Box
Add Points To Project Dialog Box (page 2445)

Checking Out Points
You can use the Check Out command to prevent others from making changes to project points while you
are editing them.
To edit a project point, check it out to a drawing, edit it in the drawing, and then check it back into the
project.
NOTE When working with project points, the term local copy refers to the copy of the point in your drawing.
Checking out a project point creates a local copy of the point in the drawing. The Check Out command
gives you exclusive access to the project point; no one else can check it out while you are working on it.
If the Check Out command is not available, you can use the Get From Project command to a read-only local
copy of the point. For more information, see Copying Project Points into a Drawing (page 192).
To check out project points
1 Verify that the drawing you want to bring the points into is the active drawing. If it is not, right-click
the drawing name in the Open Drawings collection in the Prospector tree and click Switch To.
2 In Toolspace, on the Prospector tab, expand the Projects collection and then expand the project that
contains the points you want to check out.
3 Click the project Points collection to display a list view.
4 In the list view, select the project points you want to check out, right-click, and click Check Out.
5 In the Check Out (page 2450) dialog box, click OK.
Local copies of the points are created in the active drawing.
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Quick Reference
Toolspace Shortcut Menu
Prospector tab (Master View): Projects collection ➤ project Points collection ➤ right-click selected points
in list view ➤ Check Out
OR
Prospector tab: Open Drawings collection ➤ Point Groups collection ➤ right-click <point group> ➤
Check Out Points
Dialog Box
Check Out Points Dialog Box (page 2450)

Checking In Points
You can use the Check In command to check in checked-out project points.
NOTE When working with project points, the term local copy refers to the copy of the point in your drawing.
After you edit one or more project points, use the Check In command to replace the existing project point
with your local copy of the project point, and increase the project point’s version number.
The Check In command always updates the project point from the drawing that the point was checked out
to.
To check in project points
1 Verify that the drawing that you want to check the points in from is the active drawing. If it is not,
right-click the drawing name in the Open Drawings collection in the Prospector tree and click Switch
To.
2 Click the drawing’s Points collection to display a list view.
3 In the list view, select the points to check in and right-click.
4 Click Check In.
5 In the Check In (page 2449) dialog box, enter a comment.
6 From the Check In Options list, select an option to specify the state of the points after you check them
in.
7 Click OK.

Quick Reference
Toolspace Shortcut Menu
Prospector tab (Master View): Projects collection ➤ project Points collection ➤ right-click selected points
in list view ➤ Check In
OR
Prospector tab: Open Drawings collection ➤ drawing Points collection ➤ right-click selected points in
list view ➤ Check In
OR
Prospector tab: Open Drawings collection ➤ Point Groups collection ➤ right-click <point group> ➤
Check In Points
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Dialog Box
Check In Points Dialog Box (page 2449)

Copying Project Points into a Drawing
You can use the Get From Project command to make a read-only copy of project points in a drawing.
To copy project points into a drawing
1 Verify that the drawing to which you want to copy is the active drawing. If it is not, right-click the
drawing name in the Prospector tree and click Switch To.
2 In Toolspace, on the Prospector tab, expand the Projects collection and then expand the project collection
that contains the points you want to copy.
3 Click the project Points collection to display the list view.
4 In the list view, select the points to copy, right-click, and click Get From Project.
5 In the Get From Project (page 2456) dialog box, click OK.

Quick Reference
Toolspace Shortcut Menu
Prospector tab (Master View): Projects collection ➤ project Points collection ➤ right-click selected points
in list view ➤ Get From Project
OR
Prospector tab: Open Drawings collection ➤ drawing Points collection ➤ right-click selected points in
list view ➤ Get From Project
OR
Prospector tab: Open Drawings collection ➤ Point Groups collection ➤ right-click <point group> ➤
Get Points From Project
Dialog Box
Get Points From Project Dialog Box (page 2456)

Protecting Project Points
You can use the Protect command to prevent project points from being checked out and edited.
You cannot protect a project point that is checked-out.
To protect project points
1 In Toolspace, on the Prospector tab, expand the Projects collection and then expand the project collection
that contains the points you want to protect.
2 Click the project Points collection to display the list view.
3 In the list view, select the points to protect, right-click, and click Protect.
4 In the Protect (page 2458) dialog box, click OK.
A lock icon

is displayed next to a protected project point in the Points list view.
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Quick Reference
Toolspace Shortcut Menu
Prospector tab (Master View): Projects collection ➤ project Points collection ➤ right-click selected points
in list view ➤ Protect
OR
Prospector tab: Open Drawings collection ➤ drawing Points collection ➤ right-click selected points in
list view ➤ Protect
OR
Prospector tab: Open Drawings collection ➤ Point Groups collection ➤ right-click <point group> ➤
Protect Points
Dialog Box
Protect Points Dialog Box (page 2458)

Unprotecting Project Points
You can use the Unprotect command to allow protected project points to be checked out and edited.
Only the person who protected a project point can unprotect it.
A lock icon

is displayed next to a protected point in the Points list view.

To unprotect project points
1 In Toolspace, on the Prospector tab, expand the Projects collection and then expand the project collection
that contains the points you want to unprotect.
2 Click the Points collection to display the list view.
3 In the list view, select the protected points, right-click, and click Unprotect.
4 In the Unprotect (page 2460) dialog box, click OK.

Quick Reference
Toolspace Shortcut Menu
Prospector tab (Master View): Projects collection ➤ project Points collection ➤ right-click selected points
in list view ➤ Unprotect
OR
Prospector tab: Open Drawings collection ➤ drawing Points collection ➤ right-click selected points in
list view ➤ Unprotect
OR
Prospector tab: Open Drawings collection ➤ Point Groups collection ➤ right-click <point group> ➤
Unprotect Points
Dialog Box
Unprotect Points Dialog Box (page 2460)

Deleting Project Points
You can use the Delete From Project command to delete project points.
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When you delete a project point, it is permanently removed from the project, and is no longer listed in the
Prospector tree.
Before you can delete a project point, you must check it out. For more information, see Checking Out Points
(page 190).
To delete project points
1 In Toolspace, on the Prospector tab, expand the Projects collection and then expand the project collection
that contains the points you want to delete.
2 Click the Points collection to display the list view.
3 In the list view, select the points to delete, right-click, and click Delete From Project.
4 In the Delete From Project (page 2455)dialog box, click OK.

Quick Reference
Toolspace Shortcut Menu
Prospector tab (Master View): Projects collection ➤ project Points collection ➤ right-click selected points
in list view ➤ Delete From Project
OR
Prospector tab: Open Drawings collection ➤ drawing Points collection ➤ right-click selected points in
list view ➤ Delete From Project
OR
Prospector tab: Open Drawings collection ➤ Point Groups collection ➤ right-click <point group> ➤
Delete Points From Project
Dialog Box
Delete Points From Project Dialog Box (page 2455)

Resetting Points You Checked Out
You can use the Undo Check Out command to reset checked-out project points back to a checked-in state.
Use this command if you checked out one or more points but do not want to update the project with any
changes you have made.
You can use this command only on project points that are checked out to you.
To reset your checked out project points
1 In Toolspace, on the Prospector tab, expand the Projects collection and then expand the project collection
that contains the points you want to reset.
2 Click the Points collection to display the list view.
3 In the list view, select the points to reset, right-click, and click Undo Check Out.
4 In the Undo Check Out (page 2460) dialog box, click OK.
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Quick Reference
Toolspace Shortcut Menu
Prospector tab (Master View): Projects collection ➤ project Points collection ➤ right-click selected points
in list view ➤ Undo Check Out
OR
Prospector tab: Open Drawings collection ➤ drawing Points collection ➤ right-click selected points in
list view ➤ Undo Check Out
OR
Prospector tab: Open Drawings collection ➤ right-click <point group> ➤ Undo Check Out
Dialog Box
Undo Check Out Points Dialog Box (page 2460)

Resetting Project Points Set by Others
If you are a Vault administrator, you can use the Reset To Checked In command to reset to a checked-in
state a project point checked-out or protected by someone else.
Use this command if a point is checked out or protected and for some reason the person who originally
checked it out or protected it cannot undo the operation or check in the point.
NOTE The Reset to Checked In command is available only to a Vault administrator.
To reset points checked out to someone else
1 In Toolspace, on the Prospector tab, expand the Projects collection, and then expand the project
collection that contains the points you want to reset.
2 Click the Points collection to display the list view.
3 Select the checked-out or protected points, right-click, and click Reset To Checked In.
4 In the Reset To Checked In (page 2458) dialog box, click OK.
NOTE The Project Points item list can be sorted to assist selecting the project points to be reset to a checked
in state.

Quick Reference
Toolspace Shortcut Menu
Prospector tab (Master View): Projects collection ➤ project Points collection ➤ right-click selected points
in list view ➤ Reset to Checked In
Dialog Box
Reset Points To Checked In Dialog Box (page 2458)

Error Codes
Errors encountered during Vault project management commands are reported in two ways.
If a single error is encountered during a project management operation, it is displayed in a message box. If
multiple errors occur during a single operation, the resulting Vault error codes are displayed in the Event
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Viewer. For example, if a drawing check-in operation fails, and then subsequent check-ins of dependent files
also fail, the error codes for the related multiple failures are displayed in the Event Viewer.
The following table lists the Vault error codes that can be displayed if a project management command fails:
Group Code/Error Code

Error Description

SysErrCodes
0

Error code is not valid or is unspecified.

CoreErrCodes
100

Error creating the knowledge vault in
database.

101

Script to prime the database with its
schema failed.

102

Knowledge vault already exists in database.

103

Attempt to create user in database failed.

104

Error adding user role in database.

105

Error removing user role in database.

106

Error validating the principal as being a
secure principal (i.e. authenticated).

107

Principle requirement does not match.
Should be anonymous.

108

Requires new transaction, but transaction
was not created.

109

Error initializing knowledge vault in database.

110

Stored procedure cannot be found.

111

Error getting relative resource path.

112

File stream is null, so the crc code can't be
calculated

113

File is not readable, so the crc code can't
be calculated

114

Could not create (Knowledge)VaultMaster
Database

115

Could not create (Knowledge)VaultMaster
Database schema

116

Could not initialize (Knowledge)VaultMaster Database tables
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Group Code/Error Code

Error Description

117

Failure during migrate of a KnowledgeVault

118

Failure creating VultSys user for the DB

119

Failure during migrate of KnowledgeVaultMaster

120

Failure updating the KnowledgeVaultMaster stored procedures

121

Failure deleting the KnowledgeVaultMaster

122

Failure updating user information

123

Could not update EIDatabase table

124

Failure moving the file store

125

Failure attaching a database

126

Failure detaching a database

127

Failure deleting a Vault

128

Failure backing up

129

Failure restoring

130

Unable to determine the version of a
KnowledgeVault or Master

131

The database master login is invalid

132

The directory is not empty

133

The Knowledge Vault referenced doesn't
exist

134

There are Knowledge Vaults still attached.

135

Failure activating a vault

136

Failure deactivating vault. DB is probably
in use

137

One of the inputs to the service call is incorrect.

138

Vault name is not allowed, most likely due
to illegal characters.

139

Specified folder is illegal.

140

Specified folder is already in use.
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Group Code/Error Code

Error Description

141

Could not find global option.

142

Could not find local option.

143

Duplicate User Name

144

Database error because an MDF or LDF file
with that name already exists.

145

Database is in use

146

Cannot determine the migration steps.

147

The specified path is too long.

148

Incorrect vault category Id entered

149

The vault's category does not support the
operation.

150

The KnowledgeVaultMaster referenced
doesn't exist

151

Not enough disk space to perform
Backup/Restore operation.

152

Cannot restore db files to a remote location

153

Selected directory does not contain a valid
backup structure.

SecurityErrCodes
300

Authentication Token is invalid.

301

User name and/or Password is invalid, so
user cannot be authenticated.

302

User is not a member of the vault

303

Invalid permissions for transaction

304

User is disabled

305

Vault database does not exist

DocServiceErrCodes
1000

Folder id is invalid.

1001

Cannot get the latest version of file.
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Group Code/Error Code

Error Description

1002

Cannot get file version.

1003

File id is invalid.

1004

Checkout latest file version failed.

1005

Error checking in file version into database.

1006

Error undoing check out of file version.

1007

Bad version id when getting file version
dependents or dependencies by version
id.

1008

Cannot add file because file exists.

1009

Cannot add file (unspecified failure)

1011

Cannot add folder because folder exists.

1012

Cannot add folder (unable to create/make
new folder).

1013

Cannot get file (file id is invalid).

1014

Cannot create/make version in database.

1015

Cannot delete file version because of dependencies.

1016

Cannot undo checkout because user is not
the same as user who checked out file.

1017

Cannot undo checkout because passed in
folder id is not the same folder that the file
was checked out from.

1018

Cannot check in file because the file is not
currently checked out

1019

Cannot check in file because the file is not
currently checked out by the same user.

1020

Cannot check in file because passed in
folder id is not the same folder that the file
was checked out from.

1021

Cannot check out the file because it is
already checked out.

1022

Circular dependency check failed.

1023

Cannot create folder in database.
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Group Code/Error Code

Error Description

1024

Cannot get folder.

1025

Cannot get root folder from the database.

1026

File belongs to a library folder.

1027

Folder is a library folder.

1028

Cannot move file.

1029

A file exists in the destination folder that
has the same name as the file that is being
moved from its source folder.

1030

Cannot share because a file already exists
in the destination folder with the same
name.

1034

Cannot rename the file because there was
some other unexpected error.

1035

Could not create property definition in
database.

1036

Cannot get all property definitions.

1037

Cannot get all extended property definitions.

1039

Property could not be added in database.

1040

Big property could not be added in database

1041

Cannot get properties

1042

Create folder rule-check failed: parent must
exist, for all but root

1043

Create folder rule-check failed: libs can only
have non lib parent if that parent is root.
Libs cannot have non-lib children.

1044

Request to share a file to a folder fails because of a concurrent request to share the
file to the same folder.

1045

Request to move a file to a folder fails because of a concurrent request to move the
file to the same folder or because of a
concurrent request to move the file to another folder
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Group Code/Error Code

Error Description

1046

Request to create a folder fails because the
folder name is longer that 80 characters.

1050

Request to conditionally delete a file fails
because there are delete restrictions (file
has dependent parent files, file is checked
out, or file is linked or attached to an item)

1051

Request to unconditionally delete a file fails
because the are delete restrictions that
cannot be overridden (file is linked or attached to an item)

1052

Request to delete a file failed for an unspecified reason.

1053

Request to conditionally delete a folder fails
because there are delete restrictions on
one or more child files (file has dependent
parent files, file is checked out, or file is
linked or attached to an item)

1054

Request to unconditionally delete a folder
fails because the are delete restrictions that
cannot be overridden on one or more child
files (file is linked or attached to an item)

1055

Request to delete a folder fails due to an
unspecified reason

1056

Occurs when either no parameters have
been set and a purge is attempted or when
an attempt is made set invalid parameter
values.

1057

Occurs when something goes wrong while
purging file iterations from the database,
or while deleting files from the file store

1058

If the Unique File Name Required Vault
option is ON, a request to Add or Check
in a file with the same name as a file
already existing in the Vault will fail with
this error.

1059

Occurs when an attempt to update a
Folder fails for an unspecified reason.

1060

Occurs when an attempt to update a
Folder Name fails because another Folder
with that name exists in the parent.

1061

Label ID is invalid
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Group Code/Error Code

Error Description

1062

Label Name contains invalid characters

1063

Label Name already exists in vault

1064

Cannot create label in database.

1065
1066

No PropertyGroup with the given Id exists

1067

A PropertyGroup with the specified name
already exists.

1068

The PropertyDefinitions to be assigned to
the PropertyGroup do not share the same
DataType.

1069

The PropertyGroup must be assigned
PropertyDefinitions

1070

Request to add a PropertyGroup failed for
an unspecified reason

1071

Request to update a PropertyGroup failed
for an unspecified reason.

1072

Request to delete a PropertyGroup failed
for an unspecified reason.

1073

An unknown error occurred.

1074

Folder with the same name already exists
in the destination folder

1075

Folder being moved has descendent files
that are checked out.

1076

Move folder rule-check failed: parent must
exist, for all but root

1077

Move folder rule-check failed: libs can only
have non lib parent if that parent is root.
Libs cannot have non-lib children.

1078

A null path or path with illegal characters
has been passed in.

1079

The full path of the folder is greater than
256 characters

1080

A null value has been passed in where null
values are not allowed.
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Group Code/Error Code

Error Description

1081

The date is out of range for the DB.The
date should be between 1-1-1753 and 1231-9999

SerializeErrCodes
1200

Exception passed to Encodable Exception
saying the object is null

Project Management Command Reference
Use these commands to access reference functionality for data shortcuts or Vault.
The following table lists AutoCAD Civil 3D commands related to project management and briefly describes
their functionality.
Command

Description

AssociateProjectToDrawings

Associates multiple drawings with a data shortcut
project. (page 150)

AssociateShortcutProject

Associates the current drawing to a data shortcut
project. (page 150)

CreateAlignmentReference

Creates a Vault alignment reference (page 954)

CreateNetworkReference

Creates a Vault pipe network reference (page 1342)

CreateProfileReference

Creates a Vault profile reference (page 1150)

CreateSurfaceReference

Creates a Vault surface reference (page 656)

CreateViewFrameGroupReference

Creates a Vault view frame group reference (page
1917)

CreateDataShortcuts

Creates a data shortcut for each eligible object in
the active drawing (page 151)

NewShortcutsFolder

Creates a new project folder for use with data
shortcuts (page 147)

PromoteAllReferences

Promotes all reference objects in the drawing,
whether they are Vault or data shortcut references
(page 154)

PromoteNetwork

Promotes a data shortcut reference pipe network
(page 154)

PromoteReference

Promotes a data shortcut reference surface, alignment, or profile (page 154)

PromoteViewFrameGroup

Promotes a data shortcut reference view frame
group (page 154)
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Command

Description

RepairBrokenReferences

Repairs one or more data shortcut references in a
consumer drawing (page 155)

SetShortcutsFolder

Changes the active project folder for use of data
shortcuts (page 148)

SetWorkingFolder

Points to a different working folder for data shortcuts projects (page 147)

ShortcutNode

Hides or shows the Data Shortcuts node on the
Prospector tab (page 152)

SynchronizeReferences

In data shortcuts projects, updates data references
with current versions of their source objects (page
152)

ValidateShortcuts

Ensures that all data references are up to date and
reloads any outdated ones from their source objects
(page 155)

204 | Chapter 7 Project Management

Survey

205

206

Understanding Survey

8

You can use the AutoCAD Civil 3D survey features to download, create, analyze, and adjust survey data. The survey features
extend the functionality of AutoCAD Civil 3D by streamlining the process of transferring field-captured survey data to
and from the office.
Survey Workflow (page 26)

Survey Overview
You can use the complete set of tools in AutoCAD Civil 3D to import survey data, perform surveying
calculations, and automate symbol placement and line work.
AutoCAD Civil 3D survey data and figures persist in a survey database, and can be accessed using multiple
drawings attached to the same AutoCAD Civil 3D survey database.
The survey database stores angle values in Radians and distance values in Meters. Survey data is transformed
according to the database units for the purposes of display and input. AutoCAD Civil 3D drawing units can
be independent of the survey database units. If drawing objects are imported from the survey database and
the AutoCAD Civil 3D drawing units and coordinate zone differ, the objects are transformed.
During the field survey data collection process, you can use a coding convention established in AutoCAD
Civil 3D to automate the conversion of field survey data, collected with data collection equipment, into
AutoCAD Civil 3D linework.

207

Imported Survey data without linework coding

Linework created by importing survey data using linework coding

Survey objects and their components are displayed based on their styles. Before creating survey components,
you should be familiar with creating and managing styles (page 66).

Establish Survey Settings
Define and manage the following survey settings:
Figure Prefix Database

Determine the display and properties of
figures.

Survey Equipment Database

Establish an error model for a specific survey instrument when analyzing survey data
using least squares.

Survey Database Settings

Control the default settings for all database
properties.
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User Settings

Control the default settings for survey
specific properties.

Linework Code Set

Define the codes that are used in the filed
to determine the connectivity of linework
from point descriptions.

Survey Feature Settings

Control the default styles for figures and
networks.

For more information about settings, see Survey Settings (page 227).

Import and Edit Survey Data
You can import and modify survey data in the AutoCAD Civil 3D environment and use the AutoCAD Civil
3D drawing session to graphically display the survey data. Use the AutoCAD Civil 3D survey data to affect
other AutoCAD Civil 3D data, such as points and surfaces.
Survey Data Collection Link

Convert raw survey observation data to a
field book file (.fbk) that can be imported
into an AutoCAD Civil 3D survey database.

Import Survey Data Wizard

Use the Import Survey Data wizard to import field book files, point files, and
LandXML files or to select points in the
drawing.

Import Commands

Use the commands available from a network to import a field book, point file, or
points in a drawing.

Import Survey Land XML

Import Survey LandXML data into the survey database.

Import Events

An import event is created each time a
data source is imported into the survey
database. Use import events to process
linework and re-import data with existing
settings, also to delete only the data created from the import event.

Add survey data to a network

Use the commands from within a network
collection to create or edit control points,
non-control points, directions and observations from a network.

Survey Command Window

Perform coordinate geometry operations
using specific survey commands, along
with the options to record input and output, and to re-run the input from a batch
file.

For more information about input and figures, see Adding and Editing Survey Data (page 279) and Survey
Figures (page 347).
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Perform Analysis Adjustments
Using traverse and least squares adjustments, you can reduce field data for analysis.
Define a traverse

Perform Compass, Crandall, Transit, and
Least Squares analysis.

Least Squares analysis

Perform 2D or 3D network least squares
analysis. Update points in the survey database and the linework input.

Mapcheck Analysis

Check the closure of values from label objects based on the precision of the annotation of the label object, or enter mapcheck
data manually.

For more information, see Survey Analysis and Output (page 389).

Export Survey Data
You can output and export survey data:
Export survey data

Export data as a field book or Survey
LandXML file.

Define surface breaklines

Use survey figures as breaklines when you
create a surface model.

Update the survey objects in the drawing

Select a survey object in the drawing and
use short-cut menus to update the drawing
object on the Prospector tab.

Survey Project Phases
Organize survey data by creating networks within the survey database for the various stages of a project.
Throughout a survey project it may be necessary to perform several types of survey tasks such as a site
analysis, a boundary analysis, and a topographic survey.
In AutoCAD Civil 3D you can create multiple networks within a survey database and append survey data
to the survey database to maintain the integrity of existing survey data. The benefits of multiple networks
are:
■

Each network can represent a specific purpose.

■

Each network can be analyzed and adjusted separately, but can reference data from another network.

■

When you create figures by importing data into a network, that network contains information as to
which figures will need to be updated if the network is modified.

Site Analysis Phase Workflow
In the first phase of a project, a preliminary analysis of a site is necessary to determine if the project is feasible.
As an example of this phase, a survey crew would go to the site with a mapping grade GPS data collector to
map wetlands that have been delineated on the site. This information is imported into a survey network of
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the project's survey database and overlaid onto a map of the area along with other relevant information,
such as a steep slope analysis of the site’s topography.
To accomplish this phase in AutoCAD Civil 3D:

Create a new project (page 146)

In Toolspace on the Prospector tab choose Master
----- View and create a new project or create a local
survey database.

Check out the Survey Database
(page 143)

If you are working with the project management
----- tools, open the Survey database for editing and
import the wetland mapping points and line
features.

Create a network with a relevant name to the site
Create a new survey network (page
----- (<name>_Site Analysis) and import the points and
224)
line work into the survey database.

Boundary Survey Phase Workflow
In the second phase, a boundary survey is performed to locate physical evidence and establish horizontal
and vertical control on the site.
After determining that a site development is feasible and deed research is completed, a survey crew performs
a boundary survey. Survey grade GPS control is established on the site to provide a tie onto the State Plane
coordinate system. When the boundary survey is completed, the data (survey observations and linework)
is imported into another survey network in the same project survey database. The data is analyzed to
determine positional error and the network is adjusted.
To accomplish this phase in AutoCAD Civil 3D:

Create a new survey network in the
----- Create a network with a relevant name
project database (page 224)
(<name>_Boundary Survey).

Import the field book file (page 267) ----- Import the survey data into the survey database.

Perform traverse and least squares
----- Determine error of closure and positional accuracy
analysis (page 389)
and adjust the survey data.
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Boundary Analysis Phase Workflow
In the third phase, the boundary is closed and a survey figure is created.
To maintain the integrity of the boundary survey network, you can create a new network and perform
iterative coordinate geometry calculations. The parcel can be closed by creating a survey figure from the
coordinate geometry calculations in conjunction with the points located in the field. You can query the
survey figure to report the figure inverse and area. The figure can then be inserted into a drawing as the basis
of a new subdivision.
To accomplish this phase in AutoCAD Civil 3D:

Create a new survey network in the
----- Create a new network with a relevant name
project survey database (page 224)
(<name>_Boundary Analysis).

In the Survey Command Window, use the Survey
Perform coordinate geometry
calculations on the network (page ----- Command Language, commands to close the
parcel and create a survey figure by performing
2697)
coordinate geometry calculations.

Mapcheck (page 384) and Figure
----- Query the figure to report mapcheck and figure
Inverse (page 385)
inverse.

Insert the figure into a drawing
(page 351)

----- The new figure can be used a basis in creating a
subdivision layout.

Topographic Survey Phase Workflow
In the last phase, a topographic survey of the proposed road locations is performed.
The topographic survey supports the engineering of the street grades, upgrade of the access from existing
streets, site drainage, and driveway access to the proposed building sites. The topographic survey is based
on the horizontal and vertical control established from the boundary survey network. After completing the
topographic survey, the data is imported into a new survey network. This survey network references control
from the boundary survey, and creates additional survey points and linework that can be used to create a
terrain model for the site engineering.
To accomplish this phase in AutoCAD Civil 3D:

Create a new survey network (page
----- In the survey database, create a new network with
224)
a relevant name (<name>_Topo).
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Import the topographic survey
data (page 267)

----- Import topographic survey data into the survey
network using the Import Field Book command.

Create a new drawing (page 132) ----- Create a new drawing that contains the surface
for the site engineering.

Create a point group and add the
----- Create a new point group and add the survey
survey points (page 561)
points.

Create a new surface (page 648)

----- Create a new surface and add the point group to
the surface.

Add the survey figures as breaklines
----- Add the survey figures (located in the topographic
(page 349)
survey) to the surface as breaklines.

Edit the surface (page 660)

----- Perform additional edits on the surface, such as
editing the surface boundary.

Working with Vault Project
Drawings (page 176)Adding a
Drawing to a Project (page 177)

----- Add the drawing with the new surface to the
project if you are using project management.

Example: Using Networks with Import Events and Survey Data
The following descriptions of survey phases show an example of using networks and import events with
survey data.
Phase One
■

A survey is being done on a parcel of land by multiple survey crews. The survey will be analyzed within
a single survey network, for example a least squares network analysis.
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■

The data from each survey crew is downloaded into separate .fbk files and each .fbk file is imported into
the same network, creating a separate import event. During each import, potential point identifier (point
name or point number) conflicts can be resolved by applying a point identifier offset, and linework can
be processed using the specified linework code set.

■

The network is analyzed creating adjusted control points for each setup and updated coordinates for
each sideshot within each setup. The coordinates for each figure are updated in each import event.

Phase Two
■

In a later stage of the civil engineering process, an additional survey has to be performed to establish
control for construction stakeout of proposed roads and parcel corners.

■

This additional survey ties into the network that was adjusted in phase one and also requires a least
squares analysis.

■

A new network is created, and for each survey data file that is imported into this network an import
event is created.

Survey User Interface
Manage, analyze, and edit survey data using the Toolspace Survey tab, the Survey collection in the Prospector
tab, the Survey collection in the Settings tab, the Survey Command Window, and various panorama vistas.

Survey Tab
Use the Survey tab in Toolspace to access and manage survey settings, survey-related databases, and survey
project data.
For more information about the Survey tab, see The Toolspace Survey Tab (page 115).

Survey Collection (Prospector Tab)
Use the Survey collection on the Prospector tab in Toolspace to access survey data contained in the drawing.
As you insert survey network and figure objects into the drawing, they are displayed in the Prospector Survey
collection.
Expand the Survey collection to view the names of the survey components and display a tabular list of the
components in the Prospector list view. For more information, see The Toolspace Item View (page 99).
Since the Prospector tab displays only the drawing representations of survey data, you manipulate and edit
the data in the Survey tab.
To browse to survey data from the Prospector tab
■

In Toolspace, on the Prospector tab, right-click a network object or a figure object ➤ Browse To Survey
Data.
The Survey tab is displayed, and the selected network is displayed in the Survey tree, or the selected figure
is displayed in the Figures Editor in the Panorama window.

To update a network or figure drawing object from survey data
■

In Toolspace, on the Prospector tab, right-click a network object or a figure object ➤ Update From Survey
Data.
The drawing object is updated with the data in the survey database.
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To update survey data from the drawing
■

In Toolspace, on the Prospector tab, right-click a figure object ➤ Update Survey Data From Drawing.
The survey database is updated with changes made to the selected figure object.

Survey Collection (Settings Tab)
Use the Survey collection in the Settings tree to manage survey drawing settings and survey styles.
Right-click the Survey collection to edit survey feature settings. For information about survey feature settings,
see Edit Feature Settings - Survey Dialog Box (page 2670).
Expand the Survey collection to display and edit the styles that are available for survey objects. For
information, see Survey Styles and Display (page 216).

Survey Command Input
Use the Survey Command Window to access survey input and analysis functionality with menu choices, or
you can enter survey commands directly.
For more information about the Survey Command Window layout and options, see Survey Command
Window (page 2697).

Survey Command Language
The survey command language (which is also used in field book files) is one way to enter survey data into
AutoCAD Civil 3D.
Commands entered at the survey command line use a specific syntax. For information about the syntax and
available commands, see Survey Command Reference (page 419).
To display the Survey Command Window
■

In Toolspace, on the Survey tab, expand the Network collection. Right-click a network item. Click Survey
Command Window.

Quick Reference
Toolspace
Survey tab: ➤ right-click <named network> ➤ Survey Command Window
Dialog Box
Survey Command Window (page 2697)

Survey Objects
Survey networks and figures persist in AutoCAD Civil 3D drawings as drawing objects.
■

Network object. Represents a survey network or traverse in the drawing. The network object is a read-only
object that cannot be edited in the drawing. If the network is modified in the database, the survey network
displayed on the Survey tab in Toolspace indicates that it needs to be updated.

■

Figure object. Represents a survey figure in a drawing.
The figure object can be edited in the drawing (depending on how the figure is defined), but it displays
as out-of-sync with the survey database. The survey database can be updated from the figure drawing
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object. If other drawings have the same figure in a drawing and the survey database has been updated,
their drawing figures are shown as out-of-date and can be updated from the survey database.
When a figure with a Lot Line property is inserted into the drawing, an AutoCAD Civil 3D site is created
in the drawing (if it does not exist) and parcel segment objects are created in the site that is specified for
the figure. If the figure is closed, a parcel object of the same geometry is added. If not, then parcel segments
are added to the site for the figure geometry.
■

Survey Point. A special type of COGO Point that is read-only in a drawing session. However, the display
properties of a Survey Point can be modified in the points or point groups collection on the Prospector
tab in Toolspace. A survey point is read-only in the drawing, because a survey point may have dependent
data, such as an Angle, Distance, Vertical Angle, Prism Height, from a specific instrument setup.

Survey drawing network and figure objects are displayed in the Toolspace Prospector tab under the Survey
collection.
For general information about AutoCAD Civil 3D objects, see Understanding Objects and Styles (page 63).

Survey Styles and Display
Use the survey styles to control the way that survey networks and figures are displayed in a drawing.
The survey styles are accessed and managed on the Settings tab in Toolspace, where you can create, edit,
copy, and delete them. For more information, see The Object Style Collection (Settings Tree) (page 111).
There are two survey-related styles:
■

Network styles. Include display control for survey network components, including known and unknown
control points, non-control points, sideshot lines and sideshot points, direction lines, network lines,
error ellipses, and tolerance error points and lines. You can also control the network marker styles and
3D geometry display. For more information, see Survey Network Style Dialog Box (page 2711).

■

Figure styles. Include display control for survey figure components, including plan and model markers,
and 3D display. For more information, see Survey Figure Style Dialog Box (page 2707).

For more general information about styles, see Object and Label Styles (page 66).
To create a network style
1 In Toolspace, on the Settings tab, expand the Survey collection. Right-click the Network Styles collection.
Click New.
2 In the Network Style dialog box, click the Information tab and enter a name and description for the
style.
3 To specify the styles for markers and the error ellipse scale factor in the network, click the Components
tab. For information on the components about this tab, see Components Tab (Survey Network Style
Dialog Box) (page 2711).
4 To specify the 3D geometry display of the network, click the 3D Geometry tab and specify the settings.
5 To define the display of the various network components, including network lines, points, and error
ellipses, click the Display tab.
6 To view summary information about the style, click the Summary tab.
7 Click OK.
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To create a figure style
1 In Toolspace, on the Settings tab, expand the Survey collection, right-click the Figure Styles collection,
and click New.
2 In the Figure Style dialog box, click the Information tab and enter a name and description for the style.
3 To define figure marker placement and styles, click the Markers tab and specify the options. For
information about the components on this tab, see Plan and Model Tab (Survey Figure Style Dialog
Box) (page 2707).
4 To specify the 3D geometry display of the figure, click the 3D Geometry tab and specify the settings.
5 To define the display of the various figure components, including figure lines, and markers, click the
Display tab.
6 To view summary information about the style, click the Summary tab.
7 Click Apply.
To edit a survey style
1 In Toolspace, on the Settings tab, right-click the name of the network or figure style that you want to
edit and click Edit.
2 In the Style dialog box, change the properties of the style as required.

Survey Databases
In AutoCAD Civil 3D, survey data is not drawing dependent and is stored in an external database. For display
and visualization, survey data can be manually and automatically inserted into a drawing when the survey
database is updated or when data is imported into the survey database.
The Survey database consists of two files, the.sdbx file is the main survey database and it contains all the
data in the survey database collections except for the Extended Properties definitions and values. The Survey
.sdxx file contains the Extended Properties definitions and values.
NOTE Survey databases from versions prior to AutoCAD Civil 3D 2011 will be converted to Microsoft® SQL Server®
Compact 3.5. New and converted survey database files have the file extensions SDBX and SDXX.
IMPORTANT To support a 64-bit operating system in AutoCAD Civil 3D 2011, survey database files, equipment
database files, and figure prefix database files must be migrated to a new format. On the Survey tab in Toolspace,
a database item that requires migration will display the "out-of-date" icon to provide a visual cue that it requires
migration. To complete the migration, right-click the item and select the migration command.

Survey Database
Use the Toolspace Survey tab to create local survey databases. You can subsequently create a new AutoCAD
Civil 3D Project from the existing local survey database.
A survey database contains all the control points, known directions, observation measurements, traverse
definitions, figures, and standard deviations based on equipment data for the survey database. This includes
observations imported from data collector files, entered from the Toolspace Survey tab, the survey editors
(for example, Traverse Editor and Observation Editor), and Survey Command Window.
A survey database is displayed on the Toolspace Survey tab under the Survey Databases collection.
By default, survey databases are local and do not use the AutoCAD Civil 3D project management functionality.
You can subsequently create a new AutoCAD Civil 3D Project from the existing local database. When a new
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AutoCAD Civil 3D project is created from Prospector, a new Survey database is automatically created and
must be checked out to add or modify data.
NOTE AutoCAD Civil 3D project management determines the working folder, therefore the databases that are
displayed in the working folder may vary depending on whether you are logged in or logged out.
For more information about AutoCAD Civil 3D project management, see Project Management (page 143).

Using a Local Survey Database
Use the Toolspace Survey tab to create local survey databases.
Each local survey database is stored in the project working folder, for example: Civil 3D Projects\<project
name>. You can set the current working folder from either the Survey Databases collection on the Survey
tab or in the Projects folder on the Prospector tab if you have Vault Explorer installed.
A survey database is displayed on the Toolspace Survey tab as a named survey database item under the Survey
Databases collection.
To create a local survey database
1 In Toolspace, on the Survey tab, right-click the Survey Databases collection.
2 Click New Local Survey Database.
3 In the New Local Survey Database dialog box, enter the name for the database.
The database is created and displayed in bold text under the Survey Databases collection.
To change the location for local survey databases
1 In Toolspace, on the Survey tab, right-click the Survey Databases collection.
2 Click Set Working Folder.
NOTE If you have Vault Explorer installed you can also set the working folder on the Prospector tab in the
Projects collection.
3 In the Browse For Folder dialog box, browse to the working folder location.
Survey databases in the working folder are displayed in the Survey Databases collection and all local
survey databases that you subsequently create are stored in this location.
NOTE By default, to save on resource usage, when you start AutoCAD Civil 3D, all survey databases are displayed
in a closed state.
To open or close a survey database
1 In Toolspace, on the Survey tab, right-click the named survey database. Click Open For Edit or Open
For Read-only. If you double click the database it opens in read-only mode. A database in read-only
mode always displays
and the only option provided is to open in for read-only. Writable databases
opened in read-only mode will display this icon only while they are open.
The named survey database is displayed in bold text and it is expanded to display the Networks, Network
Groups, Figures, Figure Groups, Survey Points, and Survey Point Groups collections.
NOTE Only one survey database can be open at a time.
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2 To close an open database, in Toolspace, on the Survey tab, right-click the named database. Click Close
Survey Database.

Quick Reference
Ribbon
Click Home tab ➤ Palettes panel ➤ Open Survey Toolspace
Toolspace
Survey tab: expand Survey Databases ➤ right-click <database name> ➤ Open For Edit
or
Open For Read-only
To close a survey database click Survey tab: expand Survey Databases ➤ right-click <database name> ➤
Close Survey Database

Sharing a Survey Database on a Network
Multi-user access to a survey database on a network has changed due to the new Microsoft® SQL Server®
Compact 3.5 format.
NOTE If a survey database is located on a shared folder on the network and is opened for editing, it is opened
exclusively and all others are prevented from opening it, even in read-only mode. If the survey database is only
opened as read-only, others can also open it as read-only.
To open a survey database for edit
■

On the Survey tab in Toolspace, right-click a database ➤ Open For Edit.
This command gives exclusive write access to the database. All other users are prevented from accessing
the database, either for edit or read-only mode.

To open a survey database for read-only
■

On the Survey tab in Toolspace, right-click a database ➤ Open For Read-only.
Multiple users can access the database in read-only mode and browse to and consume the data.

A database that is open for read-only mode displays a

icon.

TIP Double-click a closed database to open it in read-only mode. Double-click an open database to display the
Survey Database Settings dialog box.

Adding a Survey Database to a New Project
Create a new AutoCAD Civil 3D project from an existing survey database to take advantage of the standard
project management functionality when accessing survey databases.
After you add a survey database to a project, you must check it out to make changes to the survey data.
For more information about AutoCAD Civil 3D project management, see Project Management (page 143).
To create a new AutoCAD Civil 3D project from an existing survey database
1 In Toolspace, on the Survey tab, right-click the survey database. Click Add To New Project.
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NOTE The Add To New Project menu item is displayed if you have logged into Vault. For information, see
Logging in to a Vault Server (page 169).
2 In the Add To New Project dialog box, the database name is displayed. The project icon is displayed
next to the survey database name to indicate that the survey database is contained in an existing
AutoCAD Civil 3D project.
3 In Toolspace, click the Prospector tab, expand the Projects collection and right-click the newly created
project to access the standard project management functions. See Working with Vault Projects (page
169).
NOTE If the Projects collection is not visible, click Master View from the list.

Quick Reference
Toolspace
Survey tab: expand Survey Databases ➤ right-click <database name> ➤ Add To New Project

Translating a Survey Database
Use this command to perform a simple translation of a selected survey database.
This command is useful when you need to move all the data in the survey database from an assumed location
to a known location, subsequent to importing the survey data into AutoCAD Civil 3D.
Translate the selected database by specifying a base point, rotation angle, destination point, and optional
elevation.
To translate a survey database
1 Click Survey tab ➤ Modify panel

Translate Database.

2 On the Translate Survey Database Base Point page, enter a point number from the open database or
click Pick In Drawing and select a point in the drawing. Click Next.
NOTE If the base point exists as a survey point within the survey database, the Name, Easting, Northing,
Elevation, Description, Latitude, and Longitude property values are displayed.
3 On the Translate Survey Database Rotation Angle page, click the value cell and enter a rotation angle.
Click Next.
4 On the Translate Survey Database Destination page, click the value cell and enter Easting, Northing,
and optional Elevation Change values. Click Next.
5 On the Translate Survey Database Summary page, review the values for Base Point, Destination Point,
and Translation. Click Finish.

Quick Reference
Ribbon
Click Survey tab ➤ Modify panel
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Translate Database

Menu
Survey menu ➤ Translate Survey Database
Toolspace
Right-click <database name> ➤ Translate Survey Database
Command Line
TranslateSvDatabase

Survey Database Change Report
Use the Survey Change Reporting feature to report any changes that are made to a survey database.
When you enable logging in the Survey Database Settings, each time you open the survey database a .log
file opens and any changes in the survey database are recorded.
The .log file is located in the project folder and uses the project name by default. The file contains the log
events in XML format, but the .log file is not the report.The .log file is formatted based on the Change
Reporting settings that are specified in the Survey User Settings. To display the report, you select the Display
Change Report command from the survey database on the Survey tab in Toolspace.
To create a database change report
1 In Toolspace, on the Survey tab, click

.

2 In the Survey User Settings dialog box, under the Change Reporting property, specify the Report Style
Path and Report Style. The report style is a style sheet (.xsl file) that is used in conjunction with an XML
file.
3 Right-click the database ➤ Edit Survey Database Settings.Under the Change Reporting property, select
Logging Enabled. This setting is off by default.
4 Right-click a survey database ➤ Display Change Report. The report is generated by reading the .log file
and formatted using the Change Report Style (.xsl).

Quick Reference
Toolspace
Survey tab ➤ expand <named> survey database ➤ right-click <named> network ➤ Display Change Report

Survey Equipment Database
The survey equipment database contains one or more equipment definitions.
Equipment definitions specify the values associated with a specific surveying instrument, such as the standard
deviations associated with the measuring capabilities.
NOTE Equipment databases that have been migrated to XML format have the file extension EDB_XDEF.
For information on equipment definition settings, see Equipment Database Manager Dialog Box (page 2672).
To create an equipment database
1 In Toolspace, on the Survey tab, right-click the Equipment Databases collection. Click New.There is a
default equipment database named ‘Sample,’ which is displayed in the Equipment Databases collection.
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2 In the New Equipment Database dialog box, enter a name for the new equipment database.
NOTE A best practice is to enter the model number or the name of the equipment manufacturer in the
Name field.
3 To enter equipment definitions, right-click the equipment database and click Manage Equipment
Database.
4 In the Equipment Database Manager dialog box, enter a name for the Sample equipment definition
and modify other properties as required. For more information about the equipment properties, see
Equipment Database Manager Dialog Box (page 2672).
To make an equipment database current
■

In Toolspace, on the Survey tab, expand the Equipment Databases collection. Double-click a database
to make it current or right-click the database ➤ Make Current.

To add or edit an equipment definition
1 In Toolspace, on the Survey tab, expand the Equipment Databases collection. Right-click a named
equipment database ➤ Manage Equipment Database.

2 In the Equipment Database Manager dialog box, click
default name Sample.

. The new definition is added with the

3 Expand Sample and under Miscellaneous enter a name for the definition. Modify the properties as
required. For more information about the equipment properties, see Equipment Database Manager
Dialog Box (page 2672)
To delete an equipment definition
1 In Toolspace, on the Survey tab, expand the Equipment Databases collection. Right-click the database
that contains the definition that you want to delete ➤ Manage Equipment Database.
2 In the Equipment Database Manager, select the definition you want to delete and click

.

Quick Reference
Toolspace
Survey tab: right-click Equipment Databases
or
Survey tab: Equipment Databases ➤ right-click <database-name>
or
Survey tab: Equipment Databases ➤ <database name> ➤ right-click <equipment-definition-name>

Survey Figure Prefix Database
The survey figure prefix database contains information to determine the layer that a figure is drawn on, how
a figure is stylized, and whether figures are created as breaklines and lot lines.
When figures are imported or created, they are matched based on their names and the prefix names. When
a figure is created and its name is matched with a figure prefix, the figure prefix properties are assigned to
the new figure, such as a layer name.
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Figure prefixes are also used to determine linework connectivity when you use the Process Linework command.
Any point that is coded with a name that matches a figure prefix is treated as an active feature. The Process
Linework command may begin a figure when it encounters a prefix match if there is not an active figure
with the same name and if the current Linework Code Set setting Automatic Begin On Figure Prefix Match
is set to Yes.
For information about specifying the default path and location for figure prefix database, see Setting the
Figure Prefix Database (page 230).
To create a figure prefix database
1 In Toolspace, on the Survey tab, right-click the Figure Prefix Databases collection. Click New.
2 In the New Figure Prefix Database dialog box, enter a name for the new figure prefix database.
3 To create a figure prefix definition, right-click the figure prefix database. Click New.
4 In the Figure Prefix Properties dialog box, enter a name for the figure prefix definition and modify other
properties as required. For more information about the figure properties, see Figure Prefix Database
Manager Dialog Box (page 2677).
To add or delete a figure prefix definition
5 In Toolspace, on the Survey tab, expand the Figure Prefix Databases collection. Click New.
6 Right-click a database ➤ Manage Figure Prefix Database.

7 In the Figure Database Manager, click

. A new line called Sample is added to the database manager.

8 Click Sample and enter a new name. Specify the remaining values.
9 Repeat steps 7 and 8 for each new definition.
To delete a figure prefix definition
10 Select the definition you want to delete. Click

.

To make a figure prefix database current
■

In Toolspace, on the Survey tab, expand the Figure Prefix Databases collection. Right-click the figure
prefix database. Click Make Current.

To copy a figure prefix definition
1 In Toolspace, on the Survey tab, expand the Figure Prefix Databases collection. Right-click the named
figure prefix database ➤ Manage Figure Prefix Database.
2 In the Figure Prefix Databases dialog box, select a figure definition and click the
copied to the end of the list.

. The definition is

Quick Reference
Toolspace
Survey tab: right-click Figure Prefix Databases
or
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Survey tab: Figure Prefix Databases ➤ right-click <database-name>
or
Survey tab: Figure Prefix Databases ➤ right-click <database name> ➤ Manage Figure Prefix Database

Survey Networks
A survey network is a series of interconnected lines that represent the observed instrument setups, or stations.
It contains all associated known control points, known directions, setups, and observations.
TIP Use the Import Survey Data command to create a network and import data using the wizard interface. For
more information, see Import Survey Data Wizard (page 261).
After you have imported or created data in the survey network you can insert the network into your AutoCAD
Civil 3D drawing as a network object. For information about survey objects, see Survey Objects (page 215).
The following illustration shows the network components:

Tips for working with Networks
■

In a drawing you can hover your mouse over any network component to display a tooltip with component
information.

■

In the drawing, select a network component and right-click for options to browse to the survey data on
the Survey tab, edit, or update the data.

■

In Survey Toolspace, you can change the network display order using drag and drop functionality. When
you drag and drop a network it is inserted after the network on to which it is dropped. Drag a network
and drop it on the Networks collection to have it display first in the list.

■

You can drag and drop a Network from the Survey tab in Toolspace into the drawing.

■

Create a new network for each phase of a surveying project.
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■

Create a new survey network to use the Survey Command Window to perform calculations involving
points from other existing survey networks. Data that you input is captured in the batch file, where you
can make edits and run the file again with the corrections, if necessary, without affecting the integrity
of the other survey networks.

To create a survey network
■

In Toolspace, on the Survey tab, expand the survey database. Right-click the Networks collection. Click
New.

To insert a survey network into the drawing
■

In Toolspace, on the Survey tab, expand the survey database, expand the Networks collection, right-click
the named network, and click Insert Into Drawing.

■

In Toolspace, on the Survey tab, select the network and drag and drop the selection onto an open drawing
in the AutoCAD Civil 3D.

A survey network object is created in the drawing. Browse to the Survey collection in the Toolspace Prospector
tab to view and modify the network object.
To view survey network data in the drawing
■

In the drawing, hover your cursor over a network object component to display a tooltip with relevant
data.

To browse to survey network data from the drawing to the Survey tab in Toolspace
■

In the drawing, use CTRL + Select to select a network object sub-component, such as a sideshot point,
and right-click to display commands for browsing to the survey data. The Survey tab is displayed (if
hidden) and the survey database item is highlighted.

Quick Reference
Toolspace
Survey tab: expand Projects ➤ <project name> ➤ right-click Networks ➤ New
or
Survey tab: expand Projects ➤ <project name> ➤ expand Networks ➤ right-click <named network> ➤
Insert Into Drawing

Browsing to a Survey Network
Browse to a network in the Networks collection on the Survey tab in Toolspace.
The survey network is highlighted in the Networks collection on the Survey tab in Toolspace.
To browse to a survey network
■

Click Survey tab ➤ Modify panel ➤ Browse To Survey Data

■

Click Survey menu ➤ Browse ➤ Browse To Network. Double click a network name on the Survey tab in
Toolspace to display the network in the drawing, or click a network in the drawing to highlight the
network on the Survey tab.

Browse To Network

.
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Quick Reference
Ribbon
Click Survey tab ➤ Modify panel ➤ Browse To Survey Data
Menu
Survey menu ➤ Browse ➤ Browse To Network
Command Line
BrowseToSvNetwork
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Browse To Network

9

Survey Settings

Before using the AutoCAD Civil 3D survey features, review and modify the settings that define survey user defaults, drawing
settings, database settings, and equipment settings.

User Settings
Survey user settings are specific to a Windows user login account and affect only the survey features, not
project or drawing data.
Specify the default settings for importing and exporting survey data and the display of interactive graphic
components.
Tips for working with Settings
■

Default Survey Database Settings can be set up and can then be used each time you create a new survey
database.

■

Survey database settings can be exported to file with a *.sdb_set extension.

■

Survey User Settings can be exported to a *.usr_set file.

■

You can create a .sdb_set for imperial or metric survey database settings, or for use with for specific
coordinate zone.

■

Have everyone in your organization use the same path for the Survey User Settings.

Setting the Survey Database Defaults
Specify the settings for survey database features.
To specify the survey database defaults
1 Click Survey tab ➤ Modify panel

Edit User Settings

.

2 In the Survey User Settings dialog box, expand the Survey Database Defaults property group.
3 Under Survey database settings path, specify the path to where survey database settings files are located.
This path should be in a common location within an organization.
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4 Under Survey database settings, select a survey database settings file from the drop list. All files with a
*.sdb_set extension are listed. The settings in this file are used whenever a new survey database is created
by AutoCAD Civil 3D.
5 Under, Extended properties definition path, specify the path to where Extended Properties definitions
are located. This path should be a common location within an organization.
6 Under Extended properties definition, specify an extended properties definition file from the list. All
files in the extended properties definition path that has a *.sdx_def extension is listed.
For information about the setting equipment properties, see Equipment Database Manager Dialog Box (page
2672).

Quick Reference
Ribbon
Click Survey tab ➤ Modify panel

Edit User Settings

Menu
Click Survey menu ➤ Edit User Settings.
Toolspace
Survey tab:
Dialog Box
Survey User Settings Dialog Box (page 2726)

Setting the Current Equipment Database
Specify the current equipment, equipment database, and equipment database path.
The current equipment sets the values associated with a specific surveying instrument, such the standard
deviations associated with the measuring capabilities for the equipment. This information is used in various
calculations including Least Squares.
To specify the current equipment database
1 Click Survey tab ➤ Modify panel

Edit User Settings

.

2 In the Survey User Settings dialog box, expand the Equipment Defaults property group.
3 Under Equipment Database Path, enter the path for the survey equipment databases or click
browse to the folder. This is the path where all new equipment databases are stored.

to

4 Under Current Equipment Database, select the current database from the drop-down list.
The list of available databases is determined from the databases contained in the Equipment Databases
collection in the Toolspace Survey tab.
5 Under Current Equipment, select the current equipment from the drop-down list.
For information about the setting equipment properties, see Equipment Database Manager Dialog Box (page
2672).
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Quick Reference
Ribbon
Click Survey tab ➤ Modify panel

Edit User Settings

Menu
Click Survey menu ➤ Edit User Settings.
Toolspace
Survey tab:
Dialog Box
Survey User Settings Dialog Box (page 2726)

Setting the Linework Processing Defaults
Specify the default path for the linework code set.
A linework code set interprets the syntax of the field codes that are entered into the data collector by the
survey field crew.
To specify the linework processing defaults
1 Click Survey tab ➤ Modify panel

Edit User Settings

.

2 In the Survey User Settings dialog box, expand the Linework Processing Defaults property group.
3 For Linework Code Sets Path, enter the path for the linework code or click
This is the path where all linework code set files are stored.

to browse to the folder.

4 For Process Linework During Import, select the check box to process linework during the import.
Linework can also be processed after the import is completed.
WARNING In the Import Settings, clear the Process Linework check box if you are importing the following:
■

.fbk files created from the Survey Data Collection Link application because Linework Codes Set
definitions may not be recognized. However, the figure commands created using the Survey Data
Collection Link are recognized.

■

.fbk files that were created in Autodesk Land Desktop or in a previous version of AutoCAD Civil 3D.
Using the Process Linework command on these files may create duplicate and erroneous figures.

5 For the Current Linework Code Set, select a linework code set from the list.
6 For the Process Linework Sequence, select one of the following from the list:
■

By Import Order - processes points in the order which they are imported. Point names are always
processed by import order.

■

By Point Number - processes points sequentially by point number (ascending order only).

For more information about linework processing settings, see Survey User Settings Dialog Box (page 2726).
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Quick Reference
Ribbon
Click Survey tab ➤ Modify panel

Edit User Settings

Menu
Click Survey menu ➤ Edit User Settings.
Toolspace
Survey tab:
Dialog Box
Survey User Settings Dialog Box (page 2726)

Setting the Figure Prefix Database
Specify the current and default figure prefix database and database path.
Figure prefixes enable you to determine the layer that a figure is drawn on, how a figure is stylized, and
whether figures are created as breaklines and lot lines. When figures are imported or created, they are matched
based on their names and the prefix names. All figures with a specific prefix are assigned the properties of
the prefix.
To specify the figure prefix database
1 Click Survey tab ➤ Modify panel

Edit User Settings

.

2 In the Survey User Settings dialog box, expand the Figure Defaults property group.
3 For Figure Prefix Database Path, enter the path for the figure prefix databases or click
the folder. This is the path where all new figure prefix databases are stored.

to browse to

4 For Current Figure Prefix Database, select the current database from the drop-down list.
The list of available databases is determined from the databases contained in the Figure Prefix Databases
collection on the Toolspace Survey tab.
For more information about figure prefix settings, see Survey User Settings Dialog Box (page 2726).

Quick Reference
Ribbon
Click Survey tab ➤ Modify panel

Edit User Settings

Menu
Click Survey menu ➤ Edit User Settings.
Toolspace
Survey tab:
Dialog Box
Survey User Settings Dialog Box (page 2726)
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Specifying External Editor Settings
Specify whether to use an external editor for displaying analysis input and output and for editing field book
and batch files.
To specify the external editor settings
1 Click Survey tab ➤ Modify panel

Edit User Settings

.

2 In the Survey User Settings dialog box, expand the Miscellaneous property group.
3 For Use External Editor, select the check box to use an external editor.
NOTE If you do not specify to use an external editor, the default editor, specified in the AutoCAD Options
dialog box, is used.

4 For External Editor, enter the path and name for the editor or click

to browse to the editor.

Quick Reference
Ribbon
Click Survey tab ➤ Modify panel

Edit User Settings

Menu
Click Survey menu ➤ Edit User Settings
Toolspace
Survey tab:
Dialog Box
Survey User Settings Dialog Box (page 2726)

Specifying Interactive Graphics Settings
Use Interactive Graphics settings to control the display of survey components during import and entry of
survey data.
NOTE The interactive graphics are temporary.
Examples of survey interactive graphics:
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foresight prism

station transit
foresight line

current figure

backsight line

figure vertex

backsight prism

baseline
baseline offset line
baseline prism

To specify interactive graphics settings
NOTE Using interactive graphics when you are importing a field book file significantly slows the import process.
1 Click Survey tab ➤ Modify panel

Edit User Settings

.

2 In the Survey User Settings dialog box, expand the Interactive Graphics property group.
3 Select the check boxes for the interactive graphics that you want to display.
For descriptions of the interactive graphic components, see Survey User Settings Dialog Box (page 2726).
4 Optionally, to change the colors for the components, click the color swatch to open the Select Color
dialog box, from which you can select a color.

Quick Reference
Ribbon
Click Survey tab ➤ Modify panel

Edit User Settings

Menu
Click Survey menu ➤ Edit User Settings.
Toolspace
Survey tab:
Dialog Box
Survey User Settings Dialog Box (page 2726)
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Setting Import Defaults
Specify the Import Defaults properties for importing a field book or batch files into the selected project
network.
To specify import defaults
1 Click Survey tab ➤ Modify panel

Edit User Settings

.

2 In the Survey User Settings dialog box, expand the Import Defaults property group.
3 Select the check boxes for the defaults that you want to enable.
For descriptions of the import defaults, see Survey User Settings Dialog Box (page 2726).
4 Optionally, for Default Figure Site property, enter a site name.
If the site does exists in the current drawing, it is created, or if it exists, it is used.
NOTE The site is used if the Lot Line property for the figure is true and the Site property for the figure is not
specified.

Quick Reference
Ribbon
Click Survey tab ➤ Modify panel

Edit User Settings

Menu
Click Survey menu ➤ Edit User Settings.
Toolspace
Survey tab:
Dialog Box
Survey User Settings Dialog Box (page 2726)

Reporting Tolerance Errors
Display tolerance errors in the Event Viewer at the completion of survey data import or run the command
from the network collection or an individual network on the Survey tab.
Tolerance errors are based on the values you specify in the Survey Database Settings (page 2698). At the
completion of importing survey data into the survey database, tolerance errors (in the network) that exceed
these values can be displayed as events in the Event Viewer. In the Survey User Settings dialog box (page
2726) - Import Defaults, specify Yes for Display Tolerance Errors In Event Viewer.
The Report Tolerance Error command can be run at anytime from the right-click shortcut menu on the
Networks collection or an individual network.
You can override the default settings in the Import Survey LandXML (page 2681), Import Field Book (page
2679), and Batch File (page 345)dialog boxes.
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To report tolerance errors at the completion of importing survey data
■

In the Survey User Settings - Import Defaults, specify Yes for Display Tolerance Errors In Event Viewer.
The event viewer is displayed at the completion of any import function if the data contains tolerance
errors.

To report tolerance errors
■

On the Survey tab in Toolspace right-click the Networks collection or a <named> network ➤ Report
Tolerance Errors.

Quick Reference
Toolspace
Survey tab: expand Survey Databases ➤ right-click Networks collection or right-click <named> Network ➤
Report Tolerance Errors

Tolerance Errors Display in the Event Viewer
Use the event viewer to review and edit tolerance errors.
If you have specified Display Tolerance Errors In Event Viewer in the Survey User Settings (page 2726) and if
the network contains tolerance errors, the following items are displayed the Event Viewer at the completion
of a survey import command.
NOTE You can also run the Report Tolerance Error command from the right-click shortcut menu on the Networks
collection or an individual network.
Column

Description

Tree tab

Displays the tolerance error and the associated network.

Type

Displays the tolerance error as a warning
using the warning icon.

Date

Displays the system date of the event.

Time

Displays the system time of the event.

Source

Displays the name of the network that
contains the tolerance error.

User

Displays the Windows user log in.

Description

Displays the Point ID and the tolerance error type.

More information

Click Zoom To to zoom to the tolerance
error in the drawing.

Action

Click Browse To to display the Observations
Editor. The observation with the tolerance
error is highlighted.
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Column

Description
NOTE The Survey Database must be open
to use the Browse To link.

See also:
■

Event Viewer Vista (page 2753)

Setting Export Defaults
Use the Export Defaults to specify the properties for exporting survey data to a field book file.

Figure Export Conditions and Formats
When you select the Export Figures With Network property, the format of the figure data exported to the
field book is dependent on the conditions of the survey data as shown in the following.
NOTE For more information about the syntax in the following section, see the Figure Commands (page 426).
■

If the figure vertex has a point number, then the figure vertex is defined by referencing the point in the
field book file:
BEG <figure name>
PT <point ID>

■

Then the following lines are added to the field book file:
NE SS <point ID> <north> <east> <elevation> <description>
BEG <figure name>
PT <point ID>

■

Then the following line is added to the field book file defining the figure vertex:
FIG NE <north> <east>

■

If the figure segment is a curve, then the curve segment is defined using the XC ZD (BULB) command.
The BULB parameter is used when the delta angle for the curve is greater than 180 degrees.

■

If both ends of the curve segment reference point IDs, then the following format is output:
XC ZD (AZ <point ID> <point ID>) (D <point ID> <point ID>)

■

Otherwise the following format is output:
XC ZD <Azimuth> <Distance>

Point Export Conditions and Format
If you select the Export Point Identifiers property, for each figure vertex, the following formats are output
to the field book file.
NOTE For more information about the syntax in the following section, see the Figure Commands (page 426).
■

If the figure vertex has a point ID, then the following lines are added to the field book file:
BEG <Figure name>
PT <point ID>

■

If the vertex does not reference a point ID, then the following lines are added to the field book file:
BEG <figure name>
FIG NE <north> <east>
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■

If Export Point Identifiers property is not selected, the following lines are added to the field book file:
BEG <figure name>
FIG NE <north> <east>

■

If the figure segment is a curve, then the curve segment is defined using the XC ZD (BULB) command.
The BULB parameter is used when the delta angle for the curve is greater than 180 degrees.

■

If both ends of the curve segment reference point numbers (and if this check box is selected), then the
following format is output:
XC ZD (AZ <point ID> <point ID>) (D <point ID> <point ID>)

■

Otherwise the following format is output:
XC ZD <azimuth> <distance>

When the Export Point Data is enabled, for each figure vertex that references a point ID, the following
format is output to the field book file prior to the section defining the figures:
NE SS <point ID> <north> <east> <elevation> <description>
To specify export defaults
1 Click Survey tab ➤ Modify panel

Edit User Settings

.

2 In the Survey User Settings dialog box, expand the Export Defaults property group.
3 Select the check boxes for the defaults that you want to enable.
For descriptions of the properties, see Survey User Settings Dialog Box (page 2726).

Quick Reference
Ribbon
Click Survey tab ➤ Modify panel

Edit User Settings

Menu
Click Survey menu ➤ Edit User Settings.
Toolspace
Survey tab:
Dialog Box
Survey User Settings Dialog Box (page 2726)

Setting Display Preview Behavior
Use the Network Preview, Setup Preview, and Figure Preview settings to specify the preview properties when
an item is selected in the Toolspace Survey tab.
NOTE The previews use the colors set by the Interactive Graphics settings. For information, see Specifying Interactive
Graphics Settings (page 231)
To specify display preview behavior
1 Click Survey tab ➤ Modify panel
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Edit User Settings

.

2 In the Survey User Settings dialog box, expand the Miscellaneous property group and edit the Preview
Vertical Exaggeration setting.
3 In the Survey User Settings dialog box, expand the Network Preview, Setup Preview, and Figure Preview
property groups.
4 Select the check boxes for the components that you want to display in the previews.

Quick Reference
Ribbon
Click Survey tab ➤ Modify panel

Edit User Settings

Menu
Click Survey menu ➤ Edit User Settings.
Toolspace
Survey tab:
Dialog Box
Survey User Settings Dialog Box (page 2726)

Importing and Exporting User Settings
Import and export existing user settings.
User settings can be exported to a user settings (.usr_set) file and subsequently imported.
To export user settings
1 Click Survey tab ➤ Modify panel

Edit User Settings

2 In the Survey User Settings dialog box, click

.

.

3 In the Save As dialog box, browse to the path where you want to save the settings file and enter a name.
4 Click Save.
To import user settings
1 Click Survey tab ➤ Modify panel

Edit User Settings

2 In the Survey User Settings dialog box, click

.

.

3 In the Open dialog box, browse to the path where the settings file is located and select it.
4 Click Open.
The Survey User Settings dialog box is populated with the settings from the file.
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Quick Reference
Ribbon
Click Survey tab ➤ Modify panel

Edit User Settings

Menu
Click Survey menu ➤ Edit User Settings.
Toolspace
Survey tab:

➤

Command Line
EditSvUserSettings

Database Settings
Survey database settings are specific to the survey features of an AutoCAD Civil 3D survey database.
By default, the survey database settings are stored in the C:\Civil 3D Projects\<database name>\Survey.sdb
file.
To edit survey database settings, the survey database must be open.

Setting Measurement Units
Use the Units settings to specify project units including coordinate zone, distance, angle, direction,
temperature, and pressure.
NOTE The survey database units are independent from the drawing units. If the survey database units and drawing
units are different, the survey data is transformed when it is inserted into the drawing.
To specify survey database measurement units
1 In Toolspace, on the Survey tab, expand the Survey Databases collection, right-click on the database
name, and click Edit Survey Database Settings.
2 In the Survey Database Settings dialog box, expand the Units property group.
3 For the Coordinate Zone property, click
box.

and select the zone in the Select Coordinate Zone dialog

4 For the other unit settings, click the drop-down list and select the value for the unit type that you want
to modify.
For more information about the settings, see the Units section of the Survey Database Settings Dialog
Box (page 2698).

Quick Reference
Ribbon
Click Survey tab ➤ Modify panel
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Edit Database Settings

Menu
Click Survey menu ➤ Edit Survey Database Settings.
Toolspace
Survey tab: Survey Databases ➤ right-click <database-name> ➤ Edit Survey Database Settings
Dialog Box
Survey Database Settings Dialog Box (page 2698)

Setting Unit Display Precision
Use the Precision settings to specify the survey database display precision for units, including angle, distance,
elevation, coordinates, and latitude and longitude.
The precision value specifies the number of digits to display to the right of the decimal.
To specify display precision
1 In Toolspace, on the Survey tab, expand the Survey Databases collection, right-click the project name,
and click Edit Survey Database Settings.
2 In the Survey Database Settings dialog box, expand the Precision property group.
3 Click the value for the unit, and enter the precision value.
For more information about the settings, see the Precision section of the Survey Database Settings Dialog
Box (page 2698).

Quick Reference
Ribbon
Click Survey tab ➤ Modify panel

Edit Database Settings

Menu
Click Survey menu ➤ Edit Survey Database Settings.
Toolspace
Survey tab: Survey Databases ➤ right-click <database-name> ➤ Edit Survey Database Settings
Dialog Box
Survey Database Settings Dialog Box (page 2698)

Setting Measurement Type Defaults
Use the Measurement Type Defaults to specify the default measurement types for the database when adding
new survey data, including angle type, distance type, vertical type, and target type.
For example, the defaults are used for adding new observations in the Observations Editor.
To specify the measurement type defaults
1 In Toolspace, on the Survey tab, expand the Survey Databases collection, right-click on the database
name, and click Edit Survey Database Settings.
2 In the Survey Database Settings dialog box, expand the Measurement Type Defaults property group.

Setting Unit Display Precision | 239

3 Click the drop-down list and select the value for the measurement type that you want to modify.
For more information about the measurement type defaults, see Survey Database Settings Dialog Box
(page 2698).

Quick Reference
Ribbon
Click Survey tab ➤ Modify panel

Edit Database Settings

Menu
Click Survey menu ➤ Edit Survey Database Settings.
Toolspace
Survey tab: Survey Databases ➤ right-click <database-name> ➤ Edit Survey Database Settings
Dialog Box
Survey Database Settings Dialog Box (page 2698)

Setting Measurement Corrections
Use the Measurement Corrections settings to specify measurement corrections to apply to survey observations.
To specify measurement corrections
1 In Toolspace, on the Survey tab, expand the Survey Databases collection, right-click on the database
name, and click Edit Survey Database Settings.
2 In the Survey Database Settings dialog box, expand the Measurement Corrections property group.
3 Select the check boxes for the corrections that you want to enable.
For more information about the settings, see the Measurement Corrections section of the Survey Database
Settings Dialog Box (page 2698).

Quick Reference
Ribbon
Click Survey tab ➤ Modify panel

Edit Database Settings

Menu
Click Survey menu ➤ Edit Survey Database Settings.
Toolspace
Survey tab: Survey Databases ➤ right-click <database-name> ➤ Edit Survey Database Settings
Survey Command Window
Equipment Correction Commands (page 428).
Dialog Box
Survey Database Settings Dialog Box (page 2698)
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Measurement Correction Formulas
The survey corrections are calculated using the following formulas.

Curvature and Refraction Formula
The following formula calculates the vertical angle (in radians):

where:
■

OVA: Old vertical angle (in radians)

■

VA: Vertical angle (in radians)

■

SD: Slope distance

■

R: Spheroid radius (if a coordinate system zone is set, this value is obtained from the zone)

■

k: Coefficient of refraction

Atmospheric Conditions Formula
The following formula determines the slope distance:

where:
■

OSD: Old slope distance

■

SD: Slope distance

■

C: Constant for the EDM carrier (for example, Sokkia Lietz 0.86)

■

P: Atmospheric pressure in mm Hg

■

RI: Group refractive index for EDM carrier (for example, Sokkia Lietz 287.96)

■

T: Dry air temperature in degrees Celsius

Sea Level Formula
The following formula calculates the horizontal distance at sea level:

where:
■

OHD: Old horizontal distance

■

HD: Horizontal distance

■

SE: Station elevation

■

R: Spheroid radius (if a coordinate system zone is set, this value is obtained from the zone)
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Collimation Formulas
The following formulas determine the collimation:
Horizontal collimation:
■

For FACE 1: Horizontal Angle = Measured Horizontal Angle + Horizontal Collimation Error

■

For FACE 2: Horizontal Angle = Measured Horizontal Angle - Horizontal Collimation Error

Vertical collimation (all vertical angles are converted to zenith):
■

For FACE 1: Vertical Angle = Measured Vertical Angle + Vertical Collimation Error

■

For FACE 2: Vertical Angle = Measured Vertical Angle - Vertical Collimation Error

Setting Traverse Analysis Defaults
Use the Traverse Analysis Defaults to specify the database setting defaults for performing a traverse analysis
on survey data.
To specify traverse analysis defaults
1 In Toolspace, on the Survey tab, expand the Survey Databases collection, right-click on the project
name, and click Edit Survey Database Settings.
2 In the Survey Database Settings dialog box, expand the Traverse Analysis Defaults property group.
3 Edit the defaults as required.
For more information about the settings, see the Traverse Analysis section of the Survey Database
Settings Dialog Box (page 2698).

Quick Reference
Ribbon
Click Survey tab ➤ Modify panel

Edit Database Settings

Menu
Click Survey menu ➤ Edit Survey Database Settings.
Toolspace
Survey tab: Survey Databases ➤ right-click <database-name> ➤ Edit Survey Database Settings
Dialog Box
Survey Database Settings Dialog Box (page 2698)

Setting Least Squares Analysis Defaults
Use the Least Squares Analysis Defaults to specify the database setting defaults for performing a least square
analysis on a network or a traverse.
To specify least squares analysis defaults
1 In Toolspace, click the Survey tab, expand the Survey Databases collection, right-click on the database
name, and click Edit Survey Database Settings.
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2 In the Survey Database Settings dialog box, expand the Least Squares Analysis Defaults property group.
3 Edit the defaults as required.
For more information about the settings, see the Least Squares Analysis section of the Survey Database
Settings Dialog Box (page 2698).

Quick Reference
Ribbon
Click Survey tab ➤ Modify panel

Edit Database Settings

Menu
Click Survey menu ➤ Edit Survey Database Settings.
Toolspace
Survey tab: Survey Databases ➤ right-click <database-name> ➤ Edit Survey Database Settings
Dialog Box
Survey Database Settings Dialog Box (page 2698)

Setting Survey Command Window Options
Use the Survey Command Window options to specify the settings that control interaction with the Survey
Command Window.
For information about using the Survey Command Window, see Survey Command Window (page 2697).
To specify survey command defaults
1 In Toolspace, click the Survey tab, expand the Survey Databases collection.
2 Right-click the database name, and click Edit Survey Database Settings.
3 In the Survey Database Settings dialog box, expand the Survey Command Window property group.
4 Edit the settings as required.
For more information about the settings, see the Survey Commands section of the Survey Database
Settings Dialog Box (page 2698).

Quick Reference
Ribbon
Click Survey tab ➤ Modify panel

Edit Database Settings

Menu
Click Survey menu ➤ Edit Survey Database Settings.
Toolspace
Survey tab: Survey Databases ➤ right-click <database-name> ➤ Edit Survey Database Settings
Dialog Box
Survey Database Settings Dialog Box (page 2698)
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Setting Error Tolerance
Use Error Tolerance to specify the maximum difference distance, angle, elevation, and coordinates in point
observations.
If the maximum difference is greater than the specified value, the Event Viewer displays the errors. For more
information, see Reporting Tolerance Errors (page 233).
To specify error tolerance settings
1 In Toolspace, on the Survey tab, expand the Survey Databases collection, right-click on the database,
and click Edit Survey Database Settings.
2 In the Survey Database Settings dialog box, expand the Error Tolerance property group.
3 Edit the settings as required.
For more information about the settings, see the Error Tolerance section of the Survey Database Settings
Dialog Box (page 2698).

Quick Reference
Ribbon
Click Survey tab ➤ Modify panel

Edit Database Settings

Menu
Click Survey menu ➤ Edit Survey Database Settings.
Toolspace
Survey tab: Survey Databases ➤ right-click <database-name> ➤ Edit Survey Database Settings
Dialog Box
Survey Database Settings Dialog Box (page 2698)

Setting Extended Properties
Use Extended Properties to specify if new extended property definitions are to be automatically created
during a Survey LandXML import, or to display warnings in the Event Viewer if required extended properties
have not been assigned during an export of Survey LandXML data.
To specify extended properties settings
1 In Toolspace, on the Survey tab, expand the Survey Databases collection, right-click on the database,
and click Edit Survey Database Settings.
2 In the Survey Database Settings dialog box, expand the Extended Properties property group.
3 Specify Yes to create new definitions automatically when you are importing a LandXML file.
4 Specify Yes to display warnings for required properties that are missing when you export a LandXML
file.

244 | Chapter 9 Survey Settings

Quick Reference
Ribbon
Click Survey tab ➤ Modify panel

Edit Database Settings

Menu
Click Survey menu ➤ Edit Survey Database Settings.
Toolspace
Survey tab: Survey Databases ➤ right-click <database-name> ➤ Edit Survey Database Settings
Dialog Box
Survey Database Settings Dialog Box (page 2698)

Importing and Exporting Survey Database Settings
Import or export existing survey database settings.
Database settings can be exported to a database settings (.set) file and subsequently imported.
To export survey database settings
1 In Toolspace, on the Survey tab, expand the Survey Databases collection, right-click on the database
name, and click Edit Survey Database Settings.
2 In the Survey Database Settings dialog box, click

.

3 In the Save As dialog box, browse to the path where you want to save the settings file and enter a name.
4 Click Save.
To import survey database settings
1 In Toolspace, on the Survey tab, expand the Survey Databases collection
2 Right-click the database name, and click Edit Survey Database Settings.
3 In the Survey Database Settings dialog box, click

.

4 In the Open dialog box, browse to the path where the settings file is located and select it.
5 Click Save.
The Survey Database Settings dialog box is populated with the settings from the file.

Quick Reference
Ribbon
Click Survey tab ➤ Modify panel

Edit Database Settings

Menu
Click Survey menu ➤ Edit Survey Database Settings.
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Toolspace
Survey tab: Survey Databases ➤ right-click <database name> ➤ Edit Survey Database Settings ➤
or
Survey tab: Survey Databases ➤ right-click <database name> ➤ Edit Survey Database Settings ➤

Equipment Properties
The survey equipment properties specify the values associated with a specific surveying instrument, such as
the standard deviations associated with the measuring capabilities for the equipment. This information is
used in the Least Squares calculations.
The equipment property groups are:
■

Miscellaneous. Specifies the name and description of the equipment that is displayed in the equipment
database.

■

Angle. Determines how an instrument measures angles.

■

Units. Determines the unit types for angle and distance.

■

Electronic Distance Meter (EDM). Determines the Electronic Distance Measuring settings.

■

Prism. Sets the Prism accuracy, offset, and constant.

■

Standard deviations. Specifies the accuracy of the surveying equipment. These values are used in calculating
the standard errors that are displayed in the Least Squares input file.

NOTE For detailed descriptions of the equipment properties, see Equipment Database Manager Dialog Box (page
2672).
To set the equipment properties
1 In Toolspace, on the Survey tab, expand the Equipment Databases collection, and expand the database
name.
2 Right-click on the equipment name and click Properties.
NOTE For information about creating equipment databases, see Survey Equipment Database (page 221).
3 Edit the properties as required.
For more information about the settings, see the Equipment Database Manager Dialog Box (page 2672).

Quick Reference
Toolspace
Survey tab: Equipment Databases ➤ <equipment database name> ➤ right-click <equipment name> ➤
Properties
Dialog Box
Equipment Database Manager Dialog Box (page 2672)
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Survey Drawing Settings
You can use survey drawing settings to specify the default behavior for drawing-related survey commands.
Drawing settings are handled in a standard way throughout AutoCAD Civil 3D. You access drawing settings
using the Toolspace Settings tab. You can control these settings at three levels: the drawing level, the object
collection (feature) level, and the command level. It is important to understand how the different levels of
settings work together. For more information, see Understanding Settings (page 77).
Use the Survey collection in the Settings tab to establish defaults for survey-related commands. You can
change either survey-specific settings at this level or override the drawing ambient settings.
NOTE Overrides to the drawing ambient settings at the Survey collection level affect only the specified level. The
drawing level settings are not changed.
The topics in this section describe only those settings that affect survey-related commands, and do not cover
the drawing ambient settings that you can change at the survey collection level, even though those settings
are displayed in the Edit Feature Settings - Survey dialog box. For more information, see Specifying Ambient
Settings (page 84).
To change the survey feature settings
1 In Toolspace, on the Settings tab, right-click Survey ➤ Edit Feature Settings.
2 In the Edit Feature Settings dialog box (page 2670), make changes to the existing settings.
3 Click OK to save the changed settings in the drawing.

Quick Reference
Toolspace
Settings tab: right-click Survey ➤ Edit Feature Settings
Dialog Box
Edit Feature Settings - Survey Dialog Box (page 2670)
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Survey Field to Finish

10

Refer to this section for a description of the commands you can use to import and process survey data in AutoCAD Civil
3D.
Field to Finish (page 2774) is a general term used to describe the surveying process that determines the connectivity and
symbology of points surveyed in the field that match the feature name and field code (page 2774) that is defined in a AutoCAD
Civil 3D linework code set (page 2777), and the description keys that are defined for the current drawing. A field code is
contained within the description of a survey point, and typically contains both the name of the point feature or line
feature, and a special line segment or curve segment code to indicate connectivity between survey points of the same
feature. During the processing of linework, the linework code set interprets the syntax of the field code within a survey
point description. When you insert points into the drawing from the survey database, the display of the survey points is
determined by a raw description match with the description keys in the drawing.
For more information, see Description Keys (page 571).

Preparing to Import Survey Data
To successfully bring data from the field into AutoCAD Civil 3D, it is important to understand the interaction
between field codes, the linework code set, description keys, and the figure prefix database.
Perform the following setup tasks before importing survey data:
■

Establish consistent point coding and linework connectivity. For more information, see Field Codes,
Figure Prefixes, and Description Keys (page 250).

■

Create a Linework Code Set based on the point coding and linework connectivity. For more information,
see Linework Code Sets (page 252).

■

Define the Survey User Settings. For more information, see User Settings (page 227).

■

Define the Survey Database Settings. For more information, see Database Settings (page 238).

■

Create a Survey Equipment Database. For more information, see Survey Equipment Database (page 221).

■

Create a Figure Prefix Database and figure prefixes. For more information, see Survey Figure Prefix Database
(page 222).

■

Create Description Key Sets and description keys. For more information, see Creating Description Keys
(page 584).

■

Import survey data based on a drawing template (*.dwt) that contains established styles and layers. For
more information, see Drawing Templates (page 127).
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Perform the following tasks after importing survey data:
■

View data in an import event and re-import the data if necessary. For more information, see Import
Events (page 274).

■

Edit survey point properties and reprocess linework. For more information, see Editing Survey Point
Properties (page 275) and Processing Survey Linework (page 276).

■

Create a traverse and perform traverse analysis. For more information, see Survey Analysis and Output
(page 389).

■

Use the Survey Command Window and survey command language to batch process and record coordinate
geometry operations. For more information, see Survey Command Reference (page 419).

Field Codes, Figure Prefixes, and Description Keys
Surveyors locate existing features on the ground using systems, such as a total station or a GPS unit, that
are configured with data collectors. For each surveyed point, the surveyor assigns a field code that describes
the point feature or line feature and that is then saved in the data collector. Line features contain a line
command code that indicates whether the line is a beginning, a continuation, an end, a curve segment, or
a line segment. In AutoCAD Civil 3D, the syntax of the field code corresponds to a previously defined
linework code set. The correspondence between the field codes and the linework code set allows for the
following:
■

Automatic assignment of COGO point properties such as Layer, Symbol, and Label when inserted into
the drawing

■

Automatic assignment of line feature properties, such as Layer, Color, Linetype, and Lineweight when
inserted into the drawing

■

Line connectivity between the COGO points

An example of a field code is EP1 B, where:
■

EP = the standard abbreviation that a company uses to represent an edge of pavement

■

1 = the first edge of pavement that is located

■

B = the code in the linework code set to begin a figure
NOTE NOTE: When you import survey data, you can omit the Begin code if the feature name matches a
figure prefix that is defined in the current figure prefix database. If the feature name does not match a figure
prefix, you must specify a Begin code.

Field codes are associated with both the figure prefix database and the description keys in the current drawing.
If EP has been defined in the figure prefix database, then EP1 matches EP and is assigned the properties of
the EP figure prefix, such as layer, figure style, breakline. If the survey point with the description EP1 B is
placed in a drawing that has a description key of EP*, then EP1 B matches description key EP* and is assigned
the point properties defined in the EP* description key, such layer, point style, point label style.
The following table lists examples of features coded in the field and the field code assigned to the feature,
and the description keys and Figure prefixes created in AutoCAD Civil 3D to support the field codes:
Feature

Field Code

Description Key Figure Prefix

Edge of pavement

EP<ID>

EP*

Utility Pole

UP<ID>

UP*

250 | Chapter 10 Survey Field to Finish

EP

Feature

Field Code

Description Key Figure Prefix

Fence Line

FCE<ID>

FCE*

FCE

Centerline

CL<ID>

CL*

CL

Ditch Line

DL<ID>

DL*

DL

Edge of Gravel

EG<ID>

EG*

EG

Sewer Manhole

SMH<ID>

SMH*

Storm Manhole

DMH<ID>

DMH<ID>

The following illustration shows an example of feature definitions:

The following illustration shows these feature codes:
■

1: BC (back of curb)

■

2: TC (top of curve)

■

3: FL (flow line)

■

4: EP (edge of pavement)

■

5: CL (centerline of existing roadway)

■

6: Point located in the field by a surveyor
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Linework Code Sets
A linework code set interprets the syntax of the field codes that are entered into the data collector by the
survey field crew. Linework Code sets are displayed on the Toolspace Survey tab. Specify the default linework
code set in the Survey User Settings. An import event (page 2776) stores the linework code set that was last
used to process linework for that event.
To create a new linework code set
1 On the Survey tab in Toolspace, right-click the Linework Code Sets collection ➤ New.
2 In the New Linework Code Set dialog box, enter a unique file name.
3 In the Edit Linework Code Set dialog box, specify values for the following:
■

Information

■

Coding Methods

■

Special Codes

■

Line Segment Codes

■

Curve Segment Codes

For more information, see Examples - Linework Codes (page 253).
4 Click OK.
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For more information, see Edit Linework Code Set Dialog Box (page 2670).
To copy or edit an existing linework code set
1 On the Survey tab in Toolspace, expand the Linework Code Sets collection.
2 Right-click the existing linework code set and click Copy or Edit.
3 In the Edit Linework Code Set dialog box, enter a unique file name.
By default, the Edit Linework Code Set dialog box displays the values of the copied file.
4 Edit the values and click OK.

Quick Reference
Toolspace
Survey tab: right-click Linework Code Sets ➤ New, Edit, or Copy

Examples - Linework Codes
The following tables provide examples of linework code set properties.

Coding Methods
WARNING It is recommended that you use <space> as the Field/Code Delimiter Property Value. Using decimal
characters as the Field/Code Delimiter Property Value may cause certain codes to fail. For example the (decimal).
character is valid for a right-turn value and the (minus sign) - character is valid for a negative right-turn value.
Property

Example

Description

Feature/Code Delimiter:
code that indicates the
separation of the feature name from the
code.

EP1 B SW1 B

A “ “ (space) is the recommended delimiter.

Field Code Escape: code
that indicates that anything entered after the
escape indicator is a
comment.

EP1 SW1 B/Start of
sidewalk

A / (forward slash) is the recommended
escape. Start of sidewalk is a comment.
You can enter and exit comment mode
using multiple slashes. In the following
example, /parking space line/is a comment and ignored. EP1 B/parking space
line/LN CPN211.

Automatic Begin on
Figure Prefix Match

EP1 B

Select Yes to specify that in EP1 B, EP1
matches the figure prefix of EP, and B is
the Begin code.
Specify No, if you do not want the first
instance of EP1 to automatically start a
new figure named EP. To start a new figure named EP, when EP1 is not an active
figure, enter a code for the point as EP1
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Property

Example

Description
B, where B is the Begin code in the current linework code set.

Special Codes
Property

Example

Description

Begin: code that indicates the start
of a new figure at the specified
point.
If a figure prefix exists that matches
the figure name, you can omit the
Begin code. This works best with
unique figure names.

EP1 B SW1 B or B EP1
B SW1

EP1 and SW1 are figure names. The letter
B is the special code used to begin new figures named EP1 and SW1.

Continue: code that indicates a
figure is continued from its last
vertex.

EP1 C SW1

The figure is continued with an explicit
<Continue code>. EP1 is a figure name, C
continues the active figure named EP1
If the field code does not contain an explicit
<Continue> code and the figure name
within the field code matches an active figure, the figure is continued.

End: code that indicates the figure
is terminated.

EP1 E SW1 B

EP1 is the figure name, “ “ (space) is the
Field/Code Delimiter, E is the End code and
continues an active figure with the name
EP1 to this point and then it is terminated
(it is no longer an active figure). SW1 is a
figure name, “ “ (space) is the Field/Code
Delimiter, and B is the Begin code and starts
a new figure named SW1. In this example,
if there is an existing figure named SW1 it
is terminated at its last vertex, and a new
figure named SW1 is started at this point.

Close: code that indicates that an
active figure is continued from its
last vertex to the current point and
closes the figure with a line segment back to the starting vertex
for that figure.

EP1 SW1 CLS

EP1 is a figure name and if it matches an
active figure it is continued to this point.
SW1 is a figure name and if it matches an
active figure it is continued from its last
vertex to this point, CLS is the Close code
and a line segment is closed back to the
starting vertex for the figure SW1.

Horizontal Offset: code used to
specify a relative horizontal offset
for creating a parallel figure starting at the current point, or transitioning to another offset if the
active figure has a previous horizontal offset.

101,500,490,100.01,BC1
B H-4 V.1 H.5 H.75 V.7 H2.25 V-.35
...
112,500,500,100.02,BC1
...
123,500,510,100.03,BC1
...
134,500,520,100.04,BC1
...

Point 101: BC1 is the line feature name, " "
(Space) is the Feature/Code delimiter, B is
the <Begin> code, H is the <Horizontal offset> code, -4 is the value for the first horizontal offset value, V is the <Vertical offset>
code, .1 is the first vertical offset value, and
so on for each of the remaining 3 offsets.
Points 112, 123, 134, 145, and 156: BC1
figure with current offsets are continued.
Point 167: BC1 is continued, but the offset

254 | Chapter 10 Survey Field to Finish

Property

Vertical Offset: code used to specify a relative vertical offset starting
at the current point. A value must
follow the Vertical offset code.

Example

Description

145,500,530,100.05,BC1
...
156,500,540,100.06,BC1
...
167,500,550,100.07,BC1
SO
...
178,500,560,100.08,BC1

figures are stopped by the SO <Stop offsets>
code. Point 178: BC1 is continued.
A value must follow the Horizontal offset
code. A negative value offsets the active
figure to the left and a positive value offsets
the active figure to the right. Multiple offsets
can be used, but if subsequent horizontal
or vertical transitions are made, all previous
horizontal offset or vertical offset codes must
be specified for each offset.

(Shown in the following illustration)

A positive value is added to the elevation of
the current vertex for the active figure and
a negative value is subtracted from the current vertex for the active figure. If a Vertical
offset is specified with no previous Horizontal offset, the Horizontal offset value is assumed to be zero. If a Horizontal offset is
specified with no Vertical offset or no previous Vertical offset, the Vertical offset value
is assumed to be zero.
NOTE If a previous horizontal or vertical
offset was specified in the current point
code, and if a subsequent horizontal or
vertical offset is omitted within the current
field code, the previous horizontal or vertical
offset value is used. For example:
V1 H1 H2 = H0 V1 H1 V1 H2 V1
H1 H2 V1 H3 = H1 V0 H2 V1 H3 V1

Stop Offsets: code used to specify
the termination of all offsets on the
active figure. Only the active figure
can be continued.

(Shown in the following illustration)

The following illustration shows an example using the codes for Horizontal Offsets, Vertical Offsets, and
Stop Offsets:
1,500,490,100.01,BC1 B H-4 V.1 H.5 H.75 V-.7 H2.25 V-.35
2,500,500,100.02,BC1
3,500,510,100.03,BC1
4,500,520,100.04,BC1
5,500,530,100.05,BC1
6,500,540,100.06,BC1
7,500,550,100.07,BC1 SO
8,500,560,100.08,BC1
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Line Segment Codes
Property

Example

Description

Recall Point: code used to connect
the active figure with a segment
from the last point, or a specified
pointID.

EP1 RPN
EP1 RPN101

EP1 is the figure name and continues an active figure if the name
matches. RPN is the Recall Point
code and if there is no point it
connects from the previous point
to the current point and inserts a
segment before the current point.
The code EP1 RPN101 connects
from the current point to the indicated point.

Connect Point: code used to indicate the creation of a new figure (of
the same feature) with a single line
segment from the current point to
the specified point ID. The specified point ID follows the Connect
Point code.

EP1 B CPN101

In this example, a new figure is
created at the current point, and
also another new figure with a
single line segment is drawn to
point 101, called EP1.CPN101. The
figure name can be modified using
the Figure Properties command.

The Connect Point code always creates a figure composed of a single line segment. The following illustration
shows an example of the Connect Point code:

256 | Chapter 10 Survey Field to Finish

Property

Example

Description

Rectangle: code used to offset the
segment coming into the current
point by the specified number.

BLD1 <Rectangle>40

A positive number indicates an
offset to the right, a negative
number indicates an offset to the
left, which is relative to the direction of the line segment coming in
to the current point. If no number
follows the Rectangle code, this
code closes the figure by performing a perpendicular/perpendicular
line intersection between the previous segment coming into the current point and the first segment of
the figure.
NOTE A Rectangle code without
a number requires at least three
points previously located on the
current figure.

The following illustration shows the Rectangle code with a specified value of 40:

Right Turn: code used with a line
segment code to allow for additional vertices to be inserted perpendicular into the figure, or as extensions (straight offsets).

BLD1 RT X10.1 5 -12.2 -5 -12.2

Continues an active figure BLD1
to the current point, extends the
current segment 10.1 units, and
then draws perpendicular segments for each value.
Offset values, <Extend>, or <Rectangle> codes follow the <Right
turn> code. Positive numbers indicate a jog to the right and negative
numbers indicate a jog to the left.
NOTE Use <Extend><Value> to
make an extension straight ahead
by using a positive # or behind by
using a negative #.
NOTE Use the <Rectangle> code
to complete the <Right turn> code,
closing back to the starting segment as a perpendicular/perpendicular line intersection from the current figure line segment.

The following illustration shows examples of the Right Turn code and the Rectangle code:
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Property

Example

Description

Extend: code that is used to make
an extension of a line segment
ahead through the current point
by using a positive value or a line
segment that is short of the current
point by using a negative value.

BLD1 X15.5

BLD1 continues an active figure,
X is the Extend code, and 15.5 is
the value that the figure line segment is extended through the
current point.

The following illustrations show examples of the Extend code, Right Turn code, and Rectangle code:

Curve Segment Codes
Property

Example

Description

Begin Curve: code used to specify
that the current point is the beginning of a single curve (arc) segment or multiple curve segments.

EP1 BC

EP1 is the active figure name and
is continued to the current point,
“ “ (space) is the Feature/Code
Delimiter, BC indicates that the
current point is the beginning of
curve segments.
The current point with this code is
the first point on the curve. The
next point with the same figure
name is considered a point on the
curve, and the third point with the
same figure name is the curve endpoint if no <End curve> code is
used to correspond with the <Begin curve> code.

End Curve: code used with the
<Begin curve> code to define curve
segments with more than three
points. Points on a curve do not
have to be located sequentially.

101 … EP1 BC
112 … EP1
123 … EP1
134 … EP1
145 … EP1 EC

EP1 is the active figure name and
is continued to the current point,
“ “ (space) is the Feature/Code
Delimiter, EC indicates that the
current point is the end of curve
segments.
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Property

Example

Description
Starting at the point with the <Begin curve> code, the linework processor will look for an <End curve>
code. If the <End curve> code is
found, all the points between the
<Begin curve> code and <End
curve> code are used to fit arc
segments of the figure. The curves
pass through each of the points
(similar to the PEDIT/Fit [curve]
option). If no <End curve> is found
following a <Begin curve> code,
then a three-point arc is applied to
the figure.

Circle: code that indicates the beginning of the circle feature. This
code stops the linework on the
previous point if it is a two or
three-point circle.
A one point circle with a radius
value is similar to the connect
point command. The linework
code stops and a new circle is created using the point as the center
point and the radius. The two and
three-point circles behave like begin commands to create a new
figure and end an active feature
with the same name.

POOL CIR5.0

POOL is the figure name, “ “
(space) is the Feature/Code Delimiter, CIR is the <Circle> code, and
creates a new circular figure where
the current point is the radius
point, and 5.0 is the circle radius
value. The elevation of the figure
is the elevation of the current
point. This example uses only the
current point as the center point,
with the <Circle> code followed
immediately by the radius.
Method 1 uses only the current
point as the center point, with the
<Circle> code followed immediately by the radius.
Method 2 uses two consecutive
points to define the circular figure.
The first point defines the center
location and the second point
defines the elevation and the radius.
Method 3 uses three points to
define a circular figure. The elevation of all three points is used and
continues the closure with an arc
instead of a line.

Point On Curve: code to indicate
that the current point resides on a
curve segment.

EP1 OC

EP1 matches the name of an active
figure, “ “ (space) is the Field/Code
Delimiter, and OC is the Point On
Curve code. The figure is continued and the point is evaluated as
a point residing on a curve. If there
is no match to an active figure, EP1
OC may be a point coding error.
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Property

Example

Description

Curve Fit - No curve: In the following illustration, each survey point has the same EP1 figure name and are line
points (no <Point on curve> code indicating a curve point, or <Begin curve> code). The resulting figure is a
series of connected line segments.

Curve Fit - One point on curve: In the following illustration each point has the same EP1 figure name, and one
survey point is a coded as a curve point (OC <Point on curve> code). The resulting figure will have a calculated
point of curvature (PC) and point of tangency (PT), and the curve will pass through the point.

Curve Fit - Three-point curve: In the following illustration, each point has the same EP1 figure name, and there
is three consecutive curve points (OC <Point on curve> code, or BC <Begin curve> code at the beginning of
the curve). The resulting figure will have a begin curve (BC) at the first EP1 point, an end curve (EC) at the
third EP1 point, and the curve will pass through the second EP1 point.

Curve Fit - Multi-point curves: In the following illustration, each point has the same CL1 figure name, and
there are more than three consecutive points with an OC <Point on curve> code, or the first point on the curve
segments has a BC <Begin curve> code and the ending point of the curve segments has an EC <End curve>
code. The resulting figure will have a beginning of curve (BC) at the first CL1 point, and an end of curve (EC)
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Property

Example

Description

at the last CL1 point. Compound and reverse curves will pass through each point between the BC figure vertex
and the EC figure vertex.

Importing Survey Data
Import data using the wizard or import commands in the survey network.

Import Survey Data Wizard
Use the wizard to easily import survey data.
In the Import Survey Data wizard you have options for importing field book files, point files, points from
the drawing, or Survey LandXML files. Importing data using this method creates an Import Event. For more
information, see Import Events (page 274).
To import survey data using the wizard
1 Click Home tab ➤ Create Ground Data panel ➤ Import Survey Data

.

2 On the Specify Database page, select an existing database or click Create New Survey Database.
3 On the Specify Data Source page, select one of the following options:
■

Field Book File

■

LandXML File

■

Point File(When you import a point file, you must specify or create a point file format.)

■

Points From Drawing

4 On the Specify Network page, specify a network or click Create New Network.
NOTE Click None if you are importing project points that you do not want associated with a network. This
option is only available when you import points from a point file.
5 On the Import Options page, specify the import settings.
6 Click Finish.
An import event is created in the Import Events collection for the survey database.
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Quick Reference
Ribbon
Click Home tab ➤ Create Ground Data panel ➤ Import Survey Data
Toolspace
Survey tab: expand Survey Databases ➤ expand <named> database ➤ right-click Import Events ➤ Import
Survey Data
Command Line
ImportSurveyData

Importing Point Files
Use the Import Point File command to import points into the Survey database and network as control points
or non-control points.
In the import settings, you have an option for linework processing. The selected point file format determines
the column order, (P,N,E,Z,D), the delimiter, and coordinate zone of the file being imported. If you select
the Process Linework option, the point file format must contain a Raw Description column. A point file
format with a coordinate system zone that is different from the coordinate zone assigned to the Survey
Database will require a transformation.
Each time you import a point file, a point group is created on the Prospector tab in Toolspace. The file name
for the file you import is the default point group name.
TIP You can also use the Import Survey Data wizard to import point files. For more information, see Import Survey
Data Wizard (page 261).
To import a point file
1 In Toolspace, on the Survey tab, right-click a <named> network.
2 Click Import ➤ Import Point File.
3 Browse to the file you want to import and click Open.
4 Make any necessary changes to the Import Point File settings and click OK.

Quick Reference
Ribbon
Click Home tab ➤ Create Ground Data panel ➤ Import Survey Data
Toolspace
<named> network ➤ Import ➤ Import Point File

Importing Multiple Point Files
Using the Import Survey Data wizard or the Import Point File command, you now have the option to import
multiple ASCII point files, and also import points using a point file format that contains user-defined
properties.
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To import point files
1 On the Ribbon, click Home tab ➤ Import Survey Data.
2 In the Import Survey Data Wizard - Specify Database page, select a database or create a new one.
3 In the Import Survey Data Wizard - Specify Data Source page, select Point File as the Data Source Type.
4 Click
, and browse to the file(s) that you want to import. Use control-click to select multiple files
of the same format.
5 In the Specify Point File Format list, select the point file format or click New to display the Point File
Formats - Select Type dialog box. For more information on creating point file formats, see Understanding
Point File Formats (page 525).
NOTE The first time you import a with a Caltrans TSS point file format, you must specify a .SYM file or a .DIS
file, and a .RPT file. If you do not specify a .SYM file or a .DIS file, and a .RPT file, the data is imported using
the general properties.
6 In the Import Survey Data Wizard - Specify Network page, select a network or create a new one. If you
are importing project points that you do not want associated with a network, click <none> from the
list of networks. Click Next.
7 In the Import Survey Data Wizard - Import Options page, specify the import settings.
8 Click Finish.

Quick Reference
Ribbon
Home tab ➤ Import Survey Data
Toolspace
Survey tab ➤ expand <named> survey database ➤ right-click <named> network ➤ Import ➤ Import Point
File
or
Survey tab ➤ expand Survey Databases collection ➤ right-click <named> survey database ➤ Import ➤ Import
Point File
Command Line
ImportSurveyData
Dialog Box
Import Survey Data Wizard (page 2685)

Importing Point Files that Contain User-defined Properties
Import point files using point file formats that contain user-defined properties.
When you import an ASCII point file, user-defined attributes described in the point file format are mapped
to the user-defined properties in the survey database. If a matching property does not exist then it is created.
The user-defined attribute data for the points is stored as extended data using the same attribute data system
as the LandXML extended properties. These properties are managed on the Survey tab in the Manage Extended
Data collection in a survey database.
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In the Manage Extended Properties dialog box, on the Survey Points node there is a new right-click menu
option to Insert Into Drawing. When you use this option it forces the creation of the Survey-defined extended
properties in the current drawing.
When new attributes are created in the survey database during an ASCII point file import, the data type of
the drawing side attribute is replicated in the survey database, for example, Station would map to Station.
Also, when attributes are mapped back to the drawing, the data type is preserved. For more information, see
Managing Survey Extended Properties (page 271).

Limitations
■

Enumeration type attributes are not recognized by survey and are ignored during the attribute creation
and data mapping process.

■

Attributes that are displayed on the Survey tab in Toolspace are formatted using the units and the display
format that is defined in the survey database and user settings. The attribute units and display are not
based on the current Drawing Settings.

■

Attributes that are initially created in a drawing and then added to the survey database during import
do not map back to the same drawing side attribute when you add survey data to the drawing. Survey
creates a new survey specific attribute definition in the drawing. For example: a string attribute "Address"
that is created in the drawing would round trip back to the drawing as "Point.Address" within the Survey
User-defined classification.

■

User-defined Property support is only available for ASCII point file import using external point files and
the Point File Formats. User-defined Properties are not supported when you import points directly from
a drawing or from field book files.

To import point files that contain user-defined properties
1 In Toolspace, on the Survey tab, right-click the survey database collection ➤ New Local Survey Database.
Enter a name
2 Right-click the new database ➤ Manage Extended Properties.
TIP Importing the LandXML Property definitions before you create new user-defined properties can save
time because the LandXML property definitions may match the requirements for the additional properties.
For more information, see Extended Property Definition Files (page 273).
3 Define properties for the Survey Points. Expand the Survey Point node, right click User-Defined ➤ New.
For more information, see Creating and Editing User-defined Properties (page 272).
4 When you have completed creating the Survey Point user-defined attributes, in the Manage Extended
Properties dialog box right-click Survey Points ➤ Insert Into Drawing.
5 In Toolspace, on the Settings tab, expand the Points collection and create a new Point File Format that
uses the new attributes you created in step 3. When you set the column name in the Point File format,
verify that the user-defined properties you created are prefaced with “Point.”. For more information,
see Understanding Point File Formats (page 525).
NOTE When you have completed creating the user-defined properties and the new point file format, save
the drawing as a new drawing template. You can use this template when you want to import points into the
survey database using the customized point file format.
6 Import a point file using the Import Survey Data wizard or the Import Points command. For more
information, see Importing Point Files (page 262).
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Importing Points From a Drawing
Use this command to import points from a drawing into the Survey database and network as control points
or non-control points.
TIP You can also use the Import Survey Data wizard to import points from a drawing. For more information, see
Import Survey Data Wizard (page 261).
To import points from a drawing
1 In Toolspace, on the Survey tab, right-click a <named> network.
2 Click Import ➤ Import Points From Drawing.
NOTE COGO points are imported from the current drawing.
3 At the command line, enter one of the following:
■

All: imports all points in the drawing.

■

Numbers: enter the point numbers you want to import.

■

Group: select the point group you want to import.

■

Selection: select points in the drawing.

4 Make any necessary changes in the Import Points From Drawing settings and click OK.

Quick Reference
Ribbon
Click Home tab ➤ Create Ground Data panel ➤ Import Survey Data
Toolspace
<named> network ➤ Import ➤ Import Points From Drawing

Resolving Duplicate Point Numbers
Resolve duplicate point numbers when you import an ASCII file by re-naming or re-numbering the points.
When you import an ASCII point file and duplicate points are encountered, a dialog box is displayed with
the options for re-naming and re-numbering the duplicate points. You can ignore the duplicate point
number(s), or choose to resolve an individual point conflict or all point conflicts.
The point conflict resolution depends on the type of conflict:
■

If only the number conflicts, and there is a valid name, then only the name is assigned.

■

If only the name conflicts, the name has a sequence number added to the end, for example EOP112.1
or EOP112.2.

■

If the number conflicts and the name is blank, the number is used as the name and with a sequence
number added to the end of the name. For example, if there is a point 112 and no name assigned, point
112 will be hidden and the point is assigned the name 112.1.

■

If the name and number conflict, the number is ignored and a sequence is added to the existing name.
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For all resolutions, the original point name and original point number should be as they appear in the file.
All offsets are applied before the detection of conflicts. In situations where offsets are used, it is possible to
have a name like EOP112.1000.1 if EOP112.1000 is already in the database.
All point conflicts are logged to the Event Viewer where a description of the change is displayed. You can
use the links in the Event Viewer to zoom to and edit the point.

Field Book Files
Import field book files to enter data into the survey database and drawings.
Field book files (.fbk) are text files containing observed point data and figure definitions, which you can
import into a drawing and database. Use the Survey Data Collection Link command to transfer and convert
raw survey data to a field book file (.fbk) that you can import into AutoCAD Civil 3D. For more information,
see Survey Data Collection Link (page 266).

Survey Data Collection Link
Use the Survey Data Collection Link command to transfer data from data collectors and convert the raw
data files and coordinate data files into field book (.fbk) files.
Then you can import the .fbk files using the Import Survey Data wizard or the import command in the survey
network.
NOTE If you are using Windows Vista, you cannot display the Survey Data Collection Link Help files (Link32.hlp
and Survey Attribute Manager.hlp) by default. To display the Survey Data Collection Link Help files in Windows
Vista, download and install the Windows Help program (WinHlp32.exe) from the Microsoft Download Center.

Transferring and Converting Data Using Survey Data Collection Link
Transfer and convert raw data files and coordinate data files into field book (.fbk) files that you can import
into AutoCAD Civil 3D.
To transfer data
1 Click Home tab ➤ Create Ground Data panel
Link DC.

Survey Data Collection Link

to display Survey

Survey Data Collection Link

to display Survey

2 Click Transfer menu ➤ Send/Receive.
To convert data files
1 Click Home tab ➤ Create Ground Data panel
Link DC.

2 Click Conversions menu ➤ Convert File Format.
NOTE For more information, use the Survey Link DC Help.

Quick Reference
Ribbon
Click Home tab ➤ Create Ground Data panel
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Survey Data Collection Link

Menu
Click Survey menu ➤ Survey Data Collection Link
Command Line
StartSurveyLink

Supported Input Types
The Survey Data Collection Link Extension supports the following input types.
AutoCAD DXF

User Defined ASCII

AutoCogo

WILDSoft

ASCII (N,E,Z,Note)

Surv CAD

CLM

ASCII 2

Autodesk-Softdesk

PacSoft Coordinates

ASCII

Maptech

Sierra Cybernetics

MTI

Drafix

Lewis & Lewis

TDS Coordinates

C&G

TDS Raw Data (.rw5)

TDS Raw Data (.raw)

Sokkia SDR Numeric 4

Sokkia SDR Alpha 14

Topcon FC-4

Leica GRE3

SMI

Nikon AP800,700,DTM500,400,300,DR48

Topcon GTS210/220/310 Raw Data

Topcon DL-100 Digital Level

Leica GSI Raw Data

Importing a Field Book File
Enter data into your drawing and survey database by importing an existing field book file.
NOTE In the Import Settings, clear the Process Linework check box when you are importing . fbk files created
from the Survey Data Collection Link application because Linework Code Set definitions may not be recognized.
However, the figure commands created using the Survey Data Collection Link are recognized.
TIP You can also use the Import Survey Data wizard to import field book files. For more information, see Import
Survey Data Wizard (page 261).

Field Book Files | 267

To import a field book file from a network
1 In Toolspace, on the Survey tab, expand the Networks collection and right-click the network to which
you want to import the field book.
2 Click Import ➤ Import Field Book.
3 In the Field Book Filename (.FBK) dialog box browse to the field book that you want to import. Click
Open.
4 In the Import Field Book dialog box, modify settings as required. For information about the settings,
see Import / Re-import Field Book Dialog Box (page 2679).

Quick Reference
Ribbon
Click Home tab ➤ Create Ground Data panel ➤ Import Survey Data
Toolspace
Survey tab: Survey Databases ➤ <database-name> ➤ Networks ➤ right-click <network-name> ➤ Import
➤ Import Field Book

Editing a Field Book File
Use AutoCAD Civil 3D to view and edit an existing field book file.
Load a field book file into a text editor so that you can view or edit it.
NOTE Notepad is the text editor unless you specify another editor in the External Editor in the Survey User Settings
dialog box. For more information, see Specifying External Editor Settings (page 231).
WARNING To work correctly, a field book file must be in an ASCII format.
To edit a field book file
1 In Toolspace, on the Survey tab, expand the Networks collection and right-click on a network name.
2 Click Edit Field Book.
3 In the Field Book Filename (.FBK) dialog box, browse to the field book that you want to edit. Click
Open.
4 The field book contents are displayed in the text editor.
5 Make any necessary changes and save the file.

Quick Reference
Toolspace
Survey tab: Survey Databases ➤ <database-name> ➤ Networks ➤ right-click <network-name> ➤ Edit
Field Book
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Exporting a Field Book File
Export survey data from an individual network, individual figure, or collection of figures to a field book file.
To export a field book file
NOTE A field book can be exported from networks and figures.
1 In Toolspace, on the Survey tab, do one of the following:
■

Expand the Networks collection and right-click the network from which you want to export data
to a field book.

■

Right-click the Figures collection that you want to export to a field book.

■

Expand the Figures collection and right-click a figure name to export it to a field book.

2 Click Export Field Book.
3 In the Save As dialog box, browse to the location where you want to save the field book and enter a file
name. Click Save.
4 If you are exporting a network to a field book, in the Export Field Book dialog box, modify the settings
as required. For information about the settings, see Export Field Book Dialog Box (page 2675).

Quick Reference
Toolspace
Survey tab: Survey Databases ➤ <database-name> ➤ Networks ➤ right-click <network-name> ➤ Export
Field Book
or
Survey tab: Survey Databases ➤ <database-name> ➤ Figures ➤ right-click <figure-name> ➤ Export
Field Book

Survey LandXML Data
You can import and export survey LandXML data directly into or from the survey database.
Use the AutoCAD Civil 3D Import Survey LandXML command to import LandXML survey data directly into
the survey database. You can subsequently insert the data into the drawing, using the Insert Into Drawing
commands.
The following table illustrates the results of importing LandXML data using the Import Survey LandXML
command.
LandXML Data

Results Using Import Survey
LandXML

Parcels

Figures in the survey database

PlanFeatures

Figures in the survey database

COGO points, survey monuments

Survey points in the survey database

Reduced observations

Setups and Observations, control points,
or non-control points in the survey database
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LandXML Data

Results Using Import Survey
LandXML

Raw observations

Setups and Observations in the survey
database

NOTE You can import reduced survey data directly into a AutoCAD Civil 3D drawing. For more information about
the different types of LandXML import functionality for survey data, see Importing Survey XML Data.
You can also export LandXML data from the survey database.
You specify both the LandXML import settings and data selection using the Import Survey LandXML
command.
The LandXML import and export functionality is based on the LandXML schema. For more information
about the LandXML schema, go to http://www.landxml.org.

Importing Survey LandXML Data
Enter data into the survey database and the drawing by importing an existing LandXML.
Survey Point groups and Figure groups are automatically created when you import an .xml file that has
figure groups and survey point groups defined.
TIP You can also use the Import Survey Data wizard to import Survey LandXML files. For more information, see
Import Survey Data Wizard (page 261).
NOTE You can only import a LandXML file into an open survey database. For information about creating and
opening a survey database, see Survey Database (page 217).
To import a LandXML file
1 On the Survey tab in Toolspace, right-click a survey database ➤ Import Survey LandXML.
2 In the Select LandXML File dialog box, browse to the LandXML file that you want to import. Click
Open.
3 In the Import Survey LandXML dialog box, modify the import settings and select the survey data that
you want to import. For information about the import settings, see Import / Re-import Survey LandXML
Data Dialog Box (page 2681).

Quick Reference
Ribbon
Click Home tab ➤ Create Ground Data panel ➤ Import Survey Data
Toolspace
Survey tab: Survey Databases ➤ right-click <database-name> ➤ Import Survey LandXML

Exporting Survey Data to LandXML
Export survey data to a LandXML file using AutoCAD Civil 3D.
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To export survey data to a LandXML file
1 In Toolspace, on the Survey tab, expand the Survey Databases collection and right-click a database
name.
2 Click Export Survey LandXML.
3 In the Export Survey LandXML dialog box, modify the export settings and select the survey data that
you want to export. For information about the settings, see Export Survey LandXML Data Dialog Box
(page 2676).

Quick Reference
Toolspace
Survey tab: expand Survey Databases ➤ right-click <database-name> ➤ Export Survey LandXML

Managing Survey Extended Properties
Use extended properties to import and export Survey LandXML attributes and to create, assign, and view
user-defined attributes.
Using the extended properties command, you can do the following:
■

Import Survey LandXML data and attributes into the survey database.

■

View Survey LandXML attributes and modify user-defined attributes using the AutoCAD Civil 3D Survey
user interface.

■

Export Survey LandXML data (with attributes) to a specified LandXML file.

■

Insert Survey Points into a drawing with the Survey LandXML and user-defined attributes assigned.

■

Complete round-tripping of Survey LandXML and user-defined data using the Import Survey LandXML
and Export Survey LandXML commands on the Survey tab in Toolspace.

Extended Properties User Interface
By default there are no extended properties defined in the sdx_def file.
To display extended properties, you must specify an sdx_def file that contains definitions, or import a
LandXML file with the Create New Definitions Automatically option selected in the Survey Database Settings.
For more information, see Survey Database Settings dialog box. (page 2698)
To display the survey extended properties
1 In the Survey Database Defaults specify the path and the extended properties definition file.
2 In Toolspace, on the Survey tab, expand the Survey Databases collection and right-click a database
name ➤ Manage Extended Properties.
3 In the Manage Extended Properties dialog box, select the check boxes for collections or individual
properties.
For more information, see the Manage Extended Properties dialog box. (page 2687)
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Quick Reference
Toolspace
Survey tab: expand Survey Database ➤ right-click <database-name> ➤ Manage Extended Properties

Creating and Editing User-defined Properties
Use the options in the Manage Extended Properties dialog box to create or edit a user-defined property.
To create or edit a user-defined extended property
1 In Toolspace, on the Survey tab, expand the Survey Databases collection and right-click a database
name.
2 Click Manage Extended Properties. In the Manage Extended Properties dialog box, collections are
displayed for each of the <SurveyFeatureClasses>.
3 In the Manage Extended Properties dialog box, click
to expand the <SurveyFeatureClasses>in the
tree. Each feature class has a collection for LandXML and User-defined.
4 Select a User-defined check box under a feature class, right-click ➤ New or Edit.
5 In the Edit Extended Property dialog box, enter the following:
■

XML Name

■

Display Name

■

Description

6 Select a type in the Property Field Type list. For more information on the display of property fields, see
Property Field Type Table (page 273).
7 Select the Required Value check box to display a warning icon for properties that have not been assigned
to an instance of a <SurveyFeatureClass>. The Event Viewer will also post a warning when you export
the LandXML file using the Export Survey LandXML command.
8 Select the Display check box to have the extended property display on the object.
9 If you specified String as the Property Field Type, enter values for String.
See also:
■

Manage Extended Properties Dialog Box (page 2687)

Quick Reference
Toolspace
Survey tab: Survey Databases ➤ right-click <database-name> ➤ Manage Extended Properties
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Property Field Types Table
Use this table to determine the display of the various Property Field types both in the Survey user interface
and the display of extended properties that are assigned to Survey points in the drawing.
Property Field Types Stored in Survey
Database As

Survey User-interface DWG Formatting
Display

Angle

Angle in radians

SDB Angle

Angle

Area

Square Units in Meters

SDB Square Distance

Area

Azimuth

Direction in Radians

SDB Direction

Direction

Boolean

Boolean

Boolean

Boolean

Coordinate

Distance in Meters

SDB Distance

Coordinate

Dimension

Distance in Meters

SDB Distance

Dimension

Direction

Direction in Radians

SDB Direction and
Angle

Direction

Distance

Distance in Meters

SDB Distance

Distance

Double

Double

Double

Unitless

Elevation

Elevation in Meters

SDB Distance

Elevation

Grade

Double

Double

Grade

Slope

Double

Double

Slope

Integer

Integer

Integer

Unitless

Latitude

Angle in Radians

Signed Angle

Latitude

Longitude

Angle in Radians

Signed Angle

Longitude

Percent

Percent

Percent

Percent

Station

Distance in Meters

SDB Distance

Station

String

String

String

String

Volume

Cubic Meters

Cubic Yards if Foot or
Cubic Meters if Meters

Volume

Extended Property Definition Files
You can edit default .sdx_def files or specify a pre-defined schema with specialized LandXML and User-defined
properties contained in an existing *.sdx_def file.
By default, AutoCAD Civil 3D Survey installs the LandXML - Standard .sdx_def and Sample .sdx_def files at
the following location:
C:\ Documents and Settings\All Users\Application Data\Autodesk\C3D2011\enu\Survey.

Managing Survey Extended Properties | 273

For example, the LandXML - Standard .sdx_def file contains numerous SurveyFeatureClass items. You can
open this file in a text editor and make any necessary edits to streamline this file to meet your needs. Use
the Save As command and then save the file with a new name.

Using Groups to Manage Survey Data
Use Network Groups, Figure Groups, and Survey Point Groups to organize and manage survey data.
Organize LandXML collections of elements, such as CgPoints or PlanFeature collections, using Network
Groups, Figure Groups, and Survey Point Groups. These groups are located at the root collection within a
Survey database item on the Survey tab in Toolspace.
To create a new Network Group, Figure Group, and Survey Point Group
1 In Toolspace, on the Survey tab, expand the Survey Databases collection and expand a database name.
2 Right-click ➤ New for the group you want to create.
3 In the New <type> Group dialog box enter a name and description.
4 In the lower pane of the dialog box, check the items you want to add to the group.
NOTE If you are using the extended properties feature, and have created User-defined properties, they are
displayed. Click the cell in the Value column to assign an attribute.

Quick Reference
Toolspace
Survey tab: Survey Databases ➤ right-click <group-name> ➤ New

Import Events
The import event provides a framework that you can use to view and edit specific survey data that is referenced
within the import event.
An import event is created each time you import data using either the Import Survey Data wizard, the import
commands on the survey network shortcut menu, or the import Survey LandXML command.
Import Events are displayed as a collection within a database on the Toolspace Survey tab. The default name
for the import event is the same as the imported file name "<File name>.<ext>".
The Import Events collection contains the Networks, Figures, and Survey Points that are referenced from
the specific import command, and provides a convenient way to remove, re-import, and reprocess linework,
and insert survey data into the current drawing.
TIP Commands entered in the Survey Command Window or from using the Run Batch File command do not
create an import event. To maintain the integrity of existing networks, you should create a separate network when
you use the Survey Command Window.
To edit an import event
1 In Toolspace, on the Survey tab, expand a named survey database, and then expand the Import Events
collection.
2 In the Import Events Editor vista, select an import event, right-click ➤ Edit.

274 | Chapter 10 Survey Field to Finish

To delete an import event
1 In Toolspace, on the Survey tab, expand a named survey database, and then expand the Import Events
collection.
2 Select an import event, right-click ➤ Delete.
To change the order of import events
1 In Toolspace, on the Survey tab, expand a named survey database, and then expand the Import Events
collection.
2 Select the import event and drag it to a new location in the collection.

Quick Reference
Toolspace
Survey tab: expand Survey Databases ➤ <named> survey database ➤ Import Events ➤ <named> event

Import Event Commands
Use the following right-click commands to view and edit data in the Import Event collection and in individual
import events.
Import Events Collection
■

Import Survey Data: Displays the Import Survey Data wizard.

■

Edit: Displays the Import Events Editor in the panorama vista.

■

Process Linework: Displays the Process Linework dialog box where you can edit settings if necessary and
then process the linework for all import events using the specified settings.

■

Insert Into Drawing: Inserts data from all import events into the current drawing.

■

Remove From Drawing: Removes data from the import events created in the current drawing.

Import Event
■

Properties: Displays the properties for a selected event, such as name, description, and linework code set.

■

Edit: Displays the Import Events Editor in the panorama vista.

■

Re-import: Displays the import settings for the event. Edit settings if needed and click OK to re-import
the event data.

■

Process Linework: Displays the Process Linework dialog box where you can edit settings if necessary and
then process the linework for the selected import events using the specified settings.

Editing Survey Point Properties
After importing survey data, you can edit survey point descriptions to correct field coding errors.
A survey point is a COGO point that is created by the Survey feature. When the survey point description is
changed and the field coding errors are corrected you can re-process the linework. For more information,
see Processing Survey Linework (page 276).
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To edit survey point properties
1 Do one of the following:
■

In the drawing, right-click a survey point ➤ Edit Survey Point Properties.

■

From any survey point list view right-click a point ➤ Properties.

■

In the Figure Properties dialog box, click

to display the Survey Point Properties dialog box.

2 In the Survey Point Properties dialog box, edit the point name and the point description.
3 Click OK. At the command line, you are prompted to select another point. Continue to edit the points
as necessary.
4 Press Enter to end the edit command and update the linework.
To process linework at anytime, right-click the Survey Points collection on the Survey tab in Toolspace ➤
Process Linework.

Quick Reference
Ribbon
Click Survey tab ➤ Modify panel ➤ Survey Point Properties
Toolspace
Expand Survey Point Collection ➤ right-click a survey point in a point list ➤ Properties
Command Line
EditSvPointProperties

Processing Survey Linework
Process Linework during the import of survey data or as a post import process.
IMPORTANT Figures that are created using a Linework Code Set do not automatically update when you modify
survey data by updating figures, changing survey point descriptions, editing point coordinates through changes
in observations, or network and traverse adjustment. In order to obtain the most accurate results, it is recommended
that you process the linework each time you make modifications to the survey data.
To process or re-process linework
1 In Toolspace, on the Survey tab, do one of the following:
■

Right-click the Import Events collection ➤ Process Linework. Linework for all import events in the
collection is processed in the order that the import events are displayed in the Import Events
collection. Use this command in situations where a figure spans across multiple import events. For
example, in the first import event EP1 was created, but in a subsequent import event an attempt is
made to continue the same EP1.

■

Right-click a named import event ➤ Process Linework. Linework for the event you selected is
processed.

■

Right-click the Survey Points collection ➤ Process Linework. Linework for all points, including
points from previous versions and manually entered points.

2 In the Process Linework dialog box, verify the settings and click OK.
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Quick Reference
Toolspace
Right-click Import Event Collection or <named> Import Event ➤ Process Linework
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Adding and Editing Survey
Data

11

You can use AutoCAD Civil 3D to add and edit survey data.
To add survey data to your drawing, you can:
■

Use the AutoCAD Civil 3D Toolspace Survey tab to define and manage survey data such as point, setups, directions,
traverses, and figures.

■

Use the AutoCAD Civil 3D Survey Command Window to define survey data such as baselines, centerlines, and
intersections, and to view and manage survey command input and output history.

In AutoCAD Civil 3D, a survey database holds all the observed angles and distances for each point.

Editing Survey Data in the Panorama Vista Editor
Many of the collections on the Survey tab in Toolspace have a right-click Edit command that opens a
panorama vista editor. The benefit of the panorama vista editor is that you can easily switch to the Survey
tab and browse through the data and then return back to the editor to continue with your edits. The vista
displays all the data from the collection, with varying editing options depending on the type of object.
To edit survey objects using the panorama vista editor
1 Do one of the following:
■

To view and edit all objects in a collection, in Toolspace, on the Survey tab, right-click the
collection ➤ Edit to display all objects in the editor panorama vista.

■

To view and edit a single object, in Toolspace on the Survey tab, right-click the object in the list
view ➤ Properties.

2 Modify the available fields. When you make a changes to data, the entire row is displayed in bold until
you save the changes to the survey database.
3 To edit the values in multiple rows, select the rows, right-click the column heading, click Edit, and
enter the new value. If no rows are selected, then all rows are updated. Press the ESC key to clear the
selection.
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4 To undo the changes for a single row or multiple rows, select the row(s), right-click ➤ Reload.
Alternatively, to undo all the changes in the vista, click

.

5 To apply the changes for a single row or for multiple rows, select the row(s), right-click ➤ Apply.
Alternatively, to apply all changes in the vista, click

.

6 For information about the standard panorama vista functions, see The Panorama Window (page 119).

Quick Reference
Toolspace
Survey tab: Survey Databases ➤ <database name> ➤ Networks ➤ <network name> ➤ right-click object
collection ➤ Edit

Control Points
You can use several methods to create control points.
Control points are points you create at a known location. Control points are not affected by any adjustments
or corrections you make. When you create a control point, it is added to survey database.
Click the Control Points collection on the Toolspace Survey tab to display individual control points in the
list view.

Creating Control Points
Use the Toolspace Survey tab to create a control point using known northing and easting, or latitude and
longitude (if the survey database references a coordinate zone), and elevation coordinates, to be used for
traverse and least squares adjustments.
To create a control point
1 In Toolspace, on the Survey tab, right-click the Control Points collection. Click New to open the New
Control Point dialog box.
2 Enter the point number.
IMPORTANT If there is a Survey Point (Non-Control point) with a matching number then the data for that
point displays in the New Control Point dialog box. If there is no Survey Point defined in the Survey database
that has a matching name, the program checks the active drawing to see if there is an AutoCAD Civil 3D
point with a matching number. If there is an AutoCAD Civil 3D point with a matching number, then the
point information displays in the New Control Point dialog box.
3 Optionally, enter the point name.
IMPORTANT You can define a point by Name, or by deleting the number in the Number field and leaving
it blank. Enter a Name in the Name field. If there is already a control point with that name an error message
is displayed. If there is a Survey point with a matching name then the data for that point displays in the New
Control Point dialog box. If there is no survey point or control point defined in the Survey database that has
a matching name, the program checks the active drawing to see if there is an AutoCAD Civil 3D point with
a matching name. If there is an AutoCAD Civil 3D point with a matching name, then the point information
displays in the New Control Point dialog box.
4 Enter the easting (X-coordinate) of the new control point.
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5 Enter the northing (Y-coordinate) of the new control point.
6 Optionally, enter the elevation (Z-coordinate) of the new control point.
7 Enter a description for the control point.
8 Optionally, enter the latitude of the point. The Northing property value is calculated from the value
entered in this field.
NOTE This property is not available if the survey database does not have an assigned coordinate system
zone.
9 Optionally, enter the longitude of the point. The Easting property value is calculated from the value
entered in this field.
NOTE This property is not available if the survey database does not have an assigned coordinate system
zone.
10 Click OK to create the new control point. The new control point is displayed in the control points list
view in Toolspace.
To create a new control point using the survey command language
1 In Toolspace, on the Survey tab, right-click on the network that you want to add the control point to.
Click Survey Command Window.
2 To create a control point by northing and easting, at the Command line, enter:
NE (point) [north] [east] (description)
To create a control point by northing, easting, and elevation, at the Command line, enter:
NEZ (point) [northing] [easting] (elevation) (description)
3 To create a control point by latitude and longitude (if the survey database settings reference a coordinate
zone), enter:
LAT LONG (point) [latitude] [longitude] (description)
NOTE For parameter descriptions, see the Quick Reference tab.

Examples
The following example sets point 2 at northing 2000, easting 2000 with an elevation of 100, and a description
of TP.
NEZ 2 2000 2000 100 TP
The following example sets point number 55 at latitude 45°16'17" and longitude 36°55'55".
LAT LONG 55 45.1617 36.5555

Quick Reference
Toolspace
Survey tab: right-click Control Points ➤ New
Survey Command Window Syntax
NE (point) [northing] [easting] (description)
or
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NEZ (point) [northing] [easting] (elevation) (description)
or
LAT LONG (point) [latitude] [longitude] (description)
Parameter

Definition

point

The point identifier of the new point. You do not need to assign a point number if auto point numbering is on.

northing

The northing of the point.

easting

The easting of the point.

elevation

The elevation of the point.

latitude

The latitude of the point. Enter this value using the current
survey database Angle unit. Use a positive value to indicate a
location above the equator, or a negative value for one below
it.

longitude

The longitude of the point. Enter this value using the current
survey database Angle unit. Use a positive value to indicate a
location east of the prime meridian, or a negative value for a
location west of the prime meridian.

description

An optional description associated with the point.

Editing Control Points
Use the Control Points Editor to view and edit control point data for individual or multiple control points.
For individual control points, the Control Points Editor provides the same functionality as the Control Points
properties list view in the Toolspace Survey tab, but it is more suited for horizontal viewing of a tabulation
of this type of data. The benefit of editing control points in the Control Points Editor is that you can easily
switch to the Survey tab and browse through the data and then return back to the Control Points Editor to
continue with your edits.
To edit control points
1 Do one of the following:
■

To view and edit control points, in Toolspace, on the Survey tab, right-click the Control Points
collection and click Edit to open the Control Points Editor.

■

To view and edit a single control point, in Toolspace on the Survey tab, click the Control Points
collection. In the item list view, right-click the point ➤ Properties.

2 Modify the applicable fields as required.
NOTE When you make a change to any control point data, the entire row is displayed in bold until you save
the changes to the survey database.
3 To edit the values in multiple rows, select the rows, right-click the column heading, click Edit, and
enter the new value.
4 The selected row values for the column are updated with the new value.
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NOTE If no rows are selected, then all rows are updated. Press the ESC key to clear the selection.
5 To undo the changes for a single row or multiple rows, select the row(s), right-click, and click Reload.
Alternatively, to undo all the changes in the vista, click

.

6 To apply the changes for a single row or for multiple rows, select the row(s), right-click, and click Apply.
Alternatively, to apply all changes in the vista, click

.

7 For information about the standard panorama vista functions, see The Panorama Window (page 119).

Quick Reference
Toolspace
Survey tab: Survey Databases ➤ <database name> ➤ Networks ➤ <network name> ➤ right-click Control
Points ➤ Edit

Non-Control Points
Use the Survey tab to create non-control points.
Non-control points are created with a northing, easting, and optional elevation.
Non-control points can be promoted to control points if you reference the point as a control point for
creating a traverse, or reference the point as a setup to make observations to other points that may affect
locations during an analysis.
Click the Non-Control Points collection on the Toolspace Survey tab to display individual non- control
points in the list view.

Creating a Non-Control Point
Create a point using known northing, easting, optional latitude and longitude, and optional elevation.
To create a non-control point
1 In Toolspace, on the Survey tab, right-click the Non-Control Points collection and click New to open
the New Non-Control Point dialog box.
2 Enter the point number. You do not need to assign a point number if auto point numbering is on.
IMPORTANT If there is an AutoCAD Civil 3D point with a matching number, then the point information
displays in the New Non-Control Point dialog box.
3 Optionally, enter the point name.
IMPORTANT You can define a point by Name, by deleting the number in the Number field and leaving it
blank. Enter a Name in the Name field. If there is already a control point or non-control with that name an
error message is displayed. If there is a point Survey point with a matching name then the data for that point
displays in the New Non-Control Point dialog box. If there is no survey point or non-control point defined
in the Survey database that has a matching name, the program checks the active drawing to see if there is
an AutoCAD Civil 3D point with a matching name. If there is an AutoCAD Civil 3D point with a matching
name, then the point information displays in the New Non-Control Point dialog box.
4 Enter the easting (X-coordinate) of the new non-control point.
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5 Enter the northing (Y-coordinate) of the new non-control point.
6 Optionally, enter the elevation (Z-coordinate) of the new non-control point.
7 Enter a description for the non-control point.
8 Enter the latitude of the point. The Northing property value is calculated from the value entered in this
field.
NOTE This property is not available if the survey database does not have an assigned coordinate system
zone.
9 Enter the longitude of the point. The Easting property value is calculated from the value entered in this
field.
NOTE This property is not available if the survey database does not have an assigned coordinate system
zone.
10 Click OK to create the new non-control point. The new control point is displayed in the non-control
points list view in Toolspace.
To create a non-control point using the survey command language
1 In Toolspace, on the Survey tab, right-click the network that you want to add control points to. Click
Survey Command Window.
2 At the Command line, enter:
NE SS (point) [north] [east] (elevation) (description)
NOTE For parameter descriptions, see the Quick Reference tab.

Quick Reference
Toolspace
Survey tab: Survey Databases ➤ <database name> ➤ Networks ➤ <network name> ➤ right-click
Non-Control Points ➤ New
Survey Command Window Syntax
NE SS (point) [North] [East] (elevation) (description)
Parameter

Definition

point

The point identifier of the new point. You do not need to assign a point number if auto point numbering is on.

north

The northing of the point.

east

The easting of the point.

elevation

The elevation of the point.

description

An optional description associated with the point.
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Editing Non-Control Points
Use the Non-Control Points Editor to view and edit point data for individual or multiple non-control points.
For individual points, the Non-Control Points Editor provides the same functionality as the properties list
view in Survey tab, but is more suited for horizontal viewing of a tabulation of this type of data. The benefit
of editing non-control points in the Non-Control Points Editor is that you can switch to the Survey tab and
browse through the data and then return to the Non-Control Points Editor to continue with your edits.
To edit non-control points
1 Do one of the following:
■

To view and edit all non-control points, on the Survey tab, right-click the Non-control Points
collection and click Edit to display the Non-Control Points Editor.

■

To view and edit a single non-control point, in the Survey tab, click the Non-Control Points collection.
In the item list view, right-click the point ➤ Properties.

2 Modify the applicable fields as required.
NOTE When you make a change to any point data, the entire row is displayed in bold until you save the
change to the survey database.
3 To edit the values in multiple rows, select the rows, right-click the column heading, click Edit, and
enter the new value.
4 The selected row values for the column are updated with the new value.
NOTE If no rows are selected, then all rows are updated.
5 To undo the changes for a single row or multiple rows, select the row(s), right-click, and click Reload.
Alternatively, to undo all the changes in the vista, click

.

6 To apply the changes for a single row or for multiple rows, select the row(s), right-click, and click Apply.
Alternatively, to apply all changes in the vista, click

.

7 For information on the standard panorama vista functions, see The Panorama Window (page 119).

Quick Reference
Toolspace
Survey tab: Survey Databases ➤ <database name> ➤ Networks ➤ <network named> ➤ right-click
Non-Control Points ➤ Edit

Setups
Setups are the instrument setups that are defined in the survey database. The Setups collection on the
Toolspace Survey tab expands to display individual setups.

Creating a New Setup
Use the Toolspace Survey tab to create new instrument setups.
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You can create a point using an angle turned from either a specified reference line or a previously determined
backsight point. Additionally, you can also use a vertical angle or vertical distance to locate the point.
To create a new setup
1 In the Survey Toolspace tab, right-click on the Setups collection and click New to display the New Setup
dialog box.
2 Enter the station point for the setup.
NOTE If you enter a non-existent station point, you are prompted to create a point and the New Control
Point dialog box is displayed where you can create a new station point.
3 Enter the backsight point for the setup. When this column contains a valid entry, the Backsight Direction
column displays the calculated backsight direction value and is read-only.
NOTE If you enter a non-existent backsight point, you are prompted to create a point and the New Control
Point dialog box is displayed from which you can create a new backsight point.
NOTE Setups can be created using the names of Survey Points that exist in the Survey Database. Enter the
point names in the Station Point and Backsight Point fields.
4 Enter a backsight direction. This field is read-only if the Backsight Point column contains a valid point
number.
5 Enter the backsight orientation angle for the setup.
NOTE This is the reference angle for all angle observations except Face1 and Face2 angles.
6 Enter the direct angle reference on the backsight for Face1 angles.
7 Enter the reverse angle reference on the backsight for Face2 angles.
8 Enter the measured instrument (theodolite) height. This is typically measured from the center of the
theodolite optics to the setup point on the ground.
9 Click OK to create the new setup.
To create a setup using the survey command language
1 In Toolspace, on the Survey tab, right-click on the network that you want to add control points to.
Click Survey Command Window.
2 At the Command line, enter:
STA [point] (instrument height) (description)
NOTE For parameter descriptions, see the Quick Reference tab.

Example
This example sets the instrument on point 1. It is 5.1 feet above ground elevation. Therefore, the instrument
elevation is 105.1 feet.
NEZ 1 1000 1000 100
AZ 1 2 90
STA 1 5.1
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!STATION h.i.: 105.10
!POINT: 1 NORTH: 1000.0000 EAST: 1000.0000 ELEV: 100.0000

Quick Reference
Toolspace
Survey tab: Survey Databases ➤ <database name> ➤ Networks ➤ <network name> ➤ right-click Setups
➤ New
Survey Command Window Syntax
STA [point] (instrument height) (description)
Parameter

Definition

point

The point identifier of the traverse station.

instrument height

The height of the instrument above ground elevation.

description

An optional description associated with the point.

Defining New Station and Backsight Points
When creating a new setup, you can specify station and backsight points. If you enter a point identifier that
does not exist in the survey database, you are prompted to create a new point in the New Control Point
dialog box.
To define new station or backsight points
1 In the New Setup dialog box, enter the new station or backsight point in the respective fields.
2 Click Yes when you are prompted with the message asking you if you want to create the point.
3 In the New Control Point dialog box, enter the easting, northing, elevation, and description for the
new point. Click OK.
4 The point is added to the Control Points collection and the survey database.

Viewing and Editing Setups
Use the Toolspace Survey tab to view and edit setup data for multiple setups or for an individual setup.
For individual setups, the Setups Editor vista provides the same functionality as the setup properties list view
in the Toolspace Survey tab, but is more suited for horizontal viewing of a tabulation of this type of data.
The benefit of editing setups in the Setups Editor is that you can easily switch to the Survey tab and browse
through the data and then return to the Setups Editor to continue with your edits.
To edit setups
1 Do one of the following:
■

To view and edit all setups, on the Survey tab, right-click the Setups collection and click Edit to
display the Setups Editor.

■

To view and edit a single setup, on the Survey tab, cliches Setups collection. In the item list view,
click the setup you want to edit.
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NOTE You can also edit a single setup in the Toolspace item view, which is displayed when you select a setup
in the tree view on the Survey tab.
2 Modify the applicable fields as required.
NOTE When you make a change to any setup data, the entire row is displayed in bold until you save the
change to the survey database.
3 To edit the values in multiple rows, select the rows, right-click the column heading, click Edit, and
enter the new value.
The selected row values for the column are updated with the new value.
NOTE If no rows are selected, then all rows are updated.
4 To undo the changes for a single row or for multiple rows, select the row(s), right-click, and click Reload.
Alternatively, to undo all the changes in the vista, click

.

5 To apply the changes for a single row or multiple rows, select the row(s), right-click, and click Apply.
Alternatively, to apply all changes in the vista, click

.

6 For information about the standard panorama vista functions, see The Panorama Window (page 119).
To edit setups that observe a point
1 On the Toolspace Survey tab, expand the network name and click Survey Points.
2 In the Toolspace list view, right-click the point for which you want to edit the setups that observe. Click
Edit Setups That Observe to open the Setups Editor.
3 In the Setups Editor, optionally, right-click a setup and click Edit Observations.
4 Modify the applicable fields as required.
NOTE When you make a change to any setup data, the entire row is displayed in bold until you save the
change to the survey database.
5 To edit the values in multiple rows, select the rows, right-click the column heading, click Edit, and
enter the new value.
6 The selected row values for the column are updated with the new value.
NOTE If no rows are selected, then all rows are updated.
7 To undo the changes for a single row or multiple rows, select the row(s), right-click, and click Reload.
Alternatively, to undo all the changes in the vista, click

.

8 To apply the changes for a single row or for multiple rows, select the row(s), right-click, and click Apply.
Alternatively, to apply all changes in the vista, click

.

9 For information about the standard panorama vista functions, see The Panorama Window (page 119).
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Quick Reference
Toolspace
Survey tab: Survey Databases ➤ <database name> ➤ Networks ➤ <network name> ➤ right-click Setups
➤ Edit

Deleting Setups
Delete setups from the Toolspace Survey tab list view or from the Setups Editor vista.
Use the Setups Editor vista to mark setups for deletion, and then accept or roll back the deletions.
NOTE When a setup is deleted, only the setup is deleted, not the points that were created by the setup.
To delete a setup from the Toolspace Survey tree
1 In Toolspace, on the Survey tab, click the Setups collection.
2 In the list view, right-click a setup and click Delete.
To delete a setup from the Setups Editor
1 In Toolspace, on the Survey tab, right-click the Setups collection and click Edit to open the Setups
Editor.
2 Select the setup(s) to delete, right-click, and click Delete.
The setup icon is replaced with a

and the row is set to read-only.

3 To undo the changes for a single row or for multiple rows, select the row(s), right-click, and click
Undelete. Alternatively, to undo all the changes in the vista, click

.

4 To apply the changes for a single row or multiple rows, select the row(s), right-click, and click Apply.
Alternatively, to apply all deletions and changes in the vista, click

.

Quick Reference
Toolspace
Survey tab: Survey Databases ➤ <database name> ➤ Networks ➤ <network name> ➤ right-click Setups
➤ Edit Observations
or
Survey tab: Survey Database ➤ <database name> ➤ Networks ➤ <network name> ➤ Setups ➤ right-click
<named setup> ➤ Delete

Observations
Observations are measured to survey points in relation to a setup.
You use the Toolspace Survey tab and the Observations Editor to add, edit, and manage observations at a
specific setup.
In addition to creating and editing observation at a specific setup in the Observations Editor, you can create
observations using the Survey Command Window.
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Observations are used to measure locations on the Earth's surface that have been determined by surveying
(geometric) methods. You can locate points by known coordinates, or in reference to some other known
location, such as an angle and distance from an existing point.
When automatic point numbering is off, you must specify the point numbers. If automatic point numbering
is on, the points are automatically numbered. Subsequent points are assigned the next available number in
sequential order. For information about setting automatic point numbering, see Setting Survey Command
Window Options (page 243).
It is helpful to establish a point numbering system for all your projects. A recommended point numbering
method might be to number traverse points sequentially, starting with 1. If the job contains fewer than 100
traverse points, then number all sideshots observed from point 1 with numbers 101 to 199, and sideshots
taken at point 2 with numbers 201 to 299. This method makes it easy to determine where any given point
was observed from.

Browsing to an Observation
Browse to an observation in the Observation Editor.
In the Observations Editor you have the options to view, create, and edit survey data.
To browse to an observation
1 Click Survey tab ➤ Modify panel ➤ Browse To Survey Data Drop-down ➤ Browse To Observation

.

2 At the command line, enter the point identifier for the observation you wish to find.
The specified observation is displayed in the Observation Editor.

Quick Reference
Ribbon
Survey tab ➤ Modify panel ➤ Browse To Survey Data Drop-down ➤ Browse To Observation
Command Line
BrowseToSvObservation

Enabling Point Numbering
When automatic point numbering is on, new points are automatically assigned the next available point
number. When automatic point numbering is off, you must specify new point numbers as they are needed.
To turn point numbering on or off
1 In the Toolspace Survey tab, right-click the survey database name and click Edit Survey Database Settings.
2 In the Survey Database Settings dialog box, expand the Survey Command Window property group.
3 Do one of the following:
■

To enable automatic point numbering, select the Auto Point Numbering check box.

■

To turn off automatic point numbering, clear the Auto Point Numbering check box.

4 Click OK.
NOTE For parameter descriptions, see the Quick Reference tab.
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To turn point numbering on or off using the survey command language
1 In Toolspace, on the Survey tab, right-click the network name for which you want to turn automatic
point numbering on or off. Click Survey Command Window.
2 To turn automatic point numbering on, at the Command line, enter:
AUTO ON [point]
3 To turn automatic point numbering off, at the Command line, enter:
AUTO OFF

Example
The following example shows a valid entry using the Automatic Point Numbering On command with 1001
as the starting point number:
AP ON 1001
If you do not enter a point number, then the program assigns the next available point number.

Quick Reference
Toolspace
Survey tab: Survey Databases ➤ right-click <database name> ➤ Edit Survey Database Settings
Survey Command Window Syntax
AUTO ON [point]
or
AUTO OFF
Parameter

Definition

point

The assigned starting point number.

Creating Observations
Use the Observations Editor to add observations to an existing setup.
Add points using one of the following methods:
■

Angle: Creates an observation using an angle turned from either a specified reference line or a previously
determined backsight point. For an example and illustration of this method, see Creating an Observation
by Angle and Distance (page 292).

■

Deflection: Creates an observation using a deflection angle and distance from an established line. For
an example and illustration of this method, see Creating an Observation by Deflection Angle and Distance
(page 296).

■

Face1/Face2 angle: Creates an observation from a traverse station using a horizontal angle measured on
Face1 or Face2 of your instrument. For an example and illustration of this method, see Creating an
Observation Using a Face1 or Face2 Angle (page 298).

■

Azimuth: Creates an observation from an occupied traverse station by entering a recorded azimuth and
distance. For an example and illustration of this method, see Creating an Observation Using an Azimuth
(page 301).
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■

Bearing: Creates an observation in reference to the occupied point using bearing and distance. For an
example and illustration of this method, see Creating an Observation by Bearing and Distance (page 294).

To add an observation to a setup
1 In Toolspace, on the Survey tab, right-click the setup name and click Edit Observations.
2 In the Observations Editor, right-click either an existing observation or an empty row and click New.
A new row is added to the Observations Editor.
NOTE If you select an existing row and add a new observation, the new observation uses the settings of the
selected row. If you select an empty row, the new observation's settings are based on the Database Settings
(page 238).
3 Modify the fields by selecting the field and entering the new value as needed.
4 To edit the Angle Type, Distance Type, Vertical Type, and Target Type fields, click the field and select
a new value from the drop-down lists. For information about these types, see Survey Database Settings
Dialog Box (page 2698).
NOTE If no rows are selected, then all rows are updated.
5 To create an observation using a point name, delete the value in the point number field and then specify
the Angle and Distance values, and then enter a point name. The Angle and Distance values must be
entered before you enter the Name. If there is a point Survey point with a matching name then the
data for that point is displayed.
6 To undo the changes for a single row or multiple rows, select the row(s), right-click, and click Reload.
Alternatively, to undo all the changes in the vista, click

.

NOTE If you have new observations and have not applied them, clicking the Reload button will discard the
new observations.
7 To apply the changes for a single row or multiple rows, select the row(s), right-click, and click Apply.
Alternatively, to apply all changes in the vista, click

.

8 For information about the standard panorama vista functions, see The Panorama Window (page 119).

Quick Reference
Toolspace
Survey tab: Survey Databases ➤ <database name> ➤ Networks ➤ <network name> ➤ right-click Setups
➤ Edit Observations

Creating Observations Using the Survey Command Language
In addition to adding observations using the Observations Editor, you can add observations using the survey
command language.

Creating an Observation by Angle and Distance
Use the angle distance (AD) command to quickly create a point by angle and distance.
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Create a point using an angle turned from either a specified reference line or a previously determined
backsight point. You can also use a vertical angle or vertical distance to locate the point.
NOTE For parameter descriptions, see the Quick Reference tab.
To create an observation by angle and distance, using the command language
1 In Toolspace, on the Survey tab, right-click the network that you want to add points to, and click Survey
Command Window.
2 At the Command line, enter:
AD (point) [angle] [distance] (description)
To create an observation by angle, distance, and vertical angle, using the command language
1 In Toolspace, on the Survey tab, right-click the network that you want to add points to, and click Survey
Command Window.
2 At the Command line, enter:
AD VA (point) [angle] [distance] [vertical angle] (description)
To create an observation by angle, distance, and vertical distance, using the command language
1 In Toolspace, on the Survey tab, right-click the network that you want to add points to, and click Survey
Command Window.
2 At the Command line, enter:
AD VD (point) [angle] [distance] [vertical distance] (description)

Examples
This example creates point 103, which is located by turning a horizontal angle of 80°20'40" right at a distance
of 100 units from the instrument point with the description WELL. Because no method of vertical difference
determination was given, the elevation is <Null>.
AD 103 80.2040 100 WELL
This example creates point 101, which is located by turning a horizontal angle of 100°20'45" right from the
backsight and using a vertical angle of 91°15'15" at a distance of 100 units from the instrument point with
the description IP.
AD VA 101 100.2045 100 91.1515 IP
This example creates point 102, which is located by turning a horizontal angle of 90°30'30" right from the
backsight and using a vertical distance of -1.5 units at a distance of 200 units from the instrument point
with the description EL.
AD VD 102 90.3030 200 -1.5 EL
Points created with the angle distance command:
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Point 101 is located by turning a horizontal angle of 100°20'45" right from the backsight and using a vertical
angle of 91°15'15" at a distance of 100 units from the instrument point with the description IP.
Point 102 is located by turning a horizontal angle of 90°30'30" right from the backsight and using a vertical
distance of -1.5 units at a distance of 200 units from the instrument point with the description EL.
Point 103 is located by turning a horizontal angle of 80°20'40" right at a distance of 100 units from the
instrument point with the description WELL. Because no method of vertical difference determination was
given, the elevation is <Null>.

Quick Reference
Survey Command Window Syntax
AD (point) [angle] [distance] (description)
or
AD VA (point) [angle] [distance] [vertical angle] (description)
or
AD VD (point) [angle] [distance] [vertical distance] (description)
Parameter

Definition

point

The assigned point identifier. You do not need to assign a
point number if auto point numbering is on.

angle

The measured horizontal angle. It is assumed to be clockwise
(right). Use a negative number (-) to turn counter-clockwise
(left). Express in the current units (Degrees Minutes Seconds
(D.MS), grads, decimal degrees (D.DD), radians, or mils).

distance

The distance from the instrument point to the point being
located. It is measured in the current units unless otherwise
specified. Distance is assumed to be a horizontal distance unless VA is used. When VA is used, the distance is recognized
as slope distance.

vertical angle

The direction of the vertical angle (zenith, horizontal, or nadir).
Specify the vertical angle in the current angular units.

vertical distance

The elevation difference from the instrument to the prism. If
the prism is higher than the instrument, then this is a positive
value.

description

An optional description associated with the point.

Creating an Observation by Bearing and Distance
Use the bearing and distance command (BD) to create an observation in reference to the occupied point
using bearing and distance.
NOTE For parameter descriptions, see the Quick Reference tab.
To create an observation using bearing and distance, using the command language
1 In Toolspace, on the Survey tab, right-click the network that you want to add points to, and click Survey
Command Window.
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2 At the Command line, enter:
BD (point) [bearing] [quadrant] [distance] (description)
To create an observation using bearing, distance, and vertical angle, using the command language
1 In Toolspace, on the Survey tab, right-click the network that you want to add points to, and click Survey
Command Window.
2 At the Command line, enter:
BD VA (point) [bearing] [quadrant] [distance] [vertical angle] (description)
To create an observation using bearing, distance, vertical distance, using the command language
1 In Toolspace, on the Survey tab, right-click the network that you want to add points to, and click Survey
Command Window.
2 At the Command line, enter:
BD VD (point) [bearing] [quadrant] [distance] [vertical distance] (description)

Examples
The following example illustrates using the BD command when the units are set to feet:
NE 1 100 100
STN 1
BD 2 45 1 100 PT
! BEARING: N 45-00-00 E DISTANCE: 100.0000
! POINT 2 NORTH: 170.7107 EAST: 170.7107
! ELEV: <Null>
This creates point 2 at the bearing and distance specified.
Point created with the BD command:

N45° 00'00"E
{50.00 grads}
point set by Bearing Distance

reference meridian

quadrant 1

00

ft

}

48

1
instrument point

0.

{3

m

reference parallel

Point 2 is located by turning a bearing of 45°0'0" (50 grads) in Quadrant 1 (NE) at a distance of 100 feet from
the instrument point with the description PT.
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Quick Reference
Survey Command Window Syntax
BD (point) [bearing] [quadrant] [distance] (description)
or
BD VA (point) [bearing] [quadrant] [distance] [vertical angle] (description)
or
BD VD (point) [bearing] [quadrant] [distance] [vertical distance] (description)
Parameter

Definition

point

The point identifier of the new point. You do not need to assign a point number if auto point numbering is on.

bearing

The bearing. Enter this value in the current angular units (DMS,
grads, decimal degrees, mils, or radians).

quadrant

The quadrant for the bearing. Specify the quadrant using one
of the following numbers: 1 (for NE), 2 (for SE), 3 (for SW),
or 4 (for NW).

distance

The distance from the instrument point to the point being
located. It is measured in the current distance units. The distance is assumed to be a horizontal distance unless VA is used.
When VA is used, the distance is recognized as a slope distance.

vertical angle

The direction of the vertical angle (zenith, horizontal, or nadir).
Type this value in the current angular units (DMS, grads,
decimal degrees, mils, or radians).

vertical distance

The elevation difference from the instrument to the prism. If
the prism is higher than the instrument, then this is a positive
value.

description

An optional description associated with the point.

Creating an Observation by Deflection Angle and Distance
Use the deflection distance (DD) command to quickly create a point using a deflection angle and distance
from an established line.
The term deflection angle refers to the angular direction turned from the extension of the previous course.
Additionally, you can also use a vertical angle or vertical distance to locate the point.
NOTE For parameter descriptions, see the Quick Reference tab.
To create an observation using deflection angle and distance, using the command language
1 In Toolspace, on the Survey tab, right-click the network that you want to add points to, and click Survey
Command Window.
2 At the Command line, enter:
DD (point) [angle] [distance] (description)
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To create an observation using deflection angle, distance, and vertical angle, using the command language
1 In Toolspace, on the Survey tab, right-click the network that you want to add points to, and click Survey
Command Window.
2 At the Command line, enter:
DD VA (point) [angle] [distance] [vertical angle] (description)
To create an observation using deflection angle, distance, and vertical distance, using the command language
1 In Toolspace, on the Survey tab, right-click the network that you want to add points to, and click Survey
Command Window.
2 At the Command line, enter:
DD VD (point) [angle] [distance] [vertical distance] (description)

Examples
The following example illustrates using the deflection distance command.
NE 1 100 100
STN 1
AZ 1 2 100
BS 2
DD 3 85.2657 60.960
! AZIMUTH: 385.2657 DISTANCE: 60.9600
! POINT 3 NORTH: 159.3345 EAST: 86.0167
! ELEV: <Null>
Points created using the DD command:

point set by Deflection Distance
200 ft

{60.96

76°44'21"

m}

{85.26 grads}

backsight
instrument point

Point 3 is located by turning a deflected angle of 85.2657 right from the extension of the backsight line at
a distance of 200. Angles and distances are in the current units, unless you type a qualifying suffix.

Quick Reference
Survey Command Window Syntax
DD (point) [angle] [distance] (description)
or
DD VA (point) [angle] [distance] [vertical angle] (description)
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or
DD VD (point) [angle] [distance] [vertical distance] (description)
Parameter

Definition

point

The point identifier of the new point. You do not need to assign a point number if auto point numbering is on.

angle

The deflection angle as measured to the point. Type this value
in the current angular units (DMS, grads, decimal degrees,
radians, or mils).

distance

The distance from the instrument point to the point being
located. It is measured in the current units unless otherwise
specified. The distance is assumed to be a horizontal distance
unless VA is used. When VA is used, the distance is recognized
as a slope distance.

vertical angle

The direction of the vertical angle (zenith, horizontal, or nadir).
Type this value in the current angular units (DMS, grads,
decimal degrees, mils, or radians).

vertical distance

The elevation difference from the instrument to the prism. If
the prism is higher than the instrument, then this is a positive
value.

description

An optional description associated with the point.

Creating an Observation Using a Face1 or Face2 Angle
Create an observation from a traverse station using a horizontal angle measured on Face1 or Face2 of your
instrument.
You can then input the measurements, using the Face1 (direct) and Face2 commands. These commands
apply collimation (if set), and automatically average the sightings after you input observations.
Face1/Face2 angles can be collected in any order. The only requirement is that the Face1 backsight be recorded
first. If Face2 observations are recorded, then a corresponding Face2 backsight should also be recorded. In
the case where Face2 foresight observations are recorded previous to the Face2 backsight, the Face2 backsight
is assumed to be the Face1 backsight plus 180°.
AutoCAD Civil 3D uses all reciprocal observations to a point (both foresight and backsight) by calculating
an average horizontal and vertical distance of all the observations as long as the distance is a non-zero value
to calculate the average horizontal and vertical position of a point.
The correct average for all Face1/Face2 and reciprocal observations is applied when the [adjust] command
is used. An adjustment may be done to get the correct average values whether there is a closed traverse or
not.
NOTE For parameter descriptions, see the Quick Reference tab.
To create an observation using a Face1 or Face2 angle, using the command language
1 In Toolspace, on the Survey tab, right-click the network that you want to add points to, and click Survey
Command Window.
2 At the Command line, enter:
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F1(point) [angle] [distance] (description)
or
F2 (point) [angle] [distance] (description
To create an observation using a Face1 or Face2 angle and vertical angle, using the command language
1 In Toolspace, on the Survey tab, right-click the network that you want to add points to, and click Survey
Command Window.
2 At the Command line, enter:
F1 VA (point) [angle] [distance] [vertical angle] (description)
or
F2 VA (point) [angle] [distance] [vertical angle] (description)
To create an observation using a Face1 or Face2 angle and vertical distance, using the command language
1 In Toolspace, on the Survey tab, right-click the network that you want to add points to, and click Survey
Command Window.
2 At the Command line, enter:
F1VD (point) [angle] [distance] [vertical distance] (description)
or
F2 VD (point) [angle] [distance] [vertical distance] (description)

Example: Face1
NE 2 200 200
AZ 2 1 100
STN 2 1.585
BS 1
F1 VA 101 0 30.480 100 BS
! AZIMUTH: 101.6126 DISTANCE: 30.4800
! POINT 101 NORTH: 199.2280 EAST: 230.4702
! ELEV: <Null>
F1 VA 102 89.5370 15.304 101.2052 IP
! AZIMUTH: 191.1682 DISTANCE: 15.3013
! POINT 102 NORTH: 184.8457 EAST: 202.1159
! ELEV: <Null>
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Points created Face1 command:

100 feet {30.48 m}
backsight

50.21

point set by Face 1
80°36'00"
{89.54 grads}

ft

{15.30 m

instrument point

}
point set by Face 1

Point 101 is located by turning a horizontal angle of 0 right from Face1, and a vertical angle of 100 at a
distance of 30.480 from the instrument point with the description BS.
Point 102 is located by turning a horizontal angle of 89.5370 right from Face1, and a vertical angle of
101.2052 at a distance of 15.304 from the instrument point with the description IP. Angles and distances
are in the current units, unless you type a qualifying suffix.

Example: Face2
NE 2 200 200
AZ 2 1 100
STN 2 1.585
F2 1 200
F2 VA 101 311.4954 15.30 301.0355 IP
! AZIMUTH: 213.1080 DISTANCE: 15.300
! POINT 101 NORTH: 198.2901 EAST: 199.6429
! ELEV: <Null>
Points created Face2 command:

instrument point

50.21 ft
{15.30 m

}

backsight

100°20'45"
{111.49 grads}

point set by Face 2

Point 101 is located a distance of 15.30 from the instrument setup at an observed angle right from the
backsight of 311.4954. The actual physical angle turned is 111.49, with a vertical angle of 301.03. The
description for the point is IP. Angles and distances are in the current units, unless you type a qualifying
suffix.
NOTE This is an angle turned with the scope inverted. Normally, the backsight is set at a 180° angle, so that the
difference between it and the angle is the amount of the angle turned right (100°20'45").
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Quick Reference
Survey Command Window Syntax
F1 (point) [angle] [distance] (description)
F2 (point) [angle] [distance] (description)
or
F1 VA (point) [angle] [distance] [vertical angle] (description]
F2 VA (point) [angle] [distance] [vertical angle] (description]
or
F1 VD (point) [angle] [distance] [vertical distance] (description)
F2 VD (point) [angle] [distance] [vertical distance] (description)
Parameter

Definition

point

The point identifier of the new point. You do not need to assign a point number if auto point numbering is on.

angle

The measured horizontal angle. It is assumed to be clockwise
(right). Use a negative number (-) to turn counter-clockwise
(left). Type the horizontal angle in the current angular units
(DMS, grads, decimal degrees, radians, or mils).

distance

The distance from the instrument point to the point being
located. It is measured in the current units unless otherwise
specified. The distance is assumed to be a horizontal distance
unless VA is used. When VA is used, the distance is recognized
as a slope distance.

vertical angle

The direction of the vertical angle (zenith, horizontal, or nadir).
Type this value in the current angular units (DMS, grads,
decimal degrees, mils, or radians).

vertical distance

The elevation difference from the instrument to the prism. If
the prism is higher than the instrument, then this is a positive
value.

description

An optional description associated with the point. If you use
a description key, then specific information is assigned to the
point.

Creating an Observation Using an Azimuth
Create an observation from an occupied traverse station by entering a recorded azimuth and distance.
Additionally, you can also use a vertical angle or vertical distance to locate the point.
NOTE For parameter descriptions, see the Quick Reference tab.
To create an observation using an azimuth and distance, using the command language
1 In Toolspace, on the Survey tab, right-click the network that you want to add points to, and click Survey
Command Window.
2 At the Command line, enter:
ZD (point) [azimuth] [distance] (description)
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To create an observation using an azimuth, distance, and vertical angle, using the command language
1 In Toolspace, on the Survey tab, right-click the network that you want to add points to, and click Survey
Command Window.
2 At the Command line, enter:
ZD VA (point) [azimuth] [distance] [vertical angle] (description)
To create an observation using an azimuth, distance, and vertical distance, using the command language
1 In Toolspace, on the Survey tab, right-click the network that you want to add points to, and click Survey
Command Window.
2 At the Command line, enter:
ZD VD (point) [azimuth] [distance] [vertical distance] (description)

Quick Reference
Survey Command Window Syntax
ZD (point) [azimuth] [distance] (description)
or
ZD VA (point) [azimuth] [distance] [vertical angle] (description)
or
ZD VD (point) [azimuth] [distance] [vertical distance] (description)
Parameter

Definition

point

The new point identifier. You do not need to assign a point
number if auto point numbering is on.

azimuth

The measured azimuth from the traverse station to the point
being located. Type this value in the current angular units
(DMS, grads, decimal degrees, mils, or radians).

distance

The distance from the instrument point to the point being
located. It is measured in the current distance units. The distance is assumed to be a horizontal distance unless VA is used.
When VA is used, the distance is recognized as a slope distance.

vertical angle

The direction of the vertical angle (zenith, horizontal, or nadir).
Type this angle in the current angular units.

vertical distance

The elevation difference from the instrument to the prism. If
the prism is higher than the instrument, then this is a positive
value.

description

An optional description associated with the point.

Creating a Point By Offset
Create a new point by offsetting the last point you created by a given distance.
NOTE For parameter descriptions, see the Quick Reference tab.
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To create a point by offset, using the command language
1 In Toolspace, on the Survey tab, right-click the network that you want to add points to, and click Survey
Command Window.
2 At the Command line, enter:
PT OFFSET (point) [offset] [ahead] (description)

Example
NEZ 1 1000 1000 30.480
AZ 1 2 100
STN 1 1.585
BS 2
AD 3 100 30.480
PT OFFSET 4 15.240 7.620
! AZIMUTH: 224.2238 DISTANCE: 41.0350
! POINT 4 NORTH: 961.9000 EAST: 984.7600
! ELEV: <Null>
Point 4 is located at an offset distance of 15.240, and an ahead distance of 7.620, from point 3.
Point created by offset:

instrument point

backsight

25 ft
{7.63 m}

50 ft
{15.24 m}

point set by Point Offset

Quick Reference
Survey Command Window Syntax
PT OFFSET (point) [offset] (ahead) (description)
Parameter

Definition

point

The point identifier of the new point. You do not need to assign a point number if auto point numbering is on.

offset

The offset distance from the last point created.
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Parameter

Definition

ahead

The distance added to the line between the station and the
last point created to locate the position of the new point (optional).

description

An optional description associated with the point.

Creating an Observation Point Using the Stadia Rod
Use the stadia rod intercept method to reduce a distance that has been measured.
NOTE For parameter descriptions, see the Quick Reference tab.
To create an observation using the stadia rod method, using the command language
1 In Toolspace, on the Survey tab, right-click the network that you want to add points to, and click Survey
Command Window.
2 At the Command line, enter:
STADIA (point) [angle] [distance] [rod] (vertical angle) (description)

Quick Reference
Survey Command Window Syntax
STADIA (point) [angle] [distance] [rod] (vertical angle) (description)
Parameter

Definition

point

The point identifier of the new point. You do not need to assign a point number if auto point numbering is on.

angle

The measured horizontal angle. It is assumed to be clockwise
(right). Use a negative number (-) to turn counter-clockwise
(left). Type the angle in the current units (DMS, grads,
decimal degrees, radians, or mils).

distance

The distance from the instrument point to the point being
located. It is measured in the current units unless otherwise
specified. The distance is assumed to be a horizontal distance
unless a vertical angle is specified. When a vertical angle is
specified, the distance is recognized as a slope distance. The
distance required here is actually the rod intercept multiplied
by the stadia constant. For example, if 1.37 is intercepted on
the stadia board, and the stadia constant is 100, then you
should type 137 as the distance.

rod

The rod reading taken by the central hairline of the instrument.
This is, in effect, the height above ground of the sighted target
point.

vertical angle

The direction of the vertical angle to the rod (zenith, horizontal, or nadir) and must be specified in the current angular units.
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Parameter

Definition

description

An optional description associated with the point.

Editing Observations
Use the Observations Editor panorama vista to edit the observations of a selected setup item in the list view.
NOTE When changes made in the Observations Editor are saved back to the survey database, the affected points
in the drawing are updated from the survey database.
To edit observations for a setup
1 In the Toolspace Survey tab, click the Setups collection. In the list view, right-click the setup ➤ Edit
Observations.
2 Modify the fields by selecting the field and entering the new value.
NOTE If an observation is marked with a
, the observation has been modified outside of the Observations
Editor and must be reloaded (by right-clicking and clicking Reload) before you can make any edits to the
observation.
3 To edit the Angle Type, Distance Type, Vertical Type, and Target Type fields, click the field and select
a new value from the drop-down lists. For information about these types, see Database Settings (page
238).
4 To edit the values in multiple rows, select the rows, right-click the column heading, click Edit, and
enter the new value.
The selected row values for the column are updated with the new value. If no rows are selected, then
all rows are updated.
NOTE When you make a change to any observation data, the entire row is displayed in bold until you save
the change to the survey database.
5 To delete observations, click the observation(s) to delete, right-click, and click Delete. The observation
icon is replaced with a

and the row is set to read-only.

6 To undo the changes for a single row or multiple rows, select the row(s), right-click, and click Reload
or Undelete. Alternatively, to undo all the changes in the vista, click

.

7 To apply the changes for a single row or multiple rows, select the row(s), right-click, and click Apply.
Alternatively, to apply all changes in the vista, click

.

8 For information about the standard panorama vista functions, see The Panorama Window (page 119).

Quick Reference
Toolspace
Survey tab: Survey Databases ➤ <database name> ➤ Networks ➤ <network name> ➤ right-click Setups
➤ Edit Observations
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Modifying the Description of a Point at the Survey Command Line
You can assign or edit the description of a point.
NOTE For parameter descriptions, see the Quick Reference tab.
To modify the description for a point, using the survey command language
1 In Toolspace, on the Survey tab, right-click the network that you to edit, and click Survey Command
Window.
2 At the Command line, enter:
MOD DESC [point 1] [description]

Example
NE 1 1000 1000 FENCE
MOD DESC 1 HOUSE
! POINT 1 DESC: HOUSE
This example changes the description of point 1 from FENCE to HOUSE.

Quick Reference
Survey Command Window Syntax
MOD DESC [point 1] [description]
Parameter

Definition

point 1

The point number which has the description you want to
modify.

description

An optional description associated with the point.

Modifying the Elevation of Points at the Survey Command Line
Use the Survey Command Window to modify the elevation of points.
The elevation modification commands are intended to work only with control and non-control points.
NOTE For parameter descriptions, see the Quick Reference tab.
To modify the elevation of a single point
1 In Toolspace, on the Survey tab, right-click the network that you want to edit, and click Survey Command
Window.
2 At the Command line, enter:
MOD ELEV [point 1] (elevation)
To modify the elevation of a multiple points
1 In Toolspace, on the Survey tab, right-click the network that you want to edit, and click Survey Command
Window.
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2 At the Command line, enter:
MOD ELEVS [point 1] [point 2] [elevation]
To modify point elevation by an increment
1 In Toolspace, on the Survey tab, right-click the network that you want to edit, and click Survey Command
Window.
2 At the Command line, enter:
MOD ELEV BY [point 1] (amount)
or
MOD ELEVS BY [point 1] [point 2] (amount)

Example
This example modifies the elevation of point 2 from 33.528 to 32.004 and then increases the elevation of
point 2 by an increment of 10.0. Elevations are in the current units, unless you type a qualifying suffix:
NEZ 1 100 100 30.480
NEZ 2 200 200 33.528
MOD ELEV 2 32.004
! POINT 2 ELEVATION: 32.004
MOD ELEV BY 2 10.0
! POINT 2 ELEVATION ADDED: 42.004

Quick Reference
Survey Command Window Syntax
MOD ELEV [point 1] (elevation)
or
MOD ELEVS [point 1] [point 2] [elevation]
or
MOD ELEV BY [point 1] (amount)
or
MOD ELEVS BY [point 1] [point 2] (amount)
Parameter

Definition

point 1

The point number to assign an elevation to.

point 2

Used with point 1 to specify the range of points affected.

elevation

The new elevation value.

amount

The amount to increment or decrement the height of point
1. To decrement the height, type a negative value.

Inserting, Removing, and Updating Points
You can access a standard set point manipulation commands from the Toolspace Survey tab collections and
items.
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The point manipulation commands are available via a right-click menu and are applicable to the points
relative to where the commands are accessed. For example, if you use the Insert into Drawing command on
an individual control point, it only inserts that control point.
Select this...

If you want to do this...

Update

Update the points in the drawing to the
values in the survey database.

Insert Into Drawing

Insert points referenced in the survey
database into the drawing.

Remove From Drawing

Remove points referenced in the survey
database from the drawing.

Updating the Drawing Points with the Survey Points
If the points in the drawing are out-of-sync with the survey database, you can update them to the values in
the survey database.
To update the drawing points with the survey database points
1 In Toolspace, on the Survey tab, right-click the collection or item for which you want to update the
points with the survey database.
2 Click Points ➤ Update.
The points in the drawing and point database are updated with the values from the survey database. Points
that are not referenced in the survey database are not affected by the Update command.
The points will not be updated if the points reside on a locked layer.

Quick Reference
Toolspace
Survey tab: right-click <collection or item> ➤ Points ➤ Update

Inserting Points into a Drawing
You can insert points into a drawing from the point database. The drawing points, which are referenced by
the points in the survey database for the applicable collection or item, are inserted.
To insert survey points into the drawing
1 In the Survey tab, right-click the collection or item for which you want the points (referenced in the
survey database) inserted, and click Points ➤ Insert Into Drawing. If you select points that are already
in the drawing, then the Duplicate Point Number dialog box is displayed.
2 Click one of the following options:
■

Skip to leave the existing point in the drawing.

■

Replace to replace the existing point in the drawing with the selected point in the point database.

■

Skip All to leave all existing points in the drawing.
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■

Replace All to replace the existing points in the drawing with the selected points in the point
database.

■

Cancel to cancel the command.

Quick Reference
Toolspace
Survey tab: right-click a collection or item ➤ Points ➤ Insert Into Drawing

Removing Points from a Drawing
You can remove points that are referenced by the survey database from the drawing.
To remove points from the drawing
➤

In the Survey tab, right-click the collection or item for which you want the points (referenced in the
survey database) removed from the drawing, and click Points ➤ Remove From Drawing.

Quick Reference
Toolspace
Survey tab: right-click a collection or item ➤ Points ➤ Remove From Drawing

Directions
A direction is an angle measured from the north or south meridian.
A direction can be formatted as either a bearing or azimuth and must be defined from an existing control
point to another point (either a false point or another control point).
A bearing is less than 90 degrees (PI/2 radians or 100 grads), and is measured clockwise in the NE quadrant,
counter-clockwise in the SE quadrant, clockwise in the SW quadrant, and counter-clockwise in the NW
quadrant.

north west bearing quadrant NW-4

north meridian
north east bearing quadrant NE-1

foresight point
foresight point

setup point

foresight point
foresight point

south meridian
south west bearing quadrant SW-3

south east bearing quadrant SE-2
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An azimuth is measured clockwise from either the north or south meridian and is always less than or equal
to 2PI.

north meridian

foresight point

north azimuth

south azimuth

setup point

foresight point
south meridian

Creating a Direction
Use the Toolspace Survey tab to create directions.
To create a direction
1 In the Toolspace Survey tab, right-click the Directions collection and click New.
2 In the New Direction dialog box, specify the point and direction information. For information about
the direction properties, see New Direction/Direction Properties Dialog Box (page 2689).
3 Click OK to create the direction.

Quick Reference
Toolspace
Survey tab: Expand Survey Databases ➤ <database name> ➤ Networks ➤ <network name> ➤ right-click
Directions ➤ New

Editing a Direction
Use the Toolspace Survey tab item view to edit directions.
You can change the direction value and type.
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To edit a direction
1 In the Toolspace Survey tab, click the Directions collection.
2 In the Survey tab item view, click the field for the direction that you want to edit. Editable fields are
colored white.
For information about common functions available in the list view, see Survey Tab Item View (page
2725).

Quick Reference
Toolspace
Survey tab: expand Survey Databases ➤ expand <named project> ➤ click Directions ➤ edit in the item
view

Baselines
You can create baselines, which are reference lines from a baseline start point and a baseline end point.
You can create or list points in respect to the defined baseline. The Inverse Point command determines the
station and offset distance of an existing point, or group of points, from an existing baseline. The
Station/Offset command creates a new point using a station and an offset distance in reference to an existing
baseline. Before you can use the Inverse Point, or the Station/Offset commands, you must define the current
baseline. If you haven't defined the baseline and you select one of these commands, you are prompted to
define the baseline.

Defining a Baseline
Use the Survey Command Window to define a baseline.
You can create a baseline as a reference line, and then create or list points in relation to the line.
NOTE For parameter descriptions, see the Quick Reference tab.
To define a baseline from the Survey Command Window menu
1 In Toolspace, on the Survey tab, right-click the network to edit, and click Survey Command Window.
2 Click Baseline menu ➤ Define Baseline.
3 Enter the point identifier for the origin of the baseline.
4 Enter the point identifier for the end point of the baseline.
5 Enter the point identifier for the starting station of the baseline.
To define a baseline, using the survey command language
1 In Toolspace, on the Survey tab, right-click the network to edit, and click Survey Command Window.
2 At the Command line, enter:
BL IS [point 1] [point 2] [station]

Command Line Example
NEZ 1 1000 1000 30.48
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NEZ 2 1500 1500 32.004
BL IS 1 2 100
The baseline runs from point 1 to point 2. Point 1 is set as station 1+00. Direction and distances are in the
current units, unless you type a qualifying suffix.
Baseline from point 1 to point 2:

baseline

point 2

point 1

station 1+00

Quick Reference
Survey Command Window
Baseline ➤ Define Baseline
Survey Command Window Syntax
BL IS [point 1] [point 2] [station]
Parameter

Definition

point 1

The existing point identifier for the beginning point of the
baseline. This point is assigned the station number given for
the station component.

point 2

The existing point identifier for the end point on the baseline.
When you assign this point, you define the direction and
length of the baseline.

station

The station for the assigned point number. Type the station
in the current distance units. Some examples of station entries
are 0, 50, and 100. For example, station 150 indicates that
the station is 150 feet or meters along the baseline.

Listing a Baseline Direction Using Inverse Point
You can determine the station and offset distance of an existing point, or group of points, from an existing
baseline with the Inverse Point command.
NOTE For parameter descriptions, see the Quick Reference tab.
To inverse a point from the Survey Command Window
1 In Toolspace, on the Survey tab, right-click the network to edit, and click Survey Command Window.
2 Click Baseline menu ➤ Inverse Point.
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3 Type the start and end of the point range for which you want the station and offset information.
NOTE You must define the baseline as a prerequisite.

To inverse a point, using the survey command language
1 In Toolspace, on the Survey tab, right-click the network to edit, and click Survey Command Window.
2 At the Command line, enter:
BL INV [point 1] (point 2)

Command Line Example
NE 1 1000 1000
STN 1
ZD 2 90 400
BL IS 1 2 100
BL PT 3 220 50
BL PT 4 270 -50
BL INV 1 4
This station and offset of points 1, 2, 3, and 4 are listed:
! Point Station Offset Elevation. Northing Easting
! 1 100.00 0.00 <Null> 1000.00 1000.00
! 2 500.00 0.00 <Null> 1000.00 1400.00
! 3 220.00 50.00 <Null> 950.00 1120.00
! 4 270.00 -50.00 <Null> 1050.00 1170.00

Quick Reference
Survey Command Window
Baseline ➤ Inverse Point
Survey Command Window Syntax
BL INV [point 1] (point 2)
Parameter

Definition

point 1

An existing point in the drawing. It does not need to be adjacent to the baseline since the baseline is infinite in length.

point 2

Used with point 1 to specify a range of points that you want
to list. If you do not specify point 2, then only point 1 is listed.

Creating a New Point from a Baseline Using a Station and Offset
You can create a new point by specifying a station on a baseline, and an offset distance in reference to an
existing baseline, with the Station/Offset command.
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NOTE For parameter descriptions, see the Quick Reference tab.
To create a point by station and offset from the Survey Command Window
1 In Toolspace, on the Survey tab, right-click the network to edit, and click Survey Command Window.
2 Click Baseline menu ➤ Station/Offset.
3 Enter the point identifier of the point you want to create.
NOTE If Auto point numbering is on, then the next point number is displayed.
4 Enter the station of the new point. The station can be a positive or a negative value.
5 Enter the offset of the new point. The offset can be a positive or a negative value.
6 Optionally, enter a description of the new point.
To create a point at an offset from a baseline, using the survey command language
1 In Toolspace, on the Survey tab, right-click the network to edit, and click Survey Command Window.
2 At the Command line, enter:
BL PT (point 1) [station] (offset) (description)

Command Line Example
NE 1 1000 1000
STN 1
ZD 2 100 121.92
BL IS 1 2 0
BL PT 3 220 15.24
! POINT 3 NORTH: 946.7889 EAST: 1214.0113 ELEV:<Null>
BL PT 4 270 -15.24
! POINT 4 NORTH: 968.1235 EAST: 1268.5445 ELEV: <Null>
Point 3 is offset a distance of 15.24 to the right of the baseline at Station 2+20 and Point 4 is offset a distance
of 15.24 to the left of the baseline at Station 2+70. Distances are in the current units, unless you type a
qualifying suffix.
Baseline created at an offset distance:

point set by Baseline Point
station 2+20
baseline

-50 ft
{-15.24 m}

50 ft
{15.24 m}
point set by Baseline Point
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station 2+70

Quick Reference
Survey Command Window
Baseline ➤ Station/Offset
Survey Command Window Syntax
BL PT (point 1) [station] (offset) (description)
Parameter

Definition

point 1

The point identifier for the new point. You do not need to assign a point number if auto point numbering is on.

station

The station location of the assigned point. Type the station in
the current distance units. Some examples of station entries
are 0, 50, and 100. For example, station 150 indicates that
the station is 150 feet or meters along the baseline.

offset

An optional distance offset from the baseline.

description

An optional description associated with the point.

Centerlines
A centerline is defined from a figure. After you define the current centerline and current cross section, you
can create new points in relation to them.
Before using the Inverse Point command, you must define the current centerline. If you haven't defined the
centerline, you are prompted to define the centerline.
The cross section commands operate in a similar manner; if you have not set the current cross section, then
you are prompted to set the cross section.
If you have not set the height of instrument and you use either the Station/ Offset Vertical Distance or the
Station/Offset Rod command, then the Set Height of Instrument command is automatically invoked. Likewise,
the Offset Rod or Offset Vertical Distance commands invoke the Prism command the first time you select
them.

Defining a Centerline
Use the Survey Command Window to quickly define a centerline.
To define a centerline, you specify a figure name, starting station, and starting point number.
If you use a point off the centerline to determine the beginning station, then a perpendicular line is established
and that intersection is the starting station. Therefore, any point you use to establish the beginning station
must be adjacent to some leg of the centerline.
NOTE For parameter descriptions, see the Quick Reference tab.
To define a centerline from the Survey Command Window menu
1 In Toolspace, on the Survey tab, right-click the network to edit, and click Survey Command Window.
2 Click Centerline menu ➤ Define Figure Centerline.
3 Enter a figure name for the centerline.
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4 Enter the starting station value.
5 Enter the starting station point identifier. This is the location to start stationing from. The starting
station is the perpendicular intersection of the starting station point identifier and the centerline.
To define a centerline, using the survey command language
1 In Toolspace, on the Survey tab, right-click the network to edit, and click Survey Command Window.
2 At the Command line, enter:
CL IS [figure] (station) (point)

Command Line Example
In the following example, the beginning of this command sequence describes how to draw the centerline
figure.
BEGIN CL1
NE 1 1000 1000
NE 2 1000 1500
NE 3 1300 1700
END
NE 4 1100 1100
CL IS CL1 500 4
! Figure CL1 is the current centerline.
! Start Station: 400.00 End Station: 1260.56
Figure CL1 is the current centerline. Assigning Point 4 a station of 5+00 results in the centerline starting at
station 4+00.
Centerline figure:

station 500
centerline figure

Quick Reference
Survey Command Window
Centerline ➤ Define Figure Centerline
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Survey Command Window Syntax
CL IS [figure] (station) (point)
Parameter

Definition

figure

The figure that you want to use as the centerline.

station

The defining station of the centerline. If you do not type a
point number, then this is the station at the beginning of the
figure. If you type a point number, then the station is at the
point you specify. When you don't specify a station, the default
0+00 is used.

point

An optional reference point for the station. The point specified
need not be on the centerline, but it must be adjacent to the
centerline (not beyond the end points).

Listing Centerline Data Using Inverse Point
You can display the station, offset, and elevation of an existing point(s) in reference to the current centerline.
NOTE For parameter descriptions, see the Quick Reference tab.
To display point data in reference to the current centerline from the Survey Command Window
1 In Toolspace, on the Survey tab, right-click the network to edit, and click Survey Command Window.
2 Click Centerline menu ➤ Inverse Point.
3 Enter the point number range you want the station, offset, and elevation information for.
To display point data in reference to the current centerline, using the survey command language
1 In Toolspace, on the Survey tab, right-click the network to edit, and click Survey Command Window.
2 At the Command line, enter:
CL INV [point 1] (point 2)

Command Line Example
BEGIN CL1
NE 1 1000 1000
NE 2 1000 1500
NE 3 1300 1700
END
CL IS CL1
CL PT 4 200 60.96
CL PT 5 625 -45.72
CL INV 1 5
! Point Station Offset Elevation Northing Easting
! 1 0.00 0.00 <Null> 1000.0000 1000.0000
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! 2 500.00 0.00 <Null> 1000.0000 1500.0000
! 3 860.56 0.00 <Null> 1300.0000 1700.0000
! 4 200.00 60.96 <Null> 939.0400 1200.0000
! 5 625.00 -45.72 <Null> 1129.3672 1531.2962
These examples return station information along the centerline. Distances are in the current units, unless
you type a qualifying suffix.

Quick Reference
Survey Command Window
Centerline ➤ Inverse Point
Survey Command Window Syntax
CL INV [point 1] (point 2)
Parameter

Definition

point 1

The point to inverse.

point 2

Used with point 1 to specify the range of points affected. This
point is optional. If you do not specify point 2, then only data
for point 1 displays.

Setting the Height of the Instrument
You can establish the instrument height to use with the Station/Offset Rod or Offset Rod commands by
using the Set Height of Instrument command.
NOTE For parameter descriptions, see the Quick Reference tab.
To set the instrument height from the Survey Command Window
1 In Toolspace, on the Survey tab, right-click the network to edit, and click Survey Command Window.
2 Click Centerline menu ➤ Set Height of Instrument.
3 Enter the instrument height.
NOTE The Set Height of Instrument command does not affect the height of the traverse station. It lets you
process level data.

To set the instrument height, using the survey command language
1 In Toolspace, on the Survey tab, right-click the network to edit, and click Survey Command Window.
2 At the Command line, enter:
HI [elevation]

Command Line Example
BEGIN CL1
NE 1 1000 1000
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NE 2 1000 1500
NE 3 1300 1700
END
CL IS CL1
HI 200
! Current HI: 200.000
The height of instrument is set to 200.00.

Quick Reference
Survey Command Window Menu
Centerline ➤ Set Height of Instrument
Survey Command Window Syntax
HI PT [elevation]
Parameter

Definition

elevation

The elevation of the optical axis of the instrument above datum
(not the height above ground).

Creating a New Point by Station Offset
You can create a new point using an offset from a station on the current centerline.
NOTE For parameter descriptions, see the Quick Reference tab.
To create a point by station offset in the Survey Command Window
1 In Toolspace, on the Survey tab, right-click the network to edit, and click Survey Command Window.
2 Click Centerline menu ➤ Station/Offset.
3 Enter the point identifier of the point you want to create.
NOTE If Auto point numbering is on, then the next point number is displayed.
4 Enter the station of the new point. The station can be a positive or a negative value.
5 Enter the offset of the new point. The offset can be a positive or a negative value.
6 Optionally, enter a description for the point.
To create a point at an offset, using the survey command language
1 In Toolspace, on the Survey tab, right-click the network to edit, and click Survey Command Window.
2 At the Command line, enter:
CL PT (point 1) [station] (offset) (skew angle) (description)
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Command Line Example
BEGIN CL1
NE 1 1000 1000
NE 2 1000 1500
NE 3 1300 1700
END
CL IS CL1
CL PT 100 200
! POINT 100 NORTH: 1000.0000 EAST: 1200.0000 ELEV: <Null>
CL PT 101 450 -91.44
! POINT 101 NORTH: 1091.4400 EAST: 1450.0000 ELEV: <Null>
102 600 152.4 50
! POINT 102 NORTH: 931.7283 EAST: 1572.2198 ELEV: <Null>
Point 100 is located at station 200 with a zero offset. Point 101 is located at station 450 with a left offset
distance of 91.44. Point 102 is located at station 600 with a right offset distance of 152.4 and a skew angle
of 50.
NOTE The point 102 input uses the Ditto command. Angles and distances are in the current units, unless you
type a qualifying suffix.
Centerline point created by a station offset:

point set by centerline point

90°
{100 grads}

station 2+00
point set by centerline point

- 300 ft
{- 91.44m m}

station 6+00
centerline figure
90°{100 grads}
45°{50 grads}

station 4+50

9 m}

Quick Reference
Survey Command Window Menu
Centerline ➤ Station/Offset
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t

500 f

{152.3
point set by centerline point

Survey Command Window Syntax
CL PT (point 1) [station] (offset) (skew angle) (description)
Parameter

Definition

point 1

The point identifier for the new point. You do not need to assign a point number if auto point numbering is on.

station

The station at which to set the point.

offset

An optional component that specifies the distance from the
centerline to the new point. A negative offset sets the point
to left of the centerline, and a positive offset sets it to the right.

skew angle

An optional component that specifies the clockwise angle to
skew the point from the centerline to create non-perpendicular
offsets. Type this value in the current angular units (DMS,
grads, decimal degrees, radians, or mils).

description

An optional description associated with the point.

Creating a Point Using a Station, Offset, and Elevation
You can create a point at a given station, offset, and elevation with respect to the current centerline.
NOTE For parameter descriptions, see the Quick Reference tab.
To create a point by station, offset, and elevation from the Survey Command Window
1 In Toolspace, on the Survey tab, right-click the network to edit, and click Survey Command Window.
2 Click Centerline menu ➤ Station/Offset Elevation.
3 Enter the point number of the point you want to create.
NOTE If Auto point numbering is on, then the next point number is displayed.
4 Enter the station of the new point. The station can be a positive or a negative value.
5 Enter the offset of the new point. The offset can be a positive or a negative value.
6 Enter the elevation for the point.
7 Optionally, enter a description for the point.
To create a point by station, offset, and elevation, using the survey command language
1 In Toolspace, on the Survey tab, right-click the network to edit, and click Survey Command Window.
2 At the Command line, enter:
CL EL (point) [station] [offset] [elevation] (description)

Command Line Example
BEGIN CL1
NE 1 1000 1000
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NE 2 1000 1500
NE 3 1300 1700
END
CL IS CL1
CL EL 100 350 45.72 58.7502
! POINT 100 NORTH: 954.2800 EAST: 1350.0000 ELEV: 58.7502

Quick Reference
Survey Command Window Menu
Centerline ➤ Station/Offset Elevation
Survey Command Window Syntax
CL EL (point) [station] [offset] [elevation] (description)
Parameter

Definition

point

The identifier of the new point that you want to create. You
do not need to assign a point number if auto point numbering
is on

station

The station of the new point.

offset

The perpendicular distance from the centerline to the new
point.

elevation

The elevation of the new point. Elevations are in the current
units, unless you type a qualifying suffix.

description

An optional description associated with the point.

Creating a New Point by Station, Offset, and Rod Height
You can create a point by specifying a station, offset, and rod height from the current centerline. The elevation
is computed by algebraically adding the rod reading to the current value set with the Set Height of Instrument
command.
NOTE For parameter descriptions, see the Quick Reference tab.
To create a point along a centerline using a rod reading from the Survey Command Window
1 In Toolspace, on the Survey tab, right-click the network to edit, and click Survey Command Window.
2 Click Centerline menu ➤ Station/Offset Rod.
3 Enter the station.
4 Enter the offset.
5 Enter the rod reading.
6 Optionally, enter a description for the point.
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To create a point along a centerline using a rod reading, using the survey command language
1 In Toolspace, on the Survey tab, right-click the network to edit, and click Survey Command Window.
2 At the Command line, enter:
CL ROD (point) [station] [offset] [rod] (description)

Command Line Example
BEGIN CL1
NE 1 1000 1000
NE 2 1000 1500
NE 3 1300 1700
END
CL IS CL1
HI 60.96
CL ROD 100 350 45.72 4.2098
! POINT 100 NORTH: 954.2800 EAST: 1350.0000 ELEV: 56.7502

Quick Reference
Survey Command Window Menu
Centerline ➤ Station/Offset Rod
Survey Command Window Syntax
CL ROD (point) [station] [offset] [rod] (description)
Parameter

Definition

point

The point identifier for the new point. You do not need to assign a point number if auto point numbering is on.

station

The station of the new point.

offset

The perpendicular distance from the centerline to the new
point.

rod

The rod height. This value is subtracted from the height of
instrument elevation to determine the elevation of the new
point.

description

An optional description associated with the point.

Creating a New Point by Station, Offset, and Vertical Distance
You can create a point given a vertical distance, with respect to the current centerline, height of instrument,
and prism height.
The elevation is computed by subtracting the prism height from the instrument height, then algebraically
adding the vertical distance.
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NOTE For parameter descriptions, see the Quick Reference tab.
To create a point along a centerline using a vertical distance from the Survey Command Window
1 In Toolspace, on the Survey tab, right-click the network to edit, and click Survey Command Window.
2 Click Centerline menu ➤ Station/Offset Vertical Distance.
3 Enter the point number of the point you want to create.
NOTE If auto point numbering is on, then the next point is displayed.
4 Enter the station of the new point. The station can be a positive or a negative value.
5 Enter the offset of the new point. The offset can be a positive or a negative value.
6 Enter the vertical distance.
7 Optionally, enter a description for the point.
To create a point along a centerline using a vertical distance, using the survey command language
1 In Toolspace, on the Survey tab, right-click the network to edit, and click Survey Command Window.
2 At the Command line, enter:
CL VD (point) [station] [offset] [vertical distance]

Command Line Example
BEGIN CL1
NE 1 1000 1000
NE 2 1000 1500
NE 3 1300 1700
END
CL IS CL1
HI 200
PRISM 5
CL VD 10 350 150 7.25
! POINT 10 NORTH: 850.0000 EAST: 1350.0000 ELEV: 202.2500

Quick Reference
Survey Command Window Menu
Centerline ➤ Station/Offset Vertical Distance
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Survey Command Window Syntax
CL VD (point) [station] [offset] [vertical distance]
Parameter

Definition

point

The identifier of the new point that you want to create. You
do not need to assign a point number if auto point numbering
is on.

station

The station of the new point.

offset

The perpendicular distance from the centerline to the new
point.

vertical distance

The elevation difference from the instrument to the prism. If
the prism is higher than the instrument, then this is a positive
value.

Setting the Current Cross Section
You can set the current cross section by station value. When the current cross section is set, you can create
new points from this occupied point by supplying the offset and elevation information.
To use the Offset Rod, Offset Elevation, and Offset Vertical Distance commands, you must set the current
cross section station.
NOTE For parameter descriptions, see the Quick Reference tab.
To set the current cross section from the Survey Command Window
1 In Toolspace, on the Survey tab, right-click the network to edit, and click Survey Command Window.
2 Click Centerline menu ➤ Set Cross Section.
3 Type the station of the current cross section.
To set the current cross section, using the survey command language
1 In Toolspace, on the Survey tab, right-click the network to edit, and click Survey Command Window.
2 At the Command line, enter:
XS [station]

Command Line Example
BEGIN CL1
NE 1 1000 1000
NE 2 1000 1500
NE 3 1300 1700
END
CL IS CL1
XS 350
Current Cross-section Station: 350.00
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Quick Reference
Survey Command Window Menu
Centerline ➤ Set Cross Section
Survey Command Window Syntax
XS [station]
Parameter

Definition

station

The station to use for subsequent cross section commands.

Creating a New Point on the Cross Section by Offset and Elevation
You can create a new point by giving an offset and elevation, with respect to the current cross section located
on the current centerline.
NOTE For parameter descriptions, see the Quick Reference tab.
To create a point with offset and elevation from the current cross section from the Survey Command Window
1 In Toolspace, on the Survey tab, right-click on the network to edit, and click Survey Command Window.
2 Click Centerline menu ➤ Offset Elevation.
3 Type the point number of the point you want to set.
4 Enter the offset.
5 Enter the elevation.
To create a point with offset and elevation from the current cross section using the survey command
language
1 In Toolspace, on the Survey tab, right-click on the network to edit, and click Survey Command Window.
2 At the Command line, enter:
XS EL (point) [offset] [elevation] (description)

Command Line Example
BEGIN CL1
NE 1 1000 1000
NE 2 1000 1500
NE 3 1300 1700
END
CL IS CL1
XS 350
XS EL 100 45.72 58.7502
! POINT 100 NORTH: 954.2800 EAST: 1350.0000 ELEV: 58.7502
Point 100 is offset from cross section 350 by a distance of 45.72 with an elevation of 58.7502. Distance and
elevations are in the current units unless you type a qualifying suffix.
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Quick Reference
Survey Command Window Menu
Centerline ➤ Offset Elevation
Survey Command Window Syntax
XS EL (point) [offset] [elevation] (description)
Parameter

Definition

point

The identifier of the new point that you want to create. You
do not need to assign a point number if auto point numbering
is on.

offset

The perpendicular distance from the centerline to the new
point.

elevation

The elevation of the new point

description

An optional description associated with the point.

Creating a New Point on the Cross Section by Offset and Rod Height
You can create a point by giving an offset and rod height with respect to the current cross section, height
of instrument, and centerline.
The elevation is computed by subtracting the rod from the current value you set with the Set Height of
Instrument command.
NOTE For parameter descriptions, see the Quick Reference tab.
To create a point by offset and rod height from the current cross section in the Survey Command Window
1 In Toolspace, on the Survey tab, right-click on the network to edit, and click Survey Command Window.
2 Click Centerline menu ➤ Offset Rod.
3 Enter the point number of the point you want to set.
4 Enter the offset of the new point. The offset can be a positive or a negative value.
5 Enter the rod height.
To create a point by offset and rod height from the current cross section, using the survey command
language
1 In Toolspace, on the Survey tab, right-click on the network to edit, and click Survey Command Window.
2 At the Command line, enter:
XS ROD (point) [offset] [rod] (description)

Command Line Example
BEGIN CL1
NE 1 1000 1000
NE 2 1000 1500
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NE 3 1300 1700
END
CL IS CL1
XS 350
HI 200
XS ROD 100 150 7.25
! POINT 100 NORTH: 850.000 EAST: 1350.000 ELEV: 192.750
Point 100 is offset from cross section 350 a distance of 150 with an elevation of 192.75 (height of instrument
- rod).

Quick Reference
Survey Command Window Menu
Centerline ➤ Offset Rod
Survey Command Window Syntax
XS ROD (point) [offset] [rod] (description)
Parameter

Definition

point

The identifier of the new point that you want to create. You
do not need to assign a point number if auto point numbering
is on.

offset

The distance from the cross section to the new point.

rod

The rod height. This value is subtracted from the height of
instrument elevation to determine the elevation of the new
point.

description

An optional description associated with the point. If you use
a description key, then specific information is assigned to the
point.

Creating a New Point on the Cross Section by Vertical Distance
You can create a point by specifying a vertical distance from the current cross section, height of instrument,
prism height, and centerline.
The elevation is computed by subtracting the prism height from the value you specified with the Set Height
Of Instrument command, and then adding the vertical distance.
NOTE For parameter descriptions, see the Quick Reference tab.
To create a point by offset and vertical distance from the current cross section in the Survey Command
Window
1 In Toolspace, on the Survey tab, right-click on the network to edit, and click Survey Command Window.
2 Click Centerline menu ➤ Offset Vertical Distance.
3 Enter the point number of the point you want to create.
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4 Enter the offset of the new point. The offset can be a positive or a negative value.
5 Enter the vertical distance.
To create a point by offset and vertical distance from the current cross section, using the survey command
language
1 In Toolspace, on the Survey tab, right-click on the network to edit, and click Survey Command Window.
2 At the Command line, enter:
XS VD (point) (offset) [vertical distance]

Command Line Example
BEGIN CL1
NE 1 1000 1000
NE 2 1000 1500
NE 3 1300 1700
END
CL IS CL1
XS 350
HI 200
PRISM 5
XS VD 100 150 7.25
! POINT 100 NORTH: 850.000 EAST: 1350.000
! ELEV: 202.2500

Quick Reference
Survey Command Window Menu
Centerline ➤ Offset Vertical Distance
Survey Command Window Syntax
XS VD (point) (offset) [vertical distance]
Parameter

Definition

point

The identifier of the new point that you want to create. You
do not need to assign a point number if auto point numbering
is on.

offset

The distance from the centerline to the new point. A positive
distance indicates an offset to the right, and a negative distance indicates an offset to the left.

vertical distance

The elevation difference from the instrument to the prism. If
the prism is higher than the instrument, then this is a positive
value.
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Intersections
You can use the intersection commands to locate intersection points between bearings, azimuths, lines, and
arcs, and to calculate the square offset.
After you find an intersection, you can save the intersection point by specifying a new point identifier.

Creating a Bearing/Bearing Intersection
You can find the point of intersection between two infinite lines from existing points.
After an intersection is found, you can save it by specifying a new point identifier.
NOTE For parameter descriptions, see the Quick Reference tab.
To calculate a Bearing/Bearing intersection in the Survey Command Window
1 In Toolspace, on the Survey tab, right-click the network to edit, and click Survey Command Window.
2 Click Intersections menu ➤ Bearing/Bearing.
3 Enter the starting point number of the first bearing.
4 Enter the bearing from that point.
5 Enter the quadrant for the first point.
6 Enter an offset for the first points.
7 Enter the starting point number of the second bearing.
8 Enter the bearing from that point.
9 Enter the quadrant for the second point.
10 Enter the offset for the second point.
To calculate a Bearing/Bearing intersection, using the survey command language
1 In Toolspace, on the Survey tab, right-click the network to edit, and click Survey Command Window.
2 At the Command line, enter:
BB [point 1] [bearing 1] [quadrant 1] [offset 1] [point 2] [bearing 2] [quadrant 2] [offset 2]

Command Line Example
NE 1 100 100
NE 2 200 200
BB 1 66.6667 1 50 2 33.3333 2 50
! INTERSECTION # 1 NORTH:100.000000 EAST:200.000000
An intersection is located between a bearing of N66.6667"E drawn from point 1, with an offset distance of
50 feet to the right and a bearing of S33.3333"E drawn from point 2 with, an offset distance of 50 to the
right.
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S30° 00'00"E
{166.67 grads}

ft
50 4 m}
.2
{15

N60° 00'00"E
{66.67 grads}

intersection located by Bearing Bearing

ft
m}
50
.24
5
{1

Quick Reference
Survey Command Window Menu
Centerline ➤ Station/Offset
Survey Command Window Syntax
BB [point 1] [bearing 1] [quadrant 1] [offset 1] [point 2] [bearing 2] [quadrant 2] [offset 2]
Parameter

Definition

point 1, point 2

The existing point identifiers that establish the beginning of
the bearings.

bearing 1, bearing 2

The bearings for the lines from the existing points. Bearings
establish a direction for each vector and are expressed in current angle units.

quadrant 1, quadrant
2

The quadrants in which the bearings exist. The possible values
are: 1 (for NE), 2 (for SE), 3 (for SW), and 4 (for NW).

offset 1, offset 2

The offsets from the lines. This acts as if the lines are moved
X feet or meters to the left or right. An offset to the right is a
positive number, and an offset to the left is a negative number.
If you do not want an offset, then use zero.

Creating an Azimuth/Azimuth Intersection
You can find the point of intersection between two infinite lines from existing points.
After an intersection is found, you can save it by specifying a new point number.
NOTE For parameter descriptions, see the Quick Reference tab.
To calculate an azimuth/azimuth intersection in the Survey Command Window
1 In Toolspace, on the Survey tab, right-click the network to edit, and click Survey Command Window.
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2 Click Intersections menu ➤ Azimuth/Azimuth.
3 Enter the starting point number of the first azimuth.
4 Enter the azimuth from that point.
5 Enter an offset.
6 Enter the starting point number of the second azimuth.
7 Enter the azimuth from that point.
8 Enter an offset.
To calculate an azimuth/azimuth intersection, using the survey command language
1 In Toolspace, on the Survey tab, right-click the network to edit, and click Survey Command Window.
2 At the Command line, enter:
AZAZ [point 1] [azimuth 1] [offset 1] [point 2] [azimuth 2] [offset 2]

Command Line Example
NE 1 100 100
NE 2 200 200
AZAZ 1 50 10 2 183.3333 -20
! INTERSECTION # 1 NORTH:186.991377 EAST:219.229524
An intersection is located between an azimuth of 50.000 drawn from point 1 with an offset distance of 10
to the right, and an azimuth of 183.3333 drawn from point 2 with an offset distance of 20 to the left.

{183.33 grads}
intersection located by
Azimuth-Azimuth

10 ft {3.05 m}

{50 grads}

Quick Reference
Survey Command Window Menu
Intersections ➤ Azimuth/Azimuth
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-20 ft {6.10 m}

Survey Command Window Syntax
AZAZ [point 1] [azimuth 1] [offset 1] [point 2] [azimuth 2] [offset 2]
Parameter

Definition

point 1, point 2

The existing point identifiers defining the beginning of the
azimuths

azimuth 1, azimuth 2

The azimuths for the lines from the existing points (point 1
and point 2). Azimuths establish a direction for each vector
and are expressed in current angle units.

offset 1, offset 2

The offsets from the lines. This acts as if the lines are moved
X feet or meters to the left or right. An offset to the right is a
positive number, and an offset to the left is a negative number.
If you do not want an offset, then use zero.

Creating a Line/Line Intersection
You can find the point of intersection between two lines defined from existing points. After an intersection
is found, you can save it by specifying a new point number.
NOTE For parameter descriptions, see the Quick Reference tab.
To create a Line/Line intersection in the Survey Command Window
1 In Toolspace, on the Survey tab, right-click the network to edit, and click Survey Command Window.
2 Click Intersections menu ➤ Line/Line.
3 Enter the starting point identifier of the first line.
4 Enter the second point identifier to define the first line.
5 Enter an offset.
6 Enter the starting point identifier of the second line.
7 Enter the second point identifier to define the second line.
8 Enter an offset.
To create a Line/Line intersection, using the survey command language
1 In Toolspace, on the Survey tab, right-click the network to edit, and click Survey Command Window.
2 At the Command line, enter:
LNLN [point 1] [point 2] [offset 1] [point 3] [point 4] [offset 2]

Command Line Example
NE 1 100 100
NE 2 200 200
NE 3 175 200
NE 4 100 200
LNLN 1 2 100 3 4 -100
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! INTERSECTION # 1 NORTH:158.578644 EAST:300.000000
An intersection is located between a line drawn between points 1 and 2 with an offset of 100 feet to the
right and a line drawn between points 3 and 4 with an offset of 100 feet to the left.

intersection located by Line-Line

0
10
ft

-100 ft
{-30.48 m}

48

0.
{3
m
}

Quick Reference
Survey Command Window Menu
Intersections ➤ Line/Line
Survey Command Window Syntax
LNLN [point 1] [point 2] [offset 1] [point 3] [point 4] [offset 2]
Parameter

Definition

point 1, point 2

The point identifiers that establish the position and direction
of vector 1. Point 1 is the end point and Point 2 is the start
point. These points can be any points including figure points.

offset 1, offset 2

The offsets from the lines. This acts as if the vectors are moved
X feet or meters to the left or right. An offset to the right is a
positive number, and an offset to the left is a negative number.
If you do not want an offset, then use a zero for the offset.

point 3, point 4

The point numbers that establish the position and direction
of vector 2. Point 3 is the end point and point 4 is the start
point. These points can be any points including figure points.

Creating a Square Offset Intersection
You can determine the offset, distance, and point of intersection where a right angle would be projected
onto an infinite line (defined by two points). After an intersection is found, you can save it by specifying a
new point identifier.
NOTE For parameter descriptions, see the Quick Reference tab.
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To create a square offset in the Survey Command Window
1 In Toolspace, on the Survey tab, right-click the network to edit, and click Survey Command Window.
2 Click Intersections menu ➤ Square Offset.
3 Enter the starting point identifier of the line.
4 Enter the second point identifier to define the line.
5 Enter the point identifier of the point offset from the line.
AutoCAD Civil 3D determines the offset distance of the point (entered in step 5) from the line established
by the first two points. This establishes one known side distance and two known side directions. Using
this information, AutoCAD Civil 3D calculates the corners of a square and creates the corner of the
square offset from the line (established in steps 3 and 4) at the same distance as defined by the point
entered in step 5.
To create a square offset, using the survey command language
1 In Toolspace, on the Survey tab, right-click the network to edit, and click Survey Command Window.
2 At the Command line, enter:
SQ [reference 1] [reference 2] [reference]

ref 1

ref
ref 2

90°

offset

ahead
intersection located by Square Offset

Command Line Examples
The following example shows a valid entry using the Square Offset command:
SQ 302 303 501
This example finds the point that creates a right angle between the line from point 302 to point 303 and
point 501.
SQ 13 14 501
This example finds the point that creates a right angle between the line from point 13 to point 14 and point
501.
The Square Offset command lists the ahead distance and offset distance to the point of intersection.

Quick Reference
Survey Command Window Menu
Intersections ➤ Square Offset
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Survey Command Window Syntax
SQ [reference 1] [reference 2] [reference]
Parameter

Definition

reference 1

The existing end point on the vector. It can be any type of
point, including a figure point.

reference 2

The existing start point on the vector. Ref 1 and Ref 2 establish
a direction on the vector.

reference

The point off the vector. The intersection point creates a right
angle between the vector and this point.

Creating an Arc/Bearing Intersection
You can calculate the intersection between a line and an arc. The line is established by a point, bearing, and
offset.
NOTE For parameter descriptions, see the Quick Reference tab.
To calculate the intersection of an arc and bearing line in the Survey Command Window
1 In Toolspace, on the Survey tab, right-click the network to edit, and click Survey Command Window.
2 Click Intersections menu ➤ Arc/Bearing.
3 Enter the point identifier of the arc center.
4 Enter the radius of the arc.
5 Enter the starting point identifier of the line.
6 Enter the bearing of the line.
7 Enter the quadrant of the line.
8 Enter an offset.
9 Enter one of the following options:
■

N: To select the northern-most intersection.

■

S: To select the southern-most intersection.

■

E: To select the eastern-most intersection.

■

W: To select the western-most intersection.

■

R: To select the solution nearest.

■

F: To select the solution farthest.

■

1: To select intersection 1.

■

2: To select intersection 2.

■

A: To select all the intersections.

■

P: To pick the intersection with your pointing device
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To calculate the intersection of an arc and bearing line, using the survey command language
1 In Toolspace, on the Survey tab, right-click the network to edit, and click Survey Command Window.
2 At the Command line, enter:
ARCB [point] [radius] [point 1] [bearing] [quadrant] [offset]

Command Line Example
NE 1 100 100
NE 2 200 200
ARCB 2 200 1 50 1 -50
! INTERSECTION # 1 NORTH:372.285978 EAST:301.575300
! INTERSECTION # 2 NORTH:98.424700 EAST:27.714022
Intersections are located between an arc radius of 200 with its center at point 2 and a bearing of 50.0000
drawn from point 1 with an offset distance of 50 to the left.

intersection located by Arc-Bearing

-50 ft {-15.24 m}
200
ft
{60
.96
m}

intersection located by
Arc-Bearing

N45°00'00"E
{50.00 grads}

Quick Reference
Survey Command Window Menu
Intersections ➤ Arc/Bearing
Survey Command Window Syntax
ARCB [point] [radius] [point 1] [bearing] [quadrant] [offset]
Parameter

Definition

point

The radial point. This is an existing point that is used as the
center point for the arc.

radius

The radial distance. This is the distance in feet or meters from
the radial point to the arc.

point 1

The existing point from which a vector extends. It can be any
type of point including a figure point.
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Parameter

Definition

bearing

The bearing of the line from the existing point. A bearing establishes a direction for the vector and is expressed in current
angle units.

quadrant

The quadrant in which the bearing exists. The possible values
are: 1 (NE), 2 (SE), 3 (SW), and 4 (NW).

offset

The offset left or right from the vector. This acts as if the line
is moved X feet. An offset to the right is a positive number,
and an offset to the left is a negative number. If you do not
want an offset, then use zero for the offset.

Creating an Arc/Azimuth Intersection
You can find the points of intersection between an arc and a line that is established by a point, azimuth,
and offset.
NOTE For parameter descriptions, see the Quick Reference tab.
To calculate the intersection of an arc and a line determined by an azimuth in the Survey Command Window
1 In Toolspace, on the Survey tab, right-click the network to edit, and click Survey Command Window.
2 Click Intersection menu ➤ Arc/Azimuth.
3 Enter the point number of the arc center.
4 Enter the radius of the arc.
5 Enter the starting point number of the line.
6 Enter the azimuth of the line.
7 Enter an offset.
8 Enter one of the following options:
■

N: To select the northern-most intersection.

■

S: To select the southern-most intersection.

■

E: To select the eastern-most intersection.

■

W: To select the western-most intersection.

■

R: To select the nearest intersection.

■

F: To select the farthest intersection.

■

1: To select intersection 1.

■

2: To select intersection 2.

■

A: To select all the intersections.

■

P: To pick the intersection with your pointing device.
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To calculate the intersection of an arc and a line determined by an azimuth, using the survey command
language
1 In Toolspace, on the Survey tab, right-click the network to edit, and click Survey Command Window.
2 At the Command line, enter:
ARCAZ [point] [radius] [point 1] [azimuth] [offset]

Command Line Example
NE 1 100 100
NE 2 200 200
ARCAZ 2 200 1 50 50
! INTERSECTION # 1 NORTH:274.411634 EAST:385.641883
! INTERSECTION # 2 NORTH:30.099879 EAST:94.482471
Intersections are located between an arc radius of 200 with its center at point 2 and an azimuth of 50.0000
drawn from point 1 with an offset distance of 50 to the right.
Intersection of arc and line determined by azimuth:

intersection located by Arc-Azimuth
200

{60

.96

ft

m}

N45°00'00"E
{50.00 grads}

50 ft {15.24 m}

intersection located by Arc-Azimuth

Quick Reference
Survey Command Window Menu
Intersections ➤ Arc/Azimuth
Survey Command Window Syntax
ARCAZ [point] [radius] [point 1] [azimuth] [offset]
Parameter

Definition

point

The radial point. This is an existing point that is used as the
center point for the arc.

radius

The radial distance in feet or meters for the first arc. Radial
distance is the length of a line from the radius point to the
arc.
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Parameter

Definition

point 1

The existing point from which a vector extends. It can be any
type of point including a figure point.

azimuth

The azimuth of the line from the existing point. An azimuth
establishes the direction for the vector and is expressed as
current angle units.

offset

The distance to offset the intersection.

Creating an Arc/Line Intersection
You can calculate the intersection(s) of a line established by two points, and an arc established by a radial
point and radius.
NOTE For parameter descriptions, see the Quick Reference tab.
To calculate an Arc/Line intersection in the Survey Command Window
1 In Toolspace, on the Survey tab, right-click the network to edit, and click Survey Command Window.
2 Click Intersections menu ➤ Arc/Line.
3 Enter the point identifier of the arc center.
4 Enter the radius of the arc.
5 Enter the starting point identifier of the line.
6 Enter the ahead or the direction point for the line.
7 Enter an offset.
8 Enter one of the following options:
■

N: To select the northern-most intersection.

■

S: To select the southern-most intersection.

■

E: To select the eastern-most intersection.

■

W: To select the western-most intersection.

■

R: To select the nearest intersection.

■

F: To select the farthest intersection. 1: To select intersection 1.

■

2: To select intersection 2.

■

A: To select all the intersections.

■

P: To pick the intersection with your pointing device.

To calculate an Arc/Line intersection, using the survey command language
1 In Toolspace, on the Survey tab, right-click the network to edit, and click Survey Command Window.
2 At the Command line, enter:
ARCLN [point] [radius] [point 1] [point 2] [offset]

340 | Chapter 11 Adding and Editing Survey Data

Command Line Example
NE 1 100 100
NE 2 200 200
NE 3 250 100
ARCLN 3 200 1 2 -100
! INTERSECTION # 1 NORTH:387.066972 EAST:245.645615
! INTERSECTION # 2 NORTH:104.354385 EAST:-37.066972
Intersections are located between an arc radius of 200 with the center at Point 3 and a line drawn between
Points 1 and 2 with an offset distance of 100 to the left.
Intersection of arc and line:

intersection located by Arc-Line
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Quick Reference
Survey Command Window Menu
Intersections ➤ Arc/Line
Survey Command Window Syntax
ARCLN [point] [radius] [point 1] [point 2] [offset]
Parameter

Definition

point

The point number of the radial (center) point.

radius

The radial distance in feet or meters. The radial distance is the
length of a line from the radius point to the arc.

point 1, point 2

The existing points that establish the position and direction
of the line. Point 1 is the start point and point 2 is the end
point. These points can be any points including figure points.
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Parameter

Definition

offset

The offset from the vector. This acts as if the line is moved a
specified number of feet (or meters) to the left or right. An
offset to the right is a positive number, and an offset to the
left is a negative number. If you do not want any offset, then
use zero.

Creating an Arc/Arc Intersection
You can calculate the intersection(s) of two arcs, each defined by an existing center point and a radius.
NOTE For parameter descriptions, see the Quick Reference tab.
To calculate the intersection of two arcs in the Survey Command Window
1 In Toolspace, on the Survey tab, right-click the network to edit, and click Survey Command Window.
2 Click Intersections menu ➤ Arc/Arc.
3 Enter the point identifier of the first arc center.
4 Enter the radius of the first arc.
5 Enter the point identifier of the second arc center.
6 Enter the radius of the second arc.
7 Enter one of the following options:
■

N: To select the northern-most intersection.

■

S: To select the southern-most intersection.

■

E: To select the eastern-most intersection.

■

W: To select the western-most intersection.

■

R: To select the nearest intersection.

■

F: To select the farthest intersection.

■

1: To select intersection 1.

■

2: To select intersection 2.

■

A: To select all the intersections.

■

P: To pick the intersection with your pointing device.

To calculate the intersection of two arcs, using the survey command language
1 In Toolspace, on the Survey tab, right-click the network to edit, and click Survey Command Window.
2 At the Command line, enter:
ARCARC [point 1] [radius 1] [point 2] [radius 2]

Command Line Example
NE 1 100 100
NE 2 200 200
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ARCARC 1 100 2 200
! INTERSECTION # 1 NORTH:8.856217 EAST:141.143783
! INTERSECTION # 2 NORTH:141.143783 EAST:8.856217
Intersections are located between an arc radius of 100 with a center at Point 1 and an arc radius of 200 with
its center at Point 2.

intersection located by Arc-Arc
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Quick Reference
Survey Command Window Menu
Intersections ➤ Arc/Arc
Survey Command Window Syntax
ARCARC [point 1] [radius 1] [point 2] [radius 2]
Parameter

Definition

point 1

The point number of radial (center) point 1.

radius 1

The radial distance in feet or meters for the first arc. The radial
distance is the length of a line from the radius point to the
arc.

point 2

The point number of radial (center) point 2.

radius 2

The radial distance in feet or meters for the second arc.

Saving Intersection Points
After you find an intersection using the Intersection commands, you can save the new intersection point.
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To save the intersection point, using the survey command language
1 In Toolspace, on the Survey tab, right-click the network to edit, and click Survey Command Window.
2 At the Command line, enter:
SAVE [NORTH, SOUTH, EAST, WEST, 1, 2, ALL] (point) (description)
NOTE For parameter descriptions, see the Quick Reference tab.

Command Line Example
SAVE NORTH 5
This saves the north intersection solution to point number 5.

Quick Reference
Survey Command Window Syntax
SAVE [NORTH, SOUTH, EAST, WEST, 1, 2, ALL] (point) (description)
Parameter

Definition

NORTH

Saves the northern most intersection.

SOUTH

Saves the southern most intersection.

EAST

Saves the eastern most intersection.

WEST

Saves the western most intersection.

1

Saves intersection 1.

2

Saves intersection 2.

ALL

Saves all intersections.

point

Saves the intersection nearest a point that you select.

description

An optional description associated with the point. If you use
a description key, then specific information is assigned to the
point.

Batch Files
Use batch files to record all survey commands that you use.
You can use the commands on the Batch File menu and the Output menu in the Survey Command Window
to provide a historical record of a surveyor's decisions. A best practice is to create a new survey network to
use in the Survey Command Window where you can perform calculations involving points from other
existing survey networks. By using a new network, the data that is being input is captured in the batch file,
where it can be edited and run with the corrections, and it will not affect the integrity of the other survey
networks.
These commands are from data that is downloaded from a field book or entered from either the menus or
at the Survey Command Window. You can open this file in your text editor to review and edit it.
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After you make changes in the batch file, you can use the Run command to insert the data and draw the
points in your drawing. The Run - Walk Through command downloads the data from the batch file and
prompts you to press a key after each command in the batch file.
To use batch files, select the Use Batch File setting in the Survey Database Settings. For more information,
see Database Settings (page 238).

Setting the Batch File
Enable default batch file functionality in the Survey Database Settings.
You can also enable and change the batch file name in the Survey Command Window or by using the survey
command language.
To set the batch file
1 In Toolspace, on the Survey tab, expand the Survey Databases collection, right-click the database, and
click Edit Survey Database Settings.
2 Expand the Survey Command Window property group.
3 Ensure that Use Batch File is selected and enter the name for the batch file.

Quick Reference
Toolspace
Survey tab: Survey Databases ➤ right-click <database-name> ➤ Edit Survey Database Settings
Survey Command Window
Use Batch File
and
Batch File ➤ Set File Name

Editing a Batch File
Use the Edit command to load the current batch file into your text editor, where you can view and edit it.
AutoCAD Civil 3D uses Notepad as the default text editor. You can specify another editor in the Survey User
Settings dialog box.
NOTE Some text editors format files. The batch file must be saved in standard ASCII format to work correctly.
To edit a batch file
1 In Toolspace, on the Survey tab, expand the Networks collection and right-click a network item. Click
Survey Command Window.
2 In the Survey Command Window, click Batch File menu ➤ Edit.
3 The batch file is opened in a text editor.
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Quick Reference
Survey Command Window
Batch File ➤ Edit

Running a Batch File
Use the Run command to load the batch file into the current project.
Running a batch file updates your drawing with any points and line work specified in the file (if the Insert
settings are enabled). For information, see Setting Import Defaults (page 233).
The Run - Slow Motion command loads the batch file at a slower rate. You can watch each command entry
as it is added to and displayed in your drawing.
Use the Run - Walk Through command to stop the action at every file line as it is read into the drawing.
This command is very helpful when you are looking for problems in the data.
To run a batch file
1 In Toolspace, on the Survey tab, expand the Networks collection and right-click a network item. Click
Survey Command Window.
2 In the Survey Command Window, click Batch File menu ➤ Run.
To run a batch file in slow motion
1 In Toolspace, on the Survey tab, expand the Networks collection and right-click a network item. Click
Survey Command Window.
2 In the Survey Command Window, click Batch File menu ➤ Run - Slow Motion.
To walk through a batch file
1 In Toolspace, on the Survey tab, expand the Networks collection and right-click a network item. Click
Survey Command Window.
2 In the Survey Command Window, click Batch File menu ➤ Run - Walk Through.
3 Press Enter after each line is displayed to continue. You must repeat this until you import the whole
file.

Quick Reference
Survey Command Window
Batch File ➤ Run
or
Batch File ➤ Run - Slow Motion
or
Batch File ➤ Run - Walk Through
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Survey Figures

12

You can use the Survey Toolspace and Survey Figure commands to create and edit survey figures, as well as to perform
figure inquiries, identifying figures, and checking them for exact course and closure.

Creating Figures
When you create a figure, it is stored in the survey database and may be also inserted into the active drawing
depending on the Survey User Settings. Create a figure by either entering coordinates or referencing an
existing point, and then giving a distance and direction to the next point.
Each figure consists of points or locations that have a relationship. You use figures to represent features such
as fences, buildings, or roads. Figures are always referenced by name, and can consist of letters and numbers.
For example: ROAD_1. One survey database may contain many figures. The AutoCAD Civil 3D Survey feature
has options to perform figure inquiries that identify a figure and determine exact courses and closure.
NOTE Numeric figure names should not start with the number zero. For example, a figure name of 235 is
acceptable but 0235 is not.

Creating a New Figure
Create new survey figures by selecting COGO Points, Survey Points, or other positions in the drawing.
In the Figure Properties dialog box, survey point numbers are associated with the vertices, and the point
number, point name, and the XYZ values are displayed. For the selected COGO points, XYZ values are
displayed and transformed if the coordinate system in the current drawing differs from the current survey
database.
To create a new figure
1 On the Survey tab in Toolspace, expand <named> survey database ➤ right-click Figures collection ➤
Create Figure Interactively.
2 In the New Figure dialog box, enter a figure name.
3 In the drawing, select point objects or use a selection window to select the points.
4 Press Enter. The Figure Properties dialog box is displayed with the new figure name and the figure
properties match the current figure prefix database. Vertices are defined from the selected point objects
or digitized points.
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5 Optionally, to edit survey point properties, in the Figure Properties dialog box, click
Survey Point Properties dialog box.

to display the

For more information on editing figure properties, see Survey Figure Properties Dialog Box (page 2704).

Quick Reference
Toolspace
Right-click Survey tab Figures collection ➤ Create Figure Interactively
Command Line
CreateNewSurveyFigure
Dialog Box
Survey Figure Properties Dialog Box (page 2704)

Creating a Figure from an Object
Create a figure by selecting an object in the drawing.
When you create a figure, it is stored in the survey database and may be also inserted into the active drawing
depending on the Survey User Settings.
You can create a survey figure from the following object types:
■

2D Line

■

3D Line

■

2D Polyline

■

3D Polyline

■

Feature Line

■

Lot Line

■

Parcel (select the parcel area label)

To create a figure from an object
1 In Toolspace, on the Survey tab, right-click the Figures collection ➤ Create Figure from Object.
2 Select an object in the drawing.
3 Specify settings in the Create Figure From Object dialog box.
4 Click OK. The figure is created and listed in the Figures collection.

Quick Reference
Ribbon
Click Home tab ➤ Create Design panel ➤
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➤ Create Figure From Object

Menu
Survey Menu ➤ Create Figure From Object ➤
Toolspace
Survey tab: Survey Databases ➤ <named survey database> ➤ Figures ➤ right-click ➤ Create Figure From
Object
Dialog Box
Create Figure From Object Dialog Box (page 2669)

Creating Breaklines from Figures
Use figures that you located in your survey as surface breaklines.
In the process of making a surface model, you can easily select the figures to use as breaklines.
To create breaklines from figures using Toolspace
1 In Toolspace, on the Survey tab, right-click Figures ➤ Create Breaklines.
2 In the Create Breaklines dialog box, click the Select Surface drop-down list and click a surface name or
click
to open the New Surface dialog box, where you can create a new surface. Figures are displayed
in the list view part of the dialog box.
3 In the Breakline column, click the check box next to the figures that you want as breaklines. Optionally,
to prevent a breakline from being created from a figure, in the list view, click the check box and set the
value to No.
NOTE Click
check boxes.

to set the breakline property for all figures to Yes. Click

to clear all the breakline property

4 Click OK to create the breaklines.
5 In the Add Breaklines dialog box (page 2615), enter a Description for the breakline operation, specify the
Type of breaklines, or specify the Mid-ordinate distance for any breaklines that have curved segments.
6 Click OK. The breaklines are inserted into to the drawing, or if necessary updated if they already exist
in the drawing.

Quick Reference
Toolspace
Survey tab: Survey Databases ➤ <survey database name> ➤ Figures collection ➤ right-click Create
Breaklines

Survey Figure Commands
Closing Figures
Close a figure by joining the last point of a figure to the first point of the same figure using the CLOSE
command.
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NOTE For syntax descriptions, see the Quick Reference tab.
To close a figure
1 In Toolspace, on the Survey tab, right-click a named network ➤ Survey Command Window.
2 At the Command line, enter:
CLOSE [figure]
To close a building figure
1 In Toolspace, on the Survey tab, right-click a named network ➤ Survey Command Window.
2 At the Command line, enter:
CLOSE BUILDING
To close a rectangle figure
1 In Toolspace, on the Survey tab, right-click a named network ➤ Survey Command Window.
2 At the Command line, enter:
CLOSE RECTANGLE [offset].
The offset is the distance to the other side of the rectangle.

Command Line Example of Closing a Figure
BEG ROAD
NE SS 1000 1000
FIG BD 90 1 100
NE SS 1400 1400
CLOSE
END

Command Line Example of Closing a Building Figure
NE 1 1000 1000
AZ 1 2 90
STN 1
BS 2
BEG HOUSE
AD 101 90 100.21
AD 102 80.30 30.54
RT 80
RT 40
RT -40
CLOSE BLD
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Command Line Example of Closing a Rectangle Figure
NE 10 2000 2000
STN 10
AZ 10 11 0
BS 11
BEG RECTA
AD 12 45 100
AD 13 30 50
CLOSE RECT -50

Quick Reference
Toolspace
Survey tab: Survey Databases ➤ <named survey database> ➤ Network ➤ right-click <named> Network ➤
Survey Command Window
Survey Command Window Syntax
CLOSE
CLOSE BUILD
CLOSE RECTANG [offset]
Command Synonyms
CLOSE BLDG
CLOSE BLD
CLOSE RECT
Parameter

Definition

figure

The name of the figure you want to close.

offset

The distance to the other side of the rectangle when you are
closing a rectangle figure.

Inserting Figures into Drawings
Insert all survey figures or selected figures into drawings.
To insert all survey figure into a drawing
■

In Toolspace, on the Survey tab, right-click the Figures collection ➤ Insert Into Drawing.

To insert selected figures into a drawing
■

In Toolspace, on the Survey tab, click the Figures collection. In the list view, select the figures to insert,
right-click ➤ Insert Into Drawing.
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Quick Reference
Toolspace
Survey tab: Figurescollection ➤ right-click <named figure> ➤ Insert Into Drawing

Creating Points on a Figure
Add survey points to the vertices of an existing figure by selecting a figure and then setting a survey point
at each figure vertex.
To create points on a figure in the Survey Command Window
1 In Toolspace, on the Survey tab, right-click a named network ➤ Survey Command Window.
2 Click Figures menu ➤ Create Points on Figures.
3 Select the figure that you want to create the points on.
4 At the Command line, enter the starting point number or accept the default. A survey point is created
for each figure vertex.

Quick Reference
Toolspace
Survey tab: Survey Databases ➤ <named survey database> ➤ Network ➤ right-click <network name>
➤ Survey Command Window

Creating a Point of Curvature on a Figure
Create a curve (on a figure) with three shots: the first at the beginning, the second on the arc between the
beginning and end of the curve, and the third at the end of the curve.
To draw a 3-point curve
1 In Toolspace, on the Survey tab, right-click a named network ➤ Survey Command Window.
2 At the Command line, enter:
C3

Command Line Example
BEG CURVE
C3
AD VA 11 85 200 90
AD VA 12 82 200 90
AD VA 13 80 190 90
END
The following illustrates the Three Point Curve command:
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instrument point
PT

point on curve
PC

Quick Reference
Toolspace
Survey tab: Survey Databases ➤ <named survey database> ➤ Network ➤ right-click <named> Network ➤
Survey Command Window
Survey Command Window Syntax
C3

Creating Multi-point Curves in a Figure
Within an active Figure, where (BEG <Figure name>) has been invoked, you can enter a figure command to
specify subsequent points to define multiple points on a curve.
After the points on the curve have been defined, you can enter a command to end the multi-point curve
and subsequent points will define line segments. The figure object created from the multi-point curve
contains contiguous arc segments for each multi-point curve range.
NOTE For syntax descriptions, see the Quick Reference tab.
To create a multi-point curve in a figure
1 In Toolspace, on the Survey tab, right-click a named network ➤ Survey Command Window.
2 At the Command line, enter:
BEGIN [figure]
3 With the BEGIN command active, enter:
MCS
The next points you enter will define the points on the curve.
4 Enter MCE to end the curve on the figure. Entering MCE does not end the figure. Enter END to end
the active figure or enter BEGIN to start a new figure.

Command Line Example
NE 1000 1000
BEG EP1
PT1
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NE SS 2 1100 1100
MCS
NE SS 3 1140 1120
NE SS 4 1800 1110
NE SS 5 1180 1070
MCE
NE SS 6 1160 1020
END

Quick Reference
Toolspace
Survey tab: Survey Databases ➤ <named survey database> ➤ Network ➤ right-click <named> Network ➤
Survey Command Window
Survey Command Window Syntax
BEGIN [figure] and then MCS
Command Synonyms
BEG and MCS to start curve
MCE to end the Multi-point Curve command
Parameter

Definition

figure

The name of the figure.

Creating a Curve on a Figure Using Point of Curvature
Specify that the next shot is a Point of Curvature (PC) in the current figure. The shot immediately following
the next shot is on the Point of Tangency (PT). This command creates a tangential arc from the last leg in
the figure.
To specify that the next shot is a Point of Curvature (PC)
1 In Toolspace, on the Survey tab, right-click a named network ➤ Survey Command Window.
2 At the Command line, enter:
PC

Command Line Example
PC
AD 13 30 25 ! Shot on PC
AD 14 33 24 ! Shot on PT
END
The following illustrates the Point of Curvature command:
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instrument point

figure start point

Quick Reference
Toolspace
Survey tab: Survey Databases ➤ <named survey database> ➤ Network ➤ right-click <named> Network ➤
Survey Command Window
Survey Command Window Syntax
PC

Creating a Curve in the Current Figure
Create a curve in the current figure using two known variables.
To create a curve
1 In Toolspace, on the Survey tab, right-click a named network ➤ Survey Command Window.
2 In the Command line, enter any capitalized curve parameters, plus the radius and the curve parameter
value:
■

CURVE DELTA [radius] [value]

■

CURVE LENGTH

■

CURVE DEFL

■

CURVE TANGENT

■

CURVE CHORD

■

CURVE MID

Quick Reference
Toolspace
Survey tab: Survey Databases ➤ <named survey database> ➤ Network ➤ right-click <named> Network ➤
Survey Command Window
Survey Command Window Syntax
CURVE DELTA [radius] [value]
CURVE LENGTH [radius] [value]
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CURVE DEFL [radius] [value]
CURVE TANGENT [radius] [value]
CURVE CHORD [radius] [value]
CURVE MID [radius] [value]
Command Synonyms
CURVE TAN
Parameter

Definition

DELTA

The value parameter indicates the angle of the circular curve.

LENGTH

The value parameter indicates the length of the circular curve.

DEFL

The value parameter indicates the deflection angle between
the current figure direction and the chord.

TANGENT, TAN

The value parameter indicates the tangent distance of the
curve.

CHORD

The value parameter indicates the chord length of the curve.

MID

The value parameter indicates the mid-ordinate distance of
the desired curve.

radius

The distance from a center point to the curve. You must enter
this value in the current survey database distance units. Use a
negative radius to draw the curve in a counter-clockwise (left)
direction.

value

A curve value that depends on the curve parameter that you
specified. For example, if you specify CHORD, then the value
is the chord length. You must enter all distances in the current
survey database distance units, and angles in the current survey
database angular units, either DMS, grads, decimal degrees,
mils, or radians. If you enter a negative value, then the negative
sign is ignored. The radius component described above is used
to control the direction of the curve.

Creating a Figure Vertex Using an Angle Distance
Create a figure vertex using an angle turned from a previous backsight. Two or more vertices must exist in
the figure to use this command.
To create a figure vertex using an angle and distance
1 In Toolspace, on the Survey tab, right-click a named network ➤ Survey Command Window.
2 At the Command line, enter:
FIGURE ANG-DIST [angle] [distance]

Command Line Example
FIG NE 1000 1000
FIG ZD 0 222.2222
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FIG AD 55.5556 304.80
AZIMUTH: 255.5556 DISTANCE: 304.8000
NORTH: 1026.301 EAST: 766.510
FIG AD 83.3333 15.240
AZIMUTH: 138.8889 DISTANCE: 15.2400
NORTH: 1017.559 EAST: 778.993
END
NOTE Distances are in the current survey database units, unless you enter a qualifying suffix.
The following illustrates the Figure Angle Distance command:

instrument point

backsight

WELL

IP

points set by Angle Distance
EL

Quick Reference
Toolspace
Survey tab: Survey Databases ➤ <named survey database> ➤ Network ➤ right-click <named> Network ➤
Survey Command Window
Survey Command Window Syntax
FIGURE ANG-DIST [angle] [distance]
Command Synonyms
FIG AD
Parameter

Definition

angle

The clockwise angle to turn from the last vertex in the figure.
Enter this value in the current survey database angular units,
either DMS, grads, decimal degrees, radians, or mils.

distance

The distance from the current vertex in the figure. Enter this
value in the current survey database distance units.
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Creating a Figure Using an Azimuth Distance
Create a new vertex from an existing vertex in the figure using an azimuth and distance. At least one vertex
must exist in the figure for this command to work.
To create a new vertex
1 In Toolspace, on the Survey tab, right-click a named network ➤ Survey Command Window.
2 At the Command line, enter:
FIGURE AZ-DIST [azimuth] [distance]

Command Line Example
BEGIN 1_95
FIG NE 2000 2000
FIG ZD 50.5556 91.440
AZIMUTH: 50.5556 DISTANCE: 91.4400
NORTH: 2057.6291 EAST: 2070.9941
CRV DELTA 152.400 9.1440
CRV LENGTH -243.840 152.400
END
The following illustrates the Azimuth Distance command:

reference meridian
azimuth
current vertex
vertex set by figure azimuth distance

last vertex
distance

Quick Reference
Toolspace
Survey tab: Survey Databases ➤ <named survey database> ➤ Network ➤ right-click <named> Network ➤
Survey Command Window
Survey Command Window Syntax
FIGURE AZ-DIST [azimuth] [distance]
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Command Synonyms
FIG ZD
Parameter

Definition

azimuth

The desired azimuth from the current vertex to the new vertex.
Enter this value in the current survey database angular units,
either DMS, grads, decimal degrees, radians, or mils.

distance

The distance from the current vertex in the figure to the new
vertex. Enter this value in the current survey database distance
units.

Creating a Figure Vertex Using a Deflection Distance
Create a figure vertex using a deflection angle and distance. The deflection angle is turned clockwise from
the current azimuth. Two or more vertices must exist in the figure to use this command.
To create a figure vertex using a deflection angle and distance
1 In Toolspace, on the Survey tab, right-click a named network ➤ Survey Command Window.
2 At the Command line, enter:
FIGURE DEFL-DIST [angle] [distance]

Command Line Example
NE 20 1200 1200
NE 21 1400 1300
BEGIN STONE_ST
PT 20
PT 21
FIG DD -33.3333 91.440
RT -91.440
FIG ZD (AZ 21 20) 60.960
CLOSE
The following illustrates the Figure Deflection Distance command:

vertex set by figure deflection distance
distance
angle
last vertex
current vertex
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Quick Reference
Toolspace
Survey tab: Survey Databases ➤ <named survey database> ➤ Network ➤ right-click <named> Network ➤
Survey Command Window
Survey Command Window Syntax
FIGURE DEFL-DIST [angle] [distance]
Command Synonyms
FIG DD
Parameter

Definition

angle

The deflection angle as measured to the new vertex.Enter this
value in the current survey database angular units, either DMS,
grads, decimal degrees, radians, or mils.

distance

The distance from the current vertex in the figure. Enter this
value in the current survey database distance units.

Creating a Figure Vertex Using a Bearing Distance
Create a new vertex in a specified direction from the current figure vertex. At least one vertex must exist in
the figure for this command to work properly.
To create a new vertex in a direction from the current figure
1 In Toolspace, on the Survey tab, right-click a named network ➤ Survey Command Window.
2 At the Command line, enter:
FIGURE BRG-DIST [bearing] [quadrant] [distance]

Command Line Example
BEG BFIG
FIG NE 1000 1000
FIG BD 61.1111 1 30.480
AZIMUTH: 61.1111 DISTANCE: 30.4800
NORTH: 1014.6902 EAST: 1026.7063
END
The following illustrates the Figure Bearing Distance command:
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quadrant 4

vertex set by figure Bearing
Distance
reference meridian

quadrant 1

bearing

last vertex
distance
current vertex

reference parallel
quadrant 2

quadrant 3

Quick Reference
Toolspace
Survey tab: Survey Databases ➤ <named survey database> ➤ Network ➤ right-click <named> Network ➤
Survey Command Window
Survey Command Window Syntax
FIGURE BRG-DIST [bearing] [quadrant] [distance]
Command Synonyms
FIG BD
Parameter

Definition

bearing

The desired bearing. Enter this value in the current survey
database angular units, either DMS, grads, decimal degrees,
mils, or radians.

quadrant

Specify the quadrant using one of the following numbers: 1
(for NE), 2 (for SE), 3 (for SW), or 4 (for NW).

distance

The measured distance from the current vertex to the new
vertex. Enter this value in the current survey database distance
units.

Creating a New Vertex with Known Coordinates
Create a new vertex by using known coordinates.
To create a new figure vertex using known coordinates
1 In Toolspace, on the Survey tab, right-click a named network ➤ Survey Command Window.
2 At the Command line, enter:
FIGURE NORTH-EAST [northing] [easting]
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Command Line Example
BEG CITY_LIMIT
FIG NE 2000 2000
FIG NE 1400 1400
FIG ZD 290 4000
FIG ZD 45 3000
CLOSE

Quick Reference
Toolspace
Survey tab: Survey Databases ➤ <named survey database> ➤ Network ➤ right-click <named> Network ➤
Survey Command Window
Survey Command Window Syntax
FIGURE NORTH-EAST [northing] [easting]
Command Synonyms
FIG NE
Parameter

Definition

northing

The northing of the new vertex location that you want to
create.

easting

The easting of the new vertex location that you want to create.

Creating a Figure Vertex Using an Existing Point as the Next Point
Enter an existing point identifier to use as the next vertex location in the figure you are drawing.
To specify an existing survey point in the survey database to be the next location of the figure
1 In Toolspace, on the Survey tab, right-click a named network ➤ Survey Command Window.
2 At the Command line, enter:
POINT [point]

Command Line Example
NE 1 1000 1000
BEG FIG
FIG NE 2000 2000
PT 1
BEARING: S 45-00-00 W DISTANCE: 1414.2136
NORTH: 1000.0000 EAST: 1000.0000
END
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Quick Reference
Toolspace
Survey tab: Survey Databases ➤ <named survey database> ➤ Network ➤ right-click <named> Network ➤
Survey Command Window
Survey Command Window Syntax
POINT [point]
Command Synonyms
PNT
RECALL
PT
Parameter

Definition

point

The point identifier of the point to use in the figure. This point
must already exist in the survey database.

Creating Right Angle Segments on a Figure
Define left and right turns, creating square sides on your figure. This is useful when drafting building
footprints. At least two vertices must exist in the current figure for this command to work properly.
To define a right turn
1 In Toolspace, on the Survey tab, right-click a named network ➤ Survey Command Window.
2 At the Command line, enter:
RT-TURN [distance]

Command Line Example
BEG HOUSE
NE 1 1000 1000
FIG ZD 100 30.480
RT 30.480
AZIMUTH: 190-00-00 DISTANCE: 30.4800
NORTH: 964.6903 EAST: 1024.7241
RT -3.048
AZIMUTH: 100-00-00 DISTANCE: 3.0480
NORTH: 964.1610 EAST: 1027.7258RT 15.240
AZIMUTH: 190-00-00 DISTANCE: 15.2400
NORTH: 949.1525 EAST: 1025.0794
CLOSE BLD
END
The following illustrates the Right Turn command:
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vertex set by right turn
(@ - distance)

(-) distance

last vertex

90°
current vertex
(+) distance

90°
vertex set by right turn
(@ + distance)

Quick Reference
Toolspace
Survey tab: Survey Databases ➤ <named survey database> ➤ Network ➤ right-click <named> Network ➤
Survey Command Window
Survey Command Window Syntax
RT-TURN [distance]
Command Synonyms
RIGHT
RT
Parameter

Definition

distance

The distance from the current vertex to the new vertex. Enter
this value in the current survey database distance units.

Creating a Point at the Current Location
Create a point at the current location as you create a figure.
To create a point at the current location in a figure
1 In Toolspace, on the Survey tab, right-click a named network ➤ Survey Command Window.
2 At the Command line, enter:
SET (point)

Command Line Example
BEG FIG
FIG NE 1000 1000
FIG ZD 0 30.480
RT 60.960
FIG AD 50 60.960
SET 5

364 | Chapter 12 Survey Figures

POINT 5 NORTH: 1077.1781 EAST: 1021.7757 ELEV: <Null>
END

Quick Reference
Toolspace
Survey tab: Survey Databases ➤ <named survey database> ➤ Network ➤ right-click <named> Network ➤
Survey Command Window
Survey Command Window Syntax
SET (point)
Parameter

Definition

point

The assigned point identifier. You do not need to assign a
point number if auto point numbering is on.

Editing Figures
Adjust the point data in a defined figure. After you enter the adjusted data, you can update and rename the
figure.
The Figures Editor, which is accessible in the Survey Toolspace, provides a centralized way of editing and
managing figure data.
IMPORTANT Figures that are created using a Linework Code Set do not automatically update when you modify
survey data by updating figures, changing survey point descriptions, editing point coordinates through changes
in observations, or network and traverse adjustment. In order to obtain the most accurate results, it is recommended
that you process the linework each time you make modifications to the survey data. For more information, see
Processing Survey Linework (page 276).

Editing Figures from the Toolspace
Use the Survey Toolspace to view and edit figure data for either multiple figures or an individual figure.
The Figures Editor provides the same editing functionality as the Figure properties list view does in Toolspace,
but is more suited for horizontal viewing of a tabulation of this type of data. The benefit of editing figures
in the Figures Editor is that you can switch to the Survey Toolspace browse through the data, and then return
to the Figures Editor and continue with your edits.
NOTE You can use the Survey Database Settings dialog box to set the Direction Type, Angle Unit,
Distance/Coordinate Unit that is displayed for the Figures Editor vista.
To view and edit figures
1 In Toolspace, on the Survey tab, do one of the following:
■

To view and edit all figures, right-click the Figures collection ➤ Edit Figures to display the Figures
Editor.
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NOTE Click
■

to display a list view for the selected figure.

To view and edit a single figure, click the Figures collection to display figures in the list view, where
you can edit the figure data.

2 Modify the fields as required by selecting the field and entering or selecting the new value.
In the Breakline field, select the check box to indicate that the figure will be used as a surface breakline
when you run the Create Breakline command.
For more information, see Creating Breaklines from Figures (page 349). When you make a change to any
figure data, the entire row is highlighted in bold until the change is saved to the survey database.
3 To edit the values in multiple rows, select the rows, right-click the column heading, click Edit. Enter
the new value. The selected row values for the column are updated with the new value.
NOTE If no rows are selected, then all rows are updated.
4 To delete figures, click the figure(s) to delete, right-click, and click Delete.
The figure icon

is replaced with

and the row is set to read-only.

5 To undo the changes for a single row or multiple rows, select the row(s), right-click, and click Reload
or Undelete. To undo all the changes in the vista, click

.

6 To apply the changes for a single row or multiple rows, select the row(s), right-click, and click Apply.
To apply all changes in the vista, click
7 Click

.

to close the vista.

Quick Reference
Toolspace
Survey tab: Survey Databases ➤ <named survey database> ➤ Figures Collection

Editing Survey Figure Vertices
Expand the Survey Figure Properties dialog box where you have editing options for each figure vertex
displayed in the list view.
You can add, remove, reorder, and change the point identifier (name or number) for each survey figure
vertex. Figure preview graphics are displayed in the drawing indicating the selected vertices. An arrow head
is displayed at the end of each segment to indicate the order (direction) of the figure vertices. Specify the
color for the current vertex in the Interactive Graphics section of the Survey User Settings. For more
information see, Survey User Settings.
The following illustration shows an example of the figure preview graphics:
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To edit survey figure vertices
1 Open the Figure Properties dialog box by doing one of the following:
■

Right-click a figure in the drawing ➤ Edit Survey Figure Properties.

■

In the drawing select a figure. On the Figure contextual tab, click Survey Figure Properties.

2 Click

to expand the dialog box.

3 Use the icons to perform editing operations. For a description of the available options, see Survey Figure
Properties Dialog Box (page 2704).
4 In the list view Number or Name column, you can clear the value to disassociate the vertex from the
referenced survey point. Enter a new point number or name if necessary. When the Number or Name
column is clear, the Easting, Northing, and Elevation columns are enabled and you can edit those
values.

Quick Reference
Ribbon
Select a figure in the drawing ➤ Figure contextual tab ➤ Survey Figure Properties
Toolspace
Survey tab ➤ click Figures collection ➤ in the figure list view select a figure ➤ right-click Properties
Command Line
EditSvFigureProperties
Dialog Box
Survey Figure Properties Dialog Box (page 2704)

Browsing to a Figure
Browse to a figure in the Figures collection on the Survey tab in Toolspace.
The figure is highlighted in the Figures collection on the Survey tab in Toolspace.
To browse to a figure
1 Click Survey tab ➤ Modify panel ➤ Browse To Survey Data Drop-down ➤ Browse To Figure

.

2 Select a figure in the drawing. The figure is displayed in the Figures Editor.
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Quick Reference
Ribbon
Survey tab ➤ Modify panel ➤ Browse To Survey Data Drop-down ➤

Browse To Figure

Menu
Click Survey menu ➤ Browse ➤ Survey Figure
Command Line
BrowseToSvFigure

Updating Survey Figure Objects
To update the survey figure drawing object
➤

Click Survey tab ➤ Modify panel ➤ Update Figure drop-down ➤ Update Figure From Survey Data

Quick Reference
Ribbon
Click Survey tab ➤ Modify panel ➤ Update Figure drop-down ➤ Update Figure From Survey Data
Toolspace
Prospector tab ➤ Survey ➤ Figures ➤ <named figure> ➤ Update from Survey Data
Command Line
UpdateFromSvFigure

Updating Survey Figure Data
To update the survey database with changes made to the figure drawing object
➤

Click Survey tab ➤ Modify panel ➤ Update Figure drop-down ➤ Update Survey Data From Drawing
.

Quick Reference
Ribbon
Click Survey tab ➤ Modify panel ➤ Update Figure drop-down ➤ Update Survey Data From Drawing
Toolspace
Prospector tab ➤ Figures collection ➤ right-click <named figure> ➤ Update from Survey Data
Command Line
UpdateSvFigureFromDwg
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.

Changing the Name of an Existing Figure
You can change the name of a figure.
To change the name of a figure
1 In Toolspace, on the Survey tab, do one of the following:
■

Right-click the Figures collection ➤ Edit Figures to display the Figures Editor.

■

Click the Figures collection to display figures in the list view.

2 Do one of the following:
■

If you are working in the Figures Editor, select the figure you want to rename.

■

If you are working in the list view, click the figure name field.

3 Enter a new name for the figure.

Quick Reference
Toolspace
Survey tab: Survey Databases ➤ <named survey database> ➤ Figures Collection

Redrawing Adjusted Figures
You can redraw all the defined figures in your survey database based on the current point coordinates.
After you adjust and update survey points, you can update the figures based on adjusted coordinates.
To update figures
➤

In Toolspace, on the Survey tab, do one of the following:
■

To update all figures, right-click the Figures collection ➤ Update Figures.

■

To update a single figure, click the Figures collection and in the list view, right- click the individual
figure ➤ Update Figure.

Quick Reference
Toolspace
Survey tab: Survey Databases ➤ <named survey database> ➤ Figures collection ➤ Update Figures

Offsetting a Figure
You can offset an existing figure by a specified distance. A positive value indicates an offset to the right; a
negative value indicates an offset to the left.
To offset a figure
1 In Toolspace, on the Survey tab, right-click a named network ➤ Survey Command Window.
2 At the Command line, enter:
OFFSET [figure] [distance]
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NOTE Numeric figure names should not start with the number zero. For example, a figure name of 235 is
acceptable but 0235 is not.

Command Line Example
NE 30 2000 2000
NE 31 2500 2500
BEGIN EASTERN_AVE
PT 30
PT 31
CRV LENGTH 60.960 91.440
FIG DD 0 91.440
CRV DELTA -121.920 6.096
END
OFFSET EASTERN_AVE 15.240
OFFSET EASTERN_AVE -6.096
The following illustrates the Offset Figure command:

figure offset (@ - distance)
second point
figure

figure
(-) distance

first point
(+) distance
figure offset (@ + distance)
before

after

Quick Reference
Toolspace
Survey tab: Survey Databases ➤ <named survey database> ➤ Network ➤ right-click <named> Network ➤
Survey Command Window
Survey Command Window Syntax
OFFSET [figure] [distance]
Command Synonyms
OFFSETS
Parameter

Definition

figure

The name of the figure you want to extend.
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Parameter

Definition

distance

The offset distance from the current point. Enter this value in
the current survey database distance units.

Ending a Figure
Use the End command to disable the DRAW mode. After you disable the DRAW mode, you can use commands
not related to the figure, such as commands to add points or plot the drawing.
NOTE The Begin and Continue commands also end the current figure. However, these commands also cause a
different figure to become the current figure.
To indicate the end of a figure
1 In Toolspace, on the Survey tab, right-click a named network ➤ Survey Command Window.
2 At the Command line, enter:
END

Command Line Example
NE 20 1200 1200
NE 21 1400 1300
BEG CONYROAD
PT 20
PT 21
CRV DELTA 300 90
FIG DD 0 300
END

Quick Reference
Toolspace
Survey tab: Survey Databases ➤ <named survey database> ➤ Network ➤ right-click <named> Network ➤
Survey Command Window
Survey Command Window Syntax
END
Command Synonyms
E

Deleting Figures
Delete figures from either the Toolspace list view or the Figure Editor vista, and also in the Survey Command
Window.
Use the Figures Editor vista to mark figures for deletion and then accept or roll back the deletions.
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To delete figures from the Toolspace list view
1 In Toolspace, on the Survey tab, click the Figures collection to display the Figures list view.
2 Right-click the figure in the list view, and click Delete.
To delete figures from the Figures Editor
1 In Toolspace, on the Survey tab, right-click the Figures collection ➤ Edit Figures to display the Figures
Editor.
2 Select the figure(s) to delete, right-click, and click Delete. The figure icon
the row is set to read-only and cannot be edited.

is replaced with a

and

3 To undo the deletion for a single row or multiple rows, select the row(s), right-click, and click Undelete.
To undo all the deletions in the vista, click

.

4 To apply the deletion for a single row or multiple rows, select the row(s), right-click, and click Apply.
To apply all deletions and changes in the vista, click

.

To delete a figure in the Survey Command Window
1 In Toolspace, on the Survey tab, right-click a named network ➤ Survey Command Window.
2 At the Command line, enter:
DELETE FIGURE <name>.

Quick Reference
Toolspace
Survey tab: Survey Databases ➤ <named survey database> ➤ clickFigures collection ➤ right-click <named>
Figurein list view ➤ Delete
Survey Command Window Syntax
DELETE FIGURE (name)
Command Synonyms
DEL FIG
Parameter

Definition

name

The name of the figure that you want to delete.

Creating Non-Tangential Curves in Figures
You can use the following commands to create non-tangential curves in the Survey Command Window.

Creating a Non-Tangential Curve in the Current Figure
Create a non-tangential curve in the current figure.
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To create a non-tangential curve
1 In Toolspace, on the Survey tab, right-click a named network ➤ Survey Command Window.
2 At the Command line, enter:
XC AD BULB [radius] [chord angle] [chord distance]
NOTE Use the BULB parameter if the resulting curve is greater than 180 degrees.

Command Line Example
NE 1 1000 1000
NE 2 1000 1200
BEG ROADCL
PT 1
PT 2
XC ZD 100 45 120
SET 3
FIG DD 0 100
SET 4
XC AD 100 45 150
SET 5
END
The following illustrates a non-tangential curve:

chord azimuth or bearing
reference meridian

point on curve

curve
end point

chord angle

chord
chord distance

centerline figure

radius
radius point
current vertex

chord deflection

Quick Reference
Toolspace
Survey tab: Survey Databases ➤ <named survey database> ➤ Network ➤ right-click <named> Network ➤
Survey Command Window
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Survey Command Window Syntax
XC AD BULB [radius] [chord angle] [chord distance]
Parameter

Definition

radius

The distance from a center point to the curve. Enter this value
in current survey database distance units. Use a negative radius
to draw the curve in a counter-clockwise (left) direction.

chord angle

The clockwise angle to turn from the last vertex in the figure.

chord distance

The distance from the current vertex in the figure.

Creating a Curve on a Figure Using a Point on the Curve
Create a non-tangent curve on a figure using three points.
NOTE For syntax descriptions, see the Quick Reference tab.
To create a curve on a figure using a point on the curve
1 In Toolspace, on the Survey tab, right-click a named network ➤ Survey Command Window.
2 At the Command line, enter:
XC C3 [point on curve] [end point]

Quick Reference
Toolspace
Survey tab: Survey Databases ➤ <named survey database> ➤ Network ➤ right-click <named> Network
➤ Survey Command Window
Survey Command Window Syntax
XC C3 [point on curve] [end point]
Parameter

Definition

point on curve

The point identifier of an existing point on the curve.

end point

The point identifier of the end point of the curve.

Creating a Curve Using a Radius Point
Create a non-tangential curve using a radius point and point at the end of the curve.
NOTE For syntax descriptions, see the Quick Reference tab.
To create a non-tangential curve using a radius point and a point at the end of the curve
1 In Toolspace, on the Survey tab, right-click a named network ➤ Survey Command Window.
2 At the Command line, enter:
XC PTS [radius] [radius point] [end point]
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Command Line Example
NE 1 1000 1000
NE 2 1000 1200
NE 3 1084.8528 1284.8528
NE 6 985.8579 1298.9949
BEG ROADCL
PT 1
PT 2
XC PTS 100 6 3
FIG DD 0 100
SET 4
XC AD 100 45 150
SET 5
END
The following illustrates two non-tangential curves:

100 ft {30.48 m}
150 ft {45.72 m}
curves created by extended curve

45° {50 grads}

45° {50 grads}
120 ft {36.58 m}
100 ft {30.48 m}

Quick Reference
Toolspace
Survey tab: Survey Databases ➤ <named survey database> ➤ Network ➤ right-click <named> Network ➤
Survey Command Window
Survey Command Window Syntax
XC PTS [radius] [radius point] [end point]
Parameter

Definition

radius

The distance from a center point to the curve. Enter this value
in current survey database distance units. Use a negative radius
to draw the curve in a counter-clockwise (left) direction.
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Parameter

Definition

radius point

The point identifier of an existing point that is used as the radial point for the arc.

end point

The point identifier of the end point of the curve.

Creating a Curve Using the Chord Bearing
Create a non-tangential curve using the chord bearing.
NOTE For syntax descriptions, see the Quick Reference tab.
To create a non-tangential curve using the chord bearing
1 In Toolspace, on the Survey tab, right-click a named network ➤ Survey Command Window.
2 At the Command line, enter:
XC BD BULB [radius] [chord bearing] [quadrant] [chord distance]

Quick Reference
Toolspace
Survey tab: Survey Databases ➤ <named survey database> ➤ Network ➤ right-click <named> Network ➤
Survey Command Window
Survey Command Window Syntax
XC BD BULB [radius] [chord bearing] [quadrant] [chord distance]
Parameter

Definition

BULB

Creates a curve that is greater than 180°.

radius

The distance from a center point to the curve. Enter this value
in the current survey database distance units. Use a negative
radius to draw the curve in a counter-clockwise (left) direction.

chord bearing

The desired bearing. Enter this value in the current survey
database angular units, either DMS, grads, decimal degrees,
mils, or radians.

quadrant

Specify the quadrant using one of the following numbers: 1
(for NE), 2 (for SE), 3 (for SW), or 4 (for NW).

chord distance

The distance from the current vertex in the figure. Enter this
value in the current survey database distance units.

Creating a Curve Using the Chord Deflection
Create a non-tangential curve using the chord deflection.
NOTE For syntax descriptions, see the Quick Reference tab.

376 | Chapter 12 Survey Figures

To create a non-tangential curve using the chord deflection
1 In Toolspace, on the Survey tab, right-click a named network ➤ Survey Command Window.
2 At the Command line, enter:
XC DD BULB [radius] [chord deflection] [chord distance]

Quick Reference
Toolspace
Survey tab: Survey Databases ➤ <named survey database> ➤ Network ➤ right-click <named> Network ➤
Survey Command Window
Survey Command Window Syntax
XC ZD BULB [radius] [chord deflection] [chord distance]
Parameter

Definition

BULB

Creates a curve that is greater than 180°.

radius

The distance from a center point to the curve. Enter this value
in the current survey database distance units. Use a negative
radius to draw the curve in a counter-clockwise (left) direction.

chord bearing

The desired bearing. Enter this value in the current survey
database angular units, either DMS, grads, decimal degrees,
mils, or radians.

chord distance

The distance from the current vertex in the figure. Enter this
value in the current survey database distance units.

Creating a Curve Using the Chord Azimuth
Create a non-tangential curve using the chord azimuth.
NOTE For syntax descriptions, see the Quick Reference tab.
To create a non-tangential curve using the chord azimuth
1 In Toolspace, on the Survey tab, right-click a named network ➤ Survey Command Window.
2 At the Command line, enter:
XC ZD BULB [radius] [chord azimuth] [chord distance]

Quick Reference
Toolspace
Survey tab: Survey Databases ➤ <named survey database> ➤ Network ➤ right-click <named> Network ➤
Survey Command Window
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Survey Command Window Syntax
XC ZD BULB [radius] [chord azimuth] [chord distance]
Parameter

Definition

BULB

Creates a curve that is greater than 180°.

radius

The distance from a center point to the curve. Enter this value
in the current survey database distance units. Use a negative
radius to draw the curve in a counter-clockwise (left) direction.

chord bearing

The desired bearing. Enter this value in the current survey
database angular units, either DMS, grads, decimal degrees,
mils, or radians.

chord distance

The distance from the current vertex in the figure. Enter this
value in the current survey database distance units.

Modifying Figures
Use the Modify Figure commands to add points, segments and vertices to existing figures.

Beginning a New Figure
You can create a figure by either entering coordinates or referencing an existing point, and then giving a
distance and direction to the next point.
Within an active Figure where (BEG <Figure name>) has been invoked, you can enter a figure command to
specify that subsequent points define multiple points on a curve. After the points on the curve have been
defined, you can enter a command to end the multi-point curve and subsequent points will define line
segments. The Polyline object created from the multi-point curve contains contiguous arc segments for each
multi-point curve range.
NOTE For syntax descriptions, see the Quick Reference tab.
To begin a new figure
1 In Toolspace, on the Survey tab, right-click a Figure collection ➤ Modify Figure ➤ Begin New Figure.
2 At the Command line, enter a figure name.
3 Pick the first point. You can pick a point on the screen with object snaps.
4 Select the next vertex by selecting a point on the screen, or entering one of the following options:
■

AD and then the angle and distance.

■

BD and then the bearing and distance.

■

ZD and then the azimuth and distance.

■

DD and then the deflection distance.

■

RT and then a negative or positive right distance, which is a right angle departure from the last leg
of the figure.

■

CU to create a curve, type the radius, and select one of the following options for creating the curve:
Select entry (Tan/Chord/Delta/Ext/Mid/Length)<Length>:
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■

PT and then the point number.

■

CL to close the figure, linking the last vertex with the first point.

Command Line Example
1000 1000
BEG EP1
PT 1
NE 2 1100 1100
MCS
NE 3 1140 1120
NE 4 1800 1110
NE 5 1180 1070
MCE
NE 6 1160 1020
END
When you use the Begin command to start another figure, any figure currently being drawn is automatically
ended.

Quick Reference
Toolspace
Survey tab: Survey Databases ➤ <named survey database> ➤ Network ➤ right-click <named> Network ➤
Modify Figure ➤ Begin New Figure
Command Line Syntax
BEGIN [figure]
Command Synonyms
BEG
Parameter

Definition

figure

The name of the figure.

Extending a Figure from the Start Point
Add segments to the start point of an existing figure. The start point of the figure becomes the first point of
the new segments.
NOTE For syntax descriptions, see the Quick Reference tab.
To extend a figure from the start point in the Survey Command Window
1 In Toolspace, on the Survey tab, right-click a Figure collection or in individual figure ➤ Modify Figure
➤ Start Figure.
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2 Enter the figure name.
3 Define the next vertex by selecting the points on screen or by entering one of the following options:
■

AD and then the angle and distance

■

BD and then the bearing and distance.

■

ZD and then the azimuth and distance.

■

DD and then the deflection distance.

■

RT and then a negative or positive right distance, which is a right angle departure from the last leg
of the figure.

■

CU to create a curve, type the radius, and select one of the following options for creating the curve:
Select entry (Tan/Chord/Delta/Ext/Mid/Length)<Length>:

■

PT and then the point identifier.

■

CL to close the figure, linking the last vertex with the first point.

Command Line Example
AP ON 1
BEG ROAD
NE SS 1000 1000
NE SS 1200 1200
NE SS 1400 1400
BEG EP
FIG NE 1300 1300
FIG ZD 180 200
START ROAD
This example starts figure ROAD, which proceeds from N 1000 E 1000 with a referenced azimuth away from
N 1300 E 1300.
NOTE The Start command, like the Continue and Begin commands, ends the current figure.

Quick Reference
Toolspace
Survey tab: Survey Databases ➤ <named survey database> ➤ Network ➤ right-click <named> Network ➤
Modify FigureStart Figure
Command Line Syntax
START [figure]
Parameter

Definition

figure

The name of the figure that you want to extend.
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Continuing a Figure
Add additional vertices to an existing figure using the last vertex entered as the starting point.
NOTE For syntax descriptions, see the Quick Reference tab.
To continue a figure in the Survey Command Window
1 In Toolspace, on the Survey tab, right-click a Figure collection or in individual figure ➤ Modify Figure
➤ Continue Figure.
2 Enter the figure name.
3 Define the next vertex by selecting the points on screen or by entering one of the following options:
■

AD and then the angle and distance

■

BD and then the bearing and distance.

■

ZD and then the azimuth and distance.

■

DD and then the deflection distance.

■

RT and then a negative or positive right distance, which is a right angle departure from the last leg
of the figure.

■

CU to create a curve, type the radius, and select one of the following options for creating the curve:
Select entry (Tan/Chord/Delta/Ext/Mid/Length)<Length>:

■

PT and then the point identifier.

■

CL to close the figure, linking the last vertex with the first point.

Command Line Example
NE 1 1000 1000
NE 2 1000 2000
STN 1
BS 2
BEG CURBA
AD 4 50 60
BEG CURBB
AD 5 60 80
AD 6 90 40
CONT CURBA
!Figure CURBA has been continued.
AD 7 20 60
END
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Quick Reference
Toolspace
Survey tab: Survey Databases ➤ <named survey database> ➤ Network ➤ right-click <named> Network ➤
Modify FigureContinue Figure
Command Line Syntax
Continue [figure]
Command Synonyms
CONT
Parameter

Definition

figure

The name of the figure that you want to continue.

Editing Figure Elevations and Figure Geometry
Use the feature line editing commands to edit survey figure elevations and figure geometry.
You can access these commands by clicking Modify tab ➤ Edit Geometry Panel or Modify tab ➤ Edit Elevations
panel. For more information on these commands see Editing Feature Lines (page 816).

Figure Inquiry Commands
Use either the Figure collection in the Survey Toolspace or the Survey Command window to access Figure
Inquiry commands to identify figures, obtain closure information, and determine the area and perimeter
for the figures in your drawing.

Identifying a Figure
Identify and display the figure name for a selected figure.
To identify a figure
1 In Toolspace, on the Survey tab, click the Figures collection.
2 In the list view, right-click a figure ➤ Properties. The properties for the figure are displayed in the
Figure Properties dialog box.
To identify a figure in the Survey Command Window
1 In Toolspace, on the Survey tab, right-click a named network ➤ Survey Command Window.
2 At the Command line, enter:
ID FIG
The following prompt is displayed:
Select figure:
After you select the figure, the figure name displays as shown below:
Name: {Figure Name}
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Quick Reference
Toolspace
Survey tab: Survey Databases ➤ <named survey database> ➤ Network ➤ right-click <named> Network ➤
Survey Command Window
Survey Command Window Syntax
ID FIG
Command Synonyms
DISP FIGS, LIST FIGS, DSP FIGS

Displaying All Figures
Use either the Survey Toolspace or the Survey Command Window Display All command to view a list of all
the existing figure names in a current drawing.
To display all the figures in the current drawing in the Survey Command Window
1 In Toolspace, on the Survey tab, right-click a named network ➤ Survey Command Window.
2 At the Command line, enter:
DISPLAY FIGS

Command Line Example
The following is an example of a typical list generated by the Display Figures command:
Figure:
PL
Alder
Drive
Drive 2
Wall

Quick Reference
Toolspace
Survey tab: Survey Databases ➤ <named survey database> ➤ Network ➤ right-click <named> Network ➤
Survey Command Window
Survey Command Window Syntax
DISPLAY FIGURES
Command Synonyms
DISP FIGS, LIST FIGS, DSP FIGS
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Listing Mapcheck Information for a Figure
Use the Mapcheck command to check your figure for length, course, perimeter, area, error of closure, or
precision information.
Calculate closure, precision, perimeter, and area using the listed distances, courses, and units based on the
current drawing unit precision set.
NOTE Use the Inverse command to return exact distances and courses, based on the current survey database
distance units in the Survey Database Settings.

Notes on Mapcheck Information
The Mapcheck report starts at the beginning of the figure. For each segment, based on the Linear and Angle
precision (set in the Survey Database Settings) then the next figure vertex XY coordinates are computed
based on the inversed direction and distance/curve data (rounded to the Linear and Angle precision values).
For closed figures, due to the fact that error is introduced into the sequential computation of vertices of the
mapcheck report, a closure error, closure direction, and precision can be calculated. The area is also based
on the computed vertex XY coordinates.
To do a Mapcheck in Toolspace
■

In Toolspace, on the Survey tab, click the Figures collection. In the list view, right-click a figure ➤ Display
Mapcheck. The Figure Display vista is displayed with the Mapcheck information for the selected figure.

To Mapcheck a figure in the Survey Command Window
1 In Toolspace, on the Survey tab, right-click a named network ➤ Survey Command Window.
2 At the Command line, enter:
MAPCHECK [figure name]
For more information about performing mapcheck on labels, see Performing a Mapcheck Analysis (page
1796).

Command Line Example
The following is a typical report generated by the Mapcheck command:
Line Length: 73.01

Course: N 00-00-00 E

Line Length: 92.99

Course: N 90-00-00 W

Line Length: 73.09

Course: S 02-36-16 E

Line Length: 89.67

Course: S 90-00-00 E

Perimeter: 328.76
Area: 6667.83

0.15 acres

Mapcheck Closure - (Uses listed courses & COGO Units)
Error Closure: 0.005
Precision 1: 70392.06
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Course: 285-27-17

Quick Reference
Toolspace
Survey tab: Survey Databases ➤ <named survey database> ➤ Network ➤ right-click <named> Network ➤
Survey Command Window
Survey Command Window Syntax
MAPCHECK FIGURE [figure]
Command Synonyms
MAPCHK FIG
CHECK FIG
CHK FIG
Parameter

Definition

figure

The name of the figure you want to mapcheck.

Listing Inverse Information for a Figure
Use the Inverse command to display the inverse information which includes the length, course, perimeter,
area, closure error, and precision information for a given figure.
Closure, perimeter, precision, and area values are calculated using the exact XY coordinate data of each
figure vertex.

Notes on Inverse Information
The Inverse report starts at the beginning of the figure. For each segment, the inverse report lists the direction
and distance, or curve data computed from the XY coordinates of the endpoints of the figure segments. The
area is calculated from the XY coordinates of each segment.
To display Inverse (exact closure) information using Toolspace
■

In Toolspace, on the Survey tab, click the Figures collection. In the list view, right-click a figure ➤
Display Inverse. The Figure Display vista is displayed with the Inverse information for the selected figure.
NOTE Figures that have vertices created using Point names will display the point name in the Point column.

To calculate the mathematical closure of a figure using the Survey Command Window
1 In Toolspace, on the Survey tab, right-click a named network ➤ Survey Command Window.
2 At the Command line, enter:
INVERSE FIGURE [figure]
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Command Line Example
The following is a typical report generated by the Mapcheck command:
Figure Name: WALL
North: 5000.000

East: 5000.000

Line Length: 431.47
North: 5429.830

Course: 355-00-19
East: 4962.435

Line Length: 265.59

Course: 43-52-25

Line Length: 609.71

Course: 93-31-48

North: 5583.743

East: 5755.061

Line Length: 954.40
North: 5000.000

Course: 232-17-32
East: 5000.000

Perimeter: 2261.16
Area: 234948.16

5.39 acres

Mathematical Closure - (Uses Survey Units)
Error Closure: 0.000

Course: 0-00-00

Error Closure: 0.000

Course: 0-00-00

Precision 1: 2261164601.60

Quick Reference
Toolspace
Survey tab: Survey Databases ➤ <named survey database> ➤ Network ➤ right-click <named> Network ➤
Survey Command Window
Survey Command Window Syntax
INVERSE FIGURE [figure]
Command Synonyms
INV FIG
Parameter

Definition

figure

The name of the figure you want to inverse.

Listing the Area and Perimeter of a Figure
Determine and report the area and perimeter of an existing figure. Use the Toolspace list view to list the
figure properties, or you can use the Area Perimeter command. The figure can be any shape, provided it is
a closed figure.
NOTE The area and perimeter information is also listed at the top of the Figure Display vista when displaying
Inverse information for the figure.
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To list the area of a figure
1 In Toolspace, on the Survey tab, right-click a named network ➤ Survey Command Window.
2 At the Command line, enter:
AREA [figure]

Command Line Example
The following is a sample valid entry using the Area command:
BEG TRIANGLENE 1 0 0NE 2 10 10NE 3 0 10CloseAREA TRIANGLEArea = 50.000 Perimeter = 46.5028

Quick Reference
Toolspace
Survey tab: Survey Databases ➤ <named survey database> ➤ Network ➤ right-click <named> Network ➤
Survey Command Window
Survey Command Window Syntax
AREA [figure]
Parameter

Definition

figure

The name of the figure for which you want to list the area and
the perimeter.

Labeling Figures
To label survey figures
1 Click Annotate tab ➤ Labels & Tables panel ➤ Add Labels menu ➤ Figure ➤ Add Figure Labels

.

2 In the Add Labels dialog box, specify the label type and label style.
To add labels to single or multiple segments
1 Click Annotate tab ➤ Labels & Tables panel ➤ Add Labels menu ➤ Figure ➤ Add Single Segment or
Multiple Segments

.

2 If you select Single Segment you are prompted to select a point on an entity in the drawing. If you
select Multiple Segment you are prompted to select an entity in the drawing.
To add tables
1 Click Annotate tab ➤ Labels & Tables panel ➤ Add Tables menu ➤ Figure ➤ Add Line/Curve/Segment
.
2 Specify values in the Table Creation dialog box.
For more information, see Add Labels Dialog Box (page 2208) and Table Creation Dialog Box (page 2739).
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Quick Reference
Ribbon
Click Annotate tab ➤ Labels & Tables panel ➤ Add Labels menu ➤ Figure ➤ Add Figure Labels
Menu
Survey menu ➤ Add Labels
Survey menu ➤ Add Tables
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Survey Analysis and
Output

13

You can use analysis tools, such as Least Squares, to make adjustments in Survey Networks as well as individual traverses.
Use the menus on the Survey Command Window to input survey data using the command line.

Least Squares Analysis
You can use Least Squares Analysis to make adjustments in Survey Networks.
A surveyor's fundamental job is making measurements, or observations, to determine the relative position
of points. In doing this, many surveyors typically make more measurements than are minimally necessary
to rule out the possibility of gross errors, or blunders, which might have occurred during the measurement
process. As a result, redundant measurements, together with random measurement errors, create a model
that is geometrically over-determined. This condition may also be referred to as an over-constrained problem.
You can calculate the most probable value for each observation by adjusting each of the observations
simultaneously so that the sum of the squares of the residuals (the difference between measured and adjusted
observations) is at a minimum. This is the origin of the term "least squares."
You use the AutoCAD Civil 3D Survey Least Squares commands to perform least squares adjustments of
surveys. Traverse loops and networks of distance and angle measurements are evaluated by the observation
equation method.

Using Least Squares with Networks
Use the Least Squares method to make adjustments to the survey observations database. These adjustments
update points in the survey database and the line work input with your survey.

Creating an Input File for a Network
The Create Input File command creates the Least Squares Network input file, network.lsi, which is generated
from station-to-station observations in the current project survey database (sideshots are not considered).
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To create an input file for a network
■

In Toolspace, on the Survey tab, expand the Networks collections. Right-click a named network ➤ Least
Squares Analysis ➤ Create Input File.

NOTE The current equipment settings are used to compute the standard deviations for each observation, when
the observation is created.

Quick Reference
Toolspace
Survey tab: expand Survey Databases ➤ <named> survey database ➤ Networks ➤ right-click <named>
network ➤ Least Squares Analysis ➤ Create Input File

Editing the Input File for a Network
Use the Edit Input File command to add or make changes to the data using the text editor you specified in
the External Editor Settings.
To edit an input file
1 In Toolspace, on the Survey tab, expand the Networks collection. Right-click a named network ➤ Least
Squares Analysis ➤ Edit Input File.
2 In the text editor, enter your changes.
3 Click File menu ➤ Save. Click Exit to leave the text editor and return to the drawing.

Quick Reference
Toolspace
Survey tab: expand Survey Databases ➤ <named> survey database ➤ Networks ➤ right-click <named>
network ➤ Least Squares Analysis ➤ Edit Input File

Processing the Input File for a Network
Use the Process Input File command to process and view the results of the Least Squares adjustment for the
network.
The program reads the input file, network.lsi. The adjustment is calculated, and the program creates a least
squares network adjustment file (network.adj) and a least squares network output file (network.lso).
To process the input file for a network
1 In Toolspace, on the Survey tab, expand the Networks collection. Right-click a named network ➤ Least
Squares Analysis ➤ Process Input File.
2 Use the scroll bar to review the information in the file. You can also save the output file to a new
filename, or print the file to your printer.
The least squares network output file initially displays the Survey Least Squares calculations data, based
on the processed network.lsi input file.
3 Page down to display the observation data for the network.

390 | Chapter 13 Survey Analysis and Output

The measured observations and standard deviations are the values that existed before the Least Squares
adjustment. The adjusted observations and residuals are the results of the Least Squares adjustment.
4 Page down again to display the adjusted coordinates for the network. The point identifiers, northing,
easting, northing standard deviation, and easting standard deviation for each unknown point are listed.
5 Page down to the end of the file to display the error analysis for the network. The values of the semi-major
and semi-minor axes, as well as the axis azimuth of the error ellipse for each unknown point are listed.

Quick Reference
Toolspace
Survey tab: expand Survey Databases ➤ <named> survey database ➤ Networks ➤ right-click <named>
network ➤ Least Squares Analysis ➤ Process Input File

Displaying the Output File for a Network
Use the Display Output File command to view information about a network. The least squares network
output file, network.lso, is automatically loaded into the text editor.
To display the output file for a network
1 In Toolspace, on the Survey tab, expand the Networks collections. Right-click a <named> network ➤
Least Squares Analysis ➤ Display Output File.
2 Use the scroll bar to review the information in the file. Optionally, from the viewer, save the output
file to a new file name, or print the file to your printer.

Quick Reference
Toolspace
Survey tab: expand Survey Databases ➤ <named> survey database ➤ Networks ➤ right-click <named>
network ➤ Least Squares Analysis ➤ Display Output File

Updating the Survey Database with Adjusted Coordinates
Use the Update Survey Database command to import the adjusted network points in the survey database
and their graphic information into the current drawing. The Least Squares network adjustment file, network.adj,
is automatically selected.
To update the database with the adjusted network coordinates
1 In Toolspace, on the Survey tab, expand the Networks collections. Right-click a <named> network ➤
Least Squares Analysis ➤ Update Survey Database.
2 In the Least Squares Adjusted File Selection dialog box, select the network.adj file.
When you update the survey database and insert the network into the drawing, the network object can
display error ellipses according to the Style properties for the network.
The following illustration shows the least squares network:

Using Least Squares with Networks | 391

Quick Reference
Toolspace
Survey tab: expand Survey Databases ➤ <named> survey database ➤ Networks ➤ right-click <named>
network ➤ Least Squares Analysis ➤ Update Survey Database

Least Squares Formulas
You can use these formulas as a reference for Least Squares analysis.

Least Squares Algorithm
The algorithm used by the AutoCAD Civil 3D Survey Least Squares program uses a series of matrixes and
formulas.
This algorithm is used to determine the probable position of points based on the least squares method.
The following matrix equation, based on a system of weighted observations, is solved iteratively:

where:
■

X is a matrix that contains the difference between the current coordinates and the new coordinates of
each unknown station, and that updates the current coordinates with each iteration (until X @ 0.0).

■

A is a matrix that is created from the observations and coordinates of the points, based on a linearization
by a Taylor series expansion of the specific observation type.

■

P is a diagonal matrix with the standard deviations, or weights, of the observations.

■

L is a matrix that contains the difference between measured observations and calculated observations.
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Horizontal Survey Adjustment
The first step in the adjustment of a horizontal survey is the calculation of C, the coordinate matrix, with
the approximate coordinates for all stations.

Next, the L matrix is calculated based on the calculated observations derived from the coordinate matrix,
C, and the measured observations. The following formula is used to determine each Li observation value:

where:
■

Omeas = the observation as measured

■

Ocalc = the observation as calculated

The L matrix appears as follows:

Next, the diagonal weight matrix, P, is calculated based on the standard deviations of distances and angles.
The following formulas are used to solve for
angular value:

, the weighted distance value, and

, the weighted

where:
is the standard deviation of the length ij, and
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where:
is the standard deviation of angle jik

The final step is to calculate the A matrix, which relates the changes in coordinates to each observation
determined through the use of distance observation equations and angle or azimuth/bearing observation
equations. These equations are initially nonlinear, so the Taylor series approximation is used to render them
as linear equations.

Distance Observation Equation Geometry
The change in coordinates for each observation is expressed in the following Taylor series approximations
of the distance observation equation:

and

where
■

Lij = the observed length of line IJ

■

Xi, Yi = the most probable coordinates of point I

■

Xj, Yj = the most probable coordinates of point J
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The following illustration shows the geometry of the distance observation equation:

residual error
reference meridian
observed length of line IJ
most probable coordinates for point J

most probable coordinates for point I

reference parallel

Angle Observation Equation Geometry
The change in coordinates for each observation is expressed in the following Taylor series approximations
of the angle observation equation:

where
■

Lij = the observed length of line IJ

■

Lik = the observed length of line IK

■

Lik = the observed length of line IK

■

Xi, Yi = the most probable coordinates of point I

■

Xj, Yj = the most probable coordinates of point J

■

Xk, Yk = the most probable coordinates of point K

The following illustration shows the geometry of the angle observation equation:
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most probable
coordinates for point J
observed angle
most probable
coordinates for point K

reference meridian

residual error
most probable
coordinates for point I
reference parallel

Azimuth/Bearing Observation Equation Geometry
The change in coordinates for each observation is expressed in the following Taylor series approximations
of the azimuth/bearing observation equation:

and

where
■

Lij = the observed length of line IJ

■

Xi, Yi = the most probable coordinates of point I

■

Xj, Yj = the most probable coordinates of point J

The following illustration shows the geometry of the azimuth/bearing observation equation:
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observed Azimuth/Bearing
reference
meridian

most probable
coordinates for point J

residual error
reference parallel

Weighted Observations
The following calculated values are used in the A matrix:

The computed matrices A, P, and L are now plugged into the matrix formula for a system of weighted
observations to solve for the X matrix, as stated previously:

This results in the X matrix, that consists of the difference between the current coordinates and the most
probable values for the coordinates:

These values are used to revise the coordinate matrix, C. The iteration process continues, recalculating the
A, P, and L matrices and solving for the X matrix until the values in the X matrix are negligible.
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After the X matrix values have reached the desired limits, the V matrix is calculated. This matrix consists of
the residuals after adjustment and is solved for by the following matrix equation:

This results in the V matrix, which appears as follows:

Chi-Square Value and Goodness-of-Fit Test
Chi-square distribution is a probability tool used in hypothesis testing. In the case of least squares adjustment,
original observations are compared to adjusted observations and evaluated in terms of how widely these
observations vary with respect to each other.
The following formula is used to calculate X2, the chi-square value:

where
■

m = the number of observation equations

■

vi = the residual value from the V matrix

■

pi = the corresponding weight from the P matrix

The X2 value is small if the adjusted observations are close to the corresponding measured observations.
This is referred to as a "good fit." A goodness-of-fit test is then conducted in which the X2 value is compared
to those from a table of critical values of chi-square distribution at the 5% level. A X2 value below that listed
in the table passes, while a larger X2 value than that listed fails, indicating possible blunders in the initial
surveying measurements.

Standard Deviation Computations
Calculation of the covariance matrix, Q, is next. The covariance matrix consists of the coefficients of the
unknowns from the observation equations, and is used to compute standard deviations and error ellipses.
The following matrix formula, using the previously solved A and P matrices, is used:

The Q matrix appears as follows:
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Next, the calculation of the degrees of freedom in an adjustment, r, is accomplished through the use of the
following formula:

where
■

m = the number of observation equations

■

n = the number of unknowns (or 2n in the case of coordinates, since both x and y are unknown)

The next procedure is the calculation of the standard deviation of unit weight for a weighted adjustment,
So, which is done through the following matrix formula:

where
■

r = the degree of freedom in the adjustment

Calculation of the standard deviations of the individual adjusted quantities,
by the following formula:

, is next. These are determined

where
■

■

So = the standard deviation of unit weight
= the diagonal element in the ith row and ith column from the covariance matrix Q

Error Rectangles and Ellipses
After the completing the Least Squares adjustment, the covariance matrix is used to calculate the positional
standard deviations

and

.

The following illustration shows that standard deviations represent half-dimensions of the standard 68%
probability error rectangle around each point:
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major axis

adjusted point

standard error ellipse

standard error rectangle

minor axis

Where:
■

t = the orientation of the error ellipse, the direction of the semi-major axis

■

u = semi-major axis of the error ellipse

■

v = the semi-minor axis error ellipse

■

x = half-width dimension of the error rectangle

■

y = half-height dimension of the error rectangle

■

S = Positional standard deviation of a point

Standard Error Rectangle and Ellipse Geometry
To further refine this process, a standard error ellipse can also be drawn. Using an F distribution from applied
statistics, either a 95% or 99% probability error ellipse is created. This ellipse has arcs tangent to the sides
of the error rectangle, with its orientation determined by an angle, t, and auxiliary orthogonal u-v axes.
Again, values from the covariance matrix are used to calculate the t angle and the associated semi-major
and semi-minor axes.
First solve three variables to use in equations that determine the semi-major and semi-minor axes: K, Quu
and Qvv.
The following formulas are used:

and
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where
Qxx, Qyy, and Qxy are values from the covariance matrix.

■

Then, these values are used to solve two equations to determine Su, the semi-major axis length and Sv, the
semi-minor axis length:

and

where
So = standard deviation of unit weight

■

Finally, the angle t, which the u axis makes with the Y axis, is solved for by the following equation:

The adjusted point is most likely found within this ellipse with either a 95% or 99% degree of confidence.

Traverses
Use the Traverses collection to manage the existing traverses defined within the network.
You can create a traverse from data in a field book file, or use the Traverse Editor to manually enter survey
data, for example hand notes or data from a site plan. Using the Traverse Editor is an efficient way to view
and edit all the setups in a traverse contained in a Network.

Creating Traverses
Create traverses to perform traverse closure analysis such as Compass Rule, Crandall Rule, or Transit Rule.
You can also perform a least squares analysis on a traverse.
You can create a traverse from data that you import from a field book file, or use the Traverse Editor to
manually enter traverse observations.
To create a traverse
1 In Toolspace, on the Survey tab, expand the Networks collections. Expand a network ➤ right-click
Traverses ➤ New.
2 In the New Traverse dialog box, click a cell in the Value column and enter values. Click OK.
NOTE Observations created using Point names will display in the Value column.
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Quick Reference
Toolspace
Survey tab: expand Survey Databases ➤ <named> survey database ➤ Networks ➤ <named network>
➤ Traverses ➤ New
Dialog Box
Traverse Editor (page 2721)

Editing Traverse Properties
Change the initial properties for a traverse in the Traverse Properties dialog box.
To edit traverse properties
1 In Toolspace, on the Survey tab, expand the Networks collections. Expand a named network ➤ Traverses.
2 Click the Traverses collection. In the list view, right-click a named traverse ➤ Properties
3 In the Traverse Properties dialog box, click a cell in the Value column and make any necessary changes.
4 Click OK.

Quick Reference
Toolspace
Survey tab: expand Survey Databases ➤ <named> survey database ➤ Networks ➤ <named network>
➤ Traverses ➤ <named> traverse ➤ right-click Properties
Dialog Box
New Traverse (page 2696)

Editing Traverses
Edit the properties of all traverses using the Traverses Editor panorama window, or edit an individual traverse
in the Traverse Editor.
To edit traverses
1 In Toolspace, on the Survey tab, expand the Networks collections. Expand a named network. Right-click
Traverses ➤ Edit.
2 In the Traverses Editor Panorama window, click a cell and enter changes.
3 Right-click a cell and click New to create a traverse or click Delete to remove an existing traverse.
To edit individual traverse observations using the Traverse Editor
1 In Toolspace, on the Survey tab, expand the Networks collections. Expand a named network.
2 Click the Traverses collection. In the list view, right-click a named traverse ➤ Edit.
3 In the Specify Initial Setup dialog box, enter the Initial Station and the Initial Backsight. Click OK.
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4 If you have defined the traverse, the current Setup property list is displayed on the left side of the
panorama. In the current Setup property list you can edit the Backsight Orientation, Backsight Face1
and BacksightFace2 settings, and the Instrument Height.
NOTE If the Setup you select is the initial setup for the traverse and the backsight point is not defined by a
control point, you can enter the backsight direction. If the backsight direction is not assigned in the setup
properties, you can enter it as a backsight observation.
5 Expand each Station point. Enter or edit the observations for each Setup. A new blank observation row
is added to the last setup observation where you can enter a new backsight or foresight observation.
NOTE Observations created using Point names will display the name in the Name column.
6 Specify a backsight observation in a new row by entering the point identifier for the setup.
7 Specify a foresight observation to the next station point by entering a point identifier that has not been
referenced in the current traverse.
When you specify the new foresight point identifier, the next Station point and setup are created.
NOTE Once you have referenced a foresight point identifier, all new foresight observations must use the
same point identifier.
8 Click

to apply the changes.

Quick Reference
Toolspace
Survey tab: survey Survey Databases ➤ <named> survey database ➤ Networks ➤ <named network> ➤
Traverses ➤ right-click Edit
Survey tab: expand Survey Databases ➤ <named> survey database ➤ Networks ➤ <named network>
➤ Traverses ➤ <named> traverse ➤ right-click Edit
Dialog Box
Traverse Editor (page 2721)

Performing Traverse Analysis
Analyze traverse data to determine the error of closure and to update the observations and survey data that
is changed by the traverse adjustment.
To perform traverse analysis
1 In Toolspace, on the Survey tab, expand the Networks collections. Expand a named network ➤
Traversescollection ➤ right-click named traverse ➤ Traverse Analysis.
2 Review the settings in the Traverse Analysis dialog box. Enter any changes and click OK.
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Quick Reference
Toolspace
Survey tab: expand Survey Databases ➤ <named> survey database ➤ Networks ➤ <named network> ➤
Traverses ➤ <named> traverse ➤ right-click Traverse Analysis
Dialog Box
Traverse Analysis Dialog Box (page 2732)

Mapcheck Analysis
Perform a Mapcheck Analysis by selecting AutoCAD Civil 3D line and curve labels to determine values from
label objects based on the precision of the annotation of the label object, or enter mapcheck data manually.
For more information, see Mapcheck Analysis (page 1795).

Displaying Point Information
You can use the Point Information commands to list angle, distance, and bearing information about the
points that exist in the survey database.

Listing the Horizontal Angle Between Points
Display the angle between any three points in the survey database. You must specify a backsight point,
instrument point, and ahead point.
To list the horizontal angle between three points in the Survey Command Window
1 In Toolspace, on the Survey tab, right-click a named network ➤ Survey Command Window.
2 In the Survey Command Window, click Point Information menu ➤ Angle.
3 Enter the point identifier of the backsight.
4 Enter the point identifier of the instrument point.
5 Enter the point identifier of the foresight point.
To list the horizontal angle between three points in the Survey Command Window
1 In Toolspace, on the Survey tab, right-click a named network ➤ Survey Command Window.
2 At the command line, enter:
ANGLES [point 1] [point 2] [point 3]

Command Line Example
NE 1 1200 1200
NE 2 1000 1000
NE 3 800 1100
ANGLE 1 2 3
Angle: 108-26-06
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Quick Reference
Survey Command Window Menu
Point Information ➤ Angle
Survey Command Window Syntax
ANGLES [point 1] [point 2] [point 3]
Command Synonyms
ANGLE
ANGS
ANG
A
Parameter

Definition

point 1

The point identifier of the backsight.

point 2

The point identifier of the station.

point 3

The point identifier of the foresight.

Listing the Bearing Between Two Points
Use the Bearing command to list the bearing from one point to another.
To list a bearing between two points in the Survey Command Window
1 In Toolspace, on the Survey tab, right-click a named network ➤ Survey Command Window.
2 In the Survey Command Window, click Point Information menu ➤ Bearing.
3 Enter the point identifier of the start point.
4 Enter the point identifier of the ahead point.
To list a bearing between two points at the Survey Command Window
1 In Toolspace, on the Survey tab, right-click a named network ➤ Survey Command Window.
2 At the command line, enter:
BEARINGS [point 1] [point 2] or
B [point 1] [point 2]

Command Line Example
The following example shows a valid entry using the Bearing command:
NE 1 1000 1000
NE 2 2000 2000
B12
Bearing: N 45-00-00 E
The bearing between point 1 and point 2 is listed.
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The following example shows a valid entry using the Bearing command to define an observed bearing.
Angles are in the current survey database units.
NE 1 1000 1000
NE 2 2000 2000
B 1 2 50 1
Observed direction: N 50-00-00 E

Quick Reference
Survey Command Window Menu
Point Information ➤ Bearing
Survey Command Window Syntax
B [point 1] [point 2] [observed bearing] [quadrant]
Command Synonyms
BEARINGS
BRGS
Parameter

Definition

point 1

The point identifier of the origin of the bearing.

point 2

The point identifier to which the bearing is measured. The
bearing is measured from point 1 to point 2.

observed bearing

The observed bearing between point 1 and point 2.

quadrant

The quadrant for the bearing. Specify the quadrant using one
of the following numbers: 1 (for NE), 2 (for SE), 3 (for SW),
or 4 (for NW).

Listing the Azimuth Between Two Points
You can list the azimuth between two points in the survey database using the Azimuth command.
To list the azimuth between two points in the Survey Command Window
1 In Toolspace, on the Survey tab, right-click a named network ➤ Survey Command Window.
2 In the Survey Command Window, click Point Information menu ➤ Azimuth.
3 Enter the point identifier of the start point.
4 Enter the point identifier of the ahead point.
To list the azimuth between two points at the Command line in the Survey Command Window
1 In Toolspace, on the Survey tab, right-click a named network ➤ Survey Command Window.
2 At the command line, enter:
AZIMUTH [point 1] [point 2] (observed azimuth)
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Command Line Example
The following example shows a valid entry using the Azimuth command to list an azimuth. Angles are in
the current survey database units.
NE 1 1000 1000
NE 2 2000 2000
AZ 1 2
Azimuth: 45-00-00
The following example shows a valid entry using the Azimuth command to define an observed azimuth.
NE 1 1000 1000
NE 2 2000 2000
AZ 1 2 50
Observed direction: 50-00-00

Quick Reference
Survey Command Window Menu
Point Information ➤ Azimuth
Survey Command Window Syntax
AZIMUTH [point 1] [point 2] (observed azimuth)
Command Synonyms
AZM
AZ
Parameter

Definition

point 1

The point identifier of the origin of the azimuth.

point 2

The point identifier to which the azimuth is measured. The
azimuth is measured from point 1 to point 2.

observed azimuth

The observed azimuth between point 1 and point 2.

Listing the Distance Between Two Points
Use the Distance command to determine the horizontal distance between two points in the survey database.
To determine the distance between two points in the Survey Command Window
1 In Toolspace, on the Survey tab, right-click a named network ➤ Survey Command Window.
2 In the Survey Command Window, click Point Information menu ➤ Distance.
3 Enter the point identifier of the start point.
4 Enter the point identifier of the ahead point.
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To determine the distance between two points at the Command line in the Survey Command Window
1 In Toolspace, on the Survey tab, right-click a named network ➤ Survey Command Window.
2 At the command line, enter:
DISTANCE [point 1] [point 2]

Command Line Example
The following example shows a valid entry using the Distance command:
NE 1 1000 1000
NE 2 2000 2000
D12
Distance: 1414.21

Quick Reference
Survey Command Window Menu
Point Information ➤ Distance
Survey Command Window Syntax
DISTANCE [point 1] [point 2]
Command Synonyms
DIST
DIS
D
HDIST
HD
LENGTH
Parameter

Definition

point 1 and point 2

The two existing points between which the distance is determined.

Listing the Direction and Distance Between Points
Use the Inverse Points command to determine the direction and distance between two points.
To inverse points in the Survey Command Window
1 In Toolspace, on the Survey tab, right-click a named network ➤ Survey Command Window.
2 In the Survey Command Window, click Point Information menu ➤ Inverse Points.
3 Enter the point identifier of the start point.
4 Enter the point identifier of the ahead point.
To inverse points at the Command line in the Survey Command Window
1 In Toolspace, on the Survey tab, right-click a named network ➤ Survey Command Window.
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2 At the command line, enter:
INVERSE POINTS [point 1] [point 2]

Command Line Example
The information is based on the current display setting and is calculated from the lines between points one
and two, two and three, and from three to one. The command then computes and displays the area.
The following example shows a valid entry using the Inverse Points command when units are set to feet:
NE 1 100 100
NE 2 100 200
NE 3 50 150
INV PTS 1 2
POINT 1 NORTH: 100.0000 EAST: 100.0000 ELEV: <Null>
Distance: 100.000 Course: N 90-00-00 E
POINT 2 NORTH: 100.0000 EAST: 200.0000 ELEV: <Null> 3
Distance: 70.710 Course: S 45-00-00 W Perimeter: 170.7
POINT 3 NORTH: 50.0000 EAST: 150.0000 ELEV: <Null> 1
Distance: 70.710 Course: N 45-00-00 W Perimeter: 241.4
POINT 1 NORTH: 100.0000 EAST: 100.0000 ELEV: <Null>
Area: 2500.00 0.06 acres
The following is an example of a valid metric entry using the Inverse Points command:
NE 1 100 100
NE 2 100 200
NE 3 50 150
INV PTS 1 2
POINT 1 NORTH: 100.0000 EAST: 100.0000 ELEV: <Null>
Distance: 100.000 Course: 100.0000
POINT 2 NORTH: 100.0000 EAST: 200.0000 ELEV: <Null> 3
Distance: 70.710 Course: 250.0000 Perimeter: 170.7
POINT 3 NORTH: 50.0000 EAST: 150.0000 ELEV: <Null> 1
Distance: 70.710 Course: 350.0000 Perimeter: 241.4
POINT 1 NORTH: 100.0000 EAST: 100.0000 ELEV: <Null>
Area: 2500.00 0.25 hectares

Quick Reference
Survey Command Window Menu
Point Information ➤ Inverse Points
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Survey Command Window Syntax
INVERSE POINTS [point 1] [point 2]
Command Synonyms
INV PNTS
INV PTS
Parameter

Definition

point 1 and point 2

The two existing points between which the relevant information displays.

Listing an Angle and Distance Using the Inverse Radial
You can use the Inverse Radial command to determine the angle and distance from a setup in a radial
direction from the backsight point. You must specify a backsight point identifier, an instrument point
identifier, and a foresight point.
To list angle and distance information using the Inverse Radial in the Survey Command Window
1 In Toolspace, on the Survey tab, right-click a named network ➤ Survey Command Window.
2 In the Survey Command Window, click Point Information menu ➤ Inverse Radial.
3 Enter the point identifier of the backsight.
4 Enter the point identifier of the instrument point.
To list angle and distance information using the Inverse Radial at the Command line in the Survey Command
Window
1 In Toolspace, on the Survey tab, right-click a named network ➤ Survey Command Window.
2 At the command line, enter:
INVERSE RADIAL [backsight] [station]

Command Line Example
The following example shows a valid entry using the Inverse Radial command:
NE 1 100 100
NE 2 200 200
NE 3 175 300
NE 4 300 200
NE 5 310 220
NE 6 200 250
INVERSE RADIAL 2 1
Inverses reference instrument at point 2 backsighting point 1 3
Angle: 24-26-38 Distance: 213.600
POINT 3 NORTH: 175.000 EAST: 300.000 ELEV: <Null> 4 6
Angle: 341-33-54 Distance: 223.610

410 | Chapter 13 Survey Analysis and Output

POINT 4 NORTH: 300.000 EAST: 200.000 ELEV: <Null>
Angle: 344-44-42 Distance: 241.870
POINT 5 NORTH: 310.000 EAST: 220.000 ELEV: <Null>
Angle: 11-18-36 Distance: 180.280
POINT 6 NORTH: 200.000 EAST: 250.000 ELEV: <Null>
The instrument is set on point 2, backsights point 1, and gives the angle turned from line 2-1 to line 2-3.
This command returns the distance from point 2 to point 3, then does the same for points 4 through 6.

Quick Reference
Survey Command Window Menu
Point Information ➤ Inverse Radial
Survey Command Window Syntax
INVERSE RADIAL [backsight] [station]
Command Synonyms
INV RADIUS
INV RAD
Parameter

Definition

backsight

The known reference point or line.

station

The point where the instrument is located (the occupied
point).

Listing the Elevation Distance Between Two Points
Use the Vertical Distance command to determine the elevation difference between two points in the survey
database.
To list the elevation distance in the Survey Command Window
1 In Toolspace, on the Survey tab, right-click a named network ➤ Survey Command Window.
2 In the Survey Command Window, click Point Information menu ➤ Vertical Distance.
3 Enter the point identifier of the start point.
4 Enter the point identifier of the ahead point.
To list the elevation distance at the Command line in the Survey Command Window
1 In Toolspace, on the Survey tab, right-click a named network ➤ Survey Command Window.
2 At the command line, enter:
VDIST [point 1] [point 2]

Command Line Example
The following example shows a valid entry using the Vertical Distance command:
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NEZ 1 100 100 30.480
NEZ 2 200 200 33.528
VD 1 2
Vertical distance 3.048
This example determines the vertical distance from point 1 to point 2. A positive value indicates that point
2 is higher than point 1.

Quick Reference
Survey Command Window Menu
Point Information ➤ Vertical Distance
Survey Command Window Syntax
VDIST [point 1] [point 2]
Command Synonyms
VD
Parameter

Definition

point 1 and point 2

These are the two existing points in the survey database.

Listing the Slope Distance Between Two Points
Use the Slope Distance command to determine the slope distance between two points.
To determine the slope distance between two points in the Survey Command Window
1 In Toolspace, on the Survey tab, right-click a named network ➤ Survey Command Window.
2 In the Survey Command Window, click Point Information menu ➤ Slope Distance.
3 Enter the point identifier of the start point.
4 Enter the point identifier of the ahead point.
To determine the slope distance between two points at the Command line in the Survey Command Window
1 In Toolspace, on the Survey tab, right-click a named network ➤ Survey Command Window.
2 At the command line, enter:
SDIST [point 1] [point 2]
The following illustration shows the Slope Distance command:
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slope distance
point

vertical distance ( ∆у)
slope angle

point
horizontal distance ( ∆х)

Command Line Example
The following example shows a valid entry using the Slope Distance command:
NEZ 1 100 100 30.480
NEZ 2 200 200 33.528
SD 1 2
Slope distance: 141.45
This example determines the slope distance from point 1 to point 2. Distances are in the current survey
database units.

Quick Reference
Survey Command Window Menu
Point Information ➤ Slope Distance
Survey Command Window Syntax
SDIST [point 1] [point 2]
Command Synonyms
SD
Parameter

Definition

point 1 and point 2

These are the two existing points between which an invisible
line is established. This line is used to determine the slope
distance between the two points.

Listing the Grade Between Points
Use the Grade command to determine the grade between two points. You must specify a starting point and
an ahead point.
To list the grade between two points in the Survey Command Window
1 In Toolspace, on the Survey tab, right-click a named network ➤ Survey Command Window.
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2 In the Survey Command Window, click Point Information menu ➤ Grade.
3 Enter the point identifier of the start point.
4 Enter the point identifier of the ahead point.
To list the grade between two points at the Command line in the Survey Command Window
1 In Toolspace, on the Survey tab, right-click a named network ➤ Survey Command Window.
2 At the command line, enter:
GRADE [point 1] [point 2]
The following illustrates the Grade command:

grade =
slope distance
point
grade (%)
vertical distance (Δ x)
point 1

horizontal distance (Δ x)

Command Line Example
The following example shows a valid entry using the Grade command:
NEZ 1 100 100 30.480
NEZ 2 200 200 32.004
GRADE 1 2
Grade: 1.0776 Percent
This example displays the grade from point 1 to point 2 in percent. When used as a built-in function, this
command supplies the vertical angle in the current vertical reference system (zenith, nadir, or horizontal).

Quick Reference
Survey Command Window Menu
Point Information ➤ Grade
Survey Command Window Syntax
GRADE [point 1] [point 2]
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Command Synonyms
G
Parameter

Definition

point 1 and point 2

The two existing points between which the grade is determined.

Listing the Slope Angle Between Existing Points
Use the Slope Angle command to determine the slope angle between two points.
To list the slope angle between two points in the Survey Command Window
1 In Toolspace, on the Survey tab, right-click a named network ➤ Survey Command Window.
2 In the Survey Command Window, click Point Information menu ➤ Slope Angle.
3 Enter the point identifier of the start point.
4 Enter the point identifier of the ahead point.
To list the slope angle between two points at the Command line in the Survey Command Window
1 In Toolspace, on the Survey tab, right-click a named network ➤ Survey Command Window.
2 At the command line, enter:
SLOPE [point 1] [point 2]

Command Line Example
The following example shows a valid entry using the Slope command:
NEZ 1 100 100 30.480
NEZ 2 200 200 33.528
SLOPE 1 2
Slope angle: 1.3719
This example determines the slope angle between point 1 and point 2. When used as a built-in function,
this command supplies the vertical angle in the current vertical reference system (zenith, nadir, or horizontal).

Quick Reference
Survey Command Window Menu
Point Information ➤ Slope Angle
Survey Command Window Syntax
SLOPE [point 1] [point 2]
Parameter

Definition

point 1 and point 2

The two existing points between which an invisible line is established. This line is used to determine the slope between
the two points.
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Outputting Survey Files
The Output file stores all the commands you enter at the Survey Command Line, including results from the
query commands. The format of the output file is the same language or format as the Survey Command
Language.
You can create, edit, or delete the output file using the commands in the Output menu. You can determine
the name of the current output file using the Use Output File setting in the Survey User Settings dialog box.
The output file for each network in a survey database is saved to Civil 3D Projects\<named> Survey
Database\<named> Network\Output.txt.
NOTE For other options on outputting survey data see Exporting a Field Book File (page 269) and Exporting Survey
Data to LandXML (page 270).

Turning the Output File On or Off
Use the Output File menu to specify the settings that affect how the output file is used and updated during
the Survey Command Window session.
To turn the output file on or off
1 In Toolspace, on the Survey tab, right-click a named network ➤ Survey Command Window.
2 In the Survey Command Window, click Output File menu ➤ Use Output File. A check mark next to
the item indicates it is active. Click the menu item to clear the check mark. Specify the following settings:
■

Use Output File: a check mark next to the menu item indicates the Output File is active.

■

Set File Name: enter a name for the output file.

■

Use Point Course Echo: reports the course taken to reach a point, including the direction and the
distance.

■

Use Figure Course Echo: reports the course taken to create a figure, including direction and distance.

■

Use Point Coordinate Echo: displays the point coordinates, including northing, easting, and elevation
information.

■

Use Figure Coordinate Echo: displays figure point coordinates, including northing, easting, and
elevation information.

Quick Reference
Survey Command Window Menu
Output File

Viewing the Contents of the Survey Output File
Use the Output File menu to specify the settings that affect how the output file is used and updated during
the Survey Command Window session.
To view the output file
1 In Toolspace, on the Survey tab, right-click a named network ➤ Survey Command Window.
2 In the Survey Command Window, click Output File menu ➤ View.
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The Output.txt file is displayed in the text editor.

Quick Reference
Survey Command Window Menu
Output File ➤ View

Astronomic Direction Calculations
You can use the Astronomic Direction Calculator to calculate astronomic directions from Sun Shot and Star
Shot observations.
In the Astronomic Direction Calculator you can specify the calculation type as either Sun Shot or Star Shot.
A Sun Shot calculates the astronomic direction from solar observations by the hour angle method and uses
a multiple foresight procedure. A Star Shot calculates the astronomic direction from Polaris or star observations
by the hour angle method and uses a single foresight procedure.
Each method requires a source of UT1 time (radio) and a stopwatch to measure the observations accurately.
Set the stopwatch to zero (0) at UT1 time. Start the stopwatch at a known interval of UT1 time and write
down the value of UT1 time (adding any necessary DUT corrections). When measuring the horizontal angle
to the sun or star, record the stopwatch reading (stop time) in the field book along with the angular data.

Single Foresight
This procedure is recommended for Polaris observations, or any sightings that have a large vertical angle
inherent in the observation. The single foresight procedure uses the following sequence: direct on the target,
direct on Polaris, reverse on target, reverse on Polaris. A stopwatch time is recorded for each pointing on the
Polaris. The two stopwatch times and the four horizontal circle readings correspond to one set of data. It is
recommended that you perform a minimum of three sets.

Multiple Foresight
This procedure is used as a solar observation method. It uses the following sequence: direct on the target,
multiple direct on the sun, multiple reverse on the sun (same number of times as direct), reverse on the
target. A stopwatch time is recorded for each pointing on the sun. Pair up each observation on the sun (and
its stop time) with its related target observation, and enter it into the editor as a single direct or reverse pair.
The editor computes an azimuth (or bearing) for each pair. You can average any number of these azimuths.
Do not average the multiple observations themselves because they are time-dependent and not a linear
function of time.

Calculating Directions with Sun Shots and Star Shots
In the Astronomic Direction Calculator you can select Sun Shot or Star shot to calculate astronomic directions.
Sun shots calculate a direction using solar observations by the hour angle method and use a multiple foresight
method. Star Shots calculate a direction from Polaris or a star observation by the hour angle method and
use a single foresight method.
To calculate an astronomic direction using the Sun Shot or Star Shot calculations
1 Click Analyze tab ➤ Ground Data panel ➤ Survey drop-down ➤ Astronomic Direction

.

2 In the Calculation Type list, select either Sun Shot Calculation, or Star Shot Calculation.
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3 Under Observation Station Data, specify the following:
■

Station Point

■

Backsight Point

■

Station Latitude

■

Station Longitude

■

UT1 Time (Sun Shots only)

See Astronomic Direction Calculator Dialog Box (page 2667) for more information.
4 Under Ephemeris Data, enter the following:
■

GHA 00 Hours

■

GHA 24 Hours

■

Declination 00 Hours

■

Declination 24 Hours

■

Sun Semi-diameter (Sun Shots only)

NOTE Enter zero (0) if you are sighting either the center or both the trailing and leading edges of the sun.
The left edge is always the leading edge at latitudes greater than 23.5 degrees north and greater than 23.5
degrees south. If only the left edge is being sighted (left when facing the sun), then the semi- diameter is
positive; likewise, the semi-diameter is negative when only the right edge is sighted.

5 Click
to create an observation set. Enter Direct and Reverse observations for the Backsight
Observation, Sun Observation or Star Observation and the Stop Time.
The observations determine the true astronomic direction from the first setup to the backsight. When
you enter the stop time for an observation, the observed and average directions are calculated
automatically.

Quick Reference
Ribbon
Analyze tab ➤ Ground Data panel ➤ Survey drop-down ➤ Astronomic Direction
Menu
Click Survey menu ➤ Astronomic Direction Calculator.
Command Line
SurveyCalculator
Dialog Box
Astronomic Direction Calculator (page 2667)
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14

Survey Command
Reference

You can use commands to quickly access survey functionality.

Survey Commands
The following table lists the survey-related AutoCAD Civil 3D commands that can be entered at the command
line.
Command

Description

AddFeatureLineLabels

Displays the Add Line labels dialog box (page 2208)

AddParcelCurveTable

Inserts a parcel curve table (page 1748)

AddParcelLineTable

Inserts a parcel line table (page 1748)

AddParcelSegmentTable

Inserts a parcel segment table (page 1748)

AddSegmentLabel

Add segment labels to figures (page 387)

AdjacentFeatureElevsByRef

Set the elevation based on a grade, slope, or elevation difference from another feature (page 827)

BrowseToSvData

Finds the data for the selected network object in
the survey database and displays the data on the
Survey tab in Toolspace (page 224)

BrowseToSvFigure

Synchronizes the Toolspace Survey tab to the
specified figure in the drawing (page 367)

BrowseToSvNetwork

Finds the selected survey network object's data in
the survey database and displays it on the Survey
tab of the AutoCAD PRODUCTNAME Toolspace
(page 225)
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Command

Description

BrowseToSvObservation

Finds the observation data for the specified point
identifier and displays the data in the Observation
Editor (page 290)

CloseSurveyToolspace

Closes the Survey tab of the AutoCAD AutoCAD
Civil 3DToolspace (page 115)

CreateFigureFromObject

Create a new figure from a selected polygon in
the current survey database (page 348)

DeleteElevPoint

Deletes feature line elevation points (page 832)

DeleteFeaturePI

Deletes points of intersection (page 836)

EditFeatureCurve

Edit feature line curves (page 838)

EditFeatureElevs

Edits feature-line or lot-line elevations using the
command line (page 822)

EditParcelTagNumbers

Activates the renumber label tags command (page
1723)

EditSvDatabaseSettings

Edits a variety of settings for the current opened
survey database such as units and precision, error
tolerance, and least squares analysis defaults (page
238)

EditSvFigureProperties

Edits survey figure properties (page 2704)

EditSvFigureStyle

Creates or edits a survey figure style (page 216)

EditSvNetworkStyle

Creates or edits a survey network style (page 216)

EditSvPointProperties

Edits survey point properties (page 2724)

EditSvUserSettings

Edits the survey user settings such as database
paths and preview graphic settings (page 227)

FeatureGradeExtensionByRef

Extends a grading by reference (page 828)

FeatureElevsFromSurf

Creates feature line elevations from a surface
(page 833)

FeatureLineSegmentLabels

Label feature line segments (page 852)

FilletFeature

Rounds the corners of feature lines (page 841)

FitCurveFeature

Converts tessellated curves to true arcs for better
grading results (page 842)

GradingElevEditor

Change elevations using the Grading Elevation
Editor panorama vista (page 820)
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Command

Description

ImportSurveyData

Imports field book files, point files, points in the
drawing, or Survey LandXML data (page 2685)

InsertElevPoint

Inserts an elevation point (page 830)

InsertFeatureHighLowPoint

Inserts high or low elevation points into feature
lines (page 832)

InsertFeaturePI

Inserts points of intersection (page 834)

JoinFeatures

Joins multiple feature lines into a single object
(page 836)

Mapcheck

Displays the Mapcheck Analysis Window (page
1795)

OffsetFeature

Offsets feature lines at an elevation difference
(page 848)

OpenSurveyToolspace

Displays the Survey tab of the AutoCAD Civil 3D
Toolspace which is the primary interface for
working with survey data (page 116)

RaiseLowerFeatures

Raises or lowers feature lines by elevation (page
829)

RaiseLowerFeaturesByRef

Raise/lower a feature line based on a grade, slope,
or relative elevation from a reference point (page
826)

ReverseFeature

Reverses the direction of feature lines for stationing purposes (page 837)

SetFeatureGrade

Specifies the grade or slope between selected
points on a feature line (page 823)

SetFeatureRefElev

Sets the feature line elevation in relation to an
existing elevation in the drawing (page 824)

StartSurveyLink

Survey Data Collection Link is used to download
data from a survey data collector and to convert
the raw survey data file to a Field Book file that
can be imported into PRODUCTNAME (page 266)

SvFigureProps

Displays properties for a survey figure drawing
object (page 2678)

SvNetworkProps

Changes the network name and description (page
2710)

SurveyCalculator

Calculates astronomic directions from Sun Shot
and Star Shot observations (page 417)
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Command

Description

TranslateSvDatabase

Translates all data in the current survey database
so you can move the survey database from an assumed location to a known location (page 220)

UpdateFromSvFigure

Replaces the drawing object with the data in the
survey database (page 368)

UpdateSvFigureFromDwg

Updates the survey database with changes to the
current figure object (page 368)

Survey Command Language Commands
You can use the survey command language to enter information directly at the Survey Command Window
input line.
TIP In the Survey Command Window, enter HELP at the command line to display a text file that lists all the Survey
Command Language commands.
For more information, see Survey Command Window (page 2697).

Command Language Syntax Conventions
When using the survey command language, you enter the command name and data using a specific syntax.
The following conventions are used to present the survey command language syntax:
■

Command name: Shown in uppercase.

■

[]: Square brackets enclose a required parameter, such as a coordinate or an angle measurement.

■

( ): Parentheses enclose an optional parameter, such as a description or point number.

NOTE Do not insert any brackets or parentheses when you type the command. The only exception to this rule is
when you use mathematical operations.

Example
The following is an example of the syntax to create a point by angle, distance, and vertical angle.
AD VA (point) [angle] [distance] [vertical angle] (description)
The following is an example of the actual data you would enter:
AD VA 5 67.5757 100.63 91.1546 IPF
NOTE If you use numeric descriptions such as 100, or descriptions that include one or more spaces such as VERY
LARGE MONUMENT, then you should enclose them in quotation marks.

Point Creation Commands
The following table lists the point creation-related AutoCAD Civil 3D survey commands and briefly describes
their functionality.
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NOTE These commands must be entered in the Survey Command Window. For more information, see Survey
Command Window (page 2697).
Command

Description

AD (point) [angle] [distance] (description)

Creates a point by angle and distance (page 292)

AD VA (point) [angle] [distance]
[vertical angle] (description)

Creates a point by angle, distance, and vertical
angle (page 292)

AD VD (point) [angle] [distance]
[vertical distance] (description)

Creates a point by angle, distance, and vertical
distance (page 292)

AP ON (point)

Turns automatic point numbering on (page 290)

AP OFF

Turns automatic point numbering off (page 290)

BD (point) [bearing] [quadrant]
[distance] (description)

Creates a point by bearing and distance (page
294)

BD VA (point) [bearing] [quadrant]
[distance] [vertical angle] (description)

Creates a point by bearing and distance (page
294)

BD VD (point) [bearing] [quadrant]
[distance] [vertical distance] (description)

Creates a point by bearing, distance, and vertical
distance (page 294)

DD (point) [angle] [distance] [vertical angle] (description)

Creates a point by deflection angle and distance
(page 296)

DD VA (point) [angle] [distance]
[vertical angle] (description)

Creates a point by deflection angle, distance, and
vertical angle (page 296)

DD VD (point) [angle] [distance]
[vertical distance] (description)

Creates a point by deflection angle, distance, and
vertical distance (page 296)

F1 (point) [angle] [distance] (description)

Creates a point using a FACE 1 angle (page 298)

F1 VA (point) [angle] [distance]
[vertical angle] (description)

Creates a point using a FACE 1 angle and a vertical
angle (page 298)

F1 VD (point) [angle] [distance]
[vertical distance] (description)

Creates a point using a FACE 1 angle and a vertical
distance (page 298)

F2 (point) [angle] [distance] (description)

Creates a point using a FACE 2 angle (page 298)

F2 VA (point) [angle] [distance]
[vertical angle] (description)

Creates a point using a FACE 2 angle and a vertical
angle (page 298)

F2 VD (point) [angle] [distance]
[vertical distance] (description)

Creates a point using a FACE 2 angle and a vertical
distance (page 298)
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Command

Description

LAT LONG (point) [latitude] [longitude] (description)

Creates a control point using a latitude and longitude (page 280)

NE (point) [northing] [easting]
(description)

Creates a control point using a northing and
easting (page 280)

NE SS (point) [northing] [easting]
(elevation) (description)

Creates a non control point (page 283)

NEZ (point) [northing] [easting]
(elevation) (description)

Creates a control point using a northing, easting,
and elevation (page 280)

PRISM [height]

Changes the current prism height

PT OFFSET (point) [offset] (ahead)
(description)

Createss a point by offsetting the last point (page
302)

SKIP

Skips over the next available point (when automatic point numbering is on)

STADIA (point) [angle] [distance]
[rod] (vertical angle) (description)

Creates a point using the stadia method (page
304)

ZD (point) [azimuth] [distance]
(description)

Creates a point using azimuth and distance (page
301)

ZD [VA] (point) [azimuth] [distance] [vertical angle] (description)

Creates a point using azimuth, distance, and vertical angle (page 301)

ZD [VD] (point) [azimuth] [distance] [vertical distance] (description)

Creates a point using azimuth, distance, and vertical distance (page 301)

Point Location Commands
The following table lists the point location-related AutoCAD Civil 3D survey commands and briefly describes
their functionality.
NOTE These commands must be entered in the Survey Command Window. For more information, see Survey
Command Window (page 2697).
Command

Description

AZ [point 1] [point 2] [azimuth]

Determines the azimuth between two points
(page 406)

B [point1] [point2] [bearing]
[quadrant]

Defines a bearing between two points (page 405)

BS [point] (orientation)

Locates a point by backsight

STN [point] (instrument. height)
(description)

Creates a new setup station (page 285)
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Point Information Commands
The following table lists the point information-related AutoCAD Civil 3D survey commands and briefly
describes their functionality.
NOTE These commands must be entered in the Survey Command Window. For more information, see Survey
Command Window (page 2697).
Command

Description

A [point 1] [point 2] [point 3]

Lists the horizontal angle between points (page
404)

AZ [point 1] [point 2]

Lists the azimuth between two points (page 406)

B [point 1] [point 2]

Lists a bearing between two points (page 405)

D [point 1] [point 2]

Determines the distance between two points
(page 407)

DISP PTS (point 1) (point 2)

Displays point information (page 404)

GRADE [point 1] [point 2]

Lists the grade between two points (page 413)

INV PTS [point 1] [point 2]

Lists the direction and distance between points
(page 408)

INVERSE RADIAL [backsight] [station]

Lists the angle and distance from a setup in a radial direction from the backsight point (page 410)

SLOPE [point 1] [point 2]

Lists the slope angle between two points (page
415)

SD [point 1] [point 2]

Lists the slope distance between two points (page
412)

VD [point 1] [point 2]

List the elevation distance between two points
(page 411)

Point Editing Commands
The following table lists the point information-related AutoCAD Civil 3D survey commands and briefly
describes their functionality.
NOTE These commands must be entered in the Survey Command Window. For more information, see Survey
Command Window (page 2697).
Command

Description

DEL PTS [point 1] (point 2)

Deletes points from the survey databases (page
305)

MOD DESC [point 1] [description]

Modifies a point's description (page 306)

MOD ELEV [point 1] [elevation]

Modifies the elevation of a point (page 306)
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Command

Description

MOD ELEV BY [point 1] [amount]

Modifies the elevation of a point by an increment
(page 306)

MOD ELS [point 1] [point 2] [elevation]

Modifies the elevation of multiple points (page
306)

MOD ELS BY [point 1] [point 2]
[amount]

Modifies the elevation of a group of points by an
increment (page 306)

Figure Commands
The following table lists the figure-related AutoCAD Civil 3D survey commands and briefly describes their
functionality.
NOTE These commands must be entered in the Survey Command Window. For more information, see Survey
Command Window (page 2697).
Command

Description

AREA [figure]

Lists the area and perimeter of a figure (page 386)

BEG [figure]

Begins a new figure (page 378)

C3

Draws a 3-point curve (page 352)

CLOSE

Closes a figure (page 349)

CLOSE BLD

Closes a figure (page 349)

CLOSE RECT [offset]

Closes a figure (page 349)

CONT [figure]

Continues a figure to add additional vertices to it
(page 381)

CRV [DELTA, LENGTH, DEFL, MID,
TAN, CHORD] [radius] [value]

Creates a curve in the current figure (page 355)

DEL FIG [figure]

Deletes a figure from the drawing (page 371)

DISP FIGS

Lists all the existing figure names in the current
drawing (page 383)

END

Indicates the end of a figure (page 371)

FIG AD [angle] [distance]

Creates a figure vertex using an angle and distance (page 356)

FIG DD [deflection] [distance]

Creates a figure vertex using a deflection angle
and distance (page 359)

FIG ZD [azimuth] [distance]

Creates a figure vertex using an azimuth and distance (page 358)
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Command

Description

FIG BD [bearing] [quadrant] [distance]

Creates a figure vertex using a bearing and distance (page 360)

FIG NE [northing] [easting]

Creates a figure vertex using known coordinates
(page 361)

ID FIG

Identifies a figure (page 382)

INVERSE FIG [figure]

Displays the exact closure (inverse) information
for a figure (page 385)

MCS

Starts a multi-point curve within an active figure
(page 353)

MCE

Ends a multi-point curve within an active figure
(page 353)

MAPCHECK [figure]

Displays mapcheck information for a figure (page
384)

OFFSET [figure] [distance]

Offsets a figure (page 369)

PC

Specifies that the next shot is a point of curvature
(page 354)

POINT [point]

Selects an existing point to be the next vertex in
the figure (page 362)

RT [distance]

Defines a right turn in a figure (page 363)

SET (point)

Creates a point at the current location in a figure
(page 364)

START [figure]

Extends a figure from the start point (page 379)

XC ZD (BULB) [radius] [chord azimuth] [chord distance]

Creates a curve using the chord azimuth (page
377)

XC BD (BULB) [radius] [chord
bearing] [quadrant] [chord distance]

Creates a curve using the chord bearing (page
376)

XC AD (BULB) [radius] [chord
angle] [chord distance]

Creates a non-tangential curve (page 372)

XC DD (BULB) [radius] [chord deflection] [chord distance]

Creates a curve using the chord deflection (page
376)

XC C3 [point on curve] [end point]

Creates a curve using a point on the curve (page
374)

XC PTS [radius] [radius point] [end
point]

Creates the curve radius (page 374)
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Intersection Commands
The following table lists the intersection-related AutoCAD Civil 3D survey commands and briefly describes
their functionality.
NOTE These commands must be entered in the Survey Command Window. For more information, see Survey
Command Window (page 2697).
Command

Description

AZAZ [point 1] [azimuth 1] [offset
1] [point 2] [azimuth 2] [offset 2]

Calculates an azimuth/azimuth intersection (page
331)

BB [point 1] [bearing 1] [quadrant
1] [offset 1] [point 2] [bearing 2]
[quadrant 2] [offset 2]

Calculates a bearing/bearing intersection (page
330)

LNLN [point 1] [point 2] [offset 1]
[point 3] [point 4] [offset 2]

Calculates a line/line intersection (page 333)

ARCAZ [point] [radius] [point 1]
[azimuth] [offset]

Creates an arc/azimuth intersection (page 338)

ARCB [point] [radius] [point 1]
[bearing] [quadrant] [offset]

Calculates an arc/bearing intersection (page 336)

ARCLN [point] [radius] [point 1]
[point 2] [offset]

Calculates an arc/line intersection (page 340)

ARCARC [point 1] [radius 1] [point
2] [radius 2]

Calculates an arc/arc intersection (page 342)

SAVE [NORTH, SOUTH, EAST,
WEST, 1, 2, ALL] (point) (description)

Saves the intersection point (page 343)

SAVE [NEAR, FAR] (point) [reference
point number] (description)

Saves the intersection point (page 343)

SAVE PICK (point) (description)

Saves the intersection point (page 343)

SQ [reference 1] [reference 2] [reference]

Calculates a square offset (page 334)

Equipment Correction Commands
The following table lists the equipment correction-related AutoCAD Civil 3D survey commands and briefly
describes their functionality.
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NOTE These commands must be entered in the Survey Command Window. For more information, see Survey
Command Window (page 2697).
Command

Description

ANGLES [RIGHT, LEFT] [ZENITH,
NADIR, HORIZ]

Changes the horizontal angle type (right or left)
and the vertical angle type

ATMOS [ON, OFF]

Turns atmospheric corrections on or off

COLL [ON, OFF]

Turns the collimation corrections for measurements on or off

CR [ON, OFF]

Turns curvature and refraction corrections on or
off

EDM OFFSET [offset]

Sets the EDM (Electronic Distance Measuring)
offset for an instrument

HORIZ ANGLE [RIGHT, LEFT]

Changes the horizontal angle type

PRESS [pressure] [INCH, MBAR,
MM]

Specifies the atmospheric pressure

SF [factor]

Changes the scale factor

PRISM CONSTANT [constant]

Changes the prism constant

PRISM OFFSET [offset]

Changes the prism offset

TEMP [temperature] [F, C, K]

Sets the temperature for atmospheric corrections

UNITS [METER, FOOT] [DMS,
DECDEG, GRAD, MILS, RADIANS]

Changes the distance or angle units for measurements

VERT ANGLE [ZENITH, NADIR,
HORIZ]

Changes the vertical angle reference system

Baseline Commands
The following table lists the baseline-related AutoCAD Civil 3D survey commands and briefly describes their
functionality.
NOTE These commands must be entered in the Survey Command Window. For more information, see Survey
Command Window (page 2697).
Command

Description

BL IS [point 1] [point 2] [station]

Defines a baseline (page 311)

BL PT (point 1) [station] (offset)
(description)

Creates a point at an offset from a baseline (page
313)

BL INV [point 1] (point 2)

Lists a baseline direction using inverse point (page
312)
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Centerline Commands
The following table lists the centerline-related AutoCAD Civil 3D survey commands and briefly describes
their functionality.
NOTE These commands must be entered in the Survey Command Window. For more information, see Survey
Command Window (page 2697).
Command

Description

CL IS [figure] (station) (point)

Defines a centerline (page 315)

CL INV [point 1] (point 2)

Displays point data in reference to the current
centerline (page 317)

CL PT (point) [station] (offset)
(skew angle) (description)

Creates a new point by station offset (page 319)

CL PT BY [point] [station 1] [offset]
[distance] (station 2) (description)

Creates points at an increment along the centerline (page 319)

CL ELEV (point) [station] [offset]
[elevation] (description)

Creates a point by station, offset, and elevation
(page 321)

CL ROD (point) [station] [offset]
[rod] (description)

Creates a point using station, offset and rod height
(page 322)

CL VD (point) [station] [offset]
[vertical distance] (description)

Creates a point along a centerline using a vertical
distance (page 323)

HI [elevation]

Defines the height of instrument (page 318)

XS [station]

Sets the current cross section station (page 325)

XS ELEV (point) [offset] [elevation]
(description)

Creates a point with offset and elevation from the
current cross section (page 326)

XS ROD (point) [offset] [rod] (description)

Creates a point by offset and rod height from the
current cross section (page 327)

XS VD (point) [offset] [vertical distance] (description)

Creates a point by offset and vertical distance from
the current cross section (page 328)

AutoCAD Related Commands
The following table lists the AutoCAD commands that you can use at the AutoCAD Civil 3D survey command
line and briefly describes their functionality.
The following table lists the corridor-related AutoCAD Civil 3D commands and briefly describes their
functionality.
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NOTE These commands must be entered in the Survey Command Window. For more information, see Survey
Command Window (page 2697).
Command

Description

PAN

Shifts the location of the drawing

REDRAW

Refreshes the display in the current viewport

ZOOM PT [point]

Zooms to a point

ZOOM [WINDOW, EXTENTS, PREVIOUS, W, P, E, A]

Zooms according to one of the specified parameters

Miscellaneous Commands
You can use commands to quickly access survey functionality.
The following table lists the survey-related AutoCAD Civil 3D commands and briefly describes their
functionality.
NOTE These commands must be entered in the Survey Command Window. For more information, see Survey
Command Window (page 2697).
Command

Description

CALC [formula]

Performs mathematical calculations

DITTO [ON, OFF]

Turns the Ditto feature on or off

HELP (command)

Displays the syntax of the specified command

HISTORY

Displays all the commands you used during the
current session

OUTPUT [ON, OFF]

Turns the use of an output file on or off

TRAV [ON, OFF]

Turns the traverse command on or off
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432

Point Data

433

434

Points

15

Points are basic building blocks in AutoCAD Civil 3D. You can use points in land development projects to identify existing
ground locations and design elements.
Points are numbered and named uniquely. Each point has properties that can include information such as northing,
easting, elevation, and description. A point that is displayed in a drawing can have additional properties that control its
appearance, such as a point style, a point label style, and a layer.
A point can be included in an AutoCAD Civil 3D project so that it can be accessed by multiple users, or it can exist outside
a project in a single drawing. For more information about the differences between project and drawing points, see Managing
Points (page 453).

Understanding Points
In AutoCAD Civil 3D, you can create, work with, and manage points using a variety of commands and tools.
The points created by AutoCAD Civil 3D are called Coordinate Geometry (COGO) points, which are very
different from AutoCAD point nodes. AutoCAD point nodes have only coordinate data (XYZ values) associated
with them. However, COGO points, in addition to coordinate data, have a variety of properties associated
with them, including point number, point name, raw (field) description, and full (expanded) description.
Unlike AutoCAD point nodes, which exist in a single drawing, COGO points can be stored in a project
outside a drawing and referenced by multiple users. In AutoCAD Civil 3D, the term point refers to a COGO
point, not to an AutoCAD point node.

Displaying and Labeling Points
To control the appearance of a point symbol in a drawing, either select a default point symbol, or create a
point symbol.
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Examples of point label styles

For more information, see Point Styles (page 449).
You can automatically label points with predefined labeling criteria as you create points in a drawing. For
more information, see Point Labels and Tables (page 451).

Editing Points
Use the Point Editor to edit point properties. For more information, see Point Properties (page 437). You can
also use AutoCAD commands to edit points graphically. For more information, see Editing Points in a
Drawing (page 517).

Creating Points
Choose from many point creation commands to create points. For more information, see Creating Points
(page 456). You can also create points by importing point data from a file. For more information, see Importing
and Exporting Points (page 525).
When you create or import points, you can use description keys to automatically control the appearance of
a point in the drawing based on its raw (field) description. For more information, see Description Keys (page
571).

Managing and Organizing Points
You can group related points into point groups using a variety of criteria. You can use point groups to control
the appearance of points in a drawing, to create surfaces, or to export selected points to a file. For more
information, see Point Groups (page 553).
Use a project to manage and protect the points needed for a design project. When you use a project as a
central repository for your project points, the points can be viewed and copied by others, but not necessarily
modified.
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The Point Object
Points are AutoCAD Civil 3D objects that can be displayed in the drawing and manipulated graphically.
Point appearance is controlled using point labels and point styles.
In the early releases of AutoCAD Civil 3D points were a subcomponents of a point group. Now points in
AutoCAD Civil 3D are individual objects where you can perform the following:
■

You can select points individually in the drawing and graphically change the location and rotation using
grips.

■

You can create a selection set of points to move their elevations to a surface.

■

You can modify point properties in the AutoCAD Properties dialog box which describes both the basic
and specific AutoCAD Civil 3D properties.

■

You can change the Next Point Number settings in the point creation commands.
NOTE To perform any of these functions, the point must be checked out, unlocked, and not a Survey Point.

You can use point groups to organize points and to control their appearance in a drawing. Point groups
reference the point data directly and are responsible for drawing the points. Point groups have an override
that forces all points in the group to use both that group’s preferred point style and point-label style, rather
than the styles assigned to the individual points.

Point groups showing different uses of point styles

When creating points you specify the point layer in the Edit Command Settings-CreatePoints dialog box.
For more information, see Edit Point Settings dialog box (page 2343).
You can use the AutoCAD LIST command to display point properties.

Point Properties
Use the Prospector tree to access point properties.
Point properties specify all the information associated with a point, including its data, such as point number,
northing, easting, and elevation. Properties for a drawing point include information about how the point
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is displayed in a drawing, and properties for a project point include information about its status with respect
to the project.
Display the properties of a point, even a point that is not in the current drawing, by clicking either a drawing
Points collection or a project Points collection in the Prospector tree to display a list view. For more
information, see The Toolspace Item View (page 99).
For a description of all drawing and project point properties, see Point Editor (page 2370). Use the Point Editor
to edit drawing point properties. View the properties of project points in the project Points collection list
view.
Point group overrides affect how some point properties, including elevation and raw description, are displayed
and are used in a drawing without changing the stored value of the point property. You can also use point
group overrides to override point styles and point label styles. For more information, see Using Point Groups
to Override Point Properties (page 555).

Points Collection (Prospector Tab)
Use the Points collection in the Prospector tree to access the points in a drawing.
Right-click the drawing Points collection to:
■

Create a new point. (page 456)

■

Export the points in a drawing. (page 534)

■

Transfer points in a file to another file format. (page 536)

■

Edit the points in a drawing with the Point Editor. (page 517)

■

Zoom or pan to the points in the drawing. (page 456)

■

Lock or unlock the points in the drawing. (page 453)

■

Refresh the Prospector tree.

NOTE The Points shortcut menu in the Prospector tree and in the Points list view can also contain project
management access control menu items when they are available. The menu items that display can change
depending on the status of the selected point relative to the project, such as whether it is checked out.
If one or more points have been added to the current drawing, you can view a list of the points in the list
view next to or beneath the Prospector tree. For more information, see The Toolspace Item View (page 99).

Point Collection (Settings Tab)
Use the Point collection in the Settings tree to manage point settings, point styles, point label styles, point
file formats, description key sets, table styles, and point command settings.
Right-click the Point collection to:
■

Edit the point feature settings. (page 439)

■

Edit the point styles defaults. (page 449)

■

Refresh the Settings tree.
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Expand the Point collection to display and edit the styles, command settings, and other collections available
for points, which are listed in the following table:
For more information
about...

Follow this link...

Point Styles

The Object Style Collection (Settings Tree) (page
111)

Label Styles

The Label Styles Collections (Settings Tree) (page
113)

Point File Formats

Point File Formats Collection (Settings Tab) (page
526)

Description Key Sets

Description Key Sets Collection (Settings Tree)
(page 572)

External Data References

Using External Data References (page 537)

User-Defined Property Classifications

Using Custom Properties with Points (page 445)

Table Styles

The Table Styles Collections (Settings Tree) (page
113)

Commands

Point Settings (page 439)

Point Settings
Point settings control how point-related commands behave.
You work with point settings the same way you work with other object settings in AutoCAD Civil 3D, using
the Toolspace Settings tree. You can control point-related settings at both the object collection (feature)
level and at the command level. For information about how the levels of settings work together, see
Understanding Settings (page 77).
Use the Settings tree Point collection shortcut menu to establish defaults for all point-specific settings and
to override the drawing ambient settings for all point-related commands. Use the Commands collection
under the Settings tree Point collection to override point-specific settings or drawing ambient settings for a
specific command.
NOTE Overrides to the drawing ambient settings at the Point collection level and the Point Commands collection
level affect only the specified level. The drawing level settings are not affected. For more information, see
Understanding Settings (page 77).
The topics in this section describe only those settings that affect point-related commands. They do not
describe the drawing ambient settings that you can edit at the Point collection level and the Point Commands
collection level, even though those settings are displayed. For more information about the drawing ambient
settings, see Specifying Ambient Settings (page 84).

Editing the Default Styles Settings
Before creating points, specify the default point style and point label style used to create the points if
description keys are not used.
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The styles you specify establish the default settings for the styles in the Create Points dialog box. When you
select the Create Points command, you can expand the Create Points dialog box and edit these default
settings.
IMPORTANT By default, in the Create Points dialog box - Points Creation section the Disable Description Keys
value is set to false and the controls in the Default Styles section are not available. To enable the Default Styles
controls, set the Disable Description Keys value to true.
To edit the Default Style settings
1 Open the Edit Point Settings (page 2343) dialog box using one of the following methods:
■

Edit settings for all point-related commands: In Toolspace, on the Settings tab, right-click Point ➤
Edit Feature Settings.

■

Click Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Point Creation Tools
the Create Points dialog box. Expand Points Creation.

■

Edit settings for a specific command: In Toolspace, on the Settings tab, expand the Commands
collection under the Point collection. Right-click the desired command. Click Edit Command Settings.

. Expand

2 If needed, scroll to Default Styles and expand the collection.
3 To specify a default point style, edit the Point Style setting.
4 To specify a default point label style, edit the Point Label Style setting.
5 Click OK.

Quick Reference
Ribbon
Click Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Point Creation Tools
Create Points dialog box. Expand Points Creation.

. Expand the

Toolspace Shortcut Menu
Settings tab: right-click Point collection ➤ Edit Feature Settings
OR
Settings tab: Point Commands collection ➤ right-click <command> ➤ Edit Command Settings
Command Line
ShowPointSettings
Dialog Box
Point Settings (page 2343)

Editing the Default Name Format
Before creating points, specify the default name template for points and point groups.
To edit the Default Name Format
1 Open the Edit Point Settings (page 2343) dialog box using one of the following methods:
■

Edit settings for all point-related commands: In Toolspace, on the Settings tab, right-click Point ➤
Edit Feature Settings.
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■

Click Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Point Creation Tools
the Create Points dialog box. Expand Points Creation.

■

Edit settings for a specific command: In Toolspace, on the Settings tab, expand the Commands
collection under the Point collection. Right-click the desired command. Click Edit Command Settings.

. Expand

2 If needed, scroll to Default Name Format and expand the collection.
3 To specify a default Point Group Name Template, click in the Point Group Name Template value column
and enter values in the Name Template dialog box.
4 To specify a default Point Name Template, click in the Point Name Template value column and enter
values in the Name Template dialog box.
5 Click OK.

Quick Reference
Ribbon
Click Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Point Creation Tools
Create Points dialog box. Expand Points Creation.

. Expand the

Toolspace Shortcut Menu
Settings tab: right-click Point collection ➤ Edit Feature Settings
OR
Settings tab: Points ➤ Commands collection ➤ right-click <command> ➤ Edit Command Settings
Command Line
ShowPointSettings
Dialog Box
Point Settings (page 2343)

Editing the Update Points Settings
Use the Update Points setting to control whether you can change project points without checking them
out.
Normally, after you check a point in to a project, you cannot modify the point in the drawing. To modify
it, you must first check it out of the project. In general, you should not modify a project point unless you
first check it out of the project.
However, there may be times when you want to modify a point that you have not checked out. In that case,
use the Update Points setting, Allow Checked-In Points To Be Modified.
WARNING If you edit points without checking them out, you cannot check the points in to the project. Your
changes exist only in the drawing in which you made them.
To edit the Update Points settings
1 Open the Edit Point Settings (page 2343) dialog box using one of the following methods:
■

Click Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Point Creation Tools
the Create Points dialog box. Expand Points Creation.

. Expand
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■

Edit settings for all point-related commands: In Toolspace, on the Settings tab, right-click the Point
➤ Edit Feature Settings.

■

Edit settings for a specific command: In Toolspace, on the Settings tab, expand the Commands
collection under the Point collection. Right-click the desired command and click Edit Command
Settings.

2 If needed, scroll to Update Points and expand the collection.
3 Edit the Allow Checked In Points To Be Modified setting.
4 Click OK.

Quick Reference
Ribbon
Click Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Point Creation Tools
Create Points dialog box. Expand Points Creation.

. Expand the

Toolspace Shortcut Menu
Settings tab: right-click Point collection ➤ Edit Feature Settings
OR
Settings tab: Point Commands collection ➤ right-click <command> ➤ Edit Command Settings
Command Line
ShowPointSettings
Dialog Box
Point Settings (page 2343)

Editing the Point Identity Settings
Before creating or importing points, specify the settings that control how the points are numbered and how
point number collisions are handled.
If you import points from an external file, and the points in your point data file do not have point numbers,
use the Point Identity settings to control how the points are numbered as they are imported.
If you import points from an external file, and the points in your point data file have point numbers, specify
how point number conflicts are resolved if the point file contains a point number that already exists. The
following example shows how the If Point Numbers Already Exists settings resolves conflicts when your
point data file contains a point number that already exists:
Example: If you have a point in the drawing with the following properties:
■

Number: 23

■

Northing: 500

■

Easting: 500

■

Elevation: 70.5

■

Description: IP
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You import a point data file containing a point with the same point number, but different properties, as
follows:
■

Number: 23

■

Northing: 502.18

■

Easting: 498.65

If you set the If Point Number Already Exists setting to Overwrite before you import the point file, the point
in the drawing becomes:
Number: 23 Northing: 502.18 Easting: 498.65 Elevation: blank Description: blank
All properties are overwritten, even properties that aren’t defined in the point data file, such as elevation
and description.
If you set the If Point Number Already Exists setting to Merge before you import the point file, the point in
the drawing becomes:
Number: 23 Northing: 502.18 Easting: 498.65 Elevation: 70.5 Description: IP
The number, northing, and elevation are overwritten, but the elevation and description in the drawing are
preserved.
To edit the Point Identity settings
1 Open the Edit Point Settings (page 2343) dialog box using one of the following methods:
■

Click Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Point Creation Tools
the Create Points dialog box. Expand Points Creation.

■

Edit settings for a specific command: In Toolspace, on the Settings tab, expand the Commands
collection under the Point collection. Right-click the desired command and click Edit Command
Settings.

. Expand

2 If needed, scroll the dialog box to Point Identity and expand the collection.
3 To specify point names and point numbers and to resolve duplicate point names and point numbers,
edit the following settings:
■

Next Point Number

■

Use Sequential Numbering

■

Point Number Offset

■

Sequence Point Numbers From

■

If Point Numbers Are Supplied

■

Force Names

■

If Point Numbers Already Exist

■

If Point Names Already Exist

■

If Point Numbers Need To Be Assigned

4 Click OK.
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Quick Reference
Ribbon
Click Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Point Creation Tools
Create Points dialog box. Expand Points Creation.

. Expand the

Toolspace Shortcut Menu
Settings tab: right-click Point collection ➤ Edit Feature Settings
OR
Settings tab: Point Commands collection ➤ right-click <command> ➤ Edit Command Settings
Command Line
ShowPointSettings
Dialog Box
Point Settings (page 2343)

Editing the Default Point Creation Settings
Use the point creation settings to change the command entry prompts, point elevations and description
key options.
To edit the Point Creation settings
1 Open the Edit Point Settings (page 2343) dialog box using one of the following methods:
■

Click Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Point Creation Tools
the Create Points dialog box. Expand Points Creation.

■

In Toolspace, on the Settings tab, expand the Commands collection under the Point collection.
Right-click the CreatePoints ➤ Edit Command Settings.

. Expand

NOTE The settings you specify when you right-click CreatePoints ➤ Edit Command Settings establish
the default settings in the Create Points dialog box.
2 If needed, scroll to Points Creation and expand the collection.
3 Specify the settings.
4 Click OK.

Quick Reference
Ribbon
Click Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Point Creation Tools
Create Points dialog box. Expand Points Creation.

. Expand the

Toolspace Shortcut Menu
Settings tab: right-click Point collection ➤ Edit Feature Settings
OR
Settings tab: Point Commands collection ➤ right-click CreatePoints ➤ Edit Command Settings
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Command Line
ShowPointSettings
Dialog Box
Point Settings (page 2343)

Editing the Default Layer Settings
Before creating points, specify the default layer for the points you create.
To edit the Default Layer settings
1 Open the Edit Point Settings (page 2343) dialog box using one of the following methods:
■

Click Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Point Creation Tools
the Create Points dialog box. Expand Points Creation.

■

In Toolspace, on the Settings tab, expand the Commands collection under the Point collection.
Right-click the CreatePoints ➤ Edit Command Settings.

. Expand

2 If needed, scroll to Default Layer.
3 To specify a new Layer, click the Value cell and specify a layer in the Layer Selection dialog box.
4 Click OK.

Quick Reference
Ribbon
Click Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Point Creation Tools
Create Points dialog box. Expand Points Creation.

. Expand the

Toolspace Shortcut Menu
Settings tab: right-click Point collection ➤ Edit Feature Settings
OR
Settings tab: Point Commands collection ➤ right-click <command> ➤ Edit Command Settings
Command Line
ShowPointSettings
Dialog Box
Point Settings (page 2343)

Using Custom Properties with Points
Points have many default properties you can use to identify them. However, if you have custom data that
does not match the existing properties, you can define your own properties. These properties are called
user-defined properties.
You can organize sets of user-defined properties in groups called user-defined property classifications. You
can then associate a classification with a point group, and then you will have those properties available to
use with the points in that point group.
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For example, if you have a survey that contains data about the trees on the site, you can start by creating a
classification called Trees. Then create properties that are specific to the classification. For example, in the
Tree Classification some properties you might create are name, species, and height.
Classifications are displayed as a collection in User-Defined Property Classifications on the Settings tab of
Toolspace. Each property you create is displayed in the Toolspace list view.
You can use user-defined properties to:
■

Import points

■

Create point groups

■

Label points

■

Create point tables

You can also use user-defined properties for parcels. For more information, see Using Custom Properties
with Parcels (page 920).

Creating a User-Defined Property Classification
To organize your custom properties, create a set called a User-Defined Property Classification.
To create a user-defined property classification
1 On the Settings tab in Toolspace, expand the object Collection.
NOTE User-defined properties can be defined only for points and parcels.
2 Right-click User-Defined Property Classifications. Click New.
3 In the User-Defined Property Classification dialog box, enter a name for the classification.
For example, to group custom properties for trees, you can create a classification named Trees.
4 Click OK.
The new classification is displayed under User-Defined Property Classifications on the Settings tab of Toolspace
and also in the list view window.
Next, create user-defined properties (page 446).

Quick Reference
Toolspace Shortcut Menu
Settings tab ➤ Point collection ➤ right-click User-defined Property Classification ➤ New

Creating a User-Defined Property
If you have custom point data that does not match the existing properties available, you can define your
own properties. These properties are called user-defined properties.
To create a user-defined property
1 On the Settings tab in Toolspace, expand the object folder.
2 Expand the User-Defined Property Classifications folder.
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3 Right click a classification. Click New.
4 Use the New User-defined Property Dialog Box (page 2027) dialog box to define the new property.
5 If you want a default value to be used for all points already in the drawing, as well as for new points as
they are created, select the Default Value check box and define the Default Value.
NOTE The default value is used for all points that do not already have a value for this property, regardless
of which point group they are assigned to.
6 Click OK.
The new property is displayed in Toolspace and also in the list view window.
Next, you can assign the property classification to a point group (page 447) or import or export point data
using the user-defined properties (page 448).

Quick Reference
Toolspace Shortcut Menu
Settings tab ➤ Point collection ➤ right-click a named User-defined Property Classification ➤ New

Editing, Copying, or Deleting User-Defined Properties
Use the shortcut menu in the Toolspace list view to make edits to user-defined properties.
To edit a user-defined property
1 On the Settings tab in Toolspace, click a User-defined Classification.
2 In the list view window, right-click a property cell. Select one of the following:
■

Edit Enumeration. Applies only to user-defined properties that use Enumeration as their type. For
more information, see the Edit Enumeration (page 2027) dialog box.

■

Delete

■

Line Shading

■

Copy to Clipboard

NOTE You can directly edit some values for the user-defined properties by clicking in the cells in the list view
and changing the values.

Quick Reference
List View Shortcut menu
Right-click a user-defined property cell ➤ Edit Enumeration, Delete, Line Shading, or Copy to Clipboard

Assigning User-Defined Properties to Point Groups
Assign a User-Defined Classification to a point group. This allows you to specify and manage the custom
properties for all points in that group.
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After you create a User-Defined Classification, you can assign it to a point group using the Classification
column of the Point Groups item list view. The properties within the classification are displayed as columns
in the Point Group item list view.
To assign user-defined properties to a point group
1 In the drawing, define the properties within the User-Defined Classification. For more information, see
Creating a User-Defined Property Classification (page 446).
2 In Toolspace, on the Prospector tab, click the Point Groups collection.
3 In the Point Groups list view window, click the Classification column. Select the User-Defined
Classification you want to assign to the specific point group.
4 In Toolspace, on the Prospector tab, select the point group to which you assigned the User-Defined
Classification.
5 In the point group list view window, right-click a column heading. Select the user-defined properties
you want to display in the list view window.
NOTE You can arrange the display of columns in the list view by dragging column headings. For more
information, see Customizing a List View (page 101).
6 You can now add data to each point directly in the list view. For more information, see Exercise 3:
Assigning User-Defined Properties to Points.

Importing and Exporting User-Defined Property Values
If you have a point file that contains custom properties, or you want to export custom point properties, you
can set up a point file format and then use it with the Import and Export commands.
You can add your custom properties, called user-defined properties, to the point file format. As prerequisites,
you must first define a user-defined property classification (page 446) and the user-defined properties (page
446) that are contained in it.
When you compose a Point File Format, the user-defined property names are displayed in the Point File
Formats - Select Column (page 2362) dialog box. You can select a property and assign it to a specific column.
To import user-defined property values into the drawing and assign them to points
1 In the drawing, define the properties within the User-Defined Classification. For more information, see
Creating a User-Defined Property Classification (page 446).
2 Define a point file format that contains columns with the user-defined properties. The point file must
have a column containing the point identity, either Name or Number, that identifies which point is
assigned the user-defined property.
3 Click Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Point Creation Tools

.

4 Click the Import Points button.
5 In the Import Points dialog box, select the point file format that contains the user-defined properties.
For more information, see Importing Point Data (page 533).
To export user-defined properties
1 Click Output tab ➤ Export panel ➤ Export Points
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.

2 In the Export Points dialog box, select the point file format that contains the user-defined properties.
For more information, see Exporting Point Data (page 534).

Quick Reference
Ribbon
Click Output tab ➤ Export panel ➤ Export Points
Menu
Click Points menu ➤ Import/Export Points ➤ Export Points.
Command Line
ExportPoints

Point Styles
Point styles control how point symbols display in a drawing.
Manage point styles the same way you manage all object styles in AutoCAD Civil 3D, using the Toolspace
Settings tree. In the Settings tree, all objects have a standard object style grouping called an object style
collection, which you use to create, edit, copy, and delete the styles for that object. For more information,
see The Object Style Collection (Settings Tree) (page 111).
When defining a point style, select from a set of default point symbols, or create a point symbol using an
AutoCAD Block. For more information about creating an AutoCAD Block, see AutoCAD Help.
Assign a point style to a drawing point either when you create the point or import the point. Use either the
Prospector Points list view or the Point Editor to change the point style. The point style referenced by a
point is not necessarily the point style used to display the point in the drawing. For more information, see
Controlling the Appearance of Points in a Drawing (page 454).

Overview of Point Styles
Use styles to control the appearance of a point symbols and a point labels in a drawing.
A point can directly reference two styles:
■

Point Style. Defines how a point symbol is displayed in the drawing. To change a point symbol, either
edit the point style or change the point so that it references a different point style. For more information,
see Point Styles (page 449).

■

Point Label Style. Defines how a point is labeled in the drawing. To change the way a point is labeled,
you can either edit the point label style or change the point so that it references a different point label
style. For more information, see Point Labels and Tables (page 451).

The point style determines the appearance of the point symbol, and the point label style determines how
the point is labeled:
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Although an individual point can reference a point style and a point label style, when possible, you will
want to use point groups to control the display of point symbols and point labels for points sharing similar
characteristics. For more information, see Controlling the Appearance of Points in a Drawing (page 454).

Creating a Point Style
Use the Settings tree to create a point style.
A point style specifies the symbol that displays at the X Y location for the point in the drawing. The style
can also specify scaling for the symbol and its appearance in 3D views.
To create a point style
1 In Toolspace, on the Settings tab, right-click the Point Styles collection ➤ New.
2 In the Point Style dialog box, click the Information (page 2355) tab. Enter a name and description for the
point style.
3 To define the symbol used to display the point, click the Marker (page 2355) tab. Specify the symbol type
and options for size, scaling, and rotation.
4 To define how the point displays in 3D views, click the 3D Geometry (page 2356) tab. Specify the 3D
Geometry settings.
5 To define the display properties for the point style, click the Display (page 2357) tab. Specify the display
properties for the symbol.
6 To view summary information about the style, click the Summary (page 2357) tab.
7 Click OK.

Quick Reference
Toolspace Shortcut Menu
Settings tab: right-click Point Style collection ➤ New
Dialog Box
Point Style (page 2354)

Creating a Point Style Based on an Existing Point Style
Use the Settings tree to create a point style based on an existing point style.
Create a point style from an existing point style by copying an existing point style and then editing the
copy.
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To create a point style from an existing point style
1 In Toolspace, on the Settings tab, right-click the point style you want to copy. Click Copy.
A copy is created and its properties are displayed in the Point Style dialog box.
2 In the Point Style dialog box, click the Information (page 2355) tab. Enter a name and description for the
new point style.
3 Use the tabs in the Point Style (page 2354) dialog box to modify the point style’s properties. For more
information, see Creating a Point Style (page 450).

Quick Reference
Toolspace Shortcut Menu
Settings tab: right-click Point Style item ➤ Copy
Dialog Box
Point Style (page 2354)

Editing a Point Style
Use the Settings tree to edit a point style.
To edit a point style
1 In Toolspace, on the Settings tab, right-click the desired point style. Click Edit.
2 In the Point Style (page 2354) dialog box, edit the properties of the point style.
For more information, see Creating a Point Style (page 450).

Quick Reference
Toolspace Shortcut Menu
Settings tab: right-click Point Style item ➤ Edit
Dialog Box
Point Style (page 2354)

Point Labels and Tables
Label and table styles control the appearance and behavior of point labels and tables in a drawing.
This section describes characteristics unique to point labels and point tables. For general information about
labels and tables, see Labels and Tags (page 1643) or Tables (page 1737).

Point Labels
Assign a point label style to a drawing point either when you create the point or import the point. Use the
Points list view on the Prospector tab or the Point Editor to change the style. The point style referenced by
a point is not necessarily the point style used to display the point in the drawing. For more information,
see Controlling the Appearance of Points in a Drawing (page 454).

Editing a Point Style | 451

Point Tables
When you insert a point table into a drawing, specified point information is automatically displayed in the
table.

Point Label Styles
Use the Settings tree to manage and create point label styles.
You can create multiple label styles for point objects.
You can label points when you create them, or you can use point groups and description keys to specify
how points are labeled in a drawing. You can also edit text on individual point labels.
For information about changing existing point label styles, see Modifying Labels in a Drawing (page 1712).
To edit point label style defaults
1 On the Settings tab in Toolspace, expand the Points collection.
2 Click the Label Styles collection, right click ➤ Edit Label Style Defaults.
For more information, see Adding Text Components to Labels (page 1686).
To create a point label style
1 On the Settings tab in Toolspace, expand the Points collection.
2 Click the Label Styles collection, right click ➤ New. For more information, see Creating and Editing
Label Styles. (page 1656)
For more information, see Adding Text Components to Labels (page 1686).
To edit point label text
1 In the drawing, right-click a point ➤ Edit Label Text.
2 At the command line you are prompted to select a text component.
3 In the Text Component Editor dialog box, make the necessary changes.
4 Click OK.
For more information, see Adding Text Components to Labels (page 1686).

Point Tables
Use Point tables to display information about points in a drawing.
Specify the points to include in the table by selecting them from the drawing or specifying a point group.
The point information is automatically displayed in the table when you insert the point table into the
drawing.
Unlike some objects, that have multiple table styles, points have only the point table style.
You create and edit tables for most objects using the same common procedures and standard dialog boxes.
The procedure in this topic explains how to access the point table creation command. It provides a link to
information about the Point Table Creation dialog box. For information about modifying tables, see Modifying
Tables (page 1750).
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To create a point table
1 Click Annotate tab ➤ Labels & Tables panel ➤ Add Tables Menu ➤ Add Point Table

.

2 In the Point Table Creation (page 2375) dialog box, change the generic table settings as needed.
3 Click

to select a point group that specifies the points to be included in the table.

4 Click

to select points in the drawing to be included in the table.

5 Click OK.
6 Select the location for the upper-left corner of the table in the drawing.

Quick Reference
Ribbon
Click Annotate tab ➤ Labels & Tables panel ➤ Add Tables Menu ➤ Add Point Table
Menu
Click Points menu ➤ Add Tables.
Command Line
AddPointTable

Managing Points
You can manage points using an AutoCAD Civil 3D project.
For example, you can add points to a project and protect them so they can be viewed and copied by others,
but not modified. For general information about project management, see Project Management (page 143).
For information about working with points in a project management environment, see Working with Vault
Project Points (page 187).
NOTE Survey points that are created using the Prospector Survey tab are not included in project management
operations even if they are selected. For example, any Survey points included in the selection list during the Add
to Project command are not added to the project.
You can populate a project with points by creating the points in the drawing and adding them to the project.
For more information, see Creating a Project Point Database (page 30).
For a recommended procedure for checking out, editing, and checking in a large number of project points,
see Modifying A Large Number of Project Points (page 523).

Locking and Unlocking Points
Lock a point to prevent its properties from being modified in a drawing.
A locked point is designated by
in the Prospector tree and the Point collection list view. The icon is
displayed only if the Toolspace tree drawing state icons are displayed. For more information, see Drawing
Item State Icons (page 161).
NOTE A locked point is locked only in the drawing. A protected point is protected at the project level. For more
information, see Protecting Project Points (page 192).
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A locked point cannot have any of its properties changed, including its point style and point label style. It
cannot be edited, deleted, or overwritten. However, you can reposition its label in the drawing.
When you are working with a drawing point that is not related to a project point, lock the point to prevent
changes as previously described. Unlock the point to change it, including changing its XYZ values.
When you work with a local copy of a project point or Survey point, the locking behavior of a point changes.
When you check a drawing point into a project, the local copy of the point is automatically locked, so that
no changes can be made to it as described previously.
If you unlock a point with either a project state of checked in, checked out to other, or protected, you cannot
modify its XYZ values, but you can change its point styles.
If you need to change a local copy of a project point in a drawing, use the Allow Checked In Points To Be
Modified setting. For more information, see Editing the Update Points Settings (page 441). It is important to
remember that any changes you make to the point can never be checked in to the project.
WARNING If you edit points without checking them out, you cannot check the points in to the project. Your
changes exist only in the drawing in which you made them.
Lock or unlock all the points in a drawing using the Points collection shortcut menu. Lock or unlock
individual drawing points using the list view shortcut menu. Lock or unlock all the points in a point group
point list using a single command.
To lock or unlock points
1 In Toolspace, on the Prospector tab, click the Points collection to display the Points list view.
2 Select the desired points. For more information, see Selecting Items in a List View (page 100).
3 Right-click then click Lock or Unlock.

Quick Reference
Ribbon
Click COGO Point tab ➤ Modify panel ➤ Lock Points
or
Click COGO Point tab ➤ Modify panel ➤ Unlock Points
Toolspace Shortcut Menu
Prospector tab: Points collection ➤ right-click points in List View ➤ Lock or Unlock
Command Line
LockPoints
or
UnlockPoints

Controlling the Appearance of Points in a Drawing
Several factors control how a point displays in a drawing.

Point Style and Point Label Style
The point style and the point label style control the basic appearance of a point symbol and label in a
drawing.
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The point style determines the appearance of the point symbol, and the point label style determines how
the point is labeled:

Each individual drawing point can directly reference a point style and a point label style. These individual
point styles are assigned when a point is created. The individual point styles assigned during point creation
are determined either by description key matching or by the styles specified in the Create Points dialog box.
A point is not required to reference a point style or point label style. (If a point does not reference a point
style, the style referenced by the layer on which the point is created is used.
If a point does not reference a point style or point label style, the point style or point label style property
for the point is empty when viewed in the Point Editor or the Points list view. You can change or remove
individual point styles using the Point Editor or Points list view.
A point group can reference a default point style and a default point label style. View or change these point
group default styles using the Information tab (page 2348) or the Overrides tab (page 2353) on the Point Group
Properties dialog box. If you change the style on one tab, the other tab updates to reflect the change.
In addition, the default styles for a point group can be designated as point group override styles. Use the
check box on the Overrides tab (page 2353) of the Point Group Properties dialog box to specify that a point
group style is an override style.
The following describes, in order of precedence, which of the previously described styles are used to display
a point in a drawing:
Style
Point Group Override Styles

The Object Style Collection (Settings Tree) (page 111)
If the point belongs to more than one point group that specifies
override styles, the override styles specified by the highest point
group in the point group display order are used to draw the
point. For more information, see Changing the Point Group
Display Order (page 558).

Individual Point
Styles

The Label Styles Collections (Settings Tree) (page 113)

Point Group Default
Styles

Point File Formats Collection (Settings Tab) (page 526)

The _All Points
group

Description Key Sets Collection (Settings Tree) (page 572)

NOTE All points belong to the _All Points point group. To display all the points in a drawing that use the same
style, specify an override style for the _All Points point group, and move it to the top of the point group display
order.

Point Style Display Settings
Use the Point Style display settings to control whether the point symbol and/or the point label is drawn for
any point that is displayed using the point style. On the Display tab in the Point Style dialog box, the Visible
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column controls the visibility of point symbols and point labels. To change the visibility of point symbols,
change the visibility for the Marker component. To change the visibility of point labels, change the visibility
for the Label component.

Layers
Use the point layer to control the appearance of a point in a drawing.
Specify a point layer for a point by setting its Layer property. Set the Layer property either during point
creation (using description key matching or the options in the Create Points dialog box) or after a point is
created (using the Point Editor or the Points list view).
If a point belongs to more than one point group, the highest point group controls the visibility of the point
in the point group display order.
A point can be displayed using the properties of a layer, such as visibility, color, line type, and line weight.
If an individual point style or point label style is used to display a point (as described earlier in this topic),
the ByBlock or ByLayer specifications in the point style or point label style refer to the layer that is assigned
to the point.

Printing Points
The Copy To Clipboard command lets you copy a list of drawing or project points to another application
for printing.
To print a list of points in a drawing or project, click the drawing or project Prospector tree collection to
display the points in a list view. Right-click the list view and select Copy To Clipboard to copy the list view
into a file you can print. For information, see Copying Items from a List View (page 103).

Zooming and Panning to Points
Use the list view shortcut menu to automatically zoom or pan to points in the drawing.
To zoom or pan to points
1 In Toolspace, on the Prospector tab, click the drawing Points collection.
2 In the list view, select the points you want to zoom or pan to. For more information, see Selecting Items
in a List View (page 100).
3 Right-click and click Zoom To or Pan To.

Quick Reference
Toolspace Shortcut Menu
Prospector tab: Points collection ➤ right-click points in List View ➤ Zoom To, Pan To

Creating Points
You can use the Create Points dialog box to create points using a variety of methods.
For standardization, you can use a drawing template that contains point settings, point styles, and point
label styles.
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IMPORTANT The highest point number allowed in Civil 3D is 4,294,967,295. You can use point names or User
Defined Properties to reference numbers greater than 4,294,967,295. For more information, see Using Custom
Properties with Points (page 445).
In the Create Points dialog box, choose commands from the following lists:
■

Miscellaneous

■

Intersection

■

Alignments

■

Surface

■

Interpolate

■

Slope

■

Import Points

You can expand the Create Points dialog box to access the settings that are relevant to point creation. If you
change the settings in this dialog box the changes are reflected in the CreatePoints command settings. For
more information, see Edit Feature Settings - Point Dialog Box (page 2343).
You can also use the Civil transparent commands in combination with the Create Points Manual command
to create points using known information such as angle and distance. For more information about the Civil
transparent commands, see Transparent Commands (page 1767).
You can use description key substitution while creating drawing points to automatically assign point style,
point label style, layer, full description, and scale and rotation of the point symbol. For more information,
see Understanding Description Keys (page 571).

Before You Create Points
Save time and effort by considering certain issues before creating points.
The following factors can affect both the point creation process and the way you work with points after they
are created:
■

When creating drawing points, work in a drawing based on a template which contains the point settings,
point styles, point label styles, and description keys you want to use when creating the point. For more
information, see Drawing Templates (page 127).

■

Plan how you will control the point style and point label style used to draw points in a drawing. You
can set the point styles at the point group level, or at the point level, and automatically assign this
method of style selection during point creation. For more information, see Controlling the Appearance
of Points in a Drawing (page 454).

■

If you plan to use description keys to assign styles, layers, and other information when creating drawing
points, make sure that the description keys are present in the drawing before you create the points. For
more information, see Understanding Description Keys (page 571).

■

Specify settings that control, among other things, how you are prompted during the point creation
commands and how the created points are numbered. For more information, see Editing the Default
Point Creation Settings (page 444).

NOTE If prompted for an elevation or description and you want to create a point without these, enter a period
(.) at the prompt.
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Creating Points Using Miscellaneous Methods
Use the icons in the Miscellaneous list to access commands that are commonly used for creating points.
Point settings, styles, layers, point groups, and description keys can all affect how a point is created or how
it is displayed in a drawing. For more information, see Before You Create Points (page 457).

Creating Points at Specified Coordinates
Creates a point at specified or selected location in the drawing.
Enter X, Y (and Z, if prompted) coordinates at the command line, or click a location in the drawing.
For more information, see Specifying Locations in a Drawing (page 133)
To create points at specified coordinates
1 Select settings and create styles, layers, point groups, and description keys. For more information, see
Before You Create Points (page 457).
2 Click Home tab ➤ Create Ground Data panel ➤ Points Menu ➤ Create Points - Miscellaneous ➤ Manual
.
NOTE You can also use transparent commands to specify point locations within a larger operation, such as
the creation of an alignment or a parcel lot line. Using transparent commands, you can calculate the location
for a point from information such as angle and distance, or from point object information, such as a point
number. For more information, see Transparent Commands (page 1767).
3 Specify the location for the point in the drawing. For more information, see Specifying Locations in a
Drawing (page 133).
4 If prompted, enter the point name, description, and elevation.
5 Press Enter to end the command.
NOTE Many factors affect how the point is displayed. For more information, see Controlling the Appearance of
Points in a Drawing (page 454).

Quick Reference
Ribbon
Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Create Points - Miscellaneous ➤ Manual
Menu
Points menu ➤ Create Points - Miscellaneous ➤ Manual
Toolspace Shortcut Menu
Prospector tab: right-click Points collection ➤ Create
Command Line
CreatePointManual
Dialog Box
Create Points (page 2357)
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Creating Points by Geodetic Direction and Distance
Creates a point by using a specified geodetic direction.
From the starting point, enter the geodetic azimuth and the geodesic distance to the location where you
want to create the point. To use this command, you must assign a coordinate system to the drawing.
NOTE To list the geodetic direction and distance, use the Point Inverse inquiry type. For more information, see
Using the Inquiry Tool (page 1806).
Point settings, styles, layers, point groups, and description keys can all affect how a point is created or how
it is displayed in a drawing. For more information, see Before You Create Points (page 457).
To create points by geodetic direction and distance
1 Select settings and create styles, layers, point groups, and description keys. For more information, see
Before You Create Points (page 457).
2 Set the zone and transformation settings for the drawing.
3 Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Create Points - Miscellaneous ➤ Geodetic
Direct

.

4 Specify a starting point.
5 Enter the geodetic azimuth from the point you previously specified to the location where you want to
create the point.
6 Enter the geodesic distance, which is the distance measured from the point you previously specified,
to the location where you want to create the point.
7 If prompted, enter the point name, description, and elevation.
NOTE The options for labeling both the grid and geodetic distance and direction are available in the General
Line Label Styles.
8 Press Enter to end the command.
NOTE Many factors affect how the point is displayed. For more information, see Controlling the Appearance of
Points in a Drawing (page 454).

Quick Reference
Ribbon
Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Create Points - Miscellaneous ➤ Geodetic Direct

Menu
Points menu ➤ Create Points - Miscellaneous ➤ Geodetic Direct
Toolspace Shortcut Menu
Prospector tab: right-click Points collection ➤ Create
Command Line
CreatePoints
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Dialog Box
Create Points (page 2357)

Creating Points by Resection
Creates a point at a position calculated from the measured angles between three known points.
To create the point, enter the backsight (reference) point, then enter the two points that are sighted on,
followed by the angles for each of the sighted points.

To create points by resection
1 Select settings and create styles, layers, point groups, and description keys. For more information, see
Before You Create Points (page 457).
2 Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Create Points - Miscellaneous ➤ Resection
.
3 Specify the first point, which is the backsight (or reference) point.
4 Specify the second point.
5 Specify the third point.
6 Enter the angle between the first point and the second point.
7 Enter the angle between the first point and the third point.
8 If prompted, enter the point name, description, and elevation.
9 Press Enter to end the command.
NOTE Many factors affect how the point is displayed. For more information, see Controlling the Appearance of
Points in a Drawing (page 454).

Quick Reference
Ribbon
Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Create Points - Miscellaneous ➤ Resection
Menu
Points menu ➤ Create Points - Miscellaneous ➤ Resection
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Toolspace Shortcut Menu
Prospector tab: right-click Points collection ➤ Create
Command Line
CreatePointResection
Dialog Box
Create Points (page 2357)

Creating Points by Station and Offset
Creates a point at a specified station and offset distance from a line, polyline, feature line, lot line, or arc.
Use the station and the offset to specify the location of the point.

To create points by station and offset
1 Select settings and create styles, layers, point groups, and description keys. For more information, see
Before You Create Points (page 457).
2 Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Create Points - Miscellaneous ➤ Station/Offset
Object

.

3 Select a line, polyline, feature line, lot line, or arc.
4 Enter the starting station or press Enter to accept the default.
The ending station is automatically calculated.
5 Enter the station at which you want to create the point or press Enter to accept the default.
6 Enter the offset distance.
7 If prompted, enter the point name, description, and elevation.
8 Press Enter to end the command.
NOTE Many factors affect how the point is displayed. For more information, see Controlling the Appearance of
Points in a Drawing (page 454).
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Quick Reference
Ribbon
Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Create Points - Miscellaneous ➤ Station/Offset
Object
Menu
Points menu ➤ Create Points - Miscellaneous ➤ Station/Offset Object
Toolspace Shortcut Menu
Prospector tab: right-click Points collection ➤ Create
Command Line
CreatePtStationOffsetObj
Dialog Box
Create Points (page 2357)

Creating Points at Object Vertices and Critical Geometric Points
Creates points automatically at the endpoints of lines, feature lines, or lot lines, or at the endpoints and
center point of arcs.
Points are created from a selection set of objects. Points are not created where lines cross unless one of the
points is an end point.

To create a point where lines cross each other, use the Create Points Manual command.
To create points at object vertices and critical geometric points
1 Select settings and create styles, layers, point groups, and description keys. For more information, see
Before You Create Points (page 457).
2 Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Create Points - Miscellaneous ➤ Automatic
.
3 Select objects. You can select lines, feature lines, lot lines, and arcs.
4 A point is placed at each vertex of the selected object.
5 For each point, if prompted, enter the point name, description, and elevation.
6 Press Enter to end the command.
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NOTE Many factors affect how the point is displayed. For more information, see Controlling the Appearance of
Points in a Drawing (page 454).

Quick Reference
Ribbon
Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Create Points - Miscellaneous ➤ Automatic
Menu
Points menu ➤ Create Points - Miscellaneous ➤ Automatic
Toolspace Shortcut Menu
Prospector tab: right-click Points collection ➤ Create
Command Line
CreatePointAutomatic
Dialog Box
Create Points (page 2357)

Creating Points Along a Line or a Curve
Creates points along a line, feature line, lot line, or arc at a specified distance from an end point.
Click near the end point from which you want to measure the distance and enter a distance to specify the
location for the created point along the object.

To create points along a line or a curve
1 Select settings and create styles, layers, point groups, and description keys. For more information, see
Before You Create Points (page 457).
2 Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Create Points - Miscellaneous ➤ Along
Line/Curve

.

3 Select a line, lot line, feature line, or arc.
The end point nearest to the point you selected is highlighted.
4 Enter the distance from the end point.
5 If prompted, enter the point name, description, and elevation.
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6 Optionally, do one of the following:
■

Enter another distance from the start point of the selected object and follow the prompts as previously
described.

■

Press Enter, select another object, and follow the prompts as previously described.

7 Press Enter twice to end the command.
NOTE Many factors affect how the point is displayed. For more information, see Controlling the Appearance of
Points in a Drawing (page 454).

Quick Reference
Ribbon
Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Create Points - Miscellaneous ➤ Along Line/Curve

Menu
Points menu ➤ Create Points - Miscellaneous ➤ Along Line/Curve
Toolspace Shortcut Menu
Prospector tab: right-click Points collection ➤ Create
Command Line
CreatePtAlongLnCurveSpir
Dialog Box
Create Points (page 2357)

Creating Points on a Line or Curve
Creates a point at the endpoint of a line, feature line, lot line, or arc and on points of intersection (PIs) and
radius points for arcs.
Locations of the specified points are created for an arc. Select one object at a time. If you select intersecting
objects, duplicate points are not created.

When you create points using this command, you work with one object at a time. After points have been
added using a selected object, you can select another object and add points using that object. If the objects
you select and the options you specify while using the command would result in the creation of duplicate
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points, for example, at the shared endpoints of two lines, only a single point is added. Duplicate points are
not created.
To create points on a line or curve
1 Select settings and create styles, layers, point groups, and description keys. For more information, see
Before You Create Points (page 457).
2 Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Create Points - Miscellaneous ➤ On Line/Curve
.
3 Select a line, lot line, feature line, or arc.
4 Points are placed at geometric points on the selected object.
5 For each point, if prompted, enter the point name, description, and elevation.
6 Press Enter to end the command.
NOTE Many factors affect how the point is displayed. For more information, see Controlling the Appearance of
Points in a Drawing (page 454).

Quick Reference
Ribbon
Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Create Points - Miscellaneous ➤ On Line/Curve

Menu
Points menu ➤ Create Points - Miscellaneous ➤ On Line/Curve
Toolspace Shortcut Menu
Prospector tab: right-click Points collection ➤ Create
Command Line
CreatePtOnLineCurveSpiral
Dialog Box
Create Points (page 2357)

Creating a Specific Number of Points Along an Object by Dividing the Object
Creates a specific number of evenly spaced points along a line, feature line, lot line, or arc.
Specify the number of segments, and a point is placed at each vertex. Points can placed on the object or at
an offset.
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When you create points using this command, you work with one object at a time. After points have been
added using a selected object, you can select another object and add points using that object. If the objects
you select and the options you specify while using the command would result in the creation of duplicate
points, for example, at the shared endpoints of two lines, only a single point is added. Duplicate points are
not created.
To create a specific number of points along an object by dividing the object
1 Select settings and create styles, layers, point groups, and description keys. For more information, see
Before You Create Points (page 457).
2 Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Create Points - Miscellaneous ➤ Divide Object
.
3 Select a line, lot line, feature line, or arc.
4 Enter the number of segments to divide the object into.
5 Enter the offset.
A series of equally spaced points are placed along the object at the specified offset.
6 For each point, if prompted, enter the point name, description, and elevation.
7 Press Enter to end the command.
NOTE Many factors affect how the point is displayed. For more information, see Controlling the Appearance of
Points in a Drawing (page 454).

Quick Reference
Ribbon
Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Create Points - Miscellaneous ➤ Divide Object

Menu
Points menu ➤ Create Points - Miscellaneous ➤ Divide Object
Toolspace Shortcut Menu
Prospector tab: right-click Points collection ➤ Create
Command Line
CreatePointDivideObject
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Dialog Box
Create Points (page 2357)

Creating Points on an Object Using Distance Intervals
Creates points that are a specified distance apart along a line, feature line, lot line, or arc.
Specify the start and end stations on the object, distance (interval) between points, and optional offset.
Use a specified interval and offset to place points along an object.

When you create points using this command, you work with one object at a time. After points have been
added using a selected object, you can select another object and add points using that object. If the objects
you select and the options you specify while using the command would result in the creation of duplicate
points, for example, at the shared endpoints of two lines, only a single point is added. Duplicate points are
not created.
To create points on an object using distance intervals
1 Select settings and create styles, layers, point groups, and description keys. For more information, see
Before You Create Points (page 457).
2 Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Create Points - Miscellaneous ➤ Measure
Object

.

3 Select a line, lot line, feature line, or arc.
4 Enter the starting station or press Enter to accept the default.
5 Enter the ending station or press Enter to accept the default.
6 Enter the offset.
7 Enter the distance interval.
Points are placed along the object at the specified offset and interval.
8 For each point, if prompted, enter the point name, description, and elevation.
9 Press Enter to end the command.
NOTE Many factors affect how the point is displayed. For more information, see Controlling the Appearance of
Points in a Drawing (page 454).
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Quick Reference
Ribbon
Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Create Points - Miscellaneous ➤ Measure Object

Menu
Points menu ➤ Create Points - Miscellaneous ➤ Measure Object
Toolspace Shortcut Menu
Prospector tab: right-click Points collection ➤ Create
Command Line
CreatePointMeasureObject
Dialog Box
Create Points (page 2357)

Creating Points on Polylines at a Specified Elevation
Creates points at the vertices of a polyline at a specified elevation.
Enter the elevation and then select the polyline. Points are placed at the vertices at the specified elevation.
Point settings, styles, layers, point groups, and description keys can all affect how a point is created or how
it is displayed in a drawing. For more information, see Before You Create Points (page 457).
To create points on polylines at a specified elevation
1 Select settings and create styles, layers, point groups, and description keys. For more information, see
Before You Create Points (page 457).
2 Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Create Points - Miscellaneous ➤ Polyline
Vertices - Manual

.

3 Enter the elevation.
4 Select a polyline.
Points are placed at the vertices of the polyline at the specified elevation.
5 For each point, if prompted, enter the point name and description.
6 Press Enter to end the command.
NOTE Many factors affect how the point is displayed. For more information, see Controlling the Appearance of
Points in a Drawing (page 454).

Quick Reference
Ribbon
Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Create Points - Miscellaneous ➤ Polyline Vertices
- Manual
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Menu
Points menu ➤ Create Points - Miscellaneous ➤ Polyline Vertices - Manual
Toolspace Shortcut Menu
Prospector tab: right-click Points collection ➤ Create
Command Line
CreatePtPlylineCtrVertMan
Dialog Box
Create Points (page 2357)

Creating Points on Polylines
Creates points at the vertices of a polyline.
Draw a polyline with elevations, and then use this command to create points along the polyline.
To create points on polylines
1 Select settings and create styles, layers, point groups, and description keys. For more information, see
Before You Create Points (page 457).
2 Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Create Points - Miscellaneous ➤ Polyline
Vertices - Automatic

.

3 Select a polyline.
Points are placed at the vertices of the polyline.
4 For each point, if prompted, enter the point name and description.
5 Press Enter to end the command.
NOTE Many factors affect how the point is displayed. For more information, see Controlling the Appearance of
Points in a Drawing (page 454).

Quick Reference
Ribbon
Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Create Points - Miscellaneous ➤ Polyline Vertices
- Automatic
Menu
Points menu ➤ Create Points - Miscellaneous ➤ Polyline Vertices - Automatic
Toolspace Shortcut Menu
Prospector tab: right-click Points collection ➤ Create
Command Line
CreatePtPlylnCtrVertAuto
Dialog Box
Create Points (page 2357)

Creating Points Using Miscellaneous Methods | 469

Creating Points at Intersections
Use the icons in the Intersection list to access commands that you can use for creating points at intersections.
Point settings, styles, layers, point groups, and description keys can all affect how a point is created or how
it is displayed in a drawing. For more information, see Before You Create Points (page 457).

Creating Points at a Direction/Direction Intersection
Creates a point at the intersection of two directions, each defined by a point and a bearing or azimuth.
Specify values by picking points in the drawing, using transparent commands, or entering values at the
command line.
Create a point at the intersection by specifying the offset distance from each direction line.

To create a point at a direction/direction intersection
1 Select settings and create styles, layers, point groups, and description keys. For more information, see
Before You Create Points (page 457).
2 Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Create Points Intersections ➤ Direction/Direction

.

3 Specify the start point by doing one of the following:
■

Pick a point in the drawing.

■

Use Transparent commands to specify the point.

4 Specify the direction from the start point by doing one of the following:
■

Pick a point in the drawing.

■

Use Transparent commands to specify the second point.

■

Enter Z. Enter the azimuth of the direction line.

■

Enter B. Specify the quadrant and the bearing.

5 Specify the offset distance by doing one of the following:
■

Enter a distance.

■

Pick a point in the drawing to define the offset.

■

Use Transparent commands to specify a point to define the offset.

6 Repeat steps 3-5 to define the second direction line.
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7 Enter a description, or press Enter to skip the description.
8 Enter an elevation for the point, or press Enter to skip the elevation.
NOTE Many factors affect how the point is displayed. For more information, see Controlling the Appearance of
Points in a Drawing (page 454).

Quick Reference
Ribbon
Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Create Points - Intersections ➤ Direction/Direction

Menu
Points menu ➤ Create Points - Intersections ➤ Direction/Direction
Toolspace Shortcut Menu
Prospector tab: right-click Points collection ➤ Create
Command Line
CreatePointDirectionDir
Dialog Box
Create Points (page 2357)

Creating Points at a Distance/Distance Intersection
Creates a point at the intersection of two distances, each defined by a radius length.
Specify values by picking points in the drawing, using transparent commands, or entering values at the
command line.

To create points at a distance/distance intersection
1 Select settings and create styles, layers, point groups, and description keys. For more information, see
Before You Create Points (page 457).
2 Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Create Points Intersections ➤ Distance/Distance

.
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3 Specify the radial point by doing one of the following:
■

Pick a point in the drawing.

■

Use Transparent commands to specify the radial point.

4 Specify the radius by doing one of the following:
■

Enter a radius value.

■

Pick a point in the drawing.

■

Use Transparent commands to specify the radius.

5 Specify the intersection point by doing one of the following:
■

Click near the X on which you want to create the point.

■

Enter A to place points at both intersections.

6 Enter a description, or press Enter to skip the description.
7 Enter an elevation for the point, or press Enter to skip the elevation.
NOTE Many factors affect how the point is displayed. For more information, see Controlling the Appearance of
Points in a Drawing (page 454).

Quick Reference
Ribbon
Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Create Points - Intersections ➤ Distance/Distance

Menu
Points menu ➤ Create Points - Intersections ➤ Distance/Distance
Toolspace Shortcut Menu
Prospector tab: right-click Points collection ➤ Create
Command Line
CreatePointDistanceDist
Dialog Box
Create Points (page 2357)

Creating Points at a Direction/Distance Intersection
Creates a point at the intersection of a direction (line) and distance (circle).
Specify values by picking points in the drawing, using transparent commands, or entering values at the
command line.
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To create points at a direction/distance intersection
1 Select settings and create styles, layers, point groups, and description keys. For more information, see
Before You Create Points (page 457).
2 Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Create Points Intersections ➤ Direction/Distance

.

3 Specify the radial point by doing one of the following:
■

Pick a point in the drawing.

■

Use Transparent commands to specify the point.

4 Specify the radius by doing one of the following:
■

Enter a radius value.

■

Pick a point in the drawing.

■

Use Transparent commands to specify the radius.

5 Specify the start point by doing one of the following:
■

Pick a point in the drawing.

■

Use Transparent commands to specify the point.

6 Specify the direction from the start point by doing one of the following:
■

Pick a point in the drawing.

■

Use Transparent commands to define the point.

■

Enter Z, and then enter the azimuth of the direction line.

■

Enter B, and then specify the quadrant and the bearing.

7 Specify the offset distance by doing one of the following:
■

Enter a distance.

■

Pick a point in the drawing.

■

Use Transparent commands to specify a point to define the offset.

In the drawing, an X marks each intersection point. If only one intersection is located then the point
is automatically created.

Creating Points at Intersections | 473

8 Specify the intersection point by doing one of the following:
■

Click near the X on which you want to create the point.

■

Enter A to place points at both intersections.

9 Enter a description, or press Enter to skip the description.
10 Enter an elevation for the point, or press Enter to skip the elevation.
NOTE Many factors affect how the point is displayed. For more information, see Controlling the Appearance of
Points in a Drawing (page 454).

Quick Reference
Ribbon
Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Create Points - Intersections ➤ Direction/Distance

Menu
Points menu ➤ Create Points - Intersections ➤ Direction/Distance
Toolspace Shortcut Menu
Prospector tab: right-click Points collection ➤ Create
Command Line
CreatePointDirectionDist
Dialog Box
Create Points (page 2357)

Creating Points at a Direction/Perpendicular Intersection
Creates a point that is on a direction line and perpendicular to a selected point.
Select a point in the drawing to create a point on the direction line that is perpendicular to the selected
point.

To create points at a direction/perpendicular intersection
1 Select settings and create styles, layers, point groups, and description keys. For more information, see
Before You Create Points (page 457).
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2 Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Create Points Intersections ➤ Direction/Perpendicular

.

3 Specify the start point by doing one of the following:
■

Pick a point in the drawing.

■

Use Transparent commands to specify the point.

4 Specify the direction from the start point by doing one of the following:
■

Pick a point in the drawing.

■

Use Transparent commands to define the point.

■

Enter Z, and then enter the azimuth of the direction line.

■

Enter B, and then specify the quadrant and the bearing.

5 Specify the offset distance by doing one of the following:
■

Enter a distance.

■

Pick a point in the drawing.

■

Use Transparent commands to specify a point to define the offset.

6 Specify the perpendicular point by doing one of the following:
■

Pick a point in the drawing.

■

Use Transparent commands to specify the perpendicular point.

7 Enter a description, or press Enter to skip the description.
8 Enter an elevation for the point, or press Enter to skip the elevation.
NOTE Many factors affect how the point is displayed. For more information, see Controlling the Appearance of
Points in a Drawing (page 454).

Quick Reference
Ribbon
Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Create Points Intersections ➤ Direction/Perpendicular
Menu
Points menu ➤ Create Points - Intersections ➤ Direction/Perpendicular
Toolspace Shortcut Menu
Prospector tab: right-click Points collection ➤ Create
Command Line
CreatePointDirectionPerp
Dialog Box
Create Points (page 2357)
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Creating Points at a Distance/Perpendicular Intersection
Creates a point that is radial to both a circle and a selected point.
Specify values by picking points in the drawing, using transparent commands, or entering values at the
command line.

To create points a distance/perpendicular intersection
1 Select settings and create styles, layers, point groups, and description keys. For more information, see
Before You Create Points (page 457).
2 Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Create Points Intersections ➤ Distance/Perpendicular

.

3 Specify the radial point by doing one of the following:
■

Pick a point in the drawing.

■

Use Transparent commands to specify the point.

4 Specify the radius by doing one of the following:
■

Enter a radius value.

■

Pick a point in the drawing.

■

Use Transparent commands to specify the radius.

5 Enter a description, or press Enter to skip the description.
6 Enter an elevation for the point, or press Enter to skip the elevation.
7 Specify the perpendicular point by doing one of the following:
■

Pick a point in the drawing.

■

Use Transparent commands to specify the perpendicular point.

8 NOTE Many factors affect how the point is displayed. For more information, see Controlling the Appearance
of Points in a Drawing (page 454).
9 Enter a description, or press Enter to skip the description.
10 Enter an elevation for the point, or press Enter to skip the elevation.

476 | Chapter 15 Points

Quick Reference
Ribbon
Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Create Points Intersections ➤ Distance/Perpendicular
Menu
Points menu ➤ Create Points - Intersections ➤ Distance/Perpendicular
Toolspace Shortcut Menu
Prospector tab: right-click Points collection ➤ Create
Command Line
CreatePointDistancePerp
Dialog Box
Create Points (page 2357)

Creating Points at a Direction/Object Intersection
Creates a point at the intersection of a line, curve, or spiral object and a direction line.
Specify values by picking points in the drawing, using transparent commands, or entering values at the
command line.

To create points at a direction/object intersection
1 Select settings and create styles, layers, point groups, and description keys. For more information, see
Before You Create Points (page 457).
2 Home tab ➤ Create Ground Data panel ➤ Points Menu ➤ Create Points - Intersections ➤ Direction/Object
.
3 Select an object.
4 Specify the offset distance by doing one of the following:
■

Enter a distance.

■

Pick a point in the drawing.

■

Use Transparent commands to specify a point to define the offset.
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5 Specify the start point by doing one of the following:
■

Pick a point in the drawing.

■

Use Transparent commands to specify the point.

6 Specify the direction from the start point by doing one of the following:
■

Pick a point in the drawing.

■

Use Transparent commands to define the point.

■

Enter Z, and then enter the azimuth of the direction line.

■

Enter B, and then specify the quadrant and the bearing.

7 Specify the offset distance by doing one of the following:
■

Enter a distance.

■

Pick a point in the drawing.

■

Use Transparent commands to specify a point to define the offset.

8 Enter a description, or press Enter to skip the description.
9 Enter an elevation for the point, or press Enter to skip the elevation.
NOTE Many factors affect how the point is displayed. For more information, see Controlling the Appearance of
Points in a Drawing (page 454).

Quick Reference
Ribbon
Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Create Points - Intersections ➤ Direction/Object

Menu
Points menu ➤ Create Points - Intersections ➤ Direction/Object
Toolspace Shortcut Menu
Prospector tab: right-click Points collection ➤ Create
Command Line
CreatePointDirectionObj
Dialog Box
Create Points (page 2357)

Creating Points at a Distance/Object Intersection
Creates a point at the intersection of an object and a radial distance.
Specify values by picking points in the drawing, using transparent commands, or entering values at the
command line. Points are offset from the intersection of an object and a radial distance.
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To create points at a distance/object intersection
1 Select settings and create styles, layers, point groups, and description keys. For more information, see
Before You Create Points (page 457).
2 Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Create Points - Intersections ➤ Distance/Object
.
3 Select an object.
4 Specify the offset distance by doing one of the following:
■

Enter a distance.

■

Pick a point in the drawing.

■

Use Transparent commands to specify a point to define the offset.

5 Specify the radial point by doing one of the following:
■

Pick a point in the drawing.

■

Use Transparent commands to specify the point.

6 Specify the radius by doing one of the following:
■

Enter a radius value.

■

Pick a point in the drawing.

■

Use Transparent commands to specify the radius.

In the drawing, an X marks each intersection point. If only one intersection is located then the point
is automatically created.
7 Specify the intersection point by doing one of the following:
■

Click near the X on which you want to create the point.

■

Enter A to place points at both intersections.

8 Enter a description, or press Enter to skip the description.
9 Enter an elevation for the point, or press Enter to skip the elevation.
NOTE Many factors affect how the point is displayed. For more information, see Controlling the Appearance of
Points in a Drawing (page 454).
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Quick Reference
Ribbon
Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Create Points - Intersections ➤ Distance/Object

Menu
Points menu ➤ Create Points - Intersections ➤ Distance/Object
Toolspace Shortcut Menu
Prospector tab: right-click Points collection ➤ Create
Command Line
CreatePointDistanceObject
Dialog Box
Create Points (page 2357)

Creating Points at an Object/Object Intersection
Creates a point at the intersection of lines, arcs, lot lines, or feature lines.
If the objects do not intersect, the command extends either object to determine the intersection point. A
point is offset from the intersection of two objects.

To create points at an object/object intersection
1 Select settings and create styles, layers, point groups, and description keys. For more information, see
Before You Create Points (page 457).
2 Click Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Create Points Intersections ➤ Object/Object

.

3 Select an object.
4 Specify the offset distance by doing one of the following:
■

Enter a distance.

■

Pick a point in the drawing.

■

Use Transparent commands to specify a point to define the offset.

5 Select the second object.
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6 Specify the offset distance by doing one of the following:
■

Enter a distance.

■

Pick a point in the drawing.

■

Use Transparent commands to specify a point to define the offset.

In the drawing, an X marks each intersection point. If only one intersection is located then the point
is automatically created.
7 Specify the intersection point by doing one of the following:
■

Click near the X on which you want to create the point.

■

Enter A to place points at both intersections.

8 Enter a description, or press Enter to skip the description.
9 Enter an elevation for the point, or press Enter to skip the elevation.
NOTE Many factors affect how the point is displayed. For more information, see Controlling the Appearance of
Points in a Drawing (page 454).

Quick Reference
Ribbon
Click Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Create Points - Intersections ➤ Object/Object

Menu
Points menu ➤ Create Points - Interpolate ➤ Intersection
Toolspace Shortcut Menu
Prospector tab: Right-click Points collection ➤ Create
Command Line
CreatePointObjectObject
Dialog Box
Create Points (page 2357)

Creating Points at a Perpendicular Intersection
Creates a point along a line or arc object, perpendicular, or radial to a specified point.
From a specified point, the created point is perpendicular on a line but radial on a curve. The point is
perpendicular to a selected point and a line.
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To create points at a perpendicular intersection
1 Select settings and create styles, layers, point groups, and description keys. For more information, see
Before You Create Points (page 457).
2 Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Create Points - Intersections ➤ Perpendicular
.
3 Select an object.
4 Specify the perpendicular point by doing one of the following:
■

Pick a point in the drawing.

■

Use Transparent commands to specify the perpendicular point.

5 Enter a description, or press Enter to skip the description.
6 Enter an elevation for the point, or press Enter to skip the elevation.
NOTE Many factors affect how the point is displayed. For more information, see Controlling the Appearance of
Points in a Drawing (page 454).

Quick Reference
Ribbon
Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Create Points - Intersections ➤ Perpendicular

Menu
Points ➤ Create Points - Intersections ➤ Perpendicular
Toolspace Shortcut Menu
Prospector tab: right-click Points collection ➤ Create
Command Line
CreatePtIntersectPerp
Dialog Box
Create Points (page 2357)
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Creating Points at a Direction/Alignment Intersection
Creates a point either at the intersection of a direction line and an alignment or at a point offset from the
intersection.
Specify values by picking points in the drawing, using transparent commands, or entering values at the
command line.
Create a point that is offset from the intersection of a direction and an alignment by selecting a direction
line and then specifying the offset from the direction line and the offset from the alignment.

To create points at a direction/alignment intersection
1 Select settings and create styles, layers, point groups, and description keys. For more information, see
Before You Create Points (page 457).
2 Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Create Points Intersections ➤ Direction/Alignment

.

3 Select an alignment object.
4 Specify the offset distance by doing one of the following:
■

Enter a distance.

■

Pick a point in the drawing.

■

Use Transparent commands to specify a point to define the offset.

5 Specify the start point by doing one of the following:
■

Pick a point in the drawing.

■

Use Transparent commands to specify the point.

6 Specify the direction from the start point by doing one of the following:
■

Pick a point in the drawing.

■

Use Transparent commands to define the point.

■

Enter Z, and then enter the azimuth of the direction line.

■

Enter B, and then specify the quadrant and the bearing.

7 Specify the offset distance by doing one of the following:
■

Enter a distance.

■

Pick a point in the drawing.
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■

Use Transparent commands to specify a point to define the offset.

In the drawing, an X marks each intersection point. If only one intersection is located then the point
is automatically created.
8 Specify the intersection point by doing one of the following:
■

Click near the X on which you want to create the point.

■

Enter A to place points at both intersections.

9 Enter a description, or press Enter to skip the description.
10 Enter an elevation for the point, or press Enter to skip the elevation.
NOTE Many factors affect how the point is displayed. For more information, see Controlling the Appearance of
Points in a Drawing (page 454).

Quick Reference
Ribbon
Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Create Points - Intersections ➤ Direction/Alignment

Menu
Points menu ➤ Create Points - Intersections ➤ Direction/Alignment
Toolspace Shortcut Menu
Prospector tab: right-click Points collection ➤ Create
Command Line
CreatePointDirectionAlign
Dialog Box
Create Points (page 2357)

Creating Points at a Distance/Alignment Intersection
Creates a point at the intersection of a distance line and an alignment.
The intersection is located where the radial distance from a specified point crosses the alignment.
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To create points at distance/alignment intersection
1 Select settings and create styles, layers, point groups, and description keys. For more information, see
Before You Create Points (page 457).
2 Home tab ➤ Create Ground Data panel ➤ Points Menu ➤ Create Points Intersections ➤ Distance/Alignment

.

3 Select an alignment object.
4 Specify the offset distance by doing one of the following:
■

Enter a distance.

■

Pick a point in the drawing.

■

Use Transparent commands to specify a point to define the offset.

5 Specify the radial point by doing one of the following:
■

Pick a point in the drawing.

■

Use Transparent commands to specify the point.

In the drawing, an X marks each intersection point. If only one intersection is located then the point
is automatically created.
6 Specify the radius by doing one of the following:
■

Enter a distance.

■

Pick a point in the drawing.

■

Use Transparent commands to specify a point to define the offset.

7 Specify the intersection point by doing one of the following:
■

Click near the X on which you want to create the point.

■

Enter A to place points at both intersections.

8 Enter a description, or press Enter to skip the description.
9 Enter an elevation for the point, or press Enter to skip the elevation.
NOTE Many factors affect how the point is displayed. For more information, see Controlling the Appearance of
Points in a Drawing (page 454).

Quick Reference
Ribbon
Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Create Points - Intersections ➤ Distance/Alignment

Menu
Points menu ➤ Create Points - Intersections ➤ Distance/Alignment
Toolspace Shortcut Menu
Prospector tab: right-click Points collection ➤ Create
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Command Line
CreatePointDistanceAlign
Dialog Box
Create Points (page 2357)

Creating Points at an Object/Alignment Intersection
Creates a point at either the intersection of any object and an alignment or at an offset from the intersection.
If the line or arc object does not intersect the alignment, the command extends either object to determine
the intersection point.

To create points at an object/alignment intersection
1 Select settings and create styles, layers, point groups, and description keys. For more information, see
Before You Create Points (page 457).
2 Home tab ➤ Create Ground Data panel ➤ Points Menu ➤ Create Points Intersections ➤ Object/Alignment

.

3 Select an alignment object.
4 Specify the offset distance by doing one of the following:
■

Enter a distance.

■

Pick a point in the drawing.

■

Use Transparent commands to specify a point to define the offset.

5 Select an object.
6 Specify the offset distance by doing one of the following:
■

Enter a distance.

■

Pick a point in the drawing.

■

Use Transparent commands to specify a point to define the offset.

In the drawing, an X marks each intersection point. If only one intersection is located then the point
is automatically created.
7 Specify the intersection point by doing one of the following:
■

Click near the X on which you want to create the point.
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■

Enter A to place points at both intersections.

8 Enter a description, or press Enter to skip the description.
9 Enter an elevation for the point, or press Enter to skip the elevation.
NOTE Many factors affect how the point is displayed. For more information, see Controlling the Appearance of
Points in a Drawing (page 454).

Quick Reference
Ribbon
Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Create Points - Intersections ➤ Object/Alignment

Menu
Points menu ➤ Create Points - Intersections ➤ Object/Alignment
Toolspace Shortcut Menu
Prospector tab: right-click Points collection ➤ Create
Command Line
CreatePointObjectAlign
Dialog Box
Create Points (page 2357)

Creating Points at an Alignment/Alignment Intersection
Creates a point either at the intersection of two alignments or an offset distance from one or both alignments.
There must be an alignment intersection in the drawing. Pick two intersecting alignments to create a point
that is offset from the intersection.

To create points at an alignment/alignment intersection
1 Select settings and create styles, layers, point groups, and description keys. For more information, see
Before You Create Points (page 457).
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2 Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Create Points Intersections ➤ Alignment/Alignment

.

3 Select an alignment object.
4 Specify the offset distance by doing one of the following:
■

Enter a distance.

■

Pick a point in the drawing.

■

Use Transparent commands to specify a point to define the offset.

5 Select a second alignment object.
6 Specify the offset distance by doing one of the following:
■

Enter a distance.

■

Pick a point in the drawing.

■

Use Transparent commands to specify a point to define the offset.

In the drawing, an X marks each intersection point. If only one intersection is located then the point
is automatically created.
7 Specify the intersection point by doing one of the following:
■

Click near the X on which you want to create the point.

■

Enter A to place points at both intersections.

8 Enter a description, or press Enter to skip the description.
9 Enter an elevation for the point, or press Enter to skip the elevation.
NOTE Many factors affect how the point is displayed. For more information, see Controlling the Appearance of
Points in a Drawing (page 454).

Quick Reference
Ribbon
Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Create Points Intersections ➤ Alignment/Alignment
Menu
Points menu ➤ Create Points - Intersections ➤ Alignment/Alignment
Toolspace Shortcut Menu
Prospector tab: right-click Points collection ➤ Create
Command Line
CreatePointAlignAlign
Dialog Box
Create Points (page 2357)
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Creating Points Based on Horizontal Alignments
Use the icons in the Alignment list to access commands that you can use to create points relative to a
horizontal alignment.
Create points either on a horizontal alignment or at an offset from the alignment.
If you want the point description to be taken from the object, specify Automatic - Object in the Prompt For
Descriptions section of the Points Creation settings. The alignment name and station display in the Raw
Description column in the Point Editor.
Point settings, styles, layers, point groups, and description keys can all affect how a point is created or how
it is displayed in a drawing. For more information, see Before You Create Points (page 457).

Creating Points Offset from Alignment Stations
Creates that are offset from stations on an alignment.
Use this command to create ROWs, shoulders, and passing lanes.

To create points offset from alignment stations
1 Choose default settings, style, layers, point group, and description keys. For more information, see
Before You Create Points (page 457).
2 Click Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Create Points Alignments ➤ Station/Offset

.

3 Select an alignment.
NOTE If the selected alignment has associated profiles, the Select a Profile dialog box displays. You can select
a profile from the list and the elevations for the points you create will be set from that profile. If there is no
profile section for a station on the alignment, or if you select <none>, the point elevation will be set according
to the Points Creation settings in the Create Points dialog box.
4 Enter the station number from which you want to offset a point. Do not include the station plus (+)
sign.
5 Enter the offset. If you have selected a profile, the offset value for the profile displays as the default.
6 If prompted, enter the name, description, and elevation for the point.
NOTE If you want the point description to be taken from the object, specify Automatic - Object in the
Prompt For Descriptions section of the Points Creation settings. The alignment name and station display in
the Raw Description column in the Point Editor.
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7 Press Enter to end the command.
NOTE Many factors affect how the point is displayed. For more information, see Controlling the Appearance of
Points in a Drawing (page 454).

Quick Reference
Ribbon
Click Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Create Points - Alignments ➤ Station/Offset

Menu
Points menu ➤ Create Points - Alignments ➤ Station/Offset
Toolspace Shortcut Menu
Prospector tab: right-click Points collection ➤ Create
Command Line
CreatePointStationOffset
Dialog Box
Create Points (page 2357)

Creating a Specific Number of Points Along an Alignment
Creates points that are a specified distance apart along an alignment.
Specify the number of segments for the alignment. Points can be placed at each vertex on the alignment or
at a specified offset.

Point settings, styles, layers, point groups, and description keys can all affect how a point is created or how
it is displayed in the drawing. For more information, see Before You Create Points (page 457).
To create a specific number of points along an alignment
1 Select settings and create styles, layers, point groups, and description keys. For more information, see
Before You Create Points (page 457).
2 Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Create Points - Alignments ➤ Divide Alignment
.
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3 Select an alignment.
NOTE If the selected alignment has associated profiles, the Select a Profile dialog box displays. You can select
a profile from the list and the elevations for the points you create will be set from that profile. If there is no
profile section for a station on the alignment, or if you select <none>, the point elevation will be set according
to the Points Creation settings in the Create Points dialog box.
4 Enter the number of segments into which you want to divide the selected alignment.
The command calculates the distances between points by dividing the total length of the alignment
by the number of segments specified.
5 Enter the offset. If you have selected a profile, the offset value for the profile displays as the default.
A series of equally spaced points are placed along the alignment at the specified offset.
6 If prompted, for each point, enter a point name, description, and elevation.
NOTE If you want the point description to be taken from the object, specify Automatic - Object in the
Prompt For Descriptions section of the Points Creation settings. The alignment name and station display in
the Raw Description column in the Point Editor.

TIP Many factors affect how the point is displayed. For more information, see Controlling the Appearance of
Points in a Drawing (page 454).

Quick Reference
Ribbon
Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Create Points - Alignments ➤ Divide Alignment

Menu
Points menu ➤ Create Points - Alignments ➤ Divide Alignment
Toolspace Shortcut Menu
Prospector tab: right-click Points collection ➤ Create
Command Line
CreatePointDivideAlign
Dialog Box
Create Points (page 2357)

Creating Points on an Alignment Using a Distance Interval
Creates points at equally spaced intervals along an alignment.
Specify the distance between points, and optionally an offset distance from the alignment.
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Point settings, styles, layers, point groups, and description keys can all affect how a point is created or how
it is displayed in the drawing. For more information, see Before You Create Points (page 457).
To create points on an alignment based on a distance interval
1 Select settings and create styles, layers, point groups, and description keys. For more information, see
Before You Create Points (page 457).
2 Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Create Points - Alignments ➤ Measure
Alignment

.

3 Select an alignment.
NOTE If the selected alignment has associated profiles, the Select a Profile dialog box displays. You can select
a profile from the list and the elevations for the points you create will be set from that profile. If there is no
profile section for a station on the alignment, or if you select <none>, the point elevation will be set according
to the Points Creation settings in the Create Points dialog box.
4 Enter the starting station or press Enter to accept the default.
5 Enter the ending station or press Enter to accept the default.
6 Enter the offset. If you have selected a profile, the offset value for the profile displays as the default.
7 Enter the interval.
Points are placed along the alignment at the specified offset and interval.
8 If prompted, for each point, enter a point name, description, and elevation.
NOTE If you want the point description to be taken from the object, specify Automatic - Object in the
Prompt For Descriptions section of the Points Creation settings. The alignment name and station display in
the Raw Description column in the Point Editor.

TIP Many factors affect how the point is displayed. For more information, see Controlling the Appearance of
Points in a Drawing (page 454).

Quick Reference
Ribbon
Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Create Points - Alignments ➤ Measure Alignment
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Menu
Points menu ➤ Create Points - Alignments ➤ Measure Alignment
Toolspace Shortcut Menu
Prospector tab: right-click Points collection ➤ Create
Command Line
CreatePointMeasureAlig
Dialog Box
Create Points (page 2357)

Creating Points at the Geometry Points of Alignments
Creates a point at every geometry point on an alignment.
Geometry points are points of curvature (PC), points of tangency (PT), spiral-curves (SC), curve-spirals (CS),
tangent spirals (TS), spiral-tangents (ST), and points of intersection (PI).

When creating points using this command, you are not prompted for a description if the Prompt For
Descriptions Points Creation setting is set to Automatic-Object. The raw and full description for the point
is automatically assigned based on the type of point created. The assigned description displays in the drawing
if the current point label style contains a raw description or a full description text component.
The following table describes alignment vertex labels that are created and the description that is assigned
based on the point type:
Created Label

Definition

BOA

Beginning of Alignment

PI

Point of Intersection

CPI

Curve Point of Intersection

PT

Point of Tangency

PC

Point of Curvature

SPI

Spiral Point of Intersection

TS

Tangent-Spiral intersection
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Created Label

Definition

CS

Curve-Spiral intersection

ST

Spiral-Tangent intersection

CC

Curve Center or radius point

EOA

End of Alignment

Point settings, styles, layers, point groups, and description keys can all affect how a point is created or how
it is displayed in the drawing. For more information, see Before You Create Points (page 457).
To create points at the geometry points of alignments
1 Select settings and create styles, layers, point groups, and description keys. For more information, see
Before You Create Points (page 457).
2 Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Create Points - Alignments ➤ At Alignment
Geometry

.

3 Select an alignment.
NOTE If the selected alignment has associated profiles, the Select a Profile dialog box displays. You can select
a profile from the list and the elevations for the points you create will be set from that profile. If there is no
profile section for a station on the alignment, or if you select <none>, the point elevation will be set according
to the Points Creation settings in the Create Points dialog box.
4 Enter the starting station or press Enter to accept the default.
5 Enter the ending station or press Enter to accept the default.
Points are placed along the alignment object.
6 If prompted, for each point, enter a point name and elevation.
The created points are automatically labeled using the current label style. If the current label style
contains either a raw description or a full description text component, the vertex type displays in the
label.
NOTE If you want the point description to be taken from the object, specify Automatic - Object in the
Prompt For Descriptions section of the Points Creation settings. The alignment name and station display in
the Raw Description column in the Point Editor.

NOTE Many factors affect how the point is displayed. For more information, see Controlling the Appearance of
Points in a Drawing (page 454).

Quick Reference
Ribbon
Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Create Points - Alignments ➤ At Alignment
Geometry
Menu
Points menu ➤ Create Points - Alignments ➤ At Geometry Points
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Toolspace Shortcut Menu
Prospector tab: right-click Points collection ➤ Create
Command Line
CreatePointAtPtPcScetc
Dialog Box
Create Points (page 2357)

Creating Radial or Perpendicular Points on Alignments
Creates a point on an alignment that is radial or perpendicular to a specified point.
From specified point, the created point is perpendicular on a line and radial on a curve.

Point settings, styles, layers, point groups, and description keys can all affect how a point is created or how
it is displayed in the drawing. For more information, see Before You Create Points (page 457).
To create radial or perpendicular points on alignments
1 Select settings and create styles, layers, point groups, and description keys. For more information, see
Before You Create Points (page 457).
2 Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Create Points - Alignments ➤ Radial Or
Perpendicular

.

3 Select an alignment.
NOTE If the selected alignment has associated profiles, the Select a Profile dialog box displays. You can select
a profile from the list and the elevations for the points you create will be set from that profile. If there is no
profile section for a station on the alignment, or if you select <none>, the point elevation will be set according
to the Points Creation settings in the Create Points dialog box.
4 Specify a point.
5 If prompted, enter the point name, description, and elevation.
NOTE If you want the point description to be taken from the object, specify Automatic - Object in the
Prompt For Descriptions section of the Points Creation settings. The alignment name and station display in
the Raw Description column in the Point Editor.
6 Press Enter to end the command.
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NOTE Many factors affect how the point is displayed. For more information, see Controlling the Appearance of
Points in a Drawing (page 454).

Quick Reference
Ribbon
Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Create Points - Alignments ➤ Radial Or
Perpendicular
Menu
Points menu ➤ Create Points - Alignments ➤ Radial Or Perpendicular
Toolspace Shortcut Menu
Prospector tab: right-click Points collection ➤ Create
Command Line
CreatePointRadialOrPerp
Dialog Box
Create Points (page 2357)

Creating Profile Geometry Points on Alignments
Creates points on the alignment at the geometry points of the profile view with elevations from the profile.
Profile geometry points can be points for the begin of vertical curvature (BVC), points of vertical intersection
(PVI), and points of end of vertical curvature (EVC).
Point settings, styles, layers, point groups, and description keys can all affect how a point is created or how
it is displayed in the drawing. For more information, see Before You Create Points (page 457).
To create profile geometry points on alignments
1 Select settings and create styles, layers, point groups, and description keys. For more information, see
Before You Create Points (page 457).
2 Click Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Create Points - Alignments ➤ Profile
Geometry Points

.

3 Select an alignment in the drawing, or if there is more than one alignment, select it from the list.
4 Select a Profile from the list.
Points are created on the alignment at the geometry points of the profile view with elevations from the
profile.
5 Press Enter to end the command.
NOTE Many factors affect how the point is displayed. For more information, see Controlling the Appearance of
Points in a Drawing (page 454).
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Quick Reference
Ribbon
Click Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Create Points - Alignments ➤ Profile
Geometry Points
Menu
Click Points menu ➤ Create Points - Alignments ➤ Profile Geometry Points.
Toolspace Shortcut Menu
Prospector tab: right-click Points collection ➤ Create
Command Line
CreateProfileGeomPoints
Dialog Box
Create Points (page 2357)

Creating Points on an Alignment by Importing ASCII Files
Creates points along an alignment by importing points from an ASCII (text) file that contains station, offset,
and elevation information.
The file you import can contain the station, offset, elevation, and description of each point. The elevation
can be expressed as either a single value (elevation) or a rod reading with instrument height (rod, hi).
ASCII (text) files that use the following layouts (formats) can be imported:
■

Station, Offset

■

Station, Offset, Elevation

■

Station, Offset, Rod, Hi

■

Station, Offset, Description

■

Station, Offset, Elevation, Description

■

Station, Offset, Rod, Hi, Description

Use commas or spaces as delimiters (separators) in the file. Include one or more comment lines in the file
by putting a semi-colon (;) or a pound sign (#) in the first column of a comment line.
The following is an example of data in an ASCII (text) file that is formatted using the Station, Offset, Elevation
format:
#station, offset, elevation: subdivision 1
0 20.0 112.00
10 23.5 114.64
20 22.5 116.56
30 23.0 116.32
40 22.0 115.83

The first line in this example is a comment line that is ignored when the points are imported. Each of the
remaining lines contains the station, offset, and elevation for a point. The file is delimited by spaces.
Before you import the file, you are prompted to describe the format of the ASCII (text) file. You can also be
prompted to specify invalid indicator values for station/offsets, elevations, and rod heights.
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Point settings, styles, layers, point groups, and description keys can all affect how a point is created or how
it is displayed in the drawing. For more information, see Before You Create Points (page 457).
To create points on an alignment by importing ASCII files
1 Select settings and create styles, layers, point groups, and description keys. For more information, see
Before You Create Points (page 457).
2 Click Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Create Points - Alignments ➤ Import
From File

.

3 In the Import Alignment Station And Offset File dialog box, browse to the folder containing the file.
Click the file name, and click Open.
NOTE The station information must be raw station values.
4 Enter a number between 1 and 6 to specify the format that describes the layout of data in your file, as
follows:
■

1: Station, Offset

■

2: Station, Offset, Elevation

■

3: Station, Offset, Rod, Hi

■

4: Station, Offset, Description

■

5: Station, Offset, Elevation, Description

■

6: Station, Offset, Rod, Hi, Description

5 Do one of the following:
■

Enter 1 if the file delimiter is a space.

■

Enter 2 if the file delimiter is a comma.

6 If prompted, specify invalid indicators for station/offset, elevation, or rod/hi values.
7 Select an alignment.
NOTE Many factors affect how the point is displayed. For more information, see Controlling the Appearance of
Points in a Drawing (page 454).

Quick Reference
Ribbon
Click Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Create Points - Alignments ➤ Import From
File
Menu
Points menu ➤ Create Points - Alignments ➤ Import From File
Toolspace Shortcut Menu
Prospector tab: right-click Points collection ➤ Create
Command Line
CreatePointImportFromFile
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Dialog Box
Create Points (page 2357)

Creating Points Based on Surface Elevations
Use the icons in the Surface list to access commands that you can use to create points using surface elevations.
Point settings, styles, layers, point groups, and description keys can all affect how a point is created or how
it is displayed in the drawing. For more information, see Before You Create Points (page 457).

Creating a Point at a Surface Elevation
Creates points at any specified location on a surface.
Point elevations are read from the specified surface.
Point settings, styles, layers, point groups, and description keys can all affect how a point is created or how
it is displayed in the drawing. For more information, see Before You Create Points (page 457).
To create a point at a surface elevation
1 Select settings and create styles, layers, point groups, and description keys. For more information, see
Before You Create Points (page 457).
2 Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Create Points - Surface ➤ Random Points
.
3 Select a surface.
4 Specify a location within the surface boundary for the point.
The point takes its elevation from the surface at the specified location.
5 If prompted, enter the point name and description.
6 Press Enter to end the command.
NOTE Many factors affect how the point is displayed. For more information, see Controlling the Appearance of
Points in a Drawing (page 454).

Quick Reference
Ribbon
Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Create Points - Surface ➤ Random Points
Menu
Points menu ➤ Create Points - Surface ➤ Random Points
Toolspace Shortcut Menu
Prospector tab: right-click Points collection ➤ Create
Command Line
CreatePointRandomPoints
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Dialog Box
Create Points (page 2357)

Creating a Grid of Points at Surface Elevations
Generates a grid of points that are automatically assigned surface elevations.
Specify grid base point (lower left corner), cell size (X and Y lengths), upper right corner, and optional
rotation angle.

Because this command creates points using elevations from a surface, the Prompt For Elevations setting,
specified in the Points Creation settings, does not affect how you are prompted during this command.
To create a grid of points at surface elevations
1 Select settings and create styles, layers, point groups, and description keys. For more information, see
Before You Create Points (page 457).
2 Click Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Create Points - Surface ➤ On Grid
.
3 Select a surface.
4 Specify the location of the grid base point, which is the lower left corner of the grid, by doing one of
the following:
■

Enter X and Y coordinates on the command line.

■

Specify a point on the screen.

5 Enter the rotation angle or press Enter to accept the default.
6 Specify the grid X spacing by entering a value or pressing Enter to accept the default value.
7 Specify the grid Y spacing by entering a value or pressing Enter to accept the default value.
8 Specify the location of the upper-right corner of the grid by clicking on the screen.
A single grid square and the outline of the entire grid are drawn on the screen.
9 Do one of the following:
■

To create the points based on the displayed grid, press Enter.

■

To change the grid, enter Yes and re-enter the rotation angle, grid base point, grid X spacing, grid
Y spacing, and the upper right corner as previously described.
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The command calculates the coordinates of each grid point. The elevation of each calculated point is
taken from the selected surface.
10 For each point, if prompted, enter the point name and description.
NOTE Many factors affect how the point is displayed. For more information, see Controlling the Appearance of
Points in a Drawing (page 454).

Quick Reference
Ribbon
Click Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Create Points - Surface ➤ On Grid
Menu
Points ➤ Create Points ➤ Surface ➤ On Grid
Toolspace Shortcut Menu
Prospector tab: right-click Points collection ➤ Create
Command Line
CreatePointOnGrid
Dialog Box
Create Points (page 2357)

Creating Points Along a Polyline or Surface Contour Using Distance and Surface
Elevations
Creates points on a surface at specified distances along a polyline object or a surface contour.
Create points using elevations from the surface. The points are created along a polyline based on a specified
distance.

The Prompt For Elevations setting, specified in the Points Creation settings, does not affect how you are
prompted during this command.
Point settings, styles, layers, point groups, and description keys can all affect how a point is created or how
it is displayed in the drawing. For more information, see Before You Create Points (page 457).
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To create points along a polyline or surface contour using distance and surface elevations
1 Select settings and create styles, layers, point groups, and description keys. For more information, see
Before You Create Points (page 457).
2 Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Create Points - Surface ➤ Along
Polyline/Contour

.

3 Select a surface.
4 Enter the distance between the points.
5 Select the polyline or surface contour along which to place the points.
The points are placed along the polyline or surface contour at the specified interval.
6 If prompted, for each point, enter the point name and description.
NOTE Many factors affect how the point is displayed. For more information, see Controlling the Appearance of
Points in a Drawing (page 454).

Quick Reference
Ribbon
Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Create Points - Surface ➤ Along Polyline/Contour

Menu
Points menu ➤ Create Points - Surface ➤ Along Polyline/Contour
Toolspace Shortcut Menu
Prospector tab: right-click Points collection ➤ Create
Command Line
CreatePtAlongPolyContour
Dialog Box
Create Points (page 2357)

Creating Points at Polyline or Surface Contour Vertices Using Surface Elevations
Creates points on a surface at the vertices of polylines or surface contours.
Points are not placed at polyline vertices that fall outside the surface boundary.
Because this command creates points using elevations from a surface, the Prompt For Elevations setting,
specified in the Points Creation settings, does not affect how you are prompted during this command.
Point settings, styles, layers, point groups, and description keys can all affect how a point is created or how
it is displayed in the drawing. For more information, see Before You Create Points (page 457).
To create points at polyline or surface contour vertices using surface elevations
1 Select settings and create styles, layers, point groups, and description keys. For more information, see
Before You Create Points (page 457).
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2 Click Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Create Points Surface ➤ Polyline/Contour Vertices

.

3 Select a surface.
4 Select a polyline or surface contour.
The points are placed at the polyline or surface contour vertices.
5 If prompted, for each point, enter the point name and description.
NOTE Many factors affect how the point is displayed. For more information, see Controlling the Appearance of
Points in a Drawing (page 454).

Quick Reference
Ribbon
Click Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Create Points - Surface ➤ Polyline/Contour
Vertices
Menu
Points ➤ Create Points ➤ Surface ➤ Polyline/Contour Vertices
Toolspace Shortcut Menu
Prospector tab: right-click Points collection ➤ Create
Command Line
CreatePtPolyContourVert
Dialog Box
Create Points (page 2357)

Creating Points by Interpolation
Use the icons in the Interpolate list to access commands that you can use to create interpolated points
between selected points.
Point settings, styles, layers, point groups, and description keys can all affect how a point is created or how
it is displayed in the drawing. For more information, see Before You Create Points (page 457)

Creating Points by Interpolation
Interpolates a specified number of points between two existing points.
Interpolation determines point location and elevation. To use this command, you must have at least two
points with elevations in the drawing.
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To create a specified number of interpolated points between two points
1 Select settings and create styles, layers, point groups, and description keys. For more information, see
Before You Create Points (page 457).
2 Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Create Points - Interpolate ➤ Interpolate
.
3 Specify the first point by doing one of the following:
■

Pick a point in the drawing.

■

Use Transparent commands to specify the point.

4 Specify the second point by doing one of the following:
■

Pick a point in the drawing.

■

Use Transparent commands to specify the point.

5 Enter the number of points to create.
6 Enter a description, or press Enter to skip the description.

Quick Reference
Ribbon
Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Create Points - Interpolate ➤ Interpolate
Menu
Points menu ➤ Create Points - Interpolate ➤ Interpolate
Toolspace Shortcut Menu
Prospector tab: right-click Points collection ➤ Create
Command Line
CreatePointInterpolate
Dialog Box
Create Points (page 2357)
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Creating Points by Relative Location
Interpolates a point between two control points based on a distance.
Select an object (1) with two control points (2) and (3) and then specify a distance (4) and offset (5) to create
the point.

To create points by relative location
1 Select settings and create styles, layers, point groups, and description keys. For more information, see
Before You Create Points (page 457).
2 Home tab ➤ Create Ground Data panel ➤ Points Menu ➤ Create Points - Interpolate ➤ By Relative
Location

.

3 Specify the interpolation region by doing one of the following:
■

Pick a point in the drawing and enter an elevation for the first point. Specify the second point and
then either enter D to specify the difference in elevation between the two points, or enter S to specify
the slope from the first point to the second point.

■

Use Transparent commands to specify the point.

■

Enter E, and select an arc, line, feature line, lot line, or polyline. Specify the distance and the offset
distance by either entering the distance, picking a point, or using Transparent commands.

4 Enter a description, or press Enter to skip the description.

Quick Reference
Ribbon
Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Create Points - Interpolate ➤ By Relative Location

Menu
Points menu ➤ Create Points - Interpolate ➤ By Relative Location
Toolspace Shortcut Menu
Prospector tab: right-click Points collection ➤ Create
Command Line
CreatePointByRelLocation
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Dialog Box
Create Points (page 2357)

Creating Points By Relative Elevation
Interpolates a point at a specified elevation between two control points.
Define the interpolation region by specifying the start and end control points, or click near the start point
of an object.

Point settings, styles, layers, point groups, and description keys can all affect how a point is created or how
it is displayed in the drawing. For more information, see Before You Create Points (page 457).
To create points at an elevation by interpolating between two points
1 Select settings and create styles, layers, point groups, and description keys. For more information, see
Before You Create Points (page 457).
2 Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Create Points - Interpolate ➤ By Relative
Elevation

.

3 Specify the interpolation region by doing one of the following:
■

Pick a point in the drawing and enter an elevation for the first point. Specify the second point and
then either enter D to specify the difference in elevation between the two points, or enter S to specify
the slope from the first point to the second point.

■

Use Transparent commands to specify the point.

■

Enter E, and select an arc, line, feature line, lot line, or polyline. Enter the elevation and then specify
the offset distance by either entering the distance, picking a point, or using Transparent commands.

4 Enter a description, or press Enter to skip the description.

Quick Reference
Ribbon
Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Create Points - Interpolate ➤ By Relative Elevation

Menu
Points menu ➤ Create Points - Interpolate ➤ By Relative Elevation
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Toolspace Shortcut Menu
Prospector tab: right-click Points collection ➤ Create
Command Line
CreatePointByRelElev
Dialog Box
Create Points (page 2357)

Creating Points using Number By Distance
Interpolates a specified number of points between two control points.
Define the interpolation region by specifying the start and end control points, or click near the start point
of an object.

Point settings, styles, layers, point groups, and description keys can all affect how a point is created or how
it is displayed in the drawing. For more information, see Before You Create Points (page 457).
To place a number of interpolated points
1 Select settings and create styles, layers, point groups, and description keys. For more information, see
Before You Create Points (page 457).
2 Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Create Points - Interpolate ➤ Number By
Distance

.

3 Specify the interpolation region by doing one of the following:
■

Pick a point in the drawing and enter an elevation for the first point. Specify the second point and
then either enter D to specify the difference in elevation between the two points, or enter S to specify
the slope from the first point to the second point.

■

Use Transparent commands to specify the point.

■

Enter E, and select an arc, line, feature line, lot line, or polyline. Enter the number of points and
then specify the offset distance by either entering the distance, picking a point, or using Transparent
commands.

4 Enter a description, or press Enter to skip the description.
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Quick Reference
Ribbon
Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Create Points - Interpolate ➤ Number By Distance

Menu
Points menu ➤ Create Points - Interpolate ➤ Number By Distance
Toolspace Shortcut Menu
Prospector tab: right-click Points collection ➤ Create
Command Line
CreatePointNumByDist
Dialog Box
Create Points (page 2357)

Creating Points Perpendicular
Interpolates a point along a control line or entity that is perpendicular to a specified point.
Create an interpolated point that is perpendicular along a line by selecting an object (1) that has two control
points (2) and (3).

Point settings, styles, layers, point groups, and description keys can all affect how a point is created or how
it is displayed in the drawing. For more information, see Before You Create Points (page 457).
To create points perpendicular from selected points
1 Select settings and create styles, layers, point groups, and description keys. For more information, see
Before You Create Points (page 457).
2 Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Create Points - Interpolate ➤ Perpendicular
.
3 Specify the interpolation region by doing one of the following:
■

Pick a point in the drawing and enter an elevation for the first point. Specify the second point and
then either enter D to specify the difference in elevation between the two points, or enter S to specify
the slope from the first point to the second point.

■

Use Transparent commands to specify the point.
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■

Enter E, and select an arc, line, feature line, lot line, or polyline. Specify the location for the
perpendicular point, and then specify the offset distance by either entering the distance, picking a
point, or using Transparent commands.

4 Enter a description, or press Enter to skip the description.

Quick Reference
Ribbon
Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Create Points - Interpolate ➤ Perpendicular
Menu
Points menu ➤ Create Points - Interpolate ➤ Perpendicular
Toolspace Shortcut Menu
Prospector tab: right-click Points collection ➤ Create
Command Line
CreatePtInterpPerpendic
Dialog Box
Create Points (page 2357)

Creating Points at an Incremental Distance
Interpolates points that are a specified distance apart.
Define the interpolation region by specifying the start and end control points, or click near the start point
of an object.
To create points at an incremental distance
1 Select settings and create styles, layers, point groups, and description keys. For more information, see
Before You Create Points (page 457).
2 Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Create Points - Interpolate ➤ Incremental
Distance

.

3 Specify the interpolation region by doing one of the following:
■

Pick a point in the drawing and enter an elevation for the first point. Specify the second point and
then either enter D to specify the difference in elevation between the two points, or enter S to specify
the slope from the first point to the second point.

■

Use Transparent commands to specify the point.

■

Enter E, and select an arc, line, feature line, lot line, or polyline. Specify the distance between points,
and then specify the offset distance by either entering the distance, picking a point, or using
Transparent commands.

4 Enter a description, or press Enter to skip the description.
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Quick Reference
Ribbon
Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Create Points - Interpolate ➤ Incremental Distance

Menu
Points menu ➤ Create Points - Interpolate ➤ Incremental Distance
Toolspace Shortcut Menu
Prospector tab: right-click Points collection ➤ Create
Command Line
CreatePtIncrementalDist
Dialog Box
Create Points (page 2357)

Creating Points at an Incremental Elevation
Interpolates points at a specified elevation increment along a control line or entity.
Define the interpolation region by specifying the start and end control points, or click near the start point
of an object.

Point settings, styles, layers, point groups, and description keys can all affect how a point is created or how
it is displayed in the drawing. For more information, see Before You Create Points (page 457).
To create points at an incremental elevation
1 Select settings and create styles, layers, point groups, and description keys. For more information, see
Before You Create Points (page 457).
2 Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Create Points - Interpolate ➤ Incremental
Elevation

.

3 Specify the interpolation region by doing one of the following:
■

Pick a point in the drawing and enter an elevation for the first point. Specify the second point and
then either enter D to specify the difference in elevation between the two points, or enter S to specify
the slope from the first point to the second point.

■

Use Transparent commands to specify the point.
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■

Enter E, and select an arc, line, feature line, lot line, or polyline. Specify the elevation difference
between points, and then specify the offset distance by either entering the distance, picking a point,
or using Transparent commands.

4 Enter a description, or press Enter to skip the description.

Quick Reference
Ribbon
Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Create Points - Interpolate ➤ Incremental Elevation

Menu
Points menu ➤ Create Points - Interpolate ➤ Incremental Elevation
Toolspace Shortcut Menu
Prospector tab: right-click Points collection ➤ Create
Command Line
CreatePtIncrmntlElev
Dialog Box
Create Points (page 2357)

Creating Points at Intersections
Interpolates points where two entities intersect, or would intersect if extended.
Define the interpolation region by specifying the start and end control points, or click near the start point
of an object.

Point settings, styles, layers, point groups, and description keys can all affect how a point is created or how
it is displayed in the drawing. For more information, see Before You Create Points (page 457).
To create points at object intersections
1 Select settings and create styles, layers, point groups, and description keys. For more information, see
Before You Create Points (page 457).
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2 Click Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Create Points - Interpolate ➤ Intersection
.
3 Specify the interpolation region for the first intersection by doing one of the following:
■

Pick a point in the drawing and enter an elevation for the first point. Specify the second point and
then either enter D to specify the difference in elevation between the two points, or enter S to specify
the slope from the first point to the second point.

■

Use Transparent commands to specify the point.

■

Enter E, and select an arc, line, feature line, lot line, or polyline. Specify the offset distance by either
entering the distance, picking a point, or using Transparent commands.

4 Repeat step 4 to specify the second interpolation region.
5 In the drawing, an X marks each intersection point. If only one intersection is located then the point
is automatically created.
6 Specify the intersection point by doing one of the following:
■

Click near the X on which you want to create the point.

■

Enter A to place points at both intersections.

7 Enter a description, or press Enter to skip the description.

Quick Reference
Ribbon
Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Create Points - Interpolate ➤ Intersection
Menu
Points menu ➤ Create Points - Interpolate ➤ Intersection
Toolspace Shortcut Menu
Prospector tab: right-click Points collection ➤ Create
Command Line
CreatePtInterpolIntersec
Dialog Box
Create Points (page 2357)

Creating Points Based on Slope
Use the icons in the Slope list to access commands that you can use to create points based on slope and
grade intersections, elevations, and distances.
Point settings, styles, layers, point groups, and description keys can all affect how a point is created or how
it is displayed in the drawing. For more information, see Before You Create Points (page 457).

Creating Points at Grade or Slope Intersections
Creates a point where two slopes or grades intersect.
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Select a start and end point; specify the grade or slope ahead from the start point and back from the end
point.
Creates a high or a low point between two existing point objects.
To create a point where two slopes or grades intersect
1 Select settings and create styles, layers, point groups, and description keys. For more information, see
Before You Create Points (page 457).
2 Click Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Create Points - Slope ➤ High/Low Point
.
3 Specify the start point by doing one of the following:
■

Pick a point in the drawing.

■

Use Transparent commands to specify the point.

4 Specify the second point by doing one of the following:
■

Pick a point in the drawing.

■

Use Transparent commands to specify the point.

5 Specify the slope from the first point to the second point by doing one of the following:
■

Enter a slope value.

■

Enter G, and then enter a grade value, or enter S and then enter a slope value.

An X displays to indicate the location of the calculated slope/grade intersection.
6 Enter Yes to accept the calculated slope/grade intersection.
7 Enter a description, or press Enter to skip the description.

Quick Reference
Ribbon
Click Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Create Points - Slope ➤ High/Low Point

Menu
Click Points menu ➤ Create Points - Slope ➤ High/Low Point.
Toolspace Shortcut Menu
Prospector tab: right-click Points collection ➤ Create
Command Line
CreatePointHighLowPoint
Dialog Box
Create Points (page 2357)
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Creating Points by Slope/Grade - Distance
Creates a specified number of points from an existing point object based on the slope or grade to a given
direction and distance.
Specify start point, elevation, direction, slope or grade, distance, and number of intermediate points. Offset
and end point are optional.
Point settings, styles, layers, point groups, and description keys can all affect how a point is created or how
it is displayed in the drawing. For more information, see Before You Create Points (page 457).
To create points at a given slope or grade for a specified distance
1 Select settings and create styles, layers, point groups, and description keys. For more information, see
Before You Create Points (page 457).
2 Click Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Create Points - Slope ➤ Slope/Grade Distance

.

3 Specify the start point by doing one of the following:
■

Pick a point in the drawing.

■

Use Transparent commands to specify the point.

4 Specify the direction and distance by doing one of the following:
■

Pick a point in the drawing.

■

Use Transparent commands to specify the point.

5 Specify the slope from the first point by doing one of the following:
■

Enter a slope value.

■

Enter G, and then enter a grade value, or enter S and then enter a slope value.

6 Specify the distance along the slope/grade by doing one of the following:
■

Pick a point in the drawing.

■

Use Transparent commands to specify the point.

7 Specify the number of intermediate points from the start along the specified direction and distance.
8 Enter Yes to add the ending point.
9 Enter a description, or press Enter to skip the description.
NOTE Many factors affect how the point is displayed. For more information, see Controlling the Appearance of
Points in a Drawing (page 454).

Quick Reference
Ribbon
Click Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Create Points - Slope ➤ Slope/Grade Distance
Menu
Click Points menu ➤ Create Points - Slope ➤ Slope/Grade - Distance
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Toolspace Shortcut Menu
Prospector tab: right-click Points collection ➤ Create
Command Line
CreatePointSlopeGradeDist
Dialog Box
Create Points (page 2357)

Creating Points by Slope/Grade - Elevation
Creates a specified number of points from an existing point object based on the slope or grade to a given
direction and elevation.
Specify start point, elevation, direction, slope or grade, target elevation, and number of intermediate points.
Offset and end point are optional.
For example, you can specify a grade and an ending elevation, and then create points along the distance it
takes to achieve the final elevation.
Point settings, styles, layers, point groups, and description keys can all affect how a point is created or how
it is displayed in the drawing. For more information, see Before You Create Points (page 457).
To create points at a given slope or grade based on an ending elevation
1 Select settings and create styles, layers, point groups, and description keys. For more information, see
Before You Create Points (page 457).
2 Click Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Create Points - Slope ➤ Slope/Grade Elevation

.

3 Specify the start point by doing one of the following:
■

Pick a point in the drawing.

■

Use Transparent commands to specify the point.

4 Specify the direction and distance by doing one of the following:
■

Pick a point in the drawing.

■

Use Transparent commands to specify the point.

5 Specify the slope from the first point by doing one of the following:
■

Enter a slope value.

■

Enter G, and then enter a grade value, or enter S and then enter a slope value.

6 Specify the elevation along the slope/grade by doing one of the following:
■

Pick a point in the drawing.

■

Use Transparent commands to specify the point.

7 Specify the number of intermediate points from the start along the specified direction and distance.
8 Specify the offset distance by doing one of the following:
■

Enter a distance.

■

Pick a point in the drawing.
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■

Use Transparent commands to specify a point to define the offset.

9 Enter Yes to add the ending point.
10 Enter a description, or press Enter to skip the description.

Quick Reference
Ribbon
Click Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Create Points - Slope ➤ Slope/Grade Elevation
Menu
Click Points menu ➤ Create Points - Slope ➤ Slope/Grade - Elevation.
Toolspace Shortcut Menu
Prospector tab: right-click Points collection ➤ Create
Command Line
CreatePointSlopeGradeElev
Dialog Box
Create Points (page 2357)

Creating Points by Importing Point Data
Creates points by importing point data from a file.
Import point data from most ASCII (text) files or Microsoft® Access database (.mdb) files. For more information,
see Importing Point Data (page 533).

Creating Points Using the Civil Transparent Commands
Use the Civil transparent commands to create points.
You use the Civil transparent commands with the Create Points Manual command, which is included in
the Miscellaneous list in the Create Points dialog box.
Create the points using known information, such as angle and distance, bearing and distance, azimuth and
distance, and deflection angle and distance.
For more information about Civil transparent commands, see Transparent Commands (page 1767).
Point settings, styles, layers, point groups, and description keys can all affect how a point is created or how
it is displayed in the drawing. For more information, see Before You Create Points (page 457).
To create points using the Civil transparent commands
1 Select settings and create styles, layers, point groups, and description keys. For more information, see
Before You Create Points (page 457).
2 Click Home tab ➤ Create Ground Data panel ➤ Points Menu ➤ Create Points - Miscellaneous ➤ Manual
.
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3 Do one of the following:
■

Enter a transparent command at the command line.

■

Select a transparent command from the Transparent Command toolbar.

For more information, see Transparent Commands (page 1767).
4 Follow the transparent command prompts to place the point.
5 If prompted, enter the point name, description, and elevation.
6 Do one of the following:
■

Continue to enter points within the transparent command.

■

Press Esc to end the transparent command and return to the Create Points Manual command.

NOTE Many factors affect how the point is displayed. For more information, see Controlling the Appearance of
Points in a Drawing (page 454).

Editing Points
You can edit individual drawing points graphically (in the drawing), or you can use the Point Editor.
Change the properties of multiple drawing points using utilities that perform batch operations, such as
renumbering or changing elevation.
You cannot edit project points directly. To edit project points, you must check the points out to a drawing,
modify them, and then check them back in to the project. For a procedure for changing large numbers of
project points, see Modifying A Large Number of Project Points (page 523).
For more information about working with project and drawing points, see Managing Points (page 453).

Editing Points in a Drawing
Use AutoCAD commands to move, rotate, copy, or erase a point in a drawing.
For a complete list of the AutoCAD commands that are supported for editing points and other AutoCAD
Civil 3D objects, see AutoCAD Commands and AutoCAD Civil 3D Objects (page 1939).
When a drawing point is locked, you cannot use any command that modifies its XYZ values, including the
AutoCAD Erase command.

Rotating Point Labels Using Grips
Use grips to rotate point labels in a drawing.
In the drawing, select a point label and click

to rotate the point label.

Editing Points Using the Point Editor
Use the Point Editor to modify the properties of drawing points.
Each row in the Point Editor Vista displays the properties for a single point. To edit, click a cell and enter
new values.
For more information about working with a vista, including keeping the window active, but hidden when
you are not using it, see The Panorama Window (page 119).
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The Point Editor displays point information arranged in a grid. Display and hide the columns in the Point
Editor the same way you display and hide the columns in a list view. For more information, see Customizing
a List View (page 101).
For a complete description of each column in the Point Editor, see Point Editor (page 2370).
Edit drawing points either in the Point Editor or from the Points list view in Prospector. The Point Editor,
because it is a separate window, provides more viewing area and greater flexibility in use of screen space.
To view project points in the project Points collection, use the Prospector list view. You cannot edit project
points using the list view. To edit project points, you must check the points out to the drawing, modify
them, and then check them back in to the project. For more information, see Managing Points (page 453).

Listing Points in the Point Editor
Use the Prospector shortcut menus or the List Points command to open the Point Editor.
The points that are displayed when you open the Point Editor are determined by the item or items that are
selected before you display the shortcut menu. You can edit either all the points in a drawing, all the points
in a point group, or selected points in a list view or drawing.
Each row in the Point Editor Vista displays the properties for a single point. To edit, click a cell and enter
new values.
To open the Point Editor
1 In Toolspace, on the Prospector tab, do one of the following:
■

To include all the points in a drawing in the Point Editor, right-click the Points collection ➤ Edit
Points or click Points menu ➤ List Points.

■

To include all the points in a point group in the Point Editor, right-click the point group.

■

To include selected points, click the Points collection. Select the points in the list view and right-click.

■

To include selected points in a drawing, select the points and right-click.

2 Click Edit Points on the shortcut menu.
The Point Editor is opened. If you cannot see the Point Editor, click
to display the Panorama window.

at the top of the Prospector tab

3 Use the Point Editor (page 2370) to edit or view the points.

Quick Reference
Ribbon
Click COGO Point tab ➤ Modify panel ➤ Edit/List Points
Menu
Click Points menu ➤ Edit Points ➤ Points.
Toolspace Shortcut Menu
Prospector tab: right-click Points collection ➤ Edit Points
OR
Prospector tab: Points collection ➤ right-click points in List View ➤ Edit Points
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Object Shortcut menu
Edit Points
Dialog Box
Point Editor (page 2370)

The Point Editor Shortcut Menu
Use a shortcut menu to access commands from within the Point Editor.
To display the shortcut menu, select at least one point and right-click. The commands that are available on
the shortcut menu depend on whether you selected drawing or local copies of project points in the drawing,
and on the state of the selected points with respect to the drawing or project.
Use the Point Editor shortcut menu to:
■

Renumber selected points. (page 523)

■

Change the elevation of the selected points. (page 521)

■

Changing the elevations of points based on a surface. (page 522)

■

Delete the selected points. (page 519)

■

Zoom or pan the drawing to the selected points. (page 456)

■

Lock or unlock the selected points. (page 453)

For information about the access control items on the menu, see Working with Vault Project Points (page
187).

Deleting Points Using the Point Editor
Use the Point Editor shortcut menu to delete drawing points from within the Point Editor.
If a deleted point is referenced by a surface, the surface will be either automatically rebuilt or be marked as
out-of-date, depending on the surfaceRebuild - Automatic setting.
To delete points using the Point Editor
1 Open the Point Editor so that it lists the point you want to delete. For more information, see Listing
Points in the Point Editor (page 518).
2 Right-click the row containing the desired point. Click Delete.
You cannot delete a locked point.
NOTE You can also use the AutoCAD ERASE command to delete a point.

Quick Reference
Toolspace Shortcut Menu
Prospector tab: Points collection ➤ right-click points in List View ➤ Delete
Object Shortcut Menu
Erase
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Editing Points Using the Object Properties Window
Use the AutoCAD properties window to change individual COGO point properties such as layer, point style,
and point label style.
To change individual point properties
1 Select a point in the drawing, right-click ➤ Properties.
2 On the Design tab expand the AutoCAD Civil 3D section to display the point properties for Display,
Information, Coordinate, and Labeling.
3 To change a property, click in the cell and enter a new value or select a value from the list.

AutoCAD Civil 3D Point Properties in the Object Properties Manager
The following AutoCAD Civil 3D point properties are displayed in the AutoCAD Properties dialog box:
Display
Point Style

Modify the style for the point object. If the
point object does not have an assigned
style <default> is displayed, indicating the
point group label style is being used to
draw the point label.

XY Scale

Modify the XY scale factor for the point
object. PROPERTY NOT SET indicates this
property is set to a null value.

Z Scale

Modify the Z scale factor for the point object. PROPERTY NOT SET indicates this
property is set to a null value.

Rotation

Modify the point object rotation.PROPERTY
NOT SET indicates this property is set to a
null value.

Information
Point Number

Modify the point number for the point
object.

Name

Modify the point name for the point object.

Raw Description

Modify the raw description for the point
object. PROPERTY NOT SET indicates this
property is set to a null value.

Full Description

Displays the full description for the point
object which is derived from the Description Format Property. This is a read only
value.
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Description Format

Modify the description format for the point
object. PROPERTY NOT SET indicates this
property is set to a null value.

Survey Point

Displays the read only value of the survey
flag for the point object. A True value indicates the COGO point was created using
AutoCAD Civil 3D Survey features.

Coordinate
Easting

Modify the Easting value for the point object.

Northing

Modify the Northing value for the point
object.

Point Elevation

Modify the Easting value for the point object.

Labeling
Point Label Style

Modify the style for the point object label
style. If the point object does not have an
assigned style <default> is displayed, indicating the point group label style is being
used to draw the point label.

Label Is Pinned

Specify True to pin the point label.

Visibility

Specify True to have the point object label
displayed.

Editing Points Using Point Editing Utilities
Use the point editing utilities to change multiple drawing points using a single command.
You cannot use the point editing utilities to edit project points directly. To edit project points, you must
check the points out to a drawing, modify them, and then check them back in to the project. For information
about a recommended procedure for checking out and changing a large number of project points, see
Modifying A Large Number of Project Points (page 523).

Changing the Elevations of Points
Use the Datum command to change the elevations of selected drawing points.
Updates points that were set, according to an assumed elevation, to a benchmark elevation. If a point has
no elevation value, its elevation is not adjusted.
NOTE Use the Point Editor to edit point elevations individually.
To change the elevation of points
1 In Toolspace, on the Prospector tab, click the Points collection to display the Points list view.
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2 In the list view, select the desired points. For more information, see Selecting Items in a List View (page
100).
3 Right-click and click Datum.
4 In response to the prompt, specify a change in elevation by doing one of the following:
■

Enter a change in elevation. To specify a decrease in the elevation, use a minus sign (-) before the
value.

■

Enter R, for reference, then enter the old and new datum elevations. The points will be modified by
the differences between the two values.

Quick Reference
Ribbon
Click COGO Point tab ➤ Modify panel ➤ Datum
Menu
Click Points menu ➤ Edit Points ➤ Datum
Toolspace Shortcut Menu
Prospector tab: Points collection ➤ right-click points in List View ➤ Datum

Changing the Elevations of Points Based on a Surface
Change the elevations of a point, point group, or a selection of drawing points based on the elevations in
a selected surface.
The elevations of the selected points is based on their location on the surface.
To change the elevation of points based on a surface
1 In Toolspace, on the Prospector tab, click the Points collection to display the Points list view, or right-click
a Points collection and select Edit Points to display the Point Editor.
2 Do one of the following to display the Select Surface dialog box:
■

Select the points to edit in the list view or the Point Editor and right-click ➤ Elevations From
Surface.
or

■

Click COGO Point tab ➤ Modify panel ➤ Elevations From Surface

.

3 Select a surface from the list and click OK. If you selected the command from the list view or the Point
Editor, the Point Elevation column reflects the elevation from the surface. If you selected the command
from the Points menu, you are prompted at the command line to select one of the following:
■

All: to select all points in the current drawing to move elevations to the selected surface.

■

Numbers: prompts the user to specify a range of numbers.

■

Group: displays the Point Groups dialog box where you can select a point group.

■

Selection: prompts the user to select points in the drawing.
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Quick Reference
Ribbon
Click COGO Point tab ➤ Modify panel ➤ Elevations From Surface
Menu
Click Points menu ➤ Edit Points ➤ Elevations From Surface
Toolspace Shortcut Menu
Prospector tab: Points collection ➤ right-click points in List View ➤ Elevations From Surface

Renumbering Points
Use the Renumber command to assign new point numbers to selected drawing points.
This command adds an integer value to the point number of each selected point.
You may be prompted to resolve any numbering conflicts that arise when the renumbering occurs.
To renumber project points, check the points out of the project into a drawing, renumber them using the
Renumber command, and then check them back in to the project.
To renumber points
1 In Toolspace, on the Prospector tab, click the Points collection to display the Points list view.
2 In the list view, select the desired points. For more information, see Selecting Items in a List View (page
100).
3 Right-click and click Renumber.
4 Enter the value to be added to the point number of the selected points.

Quick Reference
Ribbon
Click COGO Point tab ➤ Modify panel ➤ Renumber
Menu
Click Points menu ➤ Edit Points ➤ Renumber
Toolspace Shortcut Menu
Prospector tab: Points collection ➤ right-click points in List View ➤ Renumber
Command Line
SelectAndEditPointNumbers

Modifying A Large Number of Project Points
Use the procedure described in this topic to make a change, such as an elevation adjustment or a change to
all eastings or northings, to a large number of points in a project.
To change one or more project points, you must check the points out to a drawing, change the points, and
check the points back in to the project. When you are working with a large number of project points and
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do not need to view the points in the drawing while you change them, you can speed up the process by not
drawing the point symbols or point labels while the points are in the drawing.
Avoid drawing point labels and point symbols using point label styles and a point group override. The
procedure described in this topic suggests using a throw-away drawing for this process, and instructs you to
edit the Standard point style and the _All Points point group in the throw-away drawing. If you do not want
to use a throw-away drawing, you can modify the procedure to create a point group and a point style you
can use for working with large numbers of points.
Before beginning this procedure, you should understand how to work with project and drawing points. For
more information, see Working with Vault Project Points (page 187).
To modify a large number of project points
1 Create a new, empty drawing.
2 In Toolspace, on the Settings tab, under the Point Styles collection, right-click the Standard ➤ Edit.
3 On the Display tab, to turn off the display of point symbols, click in the Visible column for Marker so
that the light bulb icon is not available.
4 To turn off the display of point labels, click in the Visible column for Label so that the light bulb icon
is not available.
5 Click OK.
6 In Toolspace, on the Prospector tab, under the Point Groups collection, right-click the _All Points ➤
Properties.
7 In the Point Group Properties dialog box, on the Overrides tab (page 2353), in the Overrides column,
select the Standard point style. In the Properties column, select the check box next to Point Style.
8 In the Overrides column, select the Standard point label style. In the Properties column, select the check
box next to Point Label Style.
9 Click OK.
10 If the drawing has more than one point group, move the _All Points point group to the top of the point
group display order. For more information, see Changing the Point Group Display Order (page 558).
11 Check out the project points to the drawing.
NOTE To quickly check out all the project points, right-click the _All Points point group in the drawing and
select Check Out Points.
12 In the drawing, edit the points using either a point utility, the Point Editor, or the Prospector Points
list view.
NOTE For information about changing a point property such as elevation to the same value for every point
in the Point Editor or the Points list view, see Changing the Contents of a Column in a List View (page 102).
13 Check the points in to the project. Do not keep them checked out to the drawing.
NOTE To quickly select all the points in the drawing for checking in, right-click the _All Points point group
and select Check In Points.
14 Delete the throw-away drawing.
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Importing and Exporting Points
You can use commands to import point data, export point data, and transfer point data between files.
Using AutoCAD Civil 3D, you can:
■

Import points into a drawing from either an ASCII (text) file or a Microsoft® Access database (.mdb) file.

■

Export points from a drawing to either an ASCII (text) file or a Microsoft® Access database file.

■

Transfer points from an ASCII (text) file or a Microsoft® Access database file to another file. You can
convert the point data during the transfer, which can include changing the coordinate zone.

Importing points is a quick way to place points into a drawing. For example, if a surveyor collects point data
using a data collector, the data can be downloaded from the collector as an ASCII (text) file and then imported
into an AutoCAD Civil 3D drawing.
Before you can import, export, or transfer point data, you must specify a point file format for each file that
point data is read from or written to. The point file format describes how the point data is stored in the file.
You can use the point file formats that are supplied with AutoCAD Civil 3D or create your own formats.

Understanding Point File Formats
Use a point file format to describe how point data is arranged in a file when you import, transfer, or export
points.
A point file format does not contain point data; it describes the layout of a point data file, which is a file that
contains point data.

Using Point File Formats
When you import, export, or transfer point data, you must specify a point file format for each point data
file that is read or written to. When you import points from a point data file, you specify a point file format
that describes how the point data is arranged in the file that is being imported. When you export point data
to a file, you specify a point file format that describes how the point data is written to the exported file.
When you transfer point data from one file to another, you specify two formats, one that describes how the
data is arranged in the source file and one that describes how the data is written to the destination file.

Converting Point Data During Import or Export
A point file format can contain information that specifies the coordinate zone that was used to create the
point data in the associated point data file. Use the coordinate zone information to convert point data as it
is imported, exported, or transferred.
A point file format can indicate that the associated point data file contains values that can be used to adjust
the elevations contained within the file. The specified values can be added to or subtracted from point
elevations when you import point data.

Point File Format Types
There are two types of point file formats:
■

User Point File Format. This point file format type describes how the point data is arranged in an ASCII
(text) file.

■

User Point Database Format. This point file format type describes how point data is arranged in a
Microsoft® Access database file.

Use the point file formats that are supplied with AutoCAD Civil 3D or create your own formats. The point
file formats available in a drawing are listed in the Toolspace Settings tree.
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Point File Formats Collection (Settings Tab)
Use the Point File Formats collection in the Settings tree to create and manage point file formats.
In the Settings tree, expand the Point collection and then expand the Point File Formats collection to list
the point file formats available in the drawing.
Right-click the Point File Formats collection to:
■

Create a new point file format (page 529).

■

Refresh the Settings tree.

Right-click a point file format name to:
■

Change the properties of the point file format. (page 526)

■

Make a copy of the point file format. (page 531)

■

Delete the point file format. (page 532)

■

Refresh the Settings tree.

You can also list available point file formats by clicking the Point File Formats collection to display a list
view. For more information, see The Toolspace Item View (page 99).

Point File Format Properties
Use a dialog box to view or change the properties of a point file format.
The properties of a point file format include:
■

format file name

■

default point data file extension

■

comment tag

■

transformation information

■

column names that describe the layout of the point data in the associated point data file

■

file formatting options (point file format only)

The dialog box you use to view and change the properties of a point file format depends on whether the
format is a user point file format or a user point database format. For more information about the dialog
box used to view and change the properties of a point file format, see Point File Format Dialog Box (page
2360). For more information about the dialog box used to view and change the properties of a user point
database format, see User Point Database Format Dialog Box (page 2361).
For information about creating a new point file format, see Creating Point File Formats (page 529).

Point File Format Coordinate Zone Transformation Property
Use the coordinate zone transformation property in a point file format to specify the coordinate zone in
which the data in the associated point data file was created.
When you import or export a point data file, coordinate zone information is included in the point file
format, not the point data file. Use this information to transform points from one coordinate zone to another
while importing or exporting.
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For example, to import an ASCII (text) file that was created in an NAD27 zone when the zone of the current
drawing is NAD83, specify the NAD27 zone in the point file format. Then, when you import the points, you
can select an option that converts the points to the drawing zone, NAD83.

Point File Format Column Name Property
Use column names in a point file format to specify which point information is included in a point data file.
When creating a new point file format, you are presented with a list of unused columns:

Specify the contents of the first column in the point data file by clicking the first column heading and
specifying a point property, for example, Easting, in the Point File Formats - Select Column Name dialog
box. The first column heading is updated to reflect the specified column name:

Specify the contents of the second column in the point data file by clicking the second column heading in
the dialog box and specifying another point property, for example, Northing:

Continue to specify column headings until the point file format column names reflect the layout of the
point data file.
Some point file format columns can be used to perform calculations when they are included in the format.
For more information, see Using Point File Format Properties to Perform Calculations (page 528).

Point File Formatting Options
In a point file format, use formatting options to specify whether the associated point data file is arranged
in columns or delimited by a specified character.
Choose either Columnated or Delimited By to specify how point data is stored in a point data file.

Columnated
Use the Columnated option to separate values in the point data file by tabs. When you import the file, the
data in the file is assumed to be arranged in columns and rows. Each row contains the data for a single point,
and the individual values in the row are separated by tabs. When you export points or transfer data, the
values in the resulting file are arranged in columns and separated by tabs, with one point per row.
For example, if your format column names are Number, Northing, Easting, and Elevation, the contents of
your point data file might appear as follows:
1002

5000.00

2010.00

100.00
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1003

5001.00

2020.00

100.00

1004

5002.00

2030.00

100.00

Delimited
The Delimited By option separates the values in the point data file by a delimiter, such as a comma or a
space. When you import the file, each row in the file is assumed to contain data for a single point, with the
individual values separated by the specified delimiter. When you export points or transfer data, the values
in the resulting file are written to the file, one point per row, with the individual values separated by the
specified delimiter.
For example, if your format column names are Number, Raw Description, Northing, Easting, and Elevation,
and you specified a comma (,) for a delimiter, the contents of your point data file might appear as follows:
101,MONA,300,500,0
102,MONB,302,499,0
103,MONA,303,501,0

Using Point File Format Properties to Perform Calculations
Use some columns in a point file format to perform calculations, such as adjusting the elevation values.

Adjusting Elevation During Import and Transfer
During point import, use some format column names to adjust point elevation values during point import.
Use the following columns:
■

Thickness: Include this column name in the format if your data includes surface thickness values, such
as the thickness of a layer of topsoil or clay. The value in the Thickness column can be subtracted from
the value in the Elevation column when points are imported or transferred.

■

Z+: Include this column name in the format to define a column for point data that was taken at a height
above the datum elevation. The value in the Z+ column can be added to the value in the Elevation
column when the points are imported or transferred.

■

Z-: Include this column name to adjust the elevation of a point in a file. The value in the Z- column for
a point can be subtracted from the value in the Elevation column when the points are imported or
transferred.

The values specified for Thickness, Z+, or Z- in the point data file are not automatically used to adjust the
elevation during import or export. Select the Do Elevation Adjustment If Possible option when importing
points when you want elevation adjustments to occur.

Calculating Convergence Angles During Export
Include the Convergence column in a point file format that is used for exporting points.
Use the Convergence column name to define a point file format column containing a calculated convergence
angle. In state plane coordinate systems, the convergence angle is the difference between a geodetic azimuth
and the projection of that azimuth onto a grid (grid azimuth) of a given point.
Use this column only when you export point data. To export points using a format containing a convergence
angle, you must have set a zone in the file format and drawing, and you must turn on transformation settings
for the drawing.
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Calculating Scale Factors During Export
Include the Scale Factor column in a point file format that is used for exporting points.
Use the Scale Factor column name to define a point file format column containing a calculated convergence
angle. Scale factor is the value used to reduce or increase a local (geodetic) distance so that it equals the grid
distance.
Use this column only when you export point data. To export points using a format containing a scale factor,
you must have set a zone in the file format and drawing, and you must turn on the transformation settings
for the drawing.
Export the scale factor by using the method specified in the transformation settings, such as Prismoidal or
Unity.

Managing Point File Formats
Use the Settings tree to manage point file formats. You can share a point file format and print a list of the
point file formats in a drawing.

Sharing Point File Formats
Use the Settings tree to list the point file formats for a drawing.
Point file formats are associated with a drawing. If more than one person will need to use a point file format,
you can create it in a drawing template. For more information, see Drawing Templates (page 127).

Printing Point File Formats
Use the Copy To Clipboard command to copy the list of the point file formats in a drawing to another
application for printing.
To print a list of the point file formats in a drawing, click the Point File Formats collection in the Settings
tree to display a list view containing the point file formats in the drawing. Right-click the list view and click
Copy To Clipboard to copy the list view into a file you can print. For information, see Copying Items from
a List View (page 103).

Creating Point File Formats
Create two types of point file formats: a user point file format and a user point database format.
A point file format does not contain point data; it describes the way point data is stored in a point data file.
When you create a point file format, regardless of whether it is a user point file format or a user point database
format, you can specify the following properties:
■

A format name, which is displayed in the Settings tree.

■

A series of column names that describe both the point information stored in the point data file and the
order in which the point information is stored.

■

The coordinate zone in which the point data was created. This information is optional, but if you include
it, you can automatically perform a coordinate transformation of the point data if you import it into a
drawing that uses a different coordinate zone, or if you transfer the points from one file to another.
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Creating a User Point File Format
Create a user point file format for importing or exporting ASCII files that contain point data.
When you create a user point file format, you specify the information that is included in the point data file,
the layout of the information in the file, and the character that is used to separate the individual pieces of
information, such as a comma or a space. For more information, see Point File Format Properties (page 526).
As you create a user point file format, you can view the file that contains your point data for reference.
NOTE If you are importing point data from and ASCII file that contains user defined columns, you must create a
user defined classification for each column. For more information, see Importing Point Data from an ASCII File
Containing User Defined Columns.
To create a user point file format
1 In Toolspace, on the Settings tab, right-click the Point File Formats ➤ New.
2 In the Point File Formats - Select Format Type (page 2360) dialog box, click User Point File. Click OK.
3 In the Point File Format (page 2360) dialog box, specify a name and file extension for the format.
4 Click Load to load a point data file so that you can refer to it as you create the format.
NOTE At any time, you can click the Parse button and the loaded file is displayed in the dialog box using
the format you are building.
5 Optionally, specify a comment tag character and a coordinate zone transform.
6 Specify the format options for the file.
7 Click a column name heading that is labeled <unused>.
8 In the Point File Formats - Select Column Name (page 2362) dialog box, select a column name from the
Column Name list. Specify other parameters as needed, and click OK.
9 Repeat the previous step for each column in the point file format.
10 Click OK.

Quick Reference
Toolspace Shortcut Menu
Settings tab: right-click Point File Formats collection ➤ New
Command Line
CreatePointFormat
Dialog Box
Point File Format (page 2360)

Creating a User Point Database Format
Create a user point database format for importing or exporting .mdb files that contain point data.
When you create a user point database format, you specify both the information included in the .mdb file
and the order in which it is included. If the file has multiple tables, you specify the name of the table from
which you want to import data or to which you want to export data.
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As you create a point database format, you can view a sample point database for reference.
To create a user point database format
1 In Toolspace, on the Settings tab, right-click the Point File Formats ➤ New.
2 In the Point File Formats - Select Format Type (page 2360) dialog box, click User Point Database and click
OK.
3 In the User Point Database Format (page 2361) dialog box, specify a name for the format.
4 Click Load to load the Microsoft® Access file that you want the new format to match, so that you can
refer to it as you create the format.
5 Specify a table name if required.
6 Optionally, specify a coordinate zone transform.
7 Click a column name heading that is labeled <unused>.
8 In the Point File Formats - Select Column Name (page 2362) dialog box, select a column name from the
Column Name list. Specify other parameters as needed, and click OK.
9 Repeat the previous step for each column in the user point database format.
10 Click OK.

Quick Reference
Toolspace Shortcut Menu
Settings tab: right-click Point File Formats collection ➤ New
Command Line
CreatePointFormat
Dialog Box
User Point Database Format (page 2361)

Creating a Point File Format Based on an Existing Format
Creates a point file format based on an existing format by copying the format.
After you make a copy of a format, the format you created is automatically opened for editing.
To create a point file format based on an existing format
1 In Toolspace, on the Settings tab, expand the Point File Formats collection.
2 Right-click the point file format you want to copy. Click Copy.
3 Do one of the following:
■

If the format you copied was a user point file format, use the Point File Format (page 2360) dialog box
to change the format properties.

■

If the format you copied was a user point database format, use the User Point Database Format (page
2361) dialog box to change the format properties.
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Quick Reference
Toolspace Shortcut Menu
Settings tab: right-click Point File Formats item ➤ Copy

Editing Point File Formats
Use the Settings tree to access formats you want to change or delete.
You can change or delete point file formats that you create or most of the point file formats AutoCAD Civil
3D supplies. A point file format that cannot be changed or deleted has a
in the Prospector tree.

displayed to the left of its name

Changing a Point File Format
You can change any point file format that you create. You can also change most of the point file formats
that are supplied with AutoCAD Civil 3D.
A point file format cannot be changed if

is displayed to the left of its name in the Prospector tree.

To change a point file format
1 In Toolspace, on the Settings tab, expand the Point File Formats collection.
2 Right-click the desired point file format. Click Properties.
3 Do one of the following:
■

If the format is a point file format, use the Point File Format (page 2360) dialog box.

■

If the format is a user point database format, use the User Point Database Format (page 2361) dialog
box.

4 Click OK.

Quick Reference
Toolspace Shortcut Menu
Settings tab: right-click Point File Formats item ➤ Properties
Dialog Box
Point File Format (page 2360),
User Point Database Format (page 2361)

Deleting a Point File Format
Use the Settings tree to delete a point file format from a drawing.
If a point file format cannot be deleted,

is displayed to the left of its name in the Prospector tree.

To delete a point file format
1 In Toolspace, on the Settings tab, expand the Point File Formats collection.

532 | Chapter 15 Points

2 Right-click the desired point file format. Click Delete.
3 Click Yes to confirm.

Quick Reference
Toolspace Shortcut Menu
Settings tab: right-click Point File Formats item ➤ Delete

Importing Point Data
Import point data from an ASCII (text) file or a Microsoft® Access .mdb file into a drawing.
Importing points, such as survey point data collected by a data collector, is a quick and effective way to
place points into a drawing.
Before you import points, you must create a point file format that describes the layout of the point data in
the point data file.
IMPORTANT The highest point number allowed in Civil 3D is 4,294,967,295. You can use point names or User
Defined Properties to reference numbers greater than 4,294,967,295. For more information, see Using Custom
Properties with Points (page 445).
For more information, see Understanding Point File Formats (page 525) and Creating Point File Formats (page
529).
You can add the imported points to a point group, make adjustments to the data as it is imported, including
elevation adjustments, coordinate transformation, or coordinate data expansion, encounter how the imported
points are numbered as they are created.
To import point data
1 Specify the Point Identity settings, which control the point numbers of the created points. For more
information, see Editing the Point Identity Settings (page 442).
2 Click Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Point Creation Tools

.

3 On the Create Points (page 2357) toolbar, click the Import Points button.
4 In the Import Points (page 2364) dialog box, specify the point file format that describes the layout of the
data in the point data file you are importing.
5 In the Import Points (page 2364) dialog box, click

, and select the point data file you want to import.

NOTE To migrate points from Autodesk Land Desktop, select External Project Point Database as the format
type and select the Autodesk Land Desktop point database .mdb file as the source file.
6 Optionally, specify a point group to which the imported points are added.
7 Optionally, specify advanced options for elevation adjustment, coordinate transformation, or coordinate
data expansion.
8 Click OK to import the points.
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Quick Reference
Ribbon
Click Insert tab ➤ Import panel ➤ Points From File
Menu
Click Points menu ➤ Import/Export Points ➤ Import Points
Toolspace Shortcut Menu
Prospector tab: right-click Point collection ➤ Create ➤ Import Points
Command Line
ImportPoints
Dialog Box
Create Points (page 2357)

Importing Point Data from an ASCII File Containing User Defined Columns
Before you import point data from an ASCII (text) file that contains user-defined columns you must create
a User-Defined Property Classification.
To import point data from and ASCII file that contains user-defined columns
1 In Toolspace, on the Settings tab expand the Point collection ➤ right-click User-Defined Property
Classification ➤ New. For more information, see Creating a User-Defined Property Classification (page
446).
2 Right-click the classification that you created in the previous step and click New to create a new
user-defined property. For more information, see Creating a User-Defined Property (page 446).
3 In Toolspace, on the Settings tab expand the Points collection and click Point File Formats ➤ New.
4 Select User Point File in the Point File Formats - Select Format Type dialog box and click OK.
5 Create the new point file format. For more information, see Creating Point File Formats (page 529).
6 To specify the user-defined columns, click an <unused> column heading to display the Point File Formats
- Select Column Name dialog box.
7 In the Column list, select the user-defined property you created in step two.
8 On the Prospector tab click Points ➤ Create ➤ Import Points. Select the ASCII file you wish to import
and select the Point File Format you defined in step five.

Exporting Point Data
Export drawing points to an ASCII (text) file or a Microsoft® Access .mdb file.
Before you export points, you must create a point file format that describes the layout of the point data in
the point data file. By default, all points in the drawing are exported. To export only selected points, select
Limit To Points In Point Group.
A point file format describes how the point data is arranged in the file. For example, in a drawing, point
properties include point number, name, description, northing, easting, and elevation. If you want to export
only point number, description, and elevation, you must export points using a point file format that defines
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column names only for point number, description, and elevation. For more information, see Understanding
Point File Formats (page 525) and Creating Point File Formats (page 529).
In addition to exporting point properties, you can also export grid northing, grid easting, latitude, and
longitude if a coordinate zone and transformation settings are defined for the drawing.
You can perform a coordinate transformation on the points as you export them. To export the point data
so that it is written to the point data file using a different coordinate zone from the current drawing, specify
an option that performs a coordinate transformation of the point data as it is exported. To transform the
point data, your point file format must have a coordinate zone defined. For more information, see Point
File Format Coordinate Zone Transformation Property (page 526).
You can export either all the points in a drawing or you can export selected drawing points using a point
group.
To export point data
1 Create a point file format that describes the layout of the exported data file. For more information, see
Creating Point File Formats (page 529).
2 Do one of the following:
■

Click Output tab ➤ Export panel ➤ Export Points

■

In Toolspace, on the Prospector tab, expand the Point Groups collection. Right-click the point group
name ➤ Export Points to export only the points in a point group.

to export all the points in a drawing.

3 In the Export Points (page 2366) dialog box, in the Format list, select the point file format that describes
how you want the exported point data to be arranged in the point data file.
4 Click

to specify the file to which you want to export the data.

5 Optionally, specify advanced options.
6 Click OK to export the points.

Quick Reference
Ribbon
Click Output tab ➤ Export panel ➤ Export Points
Menu
Click Points menu ➤ Import/Export Points ➤ Export Points
Toolspace Shortcut Menu
Prospector tab: right-click Points collection ➤ Export
Command Line
ExportPoints
Dialog Box
Export Points (page 2366)
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Transferring and Converting Point Data
Use point file formats to transfer point data from one format to another and to convert the coordinate
system of a set of points.

Transferring Point Data Between Files
Use the Transfer Points utility to transfer point data from a source file to a destination file. Either file can
be an ASCII (text) file or a Microsoft® Access database file.
You must create two point file formats. The first file format describes the layout of the data in the source
file, which is the file the data is read from. The second file format describes the layout of the data in the
destination file, the file the data is written to.
For example, your source file point file format could indicate that the source point data file contains the
following point properties in this order: point number, elevation, northing, easting, and description. Your
destination file point file format could indicate that the destination file should contain the following point
properties in this order: northing, easting, elevation. In this example, when you transfer the data from the
source file to the destination file, the point number and description are not transferred, and the position of
the elevation value is changed.
When you transfer data between two files, the points that are transferred are not deleted from the source
file.
The point file format type must match the source or destination file type. For example, to transfer points
from a Microsoft Access database file to an ASCII (text) file, specify a user point database format that describes
the layout of the data in the Microsoft Access database (the source file) and a point file format that describes
the layout of data in the ASCII file (the destination file).
To transfer point data between files
1 Create point file formats for the files you want to transfer points between. For more information, see
Creating Point File Formats (page 529).
2 Click Output tab ➤ Export panel ➤ Transfer Points

.

3 In the Transfer Points (page 2367) dialog box, under Source, specify the format and file name, including
the path, for the Source file.
4 Under Destination, specify the format and file name, including the path, for the Destination file.
5 To create a new point file format or change an existing one, click Manage.
6 Optionally, specify advanced options.
7 Click OK to transfer the point data from the source file to the destination file.

Quick Reference
Ribbon
Output tab ➤ Export panel ➤ Transfer Points
Menu
Points menu ➤ Import/Export Points ➤ Transfer Points
Command Line
TransferPoints
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Dialog Box
Transfer Points (page 2367)

Converting Points to a Different Coordinate Zone
Use a combination of the Point Import, Transfer, and Export commands to convert points to a different
coordinate zone.
You convert the points by exporting them to a file, changing the current zone of the drawing, and importing
the points back into the drawing and overwriting the original point data.
To convert points to a different coordinate zone
1 Create a copy of the External Project Point Database format. For more information, see Creating a Point
File Format Based on an Existing Format (page 531).
2 Change the coordinate zone of the new format so that it matches the coordinate zone of the current
drawing. For more information, see Changing a Point File Format (page 532).
3 Export the points in the drawing using the new format. For more information, see Exporting Point Data
(page 534).
4 Change the current drawing coordinate zone to the zone you want the points to be converted to.
5 Import the points into the drawing. For more information, see Importing Point Data (page 533).

Using External Data References
AutoCAD Civil 3D creates and maintains a point database file that contains all the point information in the
project.
COGO points store the point number, name (optional), northing, easting, elevation, and description in
each drawing.
You can also reference your own customized databases and use them to do the following:
■

Substitute point elevation data when points are accessed through a point group.

■

Substitute point raw description data.

To link these custom point databases to AutoCAD Civil 3D, create External Data References (XDRefs). For
more information, see Creating an External Data Reference (page 539). An XDRef is a pointer to an entire
column of data in a custom Microsoft Access database. All of the database entries must have a point number.
Then, when you use an XDRef to get a value for a point, the point number is looked up in the custom
database, and the value from the specified column is used instead of the original point value that is stored
in the drawing.
XDRefs do not overwrite or alter the points in the drawing. Use the External Data Reference collection on
the Settings tree in Toolspace to create and manage XDRefs.
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External Data Reference Requirements
The custom databases that you can use for XDRefs must have the following features:
■

They must be Microsoft Access database files.

■

There must be a Long Integer field index column, which contains the point numbers, in each table in
the database that can be used as an XDREF.

■

Currently, only Integer, Long Integer, Single, Double, and Text type fields are supported.

■

Any number of Tables can be defined in this database, but any that are referenced by XDRefs must have
an index column defined.

■

Any number of additional Text or Number columns may also be defined in this database table. There
are no restrictions on the names and order of the columns after the index column.

■

XDRefs are stored on the Settings tab in Toolspace under the Point collection.

Creating an External Point Database with Microsoft Access
Use Microsoft Access to create custom point databases, and link these databases to AutoCAD Civil 3D by
using external data references (XDRefs).
You can modify the sample database located in c:\program files\AutoCAD Civil 3D\Sample\Civil 3D XDRef\
or create a new database.
To create an external point database
1 Start Microsoft Access.
2 Select Blank Database and click OK.
3 In the File New Database dialog box, use the Save In list to locate a folder for future use.
4 In the File Name box, enter a name for the database.
5 Click Create to display the Database dialog box.
6 On the Table tab, click New to open the New Table dialog box.
7 Select Design View.
8 Click OK to display the design view of the table.
9 In the first table cell in the Field Name column, enter a name for the Index Column.
10 In the first table cell in the Data Type column, select Number.
11 In the lower part of the dialog box, verify the following information:
■

Long Integer is the Field Size

■

Auto is the Decimal Places

12 In the Required field, select Yes.
13 In the Indexed field, select Yes (No Duplicates).
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14 Add any additional field names below the Index Column as needed for your point information, such
as DESC 1, DESC 2, ELEV 1, ELEV 2. There are no restrictions on the names and order of the columns
after Index Column.
15 In the first table cell in the Field Name column, enter the name of the Index Column.
16 In the first table cell in the Sort Order column, select either Ascending or Descending.
17 In the lower part of the dialog box, change the following settings:
■

Primary field must be Yes.

■

Unique field must be Yes.

■

Ignore Nulls field must be No.

18 From the View menu, choose Datasheet.
19 Click Yes to display the Save As dialog box.
20 Enter a name for the table and click OK.
21 In the Table dialog box, enter point information such as point numbers, elevations, and descriptions.
22 Click File menu ➤ Save.
23 Close Microsoft Access.

Creating an External Data Reference
External Data References (XDRefs) are associated with individual drawings. You can use XDRef’s to override
the raw description and elevation for a point.
To create an external data reference
1 On the Settings tab in Toolspace, expand the Points folder.
2 Right-click External Data References ➤ New.
3 Enter a name and description.
4 Optionally, if the database is password protected, enter the password to access the database.
5 Browse to the location of the external data file.
6 Select the Table type, Index Column, and Value Column.
7 Click OK. The new external data reference is listed in the External Data Reference folder under Points
in Toolspace.

Quick Reference
Toolspace Shortcut Menu
Settings tab: right-click External Data Reference collection ➤ New
Command Line
CreateXdref
Dialog Box
(page 2376)
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Changing the Properties of an External Data Reference
Edit an existing XDRef by changing its properties, such as the table and column in the Microsoft® Access
database that the XDRef points to.
To change the properties of an external data reference
1 On the Settings tab in Toolspace, expand the Points folder.
2 Right-click External Data References ➤ Properties.
3 Enter a new name and description.
4 Select new values for the Table type, Index Column, and Value Column.
5 Click OK.

Quick Reference
Toolspace Shortcut Menu
Settings tab: right-click External Data Reference collection ➤ Properties
Dialog Box
Create External Data Reference Dialog Box (page 2376)

Point Utilities
you can use these commands to view and zoom to points in the project, to draw project extents, as well as
to create BLOCKS from COGO points and to export points.

Quick View Project
Use this command for a quick graphic view of all the point objects in the drawing.
The drawing must be connected to a project for this command to work, but you do not need to have the
drawing checked out.
To view point objects in a drawing
■

Click Points menu ➤ Utilities ➤ Quick View Project.

Quick Reference
Menu
Points menu ➤ Utilities ➤ Quick View Project
Command Line
QuickViewProjectPoints

Draw Project Extents
Use this command to view the extents of points in the project.
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The drawing must be connected to a project for this command to work, but you do not need to have the
drawing checked out.
The program draws a rectangle outlining the project extents.
To draw the project extents
■

Click Points menu ➤ Utilities ➤ Draw Project Extents.

Quick Reference
Menu
Points menu ➤ Utilities ➤ Draw Project Extents
Command Line
ShowProjectPointExtents

Zoom to Project Extents
Use this command to zoom to the extents of the project.
The drawing must be connected to a project for this command to work, but you do not need to have the
drawing checked out.
To zoom to the project extents
■

Click Points menu ➤ Utilities ➤ Zoom to Project Extents.

Quick Reference
Menu
Points menu ➤ Utilities ➤ Zoom To Project Extents
Command Line
ZoomToProjectPointExtents

Listing Available Point Numbers
Use this command to list the unused point numbers in the current drawing.
Available point numbers and point number ranges are displayed at the command line.
To list available point numbers
■

Click COGO Points contextual tab ➤ COGO Point Tools ➤ List Available Point Numbers.

Quick Reference
Ribbon
COGO Points contextual tab ➤ COGO Point Tools ➤ List Available Point Numbers
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Command Line
ListAvailablePointNumbers

Converting Softdesk Point Blocks to AutoCAD Civil 3D Points
Convert Softdesk point blocks to AutoCAD Civil 3D points.
COGO points are created using elevations and raw description values contained within each Softdesk point
block reference. When the points are converted to COGO points, the full description and raw description
are the same.
To convert Softdesk point blocks to AutoCAD Civil 3D points
1 Select settings and create styles, layers, point groups, and description keys. For more information, see
Before You Create Points (page 457).
2 Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Replace Softdesk Point Blocks

.

3 Select the Softdesk point blocks to be converted. Press Enter.

Quick Reference
Ribbon
Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Replace Softdesk Point Blocks
Menu
Points menu ➤ Utilities ➤ Replace Softdesk Point Blocks
Command Line
CreatePtConvertSdskPts

Converting AutoCAD Points to AutoCAD Civil 3D Points
Convert AutoCAD point objects to AutoCAD Civil 3D points.
Each resulting COGO point acquires its elevation from the specified AutoCAD point.
To convert AutoCAD points to AutoCAD Civil 3D points
1 Select settings and create styles, layers, point groups, and description keys. For more information, see
Before You Create Points (page 457).
2 Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Convert AutoCAD Points

.

3 Select the AutoCAD points to be converted.
4 For each point, if prompted, enter the point name and description.
NOTE If you do not want to be prompted for a description for each point, in the Points Creation section of
the Edit Point Settings dialog box set the Prompt for Descriptions Property to None. You can also use this
procedure when you want to disable Prompt for Point Names and Prompt for Elevation.
5 Press Enter to end the command.
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Quick Reference
Ribbon
Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Convert AutoCAD Points
Menu
Points menu ➤ Utilities ➤ Convert From AutoCAD Points
Command Line
CreatePtConvertAdeskPts

Creating Blocks from COGO Points
Use this command to create an AutoCAD block for each AutoCAD Civil 3D point in a selection set.
The blocks can be used in backward migration to other AutoCAD programs, or to create objects that represent
the spatial location of specified civil points in the active drawing.
To create blocks from COGO points
1 Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Create Blocks From COGO Points

.

2 Specify a Spatial Filter.
3 Under Selected Point Groups, click

and specify the point groups you want included in the block.

NOTE You can select the points to include in the block using both the Spatial Filter and Point Group options.
For example, under Spatial Filter you could select the Current Display and under Point Groups you could also
include a specified point group.
4 In the Block Output section, under Block Creation, click either Use Existing Block or Make New Block.
If you select Make New Block, enter a name.
NOTE The option Use Existing Block is only available if the block contains at least three attribute definitions
with the exact names ELEV, POINT, and DESC. If there are no blocks in the drawing with these exact attribute
definitions, this option is not available. Then you must use the Make New Block option.
5 Under Block Layer, specify the layer on which you want to create the block.
NOTE The COGO points are not deleted when the blocks are created.

Quick Reference
Ribbon
Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Create Blocks From COGO Points
Menu
Points menu ➤ Utilities ➤ Create Blocks From COGO Points
Command Line
ConvertPointsToSdskPoints
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Dialog Box
Create Blocks from COGO (page 2376)

Converting Land Desktop Points
Use the convert Land Desktop Points command to convert AutoCAD Land Desktop points in a drawing to
AutoCAD Civil 3D points.
When you use AutoCAD Civil 3D to open a drawing that contains Land Desktop points, you can run this
utility to perform the conversion.
Before converting the points, you can use the Convert Autodesk Land Desktop Points dialog box to set a
variety of point settings. For example, you can set default layers, point creation settings, and more. For more
information, see Configuring Land Desktop Point Settings.
You can automatically add the converted points to a newly created point group or to an existing point group.
The existing AutoCAD Civil 3D point number and point name conflict resolution rules are used if a point
ID conflict occurs during the conversion.
To convert Land Desktop points
1 Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Convert Land Desktop Points to display the
Convert Autodesk Land Desktop Points dialog box.
2 Configure point setting parameters by expanding the parameter, selecting a setting, then specifying a
new value in the Value column.
3 To assign the Land Desktop points to a point group, select Add Points To Point Group, then choose a
point group from the list or create a new point group. If you create a new point group, it is added to
the Add Points To Point Group list.
4 To keep the existing layers referenced by the Land Desktop points, select Preserve Original Point Layer.
NOTE When this check box is checked, the existing layer of the Land Desktop point is assigned to the
AutoCAD Civil 3D point when it is converted. If the Points Creation\Disable Description Keys setting is set
to False, and the Land Desktop point matches a description key, the original point layer will still be preserved.
5 Click OK.

Quick Reference
Ribbon
Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Convert Land Desktop Points
Menu
Points menu ➤ Utilities ➤ Convert Land Desktop Points
Command Line
ConvertLDTPoints
Dialog Box
Convert Land Desktop Points dialog box (page 2377)
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Geodetic Calculator
Use the Geodetic Calculator to calculate geodetic information relative to the zone and transformation values
specified in the drawing settings.
A Coordinate System zone must be specified for the drawing in order to use this command. Transformation
settings must be specified in order to view/calculate local coordinates relative to the Latitude/Longitude
and/or Grid coordinates.
Enter one pair of known coordinate values, either Local Northing/Local Easting, Latitude/Longitude, or Grid
Northing/Grid Easting. The other two coordinate pairs are calculated.
For example, if you enter a value in the Local Northing value field, the Local Northing/Local Easting coordinate
pair is assumed to contain the known data, and the values for the Latitude/Longitude and Grid Northing/Grid
Easting pairs are calculated. If you enter a value into either the Latitude or Longitude value field, the
Latitude/Longitude coordinate pair is assumed to contain the known data, and values for the Local
Northing/Local Easting and Grid Northing/Grid Easting pairs are calculated.
If you enter a point number or select a point location in the drawing, the Local Northing/Local Easting pair
is updated, and the Latitude/Longitude and Grid Northing/Grid Easting pairs are calculated.
NOTE You can run other commands while the Geodetic Calculator is active.
To use the Geodetic Calculator
1 Click Modify tab ➤ Points ➤ Geodetic Calculator.
2 In the Geodetic Calculator (page 2373) dialog box, specify starting information by doing one of the
following:
■

Click

to select a point location in the drawing.

■

Enter a point number.

■

In the Value column of the Geodetic Calculator, enter a set of coordinate values, either Latitude
and Longitude, Grid Northing and Grid Easting, or Local Northing and Local Easting.

3 Optionally, click
to create a point with the values for the Local coordinates you entered or calculated.
You are prompted at the command line to enter a point description and elevation.
4 To perform additional calculations, enter a value for a coordinate field, such as Local Northing.
5 After you enter the value, click the Value column for another coordinate field, such as Grid Easting.
6 Update all values by clicking in another field.

Quick Reference
Ribbon
Click a point in the drawing Analyze tab ➤ ➤ COGO points tab ➤ Geodetic Calculator
Menu
Survey menu ➤ Geodetic Calculator
Command Line
ShowGeodeticCalculator
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Dialog Box
Geodetic Calculator (page 2373)

Point Command Reference
You can use these commands to quickly access point-related functionality.
The following table lists the point-related AutoCAD Civil 3D commands and briefly describes their
functionality. For more information about a command, follow the link in the Description column.
Command

Description

AddPointTable

Adds a point table to a drawing (page 452)

AeccCreatePtGeodeticDir

Creates a point from a specified location,
geodetic direction, and distance (page 459)

ConvertPointsToSdskPoints

Creates blocks at the location of specified
COGO point locations which can be used
for backward migration (page 543)

CreateDescKeySet

Creates a description key set (page 581)

CreatePointAlignAlign

CCreates a point either at the intersection
of two alignments or an offset distance
from one or both alignments (page 487)

CreatePointAtPtPcScetc

Creates a point at every intersection on the
alignment (page 493)

CreatePointAutomatic

Creates points automatically at the endpoints of lines, feature lines, or lot lines, or
at the endpoints and center point of arcs
(page 462)

CreatePointByRelElev

Interpolates a point between two specified
points based on an elevation, or between
two endpoints of an arc, line, lot line,
polyline, feature line, or figure (page 506)

CreatePointByRelLocation

Interpolates a point between two specified
points based on a distance, or between two
endpoints of an arc, line, lot line, polyline,
feature line, or figure (page 505)

CreatePointDirectionAlign

Creates a point at the intersection of a
specified location/direction and an alignment object (page 483)

CreatePointDirectionDir

Creates a point at the intersection of two
directions, each defined by a point and a
bearing or azimuth (page 470)

CreatePointDirectionDist

From two specified points, creates another
point from the intersection of a specified
distance and direction (page 472)
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Command

Description

CreatePointDirectionPerp

Creates a point at the intersection of a direction perpendicular to a selected point
(page 474)

CreatePointDirectionObject

Creates a point at the intersection of a direction and a selected arc, line, polyline, lot
line, feature line, or figure (page 477)

CreatePointDistanceAlign

Creates a point at the intersection of a
specified location/distance and an alignment object (page 484)

CreatePointDistanceDist

From two specified points, creates another
point from the intersection of two specified
distances (from each point the distance is
the radius of a circle, and two possible
solutions are returned) (page 471)

CreatePointDistanceObject

Creates a point at the intersection of a distance and a selected arc, line, polyline, lot
line, feature line, or figure (page 478)

CreatePointDivideAlign

Creates points that are a specified distance
apart along an alignment (page 490)

CreatePointDivideObject

Creates a specific number of evenly spaced
points along a line, feature line, lot line, or
arc (page 465)

CreatePointDistancePerp

Creates a point at the intersection of a distance and perpendicular to a selected point
(page 476)

CreatePointFormat

Creates a point file format (page 529)

CreatePointGroup

Creates a point group (page 561)

CreatePointHighLowPoint

Creates a point at the intersection of two
directions and two slopes or grades (page
512)

CreatePointImportFromFile

Creates points along an alignment by importing points from a text file that contains
station, offset, and elevation information
(page 497)

CreatePointInterpolate

Creates a specified number of points whose
elevations are interpolated between the
elevations of two existing points (page 503)

CreatePointManual

Creates a point at a specified location in
the drawing (page 458)
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Command

Description

CreatePointMeasureAlig

Creates points at equal intervals along an
alignment (page 491)

CreatePointMeasureObject

Creates points that are a specified distance
apart along a line, feature line, lot line, or
arc (page 467)

CreatePointNumByDist

Interpolates a specified number of points
between two points based on a distance,
or between two endpoints of an arc, line,
lot line, polyline, feature line, or figure
(page 507)

CreatePointObjectAlign

Creates a point at the intersection of an
alignment and an arc, line, lot line, polyline, feature line, or figure (page 486)

CreatePointObjectObject

Creates a point at the intersection of two
objects that can be arcs, lines, lot lines,
polylines, feature lines, or figures (page 480)

CreatePointOnGrid

Creates a grid of points within a specified
surface that are automatically assigned
surface elevations (page 514)

CreatePointRadialOrPerp

Creates a point on an alignment that is radial or perpendicular to a specified point
(page 496)

CreatePointRandomPoints

Creates a point at a specified location
within a surface, and assigns the elevation
of the surface to the new point (page 512)

CreatePointResection

CCreates a point at a position calculated
from the measured angles between three
known points (page 460)

CreatePointSlopeGradeDist

Creates a specified number of points from
an existing point object based on the slope
or grade to a given direction and distance
(page 514)

CreatePointSlopeGradeElev

Creates a specified number of points from
an existing point object based on the slope
or grade to a given direction and elevation
(page 515)

CreatePoints

Opens the Create Points toolbar where you
can access all AutoCAD PRODUCTNAME
point creation commands (page 456)

CreatePointStationOffset

Creates points that are offset from stations
on an alignment (page 489)
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Command

Description

CreateProfileGeomPoints

Creates points on the alignment at the
geometry points of the profile view with
elevations from the profile (page 496)

CreatePtAlongLnCurveSpir

Creates a point along a line, feature line,
lot line, or arc at a specified distance from
an end point (page 463)

CreatePtAlongPolyContour

Creates points on a surface at specified
distances along a polyline object or a surface contour (page 515)

CreatePtConvertAdeskPts

Converts AutoCAD point objects to COGO
points (page 542)

CreatePtConvertSdskPts

Converts Softdesk point blocks to COGO
points (page 542)

CreatePtIncrementalDist

Interpolates points at a specified distance
between two points, or between two points
on an arc, line, lot line, polyline, feature
line, or figure (page 509)

CreatePtIncrmntlElev

Interpolates points at a specified elevation
difference between two points, or between
two points on an arc, line, lot line, polyline,
feature line, or figure (page 510)

CreatePtInterpPerpendic

Interpolates a point along a control line or
arc, line, lot line, polyline, feature line, or
figure that is perpendicular to a specified
point (page 481)

CreatePtInterpolIntersec

Interpolates a point at the intersection of
a line and a slope, which is either the slope
between two specified points, or the slope
between two endpoints of a line segment
(page 511)

CreatePtIntersectPerp

Creates a point at the intersection of a
specified point perpendicular to a selected
arc, line, lot line, polyline, feature line, or
figure (page 481)

CreatePtOnLineCurveSpiral

Creates a point at the endpoints of a line,
feature line, lot line, or arc and on points
of intersection and radius points for arcs
(page 464)

CreatePtPlylineCtrVertMan

Creates points at the vertices of a polyline
at a specified elevation (page 468)
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Command

Description

CreatePtPlylnCtrVertAuto

Creates points on the vertices of a surface
contour or polyline that are automatically
assigned surface elevations (page 469)

CreatePtPolyContourVert

Creates points at polyline or surface contour vertices using elevations from a surface
(page 468)

CreatePtStationOffsetObj

Creates a point at a specified station and
offset distance from a line, polyline, feature
line, lot line, or arc (page 461)

EditAllPoints

Modify point properties in the Point Editor
(page 517)

EditPointDatum

Changes the elevation of all drawing points
by a specified amount (page 521)

EditPointNumbers

Changespoint numbers (page 523)

EditPointSurfaceElevs

Changes the elevations of points based on
a specified surface (page 522)

ExportPoints

Exports points in the current drawing to
an external file (page 534)

ImportPoints

Creates points by importing point data
from an external file (page 533)

SelectAndEditPointNumbers

Renumbers selected points by adding a
specified integer (page 523)

ShowAllPGChanges

Displays and updates out-of-date point
groups (page 557)

ShowDescKeySetsList

Changes the description key set search order (page 582)

ShowGeodeticCalculator

Calculates geodetic information relative to
the zone and transformation values specified in the drawing (page 545)

ShowPointFormats

Displays the Point File Format dialog box
for creating, copying, or deleting point file
formats (page 2359)

ShowPointGroupProperties

Displays the Properties of a selected point
group (page 567)

ShowPointGroupsList

Displays all point groups (page 557)

ShowPointSettings

Displays point settings (page 439)
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Command

Description

TransferPoints

Transfers point data in an external point
file to another external point file, using a
different point file format (page 536)
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Point Groups

16

You can use named collections of points, called point groups, to organize points and to control their appearance in a
drawing.
A point group has the following characteristics:
■

It has persistent properties you can easily review or change.

■

A points list displays the points included in a point group. The point list can be updated automatically. This might be
necessary when you change the point group’s properties, create new points that match the point group’s properties,
or erase or modify points that match the point group’s properties.

■

A point group can be locked to prevent changes within a drawing.

Understanding Point Groups
Using point groups, you can organize points and control the appearance of points in a drawing.

Reasons to Use Point Groups
Point groups provide a flexible and convenient way to identify points that share common characteristics or
that are used to perform a task, such as creating a surface. You can use point groups to create groupings of
points using point number, point name, point elevation, raw (field) or full description, and other
characteristics.
Point groups also play a fundamental role in controlling how a point displays in a drawing. If you have a
set of points that share common display characteristics, you can use a point group to identify the point style
and point label style for all the points in the point group, instead of assigning a point style and a point label
style to each individual point. Also, using a point group you can quickly change the style or label style for
all the points in a point group at once, instead of changing each point individually.
The point group display order, the point group default styles, and the point group override styles can all
affect how a point is drawn. For more information, see Controlling the Appearance of Points in a Drawing
(page 454).

Point Group Properties
A point group is defined by properties which describe the criteria that a point must match to belong to a
point group, such as its point number, its name, its raw or full description, or its elevation. Points that match
the specified criteria are added to the point group’s point list.
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You can create a point group either before or after you create the points that belong to it. The point list is
maintained dynamically, which means you are notified whenever a change occurs that could affect the
point list. For more information, see Out-of-Date Point Groups (page 556).
NOTE A point can belong to more than one point group.

Point Groups Collection (Prospector Tab)
Use the Point Groups collection on the Prospector tab to access point groups in a drawing. As point groups
are created, they are listed by their name under the Point Groups collection.
Right-click the Point Groups collection to do the following:
■

Change the point group display order. (page 558)

■

Create a new point group. (page 561)

■

View information about out-of-date point groups before updating them. (page 556)

■

Automatically update all out-of-date point groups.

■

Refresh the display.

Expand the Point Groups collection to display a list of the point groups in the drawing. Right-click a point
group to do the following:
■

Edit the point group’s properties. (page 567)

■

Edit the points in the point group’s point list.

■

Lock or unlock the points in the point group’s point list. (page 560)

■

Export the points in the point group. (page 534)

■

Delete the points in the point group.

■

Make a copy of the point group. (page 566)

■

List the changes required to update the point group if it is out-of-date. (page 556)

■

Update the point group if it is out-of-date.

■

Delete the point group. (page 568)

■

Lock or unlock the point group in the drawing. (page 560)

■

Refresh the display.

The _All Points Point Group
Use the _All Points point group to view a list of all the points in a drawing.
The _All Points point group is created automatically when you create a drawing. It is listed on the Prospector
tab under the Point Groups collection, with the other drawing point groups.
When you create a drawing point, it is added to the _All Points point group point list. When you delete a
drawing point, it is removed from the _All Points point group point list. A point can belong to other point
groups in the drawing, but it is always a member of the _All Points point group.
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The _All Points point group serves the following purposes:
■

It provides a default display for points that are created without a point style or point label style and do
not belong to any other point group. The appearance of a point in the drawing can be controlled both
by the point groups it belongs to and the order in which the point groups are displayed. For more
information, see Controlling the Appearance of Points in a Drawing (page 454).

■

It provides a complete list of all the points in a drawing.

Because the _All Points point group point list is automatically managed, you cannot change the point group
properties using the Point Groups, Raw Desc Matching, Include, Exclude, and Query Builder tabs in the
Point Group Properties dialog box. You can, however, change properties, such as styles and overrides using
the Information tab and the Overrides tab.

Point Group Default Styles
Use the Point Group Properties dialog box to specify a default point style and point label style for a point
group.
The default point style and point label style for the point group can be viewed and changed in two locations
in the point group properties dialog box: on the Information tab and on the Overrides tab.
If you change the default style on one tab, the other tab is updated to reflect the new style. The check box
next to the style name on the Overrides tab indicates when the point group default style is used. If the check
box is cleared, then the point group default style is used to display the point only if the point does not have
an individual point style assigned. If the check box is selected, the point group default style is used to display
each point in the point group, regardless of whether it has an individual point style assigned, according to
the point group display order. For more information about point group display order, see Changing the
Point Group Display Order (page 558).
Assign individual point styles either during point creation using the options in the Create Points dialog box
or using description keys. Use the Point Editor to change individual point styles after a point is created.
For more information, see Controlling the Appearance of Points in a Drawing (page 454).

Using Point Groups to Override Point Properties
Use the Overrides tab on the Point Group Properties dialog box to specify point property override values for
the points that belong to the point group.
When a point belongs to a point group, you can override some of its individual properties using point group
overrides. When you specify an override value, that value is used to display the point in the drawing and
appears in drawing point lists. However, the stored value for the point is not changed.
You can use point groups to override the following point properties:
■

raw description

■

elevation

■

point style

■

point label style

The point group display order can affect the override values displayed in labels for raw description and
elevation. It can also affect the point style and point label style that can be used to display a point in a
drawing. For more information, see Changing the Point Group Display Order (page 558).
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Raw Description Override
To specify a raw description override, click
and enter a value or click
and select or create an external
data reference. For more information, see Using External Data References (page 537). To stop using the
override, clear the check box.

Elevation Override
To specify an elevation override, click
and enter a value or click
and select or create an external data
reference. For more information, see Using External Data References (page 537). To stop using the override,
clear the check box.

User-Defined Property Override
To specify a User-Defined Property override, click
and cycle through and select
. Click in the row
and select a user-defined property from the list. For more information, see Assigning User-Defined Properties
to Point Groups (page 447). To stop using the override, clear the check box.

Point Style and Point Label Style Overrides
Use the override point style and point label style to display all the points that belong to the point group.
For more information, see Point Group Default Styles (page 555) and Controlling the Appearance of Points
in a Drawing (page 454).

Managing Point Groups
You can manage and update point groups within a drawing.
To manage point groups within a drawing, you can:
■

Identify and update out-of-date drawing point groups.

■

Lock a point group or the points in a point group’s point list.

■

Change the point group display order within a drawing.

Out-of-Date Point Groups
Use the Prospector tab or the Point Groups dialog box to identify out-of-date point groups.
Use the Prospector tree to list the point groups in a drawing. An out-of-date point group has
next to
it in the Prospector tree, in the point group list view, and in the Point Group dialog box. When a point
group is out-of-date, the points in the point list no longer match the criteria specified on the tabs in the
Point Group Properties dialog box.
NOTE Out-of-date icons are displayed only if the Toolspace tree modifier icon display is active. For more information,
see Drawing Item Modifier Icons (page 161).
A point group’s point list may be out-of-date when one or more of the following occurs:
■

You changed a point property (such as raw description or elevation) of a point belonging to the point
group, so that the point no longer meets the criteria for being included in the point group.

■

You created new points that match the point group’s properties.

■

You deleted points that belonged to the point group.
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■

A point group that is included in the point group (using the Point Groups tab) became out-of-date due
to one of the above causes.

For information about updating out-of-date point groups, see Updating All Out-of-Date Point Groups (page
557) and Updating a Single Out-of-Date Point Group (page 558).

Updating All Out-of-Date Point Groups
Use the Point Groups dialog box to update all out-of-date point groups at once.
A point group is out-of-date when the points in the point list do not match the point group’s properties.
For more information, see Out-of-Date Point Groups (page 556).
An out-of-date point group has
Group dialog box.

next to it in the Prospector tree, the point group list view, or the Point

NOTE Out-of-date icons are displayed only if the Toolspace tree modifier icon display is active. For more information,
see Drawing Item Modifier Icons (page 161).
Before you update the point groups, you can use the Point Groups dialog box to view a list of the points
that must be added to or removed from the out-of-date point groups to bring them up to date.
To update all out-of-date point groups
1 Click COGO Point tab ➤ Modify panel ➤ Edit Point Group List

.

The Point Groups dialog box is displayed. Point groups marked with
2 In the Point Groups (page 2358) dialog box, click
groups.

are out-of-date.

to display information about the out-of-date point

3 In the Point Group Changes (page 2359) dialog box, click

to update all out-of-date point groups.

4 Click Close in the Point Group Changes dialog box.
5 Click OK in the Point Groups dialog box.

Quick Reference
Ribbon
Click COGO Point tab ➤ Modify panel ➤ Edit Point Group List
Menu
Points ➤ Edit ➤ Point Groups
Toolspace Shortcut Menu
Prospector tab: right-click Point Groups collection ➤ Properties
Command Line
ShowPointGroupsList, ShowAllPGChanges
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Dialog Box
Point Groups (page 2358)

Updating a Single Out-of-Date Point Group
Use the Prospector tab to update an out-of-date point group.
An out-of-date point group has

next to it on the Prospector tab.

NOTE Out-of-date icons are displayed only if the Toolspace tree modifier icon display is active. For more information,
see Drawing Item Modifier Icons (page 161).
A point group is out-of-date when the points in the point list do not match the point group’s properties.
For more information, see Out-of-Date Point Groups (page 556).
To update a single out-of-date point group
1 In Toolspace, on the Prospector tab, right-click a point group that is out-of-date. Click Show Changes.
The Point Group Changes (page 2359) dialog box displays a list of the changes required to bring the point
group up to date.
TIP If you do not want to review the changes required to bring the point group up to date, click Update on
the shortcut menu instead of Show Changes.

2 Click

to update the point group.

3 Click OK.

Quick Reference
Toolspace Shortcut Menu
Prospector tab: right-click Point Groups item ➤ Show Changes
Dialog Box
Point Group Changes (page 2359)

Changing the Point Group Display Order
Use the point group display order to specify how points that belong to more than one point group are
displayed in a drawing.

558 | Chapter 16 Point Groups

The point group display order for a drawing determines the order in which the point groups are drawn when
a drawing is opened or graphics are regenerated. The first (highest) point group in the list is drawn last.
A point is drawn only once each time drawing graphics are regenerated. A point that belongs to more than
one point group is drawn by the point group that is highest in the display order, and it is unaffected by the
point groups that are lower in the display order. This can determine the point style, point label style, and
the layer used to display the point. For more information, see Controlling the Appearance of Points in a
Drawing (page 454).
The point group display order is also used to display override values for elevation and description in labels.
If a point belongs to more than one point group, the first point group in the display order that draws the
point will determine whether override values are used. If the point group has an override for elevation or
description, the label is displayed using the override value. If the point group does not have an override,
the label is displayed without the override.
To change the point group display order
1 In Toolspace, on the Prospector tab, right-click the Point Groups collection. Click Properties.
2 In the Point Groups (page 2358) dialog box, select the point group you want to move in the display order.
3 Hover your cursor over the arrow icons. The arrows give you options to move the point group up or
down one place in the display order, or to the top or bottom of the display order.
4 Click OK.

Quick Reference
Menu
Points ➤ Edit ➤ Point Groups
Toolspace Shortcut Menu
Prospector tab: right-click Point Groups collection ➤ Properties
Command Line
ShowPointGroupsList
Dialog Box
Point Groups (page 2358)
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Locking and Unlocking Point Groups
Use locking to prevent the properties of a point group from being modified in a drawing.
A locked point group cannot have its properties changed. It cannot be updated (if it is out-of-date), deleted,
or overwritten.
A locked point group has
next to it in the Prospector tree and the point group list view. The icon is
displayed only if the Toolspace tree drawing state icons are displayed. For more information, see Drawing
Item State Icons (page 161).
Locking a point group does not lock the points in the point list. You can lock points individually in the
Prospector list view, or you can lock all the points in the point group list at the same time using a single
command. For more information, see Locking and Unlocking Point Lists (page 560).
To lock or unlock a point group
1 In Toolspace, on the Prospector tab, right-click the point group you want to lock or unlock.
2 Click Lock or Unlock.

Quick Reference
Toolspace Shortcut Menu
Prospector tab: Right-click Point Groups item ➤ Lock or Unlock

Locking and Unlocking Point Lists
Use point list locking to prevent the points in a point group from being modified in a drawing.
A locked point cannot have its properties changed in the drawing. A locked point has
next to it in point
lists such as the Prospector tab Points list view. The icon is displayed only if the Toolspace tree drawing state
icons are displayed. For more information, see Drawing Item State Icons (page 161).
Use a single command to lock or unlock all the points in a point group’s point list.
To lock or unlock a point list
1 In Toolspace, on the Prospector tab, right-click the point group whose point list you want to lock or
unlock.
2 Click Lock Points or Unlock Points.

Quick Reference
Ribbon
Click COGO Point tab ➤ Modify panel ➤ Lock Points
or
Click COGO Point tab ➤ Modify panel ➤ Unlock Points
Toolspace Shortcut Menu
Prospector tab: right-click Point Groups item ➤ Lock Points or Unlock Points
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Specifying Case-Sensitive Description Matching for a Point Group
Specify whether description matching in the Point Group Properties dialog box is case-sensitive.
Case-sensitive matching is not a global setting. You set it separately for each point group.
The Use Case-Sensitive Matching check box on the Query Builder tab of the Point Group Properties dialog
box specifies how description matching is performed on the Raw Desc Matching, Include, and Exclude tabs
in the Point Group Properties dialog box.
To specify case-sensitive description matching for a point group
1 In Toolspace, on Prospector tab, right-click the point group you want to change. Click Properties.
2 In the Point Group Properties dialog box, click the Query Builder (page 2351) tab.
3 To enable or disable case-sensitive matching for raw and full descriptions, select or clear Use
Case-Sensitive Matching.
4 Click Apply.

Quick Reference
Toolspace Shortcut Menu
Prospector tab: right-click Point Group item ➤ Properties ➤ Query Builder tab
Command Line
ShowPointGroupProperties
Dialog Box
Query Builder Tab (Point Group Properties) (page 2351)

Printing Point Groups
Use the Copy To Clipboard command to copy the points in a point group’s point list to another application
for printing.
To print the points in a point group, click the Prospector tab and then click the point group to display the
point list in a list view. Right-click the list view. Click Copy To Clipboard to copy the list view into a file
you can print. For more information, see Copying Items from a List View (page 103).

Creating Point Groups
You create a point group by defining its properties.
Point groups organize and identify points that share common characteristics. Use point groups to assign
point styles and point label styles for all the points in a point group instead of assigning styles individually.
IMPORTANT The highest point number allowed in Civil 3D is 4,294,967,295. You can use point names or User
Defined Properties to reference numbers greater than 4,294,967,295. For more information, see Using Custom
Properties with Points (page 445).
Use the tabs on the Point Group Properties dialog box to define the properties of a point group. The tabs
you use depend on which method you use to define a point group:
■

The Basic Method. Use this method to easily define the properties for many point groups. Use the Point
Groups, Raw Desc Matching, Include, and the Exclude tabs of the Point Group Properties dialog box.
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Also, use this method when you want to identify points that belong to a point group by selecting points
in a drawing.
■

The Query Builder Method. Use this advanced method to create point groups by combining expressions,
which allows you to use a single tab, the Query Builder tab, to build a point group based on combinations
of point properties or point groups. When you create a point group using the query builder method, the
Point Groups, Raw Desc Matching, Include, and Exclude tabs are not available.

NOTE You should understand how to create a point group using the basic method before using the query builder.
After you create a point group, do not try to interchange the two methods to make changes to a point group.
You can create a point group using the basic method and then change the point group properties using the
Query Builder tab. However, you will lose the changes you made on the Query Builder tab if you then change
the point group using the Point Groups tab, the Raw Desc Matching tab, the Include tab, or the Exclude
tab.
You can always access the Information tab, the Overrides tab, the Point List tab, and the Summary tab
regardless of the method used to define or change the point group’s properties.
Because the list of points that belong to a point group (the point list) is updated dynamically, you can create
point groups either before or after you create points in the drawing. If you create the points first, and then
create the point group, the point list of the newly created point group is immediately updated with the
existing points that match the criteria for inclusion in the point group. If you create a point group before
you create points that qualify for inclusion in the point group, the point group is marked as out-of-date on
the Prospector tab as points are created. You can easily update the point list to include the new points. For
more information, see Out-of-Date Point Groups (page 556).
Also, you can create a point group when you import points. In the Import Points dialog box, specify the
name of the point group to be created.

Creating a Point Group Using the Basic Method
Use the basic method to easily define properties for point groups.
Include points in point groups by specifying point descriptions, point numbers, elevations, and point names.
You can also include points in a point group by specifying the name of one or more other point groups or
by using raw description matching.
To create a point group using the basic method
1 Click Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Create Point Group

.

2 In the Point Group Properties dialog box, on the Information (page 2348) tab, enter a name, description,
default styles, and a layer for the point group.
3 To include points from other point groups, click the Point Groups (page 2348) tab and select the check
box next to any point group you want to include.
4 To include points using raw descriptions, click the Raw Desc Matching (page 2349) tab and select the
check box next to the raw descriptions you want to match.
All points in the drawing are searched, and points with a raw description that matches a raw description
specified on the tab are included in the point group.
5 To specify criteria that explicitly includes points in the point group, click the Include (page 2349) tab and
define the criteria that a point must match to be included in the point group.
6 To specify criteria that explicitly excludes points from the point group, click the Exclude (page 2350) tab
and define the criteria that a point must match to be excluded from the point group.
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7 To specify overrides for points in the point group, click the Overrides (page 2353) tab.
8 To view the points in the point group’s point list, click the Point List (page 2354) tab.
9 To view a summary of the point group’s properties, click the Summary (page 2354) tab.
10 Click OK.

Quick Reference
Ribbon
Click Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Create Point Group
Menu
Points ➤ Create Point Group
Toolspace Shortcut Menu
Prospector tab: Right-click Point Groups collection ➤ New
Command Line
CreatePointGroup
Dialog Box
Point Group Properties (page 2348)

Creating a Point Group Using the Query Builder
Use the query builder to create point groups by combining expressions.
The Query Builder tab of the Point Group Properties dialog box consolidates many of the options available
on the Point Groups, Raw Desc Matching, Include, and Exclude tabs, and allows you to define a complex
point group by combining expressions.
For example, to use the basic method to create a point group that includes both the points with a raw
description that begins with FLOW and the points in the point group named Flow Line, you would need to
use two tabs, the Include tab and the Point Groups tab. You can create the same point group using only the
Query Builder tab. The following illustrates the Query Builder tab with a query that specifies that any point
that either has a raw description that begins with FLOW or is a member of the Flow Line point group is
included in the point group:

The contents of the entire grid on the Query Builder tab is called a query. Each row in the query builder is
an expression. You create a query by combining expressions using the set operators AND, OR, and NOT. For
more information about building queries, see Understanding Point Group Queries (page 565).
NOTE Since the query builder is an advanced tool for creating point groups, it is recommended that you master
point group creation using the basic method before you attempt to use the query builder.
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When you first click the Query Builder tab, it displays a starting query that reflects the current contents of
the Point Groups, Raw Desc Matching, Include, and Exclude tabs. After you understand how to create a
point group using the basic method, you can learn how to build queries by doing the following:
■

Create a point group using the basic method.

■

In the Point Group Properties dialog box, click the Query Builder tab.

■

Examine the starting query, which is created from the information you specified on the Point Groups,
Raw Desc Matching, Include, and Exclude tabs.

■

Make changes to the options on one of the above tabs, then return to the Query Builder tab and notice
how the changes affected the query.

The Modify Query check box on the Query Builder tab determines which tabs in the Point Group Properties
dialog box are active. When this check box is cleared, the Query Builder tab is inactive, and you can change
the point group properties using the Point Groups, Raw Desc Matching, Include, and Exclude tabs. When
the check box is selected, the Query Builder tab is active, you can change the query, the Point Groups, Raw
Desc Matching, Include, and Exclude tabs are inactive.
In general, when you change the properties of a point group, you should set the state of the Modify Query
check box once and leave it. Every time you select or clear the Modify Query check box, you can lose
information on some tabs in the Point Group Properties dialog box. For example, if you change the query,
and then clear the Modify Query check box to activate the other tabs in the dialog box, you lose the changes
you made to the query.
To create a point group using the query builder
1 Click Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Create Point Group

.

2 In the Point Group Properties dialog box, on the Information (page 2348) tab, enter a name, description,
default styles, and a layer for the point group.
3 Click the Query Builder (page 2351) tab.
4 On the Query Builder tab, select Modify Query to activate the query builder.
A starting query is created based on the contents of the Point Groups, Raw Desc Matching, Include,
and Exclude tabs, and those tabs become inactive. If you are creating a new point group, the starting
query is empty.
5 Each row in the query builder contains an expression. Do one of the following:
■

To create a new expression, activate the first row in the grid by right-clicking it and clicking Insert
Row.

■

To modify an existing expression in the query or an existing empty row, activate the row containing
the expression by clicking in it.

■

To delete an expression, click in the row containing the expression and press Delete.

6 Click in the Set Operator column and select a set operator from the list.
7 Click in the “(“ column to turn the left parenthesis on or off for the expression.
8 Click in the Property column and select a property.
9 Click in the Operator column and select an operator.
10 Click in the Value column and enter a value that is valid for the property you specified in Step 8.
11 Click in the “)“ column to turn the right parenthesis on or off for the expression.
12 Repeat Steps 5 through 11 to build the query.
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13 When you finish building the query, click Apply.
14 To specify overrides for points in the point group, click the Overrides (page 2353) tab.
15 To view the points in the point group’s point list, click the Point List (page 2354) tab.
16 To view a summary of the point group’s properties, click the Summary (page 2354) tab.
17 Click OK.

Quick Reference
Ribbon
Click Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Create Point Group
Menu
Points ➤ Create Point Group
Toolspace Shortcut Menu
Prospector tab: right-click Point Groups collection ➤ New
Command Line
CreatePointGroup
Dialog Box
Point Group Properties (page 2348)

Understanding Point Group Queries
You can use the query builder more effectively if you understand the components of a query.
A query consists of expressions that are combined using set operators.

Expressions
An expression consists of the following three components:
■

property (for example: Point Number, Point Elevation)

■

comparison operators (for example: =, >, <=)

■

value (for example: 4, 20-87, 101.33)

Use properties, comparison operators, and values to create expressions such as the following:
■

Point Number = 1-100

■

Point Elevation > 1200

■

Point Group = Detention Pond

Set Operators (AND, OR, and NOT)
Use set operators to combine or negate expressions.
For example, if you combine the first two expressions above with the OR set operator, the resulting query
is:
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(Point Number = 1-100) OR (Point Elevation > 1200)
The above query adds to the point group any point with either a point number between 1 and 100 or an
elevation greater than 1200.
If you combine the first two expressions above with the AND set operator, the resulting query is:
(Point Number = 1-100) AND (Point Elevation > 1200)
The above query adds to the point group any point that has both a point number between 1 and 100 and
an elevation greater than 1200.
The NOT operator allows you to exclude points using specified criteria. For example, if you preceded the
first expression above with the NOT operator, the resulting query is:
NOT (Point Number = 1-100)
The above query excludes points from the point group if the point number falls between 1 and 100.

Using Parentheses to Combine Expressions
You can use parentheses to combine expressions. Expressions that fall within parentheses are evaluated
before they are combined with other expressions.
The following query uses parentheses to combine expressions:
(Raw Description = MON OR Raw Description = IP) AND (Point Elevation > 200)
Because the previous query is evaluated according to the parentheses, first (Raw Description = MON OR Raw
Description = IP) is evaluated and then (Point Elevation > 200) is evaluated, then the two results are evaluated
together using the AND set operator. The query adds to the point list only points with a raw description of
MON or IP that have elevations greater than 200.

Precedence of Operators
When parentheses are not used to combine expressions, the query is evaluated using only the following
precedence of operators. The following lists the precedence of the operators from highest to lowest:
■

NOT

■

comparison operators (<> <= >= =)

■

AND

■

OR

The following query does not use parentheses to combine expressions:
Raw Description = MON OR Raw Description = IP AND Point Elevation > 200
Because the query is evaluated according to the precedence above, Raw Description = IP AND Elevation >
200 is evaluated first, then the results are evaluated with Raw Description = MON. The query adds to the
point list any point that has a raw description of IP and an elevation > 200. It also adds to the point list any
point with a raw description of MON, regardless of its elevation.

Creating a New Point Group From an Existing Point Group
Create a new point group based on an existing point group by creating a copy of the existing point group
and then changing the new point group’s properties.
Point group names must be unique. When you create a point group by creating a copy, a new point group
name is created based on the original point group name.
Change the name of a copied point group on the Information tab of the Point Group Properties dialog box.
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To create a new point group from an existing point group
1 In Toolspace, on the Prospector tab, right-click the point group you want to copy. Click Copy.
2 On the Prospector tab, right-click the new, copied point group. Click Properties.
3 In the Point Group Properties (page 2348) dialog box, on the Information tab, change the name of the
new, copied point group.
4 Change the point group’s properties using either the basic method or the query builder:
■

See Creating a Point Group Using the Basic Method (page 562).

■

See Creating a Point Group Using the Query Builder (page 563).

NOTE You must use the query builder to change the point group’s properties if the Point Groups, Raw Desc
Matching, Include, and Exclude tabs are inactive

Quick Reference
Toolspace Shortcut Menu
Prospector tab: right-click Point Groups item ➤ Copy

Creating a New Point Group From the Import Survey Data Wizard
A new point group is created in the Point Groups collection on the Prospector tab when you import a Survey
LandXML file that has survey point groups defined .
The point group name defaults to the name of the file you import.
For more information, see Import Survey Data Wizard (page 261).

Editing Point Groups
You can change the properties of existing point groups or delete a point group.

Changing the Properties of a Point Group
Use the Point Group Properties dialog box to change the properties of a point group.
The Modify Query check box on the Query Builder tab controls which tabs are active in the Point Group
Properties dialog box.
If the Modify Query check box is selected, the Point Groups, Raw Desc Matching, Include, and Exclude tabs
are inactive. If the Modify Query check box is cleared, those tabs are active, and you can use them to change
the properties of the point group.
To change the properties of a point group
1 In Toolspace, on the Prospector tab, right-click the point group you want to change. Click Properties.
2 In the Point Group Properties (page 2348) dialog box, use the Information (page 2348) tab to change the
name, description, default styles, or layer for the point group.
3 Change the point group’s properties using either the basic method or the query builder:
■

See Creating a Point Group Using the Basic Method (page 562).
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■

See Creating a Point Group Using the Query Builder (page 563).

Quick Reference
Ribbon
Select a point. Click COGO Point ➤ <number> | <name> tab ➤ Modify panel ➤ Point Group Properties
.
Toolspace Shortcut Menu
Prospector tab: right-click Point Groups item ➤ Properties
Command Line
ShowPointGroupProperties
Dialog Box
Point Group Properties (page 2348)

Changing Point Group Properties by Dragging Points into the Point Group
Include drawing points in a drawing point group using the Prospector tree drag-and-drop capability.
The destination point group must be visible in the Prospector tree. The drawing point you want to drag into
the point group must be displayed in a list view.
NOTE To display all the points in the drawing in a list view, click the _All Points point group.
In the list view, select one or more points. Hold down the left mouse button, and drag the mouse to the
point group name in the Prospector tree. When the cursor display changes to
to drop the points into the point group at the tip of the cursor arrow.

, release the mouse button

The points are added to the point group’s point list. The Include tab of the point group’s Point Group
Properties dialog box is modified to include the point number of the points.

Deleting a Point Group
Use the Prospector tree to delete a point group from a drawing.
Deleting a point group does not delete the points contained in the point group’s point list. The points remain
in the drawing.
You cannot delete the _All Points point group from a drawing.
To delete a point group
1 In Toolspace, on the Prospector tab, right-click the point group you want to delete.
2 Click Delete.
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Quick Reference
Toolspace Shortcut Menu
Prospector tab: right-click Point Groups item ➤ Delete
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Description Keys

17

You can use description keys to automatically control point appearance and some point properties when creating or
importing a point into a drawing.
Use description keys to automatically do the following when the drawing point is created:
■

Specify a point style, label style, and a layer for the point.

■

Specify scale and rotation of the point symbol.

■

Translate the raw description for the point into a full description.

Understanding Description Keys
Before using description keys to create points, you should understand the contents of a description key and
how the raw description for a point is used to match a description key.

Overview
Use description keys to automatically control some drawing point properties, such as the appearance of a
point in the drawing, when you create or import points. Before you create drawing points using description
keys, create a series of description keys. Then, when you create or import a drawing point, the raw description
for the point specifies which description key is used to create the point in the drawing. The properties defined
for that description key are applied to the point as it is added to the drawing.
NOTE Drag and drop functionality can be used to copy description keys. For more information, see Dragging
Styles or Items Within or Between Drawings (page 70).
The following are sample description keys, showing code, point style, point label style, format, and layer
properties:

Each description key in a drawing is defined by its properties. Both the code property and the format properties
are required in a description key.
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Code property. Used during description key matching, for example, if the code matches the raw description
for the point, then the properties specified in that description key are applied to the point when it is created.
A description key code can contain characters, called wild cards, that expand the matching capabilities of
the description key. For more information, see Description Key Code (page 574).
Format property. Translates the raw description for a point into a full description. The default is $*, which
indicates that the full description is the same as the raw description.
Optional description key properties include:
■

point style

■

point label style

■

layer

■

point symbol scaling information

■

point symbol rotation information

Sample Raw Descriptions
The raw description for a point is used to determine whether a point matches a description key. The following
are sample raw descriptions:
MONA U_POLE 1078 TREE OAK 5
The raw description can consist of as many as 10 alphanumeric elements separated by spaces. The leading
element in the raw description (MONA, U_POLE, and TREE in the preceding sample) is compared to
description key codes during description key matching. The remaining elements, called parameters, can be
used to translate the raw description into a more readable full description and to rotate or scale the point
symbol in the drawing.

Description Key Matching During the Creation of Drawing Points
The description key matching process compares the leading element in the raw description of the point you
are creating to each of the description key codes in the description keys contained in the drawing. The
process ends either when a match is found or when all the description keys in the drawing have been
searched.
If the leading element in the raw description for the point matches a description key code, the point style,
the point label style, and the layer specified in the description key are used to create the drawing point. The
raw description you entered is translated into a full description using the format specified in the description
key. If the raw description includes scaling and rotation information, the point symbol is scaled and rotated
as specified.
NOTE Description key matching is case-sensitive, which means that an upper case letter does not match a lower
case occurrence of the same letter. For example, the raw description “TREE” would match the description key
code “TREE.” It would not match “Tree” or “tree.”

Accessing Description Keys
Description keys are stored in sets within a drawing. All the description key sets available in a drawing are
listed in the Settings tree in the Description Key Sets collection.

Description Key Sets Collection (Settings Tree)
You can use the Description Key Sets collection in the Settings tree to create and manage description key
sets.
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In the Settings tree, expand the Point collection and then expand the Description Key Sets collection to list
the description keys in the drawing.
Right-click the Description Key Sets collection to:
■

Specify the order in which the description key sets are searched during description key matching (page
582).

■

Create a new description key set (page 581).

■

Refresh the Settings tree.

Right-click a description key set to:
■

Display the name and description of the description key set (page 2368).

■

Edit the description keys in the description key set (page 590).

■

Copy the description key set (page 582).

■

Delete the description key set (page 584).

■

Refresh the Settings tree.

Description Key Settings
Control whether description keys are matched when points are created or imported, and whether the elements
in a raw description are interpreted as parameters.

Activating Description Key Matching
You can control whether description keys are matched when you create or import points.
When you create or import points, clear the Disable Description Keys check box in the Create Points dialog
box if you want description key matching to occur.
NOTE If the Disable Description Keys setting in the Create Points dialog box is changed, then the Disable Description
Keys in the Points Creation settings is changed to the same state if the Save Command Changes To Settings in
the Drawing Settings is set to No. For more information about changing the Disable Description Key setting, see
Editing the Default Point Creation Settings (page 444).
If description key matching is active and the raw description for the point matches a description key, the
point is created with the point style, point label style, and layer specified in the description key. If a format
is specified, the raw description is translated into a full description. If rotation or scaling parameters are
specified in the description key, the point symbol is rotated or scaled. For a more information, see Using
Description Keys When Creating Points (page 579) and Using Description Keys When Importing Points from
a File (page 580).

Controlling Whether Raw Description Values Are Interpreted as Parameters During
Point Creation
You can use the Point Settings dialog box to control whether or not raw descriptions are interpreted as
parameters during point creation.
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Use the Match On Description Parameters ($1, $2, etc.) setting to specify whether or not parameters are used
during description key matching to rotate and scale the point symbol.
■

True. Indicates that parameters are used during description key matching to scale or rotate point symbols.
Because spaces are used to delimit description parameters, spaces in description key codes are not
recognized. Spaces should not be used when this option is selected.

■

False. Indicates that parameters are not used during description key matching to scale and rotate point
symbols. Spaces in description key codes are recognized.

To control whether raw description values are interpreted as parameters during point creation
1 In Toolspace, on the Settings tab, expand the Commands collection under the Point collection.
2 Right-click CreatePoints. Click Edit Command Settings.
3 In the Edit Point Settings (page 2343)dialog box, expand the Points Creation collection. For more
information, see Editing the Default Point Creation Settings (page 444).
4 For Match On Description Parameters ($1, $2, etc.), select either True or False to specify whether or not
raw descriptions contain parameters.
5 Click Apply.

Quick Reference
Toolspace Shortcut Menu
Settings tab: right-click command name in object Commands collection ➤ Edit Command Settings
Dialog Box
Edit Command Settings (page 2025)

Description Key Properties
Each description key property performs a distinct function during description key matching and point
creation.
Description key properties specify how a description key is matched and how the raw description for a point
is translated to a full description. They can also be used to specify a point style, a point label style, and a
layer for a point that matches the description key, and scaling and rotation values for the point symbol.
For a definition of all description key properties and instructions for editing them using the DescKey Editor,
see Description Key Editor (page 2368).

Description Key Code
Use the code property of a description key to specify which raw descriptions match the description key.
A description key consists of a code and a set of additional properties. When the code is matched, the other
properties specified in the description key are applied to the point when it is created.
The following are sample description key codes:
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You can either specify a simple string for a description key code or use wild card characters, such as an
asterisk (*), to expand the matching capabilities of description keys.
For example, all your benchmark points might have the BM prefix in their raw descriptions, such as BM-1
and BM-2. When you add benchmark points to a drawing in AutoCAD Civil 3D, you might want them all
to be created with the same point style, point label style, and description. To do this, you can create a
description key with a code of BM*. (The asterisk means that the code will match all raw descriptions that
begin with BM.) Then, all points with a raw description that begins with BM are created using the properties
specified in that description key.
The following table shows wild card characters you can use in a description key code:
Character

Function in Description Key Code

# (pound)

Matches any single numeric digit.

@ (at)

Matches any alphabetic character.

. (period)

Matches any non-alphanumeric character.

* (asterisk)

Matches any string and can be used anywhere in the search
string.

? (question mark)

Matches any single character, for example, ?BC matches ABC
and 3BC.

~ (tilde)

Matches anything but the pattern, for example, ~*AB*
matches all strings that don't contain AB.

[...] (brackets)

Matches any one of the characters enclosed, for example,
[AB]C matches AC and BC.

[~...]

Matches any character not enclosed, for example, [~AB]C
matches XC but not AC.

- (hyphen)

Inside brackets, specifies a range for a single character, for
example [A-G]C matches AC, BC, through GC, but not HC.

' (reverse quote)

Reads the next characters exactly, for example, '*AB matches
*AB.

The following table shows examples of description key codes containing commonly used wild card characters:
Description Key
Code

Function

T#

Matches descriptions that consist of T followed by one digit,
such as T1, T2, through T9.

STA#

Matches descriptions that consist of STA followed by one digit,
such as STA1, STA2, through STA9. It does not match the description STA, since STA is not followed by a digit.
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Description Key
Code

Function

T##

Matches descriptions that consist of T followed by 2 digits, such
as T01 through T99.

1@

Matches descriptions that consist of 1 followed by an alphabetic
character, such as 1A, 1B, and 1C. It does not match the description 1, since 1 is not followed by an alphabetic character.

T.

Matches descriptions that consist of T followed by a single nonalphanumeric character, such as T- and T+.

T*

Matches descriptions that consist of T followed by any number
of characters, such as T1, TOPO, T-2, and TREE.

NOTE Description key matching is case-sensitive, which means that an upper case letter does not match a lower
case occurrence of the same letter. For example, the raw description “TREE” would match the description key
code “TREE.” It would not match “Tree” or “tree.”

Description Key Format
Use the format property of a description key to create a full description for a point that matches a description
key.
The following are sample description key formats:

The raw description for a point is always stored with the point and often corresponds to the point description
entered by a surveyor in the field. Sometimes, for example, when you are labeling a point in a drawing, the
raw description for the point does not contain information in the format you want. You can use the format
property to create a full description that contains a more readable description of the point.

Simple Methods of Specifying Full Descriptions
Define a standard full description for points that match a description key by specifying the desired description
in the format property. For example, if you want all points that match a specific description key to have a
full description of MONUMENT, enter MONUMENT for the format. Then, points that match the description
key will be created with the full description MONUMENT.
If you want the full description to be the same as the raw description for all points that match the description
key, enter $* for the format.

Using Parameters to Translate a Raw Description into a Full Description
Create a readable full description from a raw description by either changing the order of the elements in
the raw description or adding descriptive text. To do this, you must define a format that translates the raw
description into a full description.
The raw description for a point consists of a list of elements separated by spaces, for example, TREE OAK 7.
To re-order the elements in a raw description, you must reference the individual elements. When creating
a format, you reference the leading element in a raw description using the symbol $0. You reference the
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remaining elements, which are referred to as parameters, using a $ followed by a number (1-9) that specifies
the position for the parameter in the raw description.
For example, in the raw description TREE OAK 7, the leading element in the raw description, TREE, is
referenced using the symbol $0. The first parameter, OAK, is referenced using the symbol $1. The second
parameter, 7, is referenced using the symbol $2.
When a description key match occurs, the raw description is translated into a full description using the
format, which references the elements in the raw description.
NOTE The leading element in a raw description is not referred to as a parameter. “Parameter” refers to the
individual elements that follow the leading element in a raw description.

Example
You are creating a point, and for the raw description, you specify TREE OAK 7. One of your description key
sets contains a description key with the code TREE and the format “$2 inch $1 tree.”
The leading element in the raw description, TREE, matches the code in the description key, which is also
TREE. The format specified in the description key, “$2 inch $1 tree,” is used to translate the raw description
into a full description for the point.
The $2 in the format refers to the second parameter in the raw description, which is 7. The $1 in the format
refers to the first parameter in the raw description, which is OAK. The full description is created by substituting
7 for $2 and OAK for $1 in the format “$2 inch $1 tree.” The text in the format (“inch” and “tree”) is left
unchanged. After the substitutions are made, the translated full description is “7 inch OAK tree.”
The following is a chart of description key parameter substitution codes, including the code to use if you
want the raw description to be used for the full description:
Use this Code... To do this in a format...

Example

$0

Reference the leading element in the
raw description.

TREE Oak 7

$1

Reference the first parameter in the
raw description.

TREE Oak 7

$2

Reference the second parameter in
the raw description.

TREE Oak 7

$3

Reference the third parameter in the
raw description.

TREE Oak 7 24

$4, $5, through
$9

Reference the fourth parameter, the
fifth parameter, through the ninth
parameter.

$+

Reference all the parameters in the
raw description after the leading element.

TREE Oak 7

$*

Reference all the parameters in the
raw description and also the leading
element.

TREE Oak 7

$$

Insert a single $ into the description.

If you used $$200.00 as
part of the format, then
that part of the translated
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Use this Code... To do this in a format...

Example
full description would be
$200.00.

$*

Use the point's raw description for the
full description.

If you used the raw descriptions UP-1, UP-2, and UP3, and you want to use
these descriptions for the
full description, then use
the $* as the format.

Specifying Point Symbol Scaling and Rotation Using Description Key Parameters
Use parameters to specify the point symbol scale or rotation value using the raw description for the point
when a point matches a description key.
Parameters are elements that are included in the raw description for a point. For example, the raw description
TREE OAK 7 consists of a leading element, TREE, followed by two parameters, OAK and 7, separated by
spaces.

Specifying Scale Using a Parameter
If you want the point symbol scale to be read from the raw description for the point when a description key
match is found, use the scale parameter property. In the previous example, OAK is parameter 1, and 7 is
parameter 2. If you wanted the description key to take the symbol scale value from the second parameter
(7) you would specify Parameter 2 as the scale parameter.
For a complete description of all the options available for scaling a point symbol using a description key,
see the Description Key Editor (page 2368).

Specifying Rotation Using a Parameter
If you want the point symbol rotation to be read from the raw description for the point when a description
key match is found, use the rotate parameter property. For example, a raw description Hyd 45 A consists of
the leading element Hyd followed by two parameters: 45 is parameter 1, and A is parameter 2. If you wanted
the description key to use 45 to rotate the point symbol, you would specify parameter 1 as the rotate
parameter.
For a complete description of all the options available for rotating a point symbol using a description key,
see the Description Key Editor (page 2368).
NOTE You can also use parameters in the raw description to create a full description by using a description key
format. For more information, see Description Key Format (page 576).

Description Key Properties That Are Stored with a Point
Some description key properties are stored with the point in the drawing.
When you create a point and description key matching is active, and a match is found, the point is created
using the properties specified in the description key. The following description key properties are stored
with the point, and can be changed for an individual point to alter its appearance in the drawing:
■

Format

■

X-Y Scale

■

Z Scale
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■

Rotation

Use the Point Editor to change these properties.

Managing Description Keys
You can use the Settings tree to manage description keys.
Description keys are organized into sets. The description key sets for a drawing are listed in the Settings tree
under the Description Key Sets collection, which is found under the Point collection.
Each description key set contains one or more description keys. To view or edit the description keys contained
within a set, use the DescKey Editor. For more information, see Editing Description Keys (page 590).
When description key matching is active and a drawing point is created, each description key code in every
description key set in the drawing is searched for a match. You can control the order in which the description
key sets are searched.
Include description key sets in a drawing template so they can be used in multiple drawings and shared with
other people. For more information, see Drawing Templates (page 127).

Using Description Keys When Creating Points
Use description keys when you create drawing points using the Create Points command.
When you create a drawing point and description key matching is active, the raw description you enter at
the prompt initiates a search. The leading element in the raw description is compared to each description
key code in every description key set in the drawing until either a match is found or all description key sets
have been searched.
If a match is found, the point style, the point label style, and the layer specified in the description key are
used to create the point. The raw description you entered is translated into a full description using the format
specified in the description key. If the raw description includes scaling and rotation information, the point
symbol is scaled and rotated as specified.
If a description key match is not found, the point is created without a point style or point label style. The
point is displayed using point group styles. For more information, see Controlling the Appearance of Points
in a Drawing (page 454).
For more information about working with description keys, see Understanding Description Keys (page 571).
To use description keys when creating points
1 Create one or more description key sets containing the description keys you want to use to create the
points. For more information, see Creating Description Keys (page 584).
2 Specify the description key sets search order. For more information, see Changing the Description Key
Sets Search Order (page 582).
3 In the Point Creation settings, for Prompt For Descriptions select Manual. For more information, see
Editing the Default Point Creation Settings (page 444).
4 Specify the setting that indicates whether your description keys use parameters. See Controlling Whether
Raw Description Values Are Interpreted as Parameters During Point Creation (page 573).
5 Click Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Point Creation Tools

.

6 Expand the Create Points (page 2357) dialog box. Expand Points Creation and set the Disable Description
Keysvalue to True.
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7 Click a command on the toolbar. Follow the prompts to create a point.
8 When prompted for a description, enter the leading element of a raw description that matches the code
specified in one of your description keys. If your description key requires parameters to complete the
full description or to rotate or translate the symbol, enter the parameters, separated by spaces.
The point is drawn using the properties specified in the description key, such as point style, point label
style, and layer.

Using Description Keys When Importing Points from a File
You can use description keys when you import points into a drawing.
Create drawing points by importing point data from a point data file, which can be either an ASCII text file
or a Microsoft® Access database (.mdb) file. For more information about creating points by importing, see
Importing Point Data (page 533).
When you import points from a point data file and description key matching is active, the raw descriptions
in the point data file are used for matching. For each point that is imported, the leading element in its raw
description is compared to each description key code in every description key set in the drawing until either
a match is found or all description key sets have been searched.
If a match is found, the point style, the point label style, and the layer specified in the description key are
used to create the point in the drawing. The raw description for the point is translated into a full description
using the format specified in the description key. If the raw description includes scaling and rotation
information, the point symbol is scaled and rotated as specified.
If a description key match is not found, the point is created without a point style or point label style, and
the point displays using point group styles. For more information, see Controlling the Appearance of Points
in a Drawing (page 454).
For more information about working with description keys, see Understanding Description Keys (page 571).
To use description keys when importing points from a file
1 Create one or more description key sets containing the description keys you want to use when importing
the points. For more information, see Creating Description Keys (page 584).
2 Specify the description key sets search order. For more information, see Changing the Description Key
Sets Search Order (page 582).
3 Specify the setting that indicates whether or not your description keys use parameters. For more
information, see Controlling Whether Raw Description Values Are Interpreted as Parameters During
Point Creation (page 573).
4 Click Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Point Creation Tools

.

5 Expand the Create Points (page 2357) dialog box.
6 Expand Points Creation and set the Disable Description Keysvalue to False. On the Points Creation
toolbar, clickImport Points

.

7 In the Format list, specify a format name.
8 Import the points. For more information, see Importing Point Data (page 533).
Any point with a raw description that matches a description key is created in the drawing using the
properties specified in the description key, such as point style, point label style, and layer.
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Using Description Keys to Include Points in a Point Group
Use description key codes to include points in a point group.
You can include points in a point group based on description key matching. Use the Raw Desc Matching
tab in the Point Group Properties dialog box to specify the description keys a point can match to be included
in the point group. For more information, see Raw Desc Matching Tab (Point Group Properties Dialog Box)
(page 2349).
You can also use either the raw description or the full description for a point to either include or exclude
points from a point group. For more information, see Include Tab (Point Group Properties Dialog Box) (page
2349) and Exclude Tab (Point Group Properties Dialog Box) (page 2350).

Creating a New Description Key Set
Use the Settings tree to create a description key set.
A description key set must have at least one description key in it. When you open a newly created description
key set with the DescKey Editor, a starting description key is automatically added to the description key set.
To create a new description key set
1 In Toolspace, on the Settings tab, expand the Point collection.
2 Right-click the Description Key Sets collection. Click New.
3 In the Description Key Set (page 2368) dialog box, enter a name and description for the description key
set.
4 Click OK.
The description key set is created.
5 Right-click the new description key set. Click Edit Keys.
6 In the Description Key Editor (page 2368), edit the properties of the starting description key.
7 Add additional description keys to the description key set. For more information, see Creating a New
Description Key (page 584).

Quick Reference
Toolspace Shortcut Menu
Settings tab: right-click Description Key Sets collection ➤ New
Command Line
CreateDescKeySet
Dialog Box
Description Key Set (page 2368)

Importing a Description Key Set from AutoCAD Land Desktop
Import a description key set from AutoCAD Land Desktop.
You can import description key sets that you created in AutoCAD Land Desktop to use with COGO points.
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To import a description key
1 Click Insert tab ➤ Import panel ➤ Land Desktop

.

2 In the Import Data From Autodesk Land Desktop Project dialog box, enter the Land Desktop Project
Path and the Project name.
3 Select the Description Keys check box and click OK.

Quick Reference
Ribbon
Click Insert tab ➤ Import panel ➤ Land Desktop
Menu
File menu Import ➤ Import Data From Land Desktop

Creating a Description Key Set Based on an Existing Description Key Set
Use the Settings tree to copy a description key set.
When you create a copy of a description key set, the new description key set contains a copy of all the
description keys in the original set.
To create a description key set based on an existing description key set
1 In Toolspace, on the Settings tab, expand the Point collection.
2 Expand the Description Key Sets collection.
3 Right-click the description key set you want to copy. Click Copy.
A copy of the description key set is created. Its name is based on the name of the existing description
key set.
4 Right-click the new description key set. Click Properties.
5 In the Description Key Set (page 2368) dialog box, enter a name and description for the new description
key set.
6 Click OK.
7 Right-click the new description key set. Click Edit Keys.
8 In the Description Key Editor (page 2368), edit the description keys in the new description key set.

Quick Reference
Toolspace Shortcut Menu
Settings tab: Right-click Description Key Sets item ➤ Copy

Changing the Description Key Sets Search Order
Specify the order in which description key sets are searched for matching description keys.
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The Description Key Sets Search Order dialog box contains a list of description keys. The first description
key set on the list is searched first, and the rest of the description key sets are searched sequentially in order,
ending with the last description key set on the list.
To change the search order of description key sets
1 In Toolspace, on the Settings tab, expand the Point collection.
2 Right-click the Description Key Sets collection. Click Properties.
3 In the Description Key Sets Search Order (page 2368) dialog box, click the name of a description key set
to select it.
4 Click

or

to move the point group up or down in the search order.

5 Click OK.

Quick Reference
Toolspace Shortcut Menu
Settings tab: right-click Description Key Sets collection ➤ Properties
Command Line
ShowDescKeySetsList
Dialog Box
Description Key Sets Search Order (page 2368)

Renaming a Description Key Set
Use the Settings tree to rename a description key set.
The new name does not affect the description keys contained within the set or the position of the description
key set within the search order.
To rename a description key set
1 In Toolspace, on the Settings tab, expand the Point collection.
2 Expand the Description Key Sets collection.
3 Right-click the description key set you want to rename. Click Properties.
4 In the Description Key Set (page 2368) dialog box, enter a new name for the description key set.
5 Optionally, enter a description.
6 Click OK.

Quick Reference
Toolspace Shortcut Menu
Settings tab: Right-click Description Key Sets item ➤ Properties
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Deleting a Description Key Set
Use the Settings tree to delete a description key set.
When you delete a description key set, all the description keys in the description key set are deleted.
For information about deleting an individual description key, see Deleting a Description Key (page 591).
To delete a description key set
1 In Toolspace, on the Settings tab, expand the Point collection.
2 Expand the Description Key Sets collection.
3 Right-click the description key set you want to delete. Click Delete.
4 Click Yes.

Quick Reference
Toolspace Shortcut Menu
Settings tab: right-click Description Key Sets item ➤ Delete

Printing Description Keys
Use the Copy to Clipboard command to either print a list of the description key sets in a drawing or to print
a list of the description keys contained within an individual description key set.
To print a list of the description key sets in a drawing, click the Description Key Sets collection in the Settings
tree to display a list view that contains the description key sets in the drawing. Right-click in the list view
to display a shortcut menu. Use the Copy to Clipboard command to copy the contents of the list view into
a file you can print.
To print a list of the description keys in a description key set, click the description key set in the Settings
tree to display a list view that contains the description keys in the description key set. Right-click in the list
view to display a shortcut menu. Use the Copy to Clipboard command to copy the contents of the list view
into a file you can print.
For more information about the Copy to Clipboard command, see Copying Items from a List View (page
103).

Creating Description Keys
You can use the DescKey Editor to create new description keys and to copy description keys.
You can also perform the these operations in the Prospector item view. However, the DescKey Editor, because
it is a separate window, provides more viewing area and greater flexibility in your use of screen space.

Creating a New Description Key
Use the DescKey Editor to create a new description key.
A new description key is always created with default properties. After you create the description key, you
can change the properties.
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To create a new description key
1 In Toolspace, on the Settings tab, expand the Point collection.
2 Expand the Description Key Sets collection.
3 Right-click the description key set to which you want to add the description key. Click Edit Keys.
NOTE You can create a new description key set to which you can add the description key. For more
information, see Creating a New Description Key Set (page 581).
4 In the Description Key Editor (page 2368), right-click in the section that contains description keys. Click
New.
A new description key is created with default properties.
5 If necessary, display the columns that contain the properties you want to edit. Display and hide the
columns in the DescKey Editor as you would in a list view. For more information, see Customizing a
List View (page 101).
6 Edit the description key properties as needed. For more information, see Description Key Editor (page
2368).
7 Close the DescKey Editor.

Quick Reference
Toolspace Shortcut Menu
Settings tab: Description Key Sets ➤ <description key set> ➤ right-click in List View ➤ New

Creating a Description Key Based on an Existing Description Key
Use the DescKey Editor to copy a description key.
Create a copy of a description key within the same description key set. You cannot copy a description key
from one description key set to another.
To create a description key based on an existing description key
1 In Toolspace, on the Settings tab, expand the Point collection.
2 Expand the Description Key Sets collection.
3 Right-click the description key set to which you want to add the description key. Click Edit Keys.
4 In the Description Key Editor (page 2368), right-click the description key you want to copy. Click Copy.
A copy of the description key is created.
5 If necessary, display the columns that contain the properties you want to edit in the new description
key. Display and hide the columns in the DescKey Editor as you would in a list view. For more
information, see Customizing a List View (page 101).
6 Edit the properties of the new description key as needed. For more information, see Description Key
Editor (page 2368).
7 Close the DescKey Editor.
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Quick Reference
Toolspace Shortcut Menu
Settings tab: Description Key Sets ➤ <description key set> ➤ right-click in List View ➤ Copy

Example: Creating a Basic Description Key
This example shows how to create and use a basic description key.
In this example, you create a description key that is used to create utility pole points that have raw descriptions
with a prefix of UP, for example, UP5A and UP4B. When these points are created in the drawing, they are
displayed with the same symbol and layer. Each point maintains its individual description.
This example shows how to use a wild card character in the description key code so that a single description
key matches any point whose raw description begins with the prefix UP.
As you work through this example, you might want more information about the contents of the columns
in the DescKey Editor. For more information, see Description Key Editor (page 2368).
Example: Creating a basic description key
1 Before you begin, create a point style named UP_Symbol to be used to display the utility pole points
created in this example. For more information, see Point Styles (page 449).
2 In Toolspace, on the Settings tab, expand the Point collection.
3 Right-click the Description Key Sets collection. Click New.
4 For Name, enter UP_Example. Click OK.
A description key set named UP_Example is created and is listed in the Settings tree under the Description
Key Sets collection.
5 Right-click UP_Example. Click Edit Keys.
The DescKey Editor is opened. If you cannot see the DescKey Editor, click
tab to display the Panorama window.

at the top of the Settings

If you cannot see the column headings mentioned in the following steps, use the column heading
shortcut menu to display or expand the column headings. You display and hide the columns in the
DescKey Editor as you would in a list view. For more information, see Customizing a List View (page
101).
6 In the DescKey Editor, click in the first cell under the Code column heading. Enter UP* for the code.
The asterisk (*) indicates that the description key will match any raw description that starts with UP,
such as UP5A and UP5B.
7 Under the Point Style column heading, select the check box and click in the cell. In the Point Style
dialog box, select UP_Symbol. Click OK.
The UP_Symbol style will be used to display the symbol for points that match the description key you
are creating.
8 Under the Point Label Style column heading, make sure that the check box is selected and that the
Standard style is specified. The Standard style labels the point with point number, point elevation, and
full description.
9 Click in the cell under the Format column heading, and enter $*.
The dollar sign asterisk ($*) format means that the full description and raw description for the point
will be the same.
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If you wanted, you could enter text, such as UTILITY POLE, which would be used as the full description
for all points with a raw description beginning with UP, or you could assign a format that creates a full
description from the raw description. For more information, see Description Key Format (page 576).
10 Under the Layer column heading, select the check box. Click in the cell and create a layer named
PTS_UP.
11 Clear the check boxes under all other column headings.
A point created using this description key will be placed on the PTS_UP layer.
12 Close the DescKey Editor.
13 If you have multiple description key sets defined, move the UP_Example set to the top of the search
order. For more information, see Changing the Description Key Sets Search Order (page 582).
14 Click Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Point Creation Tools
Points dialog box, click

. In the Create

to expand the dialog box.

15 Expand the Points Creation collection and specify the following settings:
■

For the Prompt For Descriptions, select Manual. For more information, see Editing the Default Point
Creation Settings (page 444)

■

For the Disable Description Keys, set the value to False.

16 From the Miscellaneous command list, select Manual.
17 Pick the location for a new point.
18 Follow the prompts. When you are prompted for the description, enter UP1A.
NOTE Description key matching is case-sensitive, which means that an upper case letter does not match a
lower case occurrence of the same letter. For example, the raw description “UP1A” matches the description
key code “UP*”, but it would does not match “up*” or “Up*”.
19 The point is drawn using the UP_Symbol point style and the Standard point label style. The point is
created on the PTS_UP layer.

Example: Using Description Key Parameters to Create a Full Description
This example shows how to use parameters in a description key format to translate a raw description into
a full description.
NOTE The following paragraphs are intended to help you understand this example. They do not provide a
complete overview of description keys. For general information about description keys, see Understanding
Description Keys (page 571). Before beginning this example, you should complete the example that shows you
how to create a basic description key. For more information, see Example: Creating a Basic Description Key (page
586).
When you create a point, the description you enter at the command line is the raw description for the point.
The raw description can consist of one element, such as UP5A, or of more than one element, such as UPNO
104. The leading element in a raw description is compared against description key codes during description
key matching. The remaining elements in the raw description are called parameters. You can use parameters
to create a full description for all points that match the description key.
In this example, you will create a description key that translate a raw description in the form UPNO <pole
number> to a full description in the form U_POLE <pole number>. For example, the field (raw) description
UPNO 104 will be translated to the full (drawing) description U_POLE 104.
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In the raw description UPNO 104, UPNO is used to match the description key code and 104 is the first
parameter. For more information, see Description Key Format (page 576).
Example: Using description key parameters to create a full description
1 In Toolspace, on the Settings tab, right-click the Description Key Sets collection. Click New.
2 For Name, enter Format_Example. Click OK.
A description key set named Format_Example is created.
3 Right-click Format_Example. Click Edit Keys.
The DescKey Editor is opened. If you cannot see the DescKey Editor, click
tab to display the Panorama window.

at the top of the Settings

If you cannot see the column headings mentioned in the following steps, use the column headings
shortcut menu to display or expand the column headings. You display and hide the columns in the
DescKey Editor the same way you display and hide the columns in a list view. For more information,
see Customizing a List View (page 101).
4 In the DescKey Editor, click in the first cell under the Code column heading, and enter UPNO for the
code.
The code will match any raw description whose leading element is UPNO.
5 Under both Point Style and Point Label Style heading columns, select the check boxes. Verify that the
Standard style is specified.
NOTE The Standard point label style displays a full description for the point.
6 Click in the cell under the Format column heading, and enter U_POLE $1.
$1 refers to the first parameter in the raw description. This format will translate the raw description
“UPNO 104” to the full description “U_POLE 104.” For more information, see Description Key Format
(page 576).
7 Under the Layer column heading, select the check box, click in the cell and create a layer named
UP_LAYER. A point created using this description key will be placed on the UP_LAYER layer.
8 Clear the check boxes under all other column headings.
9 Close the DescKey Editor.
10 If you have multiple description key sets defined, move the Format_Example description key set to the
top of the search order. For more information, see Changing the Description Key Sets Search Order
(page 582).
11 Click Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Point Creation Tools
12 In the Create Points dialog box, click

.

to expand the dialog box.

13 Expand the Points Creation collection and specify the following settings:
■

For the Prompt For Descriptions, select Manual. For more information, see Editing the Default Point
Creation Settings (page 444)

■

For the Match on Description Parameters ($1, $2, etc.) select True. For more information, see
Controlling Whether Raw Description Values Are Interpreted as Parameters During Point Creation
(page 573).

■

For the Disable Description Keys, set the value to False.

14 From the Miscellaneous command list, select Manual.
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15 Pick the location for a new point.
16 Follow the prompts. When you are prompted for the description, enter UPNO 104.
The point is drawn using the full description derived from the description key, U_POLE 104.

Example: Using Description Key Parameters to Format a Full Description and Scale
a Point Symbol
This example shows how to use description key parameters to both expand the raw description for a point
and to scale a point symbol.
NOTE The following paragraphs are intended to help you understand this example. They do not provide a
complete overview of description keys. For an overview of description keys, see Understanding Description Keys
(page 571). Before beginning this example, you should complete the example that shows you how to create a
basic description key. For more information, see Example: Creating a Basic Description Key (page 586).
When you create a point, the description you enter at the command line is the raw description for the point.
The raw description can consist of one element, such as TREE, or it can consist of more than one element,
such as TREE OAK 7. The leading element in a raw description is compared against description key codes
during description key matching. The remaining elements in the raw description are called parameters. You
can use parameters to create a full description for a point or to rotate or scale a point.
In this example, you create a description key that translates a raw description with the format TREE <tree
type> <tree size> into a full description that reads: <tree size> inch <tree type> tree, and you will scale the
point symbol using the <tree size> value. For example, the raw description TREE OAK 7 will be translated
to a full description 7 inch OAK tree. The point symbol will be scaled using a value of 7.
In the raw description TREE OAK 7, OAK is the first parameter and 7 is the second parameter. For more
information, see Description Key Format (page 576).
Example: Using parameters to format a full description and scale a point symbol
1 Before you begin, create a point style named Tree_Symbol which will display the tree points created in
this example. For more information, see Creating a Point Style (page 450).
2 In Toolspace, on the Settings tab, right-click the Description Key Sets collection. Click New.
3 For Name, enter Param_Example. Click OK.
A description key set named Param_Example is created.
4 Right-click Param_Example. Click Edit Keys.
The DescKey Editor is displayed. If you cannot see the DescKey Editor, click
tab to display the Panorama window.

at the top of the Settings

If you cannot see the column headings mentioned in the following steps, you may need to use the
column headings shortcut menu to display them, or you may need to expand the column headings.
You display and hide the columns in the DescKey Editor as you would in a list view. For more
information, see Customizing a List View (page 101).
5 In the DescKey Editor, click in the first cell under the Code column heading, and enter TREE for the
code.
The code will match any point raw description whose leading element is TREE.
6 Under the Point Style column heading, select the check box and click in the cell. In the Point Style
dialog box, select Tree_Symbol. Click OK.
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7 Under the Point Label Style column heading, select the check box. Verify that the Standard point label
style is specified.
8 Click in the cell under the Format column heading, and enter $2 inch $1 Tree.
$2 refers to the second parameter in the raw description. $1 refers to the first parameter in the raw
description. This format will translate the raw description “TREE OAK 7” into the full description “7
inch OAK tree.”
For more information, see Description Key Format (page 576).
9 Under the Layer column heading, select the check box. Click in the cell and create a layer named
PTS_TREE. A point created using this description key will be placed on the PTS_TREE layer.
10 Under Apply To X-Y, select the check box.
11 Under Apply To Z, select the check box.
12 Under Scale Parameter, select the check box.
13 Under Scale Parameter, select the check box. Select Parameter 2.
Parameter 2 refers to the second parameter in the raw description, which is 7 in this example. This
specifies that the second parameter in a description contains the value by which the point symbol is
scaled.
14 Clear the check boxes under all other column headings.
15 Close the DescKey Editor.
16 If you have multiple description key sets defined, move the Param_Example description key set to the
top of the search order. For more information, see Changing the Description Key Sets Search Order
(page 582).
17 Click Home tab ➤ Create Ground Data panel ➤ Points menu ➤ Point Creation Tools
18 In the Create Points dialog box, click

.

to expand the dialog box.

19 Expand the Points Creation collection and specify the following settings:
■

For the Prompt For Descriptions, select Manual. For more information, see Editing the Default Point
Creation Settings (page 444)

■

For the Match on Description Parameters ($1, $2, etc.), select True. For more information, see
Controlling Whether Raw Description Values Are Interpreted as Parameters During Point Creation
(page 573).

■

For the Disable Description Keys, set the value to False.

20 From the Miscellaneous command list, select Manual.
21 Pick the location for a new point.
22 Follow the prompts. When you are prompted for the description, enter TREE OAK 7.
A point is drawn and labeled with the full description 7 inch OAK tree, and the tree symbol is scaled.
23 Create another point, and specify TREE OAK 5 for the raw description to see the impact on the full
description and the scaled symbol.

Editing Description Keys
You can use the DescKey Editor to edit and delete description keys.
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To edit a description key, you must open the description key set that contains the description key.
The DescKey Editor is displayed as a vista (a tab) in the Panorama window. For more information about
working with vistas, see The Panorama Window (page 119).
The DescKey Editor displays the description keys in a grid. Each row in the grid contains a description key.
The columns contain the description key properties. You display and hide the columns in the DescKey Editor
as you would in a list view. For more information, see Customizing a List View (page 101).
For a complete description of each column in the DescKey Editor, see Description Key Editor (page 2368).
NOTE You can edit description keys in the Prospector item view. However, the DescKey Editor, because it is a
separate window, provides you with more viewing area and greater flexibility in your use of screen space.

Opening the Description Key Editor
Use the Settings tree to open the DescKey Editor.
Before you can open the DescKey Editor, you must select a description key set to edit. The DescKey Editor
displays all the description keys in the selected description key set.
NOTE You can also edit description keys in the Prospector item view. However, the DescKey Editor, because it is
a separate window, provides you more viewing area and greater flexibility in your use of screen space.
To open the Description Key Editor
1 In Toolspace, on the Settings tab, expand the Description Key Sets collection.
2 Right-click the description key set you want to edit. Click Edit Keys.
3 Use the Description Key Editor (page 2368) to edit the individual description keys.

Quick Reference
Toolspace Shortcut Menu
Settings tab: Right-click Description Key Sets item ➤ Edit Keys
Dialog Box
Description Key Editor (page 2368)

Deleting a Description Key
Use the DescKey Editor to delete a description key from a description key set.
For information about deleting an entire description key set, see Deleting a Description Key Set (page 584).
To delete a description key
1 In Toolspace, on the Settings tab, right-click the description key set that contains the description key
you want to delete. Click Edit Keys.
2 In the Description Key Editor (page 2368), right-click the description key you want to delete. Click Delete.
3 Close the DescKey Editor.
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Quick Reference
Toolspace Shortcut Menu
Settings tab: Description Key Sets ➤ <description key set> ➤ right-click in List View ➤ Delete
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Point Clouds

18

In AutoCAD Civil 3D 2011, you can create a point cloud object and manipulate its style and display properties.

Using LiDAR Data to Create Point Clouds
Use data obtained from LiDAR (Light Detection and Ranging) scanning to create point cloud objects in
AutoCAD Civil 3D.
The LiDAR technology is used to obtain the terrain elevation data. Airborne and terrestrial LiDAR sensors
are used for scanning the earth surface. The resulting data is stored in files called point clouds. A point cloud
is a collection of 3D data that represents ground, vegetation, building models, water, and other natural and
man-made objects.

Point Cloud File Formats
Point cloud data is commonly stored in binary LAS (.las), text ASCII XYZ (.xyz), and a number of other file
formats. The LAS format is a public file format for point cloud data exchange and is a standard established
by ASPRS (American Society of Photogrammetry and Remote Sensing).

LiDAR Classification Scheme
In AutoCAD Civil 3D, you can stylize the point cloud data using the LiDAR classification scheme to filter
data on more specific features of the scanned area. The following table lists the default LAS classification
values according to the ASPRS LAS specification:
0

Created, never classified

1

Unclassified

2

Ground

3

Low Vegetation

4

Medium Vegetation

5

High Vegetation

6

Building
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7

Low Point (noise)

8

Model Key-point (mass point)

9

Water

10

Reserved for ASPRS Definition

11

Reserved for ASPRS Definition

12

Overlap Points

13-31

Reserved for ASPRS Definition

See also:
■

Displaying and Stylizing Point Clouds (page 598)

Understanding Point Cloud Objects
A point cloud is a AutoCAD Civil 3D object created by importing 3D point data.
When you import a point cloud source data file, AutoCAD Civil 3D processes this data and creates an external
point cloud database. The point cloud database is a collection of three files: .iati, .isd, and .prmd. The ISD
(.isd) file format is the primary point cloud database format.

Point Cloud Components
A AutoCAD Civil 3D point cloud object contains the following components.
■

Bounding box. The size and geometry of the bounding box component depend on the point cloud object
minimum and maximum coordinate values. The bounding box serves as a point cloud object proxy
when the point cloud source data is not accessible.

■

Point cloud points. This component represents the data points that build the point cloud object.
You can control the appearance of both point cloud components using the point cloud style settings.
The bounding box display properties include Visibility, Layer, Color, Linetype, LT Scale, Lineweight, and
Plot Style. The properties that are applicable to the point cloud points component include Visibility,
Layer, and Density. See Displaying and Stylizing Point Clouds (page 598).

The following illustrations show the different views and the basic components of a point cloud object.
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The isometric view of a point cloud object shows the following point cloud components:
1 - Bounding box 2 - Point cloud point data

The front view of a point cloud object.
1 - Maximum Z-coordinate 2 - Minimum Z-coordinate
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The top view of a point cloud object.
1 - Minimum X-coordinate 3 - Maximum X-coordinate
2 - Maximum Y-coordinate 4 - Minimum Y-coordinate

Point Cloud Collection (Prospector Tab)
Use the Point Cloud collection in the Prospector tree to access point clouds in a drawing. As point cloud
objects are created, they are displayed as named point clouds under the Point Clouds collection.
You can:
■

Right-click the Point Cloud collection to create point cloud objects (page 596).

■

Right-click a named point cloud object to:modify point cloud properties (page 601),edit point cloud style
and display properties (page 598),add points to point clouds (page 599),add points to new or existing
surfaces, (page 600)add and remove Civil 3D properties from point cloud objects (page 602).

Creating Point Cloud Objects
AutoCAD Civil 3D processes point cloud database files to create a point cloud object.
You can manipulate the created point cloud as a common Civil object: add and remove properties, modify
styles for better feature visualization, snap to points, and use it to create TIN surfaces.
To create a point cloud object
1 Click Home tab ➤ Create Ground Data panel
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Create Point Cloud

.

2 On the Information (page 2380)page of the Create Point Cloud wizard, enter the required information
about the new point cloud object.
3 Select the standard style or, optionally, click

to create a new style,

to copy the existing style, or

to edit the current style. Click Next.
4 On the Source Data page (page 2380), specify the type of source data to use:
■

Select Create a New Point Cloud Database to create a point cloud object from the point cloud source
files.

■

Select Use an Existing Point Cloud Database to use the point cloud database file that exists on your
system or network.
NOTE For best results, use an existing point cloud database on a local file system.

5 If you use a new source file, select a point cloud file format and click
to add point cloud source files
to the import list. You can select multiple files of the specified file format.
Click

to remove files from the import list.

6 If you use an existing point cloud database file as a source, click

and select an ISD (.isd) file.

7 Click Next.
Optionally, click Finish to start creating a point cloud database file.
8 On the Summary page (page 2381), review the properties assigned to the new point cloud object.
9 Click Finish.
NOTE Depending on the size of the source file, the process of generating a point cloud database file may
take several minutes. You can continue working while a new point cloud database file is being created.
View the point cloud icon in the lower right corner for the status of the point cloud database file creation
process.

NOTE You cannot add points if another add point or point cloud creation operation is running in the same
drawing.
10 When you receive notification that the new point cloud database was created, click the Click Here to
Zoom link on the notification bubble to display the point cloud object.

Quick Reference
Toolbox
Home tab ➤ Create Ground Data panel

Create Point Cloud

Toolspace Shortcut Menu
Prospector tab: right-click Point Clouds collection ➤ Create Point Cloud
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Command Line
CreatePointCloud
Dialog Boxes
Create Point Cloud wizard (page 2379)

Displaying and Stylizing Point Clouds
Apply style settings to create a realistic 3D model of the area represented by the point cloud data. Additionally,
control the point cloud density in the drawing view.
Point cloud styles control the elements that define point cloud appearance in the drawing, including point
size, color, LiDAR classification scheme, and display of the point cloud components.

Modifying a Point Cloud Style
You can apply the LiDAR classification style settings to point data as well as other AutoCAD Civil 3D style
settings to create a realistic view of the point cloud data.
To modify a point cloud object style
1 Open the drawing that contains a point cloud object.
2 Select a point cloud or click Modify tab ➤ Ground Data panel ➤ Point Cloud

.

3 Click Point Cloud tab ➤ Modify panel ➤ Point Cloud Properties drop-down ➤ Edit Point Cloud Style
.
4 On the Information (page 2381)page of the Point Cloud Style dialog box, enter the style name and
description.
5 On the Points page (page 2381), modify the settings specific to point data, such as point size, colors, and
elevation ranges.
NOTE To use the LiDAR point classification scheme, in the Color section, specify Classification as the value
for the Assign Color By property.
6 On the Classification page (page 2383), select the required LiDAR point classes, click
and select a color
to assign to the point class. You can also assign points of a specific classification to separate layers.
7 On the Display page (page 2383), specify:
■

Point cloud view direction. Select Plan for 2D view display and Model for 3D view display.

■

Point cloud component display. Specify visibility settings and line properties

.On the Summary page (page 2383), review and, if required, modify the point cloud style settings.
8 Click Apply and OK.
The model regenerates and displays with the new point cloud style settings.

Modifying Point Cloud Display-view Density
AutoCAD Civil 3D enables you to control the density of a point cloud object, that is the number of points
displayed at once for all point clouds in the drawing view.
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To modify a point cloud density in the drawing view
1 Select a point cloud or click Modify tab ➤ Ground Data panel ➤ Point Cloud

.

2 On the Point Cloud tab, move the point density slider to increase or decrease the number of displayed
points.
NOTE The displayed value is the percentage of 1.5 million points, which is the maximum number of points
that can exist in a drawing, regardless of the number of point clouds in the drawing.
3 To ensure point clouds are regenerated automatically after any manipulation, select Auto Update.
See also:
■

POINTCLOUDDENSITY and POINTCLOUDAUTOUPDATE in the AutoCAD User’s Guide.

Quick Reference
Ribbon
Select a point cloud object. Click Point Cloud tab ➤ Modify panel ➤ Point Cloud Properties
drop-down ➤ Edit Point Cloud Style
Toolspace Shortcut Menu
Prospector tab: Expand Point Clouds collection ➤ right-click <point cloud object> ➤ Edit Point Cloud Style
Command Line
EditPointCloudStyle
PointCloudDensity
Dialog Box
Point Cloud Style (page 2381)

Adding Points to a Point Cloud Database
Add points to an existing point cloud objects from a specified source file or point cloud database.
You can add more points from one or several point cloud source files or from existing point cloud databases
to the point cloud object.
NOTE You cannot add points if another add point or point cloud creation operation is running in the same
drawing.
To add points to an existing point cloud database file
1 Select a point cloud or click Modify tab ➤ Ground Data panel ➤ Point Cloud
2 Click Point Cloud tab ➤ Modify panel ➤ Add Points

.

.

3 In the Add Points (page 2385) dialog box, specify the point cloud file format.
4 Click
and select one or several point cloud source files. By default, only files of the specified format
are visible.
5 Click Open. The files are added to the import list.
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6 Click OK.
Depending on the source file size, the process may take up to several minutes. You can continue using
AutoCAD Civil 3D while the new file is added to the existing point cloud. You are notified when the process
is complete.

Quick Reference
Ribbon
Select a point cloud object. Click Point Cloud tab ➤ Modify panel ➤ Add Points
Toolspace Shortcut Menu
Prospector tab: Expand Point Clouds collection ➤ right-click <point cloud object> ➤ Add Points
Command Line
AddPointCloudPoints
Dialog Box
Add Points (page 2385)

Adding Point Cloud Points to Surfaces
Use the existing point cloud object points to add points to existing surfaces or create new TIN surfaces.
You can specify points to be extracted by specifying point cloud regions. The created surface references the
source point cloud object. Any changes to the point cloud object will render the surface definition out of
date, and the out-of-date icon is displayed next to the surface node in the Prospector tree.
To automatically rebuild the surface to apply point cloud changes, select Auto Update on the Point Cloud
Tools panel.
To add point cloud points to an existing surface or create a new surface
1 Open a drawing with a point cloud object.
2 Select the point cloud object or click Modify tab ➤ Ground Data panel ➤ Point Cloud

.

NOTE To create an accurate TIN surface, you may not need to keep the default object density. If the point
cloud is too dense, drag the Point Density slider to decrease the density value.
3 Click Point Cloud tab ➤ Point Cloud Tools panel ➤ Add Points to Surface

.

4 On the Surface Options (page 2385) page of the Add Points to Surface wizard, do one of the following:
■

To create a TIN surface, select Add Points to a New Surface.

■

To add points to an existing surface, select Add Points to an Existing Surface. This option is
unavailable if there are no surfaces in the current drawing.

5 If you selected Add Points to a New Surface, specify the surface name, enter the required description,
and apply a style to the surface.
6 Click Next.
7 On the Region Options page (page 2386), specify a point cloud region option.
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8 If you selected Point Cloud Extents, click Next. All points within the point cloud boundary are used in
surface creation.
9 If you selected Window, Window Polygon, or Object, click Define Region in Drawing and specify the
point cloud region in the drawing. Press Enter.
10 Click Next to view a summary of the Add Points operation or, optionally, click Finish.
A surface is created and a the surface name is displayed under the Surfaces collection in the Prospector
tree.
The following drawing shows a 3D view of a TIN surface created from a point cloud region specified using
the Window Polygon option.

Quick Reference
Ribbon
Select a point cloud object. Click Point Cloud tab ➤ Point Cloud Tools panel ➤ Add Points to Surface
Toolspace Shortcut Menu
Prospector tab: Expand Point Clouds collection ➤ right-click <point cloud object> ➤ Add Points to Surface
Command Line
AddPointsToSurface
Dialog Box
Add Points to Surface wizard (page 2385)

Modifying Point Cloud Properties
Use the Point Cloud Properties dialog box to view and edit the point cloud object properties.
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Point cloud properties control the basic information about the point cloud object, such as name and
description. The properties also display the source files and the external point cloud database that constitute
the point cloud, enable you to configure elevation range color schemes, and view the point cloud object
statistics.
NOTE You can remove the AutoCAD Civil 3D properties from a point cloud object using a single command. See
Adding and Removing AutoCAD Civil 3D Properties from Point Cloud Objects (page 602).
To modify the properties of an existing point cloud object
1 Select the point cloud object or click Modify tab ➤ Ground Data panel ➤ Point Cloud

.

2 Click Point Cloud tab ➤ Modify panel ➤ Point Cloud Properties drop-down ➤ Point Cloud Properties
.
3 In the Point Cloud Properties dialog box, click the Statistics tab to review the current point cloud object
properties.
4 On the Information page, modify the point cloud name, description, and style and specify tooltip
display preferences.
5 On the Definition page, select a different point cloud database file.
6 On the Elevation Ranges page, modify the point elevation range values. You can:
■

Enter minimum and maximum values and click Update Range Details.

■

Click Reset from Style to apply the values specified in style settings.

■

Under Range Details, view the details of the current elevation range settings.

7 Click Apply and then click OK.

Quick Reference
Ribbon
Select a point cloud object. Click Point Cloud tab ➤ Modify panel ➤ Point Cloud Properties
drop-down ➤ Point Cloud Properties
Toolspace Shortcut Menu
Prospector tab: Point Clouds ➤ right-click <point cloud name> ➤ Point Cloud Properties
Command Line
EditPointCloudProperties
Dialog Box
Point Cloud Properties (page 2383)

Adding and Removing AutoCAD Civil 3D Properties from Point
Cloud Objects
Remove AutoCAD Civil 3D properties from a point cloud object to prepare the object for use in AutoCAD
or an AutoCAD-based application, such as AutoCAD Map 3D.
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NOTE AutoCAD Civil 3D point clouds properties have some distinct characteristics compared to AutoCAD and
AutoCAD Map 3D point cloud objects. The main difference is how the point cloud objects are stylized and displayed
in the drawing. For example, the AutoCAD point cloud object is displayed with the properties of the layer where
it resides, whereas AutoCAD Civil 3D and AutoCAD Map 3D point clouds can be displayed using the LiDAR point
classification scheme (page 593). Another difference between the AutoCAD and AutoCAD Civil 3D point cloud
object is in the ability of the latter to recognize the coordinate system information of the source data and transform
it at the point cloud database creation time.
For more information about AutoCAD and AutoCAD Map 3D point cloud objects, see respective topics in the
AutoCAD User’s Guide and Map 3D User’s Guide.
When you perform this command, AutoCAD Civil 3D removes the point cloud name, description, and any
style settings that you applied when creating the point cloud object. As a result, the point cloud displays
only the default subset of points.
Before

After

To remove AutoCAD Civil 3D properties from a point cloud object
1 In the drawing, select a point cloud object or click Modify tab ➤ Ground Data panel ➤ Point Cloud
.
2 Click Point Cloud tab ➤ Modify panel

Remove C3D Properties

.

3 Select a point cloud.
4 In the message box, click Yes.
The selected point cloud object is displayed without the AutoCAD Civil 3D properties.
NOTE The point cloud object icon in the prospector tree changes to

.

You can reverse this operation and add the removed AutoCAD Civil 3D properties to the point cloud object.
To add AutoCAD Civil 3D properties to a point cloud object
1 In the drawing, select a point cloud object or click Modify tab ➤ Ground Data panel ➤ Point Cloud
.
2 Click Point Cloud tab ➤ Modify panel

Add Civil 3D Properties

.

3 In the message box, click Yes.
4 In the Point Cloud Properties dialog box, review and, optionally, modify the current object properties.
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5 Click OK.

Quick Reference
Ribbon
Select a point cloud object. Click Point Cloud tab ➤ Modify panel

Remove C3D Properties

Select a point cloud object. Click Point Cloud tab ➤ Modify panel

Add Civil 3D Properties

Toolspace Shortcut Menu
Prospector tab: Point Clouds ➤ right-click <point cloud name> ➤ Remove Civil 3D Properties / Add Civil
3D Properties
Command Line
RemoveCivil3DProperties
AddCivil3DProperties

Point Cloud Command Reference
Quickly access point cloud functionality from the command line.
Command

Description

AddCivil3DProperties

Adds Civil 3D properties to a point cloud object. (page
602)

AddPointCloudPoints

Adds points to a point cloud database using the existing
point cloud object. (page 599)

AddPointsToSurface

Creates a TIN surface from point cloud points. (page
600)

CreatePointCloud

Creates a Point Cloud object. (page 596)

EditPointCloudProperties

Opens the Point Cloud Properties dialog box to edit
object properties. (page 601)

EditPointCloudStyle

Displays the Point Cloud Style dialog box to edit object
styles. (page 598)

PointCloudAutoUpdate

Enables point cloud automatic updates after object
manipulations. (page 598)

PointCloudDensity

Controls the number of displayed point cloud points.
(page 598)

PointCloudRTDensity

Improves performance by decreasing the number of
displayed point cloud points when performing drawing
zoom, pan,and object navigation operations. (page 598)

RemoveCivil3DProperties

Removes Civil 3D properties from a point cloud object.
(page 602)
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Lines and Curves

Many commands for creating lines and curves are included in AutoCAD Civil 3D.

Creating Lines
You can use the AutoCAD Civil 3D line creation commands to draft line geometry prior to defining it as
alignments or parcels, for example.
Several of the AutoCAD Civil 3D Line commands are simply the AutoCAD Line combined with an AutoCAD
Civil 3D transparent command. For example, when you run the Line By Bearing command, the AutoCAD
Line command starts, but the ‘BD transparent command also launches so you can immediately enter a
bearing value. For more information on transparent commands, see Transparent Commands (page 1767).

Creating Lines By Selecting a Start and End Point
The Line command on the Home tab ➤ Draw panel launches the AutoCAD LINE command. Use this
command to draw a line by selecting start and end points.
To create a line by selecting a start and end point
1 Click Home tab ➤ Draw panel ➤ Line drop-down ➤ Create Line

.

2 Specify the start point.
You can use the pointing device or enter coordinate values on the command line.
3 Complete the first line segment by specifying the endpoint.
To undo the previous line segment during the Line command, enter U or click Undo on the toolbar.
4 Specify the endpoints of any additional line segments.
5 Press Enter to end or C to close a series of line segments.
6 To start a new line at the endpoint of the last line drawn, start the Line command again and press Enter
at the Specify Start Point prompt.
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Quick Reference
Ribbon
Home tab ➤ Draw panel ➤ Line drop-down ➤ Create Line
Menu
Lines/Curves menu ➤ Create Lines ➤ Line
Command Line
Line

Creating Lines by Specifying a Range of Point Numbers
The Line By Point # Range command runs the AutoCAD Line command combined with the ‘PN transparent
command (page 1777) so you can specify a range of point numbers through which to draw the line.
You can specify a sequence of point numbers by using a comma. For example, the sequence 1-3,7 draws a
line between points 1, 2, 3, and 7.

To create a line by specifying a range of point numbers
1 Click Home tab ➤ Draw panel ➤ Line drop-down ➤ Create Line By Point # Range

.

2 Enter the number of the point at which you want to start the line.
3 Enter a hyphen (-).
4 Enter the number of the point at which you want to end the line segment and press Enter.

Quick Reference
Ribbon
Home tab ➤ Draw panel ➤ Line drop-down ➤ Create Line By Point # Range
Menu
Lines/Curves menu ➤ Create Lines ➤ Line By Point # Range
Command Line
Line, ‘PN
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Creating Lines Through Specified Point Objects
The Line By Point Object command runs the AutoCAD Line command combined with the ‘PO transparent
command (page 1778) so you can select point objects through which to draw the line.
To select the points, you can select any part of the point objects, such as the marker or the label.

To create a line by specifying point objects
1 Click Home tab ➤ Draw panel ➤ Line drop-down ➤ Create Line By Point Object

.

2 Select the start point in the drawing.
3 Select the next point in the drawing.
4 Continue to select points to define additional line segments. Or press Enter to return to the Line
command prompt where you can use additional options to define the line.

Quick Reference
Ribbon
Home tab ➤ Draw panel ➤ Line drop-down ➤ Create Line By Point Object
Menu
Lines/Curves menu ➤ Create Lines ➤ Line By Point Object
Command Line
Line, ‘PO

Creating Lines by Specifying Point Names
The Line By Point Name command runs the AutoCAD Line command combined with the ‘PA transparent
command (page 1779) so you can specify the names of points through which to draw the line.
This command allows you to draw a line between points by specifying their names instead of their point
numbers.
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To create a line by specifying point names
1 Click Home tab ➤ Draw panel ➤ Line drop-down ➤ Create Line By Point Name

.

2 Enter the name of the start point.
3 Enter the name of the next point.
4 Continue to enter point names to define additional line segments. Or press Enter to return to the Line
command prompt where you can use additional options to define the line.

Quick Reference
Ribbon
Home tab ➤ Draw panel ➤ Line drop-down ➤ Create Line By Point Name
Menu
Lines/Curves menu ➤ Create Lines ➤ Line By Point Name
Command Line
Line, ‘PA

Creating Lines by Specifying Northing/Easting Coordinates
The Line By Northing/Easting command runs the AutoCAD Line command combined with the ‘NE transparent
command (page 1775) so you can specify northing and easting coordinates of the line segments.
The order of the prompts is controlled by the Transparent Command Ambient drawing settings.
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To create a line by specifying northing and easting
1 Click Home tab ➤ Draw panel ➤ Line drop-down ➤ Create Line By Northing/Easting

.

2 Enter a northing value.
3 Enter an easting value.
NOTE The order in which you are prompted for northing and easting is controlled by the Transparent
Command setting Prompt For Easting Then Northing, located on the Ambient Settings tab of the Drawing
Settings dialog box. For more information, see Specifying Ambient Settings (page 84).
4 Continue to enter northing and easting values to define the line segments. Or press ESC to return to
the Line command prompt where you can use additional options to define the line.

Quick Reference
Ribbon
Home tab ➤ Draw panel ➤ Line drop-down ➤ Create Line By Northing/Easting
Menu
Lines/Curves menu ➤ Create Lines ➤ Line By Northing/Easting
Command Line
Line, ‘NE

Creating Lines by Specifying Grid Northing/Easting Coordinates
The Line By Grid Northing/Grid Easting command runs the AutoCAD Line command combined with the
‘GN transparent command (page 1776) so you can specify grid northing and easting coordinates of the line
segments.
A coordinate system must be specified in the drawing. The order of the prompts is controlled by the
Transparent Command Ambient drawing settings.

To create a line by specifying grid northing and easting
1 Click Home tab ➤ Draw panel ➤ Line drop-down ➤ Create Line By Grid Northing/Grid Easting

.

2 Enter a grid northing value.
3 Enter a grid easting value.
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NOTE The order in which you are prompted for grid northing and grid easting is controlled by the Transparent
Command setting Prompt For Easting Then Northing, located on the Ambient Settings tab of the Drawing
Settings dialog box. For more information, see Specifying Ambient Settings (page 84).
4 Continue to enter grid northing and easting values to define the line segments. Or press ESC to return
to the Line command prompt where you can use additional options to define the line.

Quick Reference
Ribbon
Home tab ➤ Draw panel ➤ Line drop-down ➤ Create Line By Grid Northing/Grid Easting
Menu
Lines/Curves menu ➤ Create Lines ➤ Line By Grid Northing/Grid Easting
Command Line
Line, ‘GN

Creating Lines by Specifying Latitudes and Longitudes
The Line By Latitude/Longitude command runs the AutoCAD Line command combined with the ‘LL
transparent command (page 1776) so you can specify latitude and longitude coordinates of the line segments.
A coordinate system must be specified in the drawing. The order of the prompts is controlled by the
Transparent Command Ambient drawing settings.

To create a line by specifying latitude and longitude
1 Click Home tab ➤ Draw panel ➤ Line drop-down ➤ Create Line By Latitude/Longitude

.

2 Enter a latitude value.
3 Enter a longitude value.
NOTE The order in which you are prompted for latitude and longitude is controlled by the Transparent
Command setting Prompt For Longitude Then Latitude, located on the Ambient Settings tab of the Drawing
Settings dialog box. For more information, see Specifying Ambient Settings (page 84).
4 Continue to enter latitude and longitude values to define the line segments. Or press ESC to return to
the Line command prompt where you can use additional options to define the line.
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Quick Reference
Ribbon
Home tab ➤ Draw panel ➤ Line drop-down ➤ Create Line By Latitude/Longitude
Menu
Lines/Curves menu ➤ Create Lines ➤ Line By Latitude/Longitude
Command Line
Line, ‘LL

Creating Lines by Specifying Bearings
The Line By Bearing command runs the AutoCAD Line command combined with the ‘BD transparent
command (page 1770) so you can specify a direction and distance for the line segment.
From the start point (1), specify the quadrant (2). Then specify the bearing (3) and distance (4).

To create a line by specifying bearings
1 Click Home tab ➤ Draw panel ➤ Line drop-down ➤ Create Line By Bearing

.

2 Select a temporary start point for the angle measurement by clicking in the drawing or by using the .P,
.N, or .G point filters (page 1787).
3 Specify a quadrant number by either clicking in the drawing or entering a value between 1 and 4.
4 Specify the bearing within the quadrant by clicking in the drawing or entering a bearing using the
angular units for the drawing.
5 Specify the distance by either clicking in the drawing or entering a distance.
6 Continue to specify bearings and distances to define line segments. Or press Enter to return to the Line
command prompt where you can use additional options to define the line.

Quick Reference
Ribbon
Home tab ➤ Draw panel ➤ Line drop-down ➤ Create Line By Bearing
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Menu
Lines/Curves menu ➤ Create Lines ➤ Line By Bearing
Command Line
Line, ‘BD

Creating Lines by Specifying Azimuths
The Line By Azimuth command runs the AutoCAD Line command combined with the ‘ZD transparent
command (page 1773) so you can specify a direction and distance for the line segment.
From the start point (1), specify the azimuth (2) and the distance (3).

To create a line by specifying azimuths
1 Click Home tab ➤ Draw panel ➤ Line drop-down ➤ Create Line By Azimuth

.

2 Select a temporary start point for the angle measurement by clicking in the drawing or by using the .P,
.N, or .G point filters (page 1787).
3 Specify an azimuth by either clicking in the drawing or entering a value.
4 Specify the distance by either clicking in the drawing or entering a distance.
5 Continue to specify azimuths and distances to define line segments. Or press Enter to return to the
Line command prompt where you can use additional options to define the line.

Quick Reference
Ribbon
Home tab ➤ Draw panel ➤ Line drop-down ➤ Create Line By Azimuth
Menu
Lines/Curves menu ➤ Create Lines ➤ Line By Azimuth
Command Line
Line, ‘ZD
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Creating Lines by Specifying Angles
The Line By Angle command runs the AutoCAD Line command combined with the ‘AD transparent command
(page 1769) so you can specify an angle and a distance for the line segment.
The first sequence of prompts is for establishing a temporary reference line for measuring the angle. From
the reference line (1-2), specify an angle (3), and distance (4), to specify a point (5).

To create a line by specifying angles
1 Click Home tab ➤ Draw panel ➤ Line drop-down ➤ Create Line By Angle

.

2 Specify a temporary reference line for the angle by doing one of the following:
■

Select a line.

■

Enter Points, or P, and then specify a start point and endpoint for the line.

3 Specify the angle by doing one of the following:
■

Click in the drawing to specify the angle.

■

Enter a positive or negative numeric value for the angle.

■

Enter C to switch the angle between counterclockwise and clockwise, and then specify the angle.

4 Specify the distance by either clicking in the drawing or entering a distance.
5 Specify an ending point.
This concludes the specification of the temporary reference line. Subsequent prompts for angles and
distances are then used to define the line segments.
6 Enter angles and distances to define line segments. You can then press Enter to return to the Line
command prompt where you can use additional options to define the line.

Quick Reference
Ribbon
Home tab ➤ Draw panel ➤ Line drop-down ➤ Create Line By Angle
Menu
Lines/Curves menu ➤ Create Lines ➤ Line By Angle
Command Line
Line, ‘AD
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Creating Lines by Specifying Deflection Angles
The Line By Deflection command runs the AutoCAD Line command combined with the ‘DD transparent
command (page 1771) so you can specify a deflection angle and a distance.
The first sequence of prompts is for establishing a temporary reference line for measuring the angle.
From the reference line (1-2) and start point (2), specify a deflection angle (3), and distance (4) to specify a
point (5).

To create a line by specifying deflection angles
1 Click Home tab ➤ Draw panel ➤ Line drop-down ➤ Create Line By Deflection

.

2 Specify a temporary reference line for the angle by doing one of the following:
■

Select a line.

■

Enter Points, or P, and then specify a start point and endpoint for the line.

3 Specify the angle by doing one of the following:
■

Click in the drawing to specify the angle.

■

Enter a positive or negative numeric value for the angle.

■

Enter C to switch the angle between counterclockwise and clockwise, and then specify the angle.

4 Specify the distance by either clicking in the drawing or entering a distance.
5 Specify an ending point.
This concludes the specification of the temporary reference line. Subsequent prompts for angles and
distances are then used to define the line segments.
6 Enter angles and distances to define line segments. You can then press Enter to return to the Line
command prompt where you can use additional options to define the line.

Quick Reference
Ribbon
Home tab ➤ Draw panel ➤ Line drop-down ➤ Create Line By Deflection
Menu
Lines/Curves menu ➤ Create Lines ➤ Line By Deflection
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Command Line
Line, ‘DD

Creating Lines by Specifying Stations and Offsets
The Line By Station/Offset command runs the AutoCAD Line command combined with the ‘SO transparent
command (page 1779) so you can immediately specify a station and offset from an alignment.
An alignment must exist in the drawing to use this command.

To create a line by specifying station and offset from an alignment
1 Click Home tab ➤ Draw panel ➤ Line drop-down ➤ Create Line Station/Offset

.

2 Select the alignment.
3 Specify a station by either entering a station value or clicking in the drawing.
4 Specify a distance by either entering an offset or clicking in the drawing.
5 Specify a station and offset for the next point in the line. Or press Enter to return to the Line command
prompt where you can use additional options to define the line.

Quick Reference
Ribbon
Home tab ➤ Draw panel ➤ Line drop-down ➤ Create Line Station/Offset
Menu
Lines/Curves menu ➤ Create Lines ➤ Line By Station/Offset
Command Line
Line, ‘SO

Creating Lines by Sideshot
The Line By Side Shot command runs the AutoCAD Line command combined with the ‘SS transparent
command (page 1774) so you can specify one or more point locations relative to a fixed point by specifying
an angle (bearing, azimuth, angle, or deflection) and distance.
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After defining the reference line, specify an angle and distance to the points that will define the line segment.
From the reference line (1-2) and start point (2), specify points (3, 4, 5).

To create a line by sideshot
1 Click Home tab ➤ Draw panel ➤ Line drop-down ➤ Create Line By Side Shot

.

2 Specify a temporary reference line by doing one of the following:
■

Select a line.

■

Enter Points, or P, and then specify a start point and endpoint for the line.

The following prompt is displayed:
Specify angle or [Counter-clockwise/Bearing/Deflection/aZimuth]:

3 Enter an angle by doing one of the following:
■

Enter an angle in angular units for the drawing.

■

Enter Bearing, or B, and then specify the angle by specifying a quadrant and a bearing.

■

Enter Deflection, or D, then specify a deflection angle.

■

Enter aZimuth, or Z, and then specify an azimuth.

■

Enter C to switch the direction of the angle between clockwise and counterclockwise.

4 Specify a distance by either clicking in the drawing or entering a distance.
5 Continue to specify angles and distances to define line segments. Or presss Enter to return to the Line
command prompt where you can use additional options to define the line.

Quick Reference
Ribbon
Home tab ➤ Draw panel ➤ Line drop-down ➤ Create Line By Side Shot
Menu
Lines/Curves menu ➤ Create Lines ➤ Line By Side Shot
Command Line
Line, ‘SS
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Extending Line Lengths
The Line Extension command extends an existing line by a specified distance or alters the line to match the
total length specified.
The line is extended from the end of the existing line that is closest to the selection point.

To extend an existing line
1 Click Home tab ➤ Draw panel ➤ Line drop-down ➤ Create Line By Extension

.

2 Select the line to extend.
3 To define the length of the line, do one of the following:
■

Select two locations to specify the length that you want to add to the line.

■

Enter a positive distance to extend the line.

■

Enter a negative distance to shorten the line.

■

Enter Total, or T, and then enter the total length of the segment. You can either type the new total
length, or select two locations to define the total length. This total length can be greater than (to
lengthen the line), or smaller than (to shorten the line), the current length of the line.

Quick Reference
Ribbon
Home tab ➤ Draw panel ➤ Line drop-down ➤ Create Line By Extension
Menu
Lines/Curves menu ➤ Create Lines ➤ Line Extension
Command Line
LineExtension

Creating Lines From the End Of an Object
The Line From End Of Object command creates a line from the end of an existing line or arc.
The line is drawn from the end of the object that is closest to the selection point. Specify a distance by
picking two points or entering a value. The line that is drawn from an end of an arc will be drawn tangent.
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To create a line from the end of an object
1 Click Home tab ➤ Draw panel ➤ Line drop-down ➤ Create Line From End Of Object

.

2 Select the arc or line object to extend the line from.
3 Specify a distance by either clicking in the drawing or entering a distance.

Quick Reference
Ribbon
Home tab ➤ Draw panel ➤ Line drop-down ➤ Create Line From End Of Object
Menu
Lines/Curves menu ➤ Create Lines ➤ Line From End Of Object
Command Line
LineFromEndOfObject

Creating Lines Tangent to a Specified Point
The Line Tangent From Point command draws a tangent line from a selected point on an existing object in
the drawing.
Select the location of the tangent point and then specify a distance by picking two points or entering a
value.
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To create a line tangent to a specified point
1 Click Home tab ➤ Draw panel ➤ Line drop-down ➤ Create Line Tangent From Point

.

2 Select the arc or line object to extend the line from.
3 Specify the point of tangency on the object.
4 Specify a distance by either clicking in the drawing or entering a distance.

Quick Reference
Ribbon
Home tab ➤ Draw panel ➤ Line drop-down ➤ Create Line Tangent From Point
Menu
Lines/Curves menu ➤ Create Lines ➤ Line Tangent From Point
Command Line
LineTangent

Creating Perpendicular Lines
The Line Perpendicular From Point command draws a perpendicular or radial line from a selected point on
an existing object in the drawing.
Select the location of the perpendicular point and then specify a distance by picking two points or entering
a value.

To create a perpendicular or radial line
1 Click Home tab ➤ Draw panel ➤ Line drop-down ➤ Create Line Perpendicular From Point

.

2 Select the arc or line object to extend the line from.
3 Specify the point on the object where the line will extend from.
4 Specify a distance by either clicking in the drawing or entering a distance.
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Quick Reference
Ribbon
Home tab ➤ Draw panel ➤ Line drop-down ➤ Create Line Perpendicular From Point
Menu
Lines/Curves menu ➤ Create Lines ➤ Line Perpendicular From Point
Command Line
LinePerpendicular

Creating Curves
Use the curve commands to draft curve geometry prior to defining it as alignments or parcels.
The following illustration shows the curve parameters used by AutoCAD Civil 3D.
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The following illustration shows the degree of curve definition
for arcs and chords.

Creating Curves Between Two Lines
The Curve Between Two Lines command creates a curve between two existing lines and trims the lines to
the arc endpoints.
The selected lines are trimmed to the resulting point of curvature (PC) and point of tangency (PT).

You can use the Curve Calculator (page 639) to determine the values required for defining the curve.
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To create a curve between existing lines
1 Click Home tab ➤ Draw panel ➤ Curves drop-down ➤ Create Curves Between Two Lines

.

2 Select the first tangent.
3 Select the second tangent.
The following prompt is displayed:
Select entry [Tangent/External/Degree/Chord/Length/Mid-ordinate/miN-dist/Radius] <Radius>:

4 Enter one of the following options to define the curve:
■

Enter Length, or L, and then enter the length or pick the distance in the drawing.

■

Enter Tangent, or T, and then enter the tangent length or pick the distance in the drawing.

■

Enter External, or E, and then enter the secant length or pick the distance in the drawing.

■

Enter Degree, or D, to define the curve by degree of curve.
The following prompt is displayed:
Enter degree of curve (Arc), or [Chord]:

Enter the degree of curve in DD.MMSS format using the Arc or Chord option.
Use the Chord option if the curve is a railway curve. For a railway curve, the degree of curve is the
angle at the center of a circular curve subtended by a chord of 100 units.
Use the Arc option if the curve is a roadway curve. For a roadway curve, the degree of curve is the
central angle subtended by a circular arc of 100 units.
■

Enter Chord, or C, and then enter the chord length or pick the distance in the drawing.

■

Enter Mid-ordinate, or M, and then enter the distance or pick the distance in the drawing.

■

Enter miN-dist, or N, and then select the end of an existing curve. Then enter the minimum distance
between the end of the new curve and the point selected on the existing curve.
NOTE The command sets the Object Snap to END for this prompt. The point you select does not have
to be on an existing curve; it can be any point along the adjacent tangent.

■

Enter Radius, or R, and then and then enter the radius or pick the distance in the drawing.

Quick Reference
Ribbon
Home tab ➤ Draw panel ➤ Curves drop-down ➤ Create Curves Between Two Lines
Menu
Lines/Curves menu ➤ Create Curves ➤ Curve Between Two Lines
Command Line
CurveBetweenTwoLines

Creating Curves On Two Lines
The Curve On Two Lines command creates a curve between two existing lines.
The selected lines are not trimmed to the resulting point of curvature (PC) and point of tangency (PT).
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You can use the Curve Calculator (page 639) to determine the values required for defining the curve.
To create a curve between existing lines, without trimming the lines
1 Click Home tab ➤ Draw panel ➤ Curves drop-down ➤ Create Curve On Two Lines

.

2 Select the first tangent.
3 Select the second tangent.
The following prompt is displayed:
Select entry [Tangent/External/Degree/Chord/Length/Mid-ordinate/miN-dist/Radius] <Radius>:

4 Enter one of the following options to define the curve:
■

Enter Length, or L, and then enter the length or pick the distance in the drawing.

■

Enter Tangent, or T, and then enter the tangent length or pick the distance in the drawing.

■

Enter External, or E, and then enter the secant length or pick the distance in the drawing.

■

Enter Degree, or D, to define the curve by degree of curve.
The following prompt is displayed:
Enter degree of curve (Arc), or [Chord]:

Enter the degree of curve in DD.MMSS format using the Arc or Chord option.
Use the Chord option if the curve is a railway curve. For a railway curve, the degree of curve is the
angle at the center of a circular curve subtended by a chord of 100 units.
Use the Arc option if the curve is a roadway curve. For a roadway curve, the degree of curve is the
central angle subtended by a circular arc of 100 units.
■

Enter Chord, or C, and then enter the chord length or pick the distance in the drawing.

■

Enter Mid-ordinate, or M, and then enter the distance or pick the distance in the drawing.

■

Enter miN-dist, or N, and then select the end of an existing curve. Then enter the minimum distance
between the end of the new curve and the point selected on the existing curve.
NOTE The command sets the Object Snap to END for this prompt. The point you select does not have
to be on an existing curve; it can be any point along the adjacent tangent.

■

Enter Radius, or R, and then and then enter the radius or pick the distance in the drawing.
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Quick Reference
Ribbon
Home tab ➤ Draw panel ➤ Curves drop-down ➤ Create Curve On Two Lines
Menu
Lines/Curves menu ➤ Create Curves ➤ Curve On Two Lines
Command Line
CurveOnTwoLines

Creating Curves Through a Specified Point
The Curve Through Point command creates a tangent curve between two lines that passes through a specified
point.
After selecting the two lines (1-2), select the pass-through point (3). The line objects are trimmed to the
point of curvature (PC) and the point of tangency (PT).

To create a curve between existing lines through a specified point
1 Click Home tab ➤ Draw panel ➤ Curves drop-down ➤ Create Curve Through Point
2 Select the first tangent.
3 Select the second tangent.
4 Select the pass-through point.

Quick Reference
Ribbon
Home tab ➤ Draw panel ➤ Curves drop-down ➤ Create Curve Through Point
Menu
Lines/Curves menu ➤ Create Curves ➤ Curve Through Point
Command Line
CurveThroughPoint
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.

Creating Multiple Curves
The Multiple Curves command creates up to ten adjoined curves between two lines.
You can use this command as an alternative to designing alignment curves with spiral sections because the
curves can have different lengths and radii.

To create multiple, adjoined curves
1 Click Home tab ➤ Draw panel ➤ Curves drop-down ➤ Create Multiple Curves

.

2 Select the first tangent.
3 Select the second tangent.
4 Specify the number of curves to insert between the two tangents. You can specify a maximum of 10.
5 Specify which curve will have a floating length. One curve in the set must have a floating length that
is calculated by the lengths and radii of the other curves. This is usually a middle curve.
6 Enter the length and radius for all but the floating curve, and enter the radius of the floating curve.
If the results cannot fit between the two selected line objects, the following message is displayed:
Curves cannot fit between the tangents chosen.
Press any key to continue.

Quick Reference
Ribbon
Home tab ➤ Draw panel ➤ Curves drop-down ➤ Create Multiple Curves
Menu
Lines/Curves menu ➤ Create Curves ➤ Multiple Curves
Command Line
MultipleCurves

Creating Curves From the End Of an Object
The Curve From End Of Object command creates a tangent curve off the end of an existing line or curve.
The curve is drawn from the end of the object that is closest to the object selection point.
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To create a curve from the end of an object
1 Click Home tab ➤ Draw panel ➤ Curves drop-down ➤ Create Curve From End Of Object

.

2 Select the line or arc nearest the end to which the new tangent arc is to be attached.
3 Specify one of the following types of entries to use:
■

Point: Enter P and then specify the end of the chord. The curve is then drawn.

■

Radius: Enter R and then do one of the following:
■

Enter the radius at the prompt.

■

Enter A and enter a degree of curve.

■

Enter C and enter a degree of chord.

NOTE When drawing a curve, specifying a positive radius or degree of curve draws the curve clockwise
or to the right of the starting angle, whereas a negative radius or degree of curve draws the type curve
counterclockwise or to the left.
After you enter the radius or degree of curve, the following prompt is displayed:
Select entry [Tangent/Chord/Delta/Length/External/Mid-ordinate] <Length>:

4 Do one of the following:
■

Enter Tangent, or T, and then enter the tangent length, or pick the distance in the drawing.

■

Enter Chord, or C , and then enter the chord length, or pick the distance in the drawing.

■

Enter Delta, or D, and then enter the delta angle, or pick the distance in the drawing.

■

Enter Length, or L, and then enter the curve length, or pick the distance in the drawing.

■

Enter External, or E, and then enter the external distance, or pick the distance in the drawing.

■

Enter Mid-ordinate, or M, and then enter the mid-ordinate distance, or pick the distance in the
drawing.

Quick Reference
Ribbon
Home tab ➤ Draw panel ➤ Curves drop-down ➤ Create Curve From End Of Object
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Menu
Lines/Curves menu ➤ Create Curves ➤ Curve From End Of Object
Command Line
CurveFromEndOfObject

Creating Reverse or Compound Curves
The Reverse or Compound command creates a reverse or compound curve from the endpoint of an existing
curve.
A compound curve is a curve consisting of two or more arcs of different radii curving in the same direction
and having a common tangent or transition curve at their point of junction. A reverse curve is an S-shaped
curve.

To create a reverse or compound curve
1 Click Home tab ➤ Draw panel ➤ Curves drop-down ➤ Create Reverse Or Compound Curve

.

2 Select the arc object nearest the end to which the new compound or reverse curve is to be attached.
3 Specify whether to create a Reverse or Compound curve.
4 Do one of the following:
■

Enter the radius at the prompt.

■

Enter A and enter a degree of curve.

■

Enter C and enter a degree of chord.

After you enter the radius or degree of curve, the following prompt is displayed:
Select entry [Tangent/Chord/Delta/Length/External/Mid-ordinate] <Length>:

5 Do one of the following:
■

Enter Tangent, or T, and then enter the tangent length, or pick the distance in the drawing.

■

Enter Chord, or C , and then enter the chord length, or pick the distance in the drawing.

■

Enter Length, or L, and then enter the curve length, or pick the distance in the drawing.

■

Enter Delta, or D, and then enter the delta angle, or pick the distance in the drawing.

■

Enter External, or E, and then enter the external distance, or pick the distance in the drawing.
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■

Enter Mid-ordinate, or M, and then enter the mid-ordinate distance, or pick the distance in the
drawing.

Quick Reference
Ribbon
Home tab ➤ Draw panel ➤ Curves drop-down ➤ Create Reverse Or Compound Curve
Menu
Lines/Curves menu ➤ Create Curves ➤ Reverse Or Compound Curve
Command Line
ReverseOrCompound

Creating Entities by Best Fit
Use the Best Fit Entities commands to use a series of AutoCAD Civil 3D points, AutoCAD points, existing
entities, or clicks on screen as a basis to create AutoCAD lines, arcs, and parabolas.
The best fit commands are useful when you have to resurvey existing infrastructure during rehabilitation
projects. In these cases, survey data may not match the original design. This requires you to edit the lines
and curves in your design to best represent the actual survey data.
The best fit commands use the least square regression model to create lines, arcs, and parabolas from AutoCAD
Civil 3D points, AutoCAD points, clicks on screen, or existing entities such as lines, arcs, polylines, feature
lines, etc. The line or curve that best fits through these objects represents the minimum deviation from the
original design.
NOTE When using the best fit commands for profile design, use the Create Parabola command for vertical curves.
See Vertical Curve Design (page 1166) for more information.

Creating Lines by Best Fit
Use the create line by best fit command to use a series of AutoCAD Civil 3D points, AutoCAD points, existing
entities, or clicks on screen as a basis to create an AutoCAD line.
The best-fitting line through the points is calculated. You can then use a dialog box to exclude any of the
specified points or to select a pass-through point.
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To create an AutoCAD line by best fit from AutoCAD Civil 3D points
1 If you are creating a best fit line for a profile, set the profile view style vertical exaggeration to 1. See
Creating and Editing Profile View Styles (page 1125) for more information.
2 Click Home tab ➤ Draw panel ➤ Best Fit drop-down ➤ Create Best Fit Line

.

3 In the Line By Best Fit Dialog Box (page 2225), select From COGO Points.
4 Select two or more points. Enter G to select a point group or N to enter points by number.
As you select points in the drawing window, a white X marks each regression point and a temporary,
dashed line is displayed in real time.
5 Press Enter to complete the command.
6 In the Panorama window, use the Regression Data (page 2226) vista to make changes to the regression
points.
As you highlight a row in the Regression Data vista, the corresponding regression point in the drawing
window will be highlighted in red.
NOTE When the AutoCAD line is created, it will not retain any link to the regression points.
7 Create the AutoCAD line:
■

Click
to create the line and keep the regression data. You may then use the data as a basis to
create more lines.

■

Click

to create the line, clear the regression data, and close the Regression Data vista.

8 If desired, convert the AutoCAD line to an alignment or profile entity. See Converting an AutoCAD
Line or Arc to an Alignment Sub-Entity (page 1062) or Converting AutoCAD Entities to Profile Sub-entities
(page 1196) for more information.
To create an AutoCAD line by best fit from AutoCAD points
1 If you are creating a best fit line for a profile, set the profile view style vertical exaggeration to 1. See
Creating and Editing Profile View Styles (page 1125) for more information.
2 Click Home tab ➤ Draw panel ➤ Best Fit drop-down ➤ Create Best Fit Line

.

3 In the Line By Best Fit Dialog Box (page 2225), select From AutoCAD Points.
4 Select two or more AutoCAD points.
As you select points in the drawing window, a white X marks each regression point and a temporary,
dashed line is displayed in real time.
5 Press Enter to complete the command.
6 In the Panorama window, use the Regression Data (page 2226) vista to make changes to the regression
points.
As you highlight a row in the Regression Data vista, the corresponding regression point in the drawing
window will be highlighted in red.
NOTE When the AutoCAD line is created, it will not retain any link to the regression points.
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7 Create the AutoCAD line:
■

Click
to create the line and keep the regression data. You may then use the data as a basis to
create more lines.

■

Click

to create the line, clear the regression data, and close the Regression Data vista.

8 If desired, convert the AutoCAD line to an alignment or profile entity. See Converting an AutoCAD
Line or Arc to an Alignment Sub-Entity (page 1062) or Converting AutoCAD Entities to Profile Sub-entities
(page 1196) for more information.
To create an AutoCAD line by best fit from existing entities
1 If you are creating a best fit line for a profile, set the profile view style vertical exaggeration to 1. See
Creating and Editing Profile View Styles (page 1125) for more information.
2 Click Home tab ➤ Draw panel ➤ Best Fit drop-down ➤ Create Best Fit Line

.

3 In the Line By Best Fit Dialog Box (page 2225), select From Entities. Specify the tessellation and mid-ordinate
tolerance settings.
4 Select one or more of the entities listed at the command line.
NOTE You may select several types of entities listed at the command line.
As you select entities in the drawing window, a white X marks each regression point and a temporary,
dashed line is displayed in real time.
5 If you selected a profile object, specify the starting and ending station on the Specify Station Range
Dialog Box (page 2228).
6 Press Enter to complete the command.
7 In the Panorama window, use the Regression Data (page 2226) vista to make changes to the regression
points.
As you highlight a row in the Regression Data vista, the corresponding regression point in the drawing
window will be highlighted in red.
NOTE When the AutoCAD line is created, it will not retain any link to the regression points.
8 Create the AutoCAD line:
■

Click
to create the line and keep the regression data. You may then use the data as a basis to
create more lines.

■

Click

to create the line, clear the regression data, and close the Regression Data vista.

9 If desired, convert the AutoCAD line to an alignment or profile entity. See Converting an AutoCAD
Line or Arc to an Alignment Sub-Entity (page 1062) or Converting AutoCAD Entities to Profile Sub-entities
(page 1196) for more information.
To create an AutoCAD line by best fit by clicking on screen
1 If you are creating a best fit line for a profile, set the profile view style vertical exaggeration to 1. See
Creating and Editing Profile View Styles (page 1125) for more information.
2 Click Home tab ➤ Draw panel ➤ Best Fit drop-down ➤ Create Best Fit Line
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.

3 In the Line By Best Fit Dialog Box (page 2225), select By Clicking On The Screen.
4 Select a starting point and at least one other point.
NOTE You may use OSNAP or transparent commands to select points.
As you select points in the drawing window, a white X marks each regression point and a temporary,
dashed line is displayed in real time.
5 Press Enter to complete the command.
6 In the Panorama window, use the Regression Data (page 2226) vista to make changes to the regression
points.
As you highlight a row in the Regression Data vista, the corresponding regression point in the drawing
window will be highlighted in red.
NOTE When the AutoCAD line is created, it will not retain any link to the regression points.
7 Create the AutoCAD line:
■

Click
to create the line and keep the regression data. You may then use the data as a basis to
create more lines.

■

Click

to create the line, clear the regression data, and close the Regression Data vista.

8 If desired, convert the AutoCAD line to an alignment or profile entity. See Converting an AutoCAD
Line or Arc to an Alignment Sub-Entity (page 1062) or Converting AutoCAD Entities to Profile Sub-entities
(page 1196) for more information.

Quick Reference
Ribbon
Click Home tab ➤ Draw panel ➤ Best Fit drop-down ➤ Create Best Fit Line
Menu
Lines/Curves menu ➤ Create Curves ➤ Curve Between Two Lines
Command Line
CreateLineByBestFit
Dialog Box
Line By Best Fit (page 2225)
Specify Station Range (page 2228)
Regression Data Vista (page 2226)

Creating Arcs by Best Fit
Use the create arc by best fit command to use a series of AutoCAD Civil 3D points, AutoCAD points, existing
entities, or clicks on screen as a basis to create an AutoCAD arc.
The best-fitting curve through the points is calculated. You can then use a dialog box to exclude any of the
specified points or to select one or two pass-through points.
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NOTE When using the best fit commands for profile design, use the Create Parabola command for vertical curves.
See Vertical Curve Design (page 1166) for more information.
To create an AutoCAD arc by best fit from AutoCAD Civil 3D points
1 If you are creating a best fit arc for a profile, set the profile view style vertical exaggeration to 1. See
Creating and Editing Profile View Styles (page 1125) for more information.
2 Click Home tab ➤ Draw panel ➤ Best Fit drop-down ➤ Create Best Fit Arc

.

3 In the Arc By Best Fit Dialog Box (page 2225), select From COGO Points.
4 Select three or more points. Enter G to select a point group or N to enter points by number.
As you select points in the drawing window, a white X marks each regression point and a temporary,
dashed arc is displayed in real time.
NOTE You must select at least three non-collinear regression points.
5 Press Enter to complete the command.
6 In the Panorama window, use the Regression Data (page 2226) vista to make changes to the regression
points.
As you highlight a row in the Regression Data vista, the corresponding regression point in the drawing
window will be highlighted in red.
NOTE When the AutoCAD arc is created, it will not retain any link to the regression points.
7 Create the AutoCAD arc:
■

Click
to create the arc and keep the regression data. You may then use the data as a basis to
create more arcs.

■

Click

to create the arc, clear the regression data, and close the Regression Data vista.

8 If desired, convert the AutoCAD arc to an alignment or profile entity. See Converting an AutoCAD Line
or Arc to an Alignment Sub-Entity (page 1062) or Converting AutoCAD Entities to Profile Sub-entities
(page 1196) for more information.
To create an AutoCAD arc by best fit from AutoCAD points
1 If you are creating a best fit arc for a profile, set the profile view style vertical exaggeration to 1. See
Creating and Editing Profile View Styles (page 1125) for more information.
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2 Click Home tab ➤ Draw panel ➤ Best Fit drop-down ➤ Create Best Fit Arc

.

3 In the Arc By Best Fit Dialog Box (page 2225), select From AutoCAD Points.
4 Select three or more AutoCAD points.
As you select points in the drawing window, a white X marks each regression point and a temporary,
dashed arc is displayed in real time.
NOTE You must select at least three non-collinear regression points.
5 Press Enter to complete the command.
6 In the Panorama window, use the Regression Data (page 2226) vista to make changes to the regression
points.
As you highlight a row in the Regression Data vista, the corresponding regression point in the drawing
window will be highlighted in red.
NOTE When the AutoCAD arc is created, it will not retain any link to the regression points.
7 Create the AutoCAD arc:
■

Click
to create the arc and keep the regression data. You may then use the data as a basis to
create more arcs.

■

Clickk

to create the arc, clear the regression data, and close the Regression Data vista.

8 If desired, convert the AutoCAD arc to an alignment or profile entity. See Converting an AutoCAD Line
or Arc to an Alignment Sub-Entity (page 1062) or Converting AutoCAD Entities to Profile Sub-entities
(page 1196) for more information.
To create an AutoCAD arc by best fit from existing entities
1 If you are creating a best fit arc for a profile, set the profile view style vertical exaggeration to 1. See
Creating and Editing Profile View Styles (page 1125) for more information.
2 Click Home tab ➤ Draw panel ➤ Best Fit drop-down ➤ Create Best Fit Arc

.

3 In the Arc By Best Fit Dialog Box (page 2225), select From Entities. Specify the tessellation and mid-ordinate
tolerance settings.
4 Select one or more of the entities listed at the command line.
NOTE You may select several types of entities listed at the command line.
As you select entities in the drawing window, a white X marks each regression point and a temporary,
dashed arc is displayed in real time.
NOTE You must select at least three non-collinear regression points.
5 If you selected a profile object, specify the starting and ending station on the Specify Station Range
Dialog Box (page 2228).
6 Press Enter to complete the command.
7 In the Panorama window, use the Regression Data (page 2226) vista to make changes to the regression
points.
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As you highlight a row in the Regression Data vista, the corresponding regression point in the drawing
window will be highlighted in red.
NOTE When the AutoCAD arc is created, it will not retain any link to the regression points.
8 Create the AutoCAD arc:
■

Click
to create the arc and keep the regression data. You may then use the data as a basis to
create more arcs.

■

Click

to create the arc, clear the regression data, and close the Regression Data vista.

9 If desired, convert the AutoCAD arc to an alignment or profile entity. See Converting an AutoCAD Line
or Arc to an Alignment Sub-Entity (page 1062) or Converting AutoCAD Entities to Profile Sub-entities
(page 1196) for more information.
To create an AutoCAD arc by best fit by clicking on screen
1 If you are creating a best fit arc for a profile, set the profile view style vertical exaggeration to 1. See
Creating and Editing Profile View Styles (page 1125) for more information.
2 Click Home tab ➤ Draw panel ➤ Best Fit drop-down ➤ Create Best Fit Arc

.

3 In the Arc By Best Fit Dialog Box (page 2225), select By Clicking On The Screen.
4 Select a starting point and at least two other points.
NOTE You may use OSNAP or transparent commands to select points.
As you select points in the drawing window, a white X marks each regression point and a temporary,
dashed arc is displayed in real time.
NOTE You must select at least three non-collinear regression points.
5 Press Enter to complete the command.
6 In the Panorama window, use the Regression Data (page 2226) vista to make changes to the regression
points.
As you highlight a row in the Regression Data vista, the corresponding regression point in the drawing
window will be highlighted in red.
NOTE When the AutoCAD arc is created, it will not retain any link to the regression points.
7 Create the AutoCAD arc:
■

Click
to create the arc and keep the regression data. You may then use the data as a basis to
create more arcs.

■

Click

to create the arc, clear the regression data, and close the Regression Data vista.

8 If desired, convert the AutoCAD arc to an alignment or profile entity. See Converting an AutoCAD Line
or Arc to an Alignment Sub-Entity (page 1062) or Converting AutoCAD Entities to Profile Sub-entities
(page 1196) for more information.
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Quick Reference
Ribbon
Home tab ➤ Draw panel ➤ Best Fit drop-down ➤ Create Best Fit Arc
Menu
Lines/Curves menu ➤ Create Best Fit Entities ➤ Create Arc
Command Line
CreateArcByBestFit
Dialog Box
Arc By Best Fit (page 2225)
Specify Station Range (page 2228)
Regression Data Vista (page 2226)

Creating Parabolas by Best Fit
Use the create parabola by best fit command to use a series of AutoCAD Civil 3D points, AutoCAD points,
existing entities, or clicks on screen as a basis to create an AutoCAD parabola.
The best-fitting parabola through the points is calculated. You can then use a dialog box to exclude any of
the specified points or to select one or two pass-through points.

NOTE When using the best fit commands for profile design, use the Create Parabola command for vertical curves.
See Vertical Curve Design (page 1166) for more information.
To create an AutoCAD parabola by best fit from existing entities
1 If you are creating a best fit parabola for a profile, set the profile view style vertical exaggeration to 1.
See Creating and Editing Profile View Styles (page 1125) for more information.
2 Click Home tab ➤ Draw panel ➤ Best Fit drop-down ➤ Create Best Fit Parabola

.

3 In the Parabola By Best Fit Dialog Box (page 2225), select From Entities. Specify the tessellation and
mid-ordinate tolerance settings.
4 Select one or more of the entities listed at the command line.
NOTE You may select several types of entities listed at the command line.
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As you select entities in the drawing window, a white X marks each regression point and a temporary,
dashed parabola is displayed in real time.
NOTE You must select at least three non-collinear regression points.
5 If you selected a profile object, specify the starting and ending station on the Specify Station Range
Dialog Box (page 2228).
6 Press Enter to complete the command.
7 In the Panorama window, use the Regression Data (page 2226) vista to make changes to the regression
points.
As you highlight a row in the Regression Data vista, the corresponding regression point in the drawing
window will be highlighted in red.
NOTE When the AutoCAD parabola is created, it will not retain any link to the regression points.
8 Create the AutoCAD parabola:
■

Clik
to create the parabola and keep the regression data. You may then use the data as a basis
to create more parabolas.

■

Click

to create the parabola, clear the regression data, and close the Regression Data vista.

9 If desired, convert the AutoCAD parabola to an alignment or profile entity. See Converting an AutoCAD
Line or Arc to an Alignment Sub-Entity (page 1062) or Converting AutoCAD Entities to Profile Sub-entities
(page 1196) for more information.
To create an AutoCAD parabola by best fit by clicking on screen
1 If you are creating a best fit parabola for a profile, set the profile view style vertical exaggeration to 1.
See Creating and Editing Profile View Styles (page 1125) for more information.
2 Click Home tab ➤ Draw panel ➤ Best Fit drop-down ➤ Create Best Fit Parabola

.

3 In the Parabola By Best Fit Dialog Box (page 2225), select By Clicking On The Screen.
4 Select a starting point and at least two other points.
NOTE You may use OSNAP or transparent commands to select points.
As you select points in the drawing window, a white X marks each regression point and a temporary,
dashed parabola is displayed in real time.
NOTE You must select at least three non-collinear regression points.
5 Press Enter to complete the command.
6 In the Panorama window, use the Regression Data (page 2226) vista to make changes to the regression
points.
As you highlight a row in the Regression Data vista, the corresponding regression point in the drawing
window will be highlighted in red.
NOTE When the AutoCAD parabola is created, it will not retain any link to the regression points.

636 | Chapter 19 Lines and Curves

7 Create the AutoCAD parabola:
■

Clik
to create the parabola and keep the regression data. You may then use the data as a basis
to create more parabolas.

■

Click

to create the parabola, clear the regression data, and close the Regression Data vista.

8 If desired, convert the AutoCAD parabola to an alignment or profile entity. See Converting an AutoCAD
Line or Arc to an Alignment Sub-Entity (page 1062) or Converting AutoCAD Entities to Profile Sub-entities
(page 1196) for more information.

Quick Reference
Ribbon
Click Home tab ➤ Draw panel ➤ Best Fit drop-down ➤ Create Best Fit Parabola
Menu
Lines/Curves menu ➤ Create Curves ➤ Curve Between Two Lines
Command Line
CreateParabolaByBestFit
Dialog Box
Parabola By Best Fit (page 2225)
Specify Station Range (page 2228)
Regression Data Vista (page 2226)

Attaching Multiple Lines or Curves to Existing Objects
The Attach Multiple command draws multiple lines and curves from the end of an existing line or arc.
The lines or curves are drawn from the end of the object closest to the selection point.

To attach multiple lines
1 Click Home tab ➤ Draw panel

Attach Multiple.

2 Select a line or arc.
3 Enter Line, or L, to attach a line.
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4 Enter the length of the new line section.
The new line is drawn and the following prompt is displayed:
Enter an attachment option [Line/Arc/Undo]:

5 Continue to add line or arc segments or use the Undo option to undo the last segment.
To attach multiple curves
1 Click Home tab ➤ Draw panel

Attach Multiple

.

2 Select a line or arc.
3 Enter Arc, or A, to attach an arc.
4 Specify one of the following types of entries to use:
■

Point: Enter P and then specify the end of the chord. The curve is then drawn.

■

Radius: Enter R and then do one of the following:
■

Enter the radius at the prompt.

■

Enter A and enter a degree of curve.

■

Enter C and enter a degree of chord.

NOTE When drawing a curve, specifying a positive radius or degree of curve draws the curve clockwise
or to the right of the starting angle, whereas a negative radius or degree of curve draws the type curve
counterclockwise or to the left.
After you enter the radius or degree of curve, the following prompt is displayed:
Select entry [Tangent/Chord/Delta/Length/External/Mid-ordinate] <Length>:

5 Do one of the following:
■

Enter Tangent, or T, and then enter the tangent length, or pick the distance in the drawing.

■

Enter Chord, or C , and then enter the chord length, or pick the distance in the drawing.

■

Enter Delta, or D, and then enter the delta angle, or pick the distance in the drawing.

■

Enter Length, or L, and then enter the curve length, or pick the distance in the drawing.

■

Enter External, or E, and then enter the external distance, or pick the distance in the drawing.

■

Enter Mid-ordinate, or M, and then enter the mid-ordinate distance, or pick the distance in the
drawing.

The new line is drawn and the following prompt is displayed:
Enter an attachment option [Line/Arc/Undo]:

6 Continue to add line or arc segments or use the Undo option to undo the last segment.

Quick Reference
Ribbon
Click Home tab ➤ Draw panel
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Attach Multiple Entities

Menu
Click Lines/Curvesmenu ➤ Attach Multiple Entities
Command Line
AttachMultiple

Calculating Curve Parameters
The Curve Calculator determines curve parameters based on input.
You can keep the Curve Calculator open while you do other work and use the buttons to send the output
of the curve calculations to the command line.
NOTE To change the units used in the Curve Calculator dialog box, use the Ambient Settings tab of the Drawing
Settings dialog box. Under Angle, change the Format value to the unit you want to use. For more information,
see To specify ambient settings for a drawing (page 84).
The following illustration shows the curve parameters used by AutoCAD Civil 3D.

To calculate curve parameters
1 Click Home tab ➤ Draw panel ➤ Curves drop-down ➤ Curve Calculator

.

2 Specify whether the degree of curve is determined by arc or by chord by selecting an option from the
Degree of Curve Definition drop-down list. The selected option affects how the Degree of Curve Property
is calculated.
■

Chord Definition: Use this option if the curve is a railway curve. Using this option, the degree of
curve is the angle at the center of a circular curve subtended by a chord of 100 units.

■

Arc Definition: Use this option if the curve is a roadway curve. Using this option, the degree of curve
is the central angle subtended by a circular arc of 100 units.
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3 Specify a Fixed Property for the curve by selecting one of the following options:
■

Radius: Specifies that the radius will be fixed.

■

Delta Angle: Specifies that the delta angle will be fixed.

The program then holds as fixed either of the two parameters above while performing calculations.
4 Specify one or more additional parameters for the curve.
■

Degree Of Curve: Specifies the degree of curve.

■

Delta Angle: Specifies the delta angle of the curve. This option is not adjustible if Delta Angle is
specified as the Fixed Property.

■

Radius: Specifies the radius of the curve. This option is not adjustible if Radius is specified as the
Fixed Property.

■

Tangent Distance: Specifies the tangent length of the curve.

■

Arc Distance: Specifies the arc length of the curve.

■

Chord Distance: Specifies the chord length of the curve.

■

External Distance: Specifies the external secant length of the curve.

■

Mid-ordinate Distance: Specifies the mid-ordinate length of the curve.

5 Optionally you can also:
■

Click

to send any of the values to the AutoCAD command line.

■

Right-click and select Copy Value To Clipboard to copy the selected value to the clipboard.

■

Right-click and select Copy To Clipboard to copy the entire contents of the Curve Calculator to the
clipboard.

■

Click
to select an arc in the drawing to display its values in the calculator. No edits you
subsequently make in the calculator are updated to the arc in the drawing.

Quick Reference
Ribbon
Home tab ➤ Draw panel ➤ Curves drop-down ➤ Curve Calculator
Menu
Lines/Curves menu ➤ Curve Calculator
Command Line
CurveCalculator
Dialog Box
Curve Calculator (page 2228)

Labeling Lines, Curves, and Polylines
You can label individual line and curve segments, one at a time, or multiple segments at once by using
specified line and curve label styles.
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Labeling Individual Line and Curve Segments
You can label individual line and curve segments on lines, curves, polylines, and feature lines.
On the Toolspace Settings tab, in the General Label Style collection, set up Line and Curve label styles (page
1659) to use for the lines, curves and polylines.
On the Toolspace Settings tab, in the General Label Style collection, specify the default line label style (page
1655).
Use the Single Segment or Multiple Segment command to quickly label a line or curve using the default
label style.
Use the Add Line/Curve Labels option to access the Add Labels dialog box (page 2208) if you need to create
or modify a style before labeling a line or curve segment.
To label individual line and curve segments
1 Click Annotate tab ➤ Labels & Tables panel ➤ Add Labels menu ➤ Line And Curve ➤ Add Single
Segment Line/Curve Label

.

2 Select the line segment to label.
OR
1 Click Annotate tab ➤ Labels & Tables panel ➤ Add Labels menu ➤ Line And Curve ➤ Add Line And
Curve Labels

.

2 In the Add Labels dialog box (page 2208), under Feature, ensure that Line And Curve is selected.
3 Under Label Type, select Single Segment.
4 Specify the other options as required.
5 Click Add and then select the feature line or segment to label.

Quick Reference
Ribbon
Click Annotate tab ➤ Labels & Tables panel ➤ Add Labels menu ➤ Line And Curve ➤ Add Single Segment
Line/Curve Label
Menu
Lines/Curves menu ➤ Add Line/Curve Labels ➤ Single Segment

Labeling Multiple Line and Curve Segments
You can label multiple line and curve segments on lines, curves, polylines, and feature lines.
To label multiple line and curve segments
1 Click Annotate tab ➤ Labels & Tables panel ➤ Add Labels menu ➤ Line And Curve ➤ Add Multiple
Segment Line/Curve Labels

.

2 Select the lines and curve segments to label.
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OR
1 Click Annotate tab ➤ Labels & Tables panel ➤ Add Labels menu ➤ Line And Curve ➤ Add Line And
Curve Labels

.

2 In the Add Labels dialog box (page 2208), under Feature, ensure that Line And Curve is selected.
3 Under Label Type, select Multiple Segment.
4 Specify the other options as required.
5 Click Add and then select the feature line or segment to label.

Quick Reference
Ribbon
Click Annotate tab ➤ Labels & Tables panel ➤ Add Labels menu ➤ Line And Curve ➤ Add Multiple Segment
Line/Curve Labels

Menu
Lines/Curves menu ➤ Add Line/Curve Labels ➤ Multiple Segment

Adding Line/Curve Tables
Use line/curve tables to consolidate information about the line and arc segments in your drawing.
Tables provide an alternative to labels for information management. Tables keep the information organized
and separate from the drawing, but cross-referenced by small labels known as tags.
When segment information is displayed in table rows, table tags uniquely identify the segments in the
drawing and in the initial cells of table rows. For example, if a line segment is labeled L234, its corresponding
table row is also labeled L234.
The line and curve table creation commands are available from the Labels & Tables panel on the Annotate
tab.
You create and edit tables for most objects using the same common procedures and standard dialog boxes.
For general information about modifying tables, see Modifying Tables (page 1750).

Renumbering Table Tags
Use the renumbering command to renumber table tags before creating tables.
In this release of AutoCAD Civil 3D, the table tag renumbering command is available from the Tables
contextual tab. It is also available from the Labels & Tables panel on contextual tabs for objects that support
tags, such as Alignment and Parcel.
For more information, see Renumbering Label Tags (page 1723). The Table Tag setting process is now a
drawing-wide setting. See Creating Label Tags (page 1723) for more information.
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Lines and Curves Command Reference
Quickly access Lines and Curves functionality from the command line.
Command

Description

AttachMultiple

Creates multiple lines and curves starting from the
end of an existing line or curve (page 637)

CreateArcByBestFit

Creates the most probable arc from points or entities
(page 631)

CreateLineByBestFit

Creates the most probable line from points or entities (page 628)

CreateParabolaByBestFit

Creates the most probable parabola from points or
entities (page 635)

CurveBetweenTwoLines

Creates a curve between two existing lines and trims
the lines to the arc endpoints (page 622)

CurveCalculator

Calculates curve parameters based on input (page
639)

CurveFromEndOfObject

Creates a tangent curve off the end of an existing
line or curve (page 626)

CurveOnTwoLines

Creates a curve between two existing lines and
leaves the lines intact (page 623)

CurveThroughPoint

Creates a tangent curve between two lines that
passes through a specified point (page 624)

LineExtension

Lengthens or shortens a line (page 617)

LineFromEndOfObject

Creates a line from the end of an existing line or arc
(page 618)

LinePerpendicular

Creates a line that is perpendicular or radial to a
selected object (page 619)

LineTangent

Creates a line that is tangent to a selected object
(page 619)

MultipleCurves

Creates multiple compound curves between selected
tangents (page 625)

ReverseOrCompound

Creates a reverse or compound curve from the endpoint of an existing curve (page 627)
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Surfaces

20

Surfaces are basic building blocks in AutoCAD Civil 3D. You can import surface information from LandXML, TIN (page
2785) (triangulated irregular network), and DEM (page 2772) (digital elevation model) files, and use points, point files, DEM
data, existing AutoCAD objects, contours, breaklines, and boundaries to create surfaces.
Surfaces Workflow (page 32)

Understanding Surfaces
A surface is a three-dimensional geometric representation of an area of land, or, in the case of volume surfaces,
is a difference or composite between two surface areas.
Surfaces are made up of triangles or grids, which are created when AutoCAD Civil 3D connects the points
that make up the surface data.
To use a surface in your drawing, you can create an empty surface and then add data to it. You can also
import existing files containing surface information, such as LandXML, TIN (page 2785), or DEM (page 2772)
files.
Points or contours are usually a primary part of the original surface information and are supplemented with
breakline (page 2769) and boundaries (page 2769).
Boundaries define the visible area of a surface. Only the area within the boundary is included in calculations,
such as for total area and volume. You can also define masks to hide or show parts of a surface for editing
or presentation purposes, while still including that area in calculations.
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Surfaces displaying boundaries, contours, and elevation analysis

Breaklines are used on TIN surfaces to define linear features that triangles cannot cross, such as retaining
walls or streams. Breaklines affect triangulation of the surface.
You can define different sets of contours, for example, for different intervals. Smoothing is provided for the
surface object as a whole, which gives better results than simply smoothing the contours. In AutoCAD Civil
3D, the build process for surfaces is incremental. Whenever data is added or corrected, the surface is updated.
Each surface has a definition list. This list contains all the operations performed on the surface. By turning
the operations on and off, you can return a surface to a previous state or modify it to support different types
of analysis.

Surfaces displaying slope arrows elevation analysis
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Types of Surfaces
AutoCAD Civil 3D supports several types of surfaces:
■

TIN surfaces. Formed by triangulating an arbitrary set of points.
For more information, see Creating a TIN Surface (page 649).

■

Grid surfaces. Formed from points that lie on a regular grid (for example, Digital Elevation Models
(DEMs)).
For more information, see Creating a Grid Surface (page 650).

■

TIN volume surfaces. A composite surface created from a combination of points in a top (comparison)
and base surface, also known as a differential surface.
For more information, see Creating a TIN Volume Surface (page 651).

■

Grid volume surfaces. A differential surface based on user-specified top and bottom surfaces with
points on a user-specified grid.
For more information, see Creating a Grid Volume Surface (page 653).

■

Corridor surfaces. A corridor surface is a surface created using data extracted from an underlying
corridor model.
For more information, see Creating and Editing Corridor Surfaces (page 1506).

The Surface Object
Surfaces persist in an AutoCAD drawing as objects with the names AECC_TIN_SURFACE (TIN surface) or
AECC_GRID_SURFACE (grid surface).
All AutoCAD Civil 3D objects are aware of each other and react to changes. For example, a change in a
surface results in multiple automatic updates in alignments, parcels, or other objects that reference that
surface.
For overview information about AutoCAD Civil 3D objects, see Understanding Objects and Styles (page 63).

Surfaces Collection (Prospector Tab)
Use the Surfaces collection in the Prospector tree to access the surfaces in a drawing. As surface objects are
created, they are displayed as named surfaces under the Surfaces collection.
Right-click the Surfaces collection to do the following:
■

Create a new surface. (page 649)

■

Import DEM data to create a surface. (page 656)

■

Import TIN data to create a surface. (page 655)

■

Turn on or off the surface preview (page 735). A check mark is displayed next to the Show Preview menu
item when the preview option is selected.

■

Export surface data to DEM. (page 773)

■

Export the surface to LandXML format. (page 774)

■

Refresh the view of the Surfaces collection in the Prospector tree.
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If you have added a surface to the current drawing, you can expand the Surfaces collection to view the names
of the surfaces or select surfaces to display a tabular list of the surfaces in the Prospector list view. For more
information, see The Toolspace Item View (page 99).
Expand an individual surface name to display the surface components, including its masks (page 2777),
watersheds (page 2787), and definition.
Expand the Definition collection to view and add data for the surface, such as breaklines, boundaries, and
contours. The data items that are displayed depend on the surface type.
For more information about...

See...

Masks

Masks (page 719)

Watersheds

Watersheds (page 725)

Definition

Understanding the Surface Definition
(page 660)

Surface Collection (Settings Tab)
Use the Surface collection in the Settings tree to manage surface settings, surface styles, surface label styles,
surface table styles, and surface command settings.
Right-click the Surface collection to do the following:
■

Edit the surface feature settings. (page 737)

■

Edit the surface label style defaults. (page 752)

■

Refresh the display of the settings tree.

Expand the Surface collection to display and edit the styles and command settings that are available for
surfaces.
For more information about... See...
Surface styles

Surface Styles and Visualization (page 748)

Label styles

Surface Label Styles (page 752)

Table styles

Surface Table Styles (page 762)

Commands

Surfaces Command Reference (page 775)
Command Settings (page 737)

Creating Surfaces
You can create a surface that comprises a combination of points, breaklines, boundaries, and contours.
When you create a surface, the surface name is displayed in the
Surfaces collection in the Prospector tree
so that you can perform other operations, such as adding data and editing the surface.
Initially, the surface may be empty and not be visible in the drawing. Once you add data to the surface, the
surface becomes visible in the drawing in accordance to the display settings specified in the referenced
surface style. See Surface Styles and Visualization (page 748).
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Creating a TIN Surface
A TIN (page 2785) surface comprises the triangles that form a triangulated irregular network.
TIN lines form the triangles that make up the surface triangulation. To create TIN lines, AutoCAD Civil 3D
connects the surface points that are closest together. The elevation of any point in the surface is defined by
interpolating the elevations of the vertices of the triangles that the point lies in.
TIN surfaces are most useful for:
■

Mapping highly variable surfaces with irregularly distributed sample data representing the influence of
streams, roads, and lakes.

■

Examining localized areas (large-scale maps)

TIN surfaces generally take longer to build and require more disk space than grid surfaces.
When AutoCAD Civil 3D creates a TIN surface from point data, it computes the Delaunay triangulation (page
2772) of the points. With Delaunay triangulation, no point lies inside the circle determined by the vertices of
any triangle.
Breakline data (from breaklines, contours, or boundaries) influences how the surface is triangulated. A
breakline edge between the points causes the program to connect these points with a triangle edge in the
TIN, even if doing so violates the Delaunay property.
A TIN surface with contour lines:

To create a TIN surface
1 Click Home tab ➤ Create Ground Data panel ➤ Surfaces drop-down ➤ Create Surface

.

In the Create Surface (page 2623) dialog box, in the Type list, select TIN Surface.
2 Click

to select a layer. For more information about layers, see Object Layer Dialog Box (page 2221).

NOTE If you do not select a layer, the surface is placed on the current layer.
3 In the properties grid, click the Value column for the Name property and enter a name for the surface.
NOTE To name the surface, click its default name and enter a new name, or use the Name Template. For
more information, see Name Template Dialog Box (page 2022).
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4 To change the style for the surface, click the Style property in the properties grid and click
Value column.

in the

The Select Surface Style dialog box is displayed. For more information, see Surface Styles and Visualization
(page 748).
5 To change the render material for the surface, click the Render Material property in the properties grid
and click

in the Value column.

The Select Render Material dialog box is displayed. For more information, see Applying Render Materials
to Objects (page 1763)
6 Click OK to create the surface.
The surface name is displayed under the Surfaces collection in the Prospector tree. For information
about adding data to the surface, see Adding and Editing Surface Data (page 660).

Quick Reference
Ribbon
Home tab ➤ Create Ground Data panel ➤ Surfaces drop-down ➤ Create Surface
Menu
Surfaces menu ➤ Create Surface
Toolspace Shortcut Menu
Prospector tab: right-click Surfaces ➤ Create Surface
Command Line
CreateSurface
Dialog Box
Create Surface (page 2623)

Creating a Grid Surface
A grid surface (page 2775) comprises points that lie on a regular grid.
You can create a grid surface or import it from a DEM (page 2772) file.
Use grid surfaces for:
■

Mapping more uniform surfaces with evenly distributed sample data

■

Examining large study areas (small-scale maps)

Grid surfaces generally load quickly and require less disk space than TIN surfaces.
To create a grid surface
1 Click Home tab ➤ Create Ground Data panel ➤ Surfaces drop-down ➤ Create Surface

.

In the Create Surface (page 2623) dialog box, in the Type list, select Grid Surface.
2 Click

to select a layer. For more information about layers, see Object Layer Dialog Box (page 2221).
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NOTE If you do not select a layer, the surface is placed on the current layer.
3 In the properties grid, click the Value column for the Name property and enter a name for the surface.
NOTE To name the surface, click its default name and enter a new name, or use the name template. See
Name Template Dialog Box (page 2022).
4 To change the style for the surface, click the Style property in the properties grid and click
column.

in Value

The Select Surface Style dialog box is displayed. See Surface Styles and Visualization (page 748).
5 To change the render material for the surface, click the Render Material property in the properties grid
and click

in the Value column.

The Select Render Material dialog box is displayed. See Applying Render Materials to Objects (page 1763)
6 Set the Grid Parameters, such as spacing and orientation. Enter their values or click
area to derive these values.

to use the drawing

7 Click OK to create the surface.
After the surface is created, the surface name is displayed in the Surfaces collection in the Prospector tree,
so that you can perform other operations, such as adding data and editing the surface.
For information about adding data to the surface, see Adding and Editing Surface Data (page 660).

Quick Reference
Ribbon
Click Home tab ➤ Create Ground Data panel ➤ Surfaces drop-down ➤ Create Surface
Menu
Surfaces menu ➤ Create Surface
Toolspace Shortcut Menu
Prospector tab: right-click Surfaces ➤ Create Surface
Command Line
CreateSurface
Dialog Box
Create Surface (page 2623)

Creating a TIN Volume Surface
A TIN volume surface is a composite of points in a base surface (page 2768) and comparison surface (page 2770).
A TIN volume surface provides an exact difference between the base and comparison surfaces. Therefore,
the Z-value of any point in the volume surface is precisely the difference between the Z of the comparison
surface at that point and the base surface at that point. This is true whether the comparison and base surfaces
are both grid surface, both TIN surfaces, or one of each.
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A volume surface is a persistent surface object. Therefore, you can display cut and fill contours, cut and fill
points, and add labels to it. You can view volume properties (cut, fill, net) of a volume surface by selecting
Surface Properties. For more information, see Editing and Viewing the Surface Definition (page 731).
If you want only to query and obtain information about a surface volume or bounded volume (page 2769), use
the Volumes and Bounded Volumes utilities.
See also:
■

Calculating Surface Volumes (page 740)

To create a TIN volume surface
1 Click Home tab ➤ Create Ground Data panel ➤ Surfaces drop-down ➤ Create Surface

.

In the Create Surface (page 2623), in the Type list, select TIN Volume Surface.
2 Click

to select a layer. For more information about layers, see Object Layer Dialog Box (page 2221).

NOTE If you do not select a layer, the surface is placed on the current layer.
3 In the properties grid, click the Value column for the Name property and enter a name for the surface.
NOTE To name the surface, click its default name and enter a new name, or use the name template. For
more information, see Name Template Dialog Box (page 2022).
4 To change the style for the surface, click the Style property in the properties grid and click
Value column.

in the

The Select Surface Style dialog box is displayed. For more information, see Surface Styles and Visualization
(page 748).
5 To change the render material for the surface, click the Render Material property in the properties grid
and click

in the Value column.

The Select Render Material dialog box is displayed. For more information, see Applying Render Materials
to Objects (page 1763)
6 Click the Base Surface property to select the base (bottom) surface. Enter the surface name or click
to open the Select Base Surface (page 2027)dialog box where you can select the surface in the list.
NOTE Select a surface in the drawing by clicking

and following the instructions at the command line.

7 Click the Comparison Surface property to select the comparison (top) surface. Enter the surface name
or click
list.

to open the Select Comparison Surface dialog box where you can select the surface in the

NOTE Select a surface in the drawing by clicking

and following the instructions at the command line.

8 Click OK to create the surface.
The surface name is displayed under the Surfaces collection in the Prospector tree. For information
about adding data to the surface, see Adding and Editing Surface Data (page 660).
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Quick Reference
Ribbon
Click Home tab ➤ Create Ground Data panel ➤ Surfaces drop-down ➤ Create Surface
Menu
Surfaces menu ➤ Create Surface
Toolspace Shortcut Menu
Prospector tab: Right-click Surfaces ➤ Create Surface
Command Line
CreateSurface
Dialog Box
Create Surface (page 2623)

Creating a Grid Volume Surface
A grid volume surface is a difference grid surface based on user-specified base and comparison surfaces as
well as grid spacing and orientation.

A grid volume surface is an approximation of the difference between the base and comparison surfaces. It
is formed by making a grid from points whose Z values are the differences between the Z values of the
comparison and base surfaces. Therefore, the grid volume surface gives the exact difference only at the grid
points. This is true whether the comparison and base surfaces are both grid surfaces, both TIN surfaces, or
one of each.
Grid volume surfaces enable you to generate a volume quickly, which is useful for iterative site design.
NOTE Grid spacing has a direct correlation as to how quickly grid volumes generate.
A volume surface is a persistent surface object. Therefore, you can display cut and fill contours, cut and fill
points, and add labels to it. View a volume property (cut, fill, net) of a volume surface by selecting Surface
Properties. For more information, see Editing and Viewing the Surface Definition (page 731).
If you want only to query and obtain information about a surface volume or a bounded volume (page 2769),
use the Volumes and Bounded Volumes utilities.
See also:
■

Calculating Surface Volumes (page 740)

Creating a Grid Volume Surface | 653

To create a grid volume surface
1 Click Home tab ➤ Create Ground Data panel ➤ Surfaces drop-down ➤ Create Surface

.

In the Create Surface (page 2623) dialog box, in the Type list, select Grid Volume Surface.
2 Click

to select a layer. For more information about layers, see Object Layer Dialog Box (page 2221).

NOTE If you do not select a layer, the surface is placed on the current layer.
3 In the properties grid, click the Value column for the Name property and enter a name for the surface.
NOTE To name the surface, click its default name and enter a new name, or use the name template. For
more information, see Name Template Dialog Box (page 2022).
4 To change the style for the surface, click the Style property in the properties grid and click
Value column.

in the

The Select Surface Style dialog box is displayed. For more information, see Surface Styles and Visualization
(page 748).
5 To change the render material for the surface, click the Render Material property in the properties grid
and click

in the Value column.

The Select Render Material dialog box is displayed. For more information, see Applying Render Materials
to Objects (page 1763)
6 Click the Base Surface property to select the base (bottom) surface. You can enter the surface name or
click
list.

to open the Select Base Surface (page 2027) dialog box where you can select the surface in the

NOTE Select a surface in the drawing by clicking

and following the instructions at the command line.

7 To set the grid parameters, such as spacing and orientation, enter their values into the Values column
or click

to use the drawing area to derive these values.

NOTE The grid spacing parameters determine how precise a surface volume is. For example, small grid
spacing creates a precise volume measurement (but may increase the loading time).
8 Click the Comparison Surface property to select the comparison (top) surface. Enter the surface name
or click
list.

to open the Select Comparison Surface dialog box where you can select the surface in the

NOTE Select a surface in the drawing by clicking

and following the instructions at the command line.

9 Click OK to create the surface.
The surface name is displayed under the Surfaces collection in the Prospector tree. For information
about adding data to the surface, see Adding and Editing Surface Data (page 660).
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Quick Reference
Ribbon
Home tab ➤ Create Ground Data panel ➤ Surfaces drop-down ➤ Create Surface
Menu
Surfaces menu ➤ Create Surface
Toolspace Shortcut Menu
Prospector tab: Right-click Surfaces ➤ Create Surface
Command Line
CreateSurface
Dialog Box
Create Surface (page 2623)

Creating a Surface From a TIN File
Use the Create Surface From TIN dialog box to create a surface by importing TIN (page 2785) format data.
Importing a TIN file creates a surface object on which you can perform all the standard data operations and
editing. The import operation is displayed as the operation type Import Surface. See Understanding the
Surface Definition (page 660).
You can use this command to import a TIN file from an Autodesk Land Desktop project. To import the TIN
file, the accompanying PNT point file must exist in the same source directory.
To import a surface from a TIN file
1 Click Home tab ➤ Create Ground Data panel ➤ Surfaces drop-down ➤ Create Surface From TIN

.

2 In the Create Surface From TIN dialog box, browse to the location of the TIN file and select it.
3 Click Open to add the surface to the current drawing.
The surface name is displayed under the Surfaces collection in the Prospector tree. For information
about adding data to the surface, see Adding and Editing Surface Data (page 660).

Quick Reference
Ribbon
Home tab ➤ Create Ground Data panel ➤ Surfaces drop-down ➤ Create Surface From TIN
Menu
Surfaces menu ➤ Create Surface From TIN
Toolspace Shortcut Menu
Prospector tab: right-click Surfaces ➤ Create Surface from TIN
Command Line
CreateSurfaceFromTIN
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Dialog Box
Create Surface From TIN (standard file selection dialog box)

Creating a Grid Surface from a DEM
Use the Grid Surface From DEM dialog box to create a grid surface.
A DEM file comes in several formats. You can import either USGS DEM, ESRI Arc Grid, or GeoTIFF files.
TIP You can also import DEM files into an existing surface. For more information, see Adding DEM Files to a
Surface (page 686).
For more information about DEM file data, see DEM Files (page 683).
NOTE SDTS (Spatial Data Transfer Standard (page 2782)) DEMs are not supported in AutoCAD Civil 3D. There is a
number of free utilities that you can download and use to convert SDTS data to the supported DEM format.
To create a surface from DEM data
1 Click Home tab ➤ Create Ground Data panel ➤ Surfaces drop-down ➤ Create Surface From DEM

.

2 In the Grid Surface From DEM dialog box, browse to the location of the file.
3 Select the DEM (.dem), GeoTIFF (.tif), ESRI ASCII Grid (.asc or .txt), or ESRI Binary Grid (.adf) file. The
filename is displayed in the File Name field.
4 Click Open.

Quick Reference
Ribbon
Home tab ➤ Create Ground Data panel ➤ Surfaces drop-down ➤ Create Surface From DEM
Menu
Surfaces menu ➤ Create Surface From DEM
Toolspace Shortcut Menu
Prospector tab: Right-click Surfaces ➤ Create Surface From DEM
Command Line
CreateSurfaceGridFromDEM
Dialog Box
Grid Surface from DEM (standard file selection dialog box)

Creating a Surface Reference
You can create a reference to an existing surface in a data shortcut (page 2772) or a Vault project.
The surface reference is a lightweight read-only copy of the original, but it gives you access to surface data
for other objects such as alignments and profiles. Before you create the surface reference, it must exist in
the current project collection on the Toolspace Prospector tab.
NOTE A surface reference has no data definition, but has masking and watershed analysis functionality.

656 | Chapter 20 Surfaces

See also:
■

Creating Data Shortcuts (page 151)

■

Vault: Checking a Drawing in to a Project (page 179)

To create a reference to a data shortcut surface
1 In Toolspace, on the Prospector tab, in Master View, ensure that the correct working folder is identified
on the Data Shortcuts node.
2 Expand the Data Shortcuts ➤ Surfaces collection, right-click the desired surface, and then click Create
Reference.
The Create Surface Reference dialog box is displayed, in which you can optionally change properties
of the reference surface, as described in the following steps.
3 In the Create Surface Reference dialog box, change the source of the reference by selecting a source in
the Source Surface drop-down list.
4 Click

to select a layer. For more information about layers, see Object Layer Dialog Box (page 2221).

NOTE If you do not select a layer, the surface is placed on the current layer.
5 In the properties grid, click the Value column for the Name property. Enter a name for the surface.
NOTE To name the surface, click its default name. Enter a new name, or use the name template. For more
information, see Name Template Dialog Box (page 2022).
6 To change the style for the surface, select the Style property in the properties grid. Click
column.

in the Value

The Select Surface Style dialog box is displayed. For more information, see Surface Styles and Visualization
(page 748).
7 To change the render material for the surface, select the Render Material property in the properties grid.
Click

in the Value column.

The Select Render Material dialog box is displayed. For more information, see Applying Render Materials
to Objects (page 1763).
8 Click OK to create the surface reference.
The surface name is displayed in the Surfaces collection in the Prospector tree with a

next to it.

To create a reference to a surface in a Vault project
1 In Toolspace, on the Prospector tab, in Master View, expand the Projects ➤ <project name> ➤ Surfaces
collection, right-click the desired surface, and then click Create Reference.
The Create Surface Reference dialog box is displayed, in which you can optionally change properties
of the reference surface, as described in the following steps.
2 In the Create Surface Reference dialog box, change the source of the reference by selecting a source in
the Source Surface drop-down list.
3 Click

to select a layer. For more information about layers, see Object Layer Dialog Box (page 2221).

NOTE If you do not select a layer, the surface is placed on the current layer.
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4 In the properties grid, click the Value column for the Name property. Enter a name for the surface.
NOTE To name the surface, click its default name. Enter a new name, or use the name template. For more
information, see Name Template Dialog Box (page 2022).
5 To change the style for the surface, select the Style property in the properties grid. Click
column.

in the Value

The Select Surface Style dialog box is displayed. For more information, see Surface Styles and Visualization
(page 748).
6 To change the render material for the surface, select the Render Material property in the properties grid.
Click

in the Value column.

The Select Render Material dialog box is displayed. For more information, see Applying Render Materials
to Objects (page 1763).
7 Click OK to create the surface reference.
The surface name is displayed in the Surfaces collection in the Prospector tree with a

next to it.

Quick Reference
Toolspace Shortcut Menu (for data shortcut project)
Prospector tab: Data Shortcuts ➤ Surfaces ➤ <surface name> ➤ Create Reference
Toolspace Shortcut Menu (for Vault project)
Prospector tab: Projects ➤ <project name> ➤ Surfaces ➤ <surface name> ➤ Create Reference
Command Line
CreateSurfaceReference (for Vault surface only)
Dialog Box
Create Surface Reference (page 2453)

Creating Surfaces from GIS Data
Import GIS (Geographic Information System) data to create a Civil 3D surface.
A GIS is typically associated with a datastore maintained by a local government and contains data on various
features, such as cadastral information (land parcels), infrastructure (storm sewers, sanitary sewers, and
utilities), zoning information, and other data that may be relevant to a civil development project. You can
import GIS data into AutoCAD Civil 3D to support engineering design workflows.
AutoCAD Civil 3D enables you to connect directly to a GIS datastore and import GIS data, such as contours
and point collections, without any intermediate data or file conversion.
To import data from a GIS datastore and create a Civil 3D surface
1 Click Home tab ➤ Create Ground Data panel ➤ Surfaces drop-down ➤ Create Surface From GIS Data
.
2 On the Object Options page (page 2636) of the Import GIS Data wizard, specify the standard properties
for the new surface object.
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3 On the Connect to Data page (page 2636), specify the data source type and the GIS datastore connection
parameters:
■

If you select the SHP file as the data source type, click
to specify multiple files in a folder.

to specify a single shape file or click

■

If you select ArcSDE- or Oracle-based datastores, specify a path and user login information. Click
Login.
IMPORTANT If you connect to a datastore using ArcSDE connection, you must install three DLL files. For
information about installing the DLLs, see Working with ESRI ArcSDE Data in the AutoCAD Map 3D User’s
Guide.

4 If connecting to Oracle or ArcSDE datastore, specify the datastore and click Connect to Datastore.
NOTE The connection to the datastore is terminated after the import GIS data operation is completed.
5 On the Schema and Coordinates page (page 2637), specify the GIS schema.
NOTE The schema Default is always used for SHP files.
6 Optionally, assign the coordinate system, which may differ from the current Civil 3D drawing, to the
GIS feature class. In this case AutoCAD Civil 3D performs coordinate transformation.
7 Select a GIS feature class from the list.
8 Optionally, click Restore the Original Coordinate System to revert to the default setting.
9 Optionally, on the Geospatial Query page (page 2637), select Define Area of Interest By or and select the
geospatial query boundary type:
■

Polygon: Retrieve all objects in a defined polygon.

■

Fence: Retrieve all objects that are crossed by a defined line.

■

Circle: Retrieve all objects in a defined circle.

Alternatively, click

to select an object in the drawing or specify the query area manually.

10 On the Data Mapping page (page 2638), preview the results of the geospatial query where the GIS feature
attributes are displayed in the GIS Field column and assign a corresponding Civil 3D object property
to each field.
11 Click Finish.
The objects are added to the Civil 3D drawing.

Quick Reference
Ribbon
Home tab ➤ Create Ground Data panel ➤ Surfaces drop-down ➤ Create Surface From GIS Data

.

Command Line
CreateSurfaceFromGISData
Dialog Boxes
Import GIS Data wizard (page 2636)
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Adding and Editing Surface Data
You can edit and add data to a surface after you create it.
Surface data categories include:
■

Boundaries. Polygons that define outer, hide, and show surface boundary types.

■

Breaklines. Includes standard, proximity, non-destructive, and wall breaklines. You can define breaklines
from objects in the drawing or import them from a file.

■

Contours. Includes contour data that you can define from polyline objects.

■

DEM files. Includes USGS Digital Elevation Model DEM files.
NOTE To use SDTS files, first convert them into DEM files. For more information, see About DEM File Data
(page 684).

■

Drawing objects. Includes Line, Point, Block, Text, 3D Faces, and Polyfaces. Used for creating surface
points from AutoCAD entities.

■

Point files. Includes ASCII point files.

■

Point groups. Includes previously defined point groups.

Understanding the Surface Definition
A surface definition is a collection of a surface build, data, and edit properties, as well as a list of the operations
that you have performed on the surface. The type of definition data items that a surface can have depends
on the surface type.
The Definition collection under a surface in the Prospector tree provides access to the surface possible data
and edit definition items.
See also:
■

Editing and Viewing the Surface Definition (page 731).

Data Definition
The data definition for a surface comprises the data components that you can add to a surface.
The following table illustrates the data categories that are supported for each surface type. If the surface type
does not support a data type, the data type is not available in the surface Definition collection in the
Prospector tree.
Category

TIN Surface

TIN Volume
Surface

Grid Surface Grid Volume
Surface

Boundaries

Yes

Yes

Yes

Yes

Breaklines

Yes

No

No

No

Contours

Yes

No

No

No

DEM Files

Yes

No

Yes

No

Drawing Objects

Yes

No

No

No
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Category

TIN Surface

TIN Volume
Surface

Grid Surface Grid Volume
Surface

Point Files

Yes

No

No

No

Point groups

Yes

No

No
;

No

Edits
Data edits are operations that are not added to any of the existing data components; rather, they are added
to a surface definition as edit operations.
For more information about surface edits, including the supported types of edits for the various surface
types, see Surface Editing Operations (page 699).

Operation List
The surface build process is incremental. Every time when you add data to a surface or edit the surface, the
surface is updated. When data is removed, the surface is rebuilt. For information about building a surface,
see Rebuilding a Surface (page 735).
To support the incremental build process, a surface has an operation list, which is a sequential list of all
operations performed on the surface in its current state. For more information about the surface operations,
see Surface Editing Operations (page 699) as well as the Surface Properties - Definition (page 2656) tab.

Boundaries
A boundary is a closed polygon that affects the visibility of the triangles inside it.
When you create boundaries, you specify whether they use arc tessellation (page 664) and non-destructive
breaklines (page 664).

Boundary Types
AutoCAD Civil 3D supports the following types of boundaries:
■

Outer. Defines the outer boundary of the surface; all triangles inside it are visible and all triangles that
are outside it, are invisible.
NOTE The outer boundary may be affected by subsequent edit operations, such as Add Breaklines. You may
need to move the Add Boundary operation to the bottom of the list to achieve the expected result.
An outer boundary created using non-destructive breaklines (page 664):
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NOTE You can define multiple outer boundaries, but only the last defined outer boundary is displayed. You
can use the surface definition to switch between multiple outer boundaries.

■

Show. Displays all triangles inside the boundary; you can use it to create visible areas within hide
boundaries.
NOTE The effect of adding multiple boundaries to a surface is dependent on the order in which they are
added. The effects of a boundary can be wholly or partially overridden by a subsequent boundary.

■

Hide. Masks areas of the triangulation, and therefore contours are not visible in the area; used to punch
holes in a surface (for example, a building footprint).
A hide boundary created using non-destructive breaklines (page 664):
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NOTE When you use a hide boundary, the hidden surface area is not deleted. The full surface remains intact.
If there are surface TIN lines that you want to remove from the surface, then use the Delete Line operation.
For more information, see Deleting TIN or Grid Lines (page 700).

■

Data Clip. Creates a surface boundary limited by a polygon object from the drawing, such as 2D and 3D
polylines, feature lines, survey figures, parcels, and circles.
You can add more than one data clip boundary to a surface. When you add data, only the most recent
data clip boundary is affected. A data clip boundary does not affect the visible part of the surface, but
acts as a filter on all data, such as points and breaklines added to the surface after the creation of data
clip. For example, if you add a breakline to a surface following the creation of a data clip boundary, only
the part of the breakline that is inside the data clip boundary is added.

Surface boundaries are defined by selecting existing polygons from the drawing. The surface definition
displays the numerical ID and a list of vertices for each boundary.

Applying a Data Clip Boundary to Imported Surfaces
You can apply a Data Clip boundary to surfaces created from imported data files, including TIN, LandXML,
grading, or corridor surfaces.
To apply a Data Clip boundary to an imported surface
1 Create a surface from imported data (TIN, grading, or corridor). See Creating a Surface From a TIN File
(page 655) , Creating a New Grading Group (page 806), Creating a Corridor Surface (page 1507).
2 Add the Data Clip boundary to the surface. See Adding Boundaries to a Surface (page 664).
3 In the Prospector tree, expand the Surfaces collection, right-click <surface name> ➤ Surface Properties.
4 In the Surface Properties dialog box, click the Definition tab.
5 Select the Add Data Clip Boundary operation and click

to move it to the top of the list.
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6 Click Apply.
7 In the message box, click Rebuild the Surface.

Adding Boundaries to a Surface
Use the Prospector tree to add boundaries to a surface.
When you add or remove boundaries, the surface is modified and the modification is added to the definition
list for the surface.
Boundaries are defined from closed polygons which affects the visibility of the triangles inside them.
NOTE If the polygon is not closed, the boundary definition forces a closed polygon.
Areas hidden by boundaries are not included in calculations, such as total area and volume.
When creating a boundary, you set arc tessellation and specify whether the boundary uses non-destructive
breaklines when adding boundaries to a surface.

Arc Tessellation
When you use polygons/polylines that contain curves for boundaries or breaklines, set the mid-ordinate
distance of the chord segments, which is used to tessellate the arc segments of the boundary polygon/polyline:

Non-Destructive Breaklines
Specify whether a boundary uses non-destructive breaklines when you create it by selecting Non-destructive
breaklines in the Add Boundaries (page 2616) dialog box.
NOTE You cannot add non-destructive breaklines to a grid surface.
When you create a boundary with non-destructive breaklines along the edges of the boundary, the triangle
edges are clipped exactly where they cross the boundary:
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If you create a boundary without non-destructive breaklines along the boundary edges, only triangles that
are completely within or outside the boundary are affected:

To add boundaries to a surface
1 In Toolspace, on the Prospector tab, expand the surface Definition collection, right-click
Add.

, and click

2 In the Add Boundaries (page 2616) dialog box, enter the boundary name in the Name field.
3 Select the boundary type from the Type list. See Boundaries (page 661).
4 Optionally, select Non-destructive breakline specify that the boundary uses non-destructive breaklines.
NOTE For a TIN surface, by default, the Non-destructive breakline check box is cleared and non-destructive
breaklines are not used. For grid surfaces, the Non-destructive breakline field is disabled and not available.
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5 Optionally, if the polygon from which you are creating a boundary has curves, either enter a value in
the Mid-Ordinate Distance field or click

to specify a distance in the drawing area.

The Add Boundaries dialog box is closed. You are prompted to select a polyline.
6 Select one of the following to define the boundary:
■

An existing polyline

■

An existing polygon, such as a circle object

■

An existing parcel

The boundary is created and added to the surface Boundaries collection in the Prospector tree.

Quick Reference
Toolspace Shortcut Menu
Prospector tab: Surfaces ➤ <surface-name> ➤ Definition ➤ right-click Boundaries ➤ Add
Command Line
AddSurfaceBoundaries
Dialog Box
Add Boundaries (page 2616)

Inserting Boundary Data into the Drawing
Insert boundaries into the drawing as AutoCAD polylines.
If you deleted the original AutoCAD entity and did not update the surface, you may need to insert boundaries
into the drawing. In this case, you can import the boundary from the boundaries collection.
To insert boundary data into the drawing
1 In the Prospector tree, click the surface Boundaries collection.
The boundaries appear in the list view in the Prospector tab.
2 Right-click a boundary in the list view and click Insert Into Drawing.
■

If the boundary does not exist in the drawing, it is added as a polyline object.

■

If the boundary exists in the drawing, a message box is displayed stating that no boundaries are
inserted into the drawing.

Quick Reference
Toolspace Shortcut Menu
Prospector tab: Surfaces ➤ <surface-name> ➤ Definition ➤ right-click <boundary-name> in list view
➤ Insert Into Drawing

Editing Boundary Properties
Use the Prospector tab to view and edit boundary properties.
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When you add boundaries to a surface, the icon next to the surface Boundaries collection changes to a
and the boundaries are listed in the Prospector list view.
You can view additional boundary information and perform limited edits to boundary information in the
Boundary Properties (page 2619) dialog box.
To edit boundary properties
1 In Toolspace, on the Prospector tab, expand the surface Definition collection and click

.

The Prospector list view displays the following:
■

The name of the boundary

■

The boundary type: Outer, Show, or Hide

■

Whether the boundary is trimmed with non-destructive breaklines

2 In the list view, right-click a list item.
3 Click Properties to open the Boundary Properties (page 2619) dialog box where you can edit the name of
the boundary. All other fields are read only.

Quick Reference
Toolspace Shortcut Menu
Prospector tab: Surfaces ➤ <surface-name> ➤ Definition ➤ Boundaries ➤ right-click <boundary-name>
in the list view ➤ Properties
Dialog Box
Boundary Properties (page 2619)

Breaklines
Use breaklines to define features, such as retaining walls, curbs, tops of ridges, and streams. Breaklines force
surface triangulation along the breakline preventing triangulation across the breakline.
Breaklines are critical to creating an accurate surface model because it is the interpolation of the data, not
only the data itself, that determines the shape of the model.
NOTE You can add breaklines only to TIN surfaces.
The effects of breaklines:
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Types of Breaklines
Define standard, proximity, wall, and non-destructive breaklines for a TIN surface.
■

Standard. Defined by selecting 3D lines, grading feature lines, and 3D polylines.

■

Proximity. Defined by drawing or selecting a grading feature line or polyline object in the drawing within
the extents of the surface boundary. The XYZ coordinates of proximity breakline vertices are determined
from the surface TIN points that are in closest proximity to the corresponding vertices of the defining
points or entity.
NOTE To specify breaklines from points, first convert the points into 3D or 3D polylines using the ’PN command.
For more information, see Transparent Commands (page 1767).

■

Wall. Defined using grading feature lines, 3D lines, 3D polylines, or by specifying points. A wall breakline
is stored as a standard breakline, but defined differently: you provide an offset side for the entire breakline,
and an elevation difference for each vertex, or for the entire breakline.

■

Non-destructive. Defined using grading feature lines and open or closed AutoCAD objects. A
non-destructive breakline maintains the integrity of the original surface.

You can also import breaklines from ASCII FLT files into the surface definition.

Breakline Definition Options
When you define a breakline from a polyline with curves, specify a mid-ordinate distance, which is used to
tessellate the arcs in the polyline:
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Access global breakline definition options in the Build options property group on the Definition tab (page
2656) of the Surface Properties dialog box.
The breakline definition options include:
■

Convert Proximity Breaklines. Automatically converts proximity breaklines to standard breaklines when
they are created.

■

Allow Crossing Breaklines. Allows breaklines to cross each other.

For more information, see Editing and Viewing the Surface Definition (page 731).

Creating Standard Breaklines
Use the Add Breaklines dialog box to create standard breaklines.
You can use 3D lines, grading feature lines, and 3D polylines as breaklines. The X, Y, and Z coordinates of
each vertex on the polyline that you select are converted into TIN vertices. For 3D lines, each line that you
select is defined as a two-point breakline.
WARNING If you select a 2D polyline with a zero elevation, then it is saved with that elevation. Use proximity
breaklines if you want the elevations calculated automatically.
To create a standard breakline
1 In Toolspace, on the Prospector tab, expand the surface Definition collection, right-click
Add.

, and click

2 In the Add Breaklines (page 2615) dialog box, enter the breakline description in the Description field.
3 Select Standard from the Type list.
4 Optionally, if the polyline from which you are creating a breakline has curves, enter a value into the
Mid-Ordinate Distance field or

to select a distance in the drawing area.

The Add Breaklines dialog box closes and you are prompted to select a polyline.
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5 Select the polyline or line to define the breakline.
The breakline is created and added to the surface Breaklines collection item in the Prospector tree.

Quick Reference
Toolspace Shortcut Menu
Prospector tab: Surfaces ➤ <surface-name> ➤ Definition ➤ right-click Breaklines ➤ Add
Command Line
AddSurfaceBreaklines
Dialog Box
Add Breaklines (page 2615)

Creating Proximity Breaklines
Use the Add Breaklines dialog box to define proximity breaklines that reference surface points in proximity
to the vertices of the polyline that you select as the breakline.
Surface points are any surface data points used to create a TIN that are in proximity to the vertices of the
polyline that you select as the breakline.
You can define proximity breaklines quickly because you do not have to precisely snap to the surface points
that you want to use for the breakline. You can pick locations that are near the points that you want to use.
The breakline vertices automatically snap to the nearest surface point when the breakline is added to the
surface:

Define proximity breaklines by selecting a polyline. You do not have to draw the polyline precisely between
surface points. The breakline definition automatically snaps to the surface point that is nearest each polyline
vertex when the breakline is added to the surface.
Proximity breaklines are 2D polylines with elevations of 0. The northing, easting, and elevation are calculated
for each vertex according to the closest surface point. By default, proximity breaklines are converted to
standard breaklines when added to a surface. You can disable the automatic conversion of proximity breaklines
to standard breaklines by setting the Convert Proximity Breaklines To Standard build option to No in the
Definition tab (page 2656) of the Surface Properties dialog box.
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To define a proximity breakline
1 In Toolspace, on the Prospector tab, expand the surface Definition collection, right-click
Add.

, and click

2 In the Add Breaklines (page 2615) dialog box, enter the breakline description in the Description field.
3 Select Proximity from the Type list.
4 Optionally, if the polyline from which you are creating a breakline has curves, enter a value into the
Mid-Ordinate Distance field or click

to digitize a distance in the drawing area.

The Add Breaklines dialog box is closed. You are prompted to select a polyline.
5 Select one or several polylines or lines to define the breakline.
This creates breaklines and adds them to the surface Breaklines collection in the Prospector tree.

Quick Reference
Toolspace Shortcut Menu
Prospector tab: Surfaces ➤ <surface-name> ➤ Definition ➤ right-click Breaklines ➤ Add
Command Line
AddSurfaceBreaklines
Dialog Box
Add Breaklines (page 2615)

Creating Wall Breaklines
Use the Add Breaklines dialog box to define features, such as retaining walls or curbs as breaklines.
By creating wall breaklines, you can more accurately represent the surface. For example, for a retaining wall,
you can define the differences in elevation between the material on both sides of the wall in order to represent
elevations correctly.
Define wall breaklines by selecting an existing polyline or grading feature line. The polyline is extended by
creating new polyline segments and vertices parallel to the original polyline, but offset at an incremented
distance to represent the differences in elevation between the material on either side of the wall:
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There are two methods used to define wall breaklines:
■

Define by object vertex (Individual). Select a polyline, or line, and select the offset side. For each polyline
vertex, you select either the vertex elevation (Existing Vertex Elevation is the default) and the
corresponding offset vertex elevation (the default is Existing Polyline Vertex) or the corresponding offset
vertex elevation difference. If an elevation difference option is selected, the difference value is the default
for each subsequent vertex.

■

Define by object (All). Select a polyline, or line object, and select the offset side. Then, enter the difference
elevation to be applied for all offset vertices.

To define walls or curbs as breaklines
1 In Toolspace, on the Prospector tab, expand the surface Definition collection, right-click
and click Add.

Breaklines,

2 In the Add Breaklines (page 2615) dialog box, enter the breakline description in the Description field.
3 From the Type list, select Wall.
4 Optionally, if the polyline from which you are creating a breakline has curves, enter a value into the
Mid-Ordinate Distance field or click

to digitize a distance in the drawing area.

The Add Breaklines dialog box is closed. A message prompts you to select a polyline.
5 In the drawing, select the polyline to define the breakline.

6 Select the offset side for the wall breakline. This is the side for the new offset line that represents the
elevation of material on the other side of the wall.
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A message prompts you to specify the wall height with one value for all the points (Define By Object)
or to specify values for individual points (Define By Vertex).
7 Do one of the following:
■

To define the wall breakline by object, specify All and enter the amount to add to elevation at each
point.

■

To define the wall breakline by object vertex, specify Individual at the prompt and enter the elevation
or delta for each vertex.
The prompts provide two ways to define elevations for each offset point: as an elevation (Elevation)
or as the elevation difference (Delta) between the control point and the offset point. Deltas may be
either positive or negative values.

The breakline is created and added to the surface Breaklines collection in the Prospector tree.

Quick Reference
Toolspace Shortcut Menu
Prospector tab: Surfaces ➤ <surface-name> ➤ Definition ➤ right-click Breaklines ➤ Add
Command Line
AddSurfaceBreaklines
Dialog Box
Add Breaklines (page 2615)

Creating Non-Destructive Breaklines
Use the Add Breaklines dialog box to create a non-destructive breakline from either a grading feature line
or an open or closed AutoCAD object.
When defining a non-destructive breakline, surface points are created at each vertex of the object and at
each intersection of a surface triangle edge and the non-destructive breakline object. The new points create
additional surface triangles. Non-destructive breaklines are often needed when deleting surface areas where
a clean TIN edge does not exist.
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The elevation for each new point is extracted from the original surface triangle, therefore maintaining the
integrity of the original surface.
To add non-destructive breaklines
1 In Toolspace, on the Prospector tab, expand the surface Definition collection, right-click
Add.

, and click

2 In the Add Breaklines (page 2615) dialog box, enter the breakline description in the Description field.
3 From the Type list, select Non-destructive.
4 If the object from which you are creating a breakline has curves, enter a value in the Mid-ordinate
distance field or click

to digitize a distance in the drawing area.

5 Click OK.
The Add Breaklines dialog box closes. A message appears prompting you to select an object.
6 In the drawing area, select the objects.
7 Optionally, select other objects or press Enter to end the command.
The breakline is created and added to the surface Breaklines collection in the Prospector tree.
NOTE The Description column in the Prospector list view displays the ID of the breakline that was added to
the surface. To view information about the breakline vertices, open the Breakline Properties vista. For
information, see Viewing Breakline Information (page 676)

Quick Reference
Toolspace Shortcut Menu
Prospector tab: Surfaces ➤ <surface-name> ➤ Definition ➤ right-click Breaklines ➤ Add
Command Line
AddSurfaceBreaklines
Dialog Box
Add Breaklines (page 2615)

Importing Breaklines from a File
Use the Add Breaklines dialog box to import breaklines from a file. The supported file format is .flt (ASCII
file format).

File Linking Options
When importing breaklines, you can choose to either maintain a link to the breakline file or break the link:
■

Maintain Link To File. Reads the breakline from the FLT file when they are added and when the surface
is rebuilt. If you edit or delete the source FLT file, the Import Breakline File operation is marked as
out-of-date. With this option, you cannot list individual breaklines, view them in the Breakline Properties
vista, or import them into the drawing.

■

Break Link To File. All breaklines in the FLT file are copied into the surface as Add Breakline operations.
The FLT file is no longer referenced. When you rebuild the surface, the internal copy of the breakline is
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used. The breaklines have the full functionality of other breakline types. You can see the breaklines listed
in the Breakline Properties vista, you can pan and zoom to them, and import into the drawing.
To import breaklines into a drawing
1 In Toolspace, on the Prospector tab, expand the surface Definition collection, right-click
Add.

, and click

2 In the Add Breaklines (page 2615) dialog box, enter the breakline description in the Description field.
3 Select From File from the Type list.
4 Select the file link option. For information, see File Linking Options (page 674).
5 Click OK.
The Import Breakline File dialog box is displayed.
6 Select the file to import. It must have an .flt extension.
The breakline is created and added to the surface Breaklines collection in the Prospector tree.
NOTE The breaklines are imported and grouped by type according to their order in the .flt file.

Quick Reference
Toolspace Shortcut Menu
Prospector tab: Surfaces ➤ <surface-name> ➤ Definition ➤ right-click Breaklines ➤ Add
Command Line
AddSurfaceBreaklines
Dialog Box
Add Breaklines (page 2615)

Creating Breakline Data in a Text File
Use a text editor to create a breakline file manually.
You can then import this text file to use as breakline data for building the surface. For more information,
see Importing Breaklines from a File (page 674).
To create a breakline file manually
1 Open an ASCII text editor, such as Notepad or Wordpad.
2 Create the file using the following structure:
■

Use the (#) symbol as the first character in a comment line.

■

Use one of the letters P, S, W, L, R, N (or ND) at the beginning of the line to describe the breakline
type. These letters stand for Proximity, Standard, Wall, Wall Left, Wall Right, and Non-destructive.
Identify a breakline type for each new breakline.

■

Enter the X, Y, and Z coordinates separated by a space.

■

A description of the breakline can follow the first coordinate of the line.
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■

To create another breakline, enter the breakline type letter at the beginning of a line. In the following
example, an S is placed at the beginning of line 8 of the file. All the points from this point until the
next breakline letter modifier are in one breakline. This breakline is called EOP.

3 Save the file with an .flt file extension.
The following is an example of a breakline file:
# Autodesk User-Defined
P1542.258750 179.318779
1190.721102 350.527660
860.816542 446.044194
588.600214 619.055276
608.430540 743.406990
565.164367 925.429066
S1529.639450 179.318779
1188.918348 357.736453
1021.998725 330.653391
594.008485 610.044279
761.574952 744.929530
610.233298 754.220180
570.572642 923.626865
P1542.258750 179.318779
1190.721102 350.527660
860.816542 446.044194
588.600214 619.055276
608.430540 743.406990
565.164367 925.429066

Breakline File
0.000000 Flow_Line
0.000000
0.000000
0.000000
0.000000
0.000000
100.250000 EOP
101.420000
103.530000
102.870000
104.780000
103.410000
100.980000
0.000000 Flow_Line
0.000000
0.000000
0.000000
0.000000
0.000000

Viewing Breakline Information
Use the Prospector list view and Breakline Properties vista to view a breakline description, type, and vertices,
as well as to zoom or pan to a breakline and its vertices.
To view breakline in a drawing
1 Expand the surface Breaklines collection in the Prospector tree.
The breakline operations are displayed in the Prospector tree and list view.
2 Right-click a breakline operation in the Prospector tree or list view and do one of the following:
■

Click Zoom To or Pan To to see the location of the breakline operation in the drawing.

■

Click Properties to display the Breakline Properties (page 2619) vista, which displays the individual
breaklines as well as a list of vertices and the coordinates and elevation for each vertex.

3 To zoom or pan to an individual breakline vertex, in the Breakline Properties vista, right-click the vertex
and click Zoom To or Pan To.

Quick Reference
Toolspace Shortcut Menu
Prospector tab: Surfaces ➤ <surface-name> ➤ Definition ➤ Breaklines ➤ right-click
<breakline-operation-description> ➤ Properties
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Dialog Box
Breakline Properties Vista (page 2619)

Editing Breaklines
Edit any breaklines that you have defined by selecting it in the drawing. You can insert, move, and delete
vertices, as well as redefine the elevation at a selected vertex.
Use any AutoCAD editing commands, including:
■

Properties command (editing vertex elevations)

■

Change command

■

Pedit command (graphical editing of polylines)

■

AutoCAD grip editing

The surface stores an ID for each of the objects that are defined as breaklines. Therefore, if you modify any
of the breakline objects using any of the mentioned commands, the surface is marked as out-of-date until
you rebuild it.
NOTE You can rebuild a surface automatically by toggling the check mark next to the Rebuild - Automatic menu
entry available on the surface shortcut menu in Prospector. For more information, see Rebuilding a Surface (page
735).
To change a breakline vertex elevation or location
1 Select the breakline either graphically or by using an AutoCAD command, such as Properties Edit (Pedit)
or Change.
2 Perform the edit to the breakline.
If the breakline and surface definition become out-of-date, a
Prospector tree.

is displayed next to its node in the

3 Rebuild the surface to update the breakline definition by right-clicking the surface in the Prospector
tree and clicking Rebuild.
NOTE You can rebuild a surface automatically by toggling the check mark next to the Rebuild - Automatic
menu entry available on the surface short-cut menu in Prospector. For more information, see Rebuilding a
Surface (page 735).

To change the description of a breakline operation
1 Click the surface Breaklines collection in the Prospector tree.
The breakline operations with their descriptions and types are displayed in the Prospector list view.
2 Click the breakline operation description in the list view and enter a new description.
NOTE You cannot rename individual breakline descriptions. They are named based on the breakline operation
description.

Inserting Breakline Data into a Drawing
Insert breaklines into a drawing as AutoCAD polylines.
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NOTE You cannot insert into the drawing breaklines that you have imported from an .flt file (ASCII file format),
unless you used the Break Link To File option. For information, see Importing Breaklines from a File (page 674).
You may need to insert breaklines into the drawing if you deleted the original entity and did not update
the surface. In this case, you can import the breakline from the breakline collection.
If any of the selected breaklines exist in the drawing, a message box is displayed stating that no breaklines
are inserted into the drawing. Polyline objects are created on the current layer.
To insert breakline data into the drawing
1 Click the surface Breaklines collection in the Prospector tree.
The breaklines with their descriptions and types are displayed in the Prospector list view.
2 Right-click a breakline operation in the list view and click Insert to Drawing.
■

If the breakline objects in the breakline operation do not exist in the drawing, they are added to
the drawing as polyline objects.

■

If the breaklines exist in the drawing, a message box is displayed stating that no breaklines are
inserted into the drawing.

Quick Reference
Toolspace Shortcut Menu
Prospector tab: Surfaces ➤ <surface-name> ➤ Definition ➤ Breaklines ➤ <breakline
operation-description> ➤ right-click ➤ Insert To Drawing
Or
Prospector tab: Surfaces ➤ <surface-name> ➤ Definition ➤ Breaklines ➤ right-click
<breakline-operation-description> in list view ➤ Insert To Drawing
Or
Prospector tab: Surfaces ➤ <surface-name> ➤ Definition ➤ Breaklines ➤ <breakline
operation-description> ➤ <breakline operation-description: number> in list view ➤ right-click ➤ Insert
To Drawing
Or
Breakline Properties vista: Select breakline item in the tree view ➤ right-click ➤ Insert to drawing

Contours
Use contour data to create or modify a surface.
Surface contour data are created from polylines whose points are all at the same elevation.
You can add contour data only to TIN surfaces.

Recommendations for Creating Surfaces from Contours
When you create a surface from contour data, especially if you want to add other data to the surface, you
can generate a better surface model whose contours will match the contour data if you follow recommended
guidelines.
First, create the surface and add all your contour data. For best results, add the contour data in a single
operation. Do not add additional data such as spot elevations or breaklines at this time.
You can specify Minimize Flat Areas By options when adding the contour data, or you can add the contour
data without the options and then use Check for Contour Problems to locate contour problems and repair
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them. For information on repairing contour problems, see Checking for Contour Problems (page 765) and
Minimizing Flat Areas in a Surface (page 705).
NOTE For some contour data sets, Check for Contour Problems report large numbers of errors if you add the
contour data to the surface without specifying Minimize Flat Areas By options.
After you have added your contour data and repaired problems, verify the contours visually. Add additional
contours where needed, and add spot elevation data or breaklines only where they are required to correct a
specific problem. For more information on repair, see Supplementing Missing Contour Information (page
680) and Minimizing Flat Areas in a Surface (page 705). Repair all problems.
After you have identified and repaired contour problems, add additional surface data such as additional spot
elevation points. Add surface boundaries last. Add boundaries starting at the outside of the surface and
working toward the inside.

Weeding and Supplementing Factors for Contours
Use weeding and supplementing to add or remove vertices along a contour.
Set the weeding and supplementing parameters when you add the contour data to the surface definition in
the Add Contour Data (page 2617) dialog box.

Weeding Factors
Weeding reduces the number of points generated along the contours. The weeding factors ignore both
vertices that are closer together than the distance factor and vertices that deflect less than the angle factor.
A larger distance and deflection angle weeds a greater number of points. The distance factor is measured in
linear units, and the angle factor is measured in angular units. The weeding factors must be less than the
supplementing factors.
A point on the contour is weeded by calculating its location in relation to the vertices before and after it. If
the length between these three points is less than the weeding length value, and the deflection angle is less
than the weeding angle value, then the middle point is not added to the contour data file.
Examples of weeding factor parameters:
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Supplementing Factors
Supplementing factors add vertices along contours.
The supplementing distance is the maximum distance between vertices. If the distance between vertices on
a contour is greater than the supplementing factor, then points are added along the contour at equal intervals
that are less than or equal to the supplementing distance. The smaller the distance, the greater the number
of supplemented points.
Example of the distance (SD) parameter with supplemented vertices:

The mid-ordinate distance is the distance from the midway point of an arc to the chord of the arc. The
mid-ordinate distance is used to add vertices to a polyline curve, creating an approximation of the curve
using straight line segments. The length of these segments depends on the value of the mid-ordinate distance.
Example of the mid-ordinate parameter:

Contour Data and Surface Triangulation
Information obtained from a contour map differs greatly from data taken randomly in the field.
Since contour map data is interpolated, the information may be less accurate than direct field data. The
accuracy of the final surface model depends on both the quality of the contour map and the contour interval.
If you bring contour data into the drawing as points, then the points would not be very random. In steep
areas, points would be close together. In flat areas, there is a greater distance between points on different
contours. In both cases, the points along the contours are generally close together. Therefore, information
taken from contours does not make effective random point data, and random data points generate the best
triangulation.

Supplementing Missing Contour Information
When you create a model from contours and then generate contours from this model, in some cases, AutoCAD
Civil 3D may not generate the same set of contours.
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In the most common situation, surface data is missing in either a low or high area, such as near the top of
a hill, at the bottom of a valley, or on the edge of the site.
To correct this problem, place spot elevations or another contour line near the place where the surface data
is missing. For example, if a contour line is missing along the top of a hill, place a new contour, breakline,
or spot elevation at the estimated maximum elevation of the hill. The recommended practice is to place any
interpolated data, points, or contours on a separate layer.
If you create a surface using only contour information, you may need to place breaklines or spot elevations
in areas where the contour line changes direction drastically. Areas where this is likely to happen include:
a crowned roadway, a swale, or a ridge. In these places, contours tend to triangulate onto themselves. In
most instances, the Minimize Flat Areas operation resolves this problem. For more information, see Minimizing
Flat Areas in a Surface (page 705). In severe situations, you may need to add additional point or breakline
data.
For best results, always follow the suggested order of operations for adding contour data to a surface. See
Recommendations for Creating Surfaces from Contours (page 678).

Adding Contour Data to a Surface
Use the Add Contour Data dialog box to add contour data from polylines to a surface.
To add contour data to a surface
1 In Toolspace, on the Prospector tab, expand the surface Definition collection, right-click
and click Add.

Contours,

2 In the Add Contour Data (page 2617)dialog box, enter the contour description in the Description field.
3 Enter the distance and angle weeding factors in the corresponding fields or click
to digitize a distance
or angle in the drawing area. For more information, see Weeding and Supplementing Factors for Contours
(page 679).
4 Enter the distance and mid-ordinate distance supplementing factors in the corresponding fields or click
to select a distance or mid-ordinate distance in the drawing area.
5 Select options for minimizing flat areas in the surface. For more information, see Minimizing Flat Areas
in a Surface (page 705).
6 Click OK.
7 Select the polyline to define the contour data and press Enter.
The contour data is created and added to the surface Contours collection in the Prospector tree.
NOTE Before displaying the Add Contour Data dialog box, it can be useful to create a selection set of contour
objects using the QSELECT command at the command line or choosing Select Similar from the Edit menu.

Quick Reference
Toolspace Shortcut Menu
Prospector tab: Surfaces ➤ <surface-name> ➤ Definition ➤ right-click Contours ➤ Add
Command Line
AddSurfaceContours
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Dialog Box
Add Contour Data (page 2617)

Listing and Identifying Contours
Zoom or pan to contour data and list its description and summary.
To identify contours in a drawing
1 Click the surface

Contours collection in the Prospector tree.

The contours with their descriptions and summaries are displayed in the Prospector list view.
2 Right-click a contour data item in the Prospector list view and click Zoom To or Pan To, to see the
location of the contour data in the drawing.

Editing Contours
Edit any contour that you have defined by selecting it in the drawing. You can insert, move, and delete
vertices, as well as redefine the elevation at a selected vertex.
You can use any AutoCAD editing commands, including:
■

Properties command (editing vertex elevations)

■

Change command

■

Pedit command (graphical editing of polylines)

■

AutoCAD grip editing

The surface stores an ID for each of the objects that are defined as contours. Therefore, if you modify any
of the contour objects using any of the mentioned commands, the surface is marked as out-of-date until
you rebuild it.
NOTE You can rebuild a surface automatically by toggling the check mark next to the Rebuild - Automatic menu
entry available on the surface short-cut menu in Prospector. For more information, see Rebuilding a Surface (page
735).
To change a contour vertex elevation or location
1 Select the contour graphically or by using an AutoCAD command, such as PEDIT or CHANGE.
2 Perform the edit to the contour.
If the contour and surface definition become out-of-date, a
Prospector tree.

is displayed next to its node in the

3 Rebuild the surface to update the contour definition by right-clicking the surface in the Prospector tree
and clicking Rebuild.
TIP You can update the surface automatically by turning on Rebuild - Automatic. For more information, see
Rebuilding a Surface (page 735).
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Inserting Contour Data Into a Drawing
Insert contour data into the drawing as AutoCAD polylines using the Insert to Drawing command.
In some situations, the surface keeps breakline or contour data (a list of their point coordinates), but does
not associate them with an object. This may happen, for example, when you deleted an entity that the
surface depends on, but the Copy Deleted Dependent Objects option on the Definition Tab (Surface Properties
Dialog Box) (page 2656) page of the Surface Properties dialog box is set to Yes. In this case, the surface simply
converts its reference from a drawing entity to a list of points defining the object’s geometry.
To restore the reference to the object entity, you can insert the data associated with the deleted contour.
To insert contour data into the drawing
1 In the Prospector tree, expand the Surfaces collection ➤ <surface name> ➤ Definition.
2 Click the Contours collection.
The contours with their descriptions are displayed in the Prospector list view.
3 Right-click a contour operation in the list view and click Insert To Drawing.
■

If the contour objects in the contour operation do not exist in the drawing, they are added to the
drawing as AutoCAD polyline objects.

■

If the contours exist in the drawing, a corresponding message is displayed.

NOTE You can insert multiple contours using the Insert To Drawing command.

Quick Reference
Toolspace Shortcut Menu
Prospector tab: Surfaces ➤ <surface-name> ➤ Definition ➤ Contours ➤ <breakline
operation-description> ➤ right-click ➤ Insert To Drawing
Or
Prospector tab: Surfaces ➤ <surface-name> ➤ Definition ➤ Contours ➤ right-click
<breakline-operation-description> in list view ➤ Insert To Drawing

DEM Files
Use digital elevation model (DEM) files or SDTS files converted to a DEM format to import points into a
surface.
DEM files are used to store and transfer large-scale topographic relief information for use in GIS, earth
sciences, resource management, land planning, surveying, and engineering projects. DEM files typically
contain land XYZ information at a regular grid-spaced interval to represent ground relief.
You can add and remove DEM files, and view DEM information. To transform DEM coordinates so they
match the coordinate system of the current drawing when the surface is built, specify a coordinate system
for the DEM file.
DEM files are a valuable data source for many planning and engineering tasks that might not need the type
of precision gained by doing a ground or aerial survey. DEM files can also, in some places, completely
eliminate the need for specific surveys. Usually, the DEM data is not precise enough to use on small-scale
studies, but is ideal for large-scale planning and analysis tasks.
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Some examples of projects that can benefit from DEM information include hydrologic studies, corridor
planning for highways and pipelines, land use planning and analysis, slope analysis, and large-scale project
visualization.

Obtaining DEM Files
DEM files are widely available on the Internet. For example, the United States Geological Survey (USGS)
provides many DEM files at their web site.
NOTE SDTS (Spatial Data Transfer Standard) format DEM data is not supported for this release of AutoCAD Civil
3D. However, you can use free utilities to convert SDTS data to DEM format.

About DEM File Data
DEM files typically contain land XYZ information at a regular grid-spaced interval to represent ground relief.
DEM files are created to strict standards, as specified by the USGS. For complete information about the DEM
file format, see “Standards for Digital Elevation Models,” in National Mapping Program Technical Instructions,
published by the U.S. Department of the Interior, U.S. Geological Survey, National Mapping Division. You
can find this documentation on the USGS web site.
In general, the DEM source data is contained in one section of the DEM file (Logical record type `A'), and
the actual data (XYZ) information is contained in another part of the DEM file (Logical record type `B').
The following data, based on logical record type `A', is displayed for each DEM file that you add to a surface:
Element
Name

Corresponding Data Details
Element Number in
Logical Record Type
’A’

Description

1

The first 140 characters of a DEM file, which may include
the file name and location.

Estimated
Point
Total

N/A

The estimated number of points in the DEM file, rounded
up to three significant digits.

Coordinate System Type

5

The ground planimetric reference system: UTM, State
Plane, or Lat/Long.

Zone

6

Code that defines the zone in ground planimetric reference system. These can be found in Appendixes 2-E and
2-F of Standards for Digital Elevation Models. The Zone
is meaningful only if Coordinate System Type is UTM or
State Plane.

Horizontal
Datum

27

The horizontal datum of the ground planimetric reference system, such as NAD27.

Vertical
Datum

26

■

1 = local mean sea level

■

2 = National Geodetic Vertical Datum 1929 (NGVD
29)

■

3 = North American Vertical Datum 1988 (NAVD
88)
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Element
Name

Corresponding Data Details
Element Number in
Logical Record Type
’A’
For more information, see Appendix 2-H of the Standards
for Digital Elevation Models.

Vertical
Datum
Shift

31

The value is the average shift value for the four quadrangle corners obtained from program VERTCON.
AutoCAD Civil 3D adds this value to the vertical datum
to convert to NAVD88. If the vertical datum is NAVD88,
then the vertical datum shift value should be zero.

DEM Level

3

There are three possible DEM Levels:
■

Level 1 DEMs are elevation data sets in a standardized format. This level includes 7.5-minute DEMs or
an equivalent that is derived from stereo profiling
or image correlation of National High Altitude Photography Program, National Aerial Photography
Program, or equivalent photographs.

■

Level 2 DEMs are elevation data sets that were processed or smoothed for consistency and edited to
remove identifiable systematic errors. DEM data derived from hypsographic and hydrographic data digitizing, either photogrammetrically or from existing
maps, are entered into the Level 2 category after
review on a DEM editing system.

■

Level 3 DEMs are derived from DLG data by using
selected elements from both hypsography (contours
and spot elevations) and hydrography (lakes,
shorelines, and drainage). If necessary, ridge lines
and hypsographic effects of major transportation
features are also included in the derivation.

X-Y Units

8

The unit of measure for ground planimetric coordinates
throughout the file, such as radians, feet, meters, or arcseconds.

Elevation
Units

9

The unit of measure for elevation coordinates throughout
the file, such as feet or meters.

Minimum
Elevation

12

The minimum elevation for the DEM. The value is the
units of measure defined by Elevation Units.

Maximum
Elevation

12

The maximum elevation for the DEM. The value is the
units of measure defined by Elevation Units.

X Spacing

15

DEM spatial resolution for X values. The value is the units
of measure defined by the XY Units.

Y Spacing

15

DEM spatial resolution for Y values. The value is the units
of measure defined by the XY Units.
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Adding DEM Files to a Surface
Use the Prospector tree to add DEM file data to a surface and to work with a DEM file data. The DEM file
data is combined with any other surface data that you define.
To add a DEM file to a surface
1 In Toolspace, on the Prospector tab, expand the surface Definition collection, right-click
Add.

, and click

2 In the Add DEM File (page 2627) dialog box, enter the path and name of the DEM file or click
browse to the location of the DEM file.

and

3 Select the DEM file so that its name is displayed in the File Name field and click Open.
The DEM file name and information is displayed in the corresponding Add DEM File dialog box fields.
4 Optionally, change the coordinate system of the DEM data. For more information, see Changing the
Specified Coordinate System of a DEM File (page 686).
The points of the DEM file are transformed from the specified coordinate system of the DEM file to the
coordinate system of the current drawing taking into account any Transformation settings specified in
the Drawing Settings dialog box.
NOTE DEM files cannot be transformed for grid surfaces. If you include a DEM file as part of a grid surface
definition, its coordinate system must match that of the drawing, or it cannot be added.
5 Click OK to import the DEM file into the surface.
The DEM file is added to the surface DEM Files collection in the Prospector tree.

Quick Reference
Toolspace Shortcut Menu
Prospector tab: Surfaces ➤ <surface-name> ➤ Definition ➤ right-click DEM Files ➤ Add
Dialog Box
Add DEM File (page 2627)

Changing the Specified Coordinate System of a DEM File
Use the Prospector tree to specify or change a DEM file coordinate system. If the DEM file coordinate system
is different from the current coordinate system of the drawing, you can specify a coordinate system for the
DEM file. The coordinate system you specify for the DEM file should match the data defined in the DEM
file itself.
NOTE Specify a coordinate system for the DEM file only if the coordinate system of the DEM file is different from
the current coordinate system of the drawing and you want a coordinate transformation to occur when you build
the surface.
If you used the wrong coordinate system when adding the DEM file, you can select a different coordinate
system for the file by changing the DEM file properties.
NOTE If the coordinates are transformed, the points no longer lie on a grid. Therefore, the transformation of DEM
data is not supported when adding a DEM file to a grid surface. You can change a DEM coordinate system only
when adding a DEM file to a TIN surface.
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The following table lists some specific examples about how coordinates are read and processed when using
various coordinate system settings in your drawings and DEM files:
When the DEM Coordinate System
(source) is set to...

And the Drawing
Coordinate System
(destination) is set
to...

The following results occur:

NH State Plane NAD27

NH State Plane NAD83

The DEM file coordinate data is transformed from NAD27 to NAD83 when
you build the surface.

NH State Plane NAD27

None

The DEM file data is not transformed
when the surface is built; the DEM file
data is taken at face value. For example, point 100,100,100 in the DEM
file is point 100,100,100 in the surface.

None

None

The DEM file data is not transformed
when the surface is built; the DEM file
data is taken at face value. For example, point 100,100,100 in the DEM
file is point 100,100,100 in the surface.

None

NH State Plane NAD83

The DEM file data is not transformed
when the surface is built; the DEM file
data is taken at face value. For example, point 100,100,100 in the DEM
file is point 100,100,100 in the surface.

NH State Plane NAD83

NH State Plane NAD83

No transformation is applied.
NOTE Specifying a coordinate system
for a DEM file is not necessary in this
situation. However, if you are working
with multiple drawings in the current
project, and the drawings have different coordinate systems, it is recommended that you specify a coordinate
system for the DEM file in case you
need to rebuild the surface in a drawing that has a different coordinate
system.

To change the specified coordinate system of a DEM file
1 In Toolspace, on the Prospector tab, expand the surface Definition collection, and click

DEM Files.

2 Right-click a DEM file in the Prospector list view and click Properties.
3 In the DEM File Properties (page 2627) dialog box, select the CS Code property field and click the browse
button.
4 In the Select Coordinate Zone (page 2640)dialog box, click the Category list and select a category.
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5 Select a coordinate system from the category list.
6 Optionally, click Properties to view the properties of the selected coordinate system.
7 Click OK to select the coordinate system and close the dialog box.
The DEM file property group displays the newly selected coordinate system.

Quick Reference
Toolspace Shortcut Menu
Prospector tab: Surfaces ➤ <surface-name> ➤ Definition ➤ DEM Files ➤ right-click <DEM-file> in list
view ➤ Properties
Dialog Box
DEM File Properties (page 2627)

Importing DEM Extents
You can import the extents of a selected DEM file into the drawing as 2D polyline objects.
The polyline is drawn as a rectangle representing the four corners of the DEM extents.
To import DEM extents
1 In Toolspace, on the Prospector tab, expand the surface Definition collection, and click

.

The DEM files with their names, modified dates, and sizes are displayed in the Prospector list view.
2 In the list view, right-click the DEM file for which you want to import the extents and click Import
DEM Extents.
The DEM extents are drawn as a polyline rectangle representing the four corners of the DEM extents.

Quick Reference
Toolspace Shortcut Menu
Prospector tab: Surfaces ➤ <surface-name> ➤ Definition ➤ DEM Files ➤ right-click <DEM-file> in list
view ➤ Import DEM Extents

Viewing DEM Data and Properties
Zoom or pan to DEM file data, and view information about its data including its coordinate system, projection,
and datum.
To zoom or pan to DEM file data
1 In Toolspace, on the Prospector tab, expand the surface Definition collection and click

DEM Files.

The DEM files are displayed in the Prospector list view.
2 In the list view, right-click a DEM file and click Zoom To or Pan To.
The drawing area displays the surface data zooming or panning to the area relative to the selected DEM
data (according to the surface style settings). For information about setting and changing the surface
display, see Surface Styles and Visualization (page 748).
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To view DEM file properties
1 In Toolspace, on the Prospector tab, expand the surface Definition collection, and click

.

The DEM files are displayed in the Prospector list view.
2 In the list view, right-click on the DEM file and click Properties to display the DEM File (Add/Properties)
Dialog Box (page 2627).
Detailed information about the DEM file is displayed in the DEM File Information field. For more
information, see About DEM File Data (page 684).

Quick Reference
Toolspace Shortcut Menu
Prospector tab: Surfaces ➤ <surface-name> ➤ Definition ➤ DEM Files ➤ right-click <DEM-file> in list
view ➤ Properties

DEM Files and Memory Usage
Large TIN surfaces, such as those built from DEM files, can require a substantial amount of memory (RAM
and virtual memory) and disk space to build and save the surface. TIN surfaces require about 100 bytes per
point, whereas grid surfaces require about 16 bytes per point.
It is important to ensure that you have sufficient resources before you build a surface using a DEM file. Also,
be aware that certain commands may take longer than expected when working with these surfaces.

General Guidelines for DEM File Memory Usage
As a general rule, a 1 MB DEM file contains 160,000 points. For larger DEM files, the number of points grows
proportionately to the DEM file size at a rate of approximately 160,000 points per 1 MB of DEM file size.
See also:
■

Working with Large Surfaces (page 740)

Adding Surface Point Data from AutoCAD Drawing Objects
Use AutoCAD objects such as 3D lines to add surface point data to the surface definition.
The selected AutoCAD objects are interpreted based on their points, and specific point data is created for
each object type that you add to the surface definition.
For several object types, you can specify whether to maintain the object edges when adding the object points
to AutoCAD Civil 3D.
NOTE Drawing objects added to the surface are added as point data. After the point data has been added to the
surface there is no relationship between the surface and the original drawing objects.
You can select the following AutoCAD drawing objects to add points to a surface definition:
■

Points. The XYZ coordinates of the object are used to define the surface point.

■

Lines. The XYZ coordinates of the object endpoints are used to define surface points.

■

Blocks. The block insertion point XYZ coordinates are used to define the surface point.

■

Text. The text insertion point XYZ coordinates are used to define the surface point.
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■

3D Faces. The XYZ coordinates of the object endpoints are used to define surface points.

■

Polyfaces. The XYZ coordinates of the object endpoints are used to define surface points.
NOTE Optionally, when adding lines, 3D faces, and polyfaces, you can maintain the original AutoCAD object
edges as surface triangle edges.

NOTE To add COGO points to surface data, add point groups. For more information, see Point Groups (page
693).
To add points to a surface from AutoCAD objects
1 In the Toolspace, on the Prospector tab, expand the surface Definition collection, right-click
click Add.

, and

2 In the Add Points From Drawing Objects (page 2618) dialog box, select the object type from the Object
Type list.
3 Click Maintain Edges From Objects if you are adding points from lines, 3D faces, or polyfaces, and you
want to maintain the AutoCAD object edges. This prevents AutoCAD Civil 3D from optimizing the
edges.
4 In the Description field, enter a description for the object.
5 Click OK.
6 Select the object in the drawing or use any of the standard AutoCAD object selection methods.
The objects are added to the surface definition and are displayed in the surface Drawing Objects collection
list view with their description and type.

Quick Reference
Toolspace Shortcut Menu
Prospector tab: Surfaces ➤ <surface-name> ➤ Definition ➤ right-click Drawing Objects ➤ Add
Dialog Box
Add Points from Drawing Objects (page 2618)

Moving Blocks to Attribute Elevation
Move AutoCAD block objects with attributes (such as labels or tags) at their insertion point to the elevation
of one of the block’s attribute objects.
Use this command when you need to use block objects in the drawing as surface point data.
For example, the block object can display an elevation value from one of its attributes, but the elevation of
the block reference can be different. Using this command prepares the surface data before defining a surface
from block reference objects using the Add Points From Drawing Objects (page 2618) command.
To move block objects to their attribute elevation
1 Select a surface. On the Surface tab, click Surface Tools panel
.
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Move Blocks To Attribute Elevation

2 In the Move Blocks to Attribute Elevation dialog box, select a block reference name from the list or click
to select a block reference from the drawing.
3 Under Select Elevation Attribute Tag, select the required tag.
4 Click OK.
The selected block reference objects are moved to the elevation of the specified attribute.

Quick Reference
Ribbon
Select a surface. On the Surface tab, click Surface Tools panel

Move Blocks To Attribute Elevation

Menu
Surfaces menu ➤ Utilities ➤ Move Blocks To Attribute Elevation
Command Line
MoveBlocksToAttribElev
Dialog Box
Move Blocks to Attribute Elevation (page 2639)

Moving Text to Elevation
Move AutoCAD text objects at their insertion point to the elevation of their numeric text values.
Use this command when you need to use a TEXT object in the drawing as surface point data.
You can select AutoCAD numeric TEXT and MTEXT objects in the drawing and move each object at its
insertion point to the elevation corresponding to its numeric text value.
To move a text object to the elevation value
1 Select a surface. On the Surface tab, click Surface Tools panel

Move Text To Elevation

.

2 Select the text object in the drawing or use any of the standard AutoCAD object selection methods.
3 Click Enter.
If the value of a text object is a real number, the text object is moved to the elevation corresponding to the
numeric text value.

Quick Reference
Ribbon
Select a surface. Surface tab ➤ Surface Tools panel

Move Text To Elevation

Menu
Surfaces menu ➤ Utilities ➤ Move Text To Elevation
Command Line
MoveTextToElevation
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Point Files
If you have point data files that you created either manually or by downloading a data collector, you can
use the point data as surface data.
Any point file format that can be imported to create AutoCAD Civil 3D points can be used to add points to
surfaces.
The following is an example of the PENZ space-delimited format, which is just one of the point file formats
recognized by the surface Add Point File command.
A PENZ space-delimited point file contains: point number, easting (X), northing (Y), elevation (Z)). Within
the file, the following syntax is used for each point:
[Point Number] [Easting (or X)] [Northing (or Y)] [Elevation (or Z)]

An example of the contents of a PENZ space delimited format point text file:
26303
26304
26305
26306
26307
26308
26309

315872.971714
315876.474880
315873.911320
315861.792509
315855.883079
315855.585197
315861.566272

4838799.938284
4838813.524640
4838829.056520
4838799.287159
4838798.942969
4838811.389822
4838812.001057

111.250000
111.280000
111.950000
112.060000
114.160000
114.080000
111.920000

There are several supported point file formats. If your point files use a format that is not recognized by the
surface Add Point File command, you can convert the files to a supported format.
First, you create a point file format that describes the layout of the data in the point files. Then, using the
point file format, you convert the files to a supported format using the Transfer Points utility. For more
information, see Transferring and Converting Point Data (page 536).
You can manually create ASCII text files that contain point data. For more information, see Creating a Point
File Manually (page 693).

Adding Surface Data from a Point File
Add points from a point file directly to an existing surface.
To add point files to a surface
1 In Toolspace, on the Prospector tab, expand the surface Definition collection, right-click
Add.
2 In the Add Point File (page 2618) dialog box, select the format of the point file or click
point file format that describes the layout of the data in the point data file.
3 Enter the point file path and name into the Source File field or click
file.

, and click

to create a

to browse and select the point

4 Click Open to add the point file to the surface.
If the point file contains a line with bad data, an error (including the line number) is posted the Event
Viewer and the operation continues.
The point file is added to the Point Files item view.
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Quick Reference
Toolspace Shortcut Menu
Prospector tab: Surfaces ➤ <surface-name> ➤ Definition ➤ right-click Point Files ➤ Add
Command Line
AddPointFile
Dialog Box
Import Point File (page 2364)

Creating a Point File Manually
Create a PENZ space-delimited point file containing point information and use the file to create or add data
to a surface in AutoCAD Civil 3D.
To create a point file manually
1 Open a text editor, such as Notepad.
2 Enter the point number, easting, northing, and elevation values. Separate each value by one or more
spaces.
3 Enter the information for each point on a separate line. For best results, do not include extra spaces at
the end of a line or blank lines at the end of the file. The file should consist entirely of point data.
However, you can add a comment line by entering a # sign at the beginning of a line.
4 Save the file as a text file.
An example of a PENZ space-delimited point file:
# Autodesk Point File Format
3 379.910000
511.270000
227.620000
4 393.880000
497.100000
225.750000
5 382.640000
464.050000
223.890000
6 403.690000
429.340000
222.880000
103 190.080000
307.560000
194.250000
104 182.090000
322.940000
194.940000
105 174.100000
338.320000
195.630000
106 142.910000
340.320000
203.030000
107 117.470000
342.780000
208.460000
108 124.430000
394.400000
208.410000
109 137.700000
400.690000
205.430000

Point Groups
Add point groups to a surface definition.
Use point groups to break the drawing COGO points into smaller groupings of points, to identify points
that share common characteristics, such as number, name, elevation, or that are used to perform a task,
such as creating a surface.
You can create point groups that contain specific points, such as all existing ground points, making it easier
to manage the surface points.
See Understanding Point Groups (page 553).
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Adding Point Groups
Use the Point Groups collection of the Prospector tree to add point groups to a surface definition.
For information about creating point groups, see Creating Point Groups (page 561).
To add a point group to a surface
1 Create a point group if needed. For information, see Creating Point Groups (page 561).
2 In Toolspace, on the Prospector tab, right-click the surface

Point Groups collection and click Add.

3 In the Point Groups dialog box, in the list of available point groups, select the point group to add to
the surface.
4 Click OK to add the point group to the surface.
The point group is added to the Point Group list view in Prospector.
NOTE For information about other point group functionality, such as viewing and changing the properties
of a point group, see Understanding Point Groups (page 553).

Quick Reference
Toolspace Shortcut Menu
Prospector tab: Surfaces ➤ <surface-name> ➤ Definition ➤ right-click Point Groups ➤ Add
Command Line
AddSurfacePointGroup
Dialog Box
Point Groups (page 2358)

Moving Blocks to a Surface Elevation
Use the Move Blocks to Surface command to manipulate reference object block data.
You can use the reference object block data to define a surface. Moving blocks to surface can also be useful
for visualization of multi-view block objects.
To move Block Reference objects to a surface elevation
1 Select a surface. On the Surface tab, click Surface Tools panel

Move Blocks To Surface

.

2 If the drawing contains more then one surface, from the Select a Surface dialog box, select the surface
or click

to pick the surface manually.

3 In the Move Blocks to Surface dialog box, select the Block Reference objects or click
block reference objects directly from the drawing.

to select the

4 Click OK.
Each selected Block Reference object is moved from its current elevation to the elevation of the surface at
the object insertion point.
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Quick Reference
Ribbon
Select a surface. Surface tab ➤ Surface Tools panel

Move Blocks To Surface

Menu
Surfaces menu ➤ Utilities ➤ Move Blocks To Surface
Command Line
MoveBlocksToSurface
Dialog Box
Move Blocks to Surface (page 2639)

Extracting Surface Data
You can extract AutoCAD primitive entities from an AutoCAD Civil 3D surface.
Extracting individual components from a surface enables you to manipulate these components without
exploding the surface object. The surface data available to extract is based on the display properties of the
selected surface.
NOTE The extracted objects preserve the properties set in the current surface style.
The following table lists the extracted objects for each type of surface components.
Surface component ...

Is extracted as ...

Points (2D and 3D)

Point objects

Triangles (2D and 3D)

3D face objects

Border (2D)

■

POLYLINE object

■

LWPOLYLINE object (if the Border Display Mode (page 2645)
is set to Flatten to Elevation)

■

POLYLINE object

■

LWPOLYLINE object (if the Border Display Mode (page 2645)
is set to Flatten to Elevation)

■

3D face object (if Use Datum (page 2645) and Project Grid to
Datum (page 2645) are set to true)

Border (3D)

Major Contour (2D and 3D)

LWPOLYLINE object

Minor Contour (2D and 3D)

LWPOLYLINE object

User Contours (2D and 3D)

LWPOLYLINE object

Gridded (2D and 3D)

■

POLYLINE object (if the Border Display Mode (page 2645) is
set to Use Surface Elevation

■

LWPOLYLINE object (if the Border Display Mode (page 2645)
is set to Flatten to Elevation)
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Surface component ...

Is extracted as ...

Directions (2D and 3D)

The type of object depends on the surface style settings. See
Creating a Surface Style (page 749).

Elevations (2D and 3D)
Slopes (2D and 3D)
Slope Arrows (2D and 3D)
Watersheds (2D and 3D)

To extract an object from a surface
1 Select a surface. On the Surface tab, Surface Tools panel, click Extract Objects

.

2 If more than one surface is available in the drawing, in the Select a Surface dialog box, select the surface
from which to extract components.
3 In the Extract Objects from Surface dialog box, under Property, deselect the components that you do
not want to extract (all visible surface components are selected by default).
4 Under Value, do one of the following:
■

Choose Select All to select all the surface components for extraction.

■

Choose Select From Drawing, click

, and select the required surface components.

5 Click OK.
Every selected surface component is extracted from the surface object.

Quick Reference
Ribbon
Select a surface. On the Surface tab, Surface Tools panel, click Extract Objects
Menu
Surfaces menu ➤ Utilities ➤ Extract Objects From Surface
Command Line
SurfaceExtractObjects
Dialog Box
Extract Objects from Surface (page 2635)

Surface Errors and Issues
Identify and troubleshoot errors or problems with a surface, or its data components.

Definition Type Errors
View several error types that may be displayed in the surface’s Operation Type list on the Definition tab of
the Surface Properties dialog box.
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The error types are:
■

Item modified

■

Item not found
box is initialized.

■

Item not OK
surface.

Indicates that the definition item has been modified after being added to the surface.
Indicates that the definition item is not found when the surface properties dialog

Indicates that the definition item was not successfully added due to a change in the

For more information about the Operation Type list, see (page 2656)

Build Errors
Use the Event Viewer to view surface build errors that occur when data or edit operations cannot be performed
due to removal of the data or its dependencies.
The following is a list of build errors that can be displayed:
Error String

Possible Cause

Build Error - Duplicate Point

A duplicate point XY location was ignored at <XY coordinates>.

Build Error - Crossing Breakline

A crossing breakline was ignored at <starting or ending
coordinate>.

Build Error - Breakline Crossing an Existing Data Point

Breakline crosses an existing point.

Surface Disconnection Error
Use the Surface Properties dialog box to view and correct a surface disconnection error, which can occur
when a surface becomes disconnected from an external file that it references.
When this occurs,
is displayed in the Import Surface operation type on the (page 2656) of the Surface
Properties dialog box indicating that the item was not found. You cannot rebuild the surface. However,
additional data can be added, and certain edits (those that do not cause a rebuild) can be performed.
The problem can be fixed by editing the Operation Type parameter and entering the correct path and name
for the external file.

Unable to Rebuild Snapshot
An exclamation icon
is displayed next to the definition of the surface in the Prospector tree view and
you are unable to rebuild the surface snapshot.
When you rebuild the surface snapshot, the following error message is displayed:
Unable to rebuild Surface. Couldn't find file(s).
If you installed AutoCAD Civil 3D to a location other than the default, you must update the XML file’s path
before you can update the snapshot.
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To locate and update the XML file path
1 To update the path, right-click the surface name in the Prospector tree, right-click, and click Properties.
2 In the Surface Properties dialog box, on the Definition tab, click the folder icon next to Import XML
File.
3 In the Import XML File dialog box, browse to the location where you installed AutoCAD Civil 3D, and
locate the XML files.
4 Click Open. Click OK.
5 When prompted if you want to rebuild the surface, click Yes to update the surface properties, and
rebuild the surface.
6 To update the snapshot, right-click the surface name in the Prospector tree, and click Rebuild Snapshot.
7 Right-click the surface name in the Prospector tree, and click Rebuild.

Using the Default Surface Settings
When you import a surface TIN or XML file, the surface uses the default styles as specified in the surface
settings.
To use a different style, after you import the file, change the assigned style by editing the surface properties:
1 In the Prospector tab, right-click the surface and click Properties.
2 Click the Information tab and select the desired Object Style from the drop-down list.
3 Click OK to apply the change and close the dialog box.

Deleting AutoCAD Objects from a Surface
When trying to remove AutoCAD drawing objects using the Erase command, the surface does not reflect
the change.
To delete drawing objects from a surface definition
1 In the Prospector tab, right-click the surface to be modified. Click Properties.
2 In the Definition tab, under Operation Type, clear the Drawing Objects check box, or you can right-click
Drawing Objects and click Remove From Definition.
3 When prompted to rebuild the surface, click Yes.
The drawing objects are removed from the surface definition, and the surface is automatically updated.

Surface Analysis Values are Not Updated
After modifying surface data, the values in the ranges of the Analysis tab of the Surface Properties dialog
box are not updated. Surface legend tables are not updated either.
Using the Analysis tab of the Surface Properties dialog box, you can create ranges for slopes, elevations,
directions, watersheds, and contours. These ranges require manual recalculation before the surface display
or the legend table can be updated. If the surface data changes, open the Surface Properties dialog box and
click the Analysis button in the Ranges area of the Analysis tab to reprocess the data. Surface legend tables
that are set up to be dynamic are then automatically updated with the changes.
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Surface Editing Operations
Edit surfaces using data edit operations, which are added to a surface definition as edit operations and not
to any of the existing surface data components.
You can access the data editing functionality for a surface by right-clicking
Edits under a surface Definition
in the Prospector tree. If a surface type does not support an edit operation, the operation is not listed. The
following table lists the edits that are supported for each surface type:
Edit Operation

TIN Surface

TIN Volume
Surface

Grid Surface

Grid Volume
Surface

Add points

Yes

Yes

Delete points

Yes

Editing operations are not
supported

Editing operations are not
supported

Modify points

Yes

Yes

Move point

Yes

No

Add line

Yes

No

Delete line

Yes

Yes

Swap edge

Yes

No

Minimize flat
areas

Yes

No

Smooth surface

Yes

No

Paste surface

Yes

No

Raise/Lower surface

Yes

Yes

Simplify surface

Yes

No

Yes

Adding TIN Lines
Use the Prospector tree to add new TIN lines to an existing surface. This operation modifies the way that
the surface is triangulated.
The endpoints of a new line must fall at the endpoints of other surface lines. If the new line passes through
one or more existing surface lines, the surface retriangulates that area.
TIP To perform this operation, ensure that the surface style has triangles visibility enabled. See Surface Styles and
Visualization (page 748).
NOTE TIN volume surfaces do not support editing operations.
To add TIN lines
1 In Toolspace, on the Prospector tab, expand the surface Definition collection, right-click
Add Line.

, and click
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2 At the command line, you are prompted to select the endpoints for the new TIN line.
3 Click existing vertices as the endpoints for the new TIN lines.
The triangulation of the surface is modified to reflect the new lines.
4 Optionally, continue to select endpoints to add additional new lines.
5 Press Enter to complete the operation.
The new TIN lines are added as Add Line operations to the Edits list view in Prospector.
NOTE The Description column in the list view displays the coordinates of the selected points that created
the TIN line.

Quick Reference
Toolspace Shortcut Menu
Prospector tab: Surfaces ➤ <surface-name> ➤ Definition ➤ right-click Edits ➤ Add Line
Command Line
AddSurfaceLine

Deleting TIN or Grid Lines
Use the Prospector tree to delete TIN or grid lines from a surface.
NOTE TIN or grid volume surfaces do not support editing operations.
Use this command to remove:
■

Long and narrow TIN triangles on the perimeter of a surface.

■

TIN or grid lines within a pond or building foundation to create a void area to prevent contours from
being drawn through the void areas.

When you remove an edge, an interior border, following the adjacent lines, is created, or the exterior border
is modified to follow the new lines.
TIP To perform this operation, ensure that the surface style has triangles visibility enabled and that the OSNAP
Endpoint setting is disabled. See Surface Styles and Visualization (page 748).
To delete TIN or Grid lines
1 In Toolspace, on the Prospector tab, expand the surface Definition collection, right-click
Delete Line.

, and click

2 At the command line, you are prompted to select the edges (lines) to remove.
3 Click the edges that you want to remove and press Enter.
NOTE If you are deleting grid lines, select the grid lines, not the triangulation lines.
The edges are removed. An interior border, following the adjacent TIN or grid lines, is created, or the
exterior border is modified to follow the new TIN or grid lines.
The edits are added as Delete Line or Delete Multiple Lines operations to the Edits list view in Prospector.
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NOTE The Description column in the list view displays the coordinates of the vertices for the edge that was
deleted.

Quick Reference
Toolspace Shortcut Menu
Prospector tab: Surfaces ➤ <surface-name> ➤ Definition ➤ right-click Edits ➤ Delete Line
Command Line
DeleteSurfaceLine

Swapping Edges
Use edge swapping to change the direction of two triangle faces in the surface model so that, for example,
the triangle edges match ridges or swales.
NOTE TIN volume surfaces do not support editing operations.
To swap an edge, observe the following conditions:
■

You must click within 1 unit of an edge.

■

Two visible triangles are separated by the edge.

■

The edge is not a breakline edge or an edge created by an Add Line operation.

■

The quadrilateral formed by the two triangles (which are separated by the edge) is convex.

TIP To perform this operation, ensure that the surface style has triangles visibility enabled. See Surface Styles and
Visualization (page 748).
To swap an edge
1 In Toolspace, on the Prospector tab, expand the surface Definition collection, right-click
Swap Edge.

, and click

2 At the command line, you are prompted to select an edge (line) to swap.
3 Click the edge to swap it.
The edge is swapped if the criteria are met. For information, see Swapping Edges (page 701).
4 Optionally, continue to select edges to swap by clicking them.
5 Press Enter to complete the operation.
The edits are added as Swap Edge operations to the Edits list view in Prospector.
NOTE The Description column in the Prospector list view displays the coordinates of the point that you
picked in the drawing area to select the edge.
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Quick Reference
Toolspace Shortcut Menu
Prospector tab: Surfaces ➤ <surface-name> ➤ Definition ➤ right-click Edits ➤ Swap Edge
Command Line
EditSurfaceSwapEdge

Adding Points to Surfaces
Use the Prospector tree to add points directly to a surface model.
NOTE TIN or grid volume surfaces do not support editing operations.
Adding points in this manner constitutes a surface edit, and can be enabled and disabled in the surface
properties. This operation adds points to the surface definition rather than to the surface data components.
NOTE If you are adding a point to a grid surface, you can add points only outside the existing border or to a hole
with no points inside the surface area. This command uses the SNAP orientation (based on the spacing and
orientation of the surface being edited).
TIP To perform this operation, ensure that the surface style has triangles visibility enabled. See Surface Styles and
Visualization (page 748).
To add points
1 In Toolspace, on the Prospector tab, expand the surface Definition collection, right-click
Add Point.

, and click

2 At the command line, you are prompted to select a point.
3 Click on the location for the point.
You are prompted for the elevation of the point.
4 Specify the elevation at the command line.
5 Optionally, continue to select other points to add, by clicking their locations.
6 Press Enter to complete the operation.
The points are added as Add Point or Add Grid Point operations to the Edits list view in Prospector.
NOTE The Description column in the list view displays the coordinates and elevation for the points that were
added.

Quick Reference
Toolspace Shortcut Menu
Prospector tab: Surfaces ➤ <surface-name> ➤ Definition ➤ right-click Edits ➤ Add Point
Command Line
AddSurfacePoint
AddSurfaceGridPoint
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Deleting Surface Points
Use the Prospector tree to delete points from a surface and remove inaccurate or unnecessary data.
NOTE TIN or grid volume surfaces do not support editing operations.
The points are not deleted from any of the existing surface data components. The deleted point operations
are added only to the surface definition.
TIP To perform this operation, ensure that the surface style has triangles or points visibility enabled. See Surface
Styles and Visualization (page 748).
To delete points
1 In Toolspace, on the Prospector tab, expand the surface Definition collection, right-click
Delete Point.

, and click

2 At the command line, you are prompted to select points.
3 Click the points you want to delete from the surface.
4 Press Enter.
5 The selected points are deleted from the surface.
NOTE When you delete an interior point from a grid surface, an interior border, following the adjacent grid
lines, is created.
6 Optionally, continue to select other points to delete by clicking them.
7 Press Enter to complete the operation.
The deleted points are added as Delete Point, Delete Multiple Points, or Delete Grid Point operations
to the Edits list view in Prospector.
NOTE The Description column in the list view displays the coordinates and elevation for the points that were
deleted.

Quick Reference
Toolspace Shortcut Menu
Prospector tab: Surfaces ➤ <surface-name> ➤ Definition ➤ right-click Edits ➤ Delete Point
Command Line
DeleteSurfacePoint
DeleteSurfaceGridPoint

Modifying Surface Points
Use the Prospector tree to change the elevations of individual surface points.
NOTE TIN or grid volume surfaces do not support editing operations.
These points are not modified in any of the existing surface data components. The modify point operations
are added only to the surface definition.

Deleting Surface Points | 703

To perform this operation, ensure that the surface style has points visibility enabled.
See Surface Styles and Visualization (page 748).
To modify the elevation of single surface points
1 In Toolspace, on the Prospector tab, expand the surface Definition collection, right-click
Modify Point.

, and click

2 At the command line, you are prompted to select the points to edit.
3 In the drawing area, select the points.
4 Press Enter.
5 You are prompted to specify the new elevation for the points.
6 Specify the elevation at the command line.
7 Optionally, continue to select other points to modify.
8 Press Enter to complete the operation.
9 The modified points are added as Modify Point or Modify Multiple Points operations in the Edits list
view in Prospector.
NOTE The Description column in the list view displays the coordinates and new elevation (Z) for the points
that were modified.

Quick Reference
Toolspace Shortcut Menu
Prospector tab: Surfaces ➤ <surface-name> ➤ Definition ➤ right-click Edits ➤ Modify Point
Command Line
EditSurfacePoint

Moving Surface Points
Use the Prospector tree to move an existing surface point to a new location. The surface triangulation is
updated accordingly.
NOTE TIN or grid volume surfaces do not support editing operations.
The points you move are not modified in any of the existing surface data components. The move point
operation is added to the surface definition. This operation does not require the surface points to be visible.
To move surface points
1 In Toolspace, on the Prospector tab, expand the surface Definition collection, right-click
Move Point.
2 At the command line, you are prompted to select the point you want to move.
3 In the drawing area, click the point.
You are prompted to select the new location for the point.
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, and click

4 Click the new location in the drawing.
5 Optionally, repeat steps 2 and 3 or press Enter to end the command.
The moved points are added as Move Point operations to the Edits list view in Prospector.
NOTE The Description column in the list view displays the coordinates of the old (from) and new (to) location
of the point.

Quick Reference
Toolspace Shortcut Menu
Prospector tab: Surfaces ➤ <surface-name> ➤ Definition ➤ right-click Edits ➤ Move Point
Command Line
MoveSurfacePoint

Minimizing Flat Areas in a Surface
When contour data is added to a TIN surface, the resulting surface can contain flat spots (triangles whose
points all come from the same contour) and flat edges (triangle edges that join points from the same contour
or from different contours at the same elevation).
NOTE TIN volume surfaces do not support editing operations.
The following illustration shows a surface with flat areas where the triangles (in cyan) of a surface are created
from red contour lines. Some of the flat triangles and flat edges are indicated:

These flat areas represent inaccuracies in the surface. When the contours of such a surface are displayed,
they might not match the original contour data around the flat areas. Also, displayed contours might contain
points with three contour segments emanating from them instead of the expected two segments. Use the
Minimize Flat Areas operation to find and eliminate triangles that have three points at the same elevation
and edges that connect points on different data contours at the same elevation.
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This command reduces the number of flat areas that result from the addition of contour data to a surface.
It helps create a better surface model that realistically reflects a real-world surface.
The Minimize Flat Areas operation finds flat areas defined by triangle edges that are created from either a
breakline or a contour. If a surface created from point data contains a flat area defined by three points with
the same elevation, the operation does not affect the surface.
You can specify the Minimize Flat Areas By options when using the Minimize Flat Areas operation or during
the Add Contour Data operation.
With one exception, the following Minimize Flat Areas options work only for TIN surfaces generated from
contour data. In some cases, the Swapping Edges option can change the appearance of the contours displayed
on a surface that is not generated from contour data.
TIP You can view flat triangles graphically by using slope shading. If you shade the surface using one range with
a slope of 0.00 percent, you will see the flat areas along the contour data.

Filling Gaps
This option fills the small gaps that sometimes occur in displayed contours and creates one continuous
contour. If the two ends of the gap are close enough to be connected by a single triangle edge, the gap is
filled by making that edge and the two data contours it joins into a single data contour. No additional points
or edges are added.
If you want to control which gaps are filled, you can add contour data without selecting this option, and
then use the Check for Contour Problems operation, which reports both ends of the gap. If, after reviewing
the results of the operation, you identify gaps that you do not want filled, add a surface point between the
two gap endpoints with an elevation above or below the contour. Then use the Minimize Flat Areas operation
with the Filling Gaps In Contour Data option selected to fill the remaining gaps.
NOTE Gaps are filled in displayed contours only. The original surface contour data is not changed.

Swapping Edges
This option scans the surface looking for a flat triangle that shares a non-contour edge with a non-flat
triangle. If the two triangles form a convex quadrilateral, the common edge is swapped, creating two non-flat
triangles. This may result in other flat triangles sharing non-contour edges with non-flat triangles, and these
edges are swapped if possible. The process continues until no more swapping is possible.
This command reverses the direction of a TIN line between four adjacent surface points. To perform this
operation, ensure that the surface style has points visibility enabled.
See Editing a Surface Style (page 750).
After the command is performed, the surface size remains unchanged and the surface contains the same
number of points and triangles.
IMPORTANT The command does not remove all flat triangles and flat edges. Some of the new triangles may
have extremely steep slopes.
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Adding Points to Flat Triangle Edges
Like the previous option, this option scans the surface looking for a flat triangle that has all its points on
data contours and shares a non-contour edge with a non-flat neighbor. However, instead of swapping the
common edge of the triangle pair, a new point is added at the midpoint of the common edge. The elevation
of the point is computed using Natural Neighbor Interpolation.
In many cases, this triangle falls at the edge of a chain of triangles that cross the flat area. Once you add the
new point, the chain of flat triangles is traversed, with new points being added to flat triangle edges until
the end of the chain is reached. The elevations of the points added along the chain are linearly interpolated
between the elevations of the starting point and the ending point of the chain.
This option results in the removal of more flat triangles than the Swapping Edges option. Any triangle that
would be removed by the Swapping Edges option is also removed by this option. This option also generally
results in fewer steep triangles. However, additional points and triangles are added to the surface:
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In this illustration, 27 points are added to the surface. Most flat triangles are removed, except for some along
the top and upper left borders.

Adding Points to Flat Edges
This option addresses flat edges, which are edges that bridge two same-elevation data contours but are not
in flat triangles. The surface is scanned for any flat edges with both endpoints on data contours. If the
opposing points of the two triangles containing such an edge are both at a higher elevation than the edge,
or both at a lower elevation than the edge, then a new point is added at the midpoint of the flat edge. The
elevation of the new point is computed using Natural Neighbor Interpolation. Because new points and edges
are added, this option increases the size of the surface.
The following illustration shows the same surface after applying both the Adding Points To Flat Triangle
Edges and the Adding Points To Flat Edges options. A total of 28 points are added in this example.

One benefit of the Swapping Edges option is that it does not increase the size of the surface. The Adding
Points To Flat Triangle Edges and Adding Points To Flat Edges options generally produce better results, but
they increase the size of the surface.
TIP You can differentiate between the display of points that are created from the contour data and the points
that are added by the Minimize Flat Areas operation by changing the surface style. On the Points tab in the surface
style, make the Data Point Symbol and Color different from the Derived Point Symbol and Color.
Before using the Minimize Flat Areas operation on a surface, you might find it helpful to evaluate flat areas
so you can control the results of the operation, as shown in the following examples.
The following illustration shows a surface generated for a ridge where an open contour ends near the border
of the surface but not on the border. The contours were added to the surface model with no Minimize Flat
Areas. By options specified:
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If you run the Minimize Flat Areas operation with the Adding Points to Flat Triangle Edges option, the
following results are obtained:

These results occur because the NNI interpolation uses surrounding points to determine an appropriate
elevation for a new point. Because all surrounding elevations are lower than the flat triangle, elevations
lower than the flat triangle are selected for the added points, resulting in the dip in the ridge.
In this instance, you can supplement the contour data by adding a spot elevation point near the open end
of the contour, as shown in the following illustration. Then, the Minimize Flat Areas operation generates a
crown as desired.
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NOTE For best results, follow the suggested guidelines for the order of operations for creating contours and
adding data to a surface. For more information, see Recommendations for Creating Surfaces from Contours (page
678).
To minimize flat areas
1 In Toolspace, on the Prospector tab, expand the surface Definition collection, right-click
Minimize Flat Areas.

, and click

2 In the Minimize Flat Areas (page 2639) dialog box, select check boxes to specify Minimize Flat Areas By
options.
The selected options are performed in the order in which they appear in the dialog box.
3 Click OK.
The operation is added as a Minimize Flat Areas operation to the Edits list view in the Prospector tree,
with the selected options listed in the Description column of the list view.

Quick Reference
Toolspace Shortcut Menu
Prospector tab: Surfaces ➤ <surface-name> ➤ Definition ➤ right-click Edits ➤ Minimize Flat Areas
Command Line
MinimizeSurfaceFlatAreas

Changing the Elevation of a Surface
Change the surface elevations by adding or subtracting an amount from the existing elevation of all the
surface points, which raises or lowers the surface.
NOTE TIN or grid volume surfaces do not support editing operations.
A positive value increases the elevation; a negative value lowers the elevation.
To raise or lower the surface
1 In Toolspace, on the Prospector tab, expand the surface Definition collection, right-click
Raise/Lower Surface.

, and click

The following prompt is displayed:
Amount to add to all elevations:

2 Enter a positive value to raise the surface or a negative value to lower the surface.
The surface is adjusted to the new elevation.
The operation is added as a Raise/Lower operation to the Edits list view in the Prospector tree.
NOTE The Description column in the Prospector list view displays the value by which the surface was raised
or lowered.
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Quick Reference
Toolspace Shortcut Menu
Prospector tab: Surfaces ➤ <surface-name> ➤ Definition ➤ right-click Edits ➤ Raise/Lower Surface
Command Line
RaiseLowerSurface

Pasting Surfaces
Use the Prospector tab to paste a surface into the current surface.
NOTE TIN or grid volume surfaces do not support editing operations.
For example, if you have a building pad surface, you can paste it into a full-site surface. The building pad
replaces that portion of the site surface that it covers.
To paste a surface into the current surface
1 In Toolspace, on the Prospector tab, expand the surface Definition collection, right-click
Paste Surface.

, and click

2 In the Select Surface To Paste (page 2027) dialog box, in the list of surfaces, select the surface that you
want to paste into the current surface, and click OK.
When the surface is pasted into the existing surface, the command adjusts the overlapping area to the
elevation and contouring of the pasted surface.
The operation is added as a Paste Surface item to the Edits list view in Prospector.
NOTE The Description column in the Prospector list view displays the name of the surface that was pasted.

Quick Reference
Toolspace Shortcut Menu
Prospector tab: Surfaces ➤ <surface-name> ➤ Definition ➤ right-click Edits ➤ Paste Surface
Command Line
EditSurfacePaste
Dialog Box
Select Surface To Paste (page 2027)

Smoothing Surfaces
Surface smoothing adds points at system-determined elevations using Natural Neighbor Interpolation (NNI)
or Kriging methods, which results in smoothed contours with no overlapping.
Only TIN surfaces support surface smoothing.
NOTE TIN volume surfaces do not support editing operations.
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Surface smoothing resolves a problem associated with individual contour smoothing where the smoothing
is applied to individual contour lines without regard to adjacent contours, which sometimes creates
overlapping contours. Surface smoothing results in smoothed contours with no overlaps:

There are other benefits to surface smoothing. The Kriging method enables you to extrapolate, beyond the
extents of a surface, based on the statistical trends across the existing surface. For example, if a site contains
a random sample of borehole elevations (a sparse set of data points), you can statistically extrapolate a
representation of a surface.
Because smoothing is an edit operation performed on a surface, you can specify smoothing properties and
turn them on or off. When you turn the smoothing off, the surface reverts back to its original state, but the
smoothing properties are preserved in the surface operation list. For more information about the operation
list, see Understanding the Surface Definition (page 660).
NOTE Surface smoothing can take a considerable amount of time proportional to the number of output points.
For the Kriging method, it is recommended that you use a relatively small sample point set (no more than 100 to
200 points).

Understanding Point Interpolation/Extrapolation Output
Choose between several options when you use either of the NNI or Kriging surface smoothing methods for
the interpolation and extrapolation of the point output.
NOTE For more information about the parameters, see the Smooth Surface (page 2642) dialog box help.

Grid Based Location
Use the Grid Based output location to interpolate surface points (NNI), or interpolate/extrapolate surface
points (Kriging) on a grid defined within specified polygon areas selected in the drawing. After the areas are
defined, the grid X and Y spacing, and orientation properties can be specified.

Centroids Location
Use the Centroids output location to interpolate surface points (NNI and Kriging) at the existing surface
triangle centroids within specified polygon areas selected in the drawing.
When this option is selected, the grid X and Y spacing and the orientation properties are disabled.

Random Points Location
Use the Random Points output location to interpolate (NNI), or interpolate/extrapolate (Kriging) a specified
number of random points within polygon areas selected in the drawing.
When this option is selected, the grid X and Y spacing and the orientation properties are disabled.
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Smoothing a Surface Using the Natural Neighbor Interpolation (NNI) Method
Use Natural Neighbor Interpolation (NNI) to estimate the elevation (Z) of an arbitrary point (p) from a set
of points with known elevations.
The NNI method uses information in the triangulation from the known points to compute a weighted
average of the elevations of the natural neighbors of point p. The number of neighbors (the number of
points whose Z-values are averaged to get the interpolated value) depends on the triangulation: it is the
number of points to which a new point (p) would be connected if inserted into the surface:

Using NNI, you select only the output locations of the interpolated points. The elevations of the interpolated
points are always based on the weighted average of the elevations of the existing neighboring points. The
outcome of the NNI method is more predictable than the Kriging method. NNI interpolates only within the
surface, whereas Kriging can extrapolate beyond the surface border based on a selected polygon.
To smooth a surface using Natural Neighbor Interpolation
1 In Toolspace, on the Prospector tab, expand the surface Definition collection, right-click
Smooth Surface.

, and click

2 In the Smooth Surface (page 2642) dialog box, for the Select Method property, select Natural Neighbor
Interpolation.
3 In Point Interpolation/Extrapolation Output, select the one of the Output locations: Grid Based,
Centroids, or Random Points.
4 Depending on the location you selected, specify values:
■

Grid Based: Specify values for the output regions, grid spacing, and grid orientation properties.

■

Centroids: Specify the value for the output region.

■

Random Points: Specify the value for the output region.

5 Click OK to smooth the surface.
The operation is added as a Smooth Surface item to the Edits list view in Prospector.
NOTE The Description column in the list view displays the type of surface smoothing that was used (Kriging
Smoothing or Natural Neighbor Smoothing).
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Quick Reference
Toolspace Shortcut Menu
Prospector tab: Surfaces ➤ <surface-name> ➤ Definition ➤ right-click Edits ➤ Smooth Surface
Command Line
SmoothSurface
Dialog Box
Smooth Surface (page 2642)

Smoothing a Surface Using Kriging Method
Kriging is more complex than Natural Neighbor Interpolation. It requires both a model of the spatial
continuity or dependence (in the form of a covariance or semivariogram), and a sample of surface data to
determine the statistical trend on which to base interpolated/extrapolated points.
Spatial prediction using Kriging involves two steps:
1 Model the covariance or semivariogram of the spatial process. This involves choosing both a
mathematical form and the values of the associated parameters.
2 Use this dependence model in solving the Kriging system at a specified set of spatial points, resulting
in predicted values and associated standard errors.

Sample Data
You must select the output locations of the interpolated points. It is important to ensure that the sample
data is appropriate for the interpolated point locations (the output). For example, do not select points on
the opposite side of the surface to determine a trend for the interpolated/extrapolated points locations, as
that trend may not be appropriate for the interpolated/extrapolated point locations.

Semivariogram Model
Semivariance is a measure of the degree of spatial dependence between samples. The magnitude of the
semivariance between points depends on the distance between the points. A smaller distance yields a smaller
semivariance and a larger distance results in a larger semivariance. The plot of the semivariances as a function
of distance from a point is referred to as a semivariogram.
Kriging provides five semivariogram models:
■

Exponential

■

Gaussian

■

Monomial

■

Linear (default)

■

Spherical

The semivariance increases as the distance increases until at a certain distance away from a point the
semivariance will equal the variance around the average value, and will therefore no longer increase, causing
a flat region to occur on the semivariogram called a sill. The distance from the point of interest to where
the flat region begins is termed the range or span of the regionalized variable. Within this range, locations
are related to each other, and all known samples contained in this region, also referred to as the neighborhood,
must be considered when estimating the unknown point of interest.
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The center of the neighborhood is usually the unknown value. To determine this value, all known values
within the neighborhood are assigned weights using the semivariogram. These weights and known values
are then used to calculate the unknown value.
TIP It is recommended that you understand Kriging methodology before using it to perform surface smoothing.
To smooth a surface using Kriging
1 In Toolspace, on the Prospector tab, expand the surface Definition collection, right-click
Smooth Surface.

, and click

2 In the Smooth Surface (page 2642) dialog box, for Select Method property, select Kriging.
The Kriging Method properties are available and the Kriging semivariogram model is displayed at the
bottom of the dialog box.
3 In Semivariogram Model, select the model.
4 Select a point selection method from the Point Selection Method list and following the prompts as
required.
5 Depending on the semivariogram model that you select, you can specify values for Parameter A,
Parameter C, and the Nugget Effect.
6 In Point Interpolation/Extrapolation Output, select the output locations: Grid Based, Centroids, or
Random Points.
7 Depending on the location you selected, specify values:
■

Grid Based: Specify values for the output regions, grid spacing, and grid orientation properties.

■

Centroids: Specify the value for the output region.

■

Random Points: Specify the value for the output region.

8 Click OK to smooth the surface.
The operation is added as a Smooth Surface item to the Edits list view in Prospector.
NOTE The Description column in the list view displays the type of surface smoothing that was used.

Quick Reference
Toolspace Shortcut Menu
Prospector tab: Surfaces ➤ <surface-name> ➤ Definition ➤ right-click Edits ➤ Smooth Surface
Command Line
SmoothSurface
Dialog Box
Smooth Surface (page 2642)

Simplifying Surfaces
When you simplify a surface, you reduce the number of points or triangles in a TIN surface, while preserving
the surface accuracy.
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You can remove the specified amount of points in the specified surface region. The command does not
remove points on breaklines and on the surface border.
To simplify a surface
1 Select a surface. On the Surface tab, Modify panel, click Edit Surface drop-down ➤ Simplify Surface
.
2 If more than one surface is available in the drawing, click the surface that you want to simplify or press
Enter to select a surface in the Select A Surface dialog box.
3 Follow the Simplify Surface wizard sequence and the command line prompts to specify:
■

A simplification method (page 2641).

■

The surface region (page 2641) that you want to simplify.

■

Point reduction options (page 2642).

4 Click Apply.
The total number of points to be removed is displayed.
5 Click Finish to remove the points.
The Simplify Surface operation appears in the surface definition in the Prospector tree.

Quick Reference
Ribbon
Select a surface. Surface tab ➤ Modify panel ➤ Edit Surface drop-down ➤ Simplify Surface

.

Menu
Surfaces menu ➤ Edit Surface ➤ Simplify Surface
Command Line
SimplifySurface
Dialog Box
Simplify Surface wizard (page 2641)

Cropping Surfaces
Use the Create Cropped Surface command to create a surface that is a copy of a polygonal area of a source
surface.
Each cropped area becomes a separate surface object (a new surface) that you can manage and manipulate.
When you create a surface by cropping the source surface, or when you rebuild the new surface, AutoCAD
Civil 3D creates a copy from the saved version of the source surface. If you modify the source surface and
want the changes to be reflected in the new surface, save the drawing containing the source surface before
you rebuild the new surface.
NOTE When a new surface is created, AutoCAD Civil 3D takes a snapshot of the new surface. To rebuild the new
surface, you must first perform the Rebuild Snapshot command and then the Rebuild command.
IMPORTANT Before you crop a surface, save the surface in the drawing.
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To crop a surface
1 Click Home tab ➤ Create Ground Data panel ➤ Surfaces drop-down ➤ Create Cropped Surface

.

2 In the Create Cropped Surface dialog box (page 2624), Crop Information section:
a Click

to select the source surface to crop.

b Click
to specify the crop area in the drawing using the selection window, by drawing a polygon,
or by selecting objects.
NOTE If you use the select objects option, click inside the polygon you want to use. The specified crop
area is highlighted.

3 Specify the new surface information:
a Specify a destination for the new surface. You can place it in a new drawing, in any existing drawing,
or in the currently active drawing.
b Enter the surface name and description.
4 Depending on the type of drawing that you selected in the previous step, specify the destination drawing
for the cropped surface.
5 Optionally, modify the surface style. By default, AutoCAD Civil 3D applies the standard style to the
created surface.
6 Click

to assign a layer for the cropped surface.

If you chose to create a new drawing file for the cropped surfaces, this drawing is saved in the directory
where the source drawing resides.

Quick Reference
Ribbon
Home tab ➤ Create Ground Data panel ➤ Surfaces drop-down ➤ Create Cropped Surface

.

Command Line
CreateCropSurface
Dialog Box
Create Cropped Surface (page 2624)

Removing Surface Data
You can use several methods for removing data from a drawing, surface definition, or from both.
NOTE When deleting AutoCAD objects, the surface definition is deleted along with the AutoCAD object if the
Copy Deleted Dependent Objects option in the surface definition is set to No. For more information, see Definition
Tab (Surface Properties Dialog Box) (page 2656).
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Excluding Data from the Surface Build
Hide or disable operations in the current surface build while preserving them in the surface definition list.
Excluding data is useful for comparing scenarios. For example, you can add additional points to a surface
from a point file, and later disable the Add Point File operation. The surface will revert back to the original
(pre-point file) triangulation.
To exclude data from the surface build
1 In Toolspace, on the Prospector tab, under the Surfaces collection, right-click the surface and click
Properties.
2 In the Surface Properties dialog box, click the Definition tab (page 2656).
3 In the Operations List, clear the operations that you want to exclude from the build and click OK.
You are prompted with a warning to confirm the changes that you made to the surface definition.
4 Click Yes to confirm the changes.
The surface is rebuilt with the unchecked operations excluded.

Deleting Data from the Surface
Remove a data operation permanently while retaining the AutoCAD drawing objects (for example, polylines
or points) on which the data operation may be based.
There are two methods to remove a data operation from a surface:
■

Delete it from the Prospector list view.

■

Remove it from the surface operations list in the Surface Properties dialog box.

To delete data from the surface definition using the Prospector list view
1 In Toolspace, on the Prospector tab, expand the surface Definition collection and click the collection
from which you want to delete data.
2 In the Prospector list view, right-click the list item and click Delete.
3 Click Yes to confirm the deletion of the selected breaklines.
The surface is rebuilt without the deleted operation.
To delete data from the surface operations list
1 In Toolspace, on the Prospector tab, right-click the surface and click Properties.
2 In the Surface Properties dialog box, click the Definition tab (page 2656).
3 In the Operations List, right-click the operations that you want to delete from the surface and click
Remove From Definition.
You are prompted with a warning to confirm the changes that you made to the surface definition.
4 Click Yes to confirm the changes
The surface is rebuilt with the deleted operations excluded.
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Deleting Data from the Surface and the Drawing
You can permanently remove both a surface definition item and the AutoCAD object from which it is
derived.
NOTE If you delete an AutoCAD object, the surface definition item is deleted only if the Copy Deleted Dependent
Objects option in the surface definition is set to No. For more information, see Definition Tab (Surface Properties
Dialog Box) (page 2656).
To graphically delete data from the surface and drawing
■

In the drawing area, select the object and press Delete.
Both the object and surface definition item are deleted.

Deleting AutoCAD Objects
You can permanently remove the AutoCAD objects that surface definition items are derived from without
deleting the surface definition item.
For all surface definition items that are derived from AutoCAD objects, ensure that the surface build parameter
Copy Deleted Dependent Objects is set to Yes. Then you can graphically select and delete the AutoCAD
object while preserving the surface definition.
Also, you can use the Prospector list view to delete the AutoCAD objects from which the boundaries and
breaklines are derived.
To delete AutoCAD objects from the drawing graphically
■

In the drawing area, select the object and press Delete.
The object is deleted.
NOTE If you want to delete an AutoCAD object, and not delete the surface definition item ensure that the
Copy Deleted Dependent Objects option in the surface definition is set to Yes. For more information, see
Editing and Viewing the Surface Definition (page 731).

Masks
Use masks to block out areas of a surface and prevent them from being displayed or to render a section of
the surface using a specified render material.
Masks can be defined from AutoCAD Civil 3D parcels and from the following types of polygon-type objects:
■

Polylines

■

Faces

■

3D Polylines

■

Survey Figures

■

Circles

■

Feature Lines

■

Ellipses

■

Parcel Segments

■

Rectangles

■

Surfaces

When you define a mask from a selected object, the mask geometry automatically updates when you make
changes to the original object. If the original object is deleted from the drawing, the mask is also deleted.
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The display of the mask is based on the display settings of the referenced surface style. The display type is
either trimmed to the segments of the mask or crosses the segments:
Display Type

Trim/Cross

Points

Trim

Triangles

Cross

Border

N/A*

Contours

Trim

Grid

Trim

Directions

Cross

Elevations

Cross

Slopes

Cross

Slope arrows

Cross

Watersheds

Cross

* Border display is not affected by masks.
The following illustration is an example of crossing display (triangles):

The following illustration is an example of trimmed display (contours):
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Types of Masks
Define one of the two types of surface masks: outside or inside.
NOTE If you define an inside mask, you cannot use an outside mask on the same surface.

Outside Masks
When you define a mask as an outside type, the portion of the surface outside the defined polygon is hidden
(the outside display is clipped to the mask segments):

Inside Masks
When you define a mask as an inside type, the portion of the surface residing inside the defined polygon is
hidden:

Types of Masks | 721

NOTE Only one inside mask can be defined on a surface.

Mask Render Only Property
When you define an inside or outside mask as render only, the specified render material is applied to the
inside or the outside of the mask polygon. The display of the surface is not masked, but when the surface
is rendered, the render material pattern is displayed. The following illustration shows the render material
applied to an inside mask:

Creating a Mask
Create masks by selecting existing parcels or AutoCAD polygon-type objects.
To create a mask
1 In Toolspace, on the Prospector tab, expand the surface collection, right-click
Mask.
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Masks, and click Create

2 From the drawing, select an object or multiple objects to define the mask. Press Enter.
3 In the Create Mask (page 2621) dialog box, in the properties grid, click the Value column for the Name
property and enter a name for the mask.
4 Click the Value column for the Description property and enter a description for the mask.
5 For Mask Type property, select Inside or Outside.
NOTE If you define an inside mask on a surface, you cannot create another inside or outside mask on the
same surface.
6 Depending on whether or not you want to set a selected object as a render-only mask, select Yes or No
for Render Only option.
NOTE If multiple objects are selected for the mask, the Render Only option is set to true and is unavailable.
7 Optionally, if the polygon object from which you are creating a mask has curves, enter a value in the
Mid-Ordinate Distance field or click

to digitize a distance in the drawing area.

8 Specify the render material by clicking in the Render Material row and clicking

.

The Render Material dialog box is displayed. For more information, see Applying Render Materials to
Objects (page 1763).
9 Click OK.
The mask is created and added to the surface Masks collection in the Prospector tree.
NOTE A render-only mask must be rendered before it is displayed. See Rendering Objects (page 1764)

Quick Reference
Toolspace Shortcut Menu
Prospector tab: Surfaces ➤ <surface-name> ➤ right-click Masks ➤ Create Mask
Command Line
CreateSurfaceMask
Dialog Box
Create Mask (page 2621)

Viewing Masks
Select and view masks in the Prospector tab item view.
In the Prospector item view, you can manipulate the view of the mask, including zooming, panning, rotating,
and orbiting. You can also save the view to an image file.
A render-only mask must be rendered before you can view it. For information, see Rendering Objects (page
1764).
To view a mask in the Prospector item view
1 In Toolspace, on the Prospector tab, expand the surface

Masks collection and click the mask’s name.
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The mask is displayed in the Prospector item view.
2 Right-click anywhere in the item view and select the option you want, such as Zoom To or Pan To.

Changing the Display Order of Render Only Masks
Use the Mask Display Order dialog box to change the display order of a selected render-only mask.
A mask with a higher display priority is drawn last and on top of any overlapping masks.
To change the display order of a render-only mask
1 In Toolspace, on the Prospector tab, right-click the surface

Masks collection and click Display Order.

The Mask Display Order (page 2638) dialog box is displayed.
2 From the list, click a mask and click
down.

to move the mask up in the list or click

to move the mask

The mask at the top of the list has the highest display priority and is drawn on top of any overlapping
masks.
3 Click OK to apply the changes and close the Mask Display Order dialog box.

Quick Reference
Toolspace Shortcut Menu
Prospector tab: Surfaces ➤ <surface-name> ➤ right-click Masks ➤ Display Order
Dialog Box
Mask Display Order (page 2638)

Modifying a Mask
Use the Mask Properties dialog box to edit a mask’s properties. You can also modify the extents, location,
and positioning of a mask using the appropriate AutoCAD command (depending on the type of the originating
object).
To view and modify a mask’s properties
1 In Toolspace, on the Prospector tab, click the surface

Masks collection.

The names and descriptions for the masks are displayed in the Prospector list view.
2 Right-click the mask in the Prospector tree or list view and click Mask Properties.
The Mask Properties (page 2621) dialog box is displayed. Edit the name, description, boundary type, render
material, and mid-ordinate distance.
3 Click OK to apply the changes and close the Mask Properties dialog box.
NOTE You can move masks based on AutoCAD objects. You cannot move parcel-based masks.
To move a mask using the Move command
1 At the command line, enter move.
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2 Select the mask you want to move.
3 Follow the command line prompts.
To modify (rotate, scale, or stretch) a mask
■

Use the AutoCAD grip editing capabilities of the original objects (for example, polylines, circles, and
parcels) to modify masks.

The mask reacts to changes made to the original object.

Deleting a Mask
Use the Prospector tab to remove a mask from a surface by deleting the mask or by deleting the AutoCAD
object that it was created from.
To delete a mask
1 In Toolspace, on the Prospector tab, click the surface Masks collection.
2 In the list of masks, right-click the mask and click Delete.
The mask is deleted from the surface, but the AutoCAD object (for example, a rectangle) is left in the
drawing.
3 To delete the AutoCAD object, select it in the drawing area and press Delete.

Quick Reference
Toolspace Shortcut Menu
Prospector tab: Surfaces ➤ <surface-name> ➤ Masks ➤ right-click <mask-name> in list view ➤ Delete

Watersheds
Use watersheds to analyze how water flows along and off of a surface.
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Surface TIN lines are used to calculate the areas that water would flow along the surface. From these areas,
the drain targets and watersheds are determined.
Different drain targets are calculated for watersheds. For example, some watersheds include a boundary point
as a drain target, which is the point where the channel of water would drain off the surface. Other watersheds
have depression areas that the water flows into, while some watersheds are defined as boundary segments
where the drain target includes the boundary of a surface. For more information, see Types of Watersheds
(page 726).
If AutoCAD Civil 3D determines that water from one surface triangle could flow into more than one watershed,
then it splits the TIN triangle to make two triangles. This ensures that each watershed consists of complete
triangles, and that the boundary of each watershed consists solely of TIN edges.

Types of Watersheds
Watershed types are based on the type of drain target the watershed has.
A drain target is the location where the water flow either stops or leaves the surface. Water that flows along
an area or across a surface triangle eventually flows off the surface, or it reaches a point from which there
is no downhill direction.
For each drain target in a surface, AutoCAD Civil 3D determines the region of the surface that drains to that
target. This region is called the watershed for that drain target.
Each watershed that you delineate is categorized as one of the following types, based on drain target.

Boundary Point
If the downhill end of a channel edge is on the surface boundary, then water flowing through that channel
continues off the surface. The boundary point is the lowest end of the channel.
If a watershed has this type of drain target, it is called a boundary point watershed.
In the following illustration, point p5 is a boundary point, the drain target of the channel p7-p6-p5:

NOTE The "t" in the illustration indicates that the triangle was split between two watersheds because the water
flowing across that triangle could go to either of two watersheds.
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Boundary Segment
If an edge on the surface boundary belongs to a triangle that slopes down toward that edge, then water flows
off the surface all along that edge. A boundary segment is a connected sequence of such edges.
If a watershed has this type of drain target, it is called a boundary segment watershed.
In the following illustration, the edges p1-p2, p2-p3, and p3-p4 form a boundary segment.

NOTE The "t" in the illustration indicates that the triangle was split between two watersheds because the water
flowing across that triangle could go to either of two watersheds.

Depression
If a point is at a lower elevation than all its neighboring TIN points, then when water flows to it, it has no
downhill place to go. Similarly, a connected set of points that are at the same elevation and all of whose
neighbors are at a higher elevation, is a single drain target. A depression is any such set of points.
If a watershed has this type of drain target, it is called a depression watershed.
In the following illustration, points p8 and p9 form a depression:

NOTE The "t" in the illustration indicates that the triangle was split between two watersheds because the water
flowing across that triangle could go to either of two watersheds.
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Ambiguous Depression
A depression watershed can be ambiguous. A watershed is ambiguous if it does not include any drain targets,
but water flowing on it can reach more than one drain target.
An ambiguous depression occurs when the depression watershed depth is less than the threshold depth, but
there are multiple neighboring watersheds at points of minimum elevation on the boundary.
When such a watershed fills to overflowing, water flows to all those neighboring watersheds, so it cannot
be merged into any single watershed. Instead, AutoCAD Civil 3D keeps it as a separate watershed and lists
the neighboring watersheds into which it will drain.

Shallow Depression
If a point is at a lower elevation than all its neighboring TIN points, then water that flows to it has no
downhill place to go. Similarly, a connected set of points that are at the same elevation, and all of whose
neighbors are at higher elevation, is a single drain target. A depression is any such set of points.
A shallow depression is determined by the average depth of a depression, which is the average depth of the
depression when it is filled to overflowing. This is determined by dividing the value of water in the depression
by the area of the top surface of the water. A depression is considered part of the watershed it drains into
(provided there is only one watershed it drains into) if its average depth is less than the user-set threshold.

Flat Area
A flat area watershed is a flat area, from which water could flow down to more than one drain target. It also
includes the parts of the surface that drain to that flat area. A flat area is a connected set of triangles all of
whose vertices have the same elevation. Flat areas abut parts of the surface that slopes downhill.
If for every edge on the boundary of a flat area, the opposing, non-flat triangle slopes up from the edge,
then the flat area is the bottom of a depression watershed:

If some of the opposing, non-flat triangles slope down from the flat area boundary, but all flow to the same
drain target, then the flat area is part of the watershed for that drain target “a”, as shown in the following
illustration:
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In the following illustration, the flat area, plus whatever part of the surface flows down to it, becomes a flat
area watershed. This watershed is ambiguous because water flowing through it can flow to more than one
drain target, “a” and “b”:

Multi-Drain
One type of ambiguous watershed is called a multi-drain or split channel watershed.
In the following illustration, the channel edges e2 and e3 flow to different drain targets.
Water flowing down edge e1 could eventually reach either of these drain targets. In a case like this, AutoCAD
Civil 3D determines the region that flows to edge e1 and defines this region to be a multi-drain watershed.
Also, in this situation, AutoCAD Civil 3D keeps track of the watersheds into which water from the multi-drain
watershed might drain, in this case “a” and “b”, as shown in the following illustration:
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Multi-Drain Notch
A multi-drain notch watershed occurs where there is a a flat edge between two points on a surface.
This type of watershed is called a multi-drain notch because water flowing into the notch formed from p1
and p2 and could drain to drain target “a” or drain target “b” as is shown in the following illustration:

Generating and Displaying Watersheds
Generating and displaying watersheds on a surface is a flexible process.
To generate and display watersheds
1 Configure the watershed display or style settings. For information, see Creating a Surface Style (page
749).
2 Configure the watershed analysis and legend. For information, see Analyzing Surfaces (page 764).
3 Display the watershed. Watershed display is set on the Surface Style Display (page 2655)and Surface
Properties Analysis (page 2653)tabs.
4 Insert the watershed legend table. For information, see Adding Surface Legend Tables (page 763).

Viewing Watershed Properties
After you have created a watershed analysis on a surface, the watersheds are added to the surface Watersheds
collection in the Prospector tree.
For information about creating a watershed analysis, see Analyzing Surfaces (page 764).
To view watershed properties
1 In Toolspace, on the Prospector tab, click the surface Watersheds collection.
The Prospector list view displays a tabular list of the surface watersheds with their IDs, description,
type, and the ID of the watershed that they drain into.
2 Optionally, to pan or zoom to an individual watershed, right-click the watershed item in the list view
and click Pan To or Zoom To.
NOTE The watershed display needs to be enabled before you can view it. For information on displaying
watersheds, see Surface Styles and Visualization (page 748).

Managing Surfaces
You can manage instances of surfaces in the Surfaces collection in the Prospector tab and surface settings
in the Surface collection in the Settings tab.
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You can copy, export to LandXML, delete, rebuild, rename, synchronize, take a snapshot of, and change
the style usage for a surface.
Every surface object has properties, which are defined and displayed in the Surface Properties dialog box
(page 2655).
Surface properties include:
■

General information, including the name, description, and style for the surface. For information, see
Information Tab (Surface Properties Dialog Box) (page 2656).

■

Definition attributes, including the build, data, and operation options, as well as a definition of items
that are in use in the surface. For information, see Understanding the Surface Definition (page 660).

■

Analysis information, which includes properties for all types of surface analysis, including contour,
direction, elevations, slopes, slope arrows, and watersheds. For information, see Analyzing Surfaces (page
764).

■

Statistics for the current state of the surface. For information, see Viewing Surface Statistics (page 739).

Editing and Viewing the Surface Definition
Edit and view a surface definition information, including build, data, and operation options. Additionally,
you can select or clear items that are included in the surface definition list.
For more information, see Understanding the Surface Definition (page 660).
To edit the surface build and definition information
1 In Toolspace, on the Prospector tab, expand the Surfaces collection, right-click the surface, and click
Properties.
2 In the Surface Properties dialog box, click the Definition tab (page 2656).
3 To edit the general build information, expand the Build group and edit the values.
4 To specify whether certain data categories (for example, breaklines) are to be excluded from or included
in the surface build, expand the Data Operations definition group and set the corresponding values to
Yes or No.
5 To specify whether certain edit operation categories (for example, deleting points) are to be excluded
from or included in the surface build, expand the Edit Operations group and set the corresponding
values to Yes or No.
6 To reorder any of the surface operations, click the arrow buttons to the left of the Operation Type field.
7 Click Apply to make the changes or click OK to make the changes and close the Surface Properties dialog
box.
A warning message, which enables you to confirm or cancel your changes, is displayed.

Quick Reference
Toolspace Shortcut Menu
Prospector tab: Surfaces ➤ right-click <surface-name> ➤ Properties
Object Shortcut Menu
Surface Properties
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Command Line
EditSurfaceProperties
Dialog Box
Surface Properties - Definition Tab (page 2656)

Using Surface Snapshots
A snapshot is a surface operation that captures the current state of surface.
When a surface snapshot exists and the surface is rebuilt, the build process starts at the snapshot and proceeds
sequentially through subsequent surface operations. Therefore, if a surface operation, such as an import of
an external data file, exists prior to the snapshot operation, the surface build process does not attempt to
find and open the external data file since all of the external file point data is contained in the surface snapshot
operation.

Creating a Snapshot
Use the Prospector tab to create a surface snapshot.
The current surface points and triangles resultant from previous surface operations are contained in the
surface snapshot operation. When a surface is built, previous surface operations are ignored and the surface
build begins at the snapshot operation.
Snapshots can be created automatically. A LandXML setting enables you to specify that a surface snapshot
be created in the surface definition subsequent to the importing of a surface when using Import LandXML.
For more information, see Viewing and Editing the LandXML Import Settings (page 1880).
To create a snapshot
■

In Toolspace, on the Prospector tab, expand the Surfaces collection, right-click the surface, and click
Create Snapshot.

NOTE If there is an existing snapshot operation, a warning dialog box is displayed from which you can confirm
or cancel the operation.
Surface operations that are included in the snapshot are marked with

in the Prospector tree.

Quick Reference
Toolspace Shortcut Menu
Prospector tab: right-click <surface-name> ➤ Create Snapshot

Rebuilding a Snapshot
You can rebuild a snapshot if any of the operations that precede it in the surface operation list change or
are removed.
If the snapshot operation is out-of-date,
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is displayed next to its node in the Prospector tree.

To rebuild a snapshot
■

In Toolspace, on the Prospector tab, expand the Surfaces collection, right-click the surface, and click
Rebuild Snapshot.

Quick Reference
Toolspace Shortcut Menu
Prospector tab: right-click <surface-name> ➤ Rebuild Snapshot

Deleting a Snapshot
You can remove an existing snapshot.
To delete a snapshot
■

In Toolspace, on the Prospector tab, expand the Surfaces collection, right-click the surface, and click
Remove Snapshot.

■

A warning dialog box is displayed in which you can confirm or cancel the operation.

Quick Reference
Toolspace Shortcut Menu
Prospector tab: right-click <surface-name> ➤ Remove Snapshot

Snapshots and the Surface State
The out-of-date icon can be displayed at several places in the Prospector tree or surface definition depending
on the status of the snapshot and the surface.
■

Out-of-date snapshot. When an active snapshot is out of date,
is displayed next to the snapshot
operation in the Definition tab of the Surface Properties dialog box.

■

Out-of-date surface. If the surface is out of date when you attempt to create a snapshot, a warning dialog
box is displayed, indicating that the snapshot will be created based on the current (out-of-date) state of
the surface.

■

Out-of-date data. If the surface data is out of date (Rebuild - Automatic is disabled) and is contained in
an active snapshot, the data item is shown as out of date
not shown as out of date.

in the Prospector tree, but the surface is

Changing a Surface Name, Description, or Style
Change an existing surface name, description, and style usage.
To rename a surface
1 In Toolspace, on the Prospector tab, expand the Surfaces collection, right-click the surface, and click
Properties.
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2 In the Surface Properties dialog box, click the Information tab (page 2656).
3 To edit the name of the surface, enter a new name in the Name field.
4 To edit the description of the surface, enter a new description in the Description field.
5 To change the style for the surface, select a style from the Object Style list or use the standard style
selection controls.
6 Click Apply to make the changes, or click OK to make the changes and close the Surface Properties
dialog box.

Quick Reference
Toolspace Shortcut Menu
Prospector tab: Surfaces ➤ right-click <surface-name> ➤ Properties or Prospector tab: Surfaces ➤ click
surface <property-name> in list view
Object Shortcut Menu
Surface Properties
Command Line
EditSurfaceProperties
Dialog Box
Surface Properties - Information Tab (page 2656)

Copying a Surface
Create a copy of an existing surface.
When a surface is copied, the copy is named using a naming convention. For example if the original surface
that is copied is named ‘Surface 1’, the new surface is named ‘Surface 1 (1)’. If Surface 1 is copied again, the
new surface is named ‘Surface1 (2)’. If ‘Surface 1(1)’ is copied, the new surface is named ‘Surface 1 (1) (2)’.
To copy a surface
1 In the drawing area, select the surface, right-click, click Basic Modify Tools ➤ Copy.
2 At the command line, you are prompted to specify a base point for the surface.
3 Pick an insertion point in the drawing area.
The surface is copied in the drawing and added as a new surface to the Prospector tree.
4 To edit the name of the surface, right-click the surface in the Prospector tree and click Properties.
The Surface Properties dialog box is displayed with the Information tab (page 2656) active. The Name
field contains the name of the copied surface, which is, by default “ <surface-name> (1).”
5 Enter a new name in the Name field.
6 To edit the description of the surface, enter a new description in the Description field.
7 To change the style that the surface is using, select a style from the Object Style list or use the standard
style selection controls.
8 Click Apply to make the changes, or click OK to make the changes and close the Surface Properties
dialog box.
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Quick Reference
Object Shortcut Menu
Surface Properties
Dialog Box
Surface Properties - Information Tab (page 2656)

Previewing a Surface
You can preview a surface in the Prospector item list view.
To preview a surface
1 Ensure that the Item Preview button
Graphical View (page 100).

on the Prospector tab is selected. For more information, see

2 In Toolspace, on the Prospector tab, right-click the Surfaces collection and click Show Preview.
NOTE A check mark is displayed next to the Show Preview menu item when the preview is enabled.
3 In the Prospector tree, click the surface that you want to preview.
The surface is displayed in the Prospector item view.
NOTE The preview of the surface uses the same display styles as the surface in the drawing area.

Quick Reference
Toolspace Shortcut Menu
Prospector tab: right-click Surfaces ➤ Show Preview

Rebuilding a Surface
When you make changes to a surface, such as editing data or the build parameters, the surface may become
out of date and you can rebuild it.
If the surface definition is out of date,

is displayed next to its node in the Prospector tree.

AutoCAD Civil 3D enables you to either automatically or manually rebuild a surface.
To automatically rebuild a surface
■

In Toolspace, on the Prospector tab, expand the Surfaces collection, right-click the surface and click
Rebuild - Automatic.
NOTE A check mark is displayed next to the Rebuild - Automatic menu item when it is enabled.
When changes are made to the surface, it is automatically rebuilt and updated.
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To manually rebuild a surface
■

In Toolspace, on the Prospector tab, expand the Surfaces collection, right-click the surface, and click
Rebuild.
NOTE If the surface definition is out-of-date,

is displayed next to its node in the Prospector tree.

The surface is rebuilt and updated in the drawing.

Quick Reference
Toolspace Shortcut Menu
Prospector tab: Surfaces ➤ right-click <surface-name> ➤ Rebuild

Deleting a Surface
Delete a surface, which erases it from the drawing and removes it from the Surfaces collection in the Prospector
tree.
To delete a surface
■

In Toolspace, on the Prospector tab, expand the Surfaces collection, right-click the surface, and click
Delete.
The surface is erased from the drawing and removed from the Surfaces collection in the Prospector tree.

NOTE You cannot delete a surface from the Prospector tree if it has associated dependencies (such as other
objects). You can determine if the surface has dependencies by the orange triangle attached to the surface icon.
The Delete command for such surface is missing from the shortcut menu.

Quick Reference
Toolspace Shortcut Menu
Prospector tab: Surfaces ➤ right-click <surface-name> ➤ Delete

Locking a Surface
Lock a surface so that its properties and geometry cannot be changed. Certain tabs in the Surface Properties
dialog box and some menu items cannot be selected.
See also:
■

Using Vault (page 158)

To lock a surface
■

In Toolspace, on the Prospector tab, expand the Surfaces collection, right-click the surface, and click
Lock.
In the Prospector tree,

is displayed next to the surface.

The surface is locked and its geometry cannot be edited.
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Quick Reference
Toolspace Shortcut Menu
Prospector tab: Surfaces ➤ right-click <surface-name> ➤ Lock

Moving, Scaling, or Rotating a Surface
Use standard AutoCAD commands to move, scale, and rotate a surface.
For more information about each AutoCAD command, refer to the Help.
NOTE The AutoCAD Mirror command is not supported on surfaces.
To move, scale, or rotate a surface
1 At the command line, enter the command, for example Move.
2 Follow the command-line prompts.
NOTE When moving, scaling, or rotating a surface, you should be aware that if you want to affect only the surface
and not the data, you should select only the surface. After moving, scaling, or rotating as surface, a ’Transform
By’ operation is added to the surface definition and is reapplied during subsequent rebuilding of the surface. If
the surface data in the drawing needs to be moved, scaled, or rotated, then the surface should not be selected
since the surface is rebuilt according to location of its dependent data.

Editing Surface Settings
Use surface settings to specify the default behavior for surface-related commands.
Settings are handled in a standard way throughout AutoCAD Civil 3D. You access settings using the Settings
tree. You can control settings at three levels: the drawing level, the object collection (feature) level, and the
command level. It is important that you understand how the different levels of settings work together. For
more information, see Specifying Drawing Settings (page 79).
You can use the Settings tree Surface collection shortcut menu to establish defaults for all surface-related
commands. You can change surface-specific settings at this level, or you can override the drawing ambient
settings.
Use the Commands collection under the Surface collection to change surface settings for a specific command.
You can change surface-specific settings at this level, or you can override the drawing ambient settings.
NOTE Overrides to the drawing ambient settings at the Surface collection level and the surface Commands
collection level affect only the specified level. The drawing level settings are not changed.
The topics in this section describe only those settings that affect surface-related commands, and do not cover
the drawing ambient settings that you can change at the surface collection level and the surface command
level, even though those settings are displayed in the Edit Feature Settings dialog box. For more information,
see Specifying Ambient Settings (page 84).

Changing Surface Creation Settings
Use the Surface Creation settings in the Edit Feature Settings - Surface (page 2629) dialog box to specify
surface-related settings before you create surfaces.
For example, before creating or importing surfaces, you may want to specify the default surface style and
default surface label styles.
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If a closed lock appears in the Lock column for a property, the property is locked at a higher level of the
Settings tree and cannot be changed at this level.
If you change a property value, a check mark appears in the Override column. This override is also reflected
in the property table for related objects higher up the Settings tree, where an arrow appears in the Child
Override column.
To the change surface creation settings
1 Do one of the following:
■

To edit settings for all surface-related commands: In Toolspace, on the Settings tab, right-click the
Surface collection and click Edit Feature Settings.

■

To edit settings for a specific command: In Toolspace, on the Settings tab, expand the Commands
collection under the Surface collection. Right-click the name of the command for which you want
to change settings and click Edit Command Settings.

The Edit Feature Settings - Surface (page 2629) dialog box is displayed.
2 Expand the Surface Creation property group.
3 To specify the default surface type, edit the Surface Default Type settings.
4 To specify the default grid surface spacing and orientation, edit the following settings:
■

Grid Surface X-Spacing

■

Grid Surface Y-Spacing

■

Grid Surface Orientation

5 To specify the default name format for a surface, expand the Default Name Format property group and
edit the Surface Name Template setting.
6 Click Apply.

Quick Reference
Toolspace Shortcut Menu
Settings tab: right-click Surface collection ➤ Edit Feature Settings
Or
Settings tab: Surface ➤ Commands ➤ right-click <command-name> ➤ Edit Command Settings
Dialog Box
Edit Feature Settings - Surface (page 2629)

Changing Surface Style Settings
Use the Surface Style settings to specify default surface styles and surface label styles before you create surfaces.
You can use the default styles specified in these settings to establish the default setting for the style in the
Create Surface dialog box.
To change the surface style settings
1 Do one of the following:
■

To edit settings for all surface-related commands: In Toolspace, on the Settings Tree, right-click the
Surface collection and click Edit Feature Settings.
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■

To edit settings for a specific command: In Toolspace, on the Settings tree, expand the Commands
collection under the Surface collection. Right-click the name of the command you want to change
settings for and click Edit Command Settings.

2 Expand the Default Styles property group.
3 To specify a default surface style, change the Surface Default Style setting.
4 To specify a default spot elevation label style, change the Surface Spot Elevation Label Style setting.
5 To specify a default slope label style, change the Surface Slope Label Style setting.
6 To specify a default point style, change the Point Style setting.
7 Click Apply.

Quick Reference
Toolspace Shortcut Menu
Settings tab: right-click Surface collection ➤ Edit Feature Settings
Or
Settings tab: Surface ➤ Commands ➤ right-click <command-name> ➤ Edit Command Settings
Dialog Box
Edit Feature Settings - Surface (page 2629)

Viewing Surface Statistics
AutoCAD Civil 3D provides extensive statistics based on the current state of the surface.
Surface statistics categories include:
■

General. Common to all surface types. Includes information such as bounding extents and elevations.

■

Extended. Available for (non-volume) TIN and grid surfaces. Includes information such as 2D and 3D
area as well as grade and slope values.

■

Grid. Specific to grid surfaces. Includes information such as grid spacing and orientation.

■

TIN. Specific to TIN surfaces. Includes information the number, area, and length of surface triangles.

■

Volume. Specific to volume surfaces. Includes volume statistics.

To view the statistics for a surface
1 In Toolspace, on the Prospector tab, expand the Surfaces collection, right-click the surface, and click
Properties.
2 In the Surface Properties dialog box, click the Statistics tab (page 2662).
3 To view the statistics for the surface, expand the corresponding category.

Quick Reference
Toolspace Shortcut Menu
Prospector tab: Surfaces ➤ right-click <surface-name> ➤ Properties
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Object Shortcut Menu
Surface Properties
Command Line
EditSurfaceProperties
Dialog Box
Surface Properties - Statistics Tab (page 2662)

Troubleshooting Surface Errors
Identify and troubleshoot errors or problems with a surface, or its data components, in several ways.
For surface troubleshooting information, see Surface Errors and Issues (page 696).

Working with Large Surfaces
In AutoCAD Civil 3D you can build, edit, and save large surfaces. The term “large surface” applies to a surface
with a number of points exceeding one million (generally, 1 million points for a grid surface or a snapshot
of a TIN surface, and 2 million points for a TIN surface).
AutoCAD Civil 3D has a mechanism for handling operations with large surfaces. When you save a drawing
containing a large surface, the data pertaining to the large surface is written to a separate file that is saved
in the same location where the surface drawing resides. The TIN surface companion files have the .mms file
extension, and the grid surface files have the .grs file extension. The file name of a surface companion file
has the <drawing_name>_<surface object handle>.mms format.
NOTE Every time you move the drawing file to a different location, you must move the companion file to the
same location.
For more details on working with large surfaces, see:

Calculating Surface Volumes
Use surface utilities to query composite and bounded volume differences between surface.
Composite volumes use top and bottom surfaces (a surface pair) to establish cut, fill, and net volume values.
Bounded volumes use an existing AutoCAD object (for example, a polyline or polygon) to calculate the cut,
fill, and net volume for the area bounded by the object.

Calculating Composite Volumes
Calculate volumes using the composite method, which triangulates a new surface, based on points from
both surfaces.
This method uses the points from both surfaces, as well as any location where the edges of the triangles
between the two surfaces intersect to create prismoidal segments from composite TIN lines.
The new composite surface elevations are calculated based on the difference between the elevations of the
two surfaces, as follows:
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composite surface is created by combining TIN edges from top
and bottom surface

where TIN lines intersect, new TIN
lines are added to create composite
composite volumes are calculated by creating
prismoidal segments from composite TIN lines

plan view

TIN line added

This method gives accurate volume measurements between the two surface definitions.
See also:
■

Creating a TIN Volume Surface (page 651)

■

Creating a Grid Volume Surface (page 653)

To calculate composite surface volumes
1 Open, create, or import the TIN or grid surfaces for which you want to measure the composite volume.
See Creating Surfaces (page 648).
NOTE The Composite Volumes utility compares two surfaces (surface pairs), so you must have two surfaces
available in your drawing.
2 Click Analyze tab ➤ Volumes And Materials panel ➤ Volumes drop-down ➤ Volumes

.

3 Do one of the following:
■

In the Composite Volumes (page 2620) vista, click
and select the surfaces to compare by clicking
the <select surface> entry from the Base Surface and Comparison Surface columns (for the base and
comparison surfaces respectively).

■

In the Composite Volumes vista, click
the drawing area.

and select both the base and comparison surfaces from

After you select the surfaces, the volumes are calculated and the following information is displayed:
■

Cut. The amount of material that has to be removed.

■

Fill. The amount of material that has to be added.
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■

Net. The difference between the cut and the fill. For example, if a volume is 200 m3 of cut and 100
m3 of fill, the net is 100 m3 <cut>.

■

Net Graph. A graphical percentage representation of the whole volume. A fill net is displayed as a
green bar indicating that material needs to be added to the project site. A cut net is displayed as a
red bar, indicating that material must be removed.

Quick Reference
Ribbon
Analyze tab ➤ Volumes And Materials panel ➤ Volumes drop-down ➤ Volumes
Menu
Surfaces menu ➤ Utilities ➤ Volumes
Command Line
ReportSurfaceVolume
Dialog Box
Composite Volumes (page 2620)

Calculating Bounded Volumes
Use the Bounded Volume utility to calculate the volume of an area defined by a polyline, a polygon, or a
parcel, as well as specify the datum elevation as an option.
You can calculate and display the net volume, as well as cut and fill for a bounded area defined by a polyline,
polygon, or parcel. You can also compute a volume within the polygon to a specified datum elevation,
which is useful to determine the volumes for ponds or borrow pits.
For volume surfaces, the volume of the bounded area is calculated based on the difference of elevations
originally calculated between the base surface and comparison surface. For terrain surfaces, the volume is
calculated from the zero elevation to the elevations in the bounded area or to the specified datum elevation.
See also:
■

Creating a TIN Volume Surface (page 651)

■

Creating a Grid Volume Surface (page 653)
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To calculate bounded volumes
1 Open, create, or import the surface for which you want to measure the bounded volume. See Creating
Surfaces (page 648).
2 Click Analyze tab ➤ Volumes And Materials panel ➤ Volumes drop-down ➤ Bounded Volumes

.

3 If multiple surfaces exist in the drawing, select a surface.
The current datum elevation is displayed at the command line.
TIP Press F2 to open the AutoCAD Text Window where the results are also displayed.
4 Do one of the following:
■

In the drawing, select the bounding polygon that defines the area on the surface

■

At the command line, enter D to select the Datum option and then enter a value or snap (OSNAP)
to a point on the drawing.

Volumes at the selected datum elevation, as well the net volume and cut and fill values are displayed
in the command line window.
5 Select another bounding polygon or change the current datum elevation or press Enter to terminate the
command.

Quick Reference
Ribbon
Analyze tab ➤ Volumes And Materials panel ➤ Volumes drop-down ➤ Bounded Volumes
Menu
Surfaces menu ➤ Utilities ➤ Bounded Volumes
Command Line
ReportSurfBoundedVolume

Calculating Stage Storage Volumes from a Surface
Using the Stage Storage command, you can calculate incremental and cumulative volumes of a basin.
The storage volume at each depth (stage) is calculated from the input and the cumulative volume is totaled.
To define the basin, you can use one of the following:
■

An existing surface.

■

Selected contours within an existing surface.

■

Existing polylines in the drawing. These must be lwpolylines, such as created with the PLINE command.

■

Contour elevation and area data that you enter into a dialog box.

To use either a surface or contours within a surface, contours must be visible (page 744).
Analyzing Stage Storage Volumes (page 36)
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Displaying Contours for Stage Storage Analysis
Display surface contours in the drawing to define the basin from a surface or surface contours.
This is a prerequisite if you want to use the Define From Entities option in the Stage Storage (page 2663) dialog
box.
To display contours
1 In AutoCAD Civil 3D 2011, open a drawing that contains a basin you would like to study.
2 To view surface contours, right-click on the surface, and click Edit Surface Style.
3 In the Surface Style dialog box, on the Display tab:
■

Set Major Contours and Minor Contours to be visible.

■

Optionally, set User Contours and Watersheds to be visible.

■

Click OK.

Analyzing Stage Storage Volumes
Calculate incremental and cumulative volumes of a basin.
The storage volume at each depth (stage) is calculated from the input and the cumulative volume is totaled.
NOTE The units are based on the Drawing Unit specified in the Units And Zone tab (page 80) of the Drawing
Settings dialog box.
To analyze stage storage volumes
1 Turn on the visibility of contours (page 744) for the surface if you are going to use a surface or contours
to define the basin.
2 Click Analyze tab ➤ Design panel

Stage Storage

.

3 In the Stage Storage (page 2663) dialog box, enter Stage Storage Table Details.
4 For Volume Calculation Method (page 748), click Average End Area, Conic Approximation, or Both.
5 For Basin Definition Options, do one of the following:
■

Select Define Basin From Entity, click Define Basin, and define the basin using all the contours in
a surface (page 744).

■

Select Define Basin From Entity, click Define Basin, and define the basin using polylines or selected
contours extracted from a surface (page 745).

■

Select Use Manual Contour Data Entry and click Define Basin to manually enter contour elevations
and areas (page 746).

To define the basin using all contour data from a surface object
1 In the Define Basin From Entities (page 2626) dialog box:
■

Click Define Basin From Surface Contours.

■

Click Define.

2 In the drawing, select the surface (“1” in the following illustration) and right-click or press Enter.
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The surface object data is extracted, and listed in the Stage Storage Volume Table. This option uses all
the contour data from the surface.
3 Save the results. (page 747)
To define the basin using polylines or selected surface contours
1 In the Stage Storage dialog box, under Basin Definition Options:
■

Click Define Basin From Entity.

■

Click Define Basin.

2 In the Define Basin From Entities (page 2626) dialog box, click Define Basin From Polylines.
3 Optionally, if you want to extract polylines from surface contours to define the basin, click Extract
Objects From Surface, and then select the surface in the drawing and press Enter. When you click Define
in the Define Basin From Entities dialog box, you can then select the polylines that were created to
define the basin.
NOTE Whereas the Define Basin From Surface Contours option uses all of the surface contours for the input
data, you can use the Extract Objects From Surface option to extract data from selected contours, for example,
the contours that define a depression.
4 Optionally, clear Change Selected Entities To The Following Layer.
If you select Change Selected Entities To The Following Layer, for Basin Polyline Layer, enter the layer
to which you want the polylines to be moved.
5 Select Delete Unselected Entities On Selected Layer.
TIP This option cleans up the drawing by deleting any polylines that were created by the Extract Entities
From Surface button, but which you do not select with the Define button.
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6 Click Define.
7 Select at least two polylines. In the following illustration a third polyline (3) is included. Either right-click
or press Enter.

NOTE The polylines must be lwpolylines (created with the PLINE command, for example).
The polyline data is extracted and listed in the Stage Storage Volume Table.
8 Save the results. (page 747)
To define the basin by manually entering surface contour data
1 In the Define Basin From Entered Data (page 2627) dialog box, enter contour elevation and area data for
at least two contours.
2 Click Add To Table.
The information is added to the Stage Storage Volume Table, with volumes calculated.
3 Save the results. (page 747)

Quick Reference
Ribbon
Analyze tab ➤ Design panel
Command Line
StageStorage
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Stage Storage

Dialog Boxes
Stage Storage (page 2663)
Define Basin From Entities (page 2626)
Define Basin From Entered Data (page 2627)

Saving and Displaying the Stage Storage Volume Analysis
Save and display stage storage volume analysis results.
To save and display the volume results
1 Calculate stage storage volumes (page 744).
2 In the Stage Storage dialog box, click Save Table.
3 In the Browse For Folder dialog box:
■

Select the folder in which you wish to save the table.

■

Click OK.

4 In the Save A Stage Storage Table dialog box:
■

Enter a File Name for the table.

■

Click Save.
The volume table is saved as an AeccSST file. You can click Load Table to import the saved data.

5 In the Stage Storage dialog box, click Insert.
6 Click in the drawing to insert the table.
NOTE The stage storage tables are not dynamic. To update the table, you must recalculate the data and
re-insert the table.

To save and display a stage storage volume report
1 In the Stage Storage dialog box, click Create Report.
2 In the Save A Stage Storage Report dialog box:
■

Select the folder in which you wish to save the report.

■

Enter a File Name for the report.

■

Click Save.

The report is saved as a TXT file and opens in your default text file viewer.

Quick Reference
Ribbon
Analyze tab ➤ Design panel ➤

➤ Stage Storage

Command Line
StageStorage
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Dialog Box
Stage Storage (page 2663)

Stage Storage Volume Calculation Methods
Use either the Average End Area or the Conic Approximation method, or both, to calculate volumes for the
stage storage table.

Average End Area Method
The Average End Area method calculates the volume between two cross sections; the cross-sectional areas
are averaged and multiplied by the distance between cross sections to determine the volume.
The Average End Area method is expressed by the following equation:

where V is the volume, calculated from the two end areas A1 and A2, and the distance L between the two
areas.

Conic Approximation Method
The Conic Approximation method calculates the volume between two sectional areas; the two areas being
added along with the square root of their product and multiplied by a third of distance between the areas
to determine the volume.
The Conic Approximation method is expressed by the following equation:

where V is the volume, calculated from the two areas A1 and A2, and the distance h between the two areas.

Surface Styles and Visualization
Surface styles control the surface appearance in both 2D and 3D views.
Access and manage the surface styles in the Settings tab in Toolspace, where you can create, edit, copy, and
delete them. For more information, see The Object Style Collection (Settings Tree) (page 111).
You can assign a surface style to a surface when you create or import a surface. You can also change the
surface style using the surface list view.
The surface styles contain parameters and display settings for the creation of surface data objects, including:
■

Borders. Includes interior and exterior border and datum display.

■

Contours. Includes minor, major, depression, and user-defined contour lines display.

■

Grid. Includes primary and secondary grid display.

■

Points. All surface points for the TIN or grid surfaces.

■

Triangles. TIN face information.

■

Analysis. Includes directions, elevations, slopes, and slope arrows.
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■

Watersheds. Watersheds analysis display.

For general information about AutoCAD Civil 3D styles, see Object and Label Styles (page 66).

Creating a Surface Style
Use the Settings tree to create a surface style.
A surface style defines how a surface is displayed in the drawing. You can apply the surface style to either a
TIN surface, a grid surface, or a volume surface.
You can create and manage surface styles on the Settings tab in Toolspace.
To create a surface style
1 In Toolspace, on the Settings tab, right-click the Surface Styles collection and click New.
2 In the Surface Style dialog box, click the Information (page 2644) tab and enter a name and description
for the surface style.
3 To define the display of surface borders, click the Borders (page 2645) tab and specify the settings.
4 To define the display of surface contours, click the Contours (page 2646) tab and specify the settings.
5 To define the display of surface grid, click the Grid (page 2648) tab and specify the settings.
6 To define the display of surface points, click the Points (page 2649) tab and specify the settings.
7 To define the display of surface triangles, click the Triangles (page 2651) tab and specify the settings.
8 To define the display of watersheds, click the Watersheds (page 2651) tab and specify the settings.
9 To define the display the analysis, click the Analysis (page 2653) tab and specify the settings.
10 To define the display of the various surface components, click the Display (page 2655) tab.
11 To view summary information about the style, click the Summary (page 2655) tab.
12 Click Apply.

Quick Reference
Toolspace Shortcut Menu
Settings tab: Surface ➤ right-click Surface Styles ➤ New
Object Shortcut Menu
Edit Surface Style
Dialog Box
Surface Style (page 2644)

Creating a Surface Style Based on an Existing Surface Style
Use the Settings tree to create a surface style based on an existing surface style.
You create a surface style based on an existing surface style by making a copy of the existing surface style
and then editing it.
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To create a surface style based on an existing surface style
1 In Toolspace, on the Settings tab, right-click the name of the surface style you want to copy and click
Copy.
A copy is created, and its properties are displayed in the Surface Style dialog box.
2 In the Surface Style dialog box, click the Information (page 2644) tab and enter a name and description
for the new surface style
3 Use the Surface Style (page 2644) dialog box to change any of the surface style properties. For more
information, see Creating a Surface Style (page 749).

Quick Reference
Toolspace Shortcut Menu
Settings tab: Surface ➤ Surface Styles ➤ right-click <style-name> ➤ Copy
Object Shortcut Menu
Edit Surface Style
Dialog Box
Surface Style (page 2644)

Editing a Surface Style
Use the Settings tree to edit a surface style.
To edit a surface style
1 In Toolspace, on the Settings tab, right-click the name of the surface style that you want to edit and
click Edit.
2 Use the Surface Style (page 2644) dialog box to change the properties of the surface style.
For more information, see Creating a Surface Style (page 749).

Quick Reference
Toolspace Shortcut Menu
Settings tab: Surface ➤ Surface Styles ➤ right-click <style-name> ➤ Edit
Object Shortcut Menu
Edit Surface Style
Dialog Box
Surface Style (page 2644)

Draping Images On Surfaces
Use the Drape Image command to overlay an image, such as an aerial photo, over a surface.
Before draping an image on a surface, insert the image into the drawing. The Drape Image command orients,
aligns, and renders the inserted image so that the original flat image reshapes to replicate the relief of the
surface terrain.
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To drape an image over a surface
TIP To perform this operation, ensure that the surface display style has triangles visibility enabled. See Editing a
Surface Style (page 750). Also, ensure that Realistic is a default type of materials set in the Material Editor in the
Materials window (to view the settings, at the command line, enter MATERIALS).
1 Click Insert tab ➤ Reference panel ➤ Attach

.

2 Navigate to the location where the image is saved, select the image, and click Open.
3 In the Attach Image dialog box, specify Insertion Point, Scale, and Rotation or select Specify on Screen
to do the adjustments in the drawing.
4 Click OK.
5 Select a surface. On the Surface tab, Surface Tools panel, click Drape Image
6 In the Drape Image dialog box, select the image from the Image list or click
the drawing.

.
to select the image from

7 From the Surface list, select the surface on which you want to drape the image or click
surface from the drawing.

to select the

8 Under Render Material Name, enter the name for the new render material. This name will be associated
with the new render material which is created from the image that you have imported.
NOTE By default, the name of the new render material is comprised of the surface name and the image file
name.
9 Click OK.
The image is draped over the surface. This image becomes associated with the new render material,
which is added to the materials palette.
If the image is smaller than the surface, the draping only occurs on the area covered by the image. If
the area of the image exceeds the area of the surface, the image is cropped along the surface boundary.
NOTE If you view your drawing in 2D plan view, the image displays in its 2D planar view.

Quick Reference
Ribbon
Select a surface. Surface tab ➤ Surface Tools panel ➤ Drape Image
Menu
Surfaces menu ➤ Utilities ➤ Drape Image
Command Line
ImageAttach
DrapeImage
Dialog Box
Drape Image (page 2628)
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Surface Labels and Tables
Use surface label and table styles to control the appearance and behavior of surface-related labels and tables
in a drawing.
The topics in this section describe what is unique to surface labels and tables. For a general overview of
labels, see Labels and Tags (page 1643). For an overview of tables, see Tables (page 1737).

Surface Labels
Surfaces can be labeled automatically when created, using the specified label styles. After creating a surface,
you can also add labels for the various components of the surface.

Surface Tables
You can use commands to insert surface legend tables into a drawing. Surface legend tables are used to
display surface analysis information. When you insert a table into the drawing, the detailed surface
information is inserted into the table.

Surface Label Styles
Use the Settings tab of Toolspace to manage surface label styles. You specify which label styles to use when
you create surfaces, when using the Add Labels dialog box to add slope and spot elevation labels.
For information about creating and using label styles, see Understanding Labels (page 1646).
You can create and use:
This type of surface
label style...

Labels...

Slope

A slope on a surface. The slope can be from a single point
as it resides on a TIN face or surface grid cell, or between
two points.

Spot elevation

A random point location with an elevation anywhere within
a surface.

Watershed

The centroid of a watershed when the watershed component
is displayed.

Contour

Contours at major, minor, and user-defined increments.

Slope Label Styles
A slope label style is used for labeling a slope on a surface.
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The slope can be labeled as a grade or slope, and is formatted using the slope label style. The direction of
the slope is represented by a direction arrow component defined in the slope label style.
A slope label style requires these elements:
■

Font (set in the Label Style Composer)

■

Text height (set in the Label Style Composer)

■

Orientation (set in the Label Style Composer)

■

Directional arrow (set in the Label Style Composer)

■

Position above/below directional arrow (set in the Label Style Composer)

■

Attributes (set on the Properties tab of the Text Component Editor - Contents dialog box)

■

Slope/Grade value

■

Formatting/Precision (set in the Label Style Composer)

■

Percent

■

Decimal

■

Run/Rise

Spot Elevation Label Styles
Spot elevation labels are required for labeling a random point location with an elevation anywhere within
a surface.
The spot elevation label style is configured in the Label Style Composer. When a spot elevation is created,
the command can specify an existing point style and label style at create-time, or a block can be specified
in the composition of the spot elevation label style.

The following examples illustrate a label style that can label a spot elevation at the elevation decimal point.
The decimal point of the spot elevation value is represented by a block, or a point style specified at creation
time. The labeled elevation consists of two subtext components in the label style, each with different
properties:
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general
anchor component: <feature>
anchor point: middle left
component name: elevation_left
text
attachment: middle right
contents: <elevation[feet:0:normal:lhs]>
general
anchor component: <feature>
anchor point: middle right
component name: elevation_right
text
attachment: middle left
contents: <elevation[feet:2:normal:rhs]>

Watershed Label Styles
Watershed label styles are used to draw a label at the centroid of a watershed when the watershed component
is displayed, using the surface style.
Manage watershed label styles under the Surface collection in the Settings tree.

Contour Label Styles
Use the Add Labels (page 2208) dialog box to add contour label lines to a surface.
Use the Add Labels dialog box to specify:
■

Labeling placement and spacing options

■

Major contour label style and increment properties

■

Minor contour label style and increment properties

■

User-defined contour label style

Adding Surface Labels
You can label single slopes, spot elevations, and contours by using specified surface label types.
Watershed labels are created automatically. Their display is controlled by the surface style and cannot be
added using this command.

Adding Slope Labels
You can label individual slope points or label a slope between two points on the surface in the current
drawing.
The slope can either be from a single point as it resides on a TIN face or surface grid cell, or between two
points. The slope can be labeled as a grade or slope with a negative value representing a decreasing slope or
grade. The direction of the slope is represented by a direction arrow component defined in the slope label
style.

Two-Point Slope Labels
You can create a slope label by selecting two points. The first point (XYZ) is the origin of the vector and the
second point (XYZ) determines direction and slope.
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One-Point Slope Labels
Create a slope label by selecting a single point. The normal of the surface triangle is determined and the
selected point (XYZ) and the direction of the triangle normal are passed to the slope label style.
For more information about setting the slope label styles, see Slope Label Styles (page 752).
To add slope labels
1 Click Annotate tab ➤ Labels & Tables panel ➤ Add Labels menu ➤ Surface ➤ Slope

.

2 At the command line, enter either One-point or Two-point depending on the type of the slope label
that you want to add and then press Enter.
3 Digitize the location of the first point and the second point (if applicable).
4 Optionally, repeat Step 3 to add more slope labels.
OR
1 Click Annotate tab ➤ Labels & Tables panel ➤ Add Labels menu ➤ Surface ➤ Add Surface Labels

.

2 In the Add Labels dialog box, select Surface in the Feature list.
3 Select Slope from the Label Type list.
NOTE If you want to view or edit the settings for slope labels, click
- AddSurfaceSlopeLabel dialog box.

to open the Edit Command Settings

4 Select the label style for the slope from the Slope Label Style list or use the standard style selection
controls.
NOTE Ensure that the slope label style is appropriate for one-point or two-point slope labels. A slope label
style that was composed for a start point and end point may not be appropriate for a one-point slope label.
5 Click Add.
6 At the command line, enter either One-point or Two-point depending on the type of the slope label
that you want to add and then press Enter.
7 Digitize the location of the first point and the second point (if applicable).
8 Optionally, repeat Step 7 to add more slope labels.

Quick Reference
Ribbon
Annotate tab ➤ Labels & Tables panel ➤ Add Labels ➤ Surface ➤ Slope
Menu
Surfaces menu ➤ Add Surface Labels ➤ Add Surface Labels
Command Line
AddSurfaceLabels
AddLabels

Adding Surface Labels | 755

Adding Spot Elevation Labels
Spot elevation labels are required for labeling a random point location with an elevation anywhere within
a surface.
For more information about setting the spot elevation label styles, see Spot Elevation Label Styles (page 753).
To add surface spot elevation labels
1 Click Annotate tab ➤ Labels & Tables panel ➤ Add Labels menu ➤ Surface ➤ Spot Elevation

.

2 Select the point to label.
OR
1 Click Annotate tab ➤ Labels & Tables panel ➤ Add Labels menu ➤ Surface ➤ Add Surface Labels

.

2 In the Add Labels dialog box, select Surface in the Feature list.
3 From the Label Type list, select Spot Elevation.
NOTE If you want to view or edit the settings for spot elevation labels, click
Settings - AddSurfaceSpotElevLabel dialog box.

to display the Edit Command

4 Select the label style for the spot elevation from the Spot Elevation Label Style list or use the standard
style selection controls.
5 Select the marker style for the spot elevation from the Marker Style list or use the standard style selection
controls.
6 Click Add. You are prompted at the command line to select a point in the drawing area.
7 In the drawing, click the location of the point.
8 Optionally, repeat Step 7 to add more spot elevation labels.

Quick Reference
Ribbon
Annotate tab ➤ Labels & Tables panel ➤ Add Labels menu ➤ Surface ➤ Spot Elevation
Menu
Surfaces menu ➤ Add Surface Labels ➤ Add Surface Labels
Command Line
AddSurfaceSpotElevLabel
AddSurfaceLabels

Adding Spot Elevation Labels On Grid
You can create a grid of surface spot elevation labels in the current drawing.
The following illustration shows a grid of surface spot elevation labels.
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For more information about setting the spot elevation label styles, see Spot Elevation Label Styles (page 753).
To add surface spot elevations on grid labels
1 Click Annotate tab ➤ Labels & Tables panel ➤ Add Labels menu ➤ Surface ➤ Spot Elevations On Grid
.
2 Follow command line instructions to add a grid spot elevation label.
OR
1 Click Annotate tab ➤ Labels & Tables panel ➤ Add Labels menu ➤ Surface ➤ Add Surface Labels

.

2 In the Add Labels dialog box, select Surface in the Feature list.
3 From the Label Type list, select Spot Elevations on Grid.
NOTE If you want to view or edit the settings for spot elevation labels, click
Settings - AddSpotElevLabelsOnGrid dialog box.

to display the Edit Command

4 Select the label style for the spot elevation from the Spot Elevation Label Style list or use the standard
style selection controls.
5 Select the marker style for the spot elevation from the Marker Style list or use the standard style selection
controls.
6 Click Add. You are prompted at the command line to select a point in the drawing area.
7 Follow command line instructions to add a grid spot elevation label.
8 In the drawing, click the location of the point.
9 Optionally, repeat Step 7 to add more spot elevation labels.

Quick Reference
Ribbon
Annotate tab ➤ Labels & Tables panel ➤ Add Labels menu ➤ Surface ➤ Spot Elevations On Grid
Menu
Surfaces menu ➤ Add Surface Labels ➤ Add Surface Labels
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Command Line
AddSpotElevLabelsOnGrid
AddSurfaceLabels

Adding Watershed Labels
Watershed labels can be considered an attribute of a watershed and not a separate component since they
require no placement. Watershed labels are drawn at the watershed centroid.
For more information about setting the watershed label styles, see Watershed Label Styles (page 754).

Adding Single Contour Labels
Use specified contour label styles to add single contour labels to a surface.
You can create contour labels by specifying line segments that cross contour lines of a surface. Add Single,
Multiple, or Multiple at Interval contour labels. Modify the properties of contour label lines to change the
label style for major, minor, and user-defined contour labels.
Use a line or polyline of an existing object as a label line or draw label lines on the fly for single or multiple
contours.

NOTE The line that is used to place the contour labels is a custom object called the Surface Contour Label Group
object. The default layer for this object is set on the Object Layers tab of the Drawing Settings dialog box.
TIP Freezing the default layer of the contour label line freezes the contour labels. To control the visibility of the
contour label line, change its display settings in the contour label line properties.
To make a contour label mask out the contour use the Background Mask property in the contour label style.
Edit the contour label style using the Label Style Composer, and on the Layout tab under Border, set the
value for Background Mask to True.
You can also use the Masking property in the AutoCAD Properties palette to mask contour lines. For more
information, see Background Mask (page 1675).
To add single surface contour labels
1 Click Annotate tab ➤ Labels & Tables panel ➤ Add Labels menu ➤ Surface ➤ Contour - Single

.

2 Select the contour to label.
OR
1 Click Annotate tab ➤ Labels & Tables panel ➤ Add Labels menu ➤ Surface ➤ Add Surface Labels
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.

2 In the Add Labels dialog box, from the Label Type list, select Contour - Single to add single contour
labels by picking a single point on a surface contour line.
NOTE If you want to view or edit the settings for surface contour labels, click
to display the Edit Command
Settings - AddContourLabelingSingle dialog box. Set the Display Contour Label Line to false to display contour
label lines only when its label is selected.
3 Depending on the type of surface contour lines (major, minor, or user-defined) that the contour label
line crosses, specify the label styles for the corresponding contour lines:
■

From the Major Contour Label Style list, select the style for major contour lines.

■

From the Minor Contour Label Style list, select the style for minor contour lines.

■

From the User Contour Label Style list, select the style for user-defined contour lines.

4 Click Add.
5 Click on the contour line where you want to place a label. You can add as many labels as you want.
Press Enter when finished.
6 NOTE You can set the default interval value. In the Add Labels dialog box,
to display the Edit Command
Settings - AddContourLabelingSingle dialog box and set the Interval Along Contour property.
All the surface contours that were intersected by the contour label line are labeled at the specified
intervals along their entire length.

Quick Reference
Ribbon
Annotate tab ➤ Labels & Tables panel ➤ Add Labels menu ➤ Surface ➤ Contour - Multiple At Interval
Menu
Surfaces menu ➤ Add Surface Labels ➤ Add Surface Labels
Command Line
AddSurfaceContourLabelingGroup
AddSurfaceLabels

Adding Multiple Contour Labels
You can use specified contour label styles to add multiple contour labels to a surface.
You can create contour labels by specifying line segments that cross contour lines of a specified surface. You
can add multiple contour label types. Modify the properties of contour label lines to change the label style
for major, minor, and user-defined contour labels.
Use a line or polyline of an existing object as a label line or draw a label line (1) that crosses multiple contours.
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To make a contour label mask out the contour use the Background Mask property in the contour label style.
Edit the contour label style using the Label Style Composer, and on the Layout tab under Border, set the
value for Background Mask to True.
You can also use the Masking property in the AutoCAD Properties palette to mask contour lines. For more
information, see Background Mask (page 1675).
To add multiple surface contour labels
1 Click Annotate tab ➤ Labels & Tables panel ➤ Add Labels menu ➤ Surface ➤ Contour - Multiple

.

2 Select the contours to label.
OR
1 Click Annotate tab ➤ Labels & Tables panel ➤ Add Labels menu ➤ Surface ➤ Add Surface Labels

.

2 From the Label Type list, select Contour - Multiple to add multiple contour labels either along the
contour label line or polyline by picking segments to create Surface Contour Label Group objects from
the line or polyline objects.
NOTE If you want to view or edit the settings for surface contour labels, click
to display the Edit Command
Settings - AddContourLabeling dialog box. Set the Display Contour Label Line to false to display contour
label lines only when its label is selected.
3 Depending on the type of surface contour lines (major, minor, or user-defined) that the contour label
line crosses, specify the label styles for the corresponding contour lines:
■

From the Major Contour Label Style list, select the style for major contour lines.

■

From the Minor Contour Label Style list, select the style for minor contour lines.

■

From the User Contour Label Style list, select the style for user-defined contour lines.

4 Click Add.
5 Click on the contour line to specify the start point. Drag the contour label line across multiple contour
lines until you reach the desired end point. Alternatively, after you specify the start point, you can click
at individual points on the contour lines to create a contour label polyline. Press Enter.
6 NOTE You can set the default interval value. In the Add Labels dialog box,
to display the Edit Command
Settings - AddContourLabeling dialog box and set the Interval Along Contour property.
All the surface contours that were intersected by the contour label line are labeled at the specified
intervals along their entire length.
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Quick Reference
Ribbon
Annotate tab ➤ Labels & Tables panel ➤ Add Labels menu ➤ Surface ➤ Contour - Multiple At Interval
Menu
Surfaces menu ➤ Add Surface Labels ➤ Add Surface Labels
Command Line
AddContourLabeling
AddLabels

Adding Multiple Contour Labels at an Interval
You can use specified contour label styles to add multiple contour labels to a surface at a specified interval.
Create contour labels by drawing a contour label line (1) that crosses surfaces contours and specify the
interval (2) between the labels along those contours.

Modify the properties of contour label lines to change the label style for major, minor, and user-defined
contour labels.
To add multiple surface contour labels at an interval
1 Click Annotate tab ➤ Labels & Tables panel ➤ Add Labels menu ➤ Surface ➤ Contour - Multiple At
Interval

.

2 Click on the contour line to specify the start point. Follow the prompt in the command line to specify
the next point on a contour label line and the interval along the contour line. Press Enter
OR
1 Click Annotate tab ➤ Labels & Tables panel ➤ Add Labels menu ➤ Surface ➤ Add Surface Labels

.

2 From the Label Type list, select Contour - Multiple at Interval to add multiple contour labels at a set
interval along the entire length of the contour crossed by the label line segment.
NOTE If you want to view or edit the settings for surface contour labels, click
to display the Edit Command
Settings - AddContourLabelingGroup dialog box. Set the Display Contour Label Line to false to display contour
label lines only when its label is selected.
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3 Depending on the type of surface contour lines (major, minor, or user-defined) that the contour label
line crosses, specify the label styles for the corresponding contour lines:
■

From the Major Contour Label Style list, select the style for major contour lines.

■

From the Minor Contour Label Style list, select the style for minor contour lines.

■

From the User Contour Label Style list, select the style for user-defined contour lines.

4 Click Add.
5 Click on the contour line to specify the start point. Follow the prompt in the command line to specify
the next point on a contour label line and the interval along the contour line. Press Enter.
NOTE You can set the default interval value. In the Add Labels dialog box, click
to display the Edit
Command Settings - AddContourLabelingGroup dialog box and set the Interval Along Contour property.
All the surface contours that were intersected by the contour label line are labeled at the specified
intervals along their entire length.

Quick Reference
Ribbon
Annotate tab ➤ Labels & Tables panel ➤ Add Labels menu ➤ Surface ➤ Contour - Multiple At Interval
Menu
Surfaces menu ➤ Add Surface Labels ➤ Add Surface Labels
Command Line
AddContourLabelingGroup
AddLabels

Modifying Surface Labels
Modify the display and location of surface and contour labels.
For information about modifying labels, see Inserting and Managing Labels in Drawings (page 1701). For more
information about which properties of different label types can be modified, see Managing Layout Properties
for Label Styles (page 1671).

Surface Table Styles
Use the Toolspace Settings tab to manage surface table styles.
You can create and use the following types of surface table styles:
This surface table
style...

Places the following surface information in the table...

Direction

Aspect or direction ranges, colors, and area

Elevation

Elevation ranges, colors, area, and volume

Slope

Slope ranges, colors, and face areas
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This surface table
style...

Places the following surface information in the table...

Slope Arrow

Slope arrow ranges, colors, and face areas

Contour

Contour ranges, colors, areas, and volumes

Watershed

Number, type, description, color, hatching, and drainage area
for the watersheds

User-Defined Contour

User-defined contour ranges, colors, areas, and volumes

See also:
■

Table Styles (page 1738)

Adding Surface Legend Tables
Use surface legend tables to organize and consolidate information about the surfaces in your drawing.
You can create surface legend tables for all types of surface analysis, including directions, elevations, slopes,
slope arrows, contours, and watersheds. For more information about surface analysis, see Analyzing Surfaces
(page 764).
You create and edit tables for most objects using the same common procedures and standard dialog boxes.
For information about modifying tables, see Modifying Tables (page 1750).
You can control the display of the analysis in the drawing by adjusting the surface style Display settings.
Before creating a surface legend table, generate the surface analysis from the Analysis tab on the Surface
Properties dialog box.
To create a surface legend table
1 Generate the surface analysis that you are going to display in the legend table. See Analyzing Surfaces
(page 764).
2 To edit the styles for the tables, on the Settings tab, expand the Surface collection, expand the Table
Styles collection, and select the collection for the type of legend that you want to add. In the Settings
list view, right-click the style and click Edit.
3 To add the legend table, click Annotate tab ➤ Labels & Tables panel ➤ Add Tables menu ➤ Add Surface
Legend Table

.

4 You are prompted to select the surface from the drawing area.
5 You are prompted to enter the table type. Enter one of Directions, Elevations, Slopes, SlopeArrows,
Contours, UserContours, or Watersheds.
6 You are prompted to specify if you want the table to update automatically if the analysis information
changes. Enter Dynamic to enable automatic updating.
7 You are prompted to select the upper left-hand corner for the table in the drawing area.
The legend table is displayed.

Adding Surface Legend Tables | 763

Quick Reference
Ribbon
Annotate tab ➤ Labels & Tables panel ➤ Add Tables menu ➤ Add Surface Legend Table
Menu
Surfaces menu ➤ Add Legend Table
Command Line
AddSurfaceLegendTable

Analyzing Surfaces
You can perform many types of surface-related analysis, including contour, directions, elevations, slopes,
slope-arrows, watersheds, and water drop path.
Surface analysis types include:
■

Directions. Used for aspect analysis. Renders surface triangles differently according to the direction they
face.

■

Elevations. Used for elevation banding analysis. Renders surface triangles differently according to their
elevation range.

■

Slopes. Renders surface triangles differently according to the slope range they fall within.

■

Slope Arrows. Used for slope direction analysis. Places a slope directional arrow at each triangle centroid.
The arrow color is based on the color assigned to a slope range, similar to slope analysis.

■

Contours. Renders contour lines differently in according to their elevation range.

■

User-Defined Contours. Renders user-defined contour lines differently according to their elevation range.

■

Watersheds. Renders watersheds differently according to their type.

■

Contour Problems. Used to locate problems with contours that are drawn according to the surface style
contour settings.

■

Water Drop. Used to trace the path that water would take across a surface.

Use the Analysis tab (page 2653) in the Surface Style dialog box to control the display and styles for direction,
elevation, slope, and slope arrow analysis. Contours and watersheds have corresponding tabs (Contours tab
(page 2646) and Watersheds tab (page 2651)), where their style and display are controlled. Use the Analysis tab
(page 2659) in the Surface Properties dialog box to create the actual analysis.
To check for contour problems using a separate utility, click Analyze ➤ Ground Data panel ➤ Contour
Check

.

To perform water drop analysis in a separate utility, click Analyze ➤ Ground Data ➤ Water Drop

.

Creating Surface Analysis
Use the Analysis tab in the Surface Style dialog box to set up the analysis display and the Analysis tab in the
Surface Properties dialog box to create the analysis.
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To perform surface analysis
1 In Toolspace, on the Settings tab, right-click the Surface Styles collection and click New.
2 In the Surface Style dialog box, click the Information (page 2644) tab and assign a name and description
to the style.
3 Click the Analysis (page 2653) tab and modify the properties as required.
4 For contour analysis, to modify the default analysis values, click the Contours (page 2646) tab and modify
the Contour Ranges property group as well as the Major and Minor display settings.
5 For watershed analysis, click the Watersheds (page 2651) tab and modify the properties as required.
6 Click the Display (page 2655) tab and modify the display settings so that the analysis is displayed correctly.
7 Click OK to save the style and close the Surface Style dialog box.
8 In Toolspace, on the Prospector tab, expand the Surfaces collection, right-click the surface for which
you want to create an analysis, and click Properties.
9 In the Surface Properties dialog box, click the Analysis (page 2659) tab and select the analysis that you
want from the Analysis Type list.
NOTE The Analysis tab displays varying fields and options depending on the type of analysis that you select.
10 Optionally, select a legend style. For information about creating a legend, see Adding Surface Legend
Tables (page 763).
11 Modify the range or watershed parameters as required and click

to generate the analysis.

12 Optionally, modify the details of the analysis by editing the fields in the Details table. For more
information, see the Analysis (page 2659) tab.

Quick Reference
Toolspace Shortcut Menu
Prospector tab: Surfaces ➤ right-click <surface-name> ➤ Properties (Analysis tab)
Dialog Box
Surface Properties: Analysis Tab (page 2659)

Checking for Contour Problems
Use the Check for Contour Problems utility to identify problems with contours that are drawn according
to the surface style contour settings.
NOTE The Check for Contour Problems utility operates on TIN surfaces only.
The utility takes into account the base elevation and interval specified in the surface style. When the utility
encounters an invalid condition, a warning is displayed in the Event Viewer.
The utility looks at every surface point that falls on a contour. For each point, the utility counts the number
of neighboring points (that is, points to which it is connected by an edge or a point that lies on the opposite
side of a triangle that it belongs to) that fall at the same elevation. If the number of same-elevation neighbors
is one, the warning “Contour ends at [x,y,z]” is displayed in the Event Viewer. If the number of same-elevation
neighbors is more than two, the warning “Multiple contours at [x,y,z]” is displayed in the Event Viewer. In
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the second case, if the point is on the border of the surface, the warning “Multiple contours at border point
[x,y,z]” is displayed.

The “contour ends” condition can mean that a gap in the data contour was too wide for the triangulation
process to connect the ends with an edge. You can fill this gap by creating and adding a breakline that
connects the two ends.
The multiple contours condition, which occurs when a point has more than two neighboring points with
the same elevation, generally happens in a flat area of the surface. When this condition is detected, you can
use the Minimize Flat Areas operation to correct the problem. For more information, see Minimizing Flat
Areas in a Surface (page 705). If the point is on the surface border, the flat area can simply be an unintended
artifact of the triangulation process. You can remove these unintended triangles by using the Delete Line
operation or by adding a hide boundary.
If no contour problems are found, a message is displayed in the Event Viewer stating that no problem were
found for the surface style setting for contour base elevation and interval.
NOTE All contour problems occur when the elevation of a data contour point is the same as the elevation at
which a contour is drawn. If no points in the surface are at contour elevations, there will be no problems with
drawn contours. It is often possible and acceptable to adjust the contour base elevation value to create a condition
where no points fall on surface contours, thus avoiding contour problems entirely.
To check for contour problems
1 Click Analyze tab ➤ Ground Data panel ➤ Contour Check

.

2 If more than one surface is available in the drawing, click the surface on which to perform the check
or press Enter to select a surface in the Select A Surface dialog box.
3 Click OK.
Any detected contour problems are displayed in the Event Viewer.

Quick Reference
Ribbon
Analyze tab ➤ Ground Data panel ➤ Contour Check
Menu
Surfaces menu ➤ Utilities ➤ Check For Contour Problems
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Command Line
CheckForContourProblems

Drawing Water Drop Paths
Use the water drop utility to trace the path that water takes across a surface.
The utility draws a 2D or 3D polyline that represents a flow of water and also marks the start point of the
path. If a channel splits, then new polylines are drawn to follow each water drop path.
For example, multiple water drop paths can be drawn from a contour line to illustrate the water flow at
different points along the contour:

You can use either a 2D or 3D polyline to draw the flow line. The line type that you use depends on your
analysis requirements. Following are usage examples for each line type:
■

2D polyline. Delineate an area that represents a drainage area for water runoff analysis. You create a
closed 2D polyline using AutoCAD editing commands. You can use the resulting closed 2D polyline to
query the area and perform other analysis.

■

3D polyline: You want to perform visualization and drape the lines over the surface. You can also create
grading feature lines from the water drop lines for grading purposes.

To perform water drop analysis
1 Click Analyze tab ➤ Ground Data panel ➤ Water Drop

.

2 If more than one surface is available in the drawing, click the surface on which to perform the water
drop analysis or press Enter to select a surface in the Select A Surface dialog box.
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3 In the Water Drop (page 2665) dialog box, in the properties grid, click the Value column for the Path
Layer property. Enter a name for the layer on which to draw the water drop polyline or click
select a layer. For more information about layers, see Object Layer Dialog Box (page 2221).

to

4 To specify the type of polyline to use for the water drop path, click the Path Object Type field. Select
the type.
5 To specify whether to draw a marker at the start of the water drop path, click the Place Marker At Start
Point field. Select either Yes or No.
6 To set the style for the start point maker, click the Start Point Marker Style property. Click
Value column.

in the

The Point Style dialog box is displayed.
7 Click OK.
NOTE To be certain that any changes that you make to the water drop settings persist, ensure that the
drawing setting Save Command Changes To Settings is set to Yes. For information, see Specifying Ambient
Settings (page 84)
8 Click a point on the surface for the start of the water drop path.
9 Click another point to draw another water drop path or press Enter if finished.

Quick Reference
Ribbon
Analyze tab ➤ Ground Data panel ➤ Water Drop
Menu
Surfaces menu ➤ Utilities ➤ Water Drop
Command Line
CreateSurfaceWaterdrop
Dialog Box
Water Drop Dialog Box (page 2665)

Displaying and Calculating Catchment Areas
Use the Catchment Area command to analyze water runoff and display the surface drainage area. The data
obtained from running this command helps you perform H&H (hydrology and hydraulics) tasks, such as
designing detention ponds, storm sewers, and other tasks aimed at the prevention of soil erosion.
The command defines the surface region with a depression low point (catchment point), delineates the
region with a boundary, and calculates the area of the catchment region.
You can use a water drop path utility (page 767), to determine an accurate placement of catchment regions
and catchment points.
NOTE The Catchment Area command performs the analysis only on the selected surface region and does not
account for overflow situations occurring in the neighboring surface regions.
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To display a catchment region and calculate its area
1 Locate an area of interest in the drawing.
2 Optionally, perform the following steps:
a Click Analyze tab ➤ Ground Data panel ➤ Catchment Area

.

This command creates a polyline that represents the water drop path from a point on the selected
region to the depression point in this region.
b Select the water drop path polyline, right-click, and choose Properties.
c In the Properties manager, under Geometry, navigate to the last vertex and copy and paste the Xand Y-coordinate values (comma-separated with no space) into a text file.

3 Click Analyze tab ➤ Ground Data panel ➤ Catchment Area

.

4 In the Catchment Area dialog box, click the Value column for the Catchment Layer property and click
to select an existing layer, or create a layer in the Create Layer dialog box (page 2222).
BEST PRACTICE It is useful to place the catchment region on a separate layer. Then you can control visual
style elements, such as color and line types.
5 Click the Value column for the Catchment Object Type, and select a line type.
TIP If you select 2D Polyline, you can use the AutoCAD Area command on the catchment region. If you
select 3D Polyline, you can use the elevation values of the polyline vertices for analysis.
6 Click the Value column for the Catchment Marker property, and specify whether you want to mark
the catchment point.
7 Click
in the Value column of the Catchment Marker Style property, and then select a style in the
Catchment Marker Style dialog box. Click OK.
8 If more than one surface is available in the drawing, click the surface on which to perform the catchment
region analysis, or press Enter to select a surface in the Select A Surface dialog box.
9 Specify a catchment location. You can either paste the coordinates that you copied in Step 2 or click
in the desired location.
The catchment region boundary appears on the drawing, and the value of the region area displays at
the command line.
10 Repeat Step 11 for other coordinates or locations.

Quick Reference
Ribbon
Analyze tab ➤ Ground Data panel ➤ Catchment Area
Menu
Surfaces menu ➤ Utilities ➤ Water Drop
Command Line
CatchmentArea
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Dialog Box
Catchment Area (page 2620)

Identifying the Shortest Distance Between Two Surfaces
Use the Calculate Minimum Distance Between Surfaces command to list the shortest vertical distance between
two surfaces.
You can use this command, for example, to calculate the clearance between a road surface and the bottom
of a bridge. Optionally, you can draw the line identifying the shortest distance location.
If the surfaces are flat and there is more than one location with the shortest distance, the output is represented
by a series of points, a line, or an area displayed as a closed polyline.
To identify the shortest distance between two surfaces
1 Click Analyze tab ➤ Ground Data panel ➤

➤ Minimum Distance Between Surfaces

.

2 In the drawing, select the first surface or press Enter to select it from the list.
3 Select the second surface or press Enter to select it from the list.
4 In the displayed prompt, select Y or N to specify whether you want to draw the marker line connecting
the two points that lay at the shortest distance from one another.

Quick Reference
Ribbon
Analyze tab ➤ Ground Data panel

Minimum Distance Between Surfaces

Command Line
MinimumDistBetweenSurfaces

Breakline Tools
Use the AutoCAD Civil 3D breakline tools to find, report, and correct intersecting breaklines in a survey
database or in a surface to which the breakline geometry has been added.
Breaklines are important elements in a digital terrain model (DTM). Any invalid conditions in breakline
geometry can cause issues in surface creation.
The following drawing shows an example of two crossing breaklines that create an invalid condition when
two elevations exist at the intersection point of the breaklines (1 and 2).
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The breakline tools enable you to:
■

Identify crossing breaklines in a survey database, survey figure, or a surface created from survey data. See
Finding and Fixing Crossing Breaklines (page 771).

■

Edit breakline elevations to resolve issues caused by crossing breaklines. See Finding and Fixing Crossing
Breaklines (page 771).

■

Create reports on crossing breaklines or breaklines that fall outside of specified ranges. See Creating
Breakline Reports (page 772).

Finding and Fixing Crossing Breaklines
Use the Crossing Breakline tool to identify and fix any intersecting breaklines in a drawing, survey figure,
or survey database.
To find and fix crossing breaklines
1 Click Analyze tab ➤ Ground Data ➤

Resolve Crossing Breaklines.

2 At the dynamic input prompt or at the command line, specify the location to look for crossing breaklines:
Survey Database, Figure, or Surface.
3 In the Crossing Breaklines vista (page 2625) that displays, view the list of intersecting breakline data, for
example:
Breakline 1

Breakline 2

Easting

Northing

Elevation Difference

Slopes

Dirt Road

2449329.6678’

6934649.2363’

-2.498'

Slopes

Gravel Road

2449426.7324 '

6934651.3785’

3.604'

4 To view the crossing breaklines in the drawing, click an item in the list and then click Zoom To.
NOTE If Auto Zoom is selected, the intersection point of the selected pair of breaklines is automatically
centered and zoomed to.
The breakline with lower elevation (1) appears in red. The blue color identifies the breakline with higher
elevation (2).

5 To fix breakline issues, do one of the following:
■

To resolve elevation differences of the crossing breaklines, under Crossing Resolution, specify the
elevation option (higher, lower, average, or new elevation) to use for each point of intersection in
each breakline pair.
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■

To resolve errors related to breakline length, click Trim and follow on-screen prompts to trim the
breakline segments.

6 Click

to close the Crossing Breaklines vista.

Quick Reference
Ribbon
Analyze tab ➤ Ground Data panel ➤ Resolve Crossing Breaklines
Command Line
BreaklineTool
Dialog Box
Crossing Breaklines vista (page 2625)

Creating Breakline Reports
Use the crossing breakline reporting tools to generate reports that can help you analyze and aggregate
breakline data and fix invalid conditions in the breaklines.
The reports are created in HTML format and are saved in a specified location. You can generate two types
of reports.
■

All intersecting breaklines in the current drawing. This report specifies the x- and y-coordinates of the
intersection points and the elevation difference at these points.

■

All surface breaklines, breaklines in a survey database, or survey figures that are outside of the specified
ranges.

To generate a crossing breakline report
1 In Toolspace, click Toolbox tab ➤ Reports Manager ➤ Breakline ➤ Crossing Breakline Report.
2 In the Create Reports - Crossing Breakline dialog box (page 2622), select Survey Databases, Survey Figures,
or Surfaces as the objects to analyze for crossing breaklines.
If the selected object exists in the drawing, survey database, or survey figure, the object is displayed in
the list.
3 Select the boxes in the Include column beside the objects that you want to have analyzed.
4 Optionally, click Check All to select or deselect all the entries in the list. Only the selected objects are
analyzed.
5 Under Report Settings, click

to specify the location for saving the report.

6 Click Create Report and wait until the report is generated and opens in a browser window.
7 View the information in the report and click Done.
To generate an invalid breakline conditions report
1 In Toolspace, click Toolbox tab ➤ Reports Manager ➤ Breakline ➤ Breakline Check.
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2 In the Create Reports - Breakline Check Report dialog box (page 2622), select Survey Databases, Survey
Figures, or Surfaces as the objects to analyze for the specified breakline conditions.
If the selected object exists in the drawing, survey database, or survey figure, the object is displayed in
the list.
3 Select the boxes in the Include column beside the objects that you want to have analyzed.
4 Optionally, click Check All to select or deselect all the entries in the list. Only the selected objects are
analyzed.
5 Under Report Settings, specify the query conditions for breaklines. See Create Reports - Breakline Check
Report dialog box (page 2622) for setting descriptions.
6 Click

to specify the location for saving the report.

7 Click Create Report and wait until the report is generated and opens in a browser window.
8 View the information in the report and click Done.

Quick Reference
Toolspace Shortcut Menu
Toolbox tab ➤ Reports Manager ➤ Breakline ➤ Breakline Check/Crossing Breakline Report
Dialog Boxes
Create Reports - Crossing Breakline (page 2622)
Create Reports - Breakline Check Report (page 2622)
Command Line
CrossingBreaklineReport

Exporting Surface Data
You can export an AutoCAD Civil 3D surface from a drawing to a DEM file compatible with either USGS or
GeoTIFF formats, enabling you to use the surface in applications that support these formats.

Exporting to DEM
You can export surface data to a DEM file and use the surface in other applications that support DEM data
files.
Applications such as AutoCAD MAP 3D and AutoCAD Raster Design support both USGS and GeoTIFF
standards. You can export all types of AutoCAD Civil 3D surfaces, including terrain and volume surfaces.
To export surface data to a DEM file
1 Open a drawing with surfaces that you want to export to DEM.
2 Select a surface. Click Surface tab ➤ Surface Tools panel ➤ Export To DEM

..

3 If more than one surface is available in the drawing, and you have not selected the surface in the
previous step, in the drawing, click the surface which you want to export.
4 In the Export Surface to DEM (page 2634) dialog box, under Export, add information on the exported
file, such as DEM file name, coordinate system, grid spacing, and elevation.
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5 Specify if you’d like to use the default null elevation or specify a custom value and enter the value.
6 Click OK.
The surface data is imported to a DEM file in the location that you specified.
The exported DEM file inherits the coordinate zone assigned to the drawing. If the drawing does not have
a coordinate zone assigned, you must specify one.

Quick Reference
Ribbon
Select a surface. Surface tab ➤ Surface Tools panel ➤ Export To DEM
Menu
Surfaces menu ➤ Utilities ➤ Export To DEM
Toolspace Shortcut Menu
Prospector tab: Surfaces ➤ right-click <surface-name> ➤ Export to DEM
Command
SurfaceExportToDem
Dialog Box
Export Surface to DEM (page 2634)

Exporting to LandXML
Export a TIN surface to a LandXML format file.
For more information about AutoCAD Civil 3D LandXML import and export functionality, see Viewing and
Editing LandXML Drawing Settings (page 1880).
To export a surface to a LandXML format file
1 In Toolspace, on the Prospector tab, expand the Surfaces collection, right-click the surface, and click
Export LandXML.
The Export LandXML (page 2219) dialog box is displayed with the current surface selected for export.
2 To change the export selection set (for example, to add another surface), select or clear the check boxes
in the data tree.
3 Click OK to export the surface to a LandXML format file.
4 In the Export LandXML dialog box, enter the name for the LandXML file.
The file is saved with the .xml extension.

Quick Reference
Toolspace Shortcut Menu
Prospector tab: Surfaces ➤ right-click <surface-name> ➤ Export LandXML
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Dialog Box
Export LandXML (page 2219)

Surfaces Command Reference
You can use commands to access surface functionality quickly.
The following table lists the surface-related AutoCAD Civil 3D commands and briefly describes their
functionality.
Command

Description

AddContourLabeling

Adds multiple surface contour labels at points of
intersection with contour label line (page 758)

AddContourLabelingGroup

Adds multiple surface contour labels at a set interval
(page 758)

AddContourLabelingSingle

Adds a single surface contour label (page 758)

AddSpotElevLabelsOnGrid

Adds a spot elevation label on grid (page 756)

AddSurfaceBoundaries

Adds a boundary to an existing surface (page 664)

AddSurfaceBreaklines

Adds a breakline to an existing surface (page 667)

AddSurfaceContours

Adds contours to an existing surface (page 681)

AddSurfaceDEMFile

Adds a DEM file to an existing surface (page 686)

AddSurfaceDrawingObjects

Adds points from AutoCAD objects (page 689)

AddSurfaceGridPoint

Adds a grid point to an existing surface (page 702)

AddSurfaceLabels

Invokes a labeling tool used to add slope elevations
or slope labels (page 754)

AddSurfaceLine

Adds a new TIN line to an existing surface (page
699)

AddSurfacePoint

Adds a point directly to the surface (page 702)

AddPointFile

Imports a point file into an existing surface (page
692)

AddSurfacePointGroup

Adds a point group to the surface definition (page
693)

AddSurfaceSlopeLabel

Adds a slope label to a surface (page 754)

AddSurfaceSpotElevLabel

Adds a spot elevation label to a surface (page 756)

BreaklineTool

Identifies and fixes any intersecting breaklines in a
drawing, survey figure, or survey database (page
770)
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Command

Description

CatchmentArea

Displays catchment regions and calculates the area
of catchment regions (page 768)

CheckForContourProblems

Identifies Problems with Contours (page 765)

CreateCropSurface

Creates a surface that is a copy of the selected
polygonal area of another surface (page 716)

CreateSurface

Creates a TIN or Grid terrain and volume surface
(page 648)

CreateSurfaceComposite

Calculates a composite volume between two surfaces (page 740)

CreateSurfaceGridFromDEM

Creates a grid surface from a DEM (Digital Elevation
Model) file. (page 656)

CreateSurfaceFromGIS

Imports data from a GIS datastore to create a Civil
3D surface (page 658)

CreateSurfaceFromTIN

Creates a TIN surface from a TIN data file (page 655)

CreateSurfaceReference

Creates a surface reference (page 656)

CreateSurfaceMask

Creates a mask on a surface (page 722)

CreateSurfaceStyle

Creates a new surface style (page 749)

CreateSurfaceWaterdrop

Creates a water drop path on the surface (page 767)

CreateSurfCntrLabelLine

Adds a contour label to a surface (page 758)

DeleteSurfaceGridPoint

Deletes a point from a grid surface (page 703)

DeleteSurfaceLine

Deletes a TIN line from a surface (page 700)

DeleteSurfacePoint

Deletes points from a TIN surface to remove inaccurate or unnecessary data (page 703)

DeleteSurfaceSlopeLabel

Deletes a slope label (page 762)

DrapeImage

Drapes an image onto a surface (page 750)

EditSurfacePaste

Pastes a surface into the current surface (page 711)

EditSurfacePoint

Modifies a surface point (page 703)

EditSurfaceProperties

Edits the properties of a surface (page 731)

EditSurfaceMask

Edits a surface mask (page 724)

EditSurfaceSettings

Displays the Edit Feature Settings - Surface dialog
box (page 737)
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Command

Description

EditSurfaceStyle

Edits the style of an existing surface (page 750)

EditSurfaceSwapEdge

Swaps the direction of two triangle faces (page 701)

MinimizeSurfaceFlatAreas

Minimizes the flat areas on a surface created from
contours (page 705)

MinimumDistBetweenSurfaces

Identifies the shortest vertical distance between two
surfaces. (page 770)

ModifySurfaceContourLabels

Modifies a contour label style (page 762)

ModifySurfaceSlopeLabel

Modifies a slope label style (page 762)

ModifySurfSpotElevLabel

Modifies a spot elevation label style (page 762)

MoveBlocksToAttribElev

Moves a block to an elevation value specified in one
of its nested attribute values (page 690)

MoveBlocksToSurface

Moves a block object to a surface elevation (page
694)

MoveTextToElevation

Moves text to the elevation corresponding to its
numeric value (page 691)

MoveSurfacePoint

Moves a surface point (page 704)

RaiseLowerSurface

Raises or lowers the entire surface (page 710)

RebuildSurface

Rebuilds a surface (page 735)

ReportSurfaceVolume

Displays composite volume information for two
surfaces (page 740)

ReportSurfBoundedVolume

Calculates the volume of a bounded area (page 742)

SimplifySurface

Simplifies a surface by removing points (page 715)

SmoothSurface

Smooths the surface (page 711)

StageStorage

Calculates incremental and cumulative volumes of
a basin from a surface, using either a surface or
polylines to define the basin (page 744)

SurfaceModifyGridPoint

Modifies grid surface points (page 703)

SurfaceExportToDem

Exports surface data to a DEM file (page 773)

SurfaceExtractObjects

Extracts selected components from a surface (page
695)
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Sites

In AutoCAD Civil 3D, you can manage objects with a common topology in a collection called a site. The objects that
share in the topology are parcels, alignments, gradings, and feature lines.

Understanding Sites
Use sites to collect or group collections (parcels, alignments, gradings, and feature lines) by a topology that
they have in common.
Examples of sites include soil maps, watersheds, or subdivisions. Sites can geographically overlay each other
as is shown in the following illustration, while remaining independent. For example, a soils map and a
subdivision with roads and lots can overlay each other, but remain independent of each other. Therefore,
a parcel in a soils site would never be affected by an alignment in a subdivision site, even if their extents
overlap.

All objects in a site topology collection share a common topology and have relationships to each other.
NOTE Editing an object, or moving an object from one site to another, can cause changes to other objects that
share the same topology.
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When you create parcels and gradings, you specify a site for them. If you create these objects before explicitly
creating a site, a default site named Site 1 is created for them.
When you create an alignment, you may either accept the default <none> site selection, place the alignment
on an existing site, or create a new site. When an alignment is placed on a site, it will create parcels if it
forms closed regions and subdivide existing parcels on the site if it crosses through them. Accepting the
<none> site selection places the alignment in the top-level Alignments collection, which prevents it from
forming or interacting with parcels or any other objects. See Alignment and Site Interaction (page 781) for
more information.
NOTE An object, such as an alignment, parcel, or grading, can only exist in one site. All dependent objects, such
as profiles and sections, exist in the same site as the parent object.

Sites Collection
Use the Prospector tree to access the Sites collection, which can contain one or more site topology collections.
Each site topology collection contains collections for alignments, gradings and parcels:

NOTE You can assign names to the site topology collections, but the Sites collection cannot be renamed.
Alignments may be assigned to either the Alignments collection within a topology collection or the top-level
Alignments collection. When placed in the topology collection’s Alignment collection, an alignment
subdivides parcels it crosses over and creates new parcels if it forms closed regions. Alignments that are
placed in the top-level Alignments collection do not interact with parcels or any other objects on any site.
See Alignment and Site Interaction (page 781) for more information.
Expand the Sites collection node to view the sites in the collection. The site names with their respective area
and perimeter values are displayed in the Prospector tab list view.
Access all site-related functionality by right-clicking the Sites collection and the named site topology collection
(for example, Site 1 or Site 2) in the Prospector tree.
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Site Topology Collection
Use the named site topology collection (for example, Site 1) under Sites in the Prospector tree to edit or list
the properties of a particular site, including its name, description, and 3D geometry.
Each named site topology collection contains collections of alignments, gradings, and parcels.
Right-click the named site topology collection to:
■

Edit and display the properties of the site, including 3D geometry and numbering conventions.

NOTE Parcel-related properties of a site are accessible from the site’s Parcels collection. For more information, see
Site Parcels (page 875).
■

Zoom or pan to the site.

■

Report on the site

■

Export the site to a LandXML format file.

■

Refresh the Prospector tree.

Alignment and Site Interaction
When alignments are placed on a site, they will interact with other objects on the site.
Alignments interact with sites in two ways:
■

If an alignment exists on a site with parcels, the alignment will subdivide any parcels it crosses over.

■

If one or more alignments on a site form a closed region, a parcel will be created from the region.

Alignments may be assigned to either of two collections:
■

The top-level Alignments collection. When placed in this collection, an alignment will not interact with
any other objects, including itself.

■

The Alignments collection within a topology collection, or site. When placed here, alignments will
interact with other alignments and parcels on the site. If you want alignments to form parcels by closed
regions but not subdivide existing parcels, assign alignments and parcels to separate sites.
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If you do not want an alignment to interact with other objects, accept the default <None> site selection
when you create the alignment. Alignments can be moved or copied onto sites at a later time if interaction
with other objects is desired.

Importing from and Exporting to LandXML
You can import from and export to LandXML files.
When objects that are grouped under the Sites collection are exported to a LandXML file, the site name is
exported with them.
When objects are imported from a LandXML file into the drawing, two site pickers are displayed:
■

Alignments Site allows you to specify the site on which the alignments will reside. The default selection
is <None>, which places the alignments in the top-level Alignments collection and prevents them from
interacting with parcels.
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■

Parcels Site allows you to specify the site on which the parcels will reside. If no sites exist in the drawing,
the parcels are placed on the default site (Site 1). If the LandXML file has a site name for its features, then
that site name is created in the drawing and the parcels are assigned to it.

For more information about importing to and exporting from a LandXML file, see LandXML Import and
Export (page 1875).

Managing Sites
After you create a site, you can edit its properties and add objects to it.
Before working with sites, you should review the following aspects of site functionality:
■

Sites can be copied or moved. If there is a naming conflict at the destination site, the site name is
automatically appended with the next sequential number.

■

Objects can be copied or moved between sites. If there is a naming conflict at the destination site, the
object name is automatically appended. For example, if the identical "Parcel A" object is copied three
times into the same site, the name conflict is resolved as Parcel A (1), Parcel A (2), and Parcel A (3).

■

Parcel linework, grading objects, and alignments can only belong to one unique site and do not interact
with objects in a different site.

■

Sites can only be deleted after all objects have been deleted from the site.

Creating a Site
Use the Prospector tree to create a new site. You can create a site before creating the site topology (alignments,
parcels, and grading).
NOTE When creating parcels and gradings, you must specify a site for them. You can create a new site when
creating these objects. If you do not specify a site, a default site (Site 1) is created for them. You can rename the
site using the Site Properties (page 784) dialog box.
To create a site
1 In Toolspace, on the Prospector tab, right-click the Sites

collection and click New.

The Site Properties (page 2597) dialog box is displayed with the Information tab active.
2 Enter a name and description for the site in the corresponding fields.
3 Click the 3D Geometry (page 2597) tab and specify the 3D display settings for the site.
4 Click the Numbering (page 2598)tab and specify the numbering properties for alignments and parcels.
5 Click OK.
The site is added to the Sites collection in the Prospector tree.

Quick Reference
Toolspace Shortcut Menu
Prospector tab: right-click Sites ➤ New
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Command Line
CreateSite
Dialog Box
Site Properties (page 2597)

Editing Site Properties
A site has two types of properties: those that deal with the general site and those that are associated with
the site but are primarily related to the parcel objects.

General Site Properties
General site properties are applicable to all objects in a site. These properties include the site name, site
description, 3D geometry display settings, and parcel and alignment numbering.
Access these properties by right-clicking the named site collection node (for example, Site 1) in the Prospector
tree.

Site Parcel Properties
Certain site properties are specific to the Parcels collection within a site. These properties include site parcel
style, site area label style, parcel style display order, area, perimeter, and frontage.
Access these properties by right-clicking the Parcels collection under the named site collection.

784 | Chapter 21 Sites

NOTE For information about editing Site Parcel properties, see Site Parcels (page 875).
To edit site properties
1 In Toolspace, on the Prospector tab, expand the Sites collection, right-click a site, and click Properties.
2 Optionally, on the Information (page 2597) tab, edit the name and description for the site.
3 Optionally, click the 3D Geometry (page 2597) tab and edit the 3D display settings for the site.
4 Optionally, click the Numbering (page 2598) tab and edit the numbering properties for the parcel
components.
5 Click OK.

Quick Reference
Toolspace Shortcut Menu
Prospector tab: Sites ➤ right-click <site-name> ➤ Properties
Command Line
EditSite
Dialog Box
Site Properties (page 2597)

Specifying a Site for Topology Objects
When you create a parcel, alignment, or grading object, you are prompted to specify a site name.
Use the same site for all objects that share a common topology and have specific relationships to each other.
NOTE Editing an object could cause changes to other objects that share the same topology.
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To specify a site for topology objects
1 Follow the specific procedure to create the object requiring a site (for example, parcel, alignment or
grading object).
2 When the Create dialog box for the object is displayed, do one of the following:
■

Click the Site list and select the site to which you want to add the object.
When creating an alignment, select <None> to assign the alignment to the top-level Alignments
collection. See Alignment and Site Interaction (page 781) for more information.

■

Click the Down arrow next to the Site list and click Pick From Drawing.
The following prompt is displayed:
Select object in site:

Select an object (parcel, alignment, or grading object) contained in the site to which you want to
add the new object.
■

Click the Down arrow next to the Site list and click Create New, then use the Site Properties (page
2597) dialog box to define the new site and click OK.

3 Perform the remaining object creation steps.

Deleting a Site
Use the Prospector tree to delete a site. You must first delete all the objects that are contained in the site.
To delete a site
1 Delete any objects that are included in the site.
2 In Toolspace, on the Prospector tab, expand the Sites collection, right-click a site, and click Delete.
The site is removed from the Prospector tree.

Quick Reference
Toolspace Shortcut Menu
Prospector tab: Sites ➤ right-click <site-name> ➤ Delete

Finding and Resolving Overlapping Site Objects
Use the FindSiteOverlaps command to locate overlapping (collinear) objects in the same site that could be
causing problems with your drawing.
When creating site objects (alignments, gradings, feature lines, or parcels), you may end up with collinear
segments. In most cases, this will not create a problem. However, in some cases, AutoCAD Civil 3D may
close unexpectedly because of these overlapping segments.
If the FindSiteOverlaps command detects collinear segments, the command will recommend the usage of a
subsequent command to resolve them. The FindSiteOverlaps command does not, however, diagnose exactly
what may be causing a particular problem and the recommended commands may not resolve every possible
issue you may encounter.
IMPORTANT Anytime you experience problems with a drawing, you should use the RECOVER and AUDIT
commands first before using the FindSiteOverlaps command.
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To identify collinear site objects
1 At the Command line, enter FindSiteOverlaps.
2 Press F2 to display the text window.
3 Review the command results. For example, you may see results as follows if you have overlapping feature
lines in your drawing:
Checking Alignments
Checking Lot Lines
Checking Feature Lines
2 overlapping segments found
This command will move these to their own new site: RemoveDupFeatureLines
Checking Gradings and Attached Lot Lines
2 overlapping segments found
Can only be moved with Move To Site
AutoCAD points on layer _OVERLAPPING_SEGMENT_LOCATIONS indicate location of overlapping
segments.

4 An AutoCAD point is placed in the center of each overlapping segment. If needed, use the DDPTYPE
command to change the AutoCAD point style to better see the point nodes. Or use the LAYER command
to isolate the _OVERLAPPING_SEGMENT_LOCATIONS layer.
Overlapping feature lines with an AutoCAD point marking the center of the collinear segment

5 Use one or more of the following recommended commands to resolve the overlapping segments:
■

RemoveDupFeatureLines (page 788)

■

RemoveAlignmentsFromSite (page 789)

■

RemoveDupLotLines (page 788)

■

MoveToSite (page 790)
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NOTE
If the FindSiteOverlaps command recommends removing more than one type of object from the site, it is
recommended to use the following order:
■

Remove feature lines first.
This option removes only those feature lines that do not have grading criteria applied to them.
Often these types of feature lines are only being used as surface breaklines, so there is less impact if
they are moved out of the site.
Since overlaps are often between different kinds of objects, removing only the feature lines may
resolve the problem.
Alignments and lot lines may form parcels within the site, so removing them may have greater
impact than removing feature lines.

■

Remove alignments second (if needed).

■

Remove lot lines third (if needed).

6 Erase the AutoCAD points that were created and run the FindSiteOverlaps command again to see if any
overlaps remain.
NOTE If, after removing any overlaps that can be found, there are overlaps reported for gradings, it may be
possible to edit the gradings slightly so that they no longer overlap.
7 Use the AUDIT command to detect and resolve any remaining issues with your drawing.
To remove overlapping feature lines
This command moves each overlapping feature line to its own individual site, with the site names Overlap
1, Overlap 2, and so on. For example, if there are two features lines in Site 1 that overlap, they are both
removed from Site 1. One of the feature lines will be moved to Overlap 1, and the other will be moved to
Overlap 2.
This command will not remove feature lines that use grading criteria. Feature lines created from survey data
are included only if they are part of a named site.
WARNING This command cannot be undone. Save a copy of your drawing before using it.
1 Run the FindSiteOverlaps (page 787)command to diagnose the issue.
2 If overlapping feature lines are found, then at the Command line, enter RemoveDupFeatureLines.
To remove overlapping lot lines
This command moves each overlapping lot line to its own individual site, with the names Overlap 1, Overlap
2, and so on. It operates on the linework, not the parcels themselves, so removing some of the parcel linework
to its own site may either create new parcels or remove existing parcels (a similar effect to moving the lines
with the Move To Site command).
WARNING This command cannot be undone. Save a copy of your drawing before using it.
1 Run the FindSiteOverlaps (page 787) command to diagnose the issue.
2 If overlapping lot lines are found, then at the Command line, enter RemoveDupLotLines.
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To remove alignments from a site
This command moves all alignments in a selected site to the Alignments collection in Prospector. The
alignments will no longer be part of the site, but their names will be maintained.
WARNING This command removes all alignments from the site, not just those with overlapping segments. It is
the equivalent of using the Move To Site command and selecting the <None> site.
1 Run the FindSiteOverlaps (page 787)command to diagnose the issue.
2 If overlapping alignments are found, then at the Command line, enter RemoveAlignmentsFromSite.
3 Select the site from which you want to remove the alignments and click OK.

Quick Reference
Command Line
FindSiteOverlaps
RemoveDupFeatureLines
RemoveDupLotLines
RemoveAlignmentsFromSite

Moving and Copying Site Objects
You can move or copy site objects from one site to another. The contents of an entire site, including
alignments, grading groups, or parcels, can be moved or copied together or individually.
NOTE If there is a naming conflict, duplicate objects should be deleted from the destination site prior to moving
or copying sites or objects within a site. If duplicates objects occur, the names are automatically resolved. For
example, if the destination site contains an Alignment - (1), it is renamed to Alignment - (1) (1).
See also:
■

Finding and Resolving Overlapping Site Objects (page 786)

Move Objects to a Site
Move site objects (alignments, gradings, and parcels) to a destination site, removing them from the source
site.
Objects in the same site can interact with each other. To prevent this interaction, move one or more objects
to another site.
Multiple sites can exist in the same geographic location.
Objects to move can be accessed from the Prospector tab for entire site collections or individual objects
within the collection. A shortcut menu is also available from the drawing for valid objects within a site.
See also:
■

To remove overlapping feature lines (page 788)

■

To remove overlapping lot lines (page 788)

■

To remove alignments from a site (page 789)
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To move objects to a site
1 In Toolspace, on the Prospector tab, expand Sites.
2 Right-click a site, or collections or individual objects within the site, and click Move To Site.
3 In the Move To Site dialog box, under Destination Site, select an existing site from the list, or click
to either pick a site in the drawing or create a new site.
When moving only alignments, select <None> to move the alignments to the top-level Alignments
collection. See Alignment and Site Interaction (page 781) for more information.
4 Navigate in the data tree to view the selected objects and expand the collections. Select or clear the
check boxes to filter the objects that you want to move.
5 Click OK. The selected objects are moved to the destination site. The original source site objects are
removed.

Quick Reference
Ribbon
Select the object. Click Modify panel

Move To Site

Toolspace Shortcut Menu
Prospector: Right-click object or object collection (Site, Alignment, Parcel, or Grading) ➤ Move To Site
Object Shortcut Menu
Drawing: Right-click object (Site, Alignment, Parcel, or Grading) object ➤ Move To Site
Command Line
MoveToSite
Dialog Box
Move To Site (page 2599)

Copy Objects to a Site
Copy site objects (alignments, gradings, and parcels) to a destination site, while keeping the original objects
at the source site.
Objects in the same site can interact with each other. Edits made to one object can affect other objects in
the site.
Objects to copy can be accessed from the Prospector tab for entire site collections or individual objects within
the collection. A shortcut menu is also available from the drawing for valid objects within a site.
To copy objects to a site
1 In Toolspace, on the Prospector tab, expand Sites.
2 Right-click a site, or collections or individual objects within the site, and click Copy To Site.
3 In the Copy To Site dialog box, under Destination Site, select an existing site from the list, or click
to either pick a site in the drawing or create a new site, which is then returned and displayed in the list.
When copying only alignments, select <None> to copy the alignments to the top-level Alignments
collection. See Alignment and Site Interaction (page 781) for more information.
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4 Navigate the data tree to view the selected subcomponents and expand the collections. Select or clear
the check boxes to filter the objects that you want to copy.
5 Click OK. The selected objects are copied to the destination site. The original site objects remain in the
source.

Quick Reference
Ribbon
Select the object. Click Modify panel

Copy To Site

.

Toolspace Shortcut Menu
Prospector: Right-click (Site, Alignment, Parcel, or Grading) ➤ Copy To Site
Object Shortcut Menu
Drawing: Right-click (Site, Alignment, Parcel, or Grading) object ➤ Copy To Site
Command Line
CopyToSite
Dialog Box
Copy To Site (page 2600)

Sites Command Reference
The following table lists the site-related AutoCAD Civil 3D commands and briefly describes their functionality.
For more information about a command, follow the link in the Description column.
Command

Description

CreateSite

Creates a site (page 783)

EditSite

Edits the properties of a site (page 784)

MoveToSite

Moves selected objects to another site (page 789)

CopyToSite

Copies selected objects to another site (page 790)

FindSiteOverlaps

Identifies overlapping (collinear) site objects (page
786)

RemoveDupFeatureLines

Moves feature lines that have collinear segments to
their own sites (page 788)

RemoveDupLotLines

Moves lot lines that have collinear segments to their
own sites (page 788)

RemoveAlignmentsFromSite

Removes all alignments from a specified site (page
789)
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Use the grading tools and commands in AutoCAD Civil 3D to design finished ground surfaces.
You create grading projections by applying grading criteria (page 2775) to a footprint. The grading objects are grouped into
named collections to create your final surface designs and compute volumes.
You can also use the feature lines commands to create and edit 3D feature lines. Feature lines can be included directly
into surfaces as breakline data, or you can use them as grading object footprints.
Grading Workflow (page 37)

Understanding Gradings
A grading object has its own properties and behavior, like other object types in AutoCAD Civil 3D.
A grading normally consists of a face bounded by a base line, a target line, and several projection lines. The
base line can be any open or closed figure from which you want to project the grading. It can be a feature
line or a lot line. A feature line is any linear feature in the drawing, such as a ridge line, building footprint,
or the bottom of a swale. The target for the grading can be a surface, a distance, or an elevation (absolute
or relative).
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Line components of a grading object

Before you start grading, you must configure settings and establish criteria such as the following:
■

Grading site: Gradings are created in a site topology. If you do not want a grading to interact with other
objects in a site, create a new site for your grading objects.

■

Grading group: Grading objects in a grading group (page 2775) are consolidated to create one grading
group surface so you can compute volumes. Before you create gradings, decide how you want to manage
them with regard to surface creation and volume computations.
After you create a grading group, volume tools within AutoCAD Civil 3D show you the amount of cut
and fill required for the grading design. You can raise or lower the grading group incrementally to adjust
volume requirements. You can also change the elevation of points along a grading base line, change the
grade of a base line, or modify the grading criteria.

Grading criteria specifies the grading method
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■

Grading footprints: Grading objects are projected toward their target from a selected footprint. Footprints
can be feature lines that you create specifically for this purpose, or you can export corridor feature lines
or use parcel lot lines.

■

Grading targets: Grading objects require a target. This can be a surface, a distance, or an elevation.

surface as target

daylight

footprint

Section view of surface as target

fixed elevation as target

footprint

daylight
specified elevation

Section view of elevation as target

relative elevation as target

footprint

relative elevation
daylight

Section view of relative elevation as target
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horizontal distance as target

footprint
daylight

Section view of distance as target

■

Grading criteria: When you start grading, you specify grading criteria (page 2775). This is how many of the
grading settings, such as grading target, are specified.

The list of grading objects defined in the drawing appears in Toolspace, within the Sites collection on the
Prospector tab.
Grading styles (page 802) and Grading Criteria Sets appear in Toolspace on the Settings tab.

Parts of a Grading Object
A grading object normally consists of the footprint, the daylight line, the projection lines, and the face.
The face is the area bounded by the lines that define the grading. It is marked with a center marker (page
2770).
Plan view of grading object

footprint
center marker

projection line

daylight line

The footprint can be an open or closed figure. The footprint must be either a feature line (page 2774), a lot line,
or the resulting daylight line (page 2772) of another grading.
A feature line is a line that represents some important feature in the drawing, such as a ridge line or the
bottom of a swale. A feature line can be drawn with the Draw Feature Line command, or created from 2D
and 3D polylines, lines, and arcs. You can also export feature lines from corridor models.
The target for the grading can be a surface, a distance, an elevation, or a relative elevation.

Grading Regions
You define grading regions where a grading object requires different criteria along different parts of the
footprint.
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Where you need regions, you apply the criteria to only part of the footprint rather than the entire footprint.
For example, you might have a grading region with a slope of 3:1, and another region with a slope of 2:1,
separated by a transition region, in which the grading merges from 3:1 to 2:1. Regions to which criteria have
been applied are called control regions.
You are prompted to create a transition region if you specify the start point of a grading region to begin
within an existing grading on the same footprint. You can also insert transition regions by using the Grading
Creation Tools.

Grading and Surfaces
Grading groups can be automatically turned into surfaces that dynamically update when you edit the grading.
You can also create a detached surface from a grading group, which is no longer associated with the gradings
and does not update when you edit the grading.
You can specify the Automatic Surface Creation setting when you create the grading group (page 806), or
you can create the surface later by changing the Grading Group Properties (page 864). When you create an
automatic (or dynamic) surface, the surface is displayed in the Surfaces collection in the Prospector tree. For
dynamic surfaces, the surface properties show that it was created from a grading group.

Editing Dynamic and Detached Surfaces
Dynamic surfaces created from grading groups are updated when you edit the grading object. If you turn
on Rebuild Automatic in the Surface menu the surface updates as soon as you make the edit. You can also
use the surface edit tools to refine the surface, such as adding spot elevations.
Detached surfaces created from grading groups are not updated when the grading object is edited.
You can edit both dynamic and detached surfaces like any other surface.

Pasting Grading Surfaces
Both dynamic and detached surfaces can be pasted into other surfaces, except for the grading's target surface.
By pasting a dynamic surface, any changes you make to the grading group will be reflected in the final
surface.
TIP To paste a dynamic grading surface into another surface (the “destination surface”), you must select the Paste
command from the destination surface node in the Prospector tree.
You cannot paste the grading surface into the surface that you are using as the target surface. This is disallowed
because of the dynamic relationship between the gradings and the target surface. To accomplish this task
you should create a copy of the target surface and paste the grading surface into the copy.

Surface Breaklines and Tessellation Settings
When you create a surface from a grading group, the grading group faces are included as breaklines. The
perimeter is included as a boundary.
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The surface is built by adding extra breaklines between the footprint and daylight line for better surface
definition. These extra breaklines are controlled by the tessellation settings, which you specify for each
grading group. Tessellation parameters control the triangulation of surface (for both dynamic and detached
surfaces) generated from the grading group.
Tessellation spacing represents the distance between the breaklines along the footprint segments. Tessellation
angle represents the angular spacing of breaklines around corners.

Finer values of spacing lead to a more accurate representation of the grading model, but increase the
computation time. These values should be set according to the size of grading object in consideration.

Calculating Volumes
To use the Grading Volume Tools, a dynamic surface must exist for the grading group and a Volume Base
Surface must be specified in the Grading Group Properties. You can also use the surface volume commands
to compute volumes between dynamic or detached surfaces and any other surface.

Using Feature Lines as Surface Data
You can include feature lines as breakline data in a surface. Many of the feature line editing commands (page
816) also work on 3D polylines, parcel lines, and survey figures, giving you a wide variety of options for
configuring the 3D data to include in finished ground surfaces.
If the Rebuild - Automatic setting for the surface is enabled, and you edit the feature line, parcel line, or
polyline that is used as breakline data, the surface is rebuilt as soon as you make an edit.

Feature Lines Collection (Prospector Tab)
Use the Feature Lines collection in the Prospector tree to manage feature line styles and layers. You can also
view feature line information, such as length, elevation, and grade.
In Toolspace, on the Prospector tab, select the Feature Lines collection to display a list box of all the feature
lines in the site. You can edit only the feature line style or layer values. Information such as length, elevation,
and grade is read-only.

A black dot glyph indicates a feature line in the site. To edit the feature line style, expand the Site collection,
right-click Feature Lines and select Properties. In the dialog box, set the feature line style priority on the
Options tab (page 2137). If no feature lines have been created in the site, you can set the feature line style
priority to determine the precedence for assigning elevations when feature line segments intersect. Then,
when feature lines are created and points intersect, the elevations will be determined accordingly. You can
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also set the default feature line style priority, using the command settings for Create Site. If feature lines
exist in the site, you can also use the Properties command to view statistics about the feature lines.
Icons indicate the state of the feature line.

indicates a feature line with no dynamic links.

indicates

a feature line with a dynamic alignment link.
indicates a feature line with a dynamic corridor link. For
more information, see Creating Feature Lines (page 808).
These feature line icons display a small green square in the lower corner if the feature line is in use as a
surface breakline
. You can find the name of the surfaces by listing or viewing the properties of individual
feature lines. For more information, see Adding a Feature Line to a Surface as a Breakline (page 851).
You can edit a feature line Style or Layer value by clicking the cell to open a style or layer dialog box. To
edit multiple values, use Ctrl+left-click to select multiple rows. Then right-click the column heading and
click Edit to open a Select Style or Layer Selection dialog box. For more information about the AutoCAD
Civil 3D list view, see The Toolspace Item View (page 99).
Right-click the Feature Lines collection to do the following:
■

View properties for the site feature lines and to resolve split point elevations by specifying style priority
(page 866).

■

Apply feature line names (page 811).

■

Apply feature line styles (page 811). If the feature line does not have a style set, the context menu Edit
Feature Line Style option is disabled. The style can be set in the Feature Line Properties dialog box.

■

Remove dynamic links to alignments (page 812). If there is no feature line dynamic link, the Remove
Dynamic Links command is unavailable.

■

Raise or lower feature line elevations (page 829).

■

Add a feature line to a surface as a breakline (page 851).

■

Move all of the feature lines from this site to another.

■

Copy all of the feature lines in a site to another site.

■

Select all site feature lines (page 812).

■

Select all site grading groups (page 813).

■

Zoom to the site feature lines.

■

Pan to the site feature lines.

■

Refresh the view of the feature lines in the Prospector tree.

For more information, see The Toolspace Item View (page 99).
For more information
about ...

Follow this link ...

Feature Line Creation
Methods

Creating Feature Lines
(page 808)

Editing Feature Line
Methods

Editing Feature Lines
(page 816)
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Grading Groups Collection (Prospector Tab)
As you create each grading group (page 2775) , they are displayed in the Grading Groups collection on the
Prospector tab in Toolspace.
Right-click an individual grading group in the Grading Groups collection to do the following:
■

View properties for the grading group (page 864).

■

Delete the selected grading group.

■

Zoom to the extents of the grading group.

■

Pan to the site grading groups.

■

Select all gradings in the grading group (page 813).

■

Refresh the view of the grading group in the Prospector tree.

Expand the Grading Groups collection to view the names of the grading groups and to display a tabular list
of the grading groups at the bottom of the Prospector tab. For more information, see The Toolspace Item
View (page 99).
For more information
about ...

Follow this link ...

Grading Groups

Using Grading Groups
(page 806)

Grading Creation Methods

Creating Grading (page
855)

Grading Editing Methods

Editing Grading (page
858)

Grading Collection (Settings Tab)
Use the Grading collection in the Settings tree to manage grading settings, grading styles, grading criteria
sets, and grading command settings.
Right-click the Grading collection to do the following:
■

Edit the grading feature settings. (page 801)

■

Refresh the display of the Settings tree.

Expand the Grading collection to display and edit grading styles (including center markers and slope patterns),
criteria sets, and command settings that are available for grading.
For more information about ...

See ...

Grading Styles

Using Grading Styles (page 802)

Grading Criteria Sets

Using Grading Criteria (page 804)

Commands

Grading Command Reference (page 869)
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Changing Grading Settings
Specify settings for all Grading commands with the Grading Feature Settings. Specify settings for specific
Grading commands and override feature settings with the Grading Command Settings.

Changing Grading Feature Settings
You can use the Grading Settings dialog box to change settings related to grading.
The settings you define in this dialog box override any ambient settings (page 2078) that have been established
for the drawing as a whole. The General setting Save Command Changes To Settings is typically set to No.
If you change it to Yes, then each time you run an affected command, the values you specify are saved as
defaults for the next time you run the command.
To change the grading feature settings
1 In Toolspace, on the Settings tab, right-click Grading ➤ Edit Feature Settings.
2 In the Edit Settings (page 2097) dialog box, change the existing settings.
3 Click OK to save the changed settings in the drawing.

Quick Reference
Toolspace Shortcut Menu
Settings tab: Right-click Grading collection ➤ Edit Feature Settings
Dialog Box
Grading Settings (page 2097)

Changing Grading Command Settings
You can change the prompted values for a specific command, such as CreateGrading.
TIP The General feature setting Save Command Changes To Settings is typically set to No. If you change it to
Yes, then each time you run an affected command, the values you specify are saved as defaults for the next time
you run the command. This setting affects the grading criteria and styles in the Grading Creation Tools (page 2114)
dialog box as well as the grading commands.
To change default values for grading commands
1 In Toolspace, on the Settings tab, expand Grading.
2 Expand the Commands collection and right-click a command name such as CreateGrading. Click Edit
Command Settings.
3 In the Edit Settings (page 2097) dialog box, expand the command-specific property, such as Grading
Creation, and edit the values.
4 Click OK.
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Quick Reference
Toolspace Shortcut Menu
Settings tab: Expand Grading collection ➤ Commands ➤ right-click command name ➤ Edit Command
Settings
Dialog Box
Grading Settings (page 2097)

Using Grading Styles
You can use grading styles to control the display of each grading component.
Create styles to use for different types of gradings and for the various phases of your project. Create a style
to use specifically in the design phase which shows lines, patterns and other grading subcomponents.
A style you use for plotting may show only the final grading geometry.
Grading styles are located on the Toolspace Settings tab. Slope pattern styles are located in the Multipurpose
Styles collection because they are used for corridor objects as well as for gradings.

Creating Grading Styles
Use the Grading Style dialog box to control the grading appearance.
Use the Slope Pattern Style (page 2123) dialog box to create different styles of slope patterns, which are referenced
by grading styles.
You can create and save an unlimited number of grading styles. After you save the styles, they are located
in the Grading Styles collection on the Toolspace Settings tab.
To create a new grading style
1 In Toolspace, on the Settings tab, right-click Grading Styles ➤ New.
2 In the Grading Style dialog box, click the Information tab (page 2116) and enter a name and optional
description for the grading style.
3 To define the size of the center marker for a grading, click the Center Marker tab (page 2117).
4 To define the slope pattern for a grading, click the Slope Pattern tab (page 2117).
5 To define the display properties for the grading style, click the Display tab (page 2017) and select the
display properties.
6 To view summary information about the style, click the Summary tab (page 2020).
7 Click OK to save the new style.
To create a new slope pattern style
1 In Toolspace, on the Settings tab, expand Multipurpose Styles ➤ Slope Pattern Styles.
2 Select Standard or another existing style that is similar to what you want. Right-click and click Copy.
The Slope Pattern Style dialog box is displayed.
3 On the Information tab (page 2123), enter a name and optional description for the new style.
4 On the Layout tab (page 2124), edit parameter values for each component of the slope pattern and add
or delete components as required.
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5 Click OK to save the new style.

Quick Reference
Toolspace Shortcut Menu
Settings tab: Right-click Grading Styles collection ➤ New
Settings tab: Multipurpose Styles collection ➤ Slope Pattern Styles ➤ Right-click <Style> item ➤ Copy
Dialog Boxes
Grading Style Dialog Box (page 2116)
Slope Pattern Style Dialog Box (page 2123)

Setting the Current Grading Style
Specify a grading style to apply to each grading you create.
If you want the Grading Creation Tools dialog box (page 2114) to continually retain the style you last entered,
in Toolspace, on the Settings tab, right-click Grading, select Edit Feature Settings, and specify Yes for the
General setting Save Command Changes To Settings.
See also:
■

Changing Grading Command Settings (page 801)

To specify a grading style
1 Click Home tab ➤ Create Design panel ➤ Grading drop-down ➤ Grading Creation Tools
2 In the Grading Creation Tools (page 2114), click

.

to view the current criteria and the style.

3 Select the grading style that you want to apply from the list of all the styles defined in the drawing.
When grading to a surface or elevation, there can be two style types, one for cut slopes and one for fill
slopes.
4 Create the grading.
The grading style is applied to the grading and to any grading you create until you change the style by
making another selection from the Grading Creation Tools.

Editing Grading Styles
Use the Settings tree to edit existing styles, copy existing styles to create new ones, or delete styles.
To edit, copy, or delete a grading style
1 In Toolspace, on the Settings tab, expand the Grading collection. Expand the Grading Styles collection.
2 Right-click a grading style. Click Edit, Copy, or Delete.
If you are copying a style, use the Information tab in the Grading Style (page 2116) dialog box to change
the name of the style before saving the style. The style appears in the Grading Styles collection with
the new name.
You cannot delete a style that is currently applied to an object. First assign another style to the object
and then delete the style.
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Quick Reference
Ribbon
Select the grading. Click Grading tab ➤ Modify panel ➤ Grading Properties drop-down ➤
Style

Edit Grading

Toolspace Shortcut Menu
Settings tab: Right-click Grading Style item ➤ Edit
Settings tab: Right-click Grading Style item ➤ Copy
Settings tab: Right-click Grading Style item ➤ Delete
Dialog Box
Grading Styles (page 2116)

Using Grading Criteria
You can create grading criteria, or parameters, to define how grading is created from the footprint, and apply
the criteria to other gradings.
There are many standard grading situations. For example, you may frequently need to create grading with
a slope of 3:1 and a target of a relative elevation. By defining a set of grading criteria with these values and
saving it, you can easily apply these same values to any grading that you create.

Creating Grading Criteria
Grading criteria are settings that specify the grading method. The settings are consolidated in named criteria
to eliminate repetitive prompting when you are creating gradings.
The grading method settings include the following:
■

Target. Choices include surface, elevation, relative elevation, or distance.

■

Projection type. Choices include cut/fill slope, cut slope, fill slope, and distance.

■

Interior corner overlap resolution. Choices include averaging the slopes and increasing or decreasing
one of the slopes. For more information and illustrations of the options, see Criteria Tab (Grading Criteria
Dialog Box) (page 2105).

■

Associated values. Depending on the target and projection type, you can specify default elevations,
distances, and cut/fill slopes to use.

Organize and access the criteria in the Settings tree, using the Grading Criteria Sets folders.
When setting up new criteria, it is recommended you use a descriptive naming convention. For example,
the standard AutoCAD Civil 3D drawing templates include several different criteria with names like “Surface
@ 2-1 Slope.” By using a clear naming convention, you do not need to review the criteria properties to know
how it was defined.

About Criteria Locking
Click the icon to lock or unlock a criteria value. This criteria locking affects the prompts you receive and
the values you can enter when creating or editing grading.
Lock criteria values to prevent them from being changed when you create or edit gradings.
For example, consider the different lock conditions for a criteria that is defined to grade at a slope of 3:1 to
a relative elevation of 1.50:
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Both values are unlocked
■

When creating a grading, you are prompted for both values. The prompts default to 3:1 and 1.50, but
can be changed.

■

Either value can be edited.

■

If the criteria definition is edited to change either value, it affects only the default prompt value for
grading creation; existing grading objects do not change.

■

If the criteria definition is edited and one of the values is changed from unlocked to locked, that locked
value is applied to all gradings that use the criteria.

Slope value is locked, relative elevation is unlocked
■

When creating grading, you are prompted only for the relative elevation value. Grading objects that use
this criteria always have a 3:1 slope.

■

If the criteria definition is edited to change the locked slope value to 2:1, the change applies to all grading
objects that use that criteria. If the criteria definition is edited to unlock the slope value, it does not
change existing gradings, but allows you to edit the slope value for existing grading objects.

■

If the criteria definition is edited to change the unlocked relative elevation value, it affects only the
default prompt value for new grading objects created with the criteria. If the criteria definition is edited
to lock the relative elevation, all grading objects using that criteria are set to the locked relative elevation
value.

Both values are locked
■

When creating grading, you do not receive prompts for the criteria values.

■

If the criteria definition is edited to change either value, the change applies to all grading objects that
use the criteria.

■

If the criteria definition is changed to unlock either value, it does not change the grading objects but
allows you to edit the value for existing grading objects that use the criteria.

To create a new grading criteria set
1 In Toolspace, on the Settings tab, expand Grading.
2 Right-click the Grading Criteria Sets collection and click New.
3 In the Grading Criteria Set Properties (page 2110) dialog box, enter a name and optional description for
the set and click OK.
To create a new grading criteria
1 In Toolspace, on the Settings tab, expand Grading.
2 Expand the Grading Criteria Sets collection. The defined sets are listed.
3 Right-click a named grading criteria set. Click New.
4 In the Grading Criteria dialog box, click the Information tab (page 2104) and enter a name and an optional
description.
5 Click the Criteria tab (page 2105), and edit the values to define the criteria you want.
6 Lock the items that you do not want to change when you are creating grading objects. For example, if
you are setting up a criteria to always create a 3:1 slope, lock the Slope value by clicking the lock icon.
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7 Click OK.

Quick Reference
Toolspace Shortcut Menu
Settings tab: Right-click Grading Criteria Sets collection ➤ New
Settings tab: Right-click a grading criteria set ➤ New
Dialog Box
Grading Criteria (page 2104)

Setting Default Grading Criteria
Apply a set of grading criteria to each grading that you create.
To set default grading criteria
1 Click Home tab ➤ Create Design panel ➤ Grading drop-down ➤ Grading Creation Tools
2 In the Grading Creation Tools (page 2114) dialog box, click

.

(Select A Criteria Set).

3 Select the grading criteria that you want to apply.
Click

if you want to view the settings for the current criteria.

4 Create the grading.
The grading criteria is applied to each grading you create until you change criteria by making another
selection from the Grading Creation Tools.

Using Grading Groups
You can specify which collection a grading object is part of.
Once you create a surface from a grading group, you can use the Grading Volume Tools (page 2121) to adjust
the elevation of the grading group to balance cut and fill volumes.

Creating a New Grading Group
Use the Prospector tab of Toolspace to create a new grading group.
Grading groups are used to organize gradings into named collections for surface creation and volume
computations.
You can choose whether to automatically create a surface from the grading group, and you can identify a
base surface for volume calculations.
You can also create new grading groups while using the Grading Creation Tools command.
To create a new grading group
1 In Toolspace, on the Prospector tab, expand Sites, then expand the site to which you want to add the
new grading group.
2 Right-click Grading Groups ➤ Create Grading Group.
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3 In the Create Grading Group (page 2103) dialog box, enter a name and an optional description for the
grading group.
4 Optionally, to create a surface for the grading group, select Automatic Surface Creation to activate
additional options for the output surface and the base surface. It also creates a surface in the Surfaces
collection in the Prospector tree.
NOTE When you create a surface using the Automatic Surface Creation option, the Grading Group is listed
on the Definition tab of that surface’s Properties dialog box.
5 Optionally, if you plan to do any calculations of cut and fill volumes for the grading group surface,
select Volume Base Surface and select the base surface from the list.
6 Click OK.

Quick Reference
Toolspace Shortcut Menu
Prospector tab: Right-click Grading Groups collection ➤ Create Grading Group
Command Line
CreateGradingGroup
Dialog Box
Create Grading Group (page 2103)

Changing the Grading Group of a Grading Object
A grading object can be moved from one grading group to another.
If you do not want certain grading objects to be included in the same grading group, you can move them
to a different group. There must be at least two grading groups in the same site.
To change the grading group of a grading object
1 Select a grading. Click Grading tab ➤ Modify panel ➤ Change Group

.

2 Select one or more grading objects in the drawing.
3 In the Select Grading Group (page 2122) dialog box, select or create a grading group for the grading object
to be in.
4 Click OK.

Quick Reference
Ribbon
Select the grading. Grading tab ➤ Modify panel ➤ Change Group
Menu
Grading menu ➤ Edit Grading ➤ Change Group
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Command Line
ChangeGradingGroup
Dialog Box
Select Grading Group (page 2122)

Creating Feature Lines
You can select a parcel lot line or feature line (page 2774) as the grading footprint.
A feature line is a special type of line that grading commands recognize and use as a footprint.
A feature line represents an object in the drawing from which you want to grade, such as a swale or a ridge
line. You can draw feature lines, create them by converting existing objects, or export feature lines from
corridors. Surfaces can use a feature line as a breakline.

Curved Feature Lines
Unlike 3D polylines, feature lines support arcs without tessellation (page 2785). Tessellation is undesirable in
a grading footprint because it results in many small grading faces joined by radial corners. To avoid tessellation,
you can create a feature line from a 2D polyline with arcs, and then apply elevations using theGrading
Elevation Editor. If you want to create a grading from a footprint that has tessellated curves, you can use
the Fit Curve (page 842) command to convert the tessellation to true arcs.
See also:
■

Exporting Corridor Feature Lines (page 1528)

Creating Feature Lines from Objects
You can create a feature line by converting existing 2D or 3D polylines, lines, or arcs. You can select objects
in the current drawing or from an Xref.
Names can be assigned to feature lines. Any command that prompts to select a feature line includes an
option to select by name from a list. The name is optional so that you can just name the significant feature
lines in your drawing.
You can specify the CreateFeatureLines (page 801) command settings prior to creating feature lines.
Settings control which layer the lines are placed on and whether the original objects are deleted.
To create a feature line from existing objects
1 Click Home tab ➤ Create Design panel ➤ Feature Line drop-down ➤ Create Feature Lines From Objects
.
2 In the drawing, select one or more polylines, lines, or arcs. Then press Enter.
NOTE You can enter Xref to select an object from an Xref.
You can select the objects one at a time, or you can make a multiple selection by drawing a window.
3 In the Create Feature Lines (page 2129) dialog box, specify the feature line options.
The feature line retains the elevations of the objects from which it was made. To edit these elevations,
see Editing the Elevations of a Feature Line (page 818).
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Quick Reference
Ribbon
Home tab ➤ Create Design panel ➤ Feature Line drop-down ➤ Create Feature Lines From Objects
Menu
Grading menu ➤ Create Feature Lines From Objects
Command Line
CreateFeatureLines

Assigning Elevations to a Feature Line During Creation
When creating a feature line you can manually enter an elevation or assign an elevation from a surface or
from grading objects when creating a feature line from objects.
To manually assign feature line elevations
1 Click Home tab ➤ Create Design panel ➤ Feature Line drop-down ➤ Create Feature Lines From Objects
.
2 In the Create Feature Lines (page 2129) dialog box, select the Assign Elevations check box and press OK.
3 In the Assign Elevations (page 2130) dialog box, enter an elevation in the edit box select the Elevation
option and press OK. If the object is a 3D polyline with varying elevations, the first point is set to the
specified elevation and the rest of the points are raised/lowered by the same relative amount so that
the elevation differences between the points remain.
To assign feature line elevations from a surface
1 Click Home tab ➤ Create Design panel ➤ Feature Line drop-down ➤ Create Feature Lines From Objects
.
2 In the Create Feature Lines dialog box (page 2129), select the Assign Elevations check box and press OK.
3 In the Assign Elevations (page 2130) dialog box, select the From Surface option.
NOTE If there are no surfaces in the drawing, the From Surface option is unavailable.
4 Select a surface from the list or click the arrow icon to select it in the drawing.
5 Select the Insert Intermediate Grade Break Points check box to insert intermediate grade breaks where
the entity crosses surface TIN lines. Additional elevation points are created at these locations.
To assign feature line elevations from a grading in the current site
1 Click Home tab ➤ Create Design panel ➤ Feature Line drop-down ➤ Create Feature Lines From Objects
.
2 In the Create Feature Lines dialog box (page 2129), select the Assign Elevations check box.
3 Select the From Gradings option. This option is similar to the From Surfaces option but acquires the
elevations directly from any gradings that it overlaps in the site that the feature line is to be created in.
NOTE If there are no gradings in the drawing, the From Gradings option is unavailable.
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4 Select the Insert Intermediate Grade Break Points check box to insert intermediate grade breaks where
the entity crosses surface TIN lines. Elevation points are created at these locations.

Quick Reference
Ribbon
Home tab ➤ Create Design panel ➤ Feature Line drop-down ➤ Create Feature Lines From Objects
Menu
Grading menu ➤ Create Feature Lines From Objects
Command Line
CreateFeatureLines

Creating Feature Lines from Alignments
You can create a feature line from an alignment, and use this feature line to grade from the alignment
geometry.
You can also create a link from the feature line to the alignment so that it updates dynamically if the
alignment is edited. If the feature line is linked to the alignment, you cannot edit it directly.
However, it updates automatically when you make edits to the alignment or its profile. These edits also
update any gradings attached to the feature line. If the feature line is not dynamically linked, it does not
maintain its relationship with the alignment and you can edit it.
You can specify the CreateFeatureLineFromAlign (page 801) command settings prior to creating feature lines.
To create a feature line from an alignment
1 Click Home tab ➤ Create Design panel ➤ Feature Line drop-down ➤ Create Feature Lines From Objects
.
2 In the drawing, select an alignment. Then press Enter.
If there are no sites in the drawing, a site will automatically be created.
3 In the Create Feature Line From Alignment (page 2131) dialog box, specify the feature line options.

Quick Reference
Ribbon
Home tab ➤ Create Design panel ➤ Feature Line drop-down ➤ Create Feature Lines From Objects
Menu
Grading menu ➤ Create Feature Lines From Objects
Command Line
CreateFeatureLineFromAlign
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Applying Feature Line Names
Apply optional names to feature lines to distinguish significant feature lines.
After creation, you can edit the names of individual feature lines using the Properties command, or using
the grid control in Prospector.
This command is used to apply a name template to a selection set of feature lines.
You can specify the CreateFeatureLines (page 801) command settings prior to creating feature lines.
To apply a feature line name
1 In the drawing, select a feature line, right-click, and click Apply Feature Line Names.
2 In the Apply Feature Line Names (page 2138) dialog box, in the Name field, enter a name for the feature
line.
To name the feature line, either select its default name and enter a new name, or use the name template.
For more information, see Name Template Dialog Box (page 2022).

Quick Reference
Ribbon
Select the feature line. Click Feature Line tab ➤ Modify panel ➤ Apply Feature Line Names
Menu
Prospector tab ➤ Feature Lines ➤ Apply Feature Line Names
Command Line
ApplyFeatureLineNames

Applying Feature Line Styles
Apply a style to a selected set of feature lines.
You can specify the CreateFeatureLines (page 801) command settings prior to creating feature lines.
To apply a feature line style
1 In the drawing, select two or more feature lines, right-click, and click Apply Feature Line Styles.
2 In the Apply Feature Line Styles (page 2138) dialog box, specify the feature line style.

Quick Reference
Ribbon
Select the feature line. Click Feature Line tab ➤ Modify panel ➤ Apply Feature Line Styles
Menu
Prospector tab ➤ Feature Lines ➤ Apply Feature Line Styles
Command Line
ApplyFeatureLineStyles
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Editing Feature Line Styles
Apply a style to a selected set of feature lines.
Controls the display of each feature line component.
To edit a feature line style
1 In the drawing, select a feature line, right-click, and click Edit Feature Line Style.
2 In the Feature Line Style Dialog Box (page 2118), specify the feature line style components.

Quick Reference
Ribbon
Select the feature line. Click Feature Line tab ➤ Modify panel ➤ Feature Line Properties drop-down ➤ Edit
Feature Line Style
Command Line
EditFeatureLineStyle

Removing Dynamic Links
Remove the dynamic links from grading feature lines that have been created from alignments or corridors.
Removing a dynamic link disconnects the feature line from an alignment or corridor and enables feature
line editing. You cannot edit feature lines with dynamic links. When a dynamic link is removed, it cannot
be restored.
To remove a dynamic link
1 In the drawing, select a feature line, right-click, and click Remove Dynamic Links.
2 In the Apply Feature Line Styles (page 2138) dialog box, specify the feature line style.

Quick Reference
Menu
Prospector tab ➤ Feature Lines ➤ Remove Dynamic Links
Command Line
FeatureLineRemLinks
See also:
■

Creating Feature Lines (page 808)

Selecting All Feature Lines in a Site
Make a selection set of all feature lines in the current site and edit them all simultaneously. The same
command also displays the Toolspace List View.

812 | Chapter 22 Grading

To select all feature lines in a site
1 In Toolspace, on the Prospector tab, expand the Site collection.
2 Right-click Feature Lines and click Select.
3 All features lines are selected.

Quick Reference
Toolspace Shortcut Menu
Prospector tab ➤ Feature Lines ➤ Select

Selecting All Grading Groups in a Site
Make a selection set of all grading groups in the current site. The same command is useful for visualizing
the gradings in the object viewer. This command also displays the Toolspace List View.
To select all grading groups in a site
1 In Toolspace, on the Prospector tab, expand the Site Collection.
2 Right-click Grading Groups and click Select.
3 All grading groups are selected.

Quick Reference
Toolspace Shortcut Menu
Prospector tab ➤ Grading Groups ➤ Select

Drawing Feature Lines
Draws feature line segments.
Use this command to draw straight and curved feature line segments. This command has options to specify
the elevations of the feature line, including an option to retrieve the elevations from a surface.

Arcs are created tangential to the previous segment except when the Second Point option is selected to create
a three-point arc.
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To draw straight segments of feature lines
1 Click Home tab ➤ Create Design panel ➤ Feature Line drop-down ➤ Create Feature Line

.

2 In the Create Feature Lines (page 2129) dialog box, specify a site, an optional name, and an optional style
for the feature line. Select a layer and note that the option to use a selected entity layer is disabled.
Click OK.
3 Select the start point for the line. You can use Osnaps or transparent commands to snap to existing
geometry.
4 Specify the elevation for the start point by doing one of the following:
■

Enter an elevation at the command line.

■

Enter Surface (S) and select a surface from which to obtain the elevation.
NOTE If there are no surfaces in the drawing, the Surface option is not available. If there is only one
surface in the drawing, that surface is selected automatically.

The following prompt is displayed:
Specify the next point or [Arc]:

5 Select the next point.
The following prompt is displayed:
Specify grade or [SLope/Elevation/Difference/SUrface/Transition] <0.000>:

NOTE See To draw curve segments of feature lines (page 815) for information about the Arc option.
6 If you wish to specify each elevation point as you create points, skip down to Step nine. To continue
drawing points without establishing the elevation until the end:
■

Enter the Transition command.

■

Create a new point. When Transition is selected, as each subsequent point is created the elevation
prompt will default to Transition.
Transition or [SLope/Elevation/Difference/SUrface] <Transition>

7 Press Enter to continue drawing another point(s) without specifying the elevation.
8 After creating points, select and enter the desired keyword to specify the elevation, grade, slope, or
elevation difference. If you end the command while still in the Transition prompt, you will be prompted
to specify an ending elevation.
9 Do one of the following to establish the elevation of the second point:
■

Enter a grade. The grade is applied to the segment between the first and second points.

■

Enter Slope (SL) and enter a slope. The slope is applied to the segment between the first and second
points.

■

Enter Elevation (E) and enter an elevation. The elevation is applied to the second point and the
grade of the segment between the points is calculated.

■

Enter Difference (D) and enter an elevational difference between the first and second points.

■

Enter Surface (SU) and specify a surface from which to obtain the elevation of the second point.

10 Specify the next point on the feature line by doing one of the following:
■

Select the next point in the drawing.
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■

Enter Length (L) and enter a length. When you use this option, the direction of the segment is
assumed to be the same as the end of the previous segment.

11 Specify the elevation of the point using the options described in Step 6.
To draw curve segments of feature lines
1 Complete Steps 1-4 in Drawing Feature Lines (page 813) to draw straight segments.
2 When you are prompted to select the next feature line point, enter Arc (A). The following prompt is
displayed:
Specify arc end point or [Radius/SecondPnt/Line/Undo]:

NOTE If you have not drawn any feature line segments, you are first prompted to establish the arc direction.
For more information, see To establish arc direction (page 815).
3 Do one of the following:
■

Select the end point for the arc.

■

Enter Radius (R) and specify a radius.
After entering the radius, the following prompt is displayed:
Specify arc end point or [Length]:

Select the end point or enter Length. If you use the Length option, specify a length and then a
direction for the arc.
NOTE Because this option specifies a radius and the arc is tangent to the previous segment, the actual
end point of the arc may not be at the selected end point.
■

Enter SecondPnt (S) and specify the second point for the arc.
After selecting the second point, the following prompt is displayed:
Specify arc end point or [Length]:

Select the end point or enter Length. If you use the Length option, specify a length and then a
direction for the arc.
NOTE The Length option creates an arc that is tangent to the previous segment and passes though the
second point. The arc may stop short of the second point if the length is shorter than the arc length to
the point.
4 Specify the elevation of the end point.
5 Continue to select arc points or enter Line to draw straight segments or Close to close the feature line.
To establish arc direction
1 If you use the Arc option of the Draw Feature Line command prior to drawing any segments, it defaults
to drawing a three-point arc. The following prompt is displayed:
Specify arc second point or [Direction]:

2 Do one of the following:
■

Click a location in the drawing to establish the direction of the arc.

■

Enter an angle at the command line. Use the DD.MMSS (degrees, minutes, seconds (page 2772)) format.

■

Enter Bearing (B). Temporary graphics are displayed on screen and the following prompt is displayed:
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Specify quadrant (1-4) or [aZimuth/Angle]:

Use your mouse to click one of the four bearing quadrants as indicated by the temporary graphics,
or enter the quadrant number at the command line.
After defining the quadrant, the following prompt is displayed:
Specify bearing or [aZimuth/Angle]:

Use your mouse to specify the bearing or enter it at the command line. Use the DD.MMSS format.
■

Enter Azimuth (Z). Temporary graphics are displayed on screen and the following prompt is displayed:
Specify azimuth or [Bearing/Angle]:

Use your mouse to specify the azimuth or enter it at the command line. Use the DD.MMSS format.
3 After you have established the arc direction, the following prompt is displayed:
Specify arc end point or [Radius/SecondPnt/Line]:

See To draw curve segments of feature lines (page 815) for more information.

Quick Reference
Ribbon
Home tab ➤ Create Design panel ➤ Feature Line drop-down ➤ Create Feature Line
Menu
Grading menu ➤ Draw Feature Line
Command Line
DrawFeatureLine

Editing Feature Lines
You can use feature line editing commands with several different object types in addition to feature lines.
NOTE You can use the feature line commands to edit survey figures, including control points. You should update
the survey database after editing a feature line. If you do not, the next time you recalculate the figure from the
database, your edits to the feature lines will be overwritten.
NOTE You can also use the feature line commands to edit parcel lines.
The following table lists which objects are supported for each command.
Feature Lines Parcel Lines

Survey Figures

Elevation Editor
(page 820)

X

X

X

Quick Elevation
Edit (page 819)

X

X

Edit Elevations
(page 822)

X

X
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X

3D Polylines 2D Polylines

X

Feature Lines Parcel Lines

Survey Figures

3D Polylines 2D Polylines

Set Grade/Slope
Between Points
(page 823)

X

X

X

X

Set Elevation By
Reference (page
824)

X

X

X

X

Insert Elevation
Point (page 830)

X

X

X

X

Delete Elevation
Point (page 832)

X

X

X

Insert High/Low Elevation Point
(page 832)

X

X

X

X

Raise/Lower (page
829)

X

X

X

X

Raise/Lower by
Reference (page
826)

X

X

X

X

Adjacent Elevations
by Reference (page
827)

X

X

X

X

Grade Extension by
Reference (page
828)

X

X

X

X

Set Elevations From
Surface (page 833)

X

X

X

X

Insert PI (page 834)

X

X

X

X

X

Delete PI (page 836)

X

X

X

X

X

Join (page 836)

X

X

X

X

Reverse (page 837)

X

X

X

X

NOTE Inserts
PI rather than
elevation
point.

X

X
NOTE This
command
also supports
AutoCAD
lines
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Feature Lines Parcel Lines

Survey Figures

Edit Curve (page
838)

X

X

Fillet (page 841)

X

Fit Curve (page 842)

X

Smooth (page 844)

X

Weed (page 846)

X

Stepped Offset
(page 848)

X

Apply Feature Line
Names (page 811)

X

Apply Feature Line
Styles (page 811)

X

Break (page 849)

X

Remove Dynamic
Links (page 812)

X

Trim (page 850)

X

Adding a Feature
Line to Surface as
a Breakline (page
851)

X

X

X

3D Polylines 2D Polylines

X

X

X

X

X

X

X

X

X

X

X

Convert 2D to 3D
Polyline (page 854)

X

Convert 3D to 2D
Polyline (page 854)

X

Edit Polyline Elevations (page 855)
Quick Profile (page
1153)

X

X

X

X

X

X

Editing the Elevations of a Feature Line
You can edit the elevation of a feature line using the Grading Elevation Editor, the command line, or several
different tools on the Edit Elevations panel.
You can use many of these commands on objects other than feature lines. See the Quick Reference tab of
each topic for a list of supported objects for each command.
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Quickly Editing Feature Line Elevations
Use the Quick Elevation Edit command to interactively edit the elevation or grade of any feature line or
parcel line in a specified site.
The elevation is displayed at vertices and elevation points, and the grade is displayed along segments. Click
to edit the value on the command line.

To quickly edit feature line elevations
1 Click Modify tab ➤ Design panel ➤ Elevations Drop-down ➤ Quick Elevation Edit

.

NOTE The current site is listed at the command line. If you want to select a different site or an object in the
desired site, enter Site. Then, select either an object in the drawing or select Enter to access a list of available
sites in the Select Object(s) dialog box.
2 Move your mouse over the geometry you want to edit.
■

Triangles
are displayed when you hover over a vertex or intersection point. The elevation is
displayed in a tooltip.

■

Circles
are displayed when you hover over an elevation point (page 2773). The elevation is displayed
in a tooltip.

■

Arrows
are displayed when you hover over a segment. The arrow points to the end of the
segment that is closest to the cursor. This is the point that will have its elevation changed with the
grade edit.The grade is displayed in a tooltip.

■

Gray glyphs
are displayed when you hover over an elevation or grade that cannot be edited.
Uneditable lines include objects such as daylight and dynamically linked feature lines.

When you locate the elevation or grade you want to edit, click your mouse.
3 Do one of the following:
■

Enter the new elevation or grade at the command line.

■

If you clicked an elevation point, you can also enter Surface to open the Select Surface dialog box
and select a surface to obtain the elevation from.
NOTE The Surface option only appears if there are surfaces in the drawing.
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■

If you clicked a grade point, you can also enter Slope and specify a slope. It edits the elevation at
the end of the segment in the direction that the arrow is pointing.

NOTE If the feature lines are being used as surface breaklines and the surface Rebuild-Automatic setting is turned
on, you can see the surface updating automatically as you make each edit.
To quickly edit feature line elevation points by selecting a reference
1 Click Modify tab ➤ Design panel ➤ Elevations Drop-down ➤

Quick Elevation Edit.

2 Enter Reference.
3 Select the reference point to use. When picking the reference point, it defaults to a point in the site,
but you can also select the Pick option to use OSNAP to pick any location in the drawing.
4 Move the cursor around the reference point and a yellow line is drawn on screen from the reference
point to the closest point.
5 Do one of the following:
■

Enter a grade. The grade is applied between the reference point and the point on the feature line.

■

Enter Slope and then enter a slope. The slope is applied between the reference point and the point
on the feature line.

■

Enter Difference and then enter the elevational difference. The elevational difference is applied
between the reference point and the point on the feature line.

The assigned elevation for the point is displayed at the command line.

Quick Reference
Ribbon
Click Modify tab ➤ Edit Elevations panel ➤ Quick Elevation Edit
Menu
Click Grading menu ➤ Edit Feature Line Elevations ➤ Quick Elevation Edit
Command Line
QuickEditFeatureElevs
Supported Objects
■

Feature lines

■

Parcel lines

Editing Feature Lines with the Grading Elevation Editor
Edit the vertex elevations of feature lines, survey figures, and parcel lines with the Grading Elevation Editor.
Use the Grading Elevation Editor to edit feature line elevations in a tabular dialog box. You can also assign
an elevation from an existing surface.
Changes you make in the editor dynamically change the elevation in the drawing.
Within the editor, each vertex is displayed on its own row, and is marked with a triangle or circle.
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When you click a row, a marker is displayed in the drawing, displaying the vertex that you are on.

■

Green triangles
mark the points that represent the major horizontal geometry points. For example,
when you create a feature line, all vertices are shown as triangles. If you insert points of intersection (PI),
they are also shown as triangles.

■

White triangles
indicate split points, where two feature lines cross although neither has a geometry
point at that location. You cannot directly edit the elevation of these points. For more information, see
Feature Line Site Properties (page 866).

■

Circles
mark the elevation change points. Insert a new elevation point (page 2773) by using the Insert
Elevation Point icon in the Grading Elevation Editor.

■

Grade arrows display at segment midpoints (pointing downhill) to indicate feature line flow directions
and to display the segment that is being edited when a single row is selected.

NOTE When a vertex is a shared point with another intersecting feature line, a small + symbol
with the icon for that row.

is displayed

When two features, such as feature lines, lot lines or survey figures cross and neither feature has a geometry
point at that location, a split point is created. You cannot edit this point directly, as it is controlled by the
grades of the two crossing segments which must have the same elevation at the crossing point. If the two
elevations are different, a grade break is inserted into one to match the elevation of the other.
You can assign a priority to feature line styles so that when two feature lines with different styles cross, the
one with the higher priority will set the elevation. Feature lines without a style have the lowest priority. Use
the Options tab in the Feature Line Site Properties (page 2137) dialog box to set the feature line style priority.
If two feature lines have the same style or no style, then the feature line that is modified last becomes
dominant, causing the other feature line to break at that point. To control the elevation at that point, use
the Insert PI command to create a vertex at the split point.
To edit a feature line, using the Grading Elevation Editor
1 Click Modify tab ➤ Edit Elevations panel ➤ Elevation Editor

.

2 Select the feature line or an other object.
3 Change the elevation in the Grading Elevation Editor (page 2111) dialog box.
The Elevations From Surface option is unavailable if there are no surfaces in the drawing. If there is
only one surface, that surface is automatically used to assign the elevation. If there is more then one
surface, you are prompted to select the desired surface.
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If no feature line rows are selected, the elevation of all points are updated. If the feature line is off of
the surface, a warning message displays. If some elevations are updated, but one or more points are off
of the surface, a message displays, indicating the number of points that could not be assigned elevations.
The feature line is updated in the drawing, and the grading is adjusted.

Quick Reference
Ribbon
Click Modify tab ➤ Edit Elevations panel ➤ Elevation Editor
Menu
Click Grading menu ➤ Edit Figure Elevations ➤ Elevation Editor
Command Line
GradingElevEditor
Dialog Box
Grading Elevation Editor (page 2111)
Supported Objects
■

Feature lines

■

Parcel lines

■

Survey figures

Editing Feature Line Elevations at the Command Line
Edits the vertex elevations of a survey figure, parcel line, or 3D polyline at the Command prompt.
Use this command to step through each vertex and elevation point on a feature line or figure. You can
change elevations and grades, also insert, move, and delete elevation points.
To edit a feature line from the command line
1 Click Modify tab ➤ Edit Elevations panel ➤ Edit Elevations

.

2 Select the feature line or other object.
3 To select the vertex or elevation point to edit, press Enter without entering a value. You can also enter
Next or Previous to change the direction the command uses to step through the points.
■

A triangle

■

A circle

is displayed on the feature line when you select a vertex or intersection point.
is displayed on the feature line when you select an elevation point (page 2773).

4 Do one of the following:
■

Enter an elevation and press Enter to modify the elevation and stay at the current point. The updated
values are displayed.

■

Enter Grade and specify a grade.

■

Enter Surface and select a surface to obtain the elevation from.
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■

Enter Insert and select a location for a new elevation point along the feature line.
The following options are available only for elevation points:

■

Enter Move and select a new location for the elevation point.

■

Enter Delete to delete the current elevation point.

5 As you make each change, the feature line is updated in the drawing and the grading is adjusted.
6 Enter Exit to end the command.

Quick Reference
Ribbon
Click Modify tab ➤ Edit Elevations panel ➤ Edit Elevations
Menu
Click Grading menu ➤ Elevation Editor ➤ Edit Elevations
Command Line
EditFeatureElevs
Supported Objects
■

Feature lines

■

Parcel lines

■

Survey figures

■

3D polylines

Setting a Grade or Slope Between Points
Use to edit the grade/slope between two vertices on a feature line, survey figure, parcel line, or 3D polyline
Specify grade, slope, point elevations, or elevation difference between points. For the selected segment (1),
you specify the start point (2), the elevation (3), and the end point (4). Then specify the grade, slope, elevation
or elevation difference.
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To set a grade or slope between points
1 Click Modify tab ➤ Edit Elevations panel ➤ Set Grade/Slope Between Points

.

2 Select the feature line or other object.
3 Select the start point of the segment you want to edit.
4 Optionally, specify the elevation of the start point by entering an elevation or by entering Surface and
selecting a surface to obtain the elevation from.
5 Select the end point of the segment.
6 Do one of the following to establish the grade or slope between the points:
■

Enter a grade.

■

Enter Slope and specify a slope.

■

Enter Elevation and specify an elevation for the end point.

■

Enter Difference and specify an elevational difference between the two points.

Quick Reference
Ribbon
Click Modify tab ➤ Edit Elevations panel ➤ Set Grade/Slope Between Points
Menu
Click Grading menu ➤ Edit Figure Elevations ➤ Set Grade/Slope Between Points
Command Line
SetFeatureGrade
Supported Objects
■

Feature lines

■

Parcel lines

■

Survey figures

■

3D polylines

Setting Feature Line Elevation by Reference
Sets a vertex elevation on a feature line, survey figure, parcel line, or 3D polyline at a given grade/slope from
a specified location.
Example: Specify the elevation of a ditch footprint in relation to a building pad elevation. Temporary graphics
show the reference point and the vertices on the feature line.
To set feature line elevation by reference
1 Click Modify tab ➤ Edit Elevations panel ➤ Set Elevation By Reference
2 Select the reference point to use.
The elevation of the selected point is displayed at the command line.
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.

3 Select the feature line or other object to which you want to apply the elevation.
Temporary graphics are drawn on-screen to show the reference point and the vertices and elevation
points on the feature line.

4 Do one of the following:
■

Click to select the first point selected on the feature line. Or move your mouse to snap to a different
point on the feature line, and then click to select it.

■

Enter Insert and then select a point on the feature line at which to insert a new elevation point. On
3D polylines, a new PI is inserted.

The distance between the selected point and the reference point, and the elevation and grade of the
selected point, are displayed at the command line.
5 Do one of the following:
■

Enter a grade. The grade is applied between the reference point and the point on the feature line.

■

Enter Slope and then enter a slope. The slope is applied between the reference point and the point
on the feature line.

■

Enter Difference and enter the elevational difference. The elevational difference is applied between
the reference point and the point on the feature line.

The assigned elevation for the point is displayed at the command line.
6 The original reference point remains active. Select another feature line to continue setting elevations
in reference to this point. Or, press Enter to end the command.

Quick Reference
Ribbon
Click Modify tab ➤ Edit Elevations panel ➤ Set Elevation By Reference
Menu
Click Grading menu ➤ Edit Figure Elevations ➤ Set Elevation By Reference
Command Line
SetFeatureRefElev
Supported Objects
■

Feature lines

■

Parcel lines

■

Survey figures

■

3D polylines
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Raising or Lowering Feature Line Elevation by Reference
Use the Raise/Lower By Reference command to raise or lower a feature line, based on a grade, slope or relative
elevation from a reference point.
Select the Pick option to pick any location in the drawing or use the transparent commands to select a COGO
point or surface elevation.
To raise or lower feature line elevation by reference
1 Click Modify tab ➤ Edit Elevations panel ➤ Raise/Lower By Reference

.

2 Select the reference point to use. Select the Pick option to use OSNAP to pick any location, in the
drawing or use the transparent commands to select a COGO point or surface elevation.
The elevation of the selected point is displayed at the command line.
3 Select the feature line or other object that you want to raise or lower.
4 Select a point on the object you selected.
The distance between the selected point and the reference point, and the elevation and grade of the
selected point, are displayed at the command line.
5 Do one of the following:
■

Enter a grade. The grade is applied between the reference point and the point on the feature line.

■

Enter Slope and enter a slope. The slope is applied between the reference point and the point on
the feature line.

■

Enter Difference, and enter the elevational difference. The elevational difference is applied between
the reference point and the point on the feature line.

The assigned elevation for the point is displayed at the command line.
6 The original reference point remains active. Select another feature line to continue setting elevations
in reference to this point. Or, press Enter to end the command.

Quick Reference
Ribbon
Click Modify tab ➤ Edit Elevations panel ➤ Raise/Lower By Reference
Menu
Click Grading menu ➤ Edit Figure Elevations ➤ Raise/Lower By Reference
Command Line
SetFeatureRefElev
Supported Objects
■

Feature lines

■

Parcel lines

■

Survey figures

■

3D polylines

■

Polylines
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Setting Adjacent Feature Line Elevations by Reference
Use the Adjacent Elevations By Reference command to set the elevations along a feature line, survey figure,
lot line or 3D polyline, based on a grade, slope or elevation difference from points along another feature
line.
This command is similar to setting elevations in stepped offset, without first creating the offset.
Using this command, you can edit the elevations of one feature line and then update the elevations of
another related feature line that exists alongside the first.

To set adjacent feature line elevations by reference
1 Click Modify tab ➤ Edit Elevations panel ➤ Adjacent Elevations By Reference

.

2 Select the reference object.
3 Select the feature line or another object you want to edit.
Glyphs are displayed at each point that will be edited along the feature line, as well as yellow lines
projected to the reference feature line, which display the location of the reference elevations for each
point.

Only points that fall within the range of the reference object can be modified.
4 Do one of the following:
■

Enter the elevational difference. The elevational difference is applied between the reference point
and the point on the feature line.

■

Enter Grade and enter a grade. The grade is applied between the reference point and the point on
the feature line.

■

Enter Slope and enter a slope. The slope is applied between the reference point and the point on
the feature line.

■

Enter Variable. The Variable option steps along each point prompting for the elevation difference,
grade, or slope. It does not insert any new points along the feature
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The assigned elevation for the point is displayed at the command line.

Quick Reference
Ribbon
Click Modify tab ➤ Edit Elevations panel ➤ Adjacent Elevations By Reference
Menu
Grading menu ➤ Edit Feature Line Elevations ➤ Adjacent Elevations By Reference
Command Line
SetFeatureRefElev
Supported Objects
■

Feature lines

■

Parcel lines

■

Survey figures

■

3D polylines

Extending a Grading By Reference
Use the Grade Extension By Reference command to edit an elevation by extending the grade of a segment
on another feature.
This command is used to apply the same grade from a segment across a gap to a point on another feature
line. For example, you can extend a grade across an intersection.

To extend a grading by reference
1 Click Modify tab ➤ Edit Elevations panel ➤ Grade Extension By Reference

.

2 Select the reference segment.
The segment is highlighted and the grade and slope are displayed in the command line.
3 Select the feature line or an other object that you want to edit.
As the cursor is moved along the feature line, it snaps to the nearest point that you can edit, displaying
a yellow line from the reference point to the edit point.
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4 Specify the point.
The grade, slope, elevation and distance to the point are displayed in the command line.
5 Press Enter to use the default reference grade. Do one of the following:
■

Enter a grade. The grade is applied between the reference point and the point on the feature line.

■

Enter Slope and then enter a slope. The slope is applied between the reference point and the point
on the feature line.

■

Enter Difference and enter the elevational difference. The elevational difference is applied between
the reference point and the point on the feature line.

The assigned elevation for the point is displayed at the command line.
6 Enter the grade to that point. The reference grade is the default.
7 Select another reference segment. Press Enter to end the command.

Quick Reference
Ribbon
Click Modify tab ➤ Edit Elevations panel ➤ Grade Extension By Reference
Menu
Grading menu ➤ Edit Feature Line Elevations ➤ Grade Extension By Reference
Command Line
SetFeatureRefElev
Supported Objects
■

Feature lines

■

Parcel lines

■

Survey figures

■

3D polylines

■

Polylines

Raising or Lowering Feature Lines
Use the Raise/Lower command to raise or lower the elevation for a selection of feature lines, figures, lot lines,
polylines or 3d polylines.
If the selected feature lines all have the same constant elevation, an Elevation option is available to set the
elevation value.
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To raise or lower features lines
1 Click Modify tab ➤ Edit Elevations panel ➤ Raise/Lower

.

2 Select the feature line or other objects to edit.
3 Enter the elevation difference by which to raise or lower the feature lines.
The default elevation difference is 1.0.
4 If the selected feature lines are all at the same elevation, an Elevation keyword appears. Select the
Elevation option to specify an elevation for the feature lines. The default is the elevation of the feature
lines.

Quick Reference
Ribbon
Click Modify tab ➤ Edit Elevations panel ➤ Raise/Lower
Menu
Grading menu ➤ Edit Feature Line Elevations ➤ Raise/Lower
Command Line
RaiseLowerFeatures
Supported Objects
■

Feature lines

■

Parcel lines

■

Survey figures

■

3D polylines

■

Polylines

Inserting a Feature Line Elevation Point
Use the Insert Elevation Point command to insert an elevation point (page 2773) on a feature line.
Specify a location, distance, or increments at which to insert multiple points. When a single point is inserted,
you can specify the elevation.
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To insert a feature line elevation point by selecting a location
1 Click Modify tab ➤ Edit Elevations panel ➤ Insert Elevation Point

.

2 Select the feature line or other object.
3 Click to select the location along the feature line to insert the elevation point.
4 Specify the elevation by entering a value. Or enter Surface to obtain the elevation from a surface. If
only one surface is in the drawing it is selected automatically.
5 Select another point or specify a distance to insert another point.
To insert a feature line elevation point by specifying a distance
1 Click Modify tab ➤ Edit Elevations panel ➤ Insert Elevation Point

.

2 Select the feature line or other object.
3 Enter Distance.
4 Select an existing point on the feature line to specify the start of the distance. If you select a point other
than the start or end point, you must then select the direction.
5 Enter a distance to define the location of the elevation point.
6 Do one of the following to define the elevation of the point:
■

Enter a grade.

■

Enter Slope and enter a slope.

■

Enter Elevation and enter an elevation. Or enter Surface to obtain the elevation from a surface.

■

Enter Difference and enter an elevational difference.

To insert multiple elevation points at an increment
1 Click Modify tab ➤ Edit Elevations panel ➤ Insert Elevation Point

.

2 Select the feature line or other object.
3 Enter Increment.
4 Enter a value to define the length of the increment. Points are placed equidistant along the feature line
using the specified increment.
NOTE Using this option, you are not prompted for elevations. The points are automatically assigned the
elevation that exists at their location on the feature line.

Quick Reference
Ribbon
Click Modify tab ➤ Edit Elevations panel ➤ Insert Elevation Point
Menu
Grading menu ➤ Edit Feature Line Elevations ➤ Insert Elevation Point
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Command Line
InsertElevPoint
Supported Objects
■

Feature lines

■

Parcel lines

■

Survey figures

■

3D polylines (inserts PI rather than elevation point)

Deleting a Feature Line Elevation Point
Use the Delete Elevation Point command to delete an elevation point (page 2773).
Click to select the point to delete, or enter All to delete all elevation points.
To delete a feature line elevation point
1 Click Modify tab ➤ Edit Elevations panel ➤ Delete Elevation Point

.

2 Select the feature line or other object.
3 Click to select the elevation point to delete. Or enter All to delete all elevation points.

Quick Reference
Ribbon
Click Modify tab ➤ Edit Elevations panel ➤ Delete Elevation Point
Menu
Grading menu ➤ Edit Feature Line Elevations ➤ Delete Elevation Point
Command Line
DeleteElevPoint
Supported Objects
■

Feature lines

■

Parcel lines

■

Survey figures

Inserting a High or Low Elevation Point
Inserts a high or low elevation point onto a feature line, survey figure, parcel line, or 3D polyline.
This command inserts the break point where two grades intersect. Specify the grade or slope ahead from the
start point and back from the end point.
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To insert a high or low feature line elevation point
1 Click Modify tab ➤ Edit Elevations panel ➤ Insert High/Low Elevation Point

.

2 Select the feature line or other object.
3 Select the start point and the end point of the span that you want to add the point to. These points
can span multiple feature line segments.
After you select the start and end points, an arrow is displayed at the start of the span. The command
line displays the start and end elevations and the distance between the start and end points.
4 Enter the grade (or enter Slope and specify a slope) from the start point.
Enter a positive value to grade up or a negative value to grade down.
5 Enter the grade back from the end point.
NOTE If an intersection cannot be found with the entered values a “No solution found” message is displayed.

Quick Reference
Ribbon
Click Modify tab ➤ Edit Elevations panel ➤ Insert High/Low Elevation Point
Menu
Grading menu ➤ Edit Feature Line Elevations ➤ Insert High/Low Elevation Point
Command Line
InsertFeatureHighLowPoint
Supported Objects
■

Feature lines

■

Parcel lines

■

Survey figures

■

3D polylines

Setting Feature Line Elevations from a Surface
Use the Elevations From Surface command to assign the elevations of a surface to the geometry points of
one or more feature lines, parcel lines, survey figures, or 3D polylines.
Elevations are assigned to each vertex. You can include intermediate elevation points at any break points
along the surface. Elevations obtained from the surface are not dynamic.
To set feature line elevations from a surface
1 Click Modify tab ➤ Edit Elevations panel ➤ Elevations From Surface

.

2 In the Set Elevations From Surface (page 2136) dialog box, select a surface.
3 Select the Insert Intermediate Grade Break Points check box to insert intermediate grade breaks where
the entity crosses surface TIN lines. Elevation points are created at these locations.
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4 Click OK.
5 Do one of the following:
■

Select the feature line or other object.

■

Enter Multiple, and then select multiple objects.

■

Enter Partial, and then define a portion of the feature line to assign elevations to.

6 The feature line is assigned the elevations of the underlying surface. To edit these elevations, see Editing
the Elevations of a Feature Line (page 818).

Quick Reference
Ribbon
Click Modify tab ➤ Edit Elevations panel ➤ Elevations From Surface
Menu
Grading menu ➤ Edit Feature Line Elevations ➤ Elevations From Surface
Command Line
FeatureElevsFromSurf
Supported Objects
■

Feature lines

■

Parcel lines

■

Survey figures

■

3D polylines

Inserting Feature Line PIs
Use the Insert PI command to insert points of intersection on a feature line.
Points of intersection break the existing horizontal geometry of the feature line. You can use this command
to convert a split point into a geometry point for editing.

Split points are created when two feature lines cross and neither has a geometry point. A split point cannot
be edited as it is controlled by the grades of the two crossing segments which must have the same elevation
at the crossing point. If their elevations are different, a grade break will be inserted into one to match the
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elevation of the other. If the feature lines have the same style or no styles are assigned, the segment that is
modified last will become dominant, causing the other segment to break at that point. Use the Insert PI
command to create a vertex at the split point so that you can have direct control over the elevation at that
point.
To insert points of intersection into feature lines
1 Click Modify tab ➤ Edit Geometry panel ➤ Insert PI

.

2 Select the feature line or other object.
Temporary graphics are drawn on screen.

3 Click to insert the PI.
4 Enter Distance. Then specify a distance from the start point at which a PI point along the feature line
is inserted.
5 Enter Increment. Specify distance between points, then click the feature line to to automatically insert
PI points separated by the specified distance. As this command inserts multiple points, the elevation
for each point will be determined by the existing elevation of the feature line at each point.
6 Do one of the following:
■

Enter the elevation for the point.

■

Enter Surface to obtain the elevation from a surface in the drawing.

NOTE You are not prompted for the elevation if the object you selected is a 3D polyline.

To insert points of intersection into a crossing point
1 Click Modify tab ➤ Edit Geometry panel ➤ Insert PI

.

2 Use OSNAP to select the intersection point.
Temporary graphics are drawn on screen.
3 Click to insert the PI.

Quick Reference
Ribbon
Click Modify tab ➤ Edit Geometry panel ➤ Insert PI
Menu
Grading menu ➤ Edit Feature Line Geometry ➤ Insert PI
Command Line
InsertFeaturePI
Supported Objects
■

Feature lines
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■

Survey figures

■

3D polylines

■

2D polylines

Deleting Feature Line PIs
Deletes a selected vertex on a feature line, survey figure, polyline, or 3D polyline.
Use this command to delete points of intersection from feature lines.
To delete points of intersection from feature lines
1 Click Modify tab ➤ Edit Geometry panel ➤ Delete PI

.

2 Click the feature line or other object near the PI you want to delete.

Quick Reference
Ribbon
Click Modify tab ➤ Edit Geometry panel ➤ Delete PI
Menu
Grading menu ➤ Edit Feature Line Geometry ➤ Delete PI
Command Line
DeleteFeaturePI
Supported Objects
■

Feature lines

■

Survey figures

■

3D polylines

■

2D polylines

Joining Feature Lines
Use the Join command to join connecting feature lines, polylines, or 3D polylines into one feature line or
survey figure.
Select the two lines. They are joined if they lie within the tolerance distance set in JoinFeatures (page 801)
command settings.
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To join feature lines
1 Click Modify tab ➤ Edit Geometry panel ➤ Join

.

2 Select the feature line you want to join other lines to.
3 Select the joining object or enter Multiple to make a selection of multiple feature lines, polylines, or
3D polylines.

Quick Reference
Menu
Click Modify tab ➤ Edit Geometry panel ➤ Join

.

Menu
Grading menu ➤ Edit Feature Line Geometry ➤ Join.
Command Line
JoinFeatures
Supported Objects
■

Feature lines

■

Survey figures

■

2D polylines

■

3D polylines

Reversing Feature Lines
Use the Reverse command to change the direction of feature lines.
This command affects labeling and stationing of feature lines.
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To reverse feature lines
1 Click Modify tab ➤ Edit Geometry panel ➤ Reverse

.

2 Select the feature line or other object.
3 Select additional feature lines that you want to reverse. Or, press Enter to end the command.
NOTE Use Zoom to see the directional arrows that display on each segment.

Quick Reference
Ribbon
Click Modify tab ➤ Edit Geometry panel ➤ Reverse
Menu
Grading menu ➤ Edit Feature Line Geometry ➤ Reverse
Command Line
ReverseFeature
Supported Objects
■

Feature lines

■

Survey figures

■

3D polylines

■

2D polylines

■

Lines

Editing Feature Line Curves
Use the Edit Curve command to edit the radius of feature line (or survey figure) arcs.
When the radius is changed, the new arc is displayed and the existing arc is indicated with dashed
highlighting.
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To edit feature line curves
1 Click Modify tab ➤ Edit Geometry panel ➤ Edit Curve

.

2 Select the curve to edit. The curve is highlighted, and the points are displayed.
3 In the Edit Feature Line Curve (page 2138) dialog box, edit the curve. Use the Radius edit box to specify
the radius.
4 Use the Maintain Tangency option to control the curve tangency state.

The curve is highlighted and the arc
start, center and end points are
displayed with glyphs.

When the radius is changed, if the arc is tangent to the segments on either side, the tangency is
maintained. Before selecting OK in the Edit Feature Line Curve dialog box, the new arc is displayed. At
the same time, the existing arc remains visible with the dashed highlighting.

The start and end points remain constant
if the arc is not tangent.
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If the arc is not tangent, the start and end points of the arc are held when the radius is changed.

If the curve is not tangent, the Maintain Tangency button is activated. If you toggle this button the
curve will be adjusted to make it tangent to the adjacent segments. If the curve is tangent, the button
is disabled.

NOTE When the Delete option is selected, the segments on either side of the curve are extended to an
intersection point.
Segments extend to intersection point.

Quick Reference
Ribbon
Click Modify tab ➤ Edit Geometry panel ➤ Edit Curve
Menu
Grading menu ➤ Edit Feature Line Geometry ➤ Edit Curve
Command Line
EditFeatureCurve
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Supported Objects
■

Feature lines

■

Survey figures

■

3D polylines

■

2D polylines

■

Lines

Filleting Feature Lines
Fillets a feature line, survey figure, or 3D polyline.
This command can be used to round the corners of feature lines. The fillet can span multiple segments and
can be used to join two connecting feature lines.

To fillet feature lines
1 Click Modify tab ➤ Edit Geometry panel ➤ Fillet

.

2 Select the feature line or other object.
The currently specified radius is displayed at the command line.
3 Do one of the following:
■

Select the corner to fillet. When you move your mouse over the feature line, a triangle highlights
the corners that can be filleted and the current radius value is displayed.
Single corner fillet

Multiple corner fillet
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■

Enter Radius to specify a different radius.

■

Enter All to fillet all corners.

■

Enter Join to join a connecting feature line and then select the feature line.

Quick Reference
Ribbon
Click Modify tab ➤ Edit Geometry panel ➤ Fillet
Menu
Grading menu ➤ Edit Feature Line Geometry ➤ Fillet
Command Line
FilletFeature
Supported Objects
■

Feature lines

■

Survey figures

■

3D polylines

Converting Tessellated Lines to Arcs
Fits a curve from a selection of vertices with a feature line, survey figure, parcel, or 3D polyline
Use this command to convert tessellated lines to true arcs, or to add fillets to straight segments. You can
specify start and end points or set options for automatic arc generation.

Tessellation occurs when you convert a 2D polyline with arcs to a 3D polyline. It also occurs when you
export feature lines with arcs from corridor models.
Grading created from tessellated footprint (left) compared with grading
created from arc (right)
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Feature line points that define a grade break are inserted as elevation points on the arc when using this
command.
There are three ways to select the segments to turn into arcs.
■

Automatic selection: As you move your mouse over the feature line, arcs appear where they can be
inserted. Click your mouse to insert the arc.

■

Specifying start and end points over multiple segments: Use this method to define an arc using specified
start and end points.

■

Specifying start and end points for a single segment: Use this method to replace a single segment (such
as a chamfered corner) with an arc. If the corner is asymmetrical, two arcs are inserted that are tangent
to the line segments and to each other.

You can specify the command options by editing the FitCurveFeature command settings, or by using the
Options keyword when running the Fit Curve command.
To fit a curve
1 Click Modify tab ➤ Edit Geometry panel ➤ Fit Curve

.

2 Select the feature line or other object.
3 Do one of the following:
■

Move your mouse over the feature line. Arcs appear where they can be inserted. Click your mouse
to insert an arc.

■

Enter Points (P). Then select the start and end point on the feature line for the arc location. This
option ignores the minimum number of segments setting.
If the start and end points span more than one segment but the points do not define an arc, an error
message is displayed indicating that an arc cannot be created between the specified points. This
error occurs if the segments do not all curve in the same direction or if there is a straight segment
that is composed of multiple small segments (which therefore have no deflection angle).
NOTE If the segments can define an arc but are not within the tolerance, you are prompted with an
option to override the tolerance setting and insert the arc.

■

Enter Options (O) to display the Fit Curve (page 2135) dialog box where you can change the tolerance
and minimum number of segments settings.
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Quick Reference
Ribbon
Click Modify tab ➤ Edit Geometry panel ➤ Fit Curve
Menu
Grading menu ➤ Edit Feature Line Geometry ➤ Fit Curve
Command Line
FitCurveFeature
Supported Objects
■

Feature lines

■

Survey figures

■

3D polylines

■

2D polylines

Smoothing Feature Lines
Use to replace feature line segments with arcs.
Use this command to smooth feature lines that were created from tessellated polylines. Select the Straighten
option command to restore straight lines.

Before and after smoothing
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When you select the object after smoothing, red tangent lines extend from the grips at the ends of the
feature. You may need to zoom into the end to see them.
Zoom in to end of feature line to see grip

You can use these grips to adjust the arc directions at the start and end of the feature line.
Select and move grip to adjust arc direction

Zoomed out view showing arc adjustment

To smooth feature lines
1 Click Modify tab ➤ Edit Geometry panel ➤ Smooth

.

2 Select the feature line(s) to smooth or straighten.
3 Do one of the following:
■

Press Enter to smooth the lines.

■

Enter Straighten to straighten lines that were previously smoothed.

Quick Reference
Ribbon
Modify tab ➤ Edit Geometry panel ➤ Smooth
Menu
Grading menu ➤ Edit Feature Line Geometry ➤ Smooth
Command Line
SmoothFeature
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Supported Objects
■

Feature lines

Weeding Vertices
Use the Weed Vertices command to reduce the number of vertices on a feature line.
Vertices are weeded if found to be unnecessary for line location, based on weeding factors of angle, grade,
length, and 3D distance. Points selected for weeding are highlighted in red.

The weeding factors delete vertices that:
■

Are closer together in 2D space to their two neighboring vertices than the Length factor.

weeding length factor (plan view)
possible vertex to be deleted

L
if L < length factor, then the vertex will be deleted

■

Have a 2D deflection angle that is less than the Angle factor.

weeding angle factor (plan view)

possible vertex to be
deleted

if angle < angle factor, then the vertex will be deleted
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■

Have a difference in grade that is less than the Grade factor.

weeding grade factor (profile view)

G1 %
G2

%

possible vertex to be deleted

if the difference between G1 and G2 < grade factor,
then the vertex will be deleted

■

Are closer together in 3D space to their two neighboring vertices than the 3D Distance factor.

weeding 3D distance factor (profile view)

D

possible vertex to be deleted

if D is < 3D distance factor, then the vertex will be deleted

Larger factors weed more vertices.
You can choose which factors you want to be used to calculate the weeding. For example, if you only want
to apply a length factor, select the Length check box and specify a length, and clear all other check boxes.
You can set the defaults to be used for this command by editing the WeedFeatures command settings.
To weed vertices
1 Click Modify tab ➤ Edit Geometry panel ➤ Weed

.

2 Do one of the following:
■

Select the feature line or other object.

■

Enter Multiple and then select multiple objects to weed.

■

Enter Partial and then select the object and the portion of the object to weed.

The vertices of the object(s) you selected are highlighted with green triangles and the Weed Vertices
(page 2133) dialog box is displayed.
3 Select the check boxes for the weeding factors that you want to apply and specify the values to use.
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When you specify a value that will delete a vertex, that vertex is highlighted in red in the drawing, and
a message is displayed in the dialog box indicating how many vertices will be deleted. After you change
a value, press Tab to update the message and the drawing display.
Points selected for weeding are
highlighted in red

4 Click OK to delete the vertices.

Quick Reference
Ribbon
Click Modify tab ➤ Edit Geometry panel ➤

Weed

Menu
Grading menu ➤ Edit Feature Line Geometry ➤ Weed
Command Line
WeedFeatures
Supported Objects
■

Feature lines

■

2D polylines

■

3D polylines

Creating a Stepped Offset
Creates a new feature line from an offset and difference in elevation from a selected feature line, survey
figure, polyline, or 3D polyline.
Specify the offset distance, the side, and elevational difference or absolute elevation.
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To create a stepped offset by specifying a distance
1 Click Home tab ➤ Create Design panel ➤ Feature Line drop-down ➤ Create Feature Line From Stepped
Offset

.

2 Do one of the following to specify the location for the offset:
■

Specify the offset distance, then select the object to offset.

■

Enter Through, then select the object to offset and select a through point. The offset will be drawn
through this point.

3 Do one of the following:
■

Specify a point on the side where you want to place the offset. Then specify the elevational difference
or the absolute elevation for the offset.

■

Enter Multiple and specify the side and elevational difference for each offset.

If you enter Variable, it will display a marker at the first point on the offset feature line. You can specify
the elevation difference from the original point or the absolute elevation. After you enter a value, it
will move to the next point and prompt for its elevation. It will continue to do this for each point on
the feature line until you end the command.
4 Select another object to offset, or press Enter to end the command.

Quick Reference
Ribbon
Click Home tab ➤ Create Design panel ➤ Feature Line drop-down ➤ Create Feature Line From Stepped
Offset
Menu
Grading menu ➤ Edit Feature Line Geometry ➤ Stepped Offset
Command Line
OffsetFeature
Supported Objects
■

Feature lines

■

Survey figures

■

3D polylines

■

2D polylines

Breaking a Feature Line
Use the Break command to break a feature line into two feature lines.
The prompts for this command are similar to the AutoCAD Break command.
Click two points to specify both sides of the break. By default, the point at which you select the feature line
is the first break point, or enter First to select a different break point.

Breaking a Feature Line | 849

To break a feature line
1 Click Modify tab ➤ Edit Geometry panel ➤ Break

.

2 Select the feature line to break:
3 Specify the second break point.
NOTE if you enter the @ character at the prompt for the second break point, it uses the first point location,
creating a break without a gap.

Quick Reference
Ribbon
Click Modify tab ➤ Edit Geometry panel ➤ Break
Menu
Grading menu ➤ Edit Feature Line Geometry ➤ Break
Command Line
Break
Supported Objects
■

Feature lines

Trimming a Feature Line
Use this command to trim feature lines.
Use this command to trim feature lines so that they end precisely at boundary edges defined by other objects.
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To trim a feature line
1 Click Modify tab ➤ Edit Geometry panel ➤ Trim

.

2 Select the objects to serve as cutting edges.
3 Select the feature line(s) to trim.

Quick Reference
Ribbon
Click Modify tab ➤ Edit Geometry panel ➤ Trim

.

Menu
Grading menu ➤ Edit Feature Line Geometry ➤ Trim
Command Line
Trim
Supported Objects
■

Feature lines

Adding a Feature Line to a Surface as a Breakline
Adds feature lines to a surface as breakline data.
Use this command to select one or more feature lines from a drawing and add them to a surface. You can
use breaklines to define features, such as retaining walls, curbs, tops of ridges, and streams.
When this command is selected, it will prompt for the surface, then prompt with the Add Breaklines dialog
box.
To add a feature line to a surface as breakline
1 Right-click a feature line ➤ Add To Surface As Breakline.
NOTE If there are no surfaces in the drawing, you are prompted to create one.
2 In the Select Surface dialog box, select a surface, and press OK. Or, select the Add button to create a
new surface.
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3 In the Add Breaklines (page 2615) dialog box, specify the breakline options. Press OK.
NOTE If you list a feature line or view its properties, you will see the names of the surfaces and breakline
collections that the feature line is part of.

Quick Reference
Ribbon
Select a feature line. Click Feature Line tab ➤ Modify panel ➤ Add To Surface As Breakline
Toolspace Shortcut Menu
Right-click feature line ➤ Add to Surface as Breakline

Labeling Feature Lines
Creates line or curve labels on a feature line or survey figure.
You can label single and multiple segments of feature lines by using specified line and curve label styles.

On the Toolspace Settings tab, in the General Label Style collection, set up Line and Curve label styles (page
1659) to use for the feature lines.
On the Toolspace Settings tab, in the General Label Style collection, specify the default line label style (page
1655).
Use the Single Segment or Multiple Segment command to quickly label a feature line using the default label
style.
Use the Add Feature Line Labels option to access the Add Labels (page 2208) dialog box if you need to create
or modify a style before labeling a feature line.

Labeling Individual Feature Line Segments
Creates line or curve labels on a selected feature line or survey figure segment.
You can label single feature line segments, one at a time, with specified Line and Curve label styles.
To label individual feature line segments
1 Click Annotate tab ➤ Labels & Tables panel ➤ Add Labels menu ➤ Feature Line ➤ Single Segment
.
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2 Select the feature line or segment to label.
OR
1 Click Annotate tab ➤ Add Feature Line Labels ➤ Labels & Tables panel ➤ Feature Line ➤ Add Feature
Line Labels
2 In the Add Labels dialog box (page 2208), under Feature, ensure that Line And Curve is selected.
3 Under Label Type, select Single Segment.
4 Specify the other options as required.
5 Click Add and then select the feature line or segment to label.

Quick Reference
Ribbon
Click Annotate tab ➤ Labels & Tables panel ➤ Add Labels menu ➤ Feature Line ➤ Single Segment
Menu
Grading ➤ Add Feature Line Labels ➤ Single Segment
Grading ➤ Add Feature Line Labels ➤ Add Feature Line Labels

Labeling Multiple Feature Line Segments
Creates line or curve labels on multiple line or curve objects, feature lines, or survey figure segments.
You can label multiple feature line segments with specified Line and Curve label styles.
To label multiple feature line segments
1 Click Annotate tab ➤ Labels & Tables panel ➤ Add Labels menu ➤ Feature Line ➤ Multiple Segments
.
2 Select the feature lines or segments to label.
OR
1 Click Annotate tab ➤ Labels & Tables panel ➤ Add Labels button

.

2 In the Add Labels dialog box (page 2208), under Feature, ensure that Line And Curve is selected.
3 Under Label Type, select Multiple Segment.
4 Specify the other options as required.
5 Click Add and then select the feature lines or segments to label.

Quick Reference
Ribbon
Click Annotate tab ➤ Labels & Tables panel ➤ Add Labels menu ➤ Feature Line ➤ Multiple Segments
Click Annotate tab ➤ Labels & Tables panel ➤ Add Labels button
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Menu
Grading ➤ Add Feature Line Labels ➤ Multiple Segments
Grading ➤ Add Feature Line Labels ➤ Add Feature Line Labels

Editing Polylines
You can use the Polyline Utilities to convert between types of polylines and to assign elevations to 2D
polylines.

Converting 2D Polylines to 3D
Use the Convert 2D To 3D Polylines command to convert 2D to 3D polylines.
Use this utility if you need to modify the elevations of individual vertices of a 2D polyline. 2D polylines are
coplanar objects. You can assign elevations to 3D polylines with the feature line elevation commands.
To convert 2D polylines to 3D polylines
1 Click Modify tab ➤ Design panel

Convert 2D To 3D Polylines

.

2 Select the polyline(s) to convert. Press Enter.

Quick Reference
Ribbon
Modify tab ➤ Design panel

Convert 2D To 3D Polylines

Menu
Grading menu ➤ Polyline Utilities ➤ Convert 2D To 3D Polylines
Command Line
ConvertPlines
Supported Objects
■

2D polylines

Converting 3D Polylines to 2D
Use the Convert 3D To 2D Polylines command to convert 3D to 2D polylines.
The new polyline will take on the elevation of the start point of the 3D polyline.
To convert 3D polylines to 2D polylines
1 Click Modify tab ➤ Design panel

Convert 3D To 2D Polylines

2 Select the polyline(s) to convert. Press Enter.
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.

Quick Reference
Ribbon
Modify tab ➤ Design panel

Convert 3D To 2D Polylines

Menu
Grading menu ➤ Polyline Utilities ➤ Convert 3D To 2D Polylines
Command Line
Convert3dPolys
Supported Objects
■

3D polylines

Editing Polyline Elevations
Use the Edit Polyline Elevations to specify an elevation for a 2D polyline.
This command is useful for editing polylines that are being used as contours.
To edit polyline elevations
1 Click Modify tab ➤ Design panel

Edit Polyline Elevations

.

2 Select the polyline.
3 Specify the elevation. All vertices are assigned the same elevation.

Quick Reference
Ribbon
Modify tab ➤ Design panel

Edit Polyline Elevations

Menu
Grading menu ➤ Polyline Utilities ➤ Edit Polyline Elevations
Command Line
EditPlineElevs
Supported Objects
■

2D polylines

Creating Grading
You can use the Grading Creation Tools to create grading from a footprint or to copy the criteria and style
from another grading.
Use the tools to specify the grading group and criteria and then use the Create Grading options.
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Creating Grading from a Footprint
Before you create grading, you need to select a grading group to associate the grading objects with. After
you create a grading object, you can move it to a different grading group within the same site.
Feature lines and grading are created by default on the layers specified by the drawing settings (page 2076).
Use the Grading Creation Tools (page 2114)to specify the grading criteria and style for the grading. Then create
the grading by selecting the footprint from which the grading is projected. Command prompts vary,
depending on the values that have been set in the grading criteria. For example, if the criteria has a target
of Distance, which is not locked (page 804), you are prompted to enter a number for the distance.
See also:
■

Changing Grading Command Settings (page 801)

To create grading from a footprint
1 Click Home tab ➤ Create Design panel ➤ Grading drop-down ➤ Grading Creation Tools
2 Click

and specify the grading group. Or create a new group.

3 Click

to override the layer setting and then specify the layer for the grading.

.

4 Select a grading criteria for the grading from the list.
If you have more than one set of named grading criteria, click
want.

to select the grading criteria set you

5 If the criteria you selected uses Surface as its target, specify which surface to target. The selected surface
is displayed in the status bar of the layout toolbar. To select a different surface, click

.

6 Select a grading style for the grading to use from the drop-down list.
If you don’t see the style selector, click
7 Click the arrow

to display the list of styles.

and then click Create Grading.

8 Click the footprint in the drawing. If you select a line, arc, or polyline, you are prompted to convert it
to a feature line.
9 Click in the drawing to indicate the side of the footprint that you want to apply the grading. If you are
grading from another grading’s daylight line, you are not prompted for the grading side because only
one side is available.
10 Specify whether the grading should be applied to the entire length of the line. To apply the grading to
a subset of the line, enter n, then follow the command line prompts and on-screen arrows to specify
the start and end points on the footprint.
Depending on the criteria definition, you may be prompted to specify a distance and a slope value. For
more information about the various options, see Criteria Tab (Grading Criteria Dialog Box) (page 2105).
11 Respond to any remaining prompts to complete the grading.
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Quick Reference
Ribbon
Home tab ➤ Create Design panel ➤ Grading drop-down ➤ Grading Creation Tools
Menu
Grading menu ➤ Create Grading
Command Line
CreateGrading
Dialog Box
Grading Creation Tools (page 2114)

Creating Grading by Copying an Existing Grading
Copy the criteria and style from an existing grading and apply it to a grading you create.
After selecting the grading from which to copy the criteria and style, create the new grading by selecting
the footprint from which the grading is projected and selecting the side of the footprint from which to
grade.
To create grading by copying an existing grading
1 Click Home tab ➤ Create Design panel ➤ Grading drop-down ➤ Grading Creation Tools
2 In the Grading Creation Tools (page 2114) dialog box, click the arrow next to
Grading.

. Click

.
Copy Create

3 In the drawing, select the grading from which you want to copy the criteria and style.
4 Select the footprint in the drawing and select the side of the footprint from which to grade.
If you are grading from another grading’s daylight line, you are not prompted for the grading side
because only one side is available.
5 Click in the drawing to indicate the side of the footprint to which you want to apply the grading.
Depending on the criteria definition, you may have to specify a distance and a slope value. For more
information about the various options, see Criteria Tab (Grading Criteria Dialog Box) (page 2105).
6 Specify whether you want to apply the grading to the entire length of the line. To apply the grading
only to a region, enter n and then specify the start and end points on the footprint that define the
region.
7 Respond to any remaining prompts to complete the grading.

Quick Reference
Ribbon
Home tab ➤ Create Design panel ➤ Grading drop-down ➤ Grading Creation Tools
Menu
Grading menu ➤ Create Grading

Creating Grading by Copying an Existing Grading | 857

Command Line
CopyCreateGrading
Dialog Box
Grading Creation Tools (page 2114)

Editing Grading
You can edit either grading criteria or the elevations of the footprint or daylight line using edit commands
on the Grading menu or the Grading Creation Tools.
Use the Grading Editor (Panorama) to edit unlocked criteria values for a grading object, the Grading Elevation
Editor (Panorama) for feature lines and parcel lines, and additional commands for specific editing operations.
You can also use grips to edit grading.

Editing Grading Criteria
Edit a grading object with the Grading Editor vista.
Use the Grading Editor to change the unlocked criteria values for a grading object.
You can make changes to a sequence of grading objects, selecting them one after another with a single click.
You can also edit a single grading object with the Edit Grading (page 859) command, by entering the new
criteria values on the command line.
To edit grading criteria
1 Select the grading. Click Grading tab ➤ Modify panel ➤ Grading Editor

.

2 In the drawing, select a grading.
The name of the criteria that is applied to the grading appears in the dialog box.
3 Edit the criteria for the grading.
For more information about the values that you can set for grading criteria, see Criteria Tab (Grading
Criteria Dialog Box) (page 2105).

Quick Reference
Ribbon
Select the grading. Grading tab ➤ Modify panel ➤ Grading Editor
Menu
Grading menu ➤ Edit Grading ➤ Grading Editor
Toolspace Shortcut Menu
Settings tab: Right-click Grading Criteria item ➤ Edit
Command Line
GradingEditor
Dialog Box
Grading Criteria (page 2104)
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Editing Grading Criteria (Command Line)
Changes unlocked criteria values for a selected grading object using the command line.
Use the Grading Editor (page 858) to edit a sequence of grading objects by selecting them one after another
with a single click.
To edit grading criteria on the command line
1 Select the grading. Click Grading tab ➤ Modify panel ➤ Edit Grading

.

2 In the drawing, select a grading.
3 In response to the prompts, edit the criteria for the grading.
The prompts that you see for a particular grading object depend on the criteria that the grading currently
uses. For more information about the values that you can set for grading criteria, see Criteria Tab
(Grading Criteria Dialog Box) (page 2105).

Quick Reference
Ribbon
Select the grading. Grading tab ➤ Modify panel ➤ Edit Grading
Menu
Grading menu ➤ Edit Grading ➤ Edit Grading
Command Line
EditGrading

Inserting a Transition
Add a transition to fill an area between two existing grading objects or to create a grading that has
transitioning values.
A transition is an area that merges the grading of the regions on either side, for example, from 3:1 to 2:1.

There are several ways to create transitions:
■

You can select a location within an existing grading.
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existing grading

transition inserted

■

You can select a location between two existing gradings. The transition start and end points are defined
by the existing projection lines.

existing grading

transition inserted

■

You can select start and end points for the transition and then define the parameters to use at each end.
You can use the same criteria for both ends or you can switch criteria.

In addition, you are sometimes prompted to create transitions when you use the Create Grading command.
This occurs when the start point of a new grading is inside or touching an existing grading.
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new grading insertion point

grading inserted and transitions created

To insert a transition between existing gradings
1 Click Home tab ➤ Create Design panel ➤ Grading drop-down ➤ Grading Creation Tools
2 Click the arrow next to

. Click

.

Create Transition.

3 Select the feature line.
4 Click the location where you want to add the transition (between two existing regions).
The transition is added and the grading is updated.
To insert a transition within an existing grading
1 Click Home tab ➤ Create Design panel ➤ Grading drop-down ➤ Grading Creation Tools
2 Click the arrow next to

. Click

.

Create Transition.

3 Select the feature line.
4 Enter Points.
5 Select the grading side.
6 Select the location where you want to add the transition (within an existing grading). The station of
the point you selected is displayed at the command line. You can change it or press Enter to accept the
location.
The transition is added and the grading is updated.
To insert a transition by defining different criteria and values
1 Click Home tab ➤ Create Design panel ➤ Grading drop-down ➤ Grading Creation Tools
2 Click the arrow next to

. Click

.

Create Transition.

3 Select the feature line.
4 Enter Points.
5 Select the grading side.
6 Select the location where you want to add the transition. The station of the point you selected is
displayed at the command line. You can change it or press Enter to accept the location.
7 Follow the prompts to define the criteria values for the start of the transition.
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After you define the values, the following prompt is displayed:
Select the end point or [Criteria/Next/Previous/Both/Length]:

8 Do one of the following:
■

Select the end point by clicking a location in the drawing. Then follow the prompts to define the
criteria values for the end point.

■

Enter Length to specify a length for the transition. Then follow the prompts to define the criteria
values for the end point.

■

Enter Criteria and select a different criteria to apply to the end point of the transition. If you select
a criteria that is different from the criteria applied to the start point, the two are blended to create
the transition.
NOTE The following three options are available only if other gradings exist on the footprint.

■

Enter Next to define the transition end point as the edge of the next grading on the footprint (up
station).

■

Enter Previous to define the transition end as the edge of the previous grading on the footprint
(down station).

■

Enter Both to straddle the grading transition between the next and previous grading edges on the
footprint. This option overrides the selected start point.

Quick Reference
Ribbon
Click Home tab ➤ Create Design panel ➤ Grading drop-down ➤ Grading Creation Tools
Command Line
CreateGradingTransition
Dialog Box
Grading Creation Tools (page 2114)

Filling a Void Area
Fill a hole in the site grading by creating a grading with no criteria applied to it.
Any area bounded by feature lines or lot lines that is not already a grading should be converted to an infill
grading to ensure correct contour display and volume calculations.
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To fill a void area
1 Click Home tab ➤ Create Design panel ➤ Grading drop-down ➤ Grading Creation Tools
2 Click the arrow next to

. Click

.

Create Infill.

3 Click the area that you want to fill. Valid areas that can be converted to infill are highlighted as you
move the cursor over them.
The grading face is added and the grading is updated.

Quick Reference
Ribbon
Click Home tab ➤ Create Design panel ➤ Grading drop-down ➤ Grading Creation Tools
Command Line
CreateGradingInfill
Dialog Box
Grading Creation Tools (page 2114)

Editing with Grips
Use grips to adjust the component lines in a grading by changing the footprint geometry or the grading
components.
Click a projection line in a region. Then change the start or end station point for that region by using a grip
to drag the line to another location.
Component

Description

Feature lines

Grip appears at each vertex. Move the grip as you would when
you edit a polyline.

Projection lines

Grip appears on projection lines. Slide the projection line along
the footprint to change the start or end point of the region.

Elevation points

Grip appears at any location on a feature line or lot line to mark
an intermediate elevation point. Move the point to its correct
location.
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To edit using grips
1 In the drawing, select the grading or feature line you want to edit.
2 Click the grip. The grip turns red to show it is active
3 Drag the grip to move the line.
Grips do not appear on grading component lines that are constrained or locked by the grading criteria.

Deleting Gradings
Use the Delete Gradings command to delete a grading.
Surfaces based on deleted grading objects remain in the drawing.
To delete a grading
1 Select the grading. Click Grading tab ➤ Modify panel ➤ Delete Grading

.

2 Select a point in the grading or site to delete the grading object.

Quick Reference
Ribbon
Select the grading. Grading tab ➤ Modify panel ➤ Delete Grading
Menu
Grading menu ➤ Edit Grading ➤ Delete Grading
Command Line
DeleteGradings
Supported Objects
■

Feature lines

■

Parcel lines

■

Survey figures

Grading Properties
You can view and change grading group and grading properties.

Grading Group Properties
Edits grading group properties.
These properties can be used to create the grading group and to control the surface properties of the grading
group.
If you chose not to create a dynamic surface for the grading group when you created it, use the Grading
Group Properties to create this surface. You can also specify the surface to use for volume calculations.
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To view and edit properties for a grading group
1 In Toolspace, on the Prospector tab, expand the Site collection.
2 Expand the Grading Groups collection. Right-click the grading group you want to edit.
3 Click Properties to open the Grading Group Properties (page 2113) dialog box.
4 Change the properties on the Information tab, or click the Properties tab to review the settings, styles,
criteria, and volumes for the grading group.
5 Click OK.

Quick Reference
Ribbon
Select the grading. Click Grading tab ➤ Modify panel ➤

Grading Group Properties

Toolspace Shortcut Menu
Prospector tab: Right-click Grading Group item ➤ Properties
Object Shortcut Menu
Right-click grading ➤ Grading Group Properties
Command Line
GradingGroupProperties
Dialog Box
Grading Group Properties (page 2113)

Grading Object Properties
Edits the properties of a grading object.
Changes the cut and fill styles and can be used to move a grading to another grading group.
To view and edit properties for a grading
1 Select the grading. Click Grading tab ➤ Modify panel ➤ Grading Properties drop-down ➤ Grading
Properties

.

2 In the Grading Creation Tools, click

.

3 In the drawing, click a grading to open the Grading Properties (page 2116) dialog box.
4 Change the styles or select a different grading group.
5 Click OK.

Quick Reference
Ribbon
Select the grading. Click Grading tab ➤ Modify panel ➤ Grading Properties drop-down ➤ Grading Properties
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Object Shortcut Menu
Right-click grading object ➤ Grading Properties
Command Line
GradingProperties
Dialog Box
Grading Properties (page 2116)

Feature Line Properties
Edits the properties of a feature line.
Changes the name and style assigned to a feature line. You can also view feature line statistics and breakline
data.
To change feature line properties
1 Right-click a feature line and click Feature Line Properties.
2 In the Feature Line Properties dialog box, click the Information Tab (page 2132).
3 Select the Name check box.
4 Enter a name or click

to edit the name template in the Name Template Dialog Box (page 2022).

5 Select the Style check box.
6 Select a style.
7 Click the Style Detail button to open the Style Detail dialog box. Preview the feature line style.
8 Click the Statistics tab (page 2133) to view feature line statistics and breakline data.

Quick Reference
Ribbon
Click Feature Line tab ➤ Modify panel ➤ Feature Line Properties drop-down ➤ Feature Line Properties
Object Shortcut Menu
Right-click feature line ➤ Feature Line Properties
Command Line
FeatureLineProperties
Dialog Box
Feature Line Properties (page 2132)

Feature Line Site Properties
Use the Feature Line Site Properties to view the combined statistics for all feature lines in the current site
and to resolve crossing feature line elevations by specifying style priority.
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Statistics
The Feature Line Site Properties dialog box Statistics tab displays the combined statistics for all feature lines
in the current site. The Grouped Statistics tab groups the site statistics by style and layer. The statistics cannot
be edited.

Feature Line Style Priority
The Feature Line Site Properties Options tab allows you to control the feature line style priority. The style
priority is used to control the feature line elevations at split point.
When two features, such as feature lines, lot lines or survey figures cross and neither feature has a geometry
point at that location, a split point is created. You cannot edit this point directly, as it is controlled by the
grades of the two crossing segments which must have the same elevation at the crossing point. If the two
elevations are different, a grade break is inserted into one to match the elevation of the other.
You can assign a priority to feature line styles so that when two feature lines with different styles cross, the
one with the higher priority will set the elevation. Feature lines without a style have the lowest priority.
NOTE If two feature lines have the same style or no style, then the feature line that is modified last becomes
dominant, causing the other feature line to break at that point. The last-edited feature line controls the elevation
at that point, which can cause undesirable results. To control the elevation at that point, use the Insert PI (page
834) command to create a vertex at the split point.
IMPORTANT Feature lines without a style applied can also assume the elevation of an alignment if they cross,
resulting in a vertex of zero at that point. If you find that any feature line has an elevation of zero be sure that you
have applied a style to that feature line. A feature line with a style applied will always take priority over an alignment,
and will not assume the alignment’s elevation.
To view current site feature line statistics
1 In Toolspace, on the Prospector tab, expand the site collection ➤ right-click Feature Lines and click
Properties.
2 Click the Statistics (page 2136) or Grouped Statistics Grouped Statistics (page 2137)tabs to view data about
the feature lines in the drawing.
To control the feature line style priority
1 In Toolspace, on the Prospector tab, expand the site collection ➤ right-click Feature Lines and click
Properties.
2 Click the Options (page 2137)tab.
The feature line styles are shown from highest to lowest priority.
3 Select the Filter Unused Styles check box to show only used styles.
4 You can drag and drop styles in the list or use the up/down arrows to specify priority.
NOTE When new styles are created, they are added to the end of the list.

Quick Reference
Object Shortcut Menu
In Toolspace, on the Prospector tab, right-click Feature Lines ➤ Properties
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Dialog Box
Feature Line Site Properties (page 2136)

Using Grading Utilities
You can use grading utilities to balance cut and fill volumes in a grading design, and to create a detached
surface from a grading group.

Displaying and Adjusting Surface Volumes
Use volume tools to display and adjust the elevation of a grading design.
You can change the elevation of either an entire grading group or a selection of grading objects. Use this
command to optimize cut and fill requirements.
A dynamic surface must exist for the grading group and a Volume Base Surface must be specified in the
Grading Group Properties to use most of the Grading Volume Tools.
TIP If you are designing a detention pond and want to size it by volume, it may help to create a temporary surface
to use as the Volume Base Surface for comparison. To do this, draw a polyline around the pond rim, assign it the
rim elevation, and add it as breakline data to a surface. When you use such a surface as the Volume Base Surface
for the grading group, you can more easily see how much volume the pond can contain.
To adjust cut and fill volumes
1 Click Analyze tab ➤ Volumes And Materials panel ➤ Grading Volume Tools
2 In the Grading Volume Tools (page 2121), click

.

.

3 In the Select Grading Group (page 2122) dialog box, select a grading group or create a new one.
4 Optionally, click

to review and change properties for the grading group.

NOTE If you do not see the information displayed in the Cut, Fill, and Net volumes boxes, check the Grading
Group Properties to ensure Automatic Surface Creation is selected and a Volume Base Surface is specified.
5 Select either Entire Group or Selection to identify the grading objects for which you want to raise or
lower to make the volume adjustments. For Selection, click

and select objects in the drawing.

6 In the numeric field in the upper right of the Grading Volume Tools, enter the distance (typically feet
or meters) by which the grading objects will be raised or lowered for each elevation adjustment.
7 Do one of the following:
■

To manually adjust the grading elevation, click
and net volume.

■

To automatically adjust the elevation to meet a net volume target, click
. Enter the target volume
in the Auto-Balance Volumes dialog box, then click OK. The elevation is adjusted several times,
getting as close to the target as possible.
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or

and note the changed values for cut, fill,

NOTE Automatic volume balancing is an iterative process, adjusting the gradings up or down in progressively
smaller steps to achieve the target volume. Typically the resulting volume is not exactly what was entered as the
target value. To prevent it from excessively adjusting and recomputing the volumes, it stops when the result is
within a tolerance of 0.1% of the starting net volume. If the result is not close enough to your target volume, you
can run the command again.

Quick Reference
Ribbon
Analyze tab ➤ Volumes And Materials panel ➤ Grading Volume Tools
Menu
Grading menu ➤ Grading Utilities ➤ Grading Volume Tools
Command Line
GradingVolumeTools

Creating a Detached Surface from a Grading Group
You can create a detached or static surface from a grading group.
A detached surface does not update to reflect changes to the grading group.
If the Automatic Surface Creation setting is selected for the grading group, it maintains a dynamic surface
that reflects changes.
If the grading group has a detached surface and a dynamic surface, it can be difficult to view and select one
of the surfaces unless they are on different layers and using different styles.
To create a detached surface
1 Click Home tab ➤ Create Ground Data panel ➤ Surfaces drop-down ➤ Create Surface From Grading
.
2 In the Select Grading Group (page 2122) dialog box, specify the site and the grading group.
3 Click OK. The detached surface is created.

Quick Reference
Ribbon
Home tab ➤ Create Ground Data panel ➤ Surfaces drop-down ➤ Create Surface From Grading
Menu
Grading menu ➤ Grading Utilities ➤ Create Detached Surface
Command Line
CreateDetachedGradingSurf

Grading Command Reference
The following table lists the grading-related commands and briefly describes their functionality.
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Run these commands by entering them directly at the command line.
Command

Description

AddFeatureLineLabels

Adds line and curve labels to feature lines (page 852)

AdjacentFeatureElevsByRef

Sets adjacent feature line elevations by reference (page
827)

ApplyFeatureLineNames

Applies names to feature lines (page 811)

ApplyFeatureLineStyles

Applies feature line styles (page 811)

BreakFeatures

Breaks a feature line into two feature lines (page 849)

ChangeGradingGroup

Changes the grading group of the selected grading
object (page 807)

Convert3dPolys

Converts 3D polylines to 2D polylines (page 854)

ConvertPlines

Converts 2D polylines to 3D polylines (page 854)

CopyCreateGrading

Creates grading by copying the criteria and style from
an existing grading (page 857)

CreateDetachedGradingSurf

Creates a static surface from a grading group. (page
869)

CreateFeatureLines

Creates a feature line by converting existing objects
(page 808)

CreateFeatureLineFromAlign

Creates a feature line by converting alignments (page
810)

CreateGrading

Creates grading from a footprint (page 856)

CreateGradingGroup

Creates a new grading group (page 806)

CreateGradingInfill

Fills a hole in the site grading with a grading face
(page 862)

CreateGradingTransition

Inserts a transition between two existing regions (page
859)

DeleteElevPoint

Deletes elevation points (page 832)

DeleteFeaturePI

Deletes points of intersection (page 836)

DeleteElevPoint

Deletes feature line elevation points (page 832)

DeleteGradings

Deletes a point in a grading or site (page 864)

DrawFeatureLine

Draws a feature line (page 813)

EditFeatureCurve

Edits feature line curves (page 838)
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Command

Description

EditFeatureElevs

Edits feature line or lot line elevations, using the
command line (page 818)

EditGrading

Edits grading criteria, using the command line (page
859)

EditPlineElevs

Edits elevations of 2D polylines (page 855)

FeatureElevsFromSurf

Creates feature line elevations from a surface (page
833)

FeatureGradeExtensionByRef

Extends a grading by reference (page 828)

FeatureLineProperties

Specifies feature line style (page 866)

FeatureLineRemLinks

Removes feature line dynamic links (page 812)

FilletFeature

Rounds the corners of feature lines (page 841)

FitCurveFeature

Converts tessellated curves to true arcs for better
grading results (page 842)

GradingEditor

Edits grading criteria, using the Editor (page 858)

GradingElevEditor

Edits feature line elevations, using the Grading Elevation Editor (page 818)

GradingTools

Opens the Grading Creation Tools (page 856)

GradingVolumeTools

Opens the Grading Volume Toolbar (page 868)

InsertFeatureElevPoint

Inserts an elevation point (page 830)

InsertFeatureHighLowPoint

Inserts high or low elevation points into feature lines
(page 832)

InsertFeaturePI

Inserts points of intersection (page 834)

JoinFeatures

Joins multiple feature lines to create a single object
(page 836)

OffsetFeature

Offsets feature lines at an elevational difference (page
848)

QuickEditFeatureElevs

Edits the elevations of a feature line by snapping to
editable points in the drawing (page 819)

RaiseLowerFeatures

Raises or lowers feature line elevations (page 829)

RaiseLowerFeaturesByRef

Raises or lowers feature line elevations by reference
(page 826)

ReverseFeature

Reverses the direction of feature lines for stationing
purposes (page 837)
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Command

Description

SetFeatureGrade

Specifies the grade or slope between selected points
on a feature line (page 823)

SetFeatureRefElev

Sets the feature line elevation in relation to an existing
elevation in the drawing (page 824)

SmoothFeature

Smooths out jagged feature lines (page 844)

TrimFeatures

Trims a feature line (page 850)

WeedFeatures

Deletes vertices and elevation points from feature lines
(page 846)
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Parcels

23

AutoCAD Civil 3D makes it easy to design subdivisions by providing a site topology that includes intelligent parcel objects,
which maintains relationships between objects so your design changes are dynamically updated.
Parcels Workflow (page 38)

Understanding Parcels
Parcel objects in AutoCAD Civil 3D are typically used to represent real estate parcels, such as lots in a
subdivision.
Parcel objects can also represent other features with closed boundaries, such as bodies of water and soil
regions.

Parcel Components
A parcel boundary is a closed polygon. The points where line segments join are called nodes. There are two
segment types: line and curve.
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Each parcel has an area label, which refers to the parcel as a whole. You can click the area label to select the
parcel. A parcel can also have segment labels, and associated tables, which display information about the
parcel. Labels can contain user-defined property fields.
Each parcel maintains information about its segments and nodes, and the area they enclose. Editing parcel
segments dynamically updates the parcel properties. Deleting a segment can result in one parcel merging
with another.

Parcel region before subdivision into individual lots

Parcel Collections
Parcels are contained in a parcels collection, which in turn is contained in a site.
A drawing can include any number of sites, but each site has only one parcels collection. No unique parcel
can belong to more than one site. You can see these relationships in the Sites collection in Toolspace, on
the Prospector tab:
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For more information about Parcels collections, see Parcels Collections (Prospector Tab) (page 878).
Parcels in a collection can be either unattached or touching, but they cannot overlap. If you attempt to
overlap two parcels, the region of overlap defines a third parcel. Similarly, if an alignment crosses a parcel,
it divides the parcel into two parcels. In the following illustration, before adding the alignment, the site was
all one parcel:

In situations that require overlapping parcels, such as overlaying a subdivision with soil regions, you can
put the subdivision parcels in one site and the soil region parcels in another site. Multiple sites can overlay
one another because their topologies are independent. Although everything within a site is topologically
related, sites are not topologically related to each other.
NOTE To prevent an alignment from changing a parcel, the two objects should be in different sites. To prevent
an alignment from interacting with any parcel objects, select <none> when prompted to select a site. See
Understanding Alignments (page 923).

Site Parcels
Associated with every site is a site parcel. The site parcel boundary is the outermost extent of a site, containing
all alignments, gradings, and parcels. Objects within a site parcel do not have to touch.
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The site parcel has an area label, which you can hide or show. You can control the color and line type of
the site parcel boundary, and you can control its draw order relative to the boundaries of the parcels that it
encloses.
For the purposes of calculating the area and perimeter of a site, an alignments area is zero and its perimeter
is twice the sum of its length. Adding an alignment does not affect a site parcels area, but can add to its
perimeter. If you add an alignment to an existing site
■

With none of the alignment overlaying the original site parcel, the site parcels perimeter increases by
twice the length of the alignment.

■

With all of the alignment overlaying the original site parcel, the site parcels perimeter does not increase.

■

With some of the alignment overlaying and some of it projecting, the site parcels perimeter increases by
twice the length of the part that projects.

In some circumstances, an unclosed sequence of parcel segments can define a valid parcel. With such a
parcel, as with an alignment, its area is zero, and its perimeter is twice the sum of its segment lengths.

Parcel Styles
Use styles to control the appearance of parcels, their labels, and their tables.
The Standard style is provided by default. Define additional styles as needed.
View the available parcel styles in the Parcels collection in Toolspace, on the Settings tab:
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For more information about the Parcel collection, see Parcel Collection (Settings Tab) (page 879).
There are separate label styles for parcel areas and parcel segments.

Parcel display style and two types of label

You can create, modify, copy, rename, or delete any style, including the Standard style, by right-clicking a
style in the Parcel tree and then clicking an item on the shortcut menu. Note, however, that you cannot
delete a style that is in use.
For more information
about ...

Follow this link ...

Setting up styles for a project

Setting up Parcels (page
39)

Parcel styles

Parcel Styles (page 894)

Parcel label styles

Parcel Label Styles (page
899)

Parcel table styles

Parcel Table Styles (page
910)
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Parcel Settings
Use Parcel settings to specify default styles and other default properties for new parcels.
To set or change parcel settings, go to the Toolspace Settings tree and right-click Parcels ➤ Edit Feature
Settings.
For more information about the Parcel collection, see Parcel Collection (Settings Tab) (page 879).
For more information about parcel settings, see Parcel Settings (page 891).

Parcel Properties
Use Parcel properties to view or edit details of existing parcels.
To view or edit parcel properties, go to the Toolspace Prospector tab, right-click a parcel and click Properties.
The following illustration shows two parcels: OPEN SPACE 100, and OPEN SPACE 101:

For more information parcel collections, see Parcels Collections (Prospector Tab) (page 878).
You can also right-click a selected parcel in a drawing, then click Parcel Properties. To select a parcel, click
the text of its area label. If you have selected it correctly, the label text and its anchor point are highlighted.
If the area label is not visible, see Hiding or Showing Parcel Labels (page 909).
For more information about parcel properties, see Parcel Properties (page 892).

Parcels Collections (Prospector Tab)
Use the Parcels collections in the Prospector tree to access the parcels in a drawing.
Each parcel in a site is displayed as a named object under the Parcels collection of the site. Right-click a
Parcels collection to do the following:
■

Edit properties of the collections site parcel (page 892).

■

Move or copy parcels to another site (page 789).

■

Zoom or pan to the collections site parcel in the drawing (page 885).

■

Generate a parcels report.

■

Export parcels to LandXML format.

■

Refresh the view of the Prospector tree.

Expand the Parcels collection to view the names of the parcels and to display a tabular list of the parcels in
the Toolspace item view. For more information, see The Toolspace Item View (page 99).
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Parcel Collection (Settings Tab)
Use the Parcel collection in the Settings tree to manage parcel settings, styles, and command settings.
Right-click the Parcel collection to do the following:
■

Edit parcel settings (page 891).

■

Edit parcel label style defaults (page 899).

■

Refresh the display of the Settings tree.

Expand the Parcel collection to display and edit the styles and command settings that are available for
parcels.
For more information Follow this link ...
about ...
Parcel Styles

Parcel Styles (page 894)

Parcel Label Styles

Parcel Label Styles (page
899)

Parcel Table Styles

Parcel Table Styles (page
910)

Parcel Commands

Parcels Command Reference (page 921)
Editing Parcel Command
Settings (page 891)

Creating Parcels
Create parcels from drawing objects, by layout, or by subdividing an existing parcel.
When you create parcels from drawing objects, ensure that they have no drawing errors that would make
them invalid topology sources. Use the drawing cleanup tools in Autodesk Map. When you create parcels
by layout, you draw parcel segments directly.

You can define parcel sizing criteria when creating or editing parcels by subdividing
existing parcels.
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Parcel Design Considerations
Before creating parcels, identify the different types of parcels you need and decide how to display them so
that different types are visually distinct.
You can design styles for parcels, labels, and tables. These styles control the appearance of the parcels and
the information displayed in labels and tables. For more information, see Parcel Labels and Tables (page 898).
You may want to design more than one style for a given parcel type. For example, if your project drawings
are consulted by several different users who want to see different information emphasized, use styles to
provide customized views of the same drawing. Information that is visible in one set of styles can be hidden,
de-emphasized, or emphasized in another.
After you design the required styles, you can save them in a drawing template. When you create a new
drawing, you can base it on the template, which makes every style in the template available in the new
drawing. The necessary styles for a project typically include parcel styles, area label styles, segment label
styles, and table styles.
Extend the styles concept by using drawing layers to manage how features display. For example, a parcel
style has a segment layer property, which assigns segments to a particular layer, and a segment color property.
Specify the segment color property of a parcel style explicitly, or specify it By Layer, which lets you change
the color of many segments at once by changing the color of their layer. As you can with styles, save layer
definitions in a drawing template.

Default Settings for New Parcels
The default properties for new parcels determine how new parcels are displayed. For more information, see
Parcel Settings (page 891).
When you initiate a parcel creation session, you open the Create Parcels dialog box (page 2235). This dialog
box displays the default settings for new parcels. You can revise these settings before you create any parcels.
To set how new parcels display
1 Click Home tab ➤ Create Design panel ➤ Parcel drop-down ➤ Create Parcel From Objects

.

2 If you clicked Create Parcel From Objects, click objects in the drawing to select them. When you finish,
press Enter.
This step occurs only if you are creating from objects.
3 In the Create Parcels dialog box (page 2235), you can edit default settings before creating any parcels.

Quick Reference
Ribbon
Home tab ➤ Create Design panel ➤ Parcel drop-down ➤ Create Parcel From Objects
Home tab ➤ Create Design panel ➤ Parcel drop-down ➤ Parcel Creation Tools
Menu
Parcels menu ➤ Create Parcel From Objects
Parcels menu ➤ Create Parcel By Layout
Command Line
CreateParcelFromObjects
CreateParcelByLayout
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Dialog Boxes
Create Parcels from Objects (page 2235)
Create Parcels by Layout (page 2235)

Creating Parcels From Objects
Create parcels from AutoCAD objects by defining a selection set of objects in the drawing.
AutoCAD objects that you can convert to parcels include polygons, closed polylines, and other closed
sequences of lines or arcs.
Select objects in the current drawing or from an xref. The objects you select must be free of drawing errors,
such as gaps at intersection points.
TIP To remove drawing errors from source geometry, use the drawing cleanup tools in Autodesk Map before you
import the objects.
To create parcels from objects
1 Make sure that the AutoCAD objects that you are converting to parcels are free of drawing errors.
2 Click Home tab ➤ Create Design panel ➤ Parcel drop-down ➤ Create Parcel From Objects

.

3 Click objects in the drawing to select them. When you finish, press Enter.
NOTE You can enter xref to select an object from an xref. The xref command supports multiple selections.
4 In the Create Parcels dialog box (page 2235), you can edit default settings before creating any parcels.
Click OK and the parcels are created.

Quick Reference
Ribbon
Home tab ➤ Create Design panel ➤ Parcel drop-down ➤ Create Parcel From Objects
Menu
Parcels menu ➤ Create Parcel From Objects
Command Line
CreateParcelFromObjects
Dialog Box
Create Parcels from Objects (page 2235)

Creating Parcels by Layout
Use the Parcel Layout Tools toolbar to create parcels.
The toolbar provides two types of parcel creation tools:
■

Freehand tools draw parcels as a network of lines, curves, and polylines.

■

Precise sizing tools control the angles and directions of lot lines.
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You can also set default values for the parcel sizing parameters and the Automatic Layout options.
TIP Object Snap can be very useful when creating parcels, especially with the freehand tools. Use Object Snap to
attach lines exactly to existing endpoints and vertices.
NOTE Using the layout tools is the only activity possible while the Parcel Layout Tools toolbar is open.
See also:
■

Parcel Layout Tools (page 2245)

■

Editing Parcels by Layout (page 886)

To create parcels by layout
1 Click Home tab ➤ Create Design panel ➤ Parcel drop-down ➤ Parcel Creation Tools

.

2 Click a parcel layout tool.
In theCreate Parcels - Layout dialog box (page 2235), you can edit default settings before creating any
parcels.
3 Specify a site with which to associate the parcel or accept the default <None>. For more information,
see Understanding Sites (page 779).
4 Specify a parcel style or accept the default style.
5 Specify the Object Layer Setting.
6 Specify the Parcel Label Set or accept the default. Click OK.
7 Use the commands on the Parcel Layout Tools toolbar to create the parcel.

Quick Reference
Ribbon
Home tab ➤ Create Design panel ➤ Parcel drop-down ➤ Parcel Creation Tools
Menu
Parcels menu ➤ Create Parcel By Layout
Command Line
CreateParcelByLayout
Dialog Boxes
Create Parcels by Layout (page 2235)
Parcel Layout Tools (page 2245)

Creating Parcels by Subdividing
Use the Parcel Layout Tools toolbar to create parcels by subdividing existing parcels.
When you add a new lot line to an existing parcel, you can specify the size of the new parcel and the method
with which to move the lot line. You can insert a new free-form lot line or choose one of the following types
that move across the parcel in a controlled manner:
■

Slide Line. Holds either a fixed angle to the frontage or an absolute direction.
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■

Swing Line. Fixed at one end and swings across the parcel frontage

When creating or editing parcels with the Parcel Layout Tools, preview graphics display the proposed solution
which results from the specified layout parameters used to define parcel components such as minimum
parcel frontage, width, and depth. As you use the tools to determine the design of proposed new parcels,
these graphics display to illustrate the proposed solution, and you are prompted to either accept or reject
the solution. When you modify the layout parameters, the graphics update dynamically while the Parcel
Layout Tools toolbar is open and the parameters are being edited. For more information, see Parcel Layout
Tools (page 2245).

Proposed frontage is highlighted.

Preview graphics display proposed layout solution based on
parcel sizing parameter values.

See also:
■

Parcel Layout Tools (page 2245)

To create parcels by subdividing with the Slide Line - Create command
1 Click Home tab ➤ Create Design panel ➤ Parcel drop-down ➤ Parcel Creation Tools

.

2 On the Parcel Layout Tools toolbar, click
to expand the toolbar. Specify the Parcel Sizing and
Automatic Layout parameters for the new parcel.
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3 Click

for the Slide Line - Create tool.

4 In the Create Parcels - Layout dialog box (page 2235), specify any changes to the default settings. Click
OK.
5 Click the Parcel Selection Area label to select the parcel or enter p and then click inside the parcel.
6 Click the start point on the parcel frontage.
7 Click an end point along the frontage. A preview graphic highlights the proposed frontage.
8 Specify the angle, bearing or azimuth to place the new lot line. Preview graphics display if a solution
can be obtained.
NOTE When prompted for the angle, bearing or azimuth, you can press Enter to enter the default 90 degree
angle.
9 Accept the result to edit the parcel. If a solution based on the current parcel sizing parameter values is
not found, you are prompted to adjust the parameters or reenter a new value for the method you are
using.
10 Optionally, continue creating lot lines by repeating Steps 5-9. When you finish, press Esc.
To create parcels by subdividing with the Swing Line - Create command
1 Click Home tab ➤ Create Design panel ➤ Parcel drop-down ➤ Parcel Creation Tools

.

2 On the Parcel Layout Tools (page 2245) toolbar, click
to expand the toolbar. Specify the Parcel Sizing
parameters and Automatic Mode options for the new parcel.
3 Click

for the Swing Line - Create tool.

4 In the Create Parcels - Layout dialog box (page 2235), specify any changes to the default settings. Click
OK.
5 Select the parcel to subdivide.
6 Click the start point on the parcel frontage.
7 Click an end point along the frontage. A preview graphic highlights the proposed frontage.
8 Specify the swing point. Preview graphics display if a solution can be obtained.
9 Accept the result to subdivide the parcel. If a solution based on the current parcel sizing parameter
values is not found, you are prompted to adjust the parameters, select a new point, or exit the command.
10 Optionally, continue creating lot lines by repeating Steps 4-10. When you finish, press Esc.

Quick Reference
Ribbon
Home tab ➤ Create Design panel ➤ Parcel drop-down ➤ Parcel Creation Tools
Menu
Parcels menu ➤ Edit Parcel ➤ Edit Parcel Segments
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Command Line
CreateParcelByLayout
Parcel Layout Tools
Slide Line - Create
Swing Line - Create
Dialog Boxes
Parcel Layout Tools (page 2245)
Create Parcels – Layout (page 2235)

Editing Parcels
Edit parcels to change their size, shape, or display properties.
Edit parcels in three main ways:
■

Use drafting tools. Click Home tab ➤ Create Design panel ➤ Parcel drop-down ➤ Parcel Creation Tools
. and use the Parcel Layout Tools (page 2245).

■

Change properties and labels. Click the area label to select the parcel, then right-click and select a menu
option.

■

Grip edit. Click lot lines and drag their nodes to new positions.

Locating Parcels in a Drawing
Before you can select a parcel, locate it in the drawing.
Locate it by selecting the parcel in the Parcels collection in Toolspace, on the Prospector tab, and then
zooming or panning to it in the drawing.
To locate a parcel
1 In Toolspace, on the Prospector tab click Sites ➤ Parcels.
2 Right-click a Parcel. Click Zoom To or Pan To.
To zoom or pan to the site parcel, right-click the Parcel. Click Zoom To or Pan To.

Quick Reference
Toolspace Shortcut Menu
Prospector tab: Parcel ➤ Zoom To or Pan To

Changing Parcel Appearance
Control parcel display by changing parcel styles or their label styles.
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Within a given site, you can change the display order of the site parcel and the parcels that it contains.
To change a parcels appearance
by...

See this topic...

Editing parcel styles

Editing Parcel Styles (page 895)

Editing parcel label styles

Editing Parcel Label Styles (page 901)

Replacing parcel styles

Applying Parcel Styles (page 896)

Replacing parcel label styles

Applying Parcel Label Styles (page 903)

Changing display order

Changing Parcel Display Order (page 893)

See also:
■

Parcel Layout Tools (page 2245)

■

Parcel Label Settings (page 898)

Editing Parcels by Layout
Use the Parcel Layout Tools toolbar to edit parcels.
The toolbar provides tools for creating and editing parcels. For information about tools for parcel creation,
see Creating Parcels by Layout (page 881).
The toolbar provides two types of parcel editing tools:
■

Precise sizing tools control the angles and directions of lot lines.

■

Freehand tools modify parcel geometry.

You can also modify settings for the Parcel Sizing parameters and Automatic Layout options.
Using layout tools is the only activity possible while the Parcel Layout Tools toolbar is open.
See also:
■

Parcel Layout Tools (page 2245)

To edit parcels by layout
1 Click Home tab ➤ Create Design panel ➤ Parcel drop-down ➤ Parcel Creation Tools

.

2 Click a parcel segment to indicate the site you will be editing.
3 Click a parcel layout tool.
When you finish, press Enter or click another tool. After pressing Enter (which puts a tool away without
selecting another), you can press Enter again to continue with the same tool.
4 When you finish editing parcels, press Esc to close the toolbar. (If one of the layout tools is still in use,
press Esc twice.)
Using layout tools is the only activity possible while the Parcel Layout Tools toolbar is open.
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Quick Reference
Ribbon
Home tab ➤ Create Design panel ➤ Parcel drop-down ➤ Parcel Creation Tools
Menu
Parcels menu ➤ Edit Parcel ➤ Edit Parcel Segments
Command Line
EditParcel
Dialog Box
Parcel Layout Tools (page 2245)

Editing Subdivided Parcels
Use the Slide Line and Swing Line edit commands to edit subdivided parcels.
You can use the Slide Line and Swing Line edit commands to edit attached lot lines. Attached lot lines are
parcel segments that were created with the Parcel Layout Tools subdivision commands.
Using layout tools is the only activity possible while the Parcel Layout Tools toolbar is open.
See also:
■

Parcel Layout Tools (page 2245)

To edit parcels by subdividing with Slide Line - Edit command
1 Click Home tab ➤ Create Design panel ➤ Parcel drop-down ➤ Parcel Creation Tools
2 Click

.

for the Slide Line - Edit tool.

3 In the Create Parcels - Layout dialog box, adjust default settings and press OK.
4 Select the attached lot line to adjust.
5 Click inside the parcel to be edited.
6 Click the start point on the parcel frontage.
7 Click an end point along the frontage. A preview graphic highlights the proposed frontage.
Specify the angle, bearing or azimuth to edit the lot line. Preview graphics display if a solution can be
obtained.
NOTE When prompted for the angle, bearing or azimuth, you can press Enter to enter a 90 degree angle
as this is the default angle.
8 Accept the result to edit the parcel. If a solution based on the current parcel sizing parameter values is
not found, you are prompted to adjust the parameters or reenter a new value for the method you are
using.
9 When you finish editing parcels, press Esc to close the toolbar. (If one of the layout tools is still in use,
press Esc twice.)
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To edit parcels by subdividing with Swing Line - Edit command
1 Click Home tab ➤ Create Design panel ➤ Parcel drop-down ➤ Parcel Creation Tools
2 Click

.

for the Swing Line - Edit tool.

3 In the Create Parcels - Layout dialog box, adjust default settings and press OK.
4 Select the attached lot line to adjust.
5 Click inside the parcel to be edited.
6 Click the start point on the parcel frontage.
7 Click an end point along the frontage. A preview graphic highlights the proposed frontage.
NOTE OSNAP must be turned off when using the Swing Line commands.
8 Specify the swing point. Preview graphics display if a solution can be obtained.
9 Accept the result to edit the parcel. If a solution based on the current parcel sizing parameters values
is not found, you are prompted to adjust the parameters or reenter a new value for the method you are
using.
10 When you finish editing parcels, press Esc to close the toolbar. (If one of the layout tools is still in use,
press Esc twice.)

Quick Reference
Ribbon
Home tab ➤ Create Design panel ➤ Parcel drop-down ➤ Parcel Creation Tools
Menu
Parcels menu ➤ Edit Parcel ➤ Edit Parcel Segments
Command Line
CreateParcelByLayout
EditParcel
Parcel Layout Tools
Slide Line - Edit
Swing Line - Edit
Dialog Box
Parcel Layout Tools (page 2245)

Creating a Right of Way
Use the Create ROW command to create a right of way along an alignment.
Parcels and adjacent alignment must be in the same site. Parcel boundaries are offset a specified distance
from the alignment.
Optionally, specify a radius for fillets at intersections with other objects. The following illustration shows a
right of way created between parcels 103 and 104 with fillets at intersections with parcel boundaries.
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The right of way is like a narrow parcel, but it is not dynamically linked to the alignment. If you move or
edit the alignment you must create the right of way again.
When you run the Create ROW command, you are prompted to select one or more parcels. If an alignment
is found in the site and along an edge of the selected parcels, a right of way is created in accordance with
the supplied parameters.
To create a right of way
1 Click Home tab ➤ Create Design panel ➤ Parcel drop-down ➤ Create Right Of Way

.

2 Select one or more parcels in the drawing and press Enter.
3 In the Create Right of Way dialog box (page 2236), specify the offset distance from the alignment to the
parcel boundaries.
4 If you want corner fillets at parcel boundaries along the right of way, select this option. Specify a radius.
5 If you want corner fillets at intersections with other alignments and rights of way, select this option.
Specify a radius.
6 Click OK.

Quick Reference
Ribbon
Home tab ➤ Create Design panel ➤ Parcel drop-down ➤ Create Right Of Way
Menu
Parcels menu ➤ Create ROW
Command Line
CreateParcelROW
Dialog Box
Create Right of Way (page 2236)

Deleting Parcels
Delete a parcel only if it has one or more segments that are not shared with another parcel.
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NOTE If you delete a segment that is shared by two parcels, you merge the two parcels. See Merging Parcels
(page 890).
To delete a parcel
1 Click Home tab ➤ Create Design panel ➤ Parcel drop-down ➤ Parcel Creation Tools

.

2 Click a parcel segment to indicate the site you will be editing.
3 On the Parcel Layout Tools toolbar, click
by another parcel.

Delete Sub-entity. Click a parcel segment that is not shared

Quick Reference
Ribbon
Home tab ➤ Create Design panel ➤ Parcel drop-down ➤ Parcel Creation Tools
Menu
Parcels ➤ Edit Parcel ➤ Edit Parcel Segments
Command Line
Erase
Parcel Layout Tool
Delete Sub-entity
Dialog Box
Parcel Layout Tools (page 2245)

Merging Parcels
To merge two parcels, delete a shared segment.
When you delete a shared segment, you delete the shared boundary. The two parcels become one.
If the shared boundary is composed of more than one segment, all the shared segments are deleted, not just
the one you selected.
NOTE If you delete a segment that is not shared, you delete the parcel that it belongs to. See Deleting Parcels
(page 889).
To merger parcels
1 Click Home tab ➤ Create Design panel ➤ Parcel drop-down ➤ Parcel Creation Tools

.

2 Click a parcel segment to indicate the site you will be editing.
3 In the Parcel Layout Tools toolbar, click
two parcels that you want to merge.

890 | Chapter 23 Parcels

Delete Sub-entity. Click a parcel segment that is shared by

Quick Reference
Ribbon
Home tab ➤ Create Design panel ➤ Parcel drop-down ➤ Parcel Creation Tools
Menu
Parcels ➤ Edit Parcel ➤ Edit Parcel Segments
Parcel Layout Tool
Delete Sub-entity
Dialog Box
Parcel Layout Tools (page 2245)

Editing Parcel Geometry and Parcel Elevations
Use the feature line editing commands to edit parcel geometry and parcel elevations.
You can access these commands by selecting a parcel and then selecting either the Edit Geometry or Edit
Elevations panels to access the commands. For more information, see Editing Feature Lines (page 816).

Parcel Settings
Parcel settings include settings for parcels, parcel commands, and parcel labels.
This section includes information about parcel settings and parcel command settings. For information about
Parcel label settings, see Parcel Label Settings (page 898).

Editing Parcel Settings
Parcel settings specify the default properties for new parcels. Edit parcel settings in the Parcel collection, in
Toolspace on the Settings tab.
To edit parcel settings
1 In Toolspace, on the Settings tab, right-click Parcel ➤ Edit Feature Settings.
2 In the Edit Feature Settings dialog box, edit parcel settings.

Quick Reference
Toolspace Shortcut Menu
Settings tab: Parcel ➤ Edit Feature Settings
Dialog Box
Parcel Settings (page 2236)

Editing Parcel Command Settings
Parcel command settings specify the default options for parcels commands. Edit parcel command settings
under Commands collection in Toolspace on the Settings tab.
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To edit parcel command settings
1 In Toolspace, on the Settings tab, expand Parcel ➤ Commands.
2 Right-click a command. Click Edit Command Settings.
3 In the Edit Feature Settings - Parcel (page 2236) dialog box, edit command settings.

Quick Reference
Toolspace Shortcut Menu
Settings tab: Parcel Commands ➤ Edit Command Settings
Dialog Box
Parcel Settings (page 2236)

Parcel Properties
Properties define each parcel in a drawing.
Properties control everything about a parcel except its segment label styles. A site parcel has an additional
property that specifies the display order of parcels within the site, including the site parcel itself.
For information about replacing parcel segment label styles, see Applying Parcel Label Styles (page 903).

Editing Parcel Properties
Edit parcel properties to work with styles and other basic parcel attributes.
You can edit the properties of a single parcel, or a group of parcels. In each case, you can change the parcel
style, area label style, and user defined properties such as parcel number and address.
Some typical editing tasks are as follows:
■

Replace a parcel’s style, which governs the appearance of the parcel itself.

■

Replace a parcel’s area label style, which governs the appearance of its area label and the information
displayed in the label.

■

View information about the parcel segments.

■

Specify the parcel’s Point Of Beginning, which is the parcel boundary’s initial node (start point of its
initial segment).

■

Renumber parcels to reset their starting and increment values and/or rename a parcel based on the parcel
name template.

■

Change parcel display order to set the properties of shared segments (such as color) when the two parcels
sharing it have different properties.

Edit parcel properties by right-clicking a parcel area label in the drawing, or by right-clicking a parcel in
Toolspace on the Prospector tab (or a Parcels collection for a site parcel).
To edit properties of one parcel
1 Click the text of the parcels area label.
If the parcels area label is not visible, see Hiding or Showing Parcel Labels (page 909).
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If you have selected the label correctly, the label text and its anchor point are highlighted. Selecting
the area label also selects the parcel.
2 Right-click and click Parcel Properties.
3 In the Parcel Properties dialog box (page 2251), edit parcel properties.
To edit properties of multiple parcels
1 Click a parcel.
2 Click Parcel tab ➤ Modify panel ➤ Parcel Properties drop-down ➤ Parcel Properties

.

3 The current site is displayed and the following prompt is displayed:
Start point or [Polyline/All/Site]:

4 Do one of the following:
■

Select a start and end point to draw a path through the desired parcels.

■

Select Polyline, to select a polyline that crosses through the desired parcels. The polyline prompt
will repeat until you hit Enter to end the command.

■

Select All, to select all parcels and open the Edit Parcel Properties dialog box (page 2241).

■

Select Site, to open a Select Object (Site) dialog box with which to select another available site. After
selecting a site, start back at Step 2.

5 In the Edit Parcel Properties dialog box, edit the parcel properties.

Quick Reference
Ribbon
Parcel tab ➤ Modify panel ➤ Parcel Properties drop-down ➤ Parcel Properties
Menu
Parcels menu ➤ Edit Parcel ➤ Edit Parcel Properties
Commands
EditParcelProperties for one parcel
ParcelPropertiesEdit for multiple parcels
Dialog Boxes
Edit Parcel Properties (page 2241)
Parcel Properties (page 2251)

Changing Parcel Display Order
Control parcel style display order, which is a property of the site parcel.
Display order affects the display of all parcel segments that are shared by two parcels of different styles. The
style that is higher in the display order controls the actual display.
Edit the parcel style display order as a property of the site parcel, using the Composition Tab (page 2256) of
the Site Parcel Properties dialog box. Access this dialog box by right-clicking either the site parcels area label
or the Parcels collection in the Toolspace on the Prospector tab.
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To change parcel display order
1 Click the site parcels area label in the drawing.
If the parcels area label is not visible, see Hiding or Showing Parcel Labels (page 909).
If you have selected the label correctly, the label text and its anchor point alone are highlighted. Selecting
the area label also selects the parcel.
2 Right-click and click Parcel Properties.
3 In the Site Parcel Properties dialog box, click the Composition tab.
4 On the Composition tab, under Parcel Style Display Order, change the list positions of styles listed
there.
To change a styles list position, select it. Click the Up or Down Arrow. You can also drag a style to a
new position. When you click Apply or OK, the parcels are redrawn, starting with the styles at the
bottom of the list and working up to the top.

Quick Reference
Ribbon
Parcel tab ➤ Modify panel ➤ Parcel Properties drop-down ➤ Parcel Properties
Object Shortcut Menu
Site parcel object ➤ Parcel Properties
Toolspace Shortcut Menu
Prospector tab: Parcels ➤ Properties
Dialog Box
Site Parcel Properties (page 2256)

Parcel Styles
Parcel styles govern how parcels are displayed in a drawing. Create, edit, or delete parcel styles in the Parcel
collection in Toolspace, on the Settings tab.
You can create an entirely new parcel style, or base it on an existing style.
The default Standard parcel style is always available. If you base a new drawing on a drawing template, the
styles defined in the template are available also.

Creating Parcel Styles
Create parcel styles in the Parcel collection in Toolspace, on the Settings tab.
To create a parcel style
1 In Toolspace, on the Settings tab, expand the Parcel collection.
2 Right-click Parcel Styles and click New.
3 In the Parcel Styles dialog box, name the new style and define the style settings.
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Quick Reference
Toolspace Shortcut Menu
Settings tab: Parcel Styles ➤ New
Dialog Box
Parcel Styles (page 2253)

Editing Parcel Styles
Edit parcel styles on the Toolspace Settings tab, in the Parcel collection.
Edit the style name, parcel pattern fill, and displayed elements.
You can also edit the hatch pattern for the parcel pattern fill.
To edit a parcel style
1 In Toolspace, on the Settings tab, expand Parcel ➤ Parcel Styles.
2 Right-click the style that you want to edit and click Edit.
3 In the Parcel Styles dialog box, modify style settings.

Quick Reference
Ribbon
Parcel tab ➤ Modify panel ➤ Parcel Properties drop-down ➤ Edit Parcel Style
Toolspace Shortcut Menu
Settings tab: Right-click a parcel style ➤ Edit
Dialog Box
Parcel Styles (page 2253)

Creating Parcel Styles Based on Other Styles
Create a new parcel style by copying and modifying an existing style in the Parcel collection in Toolspace
on the Settings tab.
To create a parcel style based on another style
1 In Toolspace, on the Settings tab, expand Parcel ➤ Parcel Styles.
2 Right-click the style that the new style will be based on and click Copy.
3 In the Parcel Styles dialog box, name the new style.
The settings for the new style will be the same as the settings of the style that you copied.
4 Modify style settings.
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Quick Reference
Toolspace Shortcut Menu
Settings tab: Right-click a parcel style ➤ Copy
Dialog Box
Parcel Styles (page 2253)

Applying Parcel Styles
Apply a different style to a parcel any time that you want to change its appearance or indicate a change in
the type of parcel.
The two components of a parcel style that display are the parcel segment line and the area fill. Area fill is a
hatch pattern that you can apply to the entire parcel area, or use to mark a border around the inside of the
parcel boundary. You can set a fill distance to define the width of the filled border.
For information about applying parcel styles during the creation process, see Default Settings for New Parcels
(page 880).
To apply a parcel style to an existing parcel
1 In the drawing, click a parcel area label to select the parcel.
If the label is not visible, see Hiding or Showing Parcel Labels (page 909).
If you have selected the label correctly, the label text and its anchor point are highlighted.
2 Right-click, then click Parcel Properties.
3 In the Parcel Properties dialog box, click the Information tab.
4 On the Information tab, under Object Style, specify the parcel style you want to apply.

Quick Reference
Ribbon
Parcel tab ➤ Modify panel ➤ Parcel Properties drop-down ➤ Parcel Properties
Object Shortcut Menu
Parcel object ➤ Parcel Properties
Toolspace Shortcut Menu
Prospector tab: Parcel ➤ Properties
Dialog Box
Parcel Properties (page 2251)

Deleting Parcel Styles
Delete parcel styles in the Parcel collection in Toolspace on the Settings tab.
NOTE The Standard style can only be deleted if it is not being referenced by an existing parcel.
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To delete a parcel style
1 In Toolspace, on the Settings tab, expand Parcel ➤ Parcel Styles.
2 Right-click the style that you want to delete, then click Delete.
Delete is unavailable for any style that is used in the drawing.

Quick Reference
Toolspace Shortcut Menu
Settings tab: a parcel style ➤ Delete

Exporting a Parcel Inverse or Mapcheck Report
You can export an inverse or mapcheck report for a single parcel, for a selection of parcels, or for all site
parcels at the same time.
You can access the Export Parcel Analysis (page 2242) dialog box from three locations within the Prospector
tree: the main Parcels node, from individual parcels, or by selecting multiple parcels from the Parcel list
view.
To export all of the parcels in a site, you can access the Export Analysis command from the main Parcels
node.
To export an individual parcel report, right-click a parcel under the Parcels node.
To export a selection of parcels, use Ctrl+click to select multiple parcels from the Parcel list view that appears
below the Prospector tree when the Parcels node is selected.
To run a Mapcheck Analysis on parcel labels, select the parcel labels and click Analyze tab ➤ Ground Data
panel ➤ Survey Drop-down ➤ Mapcheck. For more information, see Performing a Mapcheck Analysis (page
1796).
To export an inverse or mapcheck report
1 In Toolspace, on the Prospector tab, do one of the following:
■

Expand a site and right-click the Parcels node.

■

Expand a site and expand the main Parcels node, and then right-click an individual parcel.

■

Use Ctrl+click to select multiple parcels in the Parcel list view and right-click.

2 Select Export Analysis.
3 In the Export Parcel Analysis (page 2242) dialog box, specify the path to where the file will be exported
and saved. Enter the path or click

to browse to a location.

4 Select the analysis type.
5 Select or clear the Enable Mapcheck Across Chord check box.
6 Select the segment order.
7 Click OK.
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Quick Reference
Toolspace Shortcut Menu
Settings tab: Right-click individual parcel, main Parcels node, or a selected group of parcels ➤ Export
Analysis
Dialog Box
Export Parcel Analysis (page 2242)

Parcel Labels and Tables
Both parcel labels and tables display parcel information.
Labels display information within the parcel or adjacent to the component they describe. Tables are
constructed with one row for each parcel or component.
Parcels always have area selection labels. Segment labels are optional. You can label parcel segments when
you create them or at any time afterward.
Styles control the appearance of labels and tables and the information they contain.

Using Labels and Tables
Display parcel information in labels only, or in both labels and tables. Parcel tables are optional, but useful
for organizing data when you work with a large number of parcels.
Parcel line, curve, and area labels that are added to already created parcels are now individual objects, not
sub-objects of the parcel. These parcel labels can be controlled with the AutoCAD Properties palette. The
first area label that is automatically created when the parcel is created is a sub-entity of the parcel and is
used to select the parcel. This parcel selection label cannot be deleted.
If you want to use parcel tables, all parcels and segments to be included in a table require a label that displays
a unique table tag. This tag serves as a unique identifier for the object in the drawing and in the table. The
label can include additional information, but the tag is essential.
General line and curve label styles can be applied to parcel segment labels. As a result, when creating parcel
tables, you can select general line/curve label types and/or parcel segment labels. You can select any parcel
segment labels that use line/curve styles. Or you can use any line or curve label that is applied to a line,
curve, feature line, or polyline segment.
For more information about parcel labels, tables, and table tags, see Parcel Label Styles (page 899), Adding
Parcel Tables (page 912), and Parcel Numbering and Naming (page 916).

More About Labels and Tables
The topics in this section provide information about labels and tables in a parcels context. For information
about labels in general, see Labels and Tags (page 1643). For information about tables, see Tables (page 1737).
For information about modifying labels, see Modifying Labels in a Drawing (page 1712).

Parcel Label Settings
Parcel label settings provide default settings for parcel label styles.
Global settings apply to parcel label styles of every type; label-type settings apply only to parcel label styles
of a given type, such as area label styles.
Individual label styles inherit from label-type settings, which in turn inherit from global settings. You can
override inherited settings at lower levels. Also, you can block overrides by locking settings at higher levels.
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If a parcel label setting is changed at a higher level, the change is propagated downward except where it is
overridden. The change affects all styles that inherit it, and all labels in the drawing that use those styles.

Editing Global Settings for Parcel Label Styles
Global settings affect parcel label styles of every type. Edit these settings in the Parcel collection in Toolspace,
on the Settings tab.
To edit global settings for parcel label styles
1 In Toolspace, on the Settings tab, right-click Parcel and click Edit Label Style Defaults.
2 In the Edit Label Style Defaults dialog box, edit label style settings.

Quick Reference
Toolspace Shortcut Menu
Settings tab: Parcel ➤ Edit Label Style Defaults
Dialog Box
Edit Label Style Defaults (page 2179)

Editing Label-Type Settings for Parcel Label Styles
Label settings affect only parcel label styles of a given type: area, line, or curve.
Change label settings in the Label Styles collection, in Toolspace on the Settings tab. The parcel label types
Area, Line, and Curve, are located under the Label Styles collection. These settings inherit values and overrides
from global settings.
To edit settings for parcel label styles
1 In Toolspace, on the Settings tab, expand Parcel ➤ Label Styles.
2 Right-click either an Area, Line, or Curve label style. Click Edit Label Style Defaults.
3 In the Edit Label Style Defaults dialog box, edit parcel label style settings.

Quick Reference
Toolspace Shortcut Menu
Settings tab: Label Styles ➤ Area, Line, or Curve. Right-click ➤ Edit Label Style Defaults
Dialog Box
Edit Label Style Defaults (page 2180)

Parcel Label Styles
Parcel label styles control the appearance of parcel labels and the information they contain.
Parcel label styles include styles for area labels and segment labels (line labels and curve labels). Specify
which label styles to use when you create parcels, and when adding labels. Line and curve general label
styles can also be applied to parcel segment labels.
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You can create, edit, or delete parcel label styles in the Label Styles collection in Toolspace, on the Settings
tab. Create an entirely new parcel label style, or create one based on an existing style.

Specifying Label Contents
Parcel label styles specify label contents that are composed of several information components. These
components are identified in the Component list on the Layout tab of the Label Style Composer dialog box
(page 2180). You can add or delete information components as needed, except with segment label styles, which
have a permanent Table Tag component. The Table Tag component is essential for correlating segments in
the drawing with those in a segment table.
When a given information component is selected in a styles Component list, its settings are displayed below
it. Edit the Content setting to specify the components information. Edit other settings to specify how the
component is displayed, including its relative position. You can preview a label in the Preview pane of the
Layout tab.
Labels for line and curve segments include a property to span an outside segment. Set this property to True
to apply a single label to any segment that runs along the outside edge of multiple parcels. Set this property
to False to label the segment for each parcel separately. Set this property on the Layout tab of the Label Style
Composer dialog box.

Segment Labels and Tags
Segment label styles (unlike area label styles) include a Display Mode value, either Label or Tag. Labels are
typically used to display engineering data adjacent to each segment. They can include multiple lines of text.
Tags are generally much smaller. They display a reference number and perhaps one other element such as
a direction arrow. The tag numbers appear in the first column of a table that contains the engineering data.
By using tags, you can eliminate parcel segment data from the drawing and organize the data in a separate
table. Within a drawing, you can use labels on some segments and tags on others.
Each information component in a segment label styles label template specifies a Used In value: Label Mode,
Tag Mode, or Label And Tag Modes. These settings can help you assign data to either labels, tags, or both.

Labels, Table Tags, and Tables
To include a segment in a table the segment must have a style with the value set to Tag for the Display Mode
property. The Table Tag component must have its Used In property set to either Tag Mode or Label And Tag
Modes.
Area label styles do not have a Display Mode property. You can use any piece of information as the table
tag. Typically the parcel number is used, but it can be another information component. The table tag,
whatever it is, must also be included in the first cell of the corresponding table row. This information is
specified in the tables style. For more information, see Adding Parcel Tables (page 912).

Creating Parcel Label Styles
Create parcel label styles in the Label Styles collection in Toolspace, on the Settings tab.
To create a parcel label style
1 In Toolspace, on the Settings tab, expand Parcel ➤ Label Styles.
2 Right-click a label type: Area, Line, or Curve and click New.
3 In the Label Style Composer dialog box, specify a style name and the style settings.
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Quick Reference
Ribbon
Labels tab ➤ Modify panel ➤ Label Properties drop-down ➤ Edit Label Style
Toolspace Shortcut Menu
Settings tab: Right-click a label type: Area, Line, or Curve ➤ New
Dialog Box
Label Style Composer (page 2180)

Editing Parcel Label Styles
Edit parcel label styles in the Label Styles collection in Toolspace, on the Settings tab or by selecting the Edit
Label Style option in the drawing.
To edit a parcel label style
1 In Toolspace, on the Settings tab, expand Parcel ➤ Label Styles.
2 Expand a label type: Area, Line, or Curve.
3 Right-click the label style and click Edit.
4 In the Label Style Composer dialog box, modify style settings.
OR
1 Select the segment label to edit.
2 Right-click and select Edit Label Style.
3 In the Select Style dialog box, specify a label style, create a new style, or copy or edit an existing style.

Quick Reference
Ribbon
Labels tab ➤ Modify panel ➤ Label Properties drop-down ➤ Edit Label Style
Toolspace Shortcut Menu
Settings tab: Label Style ➤ Edit
Dialog Box
Label Style Composer (page 2180)

Editing Parcel Area Label Styles
Edit parcel area label styles in the Label Styles collection in Toolspace, on the Settings tab or by selecting
the right-click Edit Area Selection Label Style option in the drawing.
You can select a different label style, edit a style, or create a new one.
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To edit a parcel area selection label style
1 In Toolspace, on the Settings tab, expand Parcel ➤ Label Styles.
2 Expand a label type: Area.
3 Right-click the label style and click Edit.
4 In the Label Style Composer dialog box, modify style settings.
OR
1 Select the area label to edit.
2 Right-click and select Edit Area Selection Label Style.
3 In the Select Style dialog box, specify a label style, create a new style, or copy or edit an existing style.
NOTE The Parcel Area Selection label cannot be deleted as this is an embedded object and is used to select the
parcel.

Quick Reference
Ribbon
Parcel tab ➤ Modify panel

Edit Area Label Style

Toolspace Shortcut Menu
Settings tab: Label Style ➤ Edit
Dialog Box
Label Style Composer (page 2180)
See also:
■

Composition Tab (Parcel Properties Dialog Box) (page 2252)

Displaying Parcel Area Label Properties with the List Command
Use the AutoCAD List command to display parcel area label property information.
To display parcel area properties in the AutoCAD Text Window
1 In the drawing, use Ctrl+click to select an area label.
2 In the command line, enter list.
3 The AutoCAD Text Window dialog box displays parcel properties, including diameter, area and segment
information.
To display parcel area label properties in the AutoCAD Text Window
1 In the drawing, select an area label.
2 In the command line, enter list.
3 The AutoCAD Text Window dialog box displays the label type, and layer. For example,
AECC_PARCEL_FACE_LABEL Layer: “0”.
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Quick Reference
Command Line
List
Dialog Box
AutoCAD Text Window

Creating Parcel Label Styles Based on Other Styles
Create a parcel label style based on another style in the Label Styles collection in Toolspace, on the Settings
tab.
To create a parcel label style based on another style
1 In Toolspace, on the Settings tab, expand Parcel ➤ Label Styles.
2 Expand a label type: Area, Line, or Curve.
3 Right-click the label style that the new style will be based on and click Copy.
4 In the Label Style Composer dialog box, specify a name for the new style.
5 Modify style settings.

Quick Reference
Toolspace Shortcut Menu
Settings tab: Right-click <label style> ➤ Copy
Dialog Box
Label Style Composer (page 2180)

Deleting Parcel Label Styles
Delete parcel label styles in the Label Styles collection in Toolspace, on the Settings tab.
To delete a parcel label style
1 In Toolspace, on the Settings tab, expand Parcel ➤ Label Styles.
2 Expand a label type: Area, Line, or Curve.
3 Right-click the style that you want to delete and click Delete.

Quick Reference
Toolspace Shortcut Menu
Settings tab: Right-click <label style> ➤ Delete

Applying Parcel Label Styles
A parcel area label style, which you can change at any time, is applied to parcels when they are created.
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For information about applying parcel label styles during the creation process, see Default Settings for New
Parcels (page 880).
Parcel area selection labels are always created and cannot be deleted. Parcel segment labels are not always
applied in the creation process. Parcel segment labels are individual objects and can be placed on a layer
separate from the segment being annotated. For more information on how to apply segment labels to existing
parcels, see Adding Multiple Parcel Segment Labels (page 905).
To replace a parcel label style
1 Click a parcel label in the drawing.
If the label is not visible, see Hiding or Showing Parcel Labels (page 909).
If you have selected the label correctly, the label text and its anchor point are highlighted.
2 Right-click and click Label Properties or Properties.
3 In the AutoCAD Properties palette, replace the label style.
NOTE Use the Properties palette Label Style drop down menu to access a list of available parcel styles including
the general line and curve label styles which can be used to annotate parcels.

Quick Reference
Ribbon
Select the parcel label. Click Labels tab ➤ Modify panel ➤ Label Properties drop-down ➤ Edit Label Style

Object Shortcut Menu
Parcel object ➤ Label Properties or Properties
Dialog Box
AutoCAD Properties palette

Adding or Deleting Parcel Labels
Add or delete parcel segment labels, but not area labels.
For information on how to change parcel area labels, see Applying Parcel Label Styles (page 903).
On the Toolspace Settings tab, in the General Label Style collection, set up Line and Curve label styles (page
1659) to use for the parcels.
On the Toolspace Settings tab, in the General Label Style collection, specify the default line label style (page
1655).
Use the Single Segment or Multiple Segment command to quickly label a parcel using the default label style.
Use the Add Parcel Labels option to access the Add Labels dialog box (page 2208) if you need to create or
modify a style before labeling a feature line.
In the Add Labels dialog box you can specify the label types and styles to apply. You can also configure table
tags and reference text object prompt methods.
You can add segment labels in the parcel creation process, or you can add them later. For information about
adding segment labels during the creation process, see Default Settings for New Parcels (page 880).
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Adding Individual Parcel Segment Labels
You can label individual parcel segments with General Line and Curve label styles or Parcel Line and Curve
label styles.
Parcel segment labels are independent, selectable objects. Segment labels can be placed on a layer separate
from the corresponding segment. You can add segment labels automatically when you create a parcel. See
Default Settings for New Parcels (page 880).
To label parcel line segments
1 Click Annotate tab ➤ Labels & Tables panel ➤ Add Labels menu ➤ Parcel ➤ Single Segment

.

2 Select the parcel line or segment to label.
OR
1 Click Annotate tab ➤ Labels & Tables panel ➤ Add Labels menu ➤ Parcel ➤ Add Parcel Labels

.

2 In the Add Labels dialog box, for Label Type, select Single Segment.
3 In the Add Labels dialog box, set Line Label Style and Curve Label Style and click Add.
NOTE You can label parcel segments with either General Line and Curve label styles or with Parcel Line and
Curve label styles.
4 Click a parcel segment in the drawing. The label is placed at the selected location. Click additional
segments if you want.
While you select segments, the dialog box remains open. You can return to it to change styles or settings
for the next sequence of clicks. After changing a label style, click Add. If you do not click Add before
continuing to click segments, the style change will be ignored.
5 When you finish adding segment labels, click Close.

Quick Reference
Ribbon
Annotate tab ➤ Labels & Tables panel ➤ Add Labels menu ➤ Parcel ➤ Single Segment
Annotate tab ➤ Labels & Tables panel ➤ Add Labels menu ➤ Parcel ➤ Add Parcel Labels

.
.

Menu
Parcels menu ➤ Add Parcel Labels ➤ Add Parcel Labels.
Command Line
AddParcelLineLabel
AddParcelLabels
Dialog Box
Add Labels (page 2208)

Adding Multiple Parcel Segment Labels
Add labels to multiple parcel segments in one operation.
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The segments are labeled in either a clockwise or counterclockwise direction, regardless of the direction of
individual segments. Labeling direction is set in the Default Options for the AddParcelSegmentLabels
command.
You can add segment labels automatically when you create a parcel. See Default Settings for New Parcels
(page 880).
To label multiple parcel segments
1 Click Annotate tab ➤ Labels & Tables panel ➤ Add Labels menu ➤ Parcel ➤ Multiple Segments

.

2 Select the feature lines or segments to label.
When parcel face is selected, a direction prompt displays. If a different supported object is selected, the
direction prompt does not display.
OR
1 Click Annotate tab ➤ Labels & Tables panel ➤ Add Labels menu ➤ Parcel ➤ Add Parcel Labels

.

2 In the Add Labels dialog box, for Label Type, select Multiple Segment to add labels to all segments in
a parcel.
3 In the Add Labels dialog box, set Line Label Style and Curve Label Style and click Add.
NOTE You can label parcel segments with either General Line and Curve label styles or with Parcel Line and
Curve label styles.
4 Click a parcel area label in the drawing. Labels are added to every segment of the parcel.
While you select segments, the dialog box remains open. You can return to it to change styles or settings
for the next sequence of clicks. After changing a label style, click Add. If you do not click Add before
continuing to click segments, the style change will be ignored.
5 When you finish adding segment labels, click Close.

Quick Reference
Ribbon
Annotate tab ➤ Labels & Tables panel ➤ Add Labels menu ➤ Parcel ➤ Multiple Segments
Annotate tab ➤ Labels & Tables panel ➤ Add Labels menu ➤ Parcel ➤ Add Parcel Labels
Menu
Parcels menu ➤ Add Parcel Labels ➤ Multiple Segment.
Parcels menu ➤ Add Parcel Labels ➤ Add Parcel Labels
Command Line
AddParcelSegmentLabels
AddParcelLabels
Dialog Box
Add Labels (page 2208)
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.
.

Replacing Multiple Segment Labels
Use the Replace Multiple Segment command to easily replace multiple parcel segment labels.
To replace parcel segment labels
1 Click Annotate tab ➤ Labels & Tables panel ➤ Add Labels menu ➤ Parcel ➤ Add Parcel Labels

.

2 In the Add Labels dialog box, for Label Type, select Replace Multiple Segment.
3 You are prompted to select a parcel to be labelled. It will replace the labels with new ones using the
current Multiple Segment label style. If the Multiple Segment label style has already been added to the
selected parcel a message will be displayed and the labels will not be replaced.
While you select parcels, the dialog box remains open. You can return to it to change styles or settings
for the next sequence of commands. After changing a label style, click Add. If you do not click Add
before continuing to click segments, the style change will be ignored.
4 When you finish replacing multiple segment labels, click Close.

Quick Reference
Ribbon
Annotate tab ➤ Labels & Tables panel ➤ Add Labels menu ➤ Parcel ➤ Add Parcel Labels
Menu
Parcels menu ➤ Add Parcel Labels ➤ Add Parcel Labels
Command Line
AddParcelLabels

Adding Parcel Area Labels
Add multiple area labels to a single parcel.
You can control the display of parcel area labels separately for each viewport. A parcel can support more
than one area label in addition to the embedded area selection label. With multiple area labels per parcel,
you can use layer control to display a different label for each viewport with the correct orientation. You can
also manage multiple parcel labels with the Edit Parcel Properties Dialog Box (page 2241).
You can add segment labels automatically when you create a parcel. See Default Settings for New Parcels
(page 880).
To add parcel area labels
1 Click Annotate tab ➤ Labels & Tables panel ➤ Add Labels menu ➤ Parcel ➤ Add Parcel Labels

.

2 In the Add Labels dialog box, for Label Type, select Area.
3 The current site is displayed and the following prompt is displayed:
Select parcel area selection label or [STart point/Polylines/All/Site]:

4 Do one of the following:
■

Select a start and end point to draw a path through the desired parcel.
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■

Select Polylines, to select a polyline that crosses through the desired parcels. The polyline prompt
will repeat until you hit Enter to end the command.

■

Select All, to open a Select Object (Site) dialog box with which to select another available site. After
selecting a site, start back at Step 2.

■

Select Site, to open a Select Object (Site) dialog box with which to select another available site. After
selecting a site, start back at Step 2.

5 While you select parcels, the dialog box remains open. You can return to it to change styles or settings
for the next sequence of commands. After changing a label style, click Add. If you do not click Add
before continuing to click segments, the style change will be ignored.
6 When you finish adding area labels, click Close.

Quick Reference
Ribbon
Annotate tab ➤ Labels & Tables panel ➤ Add Labels menu ➤ Parcel ➤ Add Parcel Labels
Menu
Parcels menu ➤ Add Parcel Labels ➤ Add Parcel Labels
Command Line
AddParcelAreaLabel
AddParcelLabels
Dialog Box
Add Labels (page 2208)

Replacing Parcel Area Labels
Use the Replace Area command to easily replace parcel area labels.
To replace parcel area labels
1 Click Annotate tab ➤ Labels & Tables panel ➤ Add Labels menu ➤ Parcel ➤ Add Parcel Labels

.

2 In the Add Labels dialog box, for Label Type, select Replace Area.
3 You are prompted to select a parcel area label. It will replace that label with a new one using the current
Area label style. If the area label style has already been added to the selected parcel a message will be
displayed and the label will not be replaced.
While you select parcels, the dialog box remains open. You can return to it to change styles or settings
for the next sequence of commands. After changing a label style, click Add. If you do not click Add
before continuing to click segments, the style change will be ignored.
4 When you finish replacing area labels, click Close.
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Quick Reference
Ribbon
Annotate tab ➤ Labels & Tables panel ➤ Add Labels menu ➤ Parcel ➤ Add Parcel Labels
Menu
Parcels menu ➤ Add Parcel Labels ➤ Add Parcel Labels
Command Line
AddParcelLabels
Dialog Box
Add Labels (page 2208)

Deleting Parcel Segment Labels
You can select and delete parcel segment labels.
To delete a parcel segment label
1 Click to select a parcel segment label.
If you have selected the label correctly, the label text and its anchor point are highlighted.
2 Hit delete.

Quick Reference
Object Selection
Click label

Hiding or Showing Parcel Labels
Hide or show labels of any type by setting the Visibility property of their label styles.
For information about setting the Visibility property of label styles, see Editing Parcel Label Styles (page 901).
For information about applying label styles, see Applying Parcel Label Styles (page 903).
You can set the Visibility property globally, and in that way hide or show many parcel labels at the same
time. See Parcel Label Settings (page 898).
If you do not want site parcels to have area labels, assign an area label style of <none>.

Hiding or Showing Site Parcel Area Labels
In site parcels, hide or show area labels in two ways.
Hide these labels by choosing a site area label style of <none>. As with other label types, you can also set
the Visibility property of their label style to either hide or show them.
There are two types of area labels. The area selection label that is automatically created upon parcel creation
cannot be deleted. You must use Ctrl+click to select it. Additional area labels that are added after the parcel
is created are independent objects that can be deleted.
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To hide or show a site parcel area label
1 In Toolspace, on the Prospector tab, expand the Sites collection.
2 Right-click a Parcels collection and click Properties.
3 In the Site Parcel Properties dialog box, click Composition. Select one of the following settings for Site
Area Label Style:
4 ■ To hide labels, set the style to <none>, or to a style with Visibility set to False.
■

To show labels, set the style to one with Visibility set to True.

Quick Reference
Toolspace Shortcut Menu
Prospector: Right-click Site ➤ Parcels ➤ Properties
Dialog Box
Site Parcel Properties (page 2256)

Parcel Table Styles
Manage parcel table styles in the Table Styles collection in Toolspace, on the Settings tab.
Parcel table styles govern how parcel tables are displayed in a drawing. You can create, edit, or delete parcel
table styles.
Create an entirely new table style, or create a table style based on an existing style. When creating parcel
tables, you can select general line/curve label types and/or parcel segment labels. You can label parcel
segments that use line/curve label styles. Line/Curve label styles can be applied to lines, curves, feature lines,
and polyline segments.

Creating Parcel Table Styles
Create parcel table styles in the Table Styles collection in Toolspace, on the Settings tab.
To create a parcel table style
1 In Toolspace, on the Settings tab, expand Parcel ➤ Table Styles.
2 Right-click a table type: Area, Line, Curve, or Segment and click New.
3 In the Table Style dialog box, specify a name for the new style and define the style settings.

Quick Reference
Toolspace Shortcut Menu
Settings: Table Styles ➤ right-click Area, Line, Curve, or Segment ➤ New
Dialog Box
Table Style (page 2735)
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Editing Parcel Table Styles
Edit parcel table styles in the Table Styles collection in Toolspace, on the Settings tab.
To edit a parcel table style
1 In Toolspace, on the Settings tab, expand Parcel ➤ Table Styles.
2 Expand a table type: Area, Line, Curve, or Segment.
3 Right-click the table style that you want to edit and click Edit.
4 In the Table Style dialog box, modify style settings.

Quick Reference
Ribbon
Table tab ➤ Modify panel ➤ Table Properties drop-down ➤ Edit Table Style
Toolspace Shortcut Menu
Settings: Right-click Parcel table style ➤ New
Dialog Box
Table Style (page 2735)

Creating Parcel Table Styles Based on Other Styles
Create a parcel table style based on another style in the Table Styles collection in Toolspace, on the Settings
tab.
To create a parcel table style based on another style
1 In Toolspace, on the Settings tab, expand Parcel ➤ Table Styles.
2 Expand a table type: Area, Line, Curve, or Segment.
3 Right-click the table style that the new style will be based on and click Copy.
4 In the Table Style dialog box, specify a name for the new style.
5 Modify style settings.

Quick Reference
Toolspace Shortcut Menu
Settings: Right-click Parcel table style ➤ Copy
Dialog Box
Table Style (page 2735)

Deleting Parcel Table Styles
Delete parcel table styles in the Table Styles collection in Toolspace, on the Settings tab.
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To delete a parcel table style
1 In Toolspace, on the Settings tab, expand Parcel ➤ Table Styles.
2 Expand a table type: Area, Line, Curve or Segment.
3 Right-click the style that you want to delete and click Delete.

Quick Reference
Toolspace Shortcut Menu
Settings: Right-click Parcel table style ➤ Delete

Applying Parcel Table Styles
A style is applied to each parcel table in the creation process. You can change this style at any time.
For information about applying table styles in the creation process, see Adding Parcel Tables (page 912).
To replace a parcel table style
1 Click a parcel table in the drawing.
2 Right-click and click Table Properties.
3 In the Table Properties dialog box, replace the table style.

Quick Reference
Ribbon
Table tab ➤ Modify panel ➤ Table Properties drop-down ➤ Table Properties
Object Shortcut Menu
Parcel table object ➤ Table Properties
Dialog Box
Table Properties (page 2741)

Adding Parcel Tables
Use parcel tables to consolidate information about the parcels and parcel segments in your drawing.
Tables provide an alternative to labels for information management. Labels can be hard to read if your
parcels are small and the drawing is crowded with other data. Tables keep the information organized and
separate from the drawing, but cross-referenced by small labels known as tags.
When parcel or segment information is displayed in table rows, table tags uniquely identify the parcels or
segments in the drawing and in the initial cells of table rows. For example, if a line segment is labeled L234,
its corresponding table row is also labeled L234.
In AutoCAD Civil 3D, parcel tables support general line and curve label types. When creating parcel tables,
you can select general line and curve label types and/or parcel segment labels.
For more information about labels, tables, and table tags, see Parcel Labels and Tables (page 898) and Parcel
Label Styles (page 899).
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Line/curve segments must be labeled prior to adding a table to the drawing. When you add the table, the
labels are converted to tags.
You create and edit tables for most objects using the same common procedures and standard dialog boxes.
The procedures included in this topic explain how to work with parcel tables. For general information about
modifying tables, see Modifying Tables (page 1750).

Adding Tables of Parcels
A table of parcels, also known as an area table, displays the data for each parcel in a separate row.
Parcel area tables can include data such as parcel perimeter, segment bearings, and street address, depending
on the table style.
To add a table of parcels
1 Click Annotate tab ➤ Labels & Tables panel ➤ Add Tables menu ➤ Parcel ➤ Add Area

.

2 In the Table Creation dialog box, specify settings as needed, except for the Selection settings.
3 To select parcels for the table, for Selection, do one of the following:
■

In the Label Style Name list, select one or more area label styles. When you select an area label style,
you automatically select all parcels using that style.

■

Click the parcel selector button. Click the text of one parcel label after another. When you finish,
press Enter.

4 Click OK.
The upper-left corner of the new table is attached to your pointer.
5 Click in the drawing to set the location for the new table.

Quick Reference
Ribbon
Annotate tab ➤ Labels & Tables panel ➤ Add Tables menu ➤ Parcel ➤ Add Area
Menu
Annotate tab ➤ Labels & Tables panel ➤ Add Tables menu ➤ Parcel ➤ Add Area
Command Line
AddParcelTable
Dialog Box
Table Creation (page 2739)

Adding Tables of Parcel Lines
A table of parcel lines displays the data for each line in a separate row.
For each line that you want to include in the line table, the Table Tag element of its label style must have
the Used In property set to Tag Mode. Also, the Display Mode property of the label style must be set to Tag.
See Editing Parcel Label Styles (page 901).
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To add a table of parcel lines
1 Click Annotate tab ➤ Labels & Tables panel ➤ Add Tables menu ➤ Parcel ➤ Add Line

.

2 In the Table Creation dialog box, specify settings as needed, except for the Selection settings.
3 To select segments for the table, for Selection, do one of the following:
■

In the Label Style Name list, select one or more segment label styles or general line/curve label styles.
When you select a segment label style, you automatically select all segments using that style.

■

Click the segment selector button. Click one segment after another. When you finish, press Enter.

4 Click OK.
The upper-left corner of the new table is attached to your pointer.
5 Click in the drawing to set the location for the new table.

Quick Reference
Ribbon
Annotate tab ➤ Labels & Tables panel ➤ Add Tables menu ➤ Parcel ➤ Add Line
Menu
Parcels ➤ Tables ➤ Add Line
Command Line
AddParcelLineTable
Dialog Box
Table Creation (page 2739)

Adding Tables of Parcel Curves
A table of parcel curves displays the data for each curve in a separate row.
For each line that you want to include in the line table, the Table Tag element of its label style must have
the Used In property set to Tag Mode. Also, the Display Mode property of the label style must be set to Tag.
See Editing Parcel Label Styles (page 901).
To add a table of parcel curves
1 Click Annotate tab ➤ Labels & Tables panel ➤ Add Tables menu ➤ Parcel ➤ Add Curve

.

2 In the Table Creation dialog box, specify settings as needed, except for the Selection settings.
3 To select segments for the table, for Selection, do one of the following:
■

In the Label Style Name list, select one or more segment label styles or general line/curve label styles.
When you select a segment label style, you automatically select all segments using that style.

■

Click the segment selector button. Click one segment after another. When you finish, press Enter.

4 Click OK.
The upper-left corner of the new table is attached to your pointer.
5 Click in the drawing to set the location for the new table.
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Quick Reference
Ribbon
Click Annotate tab ➤ Labels & Tables panel ➤ Add Tables menu ➤ Parcel ➤ Add Curve
Command Line
AddParcelCurveTable
Menu
Parcels ➤ Add Tables ➤ Add Curve
Parcels menu ➤ Add Tables
Dialog Box
Table Creation (page 2739)

Adding Tables of Parcel Segments
A table of parcel segments displays the data for each segment in a separate row.
For each segment that you want to include in the segment table, the Table Tag element of its label style
must have the Used In property set to Tag Mode. Also, the Display Mode property of the label style must be
set to Tag. See Editing Parcel Label Styles (page 901).
To add a table of parcel segments
1 Click Annotate tab ➤ Labels & Tables panel ➤ Add Tables menu ➤ Parcel ➤ Add Segment

.

2 In the Table Creation dialog box, specify settings as needed, except for the Selection settings.
3 To select segments for the table, for Selection, do one of the following:
■

In the Label Style Name list, select one or more segment label styles. When you select a segment
label style, you automatically select all segments using that style.

■

Click the segment selector button. Click one segment after another. When you finish, press Enter.

4 Click OK.
The upper-left corner of the new table is attached to your pointer.
5 Click in the drawing to set the location for the new table.

Quick Reference
Ribbon
Click Annotate tab ➤ Labels & Tables panel ➤ Add Tables menu ➤ Parcel ➤ Add Segment
Command Line
AddParcelSegmentTable
Menu
Parcels ➤ Add Tables ➤ Add Segments
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Dialog Box
Table Creation (page 2739)

Deleting Parcel Tables
Delete parcel tables by clicking in the drawing.
To delete a parcel table
1 Click a table title or a table column title in the drawing. The entire table is selected.
2 Right-click in the drawing and click Erase.

Quick Reference
Object Shortcut Menu
Parcel table object ➤ Erase

Deleting Parcel Table Rows
Delete parcel table rows by clicking in the drawing.
To delete a parcel table row
1 Click the table row you want to delete. The row is selected.
2 Right-click in the drawing and click Erase.

Quick Reference
Object Shortcut Menu
Parcel table row object ➤ Erase

Parcel Numbering and Naming
Parcels are numbered automatically when you create them. By default, parcel names are based on the parcel
style name template (page 2022). You can manually renumber and/or rename them later.
Area parcels are numbered automatically in creation order, beginning with the Parcel: Next Automatic Area
Counter in the Site Properties dialog box. When you renumber parcels, numbering begins with the Parcel:
Next Manual Area Counter. The same concept applies to segment tags.
Tags are the label elements used as key values in parcel tables.
When numbering automatically, the increment is always 1. When numbering manually (renumbering), you
can select the increment when beginning the renumbering process.

Defining Parcel Numbering Rules
Define numbering rules for parcels, line segments, and curve segments in the Site collection in Toolspace,
on the Prospector tab.
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For each of these elements, you can specify the next automatic counter for numbering automatically, and
the next manual counter for numbering manually (renumbering).
As numbering proceeds, the next-counter values update automatically. These values are properties of the
site, and are retained from one session to the next.
To define parcel numbering rules
1 In Toolspace, on the Prospector tab, expand Sites.
2 Right-click a site and click Properties.
3 In the Site Properties dialog box, click the Numbering tab.
4 On the numbering tab, specify numbering rules.

Quick Reference
Toolspace Shortcut Menu
Prospector: Right-click a site ➤ Properties
Dialog Box
Site Properties (page 2597)

Numbering Area Parcels Automatically
Parcels are numbered automatically when you create them.
To display the numbered tags, you must set the Used In property of the Table Tag of the label style to Tag
Mode. Also, the Display Mode property of the label style must be set to Tag. See Editing Parcel Label Styles
(page 901).
Although this is not the only combination of label style properties that displays the numbered tags, it is the
required combination for creating a segment table. A segment table is required for renumbering segments.
See Numbering Parcel Segments (page 919).
To number area parcels automatically
■

To number parcels automatically, create the parcels. They will be numbered automatically in creation
order. For more information, see Creating Parcels (page 879).

Quick Reference
Ribbon
Home tab ➤ Create Design panel ➤ Parcel drop-down ➤ Parcel Creation Tools
Home tab ➤ Create Design panel ➤ Parcel drop-down ➤ Create Parcel From Objects
Menu
Parcels menu ➤ Create Parcel By Layout
Parcels menu ➤ Create Parcel From Objects
Command Line
CreateParcelByLayout
CreateParcelFromObjects
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Dialog Boxes
Create Parcels by Layout (page 2235)
Create Parcels from Objects (page 2235)
Parcel Layout Tools (page 2245)

Renumbering Parcels
Renumber area parcels after they have been created.
Parcels can be renumbered based on a starting number and increment value; they can be renamed based on
a name template.
To renumber parcels
1 Select the parcel.
2 Click Parcel tab ➤ Modify panel ➤ Renumber/Rename

.

3 In the Renumber/Rename Parcels dialog box, specify the site you want to work with and click Renumber.
4 Specify a starting number and an increment value.
5 Optionally, click Use Name Template In Parcel Style to ensure that the name template is used to resolve
the parcel name when renumbering.
6 Click OK.
7 Click in the drawing to select parcels using the selection jig (similar to the AutoCAD FENCE command,
which selects all objects that cross the selection fence). As each parcel is selected, a temporary line is
drawn and parcels faces are highlighted. When you finish picking parcels, the line disappears, enabling
you to repeat the selection process for another set of parcels.
The parcel numbers, which are displayed in the parcel area labels, are updated after you exit the
command.
8 When you finish renumbering, press Enter.

Quick Reference
Ribbon
Parcel tab ➤ Modify panel ➤ Renumber/Rename
Menu
Parcels menu ➤ Edit Parcel ➤ Renumber/Rename Parcels
Command Line
EditParcelNumbers
Dialog Box
Renumber/Rename Parcels (page 2255)

Renaming Parcels
Rename area parcels after they have been created. The parcels can be renamed automatically based on the
name template.
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To rename parcels
1 Select the parcel.
2 Click Parcel tab ➤ Modify panel ➤ Renumber/Rename

.

3 In the Renumber/Rename Parcels dialog box, specify the site you want to work with and click Rename.
4 Specify a name by manually entering a string or click
to open the Name Template dialog box (page
2022) where you can update the default parcel name, using the name template.
5 Optionally, click Use Name Template In Parcel Style to ensure that the name template is used to resolve
the name when renaming.
6 Click OK.
7 Click in the drawing to select parcels using the selection jig (similar to the AutoCAD FENCE command,
which selects all objects that cross the selection fence). As each parcel is selected, a temporary line is
drawn and parcels faces are highlighted. When you finish picking parcels, the line disappears, enabling
you to repeat the selection process for another set of parcels.
The parcel names, which are displayed in the parcel area labels, are updated after you exit the command.
8 When you finish renaming, press Enter.

Quick Reference
Ribbon
Parcel tab ➤ Modify panel ➤ Renumber/Rename
Menu
Parcels menu ➤ Edit Parcel ➤ Renumber/Rename Parcels
Command Line
EditParcelNumbers
Dialog Boxes
Renumber/Rename (page 2255)
Name Template (page 2022)

Numbering Parcel Segments
Number parcel segments either before or after they have been created.
The parcel segments can be numbered automatically with the Table Tag Numbering dialog box based on a
starting number and increment value.
Line/curve segments can be renumbered only if they are already labeled with a tag label.
To number parcel segments
1 In the Table Tag Numbering dialog box (page 2209), specify the starting number and increment values.
2 Create a parcel segment table of the segments that you want to number/renumber if they are not in a
table already.
See Adding Tables of Parcel Segments (page 915).
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3 Click Parcel tab ➤ Labels & Tables panel ➤ Renumber Tags

.

4 Click one segment label after another.
Segment numbers displayed in the labels are updated as you click them. Also, the numbers displayed
in the first cells of each row of the segment table are updated.
5 When you finish renumbering segments, click OK. At the command prompt, enter E for End.

Quick Reference
Ribbon
Parcel tab ➤ Labels & Tables panel ➤ Renumber Tags
Menu
Parcel menu ➤ Add Tables ➤ Renumber Tags
Command Line
EditParcelTagNumbers
Dialog Box
Table Tag Numbering (page 2209)
Renumber/Rename Parcels (page 2255)

Using Custom Properties with Parcels
Parcels have default properties you can use to identify them. However, if you have custom data that does
not match the existing properties, you can define your own properties. These properties are called user-defined
properties.
You can organize sets of user-defined properties in groups called user-defined property classifications.
You can also use user-defined properties for points. For more information, see Using Custom Properties with
Points (page 445).
NOTE You may also wish to review the following tutorial. While it focuses on user-defined properties for points,
the concepts also apply to parcels.

Assigning User-Defined Properties to Parcels
Assign a User-Defined Classification to a site parcel. This allows you to specify and manage the custom
properties for all parcels in that site parcel.
After you create a User-Defined Classification, you can assign it to the Parcels collection using the Site Parcels
Properties dialog box (page 2256). The properties within the classification are displayed as columns in the
Parcel item list view.
To assign user-defined properties to a parcel
1 In the drawing, define a User-Defined Classification for parcels. For more information, see Creating a
User-Defined Property Classification (page 446).
2 Define the properties in the classification. For more information, see Creating a User-Defined Property
(page 446).
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3 In Toolspace, on the Prospector tab, expand Sites ➤ <Site Name> and then click the Parcels collection.
4 Right-click and click Parcel Properties.
5 In the Site Parcel Properties dialog box, click the Composition tab.
6 On the Composition tab, under User-Defined Property Classification, select the User-Defined
Classification you want to assign to the Site Parcel. This makes your custom properties available to all
parcels that are within the site.
NOTE If you defined default values for your properties, the default value is used for all parcels in the site that
do not already have a value for this property.
7 Click OK.
8 In Toolspace, on the Prospector tab, select the site parcel to which you applied the classification by
clicking Sites ➤ <Site Name> ➤ Parcels collection.
9 In the parcel list view window, right-click a column heading. Select the user-defined properties you
want to display in the list view window.
NOTE You can arrange the display of columns in the list view by dragging column headings. For more
information, see Customizing a List View (page 101).

Next, you can define values for the custom properties by entering data in the list view. You can also set up
label styles to display these values, and then label the parcels. For more information, see Exercise 2: Creating
a Label Style That Displays a User-Defined Property.

Quick Reference
Toolspace Shortcut Menu
Prospector: Sites ➤ <site> ➤ right-click Parcels ➤ click Parcel Properties
Dialog Box
Parcel Properties (page 2251)

Parcels Command Reference
The following table lists parcel commands and briefly describes their functionality. For more information
about a command, follow the link in the Description column.
Command

Description

AddParcelAreaLabel

Adds an area label to selected parcels (page 907)

AddParcelCurveTable

Creates a curve segment table (page 915)

AddParcelLabels

Adds parcel labels (page 904)

AddParcelLineLabel

Creates line or curve labels on a selected parcel segment
(page 905)

AddParcelLineTable

Creates a line segment table (page 914)

AddParcelSegmentLabels

Labels muliple parcel segments (page 906)
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Command

Description

AddParcelSegmentTable

Creates line and curve labels on all segments of selected
parcels (page 915)

AddParcelTable

Creates a parcel area table (page 913)

CreateParcelByLayout

Creates parcels using the Parcel Layout Tools (page 882)

CreateParcelFromObjects

Creates parcels from lines, arcs, and polylines (page
881)

CreateParcelROW

Creates right-of-way parcels for intersecting alignments
and parcels (page 889)

EditParcel

Edits parcels using the Parcel Layout Tools (page 886)

EditParcelNumbers

Specifies a new format for the numbers or names that
identify a set of parcels (page 918)

EditParcelProperties

Edits the properties for a single parcel (page 892)

EditParcelStyle

Picks a different object style for the selected parcel, or
edits the object style (page 895)

EditParcelTagNumbers

Edits parcel tag numbers (page 919)

ExportParcelAnalysis

Exports a parcel inverse or mapcheck report (page 897)

ParcelPropertiesEdit

Edits the properties of a group of parcels, such as all
parcels in a site (page 892)
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Alignments

24

Alignment objects can represent road centerlines, pipe networks, and other construction baselines. Creating and defining
a horizontal alignment is one of the first steps in roadway, railroad, or site design. You can draw the alignment geometry
as a polyline, and then create the named alignment from that geometry. For greater control, you can create an alignment
object using the Alignment Layout Tools. You can also make edits to alignments using grips, or the commands on the
Alignment Layout Tools toolbar, while automatically maintaining tangency between the alignment components.
For information on recommended workflows when working with alignments, see Alignments Workflow (page 40).

Understanding Alignments
You create alignments as a combination of lines, curves, and spirals that are viewed as one object.
Alignments can be stand-alone objects or the parent object of profiles, sections, and corridors. If you edit
an alignment, the changes are automatically reflected in any related objects.

Overview of Alignments
In AutoCAD Civil 3D, you create alignments as objects.
Use the Prospector and Settings tabs to manage alignments in Toolspace.
Alignments are listed in either the Alignments collection or a Site collection in the Prospector tab. From
these collections, you can change alignment properties, generate reports, and export LandXML. See Alignment
Collection (Prospector Tab) (page 925) for more information.
NOTE There is no limit to the number of alignments a user may define in an AutoCAD Civil 3D drawing.
Use the Settings tab in Toolspace to manage the details of alignment object styles, label and table styles, and
command settings.
Control the visual appearance of alignment components and labels through styles. You can create specific
styles to use in the various phases of a project. For more information, see Alignment Styles (page 946).
When you create an alignment, you specify a style for the alignment object and styles for the alignment
labels. In the Alignment Labels dialog box (page 1952), you can create groups of styles for alignment labels,
and then save those labels as a label set to use with other alignments.
Use station equations to change station-distance references at any point without physically changing the
geometry of the alignment.
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Alignment lines, curves, and labels

Examples of alignment labels

Alignment Types
When creating an alignment, assign it a type of centerline, offset, miscellaneous, or curb return.
You can use these alignment types to categorize your data based on alignment function. Select the centerline
type for a road centerline, or the miscellaneous type for other uses, such as a utility conduit. These two types
are independent objects.
Offset alignments (page 2779) and curb return alignments (page 2771) can also be independent, but are often
dynamically linked to other alignments. Both offset alignments and curb returns can be created automatically
as components of an intersection. Offsets can also be used in widenings.
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See also:
■

Creating Alignments (page 948)

■

Widenings (page 964)

Alignment Object Relationships
Alignment objects can establish spatial parameters for other objects, including profiles, sections, corridors,
intersections, and pipe networks.
If an alignment exists in a site, its geometry interacts with that of other objects in the site, such as parcels
and feature lines. For example, an alignment subdivides any parcels it intersects within the site. Any lot
lines or feature lines that cross an alignment assume the same elevation at the intersection point. The
elevation is set by whichever object is last edited. To prevent an alignment from interacting with other
objects in a site, set the site property to <None> or move the alignment to a separate site. For more
information, see Alignment and Site Interaction (page 781).

Alignment Collection (Prospector Tab)
Use the Alignment collection in the Prospector tree to access the alignments in a drawing.
As alignment objects are created, they are displayed as named alignments, organized by type, in one of two
collections:
■

The top-level Alignments collection. When alignments are in the top-level Alignments collection, they
do not interact with parcels contained in Site collections. For more information, see Alignment and Site
Interaction (page 781).

■

A project Site collection. An alignment object can exist in only one Site. When an alignment is in a Site
collection, its geometry interacts with that of other objects in the site, such as parcels and feature lines.
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Sample alignments collections on the Toolspace
Prospector tab

Expand an Alignment collection to view the names of the alignments. Select an Alignment collection to
display a detailed tabular list of Alignment information at the bottom of the Prospector tab. For more
information, see The Toolspace Item View (page 99).
Right-click an individual alignment in the Alignment collection to:
■

View and edit the alignment properties

■

Move or copy an alignment to either another Site or the top-level Alignments collection

■

Zoom or pan to the alignment

■

Export the alignment to LandXML
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Expand an individual alignment name to display profiles, profile views, superelevation views, and sample
line groups that are associated with the alignment.
For more information
about...

See...

Profiles

Profiles Collection (Prospector Tab) (page 1117)

Profile Views

Profile Views Collection (Prospector Tab) (page 1117)

Alignment Collection (Settings Tab)
Manage alignment settings, alignment styles, alignment label styles, alignment table styles, and alignment
command settings in Toolspace, on the Settings tab.
Right-click the Alignment collection to:
■

Edit the alignment feature settings.

■

Edit the default alignment label styles.

■

Refresh the display of the settings tree.

Expand the Alignment collection to display and edit the alignment styles, label and table styles, and command
settings.
See also:
■

Alignment Settings (page 929)

■

Alignment Labels and Tables (page 1043)

The Alignment Styles Collection
Use the Alignment Styles collection in the Settings tree, which lists alignment styles that are available in a
drawing, to create an alignment style.
Expand the Alignment Styles collection to display a list of available alignment styles.
Right-click Alignment Style ➤ New to create an alignment style.
NOTE When you click New in a collection, the new style you create is based on installation defaults, not on the
existing styles in the collection. To create a style from an existing style, right-click the style. Click Copy, and save
the style with a new name.
Right-click an existing alignment style to display the shortcut menu commands:
Select this command...

If you want to...

Edit

Change the selected style.

Copy

Make a copy of the selected style.

Delete

Delete the selected style.

Refresh

Update the current view.
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See also:
■

Alignment Styles (page 946)

The Alignment Design Checks Collection
Use the Alignment Design Checks collection to manage the user-defined checks that verify alignment design
parameters.
Alignment design checks (page 2772) can be created for Line, Curve, Spiral, or Tangent Intersection entity
types. To apply a design check to an alignment, you must add it to a design check set (page 2772).
To edit, create, or copy a design check, right-click an existing design check. Click a command on the shortcut
menu:
Select this command...

If you want to...

Edit

Edit the design check.

Copy

Copy the design check.

Delete

Delete the selected design check. You can only delete
design checks that are not referenced by a design check
sets.

Refresh

Update the current view.

See also:
■

Alignment Design Checks (page 940)

The Alignment Label Styles Collection
Use the Alignment Label Styles collection to override default alignment label settings on the drawing level
and create new styles.
Alignment labels are independent objects that are managed with the AutoCAD Properties palette. At the
feature level, you can override the default label settings you established at the drawing level. You can edit
or create a label style for a specific label type.
NOTE When you click New in a collection, the new style you create is based on installation defaults, not on the
existing styles in the collection. To create a style from an existing style, right-click the style. Click Copy, and save
the style with a new name.
To edit, create, or copy a label style, right-click an existing alignment label style. Click a command on the
shortcut menu:
Select this command...

If you want to...

Edit

Edit the current label style.

Copy

Copy the style.

Delete

Delete the selected style. You can only delete styles
that are not referenced by other objects or label sets.

Refresh

Update the current view.
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See also:
■

Alignment Label Styles (page 1043)

The Alignment Table Style Collection
Use the Alignment Table Style collection to create a table style or to modify an existing table style.
To edit, copy, or delete an alignment table style, right-click an alignment table style. Click a command on
the shortcut menu.
NOTE When you click New in a collection, the new style you create is based on installation defaults, not on the
existing styles in the collection. To create a style from an existing style, right-click the style. Click Copy, and save
the style with a new name.
To edit, create, or copy a table style, right-click an existing alignment label style. Click a command on the
shortcut menu:
Select this command...

If you want to...

Edit

Edit the current table style.

Copy

Copy the style.

Delete

Delete the selected style. You can only delete styles
that are not referenced by other objects or label
sets.

Refresh

Update the current view.

See also:
■

Alignment Table Styles (page 1058)

The Alignment Command Collection
Control the settings for a specific alignment command using the Alignment Commands collection.
When you change settings for a command in the collection, the changes affect that command only.
Expand the Alignment Commands collection, on the Settings tab, to display a list of commands for an
alignment.
Right-click a command name and click Edit Command Settings to open the Edit Command Settings dialog
box for the command. Change the settings as needed.
See also:
■

Alignment Command Reference (page 1088)

Alignment Settings
You can use alignment settings to specify the default behavior for alignment commands.
Settings are handled in a standard way throughout AutoCAD Civil 3D. You access settings using the Settings
tree. Control settings at three levels: the drawing level, the object collection (feature) level, and the command
level. For more information, see Understanding Settings (page 77).
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Use the Settings tree Alignment collection shortcut menu to establish defaults for all alignment commands.
You can change alignment-specific settings at this level, such as Station Indexing and also override the
drawing ambient settings.
Use the Commands collection under the Alignment collection to change alignment settings for a specific
command. You can change alignment-specific settings at this level, or override the drawing ambient settings.
The topics in this section describe only those settings that affect alignment-related commands. The topics
in this section do not cover the drawing ambient settings, which are also displayed in the Edit Feature
Settings - Alignment dialog box.
See also:
■

Specifying Drawing Settings (page 79)

To edit the alignment feature settings
1 In Toolspace, on the Settings tab, right-click the Alignment collection ➤ Edit Feature Settings.
2 In the Edit Feature Settings - Alignment dialog box, expand the display for each setting. Click a cell in
the Value column and enter a new value or specify a different style.
3 Click Apply to accept the changes and continue working in the dialog box or click OK to accept the
changes and close the dialog box.

Quick Reference
Toolspace Shortcut Menu
Settings tab: Right-click Alignment ➤ Edit Feature Settings
Dialog Box
Edit Feature Settings - Alignment Dialog Box (page 1983)

Curve and Spiral Settings
Enter the curve settings you want to use when creating alignments using the Tangent-Tangent (With Curves)
command.
You can specify default settings for curves and spirals by editing the settings in the CreateAlignmentLayout
command.
While you can select various combinations of Spiral In, Curve, and Spiral Out, the A value of the spirals is
controlled by the radius of the curve. The length of the spirals is controlled by changing the A Value.

Specifying Curve and Spiral Settings
Specify default spiral type and values in the Curve and Spiral Settings dialog box or by editing the Curve
and Spiral Settings for the CreateAlignmentLayout command.
The parameter values in the Curve and Spiral Settings dialog box apply only to the curves and spirals created
using the Tangent-Tangent with Curves command in the current alignment. You can specify default settings
for all curves and spirals by editing the settings in the CreateAlignmentLayout command.
To change the default Curve and Spiral Settings for all instances
1 On the Settings tab in Toolspace, expand the Alignments collection and then expand the Commands
collection.
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2 Right-click CreateAlignmentLayout ➤ Edit Command Settings.
3 In the Edit Command Settings-CreateAlignmentLayout dialog box, expand the Curve and Spiral Settings
property.
4 Specify the settings, click Apply and click OK.
NOTE To save these command settings at the drawing level, on the Ambient Setting tab (page 84)select
Yes in the value column for Save Command Changes To Settings.

To change the Curve and Spiral Settings used by the tangent-tangent with curves method
1 Click Home tab ➤ Create Design panel ➤ Alignment drop-down ➤ Alignment Creation Tools

.

2 In the Create Alignment-Layout dialog box (page 1977), enter creation information.
3 On the Alignment Layout Tools toolbar, click

Curve And Spiral Settings.

4 In the Curve and Spiral Settings dialog box (page 930), enter curves values.
NOTE The spiral type you specify in the Curve and Spiral Settings dialog box is used in all spiral commands
on the Alignment Layout Tools toolbar.

Quick Reference
Ribbon
Home tab ➤ Create Design panel ➤ Alignment drop-down ➤ Alignment Creation Tools
Menu
Alignments menu ➤ Create Alignment By Layout
Alignment Layout Tools Toolbar Icon
Curve And Spiral Settings
Command Line
EditAlignment
Dialog Box
Alignment Layout Tools (page 1959)

Specifying a Curve Group Index
Use each index to identify the entities that form part of a complex alignment.
The Curve Group Index identifies a curve group, such as a spiral-curve-spiral group, within an alignment.
The Curve Group Sub-Entity Index identifies each entity within a curve group.
When you label an alignment, you can use these values for alignment identification.
To specify a curve group index
1 Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor

.
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2 On the Alignment Layout Tools toolbar, click

Alignment Grid View.

3 In the Alignment Entities Vista (page 1947), enter values for the Curve Group Index and the Curve Group
Sub-Entity Index.

Quick Reference
Ribbon
Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
Menu
Alignments menu ➤ Edit Alignment Geometry
Alignment Layout Tools Toolbar icons
Alignment Grid View
Dialog Box
Alignment Entities Vista (page 1947)

Alignment Properties
You can use the Alignment Properties dialog box to assign a name, style, and other properties to the alignment.
You can adjust the style, stationing, design criteria, and superelevation parameters of a selected alignment.
You can also view basic information about profiles and profile views that have been created for the current
alignment.
The Alignment Properties dialog box has the following tabs:
■

Information. Specifies name, description, and object style.

■

Station Control. Displays alignment length and raw stationing as well as options to change the station
reference point, and apply station equations.

■

Masking. Specifies one or more regions of the alignment that can be suppressed from display.

■

Design Criteria. Specifies design speed options to select points in the drawing where you want to assign
travel speeds to aid in design and labeling. When you assign a design speed to an alignment station, that
speed is applied to all subsequent points on the alignment, unless another speed is applied at some point.
This value also displays in the Superelevation Curve Manager dialog box (page 2602).
This tab also contains the options related to criteria-based design (page 2771). This optional feature allows
you to specify the design criteria file, default criteria, and design check set for the alignment.

■

Profiles. Displays information for profiles associated with the alignment.

■

Profile Views. Displays information for profile views associated with the alignment.

■

Offset Parameters. If the alignment is a dependent offset, this tab displays properties of the offset.

■

Curb Return Parameters. If the alignment is a curb return, this tab displays data about the two parent
alignments, offset values, and update mode.

NOTE Alignment label properties are controlled using the Alignment Labels dialog box (page 1952).
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See also:
■

Alignment Properties Dialog Box (page 1964)

To change alignment name, description, or style
1 Click Alignment tab ➤ Modify panel ➤ Alignment Properties drop-down ➤ Alignment Properties
.
NOTE The tab most recently opened in the Alignment Properties dialog box is displayed by default.
2 In the Alignment Properties dialog box, click the Information tab (page 1964).
3 Under Name, enter a name for the alignment.
4 Under Description, enter an optional description for the alignment.
5 In the Object Style list, select an existing alignment style.
6 Click the Style Detail button to open the Style Detail dialog box. Preview the alignment style.
To change alignment Station Control
1 Click Alignment tab ➤ Modify panel ➤ Alignment Properties drop-down ➤ Alignment Properties
.
NOTE The tab most recently opened in the Alignment Properties dialog box is displayed by default.
2 In the Alignment Properties dialog box, click the Station Control tab (page 1965).
3 Under Reference Point, click

. The Alignment Properties dialog box closes.

WARNING Changing the reference point location or the reference station value removes all station equations
and design speeds and can adversely affect objects and data already created from the alignment. Click OK
to continue or Cancel to abort this operation. Use Station Equations to change stations after you create Profiles
and Cross Sections.
4 In the drawing, pick a point where you want to establish the XY coordinates for the Reference Point.
The Alignment Properties dialog box is displayed again.
5 In the Reference Point box, under Station, enter a starting station value.
6 In the Station Equations box, click

. The Alignment Properties dialog box closes.

7 In the drawing, pick the point for the first station equation. The Alignment Properties dialog box is
displayed again.
8 Repeat Steps 6 and 7 to add more station equations.
9 By default Station Ahead and Raw Station Back have the same value. Click the Station Ahead cell and
enter a new value.
10 Click the Increase/Decrease cell to determine whether the station values from the Station Equation
increases or decreases from the Station Ahead value.
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To mask an alignment
1 Click Alignment tab ➤ Modify panel ➤ Alignment Properties drop-down ➤ Alignment Properties
.
2 In the Alignment Properties dialog box, click the Masking tab (page 1966).
3 Click

Add Masking Region.

4 Specify the start station for the mask by clicking along the alignment, entering a numeric station value,
or clicking Lock to Start in the masking table.
5 Specify the end station for the mask by clicking along the alignment, entering a numeric station value,
or clicking Lock to End in the masking table.
6 Optionally, enter notes about the mask in the Comment column.
TIP Use the Mask check box to temporarily enable or disable a mask without removing it from the list of masks.
To change alignment design speeds or criteria
1 Click Alignment tab ➤ Modify panel ➤ Alignment Properties drop-down ➤ Alignment Properties
.
NOTE The tab most recently opened in the Alignment Properties dialog box is displayed by default.
2 In the Alignment Properties dialog box, click the Design Criteria tab (page 1966).
3 Click

.

A new row is displayed in the table.
4 In the Start Station column, enter the station at which the design speed begins.
5 For Design Speed, enter the design speed.
The default Design Speed value is specified in the alignment feature settings.
6 Repeat Steps 3 through 5 to add more design speeds.
An alignment can have unlimited numbers of design speeds, but only one speed at any given station.
When a station has a design speed, that speed applies to subsequent stations until either the next station
at which a design speed is set, or the alignment end station. If a single entity has multiple speeds assigned
to it, the highest speed is used to validate that entity against the design criteria. The lower speed values
are ignored.
NOTE To calculate superelevation, you must specify design speeds.
7 On the right side of the dialog box, modify the design criteria as desired.
8 Click OK.
NOTE If design criteria has been associated with the alignment, the entire alignment design is validated
when you click either Apply or OK.
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To view Profiles associated with the alignment
1 Click Alignment tab ➤ Modify panel ➤ Alignment Properties drop-down ➤ Alignment Properties
.
NOTE The tab most recently opened in the Alignment Properties dialog box is displayed by default.
2 Click the Profiles tab. For more information, see Profile Data Tab (Profile Properties Dialog Box) (page
2423).
To view Profile Views associated with the alignment
1 Click Alignment tab ➤ Modify panel ➤ Alignment Properties drop-down ➤ Alignment Properties
.
NOTE The tab most recently opened in the Alignment Properties dialog box is displayed by default
2 Click the Profile View tab. For more information, see Profiles Tab (Profile View Properties Dialog Box)
(page 2429).

Quick Reference
Ribbon
Click Alignment tab ➤ Modify panel ➤ Alignment Properties drop-down ➤ Alignment Properties
Prospector Shortcut Menu
Right-click alignment ➤ Properties
Object Shortcut Menu
Right-click <alignment object> ➤ Alignment Properties
Command Line
EditAlignmentProperties
Dialog Box
Alignment Properties Dialog Box (page 1964).

Criteria-Based Alignment Design
Use the criteria-based design feature to apply agency-specific standards to an alignment.
The criteria-based design feature provides the ability to verify that your alignment design meets the minimum
standards required by your local agency.
When you use the criteria-based design feature, you can select a design criteria file (page 2773), from which
you can specify criteria such as the superelevation attainment method and minimum radius and transition
(spiral) length tables. When you lay out the alignment, the appropriate minimum values specified in the
design criteria file are displayed on the command line. You can either accept the default minimum value
for a given sub-entity, or specify a new value.
Minimum transition length values are automatically generated using the specified curve radius. If there is
no curve associated with the spiral, then the minimum value is the smallest acceptable spiral radius.
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The design criteria file can also include criteria to support automatically adding widening around curves to
dynamic offset alignments. For more information on this feature, see Adding Automatic Widening to
Dynamic Offset Alignments (page 966).
If the design parameters for a sub-entity violate the minimum values established in the design criteria file,
a warning symbol appears both on the sub-entity in the drawing window and next to the violated value in
the Alignment Entities Vista (page 1947) and Alignment Layout Parameters Window (page 1953). When you
hover the cursor over a warning symbol, a tooltip displays which standard has been violated and how to
correct the violation. The display of the warning symbol is controlled by the alignment style.
Some alignment design criteria are not available in table form in the design criteria file. For these criteria,
you can define design checks (page 2772) to validate design standards. To apply a design check to an alignment,
you must add it to a design check set (page 2772).
NOTE Compound spiral length is not validated against the design criteria file. You must use design checks to
validate compound spiral length.
You can generate a report that documents validations or violations in the alignment design. The design
criteria report identifies whether each sub-entity within a given station range violates or meets the appropriate
design criteria and design checks.

Design Criteria Files
A design criteria file contains the standards tables that specify appropriate minimum design standards for
alignments or profiles.
The design criteria file (page 2773) contains the minimum design standards for alignment and profile objects.
You can customize the design criteria file to support local design standards for such things as superelevation
and minimum K values.
Design criteria files containing A.A.S.H.T.O. (page 2767) standards in both metric and imperial units are included
with AutoCAD Civil 3D.
If your local agency standards differ from those in the supplied design criteria files, you can use the Design
Criteria Editor Dialog Box (page 2067) to customize the file to support your local standards.
NOTE If you use a custom a design criteria file, you must save it to a shared server to which all members of your
design team have access. If you send a drawing that uses a custom design criteria file, you must send the design
criteria file with the drawing.

Alignment Design Criteria
A design criteria file can contain the following alignment design criteria:
■

Minimum radius at a given design speed

■

Superelevation attainment method

■

Superelevation rate at a given radius

■

Minimum transition length at a given radius
NOTE Compound spiral length is not validated against the design criteria file. You must use design checks to
validate compound spiral length.

■

Automatically adding widening to dynamic offset alignments. For more information, see Adding Automatic
Widening to Dynamic Offset Alignments (page 966).
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Profile Design Criteria
A design criteria file can contain standards tables for minimum K values at specified design speeds. Minimum
K tables for the following distances are available:
■

Stopping Sight Distance

■

Passing Sight Distance

■

Headlight Sight Distance

See also:
■

Criteria-Based Alignment Design (page 935)

■

Criteria-Based Profile Design (page 1139)

■

Roadway Design Standards (page 1091)

■

Adding Automatic Widening to Dynamic Offset Alignments (page 966)

Creating a Design Criteria File
Create a customized design criteria file to reflect your local standards.
If you do not want to use or modify the provided design criteria file, you can create a custom design criteria
file in either of the following ways:
■

Copy the provided design criteria file. Rename the copy, and then modify the copy to reflect your design
standards.

■

Create an empty design criteria file. Add your local standards using the schema that is defined in the
design criteria file.

To copy the provided design criteria file
1 Click an alignment or profile in the drawing.
2 Click Alignment tab ➤ Modify panel ➤ Design Criteria Editor
3 In the Design Criteria Editor Dialog Box (page 2067), click

.
Open.

4 In the Select A Design Criteria File dialog box, select the design criteria file you want to copy. Click
Open.
5 In the Design Criteria Editor Dialog Box (page 2067), click

Save As.

6 In the Enter A File Name To Save dialog box, enter a new name for the design criteria file. Click Save.
NOTE Design criteria files are saved in this directory: C:\Documents and Settings\All Users|Application
Data\Autodesk\C3D2011\enu\Data\Corridor Design Standards\<units>. The criteria-based design feature uses
the first file found in the directory. To ensure that your new file is used by default, give it a name that places
it before all other files in the directory.

7 In the Design Criteria Editor dialog box, click
side of the dialog box.
8 Select the desired

Expand All to expand all nodes in the tree on the left

table.

Design Criteria Files | 937

The table contents are displayed in the grid view on the right side of the dialog box.
9 Edit contents of the design criteria file as desired.
■

To create new
tables and
folders in the tree view, right-click the desired node and use the
commands on the shortcut menu.

■

To edit a value, double-click the value.

■

To add a row to a table, click

■

To remove a row from a table, click

.
.

10 Click Save And Close to save the new design criteria file and close the Design Criteria Editor dialog box.
See also:
■

Design Criteria Files (page 936)

■

Profile Standards in the Design Criteria File (page 1140)

■

Superelevation Variables and Formulas (page 1092)

■

Adding Automatic Widening to Dynamic Offset Alignments (page 966)

To create an empty design criteria file
1 Click an alignment or profile in the drawing.
2 Click Alignment tab ➤ Modify panel ➤ Design Criteria Editor

.

3 In the Design Criteria Editor Dialog Box (page 2067), click
4 New.
An untitled design criteria file is created, with empty Units, Alignments, and Profiles folders in the tree
view.
5 In the tree view, right-click Units. Click either Metric or Imperial.
6 In the grid view, specify values for the units parameters.
7 In the tree view, right-click either the Alignments or Profiles folder. Click the desired table category.
8 Right-click the table category folder you created in Step 5. Click the desired table.
9 Enter a name for the table you created in Step 6.
10 Edit contents of the table as desired.
■

To edit a value, double-click the value.

■

To add a row to a table, click

■

To remove a row from a table, click

.
.

11 Repeat Steps 5 through 8 to add more tables to the design criteria file.
12 In the Design Criteria Editor dialog box, click

938 | Chapter 24 Alignments

Save.

13 In the Enter A File Name To Save dialog box, enter a new name for the design criteria file. Click Save.
NOTE Design criteria files are saved in this directory: C:\Documents and Settings\All Users|Application
Data\Autodesk\C3D2011\enu\Data\Corridor Design Standards\<units>. The criteria-based design feature uses
the first file found in the directory. To ensure that your new file is used by default, give it a name that places
it before all other files in the directory.
14 Click Save And Close to save the new design criteria file and close the Design Criteria Editor dialog box.
See also:
■

Design Criteria Files (page 936)

■

Profile Standards in the Design Criteria File (page 1140)

■

Superelevation Variables and Formulas (page 1092)

■

Examples of Attainment Methods (page 1094)

■

Adding Automatic Widening to Dynamic Offset Alignments (page 966)

Quick Reference
Ribbon
Click Alignment tab ➤ Modify panel ➤ Design Criteria Editor
Menu
Click Alignments menu ➤ Design Criteria Editor.
Dialog Box
Design Criteria Editor Dialog Box (page 2067)

Editing a Design Criteria File
Modify a design criteria file to reflect your local standards.
You use the Design Criteria File Editor dialog box (page 2067) to edit the design criteria file.
To edit a design criteria file
1 Click an alignment or profile in the drawing.
2 Click Alignment tab ➤ Modify panel ➤ Design Criteria Editor

.

3 In the Design Criteria File Editor dialog box (page 2067), expand the desired
left side of the dialog box.
4 Select the desired

folder in the tree on the

table.

The table contents are displayed in the grid view on the right side of the dialog box.
5 Edit contents of the design criteria file as desired.
■

To create new
tables and
folders in the tree view, right-click the desired node and use the
commands on the shortcut menu.
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■

To edit a value in the grid view, double-click the value.

■

To add a row to a table, click

■

To remove a row from a table, click

.
.

6 Click Save And Close to save the design criteria file with your changes and close the Design Criteria
Editor dialog box.
See also:
■

Design Criteria Files (page 936)

■

Profile Standards in the Design Criteria File (page 1140)

■

Superelevation Variables and Formulas (page 1092)

■

Examples of Attainment Methods (page 1094)

■

Adding Automatic Widening to Dynamic Offset Alignments (page 966)

Quick Reference
Ribbon
Click Alignment tab ➤ Modify panel ➤ Design Criteria Editor
Menu
Click Alignments menu ➤ Design Criteria Editor
Dialog Box
Design Criteria Editor Dialog Box (page 2067)

Alignment Design Checks
Create design checks to verify the design parameters for criteria that are not included in the design criteria
file.
The tables contained in the design criteria file (page 2773) contain the most commonly used criteria for alignment
design. Other criteria can be checked by using mathematical expressions known as design checks (page 2772).
Design checks are created and managed in the same manner as label expressions. Use the Design Check
Editor dialog box (page 2069), which is similar to the Expressions Dialog Box (page 2211), to create and edit
design checks. To apply a design check to an alignment, you must add it to a design check set (page 2772),
which is similar to an alignment label set.
You can create design checks for lines, curves, spirals, and tangent intersections, which are groups of multiple
line, curve, and spiral entities.
Independent entities are checked separately from sub-entities in tangent intersection groups. To apply the
same design check to both entity types, create a separate design check for each type. For example, to enforce
a minimum radius for all curves, create a curve design check for use with the independent curves and a
tangent intersection design check for use with spiral-curve-spiral groups.
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Design checks differ from label expressions in that they always return a true or false value. For example, you
can create a design check to issue a notification if a tangent is shorter than a specified minimum tangent
length.
See also:
■

Expressions (page 1726)

■

Using Alignment Label Sets (page 1045)

Design Check Examples
Following are some examples of design check syntax.
The following examples demonstrate the type of parameters that can be validated using design checks. Use
the examples as a basis to create your own custom design checks.
NOTE Several design checks are included in the AutoCAD Civil 3D templates in the
Toolspace ➤ Settings ➤ Alignment and Profile ➤ Design Checks collections.

Minimum Tangent Length
This design check validates that a tangent is a minimum specified length.
Name

Tangent Length >= 100

Type

Line

Formula

{Tangent Length}>=100

Formula Description

Tangents must be greater than or equal to 100.

Minimum Tangent Length at a Design Speed
This design check validates that a minimum tangent length is used at a given design speed.
Name

Tangent Length >= 100 @ 45mph

Type

Line

Formula

IF({Design Speed}>=45,Length>=100,1)

Formula Description

If the design speed is greater than or equal to 45, the tangent
length must be greater than or equal to 100.
NOTE In the IF function, the ending 1 indicates that if the entity
meets both the design speed and length conditions, a true value
is returned. A true value means that the entity meets the design
check, and no warning is issued. If the entity does not meet one
or both of the conditions of the design check, a warning is issued.

Design Speed On Curve Radius
This design check validates that a minimum curve radius is used at a given design speed. This design check
is relatively complex, and combines several formulas into a single design check.
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In this example, the minimum curve radius at eight separate design speeds is validated. When applied to
an alignment, the design check checks the curve design speed value, and then validates that the radius is
greater than or equal to the specified value.
Name

Design Speeds On Curve Radii (Multiple)

Type

Curve

Formula

IF({Design Speed}>=120,Radius>=750,
IF({Design Speed}>=100,Radius>=500,
IF({Design Speed}>=80,Radius>=300,
IF({Design Speed}>=70,Radius>=200,
IF({Design Speed}>=60,Radius>=125,
IF({Design Speed}>=50,Radius>=80,
IF({Design Speed}>=40,Radius>=50,
IF({Design Speed}>=30,Radius>=30,
Radius>= 0))))))))

Formula Description

If the design speed is greater than or equal to one of the specified
speed values, the radius must be greater than or equal to the
specified radius value for that speed.

Design Speed On Tangent Length
This design check validates that the tangent length is within a specified range at a given design speed. This
design check is relatively complex, and combines a several formulas into a single design check.
In this example, tangent length at five separate design speeds is validated. When applied to an alignment,
the design check checks the tangent design speed value, and then validates that the tangent length is within
the specified range.
Name

Design Speeds On Tangent Lengths (Multiple)

Type

Line

Formula

IF({Design Speed}>=120,(2000>=Length)*(Length>=500),
IF({Design Speed}>=100,(2000>=Length)*(Length>=400),
IF({Design Speed}>=80,(1500>=Length)*(Length>=350),
IF({Design Speed}>=70,(1200>=Length)*(Length>=300),
IF({Design
Speed}>=60,(1000>=Length)*(Length>=250),Length>=0)))))

Formula Description

If the design speed is greater than or equal to one of the specified
speed values, the tangent length value must be between the
maximum and minimum values specified for that speed.

See also:
■

Alignment Design Checks (page 940)

■

Profile Design Checks (page 1140)

Creating a Design Check
To create a design check, set up a mathematical formula that uses existing alignment sub-entity properties.
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Use the Toolspace Settings tab to create and manage design checks. You must create separate design checks
for lines, curves, spirals, and curve groups (tangent intersections). To apply a design check to an alignment,
you must add it to a design check set (page 2772).
Independent entities are checked separately from sub-entities in tangent intersection groups. To apply the
same design check to both entity types, create a separate design check for each type. For example, to enforce
a minimum radius for all curves, create a curve design check for use with the independent curves and a
tangent intersection design check for use with spiral-curve-spiral groups.
See also:
■

Alignment Design Checks (page 940)

To create a design check
1 In Toolspace, on the Settings tab, expand the Alignment ➤ Design Checks collection.
2 Right-click the entity type collection for which you want to create a design check. Click New.
Alternatively, you can expand the entity type collection for which you want to create a design check,
right-click an existing design check, and click Copy.
3 In the Design Check Editor dialog box (page 2069), enter a name and description for the design check.
BEST PRACTICE The name of the design check should be similar to the formula you enter in the Design
Check field. When a design check is violated, only the design check name is displayed, and not the minimum
acceptable value. If the formula is in the design check name, it is easier to correct the violation.
4 Click Insert Property. Select a property from the list.
The property appears in the Design Check field.
5 Add functions, constants, and logical operators to complete the design check.
Because design checks return either a true or false value, they must contain one of the following logical
operators: > (greater than), < (less than), >= (greater than or equals), <= (less than or equals), != (not
equals), = (equals).
NOTE Do not insert anything into the { } brackets that surround the property fields.
■

Click Insert Function to insert mathematical functions like TAN.

■

Use the calculator buttons or click in the Design Check field and use your keypad to enter numbers,
constants, and mathematical operators like * (multiply) or / (divide).

NOTE For a complete list of operators and functions, see Design Check Editor Dialog Box (page 2069).
6 Click OK.
NOTE To apply a design check to an alignment or profile, it must be saved in a design check set. For more
information, see Creating a Design Check Set (page 945) or Editing a Design Check Set (page 945).

See also:
■

Alignment Design Checks (page 940)

■

Design Check Examples (page 941)
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Quick Reference
Toolspace Shortcut Menu
<drawing name> ➤ Alignment ➤ Design Checks ➤ <design check type collection> ➤ <right-click design
check in item view>
Dialog Box
Design Check Editor Dialog Box (page 2069)

Editing a Design Check
After you create a design check, you can edit it from the Settings tab in Toolspace.
Click the appropriate Design Checks collection to display the list of defined design checks in the Toolspace
item view. Right-click a design check to access commands.
See also:
■

Alignment Design Checks (page 940)

To edit a design check
1 In Toolspace, on the Settings tab, select the Design Checks collection that contains the design check
that you want to edit.
2 Ensure the Toolspace item view is visible.
3 Right-click a design check in the item view. Click Edit.
4 Edit the design check using the (page 2069)Design Check Editor dialog box.

Quick Reference
Toolspace Settings Tab Shortcut Menu
<drawing name> ➤ Alignment ➤ Design Checks ➤ <design check type collection> ➤ <right-click design
check in item view>
Dialog Box
Design Check Editor Dialog Box (page 2069)

Alignment Design Check Sets
Save commonly used combinations of design checks in a design check set, which is then applied to an
alignment.
After you create a design check (page 2772), save it with an appropriate combination of other design checks
in a design check set. A design check set can be applied to an alignment either during the alignment creation
process, or through the properties of an existing alignment.
A design check set consists of design checks for a combination of design check types. For example, you can
create a design check set that consists of separate design checks for minimum and maximum A values for
spirals, minimum radii for curves, and minimum spiral transition lengths.
Design check sets are created and managed in the same manner as label sets. Use the Design Check Set dialog
box (page 2070), which is similar to the Label Set dialog box (page 2206), to create and edit design check sets.
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NOTE Design checks validate the type of entity for which they were created, whether the entity is independent
entity or a sub-entity in a tangent intersection group. For example, a curve design check validates a curve that is
part of a spiral-curve-spiral group. However, a design check that validates the properties of a curve in
spiral-curve-spiral groups does not validate the same properties of a standalone curve.

Creating a Design Check Set
Use the Design Check Set dialog box to assign design checks to the individual alignment or profile elements
that you want to validate.
Create design check sets from the Alignment ➤ Design Checks ➤ Design Check Sets and Profile ➤ Design
Checks ➤ Design Check Sets collections in Toolspace on the Settings tab.
To create a design check set
1 In Toolspace, on the Settings tab, expand either the Alignment ➤ Design Checks or Profile ➤ Design
Checks collection.
2 Right-click the Design Check Sets collection. Click New.
3 In the Design Check Set dialog box, on the Information tab (page 2070), enter a name and optional
description of the design check set.
4 In the Design Check Set dialog box, on the Design Checks tab (page 2071), from the Type list, select a
design check type.
5 From the <type> Checks list, select a design check.
6 Click Add.
The design check is added to the design check set and appears in the table in the dialog box.
7 Repeat Steps 4 through 6 to add other design checks to the design check set.
8 If you are creating a profile design check set, use the Apply To column to specify the type of curve (sag,
crest, or both) to apply each curve check.
9 Click OK.
See also:
■

Alignment Design Checks (page 940)

■

Applying Design Criteria to an Existing Alignment (page 1079)

Quick Reference
Toolspace Shortcut Menu
<drawing name> ➤ Alignment ➤ <right-click> Design Check Sets ➤ New
Dialog Box
Design Check Set Dialog Box (page 2070)

Editing a Design Check Set
Use the Design Check Set dialog box to edit existing design check sets.
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Edit design check sets from the Alignment ➤ Design Checks ➤ Design Check Sets and Profile ➤ Design
Checks ➤ Design Check Sets collections in Toolspace on the Settings tab.
To edit a design check set
1 In Toolspace, on the Settings tab, expand either the Alignment ➤ Design Checks or Profile ➤ Design
Checks collection.
2 Right-click the design check set that you want to edit. Click Edit.
3 Use the Design Check Set dialog box, on the Design Checks tab (page 2071), to edit the design check set.
4 Click OK.
See also:
■

Alignment Design Checks (page 940)

■

Applying Design Criteria to an Existing Alignment (page 1079)

Quick Reference
Toolspace Shortcut Menu (alignment design check sets)
<drawing name> ➤ Alignment ➤ <right-click> Design Check Sets ➤ Edit
Toolspace Shortcut Menu (profile design check sets)
<drawing name> ➤ Profile ➤ <right-click> Design Check Sets ➤ Edit
Dialog Box
Design Check Set Dialog Box (page 2070)

Alignment Styles
You can use Alignment Styles to control the visual display of each alignment component.
Changes made to a style are applied to all alignments that use the style.
Use styles to control the appearance of the alignment object components, as well as the types and appearance
of alignment labels.
You can create specific styles to use for the different phases of a project. For example, you can create one
style to use in the design layout phase and another style to use for plotting.
Access alignment styles using these methods:
If you want to access alignment Then...
styles...
In the drawing

Right-click an alignment ➤ Edit Alignment
Style.

On the Settings tab in Toolspace

Right-click a style in the Alignment Styles folder
➤ Edit.

NOTE When you click New in a collection folder, the new style you create is based on installation defaults, not
on the existing styles in the collection. To create a style from an existing style, right-click the style. Click Copy and
save the style with a new name.
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You use the tabs in the Alignment Style dialog box to set style information:
■

Information. Specifies name, description, and creation information.

■

Design. Specifies certain grip edit behavior.

■

Markers. Specifies marker styles and marker placement options for alignment points.

■

Display. Lists the alignment components and display options as well as the choice of 2D or 3D visibility.
You can display components in plan, model, or section views.

■

Summary. Lists all the style properties.

Applying an Alignment Style
You can apply different styles to alignments to change the visual display of the alignment components.
You can create specific styles to use for the different phases of a project. For example, you can create one
style to use in the design layout phase and another style to use for plotting.
To apply an alignment style to an existing alignment
1 In the drawing, click an alignment.
2 Click Alignment tab ➤ Modify panel ➤ Alignment Properties drop-down ➤ Alignment Properties
.
3 In the Alignment Properties dialog box (page 932), on the Information tab, use the Object Style list to
select a style.
4 Click OK.

Quick Reference
Ribbon
Click Alignment tab ➤ Modify panel ➤ Alignment Properties drop-down ➤ Alignment Properties
Toolspace Shortcut Menu
Prospector tab: Right-click alignment object ➤ Properties
Object Shortcut Menu
Right-click <alignment object> ➤ Alignment Properties
Dialog Box
Alignment Properties (page 932)

Copying or Editing Alignment Styles
Copy or edit an alignment style by clicking an existing style, modifying it, and saving it with a new name.
To copy or edit an alignment style
1 In Toolspace, on the Settings tab, expand the Alignment Styles collection and right-click an existing
style.
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2 Click Copy or Edit.
3 In the Alignment Style dialog box, click the Information tab (page 1970). Enter a new name and description
for the alignment style.
4 Click the Design tab (page 1970). Specify the radius snap and the snap values.
5 Click the Markers tab (page 1970). Specify the display properties for the alignment.
6 Click the Display tab (page 1971). Specify the display properties for the alignment.
7 To view a summary of information about the style, click the Summary tab (page 1971).
8 Click Apply.

Quick Reference
Ribbon
Click Alignment tab ➤ Modify panel ➤ Alignment Properties drop-down ➤ Edit Alignment Style
Toolspace Shortcut Menu
Settings tab: Right-click alignment style item ➤ Copy
Object Shortcut Menu
Right-click <alignment object> ➤ Edit Alignment Style
Dialog Box
Alignment Style Dialog Box (page 1970)

Creating Alignments
Create alignments in many ways using AutoCAD Civil 3D, such as creating them from polylines, and using
the Alignment Layout Tools.
When you create an alignment, you can use the criteria-based design (page 2771) feature to ensure that your
alignment design meets minimum local standards. For more information, see Criteria-Based Alignment
Design (page 935).
NOTE You can also create alignments either from pipe networks or by importing them from LandXML files. For
more information, see Creating Alignments from Pipe Network Parts (page 1338) and LandXML Import and Export
(page 1875).

Creating an Alignment with the Alignment Layout Tools
Create an alignment with the Alignment Layout Tools.
Use the layout command to create an alignment. Specify a unique name, site (if desired), style and label set,
and criteria-based design (page 2771) options. Then, use the Alignment Layout Tools to draw the alignment.
This toolbar provides two types of alignment creation tools:
■

Freehand drawing tools for lines, curves, and spirals.

■

Constraint-based tools that define individual entities by parameters such as length and radius.
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To create an alignment using the alignment layout tools
1 Click Home tab ➤ Create Design panel ➤ Alignment drop-down ➤ Alignment Creation Tools

.

2 In the Create Alignment - Layout Dialog Box (page 1977), enter a unique name for the alignment.
3 Enter an optional description.
4 Enter a starting station value.
5 On the General tab, specify the following settings:
■

Site
Specify a site with which to associate the alignment or accept the default <None>. For more
information, see Understanding Sites (page 779).

■

Alignment Style

■

Alignment Layer

■

Alignment Label Set

6 On the Design Criteria tab, specify a Starting Design Speed to apply to the alignment starting station.
This design speed is applied to the entire alignment. Additional design speeds can be applied at other
stations after the alignment has been created. For more information, see Alignment Properties (page
932).
NOTE If you do not want to apply design criteria to the alignment, proceed to Step 8.
7 To associate design standards with the alignment, select the Use Criteria-Based Design check box.
For more information, see Criteria-Based Alignment Design (page 935).
On the Design Criteria tab, specify the following settings:
■

Use Design Criteria File
Select this check box to associate a design criteria file with the alignment. The default design criteria
file location and the Default Criteria properties becomes available when you select the check box.
NOTE The first design criteria file found in the C:\Documents and Settings\All Users|Application
Data\Autodesk\C3D2011\enu\Data\Corridor Design Standards\<units> directory is used by default when
the criteria-based design feature is used.

■

Use Design Check Set
Select this check box to associate a design check set with the alignment. The design check set list
becomes available when you select the check box. Select a design check set from the list.
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8 Click OK to display the Alignment Layout Tools toolbar.
9 Use the commands on the Alignment Layout Tools toolbar to draw the alignment. For more information,
see Alignment Layout Tools (page 1959) and Adding Lines, Curves, and Spirals to an Alignment (page
970).

Quick Reference
Ribbon
Home tab ➤ Create Design panel ➤ Alignment drop-down ➤ Alignment Creation Tools
Menu
Alignments menu ➤ Create Alignment By Layout
Command Line
CreateAlignmentLayout
Dialog Box
Create Alignment - Layout Dialog Box (page 1977)

Drawing Tangent-Tangent Alignments
Use the Alignment Layout Tools to create and edit alignments.
You can use either of the following commands to create a quick layout of the alignment. The lines and
curves you create are fixed entities that can be edited without losing tangency.

Tangent-Tangent No Curves
Use this command to create a quick layout of an alignment. Specify tangent points of intersection (PI).
Optionally add curves later.

Tangent-Tangent With Curves
Use this command to lay out an alignment, automatically creating curves at points of intersection (PI). Curve
parameters are the current values in the Curve and Spiral Settings dialog box.
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TIP You can use transparent commands when you are prompted to specify direction, radius, or length, or use
station offsets to specify any points. For more information, see Transparent Commands (page 1767).
See also:
■

Curve and Spiral Settings (page 930)

To draw an alignment using the tangent-tangent method with no curves
1 Click Home tab ➤ Create Design panel ➤ Alignment drop-down ➤ Alignment Creation Tools

.

2 In the Create Alignment-Layout (page 1977) dialog box, enter creation information.
3 On the Alignment Layout Tools toolbar, click

Tangent-Tangent (No Curves).

4 Specify the start point.
5 Continue to specify points. Press Enter to end the command, or click another command from the
Alignment Layout Tools toolbar.
To draw an alignment using the tangent-tangent method with curves
1 Click Home tab ➤ Create Design panel ➤ Alignment drop-down ➤ Alignment Creation Tools

.

2 In the Create Alignment-Layout (page 1977) dialog box, enter creation information.
3 On the Alignment Layout Tools toolbar, click

Tangent-Tangent (With Curves).

4 Specify the start point.
5 Continue to specify points. Press Enter to end the command or select another command from the
Alignment Layout Tools.
Curves are created to comply with the values in one of the following places:
■

If the alignment has design criteria (page 935) applied to it, the minimum radius for the current
design speed is applied to the curve. If no solution can be found with the minimum radius value,
the curve is not drawn.

■

If the alignment does not have design criteria applied to it, the default value specified in the curve
and spiral settings is applied to the curve. For more information, see Curve and Spiral Settings (page
930).
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To insert a PI on a fixed line
1 Click Alignment tab ➤ Modify panel ➤ Geometry Editor
2 On the Alignment Layout Tools toolbar, click

.

Insert PI.

3 In the drawing, pick a point near a tangent, where you want to insert the PI.
To remove a PI and combine two tangents
1 Click Alignment tab ➤ Modify panel ➤ Geometry Editor
2 On the Alignment Layout Tools toolbar, click

.

Delete PI.

3 In the drawing, pick a point near the PI you want to delete.
To break apart the PI of an incoming or outgoing tangent endpoint
1 Click Alignment tab ➤ Modify panel ➤ Geometry Editor
2 On the Alignment Layout Tools toolbar, click

.

Break-Apart PI.

3 In the drawing, pick a point near the PI you want to break apart.
4 Specify the distance to split the PI by picking two points or entering a value on the command line. This
value is the distance each line is shortened from the PI.
5 Specify the second point.

Quick Reference
Ribbon
Click Home tab ➤ Create Design panel ➤ Alignment drop-down ➤ Alignment Creation Tools
Click Alignment tab ➤ Modify panel ➤ Geometry Editor
Menu
Click Alignments menu ➤ Create Alignment By Layout
Click Alignments menu ➤ Edit Alignment Geometry
Command Line
CreateAlignmentLayout
EditAlignment
Dialog Box
Create Alignment - Layout Dialog Box (page 1977)
Alignment Layout Tools (page 1959)

Creating an Alignment from Graphic Entities
Create an alignment from selected lines, curves, or polylines.
This command converts a series of graphic entities to an alignment, and optionally adds curves between
tangents.

952 | Chapter 24 Alignments

To create an alignment from graphic entities
1 Draw one or more lines, curves, or polylines in the drawing.
2 Click Home tab ➤ Create Design panel ➤ Alignment drop-down ➤ Create Alignment From Alignment
.
3 Select the graphic entities.
NOTE Enter XREF at the command line to select entities from within the xref drawing. See AutoCAD Help
for more information about external drawing references.
4 In the Create Alignment From Objects Dialog Box (page 1975), enter a unique name for the alignment.
5 Enter an optional description.
6 Enter a starting station value.
7 On the General tab, specify the following settings:
■

Site
Specify a site with which to associate the alignment or accept the default <None>. For more
information, see Understanding Sites (page 779).

■

Alignment Style

■

Alignment Layer

■

Alignment Label Set

8 On the Design Criteria tab, specify a Starting Design Speed to apply to the alignment starting station.
This design speed is applied to the entire alignment. Additional design speeds can be applied at other
stations after the alignment has been created. For more information, see Alignment Properties (page
932).
NOTE If you do not want to apply design criteria to the alignment, proceed to Step 8.
9 To associate design standards with the alignment, select the Use Criteria-Based Design check box.
For more information, see Criteria-Based Alignment Design (page 935).
On the Design Criteria tab, specify the following settings:
■

Use Design Criteria File
Select this check box to associate a design criteria file with the alignment. The default design criteria
file location and the Default Criteria properties become available when you select the check box.
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NOTE The first design criteria file found in the C:\Documents and Settings\All Users|Application
Data\Autodesk\C3D2011\enu\Data\Corridor Design Standards\<units> directory is used by default when
the criteria-based design feature is used.
■

Use Design Check Set
Select this check box to associate a design check set with the alignment. The design check set list
becomes available when you select the check box. Select a design check from the list.

10 Click OK.

Quick Reference
Ribbon
Home tab ➤ Create Design panel ➤ Alignment drop-down ➤ Create Alignment From Objects
Menu
Click Alignments menu ➤ Create Alignment From Polyline
Command Line
CreateAlignmentEntities
Dialog Box
Create Alignment From Objects Dialog Box (page 1975)

Creating an Alignment Reference
Create a reference to an existing alignment in a data shortcut (page 2772) or a Vault project
The alignment reference is a lightweight read-only copy of the original, but it gives you access to alignment
data for other objects. Before you create the alignment reference, it must exist in the current project collection
on the Toolspace Prospector tab
See also:
■

Creating Data Shortcuts (page 151)

■

Using Vault (page 158)

To create a reference to a data shortcut alignment
1 In Toolspace, on the Prospector tab, ensure that the correct working folder is identified on the Data
Shortcuts node.
2 Expand the Data Shortcuts ➤ Alignments collection.
3 Right-click the desired alignment, and then click Create Reference.
The Create Alignment Reference dialog box is displayed, in which you can optionally change the
properties of the reference alignment, as described in the following steps.
4 In the Create Alignment Reference dialog box, change the source of the reference by selecting a source
in the Source Alignment list.
5 Specify a Site with which to associate the alignment or accept the default <None>. For more information,
see Understanding Sites (page 779).
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6 Enter a Name for the alignment.
NOTE To name the alignment, click its default name. Enter a new name, or use the name template. For
more information, see Name Template Dialog Box (page 2022).
7 Specify an Alignment Style or accept the default style.
For more information, see Alignment Styles (page 946).
8 Click

to select a layer. For more information about layers, see Object Layer Dialog Box (page 2221).

NOTE If you do not select a layer, the alignment is placed on the current layer.
9 Specify a Alignment Label Set or accept the default label set.
10 Click OK to create the alignment reference.
The alignment name is displayed under the Alignments collection in the Prospector tree with a
to it.

next

To create a reference to an alignment in a Vault project
1 In Toolspace, on the Prospector tab, in Master View, expand the Projects <project name> ➤ Alignments
collection.
2 Right-click the desired alignment, and then click Create Reference.
The Create Alignment Reference dialog box is displayed, in which you can optionally change the
properties of the reference alignment, as described in the following steps.
3 In the Create Alignment Reference dialog box, change the source of the reference by selecting a source
in the Source Alignment list.
4 Specify a Site with which to associate the alignment or accept the default <None>. For more information,
see Understanding Sites (page 779).
5 Enter a Name for the alignment.
NOTE To name the alignment, click its default name. Enter a new name, or use the name template. For
more information, see Name Template Dialog Box (page 2022).
6 Specify an Alignment Style or accept the default style.
For more information, see Alignment Styles (page 946).
7 Click

to select a layer. For more information about layers, see Object Layer Dialog Box (page 2221).

NOTE If you do not select a layer, the alignment is placed on the current layer.
8 Specify an Alignment Label Set or accept the default label set.
9 Click OK to create the alignment reference.
The alignment name is displayed under the Alignments collection in the Prospector tree with a
to it.

next
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Quick Reference
Toolspace Right-Click Menu (for data shortcut project)
Prospector tab: Data Shortcuts ➤ Alignments ➤ <alignment name> ➤ Create Reference
Toolspace Right-Click Menu (for Vault project)
Prospector tab: Projects ➤ <project name> ➤ Alignments ➤ <alignment name> ➤ Create Reference
Command Line
CreateAlignmentReference
Dialog Box
Create Alignment Reference (page 2450)

Creating Offset Alignments
Create parallel alignments that are dynamically linked to an existing alignment.
In a single operation, create multiple offset alignments on one or both sides of the parent alignment. The
offset distance is specified separately for left and right sides.

Left and right sides are determined from a position facing toward the end of the parent alignment.
The offset alignments retain their offset distance if the parent alignment is edited. The only geometric
attribute of the offset alignments to be edited directly is offset distance.
To create offset alignments
1 Click Home tab ➤ Create Design panel ➤ Alignment drop-down ➤ Create Offset Alignment
2 In the Create Offset Alignments (page 1981) dialog box, select the following attributes:
■

Parent alignment

■

Name template

■

Station range for the offset

■

Number of offsets on each side

■

Incremental offset distance on each side

■

Design Criteria (optional): design speed, criteria set

3 On the General tab, enter the site, alignment style, layer, and label set for the offset alignments.
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.

4 If you want to apply criteria-based design to the offset alignments, click the Design Criteria tab. Enter
the required design speed. Click Use Criteria-Based Design, and then select the criteria for the design.

Quick Reference
Ribbon
Click Home tab ➤ Create Design panel ➤ Alignment drop-down ➤ Create Offset Alignment
Command Line
CreateOffsetAlignment
Dialog Box
Create Offset Alignments Dialog Box (page 1981)

Creating an Alignment from an Existing Alignment
Create an alignment from all or part of an existing alignment.
This command enables you to use a portion of an existing alignment as a starting point for a new alignment.
The selected geometry in the source alignment is converted to line, curve, and spiral sub-entities in the new
alignment.
This command is useful when you need to perform the following tasks:
■

Extract a portion of a source alignment to use as a baseline to create a secondary alignment that merges
with or exits from the primary (source) alignment.
Select a source alignment (1), and then specify a range of stations (2) to create an alignment (3). Add
sub-entities onto the new alignment (4) to create an alignment that merges into or exits from the source
alignment.
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■

Explore route alternatives between two sections of a source alignment.
Select a source alignment (1), and then specify sub-entities (2) from which to create an alignment (3).
Add sub-entities onto the new alignment (4) to create an alternative design that is based on the source
alignment.
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NOTE You can create the alignment using several, non-contiguous station ranges or alignment sub-entities from
the source alignment. By default, the station values of the new alignment match the station values of the source
alignment.
To create an alignment from an existing alignment
1 Click Home tab ➤ Create Design panel ➤ Alignment drop-down ➤ Create Alignment From Existing
Alignment

.

2 Select an alignment in the drawing, or press Enter to select it from a list.
The following prompt is displayed: Specify split point on alignment or [Entities/Finish]
<Entities>:

You can specify multiple, non-contiguous portions of the source alignment:
■

To add a range of stations from the source alignment, click the desired start and end stations, or
enter station numbers at the command line.
NOTE Some spiral types cannot be partially selected. If the Unable to create alignment from partial
selection of this spiral type prompt is displayed, then you must specify start and end stations that
encompass the entire spiral.

■

To add a series of sub-entities from the source alignment, press Enter. Click the desired sub-entities
on the source alignment.

3 Type ‘f’ to finish the selection.
4 In the Create Alignment from Existing Alignment Dialog Box (page 1973), enter a unique name for the
alignment.
5 Enter an optional description.
6 Enter a starting station value.
By default, this value is the lowest station that you specified, or the starting station of the beginning
sub-entity that you selected.
7 On the General tab, specify the following settings:
■

Site
Specify a site with which to associate the alignment or accept the default <None>. For more
information, see Understanding Sites (page 779).

■

Alignment Style

■

Alignment Layer

■

Alignment Label Set

8 On the Design Criteria tab, specify a Starting Design Speed to apply to the alignment starting station.
This design speed is applied to the entire alignment. Additional design speeds can be applied at other
stations after the alignment has been created. For more information, see Alignment Properties (page
932).
NOTE If you do not want to apply design criteria to the alignment, proceed to Step 10.
9 To associate design standards with the alignment, select the Use Criteria-Based Design check box.
For more information, see Criteria-Based Alignment Design (page 935).
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On the Design Criteria tab, specify the following settings:
■

Use Design Criteria File
Select this check box to associate a design criteria file with the alignment. The default design criteria
file location and the Default Criteria properties becomes available when you select the check box.
NOTE The first design criteria file found in the C:\Documents and Settings\All Users|Application
Data\Autodesk\C3D2011\enu\Data\Corridor Design Standards\<units> directory is used by default when
the criteria-based design feature is used.

■

Use Design Check Set
Select this check box to associate a design check set with the alignment. The design check set list
becomes available when you select the check box. Select a design check set from the list.

10 Click OK.

Quick Reference
Ribbon
Home tab ➤ Create Design Panel ➤ Alignment drop down ➤ Create Alignment from Existing Alignment

Command Line
CreateAlignFromExisting
Dialog Box
Create Alignment from Existing Alignment Dialog Box (page 1973)

Creating an Alignment by Best Fit
Create an alignment that follows the most logical path through a series of feature lines, COGO points, or
AutoCAD lines, arcs, points, or blocks.
You can adjust the command to obtain the desired results based on the type and the accuracy of the source
data.
For example, when you use COGO points as source data, AutoCAD Civil 3D determines the most logical
sequence of the COGO points, and then reverses the order of any that do not correspond to the sequence
of the other selected COGO points.

When two paths of roughly parallel COGO points are used, an AutoCAD spline (1, 2) is created through
each path of points. The points from each spline are projected onto the other spline; points where the two
projections meet are used to create the centerline (3).
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Next, AutoCAD Civil 3D calculates curves (1) based on the sequence of the points and the specified Maximum
Radius For Curve Detection setting. AutoCAD Civil 3D approximates the curvature by linking the sample
points together with linear segments. To increase the accuracy when using either feature lines or AutoCAD
entities, intermediate sample points may be either weeded from the original input data or created between
each pair of sample points. When a sequence of points has a radius that is greater than this setting, the
points will form a tangent (2). The apparent intersection of the tangents (3) are the points of intersection
for the alignment tangents.

When the Create Spirals option is selected, AutoCAD Civil 3D creates a symmetrical pair of spirals (1) between
each curve and its tangents. If spirals that meet the specified R/A value do not fit between the tangents (2)
and the curve (3), then the curve radius is reduced (4) until a solution is found. When you specify this option
without the Match Tangents option, the spirals will be symmetrical, but the solution may have greater error.
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When the Match Tangents option is selected, AutoCAD Civil 3D creates an asymmetrical pair of spirals (1,
2) between each curve (3) and its tangents (4, 5). If a spiral that meets the specified minimum R/A ratio does
not fit between a curve and a tangent, then the tangent (4) is moved toward the curve until a solution is
found. The minimum R/A value enables you to restrict the spiral lengths; a higher value produces shorter
spirals, while a lower value produces longer spirals.

To create an alignment by best fit
1 Click Home tab ➤ Create Design panel ➤ Alignment drop-down ➤ Create Best Fit Alignment
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.

2 In the Create Best Fit Alignment Dialog Box (page 1980), Under Input Data, specify the type of data from
which to create the best fit alignment.
3 Next to Path 1, click

.

NOTE If you selected COGO Points as the Input Type, you can use a drop-down list to select a point group.
4 In the drawing, select the objects from which you want to create the best fit alignment. Press Enter.
NOTE You may only select objects that are the input type you selected in Step 2. You may not select multiple
types of objects.

5 If you wish to create the best fit alignment between two paths of objects, next to Path 2, click

.

6 In the drawing, select the objects from which you want to create the best fit alignment. Press Enter.
7 If you chose either Feature Lines or AutoCAD Entities as the Input Data, click Weeding Options.
8 In the Best Fit Alignment Weeding Options Dialog Box (page 1972), specify whether to either weed
extraneous vertices or insert intermediate vertices. Click OK.
9 Under Best Fit Options, specify the following parameters:
■

Maximum Radius For Curve Detection—Specifies the largest acceptable radius of curves that are
created from the input data.
NOTE This value is an estimate. For best results, specify a value that is slightly greater than the largest
known radius in the input data.

■

Create Spirals—Specifies that spirals are created between the alignment tangents and curves. The
spirals on either side of a curve are symmetric unless the match tangents option is selected.
NOTE When this option is selected, the options below it become available.

■

Desired R/A for Spirals—Specifies the target R/A ratio for spirals that are created.

■

Create Spirals And Match Tangents Where Possible—Specifies that the solution will follow the
tangents as much as possible. If no solution is available, then the tangents are moved toward the
circles until a spiral solution is found between the tangent and the curve.

■

Minimum R/A For Spirals—Specifies the minimum R/A ratio for spirals that are created. This value
controls the length of the spirals:
■

A higher value produces shorter spirals.

■

A lower value produces longer spirals.

10 Under Creation Settings, specify the following parameters:
■

Alignment Name

■

Site

■

Alignment Style

■

Alignment Label Set

■

Layer

11 Use the Show Report check box to specify whether to show a report of the best fit regression points.
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12 Click OK.

Quick Reference
Ribbon
Home tab ➤ Create Design panel ➤ Alignment drop-down ➤ Create Best Fit Alignment

.

Command Line
CreateBestFitAlignment
Dialog Box
Create Best Fit Alignment Dialog Box (page 1980)
Best Fit Alignment Weeding Options Dialog Box (page 1972)

Widenings
You can apply widening for a specified length along any type of alignment.

Each widening (page 2787) includes transition regions at the entry and the exit. In the figure, region 1 is the
entry transition, and region 3 is the exit transition, based on the direction of the centerline alignment. Default
values for the length and shape of these transitions are determined by command settings for the AddWidening
command.
The transitions extend forward and back from the specified widening start and end stations. In the example
shown, the widening starts at station 3+00 and the transition length is 75, so the entry transition starts at
2+25.
Curb return alignments in intersections can be edited to add widenings at one or both ends. This type of
widening typically forms a turn lane at the entry to a curb return or a merge lane at the exit from a curb
return.
You can also add automatic widening to dynamic offset alignments. For more information, see Adding
Automatic Widening to Dynamic Offset Alignments (page 966).

In the command settings for alignment commands, you can configure a variety of options to control default
behavior for how widenings and transitions are created in widening situations. For example, on the
AddWidening command, you can configure the default settings for how the Linear Transition Around Curves
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option creates linear transitions in widening situations. For more information, see Edit Feature Settings Alignment dialog box (page 1983).
See also:
■

Editing Offset Alignments and Widenings (page 1077)

■

Editing Offsets in Intersections (page 1607)

■

Edit Feature Settings - Alignment Dialog Box (page 1983)

Creating Widening
Create a widened region along an existing alignment.
Use this command to create features such as turn lanes, bus bays, and roadside parking areas.

You can add a widening to any alignment type, or to another widening. In the creation process, you specify
the following attributes:
■

Whether the widening is a separate alignment, or part of the parent alignment

■

The start and end stations along the parent alignment

■

The offset width

■

The side (left or right) to widen, based on facing in the forward direction along the alignment

A widening can be part of the parent alignment only if the parent is a dynamic offset or curb return.
See also:
■

Editing Offset Alignments and Widenings (page 1077)

To create a widening
1 Click Home tab ➤ Create Design panel ➤ Alignment drop-down ➤ Create Widening

.

2 Click an alignment to attach the widening to. This is also known as the parent alignment.
3 Specify whether to create the widening as a new alignment, or part of the parent alignment.
4 Specify start and end stations for the widening, either by clicking on the parent alignment or entering
numeric station values.
5 Specify the offset width.
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6 Specify whether the widening is offset to the left or right of the parent alignment. The widening is
created, and its default parameters are displayed in the Offset Parameters window.

Quick Reference
Ribbon
Click Home tab ➤ Create Design panel ➤ Alignment drop-down ➤ Create Widening
Command Line
AddWidening

Adding Automatic Widening to Dynamic Offset Alignments
You can configure a dynamic offset alignment to automatically widen around horizontal curvatures of the
parent alignment based on specified criteria.

You can control the widening values and transition lengths by specifying properties, such as the number of
lanes, vehicle type, wheelbase lengths, design speeds, and so on, in a design criteria file associated with the
parent alignment. You can also specify widening values and transition lengths manually by entering values
into the Add Automatic Widening dialog box. The automatically widened curves remain dynamic to the
parent alignment geometry based on the specified criteria.
When you use a design criteria file to specify widening methods, the rules that control automatic widening
are specified in the Superelevation Tables and Widening Methods sections of the design criteria file.
The default corridor design standards file (_Autodesk Civil 3D Imperial Roadway Design Standards.xml) is
typically stored in C:\Documents and Settings\All Users\Application Data\Autodesk\C3D
<version>\enu\Data\Corridor Design Standards\Imperial.
NOTE To use design criteria to specify automatic widening on an offset alignment, a valid design criteria file must
be associated with the parent (centerline) alignment. If there is no design criteria file associated with the parent
alignment, you are prompted to specify one.
The following procedures describe the two different methods that can be used to add automatic widening
to an offset alignment (either using a criteria file or by specifying values manually):
■

using a criteria file - describes the procedure for specifying a design criteria file, associated with the parent
alignment, and then specifying property values, and other parameters, using the Add Automatic Widening
dialog box. The available choices for property values are predefined in the specified design criteria file.

■

manually specifying parameters - describes the procedure for manually specifying the widening rules by
setting the Increase In Width property and the Transition Length property on the Add Automatic Widening
dialog box.
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See also:
■

Editing Offset Alignments and Widenings (page 1077)

■

Criteria-Based Alignment Design (page 935)

To add automatic widening using design criteria
1 In the drawing, click an offset alignment.
2 Click Offset Alignment tab ➤ Modify panel ➤ Add Automatic Widening.
If there is no valid criteria file associated with the parent alignment, you may be prompted to either
select a criteria file, or to continue the current command. Click Select a Criteria File, then navigate to
and select a design criteria file. The criteria file is associated with the parent alignment. After selecting
the criteria file, the Add Automatic Widening dialog box is displayed. See Criteria-Based Alignment
Design (page 935) for more information.
If there is a valid criteria file already associated with the parent alignment, the Add Automatic Widening
dialog box is displayed.
3 On the Add Automatic Widening (page 1945) dialog box, select one of the following: Along Entire
Alignment, At Curves Without Widening, or At Selected Curves.
4 Click the Specify Widening Using Criteria option.
5 Click OK.
The Offset Alignment Parameters dialog box is displayed.
6 Configure appropriate parameters on the Offset Alignment Parameters dialog box.
To add automatic widening by manually specifying widening parameters
1 In the drawing, click an offset alignment.
2 Click Offset Alignment tab ➤ Modify panel ➤ Add Automatic Widening.
This method can be used whether or not a design criteria file is associated with the parent alignment.
If there is no valid criteria file associated with the parent alignment, you may be prompted to either
select a criteria file, or to continue the current command. Click Continue the Current Command. The
Add Automatic Widening dialog box is displayed.
If there is a valid criteria file already associated with the parent alignment, this message does not display,
and the Add Automatic Widening dialog box is displayed.
3 On the Add Automatic Widening (page 1945) dialog box, select one of the following: Along Entire
Alignment, At Curves without Widening, or At Selected Curves.
4 Click the Specify Widening Manually option.
5 In the Specify Widening Manually section, enter a value in the Increase in Width field to specify the
widening value.
6 Specify the value for Transition Length.
7 Click OK.
The Offset Alignment Parameters dialog box is displayed.
8 Configure appropriate parameters on the Offset Alignment Parameters dialog box.
To add automatic widening at selected curves
1 In the drawing, click an offset alignment.
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2 Click Offset Alignment tab ➤ Modify panel ➤ Add Automatic Widening.
This method can be used whether or not a design criteria file is associated with the parent alignment.
If there is no valid criteria file associated with the parent alignment, you are prompted to either select
a criteria file, or to continue the current command. Click Continue the Current Command. The Add
Automatic Widening dialog box is displayed.
If there is a valid criteria file already associated with the parent alignment, this message does not display,
and the Add Automatic Widening dialog box is displayed.
3 On the Add Automatic Widening (page 1945) dialog box, select At Selected Curves.
4 Click Select Curves Along Parent Alignment.
5 In the drawing, click on the curves along the alignment that you want to apply automatic to. When
you are finished selecting curves, press Enter. The Add Automatic Widening dialog box is displayed.
6 Now you can proceed with specifying automatic widening either using criteria, or manually.

Quick Reference
Ribbon
Click the offset alignment. Click Offset Alignment tab ➤ Modify panel ➤ Add Automatic Widening
Command Line
AddAutomaticWidening
Dialog Box
Add Automatic Widening Dialog Box (page 1945)

Setting Defaults for Widenings
You can specify the default behavior for how widenings are created.
In the Edit Feature Settings for Alignments, the Automatic Widening Around Curves properties control the
behavior for how automatic widenings are created for dynamic offset alignments.
The properties in the Widening Options collection control the defaults for a variety of widening creation
options.
See Edit Feature Settings - Alignment Dialog Box (page 1983) for descriptions of each property.
To configure defaults for automatic widening
1 On the Settings tab in Toolspace, right-click the Alignments collection, and then click Edit Feature
Settings.
2 Expand the Automatic Widening Around Curves collection.
3 Specify values for each property, and then click Apply.
See Edit Feature Settings - Alignment Dialog Box (page 1983) for descriptions of each property.
4 Click OK or Cancel to close the dialog box.
To configure defaults for widening options
1 On the Settings tab in Toolspace, expand the Alignments collection, right-click the Add Widening
command, and then click Edit Command Settings.
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2 Expand the Widening Options collection.
3 Specify values for each property, and then click Apply.
See Edit Feature Settings - Alignment Dialog Box (page 1983) for descriptions of each property.
4 Click OK or Cancel to close the dialog box.

Quick Reference
Toolspace Shortcut Menu
Settings tab: Alignments ➤ Commands ➤ Right-click Add Widening ➤ Edit Command Settings
Dialog Box
Edit Feature Settings - Alignment Dialog Box (page 1983)

Setting Defaults for Linear Transitions Around Curves in Widenings
You can specify the default behavior for how linear transitions around curves are created in widenings.
In the command settings for the AddWidening command, configure the Linear Transition Around Curves
properties to control this behavior.
To change this behavior after it is implemented on an existing offset alignment, select the offset alignment,
click the Offset Parameters button in the ribbon, and change the Transition Type property to Curve - Line
- Curve.
To configure defaults for creating linear transitions around curves in widenings
1 On the Settings tab in Toolspace, expand the Alignments collection and then expand the Commands
collection.
2 Right-click Add Widening ➤ Edit Command Settings.
3 In the Edit Command Settings - Add Widening dialog box, expand the Linear Transition Around Curves
collection.
4 Specify values for the Number of Segments and the Transition Segment Type properties, and then click
Apply or OK.
See Edit Feature Settings - Alignment Dialog Box (page 1983) for descriptions of each property.

Quick Reference
Toolspace Shortcut Menu
Settings tab: Alignments ➤ Commands ➤ Right-click Add Widening ➤ Edit Command Settings ➤
Linear Transition Around Curves
Dialog Box
Edit Feature Settings - Alignment Dialog Box (page 1983)

Editing Widening Parameters
You can edit widening parameters on alignments that have widening applied.
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To edit widening parameters on an alignment
1 In Toolspace, on the Prospector tab, right-click the alignment and click Edit Offset Parameters. You can
also select the offset alignment in the drawing, and click Offset Parameters in the Modify tab in the
ribbon.
2 Use the Offset Alignment Parameters dialog box (page 1989) to edit widening parameters.

Quick Reference
Toolspace Shortcut Menu
Prospector tab: Right-click <offset alignment name> ➤ Edit Offset Parameters
Dialog Box
Offset Alignment Parameters Dialog Box (page 1989)

Adding Lines, Curves, and Spirals to an Alignment
Use the constraint-based commands on the Alignment Layout Tools toolbar, to add a fixed entity (page 2774),
a free entity (page 2774), or a floating entity (page 2774) (lines, curves, spiral-curve-spiral groups and spirals) to
the alignment.
The Alignment Layout Tools toolbar provides you with an infinite number of ways to solve various problems
by using different constraints.
Using the constraint-based commands, you can fit an alignment by working inward from two known points
at the beginning and end of the design area. You can also create alignment entities in sequential order.
With the established tangency rules, you can edit the parameters of any alignment entity in real-time and
still maintain tangency.

Entity Descriptions
This section contains descriptions of fixed, free, and floating alignment entities.

Fixed Entity
A fixed entity has the following characteristics:
■

It is defined by specifying parameters, such as points or radius.

■

Its parameters are fixed in their position. Only you can change the parameters that define this entity.

■

It is not dependent on any other entity to define its geometry or to maintain tangency, but its length
can be affected by another entity that is attached to it.

■

It can be initially created with a tangency association. Fixed entities that start from the beginning of
another fixed entity can be initially tangent to the other entity, but the tangency is not maintained when
either entity is edited.

Floating Entity
A floating entity has the following characteristics:
■

It is defined by the parameters that you specify and is always tangent to one entity.
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■

It is always tangent to the entity it is attached to. A floating entity cannot be attached to a free entity,
but a free entity can be attached to a floating entity.

■

It can be attached only to another floating entity or a fixed entity.

■

It is dependent on being tangent to one other entity to define its geometry.

Free Entity
A free entity has the following characteristics:
■

It is defined by the parameters that you specify and is always tangent to an entity before and an entity
after.

■

It must have at least two other entities to add to.

■

It is dependent on two other entities to define its geometry.

■

It can only be attached between either two fixed entities, two floating entities, or one fixed and one
floating entity, but in any order.

Adding Lines
Add fixed, free, or floating lines to build constraint-based alignment geometry for the areas of your design
that require maintaining tangency.
In most cases the length of the line automatically adjusts to meet the tangency point of the next or previous
entity.
After clicking a button on the Alignment Layout Tools toolbar, follow the command prompts on the command
line.
TIP You can use transparent commands when you are prompted to specify direction, radius, or length, or use
station offsets to specify any points. For more information, see Transparent Commands (page 1767).

Adding Fixed Lines
Add fixed lines to build constraint-based alignment geometry for the areas of your design that require
maintaining tangency.
After clicking a button on the Alignment Layout Tools toolbar, follow the command prompts on the command
line.

Adding a Fixed Line Between Two Points
Add a fixed line between two points.
The entity position is not affected by edits to adjacent entities.
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To add a fixed line (two points)
1 Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
2 On the Alignment Layout Tools toolbar, click

.

Fixed Line (Two Points).

3 Specify the start point.
4 Specify the end point. A line preview is displayed.
TIP Edit the line direction or location by moving either point or move the line using the middle grip.

Quick Reference
Ribbon
Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
Menu
Alignments menu ➤ Edit Alignment Geometry
Command Line
EditAlignment
Alignment Layout Tools Toolbar icon
Fixed Line (Two Points)

Adding a Fixed Line with a Specified Length to a Curve End
Add a fixed line of a specified length to the end of an existing curve.
The direction of the line matches the direction of the attachment curve (1). The specified line length (2) is
affected only if a floating or free entity is attached to it.
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The line is tangent to the end of the selected fixed or floating entity when it is created. If you edit the line
or the entity it is attached to, tangency is not maintained.
To add a fixed line (from curve end, length)
1 Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
2 On the Alignment Layout Tools toolbar, click

.

Fixed Line (From Curve End, Length).

3 Select an entity end for the start point and direction.
4 Specify the length. A line preview is displayed.
By specifying the start point at the end of an entity, a direction, and length, you create a fixed two-point
line alignment entity. The result is a line through two points.
TIP You can edit either of the two points or the middle grip, but the initial tangency will not be maintained.

Quick Reference
Ribbon
Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
Menu
Alignments menu ➤ Edit Alignment Geometry
Command Line
EditAlignment
Alignment Layout Tools Toolbar icons
Fixed Line (From Curve End, Length)

Adding a Fixed Line by Best Fit
Add the most probable fixed line through a series of using a series of AutoCAD Civil 3D points, AutoCAD
points, existing entities, or clicks on screen.
Regression points can be added, removed, or modified after the entity has been created.
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See also:
■

Editing Best Fit Alignment Entities (page 1075)

To create a fixed line by best fit from AutoCAD Civil 3D points
1 Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
2 On the Alignment Layout Tools toolbar, click

.

Fixed Line - Best Fit.

3 In the Line By Best Fit Dialog Box (page 2225), select From COGO Points.
4 Select two or more AutoCAD Civil 3D points. Enter G to select a point group or N to enter points by
number.
As you select points in the drawing window, an X marks each regression point and a temporary, dashed
line is displayed in real time.
5 Press Enter to complete the command.
6 In the Panorama window, use the Regression Data (page 2226) vista to make changes to the regression
points.
As you highlight a row in the Regression Data vista, the corresponding regression point in the drawing
window is highlighted in red.
7 Create the line:
■

Click

to create the line and keep the Regression Data vista open.

■

Click

to create the line and close the Regression Data vista.

To create a fixed line by best fit from AutoCAD points
1 Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
2 On the Alignment Layout Tools toolbar, click

.

Fixed Line - Best Fit.

3 In the Line By Best Fit Dialog Box (page 2225), select From AutoCAD Points.
4 Select two or more AutoCAD points.
As you select points in the drawing window, an X marks each regression point and a temporary, dashed
line is displayed in real time.
5 Press Enter to complete the command.
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6 In the Panorama window, use the Regression Data (page 2226) vista to make changes to the regression
points.
As you highlight a row in the Regression Data vista, the corresponding regression point in the drawing
window is highlighted in red.
7 Create the line:
■

Click

to create the line and keep the Regression Data vista open.

■

Click

to create the line and close the Regression Data vista.

To create a fixed line by best fit from existing entities
1 Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
2 On the Alignment Layout Tools toolbar, click

.

Fixed Line - Best Fit.

3 In the Line By Best Fit Dialog Box (page 2225), select From Entities. Specify the tessellation and mid-ordinate
tolerance settings.
4 Select one or more of the entities listed on the command line.
NOTE You can select several types of entities listed on the command line.
As you select entities in the drawing window, an X marks each regression point and a temporary, dashed
line is displayed in real time.
5 If you selected a profile object, specify the starting and ending station in the Specify Station Range
Dialog Box (page 2228).
6 Press Enter to complete the command.
7 In the Panorama window, use the Regression Data (page 2226) vista to make changes to the regression
points.
As you highlight a row in the Regression Data vista, the corresponding regression point in the drawing
window is highlighted in red.
8 Create the line:
■

Click

to create the line and keep the Regression Data vista open.

■

Click

to create the line and close the Regression Data vista.

To create a fixed line by best fit by clicking on screen
1 Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
2 On the Alignment Layout Tools toolbar, click

.

Fixed Line - Best Fit.

3 In the Line By Best Fit Dialog Box (page 2225), select By Clicking On The Screen.
4 Select a starting point and at least one other point.
NOTE You can use OSNAP or transparent commands to select points.
As you select points in the drawing window, an X marks each regression point and a temporary, dashed
line is displayed in real time.
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5 Press Enter to complete the command.
6 In the Panorama window, use the Regression Data (page 2226) vista to make changes to the regression
points.
As you highlight a row in the Regression Data vista, the corresponding regression point in the drawing
window is highlighted in red.
7 Create the line:
■

Click

to create the line and keep the Regression Data vista open.

■

Click

to create the line and close the Regression Data vista.

Quick Reference
Ribbon
Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
Menu
Click Alignments menu ➤ Edit Alignment Geometry
Command Line
EditAlignment
Alignment Layout Tools Toolbar icons
Fixed Line - Best Fit
Edit Best Fit Data For All Entities
Dialog Box
Alignment Layout Tools (page 1959)
Line By Best Fit Dialog Box (page 2225)
Regression Data Vista (page 2226)

Adding Floating Lines
Add floating lines to build constraint-based alignment geometry for the areas of your design that require
maintaining tangency during edits.
After clicking a button on the Alignment Layout Tools toolbar, follow the command prompts on the command
line.

Adding a Floating Line through a Point from a Curve
Add a floating line from a point on an existing curve to a specified point.
The direction of the attachment curve (1) and the location of the pass-through point (2) determine the
attachment point.
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To add a floating line (from curve, through point)
1 Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
2 On the Alignment Layout Tools toolbar, click

.

Floating Line (From Curve, Through Point).

3 Select the end of the curve to which you want to add the floating line.
4 Specify the end point.

Quick Reference
Ribbon
Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
Menu
Alignments menu ➤ Edit Alignment Geometry
Command Line
EditAlignment
Alignment Layout Tools Toolbar icon
Floating Line (From Curve, Through Point)

Adding a Floating Line of a Specified Length to a Curve End
Adds a floating line, with a specified length, to the end of a curve.
The direction of the attachment curve (1) determines the line direction.
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This type of entity always starts at the end of the entity it is attached to. The line is always tangent to the
end of a fixed or floating curve. Unlike an entity where the location is defined by a pass-through point, this
type of entity is not pinned to a location in the drawing. Therefore, the entity geometry moves with the
entity to which it is attached.
To add a floating line (from curve end, length)
1 Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
2 On the Alignment Layout Tools toolbar, click

.

Floating Line (From Curve End, Length).

3 Select the end of the curve to which you want to add the floating line.
4 Specify a length by picking two points in the drawing, or by entering a length value on the command
line.

Quick Reference
Ribbon
Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
Menu
Alignments menu ➤ Edit Alignment Geometry
Command Line
EditAlignment
Alignment Layout Tools Toolbar icon
Floating Line (From Curve End, Length)

Adding a Floating Line by Best Fit
Adds the most probable floating line from a point on an existing entity through a series of AutoCAD Civil
3D points, AutoCAD points, existing entities, or clicks on screen.
The direction of the attachment curve (1) and the path through the selected regression points (2) determines
the location of the attachment point.

See also:
■

Editing Best Fit Alignment Entities (page 1075)
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To create a floating line by best fit using AutoCAD Civil 3D points
1 Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
2 On the Alignment Layout Tools toolbar, click

.

Floating Line - Best Fit.

3 Select a curve entity for the start point and direction.
If you select the beginning of the curve entity, the best fit line will precede the curve entity. If you
select the end of the curve entity, the best fit line will succeed the curve entity.
4 In the Line By Best Fit Dialog Box (page 2225), select From COGO Points.
5 Select one or more AutoCAD Civil 3D points. Enter G to select a point group or N to enter points by
number.
As you select points in the drawing window, an X marks each regression point and a temporary, dashed
line is displayed in real time.
6 Press Enter to complete the command.
7 In the Panorama window, use the Regression Data (page 2226) vista to make changes to the regression
points.
As you highlight a row in the Regression Data vista, the corresponding regression point in the drawing
window is highlighted in red.
8 Create the line:
■

Click

to create the line and keep the Regression Data vista open.

■

Click

to create the line and close the Regression Data vista.

To create a floating line by best fit from AutoCAD points
1 Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
2 On the Alignment Layout Tools toolbar, click

.

Floating Line - Best Fit.

3 Select a curve entity for the start point and direction.
If you select the beginning of the curve entity, the best fit line will precede the curve entity. If you
select the end of the curve entity, the best fit line will succeed the curve entity.
4 In the Line By Best Fit Dialog Box (page 2225), select From AutoCAD Points.
5 Select one or more AutoCAD points.
As you select points in the drawing window, an X marks each regression point and a temporary, dashed
line is displayed in real time.
6 Press Enter to complete the command.
7 In the Panorama window, use the Regression Data (page 2226) vista to make changes to the regression
points.
As you highlight a row in the Regression Data vista, the corresponding regression point in the drawing
window is highlighted in red.
8 Create the line:
■

Click

to create the line and keep the Regression Data vista open.
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■

Click

to create the line and close the Regression Data vista.

To create a floating line by best fit from existing entities
1 Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
2 On the Alignment Layout Tools toolbar, click

.

Floating Line - Best Fit.

3 Select a curve entity for the start point and direction.
If you select the beginning of the curve entity, the best fit line will precede the curve entity. If you
select the end of the curve entity, the best fit line will succeed the curve entity.
4 In the Line By Best Fit Dialog Box (page 2225), select From Entities. Specify the tessellation and mid-ordinate
tolerance settings.
5 Select one or more of the entities listed on the command line.
NOTE You can select several types of entities listed at the command line.
As you select entities in the drawing window, an X marks each regression point and a temporary, dashed
line is displayed in real time.
6 If you selected a profile object, specify the starting and ending station in the Specify Station Range
Dialog Box (page 2228).
7 Press Enter to complete the command.
8 In the Panorama window, use the Regression Data (page 2226) vista to make changes to the regression
points.
As you highlight a row in the Regression Data vista, the corresponding regression point in the drawing
window is highlighted in red.
9 Create the line:
■

Click

to create the line and keep the Regression Data vista open.

■

Click

to create the line and close the Regression Data vista.

To create a floating line by best fit by clicking on screen
1 Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
2 On the Alignment Layout Tools toolbar, click

.

Floating Line - Best Fit.

3 Select a curve entity for the start point and direction.
If you select the beginning of the curve entity, the best fit line will precede the curve entity. If you
select the end of the curve entity, the best fit line will succeed the curve entity.
4 In the Line By Best Fit Dialog Box (page 2225), select By Clicking On The Screen.
5 Select at least one other point.
NOTE You can use OSNAP or transparent commands to select points.
As you select points in the drawing window, an X marks each regression point and a temporary, dashed
line is displayed in real time.
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6 Press Enter to complete the command.
7 In the Panorama window, use the Regression Data (page 2226) vista to make changes to the regression
points.
As you highlight a row in the Regression Data vista, the corresponding regression point in the drawing
window is highlighted in red.
8 Create the line:
■

Click

to create the line and keep the Regression Data vista open.

■

Click

to create the line and close the Regression Data vista.

Quick Reference
Ribbon
Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
Menu
Alignments menu ➤ Edit Alignment Geometry
Command Line
EditAlignment
Alignment Layout Tools Toolbar icons
Floating Line - Best Fit
Edit Best Fit Data For All Entities
Dialog Box
Line By Best Fit Dialog Box (page 2225)
Regression Data Vista (page 2226)

Adding Free Lines
Add free lines to build constraint-based alignment geometry for the areas of your design that require
maintaining tangency between two curves.
After clicking a button on the Alignment Layout Tools toolbar, follow the command prompts on the command
line.

Adding a Free Line Between Two Curves
Add a free line between two existing curves.
This entity maintains tangency to both attachment curves (2). There are four possible solutions for this
entity, depending on the direction of the curves.
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To add a free line (between two curves)
1 Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
2 On the Alignment Layout Tools toolbar, click

Free Line (Between Two Curves).

3 Specify the curve entity from which you want to add the free line.
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.

4 Specify the curve entity to which you want to add the free line.

Quick Reference
Ribbon
Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
Menu
Alignments menu ➤ Edit Alignment Geometry
Command Line
EditAlignment
Alignment Layout Tools Toolbar icon
Free Line (Between Two Curves)

Adding Curves
Add fixed, free, or floating curves to build constraint-based alignment geometry for the areas of your design
that require maintaining tangency.
After clicking a button on the Alignment Layout Tools toolbar, follow the command prompts on the command
line.
TIP You can use transparent commands when you are prompted to specify direction, radius, or length, or use
station offsets to specify any points. For more information, see Transparent Commands (page 1767).

Adding Fixed Curves
Add a fixed curve through three specified pass-through points.
These commands are similar to an AutoCAD arc, but have a third point along the arc.

Adding a Fixed Curve with Three Points
Add a fixed three-point curve by specifying three points.
The entity position is not affected by edits to adjacent entities.
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To add a fixed curve (with three points)
1 Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
2 On the Alignment Layout Tools toolbar, click

.

Fixed Curve (Three Point).

3 Specify the start point.
4 Specify the second point.
5 Specify the next point.
TIP Edit the curve by moving any of the three points.

Quick Reference
Ribbon
Alignment tab ➤ Modify panel ➤ Geometry Editor
Menu
Alignments menu ➤ Edit Alignment Geometry
Command Line
EditAlignment
Alignment Layout Tools Toolbar icons
Fixed Curve (Three Point)

Adding a Fixed Curve with Two Points and a Direction at First Point
Add a fixed three-point curve defined by specified start and end points and a direction at the start point.
The result is a three-point curve. The specified curve direction (3) determines the location of the pass-through
point between the start (1) and end (2) points.

To add a fixed curve (two points and a direction at first point)
1 Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
2 On the Alignment Layout Tools toolbar, click
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.

Fixed Curve (Two Points And Direction At First Point).

3 Specify the start point.
4 Specify the second point.
5 Specify the direction at the start point, or specify either a bearing or azimuth.
TIP Edit the curve by moving any of the three points.

Quick Reference
Ribbon
Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
Menu
Alignments menu ➤ Edit Alignment Geometry
Command Line
EditAlignment
Alignment Layout Tools Toolbar icons
Fixed Curve (Two Points And Direction At First Point)

Adding a Fixed Curve with Two Points and a Direction at Second Point
Add a fixed curve defined by specified start and end points and a direction at the end point.
The result is a three-point curve. The specified curve direction (3) determines the location of the pass-through
point between the start (1) and end (2) points.

TIP You can use transparent commands when you are prompted to specify direction, radius, or length, or use
station offsets to specify any points. For more information, see Transparent Commands (page 1767).
To add a fixed curve (two points and a direction at second point)
1 Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
2 On the Alignment Layout Tools toolbar, click
Point).

.

Fixed Curve (Two Points And Direction At Second

3 Specify the start point.
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4 Specify the next point. A preview of the curve is displayed.
5 Specify the direction at the second point or specify a bearing or azimuth.
TIP Edit the curve by moving any of the three points.

Quick Reference
Ribbon
Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
Menu
Alignments menu ➤ Edit Alignment Geometry
Command Line
EditAlignment
Alignment Layout Tools Toolbar icons
Fixed Curve (Two Points And Direction At Second Point)

Adding a Fixed Curve with Two Points and Radius
Add a fixed curve defined by specified radius, direction, and start and end points.
The result is a three-point curve. The pass-through point between the end points (1, 4) is located at the curve
mid point.

TIP You can use transparent commands when you are prompted to specify direction, radius, or length, or use
station offsets to specify any points. For more information, see Transparent Commands (page 1767).
To add a fixed curve (two points and radius)
1 Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
2 On the Alignment Layout Tools toolbar, click
3 Specify the start point.
4 Specify a radius.
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.

Fixed Curve (Two Points And Radius).

Specify a new value, or press Enter to accept the value that is displayed on the command line.
■

If the alignment has design criteria (page 935) applied to it, the minimum value for the current design
speed is displayed.

■

If the alignment does not have design criteria applied to it, the default value specified in the curve
and spiral settings is displayed. For more information, see Curve and Spiral Settings (page 930).

5 Specify the curve direction, either clockwise or counter-clockwise. A preview of the curve is displayed.
6 Specify the end point.
TIP Edit the curve by moving any of the three points.

Quick Reference
Ribbon
Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
Menu
Alignments menu ➤ Edit Alignment Geometry
Command Line
EditAlignment
Alignment Layout Tools Toolbar icons
Fixed Curve (Two Points And Radius)

Adding a Fixed Curve from an Entity End to a Through Point
Add a fixed curve from the end of an existing entity to a specified end point
The result is a three-point curve. When the curve is created, it is tangent to the end of the selected entity,
but if you edit either the curve or the attachment entity, tangency is not maintained.

TIP You can use transparent commands when you are prompted to specify direction, radius, or length, or use
station offsets to specify any points. For more information, see Transparent Commands (page 1767).
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To add a fixed curve (from entity end, through point)
1 Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
2 On the Alignment Layout Tools toolbar, click

.

Fixed Curve (From Entity End, Through Point).

3 Select the entity for the start point and the direction.
4 Specify the next point.

Quick Reference
Ribbon
Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
Menu
Alignments menu ➤ Edit Alignment Geometry
Command Line
EditAlignment
Alignment Layout Tools Toolbar icons
Fixed Curve (From Entity End, Through Point)

Adding a Fixed Curve from Center Point with Radius
Add a full, fixed circle defined by a specified center point, direction, and radius.
The result is a circle with four pass-through points. The entity position is not affected by edits to adjacent
entities.

TIP You can use transparent commands when you are prompted to specify direction, radius, or length, or use
station offsets to specify any points. For more information, see Transparent Commands (page 1767).
To add a fixed curve (center point and radius)
1 Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
2 On the Alignment Layout Tools toolbar, click
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.

Fixed Curve (Center Point And Radius).

3 Specify the center point.
4 Specify the curve direction: either clockwise or counter-clockwise.
5 Specify a radius.
Specify a new value, or press Enter to accept the value that is displayed on the command line.
■

If the alignment has design criteria (page 935) applied to it, the minimum value for the current design
speed is displayed.

■

If the alignment does not have design criteria applied to it, the default value specified in the curve
and spiral settings is displayed. For more information, see Curve and Spiral Settings (page 930).

A preview of the curve is displayed. A fixed circle with a center point and a radius is created.

Quick Reference
Ribbon
Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
Menu
Alignments menu ➤ Edit Alignment Geometry
Command Line
EditAlignment
Alignment Layout Tools Toolbar icons
Fixed Curve (Center Point And Radius)

Adding a Fixed Curve with a Center Point and Through Point
Add a full, fixed circle defined by a specified center point, direction, and pass-through point.
The result is a circle with four pass-through points. The entity position is not affected by edits to adjacent
entities.

TIP You can use transparent commands when you are prompted to specify direction, radius, or length, or use
station offsets to specify any points. For more information, see Transparent Commands (page 1767).
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To add a fixed curve (center point, through point)
1 Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
2 On the Alignment Layout Tools toolbar, click

.

Fixed Curve (Center Point, Through Point).

3 Specify the center point.
4 Specify the curve direction: either clockwise or counter-clockwise.
5 Specify a pass-through point. A preview of the curve is displayed.
TIP Edit the curve by moving the center point or the pass-through point.

Quick Reference
Ribbon
Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
Menu
Alignments menu ➤ Edit Alignment Geometry
Command Line
EditAlignment
Alignment Layout Tools Toolbar icons
Fixed Curve (Center Point, Through Point)

Adding a Fixed Curve with a Through Point, Direction at Point, and Radius
Add a full, fixed circle defined by a specified pass-through point, direction at the pass-through point, curve
direction, and radius.
The result is a circle with four pass-through points. The entity position is not affected by edits to adjacent
entities.

TIP You can use transparent commands when you are prompted to specify direction, radius, or length, or use
station offsets to specify any points. For more information, see Transparent Commands (page 1767).
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To add a fixed curve (through point, direction at point, and radius)
1 Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
2 On the Alignment Layout Tools toolbar, click
Radius).

.

Fixed Curve (Through Point, Direction At Point And

3 Specify the pass-through point.
4 Specify the direction at the pass-through point or specify a bearing or azimuth.
5 Specify the curve direction: either clockwise or counter-clockwise.
6 Specify a radius.
Specify a new value, or press Enter to accept the value that is displayed on the command line.
■

If the alignment has design criteria (page 935) applied to it, the minimum value for the current design
speed is displayed.

■

If the alignment does not have design criteria applied to it, the default value specified in the curve
and spiral settings is displayed. For more information, see Curve and Spiral Settings (page 930).

A curve preview is displayed.
TIP Edit the curve by moving the center point or using the radius grips.

Quick Reference
Ribbon
Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
Menu
Alignments menu ➤ Edit Alignment Geometry
Command Line
EditAlignment
Alignment Layout Tools Toolbar icons
Fixed Curve (Through Point, Direction At Point And Radius)

Adding a Fixed Curve by Best Fit
Add the most probable fixed curve through a series of AutoCAD Civil 3D points, AutoCAD points, existing
entities, or clicks on screen.
The result is a three-point curve. Regression points can be added, removed, or modified after the entity has
been created.
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See also:
■

Editing Best Fit Alignment Entities (page 1075)

To create a fixed curve by best fit from AutoCAD Civil 3D points
1 Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
2 On the Alignment Layout Tools toolbar, click

.

Fixed Curve - Best Fit.

3 In the Curve By Best Fit Dialog Box (page 2225), select From COGO Points.
4 Select three or more AutoCAD Civil 3D points. Enter G to select a point group or N to enter points by
number.
As you select points in the drawing window, an X marks each regression point and a temporary, dashed
curve is displayed in real time.
NOTE You must select at least three non-collinear regression points.
5 Press Enter to complete the command.
6 In the Panorama window, use the Regression Data (page 2226) vista to make changes to the regression
points.
As you highlight a row in the Regression Data vista, the corresponding regression point in the drawing
window is highlighted in red.
7 Create the curve:
■

Click

to create the curve and keep the Regression Data vista open.

■

Click

to create the curve and close the Regression Data vista.

To create a fixed curve by best fit from AutoCAD points
1 Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
2 On the Alignment Layout Tools toolbar, click

Fixed Curve - Best Fit.

3 In the Curve By Best Fit Dialog Box (page 2225), select From AutoCAD Points.
4 Select three or more AutoCAD points.
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.

As you select points in the drawing window, an X marks each regression point and a temporary, dashed
curve is displayed in real time.
NOTE You must select at least three non-collinear regression points.
5 Press Enter to complete the command.
6 In the Panorama window, use the Regression Data (page 2226) vista to make changes to the regression
points.
As you highlight a row in the Regression Data vista, the corresponding regression point in the drawing
window is highlighted in red.
7 Create the curve:
■

Click

to create the curve and keep the Regression Data vista open.

■

Click

to create the curve and close the Regression Data vista.

To create a fixed curve by best fit from existing entities
1 Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
2 On the Alignment Layout Tools toolbar, click

.

Fixed Curve - Best Fit.

3 In the Curve By Best Fit Dialog Box (page 2225), select From Entities. Specify the tessellation and
mid-ordinate tolerance settings.
4 Select one or more of the entities listed on the command line.
NOTE You can select several types of entities listed on the command line.
As you select entities in the drawing window, an X marks each regression point and a temporary, dashed
curve is displayed in real time.
NOTE You must select at least three non-collinear regression points.
5 If you selected a profile object, specify the starting and ending station on the Specify Station Range
Dialog Box (page 2228).
6 Press Enter to complete the command.
7 In the Panorama window, use the Regression Data (page 2226) vista to make changes to the regression
points.
As you highlight a row in the Regression Data vista, the corresponding regression point in the drawing
window is highlighted in red.
8 Create the curve:
■

Click

to create the curve and keep the Regression Data vista open.

■

Click

to create the curve and close the Regression Data vista.

To create a fixed curve by best fit by clicking on screen
1 Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor

.
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2 On the Alignment Layout Tools toolbar, click

Fixed Curve - Best Fit.

3 In the Curve By Best Fit Dialog Box (page 2225), select By Clicking On The Screen.
4 Select a starting point and at least two other points.
NOTE You can use OSNAP or transparent commands to select points.
As you select points in the drawing window, an X marks each regression point and a temporary, dashed
curve is displayed in real time.
NOTE You must select at least three non-collinear regression points.
5 Press Enter to complete the command.
6 In the Panorama window, use the Regression Data (page 2226) vista to make changes to the regression
points.
As you highlight a row in the Regression Data vista, the corresponding regression point in the drawing
window is highlighted in red.
7 Create the curve:
■

Click

to create the curve and keep the Regression Data vista open.

■

Click

to create the curve and close the Regression Data vista.

Quick Reference
Ribbon
Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
Menu
Alignments menu ➤ Edit Alignment Geometry
Command Line
EditAlignment
Alignment Layout Tools Toolbar icons
Fixed Curve - Best Fit
Edit Best Fit Data For All Entities
Dialog Box
Curve By Best Fit Dialog Box (page 2225)
Regression Data Vista (page 2226)

Adding Floating Curves
Add floating curves to build constraint-based alignment geometry for the areas of your design that require
maintaining tangency.
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Adding a Floating Curve with a Radius and a Through Point to an Entity
Add a floating curve, defined by a specified radius and angle range, from an existing entity to a specified
end point.
This curve supports both compound and reverse solutions.

TIP You can use transparent commands when you are prompted to specify direction, radius, or length, or use
station offsets to specify any points. For more information, see Transparent Commands (page 1767).
The following illustration shows a floating curve attached to a fixed line and two possible solutions for a
given radius and point:

The following illustration shows a floating compound curve attached to a curve and four possible solutions
for a given radius and pass-through point. The illustration also shows variables for greater than and less than
180 degrees and compound and reverse variables:

Adding Curves | 995

To add a floating curve (from entity, radius, through point)
1 Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
2 On the Alignment Layout Tools toolbar, click

.

Floating Curve (From Entity, Radius, Through Point).

3 Select the end of the entity to which you want to add the floating curve.
4 Specify a radius.
Specify a new value, or press Enter to accept the value that is displayed on the command line.
■

If the alignment has design criteria (page 935) applied to it, the minimum value for the current design
speed is displayed.

■

If the alignment does not have design criteria applied to it, the default value specified in the curve
and spiral settings is displayed. For more information, see Curve and Spiral Settings (page 930).

5 Specify whether the curve solution angle is either greater than or less than 180 degrees. A preview curve
is displayed.
NOTE If the attachment entity is a curve, you are prompted to specify either a compound curve or a reverse
curve.
6 Specify the pass-through point.

Quick Reference
Ribbon
Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
Menu
Alignments menu ➤ Edit Alignment Geometry
Command Line
EditAlignment
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Alignment Layout Tools Toolbar icons
Floating Curve (From Entity, Radius, Through Point)

Adding a Floating Curve with a Through Point to an Entity End
Add a floating curve from the end of an existing entity to a specified pass-through point.
The attachment entity (1) and pass-through point (2) determine the curve radius. You cannot edit the radius
for this type of curve.

The result is a floating curve that is always tangent to the entity it is attached to.
TIP You can use transparent commands when you are prompted to specify direction, radius, or length, or use
station offsets to specify any points. For more information, see Transparent Commands (page 1767).
To add a floating curve (from entity end, through point)
1 Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
2 On the Alignment Layout Tools toolbar, click

.

Floating Curve (From Entity End, Through Point).

3 Select the end of the entity to which you want to add the floating curve.
4 Specify the end point. A curve preview is displayed.

Quick Reference
Ribbon
Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
Menu
Alignments menu ➤ Edit Alignment Geometry
Command Line
EditAlignment
Alignment Layout Tools Toolbar icons
Floating Curve (From Entity End, Through Point)
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Adding a Floating Curve with a Direction, Radius, and Length to an Entity End
Add a floating curve entity that is defined by the entity end to which it is attached, the radius, and the
length by specifying the entity end where you want to add the curve.
This curve is not defined by a pass-through point, so the entire curve moves with the entity to which it is
attached.

TIP You can use transparent commands when you are prompted to specify direction, radius, or length, or use
station offsets to specify any points. For more information, see Transparent Commands (page 1767).
To add a floating curve attached (from entity end, radius, length)
1 Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
2 On the Alignment Layout Tools toolbar, click

.

Floating Curve (From Entity End, Radius, Length).

3 Select the end of the entity to which you want to add the floating curve.
4 Specify the curve direction: either clockwise or counter-clockwise.
5 Specify a radius.
Specify a new value, or press Enter to accept the value that is displayed on the command line.
■

If the alignment has design criteria (page 935) applied to it, the minimum value for the current design
speed is displayed.

■

If the alignment does not have design criteria applied to it, the default value specified in the curve
and spiral settings is displayed. For more information, see Curve and Spiral Settings (page 930).

6 Specify the length or [deltaAngle/Tanlen/Chordlen/midOrd/External].

Quick Reference
Ribbon
Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
Menu
Alignments menu ➤ Edit Alignment Geometry
Command Line
EditAlignment
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Alignment Layout Tools Toolbar icons
Floating Curve (From Entity End, Radius, Length)

Adding a Floating Curve with a Through Point and a Direction to an Entity
Add a floating curve with a specified pass-through point and direction at the pass-through point to an
existing entity.
The attachment entity (1), pass-through point (2), and direction (3) determine the curve attachment point
and radius. You cannot edit the radius for this type of curve.

The result is a floating curve that is always tangent to the entity it is attached to.
TIP You can use transparent commands when you are prompted to specify direction, radius, or length, or use
station offsets to specify any points. For more information, see Transparent Commands (page 1767).
To add a floating curve (from entity, through point, direction at point)
1 Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
2 On the Alignment Layout Tools toolbar, click
At Point).

.

Floating Curve (From Entity, Through Point, Direction

3 Specify the entity to which you want to add the floating curve.
4 Specify the end point.
5 Specify the direction at the end point or specify bearing or azimuth.

Quick Reference
Ribbon
Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
Menu
Alignments menu ➤ Edit Alignment Geometry
Command Line
EditAlignment
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Alignment Layout Tools Toolbar icons
Floating Curve (From Entity, Through Point, Direction At Point)

Adding a Floating Curve by Best Fit
Add the most probable floating curve through a series of AutoCAD Civil 3D points, AutoCAD points, existing
entities, or clicks on screen.
The location of the curve start point on the attachment entity (1) is determined by the path through the
selected regression points (2).

See also:
■

Editing Best Fit Alignment Entities (page 1075)

To create a floating curve by best fit using AutoCAD Civil 3D points
1 Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
2 On the Alignment Layout Tools toolbar, click

.

Floating Curve - Best Fit.

3 Select an entity for the start point and direction.
If you select the beginning of the entity, the best fit curve will precede the entity. If you select the end
of the entity, the best fit curve will succeed the entity.
4 In the Curve By Best Fit Dialog Box (page 2225), select From COGO Points.
5 Select two or more AutoCAD Civil 3D points. Enter G to select a point group or N to enter points by
number.
As you select points in the drawing window, an X marks each regression point and a temporary, dashed
curve is displayed in real time.
NOTE You must select at least two non-collinear regression points.
6 Press Enter to complete the command.
7 In the Panorama window, use the Regression Data (page 2226) vista to make changes to the regression
points.
As you highlight a row in the Regression Data vista, the corresponding regression point in the drawing
window is highlighted in red.
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8 Create the curve:
■

Click

to create the curve and keep the Regression Data vista open.

■

Click

to create the curve and close the Regression Data vista.

To create a floating curve by best fit using AutoCAD points
1 Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
2 On the Alignment Layout Tools toolbar, click

.

Floating Curve - Best Fit.

3 Select an entity for the start point and direction.
If you select the beginning of the entity, the best fit curve will precede the entity. If you select the end
of the entity, the best fit curve will succeed the entity.
4 In the Curve By Best Fit Dialog Box (page 2225), select From AutoCAD Points.
5 Select two or more AutoCAD points.
As you select points in the drawing window, an X marks each regression point and a temporary, dashed
curve is displayed in real time.
NOTE You must select at least two non-collinear regression points.
6 Press Enter to complete the command.
7 In the Panorama window, use the Regression Data (page 2226) vista to make changes to the regression
points.
As you highlight a row in the Regression Data vista, the corresponding regression point in the drawing
window is highlighted in red.
8 Create the curve:
■

Click

to create the curve and keep the Regression Data vista open.

■

Click

to create the curve and close the Regression Data vista.

To create a floating curve by best fit using existing entities
1 Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
2 On the Alignment Layout Tools toolbar, click

.

Floating Curve - Best Fit.

3 Select an entity for the start point and direction.
If you select the beginning of the entity, the best fit curve will precede the entity. If you select the end
of the entity, the best fit curve will succeed the entity.
4 In the Curve By Best Fit Dialog Box (page 2225), select From Entities. Specify the tessellation and
mid-ordinate tolerance settings.
5 Select one or more of the entities listed on the command line.
NOTE You can select several types of entities listed on the command line.
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As you select entities in the drawing window, an X marks each regression point and a temporary, dashed
curve is displayed in real time.
NOTE You must select at least two non-collinear regression points.
6 If you selected a profile object, specify the starting and ending station on the Specify Station Range
Dialog Box (page 2228).
7 Press Enter to complete the command.
8 In the Panorama window, use the Regression Data (page 2226) vista to make changes to the regression
points.
As you highlight a row in the Regression Data vista, the corresponding regression point in the drawing
window is highlighted in red.
9 Create the curve:
■

Click

to create the curve and keep the Regression Data vista open.

■

Click

to create the curve and close the Regression Data vista.

To create a floating curve by best fit by clicking on screen
1 Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
2 On the Alignment Layout Tools toolbar, click

.

Floating Curve - Best Fit.

3 Select an entity for the start point and direction.
If you select the beginning of the entity, the best fit curve will precede the entity. If you select the end
of the entity, the best fit curve will succeed the entity.
4 In the Curve By Best Fit Dialog Box (page 2225), select By Clicking On The Screen.
5 Select at least two points.
NOTE You can use OSNAP or transparent commands to select points.
As you select points in the drawing window, an X marks each regression point and a temporary, dashed
curve is displayed in real time.
NOTE You must select at least two non-collinear regression points.
6 Press Enter to complete the command.
7 In the Panorama window, use the Regression Data (page 2226) vista to make changes to the regression
points.
As you highlight a row in the Regression Data vista, the corresponding regression point in the drawing
window is highlighted in red.
8 Create the curve:
■

Click

to create the curve and keep the Regression Data vista open.

■

Click

to create the curve and close the Regression Data vista.
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Quick Reference
Ribbon
Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
Menu
Alignments menu ➤ Edit Alignment Geometry
Command Line
EditAlignment
Alignment Layout Tools Toolbar icons
Floating Curve - Best Fit
Edit Best Fit Data For All Entities
Dialog Box
Curve By Best Fit Dialog Box (page 2225)
Regression Data Vista (page 2226)

Adding Free Curves
Add free curves to build constraint-based alignment geometry for the areas of your design that require
maintaining tangency.
These entity types are very similar to the AutoCAD "fillet" command, but give you added control.
TIP You can use transparent commands when you are prompted to specify direction, radius, or length, and use
station offsets to specify any points. For more information, see Transparent Commands (page 1767).

Adding a Free Curve Fillet with a Specified Radius Between Two Entities
Add a free curve, with a specified angle range and radius, between two entities.
This entity is defined by the attachment entities (1, 2), radius (3), solution angle, and whether the required
solution is compound or reverse. The solution can vary greatly, depending on how you define the constraints.

TIP You can use transparent commands when you are prompted to specify direction, radius, or length, and use
station offsets to specify any points. For more information, see Transparent Commands (page 1767).
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The following illustration shows a free curve fillet between two fixed lines. There are two solutions based
on the included angle of the curve:

The following illustration shows a free curve fillet between two fixed clockwise curves:
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The following illustration shows a free curve fillet between a fixed clockwise curve and a fixed
counter-clockwise curve:

The following illustration shows a free curve fillet between an overlapping clockwise curve and a
counter-clockwise curve:

The following illustration shows a free curve fillet between a line and a clockwise curve (on the left) with a
specified radius:
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The following illustration shows a free curve fillet between a line and a counter-clockwise curve (on the left)
with a specified radius:

To add a free curve fillet (between two entities, radius)
1 Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
2 On the Alignment Layout Tools toolbar, click

.

Free Curve Fillet (Between Two Entities, Radius).

3 Specify the entity (line, curve) from which you want to add the free curve.
4 Specify the entity (line, curve) to which you want to add the free curve.
NOTE The entity before and the entity after must have the same direction.
5 Specify whether the curve solution angle is either greater than or less than 180 degrees.
6 Specify the radius or [curveLen/Tanlen/Chordlen/midOrd/External].
Specify a new value, or press Enter to accept the value that is displayed on the command line.
■

If the alignment has design criteria (page 935) applied to it, the minimum value for the current design
speed is displayed.
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■

If the alignment does not have design criteria applied to it, the default value specified in the curve
and spiral settings is displayed. For more information, see Curve and Spiral Settings (page 930).

To display a curve preview you must pick a point in the drawing or enter a coordinate value, then a
rubber band is drawn to the cursor from the selected point and the curve preview is displayed.
7 Specify the second point. You can enter a 2D coordinate point or use a transparent command. For more
information, see Transparent Commands (page 1767).

Quick Reference
Ribbon
Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
Menu
Alignments menu ➤ Edit Alignment Geometry
Command Line
EditAlignment
Alignment Layout Tools Toolbar icons
Free Curve Fillet (Between Two Entities, Radius)

Adding a Free Curve Fillet with a Through Point Between Two Entities
Add a free curve, with a specified pass-through point, between two entities.
You can add this entity between two lines, two curves, or a line and a curve. The attachment entities (1, 2)
and pass-through point (3) determine the curve radius and length. You cannot edit the radius and length
for this type of curve.

TIP You can use transparent commands when you are prompted to specify direction, radius, or length, or use
station offsets to specify any points. For more information, see Transparent Commands (page 1767).
To add a free curve fillet (between two entities, through point)
1 Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor

.
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2 On the Alignment Layout Tools toolbar, click
Point).

Free Curve Fillet (Between Two Entities, Through

3 Select the entity from which you want to add the free curve.
4 Select the entity to which you want to attach the free curve. A curve preview is displayed.
5 Specify the pass-through point. You can enter a 2D coordinate point or use a transparent command.
For more information, see Transparent Commands (page 1767).

Quick Reference
Ribbon
Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
Menu
Alignments menu ➤ Edit Alignment Geometry
Command Line
EditAlignment
Alignment Layout Tools Toolbar icons
Free Curve Fillet (Between Two Entities, Through Point)

Adding a Free Curve by Best Fit
Add the most probable free curve between two entities through a series of AutoCAD Civil 3D points, AutoCAD
points, existing entities, or clicks on screen.
The location of the curve start and end points on the attachment entities (1,2) is determined by the path
through the selected regression points (3).

See also:
■

Editing Best Fit Alignment Entities (page 1075)

To create a free curve by best fit using AutoCAD Civil 3D points
1 Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
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.

2 On the Alignment Layout Tools toolbar, click

Free Curve - Best Fit.

3 Select the entity from which you want to attach the free curve (the First Entity).
4 Select the entity to which you want to add the free curve (the Next Entity).
NOTE The entity before and the entity after must have the same direction.
5 In the Curve By Best Fit Dialog Box (page 2225), select From COGO Points.
6 Select one or more AutoCAD Civil 3D points. Enter G to select a point group or N to enter points by
number.
As you select points in the drawing window, an X marks each regression point and a temporary, dashed
curve is displayed in real time.
7 Press Enter to complete the command.
8 In the Panorama window, use the Regression Data (page 2226) vista to make changes to the regression
points.
As you highlight a row in the Regression Data vista, the corresponding regression point in the drawing
window is highlighted in red.
9 Create the curve:
■

Click

to create the curve and keep the Regression Data vista open.

■

Click

to create the curve and close the Regression Data vista.

To create a free curve by best fit using AutoCAD points
1 Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
2 On the Alignment Layout Tools toolbar, click

.

Free Curve - Best Fit.

3 Select the entity from which you want to attach the free curve (the First Entity).
4 Select the entity to which you want to add the free curve (the Next Entity).
NOTE The entity before and the entity after must have the same direction.
5 In the Curve By Best Fit Dialog Box (page 2225), select From AutoCAD Points.
6 Select one or more AutoCAD points.
As you select points in the drawing window, an X marks each regression point and a temporary, dashed
curve is displayed in real time.
7 Press Enter to complete the command.
8 In the Panorama window, use the Regression Data (page 2226) vista to make changes to the regression
points.
As you highlight a row in the Regression Data vista, the corresponding regression point in the drawing
window is highlighted in red.
9 Create the curve:
■

Click

to create the curve and keep the Regression Data vista open.
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■

Click

to create the curve and close the Regression Data vista.

To create a free curve by best fit using existing entities
1 Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
2 On the Alignment Layout Tools toolbar, click

.

Free Curve - Best Fit.

3 Select the entity from which you want to attach the free curve (the First Entity).
4 Select the entity to which you want to add the free curve (the Next Entity).
NOTE The entity before and the entity after must have the same direction.
5 In the Curve By Best Fit Dialog Box (page 2225), select From Entities. Specify the tessellation and
mid-ordinate tolerance settings.
6 Select one or more of the entities listed on the command line.
NOTE You can select several types of entities listed on the command line.
As you select entities in the drawing window, an X marks each regression point and a temporary, dashed
curve is displayed in real time.
7 If you selected a profile object, specify the starting and ending station in the Specify Station Range
Dialog Box (page 2228).
8 Press Enter to complete the command.
9 In the Panorama window, use the Regression Data (page 2226) vista to make changes to the regression
points.
As you highlight a row in the Regression Data vista, the corresponding regression point in the drawing
window is highlighted in red.
10 Create the curve:
■

Click

to create the curve and keep the Regression Data vista open.

■

Click

to create the curve and close the Regression Data vista.

To create a free curve by best fit by clicking on screen
1 Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
2 On the Alignment Layout Tools toolbar, click

.

Free Curve - Best Fit.

3 Select the entity from which you want to attach the free curve (the First Entity).
4 Select the entity to which you want to add the free curve (the Next Entity).
NOTE The entity before and the entity after must have the same direction.
5 In the Curve By Best Fit Dialog Box (page 2225), select By Clicking On The Screen.
6 Select one or more points on screen.
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NOTE You can use OSNAP or transparent commands to select points.
As you select points in the drawing window, an X marks each regression point and a temporary, dashed
curve is displayed in real time.
7 Press Enter to complete the command.
8 In the Panorama window, use the Regression Data (page 2226) vista to make changes to the regression
points.
As you highlight a row in the Regression Data vista, the corresponding regression point in the drawing
window is highlighted in red.
9 Create the curve:
■

Click

to create the curve and keep the Regression Data vista open.

■

Click

to create the curve and close the Regression Data vista.

Quick Reference
Ribbon
Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
Menu
Alignments menu ➤ Edit Alignment Geometry
Command Line
EditAlignment
Alignment Layout Tools Toolbar icons
Free Curve - Best Fit
Edit Best Fit Data For All Entities
Dialog Box
Curve By Best Fit Dialog Box (page 2225)
Regression Data Vista (page 2226)

Adding Spirals
Use the Spiral commands to add fixed, free, or floating spirals to the alignment geometry.

Spiral Definitions
Various transition curves are used in civil engineering to gradually introduce curvature and superelevation
between both tangents and circular curves as well as between two circular curves with different curvature.
In its relationship to other tangents and curves, each spiral is either an incurve (page 2776) or an outcurve (page
2779).
The two most commonly used parameters by engineers in designing and setting out a spiral are L (spiral
length) and R (radius of circular curve).
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The following illustration shows the various parameters of a spiral:
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Spiral 1

L2
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ST P2

i2
Spiral 2
Tangent 2

Spiral Parameter

Description

i1

The central angle of spiral curve L1, which is the spiral angle.

i2

The central angle of spiral curve L2, which is the spiral angle.

T1

The total tangent distance from PI to TS.

T2

The total tangent distance from PI to ST.

X1

The tangent distance at SC from TS.

X2

The tangent distance at CS from ST.

Y1

The tangent offset distance at SC from TS.

Y2

The tangent offset distance at CS from ST.

P1

The offset of the initial tangent into the PC of the shifted curve.

P2

The offset of the initial tangent out to the PT of the shifted curve.

K1

The abscissa of the shifted PC referred to the TS.

K2

The abscissa of the shifted PT referred to the ST.

LT1

The long tangent spiral in.

LT2

The long tangent spiral out.

ST1

The short tangent spiral in.

ST2

The short tangent spiral out.
Other Spiral Parameters
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A1

The A value equals the square root of the spiral length multiplied
by the radius. A measure of the flatness of the spiral.

A2

The A value equals the square root of the spiral length multiplied
by the radius. A measure of the flatness of the spiral.

Formula

Compound Spiral
Compound spirals provide a transition between two circular curves with different radii. As with the simple
spiral, this allows for continuity of the curvature function and provides a way to introduce a smooth transition
in superelevation.

Clothoid Spiral
While AutoCAD Civil 3D supports several spiral types, the clothoid spiral is the most commonly used spiral
type. The clothoid spiral is used world wide in both highway and railway track design.
First investigated by the Swiss mathematician Leonard Euler, the curvature function of the clothoid is a
linear function chosen such that the curvature is zero (0) as a function of length where the spiral meets the
tangent. The curvature then increases linearly until it is equal to the adjacent curve at the point where the
spiral and curve meet.
Such an alignment provides for continuity of the position function and its first derivative (local azimuth),
just as a tangent and curve do at a Point of Curvature (PC). However, unlike the simple curve, it also maintains
continuity of the second derivative (local curvature), which becomes increasingly important at higher speeds.
Formula

Clothoid spirals can be expressed as:
Flatness of spiral:

Total angle subtended by spiral:
Tangent distance at spiral-curve point from tangent-spiral point is:

Tangent offset distance at spiral-curve point from tangent-spiral point is:

Bloss Spiral
Instead of using the clothoid, the Bloss spiral with the parabola of fifth degrees can be used as a transition.
This spiral has an advantage over the clothoid in that the shift P is smaller and therefore there is a longer
transition, with a larger spiral extension (K). This factor is important in rail design.
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Formula
Bloss spirals can be expressed as:

Other key expressions:
Tangent distance at spiral-curve point from tangent-spiral point is:

Tangent offset distance at spiral-curve point from tangent-spiral point is:

Sinusoidal Curves
These curves represent a consistent course of curvature and are applicable to transition from 0 through 90
degrees of tangent deflections. However, sinusoidal curves are not widely used because they are steeper than
a true spiral and are therefore difficult to tabulate and stake out.
Formula
Sinusoidal curves can be expressed as:

Differentiating with l we get an equation for l/r, where r is the radius of curvature at any given point:

Sine Half-Wavelength Diminishing Tangent Curve
This form of equation is commonly used in Japan for railway design. This curve is useful in situations where
you need an efficient transition in the change of curvature for low deflection angles (in regard to vehicle
dynamics.)
Formula
Sine Half-Wavelength Diminishing Tangent curves can be expressed as:

where
and x is the distance from the start to any point on the curve and is measured along the
(extended) initial tangent; X is the total X at the end of the transition curve.
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Other key expressions:
Tangent distance at spiral-curve point from tangent-spiral point is:

Tangent offset distance at spiral-curve point from tangent-spiral point is:

Cubic Spiral (JP)
This spiral is developed for requirements in Japan. Some approximations of the clothoid have been developed
to use in situations to accommodate a small deflection angle or a large radius. One of these approximations,
used for design in Japan, is the Cubic Spiral (JP).
Formula
Cubic Spirals (JP) can be expressed as:

Where X = Tangent distance at spiral-curve point from tangent-spiral point
This formula can also be expressed as:

Where

is central angle the spiral (illustrated as i1 and i2in the illustration)

Other key expressions:
Tangent distance at spiral-curve point from tangent-spiral point is:

Tangent offset distance at spiral-curve point from tangent-spiral point is:

Cubic Parabolas
Cubic parabolas converge less rapidly than cubic spirals, which makes their use popular in railway and
highway design. While they are less accurate than cubic spirals, cubic parabolas are preferred by highway
and railway engineers because they are expressed in Cartesian coordinates and are easy to set out in the
field.
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Formula
When

-> zero -> we can assume that cos

Further, if we assume that sin

=

= l, then x = l.

, then

x = l and TotalX = (approximately) L
Substituting this approximation helps us obtain the following equation:

All other parameters are the same as the clothoid spiral.
Minimum Radius of Cubic Parabola
The radius at any point on a cubic parabola is:

A cubic parabola attains minimum r at:

So
A cubic parabola radius decreases from infinity to
at 24 degrees, 5 minutes, 41 seconds
and from then onwards starts to increase again. This makes cubic parabolas useless for deflections greater
than 24 degrees.

Bi-Quadratic (Schramm) Spirals
Bi-quadratic (Schramm) spirals have low values of vertical acceleration. They contain two second-degree
parabolas whose radii vary as a function of curve length.
Simple Curve Formula
Curvature of the first parabola:

for
Curvature of the second parabola:

for
This curve is specified by the user-defined length (L) of the transition curve.
Compound Curve Formulas
Curvature of the first parabola:
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for
Curvature of the second parabola:

for

Adding Fixed Spirals
Use the Alignment Layout Tools to add a fixed spiral to the end of an existing entity.

Adding a Fixed Spiral
Add a fixed spiral to the end of a fixed or floating entity.
Depending on the desired solution, a fixed spiral can be defined by various parameters, which cannot be
edited after creation. When the attachment entity (1) is edited, the defining parameter (2) does not change.

To add a fixed spiral
1 Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
2 On the Alignment Layout Tools toolbar, click

.

Fixed Spiral.

The current spiral definition is displayed on the command line. For more information about changing
the default spiral definition, see Specifying Curve and Spiral Settings (page 930)
3 Select the entity for a start point and a direction.
4 Specify the spiral type: either Compound, Incurve, Outcurve, or Point.
5 Specify the curve direction: either Clockwise or Counterclockwise.
6 Specify a start radius by either picking two points in the drawing or entering a value on the command
line.
NOTE If the alignment has design criteria (page 935) applied to it, the minimum radius and spiral length
values for the current design speed are displayed on the command line. Specify new values, or press Enter
to accept the minimums.
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7 At the prompt Specify spiral in length or [A/aNgle] specify whether to define the spiral by length
or sweep angle.
8 Specify the length or start angle by either picking two points in the drawing or entering a value on the
command line.
9 Specify the end radius by picking two points in the drawing or entering a value on the command line.

Quick Reference
Ribbon
Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
Menu
Alignments menu ➤ Edit Alignment Geometry
Command Line
EditAlignment
Alignment Layout Tools Toolbar icons
Fixed Spiral

Adding Free Spirals
Use the free spiral commands to create spiral solutions as a transition between two curves with different
radii.

Adding a Free Spiral Between Two Entities
Add a free spiral between two fixed or floating entities.
A free spiral has only one geometric solution, so you cannot specify its length or A value. The solution
depends on the type of attachment entities (1, 2), and the order in which they are selected.

Adding a Free Spiral Between Two Curves
Use this command in situations where you need to create a single compound spiral solution as a transition
between two curves with different radii.
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Because free spirals have only one geometric solution, you cannot specify length or A value. The program
makes the calculation.
IMPORTANT Adding a free spiral between two curves is only supported for Clothoid and Bloss spiral types.
The following illustrations show a free spiral between two curves. The solution depends on the selection
order of the curve that the spiral is being attached to. The first illustration shows a left solution, where the
inner circle was selected first. The second illustration shows a right solution, where the inner circle was
selected second:

CS

C

C

free spiral (left solution)

existing fixed or floating curve
existing fixed or floating curve

existing fixed or floating curve
CS
C

free spiral right solution
C

existing fixed or floating curve

To add a free spiral (between two curves)
1 Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
2 On the Alignment Layout Tools toolbar, click

.

Free Spiral (Between Two Entities).

The current spiral definition is displayed on the command line. For more information about changing
the default spiral definition, see Specifying Curve and Spiral Settings (page 930).
3 Select the entity before and the entity after to add the spiral to.
The solution depends on the order in which you select the curves that the spiral is being attached to.
For a solution where the spiral is coming from the left, select the inner circle first. For a solution where
the spiral is coming from right, select the inner circle second.
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Quick Reference
Ribbon
Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
Menu
Alignments menu ➤ Edit Alignment Geometry
Command Line
EditAlignment
Alignment Layout Tools Toolbar icons
Free Spiral (Between Two Entities)

Adding a Free Spiral Between Two Lines
Add a free spiral between two lines in situations where you want the spirals to maintain tangency to the
lines they are attached to.
For this solution, the spirals are simple, incurve, or outcurve.
The following illustration shows a free spiral between two lines. The possible solutions include:
■

simple spiral (page 2782) incurve

■

simple spiral outcurve

L
L

To add a free spiral (between two lines)
1 Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
2 On the Alignment Layout Tools toolbar, click

.

Free Spiral (Between Two Entities).

The current spiral definition is displayed at the command line. For more information about changing
the default spiral definition, see Specifying Curve and Spiral Settings (page 930).
3 Select the entity before and the entity after to add the spiral to.
4 Specify the spiral type as either Incurve or Outcurve.
5 Specify the spiral length or the A value.
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Quick Reference
Ribbon
Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
Menu
Alignments menu ➤ Edit Alignment Geometry
Command Line
EditAlignment
Alignment Layout Tools Toolbar icons
Free Spiral (Between Two Entities)

Adding a Free Spiral Between a Line and a Curve
Add a free spiral between a line and curve in situations where you want the spiral to maintain the radius of
the curve it is attached to, even if the curve is edited.
For this solution, the spirals are simple because the radius of the spiral at the line end is infinite (as opposed
to a compound spiral, where the radius at each end is finite). This solution between a line and a curve is
valid for all spiral types because all spirals types support the simple spiral.
The two possible solutions depend on which entity you select first, either the line or the curve.
The following illustration shows a free spiral between a line and a curve, where the line was selected first:

SS

existing fixed or floating line
L

C
free spiral

existing fixed or floating curve

To add a free spiral (between a line and a curve)
1 Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
2 On the Alignment Layout Tools toolbar, click

.

Free Spiral (Between Two Entities).

The current spiral definition is displayed at the command line. For more information about changing
the default spiral definition, see Specifying Curve and Spiral Settings (page 930).
3 Select the line before and the curve after to add the spiral to.
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Quick Reference
Ribbon
Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
Menu
Alignments menu ➤ Edit Alignment Geometry
Command Line
EditAlignment
Alignment Layout Tools Toolbar icons
Free Spiral (Between Two Entities)

Adding a Free Compound Spiral-Spiral Between Two Curves
Add a free spiral-spiral group between two curves that are in the same direction but have different radii.
The spirals have finite radii on either end. Spiral parameters and attachment points are automatically
calculated. If either of the attachment curves (1, 2) are edited, the spiral-spiral group maintains tangency.
By default, the two spirals have equal lengths and A values. Both values can be modified at the time of
creation by specifying a ratio of A1/A2 or L1/L2.

The spiral radii are identical at the spiral-spiral intersection point. The radius value is determined by the
total deflection angle and the two spiral lengths. The radius value cannot be edited.
To add a free compound spiral-spiral (between two curves)
1 Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
2 On the Alignment Layout Tools toolbar, click

.

Free Compound Spiral-Spiral (Between Two Curves).

The current spiral definition is displayed at the command line. For more information about changing
the default spiral definition, see Specifying Curve and Spiral Settings (page 930).
3 Specify the entity before and the entity after to which you want to add the spiral.
4 Optionally, enter a value for the ratio of A1 to A2, or select Length and enter a value for the ratio of L1
to L2. Otherwise, the A values and lengths of each spiral will be equal.
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NOTE If the curves are in the same direction, a compound solution is given. Enter Yes at the command line
to accept the solution, or enter No to restart the command. There is no solution if the curves cross, or for
concentric curves.

Quick Reference
Ribbon
Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
Menu
Alignments menu ➤ Edit Alignment Geometry
Command Line
EditAlignment
Alignment Layout Tools Toolbar icons
Free Compound Spiral-Spiral (Between Two Curves)

Adding a Free Reverse Spiral-Spiral Between Two Curves
Add a free reverse spiral-spiral group between two curves that are in different directions.
The two spirals bend in opposite directions. Spiral parameters and attachment points are automatically
calculated. If either of the attachment curves (1, 2) are edited, the spiral-spiral group maintains tangency.

By default, the two spirals have equal lengths and A values. Both values can be modified at the time of
creation by specifying a ratio of A1/A2 or L1/L2.
To add a free reverse spiral-spiral (between two curves)
1 Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
2 On the Alignment Layout Tools toolbar, click

.

Free Reverse Spiral-Spiral (Between Two Curves).

The current spiral definition is displayed at the command line. For more information about changing
the default spiral definition, see Specifying Curve and Spiral Settings (page 930).
3 Specify the entity before and the entity after to which you want to add the spiral.
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4 Optionally, enter a value for the ratio of A1 to A2, or select Length and enter a value for the ratio of L1
to L2. Otherwise, the A values and lengths of each spiral will be equal.
NOTE If the curves are in the same direction, a compound solution is given. Enter Yes at the command line
to accept the solution, or enter No to restart the command. There is no solution if the curves cross, or for
concentric curves.

Quick Reference
Ribbon
Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
Menu
Alignments menu ➤ Edit Alignment Geometry
Command Line
EditAlignment
Alignment Layout Tools Toolbar icons
Free Reverse Spiral-Spiral (Between Two Curves)

Adding a Free Compound Spiral-Spiral Between Two Tangents
Add a free compound spiral-spiral group, with a specified parameter, between two tangents.
You specify either the length (3, 4) or A value for each spiral. The spiral radii match at the spiral-spiral
intersection point. If either of the attachment tangents (1, 2) are edited, the spiral parameters that you
specified do not change.

To add a free compound spiral-spiral (between two tangents)
1 Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
2 On the Alignment Layout Tools toolbar, click

Free Compound Spiral-Spiral (Between Two Tangents).

3 Select the tangent (the First Entity) from which you want to add the spiral group.
4 Select the tangent (the Next Entity) to which you want to add the spiral group.
5 Specify the length or A value of the first spiral (the spiral in).
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.

Specify a new value, or press Enter to accept the value that is displayed on the command line.
■

If the alignment has design criteria (page 935) applied to it, the minimum value for the current design
speed is displayed.

■

If the alignment does not have design criteria applied to it, the default value specified in the curve
and spiral settings is displayed. For more information, see Curve and Spiral Settings (page 930).

6 Specify the length or A value of the second spiral (the spiral out).
7 Specify whether the solution is greater or less than 180 degrees.

Quick Reference
Ribbon
Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
Menu
Alignments menu ➤ Edit Alignment Geometry
Command Line
EditAlignment
Alignment Layout Tools Toolbar icons
Free Compound Spiral-Spiral (Between Two Tangents)

Adding a Free Compound Spiral-Line-Spiral with Specified Spiral Lengths Between
Two Curves
Add a free compound spiral-line-spiral group, with specified spiral lengths, between two curves.
The line length is automatically calculated. If either of the attachment curves (1, 2) are edited, the spiral
lengths (3, 4) do not change.

To add a free compound spiral-line-spiral (between two curves, spiral lengths)
1 Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
2 On the Alignment Layout Tools toolbar, click
Curves, Spiral Lengths).

.

Free Compound Spiral-Line-Spiral (Between Two
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The current spiral definition is displayed at the command line. For more information about changing
the default spiral definition, see Specifying Curve and Spiral Settings (page 930).
3 Specify the entity before and the entity after to which you want to add the spiral.
4 Specify either the length or the A value for the spiral in and the spiral out.
Specify a new value, or press Enter to accept the value that is displayed on the command line.
■

If the alignment has design criteria (page 935) applied to it, the minimum value for the current design
speed is displayed.

■

If the alignment does not have design criteria applied to it, the default value specified in the curve
and spiral settings is displayed. For more information, see Curve and Spiral Settings (page 930).

NOTE If the curves are in a different direction, a reverse solution is given. Enter Yes at the command line to
accept the solution, or enter No to restart the command. There is no solution for concentric curves.

Quick Reference
Ribbon
Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
Menu
Alignments menu ➤ Edit Alignment Geometry
Command Line
EditAlignment
Alignment Layout Tools Toolbar icons
Free Compound Spiral-Line-Spiral (Between Two Curves, Spiral Lengths)

Adding a Free Reverse Spiral-Line-Spiral with Specified Spiral Lengths Between Two
Curves
Add a free reverse spiral-line-spiral group, with specified spiral lengths, between two curves.
The two spirals bend in opposite directions. You specify the spiral lengths (2, 3). The line length is
automatically calculated. If either of the attachment curves (1, 2) are edited, the spiral lengths do not change.

1026 | Chapter 24 Alignments

In this command you can specify the spiral parameters, but not the line length. Line length is calculated
automatically.
To add a free reverse spiral-line-spiral (between two curves, spiral lengths)
1 Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
2 On the Alignment Layout Tools toolbar, click
Spiral Lengths).

.

Free Reverse Spiral-Line-Spiral (Between Two Curves,

The current spiral definition is displayed at the command line. For more information about changing
the default spiral definition, see Specifying Curve and Spiral Settings (page 930).
3 Specify the entity before and the entity after to which you want to add the spiral.
4 Specify either the length or the A value for the spiral in and the spiral out.
Specify a new value, or press Enter to accept the value that is displayed on the command line.
■

If the alignment has design criteria (page 935) applied to it, the minimum value for the current design
speed is displayed.

■

If the alignment does not have design criteria applied to it, the default value specified in the curve
and spiral settings is displayed. For more information, see Curve and Spiral Settings (page 930).

NOTE If the curves are in the same direction, a compound solution is given. Enter Yes at the command line
to accept the solution, or enter No to restart the command. There is no solution for concentric curves.

Quick Reference
Ribbon
Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
Menu
Alignments menu ➤ Edit Alignment Geometry
Command Line
EditAlignment
Alignment Layout Tools Toolbar icons
Free Reverse Spiral-Line-Spiral (Between Two Curves, Spiral Lengths)

Adding a Free Compound Spiral-Line-Spiral with a Specified Line Length Between
Two Curves
Add a free compound spiral-line-spiral group, with a specified line length, between two curves.
The spiral parameters are automatically calculated. If either of the attachment curves (1, 2) are edited, the
line length (3) does not change.
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To add a free compound spiral-line-spiral (between two curves, line length)
1 Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
2 On the Alignment Layout Tools toolbar, click
Curves, Line Length).

.

Free Compound Spiral-Line-Spiral (Between Two

The current spiral definition is displayed at the command line. For more information about changing
the default spiral definition, see Specifying Curve and Spiral Settings (page 930).
3 Specify the entity before and the entity after to which you want to add the spiral.
4 Specify the line length.
NOTE If the curves are in the same direction, a compound solution is given. Enter Yes at the command line to
accept the solution, or enter No to restart the command. There is no solution for concentric curves.

Quick Reference
Ribbon
Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
Menu
Alignments menu ➤ Edit Alignment Geometry
Command Line
EditAlignment
Alignment Layout Tools Toolbar icons
Free Compound Spiral-Line-Spiral (Between Two Curves, Line Length)

Adding a Free Reverse Spiral-Line-Spiral with a Specified Line Length Between Two
Curves
Add a free reverse spiral-line-spiral group, with a specified line length, between two curves.
The two spirals bend in opposite directions. You specify the line length (3). The spiral lengths are automatically
calculated. If either of the attachment curves (1, 2) are edited, the line length does not change.
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To add a free reverse spiral-line-spiral (between two curves, line length)
1 Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
2 On the Alignment Layout Tools toolbar, click
Line Length).

.

Free Reverse Spiral-Line-Spiral (Between Two Curves,

The current spiral definition is displayed at the command line. For more information about changing
the default spiral definition, see Specifying Curve and Spiral Settings (page 930).
3 Specify the entity before and the entity after to which you want to add the spiral.
4 Specify the line length.
NOTE If the curves are in the same direction, a compound solution is given. Enter Yes at the command line to
accept the solution, or enter No to restart the command. There is no solution for crossing or concentric curves.

Quick Reference
Ribbon
Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
Menu
Alignments menu ➤ Edit Alignment Geometry
Command Line
EditAlignment
Alignment Layout Tools Toolbar icons
Free Reverse Spiral-Line-Spiral (Between Two Curves, Line Length)

Adding Lines with Spirals
Add entities that contain lines and transition spirals.
Lines and transition spirals can only be attached to fixed or floating entities.
After clicking a button on the Alignment Layout Tools toolbar, follow the command prompts on the command
line.
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TIP You can use transparent commands when you are prompted to specify direction, radius, or length, or use
station offsets to specify any points. For more information, see Transparent Commands (page 1767).

Adding Floating Lines with Spirals
Add floating lines with spirals in situations where you need a spiral transition to a line that is defined by
either a pass-through point or length.

Adding a Floating Line with Spiral with a Through Point to a Curve
Add a floating spiral-line group, with a specified spiral length and pass-through point, to a curve.
When the attachment entity (1) is edited, the spiral length (2) and pass-through point (3) do not change.
The line length and attachment point change to accommodate edits to the attachment curve.

To add a floating line with a spiral (from curve, through point)
1 Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
2 On the Alignment Layout Tools toolbar, click
Point).

.

Floating Line With Spiral (From Curve, Through

The current spiral definition is displayed at the command line.
3 Specify the curve end to attach to.
4 Specify either the spiral length or the A value, either by entering a numeric value, or selecting two
points in the drawing.
Specify a new value, or press Enter to accept the value that is displayed on the command line.
■

If the alignment has design criteria (page 935) applied to it, the minimum value for the current design
speed is displayed.

■

If the alignment does not have design criteria applied to it, the default value specified in the curve
and spiral settings is displayed. For more information, see Curve and Spiral Settings (page 930).

5 Specify the pass through point.
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Quick Reference
Ribbon
Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
Menu
Alignments menu ➤ Edit Alignment Geometry
Command Line
EditAlignment
Alignment Layout Tools Toolbar icons
Floating Line With Spiral (From Curve, Through Point)

Adding a Floating Line with a Spiral with Specified Lengths to a Curve End
Add a floating spiral-line group, with specified spiral and line lengths, to a curve.
When the attachment entity (1) is edited, the spiral (2) and line (3) lengths do not change. You can adjust
or move the attachment curve and the entire spiral-line group moves with it.

To add a floating line with spiral (from curve end, length)
1 Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor

.

2 On the Alignment Layout Tools toolbar, click
Floating Line With Spiral (From Curve End, Length).
The current spiral definition is displayed at the command line.
3 Specify the curve end to attach to.
4 Specify the spiral length or the A value, by either entering a numeric value or selecting two points.
Specify a new value, or press Enter to accept the value that is displayed on the command line.
■

If the alignment has design criteria (page 935) applied to it, the minimum value for the current design
speed is displayed.

■

If the alignment does not have design criteria applied to it, the default value specified in the curve
and spiral settings is displayed. For more information, see Curve and Spiral Settings (page 930).

5 Specify the line length.

Adding Lines with Spirals | 1031

Quick Reference
Ribbon
Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
Menu
Alignments menu ➤ Edit Alignment Geometry
Command Line
EditAlignment
Alignment Layout Tools Toolbar icons
Floating Line With Spiral (From Curve End, Length)

Adding Curves with Spirals
Add entities that contain curves and transition spirals.
This entity type can only be added to existing fixed or floating lines.
After clicking a button on the Alignment Layout Tools toolbar, follow the command prompts on the command
line.
TIP You can use transparent commands when you are prompted to specify direction, radius, or length, or use
station offsets to specify any points. For more information, see Transparent Commands (page 1767).

Adding Floating Curves with Spirals
Add floating curves with spirals in situations where you need a transition spiral and the curve geometry
must pass through a specified point.
TIP You can use transparent commands when you are prompted to specify direction, radius, or length, or use
station offsets to specify any points. For more information, see Transparent Commands (page 1767).

Adding a Floating Curve with a Spiral with a Specified Radius, Spiral Length, and
Through Point to an Entity
Add a floating spiral-curve group, with a specified radius, spiral length, and pass-through point, to an existing
line or curve entity.
When the attachment entity (1) is edited, the spiral length (3), solution angle (4), and curve radius (2) and
pass-through point (5) do not change. The attachment point and curve length adjust to accommodate edits
to the attachment curve.
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To add a floating curve with spiral (from entity, through point) off a curve
1 Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor

.

2 On the Alignment Layout Tools toolbar, click
Floating Curve With Spiral (From Entity, Radius,
Through Point) to add a floating curve with a spiral off a curve.
The current spiral definition is displayed on the command line.
3 Specify the curve entity to add to.
4 Specify the radius.
Specify a new value, or press Enter to accept the value that is displayed on the command line.
■

If the alignment has design criteria (page 935) applied to it, the minimum value for the current design
speed is displayed.

■

If the alignment does not have design criteria applied to it, the default value specified in the curve
and spiral settings is displayed. For more information, see Curve and Spiral Settings (page 930).

5 Specify either the spiral length or the A value.
6 Specify whether the curve solution angle is either greater than or less than 180 degrees.
7 Specify whether the curve is compound or reverse to the curve it is being added to.
8 Specify the pass through point.

Quick Reference
Ribbon
Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
Menu
Alignments menu ➤ Edit Alignment Geometry
Command Line
EditAlignment
Alignment Layout Tools Toolbar icons
Floating Curve With Spiral (From Entity, Radius, Through Point)
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Adding a Floating Curve with a Spiral from the Entity End with a Specified Radius and
Length to an Entity
Add a floating spiral-curve group, with a specified radius and length, to an existing entity.
When the attachment entity (1) is edited, the spiral length (3) and curve radius (2) and length (4) do not
change. You can adjust or move the attachment curve and the entire curve and spiral entity moves with it.

To add a floating curve with a spiral (from entity, radius, length) off a line
1 Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor

.

2 On the Alignment Layout Tools toolbar, click
Floating Curve With Spiral (From Entity End, Radius,
Length) to add a floating curve with a spiral off a line.
The current spiral definition is displayed at the command line.
3 Specify the line entity to add to.
4 Specify the radius.
Specify a new value, or press Enter to accept the value that is displayed on the command line.
■

If the alignment has design criteria (page 935) applied to it, the minimum value for the current design
speed is displayed.

■

If the alignment does not have design criteria applied to it, the default value specified in the curve
and spiral settings is displayed. For more information, see Curve and Spiral Settings (page 930).

5 Specify either the spiral length or the A value.
6 Specify whether the curve solution angle is either greater than or less than 180 degrees.
7 Specify an end point.

Quick Reference
Ribbon
Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
Menu
Alignments menu ➤ Edit Alignment Geometry
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Command Line
EditAlignment
Alignment Layout Tools Toolbar icons
Floating Curve With Spiral (From Entity End, Radius, Length)

Adding a Floating Reverse Curve with Spirals to a Curve
Add a floating reverse curve with spirals in situations where you need two back-to-back reverse transition
spirals and the curve geometry must pass through a specified point.
Floating reverse curves are defined by either a radius and through point or two through points.
TIP You can use transparent commands when you are prompted to specify direction, radius, or length, or use
station offsets to specify any points. For more information, see Transparent Commands (page 1767).

Adding a Floating Reverse Curve with Spirals with a Specified Radius and Through
Point to a Curve
Add a floating reverse spiral-spiral-curve group, with a specified radius and pass-through point, to a curve.
The two spirals bend in opposite directions. The curve bends in the opposite direction of the attachment
curve. When the attachment curve (1) is edited, the spiral lengths (2, 4), curve radius (3) and pass-through
point (5) do not change. The attachment point and the length of the reverse curve adjust to accommodate
edits to the attachment curve.

This entity does not support either of the following solutions:
■

Solutions that require a floating curve angle greater than 180 degrees. The following illustration shows
both the supported and unsupported solutions:
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■

Compound solutions. The following illustration shows an unsupported compound solution:

To add a floating reverse curve with spirals (from curve, radius, through point) off a curve
1 Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor

.

2 On the Alignment Layout Tools toolbar, click
Floating Reverse Curve With Spirals (From Curve,
Radius, Through Point) to add a floating reverse curve with spirals off a curve.
The current spiral definition is displayed at the command line.
3 Specify the fixed or floating curve entity to attach to.
4 Specify either the spiral in length or the A value.
Specify a new value, or press Enter to accept the value that is displayed on the command line.
■

If the alignment has design criteria (page 935) applied to it, the minimum value for the current design
speed is displayed.
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■

If the alignment does not have design criteria applied to it, the default value specified in the curve
and spiral settings is displayed. For more information, see Curve and Spiral Settings (page 930).

5 Specify either the spiral out length or the A value.
6 Specify the radius.
7 Specify the pass through point.

Quick Reference
Ribbon
Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
Menu
Alignments menu ➤ Edit Alignment Geometry
Command Line
EditAlignment
Alignment Layout Tools Toolbar icons
Floating Reverse Curve With Spirals (From Curve, Radius, Through Point)

Adding a Floating Reverse Curve with Spirals with Two Through Points to a Curve
Adds a floating reverse spiral-spiral-curve group, with two specified pass-through points, to an existing curve.
The two spirals bend in opposite directions. The curve bends in the opposite direction of the attachment
curve. When the attachment curve (1) is edited, the spiral lengths (2, 3) and pass-through points (4, 5) do
not change. The attachment point and the radius and length of the reverse curve adjust to accommodate
edits to the attachment curve.

To add a floating reverse curve with spirals (from curve, two through points) off a curve
1 Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor

.

2 On the Alignment Layout Tools toolbar, click
Floating Reverse Curve With Spirals (From Curve,
Two Points) to add a floating reverse curve with spirals off a curve.
The current spiral definition is displayed at the command line.

Adding Curves with Spirals | 1037

3 Specify the fixed or floating curve entity to attach to.
4 Specify either the spiral in length or the A value.
Specify a new value, or press Enter to accept the value that is displayed on the command line.
■

If the alignment has design criteria (page 935) applied to it, the minimum value for the current design
speed is displayed.

■

If the alignment does not have design criteria applied to it, the default value specified in the curve
and spiral settings is displayed. For more information, see Curve and Spiral Settings (page 930).

5 Specify either the spiral out length or the A value.
6 Specify the pass through point.
7 Specify the second pass through point (end point).

Quick Reference
Ribbon
Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
Menu
Alignments menu ➤ Edit Alignment Geometry
Command Line
EditAlignment
Alignment Layout Tools Toolbar icons
Floating Reverse Curve With Spirals (From Curve, Two Points)

Adding Spiral-Curve-Spirals
Add a free spiral-curve-spiral group between two entities.
The type of spirals created (simple vs. compound) depends on the types of entities you attach it to. When
the attachment entities (1, 2) are edited, the spiral lengths (3, 4) and curve radius (5) do not change. The
attachment points and the curve length adjust to accommodate edits to the attachment entities.

The Spiral-Curve-Spiral command is similar to the command that adds a free curve by radius between two
entities. However, this command adds a transition spiral in and a transition spiral out. The curve group for
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this command is the same as the automatic curve group that is created when you use the Tangent-Tangent
command. However, with this command you can create an SCS curve group between curves.
You cannot grip edit the spiral-curve-spiral curve group, but you can edit the entities to which the SCS group
is attached. Make edits to the spiral or curve parameters in the Alignment Layout Parameters (page 1953) dialog
box or the Alignment Entities (page 1947) vista.

SCS curve group between two tangents
An SCS curve group placed between two tangents creates two simple spirals.

SCS curve group between a curve and a tangent
An SCS curve group placed between a tangent and a curve results in the simple spiral attached to the tangent
and a compound spiral attached to the curve.

SCS curve group between two curves
An SCS curve group placed between two curves creates two compound spirals. The SCS curve group should
only be placed in a configuration where the attachment to either curve forms a compound curve-curve
situation.
To add a free spiral-curve-spiral (between two entities)
1 Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
2 On the Alignment Layout Tools toolbar, click

.

Free Spiral-Curve-Spiral (Between Two Entities).

3 Select the entity from which you want to add the spiral-curve-spiral.
4 Select the entity to which you want to add the spiral-curve-spiral.
5 Select the spiral-in length by picking two points in the drawing or by entering a spiral-in A value.
Specify a new value, or press Enter to accept the value that is displayed on the command line.
■

If the alignment has design criteria (page 935) applied to it, the minimum value for the current design
speed is displayed.

■

If the alignment does not have design criteria applied to it, the default value specified in the curve
and spiral settings is displayed. For more information, see Curve and Spiral Settings (page 930).

6 Select the spiral-out length or enter a spiral-out A value.
7 Specify whether the curve solution angle is either greater than or less than 180 degrees.
8 Enter a radius value or select two points in the drawing to specify the radius.
To display a curve preview you must either pick a point in the drawing or enter a coordinate value.
Then, rubber band is drawn to the cursor from the selected point and the curve preview is displayed.
NOTE If you enter an A value for either the spiral-in or the spiral-out value, then the curve preview is not
displayed when you specify the radius.

Quick Reference
Ribbon
Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
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Menu
Alignments menu ➤ Edit Alignment Geometry
Command Line
EditAlignment
Alignment Layout Tools Toolbar icons
Free Spiral-Curve-Spiral (Between Two Entities)

Adding Complex Free Curve Groups Between Tangents
Use the Alignment Layout Tools to add complex curve groups to your alignment. Complex curve groups
consist of multiple curves and spirals and are available in compound and reverse solutions.
Complex free curve groups are defined by the radius of each curve and the length or A value of each spiral.
Additionally, a second parameter must be specified for either of the two curves.

Adding a Free Compound Spiral-Curve-Spiral-Curve-Spiral Between Two Tangents
Add a free spiral-curve-spiral-curve-spiral group between two tangents.
When the attachment tangents (1, 2) are edited, the curve radii (3, 4) and spiral lengths (5, 6, 7) do not
change. The attachment points and the curve lengths adjust to accommodate edits to the attachment
tangents. The length of any of the spirals can be zero.

The compound Spiral-Curve-Spiral-Curve-Spiral (SCSCS) group is placed between two tangents. This group
is similar to the spiral-curve-spiral (SCS) group, but it has a second curve and spiral at the end of the group.
The SCSCS group accepts zero as a spiral length, which allows you to create a multiple curve group with or
without spirals. Any of the spirals in this group can have a zero length. A spiral with zero length is effectively
omitted from the group. The following combinations are possible by specifying zero as the spiral length:
SCSCS, SCSC, CSCS, CSC, SCCS, SCC, CCS, CC.
You cannot grip edit the SCSCS group, but you can edit the tangents to which it is attached. The point of
intersection (PI) of the original tangents is maintained, which causes the entire curve group to react to
changes to either tangent. You can edit the spiral or curve parameters directly in either the Alignment Layout
Parameters (page 1953) dialog box or the Alignment Entities (page 1947) vista. If a spiral in the group has zero
length specified, the spiral parameters are still displayed.
To add a free spiral-curve-spiral-curve spiral between two tangents
1 Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
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.

2 On the Alignment Layout Tools toolbar, click
(Between Two Tangents).

Free Compound Spiral-Curve-Spiral-Curve-Spiral

3 Select the tangent (the First Entity) from which you want to add the curve group.
4 Select the tangent (the Next Entity) to which you want to add the curve group.
5 Specify the length or A value of the first spiral.
NOTE You can specify length by picking two points in the drawing. Zero is an acceptable length for any of
the spirals in this curve group.
6 Specify the radius of the first curve.
7 Specify the length or A value of the second spiral.
8 Specify the radius of the second curve.
9 Specify the length or A value of the third spiral.
10 Enter a second parameter for one of the curves.
You can specify an extended tangent length, start point on a tangent, subtended angle, or pass-through
point. Enter C to switch the curve for which you will enter the parameter.

Quick Reference
Ribbon
Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
Menu
Alignments menu ➤ Edit Alignment Geometry
Command Line
EditAlignment
Alignment Layout Tools Toolbar icons
Free Compound Spiral-Curve-Spiral-Curve-Spiral (Between Two Tangents)

Adding a Free Reverse Spiral-Curve-Spiral-Spiral-Curve-Spiral Between Two Tangents
Add a free reverse spiral-curve-spiral-spiral-curve-spiral group between two tangents that are nearly parallel.
This group consists of two successive spiral-curve-spiral groups in opposing directions. When the attachment
tangents (1, 2) are edited, the curve radii (4, 7) and spiral lengths (3, 5, 6, 8) do not change. The attachment
points and the curve lengths adjust to accommodate edits to the attachment tangents.
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You cannot grip edit the reverse SCSSCS group, but you can edit the tangents to which it is attached. You
can edit the spiral or curve parameters directly in either the Alignment Layout Parameters (page 1953) dialog
box or the Alignment Entities (page 1947) vista.
To add a free reverse spiral-curve-spiral-spiral-curve-spiral between two tangents
1 Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
2 On the Alignment Layout Tools toolbar, click
(Between Two Tangents).

.

Free Reverse Spiral-Curve-Spiral-Spiral-Curve-Spiral

3 Select the tangent (the First Entity) from which you want to add the curve group.
4 Select the tangent (the Next Entity) to which you want to add the curve group.
5 Specify the length or A value of the first spiral (the spiral in).
NOTE You can specify length by picking two points in the drawing.
6 Specify a radius for the first curve.
7 Specify the length or A value of the second spiral (the spiral out).
8 Specify the length or A value of the third spiral (the spiral in).
9 Specify a radius for the second curve.
10 Specify the length or A value of the fourth spiral (the spiral out).
11 Enter a second parameter for one of the curves.
You can specify a start point on a tangent, subtended angle, or pass-through point. Enter C to switch
the curve for which you will enter the parameter.

Quick Reference
Ribbon
Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
Menu
Alignments menu ➤ Edit Alignment Geometry
Command Line
EditAlignment
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Alignment Layout Tools Toolbar icons
Free Reverse Spiral-Curve-Spiral-Spiral-Curve-Spiral (Between Two Tangents)

Alignment Labels and Tables
Use the label and table styles to control the appearance and behavior of alignment labels and tables in a
drawing.
When you create alignments, they are labeled automatically with the labels specified in the Alignment Labels
dialog box. The labels are applied along the alignment at specific points, for example, the major and minor
stations.
With the Add Labels command, you specify the following parameters as you label the alignment:
■

Label type, such as station offset, segment, and tangent intersection

■

Label and marker styles

■

Points along the alignment

You can also use commands to insert alignment tables into a drawing. Alignment tables organize and
consolidate the information about the alignment. When you insert a table into the drawing, full labels are
converted to tags, and the detailed alignment information is inserted into the table.
The topics in this section describe what is unique to alignment labels and tables. For a general overview of
labels, see Labels and Tags (page 1643). For an overview of tables, see Tables (page 1737).
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Station geometry text
always reads opposite the
alignment direction in this
example. This can be
controlled in the geometry
point label styles.

Alignment labels

Alignment Label Styles
Manage alignment label styles by specifying which label styles to use when you create alignment label sets,
as well as which styles to use with the Add Alignment Labels command.
In Prospector, on the Settings tab, the Alignment collection contains the Label Styles collection. The Label
Styles collection contains sub-folders for labels sets, individual types of alignment labels, and alignment
table styles. You can right-click a specific type of alignment label, such as for major stations and minor
stations, and either edit the default label settings or create a label style.
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The types of alignment label styles that you can create and use:
Use this type of alignment
label style...

To label...

Major Station

Stations at major intervals, which use the default
format of sta = <station> <units>. For example, sta =
1000 ft.

Minor Station

Stations at intervals that divide the major stations. To
add minor station labels, you must have major station
labels.

Geometry Point

Locations at which alignment geometry changes,
which use the default format of <Geometry point>:
<station>. For example, CS: 3+27+65.

Profile Geometry Point

Locations of profile points on the alignment geometry.

Station Equation

Points added on the Station Control tab of the Alignment Properties dialog box.

Design Speeds

Points added on the Design Speeds tab of the Alignment Properties dialog box.

Superelevation Critical Points

Stations at which the superelevation cross slope
changes.

Station Offset

A point either on or adjacent to an alignment that lists
station and offset information from the alignment to
the point picked.

Line

Properties of a line entity within an alignment object.

Curve

Properties of a curve entity within an alignment object.

Spiral

Properties of a spiral entity within an alignment object.

Tangent Intersection

Properties of a tangent-tangent intersection (PI) and
either the associated free curve or free Spiral-CurveSpiral (SCS) group. This label type can also be applied
to either individual curve or spiral entities (even within
an SCS group).

Labeling Alignment Stations
Station labels display reference information about specific points along the length of an alignment.
AutoCAD Civil 3D supports the following alignment station label types:
■

Major Stations

■

Minor Stations

■

Geometry Points

■

Profile Geometry Points

1044 | Chapter 24 Alignments

■

Station Equations

■

Design Speeds

■

Superelevation Critical Points

When you create an alignment, you select a label set, which is a predefined collection of label types with
associated styles. You can modify the station labels in an existing alignment, and then optionally save the
changes as a label set.

Using Alignment Label Sets
One step in creating an alignment is selecting the Alignment Label Set.

Using Label Sets
Use the Alignment Labels dialog box to assign styles to the individual elements that you want to label on
the alignment. Then save the group of labels as a label set.
For example, you can create a label set that only includes major and minor station types, and another label
set that includes major and minor stations, and also geometry points, station equations, and design speeds.
You can determine the style, start station, and end station for each type of individual label in the label set.
A label set can contain multiple instances of a label type. You can assign different label styles to the individual
geometry points in the Geometry Points, Profile Geometry Points, and Superelevation Critical Points label
types. For example, you can create a label set that contains multiple occurrences of the Geometry Points
label type. One occurrence can label the Alignment Beginning and Alignment End points using a style. A
second occurrence of the Geometry Points label type can label the Tangent-Tangent Intersect and
Tangent-Curve Intersect points using a different style.
After you save a label set, you can reuse it by importing it to the alignment.
Label sets include the following label types:
■

Major Stations

■

Minor Stations

■

Geometry Points

■

Profile Geometry Points

■

Station Equations

■

Design Speeds

■

Superelevation Critical Points

For more information about modifying labels, see Modifying Labels in a Drawing (page 1712). For more
information about which properties of different label types can be modified, see Managing Layout Properties
for Label Styles (page 1671).
NOTE To change the label type defaults, right-click the <Label Type> collection on the Settings tree in Toolspace
and select Edit Label Style Defaults. For more information, see Default Settings for All Labels in a Label Type (page
1655).
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To add labels to a label set
1 Click Annotate tab ➤ Labels & Tables panel ➤ Add Labels menu ➤ Alignment ➤ Add/Edit Station Labels
.
2 Select an alignment in the drawing to open the Alignment Labels dialog box.
3 In the Type list, select the type of label that you want to add.
NOTE To add minor station labels, you must have at least one major station label type added to the label
set.
4 In the Style list, select a style for the label type.
5 Click Add.
TIP To delete a label, select the label type and click. You cannot delete a major station if it has a minor station.
6 If you select either the Geometry Points, Profile Geometry Points, or Superelevation Critical Points label
type, select the specific points to label.
7 In the Style column, either click the icon to change the style or accept the label style selection.
8 In the Increment column, either enter a value to determine the increment distance between major
station labels, or accept the default.
9 In the Start Station column, either clear the check box and enter a new starting station value or accept
the default.
10 In the End Station column, either clear the check box and enter a new end station value or accept the
default.
NOTE The default start and end stations for each label type are the beginning and end of the alignment. To
change either the start station or end station, clear the check box, and enter new start station and end station
values.

11 In the Geometry Points To Label column, click

to update the points to label.

NOTE The Geometry Points To Label column is only available for the Geometry Points, Profile Geometry
Points, and Superelevation Critical Points label types.
12 Repeat Steps 2 through 10 to add more label types to the label set.

Saving Alignment Label Sets
Create and save any number of alignment label sets to use during different phases in a project.
Copy and edit label sets from the Label Style collection in Toolspace on the Settings tab.
To save a label set
1 Click Annotate tab ➤ Labels & Tables panel ➤ Add Labels menu ➤ Alignment ➤ Add/Edit Station Labels
.
2 Select an alignment in the drawing to open the Alignment Labels dialog box.
3 In the Alignment Labels dialog box, determine the label types you want to save in the label set.
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4 Click Save Label Set. The Alignment Label Set dialog box is displayed.
5 On the Information tab (page 2206), enter a name and optional description for the label set.
6 Optionally, on the Labels tab (page 2207), change values.

Importing Label Sets
Create and save any number of alignment label sets. Import the labels sets during different phases in a
project.
To import a label set
1 Click Annotate tab ➤ Labels & Tables panel ➤ Add Labels menu ➤ Alignment ➤ Add/Edit Station Labels
.
2 Select an alignment in the drawing to open the Alignment Labels dialog box.
3 In the Alignment Labels dialog box, click Import Label Set.
4 In the Select Style Set dialog box, either select an existing label set or copy, edit, or create a label set.

Editing Alignment Station Labels
After an alignment has been created, you can change the type and style of the station labels.
If you label an alignment created through an xref, the labels you add exist in the current drawing. If you
detach the xref, labels created in the current drawing will be lost.
You can save a collection of alignment station label types and styles as a label set, which can be applied to
other alignments.
To edit alignment station labels
1 Click Annotate tab ➤ Labels & Tables panel ➤ Add Labels menu ➤ Alignment ➤ Add/Edit Station Labels
.
2 Select an alignment in the drawing to open the Alignment Labels dialog box.
3 In the Alignment Labels dialog box, do any of the following procedures, and then click OK.
To add a station label type to the alignment
1 In the Type list, select the type of label that you want to add.
NOTE To add minor station labels, you must have at least one major station label type added to the label
set.
2 In the Style list, select a style for the label type.
3 Click Add.
4 If you select either the Geometry Points, Profile Geometry Points, or Superelevation Critical Points label
type, select the specific points to label.
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To delete a station label type from the alignment
To delete a label, select the label type and click
station.

. You cannot delete a major station if it has a minor

To change the parameters of an existing station label type
1 In the Style column, either click the icon to change the style or accept the label style selection.
2 In the Increment column, either enter a value to determine the increment distance between major
station labels, or accept the default.
3 In the Start Station column, either clear the check box and enter a new starting station value or accept
the default.
4 In the End Station column, either clear the check box and enter a new end station value or accept the
default.
NOTE The default start and end stations for each label type are the beginning and end of the alignment. To
change either the start station or end station, clear the check box, and enter new start station and end station
values.

5 In the Geometry Points To Label column, click

to update the points to label.

NOTE The Geometry Points To Label column is only available for the Geometry Points, Profile Geometry
Points, and Superelevation Critical Points label types.

Quick Reference
Ribbon
Click Annotate tab ➤ Labels & Tables panel ➤ Add Labels menu ➤ Alignment ➤ Add/Edit Station Labels

Menu
Click Alignments menu ➤ Add Alignment Labels ➤ Add/Edit Station Labels.
Command Line
EditAlignmentLabels
Dialog Box
Alignment Labels Dialog Box (page 1952)
Alignment Geometry Points Dialog Box (page 1951)
Profile Geometry Points Dialog Box (page 1992)
Superelevation Critical Points Dialog Box (page 1993)

Labeling Geometry Points
Use different styles to label specific alignment, profile, or superelevation critical geometry points along an
alignment.
You can apply separate label styles to specific points in the geometry point label types. You can determine
which points to label, and then apply different styles to each point type.
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For example, you can create a label set that contains multiple occurrences of the Geometry Points label type.
One occurrence can label the Alignment Beginning and Alignment End points using a style. A second
occurrence of the Geometry Points label type can label the Tangent-Tangent Intersect and Tangent-Curve
Intersect points using a different style.
Geometry point label types include:
■

Geometry Points

■

Profile Geometry Points

■

Superelevation Critical Points
NOTE Superelevation critical labels are not dynamically linked to the parent alignment. If the alignment
geometry changes, the superelevation critical labels must be updated manually.
TIP Superelevation critical point labels can also display a diagram that represents the cross section at each
superelevation transition point. For more information, see Adding Superelevation Cross-Section Diagrams
Along an Alignment (page 1050).

To add geometry point labels
1 Click Annotate tab ➤ Labels & Tables panel ➤ Add Labels menu ➤ Alignment ➤ Add/Edit Station Labels
.
2 Select an alignment in the drawing to open the Alignment Labels dialog box.
3 In the Alignment Labels Dialog Box (page 1952) dialog box, in the Type list, select the type of geometry
point label that you want to add.
Select either Geometry Points, Profile Geometry Points, or Superelevation Critical Points.
4 In the Style list, select a style for the label type.
This style is used by the geometry points you specify in Step 5.
5 Click Add.
6 In the <label type> Points dialog box, select the specific points to label.
NOTE If you selected Profile Geometry Points, you must specify a profile to reference in the Profile Geometry
Points Dialog Box (page 1992) dialog box.
7 In the Start Station column, either clear the check box and enter a new starting station value or accept
the default.
8 In the End Station column, either clear the check box and enter a new end station value or accept the
default.
NOTE The default start and end stations for each label type are the beginning and end of the alignment. To
change either the start station or end station, clear the check box, and enter new start station and end station
values.
9 Repeat Steps 1 through 7 to add more geometry point labels.
You can add multiple instances of each label type. Each instance can label different geometry points
and use a different label style and range of stations.
NOTE In the Geometry Points To Label column, click

to update the points to label.
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Quick Reference
Ribbon
Click Annotate tab ➤ Labels & Tables panel ➤ Add Labels menu ➤ Alignment ➤ Add/Edit Station Labels

Menu
Click Alignments menu ➤ Add Alignment Labels ➤ Add/Edit Station Labels
Command Line
EditAlignmentLabels
Dialog Box
Alignment Labels Dialog Box (page 1952)
Alignment Geometry Points Dialog Box (page 1951)
Profile Geometry Points Dialog Box (page 1992)
Superelevation Critical Points Dialog Box (page 1993)

Adding Superelevation Cross-Section Diagrams Along an Alignment
Add block diagrams that represent the cross section at each superelevation transition point.
To add superelevation cross-section diagrams, compose a separate label style for each of the Superelevation
Critical Points that you want to label. Use the Alignment Labels dialog box to add each of the point label
styles to the alignment. You can save the collection of superelevation critical point labels as a label set, which
you can apply to other alignments.
To add superelevation cross-section diagrams along an alignment
1 Compose a label style for each type of superelevation critical point that you want to label.
Each style must contain a block component that refers to an appropriate representation of the cross
section at that type of geometry point. Optionally, each style can include text, tick, and line components.
For information about composing a label style, see Creating New Label Styles (page 1656).
2 Click Annotate tab ➤ Labels & Tables panel ➤ Add Labels menu ➤ Alignment ➤ Add/Edit Station Labels
.
3 Select an alignment in the drawing to open the Alignment Labels dialog box.
4 In the Alignment Labels Dialog Box (page 1952), in the Type list, select Superelevation Critical Points.
5 In the Superelevation Label Style list, select a style for the superelevation critical geometry point.
6 Click Add.
7 In the Superelevation Critical Points Dialog Box (page 1993), click
Deselect All. Select the
superelevation critical points that correspond to the style you selected in Step 4. Click OK.
8 In the Start Station column, either clear the check box and enter a new starting station value, or accept
the default.
9 In the End Station column, either clear the check box and enter a new end station value, or accept the
default.
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NOTE The default start and end stations for each label type are the beginning and end of the alignment. To
change either the start station or end station, clear the check box, and enter new start station and end station
values.
10 Repeat Steps 3 through 8 to add the remaining superelevation critical points.
11 Add other alignment label types as desired.
12 Optionally, click Save Label Set to save the current label configuration as a label set.
For more information, see Saving Alignment Label Sets (page 1046).

Quick Reference
Ribbon
Click Annotate tab ➤ Labels & Tables panel ➤ Add Labels menu ➤ Alignment ➤ Add/Edit Station Labels

Menu
Click Alignments menu ➤ Add Alignment Labels ➤ Add/Edit Station Labels
Command Line
EditAlignmentLabels
Dialog Box
Alignment Labels Dialog Box (page 1952)
Superelevation Critical Points Dialog Box (page 1993)

Displaying Stations in Station Index Format
Use the Station Index Format to label a station value as a count that is relative to a distance.
This distance is referred to as a station index increment. Specify the station index increment in the Alignment
Labels dialog box. Format the station index label using the Label Style Composer Dialog Box (page 2180).
To display stations in station index format
1 In Toolspace, on the Settings tab, right-click a station label type. Click either Edit or New.
2 In the Label Style Composer, click the Layout tab.
3 Under Text, click

in the Contents Value column.

4 In the Text Component Editor, click the Format Value column. Select Station Index Format from the
list.
5 Specify other modifiers as necessary.
6 Click

to insert the property into the Text Component Editor window.

7 Click OK.

Changing the Station Character Display
Use the Station Character setting to change the display of the character in station labels.

Labeling Alignment Stations | 1051

The following station character formats are available:
■

10+50.00

■

10-50.00

■

10_50.00

■

1050.00

■

10/50.00

■

10C50.00

■

10K50.00

To change the display of the station character
1 In Toolspace, on the Settings tab, right-click a station label type. Click either Edit or New.
2 In the Label Style Composer, click the Layout tab.
3 Under Text, click

in the Contents Value column.

4 In the Text Component Editor, in the preview pane, select the station value property formula.
5 In the Properties list, select Station Value.
6 Click the Station Character Value column. Select the desired character from the list.
7 Specify other modifiers as necessary.
8 Click

to insert the property into the Text Component Editor window.

9 Click OK.

Adding Descriptive Geometry Point Text
Use the Abbreviations tab in the Drawing Settings dialog box to compose labels that include geometric
property information about the entities that come before and after geometry points.
See also:
■

Abbreviations Tab (Drawing Settings Dialog Box) (page 2077)

To add descriptive geometry point text
1 In Toolspace, on the Settings tab, right-click the drawing and click Edit Drawing Settings. Click the
Abbreviations Tab (Drawing Settings Dialog Box) (page 2077).
2 In the Alignment Geometry Point Entity Data section, select the entity endpoint type. Click
Value column to modify the label for that type.
3 In the Text Component Editor, select a property from the list and select modifiers as necessary.
4 Click

to insert the property into the Text Component Editor window.

5 Insert other properties and modifiers as necessary. Click OK.
6 Repeat Steps 2-5 to format other alignment endpoint entities listed on the Abbreviations tab.
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in the

7 In Toolspace, on the Settings tab, right-click a <geometry point label>. Click either Edit or New.
8 In the Label Style Composer, click the Layout tab.
9 Under Text, click

in the Contents Value column.

10 In the Properties list, select Geometry Point Entity Before Data. Click
11 In the Properties list, select Geometry Point Entity After Data. Click

.
.

12 Click OK.
The text you compose on the Abbreviations tab for the alignment endpoint entities is included in the labels
that display before and after the geometry point.

Labeling Alignment Line, Curve, and Spiral Entities
You can label components along an alignment by using specified label styles.
To place the label, specify the alignment and the component in the drawing, such as a line, curve, or spiral
segment. Select either a single segment or intersection or label the whole alignment using the multiple
options.
For more information about modifying labels, see Modifying Labels in a Drawing (page 1712). For more
information about modifying label properties, see Managing Layout Properties for Label Styles (page 1671).

Adding Labels to Single Segments in Alignments
Add single segment labels to the lines, curves, or spirals with Line, Curve, and Spiral label styles.
Labels are placed on each line (1), curve (2) or spiral entity that you select.

To label alignment line segments
1 Click Annotate tab ➤ Labels & Tables panel ➤ Add Labels menu ➤ Alignment ➤ Single Segment

.

2 Select a location on the alignment line or segment to label.
3 In the Label Type list, select Single Segment.
4 Specify label styles for Line, Curve, and Spiral.
5 Click Add. In the drawing, select the alignment.
6 In the drawing, select the segments you want to label.
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Quick Reference
Ribbon
Annotate tab ➤ Labels & Tables panel ➤ Add Labels menu ➤ Alignment ➤ Single Segment
Menu
Click Alignments menu ➤ Add Alignment Labels ➤ Single Segment
Command Line
AddAlignSegLbl

Adding Multiple Segment Labels to Alignments
Automatically label all lines, curves, and spirals in the alignment with Line, Curve, and Spiral label styles.
Labels are placed on each line, curve, and spiral entity in the selected alignment.

To label multiple alignment line segments
1 Click Annotate tab ➤ Labels & Tables panel ➤ Add Labels menu ➤ Alignment ➤ Add Alignment Labels
.
2 In the Add Labels dialog box, verify that Alignments is displayed in the Feature list.
3 In the Label Type list, select Multiple Segment.
4 Specify label styles for Line, Curve, and Spiral.
5 Click Add. In the drawing, select the alignment.
Labels are displayed on all lines, curves, and spirals in the alignment.

Quick Reference
Ribbon
Click Annotate tab ➤ Labels & Tables panel ➤ Add Labels menu ➤ Alignment ➤ Add Alignment Labels

Menu
Click Alignments menu ➤ Add Alignment Labels ➤ Add Alignment Labels
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Command Line
AddAlignLabels

Labeling Station Offset and Tangent Intersection Points in Alignments
You can label a station offset or a tangent intersection with specified offset and marker label styles.
You can label individual tangent-intersection points or use the multiple tangent intersection command and
label all points. The multiple tangent intersection command labels the PI points of all intersecting tangents,
along with the PI point for any curves, or spiral-curve-spiral groups.
NOTE You cannot label fixed spirals with the multiple tangent intersection label command.

Adding Station Offset Labels - Relative Point
Add station offset labels at selected points along the alignment. You must also specify a style for the point
marker.
For the selected alignment (1), you specify the desired station (2) and offset distance (3). If the alignment is
moved, the label moves with it and maintains the relative station and offset location.

NOTE If you move the alignment, labels that you add using the station offset labels command move with the
associated point.
To add station offset labels for relative points
1 Click Annotate tab ➤ Labels & Tables panel ➤ Add Labels menu ➤ Alignment ➤ Station/Offset

.

2 Select the station and offset distance to label.

Quick Reference
Ribbon
Click Annotate tab ➤ Labels & Tables panel ➤ Add Labels menu ➤ Alignment ➤ Station/Offset
Menu
Click Alignments menu ➤ Add Alignment Labels ➤ Station/Offset
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Command Line
AddAlignOffLbl

Adding Station Offset Labels - Fixed Point
Add station offset labels at fixed points in the drawing. Because the Station Offset label uses a point marker
to locate the station offset point, you must also specify a Marker Style.
For the selected alignment (1), you specify the XY location of the desired point (2). If the alignment is moved,
the point’s X-Y location is maintained, but the labels update to show new station and offset distances.

NOTE If you edit the alignment, labels that you add using the Station/Offset - Fixed Point command do not move.
To add station offset labels at a fixed point
1 Click Annotate tab ➤ Labels & Tables panel ➤ Add Labels menu ➤ Alignment ➤ Station/Offset – Fixed
.
2 Select the point location to label.

Quick Reference
Ribbon
Click Annotate tab ➤ Labels & Tables panel ➤ Add Labels menu ➤ Alignment ➤ Station/Offset – Fixed
Menu
Click Alignments menu ➤ Add Alignment Labels ➤ Station/Offset - Fixed Point
Command Line
AddAlignOffXYLbl

Adding Tangent Intersection Labels
Add tangent intersection labels to selected intersections on the alignment.
You can label the intersection point, or label the properties of a curve or a spiral-curve-spiral group at the
tangent intersection.
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NOTE Complex free curve groups (compound SCSCS and reverse SCSSCS) do not support tangent intersection
labels. For more information on complex curve groups, see Adding Complex Free Curve Groups Between Tangents
(page 1040).
To add tangent intersection labels
1 Click Annotate tab ➤ Labels & Tables panel ➤ Add Labels menu ➤ Alignment ➤ Tangent Intersection
.
2 Select the tangent intersection to label.

Quick Reference
Ribbon
Click Annotate tab ➤ Labels & Tables panel ➤ Add Labels menu ➤ Alignment ➤ Tangent Intersection
Menu
Click Alignments menu ➤ Add Alignment Labels ➤ Tangent Intersection
Command Line
AddAlignTangentIntLbl

Adding Multiple Tangent Intersection Labels
Add multiple tangent intersection labels at every point of intersection (PI) on the alignment, including the
actual point of intersection of two tangents, as well as the virtual locations of the PI for curves and
spiral-curve-spiral groups.
Labels are placed at all tangent intersection points for the selected alignment.
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NOTE Complex free curve groups (compound SCSCS and reverse SCSSCS) do not support PI labels. For more
information on complex curve groups, see Adding Complex Free Curve Groups Between Tangents (page 1040).
To add multiple tangent intersection labels
1 Click Annotate tab ➤ Labels & Tables panel ➤ Add Labels menu ➤ Alignment ➤ Multiple Tangent
Intersection

.

2 Select the tangent intersections to label.

Quick Reference
Ribbon
Click Annotate tab ➤ Labels & Tables panel ➤ Add Labels menu ➤ Alignment ➤ Multiple Tangent
Intersection
Menu
Click Alignments menu ➤ Add Alignment Labels ➤ Multiple Tangent Intersection
Command Line
AddAlignTangentIntLbls

Alignment Table Styles
Manage alignment table styles, which define the type of information that is placed in the alignment table
on the Settings tab.
The types of alignment table styles that you can create and use:
This Alignment table style...

Places the following alignment information
in the table...

Line

Geometric information for points on any solved line
portion of the alignment

Curve

Geometric information for points on any solved
curve portion of the alignment

Spiral

Geometric information for points on any solved
spiral portion of the alignment
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This Alignment table style...

Places the following alignment information
in the table...

Segment

Combines geometric information for lines, curves,
and spirals into one table

Adding Alignment Tables
Create alignment tables that contain information about the alignment components, such as lines, curves,
spirals, and segments.
Alignment segments must be labeled before you add a table to the drawing. When you add the table, the
labels are converted to tags.
Use alignment tables to present alignment data in a concise format and to reduce the labels to compact tags
that reference the table rows.
You create and edit tables for most objects using the same common procedures and standard dialog boxes.
The procedures in this topic explain how to access the alignment table creation commands, and provide
links to reference information about the Table Creation dialog box. For information about modifying tables,
see Modifying Tables (page 1750).
To create a line table
1 Click Annotate tab ➤ Labels & Tables panel ➤ Add Tables menu ➤ Alignment ➤ Add Line

.

2 In the Table Creation (page 2739) dialog box, select a Table Style and a Table Layer.
3 Specify the label styles or select labels in the drawing to create a tag child style for the labels.
4 Select the Apply check box.
5 Select the Split Table check box and enter values.
6 Under Behavior, select either Static or Dynamic.
7 Click the upper left corner in the drawing where you want the table to display.
To create a curve table
1 Click Annotate tab ➤ Labels & Tables panel ➤ Add Tables menu ➤ Alignment ➤ Add Curve

.

2 In the Table Creation (page 2739) dialog box, select a Table Style and a Table Layer.
3 Specify the label styles or select labels in the drawing to create a tag child style for the labels.
4 Select the Apply check box.
5 Select the Split Table check box and enter values.
6 Under Behavior, select either Static or Dynamic.
7 Click the upper left corner in the drawing where you want the table to display.
To create a spiral table
1 Click Annotate tab ➤ Labels & Tables panel ➤ Add Tables menu ➤ Alignment ➤ Add Spiral.
2 In the Table Creation (page 2739) dialog box, select a Table Style and a Table Layer.
3 Specify the label styles or select labels in the drawing to create a tag child style for the labels.
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4 Select the Apply check box.
5 Select the Split Table check box and enter values.
6 Under Behavior, select either Static or Dynamic.
7 Click the upper left corner in the drawing where you want the table to display.
To create a segment table
1 Click Annotate tab ➤ Labels & Tables panel ➤ Add Tables menu ➤ Alignment ➤ Add Segment

.

2 In the Table Creation (page 2739) dialog box, select a Table Style and a Table Layer.
3 Specify the label styles or select labels in the drawing to create a tag child style for the labels.
4 Select the Apply check box.
5 Select the Split Table check box and enter values.
6 Under Behavior, select either Static or Dynamic.
7 Click the upper left corner in the drawing where you want the table to display.

Quick Reference
Ribbon
Click Annotate tab ➤ Labels & Tables panel ➤ Add Tables menu ➤ Alignment ➤ Add Line
Click Annotate tab ➤ Labels & Tables panel ➤ Add Tables menu ➤ Alignment ➤ Add Curve
Click Annotate tab ➤ Labels & Tables panel ➤ Add Tables menu ➤ Alignment ➤ Add Spiral
Click Annotate tab ➤ Labels & Tables panel ➤ Add Tables menu ➤ Alignment ➤ Add Segment
Menu
Click Alignments menu ➤ Add Tables ➤ Add Line
Click Alignments menu ➤ Add Tables ➤ Add Curve
Click Alignments menu ➤ Add Tables ➤ Add Spiral
Click Alignments menu ➤ Add Tables ➤ Add Segments
Command Line
AddAlignmentLineTable
AddAlignmentCurveTable
AddAlignmentSpiralTable
AddAlignmentSegmentTable
Dialog Box
Table Creation Dialog Box (page 2739)

Editing Alignments
Edit an alignment by modifying the geometry or parameter values.
You can grip edit an alignment, modify geometric values, or add constraint-based line, curve, and spiral
entities.
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You use the Alignment Layout Tools toolbar, Alignment Layout Parameters dialog box, and Alignment
Entities vista to edit an alignment. These dialog boxes remain open if you either grip edit or deselect the
alignment, or enter another command.
If you select an alignment for editing and then select a second alignment, the second alignment becomes
the active alignment. The most recently selected alignment has the focus of the Alignment Layout Tools
toolbar and the Alignment Entities vista. The last object selected becomes the current object and has focus
of the alignment editing tools.
See also:
■

Alignment Properties (page 932)

Selecting Alignment Entities
Select an entire alignment, a single sub-entity, or a range of sub-entities.
When a single sub-entity is selected, the Alignment Layout Parameters dialog box displays the parameters
of the selected entity.
After you have selected an alignment entity (sub-entity), you can edit it using various tools.
If the Alignment Entities (page 1947) vista and Alignment Layout Tools (page 1959) toolbar is open, selecting a
sub-entity or range of sub-entities in an alignment causes the selected sub-entities to display in the Alignment
Entities vista. Selecting sub-entities or ranges of sub-entities in a different alignment causes that range of
selected sub-entities to display in the Alignment Entities vista and have focus of the Alignment Layout Tools
toolbar. The last object selected becomes the current object and has focus of the alignment editing tools.
To select an entire alignment
1 Click an alignment in the drawing.
Grips appear along the alignment.
2 Use the desired tools to edit the alignment:
To Edit the alignment...

see this topic:

by adding constraint-based sub-entities

Editing Alignment Points of Intersection
(page 1064)

Selecting Alignment Entities | 1061

To Edit the alignment...

see this topic:

by entering precise attribute values

Editing Alignment Entity Layout Parameters
(page 1066)

using grips

Editing Alignments Using Grips (page 1068)

To select a single alignment sub-entity
1 Ctrl+click an alignment sub-entity in the drawing.
2 Edit the alignment sub-entity by either manipulating the grips (page 1068) or entering specific attribute
values (page 1066).
NOTE The Alignment Entities Vista (page 1947) displays only the selected sub-entity attributes.
To select a range of alignment sub-entities
1 In the drawing window, Ctrl+click the first alignment sub-entity in the desired range.
2 Ctrl+click the last alignment sub-entity in the range.
3 Right-click one of the selected sub-entities and select Edit Alignment Geometry.
4 Click

Alignment Grid View on the Alignment Layout toolbar (page 1959).

5 Edit the alignment sub-entities by either manipulating the grips (page 1068) or entering specific attribute
values (page 1066)
NOTE The Alignment Entities vista displays only the attributes of the sub-entities in the range.

Quick Reference
Ribbon
Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
Menu
Alignments menu ➤ Edit Alignment Geometry
Command Line
EditAlignment
Dialog Box
Alignment Layout Tools (page 1959)
Alignment Entities Vista (page 1947)
Alignment Layout Parameters Window (page 1953)

Converting an AutoCAD Line or Arc to an Alignment Sub-Entity
Create a fixed two-point line or three-point curve alignment entity from an AutoCAD line or arc.
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The new sub-entity becomes part of the solved alignment geometry if either of the following two conditions
are met:
■

Before it is converted, it must be attached to an unattached end point of another solved entity in the
alignment.

■

After it has been converted, it can be joined to the solved alignment geometry using the alignment layout
tools.

This command is useful when you must add an AutoCAD line or arc onto an existing alignment. AutoCAD
lines and arcs can be created using the best fit entities or other lines and curves commands. See Lines and
Curves (page 605) for more information.
To convert an AutoCAD line or arc to an alignment sub-entity
1 Create an alignment or find an existing one.
2 Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
3 On the Alignment Layout Tools toolbar, click

.

Convert AutoCAD Line And Arc.

4 Select the AutoCAD entity.
5 If necessary, reverse the direction of the alignment sub-entity. See Reversing Alignment Sub-Entity
Direction (page 1084) for more information.
NOTE If the sub-entity you converted is hidden behind the source AutoCAD entity, use Shift+spacebar to select
it. Hover the cursor over the white AutoCAD entity. Press and hold Shift, then press the spacebar to highlight the
alignment sub-entity. Click to select the alignment sub-entity, then release the Shift key. Click the alignment
sub-entity again to select it and continue with the command.

Quick Reference
Ribbon
Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
Menu
Alignments menu ➤ Edit Alignment Geometry
Command Line
EditAlignment
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Alignment Layout Tools Toolbar icon
Convert AutoCAD Line And Arc

Editing Alignment Points of Intersection
Edit an alignment geometry by working with the points of intersection (PI).
You can access the PI commands on the Alignment Layout Tools (page 1959) toolbar.

Adding a Point of Intersection to an Alignment
Break a fixed line into two adjacent fixed lines by creating a point of intersection (PI) at a specified point.
When you select a point (1), the new PI (2) is created. At the new PI, endpoints are created for the new lines,
which maintain tangency to one another.

To add a PI to an alignment
1 Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
2 On the Alignment Layout Tools toolbar, click

Insert PI.

3 In the drawing window, click the location for the new PI.

Quick Reference
Ribbon
Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
Menu
Alignments menu ➤ Edit Alignment Geometry
Command Line
EditAlignment
Alignment Layout Tools Toolbar icon
Insert PI
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.

Deleting a Point of Intersection from an Alignment
Create a single tangent from two adjacent tangents by removing their point of intersection (PI).
When the PI (1) is deleted (2), the tangent endpoints are removed.

To delete a PI from an alignment
1 Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
2 On the Alignment Layout Tools toolbar, click

.

Delete PI.

3 In the drawing window, click a point near the PI that you want to remove.

Quick Reference
Ribbon
Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
Menu
Alignments menu ➤ Edit Alignment Geometry
Command Line
EditAlignment
Alignment Layout Tools Toolbar icon
Delete PI

Breaking Apart an Alignment Point of Intersection
Separate the point of intersection (PI) where the endpoints of two fixed or floating tangents meet.
When you break a PI (1), the tangent endpoints are separated by a specified distance (2). When a PI is broken
(3), the second tangent is no longer part of the solved alignment geometry.
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To break apart an alignment PI
1 Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
2 On the Alignment Layout Tools toolbar, click

.

Break-Apart PI.

3 In the drawing window, click a point near the PI that you want to break apart.
4 Specify the distance that you want to break apart the PI.

Quick Reference
Ribbon
Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
Menu
Alignments menu ➤ Edit Alignment Geometry
Command Line
EditAlignment
Alignment Layout Tools Toolbar icon
Break-Apart PI

Editing Alignment Entity Layout Parameters
Use the Alignment Entities vista and Alignment Layout Parameters dialog box to display and edit parameters
of alignment entities that are part of the solved alignment geometry.
The Alignment Entities vista displays a form that is like a spread sheet, where each row represents an alignment
entity and each column represents a parameter. You can right-click a column heading to display options
for customizing the display of detail in the column views.
You can use the alignment grid view, which is also known as the Alignment Entities vista, to quickly scroll
through all the sub-entities that make up the alignment. You can select a sub-entity in the Alignment Entities
vista, and then edit it in the Alignment Layout Parameters dialog box. Attributes in the Alignment Entities
vista and Alignment Layout Parameters window are automatically updated as the alignment is edited.
You can use the Alignment Layout Parameters dialog box to display and edit the many attributes for a single
alignment sub-entity. The parameters that are displayed are dependent upon the constraints you used to
create the entity.

1066 | Chapter 24 Alignments

The Alignment Layout Parameters dialog box contains up to three panels. The Layout Parameters panel,
which displays the geometric parameters of the selected sub-entity, is always present. In this panel, the Value
column lists the actual value of each sub-entity Parameter. If the alignment was created using the criteria-based
design (page 2771) feature, the Constraint column lists the value to which a Parameter is constrained by the
specified design criteria. Use the Value and Constraint columns together to view whether the sub-entity
parameters meet the specified design criteria. If the alignment was not created using the criteria-based design
feature, the Constraint column is not available.
Two additional panels may be present on the Alignment Layout Parameters dialog box if the alignment has
design criteria applied to it. If the alignment has a design criteria file (page 2773) associated with it, the criteria
from the file are displayed in the Design Criteria panel. If the alignment has a design check set (page 2772)
associated with it, the name and contents of the design check set are displayed in the Design Checks panel.
If any of the parameters violate either a design check or the standards specified in the design criteria file, a
warning symbol appears next to the violation. For more information, see Viewing and Correcting
Alignment Design Criteria Violations (page 1080).
NOTE The attributes of a curve or other alignment entity that you can edit depends on the method you used to
create the entity. Generally speaking, you can edit the numeric value of a parameter if the parameter was used to
define the entity. For all other parameters, numeric values are calculated and displayed but cannot be edited.
See also:
■

Editing Best Fit Alignment Entities (page 1075)

To edit alignment layout parameters using the Alignment Entities vista and Alignment Layout Parameters
dialog box
1 Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
2 On the Alignment Layout Tools toolbar, click

.

Alignment Grid View.

The Alignment Entities Vista (page 1947) displays the attributes of only the selected alignment entities.
If you select another entity using Ctrl+click, it is added to the list.
3 On the Alignment Layout Tools toolbar, click

Sub-Entity Editor.

The Alignment Layout Parameters Window (page 1953) displays detailed attributes of a single alignment
entity that is highlighted on the Alignment Entities vista. Selecting another entity in the Alignment
Entities vista causes the new entity’s attributes to display in the Alignment Layout Parameters dialog
box.
NOTE You can edit only values that are available. You cannot edit unavailable (shaded) text in either the
Alignment Entities vista or Alignment Layout Parameters dialog box.

Quick Reference
Ribbon
Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
Menu
Alignments menu ➤ Edit Alignment Geometry
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Command Line
EditAlignment
Alignment Layout Tools Toolbar Icons
Alignment Grid View
Sub-Entity Editor
Dialog Box
Alignment Entities Vista (page 1947)
Alignment Layout Parameters Window (page 1953)

Editing Alignments Using Grips
Use grips to change the vertical curves and tangents in an alignment graphically.
Use editing grips to relocate or modify curves and tangents using visual design cues. If you created alignment
entities using the constraint-based tools, some editing grips are not available.
Grips are oriented in the direction of the WCS (World Coordinate System) in which the object currently is
displayed. The exception is constrained grips, which indicate a particular constraint direction.
Use this grip...

AT END OF LINE OR
CURVE

To do this...
Move an unconstrained pass-through point on a line or curve.
On a line, moving this grip affects the length and angle of the
line. On a curve, moving this grip does not affect the radius of
the curve to which it belongs, but it can affect the radius of another attached entity.
Move an entire line. Moving this grip only affects the line location.

AT CENTER OF LINE

AT END OF LINE OR
CURVE

Change the constrained length of a line or curve. This grip appears on lines and curves that have a directly editable length and
is aligned with the vector at the end of the line or curve. Moving
this grip does not affect the radius of a curve or angle of a line.
Change the center point of a circle. Moving a center point
changes only the center point.

AT CURVE CENTER
POINT
Change the pass-through point and radius of a curve or circle.
Moving a pass-through point affects the radius of the curve.
AT PASS-THROUGH
POINT

AT POINT OF INTERSECTION

Change where two tangent points meet. This grip is oriented up
with the top pointing toward the Y axis of the world coordinate
system.
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Use this grip...

To do this...

AT PASS-THROUGH
POINT

Change the radius or through point of the curve. The triangle
grip appears on curves that have a directly editable radius and
is oriented in and constrained to the direction of the change.
The circle grip changes the pass-through point and radius of the
curve.

When a grip is selected, you can use either dynamic input or the Alignment Entities (page 1947) vista and
Alignment Layout Parameters (page 1953) dialog box to enter precise attribute values for the grip.
To use grips to edit a fixed line
1 In the drawing, click an alignment containing a fixed line.
Grips for a fixed line with two pass-through points:

2 Use the grips to edit the line:
■

Use the end grips to adjust the line length and pass-through point.

■

Use the center grip to move the location of the line.

To use grips to edit a fixed curve with three pass-through points
1 In the drawing, click an alignment containing a fixed curve through three points.
Grips for a fixed curve with three pass-through points:

2 Move any grip to change a pass-through point, which changes the radius of the curve.
To use grips to edit a fixed curve with a center point and radius
1 In the drawing, click an alignment that contains a fixed curve with a center point and radius.
Grips on a fixed curve with a center point and radius:
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2 Use the grips to edit the curve:
■

Move a triangular grip to change the radius.

■

Move the center grip to change the center point of the circle.

■

Move a circular grip on the circle to change a pass-through point.

To use grips to edit a fixed curve with a center point and a pass-through point
1 In the drawing, click an alignment that contains a fixed curve with a center point and a pass-through
point.
Grips for a fixed curve with a center point and a pass-through point:

2 Use the grips to edit the curve:
■

Move the center grip to change the center point of the circle.

■

Move the grip on the circle to change the pass-through point.

To use grips to edit fixed or floating intersecting lines
1 In the drawing, click an alignment that contains either a fixed or a floating line.
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PI (point of intersection) grip where the endpoints of a fixed or floating line meet:

2 Move the PI grip in any direction to edit the shared endpoints of the two lines.
To use grips to edit a floating line with a pass-through point
1 In the drawing, click an alignment that contains a floating line with a pass-through point.
Grip for a floating line with a pass-through point:

2 Move the square grip to edit the endpoint of the line.
To use grips to edit a floating line attached to an entity end
1 In the drawing, click an alignment that contains a floating line attached to an entity.
Grips for a floating line attached to an entity:

2 Move the triangular grip to change the length of the line.
NOTE You cannot move the triangular grip to the beginning of the line grip. Zero length lines are not
permitted.

To use grips to edit a floating curve with a pass-through point and radius
1 In the drawing, click an alignment that has a floating curve with a pass-through point and radius.
Grips for a floating curve with a pass-through point:
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2 Use the grips to edit the curve.
■

Moving the first circular grip, located at the PC/PT point of the curve, relocates the point of tangency
(PT). Use this grip to create a compound or reverse curve with another curve attached to the same
entity.
Changing a curve using the PC/PT grip:

■

Moving the second circular grip, located at the mid-point of the curve, modifies the radius while
changing the pass-through point.
Changing a curve using the midpoint grip:

■

Moving the square grip at the end of the curve changes the pass-through point of the curve while
holding the curve radius.
Changing a curve using the end grip:
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■

Moving the triangular grip changes the radius while holding the pass-through point.
Changing a curve using the radius grip:

To use grips to edit a floating curve attached to an entity end with a pass-through point
1 In the drawing, click an alignment that contains a floating curve attached to an entity end with a
pass-through point.
Grips for a floating curve attached to an entity end with a pass-through point:

2 Move the circular grip to change the pass-through point at the end of the curve. Moving the pass-through
point also changes the radius.
To use grips to edit a free curve by radius
1 In the drawing, click an alignment that has a free curve. Move any grip to modify the curve radius.
Grips for changing the curve radius:
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2 Use the grips to edit the curve:
■

Move the circular grips along tangent entities to adjacent PC/PT points on the opposite end of the
same tangent to create reverse or compound solutions.
Endpoint grips for dragging the beginning or end of the curve along the attachment entity:

■

Move the circular, mid-point grip to modify the pass-through point and radius for the curve. Move
the triangular grip to modify the radius for the curve while holding the pass-through point. By
moving either of these grips, you can create a curve of less than or greater than 180 degrees.
Changing the radius to less than 180 degrees:

Changing the radius to greater than 180 degrees using the circular pass-through point grip:

Changing the radius to greater than 180 degrees using the triangular radius grip:
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To use grips to edit a free curve with a pass-through point
1 In the drawing, click an alignment with a free curve and a pass-through point.
Grips for a free curve with a pass-through point:

2 Move the circular grip to change the pass-through point of the curve. This pass-through point is
maintained when you edit the attached entities.

Editing Best Fit Alignment Entities
Modify the regression data for alignment entities that were created by best fit.
The regression data can be modified, and then applied to the entity. If the entity is grip edited, it can be
re-synchronized with the original regression data.
The Regression Data vista displays the source regression data from which the best fit entity was created. The
regression data can be modified either before or after the entity has been created. The information in the
Regression Data vista can be changed, and then applied to the entity. If the entity parameters are changed
outside the Regression Data vista, the entity can be synchronized to the current regression data.
The Alignment Entities vista displays a form that is like a spread sheet, where each row represents an alignment
entity and each column represents a parameter. When an entity is created by best fit, Best Fit is displayed
in the Constraint2 column. Click

in this column to edit the source regression data.

Regression data is not dynamically linked to the best fit entity. If the entity is edited,
the Regression Data and Alignment Entities vistas.

appears in both

NOTE You can edit only values that are available, you cannot edit unavailable (shaded) text.
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Editing Floating Best Fit Entities
The manner in which a best fit floating entity reacts to edits to the attachment entity depends on whether
the best fit entity is synchronized with the best fit sample data:
■

If the floating best fit entity is synchronized with the best fit sample data, it will maintain tangency when
the attachment entity is edited. The floating best fit entity geometry will change to adapt to changes to
the attachment entity, and continue to honor the regression points.

■

If the floating best fit entity is not synchronized with the best fit sample data, it will behave as a normal
floating entity. The floating best fit entity will remain tangent to the attachment entity, and its geometry
will not change to honor the regression points.

To edit best fit regression data
1 Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
2 On the Alignment Layout Tools toolbar, click

.

Edit Best Fit Data For All Entities.

NOTE You can also open the Regression Data vista from the Alignment Entities vista. In the Constraint2
column, click

.

3 In the Regression Data vista, edit the regression data as needed.
You can add, edit, or remove regression points.
4 Click

to apply the changes and close the Regression Data vista.

To synchronize a best fit alignment entity to the regression data
1 Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
2 On the Alignment Layout Tools toolbar, click
3 In the Regression Data vista, click

.

Edit Best Fit Data For All Entities.

Synchronize Entity To Best Fit Sample Data.

NOTE You can also synchronize the entity to the regression data from the Alignment Entities vista. In the
Constraint2 column, click

.

Quick Reference
Ribbon
Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
Menu
Alignments menu ➤ Edit Alignment Geometry
Command Line
EditAlignment
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Alignment Layout Tools Toolbar Icon
Edit Best Fit Data For All Entities
Regression Data Vista Icon
Synchronize Entity To Best Fit Sample Data
Alignment Entities Vista Icon

Dialog Box
Regression Data Vista (for Best Fit Entity Analysis) (page 2226)
Alignment Entities Vista (page 1947)

Editing Offset Alignments and Widenings
You can edit the parameters of an offset alignment or widening, split it into sections, and attach additional
widenings.
Two editing methods are available:
■

Edit values in the Offset Parameters dialog box

■

Grip editing

Editing Offset Parameters
This editing method offers precise control of the dimensions and shape of an offset alignment or widening.
Parameters for each region of the object are displayed in a tabular format in the Offset Parameters (page 1989)
dialog box.
When you click on the top heading for a region, the region is highlighted in the drawing.

Example of a highlighted region

Grip Editing
This editing method enables you to use freehand controls to reshape an offset or widening. Dimensions are
also available in tooltips.
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Examples of tooltips for grip editing

The various grips and their use are described in the following table.
Grip

Function
Adjusts the width of the widening.

Adjusts the length of a region along the alignment.

Adds a widening by splitting the current offset or widening into
two regions of equal length.
On a transition, switches the available grip set from transition grips
to widening grips.
Adjusts the length of a transition.

To edit offset parameters
1 Click the offset alignment. Click Offset Alignment tab ➤ Modify panel ➤ Offset Parameters

.

2 In the Offset Parameters (page 1989) dialog box, modify station values, transition types, or other parameters.
To grip edit an offset or widening
1 Click the offset alignment or widening. Grips appear along the object.
2 Click the grip that adjusts the offset or widening as desired.

Quick Reference
Ribbon
Click the offset alignment. Click Alignment tab ➤ Modify panel ➤ Offset Parameters
Object Shortcut Menu
Right-click alignment or widening. Click Edit Offset Parameters
Command Line
EditOffsetAlignParameters
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Applying Design Criteria to an Existing Alignment
Use the Alignment Properties dialog box to apply design criteria to an existing alignment.
The criteria-based design feature provides the ability to verify that your alignment design meets the minimum
standards required by your local agency.
For more information, see Criteria-Based Alignment Design (page 935).
To apply design criteria to an existing alignment
1 Click the alignment. Click Alignment tab ➤ Modify panel ➤ Alignment Properties
drop-down ➤ Alignment Properties

.

2 In the Alignment Properties dialog box, click the Design Criteria (page 1966) tab.
NOTE To use criteria-based design, an alignment must have at least one design speed.

3 In the Design Speeds section, click

Add Design Speed.

4 Specify the Start Station and Design Speed values.
5 Repeat Steps 3 and 4 to specify design speeds at other stations.
An alignment can have unlimited numbers of design speeds, but can have only one speed at any given
station. When a station has a design speed setting, that setting applies to either the remainder of the
alignment or the next station at which a design speed is set. If a single entity has multiple speeds
assigned to it, the highest speed is used to validate that entity against the design criteria. The lower
speed values are ignored.
6 On the right side of the dialog box, select the Use Criteria-Based Design check box.
7 Specify the following settings:
■

Use Design Criteria File
Select this check box to associate a design criteria file with the alignment. The default design criteria
file location and the Default Criteria properties become available when you select the check box.
NOTE The first design criteria file found in the C:\Documents and Settings\All Users|Application
Data\Autodesk\C3D2011\enu\Data\Corridor Design Standards\<units> directory is used by default when
the criteria-based design feature is used.

■

Use Design Check Set
Select this check box to associate a design check set with the alignment. The design check set list
becomes available when you select the check box. Select a design check set from the list.

8 Click OK.
NOTE The entire alignment design is validated when you click either Apply or OK.

Quick Reference
Ribbon
Click the alignment. Click Alignment tab ➤ Modify panel ➤ Alignment Properties drop-down ➤ Alignment
Properties
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Toolspace Shortcut Menu
Prospector tab: Right-click <alignment item > ➤ Properties
Object Shortcut Menu
Right-click <alignment object> ➤ Alignment Properties
Command Line
EditAlignmentProperties
Dialog Box
Alignment Properties Dialog Box (page 1964)

Viewing and Correcting Alignment Design Criteria Violations
Use the warning symbols to verify whether the alignment design meets the specified criteria and design
checks.
When an alignment uses the criteria-based design feature, the alignment geometry must meet the design
criteria specified in the design criteria file (page 2773) and design checks (page 2772).
When an alignment sub-entity violates the design criteria, a warning symbol is displayed in the following
locations:
■

The drawing window — The
criteria.

warning symbol is displayed on each sub-entity that violates the design

NOTE The size of the warning symbol does not adjust automatically. After zooming in or out, enter REGEN
to resize the warning symbols.

■

The Alignment Entities vista — The
warning symbol is displayed in the No. column of the sub-entity
that violates the design criteria. If a criteria in the design criteria file was violated, the warning symbol
is also displayed next to the specific criteria and parameter value that violates the design criteria.

■

The Alignment Layout Parameters dialog box — If a criteria in the design criteria file was violated, the
warning symbol is displayed in the Design Criteria panel next to the Property that was violated, and
in the Layout Parameters panel next to the Parameter that was violated. If a design check was violated,
the
warning symbol is displayed in the Design Checks panel next to the design check that was
violated.

You can use the
warning symbols in the drawing window to view information about criteria and
design checks that were violated. When the cursor is hovered over a warning symbol in the drawing window,
a tooltip displays information about the violation. If a design criteria was violated, the tooltip displays the
criteria that was violated, as well as the minimum value required to meet the criteria. If a design check was
violated, the tooltip displays the name of the design check that was violated.
BEST PRACTICE The name of the design check should be similar to the formula you enter in the Design Check
field. When a design check is violated, only the design check name is displayed, and not the minimum acceptable
value. If the formula is in the design check name, it is easier to correct the violation.
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NOTE If a sub-entity violates more than one criteria or design check, only one warning symbol is displayed in the
drawing. To clear the warning symbol, the sub-entity must be modified to meet all the design criteria and design
checks.

Turning Off the Alignment Warning Symbol
Change the visibility of the warning symbol that indicates violations in the alignment design.
There are several ways to turn off the warning symbol. The following methods are listed in the order in
which they are recommended.

Modify the Alignment Geometry
Edit the alignment design to meet the specified design criteria. This option clears the warning symbols from
the drawing window, Alignment Entities vista, and Alignment Layout Parameters dialog box.
The criteria-based design feature does not validate portions of the alignment that have the design speed set
to zero.
NOTE If a sub-entity violates more than one criteria or design check, only one warning symbol is displayed in the
drawing. To clear the warning symbol, the sub-entity must be modified to meet all the design criteria and design
checks.
For more information, see Correcting Alignment Design Criteria Violations (page 1082).

Change the Alignment Style
Turn off the Warning Symbol display component in the current alignment style. Alternatively, create a
separate alignment style that has the Warning Symbol display component turned off. This option clears the
warning symbols from the drawing window for alignments that use that style. The warning symbols are still
displayed in the Alignment Entities vista and Alignment Layout Parameters dialog box.
For more information, see Alignment Styles (page 946).

Turn Off the AutoCAD Civil 3D Solution Tip
The warning symbol is controlled by the Solution Tip setting in the Options dialog box on the AEC Editor
tab. To hide the warning symbol for all drawings, clear the Drafting check box. This option clears all alignment
and profile warning symbols from the drawing window. However, the warning symbols are still displayed
in the Alignment Entities vista and Alignment Layout Parameters dialog box.
For more information, see AEC Editor Tab (Options Dialog Box) (page 2751).
WARNING Settings in the Options dialog box affect the overall behavior of AutoCAD Civil 3D. If you clear the
Solution Tip Drafting check box, the warning symbol for all alignment and profile objects will be hidden in every
drawing that is opened on the current installation of AutoCAD Civil 3D.

Turn Off the Criteria-Based Design Feature
Disassociate the design criteria from the alignment. The alignment design check set and/or the design criteria
file can be turned off in the Alignment Properties dialog box. This option clears the warning symbols from
the drawing window, Alignment Entities vista, and Alignment Layout Parameters dialog box.
For more information, see Applying Design Criteria to an Existing Alignment (page 1079).
WARNING If you turn off the criteria-based design feature, the alignment design will not be validated against
any design standards.
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Correcting Alignment Design Criteria Violations
Validate the alignment geometry against the specified criteria and design checks.
When an alignment uses the criteria-based design feature, the alignment geometry must meet the design
criteria specified in the design criteria file (page 2773) and design checks (page 2772).
When an alignment sub-entity violates the design criteria, a warning symbol is displayed in several locations.
For information about where the warning symbols appear, see Viewing and Correcting Alignment Design
Criteria Violations (page 1080).
You can use the
warning symbols in the drawing window to view information about criteria and design
checks that were violated. When the cursor is hovered over a warning symbol in the drawing window, a
tooltip displays information about the violation.
■

If a design criteria was violated, the tooltip displays the criteria that was violated, as well as the minimum
value required to meet the criteria.

■

If a design check was violated, the tooltip displays the name and formula of the design check that was
violated.

NOTE If a sub-entity violates more than one criteria or design check, only one warning symbol is displayed in the
drawing. To clear the warning symbol, the sub-entity must be modified to meet all the design criteria and design
checks.
To correct alignment design criteria violations using grips
1 In the drawing window, hover the cursor over a

warning symbol.

A tooltip displays information about the violation.
2 Select the alignment.
3 Use the alignment grips to modify the alignment geometry.
The

warning symbol disappears when the sub-entity meets the design criteria.

NOTE If a sub-entity violates more than one criteria or design check, only one warning symbol is displayed
on the sub-entity. To clear the warning symbol, the sub-entity must be modified to meet all the design
criteria.

To correct alignment design criteria violations by entering numeric values
1 Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
2 On the Alignment Layout Tools toolbar, click

.

Alignment Grid View.

3 In the Alignment Entities vista, click the row that contains the

warning symbol in the No. column.

The sub-entity parameters are displayed in the Alignment Layout Parameters dialog box.
4 In the Alignment Layout Parameters dialog box, locate the
panels:
■

warning symbol in either of the following

Layout Parameters panel — In the Value column, enter a numeric value that meets the value specified
in the Constraints column.
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■

Design Checks panel — Notice that the design check that has been violated. Modify the alignment
design to meet the parameters specified in the design check.

Quick Reference
Ribbon
Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
Menu
Click Alignments menu ➤ Edit Alignment Geometry
Command Line
EditAlignment
Alignment Layout Tools Toolbar Icons
Alignment Grid View
Dialog Box
Alignment Layout Tools (page 1959)
Alignment Entities Vista (page 1947)
Alignment Layout Parameters Window (page 1953)

Reversing Alignment Direction
Use this command to reverse the direction and stationing of an alignment.
All objects that are dependent on the alignment (such as profiles) will also be updated.

When you create an alignment, you can control the direction of the alignment, regardless of the direction
the polyline was drawn. If you create an alignment using the Create Alignment From Polyline command,
the alignment direction starts from the nearest endpoint you click the polyline. If you create an alignment
using the Create Alignment By Layout command, the alignment direction is determined by the direction
in which you draw the alignment. If you must change the direction of the alignment, you can use the Reverse
Alignment Direction command. However, it is important to note that all objects that are dependent on the
alignment (Profiles, Sample Lines, Sections, and Corridor objects, Superelevation) will change as well.
You can only change the direction of an alignment that is continuous.
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WARNING Using this command will reprocess all objects that reference the alignment (Profiles, Sections, Sample
Lines, Corridor objects, and Superelevation). It is highly recommended that you only use this command in the
early phases of the design process.
You can also reverse the direction of an individual fixed, unattached alignment sub-entity. See Reversing
Alignment Sub-Entity Direction (page 1084) for more information.
To reverse the direction of an alignment
➤

Click the alignment. Click Alignment tab ➤ Modify panel

Reverse Direction

.

Quick Reference
Ribbon
Click the alignment. Click Alignment tab ➤ Modify panel

Reverse Direction

Menu
Alignments menu ➤ Reverse Alignment Direction
Command Line
ReverseAlignmentDirection

Reversing Alignment Sub-Entity Direction
Reverse the direction of a fixed, unconnected line or curve entity.
This command works only on fixed entities that are not part of the solved alignment geometry. To reverse
the direction of the entire alignment, use the ReverseAlignDirection command.

See Reversing Alignment Direction (page 1083) for more information.
When you add an alignment sub-entity to an existing alignment, the sub-entity direction is determined by
the direction in which it was drawn. If the sub-entity direction is different from the alignment, the sub-entity
cannot become part of the solved alignment geometry. The sub-entity cannot be included in the alignment
stationing or labeling unless its direction matches the alignment’s.
To reverse the direction of an alignment sub-entity
1 Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
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.

2 On the Alignment Layout Tools (page 1959) toolbar, click

Reverse Sub-Entity Direction.

3 Click the alignment sub-entity in the drawing window.

Quick Reference
Ribbon
Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
Menu
Click Alignments menu ➤ Edit Alignment Geometry
Command Line
EditAlignment
Alignment Layout Tools Toolbar icon
Reverse Sub-Entity Direction

Using AutoCAD Object Snaps with Alignment Objects
You can use AutoCAD object snaps (OSNAPs) with the alignment object. Although there are differences,
alignment OSNAPs function in a manner consistent with OSNAPs to AutoCAD lines, curves, and polylines.
Node snaps apply to all pass-through points and all points of intersection.
OSNAPs that apply to line segments
Use OSNAPs with some alignment components. Alignment line components can have solved and unsolved
segments, depending on whether they are fixed, free, or floating.(Yes indicates that OSNAPs do apply; No
indicates that OSNAPs do not apply.)
Line Segments

Solved Segments

Unsolved Segments

Endpoint

Yes

No

Midpoint

Yes

No

Center

Yes

No

Node

Yes

No (Exception: Node does
apply to visible passthrough points.)

Quadrant

Yes

No

Intersection

Yes

No

Extension

Yes

No

Insertion

Yes

No

Perpendicular

Yes

No
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Line Segments

Solved Segments

Unsolved Segments

Tangent

Yes

No

Nearest

Yes

No

Apparent Intersection

Yes

No

Parallel

Yes

No

OSNAPs that apply to curve segments
Use OSNAPS with some curve segments. Curves can have solved or unsolved segments depending on whether
they are fixed, free, or floating curves.
(Yes indicates that OSNAPS apply; No indicates they do not apply.)
Curve Segments

Solved Segments

Unsolved Segments

Endpoint

Yes

No

Midpoint

Yes

No

Center

Yes

No

Node

Yes

No (Exception: Node does
apply to visible pass-through
points.)

Quadrant

No

No

Intersection

Yes

No

Extension

Yes

No

Insertion

Yes

No

Perpendicular

Yes

No

Tangent

Yes

No

Nearest

Yes

No

Apparent Intersection

Yes

No

Parallel

Yes

No

OSNAPs that apply to spiral segments
(Yes indicates that OSNAPS apply; No indicates they do not apply.)
Spiral Segments

Solved Segment

Unsolved Segments

Endpoint

Yes

No

Midpoint

Yes

No
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Spiral Segments

Solved Segment

Unsolved Segments

Center

Yes

No

Node

Yes

No

Quadrant

No

No

Intersection

Yes

No

Extension

Yes

No

Insertion

Yes

No

Perpendicular

Yes

No

Tangent

Yes

No

Nearest

Yes

No

Apparent Intersection

Yes

No

Parallel

Yes

No

Deleting Alignment Entities
Use one of several methods to delete an alignment or alignment sub-entity.
The dependencies for deleting an alignment or alignment sub-entity are explained in the following topics.

Deleting an Alignment
Delete an alignment from either the drawing window or the Toolspace Prospector tab.
If other objects were created from an alignment, you cannot use Prospector to delete the alignment. You
can delete the alignment from the drawing window, but the dependant objects will also be deleted. Depending
on the object type, the objects can also be deleted from Prospector.
For example, a profile and corridor can be created from an alignment. If you right-click the alignment in
the Prospector, the Delete option is not available. If you select the alignment in the drawing window and
press Delete, the corridor and profile are cleared from the drawing window. The profile is also deleted from
Prospector because it is a child of the alignment object. The corridor object is still present in Prospector
because the alignment was only one of the objects from which it was created. You can add another alignment
to the corridor as a baseline, and then rebuild the corridor.
To delete an alignment from the drawing window
1 Select an alignment in the drawing.
2 Press Delete.
To delete an alignment from the Prospector
1 In Toolspace, on the Prospector tab, select the alignment object.
2 Right-click. Click Delete.
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Deleting an Alignment Sub-Entity
Delete a specified alignment entity.
You can delete an alignment sub-entity only if no other sub-entities use it as a defining parameter. The
following points are the basic conditions for deleting the different types of alignment sub-entities:
■

A fixed entity cannot be deleted if it has a floating or free entity attached to it.

■

A floating entity cannot be deleted if it has either a floating or free entity attached to it.

■

Free entities are not used to define the geometry of other entities. You can delete a free entity at any
time.

To delete an alignment sub-entity from the Alignment Layout Tools toolbar
1 Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
2 On the Alignment Layout Tools toolbar, click

.

Delete Sub-Entity.

3 Click the sub-entity in the drawing.
4 Press Enter to end the Delete Sub-Entity command.
To delete an alignment sub-entity using the Delete key
1 Ctrl+click an alignment sub-entity in the drawing.
NOTE For more information about selecting alignment sub-entities, see Selecting Alignment Entities (page
1061).
2 Press Delete.

Quick Reference
Ribbon
Click the alignment. Click Alignment tab ➤ Modify panel ➤ Geometry Editor
Menu
Click Alignments menu ➤ Edit Alignment Geometry
Command Line
EditAlignment
Alignment Layout Tools Toolbar icon
Delete Sub-Entity

Alignment Command Reference
You can use AutoCAD Civil 3D commands when you work with alignments. The following table lists the
alignment-related AutoCAD Civil 3D commands and briefly describes their functionality.
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For more information about a command, follow the link in the Description column.
Command

Description

AddAlignmentCurveTable

Adds an alignment curve table (page 1059)

AddAlignLabels

Opens the Add Labels dialog box (page
1043)

AddAlignmentLineTable

Adds an alignment line table (page 1059)

AddAlignmentSegmentTable

Adds an alignment segment table (page
1059)

AddAlignmentSpiralTable

Adds an alignment spiral table (page 1059)

AddAlignOffLbl

Labels fixed station offsets (page 1056)

AddAlignOffXYLbl

Labels multiple station offsets (page 1055)

AddAlignSegLbl

Labels multiple segment labels (page 1054)

AddAlignSegLbls

Labels multiple segment labels (page 1054)

AddAlignTangentIntLbl

Labels single tangents intersections (page
1056)

AddAlignTangentIntLbls

Labels multiple tangent intersections (page
1057)

AddAutomaticWidening

Automatically adds widening to curved
regions of a dynamic offset alignment
(page 966)

AddWidening

Adds a widened region to an existing
alignment (page 965)

C3D_BestFitAlignment

Creates an alignment that follows the most
logical path through a series of feature
lines, COGO points, or AutoCAD lines,
arcs, points, or blocks (page 960)

CreateAlignmentEntities

Opens the Create Alignment from Objects
dialog box (page 1975)

CreateAlignFromExisting

Creates an alignment from all or part of
an existing alignment (page 957)

CreateAlignmentLayout

Opens the Create Alignment-Layout dialog
box (page 948)

CreateAlignmentReference

Creates an alignment reference in the
current drawing (page 954)

CreateOffsetAlignment

Creates one or more offset alignments
based on an existing alignment (page 956)
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Command

Description

DesignCriteriaEditor

Opens the Design Criteria Editor dialog
box (page 936)

EditAlignment

Opens the Alignment Layout Tools toolbar
(page 1060)

EditAlignmentLabels

Opens the Alignment Labels dialog box
(page 1045)

EditAlignmentTagNumbers

Renumbers alignment entity label tags
(page 1723)

EditOffsetAlignParameters

Edits the parameters of an offset alignment
or widening (page 1077)

ReverseAlignmentDirection

Reverses an alignment direction (page 1083)
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Superelevation

25

Understanding Superelevation
Calculate and edit the superelevation data to apply to roadway cross sections.
Superelevation Workflow (page 42)
NOTE Superelevation should be calculated before the corridor model is built along the alignment. The corridor
model is not dynamic to changes in the alignment superelevation parameters. You must rebuild the corridor to
include the updated superelevation.
Calculate, manage, and edit superelevation data using the following:
■

Superelevation Wizard (page 1098)

■

Superelevation Curve Manager (page 1102)

■

Superelevation Tabular Editor (page 1108)

Roadway Design Standards
Using the Superelevation wizard, you can specify roadway design standards, including superelevation
attainment method, minimum radius, and transition length values.
Roadway design standards are contained in the design criteria file (page 2773). You can customize the design
criteria file to reflect your local standards using the Design Criteria Editor Dialog Box (page 2067). For more
information, see Design Criteria Files (page 936).
The XML-based design criteria file stores the standard tables and formulas that you can use to calculate
superelevation rates and superelevation critical stations on an alignment.

Superelevation Rate Tables
A table of superelevation rates that you can apply to different types of roadways as a function of curve radius
and design speed.

1091

Transition Length Tables
A table of values you can use in the Superelevation Attainment Method formulas. You can use the table to
calculate the distances between the critical superelevation transition points for different types of roadways
as a function of curve radius and design speed. In many cases, the transition length tables provide the actual
length of transition of superelevation runoff.

Superelevation Attainment Methods
Specifies how superelevation is applied, and the method that is used to calculate superelevation critical
stations for different types of roadways. Each defined method specifies the formulas used to calculate the
distances between the critical superelevation transition points. For more information, see Superelevation
Variables and Formulas (page 1092).
AutoCAD Civil 3D supports two methods of superelevation attainment.
■

Standard. Requires removal of adverse crown. This method is typically used on undivided, crowned
roadways and divided roadways with crowned or planar sections.

■

Planar. Does not require removal of adverse crown. This method is typically used on undivided,
planar-section roadways, such as ramps and service roads.

For more information and sample XML files, see Examples of Attainment Methods (page 1094).
In the design criteria file, each attainment method, superelevation rate table, and transition length table
have unique, defined names. Use the Calculate Superelevation - Attainment Page (page 2612) to specify the
name of the design criteria file.

Superelevation Variables and Formulas
Use the following set of variables to calculate transition distances.
{e}

The full superelevation rate. This rate is determined from the superelevation rate table, based on the design speed and curve radius.

{t}

The value that is read from the transition length tables, based on
the design speed and the curve radius. In most cases, such as
AASHTO, this is the transition length value from Level Crown to
Full Superelevation. However, this value may not be an actual
length, but some other value, such as a transition rate from which
the length can be calculated.

{c}

The unsuperelevated normal lane slope (positive). This value is
defined by the user in the Calculate Superelevation - Lanes Page
(page 2611).

{s}

The unsuperelevated normal shoulder slope (positive). This value
is defined by the user in the Calculate Superelevation - Shoulder
Control Page (page 2611).

{w}

The normal width of the traveled way. This value is defined by
the user in the Calculate Superelevation - Lanes Page (page 2611).

{l}

The length of the spiral, if a spiral is involved in the transition.
This is the actual length of the spiral element in the curve group.
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{p}

The fractional part of the transition length before the start of the
curve or after the end of the curve.

{q}

The rate of increase of centripetal acceleration traveling along a
curve at a constant speed.

The variables in the previous table are used to calculate the following:
XML Code

Description

NC

Normal Crown

LC

Level Crown

RC

Reverse Crown

FS

Full Super

Example

The following table describes the formulas:
LCtoFS

The distance from the Level Crown Station
to the Full Superelevation station is the
value {t}, which is read from the selected
transition length table. The formula assumes that the transition length table
defines the runoff length.

LCtoBC

The distance from the Level Crown station
to the Beginning of Curve station is a percentage of the runoff length{t} based on
the variable {p}.

NCtoLC

The distance from Normal Crown station
to the Level Crown Station (tangent runout)
is calculated as the runoff length {t}, time
the normal crown slope {c}, divided by the
full superelevation rate {e}. The tangent
runout length is extrapolated from the
runoff length.
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LCtoRC

The distance from the Level Crown station
to the Reverse Crown station. (typically uses
the same formula as NCtoLC)

NStoNC

Normal Shoulder point to Normal Crown
point. (used for Breakover Removal Method
of superelevated shoulders and Match Lane
Slopes)

Examples of Attainment Methods
Use this section to view examples of the XML formats you can use for various superelevation attainment
methods.

Standard Attainment Method Example
The following example shows the XML format you can use to calculate transition stations for undivided,
crowned roadways using the AASHTO standard methodology:
<SuperelevationAttainmentMethod name="AASHTO 2001 - Crowned Roadway">
<AttainmentStyle style="Standard"/>
<TransitionFormula type="LCtoFS" formula="{t}"/>
<TransitionFormula type="LCtoBC" formula ="{p}*{t}"/>
<TransitionFormula type="NCtoLC" formula ="{t}*{c}/{e}"/>
<TransitionFormula type="LCtoRC" formula ="{t}*{c}/{e}"/>
<TransitionFormula type="NStoNC" formula ="{t}*({s}-{c})/{e}">
<SuperelevationAttainmentMethod>

This example defines an attainment method whose name is "AASHTO 2001 - Crowned Roadway" which
uses the standard adverse crown removal method of attaining superelevation. This example includes a
calculation for the transition distance needed for shoulder breakover removal (type="NStoNC").

Planar Transition Attainment Method Example
This example shows an undivided planar road. The roadway is not crowned, and there is no adverse crown
removal.
The Planar attainment method requires two formulas: one for curves that oppose the direction of the normal
cross slope and one for curves that continue in the direction of the normal cross-slope. The following
illustration shows normalized slope superelevation, where the unsuperelevated road is tilted downward from
left to right. Therefore the curve to the left requires a longer transition than the curve to the right:

In the following example, the Continuing section defines the Normal Crown to Full Superelevation distance
runoff length {t} (derived from the transition length tables), minus the runoff length times the normal
roadway slope {c} divided by the full superelevation rate {e}. The second formula defines the distance from
Normal Crown to the Beginning of Curve as a percentage of {t} based on the variable {p} minus {c} divided
by {e}.
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The Opposing section defines the overall transition distance to be the runoff length {t}. The distance to the
Beginning of Curve is a percentage of {t} based on the variable {p}, and the distance between the Normal
Crown and Level Crown stations is {t} * {c} / {e}.
<SuperelevationAttainmentMethod name="Undivided Planar Roadway">
<TransitionStyle style="Planar"/>
<Continuing>
<TransitionFormula type="NCtoFS" formula="{t}-{t}*{c}/{e}"/>
<TransitionFormula type="NCtoBC" formula="{t}*({p}-{c}/{e})"/>
</Continuing>
<Opposing>
<TransitionFormula type="LCtoFS" formula="{t}"/>
<TransitionFormula type="LCtoBC" formula="{p}*{t}"/>
<TransitionFormula type="NCtoLC" formula="{t}*{c}/{e}"/>
</Opposing>
<SuperelevationAttainmentMethod>

Transitions Defined by Roadway Width and Transition Rate
Not all organizations use tables that give transition length directly. The following table defines the full
superelevation rate and the
as a function of design speed and curve radius. In this situation, the
value is used to derive the transition length based on the normal width of the roadway. The Transition
Length tables define the
Radius
(m)

value instead of the actual transition length.

90 km/h

100km/h

110km/h

120km/h

E%

E%

E%

E%

n/a

7000

NC

n/a

NC

n/a

NC

n/a

NC

n/a

5000

NC

n/a

NC

n/a

NC

n/a

2.0

0.31

3000

2.0

0.39

2.0

0.34

2.0

0.32

2.0

0.31

2500

2.0

0.39

2.0

0.34

2.0

0.32

2.0

0.31

2000

2.0

0.39

2.0

0.34

2.0

0.32

2.3

0.32

1500

2.0

0.39

2.0

0.34

2.2

0.33

3.0

0.33

1400

2.0

0.39

2.0

0.34

2.4

0.33

3.2

0.34

1300

2.0

0.39

2.0

0.34

2.6

0.33

3.5

0.34

1200

2.0

0.39

2.2

0.35

2.8

0.34

3.8

0.35

1000

2.0

0.39

2.6

0.36

3.7

0.35

4.5

0.37

900

2.2

0.40

2.9

0.37

3.7

0.36

5.0

0.38

800

2.5

0.40

3.3

0.38

4.2

0.38

5.7

0.39

700

2.9

0.41

3.7

0.39

4.8

0.39

6.0

0.40
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Radius
(m)

90 km/h

100km/h

110km/h

600

3.4

0.42

4.4

0.41

5.6

0.41

500

4.0

0.44

5.2

0.43

6.0

0.42

400

5.0

0.46

6.0

0.45

300

6.0

0.48

120km/h

The following example shows attainment methods and formulas for two types of roadways based on the
previous table. The variable {w} is the normal roadway width from pivot point to edge-of traveled-way,
defined in the Superelevation wizard.
<SuperelevationAttainmentMethod name="Unspiraled ramp">
<TransitionStyle style="Planar"/>
<Continuing>
<TransitionFormula type="NCtoFS" formula="100*{e}*{w}/{t}"/>
<TransitionFormula type="NCtoBC" formula="{p}*{e}*{w}/{t}"/>
</Continuing>
<Opposing>
<TransitionFormula type="LCtoFS" formula="100*{e}*{w}/{t}"/>
<TransitionFormula type="LCtoBC" formula="{p}*{e}*{w}/{t}"/>
<TransitionFormula type="NCtoLC" formula="100*{c}*{w}/{t}"/>
<TransitionFormula type="LCtoRC" formula="100*{c}*{w}/{t}"/>
</Opposing>
</SuperelevationAttainmentMethod>
<SuperelevationAttainmentMethod name="Unspiraled 2 way roadway">
<TransitionStyle style="Standard"/>
<TransitionFormula type="LCtoFS" formula="100*{e}*{w}/{t}"/>
<TransitionFormula type="LCtoBC" formula="{p}*{e}*{w}/{t}"/>
<TransitionFormula type="NCtoLC" formula="100*{c}*{w}/{t}"/>
<TransitionFormula type="LCtoRC" formula="100*{c}*{w}/{t}"/>
<SuperelevationAttainmentMethod>

Superelevation on Undivided Roads
This section describes two situations for undivided roads and illustrates how superelevation is applied for
each situation.
■

The following illustration shows an undivided road as a corridor type and a crowned cross section shape.
During superelevation, the simple crowned roadway undergoes adverse crown removal. In this illustration,
the adverse crown removal is the distance from End Normal Crown to Reverse Crown:
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Transition Length (LF)
Runoff Length (L R)

Runout Length
(L T)

+e %

2%

0%

PC/BC
Adverse Crown Removal
Level
Crown

End Normal
Crown
-2%

-2%

■

0%

-e%
Reverse
Crown

+2%

-2%

Begin Full
Super
+e%
-e%

-2%

The following illustration shows an undivided road as the corridor type and the cross section shape is
planar. There is no crown, therefore no removal of adverse crown is necessary. This type of roadway
typically has a downward slope in one direction on the unsuperelevated sections. Because of this, the
distance required to achieve full superelevation varies depending on whether the superelevation continues
in the direction of the downward slope or superelevates in the direction opposite to the normal downward
slope. This example is typical of ramps, one-way traffic roads, and some service roads.

Runoff Length (L R)

L R * (C/e)

C
e

C

Superelevation
opposes the normal
roadway slope

B

C
e

A
A

B

C

A

B

C

B

A

C

Runoff Length (L R)
A
e
B

Superelevation
continues the normal
roadway slope

e

L R* (C/e)

C
A

A B

C

B
C

Superelevation on Divided Roads
This section describes two situations for divided roads and illustrates how superelevation is applied for each
situation.
■

The following illustration shows a divided road as the corridor type and the cross section shape is planar.
The roadway undergoes adverse crown removal during superelevation:
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Normal Crown

Level Crown

Reverse Crown

Begin Full Super

■

The following illustration shows a divided road as the corridor type and a crowned cross section shape
on each side. The roadway undergoes adverse crown removal during superelevation:

Normal Crown

Level Crown

Reverse Crown

Begin Full Super

Calculating Superelevation Data Using the Wizard
Use this wizard to specify roadway type, number of lanes, shoulder control, and attainment method for
calculating superelevation.
The Superelevation wizard can be used to:
■

Calculate the superelevation for all curves or a selected curve in an alignment

■

Store the design criteria in the superelevation curve manager for review or editing after data is calculated

NOTE The options on the wizard pages can vary depending on the type of roadway section you select. You must
complete the wizard or end the command to continue work in the drawing.
To calculate superelevation data using the wizard
1 Click an alignment in the drawing.
2 Click Alignment tab ➤ Modify panel ➤ Superelevation drop-down ➤ Calculate/Edit Superelevation
.
NOTE The first time you use the Calculate/Edit Superelevation command on an alignment that contains no
superelevation data, a superelevation curve is calculated for each curve (circular arc) in the alignment. A task
dialog is displayed with the following options:
■

Calculate Superelevation Now - choose this option to launch the Superelevation Calculation Wizard.

■

Open The Superelevation Curve Manager - choose this option to open the Superelevation Curve
Manager, where you can view curve data.
After the initial superelevation calculation, the Calculate/Edit Superelevation command automatically
displays the Superelevation Curve Manager.
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3 On the Calculate Superelevation - Roadway Type page, select one of the following road types:
■

Undivided Crowned, Pivot Center

■

Undivided Planar, Pivot Center
NOTE In the list box specify the highside as Left Edge, Level, or Right Edge.

■

Divided Crowned With Median

■

Divided Planar With Median

4 Click Next.
5 On the Calculate Superelevation - Lanes page, specify the number of lanes. Clear the Symmetric Roadway
check box if necessary and specify the number of lanes for the left and right sides.
NOTE If you select '1' for the number of lanes, the lanes that are displayed in the Superelevation Tabular
Editor (Panorama) (page 2606) are the outside lanes. Any labels, expressions, or other references for the inside
lanes do not return a value in the tabular editor. To display values for the inside lanes in the tabular editor,
select '2' for the number of lanes.
6 Enter the Normal Lane Width and Normal Lane Slope for each side of the road.
7 Click Next.
8 On the Calculate Superelevation - Shoulder Control page, specify the Shoulder Slope Treatment. The
options in the list for Shoulder Slope Treatment can vary depending on the roadway type.
9 Enter the Normal Shoulder Width value.
10 Enter the Normal Shoulder Slope value.
11 Click Next.
12 On the Calculate Superelevation - Attainment page, specify the following:
■

Design Criteria File

■

Superelevation Rate Table
NOTE In the list, choose Superelevation Rate By Formula in situations where you want to calculate the
superelevation rate based on a formula rather than a pre-defined table. In the out-of-box criteria files that
Civil 3D provides, there is a simple formula based on AASHTO standards that will calculate the
superelevation for a given radius and design speed. You can edit this formula to meet the requirements
of local agencies that may vary from AASHTO.

■

Transition Length Table

■

Attainment Method

■

Transition Formula For Superelevation Runoff

■

Curve Smoothing. To apply curve smoothing select the check box and enter the smoothing value.

■

Automatically Resolve Overlap. If you select this option all overlap conditions on the entire alignment
are resolved.

13 Click Finish. The Superelevation Tabular Editor (page 1108) is displayed.
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Quick Reference
Ribbon
Click Alignment tab ➤ Modify panel ➤ Superelevation drop-down ➤ Calculate/Edit Superelevation
Object Shortcut Menu
Right-click Alignment object ➤ Edit Superelevation
Command Line
CalcEditSuperelevation
Dialog Box
Superelevation Wizard (page 2610)

Importing Superelevation Data
Import superelevation data from a CSV file.
When you import a CSV file, the begin full super (BFS) and end full super (EFS) critical stations in the file
represent the begin and end of the curve because the file does not contain explicit transition information.
The station values in the file are used to match critical stations to the superelevation curves detected on the
alignment. The imported data is always associated with a detected curve unless both the BFS and EFS are on
a tangent/spiral entity. In that situation, the data becomes part of a user-defined curve.
If you import two regions that fall into one detected curve, they stay in the detected curve and are displayed
duplicate stations.
When you import data that does not fall within a single detected curve, or BFS or EFS is not found in the
file, a task dialog is displayed with the following options:
■

Ignore - imports all data that matches up with a curve but does not import data that does not match.

■

Accept - imports all data and forces the detection of curves based on where the BFS and EFS station values
fall.

■

Cancel - no data is imported and the command closes.

If you choose Ignore or Accept, the event viewer displays the stations that did not get imported.
Overlap is not automatically resolved on the imported data.
After you import the data you can use the Superelevation Curve Manager to view the curve data and make
edits using the Superelevation Tabular Editor and Superelevation Views.

1100 | Chapter 25 Superelevation

To import a .CSV file
IMPORTANT The columns in the CSV file must be in the following order:
■

Curve number

■

Station

■

Critical station type

■

Curve length

■

Left Outside Shoulder

■

Left Outside Lane

■

Left Inside Lane

■

Left Inside Shoulder

■

Right Outside Shoulder

■

Right Outside Lane

■

Right Inside Lane

■

Right Inside Shoulder

For successful import, each cell must contain a value. If a parameter does not have an associated value, enter
zero.
1 Click an alignment in the drawing.
2 Click Alignment tab ➤ Modify panel ➤ Superelevation drop-down ➤ Calculate/Edit Superelevation
.
NOTE The first time you use the Calculate/Edit Superelevation command on an alignment that contains no
superelevation data, a superelevation curve is calculated for each curve (circular arc) in the alignment. A task
dialog is displayed with the following options:
■

Calculate Superelevation Now - choose this option to launch the Superelevation Calculation wizard.

■

Open The Superelevation Curve Manager - choose this option to open the Superelevation Curve
Manager, where you can view curve data.
After the initial superelevation calculation, the Calculate/Edit Superelevation command automatically
displays the Superelevation Curve Manager.

3 In the task dialog box, select Open The Superelevation Curve Manager.
4 In the Superelevation Curve Manager, click Tabular Editor.
5 In the Superelevation Tabular Editor, click
6 In the Superelevation Import dialog box, click

.
.

7 In the Select File To Import dialog box, navigate to the appropriate file. Click Open.
NOTE If there is existing superelevation data, you receive a warning that existing data will be overwritten.
8 Click OK. The Superelevation Tabular Editor is populated with descriptions and values for each region.
9 Click in a cell to make edits.
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Quick Reference
Ribbon
Click Alignment tab ➤ Modify panel ➤ Superelevation drop-down ➤ Calculate/Edit Superelevation
Object Shortcut Menu
Right-click Alignment object ➤ Edit Superelevation
Command Line
CalcEditSuperelevation
Dialog Box
Superelevation Tabular Editor (Panorama) (page 2606)

Using the Superelevation Curve Manager
Use the Superelevation Curve Manager to review curve data, edit design criteria, and recalculate superelevation.
NOTE When you are working in the Superelevation Curve Manager dialog box or the Superelevation Tabular
Editor, the curve you select is highlighted in the drawing.
The Superelevation Curve Manager can be used to:
■

Navigate and view the superelevation calculation status and criteria for each curve

■

Receive graphical feedback and navigate to locations in the drawing related to superelevation curves

■

View information for transition in and out regions for each curve

■

Access the Superelevation Tabular Editor

■

Access the Superelevation wizard

■

View and edit the superelevation criteria that was used to generate superelevation data for curves that
have calculated superelevation

■

Create user-defined curves

Viewing Superelevation for Curves
Use the navigation tools in the Superelevation Manager to view curve data.
NOTE When you are working in the Superelevation Curve Manager dialog box or the Superelevation Tabular
Editor, the curve you select is highlighted in the drawing.
To view superelevation curve data
1 Click an alignment in the drawing.
2 Click Alignment tab ➤ Modify panel ➤ Superelevation drop-down ➤ Calculate/Edit Superelevation
.

1102 | Chapter 25 Superelevation

NOTE The first time you use the Calculate/Edit Superelevation command on an alignment that contains no
superelevation data, a superelevation curve is calculated for each curve (circular arc) in the alignment. A task
dialog is displayed with the following options:
■

Calculate Superelevation Now - choose this option to launch the Superelevation Calculation wizard.

■

Open The Superelevation Curve Manager - choose this option to open the Superelevation Curve
Manager, where you can view curve data.
After the initial superelevation calculation, the Calculate/Edit Superelevation command automatically
displays the Superelevation Curve Manager.

3 Click Open The Superelevation Curve Manager.
4 In the Superelevation Curve Manager dialog box, use the Previous and Next buttons to navigate through
each curve in the alignment, or select a curve from the list. The selected curve is highlighted in the
drawing.

Quick Reference
Ribbon
Click Alignment tab ➤ Modify panel ➤ Superelevation drop-down ➤ Calculate/Edit Superelevation
Object Shortcut Menu
Right-click Alignment object ➤ Edit Superelevation
Command Line
CalcEditSuperelevation
Dialog Box
Superelevation Curve Manager Dialog Box (page 2602)

Creating User-defined Curves
Create a user-defined curve by selecting a single alignment entity or string of adjacent alignment entities.
Use this command to handle special geometric cases where a curve is not automatically created by AutoCAD
Civil 3D, for example where an alignment has two compound spirals or a compound spiral in between
spirals. If there is no geometry available for the user-defined curve, you are prompted to press Enter to exit
the command.
To create a user-defined curve
1 Click an alignment in the drawing.
2 Click Alignment tab ➤ Modify panel ➤ Superelevation drop-down ➤ Calculate/Edit Superelevation
.
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NOTE The first time you use the Calculate/Edit Superelevation command on an alignment that contains no
superelevation data, a superelevation curve is calculated for each curve (circular arc) in the alignment. A task
dialog is displayed with the following options:
■

Calculate Superelevation Now - choose this option to launch the Superelevation Calculation wizard.

■

Open The Superelevation Curve Manager - choose this option to open the Superelevation Curve
Manager, where you can view curve data.
After the initial superelevation calculation, the Calculate/Edit Superelevation command automatically
displays the Superelevation Curve Manager.

3 In the task dialog box, click Open The Superelevation Curve Manager.
4 Click

Create User-defined Curve.

At the command line you are prompted to select the starting entity for the superelevation curve group.
5 In the drawing, select the starting entity and the ending entity for the superelevation curve group.
The user-defined curve is displayed in the Superelevation Curve Manager dialog box and the status is
“Not Calculated”.
6 Click Superelevation Wizard.
7 In the Create Superelevation dialog box, select This Curve Only.
8 Click OK and complete the Superelevation wizard.

Quick Reference
Ribbon
Click Alignment tab ➤ Modify panel ➤ Superelevation drop-down ➤ Calculate/Edit Superelevation
Command Line
CalcEditSuperelevation
Dialog Box
Superelevation Curve Manager Dialog Box (page 2602)

Editing Superelevation Design Criteria
Edit design criteria.
After calculating superelevation data using the wizard, you review the curve data and edit the design criteria
in the Superelevation Curve Manager dialog box.
To edit design criteria in the Superelevation Curve Manager
1 Click an alignment in the drawing.
2 Click Alignment tab ➤ Modify panel ➤ Superelevation drop-down ➤ Calculate/Edit Superelevation
.
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NOTE The first time you use the Calculate/Edit Superelevation command on an alignment that contains no
superelevation data, a superelevation curve is calculated for each curve (circular arc) in the alignment. A task
dialog is displayed with the following options:
■

Calculate Superelevation Now - choose this option to launch the Superelevation Calculation wizard.

■

Open The Superelevation Curve Manager - choose this option to open the Superelevation Curve
Manager, where you can view curve data.
After the initial superelevation calculation, the Calculate/Edit Superelevation command automatically
displays the Superelevation Curve Manager.

3 In the Superelevation Curve Manager, expand the Superelevation Criteria node and make necessary
changes.
The Superelevation Status changes to Out of Date.
4 Click Recalculate to update the superelevation.

Quick Reference
Ribbon
Click Alignment tab ➤ Modify panel ➤ Superelevation drop-down ➤ Calculate/Edit Superelevation
Command Line
CalcEditSuperelevation
Dialog Box
Superelevation Curve Manager Dialog Box (page 2602)

Using Superelevation Views
Use grips on a superelevation view to make graphical edits to superelevation data.
Make the following graphical edits using grips in the superelevation view:
■

Delete and Add superelevation critical stations

■

Move a superelevation critical station or region

■

Change full superelevation cross slope value

■

Change a given superelevation cross slope value

■

Make adjustments where there are overlap conditions

■

Clean-up an automatically resolved overlap condition

Superelevation View Feature Settings
Use the superelevation view settings to specify the default behavior for the superelevation view commands.
To change superelevation view default settings
1 In Toolspace, on the Settings tab, right-click the Superelevation View collection ➤ Edit Feature Settings.
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2 In the Superelevation View Settings dialog box, expand the display for each setting. Click a cell in the
Value column and enter a new value or specify a different style.
3 Click Apply to accept the changes and continue working in the dialog box or click OK to accept the
changes and close the dialog box.

Quick Reference
Toolspace Shortcut Menu
Right-click Superelevation View collection ➤ Edit Feature Settings
Dialog Box
Superelevation View Feature Settings Dialog Box (page 2608)

Superelevation View Styles
You can use Superelevation View Styles to control the visual display of each superelevation view component.
Changes made to a style are applied to all superelevation views that use the style.
To create a superelevation view style
■

In Toolspace, on the Settings tab, expand the Superelevation View Styles collection. Right-click ➤ New.

To copy or edit a superelevation view style
■

In Toolspace, on the Settings tab, expand the Superelevation View Styles collection. Right-click an existing
style ➤ Copy or Edit.

Quick Reference
Toolspace Shortcut Menu
On the Settings tab, Superelevation View collection ➤ Superelevation View Styles ➤ right-click <style
name> New, Edit, Copy, or Delete
Object Shortcut Menu
Right-click Superelevation View object ➤ Edit Superelevation View Style
Dialog Box
Superelevation View Style Dialog Box (page 2609)

Superelevation View Properties
Specify properties to control the content and format of the superelevation view.
To edit superelevation view properties
1 In the drawing, click any grid or axis line of the superelevation view you want to edit.
2 Right-click ➤ Superelevation View Properties.
3 Review or change properties on the tabs in the Superelevation View Properties dialog box.
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Quick Reference
Toolspace Shortcut Menu
On the Prospector tab, expand the Alignments collection. Expand Centerline Alignment ➤ expand
Superelevation Views ➤ right-click Superelevation ➤ Properties
Object Shortcut Menu
Right-click Superelevation View object ➤ Superelevation View Properties
Dialog Box
Superelevation View Properties Dialog Box (page 2608)

Creating and Editing Superelevation Views
Create superelevation views for a graphical display of superelevation and use grips to edit the superelevation
data.
The superelevation view and the superelevation tabular editor are dynamic so that changes made in one are
reflected in the other.
Exercise 5: Editing Superelevation Parameters Graphically
To create and edit a superelevation view
NOTE You must calculate superelevation before you create a superelevation view. For more information, see
Calculating Superelevation Data Using the Wizard (page 1098).
1 Click Alignment tab ➤ Modify panel ➤ Superelevation drop-down ➤ Superelevation View

.

2 In the Create Superelevation View dialog box, enter a view name, station range, and the display options
for the lanes.
3 Click OK.
4 In the drawing specify the superelevation view origin.
5 Click the superelevation view to enable the grips. Hover over a grip to view a menu of the editing
options.

Quick Reference
Ribbon
Click Alignment tab ➤ Modify panel ➤ Superelevation drop-down ➤ Superelevation View
Command Line
CreateSuperelevationView
Dialog Box
Create Superelevation View Dialog Box (page 2601)
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Editing Superelevation Data
Use the Superelevation Tabular Editor to add and edit superelevation data, the Superelevation View to make
graphical edits, and the Superelevation Curve Manager to review and edit the design criteria.

Editing Superelevation Data in the Tabular Editor
Edit superelevation data in the Superelevation Tabular Editor.
Using the Superelevation Tabular Editor you can:
■

Directly view, edit, and enter superelevation data

■

Categorize the incoming and outgoing superelevation data for each curve

■

Categorize superelevation regions and critical points within incoming and outgoing curve areas

■

Import superelevation data from a CSV file

■

Input superelevation data manually

■

Receive graphical feedback and navigate to locations in the drawing related to the selected regions and
critical points

To edit superelevation data in the tabular editor
1 Click an alignment in the drawing.
2 Click Alignment tab ➤ Modify panel ➤ Superelevation drop-down ➤ Calculate/Edit Superelevation
.
NOTE The first time you use the Calculate/Edit Superelevation command on an alignment that contains no
superelevation data, a superelevation curve is calculated for each curve (circular arc) in the alignment. A task
dialog is displayed with the following options:
■

Calculate Superelevation Now - choose this option to launch the Superelevation Calculation Wizard.

■

Open The Superelevation Curve Manager - choose this option to open the Superelevation Curve
Manager, where you can view curve data.
After the initial superelevation calculation, the Calculate/Edit Superelevation command automatically
displays the Superelevation Curve Manager.

3 Display the tabular editor by doing one of the following:
■

If you have not calculated superelevation data, choose the option to calculate superelevation. When
you click Finish on the wizard, the tabular editor is displayed.

■

If you have previously calculated superelevation, choose Open The Superelevation Curve Manager
and click Tabular Editor.

4 In the Superelevation Curve column, click
superelevation parameters are displayed.

5 Add a critical station by clicking the

to expand the tree view. The transition regions and

or right-click an item in the tree view ➤ Add Station.

6 The Superelevation Tabular Editor temporarily closes and you are prompted to pick a station on the
alignment.
The Manual Station field is added.
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7 Right-click the Manual Station ➤ Assign Critical Station and select the parameter from the list or enter
a station name.

NOTE In situations where an overlap occurs, a warning symbol
is displayed in the Overlap column. Click
for options to automatically resolve the overlap or ignore the overlap.

Quick Reference
Ribbon
Click Alignment tab ➤ Modify panel ➤ Superelevation drop-down ➤ Calculate/Edit Superelevation
Dialog Box
Superelevation Tabular Editor (Panorama) (page 2606)

Entering Superelevation Values Manually
Enter superelevation values manually using the Superelevation Tabular Editor
To enter superelevation values in the Superelevation Tabular Editor
1 Click an alignment in the drawing.
2 Click Alignment tab ➤ Modify panel ➤ Superelevation drop-down ➤ Calculate/Edit Superelevation
.
NOTE The first time you use the Calculate/Edit Superelevation command on an alignment that contains no
superelevation data, a superelevation curve is calculated for each curve (circular arc) in the alignment. A task
dialog is displayed with the following options:
■

Calculate Superelevation Now - choose this option to launch the Superelevation Calculation Wizard.

■

Open The Superelevation Curve Manager - choose this option to open the Superelevation Curve
Manager, where you can view curve data.
After the initial superelevation calculation, the Calculate/Edit Superelevation command automatically
displays the Superelevation Curve Manager.

3 Click Open The Superelevation Curve Manager.
4 In the Superelevation Curve Manager, click Tabular Editor.
Both the Superelevation Curve Manager and the Superelevation Tabular Editor are displayed.
5 In the Superelevation Tabular Editor, right-click a curve ➤ Add Station. In the drawing the curve is
highlighted and at the command line you are prompted to pick a station.
A Transition In Region is created.
6 Expand the Transition In Region ➤ right-click Manual Station ➤ Assign Critical Station and select the
critical station or enter a station name.
7 Right-click the Transition In Region ➤ Add Station.
A Transition Out Region is created.
8 Expand the Transition Out Region ➤ right-click Manual Station ➤ Assign Critical Station and select
the critical station.
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Continue adding values as needed. Use this process to add critical stations to Runoff and Runout.
9 Edit values in the columns, if necessary.
10 In the Overlap column a warning symbol indicates an overlap situation. When you click
,you are
prompted with a task dialog box where you can choose to automatically resolve the overlap or ignore
it.

Quick Reference
Ribbon
Click Alignment tab ➤ Modify panel ➤ Superelevation drop-down ➤ Calculate/Edit Superelevation
Dialog Box
Superelevation Tabular Editor (Panorama) (page 2606)

Grip Editing Alignment Geometry
The locations of superelevation critical points are dynamic when you grip edit the alignment geometry and
all distances are maintained.
NOTE Superelevation data such as slopes and transition lengths are not updated when a curve radius or design
speed is changed because those changes make superelevation data invalid. In those situations a warning is displayed
and the curve is displayed as “out of date” in the Superelevation Curve Manager. Click Recalculate to recalculate
superelevation.
The following illustrations show the dynamic updates:

After grip edits:
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Superelevation Command Reference
You can use the following commands when you work with superelevation.
The following table lists the superelevation-related AutoCAD Civil 3D commands and briefly describes their
functionality.
For more information about a command, follow the link in the Description column.
Command

Description

CalcEditSuperelevation

Displays the Superelevation Wizard or the
Superelevation Curve Manager dialog box.
(page 1098)

CreateSuperelevationView

Displays the Create Superelevation View
dialog box. (page 1107)
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Profiles

26

The main purpose of a profile is to show surface elevations along a horizontal alignment.
Use profiles to visualize the terrain along a route of interest or across a particular region.

Understanding Profiles
There are several types of profiles: surface profiles, layout profiles, superimposed profiles, quick profiles, and
corridor profiles.
■

A surface profile—often called an existing ground (EG) profile—is extracted from a surface, showing the
changes in elevation along a particular route.

■

A layout profile, by contrast, is a designed object that shows the proposed elevation changes to be
constructed. The layout profile—often called a design profile or finished grade (FG) profile—is typically
used for a roadway or other graded site. For a road, the layout profile can include slopes and curves that
are designed for safe driving at a particular speed.

■

A superimposed profile is a profile of an alignment superimposed onto profile views of different alignments.
These profiles are always dynamic and update when changes are made in the originating profile/alignment.

■

A quick profile is a temporary object that shows the elevations along any existing line or series of selected
points.

■

A corridor profile is created from a corridor feature line, such as an edge of pavement. This profile is
displayed on the profile view of the baseline alignment from which it is derived.

Layout profiles use two types of curves: crest curves and sag curves. Crest curves are placed on hilltops or
wherever the grade changes to a lesser value. There are three types of crest curves: a positive to negative
grade transition, positive to positive, and negative to negative:
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Sample Crest Curves

Sag curves are placed in valleys or wherever the grade changes to a greater value. There are three types of
sag curves: a negative to positive grade transition, negative to negative, and positive to positive:

Sample Sag Curves

An offset profile is another type of profile commonly used in road design. While the road centerline provides
the main horizontal alignment, various lines offset from the centerline mark other linear features, such as
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edges of pavement, ditches, and sidewalks. Profiles along these offsets can be analyzed in relation to each
other and to the centerline profile for a more complete view of the surface along a corridor. Offset profiles
are created and managed independently from any offset alignments that may exist, though both can be
used together in the design process.
When you create a surface profile, you specify whether it is dynamic or static. A dynamic profile automatically
changes if the surface elevation changes. Such changes can occur if you move the horizontal alignment or
edit the surface. A static profile represents the terrain at the time it is created, and does not respond to
changes in the surface.
Profiles are displayed as graphed lines in a grid known as a profile view. Typically, you create a profile view
to display surface profiles. Then, you draw layout profiles on the same grid to show elevation differences
between the two surfaces. Profiles can be created and saved in a drawing, and displayed later when a profile
view is created.
You can use a quick profile to view surface elevations along an object or through a selection of points. This
quick profile is for temporary use and is not saved in the drawing. For more information, see Creating a
Quick Profile (page 1153).

The Profile View Object
Use a profile view to display profiles as graphed lines on a grid.
When you create a profile view, you specify which existing profiles to display on the grid. Use these profiles
as a reference for drawing new layout profiles on the grid.
A profile view can include one or more related profiles, along with multiple data bands along the X-axis,
above or below the grid. Data bands annotate the profiles with stationing, elevation, horizontal geometry,
and other data that assists engineering analysis.

Profile view displaying surface and layout profiles
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Closer view of surface and layout profiles

You typically use a profile view to display several profiles along a proposed route for a road, pipe, fence, or
a similar structure. Use profile views to compare elevations of several surfaces or design profiles along the
alignment.
Within a profile view, you can superimpose the profile of another alignment. For example, in the profile
view for a road, you can superimpose the profile of a culvert that occupies the same corridor. By superimposing
a profile, you can analyze culvert elevations in relation to the same alignment stations used for the road
surfaces.
A profile view can include projected objects (page 2780) from the drawing that you want to see in relation to
a profile. See Adding Projected Objects to a Profile View (page 1219) for more information.
If you design a road, pipeline, or a similar structure across the landscape, and you want to compare the
feasibility of several possible routes, a profile view of each route can help with the comparison.
AutoCAD Civil 3D allows profiles to split to fit within a specified profile view height and displayed in either
single or multiple profile views. See Working with Profile Views (page 1206) for more information.

Profile Object Relationships
A profile object is the child of a horizontal alignment. The horizontal alignment must exist to define the
route of a profile across the terrain.
If you edit a horizontal alignment after creating dynamic surface profiles along its length, the profiles
automatically change.
A profile view object is also dependent on a horizontal alignment. The length of the alignment can control
the horizontal extents of the profile view grid, and the alignment stationing controls the annotation of
horizontal axes. The vertical extents of the profile view have an optional relationship with one of the profiles
in the profile view. You can set the vertical extents to a fixed value, but normally they are dynamically
linked to one of the profiles. The dynamic link ensures that the profile view always has several grid lines
above and below the profiles.
A profile view can contain projected objects such as points, feature lines, or AutoCAD blocks. These objects
exist in plan view and are projected into a profile view so that you can visualize them in relation to a profile.
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Profiles Collection (Prospector Tab)
Use the Profiles collection to access profiles in drawings.
As profiles are created, they are displayed as named objects in the Toolspace Prospector tab under the Profiles
collection.
Right-click the Profiles collection to do any of the following:
■

Export site data to LandXML. (page 1884)

■

Recursively refresh the Profiles collection and list view.

If one or more profiles exist in the current drawing, expand the Profiles collection in Toolspace on the
Prospector tab. The Profiles collection displays the names of all profiles associated with a particular horizontal
alignment, as well as a tabular list of the profiles.
Right-click an individual profile name to do any of the following:
■

Review or change properties (page 1119) of the profile.

■

Export profile data to LandXML (page 1884).

■

Delete the profile from the drawing.

■

Refresh the display of the profile in the Prospector tab.

Profile Views Collection (Prospector Tab)
Use the Profile Views collection to access profile views in drawings.
As profile views are created, they are displayed as objects under the Profile Views collection.
Right-click the Profile Views collection to refresh the Profile Views collection and list view.
If one or more profile views exist in the current drawing, expand the Profile Views collection in Toolspace
on the Prospector tab. The Profile Views collection displays the names of all profile views associated with a
particular horizontal alignment, as well as a tabular list of the profile views.
Right-click an individual profile view name to:
■

Review or change properties (page 1119) of the profile view.

■

Delete the profile view.

■

Refresh the display of the profile view in the Prospector tab.

Profile Collection (Settings Tab)
Use the Profile collection on the Settings tree to manage profile settings, profile styles, profile label styles,
and profile command settings.
Right-click the Profile collection to do any of the following:
■

Edit the profile feature settings.

■

Edit the profile label style defaults.

■

Refresh the display of the Profile collection in the Prospector tab.
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Expand the Profile collection to display and edit the styles and command settings that are available for
profiles.
For more information about... See...
Profile Settings

Profile Settings (page 1120)

Profile Styles

Profile Styles (page 1122)

Profile Label Styles

Managing Profile Label Styles (page 1129)

Profile Commands

Profile Command Reference (page 1221)

Profile View Collection (Settings Tab)
Use the Profile View collection on the Settings tree to manage settings, styles, label styles, band styles, and
command settings for profile views.
Right-click the Profile View collection to do any of the following:
■

Edit the profile view feature settings

■

Edit the profile view label style defaults

■

Refresh the display of the Profile Views collection in the Prospector tab

Expand the Profile Views collection to display and edit the styles and command settings that are available
for profile views.
For more information about... See...
Profile View Styles

Profile View Styles (page 1124)

Profile View Label Styles

Profile Labels and Label Styles (page 1127)

Data Band Styles

Profile View Band Styles (page 1133)

Profile View Commands

Profile Command Reference (page 1221)

Profile Shortcut Menu
Use the profile shortcut menu for quick access to common functions.
When you right-click a profile in the drawing, the shortcut menu is displayed.
The following table explains the items on the menu that are specific to profiles. Other selections on the
menu are standard AutoCAD options.
Use this menu item... To...
Profile Properties

Open the Profile Properties Dialog Box (page 2423) for the selected profile.

Edit Profile Style

Open the Profile Style Dialog Box (page 2426).

Edit Profile Geometry

Open the Profile Layout Tools (page 2419).

Superimposed Options

Open the Superimpose Profile Options Dialog Box (page 2443).
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Use this menu item... To...
Available for superimposed profiles only.
Edit Labels

Open the Label Set Dialog Box (page 2206)

Inquiry

Open the Inquiry Tool Dialog Box (page 2760) with a Profile
inquiry selected

Profile View Shortcut Menu
Use the profile view shortcut menu for quick access to common functions.
When you right-click a profile view grid in the drawing, the shortcut menu is displayed.
The following table explains the items on the menu that are specific to profile views. Other selections on
the menu are standard AutoCAD options.
Use this menu item...

To...

Profile View Properties

Open the Profile View Properties Dialog Box (page 2427).

Edit Profile View Style

Open the Profile View Style Dialog Box (page 2435).

Inquiry

Open the Inquiry Tool Dialog Box (page 2760) with a
Profile inquiry selected.

Projected Object Shortcut Menu
Use the shortcut menu for a projected object for quick access to object properties.
When you right-click a projected object (page 2780)in a profile view, the shortcut menu is displayed. The only
menu selection specific to the projection is Projection Object Properties. It opens the Projections tab (page
2433) of the Profile View Properties dialog box.

Profile Properties
When you create a profile, you set the properties, including its name, style, station range, and labeling.
Use the Profile Properties Dialog Box (page 2423) to review or edit the name and other information for an
existing profile. The three tabs correspond to general types of properties: information, profile data, and
design criteria.
See also:
■

Setting Profile Properties (page 1136)

Profile View Properties
By specifying properties, you control the content and format of a profile view.
Set these properties when you create a profile view. At any time, you can use the Profile View Properties
Dialog Box (page 2427) to make changes. The tabs on this dialog box correspond to general types of properties:
Information, Stations, Elevations, Profiles, Bands, and Hatch. Additional tabs for Projections and Pipe
Networks appear if the profile view includes these objects.
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See also:
■

Setting Profile View Properties (page 1137)

Settings for Profiles and Profile Views
You can review and edit the default style and name format settings for profiles and profile views. You can
also review and edit default settings for profile and profile view commands.
Settings are handled in a standard way throughout AutoCAD Civil 3D through the Settings tree at three
levels: drawing, feature, and command. For more information, see Understanding Settings (page 77).

Profile Settings
You can review and edit the default style and name format settings for profiles and profile commands.
Settings are handled in a standard way throughout AutoCAD Civil 3D, and accessed in Toolspace on the
Settings tab. Control settings at three levels: the drawing, the feature, and the command. For more
information, see Understanding Settings (page 77).
On the Settings tab, use the Profile collection shortcut menu to establish default settings for all profiles. At
this level, you can either change profile-specific settings or override the drawing ambient settings.
Use the Profile Commands collection under the Profile collection to change settings for a specific command.
At this level, you can either change settings for profile commands or override the settings at the profile
feature level.
NOTE Overrides to the drawing ambient settings at the Profile collection level and the Profile Command collection
level affect only the specified level. The drawing level settings are not changed. For more information, see The
Commands Collections (Settings Tree) (page 114).
This section describes only the default styles and name format settings for profile commands. It does not
cover the drawing ambient settings, even though these settings are displayed in the Edit Feature Settings
dialog box. For more information about the drawing ambient settings, see Specifying Drawing Settings (page
79).
For more information about profile view settings, see Profile View Settings (page 1121).
To change profile settings
1 In Toolspace, on the Settings tab, do one of the following:
■

Right-click the Profile collection and click Edit Feature Settings

■

In the Profile collection, open the Commands folder, right-click the command for which you want
to change settings. Click Edit Command Settings.

In the Edit Feature (or Command) Settings dialog box, profile feature-level settings are marked with
. Profile command-level settings are marked with

.

2 Expand the default styles and default name format to see the current settings.
3 In the Value column, click the entry you want to change. A small Browse button appears on the right
side of the cell.
4 Click the Browse button to open a dialog box where you can modify the value.
5 In the Edit Feature (or Command) Settings dialog box, click OK.
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Quick Reference
Toolspace Shortcut Menu
Settings tab: right-click Profile collection ➤ Edit Feature Settings
Settings tab: Profile ➤ Commands ➤ right-click command name ➤ Edit Command Settings

Profile View Settings
You can review and edit the default style and name format settings for profile views and profile view
commands.
Settings are handled in a standard way throughout AutoCAD Civil 3D, and accessed in Toolspace on the
Settings tab. You can control settings at three levels: the drawing, the feature, and the command. For more
information, see Understanding Settings (page 77).
On the Settings tab, use the Profile View collection shortcut menu to establish default settings for all profile
views. At this level, you can change settings specific to profile views, which will override the drawing ambient
settings for profile view.
Use the Commands collection under the Profile View collection to change settings for a specific command.
At this level, you can change settings specific to profile view commands or override the settings at the level
of the profile view feature.
NOTE Overrides to the drawing ambient settings at the Profile View collection level and the Profile View Command
collection level affect only the specified level. The drawing level settings are not changed. For more information,
see The Commands Collections (Settings Tree) (page 114).
This section describes only the default styles and name format settings for profile view commands. It does
not cover the drawing ambient settings, even though these settings are displayed in the Edit Feature Settings
dialog box. For more information about the drawing ambient settings, see Specifying Drawing Settings (page
79).
For more information about profile settings, see Profile Settings (page 1120).
To change profile view settings
1 In Toolspace, on the Settings tab, do one of the following:
■

Right-click the Profile View collection and click Edit Feature Settings

■

In the Profile View collection, open the Commands folder, right-click the command for which you
want to change settings. Click Edit Command Settings.

In the Edit Feature (or Command) Settings dialog box, profile view feature-level settings are marked
with

. Profile view command-level settings are marked with

.

2 Expand the default styles and default name format to see the current settings.
3 In the Value column, click the entry you want to change. A small Browse button is displayed on the
right side of the cell.
4 Click the Browse button to open a dialog box where you can modify the value.
5 In the Edit Feature (or Command) Settings dialog box, click OK.

Profile View Settings | 1121

Quick Reference
Toolspace Shortcut Menu
Settings tab: right-click Profile View collection ➤ Edit Feature Settings
Settings tab: Profile View ➤ Commands ➤ right-click <command name> ➤ Edit Command Settings
Dialog Box
Edit Feature Settings - Profile View Dialog Box (page 2409)

Styles and Display of Profiles and Profile Views
Styles control the way a profile and profile view are displayed in a drawing. Profiles have label styles that
control the appearance and behavior of their labels in a drawing.

Profile Styles
You can use styles to control profile appearance in model, profile, and section views.
Use the Toolspace Settings tree to manage profile styles. All objects have an object style collection on the
Settings tab that you can use to create, edit, copy, and delete the styles for that object. For more information,
see The Object Style Collection (Settings Tree) (page 111).
To examine the properties of an existing style, follow the procedure for Creating and Editing Profile Styles
(page 1122).
A profile object can reference two style types:
■

Profile Style. This style controls the visibility of profile components and their rendering in both 2 and
3 dimensions.

■

Profile Label Style. This style controls the appearance and content of labels for stations, lines, curves,
and geometry points along the profile. For more information, see Profile Labels and Label Styles (page
1127).

Creating and Editing Profile Styles
Use the Toolspace Settings tab to create or edit a profile style.
Create a style by adjusting the default settings, or by copying an existing style and changing its properties
to suit your requirements.
You can choose markers for key geometry points on layout profiles.
Set the style properties on the following tabs in the Profile Style dialog box:
■

Information. Specify the style name and description. See also Information Tab (Style Dialog Box) (page
2017).

■

Design. Specify the tessellation distance to control the accuracy of rendering profile curves in 3D view.

■

Markers. Specify the markers for locations on layout profiles such as PVI points, pass-through points,
and profile start and end.

■

Display. Specify the display attributes of profile components, including visibility, layer, color, linetype,
line weight, linetype scale, and plot style. See also Display Tab (Style Dialog Box) (page 2017).

■

Summary. Provides a concise display of the style properties. See also Summary Tab (Style Dialog Box)
(page 2020).
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TIP Any style changes you make apply to all existing profiles in the drawing that use the style. To change the style
of some profiles but not all, consider creating a separate style.
See also:
■

Profile Style Dialog Box (page 2426)

To create a profile style
1 In Toolspace, on the Settings tab, expand the Profile Styles collection. Right-click and click New.
2 In the Profile Style dialog box (page 2426), specify the name of the style and other settings as required.
3 Click OK.
To copy a profile style
1 In Toolspace, on the Settings tab, expand the Profile Styles collection. Identify the style you want to
copy as a basis for the new style.
2 Right-click the style name and click Copy.
3 In the Profile Style dialog box (page 2426), change the name of the style and other settings as required.
4 Click OK.
To edit a profile style
1 In Toolspace, on the Settings tab, expand the Profile Styles collection. Identify the style you want to
edit.
2 Right-click the style name and click Edit.
3 In the Profile Style dialog box (page 2426), change settings as required.
4 Click OK.

Quick Reference
Ribbon
Click the profile. Click Profile tab ➤ Modify Profile panel ➤ Profile Properties drop-down ➤ Edit Profile
Style
Toolspace Shortcut Menu
Create: Settings tab, right-click Profile Styles collection ➤ New
Copy: Settings tab, Profile ➤ Profile Styles ➤ right-click <style name> ➤ Copy
Edit: Settings tab, Profile ➤ Profile Styles ➤ right-click <style name> ➤ Edit
Command Line
CreateProfileStyle
EditProfileStyle
Dialog Box
Profile Style (page 2426)
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Selecting a Different Profile Style
Change the appearance of a profile by changing its style.
The profile style controls the visibility of profile components and their rendering in both 2 and 3 dimensions.
To select a different profile style
1 Click the profile. Click Profile tab ➤ Modify Profile panel ➤ Profile Properties drop-down ➤ Profile
Properties

.

2 In the Profile Properties dialog box, on the Information tab (page 2423), select a style from the Object
Style list.
3 Click OK.

Quick Reference
Ribbon
Click the profile. Click Profile tab ➤ Modify Profile panel ➤ Profile Properties drop-down ➤ Profile Properties

Toolspace Prospector Tab Shortcut Menu
Alignments ➤ Profiles collection ➤ right-click <profile name> ➤ Properties
Drawing Window Shortcut Menu
Right-click profile object ➤ Profile Properties
Command Line
EditProfileProperties
Dialog Box
Profile Properties Dialog Box (page 2423)

Profile View Styles
You can use profile view styles to control the appearance of the graph that displays a profile.
Use the Toolspace Settings tab to manage profile view styles. All objects have an object style collection on
the Settings tab that you use to create, edit, copy, and delete the styles for that object. For more information,
see The Object Style Collection (Settings Tree) (page 111).
To examine the properties of an existing style, follow the procedure for creating and editing profile view
styles (page 1125).
A profile view object can reference the following style types:
■

Profile View Style. This style controls the format of the graph on which the profiles are displayed, as well
as the title and annotations on the axes. For more information, see Creating and Editing Profile View
Styles (page 1125).

■

Label Style. This style controls the format of two types of manually placed labels along the profile: station
elevation and depth (elevation difference and/or grade between any two points). For more information,
see Profile Labels and Label Styles (page 1127).
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■

Band Style. This style controls the format of data bands above and below the profile view. Data bands
show station elevations, horizontal geometry, vertical geometry, superelevation, sectional data, and pipe
data. For more information, see Profile View Band Styles (page 1133).
For convenience, you can define a group of band styles as a band style set (page 1135). Then, apply the
entire set of band styles to a profile view with a single action, rather than applying each band style
separately.

■

Projection Style. This multipurpose style controls the appearance of objects projected into profile views
or section views.

■

Shape Style. This multipurpose style controls the appearance of hatching for cut and fill areas between
surfaces and profiles.

Creating and Editing Profile View Styles
Use the Toolspace Settings tab to create or edit a profile view style.
You can choose which elements to display, and change the appearance of the graph, grid, title, axes ticks,
and text.
The main properties are set on the following tabs in the Profile View Style dialog box:
■

Information. Specify style name and description. See also Information Tab (Style Dialog Box) (page 2017).

■

Graph. Specify profile view direction and vertical scale factor

■

Grid. Specify grid clipping, padding, and offset options

■

Title Annotation. Specify content and appearance of titles for the overall profile view and individual axes

■

Horizontal Axes. Specify ticks, tick justification, tick and grid spacing, and annotation of the horizontal
axes

■

Vertical Axes. Specify ticks, tick justification, tick and grid spacing, and annotation of the vertical axes

■

Display. Specify display attributes for profile view components, including visibility, layer, color, linetype,
line weight, linetype scale, and plot style. See also Display Tab (Style Dialog Box) (page 2017).

■

Summary. Provides a concise display of the style properties. See also Summary Tab (Style Dialog Box)
(page 2020).

Before editing a style to change its properties, remember that any changes you make apply to all profile
views that use the style. To change the style of some profile views but not all, consider creating a separate
style.
See also:
■

Profile View Style dialog box (page 2435)

To create a profile view style
1 In Toolspace, on the Settings tab, expand the Profile View Styles collection. Right-click and click New.
2 In the Profile View Style dialog box (page 2435), specify the name of the style and other settings as required.
3 Click OK.
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To copy a profile view style
1 In Toolspace, on the Settings tab, expand the Profile View Styles collection. Identify the style you want
to copy as a basis for the new style.
2 Right-click the style name and click Copy.
3 In the Profile View Style dialog box (page 2435), change the name of the style and other settings as
required.
4 Click OK.
To edit a profile view style
1 In Toolspace, on the Settings tab, expand the Profile View Styles collection. Identify the style you want
to edit.
2 Right-click the style name and click Edit.
3 In the Profile View Style dialog box (page 2435), change settings as required.
4 Click OK.

Quick Reference
Toolspace Shortcut Menu
Create: Settings tab, right-click Profile View Styles ➤ New
Copy: Settings tab, Profile View ➤ Profile View Styles ➤ right-click <style name> ➤ Copy
Edit: Settings tab, Profile View ➤ Profile View Styles ➤ right-click <style name> ➤ Edit
Command Line
CreateProfileViewStyle
EditProfileViewStyle
Dialog Box
Profile View Style (page 2435)

Creating and Editing Projection Styles
Use these general styles to control the display of AutoCAD objects projected into profile views and section
views.
Within a style, the settings for the appearance of an object type in profile views are independent from the
settings for section views.
The appearance of AutoCAD Civil 3D projected objects is controlled by styles for the particular object type:
points, feature lines, and survey figures.
See also:
■

Display Tab (Point Style Dialog Box) (page 2357)

■

Display Tab (Feature Line Style Dialog Box) (page 2120)

■

Display Tab (Survey Figure Style Dialog Box) (page 2709)
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To create a projection style
1 In Toolspace, on the Settings tab, expand the General ➤ Multipurpose Styles collection. Right-click
Projection Styles and click New.
2 In the Projection Styles dialog box (page 2023), specify the name of the style and other settings as required.
3 Click OK.
To copy a projection style
1 In Toolspace, on the Settings tab, expand the General ➤ Multipurpose Styles collection. Identify the
style you want to copy as a basis for the new style.
2 Right-click the style name and click Copy.
3 In the Projection Styles dialog box (page 2023), change the name of the style and other settings as required.
4 Click OK.
To edit a projection style
1 In Toolspace, on the Settings tab, expand the General ➤ Multipurpose Styles collection. Identify the
style you want to edit.
2 Right-click the style name and click Edit.
3 In the Projection Styles dialog box (page 2023), change settings as required.
4 Click OK.

Quick Reference
Ribbon
Click a projected object. Click Projected Object tab ➤ Modify Projected Object panel ➤ Projection Properties
drop-down ➤ Edit Style
Toolspace Shortcut Menu
Create: Settings tab, expand General ➤ Multipurpose Styles ➤ right-click Projection Styles ➤ New
Copy: Settings tab, expand General ➤ Multipurpose Styles ➤ Projection Styles ➤ right-click <style
name> ➤ Copy
Edit: Settings tab, expand General ➤ Multipurpose Styles ➤ Projection Styles ➤ right-click <style name>
➤ Edit
Command Line
EditProjectionStyle

Profile Labels and Label Styles
You can label profiles and profile views using different label types.

Profile labels
When you create a layout profile, you can automatically label it using label styles you specify in the Create
Profile - Draw New dialog box (page 2394). For other types of profiles, add labels using the Edit Labels command.
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Profile label styles can be configured to mark any of the following standard points along the profile:
■

Major and minor stations of the parent horizontal alignment

■

Horizontal geometry points

■

Grade breaks

■

Lines

■

Sag curves

■

Crest curves

You can save profile label styles as a profile label set and apply the labels to a profile as a group.
See also:
■

Staggering Profile and Section Labels (page 1707)

Profile view labels
After creating a profile view, use the Add Labels dialog box (page 2208) to manually add labels to particular
points of interest anywhere on the profile view grid. These labels can be of three types:
■

Station Elevation, showing the station and elevation of a point.

■

Depth, showing the elevation difference between two points, and other data such as slope and distance.

■

Projection, showing the station and elevation of a projected object (page 2780).

Profile view bands
Place data bands along the top or bottom of a profile view grid to annotate the various profile lines with
station and elevation data, vertical or horizontal geometry points, or superelevation, sectional, or pipe
network data. You can also group a set of commonly used data bands into a band set that can be applied to
a profile view as a single selection.
The topics in this section describe unique properties of profile labels. For a general overview of labels, see
Understanding Labels (page 1646).

Editing Profile Labels
Edit the set of labels used on a profile line.
Edit the settings for each label type, and import or save label sets.
Editing the labels on a profile does not affect instances of the same profile in other profile views.
Profile labels that display curve and tangent dimensions have editing grips that you can use to move labels.
Use the Label Set Dialog Box (page 2206)to numerically edit the position of labels, change the style of a label,
or save your changes as a label style.
Label styles ensure convenience and consistency. A particular profile may require different labels. After the
labels are edited, save the modified label set for reuse with other profiles.
See also:
■

Staggering Profile and Section Labels (page 1707)
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To edit profile labels
1 Do one of the following:
■

Click Annotate tab ➤ Labels & Tables panel ➤ Add Labels menu ➤ Add/Edit Profile Labels
a profile in the drawing to open the Label Set dialog box.

■

Click the profile line you want to edit. Right-click and click Edit Labels

. Select

2 In the Label Set Dialog Box (page 2206), review the existing labels and their attributes. Do any of the
following:
■

Add or remove labels of any type.

■

Change the style for a label type.

■

Import a standard set of labels.

■

Save your modified labels as a set to use again.

■

Stagger labels to avoid label collisions. For more information, see Staggering Profile and Section
Labels (page 1707).

3 Click Apply to see your changes on the profile line.
4 Click OK to save the changes.

Quick Reference
Ribbon
Click Annotate tab ➤ Labels & Tables panel ➤ Add Labels menu ➤ Add/Edit Profile Labels
Menu
Click Profiles menu ➤ Add Profile View Labels ➤ Add/Edit Profile Labels.
Object Shortcut Menu
Click profile, right-click ➤ Edit Labels
Command Line
EditProfileLabels
Dialog Box
Label Set Dialog Box (page 2206)

Managing Profile Label Styles
Use the Toolspace Settings tab to create and edit profile label styles.
The types of profile label styles that you can create:
This type of profile label
style...

Labels...

Major Stations

Stations along the profile at major intervals

Minor Stations

Stations along the profile at minor intervals
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This type of profile label
style...

Labels...

Horizontal Geometry Points

Locations where the horizontal alignment geometry
changes, such as the start of a curve

Lines

Lines that form the tangents of a profile

Grade Breaks

Locations where the vertical grade changes

Sag Curves

Sag curves in the profile

Crest Curves

Crest curves in a profile

When you need a new profile label style, it is usually easiest to find an existing style that is similar to what
you need, then copy it and make the required changes. You can also create a style and change whatever
default values are not suitable.
You can group several profile label styles into a label set. Apply the label set to a profile as a single setting.
An existing label set can be edited or copied to create a new one.
Label spacing is an important design consideration for surface profiles. Wherever they cross uneven surfaces,
this type of profile can have many short tangents and closely spaced grade breaks. As a result, labels for these
features can overlap and become unreadable when they require more horizontal space than is available. To
address this condition for one label type, the Label Set Dialog Box (page 2206)provides a weeding setting that
suppresses grade break labels within a specified distance of each other.
Profile label styles are created and edited using the Label Style Composer. For more information, see Label
Style Composer Dialog Box (page 2180).
To copy a profile label style
1 In Toolspace, on the Settings tab, expand the Profile, Label Styles, and specific label style collection.
2 Right-click the name of the label style you want to copy, and click Copy. The Label Style Composer
dialog box (page 2180) is displayed.
3 Change settings as required to produce the style you want. Specify a name for the style.
4 Click OK to save the style.
To edit a profile label style
1 In Toolspace, on the Settings tab, expand the Profile and Label Styles collections. Click a specific label
style collection.
2 Right-click the name of the label style you want to edit and click Edit. The Label Style Composer dialog
box (page 2180) is displayed.
3 Change settings as required.
4 Click OK to save the style.
To create a profile label style
1 In Toolspace, on the Settings tab, expand the Profile and Label Styles collections.
2 Right-click the collection of label style you want to create and click New. The Label Style Composer
dialog box (page 2180) is displayed.
3 Change settings as required. Specify a name for the new style.
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4 Click OK to save the style.
To create a profile label set
1 In Toolspace, on the Settings tab, expand the Profile, Label Styles, Label Sets collections.
2 Do one of the following:
■

Right-click the Label Sets collection and click New.

■

To copy an existing set as a starting point, right-click the set and click Copy

3 In the Label Set dialog box (page 2206), on the Information tab, specify a name for the label set. Optionally,
specify a description.
4 On the Labels tab (page 2207), specify the individual labels to include in the set, and settings for each
one.
5 Click OK to save the new set.

Managing Profile View Label Styles
Use the Settings tab on Toolspace to create and edit profile view label styles.
Profile view labels are added manually to mark points of interest on a profile view. The following types of
profile view labels are available:
■

Station Elevation labels show the elevation and station value at a specified point anywhere in the profile
view.

■

Depth labels show the elevation difference between two specified points, and other selected data, such
as slope and distance.

■

Projection labels show data about a projected object (page 2780), such as the elevation and station value.

Create and edit the styles for profile view labels using the Label Style Composer.
If a profile view contains projected objects, label styles for these objects are managed as feature settings for
the profile view object.
See also:
■

Label Style Composer Dialog Box (page 2180)

■

Edit Feature Settings - Profile View Dialog Box (page 2409)

To copy a profile view label style
1 In Toolspace, on the Settings tab, expand the Profile View, Label Styles, and specific label style collections.
2 Right-click the name of the label style you want to copy. Click Copy. The Label Style Composer dialog
box (page 2180) is displayed.
3 Change settings as required. Specify a name for the style.
4 Click OK to save the style.
To edit a profile view label style
1 In Toolspace, on the Settings tab, expand the Profile View, Label Styles, and specific label style collections.
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2 Right-click the name of the label style you want to edit. Click Edit. The Label Style Composer dialog
box (page 2180) is displayed.
3 Change settings as required.
4 Click OK to save the style.
To create a profile view label style
1 In Toolspace, on the Settings tab, expand the Profile View, Label Styles, and specific label style collections.
2 Right-click the name of the label style you want to create, and click New. The Label Style Composer
dialog box (page 2180) is displayed.
3 Change settings as required. Specify a name for the new style.
4 Click OK to save the style.

Adding Profile View Labels
Manually place profile view labels at points of interest anywhere on a profile view.
You can label any point to show station and elevation, to show the relationship between two points, or to
mark the location of a projected object (page 2780).
Station Elevation labels show the elevation and station value at any specified point in the profile view.
Depth labels show the elevation difference between two specified points, and other selected data, such as
slope and distance.
Projection labels show information about an object projected into the profile view, such as its elevation and
station.
Projection labels cannot be used with projected feature lines or 3D polylines that appear as lines in a profile
view.
TIP To label points on a feature line projected into a profile view, use Station Elevation or Depth labels.
To add a profile view station elevation label
1 Click Annotate tab ➤ Labels & Tables panel ➤ Add Labels menu ➤ Profile View ➤ Station Elevation
.
2 Select the station and elevation to label.
To add a profile view depth label
1 Click Annotate tab ➤ Labels & Tables panel ➤ Add Labels menu ➤ Profile View ➤ Depth

.

2 Click any two locations. Labels are displayed, showing the depths, grade, or other data about the
relationship between the two points.
To add a projection label
➤

Select the projected object. Right-click and click Add Label.
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Quick Reference
Ribbon
Click Annotate tab ➤ Labels & Tables panel ➤ Add Labels menu ➤ Profile View ➤ Add Profile View Labels

Click Annotate tab ➤ Labels & Tables panel ➤ Add Labels menu ➤ Profile View ➤ Station Elevation
Click Annotate tab ➤ Labels & Tables panel ➤ Add Labels menu ➤ Profile View ➤ Depth
Click Projected Object tab ➤ Labels panel ➤ Add Object Labels
Menu
Click Profiles menu ➤ Add Profile View Labels ➤ Add Profile View Labels
Click Profiles menu ➤ Add Profile View Labels ➤ Station Elevation
Click Profiles menu ➤ Add Profile View Labels ➤ Depth
Command Line
AddProfileViewLabels
AddProfileViewDepthLbl
AddProfileViewStaElevLbl
AddProjectionLabel

Profile View Band Styles
Use the Toolspace Settings tab to create and edit profile view band styles.
Profile view band styles control the location and content of data bands.
Use the Profile View Properties dialog box (page 2427) to specify which data band styles to use and where to
place them on the profile view.
Data band labels are label objects that can be manipulated like other AutoCAD Civil 3D label objects. For
more information, see Editing Data Band Labels (page 1708).
The types of data band styles that you can create:
This type of data band
style...

Provides this type of annotation...

Profile Data

Stations, elevation of one or two profiles at each station,
and elevation difference between two profiles at the
station
NOTE The individual geometry points to label can be
specified with the Profile Data band type. For more information, see Adding Data Bands to a Profile View (page
1215).

Vertical Geometry

Geometric details of vertical tangents and curves

Horizontal Geometry

Geometric details of horizontal tangents, curves, and
spirals

Superelevation

Critical transition stations and transition diagrams for
the superelevation at curves
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This type of data band
style...

Provides this type of annotation...

Sectional Data

Sampled station, material, typical section details, incremental distance and volume, balanced volume information

Pipe Data

Location and key dimensions of pipe network parts, offset, elevation, direction

When you need a new data band style, it is usually easiest to find an existing style that is similar to what
you need, then copy it and make the required changes. You can also create one and change whatever default
values are not suitable.
The notes in this section describe what is unique to profile data bands. For a general overview of labels, see
Understanding Labels (page 1646).
See also:
■

Adding Data Bands to a Profile View (page 1215)

■

Staggering Data Band Labels (page 1707)

To copy a data band style
1 In Toolspace, on the Settings tab, expand the Profile View, Band Styles, and specific band style collections.
2 Right-click the name of the band style you want to copy. Click Copy. The Profile Data Band Style Dialog
Box (page 2414) is displayed.
3 On the Information tab (page 2414), enter a new name for the style. Optionally, add a description.
4 On the Band Detail tab (page 2414), compose the band title and modify any settings for the band title
and layout.
5 On the right side of the Band Details tab, select a label location. Click Compose Label to define the
property fields annotated by the band. For more information, see Layout Tab (Label Style Composer
Dialog Box) (page 2183).
6 On the Display tab (page 2416), modify any display settings for the band components.
7 On the Summary tab, review all settings for the style. Make any corrections.
8 Click OK to save the style.
To edit a data band style
1 In Toolspace, on the Settings tab, expand the Profile View, Band Styles, and specific band style collections.
2 Right-click the name of the band style you want to change. Click Edit. The Profile Data Band Style
dialog box (page 2414) is displayed.
3 Review the settings on the Information tab (page 2414), the Band Details tab (page 2414), and the Display
tab (page 2416). Make any changes.
4 On the Summary tab, review all settings for the style. Make any corrections.
5 Click OK to save the style.
To create a data band style
1 In Toolspace, on the Settings tab, expand Profile View and Band Styles.
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2 Right-click the name of the band type for which you want to create a style. Click New. The Profile Data
Band Style dialog box (page 2414) is displayed.
3 On the Information tab (page 2414), enter a new name for the style. Optionally, add a description.
4 On the Band Details tab (page 2414), compose the band title and modify any settings for the band title
and layout.
5 On the right side of the Band Details tab, select a label location and click Compose Label to define the
property fields annotated by the band. For more information, see Layout Tab (Label Style Composer
Dialog Box) (page 2183).
6 On the Display tab (page 2416), modify any display settings for the band components.
7 On the Summary tab, review all settings for the style. Make any corrections.
8 Click OK to save the style.

Quick Reference
Toolspace Shortcut Menu
Settings tab: Profile View ➤ Band Styles
Dialog Box
Profile Data Band Style (page 2414)

Profile View Band Sets
Use a data band set to manage a group of band styles that you want to apply to other profile views.
See also:
■

Adding Data Bands to a Profile View (page 1215)

To create a band set
1 In Toolspace, on the Settings tab, expand Profile View and Band Styles.
2 Right-click the Band Sets folder, and click New. The Band Set dialog box (page 2389) is displayed.
3 On the Information tab (page 2389), enter a name and optional description for the band style set.
4 On the Bands tab (page 2390), in the List Of Bands area, specify the Location where you want to place
the bands.
5 In the Band Type field, select the type of band to add to the set.
6 In the Select Band Style field, select an existing band style or use one of the style buttons to create a
style.
7 Click Add to add the band type to the List Of Bands.
8 Repeat steps 4 to 7 to add more bands to the set.
9 Use the three band position buttons on the right side of the List of Bands to put the data bands in the
desired order and to delete unwanted bands.
10 Click OK to save the band style set.
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To edit a band set
1 In Toolspace, on the Settings tab, expand the Profile View, Band Styles, and Band Sets collections.
2 Right-click the name of the set you want to edit. Click Edit. The Band Set dialog box (page 2389) is
displayed.
3 Change content as required. Click OK to save the modified set.
To copy a band set
1 In Toolspace, on the Settings tab, expand the Profile View, Band Styles, and Band Sets collections.
2 Right-click the name of the set you want to copy. Click Copy. The Band Set dialog box (page 2389) is
displayed.
3 On the Information tab (page 2389), enter a new name. Optionally, enter a description.
4 Change other content as required. Click OK to save the new set.

Properties of Profiles and Profile Views
Several aspects of profile data and display are controlled by properties.

Setting Profile Properties
Set properties of individual profiles either from the Toolspace Prospector tab, or from a profile view.
You can edit some of the properties, including those for design criteria.
Profile properties are organized on three tabs of the Profile Properties (page 2423) dialog box: information,
profile data, and design criteria.

Information
The profile name, description, and object style. By changing the style here you can instantly change the
displayed appearance for the profile.

Profile Data
Each profile is one of the following types: surface, layout, superimposed, or corridor.
A surface profile can be either static or dynamic. The elevation data in a dynamic profile changes to respond
to changes in the parent alignment or surface. A static profile displays the elevation data at a particular time,
and does not respond to changes in other objects.

Design Criteria
A design criteria file (page 2773) and design check set (page 2772) can be applied to the profile if the parent
alignment has a design speed applied. The criteria-based design feature enables you to verify that a profile
design meets the minimum standards required by your local agency. These options are available if the Use
Criteria-Based Design check box is selected.
See also:
■

Criteria-Based Profile Design (page 1139)
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To set profile properties
1 In Toolspace, on the Prospector tab, expand the Alignments collection, identify the parent alignment
for the profile you want to work with, and then expand the Profiles collection for that alignment.
2 Select the profile, right-click, and then click Properties. The Profile Properties (page 2423) dialog box
opens.
3 After setting properties, click OK.

Quick Reference
Ribbon
Click the profile. Click Profile tab ➤ Modify Profile panel ➤ Profile Properties drop-down ➤ Profile Properties

Toolspace Shortcut Menu
Prospector tab: Alignments ➤ <alignment-name> ➤ Profiles ➤ <profile-name> ➤ Properties
Object Shortcut Menu
Click profile ➤ Profile Properties
Command Line
EditProfileProperties
Dialog Box
Profile Properties Dialog Box (page 2423)

Setting Profile View Properties
Set properties of profile views either from the Toolspace Prospector tab, or from the drawing window.
You can change the station range, grid, displayed profiles, and annotation of objects in the profile view.
Profile view properties are organized on several tabs of the Profile View Properties (page 2427) dialog box:
information, stations, elevations, profiles, bands, hatch, projections, and pipe networks.

Information tab
View or edit the profile view name, description, and object style.

Stations tab
Set the range of stations displayed in the profile view.

Elevations tab
Set the range of elevations displayed in the profile view. If the profile view is split, you can use this tab to
specify the stations and styles for the split segments. See The Profile View Object (page 1115) for more
information about split profile views.

Profiles tab
Specify which profiles to display in the profile view and whether the view is clipped to the extents of a
specific profile. You can edit the description, change the update mode (dynamic or static), layer, and style
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for each profile in the current view. You can also specify whether to split the profile view, which reduces its
vertical size.

Profile view without split

The sample profile view before splitting shows an elevation range of 60 feet.

Profile view with split

The split profile view is more compact, with an elevation range of about 38 feet. At the split station, a separate
elevation scale is provided for each part of the profile view.

Bands tab
Specify which data bands to include in the profile view and whether they are placed along the top or bottom
of the grid. The following data band types are available for displaying profile data: profile data, vertical
geometry, horizontal geometry, superelevation for a specified horizontal alignment, sectional data, and pipe
network data.

Hatch tab
Specify the style and location of hatching between surfaces, which shows cut regions and fill regions in the
vertical design.

Pipe Networks tab
Specify which pipes or structures to display in the profile view as well as their styles, style overrides, and
layer placement. The Pipe Networks tab is displayed only when there is one or more pipe networks in the
drawing.

Projection tab
Specify objects from plan view to project into the profile view, including AutoCAD objects and AutoCAD
Civil 3D objects. You can also specify the object display styles, elevation options, and elevation values. The
Projections tab is displayed only when projected objects (page 2780) exist in the profile view.
See also:
■

Setting Profile Properties (page 1136)
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To set profile view properties
1 Click the profile view you want to modify.
2 Click Profile View tab ➤ Modify View panel ➤ Profile View Properties drop-down ➤ Profile View
Properties

.

3 In the Profile View Properties (page 2427) dialog box, set properties, and then click OK.

Quick Reference
Ribbon
Click the profile view. Click Profile View tab ➤ Modify View panel ➤ Profile View Properties
drop-down ➤ Profile View Properties
Toolspace Shortcut Menu
Prospector tab: Alignments ➤ <alignment name> ➤ Profile Views ➤ <profile view name> ➤ Properties
Object Shortcut Menu
Click profile view, right-click ➤ Profile View Properties
Command Line
EditGraphProperties
Dialog Box
Profile View Properties Dialog Box (page 2427)

Criteria-Based Profile Design
Use the criteria-based design feature to apply agency-specific standards to a profile.
The criteria-based design feature provides the ability to verify that your profile design meets the minimum
standards required by your local agency.
When you use the criteria-based design feature, you can select a design criteria file (page 2773), from which
you can specify the minimum K value table. If the parent alignment also uses design criteria, the design
criteria file applied to the alignment is applied for the profile by default. You can specify a separate design
criteria file for the profile either during creation or in the profile properties.
When you lay out the profile, the appropriate minimum values specified in the design criteria file are
displayed on the command line. You can either accept the default minimum value for a given sub-entity,
or specify a new value.
Agency standards, which are typically based on superelevation and design speed requirements, are contained
in the customizable design criteria file. When you create the profile, the minimum standards from the design
criteria file ensure that the vertical curves comply with the minimum standards required by your local
agency.
If the design parameters for a sub-entity violate the minimum values established in the design criteria file,
a warning symbol appears both on the sub-entity in the drawing window and next to the violated value in
the Profile Entities Vista (page 2416) and Profile Layout Parameters Dialog Box (page 2417). When you hover the
cursor over a warning symbol, a tooltip displays which standard has been violated and how to correct the
violation. The display of the warning symbol is controlled by the profile style.
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Some profile design criteria are not available in table form in the design criteria file. For these criteria, you
can define design checks (page 2772) to validate design standards. A design check must be saved in a design
check set (page 2772) to be applied to a profile.
You can generate a report that documents validations or violations in the profile design. The design criteria
report identifies whether each sub-entity within a given station range meets the appropriate design criteria
and design checks.
See also:
■

Creating Layout Profiles (page 1143)

■

Applying Design Criteria to an Existing Layout Profile (page 1202)

■

Viewing and Correcting Profile Design Criteria Violations (page 1203)

Profile Standards in the Design Criteria File
The design criteria file contains the standards tables that specify design standards for alignments and profiles.
The design criteria file (page 2773) contains A.A.S.H.T.O. (page 2767) standards tables for minimum K values at
specified design speeds. Minimum K tables for Stopping Sight Distance, Passing Sight Distance, and Headlight
Sight Distance are provided. If your local agency standards differ from the standards in the supplied design
criteria file, you can use the Design Criteria File Editor dialog box (page 2067) to customize the file to support
your local standards.
By default, the profile uses the design criteria applied to the parent alignment. You can accept the default,
or select a different design criteria file for the profile.
The design criteria file contains standards for both alignment and profile objects. The Design Criteria Editor
dialog box is used to modify the standards for both objects.
NOTE Design criteria files can be created only with the Design Criteria Editor dialog box. Existing design criteria
data cannot be used unless it is input to an XML file using the Design Criteria Editor dialog box.
See also:
■

Design Criteria Files (page 936)

■

Creating a Design Criteria File (page 937)

■

Editing a Design Criteria File (page 939)

■

Criteria-Based Profile Design (page 1139)

■

Criteria-Based Alignment Design (page 935)

Profile Design Checks
Create design checks to verify the design parameters for criteria that are not included in the design criteria
tables.
The tables contained in the design criteria file (page 2773) contain A.A.S.H.T.O. (page 2767) standards tables for
Stopping Sight Distance, Passing Sight Distance, and Headlight Sight Distance minimum K values at specified
design speeds. Other criteria can be checked by using mathematical expressions, which are known as design
checks (page 2772).
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Design checks are created and managed in the same manner as label expressions. Use the Design Check
Editor dialog box (page 2069), which is similar to the Expressions dialog box (page 2211), to create and edit
design checks. To apply a design check to a profile, you must add it to a design check set (page 2772).
NOTE When you add curve design checks to a design check set, you must specify whether to apply it to sag
curves, crest curves, or both.
Design checks differ from label expressions in that they always return a true or false value. For example, you
can create a design check to issue a notification if a tangent is shorter than a specified minimum tangent
length.
See also:
■

Design Check Examples (page 941)

■

Creating a Design Check (page 942)

■

Editing a Design Check (page 944)

■

Expressions (page 1726)

Profile Design Check Sets
Save commonly used combinations of design checks in a design check set, which is then applied to a profile.
After you create a design check (page 2772), save it with an appropriate combination of other design checks
in a design check set. A design check set can be applied to a profile either during the profile creation process,
or through an existing profile’s properties.
A design check set consists of design checks for a combination of design check types. For example, you can
create a design check set that consists of separate design checks for minimum and maximum K values for
sag and crest curves.
Design checks are created and managed in the same manner as label expressions. Use the Design Check
Editor dialog box (page 2069), which is similar to the Expressions dialog box (page 2211), to create and edit
design checks. To apply a design check to a profile, you must add it to a design check set (page 2772).
See also:
■

Profile Design Checks (page 1140)

■

Design Check Examples (page 941)

■

Creating a Design Check Set (page 945)

■

Editing a Design Check Set (page 945)

Creating Profiles
Using profiles, you can view changes in elevation along a horizontal alignment.
In addition to the centerline profile, you can create offset profiles for features such as road edges or ditches.
Create a profile view to see one or more of the profiles associated with a horizontal alignment. Use the profile
view of a surface as a guide for creating the layout profile of a designed surface, such as a road. On a profile
view, you can also superimpose the profile of a different horizontal alignment that is in the same area.
To work most effectively with profiles, learn how to combine the create, copy, edit, and superimpose
operations to get the profiles you need for terrain analysis and design.
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In addition, you can use quick profiles to view and evaluate elevation information at locations where there
is no alignment. Quick profiles are temporary objects that are useful for evaluating elevation information
along a line, polyline, feature or lot line, survey figure, or along a series of points you select.

Creating Surface Profiles
You can create surface profiles to show surface elevations along an alignment.
You can create a surface profile either from a horizontal alignment on a surface or from a surface profile file.
When you create a centerline profile, you can create one or more offset profiles at the same time. Use the
Draw in Profile View option to display the profile in the drawing.

To create profiles from a surface
1 Click Home tab ➤ Create Design panel ➤ Profile drop-down ➤ Create Surface Profile

.

2 In the Create Profile from Surface dialog box (page 2396), in the Alignment list, select the horizontal
alignment to use for the profile.
3 Ensure that the surface you want to use is listed in the Select Surfaces list. If multiple surfaces are listed,
use Ctrl + click to select one or more of them from which to create profiles.
4 Optionally, in the Station Range area, specify start and end stations if you want the profile to cover a
distance less than the entire length of the horizontal alignment.
5 Click Add to add the centerline profile to the Profile List.
6 Optionally, select the Sample Offsets check box. Enter the offset distances in the field if you want the
profile to include one or more offsets from the centerline of the horizontal alignment. Use positive
numbers to specify right offsets, and negative numbers for left offsets. Use commas to separate the
values. Example: 20,-20,30,40
7 Optionally, click Add to add the offset profiles to the Profile List.
8 In the table, review the data for each profile line and make corrections as required. Optionally, add or
delete profiles in the Profile list.
9 Do one of the following:
■

If you want to draw the profile in a profile view, click Draw In Profile View, and then go to the create
profile view procedure (page 1208).
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■

Click OK. The profiles you created are saved. If the alignment has one or more profile views associated
with it, the profiles you created are added to the views.

Quick Reference
Ribbon
Home tab ➤ Create Design panel ➤ Profile drop-down ➤ Create Surface Profile
Menu
Profiles menu ➤ Create Profile From Surface
Command Line
CreateProfileFromSurface
Dialog Box
Create Profile from Surface (page 2396)

Creating Layout Profiles
Create layout profiles to represent designed elevations along an alignment.
You typically draw a layout profile on the grid of a profile view, using the surface profile as a guide.
A profile view grid must exist in the drawing to use this command. Create curves and tangents by freehand
sketching or by entering numeric values.
You can create a layout profile with tangents, and then optionally add curves at the points of vertical
intersection (PVI).
You can create a profile from an external ASCII file that contains a series of stations along an alignment,
the elevation of each station, and optionally, the length of curve at the station.
Curve attributes are set by the Curve Settings command. These curves maintain tangency when edited.
Several methods are available for drawing a layout profile:
■

Use the
Draw Tangents command to specify points of vertical intersection (PVIs) for a series of straight
tangents. Later you can add free curves (page 1184) with specific parameters between the tangents.

■

Use the
Draw Tangents With Curves command to specify PVIs for the tangents, automatically creating
curves between the tangents using the parameters you specify in the Vertical Curve Settings Dialog Box
(page 2444).

■

Use the constraint-based profile design commands (page 1156) to create a profile one sub-entity at a time.

When you are prompted for point locations, you can use the Transparent Commands (page 1767) to specify
points in the profile.
To create a more detailed design using a specific parameter or other constraints, or to create curves without
first creating tangents, use the constraint-based tools included on the Profile Layout Tools toolbar. For more
information, see Adding Tangents and Curves to a Layout Profile (page 1156).
The criteria-based design (page 2771) feature allows a layout profile to be validated against local design standards.
You can select a design criteria file (page 2773) and/or a design check set (page 2772) using either the Create Profile
- Draw New dialog box (page 2394) when you create the layout profile, or the Design Criteria tab (page 2424) of
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the Profile Properties dialog box after it has been created. For more information, see Criteria-Based Profile
Design (page 1139).
To create a layout profile
1 Click Home tab ➤ Create Design panel ➤ Profile drop-down ➤ Profile Creation Tools

.

2 Click the profile view in which to draw the layout profile.
3 In the Create Profile - Draw New dialog box (page 2394), enter a unique Name for the profile. Optionally,
enter a Description.
4 On the General tab (page 2394), specify the following settings:
■

Profile Style

■

Profile Layer

■

Profile Label Set

NOTE If you do not want to apply design criteria to the profile, proceed to step 6.
5 If you would like to associate design standards with the profile, on the Design Criteria tab (page 2395),
select the Use Criteria-Based Design check box.
For more information, see Criteria-Based Profile Design (page 1139).
On the Design Criteria tab, specify the following settings:
■

Use Design Criteria File
Select this check box to associate a design criteria file with the profile. The default design criteria
file location and the Default Criteria properties becomes available when you select the check box.

■

Use Design Check Set
Select this check box to associate a design check set with the profile. The design check set list becomes
available when you select the check box. Select a design check set from the list.

6 Click OK to display the Profile Layout Tools toolbar.
7 Use the commands on the Profile Layout Tools (page 2419) toolbar to draw the profile.
You can use any of the following methods to lay out a profile:
■

Use the
Draw Tangents command to specify points of vertical intersection (PVIs) for the tangents,
and then add free curves (page 1184) with specific parameters between the tangents.

■

Use the
Draw Tangents With Curves command to specify PVIs for the tangents, automatically
creating curves between the tangents using the parameters you specify in the Vertical Curve Settings
dialog box (page 2444).

■

Use various Profile Layout Tools (page 2419) to create separate entities and then join them together.

TIP When you are prompted for point locations, you can use the Transparent Commands (page 1767) to specify
points in the profile.
When you use Use the
Draw Tangents With Curves command, curves are created to comply with
the values in one of the following places:
■

If the profile has design criteria (page 935) applied to it, the minimum K value for the current design
speed is applied to the curve. If no solution can be found with the minimum K value, the curve is
not drawn.
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■

If the profile does not have design criteria applied to it, the default curve length or K value specified
in the vertical curve settings is applied to the curve. For more information, see Vertical Curve Settings
dialog box (page 2444).

To create a profile from a profile file
1 Click Home tab ➤ Create Design panel ➤ Profile drop-down ➤ Create Profile From File

.

2 Browse to the text file (a text file uses the .txt extension).
3 Click the text file and click Open. If the file is correctly formatted, it is read into the system and the
Create Profile - Draw New dialog box is displayed. For more information about correct file formatting,
see Format Requirements of Profile Files (page 1148).
4 In the Create Profile - Draw New dialog box (page 2394), review and revise any settings you want to change
for the profile name, description, and styles.
5 Click OK to save the profile in the drawing.

Quick Reference
Ribbon
Click Home tab ➤ Create Design panel ➤ Profile drop-down ➤ Profile Creation Tools
Click Home tab ➤ Create Design panel ➤ Profile drop-down ➤ Create Profile From File
Menu
Click Profiles menu ➤ Create Profile By Layout
Click Profiles menu ➤ Create Profile From File
Command Line
CreateProfileLayout
CreateProfileFromFile
Dialog Box
Create Profile - Draw New (page 2394)
Profile Layout Tools (page 2419)

Drawing Tangent-Tangent Profiles
Use the Profile Layout Tools to create and edit profiles.
You can use either of the following commands to create a quick layout of the profile. The lines and curves
you create maintain tangency when you edit them.

Draw Tangents Without Curves
Use this command to create a quick layout of the profile. Specify tangent start and end points (1 through
4), then add curves at the points of intersection as necessary. The tangents are fixed, so you can edit them
and they always maintain tangency.
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Draw Tangents With Curves
Use this command to create a quick layout of the profile, with curves automatically created at points of
intersection. Specify tangent start and end points (1 through 4), and curves are created at the points of
intersection (2, 3) based on the values you enter in the Curve Settings dialog box. You can edit the tangents
and curves and they always maintain tangency.

TIP You can use transparent commands when you are prompted to specify direction, radius, or length, or use
station offsets to specify any points. For more information, see Transparent Commands (page 1767).
See also:
■

Editing PVIs (page 1193)

To draw a profile using the tangent-tangent method with no curves
1 Click Home tab ➤ Create Design panel ➤ Profile drop-down ➤ Profile Creation Tools

.

2 In the Create Profile-Layout (page 1977) dialog box, enter creation information.
3 On the Profile Layout Tools toolbar, click

Draw Tangents Without Curves.

4 Specify the start point.
5 Continue to specify points. Press Enter to end the command, or click another command from the Profile
Layout Tools toolbar.
To draw a profile using the tangents with curves
1 Click Home tab ➤ Create Design panel ➤ Profile drop-down ➤ Profile Creation Tools
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.

2 In the Create Profile-Layout (page 1977) dialog box, enter creation information.
3 On the Profile Layout Tools toolbar, click

Draw Tangents With Curves.

4 Specify the start point.
5 Continue to specify points. Press Enter to end the command or select another command from the
Profile Layout Tools.
Curves are created to comply with the values in one of the following places:
■

If the profile has design criteria (page 935) applied to it, the minimum radius for the current design
speed is applied to the curve. If no solution can be found with the minimum radius value, the curve
is not drawn.

■

If the profile does not have design criteria applied to it, the default value specified in the curve and
spiral settings is applied to the curve. For more information, see Curve and Spiral Settings (page 930).

Quick Reference
Ribbon
Click Home tab ➤ Create Design panel ➤ Profile drop-down ➤ Profile Creation Tools
Menu
Click Profiles menu ➤ Create Profile By Layout
Command Line
CreateProfileLayout
Dialog Box
Create Alignment - Layout Dialog Box (page 1977)
Profile Layout Tools (page 2419)

Setting Curve Parameters
Enter the curve settings you want to use when creating profiles or parcels using the Draw Tangents With
Curves command.
You can specify default settings for curves by editing the Profile Creation settings in the CreateProfileLayout
command.

Specifying Curve Settings
Specify default curve types and values in the Vertical Curve Settings dialog box or by editing the Profile
Creation settings for the CreateProfileLayout command.
The parameter values in the Vertical Curve Settings dialog box apply only to the curves created using the
Draw Tangents with Curves command in the current profile. You can specify default settings for all curves
by editing the settings in the CreateProfileLayout command.
To change the default Curve Settings
1 On the Settings tab in Toolspace, expand the Profiles collection and then expand the Commands
collection.
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2 Right-click CreateProfileLayout ➤ Edit Command Settings.
3 In the Edit Command Settings-CreateProfileLayout dialog box, expand the Profile Creation property.
4 Specify the settings, click Apply, and click OK.
NOTE To save these command settings at the drawing level, on the Ambient Setting tab (page 84)select
Yes in the value column for Save Command Changes To Settings.

To change the curve settings when you draw a profile using the tangent with curves method
1 Click Home tab ➤ Create Design panel ➤ Profile drop-down ➤ Profile Creation Tools

.

2 In the Create Profile - Draw New (page 2394) dialog box, enter creation information.
3 On the Profile Layout Tools toolbar, click

Curve Settings.

4 In the Vertical Curve Settings (page 2444) dialog box, enter curves values.
NOTE The curve type you specify in the Vertical Curve Settings dialog box is used in all curve commands
on the Profile Layout Tools toolbar.

Quick Reference
Ribbon
Click Home tab ➤ Create Design panel ➤ Profile drop-down ➤ Profile Creation Tools
Menu
Click Profiles menu ➤ Create Profile By Layout
Command Line
CreateProfileLayout
Profile Layout Tools Toolbar Icon
Curve Settings
Dialog Box
Vertical Curve Settings Dialog Box (page 2444)

Format Requirements of Profile Files
Use profile files to record layout data for points of vertical intersection (PVIs) in a profile.
A profile file is a simple text file in ASCII format. The file contains a series of stations along an alignment,
the elevation of each station, and optionally, the length of curve at the station. Each line can include up to
three information elements, separated by spaces:
1 Station. An element required for each line. Plus characters (+) cannot be used.
2 Elevation. A required element.
3 Curve length. An optional element. However it cannot be used on the first or last line of the file. All
vertical curves must be parabolic.
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Sample file lines:
0 100.23
50 104.2
100 109.0 40.0
150 102.63
200 98.12 35.0
250 102.45
300 105.8

In this example, only the third and fifth PVIs include curves (lengths of 40.0 and 35.0). Use these other
format requirements for each profile file:
■

The first and last lines must not contain curve information.

■

The first line must provide the station and elevation for the first station.

■

Stations must be in ascending order.

■

No leading blank lines or headers.

■

No blank lines; a blank line is read as the end of the file.

■

No blank spaces at the beginning of any line.

■

The last item must be the elevation for the last station.

Creating a Superimposed Profile
In a profile view, display the profile of another alignment that is adjacent to the main horizontal alignment.
Use this option to show one profile in relation to another, such as a ditch in relation to a road centerline.
The general process is first to create separate profile views to display the two profiles. Then identify one
profile as the source profile to display in the other profile view, which is known as the destination profile
view. In the example of a ditch and a road centerline, let us assume that the ditch is the source profile and
the profile view for the road is the destination. When you superimpose the ditch profile on the profile view
of the road, you see the ditch elevations with reference to the stations along the road centerline.
When you superimpose a profile, you can set some options in the Superimpose Profile Options dialog box
(page 2443)
To superimpose a profile
1 Identify the source profile you want to superimpose. Ensure that each profile appears in a profile view.
2 Click Home tab ➤ Create Design panel ➤ Profile drop-down ➤ Create Superimposed Profile

.

3 In the drawing, click the source profile line.
4 Click the grid of the destination profile view.
5 Optionally, on the Limits tab (page 2443), specify a limited range of stations to superimpose.
NOTE If you want the superimposed profile station range to remain fixed, then select the Select Start and
Select End checkboxes and the superimposed profile will not react to changes in the station range of the
source alignment. If the Select Start and Select End boxes are not selected, then the start and end of the
superimposed profile locks to the start and end of the source alignment. If the start or end of the source
alignment changes, the superimposed profile updates dynamically.
6 Optionally, on the Accuracy tab (page 2444), specify different mid-ordinate distances for curve tessellation.
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7 Click OK.

Quick Reference
Ribbon
Home tab ➤ Create Design panel ➤ Profile drop-down ➤ Create Superimposed Profile
Menu
Click Profiles menu ➤ Create Superimposed Profile
Command Line
SuperimposeProfile
Dialog Box
Superimpose Profile Options (page 2443)

Creating a Corridor Profile
In a profile view, display a profile derived from a corridor feature line.
Profiles derived from corridor feature lines are static and are displayed with a
the Prospector tree.

in the Profile collection in

For information on creating a corridor profile, see Exporting Corridor Feature Lines as Profiles (page 1530).

Creating a Profile by Reference
Create a reference to an existing profile in a data shortcut (page 2772) or a Vault project.
The profile reference is a lightweight read-only copy of the original, but it gives you access to profile data
for other objects. Before you create a profile reference in the current drawing, the reference object or data
shortcut must exist in the current project collection on the Toolspace Prospector tab.
When a profile reference is created, a reference to the profile’s parent alignment is also created in the drawing.
AutoCAD Civil 3D automatically looks for the correct alignment reference in the source drawing when
creating the profile reference.
See also:
■

Creating Data Shortcuts (page 151)

■

Using Vault (page 158)

To create a reference to a data shortcut profile
1 In Toolspace, on the Prospector tab, ensure that the correct project folder is identified on the Data
Shortcuts node.
2 Expand the Data Shortcuts ➤ Alignments collection.
3 Expand the parent alignment of the profile you want to reference.
4 Right-click the desired profile, and then click Create Reference.
The Create Profile Reference dialog box is displayed, in which you can optionally change the properties
of the reference profile, as described in the following steps.

1150 | Chapter 26 Profiles

5 In the Create Profile Reference dialog box, change the source of the reference by selecting a source in
the Source Profile list.
6 Change the source parent alignment by selecting an alignment from the Source Alignment list.
7 Enter a Name for the profile.
NOTE To name the profile, click its default name. Enter a new name, or use the name template. For more
information, see Name Template Dialog Box (page 2022).
8 Specify a Profile Style or accept the default style.
For more information, see Profile Styles (page 1122).
9 Click

to select a layer. For more information about layers, see Object Layer Dialog Box (page 2221).

NOTE If you do not select a layer, the profile is placed on the current layer.
10 Specify a Profile Label Set or accept the default label set.
11 Click OK to create the profile reference.
A reference to the parent alignment is also created. The alignment name is displayed under the
Alignments collection in the Prospector tree with a
Profiles collection to view the profile reference.

next to it. Expand the alignment name and the

To create a reference to a profile in a Vault project
1 In Toolspace, on the Prospector tab, in Master View, expand the Projects <project name> ➤ Alignments
collection.
2 Expand the parent alignment of the profile you want to reference.
3 Right-click the desired profile, and then click Create Reference.
The Create Profile Reference dialog box is displayed, in which you can optionally change the properties
of the reference profile, as described in the following steps.
4 In the Create Profile Reference dialog box, change the source of the reference by selecting a source in
the Source Profile list.
5 Change the source parent alignment by selecting an alignment from the Source Alignment list.
6 Enter a Name for the profile.
NOTE To name the profile, click its default name. Enter a new name, or use the name template. For more
information, see Name Template Dialog Box (page 2022).
7 Specify a Profile Style or accept the default style.
For more information, see Profile Styles (page 1122).
8 Click

to select a layer. For more information about layers, see Object Layer Dialog Box (page 2221).

NOTE If you do not select a layer, the profile is placed on the current layer.
9 Specify a Profile Label Set or accept the default label set.
10 Click OK to create the profile reference.
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A reference to the parent alignment is also created. The alignment name is displayed under the
Alignments collection in the Prospector tree with a
Profiles collection to view the profile reference.

next to it. Expand the alignment name and the

Quick Reference
Toolspace Right-Click Menu (for data shortcut project)
Prospector tab: Data Shortcuts ➤ Alignments ➤ <alignment name> ➤ Profiles ➤ Create Reference
Toolspace Right-Click Menu (for Vault project)
Prospector tab: Projects ➤ <project name> ➤ Alignments ➤ <alignment name> Profiles ➤ Create
Reference
Command Line
CreateProfileReference
Dialog Box
Create Profile Reference (page 2452)

Copying a Profile
Copy a layout profile or a static surface profile. Use the copy to create a profile or replace an existing one.
Profile copying operations allow you to create a profile that is based on another. For example, you can create
an offset profile for a road edge or ditch that is a specific elevation below the road centerline. In this case,
you can copy the centerline profile, then change the elevation of the copy to create the offset profile.
After copying a profile, you can raise or lower the copy to create an initial line for a related profile. For
example, to place a ditch five feet lower than a centerline, copy the centerline profile and lower the copy
five feet to create a ditch profile.

Troubleshooting a Copied Profile
When you try copying a profile, you may receive the following error message:
Station xx+xx: Either outside of alignment limits, or within gap created by a station equation.
To resolve this issue, create a profile that extends beyond the station limits of the defined parent alignment.
You will not be able to copy a selected station range of PVIs if you select a start or end station that is outside
the limits of the parent horizontal alignment. Instead, copy the entire profile and then remove the unwanted
PVIs manually.
To copy a profile
1 Click the profile you want to copy.
2 Click Profile tab ➤ Modify Profile panel ➤ Geometry Editor
3 In the Profile Layout Tools dialog box (page 2419), click

.
Copy Profile.

4 In the Copy Profile Data Dialog Box (page 2392), check the data displayed in the Source Profile Information
area to ensure that this is the correct profile to copy.
5 Click the PVI range you want to copy: either All PVIs or those within a range of stations.
6 If you clicked Station Range, specify the start and end stations.
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7 In the Destination Profile Options area, specify what to do with the copy of the profile: either Create
New Profile or Overwrite Existing Profile.
8 If you clicked Overwrite Existing Profile, select the profile to overwrite.
9 To overwrite all properties of the existing profile, select Overwrite All Properties.
10 Click OK to create the copy of the profile. The copy is initially named according to the naming template,
like any new profile. You can change the name. The copy is displayed in the current profile view,
superimposed on its source profile. It also appears in the Toolspace Prospector tab, in the list of profiles
for the parent alignment.

Quick Reference
Ribbon
Click the profile. Click Profile tab ➤ Modify Profile panel ➤ Geometry Editor
Menu
Click Profiles menu ➤ Edit Profile Geometry
Command Line
EditProfileLayout
Dialog Box
Copy Profile Data Dialog Box (page 2392)

Creating a Quick Profile
View surface elevation data along an object or between two points.
Use the quick profile functionality to generate elevation data using a few quick steps before you create a
detailed design.
You can create quick profiles along many object types:
■

2D or 3D lines or polylines

■

Lot lines

■

Feature lines

■

Survey figures

■

A series of points

These profiles are not saved with the drawing.
You can control which surfaces are sampled in the quick profile, the style used to display the profile of each
surface, and the profile view style.
To create a profile that you can use again, create an alignment at the location of interest and use it to generate
a standard profile.
After you create a quick profile, extract information from it using the Inquiry tool. You can select and move
a quick profile. Use the object shortcut menu to change the style of one of its profiles or the profile view.
NOTE To simplify working with quick profiles, open two viewports before you create a quick profile. Use one
viewport to display the plan view and the other viewport to display the quick profiles.
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To create a quick profile from an object
1 Click Home tab ➤ Create Design panel ➤ Profile drop-down ➤ Quick Profile

.

On the command line, you are prompted to pick an object.
2 In the drawing, select a line, polyline, lot line, feature line, or survey figure.
3 In the Create Quick Profiles dialog box, select the surfaces you want to sample, and the profile and
profile view styles.
4 Optionally, if you selected a 3D object, select Draw 3D Entity Profile to display elevation data for the
object in the quick profile and a profile style for the 3D object elevation data.
5 Click OK.
6 In the drawing window, click a location for the lower left corner (origin) of the profile view grid.
The quick profile is drawn.
To create a quick profile by selecting points
1 Click Home tab ➤ Create Design panel ➤ Profile drop-down ➤ Quick Profile

.

On the command line, you are prompted to pick an object.
2 Enter p (points).
3 In the drawing, select a point, and then a second point.
4 Optionally, select additional points as required.
5 Press Enter.
6 In the Create Quick Profiles dialog box, select the surfaces you want to sample, and the profile and
profile view styles.
7 In the drawing window, click a location for the lower left corner (origin) of the profile view grid.
The quick profile is drawn.

Quick Reference
Ribbon
Click Home tab ➤ Create Design panel ➤ Profile drop-down ➤ Quick Profile
Menu
Click Profiles menu ➤ Quick Profile
Command Line
CreateQuickProfile
Dialog Box
Create Quick Profiles Dialog Box (page 2405)

Creating a Profile by Best Fit
Create a profile that follows the most logical path through a series of surface profiles, feature lines, COGO
points, or AutoCAD 3D polylines, points, or blocks.
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This tool uses a complex algorithm that you can adjust to obtain the desired results based on the type and
the accuracy of the source data.
For example, when one uses COGO points as source data, the specified points are projected onto the
alignment, and then sorted by station. The station on the alignment and the elevation of each point is
determined; if a second path of points is specified, then the offset distance from the alignment also is
determined.
Next, the algorithm calculates tangents (2) based on the sequence of the points and the specified Maximum
Radius For Curve Detection setting. When a sequence of points has a radius that is greater than this setting,
the points form a tangent. The apparent intersection of the tangents (3) are the points of intersection for
the profile tangents. The algorithm calculates arcs or parabolas (1) by approximating the curvature by linking
the sample points together with linear segments. To increase the accuracy when using either feature lines
or 3D polylines, intermediate sample points may be either weeded from the original input data or created
between each pair of sample points.

To create a profile by best fit

1 Click Home tab ➤ Create Design panel ➤ Profile drop-down ➤ Create Best Fit Profile

.

2 In the Create Best Fit Profile Dialog Box (page 2393), under Input Data, specify the type of data from
which to create the best fit alignment.
3 Next to Path 1, click

.

NOTE If you selected COGO Points or Surface Profile as the Input Type, you can use a drop-down list to
select a point group or surface profile.
4 In the drawing, select the objects from which you want to create the best fit profile. Press Enter.
NOTE You may only select objects that are the input type you selected in Step 2. You may not select multiple
types of objects.

5 If you wish to create the best fit profile between two paths of objects, next to Path 2, click

.

NOTE If you selected Surface Profile as the Input Type, you cannot use a second path.
6 In the drawing, select the objects from which you want to create the best fit profile. Press Enter.
7 If you chose AutoCAD 3D Polylines, Surface Profile, or Feature Lines as the Input Data, click Weeding
Options.
8 In the Best Fit Profile Weeding Options Dialog Box (page 2392), specify whether to either weed extraneous
vertices or insert intermediate vertices. Click OK.
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9 Under Best Fit Options, specify the following parameters:
■

Maximum Radius For Curve Detection—Specifies the largest acceptable radius of curves that are
created from the input data.
NOTE This value is an estimate. For best results, specify a value that is slightly greater than the largest
known radius in the input data.

■

Curve Type—Specifies the type of curve (either Parabola or Circular Arc) to create during the best
fit regression.

10 Under Creation Settings, specify the following parameters:
■

Profile Name

■

Profile Style

■

Layer

11 Use the Show Report check box to specify whether to show the Best Fit Profile Report Vista (page 2391),
which the results of the regression that was used to create the best fit profile.
12 Click OK.

Quick Reference
Ribbon

Home tab ➤ Create Design panel ➤ Profile drop-down ➤ Create Best Fit Profile
Double-click Create Best Fit Profile.
Command Line
C3D_BestFitProfile
Dialog Box
Create Best Fit Profile Dialog Box (page 2393)
Best Fit Profile Weeding Options Dialog Box (page 2392)
Best Fit Profile Report Vista (page 2391)

Adding Tangents and Curves to a Layout Profile
You can add fixed, floating, or free tangents and curves to a layout profile.
Use constraint-based commands on the Profile Layout Tools (page 2419) toolbar to refine the layout profile
design to meet your project objectives.
NOTE When drawing or editing constraint-based profile entities, ensure that the Profile Layout Tools (page 2419)
toolbar is set to

Entity Based mode.

The three entity type describes the way an entity is defined and edited:
■

Fixed entities are defined by specifying parameters, such as pass-through points, tangent slope, and curve
radius. The entities are fixed in position and must be edited directly. Except for its length, the geometry
of a fixed entity is not dependent on adjacent entities. If an adjacent entity is edited, the geometry of
the fixed entity is not affected.
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■

Floating entities are defined by specifying parameters and an entity to attach to. Floating entities are
always tangent to the entity they are attached to, and are dependent on the other entity to define their
geometry.

■

Free entities are defined by attachment to two entities, before and after. The free entity always remains
tangent to the two adjacent entities, and its geometry is defined by these adjacent entities.

Adding Vertical Tangents
Add fixed, free, or floating vertical tangents to build constraint-based profile geometry.
To access the vertical tangent creation commands, click the arrow next to the tangent creation command
displayed on the toolbar. The

Draw Fixed Tangent By Two Points command is displayed by default.

After clicking a button on the Profile Layout Tools toolbar, follow the command prompts on the command
line.
TIP You can use transparent commands to specify a station and elevation when you are prompted to select a
point. For more information, see Transparent Commands (page 1767).

Adding Fixed Vertical Tangents
Add fixed vertical tangents to build constraint-based profile geometry.
Fixed entities are defined by specifying parameters, such as points or minimum radius. The parameters are
fixed in their position and must be edited directly.
The position of a fixed entity is not affected by edits to adjacent entities.
Except for its length, the geometry of a fixed entity is not dependent on adjacent entities.

Adding a Fixed Vertical Tangent with Two Points
Add a fixed vertical tangent by specifying two points that the line will pass through.
To add a fixed vertical tangent with two points
1 Click the profile. Click Profile tab ➤ Modify Profile panel ➤ Geometry Editor
2 On the Profile Layout Tools (page 2419) toolbar, click

.

Draw Fixed Tangent By Two Points.

3 Specify the start point.
4 Specify the next point.

Quick Reference
Ribbon
Click profile. Click Profile tab ➤ Modify Profile panel ➤ Geometry Editor
Menu
Click Profiles menu ➤ Edit Profile Geometry
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Command Line
EditProfileLayout
Profile Layout Tools Toolbar Icon
Draw Fixed Tangent By Two Points
Dialog Box
Profile Layout Tools (page 2419)

Adding a Fixed Vertical Tangent by Best Fit
Add a fixed, two-point vertical tangent entity by best fit to a profile. You can define the best fit entity using
a series of AutoCAD Civil 3D points or clicks on screen.
The following illustration shows a fixed vertical tangent created by best fit. The Xs indicate the data points
that were used to create the entity.

NOTE Each best fit profile entity is drawn to the vertical scale set in the profile view style. To create an accurate
best fit entity, set the profile view style Vertical Exaggeration value to 1.000 to match the horizontal scale of the
profile view. For more information, see Creating and Editing Profile View Styles (page 1125).
See also:
■

Editing Best Fit Profile Entities (page 1200)

To add a fixed vertical tangent by best fit from AutoCAD Civil 3D points
1 Set the profile view style Vertical Exaggeration value to 1.0000. See Creating and Editing Profile View
Styles (page 1125) for more information.
2 Click the profile. Click Profile tab ➤ Modify Profile panel ➤ Geometry Editor
3 In the Profile Layout Tools (page 2419) toolbar, click

.

Fixed Tangent - Best Fit.

4 In the Tangent by Best Fit dialog box (page 2225), select From COGO Points.
5 In plan view, select two or more points. Enter G to select a point group or N to enter points by number.
As the points are selected in plan view, an X marks each regression point and a temporary, dashed
tangent is displayed in the profile view.
6 Press Enter to complete the command.
7 In the Panorama window, use the Regression Data vista (page 2226) to modify the regression points.
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As you highlight a row in the Regression Data vista, the corresponding regression point in the drawing
window is highlighted in red.
8 Create the tangent:
■

Click

to create the tangent and keep the Regression Data vista open.

■

Click

to create the tangent and close the Regression Data vista.

To add a fixed vertical tangent by best fit by clicking on screen
1 Set the profile view style Vertical Exaggeration value to 1.0000. See Creating and Editing Profile View
Styles (page 1125) for more information.
2 Click the profile. Click Profile tab ➤ Modify Profile panel ➤ Geometry Editor
3 In the Profile Layout Tools (page 2419) toolbar, click

.

Fixed Tangent - Best Fit.

4 In the Tangent by Best Fit dialog box (page 2225), select By Clicking On The Screen.
5 Select a starting point and at least one other point.
NOTE You can use OSNAP or transparent commands to select points.
As you select points in the drawing window, an X marks each regression point and a temporary, dashed
tangent is displayed in real time.
6 Press Enter to complete the command.
7 In the Panorama window, use the Regression Data vista (page 2226) to modify the regression points.
As you highlight a row in the Regression Data vista, the corresponding regression point in the drawing
window is highlighted in red.
8 Create the tangent:
■

Click

to create the tangent and keep the Regression Data vista open.

■

Click

to create the tangent and close the Regression Data vista.

To add a fixed vertical tangent by best fit from existing entities
1 Set the profile view style Vertical Exaggeration value to 1.0000. See Creating and Editing Profile View
Styles (page 1125) for more information.
2 Click the profile. Click Profile tab ➤ Modify Profile panel ➤ Geometry Editor
3 In the Profile Layout Tools (page 2419) toolbar, click

.

Fixed Tangent - Best Fit.

4 In the Tangent by Best Fit dialog box (page 2225), select By Clicking On The Screen. Specify the tessellation
and mid-ordinate tolerance settings.
5 Select one of the entities listed on the command line.
NOTE You can select several types of entities listed on the command line.
6 If you selected a profile entity, specify the starting and ending station on the Specify Station Range
dialog box (page 2228).
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7 Repeat steps 5 and 6 to select other entities from which to create the best fit tangent.
As you select entities in the drawing window, an X marks each regression point and a temporary, dashed
tangent is displayed in real time.
8 Press Enter to complete the command.
9 In the Panorama window, use the Regression Data vista (page 2226) to modify the regression points.
As you highlight a row in the Regression Data vista, the corresponding regression point in the drawing
window is highlighted in red.
10 Create the tangent:
■

Click

to create the tangent and keep the Regression Data vista open.

■

Click

to create the tangent and close the Regression Data vista.

Quick Reference
Ribbon
Click profile. Click Profile tab ➤ Modify Profile panel ➤ Geometry Editor
Menu
Click Profiles menu ➤ Edit Profile Geometry
Command Line
EditProfileLayout
Profile Layout Tools Toolbar Icon
Fixed Tangent - Best Fit
Dialog Box
Profile Layout Tools (page 2419)
Tangent by Best Fit (page 2225)
Regression Data (page 2226)

Adding Floating Vertical Tangents
Add floating vertical tangents to build constraint-based profile geometry.
Floating entities are defined by specifying parameters and an entity to attach to. A floating entity is always
tangent to the attached entity and is dependent on the other entity to define its geometry.

Adding a Floating Vertical Tangent with a Pass Through Point
Add a floating vertical tangent by specifying an attachment entity and a pass-through point.
The figure shows a floating tangent from an attached entity (1) to a pass-through point (2).
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To add a floating vertical tangent with a specified pass-through point
1 Click the profile. Click Profile tab ➤ Modify Profile panel ➤ Geometry Editor
2 On the Profile Layout Tools toolbar, click

.

Float Tangent (Through Point).

3 Specify the fixed or floating curve to which you want to attach the tangent.
4 Specify the pass-through point.

Quick Reference
Ribbon
Click the profile. Click Profile tab ➤ Modify Profile panel ➤ Geometry Editor
Menu
Click Profiles menu ➤ Edit Profile Geometry
Command Line
EditProfileLayout
Profile Layout Tools Toolbar Icon
Float Tangent (Through Point)
Dialog Box
Profile Layout Tools (page 2419)

Adding a Floating Vertical Tangent by Best Fit
You can define the best fit entity using a series of AutoCAD Civil 3D points, AutoCAD points, existing
entities, or clicks on screen.
The illustration shows a floating vertical tangent created by best fit from an existing endpoint (1). The Xs
indicate the data points used to create the entity.
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NOTE Each best fit profile entity is drawn to the vertical scale set in the profile view style. To create an accurate
best fit entity, set the profile view style Vertical Exaggeration value to 1.000 to match the horizontal scale of the
profile view. For more information, see Creating and Editing Profile View Styles (page 1125).
See also:
■

Editing Best Fit Profile Entities (page 1200)

To add a floating vertical tangent by best fit from AutoCAD Civil 3D points
1 Set the profile view style Vertical Exaggeration value to 1.0000. See Creating and Editing Profile View
Styles (page 1125) for more information.
2 Click the profile. Click Profile tab ➤ Modify Profile panel ➤ Geometry Editor
3 In the Profile Layout Tools (page 2419) toolbar, click

.

Float Tangent - Best Fit.

4 Select an existing fixed or floating profile entity to which to attach the best fit tangent.
5 In the Tangent by Best Fit dialog box (page 2225), select From COGO Points.
6 In plan view, select two or more points. Enter G to select a point group or N to enter points by number.
As the points are selected in plan view, an X marks each regression point and a temporary, dashed
tangent is displayed in the profile view.
7 Press Enter to complete the command.
8 In the Panorama window, use the Regression Data vista (page 2226) to modify the regression points.
As you highlight a row in the Regression Data vista, the corresponding regression point in the drawing
window is highlighted in red.
9 Create the tangent:
■

Click

to create the tangent and keep the Regression Data vista open.

■

Click

to create the tangent and close the Regression Data vista.

To add a floating vertical tangent by best fit by clicking on screen
1 Set the profile view style Vertical Exaggeration value to 1.0000. See Creating and Editing Profile View
Styles (page 1125) for more information.
2 Click the profile. Click Profile tab ➤ Modify Profile panel ➤ Geometry Editor
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.

3 In the Profile Layout Tools (page 2419) toolbar, click

Float Tangent - Best Fit.

4 Select an existing fixed or floating profile entity to which to attach the best fit tangent.
5 In the Tangent by Best Fit dialog box (page 2225), select By Clicking On The Screen.
6 Select at least one point in the drawing.
NOTE You can use OSNAP or transparent commands to select points.
As you select points in the drawing window, an X marks each regression point and a temporary, dashed
tangent is displayed in real time.
7 Press Enter to complete the command.
8 In the Panorama window, use the Regression Data vista (page 2226) to modify the regression points.
As you highlight a row in the Regression Data vista, the corresponding regression point in the drawing
window is highlighted in red.
9 Create the tangent:
■

Click

to create the tangent and keep the Regression Data vista open.

■

Click

to create the tangent and close the Regression Data vista.

To add a floating vertical tangent by best fit from existing entities
1 Set the profile view style Vertical Exaggeration value to 1.0000. See Creating and Editing Profile View
Styles (page 1125) for more information.
2 Click the profile. Click Profile tab ➤ Modify Profile panel ➤ Geometry Editor
3 In the Profile Layout Tools (page 2419) toolbar, click

.

Float Tangent - Best Fit.

4 Select an existing fixed or floating profile entity to which to attach the best fit tangent.
5 In the Tangent by Best Fit dialog box (page 2225), select From Entities. Specify the tessellation and
mid-ordinate tolerance settings.
6 Select one of the entities listed on the command line.
NOTE You can select several types of entities listed on the command line.
7 If you selected a profile entity, specify the starting and ending station on the Specify Station Range
dialog box (page 2228).
8 Repeat steps 6 and 7 to select other entities from which to create the best fit tangent.
As you select entities in the drawing window, an X marks each regression point and a temporary, dashed
tangent is displayed in real time.
9 Press Enter to complete the command.
10 In the Panorama window, use the Regression Data vista (page 2226) to modify the regression points.
As you highlight a row in the Regression Data vista, the corresponding regression point in the drawing
window is highlighted in red.
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11 Create the tangent:
■

Click

to create the tangent and keep the Regression Data vista open.

■

Click

to create the tangent and close the Regression Data vista.

Quick Reference
Ribbon
Click the profile. Click Profile tab ➤ Modify Profile panel ➤ Geometry Editor
Menu
Click Profiles menu ➤ Edit Profile Geometry.
Command Line
EditProfileLayout
Profile Layout Tools Toolbar Icon
Float Tangent - Best Fit
Dialog Box
Profile Layout Tools (page 2419)
Tangent by Best Fit (page 2225)
Regression Data (page 2226)

Adding Free Vertical Tangents
Add free vertical tangents to build constraint-based profile geometry.
A free entity is defined by attachment to two entities, which define the geometry of the free entity.
The illustration shows a free tangent between two curves.

To add a free vertical tangent between two curves
1 Click the profile. Click Profile tab ➤ Modify Profile panel ➤ Geometry Editor
2 On the Profile Layout Tools toolbar, click

Free Tangent.

3 Specify the first fixed or floating curve to which you want to attach the tangent.
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.

4 Specify the second fixed or floating curve to which you want to attach the tangent.

Quick Reference
Ribbon
Click the profile. Click Profile tab ➤ Modify Profile panel ➤ Geometry Editor
Menu
Click Profiles menu ➤ Edit Profile Geometry
Command Line
EditProfileLayout
Profile Layout Tools Toolbar Icon
Free Tangent
Dialog Box
Profile Layout Tools (page 2419)

Extending Profile Tangents to a PVI
Create a point of vertical intersection at the intersecting grade line of two tangents.
Use this command to connect short tangents that do not intersect. The result is a continuous profile that
consists of tangents and PVIs.
To extend two profile tangents to a point of vertical intersection
1 Click the profile. Click Profile tab ➤ Modify Profile panel ➤ Geometry Editor
2 On the Profile Layout Tools toolbar, click

.

Solve Tangent Intersection.

3 Select the first tangent, or specify a point/station and elevation.
4 Select the second tangent, or specify a point/station and elevation.

Quick Reference
Ribbon
Click profile. Click Profile tab ➤ Modify Profile panel ➤ Geometry Editor

.

Menu
Click Profiles menu ➤ Edit Profile Geometry
Command Line
EditProfileLayout
Profile Layout Tools Toolbar Icon
Solve Tangent Intersection
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Dialog Box
Profile Layout Tools (page 2419)

Adding Vertical Curves
Add fixed, free, or floating curves to build constraint-based profile geometry.
To access the vertical curve creation commands, click the arrow next to the curve creation command displayed
on the toolbar. The

Fixed Vertical Curve (Three Points) command is displayed by default.

After clicking a button on the Profile Layout Tools toolbar, follow the command prompts on the command
line.
TIP You can use transparent commands to specify a station and elevation when you are prompted to select a
point. For more information, see Transparent Commands (page 1767).

Vertical Curve Design
Designing vertical curves in layout profiles requires that you understand the concepts described in this topic.

Curve Types
■

Taylor Pohlman Parabolic. Most vertical curves in road design are symmetrical parabolic curves for a
good reason. The parabolic curve is the natural vertical curve followed by any projectile. A properly
designed symmetrical parabola minimizes the inertial forces on a vehicle traveling along the curve.
Highway curves are often designed with reference to curve tables, such as those provided by the American
Association of State Highway and Transportation Officials (A.A.S.H.T.O. (page 2767)). These tables can be
used only with symmetrical parabolic curves.
Quadratic parabolas are preferred in vertical designs as they have a constant rate of change of grade along
the curve. Quadratic parabolas are a very close approximation to circular curves at flat grades and are
usually used in vertical design. This quality makes them very easy to stake out. Substituting these values
we get the quadratic parabola equation for vertical curve as:

■

g1 is the grade of tangent in

■

g2 is the grade of tangent out

■

L is the horizontal length of the curve that is fit between these two tangents

Since the rate of grade change is constant over the length of the curve, the parabolic curve parameter
can be expressed as:

■

Circular. These curves are easier to lay out and construct. This type is often used for the design of railways
or roads that are traveled at low speeds.

■

Asymmetrical parabolic. These curves are the least common type. This curve type consists of two different
parabolic curves that meet at the midpoint of the vertical curve.
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K-Value
This value represents the horizontal distance along which a 1% change in grade occurs on the vertical curve.
It expresses the abruptness of the grade change in a single value. Speed tables or other design tools often
provide a target minimum K value.
The criteria-based design (page 1139) feature automatically validates profile curve design against local design
standards. A.A.S.H.T.O. tables defining minimum K values at given speeds are provided in the customizable
design criteria file. Curves that violate your design standards can be corrected by using the Profile Layout
Parameters dialog box (page 2417) to either adjust K value directly, or change curve length and tangent grade
to meet the criteria.

K-value formula

Stopping Sight Distance
This design method for crest curves provides a minimum curve length. The curve must be long enough so
that the driver of a standard vehicle can always see an object before it gets within the maximum stopping
distance for the designed speed of travel.

Diagram of stopping sight distance

Passing Sight Distance
This design method for crest curves provides a minimum curve length. The curve must be long enough so
that the driver of a standard vehicle can always see an oncoming vehicle within a safe distance for the
designed speed of travel.
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Diagram of passing sight distance

Headlight Sight Distance
This design method for sag curves provides a minimum curve length. The curve must be long enough so
that in dark driving conditions, the headlights of a standard vehicle illuminate the road a safe distance
beyond the stopping distance for the designed speed of travel.

Diagram of headlight sight distance

Rider Comfort
This design method for sag curves provides a minimum curve length. The curve must be long enough so
that people in a standard vehicle do not experience excessive inertial force as they travel through the curve
at the designed speed.
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Diagram of rider comfort design

Equations Used For Calculating Crest and Sag Curve Lengths
AutoCAD Civil 3D 2011 can calculate values from the geometric definition of a vertical curve, PVI information,
as well as object and eye height.
These values are derived from empirical equations and do not use design speed.
For a crest curve, passing and stopping sight distances are used because a curve peak can obstruct a driver's
view of the roadway surface or another object.
Passing and stopping sight distances are not used for a sag curve because there is no curve peak to obstruct
a driver's view of the roadway surface or another object. In daylight, with good visibility, the driver has a
full view of the road on a sag curve. At nighttime, however, the driver can see only as far as the distance of
the headlight beam. To design a sag curve, you can use headlight sight distance.
You can display these properties in AutoCAD Civil 3D 2011 using the Text Component Editor. In Toolspace,
on the the Settings tab, expand Profile ➤ Label Styles ➤ Curve . Double-click the default Creat and Sag
label style. Click the Layout tab. Under Component Name, select an item such as BVC. On the Text
Component Editor, click the drop-down arrow under Properties to display the list of available properties.
Scroll down to see properties such as Headlight Sight Distance, Passing Sight Distance, and so on.
Creating Crest Curves Based on Passing and Stopping Sight Distances
Passing sight distance is the distance necessary for a driver to see an oncoming vehicle in order to determine
if there is enough distance to allow a passing lane. The passing sight distance is not used often in crest curve
design because the curve length needed to meet the passing sight criteria is usually prohibitive.
Stopping sight distance, a widely used criterion for determining curve length, is the distance necessary for
a driver to see a hazard on the roadway surface. Governmental guidelines determine the sight distance for
passing and stopping requirements.
The following equations calculate crest curve lengths using the passing and stopping sight distances.
where:
L = Length of vertical curve in feet (or meters)
S = Sight distance in feet (or meters)
A = Algebraic difference in grade percent (%)
h1 = Height of observer's eye above roadway surface in feet (or meters)
h2 = Height of object above roadway surface in feet (or meters)
The following equation solves for L when S is less than L:
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The following equation solves for S when S is less than L:

The following equation solves for L when S is greater than or equal to L:

The following equation solves for S when S is greater than or equal to L:

Creating Sag Curves Based on Headlight Sight Distance
At nighttime, a vehicle's headlight beams define the sight distance. A sag curve intercepts a headlight beam
on the roadway surface and limits the length of the beam. Headlight sight distance measures the top of the
headlight beam above the pavement and the maximum headlight angle to determine curve length. The
height of the driver's eye is alsofactored.
The following headlight sight distance equations are used to create sag curves.
where:
A = Algebraic difference in grade percent (%)
hd = Height of headlight beam above the pavement in feet (or meters)
L = Length of vertical curve in feet (or meters)
S = Sight distance in feet (or meters)
Ø = Upswept angle of headlight beam from horizontal (typically 1 degree)
The following equation solves for L when S is less than L:
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The following equation solves for S when S is less than L:

The following equation solves for L when S is greater than or equal to L:

The following equation solves for S when S is greater than or equal to L:

Adding Fixed Vertical Curves
Add fixed vertical curves to build constraint-based profile geometry.
Fixed entities are defined by specifying parameters, such as points or minimum radius. The parameters are
fixed in their position and must be edited directly. If an adjacent entity is edited, the geometry of the fixed
entity is not affected. Except for its length, the geometry of a fixed entity is not dependent on adjacent
entities.

Adding a Fixed Vertical Curve with Three Points
Add a fixed vertical curve by specifying three pass-through points.
The illustration shows a fixed curve from start point 1 through specified points 2 and 3.
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To add a fixed vertical curve with three points
1 Click the profile. Click Profile tab ➤ Modify Profile panel ➤ Geometry Editor
2 On the Profile Layout Tools toolbar, click

.

Fixed Vertical Curve (Three Points).

3 Specify the start point.
4 Specify the second point.
5 Specify the end point.

Quick Reference
Ribbon
Click the profile. Click Profile tab ➤ Modify Profile panel ➤ Geometry Editor
Menu
Click Profiles menu ➤ Edit Profile Geometry
Command Line
EditProfileLayout
Profile Layout Tools Toolbar Icon
Fixed Vertical Curve (Three Points)
Dialog Box
Profile Layout Tools (page 2419)

Adding a Fixed Vertical Curve with Two Points and a Parameter
Specify two pass-through points and a K value or minimum radius.
The illustration shows a fixed curve defined by a start point (1), end point (2), and a minimum radius (3):
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To add a fixed vertical curve with two points and a parameter
1 Click the profile. Click Profile tab ➤ Modify Profile panel ➤ Geometry Editor
2 On the Profile Layout Tools toolbar, click

.

Fixed Vertical Curve (Two Points, Parameter).

3 Specify a start point.
4 Specify an end point.
5 Do one of the following:
■

To specify a crest curve, press Enter.

■

To specify a sag curve, enter S (sag).

6 Do one of the following:
■

Specify a K value.

■

To specify a minimum radius for the curve parabola, enter R (radius), and then specify the radius.
NOTE If the profile was created using the criteria-based design (page 2771) feature, a default value is
displayed on the command line. Minimum K values at given design speeds are specified in the design
criteria file (page 2773). Minimum curve length and radius are calculated from the minimum K value at the
current design speed.

Quick Reference
Ribbon
Click the profile. Click Profile tab ➤ Modify Profile panel ➤ Geometry Editor
Menu
Click Profiles menu ➤ Edit Profile Geometry
Command Line
EditProfileLayout
Profile Layout Tools Toolbar Icon
Fixed Vertical Curve (Two Points, Parameter)
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Dialog Box
Profile Layout Tools (page 2419)

Adding a Fixed Vertical Curve from an Entity with a Pass-Through Point
Add a fixed vertical curve by specifying an attachment entity and a pass-through point.
The illustration shows a fixed curve from an attached entity (1) and a pass-through point (2):

To add a fixed vertical curve with an entity and a pass-through point
1 Click the profile. Click Profile tab ➤ Modify Profile panel ➤ Geometry Editor
2 On the Profile Layout Tools toolbar, click

.

Fixed Vertical Curve (Entity End, Through Point).

3 Select the fixed or floating entity to which you want to attach the curve.
The nearest end point of the entity is the start point of the curve. The grade of the start point is the
start grade for the curve.
4 Specify a pass-through point for the curve.

Quick Reference
Ribbon
Click the profile. Click Profile tab ➤ Modify Profile panel ➤ Geometry Editor
Menu
Click Profiles menu ➤ Edit Profile Geometry
Command Line
EditProfileLayout
Profile Layout Tools Toolbar Icon
Fixed Vertical Curve (Entity End, Through Point)
Dialog Box
Profile Layout Tools (page 2419)
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Adding a Fixed Vertical Curve with Two Points and a Start Point Grade
Add a fixed vertical curve by specifying two pass-through points and a grade at the start point.
The illustration shows a fixed curve from a start point (1) to an end point (2) and the grade at the start point
(3):

To add a fixed vertical curve with two points and the start point grade
1 Click the profile. Click Profile tab ➤ Modify Profile panel ➤ Geometry Editor
2 On the Profile Layout Tools toolbar, click

.

Fixed Vertical Curve (Two Points, Grade At Start Point).

3 Specify a start point.
4 Specify an end point.
5 Enter the grade value at the start point.

Quick Reference
Ribbon
Click the profile. Click Profile tab ➤ Modify Profile panel ➤ Geometry Editor
Menu
Click Profiles menu ➤ Edit Profile Geometry
Command Line
EditProfileLayout
Profile Layout Tools Toolbar Icon
Fixed Vertical Curve (Two Points, Grade At Start Point)
Dialog Box
Profile Layout Tools (page 2419)

Adding a Fixed Vertical Curve with Two Points and an End Point Grade
Add a fixed vertical curve by specifying two pass-through points and a grade at the end point.
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The following illustration shows a fixed curve from a start point (1) to an end point (2) and the grade at the
end point (3):

To add a fixed vertical curve with two points and the end-point grade
1 Click the profile. Click Profile tab ➤ Modify Profile panel ➤ Geometry Editor
2 On the Profile Layout Tools toolbar, click

.

Fixed Vertical Curve (Two Points, Grade At End Point).

3 Specify a start point.
4 Specify an end point.
5 Enter the grade at the end point.

Quick Reference
Ribbon
Click the profile. Click Profile tab ➤ Modify Profile panel ➤ Geometry Editor
Menu
Click Profiles menu ➤ Edit Profile Geometry
Command Line
EditProfileLayout
Profile Layout Tools Toolbar Icon
Fixed Vertical Curve (Two Points, Grade At End Point)
Dialog Box
Profile Layout Tools (page 2419)

Adding a Fixed Vertical Curve by Best Fit
Add a fixed, three-point curve entity by best fit to a profile. You can define the best fit entity using a series
of AutoCAD Civil 3D points, existing entities, or clicks on screen.
The illustration shows a fixed vertical curve created by best fit. The Xs indicate the data points used to create
the entity.
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NOTE Each best fit profile entity is drawn to the vertical scale set in the profile view style. To create an accurate
best fit entity, set the profile view style Vertical Exaggeration value to 1.000 to match the horizontal scale of the
profile view. For more information, see Creating and Editing Profile View Styles (page 1125).
See also:
■

Editing Best Fit Profile Entities (page 1200)

To add a fixed vertical curve by best fit from AutoCAD Civil 3D points
1 Set the profile view style Vertical Exaggeration value to 1.0000. See Creating and Editing Profile View
Styles (page 1125) for more information.
2 Click the profile. Click Profile tab ➤ Modify Profile panel ➤ Geometry Editor
3 In the Profile Layout Tools (page 2419) toolbar, click

.

Fixed Vertical Curve - Best Fit.

4 In the Curve by Best Fit dialog box (page 2225), select From COGO Points.
5 In plan view, select three or more points. Enter G to select a point group or N to enter points by number.
As the points are selected in plan view, an X marks each regression point and a temporary, dashed curve
is displayed in the profile view.
6 Press Enter to complete the command.
7 In the Panorama window, use the Regression Data vista (page 2226) to modify the regression points.
As you highlight a row in the Regression Data vista, the corresponding regression point in the drawing
window is highlighted in red.
8 Create the curve:
■

Click

to create the curve and keep the Regression Data vista open.

■

Click

to create the curve and close the Regression Data vista.

To add a fixed vertical curve by best fit by clicking on screen
1 Set the profile view style Vertical Exaggeration value to 1.0000. See Creating and Editing Profile View
Styles (page 1125) for more information.
2 Click the profile. Click Profile tab ➤ Modify Profile panel ➤ Geometry Editor
3 In the Profile Layout Tools (page 2419) toolbar, click

.

Fixed Vertical Curve - Best Fit.
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4 In the Curve by Best Fit dialog box (page 2225), select By Clicking On The Screen.
5 Select a starting point and at least two other points.
NOTE You can use OSNAP or transparent commands to select points.
As you select points in the drawing window, an X marks each regression point and a temporary, dashed
curve is displayed in real time.
6 Press Enter to complete the command.
7 In the Panorama window, use the Regression Data vista (page 2226) to modify the regression points.
As you highlight a row in the Regression Data vista, the corresponding regression point in the drawing
window is highlighted in red.
8 Create the curve:
■

Click

to create the curve and keep the Regression Data vista open.

■

Click

to create the curve and close the Regression Data vista.

To add a fixed vertical curve by best fit from existing entities
1 Set the profile view style Vertical Exaggeration value to 1.0000. See Creating and Editing Profile View
Styles (page 1125) for more information.
2 Click the profile. Click Profile tab ➤ Modify Profile panel ➤ Geometry Editor
3 In the Profile Layout Tools (page 2419) toolbar, click

.

Fixed Vertical Curve - Best Fit.

4 In the Curve by Best Fit dialog box (page 2225), select By Clicking On The Screen. Specify the tessellation
and mid-ordinate tolerance settings.
5 Select one of the entities listed on the command line.
NOTE You can select several types of entities listed on the command line.
6 If you selected a profile entity, specify the starting and ending station on the Specify Station Range
dialog box (page 2228).
7 Repeat steps 5 and 6 to select other entities from which to create the best fit curve.
As you select entities in the drawing window, an X marks each regression point and a temporary, dashed
curve is displayed in real time.
8 Press Enter to complete the command.
9 In the Panorama window, use the Regression Data vista (page 2226) to modify the regression points.
As you highlight a row in the Regression Data vista, the corresponding regression point in the drawing
window is highlighted in red.
10 Create the curve:
■

Click

to create the curve and keep the Regression Data vista open.

■

Click

to create the curve and close the Regression Data vista.

1178 | Chapter 26 Profiles

Quick Reference
Ribbon
Click the profile. Click Profile tab ➤ Modify Profile panel ➤ Geometry Editor
Menu
Click Profiles menu ➤ Edit Profile Geometry
Command Line
EditProfileLayout
Profile Layout Tools Toolbar Icon
Fixed Vertical Curve - Best Fit
Dialog Box
Profile Layout Tools (page 2419)
Curve by Best Fit (page 2225)
Regression Data (page 2226)

Adding Floating Vertical Curves
Add floating vertical curves to build constraint-based profile geometry.
Floating entities are defined by specifying parameters and an entity to attach to. Floating entities are always
tangent to the entity it is attached to, and are dependent on the other entity to define its geometry.

Adding a Floating Vertical Curve with a Pass-Through Point and a Parameter
Add a floating vertical curve by specifying a pass-through point and a parameter.
The illustration shows a floating curve from an existing entity (1) to a pass-through point (2) and a minimum
radius (3). This curve type can also be drawn from a specified K value.

To add a floating vertical curve with a pass-through point and a parameter
1 Click the profile. Click Profile tab ➤ Modify Profile panel ➤ Geometry Editor
2 On the Profile Layout Tools toolbar, click

.

Floating Vertical Curve (Parameter, Through Point).

3 Select the fixed or floating entity to which you want to attach the curve.
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4 Do one of the following:
■

To specify a K value, enter the K value.

■

To specify a minimum radius for the curve parabola, enter R (radius), and then specify the radius.

NOTE If the profile was created using the criteria-based design (page 2771) feature, a default value is displayed
on the command line. Minimum K values at given design speeds are specified in the design criteria file (page
2773). Minimum curve length and radius are calculated from the minimum K value at the current design speed.
5 Specify a pass-through point.
6 If selected a parabola in step 5, specify whether the resulting curve should be either a crest or sag.

Quick Reference
Ribbon
Click the profile. Click Profile tab ➤ Modify Profile panel ➤ Geometry Editor
Menu
Click Profiles menu ➤ Edit Profile Geometry
Command Line
EditProfileLayout
Profile Layout Tools Toolbar Icon
Floating Vertical Curve (Parameter, Through Point)
Dialog Box
Profile Layout Tools (page 2419)

Adding a Floating Vertical Curve by Best Fit
Add a floating, three-point curve entity by best fit to a profile. You can define the best fit entity using a
series of AutoCAD Civil 3D points, existing entities, or clicks on screen.
The illustration shows a floating vertical curve created from entity 1 by best fit. The Xs indicate data points
used to create the entity.
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NOTE Each best fit profile entity is drawn to the vertical scale set in the profile view style. To create an accurate
best fit entity, set the profile view style Vertical Exaggeration value to 1.000 to match the horizontal scale of the
profile view. For more information, see Creating and Editing Profile View Styles (page 1125).
See also:
■

Editing Best Fit Profile Entities (page 1200)

To add a floating vertical curve by best fit from AutoCAD Civil 3D points
1 Set the profile view style Vertical Exaggeration value to 1.0000. See Creating and Editing Profile View
Styles (page 1125) for more information.
2 Click the profile. Click Profile tab ➤ Modify Profile panel ➤ Geometry Editor
3 In the Profile Layout Tools (page 2419) toolbar, click

.

Floating Vertical Curve - Best Fit.

4 Select an existing fixed or floating profile entity to which to attach the best fit tangent.
If you select the first half of the profile entity, the best fit entity will precede the profile entity. If you
select the second half of the profile entity, the best fit entity will succeed the profile entity.
5 In the Curve by Best Fit dialog box (page 2225), select From COGO Points.
6 In plan view, select two or more points. Enter G to select a point group or N to enter points by number.
As the points are selected in plan view, an X marks each regression point and a temporary, dashed curve
is displayed in the profile view.
7 Press Enter to complete the command.
8 In the Panorama window, use the Regression Data vista (page 2226) to modify the regression points.
As you highlight a row in the Regression Data vista, the corresponding regression point in the drawing
window is highlighted in red.
9 Create the curve:
■

Click

to create the curve and keep the Regression Data vista open.

■

Click

to create the curve and close the Regression Data vista.

To add a floating vertical curve by best fit by clicking on screen
1 Set the profile view style Vertical Exaggeration value to 1.0000. See Creating and Editing Profile View
Styles (page 1125) for more information.
2 Click the profile. Click Profile tab ➤ Modify Profile panel ➤ Geometry Editor
3 In the Profile Layout Tools (page 2419) toolbar, click

.

Floating Vertical Curve - Best Fit.

4 Select an existing fixed or floating profile entity to which to attach the best fit tangent.
If you select the first half of the profile entity, the best fit entity will precede the profile entity. If you
select the second half of the profile entity, the best fit entity will succeed the profile entity.
5 In the Curve by Best Fit dialog box (page 2225), select By Clicking On The Screen.
6 Select at least two points in the drawing.
NOTE You can use OSNAP or transparent commands to select points.
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As you select points in the drawing window, an X marks each regression point and a temporary, dashed
curve is displayed in real time.
7 Press Enter to complete the command.
8 In the Panorama window, use the Regression Data vista (page 2226) to modify the regression points.
As you highlight a row in the Regression Data vista, the corresponding regression point in the drawing
window is highlighted in red.
9 Create the curve:
■

Click

to create the curve and keep the Regression Data vista open.

■

Click

to create the curve and close the Regression Data vista.

To add a floating vertical curve by best fit from existing entities
1 Set the profile view style Vertical Exaggeration value to 1.0000. See Creating and Editing Profile View
Styles (page 1125) for more information.
2 Click the profile. Click Profile tab ➤ Modify Profile panel ➤ Geometry Editor
3 In the Profile Layout Tools (page 2419) toolbar, click

.

Floating Vertical Curve - Best Fit.

4 Select an existing fixed or floating profile entity to which to attach the best fit tangent.
If you select the first half of the profile entity, the best fit entity will precede the profile entity. If you
select the second half of the profile entity, the best fit entity will succeed the profile entity.
5 In the Curve by Best Fit dialog box (page 2225), select By Clicking On The Screen. Specify the tessellation
and mid-ordinate tolerance settings.
6 Select one of the entities listed on the command line.
NOTE You can select several types of entities listed on the command line.
7 If you selected a profile entity, specify the starting and ending station on the Specify Station Range
dialog box (page 2228).
8 Repeat steps 6 and 7 to select other entities from which to create the best fit curve.
As you select entities in the drawing window, an X marks each regression point and a temporary, dashed
curve is displayed in real time.
9 Press Enter to complete the command.
10 In the Panorama window, use the Regression Data vista (page 2226) to modify the regression points.
As you highlight a row in the Regression Data vista, the corresponding regression point in the drawing
window is highlighted in red.
11 Create the curve:
■

Click

to create the curve and keep the Regression Data vista open.

■

Click

to create the curve and close the Regression Data vista.
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Quick Reference
Ribbon
Click the profile. Click Profile tab ➤ Modify Profile panel ➤ Geometry Editor
Menu
Click Profiles menu ➤ Edit Profile Geometry
Command Line
EditProfileLayout
Profile Layout Tools Toolbar Icon
Floating Vertical Curve - Best Fit
Dialog Box
Profile Layout Tools (page 2419)
Curve by Best Fit (page 2225)
Regression Data (page 2226)

Adding a Floating Vertical Curve with a Pass-Through Point and Grade
Add a floating vertical curve by specifying a pass-through point and a grade.
The illustration shows a floating curve from an existing entity to a pass-through point (2) with a grade (3).

To add a floating vertical curve with a pass-through point and grade
1 Click the profile. Click Profile tab ➤ Modify Profile panel ➤ Geometry Editor
2 On the Profile Layout Tools toolbar, click

.

Floating Vertical Curve (Through Point, Grade).

3 Select the fixed or floating entity to which you want to attach the curve.
4 Specify a pass-through point.
5 Specify a grade.
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Quick Reference
Ribbon
Click the profile. Click Profile tab ➤ Modify Profile panel ➤ Geometry Editor
Menu
Click Profiles menu ➤ Edit Profile Geometry
Command Line
EditProfileLayout
Profile Layout Tools Toolbar Icon
Floating Vertical Curve (Through Point, Grade)
Dialog Box
Profile Layout Tools (page 2419)

Adding Free Vertical Curves
Add free vertical curves to build constraint-based profile geometry.
Free entities are defined by attachment to two entities, on which the free entity is dependent to define its
geometry.

Adding a Free Vertical Curve with a Parameter
Add a free vertical curve between two entities by specifying a parameter.
Specify a K value, length, or radius to define the curve.
The illustration shows a free curve between entities 1 and 2, specified with a length parameter 3.

To add a free vertical curve with a parameter
1 Click the profile. Click Profile tab ➤ Modify Profile panel ➤ Geometry Editor
2 On the Profile Layout Tools toolbar, click

Free Vertical Curve (Parameter).

3 Select the first fixed or floating entity to which you want to attach the curve.
4 Select the second fixed or floating entity to which you want to attach the curve.
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.

5 Enter one of the following parameters to complete the curve definition:
■

Length: Enter L

■

K Value: Enter K

■

Radius: Enter R

NOTE If the profile was created using the criteria-based design (page 2771) feature, a default value is displayed
on the command line. Minimum K values at given design speeds are specified in the design criteria file (page
2773). Minimum curve length and radius are calculated from the minimum K value at the current design speed.

Quick Reference
Ribbon
Click the profile. Click Profile tab ➤ Modify Profile panel ➤ Geometry Editor
Menu
Click Profiles menu ➤ Edit Profile Geometry
Command Line
EditProfileLayout
Profile Layout Tools Toolbar Icon
Free Vertical Curve (Parameter)
Dialog Box
Profile Layout Tools (page 2419)

Adding a Free Parabolic Vertical Curve
Add a free parabolic vertical curve.
Specify the curve by length, a pass-through point, or a K value.
The illustration shows a free curve between entities 1 and 2, specified with a length parameter 3.

To add a free parabolic vertical curve
1 Click the profile. Click Profile tab ➤ Modify Profile panel ➤ Geometry Editor

.
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2 On the Profile Layout Tools toolbar, click

Free Vertical Parabola (PVI Based).

3 In the profile view, select a location near the PVI to which you want to add a curve.
4 Enter one of the following parameters to complete the curve definition:
■

Length: Enter L.

■

Pass-Through Point: Enter P

■

K Value: Enter K.

NOTE If the profile was created using the criteria-based design (page 2771) feature, a default value is displayed
on the command line. Minimum K values at a given design speed are specified in the design criteria file (page
2773). Minimum curve length and radius are calculated from the minimum K value at the current design speed.

Quick Reference
Ribbon
Click the profile. Click Profile tab ➤ Modify Profile panel ➤ Geometry Editor
Menu
Click Profiles menu ➤ Edit Profile Geometry
Command Line
EditProfileLayout
Profile Layout Tools Toolbar Icon
Free Vertical Parabola (PVI Based)
Dialog Box
Profile Layout Tools (page 2419)

Adding a Free Asymmetrical Vertical Curve
Add a free asymmetrical vertical curve.
You specify the length of the curve before the PVI and the length of the curve after the PVI.
The illustration shows an asymmetrical curve between tangents 1 and 2, with curve lengths 3 and 4.
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To add a free asymmetrical vertical curve
1 Click the profile. Click Profile tab ➤ Modify Profile panel ➤ Geometry Editor
2 On the Profile Layout Tools toolbar, click

.

Free Asymmetrical Parabola (PVI Based).

3 In the profile view, select a location near the PVI to which you want to add a curve.
4 Specify the length of the curve before the PVI by entering a value or by selecting two points in the
drawing window.
If the first length you specify is too large for the asymmetric curve, you cannot enter the length for the
second curve. The length of the first curve must be less than the station distance between the PVI you
select and the station value of the previous PVI (or end station of the previous curve.)
5 Specify the length of the curve after the PVI by entering a value or by selecting two points in the drawing
window.
NOTE If the profile was created using the criteria-based design (page 2771) feature, a default value is displayed
on the command line. Minimum K values at given design speeds are specified in the design criteria file (page
2773). Minimum curve length and radius are calculated from the minimum K value at the current design speed.

Quick Reference
Ribbon
Click the profile. Click Profile tab ➤ Modify Profile panel ➤ Geometry Editor
Menu
Click Profiles menu ➤ Edit Profile Geometry
Command Line
EditProfileLayout
Profile Layout Tools Toolbar Icon
Free Asymmetrical Parabola (PVI Based)
Dialog Box
Profile Layout Tools (page 2419)

Adding a Free Circular Vertical Curve
Add a free circular curve.
Specify a radius, length, or pass-through point to define the curve.
The illustration shows a circular curve at PVI 1, passing through point 2.
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To add a free circular vertical curve
1 Click the profile. Click Profile tab ➤ Modify Profile panel ➤ Geometry Editor
2 On the Profile Layout Tools toolbar, click

.

Free Circular Curve (PVI Based).

3 In the profile view, select a location near the PVI to which you want to add a curve.
4 Enter one of the following parameters to complete the curve definition:
■

Radius: Enter R.

■

Length: Enter L.

■

Pass-Through Point: Enter P.

NOTE If the profile was created using the criteria-based design (page 2771) feature, a default value is displayed
on the command line. Minimum K values at given design speeds are specified in the design criteria file (page
2773). Minimum curve length and radius are calculated from the minimum K value at the current design speed.

Quick Reference
Ribbon
Click the profile. Click Profile tab ➤ Modify Profile panel ➤ Geometry Editor
Menu
Click Profiles menu ➤ Edit Profile Geometry
Command Line
EditProfileLayout
Profile Layout Tools Toolbar Icon
Free Circular Curve (PVI Based)
Dialog Box
Profile Layout Tools (page 2419)
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Adding a Free Vertical Curve by Best Fit
Add a free, three-point curve entity by best fit to a profile. You can define the best fit entity using a series
of AutoCAD Civil 3D points, existing entities, or clicks on screen.
The illustration shows a free vertical curve created by best fit between endpoints 1 and 2. The Xs indicates
data points used to create the entity.

NOTE Each best fit profile entity is drawn to the vertical scale set in the profile view style. To create an accurate
best fit entity, set the profile view style Vertical Exaggeration value to 1.000 to match the horizontal scale of the
profile view. For more information, see Creating and Editing Profile View Styles (page 1125).
See also:
■

Editing Best Fit Profile Entities (page 1200)

To add a free vertical curve by best fit from AutoCAD Civil 3D points
1 Set the profile view style Vertical Exaggeration value to 1.0000. See Creating and Editing Profile View
Styles (page 1125) for more information.
2 Click the profile. Click Profile tab ➤ Modify Profile panel ➤ Geometry Editor
3 In the Profile Layout Tools (page 2419) toolbar, click

.

Free Vertical Curve - Best Fit.

4 Select an existing fixed or floating profile entity (the First Entity) from which to attach the best fit
tangent.
5 Select an existing fixed or floating profile entity (the Next Entity) to which to attach the best fit tangent.
6 In the Curve by Best Fit dialog box (page 2225), select From COGO Points.
7 In plan view, select one or more points. Enter G to select a point group or N to enter points by number.
As the points are selected in plan view, an X marks each regression point and a temporary, dashed curve
is displayed in the profile view.
8 Press Enter to complete the command.
9 In the Panorama window, use the Regression Data vista (page 2226) to modify the regression points.
As you highlight a row in the Regression Data vista, the corresponding regression point in the drawing
window is highlighted in red.
10 Create the curve:
■

Click

to create the curve and keep the Regression Data vista open.
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■

Click

to create the curve and close the Regression Data vista.

To add a free vertical curve by best fit by clicking on screen
1 Set the profile view style Vertical Exaggeration value to 1.0000. See Creating and Editing Profile View
Styles (page 1125) for more information.
2 Click the profile. Click Profile tab ➤ Modify Profile panel ➤ Geometry Editor
3 In the Profile Layout Tools (page 2419) toolbar, click

.

Free Vertical Curve - Best Fit.

4 Select an existing fixed or floating profile entity (the First Entity) from which to attach the best fit curve.
5 Select an existing fixed or floating profile entity (the Next Entity) to which to attach the best fit curve.
6 In the Curve by Best Fit dialog box (page 2225), select By Clicking On The Screen.
7 Select one or more points in the drawing.
NOTE You can use OSNAP or transparent commands to select points.
As you select points in the drawing window, an X marks each regression point and a temporary, dashed
curve is displayed in real time.
8 Press Enter to complete the command.
9 In the Panorama window, use the Regression Data vista (page 2226) to modify the regression points.
As you highlight a row in the Regression Data vista, the corresponding regression point in the drawing
window is highlighted in red.
10 Create the curve:
■

Click

to create the curve and keep the Regression Data vista open.

■

Click

to create the curve and close the Regression Data vista.

To add a free vertical curve by best fit from existing entities
1 Set the profile view style Vertical Exaggeration value to 1.0000. See Creating and Editing Profile View
Styles (page 1125) for more information.
2 Click the profile. Click Profile tab ➤ Modify Profile panel ➤ Geometry Editor
3 In the Profile Layout Tools (page 2419) toolbar, click

.

Free Vertical Curve - Best Fit.

4 Select an existing fixed or floating profile entity (the First Entity) from which to attach the best fit
tangent.
5 Select an existing fixed or floating profile entity (the Next Entity) to which to attach the best fit tangent.
6 In the Curve by Best Fit dialog box (page 2225), select By Clicking On The Screen. Specify the tessellation
and mid-ordinate tolerance settings.
7 Select one of the entities listed on the command line.
NOTE You can select several types of entities listed on the command line.
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8 If you selected a profile entity, specify the starting and ending station on the Specify Station Range
dialog box (page 2228).
9 Repeat steps 7 and 8 to select other entities from which to create the best fit curve.
As you select entities in the drawing window, an X marks each regression point and a temporary, dashed
curve is displayed in real time.
10 Press Enter to complete the command.
11 In the Panorama window, use the Regression Data vista (page 2226) to modify the regression points.
As you highlight a row in the Regression Data vista, the corresponding regression point in the drawing
window is highlighted in red.
12 Create the curve:
■

Click

to create the curve and keep the Regression Data vista open.

■

Click

to create the curve and close the Regression Data vista.

Quick Reference
Ribbon
Click the profile. Click Profile tab ➤ Modify Profile panel ➤ Geometry Editor
Menu
Click Profiles menu ➤ Edit Profile Geometry
Command Line
EditProfileLayout
Profile Layout Tools Toolbar Icon
Free Vertical Curve - Best Fit
Dialog Box
Profile Layout Tools (page 2419)
Curve by Best Fit (page 2225)
Regression Data (page 2226)

Editing Layout Profiles
Use the profile layout tools to edit curves, tangents, and points of vertical intersection (PVIs) on layout
profiles.
You can edit a layout profile by manipulating grips or by entering specific values that reflect road design
criteria.
Selecting either the
has three effects:

PVI Based or

Entity Based button on the Profile Layout Tools (page 2419) toolbar

■

Updates the tools available on the Profile Layout Tools toolbar

■

Changes the data shown in the Profile Entities vista (page 2416)

■

Changes the data shown in the Profile Layout Parameters Dialog Box (page 2417)
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For information on profile tools for creating and editing profiles, specifying curve settings, and displaying
the profile editors, see Profile Layout Tools (page 2419).
TIP You can use transparent commands when you are prompted to specify direction, radius, or length, or use
station offsets to specify any points. For more information, see Transparent Commands (page 1767).

Selecting Profile Sub-entities
Select an entire profile or a range of sub-entities in order to precisely edit them.
Select an entire profile by clicking it. Select an individual profile sub-entity or range or sub-entities by
Ctrl+clicking.
After you have selected a profile entity, you can use a variety of editing tools.
If the Profile Entities vista (page 2416) and Profile Layout Tools (page 2419) toolbar are open, selecting a sub-entity
or range of sub-entities in a profile causes the selected sub-entities to display in the Profile Entities vista.
Selecting sub-entities or ranges of sub-entities in a different profile causes that range of selected sub-entities
to display in the Profile Entities vista and have focus of the Profile Layout Tools toolbar. The last object
selected becomes the current object and has focus of the profile editing tools.
To select an entire profile
1 Click the profile.
Grips are displayed along the profile.
2 Use the desired tools to edit the profile:
To Edit the profile by...

see this topic:

adding constraint-based fixed, free, or
floating tangents and curves

Adding Tangents and Curves to a Layout
Profile (page 1156)

changing the profile at the points of vertical intersection

Editing PVIs (page 1193)

deleting profile sub-entities

Deleting Profile Sub-entities (page 1197)

using grips or entering precise parameter
values

Editing Profile Curve and Tangent Parameter Values (page 1198)

To select a single profile sub-entity
1 In the drawing window, click the profile.
2 Click Profile tab ➤ Modify Profile panel ➤ Geometry Editor
3 In the Profile Layout Tools toolbar (page 2419), click
tools.
4 In the Profile Layout Tools toolbar, click

.

Entity Based to enable the profile entity editing

Profile Grid View.

The Profile Entities vista (page 2416) displays attributes for all profile sub-entities.
5 In the drawing window, Ctrl+click the desired profile sub-entity.
The selected sub-entity is highlighted in the drawing, and the Profile Entities vista displays attributes
for only the selected profile sub-entity.
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6 Edit the profile sub-entity by entering specific attribute values in the Profile Entities vista.
See Editing Profile Curve and Tangent Parameter Values (page 1198) for more information.
NOTE The Profile Entities vista (page 2416) displays the attributes of only the selected sub-entity.

To select a range of profile sub-entities
1 Click the profile. Click Profile tab ➤ Modify Profile panel ➤ Geometry Editor
2 In the Profile Layout Tools toolbar (page 2419), click
tools.
3 In the Profile Layout Tools toolbar, click

.

Entity Based to enable the profile entity editing

Profile Grid View.

The Profile Entities vista (page 2416) displays attributes for all profile sub-entities.
4 In the drawing window, Ctrl+click the profile sub-entity at the beginning of the desired range.
The selected sub-entity is highlighted in the drawing, and the Profile Entities vista displays attributes
for only the selected profile sub-entity.
5 In the drawing window, Ctrl+click the profile sub-entity at the end of the desired range.
The selected range of sub-entities is highlighted in the drawing, and the Profile Entities vista displays
attributes for only the selected profile sub-entities.
6 Edit the profile sub-entities by entering specific attribute values in the Profile Entities vista.
See Editing Profile Curve and Tangent Parameter Values (page 1198) for more information.
NOTE The Profile Entities vista (page 2416) displays the attributes of only the selected sub-entities.

Quick Reference
Ribbon
Click the profile. Click Profile tab ➤ Modify Profile panel ➤ Geometry Editor
Menu
Click Profiles menu ➤ Edit Profile Geometry
Command Line
EditProfileLayout
Profile Layout Tools Toolbar Icon
Profile Grid View
Dialog Box
Profile Layout Tools (page 2419)

Editing PVIs
Manage the elevations and grades along a layout profile or static surface profile by editing the points of
vertical intersection (PVIs).
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Adjusting the number and location of PVIs allows you to make major changes to a layout profile, such as
removing vertical curves and changing tangent grades.
You can lock a PVI at a specific station and elevation so that it cannot be moved by edits to adjacent entities.
This is often done in intersections, where a side road profile is locked to the crown and edge-of-pavement
elevations of the main road. If you unlock a dynamic PVI for one road in an intersection, you break the link
to the profile of the other road.
You can also move PVIs with editing grips. For more information about the use of editing grips, see Editing
Profile Curve and Tangent Parameter Values (page 1198).
To insert a PVI
1 Click the profile. Profile tab ➤ Modify Profile panel ➤ Geometry Editor
2 In Profile Layout Tools (page 2419), click

.

Insert PVI.

3 Specify a point along the profile for the location of the new PVI. Specify the point either by clicking
the point or by entering ‘pse and providing a numeric value.
4 Optionally, add other PVIs by repeating Step 4.
5 Right-click to finish.
To insert multiple PVIs (bulk data entry)
1 Click the profile. Click Profile tab ➤ Modify Profile panel ➤ Geometry Editor
2 In Profile Layout Tools (page 2419), click

.

Insert PVIs - Tabular.

3 To place a curve at each inserted PVI, click the desired curve type in the Insert PVIs dialog box (page
2413). Otherwise, click None. The choice made here applies to all PVIs inserted at this time.
4 Click the first Station cell to activate it. Enter station and elevation values for each PVI. Press Enter after
each value to move the cursor to the next field. To change a value after entering it in the table, click
the cell and modify the entry.
5 After all values are entered, check the table to ensure that each value is correct.
6 Click OK to insert the set of PVIs.
To delete a PVI
1 Click the profile. Click Profile tab ➤ Modify Profile panel ➤ Geometry Editor
2 In Profile Layout Tools dialog box (page 2419), click

.

Delete PVI.

3 In the profile view, click near the PVI you want to delete. The PVI is removed, and the tangents are
adjusted to connect the adjacent PVIs or endpoints.
To lock a PVI
1 Click the profile. Click Profile tab ➤ Modify Profile panel ➤ Geometry Editor

.

2 In theProfile Layout Tools dialog box (page 2419), select the PVI based display option.
3 Click

Profile Grid View.

4 Find the PVI to lock, and optionally edit its location by changing numeric data in the table.
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5 Click the open lock icon in the table row for the PVI. The icon changes to a closed lock state, and some
values in the table are dimmed to indicate they cannot be edited.
To unlock a PVI
1 Click the profile. Click Profile tab ➤ Modify Profile panel ➤ Geometry Editor

.

2 In the Profile Layout Tools dialog box (page 2419), select the PVI based display option.
3 Click

Profile Grid View.

4 Click the closed lock icon in the table row for the PVI. The icon changes to an open lock state, and
additional values in the table can be edited.
TIP You can also unlock a PVI by clicking the lock icon in the profile view.
To move a PVI
1 Click the profile. Click Profile tab ➤ Modify Profile panel ➤ Geometry Editor
2 In Profile Layout Tools (page 2419), click

.

Move PVI.

3 In the drawing window, click near the PVI that you want to move.
4 Click the new location for the PVI. The PVI is immediately moved to the new location. The adjacent
tangents are adjusted accordingly.
5 To move additional PVIs, repeat steps 4 and 5.
To raise or lower a series of PVIs
1 Click the profile. Click Profile tab ➤ Modify Profile panel ➤ Geometry Editor
2 In Profile Layout Tools (page 2419), click

.

Raise/Lower PVIs.

3 In the “Raise/Lower PVI Elevations dialog box”, enter the elevation distance to raise or lower the PVIs.
A positive number raises the PVIs and a negative number lowers them.
4 Click the PVI Range you want to move: either All PVIs or those within a range of stations.
5 If you clicked Station Range, specify the start and end stations.
6 Click OK to move the PVIs.

Quick Reference
Ribbon
Click the profile. Click Profile tab ➤ Modify Profile panel ➤ Geometry Editor
Menu
Click Profiles menu ➤ Edit Profile Geometry
Object Shortcut Menu
Right-click <profile object> ➤ Edit Profile Geometry
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Command Line
EditProfileLayout
AddProfilePVI
DeleteProfilePVI
Dialog Box
Profile Layout Tools (page 2419)

Converting AutoCAD Entities to Profile Sub-entities
Convert an AutoCAD line or spline to a profile sub-entity.
AutoCAD lines and curves can be created using the best fit entities or similar commands. See Lines and
Curves (page 605) for more information.
The converted sub-entity becomes part of the solved profile geometry if either of the following two conditions
are met:
■

Before it is converted, it must be attached to an unattached end point of another solved entity in the
profile.

■

After it has been converted, it may be joined to the solved profile geometry using the profile layout tools.

To convert an AutoCAD entity to a profile sub-entity
1 Create a profile view or select an existing profile view.
2 Set the profile view style vertical exaggeration to 1. For more information, see Creating and Editing
Profile View Styles (page 1125).
3 Click the profile. Click Profile tab ➤ Modify Profile panel ➤ Geometry Editor
4 On the Profile Layout Tools (page 2419) toolbar, click

.

Convert AutoCAD Line And Spline.

5 Select the AutoCAD entity.
NOTE If the sub-entity you converted is hidden behind the source AutoCAD entity, use Shift+spacebar to select
it. Hover the cursor over the white AutoCAD entity. Press and hold Shift, then press the spacebar to highlight the
profile sub-entity. Click to select the profile sub-entity, then release the Shift key. Click the profile sub-entity again
to select it and continue with the command.

Quick Reference
Ribbon
Click the profile. Click Profile tab ➤ Modify Profile panel ➤ Geometry Editor
Menu
Click Profiles menu ➤ Edit Profile Geometry
Command Line
EditProfileLayout
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Profile Layout Tools Toolbar Icon
Convert AutoCAD Line And Spline

Deleting Profile Sub-entities
Use the Profile Layout Tools dialog box (page 2419) to remove tangents and curves from a layout profile.
When you delete a curve, the tangents on either side of the curve are preserved. If the tangents were joined
when they were created, the tangents are joined at the PVI after the curve is deleted.
NOTE You cannot delete a tangent that has a curve attached to it. Before deleting a tangent, you must first
delete the PVI and any dependent curves and tangents.
You can delete profile sub-entities either using the Profile Layout Tools dialog box (page 2419) or selecting the
sub-entity and pressing Delete.
To delete a sub-entity from the Profile Layout Tools dialog box
1 Click the profile. Click Profile tab ➤ Modify Profile panel ➤ Geometry Editor
2 In the Profile Layout Tools dialog box (page 2419), click

.

Delete Entity.

If you do not see the button, click
Entity Based to change to an entity-based view.
3 In the drawing window, select a sub-entity to delete.
To delete a sub-entity using the Delete key
1 Ctrl+click the profile sub-entity you want to delete.
2 Press Delete.

Quick Reference
Ribbon
Click the profile. Click Profile tab ➤ Modify Profile panel ➤ Geometry Editor
Menu
Click Profiles menu ➤ Edit Profile Geometry
Object Shortcut Menu
Right-click <profile object> ➤ Edit Profile Geometry
Command Line
EditProfileLayout
Dialog Box
Profile Layout Tools (page 2419)
Profile Layout Tools Dialog Box Icon
Delete Entity
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Editing Profile Curve and Tangent Parameter Values
Use the Profile Entities vista and Profile Layout Parameters dialog box to display and edit parameters of
profile entities that are part of the solved profile geometry.
The Profile Entities vista displays a form that is like a spread sheet, where each row represents either a profile
entity or PVI and each column represents a parameter. Use the
PVI Based and
Entity Based buttons
on the Profile Layout Tools toolbar to change the type of data that is displayed on the Profile Entities vista.
In the Profile Entities vista, you can right-click a column heading to display options for customizing the
display of detail in the column views.
The purpose of Profile Entities vista is to let you quickly scroll through the entities that make up the profile.
The list displays only the entities that have been selected (page 1192) in the drawing window. When you select
a row, the details for the corresponding entity are displayed in the Profile Layout Parameters dialog box.
The Profile Layout Parameters dialog box enables you to view and change the many attributes for a single
profile sub-entity. The Profile Layout Parameters dialog box contains up to three panels. The Layout Parameters
panel, which displays the geometric parameters of the selected sub-entity, is always present. In this panel,
the Value column lists the actual value of each sub-entity Parameter. If the profile was created using the
criteria-based design (page 2771) feature, the Constraint column lists the value to which a Parameter is
constrained by the specified design criteria. Use the Value and Constraint columns together to view whether
the sub-entity parameters meet the specified design criteria. If the profile was not created using the
criteria-based design feature, the Constraint column is not available.
Two additional panels may be present on the Profile Layout Parameters dialog box if the profile has design
criteria applied to it. If the profile has a design criteria file (page 2773) associated with it, the criteria from the
file are displayed in the Design Criteria panel. If the profile has a design check set (page 2772) associated with
it, the name and contents of the design check set are displayed in the Design Checks panel.
NOTE The attributes of a curve or other profile entity that you can edit depends on the method you used to create
the entity. Generally speaking, you can edit the numeric value of a parameter if the parameter was used to define
the entity. For all other parameters, numeric values are calculated and displayed but cannot be edited.
See also:
■

Vertical Curve Design (page 1166)

■

Editing Best Fit Profile Entities (page 1200)

To edit profile layout parameters using the Profile Entities vista and Profile Layout Parameters dialog box
1 Click the profile. Click Profile tab ➤ Modify Profile panel ➤ Geometry Editor
2 In the Profile Layout Tools (page 2419), click

Profile Layout Parameters and

.
Profile Grid View.

3 Specify the type of data to display in the Profile Entities vista:
■

To display PVI data, click

■

To display entity data, click

PVI Based.
Entity Based.

The Profile Entities vista (page 2416) displays the attributes of the selected profile entities. The Profile
Layout Parameters dialog box (page 2417) is empty.
4 In the Profile Entities vista, select the specific PVI, entity, or sub-entity you want to analyze. The
parameters of the selected the entities are displayed in the Profile Layout Parameters dialog box. Editable
values are in black text (not shaded).
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5 To display a range of entities in the Profile Entities vista, Ctrl+click the entity at the end of the desired
range.
The selected range of entities is displayed on the Profile Entities vista. Highlighting a row displays the
parameters of that entity in the Profile Layout Parameters dialog box.
NOTE Selecting another profile causes the Profile Layout Tools dialog box, Profile Entities vista, and Profile
Layout Parameters dialog box to become active for the new profile. See Selecting Profile Sub-entities (page
1192) for more information about profile sub-entity selection.
6 Review and edit the data as required. To edit another PVI, entity sub-entity, or range, repeat Steps 5
and 6.
7 When finished, close the Profile Layout Parameters dialog box and Profile Layout Tools toolbar.

Quick Reference
Ribbon
Click the profile. Click Profile tab ➤ Modify Profile panel ➤ Geometry Editor
Menu
Click Profiles menu ➤ Edit Profile Geometry
Command Line
EditProfileLayout
Dialog Boxes
Profile Layout Tools (page 2419)
Profile Entities Vista (page 2416)
Profile Layout Parameters (page 2417)
Profile Layout Tools Dialog Box Icon
Profile Layout Parameters
Profile Grid View
PVI Based
Entity Based

Editing Layout Profiles Using Grips
Use grips to graphically change the vertical curves and tangents in a profile.
Use editing grips to relocate or modify curves and tangents using visual design cues. If you created profile
entities using the constraint-based tools, some editing grips are not available. For example, if you attach a
floating curve to a fixed or floating tangent, the editing grip is not available for editing the PVI of the two
entities.
NOTE When a grip is selected, you can use either dynamic input or the Profile Entities (page 2416) and Profile Layout
Parameters (page 2417) dialog boxes to enter precise attribute values for the grip.
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To grip edit layout profiles
1 Click a profile object in a profile view. If the profile type is static, editing grips appear on the tangents
and vertical curves. Grip behavior depends on the type of grip:
Grip Type

at point of vertical
intersection (PVI)

at end of tangent

at end of tangent

at tangent midpoint

at curve endpoint

at curve midpoint

Behavior
Moves the PVI, changing grades and lengths of adjacent
tangents.
Preserves curve length and radius.
Use with ORTHO mode turned on to move PVI horizontally
or vertically.
Adjusts the tangent length while preserving the grade.
Modifies the grade of adjacent tangent.
Preserves curve length and radius.
Adjusts the tangent length and grade simultaneously.
Modifies the grade of adjacent tangent.
Moves the entire tangent, without changing the length
or grade.
Changes the location of adjacent PVIs and the grade of
adjacent tangents.
Preserves the radius and length of adjacent curves.
Moves the endpoint along the tangent, without affecting
the tangent grades or PVI location.
Changes position of both curve endpoints so that midpoint
remains near PVI.
Changes the curve length and radius.
Moves a pass-through point for the curve, changing the
curve length, radius, and position of both endpoints as
required.
PVI location is not affected.
After the curve is edited, this grip moves to the new midpoint.

2 Identify the grip you want to move, then click it once. The grip changes color from cyan to red.
3 Drag the grip to its new location, and click to place it there. The grip follows your mouse pointer, within
the constraints imposed by the grip type.
NOTE When a grip is selected, you can use either dynamic input or the Profile Entities vista (page 2416) and
Profile Layout Parameters dialog box (page 2417) to enter precise attribute values for the grip.

Editing Best Fit Profile Entities
Use the Regression Data and Profile Entities vistas to edit parameters of profile entities that were created by
best fit.
The Regression Data vista displays the source regression data from which the best fit entity was created. The
regression data can be modified either before or after the entity has been created. The information in the
Regression Data vista can be changed, and then applied to the entity. If the entity parameters are changed
outside the Regression Data vista, the entity can be synchronized to the current regression data.
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The Profile Entities vista displays a form that is like a spread sheet, where each row represents a profile entity
and each column represents a parameter. When an entity is created by best fit, Best Fit is displayed in the
Constraint2 column. Click

in this column to edit the source regression data.

Regression data is not dynamically linked to the best fit entity. If the entity is edited,
the Regression Data and Profile Entities vistas.

appears in both

NOTE You can edit only values that are available, you cannot edit unavailable (shaded) text.

Editing Floating Best Fit Entities
The manner in which a best fit floating entity reacts to edits to the attachment entity depends on whether
the best fit entity is synchronized with the best fit sample data.
■

If the floating best fit entity is synchronized with the best fit sample data, it maintains tangency when
the attachment entity is edited. The floating best fit entity geometry changes to adapt to changes to the
attachment entity, and continue to honor the regression points.

■

If the floating best fit entity is not synchronized with the best fit sample data, it behaves as a normal
floating entity. The floating best fit entity remains tangent to the attachment entity, and its geometry
will not change to honor the regression points.

To edit best fit regression data
1 Click the profile. Click Profile tab ➤ Modify Profile panel ➤ Geometry Editor
2 On the Profile Layout Tools toolbar, click

.

Edit Best Fit Data For All Entities.

NOTE You can also open the Regression Data vista from the Profile Entities vista. In the Constraint2 column,
click

.

3 In the Regression Data vista, edit the regression data as needed.
You can add, edit, or remove regression points.
4 Click

to apply the changes and close the Regression Data vista.

To synchronize a best fit profile entity to the regression data
1 Select the profile that contains the best fit entity.
2 Click Profile tab ➤ Modify Profile panel ➤ Geometry Editor
3 On the Profile Layout Tools toolbar, click
4 In the Regression Data vista, click

.

Edit Best Fit Data For All Entities.

Synchronize Entity To Best Fit Sample Data.

NOTE You can also synchronize the entity to the regression data from the Profile Entities vista. In the
Constraint2 column, click

.
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Quick Reference
Ribbon
Click the profile. Click Profile tab ➤ Modify Profile panel ➤ Geometry Editor
Menu
Click Profiles menu ➤ Edit Profile Geometry
Command Line
EditProfileLayout
Profile Layout Tools Toolbar Icon
Edit Best Fit Data For All Entities
Regression Data Vista Icon
Synchronize Entity To Best Fit Sample Data
Profile Entities Vista Icon

Dialog Box
Regression Data Vista (page 2226)
Profile Entities Vista (page 2416)

Applying Design Criteria to an Existing Layout Profile
Use the Profile Properties dialog box to apply design criteria to an existing profile.
The criteria-based design feature provides the ability to verify that your profile design meets the minimum
standards required by your local agency.
For more information, see Criteria-Based Profile Design (page 1139).
To apply design criteria to an existing profile
1 Click the profile. Click Profile tab ➤ Modify Profile panel ➤ Profile Properties drop-down ➤ Profile
Properties

.

2 In the Profile Properties dialog box, click the Design Criteria tab (page 2424).
NOTE To apply design criteria to a profile, there must be at least one design speed applied to the alignment
from which the profile was created.
3 Select the Use Criteria-Based Design check box.
4 Specify the following settings:
■

Use Design Criteria File
Select this check box to associate a design criteria file with the profile. The design criteria file field
and the Default Criteria properties become available when you select the check box.
NOTE The design criteria file that is applied to the parent alignment is used by default. A separate design
criteria file can be applied to the profile.
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■

Use Design Check Set
Select this check box to associate a design check set with the profile. The design check set list becomes
available when you select the check box. Select a design check set from the list.

5 Click OK.
NOTE The entire profile design is validated when you click either Apply or OK.

Quick Reference
Ribbon
Click the profile. Click Profile tab ➤ Modify Profile panel ➤ Profile Properties drop-down ➤ Profile Properties

Toolspace Shortcut Menu
Prospector tab: Right-click <profile item > ➤ Properties
Object Shortcut Menu
Right-click <profile object> ➤ Profile Properties
Command Line
EditProfileProperties
Dialog Box
Profile Properties (page 2423).

Viewing and Correcting Profile Design Criteria Violations
Use the warning symbols to verify whether the profile design meets the specified criteria and design checks.
When a profile uses the criteria-based design feature, the profile geometry must meet the design criteria
specified in the design criteria file (page 2773) and design checks (page 2772).
When a profile sub-entity violates the design criteria, a warning symbol is displayed in the following locations:
■

The drawing window — The
criteria.

warning symbol is displayed on each sub-entity that violates the design

NOTE The size of the warning symbol does not adjust automatically. After zooming in or out, enter REGEN
to resize the warning symbols.

■

The Profile Entities vista — The
warning symbol is displayed in the No. column of the sub-entity
that violates the design criteria. If a criteria in the design criteria file was violated, the warning symbol
is also displayed next to the specific criteria and parameter value that violates the design criteria.

■

The Profile Layout Parameters dialog box — If a criteria in the design criteria file was violated, the
warning symbol is displayed in the Design Criteria panel next to the Property that was violated, and in
the Layout Parameters panel next to the Parameter that was violated. If a design check was violated, the
warning symbol is displayed in the Design Checks panel next to the design check that was violated.
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You can use the
warning symbols in the drawing window to view information about criteria and design
checks that were violated. When the cursor is hovered over a warning symbol in the drawing window, a
tooltip displays information about the violation. If a design criteria was violated, the tooltip displays the
criteria that has been violated, as well as the minimum value required to meet the criteria. If a design check
was violated, the tooltip displays the name of the design check that has been violated.
BEST PRACTICE The name of the design check should be similar to the formula you enter in the Design Check
field. When a design check is violated, only the design check name is displayed, and not the minimum acceptable
value. If the formula is in the design check name, it is easier to correct the violation.
NOTE If a sub-entity violates more than one criteria or design check, only one warning symbol is displayed in the
drawing. To clear the warning symbol, the sub-entity must be modified to meet all the design criteria and design
checks.

Turning Off the Profile Warning Symbol
Change the visibility of the warning symbol that indicates violations in the profile design.
There are several ways to turn off the warning symbol. The following methods are listed in the order in
which they are recommended.

Modify the Profile Geometry
Edit the profile design to meet the specified design criteria. This option clears the warning symbols from
the drawing window, Profile Entities vista, and Profile Layout Parameters dialog box.
NOTE If a sub-entity violates more than one criteria or design check, only one warning symbol is displayed in the
drawing. To clear the warning symbol, the sub-entity must be modified to meet all the design criteria and design
checks.
For more information, see Correcting Profile Design Criteria Violations (page 1205).

Change the Profile Style
Turn off the Warning Symbol display component in the current profile style. Alternatively, create a separate
profile style that has the Warning Symbol display component turned off. This option clears the warning
symbols from the drawing window for profiles that use that style. The warning symbols are still displayed
in the Profile Entities vista and Profile Layout Parameters dialog box.
For more information, see Profile Styles (page 1122).

Turn Off the AutoCAD Civil 3D Solution Tip
The warning symbol is controlled by the Solution Tip setting in the Options dialog box on the AEC Editor
tab. To hide the warning symbol for all drawings, clear the Drafting check box. This option clears all alignment
and profile warning symbols from the drawing window. However, the warning symbols are still displayed
in the Profile Entities vista and Profile Layout Parameters dialog box.
For more information, see AEC Editor Tab (Options Dialog Box) (page 2751).
WARNING Settings in the Options dialog box affect the overall behavior of AutoCAD Civil 3D. If you clear the
Solution Tip Drafting check box, the warning symbol for all alignment and profile objects is hidden in every
drawing that is opened on the current installation of AutoCAD Civil 3D.

1204 | Chapter 26 Profiles

Turn Off the Criteria-Based Design Feature
Disassociate the design criteria from the profile. The profile design check set and/or the design criteria file
can be turned off in the Profile Properties dialog box. This option clears the warning symbols from the
drawing window, Profile Entities vista, and Profile Layout Parameters dialog box.
For more information, see Applying Design Criteria to an Existing Layout Profile (page 1202).
WARNING If you turn off the criteria-based design feature, the profile design will not be validated against any
design standards.

Correcting Profile Design Criteria Violations
Validate the profile geometry against the specified criteria and design checks.
When a profile uses the criteria-based design feature, the profile geometry must meet the design criteria
specified in the design criteria file (page 2773) and design checks (page 2772).
When a profile sub-entity violates the design criteria, a warning symbol is displayed in several locations.
For information about where the warning symbols appear, see Viewing and Correcting Profile Design Criteria
Violations (page 1203).
You can use the
warning symbols in the drawing window to view information about criteria and design
checks that have been violated. When the cursor is hovered over a warning symbol in the drawing window,
a tooltip displays information about the violation.
■

If a design criteria was violated, the tooltip displays the criteria that was violated, as well as the minimum
value required to meet the criteria.

■

If a design check was violated, the tooltip displays the name and formula of the design check that was
violated.

NOTE If a sub-entity violates more than one criteria or design check, only one warning symbol is displayed in the
drawing. To clear the warning symbol, the sub-entity must be modified to meet all the design criteria and design
checks.
To correct profile design criteria violations using grips
1 In the drawing window, hover the cursor over a

warning symbol.

A tooltip displays information about the violation.
2 Select the profile.
3 Use the profile grips to modify the profile geometry.
The

warning symbol disappears when the sub-entity meets the design criteria.

NOTE If a sub-entity violates more than one criteria or design check, only one warning symbol is displayed
on the sub-entity. To clear the warning symbol, the sub-entity must be modified to meet all the design
criteria.

To correct profile design criteria violations by entering numeric values
1 Click the profile. Click Profile tab ➤ Modify Profile panel ➤ Geometry Editor

.
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2 On the Profile Layout Tools toolbar, click

Profile Grid View.

3 In the Profile Entities vista, click the row that contains the

warning symbol in the No. column.

The sub-entity parameters are displayed in the Profile Layout Parameters dialog box.
4 In the Profile Layout Parameters dialog box, locate the
panels:

warning symbol in either of the following

■

Layout Parameters panel — In the Value column, enter a numeric value that meets the value specified
in the Constraints column.

■

Design Checks panel — Notice the design check that has been violated. Modify the profile design
to meet the parameters specified in the design check.

Quick Reference
Ribbon
Click the profile. Click Profile tab ➤ Modify Profile panel ➤ Geometry Editor
Menu
Click Profiles menu ➤ Edit Profile Geometry
Command Line
EditProfileLayout
Profile Layout Tools Dialog Box Icon
Profile Layout Parameters
Profile Grid View
Dialog Boxes
Profile Layout Tools (page 2419)
Profile Entities Vista (page 2416)
Profile Layout Parameters (page 2417)

Working with Profile Views
Use the profile view grid to display one or more profiles for a horizontal alignment.
You can configure data bands and profile annotations in a profile view to make it clearer or more informative
for the user.
A profile can be presented in either single, multiple, or stacked profile views:
■

A single profile view is typically used to design and edit a profile. It displays the specified station range
of the corresponding alignment in a single profile view grid.
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■

Multiple profile views are useful for plotting shorter segments of a profile in individual profile view grids
of a consistent length and vertical scale.

■

Stacked profile views are a collection of related profiles drawn in separate, vertically arranged profile
views. Typically a centerline profile is contained in one profile view, and its left and right offsets are
drawn in profile views that are placed above and below the centerline profile view.

A profile can be split within either a single or multiple profile view. This allows a profile view to display a
profile elevation range that is greater than the specified height of the profile view.
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See The Profile View Object (page 1115) for more information.

Creating Profile Views
Create a profile view to display a surface profile and offsets.
A profile view also provides the grid on which to draw a layout profile.
You can create profiles without displaying them on a profile view. When you create a profile view, you can
display any of the profiles created from a selected alignment.
The default name format for profile views is PV - (1), PV - (2), etc. You can edit the name format to suit your
business requirements.
An easy-to-use wizard guides you through the process of creating single, multiple, or stacked profile views.
In the process, you can specify whether to display pipe networks and hatch areas to show cut and fill regions.
Use multiple profile views to create final construction documents from a design. For best results, design your
profile in a single profile view, and then create multiple profile views for plotting.
See also:
■

Plan Production Tools (page 1901)

Creating a Single Profile View
Create a single profile view to display a surface profile and to design a layout profile.
Each profile view displays new or existing profiles and offsets for one horizontal alignment.

See also:
■

Creating Multiple Profile Views (page 1209)

■

Creating Stacked Profile Views (page 1211)

■

Creating a Superimposed Profile (page 1149)

To create a single profile view
1 Click Home tab ➤ Profile & Section Views panel ➤ Profile View drop-down ➤ Create Profile View
.
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2 In the Create Profile View wizard (page 2397), navigate through the pages by using the links at the left
or clicking Back or Next.
NOTE Click Create Profile View at any time to accept the current settings.
The wizard pages contain the following controls:
■

General page (page 2398) - Specify the alignment name and profile view name and description.
NOTE The Show Offset Profiles By Vertically Stacking Profile Views is only applicable when creating stacked
profile views.

■

Station Range page (page 2398) - Specify the starting and ending stations.

■

Profile View Height page (page 2398) - Specify the profile view height and any split profile options,
including split stations and styles for individual stations.

■

Profile Display Options page (page 2400) Specify the profiles to be drawn as well as their styles, labels,
and layers.

■

Pipe Network Display page (page 2402) - Specify the pipe networks or parts to be drawn.

■

Data Bands page (page 2402) - Specify the data band sets and their properties.

■

Hatch Options page (page 2403) - Specify how to mark areas between two profiles on the profile view,
such as where terrain must be cut or filled to create the design profile.

3 Click Create Profile View.
4 In the drawing window, click a location for the lower left corner (origin) of the profile view grid. The
profile view is drawn.

Quick Reference
Ribbon
Home tab ➤ Profile & Section Views panel ➤ Profile View drop-down ➤ Create Profile View
Menu
Profiles menu ➤ Create Profile View
Command Line
CreateProfileView
Wizard
Create Profile View (page 2397)

Creating Multiple Profile Views
Create multiple profile views to plot shorter segments of a profile in individual profile view grids of a
consistent length and vertical scale.
Each profile view in the series is an independent profile view object. Each profile view object appears in
Prospector, and you can modify the properties of each object independently.
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NOTE Multiple profile views are most useful when you are creating final construction documents from your design.
For best results, design your profile in a single profile view, then use the Plan Production Tools (page 1901) to create
multiple profile views for plotting.

To create multiple profile views
1 Click Home tab ➤ Profile & Section Views panel ➤ Profile View drop-down ➤ Create Multiple Profile
Views

.

2 In the Create Multiple Profile Views wizard (page 2397), navigate through the pages by using the links at
the left or clicking Back or Next.
NOTE Click Create Profile Views at any time to accept the current settings.
The wizard pages contain the following controls:
■

General page (page 2398) - Specify the alignment name and profile view name and description.
NOTE The option Show Offset Profiles By Vertically Stacking Profile Views is applicable only when creating
stacked profile views.

■

Station Range page (page 2398) - Specify the starting and ending stations.

■

Profile View Height page (page 2398) - Specify the profile view height and any split profile options,
including split stations and styles for individual stations.

■

Profile Display Options page (page 2400) Specify the profiles to be drawn as well as their styles, labels,
and layers.

■

Pipe Network Display page (page 2402) - Specify the pipe networks or parts to be drawn.

■

Data Bands page (page 2402) - Specify the data band sets and their properties.

■

Hatch Options page (page 2403) - Specify how to mark areas between two profiles on the profile view,
such as where terrain must be cut or filled to create the design profile.

■

Multiple Plot Options page (page 2404) - Specify how the multiple profile views will be laid out.

3 Click Create Profile Views.
4 In the drawing window, click a location for the origin of the profile view grid. The profile view is drawn.
NOTE The profile view grid origin is determined by the Start Corner setting on the Multiple Plot Options
page.

1210 | Chapter 26 Profiles

Quick Reference
Ribbon
Click Home tab ➤ Profile & Section Views panel ➤ Profile View drop-down ➤ Create Multiple Profile Views

Menu
Profiles menu ➤ Create Multiple Profile Views
Command Line
CreateMultipleProfileView
Wizard
Create Profile View (page 2397)

Creating Stacked Profile Views
Create stacked profile views to display a centerline profile and related offset profiles in vertically arranged
profile views.
Each profile view in the series or stack is an independent profile view object. Each profile view object appears
in Prospector, and you can modify the properties of each object independently.

To create stacked profile views
1 Click Home tab ➤ Profile & Section Views panel ➤ Profile View drop-down ➤ Create Profile View
.
OR
Click Home tab ➤ Profile & Section Views panel ➤ Profile View drop-down ➤ Create Multiple Profile
Views

.
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2 In the Create Profile View Wizard (page 2397) wizard, on the General page (page 2398), select the Show
Offset Profiles By Vertically Stacking Profile Views check box.
The link to the Stacked Profile page (page 2399) is displayed on the left.
3 On the General page, specify the alignment name and profile view name and description.
NOTE Click Create Profile Views at any time to accept the current settings.
4 On the Station Range page (page 2398), specify the starting and ending stations.
5 On the Profile View Height page (page 2398), specify the profile view height and any split profile options,
including split stations and styles for individual stations.
NOTE If the profile elevation values are relatively consistent, under the Profile View Datum By option, select
Mean Elevation. The Mean Elevation option vertically centers the profile line in the profile view, creating
equal space above and below the profile line.
6 On the Stacked Profile page, specify the number of stacked profile views, gap between the views, and
the profile view style to use in the top, middle, and bottom views.
NOTE The top and bottom profile views can use separate styles. All profile views between the top and bottom
must be created with the same style.
7 On the Profile Display Options page (page 2400), select a profile view from the Select Stacked View To
Specify Options For list.
8 In the Specify Profile Display Options table, specify the profiles to be drawn as well as their styles, labels,
and layers.
9 Repeat steps 7 and 8 for each profile view in the stack.
10 On the Pipe Network Display page (page 2402), specify which pipe networks or parts will be drawn in
each stacked profile view. Follow the workflow described in steps 7 through 9 to specify the options
for each stacked profile view.
11 On the Data Bands page (page 2402), specify the data band sets and their properties.
The data bands will appear at the top or bottom of the stack.
12 For multiple, stacked profile views, on the Multiple Plot Options page (page 2404), specify how the multiple
profile views will be laid out.
13 Click Create Profile Views.
14 In the drawing window, click a location for the origin of the stack of profile views.
NOTE The profile view grid origin is determined by the Start Corner setting on the Multiple Plot Options
page.

Quick Reference
Menu
Profiles menu ➤ Create Profile View
Profiles menu ➤ Create Multiple Profile Views
Command Line
CreateProfileView
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CreateMultipleProfileView
Wizard
Create Profile View (page 2397)

Editing Profile Views
Edit profile views to change their contents, properties, and styles.
Use two dialog boxes to edit profile views:
■

Use the Profile View Properties dialog box (page 2427) to specify the name, profile view style, profile extents,
included profile lines, data bands, and hatch options.

■

Use the Profile View Style dialog box (page 2435) to specify the annotation, vertical exaggeration, profile
direction, grid format, and displayed elements.

You can change properties for an individual profile view. However, any changes in the Profile View Style
dialog box affect all profile views that use that style. Therefore, if you must change one or more style items,
create a style that can be applied where required.
Typical editing activities:
■

Add or delete profile lines.

■

Change the display style.

■

Add or delete data bands that display data such as stations, elevations, and horizontal geometry.

In the Profile View Properties dialog box, use the Draw check box to turn existing profiles on or off in the
profile view. To delete a profile from the drawing, select it in the profile view and press the Delete key.
If you want to superimpose a profile from another alignment on a profile view, see Creating a Superimposed
Profile (page 1149).

Adding Profile Lines to a Profile View
Add profile lines to an existing profile view grid.
This procedure assumes that the profile lines you want to add have already been created in the drawing. To
create a profile, see Creating Surface Profiles (page 1142) or Creating Layout Profiles (page 1143).
To add profile lines to a profile view
1 Click the profile view grid.
2 Click Profile tab ➤ Modify View panel ➤ Profile View Properties drop-down ➤ Profile View Properties
.
3 In the Profile View Properties Dialog Box (page 2427), click the Profiles tab (page 2429).
4 In the tables of profiles, select the Draw check box for each profile you want to add to the profile view.
5 Click OK.
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Quick Reference
Ribbon
Click profile view. Click Profile tab ➤ Modify View panel ➤ Profile View Properties drop-down ➤ Profile
View Properties
Object Shortcut Menu
Right-click profile view object ➤ Profile View Properties
Toolspace Shortcut Menu
Prospector tab: Sites ➤ <Site name> ➤ Alignments ➤ <Alignment name> ➤ Profile Views, right-click
<profile view name> ➤ Properties
Dialog Box
Profile View Properties (page 2427)

Changing a Profile View Style
Change the appearance of a profile view by changing its style.
The profile view style controls the format of the graph on which the profiles are displayed, as well as the
title and annotations on the axes.
Profile view styles are useful when your project transitions to a new phase. In the design phase, you can use
one profile style that has few grid elements and limited annotation. Limiting annotation and grid elements
reduces drawing size and improves drawing performance. A second style can be used for plotting. The plotted
profile view style can be extensively annotated and use more graph elements than the design style.
If you are working with a split profile view, the Object Style field on the Profile View Properties - Information
tab (page 2428) is ignored. Use the Profile View Style fields on the Elevations tab (page 2428) to change split
profile view styles.
See also:
■

Profile View Styles (page 1124)

To change a profile view style
1 In the drawing window, select the profile view.
2 Click Profile tab ➤ Modify View panel ➤ Profile View Properties drop-down ➤ Profile View Properties
.
3 In the Profile View Properties dialog box, on the Information tab (page 2428), select a style from the
Object Style list.
4 Click OK.
To change a split profile view style
1 In the drawing window, select the profile view.
2 Click Profile tab ➤ Modify View panel ➤ Profile View Properties drop-down ➤ Profile View Properties
.
3 In the Profile View Properties Dialog Box (page 2427), click the Elevations tab (page 2428).
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4 In the Split Profile View area, select a different style for the desired segment by name from the Profile
View Style list.
NOTE The start, intermediate, and end segments can each use a different style.

Quick Reference
Ribbon
Click profile view. Click Profile tab ➤ Modify View panel ➤ Profile View Properties drop-down ➤ Profile
View Properties
Object Shortcut Menu
Right-click profile view object ➤ Profile View Properties
Toolspace Shortcut Menu
Prospector tab: Sites ➤ <Site name> ➤ Alignments ➤ <Alignment name> ➤ Profile Views, right-click
<profile view name> ➤ Properties
Command Line
EditGraphProperties
Dialog Box
Profile View Properties (page 2427)

Adding Data Bands to a Profile View
Add data bands that display data such as stations, elevations, and horizontal geometry.
Place data bands along the top or bottom of a profile view grid to annotate the various profile lines with
station and elevation data, vertical or horizontal geometry points, or superelevation, sectional, or pipe
network data. You can also group a set of commonly used data bands into a band set that can be applied to
a profile view as a single selection.
NOTE The individual geometry points to label can be specified with the Profile Data band type.
See also:
■

Profile View Band Styles (page 1133)

■

Profile View Band Sets (page 1135)

■

Staggering Data Band Labels (page 1707)

To add data bands to a profile view
1 Click the profile view grid.
2 Click Profile tab ➤ Modify View panel ➤ Profile View Properties drop-down ➤ Profile View Properties
.
3 In the Profile View Properties Dialog Box (page 2427), click the Bands tab (page 2430).
4 In the List Of Bands area, select either the bottom or the top of the profile view as the location for the
new data band.
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5 Select a band type and style. Click Add.
If you add the Profile Data band type, use the Geometry Points to Label in Band dialog box (page 2412)
to specify the individual alignment and profile points to label with the selected style.
6 If you want to add more bands to the profile view, repeat steps 3 and 4. The List Of Bands is arranged
in the same order as the actual bands on the profile view.
7 Use the three buttons on the right side of the List Of Bands to arrange the bands as desired. You can
move selected data bands up

or down

in the stack, and delete unwanted bands

.

8 Optionally, click Save As Band Set to save this arrangement of data bands as a set for reuse with other
profile views. For more information, see Profile View Band Sets (page 1135).
9 Click OK. The bands are displayed in the profile view.

Quick Reference
Ribbon
Click profile view. Click Profile tab ➤ Modify View panel ➤ Profile View Properties drop-down ➤ Profile
View Properties
Object Shortcut Menu
Right-click profile view object ➤ Profile View Properties
Toolspace Shortcut Menu
Prospector tab: Sites ➤ <Site name> ➤ Alignments ➤ <Alignment name> ➤ Profile Views, right-click
<profile view name> ➤ Properties
Command Line
EditGraphProperties
Dialog Box
Profile View Properties (page 2427)

Adding Hatch Areas to a Profile View
Add hatch areas to highlight cut and fill regions along the profiles.
You can choose to hatch cut areas, fill areas, and areas with multiple surfaces as boundaries. You can also
import quantity takeoff (QTO) criteria as a basis for defining hatch areas.
Define hatch areas when a profile view is created, or add them to an existing profile view by editing profile
view properties.
For each hatch area type, specify which profiles to use for upper and lower boundaries, and which shape
style to use for the hatching. These styles are found on the Toolspace Settings tab ➤ General ➤ Multipurpose
Styles ➤ Shape Styles.
See also:
■

Hatch Tab (Profile View Properties Dialog Box) (page 2432)

■

Hatch Options Page (Create Profile View Wizard) (page 2403)

■

Creating Profile Views (page 1208)
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To add hatch areas to a profile view
1 Click the profile view grid.
2 Click Profile tab ➤ Modify View panel ➤ Profile View Properties drop-down ➤ Profile View Properties
.
3 In the Profile View Properties Dialog Box (page 2427), click the Hatch tab (page 2432).
4 Use the buttons on the left side to add hatch areas for Cut Area, Fill Area, Multiple Boundaries, or From
Criteria.
5 For each hatch area, review the profiles specified for upper and lower boundaries. If necessary, select
different profiles from the list beside each boundary.
6 Optionally, review the shape styles assigned to the hatch area types, and make any desired changes.
7 Click OK. The hatch areas are displayed in the profile view.

Quick Reference
Ribbon
Click profile view. Click Profile tab ➤ Modify View panel ➤ Profile View Properties drop-down ➤ Profile
View Properties
Object Shortcut Menu
Right-click profile view object ➤ Profile View Properties
Toolspace Shortcut Menu
Prospector tab: Sites ➤ <Site name> ➤ Alignments ➤ <Alignment name> ➤ Profile Views, right-click
<profile view name> ➤ Properties
Command Line
EditGraphProperties
Dialog Box
Profile View Properties (page 2427)

Using AutoCAD Object Snaps with Profiles and Profile Views
The following Object Snap modes are supported with profiles and profile views:
Osnap

Dynamic Profile Static Profiles

Profile Views

Endpoint

Yes

Yes

Yes (grid lines and
axes)

Midpoint

Yes

Yes

Yes (grid lines and
axes)

Center

No

No

No

Node

No

No

Yes (tick marks)

Quadrant

No

No

No

Using AutoCAD Object Snaps with Profiles and Profile Views | 1217

Osnap

Dynamic Profile Static Profiles

Profile Views

Intersection

Yes

No

Yes (grid lines and
axes)

Extension

No

No

No

Insertion

No

No

No

Perpendicular

No

No

No

Tangent

No

No

No

Nearest

Yes

Yes

Yes (grid lines and
axes)

Apparent
Intersection

No

No

No

Parallel

No

No

No

Working with Projected Objects in Profile Views
Visualize the location of an object in relation to a surface profile or section.
Projected objects (page 2780) can display their station location and elevation.
TIP Before projecting an object into a view, ensure that the elevation of the object has been specified. If the object
has a default elevation of 0, the view will be vertically expanded to include the 0 elevation if the Elevation Range
of the view is set to Automatic Height. For more information, see To project objects to a profile view (page 1219).
The following object types can be projected:
■

AutoCAD Civil 3D objects: Points, feature lines, and survey figures

■

AutoCAD objects: points, blocks, MView blocks, 3D solids, and 3D polylines

Pipe networks have a separate procedure for projection into profile views. See Displaying Pipe Networks in
Profile Views (page 1364) and Displaying Pipe Networks in Section Views (page 1366).

Editing Projected Objects
The station location of a projected object always reflects the location of the source object, so it can only be
changed by moving the source object.
The style and elevation of projected objects can be edited on the Projections tab of the Profile View Properties
(page 2427) or the Section View Properties (page 2542) dialog boxes.
The elevation of a projected object can be set to Use Object. This is a dynamic setting that ensures the
elevation of the projected object and the source object are the same. If the source object is edited, the
projected object reflects any changes. Elevations can also be set to match a specific surface or profile.
The elevation of some projected objects can be edited using grips. The exceptions are three object types in
profile views:
■

Survey figures
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■

Feature lines embedded in a corridor

■

Feature lines dynamic to an alignment

Grip editing the vertices of feature lines or 3D polylines in a profile view also changes the elevations of the
source objects in plan view. This behavior is useful for editing feature lines in relation to profiles. Grips
appear on 3D polylines only if the elevation is set to Use Object.
Grip editing point or block objects in profile or section views does not affect the elevations of source objects,
but it does break the dynamic link to the source object elevation. The Elevation Options setting changes to
Manual. At any time you can change this setting to Use Object, or to match a specific surface or profile.
The object and label styles of a projected object are independent of the styles used by the source object in
plan view. You can edit the styles of a projected object without affecting the source object.
See also:
■

Projecting Objects to a Single Section View (page 1265)

■

Editing Section View Properties (page 1263)

■

Setting Profile View Properties (page 1137)

Adding Projected Objects to a Profile View
Project AutoCAD or AutoCAD Civil 3D objects from plan view into a profile view.
You can project AutoCAD points, blocks, 3D solids, and 3D polylines; you can also project AutoCAD Civil
3D COGO points, feature lines, and survey figures.
To project objects to a profile view
1 Click Home tab ➤ Profile & Section Views panel ➤ Profile View drop-down ➤ Project Objects To Profile
View

.

2 Click one or more objects in the drawing that you want to project. Right-click or press Enter after all
objects are selected.
3 Click the profile view in which you want the objects to appear.
4 In the Project Objects to Profile View dialog box (page 2442), verify the settings such as Elevation Options
and Label Style, then click OK.
5 If the elevation of one or more objects is outside of a manually specified profile view elevation range,
a task dialog box is displayed. Click one of the following:
■

Do Not Add Objects Outside Of Limits: Does not add objects that are outside the range of the profile
view.

■

Add All Objects: Adds all objects, regardless of their elevation. Some objects may not be visible in
the profile view, but they are still associated with the profile view and are visible on the Profile View
Properties dialog box Projections tab.
NOTE You can make the object visible by changing the elevation property of the profile view. On the
Profile View Properties dialog box, Elevations tab, change User Specified Height to Automatic Height.
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Quick Reference
Ribbon
Click Home tab ➤ Profile & Section Views panel ➤ Profile View drop-down ➤ Project Objects To Profile
View
Command Line
ProjectObjectsToProf
Dialog Box
Projections Tab (Profile View Properties Dialog Box) (page 2433)
Project Objects to Profile View Dialog Box (page 2442)

Editing the Style of a Projected Object
Change the appearance of a projection, without affecting the source object.
Projected AutoCAD Civil 3D objects use standard style editing dialog boxes for points, feature lines, and
survey figures. Projected AutoCAD objects use multipurpose styles that control the appearance of different
object types in profile views and section views.
To edit a projection style
1 In the drawing window, in a profile view or section view, select the object for which to change the
style. Right-click. Click the menu option for the object type: Edit Point Style, Edit Feature Line Style,
Edit Survey Figure Style, or Edit Projection Style.
OR
In Toolspace, on the Settings tab, expand General ➤ Multipurpose Styles ➤ Projection Styles. Right-click
the style you want to change. Click Edit.
NOTE Multipurpose Projection Styles are used for AutoCAD objects. Each Projection Style includes settings
for all types of AutoCAD objects that can be projected. Ensure that you have the correct object selected in
the drop-down list when you are making the edits to the style.
2 In the Projection Styles dialog box, make changes as required.

Quick Reference
Ribbon
Click the projected object. Click Projected Object tab ➤ Modify Projected Object panel ➤ Projection
Properties drop-down ➤ Edit Style
Object Shortcut Menu
Right-click projected object ➤ Edit Projection Style
Toolspace Shortcut Menu
Settings tab: General ➤ Multipurpose Styles ➤ Projection Styles
Command Line
EditProjectionStyle
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Dialog Box
Projection Styles Dialog Box (page 2023)

Removing a Projected Object from a Profile View
Select a projected object and remove it from the profile view.
Other projected objects not selected in the profile view remain in place.
To remove a projected object
■

Click the projected object. Click Projected Object tab ➤ Modify Projected Object panel ➤ Remove From
View

.

Quick Reference
Ribbon
Click the projected object. Click Projected Object tab ➤ Modify Projected Object panel ➤ Remove From
View
Command Line
RemoveFromProfileView

Viewing Projected Objects on Sheets
To view projected objects on sheets created with the Plan Production tools, you must project the objects
after using the Create Sheets command.
The Create Sheets command creates new profile views in the drawing to represent the station ranges of the
view frames that are created with the Create View Frames command. To display them on the sheets, the
projected objects must be projected onto these new profile views.
To view projected objects on sheets
1 Create view frames (page 1905).
2 Create sheets (page 1910). On the first page of the wizard, select All Layouts In The Current Drawing.
NOTE Creating the sheets in the same drawing as the model space objects makes it simpler to display
projected objects on those sheets. The object projection feature requires the source object to be in the same
drawing as the profile view, so if you create the layouts (and thus the profile views) in separate drawings, the
objects to be projected would also have to be copied to those drawings before they could be projected.
3 Project (page 1219) the desired objects onto the profile views created by the Create Sheets command.

Profile Command Reference
Use commands for quick access to profile functionality.
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The following table lists the profile-related AutoCAD Civil 3D commands and briefly describes their
functionality.
Command

Description

AddProfilePVI

Adds a point of vertical intersection (PVI)
to a profile (page 1194).

AddProfileViewDepthLbl

Adds a depth label to a profile view (page
1132).

AddProfileViewLabels

Adds labels to profile views (page 1132).

AddProfileViewStaElevLbl

Adds a station elevation label to a profile
view (page 1132).

C3D_BestFitProfile

Creates a profile that follows the most logical path through a series of feature lines,
COGO points, surface profiles, or AutoCAD
3D polylines, points, or blocks (page 1154)

CreateMultipleProfileView

Creates multiple profile views (page 1210).

CreateProfileFromCorridor

Creates a profile from a corridor feature
line (page 1530).

CreateProfileFromFile

Creates a profile from a specified text file
(page 1145).

CreateProfileFromSurface

Creates a profile from a surface (page 1142).

CreateProfileLayout

Creates a layout profile on an existing
profile view (page 1143).

CreateProfileReference

Creates a profile reference (page 1150).

CreateProfileView

Creates a single section view (page 1208).

CreateProfileViewStyle

Creates a profile view style (page 1125).

CreateQuickProfile

Creates a quick profile (page 1153).

DeleteProfilePVI

Deletes a specified PVI from a profile line
(page 1194).

DesignCriteriaEditor

Edits an alignment design criteria file (page
939).

EditProfileLabels

Edits the labels on a profile line (page 1129).

EditProfileLayout

Edits the layout of the specified profile
(page 1191).

EditProfileProperties

Edits the properties of the selected profile
(page 1137).

EditProfileViewStyle

Edits a profile view style (page 1126).
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Command

Description

ProjectObjectsToProf

Projects objects to a profile view (page 1219).

RemoveFromProfileView

Removes projected objects from a profile
view (page 1221).

SuperimposeProfile

Creates a superimposed profile (page 1149).
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Sections

27

Use sections (also referred to as cross sections) to provide a view of the terrain cut at an angle across a linear feature, such
as a proposed road.
Typically, sections are cut across horizontal (plan) alignments at a specified station interval using specified swath widths.
These sections are then plotted, individually for a station, or as a group for a range of stations.
AutoCAD Civil 3D handles the creation, management, and plotting of sections with the following components:
■

Sections. Terrain elevations that cut across surfaces, including corridor surfaces, which are associated with a specified
sample line (page 2782) group. Elevations are sampled at each of the sample line XY vertices and also at locations where
the vertical plane defined by the sample line intersects with surface edges.

■

Section Views. For each sample line, views displaying some or all of the sections sampled at that sample line. This
graphical view has both horizontal limits based on the length of corresponding sample line and vertical values based
on the minimum and maximum elevations from the set of sections it is displaying.

■

Section Sheets. You can generate production-quality section layouts for plotting. For more information, see To create
layouts for section plotting (page 1934).

NOTE Before creating sections, a surface and one or more horizontal alignments must exist.
For more information, see Creating and Editing Sample Lines and Sections (page 1246).
Sections Workflow (page 52)

Understanding Sections
You can use sections to examine existing and proposed surface elevations sampled across an alignment at
defined station intervals.
In AutoCAD Civil 3D, section data is defined and displayed using sample lines, sections, and section views,
all of which are managed through a collection called a sample line group. An alignment can have more than
one sample line group associated with it, each having a unique set of sample lines and sections.
For overview information about AutoCAD Civil 3D objects, see Understanding Objects and Styles (page 63).
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Sample Line Object
Use a sample line as a linear plan object representing the direction along which sections are cut for a set of
specified surfaces.

Sample lines are linear objects that are used to cut sections across an alignment. Sample lines have their
own styles and can be labeled (for example, SL-29). A set of sample lines makes up a named collection called
a sample line group. A sample line group centrally manages the display styles and label styles for a number
of sample lines, sections, section views, and mass haul lines and mass haul views.
Sample line groups related to an alignment are displayed in the Toolspace Prospector tree under that
alignment.

Section Object
Use a section object to examine surface elevations along a sample line (across an alignment). In AutoCAD
Civil 3D, each section is an object.
Sections cut across a linear feature, to a specified distance to the left and right. Typically, sections are cut at
given stations along a horizontal alignment.
A section is an object containing elevation data along a sample line. Each surface that intersects the vertical
plane defined by the sample line results in a section object. The type of section object is defined by the
elevation source, such as the TIN surface. Sections can also be extracted from corridor surfaces, corridors,
and pipe networks along a sample line.
When you create sample lines along an alignment, the section objects are also created for a specified set of
existing or proposed surfaces. The default set of surfaces to sample at each sample line are specified through
a sample line group. To plot the sections in the drawing, create individual section views or multiple section
views.

1226 | Chapter 27 Sections

A group of sample lines

A section object is defined by the following components:
■

Vertices or grade break points, where a grade line ends and another line might begin

■

Line segments, which detail the grade of the surface between two grade break points

For example, if a section is sampled from a TIN surface, then the grade breaks are extracted at the point
where the (vertical plane defined by) sample lines intersect with the TIN edges. Elevation between these two
line segments is linearly interpolated and joined with a straight line (assuming that the sample line between
these two points is also a straight line).
Sections, like alignments and profiles, support label sets. Label sets enable you to save and apply an unlimited
number of different types of labels.

Section view of a sample line
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Corridor Section Object
The corridor section object is a special type of section object that displays assemblies as applied in a corridor
at a specified (corridor) station. While surface-created sections are usually line items with a series of lines
joining various grade breaks, corridor-created sections can display closed shapes and multiple layers.
This sectional design is accomplished using subassembly and assembly objects. Subassemblies are design
elements that define sectional geometry of a specified part or element used in typical sections. Assemblies
are collections of subassemblies that form shapes of typical sections. These assemblies can be displayed at
each station in a section view. Each station is created along the alignment at either a baseline or a controlling
offset of that corridor.
For more information, see Assemblies and Subassemblies (page 1537) and Corridors (page 1471).

Pipe Network Section Object
The pipe network section object is a special type of section object. It shows pipe networks at a specified
station. While surface-created sections are usually line items with a series of lines joining various grade
breaks, pipe-created sections can display closed (pipe) shapes.
For more information, see Pipe Networks (page 1325).

Section View Object
Create section view objects to display sectional data in the drawing.
The section view object displays sectional data (both existing and finished ground/designed) along a sample
line, at any given station along a horizontal alignment. A section view shows a section created from either
a surface (TIN or corridor), a corridor (which is an assembly at a specified station), or a pipe network. Bands
can also be displayed above or below the section view.
A section view, which is very similar to a profile view, is essentially a grid or graph with specific characteristics
that are controlled by a section view style. Section views that relate to a sample line are stored in the Prospector
tree in Toolspace under that sample line. Individual section views are accessible in Toolspace using the item
view. If you delete a sample line in the drawing, section views under that sample line are also deleted.
A section view can include projections of other objects in the drawing that you want to see in relation to a
section. See Projecting Objects to a Single Section View (page 1265) for more information.

Section Object Relationships
Since sample line geometry controls where surfaces are sampled to create section objects, sample lines are
the parent of the section object.
You create one or more section views along a sample line to graphically represent section objects at that
location across an alignment. Thus, each section and section view are children of a sample line. Each sample
line is associated with a sample line group, which is in turn associated with an alignment.
Profiles are longitudinal sections cut along a linear feature and are also children of the parent alignment.
For more information, see Profiles (page 1113).

Sample Line Groups Collection (Prospector Tab)
Use the Sample Line Groups
collection to access the sample lines, sections, section views, mass haul
lines, and mass haul views in a drawing.
As sample line groups are created, they are displayed as named sample line groups, such as SLG-1, in the
Sample Line Groups collection.
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Sample lines, in turn, are displayed as named sample lines, such as SL-1, in the named sample line groups,
which are located in the Sample Line Groups collection:

If one or more sample line groups have been added to the current drawing, expand the Sample Line Groups
collection to view the names of the sample line groups. A tabular list of the sample line groups is displayed
in the item view at the bottom of the Prospector tab.
Select Sample Lines of an individual sample line group to display the sample line group’s named sample
lines in the item view at the bottom of the Prospector tab. Similarly, expand the subordinate sections, section
views, mass haul lines and mass haul views collections to display in the item view the individual sections,
section views, mass haul lines and mass haul views. For more information, see The Toolspace Item View
(page 99).
Right-click a named sample line group to:
■

Access the sample line group’s properties (page 2515).

■

Zoom or pan to the extents of the sample line group.

■

Refresh the view of the Sample Line Groups collection.

Sections Collection (Prospector Tab)
Use the Sections

collection to access the sections in a drawing.

As section objects are created, they are displayed as named sections, such as SLG-1-SL-1-EG(1), in the Sections
collection for each named sample line.
If one or more sections has been added to the current drawing, expand the Sections collection to view the
names of the sections. A tabular list of the various types of sections is displayed in the Prospector list view.
These may include:
■

Surface sections

■

Corridor sections

■

Corridor surface sections

■

Pipe network sections

■

Material list sections

When each type of section is selected, a tabular list of individual sections of that type is displayed in the
item view at the bottom of the Prospector tab. For more information, see The Toolspace Item View (page
99).

Section View Groups Collection (Prospector Tab)
Use the Section View Groups

collection to access the section views in a drawing.
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As individual section view objects are created, they are displayed as named section views, such as 0+00.00(1),
in the item view under Individual Section Views in the Section View Groups collection for each named
sample line.
As multiple section view objects are created, they are displayed as named section views, in the item view
under their parent section view group in the Section View Groups collection.
For more information, see The Toolspace Item View (page 99).

Sample Line Collection (Settings Tab)
Use this collection in the Toolspace Settings tree to manage sample line settings, sample line styles, sample
line label styles, and sample line command settings.
Right-click the Sample Line collection to:
■

Edit the sample line feature settings

■

Edit the sample line label style defaults

■

Refresh the display of the sample line settings collection

For more information about the contents of this shortcut menu, see “The Object Collection (Settings Tree)”.
Expand the Sample Line collection to display and edit the styles and command settings that are available
for sample lines.
For information about...

See...

Sample line settings

Sample Line, Section, and Section View Settings
(page 1231)

Sample line styles

Sample Line, Section, and Section View Styles (page
1234)

Sample line label styles

Using Sample Line Labels (page 1241)

Sample line commands

Sections Command Reference (page 1272)

Section Collection (Settings Tab)
Use this collection in Toolspace in the Settings tree to manage section settings, section styles, and section
label styles.
Right-click the Section collection to:
■

Edit the section feature settings

■

Edit the section label style defaults

■

Refresh the display of the sample line settings collection

For more information about the contents of this shortcut menu, see The Object Collection (Settings Tree)
(page 110).
For information about...

See...

Section settings

Section Settings (page 1232)
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For information about...

See...

Section styles

Creating and Editing Section Styles (page 1236)

Section label styles

Using Section Labels (page 1242)

Section View Collection (Settings Tab)
Use this collection in Toolspace in the Settings tree to manage section view settings, section view styles,
section view label styles, data band styles, group plot styles, sheet styles, and section view command settings.
Right-click the Section View collection to:
■

Edit the section view feature settings

■

Edit the section view label style defaults

■

Refresh the display of the sample line settings collection

For more information about the contents of this shortcut menu, see The Object Collection (Settings Tree)
(page 110).
For information about...

See...

Section view settings

Section View Settings (page 1233)

Section view styles

Creating and Editing Section View Styles (page 1237)

Section view label styles

Using Section View Labels (page 1243)

Band styles

Creating and Editing Section View Styles (page 1237)

Sheet styles

Creating and Editing Section View Styles (page 1237)

Group plot styles

Creating and Editing Section View Styles (page 1237)

Section view commands

Sections Command Reference (page 1272)

Sample Line, Section, and Section View Settings
You can change the default style and name format settings for sample lines, sections, and section views.
Settings are handled in a standard way throughout AutoCAD Civil 3D via the Settings tree at three levels:
drawing, feature, and command. For more information, see Understanding Settings (page 77).

Sample Line Settings
To establish default settings for all sample lines, in the Settings tree, right-click the Sample Line collection.
To change settings for the CreateSampleLine command, expand the Commands collection in the Sample
Line collection and right-click the CreateSampleLine command.
The default styles and name format settings for sample line commands are described in this topic. Drawing
ambient settings are described in Specifying Drawing Settings (page 79).
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NOTE Overrides to the drawing ambient settings at the Sample Line collection level and the Command collection
level affect only the specified level. The drawing level settings are not changed. For more information, see The
Commands Collections (Settings Tree) (page 114).
To change sample line settings
1 In Toolspace, on the Settings tab, right-click the Sample Line collection. Click Edit Feature Settings.
In the Edit Feature Setting - Sample Line dialog box, note that
appears next to the settings for default
styles and default name format, marking them as specific to sample lines.
2 Expand the default styles and the default name format to see the current settings.
3 In the Value column, click the entry you want to change.
4 Click

to open a dialog box. Modify the value.

5 In the Edit Feature Settings - Sample Line dialog box, click OK.

Quick Reference
Toolspace Shortcut Menu
Settings tab: right-click Sample Line collection ➤ Edit Feature Settings
Dialog Box
Edit Feature Settings - Sample Line (page 2499)

Section Settings
You can change the default style and name format settings for sections.
To establish default settings for all sections, in the Settings tree, right-click the Section collection.
The default styles and name format settings for sections are described in this topic. Drawing ambient settings
are described in Specifying Drawing Settings (page 79).
NOTE Overrides to the drawing ambient settings at the Section collection level affect only the specified level. The
drawing level settings are not changed. For more information, see The Commands Collections (Settings Tree)
(page 114).
To change section settings
1 In Toolspace, in the Settings tree, right-click the Section collection. Click Edit Feature Settings.
In the Edit Feature Settings - Section dialog box, note that
appears next to the settings for default
styles and the default name format, marking them as specific to sections.
2 Expand the default styles and the default name format to see the current settings.
3 In the Value column, click the entry you want to change.
4 Click

to open a dialog box. Modify the value.

5 In the Edit Feature Settings - Section dialog box, click OK.
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Quick Reference
Toolspace Shortcut Menu
Settings tab: right-click Section collection ➤ Edit Feature Settings
Dialog Box
Edit Feature Settings - Section (page 2501)

Section View Settings
You can change the default style and name format settings for section views and section view commands.
To establish default settings for all section views, in the Settings tree, right-click the Section View collection.
To change settings for a specific command, use the Commands collection in the Section View collection.
The default styles and name format settings for section view commands are described in this topic. Drawing
ambient settings are described in Specifying Drawing Settings (page 79).
NOTE Overrides to the drawing ambient settings at the Section View collection level and the Command collection
level affect only the specified level. The drawing level settings are not changed. For more information, see The
Commands Collections (Settings Tree) (page 114).
To change section view settings
1 In Toolspace, in the Settings tree, right-click the Section View collection. Click Edit Feature Settings.
In the Edit Feature Settings - Section View dialog box, note that
appears next to the settings for the
default styles and the default name format, marking them as specific to section views.
2 Expand the default styles and the default name format to see the current settings.
3 In the Value column, click the entry you want to change.
4 Click

to open a dialog box. Modify the value.

5 In the Edit Feature Settings - Section View dialog box, click OK.

Quick Reference
Toolspace Shortcut Menu
Settings tab: right-click Section View collection ➤ Edit Feature Settings
Dialog Box
Edit Feature Settings - Section View (page 2501)

Sample Line, Section, and Section View Styles and Display
Styles control the way a sample line, section, and section view is displayed in a drawing. Sample lines,
sections, and sections views have label styles that control the appearance and behavior of their labels in a
drawing.

Section View Settings | 1233

Sample Line, Section, and Section View Styles
Use styles to control how sample lines, sections, and section views are displayed in a drawing.
In AutoCAD Civil 3D, all objects have a standard object style grouping on the Settings tree, called an object
style collection. You use this to create, edit, copy, and delete the styles for that object. For more information,
see The Object Style Collection (Settings Tree) (page 111).

Creating and Editing Sample Line Styles
Use the Toolspace Settings tree to create, copy, edit, or delete a sample line style.
Create a new style by copying an existing style. Then change its properties to suit your requirements. Use
the Sample Line Style dialog box (page 2525) tabs to specify the main properties.
NOTE Before editing an existing sample line style to change its properties, remember that any changes you make
will apply to all sample lines that use the style. If you want to change the style of some sample lines but not all,
consider creating a new style.

Creating a Sample Line Style
To create a new sample line style
1 In Toolspace, in the Settings tree, expand the Sample Line Styles collection.
2 Do one of the following:
■

Right-click Sample Line Styles collection. Click New.

■

Right-click the existing style to use as a template. Click Copy.

3 In the Sample Line Style dialog box (page 2525), enter or change the name of the style and other settings
as required.
4 Click OK.

Quick Reference
Toolspace Shortcut Menu
On the Settings tab, right-click Sample Line Styles collection ➤ New
Command Line
CreateSampleLineStyle
Dialog Box
Sample Line Style (page 2525)

Copying a Sample Line Style
To copy an existing sample line style
1 In Toolspace, in the Settings tree, expand the Sample Line Styles collection.
2 Right-click the existing style. Click Copy.
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3 In the Sample Line Style dialog box (page 2525), change the name of the style and other settings as
required.
4 Click OK.

Quick Reference
Toolspace Shortcut Menu
On the Settings tab, Sample Line Styles collection, right-click <style name> ➤ Copy
Dialog Box
Sample Line Style (page 2525)

Editing a Sample Line Style
To edit a sample line style
1 In Toolspace, in the Settings tree, expand the Sample Line Styles collection.
2 Right-click the existing style. Click Edit.
3 In the Sample Line Style dialog box (page 2525), change settings as required.
4 Click OK.

Quick Reference
Toolspace Shortcut Menu
On the Settings tab, Sample Line Styles collection, right-click <style name> ➤ Edit
Command Line
EditSampleLineStyle
Dialog Box
Sample Line Style (page 2525)

Deleting a Sample Line Style
To delete a sample line style
1 In Toolspace, in the Settings tree, expand the Sample Line Styles collection.
2 Right-click the style to delete. Click Delete.
3 In the confirmation dialog box, click Yes.

Quick Reference
Toolspace Shortcut Menu
On the Settings tab, Sample Line Styles collection, right-click <style name> ➤ Delete
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Creating and Editing Section Styles
Use the Toolspace Settings tree to create, copy, edit, or delete a section style.
Create an entirely new style, or create a new style by copying an existing style. Change its properties to suit
your requirements. Use the Section Style dialog box (page 2534) tabs to specify the main properties.
NOTE Before editing an existing section style to change its properties, remember that any changes you make will
apply to all sections that use the style. To change the style of some sections, but not all, consider creating a new
style.

Creating a Section Style
To create a new section style
1 In Toolspace, in the Settings tree, expand the Section Styles collection.
2 Do one of the following:
■

Right-click Section Styles collection. Click New.

■

Right-click the existing style you want to use as a template. Click Copy.

3 In the Section Style dialog box (page 2534), change the name of the style and other settings as required.
4 Click OK.

Quick Reference
Toolspace Shortcut Menu
On the Settings tab, right-click Section Styles collection ➤ New
Command Line
CreateCrossSectionStyle
Dialog Box
Section Style (page 2534)

Copying a Section Style
To copy an existing section style
1 In Toolspace, in the Settings tree, expand the Section Styles collection.
2 Right-click the existing style. Click Copy.
3 In the Section Style dialog box (page 2534), change the name of the style and other settings as required.
4 Click OK.

Quick Reference
Toolspace Shortcut Menu
On the Settings tab, Section Styles collection, right-click <style name> ➤ Copy
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Dialog Box
Section Style (page 2534)

Editing a Section Style
To edit a section style
1 In Toolspace, in the Settings tree, expand the Section Styles collection.
2 Right-click the existing style. Click Edit.
3 In the Section Style dialog box (page 2534), change settings as required.
4 Click OK.

Quick Reference
Toolspace Shortcut Menu
On the Settings tab, Section Styles collection, right-click <style name> ➤ Edit
Command Line
EditCrossSectionStyle
Dialog Box
Section Style (page 2534)

Deleting a Section Style
To delete a section style
1 In Toolspace, in the Settings tree, expand the Section Styles collection.
2 Right-click the existing style to delete. Click Delete.
3 In the confirmation dialog box, click Yes.

Quick Reference
Toolspace Shortcut Menu
On the Settings tab, Section Styles collection, right-click <style name> ➤ Delete

Creating and Editing Section View Styles
Use the Toolspace Settings tree to create, copy, edit, or delete a section view style.
Create an entirely new style, or create a new style by copying an existing style. Then change its properties
to suit your requirements. Use the Section View Style dialog box (page 2550) tabs to specify the main properties.
NOTE Before editing an existing section view style to change its properties, remember that any changes you make
will apply to all section views that use the style. To change the style of some section views, but not all, consider
creating a new style.
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Section view styles control the format of the graph on which the sections are displayed, as well as the title
and annotations on the axes.
Label styles control the format of labels for offset elevations at any point in a section view and depth/grade
between any two selected points in a section view (see Using Section Labels (page 1242)).
Band styles control the format of section bands, which can appear above and/or below the section view.
For convenience, define a group of band styles as a band set. The entire set of band styles can then be applied
to a section view with a single step, rather than applying each band style separately.
Projection styles control the appearance of AutoCAD point, solid, polyline, and block objects projected into
profile views or section views.
Group plot styles control the layout of multiple section views. They also control the spacing between sheets.
For more information, see Group Plot Style dialog box. (page 2508)
Sheet styles control the way a cross section sheet, which contains multiple section views, is displayed. They
also specify the individual plot area and visibility of sheet components. Sheet styles are maintained for
backward compatibility with earlier releases. Instead, production-ready section layout in AutoCAD Civil 3D
2011 is now controlled using a drawing template during the creation of multiple section views.
For more information, see Sheet Style Dialog Box (page 2559).

Creating a Section View Style
To create a new section view style
1 In Toolspace, in the Settings tree, expand the Section View Styles collection.
2 Do one of the following:
■

Right-click Section View Styles collection. Click New.

■

Right-click the existing style to use as a template. Click Copy.

3 In the Section View Style dialog box (page 2550), enter or change the name of the style and other settings
as required.
4 Click OK.

Quick Reference
Toolspace Shortcut Menu
On the Settings tab, Right-click Section View Styles collection ➤ New
Command Line
CreateSectionViewStyle
Dialog Box
Section View Style (page 2550)

Copying a Section View Style
To copy an existing section view style
1 In Toolspace, in the Settings tree, expand the Section View Styles collection.
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2 Right-click the existing style. Click Copy.
3 In the Section View Style dialog box (page 2550), change the name of the style and other settings as
required.
4 Click OK.

Quick Reference
Toolspace Shortcut Menu
On the Settings tab, Section View Styles collection, Right-click <style name> ➤ Copy
Dialog Box
Section View Style (page 2550)

Editing a Section View Style
To edit a section view style
1 In Toolspace, in the Settings tree, expand the Section View Styles collection.
2 Right-click the existing style. Click Edit.
3 In the Section View Style dialog box (page 2550), change settings as required.
4 Click OK.

Quick Reference
Toolspace Shortcut Menu
On the Settings tab, Section View Styles collection, Right-click <style name> ➤ Edit
Command Line
EditSectionViewStyle
Dialog Box
Section View Style (page 2550)

Deleting a Section View Style
To delete a section view style
1 In Toolspace, in the Settings tree, expand the Section View Styles collection.
2 Right-click the existing style to delete. Click Delete.
3 In the confirmation dialog box, click Yes.
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Quick Reference
Toolspace Shortcut Menu
On the Settings tab, Section View Styles collection, Right-click <style name> ➤ Delete

Editing a Section View Group Plot Style
To edit a section view group plot style
1 Select the section view whose group plot style you want to edit.
2 Click Section tab ➤ Modify View panel ➤ View Group Properties drop-down ➤ Edit Group Plot Style
.
3 In the Group Plot Style dialog box (page 2508), change settings as required.
4 Click OK.

Quick Reference
Ribbon
Select the section view. Click Section tab ➤ Modify View panel ➤ View Group Properties drop-down ➤ Edit
Group Plot Style

.

Command Line
EditSVGroupStyle
Dialog Box
Group Plot Style (page 2508)

Updating a Section View Group Layout
To update a section view group’s layout
1 Select a section view whose group layout may be modified by a style change.
2 Click Section tab ➤ Modify View panel ➤ Update Group Layout

.

The layout of the section view group is updated to reflect any style changes.

Quick Reference
Ribbon
Select the section view. Click Section tab ➤ Modify View panel ➤ Update Group Layout
Command Line
LayoutSectionViewGroup

1240 | Chapter 27 Sections

.

Sample Line, Section, and Section View Labels
You can use sample line, section, and section view label styles to control the appearance and behavior of
labels in a drawing.
This information describes what is unique to sample line, section, and section view labels. For a general
overview of labels, see Labels and Tags (page 1643).

Using Sample Line Labels
Use the Toolspace Settings tree to create and edit sample line label styles, which are used to label sample
line objects.
Specify which label styles to use when you create sample lines.
To add sample line labels automatically based on the default label style
1 In the Toolspace Settings tree, right-click Sample Line and click Edit Feature Settings.
2 In the Edit Feature Settings - Sample Line dialog box (page 2499) click Default Styles ➤ Sample Line Label
Style.
3 Click in the Value column and click

.

4 In the Sample Line Label Style dialog box (page 2021), set the default label style.
Sample line labels are displayed when you add sample lines to the drawing.
You can select a sample line label style in the Sample Line Labels dialog box, or create or edit a style in the
Label Style Composer.
To edit sample line labels
1 Select a sample line in the drawing.
2 Click Sample Line tab ➤ Labels & Tables panel ➤ Edit Labels

.

3 In the drawing, select a sample line to open the Sample Line Labels dialog box (page 2521).
4 Edit the label in the Label Style Composer dialog box (page 2180).

Quick Reference
Ribbon
Select the sample line. Sample Line tab ➤ Labels & Tables panel ➤ Edit Labels
Menu
Sections menu ➤ Add Section View Labels ➤ Add/Edit Sample Line Group Labels
Object Shortcut Menu
Right-click a sample line ➤ Edit Sample Line Labels in Group
Command Line
EditSampleLineLabels
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Dialog Boxes
Sample Line Labels (page 2521)
Label Style Composer (page 2180)

Using Section Labels
Use the Toolspace Settings tree to create and edit section label styles.
When you create sections, specify which label styles to use. Sections can be labeled automatically when
created, using the specified label set. After creating a section, you can also add labels.
Use either the Section Labels dialog box (page 2207) or the Section View Properties dialog box (page 2542)to add
labels.
You can select a section label style in the Section Labels or Section View Properties dialog box, or create or
edit a style in the Label Style Composer.
Types of section label styles:
This type of section label
style...

Labels...

Major Offset

Offsets, elevations, and instantaneous grades at major
increments.

Minor Offset

Offsets, elevations, and instantaneous grades at minor
increments.

Segments

Section segment labels for each segment (line) of a
section object. A user-specified weeding factor is supported, thus avoiding close annotation.

Grade Breaks

Grade break labels applied at every grade break point
for a section. A user-specified weeding factor is supported, thus avoiding close annotation.

Label Set

The default set of label styles to use for sections when
a section view object is created.

For a general overview of labels, see Labels and Tags (page 1643).
To add section labels
1 In the drawing, zoom to a section view.
2 Do one of the following:
■

Click the desired section line. Right-click and click Edit Labels.

■

Click the desired section view grid. Right-click and click Section View Properties. On the Sections
tab, click the Labels column.

The Section Labels dialog box (page 2207) is displayed.
3 In the Section Labels dialog box, for Type, select the label type in the list, either: Major Offset, Minor
Offset, Segments, or Grade Breaks.
4 Optionally, for Section <Label Style> Label Style, select the label style in the list or use the standard
controls to create a new style, copy or edit the current style selection, create a child of the current style
selection, or pick a style from the drawing.
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5 Click Add.
The specified label type is added to the set.
6 Review the label set in the table and make the required adjustments. Click OK.
The labels are displayed along the section line in the section view.
To edit section labels
1 Click the section line you want to edit.
2 Do one of the following:
■

Click Section tab ➤ Labels panel ➤ Edit Section Labels

■

Right-click and click Edit Labels.

.

3 In the Section Labels dialog box (page 2207), review the existing labels and their attributes. Do any of the
following:
■

Add or remove labels of any type.

■

Change the style for a label type.

■

Import a standard set of labels.

■

Save your modified labels as a set to use again.

■

Stagger labels to avoid label collisions. For more information, see Staggering Profile and Section
Labels (page 1707).

4 Click Apply to see your changes on the section line.
5 Click OK to save the changes.

Quick Reference
Ribbon
Select the section line. Section tab ➤ Labels panel ➤ Edit Section Labels
Object Shortcut Menu
Click section, right-click ➤ Edit Labels
Command Line
EditSectionLabels
Dialog Box
Section Labels (page 2207)

Using Section View Labels
Use the Toolspace Settings tree to create and edit section view label styles.
You can label section views automatically when you create them, using specified label styles. After creating
section views, you can also add Offset Elevation and Grade labels.
If a section view contains projected AutoCAD objects, label styles for these objects are managed as feature
settings for the section view object.
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Projection labels show the location of an object projected into the section view, such as a block or a point.
Use the Add Section View Labels option to access the Add Labels dialog box (page 2208) if you need to create
or modify a style before labeling a section view.
This type of section view label
style...

Labels...

Offset Elevation

The elevation and offset value at a specified point
in the section view, not necessarily on a section.

Grade

The elevation difference between two specified
points, as well as other selected data, such as
slope and distance between the points.

To add a section view grade label
1 Zoom to, and select, the section view that you want to label.
2 Click Section View tab ➤ Labels panel ➤

Add View Labels drop-down ➤

Grade.

3 Click any two points. A label is displayed, showing the grade label (default) or other data about the
relationship between the two points (depending on the label style).
4 Repeat Step 4 for each point or pair of points that you want labeled.
5 To end the procedure, press Esc. Close the Add Labels dialog box.
To add a section view offset elevation label
1 Zoom to, and select, the section view that you want to label.
2 Click Section View tab ➤ Labels panel ➤

Add View Labels drop-down ➤

Offset Elevation.

3 Click the location where you want a label. It is immediately displayed, showing the offset and elevation
values (default).
4 Repeat Step 4 for each point or pair of points that you want labeled.
5 To end the procedure, press Esc. Close the Add Labels dialog box.

Quick Reference
Ribbon
Annotate tab ➤ Labels & Tables panel ➤ Add Labels menu ➤ Section View ➤ Grade
Annotate tab ➤ Labels & Tables panel ➤ Add Labels menu ➤ Section View ➤ Offset Elevation
Menu
Sections menu ➤ Add Section View Labels ➤ Grade
Sections menu ➤ Add Section View Labels ➤ Offset Elevation
Command Line
AddSectionViewGradeLbl
AddSectionViewOffElevLbl
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Section View Bands
You can use section view bands to control the location and content of bands in section views.
A data band is an optional graphic frame that is associated with a section view. The data band contains
annotations for the section view and the section objects displayed in that section view. Some common
annotations include elevation data, offsets, and cut/fill depths.
Bands can be created automatically when you create section views and also added manually to a section
view you already created. Use the Section View Properties dialog box.

Section View Band Styles
Use the Toolspace Settings tree to create and edit section view band styles. Specify which styles to use when
you create section views. Add labels using the Add Labels dialog box (page 2208).
Data band labels are label objects that can be manipulated like other AutoCAD Civil 3D label objects. For
more information, see Editing Data Band Labels (page 1708).
Group a set of commonly used bands into a band set that can be applied to a section view as a single selection.
This type of band style... Labels...
Band Sets

Specifies the default set of bands to use (or import) when
creating a section view. Also, specifies various properties,
such as the gap between bands.

Section Data

Specifies the offsets from centerline, distance from
centerline, elevations of any section, and the cut/fill
depths at major/minor increments and other points of
interest along the sample line.
NOTE The Offset From Centerline property in Section
Data bands is measured perpendicularly to the alignment. The Distance From Centerline property is measured along the sample line. If the sample line is skewed,
the Distance From Centerline value will therefore be
different than the Offset From Centerline value. If the
sample line is perpendicular, then these values will be
the same.

Section Segment

Specifies section segment band style for each segment
(line) of a section object.

Adding Section View Bands
Add data bands that display data such as elevations and horizontal geometry.
Place data bands along the top or bottom of a section view grid to annotate the various section lines with
elevation data, vertical or horizontal geometry points, superelevation, or pipe network data. You can also
group a set of commonly used data bands into a band set that can be applied to a section view as a single
selection.
See also:
■

Section View Band Styles (page 1245)

■

Section View Band Set Dialog Box (page 2535)

■

Staggering Data Band Labels (page 1707)
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To add bands to a section view
1 In the section view, click the section view grid.
2 Right-click the section view. Click Section View Properties.
3 In the Section View Properties dialog box, click the Bands tab (page 2545).
4 In the List Of Bands area, select either Bottom or Top as the location for the new band in the section
view.
5 Select a band type and style. Click Add.
6 To add more bands to the section view, repeat Steps 4 and 5.
7 Optionally, on the right side of the List Of Bands, move selected bands up
To delete any unwanted bands, click

or down

in the stack.

.

8 To save this arrangement of bands as a set for reuse, click Save As Band Set.
9 Click OK to close the Section View Properties dialog box. The bands are displayed in the section view.
NOTE To label corridor lane widths, create a corridor, build a corridor surface using ETW (edge-of-traveled-way)
feature lines, and label that surface with an appropriate section segment band. For more information, see Creating
and Editing Section Views (page 1258) and Understanding Corridor Modeling (page 1471).

Quick Reference
Shortcut Menu
Right-click a selected section view ➤ Section View Properties
Dialog Box
Section View Properties - Bands tab (page 2545)

Creating and Editing Sample Lines and Sections
AutoCAD Civil 3D enables you can to easily create, manage, and edit sample lines and sections.

Creating Sample Lines
Create sample lines along an existing horizontal alignment.
Sections are cut along each of the samples lines for a specified set of surfaces. Corridor sections are created
when you sample a corridor.
You can create one or more sample lines that are associated with an alignment. In Toolspace, in the Prospector
tree, the sample lines are children of an alignment and appear in the hierarchy in the Sample Line Groups
collection.
NOTE When you create sample lines for the first time for an alignment, you are prompted to create a sample line
group in which to place the sample lines. This group also contains the list of surfaces, corridors, corridor surfaces,
and pipe networks (if any), based on the alignment so that you can select the data source(s) to be sampled.
In the drawing, sample lines can be labeled with annotations, including stations and other information.
The section can be displayed using the section view. For more information, see Creating and Editing Section
Views (page 1258).
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To create a perpendicular sample line, of a specified swath width, across an alignment at a specified station
1 Click Home tab ➤ Profile & Section Views panel ➤ Sample Lines

.

The cursor changes to pick mode. You are prompted to select an alignment.
2 Do one of the following:
■

Press Enter to select from a list of alignments.

■

In the drawing, click the desired horizontal alignment.

For information about creating an alignment, see Creating Alignments (page 948).
3 Specify a sample line group. A sample line must belong to a sample line group. Do one of the following:
■

If this is the first sample line group you are creating in the drawing, the Create/Edit Sample Line
Group dialog box (page 2485) is automatically displayed. Review the default styles. Change them if
necessary. Click OK.

■

If a sample line group already exists in the drawing, the Sample Line Tools toolbar (page 2526) is
displayed. To assign a sample line group to the sample line, select the sample line group in the list.

The cursor changes to station pick mode (default). You are prompted to select a station.
4 Do one of the following:
■

At the command line, specify a station by entering the desired station value.

■

In the drawing, use the cursor tooltip to find the station along the alignment. Click the station.

5 Do one of the following:
■

At the command line, enter the left swath width. Press Enter.

■

In the drawing, at the desired distance, click the first point, which defines the start of the left swath
width. Click the second point, which defines the end of the left swath width (that is, the length).

6 Do one of the following:
■

At the command line, enter the right swath width. Press Enter.

■

In the drawing, at the desired distance, click the first point, which defines the start of the right swath
width. Click the second point, which defines the end of the right swath width (that is, the length).

7 Right-click to end the By Stations mode.
Depending on the sample line style, a line is drawn perpendicular across the alignment at the specified
location and length. This sample line represents the section.
NOTE For left and right swath widths, you can attach an alignment, such as a right-of-way alignment. This enables
you to define variable sample line widths. If you later use the Edit Swath Widths for Group tool on the Sample
Line Tools toolbar (page 2526), all sample line widths will be extended or trimmed to the group’s widths.
To create a sample line or multi-segment sample line by picking points on-screen
1 Click Home tab ➤ Profile & Section Views panel ➤ Sample Lines

.

The cursor changes to pick mode. You are prompted to select an alignment.
2 Do one of the following:
■

Press Enter to select from a list of alignments.

■

In the drawing, click the desired horizontal alignment.
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For more information about creating an alignment, see Creating Alignments (page 948).
3 Specify a sample line group. A sample line must belong to a sample line group. Do one of the following:
■

If this is the first sample line group you are creating in the drawing, the Create/Edit Sample Line
Group dialog box (page 2485) is automatically displayed. Review the default styles. Change them if
necessary. Click OK.

■

If a sample line group already exists in the drawing, the Sample Line Tools toolbar (page 2526) is
displayed. To assign a sample line group to the sample line, select the sample line group in the list.

The cursor changes to station pick mode (default). You are prompted to select a station.
4 On the Sample Line Tools toolbar, in the sample line create method list, click
Points On Screen. You are prompted to select a start point.

, which selects Pick

5 In the drawing, use the cursor tooltip to find the start point. Click the start point.
6 Do one of the following:
■

In the drawing, click an end point on the opposite side of the alignment. Finish the pick point
session by right-clicking. Press Enter.

■

In the drawing, click one or more points to define the sample line (section) with the final end point
on the opposite side of the alignment from the start point. Note that if the final end point is not
on the opposite side of the alignment from the start point, the sample line is interpolated to attach
to the centerline of the alignment.

7 Do one of the following:
■

Continue picking points on screen to draw more sample lines.

■

Right-click to end the Pick Points On Screen mode.

NOTE When you create a sample line that is located between corridor stations, the data shown in the section
is interpolated between the preceding and succeeding stations.
Depending on the sample line style, a line or multi-segment line is drawn across the alignment that
represents the section.
To create perpendicular sample lines, by a range of stations, across an alignment at specified station intervals
1 Click Home tab ➤ Profile & Section Views panel ➤ Sample Lines

.

The cursor changes to pick mode. You are prompted to select an alignment.
2 Do one of the following:
■

Press Enter to select from a list of alignments.

■

In the drawing, click the desired horizontal alignment.

For information about creating an alignment, see Creating Alignments (page 948).
3 Specify a sample line group. A sample line must belong to a sample line group. Do one of the following:
■

If this is the first sample line group you are creating in the drawing, the Create/Edit Sample Line
Group dialog box (page 2485) is automatically displayed. Review the default styles. Change them if
necessary. Click OK.

■

If a sample line group already exists in the drawing, the Sample Line Tools toolbar (page 2526) is
displayed. To assign a sample line group to the sample line, select the desired sample line group in
the list.
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The cursor changes to station pick mode (default). You are prompted to select a station.
4 On the Sample Line Tools toolbar, in the sample line create method list, click
Station Range.

, which selects By

The Create Sample Lines - By Station Range dialog box (page 2491)is displayed.
5 Review the default settings. Change them if necessary. Click OK. Note that the station range defaults
to the entire length of the alignment.
Depending on the sample line style, sample lines are drawn along the alignment, cutting across the
alignment at the specified intervals. These sample lines represent the sections.
To create perpendicular sample lines across an alignment at specified corridor stations
1 Click Home tab ➤ Profile & Section Views panel ➤ Sample Lines

.

The cursor changes to pick mode. you are prompted to select an alignment.
2 Do one of the following:
■

Press Enter to select from a list of alignments.

■

In the drawing, click the desired horizontal alignment.

For more information about creating an alignment, see Creating Alignments (page 948).
3 Specify a sample line group. A sample line must belong to a sample line group. Do one of the following:
■

If this is the first sample line group you are creating in the drawing, the Create/Edit Sample Line
Group dialog box (page 2485) is displayed. Review the default styles. Change them if necessary. Click
OK.

■

If a sample line group already exists in the drawing, the Sample Line Tools toolbar (page 2526) is
displayed. To assign a sample line group to the sample line, select the desired sample line group in
the list.

The cursor changes to station pick mode (default). You are prompted to select a station.
4 On the Sample Line Tools toolbar, in the sample line create method list, click
Stations.

to select From Corridor

The Create Sample Lines - From Corridor Stations dialog box (page 2491) is displayed.
NOTE If you do not have any corridors defined based on the selected alignment, then this command will
be inactive.
5 Review the default settings. Change them if necessary. Click OK. Note that the station range defaults
to the entire length of the alignment.
Depending on the sample line style, sample lines are drawn along the alignment, cutting across the
alignment at the specified corridor stations. These sample lines represent the corridor sections.
NOTE For left and right swath widths, you can attach an alignment, such as a right-of-way alignment. This enables
you to define variable sample line widths. If you later use the Edit Swath Widths for Group tool on the Sample
Line Tools toolbar (page 2526), all sample line widths will be extended or trimmed to the group’s widths.

Creating Sample Lines | 1249

Quick Reference
Ribbon
Home tab ➤ Profile & Section Views panel ➤ Sample Lines
Menu
Sections menu ➤ Create Sample Lines
Command Line
CreateSampleLines

Editing Sample Lines
Edit sample lines to change their parameters, move, copy, delete, or replace them, and change their
appearance.
Use the editing functionality in the Edit Sample Line dialog box (page 2507) to change the name, length,
vertex locations, and station value parameters.
In the drawing, use sample line grips to specify the stretch point, base point, or to copy sample lines. You
use the grips to change swath widths or stations.

Using Parameters to Edit Sample Lines
To use parameters to edit sample line location and length
1 In the drawing, click the sample line you want to edit.
2 Click Sample Line tab ➤ Modify panel ➤ Edit Sample Line

.

Note that the Edit Sample Line dialog box and Sample Line Tools toolbar are both displayed.
3 In the Edit Sample Line dialog box (page 2507), review the parameters for each vertex of the sample line
by clicking Previous Vertex and Next Vertex.
4 At the vertex you want to edit, do one or more of the following:
■

In the Name field, change the name of the sample line.

■

In the Sample Line Vertex Northing and/or Sample Line Vertex Easting field(s), enter new values.

■

In the Sample Line Segment Length field, change the length of the swath width to the desired
distance in ground units or click

■

to pick a new segment length from the drawing.

In the Sample Line Station Value field, change the sample line station value or click
new station value from the drawing.

5 Close the Edit Sample Line dialog box and Sample Line Tools toolbar.
The sample line is redrawn with the new parameters.
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to pick a

Quick Reference
Ribbon
Select the sample line. Sample Line tab ➤ Modify panel ➤ Edit Sample Line
Menu
Sections menu ➤ Edit Sample Lines
Command Line
EditSampleLine

Using Grips to Edit Sample Lines
To use grips to edit a sample line
1 In the drawing, click the sample line you want to edit.
The sample line displays grip edit locations at each vertex.
2 Use the diamond-shaped center grip to move the sample line to a new location along the alignment.
The sample line slides to the new location while maintaining its relative geometry. As the sample line
moves, it reorients to the underlying entity (for example, spiral, curve, or other tangents). It always
remains perpendicular to the alignment.
3 Use the square-shaped end grips to stretch (lengthen or shorten), move, or rotate segments.
The sample line is redrawn.
4 Use the triangular-shaped grips at the ends of segments to stretch (lengthen or shorten) each segment
while keeping its relative direction.
The sample line is redrawn.
5 Press Esc or enter eXit to complete the procedure.
The sample line segments are moved or edited.

Restoring Rotated Sample Lines to Be Perpendicular
To restore a rotated sample line to the perpendicular
1 In the drawing, click a sample line.
The sample line displays grip edit locations at each vertex.
2 Use the square-shaped end grips to rotate segments off their perpendicular orientation to the parent
alignment.

3 Click the rotated sample line.
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4 Right-click and click Make Orthogonal.
The rotated sample line (1-2) rotates back to a perpendicular orientation (3) to its parent alignment,
but retains the length to which it was stretched or contracted.

Quick Reference
Object Shortcut Menu
Right click sample line ➤ Make Orthogonal
Command Line
MakeSampleLineOrthogonal

Changing the Display Style of a Sample Line
To change the display style of a sample line
1 In the drawing, click the sample line.
2 Right-click the sample line. Click Sample Line Properties.
3 In the Sample Line Properties dialog box, click the Information tab (page 2522).
4 In the Object Style field, select a different style in the list.

Quick Reference
Ribbon
Select the sample line. Click Sample Line tab ➤ Modify panel ➤ Sample Line Properties drop-down ➤ Sample
Line Properties

.

Command Line
EditSampleLineProperties
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Resampling Section Sources
To resample section sources
1 Select a sample line in the drawing.
2 Click Sample Line tab ➤ Modify panel ➤ Sample More Sources

.

3 In the Section Sources dialog box, do one or more of the following:
■

Select a source in the Available Sources field and click Add >> to add it to the Sampled Sources field.

■

Select a source in the Sampled Sources field and click Remove << to remove it From the Available
Sources field.

4 In the Section Sources dialog box, click OK.

Quick Reference
Ribbon
Select the sample line. Click Sample Line tab ➤ Modify panel ➤ Sample More Sources

.

Command Line
SampleSectionSources

Editing Sections
Edit a section to change its appearance or move it in the drawing.
NOTE To edit a section, the section must be a static type section (that is, a section that is not dynamic). For more
information about static and dynamic update modes for sections, see Section Data Tab (Section Properties Dialog
Box) (page 2533).
Use the Section Editor to view and edit section data. If the section is dynamic, the data is grayed out in the
Section Editor and not editable. Change the Update Mode to Static in the Section Properties dialog box if
you want to edit a section.
You can also use section grip editing to manipulate static sections. For example, you can alter the section
yet maintain the grade or elevation while stretching a segment or moving grade points.
For more information about static and dynamic update modes for sections, see Section Data Tab (Section
Properties Dialog Box) (page 2533).
To edit a static section using the Section Editor
1 Click Section tab ➤ Modify Section panel

Edit Section Geometry

.

2 Use the Section Editor (page 2531) dialog box to edit the section.
To edit a static section graphically
1 In the drawing, zoom to a section view. Click the static section line you want to edit.
The section line is displayed with triangular grips at the start and end of each section segment and
rectangular grips at grade breaks.
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2 Move the section segments. Use rectangular grips for grade points. Use triangular grips for segment
stretching (lengthen or shorten).
As you move the grips, the X and Y values are displayed dynamically.
NOTE To edit the section segment by editing the dynamic dimensions in place, press Tab to cycle through
the offset and elevation values displayed.
3 Click in the drawing at the desired location.
The section is redrawn at the new location.

Quick Reference
Ribbon
Select the section line. Click Section tab ➤ Modify Section panel

Edit Section Geometry

.

Command Line
EditCrossSection
Dialog Box
Section Editor (page 2531)

Editing Sample Line Group Properties
You can specify sample line group properties, and by extension the sample lines in that group, that control
the group’s content and format.
For example, for an existing sample line group, you can use the Sample Line Group Properties dialog box
(page 2515) tabs to apply major changes to a sample line group by changing general properties:
■

Information. Specifies the sample line group’s name and description.

■

Sample Lines. Specifies the default properties of the sample lines that are included in the sample line
group. Also, you can specify the default label style. By changing the default label style here, you instantly
change the sample line’s displayed appearance.

■

Sections. Specifies the properties that draw and manage the section associated with the current sample
line group.

■

Section Views. Specifies the properties that draw and manage the section view associated with the current
sample line group.

■

Material List. Specifies the properties of material lists associated with the current sample line group. Each
list represents quantity takeoff calculation criteria for the specified materials.

Sample line properties display and specify data only about that sample line. Sample line group properties
display and specify rules for creating sample lines by range of stations or from corridor stations.
For more information, see Editing Sample Line Properties (page 1255).
To edit sample line group properties
1 In Toolspace, on the Prospector tab, right-click the sample line group name you want to edit. Click
Properties.
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2 In the Sample Line Group Properties dialog box (page 2515), review or change properties on the following
tabs: Information, Sample Lines, Sections, Section Views, and Material List.

Quick Reference
Toolspace Shortcut Menu
Prospector tab: Sites ➤ <site name> ➤ Alignments ➤ <alignment name> ➤ Sample Line Group ➤
<sample line group name> ➤ Properties
Command Line
EditSampleLineGroupProps
Dialog Box
Sample Line Group Properties (page 2515)

Editing Sample Line Properties
When you create a sample line you can specify properties to control the sample line’s content and format.
For example, for an existing sample line group, you can use the Sample Line Properties dialog box (page 2522)
tabs to apply major changes to a sample line by changing general properties:
■

Information. Specifies the sample line’s name, text description, and object style. By changing the style
here, you instantly change the sample line’s displayed appearance.

■

Sample Line Data. Specifies the sample line’s group name, associated alignment, station information,
and whether the sample line locks to the station. Also, you can specify the label style. By changing the
label style here, you instantly change the sample line’s displayed appearance.

■

Sections. Specifies the properties that draw and manage the section associated with the current sample
line. For any sample line, you can also change its style.

■

Section Views. Specifies the properties that determine which section views are created from the current
sample line.

NOTE Sample line properties display and specify data only about that sample line. Sample line group properties
display and specify rules for creating sample lines by range of stations or from corridor stations.
To edit sample line properties
1 In the drawing, click the sample line you want to edit.
2 Right-click the sample line. Click Sample Line Properties.
3 Review or change properties on the tabs of the Sample Line Properties dialog box.

Quick Reference
Toolspace Shortcut Menu
Prospector tab: Sites ➤ <site name> ➤ Alignments ➤ <alignment name> ➤ Sample Lines ➤ <sample
line name> ➤ Properties
Object Shortcut Menu
Right-click <sample line object> (in the drawing) ➤ Sample Line Properties
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Command Line
EditSampleLineProperties
Dialog Box
Sample Line Properties (page 2522)

Editing Section Properties
When you create a section you can specify properties to set the section’s name, type, object style, station
details, and labeling.
Open the Section Properties dialog box (page 2532) for an existing section to verify the name of the section
and review other information.
Apply changes to a section by changing its general properties.
The Information tab specifies the section’s name, description, and object style. By changing the style here,
you instantly change the section’s displayed appearance.
The Section Data tab specifies and displays tabular data with a single row listing the properties of the section.
Some of these properties, such as layer, mode, and style can be edited. The other properties are only for
review.
To edit section properties
1 In the drawing, click the section line you want to edit.
2 Right-click the section line. Click Section Properties.
3 Review or change properties on the tabs of the Section Properties dialog box (page 2532).

Quick Reference
Toolspace Shortcut Menu
Prospector tab: Sites ➤ <site-name> ➤ Alignments ➤ <alignment name> ➤ Sample Line Groups ➤
<sample line group name> ➤ Sections ➤ <section name> ➤ Properties
Object Shortcut Menu
Right-click <section object> (in the drawing section view) ➤ Section Properties
Command Line
SectionProperties
Dialog Box
Section Properties (page 2532)

Editing Corridor Section Properties
When you create a corridor section you can specify properties to set the corridor section’s name, type, object
style, layer, and codes.
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Open the Corridor Section Properties dialog box (page 2483) for an existing corridor section to verify the name
of the corridor section and review other information. Apply changes to a corridor section by changing its
general properties:
■

Information. Specifies the corridor section’s name, text description, and object style. By changing the
style here, you instantly change the corridor section’s displayed appearance.

■

Section Data. Specifies and displays tabular data with a single row listing the properties of that corridor
section. Some of these properties, such as layer, mode, and style can be edited. The other properties are
only for review.

■

Codes. Displays codes and style information for review. For information about changing the display style
of various point, link, and shape codes, see Using Codes and Code Set Styles (page 1567).

To edit corridor section properties
1 On the prospector, click the corridor section collection that contains the corridor section you want to
edit.
2 On the item view, right-click the individual corridor section

. Click Properties.

3 Review or change properties on the tabs of the Corridor Section Properties dialog box (page 2483).

Quick Reference
Toolspace Shortcut Menu
Prospector tab: Alignments ➤ <alignment-type> ➤ <alignment name> ➤ Sample Line Groups ➤
<sample line group name> ➤ Sections ➤ <corridor section group name>. In the item view, right-click
<corridor section name>, click Properties
Command Line
SectionCorridorProperties
Dialog Box
Corridor Section Properties (page 2483)

Editing Pipe Network Section Properties
When you create a pipe network section you can specify properties to set the pipe network section’s name
and description and view its object style, layer, and data source.
Open the Pipe Network Section Properties dialog box (page 2510) for an existing pipe network section to verify
the name of the section and review other information.
To edit and view pipe network section properties
1 On the prospector, click the pipe network section collection that contains the pipe network section
you want to edit.
2 On the item view, right-click the individual pipe network section

. Click Properties.

3 Review or change properties on the tabs of the Pipe Network Section Properties dialog box (page 2510).
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Quick Reference
Toolspace Shortcut Menu
Prospector tab: Sites ➤ <site-name> ➤ Alignments ➤ <alignment name> ➤ Sample Line Groups ➤
<sample line group name> ➤ Pipe Network Sections ➤ <pipe network section group name>. In the item
view, right-click <pipe network section name>, click Properties
Dialog Box
Pipe Network Properties (page 2510)

Creating and Editing Section Views
AutoCAD Civil 3D enables you can to easily create, manage, and edit section views.
Section views are created from existing sample lines and sections. For more information, see Creating and
Editing Sample Lines and Sections (page 1246).
A section view consists of a grid on which one or more sections are displayed as graphed lines. Multiple
section views can be plotted on a sheet that is a specified size and configuration.
A section view is very similar to a profile view. It consists of a grid or graph with specific characteristics that
are controlled by section view styles. Bands can also be displayed above or below the section view.
A section view can display one or more of the available sections at the sample line. To plot multiple sections,
use a paperspace viewport size to set up the sheet.
Configure bands and section annotations in a section view to make the section view clearer or more
informative for the user.

Creating Section Views
Create a section view to display an existing ground section, using sample lines cut across a horizontal
alignment.
Sample lines (1) must be created prior to creating a section view (2). Section views can display existing ground
surface sections, corridor sections, and pipe sections.

Each section view must be linked to an alignment. The section view displays new or existing sections. Sections
can also be created without displaying them on a section view. When you create a section view for an
alignment, the complete list of sections for the alignment is displayed. Choose which sections to include
in the section view.
Create either an EG (existing ground) section view or multiple section views. You can change the display
style of a section view, and add labels and bands.
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NOTE As a prerequisite to using the Create Section Sheets command, you must use the Create Multiple Section
Views (page 1259) command to generate production-quality section views.
To create a section view
1 Click Home tab ➤ Profile & Section Views panel ➤ Section Views drop-down ➤ Create Section View
.
2 In the Create Section View wizard (page 2495), click Create Section View to accept location, style, offset,
elevation, display, data band, and volume table defaults. You can later change the default settings in
the Section View Properties dialog box (page 2542). Alternatively, you can change settings in the following
pages of the wizard
■

General page (page 2398) – Change the location, name, layer and style of the new section view.

■

Offset Range page (page 2398) – Change the width of the offsets of the new section view.

■

Elevation Range page (page 2398) – Change the maximum and minimum elevation of the new section
view.

■

Section Display Options page (page 2400) – Change the visibility and style of the new section view.

■

Data Bands page (page 2402) – Change the band set and data band location for the new section view.

■

Section View Tables page (page 2404) – Change the type and style of volume tables, and their position
relative to, the new section view.
NOTE A material list must exist in the drawing, before you can modify Section View Tables settings.

3 In the drawing, find a suitable location for the section view, for example, outside the surface boundary
for ease of viewing. Click that location to define the origin.
The section view is displayed.
To create multiple section views
1 Click Home tab ➤ Profile & Section Views panel ➤ Section Views drop-down ➤ Create Multiple Views
.
2 In the Create Multiple Section Views wizard (page 2486), click Create Section Views to accept location,
style, offset, elevation, display, data band, and volume table defaults. Alternatively, you can change
settings in the following pages of the wizard:
■

General page (page 2487) – Change the location, name, layer and style of the new section views.

■

Section Placement (page 2487) – Select Production or Draft quality layout options.

■

Offset Range page (page 2488) – Change the width of the offsets of the new section views.

■

Elevation Range page (page 2488) – Change the maximum and minimum elevations of, and group
options for, the new section views.

■

Section Display Options page (page 2489) – Change the visibility and style of the new section views.

■

Data Bands page (page 2490) – Change the band set and data band location for the new section views.

■

Section View Tables page (page 2490) – Change the type and style of volume tables, and their position
relative to, the new section views.
NOTE A material list must exist in the drawing, before you can modify Section View Tables settings.
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3 In the drawing, find a suitable location for the multiple section views, for example, well outside the
surface boundary for ease of viewing. Click that location to define the origin.
The multiple section views are displayed.
You can plot an entire sample line group, or you can specify a user-defined station range (1) to control how
many section views (2) are created.

Quick Reference
Ribbon
Home tab ➤ Profile & Section Views panel ➤ Section Views drop-down ➤ Create Section View
Home tab ➤ Profile & Section Views panel ➤ Section Views drop-down ➤ Create Multiple Views
Command Line
CreateSectionView
CreateMultipleSectionView

Changing the Display Style of a Section or Section View
To change the display style of a section
1 In the section view, click the section line you want to change.
2 Right-click the section line. Click Section Properties.
3 In the Section Properties dialog box, click the Information tab (page 2532).
4 In the Object Style field, select a different style in the list.
To change the display style of a section view
1 In the section view, click the section view grid.
2 Right-click the grid. Click Section View Properties.
3 In the Section View Properties dialog box, click the Information tab (page 2542).
4 In the Object Style field, select a different style in the list.
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Quick Reference
Ribbon
Select the section view. Click Section tab ➤ Modify Section panel ➤ Section Properties drop-down ➤ Section
Properties
.
Click Section tab ➤ Modify View panel ➤ Section View Properties drop-down ➤ Section View Properties
.
Command Line
SectionProperties
EditGraphProperties

Adding Section View Labels
To add a section view label
1 Zoom to the section view area to clearly see the section view and its annotations.
2 Click Annotate tab ➤ Labels & Tables panel ➤ Add Labels menu ➤ Section View ➤ Add Section View
Labels

.

3 In the Add Labels dialog box (page 2208), for Label Type, select the type of label (either Grade or Offset
Elevation) in the list.
4 Optionally, for style, select the style in the list or use the standard controls to create a new style, copy
or edit the current style selection, or pick a style from the drawing.
5 Click Add.
On the command line, you are prompted to select a section view.
6 In the drawing, click a graph line of the section view you want to label.
On the command line, you are prompted to pick a point.
7 In the section view, click the point, or points for a grade label, that define the label.
The label is displayed at the desired location in the section view.
8 Right-click or press Esc to end the session.
9 In the Add Labels dialog box, click Close.

Quick Reference
Ribbon
Annotate tab ➤ Labels & Tables panel ➤ Add Labels menu ➤ Section View ➤ Add Section View Labels
.
Command Line
AddSectionViewLabels
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Adding Bands to a Section View
To add bands to a section view
1 In the section view, click the section view grid.
2 Right-click the grid. Click Section View Properties.
3 In the Section View Properties dialog box, click the Bands tab (page 2545).
4 In the List Of Bands area, select either Bottom or Top as the location for the new data band in the
section view.
5 Select a band type and style. Click Add.
6 To add more bands to the section view, repeat Steps 4 and 5.
7 Optionally, on the right side of the List Of Bands, move selected bands up
To delete any unwanted bands, click

or down

in the stack.

.

8 To save this arrangement of bands as a set for reuse, click Save As Band Set.
9 Click OK to close the Section View Properties dialog box. The bands are displayed in the section view.

Quick Reference
Ribbon
Select the section view. Click Section tab ➤ Modify View panel ➤ Section View Properties
drop-down ➤ Section View Properties

.

Command Line
EditGraphProperties

Adding Profile Grade Points to a Section View
To add profile grade points to a section view
1 In the section view, click the section view grid.
2 Right-click the grid. Click Section View Properties.
3 In the Section View Properties dialog box, click the Profile Grade Lines tab (page 2548).
4 In the Alignment area, click an alignment in the list or click

to pick an alignment from the drawing.

5 Click Add.
6 To add more grade point labels to the section view, repeat Steps 4 and 5.
7 Optionally, to delete any unwanted grade points, select them in the list. Click

.

8 Click OK to close the Section View Properties dialog box. The profile grade points are displayed in the
section view.
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Quick Reference
Ribbon
Select the section view. Click Section tab ➤ Modify View panel ➤ Section View Properties
drop-down ➤ Section View Properties

.

Command Line
EditGraphProperties

Editing Section View Properties
When you create a section view you can specify properties to control a section view’s content and format.
In the Section View Properties dialog box, edit offset range, elevation range, section data, band information,
projected object information, volume table information and profile grade line information.
Apply changes to a section view by changing its general properties:
■

Information. Specifies the section view’s name, description, and object style. By changing the style here,
you instantly change the section’s displayed appearance.

■

Offsets. Displays the properties of the selected section view and the section view grid on which sections
are displayed.

■

Elevation. Specifies the elevation properties of the selected section view and the section view grid on
which sections are displayed.

■

Sections. Specifies which sections to display in the section view. For any section, you can also override
its style and label set to display it differently in the current section view.

■

Bands. Specifies which bands to include in the section view, and whether to place them along the top
or bottom of the grid. Data is displayed for specified section objects.

■

Volume Tables. Specifies table type and style, and the associated material, material list and layer.

■

Profile Grade Lines. Specifies a profile and displays its elevation by marking it at the appropriate offset
and elevation in the section view.

■

Projection. Specifies the name, style and elevation of projected objects in a section view.

For more information, see Section View Group Properties Dialog Box (page 2540).

Editing Section View Properties
To edit section view properties
1 In the drawing, click any grid or axis line of the section view you want to edit.
2 Right-click the section view grid. Click Section View Properties.
3 Review or change properties on the tabs of the Section View Properties dialog box (page 2542).
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Quick Reference
Ribbon
Select the section view. Click Section tab ➤ Modify View panel ➤ Section View Properties
drop-down ➤ Section View Properties

.

Toolspace Shortcut Menu
On the Prospector tab ➤ Sites ➤ <site-name> ➤ Alignments ➤ <alignment name> ➤ Sample Line
Groups ➤ <sample line group name> ➤ Section View Groups ➤ <section view group name> ➤ Right-click
<section view name> (in item view) ➤ Properties
Object Shortcut Menu
Right-click <section view object> (in the drawing) ➤ Section View Properties
Command Line
EditGraphProperties
Dialog Boxes
Section View Properties (page 2542)

Editing Section View Group Properties
To edit section view group properties
1 In the drawing, click any grid or axis line of any section view in the group you want to edit.
2 Right-click the section view grid. Click Section View Group Properties.
3 Review or change properties on the tabs of the Section View Group Properties (page 2540) dialog box.

Quick Reference
Ribbon
Select the section view. Click Section tab ➤ Modify View panel ➤ View Group Properties drop-down ➤ View
Group Properties

.

Toolspace Shortcut Menu
On the Prospector tab ➤ Sites ➤ <site-name> ➤ Alignments ➤ <alignment name> ➤ Sample Line
Groups ➤ <sample line group name> ➤ Section View Groups ➤ Right-click <section view group name>
➤ Properties
Object Shortcut Menu
Right-click <section view object> (in the drawing) ➤ Section View Group Properties
Command Line
EditSVBatchProperties
Dialog Boxes
Section View Group Properties (page 2540)
Edit Offset and Elevation Ranges (page 2506)
Profile Grade Points (page 2512)
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Section View Group Bands (page 2538)

Working with Projected Objects in Section Views
Visualize the location of an object in relation to a section.

Projecting Objects to a Single Section View
Project AutoCAD or AutoCAD Civil 3D objects from plan view into a section view.
You can project AutoCAD points, blocks, 3D solids, and 3D polylines; you can also project COGO points,
feature lines, and survey figures.
For more information, see Working with Projected Objects in Profile Views (page 1218).
To project objects to a section view
1 Click Home tab ➤ Profile & Section Views panel ➤ Section Views drop-down ➤ Project Objects To
Section View

.

2 Click one or more objects in the drawing that you want to project. Right-click or press Enter after all
objects are selected.
3 Click the section view in which you want the objects to appear.

Quick Reference
Ribbon
Home tab ➤ Profile & Section Views panel ➤ Section Views drop-down ➤ Project Objects To Section View

Command Line
ProjectObjectsToSect

Projecting Objects to Multiple Section Views
You can project objects to multiple section views by specifying projection rules for the objects.
Rather than selecting individual objects to project, all objects of a specified type within a specified area
before and after the sample lines are projected.
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NOTE In the illustrations in this topic, the sample lines are shown in blue, crossing a dark green alignment. The
purple hatched areas represent the areas before the sample lines and the green hatched areas represent the areas
after the sample lines.
Linear objects such as feature lines, survey figures, and 3D polylines are projected only when they intersect
a sample line for a given section view. The projection rules do not apply to these objects.

Projection Rule: By Percentage Option
The By Percentage option is useful when the sample lines are not evenly distributed along the alignment.
For example, in the following illustration, using a percentage of 50 will encompass all the area between
sample lines even though they are different distances apart.

Projection Rule: By Distance Option
The By Distance option is useful when the sample lines are distributed uniformly or if you only want to
include objects that are an absolute distance away from the sample lines.
The following illustration shows how objects within a specified distance of 25’ before and after the sample
lines are projected.

If an object’s insertion point is within the area, then it is projected even if part of the object extends beyond
the region, as shown by the object in the lower-left corner of the illustration.
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Projection Rules for Non-Perpendicular and Non-Radial Sample Lines
The Project Objects To Multiple Section Views command assumes the following:
■

Sample lines (solid blue lines) are considered to be either perpendicular or radial to the alignment (dotted
blue lines).

■

The locations of the objects to be projected are considered to be relative to the alignment stations (1 and
2 in the following illustration).

In cases where you have non-perpendicular or non-radial sample lines, an object that appears to be “before”
or “after” a sample line can actually be in the opposite position because of the way the object’s station is
determined relative to the alignment.
The following illustration shows how this is determined. The station of object 1 is determined to be before
the location where the sample line crosses the alignment (4), so the projection rules for “before” are used
for it, even though the object itself appears to be after the skewed sample line (3).

Projecting Objects to Multiple Section Views | 1267

The opposite is true for object 2. It is determined to be after the sample line according to its station, so the
rules for “after” are applied to it. Since both objects fall into either a “before” or “after” region, they are both
projected.
The following illustration shows how the projection results are affected by a smaller “before” region. Because
the station of object 1 now falls outside of the region, object 1 is not projected.

To project objects to multiple section views
1 Click Home tab ➤ Profile & Section Views panel ➤ Section Views drop-down ➤ Project Objects To
Multiple Section Views

.

2 Do one of the following:
■

Select a sample line in the drawing to select a sample line group. By selecting a sample line group,
objects will be projected to all section view groups that have been created from the sample line
group.

■

Select a section view in the drawing to select a section view group. By selecting a section view group,
objects will be projected only to those section views in that group.

The Project Objects To Multiple Section Views (page 2513) dialog box is displayed.
3 You can select a different sample line group or section view group, depending on which type you
selected in Step 2.
NOTE You cannot switch between sample line group and section view group after running the command.
If you want to switch, click Cancel and run the command again.
4 Specify the Projection Rules. You can specify a distance (page 1266) before and after the sample lines or
you can specify a percentage (page 1266).
NOTE The projection rules do not apply to feature lines, survey figures, or 3D polylines. Those objects are
projected only when they intersect a sample line for a given section view.
NOTE A distance or percent of zero projects non-linear objects whose insertion point is exactly on the sample
line.
5 Select the types of objects to project and specify their settings.
NOTE You can control individual object settings later by using the Projections (page 2549) tab of the Section
View Properties dialog box. For example, if you only want one feature line projected, you can clear all of the
other feature lines from the selection.
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6 Click OK.

Quick Reference
Ribbon
Home tab ➤ Profile & Section Views panel ➤ Section Views drop-down ➤ Project Objects To Multiple
Section Views
Command Line
ProjectObjectsToMultiSect
Dialog Box
Project Objects To Multiple Section Views (page 2513)

Editing Projected Objects in a Section View
Use the shortcut menu for a projected object for quick access to object properties.
When you right-click a projected object in a section view, the shortcut menu is displayed. The only menu
selection specific to the projection is Projection Object Properties. It opens the Projections tab (page 2549) of
the Section View Properties dialog box.
For more information, see Working with Projected Objects in Profile Views (page 1218).

Removing a Projected Object from a Section View
Select a projected object and remove it from the section view.
Other projected objects not selected in the section view remain in place.
For more information, see Working with Projected Objects in Profile Views (page 1218).
To remove a projected object
1 In the section view, click the object to want to remove.
2 On the ribbon, click Projected Object tab ➤ Modify Projected Object panel ➤ Remove From View
.

Quick Reference
Ribbon
Select a projected object. Click Projected Object tab ➤ Modify Projected Object panel ➤ Remove From
View.
Command Line
RemoveFromSectionView
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Labeling Projected Objects in a Section View
To label a projected object in a section view
1 Select a projected object.
2 Click Projected Object tab ➤ Labels panel ➤ Add Object Labels

.

Quick Reference
Ribbon
Select the projected object.Click Projected Object tab ➤ Labels panel ➤ Add Object Labels
Object Shortcut Menu
Right-click projected object ➤ Add Label
Command Line
AddProjectionLabel

Creating and Copying Projection Styles
Use these general styles to control the display of AutoCAD objects projected into profile views and section
views.
Within a style, the settings for the appearance of an object type in section views are independent from the
settings for profile views.
To create a projection style
1 In Toolspace, on the Settings tab, expand the General ➤ Multipurpose Styles collection. Right-click
Projection Styles and click New.
2 In the Projection Styles dialog box (page 2023), specify the name of the style and other settings as required.
3 Click OK.
To copy a projection style
1 In Toolspace, on the Settings tab, expand the General ➤ Multipurpose Styles collection. Identify the
style you want to copy as a basis for the new style.
2 Right-click the style name and click Copy.
3 In the Projection Styles dialog box (page 2023), change the name of the style and other settings as required.
4 Click OK.

Quick Reference
Toolspace Shortcut Menu
Settings tab: General ➤ Multipurpose Styles ➤ Projection Styles
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Dialog Box
Projection Style (page 2023)

Editing Projected Object Styles
Change the appearance of a projected object, without affecting the source object.
Projected AutoCAD Civil 3D objects use standard style editing dialog boxes for points, feature lines, and
survey figures. Projected AutoCAD objects use multipurpose styles that control the appearance of different
object types in profile views and section views.
To edit a projection style
1 In Toolspace, on the Settings tab, expand the General ➤ Multipurpose Styles collection. Identify the
style you want to edit.
2 Right-click the style name and click Edit.
3 In the Projection Styles dialog box (page 2023), change settings as required.
4 Click OK.
To edit the style of a projected object
1 In the drawing window, in a section view, select the object whose style you want to change.
2 Click Projected Object tab ➤ Modify Projected Object panel ➤ Projection Properties drop-down ➤ Edit
Style

.

3 In the styles dialog box, make changes as required.

Quick Reference
Ribbon
Select the projected object. Click Projected Object tab ➤ Modify Projected Object panel ➤ Projection
Properties drop-down ➤ Edit Style
Toolspace Shortcut Menu
Settings tab: General ➤ Multipurpose Styles ➤ Projection Styles
Command Line
EditProjectionStyle
Dialog Box
Projection Style (page 2023)
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Sections Command Reference
The AutoCAD Civil 3D commands for section-related functionality and a brief description of their
functionality.
Command

Description

AddProjectionLabel

Adds labels to objects projected into the view (page
1270)

AddSectionViewLabels

Creates section view labels (page 1243)

AddSectionViewGradeLbl

Creates grade labels for section views (page 1244)

AddSectionViewOffElevLbl

Creates offset elevation labels for section views (page
1244)

CreateCrossSectionStyle

Creates a new section style (page 1236)

CreateGroupPlotStyle

Creates a new group plot style (page 1236)

CreateMultipleSectionView

Creates multiple section views for a group of sample
lines along an alignment (page 1259)

CreateSampleLines

Creates sample lines and cuts sections at user specified
stations along an alignment (page 1246)

CreateSampleLineStyle

Creates a new sample line style (page 1234)

CreateSectionView

Creates a section view to display existing and proposed sections for each sample line (page 1259)

CreateSectionViewStyle

Creates a new section view style (page 1238)

EditCrossSection

Edits static section data and displays information
about dynamic sections (page 1253)

EditCrossSectionStyle

Edits the style name and appearance of selected sections (page 1237)

EditGraphProperties

Edits properties of a selected section view graph (page
1263)

EditGraphStyle

Edits an existing section view style (page 1239)

EditGroupPlotStyle

Edits a group plot style (page 1236)

EditProjectionStyle

Edits the style of a projected object (page 1271)

EditSampleLine

Edits sample line swath widths, vertices, or stations
(page 1250)

EditSampleLineLabels

Manages labels for all sample lines in a selected
sample line group (page 1241)

EditSampleLineGroupProps

Edits sample line group properties after you select a
sample line (page 1254)
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Command

Description

EditSampleLineProperties

Edits individual properties for a selected sample line
(page 1255)

EditSampleLineStyle

Edits the style name and appearance of selected
sample lines (page 1235)

EditSectionLabels

Manages labels for a particular section in a section
view (page 1129)

EditSectionViewStyle

Edits an existing section view style (page 1239)

EditSheetProperties

Edits the properties of the selected section sheet (page
2558)

EditSheetStyle

Edits the style of the selected section sheet (page 2559)

EditSVBatchProperties

Edits group and individual properties for the selected
section view group (page 1264)

EditSVGroupStyle

Edits the plot style of the selected section view group
(page 1240)

LayoutSectionViewGroup

Updates the layout of the selected section view group
(page 1240)

MakeSampleLineOrthogonal

Restores a rotated sample line to be perpendicular
(page 1251)

PanToSource

Pans to the source object in plan view that is projected to a section view

ProjectionObjectProperties

Edits the properties of the object projected into the
specified profile view or section view (page 2549)

ProjectObjectsToMultiSect

Projects objects to multiple section views using
proximity settings (page 1268)

ProjectObjectsToSect

Projects AutoCAD point, solid, polyline, or block objects into a section view (page 1265)

ZoomToSource

Zooms to the source object in plan view that is projected to a section view

RemoveFromSectionView

Removes a projected object from a section view (page
1269)

SampleSectionSources

Resamples sections of a sample line group (page 1253)

SectionProperties

Edits the name, description, and data of a selected
section (page 1256)
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Material and Quantity
Analysis

28

Use materials and sectional or profile information to extract and report material volumes.
Apply pay items to AutoCAD Civil 3D objects to analyze quantities.
You can output and render the quantities using:
■

Total volume tables

■

Material volume tables

■

Volume reports

■

Summary quantity reports

■

Detailed quantity reports

■

Quantity takeoff tables

■

Mass haul diagrams

Creating material lists (page 1282) is the essential step in the creation of volume tables and reports. Creation of tables and
reports can be performed once the material lists are generated. As part of the production of the material lists, you will
need to set up quantity takeoff criteria (page 1279).
Import (page 1294) pay item files from contracting agencies, tag (page 1298) objects, closed areas, and collections, and compute
(page 1306) quantities to create quantity reports and tables (page 1308).
As with the creation of volume tables and reports, the creation of material lists is also a prerequisite to creating mass haul
diagrams (page 1314).
Material and Quantity Analysis Workflow (page 54)

Editing Quantity Takeoff Settings
Change quantity-takeoff-related settings before you create criteria, material lists, tables, or reports.
For example, before creating a quantity takeoff table, you may want to specify the default table format.
If a closed lock appears in the Lock column for a property, the property is locked at a higher level of the
Settings tree. It cannot be changed at this level.

1275

If you change a property value, a check mark is placed in the Override column. This override is also noted
in the property table for related objects higher up in the Toolspace Settings tree, where an arrow appears in
the Child Override column. For more information, see Understanding Settings (page 77).
To change quantity takeoff settings
1 Do one of the following:
■

To edit the general quantity takeoff settings: In Toolspace, on the Settings tab, right-click the
Quantity Takeoff collection and click Edit Feature Settings.

■

To edit the settings for a specific command: In Toolspace, on the Settings tab, expand the Commands
collection in the Quantity Takeoff collection. Right-click the command for which you want to
change settings.

The Edit Feature Settings - Quantity Takeoff dialog box (page 2569) is displayed.
2 To specify the default quantity takeoff criteria and material shape style, expand the
Default Styles
property group, and edit the Quantity Takeoff Criteria and Material Shape Style settings.
3 To specify the default naming for quantity takeoff materials and material lists, expand the
Default
Name Format property group, and edit the Material Name Template and Material List Name Template
settings.
4 To modify the default material volume table settings, expand the Table Creation property group, and
edit the standard table creation options. This property group is available if you accessed the settings
from the AddMaterialVolumeTable command in Step 1.
5 To modify the default display settings for objects with assigned pay items, expand the Assign Pay Item
To Area Options property group, and edit the layer and color options. This property group is available
when you access the settings from the AssignPayItemToArea command in Step 1.
NOTE You can also edit the Assign Pay Item To Area Options in the Quantity Takeoff Command Settings
dialog box.
6 To modify the default total volume table settings, expand the Table Creation property group, and edit
the standard table creation options. This property group is available when you access the settings from
the AddTotalVolumeTable command in Step 1.
7 To modify the default material definition settings, expand the Define Materials Options property group,
and edit the curve correction settings. For more information, see Generating Material Lists (page 1282).
This property group is available when you access the settings from the ComputeMaterials command
in Step 1.
8 To modify the default quantity takeoff report settings, expand the Quantity Report Options property
group, and edit the XML report display setting. This property group is available when you access the
settings from the GenerateQuantitiesReport command in Step 1.
9 To modify the default quantity takeoff computation settings, expand the Compute Takeoff Options
property group, and edit the report and table settings, pipe network settings, and formula setting. This
property group is available when you access the settings from the Takeoff command in Step 1.
NOTE You can also edit the Compute Takeoff Options in the Quantity Takeoff Command Settings dialog
box.
10 Click Apply.
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Quick Reference
Toolspace Shortcut Menu
Settings tab: right-click Quantity Takeoff collection ➤ Edit Feature Settings
OR
Settings tab: Quantity Takeoff ➤ Commands ➤ right-click <command-name> ➤ Edit Command Settings
Dialog Box
Edit Feature Settings - Quantity Takeoff (page 2569)

Analyzing Sectional Volumes
Use the material volumes functionality to extract and report sectional material volumes, based on sample
line groups.
You can create tables and reports for:
■

Volumes along an alignment, comparing various design surfaces and existing ground surfaces.

■

Volumes for shapes, which are closed cross-sectional areas created by a single subassembly. For example,
a curb (a closed area within a concrete curb or curb and gutter).

You can display material volume information using standard AutoCAD Civil 3D table formats, or view and
export the information in an XML format file.
Material volume reporting uses criteria settings that are portable and extensible. You can create criteria based
either on existing data, including surfaces and sample line groups, or on standard surface names.
You prepare to generate material volume information by creating a list of materials and applying the
predefined criteria to it, mapping existing surfaces or other objects to the names in the criteria. After the
material list is generated, the settings and volume calculations are stored with the sample line group and
can be used to generate tables and reports.
Analyzing Sectional Volumes (page 55)

Sectional Volume Methods
When you compute the materials for a sample line group, you can use three different volume calculation
methods: Average End Area, Prismoidal, or Composite.
■

If the cut/fill areas between two successive stations are of similar shape, then the Average End Area
Method (page 1278) can be used.

■

If the terrain has greater changes between stations, then the Prismoidal Method (page 1278) can be more
accurate.

■

The Composite Method (page 1278) uses the actual surface data and does not use formulas to interpolate
the volume between sample lines. This method is particularly useful if the any of the surface triangle
edges are smaller than the sample line interval.

You can specify which volume method to use in the following dialog boxes:
■

Compute Materials. For more information, see Generating Material Lists (page 1282).

■

Edit Material List. For more information, see Generating Material Lists (page 1282).
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■

Sample Line Group Properties, Material List tab. For more information, see Editing Sample Line Group
Properties (page 1254).

Average End Area Method
The Average End Area method calculates volumes by adding the area of a material type at one station to the
area of the material type at the next station and dividing the sum by two, then multiplying the result by
the distance between the sections (L).

Prismoidal Method
The Prismoidal method is similar to the Average End Area method but uses an additional cross section at
the middle of the two successive stations.

Composite Method
The Composite method is limited to material lists that have only two surfaces and cannot be used for material
lists that contain corridor shapes.
To calculate composite volumes, AutoCAD Civil 3D creates polygons between sample lines and then computes
the bounded volumes of those polygons. The polygons are created by joining the offsets of the sample lines
between two successive stations, as shown in the following illustration.

■

If the offsets are uniform, then a line that matches the curvature of the centerline is used to join the
sample lines (1).

■

If the offsets are not uniform, then a straight line is used to join the sample lines (2).

■

The composite volume is then calculated for the area within the polygon (3) for each material in the
material list of the sample line group.

The volume is recorded at the second sample line of the polygon. The first sample line in the sample line
group will therefore have zero volume associated with it.

Defining Materials
Create quantity takeoff criteria as the first step in analyzing sectional material volumes.
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After you create a quantity takeoff criteria, you can apply it to a sample line group to create a material list.
You use the material list to generate quantity takeoff tables and reports.

Creating Quantity Takeoff Criteria
Create quantity takeoff criteria in preparation for generating quantity takeoff tables or reports.
The criteria are stored in the Toolspace Settings tab under the Quantity Takeoff collection. After you create
a quantity takeoff criteria, you can apply it to a sample line group to create a material list. You use the
material list to generate quantity takeoff tables and reports.
To create a criteria, you create a list of materials and shapes. For example, you can create an entry that
calculates the volume of material to remove by creating a material called Ground Removed, and then add
to it two surfaces that are compared to generate the volume information.
You can also define materials in a criteria using a sample line group. Select a sample line group, and then
create material definitions using the list of surfaces that are used as a data source for the group.

Quantity Types
Quantity takeoff supports the following quantity types:
■

Cut. Used to calculate the material to remove. For example, this could be the amount below an existing
ground (EG) surface and above a finished ground (FG) surface:

■

Fill. Used to calculate the material to add. For example, this could be the amount above an existing
ground (EG) surface and below a finished ground (FG) surface:

■

Cut and Refill. Used to calculate the material to remove and add based on a refill factor that is different
from the cut factor. For example, an existing subsurface material area for a corridor may have to be
removed if it comprises loose soil or marsh land, and refilled with a different type of material to provide
structural stability.

■

Earthworks. Used to calculate the total cut and fill volumes. For example, this could be any differences
between the existing ground (EG) surface and the finished ground (FG) surface:

NOTE The Earthworks Quantity Type cannot be used for subcriteria.
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■

Structures. Used to calculate the volumes of corridor shapes, for example, in the following illustration,
which is a cross-section of a corridor, the volume of the sidewalk shape would be calculated:

NOTE The Structures Quantity Type cannot be used for subcriteria.

Cut, Fill, and Refill Factors
Use Cut, Fill, and Refill factors to adjust volumes to be hauled. As the hauled volumes are used as a baseline
set at an even factor of 1.0. The adjustment factors are:
■

Cut factor - As the volume of material generally expands after it is removed, the cut factor is usually set
to greater than 1.0, indicating swell or expansion. For example, a 1.2 cut factor would mean that for
every 1.0 cubic meter of material removed, 1.2 cubic meters of volume would need to be accounted for
transport.

■

Fill factor - As the material generally compacts when used as fill, the fill factor is usually set to greater
than 1.0, to indicate compaction or shrinkage of the material when it is used as fill. For example, a 1.2
fill factor would mean that for every 1.0 cubic meter of material required for the fill site, 1.2 cubic meters
of that material would need to be transported.
NOTE For example, for a material that compacts to 93% of its original value when used as fill, enter 1.075
(which is derived by dividing 1.0 by .93) as the fill factor to compensate for the extra material that must be
added.

■

Refill factor - As this factor depends on the cut material type and other considerations, it can run across
a range. A heavy aggregate might have a Refill factor of 1.0, while fill cut from a rock ledge might have
a Refill factor of 1.2. Not all cut material may even be reusable, as when it is cut from bog or marsh. The
refill factor would then be 0.

Creating new criteria
1 In Toolspace, on the Settings Tree, expand the
Takeoff Criteria collection. Click New.

Quantity Takeoff collection. Right-click the Quantity

2 In the Quantity Takeoff Criteria dialog box, click the Information tab (page 2592).
3 To edit the name of the criterion, enter a new name in the Name field.
4 To edit the description of the criterion, enter a new description in the Description field.
5 Click Apply to make the changes, or click OK to make the changes and close the Quantity Takeoff
Criteria dialog box.
6 To define or edit the criterion, click the Material List tab (page 2593).
7 Click Add New Material.
8 Select the new material. Click the Quantity Type field. Select the quantity type, either Cut, Fill, Cut
and Refill, Earthworks, or Structures.
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9 Click the Shape Style field. Select the default style used to display the material section in a section view.
For more information about using Shape Styles to review material calculations graphically, see Reviewing
Sectional Volume Results Graphically (page 1289).
10 Optionally, edit the cut, fill, and refill factors by selecting the corresponding fields. Enter new values.
11 If you selected a quantity type of Cut, Fill, Cut and Refill, or Earthworks to add surfaces, select the new
material. From the Data Type list, select Surface. In the Select Surface list, enter the surface name or
select a surface.
12 If you selected a quantity type of Structures, to add corridor shapes, select the new material. Select
Corridor Shapes from the Data Type list. In the Select Shape list, enter the shape name or select a shape.
Click the Shape Style field. Select a style for the shapes.
13 For each data type added to a material, click the Condition field. Select the condition.
14 Optionally, repeat Steps 7 through 13 to create all required materials and surfaces.
15 Optionally, add subcriteria. For more information, see To add a material with subcriteria to the material
list of a sample line group (page 1289).
16 Click Apply.
Defining criteria from a sample line group
1 In Toolspace, on the Settings Tree, expand the
Takeoff Criteria folder and click New.

Quantity Takeoff collection. Right-click the Quantity

2 In the Quantity Takeoff Criteria dialog box, click the Information tab (page 2592).
3 To edit the name of the criteria, enter a new name in the Name field.
4 To edit the description of the criteria, enter a new description in the Description field.
5 Click Apply to make the changes, or click OK to make the changes and close the Quantity Takeoff
Criteria dialog box.
6 To define the criteria, click the Material List tab (page 2593).
7 Click Define From A Sample Line Group.
8 In the Define Material Criteria dialog box, click the Select Alignment field. Select the alignment or click
to select an alignment in the drawing.
9 Click the Select Sample Line Group field to select a sample line group.
10 Select the surfaces to use in the criteria by selecting or clearing the check box in the Select field next
to the surface name.
11 Click OK.
12 In the Quantity Takeoff Criteria dialog box, click Apply or OK.

Quick Reference
Toolspace Menu
Settings tab: Quantity Takeoff ➤ Quantity Takeoff Criteria ➤ New
Dialog Box
Quantity Takeoff Criteria (page 2592)
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Generating Material Lists
Use the Compute Materials command to generate a material list for a sample line group.
Material lists are the starting points for creating quantity takeoff tables and reports, and mass haul diagrams.
When you apply a quantity takeoff criteria to a sample line group, a material list is added to the sample line
group properties. You can then use the material list to create a volume table or report, or a mass haul diagram.
Before you create a material list, you must first define quantity takeoff criteria and create sample lines for
the alignment along which you are going to generate quantity takeoff or mass haul information.
The material lists you create are stored as part of the sample line group properties. If you select a sample line
group that already has a material list when you are using the Compute Materials command, the existing list
is opened for editing.

Curve Correction
Curve correction may be required to correct volume calculations within a curvilinear section of an alignment
(or on two sides of a horizontal intersection point). If the sample lines are within a specified tolerance or if
the angle of deflection between the successive stations is small, then curve correction is not used.
NOTE Curve correction can be applied to the Average End Area method. It cannot be applied to the Prismoidal
or Composite method.
To create a new material list for a sample line group
1 Click Analyze tab ➤ Volumes And Materials panel ➤ Compute Materials

.

2 In the Select a Sample Line Group dialog box, click the Select Alignment field. Select an alignment from
the list or click

and select an alignment in the drawing.

3 Click the Select Sample Line Group field. Select a sample line group or click
drawing.

to select a group in the

4 Click OK.
If there is no material list associated with the sample line group, the Compute Materials dialog box
(page 2562) is displayed.
If one or more material lists are already part of the sample line group properties, the Edit Material List
dialog box (page 2572) is displayed. You can add a new materials list or edit an existing list as required.
You can also add subcriteria (page 1285) to address more complex volume situations.
5 Click the Quantity Takeoff Criteria field. Select the criteria. For more information, see Creating Quantity
Takeoff Criteria (page 1279).
6 Select a Volume Calculation Method. For more information, see Sectional Volume Methods (page 1277).
7 Optionally, select the Curve Correction Tolerance check box and enter a curve correction value.
NOTE This control is grayed out if Composite Volume or Prismoidal is specified as the Volume Calculation
Method.
8 Map the object names to apply to the materials by clicking in the Object Name column and selecting
the appropriate object, such as a surface.
9 Optionally, if the criteria uses the same surface and structure names as objects in the drawing, you can
quickly map the names by clicking Map Objects With Same Name.
10 Click OK.
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The quantity takeoff calculation is performed and the material list is added to the sample line group
properties.

Quick Reference
Ribbon
Analyze tab ➤ Volumes And Materials panel ➤ Compute Materials
Menu
Sections menu ➤ Compute Materials
Command Line
ComputeMaterials
Dialog Box
Compute Materials (page 2562)
Edit Material List (page 2572)

Defining Gaps and Pockets of Materials
In situations where volume computation should not occur, you can define gaps in the materials.
A gap can be used where there is one gap in the material, such as a bridge location. Gaps can also be used
in multiple locations, where there are non-contiguous pockets of a material along the length of a corridor.
Gaps are defined in the Sample Line Group Properties, Material List tab. For more information, see Material
List Tab (Sample Line Group Properties Dialog Box) (page 2518).

Run In and Run Out Distances For Gaps
Gaps can have run in and run out distances which act as transition areas between materials. By default the
gaps have run in and run out values of zero. No material is interpolated beyond the gap stations, as shown
in the following illustration.

If marsh material is present between station 2+00 and 3+00 with short transitions before and after, you can
specify run in and run out instead of adding more sample lines, as shown in the following illustration.

The run in for the material is defined in the first gap, and the run out for the material is defined in the
second gap. Therefore, the first gap would have a run in of 50, and the second gap would have a run out of
75.
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If you want to have tighter control on the run ins and run outs, you can set smaller values or keep the default
of zero.

Defining Gaps for Pockets of Material
In the following example, three materials are defined: Cut, Fill, and Marsh material. The Marsh material
exists only at the hatched areas in the illustration. All three materials must be added into one material list
because the cumulative cut/fill calculations should include all three types.

For this example, you would add 3 gaps (as represented by numbers 1, 2, and 3 in the illustration) with
appropriate run ins and run outs for material transitions. In the material list the gaps should only be applied
to Marsh material and not for the materials named Cut and Fill.
To define gaps for a material list
1 Select a sample line.Click Sample Line tab ➤ Modify panel ➤ Group Properties

.

2 Click the Material List tab.
3 If you have not yet added materials to the sample line group, add the required materials. For more
information, see Material List Tab (Sample Line Group Properties Dialog Box) (page 2518).
NOTE You can add material list definitions on the Material List tab, or you can use the Compute Materials
command. for more information, see Generating Material Lists (page 1282).

4 At the the

Material List level, click the Gap column. The Define Gaps dialog box is displayed.

5 Use Define Gaps (page 2520) dialog box to define a list of gaps along the alignment. In this dialog box,
you define the start and end stations of the gaps for the entire material list. In Step 7 you use the Apply
Gaps dialog box to control the gaps for each individual material.
6 Click OK to return to the Material List tab.
7 At the

Material level, click the Gap column. The Apply Gaps dialog box is displayed.

8 In the Apply Gaps (page 2521) dialog box, clear the Apply Gaps check box for any material for which
gaps should not be applied. For example, if Cut or Fill material is found throughout the length of the
alignment with no gaps, clear the Apply check boxes for those gaps.
9 For materials for which you want to apply gaps, keep the Apply check box selected and define the Run
Out and Run In distances. These distances apply to the material before and after the gaps.
In the following illustration, the green areas 1 and 2 represent gaps in the material (5). Gap 1 does not
have a run out distance. However, Gap 1 has a run in distance of 40m as represented by the red area
number 3.
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Gap 2 has a run out distance of 75m as represented by the red area number 4.
These gaps would be defined as follows:
Gap 1
■

Start Station: 0+000

■

End Station: 0+300

■

Run Out Distance: 0.00

■

Run In Distance: 40.00

Gap 2
■

Start Station: 0+700

■

End Station: 1+200

■

Run Out Distance: 75.00

■

Run In Distance: 0.00

Calculating Volumes for Overlapping Materials or Overhangs
You can accomodate complex volume situations by defining subcriteria.
Subcriteria is a new type of material definition in AutoCAD Civil 3D 2011. Using subcriteria, a material
volume is reported by combining all the areas of submaterials in it.
A few cases where subcriteria can be applied are described in the following sections.

Overlapping Materials
The following illustration shows a condition of overlapping materials that can be addressed by subcriteria.

(1) is top of Existing Ground, (2) is top of Subsoil, and (3) is top of Rockbed.
To define materials for this situation, you can use the following subcriteria:
Material 1 Definition
■

Subcriteria 1
■

Surface name: EG; Condition: Below

■

Surface name: Subsoil; Condition: Above
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■

Subcriteria 2
■

Surface name: EG; Condition: Below

■

Surface name: Rockbed; Condition: Above

To calculate volumes for this situation, AutoCAD Civil 3D adds vertical links (numbers 1-4) to create closed
envelopes as shown in the following illustration.

Then the subcriteria are applied as follows, where (1) is subcriteria 1 (below EG, above subsoil), and (2) is
subcriteria 2 (below EG, above Rockbed).

Non-Overlapping Materials
The same subcriteria can be applied to the case of non-overlapping materials, as shown in the following
illustration.
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Then the subcriteria are applied as follows, where (1) is subcriteria 1 (below EG, above subsoil), and (2) is
subcriteria 2 (below EG, above Rockbed).

Intersecting Materials
The case of intersecting materials is shown in the following illustration.

In this case, because Subsoil and Rockbed surfaces intersect, this situation could be addressed with a subcriteria
that uses 3 surfaces: Below EG, Above Subsoil, and Above Rockbed.

Materials In Overhang Situations
The case of rock cut material in an overhang situation is shown in the following illustration, where (1) is
Datum, (2) is Rock Bed, (3) is Rock Under, and (4) is Rock Top.
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To accommodate this situation, you would define the following subcriteria:
Rock Cut Material Definition
■

■

■

Subcriteria 1
■

Surface name: Datum; Condition: Above

■

Surface name: Rock Bed; Condition: Below

Subcriteria 2
■

Surface name: Rock Under; Condition: Above

■

Surface name: Rock Top; Condition: Below

Subcriteria 3
■

Surface name: Datum; Condition: Above

■

Surface name: Rock Top; Condition: Below

To calculate volumes for this situation, AutoCAD Civil 3D adds vertical links (numbers 1-2) to create closed
envelopes as shown in the following illustration.

Then the subcriteria are applied as follows, where (1) is subcriteria 1 (above Datum, below Rock Bed), (2) is
subcriteria 2 (above Rock Under, below Rock Top), and (3) is subcriteria 3 (above Datum, below Rock Top).
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The volumes for the three subcriteria are then combined to obtain the sum of Rock Cut material for each
station.
Subcriteria can be defined in three different dialog boxes:
■

Quantity Takeoff Criteria dialog box, Material List tab. For more information, see Creating Quantity
Takeoff Criteria (page 1279).

■

Edit Material List dialog box. This dialog box is displayed when you run the Compute Materials command
and the selected sample line group already has a material list associated with it.

■

Sample Line Group Properties dialog box, Material List tab. This procedure is documented below.

To add a material with subcriteria to the material list of a sample line group
1 Select a sample line. Click Sample Line tab ➤ Modify panel ➤ Group Properties

.

2 Click Add New Material.
NOTE The material definition must exclusively contain subcriteria. Subcriteria cannot be combined with
material contain criteria other than subcriteria.
3 Define the Quantity Type for the material as either Cut, Fill, or Cut And Refill.
NOTE Earthworks and Structure Quantity Types are not supported for subcriteria.
4 Select the new material and click Add A Subcriteria.
5 Select the Subcriteria and use the controls under Define Material to add surfaces to it.
NOTE Corridor shapes cannot be added to a subcriteria.
6 Select the new material again and click Add A Subcriteria to define the next subcriteria for it.

Reviewing Sectional Volume Results Graphically
After you have created a material list for a sample line group, you can graphically review how the material
volumes have been calculated.
You can review the volumes graphically by plotting sections in the drawing. Each material is assigned a
shape style which can be displayed in the section view. Shape styles have unique colors and hatch patterns
which enable you to examine how each material is applied to the cross section.
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The following example shows how a material is not applied as expected on the right side due to complex
section geometry. In this case, subcriteria can be defined address the situation.

To review volumes graphically
1 Set up shape styles. For more information, see Copying or Editing Shape Styles (page 1580).
2 Set up a Quantity Takeoff Criteria. Assign each material in the Quantity Takeoff Criteria a shape style.
For more information, see Creating Quantity Takeoff Criteria (page 1279).
3 Generate a material list. For more information, see Generating Material Lists (page 1282).
4 Create sections in the drawing. For more information, see To create multiple section views (page 1259).
5 Examine how the shape styles are applied to the sections. If material areas do not have a shape style
applied, then the volume for that material area will not be included in the volume calculation.

Creating Sectional Volume Tables and Reports
Use the table and report creation commands to analyze sectional volumes.
You can create tables and reports for:
■

Volumes along an alignment, comparing various design surfaces and existing ground surfaces.

■

Volumes for shapes, which are closed cross-sectional areas created by a single subassembly. For example,
a curb (a closed area within a concrete curb or curb and gutter).

■

Volumes between various (designed/grading/existing) formations.

The results of a quantity takeoff calculation are displayed using one of the following three methods:
■

Total Volume Table

■

Material Volume Table

■

Quantities Report

A Total Volume Table contains cut, fill, and cumulative volume information (for example, an earthworks
or cut/fill report).
A Material Volume Table contains cut, fill, and cumulative volume information for a specific material in
the material list (for example, the cumulative volume of a structure element).
A Quantities Report is an XML format file that contains the criteria definition (comparable surfaces), material
types (such as cut type), shrink and swell factors, as well as refill factors. The specific format is determined
by the style sheet you select.
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Before you create a quantity takeoff report or table, materials must be defined in the Sample Line Group
properties or computed using the Compute Materials command.
You can display quantity takeoff information using standard AutoCAD Civil 3D table formats or view and
export it in an XML format file.

Style Sheets
Three style sheets installed with AutoCAD Civil 3D are used to create external quantity takeoff reports:
■

Earthworks.xsl. Reports station-by-station values in a tabular format for cut and fill volumes, incremental
volumes, and cumulative net volume.

■

Select Material.xsl. Reports station-by-station values for the selected materials. At each station, all selected
materials defined in this criteria and cumulative volumes are reported.

■

Mass Haul - Multiple Materials.xsl. If you have defined many material types to remove (for example, for
embankment creation for road widening along the corridor), you can use this style sheet to aggregate
the material types and produce material-by-material reports at each station as well as aggregate volume
reports for mass hauls.

To create a total volume table
1 Click Analyze tab ➤ Volumes And Materials panel ➤ Total Volume Table

.

2 In the Create Total Volume Table dialog box (page 2567), select a table style and layer.
3 Click the Select Alignment field. Select an alignment from the list or click
in the drawing.

to select an alignment

4 Click the Select Sample Line Group field. Select a sample line group from the list.
5 Click the Select Material List field. Select a material list from the list.
6 Optionally, select Split Table, and then specify the maximum and minimum number of rows in a table,
the distance to offset tables from each other, and the method for arranging multiple tables.
7 Under Behavior, specify whether the table is static or dynamic.
8 Click OK.
The upper-left corner of the new table is attached to your cursor.
9 Click in the drawing to set the location of the table.
To create a material volume table
1 Click Analyze tab ➤ Volumes And Materials panel ➤ Material Volume Table

.

2 In the Create Material Volume Table dialog box (page 2566), select a table style and layer.
3 Click the Select Alignment field. Select an alignment from the list or click
in the drawing.

to select an alignment

4 Click the Select Sample Line Group field. Select a sample line group from the list.
5 Click the Select Material List field. Select a material list from the list.
6 Click the Select a Material field. Select a material from the list.
7 Optionally, select Split Table, and then specify the maximum and minimum number of rows in a table,
the distance to offset tables from each other, and the method for arranging multiple tables.
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8 Under Behavior, specify whether the table is static or dynamic.
9 Click OK.
The upper-left corner of the new table is attached to your cursor.
10 Click in the drawing to set the location of the table.
To generate an external quantity takeoff report
1 Click Analyze tab ➤ Volumes And Materials panel ➤ Volume Report
2 In the Report Quantities dialog box (page 2595), click the Select Alignment field. Select an alignment
from the list or click

to select an alignment in the drawing.

3 Click the Select Sample Line Group field. Select a sample line group from the list.
4 Click OK.
5 Click the Select Material List field. Select a material list from the list.
6 Enter a style sheet name in the Select A Style Sheet field or click

to browse for one.

7 To display the quantity takeoff report, select the Display XML Report check box.
8 Click OK to save the report settings and generate the report.

Quick Reference
Ribbon
Analyze tab ➤ Volumes And Materials panel ➤ Total Volume Table
Analyze tab ➤ Volumes And Materials panel ➤ Material Volume Table
Analyze tab ➤ Volumes And Materials panel ➤ Volume Report
Menu
Sections menu ➤ Add Tables ➤ Total Volume
Sections menu ➤ Add Tables ➤ Material Volume
Sections menu ➤ Generate Volume Report
Command Line
AddTotalVolumeTable
AddMaterialVolumeTable
GenerateQuantitiesReport
Dialog Boxes
Total Volume Table Creation (page 2567)
Material Volume Table Creation (page 2566)
Report Quantities (page 2562)

Creating and Editing Quantity Takeoff Table Styles
Styles control the way quantity takeoff tables are displayed in a drawing.
Use the Toolspace Settings tree to copy, edit, or delete a quantity takeoff table style.
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Two types of quantity takeoff table styles are listed in the Settings tree under the Quantity Takeoff collection:
Total Volume and Material. The two types of table styles have the same properties as other AutoCAD Civil
3D table styles except for the property fields that can be included in the table.
NOTE If you generate a quantity takeoff report, the style of the external file is controlled using the specified style
sheet. For more information, see the report generation information in Creating Sectional Volume Tables and
Reports (page 1290).
To create a new quantity takeoff table style
1 In Toolspace, in the Settings tree, under Quantity Takeoff, expand the Table Styles collection.
2 For the Total Volume or Material collection, right-click the collection ➤ .New.
3 In the Table Style dialog box (page 2735), enter or change the name of the style and other settings as
required.
4 Click OK.
To copy or edit an existing quantity takeoff table style
1 In Toolspace, in the Settings tree, under Quantity Takeoff, expand the Table Styles collection.
2 Expand the Total Volume or Material collection.
3 Right-click an existing style. Click Copy or Edit.
4 In the Table Style dialog box (page 2735), edit the name of the style and other settings as required.
5 Click OK.
To delete a quantity takeoff table style
1 In Toolspace, in the Settings tree, under Quantity Takeoff, expand the Table Styles collection.
2 Expand the Total Volume or Material collection.
3 Right-click the style to delete. Click Delete.
4 In the confirmation dialog box, click Yes.

Quick Reference
Toolspace Shortcut Menu
Create: Settings tab: right-click Total Volume or Material collection ➤ New
Copy: Settings tab: right-click Total Volume or Material collection ➤ Copy
Edit: Settings tab: right-click Total Volume or Material collection ➤ Edit
Delete: Settings tab: right-click Total Volume or Material collection ➤ Delete
Dialog Box
Table Style (page 2735)

Using Pay Items to Analyze Quantities
Analyze quantities using the AutoCAD Civil 3D QTO Manager to apply pay items to AutoCAD Civil 3D
model objects.
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The pay item (page 2779) is one of the most important elements of a highway design plan. A pay item is a
specific unit of work for which a price is provided and a contractor is paid while a highway is under
construction.
The three major properties of a pay item are:
■

Item number, each of which is unique on a design plan

■

Specification, which describes the material to be used, the method of incorporating the material, and
how the completed work will be measured and paid for

■

Cost estimate, which is made to ensure that the overall design falls within the budget available for the
project

Incorporating pay item information correctly into design plans including plan sheets, summaries, the
engineer’s estimate and bid documents is a major task for highway designers. Designers can use the QTO
Manager functionality to automate the pay item management process to reduce errors and eliminate disputes
with contractors.
Pay items can be associated with AutoCAD lines, open or closed polygons, blocks, or any AutoCAD or Civil
3D entity after they have been created. When pay items are assigned to a AutoCAD Civil 3D code set style,
a corridor object is automatically tagged with the specified pay items. When pay items are assigned to a
AutoCAD Civil 3D pipe network parts list, any new pipes or structures are automatically tagged with the
specified pay items.

Importing Master Pay Item Lists
Import a pay item file and categorization file into a drawing.
Use the QTO Manager vista and Open Pay Item File dialog box to import pay item (page 2779) files and their
categorization files into a AutoCAD Civil 3D drawing.
A pay item file contains the pay item codes, descriptions, and units of measure for the master pay item list
(page 2779). The pay item file is formatted as either a Comma Separated Variable (CSV) file or an eXtensible
Markup Language (XML) file.
An optional pay item categorization file categorizes pay items into manageable groups. A pay item
categorization file groups similar pay items by common pay item code prefixes. The categorization file is
always formatted as an XML file.
For information on creating and editing pay item files and pay item categorization files see the Creating a
Pay Item List tutorial.
To import a pay item list
1 Open a drawing containing objects to which you want to attach pay items.
2 Click Analyze tab ➤ QTO panel ➤ QTO Manager
3 In the QTO Manager vista, click

.

.

4 In the Open Pay Item File dialog box, for Pay Item File Format, select either:
■

CSV (Comma Delimited)

■

AASHTO TransXML

■

Florida DOT
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NOTE CSV files must use a separator that matches the list separator specified in the operating system’s
Regional and Language Options. A mismatch will cause the import to fail.
5 To select a pay item file to open:
■

Next to the Pay Item File field, click

.

■

In the Open dialog box, select a pay item file.

■

Click Open.

6 Optionally, to select a pay item categorization file to open:
■

Next to the Pay Item Categorization File field, click

.

■

In the Open dialog box, select a pay item categorization file.

■

Click Open.

7 In the Open Pay Item File dialog box, click OK.
8 In the QTO Manager vista:
■

Click

Turn On Categorization to view the categories on the categorized pay item list.

■

Click

Turn Off Categorization to view all pay items on the uncategorized pay item list.

Quick Reference
Ribbon
Analyze tab ➤ QTO panel ➤ QTO Manager
Command
QTOManager
Dialog Boxes
QTO Manager vista (page 2589)
Open Pay Item File (page 2587)

Managing Pay Item Lists
Use the commands in the QTO Manager vista to manage pay items.
After you open a pay item (page 2779) file in your drawing, you can filter the pay item list (page 2779) for individual
pay items, either by Pay Item ID or by the text in the Description for the pay item.
If you do not open a pay item categorization file when you opened the pay item file, you can categorize the
pay item list at any time.
Use highlighting to visually sort items in the drawing.

Filtering Pay Items
Use the filter to sort the pay items in a list.
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Filtering a pay item list (page 2779) using IDs or keywords sorts and reduces the list down to a manageable size
when you are looking for a single pay item or a small group of pay items.
When a filter term is entered, all pay item descriptions are searched for matches to the filter keyword(s). If
no match is found, the pay item IDs are searched.
To filter for pay items
1 Open a drawing in which a pay item file is open.
2 Click Analyze tab ➤ QTO panel ➤ QTO Manager
3 In the QTO Manager vista, click

.

Turn Off Categorization so you can filter the pay item list.

4 Enter a filter keyword, such as ‘slab’, in the Enter Text To Filter Pay Items field.
5 Click

.

Only pay items with the word ‘slab’ in the Description column remain in the field.
6 Right-click any of the pay items and click Add To Favorites List.
The selected pay item is added to the Favorites list.

Quick Reference
Ribbon
Analyze tab ➤ QTO panel ➤ QTO Manager
Command
QTOManager
Dialog Boxes
QTO Manager vista (page 2589)

Categorizing Pay Items
Use a categorization file to organize a pay item list.
If you do not open a categorization file when you opened the current pay item file, you can add one later.
If you open a categorization file when you open the pay item file, you can later replace that categorization
file.
To categorize a pay item list
1 Open a drawing in which a pay item file is open.
2 Click Analyze tab ➤ QTO panel ➤ QTO Manager
3 In the QTO Manager vista, click
pay item list.
4 Click the

.

Turn On Categorization so you can see the categorization of the

drop-down ➤ Open ➤ Categorization File.

5 In the Open dialog box, select a categorization file and click Open.
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The categorization file is applied to the pay item list.

Quick Reference
Ribbon
Analyze tab ➤ QTO panel ➤ QTO Manager
Command
QTOManager
Dialog Boxes
QTO Manager vista (page 2589)

Highlighting Pay Items
Use highlighting to identify objects to which pay items have been attached.
As you use filtering to sort pay item (page 2779)s in a pay item list (page 2779), use the highlighting commands
to visually sort objects and pay items in the drawing.
For example, in a drawing or an area of a drawing where only a few objects have been tagged with pay items,
you can easily identify those objects using the
Highlight Objects With Pay Items command. In a drawing
or an area of a drawing where most objects have been tagged with pay items, you can easily identify those
objects without attached pay items using the

Highlight Objects Without Pay Items command. Also, by

using the
Highlight Objects With Selected Pay Items command, you can identify objects tagged with
specific pay items.
To highlight objects with pay items attached
1 Open a drawing containing objects to which pay items are attached.
2 Click Analyze tab ➤ QTO panel ➤ QTO Manager

.

3 To identify objects that have pay items attached, click

Highlight Objects With Pay Items.

Only objects to which pay items are attached will be highlighted. Untagged objects are dimmed.
4 To remove the highlighting, click

Clear Highlight.

All objects are again displayed without highlighting or dimming.
NOTE Clear highlighting before running another highlight command.

To highlight objects without pay items attached
1 Open a drawing containing objects to which pay items are attached.
2 Click Analyze tab ➤ QTO panel ➤ QTO Manager
3 To identify objects without pay items attached, click

.
Highlight Objects Without Pay Items.

All untagged objects are highlighted. Tagged objects are dimmed.
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4 To remove the highlighting, click

Clear Highlight.

All objects are again displayed without highlighting or dimming.
NOTE Clear highlighting before running another highlight command.

To highlight objects with a specific pay item attached
1 Open a drawing containing objects to which pay items are attached.
2 Click Analyze tab ➤ QTO panel ➤ QTO Manager

.

3 Filter (page 1296) for a specific Pay Item ID or pay item name(s).
4 To identify objects that have the selected pay item(s) attached, click
Pay Items.

Highlight Objects With Selected

Objects with the selected pay item(s) are highlighted. All other objects are dimmed.
5 To remove the highlighting, click

Clear Highlight.

All objects are again displayed without highlighting or dimming.
NOTE Clear highlighting before running another highlight command.

Quick Reference
Ribbon
Analyze tab ➤ QTO panel ➤ QTO Manager
Command
QTOManager
Dialog Boxes
QTO Manager vista (page 2589)

Tagging Objects with Pay Items
Assign pay items to objects in the drawing.
Assign pay item (page 2779)s to objects or groups of objects in your drawing. Assign pay item list (page 2779)s to
corridors and pipe networks. You can manually tag pay items to individual objects or bounded areas, or to
groups of similar objects or bounded areas. After you have prepared codes, you can automatically tag corridors
and pipe networks with pay items.

Tagging Manually
Tag objects or groups of similar objects with one or more pay items.
Tag a single object or enclosed area with one or more pay item (page 2779)s, or select each one of a type of
object or closed area and assign pay items to all objects in the group. You can add or remove a pay item for
a single object or its entire group.
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Assigning Pay Items to Objects
Assign pay items to objects in the drawing.
In the most basic tagging operation, you apply a single pay item (page 2779) to a single object in the drawing.
To assign a pay item to an object
1 Open a drawing in which a pay item file is open.
2 Click Analyze tab ➤ QTO panel ➤ QTO Manager
3 In the QTO Manager vista, click

.

.

4 In the pay item list, select a pay item.
5 Press Enter.
6 Select an object in the drawing.
7 Right-click or press Esc to end the selection process.

Quick Reference
Ribbon
Analyze tab ➤ QTO panel ➤ QTO Manager
Command
QTOManager
AssignPayItem
Dialog Box
QTO Manager vista (page 2589)

Assigning Multiple Pay Items to Areas
Assign pay items to closed areas in the drawing
Speed up the assignment of pay item (page 2779)s to objects in the drawing by tagging objects or groups of
objects in the drawing with multiple pay items.
To assign multiple pay items to a closed area
1 Open a drawing in which a pay item file is open.
2 Click Analyze tab ➤ QTO panel ➤ QTO Manager
3 In the QTO Manager vista, click

.

.

4 Press Ctrl+click to select each pay item you want to assign from the pay item list.
5 Press Enter.
6 On the Command line, enter O to select objects rather than points.
7 Select one or more closed areas in the drawing.
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NOTE To select all of the closed areas of a single type, right-click the area and click Select Similar.
The pay items are assigned to the closed area(s).
8 Press Esc to end the command.

Quick Reference
Ribbon
Analyze tab ➤ QTO panel ➤ QTO Manager
Command
QTOManager
AssignPayItemToArea
Dialog Box
QTO Manager vista (page 2589)

Editing Pay Items on Objects
Add or remove pay items from objects in the drawing.
As a project progresses, you may need to add pay item (page 2779)s to or remove them from the objects you
have tagged. You can add or remove each pay item attached to an object individually, or remove all the pay
items assigned to an object or group of objects.
To add pay items to others attached to an object
1 Open a drawing in which pay items are attached to objects.
2 Click Analyze tab ➤ QTO panel ➤ QTO Manager

.

3 Select an object whose attached pay item(s) you want to edit.
4 In the QTO Manager vista, click

.

5 In the Edit Pay Items dialog box, click

.

6 In the Pay Item List dialog box, select the pay item you want to attach to the object in the drawing.
Click OK.
7 Repeat Steps 5 and 6, as needed.
8 In the Edit Pay Items dialog box, click OK when finished.
To remove one or more pay item(s) from an object
1 Open a drawing in which multiple pay items are attached to objects.
2 Click Analyze tab ➤ QTO panel ➤ QTO Manager

.

3 Select an object whose attached pay item(s) you want to edit.
4 In the QTO Manager vista, click
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.

5 In the Edit Pay Items dialog box, select the pay item you want to remove from the object in the drawing.
6 Click

.

7 Repeat Steps 5 and 6, as needed.
8 Click OK when finished.
To remove all pay items from an object
1 Open a drawing in which pay items are attached to objects.
2 Click Analyze tab ➤ QTO panel ➤ QTO Manager

.

3 Select an object or a group of objects with attached pay item(s) you want to remove.
4 In the QTO Manager vista, click

.

All pay items are removed from the selected object(s).

Quick Reference
Ribbon
Analyze tab ➤ QTO panel ➤ QTO Manager
Commands
QTOManager
EditPayItemOnObject
DeletePayItemsFromObject
Dialog Boxes
QTO Manager vista (page 2589)
Edit Pay Items (page 2574)
Pay Item List (page 2588)

Tagging Automatically
Automatically tag corridors or pipe networks with pay items.
After you modify general and command settings, you can automatically tag corridors or new pipe network
parts with pay item (page 2779)s.

Assigning Pay Items to Corridors
After you modify Code Set Styles, you can automatically assign pay items to a corridor.
You must create a code set style for links and points before assigning pay item (page 2779)s to a corridor. Then,
you apply the code set style to the corridor.
Pay items assigned to Point codes generate length quantities from the corridor. Pay items assigned to Link
codes generate area quantities from the corridor.
To create a pay item code set style
1 Open a drawing in which a pay item file is open.
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2 In Toolspace, on the Settings tab, expand General ➤ Multipurpose Styles ➤ Code Set Styles. Right-click
All Codes. Click Copy.
3 In the Code Set Style dialog box, on the Information tab, enter a Name.
4 On the Codes tab:
■

Expand Link and click

■

Expand Point and click

in the Pay Item cells for the links to which pay items will be attached.
in the Pay Item cells for the points to which pay items will be attached.

5 Click OK.
To assign pay items to a corridor
1 In a drawing with pay item code set styles you created, select a corridor.
2 Right-click and click Properties.
3 On the Properties palette, under Data, for Code Set Style Name, select a pay item code set style you
have created.
4 Press Esc.
5 In the drawing, select the baseline of the corridor assembly.
6 Right-click and click Properties.
7 On the Properties palette, under Data, for Code Set Style Name, select a pay item code set style you
created.
8 Press Esc.
NOTE You can also assign pay items to a corridor in the Corridor Properties dialog box. For more information on
this method see the Assigning Pay Item Codes to Corridors tutorial.

Quick Reference
Toolspace Shortcut Menu
Settings tab: General ➤ Multipurpose Styles ➤ Code Set Styles ➤ All Codes
Dialog Boxes
Code Set Style (page 1999)

Assigning Pay Items to Pipe Networks
You can assign pay items to pipe network parts manually, or you can assign pay items to the pipe network
automatically.
Before assigning pay item (page 2779)s to pipe networks, either manually or automatically, specify the QTO
command settings for pipe networks. To assign pay item codes automatically, assign pay item codes to a
parts list.
To specify command settings
1 Open a drawing that has both a pipe network and an open pay item file.
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2 Click Analyze tab ➤ QTO panel ➤ QTO Manager
3 In the QTO Manager vista, click

.

.

4 In the Quantity Takeoff Command Settings dialog box, under Compute Takeoff Options:
■

For Length Computation Type, select 3D.

■

For Pipe Length Type, select To Inside Edges.

5 Click OK.
To assign pay item codes to a parts list
1 Open a drawing in which you set the QTO command settings for pipes.
2 Select a pipe network part.
3 Click Pipe Networks tab ➤ Modify panel ➤ Network Properties

.

4 In the Pipe Network Properties dialog box, on the Layout Settings tab, next to Network Parts List for
the network part you selected, click

.

5 In the Network Parts List dialog box, on the Pipes tab, expand the list to the desired part family or part
size.
6 In the Pay Item cell for the part family or part size you selected, click

.

7 In the Pay Item List dialog box:
■

Click

Turn Off Categorization.

■

Filter to select a pay item to apply to the part family or part size.

■

Click OK to apply the pay item.

8 Repeat Steps 6 and 7 for other part families or part sizes, as needed.
To add parts with pay items to a network
1 Open a drawing in which you set the QTO command settings for pipes.
2 In the drawing, select a network part.
3 Click Pipe Networks tab ➤ Modify panel ➤ Edit Pipe Network

.

4 In the Select Pipe Network dialog box, click OK to select the highlighted network.
5 On the Network Layout Tools toolbar, select the appropriate Structure and Pipe from the drop-down
lists.
6 Next to the Pipe drop-down list, click

Pipes And Structures.

7 In the drawing, click two points to place a pipe and two structures, as selected on the toolbar.
8 Press Enter.
The pipe and structures are placed in the drawing.
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To assign pay items to network parts
1 Open a drawing in which you set the QTO command settings for pipes.
2 In the drawing, select a network part or several identical parts.
3 Click Analyze tab ➤ QTO panel ➤ QTO Manager
4 In the QTO Manager vista, click

.

.

5 In the Pay Item list, select an appropriate pay item to attach to the selected pipe network part(s).
6 Press Enter to attach the pay items to the network parts.

Quick Reference
Ribbon
Analyze tab ➤ QTO panel ➤ QTO Manager
Pipe Networks tab ➤ Modify panel ➤ Network Properties
Pipe Networks tab ➤ Modify panel ➤ Edit Pipe Network
Commands
QTOManager
AssignPayItem
EditNetworkProperties
EditNetwork
Dialog Boxes
QTO Manager vista (page 2589)
Quantity Takeoff Command Settings (page 2591)
Pay Item List (page 2588)
Pipe Network Properties (page 2269)
Network Layout Tools (page 2268)

Using Formulas with Pay Item Lists
Apply formulas to pay items to modify how they are used with objects or closed areas in drawings.

Defining Formulas
Define formulas to modify pay items for use in different situations.
For example, you can use pay item (page 2779) formulas to apply specific masses to volumes, to convert one
unit of measurement to another, to apply a pay item to a set volume, or a number of other mathematical
operations.
Pay item formulas, unlike other mathematical expressions in AutoCAD Civil 3D (label expressions and design
checks), save to a separate FOR file, rather than in the drawing.
BEST PRACTICE Save the pay item formula file in the same location as the drawing with which it is used. If you
send the drawing to another user, you must also send the formula file.
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Applying and Editing Formulas
Apply or edit a pay item formula by clicking in the Formula cell in any pay item entry in the pay item list.
Use the functions, constants and logical operators in the Pay Item Formula dialog box (page 2587) to create
or edit a formula.
You open the Pay Item Formula dialog box, from either the QTO Manager vista or the Pay Item List dialog
box, by clicking in the Formula cell for any pay item for which you want to apply or edit a formula.
Corridor objects only recognize formulas entered through the QTO Manager.
To create a formula for a pay item
1 Open a drawing in which pay items are attached to objects.
2 Select an object with one or more pay items attached.
3 Click Analyze tab ➤ QTO panel ➤ QTO Manager

.

4 In the QTO Manager vista, click in the Formula cell of a pay item attached to the object you selected.
5 If a warning dialog box opens (meaning there is no formula file for the drawing), click Specify Pay Item
Formula File.
6 In the Select A Quantity Takeoff Formula File dialog box:
■

Navigate to the folder in which the current drawing is saved.

■

For File Name, enter a unique name for the takeoff formula file.

■

Click Save.

7 In the Pay Item Formula (page 2587) dialog box:
■

To define additional parameters, click Edit Parameters to display the Pay Item Formula Parameters
Dialog Box (page 2588).

■

Click
, and select either Item Area, Item Count, Item Length, Part Depth, or other user-defined
parameter (as appropriate to the pay item). Your selection is inserted into the Expression field.

■

Use the keyboard or the numeric and logical operator keys, and functions from the
dialog box, to complete the formula.

■

Click OK to apply the formula.

list in the

is displayed in the Formula cell of the selected pay item in the QTO Manager.
To edit or remove a pay item formula
1 Open a drawing in which formulas have been created for pay items.
2 Click Analyze tab ➤ QTO panel ➤ QTO Manager
3 In the QTO Manager vista, click

.

Turn Off Categorization.

4 Use the filter or scroll down through the pay item list to find the pay item whose formula you want to
edit.
5 In the Formula cell of the pay item, click

.
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6 In the Pay Item Formula (page 2587) dialog box:
■

Modify the formula in the Expression field.

■

Alternately, delete the formula from the Expression field.

■

Click OK.

Quick Reference
Ribbon
Analyze tab ➤ QTO panel ➤ QTO Manager
Command
QTOManager
Dialog Boxes
QTO Manager vista (page 2589)
Pay Item Formula (page 2587)

Computing Quantities Using Pay Item Lists
You can compute material quantities from a range of sources.
After you apply pay item (page 2779)s to objects in your drawing, you must decide whether to compute
quantities for entire drawings, the view frame sheets derived from a drawing, or a set of pay item-tagged
objects selected from a drawing.
To compute pay item quantities for an entire drawing
1 Open a drawing in which pay items are attached to objects.
2 Click Analyze tab ➤ QTO panel ➤ Takeoff

.

3 In the Compute Quantity Takeoff dialog box, for Report Type, click Summary or Detailed, based on
whether you want to include each object, or each type of object, with attached pay items in your report.
4 For Report Extents, in the drop-down list, select Drawing.
5 Clear Limit Extents To Alignment Station Range to extend the report beyond the objects along a single
alignment.
6 For Report Output, clear Report Selected Pay Items Only.
7 Click Compute.
8 In the Quantity Takeoff Report dialog box:
■

Select one or more XSL style sheets to format the report.

■

Review the report as formatted by the selected style sheet(s).

■

Click Draw to draw the report to the drawing, and/or click Save As to save the report.

9 Click Close in each dialog box.
For details about placing report tables or text in the drawing, see Placing Pay Item Tables in a Drawing
(page 1308).
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For information about saving reports in various formats, see Saving Pay Item Reports in Various Formats
(page 1309).
To compute pay item quantities from sheets
1 Open a sheet drawing created from view frames in a drawing in which pay items are attached to objects.
2 Click Analyze tab ➤ QTO panel ➤ Takeoff

.

3 In the Compute Quantity Takeoff dialog box, for Report Type, click Summary or Detailed, based on
whether you want each object, or each type of object, with attached pay items included in your report.
4 For Report Extents, in the drop-down list, select Sheet.
5 Select Report Quantity For Sheet Extents Only.
6 Clear Limit Extents To Alignment Station Range to extend the report beyond the objects along a single
alignment.
7 For Report Output, clear Report Selected Pay Items Only.
8 Click Compute.
9 In the Quantity Takeoff Report dialog box:
■

Select one or more XSL style sheets to format the report.

■

Review the report as formatted by the selected style sheet(s).

■

Click Draw to draw the report to the drawing, and/or click Save As to save the report.

10 Click Close in each dialog box.
For details about placing report tables or text in the drawing, see Placing Pay Item Tables in a Drawing
(page 1308).
For information about saving reports in various formats, see Saving Pay Item Reports in Various Formats
(page 1309).
To compute pay item quantities from drawing sets
1 Open a drawing in which pay items are attached to objects.
2 Select a set of objects with pay items attached.
3 Click Analyze tab ➤ QTO panel ➤ Takeoff

.

4 In the Compute Quantity Takeoff dialog box, for Report Type, click Summary or Detailed, based on
whether you want each object, or each type of object, with attached pay items included in your report.
5 Clear Limit Extents To Alignment Station Range to extend the report beyond the objects along a single
alignment.
6 For Report Output, select Report Selected Pay Items Only.
7 Click Compute.
8 In the Quantity Takeoff Report dialog box:
■

Select one or more XSL style sheets to format the report.

■

Review the report as formatted by the selected style sheet(s).

■

Click Draw to draw the report to the drawing, and/or click Save As to save the report.
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9 Click Close in each dialog box.
For details about placing report tables or text in the drawing, see Placing Pay Item Tables in a Drawing
(page 1308).
For information about saving reports in various formats, see Saving Pay Item Reports in Various Formats
(page 1309).

Quick Reference
Ribbon
Analyze tab ➤ QTO panel ➤ Takeoff
Command
Takeoff
Dialog Boxes
Compute Quantity Takeoff (page 2563)
Quantity Takeoff Report (page 2594)

Reporting Pay Item Quantities
You can output your quantity takeoff report in a number of formats and output several versions of a single
report.
If you select to compute a detailed report, by selecting different style sheets you can place a detailed or
summary report table (HTML) or text block (TXT or CSV) in the drawing. In the same way, you can save
both a detailed and a summary report as TransXML, CSV, HTML and TXT files.

Placing Pay Item Tables in a Drawing
Use an HTML style sheet to format a report for insertion as a table in the drawing.
Only HTML formatted reports can be inserted in the drawing as AutoCAD tables. TXT and CSV formatted
reports are inserted as AutoCAD MTEXT blocks. XML reports cannot be placed in a drawing.
To place a pay item table in a drawing
1 Open a drawing in which pay items are attached to objects.
2 Click Analyze tab ➤ QTO panel ➤ Takeoff

.

3 In the Compute Quantity Takeoff dialog box:
■

Select the option for Report Type.

■

Select the options for Report Extents.

■

Select the options for Report Output.

■

Click Compute.

4 In the Quantity Takeoff Report dialog box, review the report in the text field.
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5 For report style sheet, from the drop-down list at the bottom of the Quantity Takeoff Report dialog box,
select:
■

Detailed Area (HTML).xsl, Detailed Count (HTML).xsl, or Detailed Linear (HTML).xsl for a detailed
Report Type table.

■

Summary (HTML).xsl for a summary Report Type table.

6 Click Draw.
7 In the drawing, select a location for the table.
8 Click Close in each dialog box.

Quick Reference
Ribbon
Analyze tab ➤ QTO panel ➤ Takeoff
Command
Takeoff
Dialog Boxes
Compute Quantity Takeoff (page 2563)
Quantity Takeoff Report (page 2594)

Saving Pay Item Reports in Various Formats
Apply style sheets to save your reports in various formats.
As required, save your pay item reports in various formats, using XSL style sheets, for example Detailed Area
(CSV).xsl, Detailed Area (HTML).xsl, or Detailed Area (TXT).xsl for detailed area reports.
To create a pay item report in CSV, HTML or TXT format
1 Open a drawing in which pay items are attached to objects.
2 Click Analyze tab ➤ QTO panel ➤ Takeoff

.

3 In the Compute Quantity Takeoff dialog box:
■

Select the option for Report Type.

■

Select the options for Report Extents.

■

Select the options for Report Output.

■

Click Compute.

4 In the Quantity Takeoff Report dialog box, review the report in the text field.
5 For report style sheet, from the drop-down list at the bottom of the Quantity Takeoff Report dialog box,
select:
■

Detailed Area (<file format>).xsl, Detailed Count (<file format>).xsl, or Detailed Linear (<file
format>).xsl for a detailed report.

■

Summary (<file format>).xsl for a summary report.
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6 Click Save As.
7 Save the report in the same folder as its parent drawing.
8 If required, you can save the report in any other format (CSV, HTML, TXT or XML).
NOTE If you select Detailed as Report Type in the Compute Quantity Takeoff dialog box, you can save the
report using any style sheet. If you select Summary as Report Type, you can save the report using any summary
style sheet.
9 Click Close in each dialog box.

Quick Reference
Ribbon
Analyze tab ➤ QTO panel ➤ Takeoff
Command
Takeoff
Dialog Boxes
Compute Quantity Takeoff (page 2563)
Quantity Takeoff Report (page 2594)

Exporting Quantity Takeoff Reports as TransXML
Use any of the XML style sheets to save your reports for export as TransXML.
All the (XML) style sheets included with AutoCAD Civil 3D save quantity takeoff reports according to
TransXML schema.
To export a pay item report as TransXML
1 Open a drawing in which pay items have been attached to objects.
2 Click Analyze tab ➤ QTO panel ➤ Takeoff

.

3 In the Compute Quantity Takeoff dialog box:
■

Select the option for Report Type.

■

Select the options for Report Extents.

■

Select the options for Report Output.

■

Click Compute.

4 In the Quantity Takeoff Report dialog box, review the report in the text field.
5 For report style sheet, from the drop-down list at the bottom of the Quantity Takeoff Report dialog box,
select:
■

Detailed (XML).xsl, for a detailed report.

■

Summary (XML).xsl for a summary report.

■

TransPortDesignInterface.xsl for either a detailed or summary report, depending on which Report
Type you select in the Compute Quantity Takeoff dialog box.
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6 Click Save As.
7 Save the report in the same folder as its parent drawing.
8 If required, you can save the report in any other format (CSV, HTML, or TXT).
NOTE If you select Detailed as Report Type in the Compute Quantity Takeoff dialog box, you can save the
report using any style sheet. If you select Summary as Report Type, you can save the report using
TransPortDesignInterface.xsl or any summary style sheet.
9 Click Close in each dialog box.

Quick Reference
Ribbon
Analyze tab ➤ QTO panel ➤ Takeoff
Command
Takeoff
Dialog Boxes
Compute Quantity Takeoff (page 2563)
Quantity Takeoff Report (page 2594)

Exporting Pay Item Information to Autodesk QTO
Prepare an Autodesk takeoff catalog, a 2D DWF and a 3D DWF to export pay item information to Autodesk
QTO.
After you export a takeoff catalog and two DWFs to Autodesk QTO, users of that application to apply pay
item information to their drawings.
To export an Autodesk Takeoff Catalog and DWFs for use in Autodesk QTO
1 Open a drawing in which pay items have been attached to objects.
2 Click Analyze tab ➤ QTO panel ➤ QTO Manager
3 In the QTO Manager vista, click

.

➤ Save As ➤ Autodesk Takeoff Catalog.

4 Save the ATT file to the same folder as the drawing.
5 Save a 2D and a 3D DWF from the drawing, to the same folder.
6 Export the DWFs and ATT to Autodesk QTO.

Quick Reference
Ribbon
Analyze tab ➤ QTO panel ➤ QTO Manager
Command
QTOManager
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Dialog Box
QTO Manager vista (page 2589)

Using Mass Haul Diagrams
Use mass haul diagrams to display earthwork volumes along an alignment, based on sectional volume
computation.
The use of mass haul (page 2778) diagrams helps designers and contractors understand where gross material
movements occur and as key indicators used to compare the economies of alternative designs. These diagrams
are typically presented along with profile views for design review. They are used to analyze the following
aspects of the design:
■

Distance over which the cut and fill will balance

■

Amount of material to be moved and the direction of movement

■

Identification of borrow pit (page 2769)s and dump site (page 2773)s

To generate mass haul diagrams, you need an alignment, a sample line group, and a list of materials.
For information about creating a material list, see Generating Material Lists (page 1282).

Mass Haul
Measure mass haul volumes and mark grade points, balance points, and free haul and overhaul volumes.
A mass haul (page 2778) diagram presents a graphical view of material moved in the proposed design site,
displaying balance point (page 2768)s, free haul (page 2774) and overhaul (page 2779) regions, and grade point (page
2775)s. Mass haul diagrams are graphed with stations (sample lines) along the x-axis and cumulative material
(typically earthworks) volume on the y-axis. The middle axis (zero cumulative volume) line is called the
balance line (page 2768). When the mass haul line (page 2778) rises, it indicates that a project is in a cut region
and when it descends, it is in a fill region. A mass haul region is marked with balance points and grade
points.
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Grade points (indicated by arrows and circles) in a mass haul diagram (above) and in
a profile view connected by lines

Free Haul and Overhaul
Represent free haul and overhaul volumes using grade point and balance point methods.
During project development, contractors and design engineers may try to balance the mass haul requirements
by considering free haul (page 2774) distances, any overhaul (page 2779), and the use of borrow pit (page 2769)s for
embankments and dump site (page 2773)s for extra excavated volumes, based on the economic haul limits
and the site conditions.
In AutoCAD Civil 3D, you can specify the free haul distance as required. You can also specify the location
of borrow pits and dump sites along the roadway, with assumed capacity of the borrow pits or dump sites.
There are two ways of representing free haul (and any overhaul) in mass haul diagrams in AutoCAD Civil
3D:
■

measured from grade point (page 2775)s

■

measured from balance point (page 2768)s

Measure from Grade Points
Represent free haul and overhaul from grade points along the mass haul line.

Grade Point Method: The arrows indicate free haul distance, The number (1) indicates
grade points. Freehaul volume is indicated in green (and by the grid between the
green areas and the balance line) and overhaul volume is indicated in red.
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From grade point (page 2775)s, a segment the length of the free haul distance, which is parallel to the balance
line (page 2768), is dropped so that the ends of the segment just touch the mass haul line (page 2778). The area
enclosed within the segment and the mass haul line represents the free haul volume. Further, perpendicular
lines from the ends of the segment are dropped so that they touch the balance line. The areas enclosed
within these lines, the balance line, and the mass haul line represent the overhaul volume.

Measure from Balance Points
Represent free haul and overhaul from balance points, where the mass haul line and balance line meet.

Balance Point Method: The arrows indicate free haul distance. The number (1) indicates
balance points. Freehaul volume is indicated in green and overhaul volume is indicated
in red.

In a mass haul diagram, the balance point (page 2768)s are located on the balance line, where the net volume
is zero. In the balance points method of measuring free haul, the mass haul line is duplicated and shifted
horizontally to the right (where the project transitions from cut to fill) or to the left (where the project
transitions from fill to cut) by the free haul distance. The area enclosed by the two mass haul lines on the
left if above the balance line, or on the right if below the balance line, represents the free haul volume. The
remaining intersecting area represents the overhaul.

Creating and Editing Mass Haul Diagrams
Create a mass haul diagram using the Create Mass Haul Diagram wizard, and edit the mass haul diagram’s
properties, styles, and settings.

Creating Mass Haul Diagrams
Create a mass haul diagram to display a partial or overall view of earthwork volumes.
Using the Create Mass Haul Diagram wizard (page 2564), you can create a mass haul diagram with a single
click, accepting the default settings for name, style, display, and balancing options. Later, you can change
the default settings in the Mass Haul Properties dialog box (page 2574). Alternatively, you can specify settings
in the wizard.
You must have a material list for the drawing before you can create a mass haul diagram. A mass haul diagram
(top) can be mapped directly to a profile view (bottom) created from the same alignment.
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For information about how to create a material list, see Generating Material Lists (page 1282).
To create a mass haul diagram
1 Click Analyze tab ➤ Volumes And Materials panel ➤ Mass Haul

.

The Create Mass Haul Diagram wizard (page 2564) is displayed.
2 On the General page (page 2564), do any of the following:
■

Specify the alignment from which the mass haul diagram will be created.

■

Specify the sample line group from which the mass haul diagram will be created.

■

Specify a mass haul view style.

■

To edit the mass haul view style, next to Mass Haul View Style, click
View Styles (page 1318).)

. (See Editing Mass Haul

3 On the Mass Haul Display Option page (page 2565), do any of the following:
■

Select a material list.

■

Select a material to display as mass haul line (Total Volume, Total Cut Volume, Total Fill Volume,
Total Unusable Volume, and any other material associated with the material list).

■

Specify a mass haul line style.

■

To edit the mass haul line style, next to Mass Haul Line Style, click
Styles (page 1317).)

. (See Editing Mass Haul Line

4 On the Balancing Options page (page 2566), specify a free haul distance, and the type, location, and
capacity of borrow pits and dump sites.
5 Click Create Diagram.
6 In the drawing, find a suitable location for the mass haul diagram. For ease of viewing, place the diagram
outside the surface boundary, and above or below any section or profile views. Click that location to
set the origin of the balance line at the left side of the mass haul diagram.
The mass haul diagram is displayed.

Quick Reference
Ribbon
Analyze tab ➤ Volumes And Materials panel ➤ Mass Haul
Menu
Sections menu ➤ Create Mass Haul Diagram
Command Line
CreateMassHaulDiagram
Wizard
Create Mass Haul Diagram (page 2564)
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Editing Mass Haul Properties
Edit mass haul properties to specify naming, description and other parameters for the mass haul lines and
views.

Editing Mass Haul Line Properties
Balance mass haul volumes by editing mass haul line properties.
Edit mass haul line properties to specify a new name or description for the mass haul line, to change the
free haul distance, and to add or remove borrow pits or dump sites.
To edit mass haul line properties
1 To select a mass haul line and open the Mass Haul Line Properties (page 2574) dialog box, do either of
the following:
■

In Toolspace, on the Prospector tab, expand the Sites collection ➤ <site name> ➤ Alignments
collection ➤ <alignment name> ➤ Sample Line Groups collection ➤ <sample line group name>
➤ Mass Haul Lines collection. Right-click the mass haul line whose properties you want to edit.
Click Properties.

■

In the active viewport, select the mass haul line whose properties you want to edit. Right-click and
click Mass Haul Line Properties.

2 On the Information tab of the Mass Haul Line Properties dialog box, do any of the following:
■

Change the name of the current mass haul line.

■

Enter a description of the current mass haul line.

■

Specify the mass haul line style.

■

To edit the current mass haul line style, under Object Style, click
Editing Mass Haul Line Styles (page 1317).

. For more information, see

3 On the Balancing Options tab, you can do any of the following:
■

Specify a new free haul distance.

■

Add or remove borrow pits and dump sites, specifying their type, location and capacity.

4 Click OK.

Quick Reference
Toolspace Shortcut Menu
Prospector tab ➤ <drawing name> ➤ Sites ➤ <site name> ➤ Alignments ➤ <alignment name> ➤
Sample Line Groups ➤ <sample line group name> ➤ Mass Haul Lines ➤ right-click <mass haul line
name>. Click Properties.
Dialog Box
Mass Haul Line Properties (page 2574)

Editing Mass Haul View Properties
Edit mass haul view properties to specify a new name or description.
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To edit mass haul view properties
1 To select a mass haul view and open the Mass Haul View Properties dialog box (page 2578), do either of
the following:
■

In Toolspace, on the Prospector tab, expand the Sites collection ➤ <site name> ➤ Alignments
collection ➤ <alignment name> ➤ Sample Line Groups collection ➤ <sample line group name>
➤ Mass Haul Views collection. Right-click the mass haul view whose properties you want to edit.
Click Properties.

■

In the active viewport, select the mass haul view whose properties you want to edit. Right-click and
click Mass Haul View Properties.

2 On the Information tab of the Mass Haul View Properties dialog box, you can do any of the following:
■

Change the name of the current mass haul view.

■

Enter a description of the current mass haul view.

■

To edit the current mass haul view style, under Object Style, click
Editing Mass Haul View Styles (page 1318).)

. (For more information, see

3 Click OK.

Quick Reference
Toolspace Shortcut Menu
Prospector tab ➤ <drawing name> ➤ Sites ➤ <site name> ➤ Alignments ➤ <alignment name> ➤
Sample Line Groups ➤ <sample line group name> ➤ Mass Haul Views ➤ right-click <mass haul view
name>. Click Properties.
Dialog Box
Mass Haul View Properties (page 2578)

Editing Mass Haul Styles
Edit mass haul style to improve the display of the mass haul line and the mass haul view.

Editing Mass Haul Line Styles
Edit the mass haul line styles to improve the display of the mass haul and balance lines, and free haul and
overhaul volumes.
To edit mass haul line styles
1 In the active viewport, select the mass haul line whose styles you want to edit. Right-click and click
Edit Mass Haul Line Style.
2 On the Free Haul tab (page 2577) of the Mass Haul Line Style dialog box, specify how you want to show
free haul in the mass haul diagram: measured from grade points (page 1313) or measured from balance
point (page 1314).
3 On the Display tab (page 2577), do any of the following:
■

In Component Display, set visibility and color for the Mass Haul Line, Free Haul Line, Free Haul
Area Hatch, and Overhaul Area Hatch.
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■

In Component Hatch Display, set the pattern, angle and scale of the hatching for Free Haul Area
Hatch, and Overhaul Area Hatch.

4 On the Information and Summary tabs, set administrative information.
5 Click OK to save the edits to the mass haul line styles.

Quick Reference
Toolspace Shortcut Menu
Prospector tab ➤ <drawing name> ➤ Sites ➤ <site name> ➤ Alignments ➤ <alignment name> ➤
Sample Line Groups ➤ <sample line group name> ➤ Mass Haul Lines ➤ right-click <mass haul line
name>. Click Properties. In the Mass Haul Line Properties dialog box, Information tab, under Object Style,
click

.

Dialog Box
Mass Haul Line Style (page 2576)

Editing Mass Haul View Styles
Edit the mass haul view styles to improve the display of the mass haul graph and its annotation.
To edit mass haul view styles
1 In the active viewport, select the mass haul view whose styles you want to edit. Right-click and click
Edit Mass Haul View Style.
2 On the Information tab of the Mass Haul View Style dialog box, specify administrative information,
such as the name of the style, and a description of the style.
3 On the Graph tab, specify the vertical and horizontal scale, and the view direction.
4 On the Grid tab (page 2580), specify how you want to show the grid.
5 On the Title Annotation tab, specify attributes of the text used to annotate the graph.
6 On the Horizontal Axes and Vertical Axes tabs, specify attributes of the major and minor ticks in the
graph.
7 On the Display tab (page 2586), in Component Display, set the visibility and color for the graph.
8 In the Summary tab, modify information specified on other tabs.
9 Click OK to save the edits to the mass haul view styles.

Quick Reference
Toolspace Shortcut Menu
Prospector tab ➤ <drawing name> ➤ Sites ➤ <site name> ➤ Alignments ➤ <alignment name> ➤
Sample Line Groups ➤ <sample line group name> ➤ Mass Haul Views ➤ right-click <mass haul view
name>. Click Properties. In the Mass Haul View Properties dialog box, Information tab, under Object Style,
click

.
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Dialog Box
Mass Haul View Style (page 2579)

Editing Mass Haul Settings
Use mass haul settings to specify the default style and name format settings for mass haul lines and views
and the default behavior for mass haul-related commands.
Settings are handled in a standard way throughout AutoCAD Civil 3D. Access settings using the Toolspace
Settings tree. Control settings at three levels: the drawing level, the object collection (feature) level, and the
command level. For more information, see Understanding Settings (page 77).
On the Toolspace Settings trees, use the Mass Haul Line and Mass Haul View collection shortcut menus to
establish defaults for all of the mass haul-related features and commands. You can change mass haul lineand mass haul view-specific settings at this level, or you can override the drawing ambient settings.

Editing Mass Haul Line Settings
Edit mass haul line style settings to specify defaults for new mass haul diagrams.
To create a new mass haul line style
1 In Toolspace, in the Settings tree, under Mass Haul Line, expand the Mass Haul Line Style collection.
2 For the Mass Haul Line Style collection, do one of the following:
■

Right-click the collection. Click New.

■

Right-click the existing style to use as a template. Click Copy.

3 In the Mass Haul Line Style dialog box (page 2576), enter or change the name of the style and other
settings as required.
4 Click OK.
To edit a mass haul line style
1 In Toolspace, in the Settings tree, under Mass Haul Line, expand the Mass Haul Line Style collection.
2 Right-click the style you want to edit. Click Edit.
3 In the Mass Haul Line Style dialog box (page 2576), change the Free Haul or Display settings as required.
4 Click OK.

Quick Reference
Toolspace Shortcut Menu
Create: Settings tab: right-click Mass Haul Line collection ➤ New
Copy: Settings tab ➤ Mass Haul Line collection ➤ Mass Haul Line Styles collection: right-click <style
name> ➤ Copy
Edit: Settings tab ➤ Mass Haul Line collection ➤ Mass Haul Line Styles collection: right-click <style
name> ➤ Edit
Dialog Box
Edit Feature Settings - Mass Haul Line (page 2568)
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Editing Mass Haul View Settings
Edit mass haul view settings to specify default graph style and command settings for new mass haul diagrams.
To create a new mass haul view style
1 In Toolspace, in the Settings tree, under Mass Haul View, expand the Mass Haul View Style collection.
2 For the Mass Haul View Style collection, do one of the following:
■

Right-click the collection. Click New.

■

Right-click the existing style to use as a template. Click Copy.

3 In the Mass Haul View Style dialog box (page 2579), enter or change the name of the style and other
settings as required.
4 Click OK.
To edit a mass haul view style
1 In Toolspace, in the Settings tree, under Mass Haul View, expand the Mass Haul View Style collection.
2 Right-click the style you want to edit. Click Edit.
3 In the Mass Haul View Style dialog box (page 2579), change the Graph, Grid, Title Annotation, Horizontal
Axes, Vertical Axes, or Display settings as required.
4 Click OK.
To edit mass haul view command settings
1 In Toolspace, in the Settings tree, under Mass Haul View, expand the Commands collection.
2 Right-click CreateMassHaulDiagram. Click Edit Command Settings.
3 In the Edit Command Settings - CreateMassHaulDiagram dialog box (page 2568), expand the Mass Haul
Creation tree.
4 Specify the Analyze Free Haul value as True.
5 Specify the Free Haul Distance value or leave the default setting.
6 Specify the Borrow Pit Capacity value or leave the default setting.
7 Specify the Dump Site Capacity value or leave the default setting.
8 Click OK.

Quick Reference
Toolspace Shortcut Menu
Create style: Settings tab: right-click Mass Haul View collection ➤ New
Copy style: Settings tab ➤ Mass Haul View collection ➤ Mass Haul View Styles collection: right-click
<style name> ➤ Copy
Edit style: Settings tab ➤ Mass Haul View collection ➤ Mass Haul View Styles collection: right-click <style
name> ➤ Edit
Edit command settings: Settings tab ➤ Mass Haul View collection ➤ Commands collection: right-click
CreateMassHaulDiagram ➤ Edit Command Settings
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Dialog Boxes
Mass Haul View Style (page 2579)
Edit Settings - Mass Haul View (page 2568)

Material Analysis Command Reference
The AutoCAD Civil 3D commands for material analysis-related functionality and a brief description of their
functionality.
Command

Description

AddMaterialVolumeTable

Creates a material volume table (page 1290)

AddTotalVolumeTable

Creates a total volume or earthworks table (page 1290)

ComputeMaterials

Computes material sets by processing sections in a
selected sample line group (page 1282)

CreateMassHaulDiagram

Creates a mass haul diagram that remains dynamic
with the corridor model and persists in the drawing
(page 1314)

EditBalancingOptions

Edits free haul distances and dump site and borrow
pit locations (page 1319)

EditMassHaulLineStyle

Edits free haul type and free haul line component
appearance (page 1317)

GenerateQuantitiesReport

Generates a volume report for a group of sample lines
(page 1290)

QTOManager

Manages pay items to analyze material quantities
(page 1295)

Takeoff

Computes quantity takeoff using pay items (page 1306)
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Use AutoCAD Civil 3D pipe network features to draw 2D and 3D models of utility systems, such as storm sewers, sanitary
sewers, and more.
You can create, edit, and delete pipe networks in plan view. You can also display pipe network parts in profiles and section
views. Changes made to pipe networks in plan view are dynamically updated in any profile and section views.
Style-based rendering and labeling capabilities let you quickly create pipe networks with meaningful visual effects and
data. For example, you can use many different styles to represent two-dimensional pipe networks in construction documents.
You can also use visual rendering features to add realistic looking effects to three-dimensional pipe networks. Labeling
features let you automatically add labels to identify specific types of pipes and structures within a pipe network.
AutoCAD Civil 3D also has interference checking features let you quickly identify areas where pipes or structures physically
collide, or are too close to one another.
You can also import or export pipe network data using Autodesk LandXML format, or analyze pipe network data through
an API interface or with support from external, third-party analysis programs.
AutoCAD Civil 3D includes extension applications that enable you to perform a variety of hydraulics and hydrology tasks
on pipe network data. For more information, see Hydraulics and Hydrology Feature Overview (page 1331).
Pipe Networks Workflow (page 57)
Pipe Networks Best Practices

Understanding Pipe Networks
In AutoCAD Civil 3D, a pipe network object serves as a container for managing pipe objects and structure
objects that form a pipe network.
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A pipe network can contain pipes only, structures only, or, more commonly, both pipes and structures. A
part catalog provides access to pipe network items, such as circular, elliptical, or rectangular pipes, manholes,
catch basins, and headwalls, and more.
After you have added a pipe network to your drawing, you can edit it in the following ways:
■

Add, delete, change, swap, or move pipes or structures

■

Resize pipes and structures

■

Move a pipe network

■

Create a parts list comprised of only the part catalog items needed for a particular project or network

■

Edit elevations and sizes numerically or graphically

■

Add, change, or delete labels on pipes, a span of connected pipes, structures, or on the entire pipe network

■

Change the style of any pipe or structure in the pipe network

■

Use styles to display pipes and structures according to their true shapes, or choose a symbolic
representation, such as a block, for a structure

After the pipe network is created, you can extract a variety of data using LandXML export. For information,
see LandXML Import and Export (page 1875).
It is also possible to perform quantity take-off tasks on pipe networks by assigning pay items to individual
parts in a pipe network parts list. For more information, see Using Pay Items to Analyze Quantities (page
1293).
Like other AutoCAD Civil 3D objects, display styles for pipe network objects are based on styles assigned to
the objects: specifically, the pipe objects and structure objects. Before creating pipe networks, you should
be familiar with both creating and managing styles (page 66) and command settings (page 114).

The Pipe Network Object
A pipe network object manages a collection of pipe objects and structure objects that are associated with
each other to represent a pipe system.
Typically, the pipes and structures are connected to each other, forming a single pipe run or pipe network.
The pipe and structure objects in a pipe network can be associated with a referenced alignment and or a
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surface, which provide them with station offset and elevation data. Each part in a pipe network can reference
any given surface or alignment in the drawing.
The following sections describe the components that can comprise a pipe network:

Pipe Network
The pipe network object is used as the container object to associate pipes and structures that are part of the
same pipe run or pipe network. A pipe network typically contains pipe objects and structure objects. Pipe
network object names are displayed in the Prospector tree and in the Prospector list view.

Pipe
A pipe object is a drawing shape that represents straight or curved pipes used in utility networks, such as
sewer and irrigation systems. In a drawing, the three-dimensional pipe shape is defined by: 1) the
two-dimensional Part Shape (circular, elliptical, egg-shaped, or rectangular) of the pipe part that is selected
from the part catalog; and 2) by specifying a linear path (for straight piped) or a curved path (for curved
piped). Object names for pipes are not displayed in the Prospector tree. They are, however, displayed in the
Prospector list view when you click Pipes under a pipe network in the Prospector tree.

Structure
A structure object is a drawing shape that is used to represent items, such as manholes, catch basins, and
headwalls, used in utility networks. Structure shapes are inherently more complex than pipe shapes. In a
drawing, the three-dimensional structure shape is defined by the definition of the structure part that is
selected from the part catalog. Like pipes, object names for structures are not displayed in the Prospector
tree. They are, however, displayed in the Prospector list view when you click Structures under a pipe network
in the Prospector tree.

Null Structure
A null structure object is a special type of structure object that is inserted automatically when you connect
a pipe directly to another pipe, with no structure shape between the two pipes. Just like other types of
structure objects, object names for null structures are not displayed in the Prospector tree, but are displayed
in the Prospector list view. You can assign a style to null structures so that they are not visible in the drawing.

Part Catalog and Parts List
AutoCAD Civil 3D comes with a pipe network part catalog that contains a variety of pipe and structure
shapes organized into part families and part sizes. Since the part catalog contains many items, you can create
a parts list containing only the parts (pipes and structures) that you will use for a particular pipe network.
Using a parts list saves you from having to navigate through the entire part catalog to find a desired part.
For more information, see Part Catalog and Parts Lists (page 1380).

Pipe Network Viewports
This illustration displays three viewports: the pipe network in plan view, the profile view of some of the
network pipes and structures, and the same parts in a section view.
The left pane shows a pipe network segment made up of two manhole structures connected by pipes. The
network parts have been placed at a specified offset from an alignment, and are drawn in a profile view
created using the same alignment (upper-right pane). A sample line placed at station 7+71 was used to create
a section view (lower-right pane) that shows a cross-section view of the pipe network parts located at the
station.
You can edit the positions of the pipe network parts manually by using editing grips in either plan, profile,
or section view, or by directly editing their properties.
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Layout, profile, and section views of a pipe network segment

3D view of pipe network segment

For overview information about AutoCAD Civil 3D objects, see Understanding Objects (page 63).

Pipe Network Styles and Display
Specify a variety of style and display characteristics for displaying pipes and structures in plan view, profile
views, and section views.
When you first create a pipe network, the pipe and structure objects get their default style, render material,
and rules from definitions in their referenced parts list.
After the pipe and structures are inserted into the drawing, the styles and rule settings for the pipe or structure
object can be changed using either the Pipe Properties or the Structure Properties dialog box. You can also
use the Pipe Network Vistas (page 2302) view to edit style or property values.
If you choose to run interference checks on pipe networks, you can set styles for displaying interferences.

1328 | Chapter 29 Pipe Networks

The following table describes the ways you can specify styles for pipes and structures in a pipe network:
To specify this style...

use the...

Default object style, rules, and render
material for pipe and structure objects

Parts List definition. Specifically, you use the
Pipes tab (page 2272) or the Structures tab (page
2272) of the Network Parts List dialog box.

Label style for pipe network object
during creation

Create Pipe Network By Layout Dialog Box
(page 2259)

Object style, rules, or render material
for pipe and structure objects already
in a drawing

Pipe Properties Dialog Box (page 2275) or Structure Properties Dialog Box (page 2288)

Display style for pipes or structures
displayed in plan, profile, and section
views already in a drawing

Pipe Style Dialog Box (page 2281) or Structure
Style Dialog Box (page 2294). You can also override styles in Profile View Properties dialog box.

Display style for pipe network interferences

Interference Style Dialog Box (page 2312)

In addition to specifying and editing object styles, display styles, rules, and render material, you can also
add labels to pipe and structure objects either during creation or after the objects have been added to a
drawing. For more information about pipe and structure labels, see Labeling Pipe Networks (page 1404).
For more information about styles, see Object and Label Styles (page 66).

Pipe Networks Collection (Prospector Tab)
Use the Pipe Networks collection in the Prospector tree to access the pipe networks and interference checks
in a drawing or a project.
As pipe network objects are created, they are displayed in the Networks collection under the Pipe Networks
collection. Expand the Networks collection to view the names of the pipe networks. Click Pipes or Structures
to display a tabular list of the pipe network object informations in the Prospector list view. For more
information, see The Toolspace Item View (page 99).
You can also view interference check results by expanding the Interference Checks collection. For more
information, see Checking for Interferences (page 1369).

Pipe Network Collection (Settings Tab)
Use the Pipe Networks collection in the Settings tree to manage pipe network settings, parts lists, interference
styles, and command settings.
The Pipe Network object does not have any display styles. However, elements within the Pipe Network
object, such as pipe objects and structure objects, have their own display styles. When you insert a pipe or
structure object into a drawing, its default style comes from the part’s style definition in the parts list. After
the part is inserted into the drawing, you can change its style settings.
Right-click the Pipe Networks collection to do the following:
■

Edit the pipe network feature settings. (page 1343)

■

Refresh the display of the settings tree.
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Expand the Pipe Networks collection to display and edit the command settings that are available for pipe
networks.

Pipe Collection (Settings Tab)
Use the Pipe collection in the Settings tree to manage pipe styles, pipe rule sets, pipe label styles, and pipe
table styles.
For information about ...

See...

pipe styles

Pipe Network Styles and Display (page 1328)

pipe rule sets

Part Rules (page 1390)

pipe label styles

Labeling Pipe Networks (page 1404)

pipe table styles

Adding Pipe Tables (page 1414)

Structure Collection (Settings Tab)
Use the Structure collection in the Settings tree to manage structure styles, structure rule set styles, structure
label styles, and structure table styles.
For information about ...

See...

structure styles

Pipe Network Styles and Display (page 1328)

structure rule sets

Part Rules (page 1390)

structure label styles

Labeling Pipe Networks (page 1404)

structure table styles

Adding Structure Tables (page 1415)

Common Part Terms
This section provides descriptions for some terms that are commonly used when referring to pipe network
parts.

Structure Terms
■

Rim. The top elevation of a manhole or catch basin (junction) structure.

■

Frame. The support for the cover on a manhole or grate for a catch basin. The top elevation of the frame,
cover, and grate typically coincides with the insert (rim) elevation.

■

Cover. The top access cover of a manhole, used for servicing or inspecting the manhole. Covers are
typically circular in shape, but they can also be triangular, so that they do not fall into the manhole
when removed. The cover sits in the frame and is usually constructed of cast iron.

■

Grate. The top opening of a catch basin that typically contains numerous openings to allow surface water
entry into the structure. The grate sits in the frame and is usually constructed of cast iron. Grates can be
various shapes but are typically circular or square.

■

Sump and sump depth. Sump refers to the bottom area or chamber on the inside of a junction structure,
such as a catch basin. The sump area is sometimes used as a reservoir to catch debris. Sump depth refers
to the distance from the bottom of the inside of the structure to the lowest invert of all pipes connected
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to it. The sump depth for a particular type of structure can vary according to design requirements.
Manholes typically have no sump depth.
The following illustration shows the locations of components on a typical junction structure.

Pipe Terms
■

Invert. The elevation of the inside bottom of a pipe. Also referred to as flowline.

■

Crown. The elevation of the inside top of a pipe.

■

Pipe centerline elevation. The elevation of the centerline of a pipe.

■

Cover or Depth. Refers to the depth of the material above the topmost outer part of a pipe.

■

Slope. When slope is used to refer to the slope of a pipe, it is a measure of steepness. For pipes, the slope
is defined by rise (or fall) over run, where rise is the difference in elevation along a run of pipe length,
measured horizontally. Slope is typically represented in percent. For example, a slope of pipe at 2% means
that for every 100 feet of horizontal length of pipe, the pipe rises 2 feet. In AutoCAD Civil 3D, the slope
can be represented in a variety of ways in dialog boxes and in labels in the drawing.

Hydraulics and Hydrology Feature Overview
External applications can be used to add hydraulics and hydrology property information to AutoCAD Civil
3D pipe networks. It is also possible to add hydraulics and hydrology property information directly to
AutoCAD Civil 3D pipe networks using the Pipe Network Vista (Panorama window). For more information,
see Adding Hydraulic Property Data to AutoCAD Civil 3D Pipe Networks (page 1424).
For more information about using hydraulics and hydrology features with AutoCAD Civil 3D, see Using
Hydraulics and Hydrology Features (page 1417).
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AutoCAD Civil 3D includes three software application extensions that allow you to perform a variety of
storm water management tasks, including storm sewer design, watershed analysis, detention pond modeling,
and culvert, channel, and inlet analysis.
The extensions are typically installed by default when you install AutoCAD Civil 3D. If you chose not to
install them when you first installed AutoCAD Civil 3D, they can be installed later using Add or Remove
Programs from the Control Panel. For more information, see Add or Remove Features in the Stand-alone
Installation Guide.
Once installed, you can access the extensions from the ribbon, or by typing commands into the command
line. For more information, see Launching the Hydraflow Extensions (page 1421).
The following table describes the hydraulics and hydrology extensions available with AutoCAD Civil 3D.
Extension

Description

Hydraflow Storm Sewers Extension

Enables you to perform storm sewer design and analysis on
pipe network models. It is designed primarily for hydraulic and
hydrologic analysis of simple and complex storm sewer networks
with pavement drainage and inlet analysis. It can also be used
as to determine the hydraulic grade line in an existing system,
or for planning or designing new systems. Using Storm Sewers,
you can add hydraulic information, such as hydraulic grade
lines and energy grade lines, to AutoCAD Civil 3D pipe network
models. For more information, see Moving Pipe Network Data
Between AutoCAD Civil 3D and Storm Sewers (page 1417) and
Adding Hydraulic Property Data to AutoCAD Civil 3D Pipe
Networks (page 1424).

Hydraflow Hydrographs Extension

Used for detention pond design and modeling of simple or
complex watersheds using the SCS and/or Rational methods.
This extension lets you perform a host of functions, including
hydrograph combining, channel reach and pond routing, and
hydrograph diverting.

Hydraflow Express Extension

Provides a collection of calculators for solving hydraulics and
hydrology tasks on culverts, channels, inlets, hydrology, and
weirs. You can model and design culverts with circular, box,
elliptical, and arch shapes; compute normal-depth rating curves
for rectangular, trapezoidal, triangular, compound gutter, circular, and user-defined channel shapes. You can also calculate
hydraulics for six inlet types, including curb, grate, combination,
drop curb, drop grate, and slotted. This extension supports
SCS, Rational, and Modified Rational methods for computing
a single hydrograph.

For information about using AutoCAD Civil 3D to perform hydraulics and hydrology tasks, see Using
Hydraulics and Hydrology Features (page 1417).

Creating Pipe Networks
There are several ways you can create pipe networks.
For example, you can create a pipe network using the Network Layout Tools toolbar, or you can select an
existing polyline or feature line in a drawing and create a pipe network from it. You can also use import
features to import existing pipe networks into your drawing.
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You can also create a new network by splitting an existing pipe network into two. For more information,
see Splitting Pipe Networks (page 1358).

Importing Pipe Data
The following table describes the import features available for pipe networks.
Command

Description

Import Data From Land Desktop

You can use the Import Data From Land Desktop
command (ImportLDTData) to import pipe run
data from AutoCAD Land Desktop into AutoCAD
Civil 3D. When you import pipe data, each continuous pipe run in AutoCAD Land Desktop is
imported as a new, single pipe network object in
AutoCAD Civil 3D. For more information, see
Importing LandXML Drawing Data (page 1883).

LandXML Import

You can export pipe run data from AutoCAD Land
Desktop using the LandXML Export command
(LandXMLOut) and then import it into AutoCAD
Civil 3D using the LandXML Import command
(LandXMLIn). For more information about these
commands, see LandXML Import and Export
(page 1875).

ImportStormSewerData

Using this command, you can create AutoCAD
Civil 3D pipe networks by importing pipe networks that were created in the Storm Sewers Extension from an .stm file. For more information,
see Importing Pipe Network Data from an .stm
File (page 1422).

Before importing Land Desktop pipe run data, make sure the Parts List you associate with the pipe network
has part sizes that make sense for the pipe run you will be importing. See Part Catalog and Parts Lists (page
1380) for more information.

Managing, Displaying, and Customizing Pipe Networks
All pipe networks, once created, are managed in the same way, regardless of the method used to create them.
All pipe networks are listed in the Pipe Networks ➤ Networks collection in the Prospector tree.
Before creating a pipe network, it can be useful to first create the underlying data used by the pipe network,
such as surfaces, alignments, profiles, section views, and your own custom parts lists. However, you do not
have to have these components in place to create a pipe network.
For information about creating...

See...

Surfaces

Creating Surfaces (page 648)

Alignments

Creating Alignments (page 948)

Profiles

Creating Layout Profiles (page 1143)

Section Views

Creating Section Views (page 1258)

Parts Lists

Part Catalog and Parts Lists (page 1380)
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When you create a pipe network, the default settings come from the selections you make in the Create Pipe
Network dialog box, and from the part definitions specified in the part catalog. After the pipe and structure
objects are in your drawing, you can change many of the settings for any new parts created in the network.
For information about how to change pipe network default settings, see Changing Pipe Network Default
Style Settings (page 1345).

Creating a Pipe Network Using the Layout Tools
You can create a pipe network using the Network Layout Tools.
To automatically reference station and elevation data for the pipe network, you can associate the pipe
network with an alignment and a surface.
You can also set label styles and specify automatic labeling as new parts are created. After making these
choices or accepting the defaults, you can use the Network Layout Tools to draw the pipe network.
To create a pipe network using the layout tools
1 Click Home tab ➤ Create Design panel ➤ Pipe Network drop-down ➤ Pipe Network Creation Tools
, or in the Prospector tree, expand the Pipe Networks collection, then right-click the Networks collection,
and click Create Pipe Network By Layout.
2 In the Create Network (page 2259) dialog box, in the Network Name field, enter a name for the pipe
network.
To name the pipe network, select a default name from the naming template, or enter a new name. For
more information, see Name Template Dialog Box (page 2022).
3 In the Network Description field, enter an optional text description for this pipe network.
4 In the Network Parts List field, select a parts list or accept the default parts list for this pipe network.
For more information, see Part Catalog and Parts Lists (page 1380).
5 To view or change the default layers that will be assigned to various pipe network parts as they are
created, click Layers to open the Network Layers (page 2301) dialog box.
6 To reference a surface and/or an alignment, select the item from the list, or click to select a surface
and/or alignment in the drawing.
7 Optionally, you may select label styles for pipes and structures added to the pipe network. When <none>
is specified, no labels are added to the items, but you can add labels later if desired. See Labeling Pipe
Networks (page 1404) for more information.
8 Click OK in the Create Pipe Network dialog box. The Network Layout Tools toolbar is displayed, and
the pipe network name is displayed in the Pipe Networks collection on the Prospector tab.
9 On the Network Layout Tools toolbar, select the desired parts (pipes and structures) in the Pipe List and
Structure List. For example, select 48-inch Concentric Catch Basin for a structure, and 12-inch Concrete
Pipe 1 US Imperial for a pipe. For more information, see Part Catalog and Parts Lists (page 1380).
10 Select the types of pipe network objects you want to insert by clicking the Down Arrow button next to
Draw Pipes And Structures and selecting one of the following:
■

Pipes and Structures. Inserts pipes and structures during the same command operation. This is
the default command when creating a new pipe network.

■

Pipes Only. Inserts just one or more pipes (without inserting structures) into the pipe network.

■

Structures Only. Inserts just one or more structures into the pipe network, without inserting
any pipes.
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Pipes and Structures is the default active layout command. The initial prompt (by default) upon entering
the layout command is Specify the structure insertion point:
Upon reopening the layout toolbar, the default command is the last command that was used.
11 Click the Toggle Upslope/Downslope button to set the direction of the pipe networks part(s) to either
a positive slope value or direction (upslope) or a negative slope value or direction (downslope). This
button acts as a toggle. Downslope is the default. When the downslope

icon is displayed, each

new pipe that is inserted will slope downstream from the previous part. When the upslope
is displayed, each new pipe inserted will slope upstream from the previous part.

icon

12 Begin drawing the pipe network by specifying the insertion point for the first part (pipe or structure)
of the pipe network.
NOTE If you are in Draw Pipes And Structures mode, the first click defines the first structure insertion point,
as well as the starting point of the first pipe object. The second click specifies the end of the first pipe object,
and inserts a new structure object connected to that pipe. Subsequent clicks specify insertion points for
subsequent pipes and structures until you end the command by pressing Enter. If you are in Draw Pipes Only
mode, each click specifies the insertion point for a pipe end (a pipe start point or end point). If you are in
Draw Structures Only mode, each click specifies the insertion point for a structure.
13 Specify the next insertion point in the drawing.
14 When you finish drawing the pipe network, press Enter to end the command.
After you create a pipe network, you may want to refine parts of it. For example, you may want to add a
new pipe or structure, remove parts, move parts, or add labels. For information, see Editing Pipe Networks
(page 1345).

Quick Reference
Ribbon
Home tab ➤ Create Design panel ➤ Pipe Network drop-down ➤ Pipe Network Creation Tools
Menu
Pipes menu ➤ Create Pipe Network By Layout
Command Line
CreateNetwork
Dialog Box
CreateNetwork (page 2259)

Creating Pipe Networks from Objects
You can create pipe networks from existing objects in your drawing.
Using this method, you can automatically create a pipe network from entities such as lines, arcs, 2D and 3D
polylines, feature lines, or alignments.
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The following table lists the types of entities you can use to create pipe networks:
Entity

Description

Line

Creates a pipe network from a line that you selected. The pipe network is inserted as a straight pipe
with structures at each end.

2D polyline

Creates a pipe network from lightweight or
heavyweight 2D polylines.

2D spline polyline

Creates a series of straight line segments using fit
points to define pipe endpoints and structure
locations. For more information about fit points,
see the AutoCAD Help.

3D polyline

Creates a pipe network using vertices in 3D to
define pipe endpoints and structure locations.

Arc

Creates a pipe network from an arc that you selected. The pipe network is inserted as a curved pipe
with structures at each end.

Feature line

Creates a pipe network from a feature line.

Alignment

Creates a pipe network from an alignment.

You can select objects in the current drawing or from an Xref. You can create a pipe network that includes
the types of pipes and structures you specify.
This method of creating a pipe network uses the Pipes and Structures insertion method. You cannot use the
Pipes Only or Structures Only insertion mode with this command. If you want to create a single pipe, or a
single structure using this command, create the pipe network with pipes and structures, and then delete the
desired parts.

Using Vertex Elevations
For 3D entity types, you can select the Use Vertex Elevations option on the Create Pipe Network From Object
dialog box. When this option is selected, the elevations of any vertices along the selected entity are used to
set the elevations of the pipes created in the network. For 3D entity types, this option determines if the 3D
vertex elevations are honored by the pipes created. When checking this option, rules are not applied as they
would likely be in conflict with the vertex elevations.
By specifying the Vertex Elevation Reference, you choose the location on the pipe where the vertex elevation
is located. The following options are available: Outside Top, Crown, Centerline, Invert, or Outside Bottom.
The default is the pipe centerline.

Vertex Elevation
Reference =
Outside Top
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To create a pipe network from an object
1 Click Home tab ➤ Create Design panel ➤ Pipe Network drop-down ➤ Create Pipe Network From Object
.
2 In the drawing, select the object.
NOTE You can enter Xref to select an object from an Xref.
You may be prompted to reverse flow direction. Press Enter or click OK to keep the current flow direction.
Click Reverse to change the current flow direction. Flow direction arrows indicate the direction of the
flow.
3 In the Create Pipe Network From Object (page 2260) dialog box, specify a name for the pipe network.
4 In the Description field, enter an optional description for the pipe network.
5 In the Network Parts List field, select a parts list or accept the default parts list for this pipe network.
For more information, see Part Catalog and Parts Lists (page 1380).
6 In both the Pipe To Create and Structure To Create fields, select the types of pipes and structures to be
used.
NOTE You must select both a pipe and a structure type. After creating the pipe network, if desired, you can
delete parts you want removed.
7 To view or change the default layers that will be assigned to various pipe network parts, click Layers to
open the Pipe Network Layers (page 2301) dialog box.
8 To reference a surface and/or an alignment, select the item in the list, or click to select a surface and/or
alignment in the drawing.
9 If you want the originally selected object to be removed from the drawing automatically, clear the Erase
Existing Entity check box.
10 Select the Use Vertex Elevations check box if you want to use the elevations of any vertices along the
selected entity to set the elevations of the pipes created in the network.
NOTE For 3D entity types, this option determines if the 3D vertex elevations are honored by the pipes
created. When checking this option, rules are not applied as they would likely be in conflict with the vertex
elevations.
11 If you selected the Use Vertex Elevations option, specify a Vertex Elevation Reference (Outside Top,
Crown, Centerline, Invert, or Outside Bottom).
12 Click OK in the Create Pipe Network From Object dialog box.
The new pipe network is displayed in the drawing, and the pipe network name is displayed in the Pipe
Networks collection on the Prospector tab.

Quick Reference
Ribbon
Home tab ➤ Create Design panel ➤ Pipe Network drop-down ➤ Create Pipe Network From Object
Menu
Pipes menu ➤ Create Pipe Network From Object
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Command Line
CreateNetworkFromObject
Dialog Box
Create Network From ObjectCreate Pipe Network From Object (page 2260)

Creating Alignments from Pipe Network Parts
You can use the Create Alignment From Network Parts command to create an alignment from existing pipe
network parts.
Using this method, you can automatically create alignment objects from existing pipe network parts (pipes
and or structures) in your drawing.
You can also automatically create a profile and/or profile view showing the parts when you create the
alignment.
When you use this command, the new alignment is displayed in the drawing and in the top-level Alignments
collection or specified Site on the Prospector tab. The pipe network parts you selected to create the alignment
are unaffected by the creation of the alignment.
To create an alignment from pipe network parts
1 Click Home tab ➤ Create Design panel ➤ Alignment drop-down ➤ Create Alignment From Network
Parts
2 Select the first part (pipe or structure) to be used as the starting point for the alignment.
3 To select the end point of the alignment, do one of the following:
■

Select the next connected pipe network part to create a path for the alignment. You can continue
selecting consecutive parts to define the path for the alignment.

■

You can select the end part in a group of consecutive parts.

■

To select parts along an ambiguous path (for example, when laterals exist in the path), select the
desired parts to create the path defining the alignment.

■

Press Ctrl+Z to undo the previous path specified.

4 Press Enter after you have selected the desired parts (defining the path for the alignment).
5 In the Create Alignment From Network (page 2261) dialog box, specify a Site or accept the default <None>.
See Alignment and Site Interaction (page 781) for more information.
6 Enter a unique name for the alignment.
7 Enter an optional description for the alignment.
8 Specify an alignment style or accept the default style.
9 Specify the object layer settings.
10 Specify an alignment label set or accept the default label set.
11 Optionally, click Create Profile And Profile View to create a profile and a profile view from this alignment.
12 Click OK.
13 If you selected Create Profile And Profile View, the Create Profile View dialog box is displayed. Create
the profile view and click OK.
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The alignment name is displayed in the top-level Alignments collection or specified Site on the Prospector
tab. The pipe network parts you selected to create the alignment are unaffected by the creation of the
alignment.

Quick Reference
Ribbon
Home tab ➤ Create Design panel ➤ Alignment drop-down ➤ Create Alignment From Network Parts
Menu
Pipes menu ➤ Utilities ➤ Create Alignment From Network Parts
Command Line
CreateAlignFromNetwork
Dialog Box
CreateNetwork (page 2259)

Drawing Straight Pipes
You can draw straight pipes in a pipe network using the Network Layout Tools.
You can draw straight pipes when you are using the Draw Pipes And Structures insertion mode or when you
are using the Pipes Only insertion mode.
After they are inserted, you can edit straight pipes using grips.
TIP You can use transparent commands for pipe network objects when you are prompted to specify radius, length,
or station offset. For more information, see Using Transparent Commands Within a Running Command (page
1768).
To draw a straight pipe in a pipe network
1 Click Home tab ➤ Create Design panel ➤ Pipe Network drop-down ➤ Pipe Network Creation Tools
to create a new pipe network, or Pipe Networks tab ➤ Modify panel ➤ Edit Pipe Network
an existing pipe network.
2 On the Network Layout Tools toolbar, click or

to select

.

3 Specify the start point for the pipe.
4 Specify the end point.

Quick Reference
Ribbon
Home tab ➤ Create Design panel ➤ Pipe Network drop-down ➤ Pipe Network Creation Tools
Menu
Pipes menu ➤ Create Pipe Network By Layout or Pipes menu ➤ Edit Pipe Network
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Command Line
EditNetwork
Dialog Box
Network Layout Tools (page 2268)

Drawing Curved Pipes
You can draw curved pipes in a pipe network using the Network Layout Tools.
You can draw curved pipes when you are using
are using the Pipes Only insertion mode.

Draw Pipes And Structures insertion mode or when you

No matter which insertion mode you are using, the resulting curved geometry is equivalent to the AutoCAD
arc object, where the insertion point (or start point) of the pipe, the midpoint, and the endpoint of the
curved pipe can be gripped to edit the arc.
Curved pipe objects do not have persistent tangency once the curved pipe is created. Therefore, once a
curved pipe is grip edited, any tangency to adjacent pipes may be lost.
There are three ways that you can create curved pipes. Each of these methods are similar to methods used
for creating alignment curves, or AutoCAD arc objects.

Curve Creation Modes
You can use the default curve creation mode when you are using the Pipes and Structures insertion mode,
or when you are using the Pipes Only insertion mode. If you already have a structure inserted, and you are
adding a pipe to it, clicking on the structure specifies the initial direction and start point for the curved pipe.
You are then prompted for an end point.
This method is used when the curved pipe is starting from a structure (or a null structure) with only one
pipe already connected to it. With this method, the initial start point for the curved pipe comes from the
structure. The start direction comes from the one pipe that is already connected to that structure. This
ensures that the curved pipe will be tangent to the last pipe drawn, or to a pipe that already exists at the
structure (or null structure) from where the curved pipe is starting.
If no pipe is found to get a direction from, you are prompted to specify a direction at the first point.

Specifying Two Points and a Radius
Using this curved pipe creation mode, you specify the two endpoints of the curve and a radius. This method
also lets you choose the curve direction (clockwise or counter-clockwise).

Specifying Three Points
Using this curved pipe creation mode, the first point is selected, then a point along the curve, then the curve
endpoint.
TIP You can use transparent commands for pipe network objects when you are prompted to specify radius, length,
or station offset. For more information, see Using Transparent Commands Within a Running Command (page
1768).
To draw a curved pipe using the default curve creation mode
1 On the Network Layout Tools toolbar, click

Pipes Only or

Pipes and Structures.

2 If you clicked Pipes and Structures mode, specify the insertion point for the structure.
If you clicked Pipes Only mode, specify the first pipe point.
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3 Enter c (curve), and press Enter to begin specifying the curve.
4 Specify the second point of the curve.
5 Specify the end point for the curve.
6 Press Enter to end the command.
To draw a curved pipe by specifying two points and a radius
1 On the Network Layout Tools toolbar, click
2 If you clicke

Pipes Only or

Pipes and Structures.

Pipes and Structures mode, specify the insertion point for the structure.

If you clicked Pipes Only mode, specify the first pipe point.
3 Enter c (curve), and press Enter.
4 Enter r (radius) and specify a radius.
5 Specify a curve direction, either clockwise or counter clockwise.
6 Specify the end point for the curved pipe.
7 Press Enter to end the command.
To draw a curved pipe by specifying three points
1 On the Network Layout Tools toolbar, click
2 If you clicked

Pipes Only or

Pipes and Structures.

Pipes and Structures mode, specify the insertion point for the structure.

If you clicked Pipes Only mode, specify the first pipe point.
3 Enter c (curve), and press Enter.
4 Specify the second point of the curve.
5 Specify the end point for the curved pipe.
6 Press Enter to end the command.

Quick Reference
Ribbon
Home tab ➤ Create Design panel ➤ Pipe Network drop-down ➤ Pipe Network Creation Tools
Menu
Pipes menu ➤ Create Pipe Network By Layout or Pipes menu ➤ Edit Pipe Network
Command Line
EditNetwork
Dialog Box
Network Layout Tools (page 2268)
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Creating a Pipe Network Reference
You can create a reference to an existing pipe network in a data shortcut (page 2772) or a Vault project.
The pipe network reference is a lightweight read-only copy of the original, but it gives you access to the
network design data. Before you create the pipe network reference, it must exist in the current project
collection on the Toolspace Prospector tab.
See also:
■

Creating Data Shortcuts (page 151)

■

Vault: Checking a Drawing in to a Project (page 179)

To create a reference to a data shortcut pipe network
1 In Toolspace, on the Prospector tab, in Master View, ensure that the correct working folder is identified
on the Data Shortcuts node.
2 Expand the Data Shortcuts ➤ Pipe Networks collection, right-click the desired network, and then click
Create Reference.
The Create Pipe Network Reference dialog box is displayed, in which you can optionally change properties
of the reference network, as described in the following steps.
3 In the Create Pipe Network Reference dialog box, to change the source of the reference, select the source
in the Source Pipe Network drop-down list.
4 Enter a unique name for the pipe network and optionally, a description.
5 Specify a parts list and object layer.
6 Specify whether to override reference surface or alignment or select the defaults.
7 Select to include, or not include, source drawing labels or select other label styles.
8 Click OK to create the pipe network.
The pipe network name is displayed under the Pipe Networks collection in the Prospector tree with a
next to it.
To create a reference to a pipe network in a Vault project
1 In Toolspace, on the Prospector tab, in Master View, expand the Projects ➤ <project name> ➤ Pipe
Networks collection, right-click the desired network, and then click Create Reference.
The Create Pipe Network Reference dialog box is displayed, in which you can optionally change properties
of the reference network, as described in the following steps.
2 In the Create Pipe Network Reference dialog box, to change the source of the reference, select the source
in the Source Pipe Network drop-down list.
3 Enter a unique name for the pipe network and optionally, a description.
4 Specify a parts list and object layer.
5 Specify whether to override reference surface or alignment or select the defaults.
6 Select to include, or not include, source drawing labels or select other label styles.
7 Click OK to create the pipe network.
The pipe network name is displayed under the Pipe Networks collection in the Prospector tree with a
next to it.
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Quick Reference
Toolspace Right-Click Menu (for data shortcut project)
Prospector tab: Data Shortcuts ➤ Pipe Networks ➤ <network name> ➤ Create Reference
Toolspace Right-Click Menu (for Vault project)
Prospector tab: Projects ➤ <project name> ➤ Pipe Networks ➤ <network name> ➤ Create Reference
Command Line
CreateNetworkReference (for Vault pipe network only)
Dialog Box
Create Pipe Network Reference Dialog Box (page 2451)

Resetting Pipe Network Reference Labels
You can use the Reset Network Labels command to reset a referenced network’s labels to match the source
drawing’s labels.
You can make changes to reference network labels after referencing a pipe network into the current drawing.
Use this command when you have created a referenced pipe, and you want the labels in the referenced pipe
to match the source drawing's labels, rather than the current drawing's labels.
For information about creating a pipe network reference, see Creating a Pipe Network Reference (page 1342).
To reset a pipe network reference’s labels
1 Select the pipe network. Click Pipe Networks tab ➤ Labels & Tables panel ➤ Reset Labels

.

2 Select a referenced pipe network part. The pipe network’s labels are deleted and replaced with labels
from the source drawing. If you select parts from multiple referenced pipe networks, changes apply to
all of the referenced pipe networks.
NOTE After selecting this command, if there are no referenced pipe networks in the current drawing, an
error message is displayed. If a source drawing is not found, an error message is displayed. If you select a
part that is not from a referenced pipe network, you are prompted to select a referenced pipe network part.

Quick Reference
Ribbon
Pipe Networks tab ➤ Labels & Tables panel ➤ Reset Labels
Menu
Select the pipe network. Pipes menu ➤ Utilities ➤ Reset Network Labels
Command Line
ResetNetworkLabels

Editing Pipe Network Settings
Use pipe network settings to specify the default styles and behavior for pipe network commands.
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Settings are handled in a standard way throughout AutoCAD Civil 3D. You access settings using the Toolspace
Settings tab. You can control settings at three levels: the drawing level, the object collection (feature) level,
and the command level. For more information, see Understanding Settings (page 77).
In the Settings tree, you can use the Pipe Network collection, the Pipe collection, or the Structure collection
to establish defaults. Use the Pipe Network collection to specify defaults for all pipe network commands.
You can change object-specific settings at this level, or override the drawing ambient settings.
NOTE Overrides to the drawing ambient settings at the Pipe Network collection level, the Pipe collection level,
the Structure collection level, and the Pipe Network Commands collection level affect only the specified level. The
drawing level settings are not changed.
The topics in this section describe only those settings that affect pipe networks and pipe network commands.
For more information about the drawing ambient settings for the Pipe Network, Pipe, and Structure collections,
see Specifying Ambient Settings (page 84).

Changing Pipe Network Creation Settings
Use the pipe network creation and naming settings in the Pipe Network Settings (page 2262) dialog box to
change pipe network settings before you create a pipe network.
For example, before creating a pipe network, you may want to specify the default rules used for pipes or
structures in the parts list when new parts are added to it.
Note that if a closed lock appears in the Lock column for a property, the property is locked at a higher level
of the Settings tree. It cannot be changed at this level.
If you change a property value, a check mark is placed in the My Override column. This override is also
noted in the property table for related objects higher up the Settings tree, where a green arrow appears in
the Child Override column.
To change pipe network creation settings
1 Do one of the following:
■

To edit settings for all pipe network commands: In Toolspace, on the Settings tab, right-click the
Pipe Network collection. Click Edit Feature Settings.

■

To edit settings for a specific command: In Toolspace, on the Settings tab, expand the Commands
collection in the Pipe Network collection. Right-click the name of the command for which you want
to change settings. Click Edit Command Settings. For example, right-click the CreateNetwork
command and click Edit Command Settings.

The Edit Feature Settings (page 2262) dialog box is displayed.
2 To edit the default naming format for pipe networks and data that can be extracted from the pipe
network, expand the Default Name Format property group. Edit the Name Template settings.
3 Click Apply.

Quick Reference
Toolspace Shortcut Menu
Settings tab: Right-click Pipe Network collection ➤ Edit Feature Settings
OR
Settings tab: Pipe Network ➤ Commands ➤ Right-click <command-name> ➤ Edit Command Settings
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Dialog Box
Edit Feature Settings (page 2262)

Changing Pipe Network Default Style Settings
Use the pipe network settings to specify default object styles and labels for pipe network creation and for
data that you create or extract from a pipe network.
The default styles specified in these settings are used to establish the default setting for the style in the Create
Pipe Network and Pipe Network Properties dialog boxes.
To change the pipe network style and label default settings
1 In Toolspace, on the Settings tab, right-click the Pipe Network collection. Click Edit Feature Settings to
open the Pipe Network Settings (page 2262) dialog box.
2 Expand the

Default Styles property group.

3 To specify a default style for pipe network objects, such as pipes and structures, or for render material,
click the corresponding field. Click
style.

to display the default style dialog box, where you can select a

4 To specify a default label style for pipe network components in plan and profile views, click the
corresponding field. Click

to display the label style dialog box, where you can select a label style.

5 Click Apply.

Quick Reference
Toolspace Shortcut Menu
Settings tab: Right-click Pipe Network collection ➤ Edit Feature Settings
Dialog Box
Pipe Network Settings (page 2262)

Editing Pipe Networks
You can edit a pipe network using a variety of methods.
For example, you can edit a pipe network by:
■

manipulating a pipe network directly in the model using grips

■

using commands available from the ribbon

■

using commands available from the Network Layout Tools toolbar

■

editing pipe and structure properties using the Pipe Network Vista

■

exporting a pipe network to an .stm file, and then editing the .stm file using the Storm Sewers Extension.
Once edited, you can import the pipe network (.stm file) back into AutoCAD Civil 3D and the changes
that were made using the Storm Sewers Extension are recognized in AutoCAD Civil 3D.
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Editing Pipe Network Using the Network Layout Tools
You can use the network layout tools toolbar to edit a pipe network.
Editing commands are the same commands you use for creating a pipe network.
To edit a pipe network using the layout tools
1 In the drawing, right-click a part in a pipe network. Click Edit Network.
2 Click a button in the Network Layout Tools (page 2268) dialog box to add, change, or delete pipe network
parts, or change the surface, alignment or parts list that are referenced.

Quick Reference
Ribbon
Select pipe network. Click Pipe Networks tab ➤ Modify panel ➤ Edit Pipe Network
Menu
Pipes menu ➤ Edit Pipe Network
Object Shorcut Menu
Edit Network
Command Line
EditNetwork
Dialog Box
Network Layout Tools (page 2268)

Editing Pipe Networks Using the Pipe Network Vistas
You can use the Pipe Network Vistas to display all the components that are part of the pipe network.
The Pipe Network Vistas display pipe network data in a form that is similar to a spread sheet. Each row
represents a pipe network part. Each column represents an attribute for a pipe network part. There is a tab
to view pipe objects and a tab to view structure objects. The purpose of this view is to let you quickly see all
the parts that make up the pipe network, along with their associated properties. Right-click a column heading
to display options for customizing the display of detail in the column views.
See also:
■

The Toolspace Item View (page 99)

■

The Panorama Window (page 119)

To edit a pipe network using the Pipe Network Vistas
1 Select a pipe network part in the drawing. Right-click the part and click Edit Network.
2 On the Network Layout Tools toolbar, click

.

NOTE You can edit only values that are available, you cannot edit data in disabled (shaded) cells.
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Quick Reference
Object Shorcut Menu
Edit Network ➤ Pipe Network Vistas
Dialog Box
Pipe Network Vistas (page 2302)

Editing Pipe Networks Using Grips
You can use grips to move, shorten, or stretch pipe or structure objects, or to change the size of a pipe.
Some of the grip editing behavior for pipes and structures is similar to the grip editing behavior for alignments.
For more information about basic grip editing behavior for alignments, see Editing Alignments Using Grips
(page 1068).

Grip Editing Pipes
When moving a pipe in a pipe network using grips, structures connected to the pipe are no longer connected
to the pipe, unless the pipe end being gripped is moved to another location within the network.
You disconnect the pipe from a structure if the end is attached to a structure. If you grip the end of the pipe
to another structure, you can connect to it when a glyph appears next to the grip.

Grip editing a pipe that is connected to a structure does not move the structure along with it. Depending
on the rim and sump behaviors of the structure, it may be necessary to adjust the structure vertically to
accommodate a new sump elevation, or top of barrel, when the pipe is disconnected from the structure.

Grip Editing Structures
When the location of a structure is edited, all the pipe ends connected to it move, along with the structure.
The elevations of the original pipe ends connected to the structure are maintained.

Pipes and Elevation Data
When grip editing a pipe, if no three-dimensional object snap is used (any value other than zero), the
elevation of the end of the pipe is maintained when the pipe is connected to a new structure.
When a pipe is grip edited and moved over an existing pipe that it will “break,” the end of the pipe that is
being grip edited moves to the elevation of the pipe that is being broken.
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The lengthening grips at the ends of the pipes extend the pipe end in a 2D plan view while maintaining the
slope of the pipe. A 3D snap does not affect the elevations of the pipe when using the lengthening grip or
the resize grips.

Snapping to 3D
When viewing and editing pipe networks in plan view, you can quickly edit not only the two-dimensional
geometry of the pipe, but you can also snap the pipe to three-dimensional locations to affect the elevation
of either end of a pipe, or both ends simultaneously.

Endpoint Free Grip
In plan view, clicking the endpoint free grip moves the selected endpoint of the pipe to a new specified
point. The midpoint and opposite endpoint of the pipe are held during this edit. On a curved pipe, the
behavior is identical to AutoCAD arc object behavior.

Midpoint Free Grip
This moves the entire pipe to a new specified point. On a curved pipe, the midpoint grips behaves just like
AutoCAD arc objects: the endpoints are held, and the cursor acts as a pass-through location.
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Length Constraint Grip
A pipe can be made shorter or longer by gripping the end of the pipe. Only the end that is gripped shortens
or lengthens. The direction of the pipe does not change while performing this type of grip edit.

Midpoint Resize Constraint Grip
The midpoint resize grip lets you resize the pipe width based on the pipe sizes available in the parts list and
the part catalog for the currently selected pipe.
When you use the midpoint resize grip on a pipe, a series of parallel lines display next to the pipe. Each
parallel line represents an available pipe width. Tooltip text displays the pipe width. You can snap to any
of the parallel lines and select a new pipe width.

To use grips to edit a pipe
1 In the drawing, click a pipe in a pipe network.
The following illustration shows grips for a pipe in a pipe network:
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2 Do one of the following:
■

Use the end grips to adjust the pipe length.

■

Use the center grip to move the location of the pipe.

■

Use the midpoint resize grip to change the width of the pipe.

Editing Pipe Networks Using the Storm Sewers Extension
You can use the Storm Sewers extention to open and edit pipe networks created with AutoCAD Civil 3D.
To open pipe networks in the Storm Sewers Extension, they must first be exported to an .stm file.
The .stm file can then be opened by the Storm Sewers Extension and edited.
For example, you can create pipe networks in AutoCAD Civil 3D, and then import those pipe networks into
Storm Sewers to perform analysis tasks. After performing hydraulic analysis tasks on the pipe network, you
can then import that same pipe network back into AutoCAD Civil 3D.
Refer to the following table to find more information about using the Storm Sewers Extension:
For information about ...

See...

exporting AutoCAD Civil 3D pipe
networks to an .stm file

Exporting Pipe Network Data to an .stm File (page
1423)

importing an .stm file into the Hydraflow Storm Sewers Extension

the Hydraflow Storm Sewers Extension User’s
Guide Help

editing pipe networks in the Hydraflow Storm Sewers Extension

the Hydraflow Storm Sewers Extension User’s
Guide Help

importing an .stm file into AutoCAD
Civil 3D

Importing Pipe Network Data from an .stm File
(page 1422)

adding or editing hydraulic data
(HGL, EGL, and so on)

Adding Hydraulic Property Data to AutoCAD Civil
3D Pipe Networks (page 1424)

You can also use the EditInStorm Sewers command to browse to an .stm file, and automatically open it in
the Storm Sewers Extension.
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For more information about using the Storm Sewers Extension to edit pipe networks, see the Storm Sewers
Extension Help.
When you are finished making changes to the pipe network in the Storm Sewers Extension, save the project
to save the changes to the .stm file.
You can import that .stm file back in to AutoCAD Civil 3D, and overwrite (update) the previous version of
that pipe network data, if desired. You also have the option of importing it with a new pipe network name.
To use the EditInStormSewers command
1 Do one of the following:
■

On the Modify tab, click Pipe Networks to display the Pipe Networks contextual tab. On the Pipe
Networks contextual tab, click Analyze panel ➤ Storm Sewers drop-down ➤ Edit In Storm Sewers
.

■

Click a pipe network in the drawing to display the Pipe Networks contextual tab. On the Pipe
Networks contextual tab, click Analyze panel ➤ Storm Sewers drop-down ➤ Edit In Storm Sewers
.

■

At the command line, enter EditInStormSewers and then press Enter.

2 On the Export To Storm Sewers dialog box, select the pipe networks to export, and click OK.
NOTE You must select one or more entire pipe networks. You cannot select individual parts, or a series of
connected parts within a pipe network.
3 Enter a name and select a location for the .stm file, and click Save.
The .stm file is created, and the Storm Sewers Extension launches. The exported pipe network data is displayed
in Storm Sewers Extension. For more specific information about using the Storm Sewers Extension to edit
pipe networks, see the Storm Sewers Extension Help.

Quick Reference
Ribbon
Pipe Networks tab ➤ Analyze panel ➤ Storm Sewers drop-down ➤ Edit In Storm Sewers
Command Line
EditInStormSewers
Dialog Box
Export to Storm Sewers Dialog Box (page 2316)

Changing Flow Direction
You can change the flow direction on consecutive parts in a pipe network.
Because some pipe network rules rely on the flow direction assigned to pipes, this command lets you assign
direction as needed so that rules can be applied properly.This feature also allows for the display of appropriate
flow direction arrows in labels.
The Change Flow Direction command is also useful when other applications using AutoCAD Civil 3D pipe
network model data need to be able to determine flow direction within a network.
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You may need to change the flow direction of an entire pipe network, or only a portion of a pipe network.
Using the Change Flow Direction command, you are prompted to select a path of consecutive parts in a
pipe network.
To change the flow in a series of connected parts, select a path by clicking on a starting part, and an ending
part within a pipe run.
Changing flow direction can only be performed on a single pipe network at a time. Although you can select
structures as well as pipes when using this command, the feature affects pipes only.
To change pipe network flow direction
1 Select the pipe network. Click Pipe Networks tab ➤ Modify panel

Change Flow Direction

.

A prompt is displayed indicating that you should select the part (pipe or structure) that you want to be
used as the upstream starting point in plan view.
2 In the drawing, click a pipe or structure in the pipe network to define the upstream starting point for
the flow direction change.
A prompt is displayed indicating that you should select the part (pipe or structure) that you want to be
used as the downstream ending point in plan view.
3 Do one of the following:
■

Select a path for the flow direction change by clicking a pipe or structure to define the downstream
ending point. You can continue clicking consecutive parts in a pipe network to define the path for
the change flow direction.

■

You can click Undo at any time during this command to undo the previously selected part and path.

4 When you have finished defining the path for the flow direction change, press Enter to end the command
and implement the flow direction change on the parts in the selected path.
A prompt indicating that the flow direction has been successfully applied to the part(s) is displayed.
The Flow Direction property value on the Part Properties tab of the Pipe Properties dialog box is changed
(from Start to End to End to Start, or from End to Start from Start to End).

Quick Reference
Ribbon
Pipe Networks tab ➤ Modify panel

Change Flow Direction

Menu
Pipes menu ➤ Change Flow Direction
Command Line
ChangeFlowDirection

Grip Editing Structures
When you move a structure, all pipe ends connected to it move along with the structure.
Elevations of the original pipe ends connected to the structure are typically maintained. However, part rules
control elevations and slope of connected pipes under certain conditions. See Part Rules (page 1390) for more
information.
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It is also important to understand the automatic resize behavior that is built into junction structures. This
automatic resize behavior is designed to ensure that appropriate aspects of a junction structure’s geometry
(such as elevations of connected pipes, sump depths, and vertical pipe clearance areas) are maintained even
when the junction structure’s elevation changes. For more information, see Junction Structure Resize Behavior
(page 1354).

Rim and Sump Depth Grips
While viewing a structure in a profile view, use the structure’s rim or sump depth grip to adjust the rim or
sump depth. In the following illustration, the rim grip is located at the top of the structure. The sump depth
grip is located just above the bottom of the structure.

What the structure grips change depends on how the structure’s Insertion (Rim) and Sump Behavior properties
are set. For example, if you have the structure’s Automatic Surface Adjustment property enabled, grip editing
the structure modifies the surface adjustment factor. If you have the Automatic Surface Adjustment property
disabled, grip editing the structure modifies the rim (insertion) elevation. For sump behavior properties, if
you have the Sump Depth property enabled, grip editing the structure modifies the sump depth. If you have
the Sump Elevation property enabled, grip editing the structure modifies the sump elevation. See the Part
Properties tab (page 2289) of the Structure Properties dialog box for more information.
NOTE You cannot grip edit a structure in section view.
To use grips to edit a structure
■

To move the location of a structure that has pipes connected to it, in the drawing, click the center grip
of the structure and move it to a new location.

■

While viewing structures in a profile view, use the structure’s rim or sump depth grips to adjust the
elevation of either.

Editing Pipes Connected to Structures
You can use the Connected Pipes tab on the Structure Properties dialog box to quickly edit pipes connected
to a single structure.
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When you have pipes connected to a structure, you may need to adjust the values of properties such as
elevation, and or pipe diameter/width. To do this, you can use the Connected Pipes tab on the Structure
Properties dialog box to edit the properties of multiple pipes connected to the same structure.
Using this tab, you can
■

edit inner diameter, inner width, or inner height of pipes connected to a structure

■

quickly edit elevations on multiple pipes to match the elevation of a selected pipe

To edit pipes connected to a structure
1 In the drawing, right-click the structure you want to edit, and then select Structure Properties from the
shortcut menu.
2 Click the Connected Pipes tab.
3 To edit the following properties, click the value in the cell and enter a new value, or select one from
the list: inner diameter (for circular pipes), inner width or inner height (for non-circular pipes).
NOTE On this tab, the read-only slope value refers to the slope of the pipe as it is coming out of the structure
(slope out).
4 To edit the elevation for a single pipe, select the pipe and edit the invert, centerline, or crown elevation
value.
5 To edit elevations for multiple pipes, see for Matching Elevations on Connected Pipes (page 1363) more
information.
6 Click Apply to make the changes, or click OK to make the changes and close the Structure Properties
dialog box.

Junction Structure Resize Behavior
In AutoCAD Civil 3D, junction structures have built in resize behaviors that control how far you can move
the rim, connected pipes, and sump up and down.
For example, if you move the top-most pipe invert up, raising its elevation to the point where it reaches the
top of the structure (rim), the rim moves up automatically. This is to ensure that the pipe remains connected
to the structure below the vertical pipe clearance area. The resize behavior allows the junction structure to
maintain the frame height, cone height, and honor the vertical pipe clearance area, at the top of the structure,
with no pipes connecting in to that part of the structure.
If you try to move a connected pipe into the structure’s vertical pipe clearance area, you will notice in your
drawing that the top of the structure (rim) automatically moves up.
This is just one example of the resize behavior that is built in to junction structures. Other resize behaviors
control how far you can move the junction structure’s rim or sump up and down. These resize behaviors
are described in more detail in the following sections:
■

Junction Structures With Connected Pipes (page 1355)

■

Junction Structures With No Connected Pipes (page 1356)

Before editing junction structures, make sure you understand the following about the resize behavior:
■

Elevation changes to the junction structure’s rim, connected pipes, or sump, could occur when the
structure is grip edited, or when the referenced surface changes, or when pipe elevations are changed.
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■

The resize behavior of junction structures is independent of the behavior supplied by part rules. However,
part rules can be configured so that they affect the structure resize behavior. For more information, see
Part Rules (page 1390).

■

Note that the resize behaviors explained here apply only to junction structures. They do not apply to
inlet/outlet structures or null structure types.

■

To verify that a structure is categorized as a junction structure, check that the Part_Type property is set
to Struct_Junction. This is displayed on the Part Properties tab of the Structure Properties dialog box, in
the Part Data section.

Junction Structures With Connected Pipes
Moving pipes that are connected to junction structures invokes certain structure resize behaviors.
This section describes the structure resize behavior that is invoked in the following situations:
■

moving the top of a junction structure (rim) up or down

■

moving a pipe that is connected to a junction structure up or down

■

moving the bottom of a junction structure (sump) up or down

These changes to elevation in the junction structure’s rim, connected pipes, or sump, could occur because
the structure is grip edited, or because the referenced surface is edited, or because a connected pipe elevation
is moved. Any of these types of edits may result in elevation changes to parts of the structure.

Moving the Rim
When a junction structure’s rim (top of structure) is moved up, the rim simply moves to the new elevation.
Connected pipes, and sump elevations, remain unchanged.
If you try to move a junction structure’s rim down, to an elevation where it violates the vertical pipe clearance
area, you will not be able do so. The rim must always be located above the vertical pipe clearance area.
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Moving Connected Pipes
The following table describes the resize behavior that occurs when connected pipes are moved up.
When a pipe that is connected to a junction structure is moved up, to the point where it violates the vertical
pipe clearance, the top (rim) of the structure automatically moves up so that the pipe does not touch the
vertical pipe clearance area. In this case, the structure’s rim elevation changes (moves up).
If you move the pipe up, but not to the point where it touches the vertical pipe clearance area, then the
pipe is moved up, but the rest of the structure remains where it is. In this case, the structure’s rim elevation
remains unchanged.
Understanding the Control Sump By Property
When you are moving a connected pipe down, there is a part property associated with the junction structure
that affects the structure resize behavior in this situation. That property is the Control Sump By property,
and it can be set to Depth or Elevation. When this property is set to Depth, the sump depth is controlled
by the depth, based on the lowest pipe invert. When this property is set to Elevation, the sump depth is
controlled by the elevation value of the sump. The resize behavior is different depending on how this property
is set on the structure.
When a connected pipe is moved down, to a point where the pipe moves below the connected structure’s
sump elevation, and the Control Sump By property is set to Depth, since the sump elevation is set to be
controlled by the depth, then the sump elevation will be moved down, to a new elevation. This new sump
elevation will be the depth of the lowest pipe invert, minus the sump depth value.
If a connected pipe is moved down, to a point where the pipe moves below the connected structure’s sump
elevation, but the Control Sump By property is set to Elevation, then the sump will automatically move
down, to an elevation equal to the lowest pipe elevation. This sets the sump depth to zero.

Moving the Sump
Using the sump depth grip, you can move a junction structure’s sump up to the point where it meets the
lowest connected pipe. You will be prohibited, however, from moving the sump up past the point where it
touches the lowest connected pipe.
When you move a junction structure’s sump down, the sump will simply move to the new elevation, and
not affect any connected pipes, or the structure’s rim. This behavior is the same whether the sump is controlled
by depth or by elevation.

Junction Structures With No Connected Pipes
When there are no pipes connected to a junction structure, the rim and vertical pipe clearance take precedence
over the sump.
The following sections describe the resize behaviors on junction structures that have no connected pipes.

Moving the Rim
When you move the structure’s rim up, and the Control Sump By property is set to Depth, the sump moves
up the same distance as the rim.
When you move the structure’s rim up, and the Control Sump By property is set to Elevation, the sump
moves up the same distance as the rim.
When you move the structure’s rim down, the sump does not move. You can move the rim down, but only
to a location just above the sump. The rim must always be above the sump.
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Moving the Sump
When you move the structure’s sump up, and the Control Sump By property is set to Depth, the new sump
elevation can be below, at, or above the vertical pipe clearance area. This does not affect the rim elevation,
and it sets the sump depth to zero.
When you move the structure’s sump up, and the Control Sump By property is set to Elevation, the sump
can only move up as far as the bottom of the vertical pipe clearance area.
When you move the structure’s sump down, the sump is moved to its new location (new sump depth), but
the rim elevation does not change.

Adding a Part to a Pipe Network
You can add a part (pipe or structure) to an existing pipe network.
To add one or more parts within an existing pipe network, using the Network Layout Tools toolbar, select
the type of parts you want to insert (pipes and structures, pipes only, or structures only), and then specify
insertion points in the drawing.
You can also add parts to a pipe network by copying and pasting a part within an existing pipe network.
To add a part to a pipe network
1 In the Prospector tree, click the pipe network object, right-click, and click Edit Network. The Network
Layout Tools toolbar is displayed.
2 On tNetwork Layout Tools toolbar, click
Pipes Only, or Structures Only.

and select one of the following choices: Pipes and Structures,

3 In the drawing, specify the insertion point by clicking on the pipe network object you want to connect
to.

Quick Reference
Ribbon
Home tab ➤ Create Design panel ➤ Pipe Network drop-down ➤ Pipe Network Creation Tools
Menu
Pipes menu ➤ Create Pipe Network By Layout
Command Line
CreateNetwork
Dialog Box
Create Pipe Network (page 2259)

Swapping Pipe Network Parts
You can select an existing part in a pipe network and replace it with a part that is the same type, but is from
a different part family and/or part size.
A part can only be swapped with a part that is the same type.
For example, a pipe can only be swapped with another pipe; a junction structure can only be swapped with
another junction structure; an inlet/outlet structure can only be swapped with another inlet/outlet structure.
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Note that a null structure can only be swapped with a junction structure, since it connects two pipes together.
If you want to replace a part with a different part type, you must delete the part, and then add the new one.
Note that when swapping parts, connection elevations are maintained. For example, pipe invert elevations
remain the same if a pipe is swapped with another pipe, or if a structure with one or more pipes attached
to it is swapped with another structure.
You can swap with any part from the pipe network’s current parts list.
NOTE Part swapping should not be confused with part sizing. In part sizing, an existing part is resized within the
same part family.
To swap a part in a pipe network
1 In the drawing, right-click the pipe or structure object to swap and click Swap Part.
2 In the Swap Part Size dialog box, expand a part family. Select the part to swap and click OK.
The new part is displayed in the drawing. View the description of the new part by right-clicking on the part
and selecting Pipe Properties.

Splitting Pipe Networks
You can split a pipe network into two pipe networks.
When you split a pipe network, no pipe network parts are moved. However, the selected parts are associated
with a different pipe network name.
To split a pipe network
1 Click Modify tab ➤ Design panel ➤ Pipe Network.
The Pipe Networks contextual tab is displayed in the ribbon.
2 On the Modify panel, click Split Network

.

3 In the drawing, select the first pipe network part.
After selecting the first pipe network part, you are then prompted to select the next pipe network part
or [Undo].
4 Select the next pipe network part.
You can select multiple pipe network parts. Selected parts display with a dashed-line linetype.
5 When you are finished selecting parts, press ENTER.
Now you are prompted to either add the parts to an existing pipe network, or add them to a new pipe
network.
6 Do one of the following:
■

Select the destination pipe network to add the parts to.

■

Press C to Create a New Pipe Network.

The selected parts now belong to the destination pipe network. If you chose to create a new pipe network,
the new pipe network name is displayed in Prospector.
Most of the part properties of the selected parts are not modified when splitting a pipe network. Part properties
such as the referenced surface, referenced alignment and labeling, remain unchanged when the pipe network
is split. The only part property that changes is the pipe network that the parts are associated with.
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Quick Reference
Ribbon
Pipe Networks tab ➤ Modify panel ➤ Split Network
Command Line
SplitPipeNetwork

Merging Pipe Networks
You can combine two pipe networks into one pipe network.
When you merge pipe networks, no pipe network parts are moved. However, the selected parts are associated
with a different pipe network name.
To merge pipe networks
1 Click Modify tab ➤ Design panel ➤ Pipe Network.
The Pipe Networks contextual tab is displayed in the ribbon.
2 On the Modify panel, click Merge Networks

.

3 In the Select Source Pipe Network dialog box, select the pipe network that you want to merge with
another pipe network, and then click OK.
The source pipe network is the pipe network that will be added to the destination pipe network.
4 In the Select Destination Pipe Network dialog box, select the desired destination pipe network, and
then click OK.
The pipe network parts from the source pipe network are added to the destination pipe network. The source
pipe network name is deleted from the Prospector tree.
Most of the part properties of the selected parts are not modified when merging pipe networks. Part properties
such as the referenced surface, referenced alignment and labeling, remain unchanged when merged. The
only part property that changes is the pipe network that the parts are associated with.

Quick Reference
Ribbon
Pipe Networks tab ➤ Modify panel ➤ Merge Network
Command Line
MergeNetworks

Disconnecting Pipe Network Parts
You can select a part in a pipe network and disconnect it from the part or parts it is currently connected to.
When you disconnect a part, the disconnected part can then be moved in the drawing without moving
parts that were attached to it.
Even though a part may be disconnected from the other parts in the same pipe network, the disconnected
part still belongs to the same pipe network.
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The following behavior applies to the connectivity of pipes and structures:
■

When grip editing is used to move, lengthen, or shorten a pipe, the connectivity to any structures
connected to that pipe will be lost. There is one exception to this rule: if the pipe end being gripped is
moved to the location within the structure it was originally attached to, then the connectivity is
maintained.

■

When grip editing a pipe that is attached to a structure, moving the pipe does not move the structure.
The pipe becomes disconnected from the structure. The only affect this type of edit may have is to
possibly resize the structure vertically to accommodate for a new sump elevation or top of barrel when
the pipe is disconnected.

■

When grip editing a pipe, if no 3D OSNAP is used (any value other than zero), the elevation of the end
of the pipe is maintained when the pipe is grip edited and connected to a new structure.

■

When grip editing a pipe that is moved over an existing pipe that it will “break,” the end of the pipe
being edited moves to the elevation of the pipe being broken.

To disconnect a part in a pipe network
■

In the drawing, right-click the pipe or structure object and click Disconnect From Part. If you selected a
structure, you will be prompted to select the pipe to disconnect from.

The part name is displayed in the Pipe Networks collection on the Prospector tab.

Connecting Pipe Network Parts
You can select a disconnected part in a pipe network, or add a new part, and connect it to other pipe network
parts.
When you use this command, the disconnected part automatically snaps to connect to the selected part.
To connect a disconnected part in a pipe network
1 In the drawing, right-click the disconnected pipe or structure object and click Connect To Part.
2 Click the part you want to connect to.
The second part automatically snaps to connect to the first part.

Deleting Pipe Network Parts
You can delete one or more parts from a pipe network.
When you delete a pipe or structure from a pipe network, the object is erased from the drawing, and also
removed from the Prospector list view.
You can delete pipes or structures using the Basic Modify Tools ➤ Erase command, or using the Delete Pipe
Network Object button on the Network Layout Tools toolbar, or by selecting the object in the Prospector
list view and choosing Delete from the shortcut menu.
To delete a pipe or structure using the Basic Modify Tools
■

In the drawing, right-click the pipe or structure you want to delete. Choose Basic Modify Tools ➤ Erase,
or select the part and press the Delete key on your keyboard.

The structure or pipe object is erased from the drawing and removed from the Prospector list view.
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To delete a pipe or structure using the Network Layout Tools
1 In Toolspace, on the Prospector tab, expand the Pipe Networks collection, then expand the Networks
collection.
2 Right-click the pipe network and choose Edit Network to display the Network Layout Tools toolbar.
3 On the Network Layout Tools toolbar, click

Delete Pipe Network object.

4 In the drawing, select the pipe or structure you want to delete.
The structure or pipe object is erased from the drawing and removed from the Prospector list view.
To delete a pipe or structure in the Prospector List View
1 In Toolspace, on the Prospector tab, expand the Pipe Networks collection, then expand the desired pipe
network to display the Pipes and Structures collections beneath it.
2 If you want to delete one or more pipe objects, click the Pipes collection in the Prospector tree. If you
want to delete one or more structures, click the Structures collection. Hold down the Shift key to select
multiple objects.
3 Right-click and click Delete from the shortcut menu.
The structure or pipe object is erased from the drawing and removed from the Prospector list view.

Deleting a Pipe Network
You can delete an entire pipe network, erasing it from the drawing and removing it from the Pipe Networks
collection in the Prospector tree.
When you delete a pipe network, all parts belonging to the pipe network (pipes, structures, and null structures)
are also deleted.
To delete a pipe network
1 In Toolspace, on the Prospector tab, expand the Pipe Networks collection, then expand the Networks
collection.
2 Right-click the pipe network and click Delete.
The pipe network, and all its associated child objects, are erased from the drawing and removed from
the Pipe Networks collection in the Prospector tree.

Quick Reference
Toolspace Shortcut Menu
Prospector tab: Pipe Networks ➤ Right-click <network-name> ➤ Delete

Copying a Pipe Network
You can create a copy of an existing pipe network.
You can copy an existing pipe network, copying the parent pipe network object and all of its associated
pipes and structures, and paste this to a new location in the drawing.
When a pipe network is copied, a naming convention is used to name the new pipe network object. For
example if the original pipe network object is named ‘Pipe Network 1’, the new pipe network object is named
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‘Pipe Network 1 (1)’ in the Prospector tree. If Pipe Network 1 is copied again, the new pipe network object
is named ‘Pipe Network 1 (2)’. If ‘Pipe Network 1 (1)’ is copied, the new pipe network object is named ‘Pipe
Network 1 (1) (2)’.
To copy a pipe network
1 In the drawing, select the entire pipe network.
NOTE Make sure you select all of the pipe network. If you do not copy all of the parts associated with the
pipe network, the selected parts will be copied to the existing pipe network.
2 Use any of the following methods to copy the pipe network to the clipboard: CTRL+C, the AutoCAD
COPYCLIP command, or Clipboard ➤ Copy from the right-click shortcut menu.
3 Press CTRL+V.
At the command line, you are prompted to specify an insertion point for the pipe network.
4 Click an insertion point in the drawing area.
The pipe network is pasted in the drawing and added as a new pipe network to the Pipe Networks
collection in the Prospector tree.
5 To edit the name of the pipe network, right-click the pipe network in the Prospector tree. Click Network
Properties.
The Pipe Network Properties dialog box is displayed with the Information tab (page 2269) active. The
Name field contains the name of the copied pipe network, which is, by default, “ <pipe network-name>
(1).”
6 Enter a new name in the Name field.
7 Optionally, enter a new description of the pipe network in the Description field.
8 Click Apply to make the changes, or click OK to make the changes and close the Pipe Network Properties
dialog box.

Renaming Pipe Network Parts
You can rename some or all parts in a pipe network.
If you need to update just one or a few parts within a pipe network, you may want to use the Pipe Network
Vistas (page 2302) in the Prospector, or just right-click on the part in the drawing and enter a new name for
the object on the Pipe Properties or Structure Properties dialog box.
If you want to rename many parts within a pipe network, use the RenamePipeNetworkParts command. This
command lets you rename one, all, or a sequence of connected parts within a pipe network.
Using this command, you can also select a name template to apply the new part names.
To rename connected parts in a pipe network
1 Select the pipe network. Click Pipe Networks tab ➤ Modify panel

Rename Parts

.

2 In the drawing, select the first part (pipe or structure) within the pipe network that you want to rename.
NOTE If you select a pipe or structure that is not connected to another pipe or structure, you can only rename
that single part.
3 Select the last part in the same pipe network that you want to rename.
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4 On the Rename Pipe Network Parts dialog box (page 2315), you may enter or choose a new name (or
name template) for the selected pipe network parts. You can choose to rename just the selected structures
from the sequence of consecutive parts selected, just the pipes, or both.
5 You can enter a new starting number or leave this field blank.
6 Select one of the following Name Conflict Options. These determine how to handle any conflicts with
the naming or numbering, if there are any conflicts.
■

Skip Number: When this option is selected, if a name and number combination is already being
used by a pipe network part in the drawing, then the number is incremented until that name\number
combination is available as a name for the selected part.

■

Rename Existing Parts: When this option is selected, if a name and number combination is already
being used by a pipe network part in the drawing, then that part will be renamed so that the selected
part can use that desired name instead. The original part will be renamed using the next name and
number combination that is available.

7 Click OK. The parts are renamed.
To view the updated part names, do one of the following:
■

In the drawing, right-click on a part and select Pipe Properties or Structure Properties. View the updated
pipe or structure names on the Information tab of the Pipe Properties or Structure Properties dialog box.

■

In the Prospector tree, expand the Pipe Networks ➤ Networks collection, and then expand the pipe
network containing the renamed parts. Click Pipes or Structures and view the updated part names in the
Pipe Network Vistas (page 2302).

Quick Reference
Ribbon
Select the pipe network. Pipe Networks tab ➤ Modify panel

Rename Parts

Menu
Click Pipe Networks tab ➤ Modify panel

Rename Parts

Command Line
RenamePipeNetworkParts
Dialog Box
Rename Pipe Network Parts (page 2315)

Matching Elevations on Connected Pipes
When multiple pipes enter and exit a structure, you may need to set pipe in and pipe out elevations to
consistent, matching values.
This feature lets you quickly set pipe elevations in cases where multiple pipes connect to a single structure.
This provides a method for quickly and accurately matching multiple pipe elevations to the invert, crown,
or centerline elevation of a selected pipe.
You can also add a drop value that lets you adjust that elevation value between incoming and outgoing
pipes.
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To match elevations on pipes connected to a structure
1 In the drawing, right-click the structure, select Structure Properties, and then click the Connected Pipes
tab.
2 Press and hold the CTRL key on your keyboard and select more than one of the pipes displaying on
the Connected Pipes tab.
NOTE You must select multiple pipes for the match crown, centerline, and invert options to display on the
right-click shortcut menu.
3 While still holding down the CTRL key, right-click and select one of the following options from the
shortcut menu.
■

Match crowns

■

Match centerlines

■

Match inverts

4 On the Match Elevation dialog box, click the pipe you want to match crown, centerline, or invert
elevations to.
5 Optionally, enter a Drop Amount to adjust the elevation by the specified value.
6 Click OK to make the changes and close the Match Elevation dialog box.
7 On the Connected Pipes tab, verify that the selected elevation value has been edited.
8 Click Apply to make the changes, or click OK to make the changes and close the Structure Properties
dialog box.

Displaying Pipe Networks
You can display pipe networks in plan, profile, and section views.

Displaying Pipe Networks in Profile Views
You can display selected pipe network parts, or entire pipe networks, in profile views.
To display pipe networks in a profile view, you must have valid station offset data (from the profile view
alignment) for the pipe networks.

Editing Parts in Profile View
If you make changes to the pipe network in plan view, such as moving, swapping, deleting, or resizing parts,
those changes are reflected when the parts are displayed in profile view.
NOTE You cannot move the X, Y locations of parts in a profile view. However, you can grip edit elevations, edit
object properties, or resize parts.

Editing Display Styles in Profile View
Initially, the object style comes from the part, but it can be overridden in profile view. To edit display
characteristics for pipe network parts displayed in a profile view, you right-click the profile view, click Profile
View Properties, and then click the Pipe Networks tab. For example, you can select the parts you want to be
drawn or not drawn in the profile view, or change layers or object styles. When you edit these display
characteristics on the Profile View Properties tab, they would only affect how the object is displayed in
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profile view. For more information, see the Pipe Networks tab (page 2434) on the Profile View Properties dialog
box.

Pipe Slopes in Profile View
The calculated slope of pipes in a profile view may or may not reflect the apparent slope of the actual linework
drawn in the profile view. This is because the slope of the pipe is the slope of the actual model from end to
end. If a pipe does not geometrically correspond to the alignment defining the profile view, the pipe shown
in that profile view will appear slightly different. Also, the length of the pipe in a profile view may not reflect
the true length of the pipe as displayed in plan view. This is because the displayed length of the pipe in the
profile may be different than the true length of the pipe, as displayed during layout.

Curved Pipes in Profile View
Curved pipes represented in a profile view are always represented as a straight line from the start point of
the pipe to the end point of the pipe. In reality, when a pipe is projected onto a profile, and depending on
the combination of horizontal and vertical geometry, the pipe would have some vertical deflections here
and there, even when the pipe is actually straight with no change in grade along its length. This is especially
true for curved pipes. Therefore, it is important to understand that AutoCAD Civil 3D represents all pipes
in profile views as straight lines drawn end to end.

Pipe Crossings in Profile View
A pipe crossing in a profile view refers to the location where a pipe crosses an alignment or sample line and
is displayed in its profile view. When displaying a cross section of a pipe network in AutoCAD Civil 3D,
locations of intersected pipes (pipe crossings) are represented at the correct elevation. However, the projected
pipe may not show the same elevation at that location for the reasons described in the previous paragraph.
Typically, there is no need to represent pipe networks as both projected and crossings in the same profile.
For more information, see Displaying Pipe Crossings (page 1367).

Structures in Profile View
Pipe network structures will only display in a profile view if the insertion point of the structure is within
the limits of the profile view. Therefore, when the structure’s insertion location is outside the profile view,
the structure does not display in the profile view.
In the Structure Style dialog box, Display tab you can activate components to display connected pipes in
profile and section views.
Pipes can be represented to indicate the size/elevation where they are connected to the structure. Pipes
represent the true inside section of the pipe, and are exaggerated to the profile view scale in vertical.
NOTE The pipes are represented at the elevation of the pipe where they meet the structure, which is typically the
centerline.
To represent pipe network parts in a profile view
1 Make sure that the desired profile view is already created. See Profiles (page 1113) for more information.
2 Make sure that the pipe network parts you want to display in the profile view have already been created
in plan view, and have valid station offset data from the alignment they reference.
3 Select the profile view. Click Profile tab ➤ Launch Pad panel ➤ Draw Parts In View

.

4 In the drawing, select the pipe network parts you wish to add to the profile view, or enter E to select
an entire pipe network.
5 Select a profile view.
The pipe network parts are displayed in the profile view.
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Quick Reference
Ribbon
Profile tab ➤ Launch Pad panel ➤ Draw Parts In View
Menu
Pipes menu ➤ Edit Pipe Network
Command Line
AddNetworkPartsToProf

Displaying Pipe Networks in Section Views
You can display pipe network parts in section views.
To display pipe networks parts in a section view, the following data must exist:
■

Pipe network parts drawn in plan view

■

A sample line and section view containing pipe or structure crossings

■

Valid station offset data for the pipe network parts

Only the pipe network parts that cross the sample line are displayed in the section view.
NOTE The smoothness (tessellation) of curved edges of the pipes in section view is controlled by the FACETDEV
(Facet Deviation) system variable. The default value for FACETDEV will usually cause circular pipe sections to be
displayed with eight segments. If you set FACETDEV lower, the appearance of the pipe sections will become more
circular. For more information, see Networks in Profile and Section Views.
Pipes and structures that cross the sample line are displayed in the section view as a crossing version of the
part. This is unlike profile views where pipe network parts can be displayed both as projected and crossing
versions. See Displaying Pipe Crossings (page 1367) for more information.
Pipe objects that are displayed in a section view are displayed according to the style specified on the Sections
tab. Structures are displayed in a section view as a representation of the body of the part, even if only a
portion of the shape crosses the sample line.
When you use the Create Sample Line Group dialog box to create a sample line, you can select any and all
pipe networks in the drawing. However, only pipe network parts that actually cross the sample line are
displayed in the section view.
If you wish to display pipe network parts in a section view, a Pipe Network Section object gets created when
you create a sample line with pipe network parts that cross it. The Pipe Network Sections collection is
displayed under the Sample Line Groups collection in the Prospector tree. See Sections (page 1225) for more
information.
NOTE Network parts displaying in a section view are exaggerated vertically to match the vertical scale factor of
the view in which they are being represented.
To represent pipe network parts in a section view
1 Make sure the pipe network parts you want to display in the section view have already been created in
plan view and have valid station offset data associated with them.
2 Create the desired sample line and section view. See Sections for more information. The procedure is
similar to the procedure for creating surface sections.
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Displaying Pipe Crossings
Pipes that cross or intersect a profile view or section view are displayed as pipe crossings.
Pipes that cross or intersect a profile view can be displayed as projected, or as pipe crossings. Pipes that cross
or intersect a section view are always displayed as pipe crossings.
When a pipe is displayed as projected in a profile view, it is drawn as straight linework from pipe beginning
to pipe end. It is important to understand, however, that when a pipe is displayed in a profile view, depending
on the combination of horizontal and vertical geometry, the pipe will have some vertical deflections, even
when the pipe is actually straight with no change in grade along its length. This is especially true for curved
pipe. This is how AutoCAD Civil 3D displays pipe in profile views.
When plotting a cross section of a pipe network in AutoCAD Civil 3D, the location of an intersected pipe
is displayed at the correct elevation, but the same pipe displayed in a profile view may not show the same
elevation at that location due to the behavior described above.
The following illustration shows a pipe crossing and a projected pipe in a section view.

See also:
■

Displaying Pipe Networks in Profile Views (page 1364)

Pipe End Cleanup Option
You may need to clean up pipe to pipe connections displayed in plan or profile views.
This topic describes how to understand and use the pipe end clean up option that exists on the Plan and
Profile tabs of the Pipe Style dialog box.
Using this option, you can define a pipe style that either has this option selected (turned on or in use), or
not selected (turned off or not in use).
When this option is checked for plan views, the appearance of pipe to pipe connections in plan view is
cleaned up so that they more accurately represent the way pipe to pipe connections should look in plan
views.
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When this option is checked for profile views, the appearance of pipe to pipe connections in profile view is
cleaned up as follows:
■

The overlapping pipe ends are trimmed to the inside edges of the pipes when only the inside edges are
displayed, or when both the inside and outside edges of the pipes are displayed.

■

The outside edges of the pipes are trimmed only when the outside edges of the pipes are displayed (when
the inside edges of the pipes are not displayed).

The following illustration shows a profile of a pipe to pipe connection with the pipe end clean up option
turned on.

When this option is not checked, the appearance of pipe to pipe connections displayed in profile view is
not cleaned up. The following illustration shows a profile of a pipe to pipe connection with the pipe end
clean up option turned off.

By default, this option is not checked (turned off). But you can simply turn it on for existing (legacy) pipes
to have the pipe to pipe connections cleaned up.
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It is important to understand the following behavior regarding this option:
■

The pipe end clean up option can only be used when there is a null structure between two pipes.

■

This option behaves the same on straight and curved pipes displayed in profile views.

■

This option trims (removes) the overlapping pipe ends to the inside edges when only the inside edges
are displayed, or when both the inside and outside edges are displayed.

■

This option trims to the outside edges only when the outside edges are displayed (when the inside edges
are not displayed).

To clean up the appearance of pipe to pipe connections in profile views
1 Right-click on a pipe in a pipe to pipe connection and click Edit Pipe Style.
2 Click the Profile tab on the Pipe Style dialog box.
3 At the bottom of this dialog box, place a check mark next to the Clean Up Pipe To Pipe Connections
option.
4 Click OK.
In profile views, the pipe ends in pipe to pipe connections are trimmed (cleaned up).
To clean up the appearance of pipe to pipe connections in plan views
1 Right-click on a pipe in a pipe to pipe connection and click Edit Pipe Style.
2 Click the Plan tab on the Pipe Style dialog box.
3 At the bottom of this dialog box, place a check mark next to the Clean Up Pipe To Pipe Connections
option.
4 Click OK.
In plan views, the pipe ends in pipe to pipe connections are trimmed (cleaned up).

Checking for Interferences
Interference checking lets you quickly identify pipe network parts that may be in conflict with each other.
This feature compares the actual 3D model of parts to check for interferences. You can run an interference
check to identify pipe network parts that physically overlap, collide, or intersect in an inappropriate way,
or that have violated predefined, proximity-based criteria.
For example, you may want to run an interference check on one or more pipe networks to see if any parts
physically overlap or are too close to one another. You can select style-based visual markers to identify the
interferences, or you can choose to display the interferences as true, three-dimensional representations. You
may choose to leave the interference conditions as they are, or you may decide to resolve them by moving
parts in the drawing.
When you run an interference check, you can choose a single pipe network or you can choose two pipe
networks. When you run an interference check on a single pipe network, it check for interferences on parts
included in that network. When you choose to check two pipe networks, it checks for interferences between
the two pipe networks.
The following illustration shows two different pipe networks with structures that physically overlap. Running
an interference check would quickly indicate that these parts interference with one another.
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Another type of interference that can be detected is when two pipes intersect without a structure joining
them, as shown in the following illustrations:
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If desired, you can also perform a check for pipe network parts in their 3D representation that are too close
to one another, according to predefined distance or scale factor criteria. In the following illustration, the
two pipe networks shown are less than ten feet away from each other at the closest point, even though they
do not physically collide:

You can run an interference check that identifies parts in their 3D representation that are less than a specified
distance away from any part in the other network. The distance is checked in every direction surrounding
each part.
When you run an interference check, an Interference Check object gets created and is displayed in the
Prospector tree in the Pipe Networks ➤ Interference Checks collection. For more information, see Viewing
Interference Check Results (page 1375).

Proximity Checking Criteria
When you run an interference check, you can enable or disable 3D proximity checking criteria.
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If you enable the 3D proximity checking option on an interference check, you can identify pipe network
parts that are too close to one another in their 3D representation, according to a specified distance or a scale
factor. You can check a single pipe network or two pipe networks.
When you use proximity checking on a single pipe network, interferences are created for parts that are less
than a specified distance from one another. When you use this feature to check two pipe networks, an
interference is created for any parts from one network that are less than a specified distance or scale factor
from any parts in the second network.
You can use the 3D proximity check feature to ensure that the distance between two different types of utility
networks meets a certain requirement. For example, a sewer and water crossing typically requires that the
water line be a minimum of 18 inches above the sewer line. Running an interference check with the Use
Distance option set to 18 inches identifies any parts that were less than 18 inches away from the other pipe
network.
The following illustration shows how the distance and or the scale factor 3D proximity checking value is
used to determine proximity interference violations. The darker shaded outlines represent the actual parts
in the selected pipe network. The lighter shaded parts represent the area that is used to identify interferences.

Specifying a Distance
When you choose to enter a specified distance to perform the proximity check, you can enter a value that
is used to perform the proximity check. When you run the check, interferences are created for any pipe
network part that is less than the specified distance away from any other part in the specified network(s),
in any direction.

Specifying a Scale Factor
When you use the Use Scale Factor option is selected, you can enter a value that is used as a scale factor.
When you enter a scale factor value, AutoCAD Civil 3D calculates the limits of the part (the pipe or the
structure) multiplied by the scale factor value that is specified. For example, if the pipe diameter is 600mm,
and you specify a scale factor value of 2, AutoCAD Civil 3D identifies any interferences within a distance of
1200mm (or the pipe diameter, which is 600, multiplied by the scale factor value, which is two). When the
interference check is run, any pipe network parts within that distance away from each other (in any direction)
are marked as an interference.
To define 3D proximity check criteria
1 In the Create Interference Check dialog box, click 3D Proximity Check Criteria.
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2 In the Criteria (page 2308) dialog box, click Apply 3D Proximity Check to enable this feature.
3 Do one of the following:
■

Click Use Distance to enter a distance. When the interference check is run, interferences are created
for any pipe network part that is less than the specified distance away from any other part in the
specified network(s).

■ Click Use Scale Factor to enter a scale factor. When the interference check is run, any pipe network

parts within that distance away from each other (on any side) are marked as an interference.
4 Click OK in the Criteria dialog box.
5 Click OK in the Create Interference Check dialog box to run the interference check.
The following prompt is displayed:
Interference check created. Number of interferences found: X.
6 Click OK at this prompt.
To view the results, in Toolspace, on the Prospector tab, expand the Interference Checks collection, and
then select the interference check. The Interference Check data is displayed in the Panorama window and
Toolspace item view. See Viewing Interference Check Results (page 1375) for more information.

Quick Reference
Toolspace Shortcut Menu
Prospector tab: Pipe Networks ➤ Interference Checks ➤ Create Interference Check
Dialog Box
Criteria (page 2308)

Running an Interference Check
Run an interference check to identify parts in a pipe network that collide or violate proximity criteria.
You can check for interferences on a single pipe network, or you can check two pipe networks to determine
if parts collide or violate proximity criteria.
To run an interference check on a single pipe network
1 Click Analyze tab ➤ Design panel ➤ Interference Check

.

2 In the drawing, click any part in the pipe network.
3 Click again on the same part in the pipe network or on any other part in the same pipe network.
4 In the Create Interference Check dialog box, in the Name field, specify a name for this interference
check, or accept the default.
5 Optionally, enter a description in the Description field.
6 Specify the pipe network(s) for this interference check using the Network 1 and Network 2 fields.
These should be the same pipe network(s) that you clicked in step 3. If desired, you may change the
pipe network(s) here.
To run an interference check on a single pipe network, make sure the same pipe network name is
displayed in the Network 1 and Network 2 fields.
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7 Specify the layer the interference check results will be displayed on.
8 Specify an interference style and a render material.
9 If you want the interference check to identify pipe network parts that are too close to one another,
using a specified distance or scale factor, click the 3D Proximity Check Criteria button.
10 To use proximity checking options, in the Criteria dialog box, click Apply 3D Proximity Check, and
then do one of the following:
■

Click Use Distance and enter a distance. When the interference check is run, interferences are created
for any pipe network parts that are less than the specified distance away from each other (on any
side).

■

Click Use Scale Factor and enter a scale factor. When the interference check is run, interferences are
created for any pipe network parts that are less than the specified scale factor distance away from
each other (on any side).

11 Click OK in the Criteria dialog box.
12 Click OK in the Create Interference Check dialog box to run the interference check.
The following prompt is displayed:
Interference check created.
Number of interferences found: X
13 Click OK at this prompt.
To view the results, in Toolspace, on the Prospector tab, expand the Interference Checks collection, and
then select the interference check. The Interference Check data is displayed in the Panorama window and
Toolspace item view. See Viewing Interference Check Results (page 1375) for more information.
To run an interference check between two pipe networks
1 Click Analyze tab ➤ Design panel ➤ Interference Check

.

2 In the drawing, click any part in the first pipe network.
3 Click any part in the second pipe network.
4 In the Create Interference Check dialog box, in the Name field, specify a name for this interference
check or accept the default.
5 Optionally, enter a description in the Description field.
The Network 1 and Network 2 fields display the names of the pipe networks previously selected. If
desired, you can use these fields to change the pipe networks for this interference check.
6 Specify the layer the interference check results will be displayed on.
7 Specify an interference style and a render material.
8 If you want the interference check to identify pipe network parts that are too close to one another,
using a specified distance or scale factor, click 3D Proximity Check Criteria.
9 To use proximity checking options, click Apply 3D Proximity Check on the Criteria dialog box, and
then do one of the following:
■

Click Use Distance to enter a distance. When the interference check is run, interferences are created
for any pipe network parts that are less than the specified distance away from each other (on any
side).
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■

Click Use Scale Factor to enter a scale factor. When the interference check is run, interferences are
created for any pipe network parts that are less than the specified scale factor distance away from
each other (on any side).

10 Click OK in the Criteria dialog box.
11 Click OK in the Create Interference Check dialog box to run the interference check.
The following prompt is displayed:
Interference check created.
Number of interferences found: X
12 Click OK at this prompt.
To view the results, in Toolspace, on the Prospector tab, expand the Interference Checks collection, and
then select the interference check. The Interference Check data is displayed in the Panorama window and
Toolspace item view. See Viewing Interference Check Results (page 1375) for more information.

Quick Reference
Ribbon
Analyze tab ➤ Design panel ➤ Interference Check
Toolspace Shortcut Menu
Prospector tab: Pipe Networks ➤ Interference Checks ➤ Create Interference Check
Dialog Box
Create Interference Check (page 2307)

Viewing Interference Check Results
After running an interference check, view the results in the drawing or by looking at the data in the Toolspace
list view.
In the drawing, interferences are displayed according to the choices defined in the Interference and Render
Material options specified on the Create Interference Check dialog box. These choices are also displayed on
the Information tab of the Interference Check Properties dialog box.
To view interference data in the list view, in Toolspace, on the Prospector tab, expand the Pipe Networks
➤ Interference Checks collection. Click on the Interference Check object in the Prospector tree. The
interference data is displayed in the list view. You can right-click on the status column and Zoom To an
interference in the drawing. If you choose Delete, it deletes only the interference, not the part. In this view,
you can also right-click an interference and select Properties to display the Interference Properties dialog
box.

Updating an Interference Check
Update an interference check after pipe network parts have been changed.
An interference check is marked as out of date
when any pipe network part in the interference check is
changed. Even changing a description on a pipe network part that is not in interference causes an interference
check to become out of date. So does moving, deleting, or adding parts to any network included in the
interference check.
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NOTE Out-of-date icons are displayed only if the Toolspace drawing item modifier icon
more information, see Drawing Item Modifier Icons (page 161).

display is active. For

When you update an interference check, you can leave the interference checking conditions as they are
currently set, or you can change them before rerunning the check.
Use the Interference Check Properties dialog to change interference check options, criteria, and other
properties.
To update an interference check
1 In Toolspace, on the Prospector tab, expand the Pipe Networks ➤ Interference Checks collection.
2 Right-click the interference check and click Rerun Interference Check.
The following prompt is displayed:
Interference check created.
Number of interferences found: X
3 Click OK.
The interference check data is updated in the drawing and in the Prospector tree.
To change interference check conditions or properties
1 In Toolspace, on the Prospector tab, expand the Pipe Networks ➤ Interference Checks collection.
2 Right-click the interference check and click Interference Check Properties.
3 Change information about the Interference Check Properties (page 2309) dialog box and click Apply to
save the changes.
4 Click OK to accept all changes and rerun the interference check.
The following prompt is displayed:
Interference check created.
Number of interferences found: X
5 Click OK.
The interference check data is updated in the drawing and in the Prospector tree.

Quick Reference
Toolspace Shortcut Menu
Prospector tab: Pipe Networks ➤ Interference Checks ➤ Create Interference Check
Dialog Box
Criteria (page 2308)

Setting Interference Styles
You can create styles to display interference conditions in your drawing.
Like other AutoCAD Civil 3D style features, you can set color, size, layer and other styles for interferences.
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You can create different interference styles to use for various types of interferences. For example, you can
create an interference check and an interference style to specifically identify parts that are too close to one
another (but not overlapping), displaying these parts in a certain color.
Use the Pipe Network ➤ Interference Style collection on the Settings tab to create and manage interference
styles.
To create interference styles
1 In Toolspace, on the Settings tab, expand the Pipe Network collection, then expand the Interference
Styles collection, and click New.
The Interference Style (page 2312) dialog box is displayed.
2 Click the Information tab, enter a name for the interference style and, optionally, a description.
3 Click the View Options tab (page 2312) and set interference style options for symbols (markers) and solids
that represent interferences.
4 Click the Display tab (page 2312) and set the display style options.
5 Click OK to save changes and close this dialog.

Quick Reference
Toolspace Shortcut Menu
Settings tab: Pipe Network ➤ Interference Styles ➤ New
Dialog Box
Interference Style (page 2312)

Deleting Interference Checks
You can easily delete interference checks.
Once you have finalized your drawing or pipe network layout, you may want to delete interference checks
from the Prospector tree. When you delete an interference check, it is removed from the Prospector tree.
Any visual markers displayed in the drawing to indicate interferences are also removed.
To delete an interference check
1 In Toolspace, on the Prospector tab, expand the Pipe Networks ➤ Interference Checks collection.
2 Right-click the interference check and click Delete.
A verification prompt asks if you are sure you want to delete the interference check.
3 Click Yes.
The interference check object is deleted from the Prospector tree. Any visual markers for the interference
checking displaying in the drawing are also deleted.

Quick Reference
Toolspace Shortcut Menu
Prospector tab: Pipe Networks ➤ Interference Checks ➤ Delete
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Part Properties
Use the Pipe Properties dialog box and the Structure Properties dialog box to view or edit properties associated
with any given pipe network part.
Part properties define a variety of characteristics of the part, including the part family the part belongs to,
a part type, and properties defining the part’s size, shape, elevation, automatic resizing behaviors, and other
behaviors. Part properties originate from definitions of the part in the part catalog.
After you insert a part into a drawing, you can edit many of its properties. Those changes apply only to the
currently selected part in the drawing. For example, once you add a structure, such as a manhole, to a
drawing, you can change the structure’s inside diameter by editing the value for the Inner Structure Diameter
property, in the Part Data collection, on the Part Properties tab. The default value for the structure’s Inner
Structure Diameter property that is maintained in the part list (or the part catalog) is not affected.
Part properties are organized into the following categories:
Category

Description

General

These properties specify the surface and alignment
referenced by the part. For pipes, there are properties that specify flow direction. For structures,
the structure elevation at its insertion point is
specified.

Geometry

For pipes, these properties specify general characteristics of the pipe, such as the flow direction
method, flow direction, and the surface and
alignment referenced. For structures, these properties specify characteristics such as the structure’s
rotation angle, offset, station data, and the number of pipes that are currently connected to the
structure.

Resize Behavior

The resize behavior property is specific to pipes.
It specifies the behavior that occurs when the pipe
is automatically resized. You can choose to have
the pipe hold to its crown, invert, or centerline
elevation when it is resized.

Hydraulic Properties

For both pipes and structures, these properties
specify hydraulic information, such as hydraulic
grade lines and energy grade lines, the pipe network may have received from the Storm Sewers
Extension. For more information, see Adding Hydraulic Property Data to AutoCAD Civil 3D Pipe
Networks (page 1424).

Insertion (Rim) and Sump Behavior

These properties are associated with junction
structures only. They specify the structure’s insertion point (structure rim) and sump elevation and
adjustment behavior.

Part Data

For both pipes and structures, these properties
specify a variety of part characteristics, such as
part type, part subtype, and the part size name
as defined in the part catalog. Some of these
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Category

Description
properties define the part’s basic primitive shape
and behavior, and therefore are read-only.

The Pipe Properties and the Structure Properties dialog boxes have the following tabs:
■

Information. Specifies the name, description, object style, and object render material assigned to the pipe
or structure object.

■

Part Properties. Displays a list of properties that exist for this part. These properties define the basic size
and shape of the part, as well as the part family the part belongs to. This section also specifies hydraulic
properties for the pipe network, if they exist. You can edit values for certain properties on this tab.

■

Rules. Displays a list of the rules that are associated with the part. These rules originate from the default
rule of the part in the part catalog. You can edit the part’s rules once you have inserted the part into a
drawing. Rules are used to validate certain properties of the part, and also to determine elevation during
layout, and during certain editing commands.

The Structure Properties dialog box has the following additional tab for viewing data about pipes connected
to the structure:
■

Connected Pipes. Displays a list of each pipe connected to the structure, and property values for each
pipe. You can edit values for certain properties, such as elevation data, on this tab. It’s very useful for
quickly editing elevations, slopes, diameters or descriptions for multiple pipes connected to a structure.

See also:
■

Part Rules (page 1390)

■

Pipe Properties Dialog Box (page 2275)

■

Structure Properties Dialog Box (page 2288)

NOTE Changes made to either the Pipe Properties or the Structure Properties dialog box affect only the selected
part in the drawing. It does not affect the part definition in the part catalog or in a parts list.
To edit pipe or structure properties
1 Right-click a pipe or structure in the drawing. Click either Pipe Properties or Structure Properties.
2 In either the Pipe Properties or the Structure Properties dialog box, click the Part Properties tab (page
2276).
3 Click a property value, edit it, and click Apply or OK to save changes.
For example, to change the inner diameter of a structure, scroll to the Part Data property group, click
the value for the Inner Structure Diameter property, and select a new value.
4 Click Apply or OK to save changes.
For more information, see Part Properties (page 1378).
NOTE Changes made to either the Pipe Properties or the Structure Properties dialog box affect only the selected
part in the drawing. It does not affect the part definition in the part catalog or in a parts list.
To edit pipe or structure rules
1 Right-click a pipe or structure in the drawing. Click either Pipe Properties or Structure Properties.
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2 In either the Pipe Properties or the Structure Properties dialog box, click the Rules tab (page 2280).
3 Click the desired property value in the Value column, enter a new value, and press Enter.
4 Click Apply or OK to save changes.
For more information, see Part Rules (page 1390).

Quick Reference
Command Line
EditPipeProperties or EditStructureProperties
Dialog Box
Pipe Properties Dialog Box (page 2275)
Structure Properties Dialog Box (page 2288)

Part Catalog and Parts Lists
The pipe networks feature references a part catalog and a parts list that define the size, shape, and certain
behavior of the parts (pipes and structures) you insert into drawings.

Part Catalog
The AutoCAD Civil 3D part catalog contains definitions for all the pipe network parts that you can insert
into a drawing. It is organized at the top level into two basic domains — one for pipe parts, such as cylindrical
or rectangular pipes, and another for structure parts, such as headwalls, catch basins, and so on.
Part catalog content is further organized into types, subtypes (also referred to as shapes), and part families.
The following table illustrates how the default part catalogs are organized for pipe parts and structure parts.
Part Domain

Part Type

Part Shape

Part Family

Pipes

Pipe

Circular

Concrete
Ductile Iron
PVC

Egg-Shaped

Concrete

Elliptical

Concrete
Concrete Horizontal

Rectangular

Concrete Box

Inlet-Outlet

Rectangular

Concrete Variable Height
Concrete

Junction with
Frames

Rectangular

Slab Top Circular Frame
Slab Top Rectangular Frame
Two-Tier Circular Frame

Cylindrical

Slab Top Circular Frame
Concentric
Eccentric
Eccentric Two-Tier Circular Frame

Structures
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Part Domain

Part Type

Part Shape

Part Family

Junction without
Frames

Rectangular

Rectangular

Cylindrical

Concentric
Cylindrical

The files that make up the part catalog content are typically installed to this location: C:\Documents and
Settings\All Users\Application Data\AutoCAD\C3D2011\enu\Pipes Catalog.
NOTE The pipe network part catalog is not related to the corridor (subassembly) catalogs that are available
through the Content Browser. Also note that pipe network parts cannot be accessed through a Tool Palette.

Parts List
A parts list contains a set of pipe network parts – pipes and structures – that you can use in a pipe network.
You have parts lists so that you do not have to navigate through the entire part catalog looking for the
specific pipe network part that you need.
When you open a new blank drawing by selecting a AutoCAD Civil 3D drawing template, you will typically
find default parts lists available, such as Standard. You can create your own parts lists to suit the needs of
each project. For example, you may want to create a parts list that contains only the types of parts you will
use in a particular project or pipe network. This saves you from having to navigate through the entire part
catalog to select a part. While there is only one pipe network part catalog included with AutoCAD Civil 3D,
you can create multiple parts lists for your projects.
A parts list also serves as a way to store defaults, such as styles, render materials and design criteria (rules)
to any given part upon creation. Parts lists are objects that you can access through the Pipe Network Properties
dialog box, the Pipe Network Layout Tools toolbar, and the Toolspace Settings tree.
NOTE You can also create a Full Parts list that contains all of the parts that exist in the current metric or imperial
part catalog. For more information, see Creating a Full Parts List (page 1382).

Creating a Parts List
You can create a parts list that contains only the parts (pipes and structures) you will need on a specific pipe
network, drawing, or project.
A part list is a subset of available parts in a catalog. It provides quick access to just the parts you need for a
specific project.
You can create a parts list by copying an existing parts list and editing it, by creating a new parts list from
scratch, or by dragging and dropping a parts list from one drawing into another drawing.
To create a parts list
1 In Toolspace, on the Settings tab, expand the Pipe Networks collection, right-click Parts List, and click
New. The Network Parts List (page 2271) dialog box is displayed.
2 Click the Information tab, enter a name for the parts list and, optionally, a description.
3 Click the Pipes tab to add pipe parts to this parts list, or the Structures tab to add structure parts.
4 On either the Pipes tab or the Structures tab, right-click the parts list name at the top of the Name field
and click Add Part Family. The Part Catalog dialog box (page 2273) dialog box is displayed.
5 In the part catalog, click the check box next to the part families you want to add, and click OK.
6 Click Apply on the Pipes tab or the Structures tabs to save the changes.
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7 On either the Pipes tab or the Structures tab, right-click a part family and click Add Part Size. The Part
Size Creator dialog box is displayed.
8 To add individual sizes of the part, click on and highlight the rows you want to add.
NOTE For many part definitions, optional properties are available to the part. For more information, see
Assigning Optional Properties to a Part Size (page 1385)
9 To add all available sizes of the part, place the check mark in the Add All Sizes check box. For more
information about adding sizes, see the Part Size Creator (page 2300) dialog box.
10 Click OK on the Part Size Creator dialog box.
11 Click Apply to save changes on the Network Parts List dialog box.

Quick Reference
Toolspace Shortcut Menu
Settings tab: Pipe Networks ➤ Parts List ➤ New
Dialog Box
Network Parts List (page 2271)

Creating a Full Parts List
You can create a parts list that contains all of the part types and associated sizes that exist in the currently
selected metric or imperial part catalog.
It may be useful for you to create this master parts list (full catalog) if you are planning to import pipe
networks from LandXML or from the Storm Sewers Extension.
Once the full parts list is created, that is the parts list that you would use when importing pipe network data.
During import, using a full a parts list that contains all of the parts that are available in the catalog can
sometimes be the best option for ensuring that appropriate part types and sizes will be found when you
import pipe network data.
After creating a full parts list, you may want to configure the Storm Sewers migration settings to always use
this full parts list during import. For more information, see Setting the Default Parts List For Migration (page
1420).
NOTE It is recommended that you do not use the full parts list while manually laying out (creating by layout)
new pipe networks or while editing existing pipe networks. Because the full parts list contains several thousand
parts, navigating for parts using this large volume of available part types could be time consuming. The
CreateFullPartsList feature is intended primarily to support pipe network data import.
To create a full parts list
1 On the Home tab, click Toolspace ➤ Settings tab, expand the Pipe Network collection, and then expand
the Parts Lists collection. Note the names of the existing parts lists displayed in the Settings tree.
2 Do one of the following:
■

From the ribbon, click the Modify tab ➤ Pipe Network ➤ Network Tools panel ➤ Parts List
drop-down menu ➤ Create Full Parts List

■

At the command line, enter CreateNetworkPartsListFull and then press Enter.
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The new full parts list is created. By default, this parts list is named Full Catalog. You may want to rename
this to suit your needs.
To configure the Storm Sewers migration settings to always use this full parts list during import, see Setting
the Default Parts List For Migration (page 1420).

Quick Reference
Ribbon ➤ Modify Tab
Modify ➤ Pipe Network ➤ Pipe Networks Contextual Tab ➤ Network Tools panel ➤ Parts List ➤ Create
Full Parts List
Ribbon ➤ Pipe Networks Contextual Tab
Pipe Networks tab ➤ Network Tools panel ➤ Parts List ➤ Create Full Parts List
Command Line
CreateNetworkPartsListFull

Copying a Parts List
You can copy an existing parts list in your drawing and give it a new name, or you can copy a parts list from
one drawing to another.
To copy a parts list in a drawing
1 In Toolspace, on the Settings tab, expand the Pipe Network collection, then expand the Parts Lists
collection.
2 Right-click on the parts list you want to copy and click Copy. The Network Parts List (page 2271) dialog
box is displayed. A copy of the parts list is created, with Copy of appended to the parts list name.
3 Click the Information tab, change the name for the parts list and, optionally, enter or change the
description.
4 Click Apply to save changes.
5 Click the Pipes tab to add or remove pipe parts to this parts list, or the Structures tab to add or remove
structure parts.
6 On either the Pipes tab or the Structures tab, right-click the parts list name at the top of the Name field
and click Add Part Family. The Part Catalog dialog box (page 2273) dialog box is displayed.
7 In the part catalog, click the check box next to the part families you want to add, and click OK. Note
that only part families that are not already included in the current parts list are displayed in the part
catalog so that you cannot add the same part family twice in one parts list.
8 Click Apply on the Pipes tab or the Structures tabs to save the changes.
9 On either the Pipes tab or the Structures tab, right-click a part family and click Add Part Size. The Part
Size Creator dialog box is displayed.
10 To add individual sizes of the part, click on and highlight the rows you want to add.
NOTE For many part definitions, optional properties are appended to the part name. For more information,
see Assigning Optional Properties to a Part Size (page 1385)
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11 To add all available sizes of the part, place the check mark in the Add All Sizes check box. For more
information about adding sizes, see the Part Size Creator dialog box (page 2300).
12 Click OK on the Part Size Creator dialog box.
13 Click Apply to save changes on the Network Parts List dialog box.
To copy a parts list from one drawing to another
1 With two drawings open, in the first drawing, in Toolspace, on the Setting tab, expand the Pipe Networks
collection, and then expand the Parts Lists collection.
2 Select the desired parts list, drag it (click and hold) to anywhere in the drawing area of the second
drawing, and then release the mouse cursor (drop).
3 In the second drawing, click the Settings tab, expand the Pipe Network collection, and then expand
the Parts Lists collection to see the new parts list.

Adding a Part Family to a Parts List
Add a part family from the pipe network part catalog to a parts list.
After adding a part family, you must select desired part sizes. If you add a part family but do not select the
part sizes, part family content is not displayed in the parts list.
To add a part family to a parts list
1 In Toolspace, on the Settings tab, expand the Pipe Network collection, and then expand the Parts Lists
collection.
2 Right-click the desired parts list and click Edit Parts List. The Network Parts List dialog box is displayed.
3 Click the Pipes tab to add a pipe part family to this parts list, or the Structures tab to add a structure
part family.
4 On either the Pipes or the Structures tab, in the Name column, expand the parts list to view the part
families that are currently included.
5 Right-click the name of the parts list at the top level and click Add Part Family. The Part Catalog (page
2273) dialog box is displayed.
NOTE Part families that are included in the current parts list are not displayed in the part catalog. Only part
families that are available to be added to the current parts list are displayed in the part catalog.
6 In the part catalog, select the part families you want to add, and click OK.
7 Click OK or Apply on either the Pipes tab or the Structures tab to save the changes.
After you have added one or more part families to the parts list, the next step is to select the part sizes you
want. See Adding Part Sizes to a Parts List (page 1385).

Quick Reference
Toolspace Shortcut Menu
Settings tab: Pipe Network ➤ Parts Lists ➤ <parts list name> ➤ Edit Parts List
Dialog Box
Network Parts List (page 2271)
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Adding Part Sizes to a Parts List
After a part family is added to a parts list, select the part sizes you want to be available in that part family.
When creating new parts lists, you first add the part families, and then add the part sizes that you want to
be available within that family.
For example, for the Elliptical Concrete Pipe family, you can add only the part size of 8-inch inner pipe
width, or you can click Add All Sizes to add all of the size choices that are available in the drop-down list
for the inner pipe width value (for example, 8, 12, 18, etc.).
If you do not add part sizes within a part family, no content is displayed for that part family in the parts
list.
For existing parts lists, you can add part sizes at any time.
To add part sizes to a parts list
1 In Toolspace, on the Settings tab, expand the Pipe Network collection, and then expand the Parts Lists
collection.
2 Right-click the desired parts list and click Edit Parts List. The Network Parts List dialog box is displayed.
3 Click the Pipes tab to add sizes for pipe parts, or the Structures tab to add sizes for structures.
4 Expand the parts list so that you can see the part families that are currently included.
5 Right-click a part family and click Add Part Size. The Part Size Creator dialog box is displayed.
6 Use the Part Size Creator (page 2300) dialog box to add part sizes to the current part family.
You can select existing sizes one at a time, or you can use the Add All Sizes check box. For example, for
the Elliptical Concrete Pipe part family, you can add only the part size of “8-inch inner pipe width”,
or you can check Add All Sizes to add all the size choices that are available in the drop-down list
simultaneously: for example, 8, 12, 18, and 24.
7 For each part size that is added, you may also add optional properties which are not defined in the part
family.
For example, to specify a material for a pipe, add the optional Material property and enter the desired
text to set the property. For more information, see Assigning Optional Properties to a Part Size (page
1385).
8 Click OK on the Part Size Creator dialog box.
9 Click OK or Apply on either the Pipes tab or the Structures tab to save the changes.

Assigning Optional Properties to a Part Size
To add further definition to a part, such as a name for a material, you can assign optional properties to a
part size definition in a parts list.
After an optional property is assigned to the part, the property may be viewed or edited in the Part Properties
tab (page 2276) of either the Pipe Properties or the Structure Properties dialog box, viewed or edited in the Pipe
Network Vistas (page 2302), or it can be displayed as labeling text for the part in the drawing.
An example of an optional property is the Material property available for the Concrete Pipe part family. You
can assign this optional property to part sizes within the Concrete Pipe part family.
To add an optional property to a part size
1 In Toolspace, on the Settings tab, expand the Pipe Network collection, and then expand the Parts Lists
collection.
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2 Right-click the desired parts list and click Edit Parts List. The Network Parts List dialog box is displayed.
3 Click the Pipes tab to assign an optional property to a pipe part size, or the Structures tab to assign an
optional property to a structure part size.
4 On either the Pipes tab or the Structures tab, in the Name column, expand the parts list so that you
can see the part families that are currently included.
5 Right-click the desired part family and select Add Part Size.
6 The Part Size Creator Dialog Box (page 2300) is displayed. The optional properties are identified in the
Source field.
7 If the optional property can be assigned, you can click in the Value field and set the property from a
list of choices. If the optional property has a static value, no choices are available.
8 Click in the Value field to select and assign the property.
9 Click OK on the Part Size Creator dialog box.
10 Type in the value or string.
11 Click OK or Apply on the Pipes or Structures tabs to save the changes.
NOTE All optional properties available for a part family can be set, even after the part has been created, by
displaying the Pipe Properties or Structure Properties dialog box.
To add a user-defined property to a network part
1 Navigate to the Part Parameter Configuration xml file (AeccPartParamCfg.xml). The default location is
C:\Documents and Settings\All Users\Application Data\Autodesk\AutoCAD <version>\enu\Pipes Catalog\Aecc
Shared Content.
2 Open the file and select View ➤ Source in order to modify the file.
3 Navigate to the <AeccParamDeclaration> section. A sample optional property is the Hazen Williams
Coefficient flow analysis. The entry for this is: <AeccDfParameter name="ACHW" desc="Hazen Williams
Coefficient" context="FlowAnalysis_HazenWilliams" index="0" datatype="Float" usage="Double_General"
unit="" visible="True" internal="True"/>.
4 Copy an existing optional property and make changes as appropriate to create a new property.
5 In the <AeccParamUsage> section, the corresponding entry for the sample in step 3 is <AeccOptParam
context="FlowAnalysis_HazenWilliams"/>. Copy and modify an entry as appropriate to create an new
entry for your property.
6 Save and close the xml file.

Setting the Pipe Network Part Catalog
You can configure AutoCAD Civil 3D to access the imperial or the metric pipe network part catalog, or to
access specific folders for pipe and structure parts content.
The part catalog contains the definitions for all the pipe network parts that you can insert into a drawing.
The default part catalog location is C:\Documents and Settings\All Users\Application
Data\AutoCAD\C3D2011\enu\Pipes Catalogs.
To set the pipe network part catalog
1 Click Home tab ➤ Create Design panel
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Set Pipe Network Catalog

.

2 On the Pipe Network Catalog Settings dialog box, click the folder icon to browse to the location of the
pipe network catalog folder. This is the top-level folder containing all the pipe network part catalogs.
For example, this folder contains subfolders for imperial and metric pipes and structures.
The default part catalog location is C:\Documents and Settings\All Users\Application
Data\AutoCAD\C3D2011\enu\Pipes Catalogs.
3 Select the desired folder and click Open.
4 You may want to specify different pipe and structure catalogs, if they are available.
5 Click OK to save changes to this dialog box.

Quick Reference
Ribbon
Home tab ➤ Create Design panel

Set Pipe Network Catalog

Menu
Pipes menu ➤ Set Pipe Network Catalog
Command Line
SetNetworkCatalog
Dialog Box
Pipe Network Catalog Settings (page 2301)

Editing Part Family Sizes
Use the Part Builder feature to change the part sizes that are available in a part family.
If a part family does not have the sizes you need, you can modify the part family sizes using the Part Builder
feature.
To edit part sizes in a part family
1 Enter PartBuilder at the command line and press Enter.
2 Select Pipe or Structure from the Part Catalog drop-down list.
3 Using the catalog tree, locate and select the Part Family you want to edit.
NOTE Pipe and structure families are organized by type. For example, pipe families are organized into types
such as circular pipes, egg-shaped pipes, and so on. Structure families are organized into inlet-outlet structures,
junction structures with frames, and so on.
4 Click the Modify Part Sizes button
window.

, or double-click the Part Family, to display the Part Family browser

5 If this is a Part Family that shipped with AutoCAD Civil 3D, click the Save Part Family As button
the Part Family browser window toolbar

in

6 In the Save Part Family As dialog box, enter a new Part Name and Part Description and then click OK.
This creates your own version of the selected Part Family you can edit.
7 In the Part Family browser window, right-click the Size Parameters node, and click Edit Values.
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8 In the Edit Part Sizes dialog box, find the parameter (property) value(s) you want to edit.

9 Edit the values as described below:
Pipe values
■

To change values for pipe sizes, select the row and size cell. Double-click to edit.

■

To delete a size row, select the row and click the Delete button

■

To add a size row, select the closest size and click the New button
box, and then edit the values in the new row.

on the Edit Part Sizes dialog box.
on the Edit Part Sizes dialog

Structure values
■

To edit list values for structure sizes, select the cell and click the New button
Sizes dialog box.

on the Edit Part

10 After you have completed editing sizes, click OK on the Edit Part Sizes dialog box.
11 In the Part Family browser window toolbar, click the Save Part Family button
12 When finished editing part sizes, close the Part Builder by clicking the close
right corner of the Part Family browser window.

.
button in the upper

13 You will be prompted to save the part family with the following dialog box. Click Yes at this prompt.
14 Next, you may be prompted to save the part family drawing file with the following dialog box. Click
No at this prompt.
The new part family and the new part sizes you create will be available through the Network Layout Tools
toolbar.
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Sample Part Family Size Editing
This sample exercise walks you through how to edit the part sizes that are available in a part family.
In this example, you will edit the Pipe Inner Diameter (PID) and Wall Thickness (Wth) values in the Concrete
Pipe part family.
To edit part sizes in the Concrete Pipe part family
1 Enter PartBuilder at the command line and press Enter.
2 Click the Part Catalog drop-down list and select Pipe.
3 In the catalog tree, expand the Circular Pipes node, then select the Concrete Pipe part family.
4 Double-click the Concrete Pipe part family or click the Modify Part Sizes button
5 Click the Save Part Family As button

.

.

6 In the Save Part Family As dialog box, enter a new Part Name and Part Description for this new part
family and then click OK. This creates your own version of the selected Part Family you can edit.
7 In the Part Family browser, right-click the Size Parameters node, and click Edit Values.

8 In the Edit Part Sizes dialog box, click the Autosize Column Text button then find the Pipe Inner
Diameter (PID) value and the Wall Thickness (WTh) values.
9 Select any row in the table and click the New button
row is copied to the table.

on the Edit Part Sizes dialog box. The selected

10 In the new table row, edit the PID and WTh values by double-clicking on them and typing in the new
values.
11 After you have completed editing sizes, click OK on the Edit Part Sizes dialog box.
12 In the Part Family browser window toolbar, click the Save Part Family button

.

13 When finished editing part sizes, close the Part Builder by clicking the close
right corner of the Part Family browser window.

button in the upper

14 You will be prompted to save the part family. Click Yes at this prompt.
15 Next, you may be prompted to save the part family drawing file. Click No at this prompt.
The new part family will not be available when creating or editing a pipe network until you edit the
parts list and add this new part family to your parts list. For more information, see Adding a Part Family
to a Parts List (page 1384)
Once you have added the new part family to your parts list, the new part family and the new part sizes you
created will be available through the Network Layout Tools toolbar.
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Viewing Part Catalog Content
Use an Internet Explorer window to view content from a published part catalog.
The Internet Explorer view shows an image of the 2D or 3D shape and lists all the defined values associated
with the part family. For example, all size parameters, whether defined as table, list, range, and or calculated
values (formulas), can be viewed in a read-only mode. Constant values, such as the part domain, type,
subtype, part name, description, and the ID associated with the part, are all displayed.

To view published part catalog content using Internet Explorer
1 Using Internet Explorer, navigate to the location of the part catalog, for example, C:\Documents and
Settings\All Users\Application Data\Autodesk\C3D2011\enu\Pipes Catalog\US Imperial Structures.
2 Double-click the name of the desired part catalog, for example, US Imperial Structures.htm.
3 In the left pane catalog tree, expand a node and then select a part family.
For example, expand the Junction Structures With Frames node, and then select the
AeccStructEccentricCylinder_Imperial part family.
Content for the selected part family is displayed in the right pane.

Part Rules
Part rules are properties that affect how pipe network parts behave on creation and when you move or edit
them.
AutoCAD Civil 3D pipe network objects use part rules in the following ways:
■

To determine elevations for pipes and structures when they are created.

■

To determine how pipes connect to junction structures.

■

To warn that certain criteria is not met while creating or editing pipe networks.

Primarily, part rules automatically determine reasonable elevations for parts as they are created. The specific
elevation behavior you see is based on choices you make, such as how you define the minimum slope,
minimum cover, and desired drop across a structure. Rules also provide automatic validation of your pipe
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network design, such as checking to see if a structure is too small to accommodate a pipe size, if the length
of a pipe is greater than desired, or the maximum cover above a pipe is exceeded.
Rules provide an excellent way to give a good starting point for design. They also provide a way to quickly
determine if the location of a series of pipes and structures is actually constructible.
Rules are applied to parts automatically as they are created. However, you can reapply rules to existing parts
in your drawing as needed. Reapplying rules ensures that unintended changes are not made. For example,
if you move a structure that has pipes connected to it, you may want to reapply rules after moving the
structure to ensure that the pipes connected to it still have the desired elevations, minimum cover, and do
not exceed a maximum length.
The pipe network rules features provides a high level of design automation, while still allowing you to specify
the design according to your judgment and site-specific requirements. When rule parameter values are
violated on pipe network parts in the drawing, you can quickly review the violations and determine if you
need to edit the drawing or simply allow the rule violations.
NOTE It is important to note that rules are not applied to pipes or structures when importing pipe networks from
either LandXML or from the Storm Sewers Extension. For more information about rules, see Part Rules (page 1390).

Default Rule Behavior
The default rule behavior for pipe network parts is designed to meet the needs of some typical design
scenarios. You can lay out a pipe network without editing, removing, or adding part rules, and this behavior
may suit your needs. If you want to change the default rule behavior, you can do so by edit part rule values,
or by adding or removing rules from a part using Rule Sets. See Editing Part Rules (page 1401) for more
information.
The default pipe network rule behavior in AutoCAD Civil 3D is controlled by the following files:
■

C3DPipeRules. This Visual Basic script file is similar in design and architecture to the script file that
controls AutoCAD Civil 3D subassembly behavior for corridor modeling.

■

C3DPipeRules.xml. This file defines the pipe network part rule parameters and rule names.

These files are located in located in the \data folder. The \data folder installed to \\Documents and Settings\All
Users\Application Data\Autodesk\C3D2011\enu\data by default.

Rules and Parts Lists
Each part in a pipe network parts list references a set of pre-defined rules. When a pipe or structure is inserted
into a drawing, the rule set is referenced by the part itself. Therefore, changes made to the part in the part
catalog, or removing a part from the parts list, will have no effect on a part that has already been inserted
into a drawing.

Rule Sets
A default “rule set” exists for both pipes and structures that are inserted into your drawing. The rule set
behaves like a style, except that you can also override values if desired. Rule sets simply provide a way for
you to create a set customized set of rules. You can add or exclude certain rules, edit certain rule values, or
change the order in which the rules are processed on a part, and you can save all these changes in a named
rule set. This gives you the ability to control and customize the rule behavior for a specific pipe network or
pipe network part.
See also:
■

Creating a Rule Set (page 1402)

■

Pipe Rule Set dialog box (page 2274)
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■

Structure Rule Set dialog box (page 2286)

Rule Violations
Rule violations inform you when pipe network part parameter values have not been met or exceed certain
limits.
Whenever rules are applied to a part, validation checks occur to inform you, for example, if minimum or
maximum cover limits have been violated, or if some other condition needs attention.
When warnings occur due to rule violations, they are displayed as warning icons
in the Pipe Network
Vistas (page 2302) (Panorama window or Toolspace item view). Rule violation information is also displayed
on the Rules tab (page 2280) of the Pipe or Structure Properties dialog box, in the Status column. Placing the
mouse cursor over the warning icon in the Prospector List View displays tooltip text describing the warning
(rule violation) condition. This tooltip displays the same rule violation text that is displayed in the Status
column on the Rules tab of the Pipe or Structure Properties dialog box.
The following illustration is an example of the Rules tab on a pipe in a drawing. In this example, the Minimum
Cover and Maximum Length properties for this pipe display with descriptive rule violation text
in the
Pipe Value column because they violate the design criteria specified in the Value column. Note the rule
violation descriptive text that is displayed in the Status column; for example, “Minimum pipe cover exceeded”
and “Exceeds the maximum pipe length by”.

Fixing Broken Rules
The pipe network rule feature is a mechanism for visually identifying conditions that violate the design
criteria rules that are in place for pipes and structures. You can choose to leave broken rule conditions as
they are, or you may desire to resolve the broken rule conditions, depending on the circumstances.
If you wish to resolve a broken rule condition, there are a few different ways you can do this. You can edit
the value in the Value column (editing the rule). You can also edit the pipe or structure object itself in the
drawing so that it no longer violates the rule. For example, you could move a pipe to a different elevation
so that it no longer violates a Minimum Cover rule. In some situations, you may want to reapply rules to a
pipe network, or to pipe network parts, when you have a rule violation.
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NOTE It is important to note that reapplying rules does not automatically resolve rule violations. In some situations,
reapplying rules may result in more rule violations, some of which you may decide to simply leave as violations.
For example, there may be some situations where you have certain site-specific cover constraints that you want
to intentionally violate.
Note that if you edit the Rule Value on a pipe network part in a drawing, it does not affect the rule for other
parts in the drawing, for parts in the parts list, or for parts in the parts catalog. It also does not alter any
physical characteristics of the part in the drawing. It simply alters the rule limit on that particular part in
your drawing.

Applying Rules to Parts in a Drawing
You can apply rules to pipe network parts to ensure that certain conditions are flagged, and to ensure that
parts are placed in correct locations.
For example, you may need to reapply rules to ensure that pipes that have not met the maximum cover
value are flagged as rule violations. This enables you to quickly identify parts that may need to be adjusted
in your drawing. You may also want to reapply rules after you moved a structure that has pipes connected
to it to ensure that the connected pipes still exist in the correct elevation and connection locations.
When you apply rules to a pipe network part, rule values as defined in the Pipe Rule Set or Structure Rule
Set for the part are copied to the part.
You may need to reapply rules when:
■

The elevation of a pipe network part has changed due to pipe network parts being moved.

■

A part’s rule value has changed.

■

You add or delete a rule from a part.

■

You change the order in which rules are processed on the part.

If you look at the rule set assigned to a part, you can view the rule set, and the rules currently associated
with the part. You cannot change the processing order of the rules on the Structure or Pipe Properties Rules
tab. However, you can change the order of the rules by displaying the Rules tab on the Rule Set.
Applying rules does not automatically resolve rule violations. You can view rule violations leave them as is,
or resolve them.
In some situations, reapplying rules may result in more rule violations, some of which you may decide to
simply leave as violations. For example, there may be some situations where you have site-specific cover
constraints that you want to intentionally violate.
To apply rules to a pipe network part
➤

In the drawing, right-click either a pipe or structure in a pipe network, and then click Apply Rules.
At the command line, a prompt is displayed indicating that rules have been successfully applied to the
network part(s).

For more information, see Part Rules (page 1390).
To apply rules to parts in a pipe network
1 Click Pipe Networks tab ➤ Modify panel

Apply Rules

.

2 In the drawing, select pipe network parts in an up-slope direction.
3 When finished selecting parts, press Enter to end the command.
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At the command line, the following prompt is displayed:
Rules successfully applied to X network parts.
For more information, see Part Rules (page 1390).

Pipe Rules
These rules primarily govern how the elevations of a pipe object are determined when the object is created.
There are also rules to flag pipes that exceed certain values, such as maximum length, for example.
When a pipe rule is violated, you can complete the action, but a warning icon
is displayed for the pipe
object in the Pipe Network Vistas (page 2302) (Panorama window or Toolspace item view), and on the Rules
tab (page 2280) of the Pipe Properties dialog box. This indicates that a rule violation exists.
After a pipe object is created, you may make changes to the pipe that result in the pipe rules being violated.
For example, you might move a pipe so that the Minimum Cover distance is not met.
NOTE Drag and drop functionality can be used to copy pipe rules. For more information, see Dragging Styles or
Items Within or Between Drawings (page 70).
The following sections describe the standard rules available for pipe objects.

Cover And Slope Rule
This rule ensures that a pipe slopes appropriately and warns when a pipe is placed too close to a ground
surface.
For gravity-based systems, this is perhaps the most useful rule. It ensures that a pipe slopes in the desired
direction under various conditions, while ensuring that minimum cover is not exceeded. In addition, it
manages conditions when a pipe drop across structure rule conflicts with the pipe’s slope and cover rules.
When drawing a pipe, the pipe attempts to stay within minimum and maximum cover values, unless the
minimum or maximum slope is reached. At that point, maximum cover distance is exceeded to satisfy the
minimum slope requirement, if it is violated.
This rule ensure the following, with the first pipe having the highest precedence or priority:
■

The connections to structures are at a location as specified by the structure rules, if any are specified.

■

The pipe always slopes in the proper direction, with the minimum slope being honored, unless this is
in conflict with a connected structure.

■

The minimum cover is maintained unless this is in conflict with a connected structure.

Parameters
The following parameters govern the behavior of the pipe Cover And Slope rule.
■

Maximum Cover. Specifies the maximum cover of soil over the length of the pipe, based on the surface
being referenced by that pipe. If the maximum cover is exceeded, a rule violation occurs. Note that this
parameter provides validation only; it does not alter (move or resize) the part in the drawing in any way.
It simply produces a rule violation on the part if the specified value is exceeded.

■

Maximum Slope. Specifies the maximum slope of the pipe, expressed in percent. If the pipe slope is
greater than the maximum, a rule violation occurs for that object.

■

Minimum Cover. Specifies the minimum cover of soil over the pipe, based on the surface being referenced
by that pipe. During layout, a pipe will be created that attempts to maintain the minimum cover. This
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is also used to determine the initial elevations of the pipe. If the pipe is edited so that its cover is less
than the minimum cover value, a rule violation occurs for that object.
■

Minimum Slope. Specifies the minimum slope of the pipe, expressed in percent. During layout, a pipe
will be created according to its minimum slope rule value. If the pipe is edited so that its slope is less
than the minimum, you can still edit the pipe as desired, breaking the minimum slope rule, but a rule
violation occurs for that object.

Cover Only Rule
This rule is intended for laying out pipes in a pressure-based pipe network where pipe elevations are
determined according to a specified depth below a terrain.
This rule ensures that the minimum cover is met along the length of the pipe, and also validates that both
the minimum and maximum cover values are not violated along any length of the pipe.

Parameters
The following parameters govern the behavior of this rule:
■

Maximum Pipe Cover. Specifies the maximum cover of soil over the pipe, based on the surface being
referenced by that pipe. If the pipe cover exceeds the maximum cover value, a rule violation occurs for
that object. Note that this parameter provides validation only; it does not alter (move or resize) the part
in the drawing in any way. It simply produces a rule violation on the part if the specified value is exceeded.

■

Minimum Pipe Cover. Specifies the minimum cover of soil over the pipe, based on the surface being
referenced by that pipe. During layout, a pipe will be created that attempts to maintain the minimum
cover. If the pipe is edited so that its cover is less than the minimum cover value, a rule violation occurs
for that object.

■

Start Cover. Specifies the cover at the start of the pipe.

■

End Cover. Specifies the cover at the end of the pipe.

NOTE For spanning pipe labels Start Cover will display the cover at the beginning of the span of pipes that
comprise the spanning pipe label. End Cover will display the cover for the very end of the span.The start and end
of the spanning pipe label depends on the order in which pipes where selected when creating the pipe span.

Length Check Rule
This rule governs the behavior that produces a warning condition on a pipe if the pipe length exceeds the
value specified for the maximum pipe length, or is less than the value specified for the minimum pipe length.
This rule determines whether the 2D length of the pipe meets the values specified for the minimum and
maximum pipe lengths. For this rule, the pipe is measured from pipe end to pipe end, not from the inside
edge of the structure.
This rule is useful for design situations that require or recommend a maximum, continuous pipe length.
This rule also includes a minimum pipe length warning option. Keep in mind that this rule does not prevent
you from exceeding the minimum/maximum lengths. It notifies you that the specified length is being
exceeded.

Parameters
The following parameters govern the behavior of the Length Check rule.
■

Maximum Pipe Length. This parameter lets you define a maximum length for pipes. When this parameter
(rule) is in use, you can still draw pipes that exceed the defined maximum pipe length. However, the
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object will be displayed with a warning icon in the Prospector list view. Note that this parameter provides
validation only; it does not alter (move or resize) the part in the drawing in any way. It simply produces
a rule violation on the part if the specified value is exceeded.
■

Minimum Pipe Length. This parameter lets you define a minimum length for pipes. When this parameter
(rule) is in use, you can still draw pipes that are shorter than the defined minimum pipe length. However,
the object will be displayed with a warning icon in the Prospector list view. Note that this parameter
provides validation only; it does not alter (move or resize) the part in the drawing in any way. It simply
produces a rule violation on the part if the specified value is not met.

Pipe To Pipe Match Rule
This rule governs how a pipe elevation is determined in a pipe network that contains only pipes (no structures),
and or when a pipe is inserted onto an existing pipe to break the pipe.
This rule applies only during the following conditions:
■

Creating a pipe network that has pipes only (no structures)

■

Breaking into an existing pipe with another pipe

■

Connecting a pipe to a null structure (pipe to pipe connection with no structure)

■

Connecting a pipe to an existing pipe end

This rule manages conditions so that only continuous runs of pipe are created as typically expected. In pipe
networks where the pipe size is constant, pipes connected to other pipes must to match end to end. In pipe
networks where pipe sizes change, the point where pipes match may change, depending on the type of
system. For example, in pressure systems, it may be typical to match the pipe centerline. In gravity systems,
it may be typical to match the crowns of the pipes.
This rule also incorporates a drop value for cases where a pipe-to-pipe connection requires a drop amount.

Parameters
The following parameters govern the behavior of this rule:
■

Match Location. This parameter controls whether the inserted pipe holds to the pipe’s invert, crown, or
centerline elevation (location).

■

Drop Value. The drop value allows you to specify an additional drop amount at pipe to pipe connections.

Structure Rules
These rules govern primarily how a structure object is placed and sized during object creation. They also
can determine the elevations of connected pipes. There is also a rule to flag pipes that are too wide to connect
to a structure.
Just like pipe rules, when structure rules are violated, a warning icon is displayed for the object in the Pipe
Network Vistas (page 2302) (Panorama window or Toolspace item view), and on the Rules tab (page 2293) of the
Structure Properties dialog box.
The following sections describe the standard rules associated with structure objects.

Pipe Drop Across Structure Rule
This rule compares all pipes connected to a single structure and ensures that pipes enter and exit the structure
according to the specified drop value.

1396 | Chapter 29 Pipe Networks

This rule applies to junction structures only and is intended specifically for gravity-based systems. It is
important to note that this rule does not alter the structure in any way, nor does it alter any of the pipes
that are connected to the structure. Instead, this rule actually inserts data onto the structure that is read by
the pipes when they are using rules. It ensures that the following conditions are achieved when connecting
a new pipe to a structure that already has one or more pipes connected to it:
■

A pipe exiting a structure is no higher than the lowest pipe entering the structure.

■

A pipe entering a structure is no lower than the highest pipe exiting a structure.

■

There is always a specified minimum drop distance between the lowest incoming pipe and the highest
outgoing pipe.

The drop can be based on a comparison between the crowns, inverts, or centerlines of pipes. A validation
check is performed for drops exceeding a certain distance. This determines whether a maximum drop value
is violated or whether a drop is required.

Parameters
The following parameters govern the behavior of this rule:
■

Drop Reference Location. Specifies the drop location by referencing the pipe’s invert, crown, or centerline
elevation.

■

Drop Value. Specifies the drop value between the lowest incoming pipe and the highest outgoing pipe
connected to the structure.

■

Maximum Drop Value. Specifies what the maximum drop value is between the lowest incoming pipe
and any outgoing pipe connected to the structure. Note that this parameter provides validation only; it
does not alter (move or resize) the part in the drawing in any way. It simply produces a rule violation
on the part if the specified value is exceeded. This is intended to raise awareness when a drop structure
might be needed.

Pipe Drop Across Structure Rule Examples
The Pipe Drop Across Structure rule applies in a variety of scenarios.
The following examples show how the Pipe Drop Across Structure rule is applied when a new incoming or
outgoing pipe is added to a structure that already has pipes connected to it.
The following illustration shows a junction structure that has two incoming pipes already connected to it
on the left side of the structure. When a new incoming pipe is added to the right side of the structure, the
pipe cover and slope rule determines the optimal connection elevation for the new incoming pipe.
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Example 1: Existing Incoming Pipes with New Incoming
Pipe

In the following illustration, the junction structure has two incoming pipes already connected to it on the
left side of the structure. A new outgoing pipe is added to the right side of the structure. The pipe cover and
slope rule determines the optimal connection elevation for the new outgoing pipe.
Example 2: Existing Incoming Pipes with New Outgoing
Pipe

The following illustration shows a junction structure that has two outgoing pipes already connected to it
on the left side of the structure. A new incoming pipe is added to the right side of the structure. The pipe
cover and slope rule determines the optimal connection elevation for the new incoming pipe.
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Example 3: Existing Outgoing Pipes with New Incoming
Pipe

The following illustration shows a junction structure that has two outgoing pipes already connected to it
on the left side of the structure. A new outgoing pipe is added to the right side of the structure. The pipe
cover and slope rule determines the optimal connection elevation for the new outgoing pipe.
Example 4: Existing Outgoing Pipes with New Outgoing
Pipe

The following illustration shows a junction structure that has four pipes already connected to it on the left
side of the structure. Two of those pipes are incoming pipes, and the other two are outgoing pipes. A new
incoming pipe is added to the right side of the structure. The pipe cover and slope rule determines the optimal
connection elevation for the new incoming pipe.

Structure Rules | 1399

Example 5: Existing Incoming and Outgoing Pipes with
New Incoming Pipe

The following illustration shows a similar situation with both incoming and outgoing pipes already connected.
In this case, a new outgoing pipe is added to the structure. The pipe cover and slope rule determines the
optimal connection elevation for the new outgoing pipe.
Example 6: Existing Incoming and Outgoing Pipes with
New Outgoing Pipe

Maximum Pipe Size Check Rule
This rule checks to see if pipes entering a structure have a diameter or width that exceeds a specified maximum
value.
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This rule analyzes all pipes attached to a structure and checks to see whether the pipe diameter or width is
within the specified maximum value. For example, a manhole that is three feet wide in diameter may not
be able to accommodate a pipe that is three feet wide in diameter.

Parameters
The following parameters govern the behavior of this rule:
■

Maximum Pipe Diameter or Width. For circular pipes, this parameter measures the pipe diameter. For
rectangular pipes, it measures width. If a pipe diameter or width exceeds the maximum value, a warning
is issued on the structure. Note that this parameter provides validation only; it does not alter (move or
resize) the part in the drawing in any way. It simply produces a rule violation on the part if the specified
value is exceeded.

Set Sump Depth Rule
This rule sets the sump elevation of junction structures based on the user-specified parameters and the invert
elevations of pipes attached to the structure.
When this rule is applied, the elevation of the inside bottom (sump) of the structure is calculated by
subtracting the user-specified sump depth from the elevation of the lowest invert in the structure.

Parameter
The following parameter governs the behavior of this rule:
■

Sump Depth. Specifies the sump depth, or the vertical distance from the invert of the lowest pipe attached
to the structure to the inside bottom of the structure.

Editing Part Rules
Use the Rules tab of either the Pipe Properties or the Structure Properties dialog box to edit the values for
rules associated with a part in a pipe network.
Editing the rule values for a part in a drawing affects only the currently selected part in your drawing. It does
not affect the definition of the part as it exists in the pipe network part catalog.
You can also edit rules as they are defined for a rule set in the Settings tree. For example, in the Toolspace
Settings tree ➤ Pipe ➤ Pipe Rule Set collection, you can add rules, remove rules, or edit rule values for a
particular rule set. This provides a convenient method for creating rule sets intended for a specific pipe
network or project.
For example, you could create a rule set that has the Length Check rule value set to a certain value. You
could do the same for the Cover and Slope rule.
To edit rule values for a part in a pipe network
1 In the drawing, right-click either a pipe or structure in a pipe network, and then click either Pipe
Properties or Structure Properties.
2 Click the Rules tab.
3 Select the value of the rule you want to edit and enter a new value.
4 Click Apply or OK to save the changes.
To add, remove, or edit rules in a rule set
1 In Toolspace, on the Settings tab, expand either the Pipe or Structure collection.
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2 Expand either the Pipe Rule Set or Structure Rule Set collection
3 Double-click a rule set. The Pipe or Structure Rule Set dialog box is displayed.
4 Click the Rules tab.
Add or delete rules by clicking Add Rule or Delete Rule. Edit a rule value by clicking on the value and
entering a new value.
5 Click Apply or OK to save the changes.

Overriding Part Rules
Override part rules if you do not want certain conditions flagged with warnings in the Prospector list view
and in the Event Viewer.
You can select a part in a pipe network and override the rule value that governs it.
To override rules from a rule set
1 In the drawing, right-click a pipe network part (either a pipe or structure), and then select either Pipe
Properties or Structure Properties.
2 Click the Rules tab.
3 Clear the Use Values From Rule Set check box.
4 Click Apply or OK to save the changes.

Creating a Rule Set
Use rule sets to create customized rule behavior for pipe network parts.
A default “rule set” exists for both pipes and structures. The rule set simply provides a way for you to create
a set of customized rules. You can add or exclude certain rules, or edit certain rule values, and save them in
a named rule set designed to control the behavior for a specific pipe network or project.
For more information, see Part Rules (page 1390), the Pipe Rule Set dialog box (page 2274), or the Structure Rule
Set dialog box (page 2286)
To create a rule set
1 In Toolspace, on the Settings tab, expand either the Pipe or Structure collection.
2 Right-click either Pipe Rule Set or Structure Rule Set. Click New.
3 On the Rule Set Information tab, enter a name for the new rule set. Optionally, enter a description.
4 Click the Rules tab.
5 Click Add Rule to add a rule.
6 In the Add Rule dialog box, in the Rule Name drop-down list, select a rule to add.
When you select a rule, its parameters are displayed in the Rule Parameters table.
7 Click OK in the Add Rule dialog box.
8 Edit a rule value by clicking a value on the Rules tab and entering a new value, or select one from a list.
9 Click Apply or OK to save the changes.
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Converting VBA Rules to .NET
In drawings, you can convert AutoCAD Civil 3D pipe and structure rules that are VBA-based to .NET.
In Civil 3D 2008, and in earlier versions of Civil 3D, the pipe and structure rules that were included in the
product were created using VBA, and maintained in a .dvb file (C3DPipeNetworkRules.dvb).
In Civil 3D 2009, new pipe network rule sets that are created now point to the .NET dll version of rules, and
therefore point to a .NET .dll file (C3DPipeNetworkRules.dll).
The .NET-based rules typically provide optimal performance over VBA-based rules. Civil 3D 2009, and later
versions, still support VBA-based rules.
If you have not made any modification to your VBA pipe networks rules file (C3DPipeNetworkRules.dvb), it
is recommended that you convert the pipe and structure rules in drawings to .NET using this command. If
you have made edits to the C3DPipeNetworkRules.dvb rules file, it is not recommended that you convert
rules to .NET because you will lose any VBA changes you made to C3DPipeNetworkRules.dvb.
If you create a new rule set in AutoCAD Civil 3D 2009 or later, the rules will point to the .NET dll version
of rules. If you open a drawing that has a rule set that was created in Civil 3D 2008, or earlier versions of
Civil 3D, the rule set will still point to and execute the VBA version of rules, unless you run the convert to
.NET command.
Please note the following:
■

This command only converts the VBA-based AutoCAD Civil 3D pipe and structure rules that were included
with the product. It does not convert any VBA custom rules you may have created behind the scenes.

■

By default, the rules files are installed to the following location:

■

Internally, this command just changes a pipe rule reference to the .NET version of that rule, instead of
the VBA version of that rule.

■

In drawings, you can have a mix of pipe networks that point to VBA-based and .NET-based part rules.
For example, when you open a drawing that was created in Civil 3D 2008 or earlier in Civil 3D 2009,
that contains pipe networks, and then create a new rule set, that drawing will contain references to both
VBA and .NET rules.

■

In a single pipe network, you can have a mix of parts that point to VBA-based and .NET-based part rules.

To convert pipe and structure rules in a drawing from VBA to .NET
1 Click Modify tab ➤ Design panel

Convert VBA Pipe And Structure Rules To .NET

.

You are prompted to make sure that you really want to convert all pipe and structure rules in the drawing
to .NET.
2 Click Yes.
All VBA pipe and structure rules in the drawing are converted to VB.NET. Prompts indicate that the
command has completed, and that the Event Viewer displays more details about the conversion.

Quick Reference
Ribbon
Modify tab ➤ Design panel

Convert VBA Pipe And Structure Rules To .NET

Menu
Pipes menu ➤ Utilities ➤ Convert VBA Pipe And Structure Rules To .NET.
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Command Line
ConvertVBARulesToDot.Net

Labeling Pipe Networks
You can add labels to pipe network parts either when you create the objects or after you create them.
Use the Create Pipe Network dialog box (page 2259) to specify label styles for pipes and structures in plan view.
Use the Pipe Network Properties dialog box (page 2269) to change plan view label styles, or to specify label
styles for profile and section views. If you select a label style of <none>, labels are not added.
Use the Add Pipe Network Labels option to access the Add Labels Dialog Box (page 2208) if you need to create
or modify a style before labeling a pipe network.
Pipe network label types you can add after creation include entire network, single part, and spanning labels.
If desired, you can add a Material type to a pipe or structure label, as long as the Material property has been
added to the part family that the pipe or structure part belongs to. See Adding a Material Property to a Part
(page 1466) for more information. You can also label hydraulic properties in pipe networks. See Labeling
Hydraulic Properties in Pipe Networks (page 1413) for more information.
You can use the following commands to add labels to pipe network parts.
Command

Description

AddNetworkPartPlanLabel

Adds labels to pipes and structures in plan view.

AddNetworkPartProfLabel

Adds labels to pipes and structures in profile view.

AddNetworkPartSectLabel

Adds labels to pipes and structures in section view.

AddNetworkPlanLabels

Adds labels to a pipe network in plan view.

AddNetworkProfLabels

Adds labels to a pipe network in profile view.

AddNetworkSectLabels

Adds labels to a pipe network in section view.

AddSpanningPipeLabel

Adds label to a span of connected pipes.

For more information, see Understanding Labels in AutoCAD Civil 3D (page 1646).

Labeling Multiple Pipes and Structures in Plan Views
You can label pipe and structures in plan views with Pipe label styles.
To label all pipes and structures within an entire network in plan views
1 Click Annotate tab ➤ Labels & Tables panel ➤ Add Labels menu ➤ Pipe Network ➤ Entire Network
Plan

.

2 Select the part contained in the network to be labeled. All pipes or structures will be labeled in the
network.
OR
1 Click Annotate tab ➤ Labels & Tables panel ➤ Add Labels menu ➤ Pipe Network ➤ Add Pipe Network
Labels

.
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2 In the Add Labels dialog box (page 2208), under Feature, ensure that Pipe Network is selected.
3 Under Label Type, select Entire Network Plan.
4 Specify the other options as required.
5 Click Add and then select the part to label.

Quick Reference
Ribbon
Annotate tab ➤ Labels & Tables panel ➤ Add Labels menu ➤ Pipe Network ➤ Entire Network Plan
Menu
Pipes menu ➤ Add Pipe Network Labels ➤ Add Pipe Network Labels
Command Line
AddNetworkPlanLabels

Labeling Multiple Pipes and Structures in Profile Views
You can label pipe and structures in profile views with Pipe label styles.
To label pipes and structures in profile views
1 Click Annotate tab ➤ Labels & Tables panel ➤ Add Labels menu ➤ Pipe Network ➤ Entire Network
Profile

.

2 Select the part contained in the network to be labeled. All pipes or structures in the network will be
labeled.
OR
1 Click Annotate tab ➤ Labels & Tables panel ➤ Add Labels menu ➤ Pipe Network ➤ Add Pipe Network
Labels

.

2 In the Add Labels dialog box (page 2208), under Feature, ensure that Pipe Network is selected.
3 Under Label Type, select Entire Network Profile.
4 Specify the other options as required.
5 Click Add and then select the part to label.

Quick Reference
Ribbon
Annotate tab ➤ Labels & Tables panel ➤ Add Labels menu ➤ Pipe Network ➤ Entire Network Profile
Menu
Pipes menu ➤ Add Pipe Network Labels ➤ Add Pipe Network Labels
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Command Line
AddNetworkProfLabels

Labeling Multiple Pipes and Structures in Section Views
You can label pipes and structures in section views with Pipe label styles.
To label pipes and structures in section views
1 Click Annotate tab ➤ Labels & Tables panel ➤ Add Labels menu ➤ Pipe Network ➤ Entire Network
Section

.

2 Select the part contained in the network to be labeled. All pipes or structures in the network will be
labeled.
OR
1 Click Annotate tab ➤ Labels & Tables panel ➤ Add Labels menu ➤ Pipe Network ➤ Add Pipe Network
Labels

.

2 In the Add Labels dialog box (page 2208), under Feature, ensure that Pipe Network is selected.
3 Under Label Type, select Entire Network Section.
4 Specify the other options as required.
5 Click Add and then select the part to label.

Quick Reference
Ribbon
Annotate tab ➤ Labels & Tables panel ➤ Add Labels menu ➤ Pipe Network ➤ Entire Network Section
Menu
Pipes menu ➤ Add Pipe Network Labels ➤ Add Pipe Network Labels
Command Line
AddNetworkSectLabels

Labeling Individual Pipes and Structures in Plan Views
You can label individual parts in plan views with Pipe label styles.
To label pipe networks in plan views
1 Click Annotate tab ➤ Labels & Tables panel ➤ Add Labels menu ➤ Pipe Network ➤ Single Part Plan
.
2 Select the part contained in the network to be labeled. The individual part will be labeled.
OR
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1 Click Annotate tab ➤ Labels & Tables panel ➤ Add Labels menu ➤ Pipe Network ➤ Add Pipe Network
Labels

.

2 In the Add Labels dialog box (page 2208), under Feature, ensure that Pipe Network is selected.
3 Under Label Type, select Single Part Plan.
4 Specify the other options as required.
5 Click Add and then select the part to label.

Quick Reference
Ribbon
Annotate tab ➤ Labels & Tables panel ➤ Add Labels menu ➤ Pipe Network ➤ Single Part Plan
Menu
Pipes menu ➤ Add Pipe Network Labels ➤ Add Pipe Network Labels
Command Line
AddNetworkPartPlanLabel

Labeling Individual Pipes and Structures in Profile Views
You can label individual parts in profile view with Pipe label styles.
To label pipe networks in profile view
1 Click Annotate tab ➤ Labels & Tables panel ➤ Add Labels menu ➤ Pipe Network ➤ Single Part Profile
.
2 Select the part contained in the network to be labeled. The individual part will be labeled.
OR
1 Click Annotate tab ➤ Labels & Tables panel ➤ Add Labels menu ➤ Pipe Network ➤ Add Pipe Network
Labels

.

2 In the Add Labels dialog box (page 2208), under Feature, ensure that Pipe Network is selected.
3 Under Label Type, select Single Part Profile.
4 Specify the other options as required.
5 Click Add and then select the part to label.

Quick Reference
Ribon
Annotate tab ➤ Labels & Tables panel ➤ Add Labels menu ➤ Pipe Network ➤ Single Part Profile
Menu
Pipes menu ➤ Add Pipe Network Labels ➤ Add Pipe Network Labels
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Command Line
AddNetworkPartProfLabel

Labeling Individual Pipes and Structures in Section Views
You can label individual parts in section view with Pipe label styles.
To label pipes and structures in section view
1 Click Annotate tab ➤ Labels & Tables panel ➤ Add Labels menu ➤ Pipe Network ➤ Single Part Section
.
2 Select the part contained in the network to be labeled. The individual part will be labeled.
OR
1 Click Annotate tab ➤ Labels & Tables panel ➤ Add Labels menu ➤ Pipe Network ➤ Add Pipe Network
Labels

.

2 In the Add Labels dialog box (page 2208), under Feature, ensure that Pipe Network is selected.
3 Under Label Type, select Single Part Section.
4 Specify the other options as required.
5 Click Add and then select the part to label.

Quick Reference
Ribbon
Annotate tab ➤ Labels & Tables panel ➤ Add Labels menu ➤ Pipe Network ➤ Single Part Section
Menu
Pipes menu ➤ Add Pipe Network Labels ➤ Add Pipe Network Labels
Command Line
AddNetworkPartSectLabel

Labeling a Span of Connected Pipes
In plan or profile views, you can label a series of consecutively connected pipes with a single pipe label.
A spanning label helps minimize the number of labels displayed in a pipe network.
When you place the cursor over the spanning pipe label, the pipes that are in the span are highlighted. You
can also use the AutoCAD list command to list the connected pipes. After adding a spanning label, you can
highlight the connected pipes that comprise the span by selecting the label.
See also:
■

Resetting the Anchor Pipe on Spanning Labels (page 1413)
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To label a span of pipes in a plan view
1 Click Annotate tab ➤ Labels & Tables panel ➤ Add Labels menu ➤ Pipe Network ➤ Spanning Pipes
Plan .
2 At the command line, you are prompted to select the first pipe network part (pipe or structure).
3 In the drawing, click a pipe or structure in the pipe network to define the starting point for the connected
pipe span.
4 At the command line, you are prompted to select the next pipe network part (pipe or structure).
5 Click a part (pipe or structure) to define the ending point for the span.
6 Press Enter.
The following prompt is displayed:
Specify label location on pipe:
7 Specify the location for the label by clicking one of the pipes in the span. You must click a pipe, not a
structure.
If you select a pipe that is not included in the span, a prompt is displayed indicating that the label
location must be on a spanned pipe.
Note that the label can be slid along the span with the slider grip

.

OR
1 Click Annotate tab ➤ Labels & Tables panel ➤ Add Labels menu ➤ Pipe Network ➤ Add Pipe Network
Labels

.

2 In the Add Labels dialog box (page 2208), under Feature, ensure that Pipe Network is selected.
3 Under Label Type, select Spanning Pipes Plan.
4 Specify the other options as required.
5 Click Add.
You are prompted to select the first part (pipe or structure) in the span.
6 Define the span by clicking the first and last parts (pipes or structures) in the span. The parts must
belong to the same pipe network.
7 Press Enter.
The following prompt is displayed:
Specify label location on pipe:
8 Specify the location for the label by clicking one of the pipes in the span. You must click a pipe, not a
structure.
If you select a pipe that is not included in the span, a prompt is displayed indicating that the label
location must be on a spanned pipe.
Note that the label can be slid along the span with the slider grip

.

To label a span of pipes in a profile view
1 Click Annotate tab ➤ Labels & Tables panel ➤ Add Labels menu ➤ Pipe Network ➤ Spanning Pipes
Profile

.
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2 At the command line, you are prompted to select the first pipe network part (pipe or structure).
3 In the drawing, click a pipe or structure in the pipe network to define the starting point for the connected
pipe span.
4 At the command line, you are prompted to select the next pipe network part (pipe or structure).
5 Click a part (pipe or structure) to define the ending point for the span.
6 Press Enter.
The following prompt is displayed:
Specify label location on pipe:
7 Specify the location for the label by clicking one of the pipes in the span. You must click a pipe, not a
structure.
If you select a pipe that is not included in the span, a prompt is displayed indicating that the label
location must be on a spanned pipe.
Note that the label can be slid along the span with the slider grip

.

OR
1 Click Annotate tab ➤ Labels & Tables panel ➤ Add Labels menu ➤ Pipe Network ➤ Add Pipe Network
Labels

.

2 In the Add Labels dialog box (page 2208), under Feature, ensure that Pipe Network is selected.
3 Under Label Type, select Spanning Pipes Profile.
4 Specify the other options as required.
5 Click Add.
You are prompted to select the first part (pipe or structure) in the span.
6 Define the span by clicking the first and last parts (pipes or structures) in the span. The parts must
belong to the same pipe network.
7 Press Enter.
The following prompt is displayed:
Specify label location on pipe:
8 Specify the location for the label by clicking one of the pipes in the span. You must click a pipe, not a
structure.
If you select a pipe that is not included in the span, a prompt is displayed indicating that the label
location must be on a spanned pipe.
Note that the label can be slid along the span with the slider grip

.

To highlight a connected pipe span, do one of the following
■

Hover the cursor over the spanning label. This highlights all of the parts that are in the span.

■

Right-click the pipe span label and select Show Spanning Pipes. A dotted line will appear from the starting
point to the end point of the connected pipe span, as shown in the following illustration. The
diamond-shaped slider grip can be used to slide the label along the span. To remove the highlight, deselect
Show Spanning Pipes from the right-click menu.
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Quick Reference
Ribbon
Annotate tab ➤ Labels & Tables panel ➤ Add Labels menu ➤ Pipe Network ➤ Spanning Pipes Plan
Menu
Pipes menu ➤ Add Pipe Network Labels ➤ Spanning Pipes Plan
Command Line
AddNetworkLabels

Editing Spanning Labels with Grips
Spanning labels are not anchored to any particular pipe or structure. You can move them freely to any
connected pipe or structure in the span.
It is also possible to reset the anchor point of a spanning label. For more information, see Resetting the
Anchor Pipe on Spanning Labels (page 1413).
To move a spanning pipe label
■

Click the label to be moved and select the slider grip

.

Move the label to the desired location.
NOTE Spanning pipe labels have the same dragged state behavior as regular pipe labels. Click the round grip
to restore a dragged label to its default state.

Deleting Pipes Labeled with Spanning Labels
Deleting an individual pipe from a span labeled with a spanning label has various affects depending on
where the label is located in relation to the deleted pipe.
To delete a pipe, select it and press delete.
In the following example, the pipe span is comprised of four connected pipes. Note where the spanning
label is located. In this example, the Text Component Editor was used to create a label that dynamically
indicates the number of pipes in the span by inserting the Number of Pipes in Span property. For more
information see, Text Component Editor Dialog Box (page 2199).
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Example 1
In the following example, the vertical pipe has been deleted, or detached from the other pipes. The result
is that only the connected pipes to the right are now included in the span label. The label stays at the same
location.

Example 2
In the following example, the pipe to the left has been deleted, or detached from the vertical pipe. The result
is that only the remaining pipes are included in the span. The label indicates the span is now comprised of
three pipes.

Example 3
In the following illustration, the pipe with the span label has been deleted. The result is that the span label
is also deleted.
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Resetting the Anchor Pipe on Spanning Labels
You can reset the anchor position of label that spans multiple parts in a pipe network.
To reset the anchor position of a label that spans multiple pipe network parts
1 At the command line, enter ResetAnchorPipe.
2 In the drawing, select a label that spans multiple pipe parts (spanning pipe label).
3 Select the new anchor point by clicking on a pipe in the same network. You must select a pipe, not a
structure.
The new anchor position is set, and the spanning label will display at the midpoint of the selected pipe.

Adding a Material Type to a Pipe or Structure Label
You can add a material type, such as ductile iron or corrugated steel, to display in a pipe or structure label.
If the part family the pipe or structure belongs to includes the Material property, you can configure that
property to display text identifying the type of material used for that part. Using the Label Style Composer,
you can add that Material property to labels for pipe network parts.
To add a material type to an existing pipe or structure label
1 In the drawing, select a pipe or structure and then click Pipe Properties or Structure Properties.
2 On the Pipe Properties dialog box, or the Structure Properties dialog box, click the Part Properties tab.
3 Scroll down to the Part Data section and the Material property should be displayed.
If the Material property is not displayed, this means that this part family does not contain the Material
property. See Adding a Material Property to a Part (page 1466) for instructions on how to add this property
to a part family.
4 Click in the Value cell to select an existing or enter a new value for the Material property.
5 Click OK on the Pipe Properties dialog box or the Structure Properties dialog box.
To add a material type to a pipe or structure label style
1 In the Label Style Composer, click the Layout tab.
2 In the Text section, click in the Contents cell, and then

click to display the Text Component Editor.

3 In the Text Component Editor, select Material in the Properties list and add it to your label.
4 Click OK on the Text Component Editor dialog box.
5 Click OK on the Label Style Composer dialog box.

Labeling Hydraulic Properties in Pipe Networks
You can create a label style for labeling hydraulic properties, such as HGL and EGL, in pipe networks.
Use the Label Style Composer to create a label style that lets you add labels that display values for hydraulic
properties, such as hydraulic grade line and energy grade line in pipe networks.
Once the label style is created, you can select that label style on the following tabs of the Pipe Network
Properties dialog box: Layout Settings tab, Profile tab, Section tab.
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To create a label style for pipe network hydraulic properties
1 In Toolspace, on the Settings tab, expand the Pipe collection, then expand the Label Styles collection.
2 In the Label Styles collection, expand a collection. For example, expand the Plan Profile collection ,
and then right-click on an existing label style. For example, right-click on Standard, and then click New
or Edit.
3 On the Label Style Composer, click the Layout tab.

4 Under the Text collection, click the Browse button
property.

in the Value cell next to the Add Contents

5 Use the Text Component Editor to add the desired hydraulic properties to the label style. For example,
on this dialog box, under Properties, click the drop-down arrow to display the list of properties you can
add to the label. Select the desired hydraulic properties from this list. For example, click Hydraulic Grade
Line Up, and then click the right-arrow button to add the property to the label style.
6 When finished composing label text using this dialog box, click OK to save changes.
7 Click OK on the Label Style Composer dialog box to save changes to the label style.
For more information, see Text Component Editor Dialog Box (page 2199)or Adding Content to Labels (page
1686).

Quick Reference
Dialog Box
Text Component Editor (page 2199)

Adding Pipe Tables
You can create tables that display information about pipes inone or more a pipe networks.
When you insert a pipe table into a drawing, specified pipe information is automatically displayed in the
table.
Pipe tables can include data such as pipe shape, size, length, slope, start and end stations, or any pipe
property.
You create and edit tables for most objects using the same common procedures and standard dialog boxes.
The procedure in this topic explains how to access the pipe table creation command. It provides a link to
information about the Pipe Table Creation dialog box. For information about modifying tables, see Modifying
Tables (page 1750).
To create a pipe table
1 Click Annotate tab ➤ Labels & Tables panel ➤ Add Tables menu ➤ Pipe Network ➤ Add Pipe
2 In the Pipe Table Creation (page 2313) dialog box, change the generic table settings as needed.
3 Select a network to be included in the table.
4 Click OK.
5 Select the location for the upper-left corner of the table in the drawing.
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.

Quick Reference
Ribbon
Annotate tab ➤ Labels & Tables panel ➤ Add Tables menu ➤ Pipe Network ➤ Add Pipe
Menu
Annotate tab ➤ Labels & Tables panel ➤ Add Tables menu ➤ Pipe Network ➤ Add Pipe

Adding Structure Tables
You can create tables that display information about structures in one or more pipe networks.
When you insert a structure table into a drawing, specified structure information is automatically displayed
in the table.
Structure tables can include data such as structure type, elevation, sump depth, station, or any structure
property.
You create and edit tables for most objects using the same common procedures and standard dialog boxes.
The procedure in this topic explains how to access the structure table creation command. It provides a link
to information about the Structure Table Creation dialog box. For information about modifying tables, see
Modifying Tables (page 1750).
To create a structure table
1 Click Annotate tab ➤ Labels & Tables panel ➤ Add Tables menu ➤ Pipe Network ➤ Add Structure
.
2 In the Structure Table Creation (page 2313) dialog box, change the generic table settings as needed.
3 Select a structure to be included in the table.
4 Click OK.
5 Select the location for the upper-left corner of the table in the drawing.

Quick Reference
Ribbon
Annotate tab ➤ Labels & Tables panel ➤ Add Tables menu ➤ Pipe Network ➤ Add Structure
Menu
Annotate tab ➤ Labels & Tables panel ➤ Add Tables menu ➤ Pipe Network ➤ Add Structure

Editing Structure Table Styles
Edit structure table styles in the Table Styles collection in Toolspace, on the Settings tab.
Structure table styles govern how structure tables are displayed in a drawing. You can create, edit, or delete
structure table styles. Create an entirely new table style, or create a table style based on an existing style.
You can compose a table cell with more than one text component in order to show connected pipe data for
a given structure. The text components display data for each object associated with a parent object (the
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object you are storing data for). For example, you can use a component in a structure table style to include
cell components for pipes associated with that structure.
To edit a structure table style
1 In Toolspace, on the Settings tab, expand Structure ➤ Table Styles.
2 Right-click the table style that you want to edit and click Edit.
3 In the Table Style dialog box, modify style settings.
To add table cell components
1 Double-click a Structure Table cell in the Data Properties tab of the Table Style dialog box to access the
Table Cell Components dialog box.
2 Click the down arrow in

, and then click

to create a new text component.

You can add any number of components, and there can be more than one of any given component
type. The possible components are: Structure, Structure All Pipes, Structure In Flow Pipes, and Structure
Out Flow Pipes.
3 Click Text
to access the Text Component Editor Dialog Box (page 2199). When this option is selected,
the component is added to the list of available components. You can edit the name of the component
and/or enter the content for the table cell.
4 Set the cell justification.
5 Click OK.

Quick Reference
Toolspace Shortcut Menu
Settings: Right-click Structure table style ➤ New
Dialog Box
Table Style (page 2735)

Rendering Pipe Network Parts
Render pipe network parts using the AutoCAD Render command.
The render material that is assigned to a pipe network part by default, upon creation, is defined in the parts
list. After the part is added to the drawing, you can edit the render material for the part using the Render
Material option on the Information tab of either the Pipe Properties or the Structure Properties dialog box.
For more information about rendering AutoCAD Civil 3D objects and data, see Rendering Objects (page 1764).
To render pipe network parts
1 Create a pipe network.
2 Do one of the following:
■

In Toolspace, on the Prospector tree, expand the Pipe Networks collection, then expand the desired
pipe network, and click either Pipes or Structures. In the Prospector list view, choose a render material
for the desired parts.
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■

In the drawing, right-click the pipe network part and click Properties. On either the Pipe Properties
or the Structure Properties Information tab, select a render material.

■

Use the AutoCAD Render command to render the pipe network. For more information, see Render
a Model in the AutoCAD Help.

Using Hydraulics and Hydrology Features
The Hydraflow extensions allow you to peform a variety of hydraulics and hydrology analysis tasks on pipe
networks created with AutoCAD Civil 3D or with the Hydraflow Storm Sewers Extension.
You can migrate pipe network data between AutoCAD Civil 3D and the Hydraflow Storm Sewers Extension.

Moving Pipe Network Data Between AutoCAD Civil 3D and Storm Sewers
You can migrate pipe network data between AutoCAD Civil 3D and the Storm Sewers Extension.
For example, with AutoCAD Civil 3D, you can:
■

export one or more AutoCAD Civil 3D pipe networks to an .stm file that can then be opened by the
Hydraflow Storm Sewers Extension for analysis and or editing

■

import one or more pipe runs from an .stm file that has been exported from the Hydraflow Storm Sewers
Extension into AutoCAD Civil 3D

When importing Storm Sewer data into AutoCAD Civil 3D, you can import a single pipe network, or multiple
pipe networks. However, you must import entire pipe networks; you cannot import individual parts, or a
series of connected parts within a pipe network.
Before migrating pipe network data between AutoCAD Civil 3D and the Storm Sewers Extension, there are
a few preparation tasks you must perform. For more information, see Preparing for Migrating Storm Sewers
Data (page 1418).

Importing STM Files From Previous Versions
In AutoCAD Civil 3D, you can import .stm files that were created or saved from older versions of the Storm
Sewers Extension; for example, the Storm Sewers Extension for AutoCAD Civil 3D 2009 or earlier. You can
also successfully open .stm files that were created or saved from 2009, or earlier, versions of the Storm Sewers
Extension in the Storm Sewers Extension version 2010. However, in the Storm Sewers Extension for Civil
3D 2009, or earlier versions of the Storm Sewers Extension, you cannot open .stm files that were saved in
the Storm Sewers Extension for Civil 3D 2010, or that were exported from AutoCAD Civil 3D.
It is also important to note that when importing .stm files that were saved prior to version 2010, they may
contain hydraulic grade line (HGL) values, however, they will not contain some of the other hydraulic
properties, as listed below. The following values are calculated in the Storm Sewers Extension version 2010,
but are not found in older versions of .stm files (prior to 2010):
■

Pipes
■

Energy Grade Line Up

■

Energy Grade Line Down
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■
■

Flowrate

Structures
■

Energy Grade Line

■

Known Capacity

Storm Sewers Pipe Size Calculations
In the Storm Sewers Extension, the list of pipe sizes is hard coded and cannot be customized. This list does
not distinguish between inner and outer pipe diameter, pipe material, or pipe class, as does AutoCAD Civil
3D. When you perform calculations that resize pipes in the Storm Sewers Extension, the results include only
the sizes that are available in the hard coded list. This may result in a pipe size or sizes that are not typical
of the pipe material they are working with. However, you can always manually edit the pipe size. For more
information, see the Storm Sewers Extension Help.

Preparing for Migrating Storm Sewers Data
There are a few preparatory tasks to perform before migrating data between AutoCAD Civil 3D and the Storm
Sewers Extension.
The table below summarizes these tasks.
Task

Description

Verify that your pipe network data meets the necessary criteria for migration

Review the criteria for migrating pipe network data.
For more information, see Criteria for Migrating
Pipe Networks (page 1419).

Create the parts list that will be used during migration

When you import or export pipe networks between
AutoCAD Civil 3D and the Storm Sewers Extension,
a parts list that contains appropriate parts for the
import or export is required. You will need to create
this parts list first, before you begin importing or
exporting the data. You may need to create a full
parts list, containing all of the available parts in the
entire catalog, or you may need to create a smaller,
customized parts list that contains only the parts
included in the migrated data. For more information, see Creating a Full Parts List (page 1382) or
Creating a Parts List (page 1381).

Set the part matchup settings that will be used
during migration

In Toolspace, on the Settings tab, you need to
configure defaults that will be used for matching
up part types between AutoCAD Civil 3D and the
Storm Sewers. For more information, see Setting
Part Matching Defaults for Migration (page 1419) .

Choose the default parts list that will be used during
migration

In Prospector, on the Settings tab, you also need
to choose the default parts list that will be when
you migrate data between AutoCAD Civil 3D and
the Storm Sewers. For more information, see Setting
the Default Parts List For Migration (page 1420).
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Optionally, you may want to create a label style for displaying labels for hydraulic properties, such as hydraulic
grade lines and energy grade lines in pipe networks. For more information, see Labeling Hydraulic Properties
in Pipe Networks (page 1413).

Criteria for Migrating Pipe Networks
To successfully migrate pipe network data between the Storm Sewers Extension and the AutoCAD Civil 3D,
the pipe network data must meet certain conditions.
Verify that your pipe network data meets these criteria before migrating:
■

Note that in the Storm Sewers Extension, a pipe and its corresponding upstream inlet structure make up
a Hydraflow Storm Sewers line.

■

The Storm Sewers Extension can accept a maximum of 250 pipes (lines) with structures in one project.
If a single AutoCAD Civil 3D pipe network contains more than 250 pipes (lines), then the pipe network
must be divided into smaller pipe networks (and therefore, multiple .stm files) before the pipe network
data can be opened in the Hydraflow Storm Sewers Extension.

■

All catch basin and junction structures must have an outlet pipe. To verify this, in AutoCAD Civil 3D
display the Connected Pipes tab of the Structure Properties dialog box. Look at the In/Out column.

It is also important to be aware of the following before exporting pipe networks to an .stm file (or any type
of export of pipe data):
■

If a pipe does not have an upstream structure in AutoCAD Civil 3D, it is given a null structure in the
exported file.

■

If a structure is not attached to a pipe, the structure will not be exported.

Setting Part Matching Defaults for Migration
You must set part matching defaults before migrating pipe network data between AutoCAD Civil 3D and
Storm Sewers.
Setting the part matching defaults enables you to choose the specific AutoCAD Civil 3D part types that will
be matched up with Storm Sewers part types when you import and export pipe network data between
AutoCAD Civil 3D and Storm Sewers.
Performing this task helps avoid error messages during migration, and ensures that AutoCAD Civil 3D part
types are recoginized as appropriate part types in the Storm Sewers Extension. and vice versa.
You may only have to perform this procedure once. However, if you are adding, deleting, or changing part
types after import or export, then you would need to perform this procedure again to ensure that parts are
appropriately matched between the two applications.
To set part matching defaults for migrating pipe network data
1 In Toolspace, on the Settings tab, right-click the Pipe Network collection and select Edit Feature Settings.
2 In the Edit Feature Settings - Pipe Network dialog box, expand Storm Sewers Migration Defaults.
3 For the Part Matching Defaults, click the Browse button in the V
Settings - Storm Sewers Settings dialog box (page 2316).

alue cell to display the Part Matchup

4 To set the defaults that will be used when you are importing data from the Storm Sewers Extension
into AutoCAD Civil 3D, click the Import tab.
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5 On the Import tab, expand each part type category in the first column, and click on an item in the
column on the right to display the Browse button
Structure cell.
6 Click

. For example, click in the Concentric Cylindrical

to display the Part Catalog dialog box.

7 On the Part Catalog dialog box, select the desired AutoCAD Civil 3D part type and then click OK.
8 On the Import tab, scroll down to ensure that all part types in the first column are matched up with
appropriately part types in the second column.
9 To set the part type defaults that will be used when you are exporting data from AutoCAD Civil 3D
into the Storm Sewers Extension, click the Export tab.
10 On the Export tab, click in the column on the right to select appropriate parts from the drop-down list.
11 On the Export tab, scroll down to ensure that all part types in the first column are matched up with
appropriately part types in the second column.
12 When you are finished matching part type defaults, click OK.
Once you have finished matching up part types, the next step is to select the parts list that will be used for
migration by default. See Setting the Default Parts List For Migration (page 1420) for more information.

Setting the Default Parts List For Migration
You must set the default parts list that will be used during migration before migrating pipe network data
between AutoCAD Civil 3D and Storm Sewers.
Typically, you will want to create a parts list that contains all of the needed prts for the import or export.
You may need to create a full parts list, containing all of the available parts in the entire catalog, or you may
need to create a customized, smaller, more manageable parts list that contains only the parts included in
the migrated data. For more information, see Creating a Full Parts List (page 1382) or Creating a Parts List (page
1381)
To set the default parts list for migration
1 In Toolspace, on the Settings tab, right-click the Pipe Network collection and select Edit Feature Settings.
2 In the Edit Feature Settings - Pipe Network dialog box, expand Storm Sewers Migration Defaults.
3 For Parts List Used For Migration, click the Browse button in the Value cell to select a parts list.
4 Click OK to select the parts list.
When pipe network data is imported into or exported from AutoCAD Civil 3D, this is the parts list that will
be used to search for part families and part sizes.

Quick Reference
Toolspace Shortcut Menu
Settings tab: Right-click Pipe Network collection ➤ Edit Feature Settings ➤ Storm Sewers Migration
Defaults
Dialog Box
Part Matchup Settings Dialog Box (page 2316)
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Launching the Hydraflow Extensions
If you have the Hydraflow extensions installed, you can launch them from the AutoCAD Civil 3D ribbon
or command line.
NOTE AutoCAD Civil 3D must be running in order to start the Hydraflow extensions. Once the Hydraflow extension
is launched, you can terminate AutoCAD Civil 3D if desired.
The extensions are typically installed by default when you install AutoCAD Civil 3D. If you chose not to
install them when you first installed AutoCAD Civil 3D, they can be installed later using Add or Remove
Programs from the Control Panel. For more information, see Add or Remove Features in the Stand-alone
Installation Guide.
You can launch the Storm Sewers Entension using either the StartStormSewers command or the
EditInStormSewers command. For more information, see Editing Pipe Networks Using the Storm Sewers
Extension (page 1350).
To launch Hydraflow Express
➤

Do one of the following:
■

Click the Analyze tab ➤ Design panel ➤ Launch Express

■

On the Pipe Networks contextual tab, click the Launch Pad ➤ Express

■

At the command line, enter StartExpress.

.
.

To launch Hydraflow Hydrographs
➤

Do one of the following:
■

Click the Analyze tab ➤ Design panel ➤ Launch Hydrographs

■

On the Pipe Networks contextual tab, click the Launch Pad ➤ Hydrographs

■

At the command line, enter StartHydrographs.

.
.

To launch Hydraflow Storm Sewers
➤

Do one of the following:
■

Click the Analyze tab ➤ Design panel ➤ Launch Storm Sewers

■

On the Pipe Networks contextual tab, click the Launch Pad ➤ Storm Sewers

■

At the command line, enter StartStormSewers.

.
.

You can also launch the Storm Sewers Entension using the EditInStormSewers command. For more
information, see Editing Pipe Networks Using the Storm Sewers Extension (page 1350).

Quick Reference
Ribbon
Analyze tab ➤ Design panel ➤ Launch Express
Analyze tab ➤ Design panel ➤ Launch Hydrographs
Analyze tab ➤ Design panel ➤ Launch Storm Sewers
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Ribbon ➤ Pipe Networks Contextual Tab
Analyze panel ➤ Storm Sewers drop-down ➤ Edit in Storm Sewers
Command Line
StartExpress
StartHydrographs
StartStormSewers

Importing Pipe Network Data from an .stm File
You can import pipe network data from a Storm Sewers Extension .stm file into AutoCAD Civil 3D.
Pipe networks imported from the Storm Sewers Extension can contain hydraulic property information (page
1424), such as hydraulic grade lines (HGL) and energy grade lines (EGL) and more.
When you import the .stm file, if any of the pipe network names in the .stm file match pipe network names
in the AutoCAD Civil 3D drawing, you must choose to either create new pipe networks, or update existing
pipe networks.
If there are no name conflicts, the new pipe networks are added to the AutoCAD Civil 3D drawing with their
existing names.
Before importing an .stm file, it is important to understand issues associated with importing .stm files that
were saved prior to version 2010. For more information, see Moving Pipe Network Data Between AutoCAD
Civil 3D and Storm Sewers (page 1417).
NOTE It is important to note that rules are not applied to pipes or structures when importing pipe networks from
either LandXML or from the Storm Sewers Extension. For more information about rules, see Part Rules (page 1390).

Matching Pipe Network Names
In cases where the .stm file contains one or more pipe network names that match pipe network names in
the currently open AutoCAD Civil 3D drawing, you will be prompted to choose one of the following options:
Create new pipe network: When you choose this option, the pipe network will be imported into the drawing
as a new pipe network. The name of the newly imported pipe network is appended with a numeric counter
(1). For example, StormSewerNetwork1(1).
Update the existing pipe network: When you choose this option, the pipe network will be imported into
the drawing and it will update the existing pipe network that has the same pipe network name. For example,
if you have a pipe network named StormSewerNetwork1 in the drawing, and you import an .stm file that
contains a pipe network named StormSewerNetwork1, then the StormSewerNetwork1 imported from the
.stm file updates (overwrites) the pipe network named StormSewerNetwork1 in the drawing.

No Matching Pipe Network Names
As previously mentioned, if the pipe network names contained in the .stm file do not match any pipe network
names that exist in the currently open drawing, then the new pipe networks will be added to the drawing
with their existing names. These new pipe networks will be displayed in the drawing and in the Prospector
tree.
To import an .stm file into AutoCAD Civil 3D
1 From the Home tab, click the Insert tab, and then click Import Storm Sewers

.

2 On the Import Storm Sewers File dialog box, navigate to the desired .stm file, select it, and then click
Open.
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You are prompted to either update the existing pipe network, or to create a new pipe network.
3 Choose to either update the existing pipe network, or to create a new pipe network.
NOTE It is important to note that rules are not applied to pipes or structures when importing pipe networks from
either LandXML or from the Storm Sewers Extension. For more information about rules, see Part Rules (page 1390).

Quick Reference
Ribbon
Insert tab ➤ Import panel ➤ Storm Sewers
Or
Pipe Networks contextual tab ➤ Analyze panel ➤ Storm Sewers drop-down ➤ Import File
Menu
File menu ➤ Import ➤ Import Data From Storm Sewers
Command Line
ImportStormSewers

Exporting Pipe Network Data to an .stm File
You can export pipe network data from AutoCAD Civil 3D to an .stm file.
The .stm file can then be opened bythe Hydraflow Storm Sewers exstension for analysis and editing. After
editing the file in Storm Sewers, you can import it back into AutoCAD Civil 3D. Changes made to the file
while in the Storm Sewers extention are recognized in AutoCAD Civil 3D.
You can export one or more pipe networks into an .stm file. You must choose entire pipe networks. You
cannot export individual parts, or a set of connected parts within a pipe network.
It is important to note the following before exporting pipe networks to an .stm file (or any type of export
of pipe data):
■

If a pipe does not have an upstream structure in AutoCAD Civil 3D, it is given a null structure in the
exported file.

■

If a structure is not attached to a pipe, the structure will not be exported.

NOTE You cannot open .stm files that were exported from AutoCAD Civil 3D, or that were saved in the Storm
Sewers Extension for Civil 3D 2010, in the Storm Sewers Extension for Civil 3D 2009, or earlier versions of the
Storm Sewers Extension.
To export an .stm file from AutoCAD Civil 3D
1 Do one of the following:
■

In the drawing, select a pipe network. On the Pipe Networks tab, click the Analyze tab ➤ Storm
Sewers drop-down ➤ Export To File.

■

Click the Output tab ➤ Export panel ➤ Export To File.

■

In Toolspace, on the Prospector tab, right-click the Pipe Networks collection, or right-click the pipe
network you want to export, and then select Export to Storm Sewers .

■

At the command line, enter ExportStormSewerData.
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2 On the Export to Storm Sewers dialog box, specify the pipe networks to be exported, and then click
OK.
3 On the Export Storm Sewers to File dialog box, specify the location and the name for the .stm file, and
then click Save.
To export an .stm file from AutoCAD Civil 3D and open it in Storm Sewers for editing
1 Do one of the following:
■

In the drawing, select a pipe network. From the Pipe Networks tab ➤ Analyze panel ➤ Storm Sewers
drop-down ➤ Edit In Storm Sewers .

■

At the command line, enter EditInStormSewers.

2 On the Export to Storm Sewers dialog box, specify the pipe networks to be exported, and then click
OK.
3 On the Export Storm Sewers to File dialog box, specify the location and the name for the .stm file, and
then click Save.

Quick Reference
Ribbon
Output tab ➤ Export panel ➤ Export To Storm Sewers
Or
Pipe Networks contextual tab ➤ Analyze panel ➤ Storm Sewers drop-down ➤ Export to File
Menu
File menu ➤ Export ➤ Export Data From Storm Sewers
Toolspace Shortcut Menu
Prospector tab: right-click pipe network ➤ Export to Storm Sewers
Command Line
ExportStormSewers
Dialog Box
Export to Storm Sewers Dialog Box (page 2316)

Adding Hydraulic Property Data to AutoCAD Civil 3D Pipe Networks
You can add hydraulic property data to AutoCAD Civil 3D pipe networks in a few different ways.
Pipe networks created in AutoCAD Civil 3D do not contain values for hydraulic property information, such
as hydraulic grade lines (HGL) and energy grade lines (EGL), by default. While the pipe networks contain
the properties for this type of information, the hydraulic properties are set to zero or are “not set” by default.
You can add hydraulic property data to a AutoCAD Civil 3D pipe network using the following methods:
■

by exporting the pipe network to an .stm file, importing that file into the Storm Sewers Extension, and
using the Storm Sewers Extension to add hydraulic properties to the pipe network
You can use the Storm Sewers Extension to perform the hydraulic analysis on the pipe run. Once you
have done this, you can then import the .stm file back into AutoCAD Civil 3D. At this point, the AutoCAD
Civil 3D pipe network will containing the valid hydraulic property data (HGL, EGL, and so on) that it
got from the Storm Sewers Extension.
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■

You can also obtain hydraulic property data by importing an .xml file that contains valid hydraulic
property information.

■

You can also enter your own values for hydraulic properties using the Panorama. This may be useful if
you intend to later import the pipe network data into some other application, such as the Storm Sewers
Extension, to perform hydraulic analysis.

Once you have the hydraulic property data in a AutoCAD Civil 3D pipe network, you can display, edit, and
label the hydraulic grade lines and energy grade lines in profile views. You can also view and edit the specific
hydraulic property data values on the pipe and structure Properties dialog boxes and vistas.
When you add hydraulic analysis data to AutoCAD Civil 3D pipe networks, the following hydraulic properties
are populated with valid values for pipes and structures:
Hydraulic Property

Available for...

hydraulic grade line (page 2776)

pipes and structures

energy grade line (page 2773)

pipes and structures

flow rate (page 2774)

pipes

junction loss (page 2776)

pipes

return period (page 2781)

pipes

known capacity (page 2776)

structures

bypass target (page 2770)

structures

In AutoCAD Civil 3D, hydraulic grade lines and energy grade lines are displayed as a straight line through
structures, connected between the HGL Up or EGL Up property from one pipe to the HGL Down or EGL
Down property of the next pipe. See Viewing Hydraulic Data in Profile Views (page 1426) for an illustration
of a hydraulic grade line and an energy grade line displayed in a profile view.
You can also create label styles that display labels for hydraulic properties, such as HGL and EGL. For more
information, see Labeling Hydraulic Properties in Pipe Networks (page 1413).
To add hydraulic property data to an AutoCAD Civil 3D pipe network
1 In AutoCAD Civil 3D, export the pipe network to an .stm file. For more information, see Exporting Pipe
Network Data to an .stm File (page 1423).
2 Launch the Storm Sewers Extension. For more information, see Launching the Storm Sewers Extension
(page 1421).
3 In the Storm Sewers extension, perform the hydraulic analysis tasks on the pipe network. This adds
valid hydraulic property data (HGL, EGL) to the pipe network. For more information, see the Storm
Sewers extension Help.
4 Export the pipe network from Storm Sewers to an .stm file. For more information, see the Storm Sewers
extension Help.
In AutoCAD Civil 3D, import the .stm file that now contains valid hydraulic property data. For more
information, see Importing Pipe Network Data from an .stm File (page 1422)
Verify that the AutoCAD Civil 3D pipe network contains valid HGL and EGL data. See verifying hydraulic
property data (page 1426).
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To verify hydraulic property data
1 In AutoCAD Civil 3D, right-click a part in the pipe network and select Pipe Properties or Structure
Properties.
2 On the Pipe Properties or Structure Properties dialog box, click the Part Properties tab.
Note the items listed in the Hydraulic Properties section. The values listed here are set when the pipe network
is imported from the .stm file. For more information on these properties, see the Pipe Properties dialog box
(page 2275) or the Structure Properties dialog box (page 2288).

Viewing Hydraulic Data in Profile Views
You can view hydraulic property data (hydraulic grade lines and energy grade lines) from pipe networks in
profile views.
For example, the following illustration shows a hydraulic grade line and an energy grade line displayed in
a profile view.

The energy grade line is displayed as a red dashed lined (on the top). The hydraulic grade line is displayed
as a green dashed line (below the energy grade line).
In order to view hydraulic and energy grade lines in profile views, you must ensure that the following tasks
have been performed:
Task

Description

Add hydraulic property information to the
pipe network by performing hydraulic
analysis on the pipe network using the
Storm Sewers Extension

For more information, see Adding Hydraulic Property Data
to AutoCAD Civil 3D Pipe Networks (page 1424).

Edit the pipe style to configure display
styles for the HGL and EGL components

Edit the HGL and EGL components listed on the Display
tab of the Pipe Style dialog box. You only need to do this
for pipe styles, not for structure styles. See Editing Pipe
Display Styles for HGL and EGL Components (page 1427)for
step-by-step instructions.

Create profile view and profile

For more information, see Displaying Pipe Networks in
Profile Views (page 1364).
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You can also create label styles that display labels for hydraulic properties, such as HGL and EGL. For more
information, see Labeling Hydraulic Properties in Pipe Networks (page 1413).
In addition to viewing the hydraulic and energy grade lines in profile views, you can also view and edit the
hydraulic property data values in the following ways:
Editing Method

Description

Pipe or Structure Properties dialog box

Click the Part Properties tab of the Pipe or Structure Properties dialog boxes, and scroll down to view the values for
hydraulic properties.

Pipe Network Vista

Display the pipe network in the Pipe Network Vista, and
scroll to view or edit the hydraulic property data values.

For more information, see Displaying Pipe Networks in Profile Views (page 1364).
To edit the pipe display style for HGL and EGL
1 In Toolspace, on the Settings tab, expand the Pipe collection, then expand the Pipe Styles collection.
2 Double-click the desired pipe style to edit it.
3 Click the Display tab on the Pipe Style dialog box.
4 Select Profile in the View Direction drop-down.
5 For the Hydraulic Grade Line and Energy Grade Line components, turn on visibility, and set other
display characteristics, such as color and layer, as desired.

Editing Hydraulic Property Data
Editing a pipe network may cause the hydraulic property data to become invalid.
It is important to note that if you choose to edit a pipe network’s physical properties after if has been imported
from an .stm file, the hydraulic information can become invalid. To notify you of this possibility, a warning
message similar to the following is displayed whenever you edit pipe network parts from a pipe network
that has been imported from the Storm Sewers Extension:
A pipe network containing hydraulic properties has been altered and the properties may be invalid.
This message is displayed only the first time you try to edit the pipe network. If you try to edit the pipe
network again, the message is not displayed.
If you do see this message, you may want to use the Edit in Storm Sewers command to export pipe network
data and update hydraulic properties. As a minimum, it is recommended that you verify that the hydraulic
information for the pipe network is still valid, and has not changed in such as way as to cause undesireable
or unexpected results in your design.
If you are editing a pipe network that does not contain values for hydraulic properties, this message is not
displayed.

Understanding Event Viewer Messages
Event Viewer messages alert you to certain conditions when importing and exporting Storm Sewer data.
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The following table provides information on some of the messages that can be displayed in the Event Viewer
when importing or exporting Storm Sewer data.
Event Viewer Message

Description

Multiple barrels were found in the .stm file.

The import is successful, however, one or
more pipe networks in the .stm file contained a No. of Barrels property that is set
to more than 1. In Storm Sewers a No. of
Barrels property that is set to more than 1
creates two lines (pipes) with the same
size, invert, slope, and so on, in parallel.
AutoCAD Civil 3D cannot represent pipes
in this way. Therefore, when you attempt
to import a Storm Sewers file that contains
No. of Barrels set to more than 1, AutoCAD
Civil 3D ignores this value, and displays
this message in the Event Viewer.

Error importing pipe network <pipe network name>: The current layer is locked.

You attempted to import pipe network
data from an .stm file when the current
layer in the drawing is locked, or the object
layers for pipes or structures is locked. In
this case, no new pipe networks are created, and no existing pipe networks are
overwritten. The import is aborted. Unlock
appropriate layers and try importing again.

Error overwriting pipe network <pipe network name>: Objects reside on a locked
layer.

You attempted to update an existing pipe
network with a pipe network from an .stm
file when the current layer in the drawing
is locked, or the object layers for pipes or
structures is locked. In this case, no new
pipe networks are created, and no existing
pipe networks are overwritten. The import
is aborted. Unlock appropriate layers and
try importing again.

Pipe or structure <pipe or structure name>
was not matched exactly. The closest larger
matching part size was used.

The import was successful; however, one
or more Storm Sewers parts could not find
part sizes that matched exactly with AutoCAD Civil 3D part sizes. In cases like this,
AutoCAD Civil 3D uses the closest larger
part size for the imported Storm Sewer
part.

Pipe Network Command Reference
You can use commands to quickly access pipe network functionality.
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The following table lists the pipe network AutoCAD Civil 3D commands and briefly describes their
functionality.
Command

Description

AddNetworkLabels

Invokes a labeling tool to annotate pipes and
structures (page 1404)

AddNetworkPartPlanLabel

Adds labels to selected pipes and structures in
plan view (page 1404)

AddNetworkPartProfLabel

Adds labels to selected pipes and structures in
profile view (page 1404)

AddNetworkPartSectLabel

Adds labels to selected pipes and structures in
section view (page 1408)

AddNetworkPartsToProf

Updates a profile view to show newly added pipe
network parts (page 1364)

AddNetworkPipeTable

Creates a pipe network table (page 1414)

AddNetworkPlanLabels

Adds labels to a pipe network in plan view (page
1404)

AddNetworkProfLabels

Adds labels to a pipe network in profile view (page
1404)

AddNetworkSectLabels

Adds labels to a pipe network in section view
(page 1404)

AddNetworkStructTable

Creates a pipe structure table (page 1415)

AddSpanningPipePlanLabel

Adds labels to connected pipe spans in plan view
(page 1408)

AddSpanningPipeProfLabel

Adds labels to connected pipe spans in profile
views (page 1408)

ApplyRules

Invokes a labeling tool to annotate pipes and
structures (page 1393)

ChangeFlowDirection

Changes flow direction for selected pipes (page
1351)

CreateAlignFromNetwork

Creates an alignment from existing pipe network
parts (page 1338)

CreateInterferenceCheck

Runs an interference check (page 1369)

CreateNetwork

Creates a pipe network by layout (page 1332)

CreateNetworkFromObject

Creates a pipe network from a polyline, line, arc,
or feature line (page 1335)

CreateNetworkPartsList

Creates a pipe network parts list (page 1381)
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Command

Description

CreateNetworkPartsListFull

Creates a parts list that contains all of the parts in
the current pipe network catalog (page 1382)

CreateNetworkReference

Creates a pipe network reference (page 1342)

EditNetwork

Edits a pipe network (page 1345)

EditinStormSewers

Exports selected pipe network to an .stm file, and
then opens it in the Storm Sewers Extension for
editing

EditNetworkPartList

Edits a network part list (page 1384)

ExportStormSewerData

Exports pipe network data to an .stm file for future
import into the Storm Sewers Extension (page
1423)

ImportStormSewerData

Imports pipe network data from the Storm Sewers
Extension (.stm file) into AutoCAD Civil 3D (page
1422)

PartBuilder

Invokes the part builder interface (page 1431)

ResetAnchorPipe

Resets the anchor position of a label that spans
multiple pipe network parts (page 1413)

ResetNetworkLabels

Resets pipe network reference labels (page 1343)

SetNetworkCatalog

Sets a default path for pipe and structure catalogs
(page 1386)

ShowSpanningPipes

Displays the span of pipes that are specified as a
span for labeling a span of pipes with a single label
(page 1408)

StartExpress

Launches the Hydraflow Express extension (page
1421)

StartHydrographs

Launches the Hydraflow Hydrographs extension
(page 1421)

StartStormSewers

Launches the Hydraflow Storm Sewers Extension
(page 1421)
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Part Builder lets you create and modify pipe network parts that are available in AutoCAD Civil 3D part catalogs.

Before You Begin
Part Builder is intended primarily for users who are experienced with parametric modeling design and with
pipe network features.
Individuals who have experience with parametric modeling design, concepts, and techniques should be
comfortable making use of the full spectrum of features available through Part Builder. Individuals with
little or no experience with parametric modeling should be comfortable using the more basic Part Builder
features, such as adding or changing part sizes in existing part families. For more information on these
features, see Editing Part Family Sizes (page 1387).
Before using Part Builder, make sure you understand the following:
WARNING Before using Part Builder to create or modify pipe network parts, it is important that you create and
save a backup copy of the AutoCAD Civil 3D pipe network part catalogs and support files. These files are installed
by default in: C:\Documents and Settings\All Users\Application Data\Autodesk\C3D2011\enu\Pipes Catalog.
Create and save a backup copy of this folder and its contents, including all subfolders and their corresponding
content.
■

Pipe parts created with Part Builder must have a width, a height, and a centerline. Therefore, any pipe
shapes that do not meet this criteria are not supported in AutoCAD Civil 3D pipe networks. This includes
open channel pipes.

■

The section profiles of a pipe must have an enclosed loop. Therefore, it is not possible to create pipe
types such as horseshoe shape or U-shape (open channel).

■

Pipe part definitions must include a uniform wall thickness. Therefore, you cannot create pipe parts with
varying wall thicknesses.

■

Part Builder cannot create a rectangular box culvert shape that has chamfers on the inner diameter
corners.

■

When a pipe connects to a structure, there is a single point of connection between the pipe and the
structure. Therefore, you cannot customize a pipe part to have two connection points at one end of the
pipe, where it connects to the structure.

For more information, see the Pipe Networks chapter in the AutoCAD Civil 3D Best Practices Guide.
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Part Builder Overview
With Part Builder, you can design and edit shapes for drawing content that represent real-world pipe network
parts, such as pipes, manholes, catch basins, and headwalls.
Each piece of content represents a part family, such as concrete pipe, ductile iron pipe, and concrete elliptical
culvert. Each part family contains a collection of part sizes within that part family. For example, within the
concrete pipe part family, there are a variety of pre-defined part sizes available for that part. Part Builder
enables you to create and modify part families as well as individual part sizes.
When you use Part Builder, you can build 2D models of pipe parts, and/or 3D models of structure parts, and
generate 2D drawing views of those parts to use in design layouts. The model you create is defined according
to the size, shape, and position of the features that make up the part. Parts are stored in a part catalog, such
as the US Imperial Pipe Catalog, and you can navigate to and select the part from within a catalog when
you want to add it to your layout.

Accessing Part Builder
To access Part Builder, click Home tab ➤ Create Design panel ➤

Part Builder.

When you do this, the Getting Started - Catalog Screen dialog box is displayed.

Getting Started - Catalog Screen
From the Getting Started - Catalog Screen dialog box, you can choose to work with the pipe catalog or
structure catalog and navigate through the categories within that catalog.

The icons on this dialog box let you perform several tasks. If you position your mouse over an icon, a tooltip
provides an explanation of the icon. Icons are activated based on what is selected in the catalog tree.
If you want to…
create a new

then do this …
select a chapter folder then click New Parametric Part. Enter a
name and description for the new part on the New Part dialog

part
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If you want to…

then do this …
box, and click OK. After doing this, the building environment is
opened for part creation.

modify an existing part size

regenerate the
catalog

test (validate)
the catalog

add a new
chapter for a part

delete a part

select the part in the catalog tree, and click Modify Part Sizes.
The building environment is opened for modifying the part.

after making changes to parts or to a catalog, click Catalog Regen
to regenerate the entire pipe or structure part catalog.

after making changes to a catalog, click Catalog Test to verify
that the validation is successful.

click New Chapter and enter a name. You can add chapters to
the catalog or to another chapter.

select the part and click Delete. The part is deleted from the
catalog and is removed from the catalog tree.

Parametric Building Environment
When you choose to create or modify a part, Part Builder opens a parametric building environment that
includes a variety of features:

■

Part browser. The part browser is displayed on the left side of the screen. It provides an organized view
into the features of the currently selected part. As you define your part, additional features are nested in
a hierarchy under the appropriate folder. In the browser, you can show more or less detail by expanding
or collapsing the folders.

■

Modeling area (viewport). The modeling area (viewport) is displayed on the right side drawing space and
is designed to give you full view control over your part model. You can use the standard AutoCAD view
commands to change the direction in which you view your part model.

■

Toolbar. The toolbar provides quick access to select Part Builder commands. Icons are available for saving
your part, saving an existing part as a new part, generating a preview image, validating your part, and
specifying part options.
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■

Status bar. The status bar, located at the bottom of the part browser, provides updated information about
part validation when you click the Validate icon on the toolbar. A description of the validation status is
provided. A details button provides a list of warnings and/or errors found in your model.

■

Feature-specific menus. Feature-specific menus are available by right-clicking a part feature in the browser
window. Options not available are shaded.

Understanding Parametric Parts
Parametric parts give you the flexibility to create pipe network parts that are dynamically sized according
to size parameters.
You define a parametric part by creating a 3D model of the part and assigning variables, or parameters, to
control its shape and size. Parameters are defined by individual values, lists of values, or calculated values
based on equations. When the pipe network part is placed in your drawing, you select specific part sizes and
the part is dynamically built to reflect the specified shape and size. Parametric parts enable you to create a
single 3D model for a part family that can be updated to represent multiple part sizes. You can define millions
of parts through a single model, depending on the number and type of parameters defined.
It is beneficial to create pipe network shapes as parametric parts for many reasons. Many of the shapes used
to represent pipe network components share the same geometric features; however, the features change in
size according to the design. For example, an 8-inch circular PVC pipe looks just like 10-inch PVC pipe
except for the pipe diameter. Similarly, you may have two headwall structures that are the same basic shape
but have different heights, widths, or both.
■

Pipes: An 8-inch circular pipe looks the same as a 10-inch circular pipe, except for the size of the diameter.
By creating a parametric part, you can create a 2D cross section of a circular pipe and assign a parameter
for the pipe diameter that can change in size. When the pipe is placed in your drawing, the 3D pipe uses
this cross-sectional shape parametrically sized to match your part size selection. You specify which size
pipe you want and the appropriate diameter is dynamically built to match.

■

Structures: A 38-inch concentric catch basin looks the same as a 48-inch catch basin, except for the height
and diameter. By creating a parametric part, you can create a 3D model of a catch basin structure and
assign parameters for the height and diameter that can change in size. When the catch basin is placed
in your drawing, you can specify the height and diameter, and the appropriate size catch basin structure
is dynamically built to match.

Key Terms
Understanding the following key terms will help as you begin using Part Builder.
constraint Controls the shape of a feature by establishing relationships between features in the model.
degree of freedom In part modeling, determines how a geometric object, such as a line, arc, or circle, can
change shape or size. For example, a circle has two degrees of freedom: center and radius. When these values
are fixed, degrees of freedom are said to be eliminated.
dimension Controls the size of a feature. When changed, the feature is resized. May be expressed as a
constant value, a value as part of a table, a calculated value, or a list of values.
domain Refers to the part category. There are only two domain types by default: pipes and structures. Each
domain type has a unique behavior in AutoCAD Civil 3D.
feature A building block of a pipe network part model. You combine features to create pipe network part
models.
model The part shape representing all possible sizes, and defined by parameters, geometry, dimensions, and
geometric constraints.
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parametric A solution method that uses the values of part parameters to dynamically size the part.
part size A specific set of values applied to the parametric model to define a single size.
work plane An infinite plane related to one or more features of the model. Work planes provide a defined
place in space from which to build the model.

Overview of Creating a Part
This section provides an overview of the steps involved with creating a part.
When you create a pipe network part, you define the features of the part and how they are associated with
one another. Each pipe network part represents a unique part family. You should analyze the pipe or structure
catalog hierarchy to determine the best place to add part families. It is also important to notice the
relationships between the different part sizes you want to create. The features you define in the model
determine the flexibility you have to create multiple part sizes. You should look at the entire part you want
to create, decide how to break it down into simple shapes, and determine the relationships to establish
between the different shapes.
Creating a part with Part Builder involves performing the following tasks in the order they are presented
below:
1 Specify the part configuration.
You work in the parametric building environment to create single pipe network parts. While you are
working in this environment, only one part can exist in a drawing. The individual drawings are associated
with a part catalog to build a library of parts. You specify the type and subtype of the part to establish
basic part behavior. For more information, see Part Configuration (page 1435).
2 Create a 2D or 3D model of the part.
During this phase of the process, you create models of 2D pipe parts, or 3D structure parts, and use
them to dynamically generate 2D views of the part. You build your part from features that are combined
to define the part. The model is defined according to the size, shape, and position of its features. You
can restrict how the features of the parts fit together. To better conceptualize the size and shape of the
part model, you define dimensions, constraints, and modifiers that determine how your part is built.
For more information, see Part Modeling (page 1436), Dimensions (page 1440), Constraints (page 1441), and
Modifiers (page 1443).
3 Generate a preview image and define the insertion position of the part.
Once you have finalized the model, you generate a preview image for the part by taking a snapshot of
the model. You also specify the placement position that you use to place the part in your drawing. For
more information, see Generating a Preview Image of a Part (page 1461) and Defining Part Insertion
Position (page 1461).
4 Validate and save the part.
Once you have finalized the model, you must validate and save the part. Validation checks the model
and detects any errors that make the part invalid. You must correct all errors in order to successfully
save the part and add it to a drawing. For more information, see Validating and Saving a Part (page 1462).

Part Configuration
Defining the part configuration is the first step in creating a part.
When the parametric building environment opens, the top folder in the part browser is the Part Configuration
folder. The part configuration defines the characteristics and behavior of the part according to the domain
(pipe or structure), type, and subtype, and it is required to save the part. To ensure that the part can be
validated and saved correctly, you should define the part configuration before starting to model the part.
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The part configuration is defined once for a part family and remains constant for all part sizes. The following
components are required to define the part configuration:
Part Name You cannot change the part name of existing (default) parts. This is because part names for
existing parts are used in the filenames for the parts. You can, however, create a new name for a new part
using Save as.
Part Description Describes the part family. When you create and name a new part, you enter the description
in the New Part dialog box. By default, the description is the same as the part name unless a different
description is entered. For existing parts, the part description is predefined.
Part Domain Defines the family of parts. The two basic domains are pipes and structures. You cannot edit
the part domain in the part browser. The part domain is predefined based on the part catalog you selected
in the Getting Started - Catalog Screen dialog box of Part Builder. The part domain is selected from a list of
predefined domains for pipe networks (pipes and structures). In the illustration above, the part domain is
Structure.
Part Type The part type defines certain behavior properties that are assigned to the part.
For pipes, the predefined part type is always “pipe”. A variety of pipe shapes may be available; for example,
circular, egg-shaped, elliptical, and rectangular. However, they are all defined with same part type (pipe).
For structures, the predefined part types include general, inlet-outlet structures, and junction structures. As
previously mentioned, the part type defines certain application behavior properties that are associated with
the part. A general structure, for example, has a different set of application behavior properties than an
inlet-outlet structure, and so on. In the illustration above, the part type is Inlet-Outlet Structure.
From the part browser, you can specify the part type by right-clicking on an item under Part Configuration
and choosing Edit. The list of predefined part types is displayed.
Part Subtype Lets you organize parts into more detailed, logical groupings. This grouping does not affect
the part behavior. In the part browser, you specify the part subtype from the list of predefined subtypes.
You can also enter a custom part subtype if you wish. The part subtype is helpful during part selection to
filter a large group of parts that are of a similar type. In the illustration above, the part subtype is Undefined.

Part Modeling
Modeling a part involves configuring a variety of part features.
In Part Builder, the term model refers to the graphical representation of a part. A model consists of various
features that have specific relationships to each other and that define the behavior of the part. Some features
require that you create simple shapes or points, while others require an extrusion or path. Some features
represent visible geometry, and some help you to position geometry precisely on a part. You can modify
features to refine and improve your parts over time. You change features by modifying their size and shape
or by flipping or moving them. To effectively model a part, it is important to understand how each feature
relates to the other features of modeling.
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The following illustration shows the features that make up the model. Arrows indicate the direction of the
relationship between features. For example, modifying geometry affects a profile, which affects a modifier,
and so on.

The following sections introduce the features of modeling. Refer to this illustration as you learn more about
each feature to help you understand the relationships between features.

Work Planes Overview
Use work planes to define a part, position geometry, and define relationships between part features.
In Part Builder, a work plane is a modeling feature that defines the location of a plane in three-dimensional
(3D) space. It is an infinite construction plane that can be placed at any orientation in space. It can be offset
from an existing work plane, or it can reference 3D geometry. Using a work plane, you define the geometry,
dimensions, constraints, and profiles that make up the part model. Work planes help you to place geometry
that would otherwise be difficult to position. By constraining geometry to work planes, you can control
their location. Work planes help you to define relationships between features and provide control when
placing features.
A work plane is displayed as a rectangular two-dimensional (2D) object. The work plane display is only a
visual representation of the infinite plane and cannot be moved or resized. However, you can control its
visibility for ease of viewing the model. Offset and reference work planes are user-defined and provide the
flexibility to be moved and redefined.
NOTE To ensure a manageable model size, it is recommended to use a minimum number of work planes.
When you right-click on a work plane in the part browser, it is highlighted in the modeling area. You can
change the view direction to match that of the selected work plane when adding geometry or dimensions
by using the Set View option on the Work Plane shortcut menu.
IMPORTANT Any features attached to a work plane are restricted to the original plane. If you move a work plane,
any features attached to the plane also move. If you delete a work plane, any features attached to the plane are
also deleted. Each feature attached to a work plane appears under the Work Plane folder in the part browser.
Part Builder provides three default work planes that intersect at the origin of the X, Y, and Z axes. The default
work planes help you to get started with modeling a part. Generally, it is best to start your modeling in the
top work plane, and add others as needed. You can add work planes at any time during the modeling process.
Each work plane has its own internal coordinate system. Work planes can be created on any plane in the
current user coordinate system (UCS) or in the World Coordinate System (WCS).
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The following preset work planes can be added to a model from the Create Work Plane dialog box:
Default Creates the standard ZX, YZ, and XY work planes of the WCS.
Custom Creates a work plane that is not available by the preset work planes. The work plane has user-defined
values for the X and Y direction and the origin of the plane in the current UCS.
Offset Creates a work plane that is offset by a specified distance from a selected source work plane. For more
information, see Offset and Reference Work Planes (page 1438).
Reference Creates a work plane that is attached to the extents of a modifier feature. For more information,
see Offset and Reference Work Planes (page 1438).
Top Creates a work plane that matches the standard Top 3D view.
Bottom Creates a work plane that matches the standard Bottom 3D view.
Front Creates a work plane that matches the standard Front 3D view.
Back Creates a work plane that matches the standard Back 3D view.
Left Creates a work plane that matches the standard Left 3D view.
Right Creates a work plane that matches the standard Right 3D view.
Viewing default work planes

Offset and Reference Work Planes
Offset and reference work planes are relational and are based on one or more defined features in the model,
such as other work planes or modifiers.

Offset Work Planes
An offset work plane is a specified distance away from another work plane. This work plane can be offset
from any existing work plane, including another offset or reference work plane. You define an offset work
plane by selecting a source work plane and specifying a distance between the work planes. You can use offset
work planes to maintain specified or calculated distances between features, such as profiles, geometry, or
modifiers. You can also use offset work planes as construction guides for locating features that would otherwise
be difficult to locate. For example, use an offset work plane to define the length of a transition.
Creating an offset work plane
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Reference Work Planes
A reference work plane is defined as a plane on the face of the extents of a modifier. Every modifier has an
invisible extent, or boundary box, that defines the extents of the feature. You can create a work plane that
references one of the planes of the extent. To define a reference work plane, you select a modifier and a
source work plane that represents the plane direction you want to create. The extents, or boundary box, of
the feature is detected, and two valid reference work planes are available for selection. If the modifier is
moved or resized, the reference work plane is moved with it.
Creating a reference work plane

Geometry
Geometry features are the basic building blocks for defining the size and shape of the model.
In Part Builder, geometry that you define is constraint based, two-dimensional (2D), and must be attached
to a work plane. You can switch between work planes to define different geometry. As you add geometry to
a work plane, the geometry features appear under the Geometry folder of the associated work plane.
WARNING Avoid using basic AutoCAD geometry commands. AutoCAD geometry is not valid for work planes
and cannot be used to create features for part models.
Viewing geometry types

Part Builder provides nine types of geometry you can use to build the model:
Point Defined by an X and Y coordinate.
Line Defined by a position and a direction; constrained by a start point and endpoint.
Unbounded Line Defined by a position and a direction; infinite in length because it has no constraining
start point or endpoint.
Circle Defined by a center point and a radius.
Arc Defined by a center point and a radius; constrained by a start point and endpoint.
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Rectangle Defined by lines and points that are constrained to maintain start points and endpoints for each
side and perpendicular angle.
Oval Defined by lines, arc, and points that are constrained to create two arcs tangent to two lines, with
defined start points and endpoints.
Point Reference Defined by a point in the work plane that is based on a source point selected from a different
work plane. A point reference is moved or deleted with the source point.
Project Geometry Defined by a projection of a modifier on a specified work plane. The project geometry is
fixed and cannot be moved in the work plane. It is linked to the modifier and adjusts as the modifier changes.

Dimensions
Add dimension information to specify the length, diameter, or rotation angle of geometric elements in the
model.
Models require dimension information to define the size and position for the design. Dimensions are typically
added after you have finalized the geometric features of the model; however, you can add dimensions at
any time during the creation process. When you add dimensions, you apply rules that control the size and
position of features in the model. Dimensions work in conjunction with constraints. The model is updated
when changes are made to the dimensions.
Dimensions specify the length, diameter, or rotation angle of geometric elements in the model. When a
dimension is added, a corresponding size parameter is also added. This parameter creates a placeholder value
for the dimension that provides flexibility for defining the values of dimensions. Dimensions can be defined
as default numeric constants or as equations. Although you can use them interchangeably, they each have
specific uses.
■

Numeric constants are useful when a geometric element has a static or fixed size that is populated as a
value in a basic table, list, or constant storage type.

■

Equations are useful when the size of a feature icon must be mathematically defined relative to the size
of another feature.

Part Builder assigns a variable name to each dimension parameter. Letters and numbers are used to signify
the type of dimension (such as length or diameter) and the sequence in which the dimension was added to
the model (1 for first, 2 for second, and so on). To keep the model shape from becoming distorted as the
dimensions resize it, define the large dimensions first. Dimension type depends on the feature you choose
and where you place the dimensions.
NOTE When adding dimensions it is recommended to select points to specify the start and end locations. It is
also helpful to turn off geometry that you not dimensioning for ease of selection.
Viewing dimension types
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Part Builder provides seven types of dimensions you can add to the model:
Distance Can be defined for pairs of geometry of all types. Defines a value between two features. The value
of a distance dimension cannot be negative. When adding distance dimensions between two lines, it is
implied that the lines are parallel with a given separation.
Horizontal Distance Can be defined for pairs of geometry of all types. Defines a value between two features
in a horizontal direction. The value of a distance dimension cannot be negative.
Vertical Distance Can be defined for pairs of geometry of all types. Defines a value between two features
in a vertical direction. The value of a distance dimension cannot be negative.
Parallel Distance Can be defined for pairs of geometry of all types. Defines a value between two features in
a parallel direction. The value of a distance dimension cannot be negative.
Perpendicular Distance Can be defined for pairs of geometry of all types. Defines a value between two
features in a perpendicular direction. The value of a distance dimension cannot be negative.
Diameter Can be defined for circular and arc geometry. Defines a value for the diameter of a circular feature.
Angle Can be defined for pairs of linear geometry. Defines a value for the degrees between two linear features.

Constraints
Add constraints to create rules that control how a part can change in shape or size.
Depending on the geometry of the model, you may need to add one or more constraints to define the shape
or size of the model. Constraints enforce rules that you want the model to obey. Constraining a model
controls how a model can change in shape or size, called “degrees of freedom.” For example, a circle has
two degrees of freedom: the location of its center and its diameter. If the center and diameter are defined,
the circle is fully constrained and those values can be maintained. Constraints specify the relationships of
geometric features; for example, whether two features are perpendicular, parallel, tangent, concentric, or
have the same midpoint or radius.
NOTE After you add geometry, dimensions, or constraints to the model, the degrees of freedom are listed on the
command line.
Constraints work in conjunction with dimensions to control the shape and size of the model. Any time you
modify the model, the geometry retains the relationships among features in accordance with the applied
constraints. You add constraints to indicate your design intent. For example, a parallel constraint could be
defined between two lines based on the geometry of the model. You could also add a constraint to force
both lines to have the same length.
As you apply geometric constraints, continue to analyze the model, reviewing and replacing constraints as
necessary. As you gain experience, you will be able to determine which constraints control the model to
meet your design requirements. Some constraints work only with lines, while others work only with arcs,
circles, or points.
See Adding a Constraint (page 1459) for step by step instructions on how to add a constraint.
Applying a tangent constraint
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Applying a parallel constraint

Applying a perpendicular constraint

Applying a concentric constraint

Part Builder provides ten geometric constraints. The following list describes these constraints and the features
with which they can be used.
Tangent Can be defined between curved geometry (such as a circle or arc) and either another curved geometry
or a line. Makes two curves tangential to one another, even if they do not physically share a point. Tangency
is commonly used to constrain a line to an arc or circle.
Parallel Can be defined between pairs of geometry with a direction, such as lines. Causes two or more lines
to be parallel to one another.
Perpendicular Can be defined between pairs of geometry with a direction, such as lines. Causes selected
lines to lie at right angles to one another.
Concentric Can be defined for any combination of circles and points. Fixes the centers of the geometry to
the same location. Common uses include circle to circle, where the center of both circles is the same; circle
to point, where the point lies at the center of the circle; and point to point, where the points are the same.
Coincident Can be defined between a point and any geometry. Fixes two points (including center points)
together; essentially, the point lies on the geometry.
Equal Distance Can be defined between two pairs of geometry. The distance between the first pair of
geometries is fixed to the distance between the second pair. Equal distance constraints do not control the
actual distance. Each pair of geometries must be one of the following: any combination of points and lines,
two circles or arcs concentrically constrained, or a point and circle or arc concentrically constrained.
Equal Radius Can be defined between two circles or two arcs. Fixes the radius of both circles or arcs to be
of the same value. Equal radius constraints do not control the value of the radii.
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Midpoint Can be defined between a point and either two other points or two lines. The point is equal
distance from the other two geometries. Midpoint constraints do not control the distance. A common use
is constraining a point to the middle of a line.
Symmetric Can be defined between two geometries of the same type and a line. The two geometries are
symmetrically arranged on opposite sides of the line. The symmetric constraint does not force constrained
geometry to maintain an exact mirror image.
Normal Can be defined between a line or curve and a curve. (Two lines cannot be made normal; a
perpendicular constraint must be used instead.) The curves intersect and the directions of curve tangents
are perpendicular at the point of intersection. A common use is constraining a line to the normal of an
ellipse.

Profiles
Create profiles to define a two-dimensional (2D) outline of a part’s geometric shape.
Using Part Builder, creating a profile is as easy as drawing a closed shape. Profiles are similar to geometry in
that they are a visual representation of the 2D shapes that make up the model. Because profiles automatically
associate constraints to the geometry, you can use profiles as a source of information from which to create
features. You create profiles on a work plane and apply modifiers, such as extrusions, to them.
NOTE Profiles can be used to create solids using modifiers. Non-profile geometry cannot be used to create solids
directly. However, you can group a set of non-profile geometries together to create a custom profile.
Part Builder provides four types of profiles to use for creating features in the model:
Circular Creates a profile based on a circle defined by a center point and diameter to maintain its shape.
Rectangular Creates a profile based on a rectangle defined by four lines, four points, and four perpendicular
constraints to maintain its shape.
Oval Creates a profile based on an oval defined by two lines, two arcs, four points, and four tangent
constraints to maintain its shape.
Custom Creates a profile from existing geometry in the model. The geometry must be attached to a single
work plane. Constraints are assigned as needed to maintain the shape of the geometry as it was selected.

Modifiers
Use modifiers to create three-dimensional features of the model.
A modifier is a general term for any operation that affects features of the model. After creating profiles, you
can use modifiers to extrude, add, or subtract features and to sweep a profile along a path. You can also use
modifiers to create cut planes and transition features.
Part Builder provides six types of modifiers: extrusion, path, transition, cut plane, Boolean add, and Boolean
subtract. The extrusion modifier is the most common type used in part modeling and is generally the base
feature for a model. When you extrude a profile to create a feature, you specify how the feature will modify
the shape by choosing one of four operations: midplane, plane, from-to, or blind.
See Applying a Modifier (page 1460) for step by step instructions on how to apply a modifer.

Midplane Extrusion Modifier
A midplane extrusion uses a profile as the center of the extrusion and sweeps the profile an equal distance
away from each side of the center.
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Applying a midplane extrusion modifier

Plane Extrusion Modifier
A plane extrusion sweeps a profile between the profile itself and a specified work plane. If the work plane is
a reference work plane, the extrusion is updated when the work plane is moved.
Applying a plane extrusion modifier

From-To Extrusion Modifier
A from-to extrusion sweeps a profile between two work planes.
Applying a from-to extrusion modifier

Blind Extrusion Modifier
A blind extrusion sweeps a profile a specified distance along its normal, or perpendicular axis. You can flip
the extrusion to sweep the profile in the opposite direction as the default normal.
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Applying a blind extrusion modifier

Path Modifier
A path modifier sweeps a profile along path geometry. It creates a 3D feature based on the start and end
profile of a piece of geometry, such as a line or an arc. The start and end profiles can be different.
Applying a path modifier

You can also specify the number of segments to use to create a 3D feature.

Transition Modifier
A transition modifier creates a transition body between two profiles. A transition includes both a start and
end profile, which cannot be in the same work plane. Point references are useful to ensure that the profiles
align between work planes; however, the centers do not need to align.
Applying a transition modifier
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Cut Plane Modifier
A cut plane modifier cuts a feature into two parts, only one of which is kept. A cut plane modifier enables
you to change the end of a feature to a slope, providing for the creation of more advanced features, such as
an exhaust vent. You can modify the cut plane by dragging the normal, or perpendicular axis, of the modifier
to create custom slopes. Cut planes are updated when the length of the modifier changes.
NOTE Cut planes cannot be defined parametrically. How they are defined in the model is how they will be
displayed when placed in your drawing.
Applying a cut plane modifier

Boolean Add Modifier
A Boolean add modifier combines two features to create a single feature. This modifier assumes a basic
concept of addition: that geometry inside other geometry, when added together, is removed. This modifier
is helpful when creating models of parts that are placed in your drawing exactly as they were created in the
model.
Applying a Boolean add modifier

Boolean Subtract Modifier
A Boolean subtract modifier subtracts one or more features from another to create a new feature. The Boolean
subtract modifier uses a basic formula when creating the resulting feature: that the subtractor objects are
removed from the base object. To see results in the model, the subtractor features must intersect with the
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base feature. When no intersection of features exists, the subtractor features are removed from the base
feature with no visible change in the model.
Applying a Boolean subtract modifier

Placement Points
Use the Autolayout Data option to define the part placement point in the drawing.
After finalizing the part model, you need to define the placement point for the part to ensure that it can be
placed correctly in a drawing. The Autolayout Data option in the part browser controls how placement
points can be defined. When you enable this option, an Autolayout Data folder is available in the part
browser that includes commands for adding placement points.
This is done by selecting a fixed point in the model. This point must be in the z = 0 plane. By choosing a
fixed point, the parametric model will retain this position as it is dynamically sized.

The placement point is the insertion point used to place the part in a drawing. You simply specify a point
in your model for the placement point.

Model Parameters
Configuring model parameters enables you to control the model’s shape and size by establishing relationships
between defined parameters.
As you add dimensions and constraints to the model, parameters appear under the Model Parameters folder
in the part browser. The Model Parameters dialog box provides a central location where you can view, create,
and edit the dimensional parameters of the model. You can define parameters to create additional model
relationships later.
It is often more efficient to assign numeric values to dimensions and other feature parameters as you build
the model. When you finalize the geometry, you can edit the model parameters to add calculated values.

Placement Points | 1447

An equation assistant is available in the Model Parameters dialog box to ensure that the equation you create
is valid and can produce a result. Each parameter in the Model Parameters dialog box includes the following:
Name A unique identifier for the model parameter. Model parameters are assigned default names, such as
LenB1, (Length Body 1), WTh (Wall Thickness), PID (Pipe Inner Diameter), and BdyD1 (Body DImension
1), that can be changed. Model Parameter names are typically short acronyms because they can be used in
equations. User-defined parameters must have unique names.
Value The result of evaluating the equation.
Equation The mathematical expression that defines the value of the parameter. Constants, other model
and user-defined parameters, and mathematical operators can be used in an equation. You can use the
Equation Assistant to define the equation.
Description A narrative, user-defined description of the parameter.
NOTE When using a constant value in an equation, be sure to define the constant as a model parameter. You
should verify that the result of the equation is non-zero to avoid undesirable results in your model.

Size Parameters
Part sizes are controlled by size parameters that set the dimensions of the part size.
Model parameters define the default part size of the model, and act as placeholders for new values that can
be specified later. There is a direct connection between the model parameters and size parameters in that
each model parameter is added to the size parameters in the part browser. Size parameters enable you to
create different sizes for the model to represent multiple part sizes and to add non-graphical parameters to
the part family.
You work with size parameters in the Edit Part Sizes dialog box. This dialog box lets you view and edit
parameter values and configuration attributes in a table. Each parameter is viewed or modified independently
of the others, so you can modify a single parameter at a time without scrolling through a large table.
The Edit Part Sizes dialog box has three working modes: Calculations, Parameter Configuration, and Values.
■

The Calculations mode provides access to the calculation formula of the parameter.

■

The Parameter Configuration mode provides access to attributes of the parameters, and includes
description, data storage, data type, units, visibility, context, and index.
NOTE When parameters are added to the model, the name, data storage, context, and type attributes are
assigned, and they cannot be changed.

■

The Values mode provides access to defined values of the parameter when they are stored as constants,
lists, and tables.
NOTE Any calculations set in the model are fixed and can be changed only in the model.

The parameter configuration allows you to configure data storage. The type of data storage lets you define
the parameter as a list or table of values, in addition to a constant or calculated value. You can also revise
the parameter description and control parameter visibility. For more information, see Adding Individual
Part Sizes (page 1456). You can define constant values, and copy and paste lists of values from other parts to
define multiple part sizes. Calculated values can only be viewed. Use the Model Parameters dialog box to
modify formulas for calculated values.
By creating a new parameter, you can define values that store additional information about the part. You
can add custom parameters in which you define all parameter attributes, such as data storage type. You can
also add parameters by selecting from a list of optional parameters that have been defined for you. The list
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of predefined parameters is determined by the part type and existing parameters found in the part family.
These parameters provide additional part information that can help to identify parts in your drawing during
the design process or when you produce a set of construction documents.
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This section provides step-by-step procedures, illustrations, and tips for creating pipe network content using Part Builder.
In AutoCAD Civil 3D, content is used to represent real-world pipe network parts such as pipes, manholes, catch basins,
and headwalls. Pipe shapes are organized into the following part family categories based on the shape of the pipe: circular,
egg-shaped, elliptical, or rectangular pipes. Structure shapes, such as manholes, catch basins, and headwalls, are organized
into the following categories, or part families, based on shape characteristics: general structures, inlet-outlet structures
(headwalls), junction structures (catch basins). Part Builder enables you to create and modify part families as well as
individual parts.

Tips for Creating Parts
Make sure you understand these tips before modeling parts with Part Builder.

Tips for Using Part Builder
Keep the following tips in mind as you use Part Builder:
■

Save a backup copy of the part catalogs before using Part Builder, in case you need to revert to the original
catalogs provided with AutoCAD Civil 3D. You can use a browser application, such as Windows® Explorer,
to copy and paste the catalogs and their sub-folders to a new location.

■

Determine model dependencies. Analyze the model design to determine how features interrelate; then
decide how to create the model.

■

Work in a three-dimensional (3D) view. Creating the model in a two-dimensional (2D) view may lead
to confusion.

■

Start any new model in the top work plane and pick your fixed insertion position before modeling.

■

Use the order of the folders in the part browser as a guide to the steps involved in the creation process.

■

Do not use the EXPLODE command. Exploding a part deletes the part definition from the catalog.

■

Part Builder generates drawing views of your pipe network part. The AutoCAD MVIEW command does
not create associative views of your parts.

■

AutoCAD object snaps can be used to assist in object selection.
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Tips for Modeling the Part
Keep the following tips in mind as you model the part:
■

Use work planes to control the UCS orientation. Using the AutoCAD UCS command does not associate
the current plane with your part.

■

Use the AutoCAD Point Style command to increase point sizes. It is recommended to use an absolute
point size.

■

Use a minimum number of points. Reusing points is less confusing and helps in constraining the model.

■

Use both constraints and dimensions. Some constraint combinations may distort unconstrained features
of the model. If so, delete the last constraint and consider using a dimension or a different constraint
combination.

■

Use Part Builder dimensions. AutoCAD dimensions are not parametric and therefore cannot control the
size, shape, or position of part content.

■

Dimension large features before small features. To minimize distortion, define larger features that have
an overall bearing on the model. Dimensioning small features first may restrict overall size. Delete or
undo a dimension if the model shape is distorted.

■

Define shape before size. If you apply constraints before dimensions, your model shape is less likely to
become distorted.

■

Determine model dependencies before applying constraints. A single constraint can often be used to
define more than one feature’s shape. Therefore, analyze the model design to help identify necessary
constraints.

■

Add constraints as needed to define the model shape. Because constraints often restrict more than one
feature, use fewer constraints to avoid distorted models.

■

When using calculated values for model parameters, be aware that calculated values are not available in
the part Add Size dialog box.

Creating a Part
This section contains step-by-step instructions for creating a simple part using Part Builder.
Each section describes a separate phase in the creation process. You should perform the steps in the order
in which they are presented to avoid creating unusable parts.

Creating a New Part
Use this procedure to start Part Builder and to begin creating a new part.
1 Click Home tab ➤ Create Design panel

Part Builder

.

The Getting Started - Catalog Screen dialog box is displayed.
2 Select the Structure part catalog by selecting Structure from the Part Catalog list at the top of this dialog
box.
3 Select the Simple Shapes folder, then click New Parametric Part

.

The New Part dialog box is displayed.
4 Enter a name for this new part family. For example, enter Simple Cylinder 2.
5 Click in the Description field.
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By default, when you click in the Description field, the description is the same as the part name until
you change it. You can type over this text to change it or add to it.
6 Click OK to create the new, undefined part family.
The new part family is displayed in the part browser window.
7 Proceed to Specifying the Part Configuration (page 1453).

Specifying the Part Configuration
Use this procedure to specify the part configuration, defining certain behavior of the new part family you
just created (Simple Cylinder 2).
1 In the part browser, expand Part Configuration.
2 To specify the part type, right-click Undefined Part Type, click Edit, and select a part type, such as
General Structure.
The predefined part types are dependent on the selected part domain. For example, for a pipe part, the
only available part type choice is “Pipe”. For structure shapes, which are more complex than pipe shapes,
there are multiple part type choices, such as general, inlet-outlet structures, junctions structures, and
so on.
3 To specify the part subtype, right-click Undefined Bounded Shape, click Edit, and select Cylinder.
The list of predefined subtypes depends on the selected type. For example for pipes, choices are arched,
circular, egg-shaped, elliptical, rectangular, and undefined shape. For structures, you can specify the
following subtypes for undefined bounded shapes: box, cylinder, sphere, and undefined.
4 If desired, you can also enter a new subtype.
5 Proceed to Modeling a Part (page 1453).

Modeling a Part
To model a part, you must first define work planes on which to create the geometry of your model.
You can then create profiles and apply modifiers to define the shape and default size of the part. To avoid
distortion in the model, start with the larger features, which have more impact on the overall size of the
part, and then add the smaller features.

Establishing Work Planes
Use this procedure to add work planes on which to create the geometry of the model.
To avoid confusion, work with only one work plane visible, unless you are using offset or reference work
planes.
1 In the part browser, expand Modeling.
2 Right-click Work Planes and click Add Work Plane.
The Create Work Plane dialog box is displayed.
3 Click Top and then click OK.
The top work plane is created.
You can add other types of work planes as needed. For more information, see Work Planes Overview
(page 1437).
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4 To view the work planes in the modeling area, on the View menu, click 3D Views ➤ SW Isometric.
You can select any view direction or use the Views toolbar to zoom extents of your work planes.
5 In the part browser, expand the Work Planes folder.
When you select a work plane in the part browser, the work plane is highlighted in the modeling area.
6 Add more work planes as necessary to model the shape.
To avoid confusion, work with only one work plane visible at a time. To make only one work plane
visible at a time, in the part browser, right-click a work plane and remove the check from the Visible
check box (uncheck it).
When a workplane is marked as unvisible, the workplane icon in the part browser is grayed out, and
the work plane itself is not displayed in the modeling area.

Modeling a New Part
Use this procedure to model the new part you are adding.
Modeling any part typically involves adding a profile, geometry, dimensions, and constraints. You may need
to add extrusions, but these are typically used for more complex structure shapes.
For a simple cylindrical structure part, the profile is circular, the geometry is typically fixed center, and an
example of a constraint is concentric. Dimension parameters define various diameters for the shape. For
example, a dimension parameter named BdyD1 is used to define the diameter for the body of a simple
cylindrical structure.
1 To create the new cylindrical structure, in the part browser, right-click XY Plane and click Add
Profile ➤ Circular.
For more information about profiles, see Profiles (page 1443).
2 Select a center point in the modeling area and specify a second point, or enter a value such as 12, to
define the cylindrical shape radius.
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A circular profile is created and is added to XY Plane in the part browser.
3 The next step is to add model dimensions to the part. Proceed to Adding Model Dimensions (page 1455).
For some shapes, you may want to add constraints or extrusion modifiers. For more information, see
Constraints and Modifiers in Understanding Part Builder.

Adding Model Dimensions
Use this procedure to add dimensions to specify the overall default size of the model.
Dimensions are used to define the default size of a part family (or part within a part family). You can add
other sizes, such as a list of values, to create individual part sizes within a part family.
TIP You may find it easier to add model dimensions in the top view, rather than in a model view direction. To
change the view, on the View menu, click 3D Views ➤ Top.
1 To define the overall length of the part, in the part browser, right-click Model Dimensions, and then
click Add Distance.
NOTE For constant parameter values, you can define a constant dimension, or choose not to add a dimension
and use the default value based on the actual size of the geometry. When no dimensions are added, the
parameter and its value are not displayed during part size selection.
2 Select the model modifier feature in the modeling area, and specify a location to place the dimension.
A length dimension (for example, LenB1 or LenB2) is placed in the model and is added to Model
Parameters and Size Parameters in the part browser.
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3 To modify the default, or to specify a calculated value for the length of the component, in the part
browser, expand Model Parameters, right-click a length dimension, and click Edit.
The Model Parameters dialog box is displayed.
4 Double-click the Equation column value for a model parameter (such as LenB1), and you can enter a
value or an equation to specify the length of the part.
TIP Click Calculator to access the Equation Assistant.

5 The next step is to add individual part sizes to the model. Proceed to Adding Individual Part Sizes (page
1456)

Adding Individual Part Sizes
Use this procedure to add individual part sizes to the model.
You create individual part sizes by adding parameter values. Values can be a list or table of values, a constant
value, or a calculation.
You can also create unique part size names. Each part size name is generated using a calculation – a formatted
string of parameter values and text.
The set of default size parameters that are available for each part differs depending on the part type. For
example, a structure part defined as a junction structure (part type = junction structure) has a certain set of
default size parameters that are appropriate for junction structures. Inlet-outlet structures (part type =
inlet-outlet structure) have a different set of default size parameters available. Pipe parts have yet another
set of available size parameters.
1 To add part sizes, in the part browser, right-click Size Parameters and click Edit Configuration.
The Edit Part Sizes dialog box is displayed, showing all of the currently available size parameters for the
selected part. For the Simple Cylindrical Structure part example, some default size parameters are Part
Size Name (PrtSN) and Structure Vertical Pipe Clearance (SVPC).
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NOTE Calculated values set in the model cannot be edited in the Edit Part Sizes dialog box. To change these
values you must edit the model.
2 To add a list of available sizes for the part, change the data storage type of a size parameter to List.

3 In the toolbar, select Values from the list.
The parameter values are displayed.

4 To add new sizes for the part, click a parameter value such as the LenB1 parameter, and click Edit on
the toolbar.
The Edit Values dialog box is displayed.
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5 Click Add and enter a new size. When you are finished adding sizes, click OK.
TIP You can cut and paste values from other part families using standard Microsoft® Windows cut and paste
functionality (CTRL+C and CTRL+V). Open another part in Part Builder, select the size parameter you want
to copy, and then paste the selected values in the desired parameter of your part. You can also create a list
of values in Microsoft® Excel, select the list of values you want to add, and then paste the values in the desired
parameter of your part.
Now when you click in the size parameter value you edited (for example, LenB1) on the Edit Part Sizes
dialog box, the list of sizes you just added is displayed.
6 To specify a unique, calculated part size name, select Calculations from the toolbar list box.
The calculation strings associated with parameter values are displayed. For example, the calculation
formula for a Part Size Name (PrtSN) for a structure could be “SHBW x SHBTh x SBSH inch Concrete
Rectangular Headwall”. Or for a pipe, it could be FormatNumber($PID,0) + “ inch Concrete Pipe”.
7 Double-click the value cell of PrtSN.
The Calculation Assistant is displayed.
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8 Define the part size name with a calculated value:
■

Highlight the value in the PrtSN: Part Size Name text box and press DELETE to remove the text.

■

Select 0 for Precision.

■

Under Insert Variable, select a variable and click Insert.

■

Click the value of PrtSN:Part Size Name and enter the text you want to display in the Part Size Name
string. For example, enter inch Dia. Concrete Pipe to add that text to the part size name.

■

Under Insert Variable, select Ptype and click Insert.

■

Select PTyp and click Insert.

9 Click Evaluate; the calculation result is displayed.
10 Click OK.
The calculation value of PrtSN is updated with the valid string and, when selected, the result is displayed
in the status bar.

IMPORTANT The part size name is generated using VB (Visual Basic) Script’s FormatNumber function and
simple string substitutions. Correct syntax is crucial. Use the Calculator to ensure that the string is valid.
11 Click OK.

Adding a Constraint
Use this procedure to add constraints to the model.
The procedure below uses the example of aligning the top and bottom faces of a rectangular shaped part.
For more information on constraints, see Constraints in Understanding Part Builder.
1 In the part browser, right-click XY Plane and click Add Geometry ➤ Point.
2 In the modeling area, specify a point near the center of the top face rectangular profile and press Enter.
3 In the part browser, right-click XY Plane and click Add Constraints ➤ Equal Distance.
4 In the modeling area, specify the pairs of geometric constraints.
5 For the first pair, select the point in the center of the top face, and then the lower-left edge of the top
face rectangular profile.
6 For the second pair, select the point in the center of the top face, and then the upper-right edge of the
top face rectangular profile.
The model of the top face is updated to the specified constraint.
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7 Repeat steps 3 and 4 to constrain the upper-left and lower-right edges of the top face.
The model of the top face is updated to the specified constraint.
NOTE When adding constraints, you may be prompted that the geometry is unconstrained by a specific
number of dimensions. These prompts are for informational purposes only to assist you during the modeling
process. It is recommended that you add a minimum number of constraints to define the shape of the part
to avoid undesirable results.
8 To ensure the alignment of the top and bottom faces, in the part browser, right-click Bottom Face and
click Add Geometry ➤ Point Reference.
9 Select the existing point in the center of the top face rectangular profile.
A reference point is added to the bottom face work plane.
10 Repeat steps 3 through 5 to constrain all four edges of the bottom face using the reference point in the
center of the bottom face.
The model of the bottom face is updated to the specified constraints.

Applying a Modifier
Use this procedure to apply modifiers to the model.
The procedure below uses the example of applying a transition modifier to the two rectangular shaped parts
described in Adding a Constraint. For more information on modifiers, see Modifiers in Understanding Part
Builder.
1 In the part browser, right-click Modifiers and click Add Transition.
2 In the modeling area, select the top face rectangular profile for the start profile; then select the bottom
face rectangular profile for the end profile.
A transitional box is created to represent the diffuser, and a transition modifier is added to Modifiers
in the part browser.
3 To add the lip of the diffuser, in the part browser, right-click Work Planes and click Add Work Plane.
The Create Work Plane dialog box is displayed.
4 Click Offset, enter Lip Offset for Name, and click OK.
5 In the modeling area, select the XY plane as the reference work plane, drag the cursor above the XY
plane, and enter 1 for the offset distance.
The Lip Offset work plane is created.
6 In the part browser, expand Modifiers, right-click Transition, and click Visible.
The transition modifier display is turned off in the modeling area.
7 In the part browser, right-click Modifiers, click Add Extrusion, and select the top face rectangular profile.
The Extrusion Modifier dialog box is displayed.
8 Under Termination, select Plane for Type, select Lip Offset for To, and then click OK.
A box is created to represent the top lip of the diffuser, and an extrusion modifier is added to Modifiers
in the part browser.
9 To see the entire model of the part, in the part browser, right-click Transition and click Visible.
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Generating a Preview Image of a Part
Use this procedure to generate a preview image of the part to help during part selection.
Part Builder generates the preview image based on a specified view direction. You can select from the ten
standard AutoCAD view directions to view the model (top, bottom, left, right, front, back, SW isometric, SE
isometric, NE isometric, and NW isometric).
1 To create a preview image, on the toolbar, click Generate Bitmap.
The Bitmap Preview dialog box is displayed.
2 Under Generate View, click a view direction for the preview image of the part.

TIP As you select a view, the preview image window in the dialog box is updated. This enables you to view
all the available preview images for the part before selection.
You can also click Browse to navigate to and select a bitmap image. Predefined images must be 200 x
200 pixels saved with 256 colors.
3 Click OK.

Defining Part Insertion Position
Use the Part Builder Autolayout commands to define the placement point where a part is inserted into a
drawing.
NOTE It is helpful to clean up the appearance of the model before defining the placement point. To turn off all
work planes and the associated geometry, profiles, and dimensions on those work planes, in the part browser,
right-click each feature and click Visible.
1 On the Part Builder toolbar, click Options.
The Options dialog box is displayed.
2 Make sure the check box in the Value column for the Custom Sizing Flag property is unchecked, and
that the Hide Part Flag property is checked, then click OK.
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In the part browser, Autolayout Data is added to Modeling, and trim length points are displayed on
the model in the modeling area.
3 Change the model view to plan view. On the View menu, click 3D Views ➤ Plan View ➤ World UCS.
4 In the part browser, expand Autolayout Data, right-click Layout Data and click Add Trim Length.
NOTE To ensure components are trimmed correctly when placing a part into a drawing, you must define
trim lengths for the part in a specific order—left to right, then bottom to top.
You are prompted to select the start and end of the trim length. Repeat this for the three trim lengths
required for auto layout of the part.
■

Define the first trim length.
For the start of trim length 1, select the point at the center of the part. For the end of trim length
2, select the point at the left end of the part.

■

Define the second trim length.
For the start of trim length 2, select the point at the center of the part. For the end of trim length
2, select the point at the right end of the part.

■

Define the third trim length.
For the start of trim length 3, select the point at the top of the branch (the center of the part). For
the end of trim length 3, select the point at the bottom of the branch.

Trim length lines are displayed between the selected points.
5 In the part browser, right-click Layout Data and click Select Placement Point.
You are prompted to select a point on your model. This point is the location at which connecting
segments would intersect if they were extended along their logical paths. The placement point is used
as the insertion point for the part when it is added to a drawing during autolayout.
6 Select the trim length point at the center of the part.
A placement point is displayed at the selected location.

Validating and Saving a Part
Use this procedure to validate and save the part.
1 On the Part Builder toolbar, click Validate.
Upon successful completion of these procedures, the part is validated and the status bar is updated with
a message indicating if the part validation is successful.
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Part is valid

If you have errors in your model, the status bar message displays that the part validation failed, and a
dialog box is displayed listing the errors. Review the errors, make necessary modifications, and repeat
this step until validation is successful.
Part is invalid

resulting error dialog box when part is invalid

NOTE You may have warnings in the Part Family Validation Results dialog box even when the part is valid.
2 Once validation is successful, on the toolbar, click Save Part Family or Save Part Family As.
3 Specify whether to make the part available in the catalog.
■

Click Yes to make the part available to users.

■

Click No to keep the part hidden.

NOTE This prompt toggles the Hide Part option in the Options dialog box in Part Builder.
The part is saved in the specified catalog location.
4 Click Close on the File menu.
NOTE At this point, you are prompted to save changes to the drawing file <new part family name>.dwg. If
you saved the part family, you should also save this drawing file, so click Yes at this prompt. If you did not
save the part family, then you should click No at this prompt and not save this drawing file.
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Testing Parts
The guidelines presented here will verify that your part sizes work correctly for your AutoCAD Civil 3D
drawings.
It is important to test each part size before using it in your drawings. You should verify the insertion point,
and all view representations. If testing produces undesirable results, you should modify and retest the
appropriate part sizes.

Testing the Display Representations
This section summarizes how to test the display representations of parts.
Depending on whether you test part sizes in a drawing started from scratch or from a template, you verify
accurate view representations in one of two ways: by scrolling through the various display configurations
in a viewport, or by scrolling through the various layout tabs in a template. You should see representations
on the Model tab similar to the following as you change display configurations for the viewport.
TIP To quickly change display configurations for a viewport, select a display configuration from the list in the
bottom-right corner below the drawing area.

Using Catalog Regen
Catalog Regen is a necessary step that runs through an entire part catalog and validates all parts.
You can run Catalog Regen by clicking the Catalog Regen button on the Getting Started - Catalog Screen
dialog box. Use this procedure to regenerate a part catalog that you have modified. Regenerating a part
catalog updates the APC file. A part catalog can be used inAutoCAD Civil 3D only if regeneration has been
completed.
To regenerate a part catalog
1 Verify that the part catalog you modified is the current catalog that is selected in the Part Catalog field
of the Getting Started - Catalog Screen dialog box.
For example, if you modified the pipe catalog, make sure Pipe is selected in the Part Catalog field. If
you modified the structure catalog, make sure Structure is selected in the Part Catalog field.
2 On the Getting Started - Catalog Screen dialog box, select the top-level catalog folder in the tree view,
and then click the Catalog Regen button. This regenerates the selected part catalog and updates the
catalog to reflect new or deleted part sizes.
The Catalog Regen dialog box is displayed, showing the status of the regeneration process.
3 To verify that the part catalog has been regenerated and updated, open Windows Explorer.
4 Navigate to the part catalog location \Documents and Settings\All Users\Application
Data\Autodesk\C3D2011\enu\Pipes Catalog\US Imperial Structures\Validate, and double-click the
Validate folder located in the same directory as the appropriate Autodesk part catalog (APC) file.
5 In the Validate folder, open Catalog_Regen_Summary.txt, and scroll through the file to verify that the
selected part sizes have been copied to, or deleted from, the part catalog.

Validating Parts in a Catalog
Use this procedure to validate parts you have changed or added to a part catalog.
Validating a part catalog steps through the catalog structure and verifies its parts. Remember that only valid
parts are available during part selection.
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To validate parts in a part catalog
1 Verify that the appropriate part catalog is the current catalog that is selected in the Part Catalog field
of the Getting Started - Catalog Screen dialog box.
For example, if you want to validate the pipe catalog, make sure Pipe is selected in the Part Catalog
field. If you want to validate the structure catalog, make sure Structure is selected in the Part Catalog
field.
2 On the Part Builder Getting Started - Catalog Screen dialog box, click the Catalog Test button.
The Test Catalog feature steps through the catalog structure and validates part sizes by verifying that
necessary part size information exists for each part size. The Catalog Test dialog box is displayed, showing
the status of the testing process. When the catalog test is complete, an AutoCAD alert dialog box is
displayed, reporting the results of the test.
3 To verify that the part sizes in the part catalog have been validated, open Windows Explorer.
4 Navigate to the part catalog location \Documents and Settings\All Users\Application
Data\Autodesk\C3D2011\enu\Pipes Catalog\US Imperial Structures\Validate, and double-click the
Validate folder located in the same directory as the appropriate Autodesk part catalog (APC) file.
5 In the Validate folder, open Catalog_Validation_Summary.txt, and scroll through the file to verify that
all the part sizes have been validated. If a part was not validated, an error notice in the file states which
information is missing for the part size.

Modifying Parts
This section summarizes how to modify existing parts using Part Builder.
For parts in the pipe network catalogs provided by AutoCAD Civil 3D, you can change the part behavior
and part size parameters. For parts you create using Part Builder, you can change the part behaviors, part
size parameters, and part model including geometry, profiles, modifiers, constraints, and dimensions. You
can also delete parts that you no longer need. Deleting parts can be helpful when creating custom catalogs
to ensure that all associated definition files are managed correctly.

Starting Part Builder for Modifying a Part
Use this procedure to start Part Builder and modify a part.
1 Home tab ➤ Create Design panel

Part Builder

.

The Getting Started - Catalog Screen dialog box is displayed.
2 In the part browser, navigate to and select a part.
3 To modify the part, click

.

The existing part is opened in the parametric building environment.
4 To delete a part, click

.

The selected part family is deleted from the part catalog, including all associated definition files (XML,
DWG, and BMP files).
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Making Changes to a Part
As your design develops and parts change, you can modify parts using Part Builder. You can change the part
behavior and part size parameters. For parts you created using Part Builder, you can also change the part
model, including geometry, profiles, modifiers, constraints, and dimensions. You can use the same procedures
that guide you through creating a part to modify it. This section outlines how you can modify a part and
provides references to the related procedures that you can use to make changes.
IMPORTANT When making changes to a part, refer to the illustration in Part Modeling (page 1436). This illustration
shows the relationship dependencies between features that must be maintained to ensure you are creating a
usable part.

Modifying the Part Configuration
You can change the part configuration that controls the behavior of and defines the characteristics of the
part. In the part browser, expand Part Configuration and change the part type or subtype. For more
information, see Specifying the Part Configuration (page 1453).

Modifying the Part Model
For parts that you created using Part Builder, you can change the model parameters that define the overall
size of the model. You can change the geometry, dimensions, and constraints of the model.
You can add, modify, or remove geometry in the model; however, you must append the changed geometry
to the profile in order for Part Builder to update the model and assign new geometric constraints.
You can also change the parametric relationships of model elements by modifying the geometric and
dimension constraints. Because constraints control the overall shape of the model, you cannot safely make
changes until you know the current constraints applied to the model. You can delete an unwanted constraint
or add new constraints to reshape the sketch.
Part Builder’s parametric commands ensure that relationships among geometric elements remain intact;
however, after changes are made to the model you should re-examine the geometric constraints and
dimensions to verify that nothing else in the model needs to be updated.

Modifying Part Sizes
You can change the model dimensions of the part that determine the overall size of the model, such as
length and width. You can also change individual size parameters for a specific part size. For example, you
can change a constant size parameter value to a list of values. For more information, see Adding Model
Dimensions (page 1455) and Adding Individual Part Sizes (page 1456).

Modifying the Preview Image or Part Insertion Behaviors
You can change the preview image by selecting a different view direction that Part Builder uses to generate
the preview image. For more information, see Generating a Preview Image of a Part (page 1461).
You can change the insertion configuration of the part that defines the placement point of a part in a
drawing. For more information, see Defining Part Insertion Position (page 1461).

Adding a Material Property to a Part
Use this procedure to add the Material property to a part family in the part catalog.
Having the Material property available for parts enables you to use Civl 3D labeling features to add text to
identify the type of material used for the pipe. For example, you can configure the Material property to
display text such as PVC, ductile iron, or corrugated steel.

1466 | Chapter 31 Creating Parts with Part Builder

Some part families may already have the Material property included by default. However if a part family
does not have the Material property included, you can add this property to a part family using the following
procedure.
To add the Material property to a part family
1 Open Part Builder by selecting Home tab ➤ Create Design panel

Part Builder

.

The Getting Started - Catalog Screen dialog box is displayed.
2 In the Getting Started - Catalog Screen dialog box, open the desired pipe or structure part catalog.
For example, under Pipe ➤ US Imperial Pipe Catalog ➤ Circular Pipes, open the Concrete Pipe catalog
by double-clicking it, or by clicking Getting Started - Catalog Screen Modify Part Sizes.
3 In the Part Builder left pane, right-click Size Parameters, and then click Add.
4 On the New Parameter dialog box, click Material, and then click OK.
Notice that when you do this, the Mat (material) property is added to the Edit Part Sizes dialog box.
You may need to scroll to the right on this dialog box to see this property added.
5 Now that the Material property is added to this dialog box, you can configure the attributes for this
property by clicking in the cell for each attribute.
For example, you may want this Material property to show or not show in AutoCAD Civil 3D drawings.
Do this by setting the Visible attribute to True or False.
6 Make sure you set the Visible attribute to True so that the value for the Material property displays in
the drawing.
7 Click OK on the Edit Part Sizes dialog box.
8 Click Save Part Family.
Now the Material property is available for parts in this part family. Using AutoCAD Civil 3D labeling features,
you can add text to this property to identify the type of material used for the pipe. For more information,
see Adding a Material Type to a Pipe or Structure Label (page 1413).
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You can test use AutoCAD Civil 3D corridor modeling to create flexible and configurable 3D models of corridors, such as
roads, highways and railways.
Corridor Modeling Workflow (page 45)

Understanding Corridor Modeling
A corridor model builds on and uses various AutoCAD Civil 3D objects and data, including subassemblies,
assemblies, alignments, surfaces, and profiles.
A corridor object is created from a baseline (alignment) by placing 2D sections (assemblies) at incremental
locations, and by creating matching slopes that reach a surface model at each incremental location:

Elements of a corridor design

1471

You can create corridors with multiple baselines, which enables you to create more complex designs, such
as intersections.
NOTE There is no limit to the number of alignments that can be used to define an AutoCAD Civil 3D corridor.

Corridors are created from and based on existing AutoCAD Civil 3D objects, which include:
■

Alignments (horizontal). Used by a corridor as its centerline. For information, see Alignments (page 923).

■

Profiles (vertical alignments). Used to define surface elevations along a horizontal alignment. For
information, see Creating Profiles (page 1141).

■

Surfaces. Used to derive alignments and profiles, and for corridor grading. For information, see Surfaces
(page 645).

■

Subassemblies. A fundamental component of a corridor model. Subassemblies define the geometry of a
corridor section (assembly). For example, a typical roadway may be composed of paved lanes (on either
side of the centerline), a paved shoulder, a gutter and curb, and a roadside grading. These parts are defined
independently as subassemblies. You can stack any type of subassembly to make up a typical assembly
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and apply the same assembly for a station range along an alignment. For more information, see
Understanding Subassemblies (page 1555).
■

Assemblies. Represent a typical section of a corridor. Assemblies comprise one or more subassemblies
connected together. For more information, see Understanding Assemblies (page 1537).

After you have created a corridor, you can extract data from it, including surfaces, feature lines (as polylines,
alignments, profiles, and grading feature lines), and volume (quantity takeoff) data. For information, see
Exporting Corridor Data (page 1528) and Analyzing Sectional Volumes (page 1277).
NOTE There is no limit to the number of feature lines that can be created at a AutoCAD Civil 3D corridor station
or range of stations.
Corridors have their own display style and also inherit styles from their components. Before creating corridors,
you should be familiar with creating and managing styles (page 66) and command settings (page 114).

The Corridor Object
Corridors persist in an AutoCAD drawing as objects with the name AeccCorridor.
Corridor objects are defined by associating a baseline (alignment) with sectional design elements, and other
structural data. The corridor object manages the data, tying various assemblies (applied for different ranges
of stations) to the baselines (alignments) and their finished grade profiles. It manages the connection of
project-specific surface and alignment data to the subassembly and assembly content. The object includes
corridor body geometry, longitudinal feature lines, embedded surfaces, rendering support, and slope hatching
support.
A corridor can define and display components, such as:
■

Feature lines connecting points along the point codes, which are defined in the subassemblies (used to
create the assemblies).

■

Surfaces, using link codes and feature lines.

For overview information about AutoCAD Civil 3D objects, see Understanding Objects and Styles (page 63).

Corridor Styles and Display
How corridor elements are displayed is controlled both by a specific corridor style and the styles and labels
associated with the objects used to create the corridor.
Use corridor styles to control the appearance of corridor region boundaries, assembly insertion stations, and
stations where the default properties of the subassemblies are overridden.
For more information, see Corridor Style Dialog Box (page 2044).
In addition, various components within the corridor are controlled by their own display styles and labels:
■

Display styles for corridor components include alignments, code sets, slope patterns, surfaces, and feature
line styles.

■

Components of the corridor object have their own labels. Corridor surface objects support all annotation
capabilities that a regular surface supports.
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The following table lists the styles of the corridor components and where they are derived from.
Corridor Component

Display Style

Notes

Links

Link style

Set through associated Code Set
style.

Points

Marker style

Set through associated Code Set
style.

Shapes

Shape style

Set through associated Code Set
style.

Feature Line

Feature Line style

Defined in the corridor properties.

Surfaces

Surface style

Defined in the corridor properties and in the surface properties, if a dynamic surface is
generated.

Material Rendering

Render Material

Defined in the corridor properties.

Corridor Section

Code Set style; assigned from
corridor.

View of an assembly, so all elements, such as links, points, and
shapes, are displayed through
respective styles in the set.

Surface Section

Section style

For more information about styles, see Object and Label Styles (page 66).

Corridors Collection (Prospector Tab)
Use the Corridors collection in the Prospector tree to access the corridors in a drawing or a project. As corridor
objects are created, they are displayed in the Corridors collection.
Expand the Corridors collection to view the names of the corridors in the drawing. Expand a corridor in the
Prospector tree to display a list of the baselines associated with it. Select a corridor, or a baseline, to display
a tabular list of details in the Prospector list view. For more information, see The Toolspace Item View (page
99).

Corridor Collection (Settings Tab)
Use the Corridor collection in the Settings tree to manage corridor settings, styles, and command settings.
Right-click the Corridor collection to do the following:
■

Edit the corridor feature settings

■

Refresh the display of the settings tree.

For more information about the contents of this shortcut menu, see “The Object Collection (Settings Tree)”.
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Expand the Corridor collection to display and edit the styles and command settings that are available for
corridors.
For information about...

See...

Corridor settings

Editing Corridor Settings (page 1478)

Corridor styles

Corridor Styles and Display (page 1473)

For more information, see Edit Feature Settings - Corridor dialog box (page 2053).

Creating Corridors
You can use two methods to create a corridor: using the Create Corridor command or the Create Simple
Corridor command.
All corridors are managed in the same way, regardless of how you create them. Also, all corridors are listed
in the Corridors collection in the prospector tree.
Before you can create a corridor, you must create the underlying data, such as surfaces, alignments, profiles,
subassemblies, and assemblies.
For information about creating...

See...

Surfaces

Creating Surfaces (page 648)

Alignments

Creating Alignments (page 948)

Profiles

Creating Layout Profiles (page 1143)

Subassemblies

Creating Subassemblies (page 1557)

Assemblies

Creating Assemblies (page 1541)

For information about how a corridor is displayed after it is created, see Changing Corridor-Related Default
Style Settings (page 1480).

Creating a Simple Corridor
Use the Create Simple Corridor command to quickly create a basic corridor.
This method is ideal for creating basic corridors based on a single alignment (1), a profile (2) along the
alignment, and an assembly (3) across it. You can subsequently add more complexity to the corridor by
editing it.

For information about adding more complexity, see Managing and Editing Corridors (page 1478).
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NOTE Before you create a corridor, you must create the underlying data, such as surfaces, alignments, profiles,
and assemblies.
To create a simple corridor
1 Click Home tab ➤ Create Design panel ➤ Corridor drop-down ➤ Create Simple Corridor

.

2 In the Create Simple Corridor Dialog Box (page 2052), in the Name field, enter a name for the corridor.
To name the corridor, select its default name and enter a new name, or use the name template. For
more information, see Name Template Dialog Box (page 2022).
3 In the Description field, enter a description for the corridor.
4 To change the style used by the corridor, click the Corridor Style list or use the standard style creation
tools to edit or create a style. For more information about the style creation tools, see the Select Style
Dialog Box (page 2021).
The corridor style controls the appearance of corridor region boundaries and assembly insertion stations.
For more information, see Corridor Styles and Display (page 1473).
5 Click

to select a layer. For more information about layers, see Object Layer Dialog Box (page 2221).

NOTE If you do not select a layer, the corridor is placed on the default layer.
6 Click OK.
7 Select an alignment in the drawing or press Enter to select an alignment in the Select An Alignment
dialog box (page 2027).
8 Select a profile in the drawing or press Enter to select a profile in the Select A Profile dialog box (page
2062).
9 Select an assembly in the drawing or press Enter to select an assembly in the Select An Object dialog
box (page 2027).
10 The corridor name is displayed in the Corridors collection on the Prospector tab. For information about
editing and managing the corridor, see Managing and Editing Corridors (page 1478).

Quick Reference
Ribbon
Home tab ➤ Create Design panel ➤ Corridor drop-down ➤ Create Simple Corridor
Menu
Corridors menu ➤ Create Simple Corridor
Command Line
CreateSimpleCorridor
Dialog Box
Create Simple Corridor (page 2052)

Creating a Corridor
Use the Create Corridor command to specify complex parameters at creation time.
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You specify the station range, profile, assembly, and any necessary targets.

Other parameters could include station frequency and controlling offsets, as well as information about
multiple baselines and regions.
To create a corridor
1 Click Home tab ➤ Create Design panel ➤ Corridor drop-down ➤ Create Corridor

.

2 Select an alignment in the drawing or press Enter to select an alignment in the Select An Alignment
dialog box (page 2027).
3 Select a profile in the drawing or press Enter to select a profile in the Select A Profile dialog box (page
2062).
4 Select an assembly in the drawing or press Enter to select an assembly in the Select An Assembly dialog
box (page 2027).
5 In the Create Corridor dialog box (page 2049), in the Name field, enter a name for the corridor.
To name the corridor, select its default name and enter a new name, or use the name template. For
more information, see Name Template Dialog Box (page 2022).
6 In the Description field, enter a description for the corridor.
7 Click

to select a layer. For more information about layers, see Object Layer Dialog Box (page 2221).

NOTE If you do not select a layer, the corridor is placed on the default layer.
8 To change the style used by the corridor, click the Corridor Style list or use the standard style creation
tools to edit or create a style. For more information about the style creation tools, see the Select Style
Dialog Box (page 2021).
The corridor style controls the appearance of corridor region boundaries and assembly insertion stations.
For more information, see Corridor Styles and Display (page 1473).
9 Edit the parameters in the properties table. You can add additional controlling baselines, regions, or
offsets, modify alignments, profiles, assemblies, or station ranges and frequency, or edit targets. For
more information, see Editing Corridor Parameters (page 1486).
NOTE If targets are required for the corridor and not set, messages are displayed in the Event Viewer. To
display the Event Viewer, click General ➤ Utilities ➤ Event Viewer. For more information about the event
viewer, see The Event Viewer Vista (page 1817).
10 Click OK to create the corridor.
The corridor name is displayed in the Corridors collection on the Prospector tab.
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Quick Reference
Ribbon
Home tab ➤ Create Design panel ➤ Corridor drop-down ➤ Create Corridor
Menu
Corridors menu ➤ Create Corridor
Command Line
CreateCorridor
Dialog Box
Create Corridor (page 2049)

Managing and Editing Corridors
You can control the default settings and styles for creating corridors and also edit or add data to corridors
after you create them.
Right-click a corridor in Toolspace, or in the drawing, to display a shortcut menu with various available
options.
Use the Corridor tab in the ribbon to access most corridor managing and editing commands.
To display the Corridor tab in the ribbon, do one of the following:
■

In the drawing window, click a corridor in the drawing.

■

In the ribbon, click the Modify tab ➤ Design panel ➤ Corridor.

■

In Toolspace, on the Prospector tab, right-click a corridor and then click Select.

You can use the Corridor Properties dialog box to view and or change:
■

a corridor’s administrative information, such as name description, and object style

■

parameters such as baselines, frequencies, and targets

■

code sets

■

corridor feature lines, surfaces, boundaries, and slope patterns

Many of these functions can also be accessed from the Corridor tab in the ribbon.
NOTE You cannot copy a corridor.

Editing Corridor Settings
Use corridor settings to specify the default behavior for corridor-related commands.
Settings are handled in a standard way throughout AutoCAD Civil 3D. You access settings using the Toolspace
Settings tree. You can control settings at three levels: the drawing level, the object collection (feature) level,
and the command level. For more information, see Understanding Settings (page 77).
In the Settings tree, use the Corridor collection’s shortcut menu to establish defaults for all corridor-related
commands. You can change corridor-specific settings at this level, or override the drawing ambient settings.
Use the Commands collection in the Corridor collection to change corridor settings for a specific command.
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NOTE Overrides to the drawing ambient settings at the Corridor collection level and the Commands collection
level affect only the specified (and subordinate) levels. The drawing level settings are not changed.
The topics in this section describe only those settings that affect corridor-related commands. They do not
apply to the drawing ambient settings that you can change at the Corridor collection level. For more
information about the drawing ambient settings, see Specifying Ambient Settings (page 84).
For more information, see Edit Feature Settings - Corridor dialog box (page 2053).

Changing Corridor Creation Settings
Use the corridor creation and naming settings in the Edit Feature Settings - Corridor dialog box to change
corridor-related settings before you create corridors.
For example, before creating a corridor, you may want to specify the default assembly frequency along
tangents, curves, or spirals.
If a closed lock appears in the Lock column for a property, the property is locked at a higher level of the
Settings tree. It cannot be changed at this level.
If you change a property value, a check mark is placed in the Override column. This override is also noted
in the property table for related objects higher up the Settings tree, where an arrow is displayed in the Child
Override column.
To change corridor creation settings
1 Do one of the following:
■

To edit settings for all corridor-related commands: In Toolspace, on the Settings tab, right-click the
Corridor collection. Click Edit Feature Settings.

■

To edit settings for a specific command: In Toolspace, on the Settings tab, expand the Corridor
collection. Expand the Commands collection. Right-click the name of the command and click Edit
Command Settings. For example, right-click the CreateCorridor command and click Edit Command
Settings.

An Edit Feature Settings - Corridor dialog box (page 2053) is displayed.
2 To specify the default highlight settings for corridor region baselines, boundaries, targets and internal
assemblies; right-click the Corridor collection and click Edit Feature Settings. Edit the Region Highlight
Graphics settings.
3 To specify the default assembly frequency along tangents, curves, and spirals, right-click the
CreateCorridor or CreateSimpleCorridor commands and click Edit Command Settings. Edit the Assembly
Insertion Defaults settings.
4 To specify whether assemblies are to be inserted at specific points, such as horizontal geometry or
superelevation critical points, right-click the CreateCorridor or CreateSimpleCorridor commands and
click Edit Command Settings. Edit the Assembly Insertion Defaults settings.
5 To edit the default scale to view corridor sections, right-click the ViewEditCorridorSection command
and click Edit Command Settings. Expand the View/Edit Options property group. Edit the Default View
Scale setting.
6 To specify whether a corridor is automatically rebuilt when you edit a subassembly parameter, right-click
the ViewEditCorridorSection command. Click Edit Command Settings. Expand the View/Edit Options
property group. Edit the Rebuild On Edit setting.
7 To specify the front and back clip values for 3D objects displayed in a corridor section view, right-click
the ViewEditCorridorSection command and click Edit Command Settings. Expand the View/Edit Options
property group. Edit the Front Clip and Back Clip settings.
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8 To specify whether the station tracker is on, right-click the ViewEditCorridorSection command. Click
Edit Command Settings. Expand the View/Edit Options property group. Set the Turn Off Unassociated
Layers setting to no and the Station Tracker in Multiple Viewports setting to yes.
9 To specify the grid and grid text display settings for a corridor section view, right-click the
ViewEditCorridorSection command and click Edit Command Settings. Expand the Grid Settings and
Grid Text Settings property groups. Edit the grid line, grid spacing, color, and text size settings.
10 To edit the default naming format for corridors and data that can be extracted from the corridor, expand
the Default Name Format property group. Edit the Corridor Name Template settings.
11 Click Apply.

Quick Reference
Toolspace Shortcut Menu
Settings tab: Right-click Corridor collection ➤ Edit Feature Settings
OR
Settings tab: Corridor ➤ Commands ➤ Right-click <command-name> ➤ Edit Command Settings
Dialog Box
Edit Feature Settings - Corridor (page 2053)

Changing Corridor-Related Default Style Settings
Use the corridor settings to specify default styles and labels for corridor creation and for data that you create
or extract from corridors.
You can select the default styles for alignments and profiles exported from corridors and a default corridor
style and label set.
The default styles specified in these settings are used to establish the default setting for the style in the Create
Corridor and Corridor Properties dialog boxes.
To change the corridor-related style and label settings
1 In Toolspace, on the Settings tab, right-click the Corridor collection. Click Edit Feature Settings to open
the Edit Feature Settings - Corridor dialog box (page 2053).
2 Expand the Default Styles property group.
3 To specify a default style for corridor output objects, such as alignments and profiles generated from
corridors, click the corresponding field. Click

to open the Select Style dialog box.

4 To specify a default corridor style, click Corridor Style. Click

to open the Select Style dialog box.

5 To specify a default style for a label set, click the corresponding field. Click
Set dialog box.

to open the Select Label

6 To specify a default style for viewing corridor sections, click Section View Style. Click
Select Style dialog box.
7 Click Apply.
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to open the

Quick Reference
Toolspace Shortcut Menu
Settings tab: Right-click Corridor collection ➤ Edit Feature Settings
Dialog Box
Edit Feature Settings - Corridor (page 2053)

Editing Basic Corridor Information
After creating a corridor, use the Corridor Properties dialog box to edit a corridor’s name and description.
To edit basic corridor information
1 In Toolspace, on the Prospector tab, expand the
Corridors collection. Right-click the corridor. Click
Properties. (You can also click the corridor in the drawing, and then click Corridor Properties in the
Modify Corridor panel of the corridors contextual ribbon.)
2 In the Corridor Properties dialog box, click the Information tab (page 2035).
3 To change the name of the corridor, enter a new name in the Name field.
4 To change the description of the corridor, enter a new description in the Description field.
5 To change the style of the corridor, click the Object Style list. Alternately, or use the standard buttons
to create, edit, or select a style.
6 Click Apply to make the changes, or click OK to make the changes and close the Corridor Properties
dialog box.

Quick Reference
Ribbon
Corridor tab ➤ Modify Corridor panel ➤ Corridor Properties drop-down ➤ Corridor Properties
Toolspace Shortcut Menu
Prospector tab: Corridors ➤ <corridor name> ➤ Properties ➤ Information tab
Object Shortcut Menu
Corridor Properties
Dialog Box
Corridor Properties - Information tab (page 2035)

Setting Targets
On a corridor, you can set and edit the values of subassembly target objects, such as surfaces, alignments,
and profiles.
Targets are required when the geometry of one or more of an assembly’s subassemblies requires corresponding
surface, offset, or elevation targets for defining that geometry.
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A few subassemblies even use pipe networks as target objects. When a corridor contains subassemblies that
use targets, the object names of the intended target objects must be mapped from the subassembly definition
to the corresponding drawing objects. This task is referred to as setting targets or mapping targets.
NOTE If targets required for the corridor are not set, messages are displayed in the Event Viewer, indicating that
target objects are not found. To display the Event Viewer, click View tab ➤ Palettes panel
For more information about the event viewer, see The Event Viewer Vista (page 1817).

Event Viewer

.

For example, a subassembly ‘SideSlope’ parameter is used to define roadside grading, starting from the edge
of shoulder, and sloping at a specified grade, until it intercepts with an existing ground surface. In the
subassembly, references to the target surface are made by calling a surface object named ‘TargetDTM.’
However, when you create the corridor, and apply the subassembly to a corridor definition, there may not
be a surface named ‘TargetDTM’, and there may be multiple ground surfaces. Therefore, after the assembly
is applied to the corridor, you need to map the target name (TargetDTM) to an actual surface object name.
Typically, subassembly parameters that can use a target object to define a width or an offset can use the
following types of objects to define that width or offset: alignments, polylines, feature lines, or survey figures.
Similarly, subassembly parameters that can use a target object to define an elevation can use the following
types of objects to define that elevation: profiles, 3D polylines, feature lines, or survey figures.
Subassemblies that can use a target object to define a surface can only use a surface object to define that
surface.
As previously mentioned, a few subassemblies allow you to use pipe network objects as targets, such as the
TrenchPipe subassemblies.
The following table summarizes these capabilities:
Target Type

Object types that can be used as targets

widths or offsets

alignments, polylines, feature lines, or survey figures

elevations

profiles, 3D polylines, feature lines, or survey figures

surfaces

surfaces

pipe networks

pipe networks

The Help topic for each subassembly lists the parameters in the subassembly that can be associated with a
target object.
BEST PRACTICE It is generally considered a best practice to set region targets after creating the regions. For
example, while creating regions, leave the targets set to “None”, and proceed with creating the regions. After
the regions are created, set the targets on the regions. This reduces the processing load because processing the
assembly insertion points (during region creation), and processing the setting of the assembly targets, are two
separate operations instead of one.
See also:
■

Editing Corridor Region Targets (page 1487)

To set targets using the ribbon
1 In the drawing, select the corridor.
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2 Click Corridor tab ➤ Modify Corridor panel ➤ Corridor Properties drop-down ➤ Corridor Properties
.
3 In the Corridor Properties dialog box, click the Parameters tab (page 2035).
4 Do one of the following:
■

To view or map all targets required by the corridor, click Set All Targets.

■

To view or map the targets for a specific baseline or assembly, click the Target field for that baseline
or assembly.

5 In the Target Mapping dialog box (page 2064), set the surface, offset, and elevation targets in the
corresponding Object Name fields.
6 Click OK to close the Target Mapping dialog box.
7 Click Apply.
To set targets using the Corridor Properties dialog box
1 In the drawing, click the corridor, then right-click and click Corridor Properties.
2 In the Corridor Properties dialog box, click the Parameters tab (page 2035).
3 Do one of the following:
■

To view or map all targets required by the corridor, click Set All Targets.

■

To view or map the targets for a specific baseline or assembly, click the Target field for that baseline
or assembly.

4 In the Target Mapping dialog box (page 2064), set the surface, offset, and elevation targets in the
corresponding Object Name fields.
5 Click OK to close the Target Mapping dialog box.
6 Click Apply.
To select a surface to target
1 In the Target Mapping dialog box (page 2064), do one of the following:
■

To select surfaces individually, click the Object Name field next to the corresponding surface in the
Target column.

■

To select all surfaces at once, click <Click Here To Set All> in the Object Name field. This is useful
for mapping TargetDTM's that are referenced by multiple subassemblies used in the corridor through
multiple assembly regions. For example, all side slope subassemblies typically need to be mapped
to the same existing ground surface.

2 In the Pick a Surface dialog box, select the surface from the list or click
drawing.

and select the surface in the

3 Click OK to close the Pick a Surface dialog box.
To select a width or offset to target
1 In the Target Mapping dialog box (page 2064), click the Object Name field next to the corresponding
width or offset target name in the Target column.
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2 To target an alignment:
■

In the Select Object Type To Target list of the Set Width Or Offset Target dialog box (page 2064), select
Alignment.

■

Select an alignment from the Alignment list, or click
to add to the list.

■

Click Add >> to add an alignment to the Selected Entities to Target list.

and select an alignment in the drawing,

3 To target a feature line, survey figure or polyline:
■

In the Select Object Type To Target of the Set Width Or Offset Target dialog box select Feature Lines,
Survey Figures and Polylines.

■

Click Select By Layer to import all named targets on any layer selected in the Select By Layer, dialog
box or click Select From Drawing to select entities in the drawing.

■

Click

■

If there are two or more targets in the Selected Entities To Target list, select Target To Nearest Offset
or Target To Farthest Offset for Selection Choice If Multiple Targets Are Found.

to remove any excess entities from the Selected Entities To Target list.

4 Click OK to close the Set Width Or Offset Target dialog box.
NOTE If you select more than one target object, **Varies** is displayed in the Object Name field.
To select a slope or elevation to target
1 In the Target Mapping (page 2064) dialog box, click the Object Name field next to the corresponding
slope or elevation target name in the Target column.
2 To target a profile:
■

In the Set Slope Or Elevation Target dialog box (page 2063), in the Select Object Type To Target list,
select Profiles.

■

Select from the Select An Alignment list, or click

■

Select from the Select Profiles list, or click

■

Click Add >> to add a profile to the Selected Entities To Target list.

and select an alignment in the drawing.

and in the drawing select a profile to add to the list.

3 To target a feature line, survey figure or polyline:
■

In the Select Object Type To Target of the Set Slope Or Elevation Target dialog box select, Feature
Lines, Survey Figures and Polylines.

■

Click Select By Layer to import all named targets on any layer selected in the Select By Layer dialog
box or click Select From Drawing to select entities in the drawing.

■

Click to remove any excess entities from the

■

If there are two or more targets in the Selected Entities To Target list, select Target To Nearest Offset
or Target To Farthest Offset for Selection Choice If Multiple Targets Are Found.

Selected Entities to Target list.

4 Click OK to close the Set Slope or Elevation Target dialog box.
NOTE If you select more than one target object, **Varies** is displayed in the Object Name field.
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Quick Reference
Toolspace Shortcut Menu
Prospector tab: Corridors ➤ <corridor name> ➤ Properties ➤ Parameters tab
Object Shortcut Menu
Corridor Properties
Dialog Box
Corridor Properties - Parameters tab (page 2035)

Adding Assemblies At Offset Geometry Points
You can automatically add assemblies to a corridor at offset target object (feature line or alignment or
polyline) geometry points.
This feature is specified in the command settings for the CreateCorridor command. By default, the command
setting option for this behavior is set to Yes. If you do not want newly created corridors to automatically
add assemply insertion stations, set this to No.
You can also specify this option on individual corridors that already exist in the drawing.
NOTE Using this feature adds additional stations to the corridor at the offset targets geometry points. Therefore,
if you have large or complex corridors, you may notice an increase in the time it takes to process (rebuild) corridor
models. It is important to note, though, that the corridor stations are only being added based on the horizontal,
and not on the vertical, geometry points of the offset targets.
To automatically add assemblies at offset geometry points using command settings
1 In Toolspace, click the Settings tab.
2 Expand Corridor ➤ Commands.
3 Right-click CreateCorridor, and click Edit Command Settings. In the Edit Command Settings dialog
box, and then expand the Assembly Insertion Defaults property group.
4 Set the Value field for the Offset Target Geometry Points to Yes to enable this option.
5 Click Apply or OK.
To automatically add assemblies at offset geometry points on an existing corridor
1 In Toolspace, right-click a corridor and click Select.
2 Click Corridor tab ➤ Modify Region panel ➤ Edit Frequency

.

3 Select the desired corridor region.
4 In the Frequency To Apply Assemblies dialog box, expand the Apply Assembly node.
5 Set the Value field for the At Offset Target Geometry Points to Yes to enable this option.
6 Click OK.
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Quick Reference
Toolspace Shortcut Menu
Settings tab: Corridor ➤ Commands ➤ Right-click CreateCorridor ➤ Edit Command Settings ➤ Assembly
Insertion Defaults ➤ Offset Target Geometry Points
Dialog Box
Edit Feature Settings - Corridor (page 2053)
Frequency To Apply Assemblies (page 2060)

Editing Corridor Parameters
You can edit corridor parameters, such as baselines, regions, targets, assembly frequency, and controlling
offsets.
A corridor is defined by at least one baseline (alignment) and an assembly that is applied for a range of
stations on that baseline. In many cases, corridors will have different assemblies at different stations,
depending on the existing ground and other design considerations. Also, it may be necessary to build a
corridor model that is controlled by multiple baselines, for example, one that includes intersection objects
(page 1587). To add and edit this type of complexity, you can use the Parameters tab, where you can modify
the associated alignments, profiles, and assemblies, change assembly frequency and range, and update targets.
Many of these functions can be accessed from commands available on the Corridors contextual ribbon tab.

Editing Corridor Regions
There are various ways you can edit corridor regions.
You can
■

move the region’s start or end stations

■

add baselines

■

set or edit assembly frequencies

■

set or edit targets

■

split a region into two regions

■

merge two regions into one region

■

copying corridor regions

■

match the parameters of one region to other regions

■

add regions

■

isolate regions

■

hide regions

■

delete regions

Each of these tasks is covered in the Help topics that follow.
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Editing Corridor Regions Using Grips
When you select a corridor region, triangular grips are displayed at the start and end stations of the region.
Use these grips to manually change the start and end station for a region.
If the start station of one region is the end point of another region, the grip at the station is displayed as a
diamond shaped grip, which enables you to edit the shared extents of the adjacent regions at the same time.

If you want to edit the start or end point of a region without editing the adjacent region, additional grips
enable you to edit the extents of the regions independently.

To edit a corridor region using editing grips
1 In the drawing, select the corridor.
Grips are displayed at the start and end stations of the region.
2 Ctrl+click a grip to make it active, and drag it to a new location.
3 If the grip is diamond-shaped, the start of one region and the end of another are both at this location.
You can edit the two regions at the same time, or edit the extents of the regions independently.

Editing Corridor Region Targets
You can edit corridor region targets using the Edit Targets command in the Corridor ribbon tab.
BEST PRACTICE Set region targets after creating the regions. For example, when creating regions, leave the
targets set to “None” and proceed with creating the regions. After the regions are created, set the targets on the
regions. This reduces the processing load because processing the assembly insertion points (during region creation),
and processing the setting of the assembly targets, are two separate operations instead of one.
To edit corridor region targets
1 In the drawing, click the corridor.
2 Click Corridor tab ➤ Modify Region panel ➤ Edit Targets

.

3 Select a region on the corridor.
4 In the Target Mapping dialog box (page 2064), set the surface, offset, and elevation targets in the
corresponding Object Name fields.
For more information, see Setting Targets (page 1481).
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5 Click OK to close the Target Mapping dialog box.
6 Click Apply.
NOTE You can also edit targets using the Parameters tab (page 2035) of the Corridor Properties dialog box. For
more information, see Setting Targets (page 1481).

Quick Reference
Ribbon
Corridor tab ➤ Modify Region panel ➤ Edit Targets
Toolspace Shortcut Menu
Prospector tab: Corridors ➤ <corridor name> ➤ Properties ➤ Parameters tab
Object Shortcut Menu
Corridor Properties
Dialog Box
Corridor Properties - Parameters tab (page 2035)

Splitting Corridor Regions
You can split a corridor region into two regions.
You may need to split a corridor region into multiple regions so that you can assign different assemblies to
certain regions of the corridor.
Use the Split Region command to split a corridor region into two regions.
To split a corridor region
1 In the drawing, click a corridor.
2 Click Corridor tab ➤ Modify Region panel ➤ Split Region

.

3 Click the region you want to split.
4 Zoom in and click the station (or enter the station value) where you want to split the region.
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5 Do one of the following:
■

Press Enter to end the command now, and the region will be split into two regions.

■

You can continue splitting regions by selecting another region to split, and another split location.
Press Enter when you are finished selecting regions and split locations.

6 Press Enter to end the command.
NOTE You can also split regions using the Parameters tab of the Corridor Properties dialog box. In the table on
this tab, right-click a corridor region, and click Split Region. In the drawing, click a point or points parallel to the
alignment to split the selected region. Right-click to stop selecting split point(s), then click OK to split the region.

Quick Reference
Ribbon
Corridor tab ➤ Modify Region panel ➤ Split Region
Object Shortcut Menu
Split Region

Adding Corridor Regions
You can add corridor regions using the AddCorrRegions command.
Corridor regions are used to associate assemblies to specific station ranges along the corridor. Therefore, to
assign different assemblies to sections of the corridor, you create regions.
Once a new region is created, you can edit it using various the commands available from the Modify Region
panel on the Corridor ribbon, including:
Match Corridor Region Parameters
Copies the parameters of the selected source region and applies it to the destination region.
Edit Corridor Region Properties
Edit the properties of the selected region including; assembly, start and end stations, the frequency to apply
assemblies, target mapping, and station overrides.
Isolate Region
This command turns off the visibility of all corridor regions, except the selected one. This command has
the same effect as clearing all region check boxes on the Parameters tab of the Corridor Properties dialog
box, except that of the selected region.
Show All Regions
This command restores the visibility of any regions whose visibility is currently turned off. The command
is not available if all regions are visible.
BEST PRACTICE Instead of creating one region for a long corridor, dividing the corridor into multiple, smaller
regions typically results in faster processing time for corridor rebuilds and o ther functions. For example, on a
5,000 meter corridor, create five regions, each of which is about 1,000 meters long. This reduces the processing
load when rebuilding the corridor.
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To add a corridor region using the Corridor ribbon tab
1 In the drawing, click a corridor.
2 Click Corridor tab ➤ Modify Region panel ➤ Add Regions

.

3 If the corridor has multiple baselines, select a baseline. In the drawing, hover over the corridor region
to highlight the baselines.
4 Do one of the following:
■

Specify the region start and end stations.

■

Enter F to fill an entire gap area as a new region. After entering F, you are prompted to specify the
region location.

5 In the Create Corridor Region dialog box, specify a name for the new region, and specify an assembly.
Click OK.
NOTE If the assembly has offsets defined, the offsets are displayed as children of the region. For information
about creating an assembly offset, see Creating an Assembly Offset (page 1543). For information about editing
a corridor region’s offset, see Editing Offsets (page 1499).
6 On the Target Mapping dialog box, set and edit targets the region.
7 Press Enter to end the command.
To add a corridor region using the Corridor Properties dialog box
1 In the drawing, click the corridor, and then click Corridor Properties.
2 In the Corridor Properties dialog box, click the Parameters tab (page 2035). Do one of the following:
■

To add a new region after any existing regions, right-click the baseline for which you want to add
a new region. Click Insert Region - After.

■

To insert a new region between two existing regions, right-click the first region. Click Insert Region
- After.

3 In the Create Corridor Region dialog box, select the assembly to assign to the region. Optionally, you
may specify a custom region name; otherwise accept the default region name.
The region is added to the corridor.
NOTE If the assembly has offsets defined, the offsets are displayed as children of the region. For information
about creating an assembly offset, seeCreating an Assembly Offset (page 1543). For information about editing
a corridor region’s offset, see Editing Offsets (page 1499)
4 Edit the region. For information, see To Edit a Corridor Region (page 1490).
To edit a corridor region using the Corridor Properties dialog box
1 At the command line, enter EditCorridorRegion.
2 Select a corridor in the drawing, or press Enter to select from the list of corridors in the current drawing.
3 In the Corridor Properties dialog box, click the Parameters tab (page 2035).
4 To edit a selected region from the drawing, click
in the drawing.
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Select Region From Drawing and select the region

5 To change the assembly for the region, click the Assembly field. Select the assembly in the Select An
Assembly dialog box.
6 To change either the start or end station for the region, select either the Start Station or End Station
field. Enter the station number or click

and click the station in the drawing.

7 To change the station frequency, click Set All Frequencies. Specify the frequency in the Frequency To
Apply Assemblies dialog box (page 2060).
8 To change the target to which the region is mapped, click Set All Targets. Specify the targets in the
Target Mapping dialog box (page 2064).
If you do not change the target when you change an assembly, the target will remain the same for most
common target types.
9 To delete a region, select the region, right-click, and click Remove Region.
10 Click Apply to make the changes.

Quick Reference
Ribbon
Corridor tab ➤ Modify Region panel ➤ Add Regions
Command Line
AddCorrRegions

Adding Stations to a Region
To add stations to a region using the Corridor ribbon tab
NOTE This method of adding stations by editing the frequency is the method that is typically used to change the
regular intervals for a region. To add manual stations to a corridor, it is best to use the Add a Section command
on the Modify Corridor Sections panel. This method lets you specify stations on any region and any baseline.
1 In the drawing, click a corridor.
2 Click Corridor tab ➤ Modify Region panel ➤ Edit Frequency

.

3 Select a region to edit.
4 In the Frequency To Apply Assemblies dialog box (page 2060), click
drawing.

. Select the station location in the

5 To add a description for the station, click the Description field and enter a description.
6 Click OK.
To add stations to a region using the Corridor Properties dialog box
1 In the drawing, click the corridor, and then click Corridor Properties.
2 In the Corridor Properties dialog box, click the Parameters tab (page 2035).
3 Click the Frequency field for the region to which you want to add stations.
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4 In the Frequency To Apply Assemblies dialog box (page 2060), click
drawing.

. Select the station location in the

5 To add a description for the station, click the Description field. Enter the description.
6 Click OK.

Changing Station Frequency
You can add or modify the frequency of stations in a corridor region using the EditCorrRegionFreq command.
Station frequency can be specified by referencing portions of the existing alignment and profile geometry
in a region.
For example, you can specify assembly insertion frequency for the following components of a corridor
region:
■

Along tangents. Specify the assembly insertion frequency along the tangent portion of an alignment.

■

Along curves. Specify the assembly insertion frequency along the curve portion of an alignment.

■

Along spirals. Specify the assembly insertion frequency along the spiral portion of an alignment.

■

Along profile curves. Specify the assembly insertion frequency along the curve portion of the profile.

■

At specific points. Specify whether assemblies should be inserted at specific geometry points, including
horizontal geometry, superelevation critical, profile geometry, and profile high and low points.

NOTE If both an assembly frequency setting that references horizontal geometry and a setting that references
vertical geometry apply to a portion of a corridor, the setting that results in a smaller interval is used. For example,
if a segment is both a horizontal tangent and a vertical curve, and the vertical curve frequency adds assemblies
at more frequent intervals, the frequency specified for vertical curves is used.
You can also modify station location and frequency by manually adding stations.
To change the station frequency for a region using the ribbon
1 In the drawing, click the corridor.
2 Click Corridor tab ➤ Modify Region panel ➤ Edit Frequency

.

3 Select a region on the corridor.
4 In the Frequency To Apply Assemblies dialog box (page 2060), modify the properties as required.
5 To manually add a station, click

. Select the station location in the drawing.

6 To add a description for the station, click the Description field. Enter the description.
7 Click OK.
To change the station frequency for a region using the Corridor Properties dialog box
1 In the drawing, click the corridor, then right-click and click Corridor Properties.
2 In the Corridor Properties dialog box, click the Parameters tab (page 2035).
3 Click the Frequency field for the region to which you want to add stations.
4 In the Frequency To Apply Assemblies dialog box (page 2060), modify the properties as required.
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5 To manually add a station, click

. Select the station location in the drawing.

6 To add a description for the station, click the Description field. Enter the description.
7 Click OK.
To change the station frequency for a region using the Prospector list view
1 In Toolspace, expand the Corridors collection, and then expand a corridor.
2 In Prospector, select a corridor baseline.
3 In the Prospector List View, select a region.
4 Click the Frequency field for the region to which you want to add stations.
5 In the Frequency To Apply Assemblies dialog box (page 2060), modify the properties as required.
6 To manually add a station, click

. Select the station location in the drawing.

7 To add a description for the station, click the Description field. Enter the description.
8 Click OK.

Quick Reference
Ribbon
Corridor tab ➤ Modify Region panel ➤ Edit Frequency
Toolspace Shortcut Menu
Prospector tab: Corridors ➤ <corridor name> ➤ Properties ➤ Parameters tab
Object Shortcut Menu
Corridor Properties
Dialog Box
Corridor Properties - Parameters tab (page 2035)
Command Line
EditCorrRegionFreq

Matching Corridor Region Parameters
This command lets you match the assembly, target, and or frequency parameters for selected corridor regions.
To match a corridor region’s parameters
1 In the drawing, click a corridor.
2 Click Corridor tab ➤ Modify Region panel ➤ Match Parameters

.

3 In the drawing, select a region to copy parameters from (source region).
4 Optionally, you can type ‘S’ and press Enter to display the Match Region Parameters dialog box.
Select the parameters to match (assembly, target, and or frequency). By default, all three are matched.
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5 Select a destination region or regions to apply parameters to.
When a region is selected, it becomes highlighted gray.
6 When you are finished selecting regions, press Enter.
See also:
■

Editing Corridor Regions (page 1486)

Quick Reference
Ribbon
Corridor tab ➤ Modify Region panel ➤ Match Parameters
Command Line
MatchCorrRegionParams
Dialog Box
Match Region Parameters (page 2061)

Merging Corridor Regions
Use this command to merge corridor regions along the same baseline.
If you want to merge two or more regions into one region, use the Merge Corridor Regions command.
You can only merge corridor regions that are consecutive, and of course, along the same baseline. AutoCAD
Civil 3D prevents you from selecting regions that are not consecutive.
You can merge two consecutive regions along the same baseline that have a gap between them; however,
when you merge them, the gap will be filled.

To merge corridor regions
1 In the drawing, click a corridor.
2 Click Corridor tab ➤ Modify Region panel ➤ Merge Regions
3 In the drawing, select the first region you want to merge.
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.

The selected region is highlighted gray.
4 Select the next region you want to merge.
5 Do one of the following:
■

Press Enter to end the command, and merge the two regions.

■

Select another (more) consecutive region, and press Enter to end the command.

When you merge corridor regions, the new region keeps the region name of the first region.

Quick Reference
Ribbon
Corridor tab ➤ Modify Region panel ➤ Match Parameters
Command Line
MatchCorrRegionParams

Copying Corridor Regions
Use this command to copy corridor regions along the same baseline.
To copy a corridor region
1 In the drawing, click a corridor.
2 Click Corridor tab ➤ Modify Region panel ➤ Copy Region

.

3 In the drawing, select a region to copy.
NOTE Only valid locations are available for selection. For example, only stations along the current baseline
that do not have a corridor region can be selected.
4 Do one of the following:
■

Specify the region start and end stations.

■

Enter F to fill an entire gap area with the copied region. After entering F, you are prompted to specify
the region location.

5 Press Enter to end the command.

Quick Reference
Ribbon
Corridor tab ➤ Modify Region panel ➤ Copy Region
Object Shortcut Menu
Copy Region
Command Line
CopyCorrRegions
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Isolating Regions
To isolate a corridor region to edit it
1 In the drawing, select the corridor region you want to edit.
2 Click Corridor tab ➤ Modify Region panel ➤

➤ Isolate Region

.

3 Edit the region as desired.
4 Click Corridor tab ➤ Modify Region panel ➤

➤ Show All Regions

.

All corridor regions are again visible.
NOTE You may have to rebuild (page 1615) the corridor to restore the visibility of all its regions.

Quick Reference
Ribbon
Corridor tab ➤ Modify Region panel ➤

➤ Isolate Region

Click Corridor tab ➤ Modify Region panel ➤

➤ Show All Regions

.

Toolspace Shortcut Menu
Prospector tab: Corridors ➤ <corridor name> ➤ Properties ➤ Parameters tab
Object Shortcut Menu
Corridor Properties
Command Line
EditCorridorProperties
EditCorridorRegion
IsolateCorridorRegion
ShowAllCorridorRegions
Dialog Box
Corridor Properties - Parameters tab (page 2035)

Hiding and Showing Regions
Hide or show corridor regions or entire baselines.
It is recommended that you hide unneeded regions while performing corridor edits. For example, when
editing a corridor that contains multiple regions, hide the regions that you are not editing. This typically
results in faster systm response time while editing a corridor.
To hide corridor regions or baselines using the ribbon
1 In the drawing, click the corridor.
2 Click Corridor tab ➤ Modify Region panel ➤

➤ Hide Regions

3 Select the regions to hide.
4 When you are finished selecting regions, press Enter.
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.

NOTE You can also hide regions or baselines using the Parameters tab of the Corridor Properties dialog box by
clearing the check box next to the region or baseline name. The check boxes you use to hide a region have a
tri-state display. If a baseline has multiple regions and only one of the regions is selected, the check box is dimmed
and not available.

Quick Reference
Ribbon
Corridor tab ➤ Modify Region panel ➤

➤ Hide Regions

Toolspace Shortcut Menu
Prospector tab: Corridors ➤ <corridor name> ➤ Properties ➤ Parameters tab
Object Shortcut Menu
Corridor Properties
Dialog Box
Corridor Properties - Parameters tab (page 2035)
Command Line
HideCorridorRegions

Deleting Corridor Regions
To delete corridor regions
1 Click a corridor.
2 Click Corridor tab ➤ Modify Region panel ➤

➤ Delete Regions

.

3 In the drawing, select a region to delete.
The selected region is highlighted gray.
4 Do one of the following:
■

Press Enter to delete the selected region, and end the command.

■

Select more regions to delete. Each selected region is highlighted gray. Press Enter to delete selected
regions, and end the command.

Quick Reference
Ribbon
Corridor tab ➤ Modify Region panel ➤

➤ Delete Regions

Object Shortcut Menu
Delete Regions
Command Line
DeleteCorrRegions
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Editing Corridor Region Properties
To edit a corridor region’s properties
1 In the drawing, click a corridor.
2 Click Corridor tab ➤ Modify Region panel ➤

➤ Region Properties

.

3 In the drawing, select a region to edit.
4 Edit the appropriate properties in the Corridor Region Properties dialog box (page 2041)Corridor Region
Properties dialog box.

Quick Reference
Ribbon
Corridor tab ➤ Modify Region panel ➤

➤ Region Properties

Command Line
EditCorrRegionProps
Dialog Box
Corridor Region Properties (page 2041)

Adding Baselines
Add additional baselines to a corridor to create offset alignments.
Typically, you need to add additional baselines if you require offsets or more complex corridor models, such
as ones with intersections.
To add baselines using the ribbon
1 In the drawing, click the corridor.
2 Click Corridor tab ➤ Modify Corridor panel ➤ Add Baseline

.

3 In the Create Corridor Baseline dialog box, specify a baseline name.
4 Specify a horizontal alignment by selecting one from the drop-down list, or click
in the drawing.

to select a baseline

5 Click OK.
6 On the Select a Profile dialog box, specify a profile by selecting one from the drop-down list, or click
to select a baseline in the drawing.
7 Click OK.
To add baselines using the Corridor Properties dialog box
1 In the drawing, click the corridor, then right-click and click Corridor Properties.
2 In the Corridor Properties dialog box, click the Parameters tab (page 2035).
3 To add a new baseline, click Add Baseline.
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4 In the Pick Horizontal Alignment dialog box, select the alignment from the list or click
alignment in the drawing.

to select an

5 To select the profile for the baseline, click the Profile field. Select the profile from the list or click
to select a profile in the drawing.
6 To add a region to the baseline, right-click the baseline. Click Add. For information, see Adding Corridor
Regions (page 1489).
7 Click Apply.

Quick Reference
Ribbon
Corridor tab ➤ Modify Corridor panel ➤ Add Baseline
Toolspace Shortcut Menu
Prospector tab: Corridors ➤ <corridor name> ➤ Properties ➤ Parameters tab
Object Shortcut Menu
Corridor Properties
Dialog Box
Corridor Properties - Parameters tab (page 2035)

Editing Offsets
If a region has an assembly offset specified, you can edit the alignment, profile, and station start and end
for the offset.
For information, on assembly offsets, seeCreating an Assembly Offset (page 1543).
To edit an offset alignment for a region
1 In the drawing, click the corridor, then right-click and click Corridor Properties.
2 In the Corridor Properties dialog box, click the Parameters tab (page 2035).
3 To change the alignment for the offset, click the Alignment field. Select the alignment in the Pick
Horizontal Alignment dialog box.
4 To change either the start or end station for the region, select either the Start Station or End Station
field. Enter the station number or click

and select the station in the drawing.

5 Click Apply.

Quick Reference
Ribbon
Offset Alignment tab ➤ Modify panel ➤ Offset Parameters
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Toolspace Shortcut Menu
Prospector tab: Corridors ➤ <corridor name> ➤ Properties ➤ Parameters tab
Object Shortcut Menu
Corridor Properties
Dialog Box
Corridor Properties - Parameters tab (page 2035)

Viewing and Deleting Overridden Stations
View and delete stations that have assembly overrides applied.
Assembly overrides are created and edited using the Corridor Section Editor. However, you can view and
delete overrides in the Corridor Properties dialog box, on the Parameters tab.
For information about creating assembly overrides, see Editing Corridor Sections (page 1523).
To view or delete assembly overrides for a region
1 In the drawing, select the corridor, right-click, and click Corridor Properties.
2 In the Corridor Properties dialog box, click the Parameters tab.
3 For a region that has assembly overrides, click the Overrides column. For information about creating
assembly overrides, see Editing Corridor Sections (page 1523).
4 In the Assembly Override Stations dialog box (page 2034), the assembly name, range, stations, and override
method are displayed.
5 To remove the assembly overrides from a station (and apply the default assembly parameters) and delete
the station from the list, click the station and click

.

6 To remove all the assembly overrides from the region, click Delete All.
The list is cleared and the default assembly parameters are applied to all stations in the corridor region.
7 Click OK to close the dialog box.

Quick Reference
Toolspace Shortcut Menu
Prospector tab: Corridors ➤ <corridor name> ➤ Properties ➤ Parameters tab
Object Shortcut Menu
Corridor Properties
Dialog Box
Assemblies Overrides (page 2034)

Editing the Code Set Style
View and modify the code set style for the corridor.
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A corridor is defined using a set of subassemblies. These subassemblies can have styles assigned to points,
links, and shapes. You may want to display these components in various ways. Code set styles enable you
to manage the display of these components by using a mapping system that maps codes to styles.
For information about code set styles and subassemblies, see Using Codes and Code Set Styles (page 1567).
To edit a corridor’s code set style using the Corridor Properties dialog box
1 In the drawing, click the corridor, then right-click and click Corridor Properties.
2 In the Corridor Properties dialog box, click the Codes tab (page 2037). All codes used by the corridor with
their corresponding descriptions, style, and label style information are displayed in the properties table.
3 To change the code set style used by the corridor, click the Code Set Style list or use the standard style
creation tools to edit or create a style. For more information about the style creation tools, see the Select
Style Dialog Box (page 2021).
These styles control the way the corridor is displayed in section view.
4 Click

to view information for the selected style.

5 Click Apply.
To edit a corridor’s code set style using the ribbon
1 In the drawing, click the corridor.
2 Click Corridor tab ➤ Modify Corridor panel ➤
3 Click

➤ Edit Code Set Styles

.

to view information for the selected style.

4 Click Apply.

Quick Reference
Ribbon
Corridor tab ➤ Modify Corridor panel ➤

➤ Edit Code Set Styles

Toolspace Shortcut Menu
Prospector tab: Corridors ➤ <corridor name> ➤ Properties ➤ Codes tab
Object Shortcut Menu
Corridor Properties
Dialog Box
Corridor Properties - Codes tab (page 2037)

Editing Feature Lines
Use the Feature Lines tab to view the feature line codes and display styles or to modify how a corridor’s
feature lines are connected.
By default, AutoCAD Civil 3D joins all points with the same point code along a baseline and displays them
as feature lines. You can modify how points are connected when a point code is used multiple times at
consecutive stations.
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Editing Feature Line Connections
Modify feature line connections by specifying which point codes are connected using branching options
and the direction for branching, and whether extra point codes are to be connected.

Branching and Connecting Extra Points
If an assembly is applied at consecutive stations with a varying number of point codes (of the same type),
you can control both whether the feature lines are connected and how they are connected.
The following illustrations show different branching and point connection options and the resultant feature
lines.
In all illustrations:
■

Assemblies with a varying number point codes of the same type are used at the stations.

■

The centerline (heavy black line) is the corridor baseline (alignment).

■

The circular points on the gray lines are of one type of point code.

■

The circular points on the green lines are of another type point code.

■

There are two groups in each assembly: left and right (of the baseline).

■

The Connect option is selected for both types of point codes.

Inward branching and extra points (with the same point code) are not connected:

Inward branching and extra points (with the same point code) are connected:
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Outward branching and extra points (with the same point code) are not connected:

Outward branching and extra points (of the same point type) are connected:
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To edit the feature line connection using the Corridor Properties dialog box
1 In the drawing, click the corridor, then right-click and click Corridor Properties.
2 In the Corridor Properties dialog box, click the Feature Lines tab (page 2037).
3 By default, all identical point codes are connected as longitudinal feature lines. To delete feature lines
between one or more types of point codes, clear the check box in the Connect field for the appropriate
code.
NOTE If the Connect check box is disabled, the feature line is being used in a corridor surface definition. It
cannot be disconnected.
4 To control how to connect point codes that are used a varying number of times at different sections,
use the Branching field. Select one of the following:
■

Inward: The feature line branches inward, joining the innermost points.

■

Outward: The feature line branches outward, joining the outermost points.

5 To prevent feature lines from being disconnected when there is branching, select Connect Extra Points.
6 Click Apply.
To edit the feature line connection using the ribbon
1 In the drawing, click the corridor.
2 Click Corridor tab ➤ Modify Corridor panel ➤

➤ Feature Lines

.

The Connect Feature Lines dialog box Connect Feature Lines dialog box (page 2031)is displayed.
3 By default, all identical point codes are connected as longitudinal feature lines. To delete feature lines
between one or more types of point codes, clear the check box in the Connect field for the appropriate
code.
NOTE If the Connect check box is disabled, the feature line is being used in a corridor surface definition. It
cannot be disconnected.
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4 To control how to connect point codes that are used a varying number of times at different sections,
use the Branching field. Select one of the following:
■

Inward: The feature line branches inward, joining the innermost points.

■

Outward: The feature line branches outward, joining the outermost points.

5 To prevent feature lines from being disconnected when there is branching, select Connect Extra Points.
6 Click Apply.

Quick Reference
Ribbon
Corridor tab ➤ Modify Corridor panel ➤

➤ Feature Lines

Toolspace Shortcut Menu
Prospector tab: Corridors ➤ <corridor name> ➤ Properties ➤ Feature Lines tab
Object Shortcut Menu
Corridor Properties
Dialog Box
Corridor Properties - Feature Lines tab (page 2037)

Editing Feature Line Styles
View and modify the feature line styles for the corridor.
Use different feature line styles to distinguish the feature lines for easier selection and identification. The
feature line style for each code is controlled by the code set style.
To edit the feature line styles using the Corridor Properties dialog box
1 In the drawing, click the corridor, then right-click and click Corridor Properties.
2 In Corridor Properties dialog box, click the Feature Lines tab (page 2037). All point codes with their
corresponding types and feature line style information are displayed in the grid.
3 To change the style for an individual code, for the point code you want to change, click
in the
Feature Line Style field. Select a style in the Pick Feature Line Style dialog box. For more information
about the style creation tools, see the Select Style Dialog Box (page 2021).
4 Click Apply.
To edit the feature line styles using the ribbon
1 In the drawing, click the corridor.
2 Click Corridor tab ➤ Modify Corridor panel drop-down ➤ Feature Lines

.

The Connect Feature Lines dialog box is displayed. All point codes with their corresponding types and
feature line style information are displayed in the grid.
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3 To change the style for an individual code, for the point code you want to change, click
in the
Feature Line Style field. Select a style in the Pick Feature Line Style dialog box. For more information
about the style creation tools, see the Select Style Dialog Box (page 2021).
4 Click Apply.

Quick Reference
Ribbon
Feature Line tab ➤ Modify panel ➤ Feature Line Properties drop-down ➤ Edit Feature Line Style
Toolspace Shortcut Menu
Prospector tab: Corridors ➤ <corridor name> ➤ Properties ➤ Feature Lines tab
Object Shortcut Menu
Corridor Properties
Dialog Box
Corridor Properties - Feature Lines tab (page 2037)

Creating and Editing Corridor Surfaces
You can create a surface from a corridor.
Because corridor surfaces are an output of a corridor model, they remain dynamically linked to the corridor.
Any changes to the corridor definition are reflected in the surface definitions. You can also create a detached
surface from a corridor surface.
You can use the Surfaces tab of the Corridor Properties dialog box to create corridor surface. Clicking Corridor
Surfaces
surface.

on the Corridors contexual ribbon tab also displays the dialog box that lets you create a corridor

For information about creating a detached surface, see Exporting Corridor Surfaces (page 1532).
When you create a corridor surface, it is added to the Surfaces collection on the Toolspace Prospector tab
with the corridor surface icon
. You can work with a corridor surface the same way you do with any
surface in the Surfaces collection, including changing its style, adding labels to it, and using it for surface
analysis. The following features and behaviors are unique to corridor surfaces:
■

When you select a corridor surface, only the surface is selected. The corridor it is based on is not selected.

■

When you change the surface style of a corridor surface using its surface properties, the style is also
changed on the corridor properties Surfaces tab.

■

When a corridor is rebuilt, corridor surfaces are updated to reflect any changes in the corridor, and then
any edits are applied to the corridor model.

■

The corridor from which the surface was taken is listed in the surface properties definition.

NOTE Do not use a corridor surface as a target for assemblies.
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Creating a Corridor Surface
You can create a corridor surface and then add the required feature line or link codes. Also, you can create
a separate corridor surface from each link code in a single operation.
■

Create a corridor surface. Use this method if a corridor surface is to be extracted from a set of link codes
and corridor feature lines. For example, create a surface using the Links data type and the Top code. After
a surface is created, you can add more link codes and feature lines to the surface definition.

■

Create a corridor surface from each link code. Use this method to create one surface based on each link
code. For example, if Top, Paved, and Side_slope are defined as link codes (in the subassemblies used to
build the corridor), this method creates three surfaces: one surface using Top as breaklines, a second
surface using Paved, and a third surface using Side_slope.

When creating corridor surfaces, sometimes you may need to correct overhanging surfaces in the corridor.
Overhanging surfaces are corrected in the Surfaces tab, Corridor Properties dialog box. For more information,
see Resolving an Overhanging Surface (page 1510).
To create a corridor surface
1 In the drawing, click the corridor.
2 Click Corridor tab ➤ Modify Corridor panel ➤ Corridor Surfaces

.

The Corridor Surfaces dialog box is displayed.
NOTE You can also access this dialog box by right-clicking a corridor in Toolspace, selecting Properties, then
clicking the Surfaces tab.
3 Optional ly, click
to open the Name Template dialog box. Set or modify the corridor surface naming
convention. For information about the name template, see Name Template Dialog Box (page 2022).
4 Click

to create an empty corridor surface.

5 To add data to the surface, select it in the grid. Select the data type from the Data Type list. Select the
code from the Specify Code list. Click

.

6 In the grid, expand the surface to view its data components.
7 Optionally, to add additional data to the corridor surface, repeat Step 3.
8 Optionally, to create another surface and add data to it, repeat Steps 2 and 3.
9 Optionally, you may need to resolve overhanging surfaces. For more information, see Resolving an
Overhanging Surface (page 1510).
10 If you do not want to create a dynamic corridor surface, clear the check box next to the surface name.
11 Click Apply to display the corridor surface in the drawing.
If the check box beside the surface name is selected, the surface is added to the Surfaces collection on
the Toolspace Prospector tab.
To create a corridor surface for each link
1 In the drawing, click the corridor.
2 Click Corridor tab ➤ Modify Corridor panel ➤ Corridor Surfaces

.

3 In Corridor Surfaces dialog box, click the Surfaces tab.
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4 Optionally, click
to open the Name Template dialog box. Set or modify the corridor surface naming
convention. For information about the name template, see Name Template Dialog Box (page 2022).
5 Click
to create a corridor surface from each link code. Corridor surfaces are created from all link
codes and are listed in the grid. You can view and modify them.
6 If you do not want a corridor surface added to the Surfaces collection on the Toolspace Prospector tab,
clear the check box next to that surface name.
7 Click Apply to display the corridor surfaces in the drawing.
If the check box next to a surface name is selected, the surface is added to Surfaces collection on the
Toolspace Prospector tab.

Quick Reference
Ribbon
Corridor tab ➤ Modify Corridor panel ➤ Corridor Surfaces
Toolspace Shortcut Menu
Prospector tab: Corridors ➤ <corridor name> ➤ Properties ➤ Surfaces tab
Object Shortcut Menu
Corridor Properties
Dialog Box
Corridor Surfaces (page 2045)

Copying Corridor Surfaces
Create a copy of an existing corridor surface
NOTE Because a corridor has a large number of dependencies, it cannot be moved, copied, rotated, nor scaled
up or down. However, a corridor surface can be copied. You can then edit the copied surface.
When a corridor surface is copied, a naming convention is used. For example if the original corridor surface
is named ‘Corridor - Datum’, the new surface is named ‘Corridor - Datum (1)’. If the ‘Corridor - Datum‘
surface is copied again, the new surface is named ‘Corridor - Datum (2)’. If the ‘Corridor - Datum (1)’ surface
is copied, the new surface is named ‘Corridor - Datum (1) (2)’.
To copy a corridor surface
1 In the drawing area, click the corridor surface. Right-click and click Basic Modify Tools ➤ Copy.
At the command line, you are prompted to specify a base point for the corridor surface.
2 Click an insertion point in the drawing area.
The corridor surface is pasted in the drawing and added as a new surface to the Surfaces collection in
the Prospector tree.
3 To edit the name of the corridor surface, right-click the surface in the Prospector tree. Click Properties.
The Surface Properties dialog box is displayed with the Information tab (page 2656) active. The Name
field contains the name of the copied corridor, which is, by default, “ <surface-name> (1).”
4 Enter a new name in the Name field.
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5 To specify the description of the corridor surface, enter a new description in the Description field.
6 Click Apply to make the changes, or click OK to make the changes and close the Surface Properties
dialog box.

Editing a Corridor Surface
Modify corridor surfaces to change how they are displayed and to add or remove data from the surfaces.
When you create a corridor surface as a dynamic surface, you can edit many of the surface properties and
perform surface analysis using the surface properties. Access surface properties from the ribbon, or using the
Surfaces collection in the Toolspace Prospector tab. For more information, see Understanding Surfaces (page
645).
To edit a corridor surface
1 In the drawing, click the corridor.
2 Click Corridor tab ➤ Modify Corridor panel ➤ Corridor Surfaces

..

3 In Corridor Surfaces dialog box, click the Surfaces tab.
4 In the properties table, select the surface that you want to edit.
5 To modify the name of the surface, click the name. Modify accordingly.
6 To change the surface display style used by the corridor surface, click the Surface Style field. Select the
style from the Pick Corridor Surface Style dialog box or use the standard style creation tools to edit or
create a style. For more information about the style creation tools, see the Select Style Dialog Box (page
2021).
7 To change the render material used by the corridor surface, click the Render Material field. Select the
style from the Select Render Material dialog box or use the standard style creation tools to edit or create
a style. For more information about rendering corridor surfaces, see the Rendering Corridor Models
(page 1533).
8 To add data to the surface, select the surface in the properties table. Select the data type in the Data
Type list. Select the code in the Specify Code list. Click

.

9 To remove data from a surface, in the properties table, expand the surface. Select the data component
that you want to delete, and click

.

10 To remove the corridor surface from the Surfaces collection on the Toolspace Prospector tab, clear the
check box next to the surface name.
11 Click Apply.

Quick Reference
Ribbon
Corridor tab ➤ Modify Corridor panel ➤ Corridor Surfaces
Toolspace Shortcut Menu
Prospector tab: Corridors ➤ <corridor name> ➤ Properties ➤ Surfaces tab

Creating and Editing Corridor Surfaces | 1509

Object Shortcut Menu
Corridor Properties
Dialog Box
Corridor Properties - Surfaces tab (page 2038)
Command Line
DefineCorridorSurfaces

Resolving an Overhanging Surface
Correct overhanging surfaces in the corridor.
When subassemblies are joined to form an assembly, surfaces of the subassemblies can overhang one another.
This presents an incorrect representation of how the surface should be modeled.
Overhanging surfaces can be corrected using the Surfaces tab, Corridor Properties dialog box. You can correct
the overhang by following the top links or bottom links in the assembly. The overhang correction feature
defaults to no links.

Surface (red) corrected to top links

Surface corrected to bottom links

To resolve an overhanging surface
1 In the drawing, click the corridor, then right-click and click Corridor Properties.
2 In Corridor Properties dialog box, click the Surfaces tab (page 2038).
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You can also access this functionality from the ribbon by clicking Corridor tab ➤ Modify Corridor
panel ➤ Corridor Surfaces

..

3 In the Name column, select the corridor surface.
4 Click in the Overhang Correction column, and select Top Links or Bottom Links. The entry defaults to
None.
5 Click OK to correct the overhang.

Quick Reference
Ribbon
Corridor tab ➤ Modify Corridor panel ➤ Corridor Surfaces
Toolspace Shortcut Menu
Prospector tab: Corridors ➤ <corridor name> ➤ Properties ➤ Surfaces tab
Object Shortcut Menu
Corridor Properties
Dialog Box
Corridor Properties - Surfaces tab (page 2038)

Adding and Editing Corridor Boundaries
Use corridor surface boundaries to prevent triangulation outside of the daylight lines of a corridor surface
and prevent them from being displayed or to render an area of the corridor surface as a render material.
Corridor surfaces support the following types of boundaries:
■

Render Only. Used to represent different parts of corridor surface with different materials (when rendering),
for example, asphalt and grass. For more information about rendering, see Rendering Objects (page 1764).

■

Hide Boundary. Used to mask to create void areas or punch holes in the corridor surface. For example,
if a link code Paved is used on either side of the corridor with another surface (a median), separating
them, when you create a corridor surface using Paved as the data, AutoCAD Civil 3D tries to connect the
gap in between two link codes. To create voids, you define boundaries to represent the surface
appropriately.

■

Outside Boundary. Used to define the outer boundary of the corridor surface.
NOTE A corridor surface must exist before you can add a corridor boundary. For information about creating
a corridor surface, see Creating and Editing Corridor Surfaces (page 1506).

Adding Boundaries to a Corridor Surface
Use the Boundaries tab of the Corridor Properties dialog box, or the Create Boundary From Corridor command
on the Create Design panel of the Home tab, to create corridor boundaries.
In the Boundaries tab, you can create the boundaries using the following options:
■

Add Automatically, when there is a single baseline, based on point codes to which feature lines are
assigned
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■

Corridor Extents As Outer Boundary, when there are multiple baselines, based on feature lines or surface
link codes

■

Add Interactively, by selecting feature lines in the drawing

■

Add From Polygon, using a closed polygon that forms the boundary

When selecting the feature lines from which to create the boundary, first select the bottom end of one
feature line, followed by the top end of its pair.
For example, select the bottom outside edge of a lane followed by the top outside edge of a lane to create a
boundary that encompasses both lanes:

If you are creating the corridor boundary using a polygon, you can create the required polygon by exporting
corridor feature lines as polylines, and then join them to create the required polygon.
For more information about converting feature lines to polylines, see Exporting Corridor Data (page 1528).
NOTE The Add Automatically option to add boundaries Automatically is not available if more than one baseline
is used in the corridor. In that case, select Corridor Extents As Outer Boundary, to automatically add a boundary
for each corridor surface.
To automatically create outer boundaries
1 In the drawing, click the corridor, then right-click and click Corridor Properties.
You can also access this functionality from the ribbon by clicking Corridor tab ➤ Modify Corridor
panel ➤ Corridor Surfaces

..

2 Click the Boundaries tab (page 2039).
3 Right-click the corridor surface to which you want to add a mask.
■

To automatically add a boundary to a corridor with a single baseline, click Add Automatically ➤
<code name>.
NOTE Only point codes that form a pair of feature lines in the corridor are listed, for example daylight
and ETW.

■

To automatically add a boundary to a corridor with multiple baselines, click Corridor Extents As
Outer Boundary.

The boundary is added to the corridor surface where you can modify its name, style usage and type.
For information, see Editing a Corridor Boundary (page 1514).
To interactively add a boundary to a corridor surface
1 In the drawing, click the corridor, then right-click and click Corridor Properties.
You can also access this functionality from the ribbon by clicking Corridor tab ➤ Modify Corridor
panel ➤ Corridor Surfaces
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.

2 Click the Boundaries tab (page 2039).
3 Right-click the corridor surface to which you want to add a boundary. Click Add Interactively.
NOTE A corridor surface must exist before you can add a corridor boundary. For information about creating
a corridor surface, see Creating and Editing Corridor Surfaces (page 1506).
4 In the drawing, click a corridor feature line that will form one side of the boundary. If you make an
ambiguous selection, the Select A Feature Line dialog box is displayed. Select a feature line from the
list.
5 In the drawing, click the corridor feature line that will form the other side of the boundary. If you make
an ambiguous selection, the Select A Feature Line dialog box is displayed. Select a feature line from the
list.
6 When you finish selecting the feature lines, press Enter.
7 In the Boundaries tab grid, expand the corridor surface to display the boundary.
8 Click Use Type. Select the type of boundary, either: Render Only, Hide Boundary, or Outside Boundary.
9 Click Apply.
To create outer boundaries using a closed polygon
1 In the drawing, click the corridor, then right-click and click Corridor Properties.
You can also access this functionality from the ribbon by clicking Corridor tab ➤ Modify Corridor
panel ➤ Corridor Surfaces

..

2 Click the Boundaries tab (page 2039).
3 Right-click the corridor surface to which you want to add a mask. Click Add From Polygon.
4 In the drawing window, click the closed polygon you want to use to define the boundaries of the
corridor surface.
5 The boundary is added to the corridor surface where you can modify its name, render style, and type.
For more information, see Editing a Corridor Boundary (page 1514).
NOTE If you create an invalid boundary, you will be prompted to continue (and correct the error), to save the
invalid boundary (which can be corrected later) or to cancel the boundary creation.
To create a polyline boundary from a corridor
1 Click Home tab ➤ Create Design panel

Create Boundary From Corridor.

2 Click a corridor in the drawing, or press Enter to select a corridor in the Select A Corridor dialog box.
A closed polyline is created as the outer boundary of the corridor. This closed polyline can then be used
to create a surface boundary, using the Add From Polygon (page 1513) command.

Quick Reference
Ribbon
Home tab ➤ Create Design panel

Create Boundary From Corridor
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Toolspace Shortcut Menu
Prospector tab: Corridors ➤ <corridor name> ➤ Properties ➤ Boundaries tab
Object Shortcut Menu
Corridor Properties
Command Line
CreateBoundaryFromCorridor
Dialog Box
Corridor Properties - Boundaries tab (page 2039)

Editing a Corridor Boundary
Rename, change styles, view, and modify the boundary definition.
Because boundaries are connected based on how the feature lines are selected, you can use the Corridor
Boundary Definition dialog box to iteratively modify, preview, and validate the boundaries after you create
them. You can:
■

Add or remove feature lines from the boundary definition

■

Specify if the boundary is to be drawn on a feature line in reverse of the station incrementing order.

■

Change the draw order of feature lines in the boundary.

■

Preview the boundary. The boundary is temporarily drawn as a green polygon.

■

Ensure that the boundary is well-formed and has no crossing edges.

To edit a corridor boundary
1 In the drawing, click the corridor, then right-click and click Corridor Properties.
You can also access this functionality from the ribbon by clicking Corridor tab ➤ Modify Corridor
panel ➤ Corridor Surfaces

..

2 Click the Boundaries tab (page 2039).
3 Expand the corridor surface for which you want to modify a boundary.
4 To modify the boundary name or description, click its Name or Description field. Enter a new name or
description.
5 To change the render material, which is used for Render Only boundaries, click the Render Material
field for the boundary. Select a render material from the Select Render Material dialog box.
6 To view the boundary definitions and change the extents, click [...] in the Definition column.
7 In the Corridor Boundary Definition dialog box (page 2032), to change either the start or end points for
the boundary, either select the Start Point or End Point fields and enter the values number, or click
and click the point in the drawing.
8 To reverse the boundary draw direction along a feature line, either select or clear the Reverse Direction
check box.
9 To add a new feature line to the boundary definition, click

. Click the feature line in the drawing.

10 To delete a feature line from the boundary definition, select the feature line. Click
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.

11 To move a feature line up or down in the boundary definition order, select the feature line. Click
to move it up or

to move it down.

12 To preview the corridor boundary, click

.

The boundary is displayed as a green polyline.
13 To verify that the boundary polygon is well formed (for example, that its edges do not cross each other),
click

.

A message is displayed next to the button, indicating the state of the boundary.
14 Click OK to close the Corridor Boundary Definition dialog box.
15 To change the boundary type, click Use Type. Select the boundary type.
16 Click Apply.

Quick Reference
Toolspace Shortcut Menu
Prospector tab: Corridors ➤ <corridor name> ➤ Properties ➤ Boundaries tab
Object Shortcut Menu
Corridor Properties
Dialog Box
Corridor Properties - Boundaries tab (page 2039)

Creating and Editing Corridor Slope Patterns
Add slope patterns between a set of feature lines.
Slope patterns are slope indicator lines. They have one or more repeating lines that are aligned with the flow
direction. The lines can be the length of the slope or less. They can have a predefined symbol or an AutoCAD
block inserted at one end.
Slope patterns are applied between any two feature lines (typically, between a grading footprint and daylight
line).
For more information about slope patterns, see Creating Grading Styles (page 802).
Typical slope pattern usage along a corridor:
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Adding a Corridor Slope Pattern
Add slope patterns to corridor surfaces.
To add a corridor slope pattern using the Corridor Properties dialog box
1 In Toolspace, on the Prospector tab, expand

Corridors, right-click the corridor, and click Properties.

2 In Corridor Properties dialog box, click the Slope Patterns tab (page 2040).
3 Click Add Slope Pattern >>.
4 In the drawing, select the first corridor feature line that will form one side of the slope. If you make an
ambiguous selection, the Select A Feature Line dialog box is displayed. Select a feature line from the
list.
5 Select the second corridor feature line that will form the other side of the slope. If you make an ambiguous
selection, the Select A Feature Line dialog box is displayed. Select a feature line from the list.
6 Click Apply.
To add a corridor slope pattern using the ribbon
1 In the drawing, click the corridor.
2 Click Corridor tab ➤ Modify Corridor panel ➤

➤ Slope Patterns

.

3 Click Add Slope Pattern >>...
4 In the drawing, select the first corridor feature line that will form one side of the slope. If you make an
ambiguous selection, the Select A Feature Line dialog box is displayed. Select a feature line from the
list.
5 Select the second corridor feature line that will form the other side of the slope. If you make an ambiguous
selection, the Select A Feature Line dialog box is displayed. Select a feature line from the list.
6 Click Apply.

Quick Reference
Ribbon
Corridor tab ➤ Modify Corridor panel ➤

➤ Slope Patterns

Toolspace Shortcut Menu
Prospector tab: Corridors ➤ <corridor name> ➤ Properties ➤ Slope Patterns tab
Object Shortcut Menu
Corridor Properties
Dialog Box
Corridor Properties - Slope Patterns tab (page 2040)
Define Slope Patterns Dialog Box (page 2053)

Editing a Corridor Slope Pattern
Modify the display and extents of a slope pattern.
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To edit a corridor slope pattern using the Corridor Properties dialog box
1 In Toolspace, on the Prospector tab, expand

Corridors. Right-click the corridor. Click Properties.

2 In the Corridor Properties dialog box, click the Slope Patterns tab (page 2040).
3 To change the slope pattern style, click
in the Slope Pattern Style field. Select a style from the Pick
Style dialog box or use the standard style creation tools to edit or create a style. For more information
about the style creation tools, see the Select Style Dialog Box (page 2021).
4 To change either the start or end points for the slope pattern, select either the Station Start or Station
End fields. Enter the values, or click

and click the location in the drawing.

5 Click Apply.
To edit a corridor slope pattern using the ribbon
1 In the drawing, click the corridor.
2 Click Corridor tab ➤ Modify Corridor panel ➤

➤ Slope Patterns

.

3 To change the slope pattern style, click
in the Slope Pattern Style field. Select a style from the Pick
Style dialog box or use the standard style creation tools to edit or create a style. For more information
about the style creation tools, see the Select Style Dialog Box (page 2021).
4 To change either the start or end points for the slope pattern, select either the Station Start or Station
End fields. Enter the values, or click

and click the location in the drawing.

5 Click Apply.

Quick Reference
Ribbon
Corridor tab ➤ Modify Corridor panel ➤

➤ Slope Patterns

Toolspace Shortcut Menu
Prospector tab: Corridors ➤ <corridor name> ➤ Properties ➤ Slope Patterns tab
Object Shortcut Menu
Corridor Properties
Dialog Box
Corridor Properties - Slope Patterns tab (page 2040)
Define Slope Patterns Dialog Box (page 2053)

Rebuilding Corridors
After making certain types of changes to a corridor, you need rebuild the corridor.
Rebuilding a corridor updates it to apply all changes made to the corridor’s dependent components, such
as its baselines, profiles, or dependent surfaces.
Corridors that need to be rebuilt have a warning icon
Prospector tree.

displayed next to the corridor’s name in the
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In AutoCAD Civil 3D, you can rebuild a corridor manually, or set the corridor to rebuild automatically.
You can manually rebuild a selected corridor, or rebuild all corridors in the drawing.
To configure a corridor to rebuild automatically
1 In Toolspace, on the Prospector tab, expand the Corridors collection.
2 Right-click the corridor with the warning

.

3 Click Rebuild - Automatic.
A check mark is displayed next to Rebuild - Automatic command when it is enabled.
To manually rebuild a corridor
1 In the drawing, click the corridor with the warning

.

2 Click Corridor tab ➤ Modify Corridor panel ➤ Rebuild Corridor drop-down ➤ Rebuild Corridor

.

NOTE You can also rebuild a corridor by right-clicking the corridor in Prospector and selecting Rebuild.
To manually rebuild all corridors in the drawing
1 Click Modify tab ➤ Design panel ➤ Corridor.
2 Click Corridor tab ➤ Modify Corridor panel ➤ Rebuild Corridor drop-down ➤ Rebuild All Corridors
.
NOTE You can also rebuild all corridors in the drawing by right-clicking the Corridors collection in Prospector and
selecting Rebuild All.

Quick Reference
Ribbon
Corridor tab ➤ Modify Corridor panel ➤ Rebuild Corridor
Toolspace Shortcut Menu
Prospector tab: Corridors ➤ right-click <corridor name> ➤ Rebuild
Object Shortcut Menu
Rebuild Corridor
Command Line
UpdateCorridor

Deleting a Corridor
You can delete a corridor, erasing it from the drawing and removing it from the Corridors collection in the
Prospector tree.
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To delete a corridor
■

In Toolspace, on the Prospector tab, expand the Corridors collection. Right-click the corridor. Click
Delete.
The corridor is erased from the drawing and removed from the Corridors collection in the Prospector
tree.
NOTE You cannot delete objects that have dependencies (other objects). For example, if you have created a
section object from the corridor, you must delete the section before you delete the corridor.

Quick Reference
Toolspace Shortcut Menu
Prospector tab: Corridors ➤ right-click <corridor name> ➤ Delete

Viewing and Editing Corridor Sections
You can use the Corridor Section Editor to view and modify corridor sections.
Use the Corridor Section Editor to apply assembly overrides to a corridor section or a range of sections and
then view only those sections. To view both the corridor section view and its location along the corridor
(1), open two horizontal viewports.

Viewing Corridor Sections
Use the Corridor Section Editor to visually inspect how assemblies are applied at various stations.
A simple corridor section as viewed with the Corridor Section Editor.
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You can step through corridor stations or jump to any station of interest.
To view a corridor by sections
1 Select a corridor in the drawing.
2 Click Corridor tab ➤ Modify panel ➤ Corridor Section Editor

.

3 Optionally, you can use the Select A Baseline list to select another baseline for the corridor or click
and select an alternate alignment in the drawing.
Alternately, in the prospector or the viewport, you can right click on the corridor you wish to view as sections,
right-click and click View/Edit Corridor Section.
To change your view of corridor sections
1 To view a section at a different station: On the Station Selection panel, select it from the Select a Station
drop-down list.
2 On the Station Selection panel, click
3 Click

or

to view the previous station or click

to view the first or end station.
to view the next station.

4 To view only the stations that have assembly overrides applied to them, click
Stations. Only stations with assembly overrides are displayed in the list.
5 To view all stations, click

Show Overridden

Show Overridden Stations again.

6 To set zoom options, on the View Tools tab, either:
■

Click

Zoom to Extents to view the entire corridor section view.

■

Click

Zoom to an Offset and Elevation to lock the zoom to a selected elevation or offset.

■

Click

Zoom to Subassembly to lock the zoom to a selected subassembly.

7 Optionally, to view detailed information about the assembly and subassemblies used by the region in
the Corridor Parameters vista: On the Corridor Edit Tools panel, click
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Parameter Editor.

To edit corridor section viewing and editing options
1 To change corridor section viewing and editing options: On the Section Editor tab, View Tools panel,
click

View/Edit Options.

2 In the View/Edit Corridor Section Options (page 2065) dialog box, under View/Edit Options, select a style
from the Code Set Style list, to change the display of corridor section elements such as shapes, links,
and points.
3 Under View/Edit Options, enter a new scale in the Default View Scale field.
4 Under View/Edit Options, select the Rebuild on Edit option, to automatically rebuild the corridor model
when you edit a subassembly using the section viewing and editing tools.
NOTE To change the default section viewing scale or automatic corridor rebuild value, on the Toolspace
Settings tab, expand Corridor ➤ Commands. Right-click ViewEditCorridorSection, and click Edit Command
Settings. In the Edit Command Settings dialog box, expand the View/Edit Options property group. Modify
the Default View Scale and Rebuild On Edit settings as required.
5 Under View/Edit Options, edit the values in the Front Clip and Back Clip fields, to display 3D objects,
such as pipe network parts located at the specified station.
You can display any 3D object located at the station, including pipe network parts, blocks, and polylines.
The clip values control the start and end of the visible extents of objects in the corridor section, from
front to back.
NOTE Unless 3D Objects reside on a visible layer, they are not displayed in the corridor section view. By
default, layers for objects that are not referenced by the corridor are not visible.
6 Under Grid Settings, set the visibility and separation of grid lines, the color of grid lines, and the visibility
and color of a center axis for the grid.
7 Under Grid Text Settings, set the style, color and size of text, along with the visibility of center axis
annotation.

Quick Reference
Ribbon
Corridor tab ➤ Modify panel ➤ Corridor Section Editor
Menu
Corridors menu ➤ View/Edit Corridor Section
Command Line
ViewEditCorridorSection
Dialog Box
Corridor Section Editor Ribbon (page 2042)
View/Edit Corridor Section Options (page 2065)

Tracking Corridor Sections at Stations
Use the Station Tracker and Corridor Section Editor to track the location of corridor sections in plan and
profile view.
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Station Tracker displays (in both plan and profile view) the location of the station from which the current
corridor section view is sampled. Station Tracker can be used only with multiple viewports, where one
viewport contains the corridor section view and one or two others contain plan and profile views.
To track corridor section views in plan and profile views
1 Change the ViewEditCorridorSection command settings:
■

In the Corridor settings, expand the Commands folder.

■

Right-click ViewEditCorridorSection and click Edit Command Settings.

■

In the Edit Command Settings - ViewEditCorridorSection dialog box, expand the View/Edit Options
property group.

■

Set the Turn Off Unassociated Layers setting to No.

■

Set the Station Tracker in Multiple Viewports setting to Yes.

■

Click OK.

2 Set the view to multiple viewports:
■

Click View tab ➤ Viewports panel ➤ New

■

In the Viewports dialog box, New Viewports tab, Standard Viewports list, select Three: Above.

■

Click OK.

.

3 Set the corridor plan view in one of the smaller viewports, and the profile view in the other smaller
viewport.
4 Select a corridor in the top viewport.
5 Click Corridor tab ➤ Modify panel ➤ Corridor Section Editor

.

6 In the Section Editor tab, Station Selection panel, Select a Station list, select a station.
That station’s corridor section view will be displayed in the top viewport. Station Tracker displays the
station location in both plan and profile views.

Quick Reference
Ribbon
Corridor tab ➤ Modify panel ➤ Corridor Section Editor
View tab ➤ Viewports panel ➤ New
Menu
Corridors menu ➤ View/Edit Corridor Section
View menu ➤ Viewports ➤ Named Viewports
Command Line
ViewEditCorridorSection
+vports 0
Dialog Box
Corridor Section Editor Ribbon (page 2042)
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Editing Corridor Sections
You can use the Corridor Section Editor to override corridor and assembly parameters and apply the overrides
to a station or range of stations.
Edit corridor and assembly parameters as required, using the following methods:
■

Edit the assembly numerically by editing the subassembly parameters.

■

Edit the assembly manually by adding links and points to the subassembly part geometry.

■

Resize assembly parameters by grip editing the subassembly part geometry.

■

Insert or remove subassemblies from a corridor section.

Overriding assemblies may require you to edit the way points, links, and shapes are represented in the
corridor as feature codes. Use the Edit User Defined Codes command to change or delete codes as required.
NOTE If you have edited a subassembly by either adding or deleting a point, adding or deleting a link, or editing
the subassembly geometry using grips, you cannot edit the values of the changed parameters in the Corridor
Section Editor.
To override subassembly parameters by editing their values
1 Select a corridor in the drawing.
2 Click Corridor tab ➤ Modify panel ➤ Corridor Section Editor

.

3 To view detailed information about the assembly and subassemblies used by the region in the Corridor
Parameters vista: On the Section Editor tab, Corridor Edit Tools panel, click

Parameter Editor.

4 Click the station drop-down list and select the station for which you initially want to override one or
more assembly parameters.
5 In the Corridor Parameters vista, click the Value field for the parameter that you want to override. Enter
a new value. When an override is applied, the Override column displays True. To remove an individual
override, clear the check box next to the subassembly or parameter. To remove all overrides in an
assembly, clear the checkbox in the Override column next to the assembly name.
6 To apply the override to a range of stations: On the Section Editor tab, Corridor Edit Tools panel, click
Apply to a Station Range.
7 In the Apply To A Range Of Stations dialog box, enter both the start station and the end station. Click
OK.
8 To view only the stations that have assembly overrides applied to them: On the Station Selection panel,
click

Show Overridden Stations. Only stations with assembly overrides are displayed in the list.

9 To view all stations, click

Show Overridden Stations again.

10 If the corridor is not set to rebuild automatically, click

Update Corridor to rebuild the corridor.

Corridor surfaces and any other data that is derived from the corridor are updated using the overrides.
To override subassembly parameters by adding or deleting points
1 Select a corridor in the drawing.
2 Click Corridor tab ➤ Modify panel ➤ Corridor Section Editor

.
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3 To view detailed information about the assembly and subassemblies used by the region in the Corridor
Parameters vista: On the Section Editor tab, Corridor Edit Tools panel, click

Parameter Editor.

4 In the Section Editor tab, Station Selection panel, Select a Station list, select the station to which you
want to add a point.
5 To add a point: On the Section Editor tab, Corridor Edit Tools drop-down, click

Add Point.

6 In the drawing window, select the link you want to break by adding a point.
7 Enter a point code value for the new point.
The new vertex is added at the midpoint of the link. The points at the end of the links retain the codes
from the original link.
In the Corridor Parameters vista, the Override column displays
8 To delete a point: On the Corridor Edit Tools drop-down click

True.
Delete Point.

9 In the drawing window, click the point you want to delete.
The point and all links connected to it are deleted.
10 To view only the stations that have assembly overrides applied to them: On the Station Selection panel,
click

Show Overridden Stations. Only stations with assembly overrides are displayed in the list.

11 To view all stations, click

Show Overridden Stations again.

12 If the corridor is not set to rebuild automatically, on the Corridor Edit Tools panel, click
Update
Corridor to rebuild the corridor. Corridor surfaces and any other data that is derived from the corridor
are updated using the overrides.
To override subassembly parameters by adding or deleting links
NOTE You can add links only to individual subassemblies. You cannot add links that connect two subassemblies.
1 Select a corridor in the drawing.
2 Click Corridor tab ➤ Modify panel ➤ Corridor Section Editor

.

3 In the Section Editor tab, Station Selection panel, Select a Station list, select the station to which you
want to add a link.
4 To add a link: On the Corridor Edit Tools drop-down, click

Add Link.

5 In the drawing window, select the first point of the two points you want to connect.
6 Select the second point.
The link is added.
7 To delete a link: On the Corridor Edit Tools drop-down, click

Delete Link.

8 In the drawing window, click the link you want to delete.
The link is deleted. The points that were connected to create the link are not deleted.
9 To view only the stations that have assembly overrides applied to them: On the Station Selection panel,
click

Show Overridden Stations. Only stations with assembly overrides are displayed in the list.
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10 To view all stations, click

Show Overridden Stations again.

11 If the corridor is not set to rebuild automatically, on the Corridor Edit Tools panel, click
Update
Corridor to rebuild the corridor. Corridor surfaces and any other data that is derived from the corridor
are updated using the overrides.
To override subassembly parameters by inserting or deleting subassemblies
1 Select a corridor in the drawing.
2 Click Corridor tab ➤ Modify panel ➤ Corridor Section Editor

.

3 To view detailed information about the assembly and subassemblies used by the region in the Corridor
Parameters vista: On the Section Editor tab, Corridor Edit Tools panel, click

Parameter Editor.

4 In the Section Editor tab, Station Selection panel, Select a Station list, select the station to which you
want to add subassemblies.
5 Select a subassembly from a tool palette in the Tool Palettes window.
6 Press Enter to create a detached subassembly.
7 To add the subassembly to the assembly: On the Corridor Edit Tools drop-down, click
Subassembly.

Add

8 In the drawing window, select the subassembly to which you want to attach the new subassembly.
9 Optionally, if you are inserting the subassembly between two existing subassemblies, select the second
assembly.
10 To delete a subassembly: On the Corridor Edit Tools drop-down, click

Delete Subassembly.

11 In the drawing window, click the subassembly you want to delete.
The subassembly is deleted. If the deleted subassembly connected two subassemblies, they are attached
to each other at the attachment point of the deleted subassembly.
12 To view only the stations that have assembly overrides applied to them: On the Station Selection panel,
click

Show Overridden Stations. Only stations with assembly overrides are displayed in the list.

13 To view all stations, click

Show Overridden Stations again.

14 If the corridor is not set to rebuild automatically, on the Corridor Edit Tools panel, click
Update
Corridor to rebuild the corridor. Corridor surfaces and any other data that is derived from the corridor
are updated using the overrides.
NOTE You cannot undo a subassembly deletion. To rebuild the original design, insert a new instance of the
subassembly or repeat the assembly selection for the region.
To override subassembly parameters by editing a user-defined code
1 Select a corridor in the drawing.
2 Click Corridor tab ➤ Modify panel ➤ Corridor Section Editor

.

3 In the Section Editor tab, Station Selection panel, Select a Station list, select the station for which you
want to edit feature codes.
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4 To edit a feature code: On the Corridor Edit Tools drop-down, click

Edit User Defined Codes.

5 In the corridor section view, select a point marker, link, or shape.
6 Do one of the following:
■

Enter a new code for the feature.

■

Enter d (delete), and then click Yes to delete the user-defined codes associated with the feature.

NOTE You can only delete user-defined point, link, and shape codes. You cannot delete codes added by the
subassembly macro using the Edit User Defined Code command.
7 If the corridor is not set to rebuild automatically, on the Corridor Edit Tools panel, click
Update
Corridor to rebuild the corridor. Corridor surfaces and any other data that is derived from the corridor
are updated using the overrides.
To override subassembly parameters by grip editing
1 Select a corridor in the drawing.
2 Click Corridor tab ➤ Modify panel ➤ Corridor Section Editor

.

3 In the Section Editor tab, Station Selection panel, Select a Station list, select the station at which you
want to edit.
4 Ctrl+click a subassembly in the corridor section view.
Grip behavior depends on the type of grip:
Grip Type

Behavior

Square grip at end of link

Moves the end of one of more links at this point to any
point in the grid. When active, the following values are
labeled: offset from baseline or controlling offset, elevation,
grade, and slope.To maintain the elevation value while
editing, keep the point near its original vertical location.
To maintain the offset value, keep the point near the original horizontal location.

Triangular grip at end of
link

Moves the endpoint of a link while preserving the grade.
When active, the following values are labeled: offset and
length of link, elevation difference from original location.

Square grip at link midpoint

Moves the link to a parallel position above or below the
current position. When active, the following values are
labeled: offset from baseline or controlling offset, elevation,
elevation difference from original location.

5 Identify the grip you want to move, and then Ctrl+click it once to make it active.
The grip changes color from blue to red, and the link property labels are displayed.
6 To edit a value in one of the grip labels, press Ctrl + Tab until the value you want to edit is active. Enter
a new value.
7 Drag the grip to its new location, and click to place it there. The grip follows your mouse pointer, within
the limits imposed by the grip type.
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Quick Reference
Ribbon
Corridor tab ➤ Modify panel ➤ Corridor Section Editor
Menu
Corridors menu ➤ View/Edit Corridor Section
Command Line
ViewEditCorridorSection
Dialog Boxes
Corridor Section Editor Ribbon (page 2042)
Corridor Parameter Editor Vista (page 2033)

Adding A Corridor Section
You can manually add stations in a corridor on any baseline and any region using the Add a Corridor Section
command.
To add a corridor section using the Add A Section command
1 Select a corridor in the drawing.
2 Click Corridor tab ➤ Modify Corridor Sections panel ➤ Add A Section

.

3 If the corridor has multiple baselines, you are prompted to select a baseline.
4 Select a manual assembly insertion station, and press Enter to add the section.

Quick Reference
Ribbon
Corridor tab ➤ Modify Corridor Sections panel ➤ Add A Section
Command Line
AddCorrSections

Deleting a Corridor Section
You can manually delete stations in a corridor on any baseline and any region using the Delete a Corridor
Section command.
To delete a corridor section using the Delete A Section command
1 Select a corridor in the drawing.
2 Click Corridor tab ➤ Modify Corridor Sections panel ➤ Delete A Section

.

3 If the corridor has multiple baselines, you are prompted to select a baseline.
4 Select a manual assembly insertion station, and press Enter to delete the section.
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Quick Reference
Ribbon
Corridor tab ➤ Modify Corridor Sections panel ➤ Delete A Section
Command Line
DeleteCorrSections

Exporting Corridor Data
Use the corridor export utilities to export corridor data.
You can export alignments along known point codes/feature lines, feature lines for grading (using the grading
feature), corridor surfaces as surface objects, and COGO points at stations on a baseline where assemblies
are inserted.

Exporting Corridor Feature Lines
Export feature lines as polylines, grading feature lines, alignments, and profiles.
NOTE Exported feature lines are not connected to the corridor and are not updated if the corridor changes.

Exporting Feature Lines as Polylines
Export polylines from corridor feature lines.
Use this option if you want to use the corridor geometry for another purpose, such as for drafting or for
surface data.
To export corridor feature lines as polylines
1 Click Home tab ➤ Create Design panel

Create Polyline From Corridor

.

2 In the drawing, click the corridor feature line. If you make an ambiguous selection, the Select A Feature
Line dialog box is displayed. Select a feature line from the list.
The feature line is exported as a polyline. The feature line’s point code is displayed at the command
line.

Quick Reference
Ribbon
Home tab ➤ Create Design panel
Command Line
CreatePolylineFromCorrdor
Dialog Box
Select a Feature Line (page 2061)
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Create Polyline From Corridor

Exporting Feature Lines as Grading Feature Lines
Export corridor feature lines as grading feature lines.
Use this option to create a feature line that grading commands recognize and use as a grading baseline or
target.
A grading feature line represents an object in the drawing from which to grade. For more information, see
Creating Feature Lines (page 808).
To export corridor feature lines as a grading feature line
1 Click Home tab ➤ Create Design panel ➤ Feature Line drop-down ➤ Create Feature Line From Corridor
.
You can also access this command by selecting a corridor in the drawing, and clicking Corridors tab
➤ Launch Pad panel ➤ Feature Lines From Corridor.
2 In the drawing, click the corridor feature line you want to export. If you make an ambiguous selection,
the Select A Feature Line dialog box is displayed. Select a feature line from the list.
3 In the Create Feature Line From Corridor dialog box:
■

Select the Name check box and enter a name for the feature line.

■

Click the Create Dynamic Link To The Corridor check box to maintain a link between the feature
line and the corridor.

4 If more than one site exists in the drawing, the Pick A Site dialog box is displayed. Select a site.
5 The feature line is exported as a grading feature line. For information about grading feature lines, see
Creating Feature Lines (page 808).
NOTE Grading feature line objects are not named components in AutoCAD Civil 3D. The style for the feature
line is derived from the corridor object properties for the point code from which the feature line was derived.
For information about changing the style for the grading feature line, see Using Grading Styles (page 802).

Quick Reference
Ribbon
Home tab ➤ Create Design panel ➤ Feature Line drop-down ➤ Create Feature Line From Corridor
Menu
Corridors menu ➤ Utilities ➤ Create Grading Feature Line From Corridor
Command Line
FeatureLinesFromCorridor
Dialog Box
Select a Feature Line (page 2061)

Exporting Corridor Feature Lines as Alignments
Export corridor feature lines as alignments.
Use this command if you want to apply an alignment style or label set, or to view a specific feature line in
profile view.
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To export feature lines as alignments
1 Click Home tab ➤ Create Design panel ➤ Alignment drop-down ➤ Create Alignment From Corridor
.
2 In the drawing, select a corridor feature line to export. If you make an ambiguous selection, the Select
A Feature Line dialog box is displayed. Select a feature line from the list.
3 Enter the required data in the Create Alignment - From Polyline dialog box. For more information, see
Creating an Alignment from Graphic Entities (page 952).
4 Select another feature line to export as an alignment or press Enter to end the command.
5 The feature line(s) is exported as an alignment and can be viewed and edited in the Toolspace Prospector
tree. For information, see Editing Alignments (page 1060).

Quick Reference
Ribbon
Home tab ➤ Create Design panel ➤ Alignment drop-down ➤ Create Alignment From Corridor
Menu
Corridors menu ➤ Utilities ➤ Create Alignment From Corridor
Command Line
CreateAlignFromCorridor
Dialog Box
Create Alignment - From Polyline (page 1975)

Exporting Corridor Feature Lines as Profiles
Export corridor feature lines as profiles.
Profiles that are exported from corridor feature lines are listed in Prospector under the baseline alignment
from which the original corridor feature line is derived.
To export feature lines as profiles
1 Click Home tab ➤ Create Design panel ➤ Profile drop-down ➤ Create Profile From Corridor

.

2 In the drawing, select the corridor feature line to export. If you make an ambiguous selection, the Select
A Feature Line dialog box is displayed. Select a feature line from the list.
3 In the Create Profile - Draw New dialog box, enter the required data. For more information, see Creating
Layout Profiles (page 1143).
The message “<profile name> is created” is displayed at the command line. If you have any profile views
in the current drawing for the baseline alignment, the new corridor profile is added to it and displayed
with the selected style.
4 Select another feature line to export as a profile or press Enter to end the command.
5 The feature line(s) is exported as a profile and can be viewed and edited in the Toolspace Prospector
tree. For information, see Profile Properties (page 1119).
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Quick Reference
Ribbon
Home tab ➤ Create Design panel ➤ Profile drop-down ➤ Create Profile From Corridor
Menu
Corridors menu ➤ Utilities ➤ Create Profile From Corridor
Command Line
CreateProfileFromCorridor
Dialog Box
Create Profile - Draw New (page 2394)

Exporting Corridor Points as COGO Points
Export corridor points as COGO points.
You can either export all points from a selected corridor or constrain the selection based on station ranges
or point code types.
COGO points are basic building blocks in AutoCAD Civil 3D. Use points in land development projects to
identify existing ground locations and design elements.
For more information about COGO points, see Understanding Points (page 435).
To export corridor points as COGO points
1 Click Corridor tab ➤ Launch Pad panel

Points From Corridor

.

2 In the drawing, click the corridor from which you want to export the points.
3 In the Export COGO Points (page 2048) dialog box, click For Entire Corridor Range to export all points
or click For User Specified Range to select a range of points.
4 Optionally, if you selected For User Specified Range, click the Select A Baseline list to select the baseline
or click

and select an alignment in the drawing.

5 If you selected For User Specified Range, enter the start and end range in the Alignment Start and
Alignment End fields, or click

and click the locations in the drawing.

6 In the New Point Group Name field, enter the name for the point group that will contain all the extracted
points. For information about point groups, see Point Groups (page 553).
7 Optionally, select the points you want to export, based on their point codes, by selecting or clearing
the point code’s Select field in the Select Point Codes To Create table. For information about point
codes, see Understanding Point, Link, and Shape Codes (page 1568).
8 Click OK.
The point group is created and is displayed in the Point Groups collection in the Toolspace Prospector
tree. The points are displayed in the drawing using the default Point Group display settings. They are
labeled with their point code names.
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Quick Reference
Ribbon
Corridor tab ➤ Launch Pad panel

Points From Corridor

Menu
Corridors menu ➤ Utilities ➤ Create COGO Points From Corridor
Command Line
CreatePointsFromCorridor
Dialog Box
Create COGO Points (page 2048)

Exporting Corridor Surfaces
You can export corridor surfaces as detached (DTM) surface objects.
You export corridor surfaces, which are components of the corridor object, as AutoCAD Civil 3D surface
objects. For more information, see Surfaces (page 645).
The exported surface comprises breaklines based on how the corridor surface was defined (links or feature
lines).
For information about corridor surfaces, see Creating and Editing Corridor Surfaces (page 1506).
NOTE Exported surfaces are no longer part of the corridor. They will not react to changes to the underlying
corridor object.
To export corridor surfaces as detached (DTM) surfaces
1 Click Home tab ➤ Create Ground Data panel ➤ Surfaces drop-down ➤ Create Surface From Corridor
.
2 In the drawing, click the corridor from which you want to export the surface.
The Export Corridor Surfaces (page 2051) dialog box is displayed. View all the available corridor surfaces
for the selected corridor.
3 Clear the Select field for a surface you do not want to export.
4 Optionally, to set the style for an exported surface, click the Surface Style field. Select a new style in the
Pick Corridor Surface Style dialog box.
5 Optionally, to set the render material for an exported surface, click the Render Material field. Select a
new render material in the Select Render Material dialog box.
6 Click OK.
The surface(s) is created and available in the Surfaces collection in the Toolspace Prospector tree. The
surfaces are displayed in accordance to the surface style set in the Export Corridor Surfaces dialog box.

Quick Reference
Ribbon
Home tab ➤ Create Ground Data panel ➤ Surfaces drop-down ➤ Create Surface From Corridor
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Menu
Corridors menu ➤ Utilities ➤ Create Detached Surfaces From Corridor
Command Line
CorridorExtractSurfaces
Dialog Box
Create Corridor Surfaces (page 2051)

Rendering Corridor Models
Render corridor data using the AutoCAD Render command.
For more information about rendering AutoCAD Civil 3D objects and data, see Rendering Objects (page 1764).
To render corridor data
1 Create a corridor model (page 1475) for an alignment.
2 Optionally, create feature line styles (page 1505) with different colors and apply them to the feature lines
in the corridor model. For example, create a blue Edge Of Pavement style to distinguish it from a red
Shoulder style.
3 Use the Feature Lines tab (page 2037) of the Corridor Properties dialog box to assign the feature line styles
to the feature lines. This step helps distinguish the feature lines for easier selection when you are creating
the corridor boundaries. A corridor boundary specifies an area of the corridor to render using a specified
render material.
4 Use the Surfaces tab (page 2038) of the Corridor Properties dialog box to create a corridor surface. For
example, create a surface using the Links data type and the Top code. Assign a simple surface style that
does not have triangles visible, such as border and contours only.
NOTE You can more easily create the corridor boundaries if the triangles are not visible.
5 Select the Render Material for the corridor surface.
6 Optionally, use the Boundaries tab (page 2039) of the Corridor Properties dialog box to create corridor
boundaries that correspond to the areas on the corridor that you want to render with a specific material.
You create the boundaries by selecting corridor feature lines that form the boundaries of the area. You
should select the bottom end of one feature line followed by the top end of its pair.
For example, select the bottom outside edge of the lane followed by the top outside edge of the lane
to create a boundary that encompasses both lanes:

7 Use the AutoCAD Render command to render the corridor. For more information, see Rendering Objects
(page 1764).
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Using Visibility Check Tools on Corridors
You can use the following visibility check features to visually analyze corridor models.
■

Drive - Use this tool to simulate driving through a 3D model by following a corridor, alignment, feature
line, or 3D polyline.

■

Point to Point Line of Sight - Use this tool to perform a local sight distance check, for example, at a high
risk location in an intersection.

■

Sight Distance Along a Corridor - Use this tool to calculate sight distances along a roadway, and to ensure
that the design meets the required minimum sight distances.

■

Zone of Visual Influence - Use this tool when you need to determine if a vertical object, such as a traffic
light or a tower, can be seen from within a certain radius. You can also use this tool to determine how
far a driver can see from a stop line at an intersection.

For more information on using these tools, see Visibility Checks (page 1842) in the Utilities chapter.

Corridor Command Reference
You can use these commands to quickly access corridor functionality.
The following table lists the corridor-related AutoCAD Civil 3D commands and briefly describes their
functionality.
Command

Description

AddCorrRegion

Adds corridor regions (page 1489)

CopyCorrRegions

Copies a corridor region to create one or more
new corridor regions (page 1495)

CorridorExtractSurfaces

Exports a (DTM) surface object from a corridor
surface (page 1532)

CreateAlignFromCorridor

Creates an alignment from a corridor feature line
(page 1529)

CreateBoundaryFromCorridor

Creates a boundary at the outer edge of corridor
(page 1513)

CreateCorridor

Creates a corridor (page 1476)

CreatePointsFromCorrdor

Exports corridor points as COGO points (page
1531)

CreatePolylineFromCorrdor

Exports a corridor feature line as a polyline (page
1528)

CreateProfileFromCorridor

Creates a profile from a corridor feature line (page
1530)

CreateSimpleCorridor

Creates a basic corridor (page 1475)

DefineCorridorSurfaces

Defines a surface object for the selected corridor
(page 1509)
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Command

Description

DeleteCorrRegions

Deletes a corridor region (page 1497)

EditCorrRegionFreq

Edits the station frequency of edits corridor region
targets (page 1492)

EditCorrRegionProps

Edits corridor region properties (page 1498)

EditCorrRegionTargets

Adds or edits corridor region targets (page 1487)

FeatureLinesFromCorridor

Creates a grading feature line from a corridor
(page 1529)

HideCorridorRegions

Hides a corridor region (page 1496)

IsolateCorridorRegion

Turns off the visibility of all corridor regions except
the selected region (page 1496)

MatchCorrRegionParams

Copies the parameters a selected source corridor
region to one or more destination regions (page
1493)

MergeCorrRegions

Merges two corridor regions into one region (page
1494)

ShowAllCorridorRegions

Restores the visibility of all corridor region (page
1496)

SplitCorrRegion

Splits a corridor region into two or more regions
(page 1488)

UpdateCorridor

Rebuilds the selected corridor (page 1615)

ViewEditCorridorSection

Displays corridor sections (stations) (page 1519)
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Assemblies and
Subassemblies

33

Assembly and subassembly objects create the primary structure of an AutoCAD Civil 3D corridor model.

Understanding Assemblies
Assembly objects contain and manage a collection of subassemblies that are used to form the basic structure
of a 3D corridor model.
Adding one or more subassembly objects, such as travel lanes, curbs, and side slopes, to an assembly baseline
creates an assembly object. This forms the design for a corridor section. The subassemblies are provided in
a set of catalogs.

Roadway assembly (left), with subassemblies shown in a tool palette (right)

NOTE There is no limit to the number of slope segments a user may define in an AutoCAD Civil 3D assembly.
The following illustration shows a simple assembly object that represents one side (lane) of a two-lane road.
Subassembly objects named BasicLane and BasicCurbAndGutter have been added to a baseline alignment,
forming a single travel lane with a curb and gutter.

1537

Each subassembly has a defined cross-section, and some subassemblies automatically adapt to their location.
For example, the slope of a road lane changes as superelevation is applied, and a side slope automatically
creates either a cut or fill slope, depending on the relative elevation of the existing surface.
The dimensions of a subassembly, such as the width of a lane or the height of a curb are stored as properties.
You can also create custom subassemblies from AutoCAD polylines. In this case, you must also specify the
subassembly behavior within an assembly and in the process of corridor creation. You can define custom
subassemblies and their behavior using .NET scripts, then use the AutoCAD Civil 3D COM application
programming interface (API) to link these to the main application.
It is also possible to create more advanced assemblies referred to as conditional assemblies. A conditional
assembly contains one or more conditional subassemblies, which apply subsequent subassemblies when
specified conditions at a given station are met. For more information, see Creating Assemblies with
Conditional Subassemblies (page 1545).
After creating assembly objects, you can proceed with other corridor modeling tasks, such as creating corridor
objects, feature lines, and section views. For more information, see Corridors (page 1471).
Review the assemblies and corridors tutorials for step-by-step instructions on how to create a variety of
assemblies for corridor model.

The Assembly Object
Use an assembly object to create the structure for a corridor section.
An assembly is a AutoCAD Civil 3D drawing object (AECCAssembly) that manages a collection of subassembly
objects. Together, assemblies and subassemblies function as the basic building blocks of a roadway or other
alignment-based design. An assembly object must be applied along an alignment to form a corridor, and it
can reference one or more offsets.
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An assembly object, like its corridor and subassembly counterparts, can adapt to conditions such as
superelevation and cut or fill requirements.
The following components comprise an assembly object:
■

Insertion Point. This is the initial point in the drawing that is selected to create the assembly object. It
corresponds to the centerline of the eventual corridor object. This is also known as the ground reference
point and typically follows an alignment as well as a design profile (vertical alignment).

■

Baseline. The baseline of an assembly typically displays as a visual aid (marker) representing a vertical
axis at the assembly baseline point. If you want to attach a subassembly to the baseline point, you can
do so by selecting the baseline marker. This method of attaching subassemblies to an assembly is sometimes
easier than selecting the baseline point, especially when there are already one or more subassemblies
attached at that point.

■

Baseline Point. This is a point on the assembly typically representing the start point of the first subassembly
that is attached to the assembly near the controlling alignment. By default, the baseline point coincides
with the insertion point and therefore follows the centerline alignment and profile. If you want to begin
sectional elements oriented away (horizontally and vertically) from the centerline, do so by moving this
baseline point away from the assembly insertion point.

■

Offset Line. The offset line is a typically vertical line visually representing a vertical axis at the offset
point. If you want to attach a subassembly at an offset point, you can do so by selecting the offset line
marker instead of selecting the offset point. This method of attaching subassemblies to an assembly offset
point is sometimes easier than selecting the offset point, especially when there are already one or more
subassemblies attached at that point.

■

Offset Point. This is a point on the assembly representing the ground reference point along an offset
alignment for the eventual corridor object. Subassemblies attached at this point follow an offset alignment
and its designed profile. For example, in the case of a highway with service roads on one or both sides,
the service road centerlines are represented by offset points. There is always just one baseline point on
an assembly, and there can be zero or many offset points on an assembly. Offset points can be added to
or deleted from an assembly at any time.

To complete the definition of an assembly object, you typically add multiple subassembly objects, such as
lanes, curbs, or ditches, along an alignment. Each subassembly can connect to the assembly baseline point,
any assembly offset point, or to another subassembly already associated with the assembly. A subassembly
can also be attached to these points with a relative offset and/or elevation from the point.
A subassembly definition references point, link, and shape codes. Points are the vertices of the subassembly,
and they can be attachment points for adjacent assemblies. Links are the line segments or curves between
the points. Shapes are two-dimensional polygons that represent the cross-sectional shape of the subassembly.
The following figure shows a coding diagram for a Basic Curb and Gutter subassembly:
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For more information, see Understanding Subassemblies (page 1555).

Assembly Settings
Use assembly settings to control the behavior of assembly-related commands.
Work with assembly settings the same way you work with other object settings in AutoCAD Civil 3D, using
the Toolspace Settings tree. You can control assembly-related settings at both the object collection (feature)
level and at the command level. For information about how the levels of settings work together, see Specifying
Drawing Settings (page 79).
Right-click the Settings tree Assemblies collection to establish defaults for all assembly-specific settings and
to override the drawing ambient settings for all assembly-related commands. Use the Commands collection
in the Settings tree Assembly collection to override assembly-specific settings or drawing ambient settings
for a specific command.
NOTE Overrides to the drawing ambient settings at the Assemblies collection level and the Assembly Commands
collection level affect only the specified level. The drawing level settings are not affected. For more information,
see Understanding Settings (page 77).

Assembly Properties
Specify administrative, and codes structural information using assembly properties.
Assembly properties specify all the information associated with an assembly, including its style, subassemblies,
and link, point, and shape codes.
Display the properties of an assembly:
■

Right-click an assemblies collection in the Prospector tree and click Properties.

■

Select an assembly in the drawing, right-click and click Assembly Properties.

For more information, see Assembly Properties Dialog Box (page 1995) and The Toolspace Item View (page
99).

Assemblies Collection (Prospector Tab)
Use the Assemblies collection in the Prospector tree to access the assemblies in a drawing. As assemblies are
created, they are displayed in the Assemblies collection.
Right-click the Assemblies collection to do the following:
■

Turn on or off the assembly preview (page 1552).

■

Refresh the Assemblies collection in the Prospector tree.
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If an assembly has been added to the current drawing, you can expand the Assemblies collection to view
the names of the assemblies in the Prospector list view. For more information, see The Toolspace Item View
(page 99).
Each assembly in a site is displayed as a named object under the Assemblies node of the site. Right-click an
assembly name to do the following:
■

Display assembly properties (page 1540).

■

Delete an assembly (page 1549) in the drawing.

■

Zoom or pan to an assembly in the drawing.

■

Refresh the Prospector tree.

Assembly Collection (Settings Tab)
Use the Assembly collection in the Settings tree to manage assembly settings, styles, and command settings.
Right-click the Assembly collection to do the following:
■

Edit assembly feature settings (page 1540).

■

Refresh the Settings tree.

Expand the Assembly collection to display and edit the styles and command settings available for assemblies.

Creating Assemblies
You can create an assembly from the ribbon, from a tool palette, from a catalog, or from an assembly drawing.
You can create a basic assembly, without an offset, or you can create an assembly with an offset. When you
create an assembly without an offset, the subassemblies included in the assembly are controlled by a single
baseline. When you add an offset to an assembly, the subassemblies included in the assembly are controlled
by the baseline and by the offset alignment.
It is also possible to specify different subassemblies to apply depending on the conditions that exist at a
given corridor station. This type of assembly is referred to as a conditional assembly. For more information,
see Creating Assemblies with Conditional Subassemblies (page 1545).

Creating an Assembly
Use the Create Assembly command to define the baseline of an assembly, and start adding subassemblies
to the assembly.
Define the assembly basepoint (1), then add subassemblies (2,3,4) to the baseline to build the assembly (5).
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When designing an assembly that contains a left side and a right side, typically you add the subassemblies
to the one side, and then add subassemblies to the other side.
The following options are available from both the Assembly and Subassembly tabs (when you click on an
assembly or subassembly in the drawing):
Copy To Assembly lets you copy subassemblies from one assembly to another, or to another location
(marker point) on the same assembly.
Move To Assembly lets you move subassemblies from one assembly to another, or to another location
(marker point) on the same assembly.
Mirror Subassemblies is available on subassemblies that have a Side parameter. You can use it to quickly
copy subassemblies from one side of an assembly to the other.
While creating an assembly, you can first add the right-side (right lane) subassemblies, then use Mirror
Subassemblies to copy the right-side subassemblies to the left-side (left lane) of the assembly. Subassembly
parameter values are automatically set to appropriate values.
Alternately, you can enter CopySubassemblyTo, MoveSubassemblyTo, or MirrorSubassembly on the Command
line, to invoke the commands.
NOTE Corridor target settings (page 1481) of a copied, moved or mirrored subassembly are not preserved. You will
have to set any targets (page 1482) of the subassembly.
To create an assembly
1 Click Home tab ➤ Create Design panel ➤ Assembly drop-down ➤ Create Assembly

.

2 In the Create Assembly dialog box (page 2000), in the Name field, enter a name for the assembly.
NOTE To name the assembly, select its default name and enter a new name, or you can use the Name
Template. For more information, see Name Template Dialog Box (page 2022).
3 For Description, enter an optional description of the assembly.
4 For Assembly Style and Code Set Style, either accept the default style, select another style, or create a
new style. For more information, see Assembly Styles and Display (page 1550) and Using Code Set Styles
(page 1577).
5 Click

to select a layer. For more information about layers, see Object Layer Dialog Box (page 2221).

NOTE If you do not select a layer, the assembly is placed on the default layer.
6 Click OK.
7 To insert the assembly into the drawing, click a baseline location in the drawing.
The assembly name is displayed under the Assemblies collection in the Prospector tree. A vertical line
with a circular marker in the middle is inserted into the drawing. This is the assembly baseline location
point, where you will attach one or more subassemblies.
8 Select a subassembly from a tool palette in the Tooltip Palette vista (page 1544), or from a tool catalog
through the Content Browser.
NOTE Not all subassemblies in AutoCAD Civil 3D are located on a tool palette by default. All subassemblies
are stored in the Content Browser, and you can add subassemblies (page 122)that you use frequently to a
tool palette for easy access.
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9 To attach the subassembly to the assembly baseline location, select the baseline point or the baseline
marker. Typically, the baseline marker displays as a vertical line.
The subassembly name is displayed in the Subassemblies collection in the Prospector tree. A subassembly
group (page 1562) is added to the assembly.
10 To add subassemblies to the subassembly just added, do any of the following:
■

Select a subassembly in a tool palette, or in a tool catalog, and then select an appropriate marker
point on the previously added subassembly.

■

Select a subassembly that is already attached to an assembly and click

Copy To Assembly,

Move To Assembly, or
Mirror Subassemblies on the Modify Subassembly panel of the Subassembly
tab. You can also select multiple subassemblies using these features.
When you add a set of subassemblies sequentially to a baseline (for example, lane, curb, sideslope, then
ditch), they are all added to the same subassembly group. The next time you select the assembly baseline,
a new group is created and subsequent subassemblies added belong to the new subassembly group.
For information about editing and managing assemblies, see Managing and Editing Assemblies (page 1548).

Quick Reference
Ribbon
Home tab ➤ Create Design panel ➤ Assembly drop-down ➤ Create Assembly
Menu
Corridors menu ➤ Create Assembly
Command Line
CreateAssembly
Dialog Box
Create Assembly (page 2000)

Creating an Assembly Offset
Specify a controlling offset within an assembly.
An assembly with an offset is useful for a corridor section that has more than one definitive path, such as
a highway with a service road on one or both sides. Create the offset (3) by placing it a distance (2) from
the existing assembly baseline (1).
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You then add subassemblies to the offset using the Subassembly Tool Palette.
The service road centerline(s) can be described by a specified offset line and offset point. The offset line is a
vertical line that visually represents a secondary location that will follow an offset alignment when creating
a corridor, and that subassemblies can attach to.
When assembly offsets are created, they are displayed on the Construction tab of the Assembly Properties
dialog box. If desired, you can rename an offset on this tab by right-clicking the offset in the list, and selecting
Rename.
You can also add or remove an offset, from the Assembly contextual menu, or the Assembly right-click
menu. For more information, see Adding an Assembly Offset (page 1550) and Removing an Assembly Offset
(page 1550)
To create an assembly offset
1 Click Home tab ➤ Create Design panel ➤ Assembly drop-down ➤ Add Assembly Offset
2 Do one of the following:
■

Click an assembly in the drawing.

■

Press Enter to select an assembly from a list.

3 Click an offset location in the drawing.
The offset location is displayed in the drawing.
For information, see Managing and Editing Assemblies (page 1548).

Quick Reference
Ribbon
Home tab ➤ Create Design panel ➤ Assembly drop-down ➤ Add Assembly Offset
Command Line
AddAssemblyOffset

Creating an Assembly from a Tool Palette
You can create an assembly object by adding it to your drawing from a tool palette.
Once selected in the tool palette, you can add the assembly to your drawing.
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.

To create an assembly from a tool palette
1 To display the Tool Palettes window:
Click Home tab ➤ Palettes panel ➤

.

2 Open the tool palette containing the desired assembly.
3 On the tool palette, click the assembly, and then click a location in the drawing. Press Enter to end the
command. You can also use drag and drop.
The assembly object is added to the drawing. The assembly name is displayed under the Assemblies
collection in the Prospector tree.

Quick Reference
Ribbon
Click Home tab ➤ Palettes panel ➤

.

Command Line
ToolPalettes

Creating Assemblies with Conditional Subassemblies
You can create an assembly that contains conditional subassemblies.
An assembly that contains one or more conditional subassemblies can be referred to as a conditional assembly.
When you have a conditional assembly in your drawing, specified subassemblies are automatically applied
at stations when conditions exist.
For example, a conditional corridor assembly could contain two ConditionalCutOrFill subassemblies. The
first ConditionalCutOrFill subassembly can be configured to apply a ditch subassembly when a cut condition
exists. The second ConditionalCutOrFill subassembly can be configured to apply a guardrail, shoulder, and
daylight to surface when a fill condition exists. Using conditional subassemblies enables you to reduce the
number of corridor regions and assemblies that you have to maintain.
The following illustration shows an example of an assembly that contains a ConditionalCutOrFill subassembly
that is configured to apply a ditch in cut situations, and another ConditionalCutOrFill subassembly that is
configured to apply a guardrail, shoulder, and to daylight to surface in fill situations.
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To create a conditional assembly
The following procedure describes how to add a conditional subassembly to an existing assembly.
1 Create an assembly containing at least one subassembly. For instructions on how to do this, refer to
Creating an Assembly (page 1541).
2 In the tool palette, click the desired conditional subassembly. For example, you may want to select the
ConditionalCutOrFill subassembly, which may be located on the Conditional tool palette.
3 In the Properties palette, set the subassembly’s Side, Layout Width, Layout Grade, Type, and
Minimum\Maximum Distance parameters to indicate the conditions under which they should be
applied. For example, the table below shows how to set these parameters for the ConditionalCutOrFill
subassembly in a fill situation. You may want to specify these settings differently, depending on the
type of condition you want to configure.
Parameter

Value

Description

Side

Left

Specifies which side of the assembly
or corridor the subassembly is inserted
towards.

Layout Width

20.0000’

Specifies the length of the line that is
drawn to represent this subassembly
in layout mode. This parameter, in
combination with the Layout Grade
parameter, allows you to position the
ConditionalCutOrFill subassembly and
subassemblies that are attached to it,
but does not display or have any effect in the corridor model.

Layout Grade

4.000:1

Specifies the grade of the line that is
drawn to represent this subassembly
in layout mode. This parameter, in
combination with the Layout Width
parameter, allows you to position the
ConditionalCutOrFill subassembly and
subassemblies that are attached to it,
but does not display or have any effect in the corridor model.

Type

Fill

Specifies the type of condition that
when detected subsequent specified
subassemblies will be applied to the
assembly.

Minimum Distance

0.0000’

Maximum Distance

5.0000’

When the Cut or Fill (Type) depth is
between these two values, the subsequent subassemblies will be applied
to the assembly.

NOTE For the ConditionalCutOrFill subassembly, the Layout Width and Layout Grade parameters only affect
the appearance of the subassembly in layout view. These parameters enable you to position the conditional
subassembly and the subassemblies that are attached to it, but do not affect the corridor model.
4 If desired, you can add more conditional subassemblies to the same side of the assembly.
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5 Configure the opposite side of the assembly as desired. You can add conditional subassemblies to one
or both sides.
6 When you are finished adding subassemblies to the assembly, press Esc to exit subassembly placement
mode.
The next step is to assign descriptive names to each of the subassemblies in the conditional assembly.
Assigning meaningful names to the subassemblies makes it easier to identify them when you are assigning
targets, and helps you to identify subassemblies in the Subassemblies collection in Prospector.
7 For instructions on how to add meaning names to conditional subassemblies in an assembly, see
Assigning Meaningful Names to Conditional Subassemblies (page 1547).
After assigning meaningful names to the conditional subassemblies, the final step is to set the corridor
targets. For more information, see Setting Targets (page 1481).
To assign meaningful names to conditional subassemblies
1 In the drawing, right-click the conditional assembly and select Assembly Properties.
2 In the Assembly Properties dialog box, click the Construction tab.
Subassemblies that are added to the one side of an assembly display the default names, followed by the
side to which they were added.
3 In the Item list, select the conditional subassembly that is located on the left side of the assembly. Click
it again to highlight the text. Change the name so that it indicates the type of condition it is set to
detect. In the following example, the name of the first conditional subassembly has been changed to
COND Fill 0-5 for TR-L. In this example, COND indicates that this is a conditional subassembly. Fill
indicates the type of condition that activates it. 0-5 indicates the minimum and maximum distance
value of the fill condition it is looking for. In this example, TR-L is a reference to the name of the parent
assembly this particular subassembly is associated with (in this case, “Through Road” or “TR” and “Left
side” or “L”.)

4 Rename any other conditional subassemblies in the assembly to meaningful names.
5 Click OK.
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After assigning meaningful names to the conditional subassemblies, the final step is to set the corridor
targets. For more information, see Setting Targets (page 1481).

Quick Reference
Object Shortcut Menu
Right-click conditional assembly ➤ Properties
Dialog Box
Construction tab (Assembly Properties) (page 1995)

Managing and Editing Assemblies
This section covers a variety of tasks you may perform while working with assemblies in AutoCAD Civil 3D.

Planning an Assembly
Before creating an assembly, identify the different types of subassemblies you need, make sure they are
available, and decide how you want them to display.
The easiest way to access subassemblies is through a tool palette. Drag a subassembly (2) from a palette to
add it to an assembly (1). You can add more subassemblies to the expanded assembly (3).

You can also add assemblies to a tool palette you create. For more information, see Understanding
Subassemblies (page 1555).
You can design styles that control the appearance of the assembly components, such as the insertion point
and baseline point, in the drawing. For more information, see Assembly Styles and Display (page 1550).
Use code set styles (page 1577) to control the appearance of subassembly components, such as points, links,
and shapes. These components will display within your assembly object.

Creating Assembly Sets
If you use the Create Intersection wizard to create intersections, you may want to create customized assembly
set (page 2767)s for intersection creation. Assembly sets are XML files, used to organize assemblies for creating
intersections. Assembly sets reference groups of existing assemblies and may reference null assemblies (page
2779). Null assemblies are used as placeholders, when complete assemblies are unavailable.
For more information on assembly sets, see Assembly Sets (page 1619).
For more information on null assemblies, see Null Assemblies (page 1622).

1548 | Chapter 33 Assemblies and Subassemblies

Copying an Assembly
Copying an assembly creates a new assembly using the standard object naming convention.
If the assembly has subassemblies associated with it, new subassembly objects are also created. The new
assembly is placed in the drawing and in the Assemblies collection in the Prospector tree. The new
subassemblies are included in the assembly, and are also displayed in the Prospector tree as new subassembly
objects.
When you copy an assembly, the new assembly is named using an incremental naming convention. For
example if the original assembly that is copied is named “Assembly 1”, the new assembly is named “Assembly
1 (1)”. If assembly 1 is copied again, the new assembly is named “Assembly 1 (2)”. If “Assembly 1 (1)” is
copied, the new assembly is named “Assembly 1 (1) (2)”.
This same naming convention also applies to any new subassemblies created when copying an assembly.
To copy an assembly
1 In the drawing area, right-click the assembly baseline and click Basic Modify Tools ➤ Copy.
At the command line, you are prompted to specify a base point for the assembly.
2 Pick an insertion point in the drawing area.
The assembly is copied in the drawing and added as a new assembly to Assemblies collection.
3 To edit the name of the assembly, right-click the assembly in the Prospector tree and click Properties.
The Assembly Properties dialog box is displayed with the Information tab (page 1995) active. The Name
field contains the name of the copied assembly, which is, by default “ <assembly name> (1).”
4 Enter a new name in the Name field.
5 To edit the description of the assembly, enter a new description in the Description field.
6 Click Apply to accept the changes, or click OK to accept the changes and close the Assembly Properties
dialog box.

Quick Reference
Object Shortcut Menu
Right-click assembly baseline ➤ Basic Modify Tools ➤ Copy
Dialog Box
Information tab (Assembly Properties) (page 1995)

Deleting an Assembly
Deleting an assembly erases it, and associated subassemblies, from the drawing and removes them from the
Assemblies and Subassemblies collections in the Prospector tree.
You can delete a subassembly within an assembly, and it deletes the subassembly but not the assembly.
To delete an assembly, do one of the following
■

In the drawing area, right-click the assembly baseline, or select the entire assembly object, and click Basic
Modify Tools ➤ Erase.

■

In the Prospector tree, right-click the assembly and click Delete.
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The assembly is erased from the drawing and removed from the Assemblies collection in the Prospector tree.

Quick Reference
Toolspace Shortcut Menu
Prospector tab: Assemblies ➤ Right-click <assembly name> ➤ Delete

Adding an Assembly Offset
You can add an offset to an assembly object.
For more information on assembly offsets, see Creating an Assembly Offset (page 1543).
To add an assembly offset
1 In the drawing area, right-click the assembly baseline and click Add Offset.
2 Select an offset location in the drawing.
The offset location is displayed in the drawing.

Quick Reference
Object Shortcut Menu
Right-click assembly baseline ➤ Add Offset

Removing an Assembly Offset
You can remove an offset from an assembly which erases the offset from the drawing.
For more information on assembly offsets, see Creating an Assembly Offset (page 1543).
To remove an assembly offset
1 In the drawing area, select the assembly baseline from which you want to remove the offset.
2 Right-click and click Remove Offset.
If there are multiple offsets associated with the assembly, you are prompted to select an offset. If there is
only one offset associated with the assembly, it is removed.

Quick Reference
Object Shortcut Menu
Right-click assembly baseline ➤ Remove Offset

Assembly Styles and Display
Use assembly styles and code set styles to control the visual display of each assembly component.
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Using Assembly Styles
Use styles to control the visual appearance of the assembly object components.
You can create specific styles to use for the different phases of a project. For example, you can create one
style to use in the design layout phase and another style to use for plotting.
Use assembly styles to control the appearance of assembly baseline location, profile grade reference point,
controlling offset baseline location and profile point markers.
You can access assembly styles using the methods in the following table:
To access assembly styles... Then...
In the drawing

Right-click an assembly and then click Edit Assembly
Style.

On the Settings tab in
Toolspace

Right-click a style in the Assembly Styles folder and
then click Edit.

NOTE When you click New on the shortcut menu of a collection folder, the new style you create is based on
installation defaults, not on the existing styles in the collection. To create a new style from an existing style,
right-click the style, click copy, and then save the style with a new name.
Use the various tabs in the Assembly Style dialog box to set the following style information:
■

Information. Specifies name, description, and creation information.

■

Marker. Specifies the display of marker symbols (such as for the baseline point) within an assembly.

■

Display. Lists the assembly components and display options as well as the choice of 2D or 3D visibility.
You can display components in a 2D plan view or a 3D view using other tools, such as Orbit or Vpoint.

■

Summary. Lists all the style properties.

Copying or Editing Assembly Styles
Use the Settings tree to copy or edit an assembly style by clicking an existing style, making modifications
and then saving it with a new name.
To copy or edit an assembly style
1 In Toolspace, on the Settings tab, expand the Assembly Styles collection and right-click an existing
style.
2 Click Copy or Edit.
3 In the Assembly Style dialog box, click the Information (page 1997) tab and enter a new name and
description for the assembly style.
4 To specify the display of marker symbols (such as for the baseline, baseline point, and insertion point),
click the Marker (page 1997) tab and specify the marker properties for the assembly.
5 To define the display properties for the assembly style, click the Display (page 1998) tab and specify the
display properties for the assembly.
6 To view a summary of information about the style, click the Summary (page 1999) tab.
7 Click Apply.
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Quick Reference
Toolspace Shortcut Menu
Settings tab: Right-click Assembly Style item
Object Shortcut Menu
Right-click Assembly object ➤ Copy or Edit Assembly Style
Dialog Box
Assembly Style (page 1997)

Previewing an Assembly
You can preview an assembly in the Prospector Item List View.
To preview an assembly
1 Ensure that the Item Preview button
Graphical View (page 100).

on the Prospector tab is selected. For more information, see

2 In Toolspace, on the Prospector tab, right-click the Assemblies collection and click Show Preview.
NOTE A check mark is displayed next to the Show Preview menu item when the preview is enabled.
3 In the Prospector tree, click the assembly that you want to preview.
The assembly is displayed in the Prospector item view.
NOTE The preview of the assembly uses the same display styles as the assembly in the drawing area.

Quick Reference
Toolspace Shortcut Menu
Prospector tab: Right-click Assemblies ➤ Show Preview

Sharing Assemblies
You can access and share assemblies using tool palettes, catalogs, or assembly drawings.
For example, you can create an assembly in your drawing, and then drag and drop it to a tool palette. Once
it is in a tool palette, you can copy an assembly from a tool palette into a catalog. You can create a tool
palette or a catalog that contains multiple assemblies, and then share that tool palette or catalog with others.
You can also save an assembly to a drawing file (.dwg), and then drag and drop that drawing file into your
current drawing.
The following list summarizes ways you can share assemblies:
■

copy an assembly from the drawing area to a tool palette

■

copy an assembly from a tool palette to the drawing area

■

copy an assembly from a tool palette to a catalog

■

copy an assembly from a catalog to the drawing area
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■

copy an assembly from a catalog to a tool palette

■

drag (copy) an assembly drawing (.dwg) into another drawing

NOTE You cannot copy an assembly directly from a drawing into a catalog. You must first copy the assembly to
a tool palette. From a tool palette, you can copy an assembly to a catalog.
To copy an assembly from the drawing area to a tool palette
1 Display the Tool Palettes window.
Click Home tab ➤ Palettes panel ➤

.

2 Open the desired tool palette or create a new tool palette.
3 In the drawing area, zoom to the desired assembly.
4 Select the desired assembly, and click and hold down the mouse button to drag it onto the tool palette.
NOTE To select an assembly, make sure that you click only on the assembly baseline (vertical line). Do not
click on any grips on the assembly baseline.

The assembly is copied to the tool palette.
To copy an assembly from a tool palette to the drawing area
1 Display the Tool Palettes window.
Click Home tab ➤ Palettes panel ➤

.

2 Open the tool palette that contains the desired assembly.
3 In the tool palette, click the desired assembly, and then click a location in the drawing area.
The assembly is copied to the drawing area.
To copy assemblies from a tool palette to a catalog
1 To display catalogs:
Click View tab ➤ Palettes panel ➤

.

TIP When working with both the AutoCAD Civil 3D workspace and the Content Browser, you may find it
useful to have the Content Browser window displayed at all times. To do this, right-click in the Content
Browser title bar and select Always On Top.

2 To display tool palettes: Click Palettes panel ➤

.

3 Open the tool palette that contains the desired assembly or assemblies.
4 In the tool palette, click on the desired assembly or assemblies, and hold down the mouse button to
drag and drop them into the desired catalog.
The assemblies are copied to the catalog.
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To copy an assembly from a catalog to the drawing area
You can copy an assembly from a catalog directly into the drawing area.
1 To display catalogs in the Content Browser: Click View tab ➤ Palettes panel ➤

.

TIP When working with both the AutoCAD Civil 3D workspace and the Content Browser, you may find it
useful to have the Content Browser window displayed at all times. To do this, right-click in the Content
Browser title bar and select Always On Top.
2 Navigate to the catalog containing the desired assembly.
3 Once you have located the desired assembly, click on the i-drop icon
image. When you do this the cursor image changes to an eye-dropper

that is located on the assembly
.

4 Drag the eyedropper icon into the drawing area.
The assembly is copied into the drawing area.
To copy an assembly from a catalog to a tool palette
You can copy an assembly from a catalog directly onto a tool palette.
1 To display catalogs in the Content Browser: Click View tab ➤ Palettes panel ➤

.

TIP When working with both the AutoCAD Civil 3D workspace and the Content Browser, you may find it
useful to have the Content Browser window displayed at all times. To do this, right-click in the Content
Browser title bar and select Always On Top.
2 Navigate to the catalog containing the desired assembly.
3 Once you have located the desired assembly, click on the i-drop icon
image. When you do this the cursor image changes to an eye-dropper

that is located on the assembly
.

4 Drag the eyedropper icon into the desired tool palette.
The assembly is copied into the tool palette.
To drag (copy) an assembly from a drawing (.dwg) to another drawing
You can drag and drop an assembly drawing into another drawing. In this scenario, the assembly drawing
that you want to copy (drag) must contain just the assembly that you want to copy, and no other data.
1 Using Windows Explorer, navigate to the folder containing the assembly drawing file.
2 Right-click on the assembly drawing file and drag and drop it into the AutoCAD Civil 3D drawing area.
The assembly contained in the assembly drawing file is copied into the currently open AutoCAD Civil 3D
drawing.
The assembly is inserted as a block. Explode it to create the assembly object. When the assembly object is
created, it appears in the Assemblies node in Prospector.
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Quick Reference
Ribbon
Click Home tab ➤ Palettes panel ➤
Click View tab ➤ Palettes panel ➤
Click View tab ➤ Palettes panel ➤
Command Line
ContentBrowser
ToolPalettes

Understanding Subassemblies
Subassemblies are the basic building blocks of a corridor design.
A subassembly is an AutoCAD drawing object (AECCSubassembly) that defines the geometry of a component
used in a corridor section. Through the tool palette and tool catalogs, AutoCAD Civil 3D provides
preconfigured subassemblies for components such as travel lanes, curbs, side slopes and ditches. These
subassemblies are defined by a set of points, links, and optionally closed areas referred to as shapes.
The subassemblies provided with AutoCAD Civil 3D have built-in intelligent behavior. They can automatically
adapt to conditions such as superelevation and cut or fill requirements. For example, a side slope subassembly
has variable slopes that change automatically depending on the depth of cut along the corridor. In fill
conditions exceeding a given depth, the shoulder automatically widens to include a guardrail or barrier.
After you determine the kinds of subassemblies to use, make sure they are available through an AutoCAD
Civil 3D tool palette or tool catalogs available through the Content Browser. For more information, see the
Content Browser Help.
In addition to ready-to-use subassemblies, AutoCAD Civil 3D also lets you create your own custom subassembly
objects from polylines, or design more sophisticated ones using a .NET language. (See AutoCAD Civil 3D
Developer’s Guide.)

Layout and Modeling Modes
A subassembly that has not yet been applied to a corridor is considered to be in layout mode. After you
create a corridor, all subassemblies included in the corridor model are considered to be in modeling mode.

Conditional Subassemblies
You can use a special type of subassembly called a conditional subassembly that automatically inserts other
specified subassemblies when certain conditions are met.
For example, a conditional corridor assembly could contain two ConditionalCutOrFill subassemblies. The
first ConditionalCutOrFill subassembly can be configured to apply a ditch subassembly when a cut condition
exists. The second ConditionalCutOrFill subassembly can be configured to apply a guardrail, shoulder, and
daylight to surface when a fill condition exists. Using conditional subassemblies enables you to reduce the
number of corridor regions and assemblies that you have to maintain.
An assembly that contains one or more conditional subassemblies can be referred to as a conditional assembly.
For more information, see Creating Assemblies with Conditional Subassemblies (page 1545), or the tutorial
exercise Creating an Assembly with Conditions.
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The Subassembly Object
A subassembly is an AutoCAD Civil 3D drawing object (AECCSubassembly) that defines the geometry of a
component used in a corridor section.
Add subassembly objects to an assembly object to create a road cross section. Through tool palette and tool
catalogs, AutoCAD Civil 3D provides preconfigured subassemblies for components such as travel lanes,
curbs, side slopes and ditches.
For information on stock subassemblies, see Subassemblies at a Glance.

Subassembly Styles
Use code set styles to control the appearance of subassemblies.
The subassembly object itself does not have its own style. However, since you will typically be working with
sets of subassemblies, you can assign styles to subassembly components (point, links, and shapes) through
code set styles. For more information, see Using Codes and Code Set Styles (page 1567).

Subassembly Settings
Use subassembly settings to control the behavior of subassembly-related commands.
Work with subassembly settings the same way you work with other object settings in AutoCAD Civil 3D,
using the Toolspace Settings tree. You can control subassembly-related settings at both the object collection
(feature) level and at the command level. For information about how the levels of settings work together,
see Specifying Drawing Settings (page 79).
Right-click the Settings tree Subassembly collection to establish defaults for all subassembly-specific settings
and to override the drawing ambient settings for all subassembly-related commands. Use the Commands
collection in the Settings tree Subassembly collection to override subassembly-specific settings or drawing
ambient settings for a specific command.
NOTE Overrides to the drawing ambient settings at the Subassembly collection level and the Subassembly
Commands collection level affect only the specified level. The drawing level settings are not affected. For more
information, see Understanding Settings (page 77).

Subassembly Properties
Specify administrative, parameter and codes information using subassembly properties.
Subassembly properties specify all the information associated with a subassembly, including its code set
style, input and output parameters, the name of the macro file it is derived from, and a list of the link, point,
and shape codes associated with it.
Display the properties of a subassembly:
■

Right-click a subassemblies collection in the Prospector tree and click Properties.

■

Select a subassembly in the drawing, right-click and click Subassembly Properties.

For more information, see Subassembly Properties Dialog Box (page 2006) and The Toolspace Item View (page
99).

Subassemblies Collection (Prospector Tab)
Use the Subassemblies collections in the Prospector tree to access the subassemblies in a drawing.
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Right-click the Subassemblies collection to do the following:
■

Turn on or off the subassembly preview (page 1563).

■

Refresh the Subassemblies collection in the Prospector tree.

If a subassembly has been added to the current drawing, you can expand the Subassemblies collection to
view the names of the subassemblies in the Prospector list view. For more information, see The Toolspace
Item View (page 99).
Each subassembly in a site is displayed as a named object under the Subassemblies node of the site. Right-click
a subassembly name to do the following:
■

Display subassembly properties (page 1556).

■

Delete the subassembly (page 1562) in the drawing.

■

Zoom or pan to the subassembly in the drawing.

■

Refresh the Prospector tree.

Subassembly Collection (Settings Tab)
Use the Subassembly collection in the Settings tree to manage subassembly settings and commands.
Right-click the Subassembly collection to do the following:
■

Edit subassembly feature settings (page 1556).

■

Refresh the Settings tree.

Expand the Subassembly collection to display and edit the subassembly commands.

Creating Subassemblies
Add subassemblies to a drawing using the subassemblies provided through the AutoCAD Civil 3D tool palette
or tool catalog, or create your own custom subassemblies.
When using the preconfigured AutoCAD Civil 3D subassemblies, adding the subassembly to the drawing
creates the subassembly object.
If you want to create a custom shape and use it as a subassembly, use the Create Subassembly from Polyline
feature. For more information, see Creating Subassemblies From Polylines (page 1558).
Another approach to creating customized subassemblies is using scripts in a .NET language. This method
provides you with the ability to create custom subassemblies with simple or complex conditional behavior
built in. For more information, see Creating Custom Subassemblies Using .NET in the AutoCAD Civil 3D
Developer’s Guide.

Creating a Subassembly from a Tool Palette
You can create a subassembly object by adding it to your drawing from a tool palette.
Once selected in the tool palette, you can add the subassembly to an assembly baseline, or to a subassembly
attached to an assembly. You can also just add the subassembly to your drawing and not associate it with
an assembly. This is referred to as a detached subassembly.
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To create a subassembly from a tool palette
1 Display the Tool Palettes window.
Click Home tab ➤ Palettes panel ➤

.

2 On the Tool Palettes window, click the desired subassembly.
3 Do one of the following:
■

To add the subassembly to an assembly, select a marker point on an assembly in the drawing.

■

To add the subassembly to the drawing, and not associate it with an assembly, press Enter then click
a location in the drawing.

The subassembly name is displayed under the Subassemblies collection in the Prospector tree.
If you subsequently move the subassembly from its original insertion point in an assembly, you can return
it to that point by clicking Clear Offset in Assembly on the Modify Subassembly panel, or by entering
SubassemblyClearOffset at the command line.
The Clear Offset in Assembly button is only enabled if a selected subassembly is part of an assembly, and
was moved away from its original insertion point.

Quick Reference
Ribbon
Click Home tab ➤ Palettes panel ➤
Command Line
ToolPalettes
CreateSubAssemblyTool
SubassemblyClearOffset

Creating Subassemblies From Polylines
You can create customized subassemblies from AutoCAD polyline objects in a drawing.
To create a subassembly from a polyline object, first create the desired polyline object in the drawing. Then
convert the polyline to a subassembly using the Create Subassembly From Polyline command. Add the new
subassembly to an assembly by right-clicking it and clicking Add To Assembly.
Make sure the polyline object is free of drawing errors. If necessary, use the drawing cleanup tools in AutoCAD
Map 3D.
After you have created the subassembly from a polyline, add the desired point, link, and shape codes to the
subassembly. If you do not add any codes to the subassembly, the subassembly does not display when you
create the corridor. For more information, see Understanding Point, Link, and Shape Codes (page 1568) and
Adding Codes to a Subassembly (page 1576).
Use code set styles (page 1567) to control the visual appearance of subassembly components. You can use
existing code set styles or create your own.
The origin point of the polyline is used as the attachment point, or origin point, of the subassembly. You
can change this origin point for subassemblies created from polylines using the Modify Origin command.
For more information, see Changing the Origin Point on Polyline Subassemblies (page 1564).
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To create a subassembly from a polyline
1 Create the desired polyline shape in the drawing.
2 Click Home tab ➤ Create Design panel

Create Subassembly From Polyline

.

3 Click the polyline object in the drawing and press Enter.
4 In the Create Assembly (page 2000) dialog box, for Name, enter a name for the subassembly.
NOTE To name the subassembly, you can select its default name and enter a new name, or you can use the
Name Template. For more information, see Name Template Dialog Box (page 2022).
5 For Description, enter an optional description for the subassembly.
6 In the Code Set Style list, select a Code Set Style or accept the default. For more information, see Using
Codes and Code Set Styles (page 1567).
7 Click

to select a layer. For more information about layers, see Object Layer Dialog Box (page 2221).

NOTE If you do not select a layer, the subassembly is placed on the default layer.
8 Optionally, select a mid-ordinate distance.
If this subassembly contains curves, they will be tessellated (converted into a finite number of segments).
This value determines the length of the tessellated segments.
9 In the Link Creation list, choose the behavior for link creation by selecting Multiple, Single, or None.
Multiple is the default.
Multiple: Creates a new link for each segment created from the object selected. This is useful for
assigning link codes to different components of the subassembly for creating surfaces, or other
display features.
Single: Creates one link from all segments created from the selected object. This is provided to make
creating shapes simpler. Using the Add Shape right-click command, you only need to perform one
action.
None: Produces no links; only points will be created at the vertices.
10 Optionally, you may clear Erase Existing Entities if you want to save the original polyline object selected
to create the subassembly. By default, this option is checked and the polyline selected is automatically
deleted.
11 Click OK. The new subassembly is created and is displayed in the Subassemblies collection in the
Prospector tree.
To add codes to the subassembly, see Adding Codes to a Subassembly (page 1576).
To add the subassembly to an assembly, see Creating Assemblies (page 1541).

Quick Reference
Ribbon
Home tab ➤ Create Design panel

Create Subassembly From Polyline

Menu
Corridors menu ➤ Create Subassembly From Polyline
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Command Line
CreateSubFromPline
Dialog Box
Create Subassembly From Polyline (page 2001)

Inserting Subassemblies on Right and Left Sides of a Corridor
Some subassemblies use a Side input parameter to specify inserting the subassembly on the right or left side
of a corridor; other subassemblies allow you to do this by specifying a positive or negative value for the
insertion point input parameter.
Subassemblies that contain a Side input parameter let you specify which side the subassembly is inserted by
setting this parameter to Right or Left. By default, this parameter is typically set to Right. Change it to Left
to insert the subassembly onto the left side.
Other subassemblies, such as LinkOffsetAndElevation, do not contain a Side input parameter. However, you
can insert the subassembly onto the right or left side of a controlling baseline by entering a positive or a
negative value for the insertion point input parameters. A positive value for this parameter inserts the
subassembly onto the right side of a corridor, or of a controlling baseline. A negative value inserts the
subassembly onto the left side. The insertion point input parameter could be named any of the following,
depending on the function of the subassembly: Insert Point Offset, Sample Point Offset, Daylight Offset
from Baseline.
The following are examples of subassemblies that do not contain an input parameter named Side. For these
types of subassemblies, you specify the side by using positive and negative values for the insertion point
input parameter.
■

DaylightToOffset

■

DaylightToRow

■

LinkOffsetAndElevation

■

LinkOffsetAndSlope

■

LinkOffsetOnSurface

■

OverlayMillAndLevel1

■

OverlayWidenMatchSlope1

■

OverlayWidenWithSuper

You can also use the Mirror option to automatically copy a subassembly, or multiple subassemblies, from
one side of an assembly to the other. For more information, see Creating an Assembly (page 1541)
To insert a subassembly on the left side of a corridor using the Side parameter
1 Click Home tab ➤ Create Design panel ➤ Assembly drop-down ➤ Create Assembly

.

2 In the Create Assembly (page 2000) dialog box, accept the default settings. Click OK.
3 When you are prompted to specify the assembly baseline location, click a point in the drawing to insert
the assembly.
4 In the Tool Palettes window, open the Imperial - Basic tool palette by clicking the Imperial - Basic tab.
(To display the Tool Palettes window, click Home tab ➤ Palettes panel ➤
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.)

5 Click the BasicLane subassembly. The Properties dialog box is displayed for the BasicLane subassembly.
Note that the Side parameter is set to Right by default.
6 Click on the assembly. The BasicLane subassembly is inserted onto the right side of the assembly.
7 On the tool palette, click the BasicLane subassembly again. Again the Properties dialog box is displayed.
8 In the Properties dialog box, in the Advanced section, click the value for the Side parameter and change
it from Right to Left.
9 Click on the assembly. The BasicLane subassembly is inserted on the left side of the assembly.
To insert a subassembly on the left side of a corridor using (negative) insertion point values
1 Click Home tab ➤ Create Design panel ➤ Assembly drop-down ➤ Create Assembly

.

2 In the Create Assembly dialog box, accept the default settings. Click OK.
3 When you are prompted to specify the assembly baseline location, click a point in the drawing to insert
the assembly.
4 In the Tool Palettes window, open the Imperial - Daylight tool palette by clicking the Imperial - Daylight
tab. (To display the Tool Palette window, click Home tab ➤ Palettes panel ➤

.)

5 Click the DaylightToOffset subassembly. The Properties dialog box is displayed for the DaylightToOffset
subassembly. Note that the Daylight Offset from Baseline parameter is set to 10 by default.
6 Click on the assembly. The DaylightToOffset subassembly is inserted onto the right side of the assembly.
7 On the tool palette, click the DaylightToOffset subassembly again. Again the Properties dialog box is
displayed.
8 In the Properties dialog box, in the Advanced section, click the value for the Daylight Offset from
Baseline parameter and change it from positive 10 to negative 10.
9 Click on the assembly. The DaylightToOffset subassembly is inserted on the left side of the assembly.
To insert a subassembly on the left side of a corridor using Mirror
1 Click Home tab ➤ Create Design panel ➤ Assembly drop-down ➤ Create Assembly

.

2 In the Create Assembly (page 2000) dialog box, accept the default settings. Click OK.
3 When you are prompted to specify the assembly baseline location, click a point in the drawing to insert
the assembly.
4 In the Tool Palettes window, open the Imperial - Basic tool palette by clicking the Imperial - Basic tab.
(To display the Tool Palette window, click Home tab ➤ Palettes panel ➤

.)

5 Click the BasicLane subassembly. The Properties dialog box is displayed for the BasicLane subassembly.
Note that the Side parameter is set to Right by default.
6 Click on the assembly. The BasicLane subassembly is inserted onto the right side of the assembly.
7 On the assembly, right-click on the BasicLane subassembly and click Mirror. The BasicLane subassembly
is inserted on the left side of the assembly. Note that the Mirror option is only available for subassemblies
that contain a Side parameter.
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Quick Reference
Ribbon
Home tab ➤ Create Design panel ➤ Assembly drop-down ➤ Create Assembly
Home tab ➤ Palettes panel ➤
Menu
Corridors menu ➤ Create Assembly
Command Line
CreateAssembly
ToolPalettes
Dialog Box
Create Assembly (page 2000)

Managing and Editing Subassemblies
There are a variety of ways you can work with subassemblies in AutoCAD Civil 3D.

Deleting a Subassembly
Deleting a subassembly erases it from the drawing and removes it from the Subassemblies collection in the
Prospector tree.
When you delete an assembly, and subassemblies associated with that assembly are also deleted.
To delete a subassembly, do one of the following
■

In the drawing area, right-click the subassembly and click Basic Modify Tools ➤ Erase.

■

In the Prospector tree, right-click the subassembly and click Delete.

The subassembly is erased from the drawing and removed from the Subassemblies collection in the Prospector
tree. If the subassembly was attached to an assembly, it is removed from the assembly too.

Quick Reference
Object Shortcut Menu
Right-click subassembly ➤ Basic Modify Tools ➤ Erase
Toolspace Shortcut Menu
Prospector tab: Subassemblies ➤ Right-click <subassembly name> ➤ Delete

Managing Subassembly Groups
Each subassembly added to an assembly is automatically associated with a named group within the assembly.
Subassembly groups manage the order in which subassemblies are processed during corridor modeling. The
first time you add a subassembly to an assembly, the subassembly is added to the first group. When you add
a second subassembly by attaching it to the first subassembly, the second subassembly also gets added to
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the first subassembly group. The next time you select an assembly baseline, a new subassembly group is
automatically created and subsequent subassemblies added to the assembly are added that group.
The Construction tab (page 1995) of the Assembly Properties dialog box displays the subassembly groups for
a given assembly. The location of the groups on this tab reflects the order in which the subassemblies are
processed. The group of subassemblies located at the very top of the list is processed first, in top-to-bottom
order. The group of subassemblies located directly beneath the top group is processed second, and so on.
NOTE Subassembly groups are not processed according to the numeric order associated with their subassembly
group name. For example, a subassembly group named Group (1) located at the bottom of the Item list is processed
last, even though the group is named Group (1).
You can change the order of subassembly groups by moving them up or down. However, you cannot reorder
subassemblies within a group. If you delete subassemblies or subassembly groups using this tab, the
subassemblies are deleted from the drawing.
Subassemblies that are not associated with assemblies (detached subassemblies and subassemblies created
from polylines) are not associated with groups.
To move a subassembly group
1 In Toolspace, on the Prospector tab, expand the Assemblies collection and right-click an existing
assembly.
2 Click Properties.
3 Click the Construction tab.
4 In the Item list, right-click the name of a subassembly group and select Move up or Move down.
The group of subassemblies is moved up or down in the list.

Previewing a Subassembly
You can preview a subassembly in the Prospector Item List View.
To preview a subassembly
1 Ensure that the Item Preview button
Graphical View (page 100).

on the Prospector tab is selected. For more information, see

2 In Toolspace, on the Prospector tab, right-click the Subassemblies collection and click Show Preview.
NOTE A check mark is displayed next to the Show Preview menu item when the preview is enabled.
3 In the Prospector tree, click the subassembly you want to preview.
The subassembly is displayed in the Prospector item view.
NOTE The preview of the subassembly uses the same display styles as the subassembly in the drawing area.

Quick Reference
Toolspace Shortcut Menu
Prospector tab: Right-click Subassemblies ➤ Show Preview
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Changing the Origin Point on Polyline Subassemblies
You can change the origin point on subassemblies created from polylines.
The origin point of the polyline is used at the attachment point, or origin point, of the subassembly. The
origin point is the point where the subassembly attaches to an assembly baseline, or to another subassembly.
You can change this origin point for subassemblies created from polylines using the Modify Origin command.
To change the origin point on a polyline subassembly
1 In the drawing, or in Toolspace, select the polyline subassembly.
2 Click Subassembly tab ➤ Modify Subassembly panel ➤ Modify Origin

.

3 In the drawing, click a location on the subassembly where you want to specify the new origin (attachment
point).
For more information, see Creating Subassemblies From Polylines (page 1558).

Quick Reference
Ribbon
Subassembly tab ➤ Modify Subassembly panel ➤ Modify Origin
Command Line
SubassemblyModifyHook

Converting VBA Subassemblies to .NET
You can convert AutoCAD Civil 3D stock subassemblies that are VBA-based to .NET.
In Civil 3D 2007, and in earlier versions of Civil 3D, the subassemblies that were included in the product
were created using VBA.
In Civil 3D 2008, all of the subassemblies included in the product were created using .NET. This is because
.NET versions of subassemblies provide faster performance than VBA-based subassemblies when generating
corridor models. Civil 3D 2008, and later versions, still support VBA-based subassemblies. For example, in
drawings, catalogs, and tool palettes, you can have a mix of VBA-based and .NET-based subassemblies.
However, it is recommended that you convert VBA-based subassemblies to .NET using the following procedure
to achieve optimal performance when generating corridor models.
NOTE This command only converts the VBA-based AutoCAD Civil 3D stock subassemblies that were included
with the product. It does not convert any VBA-based subassemblies that were created from user-defined (custom)
VBA code.
To determine if a subassembly is VBA-based, .NET-based, or created from a polyline, use the Subassembly
Properties dialog box or the Properties palette to display the subassembly definition.
For information on creating custom subassemblies, see the AutoCAD Civil 3D Developer’s Guide.
To display the subassembly definition in the Subassembly Properties dialog box
1 Right-click a subassembly in the drawing and click Subassembly Properties.
2 In the Subassembly Properties dialog box, click the Parameters tab.
The Defined From field displays .NET if the subassembly was created using .NET, VBA if it was created
using VBA, and Entities if the subassembly was created from a polyline.
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To display the subassembly definition in the Properties palette
1 Right-click a subassembly in the drawing and click Properties.
2 On the Properties palette, click the Design tab.
The Geometry Generate Mode property displays .NET if the subassembly was created using .NET, VBA
if it was created using VBA, and Entities if the subassembly was created from a polyline.
To convert subassemblies from VBA to .NET
1 Click Modify tab ➤ Design panel

Convert VBA Subassemblies To .NET

.

2 Do one of the following:
■

To convert all subassemblies in the drawing, at the command line, enter A, and then press Enter.
All VBA subassemblies in the drawing are converted to VB.NET.

■

To convert all subassemblies in a selected assembly, select an assembly, and then press Enter. All
VBA subassemblies in the selected assembly are converted to VB.NET.

Quick Reference
Ribbon
Modify tab ➤ Design panel

Convert VBA Subassemblies To .NET

Menu
Corridors menu ➤ Utilities ➤ Convert VBA Subassemblies To .NET
Object Shortcut Menu
Right-click subassembly ➤ Subassembly Properties
Right-click subassembly ➤ Properties
Toolspace Shortcut Menu
Prospector tab: Subassemblies ➤ Right-click <subassembly name> ➤ Properties
Command Line
ConvertVBASAsToDotNET
Dialog Box
Parameters tab (Subassembly Properties) (page 2006)

Sharing Subassemblies
You can access and share subassemblies using tool palettes, the AutoCAD Civil 3D Corridor Modeling catalogs,
or package files.
For example, you can create custom subassemblies in your drawing, and then drag and drop them onto a
tool palette or catalog. You can create a tool palette or catalog that contains multiple custom subassemblies
and then share that tool palette or catalog with others.
Custom subassemblies that have been created using .NET or VBA can be exported and imported using a
package file. Subassemblies created from polylines cannot be included in a package file.
A package file contains all the files necessary for the custom subassemblies to work. Once the package file
is created, users can import the package file contents into AutoCAD Civil 3D using the ImportSubassemblies
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command, and copy the custom subassemblies directly into a tool palette or catalog. You can also share a
package file with others. For example, you could attach a package file containing one or more subassemblies
to an e-mail, or use other file transfer methods.
For more information on creating package files, see Exporting Custom Subassemblies Using a Package File
in the AutoCAD Civil 3D Developer’s Guide.
For information on adding subassemblies to tool palettes, see Tool Palettes (page 122).
To copy (import) subassemblies from a package file to a tool palette
1 To display the Tool Palettes window:
Click Home tab ➤ Palettes panel ➤

.

2 Open the tool palette that you want to copy the subassemblies into. You may open an existing tool
palette or create a new one.
3 Click Insert tab ➤ Import panel

Import Subassemblies

.

4 On the Import Subassemblies (page 2003) dialog box, click the folder icon to navigate to and select the
package file.
5 In the Import To section, click Tool Palette, and then select the desired tool palette in the drop-down
list.
NOTE You can import the subassemblies to a tool palette and to a catalog at the same time. When you
import subassemblies to a catalog, they automatically get imported to the My Imported Tools catalog. If the
My Imported Tools catalog does not exist, it is automatically created.
6 Click OK.
The subassemblies contained in the package file are copied to the tool palette. If you chose to copy the
subassemblies to a catalog at the same time, the subassemblies are also copied to the My Imported Tools
catalog.
NOTE Subassemblies created from polylines cannot be included in a package file. Package files are intended for
sharing custom subassemblies that have been created using .NET or VBA.
To copy (import) subassemblies from a package file to a catalog
1 To display the corridor modeling catalogs:
Click View tab ➤ Palettes panel ➤

.

TIP When working with both the AutoCAD Civil 3D workspace and the Content Browser, you may find it
useful to have the Content Browser window displayed at all times. To do this, right-click in the Content
Browser title bar and select Always On Top.
2 Click Insert tab ➤ Import panel

Import Subassemblies

.

3 On the Import Subassemblies (page 2003) dialog box, click the folder icon to navigate to and select the
package file.
4 In the Import To section, click Catalog Library/My Imported Tools.
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NOTE You can import the subassemblies to a tool palette and to a catalog at the same time. When you
import subassemblies to a catalog, they automatically get imported to the My Imported Tools catalog. If the
My Imported Tools catalog does not exist, it is automatically created.
5 Click OK.
The subassemblies contained in the package file are copied to the My Imported Tools catalog.
NOTE When you import subassemblies to a catalog using this method (package files), you can only copy the
subassemblies to the My Imported Tools catalog. If the My Imported Tools catalog does not exist, one is
automatically created. Once the subassemblies are in the My Imported Tools catalog, you can then copy them to
other catalogs.
If you chose to copy the subassemblies to a tool palette at the same time, the subassemblies are also copied
to the selected tool palette.
NOTE Subassemblies created from polylines cannot be included in a package file. Package files are intended for
sharing custom subassemblies that have been created using .NET or VBA.

Quick Reference
Ribbon
Insert tab ➤ Import panel

Import Subassemblies

Menu
Corridors menu ➤ Utilities ➤ Import Subassemblies
Tool Palette Shortcut Menu
In Tool Palette: Right-click Import Subassemblies
Command Line
ImportTools
Dialog Box
Import Subassemblies (page 2003)

Using Codes and Code Set Styles
Codes can be associated with the point, link, and shape components of a subassembly.
Codes allow you to apply simple or complex rules governing the offset and elevation behavior of
subassemblies. You can choose to add codes to certain subassembly components to implement presentation
or annotation features to a corridor design.
A typical subassembly is comprised of the following components, which can have codes associated with
them:
■

Point. Define the basic subassembly structure.

■

Link. Connect points to form planar structural surfaces of a corridor.

■

Shape. Defined from links and define a closed region that represents materials used in a corridor model.
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For a set of point, link or shape components, you can define a set of display characteristics and assign them
to a code set style. You can then assign a code set style to a subassembly, assembly, corridor, or section view.
You can assign appropriate label styles to various code sets in the code set styles.

Pavement Structure of Paved Sections
The AutoCAD Civil 3D Corridor Modeling subassemblies that model paved components of a roadway, such
as travel lanes and shoulders, allow multiple material layers to be defined.
These material layer sections are defined by sets of links. The typical structure is shown in the following
diagram.
Pavement Structure on Paved Sections

Link code Pave (and Top)
Link code Pave1
Link code Pave2

Shape code Pave1
Shape code Pave2
Pave1 Depth
Pave2 Depth

Link code Base

Shape code Base
Base Depth
Subbase Depth

Shape code Subbase

Link code Subbase (and
Datum)

The standard link codes from top to bottom are Pave, Pave1, Pave2, Base, and Subbase. The code Top is also
assigned to all finish grade links, thus coinciding with the Pave links on paved sections. The code Datum is
also assigned to the bottom of subbase. The shape codes for the material areas from top to bottom are Pave1,
Pave2, Base, and Subbase.
The subassemblies that create paved sections have the depth or thickness of each layer as user-definable
input parameters. Each subassembly that creates paved sections closes the layer areas to form a closed shape,
even if those layers actually continue into the adjacent component. Layers can be omitted by setting the
corresponding depth to zero. This collapses that layer so that the shape also has a zero area.

Understanding Point, Link, and Shape Codes
The optional codes associated with a subassembly point, link, or shape components determine some of the
behavior you will see in corridor modeling.
When designing custom subassemblies, you must consider not only the geometric shape of the corridor
model that will ultimately be created by the subassemblies, but also how the model is used for post-modeling
design operations. These operations include:
■

Design surface modeling

■

Combining the corridor model with grading models

■

Earthwork and material volume analysis

■

Design visualization and rendering

■

Right-of-way acquisition

■

Slopestake reporting

■

Export to survey data recorders for construction stakeout
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■

Plans production

■

Staged construction modeling

Nearly all of these operations depend on the codes assigned to points, links, and shapes in the corridor
model. To create models that integrate into all of the operations listed above, the coding scheme must be
carefully designed before creating the first subassembly. The best practice is to diagram all of the different
roadway types and situations that can be anticipated for the users you are supporting. Next, devise and
annotate codes for all critical points, links, and shapes. Use this diagram when documenting the codes for
each subassembly. Note that it is difficult to design a single set of codes that meet needs of every operation.
For this reason, AutoCAD Civil 3D lets you assign any number of codes to each point, link, and shape. How
these codes are utilized is described in the following sections.

Creating Point, Link, and Shape Codes
You can create new point, link, and shape codes using a .NET language.
For more information about creating point, link, and shape codes using .NET languages, see AutoCAD Civil
3D Developer’s Guide.
For more information about assigning code set styles to point, link, and shape codes, see Using Codes and
Code Set Styles (page 1567).

Point Codes
Point codes are the feature codes assigned to the endpoints of the links that make up the subassembly
component
Operation

Description

Corridor Modeling

The corridor model is represented graphically by roadway
cross sections at predetermined stations, with longitudinal
strings connecting points between adjacent stations. Points
with the same code and in the same region of the section
are automatically connected with longitudinal lines.

Plans Production

Many organizations require that critical points be annotated on cross section drawings. For example, a given
state’s Department of Transportation may require the following: 1.) Elevations at ditch bottoms, 2.) Slopes (x:1) of
ditch sides, clear zones, and cut/fill daylight links, 3.) %
Slopes of lanes and shoulders, 4.) Offsets of the cut/fill
daylight points. To create custom cross-section sheet utilities that meet these requirements, these points must be
identifiable within the model. Another plans production
operation is depicting the limits-of-construction in plan
view, with different symbology and line types used for cut
lines and fill lines.

Design Surface Modeling
and Staged Design

Point codes make it possible to extract finish grade profiles
at critical points on the corridor model surfaces. For example, a profile connecting the left edge-of-pavement
points of a roadway can be used in drainage analysis and
design, tying links from an adjacent road’s model, and to
combine corridor models with grading models.

Right-of-Way Analysis

The limits-of-construction of the corridor model can be
determined by extracting alignments or figures that con-
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Operation

Description
nect the cut/fill daylight points on each side of the model.
These are used to determine what property has to be acquired.

Slopestake reporting and
construction stakeout

Identifying critical points on the different layers of the
corridor model is essential to creating construction staking
reports, or when exporting data to survey data recorders
for construction stakeout. Since grading is nearly always
done to the subbase line, not to the finish grade, it may
be necessary to define distinct codes on both the finish
grade and subbase surface links. For example, the edgeof-traveled-way may use code ETW on finish grade, and
ETW_Sub on the subbase layer.

The cut/fill daylight points are a good example of where two codes may be needed for the same point. If
the daylight points for both cut and fill links have the code “Daylight”, then it is easy to depict and extract
a single figure defining the limit of construction on each side. If the same points have the code “Daylight_Cut”
or “Daylight_Fill,” depending on circumstances, it is also easy to annotate cut and fill daylight lines differently.

Link Codes
Link codes are the feature codes assigned to each of the links that make up the roadway component. A link
is defined as a single straight-line segment between endpoints.
Operation

Description

Design surface modeling

Design surfaces can be built by extracting all links with a
particular code. Link codes should be designed so that it
is easy to extract the types of surfaces needed for surface
modeling. Typically these are used for earthwork calculations, additional grading, visualization, and drainage analysis. Depending on the application, you may need to extract paved surfaces, all finish grade surfaces, or subbase
surfaces.

Earthwork and material
volume analysis

Different layers of the corridor model can be separated
and used for volume calculations using tables that define
materials in terms of which link codes are above, below,
left, and right of the material layers. Simple cut and fill
quantities are usually determined by comparing the existing
ground to a combination of unpaved finish grade links and
subbase links. Pavement layers, such as wearing course,
asphalt base, and granular subbase, are determined based
on the surface links defining those as closed areas.

Visualization and rendering

For realistic renderings of design surfaces, it is useful to
distinguish between different surface materials such as
pavement, gravel, grass, and concrete.

To meet the requirements of these operations, it is usually necessary to assign multiple codes to links on
certain portions of the roadway. A typical scheme:
Link Code

Description

Top

Assigned to all links on the finished grade, whether paved or unpaved
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Link Code

Description

Pave

A second code assigned to all paved links on the finished grade

Datum

Assigned to all unpaved finished grade links, and all links on the bottoms and sides of the subbase layers

Subbase

Assigned to all links on the bottoms and sides of the subbase layers

Thus, the Top links can be used to build a surface model of the entire finished grade surface, which is used
for visualization and drainage analysis. The Pave links can be used to render the paved portions of the
finished grade surface with a particular color or texture. The Datum links can be used to model the surface
that is graded with earth moving equipment, and is also used for simple cut and fill volume analysis. The
Subbase links are used to define the bottom of the granular base material areas for material volume analysis.

Shape Codes
Shapes are closed cross-sectional areas created by a single subassembly. The primary use for shape codes;
defining hatch patterns for different materials, and to extract areas for material volume tabulation. The
codes should reflect how you want the materials identified in the earthwork reports.

Standard Point Codes
A set of standard codes define the display and behavior of the point components used in the AutoCAD Civil
3D Corridor Modeling subassemblies.
The following illustration shows the location of the standard point codes on subassemblies defining a divided
road with a depressed median and truncated shoulders.
C/L

29

30

19 12
13
14
15
16

6 7 8 9
17

21,23
9 8 7 6
17

18
10

18
10

12 19
13
14
15
16
24

25,38,39

19
27,38,40
26

21,22

Divided Road with Depressed Median; Truncated Shoulders

The table following the illustrations provides descriptions of the point codes used in the illustrated assemblies.
The following illustration shows the location of the standard point codes on subassemblies defining a divided
road with a depressed median and extended shoulders:
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Median

13
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6

15

8

7

12

8
9
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20
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Divided Road with Depressed Median; Extended Shoulders

The following illustration shows the location of the standard point codes on subassemblies defining an
undivided road with a curb-and-gutter. Not all layers are shown.
35
33
37

32
36

1

6,31
4
9

5

10

Undivided Road with Curb-and-Gutter; Not All Layers Shown

The table below names and describes the standard point codes used in the example assembly illustrations.
Point Codes
No.

Code

Description

1

Crown

Crown point between travel lanes on finish grade.

4

Crown_Base

Crown point between travel lanes on the base layer.

5

Crown_Sub

Crown point between travel lanes on the subbase layer.

6

ETW

Edge of traveled way; inside or outside edges of travel lanes on finish grade.

7

ETW_Pave1

Edge of traveled way on the Pave1 layer.

8

ETW_Pave2

Edge of traveled way on the Pave2 layer.

9

ETW_Base

Edge of traveled way on the base layer.

10

ETW_Sub

Edge of traveled way on the subbase layer.

12

Lane_Pave1

Lane break point on Pave1.

13

Lane_Pave2

Lane break point on Pave2.

14

Lane_Base

Lane break point on Base.

15

Lane_Sub

Lane break point on Subbase.
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No.

Code

Description

16

EPS

Edge of paved shoulder; outer edge of paved portions of shoulder on finish
grade.

17

EPS_Pave1

Edge of paved shoulder on the Pave1 layer.

18

EPS_Pave2

Edge of paved shoulder on the Pave2 layer.

19

EPS_Base

Edge of paved shoulder on the Base layer.

20

EPS_Sub

Edge of paved shoulder; outer edge of paved portions of shoulder on the
Subbase layer.

21

EPS_Base_In

Inside edge of paved shoulder on the base layer.

22

EPS_Sub_In

Inside edge of paved shoulder on the subbase layer.

23

ES_Unpaved

Edge of gravel shoulder; outer edge of unpaved portions of shoulder on
finish grade.

24

Daylight_Sub

Subgrade intercept point; point where the subbase surface extends and
intersects the finish grade.

25

Daylight

Daylight point for a cut or fill slope.

26

Daylight_Fill

Daylight point for a fill slope.

27

Daylight_Cut

Daylight point for a cut slope.

29

Ditch_Out

Outside edge of ditch.

30

Bench_In

Inside edge of bench.

31

Bench_Out

Outside edge of bench.

32

Flowline_Ditch

Flowline of a V-shaped ditch.

33

LMedDitch

Left edge of median ditch.

38

Bottom_Curb

Bottom of curb for a curb without gutter.

39

Back_Curb

Back of curb.

40

Sidewalk_In

Inside edge of sidewalk.

To view all actual code numbers, the code names and brief code descriptions: In Notepad, open ..\Documents
and Settings\All Users\Application Data\Autodesk\C3D2010\enu\C3DStockSubassemblyScripts.codes.

Standard Link Codes
A set of standard codes define the display and behavior of the link components used in the AutoCAD Civil
3D Corridor Modeling subassemblies.
The following illustration shows the location of the standard link codes on subassemblies defining a divided
road with a depressed median and truncated shoulders.
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Divided Road with Depressed Median; Truncated Shoulders

The table following the illustrations provides descriptions of the link codes used in the illustrated assemblies.
The following illustration shows the location of the standard link codes on subassemblies defining a divided
road with a depressed median and extended shoulders.
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1,8

1,7
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Divided Road with Depressed Median; Extended Shoulders

The following illustration shows the location of the standard link codes on subassemblies defining an
undivided road with a curb-and-gutter. Not all layers are shown.

1,7
1,2

1,13
1,12

5
6,7

Undivided Road with Curb-and-Gutter; Not All Layers Shown

The table below names and describes the standard link codes used in the example assembly illustrations.
Link Codes
No.

Code

Description

1

Top

Traces all links on finished grade, including:
Unpaved finish grade links (clear zone, cut/fill slopes)
Top paved surface on paved sections.
Gutter, face of curb, and top of curb.
Top of sidewalk.
For most roadways, the Top links trace the finished grade surface from the left
catch point to the right catch point. These links would build the finish grade
surface.

2

Pave

Any finished grade surface on a paved section.

5

Base

All links on the base surface of paved sections.
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No.

Code

Description

6

SubBase

All links on the subbase surface of paved sections.

7

Datum

All finish grade links on unpaved sections, and all subbase links on paved sections.
For most roadways, the Datum links trace the unpaved finished grade and subbase from the left catch point to the right catch point. These links would build
the surface used to calculate cut and fill volumes.

8

Gravel

Finish grade surfaces above gravel shoulders with subbase.

12

Curb

All links comprising a curb or curb and gutter.

13

Sidewalk

All links comprising a sidewalk.

To view all actual code numbers, the code names and brief code descriptions: In Notepad, open ..\Documents
and Settings\All Users\Application Data\Autodesk\C3D2010\enu\C3DStockSubassemblyScripts.codes.

Standard Shape Codes
A set of standard codes define the display and behavior of the shape components used in the AutoCAD Civil
3D Corridor Modeling subassemblies.
The following illustration shows the location of some standard shape codes on subassemblies defining an
undivided road with a curb-and-gutter:
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Undivided Road with Curb-and-Gutter

The table below names and describes the standard shape codes used in the example assembly illustration.
Shape Codes
No.

Code

Description

1

Pave1

Closed shape between the finish grade and first pavement surface on paved sections.

2

Pave2

Closed shape between the first and second pavement surface on paved sections.

3

Base

Closed shape between the second pavement surface and the base surface on paved
sections.
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No.

Code

Description

4

SubBase

Closed shape between the base and subbase surfaces on paved sections.

5

Curb

Closed area within a concrete curb or curb and gutter.

6

Sidewalk

Closed area within a concrete sidewalk.

To view all actual code numbers, the code names and brief code descriptions: In Notepad, open ..\Documents
and Settings\All Users\Application Data\Autodesk\C3D2010\enu\C3DStockSubassemblyScripts.codes.

Adding Codes to a Subassembly
Add codes to a subassembly created from a polyline.
After you create a subassembly from a polyline, the next step is to add the necessary codes to the subassembly.
For more information, see Creating Subassemblies From Polylines (page 1558).
To add a code to a subassembly created from a polyline
1 In the drawing, select the subassembly, then right-click it and click Add Code.
2 Enter the code and press Enter.
NOTE The code you enter must be an existing code, or, if it is a new code, you must make sure that it gets
added to the codes file (C3DStockSubassemblyScripts.codes). For more information, see Adding a New Code
to the AutoCAD Civil 3D Stock Subassemblies (page 1581).
3 Select a point, link, or shape on the subassembly.
4 To see the code, in Toolspace, on the Prospector tab, right-click the subassembly and select Properties.
Click the Codes tab. The code added is displayed in the Name column under the point, link, or shape
collections.
To remove codes from a subassembly created from a polyline
1 In the drawing, select the subassembly from which you want to remove the code.
2 Click Subassembly tab ➤ Modify Subassembly panel ➤ Remove Code
3 Click the point, link, or shape on the subassembly.
The code is removed from the subassembly.

Quick Reference
Ribbon
Subassembly tab ➤ Modify Subassembly panel ➤ Remove Code
Object Shortcut Menu
Right-click subassembly object ➤ Add Code
Command Line
AddSubassemblyCode
RemoveSubassemblyCodes
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Using Code Set Styles
Use code set styles to control the visual appearance of a code set (link, point, and shape codes). You can
create specific styles to use for the different aspects of an assembly or corridor.
Since subassemblies can be displayed in a number of objects, code set styles are applicable to those objects
as well. The following types of objects use code set styles:
■

Subassemblies

■

Assemblies

■

Corridors

■

Section views

An individual subassembly typically contains just a few points, links and shapes. Therefore, most subassemblies
typically contain a relatively simple code list. Since an assembly manages a group of subassemblies, the code
list for an assembly is comparatively larger. Furthermore, since a corridor can have multiple assemblies
applied within it, the code list becomes larger and complex. The same holds true for the section views.

Adding or Importing Codes to a Code Set Style
Add or import codes to a code set style. Both methods use the Codes tab of the Code Set Style dialog box.
Click the Add button to add a new or existing code, or use the Import Codes button to import codes from
a subassembly, assembly, or corridor object.
To add a code to a code set style
1 In Toolspace, on the Settings tab, expand the General collection, the Multipurpose Styles collection,
then the Code Set Styles collection, and right-click an existing style.
2 Click either Copy or Edit.
3 In the Code Set Style dialog box, click the Codes (page 1999) tab.
4 Right-click a code collection (one of Link, Point, or Shape) in the Name column. Click Add.
5 In the Pick Style dialog box, select a style for the code.
6 In the Name column, click NEW CODE, enter the name of the code you want to add, and press Enter.
7 Click Apply.
To import codes to a code set style
1 In Toolspace, on the Settings tab, expand the General collection, the Multipurpose Styles collection,
then the Code Set Styles collection, and right-click an existing style.
2 Click Copy or Edit.
3 In the Code Set Style dialog box, click the Codes (page 1999) tab.
4 Click Import Codes.
5 In the drawing, click on a subassembly, assembly, or corridor object, and press Enter. The codes are
automatically displayed in the Codes tab list.
6 Click Apply.
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Quick Reference
Toolspace Shortcut Menu
Settings tab: General collection ➤ Multipurpose Styles collection ➤ Code Set Styles collection ➤
Right-click <style name>
Dialog Box
Codes tab (Code Set Style) (page 1999)

Copying or Editing Code Set Styles
Use the Settings tree to copy or edit a code set style by clicking an existing style, making modifications and
then saving it with a new name.
To copy, edit, or create a code set style
1 In Toolspace, on the Settings tab, expand the General collection, the Multipurpose Styles collection,
then the Code Set Styles collection, and right-click an existing style.
2 Click Copy or Edit.
3 In the Code Set Style dialog box, click the Information (page 1999) tab and enter a new name and
description for the code set style.
4 Click the Codes (page 1999) tab to define styles for each link, point (marker), or shape code associated
with this code set.
5 Click Apply.
To edit a corridor’s code set style
This procedure describes how to change the code set style assigned to a corridor. To edit a code set style, see
To copy, edit, or create a code set style (page 1578).
1 Do one of the following:
■

In Toolspace, on the Prospector tab, expand the Corridors collection, and right-click an existing
corridor. Click Properties, and then click the Codes tab.

■

In the ribbon, click Modify ➤ Corridor. In the Modify Corridor panel, click the down arrow, select
Edit Code Set Styles, then select a corridor.

■

In the drawing, right-click a corridor, and select Properties. On the Corridor Properties dialog box,
click the Codes tab.

2 Click the drop-down arrow next to the Code Set Style, and select a new code set style.
3 Click Apply.

Quick Reference
Toolspace Shortcut Menu
Settings tab: Right-click <code set style item>
Dialog Box
Code Set Style (page 1999)
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Copying or Editing Link Styles
Use the Settings tree to copy or edit a link style by clicking an existing style, making modifications and then
saving it with a new name.
To copy or edit a link style for subassembly links
1 In Toolspace, on the Settings tab, expand the General collection, the Multipurpose Styles collection,
then the Link Styles collection, and right-click an existing style.
2 Click Copy or Edit.
3 In the Link Style dialog box, click the Information (page 2004) tab and enter a new name and description
for the link style.
4 To define the display properties for the link style, click the Display (page 2004) tab and specify the display
properties for the link.
5 To view a summary of information about the style, click the Summary (page 2004) tab.
6 Click Apply.

Quick Reference
Toolspace Shortcut Menu
Settings tab: Right-click <link style item>.
Dialog Box
Link Style (page 2004)

Copying or Editing Marker Styles
Use the Settings tree to copy or edit a marker style for subassembly points by clicking an existing style,
making modifications and then saving it with a new name.
To copy or edit a marker style for subassembly points
1 In Toolspace, on the Settings tab, expand the General collection, the Multipurpose Styles collection,
then the Marker Styles collection, and right-click an existing style.
2 Click Copy or Edit.
3 In the Marker Style dialog box, click the Information Tab (Marker Style Dialog Box) (page 2004)tab and
enter a new name and description for the marker style.
4 To define the symbol used to display markers, click the Marker (page 2004) tab and specify the type of
symbol, as well as the size, scaling and rotation, for the marker symbol.
5 To define the display properties for the marker style, click the Display (page 2005) tab and specify the
display properties for the marker.
6 To view a summary of information about the style, click the Summary (page 2005) tab.
7 Click Apply.
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Quick Reference
Toolspace Shortcut Menu
Settings tab: Right-click <marker style item>
Dialog Box
Marker Style (page 2004)

Copying or Editing Shape Styles
Use the Settings tree to copy or edit a shape style by clicking an existing style, making modifications and
then saving it with a new name.
To copy or edit a shape style for subassembly shapes
1 In Toolspace, on the Settings tab, expand the General collection, the Multipurpose Styles collection,
then the Shape Styles collection, and right-click an existing style.
2 Click Copy or Edit.
3 In the Shape Style dialog box, click the Information (page 2006) tab and enter a new name and description
for the shape style.
4 To define the display properties for the shape style, click the Display (page 2006) tab and specify the
display properties for the shape.
5 To view a summary of information about the style, click the Summary (page 2006) tab.
6 Click Apply.

Quick Reference
Toolspace Shortcut Menu
Settings tab: Right-click <shape style item>
Dialog Box
Shape Style (page 2006)

Localizing or Modifying Subassembly Codes
For localization purposes, the AutoCAD Civil 3D stock subassemblies use an external codes file to define the
point, link, and shape codes referenced in the subassemblies.
The external codes file is named C3DStockSubassemblyScripts.codes and is located in the same folder as the
C3DStockSubassemblyScripts.dvb file and/or C3DStockSubassemblies.dll file. By default, on English-language
based systems, this location is typically C:\Documents and Settings\All Users\Application
Data\Autodesk\C3D2011\enu. For non-English-language-based systems, the “enu” location corresponds
to the appropriate language or region.
The codes file is associated with each subassembly with the CodesSpecific module in the .dvb file. The
following sections explain the definition of the code files and how to edit it or add point, link, and shape
codes to it.
The CodesSpecific module is in the CodesSpecific.vb file of the C3DStockSubassemblies VB project in the
case of .NET subassemblies, and in the .dvb file in the case of VBA subassemblies.
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Understanding the C3DStockSubassemblyScripts.codes File
You can open the C3DStockSubassemblyScripts.Codes file with any text editor. Add comments in this file
by adding // in front of a sentence. Do not leave any blank lines in the file. Each code line is separated with
a return character. Each code definition is comprised of the following components, separated by commas:
■

Index Number: An integer value used (for a point, link, or shape as required) to assign a label to the
subassembly module.

■

Localized Code: The value that will be displayed AutoCAD Civil 3D in your Subassembly, Assembly, and
or Corridor Properties Codes tab, and is used to set the style for the link.

■

Original Code: The code variable used by AutoCAD Civil 3D. No matter what localized version of the
subassembly is used, it is interpreted the same way to make drawings portable across different language
versions.

■

Code Description: A localized description to further explain the functionality associated with this code.
This text is displayed in the Description column of the Codes tab on the subassembly, assembly, and or
corridor properties dialog box. This text is optional.

NOTE Codes files must be saved in Unicode format. For example, if you are using Notepad to update the codes
file, when you save the file, the Save As dialog box lets you choose an encoding method. Make sure you choose
Unicode.
The following is an example of a code definition line in the C3DStockSubassemblyScripts.codes file:
38,BottomCurb,BottomCurb,Bottom of curb for a curb without gutter.

The Index number is: 38
The Localized Code is: BottomCurb
The Original Code is: BottomCurb
The Code Description is: Bottom of curb for a curb without gutter.

Modifying Default Codes for AutoCAD Civil 3D Stock Subassemblies
To change or localize code display names, open the C3DStockSubassemblyScripts.codes file in a text editor
and change the Localized Code and or corresponding code description.
For example, the display name of the Curb Bottom can be changed by editing the following bolded
components in the C3DStockSubassemblyScripts.codes file as follows:
38,BottomKerb,BottomCurb,Bottom of kerb for a kerb without gutter

Adding a New Code to the AutoCAD Civil 3D Stock Subassemblies
If you want to modify existing subassemblies to new codes, or add a new subassembly module, and you
would like to use the same structure as default content, for .NET subassemblies you can do the following:
1 Add <New Code> at the end of the C3DStockSubassemblyScripts.Codes file, with a new index, localized
name, original code, and optional description.
2 In the CodesSpecific.vb of the C3DStockSubassemblies VB project, add the following at the end of the
AllCodes structure: Public <New Code> as CodeType
3 In the CodesSpecific.vb of the With/End With block of the FillCodeStructure routine, add the following
at the end: GetFromCollection colCodesAndDescriptionHashtable, n, .<NewCode>
4 Declare the default value, in case the codes file is not found, for the CodesDefault(<New Code Index>)
in InitializeDefaults() function of the CodesSpecific module.
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5 Change the size of array CodesDefault in the CodesSpecific module in the Dim statement.
A new code added using these procedures can be used for any existing or new .NET-coded subassemblies in
AutoCAD Civil 3D Stock Subassemblies.
For VBA subassemblies, you can do the following:
1 Add <New Code> at the end of the C3DStockSubassemblyScripts.Codes file, with a new index, localized
name, and optional description.
2 In the CodesSpecific module of C3DStockSubassemblyScripts.dvb file, add the following at the end of
the AllCodes structure: g_s<New Code> as CodeType
3 In the CodesSpecific file, in the With/End With block of the FillCodeStructure routine, add the following
at the end: GetFromCollection colCodesAndDescriptionHashtable, n, .g_s<NewCode>
4 Declare the default value, in case the codes file is not found, for the g_arrDefaults(<New Code Index>)
in InitializeDefaults() function of the CodesSpecific module.
5 Change the size of array g_arrDefault in the CodesSpecific module.
A new code added using these procedures can be used for any existing or new VBA-coded subassemblies in
AutoCAD Civil 3D Stock Subassemblies.
NOTE The process of associating point codes is primarily done for easy localization of default content. If you are
writing custom subassemblies, you do not have to follow this procedure. You can create a new module that
contains a customized list of codes your subassemblies can reference. You can also bypass this process by
hard-coding strings locally within each module.

Localizing Subassembly Catalogs and Tool Palettes
The default subassemblies are generally defined for a wide range of clients and geographical regions. You
may want to change some of the display names of catalogs, palettes, tools, or tool variables as applicable to
various situations and languages. These catalogs and tool palettes are composed in XML format, in .atc files,
and can be edited.
NOTE By default, on English-language-based systems, the AutoCAD Civil 3D subassembly tool catalog .atc files
are installed to C:\Documents and Settings\All Users\Application Data\Autodesk\C3D2011\enu\Tool
Catalogs\Road Catalog.
The following list identifies the data element values you can change in the subassembly tool catalog .atc file
for localization purposes:
■

The <ItemName> value is the descriptive name of the catalog, category, palette, or subassembly.

■

The <Description> value describes the catalog, category, palette, or subassembly.

■

The <Keywords> value contains a help string for subassemblies.

■

The following attributes of the <Params> data element:

■

■

DisplayName: Name displayed in the AutoCAD Properties window for a selected subassembly.

■

Description: Descriptive text that is displayed at the lower left corner of the AutoCAD Properties
window for a selected subassembly.

The following data element values can be changed if needed:
■

The parameter values (such as Width in BasicLane subassembly) for any sub-element in <Params>.

■

The <Units> value which supports feet and meters in AutoCAD Civil 3D.
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■

The <DotNetClass Assembly = ...> (for .NET subassemblies), which can be modified to point to a
different .NET class.

■

The <Macro Module = ...> (for VBA subassemblies), which can be modified to point to a different
macro.

NOTE Only the values of a data element should be changed, not the data element name itself (such as Width in
the BasicLane subassembly). These data elements are global variable names that are used in subassembly scripts.

Installing Country Kits, Customized Codes Files, or Locale-specific Codes Files
If you plan to install a country kit that contains a region-specific codes file, or, if you plan to install (use) a
codes file that contains region-specific content, you must do the following before installing the country kit,
or before installing the customized codes file.
Make a backup copy of the region-specific or customized codes file, rename it to the default name of your
installed codes file (for example, for English version products, the default codes file is named
C3DStockSubassemblyScripts_US.codes) and copy it to the following location: C:\Documents and Settings\All
Users\Application Data\Autodesk\C3D2011\enu. For non-English-language based systems, the “enu”
location should correspond to the appropriate locale.
Note that when AutoCAD Civil 3D is first installed on a new machine, the following two versions of the
codes file are installed:
■

C3DStockSubassemblyScripts.codes

■

C3DStockSubassemblyScripts_US.codes

The C3DStockSubassemblyScripts_<locale>.codes file (in this example, C3DStockSubassemblyScripts_US.codes)
is installed to provide a backup mechanism for securing codes file content.
When a country kit that contains a region-specific codes file is installed, the localized codes file is installed
to C3DStockSubassemblyScripts.codes overwriting the existing file, and a copy is made at
C3DStockSubassemblyScripts_<locale>.codes. If you have modified your C3DStockSubassemblyScripts.codes
file, this is why it is important to make a backup of it before installing the country kit, or locale-specific
codes file.

Troubleshooting Codes File Issues
If you are experiencing unexpected results when using customized subassemblies, or when performing certain
AutoCAD Civil 3D corridor modeling tutorials, this may be due to the drawing attempting to reference codes
file information that it cannot find. In some cases, these issues can be resolved by updating your existing
codes file so that it contains the necessary information.

Assembly and Subassembly Command Reference
You can use these commands to quickly access assembly and subassembly functionality.
The following table lists the assembly- and subassembly-related AutoCAD Civil 3D commands and briefly
describes their functionality.
Command

Description

AddAssemblyOffset

Adds an offset assembly to an existing assembly (page
1544)
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Command

Description

AddSubassemblyCode

Adds a code to a subassembly created from a polyline
(page 1576)

ContentBrowser

Displays the Content Browser (page 123)

ConvertVBASAsToDotNET

Converts VBA subassemblies to .NET (page 1403)

CopySubssemblyTo

Copies a subassembly to or within an assembly (page
1541)

CreateAssembly

Creates an assembly (page 1542)

CreateSubAssemblyTool

Creates a subassembly from a tool palette (page 1558)

CreateSubFromPline

Creates a subassembly from a polyline (page 1559)

ImportTools

Imports subassemblies to a palette or catalog (page 1565)

MirrorSubssembly

Mirrors the selected subassembly or subassemblies
within an assembly (page 1541)

MoveSubssemblyTo

Moves a subassembly to or within an assembly (page
1541)

RemoveSubassemblyCodes

Removes a code from a subassembly created from a
polyline (page 1576)

SubassemblyClearOffset

Returns a moved subassembly to its insertion point in
an assembly (page 1558)

SubassemblyModifyHook

Changes the attachment point for polyline subassemblies
(page 1558)

ToolPalettes

Displays the Tool Palettes window (page 121)
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Intersections and
Roundabouts

34

This chapter describes how to use the intersection and roundabout design features in AutoCAD Civil 3D.

Intersections
This chapter describes how to use the intersection design features in AutoCAD Civil 3D.
You can use AutoCAD Civil 3D intersection design features to automatically create flexible 3D models of
corridor intersections.
Intersection Design Workflow (page 48)

Understanding Intersections
An intersection object builds on and manages various object data, including alignments, profiles, corridors,
assemblies, subassemblies, and surfaces.
In its simplest form, an intersection object can be created by selecting the location where two alignments
intersect. This automatically creates an intersection object in the drawing, and this intersection object is
also displayed in the Prospector tree.
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Another approach to creating intersections is to first create roadway alignments, offset alignments, and
profiles. Once these preliminary design items are in place, you can create an intersection object that utilizes
the 3D aspects of these road design geometry components.
Intersections are created from and based on existing AutoCAD Civil 3D objects, which include:
■

Alignments (horizontal). Used by an intersection to define the centerlines of the two roads that intersect.
Three types of alignments are used in intersections: centerline alignments, offset alignments, and curb
return alignments. The centerline and offset alignments are used to define the horizontal geometry
aspects of an intersection object.

■

Profiles (vertical alignments). Used to define surface and design elevations along a horizontal alignment.

■

Surfaces. Used to build surface profiles, and for corridor grading in an intersection.

■

Corridors. A corridor can be built automatically to represent the 3D aspects of the intersection. You can
also add to this new corridor information to an existing corridor on the intersecting alignment(s).

■

Assemblies. Roadway assemblies are required to build a corridor representing the intersection. To build
an intersection corridor, you must be able to access appropriate assemblies to build the intersection
model. AutoCAD Civil 3D comes with a set of default intersection assemblies that you can use, or you
can create your own custom assemblies that have been designed specifically to suit the needs of
intersections you create.

■

Assembly set. An intersection corridor requires an assembly set, which is a set of assemblies that are
designed specifically for a specific type of intersection design. The assemblies included in an assembly
set are defined in an .xml file that is referred to as the assembly set file. A default assembly set and
assembly set file is included with AutoCAD Civil 3D. You can create an intersection using this default
assembly set, or you can create your own custom assembly sets.

■

Subassemblies. Subassemblies define the geometry of a corridor section (through an assembly). For
example, a typical roadway may be composed of paved lanes on either side of a centerline, a paved
shoulder, a gutter and curb, and a roadside grading. These components are defined independently as
subassemblies. You can add any type of subassembly to make up a typical assembly, and then apply that
assembly for a station range along an alignment.

Intersection objects have their own display style that controls the intersection object marker. Intersection
components, such as offset alignments, curb return alignments, and corridors, also each have their own
display styles. Before creating intersections, you should be familiar with creating and managing styles (page
66) and command settings (page 114). For more information on intersection styles, see Intersection Styles
and Display (page 1588).
Intersection Object Considerations
It is important to understand the following before you begin creating intersections:
■

Using the Create Intersection wizard, you can create an intersection object that contains up to four
quadrants.

■

If the default intersection assembly mapping and target assignments does not meet your design
requirements, you can create the intersection using these components, and then edit the intersection
regions manually to satisfy your design requirements.

■

If you create an intersection, and then manually edit the intersection corridor regions, those changes
will be overwritten if the intersection is regenerated (by clicking Recreate Corridor Regions on the
Intersection tab) or by rebuilding the intersection.

■

When creating an intersection, targeting (both horizontally and vertically) is done automatically. If you
want to change targets, you must manually modify the intersection corridor region(s) using the Corridor
Properties dialog box.
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■

Typically, when an intersection object is created, the following objects are automatically added to the
current drawing: intersection object, corridor(s), assemblies, subassemblies, offset alignments, and curb
return alignments. However, assemblies, subassemblies, corridors, and profiles are only added if the
appropriate options are selected.

The Intersection Object
Intersection objects persist in an AutoCAD drawing as objects with the type AeccIntersection.
The intersection object allows you to create a 2D or 3D dynamic model of a T-shaped (3-way) intersection,
or a four-way intersection.

Before creating an intersection object, you must have two alignments that intersect. If you want to create a
three-dimensional intersection model, you must also have profiles associated with the intersecting alignments.
Once you have the desired prerequisites, then you can create the intersection object using the Create
Intersection wizard.
When the intersection object is created, a variety of tasks can be performed automatically, including the
following:
■

creates offset alignments for the roads included in the intersection

■

creates curb return alignments (curb returns) in the intersection area

■

creates profiles for the offset alignments and curb return alignments created when the intersection was
created (Note: An exception to this is that if you set pre-defined static alignments as offsets, it is expected
that you will specify profiles too. No dynamic offset profiles will be created.)

■

creates new corridor regions for the existing corridors in the intersection area, or creates new corridor
objects in the intersection area

■

locks the profile elevations of the secondary road to the main (primary) road profile

Some of these tasks are optional. They depend on options selected on the wizard dialog boxes.
For overview information about AutoCAD Civil 3D objects, see Understanding Objects and Styles (page 63).
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Intersection Styles and Display
Intersection object display style is controlled both by a specific intersection object style, and the styles and
labels associated with the objects used to create the intersection, such as the intersecting alignments.
Use the intersection object style to control the appearance of the intersection object marker. For more
information, see Intersection Style Dialog Box (page 2170).
Other components associated with an intersection, such as offset alignments, curb return alignments, and
profiles, each have their own object style to control their appearance.
Similarly, when you have corridor objects associated with the intersection, various components within the
corridor are controlled by their own display styles and labels. For more information, see Corridor Styles and
Display (page 1473).
To set default styles for components that are created through the intersection creation command, use the
default styles collection in command settings. For more information, see Changing Intersection-Related
Default Style Settings (page 1600).
The following table lists the components of the intersection and where they derive their styles from.
Intersection
Component

Display Style

Notes

Main and secondary road alignments

Alignment style

Defined in the existing alignment style

Offset alignments

Offset alignment style

Defined in the Create Intersection command settings

Curb returns

Curb return alignment style

Defined in the Create Intersection command settings

Offset profile

Curb return alignment style

Defined in the Create Intersection command settings

Curb return profile

Curb return alignment style

Defined in the Create Intersection command settings

For more information about styles, see Object and Label Styles (page 66).

Intersection Collection (Prospector Tab)
Use the Intersection collection in the Prospector tree to access the intersection objects in a drawing. As
intersection objects are created, they are displayed in the Intersections collection.
Expand the Intersections collection to view the names of the intersection objects included in the drawing.
Expand an intersection object to display the Intersecting Alignments collection and the Intersection Quadrants
collection. Click either of these collections to display a tabular list of the components in the Prospector list
view. For more information, see The Toolspace Item View (page 99).

Intersecting Alignments Collection
Use the Intersecting Alignments collection in the Prospector tree to access the alignments included in the
intersection object.
Expand the Intersecting Alignments collection to view the names of the alignments included in the
intersection. You can also click this collection to display the alignments in the Prospector list view. You can
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edit the alignment style or assign a different profile using this view. For more information, see The Toolspace
Item View (page 99).

Exploring Intersection Alignments in Prospector
Another feature available from the Intersecting Alignments collection is the Explore In Prospector command.

To use this command, right-click an alignment in the Intersecting Alignments collection, and select Explore
In Prospector.
The same alignment is automatically displayed and selected in under the Alignments ➤ Centerline
Alignments collection of the Prospector tree. Use this command to quickly find the location of an intersecting
alignment in the Prospector tree.

The Explore In Prospector command is available for centerline alignments, offset alignments, and curb return
alignments, and is available from the Intersecting Alignments collection as well as from the Intersection
Quadrants collection.

Intersection Quadrants Collection
Use the Intersection Quadrants collection in the Prospector tree to access details about the quadrants in the
intersection object.
Expand the Intersection Quadrants collection to view the names of the quadrant included in the intersection.
This collection also displays the names of the curb return alignments for each quadrant. You can also use
this collection to display the names of the incoming and outgoing lane centerlines in the Prospector list
view. The list view also displays the value of the intersecting angle between the incoming and outgoing lane
centerlines. For more information, see The Toolspace Item View (page 99).
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Right-clicking an intersection quadrant name in Prospector lets you do the following:
Item

Description

Edit Curb Return Parameters

Displays the Intersection Curb Return
Parameters dialog box. You can change
the quadrant name, or edit the curb return
type and geometry (such as simple curve
type). You can also add widening, or edit
widening parameters.

Edit Curb Return Profile Rules

Displays the Intersection Curb Return Profile Parameters dialog box. You can change
whether to extend the profile along the
incoming or outgoing lanes, and also
change the length by which to extend the
profile. Editable parameters have a white
background in the Value column, while
read-only parameters have a shaded background.

Recreate Corridor Regions

Recreates corridor regions for the currently
selected intersection. It is important to note
that using this option removes any manual
edits that may have been made to the intersection corridor.

Refresh

Refreshes the display of items displayed in
Prospector.

Intersection Collection (Settings Tab)
Use the Intersection collection in the Settings tree to manage intersection object settings, including
intersection object styles, label styles, and command settings.
An intersection object has its own display style that controls the appearance of the intersection object marker.
Components included within the intersection object, such as alignments, profiles, corridors, and so on, each
have their own display styles.
An intersection object style controls the intersection object marker appearance. For more information, see
Intersection Style Dialog Box (page 2170).
Right-click the Intersection collection to do the following:
■

Edit the intersection feature settings. (page 1598)

■

Edit Intersection Label Style Defaults

■

Refresh the display of the settings tree.

Expand the Intersection collection to display and edit the intersection object style, label styles, and command
settings that are available for the intersection feature.

Creating Intersections
You can create an intersection using the Create Intersection wizard.
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Before You Begin
Before you can create a simple intersection, you must have at least two alignments that intersect each other
only once in your drawing.

Creating a Simple 2D Intersection
The simplest way to create a basic two-dimensional intersection object is to start with two alignments that
intersect each other only once. You cannot use the Create Intersection wizard if the alignments do not
intersect.
If your drawing has two intersecting alignments that meet this criteria, you can create a basic 2D intersection
object using the Create Intersection wizard. Simply start the command, follow the prompts, and accept the
default choices on the wizard dialog boxes.

Creating a 3D Intersection with Corridor Objects, Alignments, and Profiles
To create a 3D intersection that includes a corridor, you will need to first create the road geometry (road
centerline alignments and profiles) and existing ground surface in your drawing. Once these components
exist in the drawing, you can proceed with using the Create Intersection wizard. The wizard prompts you
to select the location in the drawing where the two road centerline alignments intersect.
You can start with the following data combinations:
■

two intersecting centerline alignments

■

two intersecting centerline alignments with one or more road edge offset alignments and or their profiles

You can have profiles defined already, or not. However, if profiles are not available, then features that are
associated with 3D modeling will not be available on the wizard. For example, if you begin creating an
intersection object with no profiles, then the following wizard options will not be available for selection:
creating offset alignment and curb return profiles, as well as the ability to create a new corridor, or to add
to an existing corridor in the intersection area.
With any of the scenarios just described, you can start the Create Intersection command, select the point
where the centerline alignments intersect, and proceed with creating an intersection using the Create
Intersection wizard.
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If you need more information about creating the underlying objects required for creating 3D intersections,
you can refer to the following table.
For information about creating...

See...

Alignments

Creating Alignments (page 948)

Profiles

Creating Layout Profiles (page 1143)

Corridors

Creating Corridors (page 1475)

Assemblies

Creating Assemblies (page 1541)

Assembly Sets

Assembly Sets (page 1619)

Subassemblies

Creating Subassemblies (page 1557)

Surfaces

Creating Surfaces (page 648)

Setting Driving Direction
The Driving Direction option determines the direction in which curb returns are drawn when an intersection
is created.
This setting should be set to Left Side of the Road when creating intersection objects for projects that have
vehicles traveling on the left side of the road; for example, in countries such as the United Kingdom. In this
case, curb return alignments in intersection objects are drawn starting on the left side of the outgoing road,
and ending on the left side of the merging road.
When set to Right Side of the Road, curb return alignments in intersections are drawn starting from the
right side of the outgoing road, and ending on the right side of the merging road.
NOTE You cannot change the “Driving Direction” setting on an intersection object that has already been created.
To set driving direction
1 In Toolspace, on the Settings tab, right-click the name of the drawing at the top of the Settings tree
collection, and click Edit Drawing Settings.
2 Click the Ambient Settings tab, and expand the General collection.
3 Next to Driving Direction, click in the Value cell and select Left Side of the Road or Right Side of the
Road.

Quick Reference
Dialog Box
Ambient Settings Tab (Drawing Settings) (page 2078).

Using the Create Intersection Wizard
To use the Create Intersection wizard, make sure you have the required data in your drawing before you
begin.
As a minimum, you must start with a drawing that has two alignments that each have profiles and station
data associated with them.
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NOTE If you are creating a T-shaped (3-way) intersection, you must ensure that the alignments snap together
precisely and do not overlap. If there is any overlap between the two alignments, a 4-way intersection will be
created.
To create an intersection using the Create Intersection wizard
1 Do one of the following:
■

Click the Home tab ➤ Create Design panel ➤ Intersection

■

At the command line, enter CreateIntersection.

.

You are prompted to pick an intersection point in the drawing.
NOTE If you wish to create a 3-way intersection, it is important that the alignments meet precisely and do
not overlap or undershoot. If the two alignments overlap, a 4-way intersect is created.
2 In the drawing, click the location in the drawing where two alignments intersect.
3 If you are creating a 4-way intersection, you will be prompted to select the alignment that will be
identified as the primary road. If so, select the alignment by clicking the alignment in the drawing, or
by pressing Enter and selecting from the list of alignments in the drawing.
If you are creating a T-shaped (3-way) intersection, then the alignment that passes through the
intersection is automatically specified as the primary road (main road). In this situation, you are not
prompted to specify which road is the primary road because this happens automatically. It is possible
to change the road priority only during intersection object creation (on the Geometry Details page of
the Create Intersection wizard). For more information, see Changing Road Priority (page 1595).
4 On the General page of the Create Intersection wizard, enter a name for the intersection object, or
accept the default. You can also enter an optional description, and change defaults for marker styles,
layer, and labels.
5 For the Intersection Corridor Type, select one of the following to specify the corridor grade options
through the intersection area:
■

Primary Road Crown Maintained: When this options is selected, the primary road crown is maintained
through the intersection.

■

All Crowns Maintained: When this options is selected, the crowns of both roads included in the
intersection are maintained through the intersection.

An illustration at the bottom of the wizard dialog box provides a conceptual graphic of the grade type
selected.
6 Click Next to proceed to the next page of the wizard.
7 On the Geometry Details page, you may accept or change the defaults. For example, if desired you can
perform the tasks listed in the following table:
To perform this option...

do this...

Change the alignment priority

Select an alignment in the list and click the
arrows. For more information, see Changing Road Priority (page 1595).

Select different profiles for the alignments

Select an alignment in the list and click in
the Profile cell to select a profile from the
drop-down list of available profiles in the
current drawing.
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To perform this option...

do this...

Choose to create or not create offset
alignments and curb returns for the intersection

Place or remove the check mark from the
appropriate box on this wizard dialog box.

Change parameters for the offset alignments, curb returns, lane slopes, curb return profiles

Click the appropriate Parameters button
on this wizard dialog box.

8 By default, new offset alignment objects will be created. However, if you want to specify an existing
offset alignment from the drawing, click the Offset Parameters button, set Use An Existing Alignment
to Yes, and select the alignment by clicking

next to the Alignment Name property.

9 When you are finished configuring the Geometry Details page, click Next to proceed to the next page
of the wizard.
10 On the Corridor Regions page, you may accept or change the defaults. For example, if desired you can
perform the tasks listed in the following table:
To perform this option...

do this...

Create or not create a new corridor in the
intersection area

Add or remove the check mark next to this
option. For more information, see Creating
Corridors in the Intersection Area (page
1597).

Add to an existing corridor

Select this option. If you do not have corridor objects in the drawing, this option is
not available. For more information, see
Creating Corridors in the Intersection Area
(page 1597).

Select a surface to daylight

If a surface is available in the current
drawing, you can select a surface to daylight. However, you cannot target a surface
that is an output of another corridor.

Select an assembly set to import

Click Browse, select the assembly set, then
ensure the assembly set is selected using
the drop-down arrow under Select Assembly Set To Import. For more information, see Assembly Sets (page 1619).

Select different assemblies

If the desired assembly objects exist in the
current drawing, you can select different
assemblies by c licking
in the Assembly
To Apply column. Otherwise, accept the
default assemblies specified.

11 Click the items listed under Corridor Region Section Type, and notice that the conceptual graphics
update with each selection. The location where the assembly will be applied along the intersection is
highlighted in the conceptual graphic.
12 Click Create Intersection. The intersection is created.
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Quick Reference
Ribbon
Home tab ➤ Create Design panel ➤ Intersection
Command Line
CreateIntersection
Dialog Box
Create Intersection Wizard (page 2145)

Changing Road Priority
When you create an intersection object, a Priority value is assigned to the main (primary) and secondary
(side) road alignments .
The following table lists the value of the Priority property:
Road (alignment)

Priority

Main (primary) road alignment

1

Secondary road alignment

2

If you are creating a T-shaped (3-way) intersection, then the alignment that passes through the intersection
is automatically specified as the primary road (main road). In this situation, the Priority is automatically set
to a value of 1 for that alignment, and you are not prompted to specify which road is the primary road
because this happens automatically.
You cannot change the priority of a road in an intersection after it has been created. However, if you want
to change the priority of the alignments during the intersection creation, you can do so from the Geometry
Details page of the Create Intersection wizard.
It is also important to note that typically, the secondary road (or lower priority) profile is automatically
locked at the intersection location to the elevation of the main road (higher priority) main road. The profile
of the main road is not modified.
To change road (alignment) priority during intersection creation
1 Click the Home tab ➤ Create Design panel ➤

Intersection.

2 Advance to the Geometry Details page of the Create Intersection wizard.
3 At the top of this dialog box, in the Intersecting Alignments section, select the road (alignment) you
want to change by clicking the name of the alignment in the list.
4 Click the up or down arrow to change the road priority.
NOTE Once the intersection object is created, you cannot change the value of the road priority for an
alignment.
5 Continue creating the intersection. For more information, see Using the Create Intersection Wizard
(page 1592).
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Quick Reference
Dialog Box
Geometry Details Page (Create Intersection Wizard) (page 2147)

Intersection Corridor Type
In AutoCAD Civil 3D, the Intersection Corridor Type property identifies the type of grading that will be
applied to roads in an intersection object.
There are two types of intersection grading options that are available with AutoCAD Civil 3D intersection
objects: Primary Road Crown Maintained and All Crowns Maintained. You must specify this type when you
create the intersection, on the General page of the Create Intersection wizard.
For existing intersections, the intersection corridor type is displayed on the Intersection Details tab of the
Intersection Properties dialog box, in the Intersection Quadrants section. You can set the creation default
for this option on the Edit Command Settings - CreateIntersection dialog box (page 2159).
Once the intersection is created, you cannot change the value of the Intersection Corridor Type property.
If you do want to change this option after the intersection object is created, you must delete the intersection
object, and create a new one with the desired Intersection Corridor Type.

Primary Road Crown Maintained
In this type of intersection, the crown of the primary road is maintained, while the crown (profile) of the
secondary road is adjusted to match the edge of the primary road and the intersection point. The crown
(profile and edges) of the primary road are not affected.
The following conceptual graphic is displayed on the wizard dialog when you select this option:

This represents how the grading occurs for the intersection object.

All Crowns Maintained
In this type of intersection, the profile of the side road is adjusted to match the main road elevation at the
intersection point. The main road profile is not affected. The edges are blended together along the curb
returns (via the curb return profiles).
The following conceptual graphic is displayed on the wizard dialog when you select this option:

NOTE Once an intersection object is created, you cannot change the value of the intersection Corridor Type
property.
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Creating Corridors in the Intersection Area
You can choose to create corridor objects within intersections, or add to existing corridors. You can also
choose not to have corridor objects in the intersection.
In order to create the intersection corridor, the following must have already been done:
■

Side road profile matching

■

Creation or selection of offsets and profiles

■

Creation of curb returns and profiles

If the above items have not been met, then the create corridor options on the Create Intersection wizard
dialog box are not available.
The following table describes the options that are provided through the Create Intersection wizard dialog
box:
Option

Description

Create a New Corridor

Specifying this option creates a new corridor object in the intersection area.

Add to an Existing Corridor

Specifying this option lets you select an
existing corridor object in the drawing to
add to the intersection area.

No Corridors in the Intersection Area

When neither of the previouos two options
are selected, no corridor object are created
in the intersection area.

You can specify these options during intersection object creation, using the Create Intersection wizard, or
you can choose to edit these options after the intersection object has been created.
For example, you can select an existing intersection object, and click Recreate Corridor Regions from the
shortcut menu. This displays the Intersection Corridor Regions dialog box which lets you edit corridor
regions on the intersection. From this dialog box, you can change the options selected for corridor object
creation. After making changes on this dialog box, you need to recreate the corridor regions for the intersection
area.
To create a new corridor in the intersection during creation
This procedure describes how to create a new corridor in an intersection area during intersection object
creation.
1 Start the Create Intersection wizard by doing one of the following:
■

Click the Home tab ➤ Create Design panel ➤ Intersection

■

At the command line, enter CreateIntersection.

.

You are prompted to pick an intersection point in the drawing.
2 Configure the first two pages of the wizard as desired, and advance to the Corridor Regions page. For
more information, see Using the Create Intersection Wizard (page 1592).
3 On the Corridor Regions page, place a check mark in the Create Corridors in the Intersection Area check
box.
4 Select the Create a New Corridor option.
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5 Proceed with configuring the rest of the wizard options.
To add to an existing corridor in the intersection during creation
This procedure describes how to add to an existing corridor in an intersection area during intersection object
creation.
1 Start the Create Intersection wizard by doing one of the following:
■

Click the Home tab ➤ Create Design panel ➤ Intersection

■

At the command line, enter CreateIntersection.

.

You are prompted to pick an intersection point in the drawing.
2 Configure the first two pages of the wizard as desired, and advance to the Corridor Regions page. For
more information, see Using the Create Intersection Wizard (page 1592).
3 On the Corridor Regions page, place a check mark in the Create Corridors in the Intersection Area check
box.
4 Select the Add to an Existing Corridor option.
5 Select an existing corridor using the drop-down list or by picking from the drawing.
NOTE If you do not have corridor objects in the drawing, these options is not available.
6 Proceed with configuring the rest of the wizard options.
To create a new, or to add to an existing corridor in an intersection
This procedure describes how to edit an existing intersection object to either add a new corridor object to
it, or to add an existing corridor object to it.
1 Select an intersection object, and then click Recreate Corridor Regions.
The Intersection Corridor Regions dialog box is displayed.
2 On the Intersection Corridor Regions dialog box, select one of the following: Create a New Corridor or
Add to an Existing Corridor.
3 If you selected, Add to an Existing Corridor, select an existing corridor using the drop-down list or by
picking from the drawing.
NOTE If you do not have corridor objects in the drawing, this option is not available.
4 Configure the rest of the choices on this dialog box. For example, you may want to select a different
assembly set, or select different assemblies. For more information, see Intersection Corridor Regions
Dialog Box (page 2165).
5 To apply the changes, click the Recreate button on this dialog box.
NOTE Because this command deletes and recreates the corridors in the intersection, if you made any changes
to the corridors in the intersection object, those changes will be overwritten (discarded) when the new
corridors are created. For more information, see Recreating Corridor Regions in Intersections (page 1615).

Editing Intersection Settings
Use intersection settings to specify the default behavior for intersection-related commands.
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Settings are handled in a standard way throughout AutoCAD Civil 3D. You access settings using the Toolspace
Settings tree. You can control settings at three levels: the drawing level, the object collection (feature) level,
and the command level. For more information, see Understanding Settings (page 77).
In the Settings tree, use the Intersection collection’s shortcut menu to establish defaults for all
intersection-related commands. You can change intersection-specific settings at this level, or override the
drawing ambient settings.
Use the Commands collection in the Intersection collection to change intersection settings for a specific
command.
NOTE Overrides to the drawing ambient settings at the Intersection collection level and the Commands collection
level affect only the specified (and subordinate) levels. The drawing level settings are not changed.
The topics in this section describe only those settings that affect intersection-related commands. They do
not apply to the drawing ambient settings that you can change at the Intersection collection level. For more
information about the drawing ambient settings, see Specifying Ambient Settings (page 84).

Changing Intersection Creation Settings
Use the intersection creation and naming settings in the Edit Feature Settings - Intersections dialog box to
change intersection-related settings before you create intersections.
For example, before creating an intersection, you may want to specify the default frequency for inserting
assemblies along tangents, curves, or spirals. You may also want to set default parameters for curb returns,
widening, or curb return profiles.
If a closed lock icon
is displayed in the Lock column for a property, the property is locked at a higher
level of the Settings tree. It cannot be changed at this level.
If you change a property value, a check mark
is displayed in the Override column. This override is also
noted in the property table for related objects higher up the Settings tree, where an arrow is displayed in
the Child Override column.
To change intersection creation settings
1 Do one of the following:
■

To edit settings for all intersection-related commands: In Toolspace, on the Settings tab, right-click
the Intersection collection. Click Edit Feature Settings.

■

To edit settings for a specific command: In Toolspace, on the Settings tab, expand the Intersection
collection. Expand the Commands collection. Right-click the name of the command and click Edit
Command Settings. For example, right-click the CreateIntersection command and click Edit
Command Settings.

TheEdit Feature Settings - Intersection dialog box (page 2159) is displayed.
2 To specify defaults for intersection creation, right-click the CreateIntersection command and click Edit
Command Settings. For example, to edit default frequencies for inserting assemblies along tangents,
curves, and spirals, expand Assembly Insertion Defaults. For more information on intersection defaults,
see the Edit Feature Settings - Intersection (page 2159) dialog box.
3 To edit the default naming format for intersection data, expand the Default Name Format property
group. Edit the various name template settings.
4 Click Apply.
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Quick Reference
Toolspace Shortcut Menu
Settings tab: Right-click Intersection collection ➤ Edit Feature Settings
OR
Settings tab: Intersection ➤ Commands ➤ Right-click <command-name> ➤ Edit Command Settings
Dialog Box
Edit Feature Settings - Intersection (page 2159)

Changing Intersection-Related Default Style Settings
Use the intersection settings to specify default styles and labels for intersection creation and for certain
components that are create during intersection creation.
In addition to selecting a default style for the intersection object marker, you can also select default styles
for the following objects that can be created when an intersection object is created:
■

Intersection label

■

Offset alignment

■

Curb return alignment

■

Offset alignment profile

■

Curb return alignment profile

You can also create label sets for offset alignments and for curb return alignments.
The default styles specified for these components are used to establish the default styles that are used when
these items are created using the CreateIntersection command.
To change the intersection-related style and label settings
1 In Toolspace, on the Settings tab, right-click the Intersection collection. Click Edit Feature Settings to
open the Edit Feature Settings - Intersection dialog box (page 2159).
2 Expand the Default Styles property group.
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3 To specify a default style for intersection output objects, such as offset alignments, curb returns, and
profiles generated from intersections, click the corresponding field. Click
dialog box.
4 To specify a default intersection style, click Intersection Style. Click
box.

to open the Select Style

to open the Select Style dialog

5 To specify a default style for a label set, click the corresponding field. Click
Set dialog box.

to open the Select Label

6 Click Apply.

Quick Reference
Toolspace Shortcut Menu
Settings tab: Right-click Intersection collection ➤ Edit Feature Settings
Dialog Box
Edit Feature Settings - Intersection (page 2159)

Editing Intersections
There are a variety of ways that you can edit intersections.
You can edit intersections using commands available from the ribbon, from right-click shortcut menus, or
by editing the objects directly in the drawing using grips.
The following lists describe some of the ways that you may want or need to edit an intersection object after
it has been created.

Changes Managed by the Intersection Object
The following types of edits can be performed by making changes directly to components that are controlled
by the intersection object:
■

Change the parametric values of the intersection object definition, such as nominal offsets/ cross slopes,
curb return profile rules, and corridor regions

■

Change edge offsets from parametric (nominal offset) values to predefined alignments

■

Change edge offset profiles from parametric (nominal cross slopes) to predefined profiles

■

Change (intersection) rule-based dynamic offset alignments and dynamic profiles to static and then
make edits to them

■

Change association of assemblies to one or more of “dynamic corridor regions”

■

Change the frequency that the assemblies are applied to the dynamic corridor regions

Typically you will need to update corridor regions after making these types of edits to intersection objects.
When an update is necessary, an out-of-date icon
is displayed in Prospector for the corridors in the
intersection. If you have Update Regions Automatically turned on for the intersection object, then the
corridor regions are updated automatically after these types of edits. For more information, see Updating
Corridor Regions in Intersections (page 1614).
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Changes Not Managed by the Intersection Object
While you can make the above types of changes by manipulating components that are controlled by the
intersection object, it is also possible to make other types of changes that are not directly managed by the
intersection object. For example, you can make the following types of changes that are not managed by the
intersection object:
■

Change the intersection area corridor region extents and or add more regions within the intersection
extents

■

Change the corridor targets in the intersection for the edge offsets and profiles

■

Edit corridor parameters in the intersection area regions using the Corridor Section View Editor

Because these last three types of changes do not modify the intersection object definition, it is important
to understand that if you do make these types of changes, they could be overwritten or ignored if you update
the corridor regions in the intersection, or if you recreate the intersection.
NOTE When you edit the horizontal or vertical geometry of the intersection object, the road that is specified as
the secondary road is automatically adjusted to accommodate the horizontal and vertical position of the road that
is specified as the primary road.
The sections that follow describe how to make various types of edits to intersection objects.

Editing Basic Intersection Information
After creating an intersection, you can use the Prospector tree to edit basic intersection object information,
such as object name and description.
To edit basic intersection information
1 In Toolspace, on the Prospector tab, expand the
Click Properties.

Intersection collection. Right-click the intersection.

2 In the Intersection Properties dialog box, click the Information tab (page 2169).
3 To change the name of the intersection, enter a new name in the Name field.
4 To change the description of the intersection, enter a new description in the Description field.
5 To change the style of the intersection, click the Object Style list. You can also use the standard buttons
to create, edit, or select a style.
6 Click Apply to make the changes, or click OK to make the changes and close the Intersection Properties
dialog box.

Quick Reference
Toolspace Shortcut Menu
Prospector tab: Intersections ➤ <intersection name> ➤ Properties ➤ Information tab
Object Shortcut Menu
Intersection Properties
Dialog Box
Intersection Properties - Information tab (page 2169)
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Editing Intersection Properties
You can change the intersection object name, style, alignment profiles, and view details about the alignments
and quadrants in the current intersection using the Intersection Properties dialog box.
The Intersection Properties dialog box has the following tabs:
■

Information. Specifies intersection object name, description, and style.

■

Intersection Details. Displays information about the alignments and the quadrants included in the
intersection. This tab displays the names of the alignments, the station of the point of intersection, and
profile associated with each alignment. If multiple profiles are available, you can change the profile
associated with the alignment by clicking in the Profile cell and selecting a new profile from the drop-down
list. The Intersection Quadrants section displays the names of the alignments included in each quadrant,
and identifies incoming and outgoing alignments, as well as the value for the intersection angle between
the two alignments. This is for information only and cannot be edited in the properties dialog.

See also:
■

Intersection Properties dialog box (page 2169)

To change intersection object name, description, or the intersection marker style
1 Right-click an intersection in the drawing. Click Intersection Properties.
NOTE The tab most recently opened in the Intersection Properties dialog box is displayed by default.
2 In the Intersection Properties dialog box, click the Information tab (page 2169).
3 Under Name, enter a name for the intersection object.
4 Under Description, enter an optional description for the intersection.
5 In the Object Style list, select an existing intersection style. Note that this only affects the intersection
marker style.
6 Click the Style Detail button to open the Style Detail dialog box. Preview the intersection marker style.
To change the profile associated with an alignment
1 Right-click an intersection in the drawing. Click Intersection Properties.
NOTE The tab most recently opened in the Intersection Properties dialog box is displayed by default.
2 In the Intersection Properties dialog box, click the Intersection Details tab (page 2170).
3 In the Alignment Details section, click a profile name in the Profile column. Select a profile from the
drop-down list. If there are not multiple profiles in the drawing, no other profiles will be displayed.
4 Click Apply to apply the new profile.
5 After changing the profile, you may also need to rebuild the corridor, recreate corridor regions in the
intersection, or rebuild the intersection. For more information see Rebuilding Corridors (page 1517),
Recreating Corridor Regions in Intersections (page 1615), or Updating Corridor Regions in Intersections
(page 1614).
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Quick Reference
Toolspace Shortcut Menu
Prospector tab: Right-click <intersection item > ➤ Properties
Object Shortcut Menu
Right-click <intersection object> ➤ Intersection Properties
Command Line
EditIntersectionProperties
Dialog Box
Intersection Properties Dialog Box (page 2169).

Editing Intersection Styles
Use styles to control the visual display of each intersection component.
The intersection style controls the appearance of the intersection object marker. You can change the marker,
as well as display parameters such as visibility, layer, and color used in plan and model views.
Access intersection styles using these methods:
If you want to access intersection styles...

Then...

From the ribbon

Select an intersection ➤ Intersection
tab ➤ Modify panel ➤ Intersection Properties ➤ Edit Intersection Style

In the drawing

Right-click an intersection ➤ Edit Intersection
Style.

On the Settings tab in Toolspace

Right-click a style in the Intersection Styles folder
➤ Edit.

NOTE When you click New in a collection folder, the new style you create is based on installation defaults, not
on the existing styles in the collection. To create a style from an existing style, right-click the style. Click Copy and
save the style with a new name.
Use the tabs in the Intersection Style dialog box to set style information. For more information, see Intersection
Style Dialog Box (page 2170).
The following intersection components derive their styles from their own object styles: primary and secondary
road alignments, offset alignments, curb return alignments, profiles, corridors.
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Use the CreateIntersection command settings to set the default styles that will be used when creating some
of these components.

Intersection Editing Visual Cues
Visual cues help you edit intersection components quickly.
Many of the dialog boxes that allow you to create or edit intersection object components have visual behavior
built in to help you quickly identify the area of the intersection object being edited.
For example, editing dialog boxes, such as the Intersection Offset Parameters dialog box and the Intersection
Curb Return Parameters dialog box, contain the following behaviors:
Object Highlighting in Drawing: When you select some items on an intersection editing dialog box, the
affected object is highlighted in the drawing. For example, when you select an offset on the Intersection
Offset Parameters dialog box, that offset alignment is highlighted in the drawing. This behavior is displayed
in the following illustration.

The right side offset alignment named First Street is selected in the Intersection Offset parameters dialog
box, shown on the left. In the drawing, that offset alignment is highlighted.
Similarly, if you are editing intersection curb return parameters using the Intersection Curb Return Parameters
dialog box, each time you select a quadrant or curb return in this dialog box, the selected quadrant or curb
return is highlighted in the drawing.
The following illustration shows temporary arrows along the alignments that indicate the direction of
incoming and outgoing traffic. These arrows are displayed when you are specifying intersection curb return
parameters.
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Conceptual Graphics on Dialog Boxes: Each time you select a property or item to edit on intersection editing
dialog boxes, the conceptual graphic is displayed at the bottom of the editing dialog box updates to indicate
the location along the intersection affected by the edit.
For example, when you select the “Primary Road Full Section” corridor region on an intersection editing
dialog box, the following conceptual graphic is displayed, indicating the location of this region along the
corridor.

Similarly, when you select the “Primary Road Full Section” corridor region

This behavior also exists on the Create Intersection wizard dialog boxes.
Shading of Non-editable Properties: In editing dialog boxes, properties that are not editable are displayed
with a gray (shaded) background color. Properties that are editable are displayed with a white (not shaded)
background color.
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Editing Offsets in Intersections
There are several ways you can edit offset alignments in an intersection area.
You may need to edit offset alignments after an intersection is created. You can change the offset value, or
select a different alignment to use as the offset.
For example, you can use the Edit Offsets command on an existing intersection object to change the
parametric value of the intersection, or you can select a different offset alignment, using one from the current
drawing. You can also grip edit the dynamic offset alignment after it is created.
It is also possible to edit offsets for incoming and outgoing roads by editing the corridor parameters, although
this is not typically the preferred method. For example, the offsets can be changed by overriding offsets at
one or more stations, or by overriding target parameters for incoming and outgoing lanes.
Visual Cues: When you select an item on this dialog box, the affected object is highlighted in the drawing,
and the conceptual graphic on the dialog box updates to indicate the location of the edit. For more
information, see Intersection Editing Visual Cues (page 1605).
To edit offset alignments using the Edit Offsets command
This procedure describes how to widen a road by editing the offset alignment definition on an existing
intersection object.
1 Do one of the following:
■

In the drawing, click the intersection object. On the ribbon, click Edit Offsets
panel of the Intersection contextual tab.

on the Modify

■

In the drawing, right-click the intersection object, and then select Edit Offset Parameters from the
object shortcut menu.

■

In Prospector, expand the Intersections collection, right-click the intersection object, and then select
Edit Offset Parameters from the Toolspace shortcut menu.

2 On the Intersection Offset Parameters dialog box, expand the collection for the alignment you want
to edit.
Notice that when the Use An Existing Alignment property is set to No, the Alignment Name property
is read only. Notice also how the Offset Value property is set, and that it is currently editable.
3 Set the Use An Existing Alignment property to Yes, and notice that the Alignment Name property
becomes editable.
4 Click

to select another alignment from the current drawing.

Notice that the Offset Value is set to *Varies* if the alignment is not a dynamic offset alignment based
on a centerline. Otherwise, the Offset Value specifies the offset value of the attached dynamic alignment.
This control is disabled (read only) in both cases.
NOTE If you select another alignment in the Alignment Name field, the original offset alignment that was
created during intersection object creation is not deleted.
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To specify offset alignment width during intersection creation
This procedure describes how to widen a road by specifying a different offset alignment using the Create
Intersection wizard.
1 Do one of the following:
■

Click Home tab ➤ Create Design panel ➤ Intersection

■

At the command line, enter CreateIntersection.

.

2 Pick the intersection point in the drawing.
3 In the wizard, click Next to proceed to the Geometry Details page.
4 Click Offset Parameters.
5 On the Intersection Offset Parameters dialog box, expand the collection for the alignment you want
to edit.
6 Set the Use An Existing Alignment property to Yes, and notice that the Offset Alignment Name Format
property is replaced with the Alignment Name property.
7 In the Value field for the Alignment Name property, click
current drawing.

to select an offset alignment from the

Notice that the Offset Value is set to *Varies* if the alignment is not a dynamic offset alignment based
on a centerline. Otherwise, the Offset Value specifies the offset value of the attached dynamic alignment.
NOTE When you assign an offset value to an existing alignment, either dynamic or static, the Intersection
object does not remember the original dynamic object associated with it.
8 Click OK on the Intersection Offset Parameters dialog box, and proceed with using the wizard to create
the intersection object. For more information, see Using the Create Intersection Wizard (page 1592).
To edit offset alignments using grips
This procedure describes how to widen a road by grip editing the offset alignment that is controlling an
intersection.
1 In the drawing, select the desired offset alignment in the intersection object.
2 On the offset alignment, click and drag the Change Offset (triangle grip) to specify the new offset value.
Notice that the intersection object and the associated curb returns update.

Quick Reference
Ribbon
Click Intersection tab ➤ Modify panel ➤ Edit Offsets
Toolspace Shortcut Menu
Prospector tab: Right-click <intersection item > ➤ Edit Offsets
Object Shortcut Menu
Right-click <intersection object> ➤ Edit Offsets
Command Line
EditIxOffsets
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Dialog Box
Intersection Offset Parameters Dialog Box (page 2168)

Editing Curb Returns in Intersections
You can edit curb returns in an intersection.
You may need to edit curb returns after an intersection is created. For example, you can change the curb
return type or dimension, or edit widening or transition details.
Visual Cues: When you select an item on this dialog box, the affected object is highlighted in the drawing,
and the conceptual graphic on the dialog box updates to indicate the location of the edit. For more
information, see Intersection Editing Visual Cues (page 1605).
To edit curb returns in an intersection
1 Do one of the following:
■

In the drawing, click the intersection object. On the ribbon, click Edit Curb Returns
Modify panel of the Intersection contextual tab.

on the

■

In the drawing, right-click the intersection object, and then select Edit Curb Return Parameters from
the object shortcut menu.

■

In Prospector, expand the Intersections collection, right-click the intersection object, and then select
Edit Curb Return Parameters from the Toolspace shortcut menu.

2 Use the Intersection Curb Return Parameters dialog box to edit the following parameters associated
with this component.
■

Intersection Quadrant: You can specify which quadrant of the intersection to edit.

■

Widen Turn Lane For Incoming\Outgoing Road: These options automatically add widening to the
incoming or outgoing road in the intersection when the intersection is created.

■

Intersection Quadrant Name: Displays the name of the intersection quadrant. You can change the
name here, if desired.

■

Incoming Road Centerline Name: Displays the name of the centerline alignment for the incoming
road.

■

Outgoing Road Centerline Name: Displays the name of the centerline alignment for the outgoing
road.

■

Intersection Quadrant Angle: Specifies the angle in degrees that is created by the two alignments
that intersect, forming this intersection quadrant.

■

Curb Return Type: Specifies the type of curb return, either chamfer, circular fillet, or 3-centered arc.

■

Radius: When the curb return type is circular fillet or 3-centered arc, you can specify radius parameters
for the curb return.

■

Copy These To All Quadrants: On this dialog box, you can right-click the Curb Return Parameters
node in the Property column, and select Copy These To All Quadrants. When this option is selected,
the curb return parameters currently selected are automatically applied to all quadrants in the
intersection.

■

Widening At Incoming\Outgoing Lane: Specifies details for the widening at the incoming and
outgoing lanes in the intersection.
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■

Transition Details: Specifies the transition details for the incoming or outgoing lanes in the
intersection.

■

Widening Details: Specifies the widening details for the incoming or outgoing lanes in the
intersection.

Quick Reference
Ribbon
Click Intersection tab ➤ Modify panel ➤ Edit Curb Returns
Toolspace Shortcut Menu
Prospector tab: Right-click <intersection item > ➤ Edit Curb Returns
Object Shortcut Menu
Right-click <intersection object> ➤ Edit Curb Returns
Command Line
EditIxOffsets
Dialog Box
Intersection Curb Return Parameters Dialog Box (page 2166)

Editing Side Road Profiles for Intersections
You can edit the rules to adjust the profile of the side road in an intersection.
You may need to edit the profile for a side road after an intersection is created. For example, you can apply
or not apply grade rules, or change the maximum grade.
This helps set reasonable grades coming in and out of the intersection on the side road.
Visual Cues: When you select an item on this dialog box, the affected object is highlighted in the drawing,
and the conceptual graphic on the dialog box updates to indicate the location of the edit. For more
information, see Intersection Editing Visual Cues (page 1605).
To edit a side road profile in an intersection
1 Do one of the following:
■

In the drawing, click the intersection object. On the ribbon, click Side Road Profile
panel of the Intersection contextual tab.

on the Modify

■

In the drawing, right-click the intersection object, and then select Adjust Side Road Profile from the
object shortcut menu.

■

In Prospector, expand the Intersections collection, right-click the intersection object, and then select
Adjust Side Road Profile from the Toolspace shortcut menu.

NOTE If one or more of the dynamic PVIs created by the intersection are unlocked, a task dialog is displayed
prompting you to either relock the PVIs to match the primary road, or to continue the command without
relocking the PVIs. If they do not match the primary road elevation, the corridor top surface in the curb return
fillet areas will be uneven. Choose to either relock the PVIs, if possible, or to continue the command without
relocking the PVIs.
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2 Use the Secondary Road Profile Rules dialog box to edit the following parameters associated with this
component.
■

Apply Grade Rules: Specifies whether to apply grade rules for this secondary road profile.

■

Maximum Grade: Specifies the maximum grade that can be used for the tangents leading in to or
leaving the intersection along the secondary road.

■

Maximum Grade Change: Specifies the maximum grade change between the intersection area and
the tangent leading to the intersection along the secondary road.

■

Distance Rule to Adjust the Grade: Specifies to use a user-defined length or to the extents of the
intersection, as lengths, for incoming and outgoing grades along the secondary roads.

■

Distance Value: When using the Distance Rule to Adjust the Grade option, this specifies the distance
rule value used for the grade used for the secondary road in the intersection.

Quick Reference
Ribbon
Click Intersection tab ➤ Modify panel ➤ Side Road Profile
Toolspace Shortcut Menu
Prospector tab: Right-click <intersection item > ➤ Adjust Side Road Profile
Object Shortcut Menu
Right-click <intersection object> ➤ Adjust Side Road Profile
Command Line
EditIxSideRoadProfile
Dialog Box
Secondary Road Profile Rules Dialog Box (page 2173)

Editing Lane Slopes for Intersections
You can edit lane slopes in an intersection.
You may need to edit lane slopes after an intersection is created. For example, you can change the cross
slope from centerline, or select a different profile to use.
It is importnat to note that if you manually specify a lane slope by selecting a profile for the left edge (for
example), then the lane slope is determined by that profile.
Visual Cues: When you select an item on this dialog box, the affected object is highlighted in the drawing,
and the conceptual graphic on the dialog box updates to indicate the location of the edit. For more
information, see Intersection Editing Visual Cues (page 1605).
To edit lane slopes in an intersection
1 Do one of the following:
■

In the drawing, click the intersection object. On the ribbon, click Lane Slopes
panel of the Intersection contextual tab.

on the Modify

■

In the drawing, right-click the intersection object, and then select Edit Lane Slope Parameters from
the object shortcut menu.
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■

In Prospector, expand the Intersections collection, right-click the intersection object, and then select
Edit Lane Slope Parameters from the Toolspace shortcut menu.

2 Use the Intersection Lane Slope Parameters dialog box to edit the following parameters associated with
this component.
■

Left or Right Edge Profile Definition: Specifies the parameters defining the left and right edge of the
slope

■

Use an Existing Profile: When Yes is selected, you can select a profile from the available profiles in
the current drawing. When No is selected, this indicates that the profile was created during
intersection creation.

■

Cross Fall From Centerline: Specifies the slope of the grade from the centerline.

■

Profile Name: Displays the name of the profile associated with this edge profile definition. When
Use An Existing Profile is set to Yes, you can select a new profile from available profiles in the current
drawing.

Quick Reference
Ribbon
Click Intersection tab ➤ Modify panel ➤ Lane Slopes
Toolspace Shortcut Menu
Prospector tab: Right-click <intersection item > ➤ Edit Lane Slope Parameters
Object Shortcut Menu
Right-click <intersection object> ➤ Edit Lane Slope Parameters
Command Line
EditIntersectionLaneSlopes
Dialog Box
Intersection Lane Slope Parameters Dialog Box (page 2168)

Editing Curb Return Profiles for Intersections
You can edit curb return profiles in an intersection.
You may need to edit curb return profiles after an intersection is created. For example, you can extend or
not extend the profile along the incoming or outgoing lanes.
Visual Cues: When you select an item on this dialog box, the affected object is highlighted in the drawing,
and the conceptual graphic on the dialog box updates to indicate the location of the edit. For more
information, see Intersection Editing Visual Cues (page 1605).
To edit curb return profiles in an intersection
1 Do one of the following:
■

In the drawing, click the intersection object. On the ribbon, click Curb Return Profiles
Modify panel of the Intersection contextual tab.

■

In the drawing, right-click the intersection object, and then select Edit Curb Return Parameters from
the object shortcut menu.
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on the

■

In Prospector, expand the Intersections collection, right-click the intersection object, and then select
Edit Curb Return Parameters from the Toolspace shortcut menu.

2 Use the Intersection Curb Return Parameters dialog box to edit the following parameters associated
with this component.
■

Extend Profile Along Incoming (or Outgoing) Lane: Specifies whether to extend the curb return
profile along the incoming (or outgoing) lane of the intersection.

■

Length To Extend Along Incoming (or Outgoing) Lane: When Extend Profile Along Incoming (or
Outgoing) Lane is set to Yes, this option lets you specify the length to extend the curb return profile
along the incoming (or outgoing) lane of the intersection.

Quick Reference
Ribbon
Click Intersection tab ➤ Modify panel ➤ Curb Return Profiles
Toolspace Shortcut Menu
Prospector tab: Right-click <intersection item > ➤ Edit Curb Return Profile Rules
Object Shortcut Menu
Right-click <intersection object> ➤ Edit Curb Return Profile Rules
Command Line
EditIntersectionCurbReturnProfiles
Dialog Box
Intersection Curb Return Profile Parameters Dialog Box (page 2167)

Changing Corridor Assembly Frequency
You can change the frequency of assemblies applied in corridors within intersection objects.
The frequency that assemblies are applied to corridors in an intersection is specified at intersection creation,
and is controlled at the command settings level.
You can specify different frequencies for tangent, circular arcs, or spirals segments separately. Once the
intersection is created, you can edit the corridor properties to change frequencies as needed. For example,
suppose originally the curb return fillet is from station 1+00 to 3+00.
Then suppose that you change the frequency of assembly insertion for one or more of the corridor regions;
for example, quadrant 2. Also perhaps you may add manual stations, for example, at station 2+05 and at
2+15 in the curb return fillet section of the corridor in quadrant 2.
Now suppose that you edit the intersection geometry so that the curb return fillet radius at quadrant 2 is
increased. Suppose that due to this change, the curb return fillet station changed from 0+50 to 3+50 because
of the increased length of arc. In this case, the intersection object will do the following:
■

Corridor region station for that curb return fillet area (in quadrant 2) will be updated as 0+50 to 3+50.

■

Frequencies for this region will be based on the newly set values.

■

Manual stations at 2+05 and 2+15 will still be in the list.
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■

All other regions in other quadrants and region types will still have the frequencies set during the
intersection object creation.

If the corridor is set to rebuild automatically, then the corridor will be updated with the changes noted
above, including manual stations (which would remain at their previous station values).
If one of the manual stations is no longer part of the new curb return fillet area, then that manual station
is removed from the list.
If the corridor is set with Rebuild Automatic turned off, then the intersection will still change the corridor
regions to the new stations. However, the corridor is not rebuilt unless “Rebuild” is selected on the corridor
object, either in the drawing, or in Prospector.
NOTE The above steps describe behavior when the corridor is set to rebuild automatically. If it is not set to rebuild
automatically, this behavior occurs only when you explicitly click the Rebuild button.
To change assembly frequency
1 In Toolspace, on the Settings tab, expand the Intersection collection. Expand the Commands collection.
2 Right-click the CreateIntersection command and click Edit Command Settings.
The Edit Feature Settings - Intersection dialog box (page 2159) is displayed.
3 Expand Assembly Insertion Defaults.
4 Click in the Value cell for the following frequency options, and specify the desired values: Frequency
Along Tangents, Frequency Along Curves, Frequency Along Spirals, Frequency Along Profile Curves.
5 Click Apply.

Quick Reference
Toolspace Shortcut Menu
Settings tab: Intersection ➤ Commands ➤ Right-click <command-name> ➤ Edit Command Settings
Dialog Box
Edit Feature Settings - Intersection (page 2159)

Updating Corridor Regions in Intersections
You can update the corridor regions in an intersection manually or automatically.
If the intersection definition is out-of-date,
is displayed next to the intersection in the Prospector tree.
This indicates that the corridor regions in the intersection need to be updated.
When you update corridor regions in an intersection, any manual edits that were made to the regions or
targets within the intersection corridor are lost.
You can update corridor regions in an intersection manually, or you can specify that the intersection object
update corridor regions automatically. When you configure the intersection object to update corridor regions
automatically, a check mark is displayed next to the Update Regions Automatically option on the Toolspace
shortcut menu.
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The following two options are available for updating corridor regions in an intersection:
Options

Description

Update Regions and Rebuild Corridor

Updates the corridor regions in an intersection object and rebuilds the corridors that
are included in the intersection object.

Update Regions Automatically

Specifies that the intersection object automatically updates the corridor regions and
rebuilds the corridors in the intersection
object whenever certain types of changes
are made to the intersection.

When the Update Regions and Rebuild Corridor command is invoked, the corridor region stations in the
intersection are updated (recalculated) in order to stay in synchronization with the intersection area geometry.
The corridor properties are updated to reflect these new region station values.
To manually update the corridor regions in an intersection
■

In Toolspace, on the Prospector tab, expand the Intersections collection. Right-click the intersection.
Click Update Regions and Rebuild Corridor.
NOTE If the intersection definition is out-of-date,

is displayed next to its node in the Prospector tree.

To automatically update the corridor regions in an intersection
■

In Toolspace, on the Prospector tab, expand the Intersections collection. Right-click the intersection.
Click Update Regions Automatically.
NOTE When you toggle this option on, if AutoCAD Civil 3D detects that changes have been made to the
intersection that require the corridor regions to be updated, then the update occurs immediately when you
toggle the option on.

A check mark is displayed next to the Update Regions Automatically option on the Toolspace shortcut menu,
indicating that this option is turned on.

Quick Reference
Toolspace Shortcut Menu
Prospector tab: Intersections ➤ right-click <intersection name> ➤ Update Regions and Rebuild Corridor
or Update Regions Automatically
Object Shortcut Menu
Update Regions and Rebuild Corridor or Update Regions Automatically

Recreating Corridor Regions in Intersections
You can recreate corridor regions in an intersection after intersection geometry has changed, or after you
have applied different assemblies.
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You may need to recreate corridor regions if intersection components have been edited. For example, if you
change the radius or length of curb return alignments, you must recreate corridor regions in the intersection
area to ensure that no geometry gaps or overlaps exist.
Another scenario for recreating corridor regions is as follows:
You may want to discard all changes made to the intersection corridors, and recreate the corridors again
using the original intersection creation logic.
For example, if you created an intersection object using a particular assembly set (page 2767), and then made
changes to that intersection, such as changing curb return corridor stations, frequencies, and assemblies.
You may also have changed the extents of the entire length of the primary road on either side of the
intersection. Perhaps next you change the horizontal geometry and curb return parameters. If the corridor
is set to rebuild automatically, it will update automatically. Otherwise, at this point the corridor will be
displayed as out-of-date in Prospector.
Now you may want to discard all those changes and either reapply the original assemblies specified during
intersection creation, or apply different assemblies. If so, you can use the Recreate Corridor Regions command
to do this.
When you select the Recreate Corridor Regions command, the Intersection Corridor Regions dialog box is
displayed. On this dialog box, you can change parameters if desired, including assemblies to apply, or you
can leave the parameters on this dialog as specified, and click Recreate to recreate the corridor regions in
the intersection object according to the parameters, and assemblies, that were specified when this intersection
object was originally created.
The Recreate Corridor Regions command performs the following actions:
■

All corridor regions in the selected intersection are deleted, and are recreated according to the parameters
that were specified on the Intersection Corridor Regions dialog box.

■

Any user-defined corridor regions within the extents of the intersection are deleted.

■

A new set of corridor regions is created according to the assembly insertion frequency that is specified
in the command settings.

Because this command deletes and recreates the corridors in the intersection, if you made any changes to
the corridors in the intersection object, those changes will be overwritten (discarded) when the new corridors
are created.
To recreate corridor regions in an intersection
1 In the drawing, select the intersection object.
2 Do one of the following:
■

In the Intersection tab on the ribbon, click the Modify panel ➤ Recreate Corridor Regions

■

Right-click and select Recreate Corridor Regions.

3 On the Intersection Corridor Regions dialog box, click Recreate.

Quick Reference
Ribbon
Click Intersection tab ➤ Modify panel ➤ Recreate Corridor Regions
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Toolspace Shortcut Menu
Prospector tab: Intersection ➤ right-click <intersection name> ➤ Recreate Corridor Regions
Object Shortcut Menu
Recreate Corridor Regions

Deleting Intersection Objects
You can delete an intersection object, erasing it from the drawing and removing it from the Intersections
collection in the Prospector tree.
When you delete an intersection object in the drawing, the following are deleted:
■

the intersection object, and its label, in the drawing

■

the intersection object in the Intersections collection in Prospector

The following components associated with an intersection object are not deleted when you delete an
intersection object:
■

the following 2D geometry components associated with the intersection object: intersecting alignments,
offset alignments, curb return alignments

■

the following other components associated with the intersection object: offset profiles, curb return
profiles

■

If you created a new corridor object inside the intersection area, this corridor object is not deleted when
you delete an intersection object. You must delete this corridor object manually, if desired.

You can use the following methods to delete an intersection object:
■

In the drawing, select the intersection object, and delete or erase it.

■

If you delete one or both of the intersecting alignments that create the intersection, then the intersection
object is automatically deleted.

■

In the drawing, if you move one or both of the intersecting alignments that create the intersection so
that the alignments no longer intersect, then the intersection object is automatically deleted.

Deleting Intersection Object Dependent Components
It is important to understand the following behavior associated with deleting objects that intersection objects
depend on.
■

Centerline Profiles: If any of the centerline profiles associated with the intersection are deleted, then the
curb return profiles will become static (no longer a dynamic profile). Accordingly, the intersection
corridors will be updated. This behavior is similar to how a corridor reacts to its profile grade line, or
when a centerline profile is deleted. In this scenario, the intersection object still exists (is not deleted),
with just horizontal geometry.

■

Offset Alignments: If an offset alignment associated with an intersection object is deleted, and that offset
alignment has a curb return alignment attached to it, the curb return attached to that offset alignment
is not deleted; however, the curb return alignment is no longer dynamic to the intersection object. It
becomes a static curb return alignment, meaning that if you move the intersection object, the now static
curb return alignment does not move. The same is true for the profile associated with the curb return
alignment. It becomes a static (non-dynamic) profile.
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■

Curb Return Alignments: If the curb return alignments or profiles are deleted (using AutoCAD Delete),
then the intersection area corridors based on those baselines are also deleted. If only the profile is deleted,
then the corridors based on those profiles are moved to zero elevation. The intersection object still exists.
Deleting the curb return does not automatically delete the profile associated with it; however, if you
delete the curb return, the curb return profile becomes static.

■

Assemblies: If any of the assemblies used the intersection are deleted, and the corridor is set to “Rebuild
Automatic”, then the corridor regions that use the deleted assemblies are set to <None>. This creates an
empty corridor even though corridor regions still exist. You can use the Recreate Corridor command to
download the assemblies from the source location into the current drawing, and this recreates the corridor
regions.

To delete an intersection object
■

In the drawing, select the intersection object, and use the AutoCAD Delete or Erase command.
The intersection object, and its label, are erased from the drawing. The intersection object is also removed
from the Intersections collection in the Prospector tree.

Labeling Intersections
You can add labels to intersection objects.
There are three ways to add labels to intersection objects:
■

during intersection object creation

■

using the AddLabel command

■

using the AddIntersectionLabel command

By default, the standard intersection object label contains the name of the intersection object, the names
of the intersecting alignments, and the station value locations where the alignments intersect.
There is no placement option available for an intersection label. The label is always placed at the intersection
point. If that point is already labeled, then a second label is placed on top of the existing label.
For more information, see Understanding Labels in AutoCAD Civil 3D (page 1646).

Adding Labels to Intersection Objects
To add labels to intersection objects
1 Click Annotate tab ➤ Labels & Tables panel ➤ Add Labels menu ➤ Add Intersection Label
2 Select the intersection object to be labeled.

Quick Reference
Ribbon
Annotate tab ➤ Labels & Tables panel ➤ Add Labels menu ➤ Add Intersection Label
Command Line
AddIntersectionLabel
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Intersections and Assemblies
Assembly Sets
An assembly set is a group of assemblies used to create a corridor in an intersection object.
Assembly sets are used only with intersection object creation. A default assembly set is included with AutoCAD
Civil 3D. You can create an intersection using this default assembly set, or you can create your own custom
assembly sets to suit the needs of specific intersection design.

When you apply the assembly set, and create or update the intersection object corridors, the referenced
assembly objects are imported into the current drawing, if they are not already there.
The following table describes the components that are associated with an assembly set:
Component

Description

assembly set

A group of assemblies that have been designed for use
in specific type of intersection design. An assembly set
is defined in an assembly set file.

assembly set file

An .xml file containing information that defines the
assemblies that are included in an assembly set. An
assembly set file contains the names of the assembly
objects, the location (path) where the individual assembly drawings exist, and other information about
the assemblies included in the set. This .xml file serves
primarily as a pointer (reference mechanism). It does
not contain the actual assembly drawing data.

assembly object names

The name of each assembly object referenced in the
set is maintained in the assembly set file. Note that the
assembly object data itself is not contained in the assembly set file, just the information that enables AutoCAD Civil 3D to locate the assembly object data (a
reference to the assembly name, and the name of the
drawing file that contains the assembly object.)

assembly drawings

Each assembly object referenced in an assembly set is
also saved to an assembly drawing file. An assembly
drawing file contains a single assembly object. The assembly drawing file typically has the same name as the
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Component

Description
assembly object. For example, the assembly drawing
file for an assembly object named Secondary_Road_Half_Section _Daylight_Left is named Secondary_Road_Half_Section _Daylight_Left.dwg. The assembly drawing file associated with each assembly
object referenced in the assembly set is also stored
(referenced) in the assembly set.

The fist time you use the Create Intersection wizard, it is recommended that you accept and use the assembly
set that is referenced by default on the wizard. As you become more familiar with creating intersections,
you will want to create your own customized assembly sets. For instructions see, To Create an Assembly Set
(page 1620).
The assembly set that is included with AutoCAD Civil 3D is typically located by default in the following
location:
C:\Documents and Settings\All Users\Application Data\ Autodesk\C3D2011\enu\Assemblies\Imperial (or Metric)
NOTE If the assembly set file references an assembly name that cannot be found, then a null assembly (page 2779)
will be used to in its place to create the intersection object. For more information, see Null Assemblies (page 1622).
The following illustration shows the contents of the default assembly set file that is included with AutoCAD
Civil 3D.

Modifying Assemblies Referenced in Assembly Sets
It is important to note that if you modify an assembly that is referenced in an assembly set, and that is
already used in the current drawing, and you do not change the name of the modified assembly, this does
not change the intersection area corridor definition.
In such cases, if you try to create a new intersection, or recreate an existing intersection, the intersection
corridor will continue to use the assembly of the same name in the current drawing, and will not use the
modified assembly that is referenced in the assembly set folder.
If you want to apply the updated assembly that is referenced in the assembly set to the intersection corridor,
you must delete (or rename) the assembly with the same in name in the current drawing first.
To create an assembly set
1 Ensure that the assemblies that you intend to save to the new assembly set exist in the current drawing.
You can perform this procedure using the Create Intersection wizard, or by editing an existing intersection
object.
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2 Do one of the following:
■

Using the Create Intersection Wizard: You can create an assembly set during intersection creation,
using the Corridor Regions page of the Create Intersection wizard. To do so, start the
CreateIntersection comand, select the new assemblies in the Assemblies To Apply section of the
Corridor Regions page, and then proceed to Step 3 below. If desired, you can click Cancel on the
Create Intersection wizard after you have saved the new assembly set. This allows you to create a
new assembly set without creating a new intersection object.

■

Edit an Existing Intersection: Select an existing intersection, and then click Recreate Corridor Regions
on the Modify panel of the Intersection contextual tab. On the Intersection Corridor Regions dialog
box, select the assemblies in the Assemblies To Apply section of this dialog box.

3 After selecting the desired assemblies, click Save As a Set.
4 On the Select Assembly Set File dialog box, enter a name for the new assembly set file, and then click
Save.
NOTE At this point, the new assembly set file is created. You may or may not want to proceed with applying
the new assembly set to the current intersection. If you do want to apply the new assembly set to the current
intersection, follow the next step.
5 To apply the assembly set to the intersection, do one of the following:
■

If you selected the assemblies from the Corridor Regions page of the Create Intersection wizard,
click the Browse button, select the newly created assembly set file, and then click Create Intersection.

■

If you selected the assemblies from the Intersection Corridor Regions dialog box, click the Browse
button, select the newly created assembly set file, and then click Recreate.

To apply a different assembly set to an intersection
1 In the current drawing, create the desired assemblies. You can edit the existing assemblies, or create
new ones from scratch.
2 Do one of the following:
■

If you are creating an intersection, on the Corridor Regions page of the Create Intersection wizard,
select the new assemblies in the Assemblies To Apply section of this dialog box.

■

On an existing intersection, select the intersection, and then click Recreate Corridor Regions on the
Modify panel of the Intersection contextual tab. On the Intersection Corridor Regions dialog box,
select the assemblies in the Assemblies To Apply section of this dialog box.

3 After specifying the desired assemblies, click Save As a Set.
4 On the Select Assembly Set File dialog box, specify the name and location for the assembly set file, and
click Save. If desired, you can select an existing assembly set file and save (update) it with the information
about the newly specified assemblies.
5 Click Browse to navigate to and select the desired assembly set file.
6 Use the drop-down arrow on the Select Assembly Set To Import field to ensure that the desired assembly
set file is specified on this dialog box.
7 To apply the new assembly set to the intersection, do one of the following:
■

If you are creating a new intersection, click Create Intersection on the Corridor Regions page of the
Create Intersection wizard.

■

If you edited an existing intersection, click Recreate on the Intersection Corridor Regions dialog
box.
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Null Assemblies
A null assembly is created in an intersection object during creation when an assembly name referenced in
the assembly set file cannot be found.
AutoCAD Civil 3D automatically creates a null assembly when you create an intersection that references an
assembly name that cannot be found in any of the assembly drawings referenced in the selected assembly
set (page 2767) file. The null assembly serves as a placeholder object so that the intersection object can still be
created even though an assembly cannot be found.
If the assembly name is not found in the assembly drawings referenced by the assembly set file, AutoCAD
Civil 3D then searches for the assembly name in the current drawing. If the assembly is found in the current
drawing, then AutoCAD Civil 3D proceeds with creating the intersection using that assembly, and creating
the external assembly drawing for the assembly, if one does not already exist.
A null assembly allows AutoCAD Civil 3D to continue with intersection creation even though all of the
referenced assemblies are not found.

After the intersection is created, you can assign appropriate assemblies, or a different assembly set. If you
do, you will need to recreate the intersection corridor regions, as well as rebuild the intersection, to apply
the new assembly or assemblies to the intersection. You may also need to rebuild corridors. For more
information on recreating intersection corridor regions, or on rebuilding an intersection, see Updating
Corridor Regions in Intersections (page 1614) and Recreating Corridor Regions in Intersections (page 1615).

Intersection Command Reference
You can use commands to quickly access intersection functionality.
The following table lists the intersection commands and briefly describes their functionality.
Command

Description

AddIntersectionLabel

Adds a label to an intersection object (page 1618)

CreateIntersection

Creates an intersection (page 1592)

EditIntersectionProperties

Displays the Intersection Properties dialog box
which lets you edit Intersection object properties
(page 1603)

EditIxCorridorRegions

Edits corridor regions in an intersection (page 1614)
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Command

Description

EditIxCurbReturns

Edits curb returns in an intersection (page 1609)

EditIxCurbReturnProfiles

Edits curb return profiles associated with an intersection object (page 1612)

EditIxOffsetProfiles

Edits offset alignment profiles associated with an
intersection object (page 1611)

EditIxOffsets

Edits offset alignments in an intersection (page
1607)

EditIxSideRoadProfile

Edits side road profiles associated with an intersection (page 1610)

Roundabouts
AutoCAD Civil 3D 2011 includes features that let you create and edit 2D roundabouts in roadway models.
Roundabout Design Workflow (page 49)

Understanding Roundabouts
The roundabout features include several commands that let you create and edit 2D roundabouts.

You can quickly create a 2D roundabout that comprises the following components:
■

Roundabout Central Area - Includes a central island and a circulatory roadway. The central area geometry
is defined by circular alignments. Appropriate road markings are automatically added as polylines.

■

Approach Roads - Alignments define the centerline and outer boundaries of approach roads entering
the roundabout. Optional polylines that represent construction triangles, splitter islands, and other road
markings, can be included.
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■

Slip Lanes - You can add slip lanes, or bypass lanes, to an existing roundabout. The geometry boundaries
of the slip lane are drawn with alignments. Polylines indicate road markings.

■

Markings and Signs - These can be added to various parts of a roundabout by specifying linetypes, blocks,
and other parameters. The default signs that are used are specified using existing AutoCAD blocks.
However, to suit your project’s needs, you can create and specify your own signs using AutoCAD blocks.

A roundabout created using the Create Roundabout command is a 2D representation of a roundabout, and
has no vertical data associated with it. Alignments and polylines define the shape. There is no roundabout
object and no roundabout node in Prospector.

Setting Driving Direction for Roundabouts
When using the Create Roundabout feature, ensure that the Driving Direction option in Drawing Settings
is set to the appropriate option for your project. For example, in countries such as the United Kingdom
where vehicles travel on the left side of the road, the Driving Direction should be set to Left Side of the Road.
When the Driving Direction option is set to Left Side of the Road, curb return alignments in intersections,
or roundabouts, are drawn starting from the left side of the outgoing road, and ending on the left side of
the merging road. Right Side of the Road is typically selected for projects where vehicles travel on the right
side of the road; for example, in countries such as the United States. In this case, curb return alignments in
intersections or roundabouts are drawn starting from the right side of the outgoing road, and ending on the
right side of the merging road. For more information, see Setting Driving Direction.
When creating roundabouts, you should verify that signage and road markings are inserted as desired, based
on the driving direction. You may need to manually adjust signage.

Roundabout Alignments in Prospector
When you create a roundabout, it automatically creates a group of new alignments and polylines that
represent roundabout components. In Prospector, roundabouts alignments are added to the Alignments ➤
Centerline Alignments location, if you do not have a site assigned to the alignments.
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If the selected base alignments are associated with sites, then the resulting roundabout alignments are
displayed in the appropriate Sites collection, under Sites ➤ Alignments ➤ Centerline Alignments.
In Prospector, there is no collection that is specific to roundabouts. The resulting roundabout alignments
are visible in the Prospector Alignments ➤ Centerline Alignments or Sites collections. There is no
“roundabout” object type.

Roundabout Limitations
It is important to be aware of the following when using the Create Roundabout feature, or when opening
drawings that contain roundabouts created using this feature.

Editing Roundabouts in Other Versions of AutoCAD Civil 3D
Roundabouts created using the Create Roundabout command can only be edited in versions of AutoCAD
Civil 3D that contain the roundabout creation functionality. These versions include:
AutoCAD Civil 3D 2010 that has the Subscription Advantage Pack for AutoCAD Civil 3D 2010 installed
AutoCAD Civil 3D 2011 or greater

Overlapping Curb Returns in Roundabouts
In situations where curb returns for approaching roads overlap each other as they enter the circular portion
of the roundabout, the curb returns do not blend together. They remain slightly overlapping, as shown in
the following illustration:

Before You Begin
Before creating roundabouts, create appropriate alignments, styles, and other drawing data.
Typically, you will have two or more alignments drawn, representing approach roads. However, you may
begin with just one alignment, if you desire just one approach road connected to the roundabout.
You may also want to have sites, alignment styles, layers and label sets already established.
After the appropriate base geometry (alignments) has been drawn, you can execute the Create Roundabout
command. The alignments you select will form the approach roads leading into the roundabout.
You can start with alignments that intersect (crossing alignments), or with alignments that do not intersect.

Intersecting Alignments
If you create a roundabout from intersecting alignments, you may need to add additional approach roads
after you create the roundabout. For example, the following illustration shows two alignments that intersect.
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In this example, the two alignments intersect each other, and they both pass through the roundabout
location on both sides.
If you execute the Create Roundabout command in this situation, and select these two alignments, the
following roundabout is created:

This roundabout contains only two approach roads. If you want more approach roads in this roundabout,
you can add them using the Add Approach command.

Non-Intersecting Alignments
If you create a roundabout from alignments that do not intersect, can create all four approach roads at once.
In this scenario, the approach roads are added automatically, according to the alignments that have been
selected. For example, the following illustration shows four alignments that do not intersect.
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If you execute the Create Roundabout command and select these four alignments, the following roundabout
is created:

In this scenario, four approach roads are created automatically.

Central Area
The central area of a roundabout includes the central island, the traversable area, and the outside edge of
the roundabout.
This geometry is constructed with alignments as shown in the following illustration. The first arrow (1)
identifies the alignment that defines the outer edge of the circulatory road. The second arrow (2) identifies
the alignment that defines the inner edge of the circulatory road. There is also a circular alignment defining
the central island in the middle of the roundabout central area.
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The following table lists the default naming convention that is used to name these alignments. You can
change the “Roundabout” prefix to something that better suits your project’s needs. However, you cannot
edit the “OUTER_EDGE” suffix.
Approach Road Alignment

Alignment Name

alignment that defines the outer edge of the
roundabout central area (1 in the illustration)

Roundabout_OUTER_EDGE

alignment that defines the inner edge of the
roundabout central area (2 in the illustration)

Roundabout_INNER_EDGE

alignment that defines the island in the roundabout
central area

Roundabout_ISLAND

The central area can also include pavement markings that are constructed as polylines offset from the
traversable area and the outside edge.

Approach Roads
Before you can create a roundabout, you must create at least one alignment to represent an approach road.
This is the alignment to which an approach will be dynamically connected. If you change or move this base
approach alignment, the roundabout approach is dynamically updated.
The Create Roundabout - Approach Roads dialog box provides parameters that let you define the approach
road geometry. It creates three alignments that define the approach road. The following table lists the default
naming convention that is used to name the approach road alignments. You can change the “Approach_”
prefix to something that better suits your project’s needs. However, you cannot edit the “_EW_EDGE_LEFT”
suffix during creation.
Approach Road Alignment

Alignment Name

alignment that defines the center of the approach
road

Approach_EW

alignment that defines the left edge of the approach
road

Approach_EW_EDGE_LEFT
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Approach Road Alignment

Alignment Name

alignment that defines the right edge of the approach road

Approach_EW_EDGE_RIGHT

NOTE In the above example, “EW” in the alignment name identifies the alignment as the “East-West” alignment.
This two-letter naming convention is based on the alignment direction, and not on the roundabout approach
road direction. For example, NW is used for an alignment that runs from the north to the west, and so on.
These approach road alignments (1 = Approach_EW_EDGE_LEFT, 2 = Approach_EW, and 3 =
Approach_EW_EDGE_RIGHT) are shown in the following illustration.

The island, construction triangle, and pavement markings on the approach road are constructed as polylines.

Slip Lanes
You can add an extra lane for right turning or left turning vehicles, as a bypass lane, to allow vehicles to
avoid traveling through the central area of the roundabout.
A slip lane is constructed with two alignments - one each for the left and right side boundary of that lane.
Road markings constructed as polylines are placed on top of the alignments. If you grip edit and move the
polyline road markings, as shown in the following illustration, you expose the slip lane alignments.
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The first arrow (1) identifies the road marking solid line (polyline). The second arrow (2) identifies the slip
lane alignment for the left edge of the slip lane.
The following table lists the default naming convention that is used to name the slip lane alignments. You
can change the prefix “SlipLane_” to something that better suits your project’s needs. However, you cannot
edit the “_EDGE_LEFT” or “_EDGE_RIGHT” suffix.
Slip Lane Alignment

Alignment Name

alignment that defines the left edge of the slip lane

SlipLane_EDGE_LEFT

alignment that defines the right edge of the slip
lane

SlipLane_EDGE_RIGHT

Roundabout Parameters
Roundabout creation and editing dialog boxes display conceptual illustrations of most roundabout parameters.
These conceptual illustrations are displayed in the dialog box when you place your cursor on one of the
roundabout parameters fields.
For example, on the Create Roundabout - Circulatory Road dialog box, place your cursor over the Outer
Radius parameter field, or click in that field. The following conceptual illustration is displayed in the dialog
box.

The arrow that is displayed identifies the distance this parameters controls.
Next, place your cursor over the Apron Width field in the dialog box. The following illustration is displayed
in the dialog box.
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The conceptual illustration updates and two arrows are displayed, identifying the width this parameter
controls.
Conceptual illustrations are available for the following parameters on roundabout dialog boxes:
Roundabout Dialog Box

Parameters with Conceptual Illustrations

Create Roundabout - Circulatory Road dialog box

Roundabout Parameters
Markings Parameters

Create Roundabout - Approach Roads dialog box

Approach Road Parameters

Create Roundabout - Islands dialog box

Construction Triangle Parameters
Splitter Island Parameters

Preset Add dialog box

Roundabout Parameters
Markings Parameters
Approach Road Parameters
Construction Triangle Parameters
Splitter Island Parameters

Creating Roundabouts
Use the Create Roundabout command to create a roundabout in your roadway model.
After you have completed setup tasks, such as setting up sites, alignment styles, layers, and alignment label
sets, create the base alignments that will be used to define the approach roads that lead in to and out of the
roundabout central area.
Once you have appropriate base alignments created, you can execute the Create Roundabout command.
You will be prompted to select a location for the roundabout center point. Once you select the roundabout
center point location, a series of Create Roundabout dialog boxes are displayed. These wizard dialog boxes
let you specify a variety of parameters for the roundabout.
You can start with alignments that intersect, or with alignments that do not intersect. If your alignments
intersect, you may need to add approach roads after the alignment has been created. If you start with
alignments that do not intersect, the approach roads are added automatically.
To create a roundabout
1 Click Home tab ➤ Create Design panel ➤ Intersections drop-down ➤ Create Roundabout

.

You are prompted to select a roundabout center point.
2 Click on the location where you want to insert the roundabout center point.
After selecting the center point location, you are prompted to select an approach road.
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3 Select the first approach road by clicking on an alignment in the drawing.
NOTE When an alignment is selected, the alignment temporarily displays as a dashed line. If the alignment
does not change to a dashed line, is not selected.
You are prompted to select the next, and successive, approach roads. For more information, see Adding
Approach Roads (page 1632).
4 When you are finished selecting approach roads, press Enter.
The Create Roundabout - Circulatory Road dialog box is displayed.
5 Select desired options on the Create Roundabout - Circulatory Roads dialog box (page 2149), and then
click Next to proceed to the next roundabout dialog box.
6 On the Create Roundabout - Approach Roads dialog box (page 2151), select the desired options, and then
click Next.
7 On the Create Roundabout - Islands dialog box (page 2153), select the desired options, and then click
Next.
8 On the Create Roundabout - Markings and Signs dialog box (page 2155), select the desired options, and
then click Finish.
NOTE Informational messages may be displayed to inform you of certain conditions. Click OK to close these
messages.
The roundabout is created in the drawing.

Quick Reference
Ribbon
Click Home tab ➤ Create Design panel ➤ Intersections drop-down ➤ Create Roundabout

.

Command Line
CreateRoundabout
Dialog Box
Create Roundabout - Circulatory Road Dialog Box (page 2149)
Create Roundabout - Approach Roads Dialog Box (page 2151)
Create Roundabout - Islands Dialog Box (page 2153)
Create Roundabout - Markings and Signs Dialog Box (page 2155)

Adding Approach Roads
Use the Add Approach command to add an approach road to a roundabout.
After executing the command, you are prompted to select a location on the circular area of the roundabout
where you want the approach road to be added. After clicking on the circular area, you are prompted to
select the alignment or alignments that will be used to define the approach roads. After selecting the approach
road alignments, and pressing Enter, the Create Roundabout - Approach Roads Dialog Box (page 2151) is
displayed. Specify parameters for the approach roads using this dialog box.
For more information, see Approach Roads (page 1628).
You can add one or more approach roads, depending on your base geometry.
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To add an approach road to a roundabout
1 Click Home tab ➤ Create Design panel ➤ Intersections drop-down ➤ Add Approach

.

You are prompted to select a location along the circular area of the roundabout.
2 Select a location along the circular area of the roundabout, and then press Enter.
You are prompted to select the alignment for the approach road. When you are finished selecting
alignments, press Enter. The Create Roundabout - Approach Roads dialog box (page 2151) is displayed.
3 Specify the desired parameters on the Create Roundabout - Approach Road dialog box, and then click
next to proceed to the Islands dialog box.
4 If desired, you can edit the default choices on the Islands and Markings and Signs dialog box.
5 Click Finish on the Markings and Signs dialog box to add the approach road.
NOTE Informational messages may be displayed to inform you of certain conditions. Click OK to close these
messages.
The approach road is added to the roundabout. Depending on your base design, you can add one or
multiple approach roads using this procedure.

Quick Reference
Ribbon
Click Home tab ➤ Create Design panel ➤ Intersections drop-down ➤ Add Approach

.

Command Line
AddApproach
Dialog Box
Create Roundabout - Approach Roads Dialog Box (page 2151)

Adding Slip Lanes
Use the Add Turn Slip Lane command to add a slip lane to a roundabout.
After executing the command, you are prompted to select the entry and exit roads in the roundabout. Next,
the Draw Slip Lane dialog box is displayed where you can specify a variety of parameters for the slip lane.
For more information, see Slip Lanes (page 1629).
To add a slip lane to a roundabout
1 Click Home tab ➤ Create Design panel ➤ Intersection

drop-down ➤ Add Turn Slip Lane.

You are prompted to select the entry approach lane.
2 In the roundabout, select the approach road that will be used as the start (entry) of the slip lane.
You must select a location along one of the existing roundabout approach road alignment extents. For
example, the following illustration shows the valid area of a roundabout for selecting an approach road.
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If you try to select outside of this area, the approach road is not selected. Only valid locations are
accepted.
When a valid location has been selected, you are then prompted to select the end (exit) for the slip
lane.
3 Select the end (exit) of the slip lane by clicking on an appropriate (adjacent) approach road in the
roundabout.
If you click on an invalid alignment, it will not be selected. When you make a valid selection, the Draw
Slip Lane dialog box (page 2158) is displayed.
4 Make adjustments to slip lane parameters on this dialog box, if desired.
5 Click OK to create the slip lane.
The slip lane is added to the roundabout. For more information, see Editing Slip Lanes (page 1636).

Quick Reference
Ribbon
Home tab ➤ Create Design panel ➤ Intersection

➤ Add Turn Slip Lane

Command Line
CreateTurnSlipLn
Dialog Box
Draw Slip Lane Dialog Box (page 2158)

Editing Roundabouts
Edit roundabouts using the Edit Roundabout command.
When you use this command, you are prompted to select the roundabout.
You can click anywhere on the roundabout to edit it. Depending on which roundabout component you
click on, the corresponding roundabout dialog box is displayed. Make changes to the dialog boxes to edit
the roundabout.
For example, if you click on the central area of the roundabout, the Create Roundabout - Circulatory Road
dialog box is displayed. If you click on an approach road, the Create Roundabout - Approach Roads dialog
box is displayed. Similarly, if you click on an island, marking, or slip lane, the appropriate dialog box is
displayed.
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The following table summarizes this behavior during roundabout edit mode.
Clicking on this roundabout component...

Displays this dialog box...

central area

Create Roundabout - Circulatory Road

approach road

Create Roundabout - Approach Roads

island

Create Roundabout - Islands

road marking or sign

Create Roundabout - Markings and Signs

slip lane

Draw Slip Lane

You can move forward or backwards through the roundabout dialog boxes using the Next and Back buttons.
Any changes you make on the dialog boxes updates the roundabout when you click Finish on the Create
Roundabout - Marking and Signs dialog box.
For more information, see Understanding Roundabouts (page 1623).

Moving Roundabouts
You can move a roundabout by selecting the centerpoint of the roundabout, and dragging it. If you move
the base alignment that a roundabout approach road was created from, the roundabout components remain
dynamic to the base alignment, and move with the base alignment.
If you need to change the centerpoint location of a roundabout, you can do it by deleting the roundabout,
recreating the roundabout, and selecting a new roundabout center point location.
To edit a roundabout
1 Click Modify tab ➤ Design panel ➤ Intersection

.

2 On the Intersection contextual tab ➤ Modify Roundabout panel ➤ Edit Roundabout.
You are prompted to select a roundabout.
3 Select the roundabout in the drawing.
The Create Roundabout dialog box is displayed.
4 In the roundabout dialog boxes, make changes to the desired options, and then click Next.
You can click Back or Next to move through all of the roundabout dialog boxes.
5 When you are finished making changes, click Next to advance to the Create Roundabout - Markings
and Signs dialog box, and then click Finish.
The roundabout is updated in the drawing.

Quick Reference
Ribbon
Select the roundabout. Click Modify tab ➤ Design panel ➤ Intersection ➤ Edit Roundabout.
Command Line
EditRoundabout
Dialog Box
Create Roundabout - Circulatory Road Dialog Box (page 2149)
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Create Roundabout - Approach Roads Dialog Box (page 2151)
Create Roundabout - Islands Dialog Box (page 2153)
Create Roundabout - Markings and Signs Dialog Box (page 2155)
Draw Slip Lane Dialog Box (page 2158)

Editing Approach Roads
Edit an approach road in a roundabout using the Edit Roundabout command.
When you use this command, you are prompted to select the roundabout. Click on the approach road in
the roundabout to display the Create Roundabout - Approach Roads dialog box (page 2151). If you do not
click on an approach road, the approach road dialog box is not displayed. Edit the approach road by making
changes to the parameters on the dialog box.
For more information, see Approach Roads (page 1628).
To edit an approach road
1 Click Modify tab ➤ Design panel ➤ Intersection

.

2 On the Intersection contextual tab ➤ Modify Roundabout panel ➤ Edit Roundabout.
You are prompted to select a roundabout.
3 Click on the approach road that you want to edit.
NOTE You must click on an approach road to display the Create Roundabout - Approach Road dialog box.
4 Make changes to the Create Roundabout - Approach Road dialog box and click OK.
The approach road is updated in the drawing.

Quick Reference
Ribbon
Select the roundabout. Click Modify tab ➤ Design panel ➤ Intersection ➤ Edit Roundabout.
Command Line
EditRoundabout

Editing Slip Lanes
Edit a slip lane in a roundabout using the Edit Roundabout command.
When you use this command, you are prompted to select the roundabout. Click on the slip lane in the
roundabout to display the Draw Slip Lane dialog box (page 2158). If you do not click on the slip lane, the Draw
Slip Lane dialog box is not displayed. Edit the slip lane by making changes to the parameters on the dialog
box.
For more information, see Slip Lanes (page 1629).
To edit a slip lane
1 Click Modify tab ➤ Design panel ➤ Intersection

.

2 On the Intersection contextual tab ➤ Modify Roundabout panel ➤ Edit Roundabout.
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You are prompted to select a roundabout.
3 Click on the slip lane that you want to edit.
NOTE You must click on a slip lane to display the Draw Slip Lane dialog box.
4 Make changes to the Draw Slip Lane dialog box and click OK.
The slip lane is updated in the drawing.

Quick Reference
Ribbon
Select the roundabout. Click Modify tab ➤ Design panel ➤ Intersection ➤ Edit Roundabout.
Command Line
EditRoundabout

Deleting Roundabouts
You can delete an entire roundabout, including approach roads and slip lanes, or just certain components
of the roundabout.
Where you click on the roundabout determines which roundabout components are deleted. The following
table describes the resulting behavior, depending on which roundabout component you clicked on after
executing the Delete Roundabout command.
Clicking on this component:

Has this result:

the roundabout central area, including the circulatory road alignments, markings, signs, or labels located in the central area

Deletes the entire roundabout, including all components associated with the roundabout (approach
roads, slip lanes, islands, marking, signs, and labels).

approach road

Deletes the approach road, including all components associated with the selected approach road,
such as islands, marking, and signs.

slip lane

Deletes the slip lane

sign

Deletes the sign, and the parent roundabout component the sign is attached to, such as the approach road, or slip lane. To delete just the sign,
select the sign, and then use the AutoCAD Delete
command.

marking (roundabout road marking, crosswalk, etc.)

Deletes the marking, and the parent roundabout
component the marking is attached to, such as the
approach road, or slip lane. To delete just the
marking, select the marking, and then use the
AutoCAD Delete command.

label

Deletes the label, and the parent roundabout
component the label is associated with, such as the
approach road, or slip lane. To delete just the label,
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Clicking on this component:

Has this result:
select the label, and then use the AutoCAD Delete
command.

When you delete a roundabout, or roundabout components, the pre-existing base alignments used to create
the roundabout, are not deleted.
To delete a roundabout
1 Click Modify tab ➤ Design panel ➤ Intersection

.

2 Click Intersection tab ➤ Modify Roundabout panel ➤ Delete Roundabout

.

You are prompted to select a roundabout.
3 Click on the roundabout central area to delete the entire roundabout, and all of its associated
components, or click on one of the following roundabout components to delete just that component:
approach road, slip lane.
The roundabout, or roundabout component, is deleted from the drawing.

Quick Reference
Ribbon
Select the roundabout. Click Modify tab ➤ Design panel ➤ Intersection ➤ Delete Roundabout.
Command Line
DeleteRoundabout

Deleting Approach Roads
Use the Delete Roundabout command to delete an approach road in a roundabout.
After you execute the Delete Roundabout command, you are prompted to select the roundabout. Clicking
on an approach road deletes just the approach road.
To delete approach roads
1 Click Alignment tab ➤ Modify Roundabout panel ➤ Delete Roundabout

.

You are prompted to select the roundabout.
2 Select the desired approach road, and then press Enter.
The approach road is deleted from the drawing.

Quick Reference
Ribbon
Click Alignment tab ➤ Modify Roundabout panel ➤ Delete Roundabout
Command Line
DeleteRoundabout
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.

Deleting Slip Lanes
Use the Delete Roundabout command to delete slip lanes in a roundabout.
Once you execute the Delete Roundabout command, you are prompted to select the slip lane. Clicking on
a slip lane deletes just the slip lane (polyline).
For more information, see Slip Lanes (page 1629).
To delete slip lanes
1 Click Alignment tab ➤ Modify Roundabout panel ➤ Delete Roundabout

.

You are prompted to select the roundabout.
2 In the roundabout, click on the desired slip lane, and then press Enter.
The slip lane is deleted from the drawing.

Quick Reference
Ribbon
Click Alignment tab ➤ Modify Roundabout panel ➤ Delete Roundabout

.

Command Line
DeleteRoundabout

Roundabout Drawing Standards
A roundabout drawing standards file controls the default parameters and values that are applied when a
roundabout is created.
For imperial drawings, the default roundabout drawing standards .xml file is located in:
C:\Documents and Settings\All Users\Application Data\Autodesk\C3D 2010\enu\Data\Corridor Design
Standards\Imperial
For metric drawings, the file is located in:
C:\Documents and Settings\All Users\Application Data\Autodesk\C3D 2010\enu\Data\Corridor Design
Standards\Metric
This .xml file contains values for roundabout parameters that are customized for specific geographical or
organizational requirements. For example, the roundabout design standard .xml file can contain one or more
design standards, or roundabout types, such as US standard, Florida standard, UK, France, and so on.
If desired, you can create your roundabout design standard .xml files to suit your own specific regional or
project needs.
A roundabout design standard .xml file also contains presets, which are sets of predefined values for certain
roundabout parameters. For more information, see Using Presets (page 1639).

Using Presets
You can create presets to save time when creating or editing roundabouts.
On roundabout dialog boxes, you can save the geometry parameter settings as a preset. To do this, use the
Predefined Parameters To Import choice on the dialog box.
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When you use this feature, you can specify and save certain roundabout parameter values on the dialog
boxes and store in the currently selected roundabout drawing standards .xml file as a preset.
You can give these presets a unique name to suit the needs of your project.
Only certain parameters are saved in the preset .xml file (primarily the geometry defining parameters). The
following table lists the parameters that can be saved as a preset using the Predefined Parameters To Import
choice on the dialog box.
Dialog Box

Parameters

Create Roundabout - Circulatory Road
Roundabout Parameters:

Outer Radius
Inner Radius (French standard only)
Circulatory Road Width (EN-US standard only)
Apron Width (EN-US standard only)
Traversable Extra Width (French standard only)

Markings Parameters:

Outer Offset
Number of Lanes to Mark
Inner Offset
Number of Lanes to Mark
Marker Line Width ,Lane Marker Linetype

Create Roundabout - Approach Road
Approach Road Parameters:

Exit Road Width
Exit Radius
Exit Flare Length
Exit Flare Type
Width At Departure
Entry Road Width
Entry Radius
Entry Flare Length
Entry Flare Type
Width At Approach

Create Roundabout - Islands
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Dialog Box

Parameters

Construction Traiangle Parameters:

Length
Base

Splitter Island Parameters:

Provide Crosswalk (Length)
Rounding At Exit
Offset From Circle At Exit
Offset At Exit
Offset At Departure
Rounding At Tip
Island Total Length
Island Base Length
Rounding At Entry
Offset From Circle At Entry
Offset At Entry
Offset At Approach
Rounding At Crosswalk

To save presets for roundabout parameters
Before you save the preset, make note of the roundabout drawing standards .xml file that is currently selected
for the roundabout. Any changes or additions you make to presets are saved within that .xml file.
1 Click Alignment tab ➤ Modify Roundabout panel ➤ Edit Roundabout

.

You are prompted to select the roundabout.
2 Select the roundabout.
3 On the roundabout dialog box, click the
the dialog box.

button in the Predefined Parameters To Import section of

The Preset - Add dialog box is displayed.
4 In the Preset Name field, type in a unique name to identify this set of presets.
NOTE All roundabout presets are stored in the currently selected roundabout drawing standards .xml file,
located by default in C:\Documents and Settings\All Users\Application Data\Autodesk\C3D
2010\enu\Data\Corridor Design Standards\Imperial or Metric. The Preset name identifies a particular set of
presets that are defined in that file. This provides a way to quickly create your own custom XML file to define
these settings.
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Roundabout Command Reference
You can use commands to quickly access roundabout functionality.
The following table lists the roundabout commands and briefly describes their functionality.
Command

Description

AddApproach

Adds an approach road to a roundabout (page
1632)

CreateRoundabout

Creates a roundabout by selecting a center point
and existing alignments (page 1631)

CreateTurnSlipLn

Adds a slip lane to a roundabout (page 1633)

DeleteRoundabout

Deletes the roundabout and associated components, such as center area, approach roads, and
slip lanes (page 1637)

EditRoundabout

Edits a roundabout (page 1634)
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You can annotate AutoCAD Civil 3D objects with labels that update dynamically when the drawing objects change.
Labels can contain single or multiple lines of text, blocks, ticks, lines, and direction arrows.
Labels have two modes: label mode and tag mode. Use tags to mark drawing objects with numbers so you can insert
detailed information in tables.
In AutoCAD Civil 3D, tag settings are a drawing-wide setting. See Creating Label Tags (page 1723) for more information.

Label Objects
AutoCAD Civil 3D includes independent label objects. Most labels in AutoCAD Civil 3D are implemented
as label objects that reside on their own layer.
NOTE Points, surface watershed, and all corridor labels are not object type labels. They are sub-entities of a parent
object and their properties are managed in the Label Properties dialog box.
■

Label objects are not highlighted when the parent object is selected as they are separate independent
objects.

■

Labels can include references to other AutoCAD Civil 3D objects by including Referenced Text (page 1693)
components.

■

You can label external reference (xref) data objects. When you insert xref objects from a source drawing
into your current drawing, you can annotate them as you would other objects. For more information,
see Labeling External References (Xrefs) (page 1710).

■

You can use alignment label styles to label superelevation critical points (page 929).

■

Label text can be overridden by using the Edit Label Text (page 1714) command on the shortcut menu.

■

Group Label Properties (page 1712) such as layer, linetype, and color are changed with the AutoCAD
Properties palette. You have the ability to simultaneously edit group labels with the Properties palette.

■

Label object properties are separate from the parent object. Use the Label List command (page 1665) to
display the label properties (including its designation as a single or group label object).

■

Label visibility (page 1665) can be controlled with label style settings or through layer management.

■

New label styles can reference the layer in the style, or the layer that the label(s) resides on. This gives
you the option of managing labels with styles (page 1671) or the use of layers.
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■

Labels that are part of a group can be selected individually and changed using “Ctrl+click” selection (page
1713).

■

A label’s default layer (page 1667) can be specified and changed with the Properties palette, or other AutoCAD
layer manipulation tools.

■

Alignment label styles are edited in the Alignment Labels Dialog Box (page 1952).

■

Use the Mapcheck Analysis command to determine values from label objects based on the precision of
the annotation of the label object. Click Analyze tab ➤ Ground Data panel ➤ Survey
drop-down ➤ Mapcheck

. For more information, see Performing a Mapcheck Analysis (page 1796).

■

This release of AutoCAD Civil 3D features label leader line enhancements for improved control and
flexibility when grip editing labels. See Editing Line, Arc, and Polyline Labels with Grips (page 1717), and
Managing Leader Vertices (page 1684) for more information.

■

Use the Label Stagger options to avoid densely populated graph views. These options allow you to stagger
labels for profile views, section views, and data bands for improved visibility. For more information, see
Staggering Profile and Section Labels (page 1707) and Staggering Data Band Labels (page 1707).

■

Data band labels are now object labels that can be edited, dragged, and reset like other label objects. See
Editing Data Band Labels (page 1708), Deleting Band Labels (page 1724), and Restoring Band Labels (page 1725)
for more information.

■

This release of AutoCAD Civil 3D include projected object label styles for profile and section views. See
Adding Profile View Labels (page 1132)and Using Section View Labels (page 1243)for more information.

The label objects are listed in the table below. Note that the label objects include two distinct object types:
group and single labels.
Group label objects and single label objects behave differently with respect to screen interaction and AutoCAD
object management. The selection of the group label objects is limited to the group (the entire group is
highlighted when selected), which means the context menu no longer applies to the perceived selected
label.
This group selection functionality allows you to simultaneously edit an entire group of labels. As group type
labels have an object controlling the creation and application of the label within a group, the AutoCAD
Properties palette lists information regarding the annotated object.
Single type labels do not list this information, but both types display Standard AutoCAD properties and
Label properties with the Properties palette. See Modifying Labels in a Drawing (page 1712) for more information.
The label objects are listed in the table below and are identified as either group or single labels.
Feature / Label Type

Group or Single Label

Note

Single

Segment

Single

Surface Slope

Single

Surface Spot Elev

Single

Surface Contour - Major, Minor, User

Group (no sub-entity selection)

Alignment Major Stations

Group

Alignment Minor Stations

Group
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Feature / Label Type

Group or Single Label

Alignment Geometry Point

Group

Alignment Station Equation

Group

Alignment Design Speed

Group

Alignment - Profile Geometry Point

Group

Alignment Station Offset - Fixed Point

Single

Alignment Station Offset

Single

Alignment Line

Single

Alignment Curve

Single

Alignment Spiral

Single

Alignment Tangent Intersect

Single

Parcel Line

Single

Parcel Curve

Single

Parcel Area

The first area label is part of the parcel
object (to select the parcel). Additional
area labels can be added, but they are
single.

Profile Major Stations

Group

Profile Minor Station

Group

Profile Horizontal Geometry

Group

Profile Grade Breaks

Group

Profile Line

Group

Profile Sag Curves

Group

Profile Crest Curves

Group

Profile View Depth

Single

Profile View - Station Elevation

Single

Sample Line

Group

Section Major Offset

Group

Section Minor Offset

Group

Section Grade Break

Group
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Feature / Label Type

Group or Single Label

Section Segment

Group

Section View Grade

Single

Network Pipe in plan

Single

Network Pipe in profile

Single

Network Pipe in section

Single

Network Structure in plan

Single

Network Structure in profile

Single

Network Structure in section

Single

Network Pipe - Spanning pipe

Single

Plans Production - View Frame

Single

Plans Production - Matchline

Group

Profile Data Band

Group

Section Data Band

Group

Understanding Labels
In AutoCAD Civil 3D, labels and tags are controlled by label styles.
In the Toolspace Settings tree, most feature collections, such as parcels, alignments, and surfaces, contain
their own unique label styles. When you define a label style, you determine the purpose of the label and set
up a relationship with the object that uses it. Labels always remain associated with the object they are
annotating.
General line and curve label styles can be used for parcel segments labels, and alignment line/curve labels.
Previously, general line label styles could modify only lines, curves, and polylines. For more information,
see Editing Label Styles (page 1661).
The general line label styles are available for the parcel, alignment, grading, and survey labeling commands.
Parcel tables now support general line/curve label types. Parcel tables display either general/line curve labels
or parcel segment labels. For more information, see Adding Parcel Tables (page 912).
There are three levels of label settings in addition to settings that you define in the label styles themselves.
For more information, see The Hierarchy of Label Settings (page 1648).
As you create AutoCAD Civil 3D objects in a drawing, they are labeled automatically using specified label
styles. However, after an object is created, you can add more labels manually.
Labels are defined by the following properties:
■

Location. Label location in a drawing depends on the object using the label.
For example, a parcel area label is usually placed at the center of the parcel, and surface contour labels
are usually placed on the contour line.
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■

Appearance and Visibility. Whether a label is visible, and how it appears in a drawing, can be specified
in the label style or by managing the AutoCAD properties. You can define different display settings, such
as color, lineweight, and linetype, for each label component.

■

Mode. Many label styles have two modes: label and tag. Tags are used to identify labeled objects within
a table. For more information, see Setting Up Label Styles To Be Used as Tags (page 1663).

■

Behavior. Labels behave according to their association with objects. For example, if you move an object
in a drawing, the label moves with it.
Also, behavior can also depend on how a label is positioned in a drawing.

■

Placement. A label is placed in relation to an object or another label style component. For more
information, see Anchor Points and Attachment Points (page 1671).

■

Plan-Readable text. Labels can be placed at any angle, but you can select a plan-readability setting to
maintain legibility. For more information, see Using Plan-Readability (page 1668) and Changing Label
Insertion (page 1669).

■

Orientation. Label orientation refers to the rotation angle of the labels in 3D space. For more information
about label orientation, see Changing Label Orientation (page 1667).

The commands used to add single and multiple label types from the parcels, alignments, and line/curve
menus support each of the three object types. For example, if you click Annotate tab ➤ Labels & Tables
panel ➤ Add Labels menu ➤ Line And Curve ➤ Add Single Segment Line/Curve Label
a parcel in the drawing, a parcel segment (line or curve) label is created.

and then select

The following object type/segments are supported by these commands:
■

line

■

arc

■

polyline line segment

■

feature line, line segment

■

feature line, arc segment

■

parcel line segment

■

parcel curve segment

■

alignment line segment

■

alignment curve segment

■

alignment spiral segment

The following table lists what determines the default style/style type when you use the add label command
from particular menus.
General
Parcel Line/Curve Alignment
Line/Curve Menu Menu
Line/Curve Menu
Create label on
line, curve, pline, or
feature line

Styles come from
line/curve settings
(General line/curve
style type).

Styles come from
Parcel settings
(General line/curve
style type, or parcel
types supported).

Styles come from
line/curve settings
(General line/curve
style type).
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General
Parcel Line/Curve Alignment
Line/Curve Menu Menu
Line/Curve Menu
Create label on Parcel Segment

Styles come from
line/curve settings
(General line/curve
style type).

Styles come from
Parcel settings
(General line/curve
style type, or parcel
types supported).

Styles come from
Parcel settings
(General line/curve
style type, or parcel
types supported).

Create label on
Alignment Segment

Styles come from
line/curve settings
(General line/curve
style type). When
labeling using
"Multiple" or
"Single," and any
spirals are labeled
they use the alignment settings for
the spiral style.

Styles come from
Alignment settings
(General line/curve
style type, or Alignment types supported). When labeling
using "Multiple" or
"Single," and any
spirals are labeled,
they use the alignment settings for
the spiral style.

Styles come from
Alignment settings
(General line/curve
style type, or Alignment types supported).

Create label on
Line, Curve, Pline
or Feature Line

Styles come from
Add Labels dialog

Styles come from
Add Labels dialog

Styles come from
Parcel settings
(General line/curve
style type, or parcel
types supported).

Create label on
Alignment Segment

Styles come from
Add Labels dialog.
When labeling using "Multiple" or
"Single," and any
spirals are labeled,
they use the alignment settings for
the spiral label
style.

If current style referenced in label tool
is line/curve type,
then that style is
applied. If style is
parcel type, get
styles from alignment settings.
When labeling spirals using "Multiple"
or "Single," and any
spirals are labeled,
they use the alignment settings for
the spiral style.

Styles come from
Add Labels dialog.

The Hierarchy of Label Settings
You can manage label style settings in a drawing at different levels using the Settings tree in Toolspace.
The hierarchy that label style settings use can be best viewed in the tree structure in Toolspace, shown in
the following illustration.
Edit label settings at the Drawing
level, object level (such as Surface),
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and label-style-type level (such as
Contour)

At each level, right-click and click
Edit Label Style Defaults

Each level of settings controls the characteristics in subordinate levels, unless a setting has been specifically
changed or overridden in the subordinate.
At the drawing level you can determine how table tags are numbered. Click the drawing name, right-click
and click Table Tag Numbering to access the Table Tag Numbering Dialog Box (page 2209). For more
information, see Creating Label Tags (page 1723).

Tag numbering settings are drawing-wide settings

Overview of Label Styles
Use a label style to define the behavior, appearance, and content of labels.
Every label in the drawing has a style associated with it, and edits to the label styles are immediately reflected
in the labels in the drawing.
In the Toolspace Settings tree, Label Styles collections contain one or more types of label styles that represent
a unique aspect of the object using it. The following illustration shows the hierarchy of the label style
collection, the label style types, and the individual label styles:
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Parcel Area label style type collection

Each label type has a Standard label style. The AutoCAD Civil 3D drawing templates also contain several
other label styles you can use.
You can create child styles that are based on an existing style. For more information, see Defining Children
of Existing Label Styles (page 1657).

Viewing and Selecting Available Label Styles
Use the Toolspace Settings tree to view available label styles in a drawing.
NOTE You can identify a label style in the Settings tree by
then

next to it. If a label style is in use in the drawing,

is displayed when the Drawing Item State icons are visible in Toolspace.

To view available label styles
1 In Toolspace, click the Settings tab.
TIP From the View Control list, select Active Drawing Labels Only View. Or, if you have more than one
drawing open, select Labels Only View.
2 Expand the Settings tree by clicking

next to a drawing name.

3 Expand a feature collection, such as the Surface collection.
4 Expand the Label Styles collection to display the label style types inherent to that object.
In the Alignment, Profile, and Section collections, you can also view any label sets (page 1725) for that
feature.
5 Expand the label style type collection to view the available label styles.
6 Right-click a label style to access commands for working with the style. You can edit, delete, or copy
the style, or create a new child style.
NOTE Right-click the label style type collection and click New to create a new label that is not a child style
of an existing style.

OR
1 In the drawing, select the label to edit. Right-click and select Edit Label Style.
2 In the Label Style Control (page 2203) box, click the Select a Style arrow to display a list of available styles.
OR
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1 Select a label, right-click and select Properties or Label Properties.
2 In the Properties palette, click Line or Curve label style to display a list of available styles.
Select the Edit/Create option to access the Label Style Control (page 2203) dialog box with which you can
create a new style, copy the currently selected style, create a child style, or edit the currently selected
style with the Label Style Composer.
OR
1 In the drawing, select the label to edit.
2 Select the Labels tab ➤ Label Properties drop-down menu ➤ Edit Label Style to access the Label Style
Control (page 2203) dialog box.

Quick Reference
Ribbon
Click Labels tab ➤ Modify panel ➤ Label Properties drop-down ➤ Edit Label Style
Toolspace Shortcut Menu
Settings tab: <drawing name> ➤ <object collection> ➤ Label Styles ➤ <label style type name> ➤ <label
style name>

Predefined Label Styles in Templates
Use drawing templates provided with AutoCAD Civil 3D to access predefined label styles for each feature.
Use these styles as-is or use them as a basis for creating your own styles.

Standard Label Styles
By default, all label style types have a Standard label style.
When you create a new drawing without a reference to a template (.dwt), the label style types in the Label
Styles collections in the Settings tree contain a Standard label style based on default settings. You can use
the Standard style as-is, or you can use it as a basis for a new style by changing its properties and renaming
it.
You can delete a Standard label style only when it is not referenced in a drawing or if it is not a “parent”
label style with a subordinate “child” label style. For more information, see Defining Children of Existing
Label Styles (page 1657).

Working with Label Styles in Toolspace
Use the Settings tree to create or edit label styles.
Right-click either a label style type or a specific label style to display a shortcut menu with options for working
with label styles.
Select this command…

If you want to…

Right-click label style ➤ New
(page 1657)

Create a label style that is based on the settings
of a parent label style. This command displays
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Select this command…

If you want to…
the Label Style Composer and contains “Child
of...” as the label style name.

Right-click label type ➤ New
(page 1656)

Create a label style that is not a child of an existing label style. The new label style is a parentlevel style and obtains its defaults from the label
type settings.

Right-click label style ➤ Edit
(page 1686)

Edit a label style in the Label Style Composer.

Using Label Styles From Other Drawings
Use a label style from any open drawing by dragging the style from one drawing to another in the Settings
tree. You can also drag the style from the Settings tree into the drawing window to copy it into that drawing.
When you attempt to copy a named label style to a location where a matching named label style exists, you
are prompted with a warning, and you can choose one of the following options:
■

No: Leaves the existing style and cancels the operation.

■

Yes: Copies the style to the new drawing and renames the style using the format <source drawing
name>.<style name>.1

Using Child Label Styles From Other Drawings
If you copy a child label style to another drawing, its parent style is also copied.
TIP Because you can only drag one label style at a time into another drawing, it is more efficient to set up your
commonly used label styles in a DWT file that you can use for each new drawing you create.
To use label styles from other drawings
1 Open the drawing that contains the styles you want to copy (Drawing1, for example), and the drawing
you want to copy styles to (Drawing2, for example).
2 In Toolspace, click the Settings tab.
3 From the View Control list, select Labels Only View to see the labels in all open drawings.
4 In the Settings tree, expand the Drawing1 collection and select the label style that you want to copy.
5 Drag and drop the label style to Drawing2 in the Settings tree. You must drag the style over the drawing
name in the Settings tree before releasing the mouse button.
■

A valid drag and drop operation will display a

■

An invalid drag and drop operation will display a

cursor.
cursor.

Previewing Label Styles
Use the preview window to view how a label style will appear in the drawing. When you make modifications
to the label style, the preview window updates.
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The preview window is located on the General, Layout, and Dragged State tabs of the Label Style Composer
(page 1686). You can select a different preview by selecting it in the Preview list.
To change the view in the Preview window, you can use AutoCAD commands on the shortcut menu, such
as Pan and Zoom.
Previews are actually stored as DWG files in the \Data\Preview folder. If you would like to add your own
preview drawings that contain specific label styles, you can place the drawings in the Preview folder.
NOTE Do not rename the Preview folder or its sub-folders. Any changes to the folder structure prevents AutoCAD
Civil 3D from accessing the preview drawings.
To add preview drawings to the Preview folder
1 Create a new drawing, create one or more label styles, and label an object with the label styles you want
to preview.
2 Click App Frame ➤ Save As.
3 Navigate to the Data\Preview folder and save the drawing file.
NOTE The \Data folder path is set up during installation.

To view a preview drawing in the Preview pane
1 On the General, Layout, or Dragged State tabs of the Label Style Composer (page 2180), click the Preview
arrow in the upper-right corner of the dialog box to display a list of preview drawings.
2 Select the preview drawing you want to view.
3 Right-click in the preview pane to access commands you can use to change the display of the preview
drawing.

Scaling Labels in Drawings
Labels are scaled relative to the drawing scale in model space, and are scaled to the assigned text height in
paper space, regardless of the viewport scale.

Model space scaling
In model space, label text height is controlled by the drawing scale and the text height as specified in the
label style.
For example:
■

In a 1:50 scale drawing, with the label text height 0.1, the labels are created at a height of 5'.

■

In a 1:100 scale drawing, with the label text height 0.1, the labels are created at a height of 10'.

Paper space scaling
In paper space, label text always appears at the same height regardless of the paper space viewport scale.
For example, label text height set to 0.1 appears as 0.1 inch on the plotted sheet, regardless of viewport scale
or zoom level.
You must use the REGENALL command to update the label display on the screen when you either change
the paper space viewport scale or zoom.

Scaling Labels in Drawings | 1653

Scaling of Xrefs
Labels in drawings that you xref also respect the scale of paper space viewports, so you can create project
documentation in paper space at the correct scale for several drawings at the same time.
NOTE To label an xref object, the scale of the inserted xref is must be 1,1,1.

Recommendations for managing AutoCAD Civil 3D labels in a viewport
When working with labels in a viewport, do not use the Annotation Scale at the bottom of the drawing
window as this will change the viewport scale.
When working with labels in a viewport, you should use one of the following methods:
■

Use the Standard Scale in the View Port Properties Palette window. This will not change the Annotation
Scale.

■

Use the zoom command in the viewport to get the desired viewport zoom scale.

NOTE You can reset dragged labels per viewport.

Defining Label Settings
You can define default label settings at three different levels. Each level controls default characteristics in
subordinate settings and in the label styles.
At subordinate levels you can override the default settings. However, you can lock the default settings so
that they cannot be changed.

Default Settings for All Label Styles in a Drawing
Label style defaults that you set at the drawing level can affect every label style in the drawing.
To specify default label style settings for a drawing
1 In Toolspace, on the Settings tab, right-click a drawing name, and click Edit Label Style Defaults.
2 In the Edit Label Style Defaults - Drawing (page 2179) dialog box, define defaults for all labels in a drawing
by changing the settings in the Value column.
TIP Using the Visibility setting in the drawing-level label settings is a quick way to turn off all labels in a
drawing.
If you want a different setting for an individual label style, you can override the default in a subordinate
setting.
3 Optionally, lock any setting by clicking

to change it to

.

4 Click OK.

Quick Reference
Toolspace Shortcut Menu
Settings tab: Right-click <drawing name> ➤ Edit Label Style Defaults
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Dialog Box
Edit Label Style Defaults - Drawing (page 2179)

Default Settings for All Label Styles in a Feature
Label style defaults that you set at the feature level can affect every label style defined for that specific feature.
To specify default label settings for all label styles in a feature
1 In Toolspace, on the Settings tab, right-click a feature collection and click Edit Label Style Defaults.
2 In the Edit Label Style Defaults <Feature Name> (page 2179) dialog box, define defaults for all label styles
belonging to the feature by changing the property settings in the Value column.
When you change a value at the current level, the check box
column.
3 Optionally, lock any setting by clicking

to change it to

is selected in the Override (page 2198)

.

4 Click OK.

Quick Reference
Toolspace Shortcut Menu
Settings tab: <drawing name> ➤ Right-click <object collection> ➤ Edit Label Style Defaults
Dialog Box
Edit Label Style Defaults <Feature Name> (page 2179)

Default Settings for All Labels in a Label Type
Label style defaults that you set at the label-style-type-level can affect every label style defined for that specific
label style type.
To specify default settings for all labels in a label type
1 In Toolspace, on the Settings tab, right-click a label style type and click Edit Label Style Defaults.
NOTE Label style types are the lowest-level collection within the Label Styles collection. For example, under
Alignment, expand Station to display the label style types Major Station, Minor Station, Geometry Point, and
so on.
2 In the Edit Label Style Defaults <Style Type> (page 2180) dialog box, define defaults for all label styles
belonging to that label type collection by changing the property settings in the Value column.
When you change a value at the current level, the check box
column.
3 Optionally, lock any setting by clicking

to change it to

is selected in the Override (page 2198)

.

4 Click OK.
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Quick Reference
Toolspace Shortcut Menu
Settings tab: <drawing name> ➤ <object collection> ➤ Label Styles ➤ Right-click <label style type name>
➤ Edit Label Style Defaults
Dialog Box
Edit Label Style Defaults <Style Type> (page 2180)

Changing Command Settings for Labeling Lines, Arcs, and Notes
Specify the default styles to use when inserting Note and Line and Curve labels.
To specify default styles for Note and Line and Curve Labels
1 In Toolspace, on the Settings tab, expand the General collection.
2 Expand the Commands collection.
3 Right-click a command item and click Edit Command Settings.
4 Expand Default Styles.
5 Specify the styles for each label type.
6 Click OK.

Quick Reference
Toolspace Shortcut Menu
Settings tab: <drawing name> ➤ General ➤ Commands ➤ Right-click <command name> ➤ Edit
Command Settings
Dialog Box
Edit Feature Settings - General Dialog Box (page 2015)

Creating and Editing Label Styles
You can create new label styles that are derived from existing styles and styles that are independent of
existing label styles. When you edit a label style, all labels in the drawing that use that style are updated.
NOTE Label style names are case-sensitive. For example, the label name “Standard” is not the same as “standard”.

Creating New Label Styles
Define the settings for a new or existing label style by using the Label Style Composer.

Defining an Independent Label Style
You can define a label style that has no dependencies on another existing label style.
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To define an independent label style
1 In Toolspace, on the Settings tab, right-click a label style type and click New.
NOTE Label style types are the lowest-level collection within the Label Styles collection. For example, under
Alignment, expand Station to display the label style types Major Station, Minor Station, Geometry Point, and
so on.
2 In the Label Style Composer, click the Information (page 2180) tab and enter a name in the Name box.
3 Use the other tabs in the Label Style Composer (page 2180) to change the settings.
4 Click OK.

Quick Reference
Toolspace Shortcut Menu
Settings tab: <drawing name> ➤ <object collection> ➤ Label Styles ➤ right-click <label style type name>
➤ New
Dialog Box
Label Style Composer (page 2180)

Defining New Label Styles by Copying Existing Label Styles
Create a copy of a label style.
To copy label styles
1 In Toolspace, on the Settings tab, right-click a label style and click Copy.
2 In the Label Style Composer, click the Information (page 2180) tab and enter a name in the Name box.
3 Use the other tabs in the Label Style Composer (page 2180) to change the settings.
4 Click OK.

Quick Reference
Toolspace Shortcut Menu
Settings tab: <drawing name> ➤ <object collection> ➤ Label Styles ➤ <label style type name> ➤
right-click <label style name> ➤ Copy
Dialog Box
Label Style Composer (page 2180)

Defining Children of Existing Label Styles
You can define a new child label style that derives its default settings from an existing label style, or parent.
To create a child of a label style
1 In Toolspace, on the Settings tab, right-click a label style, and click New.
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In the Label Style Composer, “<name of parent style> [Child]” is displayed in the title bar.
2 Click the Information (page 2180) tab, and enter a name in the Name box.
3 Use the other tabs in the Label Style Composer (page 2180) to change the settings.
4 Click OK.

Quick Reference
Toolspace Shortcut Menu
Settings tab: <drawing name> ➤ <object collection> ➤ Label Styles ➤ <label style type name> ➤
right-click <label style name> ➤ New
Dialog Box
Label Style Composer (page 2180)

Automatically-Created Child Styles
To be displayed in a table, the labels must be converted to tag display mode. Tag and label mode are style-wide
settings. However, when you manually select labels that are in label mode, AutoCAD Civil 3D generates a
child style that is set to tag mode and changes only the selected label to this new child style.

Selecting Labels to Add to a Table
When you insert a table, you can specify the contents of the table in two ways:
■

The table can contain all labels of a particular label style.

■

You can select the labels to add to the table from the drawing.

When you use the second method, you are prompted to create a child style if the selected labels are currently
in Label display mode.
The following illustration shows the Selection section of the Add Table dialog box:

To add all labels of a particular label style name to a table, select the Apply check box next to the label style
name. When you use this method, all the labels are switched to tag mode, and a child style is not created.
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To add selected labels of a particular style to a table, click
and click the labels. When you select a label
in the drawing that is not in Tag display mode, a dialog box is displayed informing you that the label is not
currently in tag mode and asking whether you want to create a new child style.
Click Yes to continue (if you click No a child style is not created and the label is not added to the table).
Clicking Yes creates a child style of the current label style in the format <style name>.Tag.1.
If you want to avoid generating child styles when creating a table, then you can do either of the following:
■

Always use the style-based selection method when creating tables. You can specifically set up “tag” label
styles to use for this purpose, and use the tag label styles to label only those entities you want to insert
into the table. For more information, see Setting Up Label Styles To Be Used as Tags (page 1663).

■

Before creating a table, switch the label style display mode to Tag. Then when you use the Select In
Drawing method when tags are displayed, child styles are not created. For more information on switching
to tag mode, see Displaying Labels as Tags (page 1666).

Creating Label Styles for Lines, Curves, and Polylines
Line, Curve, and Polyline labels use the styles that are defined in the General ➤ Label Styles collection in
the Settings tree.
Polylines use Line label styles for straight segments and Curve label styles for curved segments. You can set
up the Line and Curve label styles to label the total length and area of polylines by using the “Overall” label
properties.
To create a line or curve label style
1 In Toolspace, on the Settings tab, expand the General ➤ Label Styles collection.
2 Right-click the Line or Curve collection and click New.
3 Use the tabs on the Label Style Composer (page 2180)to set up the label style.
NOTE From the Layout tab, you can add or edit label components to include the overall length of lines and
polylines and the total area of polylines. Follow the steps in Adding Text Components to Labels (page 1686)
and use the General Overall Length and General Overall Area properties.
4 If you have multiple components in the label style, be sure to specify appropriate Anchor Points and
Attachment Points (page 1671) so the components do not overlap. You can use the Preview window to
check the label layout.
NOTE Specify the default layer for Line and Curve labels on the Layers tab (page 82) of the Drawing Settings
dialog box. You can also change the layer of these labels by using the AutoCAD Properties palette (right-click label
and select Label Properties or Properties).

Quick Reference
Toolspace Shortcut Menu
Settings tab: <drawing name> ➤ General ➤ Label Styles ➤ right-click Line or Curve ➤ New
Dialog Box
Label Style Composer (page 2180)
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Creating Note Labels
Note label styles are inserted at selected points in the drawing, and are not physically attached to specific
objects. They can use Referenced Text components to contain references to other objects in the drawing.
The insertion point of a Note label can be used to identify location-based Referenced Text data. For example,
in the following illustration, the insertion point determines the station and offset values that appear in the
label.

Note insertion point determines offset and station values

Offset = - 50 feet
from station 9+50 on Oak Street

9+00

10+00

11+00

Offset = 100 feet
from station 8+50 on Oak Street

Referenced Text Component
refers to alignment offset, station, and name

This component would be set up as follows in the Text Component Editor:
Offset = <[Offset(Uft|P3|RN|Sn|OF|AP)]> feet
from station <[Station Value(Uft|FS|P2|RN|AP|Sn|TP|B2|EN|W0|OF)]> on <[Name(CP)]>

To create a note label style
1 In Toolspace, on the Settings tab, expand the General ➤ Labels collection.
2 Right-click the Note collection and click New.
3 On the Information tab of the Label Style Composer dialog box, specify a name for the new style.
4 Click the Layout tab (page 2183).
5 A default text component is created by default. To change the text string, under Text, click the Contents
row. Then click

.

6 In the Text Component Editor (page 2199), edit the text for the note as needed. You can type directly
into the window.
7 Close the Text Component Editor window.
8 If you want to reference objects in the drawing, create a Referenced Text (page 1693) component for each
object you want to reference.
For example, you can create a note label with two Referenced Text components, each which refers to
an alignment name. You can then insert that label at the intersection of two alignments, and select the
intersecting alignments as the object data.
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Intersection of Elm Street and
Oak Street

9 If you have multiple components in the label style, be sure to specify appropriate Anchor Points and
Attachment Points (page 1671) so the components do not overlap. You can use the Preview window to
check the label layout.
10 Use the other tabs on the Label Style Composer (page 2180)to set up the label style.
NOTE Specify the default layer for Note labels on the Layers tab (page 82) of the Drawing Settings dialog box.
You can also change the layer of these labels by using the AutoCADProperties palette (right-click label and select
Label Properties or Properties).
See also:
■

Inserting Note Labels (page 1709)

Quick Reference
Toolspace Shortcut Menu
Settings tab: <drawing name> ➤ General ➤ Label Styles ➤ right-click Note ➤ New
Dialog Box
Label Style Composer (page 2180)

Editing Label Styles
Use the Edit Label Style command to specify a label style for an object, to create a new style, or to copy or
edit an existing label style.
When you edit a label style, all labels in the drawing that reference that style are updated.
Edit an existing label style by using the Label Style Composer. You can access the Label Style Composer from
Toolspace Settings tab or from the label object’s context menu.
The Label Style Composer can also be accessed from the AutoCAD Properties palette by selecting Create/Edit
from the available style drop-down menu. In the Label Style Control (page 2203) dialog box, select Edit Current
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Selection. You can use the Style Selection pull-down menu in the AutoCAD Properties palette to bulk edit
label properties for labels placed in the drawing. This is a convenient method of editing label styles without
having to navigate to the Toolspace Settings tab.
Notice in the following example that in addition to the Parcel Line Label Styles, the General Line Label Style
is available for use when editing a Parcel Line Label.

AutoCAD Properties palette list of available label styles

To edit an existing label style
1 In Toolspace, on the Settings tab, right-click the label style you want to edit and click Edit.
2 Use the Label Style Composer (page 2180) to edit the label style.
3 Click OK.
OR
1 In the drawing, select a label, right-click and select Properties or Label Properties.
2 In the Properties palette, click Line or Curve label style to display a list of available styles.
Select the Edit/Create option to access the Label Style Control (page 2203) dialog box with which you can
create a new style, copy the currently selected style, create a child style, or edit the currently selected
style with the Label Style Composer.
OR
1 In the drawing, select the label to edit.
2 Right-click and select Edit Label Style.
3 In the Label Style Control (page 2203) dialog box, specify a label style, create a new style, or copy or edit
an existing style. Press

to access the Label Style Composer.

Quick Reference
Ribbon
Select the label. Click Labels tab ➤ Modify panel ➤ Label Properties drop-down ➤ Edit Label Style
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Toolspace Shortcut Menu
Settings tab: <drawing name> ➤ <object collection> ➤ Label Styles ➤ <label style type name> ➤
right-click <label style name> ➤ Edit
Dialog Box
Label Style Composer (page 2180)

Modifying Label Style Content
Label content contains information that is linked directly to an object and consists of text, symbols, blocks,
lines, ticks, and direction arrows. Set up this content by using the Label Style Composer.
To modify the content of a label style
1 In the Settings tree, right-click an existing label style and click Edit.
TIP Create a new drawing using one of the default AutoCAD Civil 3D drawing templates, which contain a
set of pre-defined label styles.
2 In the Label Style Composer dialog box, click the Layout tab.
3 Click the Component Name list to see which components have been defined for the label style. The
components control the label content.
4 To modify the content of a label component, select its name in the Component Name list.
5 Under Text, click in the Value column of the Contents row to display the Browse button
in the following illustration:

, as shown

6 Click
to display the Text Component Editor, where you can change the label properties. For more
information, see Adding Text Components to Labels (page 1686).
7 You can also edit the static text in the label. For more information, see Editing Text in the Text
Component Editor (page 1690).

Setting Up Label Styles To Be Used as Tags
If a label style supports the use of tags and tables, there are a few unique properties you can manage in the
style by changing settings in the Label Style Composer.
■

Display Mode. Controls whether the labels are currently displayed as labels or tags. This switches to tag
mode automatically when a table is inserted into the drawing using the style-based selection method.

■

Table Tag Component. A unique component that is defined on the Layout tab of the Label Style Composer
and is required for labels that support tables.

■

Label “Used In” Property. Controls whether label style components (such as text or blocks) are used in
label mode, tag mode, or both.

A single label style can contain settings for both the label mode and the tag mode. You do not have to have
separate label styles set up for tags. However, it may help you manage your drawings (and prevent additional
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styles from being created automatically) if you set up a style with its default state set to tag mode and give
the style an explicit name. For more information, see Automatically-Created Child Styles (page 1658).
To set up a label style for tags
1 Create a new label style and give the style a unique name. For more information, see Creating and
Editing Label Styles (page 1656).
2 With the new style open in the Label Style Composer dialog box, click the General tab.
3 Under Label, set the Display Mode to Tag. This sets the default state of this label style to tag mode.
Then, when you label an object with this style, tags are created rather than full labels. For more
information, see Displaying Labels as Tags (page 1666).
4 Click the Layout tab and select the Table Tag component in the Component Name list. This component
is required for labels that support tables. You cannot delete or change the name of this component.
5 Under General, set the value of Used In property. For Table Tag components, the tag can be displayed
in tag mode or in label and tag modes. For more information, see Layout Tab (Label Style Composer
Dialog Box) (page 2183).
6 Under Text, click the Value column for Contents and then click
Editor.

to display the Text Component

7 Note the property listed in the Properties list. Table tags support only the Segment Number property
field. For more information, see Property Fields (page 1691).
8 In the Text Component Editor, edit the static text as needed. You can change “C” to “Curve” for
example. Do not alter the property field itself. For more information, see Editing Text in the Text
Component Editor (page 1690).
9 You can click the Format tab to change the tag justification or color, for example. For more information,
see Formatting Text (page 1688).
10 Click OK in the Text Editor window and the Label Style Composer to close them.
11 Use the new label style for tagging objects, and then insert an object table into the drawing. For more
information, see Adding Labels to Drawings (page 1701).

Managing Properties for Label Styles
Use the Label Style Composer dialog box to define properties for label styles.

Managing General Properties for Label Styles
Use the General tab of the Label Style Composer dialog box to define label style layer, visibility, display
mode, and text style. The General properties also include behavior rules regarding how a label is oriented
to an object, and whether it is plan-readable.

Specifying Label Text Style
Each label style has one AutoCAD text style associated with it.
To specify the text style to use for a label style
1 In the Label Style Composer dialog box, click the General (page 2181) tab.
2 Under Label, click the Value column for the Text Style property, and then click
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.

3 In the Select Text Style dialog box, select a text style.
4 Click OK.

Quick Reference
Toolspace Shortcut Menu
Settings tab: <drawing name> ➤ <object collection> ➤ Label Styles ➤ <label style type name> ➤
right-click <label style name> ➤ Edit
Dialog Box
Label Style Composer (page 2180)

Displaying Label Properties with the List Command
Use the AutoCAD List command to display label property information.
To display the AutoCAD Text Window
1 In the drawing, select a label.
2 In the command line, enter List.
3 The AutoCAD Text Window dialog box displays the label type, entity type, and layer.
Group type labels display “GROUP” at the end of the entity type, as well as the parent object and the
default label style. For example, AECC_ALIGNMENT_STATION_LABEL_GROUP Layer: "0". In this case,
the entity type is alignment station. The label type is group, and the layer is set to zero.
4 Single type labels differ from group labels as they do not display “GROUP” at the end of the entity type
listing, and the label style is displayed.
NOTE The alignment label type vertical geometry point label does not include “GROUP” at the end of the
entity type listing. It is called: AECC_ALIGNMENT_VAGEOMPOINT_LABELING.

Quick Reference
Command Reference
List
Dialog Box
AutoCAD Text Window

Hiding and Displaying Labels in the Drawing
The label style Visibility setting controls whether the labels are visible in the drawing. You can use this
setting to quickly hide and display all labels of a particular label style.
In previous releases of AutoCAD Civil 3D, most labels were sub-entities of the parent object. If the parent
object was frozen, the labels would disappear with the frozen parent object. The independent label objects
are no longer sub-entities of the parent object but still behave as previously. You also have the option of
controlling label visibility independently through layer manipulation (with either the label style layer
references, label visibility switches, or the layer that the label object itself resides on).
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To hide or display labels in a drawing
1 In the Label Style Composer dialog box, click the General (page 2181) tab.
2 Under Label, change the Visibility value to True or False.
3 Click OK.

Quick Reference
Toolspace Shortcut Menu
Settings tab: <drawing name> ➤ <object collection> ➤ Label Styles ➤ <label style type name> ➤
right-click <label style name> ➤ Edit
Dialog Box
Label Style Composer (page 2180)

Displaying Labels as Tags
Display labels as tags when you want label content to be in a table.
Tags contain an identifier number that is displayed in the first column in an associated table. The other
columns of the table display the object data as defined in the table style. For more information about creating
tables, see Tables (page 1737).
General line and curve label styles can be displayed as tags. Tag display mode is also supported by parcel
and alignment segments labels as well as curve labels. You can specify the tag start number and increment
numbers in the Table Tag Numbering Dialog Box (page 2209).
NOTE By setting label styles to Tag display mode before creating tables, you can avoid creating unnecessary child
styles. For more information, see Automatically-Created Child Styles (page 1658).
To display labels as tags
1 In the Label Style Composer dialog box, click the General (page 2181) tab.
2 Under Label, change the Display Mode value to Tag.
NOTE Some label types (such as parcel area labels and alignment station labels) cannot be displayed in tag
mode and therefore do not have the Display Mode property.
3 Click OK.

Quick Reference
Toolspace Shortcut Menu
Settings tab: <drawing name> ➤ <object collection> ➤ Label Styles ➤ <label style type name> ➤
right-click <label style name> ➤ Edit
Dialog Box
Label Style Composer (page 2180)
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Specifying the Label Style Layer
Each label style can be assigned to its own layer. The independent label objects reside on their own layer.
You can also specify reference layer within the label style.
NOTE Specify the default layer for labels on the Object Layers tab (page 82) of the Drawing Settings dialog box.
You can also change the layer of these labels by using the AutoCAD Properties palette (right-click label and select
Label Properties or Properties), or any other object layer manipulation tool.
To specify the label reference style layer
1 In the Label Style Composer dialog box, click the General (page 2181) tab.
2 Under Label, click the Value column for Layer and then click

.

3 In the Layer Selection dialog box, select a layer, or create a new one.
4 Click OK.

Quick Reference
Toolspace Shortcut Menu
Settings tab: <drawing name> ➤ <object collection> ➤ Label Styles ➤ <label style type name> ➤
right-click <label style name> ➤ Edit
Dialog Box
Label Style Composer (page 2180)

Changing Label Orientation
Labels are composed relative to a zero angle (the default X axis), and are placed in a drawing based on an
orientation setting.
Label offsets and rotation values are measured relative to the orientation setting.
To change the orientation of labels
1 In the Label Style Composer dialog box, click the General (page 2181) tab.
2 Under Behavior, change the Orientation Reference value to the desired item.
3 Click OK.

Quick Reference
Toolspace Shortcut Menu
Settings tab: <drawing name> ➤ <object collection> ➤ Label Styles ➤ <label style type name> ➤
right-click <label style name> ➤ Edit
Dialog Box
Label Style Composer (page 2180)
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Using Plan-Readability
Use the plan-readability settings to make label text readable in a normal plan view.
When you select the plan-readable option, label text is rotated to a consistent readable angle.
You can specify the angle at which to start flipping labels. By default this angle is set to 110 degrees. That
means that as soon as the angle of the text goes beyond 110 degrees, the label will flip 180 degrees to remain
plan-readable.
The following illustration shows labels with Plan Readable set to False. Note the label at the bottom of the
illustration:

The following illustration shows labels with Plan Readable set to True:

To make a label style plan-readable
1 In the Label Style Composer dialog box, click the General (page 2181) tab.
2 Under Plan Readability, change the Plan Readable value to True.
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3 Change the Readability Bias angle to the angle at which you want the labels to start flipping. For
example, an angle of 110 degrees means that label text inserted at an angle greater than 110 degrees is
flipped.
NOTE The labels are flipped again when they reach 180 degrees from the Readability Bias angle. For example,
if the bias angle is 90, the labels are flipped at 90 degrees, and then are flipped again at 270 degrees.
4 Set the Flip Anchors With Text setting to False to flip labels so they are mirrors of the original labels.
Set this setting to True if you also want to flip the label’s anchor point.
NOTE In most cases, it is not desirable to have this setting set to True. However, there are cases where it is
needed, such as with a station label with a plus sign located always at the station tick.
5 Click OK.

Quick Reference
Toolspace Shortcut Menu
Settings tab: <drawing name> ➤ <object collection> ➤ Label Styles ➤ <label style type name> ➤
right-click <label style name> ➤ Edit
Dialog Box
Label Style Composer (page 2180)

Changing Label Insertion
You can force labels to the top or bottom of objects or to the inside of curves.

Top
This setting ensures that the label is always placed on top of the object, regardless of the relationship to the
zero angle of an object. The Top setting determines label placement based on the same calculation used for
Plan Readability. For more information, see Using Plan-Readability (page 1668).

Bottom
This setting ensures that the label is always placed beneath the object, regardless of the relationship to the
zero angle of an object. The Bottom setting determines label placement based on the same calculation used
for Plan Readability.
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Force to Inside of Curve
This setting ensures that the label is always placed in the inside of a curve regardless of the zero direction
of the curved object.

None
This setting places labels as they relate to the calculated zero angle of an object. It does not change label
composition and, in essence, ignores any label placement rules.

To change label insertion
1 In the Label Style Composer dialog box, click the General (page 2181) tab.
2 Under Behavior, change the Forced Insertion value to either None, Top, or Bottom.
3 Click OK.
To change label insertion for curves
1 In the Label Style Composer dialog box, click the General (page 2181) tab.
2 Under Behavior, change the Force Inside Curve value to either True or False.
3 Click OK.

Quick Reference
Toolspace Shortcut Menu
Settings tab: <drawing name> ➤ <object collection> ➤ Label Styles ➤ <label style type name> ➤
right-click <label style name> ➤ Edit
Dialog Box
Label Style Composer (page 2180)
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Managing Layout Properties for Label Styles
You use the Layout tab of the Label Style Composer dialog box to control text and border settings, display
properties, and content.
Layout properties are controlled independently for each label component. A label component can be text, a
block, a line, a tick, or a direction arrow.
For example, a parcel line “Bearing Over Distance” label may have four components:
■

Bearing. A text component that labels the line’s angle.

■

Distance. A text component that labels the line’s distance.

■

Table Tag. A text component. Used only for table insertion. Required for labels that can be inserted into
tables.

■

Direction Arrow. A direction arrow component that is positioned relative to the Bearing.

You can use the Layout properties to control each of these components separately.
NOTE For more information about defining new label components, see Adding Content to Labels (page 1686).
NOTE This section describes the Layout Properties for Text Components. Many of the same properties are available
for Block, Tick, Line, and Direction Arrow components. Additional layout properties are described in Blocks (page
1696), Ticks (page 1697), Lines (page 1695), and Direction Arrows (page 1699).

Anchor Points and Attachment Points
Label component position is defined by specifying an anchor component, an anchor point, and an attachment
point. Rotation angles and X and Y offsets are applied in relation to the anchor component and anchor
point.
■

Anchor Component. The anchor component is the item that the label component is positioned relative to.
It can be the object that is labeled, or it can be another label component.

■

Anchor Point. The anchor point is the location on the anchor that is attached to the label component’s
attachment point. It can be the label location (when the anchor component is set to Feature) or it can be
one of several locations on the label component (when the anchor component is set to a specific label
component).

■

Attachment Point. The attachment point is the location on the label component that is attached to the
anchor point.

The following illustration shows how these points work together to position the label component (the
rotated text in the illustration):
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Anchor and attachment points for text component

The anchor is on a line (the anchor is set to Feature and the anchor point to Label Location). The attachment
point on the text is set to Bottom Left. Note how the X and Y offsets, angle, and border gap all affect how
the label is positioned relative to the attachment and anchor points
The following illustrations show the different points on label components that can be used either as anchor
points or attachment points.

Anchor and attachment points on text component

Anchor and attachment points on a block component

NOTE The location of the insertion point is defined in the block itself. The anchor and attachment points are the
same on blocks and ticks.
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Anchor and attachment points on a direction arrow
component

NOTE The anchor and attachment points are the same on direction arrows and lines.
To specify anchor and attachment points for a label component
1 In the Label Style Composer dialog box, click the Layout (page 2183) tab.
2 Select a component from the Component Name list.
3 Under General, specify the Anchor Component value for the component.
The Anchor Component defines what the selected component should be “anchored to” — or positioned
relative to—in the label.
For example, if you are setting up a Direction Arrow component for a direction label, you might want
to specify the Bearing as the Anchor Component so that you can position the arrow in relation to the
bearing label text.
4 Change the Anchor Point value to specify the location of the anchor point.
This value specifies precisely where on the Anchor Component you want to place the anchor.
5 Under Text, change the Attachment value to specify the location on the label component that will be
attached to the anchor point.
6 Optionally, specify X and Y offsets and a Rotation Angle. For example, you may want to specify X or
Y offsets from the anchor point to add some space between the components. For more information,
see Offset (page 1676) and Rotation (page 1677).
TIP Refer to the Label Preview window when editing the label layout properties. This preview dynamically
shows the effect of each of these settings.
7 Click OK.

Quick Reference
Toolspace Shortcut Menu
Settings tab: <drawing name> ➤ <object collection> ➤ Label Styles ➤ <label style type name> ➤
right-click <label style name> ➤ Edit
Dialog Box
Label Style Composer (page 2180)

Specifying Anchor Points
You can attach labels to specified geometry point locations.
Line and curve label anchors allow you to create much more graphic type label styles. For example, you can
display crow’s feet to indicate where segments start and end.
NOTE Anchor points do not support the spanning option for parcel segment labels.
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These anchors apply to the following segment labels: parcel lines and curve Label, general line and curve
labels, alignment line, and curve and spiral labels.
There are four line label anchor points that you can use to attach labels to: start, end, middle points and
label location. The label location anchor can be dragged anywhere along the line.

Line label anchor points

For spiral labels, in addition to the label location, start, end, and middle points anchors, there is a Point of
Intersection anchor.

Spiral label anchor points

With curve label anchors, you can attach a label to the center point of the arc.

Curve label anchor points
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To specify label anchor point
1 In the Label Style Composer dialog box, click the Layout tab.
2 Select an anchor point from the Anchor Point list.
3 Click Apply and then OK.

Quick Reference
Toolspace Shortcut Menu
Settings tab: <drawing name> ➤ <object collection> ➤ Label Styles ➤ <label style type name> ➤
right-click <label style name> ➤ Edit
Dialog Box
Label Style Composer (page 2180)

Background Mask
Use a background mask for Text and Referenced Text components to mask the background of a label
component.

without mask
1234
with mask
1234

The size and shape of the mask is configured using the border settings. For example, if you specify a rectangular
border with a gap of 0.1, the mask respects those settings, even if the border visibility is set to False.
You can use the AutoCAD Properties palette to include a background mask for surface contour labels
To include a background mask
1 In the Label Style Composer dialog box, click the Layout (page 2183) tab.
2 Select a Text or Referenced Text component from the Component Name list.
3 Under Border, change the Background Mask property to True.
4 Configure the other Borders (page 1680) settings to adjust the mask and border size and shape.
5 Adjust the label component Draw Order (page 1701) as needed.
Any label component that is drawn before the mask may be covered if it is within the mask boundary.
To set the background mask setting for surface contour labels in AutoCAD Properties
1 In the drawing, right-click a surface contour label and select Properties.
2 In the AutoCAD Properties palette, under Labels change the Masking property to From Label Style. This
sets the contour label to the label background mask setting from the assigned label style.
OR
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3 Under Labels, change the Masking property to Contour Line Only.

Quick Reference
Toolspace Shortcut Menu
Settings tab: <drawing name> ➤ <object collection> ➤ Label Styles ➤ <label style type name> ➤
right-click <label style name> ➤ Edit
Dialog Box
Label Style Composer (page 2180)

Offset
Specify X and Y offsets to define the distance between the anchor point of the anchor component and the
attachment point of the label component.

X and Y offsets in a text component

Offsets are dependent on the Orientation Reference of the label style:
■

Label Orientation Reference set to Object. X and Y offset values are relative to the X and Y coordinate
system as defined by the anchor component direction. In the preceding illustration, the anchor component
direction is zero (0) degrees, so X, and Y offsets are measured relative to zero (X direction = 0° and Y
direction = 90°). If the anchor component direction changed to 45°, then the X direction is measured at
45°, and the Y direction is measured at 135°.

■

Label Orientation Reference set to World. X and Y offset values are relative to the world coordinate system
(X direction = 0° and Y direction = 90°).

■

Label Orientation Reference set to View. X and Y offset values are relative to the current view (X direction
= bottom of screen and Y direction = 90° from bottom of screen).
For more information about these settings, see General Tab (Label Style Composer Dialog Box) (page 2181).

To define offset values
1 In the Label Style Composer dialog box, click the Layout (page 2183) tab.
2 Select a component from the Component Name list.
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3 Change the X and Y offset values. If the label component type is a line, you must define X, Y start and
endpoints.
4 Click OK.

Quick Reference
Toolspace Shortcut Menu
Settings tab: <drawing name> ➤ <object collection> ➤ Label Styles ➤ <label style type name> ➤
right-click <label style name> ➤ Edit
Dialog Box
Label Style Composer (page 2180)

Rotation
Specify a rotation angle for a label component.
Rotation angles are dependent on the Orientation Reference of the label style:
■

Label Orientation Reference set to Object. The rotation angle is measured relative to the X and Y coordinate
system as defined by the anchor component direction. For example, if the anchor component direction
is 45°, then the rotation angle is measured relative to 45°.

■

Label Orientation Reference set to World. The rotation angle is measured relative to the world coordinate
system (X direction = 0° and Y direction = 90°).

■

Label Orientation Reference set to View. The rotation angle is measured relative to the current view (X
direction = bottom of screen and Y direction = 90° from bottom of screen).

To change the rotation of a label component
1 In the Label Style Composer dialog box, click the Layout (page 2183) tab.
2 Select a component from the Component Name list.
3 Change the Rotation Angle value.
4 Click OK.

Quick Reference
Toolspace Shortcut Menu
Settings tab: <drawing name> ➤ <object collection> ➤ Label Styles ➤ <label style type name> ➤
right-click <label style name> ➤ Edit
Dialog Box
Label Style Composer (page 2180)

Colors
Assign colors to individual components in a label.
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Use the Select Color dialog box to assign a standard AutoCAD color or use one of the following options:
■

ByLayer. Labels obtain their color from the label style’s layer (defined on the General tab of the Label
Style Composer).

■

ByBlock. Labels obtain their color from the parent object’s AutoCAD properties. The object is first examined
for any property overrides. If none are found, then the color property of the object layer is used.

To specify colors for label components
1 In the Label Style Composer dialog box, click the Layout (page 2183) tab.
2 Select a component from the Component Name list.
3 Click the Value column for Color, and then click

.

4 In the Select Color dialog box, select a color or select ByLayer or ByBlock.
5 Click OK.

Quick Reference
Toolspace Shortcut Menu
Settings tab: <drawing name> ➤ <object collection> ➤ Label Styles ➤ <label style type name> ➤
Right-click <label style name> ➤ Edit
Dialog Box
Label Style Composer (page 2180)

Linetypes
Assign linetypes to individual components in a label.
Use the Select Linetype dialog box to assign a specific linetype or use one of the following options:
■

ByLayer. Labels obtain their linetype from the label style’s layer (defined on the General tab of the Label
Style Composer).

■

ByBlock. Labels obtain their linetype from the parent object’s AutoCAD properties. The object is first
examined for any property overrides. If none are found, then the linetype property of the object layer
is used.

To specify linetypes for label components
1 In the Label Style Composer dialog box, click the Layout (page 2183) tab.
2 Select a component from the Component Name list.
NOTE Text components do not have a Linetype option.
3 Click the Value column for Linetype, and then click

.

4 In the Select Linetype dialog box, select a linetype or select ByLayer or ByBlock.
5 Click OK.
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Quick Reference
Toolspace Shortcut Menu
Settings tab: <drawing name> ➤ <object collection> ➤ Label Styles ➤ <label style type name> ➤
right-click <label style name> ➤ Edit
Dialog Box
Label Style Composer (page 2180)

Lineweights
Assign lineweights to individual components in a label.
Use the Select Lineweight dialog box to select a specific lineweight or use one of the following options:
■

ByLayer. Labels obtain their lineweight from the label style’s layer (defined on the General tab of the
Label Style Composer).

■

ByBlock. Labels obtain their lineweight from the parent object’s AutoCAD properties. The object is first
examined for any property overrides. If none are found, then the lineweight property of the object layer
is used.

To specify lineweights for a label component
1 In the Label Style Composer dialog box, click the Layout (page 2183) tab.
2 Select a component from the Component Name list.
3 Click the Value column for Lineweight, and then click

.

4 In the Select Lineweight dialog box, select a lineweight, or select ByLayer or ByBlock.
5 Click OK.

Quick Reference
Toolspace Shortcut Menu
Settings tab: <drawing name> ➤ <object collection> ➤ Label Styles ➤ <label style type name> ➤
right-click <label style name> ➤ Edit
Dialog Box
Label Style Composer (page 2180)

Text Height
Specify text height for label text components.
To define text height for label components
1 In the Label Style Composer dialog box, click the Layout (page 2183) tab.
2 Select a component from the Component Name list.
3 Under Text, change the Text Height value.
4 Click OK.
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Quick Reference
Toolspace Shortcut Menu
Settings tab: <drawing name> ➤ <object collection> ➤ Label Styles ➤ <label style type name> ➤
right-click <label style name> ➤ Edit
Dialog Box
Label Style Composer (page 2180)

Curved Text
For label styles designed to label curves, you can specify that the label text is drawn to follow the curve.
To define curved text
1 In the Label Style Composer dialog box, click the Layout (page 2183) tab.
2 Select a text component from the Component Name list.
3 Under Text, change the Allow Curved Text value to True.
4 Click OK.

Quick Reference
Toolspace Shortcut Menu
Settings tab: <drawing name> ➤ <object collection> ➤ Label Styles ➤ <label style type name> ➤
right-click <label style name> ➤ Edit
Dialog Box
Label Style Composer (page 2180)

Borders
You can add rectangular, circular, or rounded rectangular borders to individual label components.

1234

To add borders to label components
1 In the Label Style Composer dialog box, click the Layout (page 2183) tab.
2 Select a component from the Component Name list.
3 Under Border, change the values for Visibility, Type, Gap, Color, Linetype, Lineweight, and Background
Mask.
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TIP You can specify a Gap value and set the Visibility value to False to add space around the label component
without actually inserting a border.
4 Click OK.

Quick Reference
Toolspace Shortcut Menu
Settings tab: <drawing name> ➤ <object collection> ➤ Label Styles ➤ <label style type name> ➤
right-click <label style name> ➤ Edit
Dialog Box
Label Style Composer (page 2180)

Managing Dragged Properties for Label Styles
Use the Dragged State tab of the Label Style Composer dialog box to define leader visibility and properties
for dragged label text.
You can display dragged label text as you composed it originally, or as stacked text, as shown in the following
illustrations:

Label “As Composed”
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Stacked label

Managing Leader Properties for Label Styles
Leaders can be displayed when you drag a label away from its default location.

Default label location
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Dragged label with leader

A leader line remains attached to the original insertion point of the label and stretches to the label’s new
location. A leader can be drawn with an arrowhead and can be a straight line or a spline curve.

Straight leader

Spline leader

Text in a dragged label is stacked according to settings that you specify in the Dragged State (page 2196) tab
of the Label Style Composer.
To manage leader properties
1 In the Label Style Composer dialog box, click the Dragged State (page 2196) tab.
2 Under Leader, change the Visibility value to True to display leaders when you move a label away from
its original placement.
3 Specify the leader arrow head style and size.
4 Specify the leader type, either Straight Leader or Spline Leader.
5 Specify color, linetype, and lineweight properties.
To display/hide the leader
■

Right-click a label and click Toggle Leader.

To display/hide the leader tail
■

Right-click a label and click Toggle Leader Tail.
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Settings tab: <drawing name> ➤ <object collection> ➤ Label Styles ➤ <label style type name> ➤
right-click <label style name> ➤ Edit
Dialog Box
Label Style Composer (page 2180)

Managing Leader Vertices
Leader vertices can be added, moved, or removed.
Use the leader vertex grips to add, move, and reset leader vertices. You can add as many leader segments as
desired.

To add a leader vertex
1 Click on a dragged label and select the

grip.

2 Move the grip to the new location. A vertex is created. Note that new
leader lines. Use these grips to create additional vertices.
NOTE Click the
undragged state.

grip once to reset the leader. Click the

grips display on the resulting

grip twice to reset a dragged label to its

NOTE If the leader type in label style dragged state is set to spline, an AutoCAD spline fit is made passing
through the vertex points.

To move a leader vertex
1 Click on a dragged label that has at least two leader lines.
2 Select the

grip and select a new vertex location.

To remove a leader vertex
1 Click on a dragged label that has at least two leader lines.
2 Select the

grip and the adjacent vertex is reset.
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To reset leaders
1 Click on a dragged label that has at least two leader lines.
2 Select the
NOTE Click the

grip and the leader line is reset to its original state.
grip a second time to reset the dragged label to its undragged state.

Managing How Label Text Appears when Dragged
Dragged label text can be displayed as composed, which means that it is displayed the same way when
dragged as when it is originally inserted, or it can be stacked. When stacked, all blocks, lines, and direction
arrows are removed.
You can add borders around stacked label text, and specify how the text is justified. Label text is left-justified
when the leader is on the left side of the text and is right-justified when the leader is on the right, as shown
in the following illustration.

However, you can set the label text to be always left-justified regardless of the location of the leader, as
shown in the following illustration.

You can also define the leader attachment position, which defines where the leader appears in relation to
the label content.
NOTE If you set the display of a dragged label component to As Composed, then all the Dragged State Components
properties are unavailable for editing. To control leader placement for “as composed” labels, edit the text
attachment, anchor point, and offset settings on the Layout tab.
To control how label text appears when dragged
1 In the Label Style Composer dialog box, click the Dragged State (page 2196) tab.
2 Under Dragged State Components, change the Display value to either As Composed or Stacked Text.
NOTE When you use the As Composed setting, you may need to adjust the text attachment point on the
Layout tab to prevent the leader from crossing the text. For more information, see Anchor Points and
Attachment Points (page 1671).
3 If you select Stacked Text, specify the border and leader values, including the Leader Justification value:
■

True. Text is right-justified when the leader is on the left side of the text and is left-justified when
the leader is on the right.

■

False. Text is always left-justified regardless of the location of the leader.
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Adding Content to Labels
You can use the Layout tab of the Label Style Composer to define label components, which define the content
of labels. Label components include text, referenced text, blocks, direction arrows, lines, and ticks.

Text
Use the Text Component Editor to format and define label text components.
■

To define dynamic text, select and add label property fields.

■

To define static text, enter text directly into the Text Component Editor window.

All text components are based on the AutoCAD text style that is defined on the General tab (page 2181) of
the Label Style Composer.

Adding Text Components to Labels
By adding text components to labels, you can create new label styles that label specific features, such as
parcel area, name, and perimeter.
Text components make use of dynamic label properties that you can assign in the Text Component Editor.
Each object type has several properties you can use to build the label style components.
For example, when setting up parcel line segment labels, you can choose among the following label properties:
■

Segment length

■

Segment start and end northings and eastings

■

Segment direction

■

Parcel line number

When you label a parcel using the label style, the labels are generated based on the parcel object’s properties.
If the parcel properties change, then the labels are updated dynamically.
There are two basic strategies you can use when adding text components to a label. If you want more precise
control over the label’s appearance, you can either add several properties to one text component or define
a separate component for each piece of text in the label.

Adding Multiple Properties to a Text Component
You can add multiple properties to one text component.
The advantages of this strategy include
■

Fewer text components to define
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■

Fewer placement rules to define

■

The ability to place one border around the entire label

Adding a Single Property to a Text Component
Alternately, you can add a single property per text component, and define multiple text components.
The advantages of this strategy include
■

More precise control over the placement of each piece of text

■

More property formatting options

■

The ability to turn off the visibility of one or more of the text components while leaving others visible

To add a text component to a label
1 In the Label Style Composer dialog box, click the Layout tab.
2 Click the Down arrow in

, and then click

.

The component automatically receives a default name, Text.1.
3 Enter a name in the Name box.
TIP Use a descriptive name that describes the content of the text component.
4 Under Text, click the Value column for Contents and then click

:

5 In the Text Component Editor, on the Properties (page 2200) tab, select a property from the Properties
list. This list contains a set of properties applicable to each label style type.
When you select a property, Modifiers and their Values are displayed in the grid below it. These modifiers
control such things as the units and precision of the labels.
6 Change the modifier values in the Value column as needed.
7 Click

. This inserts a property field into the Text Component Editor window.

For example, if you are setting up a parcel area label, and you insert the Parcel Area property, the
following property field is inserted:
<[Parcel Area(Usq_m|P2|RN|AP|Sn|OF)]>
WARNING You cannot edit the label property fields after you have inserted them into the Text Component
Editor window. If you alter anything about the field itself, such as using the shortcut menu to change
capitalization, the label style will not function correctly.
For more information about property fields, see Property Fields (page 1691).
WARNING To later change any of the modifier values you specified, delete the property field from the Text
Component Editor window and then reinsert the property by clicking
and clicking OK does not update the label style.

. Simply changing a modifier value

8 Add static text as needed in the Text Component Editor window.
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For example, you might want to add “Area =” before the parcel area property field, and “square meters”
after the property field.
To do this, click in the Text Component Editor window and enter the text directly. You can also insert
a paragraph return after a property field and then insert additional properties to create a multi-line
label.
You can use the formatting options on the Text Component Editor window shortcut menu to modify
the text that you manually enter.
9 If you want to add additional properties to the text component, select them from the Properties list
and insert them, as shown in Step 7.
10 If you want to specify different justification, fonts, or colors for the label component, click the Format
(page 2201) tab in the Text Component Editor. For more information, see Formatting Text (page 1688).
11 Click OK to close the Text Component Editor.

Quick Reference
Toolspace Shortcut Menu
Settings tab: <drawing name> ➤ <object collection> ➤ Label Styles ➤ <label style type name> ➤
right-click <label style name> ➤ Edit
Dialog Box
Label Style Composer (page 2180)
Text Component Editor (page 2199)

Formatting Text
Use the formatting options on the Format tab in the Text Component Editor to determine how text is
displayed in a label.
Some options require you to select text in the Text Component Editor window first.
To format label text
1 In the Label Style Composer dialog box, click the Layout tab.
2 Select a component from the Component Name list.
3 Under Text, click the Value column for Contents, and then click

.

4 In the Text Component Editor dialog box, click the Format tab (page 2201).
5 Format the text as desired.
6 Click OK.

Quick Reference
Toolspace Shortcut Menu
Settings tab: <drawing name> ➤ <object collection> ➤ Label Styles ➤ <label style type name> ➤
right-click <label style name> ➤ Edit
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Dialog Box
Label Style Composer (page 2180)
Text Component Editor (page 2199)

Creating Stacked Characters
Add fractions or any other type of stacked text to label styles in the Text Component Editor.
To create stacked characters in label styles
1 In the Label Style Composer dialog box, click the Layout tab.
2 Select a component from the Component Name list.
3 Under Text, click the Value column for Contents, and then click

.

4 In the Text Component Editor dialog box, click the Format tab (page 2201).
5 In the Text Component Editor window, enter the text you want to stack separated by one of the following
characters:
■

Slash (/) stacks text vertically, separated by a horizontal line.

■

Pound sign (#) stacks text diagonally, separated by a diagonal line.

■

Carat (^) creates a tolerance stack, which is not separated by a line.

For example, if you want to create a fraction of 1 over 2, enter 1/2.
6 In the Text Component Editor window, select the text that you want to stack, and then click
the Format tab.

on

NOTE If you enter numbers separated by stack characters and then either enter a nonnumeric character or
press Spacebar or Enter, the Multiline Text - AutoStack Properties dialog box is displayed. In the Multiline
Text - AutoStack Properties dialog box, you can select to automatically stack numbers (not nonnumeric text)
and to remove leading blanks. You can also specify whether the slash character creates a diagonal fraction
or creates a vertical fraction. If you do not want to use AutoStack, click Cancel to exit the dialog box.

7 To unstack text, select it and click

again.

8 To edit stacked text properties, select the stacked text, right-click, and click Properties to display the
AutoCAD Stack Properties dialog box.
You can edit the upper and lower text separately. The Appearance options control the stack style,
position, and text size of the stacked text.
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Toolspace Shortcut Menu
Settings tab: <drawing name> ➤ <object collection> ➤ Label Styles ➤ <label style type name> ➤
right-click <label style name> ➤ Edit
Dialog Box
Label Style Composer (page 2180)
Text Component Editor (page 2199)
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Adding Special Characters
Use the Symbol option to add symbols to label text.
To add symbols or special characters
1 In the Label Style Composer dialog box, click the Layout tab.
2 Select a component from the Component Name list.
3 Under Text, click the Value column for Contents, and then click

.

4 In the Text Component Editor dialog box, click the Format tab (page 2201).
5 Click in the Text Component Editor window in the location where you want to add the symbol or
special character.
6 Click Symbol.
7 From the list, select a symbol, such as degree, diameter, or plus/minus, or a non-breaking space.
The symbol is added to the label text at the cursor location.
8 To select a special character, click Other to display the Character Map dialog box.
9 Select a character, click Select, and then click Copy.
10 In the Text Editor window, place the pointer in the location where you want to add the special character.
11 Paste the copied character by either right-clicking and clicking Paste or pressing Ctrl+V.

Quick Reference
Toolspace Shortcut Menu
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Text Component Editor (page 2199)

Editing Text in the Text Component Editor
Use a shortcut menu in the Text Component Editor window to edit the format of text content you have
manually entered.
WARNING You cannot edit the label property fields. If you alter anything about the field itself, such as using the
shortcut menu to change capitalization, the label style will not function correctly.
Right-click in the Text Component Editor window to display the shortcut menu.
The lower part of the shortcut menu contains specific formatting options. If you have selected stacked text,
then options that are specific to stacked text are added to the menu.
■

Select All. Selects all text in the editor window.

■

Change Case
■

UPPERCASE. Changes all selected text to uppercase characters.
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■

lowercase. Changes all selected text to lowercase characters.

■

Remove Formatting. Removes any formatting, such as underline, bold, and italic.

■

Combine Paragraphs. Removes all line returns.

■

Stack. Stacks selected text. Available only when text separated by stack characters is selected. For more
information, see Creating Stacked Characters (page 1689).

■

Unstack. Unstacks text. Available only when stacked text is selected.

■

Properties. Displays the AutoCAD Stack Properties dialog box. Available only when stacked text is selected.

Property Fields
Use property fields to control the label content. You add property fields to label text components to act as
placeholders for the label or tag content.

Adding Property Fields to Label Text Components
Insert property fields in text components to add content that is linked directly to drawing components.
Label text generated by most property fields is dynamic and is updated whenever changes are made to a
drawing.
NOTE You cannot edit the property fields in the edit pane of the Text Component Editor window. You can only
add or delete a property field or add static text.
As you view the property field in the edit pane of the Text Component Editor, the characters are defined
and separated by the following symbols:
Character

Description

<[

Begin property field

(

Begin modifier list

|

Modifier separator

)

End modifier list

]>

End property field

For example, the property field format may look like this:
<[Attribute(Unit|Precision|Rounding|Sign|Capitalization|Format|Direction|Output)]>

Property fields attributes are formatted with predefined modifiers, such as measurement units (acres, feet,
and meters), precision, and rounding.
For more information about the modifiers for feature property fields in AutoCAD Civil 3D, see Property Field
Modifiers (page 1692).
To add property fields to label text
1 In the Label Style Composer dialog box, click the Layout tab.
2 Select a component from the Component Name list, or create a new text component.
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3 Under Text, click the Value column for Contents, and then click

.

4 In the Text Component Editor dialog box, click the Properties tab (page 2200).
5 From the Properties list, select a property.
NOTE If you have defined user-defined property classifications, these are displayed in the Properties list for
you to select and add to certain label styles. For more information, see Using Custom Properties with Points
(page 445).
The modifier values are displayed in the grid below the property.
NOTE Because certain label style types have many possible properties, an additional filtering feature is
provided for these types so you can restrict the list. Click
to display the Property Filter (page 2201) Property
Filter dialog box. A filter remains active until you turn it off.
6 In the Value column, change the modifier values.
7 Click

to insert the property into the text window.

8 Click OK.

Quick Reference
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Settings tab: <drawing name> ➤ <object collection> ➤ Label Styles ➤ <label style type name> ➤
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Text Component Editor (page 2199)

Property Field Modifiers
Most label styles associated with AutoCAD Civil 3D objects contain property fields with modifiers. These
modifiers are abbreviations for the values you specified for the label property.
The following is a key to the modifier codes:
U=

Units

S=

Sign

F=

Format

D=

Direction

P=

Precision

C=

Capitalization

R=

Rounding

O=

Output

A=

Decimal character

For example, the following is a parcel area property field:
<[Parcel Area(Usq_m|P2|RN|AP|Sn|OF)]>
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The following lists each of the modifiers for this label property:
■

Usq_m: Units = square meters

■

P2: Precision = 2

■

RN: Rounding = Normal

■

AP: Decimal Character = Period

■

Sn: Sign Negative = ‘-’

■

OF: Output = Full

Referenced Text
Use Referenced Text components in label styles to include references to other objects in a label. You can
insert references to surfaces, profiles, parcels, and alignments.
Referenced Text components are supported for most object label types. See Label Objects (page 1643) for a list
of label objects supported by Referenced Text.
NOTE Referenced Text is supported for most label object types in AutoCAD Civil 3D. Label types for points, parcel
face, parcel segment, corridor labels, and surface watershed do not support reference text.
Each Referenced Text component can refer to only one AutoCAD Civil 3D object. For example, you can
format a Referenced Text component to include an alignment name and its description, but it cannot refer
to two different alignment names. To include references to two different alignments you need to include
two Referenced Text components in the label style, one for each different alignment.
NOTE You can format a Referenced Text component to include an expression. Note that if you have referenced
an expression with a property that is not supported through the referenced text property field this results in
questions marks (???) inserted into the label.
To create a Referenced Text component
1 In the Label Style Composer dialog box, click the Layout tab.

2 Click the Down arrow in

, and then click

Reference Text.

3 In the Select Type (page 2187) dialog box, select the type of object data to include in the Referenced Text
component. Click OK.
You are returned to the Label Style Composer dialog box. The type of object data you selected is listed
as the Reference Text Object Type in the General section.
4 Under Text, click the Value column for Contents, and then click

.

5 In the Text Component Editor dialog box, ensure the Properties tab (page 2200) is selected.
6 From the Properties list, select a property. The list of properties available reflects the object you selected
in step 2 previously.
7 In the Value column, change the modifier values as needed.
8 Click

to insert the property into the text window.

9 Add other properties or descriptive text as needed. Click OK to return to the Label Style Composer
dialog box.
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10 Set up the other Layout settings the Referenced Text component using the same settings that are available
for text components (page 1686).
NOTE If the Visibility setting is set to True for the Referenced Text component in the label style, and you do
not select an object for the reference when you insert the label, question marks (???) are inserted into the
label. This is because the reference text component is not yet connected to an object. You can specify an
object by editing the label properties and the question marks will be replaced with the object data.

See also:
■

Inserting Note Labels (page 1709)
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Text-For-Each
Use the Text Component Editor to format and define text-for-each components for a variety of object types.
Text-for-each components label each object associated with a parent object (the object you are labeling). For
example, you can use a text-for-each component in a structure label style to include labels for pipes associated
with that structure. These components are only used in structure label styles and structure tables.
Text-for-each components are formatted just like text components, except that you select which child objects
to label when you first create a text-for-each component. For example, you can add labels for all the pipes
that enter or exit a structure, or only for invert-in or invert-out pipes. These label components are dynamic,
so that if you remove or add a child object, the labels are updated.
The following shows an example of a structure label where the first three lines of the label contain structure
data. The last three lines of the label contain data about the pipes that connect to the structure:
MH - 54 TYPE “B”
STA. 20+11.35, 6.00’ RT
TOP ELEV. = 62.91
INV. IN = 47.08 (N)
INV. IN = 54.42 (SE)
INV. OUT = 47.08 (W)
You would set up this label style by including two text-for-each components. One component is for all pipes
in, which lists invert in values. The other component is for all pipes out, which lists the one invert out value.
To create a text-for-each component
1 In the Label Style Composer dialog box, click the Layout tab.
NOTE The text-for-each component type is available only for structure label styles.

1694 | Chapter 35 Labels and Tags

2 Click the Down arrow in

, and then click

.

3 In the Select Type (page 2187) dialog box, select the type of data to include in the text-for-each component
and click OK.
4 Set up the other Layout settings the text-for-each component using the same settings that are available
for text components (page 1686).
For example, if you are setting up a label for invert in pipes, you could use the Text Component Editor
to add static text (INV. IN =), and also add a dynamic property field that labels the pipe elevation.
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Lines
Add line components to a label style using one of two methods.
■

Start Point, Length, and Angle: Use this method to anchor the start point of the line component to the
anchor component. Then, specify the length and angle. The following illustration shows a line defined
using this method:

■

Start Point and End Point: Use this method to anchor the start and end point of the line component.
The length and angle of the line are determined by the position of the anchor objects, and adjust if the
anchor components are edited. The following illustration shows a line defined using this method:
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To add lines
1 In the Label Style Composer dialog box, click the Layout (page 2183) tab.
2 Click the Down arrow in

, and then click

.

The component automatically receives a default name, Line.1.
3 Enter a new name in the Name box.
4 Specify the desired settings in the General and Line categories.
To define a line, either specify a start and end point anchor or define a start point anchor, a length,
and a direction.
For more information, see Managing Layout Properties for Label Styles (page 1671).
5 Click OK.
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Blocks
Add block components, such as a custom arrowhead or symbol, to a label style.
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Block component properties

To add blocks
1 In the Label Style Composer dialog box, click the Layout (page 2183) tab.
2 Click the Down arrow in

, and then click

.

The component automatically receives a default name, Block.1.
3 Enter a new name in the Name box.
4 Under Block, click the Value column for Block Name, and then click

.

5 In the Select A Block dialog box, select the block to use, and then click OK.
NOTE The AutoCAD Civil 3D drawing templates contain several blocks you can use.
6 Specify the desired settings in the General and Block categories.
For more information, see Managing Layout Properties for Label Styles (page 1671).
7 Click OK.
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Ticks
You can add tick components, which are short lines inserted at a perpendicular angle to another object, to
a label style. For example, ticks can be used to mark the location of a station label on an alignment.
Ticks cannot be edited with grips or moved from the object on which they are inserted. They are always
anchored to the object.
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Tick component properties

The following illustrations show the effect of the Align With Object setting for ticks:
■

True. Inserts the tick at an angle relative to the object, as shown in the following illustration:

■

False. Inserts the tick at an angle relative to the UCS setting, as shown in the following illustration:

To add ticks
1 In the Label Style Composer dialog box, click the Layout (page 2183) tab.
2 Click the Down arrow in

, and then click

.

The component automatically receives a default name, Tick.1.
NOTE This option is not available in label style types that do not support ticks.
3 Enter a new name in the Name box.
4 Under Tick, click the Value column for Block Name, and then click

.

5 In the Select A Block dialog box, select the block to use, and then click OK.
NOTE The AutoCAD Civil 3D drawing templates contain several blocks you can use.
6 Specify the desired settings in the General and Tick categories.
For more information, see Managing Layout Properties for Label Styles (page 1671).
7 Click OK.
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Direction Arrows
Add an arrow to a label style to indicate direction.

Direction arrow properties

The standard AutoCAD arrowheads are used in AutoCAD Civil 3D:
architectural tick

datum triangle filled

oblique

box

dot

open

box filled

dot blank

open 30

closed blank

dot small

origin indicator

closed filled

dot small blank

origin indicator 2

datum triangle

integral

right angle

To add direction arrows
1 In the Label Style Composer dialog box, click the Layout (page 2183) tab.
2 Click the Down arrow in

, and then click

.

The component automatically receives a default name, Arrow.1.
NOTE This option is not available in label style types that do not support direction arrows.
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3 Enter a new name in the Name box.
4 Under Direction Arrow, select an Arrow Head Style.
5 Specify the desired settings in the General and Direction Arrow categories.
NOTE The direction arrow length must be at least twice that of the specified arrow head size. If not, the
arrow head is not displayed. For example, if you specify an arrow head size of 0.2, the arrow length must be
at least 0.4. This behavior is similar to AutoCAD leaders.
Arrow head is not displayed when
arrow length is decreased

6 Click OK.
For more information, see Managing Layout Properties for Label Styles (page 1671).
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Copying Label Components
To quickly create a new label component, you can copy and edit an existing component.
To copy a label component
1 In the Label Style Composer dialog box, click the Layout (page 2183) tab.
2 Select the component you want to copy from the Component Name list.
3 Click

Copy Component.

A copy is created and named “Copy of” the component you selected.
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Changing Label Component Draw Order
You can change the label component draw order to control which label components are drawn on top of
other components.
This is useful if you want to use a mask in a label style to cover drawing entities and then have another
component appear on top of the mask.
To change label component draw order
1 In the Label Style Composer dialog box, click the Layout (page 2183) tab.
2 Click

Draw Order.

3 In the Component Draw Order (page 2196) dialog box, select a label component in the list and click the
Up or Down arrows to move it up or down in the display order. The item at the top of the list is drawn
last, so it will appear on top of all other objects.

Quick Reference
Toolspace Shortcut Menu
Settings tab: <drawing name> ➤ <object collection> ➤ Label Styles ➤ <label style type name> ➤
right-click <label style name> ➤ Edit
Dialog Box
Component Draw Order (page 2196)

Inserting and Managing Labels in Drawings
You can add labels to drawing objects, change label properties, flip and pin labels, and renumber label tags.

Adding Labels to Drawings
You usually add labels to drawings when you create objects such as points, alignments, or parcels. You can
also add labels after you create the objects.
■

You specify the label styles to use when creating objects, and these labels are created automatically. For
more information, see the Help about creating individual features.

■

You can also insert labels using the Add Labels (page 2208) dialog box, and by using other feature-specific
commands, such as the surface contour label command.

■

You can also insert labels using the Annotate tab. This tab provides an efficient work environment for
when you are ready to label objects that you have created. This tab provides quick access to all AutoCAD
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Civil 3D feature-specific commands. Before using this tab, set your default label settings for best results
as you are able to quickly label objects in rapid succession.
The labels that are created when you create objects can be deleted. Specifically, you can erase a whole group
of labels and restore them by resetting the label group. You can also hide a single label and restore its visibility
by resetting the label group. You can also explode labels and delete the labels that you manually insert.
To manually add labels to drawings
1 Click Annotate tab ➤ Labels & Tables panel ➤ Add Labels Drop-down ➤ Add <feature-specific label>.
2 In the Add Labels (page 2208) dialog box, select the desired label type and style.
3 Click Add and select the label location in the drawing.

Quick Reference
Ribbon
Click Annotate tab ➤ Labels & Tables panel ➤ Add Labels menu ➤ <Feature ➤ Add <Feature> Labels
Menu
<Feature> menu ➤ Add <Feature> Labels
Dialog Box
Add Labels (page 2208)
To add feature specific labels to drawings
➤

Click Annotate tab ➤ Labels & Tables panel ➤ Add Labels drop-down ➤ Add <feature-specific label>.

OR
1 Click <feature> tab ➤ Labels & Tables panel ➤ <command>.
2 Select the object to add the label to.

Labeling Lines and Arcs
You can label lines, arcs, 2D polylines, feature lines, parcels, and alignments with AutoCAD Civil 3D label
styles. The general line label styles are available for lines, arc, 2D polylines, feature lines, lot lines, and
alignments. You can also convert these general line labels to tags.
When creating or editing line labels, you can select both parcel label/alignment label styles as well as general
line and curve label styles. The commands to add single and multiple label types support each of the three
object types (line/curve, parcel, and alignment).
To label lines, arcs, polylines, feature lines, parcel, and alignments with general line label styles
1 Click Annotate tab ➤ Labels & Tables panel ➤ Add Labels menu ➤ Line and Curve ➤ Add Line and
Curve Labels

.

2 In the Add Labels (page 2208) dialog box, under Feature, select Line and Curve.
3 Under Label Type, select Single Segment or Multiple Segment. Multiple Segment labels all segments on
a selected polyline or feature line.
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4 Select the Line and Curve label styles to use. For more information, see Creating Label Styles for Lines,
Curves, and Polylines (page 1659).
Note that you can select parcel, alignment, and general line and curve label styles to annotate lines.
5 If the label styles use Referenced Text (page 2781), specify the Reference Text Object Prompt Method to
use.
6 Click Add. Then select the object to label.

Quick Reference
Ribbon
Annotate tab ➤ Labels & Tables panel ➤ Add Labels menu ➤ Line and Curve ➤ Add Line and Curve Labels

Menu
General menu ➤ Add Labels
Command Line
AddSegmentLabel
AddSegmentLabels (for multiple segments)
Dialog Box
Add Labels (page 2208)

Labeling the Overall Length of Parcels
AutoCAD Civil 3D contains label properties that you can use to label the overall length on the outside of
contiguous parcels.
To label the overall length of parcel segments
1 Create a new parcel line label style or open an existing style to edit.
NOTE You can also set up parcel curve label styles to span multiple segments.
2 On the Layout tab of the Label Style Composer, select or create the label component that you want to
span multiple segments.
3 In the Properties list, under General, change the Span Outside Segments property to True.
Specify this setting for each component that you want to span multiple segments.
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NOTE The Span Outside Segments option works only on outside segments. If you have this option specified
for a component, but it is positioned so that it appears inside a parcel, it will label the individual segment,
not the spanned segment.
Even if a label is set to Span Outside
Segments, it must be positioned outside the
parcel to label the span

span label positioned outside
20.00
10.00

span label positioned inside

4 Make sure that the components are all set up to display on the outside of the parcel line.
■

On the Layout tab, adjust the Anchor Component, Attachment position, and Y Offset values as
needed.
For example, if the Anchor Component is Feature, set the Attachment to Bottom Center adjust the
Y Offset to a positive number so the label will appear above the feature.

■

On the General tab, set the Orientation Reference setting to Object and the Forced Insertion setting
to None.
The None setting forces the label component to the outside of most segments. However, on some
segments, you may need to use the Flip Label command to flip the label to the outside.

15.00

5.00

15.00

flip this label to get it
to span

15.00

5 To insert the labels, use the Parcels ➤ Add Labels command, select Single Segment as the label type,
and select the label style that you set up to span.
The span label is inserted at the location you click, and the values contain the overall data for the
contiguous parcels.
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The parcel segment to label with the span must be one unbroken entity. For example, in the tutorial drawing
Parcel-3.dwg, you can see that the top of the parcel group is one segment, so a span label can be successfully
applied.

However, the left side of the parcel group is broken up into three segments, as shown below. The span label
will not label all three. If you want to label the overall distance of that side, you would need to redraw the
left side as one parcel entity.

Setting Up Profile and Section View Labels
Because profile views and section views can contain more than one profile or section, certain profile and
section labels require that you specify which profile or section data to use for the labels.
Specify which profile or section data to use by modifying the label properties after you add the label to the
drawing. The label styles that use this feature are
■

Profile view Station Elevation labels

■

Section view Station Offset labels

The following workflow describes how to set up the profile view labels, and the same concepts can be applied
to setting up the section view labels.
To create profile view labels that contain data for multiple profiles
1 Create a profile view that contains multiple profiles.
NOTE The Profile-3.dwg file in the \AutoCAD Civil 3D 2011\Help\Civil Tutorials\drawings folder contains a
profile view you can use for experimenting.
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2 Create a new profile view Station Elevation label style, or open an existing profile view Station Elevation
label style for editing. For more information, see Creating and Editing Label Styles (page 1656).
3 With the style open in the Label Style Composer dialog box, click the Layout tab.
4 Verify that the Station Elevation Data component is selected in the Component Name list.
5 Under Text, click the Value column for Contents, and then click
Editor.

to display the Text Component

6 Expand the Properties list. Note the following properties you can specify:
■

Profile 1 Name

■

Profile 1 Elevation

■

Profile 1 Elevation Difference

■

Profile 2 Name

■

Profile 2 Elevation

■

Profile 2 Elevation Difference

■

Profile 1 Elevation minus Profile 2 Elevation

■

Profile 2 Elevation minus Profile 1 Elevation

Because there may be multiple profiles in a profile view, you can assign any of those profiles to be
“Profile 1” or “Profile 2.” After you add these property fields to the label style and label the profile view,
you can edit the label properties to specify which profiles you want to use.
7 In the Text Component Editor window, place your cursor at the end of the existing property fields and
press Enter to create a new row.
8 In the Properties list, select a Profile 1 or Profile 2 property to add, and then click
to insert the
property field. For more information, see Adding Text Components to Labels (page 1686).
For example, you could insert the “Profile 1 Name” property, enter a colon, and then insert the “Profile
1 Elevation” property, enter a paragraph return, and then insert similar properties for Profile 2.
9 Click OK to save your changes and close the dialog boxes.
10 Click Annotate tab ➤ Labels & Tables panel ➤ Add Labels menu ➤ Profile View ➤ Add Profile View
Labels

.

11 In the Label Type list, select Station Elevation.
12 In the Station Elevation Label Style list, select the new style you created or the style you edited.
13 Click Add, and then select the profile view to label.
14 Specify the station and the elevation, and then press Enter to end the command.
The label is inserted with question marks (???) as placeholders for the profile 1 and profile 2 data.
15 Select the label, right-click, and click Label Properties.
16 In the Label Properties dialog box, click the Profile 1 Object column, and then click

.

17 In the Profile 1 Object dialog box, select the profile that you want to use as Profile 1, and then click
OK.
18 Repeat Steps 14 and 15 for the Profile 2 Object.
19 Click OK to close the Label Properties dialog box.
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The label is updated with the profile data.
NOTE If the label does not update immediately, enter Regen at the command line.
20 Use the label staggering options to avoid label collisions and to improve readability. For more
information, see Staggering Profile and Section Labels (page 1707).

Staggering Profile and Section Labels
Staggers profile and section labels for improved visibility.
Use the label height staggering options to avoid collisions in densely populated graph views in order to
improve legibility. The staggering options are available through the AutoCAD Properties palette or the
Properties dialog boxes.
Specify the height of the stagger lines so that label components have adequate spacing.

Profile with
staggered labels to
avoid collisions

To stagger profile labels
1 Right-click a profile object and select Edit Labels.
2 In the Label Set Dialog Box (page 2206) dialog box, specify the Stagger Labels settings as required.
3 Specify the height of the stagger lines.
NOTE Layer, linetype and other AutoCAD properties of the stagger lines are determined by the leader settings
in the Dragged State tab of the corresponding label style.

OR
1 Right-click a profile label and select Properties
2 In the AutoCAD Properties palette under Staggering, specify the stagger label settings as required.

Staggering Data Band Labels
Staggers data band labels for improved visibility.
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Data band labels are objects that can be manipulated like other AutoCAD Civil 3D label objects. Use the
label height staggering options to avoid label collisions in densely populated data bands. The staggering
options are available through the Profile View Properties or the AutoCAD Properties palette.
NOTE Data band labels can also be grip edited like other label objects.

You set the stagger label line height

The staggering options are available for the following label types
■

Grade breaks (profile labels)

■

Major/minor stations (profile labels)

■

Horizontal geometry points (profile labels)

■

Major/minor offsets (section labels)

■

Grade breaks (section labels)

The following workflow describes how to stagger profile view labels, and the same concepts can be applied
to setting up the section view labels.
To stagger data band labels
1 Right-click a data band label and select Profile View Properties.
2 In the Profile View Properties dialog box, click the Bands (page 2430) tab. Specify the Stagger Labels setting
as required.
3 Specify the height of the stagger lines.
OR
1 Right-click a data band label and select Properties.
2 In the AutoCAD Properties palette under Staggering, specify the stagger label settings as required.

Editing Data Band Labels
You can edit data band label objects with the Label Style Composer.
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Use the Label Style Composer to specify a label style for an band, to create a new style, or to copy or edit an
existing label style.When you edit a label style, all band labels in the drawing that reference that style are
updated.
To edit data band label styles
1 Right-click a data band label and select Edit Band Style.
2 In the Profile Data Band Style dialog box, click the Band Details (page 2414) tab. Select the Compose Label
button.
3 Use the Label Style Composer Dialog Box (page 2180) to edit the data band label style.
4 Click OK.

Inserting Note Labels
You can insert Note labels that are not anchored to a specific object.
Note labels can contain text strings as well as Referenced Text (page 2781), which refers to other objects in the
drawing.
It is important to remember that although the Referenced Text components in a Note label will update if a
referenced object changes, a Note label itself is not attached to a specific object. Therefore, it does not move
if you move a referenced object or an object that you have snapped it to. You must manually move a Note
label to reposition it.
You can edit (or override) Note labels in a drawing to change the text for unique information. That way you
do not have to have a separate label style for each note you want to insert. For more information, see
Overriding Label Text (page 1714).
To insert note labels
1 Specify the layer for Note labels on the Layer tab (page 82) of the Drawing Settings dialog box.
2 Click Annotate tab ➤ Labels & Tables panel ➤ Add Labels menu ➤ Notes

.

3 In the Add Labels (page 2208) dialog box, under Feature, select Note.
4 Select the Note label style to use. For more information, see Creating Note Labels (page 1660).
5 Optionally, select a Marker Style to use. Using a Marker Style places a symbol at the Note label insertion
point. If you do not select a Marker Style now, you can specify one later by editing the Label Properties.
NOTE You can set up new Marker Styles from the Toolspace Settings tab. Expand the General collection ➤
Multipurpose Styles ➤ Marker Styles.
6 If the label style uses Referenced Text (page 2781), specify the Reference Text Object Prompt Method to
use.
7 Click Add.
8 Select the location in the drawing where you want to insert the note.
9 If the label uses Referenced Text, select the object(s) to reference by doing one of the following:
■

If you specified Command Line as the prompt method: Refer to the command line prompts to select
the objects.

■

If you specified Dialog as the prompt method: The Label Properties (page 2204) dialog box is displayed.
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Click the Value column next to the Referenced Text item (where <none> is listed). Then click
and select the object from the Property Field Object dialog box.
NOTE If the Visibility setting is set to True for the Referenced Text component in the label style, and you do
not select an object for the reference when you insert the label, question marks (???) are inserted into the
label. You can specify an object by editing the label properties.
NOTE See Referenced Text (page 1693) for a list of other label types that support Referenced Text.

Quick Reference
Ribbon
Annotate tab ➤ Labels & Tables panel ➤ Add Labels menu ➤ Notes
Menu
General menu ➤ Add Labels
Command Line
AddNoteLabel
Dialog Box
Add Labels (page 2208)

Labeling External References (Xrefs)
You can label xref objects as you would native objects.
The process to label xref objects is the same as if you were labeling an object in the current drawing. If the
xref object is modified in the source drawing, then the corresponding label updates dynamically.
Labels you add to an xref exist in the current drawing. If you detach the xref, labels created in the current
drawing will be lost. Xref data is read-only in the current drawing and can only be edited in the source
drawing.
For Xref labels to be created
1 The xref must be inserted into the current drawing at 0, 0, 0.
2 The xref must be scaled at 1,1,1.
3 The xref must not be rotated.
Objects in an xref cannot be individually context selected. Xref commands, such as detach, bind, and unload,
can alter the association between a label and the object within an xref. For more information, see Xref Label
Behavior (page 1711).
If a drawing containing AutoCAD Civil 3D objects and labels is inserted as an xref into another drawing,
the labels will not be altered. It is recommended that if you insert xrefs that include labels, you should set
the labels on layers that can be frozen.
NOTE Xrefs can only be used to create parcel and alignment tables. Other xref objects are not currently supported
by tables.
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To add Xref labels
1 Click Insert tab ➤ Reference panel ➤ Attach

.

2 In the Select Reference File dialog box, select the DWG to insert into the current drawing.
3 In the External Reference dialog box, set the Insertion Point values (X, Y, and Z) to 0.00.
4 Set the Scale values (X, Y, and Z) to 1.00.
5 Set the Rotation angle to 0. Press OK.
The xref object displays in the current drawing. Now you can label the xref data.
6 Click Annotate tab ➤ Labels & Tables panel ➤ Add Labels menu ➤ Notes

.

7 Select the label style to use.
NOTE Labels for View Frames and Matchlines are NOT supported through xrefs.
8 Click OK and pick the label locations.

Quick Reference
Ribbon
Annotate tab ➤ Labels & Tables panel ➤ Add Labels menu ➤ Notes
Menu
General menu ➤ Add Labels
Command Line
AddLabels
Dialog Box
Add Labels (page 2208)

Xref Label Behavior
Existing Xref labels are affected by edits to the xref object.
When an xref is modified, the xref label can be affected and/or removed.
The following describes the behavior of existing xref labels if the xref is modified through xref or AutoCAD
commands.
Command

Result

Xref Unload

While unloaded, the labels temporarily
disappear, but still exist. When the xref is
reloaded, the labels reappear.

Broken (Xref not found)

This occurs when an xRef file is renamed,
deleted or path to it changed. While not
found, the labels temporarily disappear,
but still exist. When the xref is reloaded,
the labels reappear.
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Command

Result

Xref Detach (or erase)

The labels are erased and cannot be restored.

Xref Reload

The labels updated accordingly to the xref.
If the xref has been modified, the label
updates. If the xref has been removed, the
label is erased.

Bind Xref

The label is erased.

Explode Xref

The label is erased.

AutoCAD command that alters the size or
position of the xref. Such as move, rotate,
or stretch.

Labels are converted to a single line of text
"???", at the new insertion point. When the
xref is altered back to meet the insertion
requirements listed previously, the labels
regenerate and appear as designed. When
an xref is moved, the label displays xref
moved.

You cannot select a pick-sensitive context (right-click) menu for an object within an xref. Some labeling
commands are available in <object> feature menus so they can be used with xref objects. Commands for
editing alignment station labels (page 1045), profile labels (page 1128), sample line (page 1241), and section labels
(page 1242) are now available in their respective label menus on the Annotate tab.

Identifying and Selecting Xrefs
Xrefs are easy to identify when selecting reference text objects for label styles or objects for inclusion in
tables.
The name of the xref object uses this convention: <XRef DWG Name>|<Object name in XRef>. Note that
the XRef DWG Name does not include the file extension or path. This is the same convention that AutoCAD
uses for xref layer names.

Modifying Labels in a Drawing
You can modify label object properties by right-clicking a label and selecting Label Properties or Properties
to open the AutoCAD Properties palette. Use Ctrl+click to select individual labels within a group for editing.
You can also grip edit label components, flip, pin, and reset labels.

Changing Group Label Object Properties
Turn off the visibility of a group of labels, change the label style, and specify other properties depending on
the type of label selected.
To change group label properties
1 Select a label in a drawing (the entire group is selected), right-click, and select Label Properties or
Properties.
2 In the Properties palette, change the desired properties.
3 Click OK.
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Quick Reference
Ribbon
Select the label. Click Labels tab ➤ Modify panel ➤ Edit Label Group
Object Shortcut Menu
Right-click label ➤ Label Properties or Properties

Changing Single Label (single label within a group) Properties
To turn off the visibility of the label, change the label style, and specify other properties depending on the
type of label selected, you can select sub-entities (single labels) within a group label using Ctrl+click.
To change sub-entities (single labels) within a group label
1 Press Ctrl+click to select labels in a drawing.
2 Right-click and select Label Properties or Properties.
3 In the Properties palette, change the desired properties.
4 Click OK.
OR
1 In the drawing, select the label to edit.
2 Right-click and select Edit Label Style.
3 In the Label Style Control (page 2203) box, specify a label style, create a new style, or copy or edit an
existing style. Press

to access the Label Style Composer.

Quick Reference
Object Shortcut Menu
Press Ctrl and right-click label ➤ Label Properties or Properties

Changing Non-Object Type Label Properties
Properties for points labels, all corridor labels, and surface watershed labels are modified with the Label
Properties dialog box. Turn off the visibility of the label, change the label style, and specify other properties
depending on the type of label selected.
To change label properties
1 Select a label in a drawing, right-click, and click Label Properties or Properties.
2 In the Label Properties (page 2204) dialog box, change the desired properties.
3 Click OK.
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Quick Reference
Use these commands to modify label properties.
Ribbon
Select the label. Click Labels tab ➤ Modify panel ➤ Label Properties drop-down ➤ Label Properties

Quick Reference
Object Shortcut Menu
Right-click label ➤ Label Properties or Properties

Overriding Label Text
Use the Edit Label Text command to override content of individual labels.
For certain label object types, you can override the content of individual labels. This override is useful if you
want to add additional text specific to a certain label.
If you have edited the label text, this allows you to clear those edits. The label will only display what is in
the style.
Overrides are supported for the following label types:
■

Line

■

Curve

■

Note

■

Profile View Station Elevation

■

Surface Spot Elevation

■

Section View Offset Elevation

■

Segment

■

Surface Slope

■

Surface Contour - Major, Minor, User

■

Alignment Major Stations

■

Alignment Minor Stations

■

Alignment Geometry Point

■

Alignment Station Equation

■

Alignment Design Speed

■

Alignment - Profile Geometry Point

■

Alignment Station Offset - Fixed Point

■

Alignment Station Offset

■

Alignment Line

■

Alignment Curve
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■

Alignment Spiral

■

Alignment Tangent Intersect

■

Profile Major Stations

■

Profile Minor Station

■

Profile Horizontal Geometry

■

Profile Grade Breaks

■

Profile Line

■

Profile Sag Curves

■

Profile Crest Curves

■

Profile View Depth

■

Profile View - Station Elevation

■

Sample Line

■

Section Major Offset

■

Section Minor Offset

■

Section Grade Break

■

Section Segment

■

Section View Grade

■

Network Pipe in plan

■

Network Pipe in profile

■

Network Pipe in section

■

Network Structure in plan

■

Network Structure in profile

■

Network Structure in section

■

Network Pipe - Spanning pipe

■

Plan Production - View Frame

After you have overridden a label component, any changes you make to the text content in the label style
are not applied until you clear the label text overrides. Changes you make to the non-text content in the
label style (such as border, visibility, or color) are still applied to the overridden label.
To override label text
1 Select the label in the drawing. Right-click and click Edit Label Text.
2 The Text Component Editor (page 2199) is displayed.
3 Edit the label component as needed. Click OK.
To clear label overrides
1 Right-click the label and click Clear Label Text Override.
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If multiple text components have been overridden for the label, you are prompted to select the text
component to clear.
2 Do one of the following:
To clear all label overrides
1 Select the label(s) that contain the overrides.
2 Right-click and click Clear All Label Text Overrides.

Quick Reference
Use these commands to edit label text.
Ribbon
Select the label. Click Labels tab ➤ Modify panel ➤ Clear Label Text
Command Line
EditLabelText

Quick Reference
Object Shortcut Menu
Right-click label ➤ Edit Label Text
Command Line
EditLabelText

Moving Labels in a Drawing
Use grips to move labels. Each label in a drawing contains a single, primary grip that can be used to drag a
label from its position.
The Dragged State settings within the label style control how labels appear when dragged. If the Stacked
Text option is selected, text components in dragged labels are stacked vertically based on the order in which
the text components were created in the label style. Dragged labels can display a leader pointing from the
text to the label’s original location. For more information about stacked text, see Managing How Label Text
Appears when Dragged (page 1685).
To move a label in a drawing
1 Click the label to be moved and select the square grip.
2 Move the label to the new location.
NOTE
To return the label to its original position, if the leader is not modified from its original state, click the
reset grip or right-click the label and click Reset Label. For group labels, click the
the label and click Reset All Group Labels.

reset grip or right-click

If the leader has been divided into multiple segments, a single click will restore the leader to its original state.
Click the

reset grip twice to reset the label to its original location.
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Editing Point Label Components with Grips
Move each component of a point label independently by using component grips.
The following illustration shows the round and diamond-shaped component grips on a point label:

To edit point label text with grips
1 Click the point label to display the round and square grips.
2 Click the round grip to display the diamond-shaped grips.
3 Click a diamond-shaped grip and move the label component to the new location.

Editing Line, Arc, and Polyline Labels with Grips
Use the square grip on line, arc, and polyline labels to drag the label off the entity. Use the diamond grip
to slide the label along the entity.
If you slide a label along a polyline from one type of segment to another (such as a line to a curve), the label
style changes.
To move line, arc, and polyline labels away from the entity
1 Click the label to be moved and select the

grip.

2 Move the label to the new location. A leader is created and the label is displayed using the Dragged
State settings defined in the label style. A

grip is also displayed on the label.

NOTE If no additional leader line vertices have been added, click the
undragged state. If there are multiple leader lines, click the
state. Click the

grip store a dragged label to its

grip once to restore the leader to its original

grip twice to restore a dragged label to its undragged state.

To move line, arc, and polyline labels along the entity
1 Click the label to be moved and select the diamond grip.
2 Slide the label along the entity.
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Editing Unanchored Labels with Grips
Single point type labels such as note and station offset labels are not anchored to any specific object. You
can move them freely about the drawing.
To move a Note label
1 Click the label to be moved and select the diamond grip.
2 Move the label to the new location.
To drag a Note label away from its insertion point and create a leader
1 Click the label to be moved and select the

grip.

2 Move the label to the new location. A leader is created and the label is displayed using the Dragged
State settings defined in the label style. A

grip is also displayed on the label.

NOTE If no additional leader line vertices have been added, click the
its undragged state. If there are multiple leader lines, click the
state. Click the

grip to restore a dragged label to

grip once to restore the leader to its original

grip twice to restore a dragged label to its undragged state.

Editing Data Band Labels with Grips
Edit data band label objects with grips.
Use the

grip on data band labels to drag the label off of the entity.

To move a band label
1 Click the label to be moved and select the

grip.

2 Move the label to the new location. A leader is created and the label is displayed using the Dragged
State settings defined in the label style.
3 Manage the label leader as you would for other label objects. For more information, see Managing
Leader Vertices (page 1684).
4 NOTE If no additional leader line vertices have been added, click the
its undragged state. If there are multiple leader lines, click the
state. Click the

grip to restore a dragged label to

grip once to restore the leader to its original

grip twice to restore a dragged label to its undragged state.
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Resetting Group Label Location
Returns dragged group labels to their original position.
Use the Reset All Group Labels command to return dragged group labels to their original position.
To reset group label location
1 Select one of the labels in the group.
2 Right-click the label, and click Reset All Group Labels.
NOTE To reset a single sub-entity of a group label, the available command is Reset Label.
NOTE You can also click the
grip to restore a dragged label to its default state. Click once to reset the
leader to its original state if vertices have been added. Click twice to reset the label to its undragged state.

Quick Reference
Ribbon
Select the label. Click Labels tab ➤ Modify panel ➤ Reset Label Group
Object Shortcut Menu
Right-click label ➤ Reset All Group Labels

Resetting Single Label Location
Resets single labels to their original position.
Use this command to return dragged single labels to their original position. You can also reset a single,
dragged sub-entity of a group label.

To reset single label location
1 Select the label you want to reset.
2 Right-click the label, and click Reset Label.
NOTE You can also click the
grip to restore a dragged label to its default state. Click once to reset the
leader to its original state if vertices have been added. Click twice to reset the label to its undragged state.
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Quick Reference
Ribbon
Select the label. Click Labels tab ➤ Modify panel ➤ Reset Label
Object Shortcut Menu
Right-click label ➤ Reset Label

Resetting Label Properties
Resets group labels.
Use this command to reset dragged group labels group back to their original position, as well as remove any
style overrides.

NOTE You can also reset dragged labels per viewport.
To reset label group properties
1 Select one of the labels in the group.
2 Right-click the label, and click Reset All Group Labels.

Quick Reference
Ribbon
Select the label. Click Labels tab ➤ Modify panel ➤ Reset Label Group
Object Shortcut Menu
Right-click label ➤ Reset All Group Labels

Exploding Labels
Use the Explode command to convert labels to AutoCAD MText, line, and block entities without affecting
the parent object.
If the label has a leader, then it is converted to an AutoCAD leader entity.
To explode labels
1 Click Home tab ➤ Modify panel ➤ Explode
2 Select the label to explode and press Enter.
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.

Quick Reference
Ribbon
Click Home tab ➤ Modify panel ➤ Explode
Menu
Modify ➤ Explode
Command Line
Explode

Flipping Labels
Flip a label in its location to reverse the placement order of the label components. You can flip labels for
lines, curves, and spirals.
For example, flipping a bearing over distance label moves the bearing and distance to the other sides of the
line or arc.

To flip labels
■

Right-click a label, and click Flip Label.
NOTE To return the label to its original position, right-click the label and select Reset Label.

Quick Reference
Ribbon
Select the label. Click Labels tab ➤ Modify panel ➤ Flip Label
Object Shortcut Menu
Right-click label ➤ Flip Label
Command Line
LabelFlip
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Pinning Labels
Pins labels to their current location.
After you have dragged a label to another location, you can force (pin) labels to remain in the current
location, regardless of edits that are made to the parent object.
To pin labels
■

Right-click a label, and click Toggle Label Pin.

Quick Reference
Ribbon
Select the label. Click Labels tab ➤ Modify panel ➤ Toggle Label Pin
Object Shortcut Menu
Right-click a label ➤ Toggle Label Pin
Command Line
LabelTogglePin

Reversing Label Direction
Reverses label direction.
Reverse a bearing direction component in labels that support bearing direction.

To reverse a label direction
■

Right-click a label, and click Reverse Label.

Quick Reference
Ribbon
Select the label. Click Labels tab ➤ Modify panel ➤ Reverse Label
Object Shortcut Menu
Right-click label ➤ Reverse Label
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Command Line
LabelReverseBearing

Creating Label Tags
Control label tags with the Table Tag Numbering dialog box. You can set the default starting number and
increment options for table tags.
General line and curve labels can be used alone or with parcel segment labels to create a table.
To control table tag starting numbers and increments
■

In the Toolspace Settings tab, right-click the drawing name, and click Table Tag Numbering.

■

In the Table Tag Numbering (page 2209) dialog box, specify the default tag starting number and the
increment number. No duplicate tags are created unless you manually create them with the Renumbering
label tags tool. If there is a duplicate with the starting number, the number increments up by the specified
amount. If there is still a duplicate, it increments up, until an unused tag number is found and applied.
The starting number is then set to the next number according to the increment (even if it is a duplicate).

Quick Reference
Object Shortcut Menu
Right-click drawing name ➤ Table Tag Numbering

Renumbering Label Tags
Label tags are numbered sequentially according to the order in which they are created, but you can renumber
them to remove gaps in a sequence, or to change the starting number or increment value.
By default, newly created tags are unique. Duplicate tags are only created manually. Specify tag starting and
increment numbers in the Table Tag Numbering Dialog Box (page 2209). You can create a duplicate by opening
an existing drawing that contains duplicates across sites/alignment collections or with the renumber
command. You can create or avoid duplicate tags as desired.
Table tags support the following tag mode labels: general line, general curve, parcel line, parcel curve,
alignment line, alignment curve, and alignment spiral.
To renumber tags
1 Click <Object Name> tab ➤ Labels & Tables panel ➤ Renumber Tags

.

2 Do one of the following:
■

In the drawing, select a tag to renumber. The starting number is determined by the Table Tag
Renumbering settings. If there is a duplicate in the drawing, you are prompted to skip to the next
available number or to create a duplicate. By default, duplicates are not created unless you allow it.
You can select multiple tags to renumber. Select the tags in the sequential order that you want them
numbered. If you selected a label that is not a valid type or is not in tag mode, you are prompted
to try again.

■

At the command line, enter S. In the Table Tag Numbering (page 2209) dialog box, set the starting
number and increment for the label types, either line, curve or spiral. Then press OK.

3 Enter end to end the command.
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Quick Reference
Ribbon
Click <Object name> tab ➤ Labels & Tables panel ➤ Renumber Tags.
Menu
<Object name> ➤ Add Tables ➤ Renumber Tags
Dialog Box
Renumbering (page 2742)

Deleting Labels From Drawings
You can delete some labels from drawings.
Labels that you can delete include all label types that you can add manually, after an object is created. You
can also delete group labels. Labels that you cannot delete include some of the label types that are added to
an object automatically when it is created, such as parcel area labels.
NOTE You can also explode labels, and then erase the exploded entities. For more information, see Exploding
Labels (page 1720).
If you delete an object, all labels that are associated with it are also deleted.
To delete labels from drawings
■

To delete manually-added labels, right-click a label and click Erase.
NOTE Some labels cannot be deleted, but can be hidden. For more information, see Hiding and Displaying
Labels in the Drawing (page 1665).

Quick Reference
Object Shortcut Menu
Right-click label ➤ Basic Modify Tools ➤ Erase

Deleting Band Labels
You can delete band labels from drawings.
Band label objects can be deleted individually or as part of a group.
To delete band labels as a group
■

Right-click a band group label and click Erase.

To delete individual band labels
■

Ctrl-click a band label and click Erase.
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Quick Reference
Object Shortcut Menu
Right-click label ➤ Basic Modify Tools ➤ Erase

Restoring Band Labels
You can restore band labels that have been deleted from drawings.
When the complete set of band group labels are deleted, the band displays without labels. You can use the
Bands tab in the Profile View Properties dialog box to restore deleted band group labels.
The following workflows describe how to restore deleted profile view band labels, and the same concepts
can be applied to restoring section view band labels.
To restore deleted band group labels
1 Right-click the profile view and select Profile View Properties.
2 In the Profile View Properties dialog box, click the Bands tab.
3 Select the Show Labels check box. Click OK.
To restore deleted individual band labels
■

Right-click a band label and click Reset All Group Labels
All previously deleted labels display on the bands.

Deleting a Label Style
You can delete a label style if it is not being used in a drawing.
To delete a label style
1 In Toolspace, on the Settings tab, right-click the label style you want to delete.
2 Click Delete.
NOTE You cannot delete a label style that is referenced by an object or by another label style.
3 Click Yes to confirm the deletion.

Quick Reference
Toolspace Shortcut Menu
Settings tab: <drawing name> ➤ <object collection> ➤ Label Styles ➤ <label style type name> ➤
right-click <label style name> ➤ Delete

Creating a Label Set
Defines new label sets.
This allows you to modify the set of labels by adding or removing label types or parameters.
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To define a new label set
1 In Toolspace, on the Settings tab, expand a drawing’s Alignment, Profiles, or Section object collection,
and then expand Label Styles.
2 Right-click Label Sets, and click New.
3 In the <Feature Name> Label Set (page 2206) dialog box, click the Information tab.
4 Enter the label set name and description information.
5 Click the Labels tab.
6 Under Type, select a label style type from the list.
7 Under <label style name> Label Style, select a specific label style from the list.
8 Click Add to add the style to the label set.
The label style is displayed in a row in the window section.
9 Repeat Steps 7–8 for each label style that you want to add to the set.
10 Specify values for the label properties, such as the Increment value for station labels. For more
information, see Labels Tab (Label Set Dialog Box) (page 2207).
11 Click OK.

Quick Reference
Toolspace Shortcut Menu
Settings tab: <drawing name> ➤ <Alignment, Profile, or Section object collection> ➤ Label Styles ➤
right-click Label Sets ➤ New
Dialog Box
<Feature Name> Label Set (page 2206)

Expressions
Set up mathematical expressions to use in label styles.
Label styles are composed of property fields that display information about an object. Expressions allow you
to convert the object information using a formula, then insert the result into a label style component.
Expressions are stored in the Settings tree, within the label style type folders. They are not available for label
style types that do not have relevant properties, such as Note label styles.
You insert expressions into label styles using the Text Component Editor when you are editing a label style
text component.
You can use design data to determine how a label style is drawn using text, lines or block components. You
can insert expressions into label styles by selecting expressions in place of static values for text, line, and
block component modifiers. For example, in the Layout tab of the Label Style Composer dialog box, you
can insert an expression in place of a static value when determining the text height of a label. This expression
could increase the text height of a spot elevation label to coincide with the elevation height.
You can insert expressions in label styles to create custom graphics. For example, you can create a graphical
profile band, in which the graphics of the vertical grades are relative to the actual grades in order to visually
reinforce the data representation, or match graphical standards. A PVI can be represented by a symbol, where
the lines/values representing the grade in and grade out change quadrants based on the sign of the grades.
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Setting Up Expressions
Expressions make use of the same properties that you can add to label styles, such as Point Elevation,
Northing, and Easting. By using expressions, you can set up separate mathematical formulas using the
existing properties. For example, you could subtract a value from a point elevation, and display that number
along side the actual elevation in a point label.
After you set up expressions, they are available in the Properties list in the Text Component Editor so you
can add them to label styles. In effect, expressions become new properties that you can use to compose a
label style.
Expressions are unique to a particular label style type. Only those properties that are relevant to the label
style type are available to choose from in the Expressions dialog box.

Brackets and Parentheses
When you insert a property into an expression, it appears in curly brackets if it contains spaces. For example:
{Segment Length}

Do not insert anything else into the curly brackets, and do not remove them. If the property name does not
have any spaces (like Northing), then curly brackets are not required.
For expression grouping, use parentheses. For example:
0.567*({Segment Length} + 56)

Restrictions
Expressions are mathematical formulas that are used to compute a value. No text can be added directly to
them. Any text you want to include can be added to the label style. For example, to convert feet to meters,
you could set up the following expression:
{Segment Length} *.3084

If you want to add “meters” to the end of this string, you must add it later when you set up the label style.
To set up an expression
1 In Toolspace, on the Settings tab, expand a label style type collection.
For example, expand Parcel ➤ Label Styles ➤ Line.
2 Right-click Expressions and click New.
3 In the Expressions dialog box, enter a name and description for the expression.
NOTE It is recommended that you use a clear naming convention such as “Parcel line expression: Length in
meters” so you can distinguish them when composing a label style.
4 Click the Insert Property button and select a property from the list.
The property appears in the editor box.
5 Add functions, constants, and logical operators to complete the equation.
NOTE Do not insert anything into the curly brackets that surround the property fields.
■

Use the calculator buttons or click in the editor field and use your keypad to enter numbers and
mathematical operators like * (multiply) or \ (divide).

■

Use the Insert Function button to insert mathematical functions like TAN.
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NOTE For a complete list of operators and functions, see Expressions Dialog Box (page 2211).
6 Specify how the expression should be formatted by selecting a format from the Format Result As list.
7 Click OK.
See Inserting Expressions into Label Styles as Properties (page 1729)

Quick Reference
Toolspace Shortcut Menu
Settings tab: <drawing name> ➤ <object type collection> ➤ <label style type collection> ➤ right-click
Expressions ➤ New
Dialog Box
Expressions (page 2211)

Expression Examples
Following are some examples of expression syntax.

Converting Northings and Eastings to Polar Coordinates
You can create expressions for point labels to convert northings and eastings to polar radius and polar angle
values. These expressions compute the radius and angle from the coordinate system origin to the point.
Polar Radius Expression Syntax:
SQRT (Northing^2 + Easting ^2)
Format as Distance.
Polar Angle Expression Syntax:
ATAN2 (Northing, Easting)
Format as Angle.

Converting Astronomic Direction to Magnetic Direction
All internal angle calculations in AutoCAD Civil 3D are done in radians. You can take this into account
when you apply a formula to an angle, such as when you label a line with both a true direction and a
magnetic direction.
To subtract a 15d 30' 15" magnetic declination from an astronomic direction to derive the magnetic direction,
you can set up the following expression:
Known:
PI = 3.141592654
360 degrees = 2(pi) radians
1 radian = 57.29577951 degrees
Given:
15d 30' 15" = 15.50417 degrees
Expression Syntax:
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{Segment Direction} - (15.50417*((2*pi)/360))
Or alternatively using the built-in functions as follows:
{Segment Direction} - DEG2RAD(15.50417)
Format the result as Direction.

Tower Top Elevation
You can create expressions for surface spot elevation labels to calculate the sum of the height of a structure
such as an airport control tower with the ground elevation.
Tower Top Expression Syntax:
{Surface Elevation+ 228.5}
In this example, 228.5 is the height of the structure.

Editing Expressions
After you create an expression, it is listed in the Settings tree item view.
Click the Expressions collection to display the list of defined expressions in the Toolspace item view.
Right-click an expression to access commands.
To edit an expression
1 Select the Expressions collection that contains the expression you want to edit.
2 Ensure the Toolspace item view (page 99) is visible.
3 Right-click an expression in the item view and click Edit Expression.
4 Edit the expression using the Expressions (page 2211) dialog box.

Quick Reference
Toolspace Shortcut Menu
Settings tab: <drawing name> ➤ <object type collection> ➤ <label style type collection> ➤ Expressions
➤ right-click expression in item view ➤ Edit Expression
Dialog Box
Expressions (page 2211)

Inserting Expressions into Label Styles as Properties
Expressions are listed in the Properties list of the Text Component Editor. You can insert them into label
styles like any other property.
To insert an expression into a label style
1 Set up an expression (page 1727) for a label style type.
2 Open an existing label style in the Label Style Composer or create a new label style. The type of this
label style must match the type of the expression you created.
For example, if you created an expression for a parcel line, you can only add that expression to a parcel
line label style.
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3 In the Label Style Composer dialog box, click the Layout tab and select or create a text, line, tick, or
block component to which you want to add the expression. For more information, see Text (page 1686).
4 Under Text, click the Value column for Contents click

5 In the Text Component Editor, on the Properties (page 2200) tab, click the Down arrow on the Properties
list.
This list contains a set of properties and expressions applicable to each label style type.
6 Select the expression and click

. This inserts the expression into the Text Component Editor window.

7 Add any descriptive label text before or after the expression as needed. For example, add descriptive
information about the expression, such as units, that will distinguish it in the label.
WARNING Expressions have the same editing restrictions as property fields. If you alter anything about the
expression, such as using the shortcut menu to change capitalization, the expression will not function correctly.
8 Click OK to close the Text Component Editor and the Label Style Composer dialog boxes.

Quick Reference
Toolspace Shortcut Menu
Settings tab: <drawing name> ➤ <object collection> ➤ Label Styles ➤ <label style type name> ➤
right-click <label style name> ➤ Edit
Dialog Box
Label Style Composer (page 2180)
Text Component Editor (page 2199)

Inserting Expressions into Label Styles as Values
You can insert expressions as values to modify components in the Label Style Composer.
To insert an expression as a value into a label style
1 In Toolspace, on the Settings tab, expand a label style collection. For example, expand Parcel ➤ Label
Styles ➤ Line.
2 Right-click Line and click Edit.
3 In the Label Style Composer dialog box, click the Layout tab and click a component modifier to access
a drop-down list of compatible expressions. You can also type in a new value.
4 Click OK.
NOTE When inserting expressions as values for text, line, block or tick components, any non-number, or
"double" type property cannot be used and will not appear in the drop-down list. Height, length, or size
modifiers must be absolute numbers, so that the property is converted to an absolute value. For example, if
the entered value for text height is zero, the default height from drawing label style defaults will be used.
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The tables below list the Label Style Composer component modifiers that support expressions.
Text Components
Text Height
Rotation Angle
X Offset
Y Offset

Line Components
Length
Angle
Start Point X Offset
Start Point Y Offset
End Point X Offset
End Point Y Offset

Block Component
Block Height
Rotation Angle
X Offset
Y Offset

Tick Components
Block Height
Rotation Angle

Quick Reference
Toolspace Shortcut Menu
Settings tab: <drawing name> ➤ <object collection> ➤ Label Styles ➤ <label style type name> ➤
right-click <label style name> ➤ Edit
Dialog Box
Label Style Composer (page 2180)
Text Component Editor (page 2199)
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Functions and Operators
The following tables list formulas and operators that can be used in expressions.

Functions
NOTE Functions can be either upper case or lower case but not mixed case. The editor buttons will always insert
functions in upper case. Unless otherwise stated, theta is in radians.
ABS(x)

Returns the absolute value of x.

ACOS(x)

Returns the arccosine of x.

ASIN(x)

Returns the arcsine of x.

ATAN(x)

Returns the arctangent of x.

ATAN2(y,x)

Returns the arctangent of y/x in the correct
quadrant based on sines of x and y.

CEIL(x)

Ceiling function: returns the smallest integer that is not less than x. For example,
CEIL(1/3) is 1.

COS(theta)

Returns the cosine of theta.

COSH(theta)

Returns the hyperbolic cosine of theta.

COT(theta)

Returns the cotangent of theta.

COTH(theta)

Returns the hyperbolic cotangent of theta.

CSC(theta)

Returns the cosecant of theta.

CSCH(theta)

Returns the hyperbolic cosecant of theta.

DEG2GRD(theta)

Converts theta in degrees to gradians.

DEG2RAD(theta)

Converts theta in degrees to radians.

DRVSTN(x)

Returns the derived station from a raw
station x, using the station equations. This
function is meaningful only for entities that
support station equations (alignments,
vertical alignments, sample lines, graph
profiles, pipes and structures).

EXP(x)

Returns the exponential of x.

FLOOR(x)

Returns the largest integer that is less-than
or equal to x. For example, FLOOR(3/2) is
1.
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FMOD(x,y)

Returns the floating point remainder of
x/y.

GRD2DEG(theta)

Converts theta in gradians to degrees.

GRD2RAD(theta)

Converts theta in gradients to radians.

IF(test,true_val,false_val)

Evaluates test - if test is non-zero evaluates
and returns true_val else evaluates and returns false_val. True_val and false_val can
be any expression.
For example, where x is a Property:
IF(x=0,1,sin(x)/x)
The above tests x to see if it is zero, and if
it is, the expression returns 1. If x is nonzero, the expression returns sin(x)/x.

LOG(x)

Returns the log (base e) of x.

LOG10(x)

Returns the log (base 10) of x.

MAX(a,b)

Returns maximum value of a and b.

MIN(a,b)

Returns minimum value of a and b.

POW(x,y)

Returns x raised to the y power.

POW10(x)

Returns x raised to 10.

RAD2DEG(theta)

Converts theta in radians to degrees.

RAD2GRD(theta)

Converts theta in radians to gradians.

ROUND(x)

Rounds x to the nearest integer.

ROUNDDOWN(x)

Rounds x down to the nearest integer. For
example, ROUNDDOWN(1.9) is 1.

ROUNDUP(x)

Rounds x up to the nearest integer. For
example, ROUNDUP(2.1) is 3.

SIN(theta)

Returns the sin of theta.

SEC(theta)

Returns the secant of theta.

SECH(theta)

Returns the hyperbolic secant of theta.

SINH(theta)

Returns the hyperbolic sin of theta.

SQR(x)

Returns x squared (x*x).

SQRT(x)

Returns the square root of x.

TAN(theta)

Returns the tangent of theta.
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TANH(theta)

Returns the hyperbolic tangent of theta.

TRUNC(x)

Truncates x to an integer value.

Operators
NOTE Logical operators return 1.0 for true and 0.0 for false. Since they return values, you can perform logical
AND and OR with addition and multiplication. For example: ((a<b) + (b>c)) tests for a < b or b > c. ((a<b)*(b>c))
tests for a<b and b>c.
Symbol

Operator Definition

=

logical equals

!=

logical not equals

!

logical not

<

logical less-than

>

logical greater-than

<=

logical less-than or equals

>=

logical greater-than or equals

And

boolean "AND"

~

logical approximately equal

<~

logical less-than or approximately equal

>~

logical greater-than or approximately equal

Or

boolean "OR"

+

binary addition

-

binary subtraction

*

binary multiplication

/

binary division

-

unary minus

+

unary plus

^

power
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Labels Command Reference
The following table lists label commands and briefly describes their functionality. For more information
about a command, follow the link in the Description column.
Command

Description

AddLabels

Adds labels with the Add Labels dialog box (page 1701)

AddNoteLabel

Adds a note label (page 1709)

AddSegmentLabel

Adds line, arc, and polyline segment labels (page 1702)

FlipLabel

Flips label components (page 1721)

LabelDlgGeneralNote

Inserts a label that is not attached to an object (page
1709)

LabelReset

Returns a dragged label to its original position (page
1719)

LabelReverseBearing

Reverses label direction components (page 1722)

LabelStyleEdit

Edits object label styles (page 1661)

LabelTogglePin

Pins a dragged label to its current location (page 1722)
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Tables

You can insert tables into a drawing to document the geometry of selected objects.

Understanding Tables
Each row in a table contains information about a single object component, such as a line. Tables are supported
for points, parcels, alignments, surfaces, pipes, and structures.
■

The first column of data in a table is reserved for the tag number or identifier.
NOTE For point tables, the point number is used as the identifier. For parcel tables, the parcel ID is used as
the identifier for the area and tag numbers are used for lines and curves.

■

Additional columns display the object data.

Adding Object Tables
Add a table to a drawing by doing the following:
■

Set up a table style for the object. The table style specifies the type of data that is inserted into the table.

■

Label the objects whose data you want to add to a table.

Select table data by using the following methods:
■

By selecting individual labels

■

By specifying a label style

■

By selecting point groups (for point tables)

■

By selecting an alignment (for alignment segment tables)

When you insert a table into a drawing, most labels are required to be displayed in tag mode (the exceptions
to this rule are parcel area tables and point tables).
If the labels are currently set to label mode, they are automatically switched to tag mode when you insert
the table. Although it is not required, you may prefer to set the label styles to tag mode before inserting a
table to avoid the creation of unwanted styles. For more information, see Setting Up Label Styles To Be Used
as Tags (page 1663).
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After creating tags, you can renumber them to reset their sequential order. For more information, see
Renumbering Label Tags (page 1723).

Adding Surface Legend Tables
When you perform a surface analysis, the data is separated into ranges that are assigned different colors.
Legend tables display these colors and range values.
Add a surface legend table to a drawing, by doing the following:
■

Perform a surface analysis. For more information, see Analysis Tab (Surface Properties Dialog Box) (page
2659).

■

Modify the surface style so that it displays the analysis type. For more information, see Display Tab
(Surface Style Dialog Box) (page 2655).

■

Set up a surface legend table style to display the surface data. For more information, see Table Styles (page
1738).

Table Styles
Edits table content and style.
Table styles define which data is displayed in the table, and control the table appearance.

Defining a New Table Style
Right-click a table style type and click New to create a new table style.
To define a new table style
1 In Toolspace, on the Settings tab, right-click a table style type name, and click New.
2 In the Table Style dialog box, click the Information tab (page 2735).
3 Enter a name.
4 Click OK.

Quick Reference
Toolspace Shortcut Menu
Settings tab: <drawing name> ➤ <object collection> ➤ Table Styles ➤ Right-click <table style type name>
➤ New
Command Line
EditTableStyle
Dialog Box
Table Style (page 2735)

Defining Table Text Styles
Define text properties for a table style, such as text style and height.
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To define table text styles
1 In the Table Style dialog box, click the Data Properties (page 2735) tab.
2 Under Text Settings, select text styles from the Title Style, Header Style, and Data Style lists.
3 Under Text Settings, set text heights for the Title Style, Header Style, and Data Style text styles.
4 Click OK.

Quick Reference
Ribbon
Select the table. Click Table tab ➤ Modify panel ➤ Table Properties drop-down ➤ Edit Table Style
Toolspace Shortcut Menu
Settings tab: <drawing name> ➤ <object collection> ➤ Table Styles ➤ <table style type name> ➤
Right-click <table style name> ➤ Edit
Object Shortcut Menu
Right-click table ➤ Edit Table Style
Command Line
EditTableStyle
Dialog Box
Table Style (page 2735)

Defining Table Titles
The title is displayed in the first row of a table.
NOTE Except for Alignment tables, you cannot define property fields as a table title.
To define the table title
1 In the Table Style dialog box, click the Data Properties (page 2735) tab.
2 Under Structure, double-click the table title element in the top row of the table heading. The Text
Component Editor opens.
3 Enter the title.
4 Format the text using the editing options.
5 Click OK.

Quick Reference
Toolspace Shortcut Menu
Settings tab: <drawing name> ➤ <object collection> ➤ Table Styles ➤ <table style type name> ➤
Right-click <table style name> ➤ Edit
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Object Shortcut Menu
Right-click table ➤ Edit Table Style
Command Line
EditTableStyle
Dialog Box
Table Style (page 2735)

Defining Table Column Titles
Column titles are displayed in the second row of a table.
NOTE The first column must be the tag column.
To define column titles
1 In the Table Style dialog box, click the Data Properties (page 2735) tab.
2 Under Structure, double-click a column heading to open the Text Component Editor.
3 Enter the column title.
4 Format the text using the editing options.
5 Click OK.

Quick Reference
Toolspace Shortcut Menu
Settings tab: <drawing name> ➤ <object collection> ➤ Table Styles ➤ <table style type name> ➤
Right-click <table style name> ➤ Edit
Object Shortcut Menu
Right-click table ➤ Edit Table Style
Command Line
EditTableStyle
Dialog Box
Table Style (page 2735)

Linking Table Data
Properties control which data is inserted in table columns.
Available properties are specific to the table type. For example, point table properties include only those
properties that are relevant to points, such as point number.
Surface legend table styles contain a Surface Range Color property that displays the color swatch in the
specified column.
To link property fields to table rows
1 In the Table Style dialog box, click the Data Properties (page 2735) tab.
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2 Under Structure, double-click a Column Value cell to open the Text Component Editor.
3 Click the Properties tab.
4 In the Properties list, select a property, and enter the Modifier values.
5 Click

to insert the property into the window.

6 Click OK.

Quick Reference
Toolspace Shortcut Menu
Settings tab: <drawing name> ➤ <object collection> ➤ Table Styles ➤ <table style type name> ➤
Right-click <table style name> ➤ Edit
Object Shortcut Menu
Right-click table ➤ Edit Table Style
Command Line
EditTableStyle
Dialog Box
Table Style (page 2735)

Table Format
Manage table size and appearance.

Defining Column Size
Set columns to either a specific or an automatic width.
■

You can set the column width to Manual and specify the number of characters allowed in a string. Strings
over the specified amount are truncated unless word wrapping is selected.

■

You can set the column width to Automatic, which adjusts the width to accommodate the longest string
in the column.

To define column size
1 In the Table Style dialog box, click the Data Properties (page 2735) tab.
2 Under Structure, click a Column Width icon

to display the selections.

3 Click either Automatic or Manual.
4 If you select Manual, enter the number of characters.
5 Click OK.
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Quick Reference
Toolspace Shortcut Menu
Settings tab: <drawing name> ➤ <object collection> ➤ Table Styles ➤ <table style type name> ➤
Right-click <table style name> ➤ Edit
Object Shortcut Menu
Right-click table ➤ Edit Table Style
Command Line
EditTableStyle
Dialog Box
Table Style (page 2735)

Rearranging Columns
Rearrange and move columns in the table by dragging them.
To rearrange columns
1 In the Table Style dialog box, click the Data Properties (page 2735) tab.
2 Under Structure, click the column to be moved in its title cell and drag it to the new position.
NOTE You cannot move the first table column.

Quick Reference
Toolspace Shortcut Menu
Settings tab: <drawing name> ➤ <object collection> ➤ Table Styles ➤ <table style type name> ➤
Right-click <table style name> ➤ Edit
Object Shortcut Menu
Right-click table ➤ Edit Table Style
Command Line
EditTableStyle
Dialog Box
Table Style (page 2735)

Adding or Deleting Columns
Add or delete columns in a table.
To add columns
1 In the Table Style dialog box, click the Data Properties (page 2735) tab.
2 Under Structure, click
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to add a column.

3 Double-click the blank column heading to open the Text Component Editor window.
4 Enter a title, and then click OK.
5 Double-click the blank Column Value cell and select a property on the Properties tab of the Text
Component Editor. For more information, see Linking Table Data (page 1740).
To delete columns
1 In the Table Style dialog box, click the Data Properties (page 2735) tab.
2 Under Structure, click the column and then click

.

3 Click OK.

Quick Reference
Toolspace Shortcut Menu
Settings tab: <drawing name> ➤ <object collection> ➤ Table Styles ➤ <table style type name> ➤
Right-click <table style name> ➤ Edit
Object Shortcut Menu
Right-click table ➤ Edit Table Style
Command Line
EditTableStyle
Dialog Box
Table Style (page 2735)

Sorting Columns
Sort columns in ascending or descending order.
To sort a column
1 In the Table Style dialog box, click the Data Properties (page 2735) tab.
2 Select the Sort Data check box.
3 Select the column whose rows you want to sort and specify whether the sort should be in Ascending
or Descending order.
4 Click OK.

Quick Reference
Toolspace Shortcut Menu
Settings tab: <drawing name> ➤ <object collection> ➤ Table Styles ➤ <table style type name> ➤
Right-click <table style name> ➤ Edit
Object Shortcut Menu
Right-click table ➤ Edit Table Style
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Command Line
EditTableStyle
Dialog Box
Table Style (page 2735)

Splitting Tables
Split tables into smaller sets and customize the display of the headers.
To set up a split table
1 In the Table Style dialog box, click the Data Properties (page 2735) tab.
2 Under Table Settings, you can select the following options:
■

Repeat Title In Split Tables.

■

Repeat Column Headers In Split Tables.

3 Click OK.
NOTE When you create a table, or edit table properties, you can specify both whether the table should be
split and how many rows each section should contain. For more information, see Table Properties Dialog
Box (page 2741).

Quick Reference
Toolspace Shortcut Menu
Settings tab: <drawing name> ➤ <object collection> ➤ Table Styles ➤ <table style type name> ➤
Right-click <table style name> ➤ Edit
Object Shortcut Menu
Right-click table ➤ Edit Table Style
Command Line
EditTableStyle
Dialog Box
Table Style (page 2735)

Word Wrapping
If any columns are set to a Manual width, you can enable the Wrap Text option. This option wraps text that
exceeds the character limit instead of truncating it.
To enable word wrapping
1 In the Table Style dialog box, click the Data Properties (page 2735) tab.
2 Under Table Settings, select the Wrap Text check box.
3 Click OK.
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Quick Reference
Toolspace Shortcut Menu
Settings tab: <drawing name> ➤ <object collection> ➤ Table Styles ➤ <table style type name> ➤
Right-click <table style name> ➤ Edit
Object Shortcut Menu
Right-click table ➤ Edit Table Style
Command Line
EditTableStyle
Dialog Box
Table Style (page 2735)

View Orientation
Use the Maintain View Orientation option to ensure that tables appear plan-readable.
To maintain the view orientation
1 In the Table Style dialog box, click the Data Properties (page 2735) tab.
2 Under Table Settings, select the Maintain View Orientation check box.
3 Click OK.

Quick Reference
Toolspace Shortcut Menu
Settings tab: <drawing name> ➤ <object collection> ➤ Table Styles ➤ <table style type name> ➤
Right-click <table style name> ➤ Edit
Object Shortcut Menu
Right-click table ➤ Edit Table Style
Command Line
EditTableStyle
Dialog Box
Table Style (page 2735)

Table Display
Specify layer, color, and linetype options for a table style.
To define table display
1 In the Table Style dialog box, click the Display (page 2738) tab.
2 In the View Direction list, select either 2D or 3D.
3 Specify the display options for each component type.
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4 Click OK.

Quick Reference
Toolspace Shortcut Menu
Settings tab: <drawing name> ➤ <object collection> ➤ Table Styles ➤ <table style type name> ➤
Right-click <table style name> ➤ Edit
Object Shortcut Menu
Right-click table ➤ Edit Table Style
Command Line
EditTableStyle
Dialog Box
Table Style (page 2735)

Viewing a Summary of Table Settings
Review the settings for a table style.
To view a summary of table settings
■

In the Table Style dialog box, click the Summary (page 2739) tab.

Quick Reference
Toolspace Shortcut Menu
Settings tab: <drawing name> ➤ <object collection> ➤ Table Styles ➤ <table style type name> ➤
Right-click <table style name> ➤ Edit
Object Shortcut Menu
Right-click table ➤ Edit Table Style
Command Line
EditTableStyle
Dialog Box
Table Style (page 2735)

Using Table Styles from Other Drawings
Drag and drop table styles from other drawings to copy the styles.
Drag a style from one drawing to another in the Settings tree, or drag the style from the Settings tree into
the drawing window to copy the style into that drawing.
When you attempt to copy a table style to a location where a matching table style exists, you are prompted
with a warning, and have the following options:
■

No. Leaves the existing style and cancels the operation.
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■

Yes. Copies the style to the new drawing and renames the style using the format <source drawing
name>.<style name>.1

To copy table styles from other drawings
1 Open the drawing that contains the styles you want to copy (Drawing1, for example), and the drawing
you want to copy styles to (Drawing2, for example).
2 In Toolspace, click the Settings tab.
3 In the View Control list, select Master View.
4 In the Settings tree, expand the Drawing1 collection and select the table style to copy.
5 Drag and drop the table style to Drawing2 in the Settings tree. You must drag the style over the drawing
name in the Settings tree before releasing the mouse button.
■

A valid drag and drop operation will display a

■

An invalid drag and drop operation will display a

cursor.
cursor.

Deleting a Table Style
Use the Settings tree in Toolspace to delete a table style.
To delete a table style
■

In Toolspace, on the Settings tab, expand the object collection, expand the table style type collection (if
applicable), right-click the table style name, and click Delete.
For example, to delete the surface direction table style named ‘Standard’:

NOTE A style that is used in the drawing cannot be deleted.

Quick Reference
Toolspace Shortcut Menu
Settings tab: <drawing name> ➤ <object collection> ➤ Table Styles ➤ <table style type name> ➤
Right-click <table style name> ➤ Delete
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Adding Tables to Drawings
Add tables to a drawing.

Adding Object Tables to Drawings
Specify table data differently for each object type.
■

Point tables. Select points, point groups, or label styles.

■

Alignment tables. Select an alignment, individual labels or tags, or label styles.

■

Parcel tables. Select individual parcel labels or tags, or label styles.

■

Survey figure tables. Select survey figure labels or tags, or label styles.

When creating parcel tables, you can select any general line/curve label types and/or parcel segment labels
including any line or curve label, applied to a line, curve, feature line, or polyline.
You can create an alignment segment label that references a general line or curve style for inclusion in a
table.
General line and curve label styles have a Tag Mode which supports general line and curve labels, parcel
segment labels that reference a general line or curve style, and alignment segment labels that reference a
general line or curve style.
The Add Table commands are available from the Annotate tab.
To add tables to a drawing
1 Do the following:
■

Click Annotate tab ➤ Labels & Tables panel ➤ Add Tables menu ➤ <feature> ➤ Add <feature-specific>
Table

.

2 In the Table Creation dialog box, select the table style, layer, and behavior properties. For more
information, see Table Creation Dialog Box (page 2739).
3 Select the data for the table:
■

For all types of tables, select the check boxes next to the style name to select label styles to include
in the table.

■

For alignment segment tables, select By Alignment and click
Multiple Selection and select the check boxes or click

to select an alignment. Or, select

to select tags.

■

For alignment line, curve, or spiral tab click

to select tags.

■

For point tables, click

■

For parcel tables, click
to select tags or area labels. Note that you can select line and curve labels
within the drawing, just as you would select parcel segment or alignment labels. These labels go
into tag mode when selected. If they are selected in the drawing, you are prompted to create a child
style in tag mode for the selected label.

to specify a point group or click

to select points from the drawing.

NOTE To avoid creating child label styles, set up label styles to be used as tags. For more information, see
Setting Up Label Styles To Be Used as Tags (page 1663).
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4 Click OK.
5 Select an insertion point.

Quick Reference
Ribbon
Annotate tab ➤ Labels & Tables panel ➤ Add Tables menu ➤ <feature> ➤ Add <feature-specific> Table
Menu
<Feature> menu ➤ Add Tables
Dialog Box
Table Creation (page 2739)

Adding Surface Legend Tables to Drawings
Surface tables are created in a legend style and do not use label styles or tags.
To add a surface legend table to a drawing, first do the following:
■

Perform a surface analysis. For more information, see Analysis Tab (Surface Properties Dialog Box) (page
2659).

■

Modify the surface style so that it displays the analysis type. For more information, see Display Tab
(Surface Style Dialog Box) (page 2655).

■

Set up a surface legend table style to display the surface data. For more information, see Table Styles (page
1738).

To add surface legend tables
1 Annotate tab ➤ Labels & Tables panel ➤ Add Tables menu ➤ Add Surface Legend Table
2 Select a surface in the drawing.
3 At the Command prompt, enter the table type.
4 At the Command prompt, enter Dynamic to enable the table to be updated automatically if the surface
analysis is updated. Enter Static to require manual updating.
5 Select an insertion point.

Quick Reference
Ribbon
Annotate tab ➤ Labels & Tables panel ➤ Add Tables menu ➤ Add Surface Legend Table
Menu
Surfaces menu ➤ Add Legend Table
Command Line
AddSurfaceLegendTable
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Dialog Box
Table Creation (page 2739)

Modifying Tables
You can modify the appearance of a table, or add or remove data.

Changing Table Properties
Change table properties to modify table content, appearance, layout, and update behavior.
To change the properties of a table in a drawing
1 Right-click a table, and click Table Properties.
2 In the Table Properties (page 2741) dialog box, you can change the Table Style, Split Table, and Behavior
options.
3 Click OK.

Quick Reference
Ribbon
Select the table. Click Table tab ➤ Modify panel ➤ Table Properties drop-down ➤ Table Properties
Object Shortcut Menu
Right-click table ➤ Table Properties
Command Line
EditTableProperties
Dialog Box
Table Properties (page 2741)

Changing Table Data
Add, remove, or replace data in a table.
NOTE The Table Selection shortcut commands are not available for surface legend tables and alignment segment
tables.
To add data to a table
1 Right-click a table, and click Selection ➤ Add.
2 In the Selection dialog box, select the data by doing the following:
■

All table types: Select label styles by selecting the Apply check box and then selecting Add Existing
or Add Existing And New from the Selection Rule list.

■

Point tables: Click

■

Alignment tables: Click

1750 | Chapter 36 Tables

and select point groups, or click

and select points in the drawing.

and select alignment tags in the drawing.

■

Parcel tables: Click

and select parcel tags in the drawing.

3 Click OK.
To remove data from a table
1 Right-click a table, and click Selection ➤ Remove.
2 In the Selection dialog box, select the data by doing the following:
■

All table types: Select label styles by selecting the Apply check box, click

■

Point tables: Click

and select table rows.

and select point groups.

3 Click OK.
To replace data in a table
1 Right-click a table, and click Selection ➤ Replace.
2 In the Selection dialog box, select the data by doing the following:
■

All table types: Select label styles by selecting the Apply check box and then selecting Add Existing
or Add Existing And New from the Exclusion Rule list.

■

Point tables: Click

■

Alignment tables: Click

■

Parcel tables: Click

and select point groups, or click

and select points in the drawing.

and select alignment tags in the drawing.

and select parcel tags in the drawing.

3 Click OK.

Quick Reference
Ribbon
Select the table. Click Table tab ➤ Modify panel ➤ Add Items
Click Table tab ➤ Modify panel ➤ Remove Items
Click Table tab ➤ Modify panel ➤ Replace Items
Object Shortcut Menu
Right-click table ➤ Selection ➤ Add
Right-click table ➤ Selection ➤ Remove
Right-click table ➤ Selection ➤ Replace
Dialog Box
Add Selection (page 2742)
Remove Selection (page 2743)
Replace Selection (page 2743)

Updating Table Data
Use to update table content.
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Set to Static mode to keep data from updating dynamically.
If a table is set to Static behavior mode, you can update it in the Table Properties dialog box or use the Update
Content command.
The Update Content command overrides static mode and updates the table data.
To update table data
1 Right-click a table and click Table Properties.
2 In the Table Properties dialog box, click Force Content Update.
NOTE You can select this option only when the Reactivity Mode is set to Static.
3 Click OK.
OR
➤

Right-click a table and click Update Content.

Quick Reference
Ribbon
Select the table. Click Table tab ➤ Modify panel ➤ Update Content
Object Shortcut Menu
Right-click table ➤ Table Properties
Right-click table ➤ Update Content
Command Line
EditTableProperties
Dialog Box
Table Properties (page 2741)

Locking Table Data
Use to set table content to static mode.
Set to Static mode to keep data from updating dynamically.
The Update Content command overrides static mode and updates the table data.
To set table data to static mode
➤

Right-click a table and click Static Mode.

Quick Reference
Ribbon
Select the table. Click Table tab ➤ Modify panel ➤ Static Mode
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Command Line
ToggleTableStaticMode
Object Shortcut Menu
Right-click table ➤ Static Mode

Moving Tables
Use the grip in a table’s upper-left corner to move it.
To change the location of a table
■

Select the table and use its grip to drag it to a new location.

Realigning Table Stacks
Use to realign table stacks.
Realigning a table restores table stacks to their original positions. It also adjusts columns if the table data
has changed and a column has overlapped another table section.
To realign table stacks
1 Click any section of a table to select it.
2 Right-click and click Realign Stacks.

Quick Reference
Ribbon
Select the table. Click Table tab ➤ Modify panel ➤ Realign Stacks
Object Shortcut Menu
Right-click table ➤ Realign Stacks
Command Line
RealignTableStacks

Joining Split Tables
Re-connect tables that were split.
To join split tables
1 Right-click a table and click Table Properties.
2 In the Table Properties dialog box, clear the Split Table check box.
3 Click OK.
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Quick Reference
Object Shortcut Menu
Right-click table ➤ Table Properties
Dialog Box
Table Properties (page 2741)

Exploding Tables
Use the AutoCAD EXPLODE command to explode a table into an AutoCAD unnamed block.
An exploded table retains its appearance. However, if you use EXPLODE again, then table components are
converted to AutoCAD objects as follows:
These exploded
table components...

...are converted to these
AutoCAD objects.

text

MText

boundary

polyline

interior borders

lines

boundary fills

hatch objects

To explode a table
1 Click Home tab ➤ Modify panel ➤ Explode
2 Select the table and press Enter.

Quick Reference
Ribbon
Home tab ➤ Modify panel ➤ Explode
Menu
Modify ➤ Explode
Command Line
EXPLODE

Deleting Tables
Delete a table in a drawing.
To delete a table from a drawing
■

Right-click a table and click Erase.
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.

Quick Reference
Object Shortcut Menu
Right-click table ➤ Erase

Table Commands
The following table lists the table-related AutoCAD Civil 3D commands that can be entered at the command
line.
Command

Description

AddSurfaceLegendTable

Creates a legend table to explain colors used in
the surface analysis display (page 1749)

AddTableSelSetByLStyle

Adds data to a table (page 1750)

EditTableProperties

Edits table properties (page 1750)

EditTableSelSet

Replaces data in a table (page 1750)

EditTableStyle

Edits table styles (page 1738)

EditTagNumbers

Renumbers alignment line, arc, or spiral label
segment tags used in tables (page 1723)

RealignTableStacks

Realigns table columns (page 1753)

RemoveTableSelSetByLStyle

Removes rows from a table (page 1750)

ToggleTableStaticMode

Sets table data to static mode (page 1752)

UpdateTable

Updates table content (page 1751)
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Reports

37

In AutoCAD Civil 3D 2011, all reports are consolidated within the Reports Manager. The Reports Manager is displayed
on the Toolbox tab of Toolspace.

Understanding the Reports Manager
Use the Reports Manager to access all the report types that are available in AutoCAD Civil 3D. You can add
custom reports to the Reports Manager so even your custom reporting can be done through the same
interface.
Reports in AutoCAD Civil 3D are of two types: LandXML and .NET. Depending on the type of report, different
dialog boxes are displayed after you select the report to run.
■

The LandXML reports use LandXML data output for report generation, and use predefined or custom
XSL style sheets to format the report data. LandXML reports use the Report Settings (page 1757) for all
settings, such as report header information, units, precision, and so on.
TIP You can tell if a report is a LandXML-based report if the Export To XML Report dialog box is displayed
when you run the report.

■

The .NET reports use custom dialog boxes for selecting the data and options for the report. .NET reports
use a combination of Report Settings (page 1757) (for Client and Owner settings), but they use the drawing
Ambient Settings (page 84) for units, precision, and so on.

NOTE The LandXML Reporting tool is included with AutoCAD Civil 3D as an application that you can run
independently of AutoCAD Civil 3D. To use this tool, you export a LandXML file (page 1884) and then open it within
the LandXML Reporting tool. Access the LandXML Reporting tool by double-clicking Reporting.exe in the
\Autodesk\LandXML Reporting 8 folder.

Specifying Report Settings
Use the Edit Report Settings dialog box to specify report settings.
■

LandXML reports use the Report Settings (page 1757) for all settings, such as report header information,
units, precision, and so on.
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TIP You can tell if a report is a LandXML-based report if the Export To XML Report dialog box is displayed
when you run the report.
■

.NET reports use a combination of Report Settings (page 1757) (for Client and Owner settings), but they
use the drawing Ambient Settings (page 84) for units, precision, and so on.

NOTE Not all settings are displayed in each report. If the style sheet or html formatter does not include an option
to display an item, it is not displayed in the report results.
To specify report settings
1 Click Home or View tab ➤ Palettes panel ➤
2 On the Toolbox tab, click

Toolbox.

Edit Report Settings.

3 In the Edit Report Settings (page 2464) dialog box, expand the tree view and edit the values in the Value
column.
4 Click OK.

Quick Reference
Ribbon
Home or View tab ➤ Palettes panel ➤

Toolbox

Menu
General menu ➤ Reports Manager
Command Line
Toolbox
Dialog Box
Edit Report Settings (page 2464)

Generating a Report
Generate reports by double-clicking a report in the Reports Manager.
To generate a report
1 Click Home or View tab ➤ Palettes panel ➤

Toolbox.

2 Expand Reports Manager ➤ <Report Type> to see the available reports.
3 Double-click a report, or right-click a report and click Execute.
4 Do one of the following:
■

LandXML Reports: In the Export To LandXML (page 2219) dialog box, select the data to include in
the report and click OK.
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NOTE If you are running a points report, for example, only the points that are selected are used in the
report. You can clear the selection of other objects, but that is not necessary. All objects other than points
are filtered out.
“LandXML export complete,” “Generating XSLT Report...”, and “Generating XSLT Report Complete...”
are displayed at the command line. The report is then displayed in the default Internet browser
window.
NOTE It is recommended that Microsoft® Internet Explorer is specified as your default web browser when
you are generating reports. If a different browser is specified as your default browser, and you notice
issues with the output, please change your default browser to Internet Explorer.
NOTE Some LandXML reports display a Save As dialog box which you can use to specify a file location
and file type. LandXML reports can be saved in HTML or Adobe® PDF formats. However, some LandXML
reports are not saved automatically. For more information, see Saving LandXML Report Files (page 1759).
■

.NET Reports: Select the data to include and specify the location to save the report. For more
information on the specific dialog boxes, see Reports Dialog Boxes (page 2463). Click Create Report.
NOTE .NET reports can be saved in several formats, including HTML, Adobe® PDF, Microsoft® Word
Document, Microsoft® Excel Workbook, and Text Document. If Microsoft® Office is not installed, then
the options for Word Document, Excel Workbook, and Text Document are not available.
The report is then displayed and saved to the specified location.

Quick Reference
Ribbon
Home or View tab ➤ Palettes panel ➤

Toolbox

Menu
General menu ➤ Reports Manager
Command Line
Toolbox

Saving LandXML Report Files
You can save your report for future use.
NOTE .NET reports are saved automatically to the specified location in the report dialog box.
To save LandXML report files
1 In the Internet browser window, click File menu ➤ Save As.
2 Change the folder to an appropriate location, or use the default, which is the last folder used.
3 Enter the file name and specify the file type for the report.
4 Click Save.
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NOTE If you do not want to save the entire report, select the area of the report you want to save, copy it
and paste the data into Microsoft Word, Microsoft Excel, or another editor. If you save your files as comma
or space delimited files you can successfully import them into Microsoft Excel spreadsheets.

Editing Toolbox Content
The Reports Manager is displayed on the Toolbox tab of Toolspace. You can add custom reports to the
Reports Manager, or other custom tools to the Toolbox.
To edit Toolbox content
1 Click Home or View tab ➤ Palettes panel ➤
2 On the Toolbox tab, click

Toolbox.

Edit Toolbox Content.

3 To edit the Reports Manager items, in the Toolbox Editor vista (page 2463), expand the Reports Manager
item.
4 Do one of the following:
■

To add a new collection for reports, right-click the Reports Manager item and click New Category.
You can specify a name and description for the category by selecting the new category and editing
the values displayed in the right pane.

■

To add a new report, right-click a collection (category) and click New Tool.
A new tool is inserted into the category with a default name. Expand the collection and click the
New Tool item to select it. Specify the properties for the new tool by editing the values in the right
pane.

Quick Reference
Ribbon
Home or View tab ➤ Palettes panel ➤ Toolbox
Menu
General menu ➤ Toolbox
Command Line
Toolbox

Reports Command Reference
Quickly access reports functionality from the command line.
Command

Description

Toolbox

Opens or closes the Toolspace Toolbox tab (page
117).
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Object Rendering

38

You can create realistic rendering of AutoCAD Civil 3D objects using render materials.
A render material corresponds to a specific material in a civil model, such as asphalt, concrete, or gravel. It consists of a
pointer to a material and settings that control the material properties when it is rendered.
You can apply render materials to several objects, including surfaces and surface masks, corridor surfaces and corridor
surface boundaries, pipes and structures, and interferences.

View using styles such as 2D wireframe and 3D realistic
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Rendered image of a surface object simulated with grass and the underlying concrete
drainage pipes and catch basins

For more information about render materials, including how to create custom render materials, modify render materials,
add render materials to the drawing, and apply render materials to objects, see Materials and textures in the AutoCAD User’s
Guide.

Creating Render Materials
Create render materials for enhancing the rendered views of surfaces, corridor models, pipes, structures, and
interferences.
You use a render material to add a realistic look to an object in AutoCAD Civil 3D. The material you select
for visualization must exist in the current drawing.
After you create a render material, you can save it to a drawing template or copy it to other drawings.
If, at rendering time, the material specified as the render material cannot be found in the drawing, the
AutoCAD GLOBAL material is used.
To create a render material
■

To open the Materials window, click View menu ➤ Render ➤ Materials.

For instructions about how to create a render material, see Create Materials in the AutoCAD User’s Guide.

Quick Reference
Menu
View menu ➤ Render ➤ Materials
Command Line
MATERIALS
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Adding Materials to Drawings
To use a material in a rendering, the material must exist in the current drawing.
A Material Library is installed with AutoCAD Civil 3D by default. You can open the Tools Palette and either
drag a render material into a drawing or insert the material by using the Add to Current Drawing command.
To add materials to the current drawing
1 Click Home tab ➤ Palettes panel ➤ Tool Palettes Window.
2 In the Tool Palettes window, right-click the Tool Palettes Window button, and choose Civil Materials
from the list.
NOTE In addition to civil-specific render materials, you can access and use all the render materials contained
in the AutoCAD Materials Library palette. Choose one of the Materials Library palettes from the Tools Palettes
Window shortcut menu.
3 In the Civil Materials palette, do one of the following:
■

Right-click the swatch representing the chosen render material and select Add to Current Drawing.

■

Drag and drop a render material swatch into the drawing.

The selected render material is added to the drawing. For more information, see “Materials Dashboard
and Tools Palettes” in AutoCAD Help.

Quick Reference
Menu
General ➤ Tool Palettes Window ➤ click the Properties button ➤ choose Materials Library ➤ right-click
a render material swatch ➤ Add to Current Drawing
Command Line
ToolPalettes

Applying Render Materials to Objects
You can apply a render material to AutoCAD Civil 3D objects.
You can specify a default render material to use for surfaces in the Surface Feature Settings (page 2629). After
you create a surface or a surface mask, you can assign a different render material by changing the surface
properties or surface mask properties.
Define the render material for corridor surfaces on the Surfaces tab (page 2038) of the Corridor Properties dialog
box.
Specify the style for corridor boundaries on the Boundaries tab (page 2039).
Specify the styles for pipe network parts by using the Render Material option on the Pipe Properties
Information tab (page 2276) or the Structure Properties Information tab (page 2288). Specify the styles for
interferences by using the Interference Properties Information tab. (page 2311).
TIP Use corridor boundaries to apply different render materials to one corridor surface. For more information, see
Rendering Corridor Models (page 1533).
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To apply a render material to an object
1 Click Home tab ➤ Palettes panel ➤ Tool Palettes Window.
2 In the Tool Palettes window, click the Properties button, and choose Civil Materials from the list.
NOTE In addition to civil-specific render materials, you can access and use all the render materials contained
in the AutoCAD Materials Library palette. Choose Materials Library from the Propertied menu.
3 Do one of the following:
■

Right-click on the swatch representing the chosen material and select Apply Material to Objects.

■

Drag and drop a render material swatch onto the object in the drawing.

The selected render material is added to the drawing. For more information, see Materials Tool Palettes
in the AutoCAD Help.

Quick Reference
Ribbon
Home tab ➤ Palettes panel ➤ Tool Palettes Window
Menu
General menu ➤ Tool Palettes Window ➤ click the Properties button ➤ choose Materials Library ➤
right-click a render material swatch ➤ Apply Material to Objects
Command Line
ToolPalettes

Rendering Objects
You can use the Render command to render objects.
To render objects
1 Open the Materials window using the MATERIALS command.
2 In the Materials window, apply a render material to the object you want to render. For more information,
see Applying Render Materials to Objects (page 1763).
3 Set the rendering properties. See Basics of Rendering in AutoCAD help.
4 If you are rendering a corridor, create one or more corridor surfaces and corridor surface boundaries,
and optionally export the corridor surface. For more information, see Exporting Corridor Surfaces (page
1532).
5 To render the object in AutoCAD, click View menu ➤ Render ➤ Render.

Quick Reference
Menu
View menu ➤ Render ➤ Render
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Command Line
MATERIALS
RENDER
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Transparent Commands
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Use AutoCAD Civil 3D transparent commands to enter a value based on known information when you are prompted for
a point, a distance, or a radius.
Most AutoCAD Civil 3D transparent commands are used to specify point locations within a larger operation, such as the
creation of an alignment or a parcel lot line. Using these transparent commands, you can calculate the location for a point
from information, such as angle and distance, or from point object information, such as a point number.

NOTE For more information about AutoCAD transparent commands see AutoCAD Help.
Some of the AutoCAD Civil 3D transparent commands require a Z coordinate for the point elevation. For more information,
see Transparent Command Settings (page 1767).

Transparent Command Settings
Use Transparent Command settings to control how you are prompted when you use a Civil transparent
command.
The Transparent Command settings are specified on the Ambient Settings tab in the Edit Drawing Settings
dialog box. In addition to the specific Transparent Command settings, many of the transparent commands
are affected by other settings on the Ambient Settings tab.
NOTE Angle, Direction, and Lat Long ambient settings are set to a single unit type (degree, grad or radian) and
format (digital or various degree/minute/second formats for degrees). You will have to change these settings, if
you wish to use a different unit/format for angles, bearings or latitudes/longitudes.
You can use the Transparent Command settings to control the following prompts for transparent commands:
■

Whether you are prompted for 3D points

■

The prompt order for X/Y

■

The prompt order for northing/easting

■

The prompt order for latitude/longitude

The Transparent Command settings are drawing ambient settings that can be overridden at either the object
(feature) level or at the individual command level. For more information, see Ambient settings (page 84).
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Activating a Transparent Command
You can activate transparent commands by entering a command or by using a toolbar.
■

Enter the name of the transparent command at the command line. A transparent command always
begins with an apostrophe (‘).

■

Select the command from the toolbar. To display the toolbar for accessing transparent commands,
right-click any toolbar and select Transparent Commands.

Using Transparent Commands Within a Running Command
You can use transparent commands within a main command that requires the entry of multiple point
locations.
When you enter a transparent command within a running command that accepts more than one point
location (for example, the AutoCAD LINE command), you can enter a series of points in the same format
without having to re-enter the transparent command. At any time, you can press Esc to terminate the
transparent command and return control to the main command, where you can switch to another transparent
command. Also, you can end the transparent command by terminating the main command.

Using Previously Entered Points in a Running Command for Relative Data Input
When you use a transparent command that requires baseline data from which to calculate a relative location,
you must enter the required data before specifying the command parameters. If you use a transparent
command within a running command, the transparent command remembers the last points entered during
the running command and uses them to calculate new relative locations.
For example, when you use the Bearing Distance (‘BD) transparent command, you must first identify a
baseline point from which the bearing and distance are measured. If you initiate the Bearing Distance
command before you enter any points, you are prompted for the baseline point before you are prompted
for quadrant, bearing, and distance. If you use the Bearing Distance command after you have entered at
least one point, the last point you entered is used as the baseline.

Transparent Command Point Filters
When you are working within a transparent command and you are prompted to specify a point location,
you can use point filters to specify known point information by doing one of the following:
■

Entering a point number

■

Entering northing and easting

■

Selecting a point in a drawing

For more information, see Using Point Filters Within Transparent Commands (page 1787).

Zooming to a Point
Zoom to a point name, point number, or a range of point numbers.
Run this command at the command line or as a transparent command from within another command.
To zoom to an individual point
■

On the ribbon, click COGO Points contextual tab ➤ COGO Point Tools ➤ Zoom To Point
command line, enter the point name or number.
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. At the

To zoom to a list of points
■

At the command line, enter ZTP and then enter point numbers separated by commas.

To zoom to a range of points
■

At the command line, enter ZTP and then enter the range of points separated by a hyphen.

If a point is not in the current drawing a message is displayed at the command line. If a point is missing
from a series of points, then it is ignored and the location of all the other points will be used.
To zoom to a point from within another command
■

At the command line, enter ‘ZTP and then enter a point name, point number, or a range of point numbers.
After you run the command as a transparent command, the command line returns to the main command
after a single zoom.

NOTE At the command line you can enter a comma delimited list that contains both point numbers and point
names.

Quick Reference
Ribbon
COGO Points Contextual tab: COGO Point Tools ➤ Zoom To Point
Toolbar
Transparent Commands toolbar ➤
Command Line
ZTP
‘ZTP
ZoomToPoint

Using Angle and Distance to Specify a Point Location
You can specify a point location using an angle and a distance from a reference line.
The last two entered points define the reference line, or you must define a line. From the reference line (1-2),
specify an angle (3), and distance (4), to specify a point (5).
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If you have already entered one point in the command, you are prompted to enter a second point to define
the reference line.
A transparent command can only be used within a running command. The reference line is updated each
time you enter a point.
To specify a point location using angle and distance
1 When you are prompted to enter a point within a command, do one of the following:
■

Enter 'ad.

■

Activate the Transparent Commands toolbar and select

.

2 If you have not yet entered any points in the main command, you must specify a temporary reference
line by doing one of the following:
■

Select a line.

■

Enter p, then specify a start point and endpoint for the line.

3 If you have entered one point in the main command, that point is used as the starting point for the
temporary reference line. Specify the ending point for the temporary reference line.
4 Specify the angle by doing one of the following:
■

Click in the drawing to specify the angle.

■

Enter a positive or negative numeric value for the angle.

■

Enter c to switch the angle between counterclockwise and clockwise, and then specify the angle.

5 Specify the distance by either clicking in the drawing or entering a distance.
6 If you are prompted, enter an elevation. For more information, see Entering an Elevation for a Transparent
Command (page 1786).
NOTE Elevation prompting for transparent commands is controlled by the Transparent Command setting
Prompt For 3D Points. For more information, see Transparent Command Settings (page 1767).

Quick Reference
Command Line
‘AD
Toolbar
Transparent Commands toolbar ➤

Using Bearing and Distance to Specify a Point Location
You can specify a point location using a bearing and a distance from a reference point.
The last entered point is used, or you must specify a current point. From the start point (1), specify the
quadrant (2), a bearing (3), and distance (4), to specify a point (5).
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A transparent command can only be used within a running command. The reference point is updated each
time you enter a point.
To specify a point location using bearing and distance
1 When you are prompted to enter a point within a command, do one of the following:
■

Enter 'bd.

■

Activate the Transparent Commands toolbar and select

.

2 If you have not yet entered any points in the main command, specify a temporary point from which
the bearing and distance will be measured.
3 Specify a quadrant number by either clicking in the drawing or entering a value between 1 and 4.
4 Specify the bearing within the quadrant by clicking in the drawing or entering a bearing using the
angular units for the drawing.
5 Specify the distance by either clicking in the drawing or entering a distance.
6 If you are prompted, enter an elevation. For more information, see Entering an Elevation for a Transparent
Command (page 1786).
NOTE Elevation prompting for transparent commands is controlled by the Transparent Command setting
Prompt For 3D Points. For more information, see Transparent Command Settings (page 1767).

Quick Reference
Command Line
‘BD
Toolbar
Transparent Commands toolbar ➤

Using Deflection and Distance to Specify a Point Location
You can specify a point location using a deflection angle and a distance from a reference line.
The deflection angle is measured from the reference line’s extension beyond the endpoint, and the distance
is measured from the line’s endpoint
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The extension of the last two entered points defines the reference line, or you must define a line. From the
reference line (1-2) and start point (2), specify a deflection angle (3), and distance (4) to specify a point (5).

A transparent command can only be used within a running command. The reference line is updated each
time you enter a point.
To specify a point location using deflection and distance
1 When you are prompted to enter a point within a command, do one of the following:
■

Enter 'dd.

■

Activate the Transparent Commands toolbar and select

.

2 If you have not yet entered any points in the main command, you must specify a temporary reference
line by doing one of the following:
■

Select a line.

■

Enter p, then specify a start point and endpoint for the line.

3 If you have entered one point in the main command, that point is used as the starting point for the
temporary reference line. Specify the ending point for the temporary reference line.
4 Specify the angle by doing one of the following:
■

Click in the drawing.

■

Enter a positive or negative numeric value for the angle.

■

Enter c to switch the angle between counterclockwise and clockwise, and then specify the angle.

5 Specify the distance by either clicking in the drawing or entering a distance.
6 If you are prompted, enter an elevation. For more information, see Entering an Elevation for a Transparent
Command (page 1786).
NOTE Elevation prompting for transparent commands is controlled by the Transparent Command setting
Prompt For 3D Points. For more information, see Transparent Command Settings (page 1767).

Quick Reference
Command Line
‘DD

1772 | Chapter 39 Transparent Commands

Toolbar
Transparent Commands toolbar ➤

Using Azimuth and Distance to Specify a Point Location
You can specify a point location using an azimuth and a distance from a reference point.
The last entered point is used, or you must specify a current point. From the start point (1) and North
meridian (2), specify an azimuth (3), and distance (4), to specify a point (5).

A transparent command can only be used within a running command. The reference point is updated each
time you enter a point.
To specify a point location using azimuth and distance
1 When you are prompted to enter a point within a command, do one of the following:
■

Enter 'zd.

■

Activate the Transparent Commands toolbar and select

.

2 If you have not yet entered any points in the main command, specify a temporary point from which
the azimuth and distance will be measured.
3 Specify an azimuth by either clicking in the drawing or entering a value.
4 Specify the distance by either clicking in the drawing or entering a distance.
5 If you are prompted, enter an elevation. For more information, see Entering an Elevation for a Transparent
Command (page 1786).
NOTE Elevation prompting for transparent commands is controlled by the Transparent Command setting
Prompt For 3D Points. For more information, see Transparent Command Settings (page 1767).

Quick Reference
Command Line
‘ZD
Toolbar
Transparent Commands toolbar ➤
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Using Side Shots to Specify a Point Location
You can specify a point location using an angle (bearing, azimuth, angle, or deflection) and a distance from
a reference point.
Before you can specify an angle and distance within the Side Shot command, you must define a temporary
reference line from which all the subsequent points are calculated.
The last two entered points define the reference line, which is reused if you take multiple shots within the
command. Specify an angle and distance to the next point. From the reference line (1-2) and start point (2),
specify points (3, 4, 5) by side shot.

To define a line, you can either select an existing line in the drawing or enter two points. If you have already
entered one point in the command, you are prompted to enter a second point to define the reference line.
A transparent command can only be used within a running command. In this command, the reference line
is not updated; it remains the same for all points entered.
To specify side shot point locations
1 When you are prompted to enter a point in a command, do one of the following:
■

Enter 'ss.

■

Activate the Transparent Commands toolbar and select

.

2 If you have not yet entered any points in the main command, you must specify a temporary reference
line by doing one of the following:
■

Select a line.

■

Enter p, then specify a start point and endpoint for the line.

3 If you have entered one point in the main command, that point is used as the starting point for the
temporary reference line. Specify the ending point for the temporary reference line.
4 Enter an angle by doing one of the following:
■

Enter an angle in angular units for the drawing.

■

Enter b, then specify the angle by specifying a quadrant and a bearing.

■

Enter d, then specify a deflection angle.

■

Enter z, then specify an azimuth.

■

Enter c to switch the direction of the angle between clockwise and counterclockwise.

5 Specify a distance by either clicking in the drawing or entering a distance.
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6 If you are prompted, enter an elevation. For more information, see Entering an Elevation for a Transparent
Command (page 1786).
NOTE Elevation prompting for transparent commands is controlled by the Transparent Command setting
Prompt For 3D Points. For more information, see Transparent Command Settings (page 1767).
7 If you are working within a running command, do one of the following:
■

To enter another side shot using the same angle type, enter the angle and repeat Steps 5 and 6.

■

Press Esc to end the Side Shot transparent command.

Additional side shot locations are calculated using the reference line established at the start of the
transparent command.

Quick Reference
Command Line
‘SS
Toolbar
Transparent Commands toolbar ➤

Using Northing and Easting to Specify a Point Location
You can specify a point location using known northing and easting values.
A transparent command can only be used within a running command.
To specify a point location by northing and easting
1 When you are prompted to enter a point in a command, do one of the following:
■

Enter 'ne.

■

Activate the Transparent Commands toolbar and select

.

2 Enter a northing value.
3 Enter an easting value.
NOTE The order in which you are prompted for northing and easting is controlled by the Transparent
Command setting Prompt For Easting Then Northing. For more information, see Transparent Command
Settings (page 1767).
4 If you are prompted, enter an elevation. For more information, see Entering an Elevation for a Transparent
Command (page 1786).
NOTE Elevation prompting for transparent commands is controlled by the Transparent Command setting
Prompt For 3D Points. For more information, see Transparent Command Settings (page 1767).
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Quick Reference
Command Line
‘NE
Toolbar
Transparent Commands toolbar ➤

Using Grid Northing and Easting to Specify a Point Location
You can specify a point location using grid northing and easting values.
Grid settings are required in the drawing, including the zone, the coordinate system, and any applied
transformations.
Transformation settings for the drawing may include a base point, a rotation angle, or another reference
point.
A transparent command can only be used within a running command.
To specify a point location by grid northing and grid easting
1 When you are prompted to enter a point in a command, do one of the following:
■

Enter 'gn.

■

Activate the Transparent Commands toolbar and select

.

2 Enter a grid northing value.
3 Enter a grid easting value.
4 If you are prompted, enter an elevation. For more information, see Entering an Elevation for a Transparent
Command (page 1786).
NOTE Elevation prompting for transparent commands is controlled by the Transparent Command setting
Prompt For 3D Points. For more information, see Transparent Command Settings (page 1767).

Quick Reference
Command Line
‘GN
Toolbar
Transparent Commands toolbar ➤

Using Latitude and Longitude to Specify a Point Location
You can specify a point location, using latitude and longitude values.
Zone and coordinate system settings are required in the drawing, and any applied transformations.
A transparent command can only be used within a running command.
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To specify a point location by latitude and longitude
1 When you are prompted to enter a point, do one of the following:
■

Enter 'll (two Ls).

■

Activate the Transparent Commands toolbar and select

.

2 Enter a latitude value.
3 Enter a longitude value.
NOTE The order in which you are prompted for latitude and longitude is controlled by the Transparent
Command setting Prompt For Longitude Then Latitude. For more information, see Transparent Command
Settings (page 1767).
4 If you are prompted, enter an elevation. For more information, see Entering an Elevation for a Transparent
Command (page 1786).
NOTE Elevation prompting for transparent commands is controlled by the Transparent Command setting
Prompt For 3D Points. For more information, see Transparent Command Settings (page 1767).

Quick Reference
Command Line
‘LL
Toolbar
Transparent Commands toolbar ➤

Using a Point Number to Specify a Point Location
You can specify a point location using a point number.
The system searches first in the active drawing, and then in the project, if applicable. You can enter multiple
point numbers or number ranges separated by commas.
Only the northing and easting values from the specified point are used. If you want elevation values, you
must enter or select an elevation.
You can use the command to specify a single point number, or you can specify multiple points by entering
individual point numbers or ranges of point numbers separated by commas. For example, you could enter
the following: 100-105, 603, 701-713.
A transparent command can only be used within a running command.
To specify a point location by point number
1 When you are prompted to enter a point in a command, do one of the following:
■

Enter 'pn.

■

Activate the Transparent Commands toolbar and select

.

2 Enter a point number or a list of point numbers.
3 If you are prompted, enter an elevation.

Using a Point Number to Specify a Point Location | 1777

If the point you specified in the previous step has an elevation, it is listed as the default elevation, and
you can select it by pressing Enter. For more information, see Entering an Elevation for a Transparent
Command (page 1786).
NOTE Elevation prompting for transparent commands is controlled by the Transparent Command setting
Prompt For 3D Points. For more information, see Transparent Command Settings (page 1767).

Quick Reference
Command Line
‘PN
Toolbar
Transparent Commands toolbar ➤

Using a Point Object to Specify a Point Location
You can specify a point location by selecting an existing point.
Points are highlighted as you move the cursor over them.
The northing and easting value from the point are read from the selected drawing point. If you are prompted
to enter an elevation, the default choice is the elevation value of the point. You can use the point’s elevation
value or you can enter another value.
A transparent command can only be used within a running command.
To specify a point location by selecting a point
1 When you are prompted to enter a point in a command, do one of the following:
■

Enter 'po.

■

Activate the Transparent Commands toolbar and select

.

2 Select the point in the drawing.
3 If you are prompted, enter an elevation.
If the point you selected in the previous step has an elevation, it is listed as the default elevation, which
you can select by pressing Enter. For more information, see Entering an Elevation for a Transparent
Command (page 1786).
NOTE Elevation prompting for transparent commands is controlled by the Transparent Command setting
Prompt For 3D Points. For more information, see Transparent Command Settings (page 1767).

Quick Reference
Command Line
‘PO
Toolbar
Transparent Commands toolbar ➤
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Using a Point Name to Specify a Point Location
You can specify a point location by referencing the name of an existing point.
The system searches first in the active drawing, and then in the project, if applicable.
A transparent command can only be used within a running command.
NOTE Use the Prompt For Point Names setting to control whether points are created with point names. For more
information, see Editing the Default Point Creation Settings (page 444).
To specify a point location by point name
1 When you are prompted to enter a point in a command, do one of the following:
■

Enter 'pa.

■

Activate the Transparent Commands toolbar and select

.

2 Enter a point name.
3 If you are prompted, enter an elevation.
If the point you specified in the previous step has an elevation, it is listed as the default elevation, and
you can select it by pressing Enter. For more information, see Entering an Elevation for a Transparent
Command (page 1786).
NOTE Elevation prompting for transparent commands is controlled by the Transparent Command setting
Prompt For 3D Points. For more information, see Transparent Command Settings (page 1767).

Quick Reference
Command Line
‘PA
Toolbar
Transparent Commands toolbar ➤

Using a Station Offset to Specify a Point Location
You can specify a point location using a station and an offset along an alignment.
An alignment must exist in the current drawing, and the specified station value must fall within the extents
of the alignment.
A transparent command can only be used within a running command.
To specify a point location by station offset
1 When you are prompted to enter a point in a command, do one of the following:
■

Enter 'so.

■

Activate the transparent command toolbar and select

.

2 Specify a station by either entering a station value or clicking in the drawing.
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3 Specify a distance by either entering an offset or clicking in the drawing.
The coordinates of the point are calculated.
4 Do one of the following:
■

Enter another station and follow the prompts to specify another location.

■

Press Esc to end the transparent command.

5 If you are prompted, enter an elevation. For more information, see Entering an Elevation for a Transparent
Command (page 1786).
NOTE Elevation prompting for transparent commands is controlled by the Transparent Command setting
Prompt For 3D Points. For more information, see Transparent Command Settings (page 1767).

Quick Reference
Command Line
‘SO
Toolbar
Transparent Command toolbar ➤

Using a Profile Station and an Elevation to Specify a Point Location
You can specify the X and Y coordinates for a point by identifying a station along the parent alignment of
the profile view.
Specify the alignment station and the point elevation either graphically or numerically.
A transparent command can only be used within a running command.
To specify a point location using a station along the parent alignment of a profile view
1 When you are prompted to enter a point in a command, do one of the following:
■

Enter 'stae.

■

Activate the transparent command toolbar and select

.

2 If the main command is not a profile layout or profile view label command, select a profile view.
3 In plan view, select an alignment.
4 Specify a station on the alignment by either entering the station value or clicking a point on or near
the alignment in plan view.
A selection marker displays the current location on the alignment.
5 Select the profile view again.
6 Specify an elevation in the profile view by either entering an elevation value or clicking a point in the
profile view.
In the profile view, a selection marker displays the current elevation. The station location is held at the
station you selected.
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7 Do one of the following:
■

Enter another station and elevation.

■

Press Esc to end the transparent command.

Quick Reference
Command Line
‘STAE
Toolbar
Transparent Command toolbar ➤

Using an Alignment and Surface to Specify a Point Location
You can specify the X and Y coordinates for a point by identifying a station along an alignment and location
on a surface.
Define the profile layout entities by specifying a station and elevation based on plan view objects.
Elevation data can be derived from finished surfaces such as corridors and grading or from an existing surface.
A transparent command can only be used within a running command.
To specify a point location in a profile view using an alignment and surface
1 When you are prompted to enter a point in a command, do one of the following:
■

Enter 'sse.

■

Activate the transparent command toolbar and select

.

2 In plan view, select the parent alignment of the profile view.
3 Select the surface from which you want to derive elevation data.
4 Select a point on the surface.
5 Select the profile view again.
6 Do one of the following:
■

Select additional locations on the surface to create additional points with the corresponding alignment
station and elevation values.

■

Press Esc to end the transparent command.

Quick Reference
Command Line
‘SSE
Toolbar
Transparent Command toolbar ➤
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Using an Alignment and COGO Point to Specify a Point Location
You can specify the X and Y coordinates for a point by identifying an alignment and COGO point.
COGO points can be used to define a layout profile include points along an alignment, survey points, or
corridor points.
Define profile layout entities by specifying a station and elevation based on plan view objects. Examples of
COGO points that may be used to define a layout profile are points along the parent alignment or other
alignment, survey points, or points derived from a corridor.
A transparent command can only be used within a running command.
To specify a point location in a profile view using an alignment and a COGO point
1 When you are prompted to enter a point in a command, do one of the following:
■

Enter 'spe.

■

Activate the transparent command toolbar and select

.

2 In plan view, select an alignment.
3 Select a COGO point.
4 Select the profile view again.
5 Do one of the following:
■

Select additional points in plan view to create additional points with the corresponding alignment
station and elevation values.

■

Press Esc to end the transparent command.

Quick Reference
Command Line
‘SPE
Toolbar
Transparent Command toolbar ➤

Using Station and Elevation to Specify a Point Location in a Profile
View
You can specify the X and Y coordinates for a point by identifying a station and an elevation within a profile
view.
Specify the values within the profile view, either graphically or numerically.
A transparent command can only be used within a running command.
To specify a point location in a profile view using station and elevation
1 When you are prompted to enter a point in a command, do one of the following:
■

Enter 'pse.
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■

Activate the transparent command toolbar and select

.

2 Select a profile view.
3 Specify a station in the profile view by either entering the station value or clicking a point in the profile
view.
4 Specify an elevation in the profile view by either entering an elevation value or clicking a point in the
profile view.
5 If you are working within a running command, do one of the following:
■

Enter another station and elevation.

■

Press Esc to end the transparent command.

Quick Reference
Command Line
‘PSE
Toolbar
Transparent Command toolbar ➤

Using Elevation and Grade to Specify a Point Location in a Profile
View
Create a point at a specific elevation along a fixed grade line.
Specify the values within the profile view, either graphically or numerically.
A transparent command can only be used within a running command.
To specify a point location in a profile view using elevation and grade
1 When you are prompted to enter a point in a command, do one of the following:
■

At the command line, enter ‘PGE and then enter the point name or number.

■

Activate the transparent command toolbar and select

Profile Grade Elevation.

2 Select a profile view.
3 Specify a grade in the profile view by either entering a numeric value or clicking two points in the
profile view.
4 Specify an elevation in the profile view by either entering a numeric value or clicking a point in the
profile view.
5 If you are working within a running command, do one of the following:
■

Enter another grade and elevation.

■

Press Esc to end the transparent command.
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Quick Reference
Command Line
‘PGE
Toolbar
Transparent Command toolbar ➤

Using Grade and Length to Specify a Point Location in a Profile
View
You can specify a point location using grade and length values.
Specify the values within the profile view, either graphically or numerically.
At least one point must be entered in the current running command before you use this transparent command.
A transparent command can only be used within a running command.
To specify a point location in a profile view using grade and length
1 When you are prompted to enter a point in a command, do one of the following:
■

Enter 'pgl (the last letter is an L).

■

Activate the transparent command toolbar and select

.

2 Select a profile view.
3 Specify a grade by either entering a numeric value or clicking two points in the profile view.
4 Specify a length, which is the horizontal distance from the last point picked in the running command,
by either entering a value or clicking two points.
5 If you are working within a running command, do one of the following:
■

Enter another grade and length.

■

Press Esc to end the transparent command.

Quick Reference
Command Line
‘PGL
Toolbar
Transparent Command toolbar ➤

Using Grade and Station to Specify a Point Location in a Profile
View
You can specify a point location using grade and station values.
Specify the values within the profile view, either graphically or numerically.
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At least one point must be entered in the current running command before you use this transparent command.
A transparent command can only be used within a running command.
To specify a point location in a profile view using grade and station
1 When you are prompted to enter a point in a command, do one of the following:
■

Enter 'pgs.

■

Activate the transparent command toolbar and select

.

2 Select a profile view.
3 Specify a grade by either entering a numeric value or clicking two points in the profile view.
4 Specify a station in the profile view by either entering a numeric value or clicking a point in the profile
view.
5 If you are working within a running command, do one of the following:
■

Enter another grade and station.

■

Press Esc to end the transparent command.

Quick Reference
Command Line
‘PGS
Toolbar
Transparent Command toolbar ➤

Specifying a Length by Selecting an Object
Use the Match Length transparent command to specify a distance value as the length of an existing object.
A transparent command can only be used within a running command.
To specify a length by selecting an object
1 When you are prompted to enter a length or a distance in a command, do one of the following:
■

Enter 'ml (the last letter is an L).

■

Activate the Transparent Commands toolbar and select

.

2 Select an AutoCAD line or a solved alignment line.

Quick Reference
Command Line
‘ML
Toolbar
Transparent Commands toolbar ➤
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Specifying a Radius by Selecting an Object
Use the Match Radius transparent command to specify a radius value as the radius of an existing object.
A transparent command can only be used within a running command.
To specify a radius by selecting an object
1 When you are prompted to enter a point in a command, do one of the following:
■

Enter 'mr.

■

Activate the Transparent Commands toolbar and select

.

2 Select an AutoCAD arc or a solved alignment curve.

Quick Reference
Command Line
‘MR
Toolbar
Transparent Commands toolbar ➤

Entering an Elevation for a Transparent Command
After you use a transparent command to establish the X and Y coordinates of a point location, you can
specify the Z coordinate.
Specify an elevation using any of the following methods:
■

Accept the default elevation

■

Enter an elevation value

■

Specify a grade

■

Specify a slope

■

Take the elevation from the current surface

The default elevation, displayed at the prompt, is determined by the transparent command in use. If the
current transparent command is ‘PN (point number), ‘PO (point object), or ‘PA (point name), the default
elevation is taken from the specified point. In all other cases, the default elevation is the AutoCAD default
elevation.
A transparent command can only be used within a running command.
NOTE Elevation prompting for transparent commands is controlled by the Transparent Command setting Prompt
For 3D Points. For more information, see Transparent Command Settings (page 1767).
To enter an elevation for a transparent command
1 Run a transparent command until you are prompted to enter an elevation.
2 Do one of the following:
■

To accept the default elevation that is displayed on the command line, press Enter.
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■

Enter g. The elevation is calculated using the entered grade and a previously entered point.

■

Enter s. The elevation is calculated using the entered slope and a previously entered point.

■

Enter y. The elevation is taken from the X, Y location on the current surface.

■

Enter t. If there is more than one surface in the drawing, you are prompted to select the surface from
which the elevation is read.

NOTE During a running command, the default prompts for elevation change, depending on how the previous
elevation was entered. Enter e to reset the prompts back to the defaults described above.

Using Point Filters Within Transparent Commands
Use Civil point filters to enter known point information when you are prompted for a point location within
a transparent command.
A point filter offers you three ways to specify a point location:
■

enter a point number

■

enter northing and easting values

■

select a point in the active drawing

To activate a point filter, do one of the following:
■

Enter the point filter on the command line. You must always begin a transparent command point filter
with a period (.).

■

Select the point filter from the transparent command filter toolbar. If the toolbar is not displayed, right
click any toolbar and select Transparent Command Filters.

The following table lists the point filters available within the Civil transparent commands.
To specify a location using this Enter this point
information...
filter...
point number

.p

a point in a drawing

.g

known northing and easting

.n

Or click this icon on the
Transparent Command
Filter Toolbar...

A point filter is active only while you enter a single point location. Control then returns to the main
transparent command.
Point filters are available for use only when you are prompted for a point location during the following
transparent commands:
■

Angle Distance (‘AD)

■

Bearing Distance (‘BD)

■

Deflection Distance (‘DD)
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■

Azimuth Distance (‘ZD)

■

Station Offset (‘SO)

■

Side Shot (‘SS)

When you are working with the .p (point number) point filter, the system searches for the point first within
the active drawing, then within the project, if the drawing is attached to a project.
To use a point filter within a transparent command
1 When you are prompted for a coordinate location from within a transparent command, do one of the
following:
■

To specify a point using a point number, enter .p and enter the point number.

■

To specify the coordinates from a point object in a drawing, enter .g and select the point.

■

To enter a known northing and easting, enter .n and enter the northing and easting values.

2 Continue with the transparent command.

Quick Reference
Command Line
.p
.g
.n
Toolbar
Transparent Command Filters toolbar ➤

Transparent Command Reference
Use Transparent Command to quickly access functionality within a larger operation.
The following table lists the transparent commands that are used to specify point locations.
To specify a point location using this information...

Use this transpar- Toolbar
ent command...
Icon

angle and distance (page 1770)

‘AD

bearing and distance (page 1771)

‘BD

azimuth and distance (page 1773)

‘ZD

deflection angle and distance (page 1772)

‘DD

northing and easting (page 1775)

‘NE

grid northing and grid easting (page 1776)

‘GN
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To specify a point location using this information...

Use this transpar- Toolbar
ent command...
Icon

latitude and longitude (page 1777)

‘LL

point number (page 1777)

‘PN

point name (alias) (page 1779)

‘PA

a point in a drawing (page 1778)

‘PO

side shot from a point (page 1774)

‘SS

station and offset (page 1779)

‘SO

station along the parent alignment of a profile
view (page 1780)

‘STAE

station along the parent alignment of a profile
view, elevation from surface (page 1781)

‘SSE

station along the parent alignment of a profile
view, elevation from a COGO point (page 1782)

‘SPE

station and elevation in a profile view (page 1782) ‘PSE

grade and length in a profile view (page 1784)

‘PGL

grade and station in a profile view (page 1785)

‘PGS

The following table lists the point filters available within the Civil transparent commands.
To specify a location using this Enter this point
information...
filter...
point number (page 1788)

.p

a point in a drawing (page 1788)

.g

known northing and easting (page
1788)

.n

Toolbar icon

The following table lists the transparent commands that are not used to specify point locations:
To specify this information when Use this transparent
prompted...
command...
an object’s length (page 1785)

Toolbar Icon

‘ML
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To specify this information when Use this transparent
prompted...
command...
an object’s radius (page 1786)

‘MR

To zoom to an individual pointzoom
to pointAt the command line, enter
ZTP and then enter the point n...
(page 1768)Zoom to a point name,
point number, or a range of point
numbers

‘ZTP
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Toolbar Icon

Utilities

40

You can use the AutoCAD Civil 3D Utilities to perform operations not related to a specific object or command.

Coordinate Geometry (COGO)
Use coordinate geometry to enter accurate geometry when creating objects and find out accurate geometry
for existing objects.
Use the transparent commands to create objects using accurate geometry. For example, you can create parcel
boundaries from legal documents or survey data. The COGO input commands expand the normal object
creation commands by letting you use coordinate geometry to specify the points for the object.
Use the inquiry commands to get accurate geometric information about objects in your drawing. For example,
you can determine the coordinates of a manhole or the centerline of a new road.

Using Coordinate Geometry to Specify Points
Use the transparent input commands to create objects using accurate geometry. For example, you can create
parcel boundaries from legal documents or survey data. For more information, see Transparent Commands
(page 1767).

Measuring Coordinate Geometry
Use the COGO inquiry commands to extract geometric information from objects such as lines, curves, closed
polylines, and polygons. This information is useful if you want to verify the accuracy of your data.
NOTE The COGO inquiry commands use the World Coordinate System (WCS) and ignore current User Coordinate
System (UCS) settings. Therefore, north is always considered to point along the WCS positive Y axis, and inquiry
results are reported in WCS coordinates.

Adding Distances
You can calculate the total of several disjunct distances on your drawing.
Specify the distance by selecting points in your drawing, enter distances on the command line, or select
numeric text, such as measurements, in your drawing.
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Select all the distances you want to add. When you press Enter, AutoCAD Civil 3D displays the total of all
the distances.
To add distances
1 Click Analyze tab ➤ Inquiry panel ➤ Add Distances

.

2 Specify the first distance by doing one of the following:
■

Enter the distance on the command line.

■

Select two locations in the drawing.

■

Enter s. Select numeric text in the drawing, such as a measurement.

3 Enter as many additional distances as you want.
4 When you finish selecting distances, press Enter to view the total of the distances.

Quick Reference
Ribbon
Analyze tab ➤ Inquiry panel ➤ Add Distances
Menu
Inquiry menu ➤ Add Distances
Command Line
CgADist

Displaying Continuous Distance
You can add and display the distance between one point and a number of other points, or between a series
of points.
The Base option measures the distance from the starting point to each of the points you select.
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The Continuous option measures the distance from the starting point to the next point in a continuous
line.

TIP To add distances that are not continuous, see Adding Distances (page 1791).
To display the distance between points
1 Click Analyze tab ➤ Inquiry panel ➤ Continuous Distance

.

2 Select Base or Continuous.
■

Base: Always measures the distance from the first point you select to each of the additional points
you select.

■

Continuous: Measures the distance from one point to the next.

3 Select two points to display the distance between the points.
4 Select another point. If you selected Base, AutoCAD Civil 3D displays the distance from first (or base)
point to the new point. If you selected Continuous, AutoCAD Civil 3D displays the distance from the
last point to the new point.
5 When you finish selecting points, press Enter to view the total of the distances.

Quick Reference
Ribbon
Analyze tab ➤ Inquiry panel ➤ Continuous Distance
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Menu
Inquiry menu ➤ Continuous Distance
Command Line
CgCDist

Displaying Angle Information
You can display the acute and obtuse angle between points or intersecting lines.
This command uses the Angle settings as specified on the Ambient tab (page 84) in the Drawing Settings
dialog box.
To display angle information
1 Click Analyze tab ➤ Inquiry panel ➤ Angle Information

.

2 Select two lines, or enter p to specify points.
3 If you entered p, specify a starting point, a vertex, and an ending point.

Quick Reference
Ribbon
Analyze tab ➤ Inquiry panel ➤ Angle Information
Menu
Inquiry menu ➤ Angle Information
Command Line
CgAng

Displaying COGO Information for Lines and Arcs
You can display coordinate geometry for lines and arcs. This information includes line and curve details,
area, and coordinates.
This command uses the Angle, Distance, and Direction settings as specified on the Ambient tab (page 84)
in the Drawing Settings dialog box.
To display COGO information
1 Click Analyze tab ➤ Inquiry panel ➤ Line And Arc Information

.

2 Select the line or arc, or enter p to specify the points for a line.
3 If you entered p, specify a starting point and an ending point for the line.

Quick Reference
Ribbon
Analyze tab ➤ Inquiry panel ➤ Line And Arc Information
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Menu
Inquiry menu ➤ Line And Arc Information
Command Line
CgList

Listing the Slope or Grade between Points
You can display the slope, grade, and horizontal distance between two points.
This command uses the Elevation, Distance, and Grade/Slope settings as specified on the Ambient tab (page
84) in the Drawing Settings dialog box.
To display the slope between two points
1 Click Analyze tab ➤ Inquiry panel ➤ List Slope

.

2 Select a line or an arc, or enter p to specify points.
3 If you entered p, specify a starting point and an ending point for the line.

Quick Reference
Ribbon
Analyze tab ➤ Inquiry panel ➤ List Slope
Menu
Inquiry menu ➤ List Slope
Command Line
CgSList

Mapcheck Analysis
Perform a Mapcheck Analysis by selecting AutoCAD Civil 3D line and curve labels to determine values from
label objects based on the precision of the annotation of the label object, or enter mapcheck data manually.
A mapcheck analysis is typically performed for each labeled polygon that represents a parcel, a labeled parcel
object, or survey figure to ensure that errors and omissions are minimized. If error is introduced and
accumulated, the coordinates of the last segment endpoint will not equal that of the point of beginning
(POB) which creates the 'error of closure'.
The report is computed based on the start and end coordinates of each parcel segment, relative to the
coordinates of the POB and the previous segment.
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In the Survey Command Window you have the option to list mapcheck information that computes the
error of closure for a figure based on the precision settings for direction and distance values which you
specify in the Survey Database settings (page 2698) For more information, see Listing Mapcheck Information
for a Figure (page 384).
In the Parcel Properties you can specify Inverse Analysis and Mapcheck Analysis. For more information, see
Exporting a Parcel Inverse or Mapcheck Report (page 897).

Performing a Mapcheck Analysis
Use the Mapcheck Analysis command to perform a mapcheck that is based on the precision of the annotation
of the label object.
The Mapcheck Analysis command computes mapcheck calculations directly from the selected labels. To
perform a mapcheck you must specify a point of beginning (POB) for each parcel. For each segment within
the parcel, you select a label containing a direction, direction and distance, distance label, or curve label
until the requirements to compute the next vertex of the current segment are met.
As you perform a mapcheck, temporary graphics are displayed in the drawing to indicate the sides that have
been entered for each parcel. The current side is displayed in bold indicating origin and direction for that
side. The temporary graphics also provide a visual confirmation of possible errors, or indicate that the
direction of a line or curve needs to be flipped or reversed.
NOTE The mapcheck report data is stored in the drawing database so you can continue a mapcheck from a
previous AutoCAD Civil 3D session. The Mapcheck Analysis window must be open to enable the display of the
temporary graphics.
From the POB, the annotation for each side in the parcel is used to calculate the coordinates of the endpoint
of the side. As you enter data for each parcel, the Output View in the Mapcheck Analysis window updates
to indicate error of closure and area based on the previously entered sides. Entering the information for the
last side closes to the POB. The Mapcheck Analysis output view contains the following information:
■

POB coordinates

■

A sequential list of each course, direction and distance, or curve data, and end point coordinates

■

An error of closure summary: Error of closure: 1 part in <X parts>

■

Error of closure direction: <bearing or azimuth>

■

Error of closure distance: <distance>

■

Perimeter distance: <total distance around the parcel>

■

Area: <area units (acres/hectares, and square feet/meters>
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For each parcel or survey figure, the area annotation is compared to the mapcheck area. If the error of closure
is acceptable, for example a closure that exceeds one part in 10,000 parts and the area annotation matches,
the annotations are considered to be mathematically correct.
Tutorial Exercise: Performing a Map Check Analysis with Parcel Labels
To perform mapcheck analysis from AutoCAD Civil 3D label objects
1 Click Analyze tab ➤ Ground Data panel ➤ Survey drop-down ➤ Mapcheck
2 In the Mapcheck Analysis window, click

.

New Mapcheck Report.

3 Enter a name for the Mapcheck, for example LOT 1.
4 Click

to Use Command Line Interface and follow the prompts at the command line.

5 Specify a Point of Beginning. The interactive graphics display the POB in the drawing.
NOTE Colors displayed in the temporary graphics are controlled by the Mapcheck command settings. For
more information, see Mapcheck Command Default Settings (page 1803).
The following illustration shows the Point of Beginning:

6 At the command line you are prompted to select a label. After selecting a label, the interactive graphics
display in the drawing. If you need to make a change, at the command line you have options to do the
following:
■

Clear: Clears the current side.

■

New: Starts a new mapcheck report.

■

Flip: Changes the direction of the curve to either clockwise or counter-clockwise.

■

Reverse: Changes the direction of the line or curve.

NOTE If the mapcheck requires more information to make the calculation, a red circle displays in the drawing
and you are prompted at the command line.
The following illustration shows how the Reverse command can be used to change the direction of the
mapcheck line:
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The following illustration shows an example of using the Flip command:
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7 Continue to follow the command line prompts by selecting labels until you return to the Point of
Beginning.
The following illustration shows the continuation of the mapcheck towards the POB:
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8 Click
New Mapcheck to add a new mapcheck to the existing Mapcheck Report. Repeat steps 5
through 7.
9 Click

Output View to review the mapcheck analysis report. Click

to return to the input window.

10 Optionally, in either the Input View or the Output View, click
Insert Mtext to insert either the
current mapcheck or all mapchecks into the drawing. Specify an insertion point in the drawing and
insert the Mapcheck Report.

Quick Reference
Ribbon
Analyze tab ➤ Ground Data panel ➤ Survey drop-down ➤ Mapcheck
Menu
General menu ➤ Mapcheck Analysis
Command Line
Mapcheck
Dialog box
Mapcheck Analysis Window (page 2745)

Manually Entering Mapcheck Data
Create a mapcheck report by manually entering data.
You can enter data from a paper drawing into the Mapcheck Analysis window to create a mapcheck report.
For each mapcheck, you can create a polyline which can then be used to create AutoCAD Civil 3D objects
such as a survey figure.
Tutorial Exercise: Performing a Map Check Analysis by Manually Entering Data
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To create a mapcheck report by manually entering data
NOTE To manually enter mapcheck data, ensure that the

Use Command Line Interface is toggled off.

1 Click Analyze tab ➤ Ground Data panel ➤ Survey drop-down ➤ Mapcheck
2 In the Mapcheck Analysis window, click

.

New Mapcheck Report.

3 Enter a name for the Mapcheck, for example LOT 1.
4 Enter the Easting and Northing values for the Point of Beginning or click
drawing.
5 Click

and select a point in the

to create a New Side. Specify the values for the side.

For a line side, enter the following:
■

Side Type: Select Line from the drop-down list.

■

Angle Type: Select Direction, Angle, or Deflection Angle from the drop-down list.

■

Angle: Enter the angle value.

■

Reverse Direction: Specify Yes or No.

■

Distance: Enter the distance value.

For a curve side, enter the following:
■

Side Type: Select Curve from the drop-down list.

■

Curve Direction: Select Clockwise or Counter-clockwise from the drop-down list.

■

Traverse Method: Select Across Chord or Through Radius from the drop-down list.
NOTE This option is used to specify how the error of closure is calculated and displayed in the Output
View. If you select Across Chord, the endpoint of the curve is calculated from the Chord direction and
distance. If you select Through Radius, the endpoint of the curve is calculated based on the direction to
the radius point, the radius length, the delta angle, and the direction from the radius point to the point
of tangency. If this option is selected, additional information is displayed in the Output View.

■

Radius: Specify the radius value.

■

Arc Length: Specify the arc length.

■

Delta Angle: Specify the delta angle.

■

Tangent: Specify a tangent.

■

Angle Type: Select Direction, Angle, or Deflection Angle from the drop-down list.

■

Chord Angle: Specify a chord angle.

■

Reverse Direction: Specify Yes or No.

■

Chord Distance: Specify the chord distance.

6 Click
Insert Side Before, or
Insert Side After, if you have omitted a side before or after the current
selected side in the mapcheck. Specify values as shown in the previous step.
7 Click

New Mapcheck to add a new mapcheck to the mapcheck report. Repeat steps 3 through 6.
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8 When you have completed entering data, click

Output View to view the mapcheck analysis. Click

Input View to return to the input window.
NOTE You can switch between input and output views at any time.
9 Optionally, click
Create Polyline to create a polyline for the current mapcheck. The polylines can
be converted to AutoCAD Civil 3D objects.
NOTE If there is no current mapcheck then a polyline for all mapchecks are inserted into the drawing. Press
ESC to clear a selection in tree view.
10 Optionally, click
Copy To Clipboard to copy the contents of the input view or output view to the
Windows Clipboard of the current mapcheck.
NOTE If there is no current mapcheck then all mapchecks are copied to the clipboard. Press ESC to clear a
selection in tree view.
11 Optionally, in either the Input View or the Output View, click
point in the drawing and insert the mapcheck analysis report.

Insert Mtext. Specify an insertion

Quick Reference
Ribbon
Analyze tab ➤ Ground Data panel ➤ Survey drop-down ➤ Mapcheck
Menu
General menu ➤ Mapcheck Analysis
Command Line
Mapcheck
Dialog box
Mapcheck Analysis Window (page 2745)

Adjusting a Mapcheck Analysis
After creating a mapcheck report by manually entering data and determining that there is a reasonable error
of closure, you can adjust the mapcheck to distribute the total error among the sides to precisely match the
point of beginning and endpoint coordinates.
To adjust a Mapcheck
1 In the Mapcheck Analysis window, right-click a Mapcheck Report ➤ Adjust Mapcheck.
2 In the Mapcheck Analysis dialog box, specify the Horizontal Adjustment Method, Horizontal Closure
Limit, and Angle Error Per Set. For more information, see Adjust Mapcheck Analysis Dialog Box (page
2748).
3 Specify Yes to update the mapcheck. The
icon is displayed next to the mapcheck name indicating
the mapcheck has been adjusted. To clear the adjustment, right-click the Mapcheck ➤ Clear Adjustment.
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Quick Reference
Mapcheck Analysis Window
Input View ➤ right-click Mapcheck ➤ Adjust Mapcheck
Dialog Box
Adjust Mapcheck Analysis Dialog Box (page 2748)

Inserting a Mapcheck Report as Mtext
You can insert a Mapcheck report as an Mtext object in the drawing.
Tutorial Exercise: Working with Mapcheck Data
To insert a Mapcheck Report into the drawing
1 Click Analyze tab ➤ Ground Data panel ➤ Survey drop-down ➤ Mapcheck

.

2 In either the Input View or the Output View of the Mapcheck Analysis window, click

Insert Mtext.

Quick Reference
Ribbon
Analyze tab ➤ Ground Data panel ➤ Survey drop-down ➤ Mapcheck
Menu
General menu ➤ Mapcheck Analysis
Command Line
Mapcheck
Dialog box
Mapcheck Analysis Window (page 2745)

Mapcheck Command Default Settings
Change the Mapcheck default command settings in the General collection on the Settings tab in Toolspace
To change Mapcheck command settings
1 On the Settings tab in Toolspace, click General ➤ Commands ➤ MapCheck.
2 In the Edit Command Settings-MapCheck dialog box, expand the Mapcheck group and specify values
for the mapcheck properties.

Quick Reference
Toolspace
Settings tab ➤ General collection ➤ Commands ➤ MapCheck
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Attaching Notes
With the Notes command, you can add either detailed or reference information to a selected object.
Use the Notes command to write textual information that can be viewed with the object and associate a
separate reference file (document, spreadsheet, image or photo, and so on).
View the notes and documents later by using the Extended Data tab of the AutoCAD Properties Palette.

Attaching Text to an Object
You can attach a text file to any AutoCAD object.
To add text notes to a drawing
1 At the Command prompt, enter Notes.
2 In the drawing, select an object on which you want to place a note.
3 Press Enter.
The Notes dialog box is displayed.
4 Click the Notes tab.
5 In the text box, enter the desired text.
6 Click OK to attach the text file to your drawing.

Quick Reference
Ribbon
Not available on the ribbon
Menu
General menu ➤ Utilities ➤ Notes
Dialog Box
Notes (page 2749)
Command Line
Notes

Attaching External Reference Documents to an Object
Attach, edit, and delete external reference documents to any AutoCAD object in a drawing.
To attach, edit, or delete an external reference document
1 At the Command prompt, enter Notes.
2 In the drawing, select an object on which you want to attach an external reference document.
3 Press Enter.
The Notes dialog box is displayed.
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4 To attach, edit, or detach a reference file, click the Reference Docs tab, and do any of the following:
■

To attach a reference file: Click Add, select a document in the Select Reference Document dialog
box, and click Open. You can type a description of the reference file on the Reference Docs tab.

■

To edit a reference file: Select the file name in the list, click Edit, and change the document or the
description in the Reference Document dialog box. To edit the file itself, double-click the reference
file name to start its application.

■

To detach a reference file: Select the file name in the list and click Delete.

5 Click OK.

Quick Reference
Ribbon
Not available on the ribbon
Menu
General menu ➤ Utilities ➤ Notes
Dialog Box
Notes (page 2749)
Command Line
Notes

Using the Object Viewer
The Object Viewer displays objects you select in your drawing, based on the current view that is set in the
drawing.
Civil objects are displayed in the Object Viewer using the Plan or Model settings specified in their styles.
For example, in a 3D view, objects are displayed using their Model settings.
You can manipulate the viewing angle and then set the drawing view equal to the view in the Object Viewer
by clicking

.

The Object Viewer contains the ViewCube and the SteeringWheel. For more information, see Use ViewCube
and Navigation Wheels in the AutoCAD Help.
To display objects from your drawing in the Object Viewer
1 Click View tab ➤ Palettes panel ➤ Object Viewer

.

2 Select the objects you want to view.
3 Press Enter.
The Object Viewer is displayed.
4 From the View Control list at the upper right of the Object Viewer, select any of the following.
■

Top, Bottom, Left, Right, Front, or Back: Sets the current view to the selected view.

■

SW Isometric, SE Isometric, NE Isometric, or NW Isometric: Sets the current view to the selected
isometric view.
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5 From the Visual Style list, select one of the following object appearance styles.
■

3D Hidden To display objects in the current view in a 3D wireframe representation with all visible
lines displayed as continuous and all hidden lines displayed as dashed.

■

3D Wireframe To display objects in the current view in a 3D wireframe representation with all lines
displayed, including those objects hidden by other objects.

■

Conceptual To display objects in a transparently shaded 3D view with all lines visible.

■

Realistic To display objects in a shaded 3D view.

6 Choose from the following zoom options from the Object Viewer to increase or decrease the apparent
size of objects in the current viewport:

7 Click

to set the view in the drawing to match the current view in the Object Viewer.

NOTE AutoCAD Civil 3D supports only the Standard Display Configuration.

Quick Reference
Ribbon
View tab ➤ Palettes panel ➤ Object Viewer
Menu
General menu ➤ Utilities ➤ Object Viewer
Command Line
ObjectViewer
Dialog Box
Object Viewer (page 2750)

Performing Inquiries on AutoCAD Civil 3D Objects
Use the Inquiry Tool or distance checks to analyze drawing data.

Using the Inquiry Tool
Use the Inquiry Tool to run inquiries on AutoCAD Civil 3D objects. You can extract information from the
design model to aid in design, validation, and analysis. See Inquiry Types (page 1808) for a list of available
inquiries.
The Inquiry Tool is in a window you can keep open on screen while you do other work. Like the Toolspace,
you can dock the window or turn on the AutoHide feature so it displays only when you move your mouse
over it to save desktop space.
The Inquiry Tool consolidates and replaces some of the listing and inquiry commands that were in previous
releases of AutoCAD Civil 3D.
For more information, see Inquiry Tool Dialog Box (page 2760).
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Performing an Inquiry
Use the Inquiry Tool to run a selected inquiry on drawing objects.
Choose an inquiry type and follow prompts to select the data. After the inquiry completes, you can copy
the data to another file such as a Microsoft© Excel spreadsheet.
There are two ways to select the data for an inquiry. When you first select the inquiry to run, you are
prompted to select the data required for the inquiry. If there is only one object of that type in the drawing,
it is selected automatically. After the inquiry is complete, you can use the object select buttons. Click
or

in the Inquiry Tool window to change the selection of data.

You can also run an inquiry by selecting an object in the drawing and accessing the Inquiry command from
the contextual ribbon or from the shortcut menu. The most recently-run inquiry type for the selected object
is selected automatically.
When you select the Inquiry command from the contextual ribbon or shortcut menu, you are not prompted
for the main object, but you are prompted for any additional object input the inquiry requires.
To perform an inquiry
1 Click Analyze tab ➤ Inquiry panel ➤ Inquiry Tool

.

Or select an object first, and then click General Tools panel ➤ Inquiry

on the contextual ribbon tab.

When you select the Inquiry command from the contextual ribbon, the most recently-run inquiry type
for the selected object is selected automatically.
2 In the Inquiry Tool window, under Select An Inquiry Type, click the Down arrow and select the inquiry
to run.
After you select an inquiry type, you are prompted to select the objects that are required for the inquiry.
NOTE To run Corridor queries, a corridor section view must be active. Select a corridor. Click Corridor tab
➤ Modify panel ➤ Corridor Section Editor
to zoom closer to the view.

. Then select the station to query. Use the Zoom command

3 Select the objects and locations for the inquiry. You can use Osnaps and transparent commands to
select the objects.
The data is displayed in the Inquiry Tool window.
4 To change selected objects or locations, click
or
and select the new object or location in the drawing.

in the Inquiry Tool window next to a value

Quick Reference
Ribbon
Analyze tab ➤ Inquiry panel ➤ Inquiry Tool
Menu
General menu ➤ Inquiry Tool
Object Shortcut Menu
Right-click object ➤ Inquiry. The most recently used inquiry type for the selected object runs automatically.
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Command Line
ShowInquiry
RunInquiry
HideInquiry
DockInquiry
FloatInquiry

Copying Inquiry Data
After you run an inquiry, you can copy the data to the clipboard, or you can send the inquiry data to the
AutoCAD text window and copy the data from there.
The option to copy the inquiry to the AutoCAD text window continually sends the data to the text window
as the inquiry proceeds.
To copy inquiry data to the clipboard
➤

Right-click in the Inquiry Tool results area and click Copy To Clipboard. Or click

.

To copy an individual value to the clipboard
1 Right-click the value in the Inquiry Tool.
2 Click Copy Value To Clipboard.
To send a running copy of inquiry data to the AutoCAD text window
1 Click

Copy To Text Screen.

As you run the inquiry, the data is sent to the text window.
2 Press F2 to expand the text window and view the data.

Quick Reference
Ribbon
Analyze tab ➤ Inquiry panel ➤ Inquiry Tool
Menu
General menu ➤ Inquiry Tool
Command Line
ShowInquiry

Inquiry Types
You can run inquiries on points, surfaces, alignments, profiles, profile views, sections, section views, and
corridor sections.
Inquiry Type

Inquiry Input

Inquiry Results

Point Inverse

■

■

Direction

■

Horizontal Distance
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Two points

Inquiry Type

Surface Elevation and Grade
At Point

Surface Elevation and Grade
Between Points

Inquiry Input

Inquiry Results
■

Grid Direction

■

Grid Distance

■

Geodetic Direction (Forward)

■

Geodetic Direction (Reverse)

■

Geodetic Distance

■

Surface

■

Surface elevation at point

■

Point on surface

■

Grade (percentage)

■

Slope

■

Grade (degree)

■

Slope direction

■

Surface

■

Surface elevation at each point

■

Two points on surface

■

Elevation difference between
points

■

Distance between points

■

Grade (percentage)

■

Slope

■

Grade (degree)

■

Slope direction

Alignment Station and Offset
at Point

■

Alignment

■

Station at point

■

Offset point

■

Offset at point

Alignment Station, Offset,
and Profile Elevation at Point

■

Alignment

■

Station at point

■

Profile

■

Offset at point

■

Horizontal offset point

■

Profile elevation at alignment
station

NOTE This command lists
the elevation not at the
offset point, but on the
alignment. Use the following query to list the elevation at the selected offset
point.

Alignment Station, Offset,
and Surface Elevation at
Point

■

Alignment

■

Station at point

■

Surface

■

Offset at point

■

Horizontal offset point

■

Surface elevation at point
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Inquiry Type

Inquiry Input

Inquiry Results

Alignment Two Stations and
Offsets at Point

■

Two alignments

■

■

Offset point

Stations and offsets (in relation
to both alignments)

Profile View Station and Elevation at Point

■

Profile View

■

Station at point

■

Point on profile view

■

Elevation at point

Profile View Elevation and
Grade Between Points

■

Profile View

■

■

Two points on profile view

Elevation difference between
points

■

Distance between points

■

Grade (percentage)

■

Slope

■

Grade (degree)

Profile Station and Elevation
at Point

■

Profile

■

Station at point

■

Point on profile

■

Elevation at point

Profile Elevation Difference
at Station

■

Profile view

■

Station at point

■

Two profiles

■

■

Point on profile view

Elevation difference between
profiles at point

■

Section view

■

Station at point

■

Point on section view

■

Horizontal offset at point

■

Elevation at point

Section View Offset and Elevation at Point

Section View Elevation and
Grade Between Points

■

Section view

■

Station of selected section view

■

Two points on section
view

■

Elevation difference between
points

■

Distance between points

■

Grade (percentage)

■

Slope

■

Grade (degree)

Section Offset and Elevation
at Point

■

Section

■

Offset at selected point

■

Point on section

■

Elevation of section at offset
point

Section Difference at Offset

■

Section View

■

Offset at selected point

■

Two sections

■

■

Offset point

Elevation difference between
the sections at offset point
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Inquiry Type

Inquiry Input

Inquiry Results

TIP To select a section, zoom into a section view and click the section object inside the view. If you
sampled multiple surfaces and you have trouble selecting the correct section surface, edit the section
view properties (Sections Tab (Section View Properties Dialog Box) (page 2544)) and turn off the display
of the sections you do not want to select.
Corridor Section Offset and
Elevation at Point

Corridor Section Elevation
and Grade Between Points

■

■

Offset/Elevation point

■

Prerequisite: Run
View/Edit Corridor Sections Command and select
station

■

Corridor Section Elevation
Difference at Offset

Prerequisite: Run
View/Edit Corridor Sections Command and select
station

■

Two Offset/Elevation
points

Prerequisite: Run
View/Edit Corridor Sections Command and select
station

■

Two corridor surfaces

■

Offset/Elevation point

■

Offset at selected point

■

Elevation at selected point

■

Elevation difference between
points

■

Distance between points

■

Grade (percentage)

■

Slope

■

Grade (degree)

■

Offset at selected point

■

Elevation difference between
corridor surfaces at selected
point

Identifying the Shortest Distance Between Two Entities
Use the Minimum Distance Between Entities command to list the shortest distance between two entities
and to optionally draw a persistent line to identify the location of this distance.
This command can help you design for a minimum distance between an alignment centerline and the
right-of-way, for example. The blue lines in the following illustration show the minimum distance found.

This command calculates the 2D distance between entities. Elevations are not considered in the calculations.
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If the selected entities cross or are collinear, the distance is displayed as zero. If the selected entities are
parallel, the first “shortest distance” point is identified, which is the point nearest the start points of both
entities, as shown in the following illustration.
Minimum distance line inserted between parallel
lines

This command can be used with the following types of entities:
■

Point (COGO, Survey, or AutoCAD)

■

Line

■

Arc

■

Circle

■

Polyline (lightweight, 2D, or 3D)

■

Feature line (can be embedded in a corridor)

■

Survey figure

■

Alignment

■

Parcel segment

To identify the shortest distance between entities
1 Click Analyze tab ➤ Inquiry panel

Minimum Distance Between Entities

.

2 Select the first entity in the drawing, and then select the second entity.
The minimum distance is displayed at the command line, along with the X,Y locations on the two
entities where this minimum distance was calculated.
The following prompt is displayed: Draw shortest distance line? [Yes/No] <Yes>:
3 Enter Yes to draw a line to mark this location, using the current layer and linetype. The line is persistent
and remains in the drawing after you save it.

Quick Reference
Ribbon
Analyze tab ➤ Inquiry panel

Minimum Distance Between Entities

Command Line
MinDistBetweenEntities

Identifying the Vertical Distance Between Two Entities
Use the Vertical Distance Between Entities command to list the vertical distance between two entities and
to optionally draw a persistent marker to identify the location of this distance.
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This command can help you calculate the distance between design profiles where the alignments cross,
which helps you determine whether a minimum clearance is maintained.
This command can be used with the following types of entities:
■

Line

■

Arc

■

Circle

■

Polyline (2D with elevation, or 3D)

■

Feature line (can be embedded in a corridor)

■

Survey figure

■

Profile

To identify the vertical distance between entities
1 Click Analyze tab ➤ Inquiry panel

Minimum Vertical Distance Between Entities

.

2 Select the first entity in the drawing, and then select the second entity.
NOTE If you select an alignment, press Enter to specify the appropriate profile.
The following information is displayed on the command line:
■

vertical distance between the entities

■

elevation of the first entity

■

elevation of the second entity

■

X,Y locations on the two entities where the distance was calculated

3 Enter Yes to draw a marker at the location at which the entities cross in plan, using the current layer
and linetype. The marker is persistent and remains in the drawing after you save it.

Quick Reference
Ribbon
Analyze tab ➤ Inquiry panel

Minimum Vertical Distance Between Entities

Command Line
VertDistBetweenEntities

The Coordinate Tracker
You can use the Coordinate Tracker to view and capture X, Y, and Z drawing coordinates.
The Coordinate Tracker displays the X and Y coordinates of the cursor in the drawing. If the cursor is within
the boundary of a specified surface, the surface elevation at the location of the cursor is displayed as the Z
coordinate.
You can send the coordinate information to the command line for use in the active command, or you can
copy the information for use in another application.
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Because the Coordinate Tracker is an AutoCAD palette, you can use Auto-hide to minimize the display space
it requires. You can also dock, move, and resize it. For more information about Auto-hide and AutoCAD
palettes, see Working with AutoCAD Civil 3D Windows (page 94).

Viewing Cursor Coordinates Using the Coordinate Tracker
Use the Coordinate Tracker to view the drawing X and Y coordinates of the cursor and a Z coordinate value
read from a specified surface.
To view cursor coordinates using the Coordinate Tracker
1 Click View tab ➤ Palettes panel ➤ Coordinate Tracker

.

2 In the Coordinate Tracker (page 2760), in the Surface list, select the surface from which Z values (elevations)
are read.
If the drawing contains only one surface, it is automatically selected.
3 Move the cursor within the boundary of the selected surface.
The drawing X and Y coordinates are updated from the cursor position within the drawing. The Z
coordinate value is read from the specified surface when the cursor is within the surface boundary. If
you move the cursor outside of the surface boundary, the Z value is not shown.
4 To suspend cursor tracking and capture the current X, Y, and Z coordinate values, do the following:
■

Enter the keys listed in the Coordinate Capture Keys edit box by pressing, and not releasing, each
key in the specified order until you are holding all the specified keys down.

■

Release all keys.

Coordinate tracking is suspended and the current X, Y, and Z coordinates are captured.
5 Optionally, send the X, Y, and Z coordinates to the command line for use in the current command.
You can edit the values before you send them. For more information, see Sending Coordinate Tracker
Values to the Current Command (page 1815).
6 To resume cursor tracking, click

.

7 To hide the Coordinate Tracker, click

.

Quick Reference
Ribbon
View tab ➤ Palettes panel ➤ Coordinate Tracker
Menu
General menu ➤ Coordinate Tracker
Command Line
ShowCT
HideCT
DockCT
FloatCT
Dialog Box
Coordinate Tracker (page 2760)
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Sending Coordinate Tracker Values to the Current Command
Use the Coordinate Tracker to capture and send drawing X, Y, and Z coordinate values to the current
command.
You can send any of the following:
■

X and Y values only

■

Z (elevation) value only

■

X, Y, and Z values

Send the value required by the current command. If the current command requires a 3D (X, Y, and Z) value,
an error occurs if you send a 2D (X and Y only) value.
Send a value by first moving the cursor to the desired location and entering the coordinate capture keys.
This suspends tracking and captures the X, Y, and Z values. You can edit one or more of the values before
you send them.
You send the values to the command line using the buttons directly beneath the X, Y, and Z values. The
buttons are shown in the following illustration:

TIP Move the cursor over each button to view a tooltip that tells you what value the button sends to the command
line.
To send Coordinate Tracker values to the current command
1 Display the Coordinate Tracker. Select a surface if required. For more information, see Viewing Cursor
Coordinates Using the Coordinate Tracker (page 1814).
2 Run any command until you are prompted at the command line for a 2D point, a 3D point, or an
elevation.
3 Move the cursor until the Coordinate Tracker displays the desired coordinate and elevation values.
4 To suspend cursor tracking and capture the current X, Y, and Z coordinate values, do the following:
■

Enter the keys listed in the Coordinate Capture Keys edit box by pressing, and not releasing, each
key in the specified order until you are holding all the specified keys down.

■

Release all keys.

Coordinate tracking is suspended and the current X, Y, and Z coordinates are captured.
5 Optionally, edit the coordinate information before sending it. In the Coordinate Tracker (page 2760),
click in either the X:, Y:, or Z: edit box and enter a new value.
TIP Move the cursor over each button to view a tooltip that tells you what value the button sends to the
command line.
6 Do one of the following:
■

To send the X and Y values, click

■

To send the Z value only, click

■

To send X, Y, and Z values, click

.
.
.
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7 After you send a value, cursor tracking is automatically resumed. To resume cursor tracking without
sending a value, click

.

Quick Reference
Ribbon
View tab ➤ Palettes panel ➤ Coordinate Tracker
Menu
General menu ➤ Coordinate Tracker
Command Line
ShowCT
Dialog Box
Coordinate Tracker (page 2760)

Changing the Coordinate Tracker Coordinate Capture Keys
Change the capture key sequence that suspends coordinate tracking and captures the current X, Y, and Z
values.
The coordinate capture keys are the keys you press to capture the current X, Y, and Z drawing coordinates.
Then you can either send the values to the command line or copy them for use in another application. For
more information, see Sending Coordinate Tracker Values to the Current Command (page 1815).
The capture key sequence always consists of any combination of Ctrl, followed by Alt and/or Shift, followed
by a single character key. The following are examples of valid capture key combinations:
■

Ctrl+Shift+Z

■

Ctrl+Alt+Z

■

Ctrl+Shift+Alt+Z

The default coordinate capture key sequence is Ctrl+Shift+Z.
You change the coordinate capture keys by clicking

and entering the new key sequence.

To change the Coordinate Tracker coordinate capture keys
1 Click View tab ➤ Palettes panel ➤ Coordinate Tracker.
2 In the Coordinate Tracker (page 2760), click

.

3 Press and hold down Ctrl.
4 While holding down Ctrl, press and hold down Alt and/or Shift.
5 While holding down the other keys, press and hold down a single character key.
6 Release all keys.
The Coordinate Capture Keys edit box displays the sequence of keys that you entered. If the Coordinate
Capture Keys edit box is not updated, the sequence of keys that you entered is not valid. This can occur
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if the sequence does not begin with Ctrl followed by either Shift or Alt, or if the sequence is reserved
for another function on your computer.

Quick Reference
Ribbon
View tab ➤ Palettes panel ➤ Coordinate Tracker
Menu
General menu ➤ Coordinate Tracker
Command Line
ShowCT
Dialog Box
Coordinate Tracker (page 2760)

The Event Viewer Vista
You can use the AutoCAD Civil 3D Event Viewer to view event messages that are logged during an AutoCAD
Civil 3D drawing session.
The display of the Event Viewer can be controlled by changing the Show Event Viewer setting in the drawing’s
Ambient Settings (page 2078).
The Event Viewer is a Panorama vista. Each drawing can have a different Event Viewer session associated
with it. When you change the active drawing, the Event Viewer session changes. If you do not activate the
Event Viewer for a drawing, the Event Viewer is not displayed when that drawing becomes active. For
information about Panorama vistas, see The Panorama Window (page 119).
The Event Viewer displays the event tree in the left pane and the event list in the right pane.
You use the event tree to control the events that are listed in the event list. For example, if you click the top
collection in the tree, Event Viewer, all events are listed in the event list. If you expand the event tree and
click either the Event Subsystem collection or Surfaces collection, only the events that were logged by either
the Event Subsystem (which is the Event Viewer) or the Surfaces feature are listed in the event list.
When you first open the Event Viewer, the event list is empty if no events have been logged to the Event
Viewer. When an event is logged to the Event Viewer, the appropriate collection is created, and the event
is added to the event list.
You can save the event list to a log file as a permanent record, and open a previously created log file to view
it in the Event Viewer. You can also export an event list to a comma-delimited or tab-delimited text file.

Customizing the Event Viewer
You can control the content and appearance of the Event Viewer, including the columns displayed in the
event list and the events listed there.

Controlling the Columns Displayed in the Event Viewer
Control the columns that are displayed in the event list and the order in which they are displayed.
Columns that you can add or remove include Date, Time, Source, User, and Description.

The Event Viewer Vista | 1817

You cannot remove the Type column from the display.
To control the columns displayed in the Event Viewer
1 Click View tab ➤ Palettes panel

Event Viewer

.

2 To change the location of a column in the event list, in the Event Viewer Vista (page 2753), click and drag
the heading right or left.
3 To add columns or remove columns, do the following:
■

In the Event Viewer, on the View menu, click Choose Columns.

■

In the Choose Columns (page 2757) dialog box, specify columns to be added or removed.

Quick Reference
Ribbon
View tab ➤ Palettes panel

Event Viewer

Event Viewer Menu
View ➤ Choose Columns
Dialog Box
Choose Columns (page 2757)

Controlling the Events Displayed in the Event Viewer
Control which events are displayed in the event list and the order in which they are displayed.
When you change the display of the event list by filtering, the events are hidden, but they are not deleted
from the event list. However, when you use the Clear All Events command, the events are permanently
deleted from the list.
For information about changing the columns that are displayed in the event list, see Controlling the Columns
Displayed in the Event Viewer (page 1817).
For information about locating an event that matches specified criteria, see Finding a Specific Event in the
Event Viewer (page 1821).
To control the events displayed in the Event Viewer
1 Click View tab ➤ Palettes panel

Event Viewer

.

2 In the Event Viewer (page 2753), do one of the following in the event tree:
■

Click the Event Viewer collection to display all the events in the event list.

■

Expand the Event Viewer collection and click a collection to display the events in that collection.

3 Click View menu ➤ Filter. Use the Filter Events (page 2755) dialog box to filter the event list to meet
only specified criteria.
4 To display the event list by date, on the View menu, click one of the following:
■

Newest First: Displays the event list with the most recent event at the top.

■

Oldest First: Displays the event list with the least recent event at the top.
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5 To sort the event list using a column heading, click the column heading.
6 Click Action menu ➤ Clear All Events to permanently remove all events from the event list.

Quick Reference
Ribbon
View tab ➤ Palettes panel

Event Viewer

Event Viewer Menu
View ➤ Filter
Action ➤ Clear All Events
Dialog Box
Filter Events (page 2755)

Working With Log Files in the Event Viewer
Open and create log files that contain event lists.
You can save the current event list to a binary log file, and also open an existing log file to view it.
For information about saving an event list to a comma-delimited or tab-delimited text file, see Exporting
an Event List to a Text File (page 1820).

Creating a Log File in the Event Viewer
Use the Save Log File As command to create a log file from the event list.
When you create a log file, all the events in the current event viewer session at the time the file is created
are written to the file. Events that have been logged during the session, but that are not displayed in the
event list due to filtering, are also written to the file. For more information about using filters to limit the
events displayed in the event list, see Controlling the Events Displayed in the Event Viewer (page 1818).
To create a log file in the Event Viewer
1 Click View tab ➤ Palettes panel

Event Viewer

.

2 In the Event Viewer (page 2753), on the Action menu, click Save Log File As.
3 In the Save As dialog box, browse to the folder where you want the log file to be located, enter a file
name, and click Save.
The current event list is saved to the log file.

Quick Reference
Ribbon
View tab ➤ Palettes panel

Event Viewer

Event Viewer Menu
Action ➤ Save Log File As
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Opening a Log File in the Event Viewer
Use the Open Log File command to open an existing Event Viewer log file.
To open a log file in the Event Viewer
1 Click View tab ➤ Palettes panel

Event Viewer

.

2 In the Event Viewer (page 2753), on the Action menu, click Open Log File.
3 In the Open dialog box, browse to the folder that contains the log file, select a file name, and click
Open.
The displayed event list is replaced by the contents of the selected log file.

Quick Reference
Ribbon
View tab ➤ Palettes panel

Event Viewer

Event Viewer Menu
Action ➤ Open Log File

Exporting an Event List to a Text File
Export an Event Viewer event list to a comma-delimited or tab-delimited text file.
When you export an event list to a file, all the events logged during the current session are written to the
file. Events that were logged during the session, but that are not displayed in the event list due to filtering,
are also written to the file. For more information about using filters to limit the events displayed in the event
list, see Controlling the Events Displayed in the Event Viewer (page 1818).
To export an event list to a text file
1 Click View tab ➤ Palettes panel

Event Viewer

.

2 In the Event Viewer (page 2753), on the Action menu, click Export List.
3 In the Save As dialog box, do the following:
■

Browse to the folder where you want to save the exported file.

■

Enter a file name.

■

Specify a file type, which determines the format the text file is saved in.

■

Click Save.

Quick Reference
Ribbon
View tab ➤ Palettes panel
Event Viewer Menu
Action ➤ Export List
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Event Viewer

OR

Finding a Specific Event in the Event Viewer
Search the event list to find events that meet specified criteria.
To find a specific event in the Event Viewer
1 Click View tab ➤ Palettes panel

Event Viewer

.

2 In the Event Viewer (page 2753), click View menu ➤ Find.
3 In the Find Event (page 2756) dialog box, specify the criteria that match the event you are searching for.
4 Click Find Next.
5 To search for the next event that matches the specified criteria, click Find Next again.

Quick Reference
Ribbon
View tab ➤ Palettes panel

Event Viewer

Event Viewer Menu
View ➤ Find
Dialog Box
Find Event (page 2756)

Copying An Event to the Clipboard
Copy a single event from the Event Viewer event list to the Windows clipboard for use in another application.
To copy an event to the clipboard
1 Click View tab ➤ Palettes panel

Event Viewer

.

2 In the Event Viewer (page 2753), select the event from the event list that you want to copy to the clipboard.
3 In the Event Viewer, on the Action menu, click Properties.

4 In the Event Properties (page 2754) dialog box, click

Copy To Clipboard.

The information about the event is copied to the Windows clipboard, and can be pasted into another
application.

Quick Reference
Ribbon
View tab ➤ Palettes panel

Event Viewer
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Event Viewer Menu
Action ➤ Properties
OR

Dialog Box
Event Properties (page 2754)

Multi-View Blocks
A multi-view block is an AutoCAD Civil 3D object that can have different representations in different view
directions. You create a multi-view block from AutoCAD blocks that represent the different views of the
custom object that you are creating.

Understanding Multi-View Blocks
A multi-view block can represent different types of objects in AutoCAD Civil 3D, such as the following:
■

Plantings, such as trees and shrubs

■

Utilities, such as fire hydrants

■

Vehicles

■

Signage

Multi-view blocks can be displayed differently in each view direction and each display representation. For
example, the top view of a multi-view block representing a traffic sign shows the top of the sign. The bottom
view shows the bottom of the sign, and there are representations for left, right, front, and back views.
Additionally, you can define a different group of displays for each display representation. You can have one
set of views for plan view and another one for reflected view.
The top and profile view blocks representing a pine tree might look like:

Predefined Multi-View Blocks
The content folders of AutoCAD Civil 3D contain a large number of predefined multi-view blocks for a
number of design purposes. These contain multi-view blocks of building footprints, landscape symbols,
annotation symbols, site-related symbols, and other useful elements.
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You can access these multi-view blocks from the AutoCAD Civil 3D MV Blocks Tool Palette. You can also
use DesignCenter™ to insert the blocks.
Predefined multi-view blocks are located in the following folder by default:
■

Windows 7 and Windows Vista: \\Program Data\Autodesk\C3D 2011\enu\Data\Symbols\Mvblocks

■

Windows XP: \\Documents and Settings\All Users\Application Data\Autodesk\C3D
2011\enu\data\Symbols\Mvblocks

Creating Multi-View Block Definitions
Each multi-view block in a drawing is based on a multi-view block definition. The multi-view block definition
specifies the display representations in which the block can be viewed, and the views available in each
representation. From a multi-view block definition, you can create as many actual multi-view block references
as you need.
Multi-view blocks typically represent 3D Civil objects. For example, you can create a customized, multi-view
fire hydrant representation by drawing plan, elevation, and model views, and save each view as an individual
AutoCAD block. You assign each block to a view when you create the multi-view block definition. The blocks
(top, bottom, front, back, left, right, and model views) are used to define the custom object as a single
multi-view block. By adding points to your views on the defpoints layer prior to defining the block, you can
identify additional insertion points for the view block. You set the display representations and view directions
when you define the multi-view block.
You can see the individual blocks of your custom object in plan, elevation, and isometric views as one
assembly after inserting them in the drawing as a multi-view block. For more information about working
with blocks, see the online AutoCAD User's Guide.

Process Overview: Creating Multi-View Block Definitions
There are four general steps for creating a multi-view block:
1 Create a set of view blocks for each view direction in each display representation that you need.
2 Create a multi-view block definition where you assign the view blocks to view directions in individual
display representations.
3 If you want the new multi-view block definition to be available in DesignCenter, add the definition to
DesignCenter.
4 If you want the new multi-view block definition to be available from a tool palette, add it to a palette.

Creating View Blocks
Create AutoCAD blocks and use them to represent each view of the multi-view block definition.
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Creating individual blocks for multi-view block definition

To create the AutoCAD blocks used to represent each view of the multi-view block
1 Draw the views you need for a specific display representation:
■

To create views for the front and back directions, draw them on the XZ plane.

■

To create views for the left and right directions, draw them on the YZ plane.

■

To create views for the top and bottom directions, draw them on the XY plane.

2 Specify additional insertion points on the defpoints layer in the AutoCAD point command, if necessary.
NOTE The points added to view blocks are cumulative. For example, if you add one point to a view block
used for the top view and two points to the view block used for the model view, you have a total of four
points to cycle through. The fourth point is the regular basepoint defined during the creation of the block.
3 Make sure the current coordinate system is the world coordinate system before making blocks from
these individual views.
For more information about coordinate systems, see “Use Coordinates and Coordinate Systems” in the
online AutoCAD User's Guide.
4 Define each view as a block, and specify the location of the insertion base point as you define each
block.
For example, if you specify the insertion base point of the model view block as the dead center of the
top side, the front, back, left, and right view blocks will all have an insertion base point at the midpoint
of the bottom edge. In the following illustration, the insertion points for the top, front, and side view
blocks are indicated by an “X”. For more information about blocks, see “Create and Use Blocks” in the
online AutoCAD User's Guide.
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TIP It is helpful to have a naming convention as you save your views as blocks. For example, name the plan view
block hydrant-p, and name the right view block hydrant-r.

Creating a New Multi-View Block Definition
Create a multi-view block definition from existing view blocks created to represent different views of a
custom object.
To create a multi-view block definition
1 Click Insert tab ➤ Block panel

Edit Multi-View Block Definition.

NOTE If there is already a multi-view block in the drawing, press Enter when the prompt Select Multi-View
Blocks is displayed.
2 In the New Multi-View Block Definition dialog box, enter a name for the new multi-view block definition.
Click OK.
3 In the Multi-View Block Definition Properties dialog box, set up the new multi-view block definition:
■

To connect view blocks representing different display representations, see Adding View Blocks to
the Multi-View Block Definition (page 1825).

■

To add notes and files to the multi-view block definition, see Attaching Hyperlinks, Notes, or Files
to a Multi-View Block (page 1832).

4 Click OK.

Quick Reference
Ribbon
Click Insert tab ➤ Block panel

Edit Multi-View Block Definition

Menu
Insert menu ➤ Multi-View Blocks ➤ Definitions
Command Line
MvBlockDefEdit
Dialog Box
Multi-View Block Definition Properties Dialog Box (page 2757)

Adding View Blocks to the Multi-View Block Definition
Add view blocks corresponding to individual display representations.
You can specify different settings for plan and profile views, for example.
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To add view blocks
1 Click Insert tab ➤ Block panel

Edit Multi-View Block Definition.

2 In the Multi-View Block Definition Properties dialog box, select the multi-view block definition from
the Multi-View Block Name list.
3 Under Multi-View Block Components, select the display representation to which you want to connect
view blocks.
There are two display representations available for multi-view blocks:
■

Select 2D for all Plan views.

■

Select 3D for all other views.

4 Click the add button.
5 Use the Select A Block dialog box to select a view block.
6 To specify view blocks in other display representations, repeat steps 4 - 5.
7 Click OK.

Quick Reference
Ribbon
Click Insert tab ➤ Block panel

Edit Multi-View Block Definition

Menu
Insert menu ➤ Multi-View Blocks ➤ Definitions
Command Line
MvBlockDefEdit
Dialog Box
Multi-View Block Definition Properties Dialog Box (page 2757)

Adding a Multi-View Block Definition to DesignCenter
Add a multi-view block to DesignCenter. When you add a multi-view block definition to DesignCenter, you
can create new multi-view blocks by dragging and dropping them from DesignCenter to your drawing. To
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add a multi-view block definition to DesignCenter, you need to first create a DWG file that contains a
multi-view block definition.
NOTE A side effect of this process is that the multi-view block, when inserted using DesignCenter, will be embedded
in an enclosing block reference and must be exploded before it will be recognized by AutoCAD Civil 3D as a
multi-view block object.
To add a multi-view block to DesignCenter
1 Click View tab ➤ Palettes panel ➤ Design Center.
2 In DesignCenter, click the Folders tab.
3 Browse to and select the folder where you would like to place the multi-view block.
4 At the command prompt, enter WBLOCK.
5 In the Write Block dialog box, select the Block option.
6 In the Block list, select the name of the multi-view block definition that you would like to add to the
folder selected in DesignCenter.
7 Under Destination, browse to the folder specified in DesignCenter. Click Save in the Browse For Drawing
File dialog box.
8 Verify the insert units for the multi-view block drawing file.
NOTE When using DesignCenter, the insert units will be used to convert the units assigned to the multi-view
block to the units specified for the active drawing.
9 Click OK in the Write Block dialog box to write the multi-view block to the drawing file.
10 In DesignCenter, press the F5 key to refresh the contents. The multi-view block is placed in the selected
DesignCenter folder.

Inserting Multi-View Blocks into a Drawing
Insert multi-view blocks into a drawing by dragging and dropping them from the AutoCAD Civil 3D MVBlocks Tool Palette, or by referencing their definitions using DesignCenter.
After a multi-view block has been inserted into the drawing, additional references can be added by using
the Insert tab ➤ Block panel

Add Multi-View Block command.

Predefined multi-view blocks are located in the following folder by default:
■

Windows 7 and Windows Vista: \\Program Data\Autodesk\C3D 2011\enu\Data\Symbols\Mvblocks

■

Windows XP: \\Documents and Settings\All Users\Application Data\Autodesk\C3D
2011\enu\data\Symbols\Mvblocks

Inserting a Multi-View Block Using the Tool Palette
Use the Civil Multiview Blocks Tool Palette to insert a multi-view block into a drawing.
To insert a multi-view block into a drawing using the Tool Palette
1 Click Home tab ➤ Palettes panel ➤ Tool Palettes Window.
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2 Right-click anywhere on the Tool Palette’s vertical bar, and click Civil Multiview Blocks.
3 Locate the block to insert by clicking the named tabs.
4 Click the block and drag it into the drawing window.
5 Specify the insertion point and rotation angle.
NOTE Multi-view blocks are embedded in an enclosing block reference when they are initially inserted and must
be exploded before they can be recognized by AutoCAD Civil 3D as a multi-view block object.

Inserting a Multi-View Block Using DesignCenter
Use DesignCenter to insert a multi-view block into a drawing.
NOTE Multi-view blocks are embedded in an enclosing block reference when they are initially inserted and must
be exploded before they can be recognized by AutoCAD Civil 3D as a multi-view block object.
To insert a multi-view block into a drawing using DesignCenter
1 Click View tab ➤ Palettes panel ➤ Design Center.
2 In DesignCenter, select the folder containing the DWG file or files (do not select individual blocks
within the DWG files).
3 From the DesignCenter preview pane, drag the image representing the multi-view block DWG file into
the drawing.
4 Specify the insertion point, if prompted.
5 Specify the scale, if prompted:
■

To specify a scale value, enter a value at the Command prompt.

■

To dynamically set the scale, use the pointing device, and click when you see the appropriate scale.

6 Specify the rotation angle, if prompted:
■

To specify a rotation value, enter a value at the Command prompt.

■

To dynamically set the rotation, use the pointing device, and click when you see the appropriate
rotation

7 To insert additional references to the multi-view block, repeat steps 3 - 6. 3.
8 Press Enter to finish inserting blocks.

Inserting Additional Instances of Multi-View Blocks into a Drawing
After one instance of a multi-view block has been inserted into the drawing, additional instances can be
added.
The block must already exist in the current drawing to use this command. Insert the original block using
the Civil Multiview Blocks Tool Palette.
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To add another instance of a multi-view block into a drawing
1 Click Insert tab ➤ Block panel

Add Multi-View Block.

2 Use the AutoCAD Properties Palette to select the multi-view block to insert. All available blocks are
listed in the Definition list on the Design tab.
NOTE If you do not see the block you want to insert, add it to the drawing by dragging it from the Tool
Palette or by adding it from the DesignCenter.
3 Specify the insertion point, rotation, and other settings. You can enter these values in the Properties
Palette, or you can use the command line options.

Modifying Multi-View Blocks
Change the attributes of a multi-view block in a drawing. For example, you can change the rotation or the
scaling factor.
There is a multi-view block contextual ribbon in AutoCAD Civil 3D 2011 that you can use to access
commonly-used commands. Select the multi-view block in the drawing to display this ribbon tab.
NOTE If you select a multi-view block in a drawing and the multi-view block contextual ribbon is not displayed,
use the EXPLODE command to explode the multi-view block. Multi-view blocks are embedded in an enclosing
block reference when they are initially inserted and must be exploded before they can be recognized by AutoCAD
Civil 3D as a multi-view block object.

Changing the Rotation of a Multi-View Block
To change the rotation of a multi-view block
1 Click View tab ➤ Palettes panel ➤ Properties.
2 Select the multi-view block.
3 On the Properties palette, expand Basic. Expand Location.
4 Enter a value for Rotation.
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Changing the Associated Multi-View Block Definition
Change the multi-view block definition associated with the multi-view block. For information about the
relationship between multi-view blocks and multi-view block definitions, see Creating Multi-View Block
Definitions (page 1823).
To change the multi-view block definition associated with the multi-view block
1 Click View tab ➤ Palettes panel ➤ Properties.
2 Select the multi-view block.
3 On the Properties palette, expand Basic. Expand General.
4 Click Definition. Select a new multi-view block definition for the multi-view block.

Changing the Scale Factor of a Multi-View Block
To change the scale factor of a multi-view block
1 Click View tab ➤ Palettes panel ➤ Properties.
2 Select the multi-view block.
3 On the Properties palette, expand Basic. Expand Scale.
4 Enter new values for the X, Y, and Z scale factors.

Changing the Offset of a Multi-View Block
Change the offset of a multi-view block from its insertion point.
When you first add a multi-view block to a drawing, the offset value is set to 0. Change the position of the
multi-view block by offsetting it from its original insertion point.
You can also change the offset of a multi-view block using the Properties palette.
To change the offset of a multi-view block from its insertion point
1 Select the multi-view block.
2 Click Multi-View Block tab ➤ Modify panel ➤ Edit View Block Offsets.
NOTE If you select a multi-view block in a drawing and the multi-view block contextual ribbon is not displayed,
use the EXPLODE command to explode the multi-view block.
3 Select the Location grip.
In Model view, the Location grip has three possible edit modes: Edit Along XY Plane, Edit Along XZ
Plane, and Edit Along ZX Plane. Press Ctrl to cycle among modes until you are in the desired mode.
The default is Edit mode along the XY plane. In Plan view, the Location grip is restricted to movement
in one plane.
4 Offset the multi-view block to the desired location and click once, or enter a value and press Enter.
If you want to enter a specific value for the second direction in any edit mode (for example, in the Y
direction when editing along the XY plane), press Tab to cycle to the second direction.
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You can also lock the movement of the multi-view block along a specific direction. If you enter a value
for either of the dimension directions in the current edit mode and then press Tab, the movement of
the multi-view block is constrained to the second dimension direction. When editing along the XY
plane, for example, you can enter a value for the X dimension, and then press Tab. The X dimension
is locked at that value, and movement of the multi-view block is constrained to the Y dimension
direction.
5 Right-click and click Exit Edit View Block Offsets.
The selected view block is offset from the original insertion point.

Changing the Location of a Multi-View Block
Relocate an existing multi-view block by changing the coordinate values of its insertion point. In Model
view, the Location grip has three possible edit modes: Edit Along XY Plane, Edit Along XZ Plane, and Edit
Along ZX Plane. Press Ctrl to cycle among modes until you are in the desired mode. The default is Edit mode
along the XY plane. In Plan view, the Location grip is restricted to movement in one plane
You can also change the location of a multi-view block using the Properties palette.
NOTE This procedure can only be done in Model view.
To relocate an existing multi-view block by changing the coordinate values of its insertion point
1 Select the multi-view block you want to relocate.
2 Select the Location grip.

3 Move the multi-view block to the desired location and click once, or enter a value and press Enter.
If you want to enter a specific value for the second direction in any edit mode (for example, in the Y
direction when editing along the XY plane), press Tab to cycle to the second direction.
You can also lock the movement of the multi-view block along a specific direction. If you enter a value
for either of the dimension directions in the current edit mode and then press Tab, the movement of
the multi-view block is constrained to the second dimension direction. When editing along the XY
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plane, for example, you can enter a value for the X dimension, and then press Tab. The X dimension
is locked at that value, and movement of the multi-view block is constrained to the Y dimension
direction.

4 Right-click and click Deselect All to turn off grips.

Attaching Hyperlinks, Notes, or Files to a Multi-View Block
Attach hyperlinks, enter notes, or attach reference files to a multi-view block in a drawing. You can also edit
notes and edit or detach reference files from a multi-view block.
To attach hyperlinks, enter notes, or attach reference files to a multi-view block in a drawing
1 Click View tab ➤ Palettes panel ➤ Properties.
2 Select the multi-view block.
3 On the Properties palette, click the Extended Data tab.
4 To add a hyperlink, click
5 To add or edit a note, click
6 Click

next to Hyperlink, and specify the link.
next to Notes. Enter text. Click OK.

next to Reference documents. Attach, detach, or edit a reference file:

■

To attach a reference file, click

■

To edit the description of a reference file, enter text under Description.

■

To edit a reference file, double-click the reference file name to start its application.

■

To detach a reference file, select the file name. Click
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. Select a file. Click Open.

.

Editing the Attributes of a Multi-View Block
To display the attributes defined for a multi-view block
1 Click View tab ➤ Palettes panel ➤ Properties.
2 Select the multi-view block.
3 On the Properties palette, click the Design tab. Expand Advanced.
4 Click Attributes.
5 Edit attributes as needed.
6 Click OK.
NOTE You can also select the multi-view block to display the Multi-View Block ribbon tab, and then use the Edit
Attributes command on the Modify panel to edit the attributes.

Updating Multi-View Block Attributes
Use this procedure to update the attributes of blocks in your drawing, using the current attributes defined
for the view blocks upon which each multi-view block is based. You need to do this if you change attribute
definitions in one or more of the block definitions on which the multi-view block is based.
To update attribute definitions
1 Select the multi-view block.
2 Click Multi-View Block tab ➤ Modify panel ➤ Update

.

3 Enter y (Yes) to include text style properties (for example, width factor, oblique, mirroring) when
updating attributes, or n (No) to update all attributes properties except those relating to text style.
4 Press Enter to end the update process.

Drafting Tools
You can perform a variety of editing operations on linework components and certain Civil objects using the
AEC Modify Tools.
This suite of tools can be used on any of the following objects and is available on the shortcut menu regardless
of whether any of these objects of these types are selected:
■

Hatches

■

Polylines

■

Circles

■

Arcs

■

Text/Multiline text (Mtext)

■

Any of the above when embedded in blocks

Although the modify tools can only be applied to the types of objects listed, objects of any type can be used
as reference points or boundaries for the editing operations. For example, linework can be trimmed or
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extended in relation to Civil objects. Likewise, Civil objects can be used to define a cropping boundary to
subtract from linework. For more information about the applicability of the various tools, refer to the
individual procedures.

Trimming Linework Objects
You can trim hatches, lines, polylines, arcs, circles, or any block-based content created from these types of
linework or objects.
To trim linework
1 Select the linework, object, or block you want to trim.
2 Right-click and click AEC Modify Tools ➤ Trim.
3 Specify two points to establish the trim line.
The trim line changes color after the second point is selected, as does all linework (except hatches) on
the side of the trim line where the cursor is positioned.
4 Click the side of the trim line where the region you want to remove is located.
All linework on the selected side of the trim line is removed. Boundaries for any closed polylines on
the other side of the trim line are redrawn along the trim line.
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Trimming a block

Trimming Linework Objects to an Edge
Trim one or more lines, polylines, arcs, circles, or hatches precisely to a selected edge or side of any straight
segment of linework.
TIP If you need to trim linework to the edge of an arced segment of an object, use either the Crop option (see
Cropping Linework Objects (page 1841)) or the Subtract option (see Subtracting from Linework Objects (page 1838)).
The Crop option removes linework outside the implied boundary of the arc, while the Subtract option removes
linework inside the implied boundary of the arc.
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To trim one or more objects to an edge
1 Select the linework or object you want to trim.
2 Right-click and click AEC Modify Tools ➤ Trim.
3 Press Enter.
4 Move the cursor over the edge or line to which you want to trim the selected linework or object.
5 Click when the trim line is displayed.
6 Click the side of the trim line you want trimmed.
All selected linework is trimmed to the edge you selected.

Trimming linework to the
edge of a wall

Extending Linework to an Edge
Extend one or more lines, open polylines, or arcs precisely to an implied edge of a straight or arced segment
of any object, or to an implied extension of that segment.
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To extend linework to an edge
1 Select the linework you want to extend.
2 Right-click and click AEC Modify Tools ➤ Extend.
3 Move the cursor over the edge or line to which you want to extend the selected linework. Click when
a temporary line is displayed extending along and beyond the edge/line in both directions.
4 Click any point on the linework you want to extend or click the edge or line to which you want to
extend the linework.
The linework is extended to the edge. If you selected multiple lines, clicking on any one of them extends
them all.

Extending linework to the
edge of a wall

Dividing Linework Objects
Divide linework or a block containing linework into two (or more) parts defined by a dividing line you draw.
You can then select the parts on either side of the line. If a closed-boundary object is divided into two parts
using this option, both parts are recreated as closed. If an open polyline in a zigzag pattern is divided along
its length, many selectable segments are created.
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To divide linework
1 Select the linework, object, or block you want to divide.
2 Right-click and click AEC Modify Tools ➤ Divide.
3 Specify two points to establish the dividing line. In the case of a closed-boundary object, the points
can be inside or outside the boundaries. The dividing line is automatically extended until it intersects
all boundaries of the selected object.
You can select the divided parts of the linework or object on either side of the divide line. The divide
line is not visible after you select the second point.

Dividing a space object

Subtracting from Linework Objects
Subtract a selected part from linework or from a block containing linework without having to redraw any
of the remaining components. The part to be subtracted can contain or be delineated by lines, polylines
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(closed or open), arcs, circles, text, or hatches. If the subtraction removes part of a closed polyline, the
polyline is recreated as closed. If the subtraction bisects a closed polyline, both parts are recreated as separate
closed polylines. However, when the subtraction bisects a hatch, the hatch remains a single linework entity
that you can select by clicking either part.
NOTE Anything subtracted by this operation is actually deleted from the drawing. If you want to hide linework
from view, you may want to use the Obscure command instead. For more information, see Obscuring Regions of
Linework (page 1839).
To subtract a selected part from an object
1 If it does not already exist, draw the linework that delineates what you want to subtract.
2 Select the linework or object from which to subtract the delineated part.
3 Right-click and click AEC Modify Tools ➤ Subtract.
4 Select the linework delineating the part you want to subtract. Press Enter.
5 Press Enter to retain the selected linework. Enter y (Yes) to erase it.

Subtracting part of a block

Obscuring Regions of Linework
Obscure or “hide” a region of linework in relation to other linework. Use this feature when you want to
indicate that one entity extends behind or beneath another entity that is displayed in the foreground. The
obscured linework is placed on the layer specified by the Hidden layer key.
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To obscure a region of linework in relation to other linework
1 Select the linework you want to obscure.
2 Right-click and click AEC Modify Tools ➤ Obscure.
3 Select the foreground linework that will obscure the linework selected in step 1.
4 Press Enter.
The obscured region is delineated with a dashed line. You can select it (or its component segments)
separately from the linework it was part of before being obscured.

Obscuring linework with a block

Merging Linework Objects
Merge contiguous closed polylines, circles, hatches, or blocks into a single closed-boundary object or linework
entity.
To merge linework
1 Select the linework or object to which you want to add one or more other linework entities or objects.
2 Right-click and click AEC Modify Tools ➤ Merge.
3 Select the linework/object(s) you want to merge with the originally selected linework/object, and press
Enter.
4 Press Enter to retain the selected linework. Enter y (Yes) to erase it.
All selected linework and/or objects are merged into a single entity.
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Merging a region with a block

Cropping Linework Objects
Crop linework to a smaller area using a boundary you define. You can crop hatches, lines, polylines, arcs,
circles, or blocks. Neither the linework to be cropped nor the linework that defines the new boundary needs
to have closed boundaries. For example, you can either use a v-shaped polyline to crop a circle or a circle to
crop a v-shaped polyline.
To crop linework using a boundary
1 Draw the linework that defines the new boundary to which you want to crop the existing linework.
2 Right-click and click AEC Modify Tools ➤ Crop.
3 Select the linework to crop and press Enter.
4 Select the linework you want to use to define the new boundary (the linework you drew in Step 1), and
press Enter.
5 Press Enter to retain the selected linework (the crop boundary), or enter y (Yes) to erase it.
All of the originally selected linework outside the crop boundary is erased. If you choose to erase the
crop boundary, boundaries are redrawn for any closed-boundary entities inside the crop area. But any
open-boundary objects that have been cropped remain open.
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Visibility Checks
Visibility checks are features that enable you to visually inspect your model, including the Drive tool and
the Line of Sight tools (Point to Point Line of Sight, Sight Distance Along Corridor, and Zone of Visual
Influence).

Drive Tool
Use this tool to simulate driving through a 3D model by following an alignment, feature line, or 3D polyline.

Using the Drive Command
You can simulate driving through a 3D model using the Drive command.
To use the Drive command, you must first select a corridor, alignment, feature line, or 3D polyline. When
you start the command, you are prompted to select a profile. After selecting a profile, the view changes to
Drive mode view, and a contextual Drive tab is displayed in the ribbon.
The Drive tab provides commands that enable you to play, pause, or reverse the display of driving through
the model. You can change the speed of the drive simulation, as well as the eye location, visual style, and
target object.
When you end Drive mode by clicking Close on the Drive tab, your view changes back to normal view.
To use the Drive command
1 Open a drawing that contains a corridor, alignment, feature line, or 3D polyline that has an associated
profile.
2 Select a corridor, alignment, feature line, or 3D polyline.
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3 Do one of the following:
■

In the ribbon, click Analyze panel ➤ Visibility Check drop-down ➤ Drive

■

At the command line, enter Drive.

.

4 Select a profile.
The Drive tab is displayed, and the view switches to the Drive mode view.
5 On the Drive tab, click Play/Pause to start the Drive command.
6 Click Play/Pause at any time to pause the motion. Other controls on the Drive tab let you navigate
along the selected object.
For information on using other Drive features, see Specifying Drive Settings (page 1843).
7 When you are finished using the Drive command, end the command by clicking Close on the Drive
tab. Your view changes back to a normal view, and you are no longer in Drive mode.

Quick Reference
Ribbon
Analyze tab ➤ Visibility Check drop-down ➤ Drive
Command Line
Drive

Specifying Drive Settings
Specify Drive settings using controls available on the Drive tab in the ribbon.
For example, you can set the location of the eye using the Eye Height and Eye Offset controls. You can also
set the speed of the driving motion using the Speed control.
Changes made to the Drive settings persist while a drawing is open. When you close the drawing and open
it again, or open another drawing, the Drive settings return to their defaults.
The following settings are available for the Drive command.

Eye Panel
Eye Height

Eye Offset

This option, along with the Eye Offset option, controls the
“eye” location or, center point of the view perspective, when
using the Drive command. It specifies the vertical distance
or height of the eye location starting from the road surface
in relation to the roadway center line. The road surface is
determined by the profile, feature line, or 3D polyline height
at that location. This is a relative value, based on the elevation of the selected drive path at a given (each) station of
the roadway.
This option, along with the Eye Height option, controls the
“eye” location or, center point of the view perspective, when
using the Drive command. It specifies the horizontal distance
or offset of the eye location starting from the center line (of
the chosen alignment and profile, or feature line, or 3D
polyline).
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Show Eye Path

Shows or hides the eye path when the Drive command is
launched.

NOTE The default values for Eye Height and Target Height are controlled by the Stopping Eye Height and Stopping
Object Height items in the Profile Creation collection in the Profile Edit Feature Setting dialog box.

Navigate Panel
Play\Pause

Starts or pauses the moving display of the view along the
roadway.

Start Station

Moves the view to the start station of the roadway. However,
if you are viewing in reverse mode, clicking Start Station
brings you to the end station of the roadway.
Moves the view to the previous station along the roadway.

Previous Station
Increment

Sets the increments that the view moves through during
Drive mode.
Moves the view to the next station along the roadway.

Next Station
Moves the view to the end station of the roadway.
End Station
Go To (Current Station)

Displays the current station being displayed and lets you
select a station to move to from a drop-down list.

Speed

Specifies the speed of the motion during Drive mode.

Visual Styles

Specifies the visual style used when using the Drive command.
Sets the play mode to display in a continuous loop.

Loop

Reverse

Displays the view along the roadway in the opposite direction.

Target Panel
Target Height

Target Offset
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Specifies the Y-axis location of the target object, in relation
to the roadway center line. This is a relative value, based on
the elevation of the selected drive path at a given (each)
station of the roadway. The target object is a vertical cylindrical-shaped object that can be displayed or not displayed
using the Show Target option. The top of the target object
is always at the middle center of your viewpoints when using
the Drive command.
Specifies the X-axis location of the target object, in relation
to the roadway center line. This is a relative value, based on
the elevation of the selected drive path at a given (each)
station of the roadway.

Target Distance

Specifies the distance that the target object is displayed from
the eye of the driver.
Shows or hides the target object at the target location.

Show Target

Quick Reference
Ribbon
Analyze tab ➤ Visibility Check drop-down ➤ Drive
Command Line
Drive

Line of Sight Tools
Use these tools to analyze the line of sight between any two points, around the radius of a single point, and
at intervals along a roadway.

Checking Sight Distance Using Point to Point Line of Sight
Use this tool to do a local sight distance check, for example, at a high risk spot in an intersection.
To check the validity of the designed terrain, this check is typically performed against a finished ground
surface, or a composite surface (a corridor surface pasted into an existing ground surface).
NOTE All sight lines that are drawn during a single command are drawn as an AutoCAD block on layer 0 so that
you can easily select them all and delete them if necessary.
To check the sight distance between two points
1 Click Analyze tab ➤ Design panel ➤ Visibility Check drop-down ➤ Point To Point

.

2 Select a surface or press Enter and select a surface from the list.
3 At the command line you are prompted to specify the following:
■

height of eye

■

location of eye

■

height of target

■

location of target

A green arrow is displayed if the target is visible from the eye location. The command line displays the
distance from the eye to the target.
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If the target is not visible from the eye location, the portion of the line of sight that is visible is green
and the line beyond the obstruction point is red. A message is displayed at the command line indicating
that the line of sight is obstructed. The name of the surface that is causing the obstruction, the
obstruction point coordinates, and the distance from the eye to the target are listed.
4 Continue to specify targets or press ESC to end the command.
NOTE All sight lines that are drawn during a single command are drawn as an AutoCAD block on layer 0 so
that you can easily select them all and delete them if necessary.

Quick Reference
Ribbon
Analyze tab ➤ Design panel ➤ Visibility Check drop-down ➤ Point To Point
Command Line
PointToPointCheck

Calculating Sight Distance Along a Corridor
Use this tool to calculate sight distances along a roadway and to ensure that the design meets the required
minimum sight distances.
When the minimum values are not met, the area is flagged in a report and graphically highlighted in the
model.
NOTE All graphic elements are drawn as blocks on the specified layers so that you can easily select them all and
delete them if necessary.
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To check sight distance along a corridor
1 Click Analyze tab ➤ Design panel ➤ Visibility Check drop-down ➤ Check Sight Distance

.

2 On the Sight Distance Check - General page, specify the path along which you want to check.
NOTE To enable the Next and Finish buttons you must specify a valid sight path.

3 Select a surface to perform the check against and click
to add it to the list. The surfaces are listed in
the order of priority. If there are multiple surfaces at a given location, then the check is done against
the surface with the highest priority. You can change the priority by clicking the

and

arrows.

4 Click Next.
5 On the Sight Distance Check - Sight Distance page, enter values for the following:
■

Minimum Sight Distance

■

Eye Height

■

Eye Offset

■

Target Height

■

Target Offset

6 Click Next.
7 On the Sight Distance Check - Results page, select the sight distance graphic components that you want
drawn in the model. You can hover over a component in the list to see a preview.
8 Click

to select a hatch color for the display of the obstructed areas.

9 Optionally, create a sight analysis report. From the Choose A File Type list, specify one of the following
report style sheets:
■

ReportCSV

■

ReportHTML

■

ReportTXT

■

ReportXML
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10 Specify the location to save the report. Click Finish.
NOTE All graphic elements are drawn as blocks on the specified layers so that you can easily select them all
and delete them if necessary.

See also:
■

Sight Distance Check Wizard (page 2765)

Quick Reference
Ribbon
Analyze tab ➤ Design panel ➤ Visibility Check drop-down ➤ Check Sight Distance
Dialog Box
Sight Distance Check Wizard (page 2765)
Command Line
SightDistanceCheck

Checking Sight Distance Using a Zone of Visual Influence
Use this tool to perform local visibility checks.
Use this command when you need to determine if a vertical object, such as traffic light or a tower, can be
seen from within a certain radius.
You can also use this command to determine how far a driver can see from a stop line at an intersection.
To check the validity of the designed terrain, this check is typically performed against a finished ground
surface, or a composite surface (a corridor surface pasted into an existing ground surface).
This command creates hatch patterns on the current drawing layer to indicate the different levels of visibility.
To display a zone of visual influence
1 Set the drawing to the layer on which you want to create the hatch patterns.
2 Click Analyze tab ➤ Design panel ➤ Visibility Check drop-down ➤ Zone Of Visual Influence

.

3 Select a surface, or press Enter and select a surface from the list.
4 At the command line you are prompted to specify the following:
■

location of the object

■

height of the object

■

radius of the vision extent

After the command is completed, the colored areas (hatch patterns) on the surface within the specified
radius indicate the following:
Color

Visibility

Green

the entire height of the object is visible
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Color

Visibility

Yellow

the object is partially visible

Red

the object is not visible

Quick Reference
Toolspace
Analyze tab ➤ Design panel ➤ Visibility Check drop-down ➤ Zone Of Visual Influence
Command Line
ZoneOfVisualInfluence

Utilities Command Reference
You can use commands to quickly access AutoCAD Civil 3D utility functionality.
The following table lists the utility-related AutoCAD Civil 3D commands and briefly describes their
functionality.
Command

Description

CgADist

Displays the total of several entered distances (page
1791)

CgAng

Displays acute and obtuse angle values between
points or intersecting lines (page 1794)

CgCDist

Displays the distance between two or multiple points
(page 1792)

CgList

Displays coordinate and geometric data for a selected
line or arc (page 1794)
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Command

Description

CgSList

Displays slope, grade, and horizontal distance on a
line or arc, or between two points (page 1795)

ContentBrowser

Opens the Autodesk Content Browser where you can
access catalogs of metric and imperial tools to use for
design creation

DockCT

Docks the Coordinate Tracker utility (page 1813)

DockInquiry

Docks the Inquiry utility (page 1806)

Drive

Displays a moving 3D view along a roadway to create
the appearance of driving through the model (page
1842)

FloatCT

Changes the Coordinate Tracker utility from docked
to floating (page 1813)

FloatInquiry

Floats the Inquiry utility (page 1806)

HideCT

Hides the Coordinate Tracker utility (page 1813)

HideEventViewer

Hides the Event Viewer utility (page 1817)

HideInquiry

Hides the Inquiry utility (page 1806)

Mapcheck

Checks the error of closure of a parcel or survey figure
from its labels, or from manual input of direction,
distance, and curve data (page 1795)

MinDistBetweenEntities

Identifies the shortest distance between two entities.
(page 1811)

MvBlockAdd

Inserts a multi-view block definition into a drawing
(page 1827)

MvBlockDefEdit

Edits how a multi-view block appears in different view
directions (page 1823)

MvBlockEditAttributes

Edits the attributes defined for a multi-view block
(page 1833)

MvBlockEditViewBlockOffsets

Changes the offset of a multi-view block from its insertion point (page 1830)

MvBlockUpdate

Updates the attributes of blocks in your drawing
(page 1833)

Notes

Adds notes to a drawing (page 1804)

ObjectViewer

Displays the Object Viewer utility (page 1805)

PointToPointCheck

Calculates a point to point sight distance check (page
1845)
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Command

Description

ShowCT

Tracks the coordinates of the cursor in any coordinate
system (page 1813)

ShowEventViewer

Opens the Event Viewer window where you can view
messages that are logged during an AutoCAD Civil
3D session (page 1817)

ShowInquiry

Lists data about objects based on a selected inquiry
type (page 1806)

SightDistanceCheck

Calculates sight distances along a roadway with the
Sight Distance Check Wizard (page 1846)

VertDistBetweenEntities

Identifies the vertical distance between two entities.
(page 1812)

ZoneOfVisualInfluence

Calculates a local visibility check (page 1848)
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Sharing Drawings and Data
With Other Applications

AutoCAD Civil 3D provides many utilities for sharing your drawings and data with other applications.

Comparing Sharing Methods
To share an AutoCAD Civil 3D drawing data with people who do not have AutoCAD Civil 3D, you can use
proxy graphics, the Object Enabler, the Export To AutoCAD commands.
The following table lists the features of each method:
Data Sharing
Method

Use of objects in Status of objects
other AutoCAD- in other applicabased applications
tions

2D and 3D style
display settings
honored in different viewports

Objects still exist
when reopened
in AutoCAD Civil
3D

Proxy Graphics

View/plot objects
and design data;
no manipulation
of objects.

Objects are displayed as proxy
graphics with no intelligence.

No

Yes

Object Enabler

View, plot, copy,
and manipulate
object labels.
Design data is not
editable.

Objects are maintained as intelligent
objects.

Yes

Yes

Export To
AutoCAD
(DWG or DXF)

Objects are exploded to AutoCAD primitives.
The visual integrity of the model
is preserved. Object design data is
not available.

No objects in other
applications. Only
AutoCAD primitives.

No

No
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Data Sharing
Method

Use of objects in Status of objects
other AutoCAD- in other applicabased applications
tions

2D and 3D style
display settings
honored in different viewports

Objects still exist
when reopened
in AutoCAD Civil
3D

Export to SDF

Points, parcels,
alignments, pipes
and structures are
exported to the
SDF file. Can be
used in applications that can
read SDF. AutoCAD Map can import this data.

Primarily a format
for AutoCAD Map.

SDF is a separate
file. Original drawing is not affected.

SDF is a separate
file. Original drawing is not affected.

Export to 3D
DWF

Uses the 3D display representations of the objects for display.
Some objects do
not have a 3D display component
so are not displayed in 3D
DWF. There is also
object meta-data
exported with 3D
DWF. All of the
objects export the
meta-data.

Autodesk Design
Review or DWF
Viewer is required.

Autodesk Design
Review or DWF
Viewer is required.
3D DWF uses the
3D display component when exported.

Original drawing is
not affected.

Using Proxy Graphics
Proxy graphics store the last viewed image of AutoCAD Civil 3D objects, which lets users view your drawing
without modifying the original objects. Proxy graphics store only the display representation for the current
active viewport.
NOTE Depending on the complexity of the drawing, a drawing saved with proxy graphics can become extremely
large, slowing drawing performance. It is recommended that you make a copy of the drawing without proxy
graphics before turning them on in the drawing you want to share with other users.
To generate proxy graphics
1 Set up the drawing to display the view for which you want to create proxy graphics.
2 At the command line, enter Proxygraphics.
3 Enter 1.
4 Save the drawing.
5 To turn off proxy graphics, enter Proxygraphics, and then enter 0.
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Quick Reference
Command Line
Proxygraphics

Using the Object Enabler
Users who do not have AutoCAD Civil 3D but who have an AutoCAD 2011-based product can install the
Object Enabler and view your drawing exactly as you created it.
The Object Enabler is available on the AutoCAD Civil 3D installation CD and on the Autodesk web site at
www.autodesk.com/aecobjenabler.
After a user installs the Object Enabler, the user can open the drawing and view, plot, manipulate, and copy
AutoCAD Civil 3D objects using standard AutoCAD commands. AutoCAD Civil 3D objects are maintained
as intelligent objects, and the drawing can be re-used in AutoCAD Civil 3D.

Exporting a Drawing to AutoCAD
You can export a drawing created in AutoCAD Civil 3D to AutoCAD®. This process creates either a new
AutoCAD 2010, 2007, 2004, 2000 or R14 format drawing with all civil objects exploded to AutoCAD primitives.
The original drawing is not affected.
When you open the resulting drawing, the primitive objects are not restored to their original state.
The following format compatibility rules apply.
Format ...

Compatible with AutoCAD
...

2010

2010-2011

2007

2007-2009

2004

2004-2006

2000

2000-2003

R14

R14

The Export To AutoCAD commands respect the current display settings of the objects in your drawing. For
example, if a surface in the drawing is set up to display the border and contours only, the drawing created
with the ExportTo Auto CAD command will contain primitives that represent the surface border and contours
only.
If the current drawing contains multiple viewports, the Export To AutoCAD commands create the primitives
based on the view of the objects in the active viewport.
TIP For information about the Save As AutoCAD DWG command and how it is different from the Export To
AutoCAD commands, see Save A Drawing in the AutoCAD Help.
To export a drawing to AutoCAD
1 Verify that the drawing’s Model tab is selected.
2 At the command line, enter UCS, and then enter World.
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3 Click

➤ Export ➤ AutoCAD DWG, and then click the version you want to use.

4 Enter a filename, and specify a path, if necessary.
The default filename includes any prefix or suffix that you specified on the AEC Editor tab of the Options
dialog box. For more information, see Changing the AEC Editor Settings (page 1858).
5 Click Save.
TIP You can use the Autodesk Civil Batch Drawing Converter Utility to convert multiple drawings to a legacy
AutoCAD drawing format. See Converting Multiple Drawings to a New Format or Changing Units (page 1859).
When converting AutoCAD Civil 3D drawings to legacy AutoCAD drawing formats, the application does
not convert AutoCAD Civil 3D objects to the previous version.

Quick Reference
Application Menu

➤ Export ➤ AutoCAD DWG
Command Line
ExportToAutoCAD2010
ExportToAutoCAD2007
ExportToAutoCAD2004
ExportToAutoCAD2000
ExportToAutoCADR14

Exploding AutoCAD Civil 3D Objects
All AutoCAD Civil 3D objects support the AutoCAD Explode command. In addition, labels on objects can
be individually exploded.
For more information on the Explode command, see Explode.
A setting in the AutoCAD Options dialog box affects how AutoCAD Civil 3D objects are exploded. For more
information, see Changing the AEC Editor Settings (page 1858).

Changing the AEC Editor Settings
You can specify settings for the Export To AutoCAD commands, including how the commands handle XRefs.
To change the AEC Editor Settings
1 At the command line, enter Options.
2 In the AutoCAD Options dialog box, click the AEC Editor tab (page 2751).
3 Under Block Properties Of Exploded Objects, select Maintain Resolved Layer, Color, Linetype to maintain
the layer, color, and linetype of objects when you explode them.
4 Under Export To AutoCAD, select Bind Xrefs if you want to bind the xrefs to the host drawing when
exploding, thus creating local block definitions. If you select this option, all xrefs and their dependent
named objects become a part of the exported drawing.
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5 If you select the Bind Xrefs check box, then either select or clear the Use Insert Method When Binding
Xrefs check box.
6 Enter a prefix or a suffix to be added to the drawing filename when the drawing is exported with the
Export To AutoCAD commands.
NOTE The other options on the AEC Editor tab are not supported by AutoCAD Civil 3D.
7 Click OK.

Quick Reference
Application Menu

➤ Options ➤ AEC Editor tab
Command Line
Options
Dialog Box
AEC Editor Tab (Options dialog box) (page 2751)

Converting Multiple Drawings to a New Format or Changing Units
Convert drawing units to a supported unit type before inserting or opening drawings in AutoCAD Civil 3D.
You can also use this utility to convert multiple drawings to a different AutoCAD drawing format and to
reduce AutoCAD Civil 3D objects to basic AutoCAD objects (line, arcs, and faces) in multiple drawings.
If you have a series of drawings that you need to save to a previous drawing format, you can use this
time-saving utility to do a batch conversion of multiple drawing files and save them to one of the following
AutoCAD drawing formats:
■

Current (AutoCAD 2010)

■

Current DXF (AutoCAD 2010)

■

AutoCAD 2007

■

AutoCAD 2004

■

AutoCAD 2000

■

R12 DXF

■

AutoCAD 2007 DXF

■

AutoCAD 2004 DXF

■

AutoCAD 2000 DXF

NOTE When converting AutoCAD Civil 3D drawings to legacy AutoCAD drawing formats, the application does
not convert AutoCAD Civil 3D objects to the previous version.
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To convert multiple drawings

1 Click

➤ Export ➤ Batch Converter.

2 Under Conversion Options in the General section, specify the following:
■

Units: in the Value column, click the cell and select the units to be used in the drawings you convert.
To maintain the current units, select Current.
NOTE To change only the drawing Units in multiple files, specify the new Units Value and set the Drawing
Save Format to Current. Civil objects are not exploded if you only change the Units Value.

■

Filename Prefix: in the Value column, click the cell and enter a prefix to be added to the files you
convert.
TIP Adding a filename prefix is helpful to easily identify the newly converted files, for example you could
use ACAD-.

■

Filename Suffix: in the Value column, click the cell and enter a suffix to be added to the files you
convert.

3 Under the Format section, specify the following:
■

Drawing Save Format: in the Value column, click the cell and from the list select the drawing format
for the converted drawings.

■

Explode Objects: in the Value column, click the cell and select Yes to explode Civil Objects to
AutoCAD primitives. Select No to convert drawings in the current format.
NOTE If you select Yes and explode objects in a AutoCAD Civil 3D drawing, the primitive objects are not
restored to AutoCAD Civil 3D objects when you re-open the drawing in AutoCAD Civil 3D.

■

Bind Xrefs: in the Value column, click the cell and select Yes or No.

■

Use Insert Method When Binding Xrefs: in the Value column click the cell and select Yes or No.

4 In the File Selection section, do the following:
■

Under Source Folder, browse to the location of the source files that you want to convert. To include
files in subfolders, select the Look in Subfolders check box. The filenames display in the Selected
Files section.

■

Under Search For Files Named, select a file type from the list, or enter a file type or file name in the
box. To search for multiple file types you can enter a comma delimited list. You can also use an
asterisk as a wildcard, for example auto*.dwg.

■

Under Destination Folder, browse to the location where you want to save the converted files.

NOTE By default, all drawing files are selected. To select files individually, click the Clear All button to clear
all check boxes and then select the check boxes for the drawing files you want to convert.
5 Do one of the following:
■

Click Apply to convert the selected files. The dialog box remains open.

■

Click OK to convert the selected files and close the dialog box.
A message box displays when the conversion is complete.
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NOTE If the program encounters an error during the conversion process, a list of the files that did not convert
and the file location will display when the conversion is complete.

See also:
■

Civil Batch Drawing Converter Dialog Box Reference (page 2763)

Quick Reference
Menu
Click Application Menu ➤ Batch Converter
Command Line
CivilBatchConverter
Dialog Box
Civil Batch Drawing Converter Dialog Box Reference (page 2763)

Exporting a Drawing to a DXF File
You can export a drawing created in AutoCAD Civil 3D to AutoCAD. This process creates either a new
AutoCAD 2010, 2007, 2004, 2000, or R12 DXF format drawing with all civil objects exploded to AutoCAD
primitives. The original drawing is not affected.
A DXF file is a text file that contains drawing information that other CAD systems can read. When you open
the DXF file, the exploded objects are not restored to their original state.
You can export drawings to the following DXF formats:
■

AutoCAD 2010 DXF

■

AutoCAD 2007 DXF

■

AutoCAD 2004 DXF

■

AutoCAD 2000 DXF (including 2000i and 2002)

■

AutoCAD Release 12 DXF

This process creates a new DXF file with all AutoCAD Civil 3D objects exploded to AutoCAD primitives. The
original drawing is not affected.
NOTE When you use the Export To AutoCAD commands, all AutoCAD Civil 3D objects are exploded to AutoCAD
primitives. Opening the drawing in AutoCAD Civil 3D does not restore these primitive objects to AutoCAD Civil
3D objects.
To export a drawing to a DXF file
1 Verify that the drawing’s Model tab is selected.
2 At the command line, enter UCS, and then enter World.

3 Click

➤ Export ➤ AutoCAD DXF.

4 Enter a filename, and specify a path, if necessary.
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The .dxf extension for the file name is specified by default. The default file name also includes any
prefix or suffix that you specified on the AEC Editor tab of the Options dialog box. For more information,
see Changing the AEC Editor Settings (page 1858).
5 Click Save.

Quick Reference
Application Menu

➤ Export ➤ AutoCAD DXF
Command Line
ExportToAutoCAD2010Dxf
ExportToAutoCAD2007Dxf
ExportToAutoCAD2004Dxf
ExportToAutoCAD2000Dxf
ExportToAutoCADR12Dxf

Exporting Civil Data to SDF Files
Use the Export to SDF command to export AutoCAD Civil 3D data to Spatial Data Format (SDF) files.
Spatial data format files can be used in AutoCAD Map 3D and Autodesk MapGuide Enterprise. The alignment,
point, parcel, and pipe network data are converted to data objects with attributes.
The AutoCAD Civil 3D alignment, point, parcel, and pipe network data is converted to data objects with
attributes. SDF files store data as features, which means that you are dealing with real-world objects rather
than geometry.
AutoCAD Civil 3D Object

Exported Attributes

Alignment

■

Alignment Name

■

Length

■

Design Speed

■

Starting Station

■

Ending Station

■

Point Number

■

Point Name

■

Elevation

■

Description

■

Raw Description

■

Latitude

■

Longitude

■

Parcel Name

■

Parcel Number

Point

Parcel
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Pipe

Structure

■

Area

■

Perimeter

■

Network Name

■

Length

■

Slope

■

Inside Diameter

■

Outside Diameter

■

Shape

■

Elevation at Start

■

Elevation at End

■

Structure Start

■

Structure End

■

Network Name

■

Rim Elevation

■

Structure Name

To export AutoCAD Civil 3D drawing data to an SDF file
1 Click Output tab ➤ Export panel ➤ Export Civil Objects To SDF

.

2 In the Export To SDF (page 2761) dialog box, specify a name for the SDF file.
3 Specify the coordinate system.
NOTE If the drawing already has a coordinate system specified, it is used automatically and the Select
Coordinate System controls in the Export To SDF dialog box are grayed out.
4 Click OK to export the file.

Quick Reference
Ribbon
Output tab ➤ Export panel ➤ Export Civil Objects To SDF
Command Line
ExportToSDF
Dialog Box
Export To SDF (page 2761)

Exporting a Drawing to a 3D DWF File
You can export a drawing created in AutoCAD Civil 3D to 3D DWF format.
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A Design Web Format (DWF) file is a set of drawings or images that is compressed into a single, smaller file,
making sharing across the Web faster and more secure.
The Export to 3D DWF command creates a DWF file with all or the selected AutoCAD Civil 3D objects and
AutoCAD primitives. The command uses the 3D display representations of the objects when displaying them
in the DWF file. Some objects do not have 3D display components (for example, profile views), so they are
not displayed in the 3D DWF.
Object metadata is also exported with 3D DWF. For example, the maximum surface elevation information
is available when you view the 3D DWF in the DWF Viewer or Autodesk Design Review.
NOTE To export to 2D DWF format, use the Plot feature. For more information see Create and Modify a Drawing
Set for Publishing.
For more information on 3D DWF publishing, see 3DDWFPublish.
To export a drawing to a DWF file
1 Verify that the drawing’s Model tab is selected.
2 At the command line, enter UCS, and then enter World.

3 Click

➤ Export ➤ Other Formats.

4 In the Files of Type drop-down, click 3D DWF, enter a filename, and specify a path, if necessary.
The .dwf extension for the file name is specified by default.
5 Optionally, click Tools ➤ Options and modify the publishing options. For more information, see DWF
Publishing Options Dialog Box (page 2762).
6 Click OK to close the DWF Publishing Options dialog box and click Save to generate the DWF file.

Quick Reference
Application Menu

➤ Export ➤ Other Formats
Command Line
3DDWFPublish

Other Data Sharing Methods
Share AutoCAD Civil 3D data using additional utilities and commands.
The following section list additional methods for sharing AutoCAD Civil 3D data.

Exporting to Google Earth
Use the Export to Google Earth utility to publish and view your design data in Google Earth. For more
information, see Publishing Civil Data to Google Earth (page 1871).
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Exporting to DEM
Use the Export Surface to DEM utility to export surface data to a DEM file. The file can be of type USGS
(.dem) or GeoTIFF (.tiff). For more information, see Exporting to DEM (page 773).

Exporting to LandXML
Use the LandXML export commands to export drawing data to LandXML format. For more information,
see Understanding LandXML Import and Export (page 1875).

Exporting Points
Use the Points export command to export drawing points to an ASCII (text) file or a Microsoft® Access .mdb
file. For more information, see Exporting Point Data (page 534).

Drawing Sharing Command Reference
You can use commands to quickly access file and drawing sharing drawing functionality.
Command

Description

3DDWFPublish

Exports an AutoCAD Civil 3D drawing to 3D DWF
format (page 1863)

CivilBatchConverter

Convert multiple drawings to a different AutoCAD
drawing format. (page 1859)

ExportToAutoCAD2000

Exports an AutoCAD Civil 3D drawing to AutoCAD
2000 format (page 1857)

ExportToAutoCAD2000Dxf

Exports an AutoCAD Civil 3D drawing to AutoCAD
2000 DXF (page 1861)

ExportToAutoCAD2004

Exports an AutoCAD Civil 3D drawing to AutoCAD
2004 format (page 1857)

ExportToAutoCAD2004Dxf

Exports an AutoCAD Civil 3D drawing to AutoCAD
2004 DXF format (page 1861)

ExportToAutoCAD2007

Exports an AutoCAD Civil 3D drawing to AutoCAD
2007 format (page 1857)

ExportToAutoCAD2007Dxf

Exports an AutoCAD Civil 3D drawing to AutoCAD
2007 DXF format (page 1861)

ExportToAutoCAD2010

Exports an AutoCAD Civil 3D drawing to AutoCAD
2010 format (page 1857)

ExportToAutoCAD2010Dxf

Exports an AutoCAD Civil 3D drawing to AutoCAD
2010 DXF format (page 1861)

ExportToAutoCADR12Dxf

Exports an AutoCAD Civil 3D drawing to AutoCAD
R12 format (page 1861)

ExportToAutoCADR14

Exports an AutoCAD Civil 3D drawing to AutoCAD
R14 format (page 1857)

Drawing Sharing Command Reference | 1865

Command

Description

ExportToSDF

Exports an AutoCAD Civil 3D drawing to SDF format
(page 1862)

1866 | Chapter 41 Sharing Drawings and Data With Other Applications

Google Earth Import and
Export

42

Use AutoCAD Civil 3D to retrieve image and terrain data from Google Earth as well as publish and view your design data
in Google Earth.
■

Import surface images and terrain data from Google Earth to better visualize the future development environment.

■

Publish the model space entities from AutoCAD Civil 3D to Google Earth to quickly view your design data in the Earth
terrain imagery.

■

Import the elevation data for the current Google Earth view as a mesh.

■

Attach time-related information to each piece of the model data and then display published model data based on start
and end times.

NOTE You can use the imported Google Earth data for demonstration purposes only. Images imported from Google
Earth are low resolution and are not suitable for a land survey. In the same manner, publishing Civil data to Google
Earth can only serve as a conceptual planning and design tool.

Importing a Google Earth Image to AutoCAD Civil 3D
You can import Google Earth images into your AutoCAD Civil 3D drawing.
You can manually specify the image insertion point or you can insert the image using the defined coordinate
system in the drawing. Before you start, ensure that no tilting, turning, or rotation have been applied to the
image.
To import a Google Earth image into a Civil project
1 In Google Earth, fly to a point of interest (see the Google Earth User Guide for more information).
The image that is displayed in the Google Earth 3D Viewer is the source image that will be imported.
See the Google Earth User Guide for more information.
2 Click Insert tab ➤ Import panel ➤ Google Earth drop-down ➤ Google Earth Image

.
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3 Follow the instructions at the command prompt and, depending on whether your drawing has a
coordinate system defined (see Specifying Units and Zone Settings (page 80)), do one of the following:
■

Choose to locate the image using the defined coordinate system or manually identify the image
location.

■

Manually specify the image insertion point and define image rotation angle by entering the
corresponding values or clicking in the drawing workspace.

NOTE If a map projection coordinate system is defined, AutoCAD Civil 3D can automatically place the image
or terrain data in the proper location in the drawing.

The image is displayed in the drawing as a new object. The image file name is generated and the image is
saved in JPEG format in the same folder as the current drawing file. You can use the imported image for
adding design objects and data.
NOTE The imported image is displayed as grayscale in the application.

Quick Reference
Ribbon
Insert tab ➤ Import panel ➤ Google Earth drop-down ➤ Google Earth Image
Menu
File ➤ Import ➤ Import Google Earth Image
Command Line
ImportGEImage

Importing Google Earth Terrain Data into a Surface
Create a AutoCAD Civil 3D surface that represents a specific location on the surface of the Earth by importing
terrain data from a Google Earth image.
You can insert the surface using the defined coordinate system or by selecting the previously imported
image. Before you start, ensure that no tilting, turning, or rotation have been applied to the image.
To create a surface using the image terrain data from Google Earth
1 In Google Earth, fly to a point of interest (see the Google Earth User Guide for more information). The
image that is displayed in the Google Earth 3D Viewer is the source image whose terrain data will be
imported.
2 Click Home tab ➤ Create Ground Data panel ➤ Surfaces drop-down ➤ Create Surface From Google
Earth

.

3 Follow instructions in the command prompt and, depending on whether your drawing has a coordinate
system defined (see Specifying Units and Zone Settings (page 80)), do one of the following:
■

Choose to locate the surface using the defined coordinate system or by selecting the previously
imported image.

■

Locate the surface using the previously imported image.
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NOTE If a map projection coordinate system is defined, AutoCAD Civil 3D can automatically place the image
or terrain data in the proper location in the drawing.
4 In the Create Surface dialog box, follow the steps for creating a TIN surface. See Creating a TIN Surface
(page 649).
A surface is created. It is displayed in AutoCAD Civil 3D drawing and the Prospector tab. The location of
the surface points is based on the closest values obtained from the transformation of the Google Earth
geographical coordinates to the linear coordinates of the drawing.

Quick Reference
Ribbon
Home tab ➤ Create Ground Data panel ➤ Surfaces drop-down ➤ Create Surface From Google Earth
Menu
File ➤ Import ➤ Import Google Earth Surface
Command Line
ImportGESurface

Importing Google Earth Image and Terrain Data
You can import Google Earth images and create a AutoCAD Civil 3D surface based on the terrain data from
the image location in one step.
The location of the surface points is based on the closest values obtained from the transformation of the
Google Earth geographical coordinates to the linear coordinates of the drawing.
The image that is displayed in the Google Earth 3D Viewer is the source image whose terrain data will be
imported. Before you start, ensure that no tilting, turning, or rotation have been applied to the image.
To create a surface and import an image using the Google Earth data
1 In Google Earth, fly to a point of interest (see the Google Earth User Guide for more information).
2 Click Insert tab ➤ Import panel ➤ Google Earth drop-down ➤ Google Earth Image And Surface

.

3 Follow the instructions at the command prompt and, depending on whether your drawing has a
coordinate system defined (see Specifying Units and Zone Settings (page 80)), do one of the following:
■

Choose to locate the image and surface using the defined coordinate system or manually identify
the image location.

■

Manually identify the image and surface location and orientation.

Quick Reference
Ribbon
Insert tab ➤ Import panel ➤ Google Earth drop-down ➤ Google Earth Image And Surface
Menu
File ➤ Import ➤ Import Google Earth Image And Surface
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Command Line
ImportGEData

Importing Google Earth Elevation Data as a Mesh
Import the elevation data for the current Google Earth view as a polygon mesh.
The image that is displayed in the Google Earth 3D Viewer is the source image whose elevation data is
imported as a polygon mesh.
Before you start, ensure that no tilting, turning, or rotation have been applied to the source image. For best
results, zoom in the displayed view, so that surface terrain details are visible.
To import a Google Earth mesh
IMPORTANT Before importing Google Earth elevation data, maximize the Google Earth application window.
1 In Google Earth, fly to a point of interest (see the Google Earth User Guide for more information).
2 In AutoCAD Civil 3D, click Insert tab ➤ Import panel ➤ Google Earth drop-down ➤ Google Earth Image
And Surface

.

3 In the drawing, specify the insertion point and rotation angle to orient the image. The mesh is imported
into the drawing.
NOTE If a map projection coordinate system is defined, AutoCAD Civil 3D can automatically place the image
or terrain data in the proper location in the drawing.
AutoCAD Civil 3D creates a render material, using the displayed Google Earth 3D Viewer image. This
render material is associates with the current drawing and assigned to the created mesh.
The image captured from the Google Earth view is saved in the same folder as the current drawing. The
image filename inherits the first three letters from the drawing file name.
4 Optionally, to view the image draped on the mesh, select Realistic from the Type list in the Material
Editor of the Materials window. For more information, see Object Rendering (page 1761) and Draping
Images On Surfaces (page 750).
When importing the Google Earth elevation data to a AutoCAD Civil 3D drawing, note the following:
■

When you place the mesh into the drawing, you can use the AutoCAD MOVE and ROTATE commands
to refine the position of the mesh relative to your model. Do not adjust the position of your model.
Rather, adjust the position of the mesh relative to your model.

■

The dimensions of the mesh are defined by the extent of longitude and latitude that the mesh covers in
Google Earth, and transformation of these extents to the linear units of the drawing.

■

The mesh size is fixed at 32 rows by 32 columns.

■

The material created in the drawing is named using the first three letters of the drawing file, followed
by several random numbers.

Quick Reference
Ribbon
Insert tab ➤ Import panel ➤ Google Earth drop-down ➤ Google Earth Image And Surface
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Menu
File ➤ Import ➤ Import Google Earth Mesh
Command Line
ImportGEMesh

Publishing Civil Data to Google Earth
Use the Google Earth publishing wizard to export the 3D design data from AutoCAD Civil 3D to Google
Earth for quick visualization of the model within the context of the Earth surface imagery.
After you prepare your AutoCAD Civil 3D drawing data, run the Publish to Google Earth command and
follow the steps in the publishing wizard.
To publish 3D design data to Google Earth
1 Click Output tab ➤ Publish panel ➤ Publish To Google Earth

.

2 On the Describe page, specify information about the published drawing. See the Describe page of the
wizard (page 2091).
3 On the Items page, specify the model space entities that you want to publish. See the Items page of the
wizard (page 2091).
NOTE When there are render materials attached to model space entities in AutoCAD Civil 3D, you can publish
the materials with the entities. If timespan information is attached to model space entities, this information
is not published to Google Earth when you select to publish render materials. See Attaching Time Information
to Model Data (page 1872).
4 On the Geo-Reference page, use the controls to transform the linear coordinates of the drawing to
geographic coordinates used in Google Earth. See the Geo-Reference page of the wizard (page 2092).
5 On the Nudge page, fine-tune the location of the created model. See the Nudge page of the wizard (page
2093).
6 On the File page, specify the name and location for your published file. See the File page of the wizard
(page 2094).
7 Click Publish and view the status of the publishing operation.
8 After the operation is finished, click View to view the published model in Google Earth.
NOTE If Google Earth is not running, it is launched and the published model is displayed in the Google Earth
3D Viewer.

The resulting .kml or .kmz file is stored in the location that you specified. You can share the published file
with remote project participants, who can view it using Google Earth.
NOTE You can control the appearance of the published data using the Google Earth controls. For more information,
see the Google Earth User Guide.

Quick Reference
Ribbon
Output tab ➤ Publish panel ➤ Publish To Google Earth
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Menu
File ➤ Publish To Google Earth
Command Line
PublishKML
PublishKMZ
Dialog Boxes
Describe Page (Publish AutoCAD DWG to Google Earth Wizard) (page 2091)
Items Page (Publish AutoCAD DWG to Google Earth Wizard) (page 2091)
Geo-Reference Page (Publish AutoCAD DWG to Google Earth Wizard) (page 2092)
Nudge Page (Publish AutoCAD DWG to Google Earth Wizard) (page 2093)
File Page (Publish AutoCAD DWG to Google Earth Wizard) (page 2094)
Publish and View Page (Publish AutoCAD DWG to Google Earth Wizard) (page 2094)

Attaching Time Information to Model Data
The GETime command enables you to attach the timespan information to civil object entities. When you
import civil model data that contains the timespan information to Google Earth, you can view the information
sequentially or as an animation.
You can attach time-related information to each piece of the model data and then display these data based
on start and end times (timespan). This command is useful when presenting project development over time.
In Google Earth, you can use the Time slider in Google Earth to control the display of the model data. You
can, for example, redefine the time range or move the time range to a different point on a timeline. For
more information on Google Earth timeline playback controls in the 3D Viewer, see “Viewing a Timeline”
in the Google Earth User Guide.
Before you assign a timespan to a civil model, decide on the best way to associate time information with
the various entities. For example, you can assign a timespan to each stage of a land development project
from modeling a subdivision layout to grading work, or building a road. Alternatively, you can show the
progress of each individual stage separately.
To attach time information to an object
NOTE If you plan to publish your model to Google Earth in the same session, ensure that Google Earth is running.
1 In the drawing, do one of the following:
■

Select an object. Click Surface tab ➤ General Tools panel ➤ Google Earth Timespan

■

At the command line, enter GETime.

.

2 Select an object to assign timespan information and press Enter.
3 In the Timespan for Google Earth dialog box (page 2095), specify the start and end dates by selecting
them from the calendar. Click OK.
4 Repeat steps 2 to 3 to assign timespan information to any other objects.
TIP Hover over an object to see a tooltip with timespan information attached to the model space entity.
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5 When finished, publish the model to Google Earth. See Publishing Civil Data to Google Earth (page
1871).
You can view the published model in the Google Earth 3D Viewer and adjust the necessary parameters using
the timeline controls. See “Viewing a Timeline” in the Google Earth User Guide.
When you attach timespan information to Civil models, note the following:
■

If you do not attach the start-time information to an object entity, Google Earth starts the playback from
the beginning of the timeline.

■

If you do not attach the end-time information to an object entity, Google Earth starts the playback from
the start-time point and continues up to the end of the timeline.

■

An object entity without any timespan information attached is displayed in Google Earth constantly.

■

When publishing an object to Google Earth, you can not attach time information to this object and
associate a render material with it at the same time.

Quick Reference
Ribbon
Select an object. Click Surface tab ➤ General Tools panel ➤ Google Earth Timespan
Command Line
GETime
Dialog Box
Timespan for Google Earth (page 2095)

Google Earth Import and Export Command Reference
You can use commands to quickly access Google Earth import and export functionality.
The following table lists the AutoCAD Civil 3D commands related to import and export operations with
Google Earth and briefly describes their functionality.
Command

Description

GETime

Attaches the timespan information to civil object
entities (page 1872)

ImportGEData

Imports Google Earth image and terrain data into
a created TIN surface (page 1869)

ImportGEImage

Imports a Google Earth Image into a drawing (page
1867)

ImportGEMesh

Imports elevation data of the current Google Earth
view into AutoCAD Civil 3D as a mesh (page 1870)

ImportGESurface

Imports Google Earth terrain data into a created
TIN surface (page 1868)

PublishKML

Publishes Civil design data to Google Earth in the
KML (uncompressed) format (page 1871)
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Command

Description

PublishKMZ

Publishes Civil design data to Google Earth in the
KMZ (compressed) format (page 1871)
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LandXML Import and
Export
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Use the AutoCAD Civil 3D LandXML import and export commands to import and export drawing data in LandXML
format.
See Understanding LandXML Import and Export (page 1875) for a list of objects that are supported in AutoCAD Civil 3D
2011.
The LandXML import and export functionality is based on the LandXML schema.
AutoCAD Civil 3D supports the following LandXML schema versions:
■

LandXML-1.0

■

LandXML-1.1

■

LandXML-1.2

For more information about the LandXML schema, go to www.landxml.org.

Understanding LandXML Import and Export
LandXML provides a non-proprietary data standard that is driven by an industry consortium of partners.
Use LandXML to transfer data to another drawing or to another application that supports imported XML.
For example, you can use LandXML to transfer surfaces between drawings.
Many AutoCAD Civil 3D objects are supported for LandXML import and export. See Supported LandXML
Data for Drawing Import and Export (page 1876)for a list of supported objects.
In addition, Survey database data can be imported and exported. For more information, see Importing Survey
XML Data.
By transforming AutoCAD Civil 3D drawing data to LandXML, you can:
■

Exchange data. Import LandXML data into other software applications. The data can then be modified
and delivered to customers and agencies in the required formats.

■

Transfer or archive data. Transfer data to another AutoCAD Civil 3D drawing. Also, you can archive data
in a non-proprietary format.
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■

Convert units. Export data using imperial measurements. Then, import it using metric to scale and convert
values.

■

Translate/rotate coordinates. Globally adjust the elevations of data.

Supported LandXML Data for Drawing Import and Export
LandXML supports AutoCAD Civil 3D drawing data for import and export.
General Data Handling (page 1876)
LandXML Elements Supported for Drawing Import (page 1876)
Supported LandXML Elements for Drawing Export (page 1878)

General Data Handling
All coordinate locations are always treated as Northing, Easting, Elevation (or Y,X,Z).
All station values are treated as the actual measured distance along the alignment or geometry. Station
equations are always imported or exported (if they are defined) with alignment data. However, they are not
applied to any geometric station locations in the data; they are used only for display and reporting purposes.
Point references to pointType derived locations <CgPoint pntRef="100"/> are supported. The supported
references include: CgPoint, Start, Center, End, Monument, and CrossSectPnt elements. For more information,
see Point Reference Export Options (page 1882).

LandXML Elements Supported for Drawing Import
LandXML Element Supported

Notes

Units
Application
Author
CoordinateSystem

Uses Map Zone name / European Petroleum
Survey Group (EPSG) name

CgPoints

Supports multiple elements. If <CgPoints> is
named, a corresponding point group is created
and COGO points are added.

CgPoint

Imports a COGO point and uses name and desc
or code attributes. Number is auto-assigned if
name is alpha-numeric, but name is maintained.

Alignments
CoordGeom

Lines, curves, spirals, and irregular lines.

AlignPI
StaEq
Superelevation
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LandXML Element Supported

Notes

DesignSpeeds
Profiles

Finished ground, design profiles created using
imported lines (PVIs), circular vertical curves,
parabolic, symmetric, and asymmetric vertical
curves.

ProfAlign

All elements supported

ProfSurf

PVI, pointlist data for a sampled ground surface

CrossSects
CrossSectSurf

As sample lines in sample line group associated
with alignment

DesignCrossSectSurf

As subassembly

Parcels

Creates parcels from data

CoordGeom

All elements supported

Monuments

Creates COGO points in a monuments points
group

Surfaces
SourceData
Breaklines

Imported as 3D polylines on layer "<surfacename>_Breaklines"

Contours

Imported as 3D polylines on layer "<surfacename>_Contours"

DataPnts

Imported as COGO point group named "<surfacename>_DataPoints" on layer "<surfacename>_DataPoints"

Definition
TIN

Option to import faces, then either update triangulation or maintain the triangulation in the file.
Supports face edge visibility and face neighbor
optimization attributes.

GRID
Survey
ReducedObservations

Creates COGO points in an observations point
group.
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LandXML Element Supported

Notes
IMPORTANT Using the Import LandXML command from the File menu does not import survey
data into the survey database. For more information, see Importing Survey XML Data.

SurveyMonuments

Creates COGO points in a monuments point
group

PlanFeatures
CoordGeom

Imported as 3D polylines to current layer

PipeNetworks

Each <Pipe Network> is imported as a AutoCAD
Civil 3D pipe network

Pipe

Supports curved pipe

Units.diameterUnit
Structs
Units.diameterUnit
PipeFlow
StructFlow

Supported LandXML Elements for Drawing Export
LandXML Element Supported

Notes

Units

Always exported

Application

Always exported

Author
CoordinateSystem

Uses Map Zone name / European Petroleum Survey Group (EPSG) name

CgPoints

Point group exports as <CgPoints> with
matching name and all points export.
If an AutoCAD Civil 3D point has a point
name, the name is exported to the
LandXML point name attribute. Otherwise,
the point number is exported to the
LandXML point name attribute.

Alignments
CoordGeom
AlignPI
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As lines, curves, and spirals.

LandXML Element Supported

Notes

StaEq
Superelevation
DesignSpeeds
Profiles
ProfAlign

Design profiles with lines, circular vertical
curves, parabolic, symmetric, and asymmetric vertical curves.

ProfSurf
CrossSects
CrossSectSurf

Sample lines exported as CrossSectSurfs

DesignCrossSectSurf

Assemblies exported as DesignCrossSectSurfs

Parcels
CoordGeom

As lines, curves, and spirals.

Surfaces

TIN, GRID, and volume surfaces exported.

SourceData
Breaklines
Contours
DataPnts
Definition
TIN
GRID
Roadways

Corridors exported as <Roadways> with
references to <Alignments> with Profiles
and Cross Sections (both sampled ground
and design sections) and to one or more
reference surfaces.

PipeNetworks
Pipes
Units.diameterUnit
Structs
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LandXML Element Supported

Notes

Units.diameterUnit
PipeFlow
StructFlow

LandXML and Sites
In an AutoCAD Civil 3D drawing, a site is used to collect or group sub-collections, such as parcels, alignments,
and gradings, by a topology that they share.
When objects that are grouped under the Sites collection are exported to a LandXML file, the site name is
exported with them.
When objects are imported from a LandXML file into the drawing, two site pickers are displayed:
■

Alignments Site allows you to specify the site on which the alignments will reside. The default selection
is <none>, which places the alignments in the top-level Alignments collection and prevents them from
interacting with parcels.

■

Parcels Site allows you to specify the site on which the parcels will reside. If no sites exist in the drawing,
the parcels are placed on the default site (Site 1). If the LandXML file has a site name for its features, then
that site name is created in the drawing and the parcels are assigned to it.

For more information about sites, see Understanding Sites (page 779).

Handling Duplicate LandXML Data on Import
When objects in the drawing have identical names to objects in a LandXML file, the imported data can be
skipped, renamed upon import, or it can overwrite the existing data.
You can specify your preference for handling duplicate data under Conflict Resolution Settings on the Import
tab of the LandXML Settings dialog box (page 2214).

Viewing and Editing LandXML Drawing Settings
You can view and edit LandXML settings for the entire drawing.
These settings control how data is converted between AutoCAD Civil 3D and a LandXML file, including
coordinate translation and rotation, and description information.
In the Toolspace, on the Settings tab, right-click the drawing collection, then, click Edit LandXML Settings.
Use the LandXML Settings (page 2214) dialog box, to view and edit all of the LandXML settings for the drawing.
For more information about using the Toolspace and the Settings tab, see The Toolspace Window (page 96).

Viewing and Editing the LandXML Import Settings
Control how LandXML data is inserted into the drawing when the file is imported.
To view and edit LandXML import settings
1 In Toolspace, on the Settings tab, right-click the <drawing name> collection ➤ Edit LandXML Settings.
2 In the LandXML Settings dialog box, click Import tab (page 2214) and modify the settings.
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3 Click OK.
The settings are saved as the default settings for the drawing.

Quick Reference
Toolspace Shortcut Menu
Settings tab: Right-click <drawing name> ➤ Edit LandXML Settings
Dialog Box
LandXML Settings (page 2214)

Unit Conversion for LandXML Data
AutoCAD Civil 3D uses conversion factors if the LandXML file you are importing has different units from
the current drawing.
You can import LandXML files that use feet or meters.
When imported, the LandXML files are converted to the units of the current drawing. In AutoCAD Civil
3D, the default drawing units can be meters, International Feet, or U.S. Survey Feet. For more information,
see Specifying Units and Zone Settings (page 80).
NOTE Previously, it was required that you specify International or US Survey Foot in the LandXML settings. This
specification is now done in the drawing settings.
NOTE Unit conversion is not applied to descriptive LandXML attributes that may contain numeric values. For
example, if you are importing a point with the description “12 oak” into a metric project, it will not be changed
to “305mm oak.”

Translating and Rotating LandXML Data
Translate imported coordinate data by specifying translation and rotation settings. Use the Import tab of
the LandXML Settings dialog box to set the values.
■

Base point values. The base point coordinates in the drawing are used to translate and rotate all imported
values. These coordinates are in the drawing units.

■

Translate coordinate values. The coordinate values are used to translate data from the base point. These
coordinates are in the drawing units.
NOTE In certain circumstances, you can assign the same values to both the translated coordinates and the
base point coordinates. For example, the values would be the same if you want to rotate the coordinates
without translating them.
For example, the following formula is used to translate the imported elevation values:
(Translation Coordinate Elevation - Base Point Elevation) + LandXML Elevation = Imported elevation
value
Therefore, if the LandXML file elevation is 90 feet, the base point elevation is 0.000 feet, and the translate
coordinate elevation is 10.000 feet, the formula is:
(10.000 - 0.000) + 90 = 100

■

Rotation angle and direction. The angle and direction, measured about the base point, about which the
data is rotated.
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Viewing and Editing the LandXML Export Settings
Control how data in AutoCAD Civil 3D is exported to a file in LandXML format.
To view or edit LandXML export settings
1 In Toolspace, on the Settings tab, right-click <drawing name> ➤ Edit LandXML Settings.
2 In the LandXML Settings dialog box, click the Export tab (page 2217) and modify the settings.
For more information, see Point Reference Export Options (page 1882) and Point Description and Code
Matching (page 1882).
3 Click OK.
The settings are saved as the default settings for the drawing.

Quick Reference
Toolspace Shortcut Menu
Settings tab: Right-click <drawing name> ➤ Edit LandXML Settings
Dialog Box
LandXML Settings (page 2217)

Point Reference Export Options
When selecting the data to export, you can choose to export point references. Set the Export Point References
property on the Export tab (page 2217) of the LandXML Settings dialog box to On.
When you turn this option on, AutoCAD Civil 3D creates COGO point references, where possible, for the
parcel, alignment, and surface geometry. This means that, if the geometry of parcels, alignments, and surfaces
in the drawing match COGO point coordinates within a specified tolerance, the object coordinates are
exported to the LandXML file as references to those COGO points.
Point references substitute a known point name instead of using northing and easting coordinates. For
example, without a point reference, the start point of a line element is written as follows:
<Start>5447.73530 4525.60643</Start>

With a point reference, it is written as follows:
<Start pntRef="371"></Start>

It is also valid for a coordinate geometry element to have a mix of pntRef and coordinate values as shown
in the following example:
<Line> <Start pntRef="250" /> <End>5632.87775298 3944.16966215</End> </Line>

This situation could occur for the endpoint if a COGO point does not exist within the specified tolerance.

Point Description and Code Matching
Match the AutoCAD Civil 3D description information with LandXML attributes. Use the Code Attribute
and Desc Attribute property groups on the Export tab of the LandXML Settings dialog box.
You can either disable or match the ‘code’ attribute in LandXML to a point’s description:
■

Disabled: Does not export a point description to the ‘code’ attribute.
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■

Raw Description: Exports a point raw description to the ‘code’ attribute.

■

Full Description: Exports a point full description to the ‘code’ attribute.

NOTE Typically, you would export the raw description to the ‘code’ attribute.
You can either disable or match the ‘desc’ attribute in the LandXML to a point’s description:
■

Disabled: Does not exports a point description to the ‘desc’ attribute.

■

Raw Description: Exports a point raw description to the ‘desc’ attribute.

■

Full Description: Exports a point full description to the ‘desc’ attribute.

NOTE Typically, you would export the full description to the ‘desc’ attribute.
You can also specify whether to export the full description if it is the same as the raw description. For
example, if the raw and full descriptions are the same, then only one value is exported. This would occur
when points do not have defined description keys.

Importing LandXML Drawing Data
Import LandXML data into the current AutoCAD Civil 3D drawing.
Importing LandXML data into AutoCAD Civil 3D is a two-step process:
1 Specify the import settings that prepare the data for import. For more information, see Viewing and
Editing LandXML Drawing Settings (page 1880).
2 Select the files and the specific data in the file to import.
The LandXML import functionality automatically handles the conversion between the units specified in
the LandXML file and the current drawing units.
NOTE LandXML does not transform coordinate systems automatically. No specific coordinate system transformation
is applied other than what is specified by the translation and rotation settings (page 1881).
To import LandXML data
1 Click Insert tab ➤ Import panel ➤ LandXML

.

2 In the Import LandXML dialog box, select or browse to the LandXML (*.xml) file you want to import.
Click Open.
3 In the Import LandXML dialog box (page 2213), select sites for the alignments and parcels. See LandXML
and Sites (page 1880) for more information.
4 The data tree displays each of the major data collections in the LandXML file. Use the data tree to:
■

Navigate a data collection and view its subcomponents.

■

Expand the collections. Select or clear the check boxes to filter the data types that you want to
import into the drawing. By default, all data components are selected for import.

NOTE The check boxes have a tri-state display. If only some objects are selected under a collection, the check
box is shaded

. If all the items are selected, the check box is selected

collection are cleared, the check box for the collection is cleared

. If all the items below the

.
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5 Click OK to import the LandXML file or click Browse to select another LandXML file.
After you click OK, the data is imported into the drawing. The data components are added to the
drawing’s applicable data collections in the Prospector tree.
NOTE As each object is imported, the Event Viewer Vista (page 2753) dialog box can display the status of each
operation. For more information, see The Event Viewer Vista (page 1817).

Quick Reference
Ribbon
Insert tab ➤ Import panel ➤ LandXML
Menu
File menu ➤ Import ➤ Import LandXML
Command Line
LandXMLIn
Dialog Box
Import LandXML (page 2213)

Exporting LandXML Drawing Data
Export LandXML drawing data from AutoCAD Civil 3D.
To export LandXML data
1 Click Output tab ➤ Export panel ➤ Export To LandXML

.

2 or
Prospector tab: Right-click <collection name> ➤ Export LandXML
The Export To LandXML (page 2219) dialog box, which contains a data tree, is displayed.
NOTE When you export from the Prospector tree, the Export To LandXML dialog box contains a pre-defined
selection set of that collection’s data. When you export from the Output tab, all drawing data is selected by
default, and you can adjust the selection by clearing check boxes. You can alternately specify the objects to
export by selecting them from the drawing.
3 Do one of the following:
■

Select or clear the check boxes to filter the data types that you want to export to the LandXML file.
Then click OK.
NOTE The check boxes have a tri-state display. If only some objects are selected under a collection, the
check box is shaded

. If all the items are selected, the check box is selected

the collection are cleared, the check box for the collection is cleared
■

Select data from the drawing by clicking
after you finished selecting the objects.
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. If all the items below

.

and selecting the objects in the drawing. Press Enter

NOTE When you select one point in a point group, the entire point group is selected. If the point belongs
to more than one point group, the point group with the highest display order is selected. For more
information, see Changing the Point Group Display Order (page 558).
4 Specify the LandXML schema version.
5 In the Export To LandXML dialog box, enter the name of the LandXML (*.xml) file you want to export
and specify the location. Click Save.

Quick Reference
Ribbon
Output tab ➤ Export panel ➤ Export To LandXML
Menu
File menu ➤ Export ➤ Export To LandXML
Toolspace Shortcut Menu
Prospector tab: Right-click <collection name> ➤ Export LandXML
Command Line
LandXMLOut
Dialog Box
Export To LandXML (page 2219)

LandXML Command Reference
The AutoCAD Civil 3D commands for LandXML and a brief description of their functionality. For more
information, follow the links.
Command

Description

LandXMLIn

Imports LandXML data into AutoCAD Civil 3D (page 1883)

LandXMLOut

Exports AutoCAD Civil 3D data to LandXML (page 1884)
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HEC-RAS Import and
Export
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The HEC-RAS import and export commands enable you to analyze flood data using the River Analysis System public
domain software from the United States Army Corps of Engineers’ Hydrologic Engineering Center.
Use the Export To HEC-RAS command to export AutoCAD Civil 3D data in HEC-RAS format, and use the Import HEC-RAS
command to import the data you export from the HEC-RAS software.
Exporting and Importing HEC-RAS Data (page 61)

Exporting Data to HEC-RAS
Use the Export To HEC-RAS command to export AutoCAD Civil 3D surface, site, alignment, and section
information for use in the HEC-RAS software.

Preparing Data to Export to HEC-RAS Format
To prepare AutoCAD Civil 3D data to export to HEC-RAS format
1 In AutoCAD Civil 3D, open a drawing that contains a stream you would like to study, along with an
existing ground surface.
2 Define the stream centerline as an alignment. Be sure the stationing goes in the desired direction. For
more information, see Creating Alignments (page 948) and Reversing Alignment Direction (page 1083).
3 Create a sample line group with stations at the desired section locations along the stream centerline
alignment. For more information, see Creating Sample Lines (page 1246).
NOTE For HEC-RAS analysis, be sure that the sample lines do not extend beyond the extents of the surface.
4 Optionally, create alignments or draw polylines to represent left and/or right stream banks.
NOTE The bank locations appear in the HEC-RAS application as red dots on the sections. The left and right
bank locations tell HEC-RAS where the Manning’s n values change for left, channel, and right bank situations
in the section. This effects the calculations and the level of water in the section.
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BEST PRACTICE It is recommended to use the same drawing for exporting data to be used in HEC-RAS that you
use for importing data from HEC-RAS.

Exporting Data to HEC-RAS Format
To export stream data using the Export To HEC RAS command
1 Prepare your drawing data (page 1887).
2 Click Output tab ➤ Export panel ➤ Export To HEC RAS

.

3 In the Export To HEC RAS (page 2141) dialog box, for Surface, select the surface you want to sample for
the stream sections.
4 For Site, select the site that contains the stream centerline alignment, or select <None> if the alignment
is not located in a site.
5 For Reach Alignment, select the alignment that represents the stream centerline.
6 Select the Sample Line Group that contains the sections you want to export.
7 Enter a River Name. This should typically be the name of the stream alignment. This name is used in
the HEC-RAS application as the title of the GEO file and is used as a label for the stream in the HEC-RAS
Geometric Data window.
8 To export river bank information, select Check This To Use River Banks, click Left and/or Right, and
select the polylines or alignments in the drawing.
NOTE The bank locations appear in the HEC-RAS application as red dots on the sections. The left and right
bank locations tell HEC-RAS where the Manning’s n values change for left, channel, and right bank situations
in the section. This effects the calculations and the level of water in the section. The Bank Positions exported
to the GEO file are measured as percentages of the overall section length rather than as offset distances.
9 Click Export.
10 In the Export Data To GEO File dialog box, navigate to the location where you want to save the GEO
file.
11 Enter a File Name. Click Save.
12 Click OK to exit the Export To HEC RAS dialog box.
13 Follow the steps in Importing To and Exporting From HEC-RAS Software (page 1889).

Quick Reference
Ribbon
Output tab ➤ Export panel ➤ Export To HEC RAS
Command Line
ExportHecRas
Dialog Box
Export To HEC RAS (page 2141)
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Importing To and Exporting From HEC-RAS Software
To import data into and export data out of HEC-RAS software
NOTE This procedure describes only how to import a GEO file into, and export an SDF file out of, HEC-RAS
software. Please refer to the HEC-RAS Help for information on how to use the application itself.
1 Start the HEC-RAS application.
2 Click Edit ➤ Geometric Data.
3 In the Geometric Data dialog box, click File menu ➤ Import Geometry Data ➤ GIS Format.
4 In the Import GIS Format Data File dialog box, navigate to and select the GEO file you exported from
AutoCAD Civil 3D. Click OK.
5 In the Import Geometry Data wizard, confirm the import geometry data and click Finished - Import
Data.
The geometry data will be visible in the Geometric Data window.
6 Complete your analysis.
7 In the main HEC-RAS window, click File menu ➤ Export GIS Data.
8 In the GIS Export dialog box:
■

Under Results Export Options, select Export Water Surfaces.

■

Select any profiles you may have created during the analysis.

■

Click Export Data. An SDF file is created.

9 Follow the steps in Importing Data from HEC-RAS (page 1889).

Importing Data from HEC-RAS
Use the Import HEC RAS command to display HEC-RAS analysis results in AutoCAD Civil 3D.
To import HEC-RAS data
1 In AutoCAD Civil 3D, open the drawing from which you exported the GEO file (page 1889).
2 Click Insert tab ➤ Import panel

Import HEC RAS

.

3 In the Import HEC RAS (page 2142) dialog box, select the Site For Reach Alignment. If no sites exist in
the drawing, then a new site named RASimport is selected and will be created.
NOTE The stream alignment is imported into the drawing only if an alignment of the same name does not
already exist in the site you specify. Existing alignments of the same name and site are not overwritten. LINE
objects that represent the sections are only imported if the alignment is imported.
4 Select the Style For Reach Alignment.
5 Select the Alignment Label Style Set.
6 Select the Profile Style.
7 Select the Profile Label Style Set.

Importing To and Exporting From HEC-RAS Software | 1889

8 Under SDF To Import, click the browse button
application.

and select the SDF file you exported from the HEC-RAS

9 Click Open.
10 In the Import HEC RAS dialog box, select the stream to import. When you select a stream, the number
of profiles and sections that exist for that stream are shown in the dialog box.
■

The profiles are imported as AutoCAD Civil 3D profile objects. You must create a profile view in the
drawing to view them. For more information, see Creating Profile Views (page 1208).
NOTE Existing profiles of the same name inside the same alignment will be overwritten. This is designed
to allow multiple iterations within the HEC-RAS application without having to manually delete profiles in
AutoCAD Civil 3D when you bring in updated data.

■

The section data is imported as LINE objects along the alignment. These lines show where the top
water surface intersects each section (according to the HEC-RAS application). They are created on
layers using the convention <alignment name> - <profile name>. The section lines are imported
only if the alignment is imported.

11 Click Import.
The flood elevation profiles are imported into the drawing and are visible in Prospector.
If an alignment of the same name and site as the selected stream alignment does not already exist in
the drawing, then it and the section lines are also imported. Section lines are not imported if the
alignment is not imported.
12 Click OK.

Quick Reference
Ribbon
Insert tab ➤ Import panel ➤

➤ Import HEC RAS

Command Line
ImportHecRas
Dialog Box
Import HEC RAS (page 2142)

HEC-RAS Import and Export Command Reference
You can use commands to access HEC-RAS import and export functionality quickly.
Command

Description

ExportHecRas

Exports surface, site, alignment, and section information for use in HEC-RAS software (page 1887)

ImportHecRas

Imports flood analysis data that was exported from
HEC-RAS software (page 1889)
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Importing Architectural
Data

45

Use the Import Building Site command to import architectural model data from Autodesk Revit Architecture to AutoCAD
Civil 3D in a collaborative design project.
By implementing the seamless data exchange between Autodesk Revit Architecture and AutoCAD Civil 3D, a site design
team can
■

Finalize the site plans before the architectural design has been completed.

■

Obtain enough information to start preparing the site for construction.

■

Reduce the communication cycle between architectural and civil engineering teams.

Importing Architectural Data Workflow (page 60)

Publishing a Design Package File
Use Autodesk Revit Architecture to prepare and publish an architectural model package file.
An architect prepares the architectural model in Autodesk Revit Architecture, applies the corresponding
templates, visibility settings and filters, and then publishes the model to the design package file (.adsk). The
imported model represents a gross area footprint of the building, with property and utility connection points.
The design package file is used to share data between Autodesk Revit Architecture and AutoCAD Civil 3D
and contains the following elements:
■

An image of a building footprint

■

Data for the building footprint (for example, area and perimeter)

■

Images of building model categories (doors, floors, roofs) visible in specific views

■

Data for the building model categories (for example, slope and area for the Roof model category)

■

An image of a site model

■

Base point coordinates data (Easting, Northing, and elevation)

■

Property line graphics
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■

Project information data (for example, building type, occupancy, and total gross building area)

■

Package file metadata for workflow type, OPC, and utilities

The following high-level procedure is performed by an architect in Autodesk Revit Architecture to prepare
the architectural model for sharing with AutoCAD Civil 3D.
To publish a design package file in Autodesk Revit Architecture
■

Prepare and simplify the file. The user applies a Civil Engineering View template and related visibility
settings and filters.

■

Launch the Export Module and specify export settings. The user specifies a footprint level, location, base
point, and the number of building model elements to export.

■

Save the file. The user specifies the file location and file name.

■

View the Export Building Site report that lists a summary of the output contents.

For details, see Exporting Building Sites in the Autodesk Revit Architecture 2011 User’s Guide.

Preparing for Importing a Design Package File
Close interaction of architects and civil engineers is important when sharing data between Autodesk Revit
Architecture and AutoCAD Civil 3D.
The following is a summary of issues that you should be aware of and steps that you can perform to facilitate
the collaboration effort:
■

When preparing a design package file for export, the architect can create site utilities with host connectors
that are functional in AutoCAD Civil 3D. You should make the architect aware of the utilities that are
relevant to the civil project beforehand, so they are exported with the design package file. If the required
utilities are not supported in Revit Architecture, the architect would be able to notify you. If you prefer
to set up the utility connections yourself, ask the architect to omit the Utilities parameter in the export
settings.

■

Before finalizing the building site model export, the architect may contact you about the site survey
point coordinates, so they can be exported with the model file.

■

The architect should apply as much model simplification settings as possible. You should communicate
to the architect your minimum requirements regarding the design package file content.

■

If the import operation is slow, you can request the architect to reexport the model with modified settings
to reduce file size.

■

The Export Building Site report is saved with the ADSK building site model file. You can use the report
to compare the content of the original file with the imported file.

■

Establish a procedure when every time the source design package file is modified, the architect notifies
you immediately, so you can update the building site object in your drawing.

Import a Building Site Model
Use the Import Building Site wizard to bring the architectural model, created in Autodesk Revit Architecture,
into AutoCAD Civil 3D, confirm and compare the building site units the Civil drawing units, and specify
the object insertion point.
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To import a building site model
1 Click Insert tab ➤ Import panel

Import Building Site

.

2 On the Select File page of the Import Building Site wizard, click
to import.
The model image appears in the Preview window. The
the building site object.
3 Click

and select the published ADSK file

marker shows the base point specified in

to select or modify a template for the building site object name.

4 Optionally, use the ViewCube to manipulate the object in the Preview window. See Overview of ViewCube
in the AutoCAD User’s Guide.
5 Click Next.
NOTE You can click Finish at any time to close the wizard and finish the import.
6 On the Confirm Units page, compare the units used in the building site object, as defined in the ADSK
file, with the units used in the current AutoCAD Civil 3D session. All the controls on this page are
read-only. Use them for reference information.
7 Click Next.
8 On the Display Properties page, click
9 Optionally, click

to specify the object layer (page 2221).

to edit the default building site style. See Editing a Building Site Style (page 1894).

10 Click Next.
11 On the Insertion Point page, confirm and modify the coordinates and rotation angle of the building
site object base point or click Specify In Drawing to orient the model in the drawing manually.
12 Optionally, click Preview to insert the building site object into the drawing as a test.
13 Do one of the following:
■

If you are in preview mode, press Esc to return to the Import Building Site wizard and continue
fine-tuning the base point location.

■

Press Enter to close the Import Building Site wizard and leave the building site object in the drawing.

14 Click Finish.

Quick Reference
Ribbon
Click Insert tab ➤ Import panel

Import Building Site

.

Command Line
ImportBuildingSite
Dialog Box
Import Building Site wizard (page 2010)

Import a Building Site Model | 1893

Creating a Building Site Style
Use the building site style to determine the display properties of the building site object components, such
as building footprint, property lines, utilities, site model, and building model.
Use the Toolspace Settings tree to create a building site style.
To create a building site style
1 In Toolspace, on the Settings tab, right-click the Building Site Styles collection and click New.
2 On the tabs of the Building Site Style (page 2012) dialog box, enter the required data or specify the settings.
3 Click OK.

Quick Reference
Toolspace Shortcut Menu
Settings tab: Building Site ➤ right-click Building Site Style ➤ Edit
Dialog Box
Building Site Style (page 2012)

Editing a Building Site Style
Edit the building site style that determines the display properties of the building site object components,
such as building footprint, property lines, utilities, site model, and building model.
Use the Toolspace Settings tree to edit a building site style.
To edit a building site style
1 In Toolspace, on the Settings tab, right-click the name of the building site style that you want to edit
and click Edit.
2 In the Building Site Style (page 2012) dialog box, change the properties of the building site style.
3 Click Apply and then OK.

Quick Reference
Toolspace Shortcut Menu
Settings tab: Building Site ➤ Building Site Styles ➤ right-click <style name> ➤ Edit
Command Line
EditBuildingSiteStyle
Dialog Box
Building Site Style (page 2012)

Modifying a Building Site Object in the Drawing
Use the EditBuildingSite command to edit the properties of the building site object in the drawing.
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To edit the building site object properties
1 In Toolspace, on the Prospector tab, right-click a Building Site item and select Building Site Properties.
2 In the Building Site Properties (page 2014) dialog box, modify the name of the building site object, enter
or edit the description, and modify the style.
3 Click Apply and than OK.

Quick Reference
Toolspace Shortcut Menu
Prospector tab: Building Site ➤ right-click <building site name> ➤ Building Site Properties
Command Line
EditBuildingSiteStyle
Dialog Box
Building Site Properties (page 2014)

Updating a Building Site Object Definition
Use the UpdateBuildingSite command to update the building site object that was imported into the drawing.
You use this command if the source architectural model has changed and a new ADSK package file was
posted in the shared location. When changes are made to the package file, the out-of-date icon
displays
next to a building site item in the Prospector tree. You can update the building site object references without
reimporting the object into the drawing.
To update a building site definition
1 In Toolspace, on the Prospector tab, right-click a Building Site item and select Update Building Site
Definition.
2 In the Select Autodesk Exchange File dialog box, select the updated ADSK file.
3 Click Open.
The definition of the imported building site object is updated and all its references are redefined with new
data.

Quick Reference
Toolspace Shortcut Menu
Prospector tab: Building Site ➤ right-click <building site name> ➤ Update Building Site Definition
Command Line
UpdateBuildingSite

Building Site Command Reference
You can use commands to quickly access the functionality of the Building Site object.

Updating a Building Site Object Definition | 1895

The following table lists the AutoCAD Civil 3D commands that relate to editing, importing, and updating
the Building Site object, and briefly describes their functionality:
Command

Description

EditBuildingSite

Opens the Building Site Properties dialog box, where
you can modify the properties of the building site
reference object (page 1894)

EditBuildingSiteStyle

Opens the Building Site Style dialog box where, you
can edit the building site style (page 1894)

ImportBuildingSite

Imports a building site object into a Civil drawing
(page 1892)

UpdateBuildingSite

Updates a building site object definition when the
original building site object data were changed
(page 1895)
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Working with DGN Data in
AutoCAD Civil 3D
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Import a MicroStation DGN file, and then copy nested objects for use in the host drawing.

Attaching a DGN File as an Underlay
You can import MicroStation DGN drawing files into DWG files.
The import process translates basic DGN data into the corresponding DWG file data. The DGN data is placed
into the DWG as an underlay. Depending on the settings that you specify, the DGN entities and their
associated linetypes may be nested within the DGN underlay, and then copied into the host drawing.
For the correct display of linetypes, the MicroStation RSC (resource file) that is referenced by the DGN file
must be available on your computer in a valid AutoCAD Support File Search Path when you import the DGN
file. You can define a path location by using the OPTIONS command, and adding a path to the AutoCAD
Support File Search Path node on the Files tab of the Options dialog box. Or you can copy the RSC file to
an already existing Support File Search Path.
For more information, see Copying Objects that are Nested in a DGN Underlay (page 1898).
The standard AutoCAD DGN import behavior is enhanced for AutoCAD Civil 3D. The following controls
are available on the Import DGN Settings dialog box in AutoCAD Civil 3D:

Import Into Current Drawing
Brings the DGN entities, and their associated linestyles, into the current drawing.
NOTE This is similar to the Insert command.

Prefix Dependent Definitions
Adds the DGN file and model name as a prefix to the incoming object’s name.
If the prefixed name results in a new name conflict, then an incremental number is appended to the name.
NOTE This is similar to the Xref Bind behavior.
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Ignore Duplicate Names
Ignores any duplicate symbol tables names in the DGN file, and gives precedence to the host definition for
duplicates.
For more information, see the AutoCAD Help topic Import MicroStation DGN Files.
NOTE If you save a AutoCAD Civil 3D DWG into which a DGN file has been imported, and then open the DWG
in another AutoCAD product, the linetypes will be displayed as Continuous.
To attach a DGN file as an underlay
1 On the command line, enter DGNImport.
2 In the Import DGN File dialog box, find and select the DGN file to import, or enter the name of the
DGN file at File Name.
3 Click Open.
4 In the Import DGN Settings dialog box, make sure the Import Into Current Drawing check box is
selected.
This option brings the DGN entities, and their associated linestyles, into the current drawing.
NOTE If this check box is cleared, the DGN entities are placed in a new drawing.
5 Under Import Into Current Drawing, specify how to name incoming objects during the import:
■

Prefix Dependent Definitions: Adds the DGN file and model name as a prefix to the incoming
object’s name. If the prefixed name results in a new name conflict, then an incremental number is
appended to the name.
NOTE This is similar to the Xref Bind behavior.

■

Ignore Duplicate Names: Ignores any duplicate symbol table names in the DGN file, and gives
precedence to the host definition for duplicates.

6 Select a design model from the list, and then specify the remaining import options.
7 Click OK.

Quick Reference
Command Line
DGNImport
Dialog Box
Import DGN Settings Dialog Box

Copying Objects that are Nested in a DGN Underlay
You can copy objects that are nested in a DGN underlay that exists in the current drawing.
The standard AutoCAD NCOPY behavior is enhanced for AutoCAD Civil 3D, in that you can copy nested
objects from DGN underlays, xrefs, or blocks into the host drawing.
For more information, see Attaching a DGN File as an Underlay (page 1897).
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To copy objects that are nested in a DGN underlay
1 Click Home tab ➤ Modify panel ➤ Copy Nested Objects

.

2 Select the DGN underlay objects to copy.
3 Press Enter.
4 Specify the base point.
5 Specify the second point.

Quick Reference
Ribbon
Home tab ➤ Modify panel ➤ Copy Nested Objects
Command Line
NCOPY

Copying Objects that are Nested in a DGN Underlay | 1899
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Plan Production Tools
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Use AutoCAD Civil 3D plan production tools to quickly create construction documents from drawings.
You can create plan/profile, plan-only, profile-only, and section sheets. The workflow is different for each.
For information on recommended workflows when working with plan production tools, see Plan Production Tools
Workflow (page 61)

Preparing for Plan Production
Your drawing must contain certain data before you can use the plan production tools. In addition, you must
use a template that is configured for the type of sheet you are creating.

Prerequisites for Using Plan Production Tools
The prerequisites are slightly different depending on the type of sheets you want to create.
Sheet type

Prerequisites for using plan production tools

Plan Only

■

The current drawing must contain an alignment.

■

You must be able to access a template that contains a
viewport with a Viewport Type defined as Plan, such as the
Civil 3D (Imperial) Plan Only.dwt template located in the
Template\Plan Production folder.

■

The current drawing must contain an alignment and a
profile.

■

You must be able to access a template that contains a
viewport with a Viewport Type defined as Profile, such as
the Civil 3D (Imperial) Profile Only.dwt template located in
the Template\Plan Production folder.

■

The current drawing must contain an alignment and a
profile.

Profile Only

Plan and Profile

1901

Sheet type

Section

Prerequisites for using plan production tools
■

You must be able to access a template that contains a
viewport with a Viewport Type defined as Plan, and a
viewport with a Viewport Type defined as Profile, such as
the Civil 3D (Imperial) Plan and Profile.dwt template located
in the Template\Plan Production folder.

■

The current drawing must contain an alignment, sample
lines, and cross sections.

■

You must be able to access a template that contains a
viewport with a Viewport Type defined as Section, such as
the Civil 3D (Imperial) Section.dwt template located in the
Template\Plan Production folder.

For more information about setting the Viewport Type in a template, see Setting Up Drawing Templates for
Plan Production (page 1902).

Setting Up Drawing Templates for Plan Production
Set up your drawing template so that each viewport is assigned the correct viewport type.
The plan production templates that are located in the Template folder have viewports that are already
configured to the appropriate viewport type: plan, profile, or section.
NOTE The templates that are preconfigured with viewport types are located in: \Template\Plan Production.
■

For Windows Vista and Windows 7 operating systems, the Template\Plan Production folder is located in:
\Users\<user name>\AppData\Local\Autodesk\C3D 2011\enu.

■

For XP operating systems, the Template\Plan Production folder is located in: \Documents and Settings\<user
name>\Local Settings\Application Data\Autodesk\C3D 2011\enu.

You can also use your own custom templates or existing AutoCAD Civil 3D templates. If you choose to use
templates other than the ones located in the Plan Production folder, an important prerequisite is that you
first set the viewport types for plan view, profile view, or section view.
While you are using the Create View Frames wizard, or the Create Multiple Views command, if you select a
template that does not have appropriately defined viewports, AutoCAD Civil 3D detects this and displays a
message indicating that layouts containing the necessary viewports for the sheet type were not found.
To prepare drawing templates for using the plan production tools
1 Open a new drawing or template.
2 Select the default settings for the template.
For example, you may want to set the default object styles and label styles for all objects, and in particular
for the plan production objects that are used for plan/profile sheets (view frame groups, view frames,
and match lines).
For information about ...

See this Help topic

General AutoCAD Civil 3D object styles

Object and Label Styles (page 66)

General AutoCAD Civil 3D label styles

Defining Label Settings (page 1654)
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For information about ...

See this Help topic

Plan production tool object styles and labels

Editing Plan Production Tool Settings (page
1913)

3 Adjust the size and scale, or other viewport settings.
4 Select the viewport that you want to display plan, profile, or section data, right-click, and then click
Properties. The Properties palette is displayed.
5 Scroll down to the Viewport section at the bottom of the Properties palette. Set the Viewport Type to
Plan, Profile, or Section.
6 Optionally, for Plan viewports, you may want to insert a north arrow block in the desired location in
the layout.
7 It is recommended that you lock the viewport(s).
8 Save the drawing as a template (.dwt).

Plan/Profile Sheet Production
Use the plan production tools to quickly create sheets that automatically display station ranges of alignments
and profiles in your plans.
Use the Create View Frames and Create Sheets wizards to create sheets that automatically display segments
of alignments and profiles in your plans. You can create view frame groups that automatically capture
predefined areas along an alignment.
Instead of manually creating many viewports on layouts to show segments of alignments, you can create
view frames that automatically capture predefined areas along an alignment. View frames are rectangular
areas along an alignment that represent what is displayed in the associated viewports on the layouts (sheets)
to be created. This automation saves you from making many manual changes when your design data changes.

View frames represent the alignment data that will be displayed in layout sheets
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The plan production tools include the following components:
■

Plan Production commands. You can access the plan production commands from the Output tab and
Plan Production contextual tab on the ribbon. The Plan Production contextual tab is displayed when
you select a view frame or a match line in the drawing.

■

Create View Frames Wizard. Start the process of using the plan production tools by using this wizard
to define a group of view frames along an alignment. For information, see Creating View Frames for
Plan/Profile Sheets (page 1904).

■

View Frame Group. The view frame group object helps you manage a single group of view frames
that are displaying consecutive station ranges along the same alignment. You can set many options at
the view frame group level, such as styles and labeling. View frame group objects are displayed in the
Prospector tree, and you can control their default command settings in the Settings tree. For information,
see The View Frame Group Object (page 1930).

■

View Frames. View frames are rectangular-shaped regions along an alignment that define an area
that will be displayed in a sheet. The view frame size, shape, and scale comes from a designated viewport
that exists on the layout tab of a specified template. After view frames are created, the properties of the
view frame objects are saved in the currently open drawing. The view frame objects are displayed in the
drawing and in the Prospector tree, and you can control their default style and labeling in the Settings
tree. For information, see The View Frame Object (page 1931).

■

Match Lines. In the AutoCAD Civil 3D plan production features, a match line is a straight line that
indicate locations in a view frame group where one view frame intersects or matches up with another
view frame. Match lines are only displayed in paper space and only in plan view. They are designed to
visually indicate the locations (start and end stations) along an alignment where each view frame begins
and ends. Match lines have their own object style and they typically include labels that can identify both
the previous and next sheet (view frame) along an alignment. You have the option to include a left side
match line label, a right side match line label, both, or none, and you can choose where along the match
line you want the label to be displayed (top, middle, end of match line). Like view frame objects, match
line objects are also displayed in the Prospector tree, and you can control their default style and labeling
in the Settings tree. For information, see The Match Line Object (page 1932).

■

Create Sheets Wizard. After you have used the Create View Frames wizard, the next step is to use
the Create Sheets wizard to quickly create your sheets. For information, see Creating Plan/Profile Sheets
(page 1909).

After you have created view frames and sheets, you can then use the Sheet Set Manager to organize, publish,
share, and manage sheet sets. For information, see “Work with Sheets in a Sheet Set” in the AutoCAD Help.
Plan/Profile Sheet Production Workflow (page 61)

Creating View Frames for Plan/Profile Sheets
Use the Create View Frames wizard to quickly create view frames along an alignment.
The view frames that are created represent rectangular areas along the alignment that will be displayed on
plan/profile or plan-only sheets.
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Before you create view frames, the desired alignment must already exist in your drawing. Depending on the
type of sheets you want to produce (plan and profile or profile only), you may also need to have a profile
already created. If you are creating a plan only view frame (or sheet set), then you do not need to have a
profile in the drawing. For information, see Preparing for Plan Production (page 1901).
You can also insert a new view frame into an existing view frame group. For information, see Inserting View
Frames (page 1922).
To create view frames
1 Click Output tab ➤ Plan Production panel ➤ Create View Frames

.

The Create View Frames wizard is displayed.
NOTE On any page of this wizard, you can click Create View Frames to create the view frames using the
default choices on the wizard pages. If a criteria is needed that has not been supplied, then the Create View
Frames button is unavailable (grayed out). You can also click the links on the left side of the wizard to go
directly to a wizard page.
2 In the Alignments page (page 2322), select an alignment.
3 In the Station Range section, choose one of the following:
■

Automatic: Selects the entire alignment. So the start station is the start station of the alignment,
and the end station is the end station of the alignment.

■

User Specified: When this is selected, you may enter a value or click
location (stations) along the alignment in the drawing area.

to specify a start and end

4 Click Next to display the Sheets page.
5 In the Sheets page (page 2323), in the Sheet Settings section, under Choose The Sheet Type You Want
To Generate, select one of the following:
Option

Result (Conceptual Image)

Plan And Profile

Creating View Frames for Plan/Profile Sheets | 1905

Option

Result (Conceptual Image)
The sheets that will be created will contain
plan views and profile views.

Plan Only

The sheets that will be created will contain
plan views only (no profile views).
Profile Only

The sheets that will be created will contain
profile views only (no plan views).

In the Template For Plan And Profile Sheet field, click
to open the Select Layout As Sheet Template
dialog box and browse to the template to use for the sheets that will be created. The template you select
must have viewports defined as plan and/or profile, depending on the sheet type selected in this dialog
box (Plan And Profile, Plan Only, or Profile Only).
6 Click OK in the Select Layout As Sheet Template dialog box.
NOTE If you select a template that does not have appropriately defined viewports for the sheet type you
select (Plan Only, Profile Only, or Plan and Profile), AutoCAD Civil 3D detects this and displays a warning
message. For more information see, Setting Up Drawing Templates for Plan Production (page 1902).
7 In the View Frame Placement section, select one of the following or accept the default:
Option

Result (Conceptual Image)

Along Alignment

The view frames will be aligned along the
alignment. Typically, this is the preferred
method for making the most efficient use
of paper when plotting.
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Option

Result (Conceptual Image)

Rotate To North

The view frames will be rotated according
to the north arrow orientation of the
drawing.

8 Optionally, you may select the check box next to the Set The First View Frame Before The Start Of The
Alignment option, and then enter a value in the value field.
This sets the distance before the start station of the alignment that the first view frame is placed. Entering
a distance here provides the specified amount of space before the selected alignment start so that the
alignment start does not coincide with the edge of the viewport. If this check box is not selected, then
this field is ignored, and the first view frame may be placed at the start of the alignment. Often the
view frame start will be as desired without altering this option.
9 Click Next to display the View Frame Group page.
10 On the View Frame Group page (page 2324), specify a name, and optionally, a description of the view
frame group object that will be created using this wizard.
11 On the View Frame section, specify a layer, name, style, and label style for the view frames.
12 In the Label Location field, choose the desired location to place the view frame labels. For example,
choosing Top Left places the view frame labels at the top left side of the view frame.
13 Click Next to display the Match Lines page.
14 On the Match Lines page (page 2325), if you chose Plan Only, you can choose to insert match lines on
the view frames by selecting the check box next to Insert Match Lines. Match lines are only displayed
in model space and in plan views. They are not displayed in profile views.
NOTE If you do not want match lines included on the plan only view frames, clear the check mark from this
option. This disables the options on this page. If you selected to create plan and profile or profile only sheets,
this check box is automatically selected, and you cannot edit it (not available, grayed out).
15 In the Positioning section, you may select one or both of the following options, and enter desired values
in the text fields. Both these options let you adjust where match lines are placed, and how they may
be moved after creation, so that they do not obstruct important drawing data.
■

Snap Station Value Down To The Nearest: When this check box is not selected (cleared), match line
positioning on the view frame is determined by using a rounding value based on derived stations.
When this check box is selected, the match lines are positioned on the view frames based on the
rounding calculation value entered. The rounding calculation always rounds down. For example, if
the calculated station for a match line is 48+37.69, then a rounding of 100 would place the match
line on 48+00.
When Snap Station Value
Down To The Nearest is set
to ...

the station will round to

100

18+00

50

18+50
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When Snap Station Value
Down To The Nearest is set
to ...

the station will round to

10

18+60

1

18+65

27+45.3 to 50

27+00 to the next lowest
multiple of 50

NOTE This option will not accept values that cause the match lines to be placed in undesirable locations,
such as before the previous match line or before the beginning of the alignment. If a rounding calculation
would result in the match line being placed in an undesirable location, then the rounding calculation is
ignored and the match lines are placed at calculated station.
■

Allow Additional Distance For Repositioning (Increases View Overlap): Because the location of match
lines is calculated automatically, it is possible that after you might need to move the match line
slightly. For example, in some cases match lines or match line labels may be obscuring data of
interest. You can use this option to increase the margin by which you can move (reposition) match
lines. Using this option will have a side-effect of increasing the overlap area of view frames. When
this check box is selected, you can move the match lines in plan view by the distance specified with
this option. This ensures that the match line remains within (between) the intersection of the two
neighboring view frames. You should enable this option if you want to be able to move the match
lines by a certain distance. Note that having this option enabled is useful if you need to force an
overlap of view frames when, on a straight line alignment, adjacent edges or sides of two view frames
are at the same location, thereby not allowing enough room for labels.

16 In the Match Line section, specify a layer, name, and style for the match lines that will be created.
17 In the Labels section, specify the labeling criteria for the match line labels, including location.
18 Click Next to display the Profile Views page.
NOTE The Profile Views page is not available (grayed out) if a sheet type of Plan Only was chosen on the
Sheet Set page of this wizard.
19 On the Profile Views page (page 2327), verify that an appropriate profile view style and band set have
been selected. If desired, you may select a different profile view style and band set.
NOTE It is important to understand that the profile view style and band set for the profile view cannot be
changed later when you are using the Create Sheets wizard to create sheets. For more information, see
Understanding Profile View Options (page 1915).
20 Click Create View Frames to create the view frames.
When the wizard has completed creating the view frames, you will notice the following:
■

The view frames and match lines are created in the drawing.

■

In the Prospector tree, the following objects are created: one view frame group, one or more view frames
in a view frames collection, one or more match lines in a match lines collection.

NOTE If the Insert Match Lines check box on the Match Lines page was not selected (cleared), then match lines
are not created.
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Now that the view frames are created, you may want to adjust the location or labels of the view frames and
match lines. See Moving View Frames (page 1919) or Moving Match Lines (page 1924) for more information.
After you are satisfied with how your view frames and match lines are positioned, the next step is to create
the sheets using the Create Sheets wizard. See Creating Plan/Profile Sheets (page 1909) for step-by-step
information.

Quick Reference
Ribbon
Output tab ➤ Plan Production panel ➤ Create View Frames
Menu
General menu ➤ Plan Production Tools ➤ Create View Frames
Toolspace Right-Click Menu
Prospector tab: right-click View Frame Groups collection ➤ Create View Frames
Command Line
CreateViewFrames
Dialog Box
Create View Frames Wizard (page 2322)

Creating Plan/Profile Sheets
Use the Create Sheets wizard to quickly create sheets for construction documents (plans).
After you have used the Create View Frames wizard to create view frames, you can create sheets automatically
using the Create Sheets wizard.
You can specify whether the sheets are created in the current drawing or in one or more new drawings.

NOTE If you choose to create sheets that display profile views, the profile views will be created and placed in the
drawing automatically in model space in the file containing the sheets.
Before you can use the Create Sheets wizard, in the drawing you must have already created a view frame
group using the Create View Frames wizard.
It is important to note that the profile view style and band set that were used during the Create View Frames
wizard are used to calculate the placement of view frames. These styles cannot be changed later for the view
frame group.
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To create sheets
1 Click Output tab ➤ Plan Production panel ➤ Create Sheets

.

NOTE On any page of this wizard, you can click Create Sheets to create the sheets using the default choices
on the wizard pages. If a criteria that is needed that has not been supplied, then the Create Sheets button is
not available (grayed out). You can also click the links on the left side of the wizard to go directly to a wizard
page.
2 On the View Frame Group And Layouts page (page 2327), select a view frame group from the list.
NOTE As a reminder, the sheet type that was selected for this view frame group is displayed beneath the
View Frame Group list.
3 For View Frame Range, all view frames are selected for processing by default, but you can choose a single
view frame, or multiple view frames from the group by clicking Selection and then clicking the Choose
View Frames button.
4 In the Layout Creation section, choose how the layouts will be created. A conceptual image on the
right side of the wizard page provides an indication of the result.
Option

Description

Number Of Layouts Per New Drawing (1)

This option may be an appropriate choice
if you plan to have several people working
on individual sheets. When this option is
selected, and you enter 1 for the value,
one new layout (sheet) is created in each
new drawing. The total number of sheets
and drawings depends on the length of
the alignment selected and other criteria,
such as the size of the viewports in the
referenced template.

Number Of Layouts Per New Drawing (>1)

If you choose this option and enter a value
greater than 1 (3, for example), then 3
new layouts are created in each new
drawing. The total number of sheets and
drawings depends on the length of the
alignment selected and other criteria, such
as the size of the viewports in the referenced template.

All Layouts In One New Drawing

This option may be an appropriate choice
if having each individual layout in a separate drawing is not necessary for you, and
if you have less than 10 sheets. You may
place all the layouts in one newly created
drawing. The total number of sheets depends on the length of the alignment selected and other criteria, such as the size
of the viewports in the referenced template. For optimal results, it is recommended that you create no more than 10
sheets per drawing. Therefore, this option
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Option

Description
may not be the best choice if you have
more than 10 sheets.

All Layouts In The Current Drawing

If you are generating less than 10 sheets,
you may want to generate the layouts in
the current drawing. The total number of
sheets depends on the length of the
alignment selected and other criteria, such
as the size of the viewports in the referenced template.

NOTE For optimal results, it is recommended that you create no more than
10 sheets per drawing. Therefore, this
option may not be the best choice if
you have more than 10 sheets.

5 Specify a name for the layouts or accept the default naming template.
6 Optionally, you can use the Choose The North Arrow Block To Align In Layouts option to automatically
align a north arrow block in the sheet(s). Any blocks that exist in the referenced template (.dwt) are
displayed in the drop-down list. If no blocks exist in the referenced template, the list displays None. If
you select a block from this list, that block will be aligned to the north on the sheet(s).
7 Click Next to display the Sheet Set page.
8 On the Sheet Set page (page 2328), do one of the following:
■

If you want to manage the sheets using the Autodesk Vault project management features, and you
are already logged in to the desired vault, the Add Files To Vault is automatically selected.

■

If you want to manage the sheets using the Autodesk Vault project management features, and you
are not logged in to the desired vault, click Log In To Vault ..., log in to the desired project, and
then return to the Sheet Set page and click Add Files To Vault.

■

If you do not want to manage the sheets using the Autodesk Vault project management features,
make sure the Add Files To Vault check box is not selected (cleared).

NOTE If you choose to manage sheets using the Autodesk Vault project management features, the sheet set
file (.dst), and the sheet files (.dwg), will be added to the vault project you selected. If Autodesk Vault is not
currently installed on the machine you are using, these options are not available (grayed out and not available
for edit).
9 In the Sheet Set section, select either New Sheet Set or Add To Existing Sheet Set.
10 In the Sheet Set File (.DST) Storage Location field, specify a location where the sheet set file (.dst) will
be stored. If you selected Add To Existing Sheet Set, this field displays the path of the sheet set file for
the sheet set selected in the Add To Existing Sheet Set field. If you want to use the Sheet Set Manager
later to manage this sheet set, you will need to know this location and filename.
11 In the Sheets section, specify a storage location and name for the sheet file(s) that will be created during
this wizard session. If you have chosen to save all sheets in the current drawing (the All Layouts In The
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Current Drawing choice on the Create Sheets wizard View Frame Group and Layouts page), these fields
are not available (read only, grayed out).
■

Sheet Files Storage Location: Specifies the location where the sheet files created during this session
will be located. Click
to select a location. If you are logged in to a project in Vault, by default
this path displays the root folder for the project. If you are not logged in to a project in Vault, by
default this path is set to the directory containing the working (current) drawing.

■

Sheet File Name: Specifies the name of the sheet file(s) that will be created.

12 Click Next to display the next page in the wizard sequence. If the view frames do not include any profile
views, then the Profile Views page of the Create Sheets wizard is not available, and the Data References
page is displayed next.
13 On the Profile Views page (page 2329), you can specify additional settings for profile views. Note that the
profile view style and the band set that were selected during view frame creation cannot be changed at
this stage; however, the current profile view style and band set that will be used are displayed as read-only
on this page. Only additional settings relating to profile views (Other Profile View Options) can be
changed at this part of the process. For more information, see Understanding Profile View Options
(page 1915).
NOTE If you need to change these profile view or band set style settings, you must cancel out of the Create
Sheets wizard and recreate the view frames, using the updated style choices for the profile views and/or the
band sets.
14 In the Other Profile View Options section, you can get other settings from an existing profile view, or
you can choose settings by launching the Profile View wizard at this point (from this page of the Create
Sheets wizard). If you choose to launch the Profile View wizard from the Create Sheets wizard, you will
be returned to the Profile Views page of the Create Sheets wizard when you are finished selecting profile
view options.
15 If you are creating plan and profile sheets, you can choose how to align the data that is displayed in
the plan and profile views using the Align Views options. If you are creating plan only or profile only
sheets, these options are not available. These options are useful on projects that require the data displayed
in sheets to be aligned according to certain project requirements (such as aligned left, center, or right).
■

Align Profile And Plan View At Start: When this option is selected, the left side (start station) match
line in the plan view aligns with the left side (start) of the profile view.

■

Align Profile And Plan View At Center: When this option is selected, the center of the plan view
aligns with the center point of the profile view.

■

Align Profile And Plan View At End: When this option is selected, the right side (end station) match
line in the plan view aligns with the right side (end) of the profile view.

16 Click Next to display the Data References page.
NOTE The Data References page is not available if you chose All Layouts In The Current Drawing in the
Layout Creation section of the View Frame Group and Layout page.
17 On the Data References page (page 2330), you can select or omit the data you want to be included in your
sheets. Select the check box next to the data references you want displayed in the sheets. Some references
cannot be removed from the selection, such as the alignment and profile associated with these sheets.
If you are including pipe networks in the destination drawing(s), you may want to check the Copy Pipe
Network Labels To Destination Drawings to also copy the labels associated with any selected pipe
networks.
18 Click Create Sheets to create the sheets.
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19 If you selected to create sheets containing profile views, you are prompted to select an insertion point
in model space to create the profile views. Click a location in the drawing (model space) to insert the
profile views.
You will only see profile views in the current drawing if you selected the All Layouts in the Current Drawing
option in the Layout Creation section of the View Frame Group and Layout page.
Depending on your Event Manager settings, Event Manager messages may inform you of the location of the
sheet sets, as well as the number of layouts created.
Once the sheets are created, the Sheet Set Manager automatically displays, showing the newly created sheets
in a sheet set. For more information about the Sheet Set Manager, see the Sheet Set Manager Help topics in
the AutoCAD Help.

Quick Reference
Ribbon
Output tab ➤ Plan Production panel ➤ Create Sheets
Menu
General menu ➤ Plan Production Tools ➤ Create Sheets
Command Line
CreateSheets
Dialog Box
Create Sheets Wizard (page 2327)

Editing Plan Production Tool Settings
Use view frame group settings to specify the default behavior for plan production tool commands.
Settings are handled in a standard way throughout AutoCAD Civil 3D. You access settings using the Toolspace
Settings tree. You can control settings at three levels: the drawing level, the object collection (feature) level,
and the command level. For more information, see Understanding Settings (page 77).
Use the Settings tree View Frame Group collection shortcut menu to establish defaults for all plan production
tool commands. You can change plan production tool-specific settings at this level, or override the drawing
ambient settings.
Use the Commands collection in the View Frame Group collection to change plan production tool settings
for a specific command.
NOTE Overrides to the drawing ambient settings at the View Frame Group collection level and the Commands
collection level affect only the specified level. The drawing level settings are not changed.
The topics in this section describe only those settings that affect plan production tool-related commands.
They do not apply to the drawing ambient settings that you can change at the View Frame Group collection
level and the View Frame Group command level, even though those settings are displayed in the Edit Feature
Settings - View Frame Group dialog box. For more information about the drawing ambient settings, see
Specifying Ambient Settings (page 84).
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Changing Plan Production Tool Creation Settings
Use the plan production tool creation and naming settings in the View Frame Group Settings (page 2319)
dialog box to change plan production tool settings before you create view frames or sheets.
For example, before using the Create View Frames wizard, you should specify the default choices you want
to use for plan production object names (object name format) and label styles. This will set your defaults
for plan production objects (view frame groups, view frames, and match lines).
If a closed lock appears in the Lock column for a property, the property is locked at a higher level of the
Settings tree. It cannot be changed at this level.
If you change a property value, a check mark is placed in the Override column. This override is also noted
in the property table for related objects higher up the Settings tree, where an arrow is displayed in the Child
Override column.
To change plan production tool creation settings
1 Do one of the following:
■

To edit settings for all plan production tool commands: In Toolspace, on the Settings tab, right-click
the View Frame Group collection. Click Edit Feature Settings. Do the same for the View Frame and
Match Line collections on the Settings tab.

■

To edit settings for a specific command: In Toolspace, on the Settings tab, expand the View Frame
Group collection. Expand the Commands collection. Right-click the name of a command and click
Edit Command Settings. For example, right-click the CreateSheets command and click Edit Command
Settings.

The Edit Feature Settings (page 2319) dialog box is displayed.
2 To specify the default sheet creation and view frame creation options, right-click either the CreateSheets
or CreateViewFrames commands and click Edit Command Settings.
3 To edit the default naming format for plan production tool objects (such as view frame groups, view
frames, and match lines), expand the Default Name Format property group. Edit the Name Template
settings for each item.
4 Click Apply.

Quick Reference
Toolspace Shortcut Menu
Settings tab: Right-click View Frame Group collection ➤ Edit Feature Settings
OR
Settings tab: Right-click View Frame collection ➤ Edit Feature Settings
OR
Settings tab: Right-click Match Line collection ➤ Edit Feature Settings
OR
Settings tab: View Frame Group ➤ Commands ➤ Right-click <command-name> ➤ Edit Command
Settings
Dialog Box
Edit Feature Settings (View Frame Group) (page 2319)
Edit Feature Settings (View Frame) (page 2322)
Edit Feature Settings (Match Line) (page 2322)
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Changing Plan Production Tools Default Style Settings
Use the view frame group settings to specify default styles and labels for view frame and match line creation.
The default styles specified in these settings are used to establish the default settings for the styles in the
Create View Frame wizard, the View Frame Group Properties dialog box, the View Frame Properties dialog
box, and the Match Line Properties dialog box.
To change the plan production tool objects style and label settings
1 In Toolspace, on the Settings tab, right-click the View Frame Groups collection. Click Edit Feature
Settings to open the View Frame Group Settings (page 2319) dialog box.
2 Expand the Default Styles property group.
3 To specify default styles for plan production tool objects (view frames and match lines), click the
corresponding field. Click

to open the Select Style dialog box.

4 To specify a default view frame or match line style, click View Frame Style or Match Line Style. Click
to open the Select Style dialog box.
5 To specify a default style for view frame or match line labels, click the corresponding field. Click
open the Select Label Style dialog box.

to

6 To specify a default location for view frame or match line labels, click the corresponding field and select
a location in the drop-down list.
7 Click Apply.

Quick Reference
Toolspace Shortcut Menu
Settings tab: right-click View Frame Group collection ➤ Edit Feature Settings
Dialog Box
View Frame Group Settings (page 2319)

Understanding Profile View Options
When using the plan production wizards, it is important to understand how profile view options affect the
data displayed in profile views.
Sizing of the profile view in the viewport requires information from the profile view style and band set.
Together these items determine the extents of the data that will be presented in the viewport. Because the
profile view style and the band set determine the extent of the data presented in the view port, these items
must be configured as desired before starting the Create View Frames wizard, and then selected at the time
that the view frames are created (when using the Create View Frames wizard).
There are other profile view settings, however, that can be specified during the creation of the profile view,
or rather, while using the Create Sheets wizard. These settings include split profile view options, profile
display options, pipe network display options, and data band information.
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Changing these settings is not required until the profile views are actually created. These profile view settings
can be specified in one of two ways on the Profile Views page of the Create Sheets wizard. These two different
methods of changing profile view information during view are described in the following table.
Method of changing profile view information

Description

Selecting an existing profile view

Selecting an existing profile view does not override
the profile view style and band set information used
when the view frames were created.

Using the Create Multiple Profile View wizard

Using this option will allow you to step through the
Create Multiple Profile View wizard with several
values pre-populated (some of which cannot be
changed, such as style, station range, etc.).
The options that will either be extracted from the
selected profile view, or gathered from the Create
Multiple Profile View wizard, and subsequently used
in creating profile views for sheets include:
■

split profile view options

■

profile display options

■

pipe network display options

■

data band (band set) information

If desired, you can select an existing profile view when you are using the Create View Frames wizard, and
then, when you are using the Create Sheets wizard, you can modify that profile view using the Multiple
Profile View wizard.

Using View Frame Groups
Create view frame groups using the Create View Frames wizard.
After view frame groups are created, you can edit certain properties of the view frame group, or delete it.
Although you can move view frames and match lines within a view frame group, view frame groups themselves
are not designed to be moved as an entity.
You can delete individual view frames within a view frame group. You can also delete the entire view frame
group. Deleting the entire view frame group object automatically deletes all the view frames and match lines
associated with it.
NOTE View frame groups are not dynamically associated with the sheet files that are created from them. Updating
a view frame group, moving match lines, or moving view frames will not affect the sheet files. The same is true
with the sheet files created from the view frame groups. Updating the sheet files has no impact on the view frame
groups.
After a view frame group is created, you can delete the alignment from which it was created, if you need to.
Labeling functionality, such as the ability to display the sheet number in labels in the view frames, is still
maintained even if the original alignment from which the view frame group was created is deleted.

Creating View Frame Groups
Use the Create View Frames wizard to create view frame groups.
On the third page of the Create View Frames wizard—the View Frame Group page—you specify the object
creation criteria for the view frame group object. For example, you enter a name for the view frame group

1916 | Chapter 47 Plan Production Tools

object, and you can select the layer for the view frames. For more information see, View Frame Group page
(page 2324) of the Create View Frames wizard.
Note that you can also create a reference to an existing view frame group data shortcut. For more information,
see Creating a View Frame Group Reference (page 1917).
You can also insert a new view frame in to an existing view frame group. See Inserting View Frames (page
1922) for more information.

Creating a View Frame Group Reference
You can create a reference to an existing view frame group in a data shortcut (page 2772) or a Vault project.
The view frame group reference is a lightweight read-only copy of the original. By means of data references,
you can reuse a view frame group among several drawings to create consistency in the plan production
sheets. Before you create the view frame group reference, it must exist in the current project collection on
the Toolspace Prospector tab.
Before you create a view frame group reference, you must first create a reference to the related alignment.
See also:
■

Creating Data Shortcuts (page 151)

■

Vault: Checking a Drawing in to a Project (page 179)

To create a reference to a data shortcut view frame group
1 In Toolspace, on the Prospector tab, ensure that the correct project folder is identified on the Data
Shortcuts node.
2 Expand the Data Shortcuts ➤ View Frame Groups collection, right-click the desired group, and then
click Create Reference.
The Create View Frame Groups Reference dialog box is displayed, in which you can optionally change
properties of the reference view frame group, as described in the following steps.
3 In the Create View Frame Group Reference dialog box, to change the source of the reference, select the
source in the Source View Frame Group list.
4 Enter a unique name for the view frame group and optionally, a description.
5 For the view frames and match lines included in this view frame group, you can specify a style, label
style, and layer, or accept the defaults.
6 Click OK to create the view frame group reference.
In the Prospector tree, the view frame group reference is displayed under the View Frame Groups
collection with a

next to it.

To create a reference to a view frame group in a Vault project
1 In Toolspace, on the Prospector tab, in Master View, expand the Projects ➤ <project name> ➤ View
Frame Groups collection, right-click the desired view frame group, and then click Create Reference.
The Create Surface Reference dialog box is displayed, in which you can optionally change properties
of the reference group, as described in the following steps.
2 In the Create View Frame Group Reference dialog box, to change the source of the reference, select the
source in the Source View Frame Group list.
3 Enter a unique name for the view frame group and optionally, a description.
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4 For the view frames and match lines included in this view frame group, you can specify a style, label
style, and layer, or accept the defaults.
5 Click OK to create the view frame group reference.
In the Prospector tree, the view frame group reference is displayed under the View Frame Groups
collection with a

next to it.

Quick Reference
Toolspace Right-Click Menu (for data shortcut project)
Prospector tab: Data Shortcuts ➤ View Frame Groups ➤ <view frame group name> ➤ Create Reference
Toolspace Right-Click Menu (for Vault project)
Prospector tab: Projects ➤ <project name> ➤ View Frame Groups ➤ <view frame group name> ➤ Create
Reference
Command Line
CreateViewFrameGroupReference (for use only with view frame groups in Vault)
Dialog Box
Create View Frame Group Reference (page 2454)

Editing View Frame Groups
You can edit certain properties of a view frame group, or add a new view frame to a view frame group.
For example, you can change a view frame group’s object name, description, or the style of the view frames
and match lines, as well as the layers on which they are displayed. For more information, see the View Frame
Group Properties dialog box (page 2333).
For information on adding a view frame to a view frame group, see Inserting View Frames (page 1922).
The following restrictions apply to editing view frame groups:
■

Although you can move view frames and match lines within a view frame group, view frame groups
themselves are not designed to be moved as an entity.

■

You can delete an entire view frame group, which deletes all view frames, match lines, and labels associated
with the group.

■

You can delete individual view frames or match lines within a view frame group.

Deleting View Frame Groups
Deleting a view frame group also deletes all view frames, match lines, and labels associated with that view
frame group.
Any sheets or sheet sets that have already been created from that view frame group are not affected.
If you explode one or more view frames or match lines, all view frames and match lines in that view frame
group are exploded, and the following objects are deleted: view frames, match lines, and the view frame
group.
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To delete a view frame group
1 Click a view frame in the group. Click Plan Production tab ➤ Modify View Frame panel
Group

Delete

.

2 The view frame group, and all view frame and match line objects belonging to it, are removed from
the View Frame Groups collection on the Prospector tab. The view frames and match lines are
automatically removed from the drawing.

Quick Reference
Ribbon
Click a view frame in the group. Click Plan Production tab ➤ Modify View Frame panel

Delete Group

Toolspace Right-Click Menu
Prospector tree: Right-click View Frame Groups collection ➤ View frame group ➤ Delete
Command Line
DeleteViewFrameGroup

Editing View Frames
You may want to edit view frame styles, view frame label styles, or edit, move or delete view frames or their
labels.
Like other AutoCAD Civil 3D objects, you can edit certain properties of a view frame. For example, you can
change a view frame’s object name, description, object style, or the layer on which it is displayed.
View frame objects are displayed in the Prospector tree, and you can control their default style and labeling
from the View Frame collection in the Settings tree. For more information, see the View Frame Properties
dialog box (page 2331).
View frames can include a label that displays the information you want. For example, you may want your
view frame labels to identify the area along the alignment it is displaying, or reference more specific data
from that area.
You can move or rotate a view frame, but you cannot resize it. You can also insert or delete view frames
within a view frame group.

Moving View Frames
After view frames are created, they can be moved or rotated using grips.
The center, slider, and rotation grips on the view frame enable you to move or rotate it.
Although you can move or rotate view frames, you cannot change the size of a view frame. This is because
the view frame’s size is based on the size of the viewport it references in the associated template.
You will notice that when you move a view frame, the view frame stays attached to the alignment it is
associated with. If a view frame is moved off the alignment, and you want to reattach it to the alignment,
be certain that OSNAPS are turned on, and you can drag the center grip towards the alignment. When you
move a view frame that has a view frame label on it, the label moves with the view frame.
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Moving a view frame does not move any match lines associated with that view frame. When moving a view
frame, the match lines associated with the view frame stay positioned where they intersect the alignment,
and do not move.
If you need to move view frames after sheets have been created, instead of moving the view frames, you
should make these changes to the sheet by editing the viewport. If you move view frames after sheets have
been created, these changes will not be reflected in any sheets that have already been created from the view
frames. In order to see those changes reflected in the sheets, you will have to recreate the sheets.
If the alignment associated with a view frame has been deleted, the view frame remains, but the slider grip
is no longer displayed, and the view frame can be moved in any direction.
Also, if the view frame is set to align with a north arrow block in the drawing, the rotation grip is not
displayed.
For more information about grips, see “Using Grips to Edit Objects” in the AutoCAD Help.
To move or rotate view frames using grips
1 In either model space, click the view frame you want to move or rotate.
2 Click one of the following grips on the view frame:
■

■

■

Center grip: Moves the view frame freely in any direction.
Slider grip: Moves the view frame forward or backward along the alignment. If the view frame
is moved off the alignment, the offset to the alignment is maintained. If the view frame remains
parallel to the tangent to the alignment, the grips stay on alignment.
Rotation grip: Rotates the view frame about the center of the view frame.

NOTE If the view frame is set to align with a north arrow block in the drawing, the rotation grip is not
displayed (not available).
3 Drag the grip to move or rotate the view frame.

Deleting View Frames
You can delete a view frames in a view frame group, or delete the entire view frame group.
You can delete a view frame in a view frame group. Or you can delete all view frames within a view frame
group by deleting the entire view frame group in Prospector. Deleting a view frame group deletes all view
frames and match lines within a view frame group, in addition to deleting the view frame group object as
well.
When you delete a view frame group, any sheets and/or sheet sets that may have already been created by
the view frame group are not affected.
If you explode one or more view frames or match lines, all view frames and match lines in that view frame
group are exploded, and the following objects are deleted: view frames, match lines, view frame group.
NOTE When two view frames share a common match line, and you delete one of the view frames, the shared
match line is not removed.
For more information, see Deleting View Frame Groups (page 1918).
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To delete a single view frame
■

In the Prospector tree, expand the desired View Frame Group object, then right-click a view frame and
click Delete.
The view frame and its associated match line object(s) are removed from the View Frames and Match
Lines collections in the Prospector tree, and in the drawing.
NOTE When two view frames share a common match line, and you delete one of the view frames, the shared
match line is not removed.

Labeling View Frames
You can include or omit labels on view frames, specify their location, and you can design and specify view
frame label styles that suit your needs.
Use the View Frame Group page in the Create View Frames wizard to select a label style and label location
for view frames in a view frame group.
If you do not want labels on a view frame, you can turn off the visibility of the labels in the label style.
Use the Label Location options on the View Frame Group page in the Create View Frames wizard to select
where the view frame labels will be placed. For example, selecting Top Left places the view frame label at
the top left corner of the view frame.
You can delete view frame labels. Selecting any view frame label automatically selects all view frame labels
associated with that view frame group. You can delete all view frame labels in a view frame group by selecting
them and pressing the Delete key. To delete individual labels, Ctrl-click on a label to select it and press
Delete.
In the View Frame collection in the Toolspace Settings tree, you can create and edit view frame label styles.
See Creating and Editing Label Styles (page 1656) for more information.
To edit view frame label styles
1 In the Settings tree, expand the View Frame collection, and then expand the Label Styles collection.
2 Double-click the Standard label style.
3 Use the Label Style Composer to edit the default Standard view frame label style, or create your own
custom label style for view frames.
To edit existing view frame labels
1 In the drawing, do one of the following:
■

to select all view frame labels in a view frame group, click on any view frame label

■

to select a single view frame label, use Ctrl + left-click on a view frame label

2 Right-click and select Edit Labels on the right-click shortcut menu.
3 Use the Edit View Frame Labels dialog box to select a different label style, create a new label style, edit
the existing label style, or change the label location.
To reset view frame labels
1 In the drawing, do one of the following:
■

to select all view frame labels in a view frame group, click on any view frame label

■

to select a single view frame label, use Ctrl + left-click on a view frame label
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2 Right-click and select Reset Labels on the right-click shortcut menu.

Quick Reference
Toolspace Shortcut Menu
Settings tab: View Frame ➤ Label Styles
Command Line
EditViewFrameLabels
Dialog Box
Label Style Composer Dialog Box (page 2180)

Inserting View Frames
You can insert a new view frame into a view frame group.
In most cases, the new view frame is inserted before the selected view frame.

You can insert a new view frame by
■

right-clicking on a view frame and clicking Insert View Frame

■

entering the InsertViewFrame command and specifying an insertion point in the drawing

Each of these methods is described below.

Right-clicking on a View Frame and Clicking Insert View Frame
When you insert a new view frame by right-clicking on an existing view frame and clicking Insert View
Frame, or if you use the InsertViewFrame command and select an existing view frame, the new view frame
is inserted as follows:
■

If there is no gap (blank space) between the selected view frame and its previous view frame, the new
view frame is inserted before the selected view frame (towards the beginning of the alignment).

■

If there is a gap (blank space) between the selected view frame and its previous view frame, the new view
frame is inserted by finding the center (at the alignment) of the two match lines, and inserting the new
view frame centered on this point. If the selected view frame is the first view frame in the view frame
group, and therefore, has no left match line, a new left match line is created.

1922 | Chapter 47 Plan Production Tools

Specifying an Insertion Point in Drawing
When you insert a new view frame by using the InsertViewFrame command and you enter S to specify an
insertion location, the following rules are used:
■

If the selected point is a valid location for a view frame, the new view frame is inserted, centered in the
selected point.

■

If the selected point is not a valid location for a view frame, a message indicates that the location is not
valid for view frame insertion, and the new view frame is not inserted.

A valid location is some other point along the alignment, or close to the alignment.
To insert a view frame into a view frame group
■

In the drawing area, right-click on a view frame and click Insert View Frame.

The new view frame is inserted.

Quick Reference
Drawing Area Shortcut Menu
Right-click <view frame object> ➤ Insert View Frame
Command Line
InsertViewFrame

Editing Match Lines
You can edit match line styles, match line label styles, or edit, move or hide match lines or their labels.
Like other AutoCAD Civil 3D objects, you can edit certain properties of a match line. For example, you can
change a match line’s object name, description, object style, or the layer on which it is displayed. Match
line objects are displayed in the Prospector tree, and you can control their default style and labeling in the
Match Line collection in the Settings tree. For more information, see the Match Line Properties dialog box
(page 2332).
Match lines can include a label containing information that you want. For example, you may want your
match line labels to identify the previous and next sheet (view frame).
You can edit a match line length using grips, or move match lines. Use the options on the Match Lines page
of the Create View Frames wizard to control how match lines are positioned on alignments, and by how
much distance match lines can be repositioned (moved) after you create them.
The only way match lines can be deleted is to delete the view frame, or the view frame group, it belongs to.
Use the match line style to hide the visibility of match lines if you do not want them to display. For more
information, see Deleting Match Lines (page 1926).

Editing the Match Line Mask Area
The Match Line Style (page 2337) dialog box contains options for setting a hatch pattern in the mask area.
The mask is displayed in paper space in the area between the outside of a match line and the inside boundary
of the view frame, indicated by the dark shaded areas in the following illustration:
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The match line mask area is the area that exists between the outside of a match line and the inside border
or boundary of the view frame. On the Display tab of the Match Line Style dialog box, there is an option to
set the hatch pattern for this match line mask area.
Match line labels are displayed on top of the match line mask area, and are therefore visible over it.
To edit the match line mask area
1 In the Settings tree, expand the Match Line collection, and then expand the Match Line Style collection.
2 Double-click a match line style to open the Match Line Style dialog box.
3 Click the Display tab.
4 Select a View Direction (2D or 3D). You can set different hatch patterns for 2D and 3D.
5 In the Component Hatch Display section at the bottom, click the current value for Pattern. The Hatch
Pattern dialog box is displayed.
6 Select a hatch type from the list. Optionally, you may browse to another hatch pattern palette. For
more information about hatch patterns, see “Overview of Hatch Patterns and Fill” in the AutoCAD
Help.
7 Click OK in the Hatch Pattern dialog box.
8 Optionally, you may specify Angle and/or Scale.
9 Click either Apply or OK on the Display tab of the Match Line Style dialog box.

Quick Reference
Toolspace Shortcut Menu
Settings tab: Expand Match Line ➤ Match Line Styles collection ➤ right-click style name ➤ Edit
Command Line
EditMatchLineStyle

Moving Match Lines
You can move match lines in plan view if you have enabled the match line repositioning option during
view frame creation.
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The following match line positioning options are displayed on the Match Lines page in the Create View
Frames wizard:
■

Snap Station Value Down To The Nearest

■

Allow Additional Distance For Repositioning (Increases View Overlap)

Snap Station Value Down to the Nearest
When the Snap Station Value Down To The Nearest check box is selected, match line positioning is determined
by using the value entered in the Distance field, which is in drawing units.
The rounding calculation always rounds down. The following table lists examples of this calculation based
on the value entered.
When Snap Station Value The station rounds to
Down To The Nearest is
set to ...
100

18+00

50

18+50

10

18+60

1

18+65

27+45.3 to 50

27+00 to the next lowest multiple of 50

NOTE This option will not accept values that cause the match lines to be placed in undesirable locations, such as
before the previous match line or before the beginning of the alignment. If a rounding calculation would result
in the match line being placed in an undesirable location, then the rounding calculation is ignored and the match
lines are placed at calculated station.
When this check box is not selected (cleared), match line positioning on the view frame is determined by
using a rounding value based on derived stations.

Allow Additional Distance For Repositioning (Increases View Overlap)
When this check box is selected, you can move match lines within a specified limit. Enabling this option
can also be used to force an overlap of frames in plan sheets only when, on a straight line alignment for
example, adjacent edges of two view frames might be coincident, and therefore not provide enough room
on either side of the match line for labeling and notes.
Note that the value entered here is the total distance that is removed from the calculated distance between
match lines. It will allow for match lines to be moved apart to the total calculated distance. However,
AutoCAD Civil 3D will not allow you to enter a distance that is greater than the view frame width.
To move match lines
1 In either model space or paper space, click the match line you want to move.
2 Click one of the following grips on the match line:
■

Center grip: Moves the match line freely in any direction.

■

Slider grip: Moves the match line forward or backward along the alignment.

■

Rotation grip: Rotates the match line about the center of the match line.
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3 Drag the grip to move or rotate the view frame.

Deleting Match Lines
Match lines are deleted automatically when you delete a view frame or view frame group.
After match lines are created, the only way to delete them is to delete the view frame, or view frame group
object they belong to. For more information, see Deleting View Frames (page 1920) or Deleting View Frame
Groups (page 1918).
If you explode one or more match lines or view frames, all match lines and view frames in that view frame
group are exploded, and the following objects are deleted: match lines, view frames, view frame group.
You can delete match line labels. Selecting any match line label automatically selects all match line labels
in that view frame group. To delete them individually, select them by using Ctrl + click, and then press the
Delete key.
If you do not want match lines to display, change the display style so that the match line component’s
visibility is turned off. For more information, see Match Lines Styles and Display (page 1933).

Labeling Match Lines
You can insert or omit labels on match lines, specify label location, and design and specify match line label
styles that suit your needs.
Use the Match Lines page of the Create View Frames wizard to select a label style and label location for the
left and right side match lines.
If you do not want labels to be displayed on match lines, turn off their visibility using the match line label
style.
Use the Left Label Location and the Right Label Location options on the Match Lines page in the Create
View Frames wizard to select where the match line labels will be placed. Select from the following locations:
■

Start: Places the match line label at the start of the match line, near the top of the view frame.

■

End: Places the match line label at the end of the match line, near the bottom of the view frame.

■

Middle: Places the match line label at the middle of the match line.

■

Alignment Intersection: Places the match line label where the alignment intersects the match line.

In the Match Line collection in the Toolspace Settings tree, you can create and edit match line label styles.
For the match line text component, by default you can select from the following properties to add to a
match line label:
■

Match Line Name

■

Match Line Number

■

View Frame Group Alignment Name

■

View Frame Group Name

■

Match Line Station Value

■

Match Line Raw Station Value

■

Previous Sheet Number

■

Next Sheet Number
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NOTE If you use the Previous Sheet Number or the Next Sheet Number properties in your match line labels, this
information displays as “####” in the match line label until the sheets are generated. After the sheets are generated,
the match line label is populated with appropriate sheet number information.
See Creating and Editing Label Styles (page 1656) for more information.
To edit match line label styles
1 In the Settings tree, expand the Match Line collection, and then expand the Label Styles collection.
2 Expand the Match Line Left collection. Double-click the Standard label style.
3 Use the Label Style Composer to edit the default Standard match line label style, or create your own
custom label style for the left side match line.
4 Repeat step 3 for the right side match line label.
To edit existing match line labels
1 In the drawing, do one of the following:
■

to select all match line labels in a view frame group, click on any match line label

■

to select a single match line label, press and hold the Ctrl key while clicking on a match line label

2 Right-click and select Edit Labels on the right-click shortcut menu.
3 Do one of the following:
■

use the Edit Match Line Group Labels dialog box to edit labels for all match lines in the view frame
group

■

use the Edit Match Line Label dialog box to edit a single match line label

You can select a different label style, create a new label style, edit the existing label style, or change the label
location for the selected match lines.
To reset match line labels
1 In the drawing, do one of the following:
■

to select all match line labels in a view frame group, click on any match line label

■

to select a single match line label, press and hold the Ctrl key while clicking on a match line label

2 Right-click and select Reset Labels on the right-click shortcut menu.

Quick Reference
Toolspace Shortcut Menu
Settings tab: Match Line ➤ Label Styles ➤ Match Line Left
Settings tab: Match Line ➤ Label Styles ➤ Match Line Right
Dialog Box
Label Style Composer Dialog Box (page 2180)

Labeling Plan Production Tool Components
By default, view frames and match lines contain standard object labels.
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If you want view frames and match lines to be displayed without labels, you can delete the labels or turn
off the visibility of the label.
The View Frame Group page of the Create View Frames wizard contains the option for setting the view frame
labels, and the Match Lines page contains the option for setting match line labels.
In the drawing, there are no labels for view frame group objects. However, since the view frame group object
is the parent object for view frames, you can set label defaults for view frames using by View Frame Group
collection in the Toolspace Settings tree. Right-click View Frame Group in the Settings tree, and click Edit
Label Style Defaults on the shortcut menu. The Edit Label Style Defaults - View Frame dialog box is displayed.
For more information, see Edit Label Style Defaults Dialog Box (Feature Level) (page 2179).
On the Toolspace Settings tab, in the View Frame ➤ Label Style collection, set up label styles to use for
view frames. Do the same for match lines using the Match Line ➤ Label Style collection.
See also:
■

Labeling View Frames (page 1921)

■

Labeling Match Lines (page 1926)

Using Vault with Plan Production Tools
This section describes how to use Autodesk Vault with plan production tools.
You may want to manage the objects and files that are both consumed (used) by and created from the plan
production tools with Autodesk Vault. If you choose to do so, you will be using an efficient mechanism for
maintaining your organization’s standards for plan set drawing templates.
If you choose to use Autodesk Vault with the plan production features, the following files associated with
plan production will be added to the selected project in Autodesk Vault:
■

sheet set data file (.dst),

■

the current drawing (.dwg)

If you are saving sheets to the current drawing file, and the current drawing file is already in the vault, that
drawing file cannot be checked in to vault automatically. This must be done by you.
The Add To Autodesk Vault check box is not available for editing (grayed out) when sheets are being saved
to the current file. In other words, when All Layouts In The Current Drawing is selected on the View Frame
Group And Layouts page in the Create Sheets wizard, the Add To Autodesk Vault option is also not available
(grayed out).

Using Data References with Plan Production Tools
You can use data references with plan production tools.
When using the Create Sheets wizard, you can select the objects in the drawing that you want to include
or exclude from the resulting sheets.
To do this, use the Data References page in the Create Sheets wizard, where you can select the objects that
you want to be referenced in the sheets. You can select the following object types:
■

surfaces

■

alignments

■

profiles
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■

pipe networks

When you select an object by placing a check mark next to it, a data reference (data shortcut) to that object
is created in the sheet. This provides a way for you to include or exclude certain objects from the sheets.
Including data references in your sheets instead the actual data ensures that the geometry of the source data
can be modified only in the source drawing, not in the resulting sheet drawing. However, display styles and
labels for the reference object can be modified in the sheet drawing.
Another benefit of using data references is that if the source data objects change, the information displayed
in the sheets dynamically updates.
For more information, see Using Data Shortcuts (page 145).

Plan Production Tools Object Styles and Display
Object styles control how plan production tool objects (view frames and match lines) are displayed.
The following illustration shows the view frame and match lines collections in the Settings tree:

The following table describes the display styles available for the plan production tools components:
Plan Production Tool Object
View Frames

Match Lines

View Frame Group

Display and labeling styles available
View frame style and view frame label style

Match line style and match line label style

View frame groups are non-graphical objects that
manage a collection of view frames and match
lines. At the view frame group level, you can set
the display and label style defaults for view frames
and match lines.

For more information about styles, see Object and Label Styles (page 66), View Frame Style dialog box (page
2336) and Match Line Style dialog box (page 2337).
For more information about labeling for view frames and match lines, see Labeling View Frames (page 1921),
and Labeling Match Lines (page 1926).
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Before creating view frames and view frame groups, you should be familiar with creating and managing
styles (page 66).
The top-level plan production tool object, the view frame group object, has command-level settings that
can be configured from the Settings tree. For general information about command settings, see command
settings (page 114).
See also:
■

Edit Feature Settings - View Frame Group Dialog Box (page 2319)

■

Edit Feature Settings - View Frame Dialog Box (page 2322)

■

Edit Feature Settings - Match Line Dialog Box (page 2322)

The View Frame Group Object
View frame groups persist in an AutoCAD drawing as objects with the name AeccViewFrameGroup.
A view frame group object manages a group of view frames that are created while using the Create View
Frames wizard. When you use the Create View Frames wizard, you are prompted to enter a name and other
object creation criteria for a view frame group. Each view frame group manages the view frames and match
lines for a single alignment.
See also:
■

Understanding Objects and Styles (page 63)

View Frame Groups Collection (Prospector Tab)
Use the View Frame Groups collection in the Prospector tree to access the view frame groups in a drawing
or a project.
After View frame group objects are created, they are displayed in the View Frame Groups collection in the
Prospector tree.
When you expand a view frame group in Prospector, you can see the view frames and match lines associated
with it. Expand the View Frames or Match Lines collections to view the names of the view frames or match
lines in that group. Selecting an individual view frame or match line in Prospector displays a tabular list of
the view frame and match line data in the Prospector list view. For more information, see The Toolspace
Item View (page 99).

View Frame Group Collection (Settings Tab)
Use the View Frame Group collection in the Settings tree to manage view frame group settings and command
settings.
Right-click the View Frame Group collection to do the following:
■

Edit the view frame group feature settings.

■

Edit the view frame group label style default settings.

■

Refresh the display of the settings tree.

For more information, see “The Object Collection (Settings Tree)”.
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Expand the View Frame Group collection to display and edit the default styles and command settings that
are available for view frame groups.
For information about...

See...

View frame group settings

Edit Feature Settings - View Frame Group Dialog
Box (page 2319)

View frame group styles

Plan Production Tools Object Styles and Display
(page 1929)

The View Frame Object
View frames persist in an AutoCAD drawing as objects with the name AeccViewFrame.
View frame objects are created automatically when you use the Create View Frames wizard. View frames are
always associated with a parent view frame group object.
View frames are created based on an alignment in the drawing, and on a designated plan view or profile
view viewport in a template. When you choose to create sheets that will contain profile view data in addition
to plan view data, you must also have a profile in the drawing. The properties of the view frame are saved
in the drawing in which you create the view frame.
Most of the view frame object information is derived from the viewport information specified in the template.
For example, the view frames you create get their size and scale from the viewport in the template. Similarly,
the sheet layout is also derived from the referenced template.
An important concept to understand is that the viewports in the referenced template must have a property
called Viewport Type set to either plan or profile, depending on the type of data you want that viewport to
display. For more information, see Setting Up Drawing Templates for Plan Production (page 1902).
See also:
■

Understanding Objects and Styles (page 63)

View Frame Styles and Display
How view frames are displayed is controlled by a view frame style, a view frame label style, and choices made
on the Create View Frames wizard.

View Frame Style
The view frame style controls the appearance of the view frame. You can set typical style characteristics,
such as visibility, layer, color, linetype, linetype scale, and lineweight.
View frames have only one display component, the border, which is visible only in plan view.
For more information, see View Frame Style Dialog Box (page 2336) or Object and Label Styles (page 66)

View Frame Label Style and Location
You can specify a label style and a location for the label that will be displayed on each view frame. Set the
defaults for this view frame label behavior using the View Frame Group Settings dialog box.
You can choose from a variety of locations around the view frame to place the view frame label. For example,
you can choose to place view frame labels at the top left, top center, middle right, and so on. You make this
choice in the Create View Frames wizard. You can change this location later, after it has been created by
right-clicking the label and selecting Edit Label. For more information, see Labeling View Frames (page 1921).
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View Frames Collection (Prospector Tab)
Use the View Frame Groups collection in the Prospector tree to access the view frames in a drawing or a
project. As view frame objects are created, they are displayed in the View Frame Groups collection.
Expand the View Frame Groups collection, and then expand a view frame group object beneath it to view
the names of the view frames associated with a view frame group. To display a tabular list of the view frames
in the Prospector list view, select a view frame in the Prospector tree. For more information, see The Toolspace
Item View (page 99).

View Frame Collection (Settings Tab)
Use the View Frame collection in the Settings tree to manage view frame feature settings, styles, and command
settings.
Right-click the View Frame collection to do the following:
■

Edit the view frame feature settings.

■

Edit the view frame label style default settings.

■

Refresh the display of the settings tree.

For more information about the contents of this shortcut menu, see “The Object Collection (Settings Tree)”.
Expand the View Frame collection to display and edit the styles that are available for view frames.
For information about...

See...

View frame settings

Edit Feature Settings - View Frame Dialog Box (page
2322)

View frame styles
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The Match Line Object
Match lines persist in an AutoCAD drawing as objects with the name AeccMatchLine.
If you selected the Insert Match Lines check box on the Match Lines page of the Create View Frames wizard,
a match line is created at each view frame intersection. The first and last view frames in a group have only
one match line. For plan only sheets, you have the option to not insert match lines on the view frames. To
do this, simply remove the check mark from this check box on the Create View Frames wizard.
NOTE When creating plan and profile or profile only sheets, match lines will always be inserted, and the Insert
Match Lines check box is selected but unavailable (you cannot remove the check mark). If you are creating plan
only sheets, you can remove the check mark from the box and match lines will not be inserted in the resulting
plan views.
Properties of match lines, such as where they are positioned on the alignment, a match line style, and a
match line label style, can be specified on the Match Lines page of the Create View Frames wizard. You can
set defaults for their styles using the Match Line settings available on the Settings tab in Toolspace.
Match lines have a match line mask area on the outside of each match line. This lets you mask data outside
of the match lines. You can set hatch pattern options for this area using the Match Line Style dialog box.
Match lines and the match line mask area are displayed only in plan views, not in profile views. The match
line mask area exists only in paper space.
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See also:
■

Editing the Match Line Mask Area (page 1923)

■

Understanding Objects and Styles (page 63)

Match Lines Styles and Display
How match lines are displayed is controlled by a match line style, a match line label style, and choices made
on the Match Lines page of the Create View Frames wizard.

Match Line Style
Use the match line style to control the appearance of the match line. You can set typical style characteristics,
such as visibility, layer, color, linetype, linetype scale, and lineweight. For more information, see Match Line
Style Dialog Box (page 2337) or Object and Label Styles (page 66).

Match Line Mask Area
Use the match line mask area to hide or mask the area that exists between the outside of a match line and
the inside border or boundary of the view frame. This component exists only in plan views, not profile
views, and only in paper space. The following illustration shows an example of the two match line mask
areas in gray, on the left and right sides of a plan view viewport:

The Display tab of the Match Line Style dialog box includes an option to specify a hatch pattern for this
match line mask area. Use this option to help you make your construction documents look better by masking
the drawing data that exists outside of the match lines. See Editing the Match Line Mask Area (page 1923) for
more information.
Match line labels are displayed on top of the match line mask area, and are therefore visible over it.

Match Line Label Style and Location
You can specify a label style for the label that will be displayed on the left side of a match line or on the
right side of a match line. Since each individual match line is displayed in two sheets, it’s convenient to
have the ability to set label styles differently for the label that will be displayed on the left side of the match
line, and another label style for the label that will be displayed on the right side of the match line.
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Also, you can display only one match line label (on the left or on the right side of the match line) by simply
turning off the visibility of one match line label.
You can choose to place the left and right side match line labels at the start, end, or middle of the match
line, or where the alignment intersects the match line. For more information, see Labeling Match Lines
(page 1926).
Set the defaults for this match line label behavior using the View Frame Group Settings dialog box.

Match Lines Collection (Prospector Tab)
Use the View Frame Groups collection in the Prospector tree to access the match lines in a drawing or a
project.
As match lines objects are created, they are displayed in the parent View Frame Groups collection they are
associated with. Expand the View Frame Group collection, and then expand a view frame group object
beneath it to view the names of the match lines associated with a view frame group. To display a tabular
list of the match lines in the Prospector list view, select a match line in the Prospector tree. For more
information, see The Toolspace Item View (page 99).

Match Line Collection (Settings Tab)
Use the Match Line collection in the Settings tree to manage match line settings, styles, and command
settings.
Expand the View Frame collection to display and edit the styles that are available for match lines.
Right-click the Match Line collection to do the following:
■

Edit the match line feature settings.

■

Edit the match line label style default settings.

■

Refresh the display of the settings tree.

For more information about the contents of this shortcut menu, see “The Object Collection (Settings Tree)”.
For information about...

See...

Match line settings

Edit Feature Settings - Match Line Dialog Box (page
2322)

Match line styles

Plan Production Tools Object Styles and Display
(page 1929)

Section Sheet Production
Use the Create Section Sheets command to create layouts for plotting section views.
As a prerequisite to using the Create Section Sheets command, you must use the Production option in the
Create Multiple Views (page 1259) command to generate section views.
Section Sheet Production Workflow (page 62)
To create layouts for section plotting
1 Use the Create Multiple Views (page 1259) command to generate production-ready section views. When
creating the section views, you must select a template that contains a Section-type viewport (page 1902).
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2 Click Output tab ➤ Plan Production panel ➤ Create Section Sheets

.

3 In the Create Section Sheets (page 2340) dialog box, select the section view group for which to create
layouts. You can filter the selection in the Section View Group list by first selecting an alignment and
sample line group.
4 Specify the layout name template.
NOTE All layouts are created in the current drawing.
5 Specify the Sheet Set options. You can add the layouts to an existing sheet set, or create a new sheet
set file.
6 Click Create Sheets.
NOTE The Sheet Set Manager opens and displays the newly-created sheets. Double-click on a sheet name
to display it in a layout view. You can also use the

Quick View Layouts button on the application status

bar to open the sheets. You can also right-click the
Tabs to display tabs for accessing the sheets.

Model button and click Display Model and Layout

Quick Reference
Ribbon
Click Output tab ➤ Plan Production panel ➤ Create Section Sheets

.

Command Line
CreateSectionSheets
Dialog Box
Create Section Sheets (page 2340)

Plan Production Tools Command Reference
You can use commands to quickly access plan production tools.
The following table lists the plan production tool AutoCAD Civil 3D commands and briefly describes their
functionality.
Command

Description

CreateSectionSheets

Creates layouts for section plotting (page 1934)

CreateSheets

Creates plan/profile sheets for plotting from existing view frames (page 1909)

CreateViewFrames

Inserts view frames along an alignment for sheet
creation (page 1904)

DeleteViewFrameGroup

Deletes the selected view frame group (page 1918)

EditMatchLineProperties

Specifies the match line style, name, and description (page 2332)
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Command

Description

EditMatchLineStyle

Controls the display of match lines and the hatch
pattern of the match line mask (page 1923)

EditViewFrameGroupProperties

Specifies view frame and match line styles, names,
and descriptions for the entire view frame group
(page 2333)

EditViewFrameLabels

Edits view frame or match line label style and
location (page 1921)

EditViewFrameProperties

Specifies the view frame name, description, and
style (page 2331)

EditViewFrameStyle

Controls the view frame border visibility and color
(page 1931)

InsertViewFrame

Inserts a new view frame into an existing view
frame group (page 1922)
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AutoCAD Civil 3D adds its own unique civil engineering and surveying commands to the AutoCAD command set.
This section provides information about the commands in AutoCAD Civil 3D.
For information about AutoCAD commands, see the AutoCAD Command Reference.

Accessing Commands
You can access many AutoCAD Civil 3D commands using more than one method.
In Help, click the Quick Reference tab on a tabbed Help topic to display a table providing the methods
available for accessing a specific command. Not all methods are available for all commands. Where applicable,
the following information is available on the Quick Reference tab:
Ribbon

Describes how to access the command from the ribbon.

Menu

Describes how to access the command from the menu bar.
NOTE By default, the menus are not displayed in AutoCAD Civil
3D. To display the menus, enter MENUBAR at the command
line, and set the value to 1.

Toolspace Shortcut
Menu

Describes how to access the command from Toolspace by rightclicking an object in the Prospector or Settings tree.

Object Shortcut
Menu

Describes how to access the command from a drawing by rightclicking the applicable object.

Command Line

Describes how to access the command from the command line.

Toolbar

Shows the toolbar icon to click or describes how to access the
command from a toolbar.

Dialog Box

Provides a link to the dialog box that is opened by the command.
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Command Listing
Use the links in this section to access Help topics that describe the commands that are available at the
command line in AutoCAD Civil 3D.
Feature

Command Summary

Alignments

Alignment Command Reference (page 1088)

Assemblies and Subassemblies

Assembly and Subassembly Command Reference (page
1583)

Building Site

Building Site Command Reference (page 1895)

Corridors

Corridor Command Reference (page 1534)

Drawings

Drawing Command Reference (page 142)

Drawing and Data Sharing

Drawing Sharing Command Reference (page 1865)

Google Earth Import and
Export

Google Earth Import and Export Command Reference
(page 1873)

Grading

Grading Command Reference (page 869)

HEC-RAS Import and Export

HEC-RAS Import and Export Command Reference (page
1890)

Intersections

Intersection Command Reference (page 1622)

LandXML

LandXML Command Reference (page 1885)

Lines/Curves

Lines and Curves Command Reference (page 643)

Materials Analysis

Material Analysis Command Reference (page 1321)

Parcels

Parcels Command Reference (page 921)

Pipes

Pipe Network Command Reference (page 1428)

Plan Production

Plan Production Tools Command Reference (page 1935)

Points

Point Command Reference (page 546)

Point Clouds

Point Cloud Command Reference (page 604)

Profiles and Profile Views

Profile Command Reference (page 1221)

Project Management

Project Management Command Reference (page 203)

Roundabouts

Roundabout Command Reference (page 1642)

Sections

Sections Command Reference (page 1272)

Sites

Sites Command Reference (page 791)

Surfaces

Surfaces Command Reference (page 775)
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Feature

Command Summary

Survey

Survey Command Reference (page 419)

Utilities

Utilities Command Reference (page 1849)

Transparent commands

Transparent Command Reference (page 1788)

User Interface

User Interface Command Reference (page 124)

AutoCAD Commands and AutoCAD Civil 3D Objects
The following topic provides information about AutoCAD command operations on certain AutoCAD Civil
3D objects and the results.
All AutoCAD Civil 3D objects support the AutoCAD List, Explode, and Erase commands.
NOTE Exploding an object results in an unnamed AutoCAD block. Exploding again results in a base AutoCAD
entity.
Most AutoCAD Civil 3D objects support other commands to some degree. These commands include Copy,
Move, Mirror, Offset, Scale, Block/wBlock, Rotate, Trim and Extend.
NOTE You can get the “Copy” behavior by using the Home tab ➤ Modify panel ➤ Copy
command on
the ribbon, or by entering COPY at the command line or by using the Basic Modify Tools ➤ Copy command on
the shortcut menu. You can get the “Block/Wblock” behavior by using the Clipboard ➤ Copy or Clipboard ➤
Copy With Base Point commands on the shortcut menu, pressing Ctrl + C, or entering WBLOCK at the command
line.

Supported AutoCAD Command Notes
Surface
If the surface is erased or exploded, profiles and sections that reference that surface become static.
Mirror will create a copy but will not honor the mirror settings.
Point groups used in the surface definition are included as part of the Wblock.
Point
When Wblocking and Inserting points, or copying points, a dialog box is displayed to resolve number
conflicts.
Table
Wblocking a table also copies the required geometry. For example, the points are copied along with the
point table.
Alignment
Exploding or erasing an alignment explodes or erases all objects that are dependent on the alignment
(such as profiles, profile views, sample lines, sections, and section views).
Copying the alignment will create an alignment with a new name in the same site. All dependent objects
will be copied and included with the new alignment.
Wblock/Insert will copy the alignment and all dependent objects into a new site.
Parcel (select parcel label)
When copying or Wblocking a parcel, the dependent parcel segments are included. If the objects are inserted into the same drawing, a new site is created.
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Only the parcel labels can be moved.
Parcel Segment Lines
Wblocking/Inserting the parcel segment lines creates segment lines in a new site.
Grading
There are two distinct copy operations which can be done on a grading object. Copying the footprint
feature line or individual target line creates a new feature line in a new site. Copying the entire grading
object copies the footprint, target, and criteria.
The footprint can be moved. The target line cannot be moved.
If the grading criteria references a surface, the surface will be included in a Wblock/Insert operation.
Profile
Erasing a profile or section erases it from all profile or section views.
Profiles and sections can only be moved vertically within a view.
Profile View
If the profile or profile view is Wblocked, all objects required for the profile or profile view (such as the
surface, alignment, profile, sample lines, and sections) are copied. If the objects are copied into the same
drawing, a new site is created.
Sample Line
You cannot copy or move a Sample Line
Section
Erasing a profile or section erases it from all profile or section views.
Profiles and sections can only be moved vertically within a view.
If the sample line, section, or section view is Wblocked, all objects that are required for the sample line,
section, or section view (such as the surface, alignment, sections, and sample lines) are copied. If the objects
are copied into the same drawing, a new site is created.
Assembly
The names of assemblies and subassemblies are incremented when copied. Copying an assembly copies
the assembly and all dependent subassemblies.
Mirror will create a copy but will not honor the mirror settings.
Corridor
Copying or Wblocking a corridor copies all of the dependent data such as assemblies, alignments, and
surfaces.
Pipe Network
Network Objects are not accessible through Object Enabler environment.
Pipe
Copying a network part profile will create a copy of the parent network part (pipe or structure).
Structure
Copying, mirroring, arraying, and offsetting pipes and structures updates the references of any connected
parts.
Copied pipes and structures will be in the same network.
Moving or rotating a structure causes any connected parts to move with it. (the connections are maintained).
Moving or rotating a pipe breaks the connection to any connected parts.
Scaling a pipe or structure affects position but does not affect size.
Wblocking pipes and structures copies all dependent objects.
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Survey Network
Using the copy command on a survey network creates feature lines. The move command disassociates
the figure from the model.
Survey Figure
Using the offset command on a survey figure generates a feature line object, not a survey figure.
The move commands dissassociates the figure from the model.
Mass Haul Line
Using the explode command keeps the layer and display settings.
With the Extend command, the object can be selected as an edge to extend to, but cannot be selected
to extend
With the Trim command, the object can be selected as a trim edge, but cannot be trimmed
If the mass hauls is Wblocked, all objects that are required for it will be copied. Wblock/Insert is used when
the user keys in ^C and ^V.
Mass Haul View
Views are automatically named according to “Existing Name” (#), where # is an increment. If a conflict
is found, the next counter will be used.
The copy command or right-click “Copy Selection” will create a copy of the View with a name of “Existing
Name” (#), where # is an increment.
The explode command will keep the layer and display settings. Exploding the View will not explode the
haul line.
The mirror command is successful on a View, but it will not honor the mirror settings. You will get an
additional copy of the Profile View.
If the View is Wblocked, all objects that are required for the View will be copied. Wblock/Insert is used
when the user keys in ^C and ^V
Civil Projection in Profile View and Section View
Erase will remove from view but should not remove plan object.
Explode will keep the layer and display settings.
AutoCAD Projection in Profile View and Section View
Erase will remove from view but should not remove plan object.
Explode will keep the layer and display settings.
Intersection
Explode will keep the layer and display settings.
Building Site
Explode will keep the layer and display settings.
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Alignment Dialog Boxes
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The following topics provide information about the Alignment dialog boxes.

Add Automatic Widening Dialog Box
Use this dialog box to configure a dynamic offset alignment to automatically widen around horizontal
curvatures of the parent alignment.
When you use this feature, there are two ways that you can create the automatic widening; either by specifying
parameters through a design criteria file (associated with the parent alignment), or by specifying parameters
manually (by entering values for the Increase in Width and the Transition Length fields on this dialog box).
This feature can only be applied to dynamic offset alignments.
Along Entire Alignment
Specifies to apply the automatic widening along the entire length of the alignment.
At Curves Without Widening
Specifies to apply the automatic widening only at curves where there is currently no widening already.
At Selected Curves
Specifies to apply the automatic widening at the curves that are selected using the Select Curves Along
Parent Alignment button. For more information, see To add automatic widening at selected curves (page
967).

Specify Widening Using Criteria
When this option is selected, the automatic widening on curves is controlled by the property values that
are specified in the property table on this dialog box. A valid design criteria file must be available for selection
to use this option. The design criteria file that is specified must be associated with the parent alignment for
the offset alignment. The default property values that are displayed in the table below are specified in the
design criteria file, and from command settings. However, you can edit these values on this dialog box.
When you edit these values on this dialog box, it does not affect the property definitions in the criteria file,
or in command settings. See the descriptions of the properties below to determine which ones are specified
in the criteria file, and which ones are specified in command settings.
The default value for this option is defined in the command settings (Automatic Widening Around Curves
property group, Widening By property).
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Parent Alignment Design Criteria File
Displays the name and location of the design criteria file that is associated with the parent alignment for
this offset alignment.
Widening Method
The default value for this property is defined in the Widening Methods section of the specified design
criteria file.
Widening To Apply On
This property specifies how the manual widening is applied. The choices are: a.) Inside Only: Applies the
automatic widening to just the insides of curves, not the outsides of the specified curves. b.) Outside Only:
Applies the automatic widening to just the outsides of curves, not the insides of the specified curves.
c.)Both Sides: Applies the automatic widening to both the inside and outside of the specified curves.
When specifying widening manually, all other controls in the property table are disabled, except for this
one.
The default value for this property is defined in the command settings (Automatic Widening Around
Curves property group).
Minimum Radius Table
The default value for this property is defined in the Widening Methods section of the specified design
criteria file.
Transition Length Table
The default value for this property is defined in the Widening Methods section of the specified design
criteria file.
Attainment Method
The default value for this property is defined in the Widening Methods section of the specified design
criteria file.
% on Spiral for Spiral-Curve
The default value for this property is defined in the command settings (Superelevation Options property
group).
% on Tangent for Tangent-Curve
The default value for this property is defined in the command settings (Superelevation Options property
group).
Normal Lane Width
Specifies the lane width or click
and select a distance in the drawing area. The default value for this
property is defined in the command settings (Superelevation Options property group).
Number of Lanes - Left
Specifies the number of lanes on the left side of the roadway. The default value for this property is defined
in the command settings (Superelevation Options property group).
Number of Lanes - Right
Specifies the number of lanes on the right side of the roadway. The default value for this property is
defined in the command settings (Superelevation Options property group).
Wheelbase Length
Specifies a numeric value for the wheelbase length that is used in the formula for widening around curves.
This value is used only when the widening method is through design standards. It is not used when the
widening is specified manually.
The default value for this property is defined in the command settings (Automatic Widening Around
Curves property group).
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Specify Widening Manually
When this option is selected, the automatic widening is controlled by the values entered for the following
fields. The default value for this option is defined in the command settings (Automatic Widening Around
Curves property group, Widening By property).
Increase In Width
Specifies the width (dW) parameter that defines the increase in width of the left or right roadway lane
around curves when automatic widening is applied. The default value for this property is defined in the
command settings for the Create Offset Alignment command (Automatic Widening Around Curves
property group, Manual Widening Width property).
Transition Length
Specifies the length of the transition to which the automatic widening is applied. The default value for
this property is defined in the command settings for the Create Offset Alignment command (Automatic
Widening Around Curves property group, Manual Widening Transition Length property).
Widening To Apply On
This property specifies how the manual widening is applied. The choices are: a.) Inside Only: Applies the
automatic widening to just the insides of curves, not the outsides of the specified curves. b.) Outside Only:
Applies the automatic widening to just the outsides of curves, not the insides of the specified curves.
c.)Both Sides: Applies the automatic widening to both the inside and outside of the specified curves.
When specifying widening manually, all other controls in the property table are disabled, except for this
one.
The default value for this property is defined in the command settings (Automatic Widening Around
Curves property group).
Related procedures:
■

Adding Automatic Widening to Dynamic Offset Alignments (page 966)

■

Criteria-Based Alignment Design (page 935)

Alignment Entities Vista
Use this vista to view and edit entities that are part of the solved alignment geometry.
Use the Alignment Entities window to navigate through all solved alignment entities. You can select an
entity in the Alignment Entities window and then edit it in the Alignment Layout Parameters window.
Attributes in the Alignment Entities window are automatically updated as you edit the alignment.
You can filter the display to show a selected range of entities along an alignment. See Selecting Alignment
Entities (page 1061) for more information.
The Alignment Entities vista is like a spreadsheet. Each row represents an alignment entity and each column
represents an attribute for that entity. You can resize, move, and copy columns.
The first column (No.) is always displayed. It does not move when you use the scroll bar.
NOTE Two column configurations are available: default and criteria-based design. To switch between the
configurations, or to create your own configuration, right-click a column heading, and click Customize Columns.
This window remains open when you grip edit the alignment or enter another command. The window
closes when you either delete the currently selected alignment, click the X button, or click
Alignment Layout Toolbar (page 1959).

on the

No.
Specifies the entity number in the order of selection. This variable changes as entities are selected and
deselected.
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A
warning symbol is displayed in this cell if the sub-entity violates the specified design criteria (page
935).
Number
Specifies the entity number in the order in which it appears along the alignment. This value changes as
alignment entities ahead of it are created or deleted. This column cannot be hidden or deleted.
Curve Group Index
Specifies the curve group description.
Curve Group Sub-Entity Index
Specifies the curve group sub-entity description.
Type
Specifies either line, curve, or spiral as the entity type.
Length
Specifies the length of the entity.
A
warning symbol is displayed in this cell if the sub-entity length value is not greater than or equal
to the value in the Minimum Length cell.
Direction
Specifies the direction of the entity.
Minimum Length
Specifies the minimum transition length defined in the design criteria file (page 2773) for the current design
speed.
Radius
Specifies the radius of the curve.
A
warning symbol is displayed in this cell if the sub-entity radius value is not greater than or equal
to the value in the Minimum Radius cell.
Minimum Radius
Specifies the minimum radius value defined in the design criteria file (page 2773) for the current design speed.
A
Specifies the A value.
Constraint1
Specifies the constraint of the entity: either fixed, free, or floating.
Constraint2
Specifies the number of points in the constraint of the tangent.
If the entity was created by best fit, [...] appears to the right of the Best Fit entry. If the entity has been
edited since it was created from best fit regression data,
appears. Click [...] to open the Regression Data
vista (page 2226) and review the regression points and synchronize the entity to the regression data.
Bearing
Specifies the direction of the entity.
Start Station
Specifies the starting station for the entity.
End Station
Specifies the ending station for the entity.
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Start Point
Specifies the coordinates for the starting point of the entity.
End Point
Specifies the coordinates for the end point of the entity.
Pass Through Point1
Specifies the point coordinates for the first pass-through point of an alignment entity.
Pass Through Point2
Specifies the point coordinates for the second pass-through point of an alignment entity.
Pass Through Point3
Specifies the direction of the third user-specified pass-through point on a curve entity.
Spiral Type
Specifies the spiral type.
Incurve
Specifies whether the curve is incoming or outgoing.
Compound
Displays True when a spiral has a curve at each end.
Radius In
Specifies the incoming curve radius.
Radius Out
Specifies the outgoing curve radius.
Total X
Specifies the tangent distance between the beginning point of the incoming spiral (TS) and the endpoint
of the spiral and beginning point of the circular curve.
Total Y
Specifies the perpendicular offset distance between the beginning point of the circular curve (SC) and the
incoming tangent.
Short Tangent
Specifies the distance from the spiral point of the horizontal tangent intersection (SPI) to the end of the
spiral (SPI).
Long Tangent
Specifies the distance from the beginning of the spiral (TS) to the spiral point of horizontal tangent
intersection (SPI).
P
Specifies the offset distance from the incoming tangent to the beginning point (PC) of the shifted circular
curve.
K
Specifies the abscissa between the beginning point of the spiral (TS) and the beginning point of the shifted
circular curve.
Spiral Definition
Specifies the spiral definition.
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SPI Station
Specifies the station value of the SPI. Adds the tangential distance from the beginning of the Spiral (TS)
to the SPI to the station value of the TS.
SPI Northing
Specifies the XY coordinates of the spiral point of horizontal tangent intersection.
SPI Easting
Specifies the XY coordinates of the spiral point of horizontal tangent intersection.
SPI Included Angle
Specifies the angle representing the difference in direction of the incoming tangent and the outgoing
tangent of the spiral.
Radial Point Northing
Specifies the coordinates of the spiral northing.
Radial Point Easting
Specifies the coordinates of the spiral easting.
Center Point
Specifies the coordinate of the center point of a circular curve.
Direction At Through Point1
Specifies the XY coordinates of the first user-specified pass-through point.
Direction At Through Point2
Specifies the XY coordinates of the second user-specified pass-through point.
Greater than 180 Degrees
■

Displays True if the curve angle is defined as greater than 180 degrees.

■

Displays False if the curve angle is defined as less than 180 degrees.

Compound
Displays True when the spiral has a curve at each end.
Delta Angle
Specifies the angular difference in the direction of the incoming and out going tangents.
External Tangent
Specifies the distance from the beginning of the curve (PC) to the PI or from the PI to the end of the curve
(PT).
Chord Direction
Specifies the bearing along the line joining the beginning of the curve (PC) and the end of the curve (PT).
External Secant
Specifies the radial difference from the PI to the midpoint of the curve.
PI Included Angle
Specifies the included angle between the incoming and outgoing tangents of the curve.
Chord Length
Displays the chord length of the circular curve.
Specifies the distance along the line joining the beginning of the curve (PC) and the end of the curve (PT).
Mid-Ordinate
Specifies the distance from the midpoint of the curve, perpendicular to the midpoint of the chord.
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PI Station
Specifies the station value of the PI by adding the PC to the PI tangent length to the station value at the
beginning of the curve (PC).
Design Speed
Specifies the design speed for each sub-entity.
Minimum Radius Table
Specifies the minimum radius table for each sub-entity. The Minimum Radius Table is defined in the
design criteria file (page 2773).
A
warning symbol is displayed in this cell if the sub-entity radius value is not greater than or equal
to the value in the Minimum Radius cell.
Transition Length Table
Specifies the minimum transition length table for each sub-entity. The Transition Length Table is defined
in the design criteria file (page 2773).
A
warning symbol is displayed in this cell if the sub-entity length value is not greater than or equal
to the value in the Minimum Length cell.
Attainment Method
Specifies the superelevation attainment method for each sub-entity. The Attainment Method is defined
in the design criteria file (page 2773).
Related procedures:
■

Criteria-Based Alignment Design (page 935)

■

Selecting Alignment Entities (page 1061)

■

Editing Alignment Entity Layout Parameters (page 1066)

Alignment Geometry Points Dialog Box
Use this dialog box to specify the alignment geometry points that you want to label.

Select Geometry Points To Label
Select All
Selects all check boxes in the Label column.
Deselect All
Clears all check boxes in the Label column.
Geometry Points Column
Identifies the available geometric details.
NOTE The Abbreviations (page 2077) tab in the Drawing Settings dialog box also lists these geometry points.
Label Column
Specifies whether to label a geometry point.
Related procedures:
■

Using Label Sets (page 1045)
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Alignment Labels Dialog Box
Use this dialog box either to create and save label sets or to import an existing label set.
Type
Specifies the type of label, which is related to elements in the alignment that can be labeled. After you
select a label type, you assign a style. Select one or more label types to include in the label set:
■

Major station

■

Minor station

■

Geometry points

■

Station equations

■

Design speeds

■

Profile Geometry Points

■

Superelevation Critical Points

NOTE You can add a label type multiple times in a label set. For example you could add geometry points twice
and then apply a style to the first entry of geometry points at specified starting and ending stations. Then, in
the second entry for geometry points, you could specify another style and the starting and ending stations
where you want to apply that style.
<Label Type> Style List
Lists the styles available for the specified label type. Select a style from the list.
Style Selection
Specifies the style options. Create a new style, copy or edit the current style selection, or pick a style from
the drawing.
Style Detail
Opens the Style Detail dialog box. Preview the style and creation information.

Adds the selected element and style to the label set.
NOTE You must first select major stations in order to add minor stations.

Deletes the selected element in the label set.

Resets manual or grip edits that may have been made to any labels.
Type
Displays the label types added from the Type list.
Style
Displays the label style selected and added from the Style list. Click
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to change the style.

Increment
Displays the increment at which the label is displayed. To change the default value, click in the cell, and
enter a new value.
NOTE Increment does not apply to all label types.
Start Station
Displays the starting station at which the label is displayed. By default, the start station is at the beginning
of the alignment. To change the default display, clear the check box and enter a new value.
End Station
Displays the ending station at which the label is displayed. By default, the end station is at the end of the
alignment. To change the default display, clear the check box and enter a new value.
Geometry Points To Label
Specifies the geometry points to label for the Geometry Points, Profile Geometry Points, and Superelevation
Critical Points label types. You can label a selection of geometry points in a label type using a selected
style. You can then add another instance of the same label type, which can label a second selection of
geometry points using a different style. Click

to select the geometry points to label.

Profile
For Profile Geometry Points label types, specifies which profile’s geometry points are labeled on the
alignment

to change the profile.

Station Index Increment
When a station label style is in Station Index Format, this is the base value used to format the station
labels.
For example, when station labels are displayed at 20-meter increments using the default Station Format,
they are formatted as 0+00, 0+20, 0+40, 0+60, etc. If the same labels used the Station Index Format, with
the Station Index Increment set to 10, the labels would be formatted as 0+0, 2+0, 4+0, 6+0, etc. Changing
the Station Index Increment to 20 would format the labels as 0+0, 1+0, 2+0, 3+0, etc.
Import Label Set
Opens the Select Style Set dialog box. Select a previously saved label set style and use it on the current
alignment. Importing a label set overwrites the existing setting on the Labels tab.
Save Label Set
Opens the Label Set Dialog Box (page 2206). Configure the name and other settings for the current label
set. This set is saved on the Toolspace Settings tab.
Related procedures:
■

Using Alignment Label Sets (page 1045)

Alignment Layout Parameters Window
Use this window to display and edit many attributes of any given single sub-entity within an alignment.
You can use the Alignment Layout Parameters window to change individual lines, curves, and spirals in the
alignment. Use this window along with the Alignment Entities vista, which displays all of the sub-entities
that make up a given alignment.
You can edit available parameters. You cannot edit parameters that are unavailable (shaded).
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If the alignment uses design criteria, then the Alignment Layout Parameters window contains up to three
panels that can be collapsed by clicking
. If design criteria has not been associated with the alignment,
then only the Layout Parameters panel is available.
You cannot dock the Alignment Layout Parameters window, but you can pin or resize it.
This window stays open when you grip edit the alignment or enter another command. The window closes
when you either delete the currently selected alignment, click the X button in the upper right-hand corner
of the window, or click

on the Alignment Layout Tools toolbar (page 1959).

Design Speed
Specifies the design speed of the current sub-entity.
NOTE If multiple speeds are assigned to a sub-entity, then the highest speed is used to look up constraint values
from the design criteria file and to validate the design checks. This ensures the safest design for that sub-entity.

Design Criteria Panel
The following parameters are displayed only if design criteria has been associated with the alignment.
Use the Design Criteria panel to apply design criteria that is different from the default values that have been
set for the alignment. To change a criterion value, click the Value cell in the appropriate row.
A
warning symbol in the Property column indicates that the sub-entity design violates the criteria set
in the design criteria file. You can find and correct the specific parameter that has been violated by examining
the Layout Parameters panel.
Minimum Radius Table
Defines the minimum radii for a given road type and design speed.
Transition Length Table
A table of values in the Superelevation Attainment Method formulas. You can use the table to calculate
the distances between the critical superelevation transition points for different types of roadways as a
function of curve radius and design speed.
Attainment Method
Specifies how superelevation is applied, and the method (crowned or planar) that is used to calculate
superelevation transition stations for different types of roadways.

Layout Parameters
Use this panel to examine and change the general layout parameters of the selected sub-entity.
Click
Show More to expand the number of parameters that appears in the window. The default, collapsed
view displays editable and other important parameters. Use the horizontal and vertical scroll bars when the
list is longer or wider than the window.
When a design criteria file has been associated with an alignment, the Constraints column displays the value
to which a given parameter is limited. The selected design criteria file defines the constrained values. When
a parameter value violates the range displayed in the Constraints column, a
next to the parameter name.

warning symbol appears

NOTE The constraint definition for each alignment entity determines the parameters that are displayed in the
Layout Parameters panel.
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Line
Entity
Specifies a number for the Line, in the order of creation.
Curve Group Index
Specifies the curve group description.
Curve Group Sub-Entity Index
Specifies the curve group sub-entity description.
Type
Specifies either Line, Curve, or Spiral as the sub-entity type.
Constraint1
Specifies either Fixed, Free, or Floating as the general constraint type.
Constraint2
Specifies a detailed description of the entity constraints.
Length
Specifies the Line length.
NOTE You can edit the length of a floating line that is attached to the end of an entity.
Bearing
Specifies the direction of the line.
Start Station
Specifies the starting station of the line for the solved portions of the alignment.
End Station
Specifies the end station of the Line for the solved portions of the alignment.
Start Point
Specifies the XY coordinates for the start point of the Line.
End Point
Specifies the XY coordinates for the endpoint of the Line.
Pass Through Point1
Specifies the XY coordinates of the first user-specified pass-through point.
Pass Through Point2
Specifies the XY coordinates of the second user-specified pass-through point.

Curve (independent or in SCS)
Entity
Specifies the curve number relative to the order of creation.
Curve Group Index
Specifies the curve group description.
Curve Group Sub-Entity Index
Specifies the curve group sub-entity description.
Type
Specifies Curve as the entity type.
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Constraint1
Specifies either Fixed, Free, or Floating as the general constraint type.
Constraint2
Specifies a detailed description of the entity constraints.
Radius
Specifies the radius of the curve entity.
Length
Specifies the length of the curve entity.
Pass Through Point1
Specifies the XY coordinates of the first user-specified pass-through point.
Pass Through Point2
Specifies the XY coordinates of the second user-specified pass-through point.
Pass Through Point3
Specifies the XY coordinates of the third user-specified pass-through point.
Center Point
Specifies the XY coordinates of the center point.
Start Station
Specifies the starting station of the curve for the solved portion of the alignment. Unsolved curves do not
display a Start Station.
Start Point
Specifies the XY coordinates of the start point of the curve.
End Station
Specifies the end station of the curve for solved portions of the alignment. Unsolved curves do not display
an end station.
End Point
Specifies the XY coordinates of the endpoint of the curve.
Direction At Through Point 1
Specifies the XY coordinates of the first user-specified pass-through point.
Direction At Through Point 2
Specifies the XY coordinates of the second user-specified pass-through point.
Greater Than 180 Degrees
■

Displays True if the curve angle is defined as greater than 180 degrees.

■

Displays False if the curve angle is defined as less than 180 degrees.

Compound
■

Displays True if the curve is defined as compound to the curve before it.

■

Displays False if the curve is defined in the reverse direction to the curve before it.

Delta Angle
Specifies the included angle of the solved portion of the curve.
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External Tangent
Specifies the distance from either the beginning of the curve (PC) to the point of intersection (PI), or from
the PI to the end of the curve (PT).
Chord Direction
Specifies the bearing along the line joining the beginning of the curve (PC) and the end of the curve (PT).
External Secant
Specifies the radial difference from the PI to the midpoint of the curve.
PI Included Angle
Specifies the included angle between the incoming and outgoing tangents of the curve.
Chord Length
Specifies the distance along the line joining the beginning of the curve (PC) and the end of the curve (PT).
Mid-Ordinate
Specifies the distance from the midpoint of the curve, perpendicular to the midpoint of the chord.
PI Station
Specifies the station value of the PI by adding the PC to the PI tangent length to the station value at the
beginning of the curve (PC).

Spiral
Entity
Specifies the spiral number relative to the order of creation.
Curve Group Index
Specifies the curve group description.
Curve Group Sub-Entity Index
Specifies the curve group sub-entity description.
Type
Specifies Spiral as the entity type.
Constraint1
Specifies the spiral as either Fixed or Free.
Constraint2
■

Specifies the Spiral In, Radius, and Spiral Out for free spirals that are part of a Spiral-Curve-Spiral group.

■

Specifies the start point, direction, radius, and length for fixed spirals.

Spiral Type
Displays True when the spiral has a curve at both ends.
Start Station
Specifies the Start Station at the beginning of the spiral.
Start Point
Specifies the XY coordinates of the Start Point of the spiral.
End Station
Specifies the end station for the solved spiral portions of the alignment. Unsolved portions do not display
an end station.
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End Point
Specifies the XY coordinates of the End Point of the spiral.
Incurve
Specifies the incoming curve radius.
Length
Specifies the length of the Spiral.
A
Specifies the A value.
Compound
■

Displays True if the curve is defined as compound to the curve before it.

■

Displays False if the curve is defined in the reverse direction to the curve before it.

Radius In
Specifies the incoming curve radius.
Radius Out
Specifies the outgoing curve radius.
Total X
Specifies the tangent distance between the beginning point of the incoming spiral (TS) and the endpoint
of the spiral and beginning point of the circular curve.
Total Y
Specifies the perpendicular offset distance between the beginning point of the circular curve (SC) and the
incoming tangent.
Short Tangent
Specifies the distance from the spiral point of the horizontal tangent intersection (SPI) to the end of the
spiral (SPI).
Long Tangent
Specifies the distance from the beginning of the spiral (TS) to the spiral point of horizontal tangent
intersection (SPI).
P
Specifies the offset distance from the incoming tangent to the beginning point (PC) of the shifted circular
curve.
K
Specifies the abscissa between the beginning point of the spiral (TS) and the beginning point of the shifted
circular curve.
Spiral Definition
This read-only field specifies the spiral definition. If the alignment is created using the Alignment Layout
tools, or converted from AutoCAD entities, then the spiral definition for these spirals is specified as one
of the following values: Clothoid, Bloss, Cubic (JP), Cubic Parabola, Sinusoidal, Sine Half-Wavelength,
Bi-Quadratic.
If the alignment is created using a dynamic offset alignment command, the spirals have a special geometry
based on the parent alignment spiral definition with the offset parameter. So, for dynamic offset alignments,
the spiral definition can be specified as one of the following values: Offset Clothoid, Offset Bloss, Offset
Cubic (JP), Offset Cubic Parabola, Offset Sinusoidal, Offset Sine Half-Wavelength, Offset Bi-Quadratic.
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PI Included Angle
Specifies the included angle between the incoming and outgoing tangents of the curve.
SPI Station
Specifies the station value of the SPI. Adds the tangential distance from the beginning of the Spiral (TS)
to the SPI to the station value of the TS.
SPI Northing
Specifies the XY coordinates of the spiral point of horizontal tangent intersection.
SPI Easting
Specifies the XY coordinates of the spiral point of horizontal tangent intersection.
SPI Included Angle
Specifies the angle representing the difference in direction of the incoming tangent and the outgoing
tangent of the spiral.
Radial Point Northing
Specifies the coordinates of the spiral northing.
Radial Point Easting
Specifies the coordinates of the spiral easting.

Design Checks
The Design Checks panel displays the name and contents of the design check set that is associated with the
alignment.
When the sub-entity design violates a design check, a
design check.

warning symbol appears next to the affected

NOTE The Design Checks panel is available only for alignments that use a design check set.
Related procedures:
■

Spiral Definitions (page 1011)

■

Editing Alignment Entity Layout Parameters (page 1066)

■

Criteria-Based Alignment Design (page 935)

Alignment Layout Tools
Use this toolbar to draw simple tangent-tangent lines, create constraint-based alignment geometry, and edit
an alignment.
The name of the currently selected alignment is displayed at the top of the toolbar. When you click an icon,
the current command is displayed at the bottom of the toolbar. The toolbar remains open when you grip
edit the alignment or enter another command. The toolbar closes when you either delete the currently
selected alignment or click the X button in the upper-right corner of the toolbar.

Tangent-Tangent (No Curves)
Adds a series of fixed tangents between specified points.
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Tangent-Tangent (With Curves)
Adds a series of fixed tangents between specified points, with free curves automatically added at the points
of intersection.
Curve And Spiral Settings
Specifies the curve parameters to use with the Tangent-Tangent With Curves command.
Insert PI
Breaks a fixed line into two adjacent fixed lines by creating a point of intersection (PI) at a point that you
specify.
Delete PI
Creates a single tangent from two adjacent tangents by removing their point of intersection (PI).
Break Apart PI
Separates the point of intersection (PI) where the endpoints of two fixed or floating tangents meet.
Convert AutoCAD Line And Arc
Creates a fixed two-point line or three-point curve alignment entity from an AutoCAD object.
An alignment sub-entity that has been converted from an AutoCAD entity may be added as a solved
portion of the alignment geometry in either of two ways:
■

Before the AutoCAD entity is converted, it must be attached to an unattached end point of another
solved sub-entity in the alignment.

■

After the AutoCAD entity has been converted, it may be joined to the solved alignment geometry
using the alignment layout tools.

Reverse Sub-entity Direction
Reverses the direction of a fixed, unconnected line or curve sub-entity.
Delete Sub-Entity
Deletes a specified alignment sub-entity.
Edit Best Fit Data For All Entities
Displays a table of data that contains the original regression data for all alignment sub-entities that were
created by best fit.
Pick Sub-entity
Displays a selected sub-entity's parameters for editing.
Alignment Layout Parameters
Displays a vertical table of numeric data about a single, selected alignment sub-entity.
Alignment Entities
Displays a horizontal table of numeric data about multiple, selected alignment subentities.
Undo
Reverses the last AutoCAD Civil 3D or AutoCAD command.
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Redo
Reverses the last Undo command. Redo is limited to one operation.

Line Tools
Add constraint-based fixed, free, or floating lines to an alignment.
Fixed Line (Two points)
Adds a fixed line between two specified points.
Fixed Line (From curve end, length)
Adds a fixed line to and from the endpoint of an existing curve to another specified point. Tangency is
not maintained if either entity is edited.
Fixed Line - Best Fit
Adds the most probable fixed line through a series of AutoCAD Civil 3D points, AutoCAD points, existing
entities, or clicks on screen.
Floating Line (From curve, through point)
Adds a floating line from any point on an existing curve entity through a specified point.
Floating Line (From curve end, length)
Adds a floating line tangent, with a specified length, to the end of a curve entity. Tangency is maintained
to the attached entity end, regardless of how the entity is edited.
Floating Line - Best Fit
Adds the most probable floating line from a point on an existing entity through a series of AutoCAD Civil
3D points, AutoCAD points, existing entities, or clicks on screen. Tangency is maintained to the attached
entity, regardless of how the entity is edited.
Free Line (Between two curves)
Adds a free line between two existing curves.

Curve Tools
Add constraint-based fixed, free, or floating curves to an alignment.
Fixed Curve (Three points)
Adds a fixed curve through three points.
Fixed Curve (Two points and direction at first point)
Adds a fixed curve that is defined by specified start and end points and a direction at the start point.
Fixed Curve (Two points and direction at second point)
Adds a fixed curve that is defined by specified start and end points and a direction at the end point.
Fixed Curve (Two points and radius)
Adds a fixed curve that is defined by specified radius, direction, and start and end points.
Fixed Curve (From entity end, through point)
Adds a fixed curve from the end of an existing entity to a specified end point.
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Fixed Curve (Center point and radius)
Adds a full, fixed circle that is defined by a specified center point, direction, and radius.
Fixed Curve (Center point and through point)
Adds a full, fixed circle that is defined by a specified center point, direction, and pass-through point.
Fixed Curve (Through point, direction at point and radius)
Adds a full, fixed circle that is defined by a specified pass-through point, direction at the pass-through
point, curve direction, and radius.
Fixed Curve - Best Fit
Adds the most probable fixed curve through a series of AutoCAD Civil 3D points, AutoCAD points, existing
entities, or clicks on screen.
Floating Curve (From entity, radius, through point)
Adds a floating curve, which is defined by a specified radius and angle range, from an existing entity to
a specified end point.
Floating Curve (From entity end, through point)
Adds a floating curve from the end of an existing entity to a specified pass-through point.
Floating Curve (From entity, through point, direction at point)
Adds a floating curve from an existing entity to a specified pass-through point.
Floating Curve (From entity end, radius, length)
Adds a floating curve, which is defined by a specified direction, radius, and length, to the end of an existing
entity.
Floating Curve - Best Fit
Adds the most probable floating curve from an existing entity through a series of AutoCAD Civil 3D
points, AutoCAD points, existing entities, or clicks on screen. Tangency is maintained to the attached
entity, regardless of how the entity is edited.
Free Curve Fillet (Between two entities, radius)
Adds a free curve, which is defined by a specified angle range and radius, between two entities.
Free Curve Fillet (Between two entities, through point)
Adds a free curve, with a specified pass-through point, between two entities.
Free Curve - Best Fit
Adds the most probable free curve between two existing entities, and through a series of AutoCAD Civil
3D points, AutoCAD points, existing entities, or clicks on screen. Tangency is maintained to the attached
entities, regardless of how the entities are edited.

Lines with Spiral Tools
Floating Line with Spiral (From curve, through point)
Adds a floating spiral-line group, which is defined by a specified pass-through point, to a curve.
Floating Line with Spiral (From curve end, length)
Adds a floating spiral-line group, which is defined by the line length, to a curve.
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Curves with Spiral Tools
Floating Curve with Spiral (From entity end, radius, length)
Adds a floating spiral-curve group, which is defined by a specified radius and pass-through point, to a
line.
Floating Curve with Spiral (From entity, radius, through point)
Adds a floating spiral-curve group, which is defined by a specified radius and length, to a curve.
Floating Reverse Curve with Spirals (From curve, radius, through point)
Adds a floating reverse spiral-spiral-curve group, which is defined by a specified radius and pass-through
point, to a curve.
Floating Reverse Curve with Spirals (From curve, two points)
Adds a floating reverse spiral-spiral-curve group, which is defined by two specified pass-through points,
to an existing curve.
Free Spiral-Curve-Spiral (Between two entities)
Adds a free spiral-curve-spiral group between
■

Two tangents, creating a simple spiral.

■

A tangent and a curve, creating a compound spiral at one end and a simple spiral at the other end.

■

Two curves, creating two compound spirals at each end.

Free Compound Spiral-Curve-Spiral-Curve-Spiral (Between two tangents)
Adds a free compound spiral-curve-spiral-curve-spiral group between two tangents. You can specify a zero
length for any of the three spirals.
Free Reverse Spiral-Curve-Spiral-Spiral-Curve-Spiral (Between two tangents)
Adds a free reverse spiral-curve-spiral-spiral-curve-spiral group between two tangents.

Spiral Tools
Fixed Spiral
Adds a fixed spiral, which is defined by a specified radius and length, to the end of a line or curve.
Free Spiral (Between two entities)
Adds a free, compound spiral between two curves with different radii.
Free Compound Spiral-Spiral (Between two curves)
Adds a free compound spiral-spiral group between two curves.
Free Reverse Spiral-Spiral (Between two curves)
Adds a free reverse spiral-spiral group between two curves.
Free Compound Spiral-Spiral (Between two tangents)
Adds a free compound spiral-spiral between two tangents.
Free Compound Spiral-Line-Spiral (Between two curves, spiral lengths)
Adds a free compound spiral-line-spiral group, which is defined by specified spiral lengths, between two
curves.
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Free Reverse Spiral-Line-Spiral (Between two curves, spiral lengths)
Adds a free reverse spiral-line-spiral group, which is defined by specified spiral lengths, between two curves.
Free Compound Spiral-Line-Spiral (Between two curves, line length)
Adds a free compound spiral-line-spiral group, which is defined by a specified line length, between two
curves.
Free Reverse Spiral-Line-Spiral (Between two curves, line length)
Adds a free reverse spiral-line-spiral, which is defined by a specified line length, between two curves.
Related procedures:
■

Adding Lines, Curves, and Spirals to an Alignment (page 970)

Alignment Properties Dialog Box
Use this dialog box to review or edit many alignment details such as the name, design speeds, and label sets.
Some of the tabs on this dialog box are conditional, subject to alignment type. For example, the Curb Return
Parameters tab appears only for curb return alignments.
See also:
■

Alignment Properties (page 932)

Information Tab (Alignment Properties Dialog Box)
Use this tab to change the alignment name, description and alignment style information, and to review
details, such as when the style was most recently modified.
Name
Specifies the name of the current alignment style.
Description
Specifies an optional description of the current alignment style.
Object Style
Specifies the alignment style. Select other styles from the list.
Style Selection
Specifies the style options. You can create a style, copy or edit the current style selection, or pick a style
from drawing.
Style Detail
Opens the Style Detail dialog box. Preview the style and creation information.
Type
Specifies the alignment type: Centerline, Offset, Curb Return, or Miscellaneous.
Show Tooltips
Controls whether tooltips are displayed for the object in the drawing (not over toolbar icons).
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Station Control Tab (Alignment Properties Dialog Box)
Use this tab to establish the Station Reference Point and assign station equations along the alignment.

Reference Point Station
X
Specifies the X coordinate value for the Station Reference Point. By default, this value corresponds to the
starting point on the alignment. Enter a value or pick a point in the drawing.
Y
Specifies the Y coordinate value for the Station Reference Point. By default, this value corresponds to the
starting point on the alignment. Enter a value or pick a point in the drawing.
Pick Reference Point
Specifies the XY coordinates for the Station Reference Point. Pick points in the drawing to specify the
coordinates.
Station
Specifies the station at the reference point.

Station Information
Start
Displays the beginning station for the first solved entity in the alignment.
End
Displays the ending station for the last solved entity in the alignment.
Length
Displays the length of the alignment as the summation of the length of solved entities along each
alignment.

Station Equations
Add Station Equation
Specifies the location for a station equation. Click the button and specify the station for the new equation
by either picking a station in the drawing or entering a raw station value on the command line.
Delete Station Equation
Deletes the selected station from the drawing. Select the station row that you want to delete and click this
button.
Equation
Displays the index number of the equation sorted by raw station location on the alignment.
Raw Station Back
Displays the station value at the location of the Station Equation before any Station Equation values are
assigned. If there is only one Station Equation value, then the Raw Station Back and Station Back values
match.
Station Back
Displays the station value at the location of the Station Equation value before any Station Equations are
assigned. If there is only one Station Equation value, then the Raw Station Back and Station Back values
match.
If the alignment contains more than one Station Equation value, then the Station Back value of all Station
Equation values, except for the first equation, are relative to the Station Ahead value and the Station
Equation value directly before it.
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Station Ahead
Specifies the new station values immediately after the Station Equation value.
Increase/Decrease
Specifies whether the stations increase or decrease in value following the Station Equation location.
Comment
Specifies notes or instructions relevant to the station equations. Enter optional comments. These comments
can be used in labels for station equations.

Masking Tab (Alignment Properties Dialog Box)
Use this tab to suppress the display of an alignment and its labels for a range of stations.
Add Masking Region
Click to add a new mask region. You are asked to specify the start and end stations for the region.
Delete Masking Region
Click to remove a mask region selected in the table.

Masking Table
Region
Identifies the mask region along the alignment.
Mask
When selected, the mask is applied; the mask region does not display. When deselected, the mask is
removed; the region displays. A deselected mask remains in the table for future use.
Lock to Start
Click to set the start of the first mask region at the start of the alignment.
Start Station
Displays the alignment station at which the mask region begins.
Lock to End
Click to set the end of the last mask region at the end of the alignment.
End Station
Displays the alignment station at which the mask region ends.
Comment
Use this space to add text notes about the mask region.

Design Criteria Tab (Alignment Properties Dialog Box)
Use this tab to establish the design criteria, including speeds along the length of the alignment.

Design Speeds
Alignments can have an unlimited number of design speeds, but they can have only one design speed at
any given location.
Add Design Speed
Specifies the location for a new design speed. Click the icon and pick a point on the alignment or enter
a value at the command line to create a design speed.
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Delete Design Speed
Deletes the selected design speed. Select the design speed row and click the button to delete the design
speed.
Station
Displays the station location of the design speed.
Design Speed
Specifies the design speed for the location. Click in the cell to enter a new design speed or accept the
default.
Comment
Specifies notes or instructions relevant to the design speeds. Enter optional comments. These comments
can be used in labels.

Criteria-Based Design (Unlabeled)
Use the following controls to change the design criteria file, default criteria, or design check set.
Use Criteria-Based Design
Causes the Use Design Criteria File and Use Design Check Set check boxes to become available. If this
check box is cleared, Design Speed is the only design criteria that will be applied to the alignment.
Use Design Criteria File
Applies the default design criteria file to the alignment and causes the Default Criteria property table to
become available. The first design criteria file found in the C:\Documents and Settings\All Users|Application
Data\Autodesk\C3D2011\enu\Data\Corridor Design Standards\<units> directory is used by default. Click
to select a different design criteria file.
The Default Criteria table displays the Properties, or table contents, that are defined in the selected design
criteria file. Click the Value column to change a criteria table.
For more information, see Design Criteria Files (page 936).
Use Design Check Set
Applies the default design check set to the alignment. Use the list to select from the available design check
sets. You can also use the selector to create a design check set, copy or edit the current design check set,
or pick a design check set from another alignment in the drawing.
For more information, see Alignment Design Checks (page 940).

Profiles Tab (Alignment Properties Dialog Box)
Use this tab to view data about a profile associated with the alignment.
Name
Specifies the name of the profile.
Description
Specifies an optional description for the profile.
Type
Specifies whether the current profile represents the existing ground or a finished grade.
Surface Name
Displays the name of the surface from which the EG Profile gets elevations.
Offset
Specifies the offset distance from the centerline of the parent horizontal alignment: either 0 for a centerline
profile, a positive number for a right offset, or a negative number for a left offset.
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Update Mode
For existing ground profiles only. Specifies whether the profile updates automatically to reflect changes
in surface elevation.
■

Dynamic: The profile automatically updates to reflect changes in the surface elevation or the geometry
of the parent horizontal alignment.

■

Static: The profile shows surface elevations at the time of its creation. It does not update to reflect
changes that occur later.

Layer
Specifies the drawing layer on which the profile is placed.
Style
Specifies the style used by the profile.
Station Start/End
Specifies the first and last station numbers for the profile. The station numbers represent distances along
the parent horizontal alignment.
Elevation Minimum/Maximum
Specifies the highest and lowest elevation values that occur along the profile.

Profile Views Tab (Alignment Properties Dialog Box)
Use this tab to view data about a profile view.
Name
Specifies the name of the profile.
Description
Specifies an optional description for the profile.
Stations Start/End
Specifies the first and last station numbers for the profile. The station numbers represent distances along
the parent horizontal alignment.
Style
Specifies the style used by the profile.
Band Style
Specifies the band style used by the profile.

Offset Parameters Tab (Alignment Properties Dialog Box)
For a dependent offset alignment, use this tab to set properties of the offset.

Parent Alignment
Name
Specifies the name of the parent alignment, which controls the offset alignment.
Nominal Offset Value
Specifies the offset distance from the parent alignment.
Start Station – Lock to Start of Parent
Specifies the station of the parent alignment where the offset alignment begins. Enter a station value, or
select the check box to begin the offset at the start of the parent alignment.
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End Station – Lock to End of Parent
Specifies the station of the parent alignment where the offset alignment ends. Enter a station value, or
select the check box to extend the offset to the end of the parent alignment.
Update Mode
Specifies whether the offset alignment reacts to edits of the parent alignment:
■

Dynamic. The offset is updated with any changes to the parent alignment.

■

Static. The offset alignment geometry is preserved, unaffected by changes to the parent alignment.

Lock Mode
For dynamic update mode, specifies how the offset alignment is associated with the geometry of the parent
alignment:
■

Geometry Locking. The start and end of the offset are located in relation to the nearest geometry points
on the parent alignment.

■

Station Locking. The start and end of the offset are locked to the specified start and end stations on
the parent alignment.

Curb Return Parameters Tab (Alignment Properties Dialog Box)
For a curb return alignment, use this tab to review and edit design data.

Parent Alignment 1
Name
Specifies the alignment that forms the basis of the design at the start of the curb return alignment.
Curb Return End Point Station
Specifies the station value on the parent alignment where the curb return alignment starts.
Curb Return Offset Value
Specifies the offset of the curb return start point from its parent alignment. This field is editable.

Parent Alignment 2
Name
Specifies the alignment that forms the basis of the design at the end of the curb return alignment.
Curb Return End Point Station
Specifies the station value on the parent alignment where the curb return alignment ends.
Curb Return Offset Value
Specifies the offset of the curb return start point from its parent alignment. This field is editable.
Update Mode
Specifies whether the curb return alignment reacts to edits of the parent alignment or offset. This field is
editable.
■

Dynamic. The curb return alignment is updated in response to edits of other intersection objects.

■

Static. The curb return alignment is at a fixed location, and does not respond to edits of other
intersection objects.

Lock Mode
Specifies that the curb return is always geometry locked. The start and end of the curb return offset are
located in relation to the nearest geometry points on the parent alignment.
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Alignment Style Dialog Box
Use this dialog box to control the display of each alignment component.
Create different styles to use in the various phases of your project. For example, you can create a first style
to use specifically in the design phase that displays lines, curves, and other alignment subcomponents in
different colors. Then, you can create a second style to use for plotting that displays only the solved alignment
geometry in one color and linetype.
See also:
■

Alignment Styles (page 946)

Information Tab (Alignment Style Dialog Box)
Use this tab to change the alignment style name and description information, and to review details about
the alignment, such as when the style was most recently modified.
For more information, see Information Tab (Style Dialog Box) (page 2017).

Design Tab (Alignment Style Dialog Box)
Use this tab to specify grip editing behavior. The value you enter increases or decreases the radius of curves
to an even increment.

Grip Edit Behavior
Enable Radius Snap
Specifies whether the cursor snaps to the specified increment when grip editing the radius of a free curve.
Radius Snap Value
Specifies the increment of the radius snap.
NOTE The snap value is based on zero. For example, if the current radius is 150.5 and the radius snap value is
10, when you grip edit the alignment to the next highest radius the radius value is 160, not 160.5.

Markers Tab (Alignment Style Dialog Box)
Use this tab to specify the display and appearance of points on the alignment.

Alignment Points and Marker Styles
Name
Displays the name of the point on the alignment.
Marker Style
Specifies the style for the point on the alignment. Click to open the Pick Marker Style dialog box where
you can select a style or <None>.

Arrowhead
Type
Specifies the arrowhead style for the alignment direction arrow. Select a style from the list or select User
Arrow to select an AutoCAD block.
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Size Options
Specifies the method used to determine the size of the arrowhead:
■

Use Drawing Scale: Determines size of the arrowhead by multiplying the specified value by the drawing
scale. Enter the scale factor.

■

Use Fixed Scale: Activates the Fixed Scale options.

■

Use Size in Absolute Units: Specifies that the arrowhead size is an absolute value based on the displayed
units. Enter the value.

■

Use Size Relative to Screen: Specifies that the size of the arrowhead is a percentage of the drawing
screen size. Enter the percentage.

Inches/Meters
Specify value for feet or meters.
Fit Options
Specifies how the arrow is displayed when the profile segment is shorter than the arrowhead. Select Shrink,
Omit, or Always Draw.
Fixed Scale
Specifies independent fixed scale values when Size Options is set to Use Fixed Scale. Enter a value for X.

Display Tab (Alignment Style Dialog Box)
Use this tab to change the display and visibility of alignment object components.
Alignment components include:
Line: Solved lines with true tangent lengths that are part of the alignment geometry.
Curve: Solved curves that are true curve lengths within the alignment.
Spiral: Spiral entities within the alignment geometry.
Arrow: Shows the direction of the alignment entities, either solved or unsolved.
Line Extensions: Line segments that extend beyond the solved portion of a line to a pass-through point or
another constraint.
Curve Extensions: Curve segments that extend beyond the solved portion of a curve to a pass-through point
or another constraint.
Warning Symbol: Markers that identify entities that violate the rules specified in the design criteria file. This
component only applies to alignments that use design criteria.
Pass-Through Points: Markers that denote the pass-through points that define the geometry of any given
entity.
PI Points: Markers that denote the pass-through points of two lines only when the pass-through points
coincide exactly.
Station Reference: Markers that denote the station reference point on the alignment.
For more information, see Display Tab (Style Dialog Box) (page 2017).

Summary Tab (Alignment Style Dialog Box)
Use this tab to review all the information about the current alignment style. You can copy and paste this
information to the clipboard.
For more information, see Summary Tab (Style Dialog Box) (page 2020).
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Best Fit Alignment Report Vista
Use this vista to analyze the results of the regression that was used to create an alignment by best fit through
a series of objects.

Regression Points Toolbar
Copy to Clipboard
Copies regression data to the clipboard with the appropriate formatting. This tool is useful for importing
the regression data into a spreadsheet.

Regression Points Table
Pt. No
Sequential number generated in the order in which the regression points were generated.
Point Northing
Northing value of the point that is closest to the regression point on the entity.
Point Easting
Easting value of the point that is closest to the regression point on the entity.
Offset to Entity
Specifies the distance of the regression point from the best fit entity.
Northing on Entity
Specifies the Northing ordinate from the best fit entity.
Easting on Entity
Specifies the Easting ordinate from the best fit entity.

Regression Graph
This graph displays the regression points’ relationship to the best fit entity. The red line represents the
regression points and the green line represents the best fit entity. Selecting a row in the Regression Points
table displays an X and dashed line in the graph to indicate the location of the selected point.
Related procedures:
■

Creating an Alignment by Best Fit (page 960)

Best Fit Alignment Weeding Options Dialog Box
Use this dialog box to add or remove vertices along a linear feature, such as a feature line or AutoCAD entity,
when creating an alignment by best fit.
Weed
Reduces the number of vertices generated along the best fit entity. The weeding factor ignores vertices
that deflect less than the Angle Tolerance. A larger deflection angle weeds a greater number of points. The
Angle Tolerance is measured in angular units. The Angle Tolerance must be less than the supplementing
Distance.
Angle Tolerance
Specifies the weeding angle factor.
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Supplement
Adds vertices along the best fit entity.
Distance
Specifies the maximum distance between vertices. If the distance between vertices on an entity is greater
than the supplementing factor, then points are added along the entity at equal intervals that are less than
or equal to the supplementing distance. The smaller the distance, the greater the number of supplemented
points.
Related procedures:
■

Creating an Alignment by Best Fit (page 960)

Create Alignment from Existing Alignment Dialog Box
Use this dialog box to enter information about an alignment, such as its name, a description, and the starting
station for the alignment. Also, you can use it to select an alignment style, label set style, site, and design
criteria.
Related procedures:
■

Creating an Alignment from an Existing Alignment (page 957)

■

Criteria-Based Alignment Design (page 935)

General Tab (Create Alignment from Existing Alignment Dialog Box)
Use this tab to enter basic information about the alignment, including site, style, layer, and label set.
Name
Specifies the name of the alignment. Each alignment must have a unique name.
Type List
Specifies the type of alignment (Centerline, Offset, Curb Return, or Miscellaneous).
Description
Specifies an optional description of the alignment.
Starting Station
Specifies the station value that is assigned to the beginning of the first alignment entity created.
By default, this value is the lowest station that you specified, or the starting station of the beginning
sub-entity that you selected.
NOTE Use the Station Control tab in the Alignment Properties dialog box to change the starting station after
you create an alignment.
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Site
Specifies a site for the alignment. Select a site from the Site list, or click
to either create a site or select
one from an object in the drawing. The alignment and the object you select in the drawing are associated
with the same site.
NOTE The default selection is <None>, which places the alignment in the top-level Alignments collection in
Prospector. See Alignment and Site Interaction (page 781) for more information.

Alignment Style
Alignment Style List
Displays the current style. Click the arrow to select another alignment style in the drawing.
Style Selection
Specifies the style options. Create a style, copy or edit the current style selection, or pick a style from
drawing.
Style Detail
Opens the Style Detail dialog box. Preview the style and creation information.

Alignment Layer
Alignment Layer Display List
Displays the layer on which the alignment object is created.
Object Layer
Opens the Object Layer Dialog Box (page 2221), in which you can select or create a layer on which the
alignment is drawn.

Alignment Label Set
Alignment Label Set List
Displays the default alignment label set. You can either accept the default label set, or use the list to select
a different one from the drawing.
Label Set Selection
Edits or copies the current label set, or creates a label set. The Style Detail icon previews the current style.
Style Detail
Opens the Style Detail dialog box. Preview the label set and creation information.

Design Criteria Tab (Create Alignment from Existing Alignment Dialog Box)
Use this tab to specify the design criteria settings, including the design criteria file and design check set.
Name
Specifies the name of the alignment. Each alignment must have a unique name.
Description
Specifies an optional description of the alignment.
Starting Station
Specifies the station value that is assigned to the beginning of the first alignment entity created.
By default, this value is the lowest station that you specified, or the starting station of the beginning
sub-entity that you selected.
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NOTE Use the Station Control tab in the Alignment Properties dialog box to change the starting station after
you create an alignment.

Starting Design Speed
Specifies the design speed at the alignment starting station. If no other design speeds are applied to the
alignment, then the Starting Design Speed is applied to the entire alignment.

Use Criteria-Based Design
Specifies whether design criteria is applied to the alignment. If this check box is cleared, then the Use Design
Criteria File and Use Design Check Set options are not available.

Use Design Criteria File
Use Design Criteria File
Specifies whether to associate a design criteria file with the alignment. If this check box is cleared, then
the design criteria file selector and Default Criteria table are not available.
For more information, see Design Criteria Files (page 936).
Design Criteria File Selector
Specifies the design criteria file to associate with the alignment. The first design criteria file found in the
C:\Documents and Settings\All Users\Application Data\Autodesk\C3D2011\enu\Data\Corridor Design
Standards\<units> directory is used by default. Click

to select a different design criteria file.

Default Criteria Table
Displays the alignment standards formulas that are defined in the selected design criteria file. Click the
Value column to change a criteria table.

Use Design Check Set
Use Design Check Set Check Box
Specifies whether to associate a design check set with the alignment. If this check box is cleared, then the
Design Check Set list is not available, and the design check is not performed.
For more information, see Alignment Design Check Sets (page 944).
Design Check Set List
Displays the default design check set. You can either accept the default design check set, or use the list to
select a different one from the drawing.
Design Check Set Selection
Edits or copies the current design check set, or creates a design check set.

Create Alignment From Objects Dialog Box
Use this dialog box to specify the attributes of an alignment, including the name, description, style, and
starting station.
Name
Specifies the name of the alignment. Each alignment must have a unique name.
Type
Specifies the alignment type: Centerline, Offset, Curb Return, or Miscellaneous.
Description
Specifies an optional description of the alignment.
Starting Station
Specifies the station value that is assigned to the beginning of the first entity in the alignment.
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NOTE Use the Station Control tab in the Alignment Properties dialog box to change the starting station after
you create an alignment.
General Tab
Site
Specifies a site for the alignment. Select a site from the list, or click
to either create a site or select one
from an object in the drawing. The alignment and the object you select in the drawing are associated with
the same site.
NOTE The default selection is <None>, which places the alignment in the top-level Alignments collection in
Prospector. See Alignment and Site Interaction (page 781) for more information.
Alignment Style List
Displays the current style. Click the arrow to select another alignment style in the drawing.
Style Selection
Specifies the style options. Create a style, copy or edit the current style selection, or pick a style from
drawing.
Style Detail
Opens the Style Detail dialog box. Preview the style and creation information.
Alignment Layer Display List
Displays the layer on which the alignment object will be created.
Object Layer
Opens the Object Layer Dialog Box (page 2221), in which you can select or create a layer on which the
alignment will be drawn.
Alignment Label Set List
Displays the default alignment label set. You can either accept the default label set, or use the list to select
a different one from the drawing.
Label Set Selection
Edits or copies the current label set, or creates a label set. The Style Detail icon previews the current style.
Style Detail
Opens the Style Detail dialog box. Preview the label set and creation information.

Conversion Options
Add Curves Between Tangents
Specifies whether to automatically add curves between each tangent.
■

Selected: Curves are placed at each tangent-tangent intersection. The radius of the curve is calculated
as a percentage of the tangent length and the deflection angle.

■

Cleared: Curves are not added automatically during creation.

NOTE You can add curves using the Alignment Layout Tools.
Erase Existing Entities
Specifies whether the entities you selected when creating the alignment are erased. Select the check box
to erase the entities.
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Design Criteria Tab
Starting Design Speed
Specifies the design speed at the alignment starting station. If no other design speeds are applied to the
alignment, then the Starting Design Speed is applied to the entire alignment.
Use Criteria-Based Design
Specifies whether design criteria is applied to the alignment. If this check box is cleared, then the Use
Design Criteria File and Use Design Check Set options are not available.
Use Design Criteria File
Specifies whether to associate a design criteria file with the alignment. If this check box is cleared, then
the design criteria file selector and Default Criteria table are not available.
For more information, see Design Criteria Files (page 936).
Design Criteria File Selector
Specifies the design criteria file to associate with the alignment. The first design criteria file found in the
following directory is used by default: C:\Documents and Settings\All Users|Application
Data\Autodesk\C3D2011\enu\Data\Corridor Design Standards\<units>. Click
criteria file.

to select a different design

Default Criteria Table
Displays the standards formulas that are defined in the selected design criteria file. Click the Value column
to change a criteria table.

Use Design Check Set
Use Design Check Set Check Box
Specifies whether to associate a design check set with the alignment. If this check box is cleared, then the
Design Check Set list is not available.
For more information, see Alignment Design Check Sets (page 944).
Design Check Set List
Displays the default design check set. You can either accept the default design check set, or use the list to
select a different one from the drawing.
Design Check Set Selection
Edits or copies the current design check set, or creates a design check set.
Related procedures:
■

Creating an Alignment from Graphic Entities (page 952)

■

Criteria-Based Alignment Design (page 935)

Create Alignment - Layout Dialog Box
Use this dialog box to enter information about an alignment, such as its name, a description, and the starting
station for the alignment. Also, you can use it to select an alignment style, label set style, site, and design
criteria.
Related procedures:
■

Creating an Alignment with the Alignment Layout Tools (page 948)

■

Criteria-Based Alignment Design (page 935)
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General Tab (Create Alignment - Layout Dialog Box)
Use this tab to enter basic information about the alignment, including site, style, layer, and label set.
Name
Specifies the name of the alignment. Each alignment must have a unique name.
Description
Specifies an optional description of the alignment.
Starting Station
Specifies the station value that is assigned to the beginning of the first alignment entity created.
NOTE Use the Station Control tab in the Alignment Properties dialog box to change the starting station after
you create an alignment.

Site
Specifies a site for the alignment. Select a site from the Site list, or click
to either create a site or select
one from an object in the drawing. The alignment and the object you select in the drawing are associated
with the same site.
NOTE The default selection is <None>, which places the alignment in the top-level Alignments collection in
Prospector. See Alignment and Site Interaction (page 781) for more information.

Alignment Style
Alignment Style List
Displays the current style. Click the arrow to select another alignment style in the drawing.
Style Selection
Specifies the style options. Create a style, copy or edit the current style selection, or pick a style from
drawing.
Style Detail
Opens the Style Detail dialog box. Preview the style and creation information.

Alignment Layer
Alignment Layer Display List
Displays the layer on which the alignment object is created.
Object Layer
Opens the Object Layer Dialog Box (page 2221), in which you can select or create a layer on which the
alignment is drawn.

Alignment Label Set
Alignment Label Set List
Displays the default alignment label set. You can either accept the default label set, or use the list to select
a different one from the drawing.
Label Set Selection
Edits or copies the current label set, or creates a label set. The Style Detail icon previews the current style.
Style Detail
Opens the Style Detail dialog box. Preview the label set and creation information.
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Design Criteria Tab (Create Alignment - Layout Dialog Box)
Use this tab to specify the design criteria settings, including the design criteria file and design check set.
Name
Specifies the name of the alignment. Each alignment must have a unique name.
Description
Specifies an optional description of the alignment.
Starting Station
Specifies the station value that is assigned to the beginning of the first alignment entity created.
NOTE Use the Station Control tab in the Alignment Properties dialog box to change the starting station after
you create an alignment.

Starting Design Speed
Specifies the design speed at the alignment starting station. If no other design speeds are applied to the
alignment, then the Starting Design Speed is applied to the entire alignment.

Use Criteria-Based Design
Specifies whether design criteria is applied to the alignment. If this check box is cleared, then the Use Design
Criteria File and Use Design Check Set options are not available.

Use Design Criteria File
Use Design Criteria File
Specifies whether to associate a design criteria file with the alignment. If this check box is cleared, then
the design criteria file selector and Default Criteria table are not available.
For more information, see Design Criteria Files (page 936).
Design Criteria File Selector
Specifies the design criteria file to associate with the alignment. The first design criteria file found in the
C:\Documents and Settings\All Users|Application Data\Autodesk\C3D2011\enu\Data\Corridor Design
Standards\<units> directory is used by default. Click

to select a different design criteria file.

Default Criteria Table
Displays the alignment standards formulas that are defined in the selected design criteria file. Click the
Value column to change a criteria table.

Use Design Check Set
Use Design Check Set Check Box
Specifies whether to associate a design check set with the alignment. If this check box is cleared, then the
Design Check Set list is not available.
For more information, see Alignment Design Check Sets (page 944).
Design Check Set List
Displays the default design check set. You can either accept the default design check set, or use the list to
select a different one from the drawing.
Design Check Set Selection
Edits or copies the current design check set, or creates a design check set.
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Create Best Fit Alignment Dialog Box
Use this dialog box to specify the settings to use when creating an alignment by best fit through a series of
objects.

Input Data
Input Type
Specifies the type of source objects (AutoCAD Blocks, AutoCAD Entities, AutoCAD Points, COGO Points,
or Feature Lines) from which to create the best fit alignment.
Weeding Options
Opens the Weeding Options dialog box, which enables you to specify options for adding or removing
vertices when using either feature lines or AutoCAD entities as the input data.
Path 1
Specifies that the alignment is created through a single path of regression points.
Use this option to create an alignment from centerline sample data.
Path 2
Specifies that the alignment is created between two paths of regression points.
Use this option to create a centerline alignment between sample data of the either the edges of pavement
of a road, or the left and right rails.

Best Fit Options
These options affect the manner in which the best fit algorithm is applied to the input data.
Maximum Radius For Curve Detection
Specifies the largest acceptable radius of curves that are created from the input data.
NOTE This value is an estimate. For best results, specify a value that is slightly greater than the largest known
radius in the input data.
Create Spirals
Specifies that spirals are created between the alignment tangents and curves. The spirals on either side of
a curve are symmetric unless the match tangents option is selected.
NOTE When this option is selected, the options below it become available.
Desired R/A For Spirals
Specifies the target R/A ratio for spirals that are created.
Create Spirals And Match Tangents Where Possible
Specifies that the solution will follow the tangents as much as possible. If no solution is available, then
the tangents are moved toward the circles until a spiral solution is found between the tangent and the
curve.
Minimum R/A For Spirals
Specifies the minimum R/A ratio for spirals that are created. This value controls the length of the spirals:
■

A higher value produces shorter spirals.

■

A lower value produces longer spirals.

Creation Settings
Alignment Name
Specifies the name of the alignment. Each alignment must have a unique name.
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Site
Specifies a site for the alignment. Select a site from the Site list, or enter a new site name.
NOTE The default selection is <None>, which places the alignment in the top-level Alignments collection in
Prospector. See Alignment and Site Interaction (page 781) for more information.
Alignment Style
Displays the current style. Click the arrow to select another alignment style.
Alignment Label Set
Displays the default alignment label set. Click the arrow to select another alignment label set.
Layer
Displays the layer on which the alignment object is created. Click the arrow to select another layer.

Show Report
Opens the Best Fit Alignment Report Vista (page 1972), which lists the results of the best fit regression, including
the coordinates of each regression point.
Related procedures:
■

Creating an Alignment by Best Fit (page 960)

Create Offset Alignments Dialog Box
Use this dialog box to create dependent offset alignments from an existing alignment.
You can create multiple offsets in a single operation, including a different number on each side of the parent
alignment. The offset distance can be different on each side of the parent alignment.
Alignment to Offset From
Specifies the name of the parent alignment.
Offsets Name Template
Specifies the format of the alignment name. If you want to change this format, click the button to open
the Name Template Dialog Box (page 2022).
Station Range
Specifies the start and end stations on the parent alignment where the offset alignments will start and
end. You can either enter numeric values, or click the buttons and pick locations in the drawing.
No. of Offsets on Left/Right
Specifies the number of offsets to create on each side of the alignment. Left and right sides are determined
from a position facing toward the end of the parent alignment.
Incremental Offset on Left/Right
Specifies the offset distance on each side, between each pair of alignment.
General Tab
Site
Specifies a site for the alignment. Select a site from the list, or click
to either create a site or select one
from an object in the drawing. The alignment and the object you select in the drawing are associated with
the same site.
NOTE The default selection is <None>, which places the alignment in the top-level Alignments collection in
Prospector. See Alignment and Site Interaction (page 781) for more information.
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Alignment Style List
Displays the current style. Click the arrow to select another alignment style in the drawing.
Style Selection
Specifies the style options. Create a style, copy or edit the current style selection, or pick a style from
drawing.
Style Detail
Opens the Style Detail dialog box. Preview the style and creation information.
Alignment Layer Display List
Displays the layer on which the alignment object will be created.
Object Layer
Opens the Object Layer Dialog Box (page 2221), in which you can select or create a layer on which to draw
the alignment.
Alignment Label Set List
Displays the default alignment label set. You can either accept the default label set, or use the list to select
a different one from the drawing.
Label Set Selection
Edits or copies the current label set, or creates a label set. The Style Detail icon previews the current style.
Style Detail
Opens the Style Detail dialog box. Preview the label set and creation information.
Widening Criteria Tab
Add Widening Around Curves
Specifies to add widening to curved sections of the offset alignment. When this option is selected, you
can specify the widening using design standards, or specify the widening manually, by entering numeric
values into the Increase in Width and Transition Length fields.
Specify Widening Through Design Standards
This option is available when the Add Widening Around Curves option is selected. It adds widening to
curved sections of the offset alignment according to the rules specified in the design criteria file that is
associated with the parent alignment. A valid design criteria file must be available for selection to use
this option. When this option is selected, you can specify a variety of widening property values in the
property table.
Specify Widening Manually
This option is available when the Add Widening Around Curves option is selected. It adds widening to
curved sections of the offset alignment according to values entered in the Increase in Width and Transition
Length fields.
Use Design Check Set Check Box
Specifies whether to associate a design check set with the offset alignment. If this check box is cleared,
then the Design Check Set list is not available.
For more information, see Alignment Design Check Sets (page 944).
Design Check Set List
Displays the default design check set. You can either accept the default design check set, or use the list to
select a different one from the drawing.
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Design Check Set Selection
Edits or copies the current design check set, or creates a design check set.
Related procedures:
■

Creating Offset Alignments (page 956)

■

Alignment Design Check Sets (page 944)

Curve and Spiral Settings Dialog Box
Use this dialog box to enter the curve settings you want to use when creating alignments or parcels using
the Tangent-Tangent (With Curves) command and to specify the spiral defaults.
While you can select various combinations of Spiral In, Curve, and Spiral Out, the A value of the spirals is
controlled by the radius of the curve. The length of the spirals is controlled by changing the A Value.
NOTE If the alignment has design criteria applied to it, the default values specified in the Curve and Spiral Settings
dialog box will not be used. Instead, the minimum values in the specified design criteria file will be applied. For
more information, see Creating an Alignment with the Alignment Layout Tools (page 948).
For more information on spirals and spiral formulas, see Spiral Definitions (page 1011).
Type
Specifies the spiral type.
NOTE The spiral type you specify is used in all spiral commands on the Alignment Layout Tools toolbar.
Spiral In
Specifies whether your design includes a spiral either before a curve or before a Spiral Out.
Length
Specifies the length for the Spiral In.
A Value
Specifies the A value for the Spiral In.
Curve
Specifies how a curve is inserted: either with or without the Spiral In, with or without the Spiral Out or
by itself.
Radius
Specifies a radius value. This value applies to curves and spirals. If you change the curve radius, the A
value also changes.
Spiral Out
Specifies whether your design includes a Spiral Out.
Length
Specifies the length for the Spiral Out.
A Value
Specifies the A value for the Spiral Out.

Edit Feature Settings - Alignment Dialog Box
Use this dialog box to view and change alignment-related settings.
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This topic documents settings in all alignment-related Edit Settings dialog boxes (drawing-level, feature-level,
and command-level).
■

Drawing-level ambient settings are identified by the

■

Alignment feature settings are listed near the top of this dialog box, after the General property group,
and are identified by the

■

drawing icon.

alignment icon.

Alignment command settings are identified by the

command icon.

For general information about drawing, feature, and command settings and their interaction, see Working
with the Standard Settings Dialog Box Controls (page 78).
For information about drawing-level ambient settings, see Ambient Settings Tab (Drawing Settings Dialog
Box) (page 2078)
These settings establish the default styles assigned to alignments and alignment-related labels.

Default Styles
Use these settings to specify the default styles for new alignments.
Alignment Style
Specifies the default alignment style. Click in the Value column, and click
Alignment Style dialog box.

to select a style in the

Alignment Label Set
Specifies the default alignment label set. Click a cell in the Value column, and click
set in the Alignment Label Set dialog box.

to select the label

Marker Style
Specifies the display and appearance of points on the alignment. Click in the Value column, and click
to select a style in the Marker Style dialog box.
Line Label Style
Specifies the default line label style. Click in the Value column, and click
Label Style dialog box.

to select a style in the Line

Curve Label Style
Specifies the default curve label style. Click in the Value column, and click
Curve Label Style dialog box.

to select a style in the

Spiral Label Style
Specifies the default spiral label style. Click in the Value column, and click
Label Style dialog box.

to select a style in the Spiral

Station Offset Label Style
Specifies the default station offset label style. Click in the Value column, and click
the Station Offset Label Style dialog box.

to select a style in

Tangent Intersect Label Style
Specifies the default tangent intersection label style. Click in the Value column, and click
style in the Tangent Intersect Label Style dialog box.
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to select a

For information about style selection, see Select Style Dialog Box (page 2021).

Default Name Format
Use these settings to specify the default name formats for new alignments. Click in the Value column, and
click

to make changes in the Name Template dialog box (page 2022).

Station Indexing
Use this setting to specify the default station increment.
Default Station Index Increment
Specifies the default value for station increments.

Superelevation Options
Use these settings to specify defaults for calculating superelevation.
Number of Lanes - Left
Specifies the number of lanes on the left side of the roadway.
Number of Lanes - Right
Specifies the number of lanes on the right side of the roadway.
Roadway Type
Specifies the roadway type as Divided or Undivided.
Cross Section Shape
Crowned: Specifies the cross sectional shape of the roadway as Planar or :
■

Planar: There is no change in slope between the travel lanes.

■

Crowned: When no superelevation is applied, travel lanes slope downward in opposite directions from
a common crown point.

Highside Location (For Undivided Planar Roads)
Specifies the default Highside Location for planar roads.
■

Left Edge: Specifies that the high side of the roadway is on the left edge on tangent (unsuperelevated)
sections when the corridor type is Undivided and the Cross Section Shape is planar.

■

Level: The roadway is level (0% slope) on tangent sections.

■

Right Edge: Specifies that the high side of the roadway is on the right edge on tangent (unsuperelevated)
sections, when the corridor type is Undivided and the Cross Section Shape is planar.

Normal Lane Width
Specifies the lane width or click

and select a distance in the drawing area.

Normal Shoulder Width
Specifies the typical roadway shoulder width.
Normal Lane Slope (%)
Specifies the % slope of the roadway lanes on tangent (unsuperelevated) tangents. Typical values are -15%
to -2.5% for the slope used for roadway lanes when no superelevation is applied.
Normal Shoulder Slope (%)
Specifies the % slope value of the roadway shoulders. This value is only required if either of the shoulder
superelevation methods is not set to Default. Default value for a normal shoulder slope is -5%.
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% On Tangent For Tangent-Curve
percentage of total transition length that is achieved before the beginning of curve (BC) point in
tangent-curve geometry.
%On Spiral For Spiral-Curve
percentage of total transition length that is achieved before the beginning of curve (BC) point in spiral-curve
geometry.
Station Rounding Option
Specifies the number of positions for station rounding. Click the Value cell and choose one of the following
from the list:
■

None: leaves stations as they are specified in the table

■

0.1: rounds to the nearest tenth value of the station

■

1: rounds up to nearest full station value

■

5: rounds up to nearest fifth meter or foot

■

10: rounds up to nearest tenth meter or foot

NOTE The following options for Outside Shoulder Superelevation Method and Inside Shoulder Superelevation
Method are only available if the Cross Section Shape is Crowned. These options are not available for Planar roads.
Outside Shoulder Superelevation Method
Specifies the method that is applied to the outside shoulder during superelevation:
■

Default Slopes: Default slopes are retained and shoulders are not superelevated.

■

Match Lane Slopes: Shoulder slopes match the slopes applied to the adjacent traveled ways through
out the superelevation process.

■

Breakover Removal: Shoulders on the outside edge of the curve are adjusted upward to match the
Normal Lane Slope (%) before the lane begins to superelevate. The high-side shoulder slope matches
the high-side lane slope throughout the superelevation process, and it then rotates downward back
to the Normal Shoulder Slope (%) value when the lanes are back to the unsuperelevated condition.

Inside Shoulder Superelevation Method
Specifies the method that is applied to the inside shoulder during superelevation:
■

Default Slopes: Default slopes are retained and shoulders are not superelevated.

■

Match Lane Slopes: Shoulder slopes match the slopes applied to the adjacent traveled ways through
out the superelevation process.

■

Breakover Removal: Shoulders on the outside edge of the curve are adjusted upward to match the
Normal Lane Slope (%) before the lane begins to superelevate. The high-side shoulder slope matches
the high-side lane slope throughout the superelevation process, and it then rotates downward back
to the Normal Shoulder Slope (%) value when the lanes are back to the unsuperelevated condition.

Design Speed Lookup Method
Specifies the table lookup rule in cases where the actual design speed does not exactly match the speed
specified in the design criteria tables:
■

Interpolate: Table values are interpolated to the given speed.

■

Use Nearest Higher Speed: Uses the table values that correspond to the next highest design speed found
in the table. (Conservative rule)

■

Round To Nearest Speed: Uses the table values corresponding to the nearest speed, either higher or
lower.
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Radius Lookup Method
Specifies the table lookup rule in cases where the actual radius does not exactly match the speed specified
in the design criteria tables:
■

Interpolate: Interpolates table values for the curve group radius.

■

Use Nearest Lower Radius: Uses table values corresponding to the next lowest radius found in the
table.(Conservative rule)

■

Round To Nearest Radius: Uses table values corresponding to the nearest radius value found in the
table.

Curve Smoothing Length
Specifies the default curve smoothing length used in superelevation.

Linear Transition Around Curves
Use these settings to specify the default settings for how linear transitions around curves are created in
widening situations. For more information, see Setting Defaults for Linear Transitions Around Curves in
Widenings (page 969).
Number of Segments
Specifies how many segments to use when creating linear transitions at curves.
Transition Segment Type
Specifies the type of segments to be used in distributing widening transition linearly around curves. The
choices are lines or arcs.

Automatic Widening Around Curves
Use these settings to specify defaults for the Add Automatic Widening command. For more information,
see Adding Automatic Widening to Dynamic Offset Alignments (page 966)
Widening to Apply on
This value, in combination with the Number of Lanes specified in the Widening Method, specifies the
amount of widening to be applied on the left-side and or the right-side offset alignments. If Inside Only
is used, then the widening value is increased to match the number of lanes on either side of the road
(doubled if the number of lanes on the inside and the outside are the same), and applied on all of the
inside offset for the widening. On the outside at these stations, no widening is applied.
Wheelbase Length
Specifies a numeric value for the wheelbase length that is used in the formula for widening around curves.
This value is used only when the widening method is through design standards. It is not used when the
widening is specified manually.
Add Automatic Widening At Curves
Specifies whether or not to automatically add widening at curves.
Widening By
Specifies the default method for applying the automatic widening - either by using design standards, or
manually (by entering values into the Increase in Width and Transition Length fields on the Add Automatic
Widening dialog box). When Through Design Standards is the default, the Specify Widening Using Criteria
option on the Add Automatic Widening dialog box is selected by default. When Manually is the default,
the Specify Widening Manually option is selected.
Manual Widening Width
Specifies the default value for the Increase in Width field on the Add Automatic Widening dialog box.
Manual Transition Length
Specifies the default value for the Transition Length field on the Add Automatic Widening dialog box.
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Criteria-Based Design Options
Use these settings to specify defaults for creating an alignment using design criteria.
Default Design Speed
Specifies the default alignment design speed. Enter a speed in the Value column or click
design speed in the drawing area.

and select a

Criteria-Based Design Option
Specifies whether alignments use design criteria by default. If this option is set to False, the remaining
Criteria-Based Design Options are not available.
NOTE If the Criteria-Based Design Option is set to False, then the remaining Criteria-Based Design Options are
not available.
Use Design Criteria File Option
Specifies whether to use a design criteria file by default. If this option is set to True, then the first XML
file found in the <install directory>\Data\Corridor Design Standards\<units> directory is used by default.
Use Design Checks Option
Specifies whether to use a design check set by default.
Default Design Check Set
Specifies the default design check set. Click in the Value column, and click
Design Check Set dialog box.

to select a set in the Default

Dynamic Alignment Highlight Options
Use these settings to specify highlighting defaults for dynamic offset alignments.
Offset Region Color & Lineweight
Specifies the color and lineweight of the highlighting on a dynamic offset alignment region when it is
selected in the Offset Alignment Parameters dialog box.
Transition Region Color & Lineweight
Specifies the color and lineweight of the highlighting on the widening transition segment when it is
selected in the Offset Alignment Parameters dialog box.
Curb Return Fillet Region Color & Lineweight
Specifies the color and lineweight of the curb return fillet when it is selected in the Intersection Curb
Return Parameters dialog box.
Parent Alignment Color & Lineweight
Specifies the color and lineweight of the parent alignment associated with the dynamic offset alignment,
when the primary\secondary roads are selected in the Intersection Offset Parameters dialog box, or
incoming and outgoing roads are selected in the Intersection Curb Return Parameters dialog box.
Parent Alignment Tracker Color & Lineweight
Specifies the color and lineweight used to identify the tracker line. The tracker line is a temporary line
that identifies the corresponding location on the parent alignment when a location on the offset alignment,
intersection offset, or curb return is selected in the associated parameters dialog box.

Dynamic Offset Alignment Options
Use these settings to specify the default settings for creating new dynamic offset alignments.
From Parent Alignment Start
Specifies offset alignments to start from the start of the parent alignment.
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To Parent Alignment End
Specifies offset alignments to end at the end of the parent alignment.
Number of Offsets - Left Side
Specifies how many offset alignments to create on the left side of the parent alignment when using the
create offset alignment command.
Number of Offsets - Right Side
Specifies how many offset alignments to create on the right side of the parent alignment when using the
create offset alignment command.
Incremental Offset Value – Left Side
Specifies the incremental offset value to use when creating offset alignments on the left side of a parent
alignment. For example, if a value of 5 is specified when there are 2 offsets on the left side, the first offset
is created at 5 (feet or meters, depending on units), and the second offset is created at 10 (feet or meters).
Incremental Offset Value – Right Side
Specifies the incremental offset value to use when creating offset alignments on the right side of a parent
alignment. For example, if a value of 5 is specified when there are 2 offsets on the right side, the first offset
is created at 5 (feet or meters, depending on units), and the second offset is created at 10 (feet or meters).

Offset Alignment Parameters Dialog Box
Use this dialog box to view, add, or edit widening or automatic widening parameters for the currently selected
offset alignment.
NOTE If the offset alignment does not have any widening or automatic widening specified on it, this dialog box
shows just the parent alignment name and nominal offset values.
Parent Alignment Name
Identifies the name of the parent alignment for this offset alignment.
Nominal Offset
Specifies the current offset distance for regions of the alignment that are not widened. You can edit this
value.
Select Widening Region
Use these controls to browse through and select the widening regions associated with this alignment. If
there are no widening regions specified for the alignment, these controls are blank.
Add a Widening
Click to add a new widening, and then specify the parameters.
Add Automatic Widening
Click to add automatic widening, and then specify the parameters.

Click to delete or remove the widening or automatic widening.
Expand All Categories
Click to show all levels of the parameter tree.
Collapse All Categories
Click to hide all sublevels of the parameter tree, showing only the region and transition headings.
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Help
Displays the Help topic for this dialog box.
NOTE When you select an item in the property table on this dialog box, it is highlighted in the drawing.

Transition In\Out
Expand this node to view the Transition In and Transition Out properties.
Transition Type
For widenings, the transition type can be one of following four types:

Linear transition

Curve-Line-Curve transition

Curve-Curve-Reverse Curve transition

Curve- Reverse Curve transition

Automatic widenings can only be linear transition type.
Taper Input Type
For transitions, specifies how the offset is designed: either By Length (longitudinal) or By Taper Ratio
(offset: station distance).
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Transition Length
Specifies the length of the transition.

Widening Region
Expand this node to view the Widening Region properties.
Region Type
This read-only field displays the type of widening applied to the region. When the widening was applied
using the Add Widening command, the region type is User Defined. When the widening was applied
using the Add Automatic Widening command, the region type is Automatic Widening.
Increased Width From Standard
Specifies the width (distance) from the standard (criteria file) definition when the widening has been
added using the Automatic Widening command. This property is not available when Add Widening has
been applied.
Offset
Specifies the offset width (distance) when the widening has been added using the Add Widening command.
This property is not available when Automatic Widening has been applied.
Start/End Station
Specifies the start or end station for the currently selected offset alignment. You can edit numeric values
in this dialog box, or click

and then click a station value in the drawing.

Region Length
Specifies the length of the region this offset alignment is associated with. You can edit the numeric value
in the table, or click
and click two points in the drawing to specify a length. Changes to this value
also change the end station value for the region.

Widening Criteria
Expand this node to view the Widening Criteria properties. Click in the cell to specify a different value.
Widening Method
When automatic widening has been applied, and the automatic widening has been specified according
to values defined in a design criteria file, this field displays the value of the Widening Method property
defined in the criteria file. When automatic widening has been applied, and the automatic widening has
been specified manually, this field is blank.
Widening To Apply On
Specifies how the manual widening is applied. The choices are: a.) Inside Only: Applies the automatic
widening to just the insides of curves, not the outsides of the specified curves. b.) Outside Only: Applies
the automatic widening to just the outsides of curves, not the insides of the specified curves. c.)Both Sides:
Applies the automatic widening to both the inside and outside of the specified curves.
The default value for this property is defined in the command settings (Automatic Widening Around
Curves property group).
Minimum Radius Table
Specifies the minimum radius table to use when applying the widening. This property is defined in the
Widening Methods section of the specified design criteria file.
Transition Length Table
Specifies the transition length table to use when applying the widening. This property is defined in the
Widening Methods section of the specified design criteria file.
Attainment Method
Specifies the attainment method to use when applying the widening. This property is defined in the
Widening Methods section of the specified design criteria file.

Offset Alignment Parameters Dialog Box | 1991

% on Spiral for Spiral-Curve
Specifies the percentage of total transition length that is achieved before the beginning of curve (BC)
point in spiral-curve geometry.
% on Tangent for Tangent-Curve
Specifies the percentage of total transition length that is achieved before the beginning of curve (BC)
point in tangent-curve geometry.
Normal Lane Width
Specifies the lane width or click
and select a distance in the drawing area. The default value for this
property is defined in the command settings (Superelevation Options property group).
Number of Lanes - Left
Specifies the number of lanes on the left side of the roadway. The default value for this property is defined
in the command settings (Superelevation Options property group).
Number of Lanes - Right
Specifies the number of lanes on the right side of the roadway. The default value for this property is
defined in the command settings (Superelevation Options property group).
Wheelbase Length
Specifies a numeric value for the wheelbase length that is used in the formula for widening around curves.
This value is used only when the widening method is through design standards. It is not used when the
widening is specified manually.
The default value for this property is defined in the command settings (Automatic Widening Around
Curves property group).
Related procedures:
■

Widenings (page 964)

■

Editing Offset Alignments and Widenings (page 1077)

Profile Geometry Points Dialog Box
Use this dialog box to specify the profile geometry points that you want to label.

Select Profile
Lists the profiles that are available for selection. Click

to select a profile from the drawing.

Description
Displays the description of the selected profile. A profile description is set in the profile properties.

Select Geometry Points To Label
Select All
Selects all check boxes in the Label column.
Deselect All
Clears all check boxes in the Label column.
Profile Geometry Points Column
Identifies the available geometric details.
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NOTE The Abbreviations (page 2077) tab in the Drawing Settings dialog box also lists these geometry points.
Label Column
Specifies whether to label a geometry point.
Related procedures:
■

Using Label Sets (page 1045)

Superelevation Critical Points Dialog Box
Use this dialog box to specify the superelevation critical points that you want to label.

Select Superelevation Points To Label
Select All
Selects all check boxes in the Label column.
Deselect All
Clears all check boxes in the Label column.
Superelevation Points Column
Identifies the available geometric details.
NOTE The Abbreviations (page 2077) tab in the Drawing Settings dialog box also lists these geometry points.
Label Column
Specifies whether to label a geometry point.
Related procedures:
■

Using Label Sets (page 1045)
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Assemblies and
Subassemblies Dialog
Boxes
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The following topics provide information about the Assemblies and Subassemblies dialog boxes.

Assembly Properties Dialog Box
Use this dialog box to edit the properties of an assembly.

Information Tab (Assembly Properties Dialog Box)
Use this tab to view or edit general information about the assembly.
Name
Specifies the name of the current assembly.
Description
Specifies an optional description for the current assembly.
Object Style
Specifies the style used to display the current assembly. See Select Style Dialog Box (page 2021) or Assembly
Style Dialog Box (page 1997) for more information.
Show Tooltips
Controls whether tooltips are displayed for the object in the drawing (not over toolbar icons).

Construction Tab (Assembly Properties Dialog Box)
Use this tab to view the organizational structure of the subassemblies and subassembly groups comprising
the assembly.
Item
The left pane tree view displays the organizational structure of the assembly. Subassemblies are displayed
in the tree view in the order in which they are processed (top to bottom). This is the same order in which
each subassembly was added to the assembly. The tree view also shows how the subassembly groups are

1995

connected to a primary baseline, or to a given offset line. You can delete, move or rename many items in
this view using the right-click shortcut menu.
Input Value
When a subassembly is selected in the left pane, this pane lists information on the input parameter values
that are used to calculate the size, shape, and geometry of the subassembly.
Value Name
Specifies the name of each input parameter associated with the subassembly.
Default Input Value
Specifies the input parameter value used in the processing for the selected subassembly. To edit this field,
double-click in it.
Parameter Reference
Specifies that the output value from another subassembly is used as the input parameter value for the
selected subassembly.
■

Use: The value specified in the Get Value From field is used for the input parameter value instead of
the default input parameter value.

■

Get Value From: Specifies the output value from another subassembly that is used as the input parameter
value for the selected subassembly.

Output Value
Lists read-only information about any output parameter values used during processing for the selected
subassembly. These output values can be used as input values for other subassemblies. The actual output
values are calculated only when the assembly is applied (when the corridor is created).
Value Name
Specifies the name of any output parameters for the selected subassembly.
Output Value
Specifies the value of any output parameters for the selected subassembly.

Subassembly Help
When a subassembly is selected in the tree view, click this button to display the Help topic describing the
construction, behavior, and other details of the subassembly.

Codes Tab (Assembly Properties Dialog Box)
Use this tab to edit the display styles for the codes associated with the selected assembly.
Code Set Style
Specifies the current code set style for the assembly. For more information, see Select Style Dialog Box
(page 2021).
The properties table contains the following columns:
Name
Displays an expandable tree with a collection for each type of code: Link, Point, and Shape. Expand the
collections to display the individual codes. For information about codes, see Understanding Point, Link,
and Shape Codes (page 1568).
Description
Displays the description of each code.
Style
Displays the style assigned to each code.
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Label Style
Displays the label style assigned to each code or <none> if no label style is assigned.
Render Material
Displays the render material assigned to each code or <none> if no render material is assigned.
Material Area Fill Style
Displays the Material Area Fill style assigned to each code or <none> if no label style is assigned.
Pay Item
Displays the ID of any pay item attached to any Link or Point. For more information, see Assigning Pay
Items to Corridors (page 1301).

Assembly Style Dialog Box
Use this dialog box to control the display of the assembly in the drawing.

Information Tab (Assembly Style Dialog Box)
Use this tab to edit the assembly style name and description and to review details, such as when the style
was created and most recently used.
For more information, see Information Tab (Style Dialog Box) (page 2017).

Marker Tab (Assembly Style Dialog Box)
Use this tab to specify the appearance of the assembly components (insertion point, baseline, baseline point,
offset, and offset point) in the drawing.
Component
Specifies the assembly component for which you want to specify the appearance.
Use AutoCAD POINT For Marker
Specifies that the assembly component is displayed using the current AutoCAD point symbol, which is
specified by the AutoCAD PDMODE and PDSIZE system variables.
Use Vertical LINE For Marker
Specifies that a vertical line is used for the component. Used for baseline and offset components. You can
specify the length of the line using the Size field.

Use Custom Marker
Use Custom Marker
Displays the assembly using the specified symbol.
Custom Marker Style
Specifies the symbol for displaying the marker. Click one of the five symbols to the left to use as a base
symbol. Optionally, click the sixth symbol, the seventh symbol, or both, to superimpose them over the
base symbol. The specified symbol combination is displayed in the Preview window.

Use AutoCAD Block Symbol For Marker
Use AutoCAD BLOCK Symbol For Marker
Displays the assembly using a reference to the selected AutoCAD block. The block is scaled using the
options specified under Size.
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Blocks
Lists block definitions available in the drawing. Do one of the following:
■

Click a block name to select the block to be used for the assembly symbol. The block is displayed in
the Preview window.

■

Right-click in the block list window and click Browse to select a block located in another folder.

The specified block is displayed in the Preview window.

Marker Rotation Angle
Marker Rotation Angle
Specifies the rotation angle for the symbol. Applies to all three symbol types (AutoCAD Point, Custom
Marker, and AutoCAD Block). Enter a value or click

to specify an angle.

Size
Options
Specifies symbol scaling:
■

Use Drawing Scale: Determines size of the marker by multiplying the specified value by the drawing
scale. Enter the scale factor.

■

Use Fixed Scale: Activates the Fixed Scale options.

■

Use Size in Absolute Units: Specifies that the marker size is an absolute value based on the displayed
units. Enter the value. This is the only setting applicable for the baseline and offset line components.

■

Use Size Relative to Screen: Specifies that the size of the marker is a percentage of the drawing screen
size. Enter the percentage.

Fixed Scale
Specifies independent fixed scale values when Options is set to Use Fixed Scale. Enter values for X, Y, or
Z.
Orientation reference
Specifies the marker rotation angle:
■

Orient Marker To World Coordinates: Specifies that the maker rotation angle is relative to the world
coordinate system.

■

Orient Marker To View: Specifies that the maker rotation angle is relative to the current AutoCAD view
direction.

Display Tab (Assembly Style Dialog Box)
Use this tab to change the display and visibility of assembly object components.
Assembly components include:
■

Insertion Point: Specifies the location in the drawing where the assembly is inserted.

■

Baseline: In layout mode, the symbol that is used to identify the assembly baseline in a drawing.

■

Baseline Point: Specifies the location that is used as the baseline location (point) for the assembly in the
drawing.

■

Offset: If the assembly is associated with an offset, specifies the offset value.

■

Offset Point: If the assembly is associated with an offset, specifies the offset location in the drawing.
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For more information, see Display Tab (Style Dialog Box) (page 2017).

Summary Tab (Assembly Style Dialog Box)
Use this tab to review all the information for the current assembly style. This information can be copied
and pasted to the clipboard.
For more information, see Summary Tab (Style Dialog Box) (page 2020).

Code Set Style Dialog Box
Use this dialog box to edit the code set style.

Information Tab (Code Set Style Dialog Box)
Use this tab to edit general information for the code set style.
Name
Specifies the code set style name.
Description
Specifies an optional description of the code set style.

Codes Tab (Code Set Style Dialog Box)
Use this tab to view or change the style for each point, link, or shape code included in the code set.
Name
Displays an expandable tree with a collection for each type of code: Link, Point, and Shape. Expand the
collections to display the individual codes. Right-click a code collection to add a style.
Description
Displays the description of each code.
Style
Displays the style assigned to each code. Click

to select a style in the Pick Style dialog box.

Label Style
Displays the label style assigned to each code or <none> if no label style is assigned. Click
style in the Pick Style dialog box.

to select a

Render Material
Displays the render material assigned to each link code or <none> if no render material is assigned. Click
to select a render material in the Select Render Material dialog box, or click
to select a render
material from an object in the drawing. You can only assign render materials to link codes, not point
codes or shape codes.
Material Area Fill Style
Displays the Material Area Fill style assigned to each link code or <none> if no label style is assigned. Click
to select a style in the Pick Style dialog box. You can only assign material area fill style to link codes,
not point codes or shape codes.
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Feature Line Style
Displays the feature line style assigned to each point code. You can only assign feature line style to point
codes, not to link codes or shape codes. des. Click

to select a style in the Pick Style dialog box.

Pay Item
Specifies the ID of any pay item attached to any Link or Point. Click
Item List dialog (page 2588).

to edit the pay item(s) in the Pay

Import Codes
Adds codes from a selected subassembly, assembly, or corridor to this code set.
Related procedures:
■

Understanding Point, Link, and Shape Codes (page 1568)

■

Adding or Importing Codes to a Code Set Style (page 1577)

Create Assembly Dialog Box
Use this dialog box to specify the initial parameters for the assembly, including a style and a layer.
Name
Specifies the name of the assembly.

Opens the Name Template (page 2022) dialog box, where you can modify the naming template.
Description
Specifies an optional description of this assembly.

Assembly Style
Style List
Specifies the assembly style. Select a new style by clicking the drop-down arrow.
Style Selection
Specifies the style options. You can create a new style, copy or edit the current style, or pick a style from
the drawing.
Style Detail
Opens the Style Detail dialog box where you can preview the style and creation information.

Code Set Style
Style List
Specifies the code set style. Select a new style by clicking the drop-down arrow.
Style Selection
Specifies the style options. You can create a new style, or copy or edit the current style.
Style Detail
Opens the Style Detail dialog box where you can preview the style and creation information.

Assembly Layer
Specifies the name of the layer on which this assembly object will be created. To change the layer, click the
Object Layer icon and select a layer.
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Create Subassembly From Polyline Dialog Box
Use this dialog box to specify the initial parameters for a subassembly created from an existing polyline.
Name
Specifies the name of the subassembly.

Opens the Name Template (page 2022) dialog box, where you can modify the naming template.
Description
Specifies an optional description of this subassembly.

Code Set Style
Style List
Specifies the current code set style. Select a new style by clicking the drop-down arrow.
Style Selection
Specifies the style options. You can create a new style, copy or edit the current style, or pick a style from
the drawing.
Style Detail
Opens the Style Detail dialog box where you can preview the style and creation information.

Subassembly Layer
Displays the name of the layer on which this subassembly object will be created. To change the layer, click
the Object Layer icon and select a layer.

Conversion Options
Mid-Ordinate Distance
If the subassembly object contains curves, all curves will be tessellated (converted into a finite number of
segments) using this value to determine the length of the tessellated segments.
Link Creation
Specifies symbol scaling:
■

None: Generates no links. Only points will be created at the vertices.

■

Single: Creates one link from all the segments created from the object selected. This is provided to
make creating shapes simpler. Using the Add Shape right-click command, you only need to perform
one action.

■

Multiple: Creates a new link for each segment created from the object selected. This is useful for
assigning link codes to different parts of the subassembly for creating surfaces and other display
characteristics.

Erase Existing Entities
To retain existing entities, as well as the new subassembly, clear this check box.

Edit Feature Settings - Assembly Dialog Box
Use this dialog box to view and change assembly-specific settings.
This topic documents settings in all assembly-related Edit Settings dialog boxes (drawing-level, feature-level,
and command-level).
■

Drawing-level ambient settings are identified by the

drawing icon.
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■

Assembly feature settings are listed near the top of this dialog box, after the General property group, and
are identified by the

■

assembly icon.

Assembly command settings are identified by the

command icon.

For general information about drawing, feature, and command settings and their interaction, see Working
with the Standard Settings Dialog Box Controls (page 78).
For information about drawing-level ambient settings, see Ambient Settings Tab (Drawing Settings Dialog
Box) (page 2078)

Default Styles
These settings establish the default styles assigned to assembly components:
Assembly Style
Specifies the default style for assemblies. Click in the Value column. Click in the Value column, and click
to select a style in the Assembly Style dialog box.
Code Set Style
Specifies the default code set style. Click in the Value column, and click
Set Style dialog box.

to select a style in the Code

For information about style selection, see Select Style Dialog Box (page 2021).

Default Name Format
Use these settings to specify the default name formats for assemblies, assembly offsets, and assembly groups.
Click in the Value column, and click

to make changes in the Name Template dialog box (page 2022).

Edit Feature Settings - Subassembly Dialog Box
Use this dialog box to view and edit subassembly-specific settings.
This topic documents settings in all subassembly-related Edit Settings dialog boxes (drawing-level, feature-level,
and command-level).
■

Drawing-level ambient settings are identified by the

■

Subassembly feature settings are listed near the top of this dialog box, after the General property group,
and are identified by the

■

drawing icon.

subassembly icon.

Subassembly command settings are identified by the

command icon.

For general information about drawing, feature, and command settings and their interaction, see Working
with the Standard Settings Dialog Box Controls (page 78).
For information about drawing-level ambient settings, see Ambient Settings Tab (Drawing Settings Dialog
Box) (page 2078)

Default Styles
These settings establish the default styles assigned to subassemblies.
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Code Set Style
Specifies the default code set style. Click in the Value column, and click
Set Style dialog box.

to select a style in the Code

For information about style selection, see Select Style Dialog Box (page 2021).

Subassembly Name Templates
Use these settings to specify the default name formats for subassemblies created from macros and from
polylines. Click in the Value column, and click
2022).

to make changes in the Name Template dialog box (page

Create From Entities
NOTE This property group is displayed when you access the settings from the CreateSubFromPline command.
Use these settings to specify the default behavior for creating subassemblies from polylines.
Mid-ordinate Distance
Specifies mid-ordinate distance to approximate curvilinear segments. Enter a distance in the Value column
or click

and select a distance in the drawing area.

Link Creation
Specifies the quantity of subassembly links (None, Single, Multiple) created from the polyline(s).

Import Subassemblies Dialog Box
Use this dialog box to import one or more subassemblies from a package file to a tool palette or catalog.
If you have a package file that contains one or more subassemblies, you can import the subassembly or
subassemblies to an AutoCAD Civil 3D tool palette or catalog.
Related procedures:
■

Sharing Subassemblies (page 1565)

Source File
Specifies the name and location of the package file (.pkt) containing one or more subassemblies.

Opens the Select File dialog box where you can navigate to the package file (.pkt) containing the
subassembly or subassemblies to be imported.

Import To
You can import subassemblies to a tool palette, to a catalog, or to both locations at the same time.
Tool Palette
When this option is selected, the subassemblies will be imported to the selected tool palette. Select a tool
palette by clicking the drop-down arrow. The name of the currently open tool palette is displayed (selected)
by default.
Catalog Library/My Imported Tools
When this option is selected, the subassembly or subassemblies contained in the package file will be
imported to the My Imported Tools catalog in the catalog library. If the My Imported Tools catalog does
not exist, it will be automatically created.
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Link Style Dialog Box
This dialog box defines a link style, which controls the way a subassembly link component is displayed in
a drawing.

Information Tab (Link Style Dialog Box)
Use this tab to change the link style name and description information and to review details, such as when
the style was most recently modified
For more information, see Information Tab (Style Dialog Box) (page 2017).

Display Tab (Link Style Dialog Box)
Use this tab to change the display and visibility of the link component.
For more information, see Display Tab (Style Dialog Box) (page 2017).

Summary Tab (Link Style Dialog Box)
Use this tab to display information about a particular link style. This information can be copied and pasted
to the clipboard.
For more information, see Summary Tab (Style Dialog Box) (page 2020).

Marker Style Dialog Box
This dialog box defines a marker style, which controls the way a subassembly marker (point) component is
displayed in a drawing.

Information Tab (Marker Style Dialog Box)
Use this tab to edit the marker style name and description and to review details, such as when the style was
most recently modified.
For more information, see Information Tab (Style Dialog Box) (page 2017).

Marker Tab (Marker Style Dialog Box)
Use this tab to specify the appearance of the marker symbol in the drawing.

Use AutoCAD Point For Marker
Use AutoCAD Point For Marker
Displays the marker using the current AutoCAD point symbol, which is specified by the AutoCAD PDMODE
and PDSIZE system variables.

Use Custom Marker
Use Custom Marker
Displays the marker using the specified symbol.
Custom Marker Style
Specifies the symbol for displaying the marker. Click one of the five symbols on the left to use as a base
symbol. Optionally, click the sixth symbol, the seventh symbol, or both, to superimpose them over the
base symbol. The specified symbol combination is displayed in the Preview window.
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Use AutoCAD Block Symbol For Marker
Use AutoCAD Block Symbol For Marker
Displays the marker using a reference to the selected AutoCAD block. The block is scaled using the options
specified under Size.
Blocks list
Lists block definitions available in the drawing. Do one of the following:
■

Click a block name to select the block to use for the point symbol. The block is displayed in the Preview
window.

■

Right-click in the block list window. Click Browse to select a block located in another folder.

The specified block is displayed in the Preview window.

Marker Rotation Angle
Marker Rotation Angle
Specifies the rotation angle for the symbol. Applies to all three symbol types (AutoCAD Point, Custom
Marker, and AutoCAD Block). Enter a value or click

to specify an angle.

Orientation Reference
Specifies the Marker Rotation Angle:
■

World Coordinate System: Specifies that the marker rotation angle is relative to the world coordinate
system.

■

View: Specifies that the marker rotation angle is relative to the current AutoCAD view direction.

Size
Options
Specifies symbol scaling:
■

Use Drawing Scale: Determines the size of the marker by multiplying the specified value by the drawing
scale. Enter the scale factor.

■

Use Fixed Scale: Activates the Fixed Scale commands.

■

Use Size in Absolute Units: Specifies that the marker size is an absolute value based on the displayed
units. Enter the value.

■

Use Size Relative to Screen: The size of the marker is a percentage of the drawing screen size. Enter the
percentage.

Fixed Scale
Specifies independent fixed scale values when Options is set to Use Fixed Scale. Enter values for X, Y, or
Z.

Display Tab (Marker Style Dialog Box)
Use this tab to edit the display and visibility of the marker symbol.
For more information, see Display Tab (Style Dialog Box) (page 2017).

Summary Tab (Marker Style Dialog Box)
Use this tab to display information about a particular marker style. This information can be copied and
pasted to the clipboard.
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For more information, see Summary Tab (Style Dialog Box) (page 2020).

Shape Style Dialog Box
Use this dialog box to define a shape style, which controls the way a subassembly shape component is
displayed in a drawing.

Information Tab (Shape Style Dialog Box)
Use this tab to edit the shape style name and description information and to review details, such as when
the style was most recently modified.
For more information, see Information Tab (Style Dialog Box) (page 2017).

Display Tab (Shape Style Dialog Box)
Use this tab to change the display and visibility of the shape’s border and hatch pattern. You can also specify
the hatch pattern style for this shape using this tab.
For more information, see Display Tab (Style Dialog Box) (page 2017).

Summary Tab (Shape Style Dialog Box)
Use this tab to display information about a particular shape style. This information can be copied and pasted
to the clipboard.
For more information, see Summary Tab (Style Dialog Box) (page 2020).

Subassembly Properties Dialog Box
Use this dialog box to view or edit the properties of a subassembly in a drawing.

Information Tab (Subassembly Properties Dialog Box)
Use this tab to view or edit the subassembly object name and description.
Name
Specifies the name of the current subassembly.
Description
Specifies an optional description of the current subassembly.
Show Tooltips
Controls whether a tooltip description is displayed for the subassembly object in the drawing.

Parameters Tab (Subassembly Properties Dialog Box)
Use this tab to view information about subassembly input and output parameters, to edit input parameter
values, and or to display the Help topic for the subassembly.
This tab also displays the method that was used to create (define) this subassembly (VBA, .NET, or from
polyline).
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Input Values
Lists information on the input parameter values that are used to calculate the size, shape, and geometry of
the subassembly. You can edit an input parameter value by clicking on a value in the Default Input Value
column.
NOTE To enter values for grades, enter % values with the percent symbol included. To enter values for slopes,
you can enter a ratio such as 4:1, with the colon included between two numbers, or you can enter a number that
gets converted into a percent value when you click OK or Apply.
Value Name
This read-only field displays the name of each input parameter associated with the subassembly.
Default Input Value
Displays the input parameter value used in the processing for the subassembly. You can click on a value
to edit it. When you edit a value and click OK or Apply, the subassembly object in the drawing is updated.

Output Values
Lists read-only information on any output parameter values used during processing for the subassembly.
These output values can be used as input values for other subassemblies. The actual output values are
calculated only when the assembly is applied.
Value Name
Displays the name of any output parameters used for the subassembly.
Output Value
Displays the value for any output parameters from the subassembly.

Defined From
This read-only field displays the method that was used to create this subassembly. If the subassembly was
created using .NET, .NET is displayed. If the subassembly was created from a polyline, Entities is displayed.
If the subassembly was created using .NET, .NET is displayed.
.NET Class Name
If the subassembly is created from .NET, this field displays the name of the .NET class that defines this
subassembly. If the subassembly is created from VBA, or from a polyline, this field is not displayed.
.NET Assembly Name
Displays the name of the file that defines this subassembly. If the subassembly is created from VBA, or
from a polyline, this field is not displayed.
Macro Name
If the subassembly is created from VBA, this field displays the name of the macro file that defines this
subassembly. If the subassembly is created from a polyline, this field is not available. If the subassembly
is created from .NET, this field is not displayed.
Project Name
If the subassembly is created from VBA, this field displays the name of the project that defines this
subassembly. If the subassembly is created from a polyline, this field is not available. If the subassembly
is created from .NET, this field is not displayed.
Subassembly Help
Clicking
opens the Help topic that describes the construction, behavior, and other definitions of this
subassembly. If the subassembly is created from a polyline, a Help topic is not available.
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Codes Tab (Subassembly Properties Dialog Box)
Use this tab to view or edit display styles for the codes associated with the selected subassembly.
Code Set Style
Specifies the current code set style for the subassembly. For more information, see Select Style Dialog Box
(page 2021).
NOTE When a subassembly is attached to an assembly, the code set style is governed by the assembly object’s
code set style, and all controls on this tab are disabled.
The properties table contains the following columns:
Name
Displays an expandable tree with a collection for each type of code: Link, Point, and Shape. Expand the
collections to display the individual codes.
Description
Displays the description of each code.
Style
Displays the style assigned to each code.
Label Style
Displays the label style assigned to each code or <none> if no label style is assigned.
Render Material
Displays the render material assigned to each code or <none> if no render material is assigned.
Material Area Fill Style
Displays the Material Area Fill style assigned to each code or <none> if no label style is assigned.
Pay Item
Displays the ID of any pay item attached to any Link or Point.
Related procedures:
■

Understanding Point, Link, and Shape Codes (page 1568)

■

Assigning Pay Items to Corridors (page 1301)
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Building Site Import Dialog
Boxes

Edit Feature Settings - Building Site
Use this dialog box to view and change settings that relate to building site objects.
This topic lists settings in all Edit Settings dialog boxes (drawing-level, feature-level, and command-level)
that relate to building site objects.
■

Drawing-level ambient settings are identified by the

■

Building site feature settings are identified by the

■

Building site command settings are identified by the

drawing icon.
Building Site object icon.
command icon.

For general information about drawing, feature, and command settings and their interaction, see Working
with the Standard Settings Dialog Box Controls (page 78).
For information about drawing-level ambient settings, see Ambient Settings Tab (Drawing Settings Dialog
Box) (page 2078)

Default Styles
Use these settings to specify the default styles assigned to building sites.
Building Site Style
Specifies the default building site style (page 1894). Click in the Value column, and click
in the Building Site Style dialog box.

to select a style

For information about style selection, see Select Style Dialog Box (page 2021).

Default Name Format
Use this setting to specify the default name format for new building site objects.

2009

Building Site Name Template
Specifies the default name format for building site objects. Click in the Value column, and click
make changes in the Name Template dialog box (page 2022).

to

Related procedures:
■

Editing a Building Site Style (page 1894)

Import Building Site Wizard
Use this wizard to specify the settings for the imported ADSK package file.

Select File Page (Import Building Site Wizard)
Use this page to select the ADSK package file that contains the building site model data referenced in the
AutoCAD Civil 3D drawing.

File Information
Enter Or Browse To The File
Specifies the name and location of the ADSK package file.

Click to select the file in the Autodesk Design Package File dialog box.
Building Site Name
Specifies the name of the building site object. The name you specify becomes the name of the Building
Site collection on the Prospector tab of the AutoCAD Civil 3D Toolspace.

Click to display the Name Template dialog box. See Name Template dialog box (page 2022).
Preview
Provides a visualization of the building site object.
Related procedures:
■

Import a Building Site Model (page 1892)

Confirm Units Page (Import Building Site Wizard)
Use this page to confirm drawing units referenced in the Revit architectural model.
All fields on this page are read-only. Use them for reference information.

Building Site Units
Unit
Specifies the unit of the building site model, as it is defined in the ADSK package file.
Scale Factor
Specifies the scaling factor that is applied to Revit architectural model data during import.
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Civil 3D Drawing Units
Drawing Units
Specifies the unit of the current Civil drawing.
Drawing Scale
Specifies the scaling factor of the current Civil drawing session.
Angular Units
Specifies the angular units of the current Civil drawing.

Zone
Coordinate System Zone Code
Specifies the code of the coordinate system used in the Civil drawing.
Description
Specifies a description of the current zone used in the Civil drawing.
Projection
Specifies the projection method for the coordinate system.
Datum
Specifies the abbreviation for the datum on which the coordinate system is based.
Related procedures:
■

Import a Building Site Model (page 1892)

Display Properties Page (Import Building Site Wizard)
Use this page to specify the display properties for the imported building site object.

Display Properties
Building Site Layer
Displays the default layer specified in the ImportBuildingSite command settings.

Click to change the default layer in the Object Layer dialog box. See Object Layer dialog box (page 2221).
Building Site Style
Displays the default style of the building site object specified in the ImportBuildingSite command settings.

Click to modify the default style. See Editing a Building Site Style (page 1894).
Related procedures:
■

Import a Building Site Model (page 1892)

Insertion Point Page (Import Building Site Wizard)
Use this page to confirm the insertion point information of the building site object in the AutoCAD Civil
3D drawing.
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Insertion Point Information
Specify In Drawing
Specifies whether you wish to specify the coordinates in the drawing. Selecting this option makes the
coordinate value controls unavailable.
Northing (Y)
Specifies the northing coordinate value of the building site base point read from the ADSK package file.
Easting (X)
Specifies the easting coordinate value of the building site base point read from the ADSK package file.
Elevation (Z)
Specifies the elevation coordinate value of the building site base point read from the ADSK package file.
Rotation Angle
Specifies the rotation angle of the building site base point read from the ADSK package file.
Preview
Click to zoom in to the extents of the building site object as it would be located on the drawing.
Finish
Click to insert the building site object at the specified coordinates. Specify In Drawing must be cleared.
Related procedures:
■

Import a Building Site Model (page 1892)

Building Site Style Dialog Box
Use this dialog box to specify the display properties of the building site object.

Information Tab (Building Site Style Dialog Box)
Use this tab to specify the information related to the building site object.
Name
Specifies the name of the style.
Created By
Specifies the name of the person who created the style.
Date Created
Specifies the date the style was created.
Last Modified By
Specifies the name of the last person who modified the style.
Date Modified
Specifies the date the style was modified.
Related procedures:
■

Editing a Building Site Style (page 1894)
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Markers Tab (Building Site Style Dialog Box)
Use this tab to specify the style of the utility connection marker.

Utility Connection Marker Style
Marker Style
Specifies the marker style for the Utility Connection component of the building site object.

Click to modify the marker style in the Marker Style dialog box. See Marker Style dialog box (page 2004).

Click to view the details of the marker style in the Style Detail dialog box. See Style Detail dialog box (page
2020).
Related procedures:
■

Editing a Building Site Style (page 1894)

Display Tab (Building Site Style Dialog Box)
Use this tab to modify the layer and the viewing mode for each component of the building site object.

View Direction
Specify one of the following views:
Plan
Displays building site components in the top-down 3D view.
Model
Displays building site components in the Model view (all but top-down view).

Component Display
Specify the Visibility, Layer, and Linetype properties of the following building site object components:
Building Footprint
Specifies the footprint of the architectural model.
Property Lines
Specifies the property lines that relate to the building site object.
Utilities
Specifies the utilities and utility connections that relate to the architectural model.
Site Model
Specifies the site details that relate to the architectural model, such as topography, parking, and landscaping.
Building Model
Specifies the 3D model of the building.
Related procedures:
■

Editing a Building Site Style (page 1894)
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Summary Tab (Building Site Style Dialog Box)
Use this tab to view a summary of the specified styles.
Information
Specifies the information associated with the building site object.
Display
Specifies the style of the building site marker.
Collapse All
Click to collapse all items in the Property column.
Expand All
Click to expand all items in the Property column.
Related procedures:
■

Editing a Building Site Style (page 1894)

Building Site Properties Dialog Box
Use this dialog box to modify the name, description, and style of the building site object.
Name
Specifies the name of the building site object.
Description
Specifies any additional information about the building site object.
Building Site Style
Specifies the style of the building site object.

Click to modify the default base layer in the Object Layer dialog box.

Click to modify the default building site object style.
Related procedures:
■

Updating a Building Site Object Definition (page 1895)
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Common AutoCAD Civil 3D
Dialog Boxes and Tabs

Use the following links to access information about the common dialog boxes that are used by several AutoCAD Civil 3D
features.

Edit Feature Settings - General Dialog Box
Use this dialog box to view and change general feature and command settings.
This topic documents settings in all general Edit Settings dialog boxes (drawing-level, feature-level, and
command-level).
■

Drawing-level ambient settings are identified by the

■

General feature settings are listed near the top of this dialog box, after the General property group, and
are identified by the

■

drawing icon.

general icon.

General command settings are identified

command icon.

For general information about drawing, feature, and command settings and their interaction, see Working
with the Standard Settings Dialog Box Controls (page 78).
For information about drawing-level ambient settings, see Ambient Settings Tab (Drawing Settings Dialog
Box) (page 2078).

Default Styles
Use these settings to establish the default styles assigned to label components:
General Note Label Style
Specifies the default style to use when inserting Note labels. Click in the Value column, and click
select a style in the General Note Label Style dialog box.

to

General Line Label Style
Specifies the default style to use when inserting Line labels. Click in the Value column, and click
select a style in the General Line Label Style dialog box.

to

2015

General Curve Label Style
Specifies the default style to use when inserting Curve labels. Click in the Value column, and click
select a style in the General Curve Label Style dialog box.

to

For information about style selection, see Select Style Dialog Box (page 2021).

Curve Tessellation Option
NOTE This property group is displayed when accessing the settings from the CreateArcByBestFit,
CreateLineByBestFit, and CreateParabolaByBestFit commands. For more information, see Creating Entities by Best
Fit (page 628).
Use these settings to specify the default behavior when curve entities are used as an input option for best
fit arc, line, and parabola creation.
Tessellate Curve
Specifies whether to tessellate curve segments if they are included as an input option.
Mid-ordinate Tolerance
Specifies the mid-ordinate tolerance based on a distance across the tessellated curve segments. Enter a
length in the Value column or click

and select two points along a curve.

Regression Graph Option
NOTE This property group is displayed when accessing the settings from the CreateArcByBestFit,
CreateLineByBestFit, and CreateParabolaByBestFit commands. For more information, see Creating Entities by Best
Fit (page 628).
Use this setting to specify the default behavior for regression analysis graphs in best fit arc, line, and parabola
creation.
Spline Fit For Regression Analysis Graph
Specifies whether the regression graph displays splines on the green line that represents the best fit entity.

Mapcheck
NOTE This property group is displayed when accessing the settings from the MapCheck command. For more
information, see Performing a Mapcheck Analysis (page 1796).
Use these settings to specify the default behavior for Mapcheck.
Use Command Line Input
Specifies whether Mapcheck will accept commands from the command line interface. Selecting No causes
Mapcheck to accept input only from the Mapcheck vista.
Default Side Type
Specifies the default type of any side created using Mapcheck.
Default Curve Direction
Specifies the default direction of any curve created using Mapcheck.
Default Angle Type
Specifies the default type of any angle created using Mapcheck.
Mapcheck Color
Specifies the color for Mapcheck lines and curves which are not part of the current mapcheck. Click in
the Value column, and click

to select a color in the Select Color dialog box.
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Current Mapcheck Color
Specifies the color for the current mapcheck. Click in the Value column, and click
the Select Color dialog box.

to select a color in

Current Point Of Beginning Color
Specifies the color of the beginning not for a selected mapcheck. Click in the Value column, and click
to select a color in the Select Color dialog box.
Current Side Color
Specifies the color for the current selected side. Click in the Value column, and click
in the Select Color dialog box.

to select a color

Styles Dialog Box
This topic describes how to use the Information, Display, and Summary tabs that are common to all object
styles. Other object-specific tabs are described in the style section for each object.

Information Tab (Style Dialog Box)
Use this tab to change the object style name and description information, and to review details, such as
when the style was most recently modified.
Name
Specifies a name for the current style. This name appears on the Settings tab in Toolspace and in the style
selection dialog box.
Description
Specifies an optional description for the current style.
Created By
Displays the AutoCAD login name of the person who created the style.
Date Created
Displays the date and time the style was created.
Last Modified By
Displays the AutoCAD login name of the person who last modified the style.
Date Modified
Displays the date and time the style was last modified.
Related procedures:
■

Changing Common Settings in Styles (page 70)

Display Tab (Style Dialog Box)
Use this tab to control the visibility and display characteristics for each component that makes up an object.
To change a setting, click the current value.
For Color, Linetype, Lineweight, and Plot Style, you can select specific values or you can use the reference
settings of ByLayer or ByBlock. These settings are indirect and require some planning. For more information,
see Using ByLayer and ByBlock to Assign Display Values (page 2019).
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NOTE The values you enter on the Display tab take precedence over other AutoCAD Property Settings and
AutoCAD Layer Settings.

View Direction
Object styles have unique display values and varying numbers of displayed components, depending on the
view direction that is selected. You can set style characteristics that control how the object components are
displayed in plan view, model view, profile view, and section view. For example, you may want to set the
object styles differently depending on the view direction that is selected.
Plan
Specifies how the object is displayed in plan view. Plan view is the view of a site if you look straight down
from an elevated position.
Model
Specifies how the object is displayed in model view. Model view is a 3D rotated view, such as when the
Orbit command is used.
Profile
Specifies how the object is displayed in a profile view.
Section
Specifies how the object is displayed in a section view.

Component Display
Use this grid to specify the visibility and layer use for components of each object. In the Color, Linetype,
and Lineweight columns you can select a specific value or set the value to BYLAYER or BYBLOCK. For more
information, see Using ByLayer and ByBlock to Assign Display Values (page 2019).
Component Type
Specifies the component. The number and type of object components varies, depending on the object
and whether the view is 2D or 3D.
Visible
Specifies the component visibility. Click the light bulb on or off to change the visibility.
Layer
Specifies the display layer for components, which is referenced if you select a ByLayer setting for any
values. A setting of 0 means that the display layer is the same as the layer on which the component is
drawn.
Color
Specifies a color for the component. Click to select a specific value or specify ByLayer or ByBlock.
Linetype
Specifies the line type for the component. You can click in the Linetype column and use the Select Linetype
dialog box.
If you choose ByLayer, the linetype value is determined by examining the properties of the layer referred
to in the Display tab pane.
If you choose ByBlock, the value is determined by examining the properties of the object for layer override
settings first. If the object doesn't have layer overrides, the layer referred to in the Display tab pane is used
to determine the properties.
LT Scale
Specifies the linetype scale for the component.
NOTE The Current Object Scale value controls the CELTSCALE system variable, which sets the linetype scale
for new objects. The CELTSCALE value is multiplied by the LTSCALE to get the displayed linetype scale.
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Lineweight
Specifies the lineweight for the component. You can click in the lineweight column and select a new
lineweight in the Lineweight dialog box.
Plot Style
Specifies the plot style for the component.

Component Hatch Display
Use this grid to specify the hatch patterns and properties for each object component.
Component Type
Lists the object components that have hatch patterns.
Pattern
Specifies the hatch pattern for the component. You can click in the column and select a new pattern from
the Hatch Pattern dialog box.
Angle
Specifies the angle value for the component.
Scale
Specifies the scale for the hatch pattern.
Related procedures:
■

Layers (page 73)

Using ByLayer and ByBlock to Assign Display Values
You can set component display properties by referencing the attributes of a drawing layer (ByLayer) or a
block definition (ByBlock).
This method is less direct than setting specific values, as shown in the following example for color selection.
If you click in the...

The component...

Layer column and select a specific
layer

Is displayed in the color assigned to that
layer.

Color column and select a specific
color

Is displayed in that specific color.

Color column and select ByLayer

Is displayed in the color specified by the
Layer column.

Color column and select ByBlock

The software determines if you made
changes to the AutoCAD Layer Properties
or AutoCAD Color Properties.
■

if you made changes, the component
color reflects those changes.

■

if you did not make changes, the component is displayed in the color specified
in the Layer column of the Display tab.
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Summary Tab (Style Dialog Box)
This tab lists the object style properties and assigned values.
You can edit any values that appear black, but not those that are shaded (gray). To copy the Summary tab
to the clipboard, right-click a cell. If you paste the contents into Excel, the column format is maintained.
Property
Displays all object style properties.
Value
Displays the value for each property.
Related procedures:
■

Changing Common Settings in Styles (page 70)

Style Detail Dialog Box
Use this dialog box to preview styles that have been defined in a drawing in the AutoCAD Civil
3D/Data/Preview folder.
After you establish styles for a particular phase of a project, you can save the drawing with those styles to
the Preview folder. When you click
, the Style Detail dialog box is displayed with an Information tab
that contains creation information and a description, and a Preview tab that lists the drawings in the Preview
folder. AutoCAD Civil 3D has several default Preview drawings.
NOTE Some styles are not supported in the Style Detail Preview. Styles that are not supported display only the
name and creation information.
Style List
Lists the object styles.
Preview List
Lists the defined previews in the current drawing.

Information Tab
Description
Displays the description of the current style.
Created By
Displays the AutoCAD login name of the person who created the style.
Date Created
Displays the date and time the style was created.
Last Modified By
Displays the AutoCAD login name of the person who last modified the style.
Date Modified
Displays the date and time the style was last modified.

Preview Tab
Style List
Displays a list of available styles for the object.
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Preview List
Displays a list of available previews for the object.
Preview Window
Displays the selected style preview.

Select Style Dialog Box
Use this dialog box to specify a style for an object, to create a new style, or to copy or edit an existing style.
Style List
Specifies the following options for style selection:
■

Create New

■

Copy Current Selection

■

Create Child of Current Selection (Labels only)

■

Edit Current Selection

■

Pick from Drawing

Specifies the style options. You can create a new style, copy or edit the current style selection, or pick a
style from drawing.

Opens the Style Detail dialog box where you can preview the style and creation information.
Related procedures:
■

Object and Label Styles (page 66)

Select Render Material Dialog Box
Use this dialog box to specify a render material for an object.
Render Material List
Lets you specify a render material in the following ways:
■

ByBlock: Uses the render material of an associated block.

■

ByLayer: Uses the render material of the current layer that the object is on.

■

Global: Uses the Global render material.

■

Use a specified render material. You can select from the list of available render materials in the drawing.

Click to select a render material of an object in the drawing.
Related procedures:
■

Object Rendering (page 1761)
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Name Template Dialog Box
Use this dialog box to specify a name format for new objects.
A name template helps to automate, and make consistent, the names of new objects.

Name Formatting Template
Property Fields List
Displays the object properties that you can use as part of the name format. The Next Counter property
increments the number using the Incremental Number Format options.
Insert
Click to add the specified property to the name. The property is inserted where the cursor is placed in the
Name field.
Name
Displays the property fields you have inserted. You can enter text directly into this box to accompany the
property fields.

Incremental Number Format
Number Style List
Specifies the number format.
Starting Number
Specifies the starting number.
Increment Value
Specifies the number that is added to each value to get the next value.
Related procedures:
■

Naming Objects (page 74)

Duplicate Station Selection Dialog Box
When you add a station equation to an alignment, you often create duplicate station values. Use this dialog
box to specify which of the duplicate stations you want to work with.
Raw Station Back
Displays the original (raw) station values, unaffected by station equations. Select the station you want to
use.
Duplicate Station
Displays the duplicate station values.
Related procedures:
■

To change alignment Station Control (page 933)

Customize Columns Dialog Box
Use this dialog box to create and modify column display configurations.
You can create and save different views of the columns in the table from which you accessed this dialog
box.
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New Configuration
Displays the configuration names. The default configuration is named ‘Standard’. Click New to create
additional configurations.
Index
Displays the order in which the columns are displayed.

Column
Name
Displays the name of the column.
Visibility
Specifies if the column is visible. Clear the check box to hide the column.
Width
Specifies the width of the column.
New
Click to create a new configuration. The Enter New Name dialog box is displayed from which you can
enter the name of the configuration.
Delete
Click to delete the selected configuration.
NOTE You cannot delete the Standard configuration.
Related procedures:
■

Changing the Contents of a Column in a List View (page 102)

Enter New Name Dialog Box
Use this dialog box to specify the name for a new column configuration.
The configuration details are specified in the Customize Columns dialog box.
Enter a configuration name in the field and click OK.

Multipurpose Styles Feature Settings
Use this dialog box to specify the feature settings for Multipurpose Styles.
For more information, see Working with the Standard Settings Dialog Box Controls (page 78).

Projection Styles Dialog Box
Use this dialog box to define styles that control the display of AutoCAD objects projected into profile views
and section views.
Projection styles are listed in the General ➤ Multipurpose Styles ➤ Projection Styles collection on the
Settings tab of Toolspace.
Multipurpose Projection Styles are used for AutoCAD objects. Each Projection Style includes settings for all
types of AutoCAD objects that can be projected. Ensure that you have the correct object selected in the
drop-down list when you are making the edits to the style.
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AutoCAD Civil 3D object styles control the appearance of AutoCAD Civil 3D objects that are projected.
Points use the point marker style. Feature lines use the feature line style Profile and Section tab settings.
Survey figures use the figure style Profile and Section tab settings.
See also:
■

Feature Line Style Dialog Box (page 2118)

■

Point Style Dialog Box (page 2354)

■

Survey Figure Style Dialog Box (page 2707)

■

Using ByLayer and ByBlock to Assign Display Values (page 2019)

Information Tab (Projection Style Dialog Box)
Use this tab to record basic information about the style.
For more information, see Information Tab (Style Dialog Box) (page 2017).

Profile Tab (Projection Style Dialog Box)
Use this tab to control how this style displays AutoCAD objects in profile views.
Each Projection Style includes settings for all types of AutoCAD objects that can be projected. Ensure that
you have the correct object selected in the drop-down list when you are making the edits to the style.
Select Object
Specify the type of object to configure: AutoCAD points, solids, 3D polylines, blocks, or multi-view blocks.
Object Display
Specify As Drawn or select a marker style for the current object. If a suitable marker style is not available
from the list, you can create a new style and select a custom marker or AutoCAD block. The marker is
displayed in the Preview pane.
Related procedures:
■

Marker Style Dialog Box (page 2004)

Section Tab (Projection Style Dialog Box)
Use this tab to control how this style displays AutoCAD objects in section views.
Each Projection Style includes settings for all types of AutoCAD objects that can be projected. Ensure that
you have the correct object selected in the drop-down list when you are making the edits to the style.
Select Object
Specify the type of object to configure: AutoCAD points, solids, 3D polylines, blocks, or multi-view blocks.
Object Display
Specify As Drawn or select a marker style for the current object. If a suitable marker style is not available
from the list, you can create a new style and select a custom marker or AutoCAD block. The marker is
displayed in the Preview pane.

Display Tab (Projection Style Dialog Box)
Use this tab to configure the displayed elements of this style.
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For more information, see Display Tab (Style Dialog Box) (page 2017).

Summary Tab (Projection Style Dialog Box)
Use this tab to review and edit style settings in summary form.
For more information, see Summary Tab (Style Dialog Box) (page 2020).

Projection Properties Tab
Use this tab to set properties of projected objects in profile views and section views.
This tab appears on the dialog boxes for Profile View Properties (page 2427), and Section View Properties (page
2542) when the view includes one or more projected objects.
You can change the elevation of a projected object, modify its object style, or remove it from the view.
Name
Displays all projected objects in the current view. If you click a name, the object is highlighted in the
view. Right-click a name for options to pan or zoom to the object or remove it from the view.
Style
Specifies the style of the projected object. Click a style name to change it. If you want to set a consistent
style for all objects of the same type, click the main heading for the object type and select the style.
Elevation Options
Specifies how the elevation of the projected object is determined:
■

Use Object. Projected object is at the same elevation as the source object in plan view.

■

Manual. Elevation of the projected object is set manually.
NOTE The Manual option is not available for all object types. It is available for blocks, points, and 3D solids
only.

■

Surface. Projected object is at the elevation of the selected surface.

■

Profile. Projected object is at the elevation of the selected profile.

Elevation Value
Displays the current elevation of the projected object. If the elevation option is Manual, you can change
the elevation in this column.
Pick Objects
Click to select additional objects to project into the current view.
Related procedures:
■

Setting Profile View Properties (page 1137)

■

Editing Section View Properties (page 1263)

Edit Settings Dialog Box
Use the standard Edit Settings dialog box to edit drawing ambient settings, object (feature) level settings,
and command level settings.
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The following describes the controls displayed in the standard Edit Settings dialog box. For a description of
a specific category or setting, display the dialog box and click Help.

Property column
Contains settings categories and settings property names.
Category names, which display in bold, contain a list of one or more settings. Click plus (+) or minus (-)
next to a category name to expand or collapse the list of settings.

Value column
Indicates the current value for the setting. The value is either derived from a dependency on a higher level
setting or you enter the value.

Override column
Identifies the derivation of a setting value and whether there are any higher level dependencies. A cleared
check box indicates that the value is dependent on a higher level setting. A selected check box indicates
that the value has been explicitly set at the current level.
If you clear the check box, then the value you entered at the current level is reset to the value of a higher
level setting.
If no check box is displayed, there is no high level dependency.

Child Override column
Override Indicator
Indicates that a value has been overridden at a lower level. Click

to remove the lower level setting

override value and replace the setting value with the current setting. The icon then changes to
.
When you click either OK or Apply in the dialog box, the override values are removed and replaced with
the current setting.

Lock
Protects a settings value by assuring that any lower-level setting is fixed at the value specified at this level.
To lock a setting, click

to change it to

. The lock cannot be set if a child override is set.

NOTE When a setting is locked at a higher level setting, the lower-level settings display a lock
to the left of
the property name to indicate that it is dependent on the higher-level setting and cannot be changed.

Control Icons
Collapse All Categories
Collapses all open categories in the dialog box.
Expand All Categories
Expands all categories in the dialog box.
Override All Dependencies
Selects all check boxes in the Override column and creates settings that are not dependent on upper-level
settings.
When you select all Override check boxes, this option is unavailable. It is also unavailable in the highest,
or the drawing level, dialog box.

Status Update in Dialog Box
In the lower-left corner of the dialog box, the status of overrides is displayed as you select an item in the
dialog box.
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Property
Displays the selected property name followed by a single line description of the property.
Parent Value
Indicates the value that the setting will have if a dependency on the higher level value is maintained.
Parent
Indicates the higher level setting from which this default setting is derived.
Related procedures:
■

Working with the Standard Settings Dialog Box Controls (page 78)

Select Object(s) Dialog Box
Use this dialog box to select one or more objects either from a list or from the drawing area.
Object Listing
Lists the objects that are available for selection. You can select a single or multiple objects, depending on
the feature you are using. To select multiple objects, hold down the SHIFT key and select the objects.

Click to select one or more objects in the drawing.

Edit Enumeration Dialog Box
Use the arrows in this dialog box to edit the order of the enumeration (page 2773) values. Click in a cell to edit
the current value or click in an empty cell to add an enumeration value.
Related procedures:
■

Editing, Copying, or Deleting User-Defined Properties (page 447)

User-defined Property Classification Dialog Box
Use this dialog box to specify a name for the classification.
Use a name that will help you identify the properties within the user-defined property classification (page 2786),
such as Trees for properties related to trees.
Related procedures:
■

Creating a User-Defined Property Classification (page 446)

New User-defined Property Dialog Box
Use this dialog box to define a user-defined property (page 2786).
Name
Specifies the name for the property.
TIP This name will appear in lists along with default properties, so it may be helpful to use a prefix or naming
convention so it is clear which properties you have added.
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Description
Specifies an optional description.
Type
Specifies the property data type. Choose the data type based on how you want to specify the data, as well
as how you want it formatted.
■

Boolean: Creates a property type that allows you to specify true or false values.

■

String: Creates a property type that allows you to enter text as the value. Use this property type when
you want to be able to enter any characters or numerals, for example, a tree species.

■

Enumeration: Creates a property type that allows you to specify values by selecting from a drop-down
list. If you select this property type, define the items that will appear in the drop-drop down list in the
Enumeration section of the dialog box.

■

Integer: Creates a property type that allows you to enter a whole numeral without decimals, for
example, 1, 2, or 3. This value is not formatted.

■

Double: Creates a property type that allows you to enter a numeral with decimals, for example, 1.05.
This value is formatted using the Unitless type settings (defined in the Ambient Settings) (page 2078).

The default values for the following data types are also formatted according to the settings on the Ambient
Settings Tab (Drawing Settings Dialog Box) (page 2078) in the Drawing settings:
■

Angle

■

Area

■

Coordinate

■

Dimension

■

Direction

■

Distance

■

Elevation

■

Grade/Slope

■

Latitude

■

Longitude

■

Station

■

Volume

Lower Bound Inclusive
For those property types that support upper and lower bounds (ranges), this setting specifies whether or
not the lower bound value is included in the property. For example, if this check box is selected, and the
lower bound value is -10, -10 is allowed as the value.
NOTE If the property type you select is Boolean, String, or Enumeration, the lower and upper bound values
are not available.
Lower Bound Value
Specifies the lowest value allowed in the range.
Upper Bound Inclusive
Specifies whether or not the upper bound value is allowed in the range.
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Upper Bound Value
Specifies the highest value allowed in the range.
Default Value check box
Specifies whether the default property value is used for all points or parcels in the drawing (if they do not
already have a value for this property), as well as for new objects as they are created.
Default Value
Specifies the default value that is used when the Default Value check box is selected.
Enumeration
For enumeration (page 2773) property field types only. Specifies the list of values you can choose from. For
example, if you are defining a property type for soil types, you could define different soil types in the
enumeration list.
Related procedures:
■

Creating a User-Defined Property (page 446)

■

Using Custom Properties with Points (page 445)

Duplicate Item Name Dialog Box
Use this dialog box to resolve situations where an item of the same name exists in the destination drawing
you are attempting to copy an item to.
These items can be styles, criteria, pipe rules, and so on. The affected item is listed at the top of the dialog
box.
Duplicate Item Name Resolution
Specifies how duplicate items are resolved.
■

Overwrite: The item in the destination drawing is overwritten with the copy.

■

Rename: The item in the destination drawing is renamed so it will not be overwritten. The item you
are copying is copied to the drawing with its original name.

■

Skip: The item is not copied and the original is not overwritten.

Apply To All Duplicate Items
Specifies how the resolution is applied.
■

Selected: Applies the resolution to all items you are currently attempting to copy.

■

Cleared: Applies the resolution to the current item only. You are prompted to resolve any additional
conflicts.

Related procedures:
■

Dragging Styles or Items Within or Between Drawings (page 70)

Duplicate Item Name Dialog Box | 2029

2030

53

Corridors Dialog Boxes

The following topics provide information about the Corridors dialog boxes:

Apply To A Range Of Stations Dialog Box
Use this dialog box to specify a range of stations for which to apply an assembly override.
Start Station
Specifies the first station for which to apply the assembly override.
To edit the station start, enter a value or click

to select a location in the drawing window.

End Station
Specifies the last station for which to apply the assembly override.
To edit the station start, enter a value or click

to select a location in the drawing window.

Related procedures:
■

Viewing and Editing Corridor Sections (page 1519)

Connect Feature Lines Dialog Box
Use this dialog box to change the feature line display styles or to modify how a corridor’s feature lines are
connected.
Code Set Style
Specifies the code set style. Select a style in the Code Set Style list or use the standard style creation tools
to edit or create a style. For more information about the style creation tools, see the Select Style (page 2021)
dialog box.

Specify Feature Lines To Create
Code
Displays point codes that are used in the subassemblies for the corridor.
Description
Specifies descriptions for the corresponding point codes.
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Connect
Specifies whether the point codes at each station are connected. By default, all identical point codes are
connected as longitudinal feature lines. To delete feature lines between point codes, clear the check box
for the applicable point code.
NOTE If the Connect check box is unavailable, the feature line is being used in a corridor surface definition. It
cannot be disconnected. For more information, see Creating and Editing Corridor Surfaces (page 1506).
Feature Line Style
Specifies the feature line style. To change the style, click in a cell and click

.

Pay Item
Specifies any pay item attached to any Code. Click
box (page 2588).

to edit the pay item(s) in the Pay Item List dialog

Branching
Specifies how the feature lines for the corridor are branched if a point code is used a varying number of
times at different stations:
■

Inward: The feature lines branch inward joining the innermost point codes.

■

Outward: The feature lines branch outward, joining the outermost point codes.

Connect Extra Points
Specifies whether feature lines are joined between stations where there are a varying number of the same
point codes. To connect the points, select the check box.
Related procedures:
■

Editing Feature Lines (page 1501)

Corridor Boundary Definition Dialog Box
Use this dialog box to view and modify the properties of a corridor surface boundary.
Feature Line
Displays the names of the feature lines that form the boundary definition.
Baseline
Displays the baseline alignment for the feature lines.
Reverse Direction
Specifies whether the boundary is to be drawn in the reverse direction of the corridor station order.
Start Point
Specifies the start point along the corridor for the boundary. To edit the start point, enter a value or click
to select a location in the drawing.
End Point
Specifies the end point along the corridor for the boundary. To edit the end point, enter a value or click
to select a location in the drawing.

Adds a new feature line to the boundary definition.

2032 | Chapter 53 Corridors Dialog Boxes

Deletes the selected feature line from the boundary definition.

Moves the selected feature line up in the boundary draw order.

Moves the selected feature line down in the boundary draw order.

Previews the boundary in the drawing as a green polyline.

Verifies that the boundary polygon is well-formed (that is, it does not cross on itself). A message is displayed
indicating if the boundary is well-formed or is ill-formed with crossing edges.
Related procedures:
■

Adding and Editing Corridor Boundaries (page 1511)

Corridor Parameter Editor Vista
Use this vista to view and modify the parameters of assemblies at stations along a corridor.

Assembly Parameters
The assembly parameters section of the vista displays the following columns:
Name
Displays an expandable tree view of selected assemblies, subassembly groups, subassemblies, and
subassembly parameters used by the selected corridor alignment.
At the top of the vista, click

to expand or

to collapse the tree view.

Design Value
Displays the default value set for the subassembly parameters.
If the default value is overridden by manually editing the subassembly in the corridor section view (for
example, by grip editing subassembly parts), the values cannot be edited.
Override
Specifies subassemblies that have been edited manually in the corridor section view (for example, by grip
editing subassembly parts) and the parameters that have overrides on their design values. A selected check
box is displayed for any subassembly parameter that is overridden. A selected check box is displayed at
the assembly level, if any of its subassemblies or parameters are overridden.
To clear an override and set the subassemblies or parameters to their design value, clear the check box.
To set an override, select or enter an override value for any subassembly in the Value column. To all
overrides for an assembly’s subassemblies or parameters to their design values, clear the check box at the
assembly level.
Value
Specifies the override value for a parameter.
When you override a value in this column, the Override column displays a check box.
NOTE Grayed out fields indicate that the value cannot be changed from the default.
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Comment
Specifies an optional comment for overridden parameters.
For subassemblies that have been edited manually in the corridor section view (for example, by grip editing
subassembly parts), a comment is added automatically to indicate that they have been edited. For
subassemblies created by editing the subassembly parameters, you can edit the comment as required.
Related procedures:
■

Viewing and Editing Corridor Sections (page 1519)

Corridor Parameter Override Stations Dialog Box
Use this dialog box to view and delete assembly overrides to stations in the selected region.
Assembly Name
Displays the name of the assembly used in the region.
Start Station
Displays the value of the first station in the region’s range.
End Station
Displays the value of the last station in the region’s range.

Deletes the override applied to the station selected in the list of stations.
Delete All
Deletes all the overrides applied to stations in the selected region and clears the list of stations.
NOTE Deleting one or all stations from the list only deletes the overrides applied to the stations.
The table displays a list of overridden stations and the override method.
Station
Displays the station’s value.
Parameter
Displays whether or not the assembly has been edited by overriding subassembly parameters.
Geometry
Displays whether or not a subassembly located at the station has been added, deleted, or edited by adding
or deleting points or links.
Related procedures:
■

Editing Corridor Sections (page 1523)

■

Viewing and Deleting Overridden Stations (page 1500)

Corridor Properties Dialog Box
Use this dialog box to change the properties of a corridor.
See also:
■

Managing and Editing Corridors (page 1478)
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Information Tab (Corridor Properties Dialog Box)
Use this tab to view or change general information for the corridor using the following settings:
Name
Specifies the name of the current corridor.
Description
Specifies an optional description for the current corridor.
Object Style
Specifies the default corridor style used to display corridor components, such as region boundaries and
assembly insertion stations. Select a style from the list or use the standard selection tools. For more
information about the standard selection tools, see the Select Style (page 2021) dialog box.
Show Tooltips
Specifies whether tooltips are displayed for the object in the drawing (not over toolbar icons).
Related procedures:
■

Creating Corridors (page 1475)

■

Editing Basic Corridor Information (page 1481)

Parameters Tab (Corridor Properties Dialog Box)
Use this tab to view and edit the parameters of the current corridor including the baselines, regions, and
controlling offsets, and setting targets.

Expands all baseline categories.

Collapses all baseline categories.

Turns on all baselines.

Turns off all baselines.
Add Baseline
Adds a baseline (alignment) to the corridor definition.
Set All Frequencies
Opens the Frequency To Apply Assemblies dialog box (page 2060), where you can map targets from
subassembly definitions to appropriate drawing object names for the entire corridor.
Set All Targets
Opens the Target Mapping dialog box (page 2064), where you can map targets from subassembly definitions
to appropriate drawing object names for the entire corridor. For more information, see Setting Targets
(page 1481).
The parameters table contains the following columns:
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Name
Displays a tree listing all baselines, regions, and corresponding offset alignments.
NOTE Offset alignments are displayed if the assembly is defined with assembly offsets. For more information,
seeCreating an Assembly Offset (page 1543).
The check boxes next to the baselines or region names specify whether to show (selected) or hide (cleared)
the baselines or regions. If the check box is cleared, that section of corridor is not reprocessed when
underlying elements (for example, alignments, subassemblies, or surfaces) change.
NOTE The check boxes have a tri-state display. If only one of the regions is selected under a baseline, the check
box is dimmed and unavailable.
Alignment
Specifies the alignment for a baseline or offset alignment. Click this field to open the Pick Horizontal
Alignment dialog box where you can select an alignment.
Profile
Specifies the profile for a baseline offset alignment. Click this field to open the Select A Profile dialog box
where you can select a profile.
Assembly
Specifies the assembly for the corridor region. Click to open the Select An Assembly dialog box where you
can select an assembly.
Start Station
Specifies the start station for the corridor region or controlling offset. By default, for the first region added
to a baseline, this value is set to the start station of the baseline. If one or more corridor regions already
exist, this value is set to the end station of last region. Enter a value or click
drawing area.

to select a location in the

End Station
Specifies the end station for the corridor region or controlling offset. By default, for the first region added
to a baseline, this value is set to the end station of the baseline. Enter a value or click
in the drawing area.

to select a location

Frequency
Specifies the frequency at which assemblies are placed for a given region. Click this field to open the
Frequency To Apply Assemblies dialog box (page 2060), where you can modify the station frequency and
manually add stations.
Target
Opens the Target Mapping dialog box (page 2064), where you can modify the mapping of targets from
subassembly definitions to appropriate drawing object names. For more information, see Setting Targets
(page 1481).
Overrides
Opens the Corridor Parameter Override Stations dialog box (page 2034), where you can view and delete
assembly overrides to stations in the selected region.
Select Region From Drawing
Selects a region in the drawing to display in the parameters table.
Related procedures:
■

Editing Corridor Parameters (page 1486)

■

Viewing and Editing Corridor Sections (page 1519)
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Codes Tab (Corridor Properties Dialog Box)
Use this tab to view all point, link, and shape codes that are used to define the corridor.
These codes are from the subassemblies (used in assemblies) that are applied to the corridor.
NOTE To change the style, description, or label style for any of the codes displayed in this tab, edit the code set
style (page 1577).
Code Set Style
Specifies the code set style for the corridor. Select a style or use the standard style selection tools. For
information, see the Select Style dialog box (page 2021).
The properties table contains the following columns:
Name
Displays an expandable tree with a collection for each type of code: Link, Point, and Shape. Expand the
collections to display the individual codes. For information about codes, see Understanding Point, Link,
and Shape Codes (page 1568).
Description
Displays the description of each code.
Style
Displays the style assigned to each code.
Label Style
Displays the label style assigned to each code or <none> if no label style is assigned.
Render Material
Specifies the render material (page 1761) associated with the corridor surface.
Material Area Fill Style
Specifies the fill displayed for the material areas of the corridor surface.
Pay Item
Displays the IDs of pay items attached to any Link or Point.
Related procedures:
■

Using Codes and Code Set Styles (page 1567)

■

Editing the Code Set Style (page 1500)

Feature Lines Tab (Corridor Properties Dialog Box)
Use this tab to change the feature line display styles or to modify how a corridor’s feature lines are connected.
Code Set Style
Specifies the code set style. Select a style in the Code Set Style list or use the standard style creation tools
to edit or create a style. For more information about the style creation tools, see the Select Style (page 2021)
dialog box.

Specify Feature Lines To Create
Code
Displays point codes that are used in the subassemblies for the corridor.
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Description
Specifies descriptions for the corresponding point codes.
Connect
Specifies whether the point codes at each station are connected. By default, all identical point codes are
connected as longitudinal feature lines. To delete feature lines between point codes, clear the check box
for the applicable point code.
NOTE If the Connect check box is unavailable, the feature line is being used in a corridor surface definition. It
cannot be disconnected. For more information, see Creating and Editing Corridor Surfaces (page 1506).
Feature Line Style
Specifies the feature line style. To change the style, click in a cell and click

.

Pay Item
Specifies any pay item attached to any Code. Click
box (page 2588).

to edit the pay item(s) in the Pay Item List dialog

Branching
Specifies how the feature lines for the corridor are branched if a point code is used a varying number of
times at different stations:
■

Inward: The feature lines branch inward joining the innermost point codes.

■

Outward: The feature lines branch outward, joining the outermost point codes.

Connect Extra Points
Specifies whether feature lines are joined between stations where there are a varying number of the same
point codes. To connect the points, select the check box.
Related procedures:
■

Editing Feature Lines (page 1501)

Surfaces Tab (Corridor Properties Dialog Box)
Use this tab to create corridor surfaces.
NOTE Corridor surfaces use standard surface display styles.

Creates an empty corridor surface to which you can subsequently add data using the Add Data fields.

Creates individual corridor surfaces from all link codes. The corridor surfaces are listed in the grid where
you can view and modify them.

Opens the Name Template (page 2022) dialog box, where you can modify the surface corridor naming
template.

Deletes the surface or data component that is currently selected in the Name column of the grid.
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Add Data
Data Type
Specifies the data type from which to create a corridor surface:
■

Feature Lines: Creates the surface from the feature lines that connect the specified point codes.

■

Links: Creates the surface from the specified link.

Specify Code
Specifies the available links or features lines, depending on whether the Data Type is set to Feature Lines
or Links.

Adds the data specified with the Data Type and Specify Code fields to the selected surface.
NOTE You must first select a corridor surface before adding the data.
The properties table contains the following columns:
Name
Specifies the corridor surface name. Click
next to the surface name to display its data (link codes and
feature lines).
Select or clear the check box next to the surface name to specify whether or not a dynamic surface is
added to the Surfaces collection on the Toolspace Prospector tab.
Surface Style
Specifies the surface style associated with the corridor surface. Click this field to open the Pick Corridor
Surface Style dialog box where you can select a style. The value is also specified on the surface properties
Information tab.
Render Material
Specifies the render material (page 1761) associated with the corridor surface. Click this field to open the
Select Render Material dialog box and select a render material.
Add as Breakline
Specifies whether the corridor surface is built using breaklines (page 667).
Overhang Correction
Specifies whether an overhang is to be corrected when rendered, and whether it is to be corrected following
the top links or bottom links.
Description
Specifies a description for the corridor surface.
Related procedures:
■

Creating and Editing Corridor Surfaces (page 1506)

Boundaries Tab (Corridor Properties Dialog Box)
Use this tab to create boundaries on corridor surfaces.
Use boundaries to prevent triangulation outside of the daylight line of a corridor surface and prevent them
from being displayed, or to render a section of the corridor surface as a material style.
NOTE A corridor surface must exist before you can create a boundary. For information about creating a corridor
surface, see Creating and Editing Corridor Surfaces (page 1506).
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The properties table contains the following columns:
Name
Specifies the corridor surface names and their corresponding boundaries. Click
next to the surface
name to display its boundaries. To add a boundary to a surface, right-click the corridor surface name and
click Add Interactively, Add Automatically, or Add From Polygon.
Description
Specifies the description for the corridor surface boundary.
Render Material
Specifies the render material style (page 1761) associated with the corridor surface boundary. Click this field
to open the Select Render Material dialog box and select a render material.
Definitions
Specifies the boundary definition. Click [...] to open the Corridor Boundary Definition (page 2032) dialog
box, where you can view and modify the boundary definition.
Use Type
Specifies the boundary type:
■

Render Only. Renders specified areas of the corridor surface with different materials (when rendering),
for example, asphalt and grass.

■

Hide Boundary. Creates void areas or punches holes in the corridor surface.

■

Outside Boundary. Defines the outer boundary of a corridor surface.

Related procedures:
■

Adding and Editing Corridor Boundaries (page 1511)

■

Rendering Corridor Models (page 1533)

Slope Patterns Tab (Corridor Properties Dialog Box)
Use this tab to add slope patterns between a set of corridor feature lines.
Add Slope Pattern >>
Adds a slope pattern to the corridor. You are prompted to select the feature lines that define the slope
pattern.

Deletes the selected slope pattern.
The properties table contains the following columns:
Index
Displays a numerical identifier for the slope pattern.
Feature Line1
Displays the point code of the first feature line selected to define the slope pattern.
Feature Line2
Displays the point code of the second feature line selected to define the slope pattern.
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Slope Pattern Style
Specifies the slope pattern style. Click
and select a style in the Pick Style dialog box or use the standard
style creation tools to edit or create a style. For more information about the style creation tools, see the
Select Style Dialog Box (page 2021).
Baseline
Displays the feature line’s corresponding baseline.
Station Start
Specifies the start station for the slope pattern display. To edit the station start, enter a value or click
to select a location in the drawing area.
Station End
Specifies the end station for the slope pattern display. To edit the station end, enter a value or click
to select a location in the drawing area.
Related procedures:
■

Creating and Editing Corridor Slope Patterns (page 1515)

Corridor Region Properties Dialog Box
Use this dialog box to edit corridor region properties, such as frequency.

General
Corridor Name
Displays the name of the corridor associated with the currently selected region.
Baseline Name
Displays the name of the baseline associated with the selected corridor region.
Current Range Start\End
Displays the start and end stations of the currently selected corridor region.

Properties
Region Name
Displays the name of the currently selected corridor region.
Assembly
Specifies the assembly associated with the currently selected corridor region. Click this field to select a
different assembly, if desired.
Frequency
Specifies the frequency at which assemblies are placed for a given region. Click this field to modify the
station frequency and manually add stations, if desired.
Target
Click this field to modify the mapping of targets from subassembly definitions to appropriate drawing
object names. For more information, see Setting Targets (page 1481).
Overrides
If there are overrides, you can click this field to view and delete assembly overrides to stations in the
selected region.
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Related procedures:
■

Editing Corridor Regions (page 1486)

Corridor Section Editor Ribbon
Use this ribbon to view and modify cross-sections at stations along a corridor.

General
Inquiry
Performs an inquiry at a selected station.

Baselines and Offsets
Select a Baseline
Specifies the baseline alignment for a corridor for which you want to view or edit sections. Click the down
arrow to select from the available alignments.

Station Selection

Displays the corridor section view at the first or Start Station on the corridor.
Use the Start Station button and the Next Station button to view the change in daylight elevation along
the corridor.

Displays the corridor section view at the Previous Station on the corridor.
Select a Station
Lists all the stations for which there are corridor section views. If you click
Show Overridden Stations,
this list displays only stations where assemblies were edited with override parameters. Click to select a
station.

Displays the corridor section view at the Next Station on the corridor.

Displays the corridor section view at the End Station on the corridor.
Use the End Station button and the Previous Station button to view the change in daylight elevation
along the corridor.
Show Overridden Stations
Specifies that only stations with assembly overrides are displayed in the station list.
If you click this button a second time, all stations are available for display.

Corridor Edit Tools
Parameter Editor
Edits the subassembly parameters of selected corridor sections.
Edit the override locations and values of selected subassemblies in the Corridor Parameter Editor vista.
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Apply to a Station Range
Applies the subassembly overrides to a list of stations. Click to open the Apply to a Range of Stations (page
2031) dialog box, where you can specify the range.
Only the overrides that you create by editing the subassembly parameters can be applied to a range of
stations. Geometric overrides, such as adding or deleting points and links, cannot be applied to a range
of stations.
Update Corridor
Rebuilds the corridor using the subassembly overrides.
All corridor surfaces and any other data that derives from the corridor are updated with the subassembly
overrides. Has no effect when no overrides are present or when the corridor is set to rebuild automatically.
NOTE When you close the Section Editor ribbon, the corridor is automatically rebuilt with the changes.
Add Point
Prompts you to add points to a subassembly by selecting a link in the corridor section view. The point is
placed at the midpoint of the link.
The points at the end of the links retain the codes from the original link.
Delete Point
Prompts you to delete points from a subassembly by selecting a point in the corridor section view.
All links connected to deleted points are also deleted.
Add Link
Prompts you to add links by selecting points within a subassembly to connect.
You cannot add a link by connecting points from two different subassemblies.
Delete Link
Prompts you to delete links from a subassembly by selecting links in the corridor section view.
The points that were connected in order to create the deleted link are not deleted.
Add Subassembly
Prompts you to add subassemblies by attaching a new subassembly to an existing subassembly or by
inserting a new subassembly between two existing subassemblies.
If you insert a subassembly between two existing subassemblies, the Override column (in the assembly
parameters) displays True.
Delete Subassembly
Prompts you to delete subassemblies by selecting a subassembly to delete in the corridor section view.
If the deleted subassembly connected two subassemblies, the remaining subassemblies are attached to
each other.
Edit User Defined Code
Prompts you to edit or delete user-defined feature codes by selecting a subassembly point marker, link,
or shape in the corridor section view.
If the corridor is not set to rebuild automatically, click Rebuild. Corridor surfaces and any other data that
is derived from the corridor are updated using overrides.
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View Tools
Edit/View Options
Sets the view/edit corridor section options.
In the View/Edit Corridor Section Options dialog box you can specify a new view scale, section view, or
code set style, and select to automatically rebuild the corridor.
Zoom to Extents
Click to zoom to the extents of the corridor section view.
Zoom to an Offset and Elevation
Click to lock the zoom to elevation and offset.
Zoom to Subassembly
Click to lock the zoom to a subassembly object. Opens the Pick Subassembly dialog box.

Close
Close
Closes the Corridor Section Editor ribbon and exits the corridor section view.
Related procedures:
■

Viewing and Editing Corridor Sections (page 1519)

Corridor Style Dialog Box
Use this dialog box to make it easier to locate and work with corridor region boundaries and assembly
insertion stations by changing their display.
The corridor style controls the appearance of corridor region boundaries, assembly insertion stations, and
stations where the default properties of the subassemblies are overridden. The other elements within the
corridor object such as feature lines, corridor sections, and surfaces, are controlled by their own display styles
and labels.
See also:
■

Corridor Styles and Display (page 1473)

Information Tab (Corridor Style Dialog Box)
Use this tab to change the corridor style name and description information, and to review details about the
style, such as when it was most recently modified. For more information, see Information Tab (Style Dialog
Box) (page 2017).
Related procedures:
■

Corridor Styles and Display (page 1473)

Display Tab (Corridor Style Dialog Box)
Use this tab to change the display and visibility of some corridor object components.
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The corridor components controlled by the corridor style include:
Region Boundaries: A closed polyline entity that shows the extents of a corridor region. It follows the
outermost feature line on either side of the baseline for the region, from the region start station to the region
end station.
Assembly Insertion Stations: Stations where an assembly is inserted to create the corridor model geometry.
A line segment that is drawn between the outermost design points on the left and right sides at the baseline
alignment station where an assembly is inserted.
Parametric Override Stations: Stations where the design parameters of a subassembly have been numerically
edited without changing the default values for the subassembly.
Geometric Override Stations: Stations where the design parameters of a subassembly have been manually
edited using grips without changing the default values for the subassembly.
For more information, see Display Tab (Style Dialog Box) (page 2017).
Related procedures:
■

Corridor Styles and Display (page 1473)

Summary Tab (Corridor Style Dialog Box)
Use this tab to review all the information about the current corridor style.
This information can be copied and pasted to the clipboard. For more information, see Summary Tab (Style
Dialog Box) (page 2020).

Corridor Surfaces Dialog Box
This dialog box lets you create corridor surfaces, and boundaries on corridor surfaces.

Surfaces Tab (Corridor Surfaces Dialog Box)
Use this tab to create corridor surfaces.
NOTE Corridor surfaces use standard surface display styles.

Creates an empty corridor surface to which you can subsequently add data using the Add Data fields.

Creates individual corridor surfaces from all link codes. The corridor surfaces are listed in the grid where
you can view and modify them.

Opens the Name Template (page 2022) dialog box, where you can modify the surface corridor naming
template.

Deletes the surface or data component that is currently selected in the Name column of the grid.
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Add Data
Data Type
Specifies the data type from which to create a corridor surface:
■

Feature Lines: Creates the surface from the feature lines that connect the specified point codes.

■

Links: Creates the surface from the specified link.

Specify Code
Specifies the available links or features lines, depending on whether the Data Type is set to Feature Lines
or Links.

Adds the data specified with the Data Type and Specify Code fields to the selected surface.
NOTE You must first select a corridor surface before adding the data.
The properties table contains the following columns:
Name
Specifies the corridor surface name. Click
next to the surface name to display its data (link codes and
feature lines).
Select or clear the check box next to the surface name to specify whether or not a dynamic surface is
added to the Surfaces collection on the Toolspace Prospector tab.
Surface Style
Specifies the surface style associated with the corridor surface. Click this field to open the Pick Corridor
Surface Style dialog box where you can select a style. The value is also specified on the surface properties
Information tab.
Render Material
Specifies the render material (page 1761) associated with the corridor surface. Click this field to open the
Select Render Material dialog box and select a render material.
Add as Breakline
Specifies whether the corridor surface is built using breaklines (page 667).
Overhang Correction
Specifies whether an overhang is to be corrected when rendered, and whether it is to be corrected following
the top links or bottom links.
Description
Specifies a description for the corridor surface.
Related procedures:
■

Creating and Editing Corridor Surfaces (page 1506)

Boundaries Tab (Corridor Surfaces Dialog Box)
Use this tab to create boundaries on corridor surfaces.
Use boundaries to prevent triangulation outside of the daylight line of a corridor surface and prevent them
from being displayed, or to render a section of the corridor surface as a material style.
NOTE A corridor surface must exist before you can create a boundary. For information about creating a corridor
surface, see Creating and Editing Corridor Surfaces (page 1506).
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The properties table contains the following columns:
Name
Specifies the corridor surface names and their corresponding boundaries. Click
next to the surface
name to display its boundaries. To add a boundary to a surface, right-click the corridor surface name and
click Add Interactively, Add Automatically, or Add From Polygon.
Description
Specifies the description for the corridor surface boundary.
Render Material
Specifies the render material style (page 1761) associated with the corridor surface boundary. Click this field
to open the Select Render Material dialog box and select a render material.
Definitions
Specifies the boundary definition. Click [...] to open the Corridor Boundary Definition (page 2032) dialog
box, where you can view and modify the boundary definition.
Use Type
Specifies the boundary type:
■

Render Only. Renders specified areas of the corridor surface with different materials (when rendering),
for example, asphalt and grass.

■

Hide Boundary. Creates void areas or punches holes in the corridor surface.

■

Outside Boundary. Defines the outer boundary of a corridor surface.

Related procedures:
■

Adding and Editing Corridor Boundaries (page 1511)

■

Rendering Corridor Models (page 1533)

Edit Code Sets Dialog Box
Use this dialog box to view or change the point, link, and shape code styles that are associated with the
corridor.
These codes are derived from the subassemblies (used in assemblies) that are applied to the corridor.
Code Set Style
Specifies the code set style for the corridor. Select a style from the drop-down list, or use the standard style
selection tools. For information, see the Select Style dialog box (page 2021).
Reset Labels
Resets the code set style labels to their original default property values. This button is enabled only when
the function is available.
The properties table contains the following columns:
Name
This read-only field displays an expandable tree with a collection for each type of code: Link, Point, and
Shape. Expand the collections to display the individual codes. For information about codes, see
Understanding Point, Link, and Shape Codes (page 1568).
Description
This read-only field displays the description of each code.
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Style
This read-only field displays the style assigned to each code.
Label Style
This read-only field displays the label style assigned to each code or <none> if no label style is assigned.
Render Material
This read-only field displays the render material (page 1761) associated with the corridor surface.
Material Area Fill Style
This read-only field displays the fill displayed for the material areas of the corridor surface.
Pay Item
This read-only field displays the IDs of pay items attached to any Link or Point.
Related procedures:
■

Using Codes and Code Set Styles (page 1567)

■

Editing the Code Set Style (page 1500)

Create COGO Points Dialog Box
Use this dialog box to export corridor points as COGO points.
For Entire Corridor Range
Specifies that all points are exported for the entire length of the corridor.
For User Specified Range
Specifies that points are exported for a certain range along the corridor. When selected, Select Baseline,
Alignment Start, and Alignment End are available.
Select Baseline
Specifies the baseline alignment from which to extract the points. Select a baseline or click
an alignment in the drawing. Available only if For User Specified Range is selected.

to select

Alignment Start
Specifies the start of the range along the alignment from which to extract points. To edit the start point,
enter a value or click

to select a location in the drawing.

Alignment End
Specifies the end of the range along the alignment at which to extract points. To edit the end point, enter
a value or click

to select a location in the drawing.

New Point Group Name
Specifies the name of the point group that will contain all the extracted points. For information about
point groups, see Point Groups (page 553).
Select Point Codes To Create
Specifies the available point codes to create. Select the check box next to the point code to create the
points for the specified point code. Clear the check box if you do not want to create the points.
Related procedures:
■

Exporting Corridor Points as COGO Points (page 1531)
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Create Corridor Baseline Dialog Box
Use this dialog box to create a baseline for a corridor.
Baseline Name
Specifies the format of the corridor baseline (alignment) name. Click
dialog box.

to open the Name Template

Horizontal Alignment
Lists the horizontal alignments that are available. Click
to select an alignment in the drawing. The
alignment selected in the drawing is then displayed as the selected alignment in the list.
Related procedures:
■

Adding Baselines (page 1498)

Create Corridor Dialog Box
Use this dialog box to specify the parameters for the new corridor including baselines, regions, and controlling
offsets.
Corridor Name
Specifies the name of the corridor.
NOTE To name the corridor, click on its default name and enter a new name or use the naming template.

Opens the Name Template (page 2022) dialog box, where you can modify the surface corridor naming
template.
Description
Specifies a description for the corridor.
Corridor Layer
Displays the layer that the corridor will be created on.

Opens the Object Layer dialog box where you can select a different layer for the corridor.
Corridor Style
Displays the style that is used to display corridor components, such as region boundaries and assembly
insertion stations. For more information, see Corridor Styles and Display (page 1473).
Add Baseline
Adds another baseline (alignment) to the corridor definition.
Set All Targets
Opens the Target Mapping (page 2064) dialog box, where you can map targets from subassembly definitions
to appropriate drawing object names for the entire corridor. If you subsequently add an assembly region
that uses the same set (or subset) of targets, the mappings are automatically assigned. For more information,
see Setting Targets (page 1481).
NOTE If targets are required and not set, messages are displayed in the Event Viewer. To display the Event
Viewer, click General ➤ Utilities ➤ Event Viewer. For more information on the event viewer, see The Event
Viewer Vista (page 1817).
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The properties table contains the following columns:
Name
Displays a tree listing all baselines, regions, and corresponding offset alignments.
NOTE Offset alignments are displayed if the assembly is defined with assembly offsets. For more information,
seeCreating an Assembly Offset (page 1543).
The check boxes beside the baselines and regions specify whether to show (selected) or hide (cleared) the
baselines or regions. If the check box is cleared, that section of corridor is not reprocessed when underlying
elements (for example, alignments, subassemblies, or surfaces) change.
NOTE The check boxes have a tri-state display. If only one of the regions is selected under a baseline, the check
box is dimmed and unavailable.
Alignment
Specifies the alignment for a baseline or offset alignment. Click this field to open the Pick Horizontal
Alignment dialog box where you can select an alignment.
Profile
Specifies the profile for a baseline offset alignment. Click this field to open the Select A Profile dialog box
where you can select a profile.
Assembly
Opens the Select An Assembly dialog box where you can select an assembly for the corridor region.
Start Station
Specifies the start station for the region or controlling offset. By default, for the first region added to a
baseline, this value is set to the start station of the baseline. If one or more corridor regions already exist,
this value is set to the end station of last region. Enter a value or click
area.

to select a location in the drawing

End Station
Specifies the end station for the region or controlling offset. By default, for the first region added to a
baseline, this value is set to the end station of the baseline. Enter a value or click
in the drawing area.

to select a location

Frequency
Specifies the frequency at which assemblies are placed for a given baseline or region. Click
to open the
Frequency To Apply Assemblies dialog box (page 2060), where you can modify the station frequency and
manually add stations.
Target
Click
to open the Target Mapping dialog box (page 2064), where you can map targets from subassembly
definitions to appropriate drawing object names for the region. For more information, see Setting Targets
(page 1481).
Overrides
This field is disabled when you are creating a corridor. For more information, see Viewing and Deleting
Overridden Stations (page 1500).
Related procedures:
■

Creating a Corridor (page 1476)

■

Editing Corridor Parameters (page 1486)
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Create Corridor Region Dialog Box
Use this dialog box to create a corridor region.
Region Name
Specifies the format of the corridor region name. Click

to open the Name Template dialog box.

Assembly Name
Lists the assemblies that are available. Click
to select an assembly in the drawing. The assembly selected
in the drawing is then displayed as the selected assembly in the list.
Related procedures:
■

Adding Corridor Regions (page 1489)

Create Corridor Surfaces Dialog Box
Use this dialog box to export corridor surfaces as (DTM) surface objects.
Surface
Displays the names of the corridor surfaces available for export.
Select
Specifies whether to export the corresponding surface.
Surface Style
Specifies the style for the surface. Click to open the Pick Corridor Surface Style dialog box where you can
select a style.
Render Material
Specifies the render material style (page 1761) associated with the surface. Click this field to open the Select
Render Material dialog box where you can select a render material.
Related procedures:
■

Exporting Corridor Surfaces (page 1532)

Create Feature Line From Corridor Dialog Box
Use this dialog box to specify feature line settings when creating a feature line from a corridor.
Site
Specifies the site in which to place the feature line. Select a site from the list or click
from the drawing.

to select a site

Name
Specifies the name of the feature line. Select the check box and click
box.

to open the Name Template dialog

Style
Select the check box and select a feature line style in the list. Click
to edit the style. Click
to preview
the selected style. A style is optional for a feature line, but it provides useful display options and allows
you to control color, visibility, and other settings.
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Layer
Specifies the layer on which the feature line should be created. Click
to open the Object Layer dialog
box and specify the layer. Click Use Current Layer to specify that layer be used.
Smoothing
Select this check box to enable the curve smoothing settings.
Horizontal Deviation
Specifies the maximum 2D distance within which the non-colinear points must be located from the
resulting smooth curve. If set to 0, the curve will interpolate all points.
Weeding Distance
Specifies the minimum distance between co-linear points in the resulting smooth curve. The intermediate
co-linear points are weeded.
Arc Inclusion Distance
Specifies the maximum distance within which the non-collinear points must be located to be converted
into arcs.
Create Dynamic Link to the Corridor
Creates a dynamic link to the corridor. Then, the feature line updates dynamically with any changes to
the corridor. If the feature line is created with the dynamic link, the link can be disabled with the Feature
Line Properties dialog box (page 2132). When the dynamic link is disabled, it cannot be restored. However,
when the feature line is not linked to the corridor, it can be edited with any of the feature line editing
commands.
Related procedures:
■

Creating Feature Lines (page 808)

■

Exporting Feature Lines as Grading Feature Lines (page 1529)

Create Simple Corridor Dialog Box
Use this dialog box to specify the initial corridor creation parameters, including corridor name, description,
and layer.
Name
Specifies the name of the corridor.
NOTE To name the corridor, click on its default name and enter a new name or use the naming template.

Opens the Name Template (page 2022) dialog box, where you can modify the corridor naming template.
Description
Specifies a description for the corridor.
Corridor Style
Displays the style that is used to display corridor components, such as region boundaries and assembly
insertion stations. For more information, see Corridor Styles and Display (page 1473).
Corridor Layer
Displays the layer that the corridor will be created on.
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Opens the Object Layer dialog box, where you can select a different layer for the corridor.
Related procedures:
■

Creating a Simple Corridor (page 1475)

Define Slope Patterns Dialog Box
Use this dialog box to add slope patterns between a set of corridor feature lines.
Add Slope Pattern >>
Adds a slope pattern to the corridor. You are prompted to select the feature lines that define the slope
pattern.

Deletes the selected slope pattern.
The properties table contains the following columns:
Index
Displays a numerical identifier for the slope pattern.
Feature Line1
Displays the point code of the first feature line selected to define the slope pattern.
Feature Line2
Displays the point code of the second feature line selected to define the slope pattern.
Slope Pattern Style
Specifies the slope pattern style. Click
and select a style in the Pick Style dialog box or use the standard
style creation tools to edit or create a style. For more information about the style creation tools, see the
Select Style Dialog Box (page 2021).
Baseline
Displays the feature line’s corresponding baseline.
Station Start
Specifies the start station for the slope pattern display. To edit the station start, enter a value or click
to select a location in the drawing area.
Station End
Specifies the end station for the slope pattern display. To edit the station end, enter a value or click
to select a location in the drawing area.
Related procedures:
■

Creating and Editing Corridor Slope Patterns (page 1515)

Edit Feature Settings - Corridor Dialog Box
Use this dialog box to view and change corridor-related settings.
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This topic documents settings in all corridor-related Edit Settings dialog boxes (drawing-level, feature-level,
and command-level).
■

Drawing-level ambient settings are identified by the

■

Corridor feature settings are listed near the top of this dialog box, after the General property group, and
are identified by the

■

drawing icon.

corridor icon.

Corridor command settings are identified by the

command icon.

For general information about drawing, feature, and command settings and their interaction, see Working
with the Standard Settings Dialog Box Controls (page 78).
For information about drawing-level ambient settings, see Ambient Settings Tab (Drawing Settings Dialog
Box) (page 2078)

Profile Creation Option
NOTE This property group is displayed when you access the settings from the CreateAlignfromCorridor command.
Use this setting, to establish the defaults when exporting alignments and profiles from a corridor.
Create Profile From Corridor
Specifies whether a profile is automatically created when creating an alignment from a corridor feature
line. If set to Yes, the profile is automatically added to the profile view.

Feature Line Creation
NOTE This property group is displayed when you access the settings from the CreateAlignfromCorridor or
FeatureLinesFromCorridor commands.
Use this setting to establish the defaults when exporting feature lines from a corridor:
Smoothen Created Entities
Specifies whether corridor feature lines are smoothed when created.

Assembly Insertion Defaults
NOTE This property group is displayed when you access the settings from the CreateCorridor or
CreateSimpleCorridor commands.
Use these settings to establish the defaults assigned to corridor creation.
Frequency Along Tangents
Specifies the corridor station placement frequency along the tangent portion of an alignment. Enter a
distance in the Value column or click

and select a distance in the drawing area.

Frequency Along Curves
Specifies the corridor station placement frequency along the curve portion of an alignment. Enter a
distance in the Value column or click

and select a distance in the drawing area.

Frequency Along Spirals
Specifies the corridor station placement frequency along the spiral portion of an alignment. Enter a
distance in the Value column or click
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and select a distance in the drawing area.

Horizontal Geometry Points
Specifies whether corridor stations are placed at horizontal geometry points.
Superelevation Critical Points
Specifies whether corridor stations are placed at superelevation critical points (such as ‘end normal crown,’
‘level crown,’ ‘reverse crown,’ and ‘begin full super’).
Profile Geometry Points
Specifies whether corridor stations are placed at profile geometry points.
Profile High Low Points
Specifies whether assemblies are inserted at the high and low points of the profile geometry.
Offset Target Geometry Points
Specifies whether or not to automatically add assemblies (assembly insertion stations) to the corridor
regions, based on offset target objects (feature lines, alignments, or polylines). For more information, see
Adding Assemblies At Offset Geometry Points (page 1485).
Frequency Along Profile Curves
Specifies the corridor station placement frequency along curve portions of the profile geometry. Enter a
distance in the Value column or click

and select a distance in the drawing area.

Feature Line Creation
NOTE This property group is displayed when you access the settings from the FeatureLinesFromCorridor command.
Use these settings to specify the defaults when creating feature lines.
Feature Line Name
Specifies whether a name is applied to feature lines when created.
Use Feature Line Style
Specifies whether a style is applied to feature lines when created.
Layer Setting
Specifies the layer that is applied to feature lines when created. The settings are: Use The Layer Setting
(from the drawing settings); and Use The Current Layer.
Create Dynamic Link
Specifies whether a dynamic link is created between the feature line and the alignment.
Smooth The Feature Line
Specifies whether feature lines are smoothed when exported.
Horizontal Deviation
Specifies the maximum 2D distance within which the non-collinear points must be located from the
resulting smooth curve. If set to 0, the curve will interpolate all points.
Inclusion Distance
Specifies the maximum distance within which the non-collinear points must be located to be converted
into arcs.
Weeding Distance
Specifies the minimum distance between co-linear points in the resulting smooth curve. The intermediate
co-linear points are weeded.
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View/Edit Options
NOTE This property group is displayed when you access the settings from the ViewEditCorridorSection command.
Use these settings to establish the default behavior for viewing corridor sections.
Default View Scale
Specifies the scale factor to use when viewing the corridor sections. For example, enter 1 to fit the section
exactly to the viewing area.
NOTE The new view scale is used for the next section that is viewed.
Turn Off Unassociated Layers
Specifies whether drawing layers unassociated with the corridor are turned off or on.
Rebuild on Edit
Specifies whether the corridor model is automatically rebuilt when you edit a subassembly using the
Corridor Section Editor Ribbon (page 2042).
Front Clip
Specifies the visible extent of 3D objects displayed in a corridor section, measured forward from the
sampled section.
Back Clip
Specifies the visible extent of 3D objects displayed in a corridor section, measured from the sampled
section back.
Station Tracker in Multiple Viewports
Specifies whether the station tracker is on.

Grid Settings
NOTE This property group is displayed when you access the settings from the ViewEditCorridorSection command.
Use these settings to establish the default behavior for corridor section view grids:
Display Horizontal Grid
Specifies whether there are horizontal grid lines.
Display Vertical Grid
Specifies whether there are vertical grid lines.
Horizontal Grid Interval
Specifies the interval between horizontal grid lines. Enter a distance in the Value column or click
select a distance in the drawing area.

and

Vertical Grid Interval
Specifies the interval between vertical grid lines. Enter a distance in the Value column or click
select a distance in the drawing area.

and

Grid Color
Specifies the color for grid lines. Click in the Value column, and click
Color dialog box.
Display Center Axis
Specifies whether there is a center axis line for the grid.
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to select a color in the Select

Center Axis Color
Specifies the color for the center axis line. Click in the Value column, and click
Select Color dialog box.

to select a color in the

Grid Text Settings
NOTE This property group is displayed when you access the settings from the ViewEditCorridorSection command.
Use these settings to establish the default behavior for viewing corridor section grid text:
Text Style
Specifies the text style. Click in the Value column, and click
dialog box.

to select a style in the Select Text Style

Text Color
Specifies the color for grid text. Click in the Value column, and click
Color dialog box.

to select a style in the Select

Text Height - Relative To Screen
Specifies the height of grid text as a percentage of the height of the grid.
Annotate Center Axist
Specifies whether there is annotation for the center axis line of the grid.

Match Region Parameters
NOTE This property group is displayed when you access the settings from the MatchCorrRegionParams command.
Use these settings to specify the defaults used when using the MatchCorrRegionParams command. These
command settings specify the default state of the Match Region Parameters dialog box (page 2061) options
(checked or unchecked) when you use this command.
Match Assembly
Specifies whether or not to match assemblies by default when using this command.
Match Targets
Specifies whether or not to match targets by default when using this command.
Match Frequency
Specifies whether or not to match assembly frequency by default when using this command.

Default Styles
Use these settings to establish the default styles assigned to corridor components:
Alignment Style
Specifies the default style for an alignment created from the corridor. Click in the Value column, and click
to select a style in the Alignment Style dialog box.
Slope Pattern Style
Specifies the default style for the slope patterns added to corridors. Click in the Value column, and click
to select a style in the Slope Pattern Style dialog box.
Code Set Style
Specifies the default code set style. Click in the Value column, and click
Set Style dialog box.

to select a style in the Code
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Alignment Label Set
Specifies the default style for the alignment label sets created from corridors. Click in the Value column,
and click

to select a style in the Alignment Label Set dialog box.

Corridor Surface Style
Specifies the default corridor surface style. Click in the Value column, and click
Corridor Surface Style dialog box.

to select a style in the

Corridor Style
Specifies the default style for the corridor. Click in the Value column, and click
Corridor Style dialog box.

to select a style in the

Profile Label Set
Specifies the default profile label set style. Click in the Value column, and click
Profile Label Set dialog box.

to select a style in the

Profile Style
Specifies the default style for a profile created from the corridor. Click in the Value column, and click
to select a style in the Profile Style dialog box.
Feature Line Style
Specifies the default style for a feature line created from a corridor. Click in the Value column, and click
to select a style in the Feature Line Style dialog box.
Render Material Style
Specifies the default render material style for the corridor. Click in the Value column, and click
select a style in the Render Material style dialog box.

to

For information about style selection, see Select Style Dialog Box (page 2021).

Default Name Format
Use these settings to specify the default name formats for corridors and corridor surfaces, as well as for
alignments and profiles from feature lines. Click in the Value column, and click
Name Template dialog box (page 2022).

to make changes in the

Region Highlight Graphics
Use these settings to establish the default styles assigned to corridor region:
Highlight Baseline
Specifies whether the baseline of a corridor region is highlighted by default.
Baseline Color
Specifies the color for the baseline. Click in the Value column, and click
Color dialog box.

to select a color in the Select

Baseline Lineweight
Specifies the default baseline lineweight. Click in the Value column, and click
Lineweight dialog box.
Highlight Region Boundary
Specifies whether the boundary of a corridor region is highlighted by default.
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to select a style in the

Region Boundary Color
Specifies the color for the region boundary. Click in the Value column, and click
the Select Color dialog box.

to select a color in

Region Boundary Lineweight
Specifies the default region boundary lineweight. Click in the Value column, and click
in the Lineweight dialog box.

to select a style

Highlight Horizontal Targets
Specifies whether the horizontal targets of a corridor region are highlighted by default.
Horizontal Targets Color
Specifies the color for horizontal targets. Click in the Value column, and click
Select Color dialog box.

to select a color in the

Horizontal Targets Lineweight
Specifies the default horizontal targets lineweight. Click in the Value column, and click
style in the Lineweight dialog box.

to select a

Highlight Interior Assemblies
Specifies whether the interior assemblies of a corridor region are highlighted by default.
Interior Assemblies Color
Specifies the color for interior assemblies. Click in the Value column, and click
Select Color dialog box.

to select a color in the

Interior Assemblies Lineweight
Specifies the default interior assemblies lineweight. Click in the Value column, and click
style in the Lineweight dialog box.

to select a

Criteria-Based Design Options
NOTE This property group is displayed when you access the settings from the CreateProfileFromCorridor command.
Use these settings to specify the defaults used when creating a profile using design criteria.
NOTE The design criteria values of the parent alignment take precedence over the default design criteria values
of the profile. If the parent alignment does not use design criteria values, then the criteria-based design options
in the profile are used.
Use Design Criteria File Option
Specifies whether to associate a design criteria file with the profile.
The first XML file found in the <install directory>\Data\Corridor Design Standards\<units> is used by default.
Use Design Checks Option
Specifies whether to associate a design check set with the profile.
Default Design Check Set
Specifies the default design check set. Click in the Value column, and click
Design Check Set dialog box.

to select a set in the Default

NOTE This setting is not available if the Use Design Checks Option is set to False.
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Related procedures:
■

Editing Corridor Settings (page 1478)

Frequency to Apply Assemblies Dialog Box
Use this dialog box to add stations to a corridor.
The properties table displays the following settings:

General
Displays general information about the corridor.
Corridor Name
Displays the corridor name.
Baseline Name
Displays the corridor baseline (alignment) name.
Current Range Start
Displays the value for the first station for the current assembly region.
Current Range End
Displays the value for the last station for the current assembly region.

Apply Assembly
Specifies the frequency and placement settings for stations along the corridor.
NOTE Change the default values for the frequency and placement settings from the Edit Feature Settings dialog
box for the CreateCorridor and CreateSimpleCorridor commands. For information, see Changing Corridor Creation
Settings (page 1479).
Along Tangents
Specifies the assembly insertion frequency along the tangent portion of an alignment. Enter a value or
click

and select a distance in the drawing.

Along Curves
Specifies the assembly insertion frequency along the curve portion of an alignment. Enter a value or click
and select a distance in the drawing.
Along Spirals
Specifies the assembly insertion frequency along the spiral portion of an alignment. Enter a value or click
and select a distance in the drawing.
Along Profile Curves
Specifies the assembly insertion frequency along curve portions of the profile geometry. Enter a value or
click

and select a distance in the drawing.

At Horizontal Geometry Points
Specifies whether the assembly should be inserted at horizontal geometry points where the horizontal
alignment geometry changes (such as the start of a curve).
At Superelevation Critical Points
Specifies whether the assembly should be inserted at superelevation critical points (such as ‘end normal
crown,’ ‘level crown,’ ‘reverse crown,’ and ‘begin full super’).
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At Profile Geometry Points
Specifies whether the assembly should be inserted at profile geometry points where the profile geometry
changes.
At Profile High/Low Points
Specifies whether the assembly should be inserted at the high and low points of the profile geometry.
At Offset Target Geometry Points
Specifies whether or not to automatically add assemblies based on offset target objects (feature lines,
alignments, or polylines). For more information, see Adding Assemblies At Offset Geometry Points (page
1485).
NOTE If both an assembly frequency setting that references horizontal geometry and a setting that references
vertical geometry apply to a portion of a corridor, the setting that results in a smaller interval is used. For example,
if a segment is both a horizontal tangent and a vertical curve, and the vertical curve frequency adds assemblies
at more frequent intervals, the frequency specified for vertical curves is used.

Adds a station. You are prompted to select a station location in the drawing. The station is added to the
table of stations.

Deletes the station selected in the table of stations.
The stations table displays the following columns:
Station
Displays the station value on the baseline.
Description
Specifies a description for the station. Click to enter a description.
Related procedures:
■

Adding Corridor Regions (page 1489)

■

Editing Corridor Settings (page 1478)

Match Region Parameters Dialog Box
This dialog box lets you select the parameters to match (assembly, target, frequency) to selected corridor
regions.
Related procedures:
■

Matching Corridor Region Parameters (page 1493)

■

Editing Corridor Regions (page 1486)

Select a Feature Line Dialog Box
Use this dialog box to select a feature line when you have made an ambiguous selection in the drawing.
Feature Line
Lists the feature lines that you can select within the picked region. Click a feature line to select it.
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Related procedures:
■

Managing and Editing Corridors (page 1478)

Select a Profile Dialog Box
Use this dialog box to select a profile either from a list or from the drawing area.
Select An Alignment
Lists the horizontal alignments that are available.

Click to select an alignment in the drawing. The alignment selected in the drawing is then displayed as
the selected alignment in the horizontal alignment listing.
Select A Profile
Displays the profiles that are available for selected alignment.

Click to select a profile in the drawing. The profile selected in the drawing is then displayed as the selected
profile in the Select A Profile list.
Related procedures:
■

Creating Profiles (page 1141)

Select a Subassembly to Insert
Use this dialog box to select a detached subassembly to insert when you are using the Edit/View Corridor
Section Tools to override corridor and assembly parameter sections.
Name
Lists the subassemblies in the current drawing.
Description
Specifies the optional description of the subassembly.

Click to select a subassembly in the drawing.
Related procedures:
■

Editing Corridor Sections (page 1523)

Related procedures:
■

Setting Targets (page 1481)

Select Entities by Layer Dialog Box
Use this dialog box to select feature lines, survey figures and polylines to target either for width or offset, or
for slope or elevation.
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Select feature lines, survey figures and polylines by layer
Layer Name
Displays the name of each layer with named entities.
Select
Click to select all entities on a layer for targeting.
Number Of Entities Found
Displays the number of entities found on the named layer.
NOTE All entities on any selected layer will be listed in Selected Entities To Target list in either the Set Width Or
Offset Target or the Set Slope Or Elevation Target dialog box.

Set Slope or Elevation Target Dialog Box
Use this dialog box to select an object to target for slope or elevation.
Select Object Type To Target
Select whether to target Profiles or Feature Lines, Survey Figures, And 3D Polylines.

Profiles
Select An Alignment
Select from the list any alignment whose profiles you intend to target.

Click to select an alignment in the drawing. The alignment selected in the drawing is then displayed as
the selected alignment in the horizontal alignment listing.
Select Profiles
Select from the list any profile you intend to target.

Click to select a profile in the drawing. The profile selected in the drawing is then displayed as the selected
profile in the Select Profiles list.
Add >>
Click to add a selected profile to the Selected Entities To Target list.

Feature Lines, Survey Figures, And 3D Polylines
Select From Drawing
Click to select a feature line, survey or 3D polyline from the drawing.
Select By Layer
Click to select objects in the Select Entities By Layer dialog box.
Selected Entities To Target
Lists all selected target objects by Number (in order of addition to the list), Type and Name.
NOTE All entities on any layer selected in the Select Entities By Layer dialog box will be listed in Selected Entities
To Target list.

Deletes the selected object from the target entities list.
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Selection Choice If Multiple Targets Are Found
Specifies whether to select Target To Nearest Offset or Target To Farthest Offset, if there are two or more
targets in the Selected Entities To Target list.
Related procedures:
■

Setting Targets (page 1481)

Set Width or Offset Target Dialog Box
Use this dialog box to select an object to target for width or offset.
Select Object Type To Target
Specify whether to target Alignments or Feature Lines, Survey Figures, And Polylines.
Alignments
Select from the list any alignment you intend to target and click Add >>, or click
from the drawing.

to select an alignment

Feature Lines, Survey Figures, And Polylines
Select From Drawing
Click to select a feature line, survey or polyline in the drawing.
Select By Layer
Click to select objects in the Select Entities By Layer dialog box.
Selected Entities To Target
Lists all selected target objects by Number (in order of addition to the list), Type and Name.
NOTE All entities on any layer selected in the Select Entities By Layer dialog box will be listed in Selected Entities
To Target list.

Deletes the selected object from the target entities list.
Selection Choice If Multiple Targets Are Found
Specifies whether to select Target To Nearest Offset or Target To Farthest Offset, if there are two or more
targets in the Selected Entities To Target list.
Related procedures:
■

Setting Targets (page 1481)

Target Mapping Dialog Box
Use this dialog box to set and edit the mapping of targets in subassemblies to the names of actual objects
in the drawing.
Corridor Name
Displays the name of the corridor.
Assembly Name
Displays the name of the assembly. If you are viewing the target for an entire corridor, for which there is
more than one baseline, ‘**Varies**’ is displayed.
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Start Station
Displays the start station for the assembly’s region or the start station on the corridor baseline. If you are
viewing the target for the entire corridor for which there is more than one baseline, ‘**Varies**’ is displayed.
End Station
Displays the end station for the assembly’s region or the end station on the corridor baseline. If you are
viewing the target for the entire corridor for which there is more than one baseline, ‘**Varies**’ is displayed.
The properties table contains the following columns:
Target
Lists targets that are required by the corridor’s subassemblies, categorized into three groups: Surfaces,
Width Or Offset Targets, and Slope Or Elevation Targets.
Object Name
Opens either the Pick A Surface, Set Width Or Offset Target, Set Slope Or Elevation Target or Select Pipe
Network dialog box, where you can select the AutoCAD Civil 3D object name to map to the subassembly
target.
NOTE To quickly set all surface targets to the same surface object, click <Click Here To Set All> next to the
Surfaces collection and select the surface object.
Subassembly
Displays the name of the subassembly that requires the target.
Assembly Group
Displays the name of the assembly group.
Related procedures:
■

Setting Targets (page 1481)

View/Edit Corridor Section Options Dialog Box
Use this dialog box to edit corridor section viewing and editing settings.

View/Edit Options
Code Set Style
Specifies the code set style for the corridor section view. Select a style from the list or use the standard
style selection tools. For information, see the Select Style dialog box (page 2021).
Default View Scale
Specifies the scale factor to use when viewing the corridor sections. For example, enter 1 to fit the section
exactly to the viewing area.
NOTE The new view scale is used for the subsequent section that is viewed.
Rebuild On Edit
Specifies whether the corridor model is automatically rebuilt when you edit a subassembly using the
View/Edit Corridor Section Tools toolbar (page 2042).
Front Clip
Specifies the visible extent of 3D objects displayed in a corridor section, measured forward from the
sampled section.
Back Clip
Specifies the visible extent of 3D objects displayed in a corridor section, measured from the sampled
section back.
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Station Tracker In Multiple Viewports
Specifies whether the station tracker is on.

Grid Settings
Horizontal Grid
Specifies whether there are horizontal grid lines.
Vertical Grid
Specifies whether there are vertical grid lines.
Horizontal Grid Interval
Specifies the interval between horizontal grid lines.
Vertical Grid Interval
Specifies the interval between vertical grid lines.
Grid Color
Specifies the color for grid lines. Click

to open the Select Color dialog box.

Center Axis
Specifies whether there is a center axis line for the grid.
Center Axis Color
Specifies the color for the center axis line. Click

to open the Select Color dialog box.

Grid Text Settings
Text Style
Specifies the text style.
Text Color
Specifies the color for grid text. Click

to open the Select Color dialog box.

Text Height - Relative To Screen
Specifies the height of grid text as a percentage of the height of the grid.
Annotate Center Axis
Specifies whether there is annotation for the center axis line of the grid.
Related procedures:
■

Viewing and Editing Corridor Sections (page 1519)
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Criteria-Based Design
Dialog Boxes

54

The following topics provide information about the Criteria-Based Design dialog boxes.

Design Criteria Editor Dialog Box
Use this dialog box to modify the design criteria file.
The design criteria file contains standards tables for design speed, superelevation attainment method, and
minimum speed, radius, and length of individual alignment and profile sub-entities.
This file can also include criteria to support automatically adding widening to dynamic offset alignments.
If your local agency standards differ from the standards in the supplied design criteria file, you can use the
Design Criteria Editor dialog box to customize the file to support your local standards.

General Controls and Toolbar (unlabled)
New Button
Creates an empty design criteria file containing the Units, Alignments, and Profiles nodes in the design
criteria hierarchy panel.
Open Button
Opens a browse dialog box, which allows you to select another design criteria file to edit.
Save Button
Saves unsaved changes to the currently open design criteria file.
Save As Button
Saves the currently open design criteria file using a new, user-specified name.
Undo Button
Reverses the most recent change to the currently open design criteria file.
Redo Button
Reverses the most recent undo operation in the currently open design criteria file.
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Make File Read-Only Check Box
Prevents the currently open design criteria file from being modified. If selected, the Save, Save As, Undo,
and Redo buttons are not available.
Save And Close Button
Saves unsaved changes to the currently open design criteria file and closes the Design Criteria Editor dialog
box.
Cancel Button
Clears unsaved changes to the currently open design criteria file and closes the Design Criteria Editor
dialog box.
Help Button
Opens the Design Criteria Editor dialog box help topic.

Design Criteria Hierarchy Panel (Unlabeld)
The design criteria hierarchy panel displays the basic categories of information in the design criteria file.
Nodes that are preceded by
preceded by

are containers for criteria tables or other container nodes. Nodes that are

are criteria tables, which contain the design criteria property values that are applied to the

alignment or profile. Right-cli
node to add new
contents in the Attributes panel.

or

nodes to it. Click a

node to edit the table

Collapse All Button
Collapses all the categories in the design criteria panel.
Expand All Button
Expands all the categories in the design criteria panel.
Units Node
Specifies the units of measure for the design criteria file. This value can be either Metric or Imperial. Select
a units value, and then specify the individual unit values in the Attributes panel.
Alignments Node
Contains the design criteria for alignments. Select a
criteria table, and then specify the individual
criteria values in the Attributes panel. The following categories and criteria are available this node:
■

Minimum Radius Tables

■

Superelevation Attainment Methods: Standard or Planar (Continuing or Opposing)

■

Superelevation Tables: Design Speed (Superelevation Design Speed or Transition Length Tables)

Profiles Node
Contains the design criteria for profiles. Select a
criteria table, and then specify the individual criteria
values in the Attributes panel. You can create multiple Minimum K Tables in this category. Each Minimum
K Table can contain any of the following criteria tables:
■

Stopping Sight Distance

■

Passing Sight Distance

■

Headlight Sight Distance
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Attributes Panel (Unlabled)
Add Button
Adds a row to the attribute table. If an existing row is selected, the new row is added below the selected
row. If a row is not selected, the new row is added to the end of the attribute table.
Delete Button
Deletes the currently selected rows.
Attribute Columns
Specify the attributes for the currently selected criteria table. Values in the individual cells are editable.

Comments Panel
User-specified comments for the currently selected container or criteria table node. Comments may be added
to any node in the design criteria hierarchy panel.
Related procedures:
■

Design Criteria Files (page 936)

■

Profile Standards in the Design Criteria File (page 1140)

■

Adding Automatic Widening to Dynamic Offset Alignments (page 966)

Design Check Editor Dialog Box
Use this dialog box to set up design checks that you can use to check your alignment or profile design against
its associated design criteria.
The tables contained in the design criteria file (page 2773) contain most of the criteria used for alignment and
profile design. Other criteria must be checked using mathematical expressions, which in the context of
criteria-based design are known as design checks (page 2772).
Design checks are created and managed in the same manner as label expressions. To apply a design check
to an alignment or profile, you must add it to a design check set (page 2772).
Design checks differ from label expressions in that they always return a true or false value. For example, a
design check may be created to verify minimum tangent length. If a tangent length is greater than or equal
to the minimum value defined in the design check, no notification is issued. If a tangent length is less than
the minimum value defined in the design check, a warning notification is issued.
For examples of design checks, see Design Check Examples (page 941). For instructions on how to create a
design check, see Creating a Design Check (page 942).
NOTE Do not enter functions, constants, or logical operators inside the { } brackets that surround Properties such
as {Minimum Radius}.
To set up a design check, you can use the buttons in the dialog box and the keypad on your keyboard. There
are menus in the dialog box from which you can choose Properties and functions to insert into the design
check.
If you enter a combination of items that is invalid, a parse error appears when you click OK.
NOTE Because design checks return either a true or false value, they must contain one of the following logical
operators: > (greater than), < (less than), >= (greater than or equals), <= (less than or equals), != (not equals), =
(equals).

Design Check Editor Dialog Box | 2069

Name
Specifies a name for the design check.
Description
Specifies a description that appears in the Settings tab item list view.
Design Check Box
Displays the design check as defined from the functions and properties. You can also click in this box and
enter characters such as numbers.
Calculator Buttons
Enter numbers and logical operators (page 1732)into the Design Check box to define the expression.
Insert Property
Inserts a property into the design check. Click the icon to display a list of properties relevant to the design
check type. Select a property to insert it into the design check.
Insert Function
Inserts a function into the expression. See functions (page 1732)for more information.

Functions and Operators
For a list of functions and operators supported in this dialog box, see Functions and Operators (page 1732)
Related procedures:
■

Alignment Design Checks (page 940)

■

Profile Standards in the Design Criteria File (page 1140)

■

Design Check Examples (page 941)

■

Adding Automatic Widening to Dynamic Offset Alignments (page 966)

Design Check Set Dialog Box
Use this dialog box to create a group of design checks for alignments or profiles.
A design check set consists of design checks for a combination of design check types. For example, you can
create a design check set that consists of separate design checks for minimum and maximum A values for
spirals, minimum radius for curves, and minimum spiral transition lengths.
See also:
■

Alignment Design Check Sets (page 944)

Information Tab (Design Check Set Dialog Box)
Use this tab to change the design check set name and description information, and to review details about
the last time the design check set was modified.
Name
Specifies the name of the current design check set.
Description
Specifies the description of the current design check set.
Created By
Displays the AutoCAD login name of the person who created the design check set.
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Date Created
Displays the date and time the design check set was created.
Last Modified By
Displays the AutoCAD login name of the person who last modified the design check set.
Date Modified
Displays the date and time the design check set was last modified.

Design Checks Tab (Design Check Set Dialog Box)
Use this tab to edit the contents of an alignment or profile design check set.
Type
Specifies the type of design check to add to the design check set. The types that are available are dependent
on the object for which you are creating the design check set. Alignments use Line, Curve, Spiral, and
Tangent Intersection types. Profiles use Spiral, Line, and Curve types.
<Type> Checks
Specifies the user-defined design checks that are available for the design check type specified in the Type
list. Select a design check from this list, and then click Add to add it to the design check set.
Label Style Control
Creates a design check, edits the current design check, or creates a copy of the current design check.
Add Label Style
Adds the design check selected in the <type> Checks list to the design check set.
Delete Design Check
Removes a design check from the design check set. Select the design check to delete by clicking in the
row in the lower part of the dialog box.

List of Selected Design Checks
When you add a design check to a set, it appears into the list in the lower part of the dialog box.
Design Check Column
Displays the names of the design checks in the current design check set.
Type Column
Displays the entity types to which the design checks apply.
Apply To Column
For profile curve design checks, specifies the type of curve that the design check will validate. Select one
of the following options:
■

Crest And Sag Curves

■

Crest Curves Only

■

Sag Curves Only

NOTE This column is not available for alignment design check sets.
Related procedures:
■

Alignment Design Check Sets (page 944)
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Drawing Settings Dialog
Box
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The following topics provide information about the Drawing Settings dialog box.

Units and Zone Tab (Drawing Settings Dialog Box)
Use this tab to select linear and angular units, intended plot scale, and coordinate zone for the current
drawing.
Drawing Units
Specifies the linear units (feet or meters) for drawing entities in AutoCAD model space.
Angular Units
Specifies the angular units for drawing entities in AutoCAD model space:
■

Degrees

■

Grads

■

Radians

Imperial To Metric Conversion
Specify one of the following conversion settings from the drop-down list:
■

International Foot (one foot = 0.3048 Meters)

■

US Survey Foot (39.37 Inches per Meter)

Scale Objects Inserted From Other Drawings
Specifies that objects inserted from another drawing will be scaled if necessary to match drawing units in
the current drawing.
Set AutoCAD Variables to Match
Synchronizes AutoCAD settings with AutoCAD Civil 3D settings. If there are no equivalent AutoCAD
settings, a message appears asking if you want to match as closely as possible. The AutoCAD settings that
are synchronized to the AutoCAD Civil 3D settings include the AUNITS, DIMAUNIT, INSUNITS, and
MEASUREMENT AutoCAD system variables (sysvars).
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Scale
Specifies the intended plot scale in imperial or metric units.
Custom Scale
Specifies the plotted size of various annotation-related components, such as label text, ticks, and band
heights. If you change the scale, all annotation objects adjust accordingly.

Zone
NOTE If you know the code of the coordinate system you want, you can enter it directly in the Selected Coordinate
System Code box. A period (.) in this box means no zone has been selected.
Categories
Specifies the geographic zone.
Available Coordinate Systems
Specifies the coordinate system within the selected zone category. If you do not select a zone category,
then the default (No Datum, No Projection) is enabled. If you select a zone category but do not select a
coordinate system, then, by default, the first entry in the list is selected.
Selected Coordinate System Code
Displays the coordinate system code.
Description
Displays a description of the selected zone.
Projection
Displays the projection method for the coordinate system.
Datum
Displays the abbreviation for the datum on which the coordinate system is based.
Related procedures:
■

Specifying Units and Zone Settings (page 80)

Transformation Tab (Drawing Settings Dialog Box)
Use this tab to transform the coordinate system specified on the Units And Zone tab to local specifications.
Zone Description
Displays the description of the zone that is selected on the Units And Zone tab.
Apply Transform Settings
Specifies whether to apply the settings for coordinate system zone transformation. Selecting this check
box enables all the other settings in the dialog box. You cannot select this check box if a zone is not
specified on the Units and Zone tab.

Apply Sea Level Scale Factor
Specifies whether to apply the settings for curvature correction to survey data so that measured horizontal
distances are reduced to the distances at the mean seal level (geodetic distances).
Elevation
Specifies the mean elevation value of your project site with respect to the mean sea level.
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Spheroid Radius
Displays the spheroid radius for the spheroid used by the coordinate system. This value is the radius of a
spheroid close to the shape of the Earth at sea level, approximately 6,370 km. The value shown in this
box is derived from the ellipsoid for the current zone.

Grid Scale Factor
Computation
Specifies the type of scale factor:
■

Unity: Uses 1.00 for all points within the zone.

■

User Defined: Allows you to specify your own scale factor. For example, you can enter the average
scale factor of the points in your survey. This value is used for all points or locations within the zone
and is constant.

■

Reference Point: Uses the scale factor of the specified reference point as the grid scale factor for all
points within the zone.

■

Prismoidal Formula: Uses the prismoidal formula to calculate the grid scale factor. This method is
recommended because it accounts for the fact that every point has a different scale factor. The following
equation is used to calculate prismoidal scale factor.

Where:
■

Keff is the grid scale factor

■

Kref is the scale factor of the reference point

■

Kpt is the scale factor of the current point

■

Kmid is the scale factor of the midpoint between the reference point and the current point.

A different value is used for each point or locations within the zone.
Scale Factor
Specifies the grid scale factor. Enabled only when you select User Defined for Computation.

Reference Point
Use this section to specify a reference point for transformation. The reference point could be a benchmark
that was used in a survey. It can be any point for which you know both the local coordinates and the grid
coordinates.
Select Point In Drawing
Click to pick a reference point on the screen.
Point Number, Local Northing, Local Easting, Grid Northing, Grid Easting
Specifies a reference point by its point number, Local Northing and Easting values, or Grid Northing and
Easting values.

Rotation Point
Use this section to specify a rotation about the reference point in one of two ways: specify a rotation point,
or apply a grid rotation angle.
Select Point In Drawing
Click to pick a rotation point on the screen to set the local Northing and Easting.
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Point Number, Local Northing, Local Easting, Grid Northing, Grid Easting
Specifies a rotation point by its point number, Local Northing and Easting values, or Grid Northing and
Easting values.

Specify Grid Rotation Angle
Click to apply a rotation angle to grid north and azimuth instead of using a rotation point.
To North
Specifies the rotation angle to north. Enter an angle or click
and pick a point or line in the drawing.
The rotation to grid north is the difference between the local coordinate system's north meridian and the
grid north meridian of the current zone. If you are using True North, this value may equal the convergence
angle. If you are using Magnetic North, this value is derived from the declination angle and the convergence
angle.
Azimuth
Specifies the direction of the azimuth. Enter an angle or click
and pick a point or line in the drawing.
Grid azimuth is the angle between the drawing north and the line defined by reference grid and rotation
grid points.
Related procedures:
■

Specifying Transformation Settings (page 81)

Object Layers Tab (Drawing Settings Dialog Box)
Use this tab to specify layers for various objects in AutoCAD Civil 3D. For example, you can specify that you
want all alignments on layer C-ROAD, all parcels on C-PROP, and so on. You can also specify prefixes and
suffixes for the layer names.
If desired, label layers can be controlled through their label style. However, label object groups and single
labels are individual AutoCAD entities, and they always reside on a given AutoCAD layer, as with all other
objects. Use this tab to specify the default layer the labels will be on when initially created. These labels
include the following:
■

Note (use the General Note Label setting)

■

Line & Curve (use the General Segment Label setting)

■

Alignment Station Offset (use the Alignment-Labeling setting)

■

Profile View Station Elevation (use the Profile View-Labeling setting)

■

Surface Spot Elevation (use the TIN Surface-Labeling setting)

■

Section View Offset Elevation (use the Section View-Labeling setting)

■

Profile-Labeling setting

■

Section-Labeling setting

■

Pipe-Labeling setting

■

Structure-Labeling setting

■

Sample Line-Labeling setting
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NOTE For pipes and structures, when indicating the "object name" as the modifier, use the parent network name,
not the name of the pipe or structure. For the Sample Line Labeling setting, the modifier will be the Sample Line
Group name, not the name of the individual sample lines.
Object
Lists all object types in AutoCAD Civil 3D.
Layer
Displays the layer on which the object is drawn. Click to open the Layer Selection dialog box.
Modifier
Specifies whether the layer name includes a text-string modifier, and if so, the location of the modifier:
■

None: No modifier.

■

Prefix: Modifier is added at the beginning of the layer name.

■

Suffix: Modifier is added at the end of the layer name.

Value
Specifies the text string to use as the modifier. You can enter an asterisk (*) to include the object name as
the modifier in the layer name and to put each named object on its own layer. For example, if C-ROAD
is the name specified for alignment layers and you add -* as a suffix, an alignment named overpass is
created on layer C-ROAD-OVERPASS.
Locked
Specifies whether layer settings are locked for the drawing to prevent overrides for individual objects.
Immediate And Independent Layer On/Off Control Of Display Components
Specifies whether object display is controlled by layer visibility.
■

Selected: If an object layer is turned off, the visibility of object subcomponents is not affected if the
subcomponents are on a different layer. For example, in a situation where an alignment is on layer
C-ROAD and the tangents are on layers C-ROAD_LINE and C-ROAD_CURVE, if you turn off the object
layer C-ROAD the lines and curves will still display. However the labels will not display because the
label object recognizes that the object layer is turned off.

■

Cleared: If an object layer is turned off, the object subcomponents are also turned off (or not drawn)
even in situations where the subcomponents are on a different layer.

Related procedures:
■

Specifying Object Layer Settings (page 82)

Abbreviations Tab (Drawing Settings Dialog Box)
Use this tab to control various default abbreviations used in drawing labels and reports.
For example, the default abbreviation for Spiral-Tangent Intersect is TS, meaning any spiral-tangent
intersections in a drawing are labeled TS. If you need spiral-tangent intersection labels to be more detailed
or different, change the abbreviation by clicking in the value column and changing the TS value.
In the Alignment Geometry Point Entity Data section the values also contain format strings that describe
entity properties that will display in the label. For more information see, Property Field Modifiers (page 1692).
NOTE For individual abbreviation definitions, see the Glossary (page 2767).
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General Text
Used for abbreviations that are not feature specific.
Infinity
Applied to alignment spiral radius property values where infinity is returned as the value.
Left/Right
Supported as a unique label text component property field name Offset Side. The left and right side is
determined by looking up-station along the entity.

Alignment Geometry Point Text
Used for abbreviations that are specific to alignment geometry points.
Property
Specifies the geometric point or other entity.

Alignment Geometry Point Entity Data
Used for abbreviations that are specific to alignment geometry point entities that are part of lines, curves,
and spirals.
Property
Specifies the geometric point entity data.

Superelevation
Used for abbreviations that are specific to superelevation.
Property
Specifies the superelevation default properties.

Profile
Used for abbreviations that are specific to profile geometry points.
Property
Specifies the geometric point or other entity.
Related procedures:
■

Specifying Abbreviation Settings (page 83)

Ambient Settings Tab (Drawing Settings Dialog Box)
Use this tab to specify default ambient (background) settings for a variety of settings, including units of
measurement. These units and settings are used throughout AutoCAD Civil 3D, unless they are overridden
at the feature or command level.
For information about working with this dialog box, including the use of the override columns, see Working
with the Standard Settings Dialog Box Controls (page 78).

General
These settings specify a variety of features, some of which control how to display text, numbers, and units.
Plotted Unit Display Type
Specifies how to display numbers in interface controls and on the command line:
■

Decimal: Display numbers with decimal points. If the drawing units are metric, this is the only option.

■

Fractional: Display numbers with fractions.
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Save Command Changes To Settings
Specifies whether any changes made to the settings during a command are saved for the drawing, even
if the setting is marked as "locked" in the settings dialog box.
Show Event Viewer
Specifies whether the Event Viewer is displayed automatically when an event occurs.
Show Tooltips
Specifies whether to display tooltips in the drawing. This setting does not affect tooltips for toolbar icons.
For example, if you move your cursor near an alignment, you see a tooltip that shows the station and
offset location of the cursor. Tooltips can also show surface elevation, point, profile, and section
information.
NOTE You can also control tooltip display at the feature settings level and by editing the properties of an
individual object.
Imperial To Metric Conversion
Displays the conversion method specified on the Units and Zone tab as either US Survey Foot or
International Foot.
New Entity Tool Tip State
Specifies whether to display tooltips by default for new objects.
Drawing Unit
Displays the linear units that are used in the model space of the drawing. Set this value on the Units And
Zone tab of this dialog box.
Drawing Scale
Displays the intended plot scale. Set this value on the Units And Zone tab of this dialog box.
Scale Inserted Objects
Displays whether objects are scaled when they are inserted from other drawings. Set this value on the
Units And Zone tab of this dialog box.
Driving Direction
Determines how curb return alignments are drawn for intersection objects. Left Side of the Road is typically
selected for projects where vehicles travel on the left side of the road; for example, in countries such as
the United Kingdom. In this case, curb return alignments in intersection objects are drawn starting from
the left side of the outgoing road, and ending on the left side of the merging road. Right Side of the Road
is typically selected for projects where vehicles travel on the right side of the road; for example, in countries
such as the United States. In this case, curb return alignments in intersection objects are drawn starting
from the right side of the outgoing road, and ending on the right side of the merging road. For more
information, see Setting Driving Direction (page 1592).
Independent Layer On
Has the same effect as the Immediate And Independent Layer On/Off Control Of Display Components
setting on the Object Layers (page 2076) tab.

Labeling
This setting specifies the default method for prompting for objects when inserting labels that contain
Referenced Text components.
Labeling Prompt Method
■

Command Line: When inserting a label that contains Referenced Text, you are prompted at the
command line to select the objects to refer to in the label.

■

Dialog: When inserting a label that contains Referenced Text, the Label Properties dialog box is
displayed.
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■

Suppress Prompts: When inserting a label that contains Referenced Text, all prompting for objects is
suppressed.

Unitless
These settings specify how to display numeric values that are not specifically defined by the unit type settings
in this dialog box such as distance and coordinate.
Precision
Specifies the number of digits to show to the right of the decimal.
Rounding
Specifies how numbers are rounded up or down to the number of decimal places specified in Precision:
■

Round Normal: If the last displayable digit is even, and the next digit is exactly 5, the program rounds
down. If the last displayable digit is odd, and the next digit is exactly 5, the program rounds up. An
input value of 100.12345 with precision of 4 would be displayed as 100.1234.
If the next digit after the last displayable digit is greater than 5, the program rounds up. If the next
digit after the last displayable digit is less than 5, the program rounds down.
NOTE AutoCAD is limited to 8 displayed decimal places. However, the actual precision beyond the display
capability will still effect rounding. For example, 25.12500000001 would round to 25.13 with two place
precision labeling.

■

Round Up: Numbers are always rounded up. The value 100.12345 with precision of 4 would be 100.1235
and with precision 2 would be 100.13.

■

Truncate: Numbers are limited to the specified number of decimal places without rounding. The value
100.12345 with precision of 4 would be 100.1234 and with precision 2 would be 100.12.

Sign
Specifies how to mark numbers as positive or negative:
■

Sign Negative: A sign is used only with negative values. Example: 100.00, -100.00

■

Bracket Negative: Brackets enclose negative values. Example: 100.00, (100.00).

■

Sign Always +/-: A sign is used with both positive and negative values. Example: +100.00, -100.00

Distance
These settings specify how to display linear distances.
Unit
Specifies the linear unit to use:
■

Meter

■

Kilometer

■

Decimeter

■

Centimeter

■

Millimeter

■

Foot

■

Inch

■

Yard

■

Mile
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Precision
For information, see the Unitless section of this topic.
Rounding
For information, see the Unitless section of this topic.
Sign
For information, see the Unitless section of this topic.

Dimension
These settings specify how to display linear dimensions.
Unit
Specifies the linear unit to use:
■

Meter

■

Kilometer

■

Decimeter

■

Centimeter

■

Millimeter

■

Foot

■

Inch

■

Yard

■

Mile

Precision
For information, see the Unitless section of this topic.
Rounding
For information, see the Unitless section of this topic.
Sign
For information, see the Unitless section of this topic.

Coordinate
These settings specify how to display X and Y coordinates.
Unit
Specifies the linear unit to use:
■

Meter

■

Kilometer

■

Decimeter

■

Centimeter

■

Millimeter

■

Foot

■

Inch

■

Yard
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■

Mile

Precision
For information, see the Unitless section of this topic.
Rounding
For information, see the Unitless section of this topic.
Sign
For information, see the Unitless section of this topic.

Elevation
These settings specify how to display surface elevations.
Unit
Specifies the linear unit to use:
■

Meter

■

Kilometer

■

Decimeter

■

Centimeter

■

Millimeter

■

Foot

■

Inch

■

Yard

■

Mile

Precision
For information, see the Unitless section of this topic.
Rounding
For information, see the Unitless section of this topic.
Sign
For information, see the Unitless section of this topic.

Area
These settings specify how to display surface areas.
Unit
Specifies the drawing unit to use:
■

Square Meter

■

Square Foot

■

Acre

■

Hectare

■

Square Kilometer

■

Square Mile

■

Square Yard
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Precision
For information, see the Unitless section of this topic.
Rounding
For information, see the Unitless section of this topic.
Sign
For information, see the Unitless section of this topic.

Volume
These settings specify how to display terrain volumes.
Unit
Specifies the drawing unit to use:
■

Cubic Meter

■

Cubic Foot

■

Cubic Yard

Precision
For information, see the Unitless section of this topic.
Rounding
For information, see the Unitless section of this topic.
Sign
For information, see the Unitless section of this topic.

Speed
These settings specify how to display speeds for design criteria.
Unit
Specifies the speed as:
■

Kilometer/hr.

■

Meter/sec.

■

Foot/sec.

■

Mile/hr.

Precision
For information, see the Unitless section of this topic.
Rounding
For information, see the Unitless section of this topic.
Sign
For information, see the Unitless section of this topic.

Angle
These settings specify how to display deflection angles between two vectors.
Unit
Specifies the angular unit to use:
■

Radian
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■

Degree

■

Grad

Precision
For information, see the Unitless section of this topic.
Rounding
For information, see the Unitless section of this topic.
Format
Specifies how to display angles:
■

Decimal (DD.DDDDDD)

■

DD°MM’SS.SS” (no spaces)

■

DD° MM’ SS.SS” (spaced)

■

DD.MMSSSS (decimal DMS)

Sign
For information, see the Unitless section of this topic.
Drop Decimal For Whole Numbers
Specifies whether to display whole numbers with zeros after decimals:
■

Yes (example: North 90.00)

■

No (example: North 90)

Drop Leading Zeros For Degrees
Drops leading zeros before values less than 10.

Direction
These settings specify how to display directions.
Unit
Specifies the angular unit to use:
■

Radian

■

Degree

■

Grad

Precision
For information, see the Unitless section of this topic.
Rounding
For information, see the Unitless section of this topic.
Format
Specifies how to display angles:
■

Decimal (DD.DDDDDD)

■

DD°MM’SS.SS” (no spaces)

■

DD° MM’ SS.SS” (spaced)

■

DD.MMSSSS (decimal DMS)
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Direction
Specifies how to display directions:
■

Long Name (example: North 50° 45' East)

■

Short Name (example: N 50° 45' E)

■

Long Name Spaced

■

Short Name Spaced

Capitalization
Specifies how to display direction names:
■

Preserve Case

■

Upper Case (example: NORTH)

■

Lower Case (example: north)

■

Title Caps. (example: North)

Sign
For information, see the Unitless section of this topic.
Measurement Type
Specifies how to calculate the direction of a vector:
■

Bearings

■

North Azimuth

■

South Azimuth

Bearing Quadrant
Specifies which bearing quadrant to use:
■

1 - NE

■

2 - SE

■

3 - SW

■

4 - NW

Drop Decimal For Whole Numbers
Specifies whether to display whole numbers with zeros after decimals:
■

Yes (example: North 90.00)

■

No (example: North 90)

Drop Leading Zeros For Degrees
Drops leading zeros before values less than 10.

Lat Long
These settings specify how to display latitude and longitude.
Unit
Specifies the angular unit to use:
■

Radian

■

Degree
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■

Grad

Precision
For information, see the Unitless section of this topic.
Rounding
For information, see the Unitless section of this topic.
Format
Specifies how to display angles:
■

Decimal (DD.DDDDDD)

■

DD°MM’SS.SS” (no spaces)

■

DD° MM’ SS.SS” (spaced)

■

DD.MMSSSS (decimal DMS)

Direction
Specifies the format of lat/long labels:
■

Prefix Short Name (example: N 50° 45')

■

Prefix Long Name (example: North 50° 45')

■

Suffix Short Name (example: 50° 45' N)

■

Suffix Long Name (example: 50° 45' North)

■

Signed: Includes minus signs for negative values (example: -72° 45’ 35.45678”)

■

Prefix Short Name Spaced

■

Prefix Long Name Spaced

■

Suffix Short Name Spaced

■

Suffix Long Name Spaced

Capitalization
Specifies how to display direction names:
■

Preserve Case

■

Upper Case (example: NORTH)

■

Lower Case (example: north)

■

Title Caps. (example: North)

Sign
For information, see the Unitless section of this topic.
Drop Decimal For Whole Numbers
Specifies whether to display whole numbers with zeros after decimals:
■

Yes (example: North 90.00)

■

No (example: North 90)

Drop Leading Zeros For Degrees
Drops leading zeros before values less than 10.
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Grade/Slope
These settings specify how to display grade and slope measurements.
Precision
For information, see the Unitless section of this topic.
Rounding
For information, see the Unitless section of this topic.
Format
Specifies how to display grade and slope values:
■

Rise:Run (example 1:5)

■

Run:Rise (example 5:1)

■

Percent (example 20%)

■

Decimal (DD.DDDDDD) (example 0.20)

■

Per Mille (example 150‰)

Sign
For information, see the Unitless section of this topic.

Grade
These settings specify how to display grade measurements.
Precision
For information, see the Unitless section of this topic.
Rounding
For information, see the Unitless section of this topic.
Format
Specifies how to display grade values:
■

Percent (example 20%)

■

Decimal (DD.DDDDDD) (example 0.20)

■

Per Mille (example 150‰)

Sign
For information, see the Unitless section of this topic.

Slope
These settings specify how to display slope measurements.
Precision
For information, see the Unitless section of this topic.
Rounding
For information, see the Unitless section of this topic.
Format
Specifies how to display grade and slope values:
■

Rise:Run (example 1:5)

■

Run:Rise (example 5:1)
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Sign
For information, see the Unitless section of this topic.

Station
These settings specify how to display linear features that use station or chainage.
Unit
Specifies the drawing unit to use:
■

Meter

■

Decimeter

■

Centimeter

■

Millimeter

■

Kilometer

■

Foot

■

Inch

■

Yard

■

Mile

Format
Specifies the station format in labels, tooltips, and elsewhere:
■

Station Format: Specifies that normal station formatting is used (example: 0+010.123).

■

Station Index Format: Specifies that indexing is used and applies the Station Index Increment that is
specified on the Labels tab of the Alignment Properties dialog box. For example, if the Station Index
Increment is 200m, then the station at 200m will appear as 1+00 and the station at 400m will appear
as 2+00, and so on. To view this format in labels, you must set up the station label style to use Station
Index Format (page 1051) also.

■

Decimal: Specifies that stations appear as decimal numbers (example: 0010.123).

Precision
For information, see the Unitless section of this topic.
Rounding
For information, see the Unitless section of this topic.
Sign
For information, see the Unitless section of this topic.
Station Delimiter Character
Specifies the separator character used to display stations:
■

Plus Sign ‘+’

■

Minus Sign ‘-’

■

Automatic (plus or minus depending on whether the station value is positive or negative)

■

Underscore ‘_’

■

None
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Station Delimiter Position
Specifies the scale to use for major stations:
■

1+0

■

1+00

■

1+000

■

1+0000

■

1+00000

Drop Decimal For Whole Numbers
Specifies whether to display station whole numbers with zeroes after decimals:
■

Yes (example: 120+00)

■

No (example: 120+00.000)

Drop Leading Zeros Right of Station Character
Drops leading zeros before the station character for whole number station values.
Minimum Display Width
Specifies the minimum display width for the station value, which allows leading zeros to be added if
necessary. For example, assuming a minimum display width of 10 and a precision of 2, a station value of
1234.234 would be displayed as 0012+34.23.

Transparent Commands
These settings specify the prompting behavior of transparent commands across all features. The formats
used to prompt for grade and slope values are set using the Grade and Slope ambient settings.
Prompt For 3D Points
Specifies the prompt sequence (X,Y or X, Y, Z) when creating a point in 3D:
■

True (prompt for 3D points)

■

False (no Z prompt)

Prompt For Y before X
Specifies whether commands prompt for the Y coordinate before the X coordinate:
■

True (Y first)

■

False (X first)

Prompt For Easting Then Northing
Specifies whether commands prompt for the Easting before the Northing:
■

True (Easting first)

■

False (Northing first)

Prompt For Longitude Then Latitude
Specifies whether commands prompt for the Longitude before the Latitude:
■

False (Latitude first)

■

True (Longitude first)
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Related procedures:
■

Specifying Ambient Settings (page 84)
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Google Earth Import and
Export Dialog Boxes

56

Publish AutoCAD DWG to Google Earth Wizard
Use this wizard to export 3D design data from AutoCAD Civil 3D to Google Earth for quick visualization of
the model within the context of the Earth’s surface imagery.

Describe Page (Publish AutoCAD DWG to Google Earth Wizard)
Use this page to specify information about the drawing to be published. This information is displayed in
the Google Earth Places panel under My Places.
Name
Specifies the name of the DWG model (required).
Description
Specifies the details about the published DWG file (optional).
Hyperlink
Specifies the url related to the description field. Only available if the description is specified.
Related procedures:
■

Publishing Civil Data to Google Earth (page 1871)

Items Page (Publish AutoCAD DWG to Google Earth Wizard)
Use this page to select the entities to be published. You can choose to publish either all or selected model
space entities. You can also specify whether you want to publish entity information or object-specific
elements, such as text or render materials.
All Model Space Entities
Select to specify all model space entities to publish in Google Earth.
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Selected Model Space Entities
Activates the specific entities selection mode. Select to specify individual model space entities to publish
in Google Earth.

Click to select model space entities from the drawing to publish in Google Earth.
Publish Text
Select to include all text strings from the drawing in the published file. The text strings are displayed in
the Google Earth data file as named placemarks.
NOTE All text elements are formatted based on Google Earth default style. Your original formatting may not
be preserved.
Publish Entity Information
Select to include additional object-specific information with the published DWG file, for example, length,
grade, and diameter for pipes.
Publish Materials
Select to include render materials associated with the model space entities.
NOTE If timespan information (page 1872)is attached to model space entities, this information is not published
to Google Earth when you select to publish render materials.
Related procedures:
■

Publishing Civil Data to Google Earth (page 1871)

Geo-Reference Page (Publish AutoCAD DWG to Google Earth Wizard)
Use this page to transform the linear coordinates of the drawing to the geographical coordinates of the
Google Earth image.

Drawing Coordinate System Transform
If you have defined a mapping coordinate system for your drawing, select this option to automatically
transform X, Y, Z coordinates of the drawing into geographical coordinates used in Google Earth. This option
is not available if the drawing does not have a coordinate system defined. Use the User-Defined Transform
options to perform manual coordinates transformation.

User-Defined Transform
Select to manually transform the drawing data into the geographical coordinates of Google Earth.
Collect From Image
Click to collect the location information from the imported Google Earth image.
DWG Location
Specifies the coordinate value in the DWG linear units. Specify the following:
■

X: The X-coordinate of the point in the drawing to be associated with the specific longitudinal position
on the Earth’s surface.

■

Y: The Y-coordinate of the point in the drawing to be associated with the specific latitudinal position
on the Earth’s surface.
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Click to select a point in the drawing to be associated with the specific position on the Earth’s surface.
Earth Position (in Decimal Degrees)
Specifies the coordinate values of the points on the Earth’s surface in decimal degrees. Specify the following:
■

Longitude: The longitudinal position of the point on the Earth’s surface that is associated with the
X-coordinate of a specific point on the drawing.

■

Latitude: The latitudinal position of the point on the Earth’s surface that is associated with the
Y-coordinate of a specific point on the drawing.

Click to open the Geographic Location dialog box. See Geographic Location Dialog Box (page 2094).
Orientation of DWG Y-axis to North
Specifies the rotation (in decimal degrees) of the positive Y-axis in the drawing to the North direction in
Google Earth.

Click to open the Geographic Location dialog box. See Geographic Location Dialog Box (page 2094).
Related procedures:
■

Publishing Civil Data to Google Earth (page 1871)

Nudge Page (Publish AutoCAD DWG to Google Earth Wizard)
Use this page to fine-tune the location of the DWG model by offsetting its final position in Google Earth.
Offset (in DWG Linear Units)
Specifies the offset values for the DWG model in Google Earth. Specify the following:
■

North/South: Specify the amount to offset in the North/South direction.

■

East/West: Specify the amount to offset in the East/West direction.

■

Elevation: Specify the amount to offset the altitude.

Elevation Relative to Ground
Select to set the elevation values of the published entities to be relative to the ground level at the location
of the DWG model in Google Earth.
Elevation Relative to Sea Level
Select to set the elevation values of the published entities to be relative to the sea level in Google Earth.
Drape Entities on Ground
Select to set the elevation values of the published entities to the ground elevation directly under the entity.
Related procedures:
■

Publishing Civil Data to Google Earth (page 1871)
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File Page (Publish AutoCAD DWG to Google Earth Wizard)
Use this page to specify the name and location for your published file.
File
Specify the name and extension of the published data file. Google Earth supports both .kmz (compressed)
and .kml (uncompressed) files.

Click to browse to the location where you want to save your DWG model data file.
NOTE Using the .kml extension may result in large data files. Use the .kmz extension to reduce file size.
Related procedures:
■

Publishing Civil Data to Google Earth (page 1871)

Publish and View Page (Publish AutoCAD DWG to Google Earth Wizard)
Use this page to view the status of the publishing operation.
Publishing Status
Shows the publishing operation status bar.
View button
Click to view the published model in Google Earth.
Related procedures:
■

Publishing Civil Data to Google Earth (page 1871)

Geographic Location Dialog Box
Use this dialog box to determine geographical coordinates of a point and specify more precisely the North
direction orientation in relation to major cities around the world.

Latitude
Specifies latitude and direction information in decimal values.
Latitude
Specifies the latitude of the current location. You can specify the value or select the location on the map.
The valid range is 1 - 90.
Direction
Specifies the latitude vertical direction.

Longitude
Specifies the longitude and direction in decimal values. Positive values represent west longitudes.
Longitude
Specifies the longitude of the current location. You can specify the value or select the location on the
map. The valid range is 1 - 180.
Direction
Specifies the longitude horizontal direction.
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North Direction
Specifies the North direction. By default, North is the positive Y direction in the world coordinate system
(WCS).
Angle
Specifies the angle from 0 for the North direction.

Displays the North Direction. Move the bar to adjust the North direction angle value.
Map
Specifies a location by using the pointing device. The latitude and longitude values are updated when
you select a location. If you enter latitude and longitude values, the pointer moves to show the location.
Nearest Big City
Uses the latitude and longitude values for the nearest big city that you select.
Region
Specifies the region of the world.
Nearest City
Specifies a city in the selected region.
Time Zone
Specifies the time zone. Time zones are estimated by reference to the location. You can set the time zone
directly.

Timespan for Google Earth Dialog Box
Use this dialog box to assign the temporal data to objects in your drawing to be able to display the published
model data as they change over the specified period of time.

Use Start Time
Specifies the start time for the object display. By default, the date is set to the current date.
Date
Specifies the date when you want the object display to start.

Use End Time
Specifies the the end time for the object display. By default, the date is set to the current date
Date
Specifies the date when you want the object display to finish.
Related procedures:
■

Attaching Time Information to Model Data (page 1872)
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Grading Dialog Boxes

The following topics provide information about the Grading dialog boxes.

Edit Feature Settings - Grading Dialog Box
Use this dialog box to view and change grading-related settings.
This topic documents settings in all grading-related Edit Settings dialog boxes (drawing-level, feature-level,
and command-level).
■

Drawing-level ambient settings are identified by the

■

Grading feature settings are listed near the top of this dialog box, after the General property group, and
are identified by the

■

drawing icon.

grading icon.

Grading command settings are identifie

command icon.

The precision and number format display used by all grading commands and used to display grading values
is specified in the drawing ambient settings.
For general information about drawing, feature, and command settings and their interaction, see Working
with the Standard Settings Dialog Box Controls (page 78).
For information about drawing-level ambient settings, see Ambient Settings Tab (Drawing Settings Dialog
Box) (page 2078)

Default Styles
Use these settings to specify the default styles for for new feature lines and grading groups.
Feature Line Style
Specifies the default style to apply when creating feature lines. Click in the Value column, and click
to select a style in the Feature Line Style dialog box.
Grading Style
Specifies the default style to apply when creating grading. Click in the Value column, and click
select a style in the Grading Style dialog box.

to
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Cut Slope Grading Style
Specifies the default style to apply when creating cut slope grading. Click in the Value column, and click
to select a style in the Cut Slope Grading Style dialog box.
Fill Slope Grading Style
Specifies the default style to apply when creating fill slope grading. Click in the Value column, and click
to select a style in the Fill Slope Grading Style dialog box.
For information about style selection, see Select Style Dialog Box (page 2021).

Default Name Format
Use these settings to specify the default name formats for new feature lines and grading groups. Click in the
Value column, and click

to make changes in the Name Template dialog box (page 2022).

Feature Line Creation
NOTE This property group is displayed (in different forms) when accessing the settings from the
CreateFeatureLineFromAlign, CreateFeatureLines, and DrawFeatureLine commands.

Feature Line Creation (CreateFeatureLineFromAlign)
Use these settings to specify the default behavior for creating feature lines from alignments.
Feature Line Name
Specifies whether a name is applied to feature lines when created.
Use Feature Line Style
Specifies whether a style is applied to feature lines when created.
Layer Setting
Specifies what layer is applied to feature lines when created. The default is Use the Layer Setting which is
from drawing settings.
Weed Points
Specifies whether to open the Weed Vertices dialog box so you can weed the objects when converting to
a feature line. Change this value to True to open the Weed Vertices dialog box.
Create Dynamic Link
Specifies whether to create a dynamic link to the alignment. Change this value to False to prevent dynamic
link creation.
Mid-ordinate Distance
Specifies the mid-ordinate distance for tessellating curves into short line segments. The default is 0.100.
Spiral Tesselation Factor
Specifies the factor for tessellating spirals into short line segments. The default is 0.25.
For more information, see Creating Feature Lines from Alignments (page 810)

Feature Line Creation (CreateFeatureLines)
Use these settings to specify the default behavior for creating feature lines from objects.
Feature Line Name
Specifies whether a name is applied to feature lines when created.
Use Feature Line Style
Specifies whether a style is applied to feature lines when created.
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Layer Setting
Specifies what layer is applied to feature lines when created. Use the layer setting (from drawing settings).
Use the current layer. Use the selected entity layer.
Erase Existing Entities
Specifies whether creation commands erase selected objects when they are converted to feature lines. By
default objects are erased. Change this value to False to have objects remain in the drawing.
Weed Points
Specifies whether to open the Weed Vertices dialog box so you can weed the objects when converting to
a feature line. Change this value to True to open the Weed Vertices dialog box.
Assign Elevations
Specifies whether to open the Assign Elevations dialog box.
Elevation Source
Specifies whether to assign elevations from a surface, from selected gradings or to set a fixed elevation.
Include Intermediate Elevation Breaks
Specifies whether to include intermediate elevation breaks when assigning elevations from a surface or
grading group.
For more information, see Creating Feature Lines from Objects (page 808)

Feature Line Creation (DrawFeatureLine)
Use these settings to specify the default behavior for drawing feature lines.
Feature Line Name
Specifies whether a name is applied to feature lines when created.
Use Feature Line Style
Specifies whether a style is applied to feature lines when created.
Layer Setting
Specifies the default layer setting when feature lines are created.
For more information, see Drawing Feature Lines (page 813)

Grading Creation
NOTE This property group is displayed when accessing the settings from the CreateGrading command.
Use this setting to specify the default behavior for creating grading.
Transition Region Length
Specifies the default length for transition regions. Enter a length in the Value column or click
and
select a distance in the drawing area. Creation commands prompt for the transition length if you select
the start point of a grading to be within or near to an existing grading.
For more information, see Creating Grading from a Footprint (page 856)

Grading Group Creation
NOTE This property group is displayed when accessing the settings from the CreateGradingGroup command.
Use these settings to specify the default behavior for creating grading groups.
Grading Surface Creation
Specifies whether a grading group generates an automatic surface by default.
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Use Group Name
Specifies whether the automatic surface is named after the grading group by default.
Surface Style
Specifies the default style for the grading group. Click in the Value column, and click
in the Surface Style dialog box.

to select a style

Surface Tessellation Increment
Specifies the default maximum distance along the feature line to add supplemental surface triangle lines
for better definition of the grading group surface. Enter a length in the Value column or click
select a length in the drawing area.

and

Surface Cone Tessellation Angle
Specifies the default maximum angle between supplemental projection lines on exterior corners. Enter
an angle in the Value column or click

and select an angle in the drawing area.

Tessellation settings control the placement of
breaklines along rounded exterior corners and
straight grading segments

For more information, see Creating a New Grading Group (page 806)

Feature Line Fit Curve
NOTE This property group is displayed when accessing the settings from the FitCurveFeature command.
Use these settings to specify the default behavior for creating feature lines along arcs.
Tolerance
Specifies the maximum distance from a PI along the feature to the arc that is to be inserted. When an arc
is inserted, it should pass through all the feature line points (between the start and end points). The
tolerance specifies how much any one point can be off of the arc that is averaged through all the points.
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Fit Curve Tolerance

Minimum Number Of Segments
Specifies the minimum number of segments that must be identified before creating an arc. This setting
is ignored when the Points option is used.
For more information, see Converting Tessellated Lines to Arcs (page 842)

Grading Elevation Editor
NOTE This property group is displayed when accessing the settings from the GradingElevEditor command.
Use these settings to specify the default behavior for the Elevation Editor, when editing feature lines.
Raise/Lower Increment
Specifies the default vertical distance used for each increment when the feature lines of a grading are
raised or lowered to adjust volumes.
Show Grade Breaks Only
Specifies whether only the feature line start/end points and any grade breaks in between are displayed.
This option simplifies the editing process by allowing elevation edits to span multiple points.
For more information, see Editing Feature Lines with the Grading Elevation Editor (page 820)

Grading Layout Tools
NOTE This property group is displayed when accessing the settings from the GradingTools command.
Use these settings to specify the default criteria for grading layout.
Grading Criteria Set
Specifies the default Criteria Set to use when creating grading. Click in the Value column, and click
to select a criteria set in the Grading Criteria Set dialog box.
Grading Criteria
Specifies the default Criteria to use when creating grading. Click in the Value column, and click
select criteria in the Grading Criteria dialog box.

to

For more information, see Creating Grading (page 855)
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Grading Volume Tools
NOTE This property group is displayed when accessing the settings from the GradingVolumeTools command.
Use these settings to specify the default criteria for grading volumes.
Raise/Lower Elevation Increment
Specifies the default vertical distance used for each increment when the feature lines of a grading are
raised or lowered to adjust volumes. Enter a incremental length in the Value column or click
a length in the drawing area.

and select

Limit Feature Selection To Current Group
Specifies whether features outside the current grading group can be selected for raising or lowering in the
volume calculations.
For more information, see Displaying and Adjusting Surface Volumes (page 868)

Join Features
NOTE This property group is displayed when accessing the settings from the JoinFeatures command.
Use this setting to specify the default tolerance for joining feature lines.
Tolerance
Specifies how close feature lines must be when using the Join (page 836) command.

Feature Line Weed
NOTE This property group is displayed when accessing the settings from the WeedFeatures command.
Use these settings to specify the default for weeding vertices.
Apply Angle Factor
Specifies whether the Angle factor in the Weed Vertices dialog box is selected by default.
Angle Factor
Specifies the default Angle factor. Enter an angle in the Value column or click
the drawing area.

and select an angle in

Apply Grade Factor
Specifies whether the Grade factor in the Weed Vertices dialog box is selected by default.
Grade Factor
Specifies the default Grade factor. Enter a percentage in the Value column or click
percentage in the drawing area.

and select a

Apply Length Factor
Specifies whether the Length factor in the Weed Vertices dialog box is selected by default.
Length Factor
Specifies the default Length factor. Enter a length in the Value column or click
the drawing area.

and select a length in

Close Point Removal
Specifies whether the 3D Distance factor in the Weed Vertices dialog box is selected by default.
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Close Point 3D Distance
Specifies the default 3D Distance factor. Enter a distance in the Value column or click
distance in the drawing area.

and select a

For more information, see Weeding Vertices (page 846)
Related procedures:
■

Changing Grading Feature Settings (page 801)

Auto-Balance Volumes Dialog Box
Use this dialog box to specify the required net surface volume (negative for cut or positive for fill) when
adjusting the elevation of grading objects.
Required Volume
Specifies the net surface volume for the grading object. When you enter a value and click OK, the grading
object is edited so that the required volume is met. The grading object may be adjusted up or down in
elevation to meet this value, for example. The action that is performed is recorded in the Description
column of the History table in the expanded part of the Grading Volume Tools (page 2121) dialog box.

Create Grading Group Dialog Box
Use this dialog box to create a new grading group.
Name
Specifies the name of the new grading group. AutoCAD Civil 3D automatically generates a sequential
number.
Description
Specifies an optional description of the grading group.
Automatic Surface Creation
Specifies whether the grading group automatically creates a dynamic surface. If selected, this option
activates all of the following fields in this dialog box.
Use the Group Name
Specifies whether to use the grading group name for the name of the dynamic surface. If cleared, the
surface is named according to the default name format in the CreateSurface command settings.
Tessellation Spacing
Used for surface creation. Specifies the distance along the footprint to add supplemental breaklines for
better definition of the grading group surface.
Tessellation Angle
Used for surface creation. Specifies the angular spacing of supplemental breaklines added around rounded
exterior corners, for better definition of the grading group surface.
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Tessellation settings control the placement of
breaklines along rounded exterior corners and
straight grading segments

Volume Base Surface
Specifies the surface to use for comparison with the grading group surface in volume calculations.
Related procedures:
■

Using Grading Groups (page 806)

■

Creating a New Grading Group (page 806)

Grading Criteria Dialog Box
Use this dialog box to manage and create collections of grading criteria for different types of grading.

Information Tab (Grading Criteria Dialog Box)
Use this tab to change the grading criteria name and description information, and to review details such as
when the criteria was most recently modified.
Name
Specifies the name of the current criteria.
Description
Specifies a text description of the current criteria.
Created By
Displays the AutoCAD login name of the person who created the style.
Date Created
Displays the date and time the style was created.
Last Modified By
Displays the AutoCAD login name of the person who last modified the style.
Date Modified
Displays the date and time the style was last modified.
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Related procedures:
■

Using Grading Criteria (page 804)

■

Editing Grading Criteria (page 858)

Criteria Tab (Grading Criteria Dialog Box)
Use this tab to create new grading criteria definitions.
NOTE The parameters that are displayed under the Grading Method and Projection groups vary, depending on
the Target and Projection parameters. For example, if you select Elevation for the target, the Elevation parameter
is displayed below Target. You can then enter the elevation.
If a criteria is currently used by one or more grading objects, you cannot edit the values for Target or
Projection.

Grading Method
Target
Specifies the target method for the grading. Click one of the following:
■

Surface: Specifies that the grading projection lines will be extended from the footprint until they
match into a surface. You are prompted to select a target surface when you create a grading that uses
these criteria.
Surface as target (section view)

surface as target

daylight

footprint

■

Elevation: Specifies that the grading projection lines will be extended from the footprint until they
reach a specified elevation. Enter a positive or negative number in the Elevation field.
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Elevation as target (section view)

fixed elevation as target

footprint

daylight
specified elevation

■

Relative Elevation: Specifies that the grading projection lines will be extended from the footprint until
they reach an elevation (depth or height) relative to the footprint. Enter a positive or negative number
in the Relative Elevation field.
Relative elevation as target (section view)

relative elevation as target

footprint

relative elevation
daylight

■

Distance: Specifies that the grading projection lines will be extended from the footprint until they are
match a specified horizontal distance. Enter a positive number in the Distance field.
Distance as target (section view)

horizontal distance as target

footprint
daylight
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Projection
Specifies the type of projection. Choices vary according to the target method.
■

Cut/Fill Slope: Creates the grading by projecting a specific slope value towards a target that can occur
both above and below the footprint, such as a surface or elevation target. Slope is always a positive
value, as the type of slope determines whether it is going up or down from the footprint. Slope can
be formatted as a slope value (run:rise or rise:run), or a grade value (percent or decimal). Related
parameter for surface target: see Search Order.

■

Cut Slope: Creates the grading by projecting a specific slope value up to a target. Slopes can be formatted
as a slope value (run:rise or rise:run), or a grade value (percent or decimal).

■

Fill Slope: Creates the grading by projecting a specific slope value down to a target. Slopes can be
formatted as a slope value (run:rise or rise:run), or a grade value (percent or decimal).

■

Distance: Creates the grading with projection lines that extend a fixed horizontal distance from the
footprint.

■

Slope: Creates the grading by projecting to a specific (absolute) elevation using a specific slope value.
Enter a positive or negative value. Slopes can be formatted as a slope value (run:rise or rise:run), or a
grade value (percent or decimal).

■

Elevation: Creates the grading by projecting to a specific (absolute) elevation value.

■

Relative Elevation: Creates the grading by projecting to an elevation value that is measured relative to
the elevation of the footprint.

Search Order
Specifies whether to search first for cut or fill slopes in cases where both would work. For example, where
the target surface has a steep slope, both cut and fill slopes may intersect the surface.
■

Cut First: Creates the grading by trying to grade up from the footprint. If no solution is found, it will
grade down.

■

Fill First: Creates the grading by trying to grade down from the footprint. If no solution is found, it
will grade up.

Different results achieved based on Cut First and Fill First settings (section
view)

Cut First grades up

Fill First grades down

NOTE Technically both of these situations are “fill”. However, AutoCAD Civil 3D treats the up-slope direction
as cut and the down-slope direction as fill.

(Cut Slope/Fill Slope/Distance/Elevation/Relative Elevation) Projection
NOTE The values available for Projection type vary according to the selected Target type.
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Format
Specifies how the slope should be represented. Click either Slope or Grade in the list. The format can be
further edited in the Grading Settings dialog box (page 2097).
Distance
Specifies the fixed distance from the footprint for the projection. Enter a value, or click
distance in the drawing area.

to select a

Slope
Specifies the slope value. Enter a positive value in the form of run:rise or rise:run.
Grade
Specifies the grade value. Enter a positive value as a decimal percent.

Conflict Resolution
Interior Corner Overlap
Specifies how interior corner projections are cleaned up when the footprint corner has different elevations.
This situation results in two possible daylight point elevations. You can choose to average the slopes to
reach the same point, or increase or decrease one of the slopes.
Corner elevation conflict (plan view)

82.2

82.4

footprint
3:1

daylight line

3:1

80.4

82.0
80.0

daylight point has two possible
elevations

■

Use Average Slope: Averages the slopes to reach same daylight point.
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82.2

82.4

slope increased
footprint
2.73:1

daylight line

slope flattened
3.33:1
82.0
80.2

slopes averaged to reach same
daylight point

■

Hold Slope As Maximum: Holds the specified grade or slope as the maximum and flattens out the slope
projected from the footprint on one side.

82.2

82.4

footprint
3:1

daylight line

slope flattened
3.75:1
82.0
80.4

slopes held at maximum of 3:1
to reach same daylight point

■

Hold Slope As Minimum: Holds the specified grade or slope as the minimum and increases the slope
projected from the footprint on one side.
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82.2

82.4

slope increased
footprint
2.5:1

daylight line

3:1
82.0
80.0

slopes held at minimum of 3:1
to reach same daylight point

Related procedures:
■

Using Grading Criteria (page 804)

■

Editing Grading Criteria (page 858)

Grading Criteria Set Properties Dialog Box
Use this dialog box to edit name and description properties for the selected criteria set.
Name
Specifies the name of the current grading criteria set.
Description
Contains the description of the current grading criteria set.
Created By
Displays the AutoCAD login name of the person who created the criteria set.
Date Created
Displays the date and time the criteria set was created.
Last Modified By
Displays the AutoCAD login name of the person who last modified the criteria set.
Date Modified
Displays the date and time the criteria set was last modified.
Related procedures:
■

Creating Grading Criteria (page 804)

Grading Editor Dialog Box
Use this dialog box to edit the grading criteria values and change the start or end point of a grading.
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You can edit unlocked grading criteria values and apply criteria to grading in the drawing. Editing a value
updates the grading in the drawing. Locked values are read-only.
For information about the criteria that you can edit, see the Grading Criteria dialog box (page 2104).
Select a Grading
Selects a different grading for editing.
Related procedures:
■

Editing Grading Criteria (page 858)

■

Using Grading Criteria (page 804)

Elevation Editor Dialog Box
Use this dialog box to edit the elevations and grades for feature line, lot line, or survey figure segments. You
cannot change the values of the stations or segment lengths.
Green triangles indicate primary geometry points. Green circles indicate intermediate elevation points.
White triangles indicate split points, where two features lines cross with neither having a geometry point
at that location. Split points cannot be directly edited. When a vertex shares a point with another intersecting
feature line, a small plus symbol is added to the icon for that row. The gray point icons in the grid control
and the drawing glyphs represent read-only objects, such as daylight lines and dynamically linked feature
lines. For more information, see Editing Feature Lines with the Grading Elevation Editor (page 820).
Use the Shift key to select multiple rows for editing with the Raise/Lower commands.
Select Line
Selects a feature line, lot line, or survey figure for editing.
Zoom To
Zooms the drawing display to the selected point of intersection (PI) or elevation point.
Quick Profile
Creates a quick profile (page 1153) of the feature line.
Raise/Lower
Adjusts the elevation of rows either upward or downward. If no rows are selected, prompts for a new
elevation for the first point, then adjusts all rows by the same relative amount. If rows are selected, prompts
for the new elevation of the first selected row, then adjusts all the selected rows by the same relative
elevation.
Raise Incrementally
Adjusts the elevations of all points upward by the increment value. If no rows are selected, the option
adjusts all points, otherwise it adjusts the points only for the selected rows.
Lower Incrementally
Adjusts the elevations of all points downward by the increment value. If no rows are selected, it adjusts
all points, otherwise it adjusts the points for the selected rows.
Set Increment
Specifies the value to be used by the Raise and Lower commands. Enter the value.
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Flatten Elevations
Specifies that the elevations of all selected rows are flattened to either the same elevation as the first row
in the selection, or a constant grade from the start elevation to the end elevation of the selection. Click
to open the Flatten dialog box.
Insert Elevation Point
Inserts an elevation point between the start and end stations of the footprint, creating an intermediate
elevation point.
Delete Elevation Point
Deletes an elevation point between the start and end stations of the footprint. You can delete only a
single-row selection of intermediate elevation points.
Elevations From Surface
Selects an elevation from a surface in the drawing. If there is only one surface, it automatically uses that
surface to retrieve the elevations. If there is more then one surface, it prompts you to select the desired
surface. If no rows are selected, it updates the elevation of all points. Otherwise, it updates just the selected
rows. If the feature line is off the surface, it displays a warning message. If some elevations are updated,
but one or more points are off the surface, it displays a message indicating the number of points off the
surface that could not be assigned elevations. This option is disabled if the drawing has no surfaces.
Reverse
Changes the direction of feature lines. Updates the editor so that the order of points is reversed. This
command affects the labeling and stationing of feature lines.
Show Grade Breaks Only
Displays only the feature line start/end points and any grade breaks in between. This option simplifies
the editing process by allowing elevation edits to span multiple points. By default, the table displays all
feature line points.
Unselect All Rows
Clears any selected rows so that the Raise, Lower, and Flatten commands to affect the entire length of the
footprint.
Station
Identifies the point that starts the current segment.
Elevation
Specifies the elevation of the point identified by the Station.
Length
Displays the length of the current segment.
Grade Ahead
Specifies the end elevation of the current segment in the forward direction. Modifying this grade will
change the elevation of the segment. This is the elevation of the next Station point in the next row of
the grid.
NOTE To edit the grade of multiple rows, select the desired rows and edit the grade of one of the selected rows.
The new grade will be applied to all selected rows.
Grade Back
Specifies the grade of the current segment from its end to start. Modifying this grade will change the start
elevation of the segment, which is the point at the beginning of the current row.
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Related procedures:
■

Editing the Elevations of a Feature Line (page 818)

Elevation Editor - Flatten Dialog Box
Use this dialog box to edit the elevations and grades for feature line, lot line, or survey figure segments to
either a constant elevation or a constant grade.
Select Constant Elevation to modify the points to a constant elevation. If no rows are selected it flattens the
entire feature line using the elevation of the start point. If some rows are selected it flattens just those using
the elevation of the first selected row. Select Constant Grade to edit the selected rows to a constant grade.
The entire feature line grade is modified if no rows are selected. It holds the start elevation and the end
elevation and sets the points in between to the same grade, in effect eliminating the grade breaks.
Select Constant Elevation to select multiple rows for editing with the Raise/Lower commands.
Related procedures:
■

Editing the Elevations of a Feature Line (page 818)

Grading Group Properties Dialog Box
Use this dialog box to view and edit the properties of the selected grading group.
See also:
■

Grading Properties (page 864)

Information Tab (Grading Group Properties Dialog Box)
Use this tab to view or change general information for the grading group. The options for automatic surface
creation and volume base surface are usually set when the grading group is created, but they can be changed
here.
Name
Specifies the name of the grading group.
Description
Specifies an optional description of the group.
Automatic Surface Creation
Specifies whether the grading group automatically creates and updates a dynamic surface. Default surface
name is the grading group name.
■

Selected: If the check box is already selected, it means a surface exists for the grading group. You can
clear the check box to either delete the dynamic surface or to create a detached surface. When you
clear the check box, you are prompted to delete the surface. If you click No, the surface is detached
from the grading group.

■

Cleared: If the check box is already cleared, no dynamic surface exists for the grading group. You can
select the check box to create a dynamic surface, and the Create Surface dialog box is opened.

Tessellation Spacing
Specifies the gap between projection lines on the grading group surface.
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Tessellation Angle
Specifies the angular distance between radial projection lines on exterior corners of the grading group
surface.
Volume Base Surface
Specifies the surface to use for comparison with the grading group surface in volume calculations.
Related procedures:
■

Create Grading Group Dialog Box (page 2103)

■

Using Grading Groups (page 806)

Properties Tab (Grading Group Properties Dialog Box)
Use this read-only tab to review properties of the grading group.
You can see basic statistics such as
■

Area covered by the grading group

■

Range of elevations and slopes

■

Volume report

■

Number of times the grading group used specific grading criteria and styles

Related procedures:
■

Grading Group Properties (page 864)

Grading Creation Tools
Use this toolbar to quickly create new grading, apply grading criteria and styles, and edit existing grading.
Set The Grading Group
Opens the Select Grading Group dialog box (page 2122). Select the current grading group, or create a new
group.
Set The Target Surface
Opens the Select Surface dialog box. Select the surface to use as a target. Applies only when the Grading
Criteria uses Surface as the Target.
Set The Grading Layer
Opens the Set Grading Layers dialog box. Specify on which layer the grading should be created.
Select a Criteria Set
Sets the current criteria set, from which you can select specific criteria.
Select a Criteria
Click the Down arrow to select a criteria to apply to the grading.
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Style Picker
Use these options to edit the current criteria or create a new criteria.

Grading Creation Tools
Create Grading
Creates grading by using prompts on the command line. The grading uses the current style and criteria.
Copy Create Grading
Creates a grading by copying the criteria and style from an existing grading object.
Create Transition
Creates a transitional slope between two different criteria or two different values.
Create Infill
Creates a grading face that has no criteria to fill in any holes that are left by creating grading.

Grading Editing Tools
Edit Grading
Provides a series of command line prompts for you to change the criteria of a grading object.
Delete Grading
Deletes a grading and removes it from the grading group.
Change Grading Group
Prompts you to select the grading objects and then opens the Select Grading Group dialog box (page 2122).
Select a grading group to move the grading objects into.

Grading Utilities
Grading Volume Tools
Opens the Grading Volume Tools (page 2121). Raise or lower the grading group to meet target cut and fill
volumes.
Create Detached Surface
Creates a new surface that is not associated with the grading group, and therefore does not update to
reflect changes in the group.
Grading Editor
Prompts you to select an existing grading and opens the Grading Editor dialog box.
Grading Elevation Editor
Prompts you to select an existing feature line or lot line, then displays the Grading Elevation Editor dialog
box.
Grading Group Properties
Opens the Grading Group Properties dialog box (page 2113).
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Grading Properties
Opens the Grading Properties dialog box (page 2116). Note that this is the only place to view the properties
of an individual grading.
Expand
Shows or hides the current grading criteria values and the style selectors. You can view the criteria values
here.
Related procedures:
■

Creating Grading (page 855)

Grading Properties Dialog Box
Use this dialog box to view and change the styles and properties for the selected grading.
Grading Group
Specifies the grading group for the selected grading.
Style Name
Specifies the grading style for the selected grading.
Property & Value
Displays information about the grading type and grading criteria.
Related procedures:
■

Grading Object Properties (page 865)

Grading Style Dialog Box
Use this dialog box to control the display of each grading component.

Information Tab (Grading Style Dialog Box)
Use this tab to change the grading style name and description information, and to review other details, such
as when the style was most recently modified.
Name
Specifies the name of the current grading style.
Description
Displays a description of the current grading style.
Created By
Displays the AutoCAD login name of the person who created the style.
Date Created
Displays the date and time the style was created.
Last Modified By
Displays the AutoCAD login name of the person who last modified the style.
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Date Modified
Displays the date and time the style was last modified.
Related procedures:
■

Using Grading Styles (page 802)

Center Marker Tab (Grading Style Dialog Box)
Use this tab to specify the size of the triangular marker for the center of a grading.
Size
Specifies the size of the marker and how it is calculated:
■

Percentage Of Screen: Marker size is a fixed percentage of the size of the drawing window, and resizes
for the current zoom level. Default option.

■

Plotted Size: Marker size is based on the current drawing scale (inches or millimeters).

■

Fixed Size: Marker size is specified in the current drawing units (usually feet or meters).

Related procedures:
■

Using Grading Styles (page 802)

Slope Pattern Tab (Grading Style Dialog Box)
Use this tab to configure the pattern used to mark grading slopes.
Slope patterns are not applied to infill gradings.
Slope Pattern
Specifies whether to use a slope pattern with the current grading style. Select a slope pattern style and
edit a style or create a new one.
Slope Range
Specifies whether the slope pattern is applied to a limited range of slope values, and specifies the range.
Related procedures:
■

Using Grading Styles (page 802)

Display Tab (Grading Style Dialog Box)
Use this tab to specify the defaults for the separate components of a grading object.
View Direction
Specifies the type of view: either 2D or 3D.
Component
Specifies the name of the grading component.
Visible
Controls component visibility.
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Layer
Opens the AutoCAD Layer Selection dialog box. You can assign components to a layer that you create
during drawing setup or you can click the New button and create a new layer for the component.
Color
Specifies the component’s color. You can select a color for the component from the Select Color dialog
box, or you can specify that the component should derive its color BYLAYER or BYBLOCK.
Linetype
Displays the Select Linetype dialog box, which allows you to specify the linetype for the component.
Lineweight
Displays the Select Lineweight dialog box, which allows you to specify the lineweight for the component.
Linetype Scale
Specifies the linetype scale for the component.
Plot Style
Sets the plot style for the component.
Related procedures:
■

Using Grading Styles (page 802)

Summary Tab (Grading Style Dialog Box)
Use this tab to view summary information about the grading. You can edit the Name and Description.

Information
Name
Specifies the name of the current grading style.
Description
Specifies the description of the current grading style.
Created By
Displays the AutoCAD login name of the person who created the style.
Date Created
Displays the date and time the style was created.
Last Modified By
Displays the AutoCAD login name of the person who last modified the style.
Date Modified
Displays the date and time the style was last modified.
Related procedures:
■

Using Grading Styles (page 802)

Feature Line Style Dialog Box
Use this dialog box to control the display of each grading feature line component.
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Information Tab (Feature Line Style Dialog Box)
Use this tab to change the grading style name and description information, and to review other details, such
as when the style was most recently modified.
Name
Specifies the name of the current feature line style.
Description
Displays a description of the current feature line style.
Created By
Displays the AutoCAD login name of the person who created the style.
Date Created
Displays the date and time the style was created.
Last Modified By
Displays the AutoCAD login name of the person who last modified the style.
Date Modified
Displays the date and time the style was last modified.
Related procedures:
■

Applying Feature Line Styles (page 811)

Profile Tab (Feature Line Style Dialog Box)
Use this tab to specify the appearance of marker symbols for a feature line projected into a profile view.
You can specify different styles for the markers at the beginning, internal vertices, and the end of the feature
line. Click

to edit the style. Click

to preview the selected style.

Related procedures:
■

Applying Feature Line Styles (page 811)

Section Tab (Feature Line Style Dialog Box)
Use this tab to specify the appearance of the feature line marker symbol in a section view.
Related procedures:
■

Applying Feature Line Styles (page 811)

Markers Tab (Feature Line Style Dialog Box)
Use this tab to specify the appearance of the feature line marker symbol in the drawing. This marker symbol
is for displaying the feature line in a section view.
Marker Style
Select the check box and specify a marker style in the list. Click
the selected style.

to edit the style. Click

to preview
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Related procedures:
■

Applying Feature Line Styles (page 811)

Display Tab (Feature Line Style Dialog Box)
Use this tab to specify the default display for the components of a feature line.
View Direction
Specifies the context for which you are setting the display:
■

Plan – the printed drawing

■

Model – the on-screen design window

■

Profile – projected into a profile view (line and vertex markers)

■

Section – projected into a section view (crossing markers)

Component Type
Specifies the name of the feature line component.
Visible
Controls component visibility.
Layer
Opens the AutoCAD Layer Selection dialog box. You can assign components to a layer that you create
during drawing setup or you can click the New button and create a new layer for the component.
Color
Specifies the component’s color. You can select a color for the component from the Select Color dialog
box, or you can specify that the component should derive its color BYLAYER or BYBLOCK.
Linetype
Displays the Select Linetype dialog box, which allows you to specify the linetype for the component.
LT Scale
Specifies the linetype scale for the component.
Lineweight
Displays the Select Lineweight dialog box, which allows you to specify the lineweight for the component.
Plot Style
Sets the plot style for the component.
Related procedures:
■

Using Grading Styles (page 802)

Summary Tab (Feature Line Style Dialog Box)
Use this tab to view summary information about the feature line. You can edit the Name and Description.

Information
Name
Specifies the name of the current feature line style.
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Description
Specifies the description of the current feature line style.
Created By
Displays the AutoCAD login name of the person who created the style.
Date Created
Displays the date and time the style was created.
Last Modified By
Displays the AutoCAD login name of the person who last modified the style.
Date Modified
Displays the date and time the style was last modified.
Related procedures:
■

Using Grading Styles (page 802)

Grading Volume Tools
Use this toolbar to adjust the cut and fill volumes for a grading group.
Controls on this toolbar are not available (dimmed) if any required data is unavailable. For example, this
can occur if a grading group has not been selected, or if one of the required surfaces has not been defined.
Set the Grading Group
Click to specify the grading group to adjust. The name of the group is displayed along the bottom of the
toolbar.
Grading Group Properties
Opens the Grading Group Properties dialog box (page 2113).
Entire Group
Click to adjust the elevation of the whole grading group.
Selection
Click to select one or more features. Click

to select the features to adjust.

Raise the Grading Group
Raises the elevation of the grading group by the amount in the box.
Lower the Grading Group
Lowers the elevation of the grading group by the amount in the box.
Automatically Raise/lower to Balance Volumes
Opens the Auto-Balance Volumes dialog box (page 2103). Specify a target value for net volume and
automatically balance cut and fill volumes to approach the target.
Auto-balancing volumes to the target is an iterative process due to surface irregularities. The system aims
to reach the target volume, with a tolerance of 0.1% of the difference between the starting and target
volumes. If necessary, re-run the command to get closer to the target.
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NOTE This button is unavailable unless the Automatic Surface Creation setting is selected and a Volume Base
Surface is specified in the Grading Group Properties

to display the Grading Group Properties dialog box.

Expand the Grading Volume Tool
Shows or hides the history of cut and fill adjustments. This history is erased when you close the toolbar.
Volume Display
Displays the current cut and fill volumes and the resulting net requirements for the grading group. This
display updates whenever you modify either of the two surfaces involved in the comparison.
Related procedures:
■

Editing the Elevations of a Feature Line (page 818)

Insert PVI Dialog Box
Use this dialog box to display and edit the values of individual PVIs that you add to a grading feature line.
This dialog box is displayed when you click the Insert PVI button in the Elevation Editor dialog box and
select a feature line.
Station
Specifies the station of the new PVI. Edit the station definition if needed.
Elevation
Specifies the elevation of the PVI. Edit the elevation if needed.
Related procedures:
■

Editing PVIs (page 1193)

New Slope Pattern Component Dialog Box
Use this dialog box to specify the position of a new component in relation to existing slope pattern
components.
Components are numbered in left to right order.
Insert New Component At Position
Specifies the position at which the new component is placed. A new component is placed at the end of
the series by default. If you select a different position, existing components in that and higher positions
are incremented by one.
Related procedures:
■

Creating Grading Styles (page 802)

Select Grading Group Dialog Box
Use this dialog box to select the grading group to which an individual grading belongs.
Site Name
Select the site you want from the list of the sites in the current drawing. Click
drawing.
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to select a site in the

Group Name
Select the group you want from the list of the grading groups in the current drawing. Click
a grading group in the drawing. Click

to select

to create a new grading group.

Description
Displays the description of the grading group, if one has been defined.
Related procedures:
■

Using Grading Groups (page 806)

■

Changing the Grading Group of a Grading Object (page 807)

Set Grading Layers Dialog Box
Use this dialog box to override the layer settings for the grading objects you create.
Grading Layer
Specifies the layer name the grading is on.
The Object Layer dialog box is used to specify default base layers for drawing objects. The base layer is
where the object physically resides.

Opens the Object Layers dialog box, which allows you to specify the layer.

Slope Pattern Style Dialog Box
Use this dialog box to specify the format of a slope pattern.

Information Tab (Slope Pattern Style Dialog Box)
Use this tab to change the style name and description information, and to review other details, such as when
the style was most recently modified.
Name
Specifies the name of the current slope pattern style.
Description
Specifies the description of the style.
Created By
Displays the AutoCAD login name of the person who created the style.
Date Created
Displays the date and time the style was created.
Last Modified By
Displays the AutoCAD login name of the person who last modified the style.
Date Modified
Displays the date and time the style was last modified.
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Related procedures:
■

Using Grading Styles (page 802)

Layout Tab (Slope Pattern Style Dialog Box)
Use this tab to configure the appearance of a slope pattern.
Each line in the slope pattern is a separate component.
Component
Specifies the name of the slope pattern component represented in the table of parameter values. You can
use the buttons next to this field to add, copy, or delete a component.
Add Component
Creates a new component using the default parameters. Opens the New Slope Pattern Component dialog
box. Specify the position of the new component in relation to existing components.
Copy Component
Creates a new component using the same parameters as the current component. Opens the New Slope
Pattern Component dialog box (page 2122). Specify the position of the new component in relation to existing
components.
Delete Component
Removes the current component from the slope pattern. Not available if only one component exists.

Slope Line Parameters
Pattern Start
Specifies whether the pattern begins at the top or bottom of the slope.
Length Type
Specifies how to determine the line length for this component. Each option invokes one or more additional
parameters, as described:
■

Length: Specifies that Line length is a fixed value. Related parameter Length specifies the value in
drawing units (usually feet or meters). The line is trimmed if the slope is shorter than this length.

■

Percent of Length: Specifies that Line length is a percentage of the slope length, up to a specified
maximum. Related parameters: Percent of Length specifies the percentage value; Maximum Length
specifies the maximum line length in drawing units.

■

Slope Ratio: Specifies that line length varies directly with the steepness of the slope. Related parameters:
Slope 1 and Slope 2 specify outside limits for slope values that are represented by line length; Percent
of Length 1 specifies the line length as a percent of slope length for Slope 1; Percent of Length 2
specifies the same value for Slope 2. Example: Slope 1 = 6:1, Percent of Length 1 = 20%, Slope 2 = 2:1,
Percent of Length 2 = 80%. On a 10-feet long slope, a 6:1 slope is marked with a 2-feet line and a 2:1
slope is marked with an 8-feet line. An intermediate value, 4:1, is marked with a 5-feet line. An outside
value, 10:1, is marked with a 1-foot line.

Color
Specifies the color of the line.
Linetype
Opens the Select Linetype dialog box. Specify the linetype for the component.
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Lineweight
Opens the Select Lineweight dialog box. Specify the lineweight for the component.

Slope Line Offset Parameters
Offset Type
Specifies how to determine the offset distance between this component and the previous component in
the slope line style. Distances are measured as a linear value along the feature and an angular value around
exterior corners. Each option invokes additional parameters as described.
■

Percent of Length: Specifies that Offset is a percentage of the slope length at the position being offset
from. Related parameters: Percent of Length specifies the percentage; Minimum Distance and Maximum
Distance specify values for minimum and maximum offsets in drawing units; Radial Offset Angle
specifies the angular value.

■

Distance: Specifies that Offset is a fixed value. Related parameters: Distance specifies the linear value
in drawing units (usually feet or meters); Radial Offset Angle specifies the angular value. The Radial
Offset Angle parameter is not used in corridors.

■

Divide: Specifies that Offset evenly divides the distance between the previous and the next components
to insert one or more instances of the current component. This option is not available if the previous
or next component is set to Divide. Related parameter: Number of Lines specifies the number of
instances of this component to insert.

Slope Line Symbol
Symbol Type
Specifies whether a symbol is added to the beginning of the slope line, and if so, the type of symbol:
■

None: No symbol.

■

AutoCAD Block: Adds a block that is defined in the drawing. Related parameter: Block Name specifies
the block to insert.

■

Triangle: Adds a triangle.

■

Filled Triangle: Adds a triangle with a solid fill.

■

Tapered Lines: Adds a set of lines parallel to the edge of the slope, tapering toward the slope line in a
triangular pattern. A gap exists between the last tapered line and the slope line. Related parameter:
Number of Lines specifies the number of lines to include in the set.

■

Tapered Lines (No Gap): Adds a set of tapered lines, and attaches the last tapered line to the slope
line. Related parameter: Number of Lines specifies the number of lines to include in the set.

Length Type
Specifies how to determine the length of the symbol. Each option invokes an additional parameter:
■

Length: Specifies that Symbol length is a fixed value. Related parameter Length specifies the value in
drawing units (usually feet or meters).

■

Percent of Length: Specifies that symbol length is a percentage of the slope length. Related parameter
Percent of Length specifies the percentage value.

Width Ratio
Specifies the ratio of the symbol’s width to its length along the slope line (width = length * width ratio).
Color
Specifies the color of the symbol.
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Linetype
Opens the Select Linetype dialog box. Specify the linetype for the symbol.
Lineweight
Opens the Select Lineweight dialog box. Specify the lineweight for the symbol.

General Properties
Minimum Display Length
Specifies the minimum slope length on which to display the slope pattern.
Use the following parameters to configure the sample slope in the preview window.
Preview Feature Length
Specifies the length of feature line to display.
Preview Slope Length
Specifies the length of slope to display.
Preview Slope
Specifies the slope value to display.
Related procedures:
■

Using Grading Styles (page 802)

Edit Geometry Panel
Use this panel to edit feature lines, 2D and 3D polylines, survey figures, and parcel lines.
This is a standard panel that you access by selecting Modify tab ➤ Edit Geometry panel.
NOTE See Editing Feature Lines (page 816) for a list of supported objects for each command. Supported objects
are also listed at the command line when you run the command.
Break
Breaks a feature line into two feature lines. (page 849)
Trim
Trims a feature line. (page 850)
Join
Joins multiple feature lines, creating a single object. (page 836)
Reverse
Reverses the direction of feature lines for stationing purposes. (page 837)
Fillet
Rounds the corners of feature lines. (page 841)
Fit Curve
Converts tessellated curves to true arcs for better grading results. (page 842)
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Smooth
Smooths out jagged feature lines. (page 844)
Weed
Deletes vertices and elevation points from feature lines. (page 846)
Stepped Offset
Offsets feature lines at an elevational difference. (page 848)

Edit Elevations Panel
Use this panel to edit feature lines, 2D and 3D polylines, survey figures, and parcel lines.
This is a standard panel that you access by selecting Modify tab ➤ Edit Elevations panel.
NOTE See Editing Feature Lines (page 816) for a list of supported objects for each command. Supported objects
are also listed at the command line when you run the command.

Elevation Editor
Edits feature line elevations using the Elevation Editor. (page 818)
Quick Elevation Edit
Edits the elevations of a feature line by snapping to points that you can edit in the drawing. (page 819)
Edit Elevations
Edits feature-line or lot-line elevations, using the command line. (page 818)
Set Grade/Slope Between Points
Specifies the grade or slope between selected points on a feature line. (page 823)
Set Elevation By Reference
Sets the feature line elevation in relation to an existing elevation in the drawing. (page 824)
Insert Elevation Point
Inserts an elevation point (page 830)
Delete Elevation Point
Deletes elevation points. (page 832)
Insert High/Low Elevation Point
Inserts high or low elevation points into feature lines. (page 832)
Raise/Lower
Raises and lowers feature line elevations. (page 829)
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Elevations From Surface
Creates feature-line elevations from a surface. (page 833)
Insert PI
Inserts points of intersection. (page 834)
Delete PI
Deletes points of intersection. (page 836)
Set Elevation By Reference
Sets an elevation by referencing from a selected point. (page 824)
Raise/Lower Elevation By Reference
Raises or lower elevations by referencing a selected point. (page 826)
Adjacent Elevations By Reference
Sets elevations by referencing an adjacent feature line. (page 827)
Break
Breaks a feature line into two feature lines. (page 849)
Trim
Trims a feature line. (page 850)
Join
Joins multiple feature lines, creating a single object. (page 836)
Reverse
Reverses the direction of feature lines for stationing purposes. (page 837)
Fillet
Rounds the corners of feature lines. (page 841)
Fit Curve
Converts tessellated curves to true arcs for better grading results. (page 842)
Smooth
Smooths out jagged feature lines. (page 844)
Weed
Deletes vertices and elevation points from feature lines. (page 846)
Stepped Offset
Offsets feature lines at an elevational difference. (page 848)
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Feature Line Contextual Commands
Use these commands to create and edit feature line properties.
You can access these commands by selecting a feature line and then select Feature line tab ➤ Modify panel.
NOTE See Editing Feature Lines (page 816) for a list of supported objects for each command. Supported objects
are also listed at the command line when you run the command.

Feature Line Properties
Draws a feature line. (page 813)
Apply Feature Line Names
Applies optional names to feature lines. (page 811)
Apply Feature Lines Styles
Applies styles to feature lines. (page 811)
Remove Dynamic Links
Removes feature line dynamic links to alignments and corridors. (page 812)

Create Feature Lines Dialog Box
Use this dialog box to specify feature line settings when drawing a feature line or creating a feature line from
objects.
Site
Specifies the site in which to place the feature line. Select a site in the list or click
the drawing.

to select a site from

Name
Specifies the name of the feature line. To name the feature line, click on its default name and enter a new
name or use the naming template. Click
to open the Name Template Dialog Box (page 2022), where
you can modify the feature line naming template.
Feature line names are optional and can be used to name significant feature lines in the drawing. When
there are named feature lines you can select feature lines to edit by name from a list.
Style
When selected, specifies a feature line style. Select a style in the list. Click
to edit the style. Click
to preview the selected style. A style is optional for a feature line, but it provides useful display options
and allows you to control color, visibility, and other settings. A style is also used to set the control the
feature line split point resolution.
Layer
Opens the Object Layer dialog box, where you can specify the layer the feature line should be created on.
This layer cannot be specified if Use Selected Entity Layers is selected under Conversion Options.
Use Current Layer
Places the new feature lines on the current layer.
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Use Selected Entity Layer
Specifies the layer where the converted feature lines are placed.
■

Selected: Places feature lines on the same layer as the selected objects.
NOTE This can make it difficult to select the feature line if the Erase Existing Entities check box is cleared.

■

Cleared: Places the feature lines on the layer specified by the Layer setting above.

Conversion Options
Erase Existing Entities
Specifies whether the selected objects are erased when they are converted to feature lines.
■

Selected: Erases the selected objects from the drawing.

■

Cleared: Does not erase the selected objects.

Assign Elevations
Specifies whether to assign elevations to the entities being converted.
■

Selected: Click OK to open the Assign Elevations dialog box.

■

Cleared: The Assign Elevations dialog box is not opened.

Weed Points
Specifies whether the selected objects are weeded when they are converted to feature lines.
■

Selected: Click OK to open the Weed Vertices dialog box.

■

Cleared: The Weed Vertices dialog box is not opened.

Related procedures:
■

Creating Feature Lines (page 808)

■

Weeding Vertices (page 846)

Assign Elevations Dialog Box
Use this dialog box to assign elevations when creating feature lines from objects. You can access this dialog
from the Create Feature Lines dialog box.
These options override the elevations of the objects that you are converting to feature lines.
Elevation
Assigns a fixed elevation to the feature line.
From Gradings
Creates a temporary surface from selected gradings to compute the feature line elevation. This produces
the same result as selecting the grading group surface if you have not created a grading group surface.
From Surface
Assigns elevations to the feature line from a surface in the drawing.
Select Intermediate Grade Break Points
Inserts intermediate grade breaks when the entity crosses surface TIN lines, creating elevation points at
these locations.
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NOTE If no gradings exist in the current site, the From Gradings option is unavailable. If no surfaces exist in the
drawing, the From Surface option is unavailable.
Related procedures:
■

Assigning Elevations to a Feature Line During Creation (page 809)

Create Feature Line From Alignment Dialog Box
Use this dialog box to specify feature line settings when creating a feature line from an alignment.
Alignment
Displays the name of the source alignment.
Site
Specifies the site in which to place the feature line. Select a site in the list or click
the drawing.

to select a site in

NOTE The feature line can not be created in the same site as the alignment. If the alignment is in a site, that
site will not be available in the site list.
Name
Specifies the name of the feature line. Select the check box and click
to open the Name Template
dialog box. In addition to the style and counter properties, there are properties to include the alignment
and profile names in the feature line name.
Profile
Specifies a vertical alignment from which to acquire the elevations for the feature line. Click
to select
a profile in the drawing. If the alignment does not have a vertical alignment, you can create the feature
line only while the dynamic link option is disabled. For the dynamic link, a vertical alignment is required.
Mid-ordinate Distance
Sets the vertical curve tessellation factor.
Spiral Tessellation Factor
Sets the clothoid spiral tessellation factor.
Weed Points
Specifies whether to open the Weed Vertices dialog box so you can weed the objects when converting to
a feature line. Change this value to True to open the Weed Vertices dialog box.
Style
Select the check box and specify a feature line style in the list. Click
to edit the style. Click
to
preview the selected style. A style is optional for a feature line, but it provides useful display options,
allowing you to control color, visibility, and other settings.
Layer
Opens the Object Layer dialog box. Specify the layer on which the feature line should be created. This
layer cannot be specified if Use Selected Entity Layers is selected under Conversion Options.
Create Dynamic Link to the Alignment
Creates a dynamic link to the alignment so that the feature line updates dynamically with any changes
to the alignment or the selected vertical alignment. If the feature line is created with the dynamic link,
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the link can be disabled, using the Feature Line Properties (page 2132) dialog box. If the dynamic link is
disabled, it cannot be restored.
■

Selected: The feature line is linked to the alignment.

■

Cleared: The feature line is not linked to the alignment and can be edited with any of the feature line
editing commands.

Related procedures:
■

Creating Feature Lines (page 808)

■

Creating Feature Lines from Alignments (page 810)

Feature Line Properties Dialog Box
Information Tab (Feature Line Properties Dialog Box)
Use this dialog box to assign a style to a feature line or to change the style assigned to a feature line.
Name
■

Specifies that a name is applied to the feature line. Click

to edit the name template.

Style check box
■

Selected: Specifies that a style is applied to the feature line.

■

Cleared: Style selection options are not available.

Style
Specifies the style for the feature line.

Specifies the style options. You can create a new style, copy or edit the current style selection, or pick a
style from drawing.

Opens the Style Detail dialog box where you can preview the style and creation information.
NOTE To create a dynamic link, the alignment must have a profile. If the alignment does not have a profile, the
options for Dynamic Link, Mid-ordinate Distance, and Weed Points are not available.
Dynamic Link
■

Displays the name of the alignment and profile to which the feature line is linked. You can change
the profile that is used to set the elevations and the mid-ordinate distance can be changed.

Mid-ordinate Distance
Specifies the mid-ordinate distance for tessellating curves into short line segments. The default is 0.100.
Weed Points
Specifies whether to open the Weed Vertices dialog box so you can weed the objects when converting to
a feature line. Change this value to True to open the Weed Vertices dialog box.
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Related procedures:
■

Feature Line Properties (page 866)

Statistics Tab (Feature Line Properties Dialog Box)
This dialog box displays read-only feature line statistics.
Count
Displays the total number of points.
PI Points
Displays the total number of PI points.
Elevation Points
Displays the total number of intermediate elevation points.
2D Length
Displays the total 2D length.
3D Length
Displays the total 3D length.
Minimum Elevation
Displays the minimum elevation.
Maximum Elevation
Displays the maximum elevation.
Minimum Grade
Displays the minimum grade.
Maximum Grade
Displays the maximum grade.

Breakline Data
If the feature line is used by any surfaces as breakline data, the following list is displayed.
Surface
Displays the name of the surface.
Breakline Group
Displays the breakline group.
Related procedures:
■

Adding a Feature Line to a Surface as a Breakline (page 851)

Weed Vertices Dialog Box
Use this dialog box to specify settings for removing vertices and elevation points from feature lines, parcel
lines, and 2D or 3D polylines.

Weeding Factors
Select one or more weeding factor to apply. Larger values remove more points. If more than one factor is
specified, both factors have to be met before the point is selected for weeding.
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When you change a value, the display in the drawing is updated with red glyphs to show the points that
will be weeded.
Angle
Specifies the weeding angle.

weeding angle factor (plan view)

possible vertex to be
deleted

if angle < angle factor, then the vertex will be deleted

Grade
Specifies the weeding grade.

weeding grade factor (profile view)

G1 %
G2

%

possible vertex to be deleted

if the difference between G1 and G2 < grade factor,
then the vertex will be deleted

Length
Specifies the weeding distance. Enter the distance value or click

weeding length factor (plan view)
possible vertex to be deleted

L
if L < length factor, then the vertex will be deleted
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to select it in the drawing.

Close Point Removal
3D Distance
Specifies the 3D distance for weeding. Points that are close together in plan view, with slightly different
elevations can be weeded using this setting.

weeding 3D distance factor (profile view)

D

possible vertex to be deleted

if D is < 3D distance factor, then the vertex will be deleted

Related procedures:
■

Weeding Vertices (page 846)

Fit Curve Dialog Box
Use this dialog box to specify the tolerance and minimum number of segments for applying the Fit Curve
command.
Tolerance
Specifies the maximum distance from a PI along the feature to the arc that is to be inserted. When an arc
is inserted, it should pass through all the feature line points (between the start and end points). The
tolerance specifies how much any one point can be off of the arc that is averaged through all the points.
Fit Curve Tolerance

Minimum Number Of Segments
Specifies the minimum number of segments that must be identified before creating an arc. This setting
is ignored when the Points option is used.
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Related procedures:
■

Converting Tessellated Lines to Arcs (page 842)

Set Elevations From Surface Dialog Box
Use this dialog box to select the surface from which to obtain feature line elevations.
Surface Selection List
Select a surface in the list or click

to select it in the drawing.

Insert Intermediate Grade Break Points
Inserts an elevation point (page 2773) at each location where the feature line crosses a surface TIN line.
Related procedures:
■

Setting Feature Line Elevations from a Surface (page 833)

Feature Line Site Properties Dialog Box
Use this dialog box to view statistics about feature lines and to resolve split point elevations by specifying
style priority.

Statistics Tab (Feature Line Site Properties Dialog Box)
Use this tab to view the combined statistics for all feature lines in the site. This data cannot be edited.
Feature Lines
Displays the total number of feature lines.
PI Points
Displays the total point of intersection (PI) points.
Elevation Points
Displays the total elevation points.
2D Length
Displays the total 2D length.
3D Length
Displays the total 3D length.
Minimum Elevation
Displays the minimum elevation.
Maximum Elevation
Displays the maximum elevation.
Minimum Grade
Displays the total point of intersection (PI) points.
Maximum Grade
Displays the maximum grade.
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Grouped Statistics Tab (Feature Line Site Properties Dialog Box)
Use this tab to view the combined statistics for all feature lines in the site. This data cannot be edited.
The data is grouped in two list boxes allowing you to extract data based on layer and/or style. The following
information is listed for each style or layer.
Count
Displays the total number of feature lines.
2D Length
Displays the total 2D length.
3D Length
Displays the total 3D length.
Minimum Elevation
Displays the minimum elevation.
Maximum Elevation
Displays the maximum elevation.
Minimum Grade
Displays the total point of intersection (PI) points.
Maximum Grade
Displays the maximum grade.

Options Tab (Feature Line Site Properties Dialog Box)
Use this dialog box to determine feature line style priority.
When two feature lines with different styles intersect, the one with the higher set priority determines the
elevation. Feature lines without a style have the lowest priority. If two feature lines have the same style or
no style, then priority is given to the last edited feature line.
Feature Line Crossings: Split Point Resolution
Displays the feature line style priority from highest to lowest. You can drag and drop styles in the list or
use the up/down arrows to specify priority. When new styles are created, they are added to the end of the
list.
Filter Unused Styles
Filters out unused styles and displays styles referenced in the current site. You can edit the style priority
in the filtered state, but some styles may be hidden. You can move a style between two visible styles that
have been filtered. If the style moves to a lower priority, it is placed above the filtered styles immediately
following the style it was placed after. If the style was moved up, it is placed below the filtered styles,
immediately above the style it was moved ahead of.
Copy From Site
Selects a different site in the drawing in order to copy the style priority order. If there is only one site in
the drawing, this option is unavailable.
Apply to All Sites
Applies the current style priority order to all sites in the drawing. If there is only one site in the drawing,
this option is unavailable.
Save as Default
Sets the default command setting to the currently set priority.
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Apply Feature Line Names Dialog Box
Use this dialog box to edit the names for a selection set of feature lines.
Name
Toggles the feature line names on or off. If only a single feature line was edited, you can use the name
template, or type in a new name. Click
to access the Name Template Dialog Box (page 2022), where
you can modify the feature line naming template. If multiple feature lines are selected, use the name
template to apply unique names to the selection set. If you attempt to use a name template that does not
include the counter, an error message will display.
Related procedures:
■

Applying Feature Line Names (page 811)

Apply Feature Line Styles Dialog Box
Use this dialog box to specify a style for a selection set of feature lines.
Style List
Specifies the following options for style selection:
■

Create New

■

Copy Current Selection

■

Create Child of Current Selection (Labels only)

■

Edit Current Selection

■

Pick from Drawing

Specifies the style options. You can create a new style, copy or edit the current style selection, or pick a
style in the drawing.

Opens the Style Detail dialog box, where you can preview the style and creation information. You can
also use the checkbox to turn off styles for the selected feature lines.
Related procedures:
■

Applying Feature Line Styles (page 811)

Edit Feature Line Curve Dialog Box
Use this dialog box to edit the radius of a feature line (or survey figure) arc. You can also delete the arc from
the feature line.
These options override the elevations of the objects you are converting to feature lines.
Radius
Specifies the radius of the arc.
Length
Displays the length of the arc.
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Chord
Displays the length of the chord.
Tangent
Displays the length of the tangent.
Maintain Tangency
When the curve is not tangent, the Maintain Tangency button is activated. If you toggle this button the
curve will be adjusted, to making it tangent to the adjacent segments. If the curve is tangent, the button
is disabled.
Edit Previous Curve
Moves to the previous curve on the feature line. If the current curve has been edited it will be saved before
moving to the previous curve. If there is no previous curve, this option is disabled
Edit Next Curve
Moves to the next curve on the feature line. If the current curve has been edited, it will be saved before
moving to the next curve. If there is no following curve this option is disabled.
NOTE The left and right arrow keys can also be used to navigate the curves. You can edit the radius, then press
the arrow key to move without using the mouse.
Pick Curve Radius
Selects points in the drawing to specify the curve radius. If the radius is valid, the value appears in the
Radius edit box and the arc preview updates. If the radius is too large for the feature line, an error message
is displayed.
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The following topics provide information about the dialog boxes used to import and export data in HEC-RAS format.

Export To HEC RAS Dialog Box
Use this dialog box to specify the surface, alignment, and section data to export to HEC-RAS format for use
in flood analysis.
See Preparing Data to Export to HEC-RAS Format (page 1887) for information about the data you select in this
dialog box.
Exporting and Importing HEC-RAS Data (page 61)

Select Surface And Alignment
Surface
Specifies the surface that you want to sample for the stream sections.
Site
Specifies the site that contains the stream centerline alignment. Select <None> if the alignment is not
located in a site.
Reach Alignment
Specifies the stream centerline alignment to be exported.

Select Sections To Export
Sample Line Groups
Specifies the sample line group that was created along the stream centerline alignment.
River Name
Specifies the name that is used in the HEC-RAS application as the title of the GEO file and is used as a
label for the stream in the HEC-RAS Geometric Data window. This name should typically be the name of
the stream alignment.
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River Banks
Check This To Use River Banks
Exports either polylines or alignments as river bank information. Select the check box and then click Left
and/or Right, and select the polylines or alignments in the drawing.
NOTE The bank locations appear in the HEC-RAS application as red dots on the sections. The left and right
bank locations tell the HEC-RAS application where the Manning’s n values change for left, channel, and right
bank situations in the section. This effects the calculations and the level of water in the section. The Bank Positions
exported to the GEO file are measured as percentages of the overall section length rather than as offset distances.
Export
Exports the data to a GEO file that you can import into the HEC-RAS application. For more information,
see Importing To and Exporting From HEC-RAS Software (page 1889).
Related procedures:
■

Exporting Data to HEC-RAS Format (page 1888)

Import HEC RAS Dialog Box
Use this dialog box to import an SDF file that was exported from the HEC-RAS software program.
Exporting and Importing HEC-RAS Data (page 61)

Reach Alignment
Site For Reach Alignment
Specifies the site into which the stream alignment is imported.
NOTE The stream alignment is imported into the drawing only if an alignment of the same name does not
already exist in the site you specify. Existing alignments of the same name and site are not overwritten. LINE
objects that represent the sections are only imported if the alignment is imported.
Style For Reach Alignment
Specifies the style to use for the stream alignment when it is imported.
Alignment Label Style Set
Specifies the label set to use for the stream alignment when it is imported.
Profile Style
Specifies the profile style to use for imported profiles.
Profile Label Style Set
Specifies the label style set to use for imported profiles.

SDF To Import
File
Specifies the SDF file that was exported from the HEC-RAS software application. Click the browse button
to select the file. For more information, see Importing To and Exporting From HEC-RAS Software (page
1889).
Stream
Specifies which stream within the SDF file to import. When you select a stream, the number of profiles
and sections that exist for that stream are shown in the dialog box.
■

The profiles are imported as AutoCAD Civil 3D profile objects. You must create a profile view in the
drawing to view them. For more information, see Creating Profile Views (page 1208).
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NOTE Existing profiles of the same name inside the same alignment will be overwritten. This behavior
enables you to perform multiple iterations within the HEC-RAS application without having to manually delete
profiles in AutoCAD Civil 3D when you bring in updated data.
■

The section data is imported as LINE objects along the alignment. These lines show the top water
surface at each section. They are created on layers using the convention <alignment name> - <profile
name>. The section lines are imported only if the alignment is imported.

Import
Imports the specified SDF file.
Related procedures:
■

Importing Data from HEC-RAS (page 1889)
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Create Intersection Wizard
Use this wizard to create an intersection object after selecting the point where two alignments intersect.
This wizard quickly leads you through the process of creating an intersection. After selecting the point where
two alignments intersect, you can configure a variety of parameters related to the intersection using the
choices available on the wizard dialog boxes.
Reviewing and changing the settings on each wizard page is optional. From any page of the wizard, clicking
Create Intersection creates the intersection using the current values specified.
Before creating an intersection object, make sure you understand the necessary object and drawing data that
must exist. See Before You Begin (page 1591) for more information.
Once created, the intersection object is displayed in the drawing and in the Prospector tree. For information
about editing intersection objects, see Editing Intersections (page 1601).

General Page (Create Intersection Wizard)
Use this page of the wizard to specify general details for the intersection object, such as object name and
style.

Intersection Name
Enter a name for the intersection object, or accept the name specified by the default name template for
intersection objects. For more information, see Name Template dialog box (page 2022).

Description
Enter an optional description for this intersection object.

Intersection Marker Style
Style List
Displays the current style for intersection object markers. Click the arrow to display the intersection marker
styles in the drawing.
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Style Selection
Specifies the style options. Create a new style, copy or edit the current style selection, or pick a style from
the drawing.
Style Detail
Opens the Style Detail dialog box, where you can preview the style and creation information.

Intersection Marker Layer
Specifies the layer of the intersection object marker. Click
to open the Object Layer dialog box where
you can select a different layer for the intersection object marker.

Intersection Label Style
Style List
Displays the current style for intersection object labels. Click the arrow to display the intersection label
styles in the drawing. Note that there is no placement option available for an intersection label. The label
is always placed at the intersection point. If that point is already labeled, then a second label is placed on
top of the existing label.
Style Selection
Specifies the style options. Create a new style, copy or edit the current style selection, or pick a style from
the drawing.
Style Detail
Opens the Style Detail dialog box, where you can preview the style and creation information.

Intersection Corridor Type
Specifies how crowns will be maintained for this intersection. For more information, see Intersection Corridor
Type (page 1596)
Primary Road Crown Maintained
When this option is specified, the crown of the primary road is maintained, while the crown (profile) of
the secondary road is adjusted to match the edge of the primary road and the intersection point. The
crown (profile and edges) of the primary road are not affected. A conceptual graphic representing this
type of intersection is displayed on the wizard dialog box.

All Crowns Maintained
When this option is specified, the profile of the side road is adjusted to match the main road elevation
at the intersection point. The main road profile is not affected. The edges are blended together along the
curb returns (via the curb return profiles). A conceptual graphic representing this type of intersection is
displayed on the wizard dialog box.
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NOTE Once an intersection object is created, you cannot change the value of the intersection Corridor Type
property.
On this dialog box, you can click Next to move to the next wizard dialog box, Create Intersection to create
the intersection using the currently selected setting, or Cancel to cancel creating the intersection.

Geometry Details Page (Create Intersection Wizard)
Use this page of the wizard to specify a variety of details about the geometry of the intersection object.

Intersecting Alignments
Use this section to view information on the alignments included in this intersection. You can view the
alignment name, priority, the station where the intersection occurs, and the profile associated with the
alignment. If other profiles exist, you can select a different profile from the drop-down list.
Priority
The priority determines how profile locking occurs for the profiles associated with the intersection. You
can change the priority of an alignment (road) during intersection creation by selecting an alignment in
this list and using the arrows. It is important to note that when you do this, the associated profiles may
change. Once an intersection object is created, you cannot change the value of the priority property. See
Changing Road Priority (page 1595) for more information.

Offset and Curb Returns
Specifies information on the alignment offsets and curb returns for this intersection.
Create Or Specify Offset Alignments
When this option is selected, offset alignments will be created for the intersection. If you do not want
offset alignments included in the intersection, remove the check mark from this option. If you do not
select an existing alignment from the current drawing, then a new offset alignment object is created. To
select an existing offset alignment from the drawing, click the Offset Parameters button, set Use An Existing
Alignment to Yes, then select the alignment by clicking

next to the Alignment Name field.

Offset Parameters
Before deciding to create offset alignments, you can view or edit the parameters that will be used for
creating the offset alignments by clicking the Offset Parameters button. This displays the Intersection
Offset Parameters dialog box (page 2168) which lets you specify an existing alignment to use, or create a
new one according to the offset value you specify. For more information, see Editing Offsets in Intersections
(page 1607).
Create Curb Return Alignments
When this option is selected, curb return alignments will be created for the intersection. If you do not
want curb return alignments included in the intersection, remove the check mark from this option.
Curb Return Parameters
Before deciding to create curb returns, you can view or edit the parameters that will be used for creating
the curb returns by clicking the Curb Return Parameters button. This displays the Intersection Curb Return
Parameters dialog box (page 2166), which lets you specify the curb return type (chamfer, circular fillet, or
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3-centered arcs), and other details, such as radius for the curb return. For more information, see Editing
Curb Returns in Intersections (page 1609).

Offset and Curb Return Profiles
These options let you create offset and curb return profiles for this intersection. If the intersecting alignments
do not have profiles associated with them, these options are not available.
Create Offset and Curb Return Profiles
Selecting this option creates offset and curb return profiles for this intersection. This option is not available
when the intersecting alignments selected for this intersection do not have profiles associated with them.
Lane Slope Parameters
Clicking this button displays the Intersection Lane Slope Parameters dialog box where you can view or
edit the lane slopes for the roads included in the intersection object. This option is not available when
the intersecting alignments selected for this intersection do not have profiles associated with them.
Curb Return Profile Parameters
Clicking this button displays the Intersection Curb Return Profile Parameters dialog box where you can
view or edit the parameters for the curb return profile included in the intersection object. This option is
not available when the intersecting alignments selected for this intersection do not have profiles associated
with them.
On this dialog box, you can click Back to return to previous wizard dialog boxes, Next to move to the next
wizard dialog box, Create Intersection to create the intersection using the currently selected setting, or Cancel
to cancel creating the intersection.

Corridor Regions Page (Create Intersection Wizard)
Use this page of the wizard to specify details about the corridor regions included in the intersection object.

Create Corridors in the Intersection Area
When this option is selected, new corridor objects are created in the intersection area when the intersection
is created. When this option is not selected, the rest of the options on this page of the wizard are unavailable.
For more information, see Creating Corridors in the Intersection Area (page 1597).
Create a New Corridor
When this option is selected, a new corridor object will be created for this intersection.
Add to an Existing Corridor
When this option is selected, you can select an existing corridor to add to for this intersection. If you do
not have corridor objects in the drawing, this option is not available.
Select Surface to Daylight
Specifies a surface to use for daylighting. If you do not have surfaces in the drawing, this option is not
available. Also, you cannot target a surface that is an output of another corridor.

Select Assembly Set to Import
Specifies the assembly set to use for creating the intersection. If desired, you can choose a different assembly
set to import for use with creating this intersection. For more information, see Assembly Sets (page 1619).
Browse
Click this button to browse to a location for selecting an assembly set to use for creating this intersection.
Save As A Set
Saves the currently selected assembly set to an xml file. When you click this button, you are prompted
to choose a name and location for the assembly set.
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Corridor Region Section Type
Specifies the assembly that defines each section (component) in each corridor region included in the
intersection. Click the items listed in this section to display a conceptual graphic that updates with each
selection.
Assembly to Apply
Displays the name of the assembly that is specified (referenced) in the selected assembly set for each
component. If there are assemblies available in the current drawing, you can click
to select a different
assembly to apply. If you click an assembly in the list, the location where the assembly will be applied
along the intersection is highlighted in the conceptual graphic.
On this dialog box, you can click Back to return to previous wizard dialog boxes, Create Intersection to create
the intersection using the currently selected settings, or Cancel to cancel creating the intersection.
When you create an intersection object, the following objects are added to the current drawing:
■

intersection object

■

corridor(s)

■

assemblies

■

subassemblies

■

offset alignments

■

curb return alignments

Related procedures:
■

Creating Corridors in the Intersection Area (page 1597)

Create Roundabout - Circulatory Road Dialog Box
Use this dialog box to specify details for the circulatory road that comprises the center portion of the
roundabout.
This dialog box is the first in a series of four dialog boxes that step you through creating a roundabout.
For more information, see Creating Roundabouts (page 1631).

Roundabout Center Point
Specifies the X Y location of the center point of the roundabout. The location selected at the Specify
roundabout center point prompt is displayed. You can change these values using the X and Y value fields,
or by clicking the

and then selecting a location in the drawing.

Drawing Standard
Specifies the roundabout drawing standard used to create the roundabout. For more information, see
Roundabout Drawing Standards (page 1639).
Roundabout Design Standard File
Specifies the .xml file that is used to control some design and geometry aspects of this roundabout,
according to geographical or organizational standards. If the current drawing is imperial, then the default
location for this .xml file is the C:\Documents and Settings\All Users\Application Data\Autodesk\C3D
<version>\enu\Data\Corridor Design Standards\Imperial folder. If the current drawing is metric, the default
location for this .xml file is the C:\Documents and Settings\All Users\Application Data\Autodesk\C3D
<version>\enu\Data\Corridor Design Standards\Metric folder. A Roundabout Design Standard File .xml file
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can contain more than one design standard or roundabout types; for example, one .xml file could contain
a US standard, a Florida Standard, UK, France, and so on. The default roundabout design standard file is
named Autodesk Civil 3D (Imperial or Metric) Roundabouts Presets.xml.
Select Roundabout Standard
Because a roundabout design standard file can contain more than one design standard, or roundabout
types, you must use the Select Roundabout Standard option to select the desired roundabout design
standard to apply.

Predefined Parameters To Import
You can select a set of parameters from the dropdown list. As soon as you select a set of parameters, the
Roundabout Parameters and Markings Parameters are updated with the selected values. If desired, you can
change the value of any parameter.

To add a new set of parameters to the list, click

. The Preset - Add dialog box is displayed.

Enter a preset name for the new set of parameters, and then enter the values for all parameters. If you want
to edit existing sets of predefined parameters, select the preset that you want to edit from the list of presets
and click

. To delete a set of predefined parameters, select the preset that you want to delete and click

. You can only delete user-defined presets (ones that you or someone else has created). You cannot
delete the default presets. For more information, see Using Presets (page 1639).

Roundabout Parameters
These parameters specify the location and geometry of the central area components of the roundabout.
Hovering the cursor over these controls displays a conceptual illustration of the component or geometry
specified by that control on the right side of this dialog box. For more information, see Roundabout Parameters
(page 1630).
Outer Radius
Specifies the outer radius of the roundabout driving area.
Circulatory Road Width
When the US_Imperial roundabout drawing standard is selected, this parameter is displayed. It specifies
the width of the roundabout driving area. (French standard)– defines the inner radius of the roundabout
driving area (outer radius of the traversable strip).
Apron Width
When the US_Imperial roundabout drawing standard is selected, this parameter is displayed. It specifies
the apron strip width.
Inner Radius
When the French (SETRA) roundabout drawing standard is selected, this parameter is displayed. It specifies
the inner radius of the roundabout driving area (outer radius of the traversable strip).
Traversable Extra Width
When the French (SETRA) roundabout drawing standard is selected, this parameter is displayed. It specifies
an extra width for the traversable area of the central area.

Markings Parameters
These parameters specify the markings for the central area components of the roundabout.
Hovering the cursor over these controls displays a conceptual illustration of the component or geometry
specified by that control on the right side of this dialog box. For more information, see Roundabout Parameters
(page 1630).
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Outer Offset
Specifies the distance of the outer radius marking from the outer edge of a roundabout.
Number of Lanes To Mark
Specifies the number of driving lanes.
Inner Offset
Specifies the distance of the inner radius marking from traversable area of a roundabout.
Lane Marker Line Width
Specifies the width of the inner and outer radius marking.
Lane Marker Linetype
Specifies the marker line linetype.

Site
Specifies the site to which the roundabout will be added. Site also controls the site parameters of all approaches
connected to this roundabout.

Alignment Style
Specifies the alignment style from the list of styles available in the drawing.

Alignment Layer
Specifies the alignment layer from the list of layers available in the drawing.

Alignment Name Prefix
Displays the name of the alignment used to specify the central approach road. This name is used as a prefix
for the alignments that are generated by the roundabout creation. For the right edge alignment, the suffix
“_EDGE_RIGHT” will be added to the alignment name. For the left edge alignment, the suffix “_EDGE_LEFT”
will be added to this name.

Alignment Label Set
Specifies the alignment label set from the list of label sets available in the drawing.

Create Roundabout - Approach Roads Dialog Box
Use this dialog box to specify details for the approach roads that are connected to the roundabout.
This dialog box is the second in a series of four dialog boxes that step you through creating a roundabout.
For more information, see Adding Approach Roads (page 1632).

Approach Road Alignments Selected
The number of approach road alignments that are currently selected for creating this roundabout is displayed
at the top of this dialog box.
Previous\Next
Use these buttons to scroll through and specify parameters for each of the approach roads included in
this roundabout. If you want to apply the same parameters to all of the approach roads in the roundabout,
use the Apply To All button. If you want to apply different parameters for the approach roads, do not use
the Apply To All button.
The approach road alignments are named using a naming convention that identifies the direction of the
base alignment that was selected; for example, an “East to west approach” road contains “EW” in the
approach road alignment name (Approach_EW_). For more information, see Adding Approach Roads
(page 1632).
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Apply to All
Clicking this button applies the parameters that are currently specified on this dialog box to all of the
approach roads included in this roundabout.

Predefined Parameters To Import
You can select a set of parameters from the dropdown list. As soon as you select a set of parameters, the
Approach Road Parameters are updated with the selected values. If desired, you can change the value of any
parameter.

To add a new set of parameters to the list, click

. The Preset - Add dialog box is displayed.

Enter a preset name for the new set of parameters, and then enter the values for all parameters. If you want
to edit existing sets of predefined parameters, select the preset that you want to edit from the list of presets
and click

. To erase an existing set of predefined parameters, select the preset that you want to erase

from the list of presets and click

. For more information, see Using Presets (page 1639).

Default Connecting Radius
This radius is used in the case where the existing alignment does not run through the center of a roundabout.
In this case, an arc with that radius is inserted in a way that the central alignment runs directly to the center
of the roundabout. If the radius you chose does not fit the geometry, then the smallest radius possible is
used to satisfy the standard.

Approach Road Parameters
These parameters specify the geometry of the approach roads in the roundabout.
Hovering the cursor over these controls displays a conceptual illustration of the component or geometry
specified by that control on the right side of this dialog box. For more information, see Roundabout Parameters
(page 1630).
Exit Road Width
When the US_Imperial roundabout standard is selected, the exit road width is measured from the pavement
marking.
When the French (SETRA) standard is selected, the exit road width is the width of the exit lane at the
beginning of the exit radius.
Exit Radius
This parameter specifies the radius at the point where the left approach edge connects to the roundabout.
Exit Connecting Radius
When the French (SETRA) roundabout drawing standard is selected, this parameter specifies the radius at
the beginning of the approach. With this arc, the left approach edge is connected to the existing road.
Exit Lane Tip Width
When the French (SETRA) roundabout drawing standard is selected, this parameter specifies the width of
the exit lane at the end of the exit connecting radius.
Exit Flare Length
Specifies the length of the flare at the exit.
Exit Flare Type
When the US_Imperial roundabout drawing standard is selected, this parameter specifies the flare type
used at the exit. You can choose arc or line flare type.
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Road Width At Departure
When the US_Imperial roundabout drawing standard is selected, this parameter specifies the width of the
exit lane at the beginning of the flare.
When the French (SETRA) roundabout drawing standard is selected, this parameter specifies the width of
the exit lane at the end of the exit connecting radius.
Entry Road Width
Specifies the entry road width, measured from the pavement marking.
Entry Radius
Specifies the radius at the point where the right approach edge connects to the roundabout.
Entry Flare Length
Specifies the length of flare at entry.
Entry Flare Type
Specifies the type of flare used at the entry. You can choose arc or line flare type.
Road Width At Approach
Specifies the width of the entry lane at the beginning of flare.

Alignment Style
Specifies the alignment style from the list of styles available in the drawing.

Alignment Layer
Specifies the alignment layer from the list of layers available in the drawing.

Alignment Name Prefix
Displays the name of the alignment used to specify the central approach road. This name is used as a prefix
for the alignments that are generated by the roundabout creation. For the right edge alignment, the suffix
“_EDGE_RIGHT” will be added to the alignment name. For the left edge alignment, the suffix “_EDGE_LEFT”
will be added to this name.

Alignment Label Set
Specifies the alignment label set from the list of label sets available in the drawing.

Create Roundabout - Islands Dialog Box
Use this dialog box to specify details for the islands located in the approach roads of the roundabout.
This dialog box is the third in a series of four dialog boxes that step you through creating a roundabout. It
lets you configure geometry parameters for the construction triangle and splitter island in each approach
road of the roundabout.

Approach Road Alignments Selected
The number of approach road alignments that are currently selected for creating this roundabout is displayed
at the top of this dialog box.
Previous\Next
Use these buttons to scroll through and specify parameters for islands included in each of the approach
roads. If you want to apply the same parameters to all of the approach roads, use the Apply To All button.
If you want to apply different parameters for the approach roads, do not use the Apply To All button.
The approach road alignments are named using a naming convention that identifies the direction of the
base alignment that was selected; for example, an “East to west approach” road contains “EW” in the
approach road alignment name (Approach_EW_).
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Apply to All
Clicking this button applies the parameters that are currently specified on this dialog box to all of the
approach roads included in this roundabout.

Predefined Parameters To Import
You can select a set of parameters from the dropdown list. As soon as you select a set of parameters, the the
Entry, Exit, Construction Triangle and Splitter Island Parameters are updated with the selected values. If
desired, you can change the value of any parameter.
To add a new set of parameters to the list, click

. The Preset - Add dialog box is displayed.

Enter a preset name for the new set of parameters, and then enter the values for all parameters. If you want
to edit existing sets of predefined parameters, select the preset that you want to edit from the list of presets
and click

. To erase an existing set of predefined parameters, select the preset that you want to erase

from the list of presets and click

. For more information, see Using Presets (page 1639).

Construction Triangle Parameters
These parameters specify the geometry of the construction triangle in the islands included in the roundabout.
Hovering the cursor over these controls displays a conceptual illustration of the component or geometry
specified by that control on the right side of this dialog box. For more information, see Roundabout Parameters
(page 1630).
Length
Specifies the length of the construction triangle.
Base
Specifies the width of the construction triangle base.
Base Offset
When the French (SETRA) roundabout drawing standard is selected, this parameter is displayed to specify
the offset of the base from the central alignment. If your base offset is half of the base value, then the
central alignment will go through the midpoint of the construction triangle base.
Tip Offset
When the French (SETRA) roundabout drawing standard is selected, this parameter is displayed to specify
the offset of tip of the construction triangle from the central alignment. If you use the value “0”, then
the tip of the construction triangle will be exactly on the central alignment.

Splitter Island Parameters (US Imperial)
These parameters specify the geometry of the splitter island included in the roundabout.
These parameters are displayed only when the US_Imperial roundabout drawing standard is selected on the
Create Roundabout - Circulatory Road dialog box.
Hovering the cursor over these controls displays a conceptual illustration of the component or geometry
specified by that control on the right side of this dialog box. For more information, see Roundabout Parameters
(page 1630).
Provide Crosswalk (Length)
Selecting this option divides the splitter island to accommodate a crosswalk. When this option is selected,
the Length and Island Base Length parameters are displayed.
Length
When the Provide Crosswalk option is selected, the Length option are displayed. This specifies the length
of the crosswalk being added to the splitter island.

2154 | Chapter 59 Intersections and Roundabouts Dialog Boxes

Island Total Base
When the Provide Crosswalk option is selected, this option is displayed. It specifies the length of the
splitter island from the base to the crosswalk.
Island Total Length
Specifies the length of the splitter island from its tip to its base.
Rounding At Exit
Specifies the rounding of the splitter island at the exit.
Offset From Circle At Exit
Specifies the offset of the splitter island from the circulatory area at the exit.
Offset At Exit
Specifies the offset from the splitter island on the exit lane at the base of the construction triangle.
Offset At Departure
Specifies the offset from the splitter island on the exit lane at the tip of the construction triangle.
Rounding At Tip
Specifies the rounding of the splitter island at the tip.
Rounding At Entry
Specifies the rounding of the splitter island at the entry.
Offset From Circle At Entry
Specifies the offset of the splitter island from the circulatory area at the entry.
Offset At Entry
Specifies the offset from the splitter island on the entry lane at the base of the construction triangle.
Offset At Approach
Specifies the offset from the splitter island on the entry lane at the tip of the construction triangle.
Rounding At Crosswalk
Specifies the rounding of the splitter island at the crosswalk.

Splitter Island Parameters (French)
The following parameters are displayed when the French (SETRA) roundabout drawing standard is selected
on the Create Roundabout - Circulatory Road dialog box.
Radius At Curbs
Specifies the radius of the splitter island fillets at all three corners.
Base Offset
Specifies the offset of the splitter island to the base of the construction triangle.
Side Offset
Specifies the offset of the splitter island to the left and right side of the construction triangle.

Create Roundabout - Markings and Signs Dialog Box
Use this dialog box to specify details for the markings and signs located in the roundabout.
This dialog box is the fourth in a series of four dialog boxes that step you through creating a roundabout.
It lets you configure geometry parameters for the construction triangle and splitter island in each approach
road of the roundabout.
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Approach Road Alignments Selected
The number of approach road alignments that are currently selected for creating this roundabout is displayed
at the top of this dialog box.
Previous\Next
Use these buttons to scroll through and specify parameters for islands included in each of the approach
roads. If you want to apply the same parameters to all of the approach roads, use the Apply To All button.
If you want to apply different parameters for the approach roads, do not use the Apply To All button.
The approach road alignments are named using a naming convention that identifies the direction of the
base alignment that was selected; for example, an “East to west approach” road contains “EW” in the
approach road alignment name (Approach_EW_). For more information, see Adding Approach Roads
(page 1632).
Apply to All
Clicking this button applies the parameters that are currently specified on this dialog box to all of the
approach roads included in this roundabout.

Signs
These parameters specify which blocks should be inserted into the roundabout to represents signs in the
roundabout. To insert a sign, place a check mark in the Draw check box, then navigate to and select the
block by clicking the

button.

Sign
Lists the type of sign that will be inserted into the roundabout. You cannot change the sign types that
are listed on this dialog box (for example, AB3a, B21-1, and so on). However, you can specify any block
to be inserted for each sign type.
Draw
Place a check mark in this check box to add the sign to the roundabout. If you do not want the sign to
be added, clear this check box.
Name
Displays the name of the selected block representing a roundabout sign.
Block
Click to select a block for this sign.
Distance
For some sign types, you can specify a distance. This specifies where the sign will be inserted, relative to
the outer edge of the roundabout. This parameter specifies a point back from the yield line from where a
tangent is established to define where the driver’s line of sight will intersect with the central island.
Offset
Specifies the offset of the traffic sign insertion point relative to the edge of the roundabout. For example,
the offset of the B21-1 sign defines the distance of the sign from the central island. This allows the sign
to be placed in the driver’s line of sight.
This parameter is used along with the Distance parameter to control where the sign is placed.
Leader Length
Specifies the leader length for the sign. Set this parameter to zero if you want the sign to be inserted
without a leader.
Post Height
Specifies the height of the sign post. Set this parameter to zero if you want the sign to be inserted without
a post.
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Scale
Specifies the size of each traffic sign block. All default signs have a width of 1 unit. To insert a sign 0.6
units wide, enter a value of 0.6 in this field.

Pavement Markings
These parameters specify the pavement markings for the roundabout. You can add four different types of
pavement markings: Outer Edge, Island Edge, Central Line, and Yield Line. For each one, you can specify a
line type and marking width. All markings are created as AutoCAD polyline objects with a defined width
factor.
Outer Edge
Adds pavement markings to the outer edge of the roundabout.
Island Edge
Adds pavement markings to the edge of the island in the roundabout.
Central Line
Adds pavement markings to the central line in the roundabout.
Yield Line
Adds pavement markings to the yield line in the roundabout.
Draw
Adds or omits pavement markings for the selected roundabout component.
Linetype
Specifies the linetype of the pavement marking.
Width
Specifies the width of the pavement marking.

Island Tip Markings
These parameters specify markings for the tip of the island included in the roundabout.
You can include or omit island tip markings for roundabouts.
Draw
Select this option to add markings to the tip of the splitter island in the roundabout.
Offset
Specifies the offset location for the island tip marking.
Width
Specifies the width of the island tip marking.
Angle
Specifies the angle that the island tip marking is inserted.
Gap
Specifies the gap between where the crosswalk marking is inserted and where the island edge marking is
inserted.

Crosswalk Markings
These parameters specify markings for the crosswalk included in the roundabout.
You can include or omit crosswalk markings for the roundabout.
Entry
Specifies parameters for crosswalk markings at the roundabout’s entry (approach road) lanes.
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Exit
Specifies parameters for crosswalk markings at the roundabout’s exit lanes.
Draw
Adds or omits crosswalk markings at the roundabout’s entry (approach roads) and or exit lanes.
Distance
Specifies the distance of the crosswalk markings from the outer edge of the roundabout.
Length
Specifies the length of the crosswalk markings.
Width
Specifies the width of the crosswalk stripe.
Gap
Specifies the width between two crosswalk stripes.
Break At Entry\Exit Island Edge
Selecting this option breaks the island edge marking at the point where it would intersect the crosswalk
marking.
Gap
Specifies a gap that you can insert between the crosswalk marking and the island edge marking.
Click Back to move to the previous dialog box in this series of dialog boxes, Finish to execute the command
and create the roundabout, or Cancel to close the dialog box and cancel creating the roundabout.

Draw Slip Lane Dialog Box
Use this dialog box to specify details for adding a slip lane (or bypass lane) to a roundabout.
In some roundabouts, a slip lane can be added between an approach road and a departure road to reduce
the traffic moving through the circular area of the roundabout.
For more information, see Adding Slip Lanes (page 1633).

Slip Lane Parameters
These parameters specify the geometry of an optional slip lane that can be added to a roundabout.
To see a conceptual illustration of the parameter location, place your cursor in the entry field for the
parameter. The conceptual illustration is displayed in the dialog box.
Segmentation Line Length
To achieve the correct geometry in approaches with base alignments that are not straight, the deceleration
lane and taper are segmented. The default value of the segment length is 1 unit. Note that lower values
will improve accuracy, however reduce the speed of operation.
Lane Width
Specifies the width of the slip lane.
Length of Deceleration Lane
Specifies the length of first part of the slip lane where the vehicle will decelerate and bear onto the right
or left turning lane.
Radius
Specifies the radius of arc in the middle of the slip lane.
Length of Acceleration Lane
Specifies the length of the road where a vehicle will accelerate to merge into a main road.
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Taper Length
Specifies the length of the road where a vehicle will merge into a main road.

Draw Pavement Markings
Specifies pavement marking for slip lane components. You can specify a linetype, width, and an offset. If
you do not want pavement markings, clear the check mark from the Draw check box.
Outer Edge
Specifies the pavement markings for the outer edge of the slip lane.
Decelerating Transition Line
Specifies the pavement markings for the decelerating transition line of the slip lane.
Accelerating Transition Line
Specifies the pavement markings for the accelerating transition line of the slip lane.
Draw
Specifies whether or not to add (draw) the pavement markings.
Linetype
Specifies the linetype of the pavement markings.
Width
Specifies the width of the pavement markings.
Offset
Specifies an offset for the pavement markings.

Alignment Style
Specifies the alignment style from the list of styles available in the drawing.

Alignment Layer
Specifies the alignment layer from the list of layers available in the drawing.

Alignment Label Set
Specifies the alignment label set from the list of label sets available in the drawing.

Alignment Name Prefix
Displays the name of the alignment used to specify the central approach road. This name is used as a prefix
for the alignments that are generated by the roundabout creation. For the right edge alignment, the suffix
“_EDGE_RIGHT” will be added to the alignment name. For the left edge alignment, the suffix “_EDGE_LEFT”
will be added to this name.
Click OK to add the slip lane to the roundabout.

Edit Feature Settings - Intersections Dialog Box
Use this dialog box to view and change intersection-specific settings.
This topic documents settings in all intersection-related Edit Settings dialog boxes (drawing-level, feature-level,
and command-level).
■

Drawing-level ambient settings are identified by the

■

Intersection feature settings are listed after the General and Labeling property groups, and are identified
by the

drawing icon.

intersection icon.
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■

Intersection command settings are identified by the

command icon.

For general information about drawing, feature, and command settings and their interaction, see Working
with the Standard Settings Dialog Box Controls (page 78).
For information about drawing-level ambient settings, see Ambient Settings Tab (Drawing Settings Dialog
Box) (page 2078)

Assembly Insertion Defaults
NOTE This property group is displayed when accessing the settings from the CreateIntersection command.
Use these settings to specify the defaults assigned during intersection object creation. For more information,
see Changing Corridor Assembly Frequency (page 1613).
Frequency Along Tangents
Specifies the frequency to insert assemblies along tangent segments of the intersection area corridor
baseline.
Frequency Along Curves
Specifies the frequency to insert assemblies along curved segments of the intersection area corridor baseline.
Frequency Along Spirals
Specifies the frequency to insert assemblies along spiral segments of the intersection area corridor baseline.
Horizontal Geometry Points
Specifies whether to add assemblies at horizontal geometry points of the corridor baselines in the
intersection area.
Superelevation Critical Points
Specifies whether to add assemblies at superelevation critical points of the corridor baselines in the
intersection area.
Profile Geometry Points
Specifies whether to add assemblies at profile geometry points of the corridor baselines in the intersection
area.
Profile High Low Points
Specifies whether to add assemblies to the highest and lowest points of the profile to define intersection
corridor.
Frequency Along Profile Curves
Specifies the frequency that intersection object assemblies are inserted along curved segments of the
profile.

Intersection Options
NOTE This property group is displayed when accessing the settings from the CreateIntersection command.
Use these settings to specify the default styles assigned to intersection creation.
Intersection Type
Specifies the corridor grade option for the corridors created in the intersection area. Primary Road Crown
Maintained: When this option is selected, the primary road crown is maintained through the intersection.
All Crowns Maintained: When this option is selected, the crowns of both roads included in the intersection
are maintained through the intersection.
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Default Exit and Entry Length - Primary Road
Specifies the intersection extents along the primary road as it enters and exits the intersection. If the curb
returns are defined, then this parameter is not used, and instead the extents are calculated by the curb
return extents on either side of intersection.
Default Exit and Entry Length - Secondary Road
Specifies the intersection extents of the secondary road as it enters and exits the intersection. If the curb
returns are defined, then this parameter is not used, and instead the extents are calculated by the curb
return extents on either side of intersection.
Create Curb Return Alignments
Specifies whether to create curb return alignments.
Create Curb Return Profiles
Specifies whether to create curb return profiles.
Create Intersection Corridors
Specifies whether to create intersection corridors.

Default Offsets
NOTE This property group is displayed when accessing the settings from the CreateIntersection command.
Use these settings to specify the default styles assigned to intersection creation.
Primary Road - Left Offset
Specifies the offset distance from the centerline on the left side of the primary road.
Primary Road - Right Offset
Specifies the offset distance from the centerline on the right side of the primary road.
Secondary Road - Left Offset
Specifies the offset distance from the centerline on the left side of the secondary road.
Secondary Road - Right Offset
Specifies the offset distance from the centerline on the right side of the secondary road.
Offset Length Options
Specifies how the length of the offset alignment is determined. When To Intersection Extents is selected,
offset alignments are extended to the length of the extent of the intersection object. When Alignment
Start To End is selected, offset alignments are created the length of the parent alignment.

Default Cross Slopes
NOTE This property group is displayed when accessing the settings from the CreateIntersection command.
Use these settings to specify the default styles assigned to intersection creation.
Primary Road - Left Cross Slope
Specifies the cross slope of the left side of the primary road.
Primary Road - Right Cross Slope
Specifies the cross slope of the right side of the primary road.
Secondary Road - Left Cross Slope
Specifies the cross slope of the left side of the secondary road.
Secondary Road - Right Cross Slope
Specifies the cross slope of the right side of the secondary road.
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Curb Return Parameters
NOTE This property group is displayed when accessing the settings from the CreateIntersection command.
Use these settings to specify the default styles assigned to intersection creation.
Curb Return Type
Specifies the type of curb return used for the intersection: Chamfer, Circular Fillet, or 3-Centered Arcs.
Circular Fillet Radius
When Circular Fillet is selected as the curb return type, this option lets you specify the radius for the
circular fillet on the curb return.
Radius of Curve (X)
When 3-Centered Arcs is selected as the curb return type, this option lets you specify the radius for each
of the three curves on the curb return.
Length of Curve (X)
When 3-Centered Arcs is selected as the curb return type, this option lets you specify the length for the
first and third curves on the curb return.
Chamfer Fillet Length - Along Incoming\Outgoing Lane
When Chamfer is selected as the curb return type, this option lets you specify the length of the curb
return’s chamfer fillet along the incoming or outgoing lane.

Default Widening Parameters
NOTE This property group is displayed when accessing the settings from the CreateIntersection command.
Use these settings to specify the default styles assigned to intersection creation. For more information, see
Widenings (page 964), or Editing Offset Alignments and Widenings (page 1077).
Widening At Incoming Lane
Specifies whether to widen the incoming lane as it enters the intersection.
Widening At Outgoing Lane
Specifies whether to widen the outgoing lane as it exits the intersection.
Widened Offset
Specifies the offset distance applied to the widened regions, at both the entrance to the intersection, and
as it exits the intersection.
Widening Segment Length
Specifies the length of the widened portion of the curb return at both the entrance to the intersection,
and as it exits the intersection.
Transition Type
Specifies the type of transition used for the widening: Linear, Curve-Line-Curve, Curve-Curve -Reverse
Curve, or Curve - Reverse Curve.
Linear Transition Type
When Linear is selected as the Transition Type, this option lets you specify the type of linear transition
used for the widening: By Length or By Taper Ratio.
Transition Length
When By Length is selected as the Linear Transition Type, this option lets you specify the length of the
transition for the widening.
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Taper Ratio
When By Taper Ratio is selected as the Linear Transition Type, this option lets you specify the ratio of the
tapering for the widening.
Radius of Curve X
When a curve option is selected as the Transition Type, this option lets you specify the radius for the first
and second curves used in the widening.
Radius of Reverse Curve
When Curve-Curve - Reverse Curve is selected as the Transition Type, this option lets you specify the
radius for the first and second curves used in the widening.

Secondary Road Profile Rules
NOTE This property group is displayed when accessing the settings from the CreateIntersection command.
Use these settings to specify the default styles assigned to intersection creation.
Apply Grade Rules
Specifies whether to apply grade rules.
Maximum Grade
Specifies the maximum grade that can be used in the profile for the secondary road.
Maximum Grade Change
Specifies the maximum grade change that can be used in the profile for the secondary road.
Distance Rule to Adjust the Grade
Specifies the method that is used to adjust the grade of the secondary road profile. When To Intersection
Extents is selected, the grade of the secondary road profile is adjusted to within the extents of the
intersection object. When Specify Distance is used, the grade of the secondary road profile is adjusted by
the value that is entered in the Distance Value.
Distance Value
Specifies the distance that is used to adjust the incoming and outgoing grade along the secondary road
profile when Specify Distance is selected for Distance Rule to Adjust the Grade.

Curb Return Profile Rules
NOTE This property group is displayed when accessing the settings from the CreateIntersection command.
Use these settings to specify the default styles assigned to intersection creation.
Define Curb Return Profile By
Specifies the method that is used to define the curb return profile.
Extend Profile Along Incoming Lane
Specifies whether to extend the curb return profile along the incoming lane of the intersection.
Length To Extend Along Incoming Lane
When Extend Profile Along Incoming Lane is set to Yes, this option lets you specify the length to extend
the curb return profile along the incoming lane of the intersection.
Extend Profile Along Outgoing Lane
Specifies whether to extend the curb return profile along the outgoing lane of the intersection.
Length To Extend Along Outgoing Lane
When Extend Profile Along Incoming Lane is set to Yes, this option lets you specify the length to extend
the curb return profile along the outgoing lane of the intersection.
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Default Styles
Use these settings to specify the default styles assigned to intersection object components.
Intersection Style
Specifies the default style for intersections. Click in the Value column, and click
Intersection Style dialog box.

to select a style in the

Intersection Label Style
Specifies the default style for intersection object labels. Click in the Value column, and click
to select
a label style. Note that there is no placement option available for an intersection label. The label is always
placed at the intersection point. If that point is already labeled, then a second label is placed on top of
the existing label.
Offset Alignment Style
Specifies the default style for offset alignments. Click in the Value column, and click
in the Offset Alignment Style dialog box.

to select a style

Curb Return Alignment Style
Specifies the default style for curb return alignments. Click in the Value column, and click
style in the Curb Return Alignment Style dialog box.

to select a

Offset Profile Style
Specifies the default style for offset profiles. Click in the Value column, and click
the Offset Profile Style dialog box.

to select a style in

Curb Return Profile Style
Specifies the default style for curb return profiles. Click in the Value column, and click
in the Curb Return Profile Style dialog box.

to select a style

Offset Alignment Label Set
Specifies the default style for offset alignment label sets. Click in the Value column, and click
a style in the Offset Alignment Label Set dialog box.

to select

Curb Return Alignment Label Set
Specifies the default style for curb return alignment label sets. Click in the Value column, and click
select a style in the Curb Return Alignment Label Set dialog box.

to

For general information about style selection, see Select Style Dialog Box (page 2021).

Default Name Format
Use these settings to specify the default name templates used for the following components associated with
an intersection object:
■

intersection object

■

intersection quadrant

■

offset alignment

■

curb return alignment

■

offset profile

■

curb return profile
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■

corridor region

Click in the Value column, and click

to select a style in the Name Template dialog box (page 2022).

Intersection Corridor Regions Dialog Box
Use this dialog box to view and edit the parameters of the corridor regions included in the intersection
object.
NOTE If you have made any changes to the corridor in the intersection area, those changes will be lost (overwritten)
when you apply new assemblies by clicking Recreate on this dialog box.
For more information, see Creating Corridors in the Intersection Area (page 1597).
Create a New Corridor
Specifies to create a new corridor object to the intersection object.
Add to an Existing Corridor
Specifies to add regions to a corridor object that already exists in the intersection object. If you do not
have corridor objects in the intersection drawing, this option is not available.
Select Surface to Daylight
Specifies a surface for daylighting. If there are other available surfaces in the current drawing, you can
select a different surface to use for daylighting. If you do not have surfaces in the drawing, this option is
not available.

Apply an Assembly Set
Specifies an assembly set file that specifies the assemblies used to create the intersection corridors. For more
information, see Assembly Sets (page 1619).
Browse
Click this button to browse to and select a new assembly set file.

Corridor Region Section Type
Expand the items in this column to display the assemblies that define each section of the corridor region.
The left column (Corridor Region Section Type) displays the names of the required sections of the corridor,
and is not editable. The right column (Assembly To Apply), displays the names of the assemblies that are
currently specified, and you can select different assemblies to apply, if desired.
Assembly to Apply
Displays the names of the assembly that is applied for each section of the corridor region. When you click
an assembly in this list, the conceptual graphic on this dialog box displays the location where the assembly
is applied in the intersection corridor.
Save As A Set
If desired, you can save the set of assemblies currently displayed on this dialog to a new or existing assembly
set. For more information, see Assembly Sets (page 1619).
Related procedures:
■

Updating Corridor Regions in Intersections (page 1614)

■

Recreating Corridor Regions in Intersections (page 1615)
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Intersection Curb Return Parameters Dialog Box
Use this dialog box to view and edit the parameters of the curb returns included in the intersection object.
When you select a property item on this dialog box, the affected object, or area of the intersection is
highlighted in the drawing, and the conceptual graphic on the dialog box updates to indicate the location
affected by the edit. For more information, see Intersection Editing Visual Cues (page 1605).

Previous and Next Buttons
The Previous and Next buttons let you select each of the quadrants in the intersection sequentially. The
currently selected quadrant is highlighted in the drawing.

Intersection Quadrant
This drop-down list lets you select each of the quadrants in the intersection.

Expand and Collapse Buttons
Click the expand
and collapse
displayed in this dialog box.

buttons at the top right to expand and collapse the property information

Widen Turn Lane For Incoming or Outgoing Road
When you select either of these options, the incoming or outgoing road in the intersection is widened.

Intersection Quadrant Details
Specifies details for the quadrants in the intersection.
Intersection Quadrant Name
Displays the name of the intersection quadrant currently selected. You can change the name here, if
desired.
Incoming Road Centerline Name
Displays the name of the centerline alignment for the incoming road.
Outgoing Road Centerline Name
Displays the name of the centerline alignment for the outgoing road.
Intersection Quadrant Angle
Specifies the angle in degrees that is created by the two alignments that intersect, forming this intersection
quadrant.

Curb Return Parameters
Specifies parameters for the curb returns in the intersection.
Curb Return Type
Specifies the type of curb return: chamfer, circular fillet, or 3-centered arcs.
Radius
If the radius type is circular fillet or 3-centered arc, you can specify radius parameters.
Length Along Incoming or Outgoing Road
Specifies the length of the curb return for the incoming or outgoing road.
Curve (X) Radius
Specifies the radius for the curves in the curb return.
Curve (X) Length
Specifies the length for each curved section in the curb return.
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Copy These To All Quadrants
On this dialog box, you can right-click the “Curb Return Parameters” node in the Property column, and
select Copy These To All Quadrants. When this option is selected, the curb return parameters currently
selected are automatically applied to all quadrants in the intersection.

Widening At Incoming\Outgoing Lane
When widening options at the top of this dialog box are selected, you can specify details for the widening
at the incoming and outgoing lanes in the intersection.
Transition Details
Specifies the transition details for the incoming or outgoing lanes in the intersection.
Widening Details
Specifies the widening details for the incoming or outgoing lanes in the intersection.
Related procedures:
■

Editing Curb Returns in Intersections (page 1609)

Intersection Curb Return Profile Parameters Dialog Box
Use this dialog box to view and edit the parameters of the curb returns included in the intersection object.
Click the expand
and collapse
displayed in this dialog box.

buttons at the top right to expand and collapse the information

When you select an item on this dialog box, the affected object is highlighted in the drawing, and the
conceptual graphic on the dialog box updates to indicate the location affected by the edit. For more
information, see Intersection Editing Visual Cues (page 1605).

Intersection Quadrant
This drop-down list lets you specify each quadrant in the intersection. You can also click Next and Previous
to advance through the quadrants.

Incoming\Outoging Lane Details
Specifies curb return profile details for the incoming and outgoing lanes.
Incoming or Outgoing Road Centerline Name
Displays the name of the centerline alignment for the incoming and outgoing road.
Side
Displays which side of the road this profile reflects.

Curb Return Profile Parameters
Use these settings to view or change the parameters of the curb return profiles included in the intersection
creation.
Define Curb Return Profile By
Displays the method that was used to define the curb return profile. For Civil 3D version 2010, the only
supported method for defining curb return profiles is by joining tangents.
Extend Profile Along Incoming Lane
Specifies whether to extend the curb return profile along the incoming lane of the intersection.
Length To Extend Along Incoming Lane
When Extend Profile Along Incoming Lane is set to Yes, this option lets you specify the length to extend
the curb return profile along the incoming lane of the intersection.
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Extend Profile Along Outgoing Lane
Specifies whether to extend the curb return profile along the outgoing lane of the intersection.
Length To Extend Along Outgoing Lane
When Extend Profile Along Incoming Lane is set to Yes, this option lets you specify the length to extend
the curb return profile along the outgoing lane of the intersection.
Related procedures:
■

Editing Curb Return Profiles for Intersections (page 1612)

Intersection Lane Slope Parameters Dialog Box
Use this dialog box to view and edit the parameters of the lane slopes for the roads included in the intersection
object.
Click the expand
and collapse
displayed in this dialog box.

buttons at the top right to expand and collapse the information

When you select an item on this dialog box, the affected object is highlighted in the drawing, and the
conceptual graphic on the dialog box updates to indicate the location affected by the edit. For more
information, see Intersection Editing Visual Cues (page 1605).

Left or Right Edge Profile Definition
Specifies the parameters defining the left and right edge of the slope.
Use an Existing Profile
When Yes is selected, you can select a profile from the available profiles in the current drawing. When
No is selected, this indicates that the profile was created during intersection creation.
Cross Fall From Centerline
Specifies the slope of the grade from the centerline.
Profile Name
Displays the name of the profile associated with this edge profile definition. When Use An Existing Profile
is set to Yes, you can select a new profile from available profiles in the current drawing.
Related procedures:
■

Editing Lane Slopes for Intersections (page 1611)

Intersection Offset Parameters Dialog Box
Use this dialog box to view and edit the parameters of the offset alignments included in the intersection
object.
Click the expand
and collapse
displayed in this dialog box.

buttons at the top right to expand and collapse the information

You can select offset alignments for the primary or secondary road in the intersection.
When you select an item on this dialog box, the affected object is highlighted in the drawing, and the
conceptual graphic on the dialog box updates to indicate the location affected by the edit. For more
information, see Intersection Editing Visual Cues (page 1605).
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Left or Right Offset Alignment Definition
Specifies the definitions of the offset alignments included in the intersection.
Use an Existing Alignment
When No is specified, the offset alignment is created during intersection object creation. When Yes is
specified, an existing alignment from the current drawing can be used to create the left and right alignment
offsets.
Offset Value
Specifies the offset distance for the offset alignment. This property is automatically set to Varies if an
alignment is selected that is not a dynamic offset alignment based on a centerline.
Alignment Name
Displays the name of the offset alignment currently specified. When Use an Existing Alignment is set to
Yes, you can click
to specify another alignment from the current drawing. When you do this, the
Offset Value property is automatically set to Varies, if the selected alignment is not a dynamic offset
alignment based on a centerline. It is also important to note that if you do select another offset alignment
from the drawing, the original offset alignment that was created during intersection object creation is not
deleted.
Related procedures:
■

Editing Offsets in Intersections (page 1607)

■

Widenings (page 964)

■

Editing Offset Alignments and Widenings (page 1077)

Intersection Properties Dialog Box
Use this dialog box to view the properties of an intersection object, such as the object name, description,
and style.
The Intersection Properties dialog box also lists details about the intersecting alignments and the corridor
regions included in the intersection.
See also:
■

Editing Intersection Properties (page 1603)

Information Tab (Intersection Properties Dialog Box)
Use this tab to view or change general information for the intersection object.
Name
Specifies the name of the current intersection object.
Description
Specifies an optional description for the current intersection.
Object Style
Specifies the default style used to display intersections. Select a style in the list or use the standard style
selection tools. For more information about the standard style selection tools, see the Select Style (page
2021) dialog box.
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Show Tooltips
Specifies whether tooltips are displayed for the object in the drawing (not over toolbar icons).

Intersection Details Tab (Intersection Properties Dialog Box)
Use this tab to view or change the parameters of the current intersection object.
Alignments Details
This section displays information about the intersecting alignments in the intersection object. It displays
the names of the intersecting alignments, the station of the point of intersection, and the profile associated
with each alignment. If there are multiple profiles available, you can change the profile associated with
the alignment by clicking in the Profile cell selecting a new profile from the drop-down list, and clicking
Apply.
Intersection Quadrants
In this section, you can click Previous and Next to advance through the quadrants in this intersection.
For each quadrant, the names of the incoming and outgoing alignments, as well as the intersection angle,
are displayed. Most of this information is read-only, however you can change the name of the intersection
quadrant if desired.

Intersection Style Dialog Box
Use this dialog box to make it easier to locate and work with intersection objects by changing their display.
The intersection style controls the appearance of intersection objects.
See also:
■

Intersection Styles and Display (page 1588)

Information Tab (Intersection Style Dialog Box)
Use this tab to change the intersection style name and description information, and to review details about
the style, such as when it was most recently modified.
For more information, see Information Tab (Style Dialog Box) (page 2017).

Marker Tab (Intersection Style Dialog Box)
Use this tab to specify the appearance of the marker that is used for intersection objects in the drawing.

Use AutoCAD POINT For Marker
Specifies that the assembly component is displayed using the current AutoCAD point symbol, which is
specified by the AutoCAD PDMODE and PDSIZE system variables.

Use Custom Marker
When this is selected, the specified symbol is used to display the intersection object in the drawing.
Custom Marker Style
Specifies the symbol that is used to display the marker for the intersection object. Click one of the five
symbols to the left to use as a base symbol. Optionally, click the sixth symbol, the seventh symbol, or
both, to superimpose them over the base symbol.
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Use AutoCAD Block Symbol For Marker
When this is selected, intersection objects are displayed in the drawing using a reference to the selected
AutoCAD block. The block is scaled using the options specified in the Size section of this dialog box.
The list displays block definitions available in the drawing. Do one of the following:
■

Click a block name to select the block to be used for the assembly symbol.

■

Right-click in the block list window and click Browse to select a block located in another folder.

The specified block is displayed in the Preview window.

Marker Rotation Angle
Specifies the rotation angle for the symbol. Applies to all three symbol types (AutoCAD Point, Custom
Marker, and AutoCAD Block). Enter a value or click

to specify an angle.

Size
Options
Specifies symbol scaling:
■

Use Drawing Scale: Determines size of the marker by multiplying the specified value by the drawing
scale. Enter the scale factor.

■

Use Fixed Scale: Activates the Fixed Scale options.

■

Use Size in Absolute Units: Specifies that the marker size is an absolute value based on the displayed
units. Enter the value.

■

Use Size Relative to Screen: Specifies that the size of the marker is a percentage of the drawing screen
size. Enter the percentage.

Fixed Scale
Specifies independent fixed scale values when Options is set to Use Fixed Scale. Enter values for X, Y, or
Z.

Orient Marker To World Coordinates
Specifies that the maker rotation angle is relative to the world coordinate system.

Orient Marker To View
Specifies that the maker rotation angle is relative to the current AutoCAD view direction.

Display Tab (Intersection Style Dialog Box)
Use this tab to change the display and visibility of intersection objects.

View Direction
Some object styles can have unique display values and varying numbers of displayed components, depending
on whether they are being displayed in Plan, Profile, Section, or Model views. You can create and set style
characteristics for each supported view direction type using the View Direction list.
Intersection objects support display styles in plan and model view.
Plan and Model
Select Plan or Model to specify display style settings when the intersection object is displayed in plan or
model view.
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Component Display
Marker
This is the closed polyline entity that represents the extents of an intersection object. You can set the
following style characteristics for this component: Visibility, Layer, Color, Linetype, LT Scale, Lineweight
and Plot Style.
For more information, see Display Tab (Style Dialog Box) (page 2017).

Summary Tab (Intersection Style Dialog Box)
Use this tab to review general the information about the current intersection object style.
You can copy and paste this information to the clipboard. For more information, see Summary Tab (Style
Dialog Box) (page 2020).

Preset - Add Dialog Box
Use this dialog box to configure and add presets to a roundabout during roundabout creation or editing.
This dialog box is displayed when you want to add presets to a new roundabout during roundabout creation,
or to an existing roundabout, while using the Edit Roundabout command. For more information, see Using
Presets (page 1639).
You can create and apply a set of presets that define the following roundabout components. The presets are
stored in an .xml file located by default in C:\Documents and Settings\All Users\Application Data\Autodesk\C3D
<version>\enu\Data\Corridor Design Standards\Imperial or Metric.

Preset Name
Specifies the name of the preset. Type in a unique name to identify a particular set of roundabout parameter
presets.

Roundabout Parameters
These parameters specify the geometry of the roundabout circular area.
Outer Radius
Specifies the outer radius of the roundabout driving area.
Circulatory Road Width
When the US_Imperial roundabout drawing standard is selected, this parameter is displayed. It specifies
the width of the roundabout driving area. (French standard)– defines the inner radius of the roundabout
driving area (outer radius of the traversable strip).
Apron Width
When the US_Imperial roundabout drawing standard is selected, this parameter is displayed. It specifies
the apron strip width.

Markings Parameters
These parameters specify the geometry and design of the roundabout markings.
Outer Offset
Specifies the distance of the outer radius marking from the outer edge of a roundabout.
Number of Lanes To Mark
Specifies the number of driving lanes.
Inner Offset
Specifies the distance of the inner radius marking from traversable area of a roundabout.
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Lane Marker Line Width
Specifies the width of the inner and outer radius marking.
Lane Marker Linetype
Specifies the marker line linetype.
Click OK to apply the specified parameters, or Cancel to close the dialog box and return to the Create
Roundabout - Circulatory Road dialog box.

Secondary Road Profile Rules Dialog Box
Use this dialog box to view and edit the parameters of the profile for the secondary roads included in the
intersection object.
Click the expand
and collapse
displayed in this dialog box.

buttons at the top right to expand and collapse the information

When you select an item on this dialog box, the affected object is highlighted in the drawing, and the
conceptual graphic on the dialog box updates to indicate the location affected by the edit. For more
information, see Intersection Editing Visual Cues (page 1605).

Secondary Road Profile Rules
Apply Grade Rules
Specifies whether to apply grade rules for this secondary road profile.
Maximum Grade
Specifies the maximum grade that can be used for the secondary road profile in the intersection.
Maximum Grade Change
Specifies the maximum grade change that can be used to adjust the secondary road profile in the
intersection.
Distance Rule to Adjust the Grade
Specifies to adjust the grade of the secondary road profile within the intersection extents, or by specifying
a distance.
Distance Value
When Distance Rule to Adjust the Grade option is set to Specify Distance, this specifies the distance value
used to adjust the incoming and outgoing grade of the secondary road profile in the intersection.
Related procedures:
■

Editing Side Road Profiles for Intersections (page 1610)
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2174

Label Dialog Boxes

60

Use the following links to access information about Label dialog boxes.

Standard Edit Label Style Defaults Dialog Box
The same standard settings are available in each of the Edit Label Style Defaults dialog boxes. See The
Hierarchy of Label Settings (page 1648) for information about how each level of setting affects the others.

Label
Text Style
Specifies a default text style for all label text components in a drawing. The default is Standard.
Select a text style from the list of all AutoCAD text styles defined in the current drawing.
Visibility
Specifies whether all label styles in a drawing are visible.
TIP Use this setting to quickly turn all labels in the drawing off or on.
Layer
Specifies the default layer for all label styles in a drawing.
The default layer is 0. When the layer is set to 0, the labels use the properties of the parent object layer
specified on the Object Layers tab of the Drawing Settings dialog box.
Click

to display the Layer Selection dialog box.

NOTE This setting specifies the layer from which the labels obtain their display properties. The labels are drawn
on the parent object layer.

Behavior
Orientation Reference
Specifies the orientation reference of the labels.
■

Object: Rotates labels relative to the zero direction of the object. You can determine the zero direction
of the object based on its start and end points. If the object vector changes at the anchor point on the
label, the orientation updates automatically. This is the default setting.

■

View: Forces labels to realign to a screen-view orientation in both model and layout views. Always
assumes the zero angle is horizontal, regardless of UCS or Dview twist. If the view changes, the label
orientation updates with it.
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■

World Coordinate System: Adjusts the labels with respect to the angle between the current view and
world view. Changing the view or current UCS does not affect label rotation with respect to the world
coordinate system.

For more information, see Changing Label Orientation (page 1667).
Forced Insertion
Specifies the position of a label relative to an object. Applies only when the Orientation Reference option
is set to Object and the objects are lines, arc segments, or spline segments.
■

None: Maintains label position as composed relative to the object. This is the default setting.

■

Top: Adjusts label position to above an object.

■

Bottom: Adjusts label position to below an object.

NOTE Plan Readable should be set to True when using the Top or Bottom settings.
Force Inside Curve
Specifies whether labels are placed inside or outside a curve. Available only for curve label styles. This
setting has precedence over any forced insertion setting.
■

None: Leaves the components as composed.

■

Inside : Moves label components on the outside of curve to the inside of curve. The components
maintain the same offset and rotation.

■

Outside : Moves label components on the inside of curve to the outside of curve. The components
maintain the same offset and rotation.

NOTE These settings apply only when the Orientation Reference option is set to Object.

Plan Readability
Plan Readable
Specifies the text rotation to insure that all text components in labels can be read easily in plan view.
■

True: Rotates text to insure that it can be read easily in plan view or as if viewed from an angle at the
bottom or right side of the screen/paper. This is the default setting.
Any text with an angle greater than the angle specified in the Readability Bias setting, or with an angle
less than the Readability Bias plus 180 degrees, is in violation of plan readability, and is adjusted
automatically.
For more information about plan-readable text, see Using Plan-Readability (page 1668).

■

False: Displays text as inserted.

This option applies only to text components in labels.
Readability Bias
Specifies the angle at which label text flips 180 degrees to remain plan readable.
Flip Anchors With Text
■

True: Ensures that if text is rotated to make plan-readable, the anchors will also be flipped.

■

False: The flipped label always looks like a mirror of the original.
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Components
Text Height
Specifies the plotted height for label text. Enter a positive value greater than zero. The value is applied to
all text components.
Color
Specifies the color for label components. Click

to open the Select Color dialog box.

Linetype
Specifies the linetype for label components. Click

to open the Select Linetype dialog box.

Lineweight
Specifies the lineweight for label components. Click

to open the Lineweight dialog box.

Span Outside Segments
Specifies whether the label style component should span outside segments.
NOTE This setting applies to parcel line and curve label styles only).
■

True: Labels the outer boundary of parcels, rather than the individual parcel segments. For example,
if four parcels share an outer boundary, use this option to label the combined outer boundary.

■

False: Labels individual parcel segments.

Leader
Arrow Head Style
Specifies an arrow head style for a leader.
Select an arrow head style from the list. Or, select None to display leaders without arrow heads. The default
arrow head style is Closed Filled.
For more information about arrow head styles, see “Choose Dimension Arrowheads” in AutoCAD Help.
Arrow Head Size
Specifies the size of the arrow head. The default arrow head size is defined in plot units (either inches or
millimeters). The plot units are determined by the drawing units established in the drawing settings.
Enter zero or a positive number. A value of zero means that a leader is displayed without an arrow head.
Visibility
Specifies whether leaders are visible when you drag a label from its original position.
Type
Specifies the shape of the leader.
■

Straight Leader: Draws a straight leader when you drag a label. This is the default leader type.

■

Spline Leader: Draws a spline (or smooth curve) leader.

Color
Specifies the color for leaders. Click

to open the Select Color dialog box.

Linetype
Specifies the linetype for leaders. Click

to open the Select Linetype dialog box.

Lineweight
Specifies the lineweight for leaders. Click

to open the Lineweight dialog box.
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Dragged State Components
Display
Specifies how label content is displayed after it is dragged from its default position.
■

As Composed: Maintains the original settings for orientation and composition. When selected, all
other properties in the Dragged State Components category are unavailable for editing. This is the
default.

■

Stacked Text. Reformats labels based on the settings in this Dragged State Components category.

NOTE When Display is set to Stacked Text, all blocks, lines, and direction arrows are removed. The text
components are stacked vertically based on the order in which the text components were created in the label
style.
Border Visibility
Specifies whether a border is visible for dragged labels.
Border Type
Specifies the shape of the border.
■

Rectangular: Draws a rectangle.

■

Rounded Rectangular: Draws a rectangle with rounded corners.
The radius used to create a rounded rectangle is calculated by adding the border and leader gap value
and half the overall text height (including descending characters, and subscript and superscript
characters).

■

Circular: Draws a circular border.

Border and Leader Gap
Specifies the distance between the leader and the label text. Enter a positive value greater than zero.
The gap value is also used to define the space between the border and the label text.
Text Height
Specifies the plotted height for all text components. Enter a positive value greater than zero.
NOTE When Display is set to As Composed, this property is unavailable for editing.
Leader Attachment
Specifies the location where a leader hook is drawn in relation to label content.
■

Top Of Top Line (of multiple lines of text)

■

Middle Of Top Line (of multiple lines of text)

■

Middle (of single line of text)

■

Middle Of Bottom Line (of multiple lines of text)

■

Bottom Of Bottom Line (of multiple lines of text)

Middle is the default setting.
Leader Justification
Specifies how label text is justified in relation to the leader.
■

True. Text is left-justified when the leader is on the left, and right-justified when the leader is on the
right, as shown in the following illustration. This is the default setting.
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■

False. Text is left-justified regardless of leader location, as shown in the following illustration:

Color
Specifies the color for dragged components. Click

to open the Select Color dialog box.

Linetype
Specifies the linetype for dragged components. Click

to open the Select Linetype dialog box.

Lineweight
Specifies the lineweight for dragged components. Click

to open the Lineweight dialog box.

Collapse All Categories
Collapses the property categories to show only the top-level item.
Expand All Categories
Expands categories to show all properties.
Override All Dependencies
Selects all the check boxes in the Override column, which prevents the setting from being changed if the
value is changed at a higher level setting. This option is not available at the drawing level.

Edit Label Style Defaults Dialog Box (Drawing Level)
Use this dialog box to set default settings for all labels in the current drawing.
For a description of the controls, see Standard Edit Label Style Defaults Dialog Box (page 2175).
The defaults that you set in this dialog box are global until overridden by changes made to default settings
at the object collection level (such as Point, Parcel, Surface, and Alignment); at the label-style-type-level; or
at the label style level. For a description of override controls unique to managing the hierarchy of default
label settings, see Managing Overrides in Label Style Dialog Boxes (page 2198).
Related procedures:
■

Default Settings for All Label Styles in a Drawing (page 1654)

Edit Label Style Defaults Dialog Box (Feature Level)
Use this dialog box to set default settings for all label styles for an object type.
For a description of the controls, see Standard Edit Label Style Defaults Dialog Box (page 2175).
These default settings can be dependent on the higher default settings at the drawing level (page 2179), or you
can override the higher settings by clicking the property and entering a value. Editing the property places
a check mark in the Override column, and the changes you make are applied to lower-level settings and in
individual label styles. For a description of override controls that are unique to managing the hierarchy of
default label settings, see Managing Overrides in Label Style Dialog Boxes (page 2198).
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Related procedures:
■

Default Settings for All Label Styles in a Feature (page 1655)

Edit Label Style Defaults Dialog Box (Label Style Type Level)
Use this dialog box to define default settings for all labels belonging to a specific label style type.
For a description of the controls, see Standard Edit Label Style Defaults Dialog Box (page 2175).
These default settings can be dependent on higher settings at the drawing level (page 2179) or at the feature
(page 2179) level.
You can override those settings by clicking the property and entering another value. For a description of
override controls unique to managing the hierarchy of default label settings, see Managing Overrides in
Label Style Dialog Boxes (page 2198).
Related procedures:
■

Default Settings for All Labels in a Label Type (page 1655)

Label Style Composer Dialog Box
Use this dialog box to create new label styles or edit both the format and content of existing label styles.
NOTE The controls and settings available in the dialog box vary for each object type.

Information Tab (Label Style Composer Dialog Box)
Use the Information tab to change the label style name and description information, and to review details,
such as when the style was most recently modified.
Name
Specifies a name for the current style.
NOTE Label styles names are case sensitive. “Standard” is not the same as “standard”.
Description
Specifies a description of the current style.
Created By
Displays the AutoCAD login name of the person who created the style.
Date Created
Displays the date and time the style was created.
Last Modified By
Displays the AutoCAD login name of the person who last modified the style.
Date Modified
Displays the date and time the style was last modified.
Related procedures:
■

Creating New Label Styles (page 1656)
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General Tab (Label Style Composer Dialog Box)
Use this tab to specify whether the label displays as a label or tag, the label visibility, and label orientation.
Property column
Lists categories and label properties. By clicking +/- next to a category name, you can expand or collapse
the list of label properties for that category.
When a lock
is displayed to the left of the property name, the property’s value has been locked at a
higher level setting and all lower settings are also locked.
Value column
Specifies the current value of the property. The value is either derived from a dependency on a higher
setting or it can be set explicitly at the current level.

Label
Text Style
Specifies the default text style on which all text components are based.
Visibility
Specifies whether labels of the current style are visible in the drawing.
Display Mode
Specifies whether labels are displayed as labels or tags.
■

Label: Displays label components that are assigned either the Label Mode or the Label And Tag Modes
“Used In” setting on the Layout tab.

■

Tag: Displays label components that are assigned either the Tag Mode or the Label and Tag Modes
“Used In” setting on the Layout tab.

NOTE Only the label styles that support tables contain this property.
Layer
Specifies the layer for all components in a label style.
Click
to open the Layer Selection dialog box, and select a layer.
If you set the layer to 0, the labels use the properties of the parent object layer specified on the Object
Layers tab of the Drawing Settings dialog box.
NOTE There are two options for the style to reference a layer for display control, when using ByBlock or ByLayer
controls. Reference the layer as specified in the style or reference the layer that the object resides on (by setting
the Layer to 0 in the style). If layer 0 is selected, any ByBlock and ByLayer components will display according
to the actual layer that the layer object is residing on in AutoCAD. If a layer other than 0 is selected, any ByBlock
or ByLayer components will display according to the layer as specified in the style.

Behavior
Orientation Reference
Specifies the orientation reference of a label.
■

Object: Rotates labels relative to the zero direction of the object. You can determine the zero direction
of the object based on its start and end points. If the object vector changes at the anchor point on the
label, the orientation updates automatically. This is the default setting.

■

View: Forces labels to realign to a screen-view orientation in both model and layout views. Always
assumes the zero angle is horizontal, regardless of UCS or Dview twist. If the view changes, the label
orientation updates with it.
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■

World Coordinate System: Adjusts the labels with respect to the angle between the current view and
world view. Changing the view or current UCS does not affect label rotation with respect to the world
coordinate system.

Forced Insertion
Specifies the position of a label relative to an object. Applies only when the Orientation Reference option
is set to Object and the objects are lines, arc segments, or spline segments.
■

None: Maintains label position as composed relative to the object.

■

Top: Adjusts label position to above an object.

■

Bottom: Adjusts label position to below an object.

NOTE Plan Readable should be set to True when using the Top or Bottom settings.
Force Inside Curve
Specifies whether labels are placed inside or outside a curve. Available only for curve label styles. This
setting has precedence over any forced insertion setting.
■

True: Moves label components on the outside of curve to the inside of curve. The components maintain
the same offset and rotation.

■

False: All label components remain as composed.
NOTE This setting applies only when the Orientation Reference option is set to Object.

Plan Readability
Plan Readable
Specifies the text rotation to insure that all text components in labels can be read easily in plan view.
■

True: Rotates text to insure that it can be read easily in plan view or as if viewed from an angle at the
bottom or right side of the screen/paper.
Any text with an angle greater than the angle specified in the Readability Bias setting, or with an angle
less than the Readability Bias plus 180 degrees, is in violation of plan readability, and is adjusted
automatically.

■

False: Displays text as inserted.

Readability Bias
Specifies the angle at which label text flips 180 degrees to remain plan readable.
Flip Anchors With Text
■

True: Ensures that if text is rotated to make plan-readable, the anchors will also be flipped.

■

False: The flipped label always looks like a mirror of the original.

Preview Pane
Dynamically displays changes to the label style. Right-click the preview pane to access view-related commands.
To change the view, select a preview drawing from the list. For more information, see Previewing Label Styles
(page 1652).
Related procedures:
■

Managing General Properties for Label Styles (page 1664)
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Layout Tab (Label Style Composer Dialog Box)
Use this tab to create and edit label components.
See the following topics to access information about defining layout properties for each label component.
See also:
■

Managing Layout Properties for Label Styles (page 1671)

Common Elements of the Layout Tab
Use controls at the top of the Layout tab to select, create, copy, delete, or change the draw order of label
components.
Component Name
Displays a list of existing label components defined for the label style. Select a component from this list
to edit its properties.
Create Component
Creates a new label component. Select a component type from this list to create a new text, text for each,
block, direction arrow, tick, or line component. The Property and Value columns display settings you can
change to define the appearance, location, and orientation of that particular component. Not all
components are available for all label types.

Copy Component
Copies the selected component.
Delete Component
Deletes the selected component.

Change Draw Order
Displays the Component Draw Order (page 2196) dialog box.
Preview Pane
Dynamically displays changes to the label style. Right-click the preview pane to access view-related
commands. To change the view, select a preview drawing from the list. For more information, see
Previewing Label Styles (page 1652).
Color
Specifies colors for components, borders, and leaders.
Click the Value column, and then click

to open the Select Color dialog box.

Linetype
Specifies linetypes for components and borders.
Click the Value column, and then click

to open the Select Linetype dialog box.

Lineweight
Specifies the lineweights for components and borders.
Click the Value column, and then click

to open the Lineweight dialog box.
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Related procedures:
■

Adding Content to Labels (page 1686)

Text Component Layout (Label Style Composer Dialog Box)
Use the Layout tab to create a text component for a label style.
From the Create Component list

, click

to create a new text component.

General
Name
Specifies the name of the text component.
The default name, such as “Text.1,” is the component name with a numeric increment. If the text
component exists in a parent label style, then the name cannot be edited.
Visibility
Specifies whether the text component is visible in the label style.
Used In
Specifies whether the component is displayed in Tag Mode, Label Mode, or both. Select a mode on the
General tab (page 2181) in the Label Style Composer.
■

Label Mode: Displays the text component when Display Mode is set to Label.

■

Tag Mode: Displays the text component when Display Mode is set to Tag.

■

Label and Tag Modes: Displays the text component regardless of the display mode setting.

NOTE If a label style type does not support tables, then this control is not available.
Anchor Component
Specifies a reference object for positioning the text component. You can select <Feature> (which is the
object being labeled) or another existing label component.
Anchor Point
Specifies the location on the Anchor Component where the text component is attached.
■

When <Feature> is the Anchor Component, Label Location is the only option available. This option
places the anchor point at the location where the label is attached to the object.

■

When the Anchor Component is another label component, you have a choice of anchor points
depending on whether the anchor is a text, block, tick, line, or direction arrow component. For example,
if the anchor is a text component, you can select from the points shown in the following illustration:

Span Outside Segments
Specifies whether the label style component should span outside segments.
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NOTE This setting applies to parcel line and curve label styles only.
■

True: Labels the outer boundary of parcels, rather than the individual parcel segments. For example,
if four parcels share an outer boundary, use this option to label the combined outer boundary.

■

False: Labels individual parcel segments.

Text
Contents
Specifies the content of the text component. When a text component is first created, displays “Label Text”
by default.
Click the Value column, and then click
to open the Text Component Editor (page 2199) dialog box where
you can create and edit the label content.
Text Height
Specifies the plotted height for text. Enter a positive value greater than zero.
Rotation Angle
Specifies the angle for the text component. Enter a positive or negative value, or
click to select an
angle in the drawing.
The angle direction is always counterclockwise, and the zero (0) direction is determined by the anchor
component type.
If the text component is anchored to a feature, then the zero direction is determined in relation to the
following Orientation Reference settings on the General (page 2181) tab:
■

Object: Calculates the zero angle by examining the object’s construction and then measuring the zero
angle from the start to the end of the object. If the object is a curve, then the zero angle is tangent to
the curve.

■

View: Sets the zero angle equal to the world coordinate system (WCS) base angle of East (horizontal,
left to right).

■

World Coordinate System: Sets the zero angle equal to the WCS base angle of East (horizontal, left to
right).

If the text compon- then the zero angle is
ent is anchored to... measured...
another text component, a block component, tick component

along the component’s zero
angle.

line component or
vertex arrow component

from the start of the line to
the end of the line.

Layout Tab (Label Style Composer Dialog Box) | 2185

Attachment
Specifies the location on the text component that is attached to the anchor point. Attachment points are
calculated based on a rectangle that encompasses the text, the size of which is determined by including
the Gap value specified in the Border category. The following illustration shows text attachment points:

X Offset
Specifies the offset distance between the attachment point and the anchor point in the X direction (zero
angle direction).
The X direction is determined by the object to which the text component is anchored. If the text component
is anchored to the label insertion point, then the X direction is determined in relation to the following
Orientation Reference settings on the General (page 2181) tab:
■

Object: Calculates the X direction by examining the object’s construction and measuring the zero
angle direction from the start to the end of the object. If the object is a curve, then the zero angle is
located tangent to the curve.

■

View: The X direction is always horizontal, left to right, regardless of the User Coordinate System (UCS)
or Dview twist direction.

■

World Coordinate System: The X direction is the same as the User Coordinate System (UCS) base angle
of East (horizontal, left to right).

Y Offset
Specifies the offset distance between the attachment point and the anchor point in the Y direction, which
is 90 degrees counterclockwise to the X direction.
Allow Curved Text
Specifies whether text is drawn along a curve for curve label styles.

Border
Visibility
Specifies whether the border is visible.
Type
Specifies the shape of the border.
■

Rectangular: Draws a rectangle around the text component.

■

Rounded Rectangular: Draws a rectangle with round corners around the text component.
The radius used to create a rounded rectangle is calculated by adding the gap value and half the overall
text height (including descending, subscript, and superscript characters).

Gap
Specifies the distance between the border and text. The Gap is still applied if Border Visibility is set to
False.
Background Mask
Specifies whether a mask is applied to the component using the border shape and size.

2186 | Chapter 60 Label Dialog Boxes

without mask
1234
with mask
1234

Related procedures:
■

Text (page 1686)

■

Managing Layout Properties for Label Styles (page 1671)

Text-For-Each Component Layout (Label Style Composer Dialog Box)
Use the Layout tab to create a Text-For-Each component for a label style.
Text-For-Each components label each object associated with a parent object (the object you are labeling).
For example, you can use a Text-For-Each component in a structure label style to include labels for pipes
associated with that structure. For more information, see Text-For-Each (page 1694).
From the Create Component list

, click

to create a new Text-For-Each component.

The Select Type (page 2187) dialog box is displayed, where you select the type of data to include in the
Text-For-Each component.
NOTE The Text-For-Each component type is available only for structure label styles.
After you select the Text-For-Each type, your selection is displayed on the Layout tab in the General section.
The remainder of the settings that you specify for a Text-For-Each component are identical to the settings
for a text component. For more information, see Text Component Layout (Label Style Composer Dialog
Box) (page 2184).

Select Type Dialog Box
Use the Select Type dialog box to select the type of Referenced Text or Text-For-Each label component to
create.

Referenced Text Options
Alignment
Creates a Referenced Text component with property fields you can use to refer to alignment data.
Profile
Creates a Referenced Text component with property fields you can use to refer to profile data.
Surface
Creates a Referenced Text component with property fields you can use to refer to surface data.
Parcel
Creates a Referenced Text component with property fields you can use to refer to parcel data.
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Text-For-Each Options
Structure All Pipes
When inserted into a structure label style, adds labels for all pipes coming into or out of the structure.
Structure In Flow Pipes
When inserted into a structure label style, adds labels for all pipes coming into the structure.
Structure Out Flow Pipes
When inserted into a structure label style, adds labels for all pipes going out of the structure.
Related procedures:
■

Referenced Text (page 1693)

Referenced Text Component Layout (Label Style Composer Dialog Box)
Use the Layout tab to create a Reference Text component for a label style.
Reference Text components refer to other objects in the drawing, instead of to the object you are labeling.

From the Create Component list

, click

to create a new Referenced Text component.

The Select Type (page 2187) dialog box is displayed, where you select the type of data to include in the
Referenced Text component.
NOTE The Referenced Text component type is available for all new label objects. See Label Objects (page 1643)for
a list of supported label objects.
After you select the Referenced Text type, the object type you selected is displayed on the Layout tab in the
General section.
NOTE Once you specify the object type, it cannot be changed. If you want to insert references to a different
object type, you must create a new Referenced Text component and select the other object type when you create
the new component.
The remainder of the settings that you specify for a Referenced Text component are identical to the settings
for a text component. For more information, see Text Component Layout (Label Style Composer Dialog
Box) (page 2184). However, when you set up the label contents, you select Properties that refer to the referenced
object.
Related procedures:
■

Creating Note Labels (page 1660)

■

Inserting Note Labels (page 1709)

Block Component Layout (Label Style Composer Dialog Box)
Use the Layout tab to create a block component for a label style.
From the Create Component list

, click

General
Name
Specifies the name of the block component.
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to create a new block component.

The default name, such as “Block.1,” is the component name with a numeric increment. If the block
component exists in a parent label style, then the name cannot be edited.
Visibility
Specifies whether the block component is visible in the label style.
Used In
Specifies whether the component is visible in tag mode, label mode, or both. Select a mode on the General
tab (page 2181) in the Label Style Composer.
■

Label Mode: Displays the block component when Display Mode (on the General tab) is set to Label.

■

Tag Mode: Displays the block component when Display Mode is set to Tag.

■

Label and Tag Modes: Displays the block component regardless of the display mode setting.

NOTE If a label style type does not support tables, then this control is not available.
Anchor Component
Specifies a reference object for positioning the block component. You can select <Feature> (which is the
object being labeled) or another existing label component.
Anchor Point
Specifies the location on the Anchor Component where the block component is attached.
■

When <Feature> is the Anchor Component, Label Location is the only option available. This option
places the anchor point at the location where the label is attached to the object.

■

When the Anchor Component is another label component, you have a choice of anchor points
depending on whether the anchor is a text, block, tick, line, or direction arrow component.

Block
Block Name
Specifies the block to use in the block component.
Click the Value column, and then click
In the Select A Block dialog box, click
viewing tools to preview the block.

to open the Select A Block dialog box.
to open a Viewer in which you can use standard AutoCAD

NOTE The block must exist in the current drawing.
Block Height
Specifies the height to which the block is scaled to fit. The block’s extents in the X direction are used for
scaling the height. The block’s aspect ratio is maintained when scaled.

Rotation Angle
Specifies the angle for the block component. Enter a positive or negative value, or click
angle in the drawing.

to select an
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The angle direction is always counterclockwise, and the zero (0) direction is determined by the anchor
component type.
Attachment
Specifies the location on the block component that is attached to the anchor point. Attachment points
are calculated based on a rectangle that encompasses the block, the size of which is determined by including
the Gap value specified in the Border category. The following illustration shows block attachment points:

X Offset
Specifies the offset distance between the attachment point and the anchor point in the X direction (zero
angle direction).
The X direction is determined by the object to which the block component is anchored. If the block
component is anchored to the label insertion point, then the X direction is determined in relation to the
following Orientation Reference setting on the General (page 2181) tab:
■

Object: Calculates the X direction by examining the object’s construction and measuring the zero
angle direction from the start to the end of the object. If the object is a curve, then the zero angle is
located tangent to the curve.

■

View: The X direction is always horizontal, left to right, regardless of the User Coordinate System (UCS)
or Dview twist direction.

■

World Coordinate System: The X direction is the same as the User Coordinate System (UCS) base angle
of East (horizontal, left to right).

Y Offset
Specifies the offset distance between the attachment point and the anchor point in the Y direction, which
is 90 degrees counterclockwise to the X direction.
Related procedures:
■

Blocks (page 1696)

■

Managing Layout Properties for Label Styles (page 1671)

Line Component Layout (Label Style Composer Dialog Box)
Use the Layout tab to create a line component for a label style.
From the Create Component list

, click

to create a new line component.

A line component can be defined in two ways, depending on the Use End Point Anchor setting:
■

Start Point, Length, and Angle: Use this method to anchor the start point of the line component to the
anchor component. Set the Use End Point Anchor setting to False, and then specify the Length and
Angle.

■

Start Point and End Point: Use this method to anchor the start and end point of the line component.
Set the Use End Point Anchor setting to True, and then specify the End Point Anchor Component and
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End Point Anchor Point. The length and angle of the line are determined by the position of the anchor
objects, and adjust if the anchor components are edited.

General
Name
Specifies the name of the line component.
The default name, such as “Line.1,” is the component name with a numeric increment. If the line
component exists in a parent label style, then the name cannot be edited.
Visibility
Specifies whether the line component is visible in the label style.
Used In
Specifies whether the component is visible in tag mode, label mode, or both. Select a mode on the General
tab (page 2181) in the Label Style Composer.
■

Label Mode: Displays the line component when Display Mode is set to Label.

■

Tag Mode: Displays the line component when Display Mode is set to Tag.

■

Label and Tag Modes: Displays the line component regardless of the display mode setting.

NOTE If a label style type does not support tables, then this control is not available.
Start Point Anchor Component
Specifies a reference object for positioning the start point of the line component. You can select <Feature>
(which is the object being labeled) or another existing label component.
Start Point Anchor Point
Specifies the location on the Start Point Anchor Component where the start point of the line component
is attached.
■

When <Feature> is the Anchor Component, Label Location is the only option available. This option
places the anchor point at the point where the label is attached to the object being labeled.

■

When another label component is the Anchor Component, you have a choice of anchor points
depending on whether the anchor is a text, block, tick, line, or direction arrow component.

Use End Point Anchor
Specifies the method for defining the line component.
■

True: Uses the Start Point and End Point method to define the line component.
The Length and Angle properties in the Line category become unavailable for editing.

■

False: Uses the Start Point, Length, and Angle method to define the line component.
The End Point Anchor Component, End Point Anchor Point, End Point X Offset, and End Point Y
Offset properties become unavailable for editing.

End Point Anchor Component
Specifies a reference object for positioning the end point of the line component.
This property is unavailable when the Use End Point Anchor property is set to False.
End Point Anchor Point
Specifies the location on the End Point Anchor Component where the end point of the line component
is attached.
This property is unavailable when the Use End Point Anchor property is set to False.
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Line
Length
Specifies the length of the line component.
This property is unavailable when the Use End Point Anchor property is set to True.
Angle
Specifies the angle of the line component from the start point. Enter a positive or negative value, or click
to select an angle in the drawing.
This property is unavailable when the Use End Point Anchor property is set to True.
Start Point X Offset
Offsets the line start point from the start point anchor point in the X direction.
The X direction is determined by the object to which the line component is anchored. If the line component
is anchored to the label insertion point, then the X direction is determined in relation to the following
Orientation Reference settings on the General (page 2181) tab:
■

Object: Calculates the X direction by examining the object’s construction and measuring the zero
angle direction from the start to the end of the object. If the object is a curve, then the zero angle is
tangent to the curve.

■

View: The X direction is always horizontal, left to right, regardless of the User Coordinate System (UCS)
or Dview twist direction.

■

World Coordinate System: The X direction is the same as the User Coordinate System (UCS) base angle
of East (horizontal, left to right).

Start Point Y Offset
Offsets the line start point from the start point anchor point in the Y direction.
End Point X Offset
Offsets the line end point from the end point anchor point in the X direction.
This property is unavailable when the Use End Point Anchor property is set to False.
End Point Y Offset
Offsets the line end point from the end point anchor point in the Y direction.
This property is unavailable when the Use End Point Anchor property is set to False.
Related procedures:
■

Lines (page 1695)

■

Managing Layout Properties for Label Styles (page 1671)

Tick Component Layout (Label Style Composer Dialog Box)
Use the Layout tab to create a tick component for a label style.
From the Create Component list

, click

to create a new tick component.

NOTE Unlike other label components, ticks are always anchored to the feature that is being labeled. Therefore
ticks do not have Anchor Component or Anchor Point properties.

General
Name
Specifies the name of the tick component.
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The default name, such as “Tick.1,” is the component name with a numeric increment. If the tick
component exists in a parent label style, then the name cannot be edited.
Visibility
Specifies whether the tick component is visible in the label style.
Used In
Specifies whether the component is visible in Tag Mode, Label Mode, or both. Select a mode on the General
tab (page 2181) in the Label Style Composer.
■

Label Mode: Displays the tick component when Display Mode is set to Label.

■

Tag Mode: Displays the tick component when Display Mode is set to Tag.

■

Label and Tag Modes: Displays the tick component regardless of the display mode setting.

NOTE If a label style type does not support tables, then this control is not available.

Tick
Block Name
Specifies the block to use for the tick component.
Click the Value column, and then click
In the Select A Block dialog box, click
viewing tools to preview the block.

to open the Select A Block dialog box.
to open a Viewer in which you can use standard AutoCAD

NOTE The block must exist in the current drawing.
Block Height
Specifies the height to which the tick block is scaled to fit. The block’s extents in the X direction are used
for scaling the height. The block’s aspect ratio is maintained when scaled.

Rotation Angle
Specifies the angle for the tick component. Enter a positive or negative value, or click
angle in the drawing.

to select an

Align With Object
Specifies whether the tick is inserted at an angle relative to the object.
■

True: Inserts the tick at an angle relative to the object:

■

False: Inserts the tick at an angle relative to the UCS setting:
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NOTE The specified Rotation Angle is applied in conjunction with this setting.
Related procedures:
■

Ticks (page 1697)

■

Managing Layout Properties for Label Styles (page 1671)

Direction Arrow Component Layout (Label Style Composer Dialog Box)
Use the Layout tab to create a direction arrow component for a label style.
From the Create Component list

, click

to create a new direction arrow component.

General
Name
Specifies the name of the direction arrow component.
The default name, such as “Direction Arrow.1,” is the component name with a numeric increment. If the
arrow component exists in a parent label style, then the name cannot be edited.
Visibility
Specifies whether the direction arrow component is visible in the label style.
Used In
Specifies whether the component is visible in tag mode, label mode, or both. Select a mode on the General
tab (page 2181) in the Label Style Composer.
■

Label Mode: Displays the direction arrow component when Display Mode is set to Label.

■

Tag Mode: Displays the direction arrow component when Display Mode is set to Tag.

■

Label and Tag Modes: Displays the direction arrow component regardless of the display mode setting.

NOTE If a label style type does not support tables, then this control is not available.
Anchor Component
Specifies a reference object for positioning the direction arrow component. You can select <Feature>
(which is the object being labeled) or another existing label component.
Anchor Point
Specifies the location on the Anchor Component where the direction arrow component is attached.
■

When <Feature> is the Anchor Component, Label Location is the only option available. This option
places the anchor point at the point where the label is attached to the object being labeled.

■

When the Anchor Component is another label component, you have a choice of anchor points
depending on whether the anchor is a text, block, tick, line, or direction arrow component.
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Span Outside Segments
Specifies whether the label style component should span outside segments.
NOTE This setting applies to parcel line and curve label styles only).
■

True: Labels the outer boundary of parcels, rather than the individual parcel segments. For example,
if four parcels share an outer boundary, use this option to label the combined outer boundary.

■

False: Labels individual parcel segments.

Direction Arrow
Arrow Head Style
Specifies the arrow head style. Select an arrow head style from the list.
NOTE Select None to create a direction arrow without an arrow head.
Arrow Head Size
Specifies the size of the arrow head in plot units.
NOTE A value of zero creates a direction arrow without an arrow head.
NOTE The direction arrow length must be at least twice that of the specified arrow head size. If not, the arrow
head is not displayed. For example, if you specify an arrow head size of 0.2, the arrow length must be at least
0.4. This behavior is similar to AutoCAD leaders.
Arrow head is not displayed when
arrow length is decreased

Fixed Length
Specifies whether the arrow length is controlled by the Length setting or by the length of the object being
labeled.
■

True: Uses the Length setting.

■

False: Draws the length of the direction arrow to match the length of the object being labeled.

Length
Specifies the overall length of the direction arrow, including the arrow head.
The Length setting is unavailable when the Fixed Length property is set to False.
X Offset
Specifies the offset distance between the mid-point of the direction arrow and the anchor component in
the X direction.
Y Offset
Specifies the offset in the Y direction.
The following illustration shows X and Y offsets for a direction arrow:
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Related procedures:
■

Direction Arrows (page 1699)

■

Managing Layout Properties for Label Styles (page 1671)

Component Draw Order Dialog Box
Use this dialog box to control how label text is drawn. Move a component up in the display order to ensure
it appears on top of other components.
Component List
Lists the defined components in their current draw order. The component at the top is drawn last. Click
a component name and then click the Top or Bottom arrows to move the component to a different draw
order location.
Related procedures:
■

Changing Label Component Draw Order (page 1701)

Dragged State Tab (Label Style Composer Dialog Box)
Use this tab to define properties for labels when they are dragged away from their insertion points.

Leader
Arrow Head Style
Specifies the arrow head style for the leader. Select an arrow head style from the list.
NOTE Select None to create a leader without an arrow head.
Arrow Head Size
Specifies the size of the arrow head in plot units.
NOTE A value of zero creates a leader without an arrow head.
Visibility
Specifies whether the leader is visible when a label is dragged from its default position.
Type
Specifies the shape of the leader.
■

Straight Leader: Draws a straight leader.

■

Spline Leader: Draws a spline leader.

Dragged State Components
Display
Specifies how label content is displayed after it is dragged from its default position.
■

As Composed: Labels maintain the original settings for composition and orientation.
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When you select As Composed, all other properties in the Dragged State Components category become
unavailable for editing.
■

Stacked Text: Reformats labels based on the settings in this Dragged State Components category.
When you select Stacked Text, all blocks, lines, ticks, and direction arrows are removed. The text
components are stacked vertically in the order they were defined in the label style.

NOTE The Summary tab of the Label Style Composer dialog box lists the components in the order in which
they were defined.
Border Visibility
Specifies whether the border is visible when a label is dragged from its original position.
Border Type
Specifies the shape of the border.
■

Rectangular: Draws a rectangle around text.

■

Rounded Rectangular: Draws a rectangle with round corners around text.
The radius used to create the round corners of the rectangle is calculated by adding the gap value and
half the overall text height (including descending, subscript, and superscript characters).

Border And Leader Gap
Specifies the distance between the leader and text.
Text Height
Specifies the plotted height for text.
Leader Attachment
Specifies the location where the leader hook is drawn relative to the label content.
Leader Justification
Specifies how label text is justified in relation to the leader.
■

True: Text is left-justified when the leader is on the left of the text, and is right-justified when the
leader is on the right.

■

False: Text is left-justified regardless of the leader location.

Related procedures:
■

Managing Dragged Properties for Label Styles (page 1681)

Summary Tab (Label Style Composer Dialog Box)
Use this tab to review all settings for a label style.
Label Content Summaries (Component 1, and so on)
Lists the label components as defined in the label style. The components are listed numerically in the
order in which they were created. For example, if the label style contains multiple components, the
categories are Component 1, Component 2, Component 3, and so on.
The properties are listed under each component prefixed with the category of the component. The values
of each of the properties replicate those made in the General, Layout, and Dragged State tabs of the Label
Style Composer dialog box.
Collapse All Categories
Collapses the property categories to show only the top level item.
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Expand All Categories
Expands categories to show all properties.
Override All Dependencies
Selects all the check boxes
in the Override column, which prevents the style from being changed if
values change at a higher-level setting (either in label settings or in a parent label style).

Status Update
At the bottom of the Summary tab the status of overrides is displayed as you select an item. For more
information, see Managing Overrides in Label Style Dialog Boxes (page 2198).
Related procedures:
■

The Hierarchy of Label Settings (page 1648)

■

Managing Overrides in Label Style Dialog Boxes (page 2198)

Managing Overrides in Label Style Dialog Boxes
Use override options in label style dialog boxes to disconnect a setting from higher-level settings, and to
restore settings to the higher-level settings.
Property column
Contains label categories and label property names.
Category names (in bold text) contain a list of one or more label properties (in normal text). Click plus
(+) or minus (-) next to a category name to expand or collapse the list of property names.
Value column
Displays the current value for each property. When you change the default value in this column, a check
mark is displayed in the Override column.
NOTE Even if you don’t want to change the default value, you can manually select the check box in the Override
column to prevent the setting from being affected by changes to a higher-level setting.
Override column
Identifies whether a property is overridden at the current level. A clear check box
is the same as the higher level default setting.

indicates the value

A selected check box
indicates that the value has been explicitly set at the current level. If you click
the check box to clear it, the setting is restored to the default, higher-level setting.
You can clear the check box to clear the override and set the value back to the value of its parent setting.
Even if you don’t specifically change a value, you can select the check box manually to disconnect the
setting from the higher-level setting. This prevents it from changing if the higher-level setting changes.
Child Override column
Indicates that the value setting has been overridden at a lower level.
Displays when you click
click OK or Apply.

and removes lower-level overrides in other settings and styles when you

WARNING Using this option resets the property in subordinate settings and/or styles even if they are locked.
Lock
Prevents the property value from being changed at a subordinate level. To lock a value, click
it to

. The lock cannot be set if there is a child override set.
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to change

Override All Dependencies
Selects all the check boxes
in the Override column, which prevents the properties from being affected
by changes to higher-level settings.

Status Update
At the bottom of the Summary tab in the Label Style Composer dialog box and in the three different Edit
Label Style Defaults dialog boxes, the override status is displayed as you select an item.
Property
Displays the selected property name followed by a single line description of the property.
Parent
Displays the name of the parent from which the default value was derived. This is always the next-highest
level at which the value was explicitly specified or overridden. Parents can include the following:
■

Drawing Settings

■

<Feature Name> Settings

■

<Label Style Type Name> Settings

■

<Parent Label Style Name>

For example, if you are reviewing a label style, the parent may be the Drawing Settings if none of the
intermediate settings were changed. However, if an intermediate setting was changed, for example, at the
feature level, then the <Feature Name> settings is listed as the parent.
Parent Value
Displays the value of the property as defined in the parent setting or style.
Related procedures:
■

The Hierarchy of Label Settings (page 1648)

Text Component Editor Dialog Box
Use this dialog box to add content to a label style.
You can override the content of an individual label by adding property fields for dynamic text, entering
static text, and specifying formatting options. These edits do not modify the style being used by the label.
Access this dialog box on the Layout tab of the Label Style Composer by clicking the button in the Contents
Value column, as shown in the following illustration:

See also:
■

Text (page 1686)

■

Adding Text Components to Labels (page 1686)

■

Formatting Text (page 1688)

■

Adding Property Fields to Label Text Components (page 1691)

■

Editing Text in the Text Component Editor (page 1690)
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Common Elements of the Text Component Editor Dialog Box
Some common elements in the Text Component Editor are available when either the Properties or Format
tab is selected.
Text Component Editor Window
Contains the property fields for the text component.
When you select a property and click
, the property field is inserted into the window. For more
information, see Properties Tab (Text Component Editor Dialog Box) (page 2200).
You can also type text directly into this window. For more information, see Text Editor (Text Component
Editor Dialog Box) (page 2203).
Import Text
Imports static text into the Text Component Editor window. Click Import Text to open the Select File
dialog box. You must select a file that is either ASCII or RTF format.
You can format imported text by using the options on the Format tab (page 2201).
Related procedures:
■

Adding Text Components to Labels (page 1686)

Properties Tab (Text Component Editor Dialog Box)
Use this tab to add property fields to text components.
Property fields control the label content. Labels that contain property fields are linked to drawing objects
and update dynamically when the drawing changes. For more information, see Property Fields (page 1691).
When a property field is added to a text component in the text editor window, the text content is constructed
of modifier codes within a two character bracket symbol <[########]>.
WARNING The angle and square bracket combination is reserved for use by property fields. If you enter an angle
and square bracket combination manually, it will cause an error in the text component. Also, manually editing
modifier codes causes an error in the property field. The errors are displayed as three question marks (???) in the
label when the property fields are processed. To change a property field in the Text Component Editor window,
delete the property field completely from the window (including the angle and square bracket combinations),
and insert a new property field.
Properties
Specifies a property to insert into the label text component. Properties are based surface spot elevation.
When you select a property, Modifiers and their Values are displayed in the grid below it.
NOTE Edit the values as needed before clicking the Add Properties button. If you make changes to the values
after you insert the property, you must delete and reinsert the property.

Filter
Opens the Property Filter (page 2201) dialog box where you can select which type of properties to include
in the Properties list. This restricts the Properties list so it shows only relevant properties for the label type
you are creating. For example, this is useful when you are creating a pipe label and want to restrict the
properties shown to those relevant only to a particular type, such as circular pipes. Not available for all
label types.
Add Properties
Inserts the property field into the Text Component Editor window at the cursor location.
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Modifier
Lists all modifiers supported by the selected property field. For example, these modifiers may include unit,
precision, and angle format. For more information, see Property Field Modifiers (page 1692).
Value
Lists the value for each modifier. The values and the method of formatting them vary according to the
type of modifier.
Related procedures:
■

Text (page 1686)

■

Adding Text Components to Labels (page 1686)

■

Adding Property Fields to Label Text Components (page 1691)

■

Property Field Modifiers (page 1692)

Property Filter Dialog Box
Use this dialog box to restrict the available properties in the Properties list on the Layout tab of the Text
Component Editor dialog box.
By selecting filter options in this dialog box, you can limit the contents of the Properties list so you can
more easily see the properties that are relevant to the label type you are composing.
Property
Lists the categories of filters available.
Value
Specifies the filter to use. Select a specific filter or specify one of the following:
■

<All>: Resets the filter to include all properties. A restrictive filter remains active until you use this
option.

■

<None>: Excludes all such properties from the Properties list.

NOTE After you select a filter, it remains active for new label styles also. If you do not see the properties you expect
in the Text Component Editor, click the Filter icon to determine whether the Properties list is filtered. Use the <All>
option to turn filters off.
Related procedures:
■

Adding Property Fields to Label Text Components (page 1691)

■

Property Field Modifiers (page 1692)

Format Tab (Text Component Editor Dialog Box)
Use this tab to define how label text is formatted.
Text Style
Displays the text style on which all text components are based.
NOTE The text style for a label is specified on the General (page 2181) tab of the Label Style Composer dialog
box.
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Justification
Specifies how the entire text component is justified.
■

Left: Text is left justified.

■

Center: Text is centered.

■

Right: Text is right justified.

Font
Specifies the font for new or selected text.
TrueType® fonts
are listed by font family name. AutoCAD compiled shape (SHX) fonts
are listed
by the name of the file in which the fonts are stored. Custom fonts or third-party fonts are substituted
with Autodesk-supplied proxy fonts. A custom SHX font is available for character formatting overrides
only if it is defined for a text style in the drawing.
Color
Specifies the text color.
Select a color from the list or click

to open the Select Color dialog box.

Formatting options
Bold
Turns bold formatting on and off for new or selected text. This option is available only for characters
using TrueType fonts.
Italic
Turns italic formatting on and off for new or selected text. This option is available only for characters
using TrueType fonts.
Underline
Turns underlining on and off for new or selected text.
Undo
Reverses the most recent action in the Text Component Editor, including changes to either text content
or text formatting.
NOTE You can also press Ctrl+Z to undo the most recent change.
Redo
Reverses the effects of the last Undo that you performed, including changes to either text content or text
formatting. The Redo option must immediately follow the Undo command.
Stack/Unstack
Stacks selected text that is formatted using stack characters, or unstacks stacked text. For more information,
see Creating Stacked Characters (page 1689).

Inserts special characters and symbols.
NOTE Diameter symbols appear as %%c in the Text Component Editor window but are converted to Ø in
labels.

2202 | Chapter 60 Label Dialog Boxes

The Other option in the Symbol list displays the Character Map dialog box. To insert a character from
this dialog box, select it, and then click Select. Select all the characters you want to use and then click
Copy. Then right-click in the Text Component Editor window, and click Paste.
Related procedures:
■

Formatting Text (page 1688)

■

Creating Stacked Characters (page 1689)

■

Editing Text in the Text Component Editor (page 1690)

Text Editor (Text Component Editor Dialog Box)
Use the Text Editor window, which is the area on the right side of the Text Component Editor dialog box,
to construct a text component.
The Text Editor window has three purposes:
■

It contains the property fields that you specify for the text component

■

It allows you to add static text to a label

■

It allows you to select text for formatting and editing

Property fields should not be edited or the label will not be created correctly. You can, however, enter text
in the window and use the following shortcut menu items to format it:
Shortcut Menu
Select the text, and right-click to display a shortcut menu for quick formatting options. The menu is
context sensitive to cursor position, text selection, and stacked text.
The shortcut menu is divided into three parts. The top part has standard editing commands: Undo, Redo,
Cut, Copy, and Paste.
The lower part of the shortcut menu contains specific formatting options.
■

Select All: Selects all text in the editor window.

■

UPPERCASE: Changes all selected text to uppercase characters.

■

lowercase: Changes all selected text to lowercase characters.

■

Remove Formatting: Removes any formatting, such as underline, bold, italic, and word-wrapping.

■

Combine Paragraphs: Removes all line returns.

■

Stack: Stacks selected text. This option appears only when text that is formatted with stacking characters
is selected. For more information, see Creating Stacked Characters (page 1689).

■

Unstack: Unstacks text. This option appears only when stacked text is selected.

■

Properties: Displays the AutoCAD Stack Properties dialog box. This option appears only when stacked
text is selected.

Related procedures:
■

Editing Text in the Text Component Editor (page 1690)

Label Style Control
Use this control to create a new label style, edit the current selection, or select a style from the drawing.
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The Label Style control is available in many dialog boxes.
Create New
Creates a new label of the same type in the Label Style Composer dialog box.
Copy Current Selection
Creates a copy of the current label style.
Create Child Of Current Selection
Creates a child from the current label style.
Edit Current Selection
Opens the Label Style Composer, where you can edit the current label style.
Pick From Drawing
Displays a pickbox so you can select a label style directly from the drawing.

Label Properties Dialog Box
Use this dialog box to change the properties of labels in the drawing.
Different properties are available, depending on the type of label selected. The most general properties are
listed first.

General
Reset Label Defaults
Returns all properties to original values. Use this option to reset the properties after you have made changes.
This option works only within the current instance of the command; it does not restore previously-changed
properties.
Label Style
Displays the style used by the selected label. Click the Value column, and then click
Style dialog box and to select a different style.

to open the Label

Visibility
Specifies whether the label is visible in the drawing.
■

True: Displays the label.

■

False: Hides the label. This setting deletes the label unless it is reset before you close the dialog box.

Flip Label
Specifies whether the label is flipped.
■

True: Flips the label components to the opposite side of a line or curve object.

■

False: Leaves label as is.

Label Is Pinned
Specifies whether the label is fixed to its location.
■

True: Pins a label to its current location regardless of edits to the object referenced by that label.

■

False: Label can be moved if the object is edited.
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Bearing Labels
Reverse Direction
Reverses the direction of labels that contain bearings.
■

True: Reverses direction label.

■

False: Leaves direction label as is.

Referenced Text Objects
Referenced Text Objects
Specifies the object to refer to in labels that contain Referenced Text. Click in the Value column and then
click

to display the Property Field Object dialog box. Select the object to refer to and click OK.

Profile View, Section View, Surface Spot Elevation Labels
Point Style
Specifies a point style which controls the appearance of the label insertion point for profile view, section
view, and surface spot elevation labels. Select a point style from the list.

Alignment Offset Labels
Leader Attachment Option
Specifies the point attachment location for the label leader line.
■

Point: Leader line attaches to the point.

■

Marker Extents: Leader line attaches to the extents of the marker.

Marker Style
Displays the style used by the currently selected marker. Click in the Value column and then click
display the Marker Style dialog box and to select a different style.

to

Fixed XY
Specifies the label position for fixed point alignment station/offset labels.
■

True: Moves the label with the alignment.

■

False: Leaves label as is.

Profile View and Section View Labels
Profile 1 Object
Specifies a profile to be used as “Profile 1” in the profile view labels. Use this option to include specific
profile data in a label. For more information, see Setting Up Profile and Section View Labels (page 1705).
Profile 2 Object
Specifies a profile to be used as “Profile 2” in the profile view labels.
Section 1
Specifies a section to be used as “Section 1” in the section view labels.
Section 2
Specifies a section to be used as “Section 2” in the section view labels.
Dimension Anchor Option
Specifies the location of the dimension line anchor used to position dimension lines for certain profile
view labels, such as vertical curve labels.
■

Default: Leaves the anchor position as is.
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■

Above: Moves the dimension line anchor up the distance specified in the Dimension Anchor Value.

■

Below: Moves the dimension line anchor down the distance specified in the Dimension Anchor Value.

■

Fixed: Places the dimension line anchor at a fixed elevation on a profile view. Specify the elevation in
the Dimension Anchor Value field.

■

Graph View Top: Places the line anchor at the top of the section view grid. This creates a vertical graph
line above the label. To ensure the full line extent is displayed, set Dim Anchor Val to 0.

■

Graph View Bottom:Anchors the line to the bottom of the section view grid. This creates a vertical
graph line below the label. To ensure the full line extent is displayed, set Dim Anchor Val to 0.

Dimension Anchor Value
Specifies the dimension line anchor value to be applied using the Dimension Anchor Option.

Pipe and Structure Labels
Alignment Name
Specifies the alignment that the pipe or structure references for labeling purposes. All alignments in the
drawing are listed, as well as <Default>. <Default> is the alignment that the part was associated with when
it was created. Changing the alignment name in the label properties changes only the data that appears
in labels; it does not change the actual association between the part and alignment.
Related procedures:
■

Modifying Labels in a Drawing (page 1712)

Label Set Dialog Box
Use this dialog box to create a group of label styles for alignments, profiles, or sections.

Information Tab (Label Set Dialog Box)
Use this tab to change the label set name and description information, and to review details, such as when
the label set was most recently modified.
Name
Specifies the name of the current label set.
Description
Specifies the description of the current label set.
Created By
Displays the AutoCAD login name of the person who created the label set.
Date Created
Displays the date and time the label set was created.
Last Modified By
Displays the AutoCAD login name of the person who last modified the label set.
Date Modified
Displays the date and time the label set was last modified.
Related procedures:
■

Creating a Label Set (page 1725)
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Labels Tab (Label Set Dialog Box)
Use this tab to select the label styles to add to an alignment, profile, or section label set.
After you add a label style to a set, you can define certain properties for the label style, such as increment.
The properties vary depending on whether you are defining an alignment, profile, or section label set.
Type
Specifies the type of label to add to the label set.
<Type> Label Style
Displays the label styles available for the specified label type. Select a label style from this list, and click
Add to add it to the label set.
Label Style Control
Creates a new label style, edits the current selection, or selects a style from the drawing.
Style Detail
Opens the Style Detail dialog box where you can preview the selected label style.
Add Label Style
Adds the label style selected in the Label Style list to the label set.
Delete Label Style
Removes a label style from the label set. Select the label style to delete by clicking in the row in the lower
part of the dialog box.

List of Selected Styles
When you add a label style to a set, it is inserted into the list in the lower part of the dialog box. You can
use this area to define properties for the label style and to change the selected label style.
Type Column
Displays the label types in the current label set.
Style Column
Specifies the label style to include in the set. Click

to open the Pick Label Style dialog box.

Increment Column
Specifies the increment at which to insert major and minor station labels.
NOTE This setting is available for station labels only.
Geometry Points To Label Column
Specifies the geometry points to label for the Geometry Points, Profile Geometry Points, and Superelevation
Critical Points label types. You can label a selection of geometry points in a label type using a selected
style. You can then add another instance of the same label type, which can label a second selection of
geometry points using a different style. Click

to select the geometry points to label.

Profile and Section Label Properties
After you add a profile or section label style to a label set, you can specify the following property values that
are unique to label sets:
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Dim Anchor Opt
Specifies the location of the dimension line anchor used to position dimension lines for certain profile
view labels, such as vertical curve labels.
■

Distance Above: Moves the dimension line anchor up the distance specified in the Dim Anchor Val
field.

■

Fixed Elevation: Places the dimension line anchor at a fixed elevation on a profile view. Specify the
elevation in the Dim Anchor Val field.

■

Distance Below: Moves the dimension line anchor down the distance specified in the Dim Anchor Val
field.

■

Graph View Top: Places the line anchor at the top of the section view grid. This creates a vertical graph
line above the label. To ensure the full line extent is displayed, set Dim Anchor Val to 0.

■

Graph View Bottom: Anchors the line to the bottom of the section view grid. This creates a vertical
graph line below the label. To ensure the full line extent is displayed, set Dim Anchor Val to 0.

Dim Anchor Val
Specifies the dimension line anchor value to be applied using the Dim Anchor Opt.
Weeding
Specifies a label exclusion distance for grade break labels only. Use this setting to remove overlapping
labels and make it easier to read the remaining labels. If another break occurs within the specified distance
from a given grade break, it is not labeled.
NOTE This setting is available for Grade Break labels only.
Stagger Labels Column
Specifies the location of the label staggering line: No staggering, Stagger both sides, Stagger to right, or
Stagger to left. The staggering options are available for the following labels: Profile (Grade Breaks,
Major/Minor Station, Horizontal Geometry), and Section labels (Major/Minor Offsets and Grade Break).
Stagger Line 1 Height Column
Specifies the height of the first profile or section view data band label stagger line.
Stagger Line 2 Height Column
Specifies the height of the second profile or section view data band label stagger line.

The following options are available when you are editing a profile or section label set.
They are not part of the style.
Start Station
Clear the check box and specify the station where the label type begins.
End Station
Clear the check box and specify the station where the label type ends.
Related procedures:
■

Creating a Label Set (page 1725)

Add Labels Dialog Box
Use this dialog box to label objects in a drawing.
The Add Labels dialog box is common to most objects. Options available in the dialog box change depending
on the feature selected.
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Feature
Specifies the feature to label.
Label Type
Specifies the type of label to add. This list changes depending on the feature selected.
Edit Command Settings
Opens the Edit Command Settings dialog box where you can specify the default styles to use for each
type of label.
Label Style list
Specifies the label style to use for new labels.
Label Style Control
Creates a new label style, edits the current selection, or selects a style from the drawing.
Style Detail
Displays the Style Detail dialog box where you can preview the selected label style.
Marker Style list
Specifies a marker style which controls the appearance of the label insertion point for profile view, section
view, and surface spot elevation labels. Select a marker style to use from the list.
Reference Text Object Prompt Method
Specifies the method for selecting Referenced Text (page 1693) objects. Used only for label types that support
Referenced Text.
■

Command Line: When inserting a label that contains Referenced Text, you are prompted at the
command line to select the objects to refer to in the label.

■

Dialog: When inserting a label that contains Referenced Text, the Label Properties dialog box is
displayed. Click in the Value column and then click
box. Select the object to refer to and click OK.

■

to display the Property Field Object dialog

Suppress Prompts: When inserting a label that contains Referenced Text, all prompting for objects is
suppressed. No objects are specified for Referenced Text fields that may exist in the label style. You
can edit the label properties later to specify the objects to refer to.

Table Tag Numbering
Accesses the Table Tag Numbering dialog box.
Add
Inserts labels of the selected style into the drawing after you select the object. The prompts that are
displayed after you click Add vary based on the label style.
Related procedures:
■

Adding Labels to Drawings (page 1701)

Table Tag Numbering Dialog Box
Use this dialog box to define how line, curve and spiral components are numbered and renumbered.
There are two numbering counters:
If you create a number of components at the same time, the Starting Number property is used to generate
the starting number and the numbering automatically increments by one unless you edit the increment
number. The starting number is only changed automatically when a table tag is created and numbered. If

Table Tag Numbering Dialog Box | 2209

there is a duplicate with the starting number, it increments up by the increment amount. If there is still a
duplicate, it increments up, until an unused tag number is found and applied. The starting number is then
set to the next number according to the increment (even if it is a duplicate).
The starting point for the increment is always the starting number. For example, if the Starting Number is
11, and the Increment is 10 and you attempt to create a tag but the starting number 11 is already used. The
next starting number is now 21. If that is also used, it will increment to 31. If 31 is available, the tag will be
numbered with 31, and the new starting number set to 41.
NOTE When creating tags, the renumbering starting number and increment will not be changed (unless you
manually change them in the Table Tag Numbering dialog box.

Table Tag Creation
Lines Starting Number
Specifies the starting number for new lines to be created in the site. The numbering is incremented with
creation of new lines.
Lines Increment
Specifies the difference between numbers in the numbering sequence.
Curves Starting Number
Specifies the starting number for new curve tags to be created in the site. The numbering is incremented
with creation of new tags.
Curves Increment
Specifies the difference between numbers in the numbering sequence.
Spirals Starting Number
Specifies the starting number for new spiral tags to be created in the site. The numbering is incremented
with creation of new tags.
Spirals Increment
Specifies the difference between numbers in the numbering sequence.

Table Tag Renumbering
Lines Starting Number
Specifies the starting number for new line tags to be renumbered.
Lines Increment
Specifies the difference between numbers in the numbering sequence.
Curves Starting Number
Specifies the starting number for new curve tags to be renumbered.
Curves Increment
Specifies the difference between numbers in the numbering sequence.
Spirals Starting Number
Specifies the starting number for new spiral tags to be created on alignments in the site. The numbering
is incremented with creation of new tags.
Spirals Increment
Specifies the difference between numbers in the numbering sequence.
Related procedures:
■

Creating a Site (page 783)
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■

Editing Site Properties (page 784)

Select Text Component Dialog Box
Use this dialog box to select a label text component to override.
Text Component
Lists the text components in the label style. Select the component to override and click OK.
A check mark appears next to any component that has already been overridden.
Related procedures:
■

Overriding Label Text (page 1714)

Select Overridden Text Component Dialog Box
Use this dialog box to select an overridden text component in order to clear the overrides.
Text Component
Lists the overridden text components in the label style. Select one or more components and click OK.
You can use the Shift and Ctrl keys to select multiple components.
Related procedures:
■

Overriding Label Text (page 1714)

Expressions Dialog Box
Use this dialog box to set up mathematical expressions that you can insert into label styles.
For example, you can set up an expression for parcel segments that converts feet to meters:
{Segment Length} *.3084

For other examples, see Expression Examples (page 1728). For procedures, see Setting Up Expressions (page
1727).
Tips for creating expressions
■

Do not enter functions, constants, or logical operators inside the curly brackets that surround Properties
such as {Segment Length}.

■

Do not enter plain text, such as “meters” in expressions. You can add this text later when you set up a
label style that includes the expression.

To set up an expression, you can use the buttons in the dialog box, and the keypad on your keyboard. There
are menus in the dialog box from which you can choose Properties and functions to insert into the expression.
If you enter a combination of items that is invalid, you will receive a parse error when you click OK.
Name
Specifies a name for the expression. It is recommended that you use a clear naming convention such as
“Parcel line expression: Length in meters”. Expressions are listed by name along with all the other label
properties in the Label Style Text Component Editor.
Description
Specifies a description that appears in the Settings tab item list view.
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Editor Box
Displays the expression as defined from the functions and properties. You can also click in this box and
type characters such as numbers.
Calculator Buttons
Enter numbers and operators (page 1732)into the Editor box to define the expression.
Insert Property
Inserts a property into the expression. Click the icon to display a list of properties relevant to the expression
type. Select a property to insert it into the expression. These are the same Properties (page 1691) that are
available for label styles.
Properties are inserted inside brackets. Do not add operators or functions within these brackets.
Insert Function
Inserts a function into the expression. See Functions (page 1732) for more information.
Format Result As
Specifies how the expression results are formatted.
■

Double: This value is formatted using the Unitless type.
NOTE The following are all of type Double but are formatted according to the settings on the Ambient
Settings tab (page 2078) in the Drawing settings:

■

Angle

■

Area

■

Coordinate

■

Dimension

■

Direction

■

Distance

■

Elevation

■

Grade/Slope

■

Latitude

■

Longitude

■

Station

■

Volume

Functions and Operators
For a list of functions and operators supported in this dialog box, see Functions and Operators (page 1732)
Related procedures:
■

Expressions (page 1726)
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LandXML Dialog Boxes

Use the following links to access information about the AutoCAD Civil 3D LandXML dialog boxes.

Import LandXML Dialog Box
Use this dialog box to select the LandXML data to import into AutoCAD Civil 3D.
Alignments Site
Specifies a site for imported alignments. Select a site from the drop-down list or click
to select an object
(parcel, alignment, or grading) contained in the site to which you want to add the new objects.
NOTE The default selection is <None>, which places the alignments in the top-level Alignments collection in
Prospector. See Alignment and Site Interaction (page 781) for more information.
Parcels Site
Specifies a site for any imported parcels. Select a site from the drop-down list or click
to select an object
(parcel, alignment, or grading) contained in the site to which you want to add the new objects.
NOTE If no sites exist in the drawing, the objects are placed in a default site.
Edit LandXML Settings
Opens the LandXML Settings dialog box (page 2214).
Data Tree
Lists the LandXML header information for each data component that can be imported. Expand each of
the collections to display all of the subcomponents.
Select or clear the check boxes to the left of each data component name to filter the data that is imported
into AutoCAD Civil 3D. By default, all data components are selected for import.
NOTE The check boxes have a tri-state display. If only some items are selected under a collection, the check
box is shaded

. If all items are selected, the check box is selected

cleared, the check box for the collection is cleared

. If all items below the collection are

.

OK
Converts LandXML data into AutoCAD Civil 3D objects. Imports each object from the LandXML file into
the AutoCAD Civil 3D drawing using the name as specified in the LandXML file.

2213

Each object uses the appropriate creation behavior based on the command setting for the object being
imported. For example, if the Surface Default Style is set to High Altitude, any surfaces imported with this
operation will use the High Altitude style.
NOTE As each object is imported, the Event Viewer Vista (page 2753) dialog box can display the status of each
operation. For more information, see The Event Viewer Vista (page 1817).
Browse
Opens the Open dialog box. Select another LandXML file from which to import data.
Related procedures:
■

Importing LandXML Drawing Data (page 1883)

LandXML Settings Dialog Box
Use this dialog box to manage a variety of settings related to the LandXML import and export properties.

Import Tab (LandXML Settings Dialog Box)
Use this tab to define how data is imported from a LandXML file to AutoCAD Civil 3D.
You can set the data translation, rotation, and conversion settings. In addition, there are options to control
the import of point, surface, and pipe network data.

Translation
Translate
Specifies whether to translate data to new coordinates when importing the data from the LandXML file.
Select On to translate the data on import. For more information, see Translating and Rotating LandXML
Data (page 1881).
NOTE If Translate is set to Off, all other data translation options are unavailable.
Base Point Northing
Specifies the base point northing coordinate from which all import values are translated.
NOTE The units used for base point and translated values are set at the drawing level in the Ambient Settings
Tab (Drawing Settings Dialog Box) (page 2078).
Base Point Easting
Specifies the base point easting coordinate from which all import values are translated.
Base Point Elevation
Specifies the base point elevation from which all import values are translated.
Translated Coordinate Northing
Specifies the northing coordinate value used to translate data from the base point.
Translated Coordinate Easting
Specifies the easting coordinate value used to translate data from the base point.
Translated Coordinate Elevation
Specifies the elevation value used to translate data from the base point.
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Rotation
Rotate
Specifies whether to rotate data when importing it from the LandXML file. Select On to rotate the data
on import.
NOTE If Rotate is set to Off, all other data rotation options are disabled.
Angle
Specifies the angle about the base point where the LandXML data is rotated.
NOTE The angle units are set at the drawing level in the Ambient Settings Tab (Drawing Settings Dialog Box)
(page 2078).
Direction
Specifies the direction of rotation. Select this option to calculate the angle in a clockwise or
counter-clockwise rotation about the base point.

Point Import Settings
Point Description
Specifies how to map the ‘desc’ and ‘code’ attributes to the point descriptions:
■

Use “Code” Value: Uses the “code” attribute value for the point description.

■

Use “Desc” Value: Uses the “desc” attribute value for the point description.

■

Use “Code” Then “Desc”: Attempts to use the “code” attribute value for the point description. If a
point does not have a “code” attribute, the “desc” attribute value, if available, is used.

■

Use “Desc” Then “Code”: Attempts to use the “desc” attribute value for the point description. If a
point does not have a “desc” attribute, the “code” attribute value, if available, is used.

Surface Import Settings
Surface Data
Specifies how to import the data:
■

Quick Import: Imports the surface information as points. Creates a surface that has identical
northing/easting/elevation points as the surface definition in the LandXML file. However, the
triangulation may be different from the original surface.

■

Full Import: Imports both the points and the surface faces, if available. Creates the surface information
from the face edges and creates a surface that is identical to the surface definition in the LandXML
file.
NOTE If the LandXML surface you intend to import has only breaklines (for example, no other points and
faces definition data is present), the resulting AutoCAD Civil 3D surface is built from the breakline data.
However, the breaklines are not available for editing (that is, they do not appear in the Prospector tree).

Create Snapshot After Import
After importing surface data, a snapshot can automatically be created. By creating a snapshot after importing
a LandXML file, AutoCAD Civil 3D does not attempt to find and open the LandXML file each time the
surface is built. Select On to create a snapshot. For more information on snapshots, see Using Surface
Snapshots (page 732).
Create Source Data In Drawing
Imports the surface source data (breaklines, contours, points, and chains) into the drawing as 3D polylines
and points.
■

Breaklines, contours, and chains are created as 3D polylines.

Import Tab (LandXML Settings Dialog Box) | 2215

■

DataPoints are created as COGO points in a point group named <surface name>_DataPoints.

This data is created on the following layers prefixed with the surface name:
■

<surface name>_Breaklines

■

<surface name>_Contours

■

<surface name>_Chains

■

<surface name>_DataPoints_PntList3D

NOTE This data is not added to the surface definition in the Prospector tree. You can manually add it if desired,
or create a different surface from it for comparison purposes.

Pipe Network Import Settings
Parts List For Part Family Size Matching
Specifies the pipe network parts list that is used during import to match pipe network part types in a
LandXML file with pipe network part types in a AutoCAD Civil 3D parts list. Review these settings prior
to import to verify that settings are appropriate for your data. For more information, see Part Catalog and
Parts Lists (page 1380).
Match <Part Type> With:
Specify individual part types to use when importing pipe network parts from a LandXML file into AutoCAD
Civil 3D. Review these settings prior to import to verify that settings are appropriate for your data. You
may use the defaults, or click

to specify other parts in the Part Catalog dialog box.

Conflict Resolution Settings
Conflict Resolution
Specifies how objects with the same name are handled.
■

Skip: Does not import conflicting objects.

■

Update: On import, replaces unlocked drawing object with object in LandXML file.

■

Append: Imports conflicting objects but renames the imported copy using the default name format
that is specified in the feature settings.

Default Diameter Units
On import, AutoCAD Civil 3D reads the <LandXML>.<Units>.diameterUnits, and if they are defined, those
units are used for both pipes and structures. If units are not defined, the following unit settings are applied.
Either the Imperial or Metric diameter settings are applied, based on the defined
<LandXML>.<Units>.linearUnit in the file.
Imperial
Defines the default imperial pipe and structure diameter units that are applied when units are not specified
in the source LandXML file.
Metric
Defines the default metric pipe and structure diameter units that are applied when units are not specified
in the source LandXML file.
Related procedures:
■

Importing LandXML Drawing Data (page 1883)

■

Viewing and Editing LandXML Drawing Settings (page 1880)
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Export Tab (LandXML Settings Dialog Box)
Use this tab to define how data is exported from AutoCAD Civil 3D to a LandXML file.

Identification
Write Identification Elements
Specifies whether the identification properties are written to the LandXML file. Select On to write populated
identification properties to the LandXML file.
NOTE If Write Identification Elements is set to Off, all other identification options are disabled.
Creator
Specifies the creator of the LandXML file.
Email Address
Specifies the creator’s email address.
Company
Specifies the creator’s company.
Company URL
Specifies the company’s URL.

Data Settings
Imperial Units
Specifies how to tag LandXML data when working in Imperial units:
■

International Foot: Tags the data in the LandXML file as International feet.

■

Survey Foot: Tags the data in the LandXML file as Survey feet.

Angle/Direction Format
Specifies the units of the exported angles and directions:
■

Degrees Decimal (DDD.DDDDDD): Exports angles and directions as decimal degrees. Decimal degrees
express the minutes and seconds of an angle as its decimal equivalent. For example, 3°30'36" equals
3.51 decimal degrees.

■

Degrees Decimal dms (DDD.MMSSSS): Exports angles and directions using the degrees, minutes, and
seconds convention, in which the numbers after the decimal are read as minutes and seconds, not
decimal degrees. For example, 3°30'36" equals 3.303600.

■

Grads: Exports angles and directions using grads (where one grad equals 1/100 of a 90° angle, or 360°
= 400 grads).

■

Radians: Exports angles and directions using radians (where 2PI radians equals 360°).

NOTE Directions are always reported in azimuths. The LandXML schema does not support bearings.
Create Read-Only File
Specifies whether the LandXML file is created as a read-only file. This is done in two places: a tag is inserted
into the LandXML, and the operating system file attributes on the file are set to read only. Select On to
specify read only.

Point Export Settings
Code Attribute
Specifies the field that is used for the ‘code’ attribute in the LandXML file:
■

Disabled: Does not export the point description to a ‘code’ attribute.
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■

Raw Description: Exports a point raw description to the ‘code’ attribute.

■

Full Description: Exports a point full description to the ‘code’ attribute.

NOTE Typically you would export the raw description to the ‘code’ attribute. For more information, see Point
Description and Code Matching (page 1882).
Desc Attribute
Specifies the field that is used for the ‘desc’ attribute in the LandXML file:
■

Disabled: Does not export the point description to a ‘desc’ attribute.

■

Raw Description: Exports a point raw description to the ‘desc’ attribute.

■

Full Description: Exports a point full description to the ‘desc’ attribute.

NOTE Typically, you would export the full description to the ‘desc’ attribute. If you select Disabled for both
the Code Attribute and Desc Attribute, then no descriptions are exported. For more information, see Point
Description and Code Matching (page 1882).
Skip Full When Same As Raw
Specifies whether to export the full description if it is the same as the raw description:
■

On: Does not export the full description if it is the same as the raw description. For example, if the
raw and full descriptions are the same, then only one value is exported. This would occur when points
do not have defined description keys.

■

Off: Exports both values.

Export Point References
Specifies whether to export point references. Point references substitute a known point name instead of
using northing and easting coordinates. Select On to export point references.
For example, if the start point of a line element dose not have a point reference, it is written as follows:
<Start>5447.73530 4525.60643</Start>
If it has a point reference, it is written as follows:
<Start pntRef="371"></Start>
For more information, see Point Reference Export Options (page 1882).
Point Reference Tolerance
Specifies the tolerance value for point references.
For example, if you enter 0.001, only those points that are located within 0.001 units of the point of
interest (for example, a start point) are exported as references.
Export Description Keys
Specifies whether the description key definitions are exported. Select On to export all description key
definitions in the drawing. If there are description keys in the drawing, a message dialog box is displayed.

Surface Export Settings
Surface Data
Specifies how to export the surface data:
■

Points Only: Exports surface information as points. Creates a surface that has northing, easting, and
elevation points that are identical to the surface definition. However, the triangulation may be different
from the original surface.

■

Points and Faces: Exports both the points and the surface faces, if available. Creates the surface
information from the face edges and creates a surface that is identical to the surface definition.
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Watersheds
Specifies whether to export watershed information with the surface data. Select On to export watershed
information to the LandXML file.

Parcel Export Settings
Parcel Direction
Specifies the direction from the parcel start point for exporting parcel segments. Parcel segments are
exported in sequence in either a clockwise or counter-clockwise direction.
■

Clockwise: Exports parcel segments in a clockwise direction.

■

Counter-clockwise: Exports parcel segments in a counter-clockwise direction.

Alignment Export Settings
Export Cross Sections
When set to On, exports cross section data if sample lines are defined for the alignment.
Related procedures:
■

Exporting LandXML Drawing Data (page 1884)

■

Viewing and Editing LandXML Drawing Settings (page 1880)

Export To LandXML Dialog Box
Use this dialog box to select the data in the drawing to export in LandXML format.
This dialog box is used for exporting LandXML data as well as for generating LandXML-based reports.
Data Tree
Lists the AutoCAD Civil 3D data that you can export in LandXML format. Expand each of the collections
to display all of the subcomponents.
Select or clear the check box to the left of each feature name to filter the data that you want to export in
LandXML format.
NOTE The check boxes have a tri-state display. If only some items are selected under a collection, the check
box is shaded

. If all the items are selected, the check box is selected

are cleared, the check box for the collection is cleared

. If all the items below the collection

.

Specify LandXML Version
Specifies the LandXML schema version. Select from 1.0, 1.1, or 1.2.
Pick From Drawing
Specifies objects to export by selecting from the drawing.
NOTE If you access this dialog box by right-clicking a collection in the Prospector tree and selecting Export
LandXML, the Pick From Drawing button is not available.
OK
Converts AutoCAD Civil 3D objects to LandXML format and exports the LandXML data.
Related procedures:
■

Exporting LandXML Drawing Data (page 1884)
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Layers Dialog Boxes

62

Use the following links to access information about the dialog boxes for managing drawing layers.

Object Layer Dialog Box
Use this dialog box to specify default layers for drawing objects. For example, when changing the layer for
a point group in the Point Group Properties.
Base Layer Name
Displays the name of the layer to which the object is assigned in the Object Layers tab of the Drawing
Settings dialog box. Use the layer selection button to select a different layer.
Layer selection button
Opens the standard Layer Selection dialog box. You can select a layer to change the base layer for the
object. This button is disabled when the object layer settings (page 82) are locked.
Modifier
Specifies whether the layer name includes a text-string modifier, and if so, the location of the modifier:
■

None: No modifier.

■

Prefix: Modifier is added at the beginning of the layer name.

■

Suffix: Modifier is added at the end of the layer name.

Modifier Value
Specifies the text string to use as the modifier. You can enter an asterisk (*) to include the object name as
the modifier in the layer name and to put each named object on its own layer. For example, if C-ROAD
is the name specified for alignment layers and you add -* as a suffix, an alignment named overpass is
created on layer C-ROAD-OVERPASS.
Preview
Displays the final name of the layer for any newly created objects.
Related procedures:
■

Layers (page 73)
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Layer Selection Dialog Box
Use this dialog box to select the layer on which to create objects of the selected type. Click anywhere in the
row to select the layer, then click Apply.
When you select a layer from a source outside the current drawing, the layer is created in the current drawing.
If you select a layer that exists in the current drawing, a warning dialog box is displayed, where you can
overwrite the current layer definition or cancel the command.
Layer Source
Specifies the drawing that contains the layer. Select one of the open drawings.
Layer
Displays the name of the layer.
Color
Displays the color of the layer.
Linetype
Displays the linetype of the layer.
Lineweight
Displays the lineweight of the layer.
Plot
Displays whether the layer is plotted or not.
Plot Style
Displays the plot style of the layer.
New
Creates a layer using the Create Layer (page 2222) dialog box. This option is available only if the current
open drawing is selected for the Layer Source.

Create Layer Dialog Box
Use this dialog box to set the properties for the new layer.

Layer Properties
Layer Name
Specifies the layer name.
Color
Specifies the layer color.
Linetype
Specifies the layer linetype. Select a linetype from the drawing or from those defined in the drawing.
Lineweight
Specifies the layer lineweight.
Locked
Specifies whether the layer is locked. On a locked layer, you cannot select or modify objects.
On
Specifies whether the layer is visible.
Freeze
Specifies whether the layer is frozen or thawed. A frozen layer is not updated.
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Plot Style
Specifies the plot style.
Plot
Specifies whether the layer can be plotted.
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Lines and Curves Dialog
Boxes

63

Entity by Best Fit Dialog Box
Use this dialog box to create an AutoCAD, Alignment, or Profile entity by best fit. You can create the entity
from a series of AutoCAD Civil 3D points, AutoCAD points, existing entities, or by clicking on screen.
Use this dialog box to select the source objects from which you want to create a best fit entity. You may
create the following types of entities by best fit:

AutoCAD Entities
■

Line

■

Arc

■

Parabola

Alignment Entities
■

Fixed Line

■

Floating Line

■

Fixed Curve

■

Floating Curve

■

Free Curve

Profile Entities
■

Fixed Tangent

■

Floating Tangent

■

Fixed Vertical Curve

■

Floating Vertical Curve
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■

Free Vertical Curve

NOTE The From AutoCAD Points and From COGO Points input options are not available on the Parabola By Best
Fit dialog box.

Input Options
From COGO Points
Specifies that two or more COGO points or survey points will be used for best fit entity creation.
From AutoCAD Points
Specifies that two or more AutoCAD points will be used for best fit entity creation.
From Entities
Specifies that one or more existing lines, arcs, polylines, feature lines, survey figures, or profile objects
will be used for best fit entity creation.
By Clicking On The Screen
Specifies that the user will click points on screen for best fit entity creation.
Tessellate Arc Segments
Tessellates the selected sample arc segments.
Mid-Ordinate Tolerance
Specifies the mid-ordinate tolerance based on a distance across the tessellated arc segments. Enter a known
value or click

to select two points along a curve.

Related procedures:
■

Creating Entities by Best Fit (page 628)

■

Adding Lines, Curves, and Spirals to an Alignment (page 970)

■

Adding Tangents and Curves to a Layout Profile (page 1156)

Regression Data Vista (for Best Fit Entity Analysis)
Use this vista to view and edit the results of the best fit regression data.

Entity Property Tree
This tree lists attributes of the best fit entity. Attribute values cannot be edited.

Regression Points Toolbar
Copy to Text Editor
Copies the regression data to the text editor that is associated with AutoCAD.
Copy to Clipboard
Copies regression data to the clipboard with the appropriate formatting. This tool is useful for importing
the regression data into a spreadsheet.
Add More Points
Adds more regression points. This button launches the appropriate Create Object by Best Fit dialog box,
which allows you to select more points to include in the regression analysis.
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Delete Selected Points
Deletes selected points (rows) from the regression points table.
Undo
Reverses the last action.
Redo
Reverses the last undo command.
Out of Sync
Indicates that the best fit entity has been modified and its parameters do not match the best fit regression
data. Click this button to force the entity to match the original best fit regression data.
Empty Current Regression Sample Data
Resets the regression points table and leaves the Regression Data dialog box open. New points may be
added by clicking

.

Create Entity and Continue to Edit the Data
Creates the entity based on the data in the regression points table and leaves the Regression Data vista
open.
Dismiss this Vista
Creates the entity based on the data in the regression points table and closes the Regression Data vista.
Other vistas in Panorama remain open.
Display Help Topic
Opens the Regression Data Vista (for Best Fit Entity Analysis) help topic.
Close
Closes the Regression Data vista and all open vistas in Panorama. Hides temporary graphics in the drawing
window. Regression data and temporary graphics are saved and will reappear when the Best Fit command
is reentered.

Regression Points Table
Pt No.
Sequential number generated in the order in which the regression points were generated. Number is
adjusted if regression points are added or deleted.
Exclude
Specifies the regression points to exclude from the best fit analysis.
Pass Through
Specifies a regression point which the best fit entity must pass through. Only one pass-through point may
be selected for a line. Two pass-through points may be selected for an arc or parabola.
Point Northing
Regression point’s Northing value. This value may be edited.
Point Easting
Regression point’s Easting value. This value may be edited.
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Point Station
For best fit profile entities, the regression point’s station value. This value may be edited.
Point Elevation
For best fit profile entities, the regression point’s elevation value. This value may be edited.
Weight
Specifies the regression point’s preference in relation to other points. A higher value gives a point preference
over points with lower values. This value may be edited, but it must be greater than zero.
Offset to Entity
Specifies the distance of the regression point from the best fit entity.
Northing on Entity
Specifies the Northing ordinate from the best fit entity.
Easting on Entity
Specifies the Easting ordinate from the best fit entity.

Regression Graph
This graph displays the regression points’ relationship to the best fit entity. The red line represents the
regression points and the green line represents the best fit entity. Selecting a row in the Regression Points
table displays an X and dashed line in the graph to indicate the location of the selected point. The selected
point is also highlighted in the drawing window.
Related procedures:
■

Creating Entities by Best Fit (page 628)

Specify Station Range Dialog Box
Use this dialog box to specify a range of stations within a profile from which to sample data for a best fit
entity regression.
Start Station
Specifies the beginning station of the range from which to take the sample. To edit the start station, enter
a value or click

to select a location on the profile.

End Station
Specifies the ending station of the range from which to take the sample. To edit the end station, enter a
value or click

to select a location on the profile.

Related procedures:
■

Creating Entities by Best Fit (page 628)

Curve Calculator Dialog Box
Use this dialog box to calculate curve parameters from input.
NOTE To change the units used in the Curve Calculator dialog box, use the Ambient Settings tab of the Drawing
Settings dialog box. Under Angle, change the Format value to the unit you want to use. For more information,
see To specify ambient settings for a drawing (page 84).
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The following illustration shows the curve parameters used by AutoCAD Civil 3D.

Degree Of Curve Definition
Specifies whether the degree of curve will be based on the arc or the chord.
■

Chord Definition: Specifies that the degree of curve is determined by the chord. Use this option if the
curve is a railway curve. For a railway curve, the degree of curve is the angle at the center of a circular
curve subtended by a chord of 100 units.

■

Arc Definition: Specifies that the degree of curve is determined by the arc. Use this option if the curve
is a roadway curve. For a roadway curve, the degree of curve is the central angle subtended by a circular
arc of 100 units.
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The following illustration shows the degree of curve
definition for arcs and chords.

Fixed Property
Specifies which property to hold as fixed while performing calculations.
■

Radius: Specifies that the radius will be fixed.

■

Delta Angle: Specifies that the delta angle will be fixed.

Degree Of Curve
Specifies the degree of curve.
Delta Angle
Specifies the delta angle of the curve. This option is not adjustible if Delta Angle is specified as the Fixed
Property.
Radius
Specifies the radius of the curve. This option is not adjustible if Radius is specified as the Fixed Property.
Tangent Distance
Specifies the tangent length of the curve.
Arc Distance
Specifies the arc length of the curve.
Chord Distance
Specifies the chord length of the curve.

2230 | Chapter 63 Lines and Curves Dialog Boxes

External Distance
Specifies the external secant length of the curve.
Mid-ordinate Distance
Specifies the mid-ordinate length of the curve.

Sends the current value to the command line.

Optionally selects an arc in the drawing and displays its values in the calculator. No edits you subsequently
make in the calculator are updated in the drawing.
Related procedures:
■

Calculating Curve Parameters (page 639)
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Migration Dialog Box

64

Use the following link to access information about the AutoCAD Civil 3D Migration dialog box.

Import Data from Autodesk Land Desktop Project Dialog Box
Use this dialog box to convert and import data from an Autodesk Land Desktop project into an AutoCAD
Civil 3D drawing.
Land Desktop Project Path
Specifies the path of the Autodesk Land Desktop project containing the data that you want to import.
Enter a valid path or click

to browse to the location. For example, C:\Land Projects 2009.

Project Name
Specifies the name of the project that contains the data you want to import. After the path is specified,
select a project in the list.
Alignments Site
Specifies a site for any alignments that are being imported. Select a site from the drop-down list or click
to select an object (parcel, alignment, or grading object) contained in the site to which you want to
add the new alignments.
NOTE The default selection is <None>, which places the alignments in the Alignments (Centerline or
Miscellaneous Alignments) collection in Prospector. See Alignment and Site Interaction (page 781) for more
information.
Parcels Site
Specifies a site for any parcels that are being imported. Select a site from the drop-down list or click
to select an object (parcel, alignment, or grading object) contained in the site to which you want to add
the new parcels.
Overwrite Existing Data
Specifies whether existing data that already exists in the drawing is overwritten.
<details area>
Imports the specified data. Navigate to the desired data and select or clear the check boxes for one or more
import options:
■

Description Keys: Imports description keys.
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■

Surfaces: Imports surface data.

■

Alignments: Imports alignment data.

■

Profiles: Imports both EG and FG profile data.

■

Parcels: Imports parcel data.

■

Pipe Runs: Imports pipe data.

To iteratively import data, you can use the Apply button and check the messaging information.
For better results, import one data type at a time. To import points from Autodesk Land Desktop, use the
Import Point option of the Create Points command and select External Project Point Database as the
format type.
For more information about importing Autodesk Land Desktop data, see Tools for Moving Land Desktop
Data into AutoCAD Civil 3D.
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Parcels Dialog Boxes

65

Use the following links to access information about the Parcels dialog boxes.

Create Parcels - Layout Dialog Box
Use this dialog box to review settings that are applied to new parcels.
Site
Specifies the site for the new parcels.
Parcel Style
Specifies the parcel style for the new parcels.

Layers
Parcel Layer
Specifies the layer for the new parcels.
Parcel Segment Layer
Specifies the layer for the new parcel segments.

Label Styles
Area Label Style
Specifies the area label style for new parcels.
Line Segment Label Style
Specifies the line segment label style for new parcels.
Curve Segment Label Style
Specifies the curve segment label style for new parcels.
Automatically Add Segment Labels
Specifies whether to add segment labels while segments are created.
Erase Existing Entities
When creating parcels from objects, specifies whether to erase original objects after parcels are created.
When the Xref option is selected, this option is disabled.
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Related procedures:
■

Creating Parcels (page 879)

■

Default Settings for New Parcels (page 880)

Create Right of Way Dialog Box
Use this dialog box to offset parcel boundaries from both sides of an alignment.

Create Parcel Right Of Way
Offset From Alignment
Specifies the offset distance of each side of the right-of-way from the alignment.

Cleanup At Parcel Boundaries
Fillet Radius At Parcel Boundary Intersections
Specifies the fillet radius or chamfer distance at boundary intersections.
Cleanup Method
None: Specifies that no cleanup is used at parcel boundary intersections.
Fillet: Specifies that a fillet is used at parcel boundary intersections. A fillet connects the parcel boundaries
with an arc that is tangent to the boundaries and has a radius specified by Fillet Radius At Parcel Boundary
Intersections.
Chamfer: Specifies that a chamfer is used at parcel boundary intersections. A chamfer connects the parcel
boundaries with an angled line at a chamfer distance specified by Fillet Radius At Parcel Boundary
Intersections.

Cleanup At Alignment Intersections
Fillet Radius At Alignment Intersections
Specifies the fillet radius or chamfer distance at alignment intersections.
Cleanup Method
None: Specifies that no cleanup is used at alignment boundary intersections.
Fillet: Specifies that a fillet is used at alignment intersections. A fillet connects the alignment boundaries
with an arc that is tangent to the alignments and has a radius specified by Fillet Radius At Alignment
Intersections.
Chamfer: Specifies that a chamfer is used at alignment intersections. A chamfer connects the alignments
with an angled line at a chamfer distance specified by Fillet Radius At Alignment Intersections.
Related procedures:
■

Creating a Right of Way (page 888)

Edit Feature Settings - Parcel Dialog Box
Use this dialog box to view and change parcel-related settings.
This topic documents settings in all parcel-related Edit Settings dialog boxes (drawing-level, feature-level,
and command-level).
■

Drawing-level ambient settings are identified by the

■

Parcel feature settings are listed near the top of this dialog box, after the General property group, and
are identified by the

parcel icon.
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drawing icon.

■

Parcel command settings are identified by the

command icon.

For general information about drawing, feature, and command settings and their interaction, see Working
with the Standard Settings Dialog Box Controls (page 78).
For information about drawing-level ambient settings, see Ambient Settings Tab (Drawing Settings Dialog
Box) (page 2078)

Default Styles
Use these settings to specify default styles for creating and labeling parcels.
Parcel Style
Specifies the default parcel style. Click in the Value column, and click
Style dialog box.

to select a style in the Parcel

Parcel Area Label Style
Specifies the default parcel area label style. Click in the Value column, and click
the Parcel Area Label Style dialog box.

to select a style in

Parcel Line Label Style
Specifies the default parcel line label style. Click in the Value column, and click
Parcel Line Label Style dialog box.

to select a style in the

Parcel Curve Label Style
Specifies the default parcel curve label style. Click in the Value column, and click
the Parcel Curve Label Style dialog box.

to select a style in

For information about style selection, see Select Style Dialog Box (page 2021).

Table Creation
NOTE This property group is displayed when accessing the settings from the AddParcelCurveTable,
AddParcelLineTable, AddParcelSegmentTable, or AddParcelTable commands.
Use these settings to specify defaults for creating tables with parcels.
Table Style
Specifies the style for a table. Click in the Value column, and click
dialog box.

to select a style in the Table Style

Split Table
Specifies whether a table is split into two or more sections after a specified maximum number of rows has
been met.
Maximum Number of Rows
Specifies the maximum number of rows to include per section. If the number of data rows exceeds the
specified maximum, the table is split into sections, and they are displayed either side by side (left to right),
or stacked vertically.
Maximum Tables Per Stack
Specifies the maximum number of tables to include in each stack.
Table Spacing
Specifies the spacing between tables.
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Tile Direction
Specifies the direction in which the table tiles (Across or Down).

Default Options
NOTE This property group is displayed when accessing the setting from the AddParcelSegmentLabels command.
Use this setting to specify defaults for creating labels with parcel segments.
Labeling Direction
Specifies the segment labeling direction (Clockwise or Counter-clockwise).

Parcel Sizing
NOTE This property group is displayed when accessing the settings from the CreateParcelByLayout command.
Use these settings to specify defaults for sizing parcels.
Parcel Selection Method
Specifies whether the Pick Point Within Parcel or Select Parcel Area Label selection method is used.
Minimum Area
Specifies the minimum area for a new parcel.
Minimum Frontage
Specifies the minimum frontage (page 2774) for a new parcel.
Use Minimum Frontage At Offset
Specifies whether Use Minimum Frontage At Offset is used.
Frontage Offset
Specifies the frontage offset (page 2774) for a new parcel. Must be greater than zero.
Minimum Width
Specifies the Minimum width for a new parcel. Must be greater than or equal to zero.
Minimum Depth
Specifies the minimum depth for a new parcel.
Use Maximum Depth
Specifies whether maximum depth is used.
Maximum Depth
Specifies the maximum depth for a new parcel. Must be greater than or equal to zero.

Preview Graphics
NOTE This property group is displayed when accessing the settings from the CreateParcelByLayout command.
Use these settings to specify defaults for temporary parcel layout preview graphics.
Frontage Color
Specifies the default color for the frontage preview.
Frontage Offset Color
Specifies the default color for the frontage offset preview.
New Parcel Color
Specifies the default color for the new parcel preview.
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Minimum Frontage Color
Specifies the default color for the minimum frontage preview.
Minimum Width Color
Specifies the default color for the minimum width preview.
Minimum Depth Color
Specifies the default color for the minimum depth preview.

Automatic Layout
NOTE This property group is displayed when accessing the settings from the CreateParcelByLayout command.
Use these settings to specify defaults for automatic parcel layout.
Automatic Mode
Specifies whether the automatic mode is set for parcel layout.
Remainder Distribution
Specifies remainder from a new parcel is distributed:
■

Create Parcel From Remainder

■

Place Remainder In Last Parcel

■

Redistribute Remainder

Convert from Entities
NOTE This property group is displayed (in different forms) when accessing the settings from the
CreateParcelByLayout and CreateParcelFromEntities commands.
Use these settings to specify defaults for creation of parcels.
Erase All Existing Entities
Specifies whether existing entities are erased when a new parcel is created. (CreateParcelFromEntities
command only)
Auto Add Segment Label
Specifies whether segment labels are automatically added to a new parcel.

Create Parcel Right of Way
NOTE This property group is displayed when accessing the settings from the CreateParcelROW command.
Use this setting to specify default offset for creation of parcel rights of way.
Offset from Alignment
Specifies the offset from the alignment for the new right of way. Enter a width in the Value column or
click

and select a width in the drawing area.

Cleanup at Parcel Boundaries
NOTE This property group is displayed when accessing the settings from the CreateParcelROW command.
Use these settings to specify default offset for cleanup at parcel boundaries.
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Fillet Radius at Parcel Boundary Intersections
Specifies the width of the radius of the fillet at parcel boundary intersections. Enter a width in the Value
column or click

and select a width in the drawing area.

Cleanup Method
Specifies whether the cleanup method is Fillet, Chamfer, or None.

Cleanup at Alignment Intersections
NOTE This property group is displayed when accessing the settings from the CreateParcelROW command.
Use these settings to specify default offset for cleanup at alignment intersections.
Fillet Radius at Alignment Intersections
Specifies the width of the radius of the fillet at alignment intersections. Enter a width in the Value column
or click

and select a width in the drawing area.

Cleanup Method
Specifies whether the cleanup method is Fillet, Chamfer, or None.

Parcels
NOTE This property group is displayed when accessing the settings from the CreateSite command
Use these settings to specify default increments for parcel numbering.
Parcel: Next Automatic Area Counter
Specifies the increment by which the next new parcel area is automatically numbered.
Parcel: Next Manual Area Counter
Specifies the increment by which the next new parcel area is manually numbered.
Parcel Line: Next Automatic Tag Counter
Specifies the increment by which the next new parcel line tag is automatically numbered.
Parcel Line: Next Manual Tag Counter
Specifies the increment by which the next new parcel line tag is manually numbered.
Parcel Curve: Next Automatic Tag Counter
Specifies the increment by which the next new parcel curve tag is automatically numbered.
Parcel Curve: Next Manual Tag Counter
Specifies the increment by which the next new parcel curve tag is manually numbered.

Alignment
NOTE This property group is displayed when accessing the settings from the CreateSite command
Use these settings to specify default increments for alignment tag numbering.
Alignment Spiral: Next Manual Tag Counter
Specifies the increment by which the next new alignment spiral tag is manually numbered.
Alignment Spiral: Next Automatic Tag Counter
Specifies the increment by which the next new alignment spiral tag is automatically numbered.
Alignment Curve: Next Manual Tag Counter
Specifies the increment by which the next new alignment curve tag is manually numbered.
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Alignment Curve: Next Automatic Tag Counter
Specifies the increment by which the next new alignment curve tag is automatically numbered.
Alignment Line: Next Manual Tag Counter
Specifies the increment by which the next new alignment line tag is manually numbered.
Alignment Line: Next Automatic Tag Counter
Specifies the increment by which the next new alignment line tag is automatically numbered.

Feature Line
NOTE This property group is displayed when accessing the settings from the CreateSite command
Use this setting to specify defaults for feature line style priority.
Feature Line Style Priority
Specifies the default feature line style priority. Click in the Value column, and click
in the Options Tab (Feature Line Site Properties Dialog Box) (page 2137).

to select a style

Parcel Analysis
NOTE This property group is displayed when accessing the settings from the ExportParcelAnalysis command.
Use these settings to specify defaults for parcel analysis.
Analysis Type
Specifies whether Inverse Analysis or Mapcheck Analysis is used.
Enable Mapcheck Across Chord
Specifies whether mapcheck across chord is enabled or disabled.
Process Counter-clockwise
Specifies whether segments will be processed in counter-clockwise or clockwise order.
Related procedures:
■

Editing Parcel Settings (page 891)

■

Editing Parcel Command Settings (page 891)

Edit Parcel Properties Dialog Box
Use this dialog box to edit the properties of a group of parcels.
After specifying the parcel style, area label styles, and user-defined properties for one parcel, you can apply
them to all selected parcels.

General
Current Parcel
Displays the name of the selected parcel and highlights it in the drawing. Use the arrow keys to view or
edit the properties of other parcels.
Parcel Style
Specifies the parcel style. Editing a style only affects the currently selected parcel. Click
style to all selected parcels.

to apply the
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Area Selection Label Style
Specifies the Area Selection Label Style that is applied to the parcel. Click
to apply the area selection
label style to all selected parcels.
Specifies the current area label styles. Click to apply these area label styles to all selected parcels. If you
try to add a style that is already in the list, you are prompted to select another style. Click
area style label.

to add an

Click
to delete one or more area label styles. If you do not select at least one style in the list box, you
are prompted to select one. If there is only one area label style and you try to delete it, an error message
displays.
Area Label Styles
Specifies the Area Label Styles that are applied to the parcel. Click
to apply these area label styles to
all selected parcels.
Specifies the current area label styles. Click to apply these area label styles to all selected parcels. If you
try to add a style that is already in the list, you are prompted to select another style. Click
area style label.

to add an

Click
to delete one or more area label styles. If you do not select at least one style in the list box, you
are prompted to select one. If there is only one area label style and you try to delete it, an error message
displays.
User Defined Properties
Lists user-defined properties (page 920) in the parcel that you are editing. Only the value field can be edited.
Click
to apply the selected property to all selected parcels. If you do not select a property in the list
you are prompted to do so. Each parcel must have its own unique number, a parcel number cannot be
applied to other parcels.
Related procedures:
■

Editing Parcels by Layout (page 886)

■

Editing Parcel Properties (page 892)

Export Parcel Analysis Dialog Box
Use this dialog box to export multiple inverse or mapcheck parcel analysis reports to a chosen location.
NOTE To perform a Mapcheck Analysis on parcel labels, click General menu ➤ Mapcheck Analysis. For more
information, see Performing a Mapcheck Analysis (page 1796).
Destination File
Specifies the file name and the location to export the analysis report to. Enter the name and file path into
the edit box or click to browse to a location. The edit box will default to the last used location.

Analysis Type
Inverse Analysis
Specifies that Inverse analysis type is used for the parcel.
Inverse analysis provides a sequential report of directions and distances, start and end coordinates, curve
data for each parcel segment starting at a specified Point of Beginning (POB), and parcel area.
Mapcheck Analysis
Specifies that Mapcheck analysis type is used for the parcel.
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Mapcheck analysis provides the same information as Inverse analysis, except that all start and end
coordinates for each parcel segment are computed relative to the coordinates of the POB and the previous
segment, using the labeled precision of the parcel segment’s direction and distance/curve data. Therefore,
error is introduced and accumulated so that the coordinates of the last segment will not equal that of the
POB. This is termed ‘error of closure’. Mapcheck reports check the plotted drawing for omissions of segment
labels to avoid errors that may be introduced into legal documents, such as deed descriptions.
Enable Mapcheck Across Chord
Enables map check across chord. This setting is available only if Mapcheck Analysis is selected.
If mapcheck across chord is enabled, the Mapcheck traverse is calculated for curve segments using their
chord length. Otherwise, it is calculated using their curve length.
Process Segment Order Counter Clockwise
If selected, segments are processed in counter-clockwise order.
Related procedures:
■

Exporting a Parcel Inverse or Mapcheck Report (page 897)

Parcel Layout Parameters Dialog Box
Use this dialog box to change the properties of parcel segments.
Attributes displaying as black text can be edited. Areas that are dimmed (gray) are not available.
NOTE The constraint definition for each parcel subentity determines which parameters are displayed in the Parcel
Layout Parameters window.
You cannot dock the Parcel Layout Parameters dialog box. You can pin it, and resize the window.
Use the horizontal and vertical scroll bars when the list is longer or wider than the window.

General
Type
Specifies either Line or Curve as the entity type.
Constraint 1
Specifies either Fixed, Free, or Floating as the general constraint type.
Constraint 2
Specifies a detailed description of the entity constraints.

Geometry (Line)
Length
Specifies the line length.
Direction
Specifies the direction of the line.
Start Station
Specifies the starting station of the line for the parcel segment.
End Station
Specifies the end station of the line for the parcel segment.
Start Point
Specifies the XY coordinates for the start point of the line.
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End Point
Specifies the XY coordinates for the endpoint of the line.
Pass Through Point 1
Specifies the XY coordinates of the first user-specified pass-through point.
Pass Through Point 2
Specifies the XY coordinates of the second user-specified pass-through point.

Geometry (Curve)
Length
Specifies the length of the curve entity.
Radius
Specifies the radius of the curve entity.
Delta Angle
Specifies the included angle of the solved portion of the curve.
Start Station
Specifies the starting station of the curve for the solved portion of the alignment. Unsolved curves do not
display a start station.
End Station
Specifies the end station of the curve for solved portions of the alignment. Unsolved curves do not display
an end station.
Start Direction
Specifies the direction of the tangent coming into the curve.
End Direction
Specifies the direction of the tangent going out of the curve.
Start Point
Specifies the XY coordinates of the start point of the curve.
End Point
Specifies the XY coordinates of the endpoint of the curve.
Center Point
Specifies the XY coordinates of the center point.
Pass Through Point1
Specifies the XY coordinates of the first user-specified pass-through point.
Pass Through Point2
Specifies the XY coordinates of the second user-specified pass-through point.
Pass Through Point3
Specifies the XY coordinates of the third user-specified pass-through point.
Chord Length
Specifies the distance along the line joining the beginning of the curve (PC) and the end of the curve (PT).
Chord Direction
Specifies the direction along the line joining the beginning of the curve (PC) and the end of the curve
(PT).
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Mid-Ordinate
Specifies the distance from the midpoint of the curve, perpendicular to the midpoint of the chord.
External Tangent
Specifies the distance from the beginning of the curve (PC) to the PI or from the PI to the end of the curve
(PT).
External Secant
Specifies the radial difference from the PI to the midpoint of the curve.
PI Included Angle
Specifies the included angle between the incoming and outgoing tangents of the curve.
Related procedures:
■

Editing Parcels by Layout (page 886)

Parcel Layout Tools
Use this toolbar to access tools for working with parcel segments and setting parameters for parcel size.
Create Parcel
Opens the Create Parcels - Layout dialog box (page 2235) where you can change default parcel settings during
a layout session.

Lot Line Tools
Add Fixed Line - Two Points
Draws a lot line as a line segment. Click a starting point and an endpoint in the drawing.
Add Fixed Curve - Three Points
Draws a lot line as a curve segment. Define a starting point, pass-through point, and endpoint.
Add Fixed Curve - Two Points And Radius
Draws a lot line as a curve segment. Define a starting point, radius value, curve direction, and endpoint.
Draw Tangent-Tangent With No Curves
Draws a connected series of lot line segments. Click a sequence of points.

Parcel Sizing Tools
These tools precisely control the position of individual lot lines while respecting user-defined parameters.
The Parcel Sizing Tools create or edit attached lot lines.
Use either the Slide Line Create or Swing Line Create command in automatic mode to create a series of
evenly sized adjacent parcels. For manual layout, specify the new location for a lot line by picking a point
or dragging the line using OSNAP.
When Parcel Sizing parameters or Automatic Layout options are selected or specified, a corresponding preview
graphic displays at the bottom of the Parcel Layout Tools dialog box.
Slide Line - Create
Creates one or more new lot lines that you define with start and end points along the frontage, and
optionally, an angle relative to the frontage or an absolute direction for the lot line. Relative angles are
measured in + degrees, from 0 (toward the endpoint) through 180 (toward the start point). Note that 90
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degrees is perpendicular/radial to the frontage definition. Define the direction by means of azimuth,
bearing, or two points in the drawing.
Slide Line - Edit
Moves a lot line. You can retain or change the line’s frontage angle or absolute direction.
Swing Line - Create
Creates a lot line defined with start and end points along the frontage and a fixed swing point on the
opposite side of the parcel. Adjust the size of the parcel by swinging the lot line to intersect a different
point along the frontage, subject to a minimum area and frontage limit.
Swing Line - Edit
Moves a lot line by swinging it from one end. Select which end to use as the swing point.
Free Form Create
Creates a new lot line. Define an attachment point and a bearing, azimuth, or second attachment point.

PI Editing Tools
Insert PI
Inserts a vertex at the point you click on a parcel segment.
Delete PI
Deletes a vertex that you select on a parcel segment, and redraws the lot line between the vertices on
either side.
Break Apart a PI
Separates end points at the vertex you select. Specify a separation distance.
NOTE Breaking a PI does not delete or merge parcels, as deleting segments does. It merely makes parcels
incomplete. Affected segments revert to geometry elements, and parcel labels disappear. Geometry elements
become parcels again if you reconnect loose vertices to make closed figures.

Other Tools
Delete Sub-entity
Deletes a parcel subentity, such as a lot line or curve. If you delete a subentity that is not shared by another
parcel, the entire parcel is deleted. If you delete a shared subentity, the two parcels that shared it are
merged.
Parcel Union
Joins two adjacent parcels. The first parcel you select determines the identity and properties of the joined
parcel.
Dissolve Parcel Union
Restores the separate identiy of joined parcels.
Pick Sub-entity
Selects a parcel subentity for display in the Parcel Layout Parameters dialog box. Click Sub-entity Editor
before you click this button.
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Sub-entity Editor
Opens the Parcel Layout Parameters dialog box (page 2243) where you can review or edit attributes of the
selected parcel subentity.
Undo
Cancels the previous command.
Redo
Repeats the cancelled command.
Expand the Toolbar
Opens a property sheet where you can change parameters for new parcel sizing, automatic layout, and
manual layout.

Parcel Sizing Parameters
When a parcel sizing parameter is selected, a graphic displays to illustrate how the parameter affects the
result of the current parcel sizing command.
Minimum Area
Specifies the minimum area criteria for new parcels. This value can be changed at anytime during the
current command and must be greater than zero.
NOTE If the minimum frontage criteria is met, but the minimum area has not, the parcel frontage will be
increased until the minimum area is obtained.

Minimum Frontage
Specifies the minimum frontage criteria for new parcels.
NOTE If the minimum area criteria is met, but the minimum frontage has not, the parcel area will be increased
until the minimum frontage is obtained.
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Use Minimum Frontage At Offset
Enables/disables the use of the minimum frontage at offset during the parcel sizing commands. This value
can be changed at anytime during the current command.

Frontage Offset
Specifies the default value for the frontage offset.

Minimum Width
Sets the default value for Minimum width. This value must be greater than or equal to zero.

Minimum Depth
Specifies the minimum depth criteria used to size new or edit existing parcels. The minimum depth starts
at the mid-point of the resulting frontage of the new or edited parcel and is oriented normal (perpendicular)
to the intersected frontage segment.
NOTE If the minimum area and frontage criteria are met, but not the minimum depth, the frontage and area
are increased until the minimum depth is obtained. If no solution is found, a command prompt displays.
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Use Maximum Depth
Specifies whether the maximum depth criteria is used when creating or editing parcels.

Maximum Depth
Specifies the maximum depth criteria for a new or edited parcel.
NOTE If the minimum area and frontage criteria are met, and the maximum depth is exceeded, a command
prompt displays that no solution is found.
Multiple Solution Preference
In certain situations, multiple valid solutions may occur during the creation of new parcels. When multiple
valid solutions occur, you can specify which solution is displayed.
Use Shortest Frontage: Specifies that the solution with the shortest frontage is displayed.

Use Smallest Area: Specifies that the solution with the smallest area is displayed.
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Automatic Layout
Automatic Mode
Specifies whether automatic mode is enabled for parcel sizing commands.
On: Enables automatic mode.

Off: Disables automatic mode.

Remainder Distribution
Specifies the method of redistributing the remainder.
Create Parcel From Remainder: Creates a new parcel from the remaining area.

Place Remainder in Last Parcel: Places the remaining area in the last parcel.
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Redistribute Remainder: Redistributes the remaining area evenly to every parcel.

Related procedures:
■

Creating Parcels by Layout (page 881)

■

Editing Parcels by Layout (page 886)

■

Editing Subdivided Parcels (page 887)

Parcel Move To/Copy To Site Dialog Boxes
Use these common dialog boxes to move or copy parcels from one site to another.
The contents of an entire site, including alignments, grading groups, or parcels, can be moved or copied
together. For more information, see Move To Site dialog box (page 2599) and Copy To Site dialog box (page
2600).
Related procedures:
■

Move Objects to a Site (page 789)

■

Copy Objects to a Site (page 790)

Parcel Properties Dialog Box
Use this dialog box to change the properties of a single parcel.
You can edit parcel name, description, object style, label style, analysis, and user-defined properties.

Information Tab (Parcel Properties Dialog Box)
Use this tab to change a parcel, name, description, or style.
Name
Specifies the name of the parcel.
Description
Specifies the description of the parcel. Enter an optional description.
Object Style
Specifies the parcel style applied to the parcel.
Use Name Template In Parcel Style
Specifies whether the parcel name is based on the parcel style name template (page 2022).
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Selected: The parcel name is (re)set based on the parcel style name template. The Name field is disabled
for manual editing (the Name column is also disabled in List View (page 99)).
Cleared: Manually enter a parcel name in the Name field (You can also edit the Name column in the List
View (page 99)).
NOTE This manually entered name is not automatically updated with subsequent changes to the parcel number.
Show Tooltips
Controls whether tooltips are displayed for the object in the drawing (not over toolbar icons).
Related procedures:
■

Parcel Properties (page 892)

Composition Tab (Parcel Properties Dialog Box)
Use this tab to change a parcel area label style, or to view its area or perimeter.
Area Selection Label Style
Specifies the area selection label style that is applied to the parcel.

Parcel Statistics
Area
Displays the area of the parcel.
Perimeter
Displays the perimeter of the parcel.
Related procedures:
■

Editing Parcel Properties (page 892)

Analysis Tab (Parcel Properties Dialog Box)
Use this tab to change parcel analysis type, point of beginning, or segment process-order, or to view analysis
results.

Analysis
NOTE Analysis results are displayed in the Result Area, which is the lower portion of the dialog box.
Inverse Analysis
Specifies that Inverse analysis type is used for the parcel.
Inverse analysis provides a sequential report of directions and distances, start and end coordinates, curve
data for each parcel segment starting at a specified Point of Beginning (POB), and parcel area.
Mapcheck Analysis
Specifies that Mapcheck analysis type is used for the parcel.
Mapcheck analysis provides the same information as Inverse analysis, except that all start and end
coordinates for each parcel segment are computed relative to the coordinates of the POB and the previous
segment, using the labeled precision of the parcel segment’s direction and distance/curve data. Therefore,
error is introduced and accumulated so that the coordinates of the last segment will not equal that of the
POB. This is termed ‘error of closure’. Mapcheck reports check the plotted drawing for omissions of segment
labels to avoid errors that may be introduced into legal documents, such as deed descriptions.
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Enable Mapcheck Across Chord
This setting is available only if Mapcheck Analysis is selected.
If mapcheck across chord is enabled, the Mapcheck traverse is calculated for curve segments using their
chord length. Otherwise, it is calculated using their curve length.

Calculation Settings
Point Of Beginning
Specifies the parcel boundary’s initial node (start point of its initial segment).
Point of Beginning Selector
Selects a new point of beginning. Click the button and click a parcel node in the drawing.
Process Segment Order Counter Clockwise
Specifies that segments are processed in counter-clockwise order.

Result Area
(Not labeled) Displays analysis results in the lower portion of the dialog box.
Related procedures:
■

Parcel Properties (page 892)

User Defined Properties (Parcel Properties Dialog Box)
Use this tab to review or change user defined parcel properties.
Parcel Number
Specifies the number assigned to the parcel.
Parcel Address
Specifies the address of the parcel.
Parcel Tax ID
Specifies the Tax ID number assigned to the parcel.
NOTE The user-defined property classification cannot be defined here. It is set in the Site Parcel Properties dialog.
Related procedures:
■

Parcel Properties (page 892)

■

Editing Parcel Properties (page 892)

Parcel Styles Dialog Box
Use this dialog box to edit settings for parcel styles.

Information Tab (Parcel Styles Dialog Box)
Use this tab to change a parcel style name or description, or to review details, such as when the parcel style
was most recently modified.
Name
Specifies the name of the parcel style.
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Description
Specifies the description of the parcel style. Enter an optional description.
Created By
Displays the Windows login name of the person who created the parcel style.
Date Created
Displays the date and time the parcel style was created.
Last Modified By
Displays the Windows login name of the person who last modified the parcel style.
Date Modified
Displays the date and time the parcel style was modified.
For more information, see Information Tab (Style Dialog Box) (page 2017).
Related procedures:
■

Parcel Styles (page 894)

Design Tab (Parcel Styles Dialog Box)
Use this tab to change parcel style settings for fill distance or parcel name template (naming convention).
The fill distance defines the width of the filled area inside the parcel boundary. If the fill distance is observed,
the pattern fill is applied to the boundary area only.
Observe Fill Distance
Specifies whether the fill distance is observed. Select the check box to apply the fill to the boundary area
only; otherwise, the fill is applied to the entire parcel.
Fill Distance
Specifies the width of the boundary area.
Parcel Name Template
Displays the parcel name template. Click
enter values for the parcel name format.

to open the Name Template dialog box (page 2022). Select or

Related procedures:
■

Parcel Styles (page 894)

Display Tab (Parcel Styles Dialog Box)
Use this tab to specify parcel style settings which affect the following parcel segments or area fill: Layer,
Color, Linetype, LT Scale, Lineweight, and Visibility. For area fill, you can specify additional settings for a
hatch: Pattern, Angle, or Scale.
For more information, see Display Tab (Style Dialog Box) (page 2017).
Related procedures:
■

Parcel Styles (page 894)
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Summary Tab (Parcel Styles Dialog Box)
Use this tab to review Information or Design settings for a parcel style. You can copy this information to a
spreadsheet.
For more information, see Summary Tab (Style Dialog Box) (page 2020).
Related procedures:
■

Parcel Styles (page 894)

Renumber/Rename Parcels Dialog Box
Use this dialog box to renumber and/or rename parcels.
Parcel names using the parcel style name template (page 2022) (with the parcel number property) are updated
automatically.
The default Starting Number is inherited from Parcel: Next Manual Area Counter on the Numbering tab of
the Site Properties dialog box for the site you are working with. After you renumber a set of parcels, the site
retains the next available number.
Site
Specifies the site in which you are renumbering parcels.
Renumber
Specifies whether to renumber the selected parcels. The names of the parcels may or may not be dynamically
changed, depending on the other settings.
Starting Number
Specifies the next number that will be used for the selected parcel. If a duplicate number occurs, the
current parcel’s number and the duplicate parcel’s number are swapped.
Increment Value
Specifies the difference between numbers in the sequence.
Use Name Template In Parcel Style
Specifies whether the names of the selected parcels are obtained from the parcel style name template.
Selected: The parcel name is (re)set based on the parcel style name template.
Cleared: The parcel number will change and, depending on the current properties of the selected parcel,
the parcel name may update.
Rename
Specifies whether the selected parcels will be renamed.
Specify The Parcel Name
Manually enter the parcel name. Note that this hard-coded name is no longer the “dynamic” name that
updates if parcels are renumbered.
Click
to open the Name Template dialog box (page 2022). Select or enter values for the parcel name
format. The parameters specified are returned and displayed in the Specify The Parcel Name field.
Use Name Template In Parcel Style
Specifies that the names of the selected parcels will be reset using the specified parcel style name template.
Related procedures:
■

Renumbering Parcels (page 918)

■

Numbering Parcel Segments (page 919)
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Site Parcel Properties Dialog Box
Use this dialog box to change properties of a site parcel.

Composition Tab (Site Parcel Properties Dialog Box)
Use this tab to change a site parcel’s label style, to view its area or perimeter, or to change the display order
of parcels that it contains, including the site parcel itself.
Site Parcel Style
Specifies the style that is applied to the site parcel.
Site Area Label Style
Specifies the area label style that is applied to the site parcel.
Specifying <none> hides the site parcel’s area label.
Parcel Style Display Order
Specifies the display order of parcels within the site, including the site parcel itself, according to the styles
that are assigned to them.
The style highest in this list if first in the display order. Where parcels of two different styles share a
common segment, the segment appears in the style that is higher in the display order.
To change a style’s list position, select it. Click an Up or Down Arrow. You can also drag a style up or
down to a new position.

Parcel Statistics
Area
Displays the area of the site parcel.
Perimeter
Displays the perimeter of the site parcel.
User-defined property classification
Specifies the user-defined property classification (page 920) to use for the parcels in the site. User-defined
properties allow you to specify custom properties for parcels.
Related procedures:
■

Using Custom Properties with Parcels (page 920)

■

Changing Parcel Display Order (page 893)

■

Hiding or Showing Parcel Labels (page 909)

Analysis Tab (Site Parcel Properties Dialog Box)
Use this tab to change a site parcel’s analysis type, its point of beginning, its segment process-order, or to
view analysis results.

Analysis
NOTE Analysis results are displayed in the Result Area in the lower portion of the dialog box.
Inverse Analysis
Specifies that Inverse analysis type is used for the parcel.
Inverse analysis provides a sequential report of directions and distances, start and end coordinates, curve
data for each parcel segment starting at a specified Point of Beginning (POB), and parcel area.
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Mapcheck Analysis
Specifies that Mapcheck analysis type is used for the parcel.
Mapcheck analysis provides the same information as Inverse analysis, except that all start and end
coordinates for each parcel segment are computed relative to the coordinates of the POB and the previous
segment, using the labeled precision of the parcel segment’s direction and distance/curve data. Therefore,
error is introduced and accumulated so that the coordinates of the last segment will not equal that of the
POB. This is termed ‘error of closure’. Mapcheck reports check the plotted drawing for omissions of segment
labels to avoid errors that may be introduced into legal documents, such as deed descriptions.
Enable Mapcheck Across Chord
Enables map check across chord. This setting is available only if Mapcheck Analysis is selected.
If mapcheck across chord is enabled, the Mapcheck traverse is calculated for curve segments using their
chord length. Otherwise, it is calculated using their curve length.

Calculation Settings
Point of Beginning
Specifies the site parcel boundary’s initial node (start point of its initial segment).

Selects a new point of beginning. Click the button and click a site parcel node in the drawing.
Process Segment Order Counter Clockwise
If selected, segments are processed in counter-clockwise order.

Result Area
(Not labeled) Displays analysis results in the lower portion of the dialog box.
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Pipe Networks Dialog
Boxes

66

Use the following links to access information about the Pipe Networks dialog boxes.

Create Pipe Network By Layout Dialog Box
Use this dialog box to enter the initial pipe network creation parameters such as a name, optional description,
parts list, layer, and more.
Also, you can select a surface and/or an alignment to associate with the pipe network, as well as styles for
structure and pipe labels.
Network Name
Specifies the name of the pipe network. Each pipe network must have a unique name.

Opens the Name Template (page 2022) dialog box, where you can modify the pipe network naming template.
Network Description
Specifies an optional description for the pipe network.
Network Parts List
Specifies the parts list associated with this pipe network.
Layers
Opens the Pipe Network Layers (page 2301) dialog box, where you can assign various views of the pipe
network components to specific layers in the drawing.
Surface Name
Specifies the surface associated with this pipe network.
Alignment Name
Specifies the alignment associated with this pipe network.

Structure Label Style
Style List
Displays the current style. Click the arrow to display the structure label styles in the drawing.
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Style Selection
Specifies the style options. Create a new style, copy or edit the current style selection, or pick a style from
the drawing.
Style Detail
Opens the Style Detail dialog box, where you can preview the style and creation information.

Pipe Label Style
Style List
Displays the current style. Click the arrow to display the pipe label styles in the drawing.
Style Selection
Specifies the style options. Create a new style, copy or edit the current style selection, or pick a style from
the drawing.
Style Detail
Opens the Style Detail dialog box, where you can preview the style and creation information.
Related procedures:
■

Creating a Pipe Network Using the Layout Tools (page 1334)

Create Pipe Network From Object Dialog Box
Use this dialog box to create a pipe network from a drawing entity such as a line, polyline, arc, or feature
line.
Using this feature, you can select one of the following entity types in a drawing and create a pipe network
from it: line, 2D or 3D polylines, 2D spline polyline, arc, feature line.
You are prompted to enter the initial pipe network creation parameters, including a pipe network name,
description, parts list, layers, and more. Also, you can select a surface and/or an alignment to associate with
the pipe network.
When using this feature, if the selected parts list has a mismatch with the selected catalog, the OK button
is disabled, as well as the selector for the structure, where the structure types within the parts list have a
mismatch with the currently selected catalog. An error message will also be displayed informing you that
parts in the selected part list cannot be found in the current catalog. You are prompted to select a different
part list or to select the correct catalog.
Network Name
Specifies the name of the pipe network. Each pipe network must have a unique name.

Opens the Name Template (page 2022) dialog box, where you can modify the pipe network naming template.
Network Description
Specifies an optional description for the pipe network.
Network Parts List
Specifies the parts list associated with this pipe network.
Pipe To Create
Specifies the part that will be used to represent pipes in this pipe network.
Structure To Create
Specifies the part that will be used to represent structures in this pipe network.
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Layers
Opens the Pipe Network Layers (page 2301) dialog box, where you can assign various views of the pipe
network components to specific layers in the drawing.
Surface Name
Specifies the surface associated with this pipe network.
Alignment Name
Specifies the alignment associated with this pipe network.
Erase Existing Entity
Specifies whether the entity (object) you selected will be erased automatically when you create the pipe
network. Select the check box to erase the entity automatically when you create the pipe network.
NOTE This option is disabled when you select an object from an XREF.
Use Vertex Elevations
When this option is selected, the elevations of any vertexes along the selected entity are used to set the
elevations of the pipes created in the network. For 3D entity types, this option determines if the 3D vertex
elevations are honored by the pipes created. When selecting this option, rules are not applied, since they
would likely be in conflict with the vertex elevations.
Vertex Elevation Reference
Specifies the location on the pipe where the vertex elevation is located. The following options are available:
Outside Top, Crown, Centerline, Invert, Outside Bottom. The default is the pipe centerline. When you
select one of these options on the dialog box, a conceptual illustration is displayed on the right side of
dialog box, indicating the location on the pipe that is used for each option. For more information, see
Using Vertex Elevations (page 1336).
Related procedures:
■

Creating Pipe Networks from Objects (page 1335)

Create Alignment From Network Dialog Box
Use this dialog box to create an alignment by selecting parts within a pipe network.
You can optionally create a profile and profile view as you create the new alignment.
Site
Specifies a site for the alignment. Either select a site from the Site list or click
to select an object in the
drawing. The alignment and the object you select in the drawing are associated with the same site.
NOTE The default Site selection is <None>, which places the alignment in the top-level Alignments collection
in Prospector. See Alignment and Site Interaction (page 781) for more information.
Name
Specifies the name of the alignment. Each alignment style must have a unique name.
Description
Specifies an optional description for the alignment.
Starting Station
Specifies the start station for the alignment.
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Alignment Style
Style List
Displays the current style. Click the arrow to display the alignment styles in the drawing.
Style Selection
Specifies the style options. You can create a new style, copy or edit the current style selection, or pick a
style from drawing.
Style Detail
Opens the Style Detail dialog box. Preview the style and creation information.
Alignment Layer
Displays the layer on which the alignment object will be created. To change the layer click the Object
Layer icon and select a layer.
Object Layer
Opens the Object Layer dialog box. Click

to create a new layer on which the alignment will be drawn.

Alignment Label Set
Lists the alignment Label Set styles in the drawing. Use the Selection icon to change the current style or
create a new style. The Style Detail icon previews the current style.
Create Profile and Profile View
Specifies whether a profile and a profile view are created for the alignment. If you select this check box,
the Create Profile View dialog box (page 2397) is displayed.
Related procedures:
■

Creating Alignments from Pipe Network Parts (page 1338)

■

Creating Alignments (page 948)

Edit Feature Settings - Pipe Network Dialog Box
Use this dialog box to view and change pipe network-related settings.
This topic documents settings in all pipe network-related Edit Settings dialog boxes (drawing-level,
feature-level, and command-level).
■
■

Drawing-level ambient settings are identified by the

Pipe network feature settings are listed near the top of this dialog box, after the General property group,
and are identified by the

■

drawing icon.

pipe network icon.

Pipe network command settings are identified by the

command icon.

For general information about drawing, feature, and command settings and their interaction, see Working
with the Standard Settings Dialog Box Controls (page 78).
For information about drawing-level ambient settings, see Ambient Settings Tab (Drawing Settings Dialog
Box) (page 2078)

Default Styles
Use these settings to establish the default styles assigned to pipe network components.
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Interference Default Style
Specifies the default style for interference in the pipe network. Click in the Value column, and click
to select a style in the Interference Default Style dialog box.
Structure Default Style
Specifies the default style for structures in the pipe network.Click in the Value column, and click
select a style in the Structure Default Style dialog box.

to

Pipe Default Style
Specifies the default style for pipes in the pipe network. Click in the Value column, and click
a style in the Pipe Default Style dialog box.

to select

Interference Render Material
Specifies the default interference render material in the pipe network. Click in the Value column, and
click

to select a style in the Interference Render Material dialog box.

Structure Plan Label Style
Specifies the default style for structure labels that are displayed in plan view. Click in the Value column,
and click

to select a style in the Structure Plan Label Style dialog box.

Pipe Plan Label Style
Specifies the default style for pipe labels that are displayed in plan view. Click in the Value column, and
click

to select a style in the Pipe Plan Label Style dialog box.

Structure Profile Label Style
Specifies the default style for structure labels that are displayed in a profile view. Click in the Value column,
and click

to select a style in the Structure Profile Label Style dialog box.

Pipe Profile Label Style
Specifies the default style for pipe labels that are displayed in profile view. Click in the Value column, and
click

to select a style in the Pipe Profile Label Style dialog box.

Structure Section Label Style
Specifies the default style for structure labels that are displayed in a section view. Click in the Value
column, and click

to select a style in the Structure Section Label Style dialog box.

Pipe Section Label Style
Specifies the default style for pipe labels that are displayed in section view. Click in the Value column,
and click

to select a style in the Pipe Section Label Style dialog box.

Render Material
Specifies the default render material in the pipe network. Click in the Value column, and click
select a style in the Render Material dialog box.

to

Default Parts List
Specifies the default parts list for the pipe network. Click in the Value column, and click
style in the Default Parts List dialog box.

to select a

For information about style selection, see Select Style Dialog Box (page 2021).
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Default Name Format
Use these settings to specify the default name formats for pipe network components (pipe network, pipes,
structures). Click in the Value column, and click
(page 2022).

to make changes in the Name Template dialog box

Default Rules
Use these settings to establish the default rule set assigned to pipes and structures that are added to the pipe
network.
Structure Default Rules
Specifies the default rule set assigned to structures. Click in the Value column, and click
in the Structure Default Rules dialog box.

to select a set

Pipe Default Rules
Specifies the default rule set assigned to pipes. Click in the Value column, and click
the Pipe Default Rules dialog box.

to select a set in

Pipe Network Defaults
Use these settings to establish the default settings assigned to pipe networks when they are created.
Use Size Name From Part List as Description
Specifies the default method used to populate the Description field for newly created parts. When set to
No, the part family name, as it is specified in the part catalog, is used to populate the part Description
field. When set to Yes, the part size name, as it is specified in the parts list, is used to populate the part
Description field.

Storm Sewers Migration Defaults
Use these settings to establish the defaults for part matching, and the default parts list, used when migrating
pipe network data between the Storm Sewers Extension and AutoCAD Civil 3D.
Part Matching Defaults
Specifies the defaults used for part matching when migrating pipe network data between the Storm Sewers
Extension and AutoCAD Civil 3D. Click in the Value column, and click
to display the Part Matchup
Settings dialog box (page 2316) for importing and exporting. For more information, see Setting Part Matching
Defaults for Migration (page 1419).
Parts List Used For Migration
Specifies the default parts list used when migrating pipe network data between the Storm Sewers Extension
and AutoCAD Civil 3D. Click in the Value column, and click
see Setting the Default Parts List For Migration (page 1420).

to select a parts list. For more information,

Default Profile Label Placement
Use these settings to establish the default placement of profile view labels associated with the pipe network.
Dimension Anchor Option for Pipes
Specifies the location of the dimension line anchor for profile view labels for pipes:
■

Fixed

■

Above

■

Below

■

Graph View Top
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■

Graph View Bottom

Dimension Anchor Elevation Value for Pipes
Specifies the default elevation of the dimension line anchor for profile view labels for pipes. Enter an
elevation in the Value column or click

and select an elevation in the drawing area.

Dimension Anchor Plot Height Value for Pipes
Specifies the default plot height of the dimension line anchor for profile view labels for pipes. Enter a
height in the Value column.
Dimension Anchor Option for Structures
Specifies the location of the dimension line anchor for profile view labels for structures:
■

Fixed

■

Above

■

Below

■

Graph View Top

■

Graph View Bottom

Dimension Anchor Elevation Value for Structures
Specifies the default elevation of the dimension line anchor for profile view labels for structures. Enter an
elevation in the Value column or click

and select an elevation in the drawing area.

Dimension Anchor Plot Height Value for Structures
Specifies the default plot height of the dimension line anchor for profile view labels for structures. Enter
a height in the Value column.
Structure Label Placement
Specifies the default location of structure labels:.
■

At Top Of Structure

■

At Middle Of Structure

■

At Bottom Of Structure

Default Section Label Placement
Use these settings to establish the default placement of section view labels associated with the pipe network.
Dimension Anchor Option for Pipes
Specifies the location of the dimension line anchor for section view labels for pipes:
■

Fixed

■

Above

■

Below

■

Graph View Top

■

Graph View Bottom

Dimension Anchor Elevation Value for Pipes
Specifies the default elevation of the dimension line anchor for section view labels for pipes. Enter an
elevation in the Value column or click

and select an elevation in the drawing area.
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Dimension Anchor Plot Height Value for Pipes
Specifies the default plot height of the dimension line anchor for section view labels for pipes. Enter a
height in the Value column.
Dimension Anchor Option for Structures
Specifies the location of the dimension line anchor for section view labels for structures:
■

Fixed

■

Above

■

Below

■

Graph View Top

■

Graph View Bottom

Dimension Anchor Elevation Value for Structures
Specifies the default elevation of the dimension line anchor for section view labels for structures. Enter
an elevation in the Value column or click

and select an elevation in the drawing area.

Dimension Anchor Plot Height Value for Structures
Specifies the default plot height of the dimension line anchor for section view labels for structures. Enter
a height in the Value column.
Structure Label Placement
Specifies the default location of structure labels:
■

At Top Of Structure

■

At Middle Of Structure

■

At Bottom Of Structure

Pipe Section Label Placement
Specifies the default location of pipe labels displayed in section views:
■

At Top Of Structure

■

At Middle Of Structure

■

At Bottom Of Structure

Table Creation
NOTE This property group is displayed when accessing the settings from the AddNetworkPipeTable and
AddNetworkStructTable commands.
Use these settings to establish the defaults when you add a network pipe or structure table.
Table Style
Specifies the style for a table. Click in the Value column, and click
dialog box.

to select a style in the Table Style

Split Table
Specifies whether a table is split into two or more sections after a specified maximum number of rows has
been met.

2266 | Chapter 66 Pipe Networks Dialog Boxes

Maximum Number of Rows
Specifies the maximum number of rows to include per section. If the number of data rows exceeds the
specified maximum, the table is split into sections, and they are displayed either side by side (left to right),
or stacked vertically.
Maximum Tables Per Stack
Specifies the maximum number of sections to include in each stack.
Table Spacing
Specifies the spacing between tables.
Tile Direction
Specifies the direction in which the table tiles (across or down).

Label New Parts
NOTE This property group is displayed when accessing the settings from the CreateNetwork command.
Use these settings to establish the default labeling when you add parts to a network.
Pipe in Plan
Specifies whether a new pipe is labeled by default when placed in plan view.
Pipe Profile
Specifies whether a new pipe is labeled by default when placed in profile view.
Structure in Plan
Specifies whether a new structure is labeled by default when placed in plan view.
Structure Profile
Specifies whether a new structure is labeled by default when placed in profile view.
Related procedures:
■

Editing Pipe Network Settings (page 1343)

Edit Feature Settings - Pipe Dialog Box
Use this dialog box to view and change standard drawing ambient settings for pipe objects.
The standard ambient settings are preceded with
. For feature-specific pipe object setting information,
see Edit Feature Settings - Pipe Network Dialog Box (page 2262).
For more information about this dialog box, see Working with the Standard Settings Dialog Box Controls
(page 78).
Related procedures:
■

Editing Pipe Network Settings (page 1343)

Edit Feature Settings - Structure Dialog Box
Use this dialog box to view and change standard drawing ambient settings for structure objects.
The standard ambient settings are preceded with
. For feature-specific structure object setting information,
see Edit Feature Settings - Pipe Network Dialog Box (page 2262).
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For more information about this dialog box, see Working with the Standard Settings Dialog Box Controls
(page 78).
Related procedures:
■

Editing Pipe Network Settings (page 1343)

Network Layout Tools
Use this toolbar to create or edit a pipe network.
The names of the parts list, surface, and alignment referenced in the currently selected pipe network are
displayed at the bottom of this toolbar.

Pipe Network Properties
Opens the Pipe Network Properties (page 2269) dialog box, where you can control defaults and properties
of the pipe network, such as the referenced parts list, object references, label defaults, and more.
Select Surface
Opens the Select Surface dialog box, where you can specify the surface referenced by any new parts to be
added to the network. When a surface is selected, it is used to determine depths and elevations of pipe
network parts, based on rules for the part. If there are no surfaces in the drawing, this button is not
available. Changes made to this selection will not affect parts already created in the pipe network.
Select Alignment
Opens the Select Alignment dialog box, where you can specify the alignment referenced by any new parts
to be added to the network. If there are no alignments in the drawing, this button is not available. Changes
made to this selection will not affect parts already created in the pipe network. The alignment provides
station offset values for the pipe network parts, including the default alignment for labels.
Parts List
Opens the Select Parts List dialog box, where you can specify the parts list referenced by the current pipe
network. The parts list controls the set of pipes and structures that are available to add in the current pipe
network.
Structure List
Specifies the type of structure currently selected for insertion into this pipe network.
Pipe List
Specifies the type of pipe currently selected for insertion into this pipe network.
Drawing Commands
This drop-down button lets you specify whether to insert both pipes and structures, only pipes, or only
structures.
When Pipes And Structures mode is selected, a structure is inserted at the first selection point, followed
by a pipe. Subsequent selection points continue to insert structures connected to pipes.
When Pipes Only mode is selected, you are prompted to select the start and end points for each pipe
you insert. You can only insert pipes in this mode.
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When Structures Only mode is selected, you are prompted to select the insertion points for each
structure you insert. You can only insert structures in this mode.
NOTE The initial default command is Pipes and Structures. The initial prompt is Specify the structure
insertion point: When reopening the toolbar, the default command is the last command that was used.
Toggle Upslope/Downslope
Specifies whether the slope of the pipe network is upstream or downstream. This button acts as a toggle.
When
is displayed, the pipe network slope attribute is set to downslope. When is
slope attribute is set to upslope. This also ensures that pipe rules are processed correctly.

displayed the

Delete Pipe Network Object
Deletes the specified pipe network part from the drawing.
Pipe Network Vistas
Opens the Panorama window (page 119). Lets you display and edit the pipe network data in vistas. There
is a vista for pipe object data and a vista for structure object data. For more information, see Pipe Network
Vistas (page 2302).
Undo
Reverses the last action.

Pipe Network Properties Dialog Box
Use this dialog box to change the pipe network name, description, default settings, layers, labels, and settings
for profile and section views.
You can change the style, parts list, surface, alignment, or layers of a selected pipe network. You can also
change style and layers for how the pipe network is displayed in profile and section views.

Information Tab (Pipe Network Properties Dialog Box)
Use this tab to view or change general information for the pipe network.
Name
Specifies the name of the current pipe network.
Description
Specifies the description for the current pipe network.
Show Tooltips
Specifies whether tooltips are displayed for the object in the drawing (not over toolbar icons).

Layout Settings Tab (Pipe Network Properties Dialog Box)
Use this tab to view and edit the default parameters used for the current pipe network during layout (plan
view) mode.
The parameters include labels, parts list, layers, and name templates.

Labels
Structure Plan Label Style
Specifies the label style used for structures inserted into this pipe network during layout (plan view) mode.
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Pipe Plan Label Style
Specifies the label style used for pipes inserted into this pipe network during layout (plan view) mode.

Network Parts List
Parts List
Specifies a parts list for this pipe network. Use the parts list to select parts (pipes and structures) that can
be inserted into the current pipe network. For more information, see Part Catalog and Parts Lists (page
1380).

Default Object Reference
Surface Name
Displays the name of the surface that is referenced by this pipe network. The surface provides elevation
data to the pipe network objects. Changing the referenced surface from this dialog does not affect any
existing pipe network objects. It only affects those created after the change is made.
Alignment Name
Displays the name of the alignment that is referenced by this pipe network. The alignment provides
station and offset data to the pipe network objects. Changing the referenced alignment from this dialog
does not affect any existing pipe network objects. It only affects those created after the change is made.

Default Network Layers
Pipe Plan Layer
Specifies the default layer used when creating pipe objects within this pipe network. After the pipe object
is created, you can change the layer using any of the standard AutoCAD layer features.
Structure Plan Layer
Specifies the default layer used when creating structure objects within this pipe network. After the structure
object is created, you can change the layer using any of the standard AutoCAD layer features.

Name Templates
Pipes
Specifies the object name template used when creating pipe objects within this pipe network.
Structures
Specifies the object name template used when creating structure objects within this pipe network.

Profile Tab (Pipe Network Properties)
Use this tab to set default label styles and layers for the pipe network objects when they are displayed in a
profile view.

Labels
Structure Profile Label Style
Specifies the label style used to display the structures within this pipe network in a profile view.
Pipe Profile Label Style
Specifies the label style used to display the pipes within this pipe network in a profile view.

Default Profile Layers
Pipe Profile Layer
Specifies the default layer used to display the pipes within this pipe network in a profile view.
Structure Profile Layer
Specifies the default layer used to display the structures within this pipe network in a profile view.
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Section Tab (Pipe Network Properties)
Use this tab to set the default layer for the pipe network objects when they are displayed in a section view.

Default Section Layers
Network Section Layer
Specifies the default layer used to display this pipe network in a section view.

Statistics Tab (Pipe Network Properties Dialog Box)
Use this tab to display pipe network statistics that are based on the current state of the pipe network.

General
Displays the general statistics for the current pipe network.
Minimum Elevation
Displays the minimum elevation value found in the pipe network.
Maximum Elevation
Displays the maximum elevation value found in the pipe network.

Pipes
Total Number of Pipes
Displays the total number of pipes in this pipe network.

Structures
Total Number of Structures
Displays the total number of structures, including null structures, in this pipe network.
Inlet-Outlet Structure
Displays the total number of inlet/outlet structures in this pipe network.
Junction Structure
Displays the total number of junction structures in this pipe network.
Null Structures
Displays the total number of null structures in this pipe network.

References
Alignments
Displays the total number of alignments referenced in this pipe network.
Surfaces
Displays the total number of surfaces referenced in this pipe network.

Network Parts List Dialog Box
Use this dialog box to create a new pipe network parts list, or to view or change the properties and/or contents
of a parts list.

Information Tab (Network Parts List Dialog Box)
Use this tab to view or change general information for the pipe network parts list.
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Name
Specifies the name of the current parts list.
Description
Specifies the description for the current parts list.

Pipes Tab (Network Parts List Dialog Box)
Use this tab to view or change the pipe sizes included in the parts list.
You can add new pipe sizes to the parts list or remove pipe sizes from the parts list. Each size selection
matches a part size from a part family in the part catalog. Optional properties may also be set on the part
size. The combined set of selected and optional properties is assigned to the pipe when it is inserted into
the drawing.
Name
This tree view displays the name of the parts list at the top level, and then the names of the part families
included in the parts list, and then the names of the part sizes included in each part family. Note when
a new size is added to the parts list, it is assigned a default unique name. The size name can be edited
(renamed) to any unique name within the part family size list.
Style
Specifies the default style assigned to the pipe when it is inserted into the drawing. Select a part family
and click the Select All Edit icon

to assign the selected style to all part sizes within that family.

Rules
Specifies the default rules assigned to the pipe when it is inserted into the drawing. Select a part family
and click the Select All Edit icon

to assign the selected style to all part sizes within that family.

Render Material
Specifies the default render material assigned to the pipe when it is inserted into the drawing. Select a
part family and click the Select All Edit icon
family.

to assign the selected style to all part sizes within that

Pay Item
Specifies the pay item ID assigned. Select a part family, or a part size within a part family, and then click
to assign a pay item to all part sizes within that family, or to an individual part size within that family.
For more information, see Assigning Pay Items to Pipe Networks (page 1302).

Structures Tab (Network Parts List Dialog Box)
Use this tab to view or change the structure sizes included in the parts list.
You can add new structure sizes to the parts list or remove structure sizes from the parts list. Each size
selection matches a part size from a part family in the part catalog. Optional properties may also be set on
the part size. The combined set of selected and optional properties is assigned to the structure when it is
inserted into the drawing.
Name
This tree view displays the name of the parts list at the top level, and then the names of the part families
included in the parts list, and then the names of the part sizes included in each part family. Note when
a new size is added to the parts list, it is assigned a default unique name. The size name can be edited
(renamed) to any unique name within the part family size list.
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Style
Specifies the default style assigned to the structure when it is inserted into the drawing. Select a part family
and click the Select All Edit icon

to assign the selected style to all part sizes within that family.

Rules
Specifies the default rules assigned to the structure when it is inserted into the drawing. Select a part family
and click the Select All Edit icon

to assign the selected style to all part sizes within that family.

Render Material
Specifies the default render material assigned to the structure when it is inserted into the drawing. Select
a part family and click the Select All Edit icon
family.

to assign the selected style to all part sizes within that

Pay Item
Specifies the pay item ID assigned. Select a part family, or a part size within a part family, and then click
to assign a pay item to all part sizes within that family, or to an individual part size within that family.
For more information, see Assigning Pay Items to Pipe Networks (page 1302).

Summary Tab (Network Parts List)
Use this tab to view information and statistics related to the part list.

Information
Displays general information about the current parts list.

Statistics
Number of Pipes
Displays the total number of pipes in this parts list.
Number of Structures
Displays the total number of structures in this parts list.

Part Catalog Dialog Box
Use this dialog box to view the contents of the part catalog and to select the items you want to add to a
parts list.
The tree view in the left pane displays the available part types in the part catalog. Parts are organized by
type (for example, “Catch Basins”), and then by part family (“Concentric Catch Basin 1”). If you access the
Part Catalog dialog box from the Pipes tab of the Network Parts List dialog box, only available pipe part
families are displayed. Similarly, if you access the Part Catalog dialog box from the Structures tab of the
Network Parts List dialog box, only available structure part families are displayed.
When a part family is selected in the left pane, a preview image of the part shape is displayed in the right
pane.
NOTE Items that are already included in the current parts list are not displayed in the part catalog. Only items
that are available to be added to the parts list are displayed in the catalog.
Related procedures:
■

Creating a Parts List (page 1381)
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Pipe Rule Set Dialog Box
Use this dialog box to view or edit the set of rules that can be assigned to pipes in a pipe network.

Information Tab (Pipe Rule Set Dialog Box)
Use this tab to view or edit basic information about this pipe rules set.
You can view or edit the name and optional description values, and you can view information about when
the rule set was created and last modified.

Rules Tab (Pipe Rule Set Dialog Box)
Use this tab to view or edit the rules included in this set of pipe rules.
You can change values of existing rules, add rules, or delete rules. You can also change the order in which
rules are processed by changing the order they appear on this dialog. For more information, see Part Rules
(page 1390).
NOTE Rules are not applied to pipes or structures when importing pipe networks from either LandXML or from
the Storm Sewers Extension.

Add Rule
Click this button to display the Add Rule dialog box (page 2307) where you can select a new rule to add to
this rule set.

Delete Rule
You can remove a rule from the rule set by selecting the rule on this dialog box and clicking this button.

Up and Down Arrow Buttons
You can change the order in which rules are processed by changing the order they appear on this
dialog. Rules are processed sequentially, starting from the rule displaying at the bottom of this dialog box,
and ending with the rule displayed at the top of this dialog box.

Cover And Slope
This rule ensures that a pipe slopes appropriately and warns when a pipe is placed too close to a ground
surface. For more information, see Cover And Slope Rule (page 1394).
Maximum Cover
Specifies the maximum cover of soil over the length of the pipe, based on the surface being referenced
by that pipe. If the maximum cover is exceeded, a rule violation occurs. Note that this parameter provides
validation only; it does not alter (move or resize) the part in the drawing in any way. It simply produces
a rule violation on the part if the specified value is exceeded.
Maximum Slope
Specifies the maximum slope of the pipe, expressed in percent. If the pipe slope is greater than the
maximum, a rule violation occurs for that object.
Minimum Cover
Specifies the minimum cover of soil over the pipe, based on the surface being referenced by that pipe.
During layout, a pipe will be created that attempts to maintain the minimum cover. This is also used to
determine the initial elevations of the pipe. If the pipe is edited so that its cover is less than the minimum
cover value, a rule violation occurs for that object.
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Minimum Slope
Specifies the minimum slope of the pipe, expressed in percent. During layout, a pipe will be created
according to its minimum slope rule value. If the pipe is edited so that its slope is less than the minimum,
you can still edit the pipe as desired, breaking the minimum slope rule, but a rule violation occurs for
that object.

Cover Only
This rule is intended for laying out pipes in a pressure-based pipe network where pipe elevations are
determined according to a specified depth below a terrain. This rule ensures that the minimum cover is met
along the length of the pipe, and also validates that both the minimum and maximum cover values are not
violated along any length of the pipe. For more information, see Cover Only Rule (page 1395).
Maximum Cover
This is the maximum cover of soil over the pipe, based on the surface being referenced by that pipe. If
the pipe cover exceeds the maximum cover value, a rule violation occurs for that object. Note that this
parameter provides validation only; it does not alter (move or resize) the part in the drawing in any way.
It simply produces a rule violation on the part if the specified value is exceeded.
Minimum Cover
This rule represents the minimum cover of soil over the pipe, based on the surface being referenced by
that pipe. During layout, a pipe will be created that attempts to maintain the minimum cover. If the pipe
is edited so that its cover is less than the minimum cover value, a rule violation occurs for that object.

Length Check
This rule governs the behavior that produces a warning condition on a pipe if the pipe length exceeds the
value specified for the maximum pipe length, or is less than the value specified for the minimum pipe length.
For more information, see Length Check Rule (page 1395).
Maximum Length
Specifies a maximum length for pipes. When this rule is in use, you can still draw pipes that exceed the
defined maximum pipe length. However, the object will be displayed with a warning icon in the Prospector
list view. Note that this parameter provides validation only; it does not alter (move or resize) the part in
the drawing in any way. It simply produces a rule violation on the part if the specified value is exceeded.
Minimum Length
Specifies a minimum length for pipes. When this rule is in use, you can still draw pipes that are shorter
than the defined minimum pipe length. However, the object will be displayed with a warning icon in the
Prospector list view. Note that this parameter provides validation only; it does not alter (move or resize)
the part in the drawing in any way. It simply produces a rule violation on the part if the specified value
is not met.

Pipe To Pipe Match
This rule governs how a pipe elevation is determined in a pipe network that contains only pipes (no structures),
and or when a pipe is inserted onto an existing pipe to break the pipe. For more information, see Pipe To
Pipe Match Rule (page 1396).
Match Location
This parameter controls whether the inserted pipe holds to the pipe’s invert, crown, or centerline elevation
(location).
Drop Value
The drop value on a structure can determine a pipe’s depth.

Pipe Properties Dialog Box
Use this dialog box to view or change the properties of a pipe object.
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You can change the name of the pipe object, description, style, render material, and more. You can also
change part properties and rules.
When you add a pipe to a pipe network, much of the information about the pipe, such as its description
and properties, is derived from the definition of the pipe in the part catalog. After the pipe is inserted into
a drawing, you can make changes using this dialog box. When you make changes to the pipe, these changes
apply only to the selected pipe in your drawing. The pipe definition in the part catalog is not affected by
your modifications in the drawing.
For descriptions of part properties, see Part Properties (page 1378).

Information Tab (Pipe Properties Dialog Box)
Use this tab to change the name, description, and style information for the pipe.
Name
Specifies the name of the current pipe.
Description
Specifies an optional description of the current pipe.
Object Styles
Specifies the pipe style. Select other styles from the list.
Style
Specifies the style options. Click to create a new style, copy or edit the current style selection, or pick a
style from drawing. Click
creation information

to open the Style Detail dialog box, where you can preview the style and

Render Material
Specifies the default render material assigned to the pipe when it is inserted into the drawing. Click
to select a render material from the drawing.
Show Tooltips
Controls whether or not tooltips are displayed for the object in the drawing.

Part Properties Tab (Pipe Properties Dialog Box)
Use this tab to view or edit properties associated with this pipe.
This tab displays the properties associated with this pipe, along with their current values. Pipe properties
define a variety of characteristics of the pipe object, including its basic size and shape, and certain behaviors
such as flow direction and conditions under which the pipe part will automatically adjust its size.
Certain properties are specific to a type of pipe. For example, circular shaped pipes use the Inner Pipe Diameter
property while rectangular shaped pipes use the Inner Pipe Width and Inner Pipe Height properties.
Some properties are read-only and others are editable. To change an editable property, double-click on the
Value field and enter in a new value, or select one from the list. For more information, see Part Properties
(page 1378).

General
These properties specify general characteristics of the pipe, such as the flow direction method, flow direction,
and the surface and alignment referenced.
Pipe Flow Direction Method
Specifies the method that is used to determine the flow for this pipe. Option are bi-directional, start to
end, end to start, or according to the current slope of the pipe.
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Flow Direction
Specifies the current flow direction of the pipe, relative to the start and endpoint of the pipe. When you
begin drawing a pipe, the flow direction is based on the direction in which you draw the pipe.
Reference Surface
Specifies the surface of the pipe.
Reference Alignment
Specifies the alignment of the pipe.

Geometry
These properties specify characteristics such as the names of the start and end structures, bearing, station
data, offsets, slope data, elevation data, and more.
Pipe Start Structure
Specifies the name of the structure connected to the start of the pipe.
Pipe End Structure
Specifies the name of the structure connected to the end of the pipe.
Bearing
Specifies pipe’s bearing.
Pipe Start Station
Specifies pipe’s start station.
Pipe End Station
Specifies pipe’s end station.
Start Offset
Specifies the offset for the start of the pipe.
End Offset
Specifies the offset for the end of the pipe.
Pipe Slope (Hold Start)
Specifies the slope of the pipe away from the pipe’s start point.
Pipe Slope (Hold End)
Specifies the slope of the pipe away from the pipe’s end point.
Pipe Slope
Specifies the pipe’s slope in absolute value.
Start Invert Elevation
Specifies the pipe’s starting point elevation according to the pipe’s invert.
End Invert Elevation
Specifies the pipe’s ending point elevation according to the pipe’s invert.
Start Crown Elevation
Specifies the pipe’s starting point elevation according to the pipe’s crown.
End Crown Elevation
Specifies the pipe’s ending point elevation according to the pipe’s crown.
Pipe Start Easting
Specifies the easting of the pipe’s starting point.
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Pipe Start Northing
Specifies the northing of the pipe’s starting point.
Pipe End Easting
Specifies the easting of the pipe’s ending point.
Pipe End Northing
Specifies the northing of the pipe’s ending point.
Start Centerline Elevation
Specifies the pipe’s starting point elevation according to the pipe’s centerline.
End Centerline Elevation
Specifies the pipe’s ending point elevation according to the pipe’s centerline.
Minimum Cover
Specifies the minimum depth of cover along the entire length of pipe, from the top outside of the pipe
to the reference surface.
Maximum Cover
Specifies the maximum depth of cover along the entire length of pipe, from the top outside of the pipe
to the reference surface.
2D Length - Center To Center
Specifies the two-dimensional length of the pipe, measured from the center of the connected starting
structure to the center of the connected ending structure.
3D Length - Center To Center
Specifies the three-dimensional length of the pipe, measured from the center of the connected starting
structure to the center of the connected ending structure.
2D Length - To Inside Edges
Specifies the two-dimensional length of the pipe, measured from the inside edge of the connected starting
structure to the inside edge of the connected ending structure.
3D Length - To Inside Edges
Specifies the three-dimensional length of the pipe, measured from the inside edge of the connected starting
structure to the inside edge of the connected ending structure.

Resize Behavior
This property specifies the pipe behavior that occurs when the pipe is automatically resized.
On Resize, Hold
Specifies if the pipe will hold its invert, crown, or centerline elevation when the pipe is automatically
resized due to an edit.

Part Data
These properties specify a variety of part characteristics, such as part type, part subtype, and the part size
name as defined in the part catalog. Some of these properties specify the dimensions that define the part’s
basic shape and therefore are read-only.
Part Type
Specifies pipe’s part type.
Part Subtype
Specifies pipe’s subtype.
Part Description
Specifies pipe’s description.
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Part Size Name
Specifies the part size name.
Cross Sectional Shape
Specifies the pipe’s cross sectional shape, such as circular, egg-shaped, elliptical, or rectangular.
Wall Thickness
Specifies the wall thickness for this pipe, measured from the inside edge of the pipe to the outside edge
of the pipe.
Material
Specifies the material defined for this part. This optional property is used mainly for labeling purposes.
It allows you to identify the type of material used to construct this part.
Minimum Curve Radius
Specifies the minimum curve radius for this part.
Manning Coefficient
This optional property specifies a Manning Coefficient value for a given part size.
Hazen Williams Coefficient
This optional property specifies a Hazen Williams Coefficient value for a given part size.
Darcy Weisbach Factor
This optional property specifies a Darcy Weisbach Factor value for a given part size.
Inner Pipe Diameter
Specifies the inner diameter for this pipe. This property is used for circular shaped pipes only.
Inner Pipe Width
Specifies the inner width for this pipe. This property is used for non-circular shaped pipes only, such as
rectangular and egg-shaped.
Inner Pipe Height
Specifies the inner height for this pipe. This property is used for non-circular shaped pipes only, such as
rectangular and egg-shaped.

Hydraulic Properties
These properties specify the hydraulic property information related to the pipe. They are responsible for
displaying the hydraulic grade line and energy grade line. Hydraulic grade lines and energy grade lines are
displayed as a straight line through structures, connected between the HGL Up or EGL Up property from
one pipe to the HGL Down or EGL Down property of the next pipe. For more information, see Adding
Hydraulic Property Data to AutoCAD Civil 3D Pipe Networks (page 1424). For information about creating label
styles for displaying labels for these properties, see Labeling Hydraulic Properties in Pipe Networks (page
1413).
Hydraulic Grade Line Up
Specifies the elevation of the hydraulic grade line for pipe networks flowing in an upstream direction that
contain hydraulic property data.
Hydraulic Grade Line Down
Specifies the elevation of the energy grade line for pipe networks flowing in a downstream direction that
contain hydraulic property data.
Energy Grade Line Up
Specifies the elevation of the energy grade line for pipe networks flowing in an upstream direction that
contain hydraulic property data.
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Energy Grade Line Down
Specifies the elevation of the energy grade line for pipe networks flowing in a downstream direction that
contain hydraulic property data.
Flow Rate
Specifies the flow rate for pipe networks that contain hydraulic property data.
Junction Loss
Specifies the junction loss for pipe networks that contain hydraulic property data.
Return Period
Specifies the return period for pipe networks that contain hydraulic property data.

Rules Tab (Pipe Properties Dialog Box)
Use this tab to view or change the rule set or rule values associated with this pipe.
For more information, see Pipe Rules (page 1394) and Editing Part Rules (page 1401).

Rule Set
This drop-down list lets you specify the rule set for the pipe.

Use Values From Rule Set
This option lets you choose to override or accept the rule values as they are defined in the specified rule set.
If you clear this check box, you can edit the rule values on this dialog box, and the pipe uses the rule values
as they are specified on this dialog box. If this option is selected, the pipe uses the rule values as they are
defined in the specified rule set, and those values display on this dialog box.

Cover And Slope
This rule ensures that a pipe slopes appropriately and warns when a pipe is placed too close to a ground
surface. For more information, see Cover And Slope Rule (page 1394).
Maximum Cover
Specifies the maximum cover of soil over the length of the pipe, based on the surface being referenced
by that pipe. If the maximum cover is exceeded, a rule violation occurs. Note that this parameter provides
validation only; it does not alter (move or resize) the part in the drawing in any way. It simply produces
a rule violation on the part if the specified value is exceeded.
Maximum Slope
Specifies the maximum slope of the pipe, expressed in percent. If the pipe slope is greater than the
maximum, a rule violation occurs for that object.
Minimum Cover
Specifies the minimum cover of soil over the pipe, based on the surface being referenced by that pipe.
During layout, a pipe will be created that attempts to maintain the minimum cover. This is also used to
determine the initial elevations of the pipe. If the pipe is edited so that its cover is less than the minimum
cover value, a rule violation occurs for that object.
Minimum Slope
Specifies the minimum slope of the pipe, expressed in percent. During layout, a pipe will be created
according to its minimum slope rule value. If the pipe is edited so that its slope is less than the minimum,
you can still edit the pipe as desired, breaking the minimum slope rule, but a rule violation occurs for
that object.

Cover Only
This rule is intended for laying out pipes in a pressure-based pipe network where pipe elevations are
determined according to a specified depth below a terrain. This rule ensures that the minimum cover is met
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along the length of the pipe, and also validates that both the minimum and maximum cover values are not
violated along any length of the pipe. For more information, see Cover Only Rule (page 1395).
Maximum Cover
This is the maximum cover of soil over the pipe, based on the surface being referenced by that pipe. If
the pipe cover exceeds the maximum cover value, a rule violation occurs for that object. Note that this
parameter provides validation only; it does not alter (move or resize) the part in the drawing in any way.
It simply produces a rule violation on the part if the specified value is exceeded.
Minimum Cover
This rule represents the minimum cover of soil over the pipe, based on the surface being referenced by
that pipe. During layout, a pipe will be created that attempts to maintain the minimum cover. If the pipe
is edited so that its cover is less than the minimum cover value, a rule violation occurs for that object.

Length Check
This rule governs the behavior that produces a warning condition on a pipe if the pipe length exceeds the
value specified for the maximum pipe length, or is less than the value specified for the minimum pipe length.
For more information, see Length Check Rule (page 1395).
Maximum Length
Specifies a maximum length for pipes. When this rule is in use, you can still draw pipes that exceed the
defined maximum pipe length. However, the object will be displayed with a warning icon in the Prospector
list view. Note that this parameter provides validation only; it does not alter (move or resize) the part in
the drawing in any way. It simply produces a rule violation on the part if the specified value is exceeded.
Minimum Length
Specifies a minimum length for pipes. When this rule is in use, you can still draw pipes that are shorter
than the defined minimum pipe length. However, the object will be displayed with a warning icon in the
Prospector list view. Note that this parameter provides validation only; it does not alter (move or resize)
the part in the drawing in any way. It simply produces a rule violation on the part if the specified value
is not met.

Pipe To Pipe Match
This rule governs how a pipe elevation is determined in a pipe network that contains only pipes (no structures),
and or when a pipe is inserted onto an existing pipe to break the pipe. For more information, see Pipe To
Pipe Match Rule (page 1396).
Match Location
This parameter controls whether the inserted pipe holds to the pipe’s invert, crown, or centerline elevation
(location).
Drop Value
The drop value on a structure can determine a pipe’s depth.

Pipe Style Dialog Box
Use this dialog box to control the display of various pipe components in a pipe network.
You can edit styles to control how components like pipes walls, pipe ends, pipe centerlines, hatchings and
crossings display in plan, profile, and section views.
Create different styles to use in the various phases of your project. For example, you can create a style to use
specifically in the design phase, displaying pipe components in different colors, and create another style to
use for plotting, displaying the components differently.
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Information Tab (Pipe Style Dialog Box)
Use this tab to change the pipe style name and description information, and to review details about the pipe
style, such as when the style was most recently modified.
For more information, see Information Tab (Style Dialog Box) (page 2017).

Plan Tab (Pipe Style Dialog Box)
Use this tab to define the appearance of the pipe in a 2D plan view.

Pipe Wall Sizes
Specifies the method that will be used to define and draw the dimensions of the pipe wall.
Use Part Dimensions
The inner and outer pipe wall dimensions are drawn according to the actual pipe dimensions.
User Defined
The inner and outer pipe wall dimensions are drawn according to user-specified values. The following
size options are available:
■

Use Drawing Scale: When this option is selected, the value specified in the Units edit box (inches or
millimeters, when the drawing linear unit is set to feet or meters, respectively) will be multiplied by
the drawing scale to determine the width of the pipe walls displayed in the drawing. The user then
enters the desired inner and outer wall dimensions in the text boxes below.

■

Use Size As Percentage Of Screen: When this option is selected, the value specified in the Units edit
box is used as a percentage of the drawing screen size. The width of the pipe walls displayed in the
drawing will be the displayed at the same percentage as the drawing screen size specified.

■

Use Size In Absolute Units: When this option is selected, the specified value that is entered in the Units
edit box is an absolute value in the drawing linear units. The title text above this box displays Feet
when the drawing units are set to feet, and Meters when the drawing units are set to meters.

Pipe Hatch Options
Specifies which components of the pipe shape display a hatch pattern.
Hatch To Inner Walls
The hatch pattern is displayed only in the central area of the pipe, and to not hatch the pipe wall. When
this option is selected, the pipe wall (which is the area between the inner wall and the outer wall of the
pipe) is not hatched.
Hatch To Outer Walls
The hatch pattern is displayed to the entire area of the pipe, including the pipe wall. When this option
is selected, the pipe wall (which is the area between the inner wall and the outer wall of the pipe) is
hatched.
Hatch Walls Only
The hatch pattern is displayed only in the pipe walls. The pipe wall is the area between the pipe inner
wall and the pipe outer wall.

Pipe End Line Size
Specifies the method that will be used to define and draw the dimensions of the pipe ends.
Draw To Inner Walls
The pipe end line draws to the inner walls of the pipe.
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Draw To Outer Walls
The pipe end line draws to the outer walls of the pipe.
User Defined
The pipe end line draws to a size specified by the user. The size options available are the same as the
options available for the pipe wall dimensions.

Pipe Centerline Options
Specifies the method that will be used to define and draw the dimensions of the pipe centerline.
By Lineweight
The pipe centerline is drawn according to the currently specified line weight of the pipe.
Specify Width
The pipe centerline is drawn according to user-specified values. The following width options are available:
■

Draw To Inner Walls: When this option is selected, the value specified in the edit box below (inches
or millimeters, when the drawing linear unit is set to feet or meters, respectively) will be multiplied
by the drawing scale to determine the width of the pipe centerline displayed in the drawing. The pipe
centerline draws to the inner walls of the pipe, according to the value specified in the text box below.

■

Draw To Outer Walls: When this option is selected, the value specified in the edit box below (inches
or millimeters, when the drawing linear unit is set to feet or meters, respectively) will be multiplied
by the drawing scale to determine the width of the pipe centerline displayed in the drawing. The pipe
centerline draws to the outer walls of the pipe, according to the value specified in the text box below.

■

Use Drawing Scale: When this option is selected, the value specified in the Units edit box (inches or
millimeters, when the drawing linear unit is set to feet or meters, respectively) will be multiplied by
the drawing scale to determine the width of the pipe walls displayed in the drawing. The user then
enters the desired inner and outer wall dimensions in the text boxes below.

■

Use Size As Percentage Of Screen: When this option is selected, the value specified in the Units edit
box is used as a percentage of the drawing screen size. The width of the pipe walls displayed in the
drawing will be the displayed at the same percentage as the drawing screen size specified.

■

Use Size In Absolute Units: When this option is selected, the specified value that is entered in the Units
edit box is an absolute value in the drawing linear units. The title text above this box displays Feet
when the drawing units are set to feet, and Meters when the drawing units are set to meters

Align Hatch To Pipe
When this option is selected, the angle of the hatch lines for the pipe align with the angle of the pipe.

Clean Up Pipe To Pipe Connections
When this option is selected, the appearance of pipe to pipe connections in plan view is cleaned up. This
option is available for multiple adjoining pipes that are connected to other pipes with null structures. This
option must be selected for the clean up to occur, and the cleanup occurs only on the pipes that are connected
to other pipes with null structures between them. For more information, see Pipe End Cleanup Option (page
1367). You can also set this option on the Profile tab of the Pipe Style dialog box for pipe to pipe connections
displayed in profile views.

Profile Tab (Pipe Style Dialog Box)
Use this tab to define the appearance of the pipe in a profile view.

Pipe Wall Sizes
Specifies the method that will be used to define and draw the dimensions of the pipe wall.
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Use Part Dimensions
The inner and outer pipe wall dimensions are drawn according to the actual pipe dimensions.
User Defined
The inner and outer pipe wall dimensions are drawn according to user-specified values. The following
size options are available:
■

Use Drawing Scale: Specifies that the value in the Units edit box (inches, or millimeters, when the
drawing linear unit is set to Feet or Meters, respectively) will be multiplied by the drawing scale to
determine the width of the pipe walls displayed in the drawing. Then the user enters the desired inner
and outer wall dimensions in the text boxes below.

■

Use Size As Percentage Of Screen: Specifies that the value in the Units edit box is a percentage of the
drawing screen size. The width of the pipe walls displayed in the drawing will always be the percentage
specified of the drawing screen size.

■

Use Size In Absolute Units: Specifies that the value entered in the Units edit box is an absolute value
of the drawing linear units. The static text of the Units edit box displays Feet when the drawing units
are set to Feet, and Meters when the drawing units are set to Meters.

Pipe Hatch Options
Specifies which components of the pipe shape display a hatch pattern.
Hatch To Inner Walls
The hatch pattern is displayed only in the central area of the pipe, and not in the pipe wall area of the
pipe. When this option is selected, the pipe wall (which is the area between the inner wall and the outer
wall of the pipe) is not hatched.
Hatch To Outer Walls
The hatch pattern is displayed in the entire area of the pipe, including the pipe wall area. When this
option is selected, the pipe wall (which is the area between the inner wall and the outer wall of the pipe)
is hatched.
Hatch Walls Only
The hatch pattern is displayed only in the pipe wall area. The pipe wall area is the area between the pipe
inner wall and the pipe outer wall.

Pipe End Line Size
Specifies the method that will be used to define and draw the dimensions of the pipe ends.
Draw To Inner Walls
The pipe end line draws to the inner walls of the pipe.
Draw To Outer Walls
The pipe end line draws to the outer walls of the pipe.
User Defined
The pipe end lines draw to a size specified by the user. The size options available are the same as the
options available for the pipe wall dimensions.

Crossing Pipe Hatch Options
Specifies which components of a pipe crossing display a hatch pattern.
Hatch To Inner Walls
The hatch pattern is displayed only to the inner walls of pipe crossings.
Hatch To Outer Walls
The hatch pattern is displayed all the way to the outer walls of pipe crossings.
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Hatch Walls Only
The hatch pattern is displayed only within the pipe wall area of pipe crossings.

Align Hatch To Pipe
When this option is selected, the angle of the hatch lines for the pipe align with the angle of the pipe.

Clean Up Pipe To Pipe Connections
When this option is selected, the appearance of pipe to pipe connections in profile view is cleaned up. This
option is available for multiple adjoining pipes that are connected to other pipes with null structures. This
option must be selected for the clean up to occur, and the cleanup occurs only on the pipes that are connected
to other pipes with null structures between them. For more information, see Pipe End Cleanup Option (page
1367). You can also set this option on the Plan tab of the Pipe Style dialog box for pipe to pipe connections
displayed in plan views. By default, this option is not checked.

Section Tab (Pipe Style Dialog Box)
Use this tab to define the appearance of the pipe in a section view.

Crossing Pipe Hatch Options
Specifies which components of a pipe crossing display a hatch pattern.
Hatch To Inner Walls
The hatch pattern is displayed only in the central area of the pipe, and does not hatch the pipe wall.
When this option is selected, the pipe wall (which is the area between the inner wall and the outer wall
of the pipe) is not hatched.
Hatch To Outer Walls
The hatch pattern is displayed the entire area of the pipe, including the pipe wall. When this option is
selected, the pipe wall (which is the area between the inner wall and the outer wall of the pipe) is hatched.
Hatch Walls Only
The hatch pattern is displayed only in the pipe walls. The pipe wall is the area between the pipe inner
wall and the pipe outer wall.

Display Tab (Pipe Style Dialog Box)
Use this tab to change the display and visibility of pipe object components.

View Direction
Some object styles can have unique display values and varying numbers of displayed components, depending
on whether they are being displayed in Plan, Profile, Section, or Model views. You can create and set style
characteristics for each supported view direction type using the View Direction list.
Plan
Specifies the display style settings when the pipe is displayed in plan view.
Model
Specifies the display style settings when the pipe is displayed in model view.
Profile
Specifies the display style settings when the pipe is displayed in a profile view.
Section
Specifies the display style settings when the pipe is displayed in a section view.
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Component Display
You can set the following display style characteristics for pipe components: Visibility, Layer, Color, Linetype,
LT Scale, and Lineweight.
Pipe Centerline
The style for pipe centerlines.
Inside Pipe Walls
The style for the inside walls of pipes.
Outside Pipe Walls
The style for the outside walls of pipes.
Pipe End Line
The style for the ends of pipes.
Pipe Hatch
The hatch style for pipes.
Pipe Solid
The style for pipes displayed in 3D model view.
Crossing Pipe Inside Walls
The style for the inside wall of pipe crossings displayed in profile or section view.
Crossing Pipe Outside Walls
The style for the outside wall of pipe crossings displayed in profile or section view.
Crossing Pipe Hatch
The hatch style for pipe crossings displayed in profile or section view.
Hydraulic Grade Line
The style for displaying hydraulic grade lines for pipe networks that are displayed in profile views. For
more information, see Viewing Hydraulic Data in Profile Views (page 1426).
Energy Grade Line
The style for displaying energy grade lines for pipe networks that are displayed in profile views. For more
information, see Viewing Hydraulic Data in Profile Views (page 1426).
In certain views, you can specify hatch display styles for the fill areas of the following pipe components:
Pipe Hatch: The hatch pattern for pipe components displayed in plan or profile view.
Crossing Pipe Hatch: The hatch pattern for pipe crossings displayed in profile or section view.
For more information, see Display Tab (Style Dialog Box) (page 2017).

Summary Tab (Pipe Style Dialog Box)
Use this tab to review all the information about the current pipe style.
This information can be copied and pasted to the clipboard. For more information, see Summary Tab (Style
Dialog Box) (page 2020).

Structure Rule Set Dialog Box
Use this tab to view or edit basic information about this structure rules set.
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You can view or edit the name and optional description values, and you can view information about when
the rule set was created and last modified.

Information Tab (Structure Rule Set Dialog Box)
Use this tab to view or edit the basic information about this structure rules set, such as a name and an
optional description for this set of structure rules.

Rules Tab (Structure Rule Set Dialog Box)
Use this tab to view or edit the rules included in this set of structure rules.
You can change values of existing rules, add rules, and or delete rules. You can also change the order in
which rules are processed by changing the order in which they appear on this dialog. For more information,
see Part Rules (page 1390).
NOTE Rules are not applied to pipes or structures when importing pipe networks from either LandXML or from
the Storm Sewers Extension.

Add Rule
Click this button to display the Add Rule dialog box (page 2307) where you can select a new rule to add to
this rule set.

Delete Rule
You can remove a rule from the rule set by selecting the rule on this dialog box and clicking this button.

Up and Down Arrow Buttons
You can change the order in which rules are processed by changing the order they appear on this
dialog. Rules are processed sequentially, starting from the rule displaying at the bottom of this dialog box,
and ending with the rule displayed at the top of this dialog box.

Pipe Drop Across Structure
This rule compares all pipes connected to a single structure and ensures that pipes enter and exit the structure
at logical locations. For more information, see Pipe Drop Across Structure Rule (page 1396).
Drop Reference Location
Determines the drop location by using the pipe’s invert, crown, or centerline elevation.
Drop Value
Specifies what the drop value is between the lowest incoming pipe and any outgoing pipe connected to
the structure.
Maximum Drop Value
Specifies the maximum drop value between the lowest incoming pipe and any outgoing pipe connected
to the structure. Note that this parameter provides validation only; it does not alter (move or resize) the
part in the drawing in any way. It simply produces a rule violation on the part if the specified value is
exceeded.

Maximum Pipe Size Check
This rule checks to see if pipes entering a structure have a diameter or width that exceeds a specified maximum
value. For more information, see Maximum Pipe Size Check Rule (page 1400).
Maximum Pipe Diameter or Width
For circular pipes, this parameter measures the pipe diameter. For rectangular pipes, it measures width. If
a pipe diameter or width exceeds the maximum value, a warning is issued on the structure. Note that this
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parameter provides validation only; it does not alter (move or resize) the part in the drawing in any way.
It simply produces a rule violation on the part if the specified value is exceeded.

Set Sump Depth
This rule specifies the sump depth, or the vertical distance from the invert of the lowest pipe attached to
the structure to the inside bottom of the Structure, see Set Sump Depth Rule (page 1401).
Sump Depth
Determines the sump depth.
Drop Value
Specifies what the drop value is between the lowest incoming pipe and any outgoing pipe connected to
the structure.
Maximum Drop Value
Specifies the maximum drop value between the lowest incoming pipe and any outgoing pipe connected
to the structure. Note that this parameter provides validation only; it does not alter (move or resize) the
part in the drawing in any way. It simply produces a rule violation on the part if the specified value is
exceeded.

Structure Properties Dialog Box
Use this dialog box to view or change the properties of a structure object.
You can change the name of the structure object, description, style, render material, and more. You can also
change part properties and rules.
When you add pipe network containing structures to a drawing, much of the information about the structure,
such as its description and properties, is derived from the definition of the structure as it exists in the part
catalog.
After a structure is inserted into a drawing, you can make changes to the structure using this dialog box, if
desired. When you make changes using this dialog box, the changes apply only to the current structure
selected in your drawing, and have no impact on the information defined for that structure in the part
catalog. For descriptions of part properties, see Part Properties (page 1378).

Information Tab (Structure Properties Dialog Box)
Use this tab to change the name, description, and style information for the structure.
Name
Specifies the name of the current pipe.
Description
Specifies an optional description of the current pipe.
Object Styles
Specifies the pipe style. Select other styles from the list.
Style
Specifies the style options. Click to create a new style, copy or edit the current style selection, or pick a
style from drawing. Click
creation information.

to open the Style Detail dialog box, where you can preview the style and

Render Material
Specifies the default render material assigned to the pipe when it is inserted into the drawing. Click
to select a render material from the drawing.
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Show Tooltips
Controls whether or not tooltips are displayed for the object in the drawing.

Part Properties Tab (Structure Properties Dialog Box)
Use this tab to view or change properties associated with this structure.
This tab displays the properties associated with this structure, along with their current values. Structure
properties define a variety of characteristics of the structure object, including its basic size and shape and
elevation adjustment behavior.
Some properties are specific to a certain type of structure. For example, only junction structures use rim and
sump behavior properties. Only inlet-outlet structures use properties that define headwalls such as Headwall
Base Width.
Some properties are read-only and others are editable. To change an editable property, double-click on the
Value field and enter a new value, or select one from the list. For more information, see Part Properties (page
1378)

General
These properties specify general characteristics of the structure, such as the structure elevation at its insertion
point, and the surface and alignment referenced.
Surface Elevation At Insertion Point
Specifies the elevation at the structure’s insertion point.
Reference Surface
Specifies the surface referenced by the structure.
Reference Alignment
Specifies the alignment referenced by the structure.

Geometry
These properties specify characteristics such as the structure’s rotation angle, offset, station data, and the
number of pipes that are currently connected to the structure.
Structure Rotation Angle
Specifies the structure’s rotation angle.
Structure Offset
Specifies the structure’s offset.
Structure Northing
Specifies the structure’s northing.
Structure Easting
Specifies the structure’s easting.
Connected Pipes
Specifies the number of pipes currently connected to the structure.

Insertion Rim Behavior
These properties are associated with junction structures only. They specify the structure’s rim elevation and
adjustment behavior.
Insertion Rim Elevation
Specifies the current elevation of the structure rim. This cannot be edited if Automatic Surface Adjustment
property is set to True.
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Automatic Surface Adjustment
Specifies whether or not to automatically adjust the rim elevation to the referenced surface, including the
Surface Adjustment Value. When this property is set to True, grip editing the structure modifies the surface
adjustment factor. When this property is set t o False, grip editing the structure modifies the rim elevation.
Surface Adjustment Value
If Automatic Surface Adjustment is set to True, the rim elevation is automatically adjusted by the surface
elevation, plus the value specified here. If the structure is moved, resulting in the structure elevation
changing, the structure automatically adjusts its elevation.

Sump Behavior
These properties are associated with junction structures only. They specify the structure’s behavior, elevation,
and the depth of the structure’s sump.
Sump Elevation
Specifies the elevation of the structure’s sump, measured at the inside bottom of the structure. When this
property is enabled, grip editing the structure modifies the sump elevation.
Sump Depth
Specifies the depth of the sump area, measured from the inside bottom of the structure to the lowest pipe
invert of all pipes connected to the structure. When this property is enabled, grip editing the structure
modifies the sump depth.
Control Sump By
Specifies if the sump depth is controlled by the depth based on the lowest pipe invert, or by a specific
elevation value of the sump.

Part Data
These properties specify a variety of part characteristics, such as part type, part subtype, and the part size
name as defined in the part catalog. Some of these properties define the part’s basic shape and behavior,
and therefore are read-only.
Part Type
Specifies structure’s part type.
Part Subtype
Specifies structure’s subtype.
Part Description
Specifies structure’s description.
Part Size Name
Specifies the part size name.
Structure Shape
Specifies the basic primitive shape of the structure, as defined from the part catalog. For example, headwalls
are typically defined in the part catalog as Bounding box shape, and manholes are typically defined as
cylindrical shaped.
Vertical Pipe Clearance
Specifies the clearance required from the top outside of the highest pipe connected to the structure, to
the rim. This is defined in the catalog and ensure that pipes enter the structure at an appropriate elevation.
For example, it prevents a pipe from entering through the cone of structure.
Rim To Sump Height
Specifies the distance between the sump to the structure’s rim. This property is for junction structures
only.

2290 | Chapter 66 Pipe Networks Dialog Boxes

Headwall Base Width
Specifies the width of the base of the headwall. This property is for inlet-outlet structures only.
Headwall Base Thickness
Specifies the thickness of the base of the headwall. This property is for inlet-outlet structures only.
Wall Thickness
Specifies the wall thickness for this structure, measured from the inside edge of the structure to the outside
edge of the structure. This property is for junction structures only.
Floor Thickness
Specifies the thickness of the bottom of the structure. This property is for junction structures only.
Material
Specifies the material defined for this part. This optional property is used mainly for labeling purposes.
It allows you to identify the type of material used to construct this part.
Frame
This optional property specifies the model or type of frame used for a structure.
Grate
This optional property specifies the model or type of grate used for a structure intended to be used as a
catchbasin.
Cover
This optional property specifies the model or type of cover used for a structure intended to be used as a
manhole.
Frame Height
Specifies the height of the structure’s frame. This property is for junction structures only.
Frame Diameter
Specifies the diameter of the structure’s frame. This property is for junction structures only.
Frame Length
Specifies the length of the structure’s frame. This property is for junction structures only.
Frame Width
Specifies the width of the structure’s frame. This property is for junction structures only.
Barrel Height
Specifies the height of the barrel section of the structure. This property is for two-tiered junction structures
only.
Barrel Pipe Clearance
This property lets you determine how close to the structure’s rim you can position a pipe. It is used for
two-tiered junction structures only and specifies the clearance required above the top of the barrel section
of the structure. It is similar to Vertical Pipe Clearance, but only describes the transition zone between
the access cylinder and the larger barrel cylinder of a two-tiered structure.
Cone Height
Specifies the height of the cone shaped section of the structure. This property is for two-tiered junction
structures only.
Slab Thickness
Specifies the thickness of the structure slab. This property is for junction structures only.
Inner Structure Diameter
Specifies the inner diameter for this structure. This property is for junction structures only.
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Structure Height
Specifies the total height for this structure, measured from the bottom outside edge of the structure to
the top outside edge of the structure.
Structure Diameter
Specifies the diameter for this structure, measured from the outside edges of the structure. Circular shaped
structures typically use the diameter property while non-circular structures use width and length.
Structure Width
Specifies the width for this structure, measured from the outside edges of the structure. Non-circular
shaped structures typically use the width and length properties while circular structures use diameter.
Structure Length
Specifies the length for this structure, measured from the outside edges of the structure. Non-circular
shaped structures typically use the width and length properties while circular structures use diameter.

Hydraulic Properties
These properties specify the hydraulic grade line, the energy grade line, and the junction loss values for pipe
networks that contain this data.
Hydraulic grade lines and energy grade lines, when present, are displayed as a straight line through structures,
connected between the HGL Up or EGL Up property from one pipe to the HGL Down or EGL Down property
of the next pipe. For more information, see Adding Hydraulic Property Data to AutoCAD Civil 3D Pipe
Networks (page 1424).
Hydraulic Grade Line
Specifies the elevation of the hydraulic grade line for pipe networks that contain this data.
Energy Grade Line
Specifies the elevation of the energy grade line for pipe networks that contain this data.
Known Capacity
Specifies the known capacity for pipe networks that contain this data.
Bypass Target
Specifies the bypass target for pipe networks that contain this data.

Connected Pipes Tab (Structure Properties Dialog Box)
Use this tab to quickly make adjustments to pipes that are connected to a single structure.
The Connected Pipes tab lets you quickly view and edit properties that are important for pipes connected
to structures. For example, you can use this tab to edit the following properties on pipes connected to the
selected structure:
■

inner diameter

■

inner width

■

invert elevation

■

centerline elevation

■

crown elevation

You can use this tab to quickly perform a variety of edits to pipes that are connected to a structure. You can
align the elevations on multiple pipes connected to the structure according to the invert, crown, or centerline
elevation of a selected pipe.
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For more information, see Matching Elevations on Connected Pipes (page 1363). The following information
describes the properties that are displayed on the Connected Pipes tab.
Name
Displays the name of the current structure and each pipe connected to it. Read-only.
Status
Displays the current status of each pipe connected to the structure. Read-only.
Description
Displays the description of each pipe connected to the structure. Read-only.
Inner Diameter
Specifies the inner diameter for circular pipes. Editable.
Inner Width
Specifies the inner width for non-circular (rectangular) pipes. Editable.
Inner Height
Specifies the inner height for non-circular (rectangular) pipes. Editable.
Invert Elevation
Specifies the invert elevation of the pipe. Editable.
Centerline Elevation
Specifies the centerline elevation of the pipe. Editable.
Crown Elevation
Specifies the crown elevation of the pipe. Editable.
Slope
Specifies the slope of the pipe coming out of the structure. Read-only.
In/Out
Displays the flow direction of the pipe, indicating if the pipe flows in to or out of the structure. Read-only.
From Structure
Displays the name of the structure at the other end of the pipe. Read-only.

Rules Tab (Structure Properties Dialog Box)
Use this tab to view or change the rule set or rule values associated with this structure.
For more information, see Structure Rules (page 1396) and Editing Part Rules (page 1401).

Rule Set
This drop-down list lets you specify the rule set for the structure.

Use Values From Rule Set
This option lets you choose to override or accept the rule values as they are defined in the specified rule set.
If you clear this check box, you can edit the rule values on this dialog box, and the structure uses the rule
values as they are specified on this dialog box. If this option is selected, the structure uses the rule values as
they are defined in the specified rule set, and those values display on this dialog box.

Pipe Drop Across Structure
This rule compares all pipes connected to a single structure and ensures that pipes enter and exit the structure
at logical locations. For more information, see Pipe Drop Across Structure Rule (page 1396).
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Drop Reference Location
Determines the drop location by using the pipe’s invert, crown, or centerline elevation.
Drop Value
Specifies what the drop value is between the lowest incoming pipe and any outgoing pipe connected to
the structure.
Maximum Drop Value
Specifies the maximum drop value between the lowest incoming pipe and any outgoing pipe connected
to the structure. Note that this parameter provides validation only; it does not alter (move or resize) the
part in the drawing in any way. It simply produces a rule violation on the part if the specified value is
exceeded.

Maximum Pipe Size Check
This rules checks to see if pipes entering a structure have a diameter or width that exceeds a specified
maximum value. For more information, see Maximum Pipe Size Check Rule (page 1400).
Maximum Pipe Diameter or Width
For circular pipes, this parameter measures the pipe diameter. For rectangular pipes, it measures width. If
a pipe diameter or width exceeds the maximum value, a warning is issued on the structure. Note that this
parameter provides validation only; it does not alter (move or resize) the part in the drawing in any way.
It simply produces a rule violation on the part if the specified value is exceeded.

Structure Style Dialog Box
Use this dialog box to control the display of each structure component in a pipe network.
You can edit styles to control how structure components like boundaries and hatchings display in model,
plan, profile, and section views.
Create different styles to represent different types of structures. You can also create different styles to use in
the various phases of your project. For example, you can create a style to use specifically in the design phase,
displaying pipe network structures in different colors, and create another style to use for plotting, displaying
the components differently.

Information Tab (Structure Style Dialog Box)
Use this tab to change the structure style name and description information, and to review details about
the structure style, such as when the style was most recently modified.
For more information, see Information Tab (Style Dialog Box) (page 2017).

Model Tab (Structure Style Dialog Box)
Use this tab to define the appearance of the 3D object used to represent the structure in model view.

Structure
Specifies the method that will be used to define and draw the dimensions of the structure in model view.
Use Catalog Defined 3D Part
The 3D object defined in the parts catalog is used when displaying the structure in 3D. For more
information, see Part Catalog and Parts Lists (page 1380). This option is enabled by default.
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Use Simple 3D Part
The structure is displayed with one of the following simple shape options:
■

Cylinder: The cylinder shape is the default. The dimensions of the cylinder are determined by the
boundary of the part. The preview image shows an elongated cylinder in isometric view.

■

Cube: The dimensions of the cube are determined by the boundary of the part. The preview image
shows an elongated cube in isometric view.

■

Sphere: The dimensions of the sphere are determined by the boundary of the part. The preview image
shows an elongated sphere in isometric view.

■

Part Defined Shape: This will be either a cylinder, cube, or sphere as defined in the 3D model. Each
part definition contains a simple shape and size. The parts display using their simple shape
representation.

Preview
Displays an image which is a reasonable facsimile of the 3D shape with the current settings.

Plan Tab (Structure Style Dialog Box)
Use this tab to define the appearance of the structure in 2D plan view.

Structure
Specifies the method that will be used to define and draw the dimensions of the structure in 2D plan view.
Use Outer Part Boundary
The 2D plan view of the structure style is displayed as an outline of the 3D object specified on the Model
tab. This option is enabled by default. A preview image is not available for this option.
User Defined Part
The structure style uses an AutoCAD block reference to display the structure. The Preview control displays
the block listed in the Block Name drop-down list. The control lists all the blocks defined in the current
drawing.
■

Block Name: Specifies the name of the drawing file to use as a structure symbol.

■

Select Drawing File Button: Click to select a drawing file to use as a structure symbol.

Size Options
When an AutoCAD block is selected above, the following size options are available:
■

Use Drawing Scale: When this option is selected, the specified value in the Units edit box (inches, or
millimeters, when the drawing linear unit is set to Feet or Meters, respectively) is multiplied by the
drawing scale to determine the size of the structure symbol displayed in the drawing. Use this setting
when annotation symbols are used.

■

Use Size As Percentage Of Screen: When this option is selected, the specified value that is entered in
the Units edit box is a percentage of the drawing screen size. The size of the structure symbol displayed
in the drawing is always the percentage specified of the drawing screen size.

■

Use Size In Absolute Units: When this option is selected, the specified value that is entered in the Units
edit box is an absolute value of the drawing linear units. The title text above this box displays Feet
when the drawing units are set to feet, and Meters when the drawing units are set to meters.

■

Use Fixed Scale: When this option is selected the Fixed Scale group box is enabled. The structure symbol
will be scaled by the Fixed Scale X, Y, and Z parameters.

■

Use Fixed Scale From Part Size: When this option is selected the Fixed Scale group box is enabled. The
structure symbol will be scaled by the Fixed Scale X, Y, and Z parameters based on the object part size.
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Inch or Percent
The type of units displayed above this box depends on what is selected in the Size options box.
■

Use Drawing Scale: When this option is selected, the title above this box displays as Inches when the
drawing units are set to Feet, and Millimeters when the drawing units are set to Meters.

■

Use Fixed Scale: When this option is selected, the units box is disabled and the Fixed Scale X, Y, and
Z boxes are enabled. The block size is based on the part size.

■

Use Size In Absolute Units: When this option is selected, the title above this box displays as Inches
when the drawing units are set to Feet, and Millimeters when the drawing units are set to Meters.

■

Use Size As Percentage Of Screen: When this option is selected, the title above this box displays as
Percent.

■

Use Fixed Scale From Part Size: When this option is selected, the units box is disabled and the Fixed
Scale X, Y, and Z boxes are enabled. The block size is based on the part size. The default fixed scale
factor for the block is 1 for X & Y.

Enable Part Masking
Specifies whether the pipe objects are masked by the plan structure object. This control is enabled by
default.
Preview
When User Defined Part is selected, this area displays an image with the current setting.

Profile Tab (Structure Style Dialog Box)
Use this tab to define the appearance of the 3D object used to represent the structure in profile view.

Structure
Specifies the method that will be used to define and draw the dimensions of the structure in profile view.
Display As Solid
The 3D object defined in the parts catalog is used when displaying the structure in 3D. For more
information, Part Catalog and Parts Lists (page 1380). This option is enabled by default. A preview image is
not available for this option.
Display As Boundary
Only the outer boundary of the structure, as defined in the parts catalog, is used when displaying the
structure in a profile.
Display As Block
Specifies that the structure style uses an AutoCAD block reference to display the structure. The Preview
control displays the block listed in the Block Name drop-down list. The control lists all the blocks defined
in the current drawing.
■

Block Name: Specifies the name of the drawing file to use as a structure symbol.

■

Select Drawing File Button: Click to select a drawing file to use as a structure symbol.

Size Options
When an AutoCAD block is selected above, the following size options are available:
■

Use Drawing Scale: When this option is selected, the specified value in the Units edit box (inches, or
millimeters, when the drawing linear unit is set to Feet or Meters, respectively) is multiplied by the
drawing scale to determine the size of the structure symbol displayed in the drawing. Use this setting
when annotation symbols are used.
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■

Use Size As Percentage Of Screen: When this option is selected, the value specified in the Units edit
box is a percentage of the drawing screen size. The size of the structure symbol displayed in the drawing
is always the same percentage specified of the drawing screen size.

■

Use Size In Absolute Units: When this option is selected, the specified value that is entered in the Units
edit box is an absolute value of the drawing linear units. The title text above this box displays Feet
when the drawing units are set to feet, and Meters when the drawing units are set to meters.

■

Use Fixed Scale: When this option is selected the Fixed Scale group box is enabled. The structure symbol
will be scaled by the Fixed Scale X, Y, and Z parameters.

■

Use Fixed Scale From Part Size: When this option is selected the Fixed Scale group box is enabled. The
structure symbol will be scaled by the Fixed Scale X, Y, and Z parameters based on the object part size.

Inch or Percent
The type of units displayed above this box depends on what is selected in the Size options box.
■

Use Drawing Scale: When this option is selected, the title above this box displays as Inches when the
drawing units are set to Feet, and Millimeters when the drawing units are set to Meters.

■

Use Size Relative To Screen: When this option is selected, the title above this box displays as Percent.

■

Use Size In Absolute Units: When this option is selected, the title above this box displays as Inches
when the drawing units are set to Feet, and Millimeters when the drawing units are set to Meters.

■

Use Fixed Scale: When this option is selected, the units box is disabled and the Fixed Scale X, Y, and
Z boxes are enabled.

■

Use Fixed Scale From Part Size: When this option is selected, the units box is disabled and the Fixed
Scale X, Y, and Z boxes are enabled. The block size is based on the part size. The default fixed scale
factor for the block is 1 for X & Y.

Enable Part Masking
Specifies whether the pipe objects are masked by the plan structure object. This control is enabled by
default.
Preview
When User Defined Part is selected, this area displays an image with the current settings.

Section Tab (Structure Style Dialog Box)
Use this tab to define the appearance of the 3D object used to represent the structure in a section view.

Structure
Specifies the method that will be used to define and draw the dimensions of the structure in a section view.
Display As Solid
The 3D object defined in the parts catalog is used when displaying the structure in 3D. For more
information, Part Catalog and Parts Lists (page 1380). This option is enabled by default. A preview image is
not available for this option.
Display As Boundary
Only the outer boundary of the structure, as defined in the parts catalog, is used when displaying the
structure in a section view.
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Display As Block
Specifies that the structure style uses an AutoCAD block reference to display the structure. The Preview
control displays the block listed in the Block Name drop-down list. The control lists all the blocks defined
in the current drawing.
■

Block Name: Specifies the name of the drawing file to use as a structure symbol.

■

Select Drawing File Button: Click to select a drawing file to use as a structure symbol.

Size Options
When an AutoCAD block is selected above, the following size options are available:
■

Use Drawing Scale: When this option is selected, the specified value in the Units edit box (inches, or
millimeters, when the drawing linear unit is set to Feet or Meters, respectively) is multiplied by the
drawing scale to determine the size of the structure symbol displayed in the drawing. Use this setting
when annotation symbols are used.

■

Use Size As Percentage Of Screen: When this option is selected, the value specified in the Units edit
box is a percentage of the drawing screen size. The size of the structure symbol displayed in the drawing
is always the same percentage specified of the drawing screen size.

■

Use Size In Absolute Units: When this option is selected, the specified value that is entered in the Units
edit box is an absolute value of the drawing linear units. The title text above this box displays Feet
when the drawing units are set to feet, and Meters when the drawing units are set to meters.

■

Use Fixed Scale: When this option is selected the Fixed Scale group box is enabled. The structure symbol
will be scaled by the Fixed Scale X, Y, and Z parameters.

■

Use Fixed Scale From Part Size: When this option is selected the Fixed Scale group box is enabled. The
structure symbol will be scaled by the Fixed Scale X, Y, and Z parameters based on the object part size.

Inch or Percent
The type of units displayed above this box depends on what is selected in the Size options box.
■

Use Drawing Scale: When this option is selected, the title above this box displays as Inches when the
drawing units are set to Feet, and Millimeters when the drawing units are set to Meters.

■

Use Size Relative To Screen: When this option is selected, the title above this box displays as Percent.

■

Use Size In Absolute Units: When this option is selected, the title above this box displays as Inches
when the drawing units are set to Feet, and Millimeters when the drawing units are set to Meters.

■

Use Fixed Scale: When this option is selected, the units box is disabled and the Fixed Scale X, Y, and
Z boxes are enabled.

■

Use Fixed Scale From Part Size: When this option is selected, the units box is disabled and the Fixed
Scale X, Y, and Z boxes are enabled. The block size is based on the part size. The default fixed scale
factor for the block is 1 for X & Y.

Enable Part Masking
Specifies whether the pipe objects are masked by the plan structure object. This control is enabled by
default.
Preview
When Display As Boundary or Display As Block is selected, this area displays a preview of the image with
the current settings.

Display Tab (Structure Style Dialog Box)
Use this tab to change the display and visibility of structure object components.
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View Direction
Some object styles can have unique display values and varying numbers of displayed components, depending
on whether they are being displayed in Plan, Model, Profile, or Section views. You can create and set style
characteristics for each supported view direction type using the View Direction list.
Plan
Specifies the display style settings when the structure is displayed in plan view.
Model
Specifies the display style settings when the structure is displayed in model view.
Profile
Specifies the display style settings when the structure is displayed in a profile view.
Section
Specifies the display style settings when the structure is displayed in a section view.

Component Display
You can set the following display style characteristics for structure components: Visibility, Layer, Color,
Linetype, LT Scale, and Lineweight.
Structure
The style for structures displayed in plan view.
Structure Hatch
The hatch pattern for structures.
3D Solid
The style for structures displayed in 3D model view.
Structure Pipe Outlines
The style for pipes that are displayed in profile or section views.
Hydraulic Grade Line
The style for displaying a hydraulic grade line for pipe networks that are displayed in profile views. For
more information, see Viewing Hydraulic Data in Profile Views (page 1426).
Energy Grade Line
The style for displaying an energy grade line for pipe networks that are displayed in profile views. For
more information, see Viewing Hydraulic Data in Profile Views (page 1426).

Component Hatch Display
In plan, profile, or section views, you can specify hatch display styles for the fill areas of the structure.
Structure Hatch
The hatch pattern for structures displayed in plan, profile, or section views.
For more information, see Display Tab (Style Dialog Box) (page 2017).

Summary Tab (Structure Style Dialog Box)
Use this tab to review all the information about the current structure style.
This information can be copied and pasted to the clipboard. For more information, see Summary Tab (Style
Dialog Box) (page 2020).
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Part Size Creator Dialog Box
Use this dialog box to select or edit sizes and parameters for parts you wish to create.
The sizes and values available through this dialog box are defined from the pipe network part catalog. In
most cases, there is only a single value available, or a drop-down list of choices, where you can select a value.
Property
Each part property is matched to the part type and may be selected, or added as an optional property, to
a part size depending on how it was published in the part catalog. Part properties are characterized by
value, units, and source.
Value
Specifies the current value defined for the property.
Units
Specifies the current units defined for this property, if applicable.
Source
Specifies how the property was published in the part catalog. For example, if the value is selected from a
list, the source will be identified as Fixed List. Source types can be:
■

Fixed List: This is a read-only, selectable list of fixed sizes or items from the catalog part family. Select
the size from the drop-down list or check the all-sizes option to bring in all size combinations.

■

Range: This is an editable value. The part catalog defines a min/max range and the user can enter any
value within that range for part creation.

■

Table: Values are arranged and selected in table rows. This is only used for pipes. Size selection is
enabled for pipe diameter or width.

■

Constant: A constant is a read-only data type. This is a value explicitly defined in the part family and
cannot be changed.

■

Calculation: This is a read-only value that is obtained from a calculation based on any other parameter
or parameter(s).

■

Optional Property: Lets you add one of the optional properties from a fixed list of optional properties
for each defined part. For example an optional property called “Material” can be added to the part.
Once the property is added to the part, the optional property then appears in the Part Size Creator
dialog box where you can set its value. Optional properties can be used for labeling purposes. For more
information, see Assigning Optional Properties to a Part Size (page 1385).

Add All SIzes
This option is available only to properties with a Fixed List source type. Selecting this options adds all of
the part sizes available in the current property. Select this option if you wish to add all of the size options
available for this property. For example, if you choose to Add All Sizes for a property called “Structure
Height” (Fixed List values = 1.0, 2.0, and 3.0) and a property called “Headwall Top Width” (Fixed List
values = 4.0 and 5.0), then the following set of part sizes are automatically added:
■

Structure Height 1.0, Headwall Top Width 4.0

■

Structure Height 2.0, Headwall Top Width 4.0

■

Structure Height 3.0, Headwall Top Width 4.0

■

Structure Height 1.0, Headwall Top Width 5.0

■

Structure Height 2.0, Headwall Top Width 5.0

■

Structure Height 3.0, Headwall Top Width 5.0
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For more information, see Assigning Optional Properties to a Part Size (page 1385).

Pipe Network Layers Dialog Box
Use this dialog box to define the layers used when creating pipe network components in plan, profile, and
section views.
The default object layers are defined from the root drawing settings on the Object Layers tab.
Pipe Plan Layer
Specifies the layer used when creating pipe network pipes in plan view.
Structure Plan Layer
Specifies the layer used when creating pipe network structures in plan view.
Pipe Profile Layer
Specifies the layer used when creating pipe network pipes in a profile view.
Structure Profile Layer
Specifies the layer used when creating pipe network structures in a profile plan view.
Pipe Network Section Layer
Specifies the layer used when creating the pipe network in a section view.

Select Parts List Dialog Box
Use this dialog box to select a parts list to associate with a pipe network.
The parts list contains the pipes and structures that are available for use in the current pipe network. You
can create new parts lists or edit existing ones.

Pipe Network Catalog Settings Dialog Box
Use this dialog box to configure AutoCAD Civil 3D to access the imperial or the metric pipe network parts
catalog, or to access specific pipe and structure catalogs within the imperial or metric catalog folders.
The part catalog settings defined here enable pipe network parts lists to access the content for pipe and
structure shapes.
Part catalogs are set for each drawing. When in a drawing, and you switch between drawings, the catalogs
(both pipe and structure) will automatically be set to the unit it was last in that particular drawing (either
imperial or metric). You can alternate between drawings that use imperial or metric units without changing
any settings.
NOTE The default catalog unit is determined by the Drawing Units setting in the Drawing Settings dialog boxUnits
and Zone tab. For new and previously existing drawings, use this setting on initialization to set the unit of measure.
See the Specifying Drawing Settings (page 79) for more information.
Catalog Folder
Specifies the folder that contains the current AutoCAD Civil 3D pipe network parts catalogs.
Pipe Catalog
Specifies the current AutoCAD Civil 3D pipe catalog.
Structure Catalog
Specifies the current AutoCAD Civil 3D structure catalog.
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Pipe Network Vistas
Use the vistas displayed in the Panorama window to view and edit objects that are part of the selected pipe
network.
Using the Panorama window, you can quickly display all data associated with pipe network parts in one of
two vistas. There is a tab for Pipe objects and a tab for Structure objects. You can select an object in the vista
and view or edit the pipe network property data.
This window is similar to a spreadsheet. Each row represents a pipe or structure object in a pipe network,
and each column represents a property for that object. You can re-size, move, and copy columns. You can
also copy all or some of the data from a vista and paste it into a spreadsheet. For more information, see The
Panorama Window (page 119).
Pipe Properties
Status
Displays a check mark icon when all design criteria (rules) have been met for this pipe object. Displays a
warning icon
to indicate if there are rule violations associated with this pipe object. The number
indicates how many rules are broken. See the Rules tab (page 2280) on the Pipe Properties dialog box to see
which rules are broken. Hovering over the icon displays a tooltip disrobing the condition.
Name
Specifies the name of the pipe object.
Description
Specifies the description for the pipe object.
Style
Specifies the style for the pipe object.
Rule Set
Specifies the rule set associated with the selected pipe object.
Render Material
Specifies the render material for the pipe object.
Shape
Specifies the shape description as defined from the part catalog definition for this part.
Inner Diameter
Specifies the value for the inner diameter of the pipe shape.
Inner Width
Specifies the value for the inner width of the pipe shape.
Inner Height
Specifies the value for the inner height of the pipe shape.
Reference Alignment
Specifies the object name of the alignment that is referenced by this pipe object.
Start Offset
Specifies the offset of the starting point for the pipe object. This offset is obtained from the alignment
referenced by this pipe object. Flow direction is not considered.
Start Station
Specifies the station of the starting point for the pipe object. This station is obtained from the alignment
referenced by this pipe object. Flow direction is not considered.
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End Station
Specifies the station of the ending point for the pipe object. This station is obtained from the alignment
referenced by this pipe object. Flow direction is not considered.
End Offset
Specifies the offset of the ending point for the pipe object. This offset is obtained from the alignment
referenced by this pipe object. Flow direction is not considered.
Reference Surface
Specifies the object name of the surface that is referenced by this pipe object.
Slope (Hold Start)
Specifies the slope of the pipe from the pipe’s starting point. Flow direction is not considered.
Slope (Hold End)
Specifies the slope of the pipe from the pipe’s ending point. Flow direction is not considered.
Slope
Specifies the slope of the pipe (upstream or downstream) based on the flow direction.
Start Structure
Specifies the name of the structure object the pipe object is connected to at the pipe start point, not
considering flow direction.
Start Northing
Specifies the northing of the pipe start point, not considering flow direction.
Start Easting
Specifies the easting of the pipe start point, not considering flow direction.
Start Invert Elevation
Specifies the invert elevation of the pipe start point, not considering flow direction.
Start Centerline Elevation
Specifies the centerline elevation of the pipe start point, not considering flow direction.
Start Crown Elevation
Specifies the crown elevation of the pipe start point, not considering flow direction.
End Structure
Specifies the name of the structure object the pipe object is connected to at the pipe’s end point, not
considering flow direction.
End Northing
Specifies the northing of the pipe end point, not considering flow direction.
End Easting
Specifies the easting of the pipe start point, not considering flow direction.
End Invert Elevation
Specifies the invert elevation of the pipe end point, not considering flow direction.
End Centerline Elevation
Specifies the centerline elevation of the pipe end point, not considering flow direction.
End Crown Elevation
Specifies the crown elevation of the pipe end point, not considering flow direction.
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2D Length - Center to Center
Specifies the two-dimensional length of the pipe, using the center of the first attached structure as the
pipe start point, and using the center of the end attached structure as the pipe end point. Some scenarios
may require or prefer that pipe length be measured in this way, from the center of the first attached
structure to the center of the next attached structure.
3D Length - Center to Center
Specifies the three-dimensional length of the pipe, using the center of the first attached structure as the
pipe start point, and using the center of the end attached structure as the pipe end point. Some scenarios
may require or prefer that pipe length be measured in this way, from the center of the first attached
structure to the center of the next attached structure.
2D Length - To Inside Edges
Specifies the two-dimensional length of the pipe, using the inside edge of the first attached structure as
the pipe start point, and using the inside edge of the end attached structure as the pipe end point. Some
scenarios performing hydraulic quantity calculations may require or prefer that pipe length be measured
in this way, from the inside edge of the first attached structure to the inside edge of the next attached
structure.
3D Length - To Inside Edges
Specifies the three-dimensional length of the pipe, using the inside edge of the first attached structure as
the pipe start point, and using the inside edge of the end attached structure as the pipe end point. Some
scenarios performing hydraulic quantity calculations may require or prefer that pipe length be measured
in this way, from the inside edge of the first attached structure to the inside edge of the next attached
structure.
Bearing
Specifies the horizontal bearing for straight pipes, and chord bearing for curved pipes.
Start Direction
Specifies the bearing of the start point for curved pipes, not considering flow direction.
End Direction
Specifies the bearing of the end point for curved pipes, not considering flow direction.
Radius
Specifies the horizontal radius for curved pipes.
Flow Direction
Specifies the flow direction relative to how the pipe was drawn end to start or start to end. The flow is
always assumed to be downstream unless Flow Method forces the flow otherwise.
Flow Method
Specifies whether the flow direction of a pipe is set by slope, start to end, or end to start. This property is
used to force the flow direction of a pipe based on start and end points.
Minimum Cover
Specifies the minimum distance of cover for the pipe, measured from the top outside of the pipe to the
referenced surface elevation.
Maximum Cover
Specifies the maximum distance of cover for the pipe, measured from the top outside of the pipe to the
referenced surface elevation.
Chord Length
Specifies the horizontal chord length of a curved pipe, measured from pipe end to pipe end.
Radius Point Northing
Specifies the northing of the radius point of a curved pipe.
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Radius Point Easting
Specifies the easting of the radius point of a curved pipe.
HGL Up\Down
Specifies the HGL Up and Down elevation values for the selected pipe object. For more information, see
Adding Hydraulic Property Data to AutoCAD Civil 3D Pipe Networks (page 1424).
EGL Up\Down
Specifies the EGL Up and Down elevation values for the selected pipe object. For more information, see
Adding Hydraulic Property Data to AutoCAD Civil 3D Pipe Networks (page 1424).
Structure Properties
Status
Displays a check mark icon when all design criteria (rules) have been met for this structure object. Displays
a warning icon
to indicate if there are rule violations associated with this structure object. The number
indicates how many rules are broken. See the Rules tab (page 2293) on the Structure Properties dialog box
to see which rules are broken. Hovering over the icon displays a tooltip disrobing the condition.
Name
Specifies the name of the structure object.
Description
Specifies the description for the structure object.
Style
Specifies the style for the structure object.
Rule Set
Specifies the rule set associated with the selected structure object.
Render Material
Specifies the render material for the structure object.
Type
Specifies the type description as defined in the part catalog definition for this part. Valid choices are
Junction, Inlet/Outlet, or Null.
Inner Diameter
Specifies the value for the inner diameter of the structure shape.
Inner Length
Specifies the value for the inner length of the structure shape.
Inner Width
Specifies the value for the inner width of the structure shape.
Inner Height
Specifies the value for the inner height of the structure shape.
Rotation Angle
Specifies the AutoCAD rotation angle of the structure object in the drawing.
Reference Alignment
Specifies the object name of the alignment that is referenced by this structure object.
Station
Specifies the station of the insertion point for the structure object. This station is obtained from the
alignment referenced by this structure object.
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Reference Surface
Specifies the object name of the surface that is referenced by this structure object.
Insertion Northing
Specifies the northing of the structure insertion point.
Insertion Easting
Specifies the easting of the structure insertion point.
Insertion Rim Elevation
Specifies the rim elevation of the structure insertion point. Typically, this applies to the rim for a junction
structure.
Connected Pipes
Specifies the number of pipes connected to this structure.
Hydraulic Grade Line
Specifies the elevation of the hydraulic grade line for the selected structure object. For more information,
see Adding Hydraulic Property Data to AutoCAD Civil 3D Pipe Networks (page 1424).
Energy Grade Line
Specifies the elevation of the energy grade line for the selected structure object. For more information,
see Adding Hydraulic Property Data to AutoCAD Civil 3D Pipe Networks (page 1424).
Related procedures:
■

Editing Pipe Networks Using the Pipe Network Vistas (page 1346)

■

The Panorama Window (page 119)

■

Part Properties (page 1378)

Swap Part Size Dialog Box
Use this dialog box to select the part size that will be used to replace the currently selected pipe network
part.
Expand the desired part family, select a part size, then click OK.
You can swap a part with a part that is the same type (pipe to pipe or structure to structure), but is from a
different part family and/or part size.
For example, a pipe can only be swapped with another pipe; a junction structure can only be swapped with
another junction structure; an inlet/outlet structure can only be swapped with another inlet/outlet structure;
and a null structure can only be swapped with a junction structure. You cannot swap a pipe with a structure,
and vice versa. Only parts that are available to be swapped display in the Swap Part Size dialog box.
If you want to replace a part with a different part type, you must delete the part, and then add the new one.
Note that when swapping parts, connection elevations are maintained. For example, pipe invert elevations
remain the same if a pipe is swapped with another pipe, or if a structure with one or more pipes attached
to it is swapped with another structure.
Related procedures:
■

Swapping Pipe Network Parts (page 1357)

2306 | Chapter 66 Pipe Networks Dialog Boxes

Add Rule Dialog Box
Use this dialog box to add a rule to a part.
You can also view the parameter values and the name and location of the VBA macro project and macro
name files associated with each rule. Click on the Parameter and or Value column names to sort the items
in ascending or descending order.
Category
Specifies the category the currently selected rule, displayed in the Rule Name field, belongs to. Click to
select a rule category.
Rule Name
Specifies the name of the rule currently selected. Only rules that belong to the currently selected Category
are displayed in the drop down list. Click to select a rule.
Macro Project
Specifies the name of the VBA project containing the macro used for processing this rule.
Macro Name
Specifies the name of the macro used for processing this rule.
Rule Parameters
Displays the rule parameter values that are used by the VBA script to process the currently selected rule.
On this dialog box, these values are read-only. You can click on the Parameter and or Value column names
to sort the items in ascending or descending order. You can also right-click in a column or row to display
a shortcut menu from which you can select options.

Default Name Format
Use these settings to specify the default name formats for pipe network components (pipe network, pipes,
structures). Click
to open the Name Template dialog box, where you can specify the template. For more
information, see Name Template Dialog Box (page 2022).

Default Rules
Use these settings to establish the default rule set assigned to pipes and structures that are added to the pipe
network. Click
to open the Structure Default Rules dialog box, where you can specify the default rule set
assigned to pipes and structures.
Related procedures:
■

Editing Part Rules (page 1401)

Create Interference Check Dialog Box
Use this dialog box to create an interference check, defining a name for the interference check, an optional
description, pipe networks, layer, and styles.
You can enable or change proximity check criteria for the interference check by clicking the 3D Proximity
Check Criteria button.
Name
Specifies the name of the interference check. Each interference check must have a unique name.

Opens the Name Template (page 2022) dialog box, where you can modify the interference check naming
template.
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Description
Specifies an optional description for the interference check.
Network 1
Specifies the first pipe network that will be tested in this interference check.
Network 2
Specifies the second pipe network that will be tested in this interference check.
Layer
Opens the Pipe Network Layers (page 2221) dialog box, where you can assign the layer for displaying
interference check results.

Interference Style
Style List
Displays the current style for interferences. Click the arrow to display the interference styles available in
the drawing.
Style Selection
Specifies the style options. Create a new style, copy or edit the current style selection, or pick a style from
the drawing.

Render Material
Material List
Displays the currently used render material. Click the arrow to display the render material available in
the drawing.
Render Material
Click to select a render material from the drawing.
3D Proximity Check Criteria
Click this button to display the Criteria (page 2308) dialog box. The Criteria dialog box lets you choose to
run the interference check using a specified distance or a specified scale factor.
Related procedures:
■

Checking for Interferences (page 1369)

Criteria Dialog Box
Use this dialog box to enable or disable proximity checking, and to specify a distance or scale factor for the
proximity check.
For more information, see Proximity Checking Criteria (page 1371).

Apply 3D Proximity Check
This option is available for checking a single pipe network, or for comparing two pipe networks to determine
if any parts from one network are too close to parts from another network.
When this option is selected, the interference check looks for and detects the proximity check conditions
specified on this dialog box. When this option is not selected, the interference check does not check for the
proximity conditions specified on this dialog box, and the proximity checking options are not available
(grayed out). Whether proximity checking is enabled or disabled, the interference check still checks for parts
that physically collide.
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Use Distance
When this option is selected, you can enter a distance. When the interference check is run, any pipe
network parts within the specified distance away from each other (on any side) are marked as an
interference.
Use Scale Factor
When this option is selected, you can enter a value that is used as a scale factor. When you enter a scale
factor value, AutoCAD Civil 3D calculates the limits of the part (the pipe or the structure) multiplied by
the scale factor value that is specified. For example, if the pipe diameter is 600mm, and you specify a scale
factor value of 2, AutoCAD Civil 3D identifies any interferences within a distance of 1200mm (or the pipe
diameter, which is 600, multiplied by the scale factor value, which is two). When the interference check
is run, any pipe network parts within that distance away from each other (on any side) are marked as an
interference.

Interference Check Properties Dialog Box
Use this dialog box to view or change the information associated with an interference check.
You can change properties such as style, layer on which the interference check object is placed, or the
interference checking criteria.

Information Tab (Interference Check Properties Dialog Box)
Use this tab to view or change the name, description, style information, and layer of an interference check.
Name
Specifies the name of the current interference check.
Description
Specifies an optional description for the current interference check.

Interference Defaults
Style
Specifies the current style option. Select other styles from the list or click to create a new style, copy or
edit the current style selection, or pick a style from drawing. Click
where you can preview the style and creation information

to open the Style Detail dialog box,

Render Material
Specifies the default render material assigned to the interference check when the interference check is
inserted into the drawing. Click

to select a render material from the drawing.

Layer
Specifies the drawing layer on which the interference check results are placed. Click
Layer Dialog Box (page 2221) dialog box to select a different layer.

to open the Object

Show Tooltips
Controls whether tooltips are displayed for the interference check object(s) in the drawing.

Criteria Tab (Interference Check Properties Dialog Box)
Use this tab to view or change the conditions set for an interference check.
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Apply 3D Proximity Check
This option is available for checking a single pipe network, or for comparing two pipe networks to determine
if any parts from one network are too close to parts from another network.
When this option is selected, the interference check looks for and detects the proximity check conditions
specified on this dialog box. When this option is not selected, the interference check does not check for the
proximity conditions specified on this dialog box, and the proximity checking options are not available
(grayed out).
For more information, see Proximity Checking Criteria (page 1371).
Use Distance
When this option is selected, you can enter a distance. When the interference check is run, any pipe
network part that is less than the specified distance away from any other part in the specified network(s),
in any direction, is marked as an interference.
Use Scale Factor
When this option is selected, you can enter a value that is used as a scale factor. When you enter a scale
factor value, AutoCAD Civil 3D calculates the limits of the part (the pipe or the structure) multiplied by
the scale factor value that is specified. For example, if the pipe diameter is 600mm, and you specify a scale
factor value of 2, AutoCAD Civil 3D identifies any interferences within a distance of 1200mm (or the pipe
diameter, which is 600, multiplied by the scale factor value, which is two). When the interference check
is run, any pipe network parts within that distance away from each other (on any side) are marked as an
interference.

Statistics Tab (Interference Check Properties Dialog Box)
Use this tab to view statistical information on the current interference check.

Comparison
Displays the names of the pipe networks used in the current interference check.
Network 1
Displays the name of the first pipe network used in the interference check.
Network 2
Displays the name of the second pipe network, if there is one, used in the interference check.

Statistics
Displays general information for the current interference check, such as the number of interference instances
found and if the interference check is still current (valid) or out of date (obsolete).
Number of Interferences
Displays the total number of pipe network parts that have met the specified interference criteria. Each
pipe network part that meets any interference criteria is considered to be an interference.
Status
Displays the current state of the interference check. Current means that the interferences found still exist,
and that no changes have been made to and of the pipe network parts included in the interference check.
A status of out of date means that one or more of the parts included in the interference check have changed.
NOTE If any pipe network part included in the interference check has changed in any way, the interference
check becomes out of date. Even changing the description of a pipe network part that is not in interference,
but is part of the pipe network that was checked causes the interference check to become out of date.
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Interference Properties Dialog Box
Use this dialog box to view or change information on an interference object.
You can change properties such as name, description, and or style of an interference object.

Information Tab (Interference Properties Dialog Box)
Use this tab to view or change the name, description, and or style information of an interference.
Name
Specifies the interference name for the current interference.
Description
Specifies an optional description of the current interference.

Object Styles
Style
Specifies the current style option. Select other styles from the list or click to create a new style, copy or
edit the current style selection, or pick a style from drawing. Click
where you can preview the style and creation information

to open the Style Detail dialog box,

Render Material
Specifies the default render material assigned to the interference when the interference is inserted into
the drawing. Click

to select a render material from the drawing.

Show Tooltips
Controls whether or not tooltips are displayed for the interference in the drawing.

Statistics Tab (Interference Properties Dialog Box)
Use this tab to view statistical information, including specific location information, and part names of the
parts involved in the interference.

General
Displays general statistics for the two parts comprising the interference.
Network Part1 / Network1
Displays the object name for the first pipe or structure comprising the interference. This field also displays
the name of the pipe network the pipe or structure belongs to.
Network Part2 / Network2
Displays the object name for the second pipe or structure comprising the interference. This field also
displays the name of the pipe network the pipe or structure belongs to.
Interference Location (X, Y, Z)
Displays the X, Y, and Z location information for the interference. The interference is a solid calculated
by the union of the two interfering parts. The X,Y,Z location is the location of the centroid of that
interference solid.
Interference Check
Displays the name of the interference check this interference belongs to.
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Interference Style Dialog Box
Use this dialog box to control the display of interferences in a pipe network.
Create different styles for various types of interferences. For example, create one interference style that
displays overlapping parts in red, and another that displays parts that are too close to one another in green.
In addition to color and layer settings, you can also choose

Information Tab (Interference Style Dialog Box)
Use this tab to change the interference style name and description information, and to review details about
the interference style, such as when the style was most recently modified.
For more information, see Information Tab (Style Dialog Box) (page 2017).

View OptionsTab (Interference Style Dialog Box)
Use this tab to define the appearance of interferences in plan and model views.

Symbol Options
Specifies the marker style that will be used to visually identify interferences in 2D plan view.
Marker Style
When this option is selected, a 2D marker is used to visually identify interferences in plan view.

Solid Options
Specifies the method that will be used to visually identify interferences in model view.
Show True Interference Solid
When this option is selected, interferences appear as a solid of the true collision of the network parts. This
includes solids that are created when using the proximity check options.
Show as Sphere
This is the default option. When this option is selected, interferences are identified in the drawing by a
sphere that is inserted into the drawing at the location of the interference. This option can be useful for
identifying interferences that are otherwise difficult to see, due to being obscured by other drawing entities.
The size of the sphere can be defined by specifying the following size (diameter) options:
■

Diameter by True Solid Extents: When this option is selected, the sphere is inserted at the centroid of
the interference solid, with a size equal to the extents of the true interference solid. This option may
be useful to visually represent (symbolize) the severity of the collision between parts.

■

User Specified Diameter: The size of the sphere is determined by the value entered in the box. When
Use Size in Absolute Units is selected, the value entered in the box is calculated in feet or meters,
depending on drawing settings. When Use Drawing Units is selected, the value is calculated in inches
or millimeters, depending on drawing settings.

Display Tab (Interference Style Dialog Box)
Use this tab to change the display and visibility of an interference.
You can specify display styles for the following interference components:
Plan 2D Symbol: The style for the symbol that unidentified interferences displayed in 2D plan view. For
example, if a rectangle is chosen as the symbol for identifying interferences in plan view, this component
lets you set the display style for the rectangle.
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Model 3D Solid: The style for interferences displayed in as solids in 3D model view.
For more information, see Display Tab (Style Dialog Box) (page 2017).

Summary Tab (Interference Style Dialog Box)
Use this tab to review all the information about the current interference style.
This information can be copied and pasted to the clipboard. For more information, see Summary Tab (Style
Dialog Box) (page 2020).

Match Elevation Dialog Box
Use this dialog box to set pipe elevations to consistent, matching values in cases where multiple pipes connect
to a single structure.
This feature lets you quickly set pipe elevations in cases where multiple pipes connect to a single structure.
This provides a method for quickly and accurately matching multiple pipe elevations to the crown, centerline,
or invert elevation of a selected pipe. You can also add a drop value that lets you adjust that elevation value
further, if desired.
For more information, see Matching Elevations on Connected Pipes (page 1363).
Drop Amount
This value is added to the elevation of the pipe that is selected on this dialog box. By default, this value
is zero. It gives you the ability to adjust the elevation you are matching to by a specified value.

Pipe Table Creation Dialog Box
Use this dialog box to create a pipe table in a drawing.
Most of the controls in this dialog box are generic table creation controls. For a description of these controls,
see Table Creation Dialog Box (page 2739).
Use the following controls to specify the points to be included in the pipe table:
By Network
Specifies a pipe network to add to the pipe table.
Multiple Selection
Selects the pipe networks to be added to the pipe table.
Related procedures:
■

Adding Pipe Tables (page 1414)

Structure Table Creation Dialog Box
Use this dialog box to create a structure table in a drawing.
Most of the controls in this dialog box are generic table creation controls. For a description of these controls,
see Table Creation Dialog Box (page 2739).
Use the following controls to specify the structures to be included in the structure table:
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By Network
Specifies a network. The structures within the selected network are added to the structure table.
Multiple Selection
Selects the multiple network structures to be added to the structure table. You can add structures from
differing networks.
Related procedures:
■

Adding Structure Tables (page 1415)

Table Cell Components Dialog Box
Use this dialog box to manage the text components within a given cell within a structure table.
This dialog box is accessed by double-clicking a cell in the Structure Table in the Table Style dialog box.
Component Name
Displays a list of existing table components defined for the table style. Select a component from this list
to edit its properties.
Create Component
Creates a new table component. Select a component type from this list to create a new text component,
or text-for-each component. The possible components are Structure, Structure all pipes, Structure in flow
pipes, and Structure out flow pipes.
Copy Component
Copies the selected component.
Delete Component
Deletes the selected component.
Component Row Order
Displays the Component Row Order (page 2315)dialog box.
From the Create Component list, click

to create a new text component.

General
Name
Specifies the name of the text component.
The default name, such as “Text.1,” is the component name with a numeric increment. If the text
component exists in a parent table style, then the name cannot be edited.
Visibility
Specifies whether the text component is visible in the label style.
Related procedures:
■

Text (page 1686)

■

Editing Structure Table Styles (page 1415)
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Component Row Order Dialog Box
Use this dialog box to determine the order of the text components within a structure table cell.
Use the Top and Bottom arrows to arrange the component row order.

Component
Name
Displays the name of the text component.
Related procedures:
■

Editing Structure Table Styles (page 1415)

Rename Pipe Network Parts Dialog Box
Use this dialog box to rename connected parts (pipes and structures) in a pipe network.
You can select one or more connected parts in a pipe network and automatically rename them. You can
enter a new name to be applied, or select a name template. Optionally, you can select a starting number to
renumber the parts.
NOTE When using this command, if the first part you select is not connected to another pipe or structure, you
can only rename that single part.
Rename Structures
Select this option to rename the selected structure(s).

Structure Name Template
Name
Specifies the name that will be used for the selected structure(s).

Opens the Name Template (page 2022) dialog box, where you can modify the naming template that will be
used for the selected structure(s).
Starting Number
This optional field lets you specify a starting number that will be used to number the selected structure(s).
Rename Pipes
Select this option to rename the selected pipe(s).

Pipe Name Template
Name
Specifies the name that will be used for the selected pipe(s).

Opens the Name Template (page 2022) dialog box, where you can modify the naming template that will be
used for the selected pipe(s).
Starting Number
This optional field lets you specify a starting number that will be used to number the selected pipe(s).

Name Conflict Options
You must select one of the following naming conflict options:
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Skip Number
When this option is selected, if a name and number combination is already being used by a pipe network
part in the drawing, then the number will be incremented until that name\number combination is
available as a name for the selected part.
Rename Existing Parts
When this option is selected, if a name and number combination is already being used by a pipe network
part in the drawing, then that part will be renamed so that the selected part can use that desired name
instead. The original pipe network part will be renamed using the next available name and number
combination available.

Export to Storm Sewers Dialog Box
Use this dialog box to select the pipe network data in the drawing to export to an .stm file format.
This dialog box is used for exporting AutoCAD Civil 3D pipe network data to an .stm file so that it can be
used by the Hydraflow Storm Sewers Extension. For more information, see Exporting Pipe Network Data to
an .stm File (page 1423).
NOTE You cannot open .stm files that were exported from AutoCAD Civil 3D, or that were saved in the Storm
Sewers Extension for Civil 3D 2010, in the Storm Sewers Extension for Civil 3D 2009, or earlier versions of the
Storm Sewers Extension.
Specify Objects To Be Exported
Lists the AutoCAD Civil 3D pipe networks that exist in the current drawing. Expand the collections to
display all of the subcomponents.
Select or clear the check box to the left of each item select the items that you want to export to an .stm
file format.
NOTE The check boxes have a tri-state display. If only some items are selected under a collection, the check
box is shaded

. If all the items are selected, the check box is selected

are cleared, the check box for the collection is cleared

. If all the items below the collection

.

Pick From Drawing
Specifies pipe networks to export by selecting from the drawing.
NOTE If you access this dialog box by right-clicking a collection in the Prospector tree and selecting Export to
Storm Sewers, the Pick From Drawing button is not available.
OK
When you click OK, the Export Storm Sewers to File dialog box is displayed where you can select a location
to save the .stm file.
Related procedures:
■

Exporting Pipe Network Data to an .stm File (page 1423)

Part Matchup Settings Dialog Box
Use this dialog box to specify the part types that will be used when importing and exporting pipe networks
between AutoCAD Civil 3D and the Storm Sewers Extension.
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Import Tab (Part Matchup Settings Dialog Box)
Use this tab to view or change the AutoCAD Civil 3D part types that will be matched up to Storm Sewers
part types when importing pipe network data from a Storm Sewers Extension .stm file into AutoCAD Civil
3D.
The list of available Storm Sewers part types is displayed in the first column. In the second column, click in
a cell, and then click
click OK.

to display the AutoCAD Civil 3D Part Catalog dialog box. Select a part type and

Related procedures:
■

Setting Part Matching Defaults for Migration (page 1419)

■

Part Catalog Dialog Box (page 2273)

Importing Circular Structures
This section lets you specify the AutoCAD Civil 3D part types that will be used when importing circular
structures from a Storm Sewers Extension .stm file.
Importing Rectangle Structures
This section lets you specify the AutoCAD Civil 3D part types that will be used when importing rectangular
structures from a Storm Sewers Extension .stm file.
Miscellaneous Part Types
This section displays the AutoCAD Civil 3D part types that will be used for importing Storm Sewer parts
that do not have a part type specified. Storm Sewers parts that do not have a part type specified are by
default matched up to null structures when imported into AutoCAD Civil 3D.
Importing Pipes
This section lets you specify the AutoCAD Civil 3D part types that will be used when importing pipes
from a Storm Sewers Extension .stm file.

Export Tab (Part Matchup Settings Dialog Box)
Use this tab to view or change the AutoCAD Civil 3D part types that will be matched up to Storm Sewers
part types when exporting pipe network data from AutoCAD Civil 3D to an .stm file.
The list of availableAutoCAD Civil 3D part types is displayed in the first column. In the second column,
click in a cell to select the Storm Sewers part type, and click OK.
Related procedures:
■

Setting Part Matching Defaults for Migration (page 1419)

■

Part Catalog Dialog Box (page 2273)

Exporting Structures
This section lets you specify the Storm Sewers part types that will be used when exporting structures from
AutoCAD Civil 3D to an .stm file.
Exporting Pipes
This section lets you specify the Storm Sewers part types that will be used when exporting pipes from
AutoCAD Civil 3D to an .stm file.
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67

Plan Production Tools
Dialog Boxes

The following topics describe the plan production tools dialog boxes.

Edit Feature Settings - View Frame Group Dialog Box
Use this dialog box to view and change view frame group-specific settings.
This topic documents settings in all view frame group-related Edit Settings dialog boxes (drawing-level,
feature-level, and command-level).
■

Drawing-level ambient settings are identified by the

■

View frame group feature settings are listed near the top of this dialog box, after the General property
group, and are identified by the

■

drawing icon.

view frame group icon.

View frame group command settings are identified by the

command icon.

For general information about drawing, feature, and command settings and their interaction, see Working
with the Standard Settings Dialog Box Controls (page 78).
For information about drawing-level ambient settings, see Ambient Settings Tab (Drawing Settings Dialog
Box) (page 2078)

Default Styles
Use these settings to specify the default styles assigned to view frame group components.
Match Line Style
Specifies the default style for match lines. Click in the Value column, and click
Match Line Style dialog box.

to select a style in the

View Frame Style
Specifies the default style for view frames. Click in the Value column, and click
View Frame Style dialog box.

to select a style in the
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Match Line Left Label Location
Specifies the default location for labels that are displayed on the left side of a match line. Click in the
value field to select a location from the list.
Match Line Right Label Location
Specifies the default location for labels that are displayed on the right side of a match line. Click in the
value field to select a location from the list.
View Frame Label Location
Specifies the default location on the view frame for view frame labels. Click in the value field to select a
location from the list.
View Frame Label Style
Specifies the default style for view frame labels. Click in the Value column, and click
in the View Frame Label Style dialog box.

to select a style

Match Line Label Style Left
Specifies the default style for labels that are displayed on the left side of a match line. Click in the Value
column, and click

to select a style in the Match Line Label Style Left dialog box.

Match Line Label Style Right
Specifies the default style for labels that are displayed on the right side of a match line. Click in the Value
column, and click

to select a style in the Match Line Label Style Right dialog box.

Profile View Style
Specifies the default profile view style. Click in the Value column, and click
Profile View Style dialog box.

to select a style in the

Profile View Band Set
Specifies the default style for profile view band sets. Click in the Value column, and click
style in the Profile View Band Set dialog box.

to select a

For information about style selection, see Select Style Dialog Box (page 2021).

Default Name Format
Use these settings to specify the default name formats for view frame group components (view frame groups,
view frames, match lines, layouts, and sheet files). Click in the Value column, and click
in the Name Template dialog box (page 2022).

to select a style

Sheet Creation
NOTE This property group is displayed when accessing the settings from the CreateSheets command.
Use these settings to specify the default styles assigned to sheet creation.
Sheet Creation Method
Specifies the default method for creating new sheets:
■

A specified number per new drawing

■

All in a new drawing

■

All in the current drawing
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Number of Layouts per Drawing
Specifies the number of layouts per new drawing.
Align North Arrow
Specifies whether the selected North arrow block is aligned to North.
North Arrow Block Name
Specifies the name of the selected North arrow, as entered in the cell.
Sheet Set Use
Specifies whether you create a New sheet set for any new sheets, or whether you Add To Existing sheet
sets.
Existing Sheet Set
Specifies the sheet set file to which you add a new sheet, if you select Add To Existing for Sheet Set Use.
Add to Vault
Specifies whether newly created sheet set files are added to Vault.
Align Profile and Plan View
Specifies whether profile and plan views are aligned:
■

At Start Station

■

At Center

■

At End Station

View Frame Creation
NOTE This property group is displayed when accessing the settings from the CreateViewFrames command.
Use these settings to specify the default styles assigned to view frame creation.
Alignment Station Range
Specifies whether creation of view frames is Automatic for the entire alignment, or for a User Specified
range.
Sheet Type
Specifies type of sheet to be created:
■

Plan And Profile

■

Plan Only

■

Profile Only

View Frame Orientation
Specifies whether view frames orient Along Alignment or Rotate To North orientation.
Enable First View Frame Offset
Specifies whether the first view frame is offset.
First View Frame Offset Distance
Specifies the distance by which the first view frame is offset. Enter a distance in the Value column or click
and select a distance in the drawing area.
Insert Match Line
Specifies whether match lines can be inserted.
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Match Line Snap Station
Specifies whether match lines snap down to a rounded station value.
Match Line Snap Station Value
Specifies a whole number, multiples of which are the station values.
Match Line Repositioning
Specifies whether match lines can be repositioned after placement.
Match Line Repositioning Value
Specifies the distance by which match lines can be repositioned after placement. Enter a distance in the
Value column or click

and select a distance in the drawing area.

Edit Feature Settings - View Frame Dialog Box
Use this dialog box to view and change standard drawing ambient settings for all view frame objects.
The standard drawing ambient settings are preceded with
. For feature-specific settings for View Frame
Style and the View Frame Name Template, see Edit Feature Settings - View Frame Group Dialog Box (page
2319).
For more information about this dialog box, see Working with the Standard Settings Dialog Box Controls
(page 78).

Edit Feature Settings - Match Line Dialog Box
Use this dialog box to view and change standard drawing ambient settings for all match line objects.
The standard drawing ambient settings are preceded with
. For feature-specific settings for Match Line
Style and the Match Line Name Template, see Edit Feature Settings - View Frame Group Dialog Box (page
2319).
For more information about this dialog box, see Working with the Standard Settings Dialog Box Controls
(page 78).

Create View Frames Wizard
Use this wizard to create a set of view frames that will be automatically placed along a selected alignment.
Using this wizard quickly leads you through the process of creating view frames along an alignment. The
view frames created will be automatically associated with a view frame group. When you finish using this
wizard, the view frame and view frame group objects are displayed in the drawing and in the Prospector
tree. If you chose to insert match lines, the match line objects are also displayed in the drawing and in the
Prospector tree.
For more information, see Creating View Frames for Plan/Profile Sheets (page 1904).

Alignment Page (Create View Frames Wizard)
Use this page of the wizard to select the alignment and station range for creating view frames.

Alignment
Select an alignment name in the list, or click
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and select an alignment in the drawing area.

Station Range
Specify a station range for the alignment that is currently selected in the Alignment field above.
Automatic
Selects the entire alignment.
User specified
When this option is selected, you may enter a value or click

to select a location in the drawing area.

If the Create View Frames button is unavailable (grayed out), it may be for one of the following reasons:
■

There are no templates available or selected.

■

There are no valid layouts in the selected template. For example, there are no appropriate viewports in
the selected template.

Related procedures:
■

Creating View Frames for Plan/Profile Sheets (page 1904)

Sheets Page (Create View Frames Wizard)
Use this page of the wizard to select the type of sheets to create, a template for the sheets, and to determine
how view frames are aligned.

Sheet Settings
Select the type of sheet to generate:
Plan And Profile
This is the default choice. The sheets that will be created will contain both a plan view and a profile view.
Plan Only
The sheets that will be created will contain plan views, but no profile views.
Profile Only
The sheets that will be created will contain profile views, but no plan views.
Template For Sheet
You must select the template to be used by the sheet. Browse to a template (.dwt) or enter a valid path to
specify the template to be used. When you click
to browse to a template, the Select Layout as Sheet Template (page 2338) dialog box is displayed.
If the Create View Frames button is disabled on this page of the wizard, it may be because a template has
not yet been selected in this field.
NOTE If you select a template that does not contain appropriately defined viewports, a message is displayed
on the Select Layout As Sheet Template dialog box indicating that no layouts contain the necessary viewports
for the selected sheet type. For more information, see Setting Up Drawing Templates for Plan Production (page
1902).

View Frame Placement
Specifies the orientation and placement of the view frame.
Along Alignment
When this option is selected, the view frames will be aligned following along the alignment. Typically,
this is the preferred method for making the most efficient use of paper when plotting.
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Rotate To North
When this option is selected, the view frames will be rotated according to the north orientation in the
drawing.
Set The First View Frame Before The Start Of The Alignment By
This option allows you to set a distance by which the first view frame is offset from the location on the
alignment where it begins. Entering a distance value here adds a margin so that the start location of your
view frame does not hide important drawing data that you want to display. If you leave this field blank,
some drawing data near the start of the first view frame may be too close to the start of the view frame.
Related procedures:
■

Creating View Frames for Plan/Profile Sheets (page 1904)

View Frame Group Page (Create View Frames Wizard)
Use this page of the wizard to specify criteria for creating the view frame group object.

View Frame Group
Name
Specifies the name for the view frame group.

Opens the Name Template (page 2022) dialog box, where you can modify the view frame group naming
template.
Description
Enter an optional text description identifying the view frame group.

View Frame
View Frame Layer
Displays the layer on which the view frame will be created.

Opens the Object Layer dialog box, where you can select a different layer for the view frame.
Name
Specifies the name of the view frame.
NOTE To name the view frame, either click on its default name and enter a new name, or use the naming
template.

Opens the Name Template (page 2022) dialog box, where you can modify the view frame naming template.
View Frame Style
Displays the style that is used to display certain components of the view frame, such as layer, line style,
line weight, color, and so on.

Click to select the style of a view frame in the drawing.
View Frame Label Style
Displays the style that is used to display labels on view frames. For more information, see Understanding
Labels (page 1646).
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Click to select the label style of a view frame in the drawing.
Label Location
Specifies the location where the label will be placed on the view frame. For example, selecting Top Left
places the label starting at the top left side of the view frame.
Related procedures:
■

Creating View Frames for Plan/Profile Sheets (page 1904)

Match Lines Page (Create View Frames Wizard)
Use this page of the wizard to configure a variety of choices that determine how and if match lines will be
placed on the view frames.
Insert Match Lines
Match lines are only displayed in Model space and in plan views. They are not displayed in profile views.
If you have selected to create plan and profile or profile only sheets, this option is automatically selected
and you cannot clear (edit) it.
When this option is selected, match lines will be inserted on the view frames in plan views. If you do not
want match lines on the view frames, clear this check box.

Positioning
Use these options to adjust where match lines are placed, and how they may be moved after creation, so
that they do not obstruct data that you want to display.
Snap Station Value Down To The Nearest
Clear this option to use a rounding value (calculation) for the match line positioning based on derived
stations. Select this option to use the rounding calculation value that is entered. The rounding calculation
always rounds down. For example, if the calculated station for a match line is 48+37.69, then a rounding
of 100 would place the match line on 48+00.
When Snap Station Value
Down To The Nearest is set
to ...

the station will round to

100

18+00

50

18+50

10

18+60

1

18+65

27+45.3 to 50

27+00 to the next lowest
multiple of 50

NOTE This option will not accept values that cause the match lines to be placed in undesirable locations, such
as before the previous match line or before the beginning of the alignment. If a rounding calculation would
result in the match line being placed in an undesirable location, then the rounding calculation is ignored and
the match lines are placed at calculated station.
Allow Additional Distance For Repositioning (Increases View Overlap)
This option gives you the ability to increase the distance that you can move match lines in plan view
after they have been created. When you increase this margin, or additional distance, the overlap area of
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the match lines increases. This option can also be used to force an overlap of frames in plan sheets only
when, on a straight line alignment for example, adjacent edges of two view frames might be coincident,
and therefore not provide enough room on either side of the match line for labeling and notes.

Match Line
Layer
Displays the layer that the match line will be created on.

Opens the Object Layer dialog box, where you can select a different layer for the match line.
Name
Specifies the name of the match line.
NOTE To name the match line, either click on its default name and enter a new name, or use the naming
template.

Opens the Name Template (page 2022) dialog box, where you can modify the match line naming template.
Match Line Style
Displays the style that is used to display the match line and the match line mask area. For more information,
see Match Line Style Dialog Box (page 2337) and/or Editing the Match Line Mask Area (page 1923).

Click to select the style of a match line in the drawing.

Labels
Left Label Style
Displays the style that is used to display the match line label that is on the left side of the match line.

Click to select the label style of a match line in the drawing.
Left Label Location
Specifies the location for the label that is placed on the left side of a match line. For example, selecting
End places the left side match line label at the end of the match line.
Right Label Style
Displays the style that is used to display the match line label that is on the right side of the match line.

Click to select the label style of a match line in the drawing.
Right Label Location
Specifies the location for the label that is placed on the right side of a match line. For example, selecting
End places the right side match line label at the end of the match line.
Related procedures:
■

Creating View Frames for Plan/Profile Sheets (page 1904)
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Profile Views Page (Create View Frames Wizard)
Use this page of the wizard to select the profile view style and band set that will be used for the profile views
displayed in the viewports (sheets).
It is important to understand that the profile view style and band set for the profile view cannot be changed
later when you are using the Create Sheets wizard to create sheets. For more information, see Understanding
Profile View Options (page 1915).
Profile View Style
Specifies the style that is used to display the profile views in the viewports (sheets).
Band Set
Specifies the band set that is used to display the profile views in the viewports (sheets). You can copy an
existing band set.
Related procedures:
■

Creating View Frames for Plan/Profile Sheets (page 1904)

Create Sheets Wizard
Use this wizard to automatically create sheets from a view frame group.
Using this wizard quickly leads you through the process of creating sheets from a selected view frame group.
The sheets created display the data that is inside each view frame within the view frame group. When you
finish using this wizard, you may want to then use the Sheet Set Manager to create, organize, and manage
sheet sets.
See also:
■

Creating Plan/Profile Sheets (page 1909)

View Frame Group and Layouts Page (Create Sheets Wizard)
Use this page of the wizard to select the view frame group and output settings for layout creation.

View Frame Group
Specifies the view frame group used to create the sheets. Click

to select a view frame group in the drawing.

View Frame Range
Specifies which view frames to include in the sheets.
■

All: This is the default setting. Select this option to create sheets for every view frame in the view frame
group.

■

Selection: When this is selected, the Choose View Frames button is available, and you can click it to
select one or more view frames from the list in the Select View Frame dialog box.

Layout Creation
These options determine how the layouts will be created.
Number Of Layouts Per New Drawing
This option may be an appropriate choice if you plan to have several people working on individual sheets.
When this option is selected, and you enter 1 for the value, you get one new layout (sheet) created in
each new drawing. The total number of sheets and drawings would depend on the length of the alignment
selected and other criteria, such as the size of the viewports in the referenced template.
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If you select this option and enter a value greater than one, three for example, three new layouts would
be created in each new drawing. The total number of sheets and drawings would depend on the length
of the alignment selected and other criteria, such as the size of the viewports in the referenced template.
You can enter an integer from 1 to 255.
All Layouts in One New Drawing
This option may be an appropriate choice if having each individual layout in a separate drawing is not
necessary for you, and if you have less than 10 sheets. You may place all the layouts in one newly created
drawing. The total number of sheets would depend on the length of the alignment selected and other
criteria, such as the size of the viewports in the referenced template. For optimal results, it is recommended
that you create no more than 10 sheets per drawing. Therefore, this option may not be the best choice if
you have more than 10 sheets.
All Layouts in The Current Drawing
If you are only generating less than 10 sheets, you may want to generate the layouts in the current drawing.
The total number of sheets would depend on the length of the alignment selected and other criteria, such
as the size of the viewports in the referenced template. For optimal results, it is recommended that you
create no more than 10 sheets per drawing. Therefore, this option may not be the best choice if you have
more than 10 sheets.
Layout Name
Specifies the name of the layout(s) that will be created.

Opens the Name Template (page 2022) dialog box, where you can modify the naming template for the
layouts.
Choose The North Arrow Block To Align In Layouts
All blocks that exist in the currently selected template are displayed in the drop-down list. If you select a
block from this list, that block will be aligned to the north on the sheet(s). Typically, this option is used
for aligning a north arrow block in the layouts.
Related procedures:
■

Creating Plan/Profile Sheets (page 1909)

Sheet Set Page (Create Sheets Wizard)
Use this page of the wizard to specify creation criteria for the sheet set, such as names and locations for the
sheet set, the sheet set file (.dst), and the sheet file.
Add Files To Vault
If you are currently logged in to a Vault, this field is available and automatically selected, and the following
files, which are related to the sheet set creation, will be checked in to the Vault:
■

Sheet files created from this wizard session

■

Sheet set files created from this wizard session

This field is not available if you are not currently logged in to a Vault, or if Autodesk Vault is not installed.
Log in to Vault...
This button is not available (grayed out) if you are already logged in to a Vault, or if Vault is not installed
on the machine. Clicking this button displays the Vault Log In dialog box which prompts you to log in
to a Vault server and a Vault database. If you wish to use Vault to manage the files created during this
wizard session, you must be logged in to Vault.
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Sheet Set
Use these options either to create a new sheet set or add to an existing sheet set. You can also specify the
storage location of the sheet set file associated with the new or existing sheet set.
New Sheet Set
Creates a new sheet set using the name of the view frame group displayed in the text box.
Add To Existing Sheet Set
Creates sheets adds them to an existing sheet set. Click

to select a sheet set.

Sheet Set File (.DST) Storage Location
Specifies the location where the sheet set file created or used during this session is located. Click
to
select a location. If you selected Add to Existing Sheet Set, this field displays the location of the sheet set
file for the sheet set that you selected in that field.

Sheets
These options determine how the sheet files will be named and stored. If you have chosen to save all sheets
in the current drawing (the All Layouts In The Current Drawing choice on the Create Sheets wizard View
Frame Group and Layouts page), these fields are not available (read only, grayed out).
Sheet Files Storage Location
Specifies the location where the sheet files created during this session will be located. Click
to select
a location.
If you are logged in to a project in Vault, by default this path displays the root folder for the project. If
you are not logged in to a project in Vault, by default this path is set to the directory containing the
working (current) drawing.
Sheet File Name
Specifies the name of the sheet file(s) that will be created.

Opens the Name Template (page 2022) dialog box, where you can modify the naming template for the sheet
files.
Related procedures:
■

Creating Plan/Profile Sheets (page 1909)

Profile Views Page (Create Sheets Wizard)
Use this page of the wizard to view the profile view style and band set selected during view frame creation.
While you cannot change the profile view style or the band set chosen, you can configure certain other
profile view options.
If you want to change the profile view style or band set, click Cancel on the Create Sheets wizard, return to
the Create View Frames wizard, change the profile view style and/or the band set there, recreate the view
frames, and then use the Create Sheets wizard. Optionally, you can launch the Profile View Wizard from
this page by choosing Choose Settings, and then clicking Profile View Wizard. This lets you change a variety
of profile view options. For more information, see Understanding Profile View Options (page 1915).
If you have chosen an output that does not include profiles, this page of the Create Sheets wizard is skipped
(not displayed), and the Data References page of the Create Sheets wizard is displayed.
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Profile View Settings
Profile View Style To Be Used
This read-only field displays the profile view style that was chosen during frame view creation. This is the
profile view style that will be added to each profile view.
Band Set To Be Used
This read-only field displays the band set that was chosen during frame view creation. This is the band
set that will be used to generate these sheets.

Other Profile View Options
Use these options to change certain settings on the profile views that will be used to create these sheets. For
more information, see Understanding Profile View Options (page 1915). If you do not want to change any
profile view settings, click Next.
Get Other Settings From An Existing Profile View
Select this option if you want to use the settings from another profile view in the current drawing. Select
a profile view in the list or click

to select a profile view in the drawing.

Choose Settings
Select this option if you want to use the Create Multiple Profile Views wizard to select options from
multiple profile views. When this option is selected, the Profile View Wizard button is available.
Profile View Wizard
Click the Profile View Wizard button to open the Create Multiple Profile View wizard. At this point in
the Create Sheets wizard, you can use the Create Multiple Profile Views wizard to create multiple profile
views if desired. If you use this option, multiple profile views will be created and placed in model space
in the file containing the sheets. At the end of the Create Multiple Profile Views wizard session, you are
returned to the Profile Views page of the Create Sheets wizard.

Align Views
When creating plan and profile sheets, you can choose how to align the data that is displayed in the plan
and profile views. If you are creating plan only or profile only sheets, these options are not available. These
options are useful on projects that require the data displayed in sheets to be aligned according to certain
project requirements (such as aligned left, center, or right).
Align Profile And Plan View At Start
The left side (start station) match line in the plan view aligns with the left side (start) of the profile view.
Align Profile And Plan View At Center
The center of the plan view aligns with the center point of the profile view.
Align Profile And Plan View At End
The right side (end station) match line in the plan view aligns with the right side (end) of the profile view.
Related procedures:
■

Creating Plan/Profile Sheets (page 1909)

Data References Page (Create Sheets Wizard)
Use this page of the wizard to select the data that you want referenced in your sheets.
In the collections that are displayed, items that are required for creating the sheets, such as the selected
alignments and profiles, are already selected. You cannot edit these items because you cannot clear the check
mark. All other items that are available are expanded in the tree. Select the items in the tree that you want
to include in your sheets.
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If you have chosen to have the sheets saved in the current file, (in other words, if you have chosen All
Layouts In The Current Drawing on the View Frame Group And Layouts page of the Create Sheets wizard),
then the Data References page of the Create Sheets wizard is skipped (not displayed).
Pick From Drawing
Click to select the objects in the drawing.
Copy Pipe Network Labels To Destination Drawings
Selecting this option copies any pipe network labels to the destination drawing(s). If no pipe networks
exist, this option is not available.
Related procedures:
■

Creating Plan/Profile Sheets (page 1909)

View Frame Properties Dialog Box
Use this dialog box to view the properties of a view frame, such as the view frame name, description, and
style.
The View Frame Properties dialog box also lists the view frame group, which template was used, and whether
a sheet has been created from the view frame.
See also:
■

Editing View Frames (page 1919)

Information Tab (View Frame Properties Dialog Box)
Use this tab to view or change general information for the view frame using the following settings:
Name
Specifies the name of the current view frame.
Description
Specifies an optional description for the current view frame.
Object Style
Specifies the default view frame style used to display view frames. Select a style in the list or use the
standard style selection tools. For more information about the standard style selection tools, see the Select
Style (page 2021) dialog box.
Show Tooltips
Specifies whether tooltips are displayed for the object in the drawing (not over toolbar icons).

View Frame Tab (View Frame Properties Dialog Box)
Use this tab to view the parameters of the current view frame, including the alignment name, view frame
group, view frame number, orientation, and station values.
Alignment
This read-only field displays the alignment that was used to create the view frame group.
View Frame Group
This read-only field displays the name of the view frame group this view frame belongs to.
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View Frame Number
This read-only field indicates the order in which this view frame is displayed in the sequence of view
frames in this view frame group. For example, the first view frame displayed in the view frame group has
a view frame number of 1. If there are a total of eight view frames in the view frame group, the last view
frame in the group would have a view frame number of 8. Note that the view frame number is not related
to the number counter that may be included in the view frame naming template.
View Frame Orientation
Displays the orientation of the view frame; either Rotate To North or Along Alignment, depending on
which option was selected in the View Frame Placement section of the Sheets page (Create View Frames
wizard).
Start Station
Displays the station value at which the match line associated with this view frame begins.
End Station
Displays the station value at which the match line associated with this view frame ends.

Sheet Tab (View Frame Properties Dialog Box)
Use this tab to view the sheet settings of the current view frame.
Sheet
This read-only field displays the path, filename, and layout name for the sheet file containing the layout
(sheet), if it has been generated. Otherwise it displays No Sheet Created.
Type
This read-only field displays the type of sheet (Plan And Profile, Plan Only, or Profile Only).
Sheet Set
This read-only field displays the path where the sheet set file associated with this view frame is stored, if
it has been generated. Otherwise it displays No Sheet Created.
Template Source
This read-only field displays the path, filename, and layout name for the sheet file/layout that was used
for the sheet creation.

Match Line Properties Dialog Box
Use this dialog box to view or change the properties of a match line, such as the match line style, name,
and description.
The Match Line Properties dialog box also lists the match line number and which alignment station it is
associated with.
See also:
■

Editing Match Lines (page 1923)

Information Tab (Match Line Properties Dialog Box)
Use this tab to view or change general information for the match line.
Name
Specifies the name of the current match line.
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Description
Specifies an optional description for the current match line.
Object Style
Specifies the default match line style used to display the match line and the match line mask area (page
1923). Select a style in the list or use the standard selection tools. For more information about the standard
style selection tools, see the Select Style (page 2021) dialog box. For more information about the match line
style components, see Match Line Style Dialog Box (page 2337).
Show Tooltips
Specifies whether tooltips are displayed for the object in the drawing (not over toolbar icons).

Match Line Tab (Match Line Properties Dialog Box)
Use this tab to view the parameters of the current match line, including the alignment name, match line
number, the station value where the match line is located, and the name of the view frame group that this
match line is associated with.
Alignment
Specifies the alignment that this match line is associated with.
Match Line Number
This read-only field indicates the order in which this match line is displayed in the sequence of match
lines in this view frame group. For example, the first match line displayed in the view frame group has a
match line number of 1. If there are a total of eight match lines in the view frame group, the last match
line in the group would have a match line number of 8. Note that the match line number is not related
to the number counter that may be included in the match line naming template.
Station
This read-only field displays the station value where this match line is located.
View Frame Group
This read-only field displays the name of the view frame group that this match line is associated with.

View Frame Group Properties Dialog Box
Use this dialog box to view or change the properties of a view frame group.
These are the default settings that are used when new view frames are added to a view frame group.

Information Tab (View Frame Group Properties Dialog Box)
Use this tab to view or change general information for the view frame group object.
Name
Specifies the name of the current view frame group.
Description
Specifies an optional description for the current view frame group.
Show Tooltips
Specifies whether tooltips are displayed for the object in the drawing (not over toolbar icons).
Related procedures:
■

Creating View Frames for Plan/Profile Sheets (page 1904)
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View Frames Tab (View Frame Group Properties Dialog Box)
Use this tab to view and edit the parameters of the view frames associated with the current view frame group.
These are the default settings that are used when new view frames are added to a view frame group using
the InsertViewFrame command.

View Frame Group Defaults
View Frame Style
Displays the style that is used to display the view frame.

Click to select the style of a view frame in the drawing.
View Frame Layer
Displays the layer that the view frame will be created on.

Click to open the Object Layer dialog box, where you can select a different layer for the view frame.
Name
Specifies the name of the view frame.
NOTE To name the view frame, either click on its default name and enter a new name, or use the naming
template.

Click to open the Name Template (page 2022) dialog box, where you can modify the view frame naming
template.
The view frames table contains the following columns:
Number
This read-only field displays the number assigned to each view frame in this view frame group.
Name
Specifies the name of the view frame. You can change the name by clicking in the field.
Description
Specifies an optional description of the view frame. You can change the description by clicking in the
field.
Begin Station
This read-only field displays the station along the alignment where this view frame begins. If the alignment
that was used to create this view frame is unavailable or has been deleted, Not Available is displayed.
End Station
This read-only field displays the station along the alignment where this view frame ends. If the alignment
that was used to create this view frame is unavailable or has been deleted, Not Available is displayed.
End Station
This read-only field displays the station along the alignment where this view frame ends. If the alignment
that was used to create this view frame is unavailable or has been deleted, Not Available is displayed.
Layer
Specifies the layer of the view frame. You can change the layer by clicking in the field.
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Style
Specifies the style of the view frame. You can change the style by clicking in the field.
Layout Path
This read-only field displays the path and filename of the layouts that are used by the view frames in this
view frame group. If it was not generated, then No Sheet Generated is displayed.

Match Lines Tab (View Frame Group Properties Dialog Box)
Use this tab to view and edit the parameters of the match lines associated with the current view frame group.
These are the default settings that are used when new match lines are added to a view frame group using
the InsertViewFrame command.

View Frame Group Defaults
Match Line Style
Displays the style that is used to display the match line and the match line mask area. Editing the Match
Line Mask Area (page 1923)

Click to select the style of a match line in the drawing.
Match Line Layer
Displays the layer that the match line will be created on.

Click to open the Object Layer dialog box, where you can select a different layer for the match line.
Name
Specifies the default name template used for new match lines.
NOTE To name the match line, click on its default name and enter a new name or use the naming template.

Click to open the Name Template (page 2022) dialog box, where you can modify the match line naming
template.
The match lines table contains the following columns:
Number
This read-only field displays the number assigned to each match line in this view frame group.
Name
Specifies the name of the match line. You can change the name by clicking in the field.
Description
Specifies an optional description of the match line. You can change the description by clicking in the
field.
Station
This read-only field displays the station along the alignment where this match line is placed. If the
alignment that was used to create this view frame group is unavailable or has been deleted, Not Available
is displayed.
Layer
Specifies the layer of the match line. You can change the layer by clicking in the field.
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Style
Specifies the style of the match line. You can change the style by clicking in the field.
Sheet Left
This read-only field displays the filename and sheet name of the sheet that is on the left side of the match
line.
Sheet Right
This read-only field displays the filename and the sheet name of the sheet that is on the right side of the
match line.

Profile Views Tab (View Frame Group Properties Dialog Box)
Use this tab to view the parameters of the profile view(s) that may be associated with the current view frame
group.

Profile View Style
Profile View Style To Be Used
This read-only field shows you the style that will be used to display the profile view(s) associated with
this view frame group.

Band Set
Band Set Style To Be Used
This read-only field shows you the style that will be used to display the band sets for profile view(s)
associated with this view frame group.

View Frame Style Dialog Box
Use this dialog box to make it easier to locate and work with view frames by changing their display.
The view frame style controls the appearance of view frames.
See also:
■

View Frame Styles and Display (page 1931)

Information Tab (View Frame Style Dialog Box)
Use this tab to change the view frame style name and description information, and to review details about
the style, such as when it was most recently modified.
For more information, see Information Tab (Style Dialog Box) (page 2017).

Display Tab (View Frame Style Dialog Box)
Use this tab to change the display and visibility of view frames.

View Direction
Some object styles can have unique display values and varying numbers of displayed components, depending
on whether they are being displayed in Plan, Profile, Section, or Model views. You can create and set style
characteristics for each supported view direction type using the View Direction list.
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Plan
Specifies the display style settings when the view frame is displayed in plan view. For view frames, only
Plan View Direction is supported.

Component Display
View Frame Border
This is the closed polyline entity that represents the extents of a view frame. You can set the following
style characteristics for this component: Visibility, Layer, Color, Linetype, LT Scale, and Lineweight.
For more information, see Display Tab (Style Dialog Box) (page 2017).

Summary Tab (View Frame Style Dialog Box)
Use this tab to review all the information about the current view frame style.
You can copy and paste this information to the clipboard. For more information, see Summary Tab (Style
Dialog Box) (page 2020).

Match Line Style Dialog Box
Use this dialog box to make it easier to work with match lines by changing their display characteristics.
The match line style controls the appearance of the match line and the match line mask area.
See also:
■

Match Lines Styles and Display (page 1933)

■

Editing the Match Line Mask Area (page 1923)

Information Tab (Match Line Style Dialog Box)
Use this tab to view or change the match line style name and description information, and to review details
about the style, such as when it was most recently modified.
For more information, see Information Tab (Style Dialog Box) (page 2017).

Display Tab (Match Line Style Dialog Box)
Use this tab to view or change the display and visibility of match lines and the match line mask area.

View Direction
Plan
Some object styles have unique display values and varying numbers of displayed components, depending
on whether Plan, Profile, Section, or Model is selected for View Direction. For match lines, only Plan View
Direction is supported.

Component Display
Lines
Specifies the style for match lines. Match lines are only displayed in plan views, not profile views. You
can set the following style characteristics for match lines: Visibility, Layer, Color, Linetype, LT Scale,
Lineweight, and Plot Style.

Summary Tab (View Frame Style Dialog Box) | 2337

Match Line Mask
Specifies the style for the match line mask areas. Match line mask areas are only displayed in plan view
and in paper space. The the match line mask area is the area outside of match lines, between the outside
of the match line, and the inside of the view frame boundary.

Component Hatch Display
Match Line Mask
Specifies the hatch pattern for the match line mask areas, which are only displayed in plan views, not
profile views. You can define a pattern, angle and scale for hatching in this closed polyline area. For more
information, see The Match Line Object (page 1932) and Editing the Match Line Mask Area (page 1923).
For more information, see Display Tab (Style Dialog Box) (page 2017).

Summary Tab (Match Line Style Dialog Box)
Use this tab to review all the information about the current match line style.
You can copy and paste this information to the clipboard. For more information, see Summary Tab (Style
Dialog Box) (page 2020).

Select Layout as Sheet Template Dialog Box
Use this dialog box to select the template to use when you create a view frame group using the Create View
Frames wizard.
The choices you make in this dialog box define the folder path, drawing template (DWT) file, and a layout
name that will be used for creating the new sheets. You must choose a template that has viewports defined
appropriately. For example, if you want to choose a template that contains viewports for both plan and
profile views, you must select a template that contains viewports with Viewport Types that are defined as
“plan” and “profile”.
If you try to select a template that does not have appropriately defined viewports for the sheet type you
selected on the Sheets page of the Create View Frames wizard (Plan Only, Profile Only, or Plan and Profile),
AutoCAD Civil 3D detects this and displays the following message: No layouts contain the necessary viewports
for this sheet type.
For more information, see Setting Up Drawing Templates for Plan Production (page 1902).
Drawing Template File Name
Specifies the drawing template file path and name that will be used for creating the new sheets. Click
to select a valid template for the sheet(s) that will be created later when using the Create Sheets wizard.
Select A Layout To Create New Sheets
Lists and specifies the name of the layout in the drawing template file to be used for the new sheet(s) that
will be created later when using the Create Sheets wizard.
Related procedures:
■

AutoCAD Help topics about Creating and Managing a Sheet Set

Edit Match Line Group Labels Dialog Box
Use this dialog box to change label styles and locations for all match lines in a view frame group.
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Left Match Line Label Style
Specifies the style for the labels that are displayed on the left side of a match line. You can choose a label
style from the list.
Right Match Line Label Style
Specifies the style for the labels that are displayed on the right side of a match line. You can choose a label
style from the list.
Style Selection
Specifies the label style options. You can create a new label style, copy or edit the current style selection,
or pick a style from the drawing.
Style Detail
Opens the Style Detail dialog box. Preview the style and creation information.
Left Label Location
Specifies the location for labels that are displayed on the left side of a match line. Click in the value field
to select a location from the list.
■

Start: Places the left match line label at the start of the match line, near the top of the view frame.

■

End: Places the left match line label at the end of the match line, near the bottom of the view frame.

■

Middle: Places the left match line label at the middle of the match line.

■

Alignment Intersection: Places the left match line label where the alignment intersects the match line.

Right Label Location
Specifies the location for labels that are displayed on the right side of a match line. Click in the value field
to select a location from the list.
■

Start: Places the right match line label at the start of the match line, near the top of the view frame.

■

End: Places the right match line label at the end of the match line, near the bottom of the view frame.

■

Middle: Places the right match line label at the middle of the match line.

■

Alignment Intersection: Places the right match line label where the alignment intersects the match
line.

Related procedures:
■

Labeling Match Lines (page 1926)

Edit Match Line Labels Dialog Box
Use this dialog box to change label styles and locations for a match line.
Match Line Label Style
Specifies the style for the labels that are displayed on a match line. You can choose a label style from the
list.
Style Selection
Specifies the label style options. You can create a new label style, copy or edit the current style selection,
or pick a style from the drawing.
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Style Detail
Opens the Style Detail dialog box. Preview the style and creation information.
Label Location
Specifies the location for labels that are displayed on a match line. Click in the value field to select a
location from the list.
■

Start: Places the match line label at the start of the match line, near the top of the view frame.

■

End: Places the match line label at the end of the match line, near the bottom of the view frame.

■

Middle: Places the match line label at the middle of the match line.

■

Alignment Intersection: Places the match line label where the alignment intersects the match line.

Related procedures:
■

Labeling Match Lines (page 1926)

Edit View Frame Labels Dialog Box
Use this dialog box to change label styles and locations for a view frame.
View Frame Label Style
Specifies the style for the labels that are displayed on a view frame. You can choose a label style from the
list.
Style Selection
Specifies the label style options. You can create a new label style, copy or edit the current style selection,
or pick a style from the drawing.
Style Detail
Opens the Style Detail dialog box. Preview the style and creation information.
Label Location
Specifies the location for labels that are displayed on a view frame. Click in the value field to select a
location from the list. For example, choosing Top Left places the view frame labels at the top left side of
the view frame.
Related procedures:
■

Labeling View Frames (page 1921)

Create Section Sheets Dialog Box
Use this dialog box to create paper space layouts that contain the section views in your drawing.
You must use the Production placement option in the Create Multiple Section Views wizard before using
the Create Section Sheets command. For more information, see Section Placement Page (Create Multiple
Section Views Wizard) (page 2487).
All layouts are created in the current drawing, using the template you selected when you created the section
views.
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TIP You can use the
object selection button to quickly select a section view group in the drawing. Or, you
can use the drop-down lists to select the alignment, sample line group, and section view group. The section view
group must have been created using the Production option of the Create Multiple Views command.
Select Alignment
Filters the Sample Line Group Name list so it shows the available sample line groups for the selected
alignment.
NOTE Select a section view group directly or use the Select Alignment and Sample Line Group Name lists to
filter the Select Section View Group selection.
Sample Line Group Name
Filters the list of available section view groups.
Select Section View Group
Specifies the section view group for which to create layouts.

Layout Settings
Layout Name
Specifies the name template for the layouts. All layouts are created in the current drawing.

Sheet Set
NOTE A sheet subset is created in the Sheet Set File each time the command is run. Sheets are not overwritten.
New Sheet Set
Creates a new sheet set of the layouts that are created. Enter the sheet set name.
Add To Existing Sheet Set
Adds the layouts to an existing sheet set. Click

to select the sheet set.

Sheet Set File (.DST) Storage Location
Specifies the sheet set storage location for both new and existing sheet sets.
Related procedures:
■

Section Sheet Production (page 1934)
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Points Dialog Boxes

Use the following links to access information about the Points dialog boxes.

Edit Feature Settings - Point Dialog Box
Use this dialog box to view and change point-related settings.
This topic documents settings in all point-related Edit Settings dialog boxes (drawing-level, feature-level,
and command-level).
■

Drawing-level ambient settings are identified by the

■

Point feature settings are listed near the top of this dialog box, after the General property group, and are
identified by the

■

drawing icon.

point icon.

Point command settings are identified by the

command icon.

You can also change the settings at the command level in the Create Points dialog box.
For general information about drawing, feature, and command settings and their interaction, see Working
with the Standard Settings Dialog Box Controls (page 78).
For information about drawing-level ambient settings, see Ambient Settings Tab (Drawing Settings Dialog
Box) (page 2078)

Default Styles
Use these settings to establish the default styles assigned to points and points labels.
IMPORTANT By default, in the Create Points dialog box - Points Creation section the Disable Description Keys
value is set to false and the controls in the Default Styles section are not available. To enable the Default Styles
controls, set the Disable Description Keys value to true.
Point Style
Specifies the default point style. Click in the Value column, and click
dialog box.

to select a style in the Point Style
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Point Label Style
Specifies the default point label style. Click in the Value column, and click
Label Style dialog box.

to select a style in the Point

For information about style selection, see Select Style Dialog Box (page 2021).

Default Name Format
Use these settings to specify the default name formats for new points and point groups. Click in the Value
column, and click

to make changes in the Name Template dialog box (page 2022).

Update Points
Use this setting to specify whether you can change local copies of project points without checking them
out.
WARNING If you edit local copies of project points in a drawing without checking them out, you cannot check
the points in to the project. Your changes exist only in the drawing in which you made them.
Allow Checked-In Points To Be Modified
Specifies whether you can change checked in points when you are working offline.
For more information, see Editing the Update Points Settings (page 441).

Point Identity
Use these settings to assign defaults for point number identity.
Next Point Number
Specifies the next available point number.
Use Sequential Numbering
Specifies whether points are automatically numbered in sequence as they are created.
■

False: Prompts you to assign point numbers as you create points.

■

True: Automatically numbers points in sequence, starting with the number specified in Next Point
Number

Point Number Offset
Specifies the offset added to imported point numbers when If Point Numbers Are Supplied is set to Add
An Offset. Enter an offset.
Sequence Point Numbers From
Specifies the starting point number for imported points when If Point Numbers Need To Be Assigned is
set to Sequence From. Enter a starting point number.
If Point Numbers Are Supplied
Specifies how to handle point numbers that are included in the point data being imported:
■

Use: Uses the point numbers in the point data file to create points during import.

■

Ignore: Does not use the point numbers in the point data file to create points during import. Points
are numbered according to the If Point Numbers Need To Be Assigned setting.

■

Add an Offset: Adds a fixed value, the value specified in Point Number Offset, to each point number
in the point data file. For example, if you specify 200 for Point Number Offset, then points with
numbers 1, 2, and 3 in the point data file are numbered 201, 202, and 203 when imported.
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Force Names
Specifies if null point names are allowed.:
■

False: Point names are not automatically assigned to a point when it is created or imported.

■

True: Point names are always assigned to a point when it is created or imported.

If Point Numbers Already Exist
Specifies how to handle point numbers that already exist when the same point number is present in the
data being imported:
■

Renumber: Assigns new point numbers to any imported points whose point numbers already exist.
Points are numbered according to the If Point Numbers Need To Be Assigned setting.

■

Merge: Merges the point data of the existing point with the point data of the imported point. Point
properties, such as elevation or raw description, that are specified in the point data file overwrite the
point properties existing in the drawing. Point properties that are not specified in the point data file
are preserved in the drawing.

■

Overwrite: Overwrites all point properties using the values in the point data file. No data is preserved;
point properties that are not specified in the point data file are blank in the drawing.

■

Notify: Notifies you that a point number collision has occurred. Opens the Duplicate Point Number
(page 2374) dialog box where you can specify how to resolve the collision.

NOTE For more information about how the Merge and Overwrite options work, see Editing the Point Identity
Settings (page 442).
If Point Names Already Exist
Specifies how to handle point names that already exist when the same point name is present in the data
being imported:
■

Use Name Template: Uses the name specified in the Point Name Template.

■

Counter: Increments a counter to the current point name.

■

Notify: Notifies you that a point name collision has occurred. Opens the Duplicate Point Name (page
2375) dialog box where you can specify how to resolve the collision.

If Point Numbers Need To Be Assigned
Specifies how new point numbers are assigned, when required, during import:
■

Use Next Point Number: Points are created using the next available point number.

■

Sequence From: Points are created beginning with the point number specified in Sequence Point
Numbers From. Additional points are created with point numbers specified by incrementing the starting
point number. For example, if you specify 300 for Sequence Point Numbers From, the first point is
created with point number 300, the second point is created with point number 301, and the next
point is created with point number 302.

Table Creation
NOTE This property group is displayed when accessing the settings from the AddPointTable command.
Use these settings to establish the defaults when you add a point table.
Table Style
Specifies the style for a table. Click in the Value column, and click
dialog box.

to select a style in the Table Style
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Split Table
Specifies whether a table is split into two or more sections after a specified maximum number of rows has
been met.
Maximum Number of Rows
Specifies the maximum number of rows to include per section. If the number of data rows exceeds the
specified maximum, the table is split into sections, and they are displayed either side by side (left to right),
or stacked vertically.
Maximum Tables Per Stack
Specifies the maximum number of sections to include in each stack.
Table Spacing
Specifies the spacing between tables.
Tile Direction
Specifies the direction in which the table tiles (across or down).

Default Layer
NOTE This property group is displayed when accessing the settings from the ConvertPointsToSdskPoints and
CreatePoints commands.
Use this setting to establish default layer information when you create points.
Layer
Specifies a default layer. Click in the Value column, and click
Selection dialog box (page 2222).

to select or create a layer in the Layer

Points Creation
NOTE This property group is displayed when accessing the settings from the CreatePoints command.
Use these settings to establish default information for creating points.
Local Coordinates
Specifies the order and format used to display local coordinates on the command line during point creation:
■

Easting - Northing

■

Northing - Easting

■

X-Y

■

Y-X

Grid Coordinates
Specifies the order in which grid coordinates are displayed on the command line during point creation:
■

Grid Easting - Grid Northing

■

Grid Northing - Grid Easting

Geographic Coordinates
Specifies the order in which geographic coordinates are displayed on the command line during point
creation:
■

Latitude - Longitude

■

Longitude - Latitude
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Prompt For Elevations
Specifies how elevations are assigned point creation:
■

Automatic: Creates points using the elevation value specified in Default Elevation.

■

Manual: Prompts you to enter an elevation at the command line when a point is created.

■

None: Creates points without elevations.

NOTE If you are prompted for an elevation while creating a point and you want to create a point without an
elevation, enter a period (.) at the prompt
Prompt For Point Names
Specifies how point names are entered during point creation:
■

Automatic: Point names will automatically be assigned based on the point name template.

■

Manual: Prompts for a point name at the command line when a point is created.

■

None: Creates points without point names.

Prompt For Descriptions
Specifies how descriptions are assigned during point creation:
■

Automatic: Creates points using the description specified in Default Description.

■

Automatic-Object: Creates point description from the object.
NOTE Use the Automatic - Object option with commands from the Creating Points Based on Horizontal
Alignments (page 489) list. When you specify this option the Alignment name and Station display in the Raw
Description column in the Point Editor window.

■

Manual: Prompts for a description at the command line when a point is created.

■

None: Creates points without descriptions.

NOTE If you are prompted for a description while creating a point and you want to create a point without a
description, enter a period (.) at the prompt.
Default Elevation
Specifies the elevation automatically assigned by the point creation commands when the Prompt For
Elevations setting is set to Automatic. Enter an elevation in the Value column or click
elevation in the drawing area.

and select an

Default Description
Specifies the description that is automatically assigned by the point creation commands when Prompt
For Descriptions is set to Automatic.
Match On Description Parameters ($1, $2, Etc.)
Specifies whether parameters are used in description key matching to rotate and scale the point symbol.
For more information, see Controlling Whether Raw Description Values Are Interpreted as Parameters
During Point Creation (page 573).
Disable Description Keys
Specifies whether description key matching occurs during point creation. For more information, see
Activating Description Key Matching (page 573).
NOTE If you change this setting, then the Disable Description Keys check box on the Create Points dialog box
is also changed to the same state.
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Echo Coordinates To Command Line
Specifies whether coordinates are displayed on the command line when creating points.
Related procedures:
■

Point Settings (page 439)

Point Group Properties Dialog Box
Use this dialog box to change the properties of a point group.

Information Tab (Point Group Properties Dialog Box)
Use this tab to view or change general information for the point group.
Name
Specifies the point group name. Change the number and the increment display in the Point Feature
Settings. For more information, see Working with the Standard Settings Dialog Box Controls (page 78).
Description
Specifies a description for the point group.
Default Styles
Point Style
Specifies the default point style used to display a point in the point group, if no other style takes precedence.
For more information, see Point Group Default Styles (page 555).
NOTE Changing the default point style updates the point style on the Overrides tab.
Point Label Style
Specifies the default point label style used to display a point in the point group, if no other style takes
precedence. For more information, see Point Group Default Styles (page 555).
NOTE Changing the default point label style updates the point label style on the Overrides tab.
Object Locked
Specifies whether changes can be made to the point group in the drawing. Select the check box to lock
the point group and prevent changes. For more information, see Locking and Unlocking Point Groups
(page 560).
Show Tooltips
Controls whether tooltips are displayed for the object in the drawing (not over toolbar icons).
For more information about how point group styles are used to display a point, see Controlling the Appearance
of Points in a Drawing (page 454).
Related procedures:
■

Creating Point Groups (page 561)

Point Groups Tab (Point Group Properties Dialog Box)
Use this tab to include points in a point group by specifying one or more other point groups.
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Point Group
Lists all point groups in the drawing. Select the check box next to the name of any point group you want
to include in the current point group.
Description
Lists point group descriptions.
Information specified on this tab also appears on the Query Builder tab.
NOTE If an included point group is out-of-date, any point group that includes it is also out-of-date. For more
information, see Out-of-Date Point Groups (page 556).
Related procedures:
■

Creating Point Groups (page 561)

Raw Desc Matching Tab (Point Group Properties Dialog Box)
Use this tab to include points in a point group using raw description matching based on available description
key codes.
This tab lists the description key codes for all the description keys in the drawing. When you select the check
box next to a description key code, any point with a raw description that matches that code is included in
the point group.
Code
Lists description key codes for all the description keys in the drawing. Select the check box next to the
name of the description key codes you want to match.
Format
Specifies the format for the description key whose code is listed.
For more information about description keys, see Understanding Description Keys (page 571).
Information specified on this tab also appears on the Query Builder tab.
NOTE You can include or exclude a point from a point group based on its raw or full description. For more
information, see Include Tab (Point Group Properties Dialog Box) (page 2349) and Exclude Tab (Point Group Properties
Dialog Box) (page 2350).
Related procedures:
■

Creating Point Groups (page 561)

Include Tab (Point Group Properties Dialog Box)
Use this tab to include points in a point group by point number, description, name, elevation, or by selection.
With Numbers Matching
Includes a point in the point group based on its point number or by selection:
■

Enter point numbers or ranges of point numbers separated by commas. Specify a range of point numbers
by separating the beginning and ending numbers with a hyphen (for example, 100-105).

■

Click Selection Set In Drawing and select points from the drawing using standard AutoCAD selection
techniques.
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■

Click Project Points In Window and define a window by specifying two points in the drawing. The
project northing and easting coordinates of the window corners are used to determine which project
points are contained in the window. All points in the project to which the drawing is attached, and
which fall within the window, are included in the point group.

With Elevations Matching
Includes a point in the point group based on its elevation. Enter any combination of the following,
separated by commas:
■

An individual elevation

■

A greater than sign (>) followed by an elevation. Includes all points with an elevation above the
specified value

■

A less than sign (<) followed by an elevation. Includes all points with an elevation below the specified
value

■

An elevation range, which is specified by separating the beginning and ending numbers with a hyphen
(for example, 1-100). Includes all points with an elevation that falls within the range

For example, <-100,1-100,110.01,>200 would include all points whose elevations meet one of the following
criteria: less than -100, equal to or between 1 and 100, equal to 110.01, or greater than 200.
With Names Matching
Includes a point in the point group based on its name. Enter one or more point names separated by
commas.
With Raw Descriptions Matching
Includes a point in the point group based on its raw description. Enter one or more raw descriptions
separated by commas, for example IP*,GB*,TREE,STA.
The asterisk (*) is a wild card that matches any string. For example, the code IP* will match all raw
descriptions that begin with IP, so the raw description IPS matches the description IP*.
With Full Descriptions Matching
Includes a point in the point group based on its full description. Enter one or more full descriptions
separated by commas, for example IP*,GB*,TREE,STA.
The asterisk (*) is a wild card that matches any string. For example, the code IP* will match all full
descriptions that begin with IP, so the full description IPS matches the description IP*.
Include All Points
Includes all points in the drawing in the point group. When the check box is selected, all other options
on the tab are disabled.
Information specified on this tab appears on the Query Builder tab.
Related procedures:
■

Creating Point Groups (page 561)

Exclude Tab (Point Group Properties Dialog Box)
Use this tab to exclude points from a point group by point number, description, name, elevation, or by
selection.
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With Numbers Matching
Excludes a point from the point group based on its point number or by selection. Select the check box
and do one of the following:
■

Enter point numbers or ranges of point numbers separated by commas. Specify a range of point numbers
by separating the beginning and ending numbers with a hyphen (for example, 100-105).

■

Click Selection Set In Drawing and select points from the drawing using standard AutoCAD selection
techniques.

■

Click Project Points In Window and define a window by specifying two points in the drawing. The
northing and easting coordinates of the window corners are used to determine which project points
are contained in the window. All points in the project to which the drawing is attached that are within
the window are excluded from the point group.

With Elevations Matching
Excludes a point from the point group based on its elevation. Enter any combination of the following,
separated by commas:
■

An individual elevation

■

A greater than sign (>) followed by an elevation. Excludes all points with an elevation above the
specified value

■

A less than sign (<) followed by an elevation. Excludes all points with an elevation below the specified
value

■

An elevation range, which is specified by separating the beginning and ending numbers with a hyphen
(for example, 1-100). Excludes all points with an elevation that falls within the range

For example, <-100,1-100,110.01,>200 would exclude all points whose elevations meet one of the following
criteria: less than -100, equal to or between 1 and 100, equal to 110.01, or greater than 200.
With Names Matching
Excludes a point from the point group based on its name. Enter one or more point names separated by
commas.
With Raw Descriptions Matching
Excludes a point from the point group based on its raw description. Enter one or more raw descriptions
separated by commas, for example IP*,GB*,TREE,STA.
The asterisk (*) is a wild card that matches any string. For example, the code IP* will match all raw
descriptions that begin with IP, so a raw description IPS matches the description IP*.
With Full Descriptions Matching
Excludes a point from the point group based on its full description. Enter one or more full descriptions
separated by commas, for example IP*,GB*,TREE,STA.
The asterisk (*) is a wild card that matches any string. For example, the code IP* will match all full
descriptions that begin with IP, so a full description IPS matches the description IP*.
Information specified on this tab appears on the Query Builder tab.
Related procedures:
■

Creating Point Groups (page 561)

Query Builder Tab (Point Group Properties Dialog Box)
Use this tab to define point groups by using a query, which is a set of complex parameters or conditions.
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A query consists of one or more expressions. Each row on the Query Builder tab contains an expression. You
combine expressions using the set operators AND, OR, and NOT. You can also use parentheses to group
expressions. For more information, see Understanding Point Group Queries (page 565).
When you first display the Query Builder tab, the starting query reflects the current contents of the following
tabs: Raw Desc Matching, Include, Exclude, and Point Group.
This tab is read only until you select the Modify Query check box. To modify a cell in the query builder grid,
click once in the cell to activate the row, then click again to activate the cell. To create a new row, right-click
in the Query Builder and click Insert Row. To delete a row, click the row and press Delete.
NOTE After you select the Modify Query check box, the Raw Desc Matching, Point Groups, Include, and Exclude
tabs become inactive. If you want to use these tabs, you must clear the Modify Query check box. For more
information, see Creating Point Groups (page 561).
Use Case-Sensitive Matching
Specifies whether raw description matching and full description matching are case-sensitive, not only on
this tab, but also on the Raw Desc Matching, Include, and Exclude tabs.
Modify Query
Controls whether the query builder tab is active.
Select this check box to edit the current query, which is derived from the contents of the Point Groups,
Raw Desc Matching, Include, and Exclude tabs. These tabs become inactive, and their contents are lost,
if you click Apply on the active Query Builder tab.
Clear this check box to activate the Point Groups, Raw Desc Matching, and Exclude tabs. If you click any
of the activated tabs, the current query in the Query Builder is lost.
Set Operator
Specifies the set operator for an expression. Activate the cell and select AND, OR, or NOT. For more
information, see Understanding Point Group Queries (page 565).
(
Turns opening parenthesis on or off. Activate the cell and click in it. For more information about using
parentheses to combine expressions, see Understanding Point Group Queries (page 565).
Property
Specifies the property for the expression:
■

Name

■

Raw Description

■

Full Description

■

Point Number

■

Point Elevation

■

Point Group

Operator
Defines the relationship between Property and Value. The operators displayed in the list depend on the
property you specified for the expression. Valid values include:
■

= (equal)

■

!= (not equal)

■

> (greater than)

■

< (less than)
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■

>= (greater than or equal)

■

<= (less than or equal)

Value
Specifies the value for the property. Activate the cell and enter the value. Valid values depend on the
property, as follows:
■

Name: Enter a point name.

■

Raw Description: Enter a raw description. You can use wild cards.

■

Full Description: Enter a full description. You can use wild cards.

■

Point Number: Enter an individual point number or a point range. A range is two point numbers
separated by a hyphen, such as 10-21.

■

Point Elevation: Enter an individual elevation or a range. A range is two elevations separated by a
hyphen, such as 1001-1050.

■

Point Group: Enter a point group name.

)
Turns closing parenthesis on or off. Activate the cell and click. For more information about using
parentheses to combine expressions, see Understanding Point Group Queries (page 565).
Reset
Resets the current query to the starting query. Any changes you made since you entered the query builder
are lost.
Apply
Applies the current query to the point group and updates the Point List and Summary tabs.
Related procedures:
■

Creating Point Groups (page 561)

Overrides Tab (Point Group Properties Dialog Box)
Use this tab to override some properties for the points in a point group.
Override values specified in this dialog box are displayed in the drawing, the point group item view, and
on the Point List tab of the Point Group Properties dialog box. However, the point itself is not changed. The
point group display order can affect the override values displayed in labels for raw description and elevation.
It can also affect both the style and label style that is used to display a point in a drawing. For more
information, see Using Point Groups to Override Point Properties (page 555).
Raw Description
Overrides the raw description for points in the point group. Under Property, select the check box. Under
Override, either click

and enter the raw description override value, click

to attach an external data

reference, or click
then click in the row to specify a user-defined property from the list. For more
information, see Using External Data References (page 537) and Using Custom Properties with Points (page
445).
Point Elevation
Overrides the elevation for points in the point group.
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IMPORTANT In situations where you want to assign a User-defined Property as a Point Elevation override, the
user-defined property must have Elevation specified as the Type.
Point Style
Overrides the point style for points in the point group. Under Property, select the check box. Click in the
Override column to open the Point Style dialog box where you can specify a style.
NOTE Changing the override point style updates the point style on the Information tab.
Point Label Style
Overrides the point label style for points in the point group. Under Property, select the check box. Click
in the Override column to open the Point Label Style dialog box where you can specify a style.
NOTE Changing the override point label style updates the point label style on the Information tab.
Related procedures:
■

Creating Point Groups (page 561)

Point List Tab (Point Group Properties Dialog Box)
This tab displays a read only list of the points in the point group.
Change the order in which the headings are displayed by dragging a heading left or right. Adjust the width
of a column by dragging the separator between two column headings left or right.
Related procedures:
■

Creating Point Groups (page 561)

Summary Tab (Point Group Properties Dialog Box)
Use this tab to display information about the point groups properties.
Some information on this tab can be copied to a file for editing or printing using standard Windows
cut-and-paste techniques.
Property
Lists point group information by category. Expand or collapse the categories to view the information.
Value
Lists the value for each property.
Query Statement
Lists the point group query. Use the Query Builder tab to modify the query.
Related procedures:
■

Creating Point Groups (page 561)

Point Style Dialog Box
This dialog box defines a point style, which controls the way a point symbol is displayed in a drawing.
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Information Tab (Point Style Dialog Box)
Use this tab to change the point style name and description information, and to review details, such as when
the style was most recently modified.
For more information, see Information Tab (Style Dialog Box) (page 2017).
Related procedures:
■

Creating a Point Style (page 450)

Marker Tab (Point Style Dialog Box)
Use this tab to specify the appearance of the point symbol in the drawing.

Use AutoCAD Point For Marker
Use AutoCAD Point For Marker
Displays the point using the current AutoCAD point symbol, which is specified by the AutoCAD PDMODE
and PDSIZE system variables.

Use Custom Marker
Use Custom Marker
Displays the point using the specified symbol.
Custom Marker Style
Specifies the symbol to be displayed. Click one of the five symbols on the left to use as a base symbol.
Optionally, click the sixth symbol, the seventh symbol, or both, to superimpose over the base symbol.
The specified symbol combination is displayed in the Preview window.

Use AutoCAD Block Symbol For Marker
Use AutoCAD Block Symbol For Marker
Displays the point using a reference to the selected AutoCAD block. The block is scaled using the options
specified under Size.
Lists available block definitions in the drawing. Do one of the following:
■

Click a block name to specify the block to be used for the point symbol. The block displays in the
Preview window.

■

Right-click in the block list window. Click Browse to select a block located in another folder.

The specified block displays in the Preview window.

Marker Rotation Angle
Marker Rotation Angle
Specifies the rotation angle for the symbol. Applies to all three symbol types (AutoCAD Point, Custom
Marker, and AutoCAD Block). Enter a value or click

to specify an angle.

Orientation Reference
Specifies the Marker Rotation Angle:
■

World Coordinate System: Indicates that the marker rotation angle is relative to the world coordinate
system.

■

Object: Indicates that the marker rotation angle is relative to an object it is attached to.

■

View: Indicates that the marker rotation angle is relative to the current AutoCAD view direction.
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Size
Options
Specifies symbol scaling:
■

Use Drawing Scale: Determines the size of the marker by multiplying the specified value by the drawing
scale. Enter the scale factor.

■

Use Fixed Scale: Activates the Fixed Scale options.

■

Use Size in Absolute Units: The marker size is an absolute value based on the displayed units. Enter
the value.

■

Use Size Relative to Screen: The size of the marker is a percentage of the drawing screen size. Enter the
percentage.

Fixed Scale
Specifies independent fixed scale values when Options is set to Use Fixed Scale. Enter values for X, Y, or
Z.

Preview
Preview
Displays a preview of the specified symbol. Right-click in the Preview window to access commands that
you can use to change the Preview window display.
Related procedures:
■

Creating a Point Style (page 450)

3D Geometry Tab (Point Style Dialog Box)
Use this tab to specify the appearance of the point symbol in 3D views.

3D Geometry
Point Display Mode
Specifies how the point symbol will be displayed in 3D views:
■

Use Point Elevation: Displays the point using its actual elevation value.

■

Flatten Points To Elevation: Specifies the elevation that the point is projected (flattened) to. Enter a
value for Point Elevation.

■

Exaggerate Points By Scale Factor: Exaggerates the elevation of the point by a specified scale factor.
Enter a value for Scale Factor.

Point Elevation
Specifies the elevation to which a point is projected when Point Display Mode is set to Flatten Points To
Elevation.
Scale Factor
Specifies the scale factor when Point Display Mode is set to Exaggerate Points By Scale Factor.
Related procedures:
■

Creating a Point Style (page 450)
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Display Tab (Point Style Dialog Box)
Use this tab to change the display and visibility of point components.
View Direction
Specify the context for which you are setting the point display attributes:
■

Plan – the printed drawing

■

Model – the on-screen design environment

■

Profile – projection into a profile view (marker only)

■

Section – projection into a section view (marker only)

Point components include:
■

Marker: The symbol displayed at the point location.

■

Label: The point label, which is specified by the point label style.

For more information, see Display Tab (Style Dialog Box) (page 2017).
Related procedures:
■

Creating a Point Style (page 450)

Summary Tab (Point Style Dialog Box)
Use this tab to display information about a particular point style. You can copy and paste this information
to the clipboard.
For more information, see Summary Tab (Style Dialog Box) (page 2020).
Related procedures:
■

Creating a Point Style (page 450)

Create Points Dialog Box
Use this dialog box to create points using a variety of options, including importing point data from a file.
You can expand the Create Points dialog box to display and edit the point creations settings. For more
information, see Point Settings (page 439) and Edit Feature Settings - Point Dialog Box (page 2343)
NOTE If you specify Save Command Changes To Settings at the Drawing Settings, and enter a different value for
Save Command Changes To Settings at the feature level or the command level, an icon displays in the Child
Override column of the Drawing Settings to indicate a setting change at a lower level. For more information, see
Ambient Settings Tab (Drawing Settings Dialog Box) (page 2078).
Expand
Expands the Create Points dialog box to display point settings.
Collapse
Collapses the Create Points dialog box so that only the command lists display.
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Point Creation Lists
Specifies point creation commands. Select a point creation command from the following lists:
■

Miscellaneous: For more information, see Creating Points Using Miscellaneous Methods (page 458).

■

Intersection: For more information, see Creating Points at Intersections (page 470).

■

Alignment: For more information, see Creating Points Based on Horizontal Alignments (page 489).

■

Surface: For more information, see Creating Points Based on Surface Elevations (page 499).

■

Interpolation: For more information, see Creating Points by Interpolation (page 503).

■

Slope: For more information, see Creating Points Based on Slope (page 512).

■

Import Points Category: For more information, see Creating Points by Importing Point Data (page 516).

Related procedures:
■

Creating Points (page 456)

Point Groups Dialog Box
Use this dialog box to change the display order for point groups in a drawing and to update out-of-date
point groups.
Also, use this dialog box to select a point group when needed, for example to add a point group to a surface
definition or to specify a point group when creating a point table.
A point group is out-of-date when

is displayed next to a point group name.

Show Differences
Displays the Point Group Changes (page 2359) dialog box.
Update Point Groups
Updates all out-of-date point groups.
Name
Lists the point groups in the order they are drawn. Select a point group to change its position in the display
order or to add it to a surface definition. For more information about point group display order, see
Changing the Point Group Display Order (page 558).
Description
Lists point group descriptions.

Moves the selected point group up in the display order to the top of the display list.
Up Arrow
Moves the selected point group up in the display order.
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Down Arrow
Moves the selected point group down in the display order.

Moves the selected point group to the end of the display order.
Related procedures:
■

Changing the Point Group Display Order (page 558)

■

Updating All Out-of-Date Point Groups (page 557)

Point Group Changes Dialog Box
Use this dialog box to review and update out-of-date point groups.
Update Point Groups
Updates all out-of-date point groups by applying the changes specified in the Name, Add/Remove, and
List columns.
Name
Lists the names of the out-of-date point groups.
Add/Remove
Specifies which of the following actions must be taken to bring the point group up to date:
■

Add: Points in the List column must be added to the point group to bring it up to date.

■

Remove: Points in the List column must be removed from the point group to bring it up to date.

List
Lists the point numbers that must be added to or removed from the point group to bring it up to date.
Related procedures:
■

Updating All Out-of-Date Point Groups (page 557)

Point File Formats Dialog Box
Use this dialog box to manage point import/export formats.
Format List
Specifies the name of the format you want to work with. Click a point file format to select it.
New
Creates a new format.
Copy
Creates a copy of the selected format.
Modify
Edits the selected format. This option is active only when the selected format can be changed.
View
Displays the properties of the selected format. This option is active only when the selected format cannot
be changed.
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Delete
Deletes the selected format.
Related procedures:
■

Understanding Point File Formats (page 525)

Point File Formats - Select Format Type Dialog Box
Use this dialog box to specify the type of point file format to create.
User Point File
Creates a point file format that describes the contents of an ASCII (text) point data file.
User Point Database
Creates a point file format that describes the content of a Microsoft® Access (.mdb) point data file.
Related procedures:
■

Understanding Point File Formats (page 525)

Point File Format Dialog Box
Use this dialog box to view or edit the properties of a user point file format, which is used to import points
from or export points to an ASCII (text) file.

File Information
Format Name
Specifies the name of the point file format. This name appears in the Point File Formats list in the Settings
tree. Enter a name.
Default File Extension
Specifies the default file extension of the point data file when you import or export points using this
format.
Enter a file extension or select one of the following:
■

.auf: Autodesk Uploadable File, comma delimited. Required values in the file are Point Number,
Northing, Easting, Elevation, and Description (in that order).

■

.csv: Comma Separated Value file; ASCII (text) file comma-delimited.

■

.nez: Northing, Easting, and Elevation data

■

.pnt: Point file.

■

.prn: Formatted text, space delimited.

■

.txt: Delimited ASCII (text) file.

■

.xyz: Coordinates X, Y, and Z.

Comment Tag
Specifies how descriptive text is designated in the point data file. Enter the symbol that precedes a comment
in the point data file. For example, if you specify # for the comment tag, any line in the point data file
that begins with #, such as #Autodesk Point Data, is ignored during import.
The comment tag indicates where the comment begins. A comment always ends at the end of the line.
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Coordinate Zone Transform
For more information, see Point File Format Coordinate Zone Transformation Property (page 526).
Coordinate Zone Transform
Indicates that the format references a coordinate zone.
Select Zone
Opens the Select Coordinate Zone dialog box.

Format Options
For more information, see Point File Formatting Options (page 527).
Columnated
Specifies that the point data in the point data file is arranged in columns.
Delimited By
Specifies that the point data in the file is separated by the indicated character. Enter the character.
Read No More Than
Specifies the maximum number of points that can be read from a file (during import) or written to a file
(during export), beginning at the top of the file. The limit does not include comment lines or errors in
the text file. If you specify a limit of 100, then 100 points are imported or exported.
Sample Every
Samples point data at a specified interval. For example, if you specify a sample interval of 100, then every
100th point is imported or exported.

Format Column Names
Column Headings or <unused>
Opens the Point File Formats - Select Column Name (page 2362) dialog box. Click an <unused> column
heading to assign a column name to the column.
NOTE Drag a column heading horizontally to quickly change the column order.

Reference File Column Names
Column Headings
Displays a point data file so that you can reference its contents as you build the format. (See Load and
Parse.)

Options
Load
Opens the Select Source File dialog box where you can load and view a point data file for reference.
Parse
Displays the loaded file in the dialog box using the point file format you are creating.
Related procedures:
■

Creating Point File Formats (page 529)

User Point Database Format Dialog Box
Use this dialog box to view or edit the properties of a user point database format, which is used to import
points from or export points to a Microsoft® Access database (.mdb) file.
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File Information
Format Name
Specifies the name of the user point database format. This name appears in the Point File Formats list in
the Settings tree. Enter a name.
Table Name
Specifies which table within the Microsoft Access file contains point data. Used when a Microsoft Access
point database contains multiple tables.
In the Table Name list, click the table in the Microsoft Access file that you want to use. If you do not see
any table names listed, then click the Load button to load the .mdb file or enter the name of the table you
want to use.

Coordinate Zone Transform
For more information, see Point File Format Coordinate Zone Transformation Property (page 526).
Coordinate Zone Transform
Indicates that the format references a coordinate zone.
Select Zone
Opens the Select Coordinate Zone dialog box.

Format Column Names
Column Headings or <unused>
Opens the Point File Formats - Select Column Name (page 2362) dialog box. Click an <unused> column
heading to assign a column name to the column.
NOTE Drag a column heading horizontally to quickly change the column order.

Options
Load
Opens the Select Source File dialog box where you can load and view a Microsoft® Access file for reference.
Related procedures:
■

Creating a User Point Database Format (page 530)

Point File Formats - Select Column Name Dialog Box
Use this dialog box to specify a column to be included in a point file format.
After you chose a column name, the dialog box displays additional edit boxes that are consistent with the
type of data the column contains.
Column Name
Specifies the name of the column to be included in the point file format. For more information, see Point
File Format Column Name Property (page 527).
■

<unused>: Designates a column in the point data file that is empty or that contains data you do not
want imported or exported.

■

Easting

■

Northing

■

Point Elevation
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NOTE The elevation value in a point data file can be adjusted during import or export. For more information,
see Adjusting Elevation During Import and Transfer (page 528).
■

Point Number

■

Name

■

Raw Description

■

Full Description

NOTE You cannot import the full description; you can only export it.
■

Grid Northing

■

Grid Easting

■

Longitude

■

Degrees-Longitude

■

Minutes-Longitude

■

Seconds-Longitude

■

Hemisphere-Longitude

■

DECDEG Longitude

■

DASHED Longitude

NOTE A DASHED longitude value is expressed with dashes, such as 73-13-12.67.
■

Latitude

■

Degrees-Latitude

■

Minutes-Latitude

■

Seconds-Latitude

■

Hemisphere-Latitude

■

DECDEG Latitude

■

DASHED Latitude

NOTE A DASHED latitude value is expressed with dashes, such as 73-13-12.67.
■

Thickness: For more information, see Adjusting Elevation During Import and Transfer (page 528).

■

User Defined: Specifies a custom column format. Create as many custom columns as you need. Specify
a name for the column, a data type, and an invalid indicator value. You should use this option when
you need to copy columns from the source file to the destination file during a Transfer Points command.

■

Z+: Specifies a positive elevation adjustment. For more information, see Adjusting Elevation During
Import and Transfer (page 528).

■

Z-: Specifies a negative elevation adjustment. For more information, see Adjusting Elevation During
Import and Transfer (page 528).
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■

Convergence: Contains calculated convergence angles during point export. For more information, see
Calculating Convergence Angles During Export (page 528).

■

Scale Factor: Contains calculated scale factors for export. For more information, see Calculating Scale
Factors During Export (page 529).

■

Intensity: Specifies the color intensity of points in a point cloud.

■

RGB-Red: Specifies the value of red in the RGB color space for points in a point cloud.

■

RGB-Green: Specifies the value of green in the RGB color space for points in a point cloud.

■

RGB-Blue: Specifies the value of blue in the RGB color space for points in a point cloud.

■

Classification: Specifies the LiDAR LAS format Classification value, such as Bare Earth,
Low/Medium/High Vegetation, or Infrastructure. For details, see The American Society Photogrammetry
and Remote Sensing (ASPRS) LAS Specification.

■

<user-defined>: Displays the name of a user-defined property. If you are importing point data from
and ASCII file that contains user defined columns, you must create a user defined classification for
each column. For more information, see Importing Point Data from an ASCII File Containing User
Defined Columns (page 534).

Invalid Indicator
(Displayed only after you click a column name.) Specifies a value that causes this column to be ignored
when detected in the point data file. Enter a value, for example, 999999.
Precision
(Displayed only after you click a column name that requires a decimal value.) Enter the number of decimal
precision places for the column, up to 12.
Thickness Name
(Displayed only after you click the Thickness column name.) Enter a name for the thickness.
User Defined Column Name
(Displayed only after you click the User Defined column name.) Enter a heading name for the user-defined
column.
Data Type
(Displayed only after you click the User Defined column name.) Select the type of data the column contains:
■

Double: Contains a double precision floating point value. Use Double for numbers that contain decimal
points, including elevations, northings, eastings, grid northings, grid eastings, latitudes, and longitudes.

■

Long: Contains a long integer value. Use Long for point numbers.

■

String: Contains an alphanumeric value. Use String for point descriptions and point names.

Related procedures:
■

Creating Point File Formats (page 529)

Import Points Dialog Box
Use this dialog box to specify options before you import points from an ASCII (text) file or a Microsoft®
Access database (.mdb) file.
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Format
Specifies the format determining how the point data is arranged in the file from which the points will be
imported.
Point Format
Opens the Point File Formats (page 2360) dialog box. Select a point file format, edit a point file format, or
create a new point file format to use when importing the point data.
Source File
Specifies the name of the point data file that contains the points to be imported. Enter a file name,
including the full path name.
File Selector
Opens the Select Source File dialog box. Browse to the folder where the point data file to be imported is
located. Select the file name, and click Open.

Add Points to Point Group
Add Points to Point Group
Specifies whether the imported points are added to a point group:
■

Selected: Adds the imported points to the specified point group and to the _All Points point group.

■

Cleared: Adds the imported points only to the _All Points point group.

Add Points To Point Group
Specifies the point group to which imported points are added when is selected.

Opens the Point File Formats - Create Group (page 2365)dialog box. Specify a point group name.

Advanced Options
Do Elevation Adjustment If Possible
Specifies that elevation adjustments are performed during import. The point file format must contain Z+,
Z-, or Thickness columns. For more information, see Adjusting Elevation During Import and Transfer
(page 528).
Do Coordinate Transformation If Possible
Specifies that coordinate transformations should occur during import. The point file format must have a
coordinate zone assigned to it, and the current drawing must have coordinate zone and transformation
information defined. The points that are imported are transformed to match the zone of the current
drawing.
Do Coordinate Data Expansion If Possible
Specifies that coordinate data properties of the points, such as degrees, minutes, seconds, and hemisphere
for latitude and longitude, should be calculated if possible. These values are calculated from known
coordinate data information contained in the point data file, such as grid northing and grid easting.
Related procedures:
■

Importing Point Data (page 533)

Point File Formats - Create Group Dialog Box
Use this dialog box while importing points to either create a point group that includes all the imported
points or to add the imported points to an existing point group.
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Point Group
Specifies the name of the point group to which the points are added. If the point group does not exist, it
is created.
Related procedures:
■

Creating Point Groups (page 561)

Export Points Dialog Box
Use this dialog box to specify options before you export points to an ASCII (text) file or a Microsoft Access
database (.mdb) file.
Format
Specifies the format describing how the point data will be arranged in the exported file.
Point Format
Opens the Point File Formats (page 2360) dialog box. Select a point file format, edit a point file format, or
create a new point file format to use when importing the point data.
Destination File
Specifies the name of the file to which the exported points will be written. Enter a file name, including
the full path name.
File Selector
Opens the Select Destination File dialog box. Browse to the folder where the exported point data file will
be located. Enter a file name, and click Save.

Limit to Points in Point Group
Limit To Points In Point Group
Specifies whether or not a point group is used to specify the points to be exported:
■

Selected: Only the points in the specified point group are exported.

■

Cleared: All points are exported.

Point Group
Specifies the name of the point group that contains the points to be exported when Limit To Points In
Point Group is selected.

Advanced Options
Do Coordinate Transformation If Possible
Specifies that coordinate transformations should occur during export. The point file format must have a
coordinate zone assigned to it and the drawing you are exporting points from must have coordinate zone
and transformation information defined. The points that are exported are transformed to match the zone
assigned to the point file format.
Do Coordinate Data Expansion If Possible
Specifies that missing coordinate data properties of the points being exported, such as degrees, minutes,
seconds, and hemisphere for latitude and longitude, are calculated if possible. These values are calculated
from known coordinate data information, such as grid northing and grid easting.
Related procedures:
■

Exporting Point Data (page 534)
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Transfer Points Dialog Box
Use this dialog box to specify options before you transfer points from a source point data file (either text or
.mdb) to a destination point data file (either text or .mdb).

Source
Format
Specifies the format describing how the point data is arranged in the source file.
Source
Specifies the name of the point data file from which the point data is read. Enter a file name, including
the full path name.
File Selector
Opens the Select Source File dialog box. Browse to the folder where the source point data file is located.
Select the file name, and click Open.

Destination
Format
Specifies the format describing how the point data will be arranged in the destination file.
Destination
Specifies the name of the file to which the point data is written. Enter a file name, including the full path
name.
File Selector
Opens the Select Destination File dialog box. Browse to the folder where the point data file will be located.
Enter a file name, and click Save.

Advanced Options
Do Elevation Adjustment If Possible
Specifies that elevation adjustments are performed during import. The format must contain Z+, Z-, or
Thickness columns. For more information, see Adjusting Elevation During Import and Transfer (page 528).
Do Coordinate Transformation If Possible
Specifies that coordinate transformations should occur during transfer. Both source and destination point
file formats must have coordinate zones assigned to them. The point data in the source file is transformed
during transfer to match the zone specified in the destination file point file format.
Do Coordinate Data Expansion If Possible
Specifies that missing coordinate data properties of the points in the source file, such as degrees, minutes,
seconds, and hemisphere for latitude and longitude, should be calculated, if possible, and transferred to
the destination file. These values are calculated from known coordinate data information such as grid
northing and grid easting in the source file.

Additional Options
Manage
Opens the Point File Formats (page 2359) dialog box. Create, copy, or change a format.
Related procedures:
■

Transferring and Converting Point Data (page 536)
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Description Key Set Dialog Box
Use this dialog box to specify the name and description of a description key set.
Name
Specifies the name of the description key set. Enter a name.
Description
Specifies a description for the description key set. Enter a description.
Related procedures:
■

Creating a New Description Key Set (page 581)

Description Key Sets Search Order Dialog Box
Use this dialog box to specify the order in which description key sets are searched during description key
matching.
The description key sets are listed in the order in which they are searched. The description key set at the top
of the list is searched first.
Name
Lists the name of the description key set. Click the name to select the description key set.
Description
Lists the description of the description key set.
Up Arrow
Moves the selected description key set up in the search order.
Down Arrow
Moves the selected description key set down in the search order.
Related procedures:
■

Changing the Description Key Sets Search Order (page 582)

Description Key Editor
Use this dialog box to edit description key properties.
You can also edit description keys in the Prospector item view. However, because the DescKey Editor is a
separate window, it provides more viewing area and greater flexibility.

Code and Format
These properties are required in every description key.
Code
Specifies what points match this description key during description key matching. Click in the cell and
then enter a code. For more information, see Description Key Code (page 574).
Format
Specifies the format used to translate the raw description into the full description. Click in the cell and
enter a format. Enter $* if you want the full description to be the same as the raw description. For more
information, see Description Key Format (page 576).
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Styles and Layer
For more information about how point style, point label style, and point layer are used to display a point,
see Controlling the Appearance of Points in a Drawing (page 454).
Point Style
Specifies the point style to be referenced by a point that is created using the description key.
To specify a point style:
■

Select the Point Style check box.

■

Click in the cell to open the Point Style (page 2354) dialog box. Select a point style.

NOTE Scale and rotation values in the point style are overridden by description key scale and rotation overrides.
Point Label Style
Specifies the point label style to be referenced by a point that is created using the description key.
To specify a point label style:
■

Select the Point Label Style check box.

■

Click in the cell to open the Point Label Style (page 2021) dialog box. Select a point label style.

Layer
Specifies the layer for the point.
To specify a layer:
■

Select the Layer check box.

■

Click in the cell to open the Layer Selection dialog box. Select a layer.

Scale Override Properties
Use the Scale Override properties of a description key to specify how the point symbol is scaled when a point
is created using the description key.
Scale values specified in this part of the description key take precedence over any scale values specified in
the point style referenced by the description key. If scale parameters have been set, hold your cursor over
in the Code column, to display a tooltip with the scale parameters and values.
Select Apply To X-Y or Apply To Z before you specify a scale using Scale Parameter, Fixed Scale Factor, or
Use Drawing Scale properties.
Scale Parameter
Specifies the position (1-9) in the raw description of the parameter that contains the value used to scale
the point symbol when the description key is matched.
To specify a scale parameter:
■

Select the Scale Parameter check box.

■

Click in the cell and select a parameter.

For more information, see Specifying Point Symbol Scaling and Rotation Using Description Key Parameters
(page 578).
Fixed Scale Factor
Specifies a fixed scale, used to scale the point symbol when the description key is matched.
To specify a fixed scale factor:
■

Select the Fixed Scale Factor check box.

■

Click in the cell and enter a scale factor.
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Use Drawing Scale
Specifies that the drawing scale is used to scale the point symbol when the description key is matched.
Click in the cell then select Yes to use the drawing scale.
Apply To X-Y
Specifies that description key scaling is applied to the X-Y axis of a point when the description key is
matched. Click in the cell then select Yes to specify X-Y scaling.
Apply To Z
Specifies that description key scaling is applied to the Z axis of a point when the description key is matched.
Click in the cell then select Yes to specify Z scaling.

Rotation Override Properties
Use the Rotation properties of a description key to specify how the point symbol is rotated when a point is
created using the description key.
Rotation values specified in this part of the description key take precedence over any rotation values specified
in the point style that is referenced by the description key.
If rotation parameters have been set, hold your cursor over in the Code column to display a tooltip with
the rotation parameters and values.
Rotate Parameter
Specifies the position (1-9) in the raw description of the parameter containing the value used to rotate
the point symbol when the description key is matched.
To specify a rotation parameter:
■

Select the Rotation Parameter check box.

■

Click in the cell then select a parameter.

For more information, see Specifying Point Symbol Scaling and Rotation Using Description Key Parameters
(page 578).
Fixed Rotation
Specifies a fixed rotation used to rotate the point symbol when the description key is matched.
To specify a fixed rotation factor:
■

Select the Fixed Rotation check box.

■

Click in the cell and enter a rotation value.

Rotation Direction
Specifies whether the values specified for the Rotate Parameter property or the Fixed Rotation property
are clockwise angles or counterclockwise angles.
Related procedures:
■

Editing Description Keys (page 590)

Point Editor
Use the window to edit drawing point properties.
Each row in the Point Editor contains the properties for a single point. To edit a point property value, click
in the cell containing the property to activate it. If a cell is shaded, you cannot change the value.
NOTE You can also edit drawing points in the Prospector item view. However, because the Point Editor is a separate
window, it provides more viewing area and greater flexibility.
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These drawing point properties are displayed in the Point Editor and in the drawing Points collection list
view:
Point Number
Specifies the point number. Point numbers must be unique. Enter an integer.
Easting
Specifies a local easting value for the point. If the transformation settings are enabled for the drawing
when you edit this value, the corresponding values for grid easting and latitude are automatically updated.
Enter a value with up to 12 digits of precision.
Northing
Specifies a local northing value for the point. If the transformation settings are enabled for the drawing
when you edit this value, the corresponding values for grid northing and longitude are automatically
updated. Enter a northing value with up to 12 digits of precision.
Point Elevation
Specifies an elevation for the point. Enter an elevation value.
Name
Specifies an optional point name, which must be unique within a drawing or a project.
NOTE Point names are not case sensitive.
Raw Description
Specifies a raw description for the point, which is often the description entered by the surveyor in the
field. Enter alphanumeric characters. Any character, including a blank, can be used.
Full Description
Specifies an expanded description that is created from the raw description using the description format.
If a point does not have a description format, the full description is the same as the raw description.
You cannot edit this field directly. The value can be set initially using description key matching. For more
information, see Description Keys (page 571). You can update the full description of a single point either
by changing the points description format or by changing the points raw description. For more information,
see Description Key Format (page 576).
Description Format
Specifies a format that translates the points raw description into a full description. If a point does not
have a description format, the full description is the same as the raw description. For more information,
see Description Key Format (page 576).
Grid Easting Grid Northing
Displays the calculated grid easting and grid northing values for the point, relative to the coordinate zone
and the transformation settings specified for the drawing.
Longitude Latitude
Displays the latitude and longitude for a point, relative to the coordinate zone and the transformation
settings specified for the drawing.
Scale Factor
Displays the scale factor value of a point, relative to the coordinate zone and the transformation settings
specified for the drawing.
Convergence
Displays the convergence value of a point, relative to the coordinate zone and the transformation settings
specified for the drawing.
Point Style
Specifies the point style for the point. Click in the cell to specify a new point style or remove a point style.
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If this field is empty, the point displays using a point style specified by a point group. Also, the point style
specified in this field might not be used to display the point in the drawing. For more information, see
Controlling the Appearance of Points in a Drawing (page 454).
Point Label Style
Specifies the point label style for the point. Click in a cell to specify a new point label style or remove the
point label style.
If this field is empty, the point uses a point label style specified by a point group. Also, the point label
style specified in this field might not be used to display the point in the drawing. For more information,
see Controlling the Appearance of Points in a Drawing (page 454).
Point Layer
Specifies the layer for the point. Click in the cell to display the Layer Selection dialog box.
If this field is empty, the point displays using a layer specified by a point group. For more information,
see Controlling the Appearance of Points in a Drawing (page 454).
Project Version
For project points, specifies the version number of the local copy of the point in the drawing.
X-Y Scale
Specifies the X-Y scale factor for the point symbol. This value can be set initially using description key
matching. For more information, see Description Keys (page 571).
Z Scale
Specifies the Z scale factor for the point symbol. This value can be set initially using description key
matching. For more information, see Description Keys (page 571).
Rotation
Specifies the rotation value for the point symbol. This value can be set initially using description key
matching. For more information, see Description Keys (page 571). Enter a value or click
points in the drawing to specify the rotation angle.
These point properties are displayed in a project Points collection list view for a project point:
Point Number, Easting, Northing, Point Elevation, Name, Raw Description
See the preceding text for descriptions of these properties.
Version
Displays the most recent project version for the point.
Modified By
Displays the login name of the person who last modified the point.
Modified Date
Displays the date when the point was last modified.
Current State
Displays the current state of the point with respect to the project.
Current State By
Displays the project member who set the points current state.
Current State Date
Displays the date the state of the point was last changed.
Checked-Out Drawing
If the point is checked out, displays the drawing it is checked out to.
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and pick two

Checked-Out Host
If the point is checked out, displays the computer it is checked out to.
Related procedures:
■

Editing Points Using the Point Editor (page 517)

Geodetic Calculator Dialog Box
Use this dialog box to calculate geodetic information relative to the zone and the transformation values
specified in the drawing settings.
To use the calculator, enter values for known coordinate properties, and the remaining coordinate values
are calculated.
NOTE If transformation settings for a drawing are not enabled, the Select Point, Local Northing, Local Easting,
and Local Elevation options are not active.
Specify Point
Specifies local northing and easting values using a drawing point. Click a point in the drawing.
Create Point
Creates a point with the specifications you enter in the value column. After you enter or edit values, you
can click this icon to create a new point. At the command line you are prompted to enter a point description
and elevation.
Zone Description
Displays read-only information about the zone specified in the drawing.
Point Number
Specifies a starting point number from which local northing and easting values are read. Grid Northing,
Grid Easting, Latitude, and Longitude are calculated using the drawing zone. Enter a point number.
Latitude
Specifies latitude. Enter a latitude value using the format specified for the Lat Long drawing ambient
setting.
Changing this property updates the fields for Grid Northing, Grid Easting, Local Northing, Local Easting,
Scale Factor, and Convergence.
Longitude
Specifies longitude. Enter a longitude value using the format specified for the Lat Long drawing ambient
setting.
Changing this property updates the fields for Grid Northing, Grid Easting, Local Northing, Local Easting,
Scale Factor, and Convergence.
Grid Northing
Specifies grid northing. Enter a grid northing value.
Changing this property updates the fields for Latitude, Longitude, Local Northing, Local Easting, Scale
Factor, and Convergence.
Grid Easting
Specifies grid easting. Enter a grid easting value.
Changing this property updates the fields for Latitude, Longitude, Local Northing, Local Easting, Scale
Factor, and Convergence.
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Local Northing
Specifies local northing. Enter a local northing value.
Changing this property updates the fields for Latitude, Longitude, Grid Northing, Grid Easting, Scale
Factor, and Convergence fields to be updated.
Local Easting
Specifies local easting. Enter a local easting value.
Changing this property updates the fields for Latitude, Longitude, Grid Northing, Grid Easting, Scale
Factor, and Convergence.
Local Elevation
Specifies the local elevation for the specified point number.
Scale Factor
Displays the scale factor for the specified coordinate values. This read-only value is updated when
coordinates are recalculated.
Convergence
Displays the convergence for the specified coordinate values using the format specified for the Lat Long
drawing ambient setting. This read-only value is updated when coordinates are recalculated.
Sea Level Corrections Applied
Specifies whether sea level corrections are applied in Drawing Settings.
Grid Scale Factor Applied
Specifies whether the grid scale factor is applied in Drawing Settings.
Related procedures:
■

Geodetic Calculator (page 545)

Duplicate Point Number Dialog Box
Use this dialog box to handle point number conflicts arising from trying to create a point with the same
point number as an existing point.
In the following descriptions, source point is the point that the command is attempting to create, and
destination point is the existing point.

Duplicate Point Number Resolution
IMPORTANT For duplicate Survey point numbers, Overwrite and Ignore are the only Resolution options. Selecting
the Ignore option leaves the COGO point values intact. Options for Add An Offset From and Sequence From are
not available.
Resolution
Specifies how the point number conflict is resolved:
■

Add An Offset: Adds the offset specified for the Add An Offset From option to the source point number.
For example, if you enter an offset of 200, source points with numbers 1, 2, and 3 are re-numbered
201, 202, and 203.

■

Merge: Overwrites point data that exists in the destination point with data that exists in the source
point and preserves data in the destination point that is not supplied by the source point.

■

Overwrite: Overwrites the destination point.

■

Sequence From: Begins renumbering the source points using the point number specified in the Sequence
From option.
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■

Use Next Point Number: Assigns the next unused point number to the point.

Add An Offset From
Specifies the offset to be added to the source point number when the Resolution is set to Add An Offset.
Enter an integer.
Sequence From
Specifies the starting sequence number for renumbering the source points when the Resolution is set to
Sequence From. Enter an integer.
Apply To All Duplicate Point Numbers
Specifies that the Resolution setting is applied to any additional duplicate point numbers encountered
by the command. If a duplicate point number occurs that cannot be resolved based on the Resolution
setting, this dialog box displays again.
Related procedures:
■

Editing the Point Identity Settings (page 442)

Duplicate Point Name Dialog Box
Use this dialog box to handle point name conflicts arising from trying to create a point with the same point
name as an existing point.
In the following descriptions, source point is the point that the command is attempting to create, and
destination point is the existing point.

Duplicate Point Name Resolution
Resolution
Specifies how the point name conflict is resolved:
■

Counter: adds a numerical suffix to the current point name. A new point is created. The second instance
of the duplicate point name would be <point name> (1).

■

Specify: Displays the Point Name edit box to specify a name for the imported point.

■

Use Name Template: Creates a new point and assigns the point name based on the point name template.

Point Name
Specify a point name if you select Specify as the Resolution.
Apply To All Duplicate Point Numbers
Select to apply the resolution to all duplicate point names. If you select Specify as the Resolution type,
this check box is not available.
Related procedures:
■

Editing the Point Identity Settings (page 442)

Point Table Creation Dialog Box
Use this dialog box to create a point table in a drawing.
Most of the controls in this dialog box are generic table creation controls. For a description of these controls,
see Table Creation Dialog Box (page 2739).
Use the following controls to specify the points to be included in the point table:
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Point Group Selector
Displays the Point Groups (page 2358) dialog box. Specifies a point group. The points in the point groups
point list are added to the point table.
Point Selector
Selects the points to be added to the point table.
Related procedures:
■

Point Tables (page 452)

Create External Data Reference Dialog Box
Use this dialog box to create an external data reference (XDRef) or change the properties of an existing
XDRef.
Name
Specifies the file name for the XDRef.
Description
Specifies an optional description.
Database
Specifies the name and the path for the external database file (.mdb file).
Password Protected Database
Specifies that a password must be entered if this is selected.
Table
Specifies the column data for the XDRef.
Index Column
Specifies the index column containing the integers that correspond to the point numbers within the point
group that you are overriding.
Value Column
Specifies the column that contains the values that override the point group values when you specify this
XDRef as the override.
Related procedures:
■

Using External Data References (page 537)

Create Blocks from COGO Points Dialog Box
Use this dialog box to specify a selection of COGO points to use in creating an AutoCAD BLOCK for each
Civil point.

Select COGO Points
Spatial Filter
Specifies a filter.
■

None: Uses only those points contained in the point group that is specified under Point Groups.

■

Current Display: Uses the current display to define the spatial selection of points in the drawing.
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■

Define Window: Uses a crossing window in the drawing to define the spatial selection of points.

Point Groups
Click
to open the Point Groups dialog box, which lists all point groups in the drawing. Specify the
point group(s) you want to include in the block creation.
NOTE You can select the points to include in the block using both the Spatial Filter and Point Group options.
For example, under Spatial Filter you could select the Current Display and under Point Groups you could also
include a specified point group(s).

Block Output
Block Creation
■

Use Existing Block: to use this option the block must contain at least three attribute definitions exactly
named ELEV, POINT, and DESC. If there are no blocks in the drawing with these exact attributes, this
option is not available.

■

Make New Block: specifies a new block and block name. If a block has two or more instances of the
same attribute, each instance is filled with the same value.

Block Layer
Specifies the layer the block is placed on.
Related procedures:
■

Creating Blocks from COGO Points (page 543)

Convert Land Desktop Points Dialog Box
Use this dialog box to enter the point settings for the Land Desktop points you are converting.
For a description of the point settings, see Edit Feature Settings - Point Dialog Box (page 2343).
Related procedures:
■

Converting Land Desktop Points (page 544)
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Point Clouds Dialog Boxes

Edit Feature Settings-Point Cloud Dialog Box
View and change point cloud object settings.
This topic lists settings in all Edit Settings dialog boxes (drawing-level, feature-level, and command-level)
that relate to point cloud objects.
■

Drawing-level ambient settings are identified by the

■

Point cloud feature settings are identified by the

■

Point cloud command settings are identified by the

drawing icon.
Point Cloud object icon.
command settings icon.

For general information about drawing, feature, and command settings and their interaction, see Working
with the Standard Settings Dialog Box Controls in the AutoCAD Civil 3D User’s Guide.
For information about drawing-level ambient settings, see Ambient Settings Tab (Drawing Settings Dialog Box)
in the AutoCAD Civil 3D User’s Guide.

Default Styles
Point Cloud Default Style
Specifies the default point cloud style. Click in the Value column, and click
Point Cloud Style dialog box.

to select a style in the

For information about style selection, see Select Style Dialog Box (page 2021).

Default Name Format
Point Cloud Name Template
Specifies the default name format for point cloud objects. Click in the Value column, and click
make changes in the Name Template dialog box.

to

Create Point Cloud Wizard
Create a Civil 3D point cloud object.
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Information Page (Create Point Cloud Wizard)
Specifies the name, description, and style of the new point cloud and the layer on which the point cloud is
created.
Related procedures:
■

Point Cloud Style Dialog Box (page 2381)

■

Creating Point Cloud Objects (page 596)

Source Data Page (Create Point Cloud Wizard)
Specifies the file names and formats of the point cloud source data.

Source Data
Create a new point cloud database
Select if you’d like to create a point cloud database.
Select a Point Cloud File Format
Specifies a file format of the point cloud source data file.
Files to Be Imported into the New Point Cloud Database
Specifies the point cloud data files to be imported into a point cloud database.

Click to add one or several files to the import list.

Click to remove a file from the import list.
Use an Existing Point Cloud Database
Select to create a point cloud using an existing point cloud database.

New/Existing Point Cloud Database

Click to select the existing point cloud database file (.isd).
NOTE By default, the point cloud database file is saved in the same folder where the destination drawing is
saved.
Point Cloud Database Coordinate System
Specifies the coordinate system assigned to the point cloud data set. The field displays <None> if no
geospatial data is available.
Current Drawing’s Coordinate System
Specifies the coordinate system assigned to the current drawing. The field displays <None> the drawing
has no coordinate system reference.
Related procedures:
■

Creating Point Cloud Objects (page 596)
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Summary Page (Create Point Cloud Wizard)
Review the settings that you applied to a new point cloud object.
/
Click to expand or collapse the Property tree.
Related procedures:
■

Creating Point Cloud Objects (page 596)

Point Cloud Style Dialog Box
View and modify point cloud object style settings.

Information Tab (Point Cloud Style Dialog Box)
Add information about the new point cloud style, such as style name, description, and style creation
information.
Related procedures:
■

Displaying and Stylizing Point Clouds (page 598)

Points Tab (Point Cloud Style Dialog Box)
Specify the size, number, and color of the point cloud points.

Point Size
Size in Pixels
Specifies point cloud point size in pixels.

Color
Assign Color By
Specifies the color scheme for the point cloud points:
■

True Color (RGB) - displays the points using the RGB color model values if this data exist in the source
file.
NOTE If no RGB values are assigned, the Single Color property is used.

■

Classification - displays the points using the properties specified on the Classification (page 2383)page.

■

Grayscale Intensity - displays the points using the grayscale color model intensity values if this data
exist in the source file. When you use this option, you can apply the Intensity Range Minimum and
Maximum values.

■

Scaled Color Intensity - displays the points using the scaled color scheme intensity values if this data
exist in the source file. When you select this option, you can apply the Intensity Range
Minimum/Maximum values.

■

Elevation Ranges - displays the points within the specified Elevation Ranges color scheme properties.

■

Single Color - displays all the point cloud points in a single color that is specified in the Single Color
property. This color option is used by default if the point color data is not specified in the point cloud
database.
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Scaled Color Intensity Scheme
Specifies the scaled color scheme options.
Intensity Range Minimum/Intensity Range Maximum
Specify the highest and the lowest values of the color saturation range (from the darkest to the brightest
color).
The values are expressed as percentage and are entered in the range from 0.0 and 1.0, where 0.0 is 0%
intensity and 1.0 is 100% intensity. For example, if you set the Intensity Range Maximum value to 0.9
points with intensity in the top 10% are not displayed.
TIP For a greater difference in shades, specify a narrower range.
Single Color
Specifies the color to used when the Assign Color By property value is set to Single Color. This color option
is used by default if the point color data is not specified in the point cloud database.

Elevation Ranges
Create Ranges By
Specifies the method to create the number of elevation ranges:
■

Number of Ranges - enables the Number of Ranges property. This option divides the point cloud
display into the specified number of ranges from the minimum to the maximum point elevation value.

■

Range Interval - enables the Range Interval property.

Range Color Scheme
Specifies the default color scheme for elevation ranges assigned in the point cloud object properties.
Number of Ranges
Specifies the default number of elevation ranges that are created for a new point cloud that references
this style.
Range Interval
Specifies the elevation range interval. The value must be greater than zero.

3D Geometry
Scale Factor
Specifies the value by which all point cloud point elevations are scaled. It must be greater than 0.
Point Elevation
Specifies the z-value applied to all point cloud points if the Flatten Points To Elevation value is selected
as Point Display Mode.
Point Display Mode
Specifies the 3D view elevation properties of point cloud points:
■

Use Point Elevation - displays point cloud point elevations at their current values. This is the default
setting.

■

Flatten Points to Elevation - flattens all point cloud point elevations to a specified value.

■

Exaggerate Points by Scale Factor - scales all point cloud point elevations up to a specified value.

Related procedures:
■

Displaying and Stylizing Point Clouds (page 598)
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Classification Tab (Point Cloud Style Dialog Box)
Specify LiDAR point classification properties.
LiDAR Classification
Specifies the 32 standard LiDAR point classes (page 593). Check a class in the list to display only the
matching point cloud points.
Color
Specifies the color to assign to the selected LiDAR point class. ByLayer is the default color.
Layer
Specifies the layer for each LiDAR point class. Click

to assign a different layer to the selected class.

Related procedures:
■

Displaying and Stylizing Point Clouds (page 598)

Display Tab (Point Cloud Style Dialog Box)
Specify point cloud display properties.
View Direction
Select Plan to display in 2D view and Model to display in 3D view.
Component Display
■

Bounding Box: Represents the bounding outline of the created point cloud.

■

Points: Represents the point cloud points.

Related procedures:
■

Displaying and Stylizing Point Clouds (page 598)

Summary Tab (Point Cloud Style Dialog Box)
Review and modify the point cloud style settings.
/
Click to expand or collapse the Property tree.
Related procedures:
■

Displaying and Stylizing Point Clouds (page 598)

Point Cloud Properties Dialog Box
View and modify point cloud object properties.

Information Tab (Point Cloud Properties Dialog Box)
View and modify the point cloud object name, description and point cloud style.
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Show Tooltips
Select to display tooltips with point data information when you hover over the point cloud areas that
contain such information.
Related procedures:
■

Modifying Point Cloud Properties (page 601)

Definition Tab (Point Cloud Properties Dialog Box)
View the point cloud source files that were imported into the point cloud database.
Operation Type
Displays a list of operations, such as Add Point File, performed on the point cloud.
Parameters
Specifies the parameters of the performed operation. The parameters include file name and its location,
file type, and the coordinate system name. Click
if its location has changed.

to specify a new path to the point cloud source file

Point Cloud Database
Specifies the file name and location of the point cloud object point cloud database file. Click
the path if the database file location has changed.

to update

Point Cloud Database Coordinate System
Displays the coordinate system assigned to the point cloud object point cloud database. Click
the current coordinate system zone.

to modify

Drawing Coordinate System
Displays the coordinate system assigned to the current drawing.
Related procedures:
■

Modifying Point Cloud Properties (page 601)

Elevation Ranges Tab (Point Cloud Properties Dialog Box)
Configure the number of point-cloud point elevation ranges and view the details of elevation ranges.
Ranges
Specifies a method to create ranges by, the number of ranges, range interval, and minimum and maximum
elevations for points within a range.
Update Range Details
Click to update the content in the Range Details list.
Reset from Style
Click to modify the point cloud display based on the point cloud style settings. Any changes are saved in
the point cloud object properties.
Range Details
Specifies the information about the selected elevation ranges.
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Related procedures:
■

Modifying Point Cloud Properties (page 601)

Statistics Tab (Point Cloud Properties Dialog Box)
View the summary of the point cloud object properties.
All the property values are read only and come either from the source point cloud database or the current
point cloud style settings (Maximum Number of Points Displayed).
Related procedures:
■

Modifying Point Cloud Properties (page 601)

Add Points Dialog Box
Add points to a point cloud database using the existing point cloud object.
Select a Point Cloud File Format
The file formats available in the list are the formats contained in the current Civil 3D drawing settings.
Files to be Imported
The table contains a list of files whose point data is to be imported into the point cloud.

Click to add the point cloud data source files to the import list. You can only select the files of the specified
point cloud file format.

Click to remove the point cloud data source file from the import list.
Point Cloud Database Coordinate System
If the point cloud data doesn’t have an assigned coordinate system, the field displays <None>.
Related procedures:
■

Adding Points to a Point Cloud Database (page 599)

Add Points to Surface Wizard
Create a TIN surface from the specified point cloud points or add points to an existing TIN surface.

Surface Options Page (Add Points To Surface Wizard)
Specify a new surface or an existing one as destination surface.

Surface Options
Add Points to a New Surface
Select to create a TIN surface from the selected point cloud points.
Add Points to an Existing Surface
Select to add point cloud points to an existing surface.
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Select an Existing Surface
Select to use an existing surface as destination.
Related procedures:
■

Adding Point Cloud Points to Surfaces (page 600)

Region Options Page (Add Points to Surface Wizard)
Specify the point cloud region for the extraction of visible points.

Specify a Region Option
Point Cloud extents
Select to extract all visible points within the point cloud extents limited by the point cloud bounding
box.
Window
Select to extract points from a point cloud region inside a rectangular selection window.
Window Polygon
Select to extract points from a point cloud region inside a polygonal selection window.
Object
Select to extract point cloud points inside the following Civil objects in the current drawing:
■

2D or 3D polylines

■

Circles

■

Survey figures

■

Feature lines

■

Parcels

Mid-Ordinate Distance
Specifies mid-ordinate distance to tessellate arc segments into chords for objects that contain arc segments.

Click to specify mid-ordinate distance directly on the object in the drawing.

Define the Region
Define Region in Drawing
Click to define the point cloud region for extraction by specifying the selection area in the current drawing.
Related procedures:
■

Adding Point Cloud Points to Surfaces (page 600)

Summary Page (Add Points to Surface Wizard)
Review the target surface information, point cloud source region, and the number of points to be added.
/
Click to expand or collapse the Property tree.
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Related procedures:
■

Adding Point Cloud Points to Surfaces (page 600)

Summary Page (Add Points to Surface Wizard) | 2387

2388

Profiles Dialog Boxes

70

The following topics provide information about the AutoCAD Civil 3D Profiles dialog boxes.

Band Set Dialog Box
Use this dialog box to create a set of data band styles for profile views.
Use a band set to apply the same set of data bands to many profile views.
See also:
■

Profile View Band Styles (page 1133)

■

Editing Profile Views (page 1213)

Information Tab (Band Set Dialog Box)
Use this tab to change the name and description for a band set, and to review details such as latest
modification date.
Name
Specifies the name of the band set.
Description
Specifies a description of the band set.
Created By
Displays the Windows login name of the person who created the band set.
Date Created
Displays the date and time the band set was created.
Last Modified By
Displays the Windows login name of the person who last modified the band set.
Date Modified
Displays the date and time the band set was last modified.
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Bands Tab (Band Set Dialog Box)
Use this tab to specify which data bands are included in the set, along with their styles and positions relative
to the profile view grid.
Band Type
Specifies which type of data band to add to the set: Profile Data, Vertical Geometry, Horizontal Geometry,
Superelevation, Sectional Data, or Pipe Data.
Select Band Style
Specifies a style for the band. To edit a style or create a new one, click
and select from the list of
operations. For more information, see Select Style dialog box (page 2021). To examine the details of an
existing style, select the style by name in the list and click
dialog box (page 2020).

. For more information, see Style Detail

Add >>
Adds the specified data band type to the style set. Before clicking this button, ensure that the settings are
correct for data band type, style, and location.

List of Bands
Location
Specifies either the top or bottom of the profile view. The table below this field shows the current location
of the bands in the current band style set.
Band Type
Specifies the data band type.
Style
Specifies the style for the band type.
Description
Specifies optional description of the band type
Gap
Specifies the distance between the current data band and the adjacent profile view grid or data band. For
bands below the profile view grid, the gap is measured from the top of the current band to the bottom of
the band or grid above it. For bands above the profile view grid, the gap is measured from the bottom of
the current band to the top of the band or grid below it.
Geometry Points
For Profile Data bands, specifies the alignment and profile geometry points to label in the data band. Click
to open the Geometry Points to Label in Band dialog box (page 2412).
Label Start Station
Specifies whether the start end of the band is labeled.
Label End Station
Specifies whether the end of the band is labeled.
Label Origin
Specifies whether the profile view origin is labeled with its station and elevation values.
Weeding
Used only for labels at vertical geometry points on profile data bands. Vertical geometry points or grade
breaks that are closer than the weeding factor are removed, making it easier to read the remaining labels.
Enter a positive number to specify a label exclusion distance.
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Stagger Labels
Specifies the location of the label staggering line: No staggering, Stagger both sides, Stagger to right, or
Stagger to left.
Stagger Line Height
Specifies the height of the label stagger line.
Band Position Controls
Changes the position of data bands in the set and deletes unwanted bands.
Moves selected data bands up.
Moves selected data bands down.
Deletes selected bands.
Match major/minor increments to vertical grid intervals
Specifies if the profile data band major/minor interval distances for profile views matches the profile view
style’s major/minor grid spacing intervals. Select the checkbox to match major/minor increments to
vertical grid intervals. If this checkbox is selected, the major/minor interval fields are unavailable.

Best Fit Profile Report Vista
Use this vista to analyze the results of the regression that was used to create a profile by best fit through a
series of objects.

Regression Points Toolbar
Copy to Clipboard
Copies regression data to the clipboard with the appropriate formatting. This tool is useful for importing
the regression data into a spreadsheet.

Regression Points Table
Pt. No
Sequential number generated in the order in which the regression points were generated.
Point Station
Station value of the point that is closest to the regression point on the entity.
Point Elevation
Elevation value of the point that is closest to the regression point on the entity.
Offset to Entity
Specifies the distance of the regression point from the best fit entity.
Station on Entity
Specifies the station ordinate from the best fit entity.
Elevation on Entity
Specifies the elevation value from the best fit entity.

Regression Graph
This graph displays the regression points’ relationship to the best fit entity. The red line represents the
regression points and the green line represents the best fit entity. Selecting a row in the Regression Points
table displays an X and dashed line in the graph to indicate the location of the selected point.
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Best Fit Profile Weeding Options Dialog Box
Use this dialog box to add or remove vertices along a linear feature, such as a feature line or AutoCAD entity,
when creating a profile by best fit.
Weed
Reduces the number of vertices generated along the best fit entity. The weeding factor ignores vertices
that deflect less than the Angle Tolerance. A larger deflection angle weeds a greater number of points. The
Angle Tolerance is measured in angular units. The Angle Tolerance must be less than the supplementing
Distance.
Angle Tolerance
Specifies the weeding angle factor.

Supplement
Adds vertices along the best fit entity.
Distance
Specifies the maximum distance between vertices. If the distance between vertices on an entity is greater
than the supplementing factor, then points are added along the entity at equal intervals that are less than
or equal to the supplementing distance. The smaller the distance, the greater the number of supplemented
points.

Copy Profile Data Dialog Box
Use this dialog box to copy all or part of an existing profile.
Copying a profile can be useful when you want to design a profile that runs parallel to another profile in
the vertical plane. For example, you can create a ditch profile that follows the shape of a centerline, but is
at a lower elevation.

Source Profile Information
Name
Displays the name of the copied profile
Style
Displays a description for the copied profile.

PVI Range
Select one of the following options:
All
Copies the entire profile.
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Station Range
Copies a series of PVIs between two station values. Default values for the station range are the beginning
and end of the profile. If a station equation is in effect, use the station equation values to specify a range

Destination Profile Options
These options determine how the copy is used: either to create a profile or to overwrite an existing profile.
Overwrite Existing Profile
Replaces an existing profile with the specified source profile. If you select this option, use the drop-down
list to specify the profile to be overwritten. To copy all styles, descriptions, and other attributes from the
source profile to the specified destination profile, select the Overwrite All Properties check box. Otherwise,
only the linear data is overwritten.
Create New Profile
Copies the current profile, subject to any limitations specified in the PVI Range section. The name of the
new profile is created according to the current naming template, like the name of any new profile. The
new profile is superimposed on the source profile in the profile view. To work on one of these profiles
without affecting the other, select it by name on the Prospector tab or in a dialog box. Control the visibility
of individual profiles in the Profile View Properties dialog box (page 2429)
Related procedures:
■

Copying a Profile (page 1152)

Create Best Fit Profile Dialog Box
Use this dialog box to specify the settings to use when creating a profile by best fit through a series of objects.

Input Data
Input Type
Specifies the type of source objects (AutoCAD Blocks, AutoCAD 3D Polylines, AutoCAD Points, COGO
Points, or Surface Profile, Feature Lines) from which to create the best fit profile.
Weeding Options
Opens the Best Fit Profile Weeding Options Dialog Box (page 2392), which enables you to specify options
for adding or removing vertices when using either feature lines or AutoCAD 3D polylines as the input
data.
Path 1
Specifies that the profile is created through a single path of regression points.
Use this option to create a profile from centerline sample data.
Path 2
Specifies that the profile is created between two paths of regression points.
Use this option to create a centerline profile between sample data of the either the edges of pavement of
a road, or the left and right rails.

Best Fit Options
These options affect the manner in which the best fit algorithm is applied to the input data.
Maximum Radius For Curve Detection
Specifies the largest acceptable radius of curves that are created from the input data.
NOTE This value is an estimate. For best results, specify a value that is slightly greater than the largest known
radius in the input data.
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Curve Type
Specifies the type of curve (either Parabola or Circular Arc) that are created between the tangents.

Creation Settings
Alignment
Specifies the name of the parent alignment. Each alignment must have a unique name.
Profile
Specifies the name of the profile. Each profile must have a unique name.
Profile Style
Displays the current style. Click the arrow to select another profile style.
Layer
Displays the layer on which the profile object is created. Click the arrow to select another layer.

Show Report
Opens the Best Fit Profile Report Vista (page 2391), which lists the results of the best fit regression, including
the coordinates of each regression point.

Create Profile Band Style Dialog Box
Click the type of profile view band style you want to create, then click OK.
After selecting the band style, the Profile View Band Style dialog box (page 2414) is displayed for you to create
the style.
Related procedures:
■

Profile View Band Styles (page 1133)

Create Profile - Draw New Dialog Box
Use this dialog box to configure the settings for a new layout profile.
After using this dialog box, click OK to open the Profile Layout Tools dialog box (page 2419) and prepare
drawing tools. Draw the profile on the profile view grid by selecting PVIs (points of vertical intersection).
Related procedures:
■

Creating Layout Profiles (page 1143)

General Tab (Create Profile - Draw New Dialog Box)
Use this tab to enter basic information about the profile, including style, layer, and label set.
Alignment
Specifies the horizontal alignment along which to create the profile.
Name
Specifies the name of the profile. Each profile must have a unique name.
Description
Specifies an optional description of the profile.
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Profile Style
Profile Style List
Displays the current style. Click the arrow to select another profile style in the drawing.
Style Selection
Specifies the style options. Create a style, copy or edit the current style selection, or pick a style from
drawing.
Style Detail
Opens the Style Detail dialog box. Preview the style and creation information.

Profile Layer
Profile Layer List
Displays the layer on which the profile object is created.
Object Layer
Opens the Object Layer dialog box (page 2221), in which you can select or create a layer on which the profile
is drawn.

Profile Label Set
Profile Label Set List
Displays the default profile label set. You can either accept the default label set, or use the list to select a
different one from the drawing.
Label Set Selection
Edits or copies the current label set, or creates a label set. The Style Detail icon previews the current style.
Style Detail
Opens the Style Detail dialog box. Preview the label set and creation information.

Design Criteria Tab (Create Profile - Draw New Dialog Box)
Use this tab to specify the profile design criteria settings, including the design criteria file and design check
set.
Alignment
Specifies the horizontal alignment along which to create the profile.
Name
Specifies the name of the profile. Each profile must have a unique name.
Description
Specifies an optional description of the profile.

Use Criteria-Based Design
Specifies whether to apply design criteria to the profile. If this check box is cleared, then the Use Design
Criteria File and Use Design Check Set options are not available.

Use Design Criteria File
Use Design Criteria File
Specifies whether to associate a design criteria file with the profile. If this check box is cleared, then the
design criteria file selector and Default Criteria table are not available.
For more information, see Profile Standards in the Design Criteria File (page 1140).
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Design Criteria File Selector
Specifies the design criteria file to associate with the profile. The design criteria file that is applied to the
parent alignment is displayed by default. Click

to select another design criteria file.

Default Criteria Table
Displays the profile standards formulas that are defined in the selected design criteria file. Click the Value
column to change a criteria table.

Use Design Check Set
Use Design Check Set Check Box
Specifies whether to associate a design check set with the profile. If this check box is cleared, then the
Design Check Set list is not available.
For more information, see Profile Design Check Sets (page 1141).
Design Check Set List
Displays the default design check set. You can either accept the default design check set, or use the list to
select a different one from the drawing.
Design Check Set Selection
Edits or copies the current design check set, or creates a design check set.

Create Profile from Surface Dialog Box
Use this dialog box to create profiles from existing surfaces, including profiles at offsets to parent alignments.
Each profile created here must be associated with a horizontal alignment and one or more surfaces.
Alignment
Specifies the horizontal alignment along which to create the profile. Select an alignment by name, or click
to select an alignment in the drawing.
Select Surfaces
Lists all surfaces in the current drawing. Select surfaces by name, or click
to select surfaces in the
drawing. To select multiple surfaces, hold down the Shift key while clicking with the mouse.
Station Range
Specifies the range of stations along the parent alignment that are included in the profile. Default values
represent the full length of the alignment. To set a different length, enter station values numerically, or
click

to select stations in the drawing.

Sample Offsets
Specifies whether to create offset profiles. Select this option if you want offsets. Enter numeric values for
the offset distances. Enter positive numbers for right offsets, negative numbers for left offsets, and commas
to separate the values (for example, 10,-10,25). Click Add to add each set of profiles to the profile list.

Profile List
Lists the profiles that have been created for the specified alignment and surfaces. You cannot edit profiles
that were created in a previous session. You can edit Profiles created in the current session.
Name
Specifies the name of the profile. Default name strings are generated as defined in Profile Settings dialog
box (page 2406). Existing profiles for the parent alignment are also displayed in this list as unavailable
entries.
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Description
Specifies optional description of the profile.
Type
Specifies whether the profile represents surface or design layout.
Data Source
For surface profile, displays the name of the surface represented in the profile. For superimposed profiles,
displays the name of the superimposed profile. For corridor profiles, specifies the name of the source
corridor. Not used for layout profiles.
Offset
Specifies the offset distance from the centerline of the parent horizontal alignment: 0 for a centerline
profile, a positive number for a right offset, a negative number for a left offset.
Update Mode
For surface profiles only. Specifies whether the profile is dynamic or static.
Dynamic: The profile automatically updates to reflect changes in the surface elevation and the route traced
by the parent horizontal alignment.
Static: The profile shows surface elevations at the time of its creation. It does not update to reflect changes
that occur later.
Layer
Specifies the drawing layer on which the profile is placed.
Style
Specifies the style used by the profile.
Station Start/End
Specifies the first and last station numbers for the profile. The station numbers represent distances along
the parent horizontal alignment.
Elevation Minimum/Maximum
Specifies the highest and lowest elevation values that occur along the profile.
Remove
Removes a selected profile from the profile list. Any profiles removed in this way are unavailable for
drawing in a profile view.
Draw in Profile View
Opens the Create Profile View dialog box (page 2397), configured to draw the current profiles.
OK
Saves the profile data and closes the Create Profile from Surface dialog box. If one or more profile views
are created along the alignment, the profiles you created are added to the views.
Cancel
Cancels the creation of profiles.
Related procedures:
■

Creating Surface Profiles (page 1142)

■

Understanding Profiles (page 1113)

Create Profile View Wizard
Use this wizard to create single or multiple profile views.
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Some controls on this wizard are disabled when it is used with the plan production tools (page 1901).
Related procedures:
■

Creating Profile Views (page 1208)

■

plan production tools (page 1901)

General Page (Create Profile View Wizard)
Use this page to specify basic information about the profile view, including the parent alignment and the
profile view name, description, style, and layer.
NOTE The controls on this page are not available when multiple profile views are created as part of the plan
production process.
Select Alignment
Specifies the name of the parent horizontal alignment for the profile that appears in the profile view.
Select a name from the list or click to pick an alignment from the drawing.
Profile View Name
Specifies an editable, system-generated name. The name must remain unique within the drawing.
Description
Specifies an optional description of the profile.
Profile View Style
Specifies the style for the profile view. Provides standard controls you use to review or change the style.
Profile View Layer
Specifies the drawing layer for the profile view. To review or change layer data, click

.

Show Offset Profiles By Vertically Stacking Profile Views
Specifies to create stacked profile views (page 2783) views. Selecting this option causes the Stacked Profile
page (page 2399) to become available.

Station Range Page (Create Profile View Wizard)
Use this page to specify the station range to which the profile view is drawn.
NOTE This page is disabled when multiple profile views are created as part of the plan production process.
Automatic
Specifies the full station range for the horizontal alignment.
User Specified Range
Limits the station range in the profile view. Either enter numeric station values in the Start and End fields,
or click

to select the range on the alignment in the drawing.

Length of Each View
Specifies a length for each profile view segment in a multiple profile view.

Profile View Height Page (Create Profile View Wizard)
Use this page to specify the profile view height and any split profile view settings.
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Profile View Height
Automatic
Specifies the full height of the highest profile. Includes a buffer region above the maximum and below
the minimum elevations.
User Specified
Specifies the height to which the profile view is drawn. If a profile extends beyond the user-specified value,
it is either split according to the Split Profile View settings or clipped.
Profile View Datum By
Specifies how to place the datum for all profiles within the profile view.
■

Minimum Elevation—All profile datum values are based on the lowest datum value of all profiles in
the profile view. This option works well for profiles that have relatively high variation in elevation.

■

Mean Elevation—Profile datum values are based on the mean value of all profiles drawn in the profile
view. Profiles are drawn in the center of the profile view, which places an equal amount of space above
and below the profile in the profile view. This option is useful in profiles that have relatively little
variation in elevation.

Split Profile View
NOTE The Split Profile View settings are enabled only if the Profile View Height is set to User Specified.
Split Profile View
Specifies that if the height of the profile extends beyond the User-Specified height value of the profile
view, the profile view splits.
First Split View Style
Specifies the profile view style to use for the first split profile view segment. Use the standard controls to
edit the style or create a new one.
Intermediate Split View Style
Specifies the profile view style to use for the all split profile view segments between the first and last
segments. Use the standard controls to edit the style or create a new one.
Split Station
Specifies the horizontal location to split the profile view: previous major grid, previous minor grid, or
exact station.
Datum Option
Specifies the vertical location to split the profile view: previous major grid, previous minor grid, or exact
elevation.
Last Split View Style
Specifies the profile view style to use for the last split profile view segment. Use the standard controls to
edit the style or create a new one.

Stacked Profile Page (Create Profile View Wizard)
Use this page to specify the settings for stacked profile views (page 2783) views.
NOTE This page is not available if the Show Offset Profiles By Stacking Views check box on the General page
(page 2398) is cleared.
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Number of Stacked Views
Specifies the total number of profile views to create. This unitless value can be any integer from 2 to 9.
The graphic on the right-hand side of the page changes to reflect the number selected.
Gap Between Views
Specifies the amount of spacing (in plotted units) to leave between stacked profile views. A negative value
in this field causes the stacked profile views to overlap.
Top View Style
Specifies the profile view style to use for the top-most profile view.
Middle View Style
Specifies the profile view style of all profile views between the top-most and bottom-most profile views.
Bottom View Style
Specifies the profile view style to use for the bottom-most profile view.
Preview (unlabled)
Displays the number of profile views specified in the Number of Stacked Views field.

Profile Display Options Page (Create Profile View Wizard)
Use this page to view and change settings for all the profiles associated with the specified alignment.

Select Stacked View To Specify Options For
NOTE This control is not available if the Show Offset Profiles By Stacking Views check box on the General page
(page 2398) is cleared.
Displays a list of the stacked profile views. The number of profile views in this list depends on the Number
Of Stacked Views specified on the Stacked Profile page (page 2399). Select a profile view from the list, and then
use the Specify Profile Display Options table to specify the settings for that stacked profile view.

Specify Profile Display Options
Change column widths in the table to make it easier to see the contents of cells. Use the following controls
to modify profiles in the view.
Select All Profiles
Selects the Draw check box for all profiles listed in the table.
Deselect All Profiles
Clears the Draw check box for all profiles listed in the table.
Name
Specifies the name of the profile.
Draw
By default, specifies that all profiles are drawn in the profile view. To omit a profile from the profile view,
clear its check box.
Clip Grid
Specifies which profile controls the horizontal and vertical extents of the profile view grid. This setting
works only if the profile view style Grid Options are set to clip the grid. For further information, see Grid
Tab (Profile View Style Dialog Box) (page 2436).
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Split At
Specifies which profile to favor when splitting a profile view containing multiple profiles.
For example, a profile view often contains both existing ground and finished ground profiles. Selecting
Split At for the finished ground profile ensures that split occurs at the finished ground profile elevation.
Description
Specifies an optional description of the profile.
Type
Specifies whether the profile is a surface profile
profile

, layout profile

, superimposed profile

, or corridor

.

Data Source
For surface profile, displays the name of the surface represented in the profile. For superimposed profiles,
displays the name of the superimposed profile. For corridor profiles, specifies the name of the source
corridor. Not used for layout profile.
Offset
Specifies the offset distance from the centerline of the parent horizontal alignment: either 0 for a centerline
profile, a positive number for a right offset, a negative number for a left offset.
Update Mode
For surface profiles only, specifies whether the profile is dynamic or static.
Dynamic: The profile automatically updates to reflect changes in the surface elevation and the route traced
by the parent horizontal alignment.
Static: The profile shows surface elevations at the time of its creation. It does not update to reflect changes
that occur later.
Layer
Specifies the drawing layer on which the profile is placed.
Style
Specifies the style used by the profile. If you change the style here, it changes the profile properties and
the style is retained as the specified style when creating additional profile views. Use the standard controls
to edit the style or create a new one.
Override Style
Specifies whether the profile style is overridden (changed) for the current profile view. You can override
the style by clicking the check box and selecting a different style. If you do, the style change applies only
to the current profile view. It does not change the style in the profile properties.
Labels
Click to open the Pick Profile Label Set dialog box where you can edit the profile labels.
Station Start/End
Specifies the first and last station numbers for the profile. The station numbers represent distances along
the parent horizontal alignment.
Elevation Low/High
Specifies the highest and lowest elevation values that occur along the profile.
Alignment
Specifies either the parent alignment of current profile view or the parent alignment of any superimposed
profiles.

Profile Display Options Page (Create Profile View Wizard) | 2401

Pipe Network Display Page (Create Profile View Wizard)
Use this page to specify which pipe networks or parts to include in the profile view.
NOTE This page is not available if there are no pipe networks present in the drawing.

Select Stacked View To Specify Options For
NOTE This control is not available if the Show Offset Profiles By Stacking Views check box on the General page
(page 2398) is cleared.
Displays a list of the stacked profile views. The number of profile views in this list depends on the Number
Of Stacked Views specified on the Stacked Profile page (page 2399). Select a profile view from the list, and then
use the Select Pipe Networks To Draw In Profile View table to specify the pipe network display settings for
that stacked profile view.

Select Parts From Screen
Select pipe networks or parts by clicking in the drawing window. Click then follow the prompts at the
command line.

Select Pipe Networks to Draw in Profile View
Use this list to select pipe networks or parts from the drawing. By default, this list is populated with all pipe
networks in the current drawing but none of the parts are selected.
Select All Networks
Selects the Select check box for all pipe networks and parts listed in the table.
Deselect All Networks
Clears the Select check box for all pipe networks and parts listed in the table.
Name
Specifies the name of the pipe network and its parts.
Select
Specifies whether a network or part is drawn in the profile view. Check box displays one of three states:
Not Selected. If a part is not selected, it is not drawn. If a pipe network is not selected, none of its parts
are drawn.
Selected. If a part is selected, it is drawn. If a pipe network is selected, all of its parts are drawn.
Partially selected. If a pipe network is partially selected, only its selected parts are drawn. Parts cannot
be partially selected.
Show Only Parts Selected
Specifies whether to display only the pipes and structures that are selected to draw in the profile view.

Data Bands Page (Create Profile View Wizard)
Use this page to specify the properties of the data bands associated with the profile view.
Select Band Set
Specifies the set of band styles for the profile view. Provides standard controls you use to review or change
the set.
NOTE This control is disabled when multiple profile views are created as part of the plan production process.
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List of Bands
Location
Specifies either the top or bottom of the profile view. The table below this field shows current location of
the bands in the current band style set.
Band Type
Specifies the data band type: Profile Data, Vertical Geometry, Horizontal Geometry, Superelevation,
Sectional Data, or Pipe Data.
Style
Specifies the style for the band type.
Profile 1/Profile 2
Specifies which profile or profiles supply the data for the band. For example, if two separate profiles are
listed in Profile 1 and Profile 2 columns, then each station displayed in the band shows the elevation
information for both profiles.
Alignment
Specifies either the parent alignment of current profile view or the parent alignment of any superimposed
profiles.
Geometry Points
Specifies the geometry points to label. Click
box (page 2412).

to open the Geometry Points to Label in Band dialog

Data Source
Specifies the source of the data displayed in the band. The options displayed depend on the type of data
band:
Pipe Data Band: Select a pipe network in the drawing file.
Sectional Data Band: Select a sample line group that is associated with the alignment in the profile view
This column is available only for pipe and sectional data bands.
Material
Specifies a material or list of materials for which data is displayed in a sectional data band. The options
are generated using the properties of sample line groups that are associated with the alignment in the
profile view.

Hatch Options Page (Create Profile View Wizard)
Use this page to add hatch areas to show cut and fill regions in a profile view.

Add Areas to Hatch
Cut Area
Click to add hatching to the profile view in areas where terrain must be cut to create the design profile.
Fill Area
Click to add hatching to the profile view in areas where terrain must be filled to create the design profile.
Multiple Boundaries
Click to add hatching to the profile view in areas where multiple boundaries are used to define a hatch
region.
From Criteria
Click to add hatching to the profile view in areas where quantity takeoff criteria are used to define a hatch
region.
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Hatch Table
Hatch Area
Specifies the upper and lower boundaries for each hatch area. Use the buttons along the top of the table
to manage these boundaries. Use the + and – buttons to expand and collapse the list of boundaries for
each hatch area heading.
Collapse All
Collapse the display of boundaries to show only the top-level headings.
Expand All
Expand the display to show all boundaries.
Add Upper Boundary
Add an upper boundary to the selected hatch area.
Add Lower Boundary
Add a lower boundary to the selected hatch area.
Delete
Click to delete a selected boundary or an entire hatch area definition, depending on what is selected in
the table. Individual boundaries can be deleted only if the definition includes more than two.
Profile
Specifies the surface or layout profile that defines each hatch area boundary. Where only a single surface
and single layout profile exist in the profile view, the profiles are automatically assigned to boundaries.
Click the arrow beside the profile name to select a different profile.
Shape Style
Specifies the shape style applied to the hatch area. Click the name to select another style or modify the
style properties. These styles are found on the Toolspace Settings tab ➤ General ➤ Multipurpose Styles
➤ Shape Styles.

Multiple Plot Options Page (Create Profile View Wizard)
Use this page to specify the layout of the plotted profile view segments.
NOTE This page is disabled if you are creating a single profile view.

Draw Order
By Rows
Specifies to draw profile view segments in a row. After the number of views in the Maximum in a Row
field has been reached, a new row is started.
By Columns
Specifies to draw profile view segments in a column. After the number of views in the Maximum in a
Column field has been reached, a new column is started.
Maximum in a Row (or Column)
Specifies the maximum number of profile view segments to draw in a single row or column. After this
value is reached, a new row or column is started.
Start Corner
Specifies the direction in which to draw the profile view segments:
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Lower Left: Draw profile view segments in rows starting from the lower left. When the Maximum in a
Row value is reached, a new row is started above.
Upper Left: Draw profile view segments in rows starting from the upper left. When the Maximum in a
Row value is reached, a new row is started below.
Lower Right: Draw profile view segments in rows starting from the lower right. When the Maximum in
a Row value is reached, a new row is started to the left.
Upper Right: Draw profile view segments in rows starting from the upper right. When the Maximum in
a Row value is reached, a new row is started to the left.

Gap Between Adjacent Profile Views
Row
Specifies amount of spacing (in plotted units) to leave between adjacent rows of profile view segments.
Column
Specifies amount of spacing (in plotted units) to leave between adjacent columns of profile view segments.

Create Quick Profiles Dialog Box
Use this dialog box to create a temporary profile to view elevation information along a line, polyline, feature
or lot line, survey figure, or surface.

Surfaces to Sample
Select All Surfaces
Specifies whether to sample all surfaces in the drawing in the quick profile. This option is cleared when
you clear any of the surfaces in the list.
Surface
The name of a surface in the drawing. This field is read only.
Select
Select the check box to sample the surface in the quick profile.
Profile Style
Specifies the style used to display the surface in the quick profile. To change the style, click in the Profile
Style column to open the Pick Profile Style dialog box. Select a style in the list or use the standard controls
to create a style, copy or edit the current style selection, or pick a style from the drawing.
Profile View Style
Specifies the style of the profile view. Select a style in the list or use the standard controls to create a style,
copy or edit the current style selection, or pick a style from the drawing.
Draw 3D Entity Profile
Specifies whether the elevation data for the selected 3D object is displayed in the quick profile. Used only
when the object you selected is a 3D object such as a 3D line or polyline.
3D Entity Profile Style
Specifies the style used to display the 3D object elevation data in the quick profile. Select a style in the
list or use the standard controls to create a style, copy or edit the current style selection, or pick a style
from the drawing.
Related procedures:
■

Creating a Quick Profile (page 1153)
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Edit Feature Settings - Profile Dialog Box
Use this dialog box to view and change profile-related settings.
This topic documents settings in all profile-related Edit Settings dialog boxes (drawing-level, feature-level,
and command-level).
■

Drawing-level ambient settings are identified by the

■

Profile feature settings are listed near the top of this dialog box, after the General property group, and
are identified by the

■

drawing icon.

profile icon.

Profile command settings are identified by the

command icon.

For general information about drawing, feature, and command settings and their interaction, see Working
with the Standard Settings Dialog Box Controls (page 78).
For information about drawing-level ambient settings, see Ambient Settings Tab (Drawing Settings Dialog
Box) (page 2078)

Default Styles
Use these settings to specify the default styles assigned to profiles and their labels.
Profile Label Set
Specifies the default profile label style set. Click in the Value column, and click
Profile Label Set dialog box.

to select a style in the

Profile Style
Specifies the default profile style. Click in the Value column, and click
Style dialog box.

to select a style in the Profile

For information about style selection, see Select Style Dialog Box (page 2021).

Default Name Format
Use these settings to specify the default name formats for profiles, offset profiles, superimposed profiles, and
3D entity profiles. Click in the Value column, and click
box (page 2022).

to make changes in the Name Template dialog

Profile Creation
Use these settings to specify the default values for vertical curve sub-entities. For all linear settings such as
length, height, or radius, enter a number in the Value column or click
area.

and select a distance in the drawing

Default Vertical Curve Type
Specifies the default vertical curve type for a new profile:
■

Circular Curve

■

Symmetric Parabola

■

Asymmetric Parabola

Parabolic Sag Curve Length And K-Value
Specifies whether curve length or K value is the primary constraint on a parabolic sag curve.
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Parabolic Crest Curve Length And K-Value
Specifies whether curve length or K value is the primary constraint on a parabolic crest curve.
Parabolic Crest Curve Length
Specifies the default length for a parabolic crest curve.
Parabolic Crest Curve K-Value
Specifies the default K-value for a parabolic crest curve.
Parabolic Sag Curve Length
Specifies the default length for a parabolic sag curve.
Parabolic Sag Curve K-Value
Specifies the default K-value for a parabolic sag curve.
Circular Crest Curve Length And Radius
Specifies whether curve length or radius is the primary constraint on a circular crest curve.
Circular Sag Curve Length And Radius
Specifies whether curve length or radius is the primary constraint on a circular sag curve:
Circular Crest Curve Length
Specifies the default length for a circular crest curve.
Circular Crest Curve Radius
Specifies the default radius for a circular crest curve.
Passing Eye Height
Specifies the default passing eye height.
Circular Sag Curve Length
Specifies the default length for a circular sag curve.
Passing Object Height
Specifies the default passing object height.
Circular Sag Curve Radius
Specifies the default radius for a circular sag curve.
Stopping Eye Height
Specifies the default stopping eye height.
Asymmetrical Crest Curve Length 1
Specifies the default length for the first part of the asymmetrical crest curve.
Stopping Object Height
Specifies the default stopping object height.
Asymmetrical Crest Curve Length 2
Specifies the default length for the second part of the asymmetrical crest curve.
Headlight Angle
Specifies the default headlight angle.
Asymmetrical Sag Curve Length 1
Specifies the default length for the first part of the asymmetrical sag curve.
Headlight Height
Specifies the default headlight height.
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Asymmetrical Sag Curve Length 2
Specifies the default length for the second part of the asymmetrical sag curve.

Criteria-Based Design Options
Use these settings to specify the default design criteria.
For more information, see Criteria-Based Profile Design (page 1139).
NOTE The design criteria values of the parent alignment take precedence over the default design criteria values
of the profile. If the parent alignment does not use design criteria values, then the criteria-based design options
in the profile are used.
Use Design Criteria File Option
Specifies whether to associate a design criteria file with the profile.
The first XML file found in the <install directory>\Data\Corridor Design Standards\<units> is used by default.
You can select another design criteria file by using either the Create Profile - Draw New dialog box (page
2394) during profile creation, or the Profile Properties dialog box (page 2424) after the profile is created.
Use Design Checks Option
Specifies whether to associate a design check set with the profile.
Default Design Check Set
Specifies the default design check set. Click in the Value column, and click
to select a set in the Default
Design Check Set dialog box.
You can select another design check set by using either the Create Profile - Draw New dialog box (page
2394) during profile creation, or the Profile Properties dialog box (page 2424) after the profile is created.
NOTE This setting is not available if the Use Design Checks Option is set to False.

Curve Tessellation Option
NOTE This property group is displayed when accessing the settings from the CreateProfileLayout command.
Use these settings to specify the default behavior when curve entities are used as an input option for best
fit arc, line, and parabola creation.
Tessellate Curve
Specifies whether to tesselate curve segments if they are included as an input option.
Mid-ordinate Tolerance
Specifies the mid-ordinate tolerance based on a distance across the tessellated curve segments. Enter a
length in the Value column or click and select two points along a curve.

Regression Graph Option
NOTE This property group is displayed when accessing the settings from the CreateProfileLayout command.
Use this setting to specify the default behavior for regression analysis graphs in best fit arc, line, and parabola
creation.
Spline Fit For Regression Analysis Graph
Specifies whether the regression graph displays splines on the green line that represents the best fit entity.

Quick Profile Options
NOTE This property group is displayed when accessing the settings from the CreateQuickProfile command.
Use these settings to specify the default settings for quick profile creation.
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Select All Surfaces
Specifies whether to generate profiles of all surfaces in the drawing file in the quick profile.
Create Profile of 3D Entities
Specifies whether to include elevation data for the selected 3D entity in the quick profile.

Superimpose Profile
NOTE This property group is displayed when accessing the settings from the SuperimposeProfile command.
Use these settings to specify the default values for the mid-ordinate distances that the system uses when
tessellating (approximating) the shape of curves in superimposed profiles.
Horizontal Mid-ordinate Distance
Specifies the horizontal mid-ordinate distance for tessellated curve segments. Enter a distance in the Value
column or click and select a distance in the drawing.
Vertical Mid-ordinate Distance
Specifies the vertical mid-ordinate distance for tessellated curve segments. Enter a length in the Value
column or click

and select a distance in the drawing.

These settings are used in the Superimpose Profile Options dialog box (page 2443).
Related procedures:
■

Profile Settings (page 1120)

■

Creating Profiles (page 1141)

Edit Feature Settings - Profile View Dialog Box
Use this dialog box to view and change profile view-related settings.
This topic documents settings in all profile view-related Edit Settings dialog boxes (drawing-level, feature-level,
and command-level).
■

Drawing-level ambient settings are identified by the

■

Profile view feature settings are listed near the top of this dialog box, after the General property group,
and are identified by the

■

drawing icon.

profile view icon.

Profile view command settings are identified by the

command icon.

For general information about drawing, feature, and command settings and their interaction, see Working
with the Standard Settings Dialog Box Controls (page 78).
For information about drawing-level ambient settings, see Ambient Settings Tab (Drawing Settings Dialog
Box) (page 2078)

Default Styles
Use these settings to specify default styles assigned to profile views and their labels.
Marker Style
Specifies the default style for markers associated with manually placed profile view labels for station and
elevation or depth. Click in the Value column, and click
box.

to select a style in the Marker Style dialog
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Profile View Style
Specifies the default profile view style. Click in the Value column, and click
Profile View Style dialog box.

to select a style in the

Profile Label Set
Specifies the default style for profile label sets. Click in the Value column, and click
in the Profile Label Set dialog box.

to select a style

First Split View Style
Specifies the default style for the first split profile segment. Click in the Value column, and click
select a style in the First SplitView Style dialog box.

to

Intermediate Split View Style
Specifies the default style for the intermediate split profile view segments. Click in the Value column, and
click

to select a style in the Intermediate SplitView Style dialog box.

Last Split View Style
Specifies the default style for the last split profile view segment. Click in the Value column, and click
to select a style in the Last SplitView Style dialog box.
Top Stack View Style
Specifies the default profile view style of the top-most profile view in the stack. Click in the Value column,
and click

to select a style in the Top StackView Style dialog box.

Middle Stack View Style
Specifies the default profile view style of all profile views between the top-most and bottom-most profile
views. Click in the Value column, and click

to select a style in the Middle StackView Style dialog box.

Bottom Stack View Style
Specifies the default profile view style of the bottom-most profile view in the stack. Click in the Value
column, and click

to select a style in the Bottom StackView Style dialog box.

Profile Label Set
Specifies the default profile label set. Click in the Value column, and click
Label Set dialog box.

to select a set in the Profile

Profile Station and Elevation Label Style
Specifies the default style for profile station and elevation labels. Click in the Value column, and click
to select a style in the Profile Station and Elevation Label Style dialog box.
Profile Depth Label Style
Specifies the default style for profile depth labels. Click in the Value column, and click
in the Profile Depth Label Style dialog box.

to select a style

Projection Label Style
Specifies the default style for labels on projected objects. Click in the Value column, and click
a style in the Profile Projection Label Style dialog box.
For information about style selection, see Select Style Dialog Box (page 2021).
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to select

Default Name Format
Use this setting to specify the default name format for profile views. Click in the Value column, and click
to make changes in the Name Template dialog box (page 2022).

Profile View Creation
Use these settings to specify default parameters for the creation of profile views.
Specify Profile Station Range
Specifies whether to allow the user to set range of stations to be displayed in the profile view.
Specify Profile Elevation Range
Specifies whether to allow the user to set a minimum and maximum height to be displayed in the profile
view.
Pipe Network Parts
Specifies whether to Display Only Selected or to Display All pipe network parts in the profile view.

Split Profile View Options
Use these settings to specify default parameters for splitting profile views.
NOTE If the Split Profile Views option is set to No, then the remaining Split Profile View Options are not available.
Split Profile Views
Specifies whether to split a profile view that exceeds the maximum profile view height setting.
Split Station Option
Specifies the default split station rounding setting.
Split Datum Option
Specifies the default datum elevation rounding setting.

Stacked Profile View Options
Use these settings to specify default parameters for stackng profile views.
NOTE If the Stacked Views option is set to No, then the remaining Stacked Profile View Options are not available.
Stacked Views
Specifies whether to create stacked profile views by default.
Number of Stacked Views
Specifies the default total number of profile views to create. This unitless value can be any integer from
2 to 9.
Gap Between Views
Specifies the default amount of spacing (in plotted units) to leave between stacked profile views. Enter a
distance in the Value column or click and select a distance in the drawing. A negative value in this field
causes the stacked profile views to overlap.

Multiple Profile View Creation
NOTE This property group is displayed when accessing the settings from the CreateMultipleProfileView command.
Use these settings to specify defaults for creating multiple profile views.
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Default Profile VIew Length
Specifies the default length for profile views. Enter a length in the Value column or click and select a
length in the drawing area.
Default Profile VIew Height
Specifies the default height for profile views. Enter a height in the Value column or click
height in the drawing area.

and select a

Plot Pattern
Specifies whether profile views are by default plotted by rows or columns.
Profile Views In Row Or Column
Specifies the default number of profile views in a row or column.
Start Corner
Specifies the default corner in which the first of the multiple profile views will be plotted. (Lower Left,
Lower Right, Upper Left, Upper Right)
Column Spacing
Specifies the default gap between individual profile views in a column. Enter a distance in the Value
column or click

and select a distance in the drawing area.

Row Spacing
Specifies the default gap between individual profile views in a row. Enter a distance in the Value column
or click

and select a distance in the drawing area.

Related procedures:
■

Profile View Settings (page 1121)

Geometry Points to Label in Band Dialog Box
Use this dialog box to specify the horizontal and vertical geometry points that you want to label in the
profile view data band.
See also:
■

Creating Profile Views (page 1208)

■

Editing Profile Views (page 1213)

Alignment Points
Use this tab to specify which alignment geometry points you want to label in the data band.

Select Geometry Points To Label
Select All
Selects all check boxes in the Label column.
Deselect All
Clears all check boxes in the Label column.

2412 | Chapter 70 Profiles Dialog Boxes

Geometry Point Column
Identifies the available geometric details.
NOTE The Abbreviations tab (page 2077) in the Drawing Settings dialog box also lists these geometry points.
Label Column
Specifies whether to label a geometry point.

Profile Points
Use this tab to specify which profile geometry points you want to label in the data band.

Select Geometry Points To Label
Select All
Selects all check boxes in the Label column.
Deselect All
Clears all check boxes in the Label column.
Geometry Point Column
Identifies the available geometric details.
NOTE The Abbreviations tab (page 2077) in the Drawing Settings dialog box also lists these geometry points.
Label Column
Specifies whether to label a geometry point.

Import Quantity Takeoff Criteria Dialog Box
Use this dialog box to specify profile view hatch areas based on quantity takeoff criteria.
Pick quantity takeoff criteria to import
Select a criteria from the list. Criteria defined for the drawing are specified on the Toolspace Settings
tab ➤ Quantity Takeoff ➤ Quantity Takeoff Criteria. Standard buttons are provided to create or edit a
style. For more information, see Select Style dialog box (page 2021).

Hatch Boundary Table
Area Boundary Name
Specifies the boundaries defined for the quantity takeoff criteria.
Profile
Specifies the profile in the profile view that is assigned to the boundary.
Related procedures:
■

Adding Hatch Areas to a Profile View (page 1216)

Insert PVIs Dialog Box
Use this dialog box to record data about points of vertical intersection (PVIs) that you want to add to a layout
profile.
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After you select the vertical curve type (or None), the table grid shows the data columns that apply to that
type.
The dialog box is designed to support rapid entry of PVI data from the numeric keypad. In the table grid,
after you enter the first station number, press Enter to move to the next cell, and continue in this manner.
Related procedures:
■

Editing PVIs (page 1193)

Profile Data Band Style Dialog Box
Use this dialog box to create band styles that annotate profile and alignment data on the profile views.
Create separate band styles for profile data (station and elevation), vertical geometry, horizontal geometry,
superelevation, pipe data, and sectional data. The procedures are similar for each type.
See also:
■

Profile View Band Styles (page 1133)

■

Editing Profile Views (page 1213)

Information Tab (Profile Data Band Style Dialog Box)
Use this tab to change the name and description of a band style or review details, such as when the style
was most recently modified.
Name
Specifies the name of the band set.
Description
Specifies an optional description of the band set.
Created By
Displays the Windows login name of the person who created the band set.
Date Created
Displays the date and time the band set was created.
Last Modified By
Displays the Windows login name of the person who last modified the band set.
Date Modified
Displays the date and time the band set was last modified.
Related procedures:
■

Profile View Band Styles (page 1133)

■

Editing Profile Views (page 1213)

Band Details Tab (Profile Data Band Style Dialog Box)
Use this tab to design the format and contents of the band style.
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Title Text
Click the Compose Label button to change attributes of the band title, using the Label Style Composer dialog
box (page 2180).

Layout
Band Height
Specifies the vertical dimension of the band in plotted units, which can affect readability of the contents.
Text Box Width
Specifies the width (in plotted units) of the box that contains the band title.
Offset From Band
Specifies the distance between the title box and the left side of the data band.
Text Box Position
Specifies the location of the title text box with respect to the band: Left of Band or Right of Band.
NOTE In the Superelevation Band Style - Band Details tab, you can specify the height as User Specified or Automatic.
If you select Automatic you can enter a Vertical Exaggeration value.

Labels and Ticks
At
Specifies the location type to be labeled, which varies according to the band style:
Profile Data Bands Style: major station, minor station, horizontal geometry point (HGP), vertical geometry
point (VGP), station equation, or incremental distance.
Vertical Geometry Bands Style: uphill tangent, downhill tangent, crest curve, or sag curve.
Horizontal Geometry Bands Style: tangent, curve, or spiral.
Superelevation Data Bands Style: normal crown, level crown, reverse crown, full super, shoulder critical
points, or slope transition region.
Sectional Data Bands Style: sample line station, incremental section data.
Pipe Data Bands Style: structure, pipe.
Several label styles can appear in the same data band, but each one must be composed separately. Each
appears in the preview as it is created.
Full Band Height Ticks
Select if you want a line across the band for each tick.
Small Ticks At
Select if you want smaller ticks. Select the tick location (Top, Middle, or Bottom of the band), and specify
the tick size in drawing units.
Compose Label
Click to review or change the label text, using the Label Style Composer dialog box (page 2180).
Anchor label to
Specifies how labels are anchored in Profile View Horizontal Geometry and Vertical Geometry Bands.
■

Segment in Band anchors the label in the middle of the drawn segment, regardless of whether this is
the true middle.

■

True Geometry Location anchors the label to the true middle of the item being labeled. If this location
is not shown in the profile view, the label components anchored to that point are not shown either.
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Schematic Line Option
For horizontal geometry data bands, specify what information is represented with schematic lines in the
data band:
■

Geometry shows curved lines where spirals and curves are located

■

Radius shows angled lines for spirals and offset straight lines for curves. The line at the location of
each curve is offset from the band centerline a distance directly proportional to the curve radius. For
example, the line for a 100-radius curve is closer to the centerline than the line for a 1000-radius curve.

■

Curvature shows angled lines for spirals and offset straight lines for curves. The line at the location of
each curve is offset from the band centerline a distance directly proportional to the rate of curvature
(inverse of radius). For example, the line for a 100-radius curve is farther from the centerline than the
line for a 1000-radius curve.

Related procedures:
■

Profile View Band Styles (page 1133)

■

Editing Profile Views (page 1213)

Display Tab (Profile Data Band Style Dialog Box)
Use this tab to manage the display of profile view band style components.
Each type of band style has a slightly different set of display components, but they are all managed in the
same way. For more information about the Component display section of this tab, see Display Tab (Style
Dialog Box) (page 2017).
Related procedures:
■

Profile View Band Styles (page 1133)

■

Editing Profile Views (page 1213)

Summary Tab (Profile Data Band Style Dialog Box)
Use this tab to review and adjust settings for the profile view band style.
For more information, see Summary Tab (Style Dialog Box) (page 2020).
Related procedures:
■

Profile View Band Styles (page 1133)

■

Editing Profile Views (page 1213)

Profile Entities Vista
Use this vista to view and edit numeric data about curves and tangents at a PVI or for a specific sub-entity
in a profile.
If
PVI Based is selected in the Profile Layout Tools (page 2419), the vista displays PVI data. If
Based is selected, the vista displays entity data.

Entity

Use the Profile Entities vista to navigate through all entities that make up the profile. You can select an
entity in the Profile Entities vista and then edit it in the Profile Layout Parameters dialog box (page 2417).
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Attributes in the Profile Entities vista and Profile Layout Parameters window are automatically updated as
the profile is edited.
If design criteria has been applied to the profile, a
warning symbol is displayed next to sub-entities that
violate the specified design criteria. For more information, see Viewing and Correcting Profile Design Criteria
Violations (page 1203).
The display can be filtered to show a selected range of entities along a profile. See Selecting Profile Sub-entities
(page 1192) for more information.
The Profile Entities vista is like a spreadsheet. Each row represents a profile entity and each column represents
an attribute for that entity. You can resize, move, and copy columns.
The first column (No.) is pinned and always displayed. It does not move when you use the scroll bar.
Two column configurations are available: default and criteria-based design. To switch between the
configurations, or to create your own configuration, right-click a column heading, and click Customize
Columns.
This window remains open when you grip edit the profile or enter another command. The window closes
when you either delete the currently selected profile, click the X button, or click
the Profile Layout Tools.

Profile Grid View on

Related procedures:
■

Vertical Curve Design (page 1166)

■

Criteria-Based Profile Design (page 1139)

■

Selecting Profile Sub-entities (page 1192)

■

Editing Profile Curve and Tangent Parameter Values (page 1198)

Profile Layout Parameters Dialog Box
Use this dialog box to analyze and modify profile data in a layout profile.
When the Profile Entities Vista (page 2416) is open, click any table row of PVI or sub-entity data. The data
populates the Profile Layout Parameters dialog box in a vertical layout that you may find more convenient
for analysis.
If

PVI Based is selected in the Profile Layout Tools (page 2419), the Profile Layout Parameters dialog box

displays PVI data. If
data.

Entity Based is selected, the Profile Layout Parameters dialog box displays entity

You can edit available parameters. You cannot edit parameters that are unavailable (shaded).
If the profile uses design criteria, then the Profile Layout Parameters dialog box contains up to three panels
that can be collapsed by clicking

. If design criteria has not been associated with the profile, then only

the Layout Parameters panel is available. If a sub-entity violates the specified design criteria, a
warning
symbol is displayed next to sub-entities that violate the specified design criteria. For more information, see
Viewing and Correcting Profile Design Criteria Violations (page 1203).
You cannot dock the Profile Layout Parameters dialog box, but you can pin or resize it.
This window remains open when you grip edit the profile or enter another command. The window closes
when you either delete the currently selected profile, click the X button in the upper right-hand corner of
the window, or click

on the Profile Layout Tools (page 2419) toolbar.

Profile Layout Parameters Dialog Box | 2417

Design Speed
Specifies the design speed of the current sub-entity. The design speed is set in the properties of the parent
alignment.
NOTE If multiple speeds are assigned to a sub-entity, then the highest speed is used to look up constraint values
from the design criteria file and to validate the design checks. This ensures the safest design for that sub-entity.

Design Criteria Panel
The following parameters are displayed only if design criteria has been associated with the profile.
Use the Design Criteria panel to apply design criteria that is different from the default values that have been
set for the profile. To change a criterion value, click the Value cell in the appropriate row.
A
warning symbol in the Property column indicates that the sub-entity design violates the criteria set
in the design criteria file. You can find the specific parameter that has been violated by examining the Layout
Parameters panel.
Minimum K For Stopping Sight Distance
Specifies the minimum K value for stopping sight distance at the specified design speed.
Minimum K For Passing Sight Distance
Specifies the minimum K value for passing sight distance at the specified design speed.
Minimum K For Headlight Sight Distance
Specifies the minimum K value for headlight sight distance at the specified design speed.

Layout Parameters
Use this panel to examine and change the general layout parameters of the selected sub-entity.
Click
Show More to expand the number of parameters that appears in the window. The default, collapsed
view displays editable and other important parameters. Use the horizontal and vertical scroll bars when the
list is longer or wider than the window.
When a design criteria file has been associated with a profile, the Constraints column displays the value to
which a given parameter is limited. The selected design criteria file defines the constrained values. When a
parameter value violates the range displayed in the Constraints column, a
to the parameter name.

warning symbol appears next

NOTE The constraint definition for each profile entity determines the parameters that are displayed in the Layout
Parameters panel.

Design Checks
The Design Checks panel displays the name and contents of the design check set that is associated with the
profile.
When the sub-entity design violates a design check, a
design check.

warning symbol appears next to the affected

NOTE The Design Checks panel is available only for profiles that use a design check set.
Related procedures:
■

Vertical Curve Design (page 1166)

■

Editing Profile Curve and Tangent Parameter Values (page 1198)
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■

Criteria-Based Profile Design (page 1139)

Profile Layout Tools
Use the tools in this toolbar to draw and edit profiles and to analyze vertical tangents and curves.
These tools are most useful for editing profiles by adding tangents and curves, or moving PVIs.
For dynamic surface profiles, most tools in this toolbar are not available. Use the Profile Entities Vista (page
2416) to display profile data. Similarly, many of the tools are unavailable for use with locked PVIs, including
the endpoints of curb return profiles.
The name of the currently selected profile is displayed at the top of the toolbar. When you click an icon,
the current command is displayed at the bottom of the toolbar. The toolbar remains open if you grip edit
the profile or enter another command. The toolbar closes if you either delete the currently selected profile
or click the X button in the upper right-hand corner of the toolbar.

Layout Profile Creation
These three buttons control how a layout profile is drawn on a profile view.
Draw Tangents
Adds a series of fixed tangents between specified points.
Draw Tangents With Curves
Adds a series of fixed tangents between specified points, with free curves automatically added at the points
of vertical intersection.
Curve Settings
Specifies the curve parameters to use with the Draw Tangents with Curves command.
To change the default curve settings, go to the Profile Creation section of the Edit Feature Settings - Profile
(page 2406) dialog box.

PVI Edit Operations
Use these three buttons to graphically modify the PVIs in a layout profile.
Insert PVI
Breaks a tangent into two adjacent tangents by creating a point of vertical intersection (PVI) at a specified
location on the profile view.
Click above or below an existing tangent to specify the new PVI location.
Delete PVI
Creates a single tangent from two adjacent tangents by removing a point of vertical intersection (PVI)
from a profile.
If two tangents meet at the PVI, they are replaced by a single tangent between two adjacent PVIs.
Move PVI
Moves a profile point of vertical intersection (PVI) to a new location on a profile view.
The tangents connected to the PVI remain attached. You can also use editing grips to move a PVI.

Tangent Creation Operations
Use these three buttons to add tangents to a layout profile.
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Fixed Tangent (Two Points)
Adds a fixed tangent between two specified points.
Fixed Tangent - Best Fit
Adds the most probable fixed tangent through a series of AutoCAD Civil 3D points, AutoCAD points,
existing entities, or clicks on screen.
Floating Tangent (Through Point)
Adds a floating tangent from an existing entity to a specified pass-through point.
Float Tangent - Best Fit
Adds the most probable floating tangent from a point on an existing entity through a series of AutoCAD
Civil 3D points, AutoCAD points, existing entities, or clicks on screen. Tangency is maintained to the
attached entity, regardless of how the entity is edited.
Free Tangent (Between Two Parabola)
Adds a free tangent between two parabolic curves.
Solve Tangent Intersection
Creates a PVI at the intersecting grade line of two tangents.

Curve Creation Operations
Use these buttons to add a curve to a profile. You can create curves by selecting entities to attach to, specifying
parameters, or selecting a PVI where you want to add a curve. Parameters can be specified numerically or
graphically.
For example, to numerically specify a pass-through point, enter the point coordinates. To graphically specify
the point, select a point in the drawing window.
To graphically specify a curve length, K value, or radius, use the cursor to pick two points on the screen the
correct distance apart. For parabolic and circular curves, you see a preview of the curve as you move the
cursor. For asymmetrical curves, you do not see the preview until you begin to specify the second length.
Fixed Vertical Curve (Three Points)
Adds a fixed curve through three specified points.
Fixed Vertical Curve (Two Points, Parameter)
Adds a fixed sag or crest curve, with a specified K value or minimum radius, through two specified points.
Fixed Vertical Curve (Entity End, Through Point)
Adds a fixed curve from the end of an existing entity to a specified pass-through point.
Fixed Vertical Curve (Two Points, Grade at Start Point)
Adds a fixed curve that is defined by two specified pass-through points and a specified grade at the start
point.
Fixed Vertical Curve (Two Points, Grade at End Point)
Adds a fixed curve that is defined by two specified pass-through points and a grade at the end point.
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Fixed Vertical Curve - Best Fit
Adds the most probable fixed vertical curve through a series of AutoCAD Civil 3D points, AutoCAD points,
existing entities, or clicks on screen.
Floating Vertical Curve (Parameter, Through Point)
Adds a floating curve, which is defined by either a K value or minimum radius, between an existing entity
and a specified pass-through point.
Floating Vertical Curve (Through Point, Grade)
Adds a floating curve, which is defined by a specified pass-though point and grade, to an existing entity.
Floating Vertical Curve - Best Fit
Adds the most probable floating vertical curve from an existing entity through a series of AutoCAD Civil
3D points, AutoCAD points, existing entities, or clicks on screen. Tangency is maintained to the attached
entity, regardless of how the entity is edited.
Free Vertical Curve (Parameter)
Adds a free curve, which is defined by a specified curve length, radius, or K value, between two entities.
Free Vertical Parabola (PVI Based)
Adds a free vertical parabola, which is defined by a specified curve length, pass-through point, or K value,
to an existing point of vertical intersection (PVI).
Free Asymmetrical Parabola (PVI Based)
Adds a free asymmetrical parabola, which is defined by specified before and after PVI curve lengths, to
an existing point of vertical intersection (PVI).
NOTE If the first length you specify is too large for the asymmetric curve, you cannot enter the length for the
second curve. The length of the first curve must be less than the station distance between the PVI you select
and the station value of the previous PVI (or end station of the previous curve).
Free Circular Curve (PVI Based)
Adds a free circular curve, which is defined by a specified radius or pass-through point, to an existing
point of vertical intersection (PVI).
Free Vertical Curve - Best Fit
Adds the most probable free vertical curve between two existing entities, and through a series of AutoCAD
Civil 3D points, AutoCAD points, existing entities, or clicks on screen. Tangency is maintained to the
attached entities, regardless of how the entities are edited.

Convert AutoCAD Line and Spline
This button enables you to convert an AutoCAD line or spline to a profile sub-entity.
Convert AutoCAD Line and Spline
Creates a fixed tangent or three-point vertical curve entity from an AutoCAD line or spline.

PVI Operations
These buttons control various operations with PVIs when the Profile Grid View dialog box is active. If the
profile is dynamic, only the Copy Profile button is available.
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Insert PVIs – Tabular
Creates points of vertical intersection (PVIs) at multiple locations simultaneously.
Raise/Lower PVIs
Changes the vertical position of a series of points of vertical intersection (PVIs) simultaneously.
Copy Profile
Copies all or a part of a layout profile or static surface profile.

Selection Operations
PVI Based
Edits the profile PVI parameter values in tabular format.
Entity Based
Edits the profile entity parameter values in tabular format.
Select PVI
Displays a selected PVI's parameter values in the Profile Layout Parameters dialog box. If you do not see
this button, click

to change to a PVI-based view.

Select Entity
Displays a selected profile subentity's parameter values in the Profile Layout Parameters dialog box. If you
do not see this button, click

to change to an entity-based view.

Delete Entities
This button enables you to delete a tangent or curve.
Delete Entity
Deletes a specified tangent or curve. If you do not see this button, click
view.

to change to an entity-based

Data Analysis
Edit Best Fit Data For All Entities
Toggles the display of a horizontal table of regression data for all entities in the profile that were created
by best fit.
Profile Layout Parameters
Toggles the display of a vertical table of numeric data about a single, selected profile subentity or PVI.
Profile Grid View
Toggles the display of a horizontal table of numeric data about multiple, selected profile sub-entities or
PVIs.
Undo
Reverses the last AutoCAD Civil 3D or AutoCAD command.
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Redo
Reverses the last AutoCAD Civil 3D or AutoCAD undo operation. Redo is limited to one operation.
Related procedures:
■

Understanding Profiles (page 1113)

■

Creating Profiles (page 1141)

■

Editing Layout Profiles (page 1191)

Profile Properties Dialog Box
Use this dialog box to view or change the properties of a profile, such as its name, style, and station data.
These properties apply to layout, surface, superimposed, curb return, and corridor profiles.
See also:
■

Profile Properties (page 1119)

Information Tab (Profile Properties Dialog Box)
Use this tab to view or change primary information about a profile.
Name
Specifies the name of the profile. The application generates a default value, or you can enter a name.
Description
Specifies an optional description of the profile.
Object Style
Specifies the name of the style used by the profile. Use the buttons to preview or edit the style.
Show Tooltips
Specifies whether tooltips are displayed for the object in the drawing (not over toolbar icons).

Profile Data Tab (Profile Properties Dialog Box)
Use this tab to view structural data about a profile.
Name
Specifies the name of the profile.
Description
Specifies an optional description for the profile.
Type
Specifies whether the profile is a surface profile
profile

, layout profile

, superimposed profile, or corridor

.

Data Source
For surface profile, displays the name of the surface represented in the profile. For superimposed profiles,
displays the name of the superimposed profile. For corridor profiles, specifies the name of the source
corridor. Not used for layout profiles or curb return profiles.
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Offset
Specifies the offset distance from the centerline of the parent horizontal alignment: either 0 for a centerline
profile, a positive number for a right offset, a negative number for a left offset. This value is set to 0 for
curb return profiles.
Update Mode
For surface profiles only. Specifies whether the profile updates automatically to reflect changes in surface
elevation.
■

Dynamic: The profile automatically updates to reflect changes in the surface elevation or the geometry
of the parent horizontal alignment.

■

Static: The profile shows surface elevations at the time of its creation. It does not update to reflect
changes that occur later.

Layer
Specifies the drawing layer on which the profile is placed.
Style
Specifies the style used by the profile.
Station Start/End
Specifies the first and last station numbers for the profile. The station numbers represent distances along
the parent horizontal alignment.
Elevation Minimum/Maximum
Specifies the highest and lowest elevation values that occur along the profile.
Alignment
Specifies the parent horizontal alignment for the profile.

Parent Horizontal Alignment
Name
Specifies the name of the horizontal alignment associated with this profile.
Stationing
Specifies the start and end station values for the horizontal alignment.

Design Criteria Tab (Profile Properties Dialog Box)
Use this tab to apply or change the profile design criteria.

Use Criteria-Based Design
Specifies whether to apply design criteria to the profile. If this check box is cleared, then the Use Design
Criteria File and Use Design Check Set options are not available.

Use Design Criteria File
Use Design Criteria File
Specifies whether to associate a design criteria file with the profile. If this check box is cleared, then the
design criteria file selector and Default Criteria table are not available.
For more information, see Profile Standards in the Design Criteria File (page 1140).
Design Criteria File Selector
Specifies the design criteria file to associate with the profile. The design criteria file that is applied to the
parent alignment is displayed by default. Click
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to select another design criteria file.

Default Criteria Table
Displays the profile standards formulas that are defined in the selected design criteria file. Click the Value
column to change a criteria table.

Use Design Check Set
Use Design Check Set
Specifies whether to associate a design check set with the profile. If this check box is cleared, then the
Design Check Set list is not available.
For more information, see Profile Design Check Sets (page 1141).
Design Check Set List
Displays the default design check set. You can either accept the default design check set, or use the list to
select a different one from the drawing.
Design Check Set Selection
Edits or copies the current design check set, or creates a design check set.

Offset Edge Profiles Tab (Profile Properties Dialog Box)
For curb return profiles only, this tab shows data about the other profiles attached to the curb return profile.

Incoming Edge Information
Incoming Alignment
Specifies the alignment to which the start of the curb return alignment is attached.
Incoming Profile
Specifies the profile to which the start of the curb return alignment is attached.
Incoming Profile Type
Specifies the profile type as either dynamic cross slope, with a numeric slope value, or static.

Outgoing Edge Information
Outgoing Alignment
Specifies the alignment to which the end of the curb return alignment is attached.
Outgoing Profile
Specifies the profile to which the end of the curb return alignment is attached.
Outgoing Profile Type
Specifies the profile type as either dynamic cross slope, with a numeric slope value, or static.

Offset Parameters Tab (Profile Properties Dialog Box)
This tab displays information for dynamic offset profiles that are created automatically during intersection
object creation.
Note that this tab is only available for offsets that are created using the Create Intersection wizard.

Parent Profile Details
Parent Profile
This read-only field displays the name of the profile for the parent alignment for this offset alignment.
Parent Alignment
This read-only field displays the name of the parent alignment for this offset alignment.
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Nominal Cross Slope
Specifies the nominal cross slope from the parent alignment and profile used to calculate the offset
alignment profile elevations.
Start/End Station
Specifies the start and end stations along the parent alignment to define the extents of the offset profile.

Profile Style Dialog Box
Use this dialog box to define profile styles that control the display and behavior of profiles.
See also:
■

Profile Styles (page 1122)

Information Tab (Profile Style Dialog Box)
Use this tab to change the style name and description and to review details such as when the style was most
recently modified.
For more information, see Information Tab (Style Dialog Box) (page 2017).

Design Tab (Profile Style Dialog Box)
Use this tab to set the representation of 3D curves.

3D Chain Visualization
Curve Tessellation Distance
Specifies the distance between elevation samples in the three-dimensional display of alignment data.
Enter a small number to see a smooth 3D curve, or a large number to see a rougher approximation.

Markers Tab (Profile Style Dialog Box)
Use this tab to specify the appearance of markers for locations on the profile.

Profile Points
Name
Displays the name of the point on the profile.
Marker Style
Specifies the style for the point marker on the profile. Click to open the Select Marker Style dialog box
where you can select a style or <None>.

Arrowhead
Type
Specifies the arrowhead style for the profile direction arrow. Select a style from the list or select User Arrow
to select an AutoCAD block.
Fit Options
Specifies how the arrow is drawn when the profile segment is shorter than the arrowhead. The arrow may
be reduced to a size 80 per cent of the segment length, not displayed, or displayed at its normal size. Select
Shrink, Omit, or Always Draw.
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Size Options
Specifies the method used to determine the size of the arrowhead:
Use Drawing Scale: Determines size of the arrowhead by multiplying the specified value by the drawing
scale. Enter the scale factor.
Use Fixed Scale: Activates the Fixed Scale options.
Use Size in Absolute Units: Specifies that the arrowhead size is an absolute value based on the displayed
units. Enter the value.
Use Size Relative to Screen: Specifies that the size of the arrowhead is a percentage of the drawing screen
size. Enter the percentage.
Size
Specifies the size of the arrowhead in the units specified in Size Options.
Fixed Scale
Specifies independent fixed scale values when Size Options is set to Use Fixed Scale. Enter values for X,
Y, and Z.

Display Tab (Profile Style Dialog Box)
Use this tab to set the visibility and format of profile components, such as lines, curves, and arrows.
Profile components include:
Line: Solved lines with true tangent lengths that are part of the profile geometry.
Circular Curve: Solved, circular curves that are true curve lengths within the profile.
Symmetrical Parabola: Solved, symmetrical parabola that are true curve lengths within the profile.
Asymmetrical Parabola: Solved, asymmetrical parabola that are true curve lengths within the profile.
Arrow: Shows the direction of the profile entities, either solved or unsolved.
Line Extensions: Line segments that extend beyond the solved portion of a line to a pass-through point or
another constraint.
Parabolic Curve Extensions: Parabolic curve segments that extend beyond the solved portion of a parabolic
curve to a pass-through point or another constraint.
Warning Symbol: Markers that identify entities that violate the rules specified in the design criteria file. This
component only applies to profiles that use design criteria.
For more information, see Display Tab (Style Dialog Box) (page 2017).

Summary Tab (Profile Style Dialog Box)
Use this tab to review and adjust settings for the profile style.
For more information, see Summary Tab (Style Dialog Box) (page 2020).

Profile View Properties Dialog Box
Use this dialog box to view or change the properties of a profile view, including annotation, projected objects,
and hatching.
See also:
■

Profile View Properties (page 1119)
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Information Tab (Profile View Properties Dialog Box)
Use this tab to view or change primary reference information about a profile view.
Name
Specifies the name of the profile view. Default value is PV - (n), where n is an integer that increments as
profile views are created in the drawing.
Description
Specifies an optional description of the profile view.
Object Style
Specifies the style used by the profile view. Click the down arrow to select a style by name. Use the buttons
to preview or edit the style.
NOTE If the profile view is split, this setting is ignored. Set split profile view styles on the Elevations tab (page
2428).
Show Tool tips
Controls whether tool tips are displayed for the object in the drawing (not over toolbar icons).

Stations Tab (Profile View Properties Dialog Box)
Use this tab to view and change the horizontal range of the profile view.

Alignment Name
Specifies the name of the alignment from which the profile view was created.

Station Range
Automatic
Specifies the first and last stations of the parent horizontal alignment.
User Specified Range
Specify a station range if you want the profile view to show less than the full length of the horizontal
alignment. Enter numeric station values or click
and pick points along the alignment in the drawing.
If you specify the station range, the profile view length remains constant. If the alignment length is
modified, the profile length does not adjust.

Elevations Tab (Profile View Properties Dialog Box)
Use this tab to view and change the vertical range and split settings of the profile view.
See The Profile View Object (page 1115) for more information about split profile views.

Elevation Range
Automatic Height
Specifies the elevation range for all profiles associated with the parent horizontal alignment, regardless
of whether they are drawn in the profile view. The system refers to these values to set the default elevation
range for the profile view.
User Specified Height
Specify an elevation range if you want the profile view to show other than the full height of the horizontal
alignment.
If the current profile view style includes a padding (buffer) setting, it is applied to expand the elevation
range. The padding is set on the Grid tab (page 2436) of the Profile View Style dialog box.
Selecting User-Specified Height enables the Split Profile View controls.
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Split Profile View
Selecting Split Profile View enables the Automatic and Manual controls.
Manual
Splits the profile view at user-specified locations and allows using a different style for each split segment.
No: Sequential number of split segments.
Split Station: Starting station value of each split location. The split station of segment number 1 is the
starting station of the profile view and is not editable. Enter a specific value or click to select a location
on the profile view.
Adjusted Datum: Vertical split location. Enter a specific value or click
view.

to select a location on the profile

Profile View Style: Style selection of each profile view segment.
Add a split location.
Delete a split location.
Automatic
Splits the profile view to fit it within the user-specified height, rounding to specified station and datum
locations.
Station Rounding: Specifies where to round the horizontal split location (Previous Major Grid, Previous
Minor Grid, or Exact Elevation)
Datum Rounding: Specifies where to round the vertical split location (Previous Major Grid, Previous Minor
Grid, or Exact Elevation)
NOTE Switching from manual to automatic clears all user-specified split settings.

Profiles Tab (Profile View Properties Dialog Box)
Use this tab to view and change properties of the individual profiles in a profile view. Change column widths
in the table to make it easier to see the contents of cells.
Name
Displays the name of the profile.
Draw
Specifies whether the profile is drawn in the profile view. After selecting or clearing check boxes here,
click Apply to see the changes.
Clip Grid
Specifies which profile controls the size of the profile view grid.
Split At
Specifies which profile to favor when splitting a profile view containing multiple profiles.
For example, a profile view often contains both existing ground and finished ground profiles. Selecting
Split At for the finished ground profile ensures that split occurs at the finished ground profile elevation.
Description
Specifies an optional description of the profile.
Type
Specifies whether the profile is a surface profile
profile

, layout profile

, superimposed profile

, or corridor

.
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Data Source
For surface profile, displays the name of the surface represented in the profile. For superimposed profiles,
displays the name of the superimposed profile. For corridor profiles, specifies the name of the source
corridor. Not used for layout profiles.
Offset
Displays the profile offset distance from the centerline of the parent horizontal alignment: either 0 for a
centerline profile, a positive number for a right offset, or a negative number for a left offset.
Update Mode
For surface profiles only. Specifies whether the profile is dynamic or static.
Dynamic: The profile automatically updates to reflect changes in the surface elevation or the geometry of
the parent horizontal alignment.
Static: The profile shows surface elevations at the time of its creation. It does not update to reflect changes
that occur later.
Layer
Specifies the drawing layer on which the profile is placed.
Style
Specifies the style used by the profile. Click to open the Pick Profile Style dialog box where you can select
a style.
Override Style
Specifies an override style for the display of the profile. This style is used only in the current profile view.
Any other profile view that is plotting the profile would use the style as specified by the Style column
value. Click the check box to open the Pick Profile Style dialog box where you can select a style.
Labels
Click to open the Profile Labels dialog box where you can edit the profile labels.
Station Start/End
Specifies the first and last station numbers for the profile. The station numbers represent distances along
the parent horizontal alignment.
Elevation Minimum/Maximum
Specifies the highest and lowest elevation values that occur along the profile.
Alignment
For superimposed profiles only. Specifies the horizontal alignment for the profile.

Bands Tab (Profile View Properties Dialog Box)
Use this tab to manage the data band sets for the profile view.
Band Type
Specifies which type of data band to add to the set: Profile Data, Vertical Geometry, Horizontal Geometry,
Superelevation, Sectional Data, or Pipe Data.
Select Band Style
Specifies a style for the band. Standard buttons are provided to create or edit a style. For more information,
see Select Style dialog box (page 2021).
Add >>
Adds the specified band type to the set for this profile view. Before clicking this button, ensure that the
settings are correct for data band type, style, and location.
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List of Bands
Location
Specifies either the top or bottom of the profile view. The table below this field shows current location of
the bands in the current band style set.
Band Type
Specifies the data band type: Profile Data, Vertical Geometry, Horizontal Geometry, Superelevation,
Sectional Data, or Pipe Data.
Style
Specifies the style for the band type.
Description
Specifies optional descriptive notes about the band type
Gap
Specifies the distance between the current data band and the adjacent profile view grid or data band.
Geometry Points
For Profile Data bands, specifies the alignment and profile geometry points to label in the data band. Click
to open the Geometry Points to Label in Band dialog box (page 2412).
Label Start Station
Specifies whether the starting station of the band is labeled.
Label End Station
Specifies whether the ending station of the band is labeled.
Alignment
Specifies either the parent alignment of current profile view or the parent alignment of any superimposed
profiles.
Profile1/Profile2
Specifies which profile or profiles supply the data for the band. For example, if two separate profiles are
listed in Profile 1 and Profile 2 columns, then each station displayed in the band shows the elevation
information for both profiles.
Data Source
Specifies the source of the data displayed in the band. The options displayed depend on the type of data
band:
Pipe Data Band: Select a pipe network in the drawing file.
Sectional Data Band: Select a sample line group that is associated with the alignment in the profile view
This column is available only for pipe and sectional data bands.
Material
Specifies a material or list of materials for which data is displayed in a sectional data band. The options
are generated using the properties of sample line groups that are associated with the alignment in the
profile view.
Weeding
Used only for labels at vertical geometry points on profile data bands. Vertical geometry points or grade
breaks that are closer than the weeding factor are removed, making it easier to read the remaining labels.
Enter a positive number to specify a label exclusion distance.
Stagger Labels
Specifies the location of the label staggering line: No staggering, Stagger both sides, Stagger to right, or
Stagger to left. This option is only enabled for profile or section data band styles.
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Stagger Line Height
Specifies the height of the label stagger line.
Band Position Controls
Changes the position of data bands in the set and deletes unwanted bands.
Move selected data bands up.
Move selected data bands down.
Delete selected bands.
Import Band Set
Opens the Band Set dialog box (page 2389). Select an existing band set to add to the band set for the current
profile view.
Save As Band Set
Opens the Band Set dialog box, where you can save the current band set for use with other profile views.
Match major/minor increments to vertical grid intervals
Specifies if the profile data band major/minor interval distances for profile views matches the profile view
style’s major/minor grid spacing intervals. Select the checkbox to match major/minor increments to
vertical grid intervals. If this checkbox is selected, the major/minor interval fields in the List of Bands
table are unavailable.
Related procedures:
■

Adding Data Bands to a Profile View (page 1215)

Hatch Tab (Profile View Properties Dialog Box)
Use this page to add hatch areas to show cut and fill regions in a profile view.

Add Areas to Hatch
Cut Area
Click to add hatching to the profile view in areas where terrain must be cut to create the design profile.
Fill Area
Click to add hatching to the profile view in areas where terrain must be filled to create the design profile.
Multiple Boundaries
Click to add hatching to the profile view in areas where multiple boundaries are used to define a hatch
region.
From Criteria
Click to add hatching to the profile view in areas where quantity takeoff criteria are used to define a hatch
region.

Hatch Table
Hatch Area
Specifies the upper and lower boundaries for each hatch area. Use the buttons along the top of the table
to manage these boundaries. Use the + and – buttons to expand and collapse the list of boundaries for
each hatch area heading.
Collapse All
Click to collapse the display of boundaries to show only the top-level headings.
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Expand All
Click to expand the display to show all boundaries.
Add Upper Boundary
Click to add an upper boundary to the selected hatch area.
Add Lower Boundary
Click to add a lower boundary to the selected hatch area.
Delete
Click to delete a selected boundary or an entire hatch area definition, depending on what is selected in
the table. Individual boundaries can be deleted only if the definition includes more than two.
Profile
Specifies the surface or layout profile that defines each hatch area boundary. Where only a single surface
and single layout profile exist in the profile view, the profiles are automatically assigned to boundaries.
Click the arrow beside the profile name to select a different profile.
Shape Style
Specifies the shape style applied to the hatch area. Click the name to select another style or modify the
style properties. These styles are found on the Toolspace Settings tab ➤ General ➤ Multipurpose Styles
➤ Shape Styles.
Related procedures:
■

Adding Hatch Areas to a Profile View (page 1216)

Projections Tab (Profile View Properties Dialog Box)
Selecting the Projection Properties command opens the Projections Tab of the Profile View Properties dialog
box.
Use this tab to edit the elevation or style of a projected object, or to remove or add projected objects.
If no objects are projected in the profile view, then this tab is not displayed in the dialog box.
Name
Specifies the names and categories of objects that are available for display in the current profile view.
Click to add or remove objects in the profile view.
Style
Specifies the display style of each projected object. Click a single entry to change it, or click <set all> for
a category to select a style for all objects in that category.
NOTE Multipurpose Projection Styles are used for AutoCAD objects. Each Projection Style includes settings for
all types of AutoCAD objects that can be projected. AutoCAD Civil 3D object styles control the appearance of
AutoCAD Civil 3D objects that are projected. Points use the point marker style. Feature lines use the feature line
style Profile and Section tab settings. Survey figures use the figure style Profile and Section tab settings. For
more information, see Editing the Style of a Projected Object (page 1220).
Elevation Options
Specifies whether the elevation of the projected object is determined by its elevation in plan view (Use
Object) or manually controlled in the profile view. Click a single entry to change it, or click <set all> for
a category to select an option for all objects in that category.
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Elevation Value
Specifies the actual elevation of the projected object. Click <set all> for a category to select an elevation
for all objects in that category.
Pick Objects
Click to select objects in the drawing and add them to the profile view.
Related procedures:
■

Adding Projected Objects to a Profile View (page 1219)

Pipe Networks Tab (Profile View Properties Dialog Box)
Use this tab to view and change properties of pipe network parts (pipes and structures) in a profile view.
You can change the column widths in the table to make it easier to see the contents of cells.
NOTE This tab is displayed only if there are one or more pipe networks in the drawing.
The properties table has the following columns:
Name
Displays the name of the pipe network and associated pipe and structure objects.
Draw
Specifies whether to display the pipe or structure in the profile view. Selected items are displayed in the
profile view.
NOTE Only checked items can have their Layer, Style, and Style Override modified.
Description
Displays an optional description of the pipe or structure.
Layer
Specifies the drawing layer on which the pipe or structure profile is placed. Click to display Layer Selection
dialog box from which you can modify the layer.
Style
Specifies the style used by the pipe or structure. Click to display the Pick Style For Pipe dialog box from
which you can modify the style.
Style Override
Specifies whether to override the style for the selected pipe or structure for this profile view. This style is
used only in the current profile view. Any other profile view that is plotting the pipe or structure would
use the style as specified by the Style column value. Click to select a style in the Pick Style For Pipe dialog
box.
Show Only Parts Drawn In The Profile View
Specifies whether to display only the pipes and structures that are selected to draw in the profile view.
Related procedures:
■

Displaying Pipe Networks in Profile Views (page 1364)

■

Profile View Properties (page 1119)
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Profile View Style Dialog Box
Use this dialog box to define profile view styles that control the format for titles, axis annotation, and other
elements of a profile view.
See also:
■

Profile View Styles (page 1124)

Information Tab (Profile View Style Dialog Box)
Use this tab to record basic information about the profile view style.
Name
Specifies the name of the profile view style.
Description
Specifies an optional description of the profile view style.
Created By
Displays the Windows login name of the person who created the profile view style.
Date Created
Displays the date and time the profile view style was created.
Last Modified By
Displays the Windows login name of the person who last modified the profile view style.
Date Modified
Displays the date and time the profile view style was last modified.

Graph Tab (Profile View Style Dialog Box)
Use this tab to set the vertical scale and direction of the profile view.

Vertical Scale
Use the controls in this area to specify how much to increase the elevation values for greater visibility in
the profile view. Specify the profile view vertical scale in either of the following ways:
■

By Vertical Exaggeration — Enter a value in the Vertical Exaggeration field. The Vertical Scale value is
calculated automatically.
The Current Horizontal Scale (HS) factor of the drawing is divided by the Vertical Scale value (VS) to
obtain the profile view Vertical Exaggeration value (VX).

For example, if the Current Horizontal Scale is 50, and you want the profile view Vertical Scale to be
1”=10’, then set the Vertical Exaggeration to 5.

■

By Vertical Scale — Select a scale from the Vertical Scale list. Alternatively, enter a custom value in the
Custom field. The Vertical Exaggeration value is calculated automatically.
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Vertical Scale
The profile view vertical scale. Select a vertical scale from the list, or enter a custom scale in the Custom
Scale field.
Vertical Scale (VS) = Current Horizontal Scale (HS) divided by Vertical Exaggeration (VX)

Custom Scale
Specifies the current Vertical Scale factor. Enter a value in this field to specify a scale factor that is not
provided in the Vertical Scale list.
Current Horizontal Scale
The overall drawing Scale specified in the Drawing Settings dialog box (page 2073). This field is not editable.
The horizontal scale must be changed in the Drawing Settings dialog box.
Vertical Exaggeration
Specifies by how much the elevation values increase in the profile view for greater visibility. Enter either
1 for no increase in scale or a larger number to increase the scale. The elevation values are multiplied by
this value, so a larger number increases the amount of exaggeration in the profile view.

Profile View Direction

Specifies the direction of the profile in the profile view grid:
■

Left To Right: The profile is drawn with 0 or the lowest station number on the left the highest station
number on the right.

■

Right To Left: The profile is drawn with the highest station number on the left and 0 or lowest station
number on the right.

Grid Tab (Profile View Style Dialog Box)
Use this tab to specify clipping, padding, and axis offset options on the profile view grid.

Grid Options

Clip Vertical Grid
Specifies that vertical grid lines are only drawn below the profile line. If Clip to Highest Profile is not
selected, the vertical lines are drawn only below the profile line that has Clip Grid selected on the Profiles
tab in the Profile View Properties dialog box (page 2429).
Clip to Highest Profile(s): Specifies that vertical profile view grid lines are drawn to the highest of all
displayed profiles.
Omit Grid in Padding Areas: Specifies that vertical profile view grid lines are not drawn in the padding
areas.
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Clip Horizontal Grid
Specifies that horizontal grid lines are only drawn below the profile line. If Clip to Highest Profile is not
selected, the horizontal lines are drawn only below the profile line that has Clip Grid selected on the
Profiles tab in the Profile View Properties dialog box (page 2429).
Clip to Highest Profile(s): Specifies that vertical profile view grid lines are drawn to the highest of all
displayed profiles.
Omit Grid in Padding Areas: Specifies that horizontal profile view grid lines are not drawn in the padding
areas.

Grid Padding

Grid Padding (Major Grids)
Specifies the distance (in major grid blocks) to add to the extents of the profile view in relation to the
profiles it contains.
Above Maximum Elevation
Specifies the number of grid blocks that the profile view extends above the maximum profile elevation.
A positive value enables the graph to be taller than the extents of the profile drawn in the profile view.
Below Datum
Specifies the number of grid blocks that the profile view extends below the datum or minimum profile
elevation. A positive value enables the graph to extend below the extents of the profile drawn in profile
view.
To Left
Specifies the number of major grids to place before the left-most station value of the alignment. A positive
value enables the graph to be wider than the extents of the profile drawn in the profile view.
To Right
Specifies the number of major grids to place after the right-most station value of the alignment. A positive
value enables the graph to be wider than the extents of the profile drawn in the profile view.
NOTE The To Left and To Right settings are not applied if the Station Range is set to User Specified. Set the Station
Range option in the Profile View Properties dialog box (page 2428).

Axis Offset
NOTE The axis offset distance is specified in plotted units, which is based on the Drawing Units and Scale settings.
Set the Drawing Units and Scale on the Units and Zone tab of the Drawing Settings dialog box (page 2073).

Axis Offset (Plotted Units)
Specifies the distance (in plotted units) to offset the profile view horizontal and vertical axes from the
grid extents (including padding). A positive value creates a blank area between the axis and the grid.
Above Maximum Elevation
Specifies the distance to offset the horizontal axis above the vertical extent.
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Below Datum
Specifies the distance to offset the horizontal axis below the vertical extent.
To Left
Specifies the distance to offset the horizontal axis to the left of the horizontal extent.
To Right
Specifies the distance to offset the horizontal axis to the right of the horizontal extent.

Title Annotation Tab (Profile View Style Dialog Box)
Use this tab to specify settings for the graph view and axis titles.

Graph View Title
Text Style
Specifies the text style for the profile view title.
Text Height
Specifies the current text height in drawing units.
Title Content
Specifies the text elements used to compose the title, such as horizontal alignment (HA) name and station
range. To change title format or content, click
2199).

to open the Text Component Editor dialog box (page

Title Position
These controls specify the position of the profile view title. Use Location and Justification settings for basic
positioning, then X and Y offsets for more precise placement, if necessary.
Location
Specifies the location of the title in relation to the profile view grid: either top, bottom, left, or right.
Justification
Specifies the justification (alignment) of the title. If Location is top or bottom, justification values are left,
right, or center. If Location is right or left, justification values are top, middle, or bottom.
X Offset
Specifies a horizontal offset from the position set by the Location and Justification values. Enter a positive
number to move the title right or a negative number to move it left.
Y Offset
Specifies a vertical offset from the position set by Location and Justification values. Enter a positive number
to move up the title or a negative number to move it down.
Border Around The Title
Specifies whether a border line is drawn around the title block.
Gap
Specifies the distance between the title and its border.

Axis Title Text
Separate titles can be displayed at each of the axes. Use the radio buttons around the graphic to select the
axis title to edit. Configure title settings and click Apply. Repeat that process with each axis title.
NOTE The Axis Title selections do not control axis title visibility. Visibility controls for all profile view components
are located on the Display tab (page 2442).
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Axis Title Text
Specifies which axis title is controlled by the text editing tools.
Title Text
Specifies the title text for the horizontal axis. To change the title content, click
Component Editor dialog box (page 2199).

to open the Text

Location
Specifies the location of the title on the axis: either Left, Center, or Right. For more precise control, use
the X and Y Offsets.
Text Style
Specifies a text style for use in the horizontal axis title.
Text Height
Specifies the title text height (in plotted units).
Rotation
Specifies the angle for the title. Enter a positive or negative value. The angle direction is always
counterclockwise. If the value is zero (0), the title is not rotated.
X Offset
Specifies a horizontal offset from the Location setting. Enter a positive number to move the title right or
a negative number to move it left.
Y Offset
Specifies a vertical offset from the Location setting. Enter a positive number to move up the title or a
negative number to move it down.

Horizontal Axes Tab (Profile View Style Dialog Box)
Use this tab to specify the settings for the tick marks on the horizontal axes of the profile view.

Select Axis to Control
Specifies the axis for which you adjust the Major and Minor Tick Details.
NOTE The bottom axis controls the major and minor grid spacing.
Top
Adjust Major and Minor Tick Details along the top axis.
Bottom
Adjust Major and Minor Tick Details along the bottom axis.
Tick and Label Start Station
Specifies whether ticks and labels are placed at the start station on the horizontal axes.

Major Tick Details
Interval
Specifies the spacing of major ticks on the horizontal axis, using the actual ground units.
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Tick Size
Specifies the height of the tick on the horizontal axis in plotted units.
Tick Justification
Specifies the position of the tick relative to the axis: top, bottom, or center.
Text Height
Specifies the height of text (in plotted units) used to label major ticks on the horizontal axis.
Tick Label Text
Specifies a label property for the tick. To change the text format or content, click
Component Editor dialog box (page 2199).

to display the Text

Text Style
Specifies the style of the tick label text.
Rotation
Specifies the angle for the tick label. Enter a positive or negative value. The angle direction is always
counterclockwise. If the value is zero (0), the label is not rotated.
X Offset
Specifies a horizontal offset for the tick label from the bottom of the tick.
Y Offset
Specifies a vertical offset for the tick label from the bottom of the tick.

Minor Tick Details
Interval
Specifies the spacing of minor ticks on the horizontal axis, using the actual ground units.
Tick Size
Specifies the height of the tick on the horizontal axis in plotted units.
Tick Justification
Specifies the position of the tick relative to the axis: top, bottom, or center.
Text Height
Specifies the height of text (in plotted units) used to label minor ticks on the horizontal axis.
Tick Label Text
Specifies a label property for the tick. To change the text format or content, click
Component Editor dialog box (page 2199).

to display the Text

Text Style
Specifies the style of the tick label text.
Rotation
Specifies the angle for the tick label. Enter a positive or negative value. The angle direction is always
counterclockwise. If the value is zero (0), the label is not rotated.
X Offset
Specifies a horizontal offset for the tick label from the bottom of the tick.
Y Offset
Specifies a vertical offset for the tick label from the bottom of the tick.
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Vertical Axes Tab (Profile View Style Dialog Box)
Use this tab to specify the settings for the tick marks on the vertical axes of the profile view.

Select Axis to Control
Specifies the axis to adjust the Major and Minor Tick Details.
NOTE The left axis controls the major and minor grid spacing.
Left
Adjust Major and Minor Tick Details along the left axis.
Right
Adjust Major and Minor Tick Details along the right axis.
Tick and Label Start Station
Specifies whether ticks and labels are placed at the start station on the vertical axes.

Major Tick Details
Interval
Specifies the spacing of major ticks on the horizontal axis, using the actual ground units.
Tick Size
Specifies the height of the tick on the horizontal axis in plotted units.
Tick Justification
Specifies the position of the tick relative to the axis being annotated: left, right, or center.
Text Height
Specifies the height of text (in plotted units) used to label major ticks on the vertical axis.
Tick Label Text
Specifies a property with which the tick is labeled. To change the text format or content, click
display the Text Component Editor dialog box (page 2199).

to

Text Style
Specifies the style of the tick label text.
Rotation
Specifies the angle for the tick label. Enter a positive or negative value. The angle direction is always
counterclockwise. If the value is zero (0), the label is not rotated.
X Offset
Specifies a horizontal offset for the tick label from the bottom of the tick.
Y Offset
Specifies a vertical offset for the tick label from the bottom of the tick.

Minor Tick Details
Interval
Specifies the spacing of minor ticks on the vertical axis, using the actual ground units.
Tick Size
Specifies the height of the tick on the vertical axis in plotted units.
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Tick Justification
Specifies the position of the tick relative to the axis being annotated: left, right, or center.
Text Height
Specifies the height of text (in plotted units) used to label minor ticks on the vertical axis.
Tick Label Text
Specifies a property with which the tick is labeled. To change the text format or content, click
display the Text Component Editor dialog box (page 2199).

to

Text Style
Specifies the style of the tick label text.
Rotation
Specifies the angle for the tick label. Enter a positive or negative value. The angle direction is always
counterclockwise. If the value is zero (0), the label is not rotated.
X Offset
Specifies a horizontal offset for the tick label from the bottom of the tick.
Y Offset
Specifies a vertical offset for the tick label from the bottom of the tick.

Display Tab (Profile View Style Dialog Box)
Use this tab to manage the display of profile view components in 2D and 3D.
For more information about the Component Display section of this tab, see Display Tab (Style Dialog Box)
(page 2017).

Summary Tab (Profile View Style Dialog Box)
Use this tab to review and adjust settings for the profile view style.
For more information, see Summary Tab (Style Dialog Box) (page 2020).

Project Objects to Profile View Dialog Box
Use this dialog box to specify objects in the current drawing to be projected into a profile view.
To highlight an object in the drawing, select its row in this table.
Name
Displays the objects that can be projected, divided into categories. Select the ones you want to project.
Style
Specifies the current style for each object. You can change the style used to project an object. Select <set
all> at the category level to change all objects in that category in one operation.
Elevation Options
Specifies how the elevation of each object is determined. Longitudinal objects, such as feature lines and
3D polylines, have multiple elevation values; their elevation options can differ from those for point objects.
■

Use Object: Elevation is read from the object properties.

■

Surface: The object is set to the elevation of a selected surface.

■

Manual: You can specify the elevation. This option cannot be used with longitudinal objects.
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■

Profile: The object is set to the elevation of a selected profile.

■

<set all>: Used at the category level to specify the elevation option for all projected objects in the
category.

Elevation Value
Specifies the elevation of each projected object. You can change the value here for point objects if the
elevation option is manual.
Label Style
Specifies the style of label applied to the projected object. Select <none> to display no label. Select <set
all> at the category level to set a label style for all projected objects in the category.
Pick Objects
Click to select objects in the drawing and add them to the profile view.
Related procedures:
■

Adding Projected Objects to a Profile View (page 1219)

Raise/Lower PVI Elevations Dialog Box
Use this dialog box to change the elevation of an entire profile either for layout profiles or static surface
profiles, or a range of stations.
In the Elevation Change field, enter either a positive number to raise the PVIs, or a negative number to lower
them. In the PVI Range area, choose one of the following options:
■

All: To raise or lower the entire profile

■

Station Range: To raise or lower a subset of PVIs, specified by start and end station values

Default values for the station range are the beginning and end of the profile. If a station equation is in effect,
use the station equation values to specify a range.
Related procedures:
■

Editing PVIs (page 1193)

Superimpose Profile Options Dialog Box
Use this dialog box to specify the station range of a superimposed profile and the accuracy of curve
approximation.
See also:
■

Creating a Superimposed Profile (page 1149)

Limits Tab (Superimpose Profile Options Dialog Box)
Use this tab to specify the start and end stations for a superimposed profile.
Specify the station range either by numeric entry or by clicking a station along the parent horizontal
alignment.
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NOTE If you want the superimposed profile’s station range to remain fixed, then select the Select Start and Select
End check boxes. Selecting these options prevents the superimposed profile from reacting to changes in the station
range of the source alignment. If the Select Start and Select End boxes are not selected, then the start and end
of the superimposed profile is locked to the start and end of the source alignment. If the start or end of the source
alignment is then changed, the superimposed profile updates dynamically.

Accuracy Tab (Superimpose Profile Options Dialog Box)
Use this tab to specify the accuracy of curves in the superimposed profile.
Specify the mid-ordinate distances used for approximating horizontal and vertical curves. A small value
results in the use of many short line segments to represent a curve. A large value results in longer segments
and a coarser curve, with a shorter drawing time.

Vertical Curve Settings Dialog Box
Use this dialog box to specify the type of curve to be placed between tangents in a profile.
Curves of the type defined here are used if you select the
Profile Layout Tools dialog box (page 2419).

Draw Tangents With Curves button on the

After you select which of the three vertical curve types to use, specify the related parameters for crest curves
and sag curves as follows:
■

Parabolic: Specify either curve length or K value.

■

Circular: Specify either curve length or radius.

■

Asymmetric: Specify separate lengths for the parabola in (Length1) and the parabola out (Length2).

Click OK to save the settings.
Related procedures:
■

Vertical Curve Design (page 1166)

■

Creating Layout Profiles (page 1143)

2444 | Chapter 70 Profiles Dialog Boxes

Project Management
Dialog Boxes

71

The following topics provide information about the Project Management dialog boxes.

Add Points To Project Dialog Box
Use this dialog box to create project points from drawing points by adding them to a project.
Point List
Lists the drawing points to be added to the project.
Comment
Specifies a comment to be associated with the point database for this operation. This comment can be
viewed in the Autodesk Vault tool by a system administrator.
Check In Options
Specifies additional actions to take after the project points are created.
■

Check In: Creates project points, and then relinquishes your control over the created points, making
them available for someone else to edit.

■

Check In And Keep Checked Out: Creates project points and then checks them out to you.

■

Check In And Protect: Creates project points and then protects them, preventing others from editing
them.

Related procedures:
■

Adding Points to a Project (page 189)

Add To Project Wizard
Use this wizard to add a drawing to a project.
This wizard leads you through the steps of adding a drawing to a project.
■

Select the project to which you will add a drawing.

■

Specify the location of the drawing within the project.
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■

Specify which dependent files will be added to the project, and whether DWF files will be created for
those files.

■

Specify which drawing objects will be shared across the project.

Related procedures:
■

Adding a Drawing to a Project (page 177)

Select Project Page (Add To Project Wizard)
Use this page to select the project to which you will add a drawing.
The available projects are listed. The active project is the default selection. If you want to select a different
project, click it in the list.
Click Next to move to the next page.
Related procedures:
■

Adding a Drawing to a Project (page 177)

Select Drawing Location Page (Add To Project Wizard)
Use this page to specify the location of the drawing within the project.
The selected project is shown, along with any existing subfolders.
Folder List
Click a subfolder to specify the location of the drawing. Optionally, click
the project under the currently selected folder.

to create a new folder within

Click Next to move to the next page.
Related procedures:
■

Adding a Drawing to a Project (page 177)

File Dependencies Page (Add To Project Wizard)
Use this page to review any dependent files to be added to the project along with the drawing, and to specify
the creation of DWF files.
DWF files display the drawing’s preview in Prospector and in the Autodesk Vault tool.
NOTE Previews from .dwf files are not displayed in the 64-bit versions of Vault and AutoCAD Civil 3D.
Keeps Files Checked Out
Specifies that the files will be added to the project, but the drawing will remain checked out to the working
folder, available for revisions. The file remains open in the current AutoCAD Civil 3D session.
Project Files
Specifies which files to add to the project. If you do not want to add a dependent file, clear its check box.
Create DWF
Specifies whether to create a DWF file.
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Enter Version Comments
Specifies an optional description of the file you are adding to the project.
Click Next to move to the next page.
Related procedures:
■

Adding a Drawing to a Project (page 177)

Share Data Page (Add To Project Wizard)
Use this page to specify which objects in the drawing to share across the project.
A shared object is available for use by others. It is listed in the project’s Prospector tree and can be referenced
by other project drawings.
NOTE You should only share objects that are required by others.
Object
Lists the objects in the drawing that can be shared with others. Select the objects that you want to share.
If you select an object collection such as Alignments, all objects in the collection are selected.
Status
Displays an error message if an object cannot be shared.
Description
Specifies an optional description of the shared object.
Click Finish to complete the process of adding the drawing to a project.
Related procedures:
■

Adding a Drawing to a Project (page 177)

Associate Project to Current Drawing Dialog Box
Use this dialog box to associate the currently open drawing with a data shortcuts project.
Working Folder
Specifies the working folder for the drawing.
Select Project
Selects the project with which to associate the current drawing. Set to None to remove an association.
Related procedures:
■

Associating a Drawing with a Data Shortcut Project (page 150)

Associate Project to Multiple Drawings Dialog Box
Use this dialog box to associate all the drawings in a folder with a data shortcuts project.
Working Folder
Specifies the working folder for the drawings.
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Select Project
Selects the project to associate with drawings. Set to None to remove an association for multiple drawings.
OK
Opens the Browse For Folder Dialog to select a folder containing drawings that are associated with the
selected project.
Related procedures:
■

Associating Multiple Drawings with a Data Shortcut Project (page 150)

Check In Drawing Wizard
This wizard leads you through the steps of checking a drawing in to a project.
■

Specify which dependent files will be checked in to the project, and whether DWF files will be created
for those files.

■

Specify which drawing objects will be shared across the project.

File Dependencies Page (Check In Drawing Wizard)
Use this page to choose the dependent files to be checked in to the project along with the drawing.
Keeps Files Checked Out
Specifies that the files will be checked in and the versions will be updated, but the drawing will remain
checked out to the working folder and available for revisions.
Project Files
Specifies which files will be checked in to the project. If you do not want to check in a dependent file,
clear its check box.
DWF Publishing Options
Specifies how to create a DWF file (used for drawing preview in Prospector and Vault Explorer) for the
drawing:
■

Create during check-in - creates a DWF file in the local AutoCAD Civil 3D session during check-in.

■

Send to Job Server - creates a DWF file on the server, which can improve check-in performance. Note
that this option is enabled only if Vault Collaboration is being used.

■

Do not create - no DWF preview file is created.

NOTE Previews from .dwf files are not displayed in the 64-bit versions of Vault and AutoCAD Civil 3D.
Enter Version Comments
Specifies an optional description of the files you are checking in to the project.
Click Next to move to the next dialog box.
Related procedures:
■

Checking a Drawing in to a Project (page 179)
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Share Data Page (Check In Drawing Wizard)
Use this page to review the set of objects in the drawing that will be shared, allowing others to reference
them in drawings.
If the drawing contains objects that have already been shared, they are not listed.
Object
Lists the objects in the drawing that can be shared with others. Select the objects that you want to share.
If you select an object collection such as Alignments, all objects in the collection are selected.
Status
Displays an error message if an object cannot be shared.
Description
Displays a description of the shared object, which you can change.
Click Finish to complete the process of checking in the drawing.
Related procedures:
■

Checking a Drawing in to a Project (page 179)

Check In Points Dialog Box
Use this dialog box to update project points with changes that you have made.
You must check the points in from the same drawing that you checked them out from.
Point list
Lists the project points to be checked in to the project.
Comment
Specifies a comment to be associated with the point database for this operation. This comment can be
viewed in the Autodesk Vault tool by a system administrator.
Check In Options
Specifies additional actions to be taken after the points are checked in.
■

Check In: Updates the project points, and then relinquishes your control over them, making them
available for someone else to edit.

■

Check In And Keep Checked Out: Updates the project points and keeps them checked out to you.

■

Check In And Protect: Updates the points and then protects them, preventing others from editing
them.

Related procedures:
■

Checking In Points (page 191)

Check Out Drawing Dialog Box
Use this dialog box to check out a project drawing.
Include File Dependencies
Specifies whether dependent files should be checked out with the project drawing.
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Get Latest Version
Specifies whether local copies of files are overwritten.
Selected: The latest versions in the project database are checked out, overwriting the related files in the
working folder.
Cleared: Files in the working folder are not overwritten, but the latest versions in the project database are
checked out. Use this option if you have made changes to the local files and you want to check them in
to the database as the latest project version.
IMPORTANT If you clear this check box with the intention of checking in files from the working folder, make
sure that no one else has revised the project versions of the files since you last checked them out. Such changes
would be lost when you check in your working version. If needed, a prior version can be restored by an
administrator using the Autodesk Vault tool.
File List
Specifies the files and the dependent files, if applicable, that you want to check out.
Enter Version Comments
Specifies an optional description of the file version you are checking out of the project.
Related procedures:
■

Checking a Drawing out from a Project (page 178)

■

Checking Out Project Object Source Drawings (page 185)

Check Out Points Dialog Box
Use this dialog box to check out project points to the active drawing.
Point List
Lists the project points to be checked out.
Related procedures:
■

Checking Out Points (page 190)

Create Alignment Reference Dialog Box
Use this dialog box to create a data reference to an alignment.
Source Alignment
Specifies the alignment from which to create the reference. Click to change the alignment or to display
all available alignments.
Site
Specifies a site for the alignment reference. Either select a site from the Site list or click
to select an
object in the drawing. The alignment and the object you select in the drawing are associated with the
same site.
NOTE Accepting the default <None> selection places the alignment in the top-level Alignments collection in
Prospector. See Alignment and Site Interaction (page 781) for more information.
Name
Specifies a system-generated name for the alignment reference. To edit the name, click
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.

Description
Specifies an optional description of the alignment reference.
Alignment Style
Displays the current style. Click the arrow to display the alignment styles in the drawing.
specifies
the style options. Create a new style, copy or edit the current style selection, or pick a style from drawing.
opens the Style Detail dialog box. Preview the style and creation information.
Alignment Layer
Displays the layer on which the alignment reference will be created. To change the layer click
select a layer.

and

Alignment Label Set
Lists the alignment label sets in the drawing. You can select a label set from the list. After you select the
label set, use the Selection icon to edit the current label set, copy the current label set, or create a new
label set. The Style Detail icon previews the current style.
Related procedures:
■

Creating an Alignment Reference (page 954)

Create Data Shortcuts
Use this dialog box to share objects from the current drawing.
Object Table
Select the objects that you want to reference in other drawings.
Hide Already Published Objects
Click to hide all objects in the table that are already shared.
Pick In Drawing
Click to select objects in the drawing rather than in the table.
Related procedures:
■

Creating Data Shortcuts (page 151)

Create Pipe Network Reference Dialog Box
Use this dialog box to create a data reference to a pipe network.
Source Pipe Network
Specifies the pipe network data shortcut from which to create the reference. Click to change the data
shortcut or display all available pipe network data shortcuts.
Network Name
Specifies a system-generated name for the pipe network reference. To edit the name, click

.

Network Description
Specifies an optional description of the pipe network reference.
Network Parts List
Specifies the parts list associated with this pipe network reference.
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Layers
Displays the layer on which the pipe network reference will be created. To change the layer click
select a layer.

and

Override Reference Surface
If you select this option, each referenced part references the surface specified here.
Override Reference Alignment
If you select this option, each referenced part references the alignment specified here.
NOTE If neither Override Reference option is selected, each part from the source drawing matches the same-named
object (surface or alignment) in the reference drawing. When specific parts reference surfaces or alignments that
cannot be found in the reference drawing, the following warning appears in event viewer: Reference <Object>
not found in reference drawing. In this case, these network parts are created with a value of <none> for the
missing reference object.
Include Source Labels
If you select this option, labels or label sets are copied with the reference object as they exist in the source
drawing and the label style options are grayed out. Otherwise, the label style options are active and the
label styles will be created when the referenced parts are added to the drawing.
NOTE Spanning pipe labels are created in the reference drawing matching their data from the source drawing.
They reference the same parts as were specified when the spanning label was created.
Structure Label Style and Pipe Label Style
These fields display the current styles for structure and pipe labels. Click the arrow to display the structure
and pipe label styles in the drawing.

specifies the style options. Create a new style, copy or edit the

current style selection, or pick a style from drawing.
style and creation information.

opens the Style Detail dialog box. Preview the

Related procedures:
■

Creating a Pipe Network Reference (page 1342)

Create Profile Reference Dialog Box
Use this dialog box to create a data reference to a profile.
Source Profile
Specifies the profile to reference. Click to change the profile or to display all available profiles.
Source Alignment
Displays the alignment data shortcut along which to create the profile data shortcut.
NOTE If the Source Alignment field is set to <None>, you must create an alignment reference before continuing
with the profile reference creation. See Creating an Alignment Reference (page 954).
Name
Specifies a system-generated name for the profile. To edit the default naming scheme, click

.

Description
Specifies an optional description of the profile.
Profile Style
Specifies the current style for the profile. Use the standard controls to edit the style or create a new one.
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Profile Layer
Displays the drawing layer on which the profile will be drawn. To change the layer, click

.

Profile Label Set
Specifies the name of the current profile label set. Use standard controls to review or change the set.
Related procedures:
■

Creating a Profile by Reference (page 1150)

Create Surface Reference Dialog Box
Use this dialog box to create a data reference to a surface.
Source Surface
Specifies the complete path to the surface in the project folder.
Surface Layer
Displays the layer on which the surface will be created.

Click to open the Object Layer dialog box where you can select a different layer for the surface.
The Properties Table section of the dialog box displays varying properties depending on the type of surface
selected.

Information
Name
Specifies the name of the surface.
NOTE To name the surface, click its default name and enter a new name, or click the Name Template button
and use the Name Template. For more information, see Name Template Dialog Box (page 2022).
Description
Specifies a description of the surface.
Style
Specifies the style for the surface. Click
you can select a different style.

to open the Select Surface Style (page 2017) dialog box where

Render Material
Specifies the render material (page 1762). Click

to select a render material.

Grid Parameters
This property group is displayed when a grid surface is selected.
Grid X Spacing
Specifies the X distance between the grid lines. When selected, you can click
in the drawing area.

to digitize the spacing

Grid Y Spacing
Specifies the Y distance between the grid lines. When selected, you can click
in the drawing area.

to digitize the spacing
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Orientation
Specifies the direction for the grid in the X and Y directions. When selected, you can click
points in the drawing to define the orientation direction.

to pick two

Volume Surfaces
Base Surface
Specifies the base surface from which the volume surface is generated. Enter the surface name or click
to open the Select Base Surface (page 2027) dialog box where you can select the surface from the list.
Comparison Surface
Specifies the comparison surface from which the volume surface is generated. Enter the surface name or
click
to open the Select Comparison Surface (page 2027) dialog box where you can select the surface
from the list.
Related procedures:
■

Creating a Surface Reference (page 656)

Create View Frame Group Reference Dialog Box
Use this dialog box to create a data reference to a view frame group.

View Frame Group
Source View Frame Group
Specifies the view frame group from which to create the reference. Click to change the group or to display
all available view frame groups.
Name
Specifies a system-generated name for the view frame group reference. To edit the name, click

.

Description
Specifies an optional description of the view frame group reference.

View Frame
View Frame Style
Displays the style used to display the view frames in this view frame group reference.
View Frame Label Style
Displays the style used to display labels on the view frames used in this view frame group reference. For
more information, see Understanding Labels (page 1646).
View Frame Layer
Displays the layer on which the view frames used in this view frame group reference will be created. To
change the layer click

and select a layer.

Match Line
Match Line Style
Displays the style used to display match lines and match line mask areas in this view frame group reference.
Match Line Left Label Style
Displays the style used for the labels that are on the left side of a match line in this view frame group
reference. For more information, see Understanding Labels (page 1646).
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Match Line Right Label Style
Displays the style used for the labels that are on the right side of a match line in this view frame group
reference. For more information, see Understanding Labels (page 1646).
Match Line Layer
Displays the layer on which the match lines used in this view frame group reference will be created. To
change the layer click

and select a layer.

Alignment
Specifies the alignment this view frame group reference is associated with.
Related procedures:
■

Creating a View Frame Group Reference (page 1917)

Databases Dialog Box
Use this dialog box to review the list of available databases on a specified Vault server and select the one to
log in to.
Related procedures:
■

Logging in to a Vault Server (page 169)

Delete Points From Project Dialog Box
Use this dialog box to delete points from a project.
You must check out a point before you can delete it.
Point list
Lists the project points to be deleted.
Related procedures:
■

Deleting Project Points (page 193)

Get Latest Version Dialog Box
Use this dialog box to get a read-only local copy of a project file.
Include File Dependencies
Specifies whether dependent files should be displayed when they exist.
File List
Lists the available files and related project files. Select the files and dependent files you want.
Related procedures:
■

Getting the Latest Version of a Drawing (page 180)

■

Getting the Latest Version of Project Objects (page 184)
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Get Points From Project Dialog Box
Use this dialog box to create a read-only local copy of project points in the active drawing.
Point list
Lists the project points to be copied into the active drawing.
Related procedures:
■

Copying Project Points into a Drawing (page 192)

Log In Dialog Box
Use this dialog box to log in to a Vault server and a Vault database.
User Name
Specifies the user name for logging in to the database. This name must be known to the Vault server.
Password
Specifies the password associated with the user name.
Server
Specifies the Vault server to log in to. The list shows all Vault servers that the user has accessed.
Database
Specifies the database on the Vault server to access. To see the list of available databases, click

.

Automatically Log In Next Session
Specifies whether the user is automatically logged in to the above-specified server and database when the
next AutoCAD Civil 3D session starts.
Related procedures:
■

Logging in to a Vault Server (page 169)

New Data Shortcut Folder
Use this dialog box to create a new folder for a project that uses data shortcuts.
Working Folder
Specifies the parent folder in which the project folder will be created. Default value is C:\Civil 3D Projects.
Name
Enter a name for the new project folder.
Description
Optionally enter a text description of the project.
Use Project Template
Select if you want to use a template (standard set of subfolders) for the new project. This option is
recommended.
Project Templates Folder
Displays the available project templates in the current folder. Default value is C:\Civil 3D Project Templates.
Click

to browse to a different template folder.

2456 | Chapter 71 Project Management Dialog Boxes

Project Template
Select the template you want to use for the new project. Default value is _Sample Project.
Related procedures:
■

Creating a New Shortcuts Folder (page 147)

New Folder Dialog Box
Use this dialog box to specify the name of a new folder you are creating within the project folder.
Enter a name and click OK to continue.

New Project Dialog Box
Use this dialog box to specify the name, description and template when creating a new Vault project.
Name
Specifies the project name.
Description
Specifies a description of the project.

Project Template
Use Project Template
Select if you want to use a template (standard set of subfolders) for the new project. This option is
recommended.
Project Templates Folder
Specifies the location for your project template. folder. Click

to browse to the folder.

Project Template
Specifies the name of the project template.
Created By
Displays the name of the user who created the project.
Date Created
Displays the date and time the project was created.
Related procedures:
■

Creating Projects (page 171)

Project Properties Dialog Box
Use this dialog box to review the properties of a Vault project.
Name
Specifies the project name.
Description
Specifies a description of the project.
Created By
Displays the name of the user who created the project.
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Date Created
Displays the date and time the project was created.
Related procedures:
■

Creating Projects (page 171)

Properties - Civil 3D Projects Dialog Box
Use this dialog box to review or change the Vault database or the working folder.
Vault Database
Specifies the database that you are logged in to.
Working Folder
Specifies the current location for your local copies of files. Click

to browse to another folder.

Project Templates Folder
Specifies the location for your project template folder. Click

to browse to the folder.

Current User Name
Displays the user name for the current session.
Related procedures:
■

Changing the Working Folder (page 170)

Protect Points Dialog Box
Use this dialog box to prevent others from editing project points.
Point list
Lists the project points to be protected.
Related procedures:
■

Protecting Project Points (page 192)

Reset Points To Checked In Dialog Box
Use this dialog box if you are a system administrator and need to reset checked-out points.
Point list
Lists the project points to be reset.
Related procedures:
■

Resetting Project Points Set by Others (page 195)

Select Projects To Display Dialog Box
Use this dialog box to select the projects to display in the Prospector tree and the Add to Project (page 2446)
dialog box.
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The dialog box contains a list of all the projects available in the Vault database you are logged in to. Project
names with a selected check box will be displayed in the Projects collection in the Master View of the
Prospector tree.
When an active project has been set, the name of the active project is not displayed in the list.

Selects all projects in the list.

Clears the selection of all projects in the list.

Selects multiple project names. Use Ctrl+click or Shift+click to select multiple project names, then click
this button to select their check boxes.

Clears multiple project names. Use Ctrl+click or Shift+click to select multiple project names, then click
this button to clear their check boxes.
Name
Lists all the projects available in the database. Click the column heading to sort the projects alphabetically
by name.
Description
Displays the description field for each project.
Related procedures:
■

Selecting Projects to Display (page 172)

Set Data Shortcuts Folder
Use this dialog box to select a different project folder as a source of data shortcuts.
Typically you select a different project folder when you want to associate the current drawing with that
project.
Folder List
Click a table row, then click OK to select the associated project folder. You can click the Name or Description
heading to sort the table entries alphabetically.
Folder Name
Displays the currently selected project folder.
Related procedures:
■

Setting the Data Shortcuts Folder (page 148)

Sync To Project Dialog Box
Use this dialog box to update out-of-date local copies of project objects and project points contained in a
drawing.
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Object
Lists the local objects in the drawing that are older than the latest project version. Select all objects that
you want to synchronize. If you select or clear an object collection, such as Alignments, the action affects
all objects in the collection.

Specifies that the object is a reference to a project object.

Specifies that the object is not synchronized with the project data.
Related procedures:
■

Synchronizing Drawing Data with Project Data (page 182)

Undo Check Out Dialog Box
Use this dialog box to reset a checked-out drawing and related files to a checked-in state.
This operation is useful if you decide to make no changes to a checked-out drawing, or if you make some
changes but do not want to update the master version of the file with the changes.
Include File Dependencies
Specifies whether related files are reset to a checked-in state.
File List
Lists the available files and related project files. Select the files and dependent files, if applicable, that you
want to reset to a checked-in state.
Version Comments
Displays any comment that was added when the drawing was checked out.
Related procedures:
■

Resetting a Checked out Drawing (page 181)

■

Resetting a Checked Out Source Drawing (page 186)

Undo Check Out Points Dialog Box
Use this dialog box to reset your checked-out points to a checked-in state.
Point list
Lists the project points to be checked in.
Related procedures:
■

Resetting Points You Checked Out (page 194)

Unprotect Points Dialog Box
Use this dialog box to allow others to edit protected project points.
Only the person who protected a project point can unprotect it.
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Point list
Lists the project points to be unprotected.
Related procedures:
■

Unprotecting Project Points (page 193)
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Reports Dialog Boxes

72

Use the following links to access information about the AutoCAD Civil 3D Reports dialog boxes.

Toolbox Editor Vista
Use this panorama vista to add custom reports or other custom tools to the Toolbox.
Expand Tree
Expands all categories.
Collapse Tree
Collapses all open categories.
Add Root Item
Inserts a new collection at the same level as the Reports Manager.
Tree Items
Right-click a tree item to display commands to add and remove categories and tools. For more information,
see To edit Toolbox content (page 1760).
Properties & Values
Specifies the values for categories in tools.
For example, if you are adding a new report, you need to specify the Report Type (VBA, COM, .NET, or
XSL), the file to use, and the macro to run.
You can optionally specify a help file and help topic to display.
Reload
Clears any changes you have made in the current session and reloads the data.
Save
Saves any changes you have made but keeps the window open for further edits.
Dismiss
Closes the Toolbox Editor vista.
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Related procedures:
■

Editing Toolbox Content (page 1760)

Edit Report Settings Dialog Box
Use this dialog box to edit report settings.
■

LandXML reports use the Report Settings (page 1757) for all settings, such as report header information,
units, precision, and so on.
TIP You can tell if a report is a LandXML-based report if the Export To XML Report dialog box is displayed
when you run the report.

■

.NET reports use a combination of Report Settings (page 1757) (for Client and Owner settings), but they
use the drawing Ambient Settings (page 84) for units, precision, and so on.

Expand Tree
Expands all categories in the dialog box.
Collapse Tree
Collapses all open categories in the dialog box.
Categories and Settings
Use the +/- boxes to display or hide the settings in the category. Use the Value column to specify a value
for a setting.
Related procedures:
■

Specifying Report Settings (page 1757)

Create Reports - PI Station Report
Use this dialog box to select the alignments and specify station ranges for the PI Station report.
This report lists tangent information for a range of alignment stations. No curve data is reported.

List of Alignments
Include
Specifies the alignments to include in the report. Select a check box to include the alignment.
Name & Description
Displays the name and description of the alignments in the drawing.
Station Start & Station End
Displays the start and end stations for a selected alignment
You can edit these values by highlighting an alignment in the list and adjusting the Report Settings (see
below).

Report Settings
Start Station & End Station
Displays the start and end stations for a highlighted alignment. Click an alignment name in the list to
highlight it.
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You can edit these values to change the range of stations included in the report. You can enter formatted
or unformatted values, such as 2+50.95 or 250.95.
Save Report To
Specifies the name and location of the resulting report.
Create Report
Generates the report and saves it to the specified location.
Done
Closes the dialog box and discards changes to station ranges.
Related procedures:
■

Generating a Report (page 1758)

■

Specifying Report Settings (page 1757)

Create Reports - Incremental Station Report
Use this dialog box to select the alignments and specify station ranges for the Incremental Station report.
This report lists northing, easting, and tangent information for a range of alignment stations, based on a
specified station increment.

List of Alignments
Include
Specifies the alignments to include in the report. Select a check box to include the alignment.
Name & Description
Displays the name and description of the alignments in the drawing.
Station Start & Station End
Displays the start and end stations for a selected alignment
You can edit these values by highlighting an alignment in the list and adjusting the Report Settings (see
below).

Report Settings
Start Station & End Station
Displays the start and end stations for a highlighted alignment. Click an alignment name in the list to
highlight it.
You can edit these values to change the range of stations included in the report. You can enter formatted
or unformatted values, such as 2+50.95 or 250.95.
Station Increment
Specifies the station increment to use. For example, specify 50 to report at increments of 50 feet or meters
along the alignment.
NOTE The increment is applied to all alignments. Station 0+00 is always included in the report. Odd stations
are not included if they do not match the station increment. For example, if the increment is 50, and the
alignment starts at station -10+00, the report will begin at station 0+00. However, if the alignment begins at
station -60+00, the report will begin at station -50+00.
Save Report To
Specifies the name and location of the resulting report.
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Create Report
Generates the report and saves it to the specified location.
Done
Closes the dialog box and discards changes to station ranges.
Related procedures:
■

Generating a Report (page 1758)

■

Specifying Report Settings (page 1757)

Create Reports - Stakeout Alignment Report
Use this dialog box to select the alignments and specify station ranges for an Alignment Stakeout report.
This report lists angle, distance, northing, and easting from the occupied point to each alignment station.

List of Alignments
Include
Specifies the alignments to include in the report. Select a check box to include the alignment.
Name & Description
Displays the name and description of the alignments in the drawing.
Station Start & Station End
Displays the start and end stations for a selected alignment
You can edit these values by highlighting an alignment in the list and adjusting the Report Settings (see
below).

Stakeout Options
Point Occupied
Specifies the point from which the angles to the alignment are calculated. You can enter a point number
or click

to select a point in the drawing.

Backsight Point
Specifies the backsight point. The backsight point and occupied point cannot be the same point.
Select Angle Type
Specifies the stakeout angle type to use.
■

Turned +: Turned angle right

■

Turned -: Turned angle left

■

Deflect +: Deflection angle right

■

Deflect -: Deflection angle left

■

Direction: Uses azimuths or bearings
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backsight point

occupied point

turned angle right

occupied point

backsight point

turned angle left

occupied point

backsight point

deflected angle right

occupied point

backsight point

deflected angle left

Report Settings
Start Station & End Station
Displays the start and end stations for a highlighted alignment. Click an alignment name in the list to
highlight it.
You can edit these values to change the range of stations included in the report. You can enter formatted
or unformatted values, such as 2+50.95 or 250.95.
Station Increment
Specifies the station increment to use. For example, specify 50 to report at increments of 50 feet or meters
along the alignment.
NOTE The increment is applied to all alignments. Station 0+00 is always included in the report. Odd stations
are not included if they do not match the station increment. For example, if the increment is 50, and the
alignment starts at station -10+00, the report will begin at station 0+00. However, if the alignment begins at
station -60+00, the report will begin at station -50+00.
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Offset
Specifies a distance from the alignment the stakeout report will use in calculations. Enter a negative
number to indicate a left offset.
Save Report To
Specifies the name and location of the resulting report.
Create Report
Generates the report and saves it to the specified location.
Done
Closes the dialog box and discards changes to station ranges.
Related procedures:
■

Generating a Report (page 1758)

■

Specifying Report Settings (page 1757)

Create Reports - Alignment Design Criteria Verification
Use this dialog box to compare alignment parameters with specified design criteria.
This report lists displays each entity’s parameters, and whether the entity clears or violates the specified
design criteria and design checks.
For more information, see Criteria-Based Alignment Design (page 935).

List of Alignments
Include
Specifies the alignments to include in the report. Select a check box to include the alignment.
Name & Description
Displays the name and description of the alignments in the drawing.
Station Start & Station End
Displays the start and end stations for a selected alignment.
You can edit these values by highlighting an alignment in the list and adjusting the Report Settings (see
below).

Report Settings
Start Station & End Station
Displays the start and end stations for a highlighted alignment. Click an alignment name in the list to
highlight it.
You can edit these values to change the range of stations included in the report. You can enter formatted
or unformatted values, such as 2+50.95 or 250.95.
Save Report To
Specifies the name and location of the resulting report.
Create Report
Generates the report and saves it to the specified location.
Done
Closes the dialog box and discards changes to station ranges.
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Related procedures:
■

Generating a Report (page 1758)

■

Specifying Report Settings (page 1757)

Create Reports - Profile Design Criteria Verification
Use this dialog box to compare profile parameters with specified design criteria.
This report lists displays each entity’s parameters, and whether the entity clears or violates the specified
design criteria and design checks.
For more information, see Criteria-Based Profile Design (page 1139).

List of Profiles
Include
Specifies the profiles to include in the report. Select a check box to include the profile.
Name & Description
Displays the name and description of the profiles in the drawing.
Station Start & Station End
Displays the start and end stations for a selected profile.
You can edit these values by highlighting a profile in the list and adjusting the Report Settings (see below).
Alignment
Displays the name of each profile’s parent alignment.

Report Settings
Start Station & End Station
Displays the start and end stations for a highlighted profile. Click a profile name in the list to highlight
it.
You can edit these values to change the range of stations included in the report. You can enter formatted
or unformatted values, such as 2+50.95 or 250.95.
Save Report To
Specifies the name and location of the resulting report.
Create Report
Generates the report and saves it to the specified location.
Done
Closes the dialog box and discards changes to station ranges.
Related procedures:
■

Generating a Report (page 1758)

■

Specifying Report Settings (page 1757)

Create Reports - PVI Station and Curve Report
Use this dialog box to select the profiles and specify station ranges for a profile PVI station and curve report.
This report lists station, elevation, and grade out for each PVI in a profile. Vertical curve information is
included for finished ground profiles.
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List of Profiles
Include
Specifies the profiles to include in the report. Select a check box to include the profile.
Name & Description
Displays the name and description of the profiles in the drawing.
Station Start & Station End
Displays the start and end stations for a selected profile.
You can edit these values by highlighting a profile in the list and adjusting the Report Settings (see below).
Alignment
Displays the horizontal alignment that the profile is associated with.

Report Settings
Start Station & End Station
Displays the start and end stations for a highlighted profile. Click a profile name in the list to highlight
it.
You can edit these values to change the range of stations included in the report. You can enter formatted
or unformatted values, such as 2+50.95 or 250.95.
Save Report To
Specifies the name and location of the resulting report.
Create Report
Generates the report and saves it to the specified location.
Related procedures:
■

Generating a Report (page 1758)

■

Specifying Report Settings (page 1757)

Create Reports - Profile Incremental Station Report
Use this dialog box to select the profiles and specify station ranges for a profile incremental station report.
This report lists PVI stations and elevations of the selected profile at regular intervals, at critical geometry
points, and crest and sag curve points.

List of Profiles
Include
Specifies the profiles to include in the report. Select a check box to include the profile.
Name & Description
Displays the name and description of the profiles in the drawing.
Station Start & Station End
Displays the start and end stations for a selected profile.
You can edit these values by highlighting a profile in the list and adjusting the Report Settings (see below).
Alignment
Displays the horizontal alignment that the profile is associated with.
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Report Settings
Start Station & End Station
Displays the start and end stations for a highlighted profile. Click a profile name in the list to highlight
it.
You can edit these values to change the range of stations included in the report. You can enter formatted
or unformatted values, such as 2+50.95 or 250.95.
Station Increment
Specifies the station increment to use. For example, specify 50 to report at increments of 50 feet or meters
along the profile.
NOTE The start and end stations are always included in the report. The increment starts at the beginning
station, even if it is an odd value. The increment is applied to all profiles.
Save Report To
Specifies the name and location of the resulting report.
Create Report
Generates the report and saves it to the specified location.
Done
Closes the dialog box and discards changes to station ranges.
Related procedures:
■

Generating a Report (page 1758)

■

Specifying Report Settings (page 1757)

Create Reports - Vertical Curve Report
Use this dialog box to select the profiles and specify station ranges for a profile vertical curve report.

List of Profiles
Include
Specifies the profiles to include in the report. Select a check box to include the profile.
Name & Description
Displays the name and description of the profiles in the drawing.
Station Start & Station End
Displays the start and end stations for a selected profile.
You can edit these values by highlighting a profile in the list and adjusting the Report Settings (see below).
Alignment
Displays the horizontal alignment that the profile is associated with.

Report Settings
Start Station & End Station
Displays the start and end stations for a highlighted profile. Click a profile name in the list to highlight
it.
You can edit these values to change the range of stations included in the report. You can enter formatted
or unformatted values, such as 2+50.95 or 250.95.
Save Report To
Specifies the name and location of the resulting report.
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Create Report
Generates the report and saves it to the specified location.
Done
Closes the dialog box and discards changes to station ranges.
Related procedures:
■

Generating a Report (page 1758)

■

Specifying Report Settings (page 1757)

Create Reports - Slope Stake Report
Use this dialog box to select the corridors and specify sample line groups for a cross section slope stake report.
This report identifies the points of slope change for a selected corridor link.

Select Report Components
Select Corridor
Specifies the corridors to include in the report. Only corridors that are based on alignments with defined
sample line groups are displayed.
Select a corridor from the list or click

to select a corridor from the drawing.

Select Alignment
Specifies the alignment to include in the report. Only the alignments contained in the selected corridor
are displayed.
Select Sample Line Group
Specifies the sample line group to include in the report. Only the sample line groups for the selected
alignment are displayed.
Select Corridor Link
Specifies which corridor link to use in the report. A link is defined as a single straight-line segment between
endpoints on a subassembly.
Add
Adds the selected corridor, alignment, and sample line group to the List of Corridors to include in the
report.

List of Corridors
Include
Lists the corridors to include in the report.
NOTE When a corridor is highlighted, the start and end stations are editable. See Report Settings below.
Alignment & Sample Line Group
Lists the alignment and sample line group that you selected.
Station Start & Station End
Displays the start and end stations for the selected sample line group.
You can edit these values using the Report Settings (see below).
Delete
Removes the corridor from the list.
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Report Settings
Start Station & End Station
Displays the start and end stations for a highlighted sample line group. Click a sample line group name
in the list to highlight it.
You can edit these values to change the range of stations included in the report. You can enter formatted
or unformatted values, such as 2+50.95 or 250.95.
Save Report To
Specifies the name and location of the resulting report.
Create Report
Generates the report and saves it to the specified location.
Done
Closes the dialog box and discards changes to station ranges.

Report Results
The slope stake report has data formatted in columns. The end columns contain information about the last
two offsets in the corridor. The other columns contain information about the point codes.
End Column Descriptions
■

Row 1: Reports either cut (C) or fill (F) which is determined by the elevational difference between the
last two offsets reported.

■

Row 2: Reports the distance difference between the last two offsets reported.

■

Row 3: Reports the slope value from the second-to-last offset point to the last offset point.

For example:
C 8.47
@33.87
S 1:4.00
Report Column Descriptions
■

Row 1: Reports the point code.

■

Row 2: Reports the offset value relative to 0+00.

■

Row 3: Reports the elevation value at that offset.

■

Row 4: Reports the slope from that point headed toward the next point (away from 0+00).

For example:
Daylight
-110.369
629.991
1:-4.00
NOTE For slope values greater than 2:1, the value is reported as 1:X. For slope values less than 2:1, the value
is reported as X%.
Related procedures:
■

Generating a Report (page 1758)

■

Specifying Report Settings (page 1757)
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Create Reports - Map Check Report
Use this dialog box to select the parcels or survey figures to include in a map check report. This report displays
the directions and distances, start and end coordinates, curve data, perimeter, and area, and calculates the
error of closure.

List of Objects
Parcels
Select this option to report on parcels in the drawing. When you select this option, the parcels in the
current drawing are listed in the table below.
Survey Figures
Select this option to report on survey figures.
NOTE The Survey database in the drawing must be open to report on figures.
Include
Select the individual parcels or figures to include in the report by selecting the check boxes. Use this
option to select an individual parcel to change the Point of Beginning (see below).
Select All
Selects all parcels or figures for the report.
Deselect All
Clears the current selection of parcels or figures.

Analysis
NOTE All options in the Analysis section are available for parcel reports only and are unavailable if you select the
Survey Figures option.
Point Of Beginning
If only one parcel is selected in the list above, its Point of Beginning X,Y values are displayed here. You
can click the icon to specify a different point of beginning to use in the report.
NOTE The Point of Beginning (POB) X,Y values are not displayed if more than one parcel is selected in the list
above. If you change the POB for one parcel, the change is not saved if you select another parcel in the list.
Changes are not saved to the parcel in the drawing.
Process Segment Order Counterclockwise
■

Selected: Segments are processed in counter-clockwise order.

■

Cleared: Segments are processed in clockwise order.

Enable Mapcheck Across Chord
■

Selected: The mapcheck traverse is calculated for curve segments using their chord length.

■

Cleared: The mapcheck traverse is calculated for curve segments using their curve length.

Truncate Area (Square Unit)
■

Selected: The area values output are limited to the specified number of decimal places in the Parcel
Area Precision settings without rounding. For example, if the area of a parcel is 43,559.989 square feet
and the Area precision is set to 2, then the value will be truncated to 43,559. 98 (it will not be rounded
up).

■

Cleared: The area values output are rounded based on the Parcel Area Rounding settings.
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Settings
Parcel Settings
Displays read-only settings for parcels, as specified in the Parcel settings (page 891).
Figure Settings
Displays read-only settings for survey figures, as specified in the Survey settings (page 247).

Report Settings
Save Report To
Specifies the name and location of the resulting report.
Related procedures:
■

Generating a Report (page 1758)

■

Specifying Report Settings (page 1757)

Create Reports - Parcel Volume Report
Use this dialog box to select the surface and parcels for a parcel volume report. This report calculates the
volume of an area bounded by the selected parcels and is based on an existing volume surface.

List of Parcels
Parcel
Specifies the parcels to use in the report. Select the check boxes next to the parcels to include.

Report Settings
Volume Surface
Specifies the volume surface to use in the report. For more information about creating a volume surface,
see Calculating Surface Volumes (page 740).
Fill Correction
Specifies a factor to accommodate for the contraction or shrinkage of the fill material.
NOTE For example, for a material that compacts to 93% of its original value when used as fill, enter 1.075
(which is derived by dividing 1.0 by .93) as the fill factor to compensate for the extra material that must be
added.
A factor of 1.00 applies no adjustment to the raw volume.
Cut Correction
Specifies the expansion or swell of the cut material. The volume of material generally expands after
removing it. Therefore, the cut factor is usually set to greater than 1, which indicates swell or expansion
of the material. For example, a 1.2 cut factor would mean that for every 1 cubic meter of material removed,
1.2 cubic meters of volume would need to be accounted for transport.
Elevation Tolerance
Specifies the difference in elevation that must exist between the two surfaces of the volume surface in
order for the volume to be included in the report. The surfaces are compared at each grid node. If the
difference in elevation is less than the tolerance value, then it is considered to be zero volume.
NOTE This control is available only if the selected Volume Surface is a grid surface.
Save Report To
Specifies the name, file type, and location of the resulting report. Click the folder icon to specify a file
type and location.
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Create Report
Generates the report and saves it to the specified location.
Done
Closes the dialog box.
Related procedures:
■

Generating a Report (page 1758)

■

Specifying Report Settings (page 1757)

Create Reports - Station Offset to Points Report
Use this dialog box to select the points and alignment to use for creating a station offset to points report.
This report lists the station and offset of the points relative to the selected alignment.

List of Points
Select All
Selects all the points in the drawing. When a point is selected the Include box is checked.
Deselect All
Deselects all the points in the drawing.
Include
When selected, includes the point in the report.

Report Settings
Select Alignment
Specifies the alignment to include in the report. Select an alignment from the list or click
alignment from the drawing.

to select an

Save Report To
Specifies the name and location of the resulting report.
Create Report
Generates the report and saves it to the specified location.
Done
Closes the dialog box and discards changes to station ranges.
Related procedures:
■

Generating a Report (page 1758)

■

Specifying Report Settings (page 1757)

Create Reports - LandXML Reports
Double-click a LandXML report to launch the Export To LandXML dialog box (page 2219) and then select the
data to include in the report.
Each report type filters out irrelevant data when the report is created. If you are creating a points report, for
example, only the points that are selected are used in the report. You can clear the selection of other objects
in the Export To LandXML dialog box, but that is not necessary.

2476 | Chapter 72 Reports Dialog Boxes

Related procedures:
■

Generating a Report (page 1758)

■

Specifying Report Settings (page 1757)

Create Reports - Feature Line Reports
Use this dialog box to select a corridor, an alignment, and the feature lines to include in a corridor feature
line report. This report displays northing, easting, and elevation coordinates at the specified station interval
for the feature lines. It also includes the coordinates of the roadway crown at those stations.
Select Corridor
Specifies the corridor to use in the report.
Select Alignment
Specifies the alignment to use in the report.
Sample Line Group
Specifies the sample line group to include in the report. This list is not available if Corridor Points is
selected.
Type selector
■

Corridor Points: Reports northing, easting, and elevation coordinates at the specified station interval
for the selected feature lines and at the roadway crown.

■

Corridor Links: Reports offset, elevations and point code information at each grade break of the selected
links.

■

Surfaces: Reports a series of data for each station for the selected surface sections.

List of Feature Lines/List of Corridor Links/List of Surfaces
This list changes depending on whether you choose to report the data based on Corridor Points, Corridor
Links, or Surfaces. Select individual items, or use the buttons on the right to select all items in the list or
to clear the entire selection.
Start Station
Specifies the start station for the report. This station is used for all selected items.
End Station
Specifies the end station for the report. This station is used for all selected items.
Station Interval
Specifies the station interval to use.
Save Report To
Specifies the location and file type for the report. Click the button and specify the folder and file type.
Create Report
Creates the report in the location specified and displays the report results.
When you click Create Report, you may be prompted to add stations to the corridor if the station interval
you specified is different than the existing corridor sampling. If you click OK, the command applies the
Station Interval setting to the corridor, which can result in increasing the frequency that data is reported.
If you click Cancel, only the stations that are common based on the specified interval and the assembly
insertion locations are presented in the report.
Increasing the frequency that data is reported is similar to using the Frequency To Apply Assemblies dialog
box to add more stations to the corridor. For more information, see To add stations to a region using the
Corridor Properties dialog box (page 1491).
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Additional station interval lines are added to the corridor in the drawing when you increase the frequency.
You can control the display properties of these lines by changing the Link Style on the Codes tab of the
Corridor Properties dialog box. For more information, see Codes Tab (Corridor Properties Dialog Box)
(page 2037).
Related procedures:
■

Generating a Report (page 1758)

■

Specifying Report Settings (page 1757)

Create Reports - Lane Slope Report
Use this dialog box to select a sample line group to include in a lane slope report. This report displays the
station values for the sample lines associated with the selected corridor and the X,Y coordinates of the sample
line at the intersection of the alignment. The report also displays the elevation values of the existing ground
and finished ground profiles at those X,Y points and the left and right slopes of the lanes defined between
the alignment and the edge of pavement.
List of Sample Line Groups
Specifies the sample line group to include in the report.
Start Station
Specifies the start station for the report. The Start Station and End Station fields are enabled only if one
of the sample line groups is selected in the list.
End Station
Specifies the end station for the report. The Start Station and End Station fields are enabled only if one
of the sample line groups is selected in the list.
Save Report To
Specifies the location and file type for the report. Click the button and specify the folder and file type.
Create Report
Creates the report in the location specified and displays the report results.
Related procedures:
■

Generating a Report (page 1758)

■

Specifying Report Settings (page 1757)

Create Reports - Daylight Line Report
Use this dialog box to select a sample line group to include in a daylight line report. This report includes
the X,Y, and elevation data for the daylight points at the ends of the sample lines. The report also includes
the widths of the sample lines to the left and right of the alignment.
List of Sample Line Groups
Specifies the sample line group to include in the report.
Start Station
Specifies the start station for the report. The Start Station and End Station fields are enabled only if one
of the sample line groups is selected in the list.
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End Station
Specifies the end station for the report. The Start Station and End Station fields are enabled only if one
of the sample line groups is selected in the list.
Save Report To
Specifies the location and file type for the report. Click the button and specify the folder and file type.
Create Report
Creates the report in the location specified and displays the report results.
Related procedures:
■

Generating a Report (page 1758)

■

Specifying Report Settings (page 1757)

Create Reports - Incremental Station Elevation Difference Report
Use this dialog box to select a profile to include in an incremental station elevation difference report. This
report compares an existing ground profile with a design profile and lists the station, existing ground
elevation, design elevation, and the elevational differences between PVIs.
List of Design Profiles
Specifies the design (layout) profile. You must select one. Only dynamic profiles are included in the list.
When you click on the design profile, the Start Station and End Station fields become active so you can
specify the station range for the report.
List of Existing Profiles
Specifies the existing ground profile. You must select one.
Start Station
Specifies the start station for the report. The Start Station and End Station fields are enabled only if one
of the design profiles is selected in the list.
End Station
Specifies the end station for the report. The Start Station and End Station fields are enabled only if one
of the design profiles is selected in the list.
Station Interval
Specifies the station interval to use when the Regular Interval option is selected.
Regular Interval
Specifies that regular station intervals are included in the report. The interval is based on the Station
Interval setting.
Horizontal Tangent Points
Specifies that tangent points in the horizontal alignment design are included in the report. For example,
PT or PC points.
Vertical Tangent Points
Specifies that tangent points in the vertical profile design are included in the report. For example, the
start vertical tangent point.
Existing Ground Points
Specifies that existing ground grade break points are included in the report.
Save Report To
Specifies the location and file type for the report. Click the button and specify the folder and file type.
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Create Report
Creates the report in the location specified and displays the report results.
Related procedures:
■

Generating a Report (page 1758)

■

Specifying Report Settings (page 1757)

Create Reports - Milling Report
Use this dialog box to generate a report that identifies the milling areas and offset details of a specified
corridor.
The corridor from which this report is generated must have been created using one of the milling
subassemblies. AutoCAD Civil 3D scans the corridor for stations at which milling occurs, the width of milling
across the corridor, and the milling area, which is the area below the existing ground surface and above the
subassembly overlay.

The milling report identifies the begin and end stations where milling occurs; left and right offsets from the
centerline at the begin and end stations; and the area that is calculated from the previous data.

Select Report Components
Select Corridor
Specifies the corridor on which to generate the report.
Select Baseline
Specifies the corridor baseline on which to generate the report. The corridor assembly that is applied to
this baseline must contain a milling subassembly.

Milling Tolerance
Width
Specifies the difference in width that must exist between the left and right offsets from one station to the
next in order for the milling area to be included in the current station range in the report.
The area between successive sample lines and the left and right offsets is used in the milling area calculation.
If the difference in width between the offsets is less than the tolerance value, then the area is not included
in the report.
Thickness
Specifies the difference in thickness that must exist between successive sample lines in order for the milling
area to be included in the report.

Report Settings
Start Station & End Station
Displays the start and end stations for the specified baseline.
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You can edit these values to change the range of stations included in the report. You can enter formatted
or unformatted values, such as 2+50.95 or 250.95.
Save Report To
Specifies the name and location of the resulting report. Click

and specify the folder and file type.

Create Report
Generates the report and saves it to the specified location.
Done
Closes the dialog box and discards changes to station ranges.
Related procedures:
■

Generating a Report (page 1758)

■

Specifying Report Settings (page 1757)
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Sections Dialog Boxes

73

The following topics provide information about the Sample Line, Section, and Section View dialog boxes.

Corridor Section Properties Dialog Box
Use this dialog box to edit properties of the selected corridor section, such as its name, section data, and
code set styles.
See also:
■

Editing Corridor Section Properties (page 1256)

Information Tab (Corridor Section Properties Dialog Box)
Use this tab to edit primary information about the selected corridor section.
Name
Specifies the name of the corridor section. The default format is <SLG>-n - <SL>-n - <corridor>(n).
<SLG> is the parent sample line group name, <SL> is the sample line name, and <corridor> is the name
of the corridor on which the corridor section is drawn.
n is an integer greater than or equal to one, which increments as each feature is created in the drawing.
Description
Specifies the optional description of the corridor section.
Object Style
Specifies the name of the style used by the corridor section.
NOTE Corridor section object styles are the same as code set styles.

Creates, copies, or edits a style using the Code Set Style dialog box (page 1999). Click the down arrow to
display the style selection menu:
■

Create New: Creates a new style.

■

Copy Current Selection: Copies the current style.

■

Edit Current Selection: Edits the current style.
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Displays details about an existing style. Select the style by name in the list. Click to open the Style Detail
dialog box (page 2020). Preview the style and creation information.
Show Tooltips
Controls whether tooltips are displayed for the object in the drawing (not over toolbar icons).
Related procedures:
■

Editing Corridor Section Properties (page 1256)

Section Data Tab (Corridor Section Properties Dialog Box)
Use this tab to edit properties of the selected corridor section object.
Description
Specifies the optional description of the current corridor section.
Type
Displays a

, which indicates that the section was extracted from a corridor.

Data Source
Displays the name of the data source from which the current corridor section was sampled.
Update Mode
Specifies the type of update mode for the corridor section. Select Dynamic to specify that the corridor
section data updates dynamically if the position of the sample line associated with the corridor section
changes or the data source (surface or corridor) geometry changes.
Layer
Specifies the drawing layer that contains the current corridor section associated with the selected sample
line group. Click in the Layer column to open the Layer Selection dialog box (page 2222). Select a layer in
the Layers table.
Style
Specifies the name of the style of the corridor section. Click in this column to open the Select Style dialog
box (page 2021). Select a style in the list or use the standard controls to create a new style, copy or edit the
current style selection.
Station
Displays the station value of the sample line along which the corridor section is sampled.
Left Offset
Displays the left offset value of the current section.
Right Offset
Displays the right offset value of the current section.
Minimum Elevation
Displays the minimum elevation of the section associated with the selected sample line group.
Maximum Elevation
Displays the maximum elevation of the section associated with the selected sample line group.
Related procedures:
■

Editing Corridor Section Properties (page 1256)
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Codes Tab (Corridor Section Properties Dialog Box)
Use this tab to display codes and code set style information of the selected corridor section object.
NOTE The codes displayed in this tab are as collected from the current corridor section’s subassemblies. The
Description, Style, and Label Style are as assigned through the associated code set style. To change the display or
label styles for any of the codes, edit the object style associated with the current corridor section in the Information
tab (page 2483).
Use code set styles to control the visual appearance of a set of codes (link, point, and shape codes) associated
with a current corridor section.
Name
Displays an expandable tree with a collection for each type of code: Link, Point, and Shape. Expand the
collections to display the individual codes.
Description
Displays the description of each code.
Style
Displays the style assigned to each code.
Label Style
Displays the label style assigned to each code or <none> if no label style is assigned.
Render Material
Displays the render material assigned to each code or <none> if no render material is assigned.
Material Area Fill Style
Displays the Material Area Fill style assigned to each code or <none> if no fill style is assigned.
Pay Item
Displays the ID of any pay item attached to any Link or Point.
Related procedures:
■

Editing Corridor Section Properties (page 1256)

Create/Edit Sample Line Group Dialog Box
Use this dialog box to create and edit a sample line group.
NOTE Sample lines must be part of one, and only one, sample line group. If a sample line group already exists,
the dialog box changes from create mode to edit mode.
Name
Specifies the name of the sample line group. The default format is <SLG>-<[Next Counter]>.
<SLG> is the sample line group name.
<[Next Counter]> is an integer greater than or equal to one, which increments as sample line groups are
created in the drawing. This naming convention is based on the name template.
Enter a name or edit a default naming convention in the Name Template dialog box.

Opens the Name Template dialog box (page 2022). Edit the default sample line group naming convention.
Description
Specifies the optional description of the sample line group.
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Alignment
Displays the parent alignment under which the sample line group belongs.
Sample Line Style
Specifies the sample line style. To edit a style or create a new one, click
. Select a style from the list of
operations. For more information, see Select Style dialog box (page 2021) and Section Data Band Style dialog
box (page 2528).
To examine the details of an existing style, select the style name in the list. Click
For more information, see the Style Detail dialog box (page 2020).

.

Sample Line Label Style
Specifies the sample line label style. Standard buttons are also provided to create or edit a label style.
Sample Line Layer
Specifies the drawing layer for the sample line. Standard buttons are also provided to review or change
the style.

Select Data Sources To Sample
Type
Displays the type of data source from which the section is sampled such as
surface;
, which indicates a corridor;
a pipe network.

, which indicates a TIN

, which indicates a corridor surface; or

which indicates

Data Source
Displays the name of the data source.
Sample
Specifies a data source from which to sample elevations. A new section object is created for each data
source selected. The section object is located at each sample line in the current sample line group.
Style
Specifies the style to apply for each section. Select a style in the list or use the standard controls to create
a new style, copy or edit the current style selection, or pick a style from the drawing.
NOTE If the data source is a corridor, then the style list is for a code set style.
Section Layer
Specifies the drawing layer for the section. Standard buttons are also provided to review or change the
style.
Update Mode
Specifies the type of update mode for the section. Select Dynamic to specify that the section data updates
dynamically if the position of the sample line associated with the section changes or the data source
(surface or corridor) geometry changes.
Related procedures:
■

Creating Sample Lines (page 1246)

Create Multiple Section Views Wizard
Use this wizard to create multiple section views.
The multiple section views are created from existing sections, which represent sectional data at the stations
along the alignment. You can also display data bands above or below each of the multiple section views.
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After configuring the settings in this wizard, click Create Section Views. Specify the location of the lower
left corner of the multiple section views grid.
NOTE Some controls on this wizard are not available when requisite objects are not present. For example, the
Section View Tables page of this wizard is not available if there is no materials list for the drawing. For information
about how to create a material list, see Generating Material Lists (page 1282).
Related procedures:
■

To create multiple section views (page 1259)

General Page (Create Multiple Section Views Wizard)
Use this page to specify basic information about the section views, including the parent alignment and
sample line group name, range of stations, description, style, and layer.
Select Alignment
Specifies the name of the parent horizontal alignment. Select a name from the list or click
alignment from the drawing.

to pick an

Sample Line Group Name
Specifies the sample line group from which the section views are created. Select a sample line group from
the list or click

to pick a sample line group from the drawing.

Automatic
Specifies that the offset range is set automatically. The start and end stations of the specified sample line
group are displayed in the fields next to the selection.
User Specified
Specifies that the station range is set by the user. Specify start and end stations for the multiple station
views in the fields next to the selection.
Section View Name
Specifies an editable, system-generated name. The name must remain unique within the drawing.
Description
Specifies an optional description of the section views.
Section View Layer
Specifies the drawing layer for the section views. To review or change layer data, click

.

Section View Style
Specifies the style of the section views. Use standard buttons to review or change the style.
Related procedures:
■

To create multiple section views (page 1259)

Section Placement Page (Create Multiple Section Views Wizard)
Use this page to control the placement of the sections in model space. Select a drawing template if you
intend to use the sections for final production drawings.
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Placement Options
Production
Specifies a drawing template to use for creating production-ready section sheets. Use this option if you
intend to use the Create Section Sheets (page 1934) command to generate paper space layouts that contain
section views.
NOTE The drawing template you select must have a viewport defined as “Section” type. For more information,
see Setting Up Drawing Templates for Plan Production (page 1902).
Draft
Specifies that section views will be created in a grid in model space without using a template. Use this
option during draft stages. A section view group created with this option cannot be used with the Create
Section Sheets command.
NOTE If you use the Draft option, and later you intend to create sheets using the Create Section Sheets
command, you must re-run the Create Multiple Views command using the Production option.
Group Plot Style
Specifies the group plot style for the section views. The group plot style controls how the sections are
displayed in Model Space and on the sheet. Use standard buttons to review or change the style. For more
information, see Group Plot Style Dialog Box (page 2508).
Related procedures:
■

To create multiple section views (page 1259)

Offset Range Page (Create Multiple Section Views Wizard)
Use this page to specify the offset range to which the section views are drawn.
Automatic
Specifies that the offset range is set automatically. The lengths of the left and right swath widths are
displayed in the fields next to the selection.
User Specified
Specifies that the offset range is set by the user. Specify the length of the left and right swath widths in
the fields next to the selection.
Left
Specifies the offset length of the left swath width.
Right
Specifies the offset length of the right swath width.
Related procedures:
■

To create multiple section views (page 1259)

Elevation Range Page (Create Multiple Section Views Wizard)
Use this page to specify the elevation properties of the selected section view.
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Elevation Range
Automatic
Specifies that the elevation range is set automatically. The minimum and maximum heights are displayed
in the fields next to the selection.
User Specified
Specifies that the elevation range is set by the user. Specify how the elevation is applied by selecting a
Section Views Height Option.
Height
Specifies the height of the elevation.

Section Views Height Option
From Lowest Elevations Of All Sections
Specifies that the elevation is set from the lowest elevation of each section.
From Mean Elevations Of All Sections
Specifies that the elevation is set from the mean elevation of each section.
Follow A Section
Specifies that the elevation is set from a particular section. Select the section from the Select Section list.
Related procedures:
■

To create multiple section views (page 1259)

Section Display Options Page (Create Multiple Section Views Wizard)
Use this page to specify section display options.

Select Sections To Draw
Name
Displays the names of the sections.
Draw
Specifies whether the sections are drawn in the section views. Select the check box to draw the sections
in the section views.
Clip Grid
Specifies whether the grid lines in the current section views are clipped to the sections (horizontal and/or
vertical depending on the section view style definition). Select the radio button to clip the grid lines in
the section views to one of the named sections.
Change Labels
Specifies the style set from which the section labels will be drawn. Click in this column to open the Select
Style dialog box (page 2021).
Style
Specifies the section style. Click in this column to open the Select Section Style dialog box.
Override Style
Specifies the style for the sections. Select the check box to open the Select Section Style dialog box.
Related procedures:
■

To create multiple section views (page 1259)
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Data Bands Page (Create Multiple Section Views Wizard)
Use this page to specify the properties of the data bands associated with the section view.
Select Band Set
Specifies the set of band styles for the section views. Provides standard controls that you use to review or
change the set.

List of Bands
Location
Specifies either the top or bottom of the section views. The table below this field shows the current location
of the bands in the current band style set.
Band Type
Specifies the data band type, either Section Data or Section Segment.
Style
Specifies the style for the band type.
Surface 1
Specifies a surface sampled by the sample line that supplies the data for the band, including any corridor
surface.
Surface 2
Specifies an additional surface sampled by the sample line that supplies the data for the band, including
any corridor surface. Not used for Section Segment type data bands.
Related procedures:
■

To create multiple section views (page 1259)

Section View Tables Page (Create Multiple Section View Wizard)
Use this page to set volume table properties for the section view.
NOTE This page is not available if there is no material list for the drawing. For information on how to create a
material list, see Generating Material Lists (page 1282).
Use the following controls to specify the volume table types to draw:
Type
Specifies the type of the volume table(s).
Select Table Style
Specifies the style of the volume table(s). Use the standard to create or edit a label style.
Add >>
Adds a volume table to the list.

List Of Volume Tables
Table Type
Displays the current table type.
Style
Specifies the name of the table style that was added using the Select Table Style list. To change the style,
click in this column to open the Select Style dialog box (page 2021). Select a band style in the list or use the
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standard controls to create a new style, copy or edit the current style selection, or pick a style from the
drawing.
Material List
Specifies the material list for the volume table.
Materials
Click

to specify the materials for the volume table.

Layer
Specifies the drawing layer that contains the sampled source.
Split
Specifies whether the layer is split.
Gap
Specifies the distance, in plotted units, between the current data band and the previous data band (or the
nearest section view axis). Enter a positive gap value in plotted units.
Reactivity Mode
Specifies the type of update mode for the section. Select Dynamic to specify that the section data updates
dynamically when either the position of the sample line associated with the section changes or the data
source (surface, corridor, or pipe) geometry changes.

Position Of Table(s) Relative To Section Views
Section View Anchor
Specifies the section view anchor (Top/Middle/Bottom, Left/Center/Right).
Table Anchor
Specifies the location of the table anchor (Top/Middle/Bottom, Left/Center/Right).
Table Layout
Specifies whether the layout of the tables is horizontal or vertical, in relation to the section view.
X Offset
Specifies the distance, in plotted units, to move the title away from the position set by the table anchor.
Enter a positive number to move the title right, or a negative number to move it left.
Y Offset
Specifies the distance, in plotted units, to move the title away from the position set by the table anchor.
Enter a positive number to move the title up, or a negative number to move it down.
Related procedures:
■

To create multiple section views (page 1259)

Create Sample Lines - By Station Range Dialog Box
Use this dialog box to create sample lines along an alignment for a specified range of stations.

General
Alignment
Displays the name of the currently selected alignment associated with the range of stations.
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Station Range
From Alignment Start
Specifies whether the station range starts at the beginning of the alignment (that is, at the station located
at the beginning of the alignment):
■

True: Begins the station range at the start of the alignment.

■

False: Specifies the beginning station in the range. Enter or pick a beginning station.

Start Station
Specifies the beginning station in the range. Enter a station value directly or click
drawing. Available if From Alignment Start is False.

to pick from the

To Alignment End
Specifies whether the station range ends at the end of the alignment (that is, at the final station along
the alignment):
■

True: Ends the station range at the end of the alignment.

■

False: Specifies the ending station in the range. Enter or pick an editing station.

End Station
Specifies the end station in the range. Enter a station value directly or click
Available if To Alignment End is False.

to pick from the drawing.

Left Swath Width
Snap To An Alignment
Specifies that the sample line extends out to an alignment at each station (rather than being a hard-coded
width).
■

True: Creates the left swath by snapping to a specified offset alignment at each station. If you specify
True, then select the alignment to use from the Alignment list.

■

False: Does not snap to an offset alignment. If you specify False, then use the Width setting to specify
the swath width.

Alignment
Specifies the alignment to which the left swath is extended. Available if Snap To Alignment is True.
NOTE Although all alignments in the current drawing are listed, do not select the parent alignment. The
resulting length will be zero.
Width
Specifies the swath width to the left of the alignment, using the actual ground units. Enter a positive value
in ground units. Available if Snap To Alignment is False.

Right Swath Width
Snap To An Alignment
Specifies that the sample line extends out to an alignment at each station (rather than being a hard-coded
width).
■

True: Creates the right swath by snapping to a specified offset alignment at each station. If you specify
True, then select the alignment to use from the Alignment list.

■

False: Does not snap to an offset alignment. If you specify False, then use the Width setting to specify
the swath width.

2492 | Chapter 73 Sections Dialog Boxes

Alignment
Specifies the alignment to which the right swath is extended. Available if Snap To Alignment is True.
NOTE Although all alignments in the current drawing are listed, do not select the parent alignment. The
resulting length will be zero.
Width
Specifies the swath width to the right of the alignment, using the actual ground units. Enter a positive
value in ground units. Available if Snap To Alignment is False.

Sampling Increments
Use Sampling Increments
Specifies whether sample lines are created at incremental stations along the alignment:
■

True: Changes the default sample increments for either tangents, curves, or spirals. For example, you
may want to decrease the values for curves and/or spirals.

■

False: Sample lines are not created at stations along the alignment.

Increment Along Tangents
Specifies the sample increment distance along tangents, using the actual ground units. Enter a positive
value in ground units.
Increment Along Curves
Specifies the sample increment distance along curves, using the actual ground units. Enter a positive value
in ground units.
Increment Along Spirals
Specifies the sample increment distance along spirals, using the actual ground units. Enter a positive value
in ground units.
NOTE Changing sampling increments can affect performance on rebuild. A shorter increment means more
sampling stations, and thus a larger drawing.

Additional Sample Controls
At Range Start
Specifies whether a sample line is created at the beginning of the specified range.
At Range End
Specifies whether a sample line is created at the end of the specified range.
At Horizontal Geometry Points
Specifies whether additional sample lines are created at horizontal geometry points, such as, at the start
of a spiral, or at a spiral-curve point.
At Superelevation Critical Stations
Specifies whether additional sample lines are created at superelevation critical stations.
Related procedures:
■

Creating Sample Lines (page 1246)

■

Editing Sample Line Group Properties (page 1254)

Create Sample Lines - From Corridor Stations Dialog Box
Use this dialog box to create sample lines along an alignment for specified corridor stations.
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General
Alignment
Displays the name of the currently selected alignment associated with the range of stations.

Station Range
From Alignment Start
Specifies whether the station range starts at the beginning of the alignment (that is, at the station located
at the beginning of the alignment):
■

True: Begins the station range at the start of the alignment.

■

False: Specifies the beginning station in the range. Enter or pick a beginning station.

Start Station
Specifies the beginning station in the range. Enter a station value directly or click
drawing. Available if From Alignment Start is False.

to pick from the

To Alignment End
Specifies whether the station range ends at the end of the alignment (that is, at the final station along
the alignment):
■

True: Ends the station range at the end of the alignment.

■

False: Specifies the ending station in the range. Enter or pick an ending station.

End Station
Specifies the end station in the range. Enter a station value directly or click
Available if To Alignment End is False.

to pick from the drawing.

Left Swath Width
Snap To An Alignment
Specifies that the sample line snaps the swath widths to an offset alignment at each station:
■

True: Snaps the widths to an offset alignment at each station.

■

False: Does not snap the widths.

Alignment
Specifies the currently selected alignment. Available if Snap To Alignment is True.
NOTE Although all alignments in the current drawing are listed, do not select the parent alignment. The
resulting length will be zero.
Width
Specifies the swath width to the left of the alignment, using the actual ground units. Enter a positive value
in ground units. Available if Snap To Alignment is False.

Right Swath Width
Snap To An Alignment
Specifies that the sample line snaps the swath widths to an offset alignment at each station:
■

True: Snaps the widths to an offset alignment at each station.

■

False: Does not snap the widths.

Alignment
Specifies the currently selected alignment. Available if Snap To Alignment is True.
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NOTE Although all alignments in the current drawing are listed, do not select the parent alignment. The
resulting length will be zero.
Width
Specifies the swath width to the right of the alignment, using the actual ground units. Enter a positive
value in ground units. Available if Snap To Alignment is False.
Related procedures:
■

To create perpendicular sample lines across an alignment at specified corridor stations (page 1249)

■

Editing Sample Line Group Properties (page 1254)

Create Section View Wizard
Use this wizard to create section views.
NOTE Some controls on this wizard are not available when requisite objects are not present. For example, the
Section View Tables page of this wizard is not available if there is no materials list for the drawing. For information
about how to create a material list, see Generating Material Lists (page 1282).
Related procedures:
■

To create a section view (page 1259)

General Page (Create Section View Wizard)
Use this page to specify basic information about the section view, including the parent alignment and sample
line group name, sample line, station, description, style, and layer.
Select Alignment
Specifies the name of the parent horizontal alignment. Select a name from the list or click
alignment from the drawing.

to pick an

Sample Line Group Name
Specifies the parent sample line group of the sample line from which the section view is created. Select a
name from the list or click

to pick an alignment from the drawing.

Sample Line
Specifies the sample line from which the section view is created. Select a name from the list or click
to pick an alignment from the drawing. Specifying a sample line also changes the Station value.
Station
Specifies the station value of the sample line from which the section view is created. Specifying a station
also changes the Sample Line value.
Section View Name
Specifies an editable, system-generated name. The name must remain unique within the drawing.
Description
Specifies an optional description of the section view.
Section View Layer
Specifies the drawing layer for the section view. To review or change layer data, click

.
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Section View Style
Specifies the style for the section view. Provides standard controls you use to review or change the style.
Related procedures:
■

To create a section view (page 1259)

Offset Range Page (Create Section View Wizard)
Use this page to specify the offset range to which the section view is drawn.
Automatic
Specifies that the offset range is set automatically. The lengths of the left and right swath widths are
displayed in the fields next to the selection.
User Specified
Specifies that the offset range is set by the user. Specify the lengths of the left and right swath widths in
the fields next to the selection.
Left
Specifies the offset length of the left swath width.
Right
Specifies the offset length of the right swath width.

Elevation Range Page (Create Section View Wizard)
Use this tab to specify the elevation properties of the section view.

Elevation Range
Automatic
Specifies that the elevation range is set automatically. The minimum and maximum heights are displayed
in the fields next to the selection.
User Specified
Specifies that the elevation range is set by the user. Specify minimum and maximum heights in the fields
next to the selection.
Minimum
Specifies the minimum height of the elevation.
Maximum
Specifies the maximum height of the elevation.
Related procedures:
■

To create a section view (page 1259)

Section Display Options Page (Create Section View Wizard)
Use this page to specify section display options.

Select Sections To Draw
Name
Displays the name of the section.
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Draw
Specifies whether the section is drawn in the section view. Select the check box to draw the section in the
section view.
Clip Grid
Specifies whether the grid lines in the section view are clipped to the section (horizontal and/or vertical
depending on the section view style definition). Click the radio button to clip the grid lines in the section
view to one of the named sections.
Change Labels
Specifies the style set from which the section labels will be drawn. Click in this column to open the Select
Style dialog box (page 2021)
Style
Specifies the section style. Click in this column to open the Select Section Style dialog box.
Override Style
Specifies the style for a section. Select the check box to open the Select Section Style dialog box.
Related procedures:
■

To create a section view (page 1259)

Data Bands Page (Create Section View Wizard)
Use this page to specify the properties of the data bands associated with the section view.
Select Band Set
Specifies the set of band styles for the section view. Provides standard controls that you use to review or
change the set.

List of Bands
Location
Specifies either the top or bottom of the section view. The table below this field shows the location of the
bands in the band style set.
Band Type
Specifies the data band type, either Section Data or Section Segment.
Style
Specifies the style for the band type.
Surface 1
Specifies a surface sampled by the sample line that supplies the data for the band, including any corridor
surface.
Surface 2
Specifies an additional surface sampled by the sample line that supplies the data for the band, including
any corridor surface. Not used for Section Segment type data bands.
Related procedures:
■

To create a section view (page 1259)
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Section View Tables Page (Create Section View Wizard)
Use this page to set volume table properties for the section view.
NOTE This page is not available if there is no material list for the drawing. For information about how to create
a material list, see Generating Material Lists (page 1282).
Use the following controls to specify the volume table types to draw:
Type
Specifies the type of the volume table(s).
Select Table Style
Specifies the style of the volume table. Standard buttons are also provided to create or edit a label style.
Add >>
Adds a volume table to the list.

List Of Volume Tables
Table Type
Displays the table type.
Style
Specifies the name of the table style that was added using the Select Table Style list. To change the style,
click in this column to open the Select Style dialog box (page 2021). Select a band style in the list or use the
standard controls to either create a new style, copy or edit the style selection, or pick a style from the
drawing.
Material List
Specifies the material list for the volume table.
Materials
Click

to specify the materials for the volume table.

Layer
Specifies the drawing layer that contains the sampled source.
Split
Specifies whether the layer is split.
Gap
Specifies the distance in plotted units between the data band and the previous data band (or the nearest
section view axis). Enter a positive gap value in plotted units.
Reactivity Mode
Specifies the type of update mode for the section. Select Dynamic to specify that the section data updates
dynamically when either the position of the sample line associated with the section changes or the data
source (surface, corridor, or pipe) geometry changes.

Position of Table(s) Relative to Section View
Section View Anchor
Specifies the section view anchor (Top/Middle/Bottom, Left/Center/Right).
Table Anchor
Specifies the location of the table anchor (Top/Middle/Bottom, Left/Center/Right).
Table Layout
Specifies whether the layout of the tables will be horizontal or vertical, in relation to the section view.
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X Offset
Specifies the distance in plotted units to move the title away from the position set by the table anchor.
Enter a positive number to move the title right, or a negative number to move it left.
Y Offset
Specifies the distance in plotted units to move the title away from the position set by the table anchor.
Enter a positive number to move the title up, or a negative number to move it down.
Related procedures:
■

To create a section view (page 1259)

Edit Feature Settings - Sample Line Dialog Box
Use this dialog box to view and change sample line-related settings.
This topic documents settings in all sample line-related Edit Settings dialog boxes (drawing-level, feature-level,
and command-level).
■

Drawing-level ambient settings are identified by the

■

Sample line feature settings are listed near the top of this dialog box, after the General property group,
and are identified by the

■

drawing icon.

sample line icon.

Sample line command settings are identified by the

command icon.

For general information about drawing, feature, and command settings and their interaction, see Working
with the Standard Settings Dialog Box Controls (page 78).
For information about drawing-level ambient settings, see Ambient Settings Tab (Drawing Settings Dialog
Box) (page 2078)

Default Styles
Use these settings to establish the default styles assigned to sample line components:
Sample Line Style
Specifies the default sample line style. Click in the Value column, and click
Sample Line Style dialog box.

to select a style in the

Sample Line Label Style
Specifies the default sample line label style. Click in the Value column, and click
the Sample Line Label Style dialog box.

to select a style in

For information about style selection, see Select Style Dialog Box (page 2021).

Default Name Format
Use these settings to specify the default name formats for new sample lines and sample line groups. Click
in the Value column, and click

to make changes in the Name Template dialog box (page 2022).

Default Swath Widths
NOTE This property group is displayed when you access the settings from the CreateSampleLine command.
Use these settings to specify the default behavior for sample line swath width.

Edit Feature Settings - Sample Line Dialog Box | 2499

Left Swath Width
Specifies the swath width to the left of the alignment, using the actual ground units. Enter a width in the
Value column or click

and select a distance in the drawing area.

Right Swath Width
Specifies the swath width to the right of the alignment, using the actual ground units. Enter a width in
the Value column or click

and select a distance in the drawing area.

Sampling Increments
NOTE This property group is displayed when you access the settings from the CreateSampleLine command.
Use these settings to specify the default behavior for sampling increments.
NOTE Changing sampling increments can affect performance on rebuild. A shorter increment means more
sampling stations, and thus a larger drawing.
Use Sampling Increments
Specifies whether sample lines are created at incremental stations along the alignment.
Increment Along Tangents
Specifies the sample increment distance along tangents, using the actual ground units. Enter a distance
in the Value column or click

and select a distance in the drawing area.

Increment Along Curves
Specifies the sample increment distance along curves, using the actual ground units. Enter a distance in
the Value column or click

and select a distance in the drawing area.

Increment Along Spirals
Specifies the sample increment distance along spirals, using the actual ground units. Enter a distance in
the Value column or click

and select a distance in the drawing area.

Additional Sample Controls
NOTE This property group is displayed when you access the settings from the CreateSampleLine command.
Use these settings to specify the default behavior for additional sample controls.
At Range Start
Specifies whether a sample line is created at the beginning of the specified range.
At Range End
Specifies whether a sample line is created at the end of the specified range.
At Horizontal Geometry Points
Specifies whether additional sample lines are created at horizontal geometry points, such as, at the start
of a spiral, or at a spiral-curve point within the current range.
At Superelevation Critical Stations
Specifies whether additional sample lines are created at superelevation critical stations within the current
range.
Start Range At Alignment Start
Specifies whether the sampling range starts at the beginning of the alignment.
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End Range At Alignment End
Specifies whether the sampling range ends at the end of the alignment.

Miscellaneous
NOTE This property group is displayed when you access the settings from the CreateSampleLine command.
Use this setting to specify miscellaneous default behavior for sample lines.
Lock To Station
Specifies whether the sample lines update when the alignment geometry and properties change.
Related procedures:
■

Sample Line Settings (page 1231)

Edit Feature Settings - Section Dialog Box
Use this dialog box to view and change section-related settings.
This topic documents settings in all section-related Edit Settings dialog boxes (drawing-level, feature-level,
and command-level).
■

Drawing-level ambient settings are identified by the

■

Section feature settings are listed near the top of this dialog box, after the General property group, and
are identified by the

■

drawing icon.

section icon.

Section command settings are identified by the

command icon.

For general information about drawing, feature, and command settings and their interaction, see Working
with the Standard Settings Dialog Box Controls (page 78).
For information about drawing-level ambient settings, see Ambient Settings Tab (Drawing Settings Dialog
Box) (page 2078)

Default Styles
Section Style
Specifies the default section object style. Click in the Value column, and click
Section Style dialog box.

to select a style in the

For information about style selection, see Select Style Dialog Box (page 2021).

Default Name Format
Use these settings to specify the default name formats for new section object. Click in the Value column,
and click

to make changes in the Name Template dialog box (page 2022).

Related procedures:
■

Section Settings (page 1232)

Edit Feature Settings - Section View Dialog Box
Use this dialog box to view and change section view-related settings.
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This topic documents settings in all section view-related Edit Settings dialog boxes (drawing-level, feature-level,
and command-level).
■

Drawing-level ambient settings are identified by the

■

Section view feature settings are listed near the top of this dialog box, after the General property group,
and are identified by the

■

drawing icon.

section view icon.

Section view command settings are identified by the

command icon.

For general information about drawing, feature, and command settings and their interaction, see Working
with the Standard Settings Dialog Box Controls (page 78).
For information about drawing-level ambient settings, see Ambient Settings Tab (Drawing Settings Dialog
Box) (page 2078)

Default Styles
Use these settings to specify the default styles assigned to section view components:
Marker Style
Specifies the default marker style for section view points for offset elevation and depth grade labels. Click
in the Value column, and click

to select a style in the Marker Style dialog box.

Section View Offset Elevation Label Style
Specifies the default section view offset elevation label style. Click in the Value column, and click
select a style in the Section View Offset Elevation Label Style dialog box.

to

Section View Depth Grade Label Style
Specifies the default section view grade label style. Click in the Value column, and click
style in the Section View Depth Grade Label Style dialog box.

to select a

Section View Style
Specifies the default section view style. Click in the Value column, and click
Section View Style dialog box.

to select a style in the

Section View Band Set
Specifies the default section view band set style. Click in the Value column, and click
set in the Section View Band Set dialog box.

to select a band

Section Label Set
Specifies the default section label set style. Click in the Value column, and click
the Section Label Set dialog box.

to select a label set in

Group Plot Style
Specifies the default group plot style for the multiple section view objects. Click in the Value column, and
click

to select a style in the Group Plot Style dialog box.

Section Projection Label Style
Specifies the default style for labels on projected objects. Click in the Value column, and click
a style in the Section Projection Label Style dialog box.
For information about style selection, see Select Style Dialog Box (page 2021).
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to select

Default Name Format
Use these settings to specify the template for naming the section view and the layouts created with the
Create Section Sheets command.
Section View Name Template
Specifies the default section view name template.
The default format is <[Section View Station (Uft|FS|P2|RN|Sn|OF|AP|B2|TP|EN|W0|DZY)]> (<[Next
Counter(CP)]>).
The Section View Station name is followed by a number of parameters that define how the text is displayed:
■

U—Units: Select one of ft (foot), m (meter), mile (mile), km (kilometer), in (inch), or yd (yard). The
default is Uft.

■

F—Format: Select either S (station format) or D (DD.DDDDDD decimal). The default is FS.

■

P—Precision: Select one of 0 (1), 1 (0.1), 2 (0.01), ... , or 8 (0.00000001). The default is P2.

■

R—Rounding: Select one of N (round normal), U (round up), or T (truncate). The default is RN.

■

S—Sign: Select one of n (sign negative ‘-’), Bn ((Bracket negative)), a (sign always ( )), D (drop sign),
BL (‘(‘ left prentice), or BR (right prentice ‘(‘). The default is Sn.

■

O—Output: Select one of F (full), LD (left of decimal), RD (right of decimal), DS (decimal character),
LB (left of station character), RB (right of station character), BBD (between station character and
decimal), or BC (station character). The default is OF.

■

A—Decimal character: Select either P (‘.’ period) or C (‘,’ comma). The default is AP.

■

B—Station character position: Select one of 1 (1+0), 2 (1+00), 3 (1+000), 4 (1+0000), or 5 (1+00000).
The default is B2.

■

T—Station character: Select one of P (plus sign ‘+’), M (minus sign ‘-’), A (automatic ( )), U (underscore
‘_’), or N (none). The default is TP.

■

E—Drop decimal for whole number: Select either N (No) or Y (Yes). The default is EN.

■

W—Minimum display width: Select one of 0 (none), 1, 2, ..., 32. The default is W0.

■

DZ—Drop leading zeros: Select one of Y (yes) or N (no). The default is DZN.

For example, a section view name, using the above defaults and following the “rules” of the parameters,
could look like this:
2+50.00 (2)
Click in the Value column, and click

to make changes in the Name Template dialog box (page 2022).

Cross Section Sheet Layout Name Template
Specifies the default name template that is used to name layouts that are created with the Create Section
Sheets command.

Section View Creation
Use these settings to establish the defaults assigned for section view creation:
Specify Section View Offset Range
Specifies whether an offset range is set for the creation of a section view.
Specify Section View Height
Specifies whether the default section view height is set for the creation of a section view.
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Section Group Elevation Range
Specifies how the elevation range of the section group is set:
■

Lowest Elevation

■

Mean Elevation

■

Follow a Section

Default Projection Label Placement
Use these settings to specify the default placement of labels for objects projected to section views:
Dimension Anchor Option
Specifies whether the default anchor option will be Fixed, Above, Below, Graph View Top, or Graph View
Bottom.
Dimension Anchor Elevation Value For Projections
Specifies the default value for anchor elevation. Enter a value or click
drawing area.

and select an elevation in the

Dimension Anchor Plot Height Value For Projections
Specifies the default value for anchor plot height. Enter a value or retain the existing default value.

Table Creation
NOTE This property group is displayed when you access the settings from the CreateMultipleSectionView or
CreateSectionView commands.
Use these settings to specify defaults for creating tables with section views.
Split Table
Specifies whether a table is split into two or more sections after a specified maximum number of rows has
been met.
Maximum Rows Per Table
Specifies the maximum number of rows to include per section. If the number of data rows exceeds the
specified maximum, the table is split into sections, and they are displayed either side by side (left to right),
or stacked vertically.
Maximum Tables Per Stack
Specifies the maximum number of sections to include in each stack.
Table Spacing
Specifies the spacing between tables.
Total Volume Table Style
Specifies the style for a total volume table. Click in the Value column, and click
Total Volume Table Style dialog box.

to select a style in the

Material Volume Table Style
Specifies the styles for a material volume table. Click in the Value column, and click
in the Material Volume Table Style dialog box.
X Offset
Specifies the horizontal offset of the table.
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to select a style

Y Offset
Specifies the vertical offset of the table.
Tile Direction
Specifies the direction in which the table tiles (across or down).
Section View Anchor
Specifies the section view anchor (Top/Middle/Bottom, Left/Center/Right).
Table Anchor
Specifies the location of the table anchor (Top/Middle/Bottom, Left/Center/Right).
Table Layout
Specifies whether the layout of the tables will be horizontal or vertical, in relation to the section view.

Multiple Section View Creation
NOTE This property group is displayed when you access the settings from the CreateMultipleSectionView command.
Use these settings to specify defaults for creating multiple section views.
Specify Multiple Section View Station Range
Specifies whether a station range is set for the creation of multiple section views.
Default Section View Height
Specifies the default height for section views. Enter a height in the Value column or click
a height in the drawing area.

and select

Placement Option
Specifies the default placement option for the section views.
■

Production: Use this option if you intend to use the Create Section Sheets command to generate paper
space layouts that contain section views.

■

Draft: Use this option if you intend to create an array of section views in model space for draft purposes.

For more information, see Section Placement Page (Create Multiple Section Views Wizard) (page 2487).

Sheet Creation
NOTE This property group is displayed when you access the settings from the CreateSectionSheets command.
Sheet Set Use
Specifies whether you create a new sheet set for any new sheets, or whether you add to an existing sheet
set.

Object Selection Options
NOTE This property group is displayed when you access the settings from the ProjectObjectsToMultiSect command.
Projection Rule Type
Specifies the default projection rule when the Project Objects To Multiple Section Views (page 2513) dialog
box is displayed.
■

By Percentage: Select this option to specify a percentage of distance before and after the sample line.

■

By Distance: Select this option to enter absolute distances before and after the sample line.

Percentage Before Current Sample Line
Specifies the default distance percentage before the sample line.
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Percentage After Current Sample Line
Specifies the default distance percentage after the sample line.
Distance Before Current Sample Line
Specifies the default distance before the sample line.
Distance After Current Sample Line
Specifies the default distance after the sample line.
Related procedures:
■

Section View Settings (page 1233)

Edit Offset and Elevation Ranges Dialog Box
Use this dialog box to specify the offset and elevation range properties for selected section view groups.
This dialog box is accessed from the Section View Group Properties dialog box. On the Section Views tab,
in the Offset And Elevation column, click

.

Related procedures:
■

Editing Section View Properties (page 1263)

Offset Range Tab (Edit Offset and Elevation Ranges Dialog Box)
Use this tab to specify the offset range to which the section views are drawn.
Automatic
Specifies that the offset range is set automatically. The lengths of the left and right swath widths are
displayed in the fields next to the selection.
User Specified
Specifies that the offset range is set by the user. Specify the length of the left and right swath widths in
the fields next to the selection.
Left
Specifies the offset length of the left swath width.
Right
Specifies the offset length of the right swath width.
Related procedures:
■

Editing Section View Properties (page 1263)

Elevation Range Tab (Edit Offset and Elevation Ranges Dialog Box)
Use this tab to specify the elevation properties of the selected section view.

Elevation Range
Automatic
Specifies that the elevation range is set automatically. The minimum and maximum heights are displayed
in the fields next to the selection.
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User Specified
Specifies that the elevation range is set by the user. Specify how the elevation is applied by selecting a
Section Views Height Option.
Height
Specifies the height of the elevation.

Section Views Height Option
From Lowest Elevations Of All Sections
Specifies that the elevation is set from the lowest elevation of each section.
From Mean Elevations Of All Sections
Specifies that the elevation is set from the mean elevation of each section.
Follow A Section
Specifies that the elevation is set from a particular section. Select the section from the Select Section list.
Related procedures:
■

Editing Section View Properties (page 1263)

Edit Sample Line Dialog Box
Use this dialog box to edit some of the values for the parameters of each of the vertices on an existing sample
line.
NOTE This dialog box is populated with parameters and values only when a valid sample line is selected.

Information
Name
Specifies the name of the selected sample line.

General
Sample Line Vertex Name
Displays the sample line vertex name.
For example, in a straight orthogonal sample line with positive left and right swath width values across
an alignment, the vertex names would be Left 1, Center, and Right 1.
Sample Line Vertex Northing
Displays the sample line vertex northing value.
Sample Line Vertex Easting
Displays the sample line vertex easting value.

Default Swath Widths
Left Swath Width
Specifies the width of the left swath
Right Swath Width
Specifies the width of the right swath

Station
Sample Line Station Value
Specifies the station value of the selected sample line.
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Navigation
Previous Vertex
Click to display the previous vertex. The previous vertex parameters and values for the selected sample
line are displayed.
Next Vertex
Click to display the next vertex. The next vertex parameters and values for the selected sample line are
displayed.
Related procedures:
■

Using Parameters to Edit Sample Lines (page 1250)

Group Plot Style Dialog Box
Use this dialog box to edit settings that control the layout of multiple section views.
NOTE Section views that are created using the Production option use a drawing template (.dwt) to control the
sheet size and viewports. For more information, see To create multiple section views (page 1259).
See also:
■

To edit a section view group plot style (page 1240)

Information Tab (Group Plot Style Dialog Box)
Use this tab to display administrative data and edit primary information about the group plot style, such as
its name and description.
This tab also contains information about who created or modified the group plot style and the date of these
events. The following fields can be modified:
Name
Specifies the name of the selected style.
Description
Specifies the optional description of the selected style.
Related procedures:
■

To edit a section view group plot style (page 1240)

Array Tab (Group Plot Style Dialog Box)
Use this tab to edit settings for the plot rules and page layout features for the section views.

Plot Rules
Specifies whether to plot the section views by rows or columns.
By Rows
Plots section views in rows as specified.
By Columns
Plots section views in columns as specified.
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Start Corner
Specifies the starting corner for plotting the section views.
Align Section Views About
Specifies how the section views are aligned. Select one:
■

Left

■

Centerline

■

Right

Cell Sizes
Specifies how the size of each cell in the array will be determined. For this item, the term “cell” refers to
the rectangular area in an array of section views in which a single section view is displayed. Select one:
■

Uniform For All: When this option is selected, each section view in the array will be displayed in an
area (cell) that is the same size for all section views in the array. The size of each cell will be the size
of the tallest and the widest section view in the array. Therefore, when this option is selected, all cells
in the array will be the same size.

■

Uniform Per Row Or Column: When By Rows is selected at the top of this dialog box, and you also
select this option, each row in the array will be fit to the height of the tallest section view in the row.
Therefore, when this option is selected, each row in an array may have a different height. However,
within each row, all section views will display in an area with the same cell height (row height). When
By Column is selected at the top of this dialog box, and you also select this option, each column in
the array will be fit to the width of the widest section view in the column. Therefore, when this option
is selected, each column in an array may have a different width. However, within each column, all
section views will display in an area with the same cell width (column width).

Space Between Adjacent Section Views
Column
Specifies the spacing between columns.
Row
Specifies the spacing between rows.
Related procedures:
■

To edit a section view group plot style (page 1240)

Plot Area Tab (Group Plot Style Dialog Box)
Use the settings on this tab to specify the grid details and the gap between successive pages.
NOTE Section views that are created using the Production option use a drawing template (.dwt) to control the
sheet size and viewports. For more information, see To create multiple section views (page 1259).

Plot Area Grid Details
Horizontal Major
Specifies the horizontal major grid line interval in plotted units. Enter a positive value in plotted units.
Horizontal Minor
Specifies the horizontal minor grid line interval in plotted units. Enter a positive value in plotted units.
Vertical Major
Specifies the vertical major grid line interval in plotted units. Enter a positive value in plotted units.
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Vertical Minor
Specifies the vertical minor grid line interval in plotted units. Enter a positive value in plotted units.
Gap Between Successive Pages
Specifies the plotted distance between each successive page in a multiple section view plot. This is the
distance by which each page will be separated from the next in model space. Enter a positive value in
plotted units.
Related procedures:
■

To edit a section view group plot style (page 1240)

Display Tab (Group Plot Style Dialog Box)
Use this tab to edit settings for the visibility and format styles of sheet components, such as grids, print area,
and sheet border.
NOTE Print Area and Sheet Border display components are not used for section view groups created with the
Draft placement option in the Create Multiple Section Views wizard (page 2486).
For more information, see Display Tab (Style Dialog Box) (page 2017).
Related procedures:
■

Creating and Editing Section View Styles (page 1237)

■

Editing a Section View Group Plot Style (page 1240)

Summary Tab (Group Plot Style Dialog Box)
Use this tab to edit settings for the group plot style.
For more information, see Summary Tab (Style Dialog Box) (page 2020).
Related procedures:
■

To edit a section view group plot style (page 1240)

Pipe Network Section Properties Dialog Box
Use this dialog box to edit properties of the selected pipe network section, such as its name, section data,
and labels.
See also:
■

Editing Pipe Network Section Properties (page 1257)

■

Displaying Pipe Networks in Section Views (page 1366)

Information Tab (Pipe Network Section Properties Dialog Box)
Use this tab to edit primary information about the selected pipe network section.
Name
Specifies the name of the section. The default format is <SLG>-n - <SL>-n - <data source>(n).
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<SLG> is the parent sample line group name, <SL> is the sample line name, and <data source> is the name
of the data source (for example, pipe network) on which the section is drawn.
n is an integer greater than or equal to one, which increments as each feature is created in the drawing.
Description
Specifies the optional description of the section.
Show Tooltips
Controls whether tooltips are displayed for the object in the drawing (not over toolbar icons).
Related procedures:
■

Editing Pipe Network Section Properties (page 1257)

■

Displaying Pipe Networks in Section Views (page 1366)

Section Data Tab (Pipe Network Section Properties Dialog Box)
Use this tab to edit properties of the selected section object.
Description
Specifies the optional description of the current section.
Type
Displays a

, which indicates that the section was extracted from a pipe network.

Data Source
Displays the name of the data source from which the current section was sampled.
Update Mode
Specifies the type of update mode for the section. Select Dynamic to specify that the section data updates
dynamically if the position of the sample line associated with the section changes or the data source
(surface or corridor) geometry changes.
Layer
Specifies the drawing layer that contains the current section associated with the selected sample line
group. Click in this column to open the Layer Selection dialog box (page 2222). Select a layer in the Layers
table.
Style
Specifies the name of the style of the section. Click in this column to open the Select Style dialog box
(page 2021). Select a style in the list or use the standard controls to create a new style, copy or edit the
current style selection, or pick a style from the drawing.
Station
Displays the station value of the sample line along which the section is sampled.
Left Offset
Displays the left offset value of the current section.
Right Offset
Displays the right offset value of the current section.
Minimum Elevation
Displays the minimum elevation of the section associated with the selected sample line group.
Maximum Elevation
Displays the maximum elevation of the section associated with the selected sample line group.
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Related procedures:
■

Editing Pipe Network Section Properties (page 1257)

■

Displaying Pipe Networks in Section Views (page 1366)

Profile Grade Points Dialog Box
Use this dialog box to select a profile and display its elevation by marking it at the appropriate offset and
elevation in the section view.
This dialog box is accessed from the Section View Group Properties dialog box. On the Section Views tab,
in the Profile Grade column, click

.

Alignment
Specifies the parent alignment whose profile grade point is to be displayed in this section view. Select an
alignment from the drop-down list or click

to pick an alignment from the drawing.

Add >>
Adds the profile grade point for the currently selected alignment to the list.

Deletes the highlighted profile grade point from the list. The profile grade point will no longer be displayed
in the section view.

List of profile grade points
Alignment
Displays the name of the parent alignment whose profile grade point is marked in this section view.
Show
Specifies whether the marker is visible in the section view (that is, without having to edit the marker style
or layer).
Profile
Displays the name of the profile whose location, with respect to the current section view, is marked.
Marker Style
Displays the marker style used for the profile grade point.
Related procedures:
■

Adding Profile Grade Points to a Section View (page 1262)

Project Objects to Section View Dialog Box
Use this dialog box to specify objects in the current drawing to be projected into a section view.
To highlight an object in the drawing, select its row in this table.
Name
Displays the objects that can be projected, divided into categories. Select the ones you want to project.
Style
Specifies the current style for each object. You can change the style used to project an object. Select <set
all> at the category level to change all objects in that category in one operation.
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Elevation Options
Specifies how the elevation of each object is determined.
■

Use Object: Elevation is read from the object properties.

■

Surface: The object is set to the elevation of a selected surface.

■

Manual: You can specify the elevation.

■

<set all>: Used at the category level to specify the elevation option for all projected objects in the
category.

Elevation Value
Specifies the elevation of each projected object. You can change the value here for point objects if the
elevation option is manual.
Label Style
Specifies the style of label applied to the projected object. Select <none> to display no label. Select <set
all> at the category level to set a label style for all projected objects in the category.
Pick Objects
Click to select objects in the drawing and add them to the section view.
Related procedures:
■

Projecting Objects to a Single Section View (page 1265)

Project Objects To Multiple Section Views Dialog Box
Use this dialog box to specify projection rules and to select the type of objects to project.
Sample Line Group/Section View Group
Specifies which sample line group or section view group to project the objects to. This list is restricted to
the object type that you select when you run the Project Objects To Multiple Section Views command
before this dialog box is displayed. If you selected a sample line group but want to restrict the projection
to a section view group, click Cancel, run the command again, and select a section view.
Projection Rules
Specifies the proximity area for objects to be projected. Objects whose insertion points are within this
area are projected. The graphics update to show you how your choices impact the object selection.
■

By Percentage: Select this option and use the sliders to specify a percentage of distance before and
after the sample line. For more information, see Projection Rule: By Percentage Option (page 1266).

■

By Distance: Select this option and enter absolute distances before and after the sample line. For more
information, see Projection Rule: By Distance Option (page 1266).

NOTE The Projection Rules do not apply to feature lines, survey figures, or 3D polylines. Those objects are
projected only when they intersect a sample line for a given section view.
NOTE A distance or percent of zero projects non-linear objects whose insertion point is exactly on the sample
line.
Name
Specifies which objects are projected. All objects of the type selected are projected if they fall within the
area specified in the Projection Rules.
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NOTE You can control individual object settings later by using the Projections tab of the Section View Properties
dialog box.
Style
Specifies the style for each object type.
Elevation Options
Specifies how the elevation of each object is determined.
■

Use Object: Elevation is read from the object properties.

■

Surface: The object is set to the elevation of a selected surface.

■

Manual: You can specify the elevation.

Elevation Value
Specifies the elevation of each projected object. You can change the value if the Elevation Options value
is Manual.
Label Style
Specifies the style of label applied to the projected object.
Related procedures:
■

Projecting Objects to Multiple Section Views (page 1265)

Resolve Duplicate Sample Lines Dialog Box
Use this dialog box to resolve duplicate sample lines that have already been defined at some stations.
This dialog box is displayed when you create sample lines if the sample line group already contains sample
lines.
The properties in this dialog box specify whether duplicate sample lines are deleted from an existing list or
appended to a new list. If you select Delete Existing List, you need not do anything further. If you select
Append New List, you can specify how the new list is appended.

Delete Existing List
Removes the existing sample lines in the drawing. Adds only new sample lines.

Append New List
Station
Displays the station where the duplicate sample line is located. This is the default.
Overwrite
Specifies whether the sample line to be created overwrites the existing sample line in the drawing:
■

Selected: The sample line to be created overwrites the existing sample line in the drawing, thus removing
the existing sample line at that station.

■

Cleared: The sample line to be created does not overwrite the existing sample line, thus preserving the
existing sample line.

Add New
Specifies whether the sample line is added as a new sample line in the drawing:
■

Selected: The sample line to be created is added as a new sample line in the drawing, thus keeping the
existing sample line.
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■

Cleared: The sample line to be created is not added as a new sample line, thus keeping the existing
sample line.

Ignore New
Specifies whether the sample line to be created is ignored and not added in the drawing:
■

Selected: The sample line to be created is ignored and not added, thus preserving only the existing
sample line in the drawing.

■

Cleared: The sample line to be created is not ignored and is added, thus preserving the existing sample
line in the drawing.

Name
Specifies the name of the sample line.
Description
Specifies the description of the sample line.
Overwrite All
Specifies that all duplicate sample lines in the list are overwritten in the drawing. Optionally select the
Overwrite check box for all duplicate sample lines. This is the default.
Add All
Specifies that all duplicate sample lines in the list are added in the drawing. Optionally select Add New
check box for all duplicate sample lines.
Ignore All
Specifies that all duplicate sample lines in the list are ignored, and not added in the drawing. Optionally
select the Ignore All check box for all duplicate sample lines.
Related procedures:
■

Creating Sample Lines (page 1246)

Sample Line Group Properties Dialog Box
Use this dialog box to edit properties of the selected sample line group, such as its name, and properties of
the displayed sections and section views.
See also:
■

Editing Sample Line Group Properties (page 1254)

Information Tab (Sample Line Group Properties Dialog Box)
Use this tab to edit primary information about the selected sample line group.
Name
Specifies the name of the selected sample line group. The default format is <SLG>-n.
<SLG> is the parent sample line group name.
n is an integer greater than or equal to one, which increments as each feature is created in the drawing.
Description
Specifies an optional description.
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Show Tooltips
Controls whether tooltips are displayed for the object in the drawing (not over toolbar icons).
Related procedures:
■

Editing Sample Line Group Properties (page 1254)

Sample Lines Tab (Sample Line Group Properties Dialog Box)
Use this tab to edit properties of the sample lines that are included in the selected sample line group.
Edit Group Labels
Click to open the Sample Line Labels dialog box (page 2521).

Sample Lines
No.
Displays the sequential number of the sample line.
Name
Displays the name of the sample line.
Station
Displays the station that is associated with the sample.
Layer
Specifies the layer on which the sample line is drawn. The default is 0 (base), which is the default layer
defined in the drawing layer settings. Click in the Layer column to open the Layer Selection dialog box
(page 2222). Select a layer in the Layers table.
Style
Specifies the sample line style. Click in the Style column to open the Pick Sample Line Style dialog box
(page 2021). Select a style in the list or use the standard controls to create a new style, copy or edit the
current style selection, or pick a style from the drawing.
Left Offset
Displays the left offset value of the current selection.
Right Offset
Displays the right offset value of the current selection.
Description
Displays the description of the sample line.
Related procedures:
■

Editing Sample Line Group Properties (page 1254)

Sections Tab (Sample Line Group Properties Dialog Box)
Use this tab to edit properties of sections that are included in the selected sample line group.
Sample More Sources
Click the Sample More Sources button to open the Section Sources dialog box (page 2533).
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Sections List
Name
Specifies the name of the section associated with the selected sample line group.
Style
Specifies the name of the style of the section. Click in the column to open the Select Style dialog box
(page 2021). Select a style in the list or use the standard controls to create a new style, copy or edit the
current style selection, or pick a style from the drawing.
Update Mode
Specifies the type of update mode for the section. Select Dynamic to specify that the section data updates
dynamically if the position of the sample line associated with the section changes or the data source
(surface, corridor, or pipe) geometry changes.
Layer
Specifies the drawing layer that contains the section associated with the selected sample line group. The
default is 0 (base), which is the default layer defined in the drawing layer settings. Click in the Layer
column to open the Layer Selection dialog box (page 2222). Select a layer in the Layers table.
Station
Displays the station value of the sample line along which the current section is sampled.
Show Sections For All Sources
Select the Show Sections for all Sources check box to view all stations of each section, arranged in an
expandable tree or hierarchy.
Related procedures:
■

Editing Sample Line Group Properties (page 1254)

■

Setting Up Sections (page 52)

Section Views Tab (Sample Line Group Properties Dialog Box)
Use this tab to edit properties of the section views in the selected sample line group.
Section View
Displays the names of section views arranged in an expandable tree or hierarchy.
Group Plot Style
Specifies the name of the plot style of the section view associated with the selected sample line group.
Click in this column to open the Select Style dialog box (page 2021). Select a style in the list or use the
standard controls to create a new style, copy or edit the current style selection, or pick a style from the
drawing.
Style
Specifies the name of the style of the section view associated with the selected sample line group. Click
in this column to open the Select Style dialog box. Select a style in the list or use the standard controls
to create a new style, copy or edit the current style selection, or pick a style from the drawing.
Change Band Set
Specifies the optional set of bands to use with the current section view. Click in this column to open the
Select Style dialog box. Select a band style in the list or use the standard controls to create a new style,
copy or edit the current style selection, or pick a style from the drawing.
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Change Volume Tables
Specifies the volume table(s) to be drawn. Click in this column to open the Change Volume Table dialog
box (page 2561). A material list must be exist for the drawing before any volume table can be created.
Section Display
Specifies the section display options for the current section view. Click in this column to open the Section
Display Controls dialog box (page 2530). Select section display options in the list.
Profile Grade
Specifies the grid lines displayed at offset alignments and other profiles within the range of section view
extents. Click in this column to open the Profile Grade Points dialog box (page 2512).
Station
Displays the station value of the sample line along which this section view is created.
Start Station
Displays the beginning station in the range.
End Station
Displays the end station in the range.
Related procedures:
■

Editing Sample Line Group Properties (page 1254)

Material List Tab (Sample Line Group Properties Dialog Box)
Use this tab to view and edit the material lists for a sample line group and add and delete materials from a
list.
Add New Material
Adds a new empty criteria to a material list. After you add the criteria, you can edit its quantity type and
settings and use the Define Material fields to populate it with data.

Opens the Name Template dialog box (page 2022), where you can modify the material naming template.
Add A Subcriteria
Adds a subcriteria to an empty material or to a material with existing subcriteria. For more information,
see Calculating Volumes for Overlapping Materials or Overhangs (page 1285).

Deletes the material or data component that is currently selected in the Material Name column.

Define Material
Data Type
Specifies the type of data that is compared and processed when defining the material. Either Surface or
Corridor Shape.
Select Surface/Shape
Lists sampled surfaces and corridor shapes for this sample line group. Select a surface or corridor shape.
NOTE Corridor shapes can be added only to a material with a Structure quantity type.

Adds the data specified in the Define Material fields to the selected material type.
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NOTE If a material is not selected, the data is not added.
The properties table contains the following columns:
Material Name
Names of material lists, material names, surfaces, and corridor shapes arranged in a tree or hierarchy. Each
instance of applying criteria to materials in a sample line group is added as a numbered list. List names
can be edited.
Click
next to a list name to display its components (materials). Click
display its components (surfaces or structures).

next to a material name to

Condition
Specifies the condition on which to base the calculation:
■

Above. Specifies that an area above this surface is included in the material definition. Used with Below
to define two or more surfaces for cut, fill, and structures material types.

■

Below. Specifies that an area below this surface is included in the material definition. Used with Above
to define two or more surfaces for cut, fill, and structures material types.

■

Base. Specifies that this surface is the surface to compare against the compare surface. Used with
Compare to define two or more surfaces for earthworks and cut and fill material types.

■

Compare. Specifies that this surface is the surface to compare against the base surface. Used with Base
to define two or more surfaces for earthworks and cut and fill material types.

■

Include. Specifies a corridor shape that is included in the structure type definition.

Quantity Type
Specifies the quantity type:
■

Cut. Calculates the material to remove.

■

Fill. Calculates the material to add.

■

Cut and Refill. Defines an area in the section where a material is removed and refilled with fill material.

■

Earthworks. Compares two surfaces to calculate both cut and fill areas and displays them separately.

■

Structures. Calculates the volume of one or more corridor shapes (as defined by the shape codes that
are used to define the corridor). For information about shape codes, see Understanding Point, Link,
and Shape Codes (page 1568).

Cut Factor
Specifies the expansion or swell of the cut material.
Fill Factor
Specifies a factor to accommodate for the contraction or shrinkage of the fill material.
NOTE For example, for a material that compacts to 93% of its original value when used as fill, enter 1.075
(which is derived by dividing 1.0 by .93) as the fill factor to compensate for the extra material that must be
added.
Refill Factor
Specifies usability factor used to calculate how much cut material can be reused as fill.
Shape Style
Specifies the default style used to display the material in a section view.
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Curve Tolerance
Specifies the curve correction tolerance, if any, that was specified when the criteria was applied. To edit
the value, select the check box, and then edit the value.
NOTE This control is not displayed if Composite Volume or Prismoidal is specified for the Volume Calculation
Method.
Gap
Defines and applies gaps to accommodate non-contiguous pockets of materials. Click in the column to
display either the Define Gaps or Apply Gaps dialog box
■

When you click the Gap column from the
Material List level, the Define Gaps (page 2520) dialog box
is displayed. Use this dialog box to define the gaps.

■

When you click the Gap column from the
Material level, the Apply Gaps (page 2521) dialog box is
displayed. Use this dialog box to apply gaps and to define run ins and run outs.

For more information, see Defining Gaps and Pockets of Materials (page 1283).
Volume Calculation Method
Specifies which method is used to calculate volumes. For more information, see Sectional Volume Methods
(page 1277).
Import Another Criteria
Prompts you to add a new materials list to the sample line group. Prompts you to select a criteria and
opens the Compute Materials dialog box.
Related procedures:
■

Editing Sample Line Group Properties (page 1254)

Define Gaps <Material List Name> Dialog Box
Use the Define Gaps dialog box to define gaps in material lists where material volumes should not be
calculated.
Access this dialog box from the Material List tab of the Sample Line Group Properties dialog box. Click the
button in the Gap column for the

Material List name.

Add A New Gap
Adds an entry to the List Of Gaps. After clicking this button, enter the start station, end station, and
description for the gap.
NOTE You can define Run Out and Run In distances for the gaps and choose to apply or not apply a gap in
the Apply Gaps (page 2521) dialog box.
Delete Selected Gap
Deletes the selected gap definition. Deleting a gap definition removes the gap type from all materials in
the material list.
Related procedures:
■

Defining Gaps and Pockets of Materials (page 1283)
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Apply Gaps <Material Name> Dialog Box
Use the Apply Gaps dialog box to apply gaps where material volumes should not be calculated and to define
run in and run out distances for the materials.
Access this dialog box from the Material List tab of the Sample Line Group Properties dialog box. Click the
button in the Gap column for the

Material name.

Before using this dialog box, you must first define the gaps using the Define Gaps dialog box. Define Run
Out Distance and Run In Distance values when the gaps do not start or stop abruptly at a specific station.
Apply
Applies a defined gap to the selected material.
NOTE The gap must be defined in the Define Gaps (page 2520) dialog box.
Run Out Distance
Defines the run out distance for the material preceding the gap. Run out is added at the start of gaps, if
needed.
In the following illustration, the green areas 1 and 2 represent gaps in the material (5). Gap 1 does not
have a run out distance. However, Gap 2 does have a run out distance of 75m as represented by the red
area number 4.

Run In Distance
Defines the run in distance for the material after the gap. Run in is added at the end of gaps, if needed.
In the illustration above, Gap 1 has a run in distance of 40m as represented by the red area number 3.
Related procedures:
■

Defining Gaps and Pockets of Materials (page 1283)

Sample Line Labels Dialog Box
Use this dialog box to manage labels for a particular sample line group.
Sample Line Label Style
Specifies the style for the labels. Standard buttons are also provided to create or edit a label style.
Add>>
Adds the specified label type to the set in the label table. These labels appear along the section line in the
section view.

Deletes the selected label type from the table. Also removes it from the section.

Label table
Type
Specifies the type of section label.
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Style
Specifies the label style.
Start Station
Specifies the start station of the sample line group to be labeled.
The check box in front of the column specifies whether the start station can be edited:
■

Selected: The start station entry is frozen.

■

Cleared: The start station entry can be edited.

End Station
Specifies the end station of the sample line group to be labeled.
The check box in front of the column specifies whether the end station can be edited:
■

Selected: The end station entry is frozen.

■

Cleared: The end station entry can be edited.

Related procedures:
■

Using Sample Line Labels (page 1241)

Sample Line Properties Dialog Box
Use this dialog box to edit properties of the selected sample line, such as its name, sample line data, and
properties of the displayed sections and section views.
See also:
■

Editing Sample Line Properties (page 1255)

Information Tab (Sample Line Properties Dialog Box)
Use this tab to edit primary information about the selected sample line.
Name
Specifies the name of the sample line. The default format is <SL>-n.
<SL> is the name of the sample line.
n is an integer greater than or equal to one, which increments as sample lines are created in the drawing.
Description
Specifies the optional description of the sample line.
Object Style
Specifies the name of the style used by the sample line.

Creates, copies, or edits a style using the Sample Line Style dialog box (page 2525). Click the Down arrow
to display the style selection menu:
■

Create New: Creates a new style.

■

Copy Current Selection: Copies the current style.

■

Edit Current Selection: Edits the current style.
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■

Pick From Drawing: Prompts you to select a style directly from the drawing. The selected style becomes
the current style.

Displays details about an existing style. Select the style name in the list. Click to open the Style Detail
dialog box (page 2020). Preview the style and creation information.
Show Tooltips
Controls whether tooltips are displayed for the object in the drawing (not over toolbar icons).
Related procedures:
■

Editing Sample Line Properties (page 1255)

Sample Line Data Tab (Sample Line Properties Dialog Box)
Use this tab to display properties for the sample line and to edit properties about the lock method and label
style.
Group Name
Displays the name of the parent sample line group for the current sample line.
Alignment
Displays the name of the parent horizontal alignment for the current sample line.
Sample Line Number
Displays the assigned sample line number of the currently selected sample line.
NOTE This is a sequential number of the sample line among all sample lines sorted by station value.
Station
Displays the station at which the sample line intersects with the parent alignment.
Lock To The Station
Locks the sample line to the station:
■

Selected: If the parent alignment geometry is updated so that the current station value is at a different
XY, then the sample line moves to that location. The sample line maintains its relative position to the
alignment (that is, it “slides” to the new location.

■

Cleared: If the parent alignment is modified, the sample line remains in its location. The sample line
maintains its geometry and recomputes the updated station where it intersects the alignment.
Subsequently, if the check box is (re-)selected, the sample line is locked to the current station.

Related procedures:
■

Editing Sample Line Properties (page 1255)

Sections Tab (Sample Line Properties Dialog Box)
Use this tab to edit properties that draw and manage the section associated with the current sample line.
Name
Displays the name of the section associated with the current sample line.
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Description
Specifies the optional description of the section.
Type
Displays the type of data source from which the section data was extracted. Either
from an existing TIN surface;
surface; or

, which indicates from a corridor;

, which indicates

, which indicates from a corridor

, which indicates a pipe network.

Data Source
Displays the name of the data source used by the section associated with the selected sample line. Can
be a surface, corridor, corridor surface, or pipe network.
Update Mode
Specifies the type of update mode for the section. Select Dynamic to specify that the section data updates
dynamically if the position of the sample line associated with the section changes or the data source
(surface, corridor, or pipe) geometry changes.
Layer
Specifies the drawing layer that contains the section object associated with the selected sample line. Click
in this column to open the Layer Selection dialog box (page 2222). Select a layer in the Layers table.
Style
Specifies the name of the style of the section. Click in this column to open the Select Style dialog box
(page 2021). Select a style in the list or use the standard controls to create a new style, copy or edit the
current style selection, or pick a style from the drawing.
Left Offset
Displays the left offset value of the current section.
Right Offset
Displays the right offset value of the current section.
Minimum Elevation
Displays the minimum elevation of the section associated with the selected sample line group.
Maximum Elevation
Displays the maximum elevation of the section associated with the selected sample line group.
Station
Displays the station value at which the sample line is created.
Related procedures:
■

Editing Sample Line Properties (page 1255)

Section Views Tab (Sample Line Properties Dialog Box)
Use this tab to edit properties of the section views that are associated with the sample line.
Name
Displays the name of the section view that is created along this sample line.
Description
Displays the optional description of the section view.
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Layer
Specifies the drawing layer that contains the section view object. Click in this column to open the Layer
Selection dialog box (page 2222). Select a layer in the Layers table.
Style
Specifies the name of the style used by the section view. Click in this column to open the Select Style
dialog box (page 2021). Select a style in the list or use the standard controls to create a new style, copy or
edit the current style selection, or pick a style from the drawing.
Change Band Set
Specifies the optional set of bands to use with the current section view. Click in this column to open the
Select Style dialog box. Select a band style in the list or use the standard controls to create a new style,
copy or edit the current style selection, or pick a style from the drawing.
Sample Line Number
Displays the current sample line number.
Sample Line Name
Displays the current sample line name.
Station
Displays the current sample line station value.
Related procedures:
■

Editing Sample Line Properties (page 1255)

Sample Line Style Dialog Box
Use this dialog box to define a sample line style, which controls the way a sample line is displayed in a
drawing.
See also:
■

Creating and Editing Sample Line Styles (page 1234)

Information Tab (Sample Line Style Dialog Box)
Use this tab to display administrative data and edit primary information about the sample line style, such
as its name and description.
This tab also contains information about who created or modified the sample line style and the date of these
events. The following fields can be modified:
Name
Specifies the name of the selected sample line style.
Description
Specifies the optional description of the selected sample line style.
Related procedures:
■

Creating and Editing Sample Line Styles (page 1234)
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Display Tab (Sample Line Style Dialog Box)
Use this tab to edit settings for the visibility and format styles of sample line components, such as lines and
vertices.
On the Display tab, you can use the ByLayer or ByBlock reference settings to set Color, Linetype, Lineweight,
and Plot Style values. Reference settings are indirect and require some planning.
For more information, see Display Tab (Style Dialog Box) (page 2017).
Related procedures:
■

Creating and Editing Sample Line Styles (page 1234)

Summary Tab (Sample Line Style Dialog Box)
Use this tab to edit settings for the sample line style.
For more information, see Summary Tab (Style Dialog Box) (page 2020).
Related procedures:
■

Creating and Editing Sample Line Styles (page 1234)

Sample Line Tools Toolbar
Use this toolbar to create and edit sample lines along a horizontal alignment.
The current sample line creation method, the alignment name associated with the sample line, and the layer
on which the sample line is contained are displayed at the bottom of the tool.

Name
Specifies the format of the name of the next sample line to be created. The default format is <SL> - <[Next
Counter]>.
<SL> is the name of the sample line.
<[Next Counter]> is an integer greater than or equal to one, which increments as sample lines are created
in the drawing. This naming convention is based on the name template.
Enter a name or edit a default naming convention in the Name Template dialog box. For more information,
see Name Template dialog box (page 2022).

Opens the Name Template dialog box. Edit the default sample line naming convention.

Prompts you to pick the horizontal alignment in the drawing to associate with the sample line. After you
click the alignment in the drawing, the Sample Line Tools toolbar is reopened.
Current Sample Line Group
Displays the current sample line group with which the sample line is associated. If no sample line groups
have been defined, you are prompted to enter a new sample line group name. For more information, see
the Create/Edit Sample Line Group dialog box (page 2485).
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TIP To edit a specific sample line group, select the sample line group name in the list.
Sample Line Group Actions
Specifies the sample line group action used to create or modify the sample line group. The default is the
last used method. Click the down arrow to display other actions.
■

Opens the Create Sample Line Group dialog box. Create a new sample line group.

■

Opens the Edit Sample Line Group dialog box. Edit the currently selected sample line group.

■

Deletes the currently selected sample line group.

■

Prompts you to pick a sample line group from the drawing, which becomes the current sample
line group.

■

Opens the Edit Sample Line Widths dialog box. Edit the left and right swath widths of the currently
selected sample line group. The swath widths of individual sample lines are extended or trimmed to
match the group’s widths.

■

Opens the Section Sources dialog box. Add more source sections to the currently selected sample
line group.

Sample Line Creation Methods
Displays the various sample line creation methods used to create the sample line(s). Click the down arrow
to display other actions.
■

Creates sample lines by specifying individual stations along the alignment.

■

Creates sample lines by picking points in the drawing.

■

Creates sample lines by picking existing polylines in the drawing.

■

Opens the Create Sample Lines - By Station Range dialog box (page 2491). Creates sample lines by
specifying a range of stations.

■

Opens the Create Sample Lines - From Corridor Stations dialog box (page 2493). Creates sample lines
from corridor stations.

Click to select a sample line and view and edit its information in the Edit Sample Line dialog box (page
2507).

Toggles the display of the Edit Sample Line dialog box. To populate the columns of the Edit Sample Line
dialog box, select a sample line from the drawing using

.

Undoes the last action.
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Redoes the last action. Limited to one operation.
Related procedures:
■

Creating Sample Lines (page 1246)

■

Editing Sample Lines (page 1250)

Section Data Band Style Dialog Box
Use this dialog box to edit settings for section view band styles.
See also:
■

Section View Bands (page 1245)

■

Creating and Editing Section View Styles (page 1237)

Information Tab (Section Data Band Style Dialog Box)
Use this tab to display administrative data and edit primary information about the section view band style,
such as its name and description.
This tab also contains information about who created or modified the section view band style and the date
of these events. The following fields can be modified:
Name
Specifies the name of the section data band.
Description
Specifies the optional description of the section view band style.
Related procedures:
■

Section View Bands (page 1245)

■

Creating and Editing Section View Styles (page 1237)

Band Details Tab (Section Data Band Style Dialog Box)
Use this tab to specify the details of the section view band, including title text, layout, and labels and ticks
values.
NOTE Both Section Data and Section Segment band styles are explained in this topic.

Title Text
Compose Label
Click to create a title label in the Label Style Composer dialog box (page 2180).

Layout
Band Height
Specifies the height of the band in plotted units. Enter a positive value in plotted units.
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Text Box Width
Specifies the width of the band text box in plotted units. Enter a positive value in plotted units.
Offset From Band
Specifies the distance from the band to the text box in plotted units. Enter a positive value in plotted
units.
Text Box Position
Specifies the location of the title text box with respect to the band.

Labels And Ticks
Type
Specifies the type of labels and ticks.
NOTE To compose labels, select the type from the list. Adjust parameters as required. Click Compose Label.
The following types are available for section data bands:
■

At Major Increment: Composes labels at major increments along the band and displays selected tick
mark(s) at each major increment. The default is Small Ticks At, with Top and Bottom selected, each
with a Tick Size of 0.1000”.

■

At Minor Increment: Composes labels at minor increments along the band and displays selected tick
mark(s) at each minor increment. The default is Small Ticks At, with Top and Bottom selected, each
with a Tick Size of 0.1000”.

■

At Centerline: Composes labels at centerline and displays selected tick mark(s) at centerline. The default
is Full Band Height Ticks.

■

At Sample Line Vertices: Composes labels at each sample line vertex along the band and displays
selected tick mark(s) at each sample line vertex. The default is Small Ticks At, with Top and Bottom
selected, each with a Tick Size of 0.1000”.

■

At Grade Breaks: Composes labels at each grade break along the band and displays selected tick mark(s)
at each grade break. The default is Small Ticks At, with Top and Bottom selected, each with a Tick Size
of 0.1000”.

■

At Incremental DIstance: Composes labels at incremental distances along the band. Click Compose
Label to set label styles in the Label Style Composer dialog box (page 2180).

The following type is available for section segment bands:
■

Segment Label: Composes labels at each segment along the band and displays selected tick mark(s)
at each major increment. The default is Full Band Height Ticks.

When you select a Label and Tick type, the appropriate default values for Full Band Height Ticks and Small
Ticks At are displayed.
Full Band Height Ticks
Specifies whether the tick is drawn at the full band height. This is the default value for the Centerline
type.
Small Ticks At
Specifies whether ticks that are smaller than the size defined in Tick Size are drawn. The default for all
types (except Centerline) is selected for both Top and Bottom and cleared for Middle. Select or clear one
or more check boxes as required.
■

Top: Draws the small tick(s) at the top of the selected type.

■

Middle: Draws the small tick(s) in the middle of the selected type.
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■

Bottom: Draws the small tick(s) at the bottom of the selected type.

Tick Size: Specifies the height in plotted units of the Small Ticks. The default is 0.1000” for Top and Bottom
ticks and 0.2500” for Middle ticks. Enter a positive value in plotted units.
Compose Label
Composes labels at major/minor increments, centerline, sample line vertices, and grade breaks for the
section data band or section segment label. For more information, see Label Style Composer dialog box
(page 2180).
NOTE The Offset From Centerline property in Section Data bands is measured perpendicularly to the alignment.
The Distance From Centerline property is measured along the sample line. If the sample line is skewed, the
Distance From Centerline value will therefore be different than the Offset From Centerline value. If the sample
line is perpendicular, then these values will be the same.
Related procedures:
■

Section View Bands (page 1245)

■

Creating and Editing Section View Styles (page 1237)

Display Tab (Section Data Band Style Dialog Box)
Use this tab to edit settings for the visibility and format styles of section view components, such as borders,
titles, ticks, and labels.
For more information, see Display Tab (Style Dialog Box) (page 2017).
Related procedures:
■

Section View Bands (page 1245)

■

Creating and Editing Section View Styles (page 1237)

Summary Tab (Section Data Band Style Dialog Box)
Use this tab to edit settings for the section view band style.
For more information, see Summary Tab (Style Dialog Box) (page 2020).
Related procedures:
■

Section View Bands (page 1245)

■

Creating and Editing Section View Styles (page 1237)

Section Display Controls Dialog Box
Use this dialog box to edit section display options.
This dialog box is accessed from the Sample Line Group Properties dialog box. On the Section Views tab, in
the Section Display column, click

Edit Section Options Table
Name
Displays the name of the section.
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.

Draw
Specifies whether the section is drawn in the current section view. Select the check box to draw the section
in the current section view.
Clip Grid
Specifies whether the grid lines in the current section view are clipped to the section (horizontal and/or
vertical depending on the section view style definition). Select the radio button to clip the grid lines in
the section view to the section.
Change Labels
Specifies the style set from which the section labels will be drawn. Click in this column to open the Select
Style dialog box (page 2021).
Style
Specifies the section style. Click in this column to open the Select Section Style dialog box.
Override Style
Specifies the style for a section. Select the check box to open the Select Section Style dialog box.
Related procedures:
■

Editing Sample Line Group Properties (page 1254)

Section Editor Dialog Box
Use this dialog box to edit static sections in a section view and to display information about dynamic sections
and corridor sections.
If a section is dynamic, the data in this dialog box is not editable. You can change the state of a section from
dynamic to static on the Section Data (page 2533) tab of the Section Properties dialog box. Static sections are
those which do not maintain a link with their elevation data source.
This dialog box has a customizable display for the columns. For more information, see Customize Columns
Dialog Box (page 2022).
Alignment
Displays the alignment name associated with the current section.
Station
Displays the station name associated with the current section.

Columns
No.
Sequential number of the vertex.
Distance from CL
Distance in ground units from the vertex to the centerline.
Vertex Elevation
Elevation at the vertex.
Section Grade In
Angle of the section grade in.
Section Grade Out
Angle of the section grade out.
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Related procedures:
■

To edit a static section using the Section Editor (page 1253)

Section Properties Dialog Box
Use this dialog box to edit properties of the selected section, such as its name, section data, and labels.
See also:
■

Editing Sections (page 1253)

■

Editing Section Properties (page 1256)

Information Tab (Section Properties Dialog Box)
Use this tab to edit primary information about the selected section.
Name
Specifies the name of the section. The default format is <SLG>-n - <SL>-n - <data source>(n).
<SLG> is the parent sample line group name, <SL> is the sample line name, and <data source> is the name
of the data source (for example, surface or corridor surface) on which the section is drawn.
n is an integer greater than or equal to one, which increments as each feature is created in the drawing.
Description
Specifies the optional description of the section.
Object Style
Specifies the name of the style used by the section.

Creates, copies, or edits a style using the Section Style dialog box (page 2534). Click the down arrow to
display the style selection menu:
■

Create New: Creates a new style.

■

Copy Current Selection: Copies the current style.

■

Edit Current Selection: Edits the current style.

■

Pick From Drawing: Prompts you to select a style directly from the drawing. The selected style becomes
the current style.

Displays details about an existing style. Select the style by name in the list. Click to open the Style Detail
dialog box (page 2020). Preview the style and creation information.
Show Tooltips
Controls whether tooltips are displayed for the object in the drawing (not over toolbar icons).
Related procedures:
■

Editing Section Properties (page 1256)
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Section Data Tab (Section Properties Dialog Box)
Use this tab to edit properties of the selected section object.
Description
Specifies the optional description of the current section.
Type
Displays the type of data source from which the section data was extracted. Either
from an existing TIN surface;
surface; or

, which indicates from a corridor;

, which indicates

, which indicates from a corridor

, which indicates from an existing pipe network.

Data Source
Displays the name of the data source from which the current section was sampled.
Update Mode
Specifies the type of update mode for the section. Select Dynamic to specify that the section data updates
dynamically if the position of the sample line associated with the section changes or the data source
geometry changes.
Layer
Specifies the drawing layer that contains the current section associated with the selected sample line
group. Click in the Layer column to open the Layer Selection dialog box (page 2222). Select a layer in the
Layers table.
Style
Specifies the name of the style of the section. Click in this column to open the Select Style dialog box
(page 2021). Select a style in the list or use the standard controls to create a new style, copy or edit the
current style selection, or pick a style from the drawing.
Left Offset
Displays the left offset value of the current section.
Right Offset
Displays the right offset value of the current section.
Minimum Elevation
Displays the minimum elevation of the section associated with the selected sample line group.
Maximum Elevation
Displays the maximum elevation of the section associated with the selected sample line group.
Station
Displays the station value of the sample line along which the section is sampled.
Related procedures:
■

Editing Section Properties (page 1256)

Section Sources Dialog Box
Use this dialog box to resample sections of a sample line group.
Sample Line Group Name
Displays the name of the sample line group being resampled.
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Alignment Name
Displays the name of the parent alignment of the sample line group.
Add >>
Adds the specified sample line group to the Sampled Sources table.
Remove <<
Removes the specified sample line group from the Sampled Sources table.

Sampled Sources Table
Name
Specifies the name of the sampled source.
Style
Specifies the style of the sampled source.
Layer
Specifies the drawing layer that contains the sampled source.
Update Mode
Specifies the type of update mode for the sampled source. Select Dynamic if the position of the sample
line changes.
Related procedures:
■

Resampling Section Sources (page 1253)

Section Style Dialog Box
Use this dialog box to define a section style, which controls the way a section is displayed in a drawing.
See also:
■

Creating and Editing Section Styles (page 1236)

Information Tab (Section Style Dialog Box)
Use this tab to display administrative data and edit primary information about the section style, such as its
name and description.
This tab also contains information about who created or modified the section style and the date of these
events. The following fields can be modified:
Name
Specifies the name of the selected section style.
Description
Specifies the optional description of the selected section style.
Related procedures:
■

Creating and Editing Section Styles (page 1236)
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Display Tab (Section Style Dialog Box)
Use this tab to edit settings for the visibility and format styles of section components, such as segments and
points.
On the Display tab, you can use the ByLayer or ByBlock reference settings to set Color, Linetype, Lineweight,
and Plot Style values. Reference settings are indirect and require some planning.
For more information, see Display Tab (Style Dialog Box) (page 2017).
Related procedures:
■

Creating and Editing Section Styles (page 1236)

Summary Tab (Section Style Dialog Box)
Use this tab to edit the settings for the section style.
For more information, see Summary Tab (Style Dialog Box) (page 2020).
Related procedures:
■

Creating and Editing Section Styles (page 1236)

Section View Bands Dialog Box
Use this dialog box to specify the source surfaces for data band annotation.

List Of Bands
Location
Specifies the location in the section view of data band annotation.
Band Type
Displays the type of data band specified in the Band Set properties.
Style
Specifies the style for the band in the Band Set properties. Click
(page 2021).

to open the Select Style dialog box

Surface 1
Specifies a surface sampled by the sample line that supplies the data for the band, including any corridor
surface.
Surface 2
Specifies an additional surface sampled by the sample line that supplies the data for the band, including
any corridor surface. Not used for Section Segment type data bands.
Related procedures:
■

Creating Section Views (page 1258)

■

Section View Bands (page 1245)

Section View Band Set Dialog Box
Use this dialog box to create a set of data band styles for section views.
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A band style set is useful when you want to apply the same set of data bands to a number of section views.
After naming your band set on the Information tab, use the Bands tab to specify the bands included in the
set and their location above or below the section view grid.
See also:
■

Section View Bands (page 1245)

Information Tab (Section View Band Set Dialog Box)
Use this tab to record basic information about the band set, such as its name and description.
This tab also contains information about who created or modified the section view style and the date of
these events. The following fields can be modified:
Name
Specifies the name of the band style set.
Description
Specifies the optional description of the selected band style set.
Related procedures:
■

Section View Bands (page 1245)

Bands Tab (Section View Band Set Dialog Box)
Use this tab to specify which data bands are included in the set, along with their styles and positions relative
to the section view grid.
Band Type
Specifies the type of data band to add to the set.
Select Band Style
Specifies the style for the band.
To edit a style or create a new one, click
and select from the list of operations. For more information,
see Select Style dialog box (page 2021) and Section Data Band Style dialog box (page 2528). To examine the
details of an existing style, select the style name in the list. Click
Detail dialog box (page 2020).

. For more information, see the Style

Add>>
Adds the specified data band type to the style set. Before clicking, ensure that the settings are correct for
data band type, style, and location.

List Of Bands
Location
Specifies either the top or bottom of the section view. For the current location, the table below this field
shows the bands in the current band style set.
Band Type
Displays the data band type.
Style
Specifies the style for the band type.
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Description
Specifies the optional description of the band style.
Gap
Specifies the distance in plotted units between the current data band and the previous data band (or the
nearest section view axis).
For bands below the section view grid, the specified gap is measured from the top of the current band to
the bottom of the previous band (or the section view bottom axis, if the current band is the first one).
Similarly, for bands above the section view grid, the specified gap is measured from the bottom of the
current band to the top of the previous band (or the section view top axis, if the current band is the first
one).
Major Interval
Specifies the section view data band major interval distance.
Minor Interval
Specifies the section view data band minor interval distance.
Label End Offset
Specifies whether or not the end of the band is labeled.
Weeding
Used only for labels at vertical geometry points on Section Data bands. Vertical geometry points or grade
breaks that are closer than the weeding factor are removed, making it easier to read the remaining labels.
Enter a positive number to specify a label exclusion distance.
Stagger Labels
Specifies the location of the label staggering line: No staggering, Stagger both sides, Stagger to right, or
Stagger to left.
Stagger Line Height
Specifies the height of the label stagger line.

Moves the selected data band up in the list.
NOTE The order in this list is the order in which the bands appear below/above the section view.

Moves the selected data band down in the list.

Deletes the selected data band from the list and removes it from the section view.
Match Major/Minor Increments to Vertical Grid Intervals
Specifies if the section data band major/minor intervals for section views matches the section view style’s
major/minor grid spacing interval distances. Select the check box to match major/minor increments to
vertical grid intervals. If this check box is selected, the major/minor interval fields in the List of Bands
table are unavailable.
Related procedures:
■

Section View Bands (page 1245)
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Section View Group Bands Dialog Box
Use this dialog box to edit properties that manage the last applied data bands for the section view group.
This dialog box is accessed from the Section View Group Properties dialog box and displays the last applied
set of bands.
Band Type
Specifies which type of data band to add to the section view. Select a band type in the list: either Section
Data or Section Segment.
Select Band Style
Specifies the style for the band. Select a band style in the list.

Creates, copies, or edits a style using the Section Data Band Style dialog box (page 2528). Click the down
arrow to display the style selection menu:
■

Create New: Creates a new style.

■

Copy Current Selection: Copies the current style.

■

Edit Current Selection: Edits the current style.

Displays details about an existing style. Select the style by name in the list. Click to open the Style Detail
dialog box (page 2020). Preview the style and creation information.
Add>>
Adds the specified data band type to the set for this section view. Before clicking, ensure that the settings
are correct for data band type, style, and location.

List Of Bands
Location
Specifies the location where you want to draw the data band relative to the current section view.
■

Bottom Of Section View: Draws the data band at the bottom (below) the current section view.

■

Top Of Section View: Draws the data band at the top (above) the current section view.

Band Type
Displays the current data band type that was added using the Band Type list.
Style
Specifies the name of the band style that was added using the Select Band Style list. To change the style,
click in this column to open the Select Style dialog box (page 2021). Select a band style in the list or use the
standard controls to create a new style, copy or edit the current style selection, or pick a style from the
drawing.
Description
Specifies the optional description of the band style.
Gap
Specifies the distance in plotted units between the current data band and the previous data band (or the
nearest section view axis). Enter a positive gap value in plotted units.
■

For bands below the section view grid, the specified gap is measured from the top of the current band
to the bottom of the previous band (or the section view bottom axis, if the current band is the first
one).
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■

For bands above the section view grid, the specified gap is measured from the bottom of the current
band to the top of the previous band (or the section view top axis, if the current band is the first one).

Label Start Offset
Specifies whether or not the start end of the band is labeled.
Label End Offset
Specifies whether or not the end of the band is labeled.
Surface1/Surface2
Specifies two surfaces that are used by the band styles to annotate either elevations or the elevation
differences between the two sections. Select the surface(s) by name in the list.
Weeding
Used only for labels at vertical geometry points on Section Data bands. Vertical geometry points or grade
breaks that are closer than the weeding factor are removed, making it easier to read the remaining labels.
Enter a positive number to specify a label exclusion distance.
Stagger Labels
Specifies the location of the data band label staggering line: No staggering, Stagger both sides, Stagger to
right, or Stagger to left.
Stagger Line Height
Specifies the height of the data band label stagger line.

Moves the selected data band up in the list.
NOTE The order in this list is the order in which the bands appear below/above the section view.

Moves the selected data band down in the list.

Deletes the selected data band from the list and removes it from the section view.
Match Major/Minor Increments to Vertical Grid Intervals
Specifies if the section data band major/minor intervals for section views matches the section view style’s
major/minor grid spacing intervals. Select the check box to match major/minor increments to vertical
grid intervals.
Import Band Set
Imports a band set. In the Band Set dialog box (page 2021), select an existing band set to be added to the
current section view in the list.
Save As Band Set
Saves a new band set. Click to open the Section View Band Set dialog box (page 2535). Save the current list
of bands as a band set for use with other section views.
Related procedures:
■

Adding Section View Bands (page 1245)
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Section View Group Properties Dialog Box
Use this dialog box to edit properties of the selected section view group, such as its name, the name of its
parent alignment, properties of its constituent section views, and properties of the displayed sections.
In the Sections tab, you edit all options for the entire group.
In the Section Views tab, you can only edit section view names individually. You can edit section view styles
individually or for the entire section view group. You can only set band set, volume tables and profile grade
settings for the group.
You cannot edit station location, or the locations of Start and End stations.
See also:
■

Editing Section View Group Properties (page 1264)

Section Views Tab (Section View Group Properties Dialog Box)
Use this tab to edit properties of the section views in the selected sample line group.
Sample Line Group Name
Specifies the name of the sample line group being resampled.
Alignment Name
Specifies the name of the parent alignment of the sample line group.

Section View List
Section View
Displays the names of section views arranged in an expandable tree or hierarchy.
Group Plot Style
Specifies the name of the plot style of the section view associated with the selected sample line group.
Click in this column to open the Select Style dialog box (page 2021). Select a style in the list or use the
standard controls to create a new style, copy or edit the current style selection, or pick a style from the
drawing.
Style
Specifies the name of the style of the section view associated with the selected sample line group. Click
in this column to open the Select Style dialog box. Select a style in the list or use the standard controls
to create a new style, copy or edit the current style selection, or pick a style from the drawing.
Change Band Set
Displays the last applied set of bands for the current section view group. Click in this column to open the
Section View Group Bands dialog box. Use this dialog box to edit properties that manage the data bands
for the section view group.
Change Volume Tables
Specifies the volume table(s) to be drawn. Click in this column to open the Change Volume Table dialog
box (page 2561). A material list must be exist for the drawing before any volume table can be created.
Profile Grade
Specifies the grid lines displayed at offset alignments and other profiles within the range of section view
extents. Click in this column to open the Profile Grade Points dialog box (page 2512).
Station
Displays the station value of the sample line along which this section view is created.
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Start Station
Displays the beginning station in the range.
End Station
Displays the end station in the range.
Related procedures:
■

Editing Section View Group Properties (page 1264)

Sections Tab (Section View Group Properties Dialog Box)
Use this tab to edit section view display options.

Edit Section Options Table
Draw
Specifies whether the section is drawn in the current section view. Select the check box to draw the section
in the current section view.
Clip Grid
Specifies whether the grid lines in the current section view are clipped to the section (horizontal and/or
vertical depending on the section view style definition). Select the radio button to clip the grid lines in
the section view to the section.
Change Labels
Specifies the style set from which the section labels will be drawn. Click in this column to open the Select
Style dialog box (page 2021).
Style
Specifies the section style. Click in this column to open the Select Section Style dialog box.
Override Style
Specifies the style for a section. Select the check box to open the Select Section Style dialog box.
Related procedures:
■

Editing Section View Group Properties (page 1264)

Sheets Tab (Section View Group Properties Dialog Box)
This tab displays information about how the section view group was created when using the Create Multiple
Views command.
■

If you used the Production placement option, this tab shows which template and layout you selected.

■

If you used the Draft placement option, this tab does not appear.

■

If the section views were created in earlier versions of AutoCAD Civil 3D, this tab will show which Sheet
Style you used.

Sheet Layout
Drawing Template File Name
Displays the template that was used when the section views were created. The template cannot be changed
after the section views are created. To select a new template, re-run the Create Multiple Views command
and select a different template.
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NOTE The Drawing Template File Name and Selected Layout options are displayed only if the section views
were created using the Production option of the Create Multiple Views command.
Selected Layout
Displays the layout within the selected template that was used when the section views were created. The
layout cannot be changed after the section views are created. To select a new layout, re-run the Create
Multiple Views command and select a different layout.
Sheet Style
Enables you to change the Sheet Style that is used for the section views.
NOTE This option is displayed only for section views that were created in AutoCAD Civil 3D 2010 or earlier
that reference a page setup in the current drawing.
Related procedures:
■

To create multiple section views (page 1259)

■

Editing Section View Group Properties (page 1264)

Section View Properties Dialog Box
Use this dialog box to edit properties of the selected section view, such as its name, grid dimensions, and
properties of the displayed sections and data bands.
See also:
■

Editing Section View Properties (page 1263)

■

Creating and Editing Section Views (page 1258)

Information Tab (Section View Properties Dialog Box)
Use this tab to edit primary information about the selected section view.
Name
Specifies the name of the section view. The default format is <start-station > (n).
<start-station> is the name of the beginning station in the section view.
n is an integer greater than or equal to one, which increments as section views are created in the drawing.
Description
Specifies the optional description of the section view.
Object Style
Specifies the name of the style used by the section view.

Creates, copies, or edits a style using the Section View Style dialog box (page 2550). Click the down arrow
to display the style selection menu:
■

Create New: Creates a new style.

■

Copy Current Selection: Copies the current style.

■

Edit Current Selection: Edits the current style.

■

Pick From Drawing: Prompts you to select a style directly from the drawing. The selected style becomes
the current style.
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Displays details about an existing style. Select the style by name in the list. Click to open the Style Detail
dialog box (page 2020). Preview the style and creation information.
Show Tooltips
Controls whether tooltips are displayed for the object in the drawing (not over toolbar icons).
Related procedures:
■

Editing Section View Properties (page 1263)

Offsets Tab (Section View Properties Dialog Box)
Use this tab to display the properties of the selected section view and the section view grid on which sections
are displayed.
Sample Line
Displays the name of the parent sample line for the current section view.
Sample Line Group
Displays the name of the parent sample line group for the current section view.
Alignment
Displays the name of the parent horizontal alignment for the current section view.

Offset Range
Automatic
Specifies that the offset range is set automatically. The lengths of the left and right swath widths are
displayed in the fields next to the selection.
User Specified
Specifies that the offset range is set by the user. Specify the lengths of the left and right swath widths in
the fields next to the selection.
Left
Specifies the offset length of the left swath width.
Right
Specifies the offset length of the right swath width.
Related procedures:
■

Editing Section View Properties (page 1263)

Elevations Tab (Section View Properties Dialog Box)
Use this tab to view or specify the elevation properties of the selected section view and the section view grid
on which sections are displayed.

Elevation Range
Automatic
Specifies that the elevation range is set automatically. The minimum and maximum heights are displayed
in the fields next to the selection.
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User Specified
Specifies that the elevation range is set by the user. Specify minimum and maximum heights in the fields
next to the selection.
Minimum
Specifies the minimum height of the elevation.
Maximum
Specifies the maximum height of the elevation.
Related procedures:
■

Editing Section View Properties (page 1263)

Sections Tab (Section View Properties Dialog Box)
Use this tab to edit properties that determine which sampled sections are drawn in the section view.
Name
Displays the name of the current section.
Draw
Specifies whether the section is drawn in the current section view. Select the check box to draw the section
in the current section view.
Clip Grid
Specifies whether the grid lines in the current section view are clipped to the section (horizontal and/or
vertical depending on the section view style definition). Select the check box to clip the grid lines in the
section view to the section.
Description
Specifies the optional description of the current section.
Type
Displays the type of data source from which the section data was extracted. Either
from an existing TIN surface;
surface; or

, which indicates from a corridor;

, which indicates

, which indicates from a corridor

, which indicates from an existing pipe network.

Data Source
Displays the name of the data source from which the current section is sampled.
Update Mode
Specifies the type of update mode for the section. Select Dynamic to specify that the section data updates
dynamically if the position of the sample line associated with the section changes or the data source
(surface or corridor) geometry changes.
Layer
Specifies the drawing layer that contains the current section view associated with the selected sample line
group. Click in this column to open the Layer Selection dialog box (page 2222). Select a layer in the Layers
table.
Style
Specifies the name of the style of the section. Click in the Style column to open the Select Style dialog
box (page 2021). Select a style in the list or use the standard controls to create a new style, copy or edit the
current style selection, or pick a style from the drawing.
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Override Style
Specifies whether the current style is overridden in the current section view. If the style is overridden, the
cell is selected. The name of the override style is displayed.
Labels
Specifies the section label style. In the Labels column, click <Edit...> to open the Section Labels dialog box
(page 2207). Select the label style.
Left Offset
Displays the left offset value of the current section.
Right Offset
Displays the right offset value of the current section.
Minimum Elevation
Displays the minimum elevation of the section associated with the selected sample line group.
Maximum Elevation
Displays the maximum elevation of the section associated with the selected sample line group.
Station
Displays the station value of the sample line along which the section is sampled.
Related procedures:
■

Editing Section View Properties (page 1263)

Bands Tab (Section View Properties Dialog Box)
Use this tab to edit properties that manage the data bands for the section view.
Band Type
Specifies which type of data band to add to the section view. Select a band type in the list: either Section
Data or Section Segment.
Select Band Style
Specifies the style for the band. Select a band style in the list.

Creates, copies, or edits a style using the Section Data Band Style dialog box (page 2528). Click the down
arrow to display the style selection menu:
■

Create New: Creates a new style.

■

Copy Current Selection: Copies the current style.

■

Edit Current Selection: Edits the current style.

Displays details about an existing style. Select the style by name in the list. Click to open the Style Detail
dialog box (page 2020). Preview the style and creation information.
Add>>
Adds the specified data band type to the set for this section view. Before clicking, ensure that the settings
are correct for data band type, style, and location.
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List Of Bands
Location
Specifies the location where you want to draw the data band relative to the current section view.
■

Bottom Of Section View: Draws the data band at the bottom (below) the current section view.

■

Top Of Section View: Draws the data band at the top (above) the current section view.

Band Type
Displays the current data band type that was added using the Band Type list.
Style
Specifies the name of the band style that was added using the Select Band Style list. To change the style,
click in this column to open the Select Style dialog box (page 2021). Select a band style in the list or use the
standard controls to create a new style, copy or edit the current style selection, or pick a style from the
drawing.
Description
Specifies the optional description of the band style.
Gap
Specifies the distance in plotted units between the current data band and the previous data band (or the
nearest section view axis). Enter a positive gap value in plotted units.
■

For bands below the section view grid, the specified gap is measured from the top of the current band
to the bottom of the previous band (or the section view bottom axis, if the current band is the first
one).

■

For bands above the section view grid, the specified gap is measured from the bottom of the current
band to the top of the previous band (or the section view top axis, if the current band is the first one).

Label Start Offset
Specifies whether or not the start end of the band is labeled.
Label End Offset
Specifies whether or not the end of the band is labeled.
Section1/Section2
Specifies two sections that are used by the band styles to annotate either elevations or the elevation
differences between the two sections. Select the section(s) by name in the list.
NOTE The Section 2 column is not available for a Segment band type row.
Weeding
Used only for labels at vertical geometry points on Section Data bands. Vertical geometry points or grade
breaks that are closer than the weeding factor are removed, making it easier to read the remaining labels.
Enter a positive number to specify a label exclusion distance.
Stagger Labels
Specifies the location of the label staggering line: No staggering, Stagger both sides, Stagger to right, or
Stagger to left.
Stagger Line Height
Specifies the height of the label stagger line.

Moves the selected data band up in the list.
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NOTE The order in this list is the order in which the bands appear below/above the section view.

Moves the selected data band down in the list.

Deletes the selected data band from the list and removes it from the section view.
Match Major/Minor Increments to Vertical Grid Intervals
Specifies if the section data band major/minor interval distances for section views matches the section
view style’s major/minor grid spacing intervals. Select the check box to match major/minor increments
to vertical grid intervals. If this check box is selected, the major/minor interval fields are unavailable.
Import Band Set
Imports a band set. In the Band Set dialog box (page 2021), select an existing band set to be added to the
current section view in the list.
Save As Band Set
Saves a new band set. Click to open the Section View Band Set dialog box (page 2535). Save the current list
of bands as a band set for use with other section views.
Related procedures:
■

Editing Section View Properties (page 1263)

■

Adding Section View Bands (page 1245)

Volume Tables Tab (Section View Properties Dialog Box)
Use this tab to set volume table properties for the section view.
Use the following controls to specify the volume table types to draw:
Type
Specifies the type of the volume table(s).
Select Table Style
Specifies the style of the volume table. Standard buttons are also provided to create or edit a label style.
Add >>
Adds a volume table to the list.

List Of Volume Tables
Table Type
Displays the current table type.
Style
Specifies the name of the table style that was added using the Select Table Style list. To change the style,
click in this column to open the Select Style dialog box (page 2021). Select a band style in the list or use the
standard controls to create a new style, copy or edit the current style selection, or pick a style from the
drawing.
Material List
Specifies the material list for the volume table.
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Materials
Click

to specify the materials for the volume table.

Layer
Specifies the drawing layer that contains the sampled source.
Split
Specifies whether the layer is split.
Gap
Specifies the distance in plotted units between the current data band and the previous data band (or the
nearest section view axis). Enter a positive gap value in plotted units.
Reactivity Mode
Specifies the type of update mode for the section. Select Dynamic to specify that the section data updates
dynamically if the position of the sample line associated with the section changes or the data source
(surface, corridor, or pipe) geometry changes.

Position Of Table(s) Relative To Section View
Section View Anchor
Specifies the section view anchor (Top/Middle/Bottom, Left/Center/Right).
Table Anchor
Specifies the location of the table anchor (Top/Middle/Bottom, Left/Center/Right).
Table Layout
Specifies whether the layout of the tables will be horizontal or vertical, in relation to the section view.
X Offset
Specifies the distance in plotted units to move the title away from the position set by the table anchor.
Enter a positive number to move the title right, or a negative number to move it left.
Y Offset
Specifies the distance in plotted units to move the title away from the position set by the table anchor.
Enter a positive number to move the title up, or a negative number to move it down.
Related procedures:
■

Editing Section View Properties (page 1263)

Profile Grade Lines Tab (Section View Properties Dialog Box)
Use this tab to select a profile and display its elevation by marking it at the appropriate offset and elevation
in the section view.
Alignment
Specifies the parent alignment whose profile grade point is to be displayed in this section view. Select an
alignment from the drop-down list or click

to pick an alignment from the drawing.

Add>>
Adds the profile grade point for the currently selected alignment to the list.

Deletes the highlighted profile grade point from the list. The profile grade point will no longer be displayed
in the section view.
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List Of Profile Grade Points
Alignment
Displays the name of the parent alignment whose profile grade point is marked in this section view.
Show
Specifies whether the marker is visible in the section view (that is, without having to edit the marker style
or layer).
Profile
Displays the name of the profile whose location, with respect to the current section view, is marked.
Marker Style
Displays the marker style used for the profile grade point.
Related procedures:
■

Editing Section View Properties (page 1263)

Projections Tab (Section View Properties Dialog Box)
Selecting the Projection Properties command opens the Projections Tab of the Section View Properties dialog
box.
Use this tab to edit the elevation or style of a projected object, or to remove or add projected objects.
If no objects are projected in the section view, then this tab is not displayed in the dialog box.
Name
Displays the names and categories of objects that are displayed in the current section view.
To remove an object from the section view, click the check box

to clear it.

Style
Specifies the display style of each projected object. Click a single entry to change it, or click <set all> for
a category to select a style for all objects of that category.
NOTE Multipurpose Projection Styles are used for AutoCAD objects. Each Projection Style includes settings for
all types of AutoCAD objects that can be projected. AutoCAD Civil 3D object styles control the appearance of
AutoCAD Civil 3D objects that are projected. Points use the point marker style. Feature lines use the feature line
style Profile and Section tab settings. Survey figures use the figure style Profile and Section tab settings. For
more information, see Editing the Style of a Projected Object (page 1220).
Elevation Options
Specifies whether the elevation of the projected object is determined by its elevation in plan view or
manually controlled in the section view. Click a single entry to change it, or click <set all> for a category
to select an option for all objects of that category.
Elevation Value
Specifies the actual elevation of the projected object. Click <set all> for a category to select an elevation
for all objects of that category.
Pick Objects
Click

to select objects in the drawing and add them to the section view.

Related procedures:
■

Editing Section View Properties (page 1263)
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Section View Style Dialog Box
Use this dialog box to define a section view style, which controls the way a section view is displayed in a
drawing.
You can change the graph, grid, title, axes ticks, and text. Select which elements to display.
See also:
■

Creating and Editing Section View Styles (page 1237)

■

Creating and Editing Section Views (page 1258)

Information Tab (Section View Style Dialog Box)
Use this tab to display administrative data and edit primary information about the section view style, such
as its name and description.
This tab also contains information about who created or modified the section view style and the date of
these events. The following fields can be modified:
Name
Specifies the name of the selected section view style.
Description
Specifies the optional description of the selected section view style.
Related procedures:
■

Creating and Editing Section View Styles (page 1237)

Graph Tab (Section View Style Dialog Box)
Use this tab to edit settings for vertical scale.

Vertical Scale
Use the controls in this area to specify the elevation values, in order to improve visibility in the section view.
Specify the section view vertical scale in either of the following ways:
■

By Vertical Exaggeration — Enter a value in the Vertical Exaggeration field. The Vertical Scale value is
calculated automatically.
The Current Horizontal Scale (HS) factor of the drawing is divided by the Vertical Scale value (VS) to
obtain the profile view Vertical Exaggeration value (VX).

For example, if the Current Horizontal Scale is 50, and you want the profile view’s Vertical Scale to be
1”=10’, then set the Vertical Exaggeration to 5.

■

By Vertical Scale — Select a scale from the Vertical Scale list. Alternatively, enter a custom value in the
Custom field. The Vertical Exaggeration value will be calculated automatically.
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Vertical Scale
The section view vertical scale. Select a vertical scale from the list, or enter a custom scale in the Custom
Scale field.
Vertical Scale (VS) = Current Horizontal Scale (HS) divided by Vertical Exaggeration (VX)

Custom Scale
Specifies the current Vertical Scale factor. Enter a value in this field to specify a scale factor that is not
provided in the Vertical Scale list.
Current Horizontal Scale
The overall drawing Scale specified in the Drawing Settings dialog box (page 2073). This field is not editable.
The horizontal scale must be changed in the Drawing Settings dialog box.
Vertical Exaggeration
Specifies by how much the elevation values increase in the section view for greater visibility. Enter either
1 for no increase in scale or a larger number to increase the scale. The elevation values are multiplied by
this value, so a larger number increases the amount of exaggeration in the section view.
Related procedures:
■

Creating and Editing Section View Styles (page 1237)

Grid Tab (Section View Style Dialog Box)
Use this tab to specify clipping, padding, and axis offset options on the section view grid.

Grid Options

Clip Vertical Grid
Specifies that vertical grid lines are only drawn below the section line. If Clip To Highest Section(s) is not
selected, the vertical lines will be drawn only below the section view line that has Clip Grid selected on
the Sections tab (page 2544) in the Section View Properties dialog box.
Clip To Highest Section(s): Specifies that vertical section view grid lines will be drawn to the highest of
all displayed profiles.
Omit Grid In Padding Areas: Specifies that vertical profile view grid lines will not be drawn in the padding
areas.

Clip Horizontal Grid
Specifies that horizontal grid lines are only drawn below the section line. If Clip To Highest Section(s) is
not selected, the horizontal lines will be drawn only below the section line that has Clip Grid selected on
the Sections tab in the Section View Properties dialog box.
Clip To Highest Section(s): Specifies that vertical section view grid lines will be drawn to the highest of
all displayed profiles.
Omit Grid In Padding Areas: Specifies that horizontal section view grid lines will not be drawn in the
padding areas.
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Grid Padding

Grid Padding (Major Grids)
Specifies the distance (in major grid blocks) to add to the extents of the section view in relation to the
profiles it contains.
Above Maximum Elevation
Specifies the number of grid blocks that the section view extends above the maximum section elevation.
This enables the graph to be taller than the extents of the section drawn in the profile view.
Below Datum
Specifies the number of grid blocks that the section view extends below the datum or minimum section
elevation. This enables the graph to extend below the extents of the section drawn in section view.
To Left
Specifies the number of major grids to place before the left-most station value of the alignment. This
enables the graph to be wider than the extents of the section drawn in the section view.
To Right
Specifies the number of major grids to place after the right-most station value of the alignment. This
enables the graph to be wider than the extents of the section drawn in the section view.

Axis Offset
NOTE The axis offset distance is specified in plotted units, based on the Drawing Units and Scale settings specified
on the Units and Zone tab (page 2073) of the Drawing Settings dialog box.

Axis Offset (Plotted Units)
Specifies the distance (in plotted units) to offset the section view’s horizontal and vertical axes from the
grid extents (including padding). This creates a blank area between the axis and the grid.
Above Maximum Elevation
Specifies the distance to offset the horizontal axis above the vertical extent.
Below Datum
Specifies the distance to offset the horizontal axis below the vertical extent.
To Left
Specifies the distance to offset the horizontal axis to the left of the horizontal extent.
To Right
Specifies the distance to offset the horizontal axis to the right of the horizontal extent.
Related procedures:
■

Creating and Editing Section View Styles (page 1237)

Title Annotation Tab (Section View Style Dialog Box)
Use this tab to specify settings for the graph view and axis titles.
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Graph View Title
Text Style
Specifies the text style for the section view title.
Text Height
Specifies the current text height in drawing units.
Title Content
Specifies the text elements used to compose the title, such as horizontal alignment (HA) name and station
range. To change title format or content, click
2199).

to open the Text Component Editor dialog box (page

Title Position
These controls specify the position of the profile view title. Use Location and Justification settings for basic
positioning, then X and Y offsets for more precise placement, if necessary.
Location
Specifies the location of the title in relation to the section view grid: either top, bottom, left, or right.
Justification
Specifies the justification (alignment) of the title. If Location is top or bottom, justification values are left,
right, or center. If Location is right or left, justification values are top, middle, or bottom.
X Offset
Specifies a horizontal offset from the position set by the Location and Justification values. Enter a positive
number to move the title right or a negative number to move it left.
Y Offset
Specifies a vertical offset from the position set by Location and Justification values. Enter a positive number
to move the title up or a negative number to move it down.
Border Around The Title
Specifies whether a border line is drawn around the title block.
Gap
Specifies the distance between the title and its border.

Axis Title Text
Separate titles may be displayed at each of the axes. Use the radio buttons around the graphic to select the
axis title to edit. Configure title settings and click Apply. Repeat that process with each axis title.
NOTE The Axis Title selections do not control axis title visibility. Visibility controls for all section components are
located on the Display tab (page 2557).

Axis Title Text
Specifies which axis title is being controlled by the text editing tools.
Title Text
Specifies the title text for the horizontal axis. To change the title content, click
Component Editor dialog box (page 2199).

to open the Text

Location
Specifies the location of the title on the axis: either Left, Center, or Right. For more precise control, use
the X and Y Offsets.
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Rotation
Specifies the angle for the title. Enter a positive or negative value. The angle direction is always
counterclockwise. If the value is zero (0), the title is not rotated.
Text Style
Specifies a text style for use in the horizontal axis title.
Text Height
Specifies the title text height (in plotted units).
X Offset
Specifies a horizontal offset from the Location setting. Enter a positive number to move the title right or
a negative number to move it left.
Y Offset
Specifies a vertical offset from the Location setting. Enter a positive number to move the title up or a
negative number to move it down.
Related procedures:
■

Creating and Editing Section View Styles (page 1237)

Horizontal Axes Tab (Section View Style Dialog Box)
Use this tab to edit settings for the section view style, such as the title format, use of tick marks, and
annotations on the horizontal axes of the section view.
After you configure horizontal axis title and tick details, click Apply. Later, you can change the Select Axis
setting and configure another axis on the opposite side of the grid.
Select Axis To Control
Click either the Top or Bottom radio button to select that axis.

Major Tick Details
Interval
Specifies the spacing of major ticks on the horizontal axis, using the actual ground units. Enter a positive
value in ground units.
Tick Size
Specifies the height of the actual tick on the horizontal axis, using plotted units. Enter a positive value in
plotted units.
Tick Justification
Specifies whether the tick is justified Top, Bottom or Center.
Text Height
Specifies the height of text used to label major ticks on the horizontal axis, using in plotted units. Enter
a positive value in plotted units.
Tick Label Text
Specifies a property with which the tick is labeled. To change the text format or content, click
display the Text Component Editor dialog box (page 2199).
Text Style
Specifies the style of the tick label text.
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to

Rotation
Specifies the angle for the tick label. Enter a positive or negative value.The angle direction is always
counterclockwise. If the value is zero (0), the label is not rotated.
X Offset
Specifies a horizontal offset for the tick label from the bottom of the tick.
Y Offset
Specifies a vertical offset for the tick label from the bottom of the tick.

Minor Tick Details
Interval
Specifies the spacing of minor ticks on the horizontal axis, using the actual ground units. Enter a positive
value in ground units.
Tick Size
Specifies the height of the actual tick on the horizontal axis, using plotted units. Enter a positive value in
plotted units.
Tick Justification
Specifies whether the tick is justified Top, Bottom or Center.
Text Height
Specifies the height of text used to label minor ticks on the horizontal axis, using plotted units. Enter a
positive value in plotted units.
Tick Label Text
Specifies a property with which the tick is labeled. To change the text format or content, click
display the Text Component Editor dialog box.

to

Text Style
Specifies the style of the tick label text.
Rotation
Specifies the angle for the tick label. Enter a positive or negative value.The angle direction is always
counterclockwise. If the value is zero (0), the label is not rotated.
X Offset
Specifies a horizontal offset for the tick label from the bottom of the tick.
Y Offset
Specifies a vertical offset for the tick label from the bottom of the tick.

Horizontal Geometry Tick Details
Tick Size
Specifies the height of the actual tick on the horizontal axis, using plotted units. Enter a positive value in
plotted units.
Tick Justification
Specifies whether the tick is justified Top, Bottom or Center.
Text Height
Specifies the height of text used to label minor ticks on the horizontal axis, using plotted units. Enter a
positive value in plotted units.
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Tick Label Text
Specifies a property with which the tick is labeled. To change the text format or content, click
display the Text Component Editor dialog box.

to

Text Style
Specifies the style of the tick label text.
Rotation
Specifies the angle for the tick label. Enter a positive or negative value.The angle direction is always
counterclockwise. If the value is zero (0), the label is not rotated.
X Offset
Specifies a horizontal offset for the tick label from the bottom of the tick.
Y Offset
Specifies a vertical offset for the tick label from the bottom of the tick.
Related procedures:
■

Creating and Editing Section View Styles (page 1237)

Vertical Axes Tab (Section View Style Dialog Box)
Use this tab to edit settings for the section view style, such as the title location and format, use of tick marks,
and annotations, on the vertical axis of the section view.
After you configure vertical axis title and tick details, click Apply. Later, you can change the Select Axis
setting and configure another axis on the opposite side of the grid.
Select Axis To Control
Click either the Left, Center or Right radio button to select that axis.

Major Tick Details
Interval
Specifies the spacing of major ticks on the vertical axis. Enter a positive value in ground units.
Tick Size
Specifies the length of the actual tick on the vertical axis, using plotted units. Enter a positive value in
plotted units.
Tick Justification
Specifies whether the tick is justified Left, Right or Center.
Text Height
Specifies the height of text used to label major ticks on the vertical axis in plotted units. Enter a positive
value in plotted units.
Tick Label Text
Specifies a property with which the tick is labeled. To change the text format or content, click
display the Text Component Editor dialog box (page 2199).

to

Text Style
Specifies the style of the tick label text.
Rotation
Specifies the angle for the tick label. Enter a positive or negative value.The angle direction is always
counterclockwise. If the value is zero (0), the label is not rotated.
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X Offset
Specifies a horizontal offset for the tick label from the end of the tick.
Y Offset
Specifies a vertical offset for the tick label from the end of the tick.

Minor Tick Details
Interval
Specifies the spacing of minor ticks on the vertical axis, using the actual ground units. Enter a positive
value in ground units.
Tick Size
Specifies the length of the actual tick on the vertical axis, using plotted units. Enter a positive value in
plotted units.
Tick Justification
Specifies whether the tick is justified Left, Right or Center.
Text Height
Specifies the height of text used to label minor ticks on the vertical axis, using plotted units. Enter a
positive value in plotted units.
Tick Label Text
Specifies a property with which the tick is labeled. To change the text format or content, click
display the Text Component Editor dialog box.

to

Text Style
Specifies the style of the tick label text.
Rotation
Specifies the angle for the tick label. Enter a positive or negative value.The angle direction is always
counterclockwise. If the value is zero (0), the label is not rotated.
X Offset
Specifies a horizontal offset for the tick label from the end of the tick.
Y Offset
Specifies a vertical offset for the tick label from the end of the tick.
Related procedures:
■

Creating and Editing Section View Styles (page 1237)

Display Tab (Section View Style Dialog Box)
Use this tab to edit settings for the visibility and format styles of section view components, such as titles,
axes annotations, tick marks, and grid options.
For more information, see Display Tab (Style Dialog Box) (page 2017).
Related procedures:
■

Creating and Editing Section View Styles (page 1237)
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Summary Tab (Section View Style Dialog Box)
Use the Summary tab to edit settings for the section style.
For more information, see Summary Tab (Style Dialog Box) (page 2020).
Related procedures:
■

Creating and Editing Section View Styles (page 1237)

Select Page Layout Dialog Box
Use this dialog box to select a page layout for the sheet style.
This dialog box is accessed from the Summary tab of the Sheet Style dialog box. Click in the Page Layout
value cell and then click

.

Page Setups
Default (Layout)
Plots section views on a sheet using the Default (Layout) format.
Default (Model)
Plot section views on a sheet using the Default (Model) format.
For more information about the sheet style, see Sheet Style Dialog Box (page 2559).

Sheet Properties Dialog Box
Use this dialog box to edit properties of a sheet used for multiple section views.
Change the name and description of sheets created in AutoCAD Civil 3D 2011. For multiple section views
created in earlier versions of AutoCAD Civil 3D, you can also change the sheet style they use.
NOTE Multiple section views created in AutoCAD Civil 3D 2011 use a drawing template instead of a sheet style,
so the option to change the sheet style is not available for section views created in AutoCAD Civil 3D 2011. To
change the size of the sheets and/or viewports created in AutoCAD Civil 3D 2011, you must recreate the section
views using the Production option with a new or revised template (.dwt). For more information, see To create
multiple section views (page 1259).
Name
Specifies the name of the sheet.
Description
Specifies the optional description of the sample line.

Object Style
NOTE The Object Style section is used only for section views created in AutoCAD Civil 3D 2010 or earlier that
reference a page setup in the current drawing.
Object Style
Specifies the name of the style used by the sheet. Select an object style in the list.

Creates, copies, or edits a style using the Sheet Style dialog box (page 2559). Click the down arrow to display
the style selection menu:
■

Create New: Creates a new style.
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■

Copy Current Selection: Copies the current style.

■

Edit Current Selection: Edits the current style.

■

Pick From Drawing: Prompts you to select a style directly from the drawing. The selected style becomes
the current style.

Displays details about an existing style. Select the style by name in the list. Click to open the Style Detail
dialog box (page 2020). Preview the style and creation information.
Related procedures:
■

Creating and Editing Section Views (page 1258)

Sheet Style Dialog Box
Use this dialog box to edit settings that define a sheet style, which controls the way a section sheet is displayed
in a drawing.
NOTE This dialog box is maintained for backward compatibility only. Sheet Styles are no longer used in AutoCAD
Civil 3D 2011. Instead, production-ready section layout is controlled using a drawing template during the creation
of multiple section views. For more information, see To create multiple section views (page 1259).
See also:
■

Creating and Editing Section View Styles (page 1237)

■

Editing a Section View Group Plot Style (page 1240)

Information Tab (Sheet Style Dialog Box)
Use this tab to display administrative data and edit primary information about the sheet style, such as its
name and description.
NOTE This dialog box is maintained for backward compatibility only. Sheet Styles are no longer used in AutoCAD
Civil 3D 2011. Instead, production-ready section layout is controlled using a drawing template during the creation
of multiple section views. For more information, see To create multiple section views (page 1259).
Name
Specifies the name of the selected sheet style.
Description
Specifies the optional description of the selected sheet style.
Related procedures:
■

Creating and Editing Section View Styles (page 1237)

■

Editing a Section View Group Plot Style (page 1240)
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Sheet Tab (Sheet Style Dialog Box)
Use this tab to edit settings for the visibility and format styles of sheet components, such as page layout,
margins, and plot area grid details.
NOTE This dialog box is maintained for backward compatibility only. Sheet Styles are no longer used in AutoCAD
Civil 3D 2011. Instead, production-ready section layout is controlled using a drawing template during the creation
of multiple section views. For more information, see To create multiple section views (page 1259).
Page Layout
Specifies the default page layout format. Select a page layout format from the list.

Page Margins
Top
Specifies the top page margin in plotted units. Enter a positive value in plotted units.
Bottom
Specifies the bottom page margin in plotted units. Enter a positive value in plotted units.
Left
Specifies the left page margin in plotted units. Enter a positive value in plotted units.
Right
Specifies the right page margin in plotted units. Enter a positive value in plotted units.
Related procedures:
■

Creating and Editing Section View Styles (page 1237)

■

Editing a Section View Group Plot Style (page 1240)

Summary Tab (Sheet Style Dialog Box)
Use this tab to edit settings for the sheet style.
NOTE This dialog box is maintained for backward compatibility only. Sheet Styles are no longer used in AutoCAD
Civil 3D 2011. Instead, production-ready section layout is controlled using a drawing template during the creation
of multiple section views. For more information, see To create multiple section views (page 1259).
To edit settings, click the Page Layout cell. Click

to open the Select Page Layout dialog box (page 2558).

For more information, see Summary Tab (Style Dialog Box) (page 2020).
Related procedures:
■

Creating and Editing Section View Styles (page 1237)

■

Editing a Section View Group Plot Style (page 1240)
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74

Material Analysis Dialog
Boxes

The following topics provide information about the Quantity Takeoff and Mass Haul dialog boxes.

Advanced Options Dialog Box
Use this dialog box to select advanced options for the pay item file you open.
NOTE This dialog box is available only when you select Florida DOT for Pay Item File Format. For more information,
see Open Pay Item File Dialog Box (page 2587).
Specification Book Version
Specifies the specification book version of the pay item file to open.
TRNS*PORT Designer Interface File
Displays the TRNS*PORT Designer Interface file path. Click

to open an interface file.

Related procedures:
■

Importing Master Pay Item Lists (page 1294)

■

Open Pay Item File Dialog Box (page 2587)

Change Volume Table Dialog Box
Use this dialog box to change volume table(s) in the drawing.
Use the following controls to specify the volume table types to draw:
Type
Specifies the type of the volume table(s).
Select Table Style
Specifies the style of the volume table. Standard buttons are also provided to create or edit a label style.
Add >>
Adds a volume table to the list.
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List Of Volume Tables
Table Type
Displays the current table type.
Style
Specifies the name of the table style that was added using the Select Table Style list. To change the style,
click in this column to open the Select Style dialog box (page 2021). Select a band style in the list or use the
standard controls to either create a new style, copy or edit the current style selection, or pick a style from
the drawing.
Material List
Specifies the material list for the volume table.
Materials
Click

to specify the materials for the volume table.

Layer
Specifies the drawing layer that contains the sampled source.
Split
Specifies whether the layer is split.
Gap
Specifies the distance in plotted units between the current data band and the previous data band (or the
nearest section view axis). Enter a positive gap value in plotted units.
Reactivity Mode
Specifies the type of update mode for the section. Select Dynamic to specify that the section data updates
dynamically when either the position of the sample line associated with the section changes or the data
source (surface, corridor, or pipe) geometry changes.

Position Of Table(s) Relative To Section View
Section View Anchor
Specifies the section view anchor (Top/Middle/Bottom, Left/Center/Right).
Table Anchor
Specifies the location of the table anchor (Top/Middle/Bottom, Left/Center/Right).
Table Layout
Specifies whether the layout of the tables is horizontal or vertical, in relation to the section view.
X Offset
Specifies the distance, in plotted units, to move the title away from the position set by the table anchor.
Enter a positive number to move the title right, or a negative number to move it left.
Y Offset
Specifies the distance, in plotted units, to move the title away from the position set by the table anchor.
Enter a positive number to move the title up, or a negative number to move it down.
Related procedures:
■

Creating Section Views (page 1258)

Compute Materials Dialog Box
Use this dialog box to create material lists for a sample line group.
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Quantity Takeoff Criteria
Specifies the criteria to use. Select from the list or click

to edit or create a criteria.

Volume Calculation Method
Specifies which method is used to calculate volumes. For more information, see Sectional Volume Methods
(page 1277).
Curve Correction Tolerance
Specifies whether curve tolerance is used. If selected, enter a value for the curve tolerance in the adjacent
field.
NOTE This control is grayed out if Composite Volume or Prismoidal is specified for the Volume Calculation
Method.
Map Objects With Same Name
Maps criteria surface or corridor shape names with surface or corridor shape names in the drawing that
are the same.
The Properties table contains the following columns:
Name In Criteria
Displays the surface and corridor shape names that are used in the criteria.
Object Name
Specifies the actual object name to map to the surface or corridor shape name in the criteria.
Material Name
Displays the material name that is referenced by the corresponding surface or corridor shape in the list.
Related procedures:
■

Generating Material Lists (page 1282)

■

Creating Sectional Volume Tables and Reports (page 1290)

Compute Quantity Takeoff Dialog Box
Use this dialog box to calculate and report quantity takeoff for a drawing or various elements of the drawing.

Report Type
Summary
Click to output a summary report of material quantity takeoff.
Detailed
Click to output an itemized report of material quantity takeoff.

Report Extents
Extents
Specifies the extent that the quantity takeoff report will cover.
Drawing: Specifies that the report will cover the entire drawing.
Sheet: Specifies that the report will cover the sheet.
Selection Set: Specifies that the report will cover selected objects in the drawing. Click
set in the drawing.

to select the

Report Quantity For Sheet Extents Only
Select to specify that the quantity report will cover only those objects in the sheet.
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This option is only available when Sheet is selected in the Extents list.
Limit Extents To Alignment Station Range
Select to specify that the report extents will be limited by a selected alignment, start station, and end
station.
Alignment
Specifies the alignment from which the station range will be drawn. Select an alignment from the list, or
click
to select the alignment in the drawing.
This option is only available when Limit Extents To Alignment Station Range is selected.
This option is not available when Sheet is selected in the Report Extents list.
Start Station
Specifies the station at which the station range will start. Enter a station in the field or click
the station in the drawing.
This option is only available when Limit Extents To Alignment Station Range is selected.

to select

End Station
Specifies the station at which the station range will end. Enter a station in the field or click
the station in the drawing.
This option is only available when Limit Extents To Alignment Station Range is selected.

to select

Report Output
Report Selected Pay Items Only
Select to specify that only objects with pay items selected in the QTO Manager vista are reported.
Report Station And Offset Relative To
Select an alignment in the list, or click
to select an alignment in the drawing, relative to which station
and offset information are reported for objects with pay items.

Compute
Compute
Generates a quantity takeoff report.
Related procedures:
■

Computing Quantities Using Pay Item Lists (page 1306)

Create Mass Haul Diagram Wizard
Use this wizard to create mass haul diagrams.
NOTE A material list must be created for the drawing before a mass haul diagram can be created. For information
about how to create a material list, see Generating Material Lists (page 1282).

General Page (Create Mass Haul Diagram Wizard)
Use this page to specify basic information about the mass haul diagram, including the parent alignment
and sample line group, mass haul view name, description, style, and layer.
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Select Alignment
Specifies the name of the parent horizontal alignment. Select a name from the list or click
alignment from the drawing.

to pick an

Sample Line Group
Specifies the parent sample line group. Select a name from the list or click
the drawing.

to pick an alignment from

Mass Haul View Name
Specifies a system-generated name that you can edit. The name must remain unique within the drawing.
Click
to open the Name Template dialog box (page 2022), where you can modify the material naming
template.
Description
Specifies an optional description of the mass haul diagram.
Mass Haul View Style
Specifies the style for the mass haul view. Use the standard controls to review or change the style.
Mass Haul View Layer
Specifies the drawing layer for the mass haul view. To review or change layer data, click

.

Related procedures:
■

Creating Mass Haul Diagrams (page 1314)

Mass Haul Display Options Page (Create Mass Haul Diagram Wizard)
Use this page to specify mass haul diagram display options.

Material
Material List
Specifies the material list for the mass haul diagram.
Choose A Material To Display As Mass Haul Line
Specifies the material to display as the mass haul line. Select from Total Volume, Total Cut Volume, Total
Fill Volume, Total Unusable Volume, and materials specific to the material list you have selected.

Mass Haul Line
Mass Haul Line Name
Specifies a system-generated name that you can edit. The name must remain unique within the drawing.
Description
Specifies an optional description of the mass haul diagram.
Mass Haul Line Style
Specifies the style for the mass haul line. Use the standard controls to review or change the style.
Mass Haul Line Layer
Specifies the drawing layer for the mass haul line. To review or change layer data, click

.

Related procedures:
■

Creating Mass Haul Diagrams (page 1314)
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Balancing Options Page (Create Mass Haul Diagram Wizard)
Use this page to set free haul distance, and borrow pit/dump site properties for the mass haul diagram.
Use the following controls to specify the free haul distance and type, location and capacity of borrow
pits/dump sites:

Free Haul Options
Free Haul Distance
Select this option to set a free haul distance value. If the option is cleared, no free haul distance is assigned
to the mass haul diagram. If you select the option, you can either accept the default or set your own free
haul distance in the field below.

Add/Remove Borrow Pits And Dump Sites
Add Borrow Pit
Click to add a borrow pit to the list.
Add Dump Site
Click to add a dump site to the list.

Deletes any selected borrow pit or dump site from the list.

List
Type
Specifies whether the balancing feature is a borrow pit or a dump site. Click in this field to change the
type of balancing feature.
Station
Specifies the station at which the borrow pit or dump site will be located. The station can be specified
either by entering a station value or selecting the station in the viewport. When you select the station in
the viewport, you must select it from a point along the alignment in the plan view, and not along the X
axis of the mass haul view.
Capacity
Specifies the volume to be borrowed or dumped at the borrow pit or dump site.
Related procedures:
■

Creating Mass Haul Diagrams (page 1314)

Create Material Volume Table Dialog Box
Use this dialog box to create a table in the drawing that contains volume data for a specific material in a
material list.
Most of the controls in this dialog box are generic table creation controls. For more information, see Table
Creation Dialog Box (page 2739).
Use the following controls to specify the materials information to be included in the material volume table:
Select Alignment
Specifies the alignment. Select an alignment from the list or click
to select an alignment in the drawing.
The alignments in the list are associated with at least one sample line group.
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Select Sample Line Group
Specifies the sample line group to use. Select a group from the list.
Select Material List
Specifies which material list defined in the sample line group properties is used.
Select A Material
Specifies which material from the material list is used to generate the table.
Related procedures:
■

Creating Sectional Volume Tables and Reports (page 1290)

Create Total Volume Table Dialog Box
Use this dialog box to create a table in the drawing using volume data from material list for a sample line
group.
Most of the controls in this dialog box are generic table creation controls. For a description of these controls,
see Table Creation Dialog Box (page 2739).
Use the following controls to specify the materials information to be included in the total volume table:
Select Alignment
Specifies the alignment. Select an alignment from the list or click
to select an alignment in the drawing.
The alignments in the list are associated with at least one sample line group.
Select Sample Line Group
Specifies the sample line group to use. Select a group from the list.
Select Material List
Specifies which material list defined in the sample line group properties is used.
Related procedures:
■

Creating Sectional Volume Tables and Reports (page 1290)

Define Material Criteria Dialog Box
Use this dialog box to define quantity takeoff criteria from a sample line group.
Select Alignment
Specifies the alignment. Click

to select an alignment in the drawing.

Select Sample Line Group
Specifies the sample line group to use. Select a group from the list.
Select Surfaces
Displays the available surfaces from which sections are to be cut. Select the check box next to surface to
use it to define a criteria material.
NOTE At least two surfaces must be selected. Surfaces selected are compared at each station and the enclosed
areas at each cross section are added as a material type to the criteria.
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Related procedures:
■

Creating Quantity Takeoff Criteria (page 1279)

Edit Feature Settings - Mass Haul Line Dialog Box
Use this dialog box to view and change standard drawing ambient settings for mass haul line.
The standard ambient settings are preceded with
. For feature-specific Mass Haul Line Style and Mass
Haul Line Name Template information, see Edit Feature Settings - Mass Haul View Dialog Box (page 2568).
For more information about this dialog box, see Working with the Standard Settings Dialog Box Controls
(page 78).
Related procedures:
■

Editing Mass Haul Line Settings (page 1319)

Edit Feature Settings - Mass Haul View Dialog Box
Use this dialog box to view and change mass haul view settings.
This topic documents settings in all mass haul-related Edit Settings dialog boxes (drawing-level, feature-level,
and command-level).
■

Drawing-level ambient settings are identified by the

■

Mass haul feature settings are listed near the top of this dialog box, after the General property group,
and are identified by the

■

drawing icon.

mass haul view icon.

Mass haul command settings are identified by the

command icon.

For general information about drawing, feature, and command settings and their interaction, see Working
with the Standard Settings Dialog Box Controls (page 78).
For information about drawing-level ambient settings, see Ambient Settings Tab (Drawing Settings Dialog
Box) (page 2078)

Default Styles
Use these settings to specify the default styles for mass haul components.
Mass Haul Line Style
Specifies the default style used for mass haul lines. Click in the Value column, and click
style in the Mass Haul Line Style dialog box.

to select a

Mass Haul View Style
Specifies the default style used for mass haul views. Click in the Value column, and click
style in the Mass Haul View Style dialog box.
For information about style selection, see Select Style Dialog Box (page 2021).
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to select a

Default Name Format
Use these settings to specify the default name format for new mass haul lines and new mass haul views.
Click in the Value column, and click

to make changes in the Name Template dialog box (page 2022).

Mass Haul Creation
Use these standard table settings, which are available when accessing the settings from the CreateMassHaul
command, to establish the default settings when you create a mass haul diagram.
Analyze Free Haul
Specifies whether the free haul distance is analyzed.
Free Haul Distance
Specifies the free haul distance.
Borrow Pit Capacity
Specifies the capacity of a borrow pit.
Dump Site Capacity
Specifies the capacity of a dump site.
Related procedures:
■

Editing Mass Haul View Settings (page 1320)

Edit Feature Settings - Quantity Takeoff Dialog Box
Use this dialog box to view and change quantity takeoff-related settings.
This topic documents settings in all quantity takeoff-related Edit Settings dialog boxes (drawing-level,
feature-level, and command-level).
■

Drawing-level ambient settings are identified by the

■

Quantity takeoff feature settings are listed near the top of this dialog box, after the General property
group, and are identified by the

■

drawing icon.

quantity takeoff icon.

Quantity takeoff command settings are identified by the

command icon.

For general information about drawing, feature, and command settings and their interaction, see Working
with the Standard Settings Dialog Box Controls (page 78).
For information about drawing-level ambient settings, see Ambient Settings Tab (Drawing Settings Dialog
Box) (page 2078)

Default Styles
Use this setting to establish the default quantity takeoff criteria and styles assigned to quantity takeoff
components.
Quantity Takeoff Criteria
Specifies the default quantity takeoff criteria when creating a quantity takeoff report. Click in the Value
column, and click

to select criteria in the Quantity Takeoff Criteria dialog box.
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Material Shape Style
Specifies the default style used for a material section when it is displayed in a section view. Click in the
Value column, and click

to select a style in the Material Shape Style dialog box.

For information about style selection, see Select Style Dialog Box (page 2021).

Default Name Format
Use these settings to specify the default name format for new quantity takeoff material lists and materials.
Click in the Value column, and click

to make changes in the Name Template dialog box (page 2022).

Table Creation
NOTE This property group is displayed when you access the settings from the AddMaterialVolumeTable and
AddTotalVolumeTable commands.
Use these settings to establish the defaults when you add a volume table.
Table Style
Specifies the style for a table. Click in the Value column, and click
dialog box.

to select a style in the Table Style

Split Table
Specifies whether a table is split into two or more sections after a specified maximum number of rows has
been met.
Maximum Number of Rows
Specifies the maximum number of rows to include per section. If the number of data rows exceeds the
specified maximum, the table is split into sections, and they are displayed either side by side (left to right),
or stacked vertically.
Maximum Tables Per Stack
Specifies the maximum number of sections to include in each stack.
Table Spacing
Specifies the spacing between tables.
Tile Direction
Specifies the direction in which the table tiles (across or down).

Assign Pay Item To Area Options
NOTE This property group is displayed when you access the settings from the AssignPayItemToArea command.
Use these settings to establish the display defaults when you assign a pay item to an area in the drawing.
Use AutoCAD Current Layer And Color
Specifies whether to use the current layer and color. Select True to use the current layer and color.
Layer For Hatch
Specifies the layer for hatching. Click in the Value column, and click
Selection dialog box.

to select a layer in the Layer

Color For Hatch
Specifies the color for hatching. Click in the Value column, and click
Color dialog box.
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to select a color in the Select

Define Materials Options
NOTE This property group is displayed when you access the settings from the ComputeMaterials and
GenerateQuantitesReport commands.
Use these settings to establish the default settings when you create a new quantity takeoff report.
Apply Curve Correction
Specifies whether curve correction is used when the Curve Correction Tolerance value is exceeded. Curve
correction may be required to correct volume calculations within a curvilinear section of an alignment
(or on two sides of a horizontal intersection point).
Curve Correction Tolerance
Specifies the curve tolerance value. If the sample lines are within the tolerance or if the angle of deflection
between the successive stations is small, then curve correction is not used. Enter an angle in degrees in
the Value column or click

and select an angle in the drawing area.

Volume Computation Method
Specifies which method is used to calculate volumes. For more information, see Sectional Volume Methods
(page 1277).

Quantity Report Options
NOTE This property group is displayed when you access the settings from the GenerateQuantitesReport command.
Use these settings to establish the default settings when you create a new quantity takeoff report.
Display XML Report
Specifies whether XML reports are displayed by default when you generate a quantity takeoff report.

Compute Takeoff Options
NOTE This property group is displayed when you access the settings from the Takeoff command.
Use these settings to establish the defaults for the Compute Quantity Takeoff dialog box.
Report Type
Specifies whether the default report type will be Summary or Detailed.
Report Extents
Specifies whether the default extent of the entities reported will be set to Drawing, Sheet, or Selection Set.
Report Selected Pay Item Only
Specifies whether the Report Selected Pay Item Only check box in the Compute Quantity Takeoff dialog
box defaults to True or False.
Limit To Alignment Station
Specifies whether the Limit Extents To Alignment Station Range check box in the Compute Quantity
Takeoff dialog box defaults to True or False.
Default Report Style
Specifies the default style sheet used to format the takeoff report.
Drawing-Based Report Table Font
Specifies the default font used in the report table. Click in the Value column, and click
in the Text Component Editor dialog box.

to select a font
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Length Computation Type
Specifies whether the default length computation type for pipes is 2D or 3D.
Pipe Length Type
Specifies whether the default pipe length type in the quantity takeoff process is measured To Inside Edges
or Center To Center.
Include Formulas In Reports
Specifies whether pay item formulas will be included in the report.
Related procedures:
■

Computing Quantities Using Pay Item Lists (page 1306)

■

Compute Quantity Takeoff Dialog Box (page 2563)

Edit Material List Dialog Box
Use this dialog box to review the material lists for a sample line group and add or delete materials from a
list.
Add New Material
Adds a new empty material to a list. After you add the material, you can edit its type and settings and use
the Define Material fields to populate it with data.

Opens the Name Template dialog box (page 2022), where you can modify the material naming template.
Add A Subcriteria
Adds a subcriteria to an empty material or to a material with existing subcriteria. For more information,
see Calculating Volumes for Overlapping Materials or Overhangs (page 1285).

Define Material
Data Type
Specifies the type of data that is compared and processed when defining the material. Either Surface or
Corridor Shape.
Select Surface/Corridor Shape
Lists the available surfaces or corridor shapes in the drawing. Select a surface or corridor shape or enter a
surface or corridor shape name.
NOTE Corridor shapes can be added only to a material with a Structure quantity type.

Adds the data specified in the Define Material fields to the selected material name.
NOTE If a material is not selected, the data is not added.

Deletes the material or data component that is currently selected in the Material Name column.

Material List
The properties table contains the following columns:
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Material Name
Specifies the material lists and names. Each instance of applying criteria to materials in a sample line
group is added as a numbered list. List names can be edited.
Click
next to a list name to display its components (materials).Click
display its components (surfaces or structures).

next to a material name to

Condition
Specifies the condition on which to base the calculation:
■

Above. Specifies that an area above this surface is included in the material definition. Used with Below
to define two or more surfaces for cut, fill, and structures material types.

■

Below. Specifies that an area below this surface is included in the material definition. Used with Above
to define two or more surfaces for cut, fill, and structures material types.

■

Base. Specifies that this surface is the surface to compare against the compare surface. Used with
Compare to define two or more surfaces for earthworks or cut and fill material types.

■

Compare. Specifies that this surface is the surface to compare against the base surface. Used with Base
to define two or more surfaces for earthworks or cut and fill material types.

■

Include. Specifies a corridor shape that is included in the structure type definition.

Quantity Type
Specifies the quantity type:
■

Cut. Calculates the material to remove.

■

Fill. Calculates the material to add.

■

Cut And Refill. Defines an area in the section where a material is removed and refilled with fill material.

■

Earthworks. Compares two surfaces to calculate both cut and fill areas and displays them separately.

■

Structures. Calculates the volume of one or more corridor shapes (as defined by the shape codes that
are used to define the corridor). For information about shape codes, see Understanding Point, Link,
and Shape Codes (page 1568).

Cut Factor
Specifies the expansion or swell of the cut material.
Fill Factor
Specifies a factor to accommodate for the contraction or shrinkage of the fill material.
NOTE For example, for a material that compacts to 93% of its original value when used as fill, enter 1.075
(which is derived by dividing 1.0 by .93) as the fill factor to compensate for the extra material that must be
added.
Refill Factor
Specifies usability factor used to calculate how much cut material can be reused as fill.
Shape Style
Specifies the default style used to display the material in a section view.
Curve Tolerance
Specifies the curve correction tolerance, if any, that was specified when the criteria was applied. To edit
the value, select the check box, and then edit the value.
NOTE This control is not displayed if Composite Volume or Prismoidal is specified for the Volume Calculation
Method.
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Volume Calculation Method
Specifies which method is used to calculate volumes. For more information, see Sectional Volume Methods
(page 1277).
Import Another Criteria
Prompts you to define a new materials list for the sample line group. Opens the Compute Materials dialog
box after you select a criteria.
Related procedures:
■

Generating Material Lists (page 1282)

■

Creating Quantity Takeoff Criteria (page 1279)

Edit Pay Item Dialog Box
Use this dialog box to edit pay items and pay item lists.

Notes
Notes field
Notes details about the listed pay items.

Add or Remove

Adds pay items to the list from the Pay Item List dialog box (page 2588).

Removes pay items from the list.

Pay Item List
Pay Item ID
Specifies the IDs of pay items in the list.
Description
Describes the item listed by ID.
Unit Type
Displays the unit type of the pay item.
Formula
Specifies the formula(s) attached to pay items.
Related procedures:
■

Editing Pay Items on Objects (page 1300)

■

Using Formulas with Pay Item Lists (page 1304)

Mass Haul Line Properties Dialog Box
Use this dialog box to edit mass haul line properties.
Mass haul line information can be viewed, but not edited, from the Mass Haul Line Data Tab (Mass Haul
Line Properties Dialog Box).
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Information Tab (Mass Haul Line Properties Dialog Box)
Use this tab to edit the name, description, or object style of a mass haul diagram.
Name
Specifies the name of the mass haul line.
Description
Specifies the optional description of the mass haul line.
Object Style
Specifies the name of the style used by the mass haul line.

Creates, copies, or edits a style using the Mass Haul Line Style dialog box. Click the Down arrow to display
the style selection menu:
■

Create New: Creates a new style.

■

Copy Current Selection: Copies the current style.

■

Edit Current Selection: Edits the current style.

■

Pick From Drawing: Prompts you to select a style directly from the drawing. The selected style becomes
the current style.

Displays details about an existing style. Select the style name in the list. Click to open the Style Detail
dialog box (page 2020). Preview the style and creation information.
Related procedures:
■

Editing Mass Haul Line Properties (page 1316)

Mass Haul Line Data Tab (Mass Haul Line Properties Dialog Box)
Use this tab to specify mass haul line data.
Material List Name
Displays the name of the material list for the mass haul line.
Material Name
Displays the material name that is referenced by the mass haul line.
Alignment Name
Displays the name of the parent alignment of the mass haul line.
Sample Line Group
Displays the name of the parent sample line group.
Related procedures:
■

Editing Mass Haul Line Properties (page 1316)

Balancing Options Tab (Mass Haul Line Properties Dialog Box)
Use this page to set free haul distance, and borrow pit/dump site properties for the mass haul diagram.
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Use the following controls to specify the free haul distance and type, location, and capacity of borrow
pits/dump sites:

Free Haul Options
Free Haul Distance
Select this option to enter a free haul distance value in the field below. If the option is cleared, the free
haul distance is set to its default.

Add/Remove Borrow Pits and Dump Sites
Add Borrow Pit
Click to add a borrow pit to the list.
Add Dump Site
Click to add a dump site to the list.

Deletes any selected borrow pit or dump site from the list.

List
Type
Specifies whether the balancing feature is a borrow pit or a dump site. Click in this field to change the
type of balancing feature.
Station
Specifies the station at which the borrow pit or dump site will be located.
Capacity
Specifies the volume either to be borrowed or dumped at the borrow pit or dump site.
Related procedures:
■

Editing Mass Haul Line Properties (page 1316)

Mass Haul Line Style Dialog Box
Use this dialog box to define a mass haul line style, which controls the way a mass haul line is displayed in
a drawing.
On the Display tab, you can use the ByLayer or ByBlock reference settings to set Color, Linetype, Lineweight,
and Plot Style values. Reference settings are indirect and require some planning.

Information Tab (Mass Haul Line Style Dialog Box)
Use this tab to display administrative data and edit primary information about the mass haul line style, such
as its name and description.
This tab also contains information about who created or modified the mass haul line style and the date the
style was created or modified. The following fields can be modified:
Name
Specifies the name of the selected mass haul line style.
Description
Specifies an optional description of the selected mass haul line style.
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Related procedures:
■

Editing Mass Haul Line Styles (page 1317)

Free Haul Tab (Mass Haul Line Style Dialog Box)
Use this tab to specify how you want to show free haul in graph.
Use the following controls to specify how free haul is graphed:

Free Haul Options

Measure From Grade Point
Select this option to show the free haul distance as measured from grade point in the mass haul diagram.

Measure From Balance Point
Select this option to show the free haul distance as measured from balance point in the mass haul diagram.
Related procedures:
■

Editing Mass Haul Line Styles (page 1317)

Display Tab (Mass Haul Line Style Dialog Box)
Use this tab to edit settings for the visibility and format styles of mass haul line components, such as mass
haul and free haul lines, and mass haul and free haul area hatch.
For more information, see Display Tab (Style Dialog Box) (page 2017).
Related procedures:
■

Editing Mass Haul Line Styles (page 1317)

Summary Tab (Mass Haul Line Style Dialog Box)
Use this tab to edit settings for the mass haul line style.
For more information, see Summary Tab (Style Dialog Box) (page 2020).
Related procedures:
■

Editing Mass Haul Line Styles (page 1317)
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Mass Haul View Properties Dialog Box
Use this dialog box to edit mass haul view properties.
Mass haul line information can be viewed, but not edited, from the Mass Haul Line Data Tab (Mass Haul
View Properties Dialog Box).

Information Tab (Mass Haul View Properties Dialog Box)
Use this tab to edit the name, description, or object style of a mass haul view.
Name
Specifies the name of the mass haul view.
Description
Specifies the optional description of the mass haul view.
Object Style
Specifies the name of the style used by the mass haul view.

Creates, copies, or edits a style using the Mass Haul View Style dialog box. Click the Down arrow to display
the style selection menu:
■

Create New: Creates a new style.

■

Copy Current Selection: Copies the current style.

■

Edit Current Selection: Edits the current style.

■

Pick From Drawing: Prompts you to select a style directly from the drawing. The selected style becomes
the current style.

Displays details about an existing style. Select the style name from the list. Click to open the Style Detail
dialog box (page 2020). Preview the style and creation information.
Related procedures:
■

Editing Mass Haul View Properties (page 1316)

Mass Haul Line Tab (Mass Haul View Properties Dialog Box)
Use this tab to specify mass haul line data.
Mass Haul Line Name
Displays the name of the mass haul line.
Alignment Name
Displays the name of the parent horizontal alignment.
Sample Line Group
Displays the name of the parent sample line group.
Material List Name
Displays the name of the material list for the mass haul line.

2578 | Chapter 74 Material Analysis Dialog Boxes

Material Name
Displays the material name that is referenced by the mass haul line.

Mass Haul Line Display Options
Mass Haul Line Display Style In This View
Specifies the name of the style used by the mass haul line in this view.

Creates, copies, or edits a style using the Mass Haul Line Style dialog box. Click the Down arrow to display
the style selection menu:
■

Create New: Creates a new style.

■

Copy Current Selection: Copies the current style.

■

Edit Current Selection: Edits the current style.

■

Pick From Drawing: Prompts you to select a style directly from the drawing. The selected style becomes
the current style.

Displays details about an existing style. Select the style name from the list. Click to open the Style Detail
dialog box (page 2020). Preview the style and creation information.
Related procedures:
■

Editing Mass Haul View Properties (page 1316)

Mass Haul View Style Dialog Box
Use this dialog box to define a mass haul view style, which controls the way a mass haul view is displayed
in a drawing.
You can change the mass haul view graph, grid, title, axes ticks, and text. Select which elements to display.

Information Tab (Mass Haul View Style Dialog Box)
Use this tab to display administrative data and edit primary information about the mass haul view style,
such as its name and description.
This tab also contains information about who created or modified the mass haul view style and the date of
these events. The following fields can be modified:
Name
Specifies the name of the selected mass haul view style.
Description
Specifies the optional description of the selected mass haul view style.
Related procedures:
■

Editing Mass Haul View Styles (page 1318)

Graph Tab (Mass Haul View Style Dialog Box)
Use this tab to edit settings for vertical scale.
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Vertical Scale
Vertical Scale
Specifies the vertical scale ratio. Standard ratios run from 1” = 1’ to 1” = 100’. Specifying a number in the
Custom Scale field sets the scale to Custom.
Custom Scale
Specifies a custom vertical scale ratio.
Current Horizontal Scale
Displays the current horizontal scale from drawing settings.
Vertical Exaggeration
Displays a value specifying the increase in the elevation values in the mass haul view. The vertical
exaggeration is equal to the current horizontal scale divided by the vertical scale.

Mass Haul View Direction
Specifies the direction of the mass haul line for the mass haul view grid:

Left To Right
The mass haul view is drawn with either 0 or the lowest station number on the left the highest station
number on the right.

Right To Left
The mass haul view is drawn with the highest station number on the left and either 0 or the lowest station
number on the right.
Related procedures:
■

Editing Mass Haul View Styles (page 1318)

Grid Tab (Mass Haul View Style Dialog Box)
Use this tab to specify clipping, padding, and axis offset options on the mass haul view grid.

Grid Options

Clip Vertical Grid
Specifies that vertical grid lines are drawn only between the mass haul line and the balancing line. Select
Omit Grid In Padding Areas to specify that vertical grid lines are not drawn in the padding areas.

Clip Horizontal Grid
Specifies that horizontal grid lines are drawn only between the mass haul line and the balancing line.
Select Omit Grid In Padding Areas to specify that horizontal grid lines are not drawn in the padding areas.
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Grid Padding

Grid Padding (Major Grids)
Specifies a value (in major grid blocks) that adds to the extents of the mass haul view in relation to the
mass haul line it contains. This creates a graph that is taller than the extents of the mass haul line drawn
in the mass haul view.
Above Maximum Point On Graph
Specifies the number of grid blocks that extend the mass haul view above the maximum point on the
graph. This creates a graph that is taller than the extents of the mass haul line.
Below Minimum Point On Graph
Specifies the number of grid blocks that extend the mass haul view below the minimum point on the
graph. This creates a graph that extends lower than the extents of the mass haul line.
To Left
Specifies the number of major grids to place before the left-most station value of the alignment. This
creates a graph that is wider than the extents of the mass haul line.
To Right
Specifies the number of major grids to place after the right-most station value of the alignment. This
creates a graph that is wider than the extents of the mass haul line.

Axis Offset
NOTE The axis offset distance is specified in plotted units, based on the Drawing Units and Scale settings specified
on the Units and Zone tab (page 2073) of the Drawing Settings dialog box.

Axis Offset (Plotted Units)
Specifies the distance (in plotted units) to offset the mass haul view’s horizontal and vertical axes from
the grid extents (including padding). This creates a blank area between the axis and the grid.
Above Maximum Point On Graph
Specifies the distance to offset the horizontal axis above the vertical extent.
Below Minimum Point On Graph
Specifies the distance to offset the horizontal axis below the vertical extent.
To Left
Specifies the distance to offset the horizontal axis to the left of the horizontal extent.
To Right
Specifies the distance to offset the horizontal axis to the right of the horizontal extent.
Related procedures:
■

Editing Mass Haul View Styles (page 1318)

Title Annotation Tab (Mass Haul View Style Dialog Box)
Use this tab to specify settings for the graph view and axis titles.
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Graph View Title
Text Style
Specifies the text style for the section view title.
Text Height
Specifies the current text height in drawing units.
Title Content
Specifies the text elements used to compose the title. Click
to open the Text Component Editor dialog
box (page 2199), where you can change title format or content.

Title Position
These controls specify the position of the mass haul view title. Use Location and Justification settings for
basic positioning, then X and Y offsets for more precise placement, if necessary.
Location
Specifies the location of the title in relation to the mass haul view grid, either: Top, Bottom, Right, or Left.
Justification
Specifies the justification (alignment) of the title. If Location is Top or Bottom, justification values are
Left, Center, or Right. If Location is Right or Left, justification values are Bottom, Middle, or Top.
X Offset
Specifies a horizontal offset from the position set by the Location and Justification values. Enter a positive
number to move the title right or a negative number to move it left.
Y Offset
Specifies a vertical offset from the position set by Location and Justification values. Enter a positive number
to move the title up or a negative number to move it down.
Border Around The Title
Specifies whether a border line is drawn around the title block.
Gap
Specifies the distance between the title and its border.

Axis Title Text
Separate titles may be displayed at each of the axes. Use the radio buttons to select the axis title to edit.
Configure title settings and click Apply. Repeat that process with each axis title.
NOTE The Axis Title selections do not control axis title visibility. Visibility controls for all section components are
located on the Display tab.

Axis Title Text
Specifies which axis title is being controlled by the text editing tools.
Title Text
Specifies the title text for the horizontal axis. Click
to open the Text Component Editor dialog box
(page 2199), where you can change title format or content.
Location
Specifies the location of the title on the axis, either: Left, Center, or Right. For more precise control, use
the X and Y offsets.
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Rotation
Specifies the angle for the title. Enter a positive or negative value. The angle direction is always
counterclockwise. If the value is zero (0), the title is not rotated.
Text Style
Specifies a text style for use in the horizontal axis title.
Text Height
Specifies the title text height (in plotted units).
X Offset
Specifies a horizontal offset from the Location setting. Enter a positive number to move the title right or
a negative number to move it left.
Y Offset
Specifies a vertical offset from the Location setting. Enter a positive number to move the title up or a
negative number to move it down.
Related procedures:
■

Editing Mass Haul View Styles (page 1318)

Horizontal Axes Tab (Mass Haul View Style Dialog Box)
Use this tab to edit settings for the mass haul view style, such as the title format, use of tick marks, and
annotations on the horizontal axes of the section view.
After you configure horizontal axis title and tick details, click Apply. Later, you can change the Select Axis
setting and configure another axis on the opposite side of the grid.
Select Axis To Control
Click either Top, Middle, or Bottom to select that axis.

Major Tick Details
Interval
Specifies the spacing of major ticks on the horizontal axis, using the actual ground units. Enter a positive
value in ground units.
Tick Size
Specifies the height of the actual tick on the horizontal axis, using plotted units. Enter a positive value in
plotted units.
Tick Justification
Specifies whether the tick is justified, either: Top, Bottom, or Center.
Text Height
Specifies the height of text used to label major ticks on the horizontal axis, using in plotted units. Enter
a positive value in plotted units.
Tick Label Text
Specifies a property with which the tick is labeled. Click
to open the Text Component Editor dialog
box (page 2199), where you can change text format or content.
Text Style
Specifies the style of the tick label text.
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Rotation
Specifies the angle for the tick label. Enter a positive or negative value.The angle direction is always
counterclockwise. If the value is zero (0), the label is not rotated.
X Offset
Specifies a horizontal offset for the tick label from the bottom of the tick.
Y Offset
Specifies a vertical offset for the tick label from the bottom of the tick.

Minor Tick Details
Interval
Specifies the spacing of minor ticks on the horizontal axis, using the actual ground units. Enter a positive
value in ground units.
Tick Size
Specifies the height of the actual tick on the horizontal axis, using plotted units. Enter a positive value in
plotted units.
Tick Justification
Specifies whether the tick is justified, either: Top, Bottom or Center.
Text Height
Specifies the height of text used to label minor ticks on the horizontal axis, using plotted units. Enter a
positive value in plotted units.
Tick Label Text
Specifies a property with which the tick is labeled. Click
box, to change the text format or content.

to open the Text Component Editor dialog

Text Style
Specifies the style of the tick label text.
Rotation
Specifies the angle for the tick label. Enter a positive or negative value.The angle direction is always
counterclockwise. If the value is zero (0), the label is not rotated.
X Offset
Specifies a horizontal offset for the tick label from the bottom of the tick.
Y Offset
Specifies a vertical offset for the tick label from the bottom of the tick.

Horizontal Geometry Tick Details
Tick Size
Specifies the height of the actual tick on the horizontal axis, using plotted units. Enter a positive value in
plotted units.
Tick Justification
Specifies whether the tick is justified, either: Top, Bottom or Center.
Text Height
Specifies the height of text used to label minor ticks on the horizontal axis, using plotted units. Enter a
positive value in plotted units.
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Tick Label Text
Specifies a property with which the tick is labeled. Click
box, to change the text format or content.

to open the Text Component Editor dialog

Text Style
Specifies the style of the tick label text.
Rotation
Specifies the angle for the tick label. Enter a positive or negative value.The angle direction is always
counterclockwise. If the value is zero (0), the label is not rotated.
X Offset
Specifies a horizontal offset for the tick label from the bottom of the tick.
Y Offset
Specifies a vertical offset for the tick label from the bottom of the tick.
Related procedures:
■

Editing Mass Haul View Styles (page 1318)

Vertical Axes Tab (Mass Haul View Style Dialog Box)
Use this tab to edit settings for the mass haul view style, such as the title location and format, use of tick
marks, and annotations, on the vertical axis of the mass haul view.
After you configure vertical axis title and tick details, click Apply. Later, you can change the Select Axis
setting and configure another axis on the opposite side of the grid.
Select Axis To Control
Click either Left or Right to select that axis.

Major Tick Details
Interval
Specifies the spacing of major ticks on the vertical axis. Enter a positive value in ground units.
Tick Size
Specifies the length of the actual tick on the vertical axis, using plotted units. Enter a positive value in
plotted units.
Tick Justification
Specifies whether the tick is justified, either: Left, Right or Center.
Text Height
Specifies the height of text used to label major ticks on the vertical axis in plotted units. Enter a positive
value in plotted units.
Tick Label Text
Specifies a property with which the tick is labeled. Click
to open the Text Component Editor dialog
box (page 2199), where you can change text format or content.
Text Style
Specifies the style of the tick label text.
Rotation
Specifies the angle for the tick label. Enter a positive or negative value.The angle direction is always
counterclockwise. If the value is zero (0), the label is not rotated.
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X Offset
Specifies a horizontal offset for the tick label from the end of the tick.
Y Offset
Specifies a vertical offset for the tick label from the end of the tick.

Minor Tick Details
Interval
Specifies the spacing of minor ticks on the vertical axis, using the actual ground units. Enter a positive
value in ground units.
Tick Size
Specifies the length of the actual tick on the vertical axis, using plotted units. Enter a positive value in
plotted units.
Tick Justification
Specifies whether the tick is justified, either: Left, Right or Center.
Text Height
Specifies the height of text used to label minor ticks on the vertical axis, using plotted units. Enter a
positive value in plotted units.
Tick Label Text
Specifies a property with which the tick is labeled. Click
box, to change the text format or content.

to open the Text Component Editor dialog

Text Style
Specifies the style of the tick label text.
Rotation
Specifies the angle for the tick label. Enter a positive or negative value.The angle direction is always
counterclockwise. If the value is zero (0), the label is not rotated.
X Offset
Specifies a horizontal offset for the tick label from the end of the tick.
Y Offset
Specifies a vertical offset for the tick label from the end of the tick.
Related procedures:
■

Editing Mass Haul View Styles (page 1318)

Display Tab (Mass Haul View Style Dialog Box)
Use this tab to edit settings for mass haul view components and format their styles, such as visibility and
color.
For more information, see Display Tab (Style Dialog Box) (page 2017).
Related procedures:
■

Editing Mass Haul View Styles (page 1318)
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Summary Tab (Mass Haul View Style Dialog Box)
Use this tab to edit settings for the mass haul view style.
For more information, see Summary Tab (Style Dialog Box) (page 2020).
Related procedures:
■

Editing Mass Haul View Styles (page 1318)

Open Pay Item File Dialog Box
Use this dialog box to specify the pay item file format, and open a pay item file and its related categorization
file.

Pay Item and Categorization Files
Pay Item File Format
Specifies whether the format of the pay item file is CSV (Comma delineated), AASHTO TransXML or
Florida DOT.
Pay Item File
Displays the pay item file path. Click

to select and open a pay item file.

Pay Item Categorization File
Displays the pay item categorization file path. Click

to select and open a categorization file.

Advanced Options
Click to set specification book version and TRNS*PORT Designer Interface File in the Advanced Options
dialog box (page 2561). This button is only available when you select Florida DOT for Pay Item File Format.
Related procedures:
■

Importing Master Pay Item Lists (page 1294)

Pay Item Formula Dialog Box
Use this dialog box to set up the formulas that you can use to calculate your quantity takeoff.
NOTE Do not enter functions, constants, or logical operators inside the { } brackets that surround Properties such
as {Item Area}.
To set up a formula, you can use the buttons in the dialog box and the keypad on your keyboard. There are
menus in the dialog box from which you can choose properties and functions to insert into the formula.
If you enter a combination of items that is invalid, a parse error is displayed when you click OK.
Expression field
Specifies the formula.
Calculator Buttons
Enter numbers and logical operators (page 1732)into the Expression box to define the expression.
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Inserts a property into the Expression. Click the icon to display the list of properties relevant to the formula
type. Select Item Area, Item Count, Item Length, Part Depth or a user-defined parameter to insert it in
the Expression field.
Item Area takes the Area property of the object to which the pay item is attached. Item Length takes the
Length property of the object to which the pay item is attached.
Part Depth applies only to pipe network parts (pipes and structures) and returns the average depth of the
part. This is calculated as (max cover + min cover)/2 + the part OD.
User-defined parameters take the value assigned in the Pay Item Formula Parameters dialog box (page 2588).
If the pay item is a subassembly, and the parameter matches a parameter in the subassembly, the value
from the subassembly is used. Otherwise, the specified value is used.

Inserts a function into the expression. See functions (page 1732)for more information.
Edit Parameters
Edits the parameters of the formula in the Pay Item Formula Parameters dialog box (page 2588), which
allows you to define new parameters and set values or defaults.

Functions and Operators
For a list of functions and operators supported in this dialog box, see Functions and Operators (page 1732)
Related procedures:
■

Using Formulas with Pay Item Lists (page 1304)

Pay Item Formula Parameters Dialog Box
Use this dialog box to add or modify the parameters of the formulas that you use to calculate your quantity
takeoff.

Parameter List
Name
Specifies a name for the formula parameter. For subassemblies, if this parameter matches a subassembly
parameter, the value from the subassembly is used.
Value
Specifies the parameter value. For subassemblies, this is the default used if no matching subassembly
parameter is found.
Related procedures:
■

Using Formulas with Pay Item Lists (page 1304)

■

Pay Item Formula Dialog Box (page 2587)

Pay Item List Dialog Box
Use this dialog box to categorize, filter, and edit pay items and pay item lists.
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Categorization
Turn On Categorization
Organizes the list of pay items into categories, defined by the pay item categorization file.
Turn Off Categorization
Presents a single-level list of pay items, without categories.

Filtering
Filter Text field
In this field, enter the text to use for filtering pay items in the selected list.

Filters pay items, based on the text entered in the Filter Text field.

Pay Item List
Pay Item ID
Displays the ID of each pay item in the list.
Description
Displays a description of each pay item.
Unit Type
Displays the type of unit of each pay item.
Formula
Specifies any formula attached to a pay item.
Related procedures:
■

Using Pay Items to Analyze Quantities (page 1293)

■

QTO Manager Vista (page 2589)

QTO Manager Vista
Use this vista to manage pay items and pay item lists.

File Management
Open Pay Item File
Opens a pay item file and its categorization file, using the Open Pay Item File dialog box.
Save As ➤
Autodesk Takeoff Catalog
Exports the pay item file as an ATT (Autodesk Takeoff Catalog) file.
Save As ➤
CSV File
Saves the pay item file as a CSV (Comma Separated Variable) file.
Open ➤
Categorization File
Opens an XML file used to categorize pay items in a pay item list.
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Open ➤
Formula File
Opens a FOR (Quantity Takeoff Formula) file used to apply formulas to pay items in a pay item list.

Categorization
Turn On Categorization
Specifies listing of pay items in categories defined by the pay item categorization file.
Turn Off Categorization
Specifies listing of pay items in a single-level list, without categories.

Filtering
Enter Text To Filter Pay Items
Specifies the text used filter pay items in the selected list.

Filters pay items, based on the text entered in the Filter Text field.

Pay Items

Assigns one or more selected pay items to an object in the drawing.

Assigns one or more selected pay items to a closed area in the drawing.

Removes pay items from specified objects.

Edits pay items on specified objects.

Compute Quantity Takeoff

Calculates material quantity takeoff in the Compute Quantity Takeoff dialog box (page 2563).

Highlighting

Highlights those objects in the drawing that have one or more pay items assigned.

Highlights those objects in the drawing that have no pay items assigned.

Highlights those objects in the drawing that have the same pay items assigned as those selected in the
Pay Item List.

Clears all highlighting based on pay items.

2590 | Chapter 74 Material Analysis Dialog Boxes

Edit Command Settings

Edits command-specific settings for the AssignPayItemToArea and TakeOff commands in the Quantity
Takeoff Command Settings dialog box (page 2591).

Dismiss

Closes the QTO Manager.

Pay Item List
Pay Item ID
Displays the ID of each pay item.
Description
Displays a description of each pay item.
Unit Type
Displays the type of unit of each pay item.
Formula
Specifies any formula attached to a pay item.
Related procedures:
■

Using Pay Items to Analyze Quantities (page 1293)

■

Importing Master Pay Item Lists (page 1294)

Quantity Takeoff Command Settings Dialog Box
Use this dialog box to view and change the TakeOff and AssignPayItemToArea command settings.
This dialog box controls command-level settings related to quantity takeoff. For more information, see Edit
Feature Settings - Quantity Takeoff Dialog Box (page 2569).

Compute Takeoff Options
Use these settings to establish the defaults for the Compute Quantity Takeoff dialog box.
Report Type
Specifies whether the default report type will be Summary or Detailed.
Report Extents
Specifies whether the default extent of the entities reported will be set to Drawing, Sheet, or Selection Set.
Report Selected Pay Item Only
Specifies whether the Report Selected Pay Item Only check box in the Compute Quantity Takeoff dialog
box defaults to True or False.
Limit To Alignment Station
Specifies whether the Limit Extents To Alignment Station Range check box in the Compute Quantity
Takeoff dialog box defaults to True or False.
Default Report Style
Specifies the default style sheet used to format the takeoff report.
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Drawing-Based Report Table Font
Specifies the default font used in the report table. Click in the Value column, and click
in the Text Component Editor dialog box.

to select a font

Length Computation Type
Specifies whether the default length computation type for pipes is 2D or 3D.
Pipe Length Type
Specifies whether the default pipe length type in the quantity takeoff process is measured To Inside Edges
or Center To Center.
Include Formulas In Reports
Specifies whether pay item formulas will be included in the report.

Assign Pay Item To Area Options
Use these settings to establish the display defaults when you assign a pay item to an area in the drawing.
Use AutoCAD Current Layer And Color
Specifies whether to use the current layer and color. Select True to use the current layer and color.
Layer For Hatch
Specifies the layer for hatching. Click in the Value column, and click
Selection dialog box.s

to select a layer in the Layer

Color For Hatch
Specifies the color for hatching. Click in the Value column, and click
Color dialog box.

to select a color in the Select

Related procedures:
■

Editing Quantity Takeoff Settings (page 1275)

Quantity Takeoff Criteria Dialog Box
Use this dialog box to create and edit quantity takeoff criteria.
See also:
■

Creating Quantity Takeoff Criteria (page 1279)

Information Tab (Quantity Takeoff Criteria Dialog Box)
Use this tab to view or change general information for the quantity takeoff criteria.
Name
Specifies the name of the quantity takeoff criteria.
Description
Specifies the description for the quantity takeoff criteria.
Related procedures:
■

Creating Quantity Takeoff Criteria (page 1279)
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Material List Tab (Quantity Takeoff Criteria Dialog Box)
Use this tab to define the quantity takeoff criteria.
Add New Material
Adds a new empty material to the list. After you add the material, you can edit its type and settings and
use the Define Material fields to populate it with components that define the criteria for calculating
volumes.

Opens the Name Template dialog box (page 2022), where you can modify the material naming template.
Add A Subcriteria
Adds a subcriteria to an empty material or to a material with existing subcriteria. For more information,
see Calculating Volumes for Overlapping Materials or Overhangs (page 1285).

Deletes the material or data component that is currently selected in the Material Name column.

Define Material
Data Type
Specifies the type of data that is compared and processed when defining the material. Either Surface or
Corridor Shape.
Select Surface/Shape
Lists sampled surfaces and corridor shapes for this sample line group. Select a surface or corridor shape.
Surface and corridor shape names in the material criteria are mapped to actual surfaces and shapes when
you generate the quantity takeoff report.
NOTE Corridor shapes can be added only to a material with a Structure quantity type.

Adds the data specified in the Define Material fields to the selected material name.
NOTE If a material is not selected, the data is not added.
The properties table contains the following columns:
Material Name
Specifies the material name. Click

next to the material name to display its components (surfaces).

Condition
Specifies the condition on which to base the calculation:
■

Above. Specifies that an area above this surface is included in the material definition. Used with Below
to define two or more surfaces for cut, fill, and structures material types.

■

Below. Specifies that an area below this surface is included in the material definition. Used with Above
to define two or more surfaces for cut, fill, and structures material types.

■

Base. Specifies that this surface is the surface to compare against the compare surface. Used with
Compare to define two or more surfaces for earthworks or cut and fill material types.

■

Compare. Specifies that this surface is the surface to compare against the base surface. Used with Base
to define two or more surfaces for earthworks or cut and fill material types.

■

Include. Specifies a corridor shape that is included in the structure type definition.
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Quantity Type
Specifies the quantity type:
■

Cut. Calculates the material to remove.

■

Fill. Calculates the material to add.

■

Cut and Refill. Defines an area in the section where a material is removed and refilled with fill material.

■

Earthworks. Compares two surfaces to calculate both cut and fill areas and displays them separately.

■

Structures. Calculates the volume of one or more corridor shapes (as defined by the shape codes that
are used to define the corridor). For information about shape codes, see Understanding Point, Link,
and Shape Codes (page 1568).

Shape Style
Specifies the default style used to display the material in a section view.
Cut Factor
Specifies the expansion or swell of the cut material.
Fill Factor
Specifies a factor to accommodate for the contraction or shrinkage of the fill material.
NOTE For example, for a material that compacts to 93% of its original value when used as fill, enter 1.075
(which is derived by dividing 1.0 by .93) as the fill factor to compensate for the extra material that must be
added.
Refill Factor
Specifies usability factor used to calculate how much cut material can be reused as fill.
Define From A Sample Line Group
Specifies that criteria is defined from sections in a sample line group. Opens the Define Material Criteria
dialog box (page 2567).
Related procedures:
■

Creating Quantity Takeoff Criteria (page 1279)

Quantity Takeoff Report Dialog Box
Use this dialog box to view, format and output quantity takeoff reports and tables.
Report
Displays the report generated in the Compute Quantity Takeoff dialog box (page 2563).
NOTE With Microsoft Excel installed and an HTML report in the Report window, right-click on the report to
export the HTML report directly to Excel.
Report Style Sheets
Specifies the style of the report. On the drop-down list, select from CSV, HTML, TXT, or XML style sheets
for either Summary or Detailed reports. Click <Browse> at the bottom of the drop-down list to select other
style sheets in the Choose Style Sheet dialog box.
Draw
Draws a CSV, HTML or TXT report at a specified location in the drawing. HTML reports are drawn as
AutoCAD tables, while CSV and TXT reports are drawn as AutoCAD MTEXT. XML reports cannot be
displayed in a drawing.
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Save As
Saves quantity takeoff reports to a specified folder. CSV and TXT formatted reports are saved as TXT files.
HTML and XML reports are saved as such.
Related procedures:
■

Reporting Pay Item Quantities (page 1308)

Report Quantities Dialog Box
Use this dialog box to create external reports in XML using a material list for a sample line group.
Select Alignment
Specifies the alignment. Select an alignment from the list or click
to select an alignment in the drawing.
The alignments in the list are associated with at least one sample line group.
Select Sample Line Group
Specifies the sample line group to use. Select a group from the list.
Select Material List
Specifies which material list defined in the sample line group properties is used to create the report.
Select A Style Sheet
Specifies the style sheet to use for the report. Enter the path and name or click
Sheet dialog box where you can browse for the style sheet.

to open the Select Style

Display XML Report
Specifies whether to display an XML report for the quantity takeoff.
Related procedures:
■

Creating Sectional Volume Tables and Reports (page 1290)

Select a Sample Line Group Dialog Box
Use this dialog box to select a sample line group from which to generate quantity takeoff information.
Select Alignment
Specifies the alignment. Click
to select an alignment in the drawing. The alignments in the list are
associated with at least one sample line group.
Select Sample Line Group
Specifies the sample line group to use. Select a group from the list.
Related procedures:
■

Generating Material Lists (page 1282)

Select Materials Dialog Box
Use this dialog box to specify the materials for the volume table.
Materials
Select or clear the check boxes to specify the addition or removal of materials from the volume table.
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Related procedures:
■

Analyzing Sectional Volumes (page 1277)
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Sites Dialog Boxes

75

Use the following links to access information about the Sites dialog boxes.

Site Properties Dialog Box
Use this dialog box to view or edit the general properties for a site.
NOTE You can set and view site parcel properties in the Site Parcel Properties (page 2251) dialog box.
Related procedures:
■

Editing Site Properties (page 784)

■

Creating a Site (page 783)

Information Tab (Site Properties Dialog Box)
Use this tab to specify and edit the name and description for a site.
Name
Specifies the name of the site, which is used to identify the site topology collection under the Sites node
in the Prospector tree.
Description
Specifies the description of the site topology collection.
Related procedures:
■

Editing Site Properties (page 784)

■

Creating a Site (page 783)

3D Geometry Tab (Site Properties Dialog Box)
Use this tab to define how alignments and parcel geometry should be displayed when viewed in 3D.
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NOTE These settings apply only to geometry. The display properties are defined by the style that the objects
reference.

3D Geometry
Site Display Mode
Specifies how a site’s elevation is displayed in 3D:
■

Use Elevation: Displays the site geometry at the actual elevation to which it was drawn.

■

Flatten To Elevation: Displays the geometry flattened or projected to the elevation value specified by
the Site Elevation property.

Site Elevation
Specifies the elevation used to flatten the geometry; enabled when the Site Display Mode property is set
to Flatten To Elevation. All site geometry will be displayed at the specified elevation, regardless of the
existing physical elevation of the geometry. The object elevations are not physically changed; they are
only displayed at a single elevation.
Curve Tesselation: Mid-ordinate Distance
Specifies the mid-ordinate distance for the 3D polylines, which is used to tessellate the feature line and
lot line arcs from which the polyline is being created.

Construction Geometry
Specifies the layers that construction geometry uses for 3D display.
When you create parcels or alignments, there may be solved and unsolved portions of the feature. The
unsolved portion includes any unconnected elements of a feature.
For example, if you use the tan-tan method and create a number of lines, the whole feature is solved and
the display characteristics are controlled by the parcel style. If you create some connected lines and then
add a line that is not connected, the result is a piece of ‘construction’ geometry.
Construction Line Layer
Specifies the layer for line construction geometry. Click
you can select a layer.

to open the Layer Selection dialog box where

Construction Arc Layer
Specifies the layer for arc construction geometry. Click
you can select a layer.

to open the Layer Selection dialog box where

Construction Spiral Layer
Specifies the layer for spiral construction geometry. Not used.
Related procedures:
■

Creating a Site (page 783)

■

Editing Site Properties (page 784)

Numbering Tab (Site Properties Dialog Box)
Use this tab to define how parcel and alignments components are numbered.
There are two numbering counters:
■

Automatic. Used for numbering at creation time.
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■

Manual. Used when renumbering.

If you create a number of parcels at the same time, the Next Automatic Counter property is used to generate
the starting number and the numbering automatically increments by one. For example, if the Next Automatic
Counter is set to 100, the parcels would be numbered starting at 100. If you renumber the parcels, the
renumbering is generated from the Next Manual Counter property. You can set the automatic and manual
numbers to avoid collisions when renumbering.

Parcels
Parcel: Next Automatic Area Counter
Specifies the starting number for new parcels to be created in the site. The numbering is incremented with
creation of new parcels.
TIP Set this range sufficiently above the manual range to avoid collisions while renumbering manually.
Parcel: Next Manual Area Counter
Specifies the default starting number for renumbering parcels in the site. This value can also be edited in
the parcel Renumbering dialog box.
Related procedures:
■

Creating a Site (page 783)

■

Editing Site Properties (page 784)

Move To Site Dialog Box
Use this dialog box to move objects from one site to another. The contents of an entire site, including
alignments, grading groups, or parcels, can be moved together.
NOTE If there is a naming conflict, duplicate objects must be deleted from the destination site prior to moving
or copying sites or objects within a site. If duplicates objects occur, the names are automatically resolved. For
example, if the destination site contains an Alignment - (1), it is renamed to Alignment - (1) (1).
Destination Site
Specifies the destination site. Select an existing site from the list, or click
to either pick a site in the
drawing or create a new site, which is then returned and displayed in the list.
NOTE If only alignments are selected, accepting the default <None> selection places the alignments in the
top-level Alignments collection in the Prospector. See Alignment and Site Interaction (page 781) for more
information.
Selected Objects
Navigate in the data tree to view its subcomponents and expand the collections. The contents of the data
tree are dependent on the commands entry point (that is, the location in the Prospector, or drawing, from
which the command was invoked). Select or clear the check boxes to filter the objects that you want to
move.
NOTE The check boxes have a tri-state display. If only some objects are selected under a collection, the check
box is dimmed and not available.
Related procedures:
■

Move Objects to a Site (page 789)
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Copy To Site Dialog Box
Use this dialog box to copy objects from one site to another. The contents of an entire site, including
alignments, grading groups, or parcels, can be copied together.
NOTE If there is a naming conflict, duplicate objects must be deleted from the destination site prior to moving
or copying sites or objects within a site. If duplicates objects occur, the names are automatically resolved. For
example, if the destination site contains an Alignment - (1), it is renamed to Alignment - (1) (1).
Destination Site
Specifies the destination site. Select an existing site from the list, or click
to either pick a site in the
drawing or create a new site, which is then returned and displayed in the list.
NOTE If only alignments are selected, accepting the default <None> selection places the alignments in the
top-level Alignments collection in the Prospector. See Alignment and Site Interaction (page 781) for more
information.
Selected Objects
Navigate in the data tree to view its subcomponents and expand the collections. The contents of the data
tree are dependent on the commands entry point (that is, the location in the Prospector, or drawing, from
which the command was invoked). Select or clear the check boxes to filter the objects that you want to
copy.
NOTE The check boxes have a tri-state display. If only some objects are selected under a collection, the check
box is dimmed and not available.
Related procedures:
■

Copy Objects to a Site (page 790)
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Superelevation Dialog
Boxes

Calculate Superelevation Dialog Box
Calculate superelevation for one curve, selected curves, or the entire alignment.
This dialog box is displayed when you click Superelevation Wizard from the Superelevation Curve Manager
dialog box. Existing superelevation data is overwritten.
Calculate Superelevation For:
This Curve Only: superelevation is calculated for the selected curve in the Superelevation Curve Manager.
Entire Alignment: superelevation is calculated for the entire alignment and all curve check boxes are
selected.
Selected Curves: specify this option and then select the check boxes next to the curves for which you
want to calculate superelevation.
Related procedures:
■

Using the Superelevation Curve Manager (page 1102)

Create Superelevation View Dialog Box
Specify the name, style, and station range for the superelevation view.
Superelevation View Name
Enter a name for the view, or click

to edit the name in the Name Template dialog box (page 2022).

Alignment
Select the alignment from the list, or click

to pick the alignment in the drawing.

Description
Enter an optional description for the view.
Superelevation View Layer
Displays the layer for the view.
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Superelevation View Style
Specify a style for the view. For more information, see Superelevation View Style Dialog Box (page 2609).

Station Range
Data Range
Displays the alignment start station and end station.
User Specified Range
Select the check box and specify the stations, or click

and pick stations in the drawing.

Specify Superelevation Display Options
Lanes
Lists the lanes in the alignment that contain superelevation data.
Display
Select the lanes to display in the superelevation view.
Color
Specify the color for the lanes in the superelevation view. Click the cell and select a color.
Related procedures:
■

Creating and Editing Superelevation Views (page 1107)

Superelevation Curve Manager Dialog Box
Review superelevation curve details and edit superelevation design criteria.
Superelevation Curve
Displays the curve name and highlights the curve in the drawing. Select a curve from the list, or click
Previous or Next to navigate through the curves.
Toggle Real-time Pan
Pans to the selected curve in the drawing.
Create User-defined Curve
Click to create a user-defined curve by selecting a single alignment entity or string of adjacent alignment
entities.

Superelevation Curve Details
Curve Name
Specifies the name of the curve. The curve is highlighted in the drawing.
Curve Definition
Displays the curve definition.
■

Automatic: the curve was automatically detected.

■

User-defined: the curve was created manually

Design Speed
Specifies the design speed for the curve. Click
to display the Design Speeds tab of the Alignment
Properties, where you can add or change design speeds on the alignment. For more information, see
Design Criteria Tab (Alignment Properties Dialog Box) (page 1966).
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NOTE The following curve properties are read-only:
■

Radius (you can enter a radius value in a user-defined curve)

■

Direction (you can change the direction in a user-defined curve)

■

Start Station

■

End Station

■

Length

Right-click any of these items for options to zoom or pan to property in the drawing.

Transition In and Transition Out Details
Entity Before
Displays the entity type and direction of the entities before the curve. None is displayed if the alignment
begins with a curve.
Transition Method
Displays one of the following:
■

Not Calculated

■

User Defined

■

Normal Transition: occurs in the area where the cross slope changes from a normal crown to full
superelevation or to normal crown from full superelevation.

■

Reverse Transition: occurs between two back to back reverse curves, where full superelevation for one
curve transitions into full superelevation in the opposing direction.

■

Compound Transition: occurs between two back to back compound curves, where full superelevation
at one curve transitions into full superelevation of the other curve.

The transition method is determined by the occurrence of overlap and the type of curve (reverse or
compound).
Overlap
Displays one of the following:
■

Not Calculated

■

With Previous or Next Curve

■

Resolved

■

None

Superelevation Criteria
Typically, this node is only displayed when you use the Superelevation wizard to create superelevation.
However, in a situation where you migrate a drawing, from a release prior to AutoCAD Civil 3D 2011, that
contains superelevation, AutoCAD Civil 3D tries to determine if the criteria that was used in the calculation
is available.
IMPORTANT In situations where the design criteria file cannot be found you must specify a file and update the
file path. After specifying the file, right-click a Value cell and click Apply To Entire Alignment.
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NOTE If you make a change to the Superelevation Criteria, the Superelevation Status in the Superelevation Curve
Manager displays
display.

to indicate the status is “Out Of Date”. Click the Recalculate button to update the data

NOTE When you edit Superelevation Criteria in the Superelevation Curve Manager, the changes are only applied
to the currently displayed superelevation curve. To apply the changes to all superelevation curves, right-click a
Value cell and click Apply To Entire Alignment.
Design Criteria File
Specifies the name of the design criteria file. This file defines minimum radius tables, superelevation
attainment methods and formulae, superelevation rates and transition lengths for various roadway types
and design speeds. Click

to browse to the location of the design criteria file.

Superelevation Rate Table
Specifies the name of the superelevation rate table used to determine the maximum superelevation rate
for the curve. Click the arrow to display a list of the superelevation rate tables associated with the specified
design criteria file.
Transition Length Table
Specifies the name of the transition length table used to calculate the transition stations for the curve.
Click the arrow to display a list of the transition length tables associated with the specified superelevation
rate table.
Roadway Type
Specifies the roadway type as Divided or Undivided.
Cross Section Shape
Specifies the cross section shape as Crowned or Planar.
Highside Location
Specifies the highside location as Left, Level, or Right. This option only applies to undivided planar
roadways.
Attainment Method
Specifies the name of the attainment method used for the superelevation. Click the arrow to display a list
of the attainment methods associated with the specified design criteria file.
Normal Lane Width
Specifies the typical width of the roadway for each lane. Some superelevation attainment methods require
that you specify this value to calculate the length of the superelevation transition.
Normal Lane Slope (%)
Specifies the typical slope for the lane on the normal unsuperelevated roadway sections.
Normal Shoulder Width
Specifies the typical with of the shoulder.
Normal Shoulder Slope (%)
Specifies the % slope value of the roadway shoulders.
Outside and Inside Shoulder Superelevation Method
NOTE These options can vary based on the Roadway Type, and whether you select the Calculate check box
on the Shoulder Control page in the Superelevation wizard.
Specifies the method that is applied to the outside and inside shoulder during superelevation:
■

Default Slopes: Default slopes are retained and shoulders are not superelevated.
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■

Match Lane Slopes: Shoulder slopes match the slopes applied to the adjacent traveled ways through
out the superelevation process.

■

Breakover Removal: Shoulders on the outside edge of the curve are adjusted upward to match the
Normal Lane Slope (%) before the lane begins to superelevate. The highside shoulder slope matches
the highside lane slope throughout the superelevation process, and it then rotates downward back to
the Normal Shoulder Slope (%) value when the lanes are back to the un-superelevated condition.

Superelevation Status
Displays the current status of the superelevation data as Calculated, Not Calculated, or Out Of Date.
Recalculate
Click to recalculate the superelevation on all “out of date” curves. This option is displayed when a change
is made to the Superelevation Criteria or design speed.
Superelevation Wizard
Displays the Create Superelevation dialog box where you can specify superelevation for one curve, a
selection of curves, or the entire alignment.
Tabular Editor
Displays the Superelevation Tabular Editor. For more information, see Superelevation Tabular Editor
(Panorama) (page 2606).
Related procedures:
■

Using the Superelevation Curve Manager (page 1102)

Superelevation Import Dialog Box
Browse and select the CSV file that contains the superelevation data for import.
IMPORTANT
■

The layout of the columns in the CSV file must match the layout of the columns in the Superelevation
Tabular Editor. You can leave a column blank but the heading must be there. For more information, see
To import a .CSV file The layout of the columns in the CSV file must match the layout of the columns...
(page 1101).

■

The first column for Curve# is equivalent to the Region# in the previous versions of AutoCAD Civil 3D.
This column can contain text and numbers.

■

If you use the right-click copy to clipboard command to copy the contents of the tabular editor and paste
in Excel, you will get the rows for runoff and runout, and transition in and transition out regions. If you
create a CSV file from the Excel file and import it, those rows are ignored.

Alignment
Displays the name of the alignment.
File To Import
Click

and browse to the CSV file you want to import.

Related procedures:
■

Importing Superelevation Data (page 1100)
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Superelevation Tabular Editor (Panorama)
View and edit superelevation data for each curve or enter data manually.
The information that is displayed in the Superelevation Tabular Editor varies depending on the type of
roadway.
NOTE Edits you make in the Superelevation Tabular Editor or the Superelevation View are dynamic. Changes
made in one are reflected in the other.

Collapses all items in the tree view.

Expands all items in the tree view.

Add A Superelevation Critical Station
Specifies a station along the alignment. Select a row in the editor and click
, the tabular editor
temporarily closes and the command line prompts you to pick a station along the alignment.
Delete Critical Station or Superelevation Region
Deletes the selected region or station.
Import Superelevation Data From File
Displays the Superelevation Import dialog box. Click
want to import.

and browse to the location of the CSV file you

Superelevation Curve
This column displays the Transition In and Transition Out Regions for the curves in the alignment.
Expand each region to view or edit the superelevation parameters.
To manually add a new critical station, right-click a region or a parameter ➤ Add Station.
Critical Stations include:
■

Begin Normal Crown

■

Begin Normal Shoulder

■

Begin Full Super

■

End Full Super

■

End Normal Crown

■

End Normal Shoulder

■

Level Crown

■

Low Shoulder Match

■

Reverse Crown

■

Shoulder Breakover
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Columns
Superelevation Curve
Displays the superelevation curve. You cannot edit this field in this editor, but if you make changes in
the Superelevation Curve Manager, the changes are reflected in the tabular editor.
Start Station and End Station
Displays the start station and end station. When you edit these fields for a Runout or Runoff region or a
critical station, the distance field and rate of change field are updated. If the station you edit is the same
as the Start Station or End Station of a Runout or Runoff region, that station value is also updated and
the transition formula (% into tangent or spiral) is not maintained.
Length
Displays the length for the Transition In Region and the Transition Out Region. Specifies the length for
the Runout and Runoff. Editing the length value changes the station values and the rate of change field.
The station value(s) update with respect to the beginning or end of curve. The station value associated
with curve start and end changes when you change the distance values to maintain the percentage of
transition shift into the specified curve.
For example: without changing any of the other distance values.
■

30% of transition length should be into the curve

■

Start Station of Runoff is 1+00

■

End Station is 2+00

■

Beginning of Curve station is 1+70

and then change the Runoff value to 150 feet, you get the following results:
■

30% of transition length should be into the curve

■

Start Station of Runoff becomes 0+65

■

End Station of Runoff becomes 2+15(to maintain the transition length at 30% into the curve)

■

Beginning of Curve station is 1+70

Any other stations or regions associated with the superelevation curve shift by the same amount.
Overlap
Displays the
warning symbol for areas on the alignment where there is overlap. Click the
, and a
task dialog box is displayed showing the options to resolve overlap. The conditions are either a reverse
curve situation or a compound curve situation. To automatically resolve overlap you can select the option
on the Attainment page in the Superelevation wizard. However, there can be situations where overlap is
created by manually editing or by importing superelevation data.
Rate of Change
Specifies the change in slope over the distance between one critical station and the previous (sequential)
critical station for each lane. If you make changes to this field, the stations and distance values stay the
same and the slope values changes accordingly. (This column is hidden by default).
Curve Smoothing
Displays the curve smoothing if the option for curve smoothing was specified in the Superelevation wizard.
(This column is hidden by default)
All Lane Columns
Changes in lane columns are reflected in the rate of change value associated with the lane that you edit.
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Related procedures:
■

Editing Superelevation Data in the Tabular Editor (page 1108)

Superelevation View Feature Settings Dialog Box
Specify the default superelevation view style and name template.
Default Style
Specifies the default style for the superelevation view.
Default Name Format
Specifies the default name template for the superelevation view. For more information, see Name Template
Dialog Box (page 2022).
Related procedures:
■

Creating and Editing Superelevation Views (page 1107)

Superelevation View Properties Dialog Box
Specify properties for the superelevation profile view.

Information Tab (Superelevation View Properties Dialog Box)
Use this tab to specify the name and style for the superelevation view.
Name
Specifies the name for the Superelevation View.
Object Style
Specifies the style to apply to the Superelevation View.
Related procedures:
■

Creating and Editing Superelevation Views (page 1107)

Stations Tab (Superelevation View Properties Dialog Box)
Use this tab to specify the station range of the superelevation view.
Alignment Name
Displays the name of the alignment that is displayed in the Superelevation View.
Station Range
■

Data Range: Displays the start and end stations for the alignment. Specify this option to include the
entire alignment in the view.

■

User Specified Range: Specify the start and end stations for a section of the alignment that you want
to include in the view.

Related procedures:
■

Creating and Editing Superelevation Views (page 1107)
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Lanes Tab (Superelevation View Properties Dialog Box)
Use this tab to specify the lanes that are displayed in the superelevation view.
Lane
Specifies the lanes to include in the Superelevation View.
Display
Displays the lanes that are included in the view.
Color
Displays the color of the lanes that are included in the view. To change a lane color, click the cell and
select a color in the dialog box.
Related procedures:
■

Creating and Editing Superelevation Views (page 1107)

Superelevation View Style Dialog Box
Use this dialog box to create styles for superelevation views

Information Tab (Superelevation View Style Dialog Box)
Use this tab to change the superelevation view style name and description information, and to review details,
such as when the style was most recently modified.
For more information, see Information Tab (Style Dialog Box) (page 2017).
Related procedures:
■

Superelevation View Styles (page 1106)

Graph Tab (Superelevation View Style Dialog Box)
Use this tab to set the vertical scale of the superelevation view.

Vertical Scale
Vertical Unit Height
Specify the vertical height for the view.
Related procedures:
■

Superelevation View Styles (page 1106)

Horizontal Axes Tab (Superelevation View Style Dialog Box)
Use this tab to specify the settings for the tick marks on the horizontal axes of the superelevation view.

Major Tick Details
Select Axis To Control
Specifies the axis for which you adjust the Major Tick Details:
■

Top - Adjust Major Tick Details along the top axis.
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■

Bottom - Adjust Major Tick Details along the bottom axis.

Interval
Specifies the spacing of major ticks on the horizontal axis.

Critical Station Tick Details
Full Height Tick
Select this check box if you want a line across the view for each tick.
Small Ticks At
Specifies smaller ticks. Select the tick location (Top, Middle, or Bottom of the view).
Related procedures:
■

Superelevation View Styles (page 1106)

Display Tab (Superelevation View Style Dialog Box)
Use this tab to view or change the display and visibility of the superelevation view components.
Plan view is the only option available for the View Direction. For more information, see Display Tab (Style
Dialog Box) (page 2017).
Related procedures:
■

Superelevation View Styles (page 1106)

Summary Tab (Superelevation View Style Dialog Box)
Use this tab to review the properties for the Superelevation View style.
For more information, see Summary Tab (Style Dialog Box) (page 2020).
Related procedures:
■

Superelevation View Styles (page 1106)

Superelevation Wizard
Use this wizard to specify roadway type, number of lanes, shoulder control, and attainment method for
superelevation.

Calculate Superelevation - Roadway Type Page
Use this page of the wizard to specify the roadway type.
Undivided Crowned, Pivot Center
Undivided Planar, Pivot Center
Specify the default Highside Location for planar roads.
■

Left Edge: Specifies that the high side of the roadway is on the left edge on tangent (unsuperelevated)
sections when the corridor type is Undivided and the Cross Section Shape is planar.

■

Level: The roadway is level (0% slope) on tangent sections.
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■

Right Edge: Specifies that the high side of the roadway is on the right edge on tangent (unsuperelevated)
sections, when the corridor type is Undivided and the Cross Section Shape is planar.

Divided Crowned With Median
Divided Planar With Median
Related procedures:
■

Calculating Superelevation Data Using the Wizard (page 1098)

Calculate Superelevation - Lanes Page
Use this page of the wizard to specify the number of lanes and the lane width and slope values.
Type
Displays the roadway type.
Symmetric Roadway
Specifies that the roadway is symmetric. When the check box is selected, the left side of the dialog box is
disabled. Clear the check box in situations where the roadway is not symmetric and specify values for
both the left and right lanes.
NOTE If you select Symmetric Roadway, the left side of the dialog box is disabled and the values for both lanes
are the same.
Number of Lanes Left
Select the number of lanes from the list.
NOTE If you select '1' for the number of lanes, the lanes that are displayed in the Superelevation Tabular Editor
(Panorama) (page 2606) are the outside lanes. Any labels, expressions, or other references for the inside lanes do
not return a value in the tabular editor. To display values for the inside lanes in the tabular editor, select '2' for
the number of lanes.
Number of Lanes Right
Select the number of lanes from the list.
Normal Lane Width
Specifies the lane width.
Normal Lane Slope
Specifies the % slope for the roadway lanes on the normal (unsuperelevated) roadway sections.
Related procedures:
■

Calculating Superelevation Data Using the Wizard (page 1098)

Calculate Superelevation - Shoulder Control Page
Use this page of the wizard to specify the shoulder treatment.

Inside Median Shoulders and Outside Edge Shoulders
NOTE The Inside Median Shoulders section is disabled if you specify Undivided Crowned or Undivided Planar as
the Roadway Type on the first page of the Superelevation wizard.
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Calculate
Clear the Calculate button to disable Shoulder Treatment.
Shoulder Slope Treatment
Select one of the following treatments:
■

Default Slopes: Default slopes are retained and shoulders are not superelevated.

■

Match Lane Slopes: Shoulder slopes match the slopes applied to the adjacent traveled ways through
out the superelevation process.

■

Breakover Removal: Shoulders on the outside edge of the curve are adjusted upward to match the
Normal Lane Slope (%) before the lane begins to superelevate. The highside shoulder slope matches
the highside lane slope throughout the superelevation process, and it then rotates downward back to
the Normal Shoulder Slope (%) value when the lanes are back to the unsuperelevated condition.

Normal Shoulder Width
Specifies the typical width of the shoulder, either inside or outside.
Normal Shoulder Slope
Specifies the % slope value of the roadway shoulders.
Related procedures:
■

Calculating Superelevation Data Using the Wizard (page 1098)

Calculate Superelevation - Attainment Page
Use this page of the wizard to specify the design criteria file, superelevation rate table, transition length
table, and the attainment method.
Design Criteria File
Specifies the name of the design criteria file. This file defines minimum radius tables, superelevation
attainment methods and formulae, superelevation rates and transition lengths for various roadway types
and design speeds. Click

to browse to the location of the design criteria file.

NOTE The specified design criteria file determines the options that are available in the Superelevation Rate Table,
Transition Length Table, and Attainment Method options in the drop-down lists.
Superelevation Rate Table
Specifies the name of the superelevation rate table used to determine the maximum superelevation rate.
Click the arrow to display a list of the superelevation rate tables associated with the specified design criteria
file.
NOTE In the list, choose Superelevation Rate By Formula in situations where you want to calculate the
superelevation rate based on a formula rather than a pre-defined table. In the out-of-box criteria files that Civil
3D provides, there is a simple formula based on AASHTO standards that will calculate the superelevation for a
given radius and design speed. You can edit this formula to meet the requirements of local agencies that may
vary from AASHTO.
Transition Length Table
Specifies the name of the superelevation transition length table used to calculate the transition stations.
Click the arrow to display a list of the transition length tables associated with the specified superelevation
rate table.
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Attainment Method
Specifies the name of the superelevation attainment method. Click the arrow to display a list of the
attainment methods associated with the specified design criteria file.

Transition Formula For Superelevation Runoff
Specify the parameter for the transition formula from the criteria file. The percentage that is entered is
converted to a decimal percent and used in the formula. If specified design criteria file does not recognize
this parameter, this section is disabled. If a curve is preceded or succeeded by another curve, the tangent
transition formula is applied.
% On Tangent For Tangent-Curve
Specifies the percent of the transition length that is located on the tangent for tangent-curve or
curve-tangent situations.
% On Spiral For Spiral-Curve
Specifies the percent of the transition length that is located on the spiral for spiral-curve or curve-spiral
situations.

Curve Smoothing
Apply Curve Smoothing
Select the check box to enable the Curve Length field.
Curve Length
Enter a length value that is greater than zero. This value is displayed in the curve smoothing column of
the tabular grid editor. A smooth curve is also shown in the superelevation band and superelevation view
at the appropriate critical station.
The following illustration shows an example of the results when you apply curve
smoothing.

Automatically Resolve Overlap
Select this check box to automatically detect overlap conditions and eliminate the overlapping stations.
All transition stations between the End Full Superelevation station on the first curve and the Begin Full
Superelevation on the second curve are removed, for compound or reverse situations. This option is only
available when superelevation is applied to the whole alignment.
NOTE When this option is selected, corrections are made on all overlap situations. To remove automatic overlap,
clear the check box and recalculate superelevation.
Related procedures:
■

Calculating Superelevation Data Using the Wizard (page 1098)
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77

Surfaces Dialog Boxes

The following topics provide information about surfaces dialog boxes.

Add Breaklines Dialog Box
Use this dialog box to add breaklines to a surface.
Description
Specifies the description of the breaklines to be created.
Type
Specifies the type of breakline to add:
■

Standard: Creates standard breaklines.

■

Proximity: Creates proximity breaklines.

■

Wall: Creates wall breaklines.

■

From File: Imports breaklines from an FLT(.flt) format file.

■

Non-Destructive: Creates non-destructive breaklines.

For more information, see Types of Breaklines (page 668).
File Link Options
Specifies the file link option to use when importing breaklines from a file:
■

Break Link To File: Copies breaklines to the surface definition. The file is no longer referenced.

■

Maintain Link To File: Maintains a reference to the breakline file. The file is used when the surface is
rebuilt.

For more information, see Importing Breaklines from a File (page 674).

Weeding Factors
Available if you select Standard or Wall as the breakline type.
Distance
Specifies the weeding distance (page 679). Enter a value or click
in the drawing area.

to digitize the mid-ordinate distance

2615

Angle
Specifies the weeding angle (page 679). Enter a value or click
drawing area.

to digitize the mid-ordinate angle in the

Supplementing Factors
Distance
Specifies the weeding distance. Enter a value or click

to specify the distance in the drawing.

Mid-Ordinate Distance
Specifies the mid-ordinate distance (page 668) for the breaklines. Enter a value or click
mid-ordinate distance in the drawing.

to digitize the

Related procedures:
■

Breaklines (page 667)

Add Boundaries Dialog Box
Use this dialog box to add boundaries to the surface definition of the selected surface.
Name
Specifies the name of the boundary to be created. If you do not specify a name, the following default
naming convention is used: “Boundary<#>.” For example, if you do not enter a name, the first boundary
is named “Boundary1,” the second boundary is named “Boundary2,” and so on.
Type
Specifies the type of boundary to add. See Boundaries (page 661):
■

Outer: Creates an outer boundary for the surface.

NOTE Although you can define more than one outer boundary for a surface, only the last one created is used
by the surface.
■

Show: Creates a show boundary. Show boundaries are used to display an area inside a hide boundary.

■

Hide: Creates a hide boundary.

■

Data Clip: Creates a surface boundary limited by a polygon object from the drawing, such as 2D and
3D polylines, feature lines, survey figures, parcels, and circles. Any data added to a surface following
a data clip boundary is clipped to that boundary.

Non-Destructive Breakline
Specifies whether or not to create boundaries with non-destructive breaklines. This clips the triangle edges
exactly where they cross the boundary. This option is unavailable when Data Clip is selected as a boundary
type.
Mid-Ordinate Distance
Specifies the mid-ordinate distance for the boundaries breaklines, which is used to tessellate the polyline
arcs from which the boundary is being created. Click
drawing area.
Related procedures:
■

Boundaries (page 661)
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to digitize the mid-ordinate distance in the

Add Contour Data Dialog Box
Use this dialog box to add contour data to the surface definition of the selected surface. Weeding and
supplementing factors are used to add or remove vertices along a contour.
Description
Specifies the description of the contour data operation. If no description is specified, a default naming
convention is used: “Contour Data<#>”. For example, if you do not enter a description, the first contour
data operation is named “Contour Data1,” the second contour is named “Contour Data2,” and so on.

Weeding Factors
Distance
Specifies the contour weeding distance. Enter the distance value or click

to select it in the drawing.

Angle
Specifies the contour weeding angle. Enter the angle value or click

to select it in the drawing.

Supplementing Factors
Distance
Specifies the contour supplementing distance. Enter the distance value or click
drawing.

to select it in the

Mid-Ordinate Distance
Specifies the contour mid-ordinate distance. Enter the distance value or click

to select it in the drawing.

Minimize Flat Areas By
Filling Gaps In Contour Data
Specifies that small gaps in contours should be filled in.
Swapping Edges
Specifies that a non-contour common edge shared between a flat triangle and a non-flat triangle should
be swapped.
Adding Points To Flat Triangle Edges
Specifies that a new point should be added at the midpoint of an edge shared between a flat triangle and
a non-flat triangle.
Adding Points To Flat Edges
Specifies that a new point should be added to edges that bridge two same-elevation data contours and are
not in flat triangles.
OK
Click to accept the contour values. You are then prompted at the command line to select objects (Polylines)
from the drawing to define as contour data. When the objects are selected, the contour data is added to
the surface definition.
Related procedures:
■

Weeding and Supplementing Factors for Contours (page 679)

■

Adding Contour Data to a Surface (page 681)

■

Minimizing Flat Areas in a Surface (page 705)
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Add Point File Dialog Box
Use this dialog box to specify options before you add a point file to a surface.
Format
Specifies the format of the point data in the file.

Opens the Point File Format (page 2360) dialog box. Select a point file format, edit a point file format, or
create a point file format to use when importing the point data.
Source File
Specifies the name of the point data file. Enter a file name, including the full path name.

Opens the Select Source File dialog box. Browse to the location of the point data file. Select the file name,
and click Open.

Advanced Options
Do Elevation Adjustment If Possible
Specifies that elevation adjustments are performed. The point file format must contain Z+, Z-, or Thickness
columns. For more information, see Adjusting Elevation During Import and Transfer (page 528).
Do Coordinate Transformation If Possible
Specifies that coordinate transformations should occur. The point file format must have a coordinate zone
assigned to it, and the current drawing must have coordinate zone and transformation information
defined. The points are transformed to match the zone of the current drawing.
Do Coordinate Data Expansion If Possible
Specifies that coordinate data properties of the points, such as degrees, minutes, seconds, and hemisphere
for latitude and longitude, should be calculated if possible. These values are calculated from known
coordinate data information contained in the point data file, such as grid northing and grid easting.
Related procedures:
■

Adding Surface Data from a Point File (page 692)

Add Points from Drawing Objects Dialog Box
Use this dialog box to add point data from AutoCAD objects to the surface definition.
Object Type
Specifies the type of AutoCAD object to add:
■

Points: Creates surface point data from AutoCAD Point objects. The points XYZ coordinates are used
to define the surface point.

■

Lines: Creates point data from AutoCAD Line objects. The XYZ coordinates of the objects endpoints
are used to define surface points.

■

Blocks: Creates point data from AutoCAD Block Reference objects. The block insertion point XYZ
coordinates are used to define the surface point.

■

Text: Creates point data from AutoCAD Text objects. The text insertion point XYZ coordinates are
used to define the surface point.

■

3D Faces: Creates point data from AutoCAD 3DFace objects. The XYZ coordinates of the objects
endpoints are used to define surface points.
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■

Polyface: Creates point data from AutoCAD PolyFaceMesh objects. The XYZ coordinates of the objects
endpoints are used to define surface point.

Maintain Edges From Objects
Specifies whether to define the AutoCAD Civil 3D triangle edges based on the edges defined in the original
AutoCAD object. If selected, AutoCAD Civil 3D maintains the edges and does not attempt to optimize
the edges. Available when importing points from lines, 3D faces, and polyfaces.
Description
Specifies the description for the point data to be created.
Related procedures:
■

Adding Surface Point Data from AutoCAD Drawing Objects (page 689)

Boundary Properties Dialog Box
Use this dialog box to view the properties of the boundary in a surface.
Name
Specifies the boundary name.
Type
Displays the boundary type.

Properties Table
Displays the following properties:
Vertex
The vertex number of the boundary.
Easting (X)
The X-coordinate value of a boundary vertex.
Northing (Y)
The Y-coordinate value of a boundary vertex.
Elevation (Z)
The Z-coordinate value of a boundary vertex.
Related procedures:
■

Editing Boundary Properties (page 666)

■

Adding Boundaries to a Surface (page 664)

Breakline Properties Vista
Use this panorama vista to view the properties of the breaklines in a surface.
For general information about using panorama vistas, see The Panorama Window (page 119).
The properties grid displays the following columns:
Description
Displays a tree-view of breakline descriptions. Click a breakline to expand it and display its vertices.
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Easting (X)
Displays the X coordinate value of a breakline vertex.
Northing (Y)
Displays the Y coordinate value of a breakline vertex.
Elevation (Z)
Displays the Z coordinate value of a breakline vertex.
Related procedures:
■

Viewing Breakline Information (page 676)

■

Breaklines (page 667)

Catchment Area Dialog Box
Specify the properties of a catchment boundary and catchment point marker.

Catchment Area
Catchment Layer
Specifies the layer for the catchment region. The default value is zero. Click
select a different layer.

in the Value column to

Catchment Object Type
Specifies the object type for the catchment boundary.
■

Select 2D Polyline if you simply want to delineate a catchment region.

■

Select 3D Polyline if you want to perform visualization and drape the catchment boundary line over
the surface.

Catchment Marker
Specifies whether or not to add a catchment point marker to a catchment region.
Catchment Marker Style
Specifies the style of the catchment point marker. The default style is Standard. Click
different style.
Related procedures:
■

Displaying and Calculating Catchment Areas (page 768)

Composite Volume Vista (Panorama)
Use this panorama vista to create composite volume calculations.
Create New Volume Entry
Creates a new composite volume entry.
Delete Volume Entry
Deletes the highlighted composite volume entry from the list.
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to specify a

Import Volume Entries
Imports a volume entry that has been saved in XML format. Click to open the Import Volume Entries
dialog box, where you can browse for the XML file. After you select the file, a new volume entry is created
in the list.
Export Volume Entries
Exports the selected volume entry to an XML file. Click to display the Export Volume Entries dialog box,
from which you enter the file name and can browse to a location to save the XML file.
Recompute Volumes
Recalculates the composite volume. For example, if you have created a composite volume on a surface
that has been updated, you can click this button to recalculate the volume.
Create New Volume Entry from Surfaces
Creates a new composite volume entry. You are prompted to select the base surface (Surface 1) and
comparison surface (Surface 2). The cut, fill, net, and net graph are calculated and displayed in the table.
Index
Displays a list of numerical identifier assigned to each composite volume calculation.

Surface Pair
Base Surface
Specifies the base surface from which to create the composite volume. Click on the field and select the
surface from the list.
Comparison Surface
Specifies the comparison surface from which to create the composite volume. Click on the field and select
the surface from the list.

Volume
Cut
Displays the amount of material that has to be removed for the base surface to equal the comparison
surface.
Fill
Displays the amount of material that has to be added for the base surface to equal the comparison surface.
Net
Displays the cut minus the fill. For example, if a volume is 200 m3 of cut, and 100 m3 of fill, the net is
100 m3<cut>.
Net Graph
Displays a graphical percentage representation of the whole volume. A fill net is displayed as a green bar
indicating that material needs to be added to the project site. A cut net is displayed as a red bar, indicating
that material must be removed.
Related procedures:
■

Calculating Composite Volumes (page 740)

Create Mask/Mask Properties Dialog Box
Use this dialog box to create a mask or to modify the properties of an existing mask.
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Information
Name
Specifies the name of the mask.
Description
Specifies the description of the mask.

Masking
Mask Type
Specifies the mask type:
■

Inside: Creates an inside mask, which clips and hides the area inside the parcel or polygon area.

■

Outside: Creates an outside mask, which clips and hides the area outside the parcel or polygon area.

Render Only
Specifies whether you want to create a render-only mask with the specified render material applied to the
inside of the parcel or polygon.
Mid-Ordinate Distance
Specifies the mid-ordinate distance for the region segments, which is used to tessellate the polyline arcs
from which the region is being created. Click

to digitize the mid-ordinate distance in the drawing area.

Render Material
Specifies the render material (page 1761). Click

to select a render material.

Related procedures:
■

Masks (page 719)

Create Reports - Crossing Breakline Report Dialog Box
Generate a report that lists all the intersecting breaklines in the current drawing, specifies the x- and
y-coordinates of the intersection points and the elevation difference at these points.

List of Objects
Check All
Click to select or deselect all the objects in the list.
Survey Databases, Survey Figures, Surfaces
Specifies the entities to be analyzed for the presence of the intersecting breaklines.

Report Settings
Save Report To
Click <icon> to specify the location fro saving the report.
Related procedures:
■

Creating Breakline Reports (page 772)

Create Reports - Breakline Check Report Dialog Box
Generate a report that lists the surface breaklines, breaklines in a survey database, or survey figures that fall
outside of a specified range.
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List of Objects
Check All
Click to select or deselect all the objects in the list.
Survey Databases, Survey Figures, Surfaces
Specifies the entities that contain the breaklines to be analyzed.

Report Settings
Maximum 2D Length
Specifies the maximum length of the breakline segment.
Maximum Delta Z
Specifies the maximum vertical deflection value.
Minimum Elevation
Specifies the minimum elevation at any point along the breakline.
Maximum Elevation
Specifies the maximum elevation at any point along the breakline.
Related procedures:
■

Creating Breakline Reports (page 772)

Create Surface Dialog Box
Use this dialog box to specify the initial surface creation parameters, including surface type and layer.
Type
Specifies the type of surface to create.
Surface Layer
Displays the layer on which the surface is created.

Click to open the Object Layer dialog box where you can select a different layer for the surface.
The properties table section of the dialog box displays varying properties depending on the type of surface
selected in the Type field.

Information
Name
Specifies the name of the surface.
NOTE To name the surface, click its default name and enter a new name, or click the Name Template button
and use the name template. For more information, see Name Template Dialog Box (page 2022).
Description
Specifies a description of the surface.
Style
Specifies the style for the surface. Click
you can select a different style.

to open the Select Surface Style (page 2017) dialog box where
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Render Material
Specifies the render material (page 1761). Click

to select a render material.

Grid Parameters
This property group is displayed when Grid Surface is selected in the Type list.
Grid-X Spacing
Specifies the X distance between the grid lines. When selected, you can click
in the drawing area.

to digitize the spacing

Grid-Y Spacing
Specifies the Y distance between the grid lines. When selected, you can click
the drawing area.

to digitize the spacing in

Orientation
Specifies the direction for the grid in the X and Y directions. When selected, you can click
points in the drawing to define the orientation direction.

to pick two

Volume Surfaces
Base Surface
Specifies the base surface from which the volume surface is generated. Enter the surface name or click
to open the Select Base Surface (page 2027) dialog box where you can select the surface from the list.
Comparison Surface
Specifies the comparison surface from which the volume surface is generated. Enter the surface name or
click
o open the Select Comparison Surface (page 2027) dialog box where you can select the surface from
the list.
Cut Factor
Specifies the expansion value of the material (page 1280).
Fill Factor
Specifies the compaction value of the material (page 1280).
Related procedures:
■

Creating Surfaces (page 648)

Create Cropped Surface Dialog Box
Specify the cropping information.

Crop Information
Select Surface to Crop
Specifies a source surface. Click

to select the surface.

Select Crop Area
Specifies a method for cropping a surface.
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New Surface
Drawing for New Surface
Specifies a drawing where to place the new surface. Select from a new drawing, an existing drawing, or a
currently open drawing.
Create a New Drawing, Specify an Existing Drawing, Select an Open Drawing
Specify the location of a new drawing of the selected type.
Surface Style
Specifies the style to apply to a created surface.
Surface Layer
Specifies a layer to assign to a created surface.
Related procedures:
■

Cropping Surfaces (page 716)

Crossing Breaklines Vista
View the list of intersecting breaklines and resolve the conflicting breaklines using the various elevation
options.
Crossing Breakline list
Specifies the breakline or survey figure names, the x- and y-coordinates of all their crossing points, and
the elevation difference at these points.
NOTE The value in the Elevation Difference column is the difference between the first and the second breaklines.
If the first breakline lies below the second breakline, the elevation value is negative.
Auto Zoom
Select to automatically zoom to and center the selected breakline crossing point.
Zoom To
Click to manually zoom to and center the selected breakline crossing point.
NOTE The breakline with lower elevation is displayed in red. The blue color identifies the breakline with a higher
elevation.

Crossing Resolution
Elevation options
Specify the possible options to resolve the crossing breaklines:
■

Use Higher Elevation

■

Use Lower Elevation

■

Use Average Elevation

■

Specify Elevation

Resolve
Click to apply the selected elevation option to resolve the crossing breakline.
Trim
Click to trim the specified segment of the breakline.
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Related procedures:
■

Finding and Fixing Crossing Breaklines (page 771)

Define Basin From Entities Dialog Box
Use this dialog box to define a basin for stage storage analysis, from either surface contours or polylines.
This dialog box is accessed from the Stage Storage dialog box (page 2663).

Basin Creation Parameters
Basin Name
Specifies a name for the basin.
Define Basin From Surface Contours
Enables you to define the basin by using all contours in a selected surface in the drawing. After you select
this option, click Define to select the surface in the drawing. All contours in the surface are used in the
basin definition. Surface contours must be visible in the surface style to use this option. For more
information, see Displaying Contours for Stage Storage Analysis (page 744).
NOTE If you want to define the basin from selected contours instead of all contours, select the Define Basin
From Polylines option, and then click Extract Objects From Surface.
Define Basin From Polylines
Enables you to use one of the following methods of selecting polylines:
■

To select existing polylines in the drawing, select the Define Basin From Polylines option and then
click the Define button at the bottom of the dialog box and select the polylines in the drawing.

■

To define the basin from selected polylines that are extracted from surface contours, select the Define
Basin From Polylines option and then use the options in the Polyline Method Options section of the
dialog box. Then click Define to select the extracted polylines.

Polyline Method Options
The options in this section of the dialog box become enabled when you select Define Basin From Polylines.
Extract Objects From Surface
Extracts polylines from surface contours which you can then use to define the basin. After clicking the
button, select the surface in the drawing and press Enter. Surface contours must be visible in the surface
style to use this option. For more information, see Displaying Contours for Stage Storage Analysis (page
744). When you click Define in the Define Basin From Entities dialog box, you can then select the polylines
that were created to define the basin.
NOTE Whereas the Define Basin From Surface Contours option uses all of the surface contours for the input
data, you can use the Extract Objects From Surface option to extract data from selected contours, for example,
the contours that define a depression.
Change Selected Entities To The Following Layer
Specifies that selected entities are moved to a new layer. Enter the layer name.
Delete Unselected Entities On Selected Layers
Cleans up the drawing by deleting any entities that were created by the Extract Entities From Surface
button, but which you do not select with the Define button.
Define
Enables you to select polylines in the drawing to use to define the basin. After clicking the button, select
the polylines in the drawing. These may be existing polylines in the drawing, or polylines that were
extracted using the Extract Objects From Surface button.
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Related procedures:
■

To analyze stage storage volumes (page 744)

Define Basin From Entered Data Dialog Box
Use this dialog box to define a basin for stage storage analysis, by entering contour elevation and area data.
This dialog box enables you to enter data for contours that may not be available in digital format. If you
have an AutoCAD Civil 3D drawing with a surface or polylines, you may wish to use the Define Basin From
Entities (page 2626) dialog box instead.
This dialog box is accessed from the Stage Storage dialog box (page 2663).

Enter Contour Elevation Data
NOTE Only numeric values are accepted in these fields. The units are based on the Drawing Units specified on
the Units And Zone tab (page 80) of the Drawing Settings dialog box.
Contour Elevation
Specifies the elevation for the contours that represent the basin elevations. You can enter the contours
in any elevational order. When you click Add To Table, the data is sorted from lowest to highest elevations
in the Stage Storage dialog box.
NOTE You can press TAB to move to the next field in the dialog box.
Contour Area
Specifies the area for the contour that exists at the specified elevation.
Add To Table
Adds the specified data to the table in the Stage Storage (page 2663) dialog box.
NOTE If needed, you can return to the Define Basin From Entered Data dialog box, add more contour data,
and add it to the table.
Related procedures:
■

To analyze stage storage volumes (page 744)

DEM Coordinate System Properties Dialog Box
Use this dialog box to view the detailed properties of the coordinate system specified in the Select Coordinate
System dialog box.

DEM File (Add/Properties) Dialog Box
Use this dialog box to specify or view the DEM (.dem) file and DEM file information.
DEM File Name
Specifies the file name and path for an existing DEM file. Enter the name and path or click
the Import Surface dialog box and browse to the location of the DEM file.

to open

NOTE If you are viewing the properties of a DEM file, this field is read only.
DEM File Information
Displays the header information for the selected DEM file. For more information, see About DEM File
Data (page 684).
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DEM File
CS Code
Specifies the coordinate system code for the DEM file. Click
systems.

to select a code in the list of coordinate

Description
Displays the coordinate system description associated with CS Code.
Projection
Displays the coordinate system projection name.
Datum
Displays the coordinate system datum name.

Current Drawing
Displays the drawing coordinate system zone information. The drawing coordinate system is specified in
the Drawing Settings Dialog Box (page 2073).
CS Code
Displays the current drawings coordinate system code.
Description
Displays the current drawings coordinate system description.
Projection
Displays the current drawing coordinate system projection name.
Datum
Displays the current drawing coordinate system datum name.
NOTE The points of the DEM file are transformed from the specified coordinate system of the DEM file to the
coordinate system of the current drawing plus any Transformation settings specified in the Drawing Settings dialog
box. DEM files cannot be transformed for grid surfaces. If you include a DEM file as part of a grid surface definition,
its coordinate system must match that of the drawing, or it cannot be added.
Related procedures:
■

Adding DEM Files to a Surface (page 686)

■

Creating a Grid Surface from a DEM (page 656)

Drape Image Dialog Box
Use this dialog box to select an image from the drawing and overlay it over a surface.
Image
Specifies the image from the drawing to be overlaid on the surface. Click

to select the image.

Surface
Specifies the surface on which the image is draped.
Render Material Name
Specifies the name of the render material associated with the current image. Once created, this render
material can be applied to a different suitable surface.
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Related procedures:
■

Draping Images On Surfaces (page 750)

Edit Feature Settings - Surface Dialog Box
Use this dialog box to view and change surface-related settings.
This topic documents settings in all surface-related Edit Settings dialog boxes (drawing-level, feature-level,
and command-level).
■

Drawing-level ambient settings are identified by the

■

Surface feature settings are listed near the top of this dialog box, after the General property group, and
are identified by the

■

drawing icon.

surface icon.

Surface command settings are identified by the

command icon.

For general information about drawing, feature, and command settings and their interaction, see Working
with the Standard Settings Dialog Box Controls (page 78).
For information about drawing-level ambient settings, see Ambient Settings Tab (Drawing Settings Dialog
Box) (page 2078)

Default Styles
Use these settings to specify the default styles assigned to surfaces and surface-related labels.
Surface Default Style
Specifies the default surface style (page 748). Click in the Value column, and click
the Surface Default Style dialog box.

to select a style in

Marker Style
Specifies the default marker style. Click in the Value column, and click
Style dialog box.

to select a style in the Marker

Surface Spot Elevation Label Style
Specifies the default spot elevation label style. Click in the Value column, and click
the Surface Spot Elevation Label Style dialog box.

to select a style in

Surface Slope Label Style
Specifies the default slope label style. Click in the Value column, and click
Surface Slope Label Style dialog box.

to select a style in the

Render Material
Specifies the default render material. Click in the Value column, and click
in the Render Material dialog box (page 2027).

to select a render material

For information about style selection, see Select Style Dialog Box (page 2021).

Default Name Format
Use this setting to specify the default name format for new surfaces. Click in the Value column, and click
to make changes in the Name Template dialog box (page 2022).
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Contour Labeling Defaults
Use these settings to specify the defaults assigned to surface labels.
Display Contour Label Line
Specifies whether or not the contour label lines are displayed.
Surface Contour Label Style Major
Specifies the default major contour label style. Click in the Value column, and click
in the Surface Contour Label Style Major dialog box.

to select a style

Surface Contour Label Style Minor
Specifies the default minor contour label style. Click in the Value column, and click
in the Surface Contour Label Style Minor dialog box.

to select a style

Surface Contour Label Style User-defined
Specifies the default user-defined contour label style. Click in the Value column, and click
style in the Surface Contour Label Style User-defined dialog box.

to select a

Surface Defaults
Default Rebuild -Automatic
Specifies Automatic as the default setting for the Rebuild Surface command.

Add Contour Labeling
NOTE This property group is displayed when accessing the settings from the AddContourLabelingGroup command.
Use this setting to specify the defaults assigned to surface labels.
Interval Along Contour
Specifies the default distance between labels along the contour. Enter a value or click
select a distance in the drawing area.

to graphically

Import Options
NOTE This property group is displayed when accessing the settings from the AddSurfaceFromDemFile and
CreateSurfaceGridFromDemFile commands.
Use these settings to specify the defaults assigned when creating surfaces.
Use Custom Null Elevation
Specifies whether a custom null elevation is used when importing a surface from a DEM file.
Null Elevation
Specifies the default custom null elevation used when importing a surface from a DEM file.

Surface Creation
NOTE This property group is displayed when accessing the settings from the CreateSurface command.
Use these settings to specify the defaults assigned when creating surfaces.
Surface Default Type
Specifies the default surface type that is used when creating a surface. For more information, see
Understanding Surfaces (page 645).
Grid Surface X-Spacing
Specifies the default value for a grid surfaces X spacing.
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Grid Surface Y-Spacing
Specifies the default value for a grid surfaces Y spacing.
Grid Surface Orientation
Specifies the default orientation for a grid. Enter a value or click
in the drawing area.

to graphically select an orientation

Build Options
NOTE This property group is displayed (in different forms) when accessing the settings from the CreateSurface
and CreateSurfaceGridFromDemFile commands.
Use these settings to specify the build options assigned when creating surfaces.
NOTE Use these settings when creating a surface, but not when importing a surface from LandXML, DEM, or
TIN.
Copy Deleted Dependent Objects
Specifies whether a drawing object is copied to the surface definition item if the object is deleted.
Exclude Elevations Less Than
Specifies whether an elevation less than a certain value should be excluded when the surface is built.
Elevation <
Specifies the elevations to exclude when the Exclude Elevations Less Than property is set to Yes. Enter a
value or click

to select an elevation in the drawing area.

Exclude Elevations Greater Than
Specifies whether an elevation greater than a certain value should be excluded when the surface is built.
Elevation >
Specifies the elevations to exclude when the Exclude Elevations Greater Than property is set to Yes. Enter
a value or click

to select an elevation in the drawing area.

Use Maximum Triangle Length
Specifies whether the surface triangles that exceed the length specified by the Maximum Triangle Length
property are removed from the boundary of the surface (CreateSurface command only).
Maximum Triangle Length
Specifies the triangle length to use when the Use Maximum Triangle Length property is set to Yes. Enter
a value or click

to select a length in the drawing area (CreateSurface command only).

Convert Proximity Breaklines to Standard
Specifies whether proximity breaklines are converted to standard breaklines when the surface is built
(CreateSurface command only).
Allow Crossing Breaklines
Specifies whether breaklines can cross each other (CreateSurface command only).
Elevation To Use
Specifies the elevation to use for the crossing breaklines (CreateSurface command only):
■

Use First Breakline Elevation At Intersection: Uses the first breakline elevation to determine the elevation
at the intersection.

■

Use Last Breakline Elevation At Intersection: Uses the last breakline elevation to determine the elevation
at the intersection.
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■

Use Average Elevation At Intersection: Uses the average of the first and last breakline to determine the
elevation at the intersection.

For more information on these settings, see the Build properties in Definition Tab (Surface Properties Dialog
Box) (page 2656).

Water Drop Path
NOTE This property group is displayed when accessing the settings from the CreateSurfaceWaterdrop command.
Use these settings to specify default water drop path options for surfaces.
Path Layer
Specifies the default layer on which to draw the water drop path. Click in the Value column, and click
to select a type of path in the Path Layer dialog box.
Path Object Type
Specifies the default type of AutoCAD object to use for the water drop path. Either 2D Polyline or 3D
Polyline.

Water Drop Marker
NOTE This property group is displayed when accessing the settings from the CreateSurfaceWaterdrop command.
Use these settings to specify default water drop marker options for surfaces.
Place Marker At Start Point
Specifies whether to draw a marker at the start point of the water drop path.
Start Point Marker Style
Specifies the default start point marker style. Click in the Value column, and click
the Start Point Marker Style dialog box.

to select a style in

Google Earth Options
NOTE This property group is displayed when accessing the settings from the ImportGEData and ImportGESurface
commands.
Use these settings to specify the default number of rows and columns collected when importing Google
Earth information.
Google Earth Rows
Specifies the number of rows of data that are collected when importing terrain information from Google
Earth.
Google Earth Columns
Specifies the number of columns of data that are collected when importing terrain information from
Google Earth.

SimplifySurface
NOTE This property group is displayed when accessing the settings from the SimplifySurface command.
Use these settings to specify default options for simplifying surfaces.
Simplify Method
Specifies the default method by which surfaces will be simplified:
■

Edge Contraction: Contracts triangle edges to single points.
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■

Point Removal: Selects and removes surface points.

Region Options
Specifies the default method by which surfaces will be simplified:
■

Use Existing Surface Border: You specify the existing surface border as the boundary of the surface
simplification region.

■

Specify Window/Polygon: You specify the surface simplification region within a drawn rectangle.

■

Select Objects: You specify one of either 2D or 3D polylines, parcels, circles, feature lines, or survey
figures.

Use Percentage Of Points To Remove
Specifies whether simplify the image by removing a percent of surface points.
Percentage Of Points To Remove
Specifies the percent of surface points to remove.
Use Maximum Change In Elevation
Specifies whether you will set a default maximum change in elevation.
Maximum Change In Elevation
Specifies the maximum allowed difference between the elevation of the original surface and the elevation
of the simplified surface.
For more information about simplifying surfaces, see Simplify Surface Wizard (page 2641).

Export Options
NOTE This property group is displayed when accessing the settings from the SurfaceExportToDem command.
Use these settings to specify the defaults assigned when exporting surfaces to a DEM file.
Use Custom Null Elevation
Specifies whether a custom null elevation is used when exporting to a DEM file.
Null Elevation
Specifies the default custom null elevation used when exporting to a DEM file.
Grid Spacing
Specifies the spacing between grids when exporting to a DEM file.

Add Data Options
NOTE This property group is displayed when accessing the settings from the AddSurfaceContours,
AddSurfaceBoundaries, and AddSurfaceBreaklines commands.
Use these settings to specify the defaults assigned when adding contours, boundaries, and breaklines to a
surface.
Default Weeding Distance
Specifies the default weeding distance.
Default Weeding Angle
Specifies the default weeding angle.
Default Supplementing Distance
Specifies the default supplementing distance.
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Default Mid-ordinate Distance
Specifies the default mid-ordinate distance.
Default Boundary Type
Specifies the default boundary type.
Default Non-destructive Setting
Specifies the default selection of a type of breakline (destructive of non-destructive).
Related procedures:
■

Editing Surface Settings (page 737)

■

Adding and Editing Surface Data (page 660)

■

Analyzing Surfaces (page 764)

Export Surface to DEM Dialog Box
Use this dialog box to specify the parameters for exporting a surface to a DEM file.

Selected Surface
Name
Displays the name of the selected surface.
Description
Displays the description for the selected surface.
Drawing Coordinate Zone
Displays the drawing coordinate zone, if specified.

Export
DEM File Name
Specifies the file name, location, and file type of your new DEM file. The file can be of type USGS (.dem)
or GEOTIFF (.tiff). Click
to open the Export Surface to DEM dialog box, then browse to the location,
enter the file name and select file type.
Export Coordinate Zone
Specifies the coordinate zone of the exported surface. If the drawing has a coordinate zone assigned, this
coordinate zone is displayed. Click
to open the Select Coordinate System dialog box to select the
required coordinate system from the list.
Grid Spacing
Specifies the horizontal spacing for the DEM profile points. Enter an integer value that is greater than or
equal to 1. This value is specified in units used in the export coordinate zone.
Determine Elevations By
Specifies how the elevations of the DEM file are determined from the exported surface. Select one of the
following values:
■

Sample surface at grid point: Ensures that for each point along a DEM profile, the elevation is sampled
from the selected surface.

■

Average: Ensures that for each point along a DEM profile, the elevation value corresponds to the mean
elevation in a grid cell-sized region centered at this point.
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Use Custom Null Elevation
Specifies whether to use a custom value for null elevation.
Null Elevation
Specifies the default value for null elevation.
Related procedures:
■

Exporting to DEM (page 773)

Extract Objects from Surface Dialog Box
Use this dialog box to extract AutoCAD objects from a surface.
Property
Displays the currently visible surface components based on the surface style settings (see Display Tab
(Surface Style Dialog Box) (page 2655). By default, all the displayed surface components are selected when
the dialog box is opened.
Value
Specifies one of the following options:
■

Select All Extracts all the surface objects of the selected type.

■

Select from Drawing Extracts an individual surface element. Click
extract from the drawing.

to select the object you want to

Related procedures:
■

Extracting Surface Data (page 695)

Hatch Properties Dialog Box
Use this dialog box to select the display of the watershed hatching pattern.
Type
Sets the pattern type. Click the
■

button to select the hatching type from the drawing area:

Predefined: Specifies a predefined AutoCAD pattern. These patterns are stored in the acad.pat and
acadiso.pat files. You can control the angle and scale of any predefined pattern. For predefined ISO
patterns, you can also control the ISO pen width.
NOTE When you use the Solid predefined pattern, ensure that the boundary is closed and does not intersect
itself. In addition, if the hatch area contains more than one loop, the loops must not intersect. These
limitations do not apply to standard hatch patterns.

■

User-Defined: Creates a pattern of lines based on the current linetype in your drawing. You can control
the angle and spacing of the lines in your user-defined pattern.

■

Custom: Specifies a pattern that is defined in any custom PAT file that you have added to the AutoCAD
search path. (To use the patterns in the supplied acad.pat and acadiso.pat files, choose Predefined.) You
can control the angle and scale of any custom pattern.
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Pattern
Lists the available predefined patterns. The six most recently used predefined patterns appear at the top
of the list. The selected patterns are stored in the HPNAME system variable. Available only if Type is set
to Predefined.
Click
to open the Hatch Pattern Palette dialog box, where you can view preview images for all predefined
patterns.
Custom Pattern
Lists the available custom patterns. The six most recently used custom patterns appear at the top of the
list. AutoCAD stores the selected pattern in the HPNAME system variable. Available only if Type is set to
Custom.
Click
to open the Hatch Pattern Palette dialog box, where you can view preview images for all custom
patterns.
Angle
Specifies an angle for the hatch pattern relative to the X axis of the current UCS. AutoCAD stores the
angle in the HPANG system variable.
ISO Pen Width
Specifies that an ISO predefined pattern is scaled based on the selected pen width. Available only if you
set Type to Predefined and set Pattern to one of the available ISO patterns.
Scale
Expands or contracts a predefined or custom pattern. AutoCAD stores the scale in the HPSCALE system
variable. This option is available only if you set Type to Predefined or Custom.
Relative to Paper Space
Specifies that the hatch pattern is scaled relative to paper space units. Using this option, you can easily
display hatch patterns at a scale that is appropriate for your layout. Available only from a layout.
Spacing
Specifies the spacing of lines in a user-defined pattern. AutoCAD stores the spacing in the HPSPACE system
variable. Available only if you set Type to User-Defined.
Related procedures:
■

Watersheds (page 725)

Import GIS Data Wizard
Object Options Page (Import GIS Data Wizard)
Specify the type of object and the standard Civil object properties, such as object name, description, style,
layer, and the render material to be applied to the created object.
Related procedures:
■

Creating Surfaces from GIS Data (page 658)

Connect to Data Page (Import GIS Data Wizard)
Specify the connection settings to the GIS datastore.
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Data Source Type
ArcSDE
Specifies ESRI ArcSDE (Spatial Database Engine) as the imported data source.
Oracle
Specifies the Oracle database as the imported data source.
SHP
Specifies the ESRI shape file as the imported data source.

Connection Parameters
Server/Service/SHP Path
Specifies the path to the shape file, spatial data server, or Oracle database service hosting the GIS data.
Instance
Specifies the ArcSDE instance.
User Name/Password
Specifies the user authentication information for GIS datastore connection.
Datastore List
Specifies the available GIS datastores.
Connect to Datastore
Click to establish the connection with the selected GIS datastore.
Related procedures:
■

Creating Surfaces from GIS Data (page 658)

Schema and Coordinates Page (Import GIS Data Wizard)
Specify the GIS feature attributes.
Schema
Specifies a GIS schema, a metadata file that contains descriptions of data types found in a datastore.
Feature Class
Specifies the GIS feature class.
Restore the Original Coordinate System
Click to restore the imported file coordinate system to the original setting.
Drawing Coordinate System
Displays the coordinate zone assigned to the current drawing. Click

to select a coordinate zone.

Related procedures:
■

Creating Surfaces from GIS Data (page 658)

Geospatial Query Page (Import GIS Data Wizard)
Query the database for the types of geospatial data it contains.
Define Area of Interest By
Select to specify the area in the drawing.
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Polygon
Select to retrieve objects in the area defined by a polygon.
Fence
Select to retrieve objects that cross a defined line.
Circle
Select to retrieve objects in the area defined by a circle.

Query Type
Inside
Specifies a condition to find only objects that are completely within a boundary.
Crossing
Specifies a condition to find objects that are either completely within or crossing the boundary.
Related procedures:
■

Creating Surfaces from GIS Data (page 658)

Data Mapping Page (Import GIS Data Wizard)
Specify the GIS data attributes to be imported and the corresponding Civil 3D object property.

Map GIS Data to Civil 3D Properties
GIS Field
Specifies the GIS data attribute.
Civil 3D Property
Specifies the Civil 3D object property.
File Name
Specifies the name and location of the file to store the current data mapping information for future use.
Related procedures:
■

Creating Surfaces from GIS Data (page 658)

Mask Display Order Dialog Box
Use this dialog box to control the display order for render-only masks.
Masks listed higher are displayed on top of masks that are listed lower.

Mask List
This area lists the existing masks. Click a mask to select it.
Name
Displays the name of the mask.
Description
Displays the description for the mask.

Click to move the selected mask up in the display order list.
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Click to move the selected mask down in the display order list.
Related procedures:
■

Changing the Display Order of Render Only Masks (page 724)

Minimize Flat Areas Dialog Box
Use this dialog box to specify the parameters for minimizing flat areas on a surface.

Minimize Flat Areas By
Filling Gaps In Contour Data
Specifies that small gaps in contours should be filled in.
Swapping Edges
Specifies that a non-contour common edge shared between a flat triangle and a non-flat triangle should
be swapped.
Adding Points To Flat Triangle Edges
Specifies that a new point should be added at the midpoint of an edge shared between a flat triangle and
a non-flat triangle.
Adding Points To Flat Edges
Specifies that a new point should be added to edges that bridge two same-elevation data contours and are
not in flat triangles.
Related procedures:
■

Minimizing Flat Areas in a Surface (page 705)

Move Blocks to Surface Dialog Box
Use this dialog box to move selected Block Reference objects to the elevation on the selected surface.
Select block reference names
Displays the names of each block definition that is referenced in the drawing. Select a block definition
name from the list to select all Block Reference objects in the drawing or click
Block Reference objects and then press Enter.

to select individual

Total block reference objects selected
Displays the number of Block Reference objects selected.
Related procedures:
■

Moving Blocks to a Surface Elevation (page 694)

Move Blocks to Attribute Elevation Dialog Box
Use this dialog box to move selected Block Reference objects to a selected attribute elevation.
Select block reference name
Use to select a block definition name from the list. Click
from the drawing and then press Enter.

to select individual Block Reference objects
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Select elevation attribute tag
Specifies attribute tags for the selected Block Reference objects. If the Block Reference object does not have
associated attribute tags, this option is unavailable.
Total block reference objects selected
Specifies the number of Block Reference objects selected.
Related procedures:
■

Moving Blocks to Attribute Elevation (page 690)

Select Coordinate Zone Dialog Box
Use this dialog box to select the coordinate system.

Zone
Categories
Specifies the category of the coordinate system. This constrains the available coordinate systems.
Available Coordinate Systems
Specifies the available coordinate systems. Select from the list or enter a known coordinate system.
Selected Coordinate System Code
Specifies the code for the coordinate system. Populated when you specify a coordinate system or you can
enter a coordinate system code.
Description
Displays a description for the selected coordinate system.
Projection
Displays the projection for the selected coordinate system. For example, LL for Latitude/Longitude or TM
for Transverse Mercator.
Datum
Displays the datum for the selected coordinate system.
Related procedures:
■

Creating a Grid Surface from a DEM (page 656)

Select Render Material Dialog Box
Use this dialog box to specify a render material for an object.
Render materials list
Select a render material from the list.

Click to select a render material from the drawing.
Related procedures:
■

Applying Render Materials to Objects (page 1763)
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Select Coordinate System Dialog Box
Use this dialog box to specify a coordinate system for an exported DEM file.
Drawing Coordinate System
Displays the coordinate system used in the drawing that references the surface.
Select DEM System
Specifies the available coordinate systems in the Projected category. Click to see the complete list of
Projected coordinate systems.
Code
Displays the code for the selected coordinate system.
Area Of Use
Displays the region of the world where the selected coordinate system is used.
Properties
Click to see the detailed properties of the selected coordinate system and its projection.
Related procedures:
■

Exporting to DEM (page 773)

Simplify Surface Wizard
Use this wizard to reduce the number of points in a TIN surface.

Simplify Methods Page (Simplify Surface Wizard)
Specify the surface simplification methods.
Edge Contraction
Contracts triangle edges to single points. The location of the point to which an edge is contracted is
chosen so that the change to the surface is minimal. Each edge contraction results in the removal of one
point.
Point Removal
Selects and removes surface points. More points are removed from the denser areas of the surface.
Related procedures:
■

Simplifying Surfaces (page 715)

Region Options Page (Simplify Surface Wizard)
Specify surface regions for simplification.

Region Options
Use Existing Surface Border
Specifies the existing surface border as the boundary of the surface simplification region.
Specify Window/Polygon
Specifies the surface simplification region within a drawn rectangle.
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Pick In Drawing
Click to specify the first and second points of the rectangle that delimits the surface simplification region.
The button is unavailable, if Use Existing Surface Border is selected as a simplification option.
Select Objects
Specifies one of the following surface objects: 2D or 3D polyline, parcel, circle, feature line, or survey
figure.
Mid-Ordinate Distance
Specifies the default mid-ordinate length used for the Select Objects option. If the selected object contains
arc segments, each segment is tessellated into chord segments. The length of each chord segment is derived
from the specified mid-ordinate distance. See also Mid-ordinate distance (page 664). Enter the distance
value or click

to select the distance in the drawing.

Pick In Drawing
Click to select an object for simplification. The button is unavailable if Use Existing Surface Border is
selected as a simplification option.
Total Points Selected In Region
Specifies the total number of points in the selected surface simplification region.
Related procedures:
■

Simplifying Surfaces (page 715)

Reduction Options Page (Simplify Surface Wizard)
Fine-tune surface point reduction options.

Reduction Options
Total Points Selected In Region
Specifies the total number of points in the selected surface simplification region.
Percentage Of Points To Remove
Specifies the percent of surface points to remove.
Maximum Change In Elevation
Specifies the maximum allowed difference between the elevation of the original surface and the elevation
of the simplified surface.
Maximum Edge Contraction Error
Appears if you select Edge Contraction as a surface simplification method. It specifies a degree of the
surface change if the edge were contracted to a point. 100 represents the maximum error over all surface
edges and 0 represents the minimum.
Total Points Removed
Specifies the number of points removed after surface simplification. Press Apply to display the number.
Related procedures:
■

Simplifying Surfaces (page 715)

Smooth Surface Dialog Box
Use this dialog box to set up the parameters for surface smoothing.
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Smoothing Methods
Select Method
Specifies the type of surface smoothing to perform:
■

Natural Neighbor Interpolation: Specifies NNI and disables the Kriging Method property group.

■

Kriging: Specifies the Kriging method.

Kriging Method
Specifies the parameters for the Kriging surface smoothing method. Available when the Smoothing Methods
property is set to Kriging.
Semivariogram Model
Specifies the semivariogram to use. For more information, see Smoothing a Surface Using Kriging Method
(page 714).
Point Selection Method
Specifies the points to use for the surface smoothing extrapolation:
■

Select Points: Selects all points inside a rectangle, polygon, surface, or parcel.

■

Random Points: Selects random points inside a rectangle, polygon, surface, or parcel.

■

Select All Points: Selects all points on a surface.

Select Points
Specifies the points that are selected. Available only when either the Select Points or Random Points
parameters are selected. Click

and follow the command line prompts to select the points.

Point Interpolation/Extrapolation Output
Output Locations
Specifies the output location for the points:
■

Grid Based: Outputs points on a grid defined within specified polygon areas selected in the drawing.

■

Centroids: Outputs points at the existing surface triangle centroids within specified polygon areas
selected in the drawing.

■

Random Points: Outputs a specified number of random points within polygon areas selected in the
drawing.

For more information, see Understanding Point Interpolation/Extrapolation Output (page 712).
Select Output Region
Specifies the area which to output the points. Click
the area.

and follow the command line prompts to select

Grid X - Spacing
Specifies the X distance between the grid lines. Available only when the Grid Based option for point
output is selected. Click

to digitize the spacing in the drawing area.

Grid Y - Spacing
Specifies the Y distance between the grid lines. Available only when the Grid Based option for point output
is selected. Click

to digitize the spacing in the drawing area.
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Grid Orientation
The orientation direction for the grid in the Y and X directions. Available only when the Grid Based option
for point output is selected. Click

to pick two points in the drawing to define the orientation direction.

Number Of Output Points
Displays the number of points that are output.

Kriging Semivariogram Model
This area of the dialog box is displayed if the Kriging surface smoothing method is selected.
Parameter A
Specifies the semivariogram scale factor.
Parameter C
Specifies the semivariogram range factor.
Nugget Effect
Specifies the discontinuity at the origin of the semivariogram model. The magnitude of the discontinuity
is called the nugget and must be greater than 0.
Graph display area
Displays the semivariogram model (in red) against the actual surface points (in white). You can visually
verify both the model and the surface points at the same time.
Related procedures:
■

Smoothing Surfaces (page 711)

Surface Style Dialog Box
Use this dialog box to define a surface style, which controls the way a surface and its components, such as
watersheds and contours, are displayed.
See also:
■

Surface Styles and Visualization (page 748)

■

Analyzing Surfaces (page 764)

Information Tab (Surface Style Dialog Box)
Use this tab to change the surface style name and description information, and to review details, such as
when you recently modified the style.
Name
Specifies a name for the current style. The style name identifies the style on the Settings tab in Toolspace
and is listed in the Styles dialog box. Changes to a style name are reflected in the title bar of the Surface
Style dialog box.
Description
Specifies a description for the current style.
Created By
Displays the AutoCAD login name of the person who created the style.
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Date Created
Displays the style creation date and time.
Last Modified By
Displays the AutoCAD login name of the person who last modified the style.
Date Modified
Displays the last date and time of the style modifications.
Related procedures:
■

Surface Styles and Visualization (page 748)

■

Analyzing Surfaces (page 764)

Borders Tab (Surface Style Dialog Box)
Use this tab to specify settings for the border component of a surface object.
Borders display the actual extents of the surface, which can be different from boundaries (page 661), which
are used to define the surface extents.

3D Geometry
Border Display Mode
Specifies how to display the border:
■

Use Surface Elevation: Displays the border at its actual elevation values.

■

Flatten Elevations: Flattens or projects the border to the elevation value specified by the Flatten Borders
To Elevation property.

■

Exaggerate Elevation: Scales the border by the factor specified in the Exaggerate Borders By Scale Factor
property.

Flatten Borders To Elevation
Specifies the elevation used to flatten the borders; available only when Border Display Mode is set to
Flatten Elevations.
Exaggerate Borders By Scale Factor
Specifies the scale factor used to exaggerate the borders; available when Border Display Mode is set to
Exaggerate Elevation.

Border Types
Display Exterior Borders
Specifies whether to display outer borders. The outer border is the outer extents of the surface.
Display Interior Borders
Specifies whether to display all interior borders. This option is useful when you want to build footprints
or “holes” in your surface where survey data is not present or applicable, and you do not want to represent
elevations for that area.

Datum
Use Datum
Specifies whether or not the outer boundary can display a datum. The datum is displayed at the elevation
specified in the Datum Elevation property.
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Project Grid To Datum
Specifies whether the outer boundary segments are projected to the datum. The projection of outer
boundary segments to the datum is only visible when viewing the surface object in 3D.
Datum Elevation
Specifies the datum elevation. The datum is only visible when the border is displayed in 3D.
Related procedures:
■

Surface Styles and Visualization (page 748)

Contours Tab (Surface Style Dialog Box)
Use this tab to specify settings for the contour components of the surface object.

Contour Ranges
Specifies the default values for the contour analysis type. The contour analysis is created using the Surface
Properties - Analysis tab (page 2659).
Major Color Scheme
Specifies the major color scheme for the contour range. Available only if you set Use Color Scheme to
True.
Minor Color Scheme
Specifies the minor color scheme for the contour range. Available only if you set Use Color Scheme to
True.
Group Values By
Specifies the creation options for the contour ranges:
■

Equal Interval: Divides the data into the specified number of ranges from the minimum value to the
maximum. Also known as equal step, this method often over-generalizes the data, with large sets of
values in one group while others have a sparse set of values.

■

Quantile: Divides the data so that the specified number of ranges contains an equal number of values.
Also known as equal count, this method is most appropriate where the data values are linear (equally
distributed).

■

Standard Deviation: Calculates and divides the data based on how far data values differ from the
arithmetic mean. This method is most effective when the data approximates a normal distribution
(bell-shaped curve), and because of this curve preference, it is best used with an even number of ranges.
Standard deviations are often used to highlight how far above or below a specific value is in relation
to the mean value.

Number Of Ranges
Specifies the number of ranges to be used. For information about setting the display properties for contours
within each range, see the Major Display and Minor Display columns in the display table on this tab.
Range Precision
Specifies the formatting and rounding of range values. The rounding only affects the range value
calculations and resulting range intervals. It does not affect the actual data values.
Use Color Scheme
Specifies whether or not major and minor color schemes are active.
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3D Geometry
Contour Display Mode
Specifies the display properties of the contours:
■

Use Surface Elevation: Displays the contours at their actual elevation values.

■

Flatten Elevations: Flattens or projects the contours to the elevation value specified by the Flatten
Contours To Elevation property.

■

Exaggerate Elevation: Scales the contours by the factor specified in the Exaggerate Contours By Scale
Factor property.

Flatten Contours To Elevation
Specifies the elevation used to flatten the contours; available only when the Contour Display Mode is set
to Flatten Elevations.
Exaggerate Contours By Scale Factor
Specifies the scale factor used to exaggerate the contours; available only when the Contour Display Mode
is set to Exaggerate Elevation.

Legend
Contour Legend Style
Specifies the default contour table (legend) style. Click
where you can select a style.

to open the Contour Legend Style dialog box

Contour Intervals
Base Elevation
Specifies the relative base elevation for the contour intervals. The contour at the base elevation is a major
contour.
Minor Interval
Specifies the distance between minor contours. This value is displayed in the drawings linear units. The
interval is relative to the Base Elevation value.
Major Interval
Specifies the distance between major contours. This value is displayed in the drawings linear units. The
value entered here is divisible by the minor interval. The interval is relative to the base elevation value.

Contour Depressions
Display Depression Contours
Specifies whether or not depression contours are displayed.
Tick Mark Interval
Specifies the spacing of the tick marks along the depression contour.
Tick Mark Length
Specifies the length of the tick mark along the depression contour. The tick mark is drawn on the downhill
side of the depression contour.

Contour Smoothing
NOTE Do not enable contour smoothing if you plan to use surface smoothing. For more information, see Smoothing
Surfaces (page 711).
Smooth Contours
Specifies whether or not to use contour smoothing. Click True to smooth contours in accordance with
the Smoothing Type parameter and the value set in the Contour Smoothing slider.
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NOTE Use the Contour Smoothing slider (at the bottom of the dialog box) to increase or decrease the smoothing.
Smoothing Type
Specifies the type of smoothing used to display contour curves:
■

Add Vertices: Adds vertices along the contours. This option supplements points on the contours when
smoothing them, giving them a more noticeably curved appearance, while maintaining the highest
level of integrity relative to the surface.

■

Spline Curve: Passes a spline curve through the contour points. This option creates the smoothest
contour representation.

Display table
Use the following settings for each contour range specified using the Contour Ranges property group in the
Properties list:
Number
Displays the number for the contour range. The numbers match the value set in the Number of Ranges
property.
Major Display
Specifies a display properties for major contours. Click
Click

to select a linetype. Click

to select a lineweight.

to select a linetype. Click

to select a lineweight.

to select a color.

Minor Display
Specifies a display properties for minor contours. Click
Click

to select a color.

NOTE After you specify the Contour Ranges properties and set the display properties, run the contour analysis to
see the changes in the surface. For information, see Creating Surface Analysis (page 764).

Contour Smoothing slidebar
Use the Contour Smoothing slidebar to give the contours a smoother appearance. The slidebar is enabled if
the Smooth Contours property (under the Contour Smoothing property group) is set to True.
Related procedures:
■

Surface Styles and Visualization (page 748)

■

Contours (page 678)

Grid Tab (Surface Style Dialog Box)
Use this tab to specify the settings for the grid line components of the surface object.

3D Geometry
Grid Display Mode
Specifies how the grid is displayed:
■

Use Surface Elevation: Displays the grid at its actual elevation values.

■

Flatten Elevations: Flattens or projects the grid to the elevation value specified by the Flatten Grid To
Elevation property.

■

Exaggerate Elevation: Scales the grid by the factor specified in the Exaggerate Grid By Scale Factor
property.
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Flatten Grid To Elevation
Specifies the elevation used to flatten the grid; available only when you set the Grid Display Mode to
Flatten Elevations.
Exaggerate Grid By Scale Factor
Specifies the scale factor used to exaggerate the grid; available only when you set the Grid Display Mode
to Exaggerate Elevation.

Primary Grid
Specifies whether the primary grid lines are used in the grid display as well as the primary grid interval value
and orientation.
Use Primary Grid
Specifies whether or not the primary grid lines are used in the grid display. Click True to use the primary
grid lines in the grid display.
Interval
Specifies the primary grid interval value in drawing linear units. The primary grid lines are the north-south,
or longitudinal grid lines.
Orientation
Specifies the angle of orientation for the primary grid lines. The angle is clockwise (+), or counterclockwise
(-) from the North-South meridian.

Secondary Grid
Specifies whether the secondary grid lines are used in the grid display as well as the secondary grid interval
value and orientation.
Use Secondary Grid
Specifies whether or not the secondary grid lines are used in the grid display. Click True to use the secondary
grid lines in the grid display.
Interval
Specifies the secondary grid interval value in drawing linear units. The secondary grid lines are the east-west,
or latitudinal, grid lines.
Orientation
Specifies the angle of orientation for the secondary grid lines. The angle is clockwise (+), or counterclockwise
(-) from the East-West meridian.
Related procedures:
■

Surface Styles and Visualization (page 748)

Points Tab (Surface Style Dialog Box)
Use this tab to specify the settings for point components of the surface objects.

3D Geometry
Point Display Mode
Specifies the points display properties:
■

Use Surface Elevation: Displays the points at their actual elevation values.

■

Flatten Elevations: Flattens or projects the points to the elevation value specified by the Flatten Points
To Elevation property.
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■

Exaggerate Elevation: Scales the points by the factor specified in the Exaggerate Points By Scale Factor
property.

Flatten Points To Elevation
Specifies the elevation used to flatten the points; available only when you set the Point Display Mode to
Flatten Elevations.
Exaggerate Points By Scale Factor
Specifies the scale factor used to exaggerate the points; available only when you set the Point Display
Mode to Exaggerate Elevation.

Point Size
Point Scaling Method
Specifies the scaling method, which, in combination with the Point Units value, determines the point
symbol size:
■

Use Drawing Scale: Specifies that the point size is a product of the value specified in the Point Units
property and the drawing scale. For example, with a 1”=40’ drawing scale, using a Point Units value
of 0.1 is the equivalent of using Size In Absolute Units with a value of 4’.

■

Size Relative To Screen: Specifies that the point symbol size is a percentage of the screen size. The
percentage value is specified by the Point Units property.

■

Size In Absolute Units: The value specified in the Point Units property is the absolute point symbol
size.

Point Units
Specifies the value used for the point size.

Point Display
Data Point Symbol
Specifies the symbology of the data point display. Click

to select a data point symbol.

Data Point Color
Specifies the color of the data point. Click

to select a data point color.

Derived Point Symbol
Specifies the symbology of the derived point display. A derived point is not a data point, but a calculated
one (for example, from a surface smoothing operation). Click

to select a derived point symbol.

Derived Point Color
Specifies the color of the derived point. Click

to select a derived point color.

Non-Destructive Point Symbol
Specifies the symbology of the non-destructive point display. Non-destructive points are creating when
adding non-destructive breaklines. Click

to select a non-destructive point symbol.

Non-Destructive Point Color
Specifies the color of the non-destructive point. Click

to select a non-destructive point color.

NOTE If you specify a color for the points using the Point Display properties, it overrides the color specified on
the Display tab. The default color value is set to ByBlock when a new style is initialized. When set to ByBlock, the
color specified on the Display tab is used.
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Related procedures:
■

Surface Styles and Visualization (page 748)

Triangles Tab (Surface Style Dialog Box)
Use this tab to specify the properties of the triangle components of the surface object.

3D Geometry
Triangle Display Mode
Specifies the triangles display properties:
■

Use Surface Elevation: Displays the triangles at their actual elevation values.

■

Flatten Elevations: Flattens or projects the triangles to the elevation value specified by the Flatten
Triangles To Elevation property.

■

Exaggerate Elevation: Scales the triangles by the factor specified in the Exaggerate Triangles By Scale
Factor property.

Flatten Triangles To Elevation
Specifies the elevation used to flatten the triangles; available only when you set the Triangle Display Mode
to Flatten Elevations.
Exaggerate Triangles By Scale Factor
Specifies the scale factor used to exaggerate the triangles; available only when you set the Triangle Display
Mode to Exaggerate Elevation.
Related procedures:
■

Surface Styles and Visualization (page 748)

Watersheds Tab (Surface Style Dialog Box)
Use this tab to control the display of watersheds.

3D Geometry
Watershed Display Mode
Specifies the watersheds display properties:
■

Use Surface Elevation: Displays the watersheds at their actual elevation values.

■

Flatten Elevations: Flattens or projects the watersheds to the elevation value specified by the Flatten
Watersheds To Elevation property.

■

Exaggerate Elevation: Scales the watersheds by the factor specified in the Exaggerate Watersheds By
Scale Factor property.

Flatten Watersheds To Elevation
Specifies the elevation used to flatten the watersheds; available only when you set the Watershed Display
Mode to Flatten Elevations.
Exaggerate Watersheds By Scale Factor
Specifies the scale factor used to exaggerate the watersheds; available only when you set the Watershed
Display Mode to Exaggerate Elevation.
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Point Size
Specifies the size and scaling method of the drain target points.
Watershed Scaling Method
Specifies the scaling method, which, in combination with the Watershed Units value, determines the
point symbol size:
■

Use Drawing Scale: Specifies that the point size is a product of the value specified in the Watershed
Units property and the drawing scale. For example, with a 1”=40’ drawing scale, using a Watershed
Units value of 0.1 is the equivalent of using Size In Absolute Units with a value of 4’.

■

Size Relative To Screen: Specifies that the point symbol size is a percentage of the screen size. The
percentage value is specified by the Watershed Units property.

■

Size In Absolute Units: The value specified in the Watershed Units property is the absolute point symbol
size.

Watershed Units
Specifies the value for the point size.

Surface
Surface Watershed Label Style
Specifies the default watershed label style. Click

to select a style.

Legend
Watershed Legend Style
Specifies the default watershed table (legend) style. Click

to select a style.

Boundary Point, Boundary Segment, Depression, Flat Area, Multi-drain, Multi-drain Notch
The above watershed categories have the following common properties.
Color
Specifies the color of the watershed. Click

to select the color.

Linetype
Specifies a linetype for the watershed. Click

to select a linetype.

Use Hatching
Specifies whether or not to use a hatch pattern for the watershed.
Hatch Pattern
Specifies the hatch pattern to use for the watershed; available only when you set the Use Hatching parameter
mode to True. Click
pattern.

to open the Hatch Properties Dialog Box (page 2635) where you can select a hatch

Draw Drain Target Point
Specifies whether or not to display drain target points for the watershed.
NOTE For depression watersheds, this setting controls if the bottom points of the depression are displayed.
Drain Target Point Display
Specifies the symbology of the drain target point display. Click

to select a drain target point symbol.

Drain Target Point Color
Specifies the color of the drain target point. Click
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to select a drain target point color.

Draw Drain Target Segment
Specifies whether or not to display drain target segments for the watershed.
NOTE For depression watersheds, this setting controls if the segments between the bottom points of the
depression are displayed.
Drain Target Segment Color
Specifies the color of the drain target segment. Click

to select a drain target segment color.

Drain Target Segment Linetype
Specifies a linetype for the drain target segment. Click

to select a linetype.

Related procedures:
■

Watersheds (page 725)

■

Surface Styles and Visualization (page 748)

Analysis Tab (Surface Style Dialog Box)
Use this tab to specify the display parameters for the surface analysis displays that have common view
properties.

Directions
Specifies the display properties for directional (aspect) analysis. Renders surface triangles according to the
direction that they face.
Group By
Specifies the direction ranges creation properties:
■

Equal Interval: Divides the data into the specified number of ranges from the minimum value to the
maximum. Also known as equal step, this method often over-generalizes the data, with large sets of
values in one group while others have a sparse set of values.

■

Quantile: Divides the data such that the specified number of ranges contains an equal number of
values. Also known as equal count, this method is most appropriate where the data values are linear
(equally distributed).

■

Standard Deviation: Calculates and divides the data based on how far data values differ from the
arithmetic mean. This method is most effective when the data approximates a normal distribution
(bell-shaped curve), and because of this curve preference, it is best used with an even number of ranges.
Standard deviations are often used to highlight how far above or below a specific value is in relation
to the mean value.

Number of Ranges
Specifies the number of ranges to be used.
Range Precision
Specifies the range precision value.
Display Type
Specifies the entity type to be drawn within the analysis view:
■

3D Faces: Generates a surface analysis display containing 3D Faces. Useful when viewing the object
in 3D. If you use the AutoCAD Explode command, the analysis view explodes to 3D Face entities.

■

2D Solid: Generates a surface analysis display containing 2D Solid hatching. Useful when viewing the
object in 2D. If you use the AutoCAD Explode command, the analysis view explodes to Solid entities.
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■

Hatch Solid: Generates hatching within polygons containing triangle faces that match the criteria for
a specific range. Useful when viewing the object in 2D. If you use the AutoCAD Explode command,
the analysis view explodes to Hatch entities.

■

Mesh: Generates a surface analysis display containing a mesh. Useful when viewing the object in 3D.

Scheme
Specifies the color scheme for the range.
Legend Style
Specifies the default analysis table (legend) style. Click

to select a style.

Directions Display Mode
Specifies watersheds display properties:
■

Use Surface Elevation: Displays the directions at their actual elevation values.

■

Flatten Elevations: Flattens or projects the directions to the elevation value specified by the Flatten
Directions To Elevation property.

■

Exaggerate Elevation: Scales the directions by the factor specified in the Exaggerate Directions By Scale
Factor property.

Flatten Directions To Elevation
Specifies the elevation used to flatten the directions display. Available only when you set the Directions
Display Mode to Flatten Elevations.
Exaggerate Directions By Scale Factor
Specifies the scale factor used to exaggerate the directions display. Available only when you set the
Directions Display Mode to Exaggerate Elevation.

Elevations
Specifies the display properties for elevation banding analysis. Renders surface triangles within an elevation
range.
NOTE Elevations analysis display properties are the same as the Directions properties.

Slopes
Specifies the display properties for slope analysis. Renders surface triangles within a slope range.
NOTE Slopes analysis display properties are the same as the Directions properties.

Slope Arrows
Used for slope direction analysis. Places a slope directional arrow at each triangle centroid. Arrow color is
based on the color assigned to a slope range (similar to slope analysis).
Uses the same display properties as the Directions properties, with the following additional properties:
Arrow Type
Specifies the type of arrow to use:
■

Filled:

■

Closed:

■

Open:

■

Double:
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Arrow Length
Specifies the length of the slope arrow that is displayed in a Slope Arrows surface analysis view.
Related procedures:
■

Analyzing Surfaces (page 764)

Display Tab (Surface Style Dialog Box)
Use this tab to control the visibility and display of the components that make up a surface. You can change
the visibility, color, or layer for the surface components at various phases in a project.
Surface components include:
■

Points: All surface points for the TIN or grid surfaces.

■

Triangles: TIN face lines.

■

Border: Interior and exterior border lines.

■

Major Contour: Contour lines defined as major interval.

■

Minor Contour: Contour lines defined as minor interval.

■

User Contours: User-defined contour lines.

■

Gridded: Primary and secondary grid lines.

■

Directions: Direction or aspect analysis display.

■

Elevations: Elevation banding analysis display.

■

Slopes: Slope analysis display.

■

Slope Arrows: Slope arrow analysis display.

■

Watersheds: Watershed analysis display.

NOTE Surface styles have unique display values and varying numbers of displayed components, depending on
whether you select 2D or 3D view.
For more information about the properties in this tab, see Display Tab (Style Dialog Box) (page 2017).

Summary Tab (Surface Style Dialog Box)
Use this tab to view all the surface style properties. For more information about the properties in this tab,
see Summary Tab (Style Dialog Box) (page 2020).

Surface Properties Dialog Box
Use this dialog box to change the properties of a surface.
Surface properties control which data is included in the surface. You also use the Surface Properties dialog
box to perform analysis calculations on the surface.
See also:
■

Understanding the Surface Definition (page 660)
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■

Excluding Data from the Surface Build (page 718)

■

Analyzing Surfaces (page 764)

Information Tab (Surface Properties Dialog Box)
Use this tab to view or change general information for the surface.
Name
Specifies the name of the current surface.
Description
Specifies the description of the current surface.
Object Style
Specifies the default surface style used to display a surface. Select a style in the list or use the standard
selection tools. For more information about the standard selection tools, see Select Style Dialog Box (page
2021).
Render Material
Specifies the default render material used to display a surface. Select a render material in the list or use
the standard selection tools. For more information, see Applying Render Materials to Objects (page 1763),
Select Render Material Dialog Box (page 2640).
Object Locked
Specifies whether the surface is locked and cannot be edited.
Show Tooltips
Controls whether tooltips are displayed for the object in the drawing (does not affect tooltips over toolbar
icons).
Related procedures:
■

Creating Surfaces (page 648)

■

Project Management (page 143)

Definition Tab (Surface Properties Dialog Box)
Use this tab to switch various data and edit items on or off, or remove surface definition items.
The bottom part of the tab lists the surface definition (operation types) in the order that the operations were
performed. You can reorder the surface operations in the list.
NOTE Properties that are not applicable for the current surface type are unavailable.

Build
NOTE You can set the default settings for the Build properties in the Edit Command Settings - CreateSurface
dialog box, which is accessed from the Settings tab on the Toolspace (under <drawing-name> ➤ Surface ➤
Commands, right-click

CreateSurface and click Edit Commands Settings).

Copy Deleted Dependent Objects
Specifies whether a drawing object is copied to the surface definition item if the object is deleted:
■

Yes: Copies the drawing object data to the surface definition if you delete the drawing object data.
When you add a surface boundary, breakline, or point group to a surface, the surface definition stores
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the Object ID. If the drawing object, such as the original polyline used to define the surface boundary,
is deleted from the drawing, the coordinates of the polyline vertices are copied into the surface definition
and saved. Thus, the surface boundary definition remains in the surface definition.
■

No: Deletes the surface boundary, breakline, or point group definition if the drawing object is deleted.
The definition item is removed from the surface definition when the surface is rebuilt.

Exclude Elevations Less Than
Specifies whether an elevation less than a certain value should be excluded when the surface is built. Click
Yes to exclude elevations less than the value specified in the Elevation < when the surface is built.
Elevation <
Specifies the elevations to exclude when the Exclude Elevations Less Than property is set to Yes.
Exclude Elevations Greater Than
Specifies whether an elevation greater than a certain value should be excluded when the surface is built.
Click Yes to exclude elevations greater than the value specified in the Elevation > when the surface is
built.
Elevation >
Specifies the elevations to exclude when the Exclude Elevations Greater Than property is set to Yes.
Use Maximum Triangle Length
Specifies whether the surface triangles that exceed the length specified by the Maximum Triangle Length
property are removed from the boundary of the surface. Click Yes to remove triangles with a length greater
than the value specified in the Maximum Triangle Length when the surface is built.
Maximum Triangle Length
Specifies the triangle length to use when the Use Maximum Triangle Length property is set to Yes.
Convert Proximity Breaklines to Standard
Specifies whether proximity breaklines are converted to standard breaklines when the surface is built. For
more information, see Types of Breaklines (page 668). Click Yes to convert proximity breaklines to standard
breaklines.
Allow Crossing Breaklines
Specifies whether breaklines can cross each other. Click Yes to enable the correction of crossing breaklines
when they occur. If a new breakline touches an existing breakline, you can specify what elevation to use
at the calculated point of intersection. The XY coordinate location is calculated and the elevation is set
by the Elevation To Use property.
This setting does not apply to breakline intersections that occur at the endpoints of breaklines. You can
change the elevation of such points using the surface Modify Point operation. For more information, see
Modifying Surface Points (page 703).
Elevation To Use
Specifies the elevation to use for the crossing breaklines:
■

Use First Breakline Elevation At Intersection: Uses the first breakline elevation to determine the elevation
at the intersection.

■

Use Last Breakline Elevation At Intersection: Uses the last breakline elevation to determine the elevation
at the intersection.

■

Use Average Elevation At Intersection: Uses the average of the first and last breakline to determine the
elevation at the intersection.
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Data Operations
All Data Operations properties specify whether a data definition of a certain type is included in the surface
build.
■

Yes: All data operations of the specified type are selected in the Operation Type list and included in the
surface build.

■

No: All data operations of the specified type are cleared in the Operation Type list and not included in
the surface build.

If the Operation Type list contains mixed selected and cleared items of a specific data type, the specific data
operation is displayed as **Varies**.
For information about data operations supported by each surface type, see Understanding the Surface
Definition (page 660).

Edit Operations
All Edit Operations specify whether surface operations of a specific type are included in the surface build.
■

Yes: All edit operations of specified type are selected in the Operation Type list and included in the surface
build.

■

No: All edit operations of the specified type are cleared in the Operation Type list and not included in
the surface build.

If the Operation Type list contains mixed selected and cleared items of a specific edit type, the specific edit
is displayed as **Varies**.
For information on edit operations supported by each surface type, see Surface Editing Operations (page
699).

Operation Type
The Operation Type list displays the surface operations and their applicable parameters in the order in which
they were performed. Clear an operation to remove it from the surface definition.
Edit the definition list by selecting or clearing a definition item, or deleting the item from the list. When
definition items are cleared, the surface is updated, but the surface still has a reference to the definition item.
If the definition item is deleted from the list, the definition item data is permanently removed from the
surface.
Reorder surface operations in the surface definition using the following controls:

Moves a selected operation to the top of the list.

Moves a selected operation one position up.

Moves a selected operation one position down.

Moves a selected operation to the bottom of the list.
For information about errors that can occur in the Operation Type list, see Surface Errors and Issues (page
696).
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Related procedures:
■

Understanding the Surface Definition (page 660)

■

Excluding Data from the Surface Build (page 718)

■

Editing and Viewing the Surface Definition (page 731)

Analysis Tab (Surface Properties Dialog Box)
Use this tab to modify the properties of a selected surface analysis type.
NOTE The Analysis tab displays varying fields and options depending on the type of analysis that you select.
Analysis Type
Specifies the current analysis type properties that you can modify.
NOTE You set the default values for the analysis in the Analysis tab of the Surface Style dialog box.
■

Contours: Specifies the contours analysis properties.

■

Directions: Specifies the directions analysis properties.

■

Elevations: Specifies the elevations analysis properties.

■

Slopes: Specifies the slopes analysis properties.

■

Slope Arrows: Specifies the slope arrows analysis properties.

■

User-Defined Contours: Specifies the user-defined contours analysis properties.

■

Watersheds: Specifies the watersheds analysis properties.

Preview
Displays a preview of the legend table for the current analysis type. Clear the check box to disable the
preview option.
Legend
Specifies the legend style for the current analysis type.
NOTE You set the default style on the Analysis tab of the Surface Styles dialog box.

Ranges
Specifies the number of ranges to use for contours, directions, elevations, slopes, slope arrows, and user-defined
contour analysis.
Number
Specifies the numbers of ranges in the analysis. Enter a number or click the up/down arrows to increment
the value.
NOTE The default number of ranges is set in the Analysis tab of the Surface Styles dialog box.

Generates the analysis and updates the Range Details group box with the analysis information.

Watershed Parameters
Displayed if Analysis Type is set to Watersheds. Specifies the minimum depression depth and area for
watershed analysis.
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Minimum Average Depth Threshold
Specifies the minimum average depth at which a depression in the surface may be considered a watershed.
This prevents minor depression depths from being defined as watersheds.
Merge Adjacent Boundary Watersheds
Specifies that adjacent boundary segment and or boundary point watersheds (along the edges of the outer
surface border) should be merged.

Generates the analysis and updates the Details group box with the analysis information.

Range Details
NOTE The Range Details area of the Analysis tab displays varying fields and columns depending on the type of
analysis that you have selected.
Scale Scheme To Fit
Specifies whether the number of entries is scaled or read sequentially:
■

Selected: The number of entries in the scheme is scaled to uniformly cover the number of ranges, that
is, an even sampling is taken from the scheme between the first and last entries.

■

Cleared: The scheme is read sequentially starting at the first entry.

NOTE If there are fewer entries in the scheme than the number of values in the list of ranges, AutoCAD Civil
3D functions as if the check box is cleared. This means that the scheme is read sequentially until all the entries
in the scheme have been used. In all cases, the last entry in the scheme is used when there are more ranges
than scheme entries.

Range Details
Specifies various details in table form depending on the type of analysis that is performed. Details are
displayed in the following columns:
ID
Displays an index number for each range.
Description
Specifies a description for user-defined contours and watersheds.
Elevation
Displays the elevation value of the user-defined contour.
Minimum Elevation/Direction/Slope
Displays the minimum range value for the analysis view.
Maximum Elevation/Direction/Slope
Displays the maximum range value for the analysis view.
Scheme
Specifies a color preview assigned by the Scheme property in the surface styles Analysis tab (page 2653).
Double-click the column to select a different color.
Major Contour
Specifies how the ranges major contours are displayed:
■

Click

to select a display color for the major contour display.

■

Click

to select a display lineweight for the major contour display.
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■

Click

to select a display linetype for the major contours.

NOTE You set the default display for the surface style on the Analysis tab (page 2653).
Minor Contour
Specifies how the ranges minor contours are displayed:
■

Click

to select a display color for the minor contour display.

■

Click

to select a display lineweight for the minor contour display.

■

Click

to select a display linetype for the minor contours.

NOTE You set the default display for the surface style on the Analysis tab (page 2653).
Type
Displays the watershed type and specifies if the individual watershed is displayed or hidden in the drawing.
Click the light bulb icon to display

or hide

.

NOTE To change the display for the watersheds by type rather than individually, click
table.

above the Details

Drains Into
Displays a comma-delimited string containing the subarea watershed IDs that the subarea watershed
drains into. For example, the string "4,5,6" indicates that the subarea drains into subareas 4, 5, and 6.
Segment Display
Specifies how the segments of the watershed subarea are displayed:
■

Click

to select a display color for the segment.

■

Click

to select a display lineweight for the segment.

■

Click

to select a display linetype for the segment.

NOTE You set the default display for the surface style on the Analysis tab (page 2653).
Area Display
Specifies and previews the hatch pattern for the watershed subarea.
■

Click the hatch pattern preview to change the pattern using the Hatch Properties (page 2635) dialog box.

■

Click

to select a display color for the hatching.

NOTE You set the default display for the surface style on the Analysis tab (page 2653).

Click to open the Watershed Display (page 2665) dialog box where you can hide or display watersheds by
type.
Related procedures:
■

Analyzing Surfaces (page 764)

■

Watersheds (page 725)
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Statistics Tab (Surface Properties Dialog Box)
Use this tab to display surface statistics that are based on the current state of the surface.

General
Displays the general statistics for a surface:
Revision Number
Displays the revision number of the surface.
Number of Points
Displays the number of vertex points in the surface.
Minimum X Coordinate
Displays the minimum X coordinate for the surface area.
Minimum Y Coordinate
Displays the minimum Y coordinate for the surface area.
Maximum X Coordinate
Displays the maximum X coordinate for the surface area.
Maximum Y Coordinate
Displays the maximum Y coordinate for the surface area.
Minimum Elevation
Displays the minimum elevation value found in the surface.
Maximum Elevation
Displays the maximum elevation value found in the surface.
Mean Elevation
Displays the mean or average elevation of all the points on the surface.

Extended
2D Surface Area
Displays the two-dimensional area of the surface.
3D Surface Area
Displays the three-dimensional area of the surface.
Minimum Grade/Slope
Displays the minimum grade or slope found on the surface. Expressed in the units specified in the Edit
Feature Settings - Surface Dialog Box (page 2629).
Maximum Grade/Slope
Displays the maximum grade or slope found on the surface. Expressed in the units specified in the Edit
Feature Settings - Surface Dialog Box (page 2629).
Mean Grade/Slope
The mean or average grade or slope for the surface. Expressed in the units specified in the Edit Feature
Settings - Surface Dialog Box (page 2629).

TIN
NOTE The following properties are displayed for TIN surfaces.
Number Of Triangles
Displays the number of triangles found in the surface.
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Maximum Triangle Area
Displays the area of the largest triangle contained in the surface.
Minimum Triangle Area
Displays the area of the smallest triangle contained in the surface.

Grid
NOTE The following properties are displayed for grid surfaces.
X Spacing
Displays the distance between the grid lines in the X direction.
Y Spacing
Displays the distance between the grid lines in the Y direction.
Orientation
Displays the orientation of the grid (in degrees). The angle is clockwise (+), or counterclockwise (-) from
the North-South meridian.

Volume
NOTE The following properties are displayed for volume surfaces.
Base Surface
Displays the name of the base surface from which the volume surface is generated.
Comparison Surface
Displays the name of the comparison surface from which the volume surface is generated.
Cut volume (unadjusted)
Displays the total cut volume for the surface, without a cut factor applied.
Fill volume (unadjusted)
The total fill volume for the surface, without a fill factor applied.
Net volume (unadjusted)
The difference between the cut and fill volumes.
Related procedures:
■

Viewing Surface Statistics (page 739)

Stage Storage Dialog Box
Use this dialog box to calculate incremental and cumulative volumes of a basin from a surface, using either
a surface or polylines to define the basin.
NOTE The units are based on the Drawing Units specified on the Units And Zone tab (page 80) of the Drawing
Settings dialog box.

Stage Storage Table Details
The following three values are displayed at the top of the stage storage report that is output.
Report Title
Specifies a title for the report.
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Project Name
Specifies a name for the project.
Basin Description
Specifies a description of the basin.

Volume Calculation Method
Average End Area
Specifies that the Average End Area method is used, which calculates the volume between two cross
sections.
For more information about the volume calculation methods, see Stage Storage Volume Calculation
Methods (page 748).
Conic Approximation
Specifies that the Conic Approximation method is used, which calculates the volume between two sectional
areas.
Both
Specifies that both volume calculation methods are used.

Basin Definition Options
Define Basin From Entity
Enables you to define the basin using either contours or polylines. After you select this option, click Define
Basin to proceed with the entity selection.
Use Manual Contour Data Entry
Enables you to define the basin by manually entering contours data. After you select this option, click
Define Basin to proceed with the contour definition.
Define Basin
Displays either the Define Basin From Entities (page 2626) dialog box, or the Define Basin From Entered
Data (page 2627) dialog box, depending on which of the two above options you selected.

Stage Storage Volume Table
Displays the incremental and cumulative volumes of the basin that you define and provides options for
saving the data and loading previously-saved data.
Load Table
Loads volume data from a table that was saved with the Save Table option.
Save Table
Saves the current volume data to a file so you can open it again later with the Load Table option.
Create Report
Outputs the volume data as a report in TXT format.
Insert
Inserts the volume data as a table in the drawing.
Open Export Folder
Opens the folder in which the table or report is saved.
Related procedures:
■

To analyze stage storage volumes (page 744)
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Water Drop Dialog Box
Use this dialog box to specify the parameters for drawing water drop paths on a surface.
NOTE The default values for these parameters can be set in the Edit Command Settings - CreateSurfaceWaterdrop
dialog box. For information about setting command parameters, see Specifying Command-Level Settings (page
85).

Water Drop Path
Path Layer
Specifies the layer on which to draw the water drop path. Click
dialog box where you can select a layer.

to open the Object Layer (page 2221)

Path Object Type
Specifies the type of AutoCAD object to use for the water drop path. Either 2D Polyline or 3D Polyline.

Water Drop Marker
Place Marker At Start Point
Specifies whether to draw a marker at the start point of the water drop path.
Start Point Marker Style
Specifies the style for the start point marker. Click
where you can select a style.

to open the Select Point Style (page 2017) dialog box

Related procedures:
■

Drawing Water Drop Paths (page 767)

Watershed Display Dialog Box
Use this dialog box to display or hide watersheds by type.
Watershed Type
Specifies whether the watershed type is displayed or hidden. Click the light bulb icon to hide or display
the watershed type:
■

: Specifies that the watershed type is displayed in the analysis and the drawing.

■

: Specifies that the watershed type is hidden in the analysis and the drawing.

Related procedures:
■

Watersheds (page 725)

■

Surface Styles and Visualization (page 748)
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Astronomic Direction Calculator Dialog Box
Use this calculator to calculate astronomic directions from Sunshots and Starshots.
Calculation Type
Specifies the calculation types. Select one of the following from the type list:
■

Sun shot calculation: Calculates the astronomic direction from solar observations by the hour angle
method and uses a multiple foresight field method.

■

Star shot calculation: Calculates the astronomic direction from Polaris or star observations by the hour
angle method and uses a single foresight method.

Observation Station Data
Station Point
Specifies the point ID for the station for which you want to calculate the direction.
Backsight Point
Specifies the backsight point ID for the station for which you want to calculate the direction.
Station Latitude
Specifies the Latitude of the station in the drawing's ambient settings format. Specify - for south.
Station Longitude
Specifies the Longitude of the station in the drawing's ambient settings format. Specify - for west.
UT1 Time
Specifies the UT1 time, which is determined by adding the correction (DUT) to the Coordinated Universal
Time (UTC). UTC time is broadcast over WWV and other radio stations. You can also get DUT corrections
via WWV; they are broadcast after the start of each minute.

Ephemeris Data
GHA 00 Hours
Specifies the Greenwich Hour Angle (GHA) at zero (0) hours for the day on which the observations were
made.
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GHA 24 Hours
Specifies the GHA at 24 hours for the day the observations were made.
Declination 00 Hours
Specifies the declination at zero (0) hours on the day the observations were made.
Declination 24 Hours
Specifies the declination at 24 hours on the day the observations were made.
Sun Semi-diameter
Specifies the semi-diameter of the sun.
Enter zero (0) if you are sighting either the center or both the trailing and leading edges of the sun. The
left edge is always the leading edge at latitudes greater than 23.5 degrees north and greater than 23.5
degrees south. If only the left edge is being sighted (left when facing the sun), then the semi- diameter is
positive; likewise, the semi-diameter is negative when only the right edge is sighted.

Observations

Creates a new observation set.

Deletes the selected observation set.
Observation Sets
Displays each observation set.
Backsight Observation
Specifies the backsight orientation.
Sun Observation or Star Observation
Specifies the sun or star observation.
Stop Time
Specifies the stop time for the observation.
Observed Direction
Calculated observed direction.
Average Direction
Calculated average direction.
Mean Direction (Station To Backsight)
Value calculated by the editor.
Related procedures:
■

Astronomic Direction Calculations (page 417)

Create Breaklines Dialog Box
Use this dialog box to add breaklines to a surface from existing figures.
Select Surface
Specifies the surface for which you want to add the breakline data. Click the surface in the drop-down
list or click

to select a surface in the drawing.
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Sets the breakline property for all figures in the list to Yes.

Clears the breakline property check boxes for all figures in the list.
Name
Displays the name of the figure.
Breakline
Specifies if the figure is to be used as breakline data in the surface. Only figures that have their Breakline
property checked are displayed in this list. Select the check box to create breaklines from the figure.
Related procedures:
■

Creating Breaklines from Figures (page 349)

Create Figure From Object Dialog Box
Use this dialog box to create a figure from an AutoCAD Civil 3D or AutoCAD object.
The following object types can be selected in the drawing to define a survey figure:
■

2D Line

■

3D Line

■

2D Polyline

■

3D Polyline

■

Feature Line

■

Lot Line

■

Parcel (select the parcel area label)

Name
Displays the name of the current figure. The name entered here is checked for a match in the current
figure prefix database. If the name matches to a figure prefix the properties in the figure prefix is assigned
to the new figure. If the name does not match a figure prefix, then the figure is assigned the default figure
style from the User Settings.
Current Figure Prefix Database
Displays the default figure prefix database that is assigned in the User Settings. This is the figure prefix
database that is used to match against the Name property value.
Associate Survey Points To Vertices
Specifies to associate survey points to vertices. When this property is checked, for each figure vertex:
■

The X-Y coordinates are checked for a match with an X-Y location of an existing survey point in the
survey database.

■

If the vertex X-Y coordinates match a survey point, then figure vertex references that survey point.

Related procedures:
■

Creating Figures (page 347)
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Edit Feature Settings - Survey Dialog Box
Use this dialog box to view and change survey-specific settings.
This topic documents settings in all survey-related Edit Settings dialog boxes (drawing-level, feature-level,
and command-level).
■

Drawing-level ambient settings are identified by the

■

Survey feature settings are listed near the top of this dialog box, after the General property group, and
are identified by the

■

drawing icon.

survey icon.

Survey command settings are identified by the

command icon.

For general information about drawing, feature, and command settings and their interaction, see Working
with the Standard Settings Dialog Box Controls (page 78).
For information about drawing-level ambient settings, see Ambient Settings Tab (Drawing Settings Dialog
Box) (page 2078)

Default Styles
Specify the default styles for the survey features.
Default Figure Style
Specifies the default style for a survey figure. Click in the Value column, and click
the Survey Default Figure Style dialog box

to select a style in

Default Network Style
Specifies the default style for a survey network. Click in the Value column, and click
in the Survey Default Network Style dialog box

to select a style

For information about style selection, see Select Style Dialog Box (page 2021).

Edit Linework Code Set Dialog Box
Specify the syntax of the field code for a survey point description.
This syntax is interpreted when you process linework by importing or re-importing survey data, or use the
Process Linework command.
For more information, see Examples - Linework Codes (page 253).

Information
Name
Specifies the name of the linework code. To re-name the linework code, enter a new name and click OK
or Apply.
Description
Specifies a description for the linework code.

Coding Methods
Codes: All codes in the linework code must be unique. If you create a duplicate code, a warning icon is
displayed on both the category and the property. Before you can close the Edit Linework Code Set dialog
box, you must resolve all duplicate codes.
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Undefined codes: If a code has no assigned value (empty string/blank value) it is considered unused and
not defined. Undefined codes may be necessary in situations where you are using an older model data
collector that may not have enough physical keys to support the codes.
WARNING It is recommended that you use a <space> as the Feature /Code Delimiter Property Value. Using
decimal characters in the Feature/Code Delimiter Property Value may cause certain codes to fail. For example the
. (decimal) character is valid for a right-turn value and the - (minus sign) character is valid for a negative right-turn
value.
For more details on linework code properties, see Examples - Linework Codes (page 253).
Feature/Code Delimiter
Specifies the code that separates the feature name from the code. It is recommended that you use a space
(“ “) character.
Field Code Escape
Specifies the code that stops the evaluation of the field code. Characters displayed after the escape character
are considered comments. It is recommended that you use a / (slash) character.
Automatic Begin On Figure Prefix Match
Specify one of the following:
■

Yes - the figure will begin with the first instance of a code that matches a figure prefix.

If you specify Yes, the first instance of “EP1” will automatically start a new figure named “EP1”
■

No - the figure will not automatically begin with the first instance of a code that matches a figure
prefix.

For example, if you specify No, the first instance of “EP1” will not automatically start a new figure named
“EP1”. To start a new figure named “EP1”, when “EP1” is not an active figure, you must code the point
as “EP1 B”, where “B” is the Begin code in the current linework code set.

Special Codes
Begin
Specifies the code that indicates a new figure starts at the specified point.
Continue
Specifies the code that indicates a figure continues from its last vertex.
End
Specifies the code that terminates the specified figure.
Close
Specifies the code that continues an active figure from its last vertex to the current point and closes the
figure with a line segment back to the starting vertex for the figure.
Horizontal Offset
Specifies the code that indicates a relative horizontal offset for creating a parallel figure starting at the
current point, or transitioning to another offset if the active figure has a previous horizontal offset. A
value must follow the Horizontal offset code. A negative value offsets the active figure to the left and a
positive value offsets the active figure to the right.
Vertical Offset
Specifies the code that indicates a relative vertical offset starting at the current point. A value must follow
the Vertical offset code. A positive value is added to the elevation of the current vertex for the active figure
and a negative value is subtracted from the current vertex for the active figure.
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Stop Offsets
Specifies the code that terminates all offsets on the active figure, and allows only the active figure to be
continued.

Line Segment Codes
Recall Point
Specifies the code that connects the active figure with a segment from the last point, or a specified pointID.
Connect Point
Specifies the code that creates a new figure (of the same feature) with a single line segment from the
current point to the specified point ID. The specified point ID follows the Connect point code.
Rectangle
Specifies the code to offset the segment coming into the current point by the specified number.
Right Turn
Specifies the code for a <Right turn> line segment that allows for additional vertices to be inserted into
the figure, perpendicular or extensions (straight offsets). Offset values, <Extend>, or <Rectangle> codes
follow the <Right turn> code. Positive numbers indicate a turn to the right and negative numbers indicate
a turn to the left.
Extend
Specifies the code that with a number is used to make an extension of a line segment ahead through the
current point by using a positive value or short of the current point by using a negative value, for example
<Figure Name><Delimiter><Extend><Value>.
NOTE The Extend code can be used within the Right turn code.

Curve Segment Codes
Begin Curve
Specifies the code that indicates the current point is the beginning of a curve (arc) segment. The current
point with this code is the first point on the curve. The next point with the same figure name is considered
a point on the curve, and third point with the same figure name is the curve endpoint.
End Curve
Specifies the code that is used with the <Begin curve> code and is used to define curved segments with
more than three points. Starting at the point with the <Begin curve> code, the linework processor will
look for a <End curve> code. If the <End curve> code is found, all the points between the <Begin curve>
code and <End curve> code are used to fit arc segments of the figure, such that the curves pass through
each of the points (similar to the PEDIT/Fit [curve] option).
Circle
Specifies the code that stops the linework on the previous point (an implied <End> code) and causes the
current point to create a circle in one of three methods.
Point on Curve
Specifies the code to indicate that the current point resides on a curve segment.
Related procedures:
■

Examples - Linework Codes (page 253)

Equipment Database Manager Dialog Box
Use this dialog box to set the current equipment and change and view survey equipment properties.
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Miscellaneous
Name
Specifies the name of the equipment that displays in the selected equipment database.
NOTE A best practice is to use the model number or the name of the equipment manufacturer.
Description
Specifies a description of the surveying equipment.

Units
Distance
Specifies the type of distance units to be used for the equipment distance property values. Changing this
value affects other settings that use angles, for example Standard Deviations.
Angle
Specifies the type of angle units to be used for the equipment angle property values.
When you change this value, other settings (for example Standard Deviations) that use angles are changed
accordingly.

Angle
Horizontal Collimation
Specifies the horizontal collimation correction applied to the FACE 1 and FACE 2 horizontal angles. The
default value is 0.0 angle units.
Angle Type
Specifies the horizontal angle type. Select one of the following:
■

Right: measures the angle clockwise. (default)

■

Left: measures the angle counter-clockwise.

Vertical Collimation
Specifies the vertical collimation correction applied to the FACE 1 and FACE 2 vertical angles. Default
value is 0.0 angle units.
Vertical Angle Type
Specifies the vertical angle type. Select one of the following:
NOTE A 90° Zenith angle equals a 0° Horizontal angle or a 270° Nadir angle. Also, an 89° Zenith angle equals
a 1° Horizontal angle and a 269° Nadir angle.
■

Zenith: Select this value to measure the vertical angle between zenith and the object that is observed.
(default)

■

Horizontal: Select this value to measure the vertical angle with respect to the horizon.

■

Nadir: Select this value to measure the vertical angle directly beneath the observer and directly opposite
the zenith.

Electronic Distance Meter (EDM)
Refractive Index
Specifies the refractive index for the carrier wavelength for the EDM, provided by the EDM manufacturer.
Default value is 287.9600.
Wave Constant
Specifies the constant for the carrier wavelength for the EDM. Default value is 105.45.
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Offset
Specifies the vertical distance between the scope center and the EDM center. Default value is 0.0000 mm.
Measuring Device
Specifies the type of device used for measuring distances. Select one of the following:
■

Scope: Select this value if the EDM is mounted above the telescope; this type of EDM rotates radially
about the horizontal axis as the telescope is rotated.(default)

■

Non-scope: Select this value if the EDM is mounted on the telescope; it is usually mounted on the
standards and it does not rotate with the telescope.

■

Other: Select this value if a device other than an EDM, such as steel tape or stadia rod, is used to
measure distances.

Prism
Tilting
Specifies the correction for EDM offset and prism offset. If this property is set to No, the following formulas
are used to calculate the slope distance:
For a non-scope mounted EDM with non-tilting reflector:

For a scope mounted EDM with non-tilting reflector:

■

EO: EDM offset

■

PO: Prism offset

■

OSD: Old slope distance

■

SD: Slope distance

■

VA: Vertical angle

NOTE Prism and EDM offset are not applied in tilting prism systems.
Prism Offset
Specifies a value for the prism offset (mm) to establish the vertical distance between the reflector (prism)
and the target. Default value is 0.0000 distance units.
Prism Constant
Specifies the value for the prism constant (mm) to establish the horizontal distance between the effective
prism and the actual prism placement. The value is added to all measured distances. Default value is
0.0000 distance units.

Standard Deviations
Use these settings to specify the accuracy of the surveying equipment. These values are used to calculate the
standard errors that appear in the least squares input file.
EDM Proportional Error (ppm)
Specifies the proportional error, in parts per-million, associated with the EDM. This value can also be
determined from the manufacturers documentation for the EDM. Default value is 5.0000 ppm.
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EDM Constant Error
Specifies the constant error, in millimeters, associated with the EDM. This value can also be determined
from the manufacturers documentation for the EDM. Default value is 0.005 meters (5mm).
Centering Error
Specifies the centering error, in millimeters, involved with centering the instrument over a point. Default
value is 0.0015 Meters (1.5 mm).
Target Alignment Error
Specifies the target alignment error, in millimeters, involved with aligning the instrument with the target.
Default value is 0.0025 Meters (2.5 mm).
Pointing Error
Specifies the pointing error, in seconds of a degree, involved with pointing the instrument at the target.
Default value is 0.0001 Degrees DMS (1.0 seconds).
Horizontal Circle
Specifies the horizontal circle error, in seconds of a degree, associated with reading a horizontal circle.
Default value is 0.0015 Degrees DMS (1.5 seconds).
Direction Error
Specifies the direction error, in seconds of a degree, associated with the measurement of an azimuth or
bearing. Default value is 0.0010 Degrees DMS (10 seconds).
Vertical Circle
Specifies the vertical circle error, in seconds of a degree, associated with reading a vertical circle. Default
value is 0.00015 Degrees DMS (1.5 seconds).
Prism Height Error
Specifies the error, in millimeters, associated with measuring the prism height. Default value is 0.001
Meters (1.0 mm).
Theodolite Height Error
Specifies the error, in millimeters, associated with measuring the theodolite height. Default value is 0.001
Meters (1.0 mm).
Related procedures:
■

Survey Equipment Database (page 221)

Export Field Book Dialog Box
Use this dialog box to edit settings associated with exporting AutoCAD Civil 3D survey data to a field book.
The settings here are not saved back to the user settings and are only applicable for the field book export
operation.
Field Book Filename (.FBK)
Specifies the name and location of the field book. Click
to specify a different name and location.
For information on the conditions and syntax that is added to the field book, see Setting Export Defaults
(page 235).
Export Figures With Network
Select Yes to export the figures in the database when you use the Export Field Book command.
The figure type determines what is added to the field book. For information on the conditions and syntax
that is added to the field book, see Setting Export Defaults (page 235).
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Export Point Identifiers
Specifies if point IDs are used to define figures when figures are exported to a field book.
For information on the conditions and syntax that is added to the field book, see Setting Export Defaults
(page 235).
Export Point Data
This check box is active when the Export Point Identifiers property is not set to None. Select Yes if you
want each figure vertex that references a point identifier to output the following to the field book file
prior to the section defining the figures: NE SS <point ID> <north> <east> <elevation> <description>
Related procedures:
■

Exporting a Field Book File (page 269)

Export Survey LandXML Data Dialog Box
Use this dialog box to select the data in the export settings and survey data to export in LandXML format.

Export Settings
File Name
Specifies the file name to contain the exported LandXML survey data. Enter a path or click
to a location.

to browse

Coordinate Zone
Click
to display the Select Coordinate Zone dialog box where you can specify the coordinate zone for
the survey database data. The default zone is set to None.
Distance
Specifies the distance unit. Click the cell in Value column and select a distance unit from the list.
NOTE If you specify a Coordinate Zone, the distance unit is obtained from the zone and the Distance property
field is not active.
Angle
Specifies the angle unit for the survey data. Click the cell in the Value column and select an angle type
from the list.
Direction
Specifies the direction unit for the survey data. Click the cell in the Value column and select a direction
type from the list.
Temperature
Specifies the temperature unit for the survey data when temperature corrections are applied to observations.
Click the cell in the Value column and select a temperature type from the list.
Pressure
Specifies the atmospheric pressure unit for the survey data when pressure corrections are applied to
observations. Click the cell in the Value column and select a pressure type from the list.

Export Data
Data tree
Lists the AutoCAD Civil 3D survey data that you can export in LandXML format. Expand each of the
collections to display all of the sub-components.
Select or clear the check box to the left of each feature name to filter the data that you want to export in
LandXML format.
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NOTE The check boxes have a tri-state display. If only some items are selected under a collection, the check
box is dimmed

; if all the items are selected, the check box is selected

are cleared, the check box for the collection is cleared

; if all the items below the collection

.

OK
Converts AutoCAD Civil 3D objects to LandXML format and exports the LandXML data.
Related procedures:
■

Exporting Survey Data to LandXML (page 270)

Figure Prefix Database Manager Dialog Box
Use this dialog box to specify the properties for a new figure prefix.

Creates a new figure prefix line in the database manager.

Copies the selected line in the in the database manager.

Deletes the selected line in the database manager.
Name
Specifies the name for the figure prefix. The prefix name is used to match on a figure name at figure
creation time, for example, when importing a field book file.
Breakline
Specifies that the matched figures can be used as breaklines (when creating surface breaklines from figures).
Lot Line
Specifies that the figure behaves as a parcel segment. When this property is selected and the figure is
inserted into drawing, the figure behaves as a parcel segment in the site that it is placed on. Figures with
this property may create parcels and can be labeled as parcel segments.
Layer
Specifies the layer that the figure object is placed on when inserting figures into a drawing. When there
is a prefix match, the following occurs:
■

If the specified layer exists in the drawing, the figure is placed on that layer.

■

If the specified layer does not exist in the drawing, the layer is created and the figure is placed on the
specified layer.

Style
Specifies the figure style that is assigned to the figure when the figure is inserted into a drawing. When
there is a prefix match, the following occurs:
■

If the specified style name exists in the drawing, the style is used.

■

If the specified style does not exist in the drawing, a new style with the specified name is created.
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Site
Specifies the site name that is assigned to the figure if a figure prefix match occurs. The figure is placed
in this site when it is inserted into a drawing. If the site name does not exist in the current drawing it is
created.
Related procedures:
■

Survey Figure Prefix Database (page 222)

Figure Properties (Drawing Object)
Use this dialog box to specify a style for the figure drawing object.
Name
Specifies the name of the figure. The figure name can be composed of characters that are number, alpha,
or alpha-numeric.
Style
Specifies the figure style.
Related procedures:
■

Survey Figures (page 347)

Import Event Properties
Displays the properties of the selected event in the Import Events collection in the list view or the Import
Events Panorama vista.
Name
By default, displays the name of the file that was imported.
Description
Displays an optional description.
Date/Time
Read-only property that is assigned at the time of the import and updated when there is a re-import.
User Name
DIsplays the read-only property of the user’s Windows login name that is used at the time of the import
and updated when there is a re-import.
File
Displays the assigned name of the imported file. (Read-only).
Import Type
Displays one of the read-only following import types:
■

Field Book File

■

Survey LandXML

■

Point File

■

Points From Drawing

Point Identifier Offset
Displays the offset value that was specified in the import command.
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Point File Format
Displays the type of point file format used during the Import Point File command, or specified during the
import survey data command.
Linework Code Set
Displays the name of the linework code set.
Process Linework Sequence
Displays the order in which survey point descriptions are processed to determine linework connectivity.
■

By Import Order - processes points in the order in which they are imported. Point names are always
processed by import order.

■

By Point Number - processes points sequentially by point number (ascending order only).

Equipment Database
Displays the name of the equipment database associated with the import event.
Equipment
Displays the name of the equipment associated with the import event.
Figure Prefix Database
Displays the name of the figure prefix database associated with the import event.
Related procedures:
■

Import Events (page 274)

Import Events Editor
Use the Import Events Editor vista to access all events associated with a survey network.
The Import Events Editor displays the properties for each event. Right-click an individual event to access
the shortcut menu commands.

Import / Re-import Field Book Dialog Box
Use this dialog box to edit user and survey database settings associated with a field book import operation.
The current user and survey database setting defaults are displayed when the dialog is initialized. The settings
here are not saved back to the user and survey database settings and are only applicable for the field book
import operation.
Field Book Filename (.FBK)
Specifies the field book (*.fbk) to import. Click

to browse to a location.

Current Equipment Database
Specifies the equipment database to use. Select the equipment database from the drop-down list.
NOTE The list of available databases is determined by the databases listed in the Equipment Databases collection
in the Toolspace Survey tab.
Current Equipment
Specifies the current equipment to use. Click the equipment name from the drop-down list.
The current equipment sets the values associated with a specific surveying instrument, such as the standard
deviations associated with the measuring capabilities of the equipment. This information is used in various
calculations including least squares.
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Show Interactive Graphics
Specifies whether to display interactive graphics during the import of survey data. Use Interactive Graphics
settings to control the display of individual graphics components.
Current Figure Prefix Database
Specifies the current figure prefix database. Click the figure prefix database from the drop-down list.
Figure prefixes enable you to determine the layer that a figure is drawn on by creating a prefix for a group
of figure names. All figures with a specific prefix are placed on a specific layer
NOTE The list of available databases is determined from the databases listed in the Figure Prefix Databases
collection on the Toolspace Survey tab.
Process Linework During Import
Specify Yes to process linework during the import.
WARNING In the Import Settings, clear the Process Linework check box if you are importing the following:
■

.fbk files created from the Survey Data Collection Link application because Linework Codes Set
definitions may not be recognized. However, the figure commands created using the Survey Data
Collection Link are recognized.

■

.fbk files that were created in Autodesk Land Desktop or in a previous version of AutoCAD Civil 3D.
Using the Process Linework command on these files may create duplicate and erroneous figures.

Current Linework Code Set
Specifies the default linework code set to use when linework processing occurs.
Process Linework Sequence
Specifies the order in which survey point descriptions are processed to determine linework connectivity.
Select one of the following:
■

By Import Order - processes points in the order which they are imported. Point names are always
processed by import order.

■

By Point Number - processes points sequentially by point number (ascending order only).

Import Event Name
Specifies a file name for the import event. The name of the file you are importing is displayed as the
default name.
Import Event Description
Optionally, enter a description of the import event.
Assign Offset To Point Identifiers
Specifies that an offset is applied to the point identifier before the points are imported into the survey
database.
Point Identifier Offset
Specifies the offset value that is applied to the point identifier. For example, if the offset value is 1000,
the point number 101 is renumbered to 1101, or point name KC101 is renamed as KC101.1000.
Insert Network Object
Specifies whether a network object is created in the drawing upon completion of the import command.
Insert Figure Objects
Specifies whether figure objects are created in the drawing upon completion of the import command.
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Insert Survey Points
Specifies whether AutoCAD Civil 3D points are created in the drawing upon completion of the import
command.
Display Tolerance Errors In Event Viewer
Select Yes to display tolerance errors in the Event Viewer when you import field book files. For more
information, see Reporting Tolerance Errors (page 233).
Related procedures:
■

Survey Database Settings Dialog Box (page 2698)

■

Survey User Settings Dialog Box (page 2726)

■

Field Book Files (page 266)

Import / Re-import Survey LandXML Data Dialog Box
Use this dialog box to specify the import settings and the survey data to import from a LandXML file.

Import Settings
Current Equipment Database
Specifies the current equipment database. Click the equipment database from the drop-down list. For
more information, see Survey Equipment Database (page 221).
NOTE The list of available databases is determined by the databases listed in the Equipment Databases collection
in the Toolspace Survey tab.
Current Equipment
Specifies the current equipment to use. Click the equipment name from the drop-down list.
The current equipment sets the values associated with a specific surveying instrument, such as the units
used to measure angles and distances, and/or the standard deviations associated with the equipment's
measuring capabilities. This information is used in various calculations including least squares.
Current Figure Prefix Database
Specifies the current figure prefix database. Click the figure prefix database from the drop-down list.
Figure prefixes enable you to determine the layer that a figure is drawn on by creating a prefix for a group
of figure names. All figures with a specific prefix are placed on a specific layer.
The list of available databases is determined from the databases listed in the Figure Prefix Databases
collection on the Toolspace Survey tab.
Process Linework During Import
Click Yes to process line work during the import.
Current Linework Code Set
Specifies the linework code file to use when linework processing occurs.
Process Linework Sequence
Specifies the order in which survey point descriptions are processed to determine linework connectivity.
Select one of the following:
■

By Import Order - processes points in the order which they are imported. Point names are always
processed by import order.

■

By Point Number - processes points sequentially by point number (ascending order only).

Import Event Name
Specify a name for the import event. The name of the file you are importing is displayed by default.
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Import Event Description
Optionally, enter a description of the import event.
Assign Offset To Point Identifiers
Specifies that an offset is applied to the point identifier before the points are imported into the survey
database.
Point Identifier Offset
Specifies the offset value that is applied to the point identifier. For example, if the offset value is 1000,
point number 101 is renumbered to 1101, or point name KC101 is renamed as KC101.1000.
Insert Network Object
Specifies whether to create a network object in the drawing.
Insert Figure Objects
Specifies whether to create figure objects in the drawing.
Insert Survey Points
Specifies that survey points are inserted into the drawing.
Display Tolerance Errors In Event Viewer
Select Yes to display tolerance errors in the Event Viewer when you import Survey LandXML files. For
more information, see Reporting Tolerance Errors (page 233).

LandXML Data tree
Lists the LandXML header information for each data component that can be imported. Only the following
LandXML components are displayed in the LandXML Data tree (if they exist in the selected LandXML
file). Non-survey LandXML elements are not displayed.
Expand each of the collections to display all of the sub-components.
Select or clear the check boxes to the left of each data component name to filter the data that is imported
into AutoCAD Civil 3D. By default, all data components are selected for import.
NOTE The check boxes have a tri-state display. If only some items are selected under a collection, the check
box is dimmed

; if all items are selected, the check box is selected

cleared, the check box for the collection is cleared

; if all items below the collection are

.

File Name
Displays the path and file name of the selected LandXML file.
CoordinateSystem
If current Coordinate Zone property in the Survey Database Settings is set and this value is different, a
coordinate transformation is attempted (the Survey Database Settings Distance property is also used to
scale the coordinate values during the transformation).
Units
If the Units ➤ linearUnit setting is different from the Survey Database Settings ➤ Units Distance property,
observation distance and target heights values are converted.
If the Units ➤ angularUnit settings is different from the Survey Database Settings ➤ Units Angle property,
observation angle (horizontal, vertical, and direction) values are converted.
NOTE The internal units of the survey database are angle values in Radians and distance and coordinate values
in Meters.
SurveyHeader
This element maps to a survey network in AutoCAD Civil 3D. The Name attribute sets the name of new
network in the survey database, or if a network of the same name exists in the survey database, it may be
overwritten or appended to, depending on the LandXML Import Settings.
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PlanFeatures
Maps to a survey figure. For each PlanFeature:
■

The PlanFeature Name attribute is the name assigned to the new figure.

■

If the PlanFeature name matches a figure prefix in the current figure prefix database, the figure prefix
properties are assigned to the new or existing figure.

Parcels
A Parcel maps to a survey figure. For each Parcel:
■

The ParcelName attribute is the name assigned to the new figure.

■

If the Parcel name matches a figure prefix in the current figure prefix database, the figure prefix
properties are assigned to the figure, except for the Lot Line property.

■

The Lot Line property is always set to True for each Parcel imported into a figure. This overrides a
figure prefix property if a figure prefix match occurs.

NOTE If the figure prefix does not have a Site name, the default Site name is used when the figure is inserted
into a drawing.
CgPoints
A CgPoint point maps to a survey point. Each CgPoint is added to the Non-Control Points collection in
the survey database.
Related procedures:
■

Importing Survey LandXML Data (page 270)

■

Importing Survey XML Data

Import / Re-import Point File Dialog Box
Import points into the survey database and survey network, as control points or non-control points, and
specify options for linework processing.
Point File Format
Displays the point file formats contained in the current drawing. The point file format determines the
column order, delimiter, and coordinate zone for the file you are importing.
NOTE In linework processing, the point file format must have a Raw Description column.
Point File Name
Displays the file path of the point file you want to import.
Point Type
Specifies the imported points as either control points or non-control points in the network.
Current Figure Prefix Database
Specifies the name of the prefix database. Select a database from the list.
Process Linework During Import
Specify Yes to process linework during the file import.
Current Linework Code Set
Specifies the linework code set that is used in the linework processing.
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Process Linework Sequence
Specifies the order in which survey point descriptions are processed to determine linework connectivity.
Select one of the following:
■

By Import Order - processes points in the order in which they are imported. Point names are always
processed by import order.

■

By Point Number - processes points sequentially, by point number (ascending order only).

Import Event Name
Specifies the name of the import event that is created by the import command.
Import Event Description
Optionally, specify a description for the import event.
Assign Offset To Point Identifiers
Specifies that an offset is applied to point identifiers before the points are imported into the survey database.
Point Identifier Offset
Specifies the offset value that is applied to the point identifier. For example, if the offset value is 1000,
point number 101 is renumbered to 1101, or point name KC101 is renamed as KC101.1000.
Insert Network Object
Specifies that the network object is inserted into the drawing when the import process is complete.
Insert Figure Objects
Specifies that the figure object is inserted into the drawing when the import process is complete.
Insert Survey Points
Specifies that the survey points are inserted into the drawing when the import process is complete.
Related procedures:
■

Importing Point Files (page 262)

Import / Re-import Points From Drawing Dialog Box
Import points from the current drawing into the survey database and survey network, as control points or
non-control points, and specify options for linework processing.
Point Type
Specifies the imported points as either control points or non-control points in the network.
Current Figure Prefix Database
Specifies the name of the figure prefix database. Select the database from the list.
Process Linework During Import
Specify Yes to process linework during the file import.
Current Linework Code Set
Specifies the linework code set that is used in the linework processing.
Process Linework Sequence
Specifies the order in which survey point descriptions are processed to determine linework connectivity.
Select one of the following:
■

By Import Order - processes points in the order in which they are imported. Point names are always
processed by import order.
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■

By Point Number - processes points sequentially by point number (ascending order only).

Import Event Name
Specifies the name of the import event that is created by the import command. By default the import
event name is the name of the imported file.
Import Event Description
Optionally, specify a description for the import event.
Assign Offset To Point Identifiers
Specifies that an offset is applied to point identifiers before the points are imported into the survey database.
Point Identifier Offset
Specifies the offset value that is applied to the point identifier. For example, if the offset value is 1000,
point number 101 is renumbered to 1101, or point name KC101 is renamed as KC101.1000.
Related procedures:
■

Importing Points From a Drawing (page 265)

Import Survey Data Wizard
Use this wizard to import field book files, point files, Survey LandXML files, or selected points in a drawing.
At the completion of the import an import event is created.
For more information, see Import Events (page 274).

Import Survey Data Wizard - Specify Database Page
Specify an existing survey database or create a new one.
Survey Databases
Select an existing survey database.
Create New Survey Database
Displays the New Local Survey Database dialog box where you can enter the folder name.
Edit Survey Database Settings
Displays the Survey Database Settings dialog box.
Related procedures:
■

Import Survey Data Wizard (page 261)

Import Survey Data Wizard - Specify Data Source Page
Specify the data source type and select the data.
Data Source Type
■

Field Book File

■

LandXML file

■

Point File

■

Points From Drawing
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Source File
Browse to the source file and select the file you want to import.

Import Survey Data Wizard - Specify Network Page
Select an existing survey network or create a new network.
NOTE Click None if you are importing project points that you do not want associated with a network. This option
is only available when you import points from a point file or select points from the drawing.
Survey Network
Displays the existing networks in the survey database.
Create New Network
Displays the New Network dialog box where you can enter a name and description for the network.

Import Survey Data Wizard - Import Options Page
Specify the import settings for the selected data source.
■

Field Book File: Import / Re-import Field Book Dialog Box (page 2679)

■

LandXML File: Import / Re-import Survey LandXML Data Dialog Box (page 2681)

■

Point File: Import / Re-import Point File Dialog Box (page 2683)

■

Points From Drawing: Import / Re-import Points From Drawing Dialog Box (page 2684)

Least Squares Analysis Dialog Box
Use this dialog box specify Least Squares settings. The settings default to the setting in the Survey Database
Settings for Least Squares.

Input
Create Input File
Specifies that the Input file name is created, or overwritten if it already exists, in the <Working
folder>\<Project>\Survey\<Network> folder.
Input File Name
Specifies name of the least squares input file. If the Create Input File property is checked, the input file
name (without the *.lsi extension) can be entered in the combo box, or an existing input file can be
selected from the list. If an existing input file is selected it is overwritten with new content.
Network Adjustment Type
Changes the default network adjustment type of the least analysis performed on the survey network.
Specify one of the following:
■

2-Dimensional: The input file contains content to perform a 2-dimensional least squares analysis.

■

3-Dimensional: The input file contains content to perform a 3-dimensional least squares analysis.

NOTE This property is enabled if the Create Input File property is checked.
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Procedure
Maximum Number of Iterations
Specifies the number of iterations of least squares analysis that is performed on the network.
Coordinate Convergence
Specifies the default coordinate convergence of the least squares analysis performed on the survey network.
Confidence Level
Specifies the confidence level of the least squares analysis performed on the survey network.
Perform Blunder Detection
Specify Yes to perform Blunder Detection on the least squares analysis performed on the survey network.
Update Survey Database
Specify Yes to update the Survey Database with the adjusted coordinates from the analysis.
Related procedures:
■

Using Least Squares with Networks (page 389)

Manage Extended Properties Dialog Box
Use this dialog box to manage the extended property definitions in the Survey .sdx file.
Expands All
Expands all items in the tree.
Collapses All
Collapses all items in the tree.
Export Settings
Exports the extended properties schema to a specified .sdx file. You specify the location of this .sdx file in
the Database Defaults of Survey User Settings.
Import Settings
Imports an extended properties definition schema into the existing .sdx file.
NOTE Existing extended property definitions that are referenced by an instance of a SurveyFeatureClass are
not redefined during the import process. Existing extended property definitions that are not referenced are
redefined by the definition in the selected .sdx_def file.
Select All
Selects all category and property check boxes.
Clear All
Clears all category and property check boxes.
Create New
Displays the New Extended Property dialog box. This button is only enabled when a user-defined category
is selected.
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Edit Selected Item
Displays the Edit Extended Property dialog box. This button is only enabled when a user-defined property
is selected.
Delete Selected Item
Displays the Delete Extended Property warning message box. This button is only enabled when a
user-defined property is selected and that property is not referenced by another instance of the
<SurveyFeatureClass>.
Property column
Lists the extended properties categories.
Description column
Displays the description of the extended property. This description can be assigned from the New/Edit
Extended Property dialog box.
Depending on your .sdx_def file, each SurveyFeatureClass has relevant LandXML and User-defined collections.
If you expand these collections, and select an attribute you can use the right-click short cut menu to edit or
copy the property.
Survey Database
SurveyFeatureClass used to manage the extended properties of survey databases and projects.
Network
SurveyFeatureClass used to manage the extended properties of survey networks.
Network Group
SurveyFeatureClass used to manage the extended properties of Network Groups.
Figure
SurveyFeatureClass used to manage the extended properties of survey figures.
Figure Group
SurveyFeatureClass used to manage the extended properties of figure groups.
Survey Point
SurveyFeatureClass used to manage the extended properties of survey points.
Survey Point Group
SurveyFeatureClass used to manage the extended properties of survey point groups.
Related procedures:
■

Managing Survey Extended Properties (page 271)

New Control Point/Control Point Properties Dialog Box
Use this dialog box to specify or edit the properties of a control point.
If you are editing the properties of a control point using the Survey tab item view, for more information on
the functions available, see Survey Tab Item View (page 2725).
Point Number
Specifies the point number.
Name
Specifies the point name. Optional.
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Easting
Specifies the point easting. Required.
NOTE If the survey database has been assigned a coordinate system zone, the Longitude property value is
calculated from the value entered in this field.
Northing
Specifies the point northing. Required.
NOTE If the survey database has been assigned a coordinate system zone, the Latitude property value is
calculated from the value entered in this field.
Elevation
Specifies the point elevation. Optional.
Description
Specifies the point description. Optional.
NOTE Latitude and Longitude values are only displayed when the survey database has an assigned coordinate
system zone.
Longitude
Specifies the point longitude. The Easting property value is calculated from the value entered in this field.
Latitude
Specifies the point latitude. The Northing property value is calculated from the value entered in this field.
Network
Displays the name of the network that first observed the point.
Import Event
Displays the name of the import event if the survey point was created by an import command.
Original Number
Displays the original survey point number if a point identifier offset was applied during the import
command.
Original Name
Displays the original survey point name if the survey point was renamed during the import command.

LandXML
If you are using the extended properties feature, the LandXML elements as defined in the .sdx_def file are
displayed. Click the cell in the Value column to assign an attribute.

User-defined
If you are using the extended properties feature, and have created user-defined properties they are displayed.
Click the cell in the Value column to assign an attribute.
Related procedures:
■

Control Points (page 280)

New Direction/Direction Properties Dialog Box
Use this dialog box to specify or edit the properties of a direction.
For more information on the functions available if you are editing the properties of a direction using the
Survey tab item view, see Survey Tab Item View (page 2725).
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From Point
Specifies the originating control point.
To Point
Specifies the destination point reference for the direction.
Direction
Specifies the direction value. The unit type is determined by the direction type setting. For more
information, see Database Settings (page 238).
Direction Type
Specifies the direction type. Either an azimuth (page 2767) or a bearing (page 2768).
Related procedures:
■

Directions (page 309)

New/Edit Extended Property Dialog Box
Use this dialog box to create a new property or edit an existing property in the Survey .sdx file.
XML Name
Specifies the XML name of the extended property.
Display Name
Specifies the display name of the property.
Description
Specifies a description of the property. This description is displayed in the Manage Extended Properties
dialog box.
Property Field Type
Specifies the data type for the property. For more information on property field types, see Property Field
Types Table (page 273).
Required Value
Select this check box to display a warning icon indicating that a required property has not been assigned
to an instance of a <SurveyFeatureClass>.
Display In Survey User Interface
Select this check box to display the extended property in the Survey user interface. This check box is
selected by default when you create a new user-defined property.
String Values
Specifies a list of string values if the Property Field type is set to String. You can enumerate the list of string
values when you assign a value to a <SurveyFeatureClass>. Use the arrows to change the display order of
the strings in this dialog box and in the Survey user-interface.
Related procedures:
■

Creating and Editing User-defined Properties (page 272)

New Figure Group/Figure Group Properties Dialog Box
Use this dialog box to create a new figure group. To support LandXML, named collections of elements such
as CgPoints or PlanFeature collections, Figure Groups are added as a root collection within a Survey database
item on the Survey tab in Toolspace.
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Figure Group
Name
Specifies the name of the Figure Group.
Description
Specifies the description of the Figure Group.

LandXML
If you are using the extended properties feature, the LandXML elements as defined in the .sdx_def file are
displayed. Click the cell in the Value column to assign an attribute.

User-defined
If you are using the extended properties feature, and have created user-defined properties they are displayed.
Click the cell in the Value column to assign an attribute.
Add To Group
Select the check box to add the figure to the new Figure Group.
Name
Displays the name of the figure to add to the Figure Group.
Breakline
Displays the status of the figure as a breakline.
Lot Line
Displays the status of the figure as a lot line.
Layer
Displays the layer the figure is drawn on.
Style
Displays the figure style.
Site
Displays the site to which the figure belongs.
Vertices
Displays the number of vertices in the figure.
Length
Displays the length of the figure.
Area
Displays the area of the figure.
Network
Displays the network name where the figure is located.
Import Event
Displays the name of the import event that the figure is associated with.
Automatic
Displays Yes if the figure is automatically generated.
Related procedures:
■

Using Groups to Manage Survey Data (page 274)
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New Network Group/Network Group Properties Dialog Box
Use this dialog box to create a new network group. To support LandXML, named collections of elements
such as CgPoints or PlanFeature collections, Network Groups are added as a root collection within a Survey
database item on the Survey tab in Toolspace.

Network Group
Name
Specifies the name for the Network Group.
Description
Specifies a description for the Network Group.

LandXML
If you are using the extended properties feature, the LandXML elements as defined in the .sdx_def file that
are relevant to networks are displayed. Click the cell in the Value column to assign an attribute.

User-defined
If you are using the extended properties feature, and have created User-defined properties they are displayed.
Click the cell in the Value column to assign an attribute.
Add To Group
Select the check box to add the named network to the group
Name
Displays the name of the networks that can be added to the Network Group.
Description
Displays the description of the networks that can be added to the Network Group.
Related procedures:
■

Using Groups to Manage Survey Data (page 274)

New Non-Control Point/Non-Control Point Properties Dialog Box
Use this dialog box to specify or edit the properties of a non-control point.
If you are editing the properties of a non-control point using the Survey tab item view, for more information
on the functions available, see Survey Tab Item View (page 2725).
Point Number
Specifies the point number.
Name
Specifies the point name. Optional.
Northing
Specifies the point northing. Required.
NOTE If the survey database has been assigned a coordinate system zone, the Latitude property value is
calculated from the value entered in this field.
Easting
Specifies the point easting. Required.
NOTE If the survey database has been assigned a coordinate system zone, the Longitude property value is
calculated from the value entered in this field.

2692 | Chapter 78 Survey Dialog Boxes

Elevation
Specifies the point elevation. Optional.
Description
Specifies the point description. Optional.
NOTE Latitude and Longitude values are only displayed when the survey database has an assigned coordinate
system zone.
Latitude
Specifies the point latitude. The Northing property value is calculated from the value entered in this field.
Longitude
Specifies the point longitude. The Easting property value is calculated from the value entered in this field.
Network
Displays the name of the network that first observed the point.
Import Event
Displays the name of the import event if the survey point was created by an import command.
Original Number
Displays the original survey point number if a point identifier offset was applied during the import
command.
Original Name
Displays the original survey point name if the survey point was renamed during the import command.

LandXML
If you are using the extended properties feature, the LandXML elements as defined in the .sdx_def file are
displayed. Click the cell in the Value column to assign an attribute.

User-defined
If you are using the extended properties feature, and have created user-defined properties they are displayed.
Click the cell in the Value column to assign an attribute.
Related procedures:
■

Non-Control Points (page 283)

New Setup/Setup Properties Dialog Box
Use this dialog box to specify or edit the properties of a setup.
If you are editing the properties of a setup using the Survey tab item view, for more information on the
functions available, see Survey Tab Item View (page 2725).
Station Point
Specifies the station point number for the setup.
NOTE If you enter a non-existent station point, you are prompted to create a point and the New Control Point
dialog box is displayed from which you can create a new station point.
Backsight Point
Specifies the backsight point for the setup. When this column contains a valid entry, the Backsight
Direction column displays the calculated backsight direction value and is read-only.
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Backsight Direction
Specifies the backsight direction. This field is read-only if the Backsight Point column contains a valid
point number.
Backsight Orientation
Specifies the backsight orientation angle for the setup. This is the reference angle for the all angle
observations except Face 1 and Face 2 angles.
Backsight Face 1
Specifies the direct angle reference on the backsight for Face 1 angles.
Backsight Face 2
Specifies the direct angle reference on the backsight for Face 2 angles.
Instrument Height
Specifies the measured instrument (theodolite) height. This is typically measured from the center of the
theodolite optics to the setup point on the ground.
Instrument Elevation
Specifies the instrument elevation.
NOTE If the setup point has an elevation, this field is read-only and displays the calculated instrument elevation
(setup point elevation plus the instrument height). If the setup point has no elevation, then this column can be
used to specify the instrument elevation
Easting
Displays the point easting.
Northing
Displays the point northing.
Longitude
Displays the point longitude.
Latitude
Displays the point latitude.
Setup Equipment Properties
Displays the name of the equipment properties for the selected setup. To edit the Setup Equipment
Properties, click

to display the Setup Equipment Properties dialog box.

Related procedures:
■

Setups (page 285)

New Survey Network Dialog Box/Survey Network Properties Dialog
Use this dialog box to specify the name for a new survey network.
New Survey Network
Specify the name for the new survey network.

LandXML
If you are using the extended properties feature, the LandXML elements as defined in the .sdx_def file are
displayed. Click the cell in the Value column to assign an attribute.
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User-defined
If you are using the extended properties feature, and have created user-defined properties they are displayed.
Click the cell in the Value column to assign an attribute.
Related procedures:
■

Survey Networks (page 224)

New Survey Point Group/Survey Point Group Properties Dialog Box
Use this dialog box to create a new survey point group. To support LandXML, named collections of elements
such as CgPoints or PlanFeature collections, Survey Point Groups are added as a root collection within a
Survey database item on the Survey tab in Toolspace.

Survey Point Group
Name
Specifies the name of the Survey Point Group.
Description
Specifies the description of the Survey Point Group.

LandXML
If you are using the extended properties feature, the LandXML elements as defined in the .sdx_def file are
displayed. Click the cell in the Value column to assign an attribute.

User-defined
If you are using the extended properties feature, and have created user-defined properties they are displayed.
Click the cell in the Value column to assign an attribute.
Add To Group
Select the check box to add the survey point to the new Survey Point Group.
Number
Displays the survey point number.
Name
Displays the survey point name.
Easting
Displays the easting of the survey point.
Northing
Displays the northing of the survey point.
Elevation
Displays the elevation of the survey point.
Description
Displays a description of the survey point.
Longitude
Displays the longitude of the survey point.
Latitude
Displays the latitude of the survey point.

New Survey Point Group/Survey Point Group Properties Dialog Box | 2695

Network
Displays the network name where the survey point is located.
Import Event
Displays the name of the import event that the survey point is associated with.
Original Number
Displays the original survey point number.
Original Name
Displays the original survey point name.
Related procedures:
■

Using Groups to Manage Survey Data (page 274)

New Traverse/Traverse Properties
Use this dialog box to specify or edit the properties of a traverse.
If you are editing the properties of a traverse using the Survey tab item view, for more information on the
functions available, see Survey Tab Item View (page 2725).
Name
Specifies the name of the traverse. The traverse name can be composed of characters that are number,
alpha, or alpha-numeric.
Description
Specifies a description for the traverse.
Initial Station
Specifies the starting station point.
Initial Backsight
Specifies the initial backsight point.
Stations
Specifies the setups as a comma delimited list.
Final Foresight
Specifies the final foresight point.
Related procedures:
■

Traverses (page 401)

Process Linework Dialog Box
The Process Linework command processes linework connectivity between points, using a specified linework
code set in situations where a linework code set was not previously specified.
You can also reprocesses linework connectivity after you make corrections to the survey point descriptions
in the Survey Point Properties dialog box (page 2724).
Current Figure Prefix Database
Specify the figure prefix database.
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Current Linework Code Set
Specify the linework code set.
Process Linework Sequence
Specifies the order in which survey point descriptions are processed to determine linework connectivity.
Select one of the following:
■

By Import Order - processes points in the order in which they are imported. Point names are always
processed by import order.

■

By Point Number - processes points sequentially by point number (ascending order only).

Insert Figure Objects
Inserts figures in the current drawing.
Insert Survey Points
Inserts survey points in the current drawing.
Related procedures:
■

Processing Survey Linework (page 276)

Preview Settings Dialog Box
Use this dialog box to specify the preview settings for networks, figures, and setups.
Select check boxes for the components that you want to display in the preview.
On Survey Toolspace, click

to display the Survey Preview Window.

Survey Command Window
Use this dialog box to enter survey commands directly using command line input or interactively using the
menus.
The menus on this dialog box provide quick access to extended survey functionality including batch and
output file usage, baseline, centerline, and intersection input, and to obtain point information.
Use the command input field to enter survey command language commands directly. For more information,
see Survey Command Reference (page 419).
TIP In the Survey Command Window, enter HELP at the command line to display a text file that lists all the Survey
Command Language commands
Main menu
Provides access to:
■

User settings (page 227)

■

Database settings (page 238)

■

Batch file functionality (page 344)

■

Output file functionality (page 416)

■

Baseline functions (page 311)

■

Centerline functions (page 315)

■

Intersection functions (page 330)
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■

Point Information (page 404)

■

Drawing zoom and pan functions

Output view
Displays all survey command output. All output is prefixed with the “!” character. Erroneous commands
are recorded as comments. For example: !Duplicate point. (Point number ' 1 ' already exists).
Batch view
Displays the input history for the current Survey Command Window session. All commands echoed here
are also written to the batch file (if turned on). Input errors are trapped and not recorded to the batch
file.
Command line
Enter survey command language commands directly. The survey command language is the basic format
for all survey data entry. After you become familiar with the survey command Language, you may find
that it is an efficient way to access and query data. Commands entered at the survey command line use
a specific syntax.
Related procedures:
■

Survey Command Language Commands (page 422)

■

Survey User Interface (page 214)

Survey Database Properties Dialog Box
View or modify extended survey database properties that are defined through an extended properties schema
(LandXML and User-Defined), based on the Manage Extended Properties dialog.
Expand All
Expands all items in the tree.
Collapse All
Collapses all items in the tree.
Property
Displays the extended property name.
Value
Click the cell to modify the value.
Related procedures:
■

Managing Survey Extended Properties (page 271)

Survey Database Settings Dialog Box
Use this dialog box to modify the survey database settings. These settings are specifically for the survey
database features. By default, the survey database settings are stored in C: Civil 3D Projects\<database
name>\Survey.sdb file.

Units
Establish specify the database units.

2698 | Chapter 78 Survey Dialog Boxes

Coordinate Zone
Click
to display the Select Coordinate Zone dialog box where you can specify the coordinate zone for
the survey database data. The default zone is set to None.
Distance
Specifies the distance unit. Click the cell in Value column and select a distance unit from the list.
NOTE If you specify a Coordinate Zone, the distance unit is obtained from the zone and the Distance property
field is not active.
Angle
Specifies the angle unit for the survey database data. Click the cell in the Value column and select an
angle type from the list.
Direction
Specifies the direction type for the Survey database data. Click the cell in the Value column and select a
direction type from the list.
Temperature
Specifies the temperature unit for the survey database data when temperature corrections are applied to
observations. Click the cell in the Value column and select a temperature type from the list.
Pressure
Specifies the atmospheric pressure unit for the survey database when pressure corrections are applied to
observations. Click the cell in the Value column and select a pressure type from the list.

Precision
Establish the display precision of the survey data.
NOTE These precision settings are independent of the Drawing Settings precision settings. These settings affect
all aspects of the user interface that displays survey data.
Angle
Specifies the precision value for all angle (including direction) values. The default precision is 4.
Distance
Specifies the precision value for all distance values. The default precision for Meters is 3, the default
precision for Feet is 2.
Elevation
Specifies the precision value for all elevation values. The default precision for Meters is 3 and Feet is 2.
Coordinate
Specifies the precision value for all coordinate values. The default precision is 4.
Latitude and Longitude
Specifies the precision value for all latitude and longitude values. The default precision is 8.

Measurement Type Defaults
Establish the default types assigned to the measurements.
NOTE For more information about the measurement types, see the Setting Measurement Type Defaults (page
239).
Angle Type
Specifies the default angle type. Click the cell in the Value column and select a distance type from the
list.
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Distance Type
Specifies the default distance type. Click the cell in the Value column and select a distance type from the
list.
Vertical Type
Specifies the default vertical type. Click the cell in the Value column and select a vertical type from the
list.
Target Type
Specifies the default target type. Click the cell in the Value column and select a target type from the list.

Measurement Corrections
Specify the default measurement corrections to apply to the survey observations.
NOTE For information on formulas used to calculate corrections, see Setting Measurement Corrections (page 240).
Curvature and Refraction
Select Yes to correct measurement calculations for curvature of the earth and refraction of the sun light.
Sea Level
Select Yes to correct measurement calculations to sea level.
Atmospheric Conditions
Select Yes to correct measurement calculations for temperature and pressure.
Horizontal Collimation
Select Yes to correct Face 1 Angle and Face 2 Angle types for horizontal collimation (page 2770).
Vertical Collimation
Select Yes to correct Face 1 Angle and Face 2 Angle types for vertical collimation.
Scale Factor
Select Yes to correct calculated horizontal distances for scale factor.
EDM-Prism Eccentricity
Select Yes to correct distance measurements for EDM (page 2773) and prism (page 2780) offsets.

Traverse Analysis Defaults
Do Traverse Analysis
Select Yes to perform a mathematical analysis based on the method you specify as the Horizontal
Adjustment Method.
Do Angle Balance
Select Yes to have the angular error evenly distributed throughout the traverse.
Horizontal Adjustment Method
Specify one of the following traverse analysis methods:
■

Compass Rule: A method of corrections where the closing errors are assumed to be as much due to
errors in observed angles as by the errors in measured distances. The closing errors in latitude and
departure are distributed according to the ratio of the length of the line to the total length of the
traverse.

■

Transit Rule: A method of balancing a traverse where the closing errors are assumed to be caused less
by the errors in the observed angles than by the errors in measured distance. Corrections are distributed
according to the ratio of the latitude and departure of each leg of the traverse to the sums of the latitude
and departures of the entire traverse.
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■

Crandall Rule: A method of balancing a traverse where all the angular error is distributed throughout
the traverse and all adjustments to the traverse are due to modifying the traverse distances. The
modification distance made to each leg is such that the sum of the squares is a minimum. Corrections
corresponding to the closing errors assume that the closing errors are random and normally distributed,
and that all the angular error has been adjusted prior to the adjustment routine.

■

Least Squares: A method of balancing a traverse. The squares of the differences between the unadjusted
and adjusted measurements (angles and distances) are summed and reduced to a minimum. This
method weights the individual measurements according to the specifications set in the Equipment
correction settings to determine the source of error. You can adjust the data for an individual traverse
loop, or a traverse network, if located from multiple observations.

Vertical Adjustment Method
Specify one of the following vertical adjustment methods:
■

None: No vertical adjustment performed.

■

Length Weighted Distribution: Vertical adjustment distributes the vertical closing error to each line
at the same ratio as the length of the line to the total length of the traverse (similar to the Compass
rule).

■

Equal Distribution: Vertical adjustment distributes the vertical closing error equally to each of the
traverse stations.

■

Least Squares: A method of distributing the vertical error throughout a traverse. The squares of the
differences between the unadjusted and adjusted measurements (angles and distances) are summed
and reduced to a minimum. This method weights the individual measurements according to the
specifications set in the Equipment correction settings to determine the source of error. You can adjust
the data for an individual traverse loop, or a traverse network, if located from multiple observations.

NOTE The Least Squares vertical adjustment method is only available if Least Squares has been selected as the
horizontal adjustment method. When this method is selected, a 3D least squares adjustment is performed. If
this method is not selected a 2D least squares adjustment is performed.
Horizontal Closure Limit 1:X
Specifies the minimum allowable error of closure in the horizontal direction, for example a value of
15000.00 is 1 part in 15000.
Vertical Closure Limit 1:X
Specifies the minimum allowable error of closure in the vertical direction, for example a value of 15000.00
is 1 part in 15000.
Angle Error Per Set
Specifics the maximum angular error per traverse observation set.

Least Squares Analysis Defaults
Specify the survey database setting defaults for performing a least square analysis on a network or a traverse.
Network Adjustment Type
Specifies the adjustment type for network least squares analysis only. The Traverse Analysis Defaults
settings determine either a 2D or 3D analysis. Click the cell in the Value column and select one of the
following from the list:
■

2-Dimensional: Sets the adjustment type to 2D. No adjustments are made to elevations. Adjustments
are only made to horizontal positions.

■

3-Dimensional: Sets the adjustment type to 3D. Adjustments are made to both horizontal and vertical
positions.
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Maximum Number of Iterations
Specifies the maximum number of times the least squares routine adjusts the observations before a solution
is reached. This default setting is 8. The maximum number of iterations that you can enter is 10. Generally,
the solution is reached within two or three iterations.
Coordinate Convergence
Specifies the maximum difference that is allowed between the coordinates before the solution is accepted.
Confidence Level
Specifies either 95% or 99% as the percentages calculated in conjunction with the F distribution. F is the
ratio of two independent chi square variables, which are divided by the respective degrees of freedom.
For example, if the confidence level is set to 99%, then you can be 99% sure that the calculated ellipse
contains the true location for the point.
Perform Blunder Detection
Select Yes to include blunder detection in the least squares output (*.lso) file.

Survey Command Window
Specify the survey database settings for interacting with the Survey Command Window.
Ditto Feature
Select Yes to automatically repeat the last command in the Survey Command Window. This setting is on
by default. When this setting is on, you can enter the command name once, and then continue to use
the command by entering numeric data. To end the command, enter another command name.
Auto Point Numbering
Select Yes to enable automatic point numbering. When automatic point numbering is on, new points are
automatically assigned the next available point number. When automatic point numbering is off, you
must specify new point numbers as they are needed.
Start Point Numbering From
Specifies the number at which to start Auto Point Numbering.
Point Course Echo
Select Yes to have the Survey Command Window report the course taken to reach a point, including the
direction and the distance.
Affects output in both the output file and the output view of the Survey Command Window.
Figure Course Echo
Select Yes to have the Survey Command Window report the course taken to create a figure, including
direction and distance.
Affects output in both the output file and the output view of the Survey Command Window.
Point Coordinate Echo
Select Yes to have the Survey Command Window display the point coordinates, including northing,
easting, and elevation information.
Affects output in both the output file and the output view of the Survey Command Window.
Figure Coordinate Echo
Select Yes to have the Survey Command Window display figure point coordinates, including northing,
easting, and elevation information.
Affects output in both the output file and the output view of the Survey Command Window.
Command Echo
Select Yes to have the Survey Command Window display the commands that are entered.
Affects output in both the output file and the output view of the Survey Command Window.
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Use Batch File
Select Yes and specify a batch file to record Survey Command Window input per network. The batch file
for each network in a survey database is saved to Civil 3D Projects\<named> Survey Database\<named>
Network\Batch.txt.
If set to No, no commands are displayed in the Batch view of the Survey Command Window.
Use Output File
Select Yes and specify an output file name to record Survey Command Window output. The output file
for each network in a survey database is saved to Civil 3D Projects\<named> Survey Database\<named>
Network\Output.txt.

Error Tolerance
NOTE Redundant observations that exceed the error tolerance values create an event in the Event Viewer. For
more information, see Reporting Tolerance Errors (page 233).
Ignore Tolerance Errors
Specifies that tolerance errors are ignored. If you specify Yes then observations with tolerance errors are
not be included in the calculation of the survey point.
Distance Difference
Specifies a maximum difference in distance. If you observe a distance to a point more than once and the
difference is greater than the acceptable value then an event is listed in the Event Viewer and a warning
icon is displayed on the observation in Toolspace. If the difference in distance is less than the acceptable
value, then the distance difference is averaged to establish the point coordinates.
Angular Difference
Specifies the maximum angular difference. If you observed an angle to a point more than once and the
difference is greater than the acceptable value then an event is listed in the Event Viewer and a warning
icon is displayed on the observation in Toolspace. If the angular difference is less than the acceptable
value, then the angular difference is averaged to establish the point coordinates.
Elevation Difference
Specifies the maximum elevation difference. If you observed an elevation to a point more than once and
the difference is greater than the acceptable value then an event is listed in the Event Viewer and a warning
icon is displayed on the observation in Toolspace. If the elevation difference is less than the acceptable
value, then the elevation difference is averaged to establish the point elevation.
Coordinate Difference
Specifies the maximum coordinate difference. If you located a point from more than one setup, and the
difference is greater than the acceptable value then an event is listed in the Event Viewer and a warning
icon is displayed on the observation in Toolspace. If the coordinate difference is less than the acceptable
value, then it is averaged to establish the point coordinates.

Extended Properties
Specify the survey database extended property settings.
Create New Definitions Automatically
Specify Yes to automatically create Survey LandXML properties in the LandXML file that do not exist in
the Survey database.
Display Warnings For Missing Required Properties
Specify Yes to display a warning in the Event Viewer for any instance of a <SurveyFeatureClass> that is
missing a required property. The Event Viewer tree displays the survey database name and the command
name. The Event Viewer description column displays the <SurveyFeatureClass><ObjectID>:Missing required
<property name> value.
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Change Reporting
Logging Enabled
Specify Yes to enable logging of changes that affect the survey database. These changes are stored in an
.log file that is use with the change report .xslfile to create the change report.
Related procedures:
■

Database Settings (page 238)

Survey Figure Properties Dialog Box
Specify or change the figure properties, the site the figure is associated with, and add or edit figure vertices.
Name
Specifies the name of the figure. The figure name can be composed of characters that are number, alpha,
or alpha-numeric.
Breakline
Specifies that the figure is used as a breakline (when creating surface breaklines from figures).
Lot Line
Specifies that the figure behaves as a parcel segment. When this property is selected and the figure is
inserted into drawing, the figure behaves as a parcel segment in the site that it is placed on. Figures with
this property may create parcels and can be labeled as parcel segments.
Layer
Specifies the layer that the figure object is placed on when inserting figures into a drawing.
Style
Specifies the style that the figure object uses when inserting figures into a drawing.
Site
Specifies the site for the figure if Lot Lines property is enabled. When inserting a figure into the current
drawing, if the site does not exist in the current drawing, it is created. The figure is placed on the specified
site
Closed
Specifies whether the figure is closed or open.
Vertices
Displays the number of vertices in the figure.
Length
Displays the length of the figure.
Area
Displays the area of the figure.
Network
Displays the name of the network that the figure is associated with.
Import Event
Displays the name of the import event that the figure is associated with.
Auto-generated
Displays Yes or No to indicate whether the figure was automatically generated.
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LandXML
If you are using the extended properties feature, the LandXML elements as defined in the .sdx_def file are
displayed. Click the cell in the Value column to assign an attribute.

User-defined
If you are using the extended properties feature, and have created user-defined properties they are displayed.
Click the cell in the Value column to assign an attribute.

Editing Tools

Displays the Survey Point Properties dialog box.
NOTE This option is not available if more than one row is selected.

Moves the selected row or a selection of rows up in the list of vertices.

Moves the selected row or a selection of rows down in the list of vertices.

Reverses the direction of the selected figure or the order of the selected vertices.

Adds a new vertex to the end of the list.

Inserts a new vertex before the selected row.

Inserts a new vertex after the selected row.

Select points in the drawing to insert as vertices, after the selected row.
NOTE This option is not available if more than one row is selected.

Breaks the figure at the selected vertex.

Trims the figure at the selected vertex.

Joins the figure to a selected figure.

Removes a row or a selection of rows from the list of vertices.
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Zooms the drawing to the extents of the current figure vertices in the list. The extents can be different
than the original figure if you insert or delete rows and then click the Apply button.

Zooms to the selected figure.

Closes the dialog box and zooms to the figure you select in the drawing.

Pans to the figure extents of the selected vertices.

Discards any changes and reloads the figure from the survey database.

List View
Number
Displays the point type icon (for example control point, non-control point, setup) and the point number
if the figure vertex is assigned a point ID. You can clear the point number to disassociate the vertex from
the referenced survey point (the survey point name column is also cleared). If you clear the point number,
you can specify a new point number value or edit the Easting, Northing, and Elevation columns.
Name
Displays the survey point name if the figure vertex is assigned a point identifier. You can clear the point
name to disassociate the vertex from the referenced survey point (the survey point number column is also
cleared). If you clear the point name, you can specify a new point name value or edit the Easting, Northing,
and Elevation columns.
Description
Displays the figure description
Geometry
Specify Point, Curve, or Curve-Break to determine if the vertex is a line segment, or multiple
compound/reverse curves, or non-tangent curve fit.
■

Point option. Indicates the figure vertex is a point on a line segment.

■

Curve option. Indicates the figure vertex is a point on a curve segment.

■

Curve Break option. Indicates that the vertex is a start of a curve segment. Use this option in situations
where two non-tangent curves share an end and start vertex. The command ends the previous curve
and begins a new non-tangent curve.

Easting
Displays the Easting value of the vertex. This column is read-only if the vertex is assigned a survey point
identifier.
Northing
Displays the Northing value of the vertex. This column is read-only if the vertex is assigned a survey point
identifier.
Elevation
Displays the Elevation value of the vertex. This column is read-only if the vertex is referencing a survey
point.
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Related procedures:
■

Editing Survey Figure Vertices (page 366)

Survey Figure Style Dialog Box
Use survey figure styles to control the way a figure and its components, such as points and lines, are displayed
in the drawing.
See also:
■

Survey Styles and Display (page 216)

Information Tab (Survey Figure Style Dialog Box)
Use this tab to view or change general information for the survey figure style.
Name
Specifies the name of the current figure style.
Description
Specifies an optional description for the current style.
Created By
Displays the AutoCAD login name of the person who created the style.
Date Created
Displays the date and time the style was created.
Last Modified By
Displays the AutoCAD login name of the person who last modified the style.
Date Modified
Displays the date and time the style was last modified.

Plan and Model Tab (Survey Figure Style Dialog Box)
Use this tab to specify marker styles and marker placement options for each figure marker component. These
figure marker components display on the Display tab of the figure style.

Vertex Markers
Use these settings to specify the marker properties for figure Vertex Markers component. You can use the
vertex markers component to create a marker style for the original data points from which the figure was
created, for example the point located in field that defined the figure.
Marker Style
Specifies the marker style for the marker component. Click
dialog to specify the marker style.

to display the Figure Vertex Marker Style

Align Markers With Figure
Specifies if the markers are aligned normal to the figure segments. Click the cell in the Value column and
select to Yes, to override the specified marker style orientation properties.
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Midpoint Markers
Use these settings to specify the marker properties for the figure Midpoint Markers component. The midpoint
markers component can be used to display a marker style for the midpoint of each figure segment.
Marker Style
Specifies the marker style for the marker component. Click
the marker style.

to display the Marker Style dialog to specify

Align Markers With Figure
Specifies if the markers are aligned normal to the figure segments. Click the cell in the Value column and
select to Yes to override the specified marker style orientation properties.

Endpoint Markers
Use these settings to specify the marker properties for the starting point and the ending point of the figure.
Start Point Marker Style
Specifies the marker style for the start point of the figure.
End Point Marker Style
Specifies the marker style for the end point of the figure.
Align Markers With Figure
Specifies if the markers are aligned normal to the figure segments. Click the cell in the Value column and
select to Yes, to override the specified marker style orientation properties.

Additional Markers
Use these settings to specify if additional markers and marker styles to use on figures. Markers are considered
additional when they are not placed at a vertex, start, mid, or endpoint on the figure.
Marker Style
Specifies the marker style for the marker component. Click
the marker style.

to display the Marker Style dialog to specify

Additional Marker Placement Method
Specifies the placement of additional markers. Click the cell in the Value column and select one of the
following from the list:
■

None: disables the placement of intermediate additional markers on the figure.
NOTE if you specify this option, At Interval and Divide Figure By properties in the Additional Markers category
are disabled.

■

At Interval: places additional markers at the specified interval.

■

Divide Figure: places markers on the figure segments determined by the Divide By property.

■

Continuous: specifies that additional markers are placed continuously along the figure. Each marker
is placed outside the extents of the previous marker.

Interval
Specifies the interval if you set the Marker Placement Method to At Interval. Click the cell in the Value
column and enter a number that is greater than zero.
Divide Figure By
Specifies the value to divide the figure by if you set the Marker Placement Method to Divide By. Click the
cell in the Value column and enter a number that is greater than zero.
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Place Marker At Figure Start Point
Specify Yes to have the Marker Placement Method always places an additional marker at the start point
of the figure.
NOTE This setting overrides the setting of None in the Marker Placement Method.
Place Marker At Figure End Point
Specify Yes to have the Marker Placement Method always places an additional marker at the end point
of the figure.
NOTE This setting overrides the setting of None in the Marker Placement Method.
Align Markers With Figure
Specifies if the markers are aligned normal to the figure segments. Click the cell in the Value column and
select to Yes, to override the specified marker style orientation properties.

3D Geometry Tab (Survey Figure Style Dialog Box)
Use this tab to specify the 3D display of the survey figure style components.
Figure Display Mode
Specifies the display mode for figure elevations in the drawing. Click the cell in the Value column and
select one of the following:
■

Use Figure Elevations: displays figure components at the actual elevations.

■

Flatten Figure To Elevation: flattens figure component elevations to a specified value:

■

Exaggerate Figure Elevations By Scale Factor: scales figure component elevations by a specified scale
factor.

Flatten Figure To Elevation
This field is enabled if you specify Flatten Figure To Elevation as the Figure Display Mode. All figure
component elevations are displayed at the specified elevation.
Exaggerate Figure Elevations By Scale Factor
This field is enabled if you specify Exaggerate Figure Elevations By Scale Factor as the Figure Display Mode.
Click the cell in the Value column and enter a value. All figure component elevations are multiplied by
the value you enter.

Profile Tab (Survey Figure Style Dialog Box)
Use this tab to specify the marker styles for survey figures projected into profile views.
You can select different markers for the beginning, internal, and end vertices of a survey figure.

Section Tab (Survey Figure Style Dialog Box)
Use this tab to specify the marker style for survey figures projected into section views.
This marker is used to indicate where a survey figure crosses the sample line displayed in the section view.

Display Tab (Survey Figure Style Dialog Box)
Use this tab to specify the display styles for survey lines and markers in different contexts.
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This is the standard AutoCAD Civil 3D Display tab. For more information, see Display Tab (Style Dialog
Box) (page 2017).
View Direction
Specifies the context for which you are setting the display:
■

Plan – the printed drawing

■

Model – the on-screen design window

■

Profile – projection into a profile view

■

Section – projection into a section view

Survey figure display components include:
■

Figure Line

■

Vertex Markers

■

Midpoint Markers

■

Endpoint Markers

■

Additional Markers

Summary Tab (Survey Figure Style Dialog Box)
Use this tab to view all the survey network style properties. For more information about the properties in
this tab, see Summary Tab (Style Dialog Box) (page 2020).

Survey Network Properties Dialog Box
Specify a name and styles for the network components, 3D Geometry, and Display options.
Name
Displays the name of the current network.
Description
Displays the description of the current network.
Object Style
Specifies the style used to display the network. Select a style from the list or use the standard selection
tools. For more information about the standard selection tools, see Select Style Dialog Box (page 2021).
Show Tooltips
Controls whether tooltips are displayed for the object in the drawing (does not affect tooltips over toolbar
icons).

LandXML
If you are using the extended properties feature, the LandXML elements as defined in the .sdx_def file are
displayed. Click the cell in the Value column to assign an attribute.

User-defined
If you are using the extended properties feature, and have created user-defined properties they are displayed.
Click the cell in the Value column to assign an attribute.
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Survey Network Style Dialog Box
Define survey network styles to control the appearance of network components such as markers and lines,
and the display of components in the drawing.
See also:
■

Survey Styles and Display (page 216)

Information Tab (Survey Network Style Dialog Box)
Use this tab to change the survey network style name and description information, and to review details,
such as when the style was most recently modified.
Name
Specifies a name for the current style. The style name identifies the style on the Settings tab in Toolspace
and is listed in the Style Selection dialog box. Changes to a style name are reflected in the title bar of the
Style dialog box.
Description
Specifies the description for the current style.

Components Tab (Survey Network Style Dialog Box)
Use this tab to specify how survey network style components are displayed, such as component scaling, and
symbols.

Marker Styles
Use these settings to specify how markers are displayed. Markers are used to control the display of network
points.
Marker Style For Known Control Points
Specifies a marker style for known (fixed) control points in the survey network.
Marker Style For Unknown Control Points
Specifies a marker style for the unknown control points in the survey network.
Unknown points are the vertices of the network lines whose locations are determined from observations
relative to the known Control Point locations. Typically, an unknown control point is an instrument
setup. However, Sideshot observations made from unknown control points are recalculated when a network
is updated from a network adjustment, such as a Traverse or Least Squares adjustment.
Marker Style For Non-Control Points
Specifies a marker style for non control points in the survey network.
Marker Style For Sideshot Points
Specifies a marker style for the sideshot points in the survey network.
Marker Style For Tolerance Error Points
Specifies a marker style for the tolerance error points in the survey network.

Error Ellipses
Error Ellipses Scale Factor
Specifies a scale factor for displaying an error ellipse (page 2773) of a survey network.
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3D Geometry Tab (Survey Network Style Dialog Box)
Use this tab to specify how the survey network style components display in 3D views.

3D Geometry
Network Display Mode
Specifies the mode in which the network elevations are displayed in the drawing. Click the cell in the
Value column and select one of the following from the list:
■

Use Network Elevations: Displays network components at the actual elevations.

■

Flatten Network To Elevation: Flattens the network component elevations to a specified value.

■

Exaggerate Network Elevations By Scale Factor: Scales network component elevations by a specified
scale factor.

Flatten Network To Elevation
Flattens the network component elevations to a specified value. This option is only active when you
specify the value Flatten Network To Elevation as the Network Display Mode.
Exaggerate Network Elevations By Scale Factor
Scales network component elevations by a specified scale factor. This option is only active when you
specify the value Exaggerate Network Elevations By Scale Factor: as the Network Display Mode.

Display Tab (Survey Network Style Dialog Box)
Use this tab to specify the survey network style component display in Plan (2D) and Model (3D) views. This
is the standard AutoCAD Civil 3D Display tab. For more information, see Display Tab (Style Dialog Box)
(page 2017)
Survey Network Display components include:
■

Known Control Points: a point symbol representing a known point in a survey network. All other
unknown points are dependent on the location of a known point.

■

Unknown Control Points: a point symbol representing a point in the survey network where the point
location is calculated relative to an observation made to a known control point. An unknown control
point may represent an instrument setup or an adjusted control point.

■

Non-Control Points: a point symbol representing a point with its location determined from a reduced
observation, for example a point created by the NE SS survey command. A non-control point is not
connected to other survey observations and remains unaffected by network analysis, but it still a
component of the survey network. A non-control point may be promoted to a control point if it is
referenced by observations.

■

Sideshot Points: a point symbol representing a sideshot point in the survey network with its location
determined from an observation made from either a known or unknown point. In most cases a sideshot
point is not connected to any other point in the network.

■

Network Lines: a line representing observations that connect two control points.

■

Direction Lines: a line representing observed direction data from either a known or unknown point in
the survey network.

■

Sideshot Lines: a line representing observations between a control point and a sideshot.

■

Error Ellipses: this component represents the positional error of an unknown control point as a result of
least squares analysis.
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■

Tolerance Error Points: this component represents an observed point where the observation(s) exceeds
the tolerance error values specified in the Survey Database Settings.

■

Tolerance Error Lines: this component represents the line of sight between the setup and the observed
point that exceeds the tolerance error values that were specified in the Survey Database Settings.

Summary Tab (Survey Network Style Dialog Box)
Use this tab to view all the survey network style properties. For more information about the properties in
this tab, see Summary Tab (Style Dialog Box) (page 2020).

Survey Panorama Vistas
Use the Survey Panorama vistas to display and edit collections of survey data, in a grid.
The Panorama displays many types of data. Each different type of data is displayed using a vista that is
specific to that data type. To conserve screen space if more than one vista is active, the Panorama displays
a tab for each one.
Click a tab to bring a vista to the front.
You can dock and move the Panorama, and you can use Auto-hide to reduce the amount of screen space it
requires when you are not using it. For more information, see The Panorama Window (page 119).

Control Points Editor
Use this dialog box to edit existing control points or create new ones.
Point Number
Specifies the point number.
Name
Specifies the point name. Optional.
Northing
Specifies the point northing.
NOTE If the survey database has been assigned a coordinate system zone, the Latitude property value is
calculated from the value entered in this field.
Easting
Specifies the point easting.
NOTE If the survey database has been assigned a coordinate system zone, the Longitude property value is
calculated from the value entered in this field.
Elevation
Specifies the point elevation.
Description
Specifies the point description.
NOTE Latitude and Longitude values are only displayed when the survey database has an assigned coordinate
system zone.
Latitude
Specifies the point latitude. The Northing property value is calculated from the value entered in this field.
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Longitude
Specifies the point longitude. The Easting property value is calculated from the value entered in this field.
Related procedures:
■

The Panorama Window (page 119)

■

Control Points (page 280)

Non-Control Points Editor
Use this dialog box to edit existing non-control points or create new ones.
Point Number
Specifies the point number.
Name
Specifies the point name.
Northing
Specifies the point northing.
NOTE If the survey database has been assigned a coordinate system zone, the Latitude property value is
calculated from the value entered in this field.
Easting
Specifies the point easting.
NOTE If the survey database has been assigned a coordinate system zone, the Longitude property value is
calculated from the value entered in this field.
Elevation
Specifies the point elevation.
Description
Specifies the point description.
NOTE Latitude and Longitude values are only displayed when the survey database has an assigned coordinate
system zone.
Latitude
Specifies the point latitude. The Northing property value is calculated from the value entered in this field.
Longitude
Specifies the point longitude. The Easting property value is calculated from the value entered in this field.
Related procedures:
■

The Panorama Window (page 119)

■

Non-Control Points (page 283)

Setups Editor
Use this dialog box to view and edit survey setups.
Station Point
Displays the station point number.
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Backsight Point
Displays the backsight point number.
Backsight Direction
Displays the direction of the backsight in the specified units.
Backsight Orientation
Specifies the orientation of the horizontal circle when backsighting the point. This is an optional value,
and is assumed to be 0.00 unless you specify otherwise.
Backsight Face1
Specifies the direct angle reference on the backsight for face 1 (page 2773) angles.
Backsight Face2
Specifies the direct angle reference on the backsight for face 2 (page 2773) angles.
Instrument Height
Specifies the measured instrument (theodolite) height. This is typically measured from the center of the
theodolite optics to the setup point on the ground.
Instrument Elevation
Specifies or displays the instrument elevation. If the setup point has an elevation, this field is read-only
and displays the calculated instrument elevation (setup point elevation plus the instrument height). If
the setup point has no elevation, then this column can be used to specify the instrument elevation.
Northing
Displays the northing value for the setup.
Easting
Displays the easting value for the setup.
Elevation
Specifies the elevation of the setup.
Related procedures:
■

The Panorama Window (page 119)

■

Setups (page 285)

Directions Editor
Use this dialog box to view and edit survey directions.
From Point
Displays the originating control point.
To Point
Displays the destination reference point for the direction.
Direction
Specifies the direction value. The unit type is determined by the direction type setting. For more
information, see Database Settings (page 238)
Direction Type
Specifies the direction type. Either an azimuth (page 2767) or a bearing (page 2768).
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Related procedures:
■

The Panorama Window (page 119)

■

Directions (page 309)

Observations Editor
Use this dialog box to view and edit survey observations.
Point Number
Specifies the point number.
When creating a new point and automatic point numbering is off, you must specify the point number.
If automatic point numbering is on, then the points are automatically numbered.
Name
Specifies an optional name for the point.
Angle
Specifies the measured horizontal angle. It is assumed to be clockwise (right). Use a negative number (-)
to turn counter-clockwise (left). Expressed in the current units.
Angle Type
Specifies the angle type to locate the point. Either angle (page 2767), deflection angle (page 2772), face 1 (page
2773), face 2 (page 2773), or bearing (page 2768).
Distance
Specifies the distance from the instrument point to the point being located. It is measured in the current
units.
Distance Type
Specifies the distance type to locate the point. Specify slope (page 2782), horizontal, or None.
Vertical
Specifies the vertical angle or distance depending on the Vertical Type.
Vertical Type
Specifies the method of measuring the vertical. Either Vertical Angle or Vertical Distance.
Target Height
Specifies the vertical distance between the ground elevation and the focal point of the prism or stadia.
Target Type
Specifies the target type. Either prism (page 2780), stadia (page 2783), or None.
Scale Factor
Specifies the scale factor that affects how ground measurements are translated into grid measurements.The
horizontal distances are then multiplied by this factor when the Scale Factor correction is checked in the
Measurement Corrections property in the Survey Database Settings dialog.
Northing
Displays the calculated northing for the point.
Easting
Displays the calculated easting for the point.
Elevation
Displays the calculated elevation for the point.
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Related procedures:
■

The Panorama Window (page 119)

■

Observations (page 289)

Survey Points Editor
Use this dialog box to view and edit all survey points.
The point icon in the first column indicates the point type:
■

Control point.

■

A control point derived from an adjustment, such Traverse or Least Squares analysis.

■

Non-control point.

■

Setup.

■

Observation.

Number
Displays the point number.
Name
Specifies the point name.
Easting
Displays the point easting.
NOTE If the survey database has been assigned a coordinate system zone, the Longitude property value is
calculated from the value in this field.
Northing
Displays the point northing.
NOTE If the survey database has been assigned a coordinate system zone, the Latitude property value is
calculated from the value in this field.
Elevation
Displays the point elevation.
Description
Specifies the point description.
NOTE Latitude and Longitude values are only displayed when the survey database has an assigned coordinate
system zone.
Longitude
Displays the point longitude, if applicable.
Latitude
Displays the point latitude, if applicable.
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Related procedures:
■

The Panorama Window (page 119)

Figure Prefixes Editor
Use this dialog box to view and edit the properties of a figure prefix.
Name
Specifies the name for the figure prefix. The prefix name is used to match on a figure name at figure
creation-time, for example when importing a field book file.
Breakline
Specifies that the matched figures can be used as breaklines (when creating surface breaklines from figures).
Lot Line
Specifies that the figure behaves as a parcel segment. When this property is selected and the figure is
inserted into drawing, the figure behaves as a parcel segment in the site that it is placed on. Figures with
this property may create parcels and can be labeled as parcel segments.
Layer
Specifies the layer that the figure object is placed on when inserting figures into a drawing. When there
is a prefix match, the following occurs:
■

If the specified layer exists in the drawing, the figure is placed on that layer.

■

If the specified layer does not exist in the drawing, the layer is created and the figure is placed on the
specified layer.

Style
Specifies the figure style that is assigned to the figure when the figure is inserted into a drawing. When
there is a prefix match, the following occurs:
■

If the specified style name exists in the drawing, the style is used.

■

If the specified style does not exist in the drawing, it is created with the specified name.

Site
Specifies the site name that is assigned to the figure if a figure prefix match occurs. The figure is placed
in this site when it is inserted into a drawing. If the site name does not exist in the current drawing it is
created.
Related procedures:
■

Survey Figure Prefix Database (page 222)

■

The Panorama Window (page 119)

Figures Editor
Use this dialog box to view and edit survey figures.
Name
Specifies the name of the figure. The figure name can be composed of characters that are number, alpha,
or alpha-numeric.
Breakline
Specifies that the figure is used as a breakline (when creating surface breaklines from figures).
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Lot Line
Specifies that the figure behaves as a parcel segment. When this property is selected and the figure is
inserted into drawing, the figure behaves as a parcel segment in the site that it is placed on. Figures with
this property may create parcels and can be labeled as parcel segments.
Layer
Specifies the layer that the figure object is placed on when inserting figures into a drawing.
Style
Specifies the style that the figure object uses when inserting figures into a drawing.
Site
Specifies the site for the figure. When inserting a figure into the current drawing:
■

If this site does not exist in the current drawing, it is created.

■

The figure is placed on this site. If the Lot Line property is checked for the figure, a parcel segment is
created.

Vertices
Displays the number of vertices in the figure.
Length
Displays the length of the figure.
Area
Displays the area of the figure.
Network
Displays the network that the figure is associated with.
Import Event
Displays the import event that the figure is associated with.
Auto-generated
Displays Yes to indicate that the figure is automatically generated from an imported file or imported
points.
Related procedures:
■

The Panorama Window (page 119)

■

Survey Figures (page 347)

Figure Groups Editor
Use this dialog box to select and edit a survey figures within a figure group.
Name
Specifies the name of the Figure Group.
Related procedures:
■

The Panorama Window (page 119)

■

Using Groups to Manage Survey Data (page 274)
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Network Groups Editor
Use this dialog box to select and edit a survey network from within a survey network group.

LandXML and User-Defined
NOTE If you are using the Extended Properties feature, relevant LandXML and User-defined properties for each
group are displayed in the panorama.To edit a group, select the group in the panorama and make edits in the
Extended Data panel (left pane). Click

to open or close the extended data panel.

Name
Specifies the name of the Network Group.
Description
Specifies an optional description.
Related procedures:
■

The Panorama Window (page 119)

■

Using Groups to Manage Survey Data (page 274)

Networks Editor
Use this dialog box to edit a survey network.

LandXML and User-Defined
NOTE If you are using the Extended Properties feature, relevant LandXML and User-defined properties for each
Network are displayed in the panorama.To edit a network, select the network in the panorama and make edits in
the Extended Data panel (left pane). Click

to open or close the extended data panel.

Name
Specifies the Network name.
Description
Specifies an optional description.
Related procedures:
■

The Panorama Window (page 119)

■

Survey Networks (page 224)

Survey Point Groups Editor
Use this dialog box to select and edit a survey point within a survey point group.

LandXML and User-Defined
NOTE If you are using the Extended Properties feature, relevant LandXML and User-defined properties for each
group are displayed in the panorama.To edit a group, select the group in the panorama and make edits in the
Extended Data panel (left pane). Click

to open or close the extended data panel.

Name
Specifies the name of the Survey Point Group.
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Description
Specifies an optional description.
Related procedures:
■

The Panorama Window (page 119)

Figure Display
Use this dialog box to display Inverse or Mapcheck information for a figure.
Related procedures:
■

Listing Mapcheck Information for a Figure (page 384)

■

Listing Inverse Information for a Figure (page 385)

■

The Panorama Window (page 119)

■

Performing a Mapcheck Analysis (page 1796)

Traverse Editor
Use this dialog box to edit the observations of an existing named traverse or to enter traverse observations
for a new empty traverse.
The left pane of the Traverse Editor displays the following properties for the selected setup within the current
station point:
Station Point
Displays the station point number.
Backsight Point
Displays the backsight number.
Backsight Direction
Specifies the backsight direction.
Backsight Orientation
Specifies the orientation of the horizontal circle when backsighting the point.
Backsight Face1
Specifies the direct angle reference on the backsight for face1 angles.
Backsight Face2
Specifies the direct angle reference on the backsight for face2 angles.
Instrument Height
Specifies the measured instrument height.
Instrument Elevation
Displays the instrument elevation.
Northing
Displays the northing value.
Easting
Displays the easting value.
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Elevation
Displays the elevation.
Latitude
Displays the latitude.
Longitude
Displays the longitude.
In the right pane of the Traverse Editor you can enter observations for each Setup and specify the following;
Name
Specifies a traverse station point name.
Angle
Specifies the angle using the current Survey database units.
Angle Type
Specify one of the following:
■

Angle

■

Deflection

■

Face1 Angle

■

Face2 Angle

■

Azimuth

■

Bearing-NE

■

Bearing-SE

■

Bearing-SW

■

Bearing-NW

■

None

Distance
Specify the distance in the current Survey database units.
Distance Type
Specify one of the following:
■

Slope

■

Horizontal

■

None

Vertical
Specifies the vertical type.
Vertical Type
Specify one of the following:
■

Vertical Angle

■

Vertical Distance

■

None
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Target Height
Specifies the target height.
Target Type
Specify one of the following:
■

Stadia

■

Prism

■

None

Scale Factor
Specifies the scale factor.
Description
Specifies a description.
Easting
Displays the easting.
Northing
Displays the northing.
Elevation
Displays the elevation.
Longitude
Displays the latitude.
Latitude
Displays the longitude.
Related procedures:
■

The Panorama Window (page 119)

Traverses Editor
Use this vista to edit and view information for multiple traverses.
Name
Specifies the name for the traverse.
Description
Specifies a description for the traverse.
Initial Station
Specifies the starting setup point ID in the traverse.
Initial Backsight
Specifies the initial backsight. The initial backsight point number must not be 0. The initial backsight
must be to either an existing survey point, or there must be a direction observation from the initial station
point to the initial backsight point. In cases where there is a direction observation, the backsight point
does not have to exist as a survey point.
Stations
Specifies the points that are included in the traverse. Separate a range of points with a hyphen (-), and
separate individual points with a comma (,). For example: 1-5,8,10,12-15.
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Final Foresight
Specifies the final foresight point ID. This establishes the final foresight station point in the traverse
definition, onto which the closing angle was turned.
Related procedures:
■

Traverses (page 401)

■

The Panorama Window (page 119)

Survey Point Properties Dialog Box
Use this dialog box to view or edit the properties of a survey point.
Survey points can be control points, non-control points, setups, or observations.
If you are editing the properties of a point using the Survey tab item view, for more information on the
functions available, see Survey Tab Item View (page 2725).
Number
Displays the point number.
Name
Specifies the point name.
Easting
Displays the point easting.
NOTE If the survey database has been assigned a coordinate system zone, the Longitude property value is
calculated from the value in this field.
Northing
Displays the point northing.
NOTE If the survey database has been assigned a coordinate system zone, the Latitude property value is
calculated from the value in this field.
Elevation
Displays the point elevation.
Description
Specifies the point description.
NOTE Latitude and Longitude values are only displayed when the survey database has an assigned coordinate
system zone.
Longitude
Displays the point longitude. The Easting property value is calculated from the value entered in this field.
Latitude
Displays the point latitude. The Northing property value is calculated from the value in this field.
Network
Displays the name of the network that first observed the point.
Import Event
Displays the name of the import event if the survey point was created by an import command.
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Original Number
Displays the original survey point number if a point identifier offset was applied during the import
command.
Original Name
Displays the original survey point name if the survey point was renamed during the import command.

LandXML
If you are using the extended properties feature, the LandXML elements as defined in the .sdx_def file are
displayed. Click the cell in the Value column to assign an attribute.

User-defined
If you are using the extended properties feature, and have created user-defined properties they are displayed.
Click the cell in the Value column to assign an attribute.

Survey Tab Item View
Use the Survey tab item view to display information about the contents of an individual item or a collection
and to access related commands.
For some collections and some individual items, you can display additional information in an item view,
which is displayed in a pane next to the tree when the Toolspace window is floating and beneath the tree
when the Toolspace window is docked. To display the item view for a collection or an individual item in
the tree, click the item name.
NOTE To see the item view, you may need to increase the size of the Toolspace window or move the bar that
separates the item view from the tree. To move the bar that separates the item view from the tree, you must first
select a collection that displays an item view.
An item view can be a collection list view, properties list view, or graphical view, depending on the selected
item.
If there are editable fields in the list view, the following icons are displayed:

Discards any edits made to the properties and reloads the properties from the relevant database.

Saves any edits made to the properties back to the relevant database.
Bold text in the survey item view indicates that there are unsaved changes made to data. Click
the changes or

to save

to discard the changes and revert the data.

LandXML
If you are using the extended properties feature, the LandXML elements as defined in the .sdx_def file that
are relevant to networks are displayed. Click the cell in the Value column to assign an attribute.

User-defined
If you are using the extended properties feature, and have created User-defined properties they are displayed.
Click the cell in the Value column to assign an attribute.

Collection List View
A collection list view is a grid of rows and labeled columns displayed by the Toolspace trees for collection
items. The list view can be displayed beneath or next to the Toolspace tree, depending on the state of the
Toolspace window. The data displayed in the list view depends on the item selected in the tree.
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Properties List View
A properties list view displays an editable view of the properties of the item selected, for example, and
individual figure, control point, or setup.

Graphical View
A graphical view displays information about the selected item in a graphical (picture) form.
You can right-click in the graphical preview to display a shortcut menu that allows you to manipulate the
image using commands such as Pan and Zoom.
Related procedures:
■

The Toolspace Item View (page 99)

■

The Toolspace Survey Tab (page 115)

Survey User Settings Dialog Box
Use this dialog box to change and view survey user settings.
Survey user settings are specific to a Windows user login account and affect the survey features, not database,
or drawing data.

Miscellaneous
Establish default external editor settings.
Use External Editor
Specifies whether to use an external editor for displaying analysis input and output and editing field book
and batch file. Click the check box to use an external editor.
NOTE If you do not specify to use an external editor, the default editor, specified in the AutoCAD Options
dialog box, is used.
External Editor
Specifies the path and name of the external editor. Enter a name and path or click
location.

to browse to a

Preview Vertical Exaggeration
Specifies if the network, setup, and figures previews are exaggerated vertically. Enter a value, which is the
factor applied to the elevations of the objects displayed in the previews.

Survey Database Defaults
Establish default locations for the survey database settings.
Survey Database Settings Path
Specifies the path for the location of the survey database settings files. The .*sdb_set files located in this
path can be selected in the Survey Database Settings.
Survey Database Settings
Specifies the survey .*sdb_set file. This file contains the default database settings that are used when you
create a new survey database.
Extended Properties Definition Path
Specifies the path for the location of the survey extended properties definition files. The .*sdx_set files
located in this path can be selected in the Extended Properties Definition.
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Extended Properties Definition
Specifies the .*sdx_set file. This pre-defined schema contains both LandXML and user defined properties
that can be specified as the default when you create a new survey database.

Equipment Defaults
Establish default equipment database settings.
Equipment Database Path
Specifies the path for the equipment databases. This is the path where all new equipment databases are
stored. Enter a path or click

to browse to a location.

Current Equipment Database
Specifies the current equipment database. Click the equipment database from the drop-down list.
NOTE The list of available databases is determined by the databases listed in the Equipment Databases collection
in the Toolspace Survey tab.
Current Equipment
Specifies the current equipment to use. Click the equipment name from the drop-down list.
The current equipment sets the values associated with a specific surveying instrument, such as the standard
deviations associated with the measuring capabilities for the equipment. This information is used in
various calculations including least squares.

Linework Processing Defaults
Establish the default location for the linework code set and specify the linework code set to be used to do
linework processing during the import.
Linework Code Sets Path
Specifies the path for the Linework Code Sets. This is the path where all linework code sets are stored.
Enter a path, or click

to browse to a location.

Process Linework During Import
Specify Yes to process linework during an import command.
Current Linework Code Set
Specifies the default linework code set to use when linework processing occurs.
Process Linework Sequence
Specifies the order in which survey point descriptions are processed to determine linework connectivity.
Select one of the following:
■

By Import Order - processes points in the order in which they are imported. Point names are always
processed by import order.

■

By Point Number - processes points sequentially by point number (ascending order only).

Figure Defaults
Establish equipment and figure prefix database information as well as the default external editor.
Figure Prefix Database Path
Specifies the path for the figure prefix database. This is the path where all new equipment databases are
stored. Enter a path or click

to browse to a location.

Current Figure Prefix Database
Specifies the current figure prefix database. Click the figure prefix database from the drop-down list.
Figure prefixes enable you to determine the layer that a figure is drawn on by creating a prefix for a group
of figure names. All figures with a specific prefix are placed on a specific layer.
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NOTE The list of available databases is determined from the databases listed in the Figure Prefix Databases
collection on the Toolspace Survey tab.
Figure Style
Specifies the default style for figures inserted into the drawing.
Figure Layer
Specifies the default layer for figures inserted into the drawing.

Interactive Graphics
Control the display of survey components during import and entry of survey data.
NOTE To change the colors for the components, click the color swatch to open the Select Color dialog box, from
which you can select a color.
Automatic Pan and Zoom
Specifies if the drawing automatically pans and zooms to the survey observations when they are imported
or entered.
Show Backsight Line
Specifies whether a line, which represents the line backsighted by the survey instrument setup, is displayed.
Show Backsight Prism
Specifies whether a symbol, which represents the prism at the backsight point, is displayed.
Show Station Instrument
Specifies whether a symbol, which represents the instrument (transit) at the station (or occupied) point,
is displayed.
Show Foresight Line
Specifies whether a line, which represents the line foresighted by the survey instrument setup, is displayed.
Show Foresight Prism
Specifies whether a symbol, which represents the prism at the foresight point, is displayed.
Show Baseline
Specifies whether a line, which represents the line established as a baseline, is displayed.
Show Baseline Prism
Specifies whether a symbol, which represents the prism at any new point created from a baseline, is
displayed.
Show Baseline Offset Line
Specifies whether a line, which represents the baseline offset to any new point created, is displayed.
Show Current Figure
Specifies whether a line, which represents the current figure, is displayed.
Show Current Figure Vertex
Specifies whether the figure vertex is displayed.

Import Defaults
Specify the properties for importing a batch file into the selected survey network.
Show Interactive Graphics
Specifies whether to display interactive graphics during the import of survey data. Use Interactive Graphics
settings to control the display of individual graphics components.
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Erase Survey Points From Drawing
Specifies whether to erase all the points referenced by the selected network from the drawing.
NOTE Points referenced by other networks are not erased from the drawing and database.
Reset Network
Specifies whether to remove all the observations in the survey database for the selected network. When
this property is unchecked, incoming observations are appended to the observation database for the
selected network.
Delete Network Figures
Specifies whether to erase figures, which have a reference to the selected network, from the drawing and
database.
Insert Network Object
Specifies whether to create a network object in the drawing.
Insert Figure Objects
Specifies whether to create figure objects in the drawing.
Insert Survey Points
Specifies that Survey points are inserted into the drawing.
Default Figure Site
Specifies the default site for figures that are set to create Lot Lines. When inserting a figure into the current
drawing:
■

If this site does not exist in the current drawing, it is created.

■

This site is used if the Lot Line property for the figure is set to True, and the Site property for the figure
is blank.

Display Tolerance Errors In Event Viewer
Select Yes to display tolerance errors in the Event Viewer when you import data using the Import Field
Book, Import LandXML, or Import Batch File commands. For more information, see Reporting Tolerance
Errors (page 233).

Export Defaults
Specify the properties for exporting survey data to a field book file.
Export Figures With Network
Select Yes to export the figures in the database when you use the Export Field Book command.
The figure type determines what is added to the field book. For information on the conditions and syntax
that is added to the field book, see Setting Export Defaults (page 235).
Export Point Identifiers
Specifies if point IDs are used to define figures when figures are exported to a field book.
For information on the conditions and syntax that is added to the field book, see Setting Export Defaults
(page 235).
Export Point Data
This check box is active when the Export Point Identifiers property is not set to None. Select Yes if you
want each figure vertex that references a point identifier to output the following to the field book file
prior to the section defining the figures: NE SS <point ID> <north> <east> <elevation> <description>

Network Preview
Specify the network preview properties when selecting a Network item in the Survey Toolspace tab.
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Show Network
Specifies whether to preview the network lines for the selected network item.
Show Sideshots
Specifies whether to preview the sideshot lines for the selected network item.
Show Points
Specifies whether to preview the points for the selected network item.
Show Figures
Specifies whether to preview the figures that reference the selected network item.
NOTE Showing figures significantly increases the time required to generate the preview entities.

Setup Preview
Specify the setup preview properties when selecting a Setup item in the Survey Toolspace tab.
Show Sideshots
Specifies whether to preview the sideshot lines for the selected setup item.
Show Points
Specifies whether to preview the points for the selected setup item.
Show Figures
Specifies whether to preview the figures affected by the selected setup item.

Figure Preview
Specify the setup preview properties when selecting a Figure item in the Survey Toolspace tab.
Show Figure
Specifies whether to preview the line segments for the selected figure item.
NOTE Showing figures significantly increases the time required to generate the preview entities.
Show Points
Specifies whether to preview the display of the points referenced by the selected figure item.

Change Reporting
Specify the default settings for the change report.
Report Style Path
Specifies the path for the change report style sheet.
Report Style
Specifies the report style sheet (.xsl file) used with an .xml file to create the report.
Related procedures:
■

User Settings (page 227)

Translate Survey Database Dialog Box
Use this dialog box to specify the values needed to perform a simple translation on an open survey database.
This command is useful when you need to move the data in a survey database from an assumed location to
a known location, subsequent to importing the survey data into AutoCAD Civil 3D.
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See also:
■

Translating a Survey Database (page 220)

Base Point Page (Translate Survey Database Dialog Box)
Specify the base point from which the survey network will be moved.
Number
Enter an existing survey point number in the survey database. The Name, Easting, Northing, Elevation,
Description, Latitude, and Longitude property values are displayed.
NOTE The values for the Base Point properties are displayed in the current Survey database units.
Name
Displays the name of the base point.
Easting
Displays the Easting value for the base point.
Northing
Displays the Northing value for the base point.
Elevation
Displays the elevation value for the base point.
Description
Displays an optional description for the base point.
Longitude
Displays the Longitude for the base point. If the Survey database has been assigned a coordinate zone,
the Longitude property displays the longitude of the easting value.
Latitude
Displays the Latitude value for the base point. If the Survey database has been assigned a coordinate zone,
the Latitude property displays the latitude of the Northing value.
Pick In Drawing
In the drawing, select the northing and easting for the base point. If the drawing has been assigned a
coordinate zone that is different from the assigned zone of the Survey Database, the coordinates of the
point that you pick in the drawing are transformed to the Survey Database coordinates.

Rotation Angle Page (Translate Survey Database Dialog Box)
Specify the rotation angle for the survey database.
Rotation Angle
Specify a positive or negative rotation angle.
NOTE The values for the Rotation Angle are displayed in the current Survey database units.
Pick In Drawing
Specify the start point of the existing direction, the second point, the start point of new direction, and a
second point.
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Destination Point Page (Translate Survey Database Dialog Box)
Specify the destination point to which the survey database will be moved.
Easting
Specifies the easting value.
Northing
Specifies the northing value.
Longitude
Displays the Longitude for the base point. If the Survey database has been assigned a coordinate zone,
the Longitude property displays the longitude of the easting value.
Latitude
Displays the Latitude value for the base point. If the Survey database has been assigned a coordinate zone,
the Latitude property displays the latitude of the Northing value.
Elevation Change
Specifies the change in elevation. (optional)
Pick In Drawing
Specify the start point of the existing direction, the second point, the start point of new direction, and a
second point.

Summary Page (Translate Survey Database Dialog Box)
Displays a summary of the Base Point, Destination Point, and the Translation values

Traverse Analysis Dialog Box
Use this dialog box to enter settings for traverse analysis. Initially, the Traverse Analysis settings you enter
in the Survey Database settings are displayed as the default settings.

Traverse Analysis Property
Do Traverse Analysis
Select Yes to perform a mathematical analysis based on the method you specify as the Horizontal
Adjustment Method.
Do Angle Balance
Select Yes to have the angular error evenly distributed throughout the traverse.
Horizontal Adjustment Method
Specify one of the following traverse analysis methods:
■

Compass Rule: A method of corrections where the closing errors are assumed to be as much due to
errors in observed angles as by the errors in measured distances. The closing errors in latitude and
departure are distributed according to the ratio of the length of the line to the total length of the
traverse

■

Transit Rule: A method of balancing a traverse where the closing errors are assumed to be caused less
by the errors in the observed angles than by the errors in measured distance. Corrections are distributed
according to the ratio of the latitude and departure of each leg of the traverse to the sums of the latitude
and departures of the entire traverse.

■

Crandall Rule: A method of balancing a traverse where all the angular error is distributed throughout
the traverse and all adjustments to the traverse are due to modifying the traverse distances. The
modification distance made to each leg is such that the sum of the squares is a minimum. Corrections
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corresponding to the closing errors assume that the closing errors are random and normally distributed,
and that all the angular error has been adjusted prior to the adjustment routine.
■

Least Squares: A method of balancing a traverse. The squares of the differences between the unadjusted
and adjusted measurements (angles and distances) are summed and reduced to a minimum. This
method weights the individual measurements according to the specifications set in the Equipment
correction settings to determine the source of error. You can adjust the data for an individual traverse
loop, or a traverse network, if located from multiple observations.

Vertical Adjustment Method
Specify one of the following vertical adjustment methods:
■

None: No vertical adjustment performed

■

Length Weighted Distribution: Vertical adjustment distributes the vertical closing error to each line
at the same ratio as the length of the line to the total length of the traverse (similar to the Compass
rule).

■

Equal Distribution: Vertical adjustment distributes the vertical closing error equally to each of the
traverse stations.

■

Least Squares: A method of distributing the vertical error throughout a traverse. The squares of the
differences between the unadjusted and adjusted measurements (angles and distances) are summed
and reduced to a minimum. This method weights the individual measurements according to the
specifications set in the Equipment correction settings to determine the source of error. You can adjust
the data for an individual traverse loop, or a traverse network, if located from multiple observations.

NOTE The Least Squares vertical adjustment method is only available if Least Squares has been selected as the
horizontal adjustment method. When this method is selected, a 3D least squares adjustment is performed. If
this method is not selected a 2D least squares adjustment is performed.
Horizontal Closure Limit 1:X
Specifies the minimum allowable error of closure in the horizontal direction, for example a value of
15000.00 is 1 part in 15000.
Vertical Closure Limit 1:X
Specifies the minimum allowable error of closure in the vertical direction, for example a value of 15000.00
is 1 part in 15000.
Angle Error Per Set
Specifics the maximum angular error per traverse setup.
Update Survey Database
Specify Yes to update the Survey database with the adjusted coordinates.
NOTE During the analysis, if the specified limits for the horizontal, vertical, or angle limits are exceeded, a
warning message box is displayed. Select Yes to update the database or No if you do not want the database
updated.
Related procedures:
■

Performing Traverse Analysis (page 403)
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Use the following links to access information about the Table dialog boxes.

Table Style Dialog Box
Use this dialog box to create or edit table styles.

Information Tab (Table Style Dialog Box)
Use this tab to change the table style name and description information.
Name
Specifies a name for the style.
Description
Specifies a description for the style.
Created By
Displays the AutoCAD login name of the person who created the style.
Date Created
Displays the date and time the table style was created.
Last Modified By
Displays the AutoCAD login name of the person who last modified the style.
Date Modified
Displays the date and time the table style was last modified.
Related procedures:
■

Defining a New Table Style (page 1738)

Data Properties Tab (Table Style Dialog Box)
Use this tab to format table text style and structure.
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Table Settings
Wrap Text
Forces text to fit within a specified column width by wrapping it in multiple lines.
NOTE Wrap text applies to columns that are not set to automatic width.
Maintain View Orientation
Specifies whether the table is realigned if the drawing view is rotated or twisted.
■

Selected: Realigns the table to the view direction.

■

Cleared: Does not realign the table.

Repeat Title In Split Tables
Specifies whether titles are duplicated in split tables.
■

Selected: Duplicates the title in all table sections.

■

Cleared: Creates split tables without titles on the second and additional sections.

Repeat Column Headers In Split Tables
Specifies whether column headers are duplicated in split tables.
■

Selected: Duplicates the column headers in all table sections.

■

Cleared: Creates split tables without headers on the second and additional sections.

Sort Data
Specifies whether table data is sorted based on a selected column.
■

Selected: Sorts table data based on the specified column.

■

Cleared: Orders table contents in the order in which the objects are drawn.

Sorting Column
Specifies the column to sort.
Order
Specifies how to sort the column.
■

Ascending: Sorts from lowest to highest.

■

Descending: Sorts from highest to lowest.

Text Settings
Title Style
Specifies a text style for the title.
Header Style
Specifies a text style for the column headings.
Data Style
Specifies a text style for the row data.
Height
Specifies the height values for Title, Header, and Data text.
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Structure
Controls the composition of data. You can do the following:
■

Edit the title or column headings. Double-click the text to display the Text Component Editor (page 2203).

■

Edit the column widths (see Column Width below).

■

Edit the content of the data columns. Double-click a Column Value cell to display the Text Component
Editor (page 2200).

■

Rearrange the order of columns. Select the column and drag it. The first column is reserved as the tag
column and cannot be moved.

Table Headers
Table Title (for example, “Line Table”)
Specifies the title contents. To edit the title, double-click the text (such as “Line Table”) to display the
Text Component Editor. For more information, see Text Component Editor (page 2203).
Column Title
Specifies the column heading contents. To edit the headings, double-click the text to display the Text
Component Editor.
NOTE Except for alignment table styles, the Properties tab in the Text Component Editor is disabled when you
edit column heading text.

Columns
Column Width
Specifies column widths. Click

and select one of the following options:

■

Automatic: Sizes the column width according to the longest text string in the table.

■

Manual: Sets the column width according to a specified character width.
NOTE When you specify a fixed width and do not select the Wrap Text option, and the content exceeds
the column width, the value in the column is a series of #### characters equal to the width of the column.

Column Value
Specifies the content for each table column. The content can be derived from a combination of static text
and property fields associated with a feature.
To edit the column values, double-click a cell in the row. Use the Properties (page 2200) tab in the Text
Component Editor to define the column’s dynamic content.

Adds a column at the end of the table. Because the new column is empty, you must define a column
heading, width, and value. The column width is set to Automatic width by default.

Deletes a column. Select the column you want to delete and then click the icon.
The first column cannot be deleted.
Related procedures:
■

Defining Table Text Styles (page 1738)
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■

Defining Table Titles (page 1739)

■

Defining Table Column Titles (page 1740)

■

Linking Table Data (page 1740)

■

Table Format (page 1741)

Display Tab (Table Style Dialog Box)
Use this tab to determine values for components in a table.

View Direction
Specifies the view direction for defining display settings.
2D
Selects the 2D set of display properties for viewing and editing.
3D
Selects the 3D set of display properties for viewing and editing.

Component Display
Component Type
Specifies display settings for each table component.
■

Overall Border: Graphic line that forms a boundary around the outside of table.

■

Title Separator: Horizontal graphic line that separates title from column headings.

■

Header Separator: Horizontal graphic line that separates column headings from data rows.

■

Data Separator: Horizontal graphic line that separates data rows.

■

Data Divider: Vertical graphic line that separates columns.

■

Title Area Fill: Solid hatch pattern that serves as background fill for the table title area.

■

Header Area Fill: Solid hatch pattern that serves as background fill for the column heading areas.

■

Data Area Fill: Solid hatch pattern that serves as background fill for all data rows.

■

Title Text: Table name in first row.

■

Header Text: Column names in second row.

■

Data Text: All text in data rows.

Visible
Specifies whether the component is visible. Click

to switch between visible and hidden

.

Layer
Specifies the layer from which the component derives its layer properties. Click the column to display
the Layer Selection dialog box.
If you set the layer to zero (0), the components use the layer properties as specified in the Drawing Settings
dialog box.
Color
Specifies the color of the component. Click the column to display the Select Color dialog box.
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Linetype
Specifies the linetype of the component. Click the column to display the Select Linetype dialog box.
LT Scale
Specifies the linetype scale of the component. To change the linetype scale for an object component,
highlight the linetype scale and enter a new value in the cell.
Lineweight
Specifies the lineweight of the component. Click the column to display the Lineweight dialog box.
Plot Style
Specifies a set of overrides to be used when plotting.
Related procedures:
■

Table Display (page 1745)

Summary Tab (Table Style Dialog Box)
Use this tab to review style settings. The property window contains two columns: Property and Value.
You can make changes to values in the Value column of the Summary tab; however, the display settings are
not available on this tab.
Related procedures:
■

Viewing a Summary of Table Settings (page 1746)

Table Creation Dialog Box
Use this dialog box to add tables to a drawing.
Table Style
Specifies the table style to use.
Style Selection Menu
Creates a new table style, edits a table style, or selects a table style from the drawing.
Style Detail
Displays the Style Detail dialog box.
Table Layer
Specifies the layer on which the table is drawn. Click

to select a layer.

Selection
Controls what data is inserted into the table.
NOTE Because objects must be labeled to create a table that contains their data, most tables require you to specify
the table data by selecting a label style or a label in the drawing. Exceptions are point tables and alignment segment
tables, which allow you to specify point groups and alignments.
Label Style Name
Adds data to the table from all objects labeled with the selected label style. Select the check box next to
the style name to select a label style.
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Selection Rule
Controls whether existing or new data is added to the table. After selecting the Apply check box, click the
Selection Rule field and select one of the following options.
■

Add Existing: Creates a table from existing objects labeled with the style. Data from new objects labeled
with the style is not added to the table.

■

Add Existing and New: Creates a table from existing and new objects that are labeled with the style.

By Alignment (alignment segment tables only)
Adds data from the selected alignment to the table.
Select Point Groups (point tables only)
Adds data from the selected point group to the table.
Pick On-Screen
Adds data to the table from the objects or labels that you select in the drawing.
NOTE This area of the Table Creation dialog box is not displayed for the Tangent-Tangent Intersection (PI)
table.

Split Table
Split Table Option
■

Selected: Divides a table into two or more sections after a specified maximum number of rows has
been met.

■

Cleared: Does not divide the table.

Maximum Rows Per Table
Specifies the maximum number of rows to include per section.
If the number of data rows exceeds the specified maximum, the table is split into sections, and they are
displayed either side by side (left to right), or stacked vertically.
Maximum Tables Per Stack
Specifies the maximum number of sections to include in each stack. See also the following Tile Tables
option.
Offset
Specifies the gap between split tables.
Tile Tables
Specifies the direction in which tables are stacked.
■

Across: Places split tables in a row from left to right. When the maximum tables per stack is reached,
a new row is started.

■

Down: Places split tables in a column from top to bottom. When the maximum tables per stack is
reached, a new column is started.

Behavior
Reactivity Mode
Specifies whether tables are updated automatically.
■

Static: Keeps table data fixed. If you want to see changes, click Update Content from the shortcut
menu.

■

Dynamic: Updates table data dynamically when you make changes.
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Related procedures:
■

Adding Object Tables to Drawings (page 1748)

Table Properties Dialog Box
Use this dialog box to review table properties and to change styles and appearance.
Table Style
Specifies the table style to use.
Style Selection Menu
Creates a new table style, edits a table style, or selects a table style from the drawing.
Style Detail
Displays the Style Detail dialog box.

Split Table
Split Table Option
■

Selected: Divides a table into two or more sections after a specified maximum number of rows has
been met.

■

Cleared: Does not divide the table.

Maximum Rows Per Table
Specifies the maximum number of rows to include per section.
If the number of data rows exceeds the specified maximum, the table is split into sections, and they are
displayed either side by side (left to right), or stacked vertically.
Maximum Tables Per Stack
Specifies the maximum number of sections to include in each stack. See also the following Tile Tables
option.
Offset
Specifies the gap between split tables.
Tile Tables
Specifies the direction in which tables are stacked.
■

Across: Places split tables in a row from left to right. When the maximum tables per stack is reached,
a new row is started.

■

Down: Places split tables in a column from top to bottom. When the maximum tables per stack is
reached, a new column is started.

Force Realignment Of Stacks
Realigns the stacks in a split table.

Behavior
Reactivity Mode
Specifies whether tables are updated automatically.
■

Static: Keeps table data fixed. If you want to see changes, click Update Table from the shortcut menu.

■

Dynamic: Updates table data dynamically when you make changes.
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Force Content Update
Refreshes the table if the Reactivity Mode is set to Static.
Related procedures:
■

Changing Table Properties (page 1750)

Renumbering Dialog Box
Use this dialog box to set the starting number and increment value for renumbering.
This dialog box is used for renumbering parcels and for renumbering alignment tags.
Site Name
Specifies the site in which the parcels, parcel tags, or alignment tags are renumbered. Click
a site in the drawing by selecting an object in the site.

to select

Increment Format
Starting Number
Specifies the next number that is used for renumbering the objects or tags.
Increment Value
Specifies the difference between numbers in the numbering sequence.
Related procedures:
■

Renumbering Label Tags (page 1723)

Add Selection Dialog Box
Adds content to a table.
Use the Add Selection dialog box to add content to a table.
Append to Current Selection Set
Controls what data is added to the table.
NOTE Because objects must be labeled to create a table that contains their data, most tables require you to
specify the table data by selecting a label style or a label in the drawing. Exceptions are point tables and alignment
segment tables, which allow you to specify point groups and alignments.
Label Style Name
Adds data from all objects labeled with the selected label style to the table. Select the Apply check box to
select a label style.
Selection Rule
Controls whether existing or new data is added to the table. After selecting the Apply check box, click the
Selection Rule field and select one of the following options.
■

Add Existing: Creates a table from existing objects labeled with the selected style. Any new objects
labeled with the specified style are not added to the table.

■

Add Existing and New: Creates a table from existing and new objects that are labeled with the selected
style.
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Pick On-Screen
Adds data selected in the drawing to the table.
Select Point Groups (point tables only)
Adds data from the selected point group to the table.
Related procedures:
■

Changing Table Data (page 1750)

Remove Selection Dialog Box
Deletes rows from a table.
Use the Remove Selection dialog box to remove rows from a table.
Exclude From Current Selection Set
Controls what data is removed from the table.
Label Style Name
Removes data for all objects labeled with the selected label style. Select the Apply check box to select a
label style.
Exclusion Rule
Remove All: Removes all data currently labeled with the specified label style.
Pick On-Screen
Removes selected table rows.
Select Point Groups (point tables only)
Removes data from the selected point group from the table.
Related procedures:
■

Changing Table Data (page 1750)

Replace Selection Dialog Box
Replaces table data.
Use the Replace Selection dialog box to replace table content with other data.
Replace Current Selection Set
Controls what data is added to the table, replacing all the data that is currently in the table.
Label Style Name
Adds data to the table from all objects labeled with the selected label style. Select the Apply check box to
select a label style.
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Exclusion Rule
Controls whether existing or new data is added to the table. After selecting the Apply check box, click the
Selection Rule field and select one of the following options.
■

Add Existing: Creates a table from existing objects labeled with the selected style. Any new objects
labeled with the specified style are not added to the table.

■

Add Existing and New: Creates a table from existing and new objects that are labeled with the selected
style

Pick On-Screen
Adds data selected in the drawing to the table.
Select Point Groups (point tables only)
Adds data from the selected point group to the table.
Related procedures:
■

Changing Table Data (page 1750)
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Utilities Dialog Boxes
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Use the following links to access information about the Utilities dialog boxes.

Description Dialog Box
Use this dialog box to change the description of an object.
Description Box
Specifies the description of the object.

Mapcheck Analysis Window
Use this window to create, edit, and output a Mapcheck Report.
Collapse All
Collapses all items in the tree view.
Expand All
Expands all items in the tree view.
Use Command Line Interface
Toggles on and off the command line input. When this button is toggled on you are prompted to pick
labels in the drawing to create the mapcheck. Toggle this button off to create a mapcheck by entering
data manually.
New Mapcheck Report
Clears the existing mapcheck report and starts a new report.
New Mapcheck
Creates a new mapcheck and Point of Beginning (POB) in the Mapcheck Report.
New Side
Adds a new side to the end of the current mapcheck.
NOTE This button is disabled if you have not entered a POB.
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Insert Side Before
Inserts a new side before the current side.
Insert Side After
Inserts a new side after the current side.
NOTE This button is disabled if a side is not selected, or if you have not entered a POB.
Delete
Deletes the current side or current mapcheck if no side is current.
Input View
Displays the Mapcheck Analysis window in input mode. You can enter and modify values in the view.
Output View
Displays the Mapcheck Analysis window in output mode. This view displays the closure summary.
Copy to Clipboard
Copies the contents of the input view or output view to the Windows Clipboard.
If a mapcheck is current then only that mapcheck is copied to the clipboard. If no mapcheck is current
then all mapchecks are copied. Press ESC to clear a selection in tree view.
Insert MTEXT
Inserts the contents of the input view or output view as an Mtext object in the drawing.
If a mapcheck is current then only that mapcheck is inserted into the drawing. If no mapcheck is current
then all mapchecks are inserted into the drawing as separate Mtext objects. Press ESC to clear a selection
in tree view.
Create Polyline
Inserts a polyline into the drawing representing the current mapcheck. If there is no current mapcheck
then a polyline for all mapchecks is inserted into the drawing. Press ESC to clear a selection in tree view.

Mapcheck Tree
Name
Specifies the optional mapcheck name. If a name is not assigned, the display is Mapcheck <number>.
Point of Beginning (POB)
Click to specify the Point Of Beginning (POB) in the drawing. All other Side points are calculated from
the POB.
Easting
Modify the easting value for the POB.
Northing
Modify the northing value for the POB.

Side
A side can be either a line or a curve. The following section describes the values for a line Side type.
Side Type
Specifies the Side as line.
Angle Type
Specifies the angle type to be used. Select Direction, Angle, or Deflection from the drop-down list.
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Angle
Specifies the angle value for the Side based on the angle type.
Reverse Direction
Select the check box to reverse the line direction or the curve chord direction by 180 degrees to calculate
the endpoint coordinates for the Side.
Distance
Specifies the distance value for the Side.
Easting
Displays the calculated easting value for the Side.
Northing
Displays the calculated northing value for the Side.
A side can be either a line or a curve. The following section describes the values for a curve Side type.
Side Type
Specifies the Side as a curve.
Curve Direction
Specifies the curve directions as Clockwise or Counter-clockwise.
Traverse Method
Specifies how the error of closure is calculated and displayed in the Output View.
Specify one of the following:
■

Across Chord: The endpoint of the curve is calculated from the Chord direction and distance.

■

Through Radius: The endpoint of the curve is calculated based on the direction to the radius point,
the radius length, the delta angle, and the direction from the radius point to the point of tangency.
If this option is selected, additional information is displayed in the Output View.

Radius
Specifies the radius value. This value is required.
NOTE Calculated curve properties do not display in the Input View. Click
view.

Output View to display the output

Arc Length
Specifies the length of the curve.
Delta Angle
Specifies the curve delta angle.
Tangent
Specifies the curve tangent distance.
Chord Angle Type
Specifies the angle type as Direction, Angle, or Deflection. If the angle type is set to Angle or Deflection,
the specified angle value is relative from a tangent line at the point of curvature to the point of tangency
(long chord).
Chord Angle
Specifies the chord angle value.
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Reverse Direction
Select the check box to reverse the line direction or the curve chord direction by 180 degrees to calculate
the endpoint coordinates for the Side.
Chord Distance
Specifies the chord distance value.
Easting
Displays the calculated easting value of the Side endpoint.
Northing
Displays the calculated northing value of the Side endpoint.
Related procedures:
■

Performing a Mapcheck Analysis (page 1796)

Adjust Mapcheck Analysis Dialog Box
Use this dialog box to adjust a mapcheck report for closure.
Do Angle Balance
Select Yes to perform a mathematical analysis based on the method you specify as the Horizontal
Adjustment Method.
Horizontal Adjustment Method
Specify one of the following traverse analysis methods:
■

Compass Rule: A method of corrections where the closing errors are assumed to be as much due to
errors in observed angles as by the errors in measured distances. The closing errors in latitude and
departure are distributed according to the ratio of the length of the line to the total length of the
traverse

■

Transit Rule: A method of balancing a traverse where the closing errors are assumed to be caused less
by the errors in the observed angles than by the errors in measured distance. Corrections are distributed
according to the ratio of the latitude and departure of each leg of the traverse to the sums of the latitude
and departures of the entire traverse.

■

Crandall Rule: A method of balancing a traverse where all the angular error is distributed throughout
the traverse and all adjustments to the traverse are due to modifying the traverse distances. The
modification distance made to each leg is such that the sum of the squares is a minimum. Corrections
corresponding to the closing errors assume that the closing errors are random and normally distributed,
and that all the angular error has been adjusted prior to the adjustment routine.

■

Least Squares: A method of balancing a traverse. The squares of the differences between the unadjusted
and adjusted measurements (angles and distances) are summed and reduced to a minimum. This
method weights the individual measurements according to the specifications set in the Equipment
correction settings to determine the source of error. You can adjust the data for an individual traverse
loop, or a traverse network, if located from multiple observations.
NOTE The Least Squares option uses the specified values for the Standard Deviations in the Equipment
Properties for the current Survey Equipment Database. Make sure that values are appropriate for the least
squares method of adjustment. For more information, see Equipment Database Manager Dialog Box (page
2672).

Horizontal Closure Limit
Specifies the minimum allowable error of closure in the horizontal direction, for example a value of
15000.00 is 1 part in 15000.
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Angle Error Per Set
Specifies the maximum angle error.
Update Mapcheck
Specify Yes to update the mapcheck report with the adjusted coordinates.
NOTE In the Mapcheck Analysis Input View, the
icon is displayed next to the Mapcheck name indicating the
mapcheck has been adjusted. To clear an adjustment, right-click the Mapcheck ➤ Clear Adjustment.
Related procedures:
■

Adjusting a Mapcheck Analysis (page 1802)

Notes Dialog Box
Use this dialog box to attach notes or reference documents to an object.

Notes Tab (Notes Dialog Box)
Use this tab to attach notes to an object.
Notes Text Box
Specifies comments to associate with the object.
Related procedures:
■

Attaching Text to an Object (page 1804)

Reference Docs Tab (Notes Dialog Box)
Use this tab to attach reference documents to an object.
Document Column
Specifies the reference document name.
Type Column
Displays the file type for the attached reference file.
Description Column
Displays the file description for the attached reference files.
Add
Displays the Select Reference Document dialog box. Browse to select the reference file that you want to
attach.
Edit
Displays the Reference Document dialog box. Click File to browse for another document. You can edit
the reference document description in the Description box.
Delete
Deletes the selected reference document.
Related procedures:
■

Attaching External Reference Documents to an Object (page 1804)
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Object Viewer Dialog Box
Use this dialog box to control the view of selected objects in your drawing.
The Object Viewer contains the ViewCube and the SteeringWheel. For more information, see Use ViewCube
and Navigation Wheels in the AutoCAD Help.
Save Image
Saves the current view as a separate file. The supported file formats are PNG, JPG, BMP, TIF.
Visual Style List
Specifies the object appearance style. Set the style to one of the following:
■

3D Hidden: Displays objects in the current view in a 3D wireframe representation with all visible lines
displayed as continuous and all hidden lines displayed as dashed.

■

3D Wireframe: Displays objects in the current view in a 3D wireframe representation with all lines
displayed, including those hidden by other objects.

■

Conceptual: Displays objects in a transparently shaded 3D view with all lines visible.

■

Realistic: Displays objects in a shaded 3D view.

Pan
Moves the current view without changing its size.
Zoom
Increases or decreases the apparent size of objects in the current viewport.
SteeringWheel
Provides a Navigation Wheelsmenu that is divided into different sections known as wedges. Each wedge
on the wheel represents a single navigation tool. You can pan, zoom, or manipulate the current view of
a model in different ways.
3D Orbit
Sets the display window to 3D orbit view.
NOTE Hold down Shift and click to pan in the Object Viewer. Hold down Ctrl and click to zoom in the Object
Viewer.

Adjust Distance
Displaces objects a specified distance in a specified direction. This control is available only when the
Perspective control is selected.
View Control List
Specifies the current view. Set the view to either Top, Bottom, Left, Right, Front, or Back. Set the isometric
view to either SW Isometric, SE Isometric, NE Isometric, or NW Isometric
Parallel
Sets the view to a parallel plane.
Perspective
Sets a perspective view and makes the Adjust Distance and Lens Length controls available.
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Lens Length
Sets the length of the lens used in perspective viewing for the current viewport. This control is available
only when the Perspective control is selected.
Zoom Window
Zooms to display an area specified by a rectangular window.
Zoom Center
Zooms to display a window defined by a center point.
Zoom Extents
Zooms to display the drawing extents and results in the largest possible display of all the objects in the
window area.
Zoom In
Zooms in an increment as defined by the Zoom Factor.
Zoom Out
Zooms out an increment as defined by the Zoom Factor.
Zoom Factor
Sets the zoom increments used by the Zoom In and Zoom Out commands.
Set View
Sets the view in the drawing equal to the view in the Object Viewer.
Display Configuration List
Specifies the object viewer display configuration.
NOTE AutoCAD Civil 3D supports only the Standard Display Configuration.
Related procedures:
■

Using the Object Viewer (page 1805)

AEC Editor Tab (Options Dialog Box)
Use the AEC Editor tab in the Options dialog box to control the visibility of the design criteria warning
marker, and settings that affect the Export To AutoCAD commands.

Solution Tip
Controls the visibility of the design criteria warning marker. This warning marker is displayed in the drawing
window when an alignment or profile entity violates the specified design criteria.
NOTE If either of these check boxes are cleared, the warning marker will not be displayed on any alignment or
profile objects that violate the specified design criteria. However, the alignments and profiles will still be validated
against the specified design criteria, and warning markers will appear the Alignment Entities and Profile Entities
vistas and the Alignment Layout Parameters and Profile Layout Parameters dialog boxes.
Drafting
Displays the warning marker in the drawing window.
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Plotting/Publishing
Displays the warning marker in plotted or published output.

Export to AutoCAD
Bind Xrefs
Binds xrefs to the host drawing when using the Export To AutoCAD commands, creating local block
definitions. If you select this option, all xrefs and their dependent named objects become a part of the
exported drawing.
Use Insert Method When Binding Xrefs
■

Selected: The drawing names of the xref drawings are discarded when the exported drawing is created.
In addition, the xref layers and styles are incorporated into the host drawing, and layers with the same
name acquire the properties of the layers of the host drawing.
This option binds the xref to the current drawing in a way similar to detaching and inserting the
reference drawing. Rather than being renamed using blockname$n$definitionname syntax, xref-dependent
named objects are stripped of the xref name. As with inserting drawings, no name-incrementing occurs
if a local named object shares the same name as a bound xref-dependent named object. The bound
xref-dependent named object assumes the properties of the locally defined named object. For example,
if you have an xref named FLOOR1 containing a layer named WALL, after binding with the Insert
option, the xref-dependent layer FLOOR1|WALL becomes the locally defined layer WALL.

■

Cleared: The xref identities, such as layer names, are retained when you export a file to AutoCAD.
By clearing this check box, xref-dependent named objects are changed from blockname|definitionname
to blockname$n$definitionname syntax. In this manner, unique named objects are created for all
xref-dependent definition tables bound to the current drawing.
For example, if you have an xref named FLOOR1 containing a layer named WALL, after binding the
xref, the xref-dependent layer FLOOR1|WALL becomes a locally defined layer named FLOOR1$0$WALL.
The number $n$ is automatically incremented if a local named object with the same name already
exists. In this example, if FLOOR1$0$WALL already existed in the drawing, the xref-dependent layer
FLOOR1|WALL would be renamed FLOOR1$1$WALL.

Filename Prefix
Adds the specified prefix to a file created with the Export To AutoCAD commands.
Filename Suffix
Adds the specified suffix to a file created with the Export To AutoCAD commands.

Block Properties of Exploded Object
Maintain Resolved Layer, Color, Linetype
Maintains the layer, color, and linetype of AutoCAD Civil 3D objects when you explode them.
When you explode an object, you create several primitive objects grouped in a block definition. If this
option is selected any objects whose component layer, color, and linetype properties are set to ByBlock
take the layer, color, and linetype of the parent object. If this option is cleared, when you explode an
object, properties that are ByBlock remain ByBlock. Clear this option if you want to explode the block
definition even further.

Unselected Grip Colors
Controls the colors of several types of unselected grips.
Object
Specifies the color of the AutoCAD Civil 3D unselected object grips. For example, if you click on a profile,
the unselected grips use this color.
Secondary Object
Not used by AutoCAD Civil 3D.
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Style
Not used by AutoCAD Civil 3D
Auxillary
Not used by AutoCAD Civil 3D
NOTE The other settings on this tab are not used by AutoCAD Civil 3D.
Related procedures:
■

Changing the AEC Editor Settings (page 1858)

■

Viewing and Correcting Alignment Design Criteria Violations (page 1080)

■

Viewing and Correcting Profile Design Criteria Violations (page 1203)

Event Viewer Vista
Use the Event Viewer to view messages that are logged during an AutoCAD Civil 3D session.

Menu and Toolbar
Action menu
Contains general Event Viewer commands, including commands for working with log files, exporting an
event list, and listing event properties. Click a command on the menu.
View menu
Contains commands that control what events are displayed in the event list and how they are displayed.
Click a command on the menu.

Returns to a previously selected collection in the event tree.

Moves forward to a previously selected collection in the event tree.

Makes the Event Viewer collection in the event tree active, displaying all events in the event list.

Shows or hides the event tree.

Displays the Event Properties (page 2754) dialog box for the selected event.

Refreshes the Event Viewer.

Exports the event list to a file. For more information, see Exporting an Event List to a Text File (page 1820).
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Event Tree
Tree
Controls the events that are listed in the event list. Expand the tree and select a collection to list the events
in the collection. For more information, see The Event Viewer Vista (page 1817).

Event List
Type
Specifies the type of event: either Information, Warning, or Error.
Date
Specifies the date the event was logged to the Event Viewer.
Time
Specifies the time the event was logged to the Event Viewer.
Source
Specifies the feature that logged the event to the Event Viewer.
User
Specifies the user who performed the action that caused the event to be logged to the Event Viewer.
Description
Describes the event.
NOTE You can control the columns and the events that are displayed in the event list. For more information,
see Controlling the Columns Displayed in the Event Viewer (page 1817) and Controlling the Events Displayed in
the Event Viewer (page 1818).
Related procedures:
■

The Event Viewer Vista (page 1817)

Event Properties Dialog Box
Use this dialog box to display detailed information about a specific event in the Event Viewer and to copy
the information to the Windows clipboard.
Type
Specifies the type of event: either Information, Warning, or Error.
Date
Specifies the date the event was logged to the Event Viewer.
Time
Specifies the time the event was logged to the Event Viewer.
Source
Specifies the feature that logged the event to the Event Viewer.
User
Specifies the user who performed the action that caused the event to be logged to the Event Viewer.
Description
Describes the event.
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Up Arrow
Changes the event displayed in the dialog box to the previous event in the event list.
Down Arrow
Changes the event displayed in the dialog box to the next event in the event list.

Copy to Clipboard
Copies the contents of the Event Properties dialog box so that it can be pasted into another application.
Related procedures:
■

The Event Viewer Vista (page 1817)

Filter Events Dialog Box
Use this dialog box to control the events that are listed in Event Viewer event list.
Event Types
Specifies the types of events to be included in the event list. Select the check box next to any or all of the
following event types:
■

Information

■

Warning

■

Error

Event Source
Displays only the events logged by the specified source. Select the name of a source in the list or click All
to display all events, regardless of their source.
User
Displays only the events associated with the specified user. Select the name of a user in the list or click
All.
NOTE You can see more than one user name in the event list if you open a log file that contained events that
were created by another user and you then perform actions that cause events to be logged using your login
name.

From Event
From list
Specifies the date and time of the first event displayed in the event list. In the list, select one of the
following:
■

First Event: Begins the display with the first event in the event list.

■

Events On: Begins the display with the first event in the list that falls on or after the specified date
and time.

From Date
When Events On is specified, specifies the date for the first event in the event list. Do one of the following:
■

Enter a date.
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■

Click the list arrow to display a calendar. Click Today at the bottom of the calendar to set the date to
the current date. Click the right and left arrows to specify a month. Click a day on the calendar to
specify a day.

From Time
When Events On is specified, specifies the time for the first event in the event list.

To Event
To list
Specifies the date and time of the last event displayed in the event list. In the list, select one of the
following:
■

Last Event: Ends the display with the last event in the event list.

■

Events On: Ends the display with the last event in the event list that falls on or before the specified
date and time.

To Date
When Events On is specified, specifies the date for the last event in the event list. Do one of the following:
■

Enter a date.

■

Click the list arrow to display a calendar. Click Today at the bottom of the calendar to set the date to
the current date. Click the right and left arrows to specify a month. Click a day on the calendar to
specify a day.

To Time
When Events On is specified, specifies the time for the last event in the event list.
Related procedures:
■

Customizing the Event Viewer (page 1817)

Find Event Dialog Box
Use this dialog box to locate a specific event in the Event Viewer event list.
Event Types
Specifies the types of event to search for. Select the check box next to any or all of the following event
types:
■

Information

■

Warning

■

Error

Event Source
Searches for events logged by the specified source. Select the name of a source in the list or click All.
User
Searches for events associated with the specified user. Select the name of a user in the list or click All.
Search Direction
Specifies the direction of the search, beginning with the selected event. Select Up or Down.
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Find Next
Selects an event in the event list that matches the specified criteria. Click to search for the next event that
matches the specified criteria.
Related procedures:
■

Finding a Specific Event in the Event Viewer (page 1821)

Choose Columns Dialog Box
Use this dialog box to control the columns that are displayed in the event list of the Event Viewer.
Hidden Columns
Displays a list of the columns currently not displayed in the event list.
Add
Adds a column to the event list. Select the column name in the Hidden Columns list and click Add.
Remove
Removes a column from the event list. Select the column name in the Displayed Columns list and click
Remove.
NOTE The Type column cannot be removed.
Displayed Columns
Displays a list of the columns that are currently displayed in the event list.
Related procedures:
■

Controlling the Columns Displayed in the Event Viewer (page 1817)

Multi-View Block Definition Properties Dialog Box
Use this dialog box to create new multi-view blocks and edit existing multi-view blocks in the current
drawing.
Multi-view Block Name
Displays the name of the multi-view block currently being edited or created. The list displays the names
of all multi-view blocks defined in the drawing.
Edit
Displays the Edit Multi-View Block Definition dialog box, which allows you to edit the name of a multi-view
block definition.
New
Displays the New Multi-View Block Definition dialog box, which allows you to specify a name for a new
multi-view block definition.
Multi-view Block Description
Specifies a description for the multi-view block.

Multi-view block components
2D View Blocks
When selected, the view blocks list displays the names of the blocks that are shown when the view direction
is a plan view.
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3D View Blocks
When selected, the view blocks list displays the names of the blocks that are shown when the view direction
is a 3D view (any direction other than plan).
Add
Displays the Blocks dialog box, which you can use to select blocks for the current multi-view block
definition. The selected blocks are added to the 2D view block list or 3D view block list depending on the
state of 2D view blocks and 3D view blocks buttons.
Remove
Removes the blocks selected in the view blocks list from the multi-view block definition. It is valid to
remove all blocks from the list box control. No confirmation dialog box is displayed when the remove
button is selected.

Multi-view block preview
2D View
Sets the preview pane to plan view, and performs a zoom to extents to display all of the 2D blocks that
define the multi-view block.
3D View
Sets the preview pane to a South-West isometric view, and performs a zoom to extents to display all of
the 3D blocks that define the multi-view block.
Preview Pane
Provides a preview of the current multi-view block definition.
Related procedures:
■

Understanding Multi-View Blocks (page 1822)

Multi-View Block Definition Properties Dialog Box
Use this dialog box to edit existing multi-view blocks in the current drawing.

General Tab (Multi-View Block Definition Properties Dialog Box)
Use this tab to edit the name and description of the multi-view block.
Name
Specifies the name of the block.
Description
Specifies the description of the block.
This Style May Act As a Boundary For Automatic Spaces
This setting is not used by AutoCAD Civil 3D.
Notes
Attaches notes (page 2749) to the block.
Floating Viewer
Displays a viewer dialog box where you can preview the appearance of the block.
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View Blocks Tab (Multi-View Block Definition Properties Dialog Box)
Use this tab to connect multi-view blocks to the view directions of individual display representations. To
ensure that the multi-view block is visible in all views, assign a block to every view direction.
Display Representations
Specifies which display representation will use the view block settings that you specify. Select General to
make assignments for plan views and Model for other model space views.
View Blocks
Specifies the block to use for each display representation. Click Add, and select a view block for the display
representation. With the block selected, specify the View Directions that correspond to the selected block
(see below).
View Directions
Specifies the view directions that correspond to the selected block. For example, to connect the view block
to the left side of the multi-view block definition, select Left and clear all other directions.
You can connect a view block to multiple view directions. For example, if you have a symmetrical element
that looks identical from left and right, you can select Left and Right.
The Other view direction represents a view that displays the block three-dimensionally. It is used for
non-orthogonal (isometric or perspective) views of the custom object.
To ensure that the multi-view block is visible in all views, assign a block to every view direction.
Set Interference Block
Specifies a cut body for the multi-view block when the block is used as interference in other objects.

Classifications Tab (Multi-View Block Definition Properties Dialog Box)
This tab is not used by AutoCAD Civil 3D.

Edit Multi-View Block Definition Dialog Box
Use this dialog box edit the name for an existing multi-view block definition.
Multi-view Block Name
Rename an existing multi-view block definition.
Related procedures:
■

Understanding Multi-View Blocks (page 1822)

New Multi-View Block Definition Dialog Box
Use this dialog box to enter the name for a new multi-view block definition.
Multi-view Block Name
Provide a name for a new multi-view block definition.
Related procedures:
■

Understanding Multi-View Blocks (page 1822)

Blocks Dialog Box
Use this dialog box to select blocks for the current multi-view block definition properties.
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Blocks
Displays the names of all blocks in the current drawing. Select the blocks to add to the multi-view block
definition. Multiple selection is supported.
Related procedures:
■

Understanding Multi-View Blocks (page 1822)

Inquiry Tool Dialog Box
Use the Inquiry Tool to run inquiries on AutoCAD Civil 3D objects.
Select An Inquiry Type
Specifies the inquiry to run. After you select an inquiry type, you are prompted to select the objects needed
to run the inquiry.
Inquiry results are displayed in the Results area.
After the prompts are complete, you can click
or
in the value rows to change any of the selections
you made. Some value rows also have lists you can use to change the selection.
For more information about the inquiry types, see Inquiry Types (page 1808).
NOTE To run Corridor queries, a corridor section view must be active. Click Corridor menu ➤ View/Edit
Corridor Section and then select the station. Use the Zoom command as needed to zoom closer to the view.
Copy To Clipboard
Copies the inquiry results to the clipboard so you can paste it into other applications, such as Microsoft©
Excel.
Copy To Text Screen
When selected, continually sends the inquiry data to the AutoCAD text window.

Coordinate Tracker Dialog Box
Use this dialog box to track and capture X, Y, and Z drawing coordinates. The precision of the displayed
value is determined by the coordinate precision drawing setting.

X, Y, Z
X:
Displays the X coordinate of the cursor location in the drawing.
Y:
Displays the Y coordinate of the cursor location in the drawing.
Z:
Displays the Z coordinate (elevation) of the cursor location in the drawing on the specified surface.
Continue Tracking
Resumes coordinate tracking after it has been suspended due to the entry of the coordinate capture keys.
Send XY
Sends the displayed X and Y values to the command line for use by the active command.
Send Z
Sends the displayed Z value to the command line for use by the active command.
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Send XYZ
Sends the displayed X, Y, and Z values to the command line for use by the active command.
For more information, see Sending Coordinate Tracker Values to the Current Command (page 1815).

Surface
Surface
Displays the name of the surface from which the elevation value is read. Select a surface from the list.
All surfaces in the active drawing are listed. If the drawing contains only one surface, that surface is
automatically used to calculate Z values.
Surface Selector
Selects a surface in the drawing.

Coordinate Capture Keys
Coordinate Capture Keys
Displays the keys that suspend coordinate tracking and capture the current coordinates. When the keys
are pressed and held down, one by one in the specified order until all keys are pressed, cursor tracking is
suspended and the X, Y, and Z values are captured at the current location of the cursor. You can then edit
the coordinate values.
Coordinate Capture Keys Selector
Changes the coordinate capture keys. Enter the new coordinate capture keys. For more information, see
Changing the Coordinate Tracker Coordinate Capture Keys (page 1816).
Related procedures:
■

The Coordinate Tracker (page 1813)

Export To SDF Dialog Box
Use this dialog box to save a AutoCAD Civil 3D drawing in Spatial Data Format (SDF). You can use an SDF
file in AutoCAD Map 3D and MapGuide Enterprise.
The AutoCAD Civil 3D alignment, point, parcel, and pipe network data is converted to AutoCAD objects
with attributes. For more information, see Exporting Civil Data to SDF Files (page 1862).
SDF File Name
Specifies the file name. Defaults to the last file name used.

Select Coordinate System
If the drawing already has a coordinate system specified, it is used automatically and these controls are not
available.
Categories
Specifies the geographic zone.
Available Coordinate Systems
Specifies the coordinate system within the selected zone category. If you do not select a zone category,
then the default (No Datum, No Projection) is enabled. If you select a zone category but do not select a
coordinate system, then, by default, the first entry in the list is selected.
Selected Coordinate System Code
Displays the coordinate system code.
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NOTE If you know the code of the coordinate system you want, you can enter it directly in the Selected
Coordinate System Code box. A period (.) in this box means no zone has been selected.
Description
Displays a description of the selected zone.
Projection
Displays the projection method for the coordinate system.
Datum
Displays the abbreviation for the datum on which the coordinate system is based.
Related procedures:
■

Exporting Civil Data to SDF Files (page 1862)

DWF Publishing Options Dialog Box
Use this dialog box to access AutoCAD Civil 3D-related settings for publishing 3D DWF data.
You can specify the objects to publish to the DWF file, how they are organized, and if the object properties
are included in the DWF file.

Object To Publish
All Model Space Objects
Specifies that all the objects in the drawing model space are published to the DWF file.
Selected Model Space Objects
Specifies that the selected objects in the drawing model space are published to the DWF file. Use the object
picker button to select objects from the drawing.

3D DWF Organization
Specifies how to organize the objects in the DWF file.
Group By Xref Hierarchy
Specifies that objects in the DWF are arranged by Xref hierarchy in the viewer. If unchecked, externally
referenced files are listed in the viewer like other objects.
Group Individual Objects By
Specifies how to group objects in the Model panel of the DWF Viewer. You can group them either by
object type and style, or by the layer that the objects reside on.

Options
Specifies additional DWF publishing options.
Publish With Materials
Specifies that the model will be exported with associated textures to various objects (for example, surfaces,
pipes, or AutoCAD solids).
If you’ve assigned texture mapped materials to your models, those materials can be published with the
3D DWF file. Texture map orientation and scaling that is set in the drawing editor is retained in the
published 3D DWF file.
There are some limitations to materials publishing.
■

The Diffuse Map channel is the only mapping that gets published. If you use Opacity, Reflection, or
Bump maps in your material, they do not get published.

■

Procedural materials such as Wood or Marble do not get published.
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NOTE Because the DWF Viewer and the rendering engine are different, you may encounter some deviation in
how the texture maps appear in the DWF Viewer.
Include Properties From Objects
Specifies that the object properties will be available in the DWF file. The properties vary from object to
object and include common properties such as Name, Description, Date Created, Created By, Date Modified,
Modified By, Object Style, Layer, and Color. Each object has special properties as well. For example, an
alignment includes start station, end station, and length.
Related procedures:
■

Exporting a Drawing to a 3D DWF File (page 1863)

Civil Batch Drawing Converter Dialog Box Reference
Use this dialog box to specify the settings for a batch conversion of multiple drawings to a different AutoCAD
drawing format.

Conversion Options
General
Units
Specifies the drawing units that are applied to the drawings in the Destination folder. The default is
Current.
NOTE To change only the drawing Units, specify the new Units Value and set the Drawing Save Format to
Current.
Filename Prefix
Adds the specified prefix to the filename after conversion. The default prefix is taken from the settings
on the AEC Editor tab. For more information, see Changing the AEC Editor Settings (page 1858). After
running a conversion, the default reflects the prefix that was last used.
Filename Suffix
Adds the specified suffix to the filename after conversion. The default suffix is taken from the settings on
the AEC Editor tab. For more information, see Changing the AEC Editor Settings (page 1858). After running
a conversion, the default reflects the suffix that was last used.

Format
Drawing Save Format
Specifies the file format that is applied to the drawings you convert. In the Value column, click the cell
and select one of the following formats:
■

Current (default)

■

Current DXF

■

AutoCAD 2007

■

AutoCAD 2004

■

AutoCAD 2000

■

AutoCAD R12 DXF

■

AutoCAD 2007 DXF

■

AutoCAD 2004 DXF
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■

AutoCAD 2000 DXF

Explode Objects
Select Yes (default) to explode Civil Objects to AutoCAD primitives. Select No to convert drawings in the
current format. After running a conversion, the default reflects the option that was last selected.
Bind Xrefs
Binds xrefs to the host drawing when using the Civil Batch Drawing Converter command, creating local
block definitions. Select Yes to have all xrefs and their dependent named objects become a part of the
exported drawing. The default settings reflect the settings in the AEC Editor tab in the Options dialog
box. The setting can be changed during the session, but once the dialog box is closed and re-opened the
setting defaults to the settings in the AEC Editor tab in the Options dialog box. For more information,
see Changing the AEC Editor Settings (page 1858).
Use Insert Method When Binding Xrefs
Selected: The drawing names of the xref drawings are discarded when the exported drawing is created.
In addition, the xref layers and styles are incorporated into the host drawing, and layers with the same
name acquire the properties of the layers of the host drawing.
This option binds the xref to the current drawing in a way similar to detaching and inserting the reference
drawing. Rather than being renamed using blockname$n$definitionname syntax, xref-dependent named
objects are stripped of the xref name. As with inserting drawings, no name-incrementing occurs if a local
named object shares the same name as a bound xref-dependent named object. The bound xref-dependent
named object assumes the properties of the locally defined named object. For example, if you have an
xref named FLOOR1 containing a layer named WALL, after binding with the Insert option, the
xref-dependent layer FLOOR1|WALL becomes the locally defined layer WALL.
Cleared: The xref identities, such as layer names, are retained when you export a file to AutoCAD.
By clearing this check box, xref-dependent named objects are changed from blockname|definitionname
to blockname$n$definitionname syntax. In this manner, unique named objects are created for all
xref-dependent definition tables bound to the current drawing.
For example, if you have an xref named FLOOR1 containing a layer named WALL, after binding the xref,
the xref-dependent layer FLOOR1|WALL becomes a locally defined layer named FLOOR1$0$WALL. The
number $n$ is automatically incremented if a local named object with the same name already exists. In
this example, if FLOOR1$0$WALL already existed in the drawing, the xref-dependent layer FLOOR1|WALL
would be renamed FLOOR1$1$WALL.

File Selection
Source Folder
Specifies the location of the folder that contains the files you want to convert.
Look In Subfolder
Select the check box to include files in subfolders as part of the search parameter.
Search For Files Named
Specifies the search parameters for the file type or file name. Select a file type from the list, or enter a file
type or file name in the box. To search for multiple file types you can enter a comma delimited list. You
can also use an asterisk as a wildcard, for example auto*.dwg.
Destination Folder
Specifies the location of the folder to store the converted files.

Selected Files
Drawing File column
Displays the selected filename(s) of the drawing file(s) you want to convert.
Location column
Displays the filepath of the selected drawing file(s).

2764 | Chapter 80 Utilities Dialog Boxes

Select All button
Selects all the files in the Drawing File list.
Clear All button
Clears the check boxes on all files in the Drawing File list.
Related procedures:
■

Converting Multiple Drawings to a New Format or Changing Units (page 1859)

Sight Distance Check Wizard
Use this wizard to calculate sight distances along a roadway and to ensure that the design meets minimum
requirements.
See also:
■

Calculating Sight Distance Along a Corridor (page 1846)

General Page (Sight Distance Check Wizard)
Select The Path Along Which You Want To Check
■

Use Alignment And Profile: Select the alignment and the profile from the lists, or click
them in the drawing. Enter the From Station and To Station, or click

■

to select

to pick in the drawing.

Use Feature Line Or 3D Polyline: Click Select From Drawing. Enter the From Point and To Point, or
click

to select them in the drawing.

Check Interval
Specify a value or click

to pick in the drawing.

Select Surfaces To Check Against
Select a surface to perform the check against and click
to add it to the list. The surfaces are listed in
the order of priority. If there are multiple surfaces at a given location, then the check is done against the
surface with the highest priority. You can change the priority by clicking the

and

arrows.

Sight Distance Page (Sight Distance Check Wizard)
Minimum Sight Distance
Specify the minimum sight distance or click

to select it in the drawing.

Eye Height
Specify a value for the height of the driver’s eye, or click

to select it from the drawing.

Eye Offset
Specify an of offset value for the driver’s eye, or click

to select it from the drawing.
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Target Height
Specify the height of the target object, or click

to select it in the drawing.

Target Offset
Specify the offset of the target object, or click

to select it in the drawing.

Results Page (Sight Distance Check Wizard)
Select The Items You Want To Draw In The Model
Click the check box next to the components you want to be drawn in the model. Hover your cursor over
a component to see a preview.
Select Hatch Display For Obstructed Areas
Click

to select a color for hatch display for the obstructed areas.

Create Sight Analysis Report
Click the check box to create a report.
Choose A File Type
Specify one of the following report style sheets:
■

ReportCSV

■

ReportHTML

■

ReportTXT

■

ReportXML

Save To
Specify the location to save the report.
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Glossary

This glossary contains terms relevant to AutoCAD Civil 3D. Please see the AutoCAD glossaryfor additional
platform terms.
2D polyline A polyline with all vertices at the same elevation.
3D face A 3D face is an AutoCAD object that represents the surface of a 3- or 4-sided area, with each vertex
potentially at a different elevation. You can view TINs (Triangulated Irregular Networks) as 3D faces. Using
the SHADE command, you can shade 3D faces. Using the RENDER command, you can render the 3D faces.
See also TIN (page 2785).
3D polyline A polyline with vertices at varying elevations.
A Grade Change.
A.A.S.H.T.O. American Association of State, Highway, and Transportation Officials.
acre A measure of land: 160 square rods; 4,840 square yards; 43,560 square feet.
adjustment A process that removes inconsistencies from the mathematical model of measured observations
such as angles and distances.
alignment A series of 2D coordinates (northings and eastings), connected by lines, curves, or spirals, used
to represent features such as the road centerlines, edges of pavement, sidewalks, or rights-of-way.
angle The difference in direction between two convergent lines measured in the units of degrees, radians,
or grads.
area The quantity of plane space in a horizontal plane enclosed by the boundary of any polygonal figure.
assembly An AutoCAD Civil 3D drawing object (AECCAssembly) that manages a collection of subassembly
components, such as travel lanes, curbs, shoulders, and ditches, to form the structural elements of a roadway
or other corridor-type structure.
assembly set The set of assemblies that are specified (referenced) by an assembly set file, used during
intersection object creation (intersection design).
astronomic azimuth An azimuth derived from sunshots or starshots.
azimuth A clockwise angle measured from a reference meridian. Also known as north azimuth. It can range
from 0 to 360 degrees. A negative azimuth is converted to a clockwise value.
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north meridian

foresight point

north azimuth

south azimuth

setup point

foresight point
south meridian

backsight A previously established point used as a direction reference to another point. A survey instrument
movements typically are locked to an angle of 0 degrees, and the vertical crosshair is set on the backsight.
All subsequent shots are then taken by turning the instrument and the upper movement together, while
the lower movement stays set on the backsight. All angles measured are, therefore, relative to the backsight.
balance line The line in a mass haul diagram at which cut and fill balance. See also mass haul line (page
2778).
balance point The point at which the mass haul line crosses the balance line (the station at which the cut
volume and fill volume are equal). See also balance line (page 2768), mass haul line (page 2778).
base surface An existing ground or undeveloped terrain. Specified when creating volume surfaces. See also
comparison surface (page 2770).
baseline See footprint (page 2774).
BC:L Curve Beginning.
bearing An angle measured from North or South, whichever is nearest, with the added designation of East
or West. The angle is always less than 90 degrees (PI/2 radians or 100 grads) and is referenced by a quadrant
number.
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north west bearing quadrant NW-4

north meridian
north east bearing quadrant NE-1

foresight point
foresight point

setup point

foresight point
foresight point

south meridian
south west bearing quadrant SW-3

south east bearing quadrant SE-2

BFS Begin Full Super.
BNC Begin Normal Crown.
BNS Begin Normal Shoulder.
BOA Begin of Alignment.
border The visible limits of a surface. The border can be defined from a boundary or can be the result of a
defined boundary and operations performed on a surface, such as a Delete Line operation (a hole is created
in the surface). If a boundary is not defined on a surface, the exterior border is always defined as the extents
of the surface triangulation.
borrow pit A pit that is created at a station along an alignment, to provide material to be used as fill in a
mass haul diagram. See also dump site (page 2773).
boundaries Three kinds of closed polylines that limit the display area of the digital terrain model. Most
common are outer surface boundaries constructed just outside the extremities of the dataset, eliminating
unwanted interpolations across empty space where the surface has a concave shape. The following two types
of internal surface boundaries are also used: hide boundaries, to punch holes in a surface (for example, a
building footprint), or show boundaries, to create smaller surfaces by eliminating areas that fall outside the
boundary.
bounded volume A method of calculating volumes using an existing AutoCAD object (for example, a
polyline or polygon) to calculate the cut, fill, and net volume for the area bounded by the object.
BP Alignment Beginning.
BP:STA Alignment Beginning Point.
BREAK Grade break.
breakline A line used to connect the data representing a distinct surface feature, like a ridge line, edge of
pavement, toe of a slope, centerline of a road, or flowline of a ditch or stream. When a breakline is defined,
the surface triangulation must first follow the breakline, by placing triangle edges coincident with the
breakline segments. This ensures the feature in the model is accurately depicted. Then, the rest of the
interpolation is performed based on proximity. Breaklines are typically critical to creating an accurate surface
model. It is the interpolation of the data, not just the data itself, that determines the shape of the model.
See also non-destructive breakline (page 2778).
breakline point A point that is included in the defined breakline’s list of vertices.
BVC Vertical Tangent-Curve Intersect.
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BVCE Vertical Tangent-Curve Intersect Elevation.
BVCS Vertical Tangent-Curve Intersect Station.
BVP Profile Start.
ByBlock A setting specifying that a component of an object inherits the color or linetype associated with
the object, or block, that contains it.
ByLayer A setting specifying that an object or component of an object inherits the color or linetype associated
with the assigned layer.
bypass target A part in a pipe network that has been identified by the user to act as the target for any bypass
flows to be directed to.
catchment area The area tributary to a lake, stream, or drainage system.
center marker A diamond-shaped graphic that marks the location of the centroid of a grading object.
Right-click the center marker to access the Grading shortcut menu.
chord A straight line connecting two points on a curve: the Point of Curvature (PC) and Point of Tangency
(PT). The curve joins with a line or another curve at these points.
closure The relative position of a traverse station as it compares to the same station position determined by
a different set of observations or route of survey.
clothoid spiral A spiral in which the curvature is a linear function of the length of the spiral, so that the
degree of curvature is zero when it meets the tangent and then increases to match the curvature of the
adjacent curve. See also compound spiral, simple spiral.
COGO Coordinate Geometry.
COGO points The point objects that you create using the point-creation or point-import. COGO points are
referred to simply as “points” in this documentation. The pieces of data associated with a point, such as
point number, northing, and easting, are referred to as properties. See also properties (page 2781).
collimation The process of adjusting the line of sight or lens of an optical instrument so that it is properly
located based on the other parts of the instrument.
comparison surface A proposed or existing terrain surface used in the creation of volume surfaces. See also
base surface (page 2768), volume surface (page 2787).
Compass rule Corrections corresponding to the closing errors that assumes the closing errors are as much
due to of errors in observed angles as errors in measured distances. Use the compass rule option when this
is the case.
composite volumes A method of calculating volumes using top and bottom surfaces (a surface pair) to
establish cut, fill, and net volume values.
compound curve A curve consisting of two or more arcs of different radii curving in the same direction,
and having a common tangent or transition curve at their point of junction.
compound spiral A spiral that provides a smooth transition between two adjoining curves of different radii
but in the same direction. It has a finite radius at each end. See also clothoid spiral (page 2770).
confidence interval In statistics, a region or area that has a known probability of containing a random
sample. In surveying, a 95% confidence interval indicates that the surveyor can be 95% sure that a point or
observation lies within the region or established parameters.
construction geometry Unconnected portions of parcel and alignment geometry. For example, if you use
the tan-tan method and create a number of connected lines, the whole feature is solved and the display
characteristics are controlled by the object style. If you create some connected lines and then add a line that
is not connected, the result is a piece of ‘construction’ geometry.
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contour A line that connects points of the same elevation or value relative to a specified reference datum.
control point Points with a unique identifier that are created at a known location (northing, easting, or
latitude, longitude, with an optional elevation or description) and are not affected by adjustments or
corrections. Control points are added to a survey database and are managed within a named survey network.
control region A region that is defined by applying grading criteria to a footprint. A footprint can have a
single region along its entire length, or it can be subdivided into a number of control, transition, and void
regions. See also footprint (page 2774).
coordinates Values that specify exactly where a point is in space in terms of three planes: X, Y, and Z (easting,
northing, and elevation).
corridor Any path, the length and location of which are typically governed by one or more horizontal and
vertical alignments. Examples are roadways, railways, traveled ways, channels, ditches, utility runs, and
airport runways.
corridor feature line A component of a corridor object. Created by joining subassembly point codes from
one station to another.
corridor surface A component of a corridor object. Surface triangulation is created from a corridor
subassembly point and link codes.
Crandall rule A method of balancing a traverse in which all the angular error is distributed throughout the
traverse and all adjustments to the traverse result from modifying the traverse distances. The modification
distance made to each leg is such that the sum of the squares is a minimum.
Corrections correspond to the closing errors, which assumes the closing errors are random and normally
distributed. It assumes all the angular error has been adjusted before the adjustment routine.
crest curve In a profile, a vertical curve on the crest of a hill or similar location where the grade leading into
the curve is greater than the grade leading out of the curve. In a crest curve, the point of vertical intersection
(PVI) for the tangents is above the curve. See also sag curve (page 2782).
criteria-based design The process of associating agency-specific standards to an alignment or profile. Agency
standards, which are typically based on superelevation and design speed requirements, are contained in a
customizable design criteria file.
The file can also specify design standards for automatically adding widening to dynamic offset alignments.
When an alignment or profile object is created, standards from the design criteria file can be associated with
the alignment or profile to ensure that the horizontal and vertical curves comply with the minimum
standards. User-defined design checks can be used to identify and report standards violations. See also design
criteria file (page 2773).
cross section See section (page 2782).
CS Curve-Spiral Intersect. See curve to spiral (page 2771).
CS_LRB:L Compound Spiral Large Radius at Beginning.
CS_LRE:STA Compound Spiral Large Radius at End.
CS_SRB:L Compound Spiral Small Radius at Beginning.
CS_SRE:STA Compound Spiral Small Radius at End.
curb return alignment An alignment that connects the edges of two intersecting roadways. The most
common curb return geometry is a simple circular fillet. In a typical intersection, curb return alignments
are placed in each of the four quadrants, between edges of pavement.
curve to spiral A point on a horizontal alignment where a curve meets a spiral.
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cut slope The slope created when the footprint falls below the existing ground line. The resulting slope
matching up into the existing ground is called a cut slope because the existing ground must be cut (removed)
during construction.
data band A graphic frame that is associated with a profile view object or section view object. The data band
contains annotations for the profile or section view, as well as for the parent horizontal alignment. Some
common annotations include elevation data, stations, and cut/fill depths.
data collector A device surveyors use to automatically record the observation data they collect in the field.
They then download and convert the raw survey data to a field book file, which is written in the Survey
Command Language format, or a LandXML file, which uses the LandXML schema to describe the Survey
data. Surveyors can then import this file to create points in the database and figures in the drawing.
data reference A read-only copy of an object from another drawing. The referenced object can be used in
multiple drawings and stylized locally. After the official copy of the object is updated, drawings with references
to it are notified of the opportunity to update their local copy. There are two data reference types used in
AutoCAD Civil 3D: data shortcuts and Vault references. Both types can reference surfaces, alignments,
profiles, pipe networks, and view frame groups.
data shortcut An object that can create a data reference between drawings in a project. Data shortcuts are
not used with Vault projects.
datum A reference value. All elevations or coordinates are set relative to this value. In surveying, you can
use two datums (horizontal and vertical).
For global coordinate systems, a datum refers to the ellipsoid information and the techniques used to
determine positions on the Earth’s surface. An ellipsoid is part of a datum definition.
daylight line A line showing the line of zero cut or fill within the job area. For grading objects, it represents
the target line produced by grading to a specified surface, distance, or elevation.
decimal degree The measure of an angle in decimal units. For example, 3°30'36" equals 3.51 decimal degrees.
Decreasing Station Equation Decreasing.
definition list A list that contains all the operations performed on a surface. By turning the items in the
list on and off, you can modify the surface, return it to a previous state, and so on.
deflection angle A horizontal angle measured from an extension of the preceding line, right or left.
degrees, minutes, seconds (DMS) A representation of an angle in degrees, minutes, and seconds in which
a full circle contains 360 degrees, each degree 60 minutes, and each minute 60 seconds. A typical bearing
in DMS measurement looks like: N45°45'58"E. Using this format, 3°30'36" is entered as 3.3036.
Delaunay triangulation A calculation method used in the creation of TIN networks. Given a set of data
points, Delaunay triangulation produces a set of lines connecting each point to its natural neighbors.
DEM (Digital Elevation Model) An array of elevations taken on a regularly spaced horizontal grid.
description keys A method of translating descriptions to help standardize point data when a variety of data
sources are used. For example, descriptions of EROAD, EPAVE, ERD, and EDGEROAD can all be translated
to a description of EOP. The layer, point style, and point label style options can greatly enhance automatic
base plan generation and the overall organization of the drawing.
design check A user-defined expression used to verify that an entity meets the minimum design standards
that were established for the alignment or profile object. Design checks may be defined for different entity
types, such as lines, curves, and spirals. A design check must be saved in a design check set to be applied to
an alignment or profile. See also design check set (page 2772).
design check set A user-defined collection of commonly used design checks. You specify a design check set
either during alignment or profile creation, or after creation using the object properties dialog box. See also
design check (page 2772).
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design criteria file A file that contains minimum design standards for alignment and profile objects. The
design criteria file may be customized to support local design standards for design speed, superelevation,
and minimum speed, radius, and length of individual entities. See also criteria-based design (page 2771).
design rule A set of automatic constraints for some objects in the drawing that are enforced by applying a
specific style. For example, if you are laying out alignments, you can specify a rule for a curve radius.
drawing objects Objects that exist in a single drawing. See also project objects (page 2780).
dump site A site that is created at a station along an alignment, at which cut material removed from a mass
haul diagram is dumped. See also borrow pit (page 2769).
easting A linear distance eastwards from the North-South line which passes through the origin of a grid.
Equivalent to the X coordinate in an XYZ coordinate system.
EC:STA Curve End.
EDM Electronic distance measuring devices that measure the round-trip transit time of a pulsed signal from
which distance is computed.
EDM Offset The vertical distance from the scope center to the EDM center. AutoCAD Civil 3D uses this
value to calculate distance.
EFS End Full Super.
EGL Energy Grade Line.
elevation The vertical distance from a datum to a point or object on the Earth's surface. The datum is
considered to be at sea level. Equivalent to the Z coordinate in an XYZ coordinate system.
elevation point A point that marks an elevation change but does not break the horizontal geometry.
ENC End Normal Crown.
energy grade line A line in a pipe network or storm sewer drainage system that represents the total available
energy in the system (potential energy, or static head, plus kinetic energy, or velocity head).
ENS End Normal Shoulder.
enumeration A type of user-defined property which has pre-defined values that you can select from a list.
EOA End of Alignment.
EP Alignment End.
EP:STA Alignment End Point.
error ellipse An elliptical region that shows the confidence interval of an adjusted point. For example, if
the confidence is set to 99 %, you can be 99 % sure the calculated ellipse contains the true location of the
point.
EVC Vertical Curve-Tangent Intersect.
EVCE Vertical Curve-Tangent Intersect Elevation.
EVCS Vertical Curve-Tangent Intersect Station.
EVP Profile End.
face A three-dimensional surface triangle. A face is represented by either a 3D face object or 3D line objects.
face 1 An angle measurement in which the scope is not flopped. Also called direct.
face 2 An angle measurement in which the scope is flopped. Also called inverse or indirect.
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feature line An object in that the grading commands can recognize and use as a footprint. Usually, a line
that marks some important feature in the drawing, such as a ridge line, or the bottom of a swale. See also
footprint (page 2774).
field book The permanent detailed record a surveyor makes of all observations made in the field. In AutoCAD
Civil 3D, a field book file, (*.fbk), it can be used as a source of survey data.
field code Syntax that corresponds to a predefined convention in a surveying application. Field codes are
assigned to each survey point to automate the assignment of point and line properties and to determine the
linework connectivity.
Field to Finish A process of determining the line and curve connectivity between points surveyed in the
field that have the same feature name within a point code. This process also assigns symbols to point features
based on a feature name within a point code.
figure Special linework automatically created in a drawing when you import a field book containing figure
data. Also created when using AutoCAD Civil 3D survey figure commands. You can control the layers for
figures by using figure prefixes.
figure prefix Used to automatically place figures on user-defined layers based on the beginning part of the
figure name. For example, the figure prefix EP can be used to place the figures EP, EP1, EP2, and EPL all on
the same layer. Using figure prefixes in conjunction with description keys can largely automate the process
of constructing a well organized base plan.
fill slope The slope created when the footprint falls above the existing ground line. The resulting slope
matching down into the existing ground is called a fill slope because material must be brought in to fill the
area during construction.
fixed entity An alignment entity with a fixed position, not necessarily tangent to another entity for the
definition of its geometry. See also floating entity (page 2774), free entity (page 2774).
floating entity An alignment entity that is tangent to one other entity (before or after) for the definition
of its geometry. See also fixed entity (page 2774), free entity (page 2774).
flow rate A hydraulic property, often used in desigining storm sewer and other systems, that represents the
volume of fluid over time that flows through a system.
footprint The object to which grading criteria are applied. A footprint can be an open or closed 2D or 3D
geometric figure that is a feature line, parcel line, or survey figure. See also feature line (page 2774).
footprint vertices The endpoints that define the segments of a footprint with an XYZ location and stationing
starting at the first vertex.
foresight A point to which an instrument sighting is made to measure or establish its elevation or horizontal
position.
free entity An entity that is tangent to two other entities (before and after) for the definition of its geometry.
See also fixed entity (page 2774), floating entity (page 2774).
free haul The material moved within a certain defined distance of its point of excavation (the free haul
distance), free of charge by the contractor. See also mass haul (page 2778), overhaul (page 2779).
front yard The offset distance from the parcel frontage segments to the setback line.
frontage The parcel segments that are adjacent to a right-of-way. The frontage is also considered to be the
parcel segments located at the front of the parcel.
frontage offset A user-defined length used to offset the current frontage definition to the inside of the parcel
being subdivided. When the frontage offset is used, the minimum frontage length is applied at and along
the frontage offset instead of the frontage.
full description The expanded description of a point after description key matching has taken place.
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geodesic On a surface, the shortest line between two points, either a line or curve from one point along an
ellipsoid to another.
geodetic A basic relationship to the Earth that takes into account the curvature of the Earth’s sea level
surface. For example, a geodetic distance is a distance or angle in which the Earth's curvature is taken into
account, versus a distance or angle measured on a flat paper map.
grade A method of reporting ground inclination in which the change in elevation is expressed as a percentage
of the horizontal distance travelled. For example, if the ground rises one linear unit (meter or foot) over a
horizontal distance of five units, the grade is 20%. See also slope (page 2782).
grade line See layout profile (page 2776).
grade point A point in a mass haul diagram at which mass haul transitions from cut to fill. When free haul
is measured from grade points, the highest point (or lowest, if below the balance line) is the grade point.
See also balance line (page 2768), mass haul line (page 2778).
grading The process used to model the finished ground surface.
grading criteria Parameters such as target and projection method for the grading.
grading face The area bounded by the footprint, the daylight line, and the two projection lines.
grading group A collection that ties grading objects together for the purposes of surface creation and volume
calculation.
grading target The grading target defines what the projection lines from the footprint will intercept. The
three choices for targets are: surface, relative or absolute elevation, and distance. See also daylight line (page
2772).
grads A system of angle measurement in which one grad equals 1/100 of a 90° angle, or 360° = 400 grads.
grid A system of lines parallel to a given set of axes at a specific spacing. Grids are used to visualize surfaces
and calculate volumes. A grid is also used for geodetic purposes.
grid distance The distance between two points based on a coordinate zone, not on local northing and
easting coordinates.
grid easting The easting coordinate that is based on a selected coordinate zone, as opposed to the local
easting, which is based on the surveyor’s base point. See also local easting (page 2777).
grid northing The northing coordinate that is based on a selected coordinate zone, as opposed to the local
northing, which is based on the surveyor's base point. See also local northing (page 2777).
grid surface A type of surface created from a DEM or SDTS file, or imported from a LandXML file. A grid
surface consists of a sampled array of elevations for a number of ground positions at regularly spaced intervals.
grid volume surface A differential grid surface based on user-specified base and comparison surfaces. The
grid method of volume calculation measures the difference in elevation between two surfaces at each
intersection in a user-defined grid.
grip A moveable point on an object that you can drag to edit the object dynamically.
handle The unique identifier of a drawing object, used as a reference within the software. Users normally
do not need to know about handles unless they are using the Data Shortcuts Editor.
hectare A measure of area, generally relating to land, of 10,000 square meters or approximately 2.47 acres.
HGL Hydraulic Grade Line.
High-definition surveying (HDS) 3D laser scanning typically associated with terrestrial based laser scanners.
The terms “High-Definition” and “HDS” are trademarks of Leica Geosystems.
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horizon An axis that the scope of a theodolite or transit rotates about when moved vertically. The axis of
rotation perpendicular to the vertical axis.
HP High Point.
hydraulic grade line A line in a pipe network or storm sewer drainage system that represents the elevation
head and pressure head of fluid at any point along a system.
import event A named collection in a survey database that provides a context to the specific data that was
imported using any of the Survey Import commands, such as the Import Survey LandXML command, or
the Import Survey Data wizard.
Increasing Station Equation Increasing.
incurve A spiral with a curve radius that decreases along the route of the defined direction.
interference checking A AutoCAD Civil 3D feature available with pipe networks that lets you identify pipe
network parts (pipes and or structures) that physically overlap each other, or are too close to one another
based on predefined proximity criteria.
intersection The point where two or more lines, arcs, figures, or objects join or cross in two- or
three-dimensional space.
inverse An inverse calculation on a closed figure calculates the bearings and distances between coordinates
and reports the area. Because you use exact numbers (coordinates) to determine corners, no closure error is
reported.
junction loss Or junction loss coefficient. A hydraulic property value used in storm sewer drainage systems
that can be computed and defined in a pipe network. It is associated with the loss of energy through a
junction. This numeric value has no units associated with it, and can be automatically calculated or manually
entered using the Hydraflow Storm Sewers extension application. It is used to compute minor loss for
hydraulic analysis.
K Curve Coefficient.
known capacity A numeric value that represents the flow in a pipe network or storm sewer drainage system
as designated by the user.
Kriging A method of surface smoothing that uses known values and a semivariogram to determine unknown
values. Based on the semivariogram used, optimal weights are assigned to known values to calculate unknown
ones. Since the variogram changes with distance, the weights depend on the known sample distribution.
L Left.
label component Text, a block, direction arrow, line, or tick that is used to construct a label style. Label
styles can be made up of multiple label components.
label set A collection of label definitions for multiple label types, such as station labels and geometry point
labels. For example, alignment station labeling can be composed of major station labels, minor station labels,
and geometry point labels.
latitude The angular distance measured on a meridian north or south from the equator.
layout profile A profile object that represents the finished ground elevations along a horizontal alignment
or other linear feature that supports profile views. Typically, this data is designed, not derived from a
pre-existing source, and consists of a series of vertical tangents connected by vertical curves located at each
point of vertical intersection (PVI). This profile is also known as vertical alignment, profile grade line, grade
line, and finished grade profile.
layout toolbar A floating, dockable toolbar that groups object-specific design and editing tools.
LB:L Line Beginning.
LC Level Crown.
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LE:STA Line End.
least squares A method of balancing a traverse in which the squares of the differences between the unadjusted
and adjusted measurements (angles and distances) are summed and reduced to a minimum. This method
uses the error specifications in the current equipment settings to determine the expected source of errors,
and weights the individual measurements accordingly.
length weighted distribution A vertical adjustment that distributes the vertical closing error to each line,
at the same ratio as the length of that line is to the total length of the traverse (similar to the Compass rule).
LIDAR Light Detection and Ranging. Typically associated with airborne laser scanning.
linework code set A file that dictates the syntax of linework connectivity commands that are specified
within a field code. A feature that is an edge of pavement may be abbreviated as EP or EOP in the field code
but the set of abbreviations are part of the field coding standard established by a company. The linework
code accompanies the feature name within the field code, for example "EP B", where "EP" is the feature name,
and "B" is the linework code to begin a survey figure.
link codes A set of standard codes that define the display and behavior of links used in subassemblies.
local copy A copy of a project drawing that resides in your local folder, as opposed to the master copy of
the file in the project Vault database. Also refers to a copy of a project point that exists in a local drawing.
local easting The easting coordinate that is based on the surveyor's assumed horizontal base point, as
opposed to the grid easting, which is based on the global coordinate zone. See also grid easting (page 2775).
local elevation The elevation coordinate based on the surveyor's assumed vertical base point, or benchmark,
versus a real world elevation value.
local northing The northing coordinate that is based on the surveyor's assumed horizontal base point, as
opposed to the grid northing, which is based on the global coordinate zone. See also grid northing (page
2775).
locked point A drawing point whose coordinate data cannot be modified. Point locking applies only to the
drawing in which the point resides. See also protected point (page 2781).
logical name mapping The process of mapping logical names in subassemblies to actual AutoCAD Civil
3D object names.
longitude The angle between the plane of a given meridian and the plane of the Greenwich meridian.
LP Low Point.
LSM Low Shoulder Match.
MAN Manual.
map check A map check reports how accurate your angle observations are, and the area of closed figures.
You can perform a map check on an open or closed figure that was drawn by using angles. Because the
accuracy of the figure is based on the precision of your angle measurements, an amount of closure error is
associated with such a figure. The greater the precision you use, the less error there will be. In contrast, if
you draw a figure between known coordinates, then there is no need to perform a map check, because there
will be no error.
A map check reports precision and mathematical closure based either on bearing and distance entries of a
closed figure, or for an open figure between two known points. The accuracy of a map check is based on the
precision used to calculate it. For example, if you use data that is rounded to the nearest foot, then the results
are less accurate than if you use data rounded to the nearest one-hundredth of a foot.
masking A process of obscuring objects so that text can be placed over them in a clear area. Masking
maintains legible text without destroying the objects underneath.
masks Polygons used to mask the visible portions of a surface.
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mass haul The volume of excavated material times the distance it is required to be moved. A mass haul
diagram presents a visual representation of the cumulative cut and fill material volumes on a project. Mass
haul diagrams (along with grading summaries) are the contractor’s primary tools for bidding earthwork. See
also free haul (page 2774), overhaul (page 2779).
mass haul line A line marking the balance between cut and fill in a mass haul diagram. When the mass
haul line is above a balance line, it indicates material to be cut. When the mass haul line is below the balance
line, it indicates a volume to be filled. See also balance line (page 2768), mass haul (page 2778).
match line See daylight line (page 2772).
mid-ordinate On a circular arc, the distance from the midpoint of a chord to the midpoint of the subtended
arc.
modifier A formula for formatting property field values, such as decimal precision for an area. You can use
predefined modifiers, such as acres, feet, and meters, or you can define a custom modifier. See also property
fields (page 2781).
nadir angle The nadir angle is opposite the zenith.
zenith

horizon

foresight point

foresight point
setup point

plumb line

nadir vertical angle

nadir

name template A default name format that can be incremented for each new object of that type.
Natural Neighbor Interpolation (NNI) A method of surface smoothing supported on TIN surfaces. NNI
uses Delaunay triangulation to determine the elevation of an arbitrary point based on the elevations of
known neighbor points.
network A series of interconnected lines that represent the observed instrument setups.
next counter The next available number in a series. Used in a name template (page 2778).
non-control point Points that are created with a unique identifier, northing, easting (or Latitude, Longitude),
and optional elevation and description. A non-control point represents a point whose location is determined
from a reduced coordinate (N,E,Z) observation, such as point created by the NE SS survey command. A
non-control point is not connected to other survey observations and remains unaffected by a network
analysis, but still resides within the context of a survey network. Non-control points are added to the survey
database and are managed with a named survey network. Non-control points can be promoted to control
points if you reference the point as a control point for creating a traverse, or reference the point as a setup
to make observations to other points that can affect locations during an analysis.
non-destructive breakline A breakline that is not crossed by triangulation lines in a TIN. Instead, new
vertices are added to the breakline at the intersection of each TIN line and the breakline. The new points
create additional surface triangles. This is useful when you do not want the elevation of a surface to be
interpolated inside an area that you know to be a constant elevation.
northing A linear distance northwards from the East-West line which passes through the origin of a grid.
Equivalent to the Y coordinate in an XYZ coordinate system.
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note reduction The process of taking field measurements and converting them from 3-dimensional to
2-dimensional in order to use the measurements in a plan view of the drawing. For example, note reduction
includes the process of converting vertical distances to horizontal distances.
null assembly A placeholder assembly that is used during intersection object creation, when a referenced
assembly cannot be found. A null assembly generally contains no subassemblies other than a marked point.
See also assembly set (page 2767).
object In AutoCAD Civil 3D, an element in a drawing, for example, a surface, that can maintain a relationship
with other objects.
object model The underlying system of links and dependencies between objects. In the object model,
changes in one object can be passed on automatically to all the objects associated with it.
occupied point A point in a traverse loop where the survey instrument is set up and observations are
recorded.
offset alignment A dynamic alignment created at an offset distance from another alignment, such as a road
edge offset from a centerline alignment. The offset alignment geometry cannot be edited directly, but it
responds dynamically to edits of the parent alignment.
outcurve A spiral with a curve radius that increases along the route of the defined direction.
overhaul The excavated material that must be hauled beyond the free haul distance. See also free haul (page
2774), mass haul (page 2778).
override A value for a setting that replaces the value already set at the next higher level.
Panorama A window that displays data in table form for the objects in a collection that is selected in
Toolspace. For example, if you select a point group, the Panorama table displays a row for each point.
parcel A discrete piece of 2D area. For example, a subdivision is composed of numerous parcels. Synonymous
with lot.
parcel node A point where two or more parcel segment ends join.
parcel segment A parcel boundary element, a line, or a curve.
Part Builder A parametric modeling tool used to create and modify the set of pipe network parts (pipe and
structure shapes) that are available in pipe network part catalogs.
part catalog An xml file that contains definitions for the three-dimensional, parametric shapes of pipe and
structure objects used in pipe networks.
parts list A set of references to pipe network parts (pipes and structures) whose shapes are defined in a catalog
called the part catalog.
pass-through point A point on the path of a line or curve, often used to define an alignment. A pass-through
point on a curve can be used as a grip to control the position of the curve. However the alignment is edited,
its geometry has to go through the pass-through point.
passing sight distance The distance measured to a point where an approaching vehicle comes into view
ahead of a driver on an undivided road. This is used to calculate vertical crest curves.
pay item A specific unit of work for which a price is provided and paid to a contractor while a project is
under construction.
pay item list A master list provided by the contracting authority, listing pay item numbers, item specifications,
and item units of measure.
PC Tangent-Curve Intersect. See point of curvature (page 2780).
PCC Compound Curve-Curve Intersect.
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PI Tangent-Tangent Intersect. See point of intersection (page 2780).
pipe network A pipe network object manages a collection of pipe objects and structure objects that are
used to represent a pipe network in a drawing.
pipe object A type of object used to visually represent a pipe in a pipe network, such as a circular, rectangular,
or egg-shaped pipe.
plan readable Text that you can read easily in a normal plan view, that is, placed at an angle less than 270
degrees and more than 90 degrees. Also called right-reading.
plan view The view of a site if you look straight down from an elevated position.
point codes A set of standard codes that define the display and behavior of points used in subassemblies.
point group Collection used to group the points in a drawing into smaller, more manageable units. For
example, you can create a point group that contains all of the points in a drawing that meet certain elevation
criteria.
point list The list of the points that belong to a point group.
point marker See point symbol (page 2780).
point of curvature (PC) The point where an arc is drawn from a tangent.
point of intersection (PI) The point where two tangents meet on a horizontal alignment. Curves and spirals
also have points of intersection, which indicate where the tangents would meet if they were extended
outward.
point of tangency (PT) The point where a curve meets a tangent.
point of vertical intersection (PVI) In a profile, the point where two tangent lines meet.
point symbol A point location marker. When you add points to a drawing, point symbols are created to
represent the points. The point style referenced by a point describes how the point symbol is drawn.
polyface A 3-dimensional (polygon) mesh object. Each face is capable of having numerous vertices.
PRC Reverse Curve-Curve Intersect.
prism A faceted glass reflector used to return the signal from an EDM, whereby the EDM can determine the
distance to its reflection point.
prism constant The distance between the point of plumb and the reflection point within the prism.
prism offset The vertical distance between the theodolite target point and the optical center of the reflector.
profile An object that contains elevation data along a horizontal alignment or other line. There are two
main types of profiles: surface and layout. Profile data objects can be viewed within a profile view object.
profile grade line See layout profile (page 2776).
profile view An object that manages the graphic display of profile data objects within a drawing. A profile
view is essentially a graph with two primary axes: the x-axis represents horizontal distance along the referenced
horizontal alignment (or other linear feature). The y-axis represents elevations. Profile view objects can also
include grid display components and data bands.
project drawing A drawing that has been added to a project.
project objects Objects that exist in a project drawing and have been designated as shared, which means
that they can be accessed by others. See also drawing objects (page 2773).
projected object An object in plan view of a drawing that is projected into a profile view or section view.
AutoCAD objects that can be projected include points, blocks, 3D solids, and polylines. AutoCAD Civil 3D
objects that can be projected include points, feature lines, and survey figures.
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projection lines In a grading, the lines that designate face edges within a region for break points on the
footprint or the daylight line, and for the facets of curves (corner cleanup, vertical curves).
properties The settings that apply to a particular instance of an object.
property fields The placeholders in labels that contain content, such as text or graphics, along with format
modifiers unique to specific features. Property fields can be named and their values defined according to
the feature with which they are associated. See also modifier (page 2778).
Prospector tab The part of Toolspace where you access drawing and project objects. Objects are arranged
in a tree or hierarchy with folders and subfolders that you navigate in standard, Windows-Explorer fashion.
See also Settings tab (page 2782).
protected point A project point that you cannot check out and therefore edit.
proximity breakline A breakline that is drawn as a polyline without snapping to points in the drawing.
The northing, easting, and elevation of the breakline vertices are determined from the nearest point contained
in the surface point data, after generating the surface.
PT Curve-Tangent Intersect. See point of tangency (page 2780).
PVI Point Of Vertical Intersection. See point of vertical intersection (page 2780).
quadrant One of the sections resulting from dividing a circle into four equal parts. Quadrant 1 is the NE
corner, and quadrants 2, 3, and 4 proceed clockwise around the compass. Bearings are usually referenced
by quadrant number.
quantity takeoff The analysis of detailed cut and fill requirements along an alignment. A quantity takeoff
report provides information on the total volume of material required to create a finished grade surface,
including the process of cutting existing ground and refilling it with a different material, such as coarse
gravel.
R Right.
radians A system of measure in which 2 pi radians equals 360°.
raw description The original description of a point, before description key matching takes place. Often
corresponds to the point description entered in the field by a surveyor.
raw station A station value on an alignment, either formatted or unformatted, that does not take into
account any station equations applied to the alignment.
RC Reverse Crown.
rear yard The offset distance from the parcel rear segments to the setback line.
reference object Within a project drawing, the read-only geometry of an object that exists in another project
drawing. Objects that can be referenced include surfaces, alignments, profiles, and pipe networks. The host
drawing can apply local object styles and annotations, and perform some analysis on reference objects.
Referenced Text A label component that contains references to other AutoCAD Civil 3D objects.
region (grading) The area where grading criteria are applied to a lot line or a feature line.
region lines The projection lines that designate the start and end of the grading regions (criteria or transition)
by connecting the footprint to the daylight line.
return period A time period that represents an interval at which an event, such as a large storm, occurs. It
is used to calculate various flow control methods in a pipe network or storm sewer drainage system.
right-of-way (ROW) The allowable work area for an alignment. Property lines of the property owners who
reside adjacent to the construction site generally specify these limits, which are called right-of-way lines.
right-of-way parcel A parcel that is created from an alignment that crosses the original parent parcel.
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rod A slender bar of wood or metal marked with some type of measurement used to measure elevation
and/or distance.
ROW See right-of-way.
sag curve In a profile, a vertical curve at the bottom of a valley or similar location where the grade leading
into the curve is less than the grade leading out of the curve. In a sag curve, the point of vertical intersection
(PVI) for the tangents is below the curve.
sample The process of obtaining elevation information from an existing terrain model or surface.
sample line A line that typically cuts across an alignment, and that can be used for creating cross sections.
SBO Shoulder Breakover.
SC Spiral-Curve Intersect. See spiral to curve (page 2783).
SDTS See Spatial Data Transfer Standard (page 2782).
section An object that contains elevation data along a sample line.
setback line A closed polygon that is the result of offsetting and intersecting each parcel segment by its
respective front/side/rear yard distance. The exterior of the setback line typically represents the area where
permanent structures are not permitted.
settings A collection of properties and styles that apply to an object.
Settings tab The part of Toolspace where you access the styles for the different types of objects, including
object labels and tables. See also Prospector tab (page 2781).
setup Instrument setups that are defined in the Survey database.
shape codes A set of standard codes that define the display and behavior of shapes used in subassemblies.
shortcut See data shortcut (page 2772).
shortcut menu A menu that is displayed when you select an object and right-click. Shortcut menus are
context sensitive so that only commands that are relative to the object that you selected are displayed.
side yard The offset distance from the parcel side segments to the setback line.
sideshot A point that is created with a unique identifier, resulting from relative observations (such as angles,
distances, vertical angles, and target heights) taken from a survey station or setup to locate a point that is
not intended to be used as a base for the extension of the survey. For example, at one station (setup) in a
traverse loop, you can survey points for stone walls, trees, buildings, and wetlands.
simple spiral A spiral that provides a smooth transition between a tangent of infinite radius to a curve of
finite radius. See also clothoid spiral (page 2770), compound spiral (page 2770).
site A collection of objects that are managed by means of common topology. The objects that participate
in the topology are parcels, alignments, and grading. See also topology (page 2785).
slope A method of reporting surface inclination as a ratio that expresses the horizontal distance in which
the elevation changes by one linear unit. For example, if the ground rises 3 units over a horizontal distance
of 15 linear units (meters or feet), the slope is 5:1 (5 to 1). See also grade (page 2775).
slope projection The method of grading to a target that is either Slope (H:V value) or Grade (percentage
value).
south azimuth Azimuths south of the equator are referenced to due South clockwise.
Spatial Data Transfer Standard A file format designed as a mechanism for the transfer of spatial data
between various computer systems. The SDTS Format is designed to transfer data with complete content
transfer (no loss of information).
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SPI Reverse Spiral Tangent.
spiral See clothoid spiral (page 2770), compound spiral (page 2770), simple spiral (page 2782).
spiral to curve (SC) A point where a spiral meets a curve.
spiral to tangent (ST) A point where a spiral meets a tangent.
split point The location where two feature lines cross although neither has a geometry point at that location.
You cannot directly edit the elevation of these points.
split profile A profile view that has a readjusted datum at a station where one or more profiles goes out of
bounds. This condition happens if a profile view that has a user-defined height is not able to adequately
portray the full extents of a profile.
spot elevation The elevation of a single point in the drawing. Used to define areas that are sparse in contour
data when generating a TIN using contour information. Areas that may also need spot elevations are the
top of hills, valleys, and bottom of swales.
SS Spiral-Spiral Intersect.
SS_LRB:L Simple Spiral Large Radius at Beginning.
SS_LRE:STA Simple Spiral Large Radius at End.
SS_SRB:L Simple Spiral Small Radius at Beginning.
SS_SRE:STA Simple Spiral Small Radius at End.
ST Spiral to Tangent Interesct. See spiral to tangent (page 2783).
stacked profile views A collection of related profiles drawn in separate, vertically arranged profile views.
Typically, a centerline profile is contained in one profile view, and its left and right offsets are drawn in
profile views that are placed above and below the centerline profile view.
stacked text When you drag a label from its point of origin, label text can be rearranged by specifying
settings for text justification, text height, and relationship to borders.
stadia A technique of distance measurement using a rod and a stadia transit.
stakeout The process of placing stakes in the ground at control points on a site that is being developed. For
example, after you place points in your drawing, or after you design an alignment, you can create stakeout
reports that list the coordinates of each stake. Someone else can then use these stakeout reports to place (or
adjust) the stakes at the site.
standard breakline A breakline defined from selecting consecutive points or point numbers, or selected
3D polyline or 3D line objects.
starshot Determining azimuth by using a star rather than a compass.
station A distance along a horizontal alignment.
station equation A point on an alignment that defines a change in the station values after that point.
stationing The labeling that provides a reference when talking about a specific point along the reference
baseline.
stopping sight distance The distance required to safely stop a vehicle, traveling at design speed, to avoid
a collision with any other non-moving objects obstructing the travel path.
stratum The difference between two surfaces that exist in a drawing, usually the existing ground surface
and a finished ground surface, which is used for calculating volumes.
structure object A type of object used to visually represent structural components used in a pipe network,
such as a headwall or a catch basin.
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style A logical collection of settings that applies to a class of objects. Styles simplify the process of apply
settings by simply referencing a style. Modifying a style affects all the objects referencing that style.
subassembly An AutoCAD drawing object (AECCSubassembly) that defines the geometry of a component
used in a corridor section. The AutoCAD Civil 3D tool palette and tool catalogs provide a variety of
preconfigured subassemblies, such as travel lanes, curbs, shoulders, and ditches.
subdivision An unimproved tract of land surveyed and divided into parcels for purposes of sales.
sunshot Determining azimuth by making observations on the sun rather than by a compass. the change in
cross slope or 'banking' on a horizontal curve to help counterbalance the centrifugal force of a vehicle
traversing the curve
superelevation The change in cross slope or 'banking' on a horizontal curve to help counterbalance the
centrifugal force of a vehicle traversing the curve.
surface A network of elevation data (either TIN or Grid). The points of a surface are connected into either
triangles or a grid, which are then used to interpolate contours, and to generate profiles and cross sections.
A surface represents the ground condition at a particular time or event.
surface border See border (page 2769).
surface boundary See boundaries (page 2769).
surface distance The distance between two points, measured along the ground surface. On a sloped surface,
the distance between two points can also be measured as a horizontal distance and a vertical distance.
surface profile A profile object that represents existing ground elevations along a horizontal alignment or
other linear feature that supports profile views. Typically this data is derived from an existing surface or data
file, and consists of a series of connected vertical tangent lines without vertical curves defined. If necessary,
you can add vertical curves.
surface smoothing A process that interpolates and extrapolates surface data to derive additional elevation
values. Kriging and Natural Neighbor Interpolation (NNI) are the two methods of surface smoothing.
survey command language A language that you can use either with a data collector or when you enter
survey data manually. This language describes survey observations. For example, you can use the AD [VA]
command to enter an angle, distance, and vertical angle.
survey database Contains all the control points, known directions, observation measurements, traverse
definitions, figures, and standard deviations based on equipment data for the Survey project. This includes
observations imported from data collector files, entered from the Survey Toolspace tab (Traverse and
Observation Editors, Survey Command Window and Batch File processing).
Survey Point A point that is created by the Survey features of AutoCAD Civil 3D, such as importing a field
book or LandXML file containing survey data. A survey point can represent a Control Point, Non-control
Point, Setup, or Sideshot. When a survey point is placed in the AutoCAD Civil 3D drawing, it creates a special
AutoCAD Civil 3D COGO point that prevents its location and description from being modified from outside
the AutoCAD Civil 3D Survey features. For example, a survey point location may be a traverse station whose
location is dependent on many observations from previous traverse stations, all originating from a known
control point and direction. In the AutoCAD Civil 3D drawing the Survey Point displays a different icon
than the AutoCAD Civil 3D COGO point to indicate its origin.
Survey tab The tab in Toolspace where you access and manage survey settings, survey-related databases,
and survey project data.
tangent A straight line segment that forms part of a horizontal alignment or profile. Tangent Distances are
measured as the horizontal distance between the two end points.
target The element of grading design criteria that determines what the grading is going to intercept. A target
can be a surface, absolute elevation, relative elevation, or distance.
target line See daylight line (page 2772).
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template A collection of default settings and styles used to create a drawing.
terminators Graphics, such as arrowheads, ticks, or crow’s feet, that display at the end of lines, arcs, or
spirals.
tessellation The representation of curves by using short straight line segments.
tessellation angle Controls the angular spacing of breaklines that are supplemented along curve segments,
such as around corners. Used for surface creation from grading objects.

tessellation spacing Controls the spacing of supplemental breaklines that are added to a grading along
straight segments. Used for surface creation from grading objects.

tick A component of a label that is usually a mark (or short line) inserted in a series at perpendicular angles
to another object, such as a line or curve.
TIN Triangular Irregular Network. A TIN surface is the most common method of interpolating elevation
data. The points are connected into triangles that are used to interpolate for contours, and to generate profiles
and cross sections. The lines that make up the surface triangulation are called TIN lines. See also 3D face
(page 2767).
TIN volume surface A differential surface created from a composite of points based on base and comparison
surface. Also known as a differential surface.
Toolspace window A window that provides an object-oriented view of your engineering data. Toolspace is
divided into four parts or tabs: Prospector tab, Settings tab, Survey tab, and Toolbox tab.
topography The features of the actual surface of the Earth.
topology A set of geometric connections between objects. Objects linked by topology maintain their
relationships with one another. In AutoCAD Civil 3D, objects that share the same topology are grouped in
a site. See also site (page 2782).
transit rule A method of balancing a traverse, in which one assumes that the closing errors are caused less
by the errors in the observed angles than by the errors in measured distance. Corrections are distributed
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according to the ratio of the latitude and departure of each leg of the traverse, to the sums of the latitude
and departures of the entire traverse. Use the Transit Rule option when it is assumed that closing errors are
due less to the errors in the observed angles than to errors in the measured distances.
transition region An area of a grading that blends the control regions on either side of it. A transition region
has no design criteria assigned to it.
transparent command A command that you can run while another command is in progress. Transparent
commands begin with an apostrophe (‘).
traverse A method of surveying in which length and directions of lines between points on the Earth are
obtained by or from field measurements, and used in determining positions of the points.
Traverse closure for closed or open loops is recognized by the observation to a control (fixed or known)
point. A closed traverse begins and ends at the same control point. An open traverse closes at a different
control point than the beginning point.
triangle area The 2-dimensional (2D) area of a triangle face computed from the northing and easting of
each triangle point. The total triangle area is the sum of all 2D triangle areas with the surface boundaries.
trim (surface) The process of removing unwanted TIN lines from a surface, thereby removing triangles.
TS Tangent-Spiral Intersect.
user-defined property A property defined by you to assign values to points or parcels. Points and parcels
have many default properties, but user-defined properties allow you to specify others as needed.
user-defined property classification A way to group user-defined properties into logical categories.
vault A database that is managed by Autodesk Vault.
Vault reference A type of data reference between drawings within a Vault project.
VCC Vertical Compound Curve Intersect.
VCCE Vertical Compound Curve Intersect Elevation.
VCCS Vertical Compound Curve Intersect Station.
vertical alignment See profile (page 2780).
vertical angle An angle above or below the horizontal plane. The angle is expressed in DDMMSS from this
horizon. Vertical angles expressing a downhill slope from the instrument station are described with a negative
value. Zenith angles are similar to vertical angles, except that a zenith angle has a vertical reference plane.
zenith

+ horizontal vertical angle
- horizon vertical angle (Z)
horizon

foresight point

foresight point

plumb line

setup point

nadir

vertical curve A curve used on a profile (most commonly on layout profiles) to provide a gradual change
in slope from one tangent to the other. There are three types of vertical curve: parabolic, circular, and
asymmetrical.
vertical distance A distance measured along a sloped surface. For example, if you measure a distance from
point A to point B that is on a 3:1 grade, then that distance is longer than the distance measured horizontally.
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prism target height (th)
vertical distance

foresight point elevation (FE)
setup point elevation (SE)

height of instrument (hi)

vertical exaggeration An increase of vertical scale relative to horizontal scale, used to make grade changes
easier to differentiate. See vertical scale (page 2787).
vertical scale The scale that is compared to the horizontal scale to calculate the vertical exaggeration in
profiles and cross sections. It does not actually change the scale that is used when the drawing is plotted.
vertical to horizontal Vertical angles and distances are converted automatically to horizontal angles and
distances when you adjust a traverse loop, or perform Least Squares adjustment on observed data.
void region An area along a footprint where grading has not been applied, creating a gap in the grading.
volume surface A surface that is created by calculating volumes using the grid (differential) or TIN (composite)
methods. The surface is created from the two surfaces that make up the stratum. The elevation values of a
volume surface are actually the difference between the two surfaces. For example, at point 1000,1000, the
bottom surface has an elevation of 100, and the top surface has an elevation of 150. The elevation of point
1000,1000 on the volume surface is the difference between the two surfaces, which is 50.
VRC Vertical Reverse Curve Intersect.
VRCE Vertical Reverse Curve Intersect Elevation.
VRCS Vertical Reverse Curve Intersect Station.
wall breakline A breakline that represents surface features such as retaining walls, curbs, bridge abutments,
and so on.
water drop A path drawn with a 2D or 3D polyline, which represents water as it flows downhill.
watersheds Catchment areas for rainfall that are delineated as the drainage areas producing runoff. Base
flow in a stream also usually comes from the same area.
weeding The removal of points along a selected polyline representing a contour. The weeding factors
determine the amount of points removed. You can use weeding to reduce the amount of point information
taken from the contours that may not be necessary to generate an accurate surface. See also weeding factors
(page 2787).
weeding factors The settings used to reduce redundant points along the contours by ignoring contour
vertices that are close together or along a straight line. A larger distance and deflection angle will weed a
greater number of points.
widening A type of dynamic offset alignment that expands the width of a roadway for a specified length
to accommodate a feature such as a turn lane or bus bay. The widening usually includes a transition region
at one or both ends.
zenith angle The point directly overhead or the point where an observer's vertical line pierces the celestial
sphere. Opposite zenith is the nadir.
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zenith

zenith vertical angle

horizon

foresight point

foresight point

plumb line

setup point

nadir
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Index
.adsk files
importing to Civil drawing 1891
preparing 1891
.dem files, as point cloud source data 593
.dvb files 1403
.fbk files 2679
.flt files 674
(See also breaklines)
.grs files, using with large surfaces 740
.kml files, location 1871
.kmz files, location 1871
.las files, as point cloud source data 593
.mms files, using with large surfaces 740
.NET reports
generating 1757
(See also reports)
settings 1757
.NET, converting pipe and structure rules to
.sdb/.sdx files, in survey databases 217
(See also survey databases)
.xyz files, as point cloud source data 593
3D DWF files, exporting drawings to 1863
(See also Design Web Format (DWF))
3D geometry, defining for sites 2597

A
abbreviation settings, specifying 83, 2077
ADSK files
importing to Civil drawings 1891
preparing 1891
AEC Editor settings 1858
AEC objects, exploding 1858
alignment curves
adding 983
editing settings 1983
alignment labels
(See also labels)
adding 1053, 1055
descriptive text, adding to 1052
geometry points 1048, 1951
importing 1047
multiple segment 1054
profile geometry points 1992
properties, editing 1952
sets, saving 1046
station character, changing 1051
station index format 1051

1403

station offset, adding 1055
styles 1043
superelevation critical points 1993
superelevation diagrams, adding 1050
tables and 1043
tangent intersection, adding 1057
alignment layout tools
(See also layout tools)
about using 1959
adding constraint-based entities using 970
creating alignments using 948
drawing tangent-tangent alignments using 950
toolbar, using for alignment edits 923
alignment points of intersection
(See also alignments)
adding 1064
breaking apart 1065
deleting 1065
editing 1064
alignment styles
about using 946
applying 947
collection 927
creating 947
creating from existing styles 947
alignments
(See also alignment curves, alignment labels,
alignment layout tools, alignment styles,
alignment points of intersection)
about 923
as parent objects 923
AutoCAD object snaps 1085
best fit entities, editing 1075
best fit, creating 960, 1980
command settings 929
components, controling display 1970
corridor feature lines, exporting as 1529
corridors, and 923
creating 780, 948, 950, 1045
creating from existing alignments 957, 1973
creating from pipe networks 2261
creating points by importing ASCII files 497
criteria violations, correcting 1080
criteria-based design, applying 1079, 1966
curve and spiral settings 930
data, importing from Land Desktop 2234
defined 2767
design criteria, applying 959
drawing tips 140
editing 1060, 1068
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editing with grips 137
entities, selecting 1061
entity descriptions 970
establishing speeds along 1966
information about, entering 1973, 1977
label sets, adding and editing 1974
lines, adding 971
masking 932, 934
new features 3, 12
numbering in sites 2210
object relationships 925
offset 956
parameters, editing 1066, 1953
profiles, and 923
properties 932, 1964
references to existing, creating 954
regression analysis 1972
removing from sites 786
reports, for best fit 1972
reports, generating for 2465–2466, 2468
reversing direction 1083
reversing direction, subentity 1084
sections, and 923
settings, modifying 929, 1983
site interaction 786
sites, specifying for 1974
source, selecting 957
station equations 933
styles 1974
subentities, creating from AutoCAD line or arc 1062
tables 1058–1059
tangent-tangent, drawing 950
types 924
widenings 964
workflow 40
ambient settings
editing 2025
specifying for drawing 84
anchor points, line 1673
Angle Distance, transparent command 1769
annotating, objects with reference information 1804
API, new features 4
arc tessellation, illustrated 664
architectural data, importing to Civil drawings 1891
arcs
creating by best fit 631
labeling 1702
ArcSDE
additional requirements for using 659
as GIS data source 2637
DLL files, installing for using 659
areas, calculating catchment 768
arrows
direction, for label style 2194
in labels 1700
North, inserting using plan production tools 1903
assemblies
(See also subassemblies)
assembly set 1586
baseline 1539
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baseline point 1539
collection (Prospector) 1540
collection (Settings) 1541
commands 1583
copying 1549
creating 1541, 2000
creating from tool palettes 1544
defined 2767
deleting 1549
description 1537
display properties 1997
editing 1548
importing 2003
insertion point 1539
managing 1548
object components 1539
offset line 1539
offset point 1539
offset, adding 1550
offset, removing 1550
offsets, creating 1543
overrides, viewing 2034
planning before creating 1548
previewing 1552
properties 1540, 1995
settings 1540
settings, editing 2001
sharing 1552
styles 1550
with conditional subassemblies 1545
astronomic direction calculator, using 417, 2667
asymmetrical parabolic curves 1166
auto-balance volumes, in grading 868, 2103
AutoCAD
exporting drawings to 1857
points, converting to COGO points 542
properties, editing 139
render materials, accessing 1763
AutoCAD objects
(See also objects)
creating surface point data from 689
dependent, removing from surface 719
viewing 1805
AutoCAD point cloud objects vs. Civil 3D point cloud
objects 602
AutoCAD point nodes vs. Civil COGO points 435
(See also COGO points)
Autodesk Design Review, using to view drawings 1864
Autodesk Land Desktop
importing data from 2233
importing points from 533
Autodesk Revit Architecture data, importing to Civil
drawing 1891
average end area, formula for stage storage volume 748
Azimuth Distance, transparent command 1773

B
bands, data

1245

base layer, in Civil objects 73
(See also layers)
baselines
adding to corridors 1498
creating new points from 313
defining, in surveys 311
direction, listing 312
in grading 856
survey commands 429
basin, stage storage volumes 743
batch converter utility 1859
batch files, using in survey 344
Bearing Distance, transparent command 1770
best fit
alignments, creating 960
analysis 2226
arcs, creating using 631
entities, creating 2225
entities, creating using 628
lines, creating using 628
options for alignments 1980
options for profiles 2393
parabolas, creating using 635
profiles, creating 1154, 1165, 2393
blind extrusion modifier, in Part Builder 1444
block componenents, creating for label styles 2188
block objects
creating from COGO points 543
moving to attribute elevation 690, 2639
moving to surface elevation 694, 2639
Bloss spirals, about 1013
(See also clothoid spirals, compound spirals, cubic
spirals)
Boolean modifiers, in Part Builder 1446
borders, display and styles in surface 2645
boundaries
about 661
adding to surface 664, 2616
corridor, creating 1511, 2039, 2046
data clip 663
defined 645
inserting into drawing 666
listing 2619
properties, editing 667
show 662
surface, creating 664
types of 661
bounded volumes, calculating 742
bounding box, as point cloud component 594
breaklines
(See also .flt files)
about 667
adding 2615
creating from figures 349, 2668
creating in text file 675
crossing, tools for finding and fixing 770, 2625
defined 2769
definition options 668
editing 677, 2619
explained 646

file linking options 674, 2615
files, creating 675
importing from file 674
inserting into drawing 677
listing 676, 2619
non-destructive 673
reports, generating 772, 2622
standard 668–669
tools for crossing 770
types of 668
building site objects
definitions, updating 1895
dialog boxes 2009
export report, using 1892
importing to Civil drawings 1891–1892
modifying in drawings 1894
properties 2014
settings 2009
styles 1894, 2012
Building Site Properties dialog box 2014
building site settings 2009
Building Site Style dialog box 2012

C
C3D objects, rendering 1761
case sensitivity, in description matching in point
groups 561
catchment points, adding marker to 2620
catchment regions
(See also waterdrop paths)
displaying 768
properties, setting 2620
centerlines
instrument height, setting using 318
using in surveys 315
using with cross sections 325–328
vertical distance 323
circular curves 1166
Civil 3D objects
overview 63
rendering 1761
Civil 3D point cloud objects
using in other applicaions 602
vs. AutoCAD and Map 3D 602
Civil 3D points, about 435
Civil objects
AutoCAD command support 1939
matching properties 72
properties 72
QSELECT command 72
rendering 1761
Civil transparent commands 1767
classification, LiDAR points 2383
clothoid spirals
(See also Bloss spirals, compound spirals, cubic spirals)
about using 1013
defined 2770
code matching, in LandXML import and export 1882
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code sets
styles, editing 1999
styles, in subassemblies 1567
styles, using 1577
codes
adding to code set style 1577
adding to subassemblies 1576
corridors, editing 2037, 2047
link 1568, 1570
link, editing styles 1999
point 1568–1569
point, editing styles 1999
shape, editing styles 1999
shape, in corridor modeling 1568, 1571
subassemblies, using in 1567
COGO (coordinate geometry), overview 1791
COGO points
(See also AutoCAD point nodes vs. Civil COGO
points)
about 435
creating blocks from 543
creating from AutoCAD points 542
creating from Softdesk point blocks 542
defined 2770
editing 520
exporting from corridor 2048
exporting from corridors 1531
listing available point numbers 541
using with external data references 537
collections, item views 137
collinear site objects 786
command reference
(See also commands)
alignments 1088
assemblies and subassemblies 1583
building site import 1895
Civil 3D 1938
corridors 1534, 1622, 1642
data shortcuts 203
drawing sharing 142, 1849, 1865
Google Earth import and export 1873
grading 869
HEC-RAS import and export 1890
labels 1735
LandXML import and export 1885
lines and curves 643
parcels 921
pipe networks 1428
plan production tools 1935
point clouds 604
points 546
profile views 1221
profiles 1221
reports 1760
sections 1272, 1321
sites 791
superelevation 1111
surfaces 775
survey 419, 1755
transparent commands 1788
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Vault 203
command settings, survey 243
command-level settings, specifying 85
commands
(See also command reference, transparent commands,
survey command language)
(See also survey command language)
accessing 1937
alignments 929
AutoCAD, supported by civil objects 1939
Civil 3D 1937
civil, general 124
collection, using to control settings 114
controlling settings 114
project management 159, 189
survey 419, 1755
component layer, in Civil objects 73
composite volumes
calculating 740
creating 2620
compound spirals
(See also Bloss spirals, clothoid spirals, cubic spirals)
about using 1013
defined 2770
conceptual design, tools for 1867
conic approximation, formula for stage storage
volume 748
constraint-based alignment entities, adding 970
constraints, adding to model geometry 1441
construction baselines, representing with
alignments 923
construction documents, creating 1901
construction geometry, for parcels and alignments 2598
Content Browser, using to move subassemblies to tool
palette 122
contour labels
(See also contours)
adding 758–759, 761
styles 754
contours
(See also contour labels)
adding 2617
data, adding to surface 681
defined 2771
display and styles 2646
editing 682
guidelines, creation 680
listing 682
missing information, adding 680
problems, checking 765
smoothing 2647
using for surface creation 678
weeding and supplementing 679
control points
creating 280
editing 279, 282, 2713
editing properties 2688
survey 280
convergence angles, calculating during point export 528
conversion factors, in LandXML import and export1881

converting
polylines, 2D to 3D to 2D 854
units in labels 1726
units of measurement 1876, 1880
coordinate geometry
(See also geometry)
displaying angle and line information 1794
displaying slope information 1795
entering when creating objects 1791
measuring 1791
overview 1791
working with distances 1791–1792
coordinate systems
selecting 2640
specifying for DEM files 686, 2641
specifying for drawing 80
Coordinate Tracker
about using 1813
changing coordinate capture keys 1816
controls 2760
sending coordinates to command line 1815
viewing coordinates 1814
coordinate zones, transformation property 526
coordinates
defined 2771
specifying in drawings 133
transformation settings 2074
using in line creation 609
corridor data
exporting 48, 1528
rendering 1533
setting up 46
corridor feature lines
(See also corridors, feature lines)
branching 1502
connections, editing 1502
creating from corridors 2051
defined 2771
editing 1501, 2031, 2037
exporting 1528
exporting as alignments 1529
exporting as grading feature lines 1529
exporting as polylines 1528
exporting as profiles 1530
styles, editing 1505
corridor profiles, creating 1150
(See also profiles)
corridor regions
adding 1489
creating 2051
managing 1487, 1496
corridor sections
(See also corridors)
editing 1519, 1523, 2065
options 2065
properties 1256
properties, editing 2483
station tracking 1521
tools, viewing and editing 2042
viewing 1519

corridor settings
accessing 1474
creation 1599
editing 1478, 1598, 2053
style and label 1480
corridor surfaces
(See also corridors, surfaces)
boundaries, adding 1511
copying 1508
creating 1506, 2038, 2045
defined 2771
editing 1509
exporting 1532, 2051
overhang, correcting 1510
corridors
(See also corridor feature lines, corridor sections,
corridor settings, corridor surfaces)
adding sections 1527
assembly overrides, applying 2031, 2034
baselines, creating and adding 1498, 2049
before creating 45
boundaries 1511, 1514, 2032, 2039, 2046
code set style, editing 1500
codes, editing 2037, 2047
COGO points, exporting 2048
collection (Prospector) 1474
components 1472
creating 1475–1476, 1590, 2049
creating roundabouts 1631
creation settings, editing 1479
defined 2771
deleting 1518
description, editing 1481
designing 47
display 1473, 1588
editing 1478
logical mapping 2064
managing 1478
mapping targets 2064
modeling, description 1471
name, editing 1481
new features 4
offset alignments, editing 1499
parameters, editing 1486, 2033, 2035
points, exporting as COGO points 1531
polylines, exporting 1528
properties, editing 2034
rebuilding 1517
recreating corridors in intersections 1615
rendering 1533
reports, generating for 2472
section objects 1228
sight distance along, checking 1847
simple, creating 1475, 2052
slope patterns 1515–1516, 2040, 2053
stations placing frequency 1492
styles 1473, 2044
targets, setting and editing 1481
updating intersection corridor regions
automatically 1614
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visualizing 47
workflow 43–45
Corridors Collection (Prospector tab) 1588–1589
country kits, migrating 141
Cover and Slope rule, using for pipes 1394
Cover Only rule, using for pipe networks 1395
crest curves 1169
crest curves, types 1113
(See also sag curves)
criteria-based design
design criteria file 936, 1140
in alignments 935, 1079, 1966
in profiles 1139, 1202
roadway standards tables 1091
violations, correcting 1080, 1203
cropped surfaces, creating 716, 2624
cross sections, about using 1225
crossing breaklines
reports 772, 2622
tools for fixing 770
cubic spirals, about using 1015
(See also Bloss spirals, clothoid spirals, compound
spirals)
curve coefficients 1167
curve group (entity) index, specifying 931
curve groups, supported labels 1057
curves
(See also vertical curves)
adding to alignments 983, 995
adding to pipe networks 1340
between two lines 621
calculator 639
command reference 643
creating 621–622, 624–625
creating multiple 625
displaying COGO information 1794
fixed, adding to alignments 983
floating, adding to alignments 994
free, adding to alignments 1003
labeling 1702
labels text 1680
multiple, attaching to existing entities 637
parameters, calculating 639
reverse or compound, creating 627
segments, labeling 641
using in layout profiles 1113
curves with spirals, adding to alignments 1032, 1038
custom properties
adding to parcels 920
adding to points 445
customizing UI 92
(See also menus, ribbon, user interface)
cut and fill balancing 868
cut factor, in quantity takeoff 1280
(See also quantity takeoff, volumes)
cut plane modifier, in Part Builder 1446
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D
data bands
adding to a profile view 1215, 1245
adding to profile view 1215
defined 2772
Distance from Centerline 2530
geometry point labels in 2412
grouping into sets 1245
labels 1708
Offset from Centerline 2530
profile view 1128
section view 1245
sets in profile view 1135
styles, creating 2394
styles, profile view 1133, 2389, 2414
data clip boundaries
about 663
applying to TIN, LandXML, grading, corridor
surfaces 663
data definition, surface 660
data exchange
before you begin 1892
between civil and architectural applications 1891
issues 1892
data references
defined 2772
relationship with data shortcut 146
using in plan production 1928
data sharing, between applications 1855
data shortcuts
about using 145
accessing source 156
create 2451
creating 151
defined 2772
deleting 152
edit and repair 157
folder 148
importing 151
new features 5
new project folder 2456
promoting 154
referencing 2450, 2452, 2454
select folder 2459
synchronizing 152
types of 146
updating 156
validating 155
Data Shortcuts Editor 157
Data Shortcuts Node, enabling or disabling 152
databases
(See also figure prefix databases)
migrating data 5, 217
new features 5
point clouds 599
points 537
survey equipment 221
survey, creating 217
survey, translating 2730

Vault, viewing 2455
datastores (GIS), connecting to 659
daylight lines, defined 2778
default (ambient) settings, specifying 84
definition list, for surfaces 646
Deflection Distance, transparent command
Delauney triangulation, about 649
DEM data
about 684
properties 688
viewing 688
DEM extents, importing 688
DEM files
about 683
adding and editing 2627
adding to surface 686
as point cloud source data 593
coordinate systems 2627, 2640
coordinate systems, changing 686
elements of 685
exporting surface data to 773
exporting surfaces to 2634
exporting to 1865
finding information about 656
memory usage 689
obtaining 684
DEM surfaces, creating 656
dependencies, between Civil objects 64
Description Key Editor, about using 591
description keys
(See also raw descriptions)
about using 571
code 574
copying 585
creating 584
defined 2772
deleting 591
editing 590, 2368
examples of creating 586–587, 589
format 576
importing 581
Land Desktop, importing 2233
managing 579
matching 572–573
naming 2368
overview 571
parameters 573
printing 584
properties 574
search order, specifying 2368
set 581–582
settings 573
using to create points 579
using to include points to point groups
wild cards 575, 577
design check sets
alignment 944
creating 945
profile 1141

1771

581

design checks
alignment 940
creating 942, 2069
editing 944, 2069
examples 941
profile 1140
sets, creating 2070
sets, editing 2070
design criteria
applying to alignments 1975
default file location 960
design criteria file
alignment standards in 936
creating 937
defined 2773
editing 939, 2067
profile standards in 1140
using with alignments 935
design package files
importing 1891
preparing 1892
publishing 1891
design speed, applying to stations along
alignments 959, 1975
Design Web Format (DWF)
(See also 3D DWF files)
about 1864
files, viewing 1864
publishing objects to 2762
DesignCenter, using with multi-view block
definitions 1826
detached grading surfaces, creating 869
DGN files
attaching as an underlay 11
copying objects in an underlay 11
dialog boxes
alignments 1945
assemblies and subassemblies 1995
Autodesk Land Desktop migration 2233
corridors 2031
drawing layers 2221
Google Earth publishing 2091
import building site 2009
intersections 2145
LandXML 2213
parcels 2235
pipe networks 2259
plan production tools 2319
point clouds 2379
profiles 2389
project management 2445
render materials 2021
roundabouts 2145
settings 78
sites 2597
surfaces 2615
tables 2735
utilities 2745
digital elevation model (DEM), files 684
dimensions, adding in Part Builder 1440
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directions
creating 310
editing 279, 310
properties, editing 2689
survey, about 309
display precision, setting for survey units 239
Distance from Centerline, in section data bands 2530
distances
between objects 770, 1811–1812
display options 2080
minimum, calculating between entities 1811
shortest, calculating between entities 1811
vertical, calculating between entities 1812
drafting tools, using for editing Civil objects 1833
drag-and-drop functionality
using in drawings or templates 71
using in Settings tree 115
with points in Prospector tree 568
draping images on surfaces, prerequisites 750
drawing compatibility 141
drawing items
(See also drawings)
in Prospector tree 159
modifier icons 161
state icons 161
drawing objects
(See also drawings)
defined 2773
drawing settings
(See also drawings)
about 79
applying 2073
LandXML 1880
object layers 82
overriding 84–85
templates 130
transformation 81
units and zone 80
drawing sharing, command reference 1849
drawing tips, for alignments, profiles, and sections 140
drawings
(See also drawing items, drawing objects, drawing
settings)
adding to a project 177
associating with project 2447
checking into projects 179
checking out from projects 178
Civil, working with 127
creating 132
data, working with 133
detaching from projects 182
display properties, ByLayer and ByBlock 2019
duplicate items in, resolving 2029
exporting 1861, 1863
exporting to AutoCAD 1857
information, displaying 162
layer standards 129
object and label styles 129
opening 132
opening project 180
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proxy graphics 1856
sharing methods 1855, 1864
template 129
templates 33, 127–128
units, display settings 2078
Vault project, working with 176
vewing in Object Enabler 1857
drive tools 1842
driving, simulating 1842
duplicate point numbers, resolving 265
duplicate site objects 786
DWF data, publishing 2762
DWF Viewer, using to view drawings 1864
DXF files, exporting drawings to 1861
dynamic Civil modelling, about 63
(See also dependencies)
dynamic links, removing from feature lines 812

E
earthworks, in volume calculations 1279
edge swapping, in TIN surface triangles 701
editing 252
figure properties 367
properties of objects 138
survey point properties 347
using grips 137
with item view 137
with Panorama window 138
elevation
surface, changing 710
elevation editor, using in grading 820, 2111, 2113
elevation points, inserting 832
elevation range
editing 2506
elevation ranges, of point cloud points 2384
elevations
adjusting during points import/export 528
data, importing from Google Earth 1870
override in point groups 556
energy grade line 2279, 2292
entities
alignment, types of 970
creating by best fit 2225
equation assistant, in Part Builder 1456
equations
crest curves 1169
equations, spiral curve 1014
(See also expressions)
equipment, survey 228
error codes, Vault 195
error tolerance, setting 244
errors
build 697
surface definition 696
surface disconnection 697
ESRI files, creating surfaces from 656
ESRI shape files, as GIS data source 2637

Event Viewer
about 1817
controlling display 1817, 2757
controls, described 2753
copying event to clipboard 1821
creating log file 1819
customizing 1817
exporting event list 1820
locating events in 1821, 2756
log files 1819
opening log file in 1820
events
application session, monitoring 2753
displaying properties 2754
filtering 2755
locating in Event Viewer 2756
Excel, pasting civil data into 103
EXPLODE command
(See also exploding)
using in Part Builder 1451
using with tables 1754
exploding
(See also EXPLOAD command)
labels 1720
objects 1858
tables 1754
Export Bulding Site report, using 1892
export settings, LandXML 1882
exporting
Civil data to HEC-RAS 1888
Civil data to Spatial Data Format (SDF) files 1862
LandXML data 1884
parcel data 897
point data 534
points 525, 529
site objects to LandXML 782
surfaces to DEM 2634
survey database settings 245
Vault projects 174
expressions
(See also equations)
adding to labels 1726
examples 1728
query building 565
setting up for label styles 2211
external data references (XDRefs), using with COGO
points 537
external reference documents, attaching to
objects 1804, 2749
extracting
objects from surfaces 2635
surface data 695

F
face, grading 793
feature lines
(See also corridor feature lines)
about 796

adding to surface as breakline 851
arcs, editing 838
assigning properties to 2132
breaking 849
by reference 824
collinear 786
converting to arcs, in grading 842
creating 808
creating from alignment 810
creating from corridor 2051
creating, in grading 808
curved 808
defined 2774
drawing 813
editing elevations, in grading 824, 833
elevation points, deleting 832
elevation points, inserting 830
elevation priority 866
elevations, assigning 809
elevations, editing 818–820, 822
grading, editing 816
in grading 793
inserting points of intersections 834
joining, in grading 836
labeling 853
labeling, in grading 852
name, assigning 811
offsetting, in grading 848
overlapping 786
points of intersection, deleting 836
properties 866
radius, editing 838
raising/lowering by reference 826
removing vertices, in grading 846
reversing, in grading 837
rounding corners in 841
selecting all in site 812
selecting from corridor 2061
setting adjacent elevation by reference 827
setting elevations from surface 833
smoothing 844
split point priority 866
statistics 866, 2133
style priority 866
style, assigning 811
styles 812, 2118
toolbar 2126–2127, 2129
trimming 850
troubleshooting 786
troubleshooting 0 elevation 866
using as breaklines, in grading 798
weeding vertices 846, 2133
features, new 3
field book file (.fbk)
importing 266
field book file (.fdb)
editing 268
exporting 269, 2675
importing 2679
transferring raw data to 266
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figure prefix databases
(See also databases)
about 222
properties, setting 2677
setting 229–230
figure prefixes, specifying properties 2718
figure properties
breaking figures 367
deleting vertices 367
editing 367
joining figures 367
reversing vertex direction 367
figures
about creating 347
beginning 378
closing 349
continuing 381
creating and editing 347
creating from breaklines 349
creating from objects 348, 2669
creating non-tangential 372
editing elevations 382
editing geometry 382
editor 2718
extending 379
groups editor 2719
inquiry commands 382
properties, specifying 2704
styles 2707, 2709
file formats, supported in Object Viewer 2750
fill factor, in quantity takeoff 1280
(See also quantity takeoff, volumes)
filleting, feature lines 841
fit curve tolerance, specifying 2135
fixed alignment entities, about 970
flat areas, minimizing in surfaces 678, 705, 2639
floating alignment entities, about 970
floating curves with spirals, adding to alignments 1032,
1038
flood analysis 1887
FLT files, importing as breaklines 674
footprints
defined 2774
footprints, creating grading from 856
format converter utility 1859
formulas
adding to labels 1726
least squares analysis 392
free alignment entities, about 971
free haul, specifying measurement options 2577
from-to extrusion modifier, in Part Builder 1444

G
General collection, using to create styles
GEO files, exporting to 1888
Geodetic Calculator, using 545, 2373
geometry
(See also coordinate geometry)
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in defining models 1439
point text, adding 1052
geospatial data
importing 658
mapping to Civil objects 2638
querying 2637
geospatial queries, creating 2637
GETime command 1873
GIS
data, creating surfaces from 658
datastore types, supported 2637
datastores, connecting to 659
schemas, specifying 2637
GIS data
importing 658
mapping to Civil object properties 2638
GIS datastores
connecting to 659
connection types 2637
GIS schemas, specifying 2637
Google Earth
3D Viewer display settings 1870
elevation data, importing 1870
exporting to 1864
GETime command, using 1872
image, importing 1867
ImportGEData command 1873
ImportGEImage command 1873
ImportGEMesh command 1873
ImportGESurface command 1873
importing terrain data from 1868
mesh, importing 1870
PublishKML command 1873
PublishKMZ command 1874
render materials, creating from 1870
using as tool for conceptual design 1867
using with Civil 3D, about 1867
viewing timeline 1872
Google Earth publishing, coordinate system
support 2092
grading
(See also grading criteria, grading feature lines,
grading groups, grading styles)
auto balancing volumes 868, 2103
changing prompted values 801
command reference 869
corner overlap 804, 2108
creating 855–856, 862
deliverables 38
design tasks 37
distance, specifying 804
editing 818, 858, 863
editor 2110
elevation editor 820, 2111, 2113
extending by reference 828
filling a void area 862
footprint, editing 816
Grading collection (Settings tab) 798, 800
object components 796
overview 793

properties 864
regions 796
settings 801, 2097
setup tasks 37
slopes 804, 858–859
styles 865, 2116
surfaces 797–798, 806
surfaces, detaching 869
targets, manipulating 795, 804, 858–859
toolbar 2114
tools, using 2114
transition regions 797
transitions, inserting 859
troubleshooting 786
utilities 868
volume tools 794, 868
volumes 864, 868, 2121
workflow 37
grading criteria
applying multiple 859
creating 804
default, setting 806
editing 858–859
locking 804
new definitions, creating 2105
using 804
grading feature lines
assigning properties to 2132
statistics 2133
grading groups 806
changing 807
collection (Prospector tab) 800
creating 806
properties 865, 2113
settings 2103
grading styles
about using 802
applying 803
creating 802
editing 803
graphical view of objects 137
grid lines, deleting from surface 700
Grid Northing Easting, transparent command 1776
grid surfaces
about 647
about creating 650
creating from DEM 656
volume, creating 653
grids
display and styles 2648
setting parameters 2453
grip editing
alignments 1068
grading 863
introduction to 137
pipes 1347, 1412
profiles 1199
structures 1352
using in pipe networks 1347
GRS files, using with large surfaces 740

H
H&H (hydrology and hydraulics), tasks 768
hatch areas, adding to profile view 1216
hatch pattern, for parcels 877
hatch properties, in watersheds 2635
hatching 1216
headlight sight distance, in profile design 1168
HEC-RAS
commands 1890
exporting civil data to 1888
exporting data out of 1889
importing data from 1889
importing data into 1889
hiding objects 134
horizontal alignments, in roadway, railway, or site
design 923
Hydraflow Express Extension, about 1332
Hydraflow Hydrographs Extension, about 1332
Hydraflow Storm Sewers Extension, about 1332
hydraulic properties 2279, 2292
hydraulics and hydrology features 1332
hydrographs 1332
hydrology and hydraulics
(See also pipes, water runoff, water drop utility,
watersheds)
catchment areas, calculating 768
water runoff, managing 768

I
icons
drawing item modifier 161
drawing item state 161
project item state 160
project point database 187
project point state 188
Prospector tree 104, 116, 119
Settings tree 108
image draping 750, 1870, 2628
(See also visualization)
image overlay. See image draping
Import Building Site wizard 2010
Import Survey Data wizard
using to import data in various formats
importing
(See also LandXML data, importing)
alignment label sets 1047
architectural data 1892
breaklines 674
building site 1892
Civil data from HEC-RAS 1889
Civil data into HEC-RAS 1889
Google Earth elevation data 1870
Google Earth images 1869
Google Earth terrain data 1868
LandXML data 1883
points 525, 533
points from ASCII file 534

261
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site objects from LandXML 782
survey database settings 245
Vault projects 175
inquiries
performing on objects 1806, 2760
types 1808
Inquiry Tool, using 1806
inquiry, new features 13
interactive graphics, using with survey data 231
interference check
creating for pipe networks 2307
defined 2776
properties, setting 2309, 2316
interferences
properties 2311
styles 2312
interoperability, civil and architectural data 1891
intersecting breaklines, tools for fixing 770
intersection settings, style 1600
intersection styles, about using 1604
intersections
arc/arc 342
arc/azimuth 338
arc/bearing 336
arc/line 340
assembly set 1586
azimuth/azimuth 331
bearing/bearing 330
components 1586
Create Intersection wizard 2145
deleting 1617
description, editing 1602
dialog boxes 2145
line/line 333
name, editing 1602
points, saving 343
properties 1603, 2169
recreating corridors 1615
settings 1590, 2159
square offsets 334
styles 1604, 2170
survey, about 330
understanding 1585
updating regions automatically 1614
workflow 48
inverse reports, used in parcel export 897
isolating objects 134
item views
as editing method 137
graphical 100
list 99
orientation 100

J
joining, line objects
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K
K-value, about 1167
KML files
location 1871
using 2094
KMZ files
location 1871
using 2094
Kriging, method in surface smoothing 714, 2642
(See also Natural Neighbor Interpolation)

L
label sets, for sections 1227
label sets, using for creating alignments 1045
label styles
(See also labels, label text)
about 1646
add leader vertices 1684
adding content 2199
alignments 1043
content, adding or modifying 1663
copies, creating 1657
creating and editing 1656, 2180, 2203
curved text, adding to 1680
default, setting 1654–1655, 2179
deleting 1725
dependent (children), defining 1657
direction arrows for leaders 1699
expressions, adding in 2211
expressions, using in 1726
groups, creating 2206
in Toolspace 1651
independent, defining 1656
layers, specifying 1667
leader properties 1682
line components, adding to 1695
note, creating 1660
overrides in point groups 556
overriding text components in 2211
points 452
previewing 1652
profile views 1131
profiles 1129
properties, defining 1664
property field modifiers 1692
referenced text component 1693
sample line 1241
section 1242
section view 1243
selecting 1649
settings 1648
stacked text, adding to 1689
standard 1651
surface 752
surface contours 754
surface slopes 752
surface watersheds 754

surfaces spot elevation 753
tick components, creating 2192
using from other drawings and templates 1652
viewing available 1650
with text-for-each components 1694
Label Styles collection, using to manage labels 113
label text
(See also labels, label styles)
about 1686
background mask 1675
component, creating 2184
displaying when dragged 1685
formatting 1688, 2201
height, specifying 1679
overriding content 1714, 2211
special characters, adding 1690
labeling
alignment geometry points 1048
curves 640
feature lines 852–853
hydraulic properties in pipe networks 1413
lines 640
lines, arcs, polylines 1702
overall parcel length 1703
pipes and structures in plan view 1404, 1406
pipes and structures in profile view 1405, 1407
pipes and structures in section view 1406, 1408
pipes span 1408
labels
(See also alignment labels, label styles, label text, tags)
adding to drawings 1701
adding to lines, arcs, polylines 1702
alignment 1043
anchor and attachment points 1671
attaching leader to text 1685
behavior 1664
block components, adding to 1696
borders, adding to 1680
colors 1677
commands 1735
components, copying 1700
components, draw order 1701
content, adding to 1686
data band 1707–1708
defaults, seting 2179
deleting from drawing 1724–1725
direction, reversing 1722–1723
display properties, specifying 2181
displaying as tags 1666
dragged, managing 1681, 2196
draw order 1701
exploding 1720
flipping 1721
hydraulic properties 2279
levels of settings, defining 1654
line components, creating 2190
linetypes, assigning to 1678
lineweights, assigning to 1679
location, resetting 1719
location, resetting with grips 138

match line styles, changing 2338
match lines 1926, 1928
modifying 1712
moving in drawings 1716
new features 6
objects, about 1643
orientation, changing 1667
parcel area and segments 877
parcels 898
pinning to specific location 1722
pipe networks 1404, 1411
placement, changing 1669
plan production tools 1928
points 437, 451
profile view 1705, 1707
profile views 1132
profile, editing 1128
profiles 1127
properties 1712, 2204
property fields, using for content control 1691
readability, improving 1668
referencing other objects 1693
resetting 1719
resetting properties 1720
rotating 1677
sample line 1241
scaling 1653
section view 1705, 1707
sections 1227
sets, creating 1725
station index format 1051
station offset 1055
styles 68
surface 752
tags, numbering 1723
tangent intersection, adding 1056
text-for-each components 1694
tick components 1697
view frames 1921, 1928
workflow 21
x and y offsets, specifying 1676
LandXML
advantages of using 1875
code matching 1882
command reference 1885
coordinate system 1876
dialog boxes 2213
export settings 1882
export, supported elements 1878
exporting data to 2219, 2316
exporting survey data to 270, 2676
exporting to 1865
import settings 1880
import, supported elements 1876
importing and exporting site objects 782
importing from/exporting to 1875
importing survey data as 270, 2681
matching data with Civil 3D 1882
objects supported for import and export 1875
reporting tool, running 1757
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schemas, supported 1875
settings 1880, 2214
site objects, exporting to/importing from 1880
survey data 269
LandXML data
exporting 1884
handling duplicate 1880
importing 1883, 2213
translating and rotating 1881
unit conversion 1881
LandXML reports
generating 1757
(See also LandXML data, reports)
settings 1757
LandXML schemas, supported 1875
large surfaces, about 740
LAS files, as point cloud source data 593
Latitude Longitude, transparent command 1776
layer settings, object 82
layers
(See also base layer)
default, specifying in drawing objects 2221
in Civil object 73
properties for new 2222
selecting for new objects 2222
setting to 0 in Civil 3D styles 74
settings, changing 2076
layout profiles
creating 1143
curves, used in 1113
defined 2776
editing 1191
settings, configuring 2394
layout settings, pipe network 2269
layout toolbars, using 121
layout tools
(See also alignment layout tools)
editing pipe networks 1346
profile 2419
layouts
Select Layout as Sheet Template dialog box 2338
selecting for sheet page 2558
leaders
displaying in labels 1682
editing in labels 1684
least squares analysis
setting defaults for 242
specifying settings for 2686
using 389
legend tables, surface 763, 1749
Length Check rule, in pipe networks 1395
LiDAR classification scheme 593
LiDAR data
classification 2383
classifying 593
using to create point clouds 593
line anchor points 1673
line of sight tools
point to point 1845
sight distance along corridor 1846
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zone of visual influence 1848
lines
command reference 643
creating by best fit 628
creating by side shots 615, 2228
creating by specifying angles 611, 614
creating by specifying coordinates 608, 610
creating by specifying stations and offsets 615
creating from points 605, 607
fixed, adding to alignments 971
floating with spirals, adding to alignments 1030
floating, adding to alignments 976
free, adding to alignments 981
labeling 1702
lenght, extending 617
multiple, attaching to existing entities 637
numbering newly created 2210
perpendicular, drawing 619
projection 793
segments, labeling 641
tangent, drawing 617–618
linetype settings, AEC Editor 1858
linework code sets
creating 252
examples 253
linking, objects to external reference documents 1804
list view of objects 137
list views
changing column properties 102, 2022
copying items from 103
customizing 101
selecting items in 100
shortcut menu, using 102
locations, specifying in drawings 133
locking
grading criteria 804
point groups 560
points 453
lot lines, for grading 793

M
Map 3D
exporting Civil data to 1862
Map 3D point cloud objects vs. Civil 3D point cloud
objects 602
Mapcheck Analysis 1795–1796
Mapcheck Analysis Report
adjustment 1802
creating 1797
inserting as mtext object 1803
Mapcheck command
default settings 1803
mapcheck reports
entering data in 1800
using in parcel export 897
markers
catchment point 2620
survey figure 2707

masking
alignment regions 932, 934
label background 1675
surface area 662
masks
about 719
creating 722, 2621
deleting 725
display order, controlling 724, 2638
inside 721
modifying 724
outside 721
render materials, using with 722
render only property 722
surface 645
types 721
viewing 723
mass haul
(See also mass haul diagrams, mass haul lines, mass
haul views)
balancing from grade points 1313–1314
line properties, editing 1316, 2574
line settings, editing 2568
line styles, editing 1317
properties, editing 1316–1317
view styles, editing 1318
volumes, calculating 1312
mass haul diagrams
See also mass haul, mass haul lines, mass haul views
creating 56, 1314, 2564
display options, setting 2565
setting balancing options 2566
using 1312
mass haul lines
(See also mass haul, mass haul diagrams, mass haul
views)
balancing options, editing 2575
display options, editing 2577
free haul options, displaying in graph 2577
setttings, editing 1319
styles, edtitng 2576
mass haul views
(See also mass haul, mass haul diagrams, mass haul
lines)
display options, editing styles 2586
graph options, vertical scale 2579
grid options, editing 2580
properties, editing 1316, 2578
settings, editing 2568
style settings, editing 1320
styles, editing 2579
title annotation, editing 2581
Match Length transparent command 1785
match lines
ambient settings, managing 2322
collection (Prospector tab) 1934
defined 2778
display 1933
display properties, changing 2337
editing 1923

label styles, changing 2338–2339
labeling 1926, 2339
numbering in veiw frame groups 2333
objects 1932
properties, managing 2332
properties, viewing 2332
settings 1934, 2322
styles 1933, 2337
Match Radius transparent command 1786
material analysis 1275
material criteria, defining 2567
material lists
defining 2562
editing 1278, 2518, 2572
generating 1282
material volume tables, generating 1290
(See also quantity takeoff)
Maximum Pipe Size Check rule, in pipe networks 1400
measurement corrections
formulas 241
survey 240
measurement type defaults, survey 239
measurement units, setting in survey database 238
memory, optimizing usage 97
menus, application 91
(See also ribbon, toolbars, user interface)
merging parcels 874
mesh, as elevation data 1870
mid-ordinate distance, in arc tessellation 664
midplane extrusion modifier, in Part Builder 1443
migrating
out date databases 217
migrating data shortcuts 156
migrating, country kits 141
minimum distance lines, displaying 770, 1812
minimum distances
between 2D entities 1811
between surfaces 770
MMS files, using with large surfaces 740
modeling
3D, using modifiers 1443
degree of freedom, defined 1434
parts, in Part Builder 1436
parts, tips for 1452
models
adding work planes for creating 1453
as used in Part Builder, defined 1434
dimensions, adding 1440, 1455
geometry features, about 1439
in Part Builder 1436
modifiers, applying to 1460
parameters, configuring 1447
modifiers, about using in 3D modeling 1443
multi-site Vault 164
multi-view blocks
about 1822
adding to DesignCenter 1826
attributes, updating 1833
creating 1823, 2757
editing names 2759
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location of predefined 1823
modifying 1829
selecting components for 2759
multipurpose styles, about using 68

N
name template 74, 2022
naming restrictions 75
naming, civil objects 74
Natural Neighbor Interpolation, method in surface
smoothing 713, 2642
(See also Kriging)
network layout tools, editing pipe networks 1346
new features in AutoCAD Civil 3D 2011 3
next counter 74
NNI (Natural Neighbor Interpolation) 713
non-control points
creating 283
editing 279, 285
properties 2692
survey 283
non-destructive breaklines, adding 673
North arrow 1903
Northing Easting transparent command 1775
notes
adding to drawings 1709–1712
attaching 1804, 2749

O
object collections
item view 137
using to access drawing information 110
object compatibility 141
Object Enabler, using to veiw drawings 1857
object projection
in visualization 1218
profile view 2442
styles 1270
styles in profile views 1126
to section views 2512
object properties 72
object relationships
alignments 925
profile 1116
sections 1228
Object Style collection, using to manage styles 111
Object Viewer
supported file formats 2750
using 1805, 2750
objects
(See also AutoCAD objects)
alignment 923
assembly 1538
Civil 3D, understanding 63
corridor 1473, 1587
exploding 1858
grip editing 137
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hiding 134
isolating 134
item view of 137
label, about 1643
layer settings 2076
list view of 137
match line 1932
naming constraints 75
naming new 74, 2022
points 437
properties 72
properties of 138
relationships 64
sample line 1226
section 1226
section view 1228
selecting 2027
sharing between drawings 143
styles 66
subassembly 1556
surface 647
view frame 1931
view frame group 1930
viewing 1805
observations
creating 291
creating with survey command language 292
editing 279, 305
survey 289
offset alignments
create 956
edit 1077
Offset from Centerline, in section data bands 2530
offset range, editing 2506
offset work planes, about 1438
(See also reference work planes, work planes)
operation list, surface 661
Oracle, datastore as GIS data source 2637
out-of-date point groups 557–558
overlapping site objects 786
overrides
point group 437
point label style 556
point raw description 556

P
Pack and Go feature, as portability solution 168
package files 1565
panning, to points 456
Panorama window
about using 119
displaying 120
displaying vistas in 119
Panorama window, editing with 138
paper space, scaling labels in 1653
parabolas, creating by best fit 635
parabolic curves, in vertical curve design 1166

parcel label styles
about 876, 899
applying 903
based on other styles 903
changing 885
creating 900
deleting 903
editing 901
parcel labels
about 898
adding or deleting 904
area 907–908
hiding or showing 909
segment 905, 907
settings 898
parcel styles
about 876, 894
applying 896
based on other styles 895
creating 894
deleting 896
display order, changing 893
editing 895, 2253
setting up 880
parcel table styles
about 876, 910
applying 912
based on other styles 911
creating 910
deleting 911
editing 911
parcels
(See also sites)
about 873
analysis report 2242
appearance, changing 885
area labels 874
as related to sites and alignments
collections 874, 879
collinear lot lines 786
command settings 891
components 873
creating 39, 879, 2235
creating by layout 881
creating by subdividing 882
creating from objects 881
custom properties 920
defined 2779
deleting 889
dialog boxes 2235
display order 893
display settings 880
editing 885–886
editing geometry 891
editing subdivided 887
exporting data 897
finding in drawings 885
getting started with 880
incomplete 876, 2246
inside sites 875

874

labeling overall length 1703
labels 898
Land Desktop, importing 2234
layout parameters, editing 2243, 2245
line segments, editing 816, 818
merging 890
naming 918, 2255
nodes 873
numbering 916, 918–919, 2255
numbering newly created 2599
overlapping lot lines 786
positioning in collection 875
properties 878, 892, 2251
properties, editing 892, 2241
relationships 873
renumbering 2742
reports, generating for 2474–2475
segment types 873
setting up 880
settings 878, 880, 891, 2236
styles for 877
tables 642, 898, 912
topology 873
unclosed 876, 2246
user-defined properties 920
within sites 784
workflow 38
Parcels collection, using to access parcels in
drawings 878
Part Builder
(See also parts)
about using 1432
constraints, defined 1434
creating pipe network parts using 1435, 1452
defined 2779
model parameters 1447
modeling parts in 1453
modifying parts using 1465
placement point 1447
terminology and concepts 1434
part catalogs
(See also parts, parts lists)
about using 1326
accessing for pipe networks 2301
default location 1386
defined 2779
full, creating 1382
veiwing content 2273
part family, description 1436
parts
(See also Part Builder, parts lists, part catalogs, pipe
networks)
adding rules to 2307
changing size 2306
configuration, specifying 1435, 1453
constraints, adding 1441
domain, defined 1436
domains, defined 1434
insertion position, defining 1461
modeling in Part Builder 1436, 1453
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modeling in workplanes 1437
modeling tips 1452
modifying 1465
names, changing 1436
optional properties, assigning 1385, 2300
parametric, defining 1434
preview image, generating using Part Builder 1461
profiles (2D), creating 1443
properties 1378
size parameters 1448, 2300
sizes, adding to models 1456
testing using Part Builder 1464
types and subtypes, about 1436
validating in Part Builder 1462
parts lists
(See also parts, part catalogs)
creating new 2271
defined 2779
full catalog parts list 1382
linking to pipe network 2301
passing sight distance, in profile design 1167
path modifier, in Part Builder 1445
pavement design 1167
pay items
categorizing 1296, 2589
editing 2574, 2588
filtering 1295, 2589
formula parameters, editing 2588
formulas, applying 1305, 2587
formulas, editing 1305, 2587
formulas, modify using 1304
highlighting 1297, 2589
information, exporting to Autodesk QTO 1311
lists, categorizing 2588
lists, editing 2574
lists, filtering 2588
lists, managing 1295, 2589
managing 1293, 1295, 2589
opening files 1294, 2587
opening files, advanced options 2561
quantities report, exporting as TransXML 1310,
2594
quantities report, setting formats 1309, 2594
quantities, reporting 1308, 2594
tables, placing in drawings 1308
tagging areas with 1299
tagging corridors with 1301
tagging objects with 1298, 2589
tagging objects with, manually 1298
tagging pipe network parts with 1301–1302
PENZ format, for point files 692
pinning labels 1722
Pipe collection (Settings tab) 1330
Pipe Drop Across Structure rule, in pipe networks 1396
pipe network sections
octagonal appearance 1366
properties 1257, 2510
pipe networks
(See also parts, pipes)
about 1325
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accessing parts catalogs 2301
changing part sizes 1387
changing pipe properties in 2275
commands 1428
controlling shape in section view 1366
converting rules 1403
copying 1361
creating 1332, 1334, 2259–2260
creating a reference (shortcut) 2451
creating alignments from 2261
creation settings 1344
deleting 1361
display 1328
displaying in section views 1366
editing operations with 1326
editing settings 1343
elevations, matching 1363
energy grade line 2279, 2292
flow direction, changing 1352
grip editing 1347, 1352
hydraulic properties 2279, 2292
interference check properties 2309, 2316
interference properties 2311
interference styles 2312
labeling 1404, 1411
labeling pipes associated with structures 1694
layers, defining 2301
layout settings 2269
layout tools 2268
Length Check rule 1395
new features 7
object 1326
octagonal appearance 1366
part catalog, default location 1386
parts, disconnecting 1359
pipe display in 2281
Pipe Drop Across Structure rule 1396
pipe rules 1394
Pipe to Pipe Match rule 1396
properties 2269
proximity checking in 2308
quantity takeoff 2272–2273
reference, creating 1342
renaming 2315
renaming parts 1362
rendering parts of 1367, 1416
resetting reference labels 1343
setting up data for 58
settings 1329
structure resize behavior 1354
structure rules 1396
structure settings 2267
structure style 2294
styles, modifying 1345
swapping parts 1358
using vertex elevations 2261
vistas 1346, 2302
workflow 57
Pipe Networks collection (Prospector tab) 1329
pipe tables, creating in drawing 2313

Pipe to Pipe Match rule (pipe networks) 1396
pipes
(See also pipe networks, pipe network sections)
connected, matching elevations 1363
curved, drawing 1340
diameter, specifying maximum 1400
Land Desktop, importing 2234
length, specifying minimum and maximum 1395
new features 7
object rules 1394
properties, changing 2276
rules for modeling 1394
rules, converting from VBA to .NET 1403
rules, editing 2274
settings, changing 2267
straight, drawing 1339
table styles 1414
width, changing 1349
placement points, in Part Builder 1447
plan production tools
about 1901
before using 1902
commands 1935
Create Sheets wizard 2327
Create View Frames wizard 2322
creating plan/profile sheets 1909
data references, using with 1928
default creation settings 1914
dialog boxes 2319
display 1929
labeling 1928
layouts, selecting 2338
profile view options 1915
section sheets 1934
settings 1913
styles 1915, 1929
templates 1902
using with Vault 1928
view frame group object 1930
view frames, creating using 1904
wizards 1904
wizards for plan/profile sheets 1909
workflow 61
plan production, new features 9
plan/profile sheets, creating 1909
plane extrusion modifier, in Part Builder 1444
point clouds
about 594
adding Civil 3D properties to 602
adding points to 599, 2385
AutoCAD vs. Civil 3D 602
bounding box 594
command reference 604
components 594
creating 596
database files 594
dialog boxes 2379
display view density, modifying 599
feature settings 2379
ISD files 594

LiDAR data source 593
Map 3D vs. Civil 3D 602
new features 8, 13
points, elevation ranges 2381, 2384
properties 601, 2383
Prospector collection 596
removing Civil 3D properties from 602
settings 2379
source file formats 593
stylizing 594, 598
surfaces from 600
TIN surfaces from 600
Point collection, in Settings tree 438
point creation commands
Horizontal Alignment 489
Interpolation 503
Intersection 470
miscellaneous 458
Slope 512
Surface Elevation 499
point data
backward migration 543
converting formats 536
exporting 534
transferring between files 536
Point Editor
about using 2370
opening 518
shortcut menu 519
point file formats
coordinate zone transformation property 526
creating 529
deleting 532
editing 532, 2360
importing and exporting 2359
managing 526, 529
printing 529
properties 526–527
setting type of 2360
sharing 529
specifying columns to include in 2362
understanding 525
using properties to perform calculations 528
point files
adding to surface 692, 2618
copying formats 531
creating 693
formatting options 527
importing multiple 263–264
using as surface data 692
point filters, in transparent commands 1787
point groups
(See also point lists)
about 693
about using 553
accessing in drawings 554
adding imported points to existing 2365
adding points to 568, 2348–2349
adding to surface 694
All points 554

Index | 2807

case-sensitive description matching 561
creating 561, 2365
creating from existing 566–567
default styles 555
defined 2780
defining using queries 2351
deleting 568
display order, changing 558, 2358
editing 567
elevation override 556
including points using description keys 581
locking 560
locking and unlocking 560
managing 556
out-of-date 556–558
overriding point properties 555
point style overrides 556
printing 561
properties 553, 567, 2348
properties override 556
queries 565
raw description override 556
removing points from 2350
updating 2359
point labels
about 451
editing label text 452
style overrides 556
styles 452, 556
point lists
(See also point groups)
defined 2780
locking and unlocking 560
point locations, specifying by
angle and distance 1769
azimuth and distance 1773
bearing and distance 1770
deflection and distance 1771
grade and length in profile view 1784
grade and station in profile view 1784
grid northing and grid easting 1776
latitude and longitude 1776
northing and easting 1775
point name 1779
point number 1777
selecting point 1778
station and elevation in profile view 1780, 1782
station offset 1779
using alignment and COGO point 1782
using alignment and surface 1781
using side shots 1774
Point Name (alias) transparent command 1779
Point Number, transparent command 1777
Point Object, transparent command 1778
point of vertical intersection (PVI), in grading 2122
point references, exporting to LandXML 1882
point removal, as surface simplification 715
point styles
copying 450
creating 450
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default tempalte, specifyig 439
editing 451
overrides 556
point symbols
defined 2780
point symbols, manipulating using description key
parameters 578
points
(See also point data, point file formats, point files,
point groups, point labels, point styles, point
symbols)
about 435
adding from drawing objects 2618
adding to point cloud 599
adding to point groups 2349
adding to project 189
adding to surface 702
changing appearance in drawing 32
converting LDT points 544
converting to different coordinate zones 537
corridor, exporting as COGO points 1531
creating 31, 456, 489, 497, 516, 2357
creating at specified elevation 1783
creating new in survey 319, 321–322
creating using description keys 579–580
custom properties 445
default name template, specifying 440
deleting 519
deleting from surface 703
display and styles 2649
displaying all in drawing 554
displaying list of 2354
drawing template, creating 29
duplicate names, resolving 2375
duplicate numbers, resolving 265, 2374
editing 517
editing utilities 521
elevation, changing 521–522
exporting 1865, 2366
formats, converting 536, 542
importing 533, 580, 2364
importing from ASCII file 534
importing from Land Desktop 533
interpolation/extrapolation in surface
smoothing 712
label styles 452
Land Desktop, importing 2234
LiDAR, classification 2383
listing available point numbers 541
locking and unlocking 453
managing 453
modifying elevation 703
moving on surface 704
new features 7, 13
numbering settings 442
numbering, enabling 290
object 437
overriding properties 555, 2353
panning to 456
planning before creating 457

printing 456
project management commands 189
properties 437, 520
removing from point group 2350
renumbering 523
reports, generating for 2476
resetting checked-out 2458
rotating labels 517
settings 439, 2343
styles 437, 449, 2354
styles overview 449
symbols, appearance 2355–2356
table styles 452
tables 452, 2375
transferring to external files 2367
update settings 441
user-defined properties 445
Vault project 187
workflow 29
zooming to 456
Points collection (Prospector tree) 438
points of intersection, editing 1064
points of vertical intersection (PVI)
defined 2780
editing 1193
recording data about 1148, 2413
polylines
convert to feature lines 793
converting 2D to 3D 854
converting 3D to 2D 854
converting lines to arcs 842
creating alignments from 952
deleting PIs 836
editing 816, 854
editing elevations 818, 855
filleting 841
inserting PIs 834
joining 836
labeling 1702
offsetting 848
removing vertices 846
reversing direction 837
weeding vertices 846
pond, stage storage volumes 743
previewing
civil objects in Prospector tree 100
printing, description keys 584
Profile collection (Settings tree), using 1117
Profile Grade Length transparent command 1784
profile grade points
edit in section view 2512
Profile Grade Station transparent command 1784
profile layout tools
drawing tangent-tangent profiles 1145
Profile Station Elevation transparent command 1780,
1782
profile view bands 1128
profile views
command reference 1221
creating 1208

creating with wizard 2397
data, viewing 1968
editing 1213
label styles 1131
labels 1128, 1132, 1705, 1707–1708
multiple 1206, 1210–1211
multiple line 1211
multiple, creating 1209
object 1115
pipe networks, changing properties 2434
properties 1119, 2427
settings 1121
shortcut menu 1119
single 1206, 1208
split 1138, 1206
stacked, creating 1211
stagger labels 1707
style, changing 1214
styles 1124, 2435
working with 1206
Profile Views collection 1117–1118
profiles
adding tangents to 1157
adding to a profile view 1213
best fit entities, editing 1200
command reference 1221
constraint-based entities, adding 1156
continuous, creating 1165
converting AutoCAD entities to profile
subentities 1196
copying 1152, 2392
copying data 2392
corridor feature lines, exporting as 1530
creating 1141, 1145
creating by best fit 1154
creating from surfaces 2396
criteria violations, correcting 1203
criteria-based design, applying 1202
curve and spiral settings 1147
curve and tangent attribute values, editing
curves, adding 1166
data, analyzing 2417
data, viewing 1967
defined 2780
dialog boxes 2389
drawing tips 140
elevations, modifying 2443
files, format requirements 1148
from file 1145
grip editing 1199
hatching 1216
label styles 1129
labeling multiple 1705
labels, managing 1127–1128
Land Desktop, importing 2234
layout, creating 1143
layout, editing 1191
new features 14
object relationships 1116
parameters, editing 2416

1198
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Part Builder 1443
preparing data for 51
properties 1119, 2423
quick, creating 1153, 2405
reference, creating 1150
reports, generating for 2469–2471
selecting for corridor creation 2062
settings 1120
shortcut menu 1118
standards 50
styles 1122, 2426
subentities, deleting 1197
subentities, selecting 1192
superimpose options 2443
superimposed, creating 1149
surface, creating 1142
tangent-tangent, drawing 1145
tools for drawing and editing 2419
types and definitions 1113
workflows 50
Profiles collection (Prospector tree) 1117
project drawings
about 159
adding to project 177
checking in 179
checking out 178, 2449
detaching from project 182
getting latest version 180
opening 180
portability solutions for 168
resetting checked out 181
source, undoing check-out of 186
synchronizing with project data 182
Vault, working with 176
project folders, Vault 164
(See also project management, working folders)
project items, Prospector tree 159
project management
(See also project folders, working folders)
commands 159
object sharing 143
working folders 165
project objects
checking out source drawing 185
copying to drawing 183
creating 183
creating references 183
getting latest version 184
opening source drawing 185
partitioning into drawings 165
promoting 187
references 159
resetting checked out source drawing 186
sharing with others 177
source drawing 176
switching to source drawing 185
undoing check out of source drawing 186
updating 184
working with 183

2810 | Index

project points
about using with Vault 159, 187
adding to project 189
checking in 191
checking out 190, 2450
copying into drawing 192
creating from drawing points 2445
creating read-only 2456
database, creating 30
getting latest version 192
list view 188
modifying 523
protecting 192, 2458
removing from project 193, 2455
resetting checked out 194–195
undoing checkout 194–195
unprotecting 193, 2460
updating 2449, 2459
projected objects
adding to profile views 1219
adding to section views 1265
in profile and section views 1218
removing from profile views 1221
removing from section views 1269
section views, adding to multiple 1265
section views, editing in 1269
section views, labeling in 1270
styles in profile views, editing 1220
projection lines, grading 793
projection method, grading 796
projection to profile view 2442
projection to section views, new features 9
projects
active, identifying 172
adding drawings to 177, 2445
administration 171
controlling data 165
creating 171
creating references to project objects 183
creating user accounts 167
creating user groups 168
data protecting 165
data, partitioning 165
deleting 173
detaching drawings from 182
displaying in Prospector tree 104, 158, 2458
exporting 174
files created automatically 167
folders, creating new 2457
importing 175
labeling milestones 174
legacy, migrating 176
managing 143
offline, working with 173
partitioning project data across drawings 165
project object source drawings 185
properties, viewing 2457
Prospector collection, Vault dependency 104
protecting project data 165
references to project objects 159

restricting access to project data 165
source drawing 176, 183
synchronizing data with 182
Vault, working with 169
working folder, creating 170
properties
AutoCAD 139
Civil object 72
custom parcel properties 920
custom point properties 445
introduction to 138
property fields, adding to label text 1691
Prospector tab
item view 137
properties of objects 138
Prospector tree
controlling items displayed in 105
described 105
displaying projects in 104, 172
dragging items within 568
drawing and project items in 159
functions shared with Settings tree 98
graphical item view 99
icons 104, 116, 119
item view 99
list view 99
master view 159
orientation 100
previewing objects 100
Projects collection, Vault dependency 104
proximity breaklines
creating 670
defined 668
proxy graphics, using 1856
PublishKML command 1873
PublishKMZ command 1874
PVI (point of vertical intersection), creating at intersecting
grade line 1165
PVI (points of vertical intersection) 2413

Q
quantities
pay items, reporting 1308, 2594
report, generating 2595
quantity reports, using in volume calculations 1290
quantity takeoff
(See also volumes, sections, material volume tables)
calculating 1306, 2563
command settings, editing 2591
computing 1306, 2563
criteria, creating 1278–1279, 2592
criteria, editing 1278, 2592
defined 2781
factors 1280
new features 8
pipe networks 2272–2273
reporting 1290
selecting sample line group 2595

settings, editing 1275, 1319, 2569
settings, using 1275
supported quantity types 1279
table styles 1292
tables and reports, generating 1290
Query Builder
creating point group using 563
expressions 565
set operators 565
Quick Access toolbar 91
Quick Properties palette 72

R
radius, feature line 838
raw descriptions
(See also description keys)
defined 2781
interpreting as parameters 573
matching, using to add points to point groups 2349
override in point groups 556
sample 572
using with description keys 571
rebuilding surfaces 646
reference work planes, about 1439
(See also offset work planes, work planes)
Referenced Text component 1693
refill factor, in quantity takeoff 1280
(See also quantity takeoff, volumes)
regions, corridor 1487
regression, analyzing results of 1972, 2391
RENDER command, using for Civil objets 1764
render materials
about 1761
adding to drawings 1763
applying to objects 1763
Civil 3D specific 1763
copying 1762
creating 751, 1762, 1870
defining for civil objects 1763
dialog box 2021
publishing to Google Earth 1871
selecting 2640
using with masks 722
rendering, Civil objects 1764
renumbering, points 523
reports
Alignment Design Criteria Verification 2468
best fit alignment 1972
best fit profile 2391
building site, export 1892
Corridor Daylight Line, creating 2478
Corridor Feature Line, creating 2477
Corridor Lane Slope, creating 2478
crossing breaklines 772, 2622
Daylight Line, creating 2478
default web browser 1759
Feature Line, creating 2477
file types 1759
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generating 1758
Incremental Station Elevation Difference,
creating 2479
Incremental Station, creating 2465
LandXML, creating 2476
Lane Slope, creating 2478
Map Check, creating 2474
milling 2480
new features 8
options, specifying 1757
Parcel Volume, creating 2475
pay item quantities 1308, 2594
PI Station, creating 2464
Profile Design Criteria Verification 2469
Profile Incremental Station, creating 2470
PVI Station and Curve, creating 2469
quantities 2595
quantity takeoff 1290
saving 1759
setting up 1757, 2464
settings 1757, 2464
Slope Stake, creating 2472
Stakeout Alignment 2466
Station Offset to Points, creating 2476
style sheets for quantity takeoff 1291
survey database change 221
types 1757
Vertical Curve, creating 2471
Reports Manager
about 1757
editing items in 1760
Revit Architecture data, importing to Civil
drawings 1891
ribbon, controls 87
(See also menus, toolbars, user interface)
rider comfort, in profile design 1168
right of way, creating 888
rim and sump depth grip, using in pipe networks
river bank, selection for HEC-RAS export 1888
road design
alignments in 923
standards 1091
vertical curves in 1166
(See also K-value)
roundabouts
approach roads 1628, 1632, 1636, 1638
central area 1627
creating 1631
deleting 1637
dialog boxes 2145
drawing standards 1639
driving direction 1624
editing 1634
moving 1635
new features 14
parameters 1630
prerequisites 1625
presets 1639
slip lanes 1629, 1633, 1636, 1639
understanding 1623
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workflow 49
rounding corners, in feature lines
runoff, analyzing water 768

841

S

1353

sag curves, types 1114
(See also crest curves)
Sample Line Collection (Settings tab) 1230
sample line groups
collection, prospector 1228
creating 2485
editing 2485
properties, editing 2515
resampling sections of 2533
sample line styles
display options, editing 2526
editing 2525
sample lines
collection (Settings tab) 1230
creating 1246
creating by station range 2491
creating from a corridor 2493
display settings 1231
display style 1252
duplicate, resolving 2514
editing 1250
editing, grip 1251
editing, parameters 1250
labels 1241
labels, managing 2521
objects 1226
perpendicular 1251
properties, editing 1254–1255, 2522
resolving duplicates 2514
restoring rotated 1251
selecting for quantity takeoff 2595
settings 2499
settings, editing 1231
sources, resampling 1253
styles 1234
styles, copying 1234
styles, creating 1234
styles, deleting 1235
styles, editing 1235
vertices, editing 2507
working with 1246
scale factor, in point export 529
scaling, labels in paper space viewports 1653
schemas
GIS 2637
LandXML, supported 1875
SDF format, exporting to 1889, 2761
Section Collection (Settings tab) 1230
section objects
about 1226
corridor, about 1228
pipe network, about 1228
section sheets, creating 1934

section styles
creating 2534
display options, editing 2535
editing 2534
Section View Collection (Settings tab) 1231
section view group plot styles, editing 1240
Section View Groups Collection (Prospector tab)
section view styles
copying 1238
creating 1238
deleting 1239
display options, editing 2557
editing 1239, 2550
editing group plot styles 1240
graph options, editing 2550
grid options, editing 2551
title annotation options, editing 2552
updating group layout 1240
section views
band set styles, editing 2535
band styles, editing 2528
bands, specifying source surfaces 2535
collection (Settings tab) 1231
creating 1258, 2495
creating multiple 2486
data bands, about using 1245
editing 1258
group bands, editing properties 2538
groups collection (Prospector tab) 1229
groups, editing properties 2540
labels 1705, 1707
multiple, settings 2508
object projection to 2512
objects, about 1228
properties, editing 1263, 2542
settings 2501
settings, editing 1233
volume table properties, editing 2547
working with 1258
sectional material volumes, reporting 55–56
sections
collection (Prospector tab) 1229
collection (Settings tab) 1230
corridor, editing 2065
corridor, options 2065
corridor, viewing 2065
corridor, viewing and editing 1519, 1523
creating 1246
defined 2782
display options, editing 2530
drawing tips 140
edit in section view 2531
editing 1253
label styles 1242
new features 9
object relationships 1228
preparing data for 53
properties, editing 1256, 2532
settings 2501
settings, editing 1232

1229

sources, resampling 1253
standards, defining 52
Station Tracker 140
styles, copying 1236
styles, creating 1236
styles, deleting 1237
styles, editing 1237
understanding 1225
workflow 52
Sections Collection (Prospector tab) 1229
selection set, creating 133
semivariograms, in surface smoothing 714
(See also Kriging)
set operators, Query Builder 565
settings
abbreviations 83, 2077
alignment 929
ambient (general) 84, 2078
assembly 1540
assembly, editing 2001
building sites 2009
command-level 79, 85
coordinate transformation 2074
corridor 1474, 1480
corridor, editing 2053
description keys 573
distance 2080
drawing 130, 2073
drawing units 2078
drawing-level 78–79
feature-level 79, 84
grading 801
Intersection Settings dialog box 2159
LandXML 1880
layers 2076
mass haul line 2568
mass haul view 2568
match line 2322
multiple section views layout 2508
object layers 82
object-level 79
overriding object-level and ambient 79
pipe networks 2262
pipes 2267
point 439
point default styles settings 439–440
profile 1120
profile view 1121
quantity takeoff 2569
quantity takeoff commands 2591
quantity takeoff, editing 1275
quantity takeoff, using 1275
sample line 1231, 2499
section 2501
section view 2501
structure objects 2267
subassembly, editing 2002
surface 2629
tooltips 2079
transformation 81
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transparent commands 1767
unitless 2080
units 80, 2073
update points 441
View Frame Group Settings dialog box 2319
view frames 2322, 2339–2340
zone 80, 2073–2074
Settings tree
about using 109
Commands collection in 114
controlling items displayed in 108
dragging items within 115
functions shared with Prospector tree 98
General collection in 112
icons 108
Label Styles collection in 113
Object collection 110
Object Style collection in 111
Table Styles collection in 113
setups
deleting from list 289
instrument, creating for surveys 285
properties, editing 2693
viewing and editing 279, 287
shape files, as GIS data source 2637
sheets
creating plan/profile using wizard 1909
properties, editing 2558
styles, defining 2559
shortcut, relationship with data reference 146
shortest distances
between objects 770, 1811
between surfaces 770
vertical, between objects 1812
SHP files, as GIS data source 2637
Side Shot transparent command 1774
side yard, defined 2782
sideshots
creating lines using 615
defined 2782
specifying point location using 1774
simplifying surfaces 715
sites
(See also parcels)
3D geometry, defining 2597
about 779
collection 780
collinear objects 786
constraints for manipulating 783
copying objects 790, 2600
creating 783
defined 2782
deleting 786
description, editing 2597
editing properties 781
exporting to/importing from LandXML 1880
interaction with alignments 779–781
managing 783
moving objects between 789, 2599
numbering 2210, 2599
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overlapping objects 786
overlaying 875
parcel properties 784, 2256
parcels 875
properties, editing 784
removing alignments 786
removing overlapping feature lines 786
removing overlapping lot lines 786
specifying for topology objects 785
topology collection 781
troubleshooting 786
slope information, displaying 1795
slope labels
adding 754
styles 752
slope patterns
corridor, adding 2040, 2053
grading 2122
styles 802, 2117, 2123
using 802
smoothing
contours 2647
feature lines 844
surfaces 646, 713, 2642
snapshots, surface 732
Softdesk point blocks, converting to COGO points 542
source drawing 176, 183
source folder 2763
Spatial Data Format (SDF), exporting Civil data to 1862
Spatial Data Format (SDF), exporting to 2761
special characters, adding to label text 1690
speed-based design 935
spiral curve spirals (SCS), adding to alignments 1038
spiral definitions
cubic parabolas 1015
sinusoidal curves 1014
spirals
bi-quadratic (Schramm) 1016
Bloss 1013
clothoid 1013
cubic 1015
curve equations 1014
definitions 1011, 1014
fixed, adding to alignments 1017
formulas 1011
free, adding to alignments 1018
parameters 1012
split points
controlling elevation at feature line crossing 866
converting into geometry points for editing 834
split profile view 1138
spot elevation labels
adding 756
styles 753
stage storage volumes 743
staggering data band, labels 1707
standards, section 52
station equations 933
station equations, alignment 923, 933
station frequency, corridor 1492

Station Index Format, about using 2088
station labels, alignment 1044
station offset labels
adding 1055
fixed point 1056
Station Offset transparent command 1779
Station Tracker 140
stations
changing station character format 1051
defined 2783
defining in survey 287
display settings 2088
displaying in station index format 1051
duplicate values, creating 2022
frequency along corridors, setting 2060
reference points, defining 1965
statistics, for surfaces 739, 2662
stopping sight distance, in profile design 1167
storm sewers, design and analysis 1332
stream analysis 1887
Structure collection (Settings tab) 1330
structure objects
defined 2783
in quantity takeoff 1280
properties, changing 2288
setings, changing 2267
table styles 1415, 2314–2315
tables, creating 2313
style settings
intersection 1600
pipe networks 1345
surface 738, 749
style sheets, for quantity takeoff reports 1291
styles
alignment 946
alignment label 1043
alignment table 1058
assembly 1550
common settings, changing 70
concepts for 66
corridor 1473, 1588
corridors, settings 1480
display, in Object Viewer 2750
grading 802
intersection 1604
labels 68, 1646
managing for objects 2017, 2021
match line 1933
multipurpose 68
naming constraints 75
object and label 66
objects 66
parcels 876–877
pipe networks 1328
plan production tools 1915, 1929
point 437, 449
point cloud 2381
point group default 555
previewing 2020
profile 1122

profile view 1124
quantity takeoff table 1292
subassembly marker, creating from existing
styles 1579
surface 748
survey 216
tables 70
view frame 1931
subassemblies
(See also assemblies)
adding to tool palettes 122
catalogs, localizing 1582
code set styles 1567, 1577
code set styles, editing 1578
codes 1577
codes, adding to 1576
codes, link 1573, 1575
codes, localizing 1580
codes, point 1571
codes, using with 1567
collection (Prospector) 1556
collection (Settings) 1557
commands 1583
conditional 1555
conditional, and assemblies 1545, 1555
converting VBA to .NET 1564
creating 1557
creating from polylines 1558, 2001
creating from tool palettes 1557
custom, designing 1568
defining 1555
deleting 1562
editing 1562
grip editing 1526
groups, managing 1562
importing to a catalog 2003
importing to a tool palette 2003
inserting at left and right sides of an assembly 1560
layout mode 1555
link style, defining 2004
location of 121
managing 1562
marker style, defining 2004
marker styles, creating from existing styles 1579
modeling mode 1555
object 1556
package files 1565
pavement structure 1568
previewing 1563
properties 1556
properties, editing 2006
selecting for insertion 2062
settings 1556
settings, editing 2002
shape styles, editing 2006
sharing 1565
stock, adding a new code 1581
stock, modifying default codes 1581
style 1556
tool palettes, localizing 1582
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using 1555
superelevation
about 1091
attainment methods 1092
calculate rate by formula 1099
curve manager 1102
divided roads 1097
editing design criteria 1104
new features 9
rates and transition tables 1091
undivided roads 1096
variables 1092, 1094
workflow 42
superelevation data
calculating 1098
editing 1108
grip editing 1105, 1110
importing 1100
superelevation views
about using 1105
creating 1107
editing 1107
properties 1106
settings 1105
styles 1106
superelevation wizard, calculating data with 1098
surface collections
in Prospector tree 647
in Settings tree 648
surface data
adding and editing 660
definition 660
deleting from drawing 719
excluding from the build 718
exporting to DEM 773
removing 717
surface definitions
about 660
editing 731
manipulating 2656
surface display
components 748
styles 648
surface labels
adding 754
modifying 762
surface legend tables
(See also tables)
adding to drawings 1749
using 763
surface references, creating 2453
surface settings 2629
creation 737
editing 737
style 738
surface smoothing
methods 2642
using Kriging method 714
using Natural Neighbor Interpolation method 713
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surface styles
analysis 2653
borders 2645
contours 2646
creating 749
creating, based on existing 749
defining 2644
displaying 2655
editing 750
grid lines 2648
overview 748
points 2649
triangles 2651
watersheds 2651
surface thinning, as simplification method 715
surfaces
(See also corridor surfaces, surface data, surface
definitions, surface display, surface settings,
surface smooting, surface styles)
analyzing 764, 2659
appearance, changing 35
as Civil objects 647
AutoCAD objects, extracting from 2635
breaklines, tools for 770
build properties 2656
catchment areas, adding 2620
commands 775
concepts 645
copying 734
creating 2623
creating by cropping 716
creating from GIS data 658
creating from TIN 655
creating, grid 650
cropping 716, 2624
data operations 2656
deleting 736
edit operations 2658
editing 733
editing operations 699
elevation, changing 710
error troubleshooting 696
errors, troubleshooting 740
exporting to DEM 2634
exporting to LandXML 774
extracting objects from 2635
grading 797–798, 806, 864
grid 647
holes in, creating 662
importing TIN files to create 655
label styles 752
labels and tables 752
Land Desktop, importing 2234
large 740
legend tables, adding 763
locking 736
managing 730
minimum distance between, calculating 770
moving and scaling 737
new features 10, 15

operation list 661
overhanging, correcting in corridors 1510
pasting 711
point clouds, creating from 600
point data, adding from AutoCAD objects 689
preventing updates to 869
previewing 735
profiles, creating 1142
properties 731, 2655
rebuilding 735
references, creating 656
simplifying 715
smoothing 712
snapshots 732
statistics, viewing 739, 2662
supported data types 660
tasks workflow 32
TIN 647
types 647
understanding 645
visualizing 2628
volume, calculating 740
survey
new features 11, 15
survey analyses
formulas 392
least squares 242, 389, 392, 2686
survey command language
about 422
AutoCAD-related 430
baseline-related 429
centerline-related 430
equipment-correction-related 428
figure-related 426
intersection-related 428
points-related 422, 424–425
syntax 422
survey commands 419, 1755
survey data
(See also surveys)
analyzing 28
converting raw data 266
exporting to LandXML 270
import preparation 249
transferring raw data 266
understanding 207
viewing settings 2697
survey databases
(See also surveys, survey equipment)
creating 217
defaults 227
display precision, specifying 239
measurement units, setting 238
settings file, location 238
settings, importing and exporting 245
settings, modifying 2698
translating 220, 2730
survey databases, finding crossing breaklines in 770
survey equipment
correction commands 428

database 221, 228
database defaults 227
properties 246, 2672
survey extended properties
managing 271
settings 244
survey field codes
examples 250
linework code sets 252
survey figures
converting lines to arcs 842
creating new 347
deleting PIs 836
editing 367, 816
editing elevations 818
filleting 841
finding crossing breaklines in 770
inserting PIs 834
joining 836
offsetting 848
reversing direction 837
survey networks
3D geometry 2712
about 224
browsing to 225
editor 2720
groups editor 2720
multiple 210
properties, modifying 2710
styles, defining 2711
survey objects, feature settings 2670
survey output file, about 416
survey points
editor 2717
groups editor 2720
information, displaying 404
inserting 307–308
properties 2724
removing from drawing 309
updating 307–308
Survey tree 116
surveys
(See also survey data, survey databases, survey
equipment, survey figures, survey networks,
survey points)
See also survey data
analysis tools, about using 389
baselines, defining in 311
batch files, using for recording commands 344
boundary analysis 212
centerlines, defining in 315
collection list view 2725
control points, about 280
creating breaklines 2668
creating figures from objects 2669
directions, about 309
directions, editing 2689, 2715
drawing settings, specifying 247
editing figures 365
equipment database, setting 228

Index | 2817

equipment properties, viewing 2672
error tolerance 244
export defaults, setting 235
extended properties user interface 271
external editor, specifying for 231
features, displaying 216
field to finish 249
import defaults 233
interactive graphics 231
intersection points, locating 330
measurements 239–240
non-control points 283, 2692, 2714
object names 215
observations 289
observations editor 2716
obtaining and creating data 27
previews, setting properties 236
setting up project 26
setups 285
setups editor 2714
setups, editing 2693
site analysis 210
styles 215
topographic, about 212
user settings, importing and exporting 237
user settings, modifying 2726
workflow 21

T
table styles
(See also tables)
alignments 1058
creating 2735
defining 1738
deleting 1747
editing 2735
modifying 2735
pipe 1414
quantity takeoff 1292
structure 1415
surfaces 762
using from other drawings 1746
Table Styles collection, using to manage table styles 113
tables
(See also surface legend tables)
adding column names to 1740
adding columns to 1742
adding data to 1740, 2742
adding to drawings 1748
alignment 1043, 1059
allignment 1748
changing volume 2490, 2498, 2547
column size, specifying 1741
creating 2739
creating material volume 2566
creating total volume 2567
data, changing 1750, 2743
deleting columns from 1742
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deleting from drawing 1754
display, defining 1745
exploding 1754
format, defining 1741
formatting 2735
item view 137
joining split 1753
material volume 1290
modifying 1750
moving in drawing 1753
parcel 1748
pay item, placing in drawing 1308
point 1748
point, styles 452
properties, changing 1740, 2741
quantity takeoff 1290
rearranging columns 1742
settings, viewing summary 1746
sorting columns 1743
splitting 1744
stacks, realigning 1753
styles 70
surface 752
text properties, defining 1738
title, adding 1739
total volume 1290
understanding 1737
updating data 1751–1752
word wrapping in 1744
tagging objects with time information 2095
tags
(See also labels)
displayed as labels 1666
label, numbering 1723
labels used as 1663
tangents, connecting non-intersecting 1165
targets
elevation, setting 2063
mapping 2064
offset, setting 2064
selecting feature lines by layers 2062
selecting polylines 2062
selecting survey features 2062
slope, setting 2063
width, setting 2064
templates
default 128
drawing 127
for naming new objects 74, 2022
layer naming conventions 128
object and label styles 129
plan production 128
plan production tools 1902
predefined label styles 1651
temporal information. attaching to models 1872
tessellation
arc, about 664
grading settings 797
removing 842
tolerance 2135

text
adding to labels 2203
attaching to objects 1804
curved, in labels 1680
editing in tables 1744
justifying in labels 1685
Text Editor window, using to build text
component 2203
thinning surfaces, as simplification method 715
tick components, in label styles 2192
time information, attaching to models 1872
timeline, viewing in Google Earth 1872
timespan information
attaching to model data 1872, 2095
publishing to Google Earth 1871
TIN files, importing for surface creation 655
TIN lines
adding to surface 699
deleting from surface 700
TIN surfaces
about 647
creating 649, 655
creating using Google Earth data 1868
usage 649
volume, creating 651
tolerance errors
reporting in the Event viewer 233
settings 233
tool palettes
adding subassemblies to 122
window, acessing from menu 1763
toolbars
application, accessing 93
layout, using 121
pipe network 2268
Workspace, accessing 92
tools
(See also utilities)
pipe network 2268
sample line 2526
Toolspace
best practice 97
item view 137
new features 11
Toolspace window
about using 96
copying items in 99
displaying 97
item view, using 99
Projects collection, Vault dependency 104
Prospector tab 104
Settings tab 108
Survey tab 116
Toolbox tab 118
tooltips, display settings 2079
total volume table 1290
transition modifier, in Part Builder 1445
transition, grading
adding 859
region 797

transparent commands
(See also commands)
about 1767
activating 1768
Angle Distance 1769
Azimuth Distance 1773
Bearing Distance 1770
creating points using 516
defined 2786
Deflection Distance 1771
entering elevation for 1786
Grid Northing Easting 1776
Latitude Longitude 1776
Match Length 1785
Match Radius 1786
Northing Easting 1775
point filters, using in 1787
Point Name (alias) 1779
Point Number 1777
Point Object 1778
Profile Grade Length 1784
Profile Grade Station 1784
Profile Station Elevation 1780–1782
settings 1767
(See also ambient settings)
Side Shot 1774
Station Offset 1779
using within running commands 1768
zoom to point 1769
traverse analysis
performing 403
setting defaults for 242
Traverse Editor, using 401, 2721
traverses
creating 401
editing 402
properties, editing 402, 2696
triangles
display and styles 2651
TIN surface, swapping edges 701
triangulation
Delauney, about 649
from contour data 680
surface 646
troubleshooting
site issues 786
surface errors 740

U
unitless settings 2080
units, Civil 3D drawing 2073
unlocking
point groups 560
points 453
updating data shortcuts 156
user interface, explained 87
(See also customizing UI, menus, ribbon, toolbars)
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user point databases
formats, creating 530
properties, editing 2361
user point file formats, creating 530
user settings, survey 237, 2726
user-defined properties
adding default property to created points
adding to parcels 920
adding to points 445
utilities
(See also tools)
Coordinate Tracker 1813
drafting 1833
Event Viewer 1817
grading 868
Inquiry Tool 1806
Notes 1804
Object Viewer 1805
point editing 521

V
Vault
about using 158
configuring 163
creating groups 168
creating user accounts 167
defined 2786
error codes 195
folder permissions, specifying 168
installing 163
logging in 169, 2456
logging out 170
multi-site 164
Pack and Go feature 168
plan production tools, using with 1928
project folders 164
projects 169
running from Microsoft Office 166
workflow 24–25
working folders, organizing 165
Vault Explorer, running 166
VBA rules, converting to .NET 1403
VBA subassemblies, converting to .NET 1564
vertical curves
(See also curves)
designing 1166
editing 1198–1199
specifying types, in profiles 2444
types 1166
vertical distances, between entities 1812
view frame groups
creating reference (shortcut) 2454
objects 1930
properties 2333
settings 1930, 2319
view frames
creating 1904
display 1931
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editing 1919
inserting 1922
label styles 2340
labeling 1921
object 1931
ordering number 2332
properties 2331
settings 1932, 2322, 2339–2340
styles 1931, 2336
View Frames collection 1932
viewing
civil objects in Prospector tree 100
viewports, configuring for plan production tools
visibility checks
line of sight tools 1845
local, performing 1848
new features 16
point to point 1845
sight distance along corridor 1846
zone of visual influence 1848
vistas
Alignment Entities 1947
breaklines 2619
manipulating in Panorama window 119
pipe networks 2302
Profile Entities 2416
Regression Data 2226
visualization, tools for design 1867, 2628
visualizing objects 1764
volume surfaces
about 647
editing operations in 699
volume tables
changing 2490, 2498, 2561
material, creating 2566
total, creating 2567
volume tools, grading 794
volumes
composite 2620
formulas for stage storage 748
grading 868, 2121
new features 9
stage storage 743
surface, bounded 742
surface, composite 740
surfaces 740

W
wall breaklines
creating 671
defined 668
warning symbol
clearing, in alignments 1080
clearing, in profiles 1203
water drop paths, creating 767, 2665
(See also catchment regions)
water runoff, analyzing 768, 1332
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watersheds
about 725
boundary points 726
boundary segment 727
depression 727
display 2651, 2665
flat area 728
generating and displaying 730
hatch properties 2635
label styles 754
labels, adding 758
multi-drain 729
multi-drain notch 730
properties 730
styles 2651
types 726
web browser, using for outputting civil reports 1759
weeding
surface contour data 679
vertices, feature line 846
what is new in AutoCAD Civil 3D 2011 3
Where is My Command? tool 90
widenings
automatic widenings on curves 966
creating 965
editing 969, 1077
on alignments 964
specifying defaults 968
specifying linear transitions around curves 969
specifying manually 967
wild cards, in description keys 575, 577
wizards
Create Intersection 2145
Create Point Cloud 2379
Create Profile View 2397
Create Sheets 2327
Create View Frames 2322
Import Building Site 1892, 2010
Import Survey Data 261
Superelevation 1098
work planes
(See also offset work planes, reference work planes)
about using 1437
coordinate systems 1437
creating for model geometry 1453

defined 1435
preset, types of 1438
using for modeling 1437
workflows
alignments 40
corridors 43–45
grading 37
intersections 48
labels 21
parcels 38
pipe networks 57
plan production 61
points 29
profiles 50
roundabouts 49
sections 52
superelevation 42
survey 21
Vault 24–25
working folders
(See also project folders, project management)
about 165
changing 170
location 147, 165
workspaces
customizing 92
selecting default 93
types 92

X
XDRefs (external data references), using 537
XYZ files, as point cloud source data 593

Z
zone of visual influence, displaying 1848
zones, settings for coordinate 2073
zooming
to point 1768
to point list 1769
to point range 1769
to points 456
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