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What is Autodesk DirectConnect?

Autodesk® DirectConnect is a family of data translators that lets you import CAD data 
into: 

• Autodesk® AliasStudio™

• Autodesk® Maya®

• Autodesk® Showcase™

• Autodesk® ImageStudio

Each Autodesk DirectConnect translator lets you import a specific CAD file format into 
one or more of the Autodesk software products listed above. In addition, the software 
enables some CAD file formats to be exported from some products.

For details, see Supported products and translators.
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Supported products and 
translators

The following table shows:

• File formats currently supported by Autodesk DirectConnect

• The Autodesk products that support them at the time of this release

• Which file formats require additional Autodesk DirectConnect licenses on which 
products.

 

File format Autodesk 
AliasStudio

Autodesk 
ImageStudio

Autodesk 
Maya (1)

Autodesk 
Showcase

CATIA® V5
(Autodesk DirectConnect for 
CATIA V5 can be purchased)

License 
required

License 
required

Not available 

License 
required

Cosmo™

(See Open Inventor and 
Cosmo.)

Not available

No license 
required

No license 
required (1)

No license 
required

DWG/DXF 

(Export is supported for 
AliasStudio.) No license 

required (4)
No license 
required

No license 
required (1)

No license 
required

IGES

No license 
required

No license 
required

No license 
required

No license 
required

Open Inventor™

(See Open Inventor and 
Cosmo.) No license 

required. (2)
No license 
required

No license 
required (1)

No license 
required

JT

(Autodesk DirectConnect for 
JT can be purchased.) License 

required
License 

Required

Not available

License 
Required
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Table Notes:
(1) The file formats listed for Autodesk Maya apply to 32-bit Windows operating systems. 
The DWG, Pro/ENGINEER, IGES, STL, and STEP formats are available for Maya 8.5 
running on Microsoft Windows XP Professional x64 Edition operating system. IGES, 
STEP and STL formats are available for Maya running on Mac OS X.

(2) Autodesk AliasStudio uses its own translators to support the STL format. Versions 
before 2008 also use their own translators to support the Open Inventor file format. For 
more information, see the Autodesk AliasStudio Data Transfer reference book and the 
Autodesk AliasStudio online help.

(3) No Autodesk DirectConnect license is required to import SolidWorks® files. However, 
SolidWorks® 2005, 2006 or 2007 must be purchased, installed and licensed on the same 
machine.

(4) Autodesk DirectConnect also supports DWG/DXF export from Autodesk AliasStudio.

(5)The information in this chart is subject to change. Go to the Web for the most up-to-
date information. (See the topic Find the latest information on the Web.)

(6)UGS NX is only available for 32-bit Windows.

Pro/ENGINEER®

(Autodesk DirectConnect for 
Pro/ENGINEER can be 
purchased.)

No license 
required

License 
required

License 
required (1)

Not available

SolidWorks® (3)

(SolidWorks 2005 or later must 
be installed and licensed.) No license 

required (3)
No license 
required (3)

No license 
required (1,3)

No license 
required (3)

STEP

No license 
required

No license 
required

No license 
required

No license 
required

STL
Not available (2)

No license 
required

No license 
required

No license 
required

UGS NX (6)

License 
required

Not available Not available

License 
required

File format Autodesk 
AliasStudio

Autodesk 
ImageStudio

Autodesk 
Maya (1)

Autodesk 
Showcase
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What’s new this release

This section outlines enhancements for the 2008.07 version (released August, 2007), in 
addition to various bug fixes. It is divided into the following sections:

What’s new for your Autodesk product?

What’s new by format?

What’s new for your Autodesk product?

For Autodesk AliasStudio
UGS NX files can now be imported to and exported from AliasStudio. UGS NX part and 
assembly (.prt) files version V13.0 to NX 5.0 are supported.

For Autodesk Showcase
UGS NX 5.0 files can now be imported. 

What’s new by format?

UGS NX enhancements
• Version 5.0 files are now supported. 

CATIA® V5 enhancements
• Japanese characters in Catia V5 files are now handled on import.

• Offset surfaces from Catia V5 R17 are now processed correctly.

• Invisible objects within geometric sets are no longer processed when importing 
Catia V5 files.

IGES/STEP enhancements
• General IGES/STEP robustness improvements have been made. 
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Release notes and limitations
• For users of AliasStudio 2008 who have not upgraded to AliasStudio 2008 SP1 

and import or export UGS NX files:

If UGS NX is installed on your machine no further action is needed. If it is not, you 
need to add the environment variable UGII_ROOT_DIR  and UGII_BASE_DIR to 
your environment. To set these environment variables, follow the general 
instructions in Additional software setup, Autodesk AliasStudio. This restriction 
has been removed in AliasStudio 2008 SP1.

Warning: if you do have UGS NX installed changing this variable may stop that 
program from working correctly.
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Find the latest information on the 
Web

For the most up-to-date information on Autodesk DirectConnect (including which CAD 
formats are currently supported, system requirements, and how to purchase translator 
licenses), go to one of the following URLs: 

For Autodesk AliasStudio:

• www.autodesk.com/aliasstudio-directconnect

For Autodesk Maya:

• www.autodesk.com/maya-directconnect

For Autodesk ImageStudio:

• www.autodesk.com/imagestudio-directconnect

For Autodesk Showcase:

• www.autodesk.com/showcase-directconnect

Japanese documentation is also provided at these URLs.
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Installing and Licensing

In this section:
Installing Autodesk DirectConnect

Licensing Autodesk DirectConnect

Installing Autodesk DirectConnect

Installing with host software
Autodesk DirectConnect software is installed automatically when the following Autodesk 
software is installed:

• Autodesk AliasStudio

• Autodesk ImageStudio

• Autodesk Maya 

• Autodesk Showcase

For information on installing these software products, refer to their respective installation 
guides.

Supported platforms
Autodesk DirectConnect runs on the same platform as the Autodesk product it is installed 
with:

Microsoft® 
Windows® XP
Professional

Microsoft 
Windows 2000
Professional

Microsoft Windows 
XP Professional x64 
Edition

Apple® Mac OS® X 
10.4 or higher

Autodesk 
AliasStudio

Autodesk 
ImageStudio

Autodesk Maya

(DWG, 
Pro/ENGINEER, 
IGES, STL, and 
STEP formats only.)

(IGES, STL and STEP 
formats only.)
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Recommended system requirements
Autodesk DirectConnect requires the following amount of disk space:

• On Windows® XP or Windows 2000 Professional, 260 megabytes of disk space 
available on a system drive or destination drive 

• On Mac OS® X, 30 megabytes of disk space.

Note that Autodesk DirectConnect is installed with other products, so your system must 
also accommodate the host product requirements. (For the system requirements of the 
host product, consult its installation guide.)

Note For the most up-to-date information on hardware qualifications, go to 
www.autodesk.com/qual-charts.

Additional software setup, Autodesk Maya
After you install your Maya software, you must load a plug-in to use Autodesk 
DirectConnect translators:

1. In Maya, select Window > Settings/Preferences > Plug-in Manager.

2. Click the DirectConnect plug-in to enable all of the Autodesk DirectConnect translators:

• Windows: DirectConnect.mll

• Mac OS X: DirectConnect.lib

A check mark appears in the box.

Installing upgrades
You can download and install newer versions of Autodesk DirectConnect as they become 
available on the Web.

1. Find the newest version on the Web and download its exe file. (See the topic, Find the 
latest information on the Web.)

Autodesk 
Showcase

Microsoft® 
Windows® XP
Professional

Microsoft 
Windows 2000
Professional

Microsoft Windows 
XP Professional x64 
Edition

Apple® Mac OS® X 
10.4 or higher

Note to Autodesk AliasStudio users:
You must set an environment variable to use the IGES translator with Autodesk 
AliasStudio Version 13.0.2. For details, see the section “IGES” on page 19.
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2. Remove the older version of Autodesk DirectConnect from your system. (In Windows, 
select Start > Settings > Control Panel and click on the Add or Remove Programs 
choice.

3. Double-click on the exe file you downloaded.

Licensing Autodesk DirectConnect

To purchase and install a license:

1. To see if a license is required, go to Supported products and translators.

2. Purchase the Autodesk DirectConnect license if required. For information on how to 
purchase a license, go to the DirectConnect Web sites. (See the topic, Find the latest 
information on the Web.)

3. From the Windows Start menu, select Programs > Autodesk > DirectConnect > 
Licensing and follow the instructions.)

4. To verify the license is installed, try to import a file (see the next topic).

To import files:

1. In your Autodesk software, choose the appropriate menu item.

2. Select the file from the file browser. If you can’t see the file, it is not supported or its 
translator is not licensed.

3. Click OK.

The translator automatically launches and the file is imported into the scene.

For details on licensing (including how to use hardware locks and how to install floating 
licenses), refer to the Install_DirectConnect.pdf document found on the installation CD 
of the Autodesk product you purchased.

To import a CAD file into... Choose...

Autodesk AliasStudio File > Open 
or
File > Import > File

Autodesk ImageStudio File > Import

Autodesk Maya File > Open Scene
or
File > Import 

Autodesk Showcase File > Import Models
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Translator details
For information on the Autodesk products that support these formats and whether a 
license is required, go to the topic Supported products and translators.

In this section:
CATIA® V5

DWG/DXF

IGES

Open Inventor and Cosmo

JT

Pro/ENGINEER®

SolidWorks®

STEP

STL

UGS NX
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CATIA® V5

CATIA® is computer-aided design software from Dassault Systèmes. It uses file format 
suffixes .CATProduct and .CATPart. 

For information on the Autodesk products that support this format and whether a license is 
required, go to the topic Supported products and translators.

Software Prerequisites
• Install the Autodesk product where you will be importing files using this format. 

(The Autodesk DirectConnect software is installed at the same time.)

• A license is typically required to import CATIA V5 files. For more information on 
how to purchase a license, go to the DirectConnect Web sites. (See the topic, 
Find the latest information on the Web.)

To install a license, refer to the Install_DirectConnect.pdf document found on the 
installation CD.

To import CATIA V5 files

1. In your Autodesk software, choose the appropriate menu item. For example,

2. Select a CATIA V5 (*.CATProduct or *.CATPart) file from the file browser.

3. Click OK.

To import a CAD file into... Choose...

Autodesk AliasStudio File > Open 
or
File > Import > File

Autodesk ImageStudio File > Import

Autodesk Showcase File > Import Models
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The translator is launched automatically and the file is imported into the scene.

Types of data imported
CATIA V5 releases R17 and earlier are supported. The following types of data are 
imported:

• Point

• Line

• Arc

• Ellipse

• Parabola/Hyperbola/BSpline curve/Polynomial curve

• Plane

• Cylindrical surface

• Conical surface

• Spherical surface

• Toroidal surface

• BSpline surface

• Revolve surface

• Ruled surface

• Open body

• Solid body

• Layer

• Geometric set

• Part (from CATIA V5 release 6 and higher)

• Product (from CATIA V5 release 6 and higher)

• Attributes (RGB color, layer, name and visibility)

For more information:
• For information on where to find this data in your Autodesk software, see “Where 

to find imported data” on page 38.

• There may be options in Autodesk AliasStudio for you to specify how this data is 
imported. See the Autodesk AliasStudio Data Transfer reference book and the 
Autodesk AliasStudio online help.

• For definitions on these data types, consult your CATIA documentation.



17AUTODESK DIRECTCONNECT ONLINE HELP

DWG/DXF

Autodesk DirectConnect lets you import Autodesk AutoCAD® drawing files (DWG) and 
Drawing eXchange File (DXF) files into supporting Autodesk products. 

Tip For information on the Autodesk products that support these formats, go to the 
topic Supported products and translators.

Software Prerequisites
• Install the Autodesk product where you will be importing files using this format. 

(The Autodesk DirectConnect software is installed at the same time.)

• No license is required to import this file format.

• For Maya, you must load a plug-in to use Autodesk DirectConnect translators. 
See “Additional software setup, Autodesk Maya” on page 12.

To import DWG/DXF files

1. In your Autodesk software, choose the appropriate menu. For example, 

To import a CAD file into... Choose...

Autodesk AliasStudio File > Open 
or 
File > Import > File

Autodesk ImageStudio File > Import

Autodesk Maya File > Open Scene
or
File > Import 

Autodesk Showcase File > Import Models
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2. Browse and select a DWG (.dwg) or DXF (.dxf) file.

3. Click OK.

The translator automatically launches and the file is imported.

Types of data imported
The following types of DWG and DXF data are supported:

• lines, arcs, and splines

• extruded curves

• extrusions

• layers

• meshes

• surfaces

• text

• 3D solids

• materials.

Note For information on locating this data in your Autodesk software, see Where to find 
imported data.

Note There may be options in Autodesk AliasStudio for you to specify how this data is 
imported. See the Autodesk AliasStudio Data Transfer reference book and the 
Autodesk AliasStudio online help.

To export DWG/DXF files (Autodesk AliasStudio)
To export DWG/DXF files from Autodesk AliasStudio:

1. In your Autodesk software, choose the appropriate menu:

2. For details on available options, use the Autodesk AliasStudio help.

To export a CAD file from... Choose...

Autodesk AliasStudio File > Save As 



19AUTODESK DIRECTCONNECT ONLINE HELP

IGES

Initial Graphics Exchange Specification (IGES) is a file format for transferring graphics 
data between CAD/CAM systems. Autodesk DirectConnect lets you import the neutral 
IGES format files (*.iges or *.igs) from any number of CAD or modeling packages.

For information on the Autodesk products that support this format, go to the topic 
Supported products and translators.

Note Maya supports this translator on the Mac OS X operating system.

Software Prerequisites
• Install one of Autodesk AliasStudio, Autodesk ImageStudio, Autodesk Maya or 

Autodesk Showcase. (The Autodesk DirectConnect software is installed at the 
same time.)

• No license is required to import this file format.

• For Maya, you must load a plug-in to use Autodesk DirectConnect translators. 
See “Additional software setup, Autodesk Maya” on page 12.

Additional software setup, Autodesk AliasStudio
For Autodesk AliasStudio Version 13.0.2, you must set the ALIAS_IGES_DC system 
environment variable to use the latest IGES translator:

1. From your Windows toolbar, select Start > Settings > Control Panel.

2. Double click on System. The Systems Properties window opens.

3. Click on the Advanced tab.

4. Click on the Environment Variables button.

5. Click New and enter the following information:

• For Variable name, ALIAS_IGES_DC
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• For Variable value, 1

To import IGES files:

1. In your Autodesk software, choose the appropriate menu item. For example,

2. Select a native IGES (*.iges or *.igs) file from the file browser.

3. Click OK.

The translator will automatically launch and the file will import into the scene.

Troubleshooting (Autodesk AliasStudio)
If the files you import contain unsatisfactory data, you may need to change the following 
import options in Autodesk AliasStudio:

Default Trim Curves 

Specifies the trim curves that the processor will use. You can select parameter 
space curves, model space curves, or use the flag that is present in the.IGES file. 
If for any reason the trimming fails, the translator will try and trim with the 
alternative curves. 

Shrink Surface 

When ON, AliasStudio detects trimmed surfaces whose trim boundaries are the 
same as, or iso-parametric to, the natural boundaries of the untrimmed surface. It 
then converts these surfaces into AliasStudio surfaces by shrinking the 
untrimmed surface to the trim boundaries. 

When OFF, AliasStudio converts all trimmed surfaces of this type to AliasStudio 
trimmed surfaces.

Types of data imported
The Autodesk DirectConnect for IGES translator imports ASCII format IGES files with or 
without linefeed characters at the end of each record. Binary IGES files are not supported.

NURBS are imported for this file format. 

To import a CAD file into... Choose...

Autodesk AliasStudio File > Open 
or
File > Import > File

Autodesk ImageStudio File > Import

Autodesk Maya File > Open Scene
or
File > Import 

Autodesk Showcase File > Import Models
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The following information is maintained on import:

• Surfaces and curves

• Data organization (groups, layers, visibility and instances)

• Units

• Colors

Note For information on this data in your Autodesk software, see “Where to find 
imported data” on page 38.

Note There may be options in Autodesk AliasStudio for you to specify how this data is 
imported. See the Autodesk AliasStudio Data Transfer reference book and the 
Autodesk AliasStudio online help.

Identifying IGES supported entities in log files
The following table shows IGES entities supported on import by Autodesk DirectConnect 
for IGES.

Note Any entities with an entity use flag value 02 (Definition) are ignored by the input 
translator except for those with IGES Subfigure Definition entity (Type 308).

Type Form IGES Entity

100 0 circular arc

102 0 composite curve

104 0-3 conic arc, ellipse, parabola, hyperbola

106 1 copious data

106 2 copious data

106 11 copious data

106 12 copious data

106 63 closed area

108 0 plane

108 +/- 1 bounded plane

110 0 line

112 0 parametric curve

114 0 parametric surface

116 0 point

118 0-1 ruled surface
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IGES levels
All supported geometric IGES entities that are associated with IGES level <n> are added 
to an Autodesk AliasStudio layer called LEVEL<n>. For example, if a 126 B-spline entity's 
directory entry indicates that it is on level 42, then it is added as Layer LEVEL42.

120 0 surface of revolution

122 0 tabulated cylinder

124 0 transformation matrix

126 0-5 rational B-spline curve

128 0-9 rational B-spline surface

130 0 offset curve

140 0 offset surface

141 0 boundary entity

142 0 curve on surface

143 0 bounded surface

144 0 trimmed surface

308 0 subfigure definition

402 7, 9 associativity instance

408 0 singular subfigure instance

Type Form IGES Entity
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Open Inventor and Cosmo

Autodesk DirectConnect lets you import Open Inventor™ ASCII or binary files (*.iv) or 
Cosmo™ scene binary files (*.csb) into supported Autodesk software.

(Open Inventor is a 3D file format from Silicon Graphics Inc. with no relation to Autodesk 
Inventor® software.)

Tip For information on the Autodesk products that support these formats, go to the 
topic Supported products and translators.

Software prerequisites
• Install the Autodesk product where you will be importing files using these formats. 

(The Autodesk DirectConnect software is installed at the same time.)

• No license is required to import these file formats.

To import Open Inventor or Cosmo files

1. Choose the appropriate menu choice. For example,

2. Browse to and select an Open Inventor (*.iv) or Cosmo (*.csb) file.

To import a CAD file into... Choose...

Autodesk AliasStudio File > Open 
or
File > Import > File

Autodesk Maya File > Open Scene
or
File > Import 

Autodesk ImageStudio File > Import

Autodesk Showcase File > Import Models
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3. Click OK.

The translator will automatically launch and the file will be imported.

Types of data imported
Polygons and NURBS are imported for these file formats. The following information is 
maintained on import:

• Data organization (parent, child and groups) 

• Units

• Materials

• Textures

• Polygonal Shapes

• Transformation nodes

Note For information on locating this data in your Autodesk software, see Where to find 
imported data.

Limitations
• Lines, cameras, lights, manipulators, tolerances and animation are automatically 

excluded when an Open Inventor file is imported.
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JT

The DirectModel format JT is developed and supported by the JT Open Program. It is a 
format for the visualization of 3D models.

Tip For information on the Autodesk products that support this format and whether or 
not a license is required, go to the topic, Supported products and translators.

Software Prerequisites
• Install the Autodesk product where you will be importing files using this format. 

(The Autodesk DirectConnect software is installed at the same time.)

• A license is required. 

For information on how to purchase a license, go to the DirectConnect Web sites. 
(See the topic, Find the latest information on the Web.) To install a license, refer 
to the Install_DirectConnect.pdf document found on the installation CD.

To import JT files

1. In your Autodesk ImageStudio software, choose the appropriate menu item.

2. Select a *.jt file from the file browser.

3. Click OK.

To import a CAD file into... Choose...

Autodesk AliasStudio File > Open 
or
File > Import > File

Autodesk ImageStudio File > Import

Autodesk ShowCase File > Import Models
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The translator is automatically launched and the file is imported into the scene.

Types of data imported
The following information is maintained when JT files are imported:

• Precise geometric data conversion

• Data organization (parent and child hierarchal data, visibility and instances)

• Units

• Levels of detail (degrees of tesselation)

• Materials (brightness (shininess), ambient color, specular color, diffuse color and 
emission color)

• Textures (embedded image files)

• XTBREP and BREP topology

Note For information on locating this data in your Autodesk software, see Where to find 
imported data.

Note There may be options in Autodesk AliasStudio for you to specify how this data is 
imported. See the Autodesk AliasStudio Data Transfer reference book and the 
Autodesk AliasStudio online help.

Limitations
• Import options are not available.

• Curve geometry and animation are automatically excluded when a JT file is 
imported.
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Pro/ENGINEER®

Autodesk DirectConnect lets you import Pro/ENGINEER® part, assembly or PTC® 
Granite® files (*.prt, *.asm or *.g) into supported Autodesk software.

Tip For information on the Autodesk products that support this format and whether a 
license is required, go to the topic, Supported products and translators.

Software Prerequisites
• Install the Autodesk product where you will be importing files using this format. 

(The Autodesk DirectConnect software is installed at the same time.)

• A license may be required. 

For information on how to purchase a license, go to the DirectConnect Web sites. 
(See the topic, Find the latest information on the Web.) To install a license, refer 
to the Install_DirectConnect.pdf document found on the installation CD.

• Export Pro/ENGINEER® files from your CAD software using Wildfire™ Release 3 
(or lower) or PTC Granite Release 4 (or lower) specifications.

• For Maya, you must load a plug-in to use Autodesk DirectConnect translators. 
See Additional software setup, Autodesk Maya.

To import Pro/ENGINEER® files

1. In your Autodesk software, choose the appropriate menu item. For example,

To import a CAD file into... Choose...

Autodesk AliasStudio File > Open 
or 
File > Import > File
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2. Browse to and select a Pro/ENGINEER® part, assembly or Granite® file (*.prt, *.asm or 
*.g).

3. Click OK.

The translator automatically launches and the file is imported.

Note If you can’t import the files, you may not have set up the license for Autodesk 
DirectConnect for Pro/ENGINEER®. For licensing information, refer to “Licensing 
Autodesk DirectConnect” on page 13.

Tip To maintain the original positioning and orientation of part files in your scene, 
import the assembly file. If you import part files before the assembly file, they will 
be positioned at the origin (0,0,0), and the original positioning will be lost.

Types of data imported
NURBS are imported for this file format. The following data is maintained on import:

• Precise geometric surface and topology information

• Data organization

• Tolerances and units.

Layers are not supported.

Note For information on locating this data in your Autodesk software, see “Where to 
find imported data” on page 38.

Note There may be options in Autodesk AliasStudio for you to specify how this data is 
imported. See the Autodesk AliasStudio Data Transfer reference book and the 
Autodesk AliasStudio online help.

Limitations
• Node names are changed based on geometry, assembly or part names.

• Construction history, lines and animation are automatically excluded when a 
Pro/ENGINEER® file is imported.

Autodesk ImageStudio File > Import

Autodesk Maya File > Open Scene
or
File > Import 

To import a CAD file into... Choose...
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SolidWorks®

Autodesk DirectConnect lets you import SolidWorks® part and assembly files (*.sldprt and 
*.sldasm) into supported Autodesk software, provided you have SolidWorks® installed 
and licensed on your machine. No Autodesk DirectConnect license is required.

Tip For information on the Autodesk products that support this format, go to the topic, 
Supported products and translators.

Software prerequisites
• Install the Autodesk product where you will be importing files using this format. 

(The Autodesk DirectConnect software is installed at the same time.)

• No Autodesk DirectConnect license is required to import this file format, but you 
must install and license SolidWorks® Versions 2005, 2006 or 2007 on the same 
machine.

• For Maya, you must load a plug-in to use Autodesk DirectConnect translators. 
See “Additional software setup, Autodesk Maya” on page 12.

To import SolidWorks® files

1. In your Autodesk software, choose the appropriate menu item. For example,

To import a CAD file into... Choose...

Autodesk AliasStudio File > Open 
or 
File > Import > File

Autodesk ImageStudio File > Import
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2. Browse to and select a SolidWorks® part or assembly file (*.sldprt or *.sldasm). (If you 
cannot see the files, start the SolidWorks® software, minimize its window, and then try 
again to open the files.)

3. Click OK.

The translator automatically launches and the file is imported.

Tip To maintain the original positioning and orientation of part files in your scene, 
import the assembly file. If you import part files before the assembly file, they will 
all be positioned at the origin (0,0,0), and the original positioning will be lost.

Types of data imported
NURBS are imported for this file format. The following information is maintained on 
import:

• Precise geometric surface and topology information

• Data organization

• Tolerances and units

• Colors

Note For information on locating this data in your Autodesk software, see “Where to 
find imported data” on page 38.

Note There may be options in Autodesk AliasStudio for you to specify how this data is 
imported. See the Autodesk AliasStudio Data Transfer reference book and the 
Autodesk AliasStudio online help.

Limitations
• Construction history, lines and animation are automatically excluded when a 

SolidWorks® file is imported.

Autodesk Maya File > Open Scene
or
File > Import 

Autodesk Showcase File > Import Models

To import a CAD file into... Choose...
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STEP

Autodesk DirectConnect lets you import STEP files (*.stp or *.STEP). No Autodesk 
DirectConnect license is required.

Tip For information on the Autodesk products that support this format, go to the topic, 
Supported products and translators.

Software prerequisites
• Install the Autodesk product where you will be importing files using this format. 

(The Autodesk DirectConnect software is installed at the same time.)

• Export STEP files from the CAD software using AP203 or AP214 specifications.

• No license is required to import this file format.

• For Maya, you must load a plug-in to use Autodesk DirectConnect translators. 
See “Additional software setup, Autodesk Maya” on page 12.

Note Maya supports this translator on the Macintosh OS X operating system.

To import STEP files

1. In your Autodesk software, choose the appropriate menu item. For example,

To import a CAD file into... Choose...

Autodesk AliasStudio File > Open 
or
File > Import > File
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2. Select a native STEP (*.stp or *.STEP) file from the file browser.

3. Click OK.

The translator automatically launches and the file is imported into the scene.

Types of data imported
NURBS are imported for this file format. The following information is maintained on import:

• Precise geometric surface and topology information (ISO 10303:42)

• Data organization (layers)

• Tolerances and units

• Colors

Note For information on locating this data in your Autodesk software, see Where to find 
imported data.

Note There may be options in Autodesk AliasStudio for you to specify how this data is 
imported. See the Autodesk AliasStudio Data Transfer reference book and the 
Autodesk AliasStudio online help.

Limitations
• Construction lines, modeling curves and animation are automatically excluded 

when a STEP file is imported.

Autodesk ImageStudio File > Import

Maya File > Open Scene
or
File > Import 

Autodesk Showcase File > Import Models

To import a CAD file into... Choose...
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STL

Autodesk DirectConnect lets you import STL files. No Autodesk DirectConnect license is 
required.

Tip For information on the Autodesk products that support this format, go to the topic, 
Supported products and translators.

Software prerequisites
• Install the Autodesk product where you will be importing files using this format. 

(The Autodesk DirectConnect software is installed at the same time.)

• No license is required to import this file format.

• For Maya, you must load a plug-in to use Autodesk DirectConnect translators. 
See “Additional software setup, Autodesk Maya” on page 12.

Note Maya supports this translator on the Macintosh OS X operating system.

To import STL files

1. In your Autodesk software, choose the appropriate menu item. For example,

To import a CAD file into... Choose...

Autodesk Maya File > Open Scene
or
File > Import 

Autodesk Showcase File > Import Models

Autodesk ImageStudio File > Import
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2. Select a native STL file from the file browser.

3. Click OK.

The translator automatically launches and the file is imported into the scene.

Types of data imported
All STL meshes and color files are imported.

For information on locating this data in your Autodesk software, see Where to find 
imported data.
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UGS NX

Autodesk DirectConnect lets you import UGS NX files (Version 5.0 and earlier) into 
supported Autodesk software.

Tip For information on the Autodesk products that support this format and whether or 
not a license is required, go to the topic, Supported products and translators.

Software Prerequisites
• Install the Autodesk product where you will be importing files using this format. 

(The Autodesk DirectConnect software is installed at the same time.)

• A DirectConnect license is required for this format. 

For information on how to purchase a license, go to the DirectConnect Web sites. 
(See the topic, Find the latest information on the Web.) To install a license, refer 
to the Install_DirectConnect.pdf document found on the installation CD.

To import UGS NX files

1. In your Autodesk ImageStudio software, choose the appropriate menu item.

To import a CAD file into... Choose...

Autodesk AliasStudio File > Open 
or
File > Import > File

Autodesk ImageStudio File > Import

Autodesk ShowCase File > Import Models
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2. Select a *.prt file from the file browser. (UGS NX part and assembly (.prt) files version 
V13.0 to NX 5.0 are supported.)

Note There are options in Autodesk AliasStudio for you to specify how this data is 
imported. For details, see the Autodesk AliasStudio Data Transfer reference book 
and the Autodesk AliasStudio online help.

3. Click OK.

The translator is automatically launched and the file is imported into the scene.

To export UGS NX files (Autodesk AliasStudio)
To export UGS NX files from Autodesk AliasStudio:

1. In your Autodesk software, choose the appropriate menu:

2. Go to the Autodesk AliasStudio documentation for more details on how to build a model in 
for maximum compatibility between UGS NX and Autodesk AliasStudio.

Types of data imported
The following UGS NX geometry types are supported by Autodesk DirectConnect. 
(Attributes such as name, color, layer and visibility are supported.) 

• Point

• Line

• BCurve

• Circle 

• Ellipse

• Parabola 

• Hyperbola 

• Surface Parameter Curve 

• Trimmed Curve 

• Intersection Curve 

• BSurface

• Planar Surface 

• Spherical Surface 

• Cylindrical Surface

• Conical Surface

To export a CAD file from... Choose...

Autodesk AliasStudio File > Save As 
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• Surface of Revolution

• Spun Surface 

• Offset Surface

• Ruled Surface

• Swept Surface 

• Toroidal Surface 

• Blended Edge Surface 

• Blended Bound Surface 

• Facet

• Sheet Body

• Solid Body

• Part 

• Instance 

• Assembly

For more information:
• For information on where to find this data in your Autodesk software, see “Where 

to find imported data” on page 38.

• For details on how these geometry types are imported into Autodesk AliasStudio 
(including descriptions of options and tables showing how the geometry types 
map to the Autodesk AliasStudio geometry), see the Autodesk AliasStudio Data 
Transfer reference book and the Autodesk AliasStudio online help.

• For definitions on these data types, consult your UGS NX documentation.

Limitations
• Categories are not supported.

• This format is only supported for Windows 32-bit operating systems.
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Where to find imported data

For Autodesk AliasStudio:

For more information on these settings, menu items and options, see the Autodesk 
AliasStudio Data Transfer reference book and the Autodesk AliasStudio online help.

For Autodesk ImageStudio:

For more information on these settings and menu items, see the Autodesk ImageStudio 
online help.

Data Organization Tolerances and Units Colors (Shaders)

Parts and assembly information 
is displayed in the Windows > 
Information > Layer Categories 
window.

Unit settings are visible from 
Preferences > Construction 
Options.

Colors are visible from the Render 
> Multi-lister > Shaders window.

Data Organization Tolerances and Units Colors (Shaders)

Parts and assembly information 
is displayed in the Groups 
window.
Layers information is displayed 
in the Layers window.

Unit settings are visible from Edit 
> Preferences.

Colors are imported as Materials 
and displayed in the Asset List as 
default1DirectConnectShader, 
default2DirectConnectShader and 
so on. 
You can only change the names for 
these materials. If you save CAD 
shaders back to the Asset Library, 
they are stored in a category called 
DirectConnect.
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For Autodesk Maya:

For more information on these settings and menu items, see the Autodesk Maya online 
help.

For Autodesk Showcase:

For more information on these settings and menu items, see the Autodesk Maya online 
help.

Data Organization Tolerances and Units Colors (Shaders)

Layer information is visible from 
either the Display > UI Elements 
> Channel Box / Layer Editor 
menu or the Windows> 
Relationship Editors > Display 
Layers menu. 
Part and assembly information is 
visible from either the Window > 
Outliner menu or the Window > 
Hypergraph menu.

Unit settings are visible from 
Window > 
Settings/Preferences > 
Preferences. Open the 
Categories tab and choose 
Settings to change the Working 
Units and Tolerances.

Colors are imported as shaders 
and are visible from either the 
Window > Rendering Editors > 
Hypershade window or the 
Window > Rendering Editors > 
Multilister window.

Data Organization Tolerances and Units Colors (Shaders)

Layers, parts, and assembly 
hierarchies are shown in the 
Organizer window (Scene > 
Organizer). 
This window shows the original 
file hierarchy and lets you create 
your own arrangements of 
objects. You can view and change 
the state of objects from visible to 
hidden to deleted. 

Unit settings are visible from 
Edit > Model settings.

The tesselation, or number of 
levels of detail (LODs), can be 
set on file import. To see the 
number of LODs after a file is 
loaded, select Options > 
Performance and Quality, 
click the Lock display quality 
to button, and move the slider 
back and forth to see the 
different LODs.

Colors are imported as materials 
and are visible from Material > 
Material Properties.
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Glossary
assembly

An organizational file that fits together a collection of manufactured parts into a 
complete model. 

CATIA® V5

CATIA V5 is computer-aided design software from Dassault Systèmes. Autodesk 
DirectConnect allows the exchange of 3D model data from CATIA V5 using the 
native CATIA part (.CATPart) and product (.CATProduct) files.

Cosmo™

A legacy 3D file format from Silicon Graphics Inc. using efficient binary 
compression using *.csb (Cosmo Scene Binary) files.

DWG

(AutoCAD drawing file) A file format used by Autodesk® AutoCAD® software that 
contains lines, curves and 3D data.

DXF

Drawing eXchange File. A file exchange format containing ASCII code and binary 
representations of the objects in a DWG file.

Granite® One

A CAD technology platform for design collaboration using solid models.

IGES

Initial Graphics Exchange Specification. A file format for transferring graphics data 
between CAD/CAM systems. A neutral file format that can be imported into any 
number of CAD or modeling packages

Inventor (Open Inventor™) 

Open Inventor™ is a legacy 3D file format from Silicon Graphics Inc. with no 
relation to Autodesk Inventor® software. Open Inventor is an object-oriented 3D 
toolkit that describes complete 3D scenes which can be made interactive and that 
are optimized for OpenGL. It is an ASCII or binary file format.

JT file

The DirectModel format JT is developed and supported by the JT Open Program. 
It is a format for the visualization of 3D models.

parts

Parts are organized into a collection of groups, which then forms a project 
hierarchy. 
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Pro/ENGINEER®

A product from Parametric Technology Corporation. A solid modeling format that 
requires positional construction tolerances. 

SolidWorks®

A product from SolidWorks Corporation. A solid modeling format that requires 
positional construction tolerances. 

STEP

An international standard for the exchange of geometric product definitions. 
STEP formats that are relevant to Autodesk products are AP203 (general 
mechanical CAD) and AP214 (automotive CAD). 

STL

An StL (“StereoLithography”) file is a triangular representation of 3-dimensional 
surface geometry. The surface is tessellated or broken down logically into a 
series of small triangles (facets). Each facet is described by a perpendicular 
direction and three points representing the vertices (corners) of the triangle. 
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Legal Notices
© 2007  Autodesk, Inc.  All Rights Reserved.

Disclaimer
This publication, or parts thereof, may not be reproduced in any form, by any method, for 
any purpose.

AUTODESK, INC., MAKES NO WARRANTY, EITHER EXPRESS OR IMPLIED, 
INCLUDING BUT NOT LIMITED TO ANY IMPLIED WARRANTIES OF 
MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE REGARDING 
THESE MATERIALS, AND MAKES SUCH MATERIALS AVAILABLE SOLELY ON AN 
"AS-IS" BASIS. IN NO EVENT SHALL AUTODESK, INC., BE LIABLE TO ANYONE FOR 
SPECIAL, COLLATERAL, INCIDENTAL, OR CONSEQUENTIAL DAMAGES IN 
CONNECTION WITH OR ARISING OUT OF ACQUISITION OR USE OF THESE 
MATERIALS. THE SOLE AND EXCLUSIVE LIABILITY TO AUTODESK, INC., 
REGARDLESS OF THE FORM OF ACTION, SHALL NOT EXCEED THE PURCHASE 
PRICE, IF ANY, OF THE MATERIALS DESCRIBED HEREIN. 

Autodesk, Inc., reserves the right to revise and improve its products as it sees fit. This 
publication describes the state of this product at the time of its publication, and may not 
reflect the product at all times in the future. 

Trademarks
The following are registered trademarks or trademarks of Autodesk, Inc., in the USA and 
other countries: 3DEC (design/logo), 3December, 3December.com, 3ds Max, 
ActiveShapes, Actrix, ADI, Alias, Alias (swirl design/logo), AliasStudio, Alias|Wavefront 
(design/logo), ATC, AUGI, AutoCAD, AutoCAD Learning Assistance, AutoCAD LT, 
AutoCAD Simulator, AutoCAD SQL Extension, AutoCAD SQL Interface, Autodesk, 
Autodesk Envision, Autodesk Insight, Autodesk Intent, Autodesk Inventor, Autodesk Map, 
Autodesk MapGuide, Autodesk Streamline, AutoLISP, AutoSnap, AutoSketch, AutoTrack, 
Backdraft, Built with ObjectARX (logo), Burn, Buzzsaw, CAiCE, Can You Imagine, 
Character Studio, Cinestream, Civil 3D, Cleaner, Cleaner Central, ClearScale, Colour 
Warper, Combustion, Communication Specification, Constructware, Content Explorer, 
Create>what's>Next> (design/logo), Dancing Baby (image), DesignCenter, Design 
Doctor, Designer's Toolkit, DesignKids, DesignProf, DesignServer, DesignStudio, 
Design|Studio (design/logo), Design Your World, Design Your World (design/logo), DWF, 
DWG, DWG (logo), DWG TrueConvert, DWG TrueView, DXF, EditDV, Education by 
Design, Extending the Design Team, FBX, Filmbox, FMDesktop, GDX Driver, Gmax, 
Heads-up Design, Heidi, HOOPS, HumanIK, i-drop, iMOUT, Incinerator, IntroDV, 
Kaydara, Kaydara (design/logo), LocationLogic, Lustre, Maya, Mechanical Desktop, 
MotionBuilder, ObjectARX, ObjectDBX, Open Reality, PolarSnap, PortfolioWall, Powered 
with Autodesk Technology, Productstream, ProjectPoint, Reactor, RealDWG, Real-time 
Roto, Render Queue, Revit, Showcase, SketchBook, StudioTools, Topobase, Toxik, 
Visual, Visual Bridge, Visual Construction, Visual Drainage, Visual Hydro, Visual 
Landscape, Visual Roads, Visual Survey, Visual Syllabus, Visual Toolbox, Visual Tugboat, 
Visual LISP, Voice Reality, Volo, and Wiretap. 
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The following are registered trademarks or trademarks of Autodesk Canada Co. in the 
USA and/or Canada and other countries: Backburner, Discreet, Fire, Flame, Flint, Frost, 
Inferno, Multi-Master Editing, River, Smoke, Sparks, Stone, Wire.

All other brand names, product names or trademarks belong to their respective holders.

Third-Party Software Credits and Attributions

  All rights reserved.  Granite is copyrighted software distributed under 
license from Parametric Technology Corporation.

CATIA is a registered trademark of Dassault Systèmes. PTC, Pro/ENGINEER and 
Granite are trademarks or registered trademarks of Parametric Technology Corporation or 
its subsidiaries in the U.S. and in other countries. All PTC Technology Logos are used 
under license from Parametric Technology Corporation, Needham MA, USA. Microsoft 
and Windows are either registered trademarks or trademarks of Microsoft Corporation in 
the United States and/or other countries. Apple and Mac OS are trademarks of Apple 
Computer, Inc., registered in the U.S. and other countries. Inventor and Cosmo are 
trademarks of Silicon Graphics, Inc. in the United States and/or other countries, 
worldwide. SolidWorks is a registered trademark of SolidWorks Corporation. All 
trademarks herein are the property of their respective owners.

All other brand names, product names, or trademarks belong to their respective holders.

GOVERNMENT USE
Use, duplication, or disclosure by the U.S. Government is subject to restrictions as set 
forth in FAR 12.212 (Commercial Computer Software-Restricted Rights) and DFAR 
227.7202 (Rights in Technical Data and Computer Software), as applicable. 

Published By: Autodesk, Inc.
111 Mclnnis Parkway 
San Rafael, CA 94903, USA
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