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What is Autodesk
DirectConnect?

Autodesk® DirectConnect’s a family of data translators that lets you import and export CAD
data into:

B Autodesk® Alias™

B Autodesk® Maya®

B Autodesk® Showcase™

B Autodesk® Opticore Studio

Each Autodesk DirectConnect translator lets you import a specific CAD file format into one

or more of the Autodesk software products listed above. In addition, you can export some
CAD file formats from some products with Autodesk® DirectConnect.



Supported products and translators

Click any of the following Autodesk products to find:
B File formats currently supported for import by Autodesk DirectConnect

B The Autodesk products and bit versions that support them at the time of
this release

B Which file formats require additional Autodesk DirectConnect licenses on
which products

Autodesk Alias 2010 Import

File Format Windows 32-bit Windows 64-bit Mac OS
SolidWorks® on page / Not available Not available
55(1)

No license re-

quired
Pro/ENGINEER® on page / / Not available
53

No license re- No license re-

quired quired

CATIA® V5 on page 28 / / Not available

License required License required

CATIA® V4 on page 30 / / Not available

License required License required

UGS NX on page 61 / / Not available

License required License required
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File Format

Windows 32-bit Windows 64-bit

Mac OS

Autodesk Inventor (Re-
quires Inventor or Invent-
or View. See Autodesk
Inventor® on page 33)

v

No license re-
quired

Available with In-
ventor View in-
stalled on Win-
dows 64-bit with
DirectConnect
2009 R2 32-bit

Not available

STEP on page 58

v

No license re-

v

No license re-

v

No license re-

quired quired quired

DWG DXF on page 37 ‘/ ‘/ Not available
No license re- No license re-
quired quired

IGES on page 44 ‘/ ‘/ ‘/
No license re- No license re- No license re-
quired quired quired

Open Inventor™ ‘/ Not available Not available
No license re-
quired (2)

JT on page 51 (Autodesk Not available

DirectConnect for |T can
be purchased.)

v

License required

v

License required

NOTE (1) For importing SolidWorks® files, you do not need an Autodesk
DirectConnect license. However, SolidWorks® 2005, 2006, 2007, or 2008 must
be purchased, installed, licensed on the same machine, and running before

importing the file.
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Autodesk Alias 2010 Export

These file formats are currently supported for export by Autodesk
DirectConnect and the following bit versions were supported at the time of
this release. Some file formats require additional Autodesk DirectConnect
licenses on Alias.

File Format Windows 32-bit Windows 64-bit Mac OS

UGS NX on page 61 ‘/ ‘/ Not available

License required  License required

DWF on page 40 ‘/ ‘/ Not available

No license re-
quired

ZPR on page 42 (for ‘/ ‘/ Not available

Rapid Prototyping)

No license re- No license re-
quired quired
DWG DXF on page 37 ‘/ ‘/ Not available
No license re- No license re-
quired quired
Autodesk Showcase 2010
File Format Windows 32-bit Windows 64-bit
SolidWorks® on page 55 (1) ‘/ Not applicable
No license re-
quired
Pro/ENGINEER® on page 53 ‘/ Not applicable
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File Format Windows 32-bit Windows 64-bit

No license re-
quired

CATIA® V5 on page 28 ‘/ Not applicable

License required

CATIA® V4 on page 30 (2) ‘/ Not applicable

License required

UGS NX on page 61 ‘/ Not applicable

License required

Autodesk Inventor (Requires Inventor or ‘/ Available with In-
Inventor View. See Autodesk Inventor® on ventor View in-
page 33) No license re- stalled on Win-
. dows 64-bit with
quired

DirectConnect
2009 R2 32-bit

Cosmo™ ‘/ Not applicable

No license re-
quired

STEP on page 58 ‘/ Not applicable

No license re-
quired

STL on page 60 ‘/ Not applicable

No license re-
quired
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File Format Windows 32-bit Windows 64-bit

DWG DXF on page 37 ‘/ Not applicable

No license re-
quired

IGES on page 44 ‘/ Not applicable

No license re-
quired

Open Inventor™ ‘/ Not applicable

No license re-
quired

JT on page 51 (Autodesk DirectConnect for ‘/ Not applicable
JT can be purchased.)

License required

NOTE (1) For importing SolidWorks® files, you do not need an Autodesk
DirectConnect license. However, SolidWorks® 2005, 2006, 2007, or 2008 must
be purchased, installed, licensed on the same machine, and running before
importing the file. (2) CATIA V4 is available for Showcase Professional only, running
DirectConnect in batch mode.

Autodesk Maya 2010 (Windows version only)

File Format Windows 32-bit Windows 64-bit Mac OS
SolidWorks® on page 55 ‘/ ‘/ Not available
M

SolidWorks li- SolidWorks li-

cense required cense required
Pro/ENGINEER® on page / / Not available
53
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File Format Windows 32-bit Windows 64-bit Mac OS

No license re- No license re-
quired quired
UGS NX on page 61 ‘/ Not available Not available

License required

Autodesk Inventor (Re- ‘/ Available with In-  Not available
quires Inventor or Invent-
or View. See Autodesk In-
ventor® on page 33)

ventor View in-
stalled on Vista
64 with Direct-

No license re-

quired
Connect 2009 R2
32-bit
Cosmo™ ‘/ Not available Not available
No license re-
quired
STEP on page 58 ‘/ ‘/ ‘/
No license re- No license re- No license re-
quired quired quired
STL on page 60 ‘/ ‘/ ‘/
No license re- No license re- No license re-
quired quired quired
DWG DXF on page 37 ‘/ ‘/ Not available
No license re- No license re-
quired quired

IGES on page 44 ‘/ ‘/ ‘/
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File Format Windows 32-bit Windows 64-bit Mac OS

No license re- No license re- No license re-
quired quired quired
Open Inventor™ ‘/ Not available Not available
No license re-
quired
JT on page 51 Not available Not available Not available
pag

IMPORTANT DirectConnect 2009 is used with the Mac version of Maya 2010.

NOTE (1) For importing SolidWorks® files, you do not need an Autodesk
DirectConnect license. However, SolidWorks® 2005, 2006, 2007, or 2008 must
be purchased, installed, licensed on the same machine, and running before
importing the file.

Autodesk Opticore Studio 2010

File Format Windows 32-bit Windows 64-bit

SolidWorks® on page 55 (1) ‘/ Not available

No license re-

quired
Pro/ENGINEER® on page 53 / ‘/
No license re- No license required
quired
CATIA® V5 on page 28 ‘/ ‘/
License required License required
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File Format Windows 32-bit Windows 64-bit

CATIA® V4 on page 30 ‘/ ‘/

License required License required
UGS NX on page 61 ‘/ ‘/
License required License required

Autodesk Inventor (Requires Inventor or ‘/ ‘/

Inventor View. See Autodesk Inventor® on
page 33)

No license re- No license required
quired

Cosmo™ ‘/ Not available
No license re-
quired

STEP on page 58 ‘/ ‘/
No license re- No license required
quired

STL on page 60 ‘/ ‘/
No license re- No license required
quired

DWG DXF on page 37 ‘/ ‘/
No license re- No license required
quired

IGES on page 44 ‘/ ‘/
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File Format Windows 32-bit Windows 64-bit

No license re- No license required
quired
Open Inventor™ ‘/ Not available

No license re-

quired
JT on page 51 (Autodesk DirectConnect for ‘/ ‘/
JT can be purchased.)
License required License required

NOTE (1) For importing SolidWorks® files, you do not need an Autodesk
DirectConnect license. However, SolidWorks® 2005, 2006, 2007, or 2008 must
be purchased, installed, licensed on the same machine, and running before
importing the file.
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What's new this release

This section outlines enhancements made and new features added to the 2010 version (released
2009) of DirectConnect, along with various bug fixes.

What's new

UGNX 6 .prt files can be imported.
UGNX import for Opticore Studio 2010.
CATIA V5 R19 .cat part and .cATProduct files can be imported.

CATIA V4 import from Alias 2010 and Opticore Studio 2010.

DWG 2010 and DXF 2010 files are exported by default. There is still an
option to export to the following older versions:

m For DWG: 2007, 2004, 2000, or R14
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m For DXF: 2007, 2004, 2000, or R12

B Geometry, as well as material and model scaling information from an
AutoCAD file (DWG or DXF) import into Showcase.

B Color 3D printer output (.zpr) for the digital prototyping solution.
B DWF export.

B Group policy installation alignment.

NOTE For licensing information, please see Supported products and translators
on page 4.

Improvements

AutoCAD to Showcase

B Much more information, such as colors, and materials, is transferred from
AutoCAD DWG and DXEF files to Showcase.

CATIA V4

B CATIA V4 data can be imported into Alias and converted to an Alias wire
file.

CATIA V5

B The processing time for importing large CATIA V5 files in Showcase has
been greatly reduced.

UG and UGNX

B Parasolid trimmed filleted and planar data in UGNX are now trimmed
correctly.

B The installation process has changed to make it faster and easier to get up
and running.

B Imported CATIA VS surface quality has greatly improved.
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If working on Vista and wanting to use the DirectConnect Inventor
translator, you must run the Inventor View as “Administrator”, before the
data can be translated.

NOTE Running the Inventor View as “Administrator” is different from running
it from an Administrator Account.

DWG

You will see improved performance in the following areas:

transfer of material properties
transfer of model units
transfer of scaling

translation performance

stability

Inventor and Showcase

With the improved Inventor translator, you can see more content, such as:

materials
file textures
visibility

part attributes, such as Suspend and Visibility

Limitations

AutoCAD to Showcase

B The AutoCAD material attribute lllumination is not supported by
Showcase.

B Only 3D hierarchical data is supported. Curves and 2D drawings are
not supported.

Limitations | 15



AutoCAD to Alias

The AutoCAD material attribute lllumination is supported by Alias, but is called
Incandecense.

Maya on the Mac OS X operating system

Maya 2010 on the Mac OS X operating system does not use DirectConnect
2010; however, it does use DirectConnect 2009. Please check the Autodesk
web site for the documentation.

16 | Chapter 3 What's new this release



Find the latest information
on the Web

For the most up-to-date information on Autodesk DirectConnect (including which CAD

formats are currently supported, system requirements, and how to purchase translator licenses),

go to one of the following URLs:
For Autodesk Alias:

B  http://www.autodesk.com/aliasstudio-directconnect

For Autodesk Maya:

B http://www.autodesk.com/maya-directconnect

For Autodesk Showcase:

B http://www.autodesk.com/showcase-directconnect

=<0 UR

(PDFE Z71JL) t:?b-tzz?tn%i'ﬁ'q

Japanese documentation is also provided at these URLs.
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Installing and Licensing

Installing Autodesk DirectConnect

Installing with host software

Autodesk DirectConnect software installs automatically when the following
Autodesk software is installed:

B Autodesk Alias

B Autodesk Maya (Windows version)

B Autodesk Showcase

For information on installing these software products, refer to their respective
installation guides.

Autodesk DirectConnect software is provided on the media with Autodesk
Opticore Studio software, in the Autodesk DirectConnect 2010 folder, and must
be installed manually:

NOTE When installing DirectConnect, ensure you install the same version, such as
32-bit or 64-bit, as your Autodesk Opticore Studio.

NOTE DirectConnect Help is only supported on Microsoft Internet Explorer.
Performance on other browsers may not provide consistent results.
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Support platforms

Autodesk DirectConnect runs on the same platform as the Autodesk product
it installs with:

Autodesk Software  Microsoft® Apple® Mac Microsoft Vista
Windows® XP  OS®X 10.5.2or 32-bit and 64-bit
Professional 32- higher 64-bit  Editions
bit and 64-bit
Editions

Autodesk Alias / / /
Autodesk Maya (Win- / /

dows version)

Autodesk Showcase ‘/ ‘/
Autodesk Opticore Stu- ‘/ ‘/
dio

Recommended system requirements

Autodesk DirectConnect requires the following amount of disk space:

B On Windows® XP, Windows 2000 Professional, or Vista, 260 megabytes
of disk space available on a system drive or destination drive.

B On Mac OS® X 10.5 or greater, 30 megabytes of disk space, on an Apple
Mac computer with 64-bit Intel processors. PowerPC (PPC) computers are
no longer supported.

Autodesk DirectConnect 2010 installs with other products, so your system
must also accommodate the host product requirements. (For the system
requirements of the host product, consult its installation guide.)

NOTE For the most up-to-date information on hardware qualifications, go to
http://www.alias.com/eng/support/qualified_hardware/.
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Setting up additional software (Autodesk Maya 2010)

NOTE Maya on the Mac OS X operating system does not support DirectConnect
2010; however, it does support DirectConnect 2009. See
http://www.autodesk.com/maya-directconnect.

After you install your Maya 2010 software, load a plug-in to use Autodesk
DirectConnect translators:

1 In Maya 2009, select Window > Settings/Preferences > Plug-in Manager.

2 Click the DirectConnect plug-in to enable all of the Autodesk
DirectConnect translators:

B Windows: DirectConnect.mll
B Mac OS X: birectConnect.lib

A check mark appears in the box.

Installing upgrades

You can download and install newer versions of Autodesk DirectConnect as
they become available on the Web.

1 Find the newest version on the Web and download its exe file. (See Find
the latest information on the Web on page 17.)

2 Remove the older version of Autodesk DirectConnect from your system.
(In Windows, select Start > Settings > Control Panel and click the Add
or Remove Programs choice.

3 Double-click the exe file you downloaded.

Software deployment using group policies for
Windows

Disclaimer

The description of methods presented here is provided to aid those looking
for a straight forward, Microsoft supported means for deployment of software
over a Local Area Network. If the Microsoft Group Policy based mechanism
does not provide sufficient control or features for the size or complexity of
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your network environment, we recommend that you consider more advanced
Microsoft solutions, or other third party solutions.

Introduction

Microsoft’s Active Directory technology provides the capability for software
to be remotely installed from a server distribution point to client computers.
The client computers must be members of an Organizational Unit (OU) in
the Active Directory. Software deployment is controlled by configuring the
Software Installation policy of the Group Policy Object (GPO) associated with
that OU. The software installation occurs automatically at boot time; no user
intervention is required.

Prerequisites

B Active Directory must be installed and properly configured.

B Client computers must have Microsoft Installer (MSI) version 3.0 or newer
installed.

Configuration process

There are three main steps to deploying software using group policies:
1 Create a Distribution Point.
2 Assign the application to client computers.

3 Verify the installation.

NOTE Consult Microsoft Knowledge Base Article #816102 for more details,
including information on how to redeploy or remove a package.

Create a distribution point

A distribution point is a shared network location containing the package(s)
to install.

To create a distribution list
1 Log on to the appointed server as Administrator.

2 Create a shared network folder.
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Grant permissions as appropriat. Permission to modify the contents of
this folder should typically be granted to an administrator or select group
of users; all other users should be restricted to read access.

Copy the .msi files for the package(s) to be deployed into this folder.

Assign a package to client computers

The Software Installation section of the Group Policy object specifies the
software packages to be deployed.

To assign a package for deployment

1

From the Windows Start menu on the server, click All Programs (or
Programs) > Administrative Tools > Active Directory Users and Computers.

Browse to the desired Organizational Unit (OU) in the Active Directory
tree, right-click, and click Properties. The Properties dialog box for the
OU selected displays.

NOTE For the Group Policy Object to take effect, the desired client computer
objects must be members of the OU selected.

Select the Group Policy tab and click New. Enter a name for the GPO.
For example, “Alias Computer Assigned Installation”. The GPO is created
and added to the Group Policy Object Links list.

In the Group Policy Object Links list, click the GPO you just created, then
Edit.

In the left pane of the Group Policy Object Editor, under computer
Configuration, click the plus sign (+) next to the Software Settings folder
to expand it.

Under Software Settings, right-click Software Installation, then click New
> Package.

enter the UNC path to the desired package located in the distribution
point created in the previous section, then click Open. For example,

\\server\share\Alias.msi

NOTE Do not browse to the network location. You must type the UNC path
into the “File name” text box.
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Select Assigned and click OK. Wait until an entry for the package is
displayed in the right pane of the Group Policy window.

Repeat steps 7 and 8 for all packages to be deployed.

Close the Group Policy window and any other open Active Directory
windows.

The package is now assigned to all computers that are members of the
OU for which the GPO has been created. The next time a computer in
the OU is restarted, the program will be installed and available for all
users of the computer.

NOTE Windows XP is shipped with Fast Logon Optimization enabled. Due
to this feature, two reboots are required before the software will be installed.
Microsoft Knowledge Base Article #305293 describes the Fast Logon
Optimization feature, along with instructions on how to disable it.

Test and verify the deployment

When a computer is restarted, the operating system displays messages about
group policy, generally just before or after the Windows Login dialog box is
displayed. These messages include the following:

Windows starting up

Applying computer settings

Installing managed software

Applying software installation settings
Loading your personal settings

Applying your personal settings

To verify that the package has been correctly assigned to a computer, restart
a computer that is in the OU for which the GPO was created. The program is
installed during the boot sequence, before the login prompt is displayed. After
logging in, the user should find the application under the Programs menu in
the same location as if it had been locally installed.

NOTE If problems arise, an entry is logged in the system’s Event Viewer under
Applications.
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Licensing Autodesk DirectConnect

Purchasing and installing a license

1 To see if you need a license, go to Supported products and translators on

page 4.

Purchase the Autodesk DirectConnect license, if necessary. For
information on how to purchase a license, go to the DirectConnect Web
sites. (See Find the latest information on the Web on page 17.)

NOTE For details on licensing (including how to use hardware locks and
install floating licenses), refer to the installation and licensing documentation
for the Autodesk product you purchased.

From the Windows Start menu, select Programs > Autodesk >
DirectConnect > Licensing and follow the instructions.

NOTE For details on licensing (including how to use hardware locks and
install floating licenses), refer to the installation and licensing documentation
for the Autodesk product you purchased.

4 To verify the license installation, try to import a file (see the next topic).

Importing Files

When importing CAD files, the process is not always the same from one
software package to another. This section provides instructions on how to do
this in your Autodesk software.
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Importing files

1 In your Autodesk software, choose the appropriate menu item.

To import a CAD file into... Choose...

Autodesk Alias File > Open or File > Import > File
Autodesk Maya (Windows version) File > Open Scene or File > Import
Autodesk Showcase File > Import Models

Autodesk Opticore Studio File > Import

2 Select the file from the file browser. If you cannot see the file, it is not
supported or its translator is not licensed.

3 Click OK.
The translator automatically launches and the file imports into the scene.
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Translator details
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CATIA® V5

CATIA® is computer-aided design software from Dassault Systémes.

The software supports this format for Windows 32-bit and 64-bit operating
systems.

NOTE For information on the Autodesk products that support this format and
whether you require a license, see Supported products and translators on page
4.

Software prerequisites

B Install the Autodesk product where you plan to import files, using this
format. (The Autodesk DirectConnect software installs at the same time.)

B The software typically requires a license to import CATIA VS5 files. For more
information on how to purchase a license, go to the DirectConnect Web
sites. (See Find the latest information on the Web on page 17.)

To install a license, refer to the Install_DirectConnect.pdf document found
on the installation CD.
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Importing CATIA VS5 files

Types of data imported

1

In your Autodesk software, choose the appropriate menu item.

To import a CAD file into...

Choose...

Autodesk Alias

File > Open or File > Import > File

Autodesk Showcase

File > Import Models

Autodesk Opticore Studio

File > Import

Select a CATIA VS5 (*.caTProduct or*.caTPart) file from the file browser.

Click OK.

The translator launches automatically and the file imports into the scene.

We support CATIA VS5 releases R18 and earlier. We support importing the
following types of data:

Point

Line

Arc

Ellipse

Parabola
Hyperbola
BSpline curve
Polynomial curve
Plane

Cylindrical surface
Conical surface
Spherical surface

Toroidal surface

CATIA® V5| 29



BSpline surface

Revolve surface

Ruled surface

Open body

Solid body

Layer

Geometric set

Part (from CATIA V3 release 6 and higher)
Product (from CATIA VS5 release 6 and higher)

Attributes (RGB color, layer, name, and visibility)

NOTE For information on locating this data in your Autodesk software, see Where
to find imported data on page 69.

NOTE In Autodesk Alias, look for options for specifying data importation. See the
Autodesk Alias Data Transfer reference book and the Autodesk Alias online help.

NOTE For definitions on these data types, consult your CATIA documentation.

CATIA® V4
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CATIA® is computer-aided design software from Dassault Systémes.
DirectConnect supports the importing of CATIA V4 geometric sets, attributes,
such as names, layers, RGB colors, and visibility, as well as the following CATIA
V4 file types:

B .model
.mdl
.session
.exp
.dlv

.dlv3

.dlv4

NOTE DirectConnect supports CATIA model and export files produced with CATIA
V4.xx and earlier V3RX Levels.

The software supports this format for Windows 32-bit and 64-bit operating
systems.

NOTE For information on the Autodesk products that support this format and
whether you require a license, see Supported products and translators on page
4.

Software prerequisites

B Install the Autodesk product where you plan to import files, using this
format. (The Autodesk DirectConnect software installs at the same time.)

B The software typically requires a license to import CATIA V4 files. For more
information on how to purchase a license, go to the DirectConnect Web
sites. (See Find the latest information on the Web on page 17.)

To install a license, refer to the Install_DirectConnect.pdf document found
on the installation CD.
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Importing CATIA V4 files

1 In your Autodesk software, choose the appropriate menu item.

To import a CAD file into... Choose...
Autodesk Alias File > Open or File > Import > File
Autodesk Opticore Studio File > Import

2 Selecta CATIA V4 (*.model, *.mdl, *.session, *.exp, *.dlvOr *.dlv3)
file from the file browser.

3 Click OK.

The translator launches automatically and the file imports into the scene.

Types of entities imported

We support importing the following SPACE (SP) on page 74 entities:
m Point (Type 1)

B Line (Type 2)

B Parametric curve (Type 3)
B Plane (Type 4)

B Parametric surface (Type 5)
B Face (Type 6)

B Volume (Type 7)

B Transformation (Type 9)

W Edge (Type 12)

B Circle (Type 20)

m Ellipse (Type 21)

W Parabola (Type 22)

B Hyperbola (Type 23)

|

Polyhedral Surface (Type 16)
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Composite curve (Type 24)

Solids - Mockup (Type 17, secondary type 1)
Exact solid (Type 17, secondary type 2)
Space Ditto (Type 28)

Parametric Skin (Type 35)

NURB Curve (Type 46)

NURB Surface (Type 47)

NOTE For information on locating this data in your Autodesk software, see Where
to find imported data on page 69.

NOTE In Autodesk Alias, look for options for specifying data importation. See the
Autodesk Alias Data Transfer reference book and the Autodesk Alias online help.

NOTE For definitions on these data types, consult your CATIA documentation.

Autodesk Inventor®

Autodesk DirectConnect lets you import Autodesk Inventor® part (*. ipt) and
assembly (*.1iam) files into supported Autodesk software, provided you have
Inventor 2009 or the free Inventor View installed and licensed on your
machine. We do not require an Autodesk DirectConnect license.
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The software supports this format for Windows operating systems.

Notes

B To enable this translator on systems where no licensed Autodesk Inventor
2009 product is available, download and install the free Inventor View
2009 product from
http://usa.autodesk.com/adsk/serviet/index?id=10535296&sitelD=123112.

B Once the DirectConnect Inventor translator is installed, run it and select
File > Open, before using DirectConnect to translate your data.
However, if working on Vista and using the DirectConnect Inventor
translator, you must run the Inventor View as “administrator”, before the
data can be translated.

Setting Inventor View as administrator

From the Start menu, select Autodesk > Autodesk Inventor 2009 > Inventor

View, then right-click @ to open a list and select Run as administrator.

). Accessories 3

bor Wisuw
Open
Dpen file location

Run a¢ sdministrator
Scan for Viuses...
Restore previous versions
Send To

Cut

Copy

Creste Shorteut

Delete

Rename

Sort by Mame
Properties
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Software Prerequisites

B Install the Autodesk product where you plan to import files, using this
format. (The Autodesk DirectConnect software installs at the same time.)

B The software does not require an Autodesk DirectConnect license to import
this file format. But, ensure that you have Inventor 2009 or Inventor View
2009 installed and licensed on the same machine.

Importing Autodesk Inventor® files

1 In your Autodesk software, choose the appropriate menu item. For

example:

To import a CAD file into... Choose...

Autodesk Alias File > Open or File > Import > File
Autodesk Showcase File > Import Models

Autodesk Opticore Studio File > Import

To import a CAD file into... Choose...

Autodesk Alias File > Open or File > Import > File
Autodesk Maya (Windows version) File > Open Scene or File > Import
Autodesk Showcase File > Import Models

Autodesk Opticore Studio File > Import

2 Browse to and select an Autodesk Inventor part or assembly file (*.ipt
Oor *.iam).

3 Click OK.
The translator automatically launches and imports the file.
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NOTE To maintain the original positioning and orientation of part files in
your scene, import the assembly file. Importing part files before the assembly
file positions all of them at the origin (0,0,0) and removes the original
positioning.

Types of data imported

We import NURBS for this file format. The software maintains following
additional information on import:

m BREP Bodies

B Data organization

B Tolerances and units
|

Material Colors and simple transparency

NOTE For information on locating this data in your Autodesk software, see Where
to find imported data on page 69.

Limitations

B WorkSources, Display Meshes, and 2D/3D Sketches are automatically
excluded when importing an Autodesk Inventor® file.

B Some cylindrical surfaces (pipes) do not trim properly.
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DWG DXF

|

i

Autodesk DirectConnect lets you import Autodesk AutoCAD drawing files
(owe) and Drawing eXchange File (pxF) files into supporting Autodesk products.

The software supports this format for Windows 32-bit and 64-bit operating
systems.

NOTE For information on Audodesk products that support these formats, see
Supported products and translators on page 4.

Software prerequisites

B Install the Autodesk product where you to import files using this format.
(The Autodesk DirectConnect software installs at the same time.)

B The software does not require a license to import this file format.

B For Maya, load a plug-in to use Autodesk DirectConnect 2010 translators.
See Recommended system requirements on page 20.

NOTE Maya on the Mac OS X operating system do not support DirectConnect
2010; however, it does support DirectConnect 2009. See
http://www.autodesk.com/maya-directconnect.
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Importing DWG/DXEF files

1 In your Autodesk software, choose the appropriate menu item.

To import a CAD file into... Choose...

Autodesk Alias File > Open or File > Import > File
Autodesk Maya (Windows version) File > Open Scene or File > Import
Autodesk Showcase File > Import Models

Autodesk Opticore Studio File > Import

2 Browse and select a DWG (.dwg) or DXF (.dxf) file.

3 Click OK.
The translator automatically launches and imports the file.

Types of data imported

We support the following types of DWG and DXF data:
Colors

Materials

Lines, arcs, and splines

Extruded curves

Extrusions

Layers

Meshes

Surfaces

Text

3D solids
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IMPORTANT Showcase do not support the AutoCAD material attribute
lllumination. Alias supports the AutoCAD material attribute lllumination; however,
itis called Incandecense.

IMPORTANT Only 3D hierarchical data is supported by Showcase. Curves and
2D drawings are not.

NOTE For information on locating this data in your Autodesk software, see Where
to find imported data on page 69.

NOTE In Autodesk Alias, look for options for specifying data importation. See the
Autodesk Alias Data Transfer reference book and the Autodesk Alias online help.

NOTE DWG and DXF both support curves and round trip data export when want
curves is set to ON. If they are not coming in, please check to ensure that want
curves is enabled.

Exporting DWG/DXF files (Autodesk Alias)

1 In your Autodesk software, choose the appropriate menu:

To export a CAD file from ... Choose ...

Autodesk Alias File > Save As

2 For details on the available options, use the Autodesk Alias help.
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DWF

Design Web Format (DWEF) is a file format developed by Autodesk for web
viewing and printing. Autodesk DirectConnect 2010 lets you export Alias
tessellated model data to DWF format files (* . dwf) to view in Autodesk Design
Review and Project Freewheel.

The software supports this format for Windows 32-bit and 64-bit operating
systems.

For information on the Autodesk products that support this format, go to
Supported products and translators on page 4.

Software prerequisites

B Install Alias. (The Autodesk DirectConnect software installs at the same
time.)

B The software does not require a license to export this file format.

NOTE For information on additional software setup for Autodesk Alias, please
see the Autodesk Alias Data Transfer reference book and the Autodesk Alias
online help.
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Exporting DWF files

1 In Alias, select a file to be exported as a DWF and choose File > Export >

Active As or File > Save As.

2 From the File Format menu, select DWF (.dwf ).

3 Set export options:

Option

Function

Export Curves

When ON, curves are exported.

Export Symmetry

If an Alias layer has symmetry ON, this in-
formation and the geometric objects result-
ing from symmetry can be merged and
converted or left intact (unmerged) and
converted.

When OFF, layer symmetry is not exported.

Tessellator

When the tessellator is set to Fast, models
are trianulated quickly and less accurately.
When the tessellation is set to Accurate,
models are triangulated slowly and more
accurately.

B Tolerance - The amount a polygonal
surface can deviate from the original
NURBS surface. The default value is
0.01.

B Limit Edge Length - If checked, a
Max edge length slider appears to
control how large the triangles can
get. If unchecked, there is no limit on
the size of the triangles.

B Max Edge Length — The maximum
length of any triangle edge (in current
linear units).

4 Click Save.

The translator automatically launches and exports the file as a DWE
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Types of data exported

The Autodesk DirectConnect 2010 for DWF translator exports only meshes.
The Alias scene dag hierarchy is preserved. Associated color information is
also exported.

NOTE Check the options in Alias to specify data importation. See the Autodesk
Alias Data Transfer reference book and the Alias online help.

ZPR

ZPrint CAD format (ZPR) is a proprietary file format developed by Z
Corporation and used with ZPrint and ZEdit for printing on high definition
color 3D printers. Autodesk DirectConnect 2010 lets you export ZPR format
files (*.zpr) to use in the Autodesk Rapid Prototyping solution.
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The software supports this format for Windows 32-bit and 64-bit operating
systems.

For information on the Autodesk products that support this format, go to
Supported products and translators on page 4.

Software prerequisites

Install any of the following Autodesk products:
W Alias

m Showcase
B Maya
B Opticore Studio

(The Autodesk DirectConnect software installs at the same time.)

The software does not require a license to export this file format.

NOTE For information on additional software setup for Autodesk Alias, please
see the Autodesk Alias Data Transfer reference book and the Autodesk Alias
online help.

Exporting ZPR files

Use the output command

1

In Alias, select a file to be exported as a ZPR file and choose File > Export
> Rapid Prototype ...0.

From theFile Format menu, select ZPR (. zpr).

Depending on the entity selected for export, such as a shell, additional
setup may be needed. See the Autodesk Alias Data Transfer reference book
and the Autodesk Alias online help for information on additional setup
options.

Click Save.
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Types of data exported

The Autodesk DirectConnect 2010 for ZPR translator exports triangle meshes
with simple colors and textures for use with ZEdit and Zprint software for
rapid prototyping.

IGES

Initial Graphics Exchange Specification (IGES) is a file format for transferring
graphics data between CAD/CAM systems. Autodesk DirectConnect 2010 lets
you import the neutral IGES format files (*.iges or *.igs) from any number
of CAD or modeling packages.

The software supports this format for Windows 32-bit and 64-bit operating
systems.

For information on the Autodesk products that support this format, go to
Supported products and translators on page 4.

NOTE Maya supports this translator on the Mac OS X operating system.

Software prerequisites

B Install one of Autodesk Alias, Autodesk Maya (Windows version), or
Autodesk Showcase. (The Autodesk DirectConnect software installs at the
same time.)

B The software does not require a license to import this file format.

B For Autodesk Maya (Windows version), load a plug-in to use Autodesk
DirectConnect 2010 translators. See Recommended system requirements
on page 20.
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NOTE Maya on the Mac OS X operating systemdoes not support DirectConnect
2010; however, it does support DirectConnect 2009. See
http://www.autodesk.com/maya-directconnect.

NOTE For information on additional software setup for Autodesk Alias, please
see the Autodesk Alias Data Transfer reference book and the Autodesk Alias
online help.

Additional software setup (Autodesk Alias)

For Alias Version 13.0.2, set the IGES system environment variable to use the
latest IGES translator:

1

wn A W N

From your Windows toolbar, select Start > Settings > Control Panel.
Double-click System. The Systems Properties window opens.

Click the Advanced tab.

Click the Environment Variables button.

Click New and enter the following information:
W For Variable name, IGES

B For Variable value, 1

Importing IGES files

1

2
3

In your Autodesk software, choose the appropriate menu item.

To import a CAD file into... Choose...

Autodesk Alias File > Open or File > Import > File
Autodesk Maya File > Open Scene or File > Import
Autodesk Showcase File > Import Models

Autodesk Opticore Studio File > Import

Select a native IGES (*.iges or .igs) file from the file browser.

Click OK.
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The translator automatically launches and imports the file into the scene.

Troubleshooting (Autodesk Alias)

If the files you import contain unsatisfactory data, try changing the following
import options in Autodesk Alias:

Default Trim Curves Specifies the trim curves that the processor uses. You
can select parameter space curves, model space curves, or use the flag that is
present in the . 1GEs file. By default, the preference flag in the IGES files is
used.

Shrink Surface When ON, Alias detects trimmed surfaces whose trim
boundaries are the same as, or iso-parametric to, the natural boundaries of
the untrimmed surface. It then converts these surfaces into Alias surfaces by
shrinking the untrimmed surface to the trim boundaries.

When OFF, Alias converts all trimmed surfaces of this type to Alias trimmed
surfaces.

Types of data imported

The Autodesk DirectConnect 2010 for IGES translator imports ASCII format
IGES files with or without linefeed characters at the end of each record. The
software does not support Binary IGES files.

The software imports NURBS for this file format and maintains the following
information on import:

Surfaces and curves
Data organization (groups, layers, visibility, and instances)

Units

Colors

NOTE For information on this data in your Autodesk software, see Where to find
imported data on page 69.

NOTE Check the options in Alias to specify data importation. See the Alias Data
Transfer reference book and the Alias online help.
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Identifying IGES supported entities in log files

The following table shows IGES entities supported on import by Autodesk
DirectConnect 2010 for IGES.

NOTE The input translator ignores any entities with an entity use flag value 02
(Definition) except for entity use flag value with IGES Subfigure Definition entity
(Type 308).

Type Form IGES Entity

100 0 circular arc

102 0 composite curve
104 0-3 conic arc, ellipse, parabola, hyperbola
106 1 copious data

106 2 copious data

106 1 copious data

106 12 copious data

106 63 closed area

108 0 plane

108 +/-1 bounded plane
110 0 line

112 0 parametric curve
114 0 parametric surface
116 0 point
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Type Form IGES Entity

118 0-1 ruled surface

120 0 surface of revolution
122 0 tabulated cylinder

124 0 transformation matrix
126 0-5 rational B-spline curve
128 0-9 rational B-spline surface
130 0 offset curve

140 0 offset surface

141 0 boundary entity

142 0 curve on surface

143 0 boundary surface

144 0 trimmed surface

308 0 subfigure definition
402 7,9 associativity instance
408 0 singular subfigure instance
IGES levels

The system adds all supported geometric IGES entities that are associated with
IGES level <n> to an Alias layer called LEVEL<n>.
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For example, if a 126 B-spline entity directory entry indicates that it is on level
42, then it is added as Layer LEVEL42.

Open Inventor and Cosmo

Autodesk DirectConnect 2010 lets you import Open Inventor™ ASCII or binary
files (*.iv) or Cosmo™ scene binary files (*.csb) into supported Autodesk
software.

(Open Inventor is a 3D file format from Silicon Graphics Inc. with no relation
to Autodesk Inventor® software.)

NOTE For information on the Autodesk products that support these formats, see
the Supported products and translators on page 4.

Software prerequisites

B Install the Autodesk product where you plan to import files using these
formats. (The Autodesk DirectConnect software installs at the same time.)

B The software does not require a license to import these file formats.

Importing Open Inventor or Cosmo files

1 Choose the appropriate menu choice.

To import a CAD file into... Choose...

Autodesk Alias File > Open or File > Import > File
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To import a CAD file into... Choose...

Autodesk Maya (Windows version) File > Open Scene or File > Import
Autodesk Showcase File > Import Models
Autodesk Opticore Studio File > Import

2 Browse to and select an Open Inventor (*.1iv) or Cosmo (.csb) file.

3 Click OK.

The translator automatically launches and imports the file.

Type of data imported

The software imports polygons and NURBS for these file formats and maintains
the following information on import:

Data organization (parent, child, and groups)
Units

Materials

Textures

Polygonal Shapes

Transformation nodes

NOTE For information on locating this data in your Autodesk software, see Where
to find imported data on page 69.

Limitations

B When importing Open Inventor files, the system automatically excludes
lines, cameras, lights, manipulators, tolerances, and animation.

B The software only supports this format for Windows 32-bit operating
systems.
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JT

The JT Open Program develops and supports the DirectModel format JT. It is
a format for the visualization of 3D models.

The software supports this format for Windows 32-bit and 64-bit operating
systems.

NOTE For information on the Autodesk products that support this format and if
you need a license, go to Supported products and translators on page 4.

Software prerequisites

B Install the Autodesk product where you plan to import files using these
formats. (The Autodesk DirectConnect software installs at the same time.)

B The software requires a license.
For more information on how to purchase a license, go to the
DirectConnect Web site. (See Find the latest information on the Web on
page 17.) To install a license, refer to the Install_DirectConnect.pdf document
found on the installation CD.

Importing JT files

1 In your Autodesk software, choose the appropriate menu item.

To import a CAD file into... Choose...

Autodesk Alias File > Open or File > Import > File
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To import a CAD file into... Choose...

Autodesk Showcase File > Import Models

Autodesk Opticore Studio File > Import

Select a (*.jt) file from the file browser.

Click OK.
The translator automatically launches and imports the file into the scene.

Type of data imported

The software maintains the following information when importing JT files:

Precise geometric data conversion

Data organization (parent and child hierarchal data, visibility, and
instances)

Units
Levels of detail (degrees of tessellation)

Materials (brightness (shininess), ambient color, specular color, diffuse
color, and emission color)

Textures (embedded image files)

XTBREP and BREP topology

NOTE For information on locating this data in your Autodesk software, see Where
to find imported data on page 69.

NOTE In Autodesk Alias, look for options for specifying data importation. See the
Autodesk Alias Data Transfer reference book and the Autodesk Alias online help.

Limitations

52 | Chapter 6

Import options are not available.

The software automatically excludes curve geometry and animation when
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Pro/ENGINEER®

Autodesk DirectConnect lets you import Pro/ENGINEER®part, assembly, or
PTC® Granite® files (*.prt, *.asm, or *.g)into supported Autodesk software.

The software supports this format for Windows 32-bit and 64-bit operating
systems.

NOTE For information on the Autodesk products that support this format and if
you need a license, go to Supported products and translators on page 4.

Software prerequisites

B Install the Autodesk product where you plan to import files using these
formats. (The Autodesk DirectConnect software installs at the same time.)

B The software may require a license.
For more information on how to purchase a license, go to the
DirectConnect Web site. (See Find the latest information on the Web on
page 17.) To install a license, refer to the Install_DirectConnect.pdf document
found on the installation CD.

B Export Pro/ENGINEER® files from your CAD software using Wildfire™
Release 4 (or lower) or PTC Granite Release 5 (or lower) specifications.

NOTE For information on additional software setup for Autodesk Alias, please
see the Autodesk Alias Data Transfer reference book and the Autodesk Alias
online help.
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m For Maya (Windows version), load a plug-in to use Autodesk DirectConnect
2010 translators. See Recommended system requirements on page 20.

NOTE Maya on the Mac OS X operating system does not support
DirectConnect 2010; however, it does support DirectConnect 2009. See
http://www.autodesk.com/maya-directconnect.

Importing Pro/ENGINEER® files

1 In your Autodesk software, choose the appropriate menu item.

To import a CAD file into... Choose...

Autodesk Alias File > Open or File > Import > File
Autodesk Maya (Windows version) File > Open Scene or File > Import
Autodesk Opticore Studio File > Import

2 Select a Pro/ENGINEER® part, assembly, or Granite® file (*.prt, .asm,
or*.g).

3 Click OK.
The translator automatically launches and imports the file.

NOTE If you cannot import the files, try setting up the license for Autodesk
DirectConnect 2010 for Pro/ENGINEER®. For licensing information, refer to
Licensing Autodesk DirectConnect on page 25.

NOTE To maintain the original positioning and orientation of part files in
your scene, import the assembly file. Importing part files before the assembly
file positions all of them at the origin (0,0,0) and removes the original
positioning.

Type of data imported

The software imports NURBS for this file format and maintains the following
data on import:

B Precise geometric surface and topology information
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W Data organization

B Tolerances and units.

NOTE For information on locating this data in your Autodesk software, see Where
to find imported data on page 69.

NOTE In Autodesk Alias, look for options for specifying data importation. See the
Autodesk Alias Data Transfer reference book and the Autodesk Alias online help.

Limitations

B The software changes node names based on geometry, assembly, or part
names.

B When importing a Pro/ENGINEER® file, the software automatically excludes
construction history, lines, and animation.

B Granite does not support layers or curves.

SolidWorks®

Autodesk DirectConnect 2010 lets you import SolidWorks® part and assembly
files (*.sldprt and *.sldasm) into supported Autodesk software, provided
you have SolidWorks® installed, licensed on your machine, and running. The
software does not require an Autodesk DirectConnect license.
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NOTE For information on the Autodesk products that support this format and if
you need a license, go to Supported products and translators on page 4.

Software prerequisites

B Install the Autodesk product where you plan to import files using these
formats. (The Autodesk DirectConnect software installs at the same time.)

B The software does not require an Autodesk DirectConnect license to import
this file format. Install and license SolidWorks® Versions 2005, 2006, 2007,
or 2008 on the same machine.

NOTE For information on additional software setup for Autodesk Alias, please
see the Autodesk Alias Data Transfer reference book and the Autodesk Alias
online help.

m For Maya 2010 (Windows version), load a plug-in to use Autodesk
DirectConnect 2010 translators. See Recommended system requirements
on page 20.

NOTE Maya on the Mac OS X operating system does not support
DirectConnect 2010; however, it does support DirectConnect 2009. See
http://www.autodesk.com/maya-directconnect.

Importing SolidWorks® files

1 In your Autodesk software, choose the appropriate menu item.

To import a CAD file into... Choose...

Autodesk Alias File > Open or File > Import > File
Autodesk Maya (Windows version) File > Open Scene or File > Import
Autodesk Showcase File > Import Models

Autodesk Opticore Studio File > Import

2 Select a SolidWorks® part or assembly file(* . sldprt or *.sldasm). (If you
cannot see the files, start the SolidWorks® software, minimize its window,
and then try again to open the files.)
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3 Click OK.
The translator automatically launches and imports the file into the scene.

NOTE To maintain the original positioning and orientation of part files in
your scene, import the assembly file. Importing part files before the assembly
file positions all of them at the origin (0,0,0) and removes the original
positioning.

Type of data imported

The software imports NURBS for this file format and maintains the following
information on import:

B Precise geometric surface and topology information
W Data organization
B Tolerances and unit

m Colors

NOTE For information on locating this data in your Autodesk software, see Where
to find imported data on page 69.

NOTE In Autodesk Alias, look for options for specifying data importation. See the
Autodesk Alias Data Transfer reference book and the Autodesk Alias online help.

Limitations

B The software automatically excludes construction history, lines, and
animation when importing a SolidWorks® file.

B The software only supports this format for Windows 32-bit operating
systems.
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STEP

Autodesk DirectConnect 2010 lets you import STEP files (*.stp or *.step).
The software does not require a Autodesk DirectConnect 2010 license.

The software supports this format for Windows 32-bit and 64-bit operating
systems.

NOTE Maya 2010 supports this translator on the Mac OS X operating system.

NOTE For information on the Autodesk products that support this format, go to
Supported products and translators on page 4.

Software prerequisites

B Install the Autodesk product where you plan to import files using these
formats. (The Autodesk DirectConnect software installs at the same time.)

B Export STEP files from the CAD software using AP203 or AP214
specifications.

B The software does not require a license to import this file format.
For more information on how to purchase a license, go to the
DirectConnect Web site. (See Find the latest information on the Web on
page 17.) To install a license, refer to the Install_DirectConnect.pdf document
found on the installation CD.
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Importing STEP files

1 In your Autodesk software, choose the appropriate menu item.

To import a CAD file into... Choose...

Autodesk Alias File > Open or File > Import > File
Autodesk Maya (Windows version) File > Open Scene or File > Import
Autodesk Showcase File > Import Models

Autodesk Opticore Studio File > Import

2 Select a native STEP (*.stp or *.step) file from the file browser.

3 Click OK.
The translator automatically launches and imports the file into the scene.

Type of data imported

The software imports NURBS for this file format and maintains the following
information on import:

Precise geometric surface and topology information (ISO 10303:42)
Data organization (layers)

Tolerances and units

Colors

NOTE For information on locating this data in your Autodesk software, see Where
to find imported data on page 69.

NOTE In Autodesk Alias, look for options for specifying data importation. See the
Autodesk Alias Data Transfer reference book and the Autodesk Alias online help.

Limitations

B When importing a STEP file, the software automatically excludes
construction lines, modeling curves, and animation.
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STL

Autodesk DirectConnect 2010 lets you import STL files. The software does not
require a Autodesk DirectConnect 2010 license.

The software supports this format for Windows 32-bit and 64-bit operating
systems.

NOTE For information on the Autodesk products that support this format and if
you need a license, go to Installing and Licensing on page 3.

Software prerequisites

B Install the Autodesk product where you plan to import files using these
formats. (The Autodesk DirectConnect software installs at the same time.)

B The software does not require a license.
For Maya 2010 (Windows version), load a plug-in to used Autodesk
DirectConnect translator. See the Setting up additional software section of
Recommended system requirements on page 20.

NOTE Maya on the Mac OS X operating system does not support
DirectConnect 2010; however, it does support DirectConnect 2009. See
http://www.autodesk.com/maya-directconnect.

NOTE Maya 2010 supports this translator on the Mac OS X operating system.
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Importing STL files

1 In your Autodesk software, choose the appropriate menu item.

To import a CAD file into... Choose...

Autodesk Maya (Windows version) File > Open Scene or File > Import
Autodesk Showcase File > Import Models

Autodesk Opticore Studio File > Import

2 Select a native STL (Stereolithography) file from the file browser.

3 Click OK.
The translator automatically launches and imports the file into the scene.

Type of data imported

ASCII and binary STL files are supported.

NOTE For information on locating this data in your Autodesk software, see Where
to find imported data on page 69.

UGS NX
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Autodesk DirectConnect 2010 lets you import UGS NX files (Version 6.0 and
earlier) into supported Autodesk software.

The software supports this format for Windows 32-bit and 64-bit operating
systems.

NOTE For information on the Autodesk products that support this format and if
you need a license, go to Supported products and translators on page 4.

Software prerequisites

B Install the Autodesk product where you plan to import files using these
formats. (The Autodesk DirectConnect software installs at the same time.)

B The software requires a DirectConnect license.
For more information on how to purchase a license, go to the
DirectConnect Web site. (See Installing and Licensing on page 3.) To
install a license, refer to the Install_DirectConnect.pdf document found on
the installation CD.

Importing UGS NX files

1 In your Autodesk import files, choose the appropriate menu item.

To import a CAD file into... Choose...

Autodesk Alias File > Open or File > Import > File
Autodesk Maya (Windows version) File > Open Scene or File > Import
Autodesk Showcase File > Import Models

Autodesk Opticore Studio File > Import

2 Select a (*.prt) file from the file browser. (The software supports UGS
NX part and assembly (.prt) files version V13.0 to NX 5.0.)

NOTE There are options in Alias for you to specify data importation. For
details, see the Alias Data Transfer reference book and the Alias online help.

3 Click OK.
The translator automatically launches and imports the file into the scene.
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Exporting UGS NX files (Autodesk Alias)
To export UGS NX files from Autodesk Alias:

1 In your Autodesk software, choose the appropriate menu:

To export a CAD file from... Choose...

Autodesk Alias File > Save As

2 Go to the Alias documentation for more details on how to build a model
in for maximum compatibility between UGS NX and Alias.

Unigraphics proprietary format

Unigraphics is a solid modeling package based on the Parasolid kernel. The
package contains many (mostly optional) modules, for example CAD, CAM,
CAE, sheet metal applications, knowledge bases, quality control, and rapid
prototyping. The file structure is binary.

The following table explains how both Autodesk Alias and Unigraphics call
in common elements.

UG Autodesk Alias
Segment Span (curve)

Point Point

Patch Span (surface)

Pole CV (control vertices)
Sew Stitch

U/V grid Patch precision
Parameters History

Control polygon (display only) Hull
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UG

Autodesk Alias

Silhouette curve

Horizon curve

Blank Invisible
Reference set Set
Category Category
Custom view Bookmark
Knot point Edit point

Supported Unigraphics geometry and data mapping

The following sections describe the mapping process used for geometry types
and non-geometric data transfers between Alias and Unigraphics.

Supported Alias geometry types

The following Alias geometry types can be exported to Unigraphics.
Non-geometry entities, such as lights, cameras, textures, windows, and
animation, are not supported by the translator. The numbers in the table
entries refer to Notes for Unigraphics entities below.

Alias Entity

Unigraphics Entity

Construction Plane

WCS

Polyset Not supported at this time.
Conic Rational Curve
Arc Rational Curve
Circle Rational Curves
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Alias Entity Unigraphics Entity
Line Line

Curve BCurve

Surface BSurface (1), (2)

Trimmed Surface

Face (1), (2)

Plane Bounded Plane (1)
Shader Colour Attribute (3)
Shell (Open) Sheet Body

Set Reference Set
Group Group

Layer Layer (4)

Category Category

Shell (Closed) Solid Body

Notes for Unigraphics entities

1 Unigraphics cannot have free-standing surfaces, so it maps all surfaces
to faces which must be attached to a sheet body.

2 Splits appear in surfaces having internal discontinuities at the

discontinuities.

3 Mapped as a Display Attribute of the mapped surface or shell.

4 Layer name is not mapped.
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Supported Unigraphics entity objects geometry types (Alias)

Alias imports the following Unigraphics geometry types. The letters and
numbers in parentheses refer to Notes for Unigraphics entities below.

Unigraphics Entity Objects Alias Entity
WCS Construction Plane
BSurface Surface
Bounded Plane Surface
Cylindrical Surface Surface

Conical Surface Surface
Tabulated Cylinder Surface

Rules Surface Surface

Blended Face Surface Surface

Surface of Revolution Surface

Offset Surface Surface
Sculptured Surface Surface

BCurve Curve

Line Line (Curve)

Arc Curve

Conic Curve

Point Point (Curve) (1)
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Unigraphics Entity Objects

Alias Entity

Sheet Body Shell (Open) (2)
Assembly Groups/Instance (3)
Group Group

Layer Layer

Category Category

Reference Set Set

Part Attribute Blind Data ()

Solid Body Shell (Closed)

Notes for Alias Unigraphics (object) entities

B (1) A Unigraphics point converts to a degree 1 curve composed of two
coincident points. On export to Unigraphics, this construction converts

back to a Unigraphics point.

(2) If the sheet body only points to one face, then Alias converts the face

to a trimmed surface.

(3) This is a one-way mapping. Assemblies cannot be exported.
() Added as blind data. Can be re-exported.

Types of data imported

Autodesk DirectConnect supports the following UGS NX geometry types. (It
supports attributes such as name, color, layer, and visibility.)

B Point
Hm Line
H BCurve

m Ellipse
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Parabola

Hyperbola

Surface Parameter Curve
Trimmed Curve
Intersection Curve
BSurface

Planar Surface
Spherical Surface
Cylindrical Surface
Conical Surface
Surface of Revolution
Spun Surface

Offset Surface

Ruled Surface

Swept Surface
Toroidal Surface
Blended Edge Surface
Blended Bound Surface
Facet

Sheet Body

Solid Body

Part

Instance

Assembly

Category

Translator details



Where to find imported
data

For Autodesk Alias

Data Organization Tolerances and Units Colors (Shaders)

Parts and assembly inform-  Unit settings are visible Colors are visible from the
ation is displayed in the from Preferences > Con- Render > Multi-lister >
Windows > Information >  struction Options. Shaders window.

Layer Categories window.

For information on these settings, menu items, and options, see the Autodesk
Alias Data Transfer reference book and the Autodesk Alias online help.
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For Autodesk Maya (Windows version)

NOTE Maya 2010 for Mac does not support DirectConnect 2010; however, it
does support DirectConnect 2009. See
http://www.autodesk.com/maya-directconnect.

Data Organization

Tolerances and Units

Colors (Shaders)

Layer information is visible
from either the Display >
Ul Elements > Channel
Box/Layer Editor menu or
the Window > Relation-
ship Editors > Display
Layers menu.

Part and assembly informa-
tion is visible for either the
Window > Outliner menu
or the Window > Hyper-
graph menu.

Unit settings are visible
from Window > Set-
tings/Preferences > Prefer-
ences.

Open the Categories tab
and choose Settings to
change the Working Units
and Tolerances.

Colors are imported as
shaders and are visible for
either the Window > Ren-
dering Editors > Hyper-
shade or Window > Ren-
dering Editors > Multil-
ister window.

For more information on these setting and menu items, see the Autodesk

Maya online help.

For Autodesk Showcase

Data Organization

Tolerances and Units

Colors (Shaders)

Layers, parts, and assembly
hierarchies appear in the
Organizer window (Scene
> Organizer).

This window shows the ori-
ginal file hierarchy and lets
you create your own ar-
rangements of objects. You
can view and change the
state of objects from visible
to hidden to deleted.

Unit settings are visible from
Edit > Model settings. Try
setting the tessellation or
number of levels of detail
(LODs) on file import.

To see the number of LODs
for a loaded file, select Op-
tions > Performance and
Quality. Next, click the
Lock display quality to
button and move the slider

70 | Chapter 7 Where to find imported data

Colors are imported as
materials and are visible
from Material > Material
Properties.


http://www.autodesk.com/maya-directconnect

Data Organization

Tolerances and Units

Colors (Shaders)

back and forth to see the
different LODs.

For more information on these settings and menu items, see the Autodesk

Showcase online help.

For Autodesk Opticore Studio

Data Organization

Tolerances and Units

Colors (Shaders)

The node structure is visible
in the Scene Graph Editor,
located in the Window >
Scene Graph Editor menu.
It opens by default.

There are no units to deal
with in Studio. All impor-
ted data is considered the
same unit. Tolerances for
tessellation are set in the
File > Preferences dialog,
in the GeomX tab.

NOTE GeomX is not avail-
able until the GeomX
module is loaded in the
Modules tab (in the same
dialog) and Studio is restar-
ted.

To set tessellation toler-
ances, use the Import tes-
sellation section of the
GeomX tab. It is also pos-
sible to re-tessellate, using
the Window > GeomX >
Tessellate dialog and enter-
ing new settings.

Colors can be shaders or
appearances. All colors are
visible in the appearance
field of a shape node in the
scenegraph of the Scene
Graph Editor. Appearances
are only visible in the Scene
Graph Editor. Shaders are
visible both in the Scene
Graph Editor and through
the Windows > Shader
List dialog.

For information on these settings, menu items, and options, see the Autodesk
Opticore Studio online help.
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Glossary

assembly An organizational file that fits together a collection of manufactured parts into a
complete model.

CATIA® V4 CATIA V4 is computer-aided design software from Dassault Systémes. Autodesk
DirectConnect allows the exchange of 3D model data from CATIA V4, using .model, .session,
.exp, .dlv, and .d1v3 files.

CATIA® V5 CATIA V5 is computer-aided design software from Dassault Systémes. Autodesk
DirectConnect allows the exchange of 3D model data from CATIA V35, using the native CATIA
part (.caTpart) and product (.CATProduct) files.

Cosmo™ A legacy 3D file format from Silicon Graphics Inc. using efficient binary compression
and *.csb (Cosmo Scene Binary) files.

DRAW (DR) A two-dimensional entity defined in the drafting and detailing world.

DWG AutoCAD drawing file) A file format used by Autodesk® AutoCAD® software that
contains lines, curves, and 3D data.

DXF (Drawing eXchange File) A file exchange format containing ASCII code and binary
representations of the objects in a DWG file.

Granite® One A CAD technology platform for design collaboration using solid models.

IGES (Initial Graphics Exchange Specification) A file format for transferring graphics data
between CAD/CAM systems. A neutral file format that can be imported into any number of
CAD or modeling packages.

Inventor (Open Inventor™) Open Inventor™ is a legacy 3D file format from SiliconGraphics
Inc. With no relation to Autodesk Inventor® software. Open Inventor is an object-oriented
3D toolkit that describes complete 3D scenes which can be made interactive and that are
optimized for OpenGL. It is an ASCII or binary file format.

JT file The DirectModel format JT is developed and supported by the JT Open Program. It is
a format for the visualization of 3D models.
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parts Parts are organized into a collection of groups, which then forms a project hierarchy.

Pro/ENGINEER® A product from Parametric Technology Corporation. A solid modeling
CAD/CAM/CAE software that requires positional construction tolerances.

SolidWorks® A product from SolidWorks Corporation. A solid modeling CAD/CAM/CAE
software that requires positional construction tolerances.

SPACE (SP) A three-dimensional entity defined in the 3D modeling world.

STEP An international standard for the exchange of geometric product definitions. STEP
formats that are relevant to Autodesk products are AP203 (general mechanical CAD) and
AP214 (automotive CAD).

STL An STL ("StereoLithography") file is a triangular representation of 3D surface geometry.
The surface is tessellated or broken down logically into a series of small triangles (facets).
Each facet is described by a perpendicular direction and three points representing the vertices
(corners) of the triangle.

V3Rx A file format generated by an older versions of CATIA, before CATIA V4.
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PCRE and BSD Licenses

PCRE License

PCRE (Perl-compatible regular expressions) is a library of functions to support
regular expressions whose syntax and semantics are as close as possible to those
of the Perl 5 language.

Release 7 of PCRE is distributed under the terms of the "BSD" license, as specified
below. The documentation for PCRE, supplied in the "doc" directory, is
distributed under the same terms as the software itself.

The basic library functions are written in C and are freestanding. Also included
in the distribution is a set of C++ wrapper functions.

The Basic library functions

Written by: Philip Hazel

Email local part: ph10

Email domain: cam.ac.uk

University of Cambridge Computing Service, Cambridge, England.
Copyright (c) 1997-2008 University of Cambridge

All rights reserved.

The C++ wrapper functions

Contributed by: Google Inc.
Copyright (c) 2007-2008, Google Inc.
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All rights reserved.

The BSD (Berkeley Software Distribution) license

Redistribution and use in source and binary forms, with or without
modification, are permitted provided that the following conditions are met:

B Redistributions of source code must retain the above copyright notice, this
list of conditions and the following disclaimer.

B Redistributions in binary form must reproduce the above copyright notice,
this list of conditions and the following disclaimer in the documentation
and/or other materials provided with the distribution.

B Neither the name of the University of Cambridge nor the name of Google
Inc. nor the names of their contributors may be used to endorse or promote
products derived from this software without specific prior written
permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND
CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES,
INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR
CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT
NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER
CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT,
STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
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Copyright and trademarks

© 2009 Autodesk, Inc. All Rights Reserved. Except as otherwise permitted by Autodesk, Inc.,
this publication, or parts thereof, may not be reproduced in any form, by any method, for
any purpose.

Certain materials included in this publication are reprinted with the permission of the
copyright holder.

Trademarks

The following are registered trademarks or trademarks of Autodesk, Inc., in the USA and other
countries: 3DEC (design/logo), 3December, 3December.com, 3ds Max, ADI, Alias, Alias (swirl
design/logo), AliasStudio, AliasilWavefront (design/logo), ATC, AUGI, AutoCAD, AutoCAD
Learning Assistance, AutoCAD LT, AutoCAD Simulator, AutoCAD SQL Extension, AutoCAD
SQL Interface, Autodesk, Autodesk Envision, Autodesk Insight, Autodesk Intent, Autodesk
Inventor, Autodesk Map, Autodesk MapGuide, Autodesk Streamline, AutoLISP, AutoSnap,
AutoSketch, AutoTrack, Backdraft, Built with ObjectARX (logo), Burn, Buzzsaw, CAiCE, Can
You Imagine, Character Studio, Cinestream, Civil 3D, Cleaner, Cleaner Central, ClearScale,
Colour Warper, Combustion, Communication Specification, Constructware, Content Explorer,
Create>what's>Next> (design/logo), Dancing Baby (image), DesignCenter, Design Doctor,
Designer's Toolkit, DesignKids, DesignProf, DesignServer, DesignStudio, DesignlStudio
(design/logo), Design Web Format, Discreet, DWF, DWG, DWG (logo), DWG Extreme, DWG
TrueConvert, DWG TrueView, DXF, Ecotect, Exposure, Extending the Design Team, Face
Robot, FBX, Filmbox, Fire, Flame, Flint, FMDesktop, Freewheel, Frost, GDX Driver, Gmax,
Green Building Studio, Heads-up Design, Heidi, HumanlIK, IDEA Server, i-drop, ImageModeler,
iMOUT, Incinerator, Inferno, Inventor, Inventor LT, Kaydara, Kaydara (design/logo), Kynapse,
Kynogon, LandXplorer, LocationLogic, Lustre, Matchmover, Maya, Mechanical Desktop,
Moonbox, MotionBuilder, Movimento, Mudbox, NavisWorks, ObjectARX, ObjectDBX, Open
Reality, Opticore, Opticore Opus, PolarSnap, PortfolioWall, Powered with Autodesk Technology,
Productstream, ProjectPoint, ProMaterials, RasterDWG, Reactor, RealDWG, Real-time Roto,
REALVIZ, Recognize, Render Queue, Retimer,Reveal, Revit, Showcase, ShowMotion, SketchBook,
Smoke, Softimage, SoftimagelXSI (design/logo), SteeringWheels, Stitcher, Stone, StudioTools,
Topobase, Toxik, TrustedDWG, ViewCube, Visual, Visual Construction, Visual Drainage,
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Visual Landscape, Visual Survey, Visual Toolbox, Visual LISP, Voice Reality, Volo, Vtour,
Wire, Wiretap, WiretapCentral, XSI, and XSI (design/logo).

The following are registered trademarks or trademarks of Autodesk Canada Co. in the USA
and/or Canada and other countries: Backburner,Multi-Master Editing, River, and Sparks.

The following are registered trademarks or trademarks of MoldflowCorp. in the USA and/or
other countries: Moldflow, MPA, MPA (design/logo),Moldflow Plastics Advisers, MPI, MPI
(design/logo), Moldflow Plastics Insight, MPX, MPX (design/logo), Moldflow Plastics Xpert.

All other brand names, product names or trademarks belong to their respective holders.

Disclaimer

THIS PUBLICATION AND THE INFORMATION CONTAINED HEREIN IS MADE AVAILABLE
BY AUTODESK, INC. "AS 1IS." AUTODESK, INC. DISCLAIMS ALL WARRANTIES, EITHER
EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO ANY IMPLIED WARRANTIES
OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE REGARDING THESE
MATERIALS.

Published by:

Autodesk, Inc.

111 Mclnnis Parkway

San Rafael, CA 94903, USA

Please send us your comment about this page.

78 | Chapter 10 Copyright and trademarks



Index

.asm 53
.csb 49

g S3

iam 33
ipt 33

iv 49
.prt 53
.sldasm 55
sldprt 55
spt S8
STEP 58

A

assembly 73
Autodesk AliasStudio
supported translators 4
web site 17
Autodesk AutoCAD drawing files
Autodesk DirectConnect
installing 20
licensing 25
supported platforms 20
supported translators 4
Autodesk Inventor
translator 33
Autodesk Maya
additional setup 21
supported translators 4
web site 17
Autodesk Showcase
supported translators 4
web site 17
Autodesk SketchBook home page

Basic, library 75
BSD 75

37

C

CATIA V4, definition 73
CATIA V4, DRAW (DR) 73
CATIA V4, SPACE 74
CATIA VS 28,31

import 29, 32

translator 28, 31
CATIA V5, definition 73
Cosmo

translator 49
Cosmo, definition 73

D

data, where to find after import
Design Web Format 40, 42
DR, definition 73
DRAW, definition 73
Drawing eXchange File 37
DWF
translator
DWG DXF
translator 37
DWG, definition 73
DXEF, definition 73

40, 42

F

file format
.csb 49
iv 49

file formats
Jdam 33
ipt 33

files, import 25
formats, summary 4

69,71

79 | Index



G

glossary 73
Granite One, definition 73

IGES

translator 44
IGES, definition 73
Import

CATIA V5
import files 26
imported data, where to find 69, 71
Initial Graphics Exchange

Specification 44

installing Autodesk DirectConnect 25
installing host software 19
Inventor (Open Inventor), definition 73

29, 32

J

JT
translator 51
JT, definition 73

L

license
purchase and install 25
when required 4
license, BSD 75
license, PCRE 75

M

Mac OS X platform

supported formats 44, 58

o

Open Inventor
translator 49

organization of imported data 69, 71

80 | Index

P

parts, definition 74
PCRE 75
plug-in, Maya 21
Pro/ENGINEER

translator 53
Pro/ENGINEER, definition 74

S

shaders, where to find 69, 71
SolidWorks

translator 55
SolidWorks, definition 74
SP, definition 74
SPACE, definition 74
STEP

translator 58
STEP, definition 74
STL

translator 60
STL, definition 74
summary, support formats 4
support platforms 20
system requirements 20

T

tolerances of imported data
translator
Autodesk Inventor 33
Cosmo 49
DWEF 40, 42
DWG DXF 37
IGES 44
JT 51
Open Inventor 49
Pro/ENGINEER 53
SolidWorks 55
STEP 58
STL 60
UGSNX 62
troubleshooting
Autodesk AliasStudio import
options 46

69, 71



can’t see CAD file to import 26 \V/

U V3Rx, definition 74
UGS NX \.V}
translator 62
units of imported data 69, 71 where to find imported data 69, 71

Windows platform 20

Index | 81



82



	Contents
	Autodesk DirectConnect 2010
	What is Autodesk DirectConnect?
	Supported products and translators

	What's new this release
	What's new
	Improvements
	Limitations

	Find the latest information on the Web
	Installing and Licensing
	Installing Autodesk DirectConnect
	Software deployment using group policies for Windows
	Licensing Autodesk DirectConnect
	Importing Files

	Translator details
	CATIA® V5
	CATIA® V4
	Autodesk Inventor®
	DWG DXF
	DWF
	ZPR
	IGES
	Open Inventor and Cosmo
	JT
	Pro/ENGINEER®
	SolidWorks®
	STEP
	STL
	UGS NX

	Where to find imported data
	For Autodesk Alias
	For Autodesk Maya (Windows version)
	For Autodesk Showcase
	For Autodesk Opticore Studio

	Glossary
	PCRE and BSD Licenses
	PCRE License
	The BSD (Berkeley Software Distribution) license

	Copyright and trademarks
	Index

