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What is Autodesk
DirectConnect?

Autodesk® DirectConnect’s a family of data translators that lets you import and export CAD
data into:

■ Autodesk® Alias™

■ Autodesk® Maya®

■ Autodesk® Showcase™

■ Autodesk® Opticore Studio

Each Autodesk DirectConnect translator lets you import a specific CAD file format into one
or more of the Autodesk software products listed above. In addition, you can export some
CAD file formats from some products with Autodesk® DirectConnect.
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Supported products and translators
Click any of the following Autodesk products to find:

■ File formats currently supported for import by Autodesk DirectConnect

■ The Autodesk products and bit versions that support them at the time of
this release

■ Which file formats require additional Autodesk DirectConnect licenses on
which products

Autodesk Alias 2010 Import

Mac OSVista 64-bitVista 32-bitWindows
64-bit

Windows
32-bit

File Format

Not avail-
able

Not avail-
able

Not avail-
able

SolidWorks®

on page 58
(1) No license

required
No license
required

Not avail-
able

Pro/ENGIN-
EER® on
page 55 No license

required
No license
required

No license
required

No license
required

Not avail-
able

CATIA® V5
on page 30

License re-
quired

License re-
quired

License re-
quired

License re-
quired

Not avail-
able

CATIA® V4
on page 33

License re-
quired

License re-
quired

License re-
quired

License re-
quired

Not avail-
able

UGS NX on
page 65

4 | Chapter 2   What is Autodesk DirectConnect?



Mac OSVista 64-bitVista 32-bitWindows
64-bit

Windows
32-bit

File Format

License re-
quired

License re-
quired

License re-
quired

License re-
quired

Not avail-
able

Autodesk In-
ventor (Re-
quires In- No license

required
No license
required

No license
required

No license
requiredventor or In-

ventor View.
See
Autodesk In-
ventor® on
page 36)

STEP on
page 60

No license
required

No license
required

No license
required

No license
required

No license
required

Not avail-
able

DWG DXF
on page 39

No license
required

No license
required

No license
required

No license
required

IGES on
page 46

No license
required

No license
required

No license
required

No license
required

No license
required

Not avail-
able

Not avail-
able

Not avail-
able

Open Invent-
or™

No license
required (2)

No license
required
(2)

Not avail-
able

JT on page
53

Supported products and translators | 5



Mac OSVista 64-bitVista 32-bitWindows
64-bit

Windows
32-bit

File Format

(Autodesk
DirectCon-

License re-
quired

License re-
quired

License re-
quired

License re-
quired

nect for JT
can be pur-
chased.)

NOTE (1) For importing SolidWorks® files, you do not need an Autodesk
DirectConnect license. However, SolidWorks® 2005, 2006, 2007, or 2008 must
be purchased, installed, licensed on the same machine, and running before
importing the file.

Autodesk Alias 2010 Export

These file formats are currently supported for export by Autodesk
DirectConnect and the following bit versions were supported at the time of
this release. Some file formats require additional Autodesk DirectConnect
licenses on Alias.

Mac OSVista 64-
bit

Vista 32-bitWindows
64-bit

Windows
32-bit

File Format

Not avail-
able

UGS NX on
page 65

License re-
quired

License re-
quired

License re-
quired

License re-
quired

Not avail-
able

DWF on
page 42

No license
required

No license
required

No license
required

No license
required

Not avail-
able

ZPR on
page 44 (for
Rapid Proto-
typing)

No license
required

No license
required

No license
required

No license
required
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Mac OSVista 64-
bit

Vista 32-bitWindows
64-bit

Windows
32-bit

File Format

Not avail-
able

DWG DXF
on page 39

No license
required

No license
required

No license
required

No license
required

Autodesk Showcase 2010

Windows 64-bitWindows 32-bitFile Format

Not availableSolidWorks® on page 58 (1)

No license re-
quired

Pro/ENGINEER® on page 55

No license requiredNo license re-
quired

CATIA® V5 on page 30

License requiredLicense required

CATIA® V4 on page 33

License requiredLicense required

UGS NX on page 65

License requiredLicense required

Autodesk Inventor (Requires Inventor or
Inventor View. See Autodesk Inventor® on
page 36) No license required

Supported products and translators | 7



Windows 64-bitWindows 32-bitFile Format

No license re-
quired

Not availableCosmo™

No license re-
quired

STEP on page 60

No license requiredNo license re-
quired

STL on page 62

No license requiredNo license re-
quired

DWG DXF on page 39

No license requiredNo license re-
quired

IGES on page 46

No license requiredNo license re-
quired

Not availableOpen Inventor™

No license re-
quired

JT on page 53 (Autodesk DirectConnect for
JT can be purchased.)

No license required
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Windows 64-bitWindows 32-bitFile Format

No license re-
quired

NOTE (1) For importing SolidWorks® files, you do not need an Autodesk
DirectConnect license. However, SolidWorks® 2005, 2006, 2007, or 2008 must
be purchased, installed, licensed on the same machine, and running before
importing the file.

Autodesk Maya 2010

Mac OSVista 64-
bit

Vista 32-bitWindows
64-bit

Windows
32-bit

File Format

Not avail-
able

Not avail-
able

Not avail-
able

SolidWorks®

on page 58
(1) No license

required
No license
required

Not avail-
able

Pro/ENGIN-
EER® on page
55 No license

required
No license
required

No license
required

No license
required

Not avail-
able

Autodesk In-
ventor (Re-
quires Invent- No license

required
No license
required

No license
required

No license
requiredor or Inventor

View. See
Autodesk In-
ventor® on
page 36)

Not avail-
able

Not avail-
able

Not avail-
able

Cosmo™

No license
required

No license
required

Supported products and translators | 9



Mac OSVista 64-
bit

Vista 32-bitWindows
64-bit

Windows
32-bit

File Format

STEP on page
60

No license
required

No license
required

No license
required

No license
required

No license
required

STL on page
62

No license
required

No license
required

No license
required

No license
required

No license
required

Not avail-
able

DWG DXF on
page 39

No license
required

No license
required

No license
required

No license
required

IGES on page
46

No license
required

No license
required

No license
required

No license
required

No license
required

Not avail-
able

Not avail-
able

Not avail-
able

Open Invent-
or™

No license
required

No license
required

Not avail-
able

Not avail-
able

Not avail-
able

Not avail-
able

Not avail-
able

JT on page
53

IMPORTANT DirectConnect 2009 is used with the Mac version of Maya 2010.

NOTE (1) For importing SolidWorks® files, you do not need an Autodesk
DirectConnect license. However, SolidWorks® 2005, 2006, 2007, or 2008 must
be purchased, installed, licensed on the same machine, and running before
importing the file.
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Autodesk Opticore Studio 2010

Vista 64-bitVista 32-bitWindows 64-
bit

Windows 32-
bit

File Format

Not availableNot availableSolidWorks® on
page 58 (1)

No license re-
quired

No license re-
quired

Pro/ENGINEER®

on page 55

No license
required

No license re-
quired

No license re-
quired

No license re-
quired

CATIA® V5 on
page 30

License re-
quired

License re-
quired

License re-
quired

License re-
quired

CATIA® V4 on
page 33

License re-
quired

License re-
quired

License re-
quired

License re-
quired

UGS NX on page
65

License re-
quired

License re-
quired

License re-
quired

License re-
quired

Autodesk Invent-
or (Requires In-
ventor or Invent- No license

required
No license re-
quired

No license re-
quired

No license re-
quiredor View. See

Autodesk Invent-
or® on page 36)

Not availableNot availableCosmo™

Supported products and translators | 11



Vista 64-bitVista 32-bitWindows 64-
bit

Windows 32-
bit

File Format

No license re-
quired

No license re-
quired

STEP on page 60

No license
required

No license re-
quired

No license re-
quired

No license re-
quired

STL on page 62

No license
required

No license re-
quired

No license re-
quired

No license re-
quired

DWG DXF on
page 39

No license
required

No license re-
quired

No license re-
quired

No license re-
quired

IGES on page 46

No license
required

No license re-
quired

No license re-
quired

No license re-
quired

Not availableNot availableOpen Inventor™

No license re-
quired

No license re-
quired

JT on page 53
(Autodesk Direct-
Connect for JT License re-

quired
License re-
quired

License re-
quired

License re-
quiredcan be pur-

chased.)
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NOTE (1) For importing SolidWorks® files, you do not need an Autodesk
DirectConnect license. However, SolidWorks® 2005, 2006, 2007, or 2008 must
be purchased, installed, licensed on the same machine, and running before
importing the file.

Supported products and translators | 13
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What's new this release

This section outlines enhancements made and new features added to the 2010 R1 version
(released 2009) of DirectConnect, along with various bug fixes.

What's new

■ Support for 2010 AutoCAD format

■ Support of CATIA V4 components (.model files) for CATIA V5 assemblies

■ Support for CATIA V5 materials

■ Support for CATIA V4 in Showcase

■ Per face style assignments are now supported in AutoCAD and CATIA V5

■ Support of IGES plane surface (type 190)

3
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■ Support of IGES direction (type 123)

■ Support of JPEG files on 64-bit machines

Improvements

■ Enhanced interoperability between Inventor and Showcase, supporting
the transfer of Inventor weld maps (bead only)

■ UG file import quality

■ IGES file import quality

■ JT file import quality

Limitations
AutoCAD to Showcase

■ The AutoCAD material attribute Illumination is not supported by
Showcase.

■ Only 3D hierarchical data is supported. Curves and 2D drawings are
not supported.

AutoCAD to Alias

The AutoCAD material attribute Illumination is supported by Alias, but is called
Incandescence.

Maya on the Mac OS X operating system

Maya 2010 on the Mac OS X operating system does not use DirectConnect
2010; however, it does use DirectConnect 2009. Please check the Autodesk
web site for the documentation.

Inventor 2008 and Showcase

Before installing Showcase 2010, if you are using Inventor 2008, follow these
steps to ensure a successful installation. Showcase 2010 cannot read the libraries
from Inventor 2008, due to backward compatibility issues.

16 | Chapter 3   What's new this release



Install Inventor View 2009, opening it after you have used Inventor 2008.
Then, install Showcase 2010. Showcase will use the correct version of
DirectConnect, ensuring solids with different materials on patches are brought
into Showcase without any issues.

Inventor to Showcase

UV mapping problems occur when using Auto Stitch. The texture from
Inventor doesn’t get placed correctly onto the surface in Showcase.
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Find the latest information
on the Web

For the most up-to-date information on Autodesk DirectConnect (including which CAD
formats are currently supported, system requirements, and how to purchase translator licenses),
go to one of the following URLs:

For Autodesk Alias:

■ http://www.autodesk.com/aliasstudio-directconnect

For Autodesk Maya:

■ http://www.autodesk.com/maya-directconnect

For Autodesk Showcase:

■ http://www.autodesk.com/showcase-directconnect

Japanese documentation is also provided at these URLs.

4
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Installing and Licensing

Installing Autodesk DirectConnect

IMPORTANT DirectConnect 2010 is compatible with the Autodesk 2010 products
listed in Supported products and translators on page 4. To determine which version
of DirectConnect is compatible with your version of Autodesk software, match the
version numbers (i.e., DirectConnect 2009 is compatible with Autodesk Showcase
2009). The only exception is Autodesk Maya 2010 for Mac, which uses DirectConnect
2009.

Installing with host software

Autodesk DirectConnect software installs automatically when the following
Autodesk software is installed:

■ Autodesk Alias

■ Autodesk Maya (Windows version)

■ Autodesk Showcase

For information on installing these software products, refer to their respective
installation guides.

Autodesk DirectConnect software is provided on the media with Autodesk
Opticore Studio software, in the Autodesk DirectConnect 2010 folder, and must
be installed manually:

NOTE When installing DirectConnect, ensure you install the same version, such as
32-bit or 64-bit, as your Autodesk Opticore Studio.

5
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NOTE DirectConnect Help is only supported on Microsoft Internet Explorer.
Performance on other browsers may not provide consistent results.

Support platforms

Autodesk DirectConnect runs on the same platform as the Autodesk product
it installs with:

Apple® Mac
OS® X 10.5.2 or
higher 64-bit

Microsoft Vista
32-bit and 64-bit
Editions

Microsoft®
Windows® XP
Professional 32-
bit and 64-bit
Editions

Autodesk Software

Autodesk Alias

Autodesk Maya

Autodesk Showcase

Autodesk Opticore Stu-
dio

Recommended system requirements

Autodesk DirectConnect requires the following amount of disk space:

■ On Windows® XP, Windows 2000 Professional, or Vista, 260 megabytes
of disk space available on a system drive or destination drive.

■ On Mac OS® X 10.5 or greater, 30 megabytes of disk space, on an Apple
Mac computer with 64-bit Intel processors. PowerPC (PPC) computers are
no longer supported.

Autodesk DirectConnect 2010 R1 installs with other products, so your system
must also accommodate the host product requirements. (For the system
requirements of the host product, consult its installation guide.)
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NOTE For the most up-to-date information on hardware qualifications, go to
http://www.alias.com/eng/support/qualified_hardware/.

Setting up additional software (Autodesk Maya 2010)

NOTE Maya on the Mac OS X operating system does not support DirectConnect
2010; however, it does support DirectConnect 2009. See
http://www.autodesk.com/maya-directconnect.

After you install your Maya 2010 software, load a plug-in to use Autodesk
DirectConnect translators:

1 In Maya 2010, select Window > Settings/Preferences > Plug-in Manager.

2 Click the DirectConnect plug-in to enable all of the Autodesk
DirectConnect translators:

■ Windows: DirectConnect.mll

■ Mac OS X: DirectConnect.lib

A check mark appears in the box.

Installing upgrades

You can download and install newer versions of Autodesk DirectConnect as
they become available on the Web.

1 Find the newest version on the Web and download its exe file. (See Find
the latest information on the Web on page 19.)

2 Remove the older version of Autodesk DirectConnect from your system.
(In Windows, select Start > Settings > Control Panel and click the Add
or Remove Programs choice.

3 Double-click the exe file you downloaded.

Software deployment using group policies for
Windows

Disclaimer

The description of methods presented here is provided to aid those looking
for a straight forward, Microsoft supported means for deployment of software
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over a Local Area Network. If the Microsoft Group Policy based mechanism
does not provide sufficient control or features for the size or complexity of
your network environment, we recommend that you consider more advanced
Microsoft solutions, or other third party solutions.

Introduction

Microsoft’s Active Directory technology provides the capability for software
to be remotely installed from a server distribution point to client computers.
The client computers must be members of an Organizational Unit (OU) in
the Active Directory. Software deployment is controlled by configuring the
Software Installation policy of the Group Policy Object (GPO) associated with
that OU. The software installation occurs automatically at boot time; no user
intervention is required.

Prerequisites

■ Active Directory must be installed and properly configured.

■ Client computers must have Microsoft Installer (MSI) version 3.0 or newer
installed.

Configuration process

There are three main steps to deploying software using group policies:

1 Create a Distribution Point.

2 Assign the application to client computers.

3 Verify the installation.

NOTE Consult Microsoft Knowledge Base Article #816102 for more details,
including information on how to redeploy or remove a package.

Create a distribution point

A distribution point is a shared network location containing the package(s)
to install.

To create a distribution list

1 Log on to the appointed server as Administrator.

24 | Chapter 5    Installing and Licensing



2 Create a shared network folder.

3 Grant permissions as appropriate. Permission to modify the contents of
this folder should typically be granted to an administrator or select group
of users; all other users should be restricted to read access.

4 Copy the .msi files for the package(s) to be deployed into this folder.

Assign a package to client computers

The Software Installation section of the Group Policy object specifies the
software packages to be deployed.

To assign a package for deployment

1 From the Windows Start menu on the server, click All Programs (or
Programs) > Administrative Tools > Active Directory Users and Computers.

2 Browse to the desired Organizational Unit (OU) in the Active Directory
tree, right-click, and click Properties. The Properties dialog box for the
OU selected displays.

NOTE For the Group Policy Object to take effect, the desired client computer
objects must be members of the OU selected.

3 Select the Group Policy tab and click New. Enter a name for the GPO.
For example, “Alias Computer Assigned Installation”. The GPO is created
and added to the Group Policy Object Links list.

4 In the Group Policy Object Links list, click the GPO you just created, then
Edit.

5 In the left pane of the Group Policy Object Editor, under computer
Configuration, click the plus sign (+) next to the Software Settings folder
to expand it.

6 Under Software Settings, right-click Software Installation, then click New
> Package.

7 enter the UNC path to the desired package located in the distribution
point created in the previous section, then click Open. For example,
\\server\share\Alias.msi

NOTE Do not browse to the network location. You must type the UNC path
into the “File name” text box.
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8 Select Assigned and click OK. Wait until an entry for the package is
displayed in the right pane of the Group Policy window.

9 Repeat steps 7 and 8 for all packages to be deployed.

10 Close the Group Policy window and any other open Active Directory
windows.

The package is now assigned to all computers that are members of the
OU for which the GPO has been created. The next time a computer in
the OU is restarted, the program will be installed and available for all
users of the computer.

NOTE Windows XP is shipped with Fast Logon Optimization enabled. Due
to this feature, two reboots are required before the software will be installed.
Microsoft Knowledge Base Article #305293 describes the Fast Logon
Optimization feature, along with instructions on how to disable it.

Test and verify the deployment

When a computer is restarted, the operating system displays messages about
group policy, generally just before or after the Windows Login dialog box is
displayed. These messages include the following:

■ Windows starting up

■ Applying computer settings

■ Installing managed software

■ Applying software installation settings

■ Loading your personal settings

■ Applying your personal settings

To verify that the package has been correctly assigned to a computer, restart
a computer that is in the OU for which the GPO was created. The program is
installed during the boot sequence, before the login prompt is displayed. After
logging in, the user should find the application under the Programs menu in
the same location as if it had been locally installed.

NOTE If problems arise, an entry is logged in the system’s Event Viewer under
Applications.
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References

■ Microsoft Knowledge Base Article #816102: How to use Group Policy to
Remotely Install Software in Windows Server 2003

■ Microsoft Knowledge Base Article #305293: Description of Windows XP
Professional Fast Logon Optimization Feature

Licensing Autodesk DirectConnect

1 To see if you need a license, go to Supported products and translators on
page 4.

2 Purchase the Autodesk DirectConnect license, if necessary. For
information on how to purchase a license, go to the DirectConnect Web
sites. (See Find the latest information on the Web on page 19.)

NOTE For details on licensing (including how to use hardware locks and
install floating licenses), refer to the installation and licensing documentation
for the Autodesk product you purchased.

3 From the Windows Start menu, select Programs > Autodesk >
DirectConnect > Licensing and follow the instructions.

NOTE For details on licensing (including how to use hardware locks and
install floating licenses), refer to the installation and licensing documentation
for the Autodesk product you purchased.

4 To verify the license installation, try to import a file (see the next topic).

Importing Files
When importing CAD files, the process is not always the same from one
software package to another. This section provides instructions on how to do
this in your Autodesk software.
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1 In your Autodesk software, choose the appropriate menu item.

Choose...To import a CAD file into...

File > Open or File > Import > FileAutodesk Alias

File > Open Scene or File > ImportAutodesk Maya (Windows version)

File > Import ModelsAutodesk Showcase

File > ImportAutodesk Opticore Studio

2 Select the file from the file browser. If you cannot see the file, it is not
supported or its translator is not licensed.

3 Click OK.

The translator automatically launches and the file imports into the scene.
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CATIA® V5

CATIA® is computer-aided design software from Dassault Systèmes.

The software supports this format for Windows 32-bit and 64-bit operating
systems.

NOTE For information on the Autodesk products that support this format and
whether you require a license, see Supported products and translators on page
4.

Software prerequisites

■ Install the Autodesk product where you plan to import files, using this
format. (The Autodesk DirectConnect software installs at the same time.)

■ The software typically requires a license to import CATIA V5 files. For more
information on how to purchase a license, go to the DirectConnect Web
sites. (See Find the latest information on the Web on page 19.)
To install a license, refer to the Install_DirectConnect.pdf document found
on the installation CD.
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Importing CATIA V5 files

1 In your Autodesk software, choose the appropriate menu item.

Choose...To import a CAD file into...

File > Open or File > Import > FileAutodesk Alias

File > Import ModelsAutodesk Showcase

File > ImportAutodesk Opticore Studio

2 Select a CATIA V5 (*.CATProduct or*.CATPart) file from the file browser.

3 Click OK.

The translator launches automatically and the file imports into the scene.

Types of data imported

We support CATIA V5 releases R19 and earlier. We support importing the
following types of data:

■ Point

■ Line

■ Arc

■ Ellipse

■ Parabola

■ Hyperbola

■ BSpline curve

■ Polynomial curve

■ Plane

■ Cylindrical surface

■ Conical surface

■ Spherical surface

■ Toroidal surface
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■ BSpline surface

■ Revolve surface

■ Ruled surface

■ Open body

■ Solid body

■ Layer

■ Geometric set

■ Part (from CATIA V5 release 6 and higher)

■ Product (from CATIA V5 release 6 and higher)

■ Attributes (RGB color, layer, name, visibility, and materials)

■ Per face material assignments

■ CATIA V4 component .model files referenced in a CATIA V5 assembly are
now processed.

NOTE For information on locating this data in your Autodesk software, see Where
to find imported data on page 73.

NOTE In Autodesk Alias, look for options for specifying data importation. See the
Autodesk Alias Data Transfer reference book and the Autodesk Alias online help.

NOTE For definitions on these data types, consult your CATIA documentation.
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CATIA® V4

CATIA® is computer-aided design software from Dassault Systèmes.
DirectConnect supports the importing of CATIA V4 geometric sets, attributes,
such as names, layers, RGB colors, and visibility, as well as the following CATIA
V4 file types:

■ .model

■ .mdl

■ .session

■ .exp

■ .dlv

■ .dlv3

■ .dlv4

NOTE DirectConnect supports CATIA model and export files produced with CATIA
V4.xx and earlier V3RX Levels.

The software supports this format for Windows 32-bit and 64-bit operating
systems.
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NOTE For information on the Autodesk products that support this format and
whether you require a license, see Supported products and translators on page
4.

Software prerequisites

■ Install the Autodesk product where you plan to import files, using this
format. (The Autodesk DirectConnect software installs at the same time.)

■ The software typically requires a license to import CATIA V4 files. For more
information on how to purchase a license, go to the DirectConnect Web
sites. (See Find the latest information on the Web on page 19.)
To install a license, refer to the Install_DirectConnect.pdf document found
on the installation CD.

Importing CATIA V4 files

1 In your Autodesk software, choose the appropriate menu item.

Choose...To import a CAD file into...

File > Open or File > Import > FileAutodesk Alias

File > Import ModelsAutodesk Showcase

File > ImportAutodesk Opticore Studio

2 Select a CATIA V4 (*.model, *.mdl, *.session, *.exp, *.dlvor *.dlv3)
file from the file browser.

3 Click OK.

The translator launches automatically and the file imports into the scene.

Types of entities imported

We support importing the following SPACE (SP) on page 78 entities:

■ Point (Type 1)

■ Line (Type 2)

■ Parametric curve (Type 3)
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■ Plane (Type 4)

■ Parametric surface (Type 5)

■ Face (Type 6)

■ Volume (Type 7)

■ Transformation (Type 9)

■ Edge (Type 12)

■ Circle (Type 20)

■ Ellipse (Type 21)

■ Parabola (Type 22)

■ Hyperbola (Type 23)

■ Polyhedral Surface (Type 16)

■ Composite curve (Type 24)

■ Solids - Mockup (Type 17, secondary type 1)

■ Exact solid (Type 17, secondary type 2)

■ Space Ditto (Type 28)

■ Parametric Skin (Type 35)

■ NURB Curve (Type 46)

■ NURB Surface (Type 47)

NOTE For information on locating this data in your Autodesk software, see Where
to find imported data on page 73.

NOTE In Autodesk Alias, look for options for specifying data importation. See the
Autodesk Alias Data Transfer reference book and the Autodesk Alias online help.

NOTE For definitions on these data types, consult your CATIA documentation.
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Autodesk Inventor®

Autodesk DirectConnect lets you import Autodesk Inventor® part (*.ipt) and
assembly (*.iam) files into supported Autodesk software, provided you have
Inventor 2008, 2009, 2010 or the free Inventor View installed and licensed
on your machine. We do not require an Autodesk DirectConnect license.

The software supports this format for Windows operating systems.

Notes

■ To enable this translator on systems where no licensed Autodesk Inventor
2008, 2009, or 2010 product is available, download and install the free
Inventor View 2010 product from
http://usa.autodesk.com/adsk/servlet/index?id=10535296&siteID=123112.

■ Once the DirectConnect Inventor translator is installed, run it and select
File > Open, before using DirectConnect to translate your data.
However, if working on Vista and using the DirectConnect Inventor
translator, you must run the Inventor View as “administrator”, before the
data can be translated.

Setting Inventor View as administrator

From the Start menu, select Autodesk > Autodesk Inventor 2010 > Inventor

View, then right-click  to open a list and select Run as administrator.
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Software Prerequisites

■ Install the Autodesk product where you plan to import files, using this
format. (The Autodesk DirectConnect software installs at the same time.)

■ The software does not require an Autodesk DirectConnect license to import
this file format. But, ensure that you have Inventor 2008, 2009, 2010 or
Inventor View 2010 installed and licensed on the same machine.

Importing Autodesk Inventor® files

1 In your Autodesk software, choose the appropriate menu item. For
example:

Choose...To import a CAD file into...

File > Open or File > Import > FileAutodesk Alias

File > Import ModelsAutodesk Showcase

Autodesk Inventor®  | 37



Choose...To import a CAD file into...

File > ImportAutodesk Opticore Studio

Choose...To import a CAD file into...

File > Open or File > Import > FileAutodesk Alias

File > Open Scene or File > ImportAutodesk Maya (Windows version)

File > Import ModelsAutodesk Showcase

File > ImportAutodesk Opticore Studio

2 Browse to and select an Autodesk Inventor part or assembly file (*.ipt
or *.iam).

3 Click OK.

The translator automatically launches and imports the file.

NOTE To maintain the original positioning and orientation of part files in
your scene, import the assembly file. Importing part files before the assembly
file positions all of them at the origin (0,0,0) and removes the original
positioning.

Types of data imported

We import NURBS for this file format. The software maintains following
additional information on import:

■ BREP Bodies

■ Data organization

■ Tolerances and units

■ Material Colors and simple transparency

■ Weld maps (beads only)
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NOTE For information on locating this data in your Autodesk software, see Where
to find imported data on page 73.

Limitations

■ WorkSources, Display Meshes, and some 2D/3D Sketches are automatically
excluded when importing an Autodesk Inventor® file.

■ Some cylindrical surfaces (pipes) do not trim properly.

DWG DXF

Autodesk DirectConnect lets you import Autodesk AutoCAD drawing files
(DWG) and Drawing eXchange File (DXF) files into supporting Autodesk products.

The software supports this format for Windows 32-bit and 64-bit operating
systems.

NOTE For information on Audodesk products that support these formats, see
Supported products and translators on page 4.

Software prerequisites

■ Install the Autodesk product where you to import files using this format.
(The Autodesk DirectConnect software installs at the same time.)
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■ The software does not require a license to import this file format.

■ For Maya, load a plug-in to use Autodesk DirectConnect 2010 R1 translators.
See Recommended system requirements on page 22.

NOTE Maya on the Mac OS X operating system do not support DirectConnect
2010; however, it does support DirectConnect 2009. See
http://www.autodesk.com/maya-directconnect.

Importing DWG/DXF files

1 In your Autodesk software, choose the appropriate menu item.

Choose...To import a CAD file into...

File > Open or File > Import > FileAutodesk Alias

File > Open Scene or File > ImportAutodesk Maya (Windows version)

File > Import ModelsAutodesk Showcase

File > ImportAutodesk Opticore Studio

2 Browse and select a DWG (.dwg) or DXF (.dxf) file.

3 Click OK.

The translator automatically launches and imports the file.

Types of data imported

We support the following types of DWG and DXF data:

■ Colors

■ Materials

■ Lines, arcs, and splines

■ Extruded curves

■ Extrusions

■ Layers
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■ Meshes

■ Surfaces

■ Text

■ 3D solids

IMPORTANT Showcase do not support the AutoCAD material attribute
Illumination. Alias supports the AutoCAD material attribute Illumination; however,
it is called Incandescence.

IMPORTANT Only 3D hierarchical data is supported by Showcase. Curves and
2D drawings are not.

NOTE For information on locating this data in your Autodesk software, see Where
to find imported data on page 73.

NOTE In Autodesk Alias, look for options for specifying data importation. See the
Autodesk Alias Data Transfer reference book and the Autodesk Alias online help.

NOTE DWG and DXF both support curves and round trip data export when want
curves is set to ON. If they are not coming in, please check to ensure that want
curves is enabled.

Exporting DWG/DXF files (Autodesk Alias)

1 In your Autodesk software, choose the appropriate menu:

Choose ...To export a CAD file from ...

File > Save AsAutodesk Alias

2 For details on the available options, use the Autodesk Alias help.
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DWF

Design Web Format (DWF) is a file format developed by Autodesk for web
viewing and printing. Autodesk DirectConnect 2010 R1 lets you export Alias
tessellated model data to DWF format files (*.dwf) to view in Autodesk Design
Review and Project Freewheel.

The software supports this format for Windows 32-bit and 64-bit operating
systems.

For information on the Autodesk products that support this format, go to
Supported products and translators on page 4.

Software prerequisites

■ Install Alias. (The Autodesk DirectConnect software installs at the same
time.)

■ The software does not require a license to export this file format.

NOTE For information on additional software setup for Autodesk Alias, please
see the Autodesk Alias Data Transfer reference book and the Autodesk Alias
online help.
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Exporting DWF files

1 In Alias, select a file to be exported as a DWF and choose File > Export >
Active As or File > Save As.

2 From the File Format menu, select DWF (.dwf ).

3 Set export options:

FunctionOption

When ON, curves are exported.Export Curves

If an Alias layer has symmetry ON, this in-
formation and the geometric objects result-

Export Symmetry

ing from symmetry can be merged and
converted or left intact (unmerged) and
converted.
When OFF, layer symmetry is not exported.

When the tessellator is set to Fast, models
are triangulated quickly and less accurately.

Tessellator

When the tessellation is set to Accurate,
models are triangulated slowly and more
accurately.

■ Tolerance – The amount a polygonal
surface can deviate from the original
NURBS surface. The default value is
0.01.

■ Limit Edge Length – If checked, a
Max edge length slider appears to
control how large the triangles can
get. If unchecked, there is no limit on
the size of the triangles.

■ Max Edge Length – The maximum
length of any triangle edge (in current
linear units).

4 Click Save.

The translator automatically launches and exports the file as a DWF.
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Types of data exported

The Autodesk DirectConnect 2010 R1 for DWF translator exports only meshes.
The Alias scene dag hierarchy is preserved. Associated color information is
also exported.

NOTE Check the options in Alias to specify data importation. See the Autodesk
Alias Data Transfer reference book and the Alias online help.

ZPR

ZPrint CAD format (ZPR) is a proprietary file format developed by Z
Corporation and used with ZPrint and ZEdit for printing on high definition
color 3D printers. Autodesk DirectConnect 2010 R1 lets you export ZPR format
files (*.zpr) to use in the Autodesk Rapid Prototyping solution.
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The software supports this format for Windows 32-bit and 64-bit operating
systems.

For information on the Autodesk products that support this format, go to
Supported products and translators on page 4.

Software prerequisites

■ Install any of the following Autodesk products:

■ Alias

■ Showcase

■ Maya

■ Opticore Studio

(The Autodesk DirectConnect software installs at the same time.)

■ The software does not require a license to export this file format.

NOTE For information on additional software setup for Autodesk Alias, please
see the Autodesk Alias Data Transfer reference book and the Autodesk Alias
online help.

Exporting ZPR files

Use the output command

1 In Alias, select a file to be exported as a ZPR file and choose File > Export
> Rapid Prototype ...❒.

2 From the File Format menu, select ZPR (.zpr).

3 Depending on the entity selected for export, such as a shell, additional
setup may be needed. See the Autodesk Alias Data Transfer reference book
and the Autodesk Alias online help for information on additional setup
options.

4 Click Save.
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Types of data exported

The Autodesk DirectConnect 2010 R1 for ZPR translator exports triangle
meshes with simple colors and textures for use with ZEdit and Zprint software
for rapid prototyping.

IGES

Initial Graphics Exchange Specification (IGES) is a file format for transferring
graphics data between CAD/CAM systems. Autodesk DirectConnect 2010 R1
lets you import and export the neutral IGES format files (*.iges or *.igs)
from any number of CAD or modeling packages.

The software supports this format for Windows 32-bit and 64-bit operating
systems.

For information on the Autodesk products that support this format, go to
Supported products and translators on page 4.

NOTE Maya supports this translator on the Mac OS X operating system.

Software prerequisites

■ Install one of Autodesk Alias, Autodesk Maya (Windows version), or
Autodesk Showcase. (The Autodesk DirectConnect software installs at the
same time.)

■ The software does not require a license to import this file format.

■ For Autodesk Maya (Windows version), load a plug-in to use Autodesk
DirectConnect 2010 R1 translators. See Recommended system requirements
on page 22.
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NOTE Maya on the Mac OS X operating system does not support
DirectConnect 2010; however, it does support DirectConnect 2009. See
http://www.autodesk.com/maya-directconnect.

NOTE For information on additional software setup for Autodesk Alias, please
see the Autodesk Alias Data Transfer reference book and the Autodesk Alias
online help.

Additional software setup (Autodesk Alias)

For Alias Version 13.0.2, set the IGES system environment variable to use the
latest IGES translator:

1 From your Windows toolbar, select Start > Settings > Control Panel.

2 Double-click System. The Systems Properties window opens.

3 Click the Advanced tab.

4 Click the Environment Variables button.

5 Click New and enter the following information:

■ For Variable name, IGES

■ For Variable value, 1

Importing IGES files

1 In your Autodesk software, choose the appropriate menu item.

Choose...To import a CAD file into...

File > Open or File > Import > FileAutodesk Alias

File > Open Scene or File > ImportAutodesk Maya

File > Import ModelsAutodesk Showcase

File > ImportAutodesk Opticore Studio

2 Select a native IGES (*.iges or .igs) file from the file browser.

3 Click OK.
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The translator automatically launches and imports the file into the scene.

Exporting IGES files

1 In your Autodesk software, choose the appropriate menu item.

Choose...To import a CAD file into...

File > Export >Autodesk Alias

File > Export Allor File > Export SelectedAutodesk Maya

File > Export ModelsAutodesk Showcase

File > ImportAutodesk Opticore Studio

2 Select a native IGES (*.iges or .igs) file from the file browser.

3 Click OK.

The translator automatically launches and imports the file into the scene.

Troubleshooting (Autodesk Alias)

If the files you import contain unsatisfactory data, try changing the following
import options in Autodesk Alias:

Default Trim Curves Specifies the trim curves that the processor uses. You
can select parameter space curves, model space curves, or use the flag that is
present in the .IGES file. By default, the preference flag in the IGES files is
used.

Shrink Surface When ON, Alias detects trimmed surfaces whose trim
boundaries are the same as, or iso-parametric to, the natural boundaries of
the untrimmed surface. It then converts these surfaces into Alias surfaces by
shrinking the untrimmed surface to the trim boundaries.

When OFF, Alias converts all trimmed surfaces of this type to Alias trimmed
surfaces.
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Types of data imported

The Autodesk DirectConnect 2010 R1 for IGES translator imports ASCII format
IGES files with or without linefeed characters at the end of each record. The
software does not support Binary IGES files.

The software imports NURBS for this file format and maintains the following
information on import:

■ Surfaces and curves

■ Data organization (groups, layers, visibility, and instances)

■ Units

■ Colors

NOTE For information on this data in your Autodesk software, see Where to find
imported data on page 73.

NOTE Check the options in Alias to specify data importation. See the Alias Data
Transfer reference book and the Alias online help.

Identifying IGES supported entities in log files

The following table shows IGES entities supported on import by Autodesk
DirectConnect 2010 R1 for IGES.

NOTE The input translator ignores any entities with an entity use flag value 02
(Definition) except for entity use flag value with IGES Subfigure Definition entity
(Type 308).

IGES EntityFormType

circular arc0100

composite curve0102

conic arc, ellipse, parabola, hyperbola0-3104

copious data1106

copious data2106
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IGES EntityFormType

copious data11106

copious data12106

closed area63106

plane0108

bounded plane+/- 1108

line0110

parametric curve0112

parametric surface0114

point0116

ruled surface0 - 1118

surface of revolution0120

tabulated cylinder0122

direction0123

transformation matrix0124

rational B-spline curve0-5126

rational B-spline surface0-9128

offset curve0130

offset surface0140
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IGES EntityFormType

boundary entity0141

curve on surface0142

boundary surface0143

trimmed surface0144

plane surface0,1190

subfigure definition0308

associativity instance7, 9402

singular subfigure instance0408

IGES levels

The system adds all supported geometric IGES entities that are associated with
IGES level <n> to an Alias layer called LEVEL<n>.

For example, if a 126 B-spline entity directory entry indicates that it is on level
42, then it is added as Layer LEVEL42.

Open Inventor and Cosmo
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Autodesk DirectConnect 2010 R1 lets you import Open Inventor™ ASCII or
binary files (*.iv) or Cosmo™ scene binary files (*.csb) into supported
Autodesk software.

(Open Inventor is a 3D file format from Silicon Graphics Inc. with no relation
to Autodesk Inventor® software.)

NOTE For information on the Autodesk products that support these formats, see
the Supported products and translators on page 4.

Software prerequisites

■ Install the Autodesk product where you plan to import files using these
formats. (The Autodesk DirectConnect software installs at the same time.)

■ The software does not require a license to import these file formats.

Importing Open Inventor or Cosmo files

1 Choose the appropriate menu choice.

Choose...To import a CAD file into...

File > Open or File > Import > FileAutodesk Alias

File > Open Scene or File > ImportAutodesk Maya (Windows version)

File > Import ModelsAutodesk Showcase

File > ImportAutodesk Opticore Studio

2 Browse to and select an Open Inventor (*.iv) or Cosmo (.csb) file.

3 Click OK.

The translator automatically launches and imports the file.

Type of data imported

The software imports polygons and NURBS for these file formats and maintains
the following information on import:

■ Data organization (parent, child, and groups)
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■ Units

■ Materials

■ Textures

■ Polygonal Shapes

■ Transformation nodes

NOTE For information on locating this data in your Autodesk software, see Where
to find imported data on page 73.

Limitations

■ When importing Open Inventor files, the system automatically excludes
lines, cameras, lights, manipulators, tolerances, and animation.

■ The software only supports this format for Windows 32-bit operating
systems.

JT

The JT Open Program develops and supports the DirectModel format JT. It is
a format for the visualization of 3D models.

The software supports this format for Windows 32-bit and 64-bit operating
systems.
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NOTE For information on the Autodesk products that support this format and if
you need a license, go to Supported products and translators on page 4.

Software prerequisites

■ Install the Autodesk product where you plan to import files using these
formats. (The Autodesk DirectConnect software installs at the same time.)

■ The software requires a license.
For more information on how to purchase a license, go to the
DirectConnect Web site. (See Find the latest information on the Web on
page 19.) To install a license, refer to the Install_DirectConnect.pdf document
found on the installation CD.

Importing JT files

1 In your Autodesk software, choose the appropriate menu item.

Choose...To import a CAD file into...

File > Open or File > Import > FileAutodesk Alias

File > Import ModelsAutodesk Showcase

File > ImportAutodesk Opticore Studio

2 Select a (*.jt) file from the file browser.

3 Click OK.

The translator automatically launches and imports the file into the scene.

Type of data imported

The software maintains the following information when importing JT files:

■ Precise geometric data conversion

■ Data organization (parent and child hierarchal data, visibility, and
instances)

■ Units

■ Levels of detail (degrees of tessellation)
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■ Materials (brightness (shininess), ambient color, specular color, diffuse
color, and emission color)

■ Textures (embedded image files)

■ XTBREP and BREP topology

NOTE For information on locating this data in your Autodesk software, see Where
to find imported data on page 73.

NOTE In Autodesk Alias, look for options for specifying data importation. See the
Autodesk Alias Data Transfer reference book and the Autodesk Alias online help.

Limitations

■ Import options are not available.

■ The software automatically excludes curve geometry and animation when
importing a JT file.

Pro/ENGINEER®

Autodesk DirectConnect lets you import Pro/ENGINEER® part, assembly, or
PTC® Granite® files (*.prt, *.asm, or *.g) into supported Autodesk software.

The software supports this format for Windows 32-bit and 64-bit operating
systems.
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NOTE For information on the Autodesk products that support this format and if
you need a license, go to Supported products and translators on page 4.

Software prerequisites

■ Install the Autodesk product where you plan to import files using these
formats. (The Autodesk DirectConnect software installs at the same time.)

■ The software may require a license.
For more information on how to purchase a license, go to the
DirectConnect Web site. (See Find the latest information on the Web on
page 19.) To install a license, refer to the Install_DirectConnect.pdf document
found on the installation CD.

■ Export Pro/ENGINEER® files from your CAD software using Wildfire™

Release 4 (or lower) or PTC Granite Release 5 (or lower) specifications.

NOTE For information on additional software setup for Autodesk Alias, please
see the Autodesk Alias Data Transfer reference book and the Autodesk Alias
online help.

■ For Maya (Windows version), load a plug-in to use Autodesk DirectConnect
2010 R1 translators. See Recommended system requirements on page 22.

NOTE Maya on the Mac OS X operating system does not support
DirectConnect 2010; however, it does support DirectConnect 2009. See
http://www.autodesk.com/maya-directconnect.

Importing Pro/ENGINEER® files

1 In your Autodesk software, choose the appropriate menu item.

Choose...To import a CAD file into...

File > Open or File > Import > FileAutodesk Alias

File > Open Scene or File > ImportAutodesk Maya (Windows version)

File > ImportAutodesk Opticore Studio
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2 Select a Pro/ENGINEER® part, assembly, or Granite® file (*.prt, .asm,
or*.g).

3 Click OK.

The translator automatically launches and imports the file.

NOTE If you cannot import the files, try setting up the license for Autodesk
DirectConnect 2010 R1 for Pro/ENGINEER®. For licensing information, refer
to Licensing Autodesk DirectConnect on page 27.

NOTE To maintain the original positioning and orientation of part files in
your scene, import the assembly file. Importing part files before the assembly
file positions all of them at the origin (0,0,0) and removes the original
positioning.

Type of data imported

The software imports NURBS for this file format and maintains the following
data on import:

■ Precise geometric surface and topology information

■ Data organization

■ Tolerances and units.

NOTE For information on locating this data in your Autodesk software, see Where
to find imported data on page 73.

NOTE In Autodesk Alias, look for options for specifying data importation. See the
Autodesk Alias Data Transfer reference book and the Autodesk Alias online help.

Limitations

■ The software changes node names based on geometry, assembly, or part
names.

■ When importing a Pro/ENGINEER® file, the software automatically excludes
construction history, lines, and animation.

■ Granite does not support layers or curves.
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SolidWorks®

Autodesk DirectConnect 2010 R1 lets you import SolidWorks® part and
assembly files (*.sldprt and *.sldasm) into supported Autodesk software,
provided you have SolidWorks® installed, licensed on your machine, and
running. The software does not require an Autodesk DirectConnect license.

NOTE For information on the Autodesk products that support this format and if
you need a license, go to Supported products and translators on page 4.

Software prerequisites

■ Install the Autodesk product where you plan to import files using these
formats. (The Autodesk DirectConnect software installs at the same time.)

■ The software does not require an Autodesk DirectConnect license to import
this file format. Install and license SolidWorks® Versions 2005, 2006, 2007,
2008, or 2009 on the same machine.

NOTE For information on additional software setup for Autodesk Alias, please
see the Autodesk Alias Data Transfer reference book and the Autodesk Alias
online help.

■ For Maya 2010 (Windows version), load a plug-in to use Autodesk
DirectConnect 2010 R1 translators. See Recommended system requirements
on page 22.
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NOTE Maya on the Mac OS X operating system does not support
DirectConnect 2010; however, it does support DirectConnect 2009. See
http://www.autodesk.com/maya-directconnect.

Importing SolidWorks® files

1 In your Autodesk software, choose the appropriate menu item.

Choose...To import a CAD file into...

File > Open or File > Import > FileAutodesk Alias

File > Open Scene or File > ImportAutodesk Maya (Windows version)

File > Import ModelsAutodesk Showcase

File > ImportAutodesk Opticore Studio

2 Select a SolidWorks® part or assembly file(*.sldprt or *.sldasm). (If you
cannot see the files, start the SolidWorks® software, minimize its window,
and then try again to open the files.)

3 Click OK.

The translator automatically launches and imports the file into the scene.

NOTE To maintain the original positioning and orientation of part files in
your scene, import the assembly file. Importing part files before the assembly
file positions all of them at the origin (0,0,0) and removes the original
positioning.

Type of data imported

The software imports NURBS for this file format and maintains the following
information on import:

■ Precise geometric surface and topology information

■ Data organization

■ Tolerances and unit
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■ Colors

NOTE For information on locating this data in your Autodesk software, see Where
to find imported data on page 73.

NOTE In Autodesk Alias, look for options for specifying data importation. See the
Autodesk Alias Data Transfer reference book and the Autodesk Alias online help.

Limitations

■ The software automatically excludes construction history, lines, and
animation when importing a SolidWorks® file.

■ The software only supports this format for Windows 32-bit operating
systems.

STEP

Autodesk DirectConnect 2010 R1 lets you import STEP files (*.stp or *.step).
The software does not require a Autodesk DirectConnect 2010 R1 license.

The software supports this format for Windows 32-bit and 64-bit operating
systems.

NOTE Maya 2010 supports this translator on the Mac OS X operating system.
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NOTE For information on the Autodesk products that support this format, go to
Supported products and translators on page 4.

Software prerequisites

■ Install the Autodesk product where you plan to import files using these
formats. (The Autodesk DirectConnect software installs at the same time.)

■ Export STEP files from the CAD software using AP203 or AP214
specifications.

■ The software does not require a license to import this file format.
For more information on how to purchase a license, go to the
DirectConnect Web site. (See Find the latest information on the Web on
page 19.) To install a license, refer to the Install_DirectConnect.pdf document
found on the installation CD.

Importing STEP files

1 In your Autodesk software, choose the appropriate menu item.

Choose...To import a CAD file into...

File > Open or File > Import > FileAutodesk Alias

File > Open Scene or File > ImportAutodesk Maya (Windows version)

File > Import ModelsAutodesk Showcase

File > ImportAutodesk Opticore Studio

2 Select a native STEP (*.stp  or *.step) file from the file browser.

3 Click OK.

The translator automatically launches and imports the file into the scene.

Type of data imported

The software imports NURBS for this file format and maintains the following
information on import:

■ Precise geometric surface and topology information (ISO 10303:42)
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■ Data organization (layers)

■ Tolerances and units

■ Colors

NOTE For information on locating this data in your Autodesk software, see Where
to find imported data on page 73.

NOTE In Autodesk Alias, look for options for specifying data importation. See the
Autodesk Alias Data Transfer reference book and the Autodesk Alias online help.

Limitations

■ When importing a STEP file, the software automatically excludes
construction lines, modeling curves, and animation.

STL

Autodesk DirectConnect 2010 R1 lets you import and export STL files. The
software does not require a Autodesk DirectConnect 2010 R1 license.

The software supports this format for Windows 32-bit and 64-bit operating
systems.

NOTE For information on the Autodesk products that support this format and if
you need a license, go to Installing and Licensing on page 1.
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Software prerequisites

■ Install the Autodesk product where you plan to import files using these
formats. (The Autodesk DirectConnect software installs at the same time.)

■ The software does not require a license.
For Maya 2010 (Windows version), load a plug-in to used Autodesk
DirectConnect translator. See the Setting up additional software section of
Recommended system requirements on page 22.

NOTE Maya on the Mac OS X operating system does not support
DirectConnect 2010; however, it does support DirectConnect 2009. See
http://www.autodesk.com/maya-directconnect.

NOTE Maya 2010 supports this translator on the Mac OS X operating system.

Importing STL files

1 In your Autodesk software, choose the appropriate menu item.

Choose...To import a CAD file into...

File > Open Scene or File > ImportAutodesk Maya (Windows version)

File > Import ModelsAutodesk Showcase

File > ImportAutodesk Opticore Studio

2 Select a native STL (Stereolithography) file from the file browser.

3 Click OK.

The translator automatically launches and imports the file into the scene.

Exporting STL files

1 In your Autodesk software, choose the appropriate menu item.

Choose...To export an STL file into...

File > Export All or File > Export SelectionAutodesk Maya (Windows version)

STL | 63

http://www.autodesk.com/maya-directconnect


Choose...To export an STL file into...

File > Export and click the option boxAutodesk Alias

2 For Maya users, you can specify:■

■ the file format, (f bool) either ASCII or binary

■ the scaling factor (s float), which is set to 1 by default

■ if you want to process the colors for the STL file (w bool)

Click OK.

■ For Alias users, you can specify:

■ the file format

■ the tolerance levels used in the export of the file

Pick the meshes or shell to export, then click Accept.

Type of data imported

ASCII and binary STL files are supported.

NOTE For information on locating this data in your Autodesk software, see Where
to find imported data on page 73.
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UGS NX

Autodesk DirectConnect 2010 R1 lets you import UGS NX files (Version 6.0
and earlier) into supported Autodesk software.

The software supports this format for Windows 32-bit and 64-bit operating
systems.

NOTE For information on the Autodesk products that support this format and if
you need a license, go to Supported products and translators on page 4.

Software prerequisites

■ Install the Autodesk product where you plan to import files using these
formats. (The Autodesk DirectConnect software installs at the same time.)

■ The software requires a DirectConnect license.
For more information on how to purchase a license, go to the
DirectConnect Web site. (See Installing and Licensing on page 1.) To
install a license, refer to the Install_DirectConnect.pdf document found on
the installation CD.
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Importing UGS NX files

1 In your Autodesk import files, choose the appropriate menu item.

Choose...To import a CAD file into...

File > Open or File > Import > FileAutodesk Alias

File > Import ModelsAutodesk Showcase

File > ImportAutodesk Opticore Studio

2 Select a (*.prt) file from the file browser. (The software supports UGS
NX part and assembly (.prt) files version V13.0 to NX 5.0.)

NOTE There are options in Alias for you to specify data importation. For
details, see the Alias Data Transfer reference book and the Alias online help.

3 Click OK.

The translator automatically launches and imports the file into the scene.

Exporting UGS NX files (Autodesk Alias)

To export UGS NX files from Autodesk Alias:

1 In your Autodesk software, choose the appropriate menu:

Choose...To export a CAD file from...

File > Save AsAutodesk Alias

2 Go to the Alias documentation for more details on how to build a model
in for maximum compatibility between UGS NX and Alias.

Unigraphics proprietary format

Unigraphics is a solid modeling package based on the Parasolid kernel. The
package contains many (mostly optional) modules, for example CAD, CAM,
CAE, sheet metal applications, knowledge bases, quality control, and rapid
prototyping. The file structure is binary.
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The following table explains how both Autodesk Alias and Unigraphics call
in common elements.

Autodesk AliasUG

Span (curve)Segment

PointPoint

Span (surface)Patch

CV (control vertices)Pole

StitchSew

Patch precisionU/V grid

HistoryParameters

HullControl polygon (display only)

Horizon curveSilhouette curve

InvisibleBlank

SetReference set

CategoryCategory

BookmarkCustom view

Edit pointKnot point

Supported Unigraphics geometry and data mapping

The following sections describe the mapping process used for geometry types
and non-geometric data transfers between Alias and Unigraphics.
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Supported Alias geometry types

The following Alias geometry types can be exported to Unigraphics.
Non-geometry entities, such as lights, cameras, textures, windows, and
animation, are not supported by the translator. The numbers in the table
entries refer to Notes for Unigraphics entities below.

Unigraphics EntityAlias Entity

WCSConstruction Plane

Not supported at this time.Polyset

Rational CurveConic

Rational CurveArc

Rational CurvesCircle

LineLine

BCurveCurve

BSurface (1), (2)Surface

Face (1), (2)Trimmed Surface

Bounded Plane (1)Plane

Colour Attribute (3)Shader

Sheet BodyShell (Open)

Reference SetSet

GroupGroup

Layer (4)Layer
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Unigraphics EntityAlias Entity

CategoryCategory

Solid BodyShell (Closed)

Notes for Unigraphics entities

1 Unigraphics cannot have free-standing surfaces, so it maps all surfaces
to faces which must be attached to a sheet body.

2 Splits appear in surfaces having internal discontinuities at the
discontinuities.

3 Mapped as a Display Attribute of the mapped surface or shell.

4 Layer name is not mapped.

Supported Unigraphics entity objects geometry types (Alias)

Alias imports the following Unigraphics geometry types. The letters and
numbers in parentheses refer to Notes for Unigraphics entities below.

Alias EntityUnigraphics Entity Objects

Construction PlaneWCS

SurfaceBSurface

SurfaceBounded Plane

SurfaceCylindrical Surface

SurfaceConical Surface

SurfaceTabulated Cylinder

SurfaceRules Surface

SurfaceBlended Face Surface

UGS NX | 69



Alias EntityUnigraphics Entity Objects

SurfaceSurface of Revolution

SurfaceOffset Surface

SurfaceSculptured Surface

CurveBCurve

Line (Curve)Line

CurveArc

CurveConic

Point (Curve) (1)Point

Shell (Open) (2)Sheet Body

Groups/Instance (3)Assembly

GroupGroup

LayerLayer

CategoryCategory

SetReference Set

Blind Data ()Part Attribute

Shell (Closed)Solid Body
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Notes for Alias Unigraphics (object) entities

■ (1) A Unigraphics point converts to a degree 1 curve composed of two
coincident points. On export to Unigraphics, this construction converts
back to a Unigraphics point.

(2) If the sheet body only points to one face, then Alias converts the face
to a trimmed surface.

(3) This is a one-way mapping. Assemblies cannot be exported.

( ) Added as blind data. Can be re-exported.

Types of data imported

Autodesk DirectConnect supports the following UGS NX geometry types. (It
supports attributes such as name, color, layer, and visibility.)

■ Point

■ Line

■ BCurve

■ Ellipse

■ Parabola

■ Hyperbola

■ Surface Parameter Curve

■ Trimmed Curve

■ Intersection Curve

■ BSurface

■ Planar Surface

■ Spherical Surface

■ Cylindrical Surface

■ Conical Surface

■ Surface of Revolution

■ Spun Surface

■ Offset Surface
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■ Ruled Surface

■ Swept Surface

■ Toroidal Surface

■ Blended Edge Surface

■ Blended Bound Surface

■ Facet

■ Sheet Body

■ Solid Body

■ Part

■ Instance

■ Assembly

■ Category
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Where to find imported
data

For Autodesk Alias

Colors (Shaders)Tolerances and UnitsData Organization

Colors are visible from the
Render > Multi-lister >
Shaders window.

Unit settings are visible
from Preferences > Con-
struction Options.

Parts and assembly inform-
ation is displayed in the
Windows > Information >
Layer Categories window.

For information on these settings, menu items, and options, see the Autodesk
Alias Data Transfer reference book and the Autodesk Alias online help.
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For Autodesk Maya (Windows version)

NOTE Maya 2010 for Mac does not support DirectConnect 2010; however, it
does support DirectConnect 2009. See
http://www.autodesk.com/maya-directconnect.

Colors (Shaders)Tolerances and UnitsData Organization

Colors are imported as
shaders and are visible for

Unit settings are visible
from Window > Set-

Layer information is visible
from either the Display >

either the Window > Ren-tings/Preferences > Prefer-
ences.

UI Elements > Channel
Box/Layer Editor menu or dering Editors > Hyper-

Open the Categories tab
and choose Settings to

the Window > Relation-
ship Editors > Display
Layers menu.

shade or Window > Ren-
dering Editors > Multil-
ister window.change the Working Units

and Tolerances.Part and assembly informa-
tion is visible for either the
Window > Outliner menu
or the Window > Hyper-
graph menu.

For more information on these setting and menu items, see the Autodesk
Maya online help.

For Autodesk Showcase

Colors (Shaders)Tolerances and UnitsData Organization

Colors are imported as
materials and are visible

Unit settings are visible from
Edit > Model settings. Try

Layers, parts, and assembly
hierarchies appear in the

from Material > Material
Properties.

setting the tessellation or
number of levels of detail
(LODs) on file import.

Organizer window (Scene
> Organizer).
This window shows the ori-
ginal file hierarchy and lets To see the number of LODs

for a loaded file, select Op-you create your own ar-
tions > Performance andrangements of objects. You
Quality. Next, click thecan view and change the
Lock display quality tostate of objects from visible

to hidden to deleted. button and move the slider

74 | Chapter 7   Where to find imported data

http://www.autodesk.com/maya-directconnect


Colors (Shaders)Tolerances and UnitsData Organization

back and forth to see the
different LODs.

For more information on these settings and menu items, see the Autodesk
Showcase online help.

For Autodesk Opticore Studio

Colors (Shaders)Tolerances and UnitsData Organization

Colors can be shaders or
appearances. All colors are

There are no units to deal
with in Studio. All impor-

The node structure is visible
in the Scene Graph Editor,

visible in the appearanceted data is considered thelocated in the Window >
field of a shape node in thesame unit. Tolerances forScene Graph Editor menu.

It opens by default. scenegraph of the Scenetessellation are set in the
Graph Editor. AppearancesFile > Preferences dialog,

in the GeomX tab.

NOTE GeomX is not avail-
able until the GeomX
module is loaded in the
Modules tab (in the same
dialog) and Studio is restar-
ted.

are only visible in the Scene
Graph Editor. Shaders are
visible both in the Scene
Graph Editor and through
the Windows > Shader
List dialog.

To set tessellation toler-
ances, use the Import tes-
sellation section of the
GeomX tab. It is also pos-
sible to re-tessellate, using
the Window > GeomX >
Tessellate dialog and enter-
ing new settings.

For information on these settings, menu items, and options, see the Autodesk
Opticore Studio online help.
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Glossary

assembly An organizational file that fits together a collection of manufactured parts into a
complete model.

CATIA® V4 CATIA V4 is computer-aided design software from Dassault Systèmes. Autodesk
DirectConnect allows the exchange of 3D model data from CATIA V4, using .model, .session,

.exp, .dlv, and .dlv3 files.

CATIA® V5 CATIA V5 is computer-aided design software from Dassault Systèmes. Autodesk
DirectConnect allows the exchange of 3D model data from CATIA V5, using the native CATIA
part (.CATPart) and product (.CATProduct) files.

Cosmo™ A legacy 3D file format from Silicon Graphics Inc. using efficient binary compression
and *.csb (Cosmo Scene Binary) files.

DRAW (DR) A two-dimensional entity defined in the drafting and detailing world.

DWG AutoCAD drawing file) A file format used by Autodesk® AutoCAD® software that
contains lines, curves, and 3D data.

DXF (Drawing eXchange File) A file exchange format containing ASCII code and binary
representations of the objects in a DWG file.

Granite® One A CAD technology platform for design collaboration using solid models.

IGES (Initial Graphics Exchange Specification) A file format for transferring graphics data
between CAD/CAM systems. A neutral file format that can be imported into any number of
CAD or modeling packages.

Inventor (Open Inventor™) Open Inventor™ is a legacy 3D file format from Silicon Graphics
Inc. With no relation to Autodesk Inventor® software. Open Inventor is an object-oriented
3D toolkit that describes complete 3D scenes which can be made interactive and that are
optimized for OpenGL. It is an ASCII or binary file format.

JT file The DirectModel format JT is developed and supported by the JT Open Program. It is
a format for the visualization of 3D models.
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parts Parts are organized into a collection of groups, which then forms a project hierarchy.

Pro/ENGINEER® A product from Parametric Technology Corporation. A solid modeling
CAD/CAM/CAE software that requires positional construction tolerances.

SolidWorks® A product from SolidWorks Corporation. A solid modeling CAD/CAM/CAE
software that requires positional construction tolerances.

SPACE (SP) A three-dimensional entity defined in the 3D modeling world.

STEP An international standard for the exchange of geometric product definitions. STEP
formats that are relevant to Autodesk products are AP203 (general mechanical CAD) and
AP214 (automotive CAD).

STL An STL ("StereoLithography") file is a triangular representation of 3D surface geometry.
The surface is tessellated or broken down logically into a series of small triangles (facets).
Each facet is described by a perpendicular direction and three points representing the vertices
(corners) of the triangle.

V3Rx A file format generated by an older versions of CATIA, before CATIA V4.

ZPR ZPrint CAD format (ZPR) is a proprietary file format developed by Z Corporation and
used with ZPrint and ZEdit for printing on high definition color 3D printers. Autodesk
DirectConnect 2010 R1 lets you export ZPR format files (*.zpr) to use in the Autodesk Rapid
Prototyping solution.
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PCRE and BSD Licenses

PCRE License
PCRE (Perl-compatible regular expressions) is a library of functions to support
regular expressions whose syntax and semantics are as close as possible to those
of the Perl 5 language.

Release 7 of PCRE is distributed under the terms of the "BSD" license, as specified
below. The documentation for PCRE, supplied in the "doc" directory, is
distributed under the same terms as the software itself.

The basic library functions are written in C and are freestanding. Also included
in the distribution is a set of C++ wrapper functions.

The Basic library functions

Written by: Philip Hazel

Email local part: ph10

Email domain: cam.ac.uk

University of Cambridge Computing Service, Cambridge, England.

Copyright (c) 1997-2008 University of Cambridge

All rights reserved.

The C++ wrapper functions

Contributed by: Google Inc.

Copyright (c) 2007-2008, Google Inc.
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All rights reserved.

The BSD (Berkeley Software Distribution) license
Redistribution and use in source and binary forms, with or without
modification, are permitted provided that the following conditions are met:

■ Redistributions of source code must retain the above copyright notice, this
list of conditions and the following disclaimer.

■ Redistributions in binary form must reproduce the above copyright notice,
this list of conditions and the following disclaimer in the documentation
and/or other materials provided with the distribution.

■ Neither the name of the University of Cambridge nor the name of Google
Inc. nor the names of their contributors may be used to endorse or promote
products derived from this software without specific prior written
permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND
CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES,
INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR
CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT
NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER
CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT,
STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
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