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Chapter 1

Installing FBX Plugins 
Overview
FBX plugins are used by XSI to import, export, and 
convert files using the .fbx file format. This document 
describes how to install XSI FBX plugins on 
Windows® systems.

Plugins for XSI are available for use with Windows 
2000/XP. 

Manual Installation
In order for your 3D software to use these plugins, you 
must manually move these files into the proper 
directories.

This section describes the naming conventions, 
supported software versions, and installation 
process for using the .fbx file format with 
SOFTIMAGE® XSI®.

SOFTIMAGE XSI FBX Plugin Naming 
Conventions
The SOFTIMAGE XSI plugin consists of the 
fbxxsi40.xsiaddon add-on.

Supported SOFTIMAGE XSI Versions

fbxxsi30.xsiaddon and fbxxsi35.xsiaddon work on 
SOFTIMAGE XSI versions 3.0 and higher.

Installing the SOFTIMAGE XSI FBX 
Plugins
We recommend that you remove all old versions of the 
SOFTIMAGE XSI FBX plugins before installing new 
plugins.

To install the XSI FBX Plugin:

1. Start XSI.

2. In XSI, select File>Add-on>Install.

3. The Install Add-On dialog box appears (fig 1-1).

4. Click Browse (...). A file browser appears.

5. Select the file fbxxsi<xsiver>.xsiaddon in the 
directory where you downloaded the plugin and click 
Ok.

6. Click Install. You can install the Add-On to the User 
Add-Ons path. 

fig 1-1: Install Add-On dialog box
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Renaming Plugins
The XSI plugin is now functional and can be accessed 
through File>Import/Export>FBX File (fig 1-2). 

Removing the SOFTIMAGE XSI FBX 
Plugin
1. To remove the fbxxsi<xsiver>.xsiaddon, select 
File>Add On>Uninstall.

2. Select the FBX Plugin.

3. Click Uninstall.

Renaming Plugins
All plugins can be renamed as long as you do not 
change the file extension. However, it is only 
advisable to rename files when you want to keep more 
than one version of the FBX Plugins in the same 
directory.

If you choose to backup your files, all files with the 
same name as those you are installing should be 
renamed with the extension .FBX_BAK.

! Note:
It is recommended that you always remove old 
versions of FBX plugins before installing newer 
versions.

fig 1-2: The XSI Plugin can be accessed through 
File>Import/Export>FBX File
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Chapter 2

Softimage XSI
Plugins
Overview
This document shows you how to export scenes from 
Softimage XSI, and how to import .fbx files into XSI. 

This document also includes important information 
regarding the XSI features supported by this version 
of the FBX XSI plugin and MotionBuilder software.

! Note:
For information on supported features between 
Softimage XSI and other 3D software 
(cross-package support), consult the Alias 
website (www.Alias.com).

Using the XSI Plugins
This section describes how to export models from XSI 
using the .fbx file format, and how to merge .fbx files 
back into XSI. This section also discusses the 
supported XSI features and the plugin’s limitations.

Importing an FBX File to XSI
To import an .fbx file into XSI, select File>Import>FBX 
File. The Import FBX File dialog box opens (fig 2-1). 
Activate the appropriate import method from the Load 
Options area.

The options specified in the Import FBX File are saved 
when you exit the XSI application, with the exception 
of the Sampling rate, which is taken from the scene. 
See “Resample” on page 5.

Load Options

The Load Options area of the Import FBX File dialog 
box consists of the Exclusive Merge, Add New Scene 
and Merge options.

Exclusive Merge: Activate Exclusive Merge to merge 
solely the animation from the .fbx file with the 
corresponding XSI elements.

fig 2-1:  The Import FBX File dialog box
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Using the XSI Plugins
! Note:
Any modifications to geometries, textures, 
materials or envelope weighting in your 
MotionBuilder software is not included in the 
Exclusive Merge process.

Add to New Scene: Activate Add to New Scene to 
clear the XSI workspace before importing all data 
from the .fbx file. Objects created include all 
applicable textures, materials, animation and 
envelope weighting.

Merge: Activate Merge to use a combination of the 
Exclusive Merge and Add to New Scene. When you 
activate Merge, the plugin merges the animation with 
the elements that are already present in the XSI 
scene, and creates any other objects that are defined 
in the .fbx file.

Scene Scaling

Lets you change the scale factor. The default XSI unit 
is assumed to be one centimeter (1 cm).

Options

Activate the following options if you want to include 
them in the import:

• Cameras

• Lights

Animation
Enable Import Animation, and select a take in the 
take menu in the Animation area of the Import FBX 
File dialog box to import all the animation in the 
specified take.

Resample: Activate Resample to enter a new 
resampling rate for the animation. The frame rate is 
used if the plugin needs to perform FCurve 
resampling.

Special Options

Protect Expression Driven Animation Curves: Lets 
you retain any expression-driven animation for 
mergeback.

Import Skeleton Elements As Nulls: Lets you convert 
all effectors and bones to nulls. Weighting on 
envelopes is not affected by this conversion.

Keep XSI Effectors: Lets you keep all effectors as they 
were created. The import process keeps the effectors 
under the root node of its respective chain. 

! Note:
This flag must match the export.

Set Envelopes: Lets you import envelopes for 
skinning.

Force Normalization of Envelope Weights: Lets you 
correct any corrupted envelopes caused by 3D 
software that does not have normalized weighting 
systems. This feature can perform a limited amount 
of correction and is not normally necessary.

Reset/Ok/Cancel

Reset: Restores the Import FBX File dialog box to its 
last saved values.

Ok: Starts the import process.

Cancel: Aborts the import process.

FBX to XSI Import

To import an .fbx file to an .xsi scene:

1. Select Exclusive Merge from the Import FBX File 
dialog box.

2. Select any applicable options from the Import FBX 
File dialog box. Geometries are always imported.

3. Activate Import Animation and specify a take in the 
Take menu. 

4. Activate any special options applicable to the 
import. See “Resample” on page 5.

5. Click Ok.

Exporting from XSI
This section explains the Export FBX File dialog box, 
where you set the options for exporting a scene from 
XSI to an .fbx file.



Chapter 2:  Softimage XSI Plugins 5
Using the XSI Plugins
The options specified in the Export FBX File are saved 
when you exit the XSI application, with the exception 
of the Sampling rate, which is taken from the scene. 
See “Resample” on page 5.

! Note:
When you export using the XSI add-on, a dialog 
box appears asking you for a location to save 
your .fbx file. We recommend you create a new 
“FBX” folder as a default for all your saved .fbx 
files.

To export an .fbx file from XSI, select File>Export. The 
Export FBX File dialog box opens (“The Export FBX File 
dialog box” on page 5). Activate the following 
appropriate export options and click OK.

Scene Scaling

Lets you change the scale factor. The XSI unit is 
assumed to be one centimeter (1 cm).

Options
Activate the following options that you want to include 
in the export:

• Geometries 

• Shapes 

• Skins

• Cameras

• Lights

Geometries: If you disable the Geometries option, the 
scene is exported with no models. Cameras and 
Lights are not considered models by the Export FBX 
File dialog box. 

Shapes: If you disable the Shapes option, the scene 
is exported with no shapes.

Skins: If you disable the Skins option, the scene is 
exported without envelopes. The geometry is still 
exported but does not have weighting assigned to it.

Embed Media

Activate Embed Media in the Export FBX File dialog 
box Options area to embed the textures and images 
associated with the .fbx file when exporting. 

Embedding Media is useful when sending the .fbx file 
somewhere where the path of the textures is 
inaccessible but keep in mind that embedding media 
creates a larger file size.

Animation

Enable Export Animation to export all the animation 
from your XSI scene.

The plugin may require that some FCurves are 
resampled in the export process. If this is the case, 
the plugin uses the specified Frame rate, which 
normally is the same as the scene’s Frame rate.

Resample

Activate Resample to enter a new resampling rate for 
the animation. The Resample option is only used if 
the plugin has to resample FCurves.

Special Options

Keep XSI Effectors: Lets you export the skeleton as 
defined in XSI. This lets you keep all effectors as they 
had been created, as the export process does not 
transfer them under the last bone of their chain. This 
does not let you characterize your skeleton in 
MotionBuilder, although keyframing is still available.

If this option is disabled, the plugin moves the 
effectors so that their parent becomes the last bone 
of their chain. This is required for characterizing in 
MotionBuilder.

fig 2-2:  The Export FBX File dialog box
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Suppor ted XSI Features
You can enable this option to export a file that is 
readable by the QuickTime™ for FBX plugin, but do not 
forget to activate Embed Media in the Options area. 
See “Embed Media” on page 5. 

! Note:
When using XSI’s Animation Mixer to animate 
your character, make sure that the animation is 
plotted and that there are no clips in the 
Animation Mixer; otherwise the file may not 
export correctly. Save your file before deleting 
your clips.

Reset/Ok/Cancel

Reset: Restores the Export FBX File dialog box to the 
last saved values. 

Ok: Starts the export process.

Cancel: Aborts the export process.

XSI to FBX Export 

To export a character with XSI animation to an .fbx file 
so it can be opened in QuickTime using the QuickTime 
for FBX plugin:

1. Make sure that all skeleton hierarchies are similar 
to the XSI BASIC skeleton. The effectors must be 
located under their chain root of their corresponding 
branch to be exported correctly. See “Default XSI 
Skeletons” in the XSI documentation.

2. If you used XSI’s Animation Mixer, make sure that 
the animation is plotted and that there are no clips in 
the Animation Mixer.

3. Use the Export to FBX plugin in XSI. 
(File>Export>FBX...).

You can now open your .fbx file in MotionBuilder, or 
in QuickTime using the QuickTime for FBX plugin.

Merging Back FBX to XSI
Mergeback options are now contained in the Import 
FBX File dialog box. See “Importing an FBX File to XSI” 
on page 3.

Supported XSI Features
The following section contains the new features and 
bug fixes of the XSI plugin.

General
• Supports import/export of limits and 
RotationOrder. Limits are queried for every exported 
object (through the KinematicState) and set to the 
corresponding .fbx Node. On import, limits are 
applied even on mergeback, and overwrite anything 
that was previously set.

• Supports color vertex import and export.

• Supports embedded textures and their portable 
format (.tiff).

• Added a Convert2Tiff option in the user parameters 
and a script command for embedded textures. Use 
this option to save an embedded texture image that 
can be read on different platforms and by most 
applications. The script command is: Convert2Tiff 
<True|False>.

• Support for Limits. Limits support now requires the 
following warning to warn about non-supported 
features:

Modified rotation space:
UseLimitsForRotationSpaceOnly is enabled in the FBX 
file. Since the feature is not supported by this plugin, 
the rotation limits for the following node(s) will be 
dropped.

Custom Properties
Because of type limitations in .fbx files, the following 
conversions are applied.



Chapter 2:  Softimage XSI Plugins 7
Known Limitat ions
Export (XSI to FBX) 

! Note:
During export, the plugin tries to get the UI range 
and uses it as the minimum and maximum 
values.

Import (FBX to XSI) 

! Note:
If the minimum and maximum ranges in the .fbx 
property has any undefined (or identical) values, 
the plugin overwrites them using the arbitrary 
value of 400. In case of COLOR or VECTOR 
imports, these relationships are lost since 4 or 
3 individual siDouble properties are created.

Default XSI Skeletons
The default XSI skeleton is not immediately 
compatible with the exporter. MotionBuilder software 
does not support effectors parented to the root of a 
chain. 

In order to have a compatible skeleton usable in your 
MotionBuilder software, the plugin can be configured 
to automatically move the effector to the expected 
location: the child of the last joint of the chain (see 
fig 2-3).

! Note:
This operation is performed automatically 
unless the Keep XSI Effectors option is 
activated.

The above move can be done even when the effector 
is somewhere else in the hierarchy. 

! Note:
If you are planning to keyframe an XSI “Skeleton 
- Man/Woman - Complete/Basic” in 
MotionBuilder after exporting with the Keep XSI 
Effectors option active, MotionBuilder 
constraints must be used to animate the 
skeleton effectors.

Known Limitations
The following section contains bugs and limitations of 
the XSI plugin, as well as some advance notes for 
users.

General
The following are limitations that apply generally to 
the XSI plugin:

siEmpty Ignored.

siDispatch Ignored.

siString Ignored.

siFloat REAL

siDouble REAL

siBool BOOL

siBye Ignored.

siUByte Ignored.

siUInt2 Ignored.

siUInt4 Ignored.

SiInt Ignored.

siInt2 Ignored.

siInt4 Ignored.

REAL siDouble

BOOL siBool

INTEGER siInt4

COLOR 4 siDouble

VECTOR 3 siDouble

fig 2-3: Chain Root Effector
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Known Limitat ions
• Export and import of ambient color is supported, 
but not animated.

• Visibility properties are supported but not 
animated.

Geometry

The following are the Geometry limitations for the XSI 
plugin.

Implicit Prims: Implicit Prims are not supported in 
this version of the FBX for XSI plugin. A message 
appears on the status bar whenever you try to 
import/export/animate/mergeback Implicit Prims.

Instead, convert them to a polymesh or NURBS 
geometry type.

Polymeshes

Import and export of polymeshes is supported in this 
version of the FBX for XSI plugin.

Supported export of:

• geometry

• normals

• global material/polygon clusters with associated 
material

• single layered textures with associated material. 
(Only one image can be defined in a material 
channel.)

Envelopes: Export and Import supported. Mergeback 
does not affect any existing data.

Shapes: Animation, Export and Import supported. 
Mergeback does not affect any existing data.

During mergeback, if the number of found shape clips 
for the model is less than the number of shape 
FCurves, a message is logged and the clips are left 
unchanged. If the number of clips is more than the 
number of shape FCurves, the first nbShapes clips 
are affected (even if it may not be with the correct 
data).

During Export, cluster shapes work only if the cluster 
contains all the points of the mesh. If it does not, a 
message is displayed in the status bar. 

Create Shape keys using the Save Shape Key option 
in the Animate Module under deform>Shape>Save 
Shape Key. 

NURBS
Import and export of NURBS is supported in this 
version of the FBX for XSI plugin.

Envelopes: Export and Import supported. Mergeback 
does not affect any existing data.

Shapes: Animation, Export and Import supported.

During mergeback, if the number of found shape clips 
for the model is less than the number of shape 
FCurves, a message is logged and the clips are left 
unchanged. If the number of clips is more than the 
number of shape FCurves, the first nbShapes clips 
are affected (even if it may not be with the correct 
data).

During Export, cluster shapes work only if the cluster 
contains all the points of the mesh. If it does not, a 
message is displayed in the status bar.

Create Shape keys using the Save Shape Key option 
in the Animate Module under deform>Shape>Save 
Shape Key. 

! Note:
When you create shapes, you must create them 
in “Local Reference Mode” and disable the 
Normalize state of the Animation Mixer. Do this 
by right-clicking one of the tracks under the 
compound track.

Bones
Import/export/animate/mergeback of Bones is 
supported in this version of the FBX for XSI plugin.

Materials
Import/export/mergeback of Materials is supported. 
Animation of Materials is not supported in this 
version of the FBX for XSI plugin. Mergeback does not 
affect any existing data.

Meshes export all materials assigned to polygon 
clusters. When NURBS are used, only the global 
material is exported.

Textures

Export of Textures is supported. Animation of Textures 
is not supported in this version of the FBX for XSI 
plugin. Mergeback does not affect any existing data.
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Advanced Notes
No layered textures are currently supported. 

Only one texture can be assigned with NURBs and its 
SwapUV flag is set.

When importing, the Texture file is connected to the 
diffuse properties of the Shader.

Lights
The following are the Light limitations for the XSI 
plugin.

General Lights Limitations

• Different Key interpolations for the same FCurve 
are not supported.

• When merging back, any earlier animations are 
deleted before being replaced by the new one. If 
there are no animations, the FCurves are still 
cleared.

The following Light types and properties are fully 
supported:

• Light Positions

• RGB Colors

• Cone Angles

• Intensity

• Interest/Rotation

XSI Light Conversion: The following XSI light types are 
converted into the MotionBuilder equivalents:

Cameras
The following are the Camera limitations for the XSI 
plugin.

General Camera Limitations
• Different Key interpolations for the same FCurve 
are not supported.

• When merging back, any earlier animations are 
deleted before being replaced by the new one. If 
there are no animations, the FCurves are still 
cleared.

• The following Camera types and properties are fully 
supported:

• Camera Position

• Interest/Rotation

• Roll

• Vertical FOV

Near/Far Plane: Animation is not supported for the 
Camera Near/Far Plane in this version of the FBX for 
XSI plugin.

Advanced Notes
The following are notes for advanced users of the XSI 
plugin:

Skeletons
A skeleton template has been created as part of this 
add-on. If the add-on is installed, the template is 
found in a sub-directory called Templates under the 
Add-Ons installation path.

Access the skeleton template through the Skeleton 
Templates toolbar in View>Custom Toolbars.

! Note:
The advantage of this template over the default 
XSI skeletons is that the skeleton template is a 
skeleton ready to be characterized in 
MotionBuilder with a simple drag and drop 
operation.

The Skeleton Template is a default Skeleton - Man - 
Complete model with some modifications, such as 
renamed nodes that match MotionBuilder’s 
Character Settings naming conventions, and some 
re-parented nodes. The Model node is named 
Human_ Skeleton_A.

XSI Light Type FBX Light Type

Box Spot

Neon Point

Sun Infinite
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Special  Notes
When you export to FBX, disable the Keep XSI 
Effectors option so the skeleton is correctly displayed 
and animated in MotionBuilder. If you do not disable 
the Keep XSI Effectors option, you must create 
parent-child constraints to create the correct bone 
movement.

Import

XSI skeletons typically use a COG constraint null. If 
this is the case, it must be deactivated or removed in 
order for the imported animation to function correctly.

Exporting NurbSurfaceMesh

In XSI, NurbSurfaceMesh can be used to define a 
collection of NurbSurfaces. The Plugin exports only 
the last element of the collection.

Batch Processing
The following new Batch Processing commands must 
be installed. See the packaging for further details 
about Batch Processing command installation.

• FBXExportScaleFactor

• FBXExportGeometries

• FBXExportShapes

• FBXExportSkins

• FBXExportCameras

• FBXExportLights

• FBXExportEmbedMedias

• FBXExportAnimation

• FBXExportFrameRate

• FBXExportKeepXSIEffectors

• FBXImportMode

• FBXImportScaleFactor

• FBXImportCameras

• FBXImportLights

• FBXImportAnimation

• FBXImportProtectExprDrivenFC

• FBXImportSkeletonsAsNull

• FBXImportKeepXSIEffectors

• FBXImportSetEnvelopes

• FBXImportForceNormEnvelope

• FBXImportNameSpaceReplace

! Note:
The FBXImportNameSpaceReplace command is 
not a dialog box option. You can use to replace 
a namespace string with another during import. 
The format of the string argument is: 
Current_name=new_name 
Do not insert spaces around the “=” or they are 
considered part of the name. 
This command lets you, for example, transfer 
the attributes of one character to another with 
the same topology. That is, the same hierarchy 
and the same node names - the only difference 
being the namespace.

To see the arguments and their type, go to the 
Views>Custom Toolbars>Customize dialog box and 
select one of the FBX commands. The arguments are 
displayed in the description section of the dialog box.

All dialog options are unavailable from the command 
line but, since they are stored, you can set them using 
the provided commands. Only these values can be 
set.

To run a batch: 

ExecuteScriptCommand “FBX import”, Array 
(“x”,1)
Two arguments are currently supported:

• Filename (mandatory and with full path - not 
validated)

• TakeID (number of the take to be imported)

This imports x using take #1, where “x” is the name 
of the file. Specifying Take “0” is the equivalent of 
specifying no takes - it loads the last take in the file. 

Any number greater than or equal to the number of 
takes in the file does not load the animation.

Special Notes
The following section describes the rationale of the 
FBX XSI plugin, as well as provides you with sample 
workflows and additional information.
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Special Notes
Textures
MotionBuilder must use optimizing algorithms to 
minimize the texture memory usage because the 
current version of the FBX XSI plugin does not fully 
support texture properties such as scaling, rotation, 
translation, and swap of texture UVs, as well as 
projection modes other that UV.

The optimizing algorithms can sometimes cause two 
or more distinct textures in XSI to merge into a single 
texture in MotionBuilder. 

Thus, when you modify certain texture properties in 
MotionBuilder, more than one object at the time may 
be affected.

If this is the case, it is always possible to prevent the 
textures from merging by using distinct image files. 
For example, one object may use a file called 
“myFile.jpg” and another object can use 
“myFile_Copy.jpg”, even though both files’ contents 
are the same. 

This limitation causes problems only if the editing of 
the texture properties occurs in MotionBuilder.

Making Cluster Shapes
The FBX XSI plugin does not support the full 
functionality of the Animation Mixer. 

For cluster shape animation, the FBX XSI plugin works 
best when it finds a Compound Shape Clip containing 
the Shape Clips, all with the same start-end interval.

! Note:
When you create shapes, you must create them 
in “Local Reference Mode” and disable the 
Normalize state of the Animation Mixer. Do this 
by right-clicking one of the tracks under the 
compound track.

A sample workflow for creating a shape animation is 
as follows:

1. Select the working object, that is, the one for 
which we are making the shape animation.

2. Select the Save ShapeKey function. Do not use the 
Store ShapeKey.

3. Select a cluster of points and edit them.

4. Move the time cursor.

5. Select the whole set of points of the model

6. Select the Save ShapeKey function.

7. Repeat steps 3 to 7 for each shape. 

! Note:
Make sure that there us the same amount of 
Clip Shapes as Source Clips, or an error occurs.

Options
This version of the FBX XSI plugin allows you to 
transfer the animation recorded on the FBX file back 
to the corresponding element in the XSI scene. 

As explained in the Export section, the Keep XSI 
Effectors and Import Skeletons as Null toggles affect 
the way the FBX XSI plugin imports the data. See 
“Exporting from XSI” on page 4.

Both the Keep XSI Effectors and Import Skeletons as 
Null toggles can be used when merging back. In every 
cases the plugin matches the elements from the FBX 
file to the elements in the scene regardless of the 
active toggles. However, the states of these toggles 
affect the way the data is processed.

When the Import Skeletons As Null toggle is active, 
the plugin does not try to perform any processing on 
the FCurves and simply transfers the FCurves to the 
XSI elements, without any further checks or data 
validation.

When the Import Skeletons As Null is inactive, then 
the Keep XSI Effectors toggle is examined and it 
behaves according to its state. 

As explained in the Export section, the Keep XSI 
Effectors toggle must always be set to the same value 
that it had when the scene was exported to .fbx 
format. 

If the Keep XSI Effectors toggle is not active, the FBX 
XSI plugin re-computes the animation on the 
effectors. This is because the plugin assumes that 
the effector is no longer a child of the last bone of the 
chain, as in the case of the .fbx file. 

At the same time, to prevent the IK solver from trying 
to find a solution, the FBX XSI plugin verifies that 
there are no Translation FCurves on any bones and/or 
effectors. If Translation FCurves on bones or effectors 
are found, a message is displayed and the translation 
animation is cleared.
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Special  Notes
If the Keep XSI Effectors toggle is active, the FBX XSI 
plugin still checks for Translation FCurves on bones. 
If Translation FCurves are present on effectors, they 
are not affected, nor is any warning issued. 

If this is the case, the IK solver may compute a 
different solution, and the resulting animation may 
not correspond with the .fbx version.
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