Lightwave FBX Plugins Guide

Version 6.0
November 2004



Copyright © 2004 Systéemes Alias Québec Inc.(“Alias”) and/or its licensors. All rights reserved.

Document: Lightwave FBX Plugins Guide
Version: 6.0

Date: November 2004

All documentation ("Documentation”) contains proprietary and confidential information of Alias. The Documentation is
protected by national and international intellectual property laws and treaties. Use of the Documentation is subject to the
terms of the license agreement that governs the use of the software product to which the documentation pertains (the
"Software"). The authorized licensee of the Software is hereby authorized to print no more than one (1) hardcopy of any
Documentation provided in digital format per valid license of the Software held by such licensee. Except for the foregoing, the
Documentation may not be translated, copied or duplicated in any form (physically or electronically), in whole or in part,
without the prior written consent of Alias.

MotionBuilder, FILMBOX, HumanlK, Open Reality, and FBX are registered trademarks of Alias in the United States and/or
other countries. Alias, the swirl logo, and Maya are registered trademarks of Alias Systems Corp. in the United States and/or
other countries. 3ds max and Discreet are either registered trademarks or trademarks of Autodesk, Inc./Autodesk Canada
Inc. in the United States and/or other countries. Adobe, the Adobe logo, Acrobat, and Distiller are either registered
trademarks or trademarks of Adobe Systems Incorporated in the United States and/or other countries. Apple, Mac,
Macintosh, and Quicktime are registered trademarks of Apple Computer, Inc., in the United States and other countries. Intel
and Pentium are registered trademarks of Intel Corporation in the United States and other countries. Macromedia and Flash
are registered trademarks of Macromedia, Inc. in the United States. Microsoft and Windows are registered trademarks of
Microsoft Corporation in the United States and/or other countries. SGI, Silicon Graphics, and OpenGL are registered
trademarks of Silicon Graphics, Inc., in the United States and/or other countries worldwide. Softimage and XSI are either
registered trademarks or trademarks of Avid Technology, Inc. in the United States and/or other countries. LightWave and
LightWave 3D are registered trademarks of NewTek, Inc. Wacom is a trademark of Wacom Co., Ltd. All other trademarks
mentioned herein are the property of their respective owners.

Alias

SYSTEMES ALIAS QUEBEC INC.| 4428 ST-LAURENT BLVD | SUITE 300 | MONTREAL, QUEBEC H2W 1Z5



Contents

1: Installing the Lightwave FBX Plugins

OVEIVIEW . ot e e 1
Manual Installation .. ............ ... ... ....... 1
LightWave 3D Plugin Naming Conventions ........ 1
Installing the LightWave FBX Plugin on Windows . ... 1
Removing the LightWave FBX Plugin from Windows .. 2
Installing the LightWave FBX Plugin on Mac OS X ... 2
Removing the LightWave FBX Plugin from Mac OS X . 2
Renaming Plugins . . ... ... .. 3

2: LightWave Plugin

OVEIVIEW . . o 5
Using the LightWave Plugin . .................... 5
Exporting from LightWave .................... 5
Importing to LightWave . ..................... 5
Merging Animation Back to Lightwave ........... 6
Supported LightWave 8.x Features . ............... 6
ObjectFiles . ..... ... i 6
Lights ..o 6
Cameras . . ... 7

Additional Features and Enhancements .......... 7

iii






Installing the Lightwave
FBX Plugins

Overview

FBX plugins are used by Lightwave® to import, export,
and convert files using the .fbx file format. This
document describes how to install FBX plugins on
Windows® and Mac™ OS X systems for LightWave.

Plugins for Lightwave are available for use with
Windows 2000/XP and Mac OS X.

Manual Installation

In order for your 3D software to use the Lightwave
plugins, you must manually move these files into the
proper directories.

This section describes the naming conventions,
supported software versions, and the installation
process for manually installing and removing the FBX
Plugin for LightWave 3D.

Note:

LightWave 3D FBX plugins are currently available
on the Windows and Mac OS X platforms only.

LightWave 3D Plugin Naming
Conventions

LightWave 3D FBX plugins conform to the following
naming conventions:

fbx1lw80.p

The plugin extension .pis a standard .dl/file that uses

a non-standard extension, as required by LightWave
3D.

Note:

A plugin’s name can be changed as long as the
extension (.p) stays the same.

Supported LightWave 3D Versions

The FBX Plugins are only available for LightWave 8.0.
These plugins will not run correctly on other versions
of LighWave:

fbx1lw80.p

Installing the LightWave FBX Plugin
on Windows

If, in earlier versions of LightWave, you had created
any menu items to import, export, or merge fbx
scenes, they will have to be removed and re-created.

1. Locate the fbxIw80.p file. By default, the plugin
files are copied to the
C:\Alias \FBXPlugins<fbxver>\Iw80 folder.

2. Make sure that the version number of the plugins
matches the version of LightWave 3D installed on
your computer. Plugins run correctly only on the
version of LightWave 3D for which they were created.

3. Remove all old versions of the LightWave 3D FBX
plugins before copying the new plugin.

4. Copy the fbxiw80.p plugin file into the
\lightwave-3d-80\Plugins \Input-Output folder.

5. Launch LightWave 3D Layout.

6. Click Utilities>Add Plugins. The file browser
appears, prompting you for a .p plugin.

7. Select the copied fbxIw80.p plugin file in the
\Plugins\Input-Output folder, and click Ok.
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Manual Installation

If the plugin is installed correctly, the options “Export
to FBX”, “Import from FBX”, and “Merge with FBX”
appear in the Edit>Edit Menu Layout menu, in the
Plug-ins Command list.

8. Add the FBX command to your File menu. Select
"Edit>Edit Menu Layout...", then drag the commands
"Import from FBX" and "Merge with FBX" from
Plug-ins to your "File>Import" menu. Drag the
command "Export to FBX" to your "File->Export"
menu.

Removing the LightWave FBX Plugin
from Windows

1. Exit LightWave.

2. Go to the FBX Plugin Install shield.

3. Locate the LightWave plugin.

4. Disable the LightWave option.

Installing the LightWave FBX Plugin
on Mac 0OS X

If, in earlier versions of LightWave, you had created
any menu items to import, export, or merge fbx

scenes, they will have to be removed and re-created.

1. Double-click the package icon to start the
installation.

Note:

The LightWave FBX Plugin is installed to the
selected disk drive in the following folder:
<Macintosh™ Drive>/Applications/LightWave
3D 80/Plugins/Input-Output.

2. Enter your login password to continue the
installation when prompted.

Note:

You must obtain administrator privileges to
continue installation.

The Welcome window appears.
3. Click Continue to start the installation process.

4. Select a destination disk for your application to be
installed and click Continue.

5. Click Install (or Upgrade). A progress bar indicates
the time remaining of the installation; when the
progress reaches 100%, the Finish button is
activated.

6. Click Finish to exit the installation program.
7. Launch LightWave 3D Layout.

8. Click Layout>Plugins>Add Plugins. The file browser
appears, prompting you for a .p plugin.

9. Select the copied fboxIw80.p plugin file in the
\Plugins\Input-Output folder, and click Ok.

If the plugin is installed correctly, the options “Export
to FBX”, “Import from FBX”, and “Merge with FBX”
appear in the Edit>Edit Menu Layout menu, in the
Plug-ins Command list.

10. Add the FBX command to your File menu. Select
"Edit>Edit Menu Layout...", then drag the commands
"Import from FBX" and "Merge with FBX" from
Plug-ins to your "File>Import" menu. Drag the
command "Export to FBX" to your "File->Export"
menu.

Disabling the LightWave FBX Plugin
1. Launch LightWave 3D Layout.

2. Select Layout|Plugins|Edit Plugin.

3. Click File.

4. Locate the fboxIw80.p plugin in the list, select it,
and click Delete to remove the plugin.

5. Exit LightWave 3D.

Removing the LightWave FBX Plugin
from Mac OS X

1. Exit LightWave

2. Locate the fbxIw80.p plugin. This file is found in
the <application directory>/Plugin/Input-Output
directory.

3. Delete the fbxIw80.p file.



Renaming Plugins

All plugins can be renamed as long as you do not
change the file extension. However, it is only
advisable to rename files when you want to keep more
than one version of the FBX Plugins in the same
directory.

If you choose to backup your files, all files with the
same name as those you are installing should be
renamed with the extension .FBX_BAK.

Note:

It is recommended that you always remove old
versions of FBX plugins before installing new
versions.

Chapter 1: Installing the Lightwave FBX Plugins
Renaming Plugins
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LightWave Plugin

Overview

This document shows you how to export .fbx files
from LightWave, how to import .fbx files into
LightWave, and how to merge back animation from
.fox files to LightWave.

This document also includes important information
regarding the LightWave features supported by this

version of the FBX plugin and MotionBuilder software.

Note:

For information on supported features between
LightWave and other 3D software
(cross-package support), consult the Alias
website (http://www.Alias.com).

MotionBuilder software supports LightWave version
8.x and higher through the FBXLW8O0.P LightWave FBX
plugin. Importing and exporting files between
MotionBuilder software and LightWave 8.x is covered
in “Using the LightWave Plugin” on page 5 and
“Importing to LightWave” on page 5.

This plugin provides additional support for weight map
deformations and multi-layered object deformations.

Using the LightWave Plugin

This section describes how to export models from
LightWave using the .fbx file format, and how to
import .fbx files into LightWave.

Exporting from LightWave

To export from LightWave:
1. Select File>Export>Export to FBX.

By default, the pop-up menu offers to export the FBX
file with the same name and directory as your
LightWave scene file.

FBX Exporter 5.1

fig 2-1: FBX Exporter menu.

2. You can modify this by clicking the browser button
next to the Address field.

3. Select which parameters to export and click OK.
Wait for a confirmation dialog box.

Importing to LightWave

To import to LightWave:
1. Launch LightWave 8.
2. Select File>Import>Import from FBX.

3. Use the file browser to select the FBX file to be
imported, and the folder where your .Iwo files are
created (fig 2-2).

FBX Importer 5.1

fig 2-2: FBX Importer window.

4. Select the take you want to import.
5. Click OK.
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Supported LightWave 8.x Features

Merging Animation Back to
LightWave

To merge back to LightWave:
1. Launch LightWave 8.
2. Load the original LightWave scene.

3. Save the scene as “working copy” (or any other
temporary name).

4. Select File>Import>Merge with FBX

5. In the pop-up menu, click the browser button next
to the address field, select the appropriate FBX file,
and click OK.

FBX Merger 5.1

fig 2-3: FBX Merger window

Supported LightWave 8.x
Features

This section lists the following LightWave features
supported by the FBX plugin. Features are organized
by object files, lights, and cameras.

Note:

LightWave envelopes are treated as
MOTIONBUILDER FCurves.

Object Files

Textures

Embedded textures are
supported.

Only UV texture maps are
supported. Other mapping
methods are not yet supported.

TRS Animation

Translation, Rotation and Scaling
animation is supported for
importing and exporting.

Bones Only Limbs are supported. Limb
Nodes are converted to nulls.
EndoMorphs EndoMorphs are supported.

Bone and Morph animations are
both supported at the same time
on the same object.

The LightWave MorphMixer must
be applied to the object before
EndoMorphs can be imported into
your MotionBuilder software.

Line Polygons

Line polygons (polygons with two
vertices) are supported on
export.

Lights

Multiple Lights

Multiple lights are supported for
importing and exporting.

Translation and

Translation and Rotation

SubPatch
Objects

SubPatch objects are not visible
as a SubPatch surface inside
MotionBuilder software.

When exporting SubPatch
objects, you can activate the
Freeze option, which makes the
object a Polygon mesh.

If you do not activate the Freeze
option, the Subpatch cage is
saved as a mesh.

Rotation animation is supported for
importing and exporting.

Lights in » LW Point, Linear, and Area light

MotionBuilder = Point light

software - LW Spot light = Spot light
« LW Distant light = Infinite light
All Lights keep their original light
type when you merge back to
LightWave.

Cone Angle Light cone angle animation is

Animation supported.

Intensity Light intensity animation is

Animation supported.

Color Animation

Light color animation is
supported.

Materials Multiple materials are supported.




Cameras
Multiple Multiple cameras are supported
Cameras for importing and exporting.

Camera Field of
View Animation

Camera vertical and horizontal
field of view animation is
supported. They are converted to
Zoom Factor in Lightwave.

Translation and

Translation and rotation

Rotation animation is supported.
Camera Roll Camera Roll is supported when
Animation the camera has a Camera

Interest (target).

Camera Interest

There is limited support for
Camera Interest (target). The
camera must not be parented.

Camera Pixel
Ratio

Supported.

Camera Target

Improved camera target support.
If you parent the camera, the
animation is plotted to the
camera.

Camera Up Node

Camera up node supported by
plotting its effect on the camera
roll animation.

Additional Features and
Enhancements
This section lists the additional features and

enhancements found in version 6.0 of the FBX
plugins for Lightwave.

Merge Back

» Improved functionality. The merge back process no

longer requires the FBX Root.

Chapter 2: LightWave Plugin
Supported LightWave 8.x Features
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