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If You are New to Alias
If you have never worked with Alias before, becoming proficient with a new 3D package 
can seem intimidating. Alias provides you with a powerful, integrated  
tool set that supports your design process. The interface includes behaviors unique to 
Alias; this booklet introduces a few basic concepts that will help you navigate  
through the product.

Other Sources
Learning Alias 2011 book
The learning book PDF contains practical tutorials that take you through step-by-step 
exercises and introduce you to Alias techniques. The tutorials are also included in the 
on-line documentation with animations to show you how to complete the tutorials.

Online documentation
By default, the documentation is 
installed with the product. 

If you install the documentation 
separately, you have one more 
step to do: in Alias, type the 
documentation path in Preferences 
> General Preferences under the 
System tab to access the help 
directly from the package.

Help
The Help menu has a “What’s 
this?” function. To show the online 
help for a specific tool or menu 
item, choose Help > What’s This?, 
then click the tool or menu item 
you want help with.

Reference Card
A Reference Card is provided at the rear of this guide for you to pull out and use to help 
remember the keyboard and mouse combinations described in the documentation.

Using this Booklet
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Alias is, simply put, a creative design tool. Unlike most 3D applications, its unique 
capabilities address a broad range of needs specific to design professionals. Here are a 
number of applications that you will find Alias very well suited for...

Ideation  Sketch and illustrate 
(paint functionality not available  
in all products).

Overlay Drawings  Sketch 
over existing 3D data (paint 
functionality not available in all 
products).

Concept Modeling and Rendering  
Create iterative concepts to study 
form and color (rendering is not 
available in all products).

Digital to Physical Modeling 
Workflow  Work with scanned 
data of physical models and output 
models for rapid prototyping.

Production Modeling  Create 
geometry for manufacture.  

Design Communication  Teams with technical modelers and designers can communicate 
with each other by annotating and drawing on the same working files.

Design Presentations Using Alias  
Annotate over live  
data and dynamically modify 2D 
images or 3D geometry during  
your design critique.

Animation  Create design animations 
to communicate use-cycles, turntable 
animations, fly-by sequences, or 
animated exploded views (not 
available in all products).

Output Images  Create high 
quality print images for sales and 
marketing collateral (not available  
in all products).

Whether a designer or a modeler is creating iterative 
concept models or Class-A technical surfaces, Alias 
provides the tools to capture complex form and to 
visualize it. 

Multiple Uses

Sketching is an integral part of design. Not only does 
Alias offer a full feature paint workflow, it provides a 
single environment from which 2D drawings flow into 
the 3D process. 

Image courtesy of Alexander Barros Neves, Duncan 
McCall.

 Image courtesy of Mike Jelinek, Autodesk.
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Launching for the First Time
When you launch Alias for the very first time,  
you are prompted to create a user_data directory.  
This directory is created in My Documents\Autodesk\
Alias (Windows) or Documents/Autodesk/Alias (Mac) .

The user_data directory contains your project folders, 
required by Alias. By default, Alias creates a project 
called Demo for you to use. A project contains many 
folders, the most important ones being the wire folder 
(where your actual file is saved) and the pix folder (the 
default location where images are saved). 
 
Workflow Setting

If you run an Alias product that includes 
both modeling and painting features, this 
window opens. Selecting Paint opens Alias 
in an environment developed for 2D 
sketching. Selecting Default opens Alias in 
an environment suitable for modeling and 
sketching.

GETTING   STARTED
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Work Area
The modeling and 
paint windows  
appear in this space.

Shelf
This is your customizable 
tool shelf. If you are running 
Alias for the first time, a 
default shelf is loaded that 
contains all the commonly 
used tools.

Menu
The menu contains  
functions that affect  
the scene, the  
picked object, or the  
Alias program.

Prompt Line
Displays instruction on  
the current tool, error 
messages, and any input 
that you key in.

Layer Bar
Lets you organize 
and manage 
objects in your 
scene using layers.

Palette
All tools for creating and  
manipulating objects are  
located in tabs in the palette.  
Unlike the Shelf, the tools are  
fixed in their tabs, and cannot  
be moved, making it ideal  
for learning.

Key Interface Elements

Control Panel
This panel has three separate modes supporting Modeling, 

Visualization, and Painting. It combines shelves, tools, and 
display controls to provide focused workflow functionality.

Marking Menus
Gesture-based menus can be activated 
right at your cursor for very quick access 
to commonly used tools.  

Cursor
This is the general cursor in Alias. Some 
features have special cursors.

Interface Overview
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Windows
Windows are automatically generated when you  
create a new file (File > New in the menu bar). 
By default, there are 4 windows, each  
occupying a quarter of the space.  
At any time, you can change the  
number of windows or position  
and resize them to suit your  
needs. The windows can overlap  
each other. In this case, the active  
window is drawn on top.

Although you can view multiple windows  
at once, you can only work in one at a time.  
Moving the cursor into a window and clicking  
in it, or on its window bar, makes that window  
active. New windows and window layouts can  
be selected from the Layouts menu.

In Alias, windows are associated with virtual cameras, so a window 
is like looking through a view finder at your data. Windows are 
independent of your data, so closing a window does not delete 
objects in your scene or the cameras. There are 3 types of 
windows in Alias: Orthographic, Perspective, and Paint.

The Orthographic Window
The orthographic window gives you a two dimensional view of  
the objects in your scene. These windows provide fixed views.  
The orthographic views are Top, Left, Right, Bottom, Front and 
Back.   
 
The Perspective Window 

This window lets you view your 3D scene from any angle. You can 
tumble, zoom, and pan the camera view. You can turn off the 
perspective in this window and tumble in an orthographic mode.  
The perspective window also has an associated Viewing Panel, 
allowing access to preset views and camera controls.

The Paint Window 
The paint window is for viewing Canvases and Overlays. This 
window type supports sketching and annotation workflows.
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+ ++
The Orthographic Window The Perspective Window

TrackZoomTumble

You have complete viewing freedom in the 
perspective window, plus essential control with 
the ViewCube and NavBar which automatically 
appear when the Shift + Alt (Windows) or Shift + 
Command (Mac) modifier keys are pressed.

Track your view and zoom in and  
out in the orthographic window.

Look at selected objects.

Orient tumble behavior 
to an active 
construction plane.

Switch between 
orthographic and 
perspective view.

Previous View
Toggle between current  
and previous view.

Interface Overview continued

Navigating Windows
Building your muscle memory using keyboard modifier keys combined with mouse button 
clicks lets you interact with Alias with incredible finesse. The Shift, Ctrl, and Alt keys 
(Windows) or Shift, Control, and Command keys (Mac) are important elements of the 
interface and can dramatically speed up your ability to switch between common 
functionality without ever losing focus. Manipulate the views inside your windows by 
clicking on tools, or by using modifier keys and mouse button combinations.

ViewCube and 
NavBar
26 Preset Views
Click faces, corners, and 
edges.
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Menu, Palette & Shelves
The menu bar contains a series of pull-down 
menus. Each menu contains a group of 
related commands.

 This symbol indicates that an item  
 has an associated option window or 
editor. To open, click on the icon. You will 
see this symbol in the menu pull-down as 
well as the palette and shelf.

 This symbol indicates a submenu.  
 Click and hold on icons that have this 
symbol to open a cascading list.

 This symbol also indicates a  
 submenu, but is used over tool  
 icons in the palette and shelf. Click  
 and hold on icons that have this 
symbol to open a cascading list.

Tabs can be found in 
the palette and the 
shelves. They can 
be opened by 
clicking on the tab 
with the left mouse 
button.

Tab contents can also 
be accessed without 
actually opening the tab. 
Clicking on the tab with 
the right mouse button 
opens a cascading 
menu revealing all the 
contents. This is useful 
when you do not want to 
lose focus from the 
current set of open tabs.
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Options, Editors & Panels

The Control Panel is an 
embedded window, exposing 
common functionality for 
different tasks. Open the 
panel from Windows > 
Control Panel in the menu 
bar or from the marking 
menus.  
To switch the Control Panel 
mode, click on the pulldown 
button at the top of the panel.  

Option windows 
let you change 
settings of the 
associated tool. 
They cannot stay 
open while you 
continue to work.

Control windows 
and Editors are 
persistent and can 
remain open while 
you work, allowing 
you to adjust 
values and/or 
switch settings.

Interface Overview continued

(Windows only) 
If you have several 
Control Windows and 
Editors open at one time, 
you may want to quickly 
toggle them all on and off. 
Use Ctrl + Space.
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Marking Menus
Marking menus™ appear when you hold the Shift and Ctrl (Windows) or Shift and Control 
(Mac) keys plus one of the mouse buttons. Once you know the positions of the primary 
tools, you can activate a selected tool by gesturing in its direction before the marking menu 
even appears. Marking menus provide the fastest method for choosing tools.

Look below for the default tool setting for each corresponding mouse button
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It is important to understand  
the basic concepts of how  
Alias manages objects.  
This is fundamental to how  
objects are picked and manipulated.

There are many different types of 
objects in Alias, but almost everything 
that exists in your scene follows the 
same basic principles. To begin, many 
objects, like curves, surfaces, and 
lights, are handled similarly. All these 
objects can be abstracted to a single 
unit, or entity.

Individual objects can be grouped together to form a ‘new’ 
object. This concept is an essential aspect of Alias. 
You will find some preset objects have separate components. 
More importantly, as Alias is a surface modeling package, any 
single part of a model can be made up of many separate 
surface patches. You will be using the Group functionality 
(Edit > Group from the menu bar) to help collate individual 
objects. In Alias, you create groups within groups, which is 
helpful for managing objects with many parts.

This cylinder is made of three 
separate surfaces, grouped 
together into one object. Using 
the Object Lister (Windows > 
Object Lister), you can view 
objects in your scene to see 
group relationships. The Object 
Lister also helps you select 
objects and serves as a layer 
manager.

Curve Surface Light

BASIC CONCEPT     of OBJECTS
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Like a hinge, the location of 
the pivot defines the point 
of rotation.

An object scales up 
and down from the 
pivot point.

The pivot does not affect free 
movement of objects unless the 
object is being snapped to a 
specific target.

Pivot Points
Each object has its own 
pivot point; a group has 
a pivot point and each 
of the components that 
makes up the group 
has its own distinct 
pivot point as well. You 
will find taking 
advantage  
of pivot points to be 
invaluable when 
manipulating objects.

When new curves, surfaces, 
or groups are created, the 
pivot point is automatically 
created at the origin (0,0,0 in 
coordinate space).

Position the pivot point using 
Transform > Local > Set Pivot 
from the palette to better 
control how your objects 
behave.
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There are many pick tools in the palette, but Pick Object 
and Pick Component are the main tools for selecting 
objects in your scene. Pick Object always selects the top 
of a group. Pick Component always selects the individual 
entities, never the group.

To pick, choose a pick 
tool, click on or draw a 
marquee over the object 
you want to pick.

To add more objects, click on them. To remove 
them from the set of picked objects, click on 
them a second time.

When you click an area with more 
than one valid object to select, a 
Pick Chooser appears. Clicking on 
the list lets you easily and accurately 
make your selection.

BASIC CONCEPT     of PICKING
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Displaying Controls
To effectively use Alias, you 
need to become accustomed to 
toggling on and off the display of 
certain elements. This is 
particularly true of Control 
Vertices. These points reveal the 
mathematics of the geometry 
and are also a powerful method 
for you to sculpt form.

Master display controls are located in  
Object Display > Control. This control 
window gives check boxes for turning  
the various controls on and off.  

You will find that it is easier to access  
these controls in the Marking Menus  
and the Control Panel.

To pick Control Vertices (CVs), use Pick CV from the palette or from 
your Marking Menus. The pick behavior is the same as that of picking 
objects, so you can click to select or marquee select multiple CVs.

When a CV is selected, it shares the same pivot point as the curve that 
it is a part of. This is useful for scaling the points and rotating. Unlike 
objects, CVs do not snap to the pivot. If you snap move a CV, the CV 
itself goes to the target location. This is also true of other points and 
handles.

Another important pick tool is Pick Nothing. Pick Nothing deselects all 
objects in the scene. This tool is a momentary function. As an example, 
if you are in Pick Object and realize you have selected the wrong 
curves, you can invoke Pick Nothing to deselect; however, you are still 
in Pick Object mode and can continue selecting, without having to 
choose that tool again.
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Transform Tools
There are numerous transform tools in the Palette. The primary tools are Move, Rotate,  
and Scale, which can also be found in the default marking menu and shelf.

When you make one of these transform tools active, it is important to know that the tool 
remembers the last pick mode that you were in. Effectively, these tools are combined 
selection/transform tools. In these tools, Shift + Click allows you to add and remove 
selected items. It is a good practice to keep your cursor away from objects when moving,  
to prevent accidentally selecting and moving the wrong object.

The Orthographic Window
There are exclusive behaviors for moving in the orthographic and perspective windows. In 
the orthographic windows, the left mouse button allows free transform. Using the middle 
mouse button constrains the transformation horizontally for Move and Scale (regardless of 
which orthographic view you are in). The right mouse button constrains vertically.

Transforming Objects

+
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The Perspective Window
In the Perspective Window, the 
mouse buttons correspond to 
the world space coordinates 
(X,Y, Z) to allow free movement 
in all axes. When moving, the 
left button constrains to X, 
middle to Y, and right to Z. For 
rotation, the buttons rotate 
around each axis; and the scale 
tool scales your objects 
uniformly.

The Perspective Window can be used exclusively in a one 
window workflow. Select any of the ViewCube’s 26 preset 
views (faces, corners and edges). These presets behave 
like the orthographic windows and thus have the same 
move constraints using the middle and right mouse 
button.

Snapping
Snapping functionality can be accessed from the top right corner of the Alias interface. 
Three icons let you toggle Point Snap, Grid Snap, and Curve Snap. Snapping can also be 
momentarily turned on using modifier keys and works in combination with the middle and 
right mouse button move constraints.

Snap to CV and Edit 
Points.

Snap to the grid. Grid 
spacing can be adjusted in 
Palette > Construction > 
Grid Preset.

Snap to curves, surfaces and 
 construction entities. The number of 
curve snap divisions can be set in 
the Snap options box by clicking the 
triangle next to the Curve Snap icon.
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Image courtesy of Martti Lemieux, Autodesk

Designers can quickly experiment 
with, and modify shapes at any 
stage of the design process.
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NURBS
Alias is a NURBS (Non-Uniform Rational 
B-Splines) surface modeler. Learning to model 
with NURBS geometry is like learning to model 
with any physical or digital medium: you need to 
understand how the material behaves and how to 
manipulate it to achieve the desired shape.

This booklet does not teach you how to model in Alias, but does 
provide you with a few introductory concepts on techniques. To learn how 
to effectively model in Alias, take advantage of the Alias learning material and on-line 
documentation.

Curves
Curves play a key role in modeling in Alias.  
Curves are used to define shapes and profiles that  
are the basis for surface creation. 

For this reason, it is important to create good quality curves, as poor shape or heavy 
geometry will be passed onto the surface you create.

Anatomy of a Curve
Alias draws CVs differently to let you tell the difference between the start and the end of a 
curve. The first CV (at the start point of the curve) is drawn as a box. The second CV is 
drawn as a small “U” to show the increasing U dimension from the start point. All other CVs 
are drawn as small Xs. The first two CVs and the last two CVs define the tangential 
direction of the start and end of the curve respectively.

Control Vertex (CV)

Edit Point (EP)
Edit points mark the connection 
point between two spans.

Hull
Helps to visualize 
relationship 
between CVs.
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Surfaces
Modeling using NURBS geometry requires a little strategy. The surface tools help you 
create surfaces, but can neither predict the type of object you are creating nor the purpose 
of the model (whether it be for a rough sketch model or for production). After you become 
familiar with various modeling techniques, you will be able to determine how to best achieve 
your forms.

Anatomy of a Surface

Control Vertex (CV)

Isoparametric Curve (Also called 
Isoparm) 
Isoparms represent the math of the  
surface and describe the spans (also 
called segmentation). This surface has 
one span in one direction and two 
spans in the other. Spans give more 
detail to the surface (more CVs). You 
can learn more about geometry in the 
tutorials and on-line documentation.

Surface Edge

Hull

Modeling Principles continued

With Alias, you can combine procedural 
modeling, direct modeling, and trimmed surfaces 
to develop your digital model. As a result, there 
can be different methods to achieve the same 
form. Though this may seem to complicate the 
modeling process, it means Alias has the 
versatility to support a broad range of modeling 
applications. Alias can be used to develop 
conceptual sketch models, production modeling, 
through to aesthetic technical surfacing.
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Create a skin 
across multiple 
curves.

Fill in boundaries defined 
by connecting curves.

Extrude profiles freely or 
along path curves to 
create sweeping surfaces.

Another approach is to manipulate CVs 
on surfaces. This technique is called 
Direct Modeling.

Surfaces can be intersected, creating curves-
on-surface. The curve-on-surface can be used 
to build from as well as define regions to trim.

Surfaces of any shape can be obtained 
by modifying existing surfaces. A set  
of trim tools allows you to cut back 
surfaces using other surfaces or 
curves to define the trim parameters. 

Modeling Approaches
Curve-based surface creation tools can be used to create the primary surfaces of your 
object.

Primary surfaces can be blended with 
secondary surfaces (also known as transition 
surfaces). In Alias, transitions can be created 
with regular surface tools, as well as specific 
filleting and blending tools.
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Construction History
Construction history is the saved information about how an object was created. When you 
edit construction history, the object automatically updates. 

For almost every tool, Alias gives you the option of 
saving the history of how an object was constructed. 
This means you can edit the curves, surfaces, 
manipulators, tool options, and so on,  
that were used to create an object, and the object 
automatically updates.

To open the History view, click the  icon in the 
menu bar. Using Marking Menus, you can quickly 
Query Edit surfaces with history. Simply click on 
the target and you are automatically returned back 
to the tool that created the history. History View can 
also be used to re-invoke, select, suspend, and 
delete history.

Key Interface Element
Many tools have option buttons that 
appear at the bottom corner of the active 
window. In Alias, the space bar is the hot 
key for accepting the outlined button. 
For repeated operations, this can 
dramatically speed up tasks.
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Construction Options
Depending on the type of modeling that 
you are doing, Construction Settings can 
play a vital role in the quality of your 
model, particularly if the data needs to 
be moved into another system.

Using Preferences > Construction 
Options, you can choose from a list of 
presets or customize the construction 
units and tolerances.

Visualize

The ability to visualize your surfaces is essential to properly 
creating them.

Alias provides a variety of evaluation tools for thorough surface 
analysis. These tools can be found in the palette and Control 
Panel.

Interactive Hardware Shading and 
Diagnostic Shading support the 
modeling process. Further details 
on visualization can be found in 
the next section.
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Image courtesy of Alexander Barros Neves, Duncan McCall.

Visualization

Autodesk Alias is capable of a  
variety of visualization techniques,  
useful for modeling as well  
as creating images.
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Interactive Shading
Interactive shading uses your computer’s graphics card to draw surfaces. There are two types of 
interactive shading: Hardware Shade and Diagnostic Shade. Either can be used to help visualize your 
model, but each provides different functionality.

Wireframe Display
The wireframe provides valuable visual feedback on your geometry, but does not 
helps you visualize what the surfaces look like.

Diagnostic Shading
Diagnostic Shading, located in Object Display from the menu bar and in the Control 
Panel, is a fast method of shading your surfaces. The controls are simple, allowing 
your whole model, or specific target surfaces, to be automatically shaded. As the 
name implies, the tool is designed to allow fast diagnostic visualization of your 
surfaces to support your modeling workflow. 

Hardware Shade
Hardware Shade is a completely different method from Diagnostic Shading. Hardware Shade requires 
Shaders to represent different materials and lights to illuminate your scene. You can achieve more realism 
with this type of shading. Access this tool from Window Display > Hardware Shade, from your marking 
menus, or from the Control Panel’s Visualization mode.

 
The first time you use Hardware Shade in a scene, a default shader is applied 
and a pair of default lights is automatically created.  

Hardware Shade is adjustable, allowing you to have settings for fast performance 
or high quality display. High quality features include interactive reflection of 
environment maps, surface characteristics (such as highlights, texture maps, 
bump textures, etc.) and options to see ground plane shadows and reflection.

Some products provide 
advanced diagnostics, such 
as Curvature and Contact 
Analysis.

Multi Color or Random  
Color can be applied  
to your surfaces.

Evaluate the flow of  
highlights with stripes  
or reflection maps.
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Shaders
Shaders are descriptions of surface materials or effects that 
control what a surface looks like. They are necessary for 
Hardware Shade as well as for Software Rendering.

You can manage shaders from Render > Multi-lister > List All 
and from the Control Panel’s Visualization mode.

The Multi-lister contains the settings for all shaders, the 
environment, and all lights in your scene.

Double-clicking any of the items in the Multi-lister opens the 
associated editor. From here, you can adjust the settings to 
achieve the material or effect you are looking for.

Types of Shaders
There are four shading models for Shaders. A shading model is a representation of how light 
bounces when it hits a surface. Different models simulate different types of materials better.

Shaders can be dragged onto geometry from 
the Control Panel with the middle mouse 
button, or assigned to the selected objects from 
the Multi-lister or Control Panel.

Visualization continued

Lambert 
Good for matte materials 
(chalk, matte paint, 
unpolished surfaces).

Phong  
Good for glassy or  
glossy materials  
(plastic, glass, chrome).

Blinn 
A versatile shader that can 
simulate glossy and dull metallic 
materials (brass, aluminum).  

Lightsource  
This shader has no shading.  
Good for representing 
incandescent or fluorescent 
objects (TV screen, light bulb).
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Control Panel, Visualization Mode

Library
These folders contain environments and shaders that  
can be loaded into your scene.

List of the current environment and shaders in the scene.

Action buttons
Assign shader to selected surfaces, pick surfaces 
associated with the current shader, duplicate shader,  
and create layered shader.

Shader Parameters
Displays the basic settings of the current shader for  
quick editing.

Action buttons
Hardware shade, toggle model, Multi-lister, and delete 
unused shaders in scene.

Creating Images
To save an image from any of the windows, use File 
> Export > Current Window. This is a useful way to 
capture snapshots of work-in-progress, or to export 
high resolution captures of fully shaded geometry.
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Rendering
In addition to interactive rendering, most Alias products have tools that generate effects 
and renderings. These are located in the Render menu and include all the global settings 
for render output, editors, and rendering features.

Software rendering provides different features and additional details to image creation than 
can be achieved with Hardware Shade. There are three methods of rendering: Raycasting, 
Raytracing, and Hidden Line Rendering.  

Raycasting 
Produces smooth shaded 
renderings that include 
basic shadows. Raycasting 
is faster than raytracing, but 
does not produce reflections 
or refraction (although you 
can simulate these using 
clever shaders). 

Hidden Line Rendering 
Produces outline renderings 
of objects that are filled with 
flat, unshaded color. 

Raytracing
Produces smooth shaded 
renderings that include 
optical effects (reflections 
and refraction) and smooth 
shadows. It creates more 
realistic renderings, but is 
slower than raycasting. 

Renderings can be launched using 
Render and Direct Render. Before 
launching a rendering, however, you 
need to set up Render Globals. In this 
editor, you establish the quality settings 
that are used by Direct Render and 
Render. For Render, the output format 
and image resolution are also defined 
in Render Globals.

Visualization continued
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Render
Choose the render method from the option box. Choosing 
Render opens a browser where you name your file. The 
default location is your current project in your My Documents\
Autodesk\Alias\user_data (Windows) or Documents/
Autodesk/Alias/user_data (Mac) directory.

Direct Render
Direct Render calculates the image directly on top of 
the active window. Using the right mouse button in  
the Direct Render window opens the options to 
re-render and save the image to your clipboard.

Ambient Occlusion
Ambient occlusion renders shading based on an omni-directional light source to create general 
areas of shadow on your model. The feature set is located in Render > Ambient Occlusion.

When calculated, the results are immediately visible on your Hardware Shaded geometry, 
adding incredible realism to your interactive display. The shadows are applied to the 
geometry and are saved with your file; however, they cannot update interactively. When 
you move geometry in the 3D scene, the ambient occlusion does not update. In order to 
update the ambient occlusion it needs to be deleted and re-calculated.

Ambient occlusion is also used with software renderers, adding a global illumination-like 
quality to your renderings. Once again, the shadows are “baked” onto the geometry, so if 
you use the animation functionality in Alias, you will not be able to combine ambient 
occlusion with moving parts.

Hardware Shade with ambient occlusion. Raytraced rendering with ambient occlusion.
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Sketch Rendering
Sketch rendering is a method for previewing concept 
sketches directly on basic geometry. This technique 
is ideal for quickly drawing in details rather than 
investing modeling time on undecided design 
features and details.

Canvas > Project sketch converts images into a 
special shader and layers it onto the model. The 
original shaders applied on the model remain, 
leaving them completely adjustable.

You must have images in Canvas planes in order to 
use Project Sketch. You can create Canvases using 
Alias integrated sketching, or import images using 
File > Import > Canvas Image.

Animation
In Alias, creating animation involves establishing a timeline, then varying one or more 
properties of objects (for example, position or color) over time.

All the animation features are gathered together in the Animation menu, including 
animation tools, editors, time slider, and playback controls. All animation sequences output 
to a series of still images corresponding to the number of frames in the timeline.

Output Image in Animation > Editors > Playback Options saves out still screen images from 
whichever screen is active in the Alias interface. This tool can be used to capture models in 
wireframe or hardware shaded modes.

Activating the animation option in Render > Render Globals sets Alias up to create a 
software rendered sequence of images when the next render is initialized.

Animation > Keyframe is the primary method of creating animation. Animation 
> Tools > Set Motion is another method, good for moving objects along set 
paths.

Animation > Turntable automatically creates a turntable animation for you 
based on the number of frames you want for a single revolution.
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Image courtesy of Mike Jelinek, Autodesk

Sketching

The Autodesk Alias Paint workflow has now  
been reorganized so that it is more intuitive to  
those designers coming from a 2D background.
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Integrated paint functionality opens up many creative possibilities in Alias. Most products 
provide a complete paint kit, allowing you to use Alias as a full featured 2D sketching 
package. Some products expose the basic paint and canvas tools for annotation and 
mark-up.

Canvas Planes
Canvases are like sheets of paper that exist in the 3D environment. You define the canvas 
in the Canvas > New Canvas option box. Canvases are created to scale at the centre of 
the window (by default). You can position and scale them with the regular transform tools 
without affecting the canvas resolution.

Overlay Planes
Overlay planes can be created in the 
perspective window. Unlike canvas planes, 
they do not exist in the 3D environment. 
Overlays only exist from the particular view 
from which they are created. Overlay planes 
allow you to annotate or create drawings 
directly over your geometry. Use Windows > 
Editors > Construction Plane Editor to 
quickly access the overlay planes that 
you’ve created.

Using the Paint window, you can view all the canvases and overlays in the scene. Working 
with overlays in the paint window allows variable zoom without losing registration of the 
underlying geometry.
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Hot Keys
When a brush tool is active, you can use hot keys to interactively adjust brush settings.  
This image illustrates the default hot keys.

You can customize your hotkeys in Preferences > Interface > Hotkeys/Menus. In addition 
to the menu and palette sections in this editor, paint-specific bindings can be found under 
Special > Paint.

Brush Modes
F - Cycle through brush modes
1 - Paint
2 - Erase
3 - Hide
4 - Show
5 - Smear
6 - Blur
7 - Sharpen

S - Brush size

T - Rotate

X - Reset brush

R - Inner/outer radii

P - Aspect ratio

L - Clone brush 
      reset

O - Opacity

C - Color grab
V - Twist canvas

Z - Snap mode

=  - Marquee add

-  - Marquee subtract

Space - If a brush
is in use, opens the 
Hot Spot Editor to 
access paint 
functionality.

Ctrl + K - Clear layer
Ctrl + L - New layer
Ctrl + M - Merge down
Ctrl + T - Transform layer
Ctrl + I - Invert layer

Alt + H - Toggle Marquee
Alt + I - Invert mask
Alt + X - Delete active layer
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Paint Workflow
The paint workflow focuses the interface for 2D sketching and drawing. The menu and 
palette are ‘shortened’ to hide the modeling, rendering, and animation tools. The workflow 
also has a unique set of marking menus and a paint shelf.

Sketching continued

+

+

The middle and right mouse buttons have 
tools for managing layers and shapes, 
more suitable for mouse control.

+

The left mouse button marking 
menu is optimized for stylus use.
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Paint Shelf

The default paint shelf is populated by all the tools that are useful for a paint workflow. The 
shelf and marking menu are ideal for use in full screen mode. Full screen display is located 
in Layouts > Full Screen or from the marking menus.

Key Interface Elements

Canvas Layer Editor

Canvas Plane tools

Layer type

Construction Plane Editor

Visibility

Control Panel, Paint Mode

Shelf

Geometry  
Display

Active tool  
controls

Quick  
access  
buttons

Quick access buttons

Links to image layers

Opacity slider
Image layer stack

Number of mask layers 
associated with 
selected image layer

Layer preview image

Mask layer stack



38 The Customizable Interface

Preferences > Interface > Shelf Extras provides 
blank spaces that can be dragged onto a shelf 
to help visually separate tool groups.

Alias provides you with a unique environment to optimize how you use the tools. As you 
become familiar with the tools and the workflows, you can tweak the interface to meet your 
own personal preferences.

Customizing Shelves and Marking Menus
Using the middle mouse button, you can drag any menu or palette 
item onto any of the shelves in the Alias interface (Shelf, Control 
Panels, Marking Menus, Command Stepper).

Using shelves gives you the ability to have different versions of  
the same tool.

When an item is dragged 
onto the shelf, a red arrow 
appears showing you where 
it will be placed. Holding the 
cursor above another icon 
draws an arrow, allowing you 
to create a cascading group 
of tools.
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Marking Menus
Marking menus use the shelf interface for set up, but do not support the cascading 
functionality. The images below illustrate how the marking menus display when you 
customize the marking menu shelf using Preferences > Interface > Marking Menus.

If four items are placed into the Marking Menu shelf, the four tools are automatically 
balanced into the North, East, South, and West positions.

When more than four items are placed on the shelf, the Marking Menus automatically use 
the 45 degree positions as well. The items fill the eight main directions (which are the 
gestural positions). All additional items fill in a menu below the South position.

N

S

W                  EN     E     S     W =

Right-click on the shelf to reveal the Shelf 
option pulldown. You can make new tabs to 
add to the current shelf set, save the shelf 
set, or load an existing shelf set. Shelf sets 
are saved in your UserPrefs folder.

1
2

NW NE

SW SE

=
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Renaming Shelf & Marking Menu Items
To rename items in your shelf or marking menus, double-click the icon while pressing the 
Ctrl (Windows) or Control (Mac) key. An option box opens where you can edit the name of 
the selected icon.

Hotkey/Menus

The Hotkeys/Menu Editor lets you assign hotkeys 
and hide tools (short menus). Each workflow has  
its own set of short menus allowing you to sculpt 
your workflow.

The Customizable Interface continued
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Preferences Overview
The Preference menu contains all the editors and features related to the Alias environment.

Workflow
Switch between 
workflows

Interface
Various interface 
options

Performance 
Options
Controls updates 
of animation 
expressions, 
constraints, 
construction 
history and 
locators.

User Options
Load or save user 
options.

Menus
Enable Menu item 
filtering (Short Menus). 
Set-up using Interface 
> Hotkeys/Menu 
Editor.

General Preferences
Option Window for 
general UI settings.

Selection Options
Choose how Pick tools 
work.

Construction 
Options
Unit and Tolerance 
settings.

User Preferences
Load or save all 
custom settings.

All user preferences are stored in the 
UserPrefs2010 folder, located in  
Documents and Settings\<username>\
Application Data\Autodesk\Alias (Windows ) 
or  
Home/Library/Preferences/Autodesk/Alias 
(Mac). 

If this directory is renamed or deleted, Alias 
launches with default settings.


