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Introducing Autodesk® ImageModelerTM
  2009

ImageModeler 2009 offers architects, designers and entertainment content creators a 
new approach to 3D modeling; by generating 3D models from 2D digital images or 
panoramas. Using advanced technology, ImageModeler 2009 extracts 3D information 
from still images to construct accurate 3D models and scenes with highly realistic 
textures automatically applied. The software also delivers a number of productivity-
enhancing features including a rules toolset that enables you to make point-to-point 
measurements, and a mapping feature that allows you to define how each texture will 
be created. Additionally, ImageModeler 2009 offers support for Autodesk® 3ds Max® 
Autodesk® Maya® and AutoCAD® software.

How does ImageModeler work?

Typically, to create a 3D model of an object from photos, the object to be modeled 
should be shot from different viewpoints. By identifying common characteristics on 
the object in each of the images displayed, you provide the software with the 
information that it needs to automatically calculate the position, the orientation, and 
the characteristics of the camera (or cameras) used to take the photos. ImageModeler 
can then retrieve the spatial coordinates of any 3D element from its projections within 
two images at least.

If you are creating a model from a single image only, you can define the angles and 
perspectives in the shot so that ImageModeler can calibrate spatial coordinates from 
the single image.

By means of the 3D points rebuilt by triangulation, or using the image(s) as visual 
guides, ImageModeler enables you to create polygon-based 3D meshes. Textures 
extracted automatically from the images and mapped on to the model keep the realism 
of the original photos. You can also edit and modify these textures manually. Finally, 
export the resulting model to compositing, animation or CAD software, for further 
enhancement and animation or for use in web application.
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What can you do with ImageModeler?

ImageModeler can be used for modeling scenes or buildings for architectural 
purposes, for calculations and 3D surveys from photographs, for creating 3D virtual 
visits and fast creation of photo-realistic backdrops, for human modeling, for 
industrial design, for animation and special effects, and for simple creation of photo-
realistic objects for video games.

Architecture, archaeology and cultural heritage
ImageModeler is designed to allow you to model of scenes or buildings “as built”, 
create 3D virtual visits, simulate and prototype projects in their final environment, 
calculate scenes and 3D surveys from photographs, and match the camera perspective 
for overlay of 3D over 2D pictures.

Industrial design
With ImageModeler, you can re-construct existing models from photographs, for 
example, create 3D models of a town, and integrate projects into their final 
environment. More specifically, ImageModeler is cut out for modeling “as built” and 
reverse engineering.

Video games
For the gaming industry, ImageModeler allows fast creation of photo-realistic 
environment, human modeling, virtual reality, and 3D virtual visits.
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Reconstruct photo-realistic scenes
ImageModeler tools allow you to extract texture maps directly from photographs to 
produce photo-realistic scenes of these meshes and re-create a scene or an object in 3D 
as it is in reality.
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Integrate projects into existing environments
ImageModeler helps you create photomontages of 3D projects in real environments, 
accurately and “at scale”. You can add extensions to existing buildings, a street, a town 
by creating your 3D project or extension with your favorite tool (3ds maxTM, REVITTM, 
AutoCAD®, etc.), take several photographs of the environment, and then use 
ImageModeler to create an accurate photomontage in all pictures at once. The image 
below shows a reconstructed archeological site (Temple of Aphrodite, Aphrodisias site, 
Turkey):
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Measure your scene
Another use of ImageModeler is to measure the 3D space from simple photographs. 
These measures, which are performed by a simple interaction with the images, do not 
require any prior information about the observed scene, or about the cameras that 
have been used.

You can use your computer offline to measure 3D distances and angles of real scenes 
from simple photographs: objects of any size, buildings, landscapes, far distances, 
inaccessible areas, crime scenes, etc.:
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About this guide

This guide takes you step by step through every step of the ImageModeler process. 
Whether you have little or no understanding of polygonal modeling, or are an 
experienced 3D modeler, you will be able to find the information you need to quickly 
become proficient at generating 3D models from 2D digital images or panoramas.

Type conventions

This guide uses the following type conventions to help you quickly find and 
understand information:

� Key combinations are capitalized with bold type. For example, press Ctrl+Z. For a 
full list of keyboard combinations, see “Keyboard Shortcuts” on page 223.

� Words referring to items within ImageModeler menus and pop-up menus are shown 
with the symbol > indicating the path to a menu item. For example, when you see 
Edit > Preferences, go to the Edit menu and then the Preferences item.

� “Click” means click the left mouse button and “right-click” means click the right 
mouse button.

Using command shortcuts

ImageModeler provides the following types of command shortcuts:

� Keyboard shortcuts 
The keyboard shortcuts are shown next to the main menu commands or actions. 
Keyboard shortcuts are available all the time, regardless of the workflow stage you 
are in. See “Keyboard Shortcuts” on page 223 for a complete list of keyboard 
shortcuts.

� Contextual (shortcut) menus 
The contextual (shortcut) menus contain commonly used commands, depending on 
whether the cursor is located in the Scene Browser or the 3D Workspace. 
To access the contextual menus, right-click in either the Scene Browser or the 3D 
Workspace. The contextual menu options vary according to the point you’re at in the 
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workflow (you’ll have different tools available to you when you’re modeling than 
when you’re texturing, for example).

� The Toolbars 
The ImageModeler six-stage workflow and Display toolbars contain icons and tools 
that help you work quickly and efficiently in each stage of the project (see “Working 
with the ImageModeler tools” on page 19 for more details about the workflow and 
display icons in the toolbars).

Autodesk Product Support

Autodesk provides “Up and Ready” support for 30 days from your date of registration 
covering installation, configuration and licensing of your new Autodesk software.

User Guide and Online Tutorials

To access the ImageModeler user guide, online tutorials or basic product support, go to 
http://www.autodesk.com/imagemodeler 

You can also access this site by selecting Help > Go to Product Center.
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New to 3D modeling or ImageModeler?

If you are new to 3D modeling or ImageModeler, consider browsing this guide and the 
tutorials to learn more about using the application. Here are some good places to start:

� “Loading images and panoramas” on page 24 and “Moving a shot into a viewport” on 
page 32. These sections give an overview how to start a project and work with 
images.

� “Calibration and the workflow” on page 41. This section and the following sections 
describe the calibration process.

� “Modeling and the workflow” on page 107. This section gives an overview of 
polygon modeling and the ImageModeler modeling workflow.

� “Autodesk Product Support” on page 9. This section explains how to use the 
ImageModeler online Help, how to get technical support, and how to view online 
Help resources.

Starting ImageModeler
Click Start > Programs > Autodesk > ImageModeler 2009 > ImageModeler

 Choosing shots to calibrate

ImageModeler uses the shots you add to construct and texture your model. The 
models you create from these photographs can only be as good as the photos you take, 
so when you select shots to calibrate the cameras, use the same standards you used to 
shoot the photographs (see “Recommendations for taking shots” on page 238).

� Choose shots that provide complete coverage of your subject’s surfaces. If part of 
the subject is masked in one image, make sure that you include another image that 
reveals the masked region. You cannot texture what you cannot see in the photos. 

� Choose shots that show good perspective and adequate spatial information, 
rather than those that show only one side of the subject. ImageModeler gets the 
depth information of an object from the perspectives shown in the photographs.

� Choose shots that are in focus and are well lit. Sharp images produce visible detail, 
making it easier for you to create models that look more realistic. Ideally, all shots 
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should have the same brightness and color balance. This ensures that the model’s 
textures blend together to give a natural appearance. 

� Choose shots that show good detail. Shots taken close enough to the subject 
capture the level of detail you need, but need to be far enough from the subject to 
include some the subject’s background.

� Choose shots that have the same zoom lens setting. If you use a constant zoom, 
the focal length is more constrained than when you use a zoom and ImageModeler 
finds the focal length of the image more precisely.

� Choose shots that include physical markers in the scene. Using shots with easy-to-
identify reference points both on the subject you want to model and in the space 
surrounding the subject in the calibration and modeling processes.

� Avoid choosing cropped images or images that have been modified in an external 
graphics package because they introduce uncontrolled changes of the distortion 
correction, the principal point, and the focal length of the image.

TIP You can calibrate multiple shots of differing types (including 360° panoramas).
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The ImageModeler  interface

When you start ImageModeler, you are presented with the ImageModeler interface:

� The Workflow toolbar contains a set of contextual toolbars for working through the 
ImageModeler six-stage workflow (see “Working with the ImageModeler tools” on 
page 19). Almost all tools have their own tool properties that appear in the toolbar 
when you select a tool. 

Workflow Toolbar Display Toolbar Scene Browser

3D Workspace

Tool Properties

Thumbnail View
Property Box
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� The Display settings change the display for objects and components in the 
viewports.

� The Scene Browser allows you to track and change properties for camera shots and 
camera devices, view locators, select and edit objects, materials, and measure objects 
(see “Viewing camera shots and properties” on page 30).

� The Tool Properties contain information on the settings relevant to the selected 
object or component (see “Viewing camera shots and properties” on page 30).

� The 3D Workspace is where you do most of your work, including calibrating 
cameras, modeling objects, and extracting textures (see “Working in the 3D 
Workspace” on page 29).

� The Thumbnail View only appears when working with a single viewport in a project 
that has multiple images. The Thumbnail View can be shown or hidden by using the 
open and close arrows on the bottom right of the 3D Workspace, and you can change 
the horizontal position of the Viewer by dragging it left or right.
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Customizable Interface

The ImageModeler interface can be customized to suit your screen real estate or 
working preferences. You can change the colour and position of the menus and 
toolbars. Drag and drop the toolbars where you prefer them (they snap to different 
edges of the screen)—or keep them floating.
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Using the Shortcut Manager

To create and edit shortcuts for ImageModeler functionality, select:

� Windows: Edit > Preferences > Shortcuts  (or press “P” and select Shortcuts)
� Mac: ImageModeler > Preferences > Shortcuts

To create and edit keyboard shortcuts:

1 Select Edit > Preferences > Shortcuts (Windows) or ImageModeler > Preferences 
> Shortcuts (Mac).

2 Choose the toolset from menu to display a list of functions.
3 Select an action from the Functions list (you will see a short description of the 

function). If a shortcut has already been assigned, the key combination is shown in 
the Current information field (no shortcut will be displayed if the action has not yet 
had one assigned to it).
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4 If you want to change the shortcut, click in the text field and enter your shortcut. 
Onscreen instructions will inform you about whether your chosen shortcut is free 
to use or not. Click Assign to activate the shortcut.

5 Click Delete to clear the text field. You can now define a new key combination for 
the shortcut in the blank text field. Click Assign to activate.

6 Click Get Default Shortcut to reset the shortcut back to the original system value. 
Click Assign to activate.

Working with the ImageModeler tools

Workflow tools and tool properties

The six-stage workflow is represented in the toolbar. When you select a tab in the 
toolbar to enter a new stage of a project, the tools you will need to work with in that 
stage of the project are displayed automatically. 

Only one tool from the workflow toolbar is activated at a given time and almost all 
tools have their own tool properties that appear in the toolbar when you select them. 

If the tool properties do not appear when you click on a tool, select Window > 
Properties  Toolbar. 

The workflow is described as follows:

1 Load images. When you create a new project, you must select whether you will be 
calibrating a single image (either a 360° panorama, or a normal shot) or a set of 
images (either a set of normal shots, or a mix of normal shots and panoramas). 
Then you load the shot(s) into a new project and create a camera device(s) (see 
“Loading images and panoramas” on page 24). When you select the Loading 
workflow tab the following tools appear:
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NOTE The calibration tools are different depending on whether you are working 
with a single shot or a set of shots. Calibrating a single image or panorama project 
uses perspective tools, instead of the location marker tools used in projects 
containing multiple shots of different angles of an object.

2 Calibrate cameras. You define the 3D space for your model from the 2D images 
and, if necessary, establish the properties of the camera(s) that were used to capture 
the photographs (see “Calibration and the workflow” on page 41). Select the 
Calibration workflow tab.
� When your project contains multiple shots, the Multiple Calibration workflow tab 

with the following tools appear:

� When your project contains a single shot, the Single Calibration workflow tab with 
the following tools appear:

3 Measure distances and angles. You can add use a ruler to accurately measure 3D 
distances and angles by identifying the corresponding elements in the 2D images 
(see “Creating a new ruler to measure distances” on page 98 and “Creating a new 
ruler to measure angles” on page 100). When you select the Measuring workflow 
tab the following tools appear:
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NOTE This workflow tab is only available in Multiple Image projects.

4 Create a model. You can create and edit polygonal meshes (see “Modeling and the 
workflow” on page 107). Select the Modeling workflow tab.
� When your project contains multiple shots, the following modeling tools appear:

� When your project contains a single shot, the following modeling tools appear:

5 Texturing a model. After creating (or importing) a model, you can texture it by 
extracting the material from the background 2D images (see “Texturing a Model” 
on page 173). When you select the Texturing workflow tab, the following tools 
appear:
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6 Exporting a project. You can export markers, locators, cameras, 3D objects, or 
textures, or any combination of them (see “Export file formats” on page 214). When 
you select the Export workflow tab, the following tools appear:

TIP At any time, you can create, open, and save a project, or undo and redo the last action 
by clicking on the tools available at each stage of the process: 

NOTE To undo or redo the last action, you can also select Edit > Undo or Redo, 
respectively.

Display properties tools

In addition to the workflow tools, you can change the display options for 3D objects 
and locators differently in each viewport and set options that aid you at any time 
during the process. The display options are shown in the Display toolbar.

To show the toolbar, select Window > Display Toolbar. 

� Multiple Image project display toolbar for calibration:

� Single Image project display toolbar for calibration:
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ImageModeler projects

ImageModeler projects are XML files saved with the file extension *.rzi. An empty 
ImageModeler project is automatically created when you start ImageModeler. 

Creating a new project

You can create an empty project when you start ImageModeler or at any stage in the 
workflow. To create a new project, do one of the following:

� Select File > New.

� Click   ( New icon) in the toolbar.

Opening an existing project

You can open an ImageModeler (*.rzi file from ImageModeler version 4.0 or higher) 
when you start ImageModeler or at any stage in the workflow. 

To open an existing project:

1 Do one of the following: 
� Select File > Open.

� Click   ( Open icon) in the toolbar.
2 In the Open dialog, select the file, and then click Open.
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Saving a project

To save a project in its current status:

1 Select File > Save As.
2 In the Save As dialog, name the file, and then click Save.

Select File > Save or click  ( Save icon) in the toolbar after you have saved the 
project once.

Loading images and panoramas

After creating a new project, the first step is to load images into a project. You should 
select images on the disk that correspond to the same “Group” with either the same 
camera used and the same image resolution (in pixels).

TIP You need to re-launch the “Load Image Wizard” to load several groups of images.

It is best to use uncompressed images, formats like TGA, and PPM for better quality 
textures. You can also load panoramic images created in Autodesk® StitcherTM. 

NOTE The image size is unlimited, but loading many or large images can impact the 
software’s responsiveness. Change the Image Cache Size in Preferences for faster pre-
loading of images in the viewports.
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Load image file formats

The table below describes the load file formats:

#8-bit and 16-bit images
The list below describes the panorama types supported:

� Spherical images (360° X 180°)
� Cylindrical images (360°)
� Cubical images: six square images (front, right, back, left, up, down)
� Spherical, cylindrical, and cubical QTVR panoramas

NOTE If you load a Quicktime panorama *.mov file, ImageModeler will convert it and create 
six cubical images automatically. The images (example_f.jpg, example_r.jpg, example_b.jpg, 
example_l.jpg, example_u.jpg, example_d.jpg) will be saved in the same place as the 
original Quicktime movie, so you must ensure that you have write permissions to the  
directory.

Load file formats Extension

JPEG *.jpg, *.jpeg

Maya® Image files# *.iff,

Portable Network Graphics# *.png

Portable Pixelmap *.ppm, *.pgm, 
*.pnm

Tagged Image File Format# *.tiff, *.tif

Truevision Targa *.tga

Windows Bitmap *.bmp
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Loading camera shots into ImageModeler

To load images into ImageModeler:

1 Click the Loading workflow tab to show the toolbar:

OR

TIP Choose Multiples for a modeling project that will use more than one image 
source (the images can have different resolutions, focal lengths or distortions, etc.), 
or choose Single for a project that will have only one source image (either a 
panorama, or a normal shot). ImageModeler functionality for calibrating shots 
changes according to the choice to load multiple, or single images so it is important 
to note what modeling requirements you have for the shot(s) when making this 
choice.

2 Do one of the following:
� Select File > Load Images from the main menu.

� Click  ( Add Images to the project icon) in the toolbar.

� Click  ( Add Panorama to the project icon) in the toolbar.
3 Click Add Images to open either:

� the Load Images dialog
� the Browse Location dialog (to load a panorama)
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4 Select the image(s) you want to add.
5 Click Open. 

� If you are loading multiple normal shots, the selected images are loaded into the 
Load Images dialog:

� If you are loading a panorama, the image is added to the project and loaded into 
ImageModeler.

6 You can assign a camera device to the images that you are about to load. If you do 
not, ImageModeler will try to estimate the properties of the cameras that were used 
to take the shots and create a new camera device for the loaded shots. 

Select from:
� Select Used Camera - If you have already loaded images into your project, you can 

assign these images to a camera device in the existing list. The option is only available 
for images that have the same ratio (width over height) and the same resolution in 
pixels.
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� Create a New Camera - If no images are loaded and you do not want to import a 
camera, select this option to create a new camera device. Change the Camera Name 
in the text field. If all images were shot using the same zoom, check the Images 
share the same zoom option. If you are not sure, leave the option unchecked and 
ImageModeler will calculate one zoom value for each of your images. Similarly, if 
you know the Focal Length of your camera, enter a value. Otherwise, leave the 
default focal length. 

� If your images are stitched images generated in Stitcher with the associated camera 
file (*.lens), click Import Camera to import the file that contains the focal length of 
the camera.

7 Click OK. The selected images are loaded into ImageModeler.

NOTE Although ImageModeler estimates the properties of the cameras, advanced users 
can control the information used to calibrate the cameras (see “Creating and modifying 
camera devices” on page 69).

The default focal length is set in the Preferences dialog. If the Read EXIF option is checked, 
ImageModeler will try to initialize the focal length data with the image data. 
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Working in the 3D Workspace

The 3D Workspace is where you do most of your work, including calibrating cameras, 
modeling objects, and extracting textures:

TIP To view the 3D Workspace in the full screen, select Window > Full Screen.  Select 
Window > Full Screen or Press Ctrl + Shift + F (Windows) or Shift + Command + F (Mac) to 
change the view back.

After loading images, ImageModeler automatically places the first image of a project 
in the 3D Workspace. 

You may need to change these images depending on the number of images in your 
project and on which images you want to place markers for calibration (see “Moving a 
shot into a viewport” on page 32).
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In the 3D Workspace, you can do the following: 

� Split the default single viewport into two (either side-by-side or stacked) or four 
viewports by selecting Window > Layout from the main menu and choosing a view. 
Changing the layout of the viewport lets you see more than one image at a time or 
your model from different angles. From multiple viewports, press Spacebar to 
return to a single viewport.

� Set display options for each viewport (see “Display properties tools” on page 22). You 
can change the options to see your model with different shading options, such as 
wireframe or transparency.

� Frame the contents of your scene by changing the zoom or the camera position in 
the viewport (see “Framing the viewport contents” on page 76).

� Change the default colors for the 3D Workspace background or elements, such as 
selected items, cameras, manipulator axes, locators and markers, and so on, by 
selecting Edit > Preferences (Windows) or ImageModeler > Preferences (Mac) and 
then the Colors tab.

� Store and restore up to five camera views (see “Navigating 2D images” on page 33).

TIP Click  (View Image Plane) in the Display toolbar. ImageModeler hides the 
background 2D image, showing locators in the plane orthogonal to the viewing camera. 
You can then navigate through the camera views of the images in your project using the 
Thumbnail View (see “Navigating 2D images” on page 33).

Viewing camera shots and properties

When you select any project item in the Scene Browser, the Property Box shows 
information relevant to your selection. 

You can track and change properties for camera shots and camera devices, view 
locators, select and edit objects, materials, and measure objects.
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Show or hide the Scene Browser and the Property Box by selecting Window > Scene 
Browser to activate or deactivate the option.

To view project camera shots, either:

� Click Cameras in the Scene Browser to see thumbnails of all images in the Property 
Box.

� Click one of the camera shots to see its properties in the Property Box:

Relabeling shots
You can rename a shot to give a more meaningful name. To rename a shot:

1 In the Scene Browser, from the Shots folder, select the shot you want to modify.
2 Select the General tab in the Property Box.
3 In the Label field, type the new name.
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TIP You can edit labels across multiple objects of the same type. For example, you 
can select several or all cameras and change the name in the property box—the 
selected objects will have the same name, ordered by a suffix number.

Moving a shot into a viewport

Each viewport shows the name of the shot it displays in the top left corner. By default, 
ImageModeler shows only one viewport containing the first loaded image, but you can 
see up to four viewports at a time (see “Working in the 3D Workspace” on page 29).

To assign a shot into a viewport:

1 Click the viewport to which you want to assign the shot. If only one viewport is 
shown, proceed to the next step.

2 Do one of the following:
� Double-click the shot name in the Scene Browser. The shot is assigned to that 

viewport.
� Click the Shot folder in the Scene Browser, and then double-click the shot in the 

Property Box you want to add.
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� Select a shot from the Scene Browser and drag and drop it into the viewport.

� Hover the cursor over a shot in the Thumbnail View, and when the thumbnail 
enlarges, click it to assign it to the viewport.

Navigating 2D images

As you work with ImageModeler you can navigate the images using the Thumbnail 
View. You can use the Thumbnail View to navigate through images before cameras 
have been calibrated, but also in 3D once the cameras are calibrated (for details on 
locked and unlocked views, see “Locking and unlocking a view” on page 76).

To navigate images using the Thumbnail View:
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1 Ensure that you have loaded more than one image for your Multiple Image project, 
and that the window layout is Single View.

2 Show the Thumbnail View by clicking  in the lower right corner of the 3D 
Workspace (the viewer is displayed by default when more than one image has been 
loaded, but only one viewport is open).

� Hide the viewer by clicking 
3 Cycle backward and forward through the images—drag the cursor to the right 

over the Thumbnail View to go forward or left to go back.
4 Hover the cursor over a thumbnail and it will enlarge—click it to see it displayed in 

the viewport (see “Moving a shot into a viewport” on page 32).

TIP You can scroll through all images in your project and view them in sequential 
order in the viewport by selecting View > Next Shot (Ctrl + right arrow (Windows) 
or Command + right arrow (Mac)) or Previous Shot (Ctrl + left arrow (Windows) or 
Command + left arrow (Mac)).



ImageModelerTM

User Guide

35

To change the field of view in a 2D image
In the real world, a photographer, looking through the camera’s eyepiece, pans up and 
down and from side to side and changes the field of view to frame a shot. As you work 
with ImageModeler you can navigate the images like a photographer using the 
navigation tools.

You use the navigation tools to navigate in an image before cameras have been 
calibrated, but also in a locked view after calibration (for details on locked and 
unlocked views, see “Locking and unlocking a view” on page 76).

�  Zoom - Place the cursor over the part of the image you want to zoom and press the 
z-key. Press the z-key again to reset the view. Alternatively, using Windows, hold 
down the Ctrl+Alt keys, left-click and drag the cursor left to zoom out or drag right 
to zoom in. If you are using a Mac, use Command + Option + left-click. The camera 
moves forward and backward.

�  Pan - If you are using Windows, hold down the Alt key, left-click and then drag up, 
down,left, or right to pan. On a Mac, use Option + left-click. Note that you can pan 
outside the viewport limits.

See also keyboard shortcuts (see “Keyboard shortcuts” on page 127).

NOTE You are not changing the object, only changing your view of it.
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Using the Quick Zoom

The Quick Zoom option allows you to zoom in and out of the image under the cursor 
to rapidly view a magnification of your area of interest. 

Pressing the Z key again reverts to the original image size.

move the pointer over 
the area of interest

press the Z key to zoom 
in on the area of 
interest
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The active viewport is magnified by a factor set in the Preferences dialog:
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3

Calibrating Cameras in Multiple-Image Projects
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Calibration and the workflow

In ImageModeler, calibration defines the 3D space for your model from the 2D images 
and establishes the properties of the camera(s) that were used to capture the 
photographs. 

NOTE Calibration is an essential step in the ImageModeler workflow and you must 
complete it successfully before you can begin to create a 3D model. Carefully calibrating 
cameras is important because everything you do in subsequent stages relies on calibration. 

Multiple image calibration workflow

For Multiple Image projects, by identifying the same features in different images 
ImageModeler can calculate the parameters (position, rotation, focal length, 
distortion) of the camera(s) used to shoot the images and calculate the 3D coordinates 
of the object. You define the features by placing markers on images.

Calibration means retrieving the camera parameters of the cameras that took the 
shots:

� 3D positions and orientation of the cameras
� Camera dependant parameters, such as focal length and radial distortion (see 

“About cameras” on page 68).
Once you have loaded shots and assigned them to workspaces, you can start to (see 
“Loading images and panoramas” on page 24 and “Working in the 3D Workspace” on 
page 29)  calibrate your project. 

Enter  Calibration mode by clicking the workflow tab to show the toolbar. For more 
information about the toolbar, see “Working with the ImageModeler tools” on page 19.

When entering markers across several shots, the calibration toolbar will have these 
tools:
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1 Set camera device parameters (see “Creating and modifying camera devices” on 
page 69).

2 Create markers on 2D images to specify 3D locators (see either “Creating 
Locators for Calibration in a Multi-Image Project” on page 43 or “Defining world 
space across multiple shots” on page 48). This process involves choosing which 
features to mark, and adding markers to each image that correspond to the same 
locator (point in space) in each image. You need to add at least 8 markers.

3 Create a coordinate system (see “Defining world space across multiple shots” on 
page 48). Define the world space for your model by specifying width, height, depth 
and direction of your modeling space. 

4 Improve the calibration by adjusting markers, or adding more markers or 
constraints, and manual calibration (see “Improving the calibration” on page 65).

Single image calibration workflow

For Single Image Projects, calibration is based on the Perspective Calibration 
Triedron. For ImageModeler to calculate the 3D space from a single image, it must 
evaluate the perspective plane of the image instead of feature-matching from different 
angles in multiple shots. For detailed information about each step in the calibration of a 
single-image project, refer to the next chapter, “Calibrating Cameras in Single-Image 
Projects” on page 77.

When calibrating a single shot, the calibration toolbar contains the Triedron Tool:
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1 Place the triedron inside the image to calibrate the 3D space (see “Calibrating a 
Single Image Project” on page 79). This process involves setting a point of origin 
from which to place X, Y and Z axes. Mark the point of origin in a place from where 
you can precisely set the three planes (preferably along clearly identifiable straight 
“edges”).

2 Improve the calibration by:

� Adding an X helper axe to complete the calibration. Then you can add other helper 
aces to further improve the calibration.

� In calibrating a single, normal shot (panoramas do not have distortion or consistent 
focal length values), use the focal length and distortion sliders to manually adjust the 
values to get a more precise, undistorted image and accurate calibration.

Creating Locators for Calibration in a Multi-Image Project

After you have assigned your images to their respective viewports, you can start 
placing the markers that will be used as reference points in the camera calibration 
process. A locator is a feature in the image (door corner, window corner, …) that is 
seen and easily identified in several shots.

Where do you place markers?

� Identify target points on more than one image and preferably in all images. 
Markers should be placed on locations that are easily identified in more than one 
image (preferably in all of the images in the project). Some objects have features that 
represent better targets than others. Buildings, for example, normally offer many 
good reference points: corners, intersection of elements, and so on. 
Look for areas where there is a clear color contrast between image elements, for 
example, at the intersection of a foreground and background element. 

� Place markers only if you are sure to see the same point in the other images. If 
you have to guess a point in one of the images, ImageModeler may not be able to 
complete calibration.

� Place markers over as much of the image as possible. Avoid putting many markers 
in just one area of an image. Doing this may not provide sufficient information to 
accurately calibrate the cameras. 
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� Place markers in the space surrounding the subject. Using the space surrounding 
the subject to place markers can aid in the calibration and modeling processes. You 
don’t need to place markers just on the object that you want to model.

� Ensure that markers cover as many different depths and planes as possible. Do 
not place them all on a single plane (such as a wall), as doing so will not provide 
sufficient 3D information.

In the example of a building (see image below), markers are evenly distributed on all 
“planes” of the object that will be modeled. The building’s corners and the 
intersections between objects are generally excellent candidates for calibration features 
and give good 3D information. Some additional markers on the surrounding scene, 
for example, in the car park, provide important information to help the calibration 
process.

How many markers to place?

This depends on the size of your project. Small projects are easier to construct, the 
complexity of the scene to reconstruct, and accessible points in all or several shots.

There is no clear rule stating how many markers you should place, but ImageModeler 
will not complete the calibration with less than eight common locators on 2 images 
and at least 4 locators on the rest of the images. Optimally, seven to 12 targets in each 
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image can be enough. However, you may have to add more points, depending on 
several factors, such as number of input images, overlap of these images, sparseness of 
targets in 3D space, and so on. 

Adding less than eight locators provides too little information to accurately define 3D 
locators. The quality and success of the camera calibration is measured according to 
the residual value. An understanding of the residual value can help you place markers 
more strategically (see “Evaluating the calibration in multi-image projects” on 
page 63).

Placing markers on 2D images

When you place markers (2D points) on images, they are transformed into locators 
(3D points) by the calibration process. You should try to place all markers in all images 
in the project. 

To place markers on images:

1 Ensure the first image you want to mark is in a viewport (see “Working in the 3D 
Workspace” on page 29).

2 Do one of the following:
� Select Marker > Place Marker Tool.

� Click the Place Marker tool icon  in the Calibration toolbar. 
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The pointer shape changes:

3 Create a new marker in the first image by pressing Ctrl + click (Windows) or 
Command + click (Mac). By default, the Magnifier window appears, helping you 
to place markers more accurately:

Action Pointer

Create new locator

Add marker to selected locator

Current viewport already has a marker for selected 
locator
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TIP When placing a second or third marker for the same position on an object across 
different shots, the magnifier will display a second, smaller view of the last marker placed. 
This helps you to more accurately place your markers for a specific position on an object 
across shots. Turn the magnifier on or off and set the zoom factor in Edit > Preferences > 
Magnifier (Windows) or ImageModeler > Preferences > Magnifier (Mac).

4 Place the corresponding markers in the other images of the project by clicking the 
corresponding locations for the same object in the other shots.

5 Create new locators by repeating steps 1 to 4.

NOTE You must either reselect the Place Marker tool or press Ctrl (Windows) or 
Command (Mac) to create a new locator. To remove a marker from a single 2D image, 
press Backspace. To remove a locator from all images, press Delete.

By default, once you have placed at least eight markers in at least two images, you can 
get a first calibration result. The calibration process runs automatically in the 
background as you place markers on images, unless Use Progressive Calibration is 
turned off in the Calibration page of the Preferences panel (see “Running the 
calibration manually” on page 67). 
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Locators are added to the Calibration folder in the Locators directory in the Scene 
Browser.

Define a coordinate system

This section applies to projects containing multiple shots. For a project with only a 
single shot, you would calibrate using the Set Triedron tool and have set up helper 
axes.

Defining world space across multiple shots

After calibration, you can define the 3D space, or “world space” in which you will 
create, evaluate, and modify your models. World space orientation is defined by the X-
, Y-, and Z-axis of the XYZ Indicator in the lower left corner of a viewport:

In addition to width, height, and depth, the XYZ axes also indicate direction (right, 
left, up, down, higher, lower) and provide a reference point for measuring the size and 
precise location of an object in the world space. 

Most 3D packages, including ImageModeler, assign an arbitrary point in space as the 
point of origin of the X-, Y-, and Z-axes. This point of origin has a coordinate value of 
(0, 0, 0): the exact point at which the three axes meet.
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About the World Space Tool

World Space Tool is used to define the origin and the main axis (X, Y, Z) of the 
coordinate system of your scene. The tool is composed of a direct trihedron (three 
orthogonal axes):

� The origin represents the point in the 3D space from where all coordinates will be 
calculated.

� The pivot handles near the origin of the tool allow you to separate the definition of 
the axis from the origin point. This is useful when you cannot or do not want to 
place all axis starting from one unique origin. 

� The extremity handles allow you to define the world coordinate system. To set the 
origin and the axes of the world space, choose characteristic points in the images 
that define a trihedron (almost right angles between each edge) and create 3D 
locators from these 2D points.

NOTE You can change the color of the axes of the World Space Tool in the Colors page in 
the Preferences dialog.

extremity 
handle

pivot 
handle

origin
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Setting the world space
1 Do one of the following:

� Select Scene > Define World Space. 

� Click   (Define World Space Tool) in the Calibration toolbar.
The World Space Tool appears in the viewport.

2 Drag the point of origin (the point at which all three axes meet) toward the locator 
to which you want it to snap. The Snap tool is automatically enabled, allowing you 
to snap to locators created from 2D markers. When the pointer changes to a 
magnet, release. In the following example, the origin is snapped to “Locator_7” the 
point of origin is locked in place:
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3 Drag one axis handle (X, Y, or Z) toward the locator to which you want it to snap. 
When the pointer changes to a magnet, release. The first handle is locked in place. 
In the following example, the X handle is snapped to “Locator”:
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4 Drag the second handle of the axis toward the locator to which you want it to snap. 
When the pointer changes to a magnet, release. The handle is locked in place, lock 
1 appears, and all three axes are set. In the following example, the X handle is 
snapped to “Locator_9”.
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5 Drag another axis handle toward the locator to which you want it to snap. When 
the pointer changes to a magnet, release. The second handle is locked in place, lock 
2 appears, and all three axes are set. In the following example, the Z handle is 
snapped from “Locator” to “Locator_2”.

The world coordinate system is now set. The position of the remaining axis that you 
have not set is imposed by the coordinates of the first two axes and the origin. In the 
above example, the Y-axis is determined by the position of the X- and the Z-axes and 
the origin.
The settings are stored in the RZI project file.
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NOTE Click Apply to validate the coordinate system you have created before choosing 
another tool. If you switch to another tool or select something else, the World Space Tool 
disappears.

Defining the reference distance

The scale of your calibrated 3D scene is set using the Reference Distance tool, 
composed of a simple ruler defined by two extremities and a line:

To define the scene scale:

1 When taking your photographs, measure the distance between two well-defined 
points in the scene. 

2 In ImageModeler, create locators where you measured the distance.
3 Do one of the following:

� Select Scene > Define Reference Tool. 

� Click  ( Define Reference Tool) in the Calibration toolbar.
The Reference Distance Tool appears in the viewport.
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4 Drag the first ruler handle toward the locator to which you want to snap it. When 
the pointer changes to a magnet, release. The first ruler handle is locked. There is 
no constraint; the locator can be one of the previously mentioned locators. In the 
following example, the first ruler handle is snapped to “Locator_2”.

5 Drag the second ruler handle toward the locator to which you want to snap it. 
When the pointer changes to a magnet, release. The second ruler handle is locked 
(the locator must be different from the locator used in step 4). In the following 
example, the second ruler handle is snapped to “Locator”.

6 In the tool properties, type the distance in the Reference Distance field and click 
on Apply to validate it. If the origin or the axes of the World Space Tool are not 
set, the Apply button will not be available to validate the world space.
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TIP The settings are stored in the RZI project file. After defining the world space axes and 
the reference distance, you can use the ruler tools to you can make virtual measurements 
of any length in a scene (see “Creating a new ruler to measure angles” on page 100).

Resetting the axes

At any time you can drag the point or origin or lock 1 or lock 2 to reset them. If you 
move the point of origin after it is snapped, lock 1 and lock 2 (if set) are unlocked. If 
you move lock 1 after it is snapped, lock 2 (if set) is unlocked. Click Reset to switch 
back to the last applied setting. 

Setting the up axis

You can define the up axis of the default coordinate system. This determines the axis 
around which you want the model to orbit. 

To set the up axis:

1 Select Edit > Preferences (Windows) or ImageModeler > Preferences (Mac).
2 From the Up-Axis drop-down list in the General page, select either X, Y, Z, -X, 

-Y, or -Z as the default up axis.
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Constraining the calibration

ImageModeler handles four types of constraints that can help make the calibration 
more accurate:

� The Corner constraint allows you to tell the solver that three points define a right 
angle.

� The Planar constraint tells the ImageModeler solver that a set of locators are in a 
same plane by fixing one of the XYZ coordinates.

� The Survey point constraint allows you to define the 3D coordinates of some points 
of the scene that will be used for calibration.

� The Distance constraint allows you to define the precise distance between two 
locators in the 3D space.

NOTE The above constraints provide strong information for the calibration process, which 
will be useful if they have been verified in the real world, but can produce a bad 
calibration if they have not.

The table below explains if the constraint sets a coordinate system or requires a 
predefined one:  

Constraint

Constraint 
sets a 

coordinate 

system

Requires a 

predefined a 

coordinate system

Corner No No

Planar No Yes

Survey 

point
Yes No

Distance No No
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Placing a corner constraint

If objects in your images contain right angles, you can speed up the calibration process 
by constraining the placement of markers on three consecutive locators of the object. 
Using the Place Corner tool, you can help the calibration solver converge and improve 
the accuracy of the calibration results.

To create a corner, you have to select three locators that form a right angle in the 3D 
space:

1 Click   (Place Corner) in the Calibration toolbar (or select Marker > Place 
Corner Tool). The pointer changes shape.

2 Place the center point of the corner constraint on an existing locator.
3 Place the first branch of the tool on an existing locator that is different from 

previous one.
4 Place the second branch of the tool on an existing locator that is different from the 

previous two locators.
The corner is displayed in all viewports and it is added to the Calibration Constraints 
folder in the Scene Browser with generic name “Right Angle”.
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NOTE You can change the color of markers (2D points) and locators (3D points) in the 
Colors page in Preferences.

Adding distance constraints

Use this constraint to define a distance between two locators. Several distance 
constraints can be used in a project to help calibrate.

1 Select two locators between which you will define a distance.

2 Click   (Distance constraint) in the Calibration toolbar (or select Marker > 
Define Distance Constraint). The pointer changes shape.

3 Enter the Reference Distance in the Properties Toolbar.
4 Click OK to validate.

NOTE Distance constraints are added to the  Constraints folder in the Scene Browser.

Adding planar constraints

The planar constraint tells ImageModeler’s calibration solver that a set of locators are 
in a same 3D plane by fixing one of the coordinates, either X, Y, or Z. 

The constraint is dependent on the project coordinates and it must be compatible with 
the world space coordinate system.

To set a planar constraint:

1 Select at least two locators.
2 Select the type of planar constraint: Normal to X, Normal to Y, or Normal to Z. 

(Oxy=shareZ, Oxz=shareY, Oyz=shareX). For example, Normal to X means that all 
selected locators L(x,y,z) are in the same plane and share the same X coordinate. If 
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Z is the up axis of your scene, all locators on the ground are probably “Normal to 
Z”.

ImageModeler calculates the values of the planar constraint. The constrained locators 
are added to the Planar Constraints folder in the Scene Browser. An arrow is drawn 
on locators in the 3D workspace to represent a planar constraint applied to them. The 
direction of the arrow depends on the shared axis. The image below shows the 
Normal to Z planar constraint.

Adding survey point constraints

If you know some of the properties of a scene, for example, GPS information, 
measurements taken onsite, or measurements deduced from CAD maps, you may 
know the 3D coordinates of some points of the scene. 

Instead of letting ImageModeler compute their 3D coordinates, you can set them 
before the computation. This is a way to use this information as an input to calibration.

Setting 3D survey points has several advantages:

� The points help ImageModeler automatically finding the appropriate coordinate 
system that matches your measurements of the scene.

� The calibration will be more robust, as all the survey points will help ImageModeler 
to find other points in the scene.
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NOTE ImageModeler will set a default coordinate system based on three unaligned survey 
points. However, if you have already set a coordinate system using the Worldspace tool 
and you then want to add survey points, the survey points should be set relative to the 
same coordinate system. If you use survey points, it is preferable to let ImageModeler set 
the coordinate system for you.

To set a survey point constraint:
1 Select a locator. 

2 Click  (Define Survey Point icon) in the Calibration toolbar (or select Marker 
> Define Survey Point).

3 Set the known position of the locator in 3D.

4 Click OK to validate the constraint.
The survey locators are added to the Calibration Constraints folder in the Scene 
Browser. A blue cube around a locator represents a survey point constraint in the 
Workspace.
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Deleting a constraint

Delete a constraint by selecting it in the Calibration Constraints folder in the Scene 
Browser and either right-click and select Delete from the contextual menu or press 
Del on the keyboard.

Modifying the Magnifier window

You can turn the Magnifier window off and you can change its size and level of 
magnification. By default, magnification is set to 4 × and the size of the window is 256 
× 256 pixels. 

To set the Magnifier window properties:

1 Select Edit > Preferences (Windows) or ImageModeler > Preferences (Mac). 
2 In the Magnifier tab, do the following:

� To change the size of the window, type the new size in the Size field.
� To change the level of magnification, type the new value in the Zoom field.
� Toggle the Magnifier display checking the Use Magnifier option.
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 Evaluating the calibration in multi-image projects

To ensure cameras are calibrated properly, you can analyze the color of the icons of the 
camera shots in the Cameras folder and locators in the Calibration folder in the 
Scene Browser as the calibration process runs.

Colored icons represent the residual value in pixels between the markers you place on 
the 2D images (see “Understanding the residual value” on page 64) and the associated 
3D locators. 

� Green icons indicate successfully created locators.
� Yellow icons indicate moderately successfully created locators.
� Red icons indicate poorly created locators.
Locator icons represent the average residual value of the locator in all the shots. 
Colored camera shots icons represent the average residual value of all locators in that 
shot. 

If the calibration is poor, a circle appears around the badly positioned locator, 
indicating that the residual is above the “good” value for the quality threshold and the 
locator is not well calibrated (see “Changing the Quality Threshold” on page 66 for 
more details on the quality threshold). The circle’s radius is proportional to the 
residual value, so you need to minimize the size of all the circles in the view by 
relocating the corresponding marker. If a locator’s residual is below the good 
threshold, no special symbol is displayed.
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Understanding the residual value

The residual value is the distance in pixels between the 2D marker placed in the image 
and the 3D locator constructed by ImageModeler and reprojected onto the image. 

For example, a residual of one pixel means that the locator is one pixel away from the 
corresponding marker that was placed on that image. This error value is directly 
related to how precisely you placed the marker; the more carefully you place markers, 
the better the chances of good calibration.

Residual value is also related to size of your images. For example a residual value of 2-
pixels on a 500 × 500 image represents less precision than that on a 1,000 × 1,000 
image.

To view the residual value of a locator:

1 Select a locator by clicking on it.
2 Click the General tab in the Property Box.
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Filtering and Sorting Locators in the Scene Browser

Locator markers can be sorted in the Scene Browser according to their residual. They 
are sorted according to their creation ID by default.

� Right-click a locator and select Sort by residual to change the order of the locators.

 Improving the calibration

What do you do if the calibration is poor?

Ideally, you want all icons to turn green. If calibration results return too many red or 
yellow icons, the 3D space construction is not precise. Try 

� Adding constraints to the calibration process (see “Constraining the calibration” on 
page 57).

� Checking the existing constraints consistency with the coordinate system 
(Worldspace) that was set (see “Setting the world space” on page 50).

� Check that the information in the camera device(s) are correct (see “Creating and 
modifying camera devices” on page 69).

� Adding more markers (see “Placing markers on 2D images” on page 45) and 
constraints (see “Constraining the calibration” on page 57).
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� Adjusting the position of the markers you have placed to reduce the residual value 
(see “Adjusting the position of markers” on page 66). 

� Change the level of precision (pixels) that ImageModeler uses to determine the 
residual value (see “Changing the Quality Threshold” on page 66).

As ImageModeler calculates the position and characteristics of the camera (or 
cameras) used to take the images by matching the points you have placed in the 
images, one badly placed marker may render not only its corresponding locator red, 
but also the neighboring locators. Try locating and changing the badly placed marker. 

If your images are large, try changing the quality threshold to change the level of 
precision (pixels) that ImageModeler uses to determine the residual value (see 
“Changing the Quality Threshold” on page 66). 

Adjusting the position of markers

By fine-tuning the position of the various markers, you can improve the positional 
quality of the markers. The corresponding locator icons change to green when good 
positional quality is achieved. 

To adjust the position of markers:

1 Click a marker that you want to move. By default, the Magnifier window appears, 
helping you to place markers more accurately.

2 Adjust the position of the marker.

NOTE Locators can be checked or unchecked for calibration by clicking on a locator and 
selecting Marker > Used for Calibration or right-clicking on a locator and selecting Used 
for Calibration from the contextual menu.

Changing the Quality Threshold 

Although changing the Quality Threshold does not change the actual accuracy of the 
calibration, you can change the level of precision (pixels) that ImageModeler uses to 
determine the residual value. 
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The default setting for Quality Threshold is optimized for six mega pixel shots. If you 
find that all the helpers are consistently red, consider changing the quality threshold to 
a lower value.

If you work with large images, consider changing the Quality Threshold to a higher 
value than the default value. Because the threshold value is measured in pixels, high-
resolution shots tolerate higher threshold values. Low-resolution shots require lower 
threshold values to maintain accuracy. 

To change the default residual setting:

1 Select Edit > Preferences (Windows) or ImageModeler > Preferences (Mac). The 
Preferences dialog opens in the Calibration page.

2 In the Min Residual and Max Residual fields, type the number of pixels that 
represent good and poor calibration.

A shot or locator with a residual higher than the poor value has a red icon in the Scene 
Browser. Shots or locators with a residual lower than the good value have a green icon 
in the Scene Browser. Shots or locators with a residual between the good and the poor 
value have yellow icons in the Scene Browser.

Running the calibration manually

The Use Progressive Calibration option in the Calibration page of the Preferences 
dialog determines whether or not cameras are automatically calibrated as you create or 
edit locators. If the option is turned off, you must run the calibration process 
manually. 

To run the calibration process manually, do one of the following:

� Select Camera > Calibrate (or press “F9”).

� Click   (Calibrate) in the toolbar.
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About cameras

Cameras represent the different devices used to capture the images. By default, when 
an image is loaded, ImageModeler creates a camera and the image is assigned to it. A 
camera is characterized by its internal parameters. the principal point, the focal length, 
the pixel aspect ratio, and the non-linear distortion. 

If you already have information concerning the camera, for example, you know that it 
is a 24 by 36 mm film back camera with a 35 mm lens, you can provide ImageModeler 
with this information before launching the camera calibration process. 

The focal length is the distance between the film and the optical center of the lens 
when the lens is focused on infinity. The principal point represents the projection of 
the optical center onto the film back, perpendicular to the film back plane. The film 
back values represent the size of your film and is proportional to the pixel aspect ratio.

Each camera parameter has a value that you can provide or you can allow 
ImageModeler to calculate it. The camera parameters—focal length, principal point, 
pixel aspect ratio, and non-linear distortion—vary or remain constant throughout the 
images and are either known or unknown. 
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Non-linear distortion

Mathematical models of a perfect camera imply that the image of a straight line is 
always a straight line. However, real lenses are not always perfect and may introduce 
distortion into your footage. The effect of distortion is that straight lines become 
curved as shown in the following image.

ImageModeler lets you input the radial distortion of your cameras if you know it, or 
will calculate it if you don’t.

Creating and modifying camera devices

Different lenses and camera settings produce different effects in photographs, such as 
lines that appear slightly curved or wider angles of view. When you load images into a 
new project, ImageModeler estimates the properties of the cameras that were used to 
take the shots and creates a new camera device for the loaded shots (see “Loading 
images and panoramas” on page 24). 

If you are an advanced user, you can control the information used to calibrate the cameras 
by adding a new camera device or changing an existing camera device’s properties.

For example:

� If all the shots were taken with the same zoom., the focal length and distortion 
should be set to “constant”. The option should already be set if you selected “zoom 
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constant” in the Load Image Wizard. This is the best case for calibration, as it is 
more constrained.

� If all the shots were taken with different zoom or you don’t remember how you shot 
them, the focal and distortion should be set to “variable”.

� If image1, image2, and image3 were taken with the same zoom and image4 and 
image5 were taken from further away, you need to zoom in the latter two 
images.You can create one device for image1, image2, and image3 with “constant” 
parameters, and another device for image4 and image5 with “variable” parameters.

You may want to modify a camera device if you captured the shots with the same camera 
and/or lens, but different zoom settings. You can change the focal length (see “Specifying 
the focal length” on page 71). Similarly, if shots have different lens distortion, you can 
change the camera device’s distortion value. However, if you captured some shots with 
different lenses or cameras, you must create a new camera device for each lens, and then 
specify which shots were captured with the device. 

If you know another camera was used to take some of your shots, but you do not know 
the values of it (for example, focal length), again you must create a new device with the 
default settings. If you’re not sure if the shots were captured with the same device, use 
the default camera device. 

Creating a new camera device

You can create a new camera device when you load images (see “Loading images and 
panoramas” on page 24), but you can also add a camera device just before calibrating 
the cameras.

To add a new camera device, select Camera > New Camera Device. The new device is 
listed in the Camera Device folder in the Scene Browser.

TIP Right-click in the Scene Browser and select Add Camera Device from the contextual 
menu to add a new camera device.
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Assigning a camera device to a shot

If you created a new camera device, you must assign the device to the shot(s) that were 
taken with the device.

To assign a camera device to a shot: 

1 In the Camera folder in the Scene Browser, select the camera shot you want to 
modify.

2 Select the General tab in the Property Box.
3 Select a new camera device from the Device drop-down list. 

Modifying a camera device 

When you modify a camera device, you can specify the focal length, the lens 
distortion, the film back value, the aspect ratio and the principal point according to 
your camera’s settings.

Specifying the focal length
If you captured the shots with the same camera and/or lens, but different focal lengths, 
you can change the camera device’s focal length. Images with the same focal length 
help to constrain the calibration, but it is not a necessary criteria. The focal length is 
the distance between the front of the lens and the film back (the plate where the film is 
exposed). 

The default camera device is 35 mm with a film back value of 32 × 24 for a typical 
digital camera, which most closely resembles how the human eye perceives the objects 
it sees. Focal lengths greater than 35 mm create a narrower angle of view; focal lengths 
less than 35 mm create a wider angle of view. 

To change the focal length of a camera device: 

1 In the Scene Browser, from the Camera Devices folder, select the camera device 
you want to modify.

2 Select the Device tab in the Property Box.
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3 In the Focal (mm) field, select either:
� Known if you know exactly the value and you do not want ImageModeler to 

recompute it. Type the approximate value in the Focal (mm) text field. 
� Constant if you do not know the exact value, but can approximate it, and know that 

the parameter does not change. Typically, the default setting is adequate. 
� Variable when the shots were taken with the same camera but with different focal 

length zoom.

Specifying the lens distortion
(Radial) distortion is a lens effect that causes straight lines close to the edge of a 
photograph to appear curved. If all the images were taken with the same camera, lens, 
and zoom settings, the images will have the same distortion:

To specify the lens distortion of a camera device: 

1 In the Scene Browser, from the Camera Devices folder, select a camera device.
2 Select the Device tab in the Property Box.
3 From the Distortion Status list, select either:

� Known if you know exactly the value and you do not want ImageModeler to 
recompute it. Type the value in the Distortion text field.

� Constant if you do not know the exact value, but can approximate it, and know that 
the parameter does not change. If the value you type is very different from the real 
one you may get unsatisfactory results. Typically, the default setting is adequate. 

� Variable for shots taken with the same camera but with different focal lengths.
4 From the Distortion Type list, choose either:

� Disto 3 (3i)—this is the default distortion type and it works in almost all cases.
� Disto 3 5 (-3i 5i)—this is a specific distortion type to be used when you’re sure that 

either -3i 5i applies.
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TIP You can also undistort your photographs with dedicated software or recreate wide-
angle photographs with ImageModeler using several photographs stitched together.

Advanced Specification—setting the principal point

NOTE The following settings are recommended only to advanced users. Changes you make 
to these settings could adversely affect your calibration.

1 In the Scene Browser, from the Camera Devices folder, select a camera device.
2 Select the Advanced tab in the Property Box.
3 Choose Known, Constant or Variable from the Principal Point list.
4 Enter the X and Y coordinates of the point.

NOTE Previously saved camera parameters (*.lens files) can be loaded—either from 
Autodesk Stitcher or from other ImageModeler projects.

Specifying the film back size
The film back is the rectangular plate where the film is exposed. Still shots usually do 
not need any change to the default values; the film back size of a typical SLR camera is 
24 × 36 mm. 

To specify the film back size: 

1 In the Scene Browser, from the Camera Devices folder, select the camera device 
you want to modify.

2 Select the Advanced tab in the Property Box.
3 In the Size fields, specify the width and height of the film back. 
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Specifying the film back aspect ratio 

The aspect ratio is the height to width ratio of an image. All the images that are 
associated with the same camera must have the same aspect ratio. You need only to 
change this setting for video images because the film back aspect ratio is the same as 
the image aspect ratio for still shots. 

To specify the film back aspect ratio: 

1 In the Camera Devices folder, select the camera device you want to modify.
2 Select the Advanced tab in the Property Box.
3 In the Aspect Ratio field, type the value of the aspect ratio.

Navigating in 3D space

Before calibration, your view of the scene matches the angle and position of the 
camera that was used to take the shot (an image must be in the viewport) and the view 
is locked. 

Interactive shot matching

While locked on a shot, you orbit in the 3D space using Alt+right-click. As you move 
the pointer, the 3D scene orbits and the viewport snaps to the nearest camera. This 
function is particularly useful to orient an object to add markers or when modeling.
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TIP Use the Lock at Nearest Camera option in Edit > Preferences > General Settings 
(Windows) or ImageModeler > Preferences > General Settings (Mac) to force the active 
viewport to use a specific camera angle. 

Select a 3D object by 
clicking on it or 
selecting it from the 
Scene Browser

Press Alt+right-click and 
drag the pointer to orbit 
the object

Release the mouse button 
and the camera snaps to 
the nearest viewpoint
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Locking and unlocking a view

When you lock a view, your view of the scene matches the angle and position of the 
camera that was used to take the shot (an image must be in the viewport). 

� Select View > Lock View or right-click and select Lock View (this action is 
independent of the General Settings option: Lock View to Nearest Camera).

� To toggle the camera display in the unlocked view, click on the View Cameras icon 

 in the Display toolbar. 

NOTE You can change the color of the cameras in the Colors page in the Preferences 
dialog.

Framing the viewport contents

ImageModeler allows you to frame the contents of your scene by selecting View and 
one of the following options.

� The Fit to View option changes the zoom to frame the content of your scene (in the 
vertical plane) in the viewport.

� The Look at Selected option centers the selected content of your scene (locators or 
objects) in the viewport.

� The Frame Selected option changes the zoom to frame the selected content of your 
scene (in the vertical and the horizontal planes) in the viewport.

� The Frame All option changes the zoom to frame all of the content of your scene (in 
the vertical and horizontal planes) in the viewport.

TIP You can access these options from the contextual menu that appears when you right-
click anywhere in the 3D Workspace. 
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Calibrating a Single Image Project

Images suitable for the single-image calibration workflow are:

� A still image, where the camera parameters are either known or unknown. If camera 
information is available, ImageModeler will initialize the focal length value for each 
new project. If no EXIF information is available, you can edit the default values in 
ImageModeler.

� A fully closed, 360-degree panorama that represents the entire 3D space of the scene, 
where the distortion and focal length values are known values. For example,  Stitcher® 
can be used to create high-quality panoramas for the Web, film, print, and 3D. Partial 
panoramas, e.g., panoramas with a FOV of less than 360 degrees, are not supported. 
The procedure for calibration is the same as for a still image except that you do not 
need to supply camera information (see “Calibrating an image” on page 87).

NOTE In certain cases, you can calibrate paintings and drawings, but satisfactory results are 
not guaranteed. ImageModeler relies on geometrically rigorous images and bases 
calibration on parallel lines representing the perspective of a scene. The perspective in 
paintings and drawings is drawn and may therefore be false.
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About the calibration features

Once you have loaded a shot or a panorama into the 3D Workspace, you are ready to 
calibrate your project. Calibration is the most important step in ImageModeler; it helps 
to define the 3D space, or “world space” in which you will create, evaluate, and modify 
your models.

The Calibration Triedron and at least one Helper Axis are used to define the origin and 
the main axes (X, Y, Z) of the coordinate system of your scene.

The Calibration Triedron is composed of a direct triedron (three orthogonal axes).

The handles allow you to define the world coordinate system. To set the origin and the 
axes of the world space, choose characteristic points in the images that define a 
triedron (right angles between each edge), like a room’s corner or the corner of a 
building.

NOTE You can change the color of the axes of the Calibration Triedron in the Colors page 
in Preferences.

When the Calibration Triedron is placed satisfactorily, ImageModeler requires you to 
place an additional edge, called a Helper Axis, in the scene that is parallel to either the 
X-, Y-, or Z-axis. By placing more Helper Axes, the calibration refines to fulfill all the 
features placed.
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Calibrating a panorama

To calibrate a panorama:
1. Do one of the following:

� Select Calibration > Set Triedron.
� Select the Calibration Triedron in the Calibration workflow tab:

The Calibration Triedron appears when you move the pointer into the 3D Workspace:
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2. Place the point of origin (the point at which all three axes meet) to where you want to 
place it, for example, in the corner of a room:

TIP Press the Z button to open the Quick Zoom view and place the triedron more accurately.
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3. Place one axis (X, Y, or Z) along the longest feature in the scene, e.g., a wall or a 
doorframe and click to place the axis.

The example below shows the placement of the X-axis along the floor/wall intersection:
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4. Place the second axis along a second visual axis that is 90 degrees to the first axis and 
click to place the axis. The example below, the Y-axis is placed at a right angle to the X-
axis where the two walls intersect:
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5. You can use the navigation options to move around in the scene until you find the 
best view for placing the axis. Place the last axis perpendicular to the other axes and 
click to place it as accurately as possible:

In the example, the Z-axis is determined by the position of the X- and the Z-axes and 
the origin. The example below shows the placement of the Z-axis along the floor/wall 
intersection.

If one of the axes is not visible in the image, you should:

� Place it approximately as a first step (see Z-axis placement in the previous image)
� You can refine its position later once additional helper axes are placed
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6. To calibrate the scene, you must at least place another Helper Axis (X-Helper Axis), 
which is parallel to the corresponding Calibration Triedron axis.

Place an X-Helper Axis by either:

� Selecting Calibration > Add X edge.
� Pressing the respective icons, or in the Calibration Toolbar:

7. Place the helper axis along the longest feature in the scene. The example below shows 
the placement of an X-Helper Axis at the wall ceiling intersection:
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8. Increase the accuracy of the calibration by continuing to place X-, Y-, or a Z-Helper 
Axes in the scene. Two or three well-placed Helper Axes are sufficient.

NOTE If you switch to another tool or select something else, the Calibration Triedron 
disappears.

Calibrating an image

Calibrating an image is exactly the same process as calibrating a panorama except that 
the focal length and the distortion of the shot might be unknown, and ImageModeler 
requires you to set those values, or a good estimation of them (see“Setting the camera 
parameters” on page 87). 

However, if the focal length is present in the EXIF header, it will be read and set 
automatically, giving a good initialization for the calibration process. You can always 
edit this value to improve the calibration accuracy value.

Setting the camera parameters

When you load an image, you can specify the focal length and the lens distortion 
according to your camera’s settings before placing calibration elements. If camera 
information is available for the images in the panorama, you can select the Read EXIF 
Header checkbox in the General page of the Preferences dialog and ImageModeler will 
initialize the focal length value for each new project.

If no EXIF information is available, enter the focal length and distortion of your camera 
in the corresponding fields in the Tool Properties.

Deleting an axis
To delete an axis, click on it to select it and press Delete.



Chapter 4
Calibrating Cameras in Single-Image Projects

88

Resetting the Calibration Triedron
To reset the Calibration Triedron, select Calibration > Reset Tool.

Refining the calibration

The world coordinate system is now set and the project is calibrated. By checking the 
position of the reconstructed axes and adjusting the Calibration Triedron and the 
Helper Axes to match it and checking the Calibration Accuracy value, you can refine 
the calibration. Check the Calibration Accuracy value in the Tool Properties, which 
should be close to 100%. A value above 95% constitutes a satisfactory calibration:

If the value is unsatisfactory and the axes do not correspond with the guidelines, you 
can:

� Adjust the camera parameters for still images only (see “Adjusting the camera 
parameters” on page 89)

� Adjust the position of the estimated axes (see “Editing the Calibration Triedron and 
Helper” on page 89)

� Add Helper Axes to improve calibration (see “Adding more Helper Axes” on page 90)
� Check the perspective (see “Checking the perspective” on page 90)
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Adjusting the camera parameters

For images, adjusting the focal length may improve the calibration. If your images are 
highly distorted, for example, if you have used a wide-angle lens to take your shots, you 
should increase the Distortion value. You can also undistort your photographs with 
dedicated software or recreate wide-angle photographs with Stitcher® using several 
photographs stitched together.

Editing the Calibration Triedron and Helper

Axes
You can edit each axis and the origin of the Calibration Triedron and the Helper Axes 
by selecting the Selection icon in the Calibration Toolbar or selecting Calibration > 
Select/Edit and dragging the origin or an axis extremity. Try to match the axes with the 
reconstructed ones to improve the calibration. Do not adjust the axes placed correctly; 
only edit the axes that have been placed approximately. For example, in the image 
below, you can clearly see the wall/wall intersection where the Y-axis is placed and the 
wall/floor intersection where the X-axis is placed. However, the table hides the wall-
floor intersection along which the Z-axis should be placed.
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You should adjust the position of the Z-axis using the reconstructed axes for guidance:

Adding more Helper Axes

You can improve calibration by adding more Helper Axes. Remember to distribute the 
Helper Axes appropriately by placing them on different areas of the scene. Refer to 
“Guidelines for placing calibration features” on page 92.

Checking the perspective

You can verify the calibration by checking the 3D perspective using a 3D object.

1. Do one of the following:

� Select Calibration > Set Triedron.
� Click the Modeling tab to display the Modeling Toolbar and click Add Primitive. 

By default, a plane appears in the 3D Workspace.
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2. Click Cube:

3. Create a box from the origin of the Calibration Triedron to each corner of the room. 
Use the navigation tools (see “To change the field of view in a 2D image” on page 35) to 
move around in the scene:

For more information on placing a primitive in a scene, see “Modeling and the 
workflow” on page 107.

Defining the reference distance

The scale of your calibrated 3D scene is set using the value set in the X Edge Length 
field: The value corresponds to the length of the X-axis of the Calibration Triedron and 
allows you define a reference distance and to measure the 3D space in a scene from a 
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simple photograph: objects of any size, buildings, landscapes, far distances, inaccessible 
areas, crime scenes, etc.

The default value is set to 1.000. Use the arrow buttons to change the value and click on 
Apply to validate it. If the origin or the axes of the Calibration Triedron are not set, the 
Apply button will not be available to validate the world space.

Setting the up axis

You can define the up axis of the default coordinate system. This determines the axis 
around which you want the model to orbit.

To set the up axis:
1. Select Edit > Preferences (Windows) or ImageModeler > Preferences (Mac).

2. From the Up-Axis drop-down list in the General page, select either X, Y, or Z as the 
default up axis.

Guidelines for placing calibration features
You should remember the following guidelines when placing the Calibration Triedron 
and the Helper Axes.
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1. Place the first axis where you see the perspective is the strongest. Generally, this is 
not the up axis. In the image below, the X-Helper Axis is placed on the left wall, which 
displays the most perspective:

� Placing one to three Helper Axes is sufficient to achieve a good calibration. You must 
place a minimum of one Helper Axis. More than three Helper Axes tends not to be 
beneficial.

� Place the Helper Axes on the longest element in the scene.
� Parallel axes should not be placed too close in the image.
� Do not place two Helper Axes in the same latitude. For example, do not place axes 

along the same wall/floor intersection, but preferably place them on opposite wall/
floor intersections.

If you need to adjust the axes, do not adjust the axes placed where you can see the 
element you are aligning with. Only edit the axes that have been placed approximately.
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About measuring distances

When shooting your images, measurement of any object in the real world must be 
taken to standardize the virtual coordinate system used by ImageModeler. To initialize 
the scale of a scene, you should capture a standard while shooting the images. The 
standard measurement can be, for example, a door’s or window’s width or height. 

Using the Distance Ruler and Angle Ruler tools, you can make virtual measurements 
of any length or angle in a scene without requiring complete scene modeling. Using 
the ruler tools, measuring objects that are difficult to access, for example, the height or 
angle of a building, becomes easy. You can add more than one ruler to a scene and 
change the units of measurements for those rulers. 

Before you can use rulers, you must define the world coordinate system correctly to 
define the 3D space in which you will create, evaluate, and modify your models. In 
doing so, you define the ratio between the real world and the virtual scene (see 
“Defining the reference distance” on page 54). 

NOTE You can change the color of the rulers in the Colors page in the Preferences dialog.
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Creating a new ruler to measure distances

To create a distance ruler:

1 Select the Measuring tab in the workflow toolbar:

2 Do one of the following:
� Select Ruler > Distance Ruler Tool. 

� Click  (Add Distance Ruler) in the toolbar. 
The ruler appears with the default measurement setting: 

Each ruler has a start point, an end point, and a line joining the points. The ruler is 
added to the Measures folder of the Scene Browser.

NOTE To change default settings, see “Changing the ruler units of measurements” on 
page 103).
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3 Click the start point of the ruler you want to measure:

To attach rulers to points on an object with precise measurements, snap the ruler 
points to a vertex, an edge, or a face of an existing object, to a locator, or the axes of 
the world space, see “Setting the world space” on page 50. You can also position the 
start point anywhere in the 3D space.

4 Click and drag the other end point of the ruler to position it:
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The measurement appears in the 3D Workspace and in the tool properties.
5 Press Enter to validate the ruler. The ruler is added to the Measures folder of the 

Scene Browser.

Creating a new ruler to measure angles

To create an angle ruler:

1 Select the Measuring tab in the workflow toolbar:

2 Do one of the following:
� Select Ruler > Angle Ruler Tool. 

� Click on the Add Angle Ruler tool icon  in the toolbar. 
The ruler appears with the default measurement setting: 
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Each ruler has a start point, an end point, and a line joining the points to a center 
point. The ruler is added to the Measures folder of the Scene Browser.

NOTE To modify default settings, see “Changing the ruler units of measurements” on page 103).

3 Drag the origin of the ruler to where you want to position it:

Snap the ruler points to a vertex, an edge, or a face of an existing object, to a locator, 
or the axes of the world space to measure with precision (see “Setting the world 
space” on page 50). You can also position the origin anywhere in the 3D space.
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4 Click and drag the first axis of the Angle Ruler tool and drag it to where you want 
to place it:

5 Click and drag the second axis of the Angle Ruler tool and drag it to where you 
want to place it:

The measurement appears in the 3D Workspace and in the tool properties.
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6 Press Enter to validate the ruler. The ruler is added to the Measures folder of the 
Scene Browser.

Changing the ruler units of measurements 

By default, the ImageModeler rulers are set to meters with a decimal digit of 2. You 
can change a distance ruler’s unit of measurement to mm, cm, m, km, inches, feet, or 
miles, an angle ruler’s unit of measurement to degrees, radians, or grads, or the 
decimal digit from 1 to 5. 

To change the ruler units of measurement:

� Click Edit > Preferences (Windows) or ImageModeler > Preferences (Mac) and 
click the Measurements tab. Do one of the following:
� Select an option from the Distance Units or Angle Units drop-down lists.
� Select an option from the Number of Digits drop-down list.

NOTE the Number of Digits setting will not affect the precision of the values in the 
property box.
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Modeling and the workflow

Computer modeling is the process of creating shapes and forms onscreen using one or 
more types of geometry. In 3D packages, the mathematics behind the geometry is 
usually well hidden so that you can mould or expand your model with tools, just like 
you would in the real world; the computer does the necessary mathematical 
calculations. In ImageModeler, you model polygon objects like a sculptor using 
various tools in a 3D scene.

What are polygons and polygon meshes?

A polygon consists of three or more points connected by lines that create a shape. A 
polygon can be three-sided (triangle), four-sided (quadrangles, or quads), or many 
sided (n-gon).

Connected polygons comprise a polygon mesh. Polygon meshes are usually called 
polygon objects, and objects are made up of vertices, edges, and faces, which are the 
points, lines, and shapes of the connected polygons. The figure below shows a simple 
(left) and more complex (right) polygon mesh:

Which modeling methods are available?

Which modeling methods and tools you use and in what order depends on factors 
such as the complexity of the model, how far into the modeling process you have 
progressed, and your personal working style. Modeling options are available in the 
Modeling toolbar and through menu commands.
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Click the Modeling tab to access the toolbar: 

The toolbar provides access to the modeling tools. You can create objects, change the 
position and shape of components in the 3D space, add and edit markers in the scene, 
and make complex edits to an object.

The modeling tools handle operations that need interactivity and tuning using several 
parameters. Only one tool is activated at time and almost all tools have their own tool 
properties that appear in the toolbar when you select a tool. In addition, several tools 
work on object components that require you to select them first. 

Menu commands perform instant operations for making complex edits to an object. 
These actions do not have properties, they apply to the selected component, and can 
be called at anytime, even when you are using a tool. 

The modeling workflow

A basic modeling workflow:

1 Create an object. You can create a primitive, create faces, create a point cloud 
mesh, or import an object on which you can lay down an initial polygon mesh and 
start your model (see “Step 1: Creating objects”).

2 Make basic edits to the object. After creating a polygon mesh, you can manipulate 
selected objects to match the objects in the 3D scene by moving, scaling, and 
rotating them using interactive manipulators. You can also snap objects and 
components to existing ones (see “Step 2: Making basic edits to objects” on 
page 131). 

3 Make complex edits to the object. You can make complex edits to a model to add 
detail. You can merge, subdivide, or triangulate objects and components, split or 
extrude faces, and glue vertices (see “Step 3: Making complex edits to objects” on 
page 148). 
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Before you begin to model...

� Ensure that cameras are successfully calibrated (see “Evaluating the calibration in 
multi-image projects” on page 63 and “Improving the calibration” on page 65).

� Place images into viewports to give you a better perspective of the objects you need 
to model (see “Working in the 3D Workspace” on page 29).

� Define the world space if necessary (see “Defining the reference distance” on 
page 54).

� Set the direction of the up axis (see “Setting the up axis” on page 56).
� Make sure you understand how to navigate 3D space for modeling (see “Navigating 

in 3D space” on page 74).

Step 1: Creating objects

To create an object, you can do one or more of the following:

� Add a primitive. The ImageModeler primitives are basic shapes that you can add to 
a scene to lay down an initial polygon mesh and start your model. You snap the 
primitive to existing locators, or any mesh components or by using the snapping 
constraints. Use a primitive to model an object with a simple or strong geometric 
shape, such as a wheel or a metal can. 

� Create a face or add faces to an existing object. You can add individual faces to a 
scene by marking 3D points anywhere in the 3D space drawing them directly on the 
image plane, which is the angle perpendicular to your view of the scene at any given 
time. You can add a new face using locators as reference points (and add new ones if 
necessary) or use existing object’s locators, vertices, edges, or faces. Create a face on 
strong geometric shapes.

� Create a point cloud mesh. A point cloud is a collection of points in space 
(locators) around which you can wrap a mesh. The points in space become the 
vertices. ImageModeler automatically creates the edges and faces of the mesh. Use a 
point cloud mesh to model an organic or complex object, such as a human face or a 
crumpled metal can.
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� Import an object. Typically you import a 3D object, make any edits you require and 
texture it from the calibrated images.

Adding a primitive

ImageModeler  allows you to add a primitive mesh, a plane, a cube, a cylinder, a 
sphere, or a disk to your project:

Before adding a primitive...
� If necessary, you can place a new locator(s) as a reference point to which you can 

snap the primitive’s vertex, see “Adding more locators for modeling” on page 122.
� You may want to change the working support to better position your object in the 

3D space according to the world space or existing objects (see “Setting the world 
space” on page 50).

� The Free Scale tool is activated by default, allowing you to change both the size and 
the shape of the primitive. To constrain the primitive’s dimensions, see “Applying 
constrained scaling” on page 115.

plane cube cylinder

disksphere
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Adding a 3D primitive
To add a primitive:

1 Do one of the following:
� Select Scene > Create Primitive Tool.

� Click   (Add Primitive icon).
Select a primitive from the tool properties:

TIP Right-click in the Scene Browser, select Add Object from the contextual menu, 
and select a primitive from the list.

TIP While placing a primitive, press the “+” key to increase the main subdivision of 
the primitive and press the “-” key to decrease the main subdivision of the 
primitive. This is particularly useful when placing circle-based primitives like disks, 
cylinders, and spheres that do not have corners.

Click... To...

Add a plane to your scene

Add a cube to your scene

Add a cylinder to your scene

 
Add a sphere to your scene

 
Add a disk to your scene
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The primitive shape is added to the scene, ready for you to place it. The Create 
Primitive tool activates the first vertex of the primitive:

The Create Primitive tool allows you to define the position of the new primitives, 
assisted by the snapping on vertex, edge, face, locator and axes constraints.

NOTE Change the Tool color in the Colors page in the Preferences dialog to change the 
color of the Create Primitive tool.

2 Drag the first vertex of the primitive and snap it to a vertex, an edge, a face of an 
existing object, a locator, or the axes that define the world space (see “Setting the 
world space” on page 50) or indeed anywhere in the 3D space.

If you are satisfied with the placement of the first vertex, proceed to step 2; 
otherwise, press Backspace to undo the last step.

TIP If a locator or a locator label hides the component to which you want to snap a 
vertex, hide it by clicking on the following icons in the Display toolbar:
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� The View Locators icon .

� The Locator Labels icon  (the option is disabled if the locators are hidden).
You can also show/hide locators by selecting a locator(s) in the Scene Browser and 
then selecting Edit > Show or Hide or right-click on a locator in the Scene Browser 
and select Hide from the contextual menu. Select Show only to hide every non 
selected locator or object. 

3 The second vertex is now activated. Snap it to a component, a locator, or anywhere 
in the 3D space:

4 The third vertex is activated. The position of the vertex is constrained around the 
axis created by the first two vertices. Snap it to a component, a locator, or anywhere 
in the 3D space:
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5 If the primitive is a 3D shape, the final vertex determines the height of the 
primitive. Snap it to a component, a locator, or anywhere in the 3D space:

The creation is validated automatically. However, the validation option is available at 
each step by pressing the Enter key or double-clicking the mouse button.

After you add a primitive to your scene, you can:

� Add more faces to the object (see “Creating and adding faces” on page 126).
� Change its position or shape (see “Step 2: Making basic edits to objects” on 

page 131).
� Apply more complex transformations that change the basic structure of the primitive 

(see “Step 3: Making complex edits to objects” on page 148). 
� Add more than one primitive, and then merge them to create one object (see 

“Merging objects and components” on page 148).
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Applying constrained scaling 

When you select the Create Primitive tool, you can scale and change the default shape 
and size of the primitive to define it in the 3D space. However, ImageModeler allows 
you to constrain the size and shape of the primitive using the Scaling options in the 
tool properties:

From left to right, the scaling options are:

� No Scale - You cannot change the size or the shape of the primitive. Snap the first 
vertex of the primitive to a project component or anywhere in the 3D space; 
thereafter, placement of the subsequent vertices is constrained by the primitive’s 
default size and shape.

� Uniform Scale - You cannot change the shape of the primitive. Snap the first and 
second vertex of the primitive to a project component or anywhere in the 3D space; 
thereafter, placement of the subsequent vertices is constrained by the primitive’s 
default shape.

� Free Scale - This is the default mode. You can change the size and the shape of the 
primitive by snapping to any vertex, edge, or face of an existing object, or to a 
locator. You can also snap the vertex to the axes that define the world space or 
indeed anywhere in the 3D space. 
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Applying the snapping filters

The snapping filters appear in the tool properties when you select the Create 
Primitive, Create Face, or Snap tools and allow you to constrain to which elements 
you can snap:

Everything existing in the 3D space as locators or any part of a mesh can be the origin 
of a snapping and constraint action. You can snap to:

� A vertex, or up to a vertex
� An edge, or along an edge, or parallel to an edge
� A face, or normal to the face, or up to any point inside the face
� A locator, or up to a locator
� The axes that define the world space (the world space axes appear on the 3D 

Workspace when you manipulate the primitive)
� Normal to a plane defined by the world space
� Along an axe defined by the local object transformation
� Normal to an axe defined by local object transformation
� The distance values in the Create Primitive and Create Face tools. Entering a value 

in the text field snaps to multiples of that distance. For example, if you enter the 
value 2.0, the tool snaps to distances equivalent to multiples of 2: -4, -2, 0, 2, 4, etc. 

If you click on an icon to deselect the filter, you cannot snap to that component of the 
selected object. 
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Constraint shortcuts

The activated filters depend on the selected tool. If activated, the object components 
are highlighted and the pointer snaps to them. A red, green, or blue dotted line 
constraints represents that two consecutive points are snapped to the X-, Y-, or Z-axis, 
respectively.

For example, the first point of your primitive is used as reference point (left figure 
below):

The line constraint defined by the reference point and the second point is aligned with 
the X-axis: a red dotted line is shown, and reference point is circled (center figure). 
The second point now becomes the reference point. The third point is aligned with the 
Z-axis: blue dotted line is shown, and reference point is circled (right figure).

Shortcut Function

V Activate the constraint selector

Esc Unlock locked constraint

Shift Lock activated constraint

Ctrl 
(Windows)
Command 
(Mac)

Avoid intersection with scene elements 
while locked

 Tab Switch between possible constraints



Chapter 6
Modeling

118

Locking the last snapped component
Press Shift to stay locked on the last snapped component.

� To snap on faces, highlight a face (see Selecting objects and components) and press 
Shift. A grid plane passing through the highlighted face appears. 

� Snapping is constrained to the face plane:

� To snap on edges, highlight an edge and press Shift. Snapping is constrained to the 
edge line:

� When an axis is displayed, snap on it by highlighting a face and pressing Shift. 
Snapping is constrained to the axis:

Tip: Press Shift to keep locked on an axis.
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Switching between line constraints

When a line constraint is activated or locked, you can switch to other axis constraints 
by pressing Tab key. By doing so, you can access points in 3D where there may be no 
locators, or any 3D model already created. 

If you press the Shift key, you lock the constraint, allowing you to make camera 
movements, zoom, rotation, change a shot. To unlock the constraint, press the R key. 
or press Shift over an empty space where nothing is activated.

For example, if the X-axis is activated, switch to the Y-axis by pressing the Tab key:

While a constraint is activated or locked, you can activate the dual constraint by 
pressing Ctrl + Tab (Windows) or Command + Tab (Mac).

Press the Tab key 
again to switch to 
the Z-axis 

and press the Tab 
key again to switch 
back to the X-axis.
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� The dual of a line is the plane normal to this line passing through the snapped point:

� The dual of a plane is the line normal to the plane passing through the snapped 
point:
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Snapping and Constraints on axes or on planes

When you are creating faces, placing primitives or splitting faces, ImageModeler has 
powerful snapping and constraints features to help you better position your object in 
the 3D space according to the world space or existing locators and objects.

The constraints you can use are:

� X, Y or Z axes
� XY, XZ or YZ planes
1 When creating a primitive or a face, select the constraint origin by moving the 

mouse over a vertex, an edge, a face or the origin of the scene.
2 Press V to activate the cosntraint selector.

3 Move the mouse over the selector to activate the different constraints available.
4 Left-click the constraint you want and the tool element will lock on this contraint.
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TIP Press ESC (or V) to quit the selector without making a choice. Change the Constraints 
colors in Edit > Preferences > Colors (Windows) or ImageModeler > Preferences > Colors 
(Mac) to change the color of the plane grid.

TIP When you move the cursor in the 3D view, tool tips appear (the tool tips are displayed 
with some transparency to keep the shot clearly visible underneath) displaying information 
or guides. Depending on the constraint or the snapping rules that have been defined, the 
information displayed will be [locator] [vertex] [edge] or [face] [aligned to ...] [locked on 
...] which corresponds to the element intesected or the active constraint.

Adding more locators for modeling

Because camera calibration creates a 3D environment from the 2D images, you can 
add locators directly to a scene after calibration is complete. 

You may want to add a locator:

� To use as a point to which you can snap an object to rotate the object with precision 
(see “Snapping objects and components” on page 145).
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� To create points in space to create a face (see “Creating and adding faces” on 
page 126).

� To create points for point cloud meshes to build an organic shape (see “Creating a 
point cloud mesh” on page 129).

Adding markers
You can use Guiding Lines, which represent the camera views, originating from the 
camera position and passing through the selected point, to help you place a marker 
where you could not do so before the calibration (for example, on borders that are not 
sharp lines). Ideally, all the Guiding Lines intersect at a single point. In practice, a 
small error is often visible with respect to the calibration quality.

Note: Change the color of the Guiding Lines in the Colors page of the Preferences 
dialog. 

To add markers:

1 Ensure the first image you want to mark is in a viewport (see “Working in the 3D 
Workspace” on page 29).

2 Create a marker in the first image. By default, the Magnifier window appears as 
you place markers, helping you to place markers more accurately:



Chapter 6
Modeling

124

The Guiding Lines are displayed in the other shots in the viewport:

If the Guiding Lines are not visible, click on the View Guiding Lines icon  in 
the Display toolbar.

3 In another shot, snap the marker to the nearest Guiding Line by pressing the Shift 
key. The pointer changes from cross hairs to a square:
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4 Slide the pointer along the Guiding Line until you reach the position where you 
want to place the marker and release the pointer:

The 3D locators generated from the markers are added to the Modeling folder in the 
Scene Browser and they are not used in the calibration process. 

Adjusting the position of markers
To adjust the position of markers:

1 Ensure the first image you want to mark is in a viewport (see “Working in the 3D 
Workspace” on page 29).

2 Select the Place Marker tool.

3 Select the marker you want to move. By default, the Magnifier window appears as 
you place markers, helping you to place markers more accurately.

4 Move the marker to the where you want it.
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Toggling the display of objects

To show/hide an object:

1 Select the object that you want to hide (see “Selecting objects and components” on 
page 131).

2 Select Edit > Show or Hide (Ctrl + H (Windows) or Command + H (Mac)).

TIP Right-click on an object in the Scene Browser and select Hide from the contextual 
menu.

Creating and adding faces

You can add an individual face to a scene by marking 3D points anywhere in the 3D 
space by drawing them directly on the image plane or attaching it to an existing 
object’s vertex, edge, or face. 

When you create a face, you draw the edges of the face in the direction facing the 
camera (or viewport). When you add a face to an existing object, the direction of the 
face normals for the object face determines the direction of the face (see 
“Understanding face normals” on page 128).

Before creating a new face...
� You can define the vertices of a new face using existing locators, or if necessary, you 

can place a new locator as a reference point to which you can snap the new face (see 
“Adding a primitive” on page 110).

� You can create a face by marking 3D points anywhere in the 3D space. However, you 
may want to define the working support to better position your object in the 3D 
space according (see “Setting the world space” on page 50).
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Creating a face or adding a face to an object
1 Do one of the following:

� Select Scene > Create Face Tool.

� Click on the Create Face icon  in the Modeling toolbar. 
The pointer changes shape. 

2 Position the pointer either:
� In the 3D space where you want to start the new face. You can snap to a locator or an 

axis (see “Creating and adding faces” on page 126).
� On the existing object’s vertex, edge, or face (see “Selecting objects and components” 

on page 131). If you want to add a face to an existing object, please make sure this 
object is selected. If not, ImageModeler will create a new object with the face. 
Starting a face from an existing object’s edge is recommended because it creates 
directly an edge of the new face with the correct orientation.

Tip: If a component to which you want to snap a vertex is hidden by a locator or a 

locator label, click on the View Locators or Locator Labels icon  in the 
Display toolbar (the latter option is disabled if you have already hidden the 
locators).

If you are satisfied with the placement of the first vertex, proceed to step 2; 
otherwise, press Backspace to undo the last step.

3 Position the pointer where you want to add the second point and click the second 
point.

4 Position the pointer where you want to place the third point. If you are creating a 
triangle, click and press Enter or double-click to validate the face. Repeat the last 
two steps for a quad or n-gon face.

ImageModeler creates a face that is defined by the points you have placed. 

When you have created three vertices, the face plane is defined. All subsequent “free” 
points are added on this same plane, except if you snap the face to locator that is not 
on the same plane.
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Understanding face normals

Face normals indicate the direction of the faces of a polygon. By default, 
ImageModeler displays face normals outward and you model an object on the outside 
of the faces.

To verify which way normals are facing, click on the View Normals icon  in the 
Display toolbar (see “The ImageModeler  interface” on page 15).

Markers facing outward or inward indicate which way the faces of a polygon face.

NOTE When creating a primitive, if the current camera is inside the primitive’s volume, the 
direction of the primitive’s normals will follow the camera’s direction (inward). However, if 
the camera is not included in the primitive’s volume, the direction of the primitive’s normals 
will be outward.

normals 
facing outward

normals 
facing inward
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Inverting face normals
Typically, you work with objects with the default normals setting, but you may need to 
invert normals, if for example, if you want to model a room. Inverting normals is like 
turning the object inside out, so you can see the surface of the normals on the outside 
of the object.

To invert face normals:

1 Select the object. To find out how to select, see “Selecting objects and components” 
on page 131.

2 Click Scene > Invert Face Normals. 

NOTE When you set face normals, you set them for the entire selected object, not just for 
a face or group.

Creating a point cloud mesh 

By the time you are ready to create a point cloud mesh in the ImageModeler workflow, 
some of the locators (a collection of markers) will have already been created during 
the camera calibration process. 

Because the calibration process does not provide enough locators to produce a quality 
point cloud mesh, you must place more markers before you can wrap a mesh around 
them.

point cloud and 
wrapped mesh
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Using the ImageModeler automatching feature to reduce the amount of time and effort 
you spend adding markers to create locators. You place one marker, and 
ImageModeler determines where to place the corresponding markers in images in 
viewports. 

NOTE Automatching results depend on high calibration quality.

Consider the following when placing markers:

� Add markers to distinguishable features in the images, not bare blue sky, for 
example.

� The more markers you add, the more accurate and better quality the model but the 
larger the file size. Keep the model simple for Web applications.

Refer also to “Where do you place markers?” on page 43.

Creating a point cloud mesh
1 Make sure you have placed images that show the feature you want to mark in at 

least two viewports. Each image must show the same feature to mark (see 
“Working in the 3D Workspace” on page 29).

TIP For an easier selection of the locators, uncheck Object Display in the display 
properties.

2 Select the Place Marker tool  in the Modeling toolbar. The pointer changes 
shape.

3 Check the Automatching option in the Properties toolbar to activate it.
4 Click and hold the pointer over the part of the feature you want to mark. The 

Magnifier window appears to help you locate the feature more precisely. 
5 Release the pointer. ImageModeler creates new marker, determines automatically 

the corresponding point in the other images in the viewports, and adds the new 
locator to the Modeling folder in the Scene Browser.

6 Repeat the previous three steps for each marker you want to add.
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7 Select Scene > Create Mesh.
ImageModeler creates a point cloud mesh.

Relabeling project items

Use the Property Box to relabel a camera shot, camera device, locator, object, 
material, or ruler to something more meaningful. 

To rename a project item:

1 In the Scene Browser, select one or more primitives or meshes you want to rename. 
2 Click the General tab. 
3 Type the new name in the Label field.
4 Press Enter.

Step 2: Making basic edits to objects

You can make basic edits to objects before you use some of the tools to make more 
complex edits, such as splitting or extruding faces. Now that you have added 3D 
objects to your project, you may need to reposition them to match the objects in the 
3D scene. You can move and/or rotate objects and components using interactive 
manipulators. You can also snap objects and components to other ones. To do so, you 
must firstly select the required components or objects, and then apply the appropriate 
editing tool. 

Selecting objects and components

Before you can position objects, or otherwise modify objects and components in your 
scene, you must select them. You can select objects, faces, edges, vertices, and pivot 
points, and locators.
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To select objects and components using the Selection tool: 

1 Do one of the following:
� Select Edit > Selection Tool.

� Click on the Select tool  in the Modeling toolbar. 
The selection options appear in the tool properties.

NOTE You can change the default color and the color of selected items in the Colors page 
in the Preferences dialog.

2 Click any of the following selection icons to activate the tool:

3 Do one of the following:
� To select one object or component, hover the pointer over the object, edge, vertex, or 

face that you want to select. ImageModeler highlights the object. Click to select it.
� To select more than one object or component, drag diagonally to marquee select 

them. A box appears as you drag, and the objects or components are highlighted.
� To add an object or component to the selection, press Shift, then click another 

object or component, or drag diagonally across it.

Tool Function

Select objects

Select faces

Select edges

Select vertices
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� To remove an object or component, press Ctrl (Windows) or Command (Mac), and 
then click another object or component or drag diagonally across it.

� To select all objects or components, select Edit > Select All.
� To unselect all objects or components, select Edit > Unselect All.

If you unintentionally select components that face away from you, turn on backface 
culling (see “Hiding back-facing polygons” on page 163).

Increasing face selection
You can increase or decrease the current face selection by adding or removing, 
respectively, faces that have the same normal.

Click Edit > Face Selection > Increase (Shift + Up) to add faces to the selection or 
Decrease (Shift + Down) to remove faces from the selection. 
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Selecting edges

By selecting one edge and using the Edge Loop command, you can simultaneously 
select all edges of an object in one plane and then manipulate the size and shape of the 
object around that plane:

For example, you may want to intent an object proportionally around the object’s 
circumference, or scale up along one plane of an object while keeping the object in 
proportion.

To select all edges on the same plane:

1 Click on an object’s edge. The object or component is highlighted.
2 Select Selection > Edge Selection > Edge Loop.
All edges in the same plane as the selected edge are selected.

selection around the horizontal 

selection around the vertical axis
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Defining the selection buffer settings

In the Display toolbar, you can toggle the priority for the selections and highlights of 
scene elements (faces, edges, vertices) and the snapping behavior in the active tool: 

By activating or deactivating the option in the locked or unlocked view, you toggle: 

� Normal selection buffer: The front faces have priority over the back faces. The 
snapped point is on the front face of the building.
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� Inverse selection buffer: Back faces have priority over the front faces. The snapped 
point is now on the bottom of the building. This is useful when you want to create 
an object in the same plane as the bottom of the building.

Storing and restoring selections

When you are modeling an object, you can select areas of your model, store the 
selection, and revert to the selection later on. ImageModeler allows you to store a 
maximum of five selections by selecting Edit > Selection Bookmark > Store 
Selection.

When required, you can revert to a previously stored selection by selecting Edit > 
Selection Bookmark > Restore Selection.
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The Move, Rotate, and Scale manipulators

ImageModeler has three manipulator tools located in the Modeling toolbar, from left 
to right, Move, Rotate, and Scale tools, to move and change the shape of objects and 
components interactively:

TIP To save time, press Tab to cycle among the interactive manipulators. 

If you select an entire object and then either the Move, Rotate, or Scale tool, the 
manipulator appears in the center of the selected object or component:

 

If you select an object’s vertex, edge, or face, the manipulator appears at the vertex or 
in the center of the object’s edge or face, respectively. You can also change the position 
of the pivot point (see “Understanding and moving the manipulator’s pivot point” on 
page 142). Subsequently, you manipulate the object or component around the 
manipulator’s pivot point. 

move scale

rotate
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NOTE You can change the color of the axes of the manipulators and the active handle in 
the Colors page in the Preferences dialog.

Moving objects and components

Use the Move manipulator to move objects and components interactively. When you 
move entire objects, the objects retain their shape; they just move to another location. 
When you move vertices, edges, or faces, you pull or push them to change the shape of 
the object. The resulting change depends on where you move the component(s). For 
example, you can move an object’s face, edge, or vertex as shown below:

You can also move objects or its components to another point in space by rotating 
them around their pivot points (see “Rotating objects and components” on page 139). 

To move objects or components with the Move manipulator: 

1 Select an object or component (see “Selecting objects and components” on 
page 131). The object or component is highlighted.
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2 Do one of the following:
� Select Scene > Move Tool.

� Click on the Move tool icon . 
The Move manipulator appears in the center of the selected object or component. 

3 Before using the manipulator:
� If you want to move the manipulator’s pivot point, see “Understanding and moving 

the manipulator’s pivot point” on page 142.
� If you want to orient the manipulator to a coordinate system, see “Aligning the 

manipulator with a different orientation mode” on page 143.
Otherwise, proceed to step 4.

4 To move the object or component along:
� The X-axis, drag the red arrow. 
� The Y-axis, drag the green arrow. 
� The Z-axis, drag the blue arrow. 

The arrow changes color as you drag. 
If you move the entire object, its new position is changed in the Property Box (for 
more details, see “Changing the size and shape of objects numerically” on page 144).

Rotating objects and components

Use the Rotate manipulator to rotate objects and components interactively. When you 
rotate entire objects, the objects retain their shape; they just turn on the axis (or 
change location in 3D space if you move its pivot point first). When you rotate edges 
or faces, you twist them to change the shape of the object. The resulting change 
depends on how far you twist the component(s). 

To rotate objects or components with the Rotate manipulator: 

1 Select an object or component (see “Selecting objects and components” on 
page 131). The object or component is highlighted.
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2 Do one of the following:
� Select Scene > Rotate Tool.

� Click on the Rotate tool icon . 
The Rotate manipulator appears in the center of the selected object or component. 

3 Before using the manipulator:
� If you want to move the manipulator’s pivot point, see “Understanding and moving 

the manipulator’s pivot point” on page 142.
� If you want to orient the manipulator to a coordinate system, see “Aligning the 

manipulator with a different orientation mode” on page 143.
Otherwise, proceed to step 4.

4 To move the object or component along:
� The X-axis, drag the red ring.
� The Y-axis, drag the green ring.
� The Z-axis, drag the blue ring. 

The ring changes color and indicates the angle to which you are rotating.
If you rotate the entire object, its new position is changed in the Property Box (for 
more details, see “Changing the size and shape of objects numerically” on page 144).

Scaling objects and components

Use the Scale manipulator to scale objects and components interactively. When you 
scale entire objects, the objects retain their shape; they just get larger or smaller. When 
you scale an edge or face, you change the shape of the object. The resulting change 
depends on how far you scale the component. 

To scale objects or components with the Scale tool: 

1 Select an object or component (see “Selecting objects and components” on 
page 131). The object or component is highlighted.
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2 Do one of the following:
� Select Scene > Scale Tool.

� Click  (Scale tool icon). 
The Scale manipulator appears in the center of the selected object or component. 

3 Before using the manipulator:
� If you want to move the manipulator’s pivot point, see “Understanding and moving 

the manipulator’s pivot point” on page 142.
� If you want to orient the manipulator to a coordinate system, see “Aligning the 

manipulator with a different orientation mode” on page 143.
Otherwise, proceed to step 4.

4 To scale along:
� The X-axis, drag the red handle.
� The Y-axis, drag the green handle.
� The Z-axis, drag the dark blue handle.
� To scale along all three axes (uniform scale), drag the light blue handle. 

The handle changes color as you drag.
If you scale the entire object, its new position is changed in the Property Box (for 
more details, see “Changing the size and shape of objects numerically” on page 144).

TIP If you press the Ctrl key (or Command key on a Mac) while scaling along an axis, you 
will scale uniformly in the complementary axes. For example, if you press Ctrl and scale 
along the X scale axis, you will scale in the Y and Z directions uniformly, and not in the X 
direction
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Understanding and moving the manipulator’s pivot point

In ImageModeler, by default, the pivot point of a manipulator is in the center of an 
object. This allows you to move, rotate, or scale an object around this central point to 
turn or resize it, respectively. However, you can move the pivot point to another point 
in 3D space, anywhere inside the object, at one side of the object (like a door hinge), or 
outside the object (like a swing). 

To move the pivot point:

1 Click on the Select tool  in the Modeling toolbar and select an object or a 
component (see “Selecting objects and components” on page 131).

2 Select either the Move, Rotate, or Scale tool. The pivot point of the object appears 
in the center of the selected object or component. The Pivot Edition options also 
appear in the tool properties:

3 Click on the Edit button.

Tip: Alternatively, press Shift+click on manipulator to edit the pivot.

4 Drag the pivot point and snap the first point of the face to a vertex to the axes that 
define the world space (see “Creating and adding faces” on page 126) or anywhere 
in the 3D space.

5 Click on the Edit button to exit the option.

NOTE Changing the X, Y, and Z values changes the position of both the object or the 
component and the pivot numerically.
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Aligning the manipulator with a different orientation mode

You can align the manipulator to either:

� The world coordinate system. The manipulator’s axes are aligned to the coordinate 
system of the scene in which you will create, evaluate, and modify your models. 
For more information about defining the world coordinate system, see “Defining the 
reference distance” on page 54.

� The object’s coordinate system. The axes are aligned according to the object’s 
position in space. The coordinate system axes align to the position of the object’s 
pivot point (see “Understanding and moving the manipulator’s pivot point” on 
page 142). 

� A defined selection. Select a vertex, an edge, a locator, or a face with which you 
want to align the manipulator. The axes align perpendicular to the normal of the 
selection. 

For example, if you choose to align the manipulator to the face of an object, the axes 
align perpendicular to the normal of the face. If you select an edge or a vertex, the axes 
align to the average of the normal of the adjoining faces. 

To align the manipulator:

1 Select an object or component to which you want to align the manipulator (see 
“Selecting objects and components” on page 131). The object or component is 
highlighted.

2 Select either the Move, Rotate, or Scale tool. The manipulator appears in the 
selected object or component.

world selectionobject
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3 Click on one of the Orientation Mode radio buttons in the tool properties:

ImageModeler aligns the manipulator. 

Changing the size and shape of objects numerically

Alternatively to changing the size and shape of objects using the manipulators, you can 
use the Property Box to alter a primitive’s properties by precise number of units. The 
available options depend on the primitive or mesh selected. 

For example, in the following figure, the objects are divided along the X- (left), the Y- 
(center), and the Z- (right) axes, respectively.

NOTE You can also subdivide an entire object along each axis evenly (see “Increasing the 
number of faces in an object” on page 152).

To change the size and shape of objects numerically:

1 In the Scene Browser, select the primitive or mesh. 
2 Click primitive’s tab. 
3 Do one of the following:

� To move, rotate, or scale a primitive or a mesh, type the new value in the Move field, 
the Rotate field, or the Scale field.

� To resize a plane or a cube type the new value in the Size field.
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� To change the radius of a cylinder, sphere, or disk, type the new value in the Radius 
field.

� To change the length a cylinder, type the new value in the Length field.
� To change the angle of a cylinder, sphere, or disk, type the new value in the Angle 

field.
To subdivide a plane, cube, cylinder, or sphere along an axis to add faces to that axis:

� To subdivide along the X-axis, enter a new value in the X-Sub field.
� To subdivide along the Y-axis, enter a new value in the Y-Sub field.
� To subdivide along the Z-axis, enter a new value in the Z-Sub field.
4 Press Enter.

Snapping objects and components 

Snap an object or component to attach it to another one in the scene. You can snap 
objects or components to a face, to a vertex, to local object axes, or world space axes 
that define the world space or anywhere in the 3D space.

NOTE The original position of a snapped element will be used as a pivot reference for the 
axis constraints.

For example, you can use the Snap tool to do the following:

� Snap a pivot point to a project component with precision to reshape objects (see 
“Step 2: Making basic edits to objects” on page 131).

� Attach faces to a vertex, an edge, or a face of existing objects or create new faces by 
snapping to locators as reference points (see “Creating and adding faces” on 
page 126).

� Align a primitive in the 3D space by snapping its vertices to the axes defined by the 
World Space Tool (see “Adding a primitive” on page 110). 
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� Split an existing face from a vertex, an edge, or anywhere in the face to create 
different shaped faces (see “Splitting faces” on page 153).

� Add a ruler to measure the distance between components or objects in the scene 
(see “Creating a new ruler to measure angles” on page 100).

Snapping one component to another
To snap one item to another item:

1 Select an object or component (see “Selecting objects and components” on 
page 131). The object or component is highlighted.

2 Do one of the following:
� Select Scene > Snap Tool.

� Click    (Snap tool icon) in the Modeling toolbar. 
The pointer changes shape.

3 If you want to constrain to which elements you can snap, click on a snapping filter 
icon to deselect the option (see “Applying the snapping filters” on page 116).

4 Click any part of the selected item, for example, a vertex, an edge, or a face, drag to 
the component to which you want to snap, and then release the mouse button.

Setting the snapping tolerance value
By default, you can drag an object or component to within five pixels around the 
destination point, release the mouse button, and the object or component snaps to it. 

1 Click Edit > Preferences (Windows) or ImageModeler > Preferences (Mac).
2 In the General tab, change the value of the Snapping Tolerance Value.
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Duplicating objects

To duplicate an object:

1 Select the object that you want to duplicate (see “Selecting objects and components” 
on page 131).

2 Select Edit > Duplicate.

TIP Right-click on an object in the Scene Browser and select Duplicate from the 
contextual menu.

Deleting objects

You can delete 3D objects or their components, cameras, camera devices, or locators from 
a scene. Deleting a face, an edge, or a vertex, does not remove the object from the scene.

To delete an object or a component from a scene:

1 Select the object or component that you want to delete (see “Selecting objects and 
components” on page 131).

2 Select Edit > Delete.

TIP Right-click on an object, camera, camera device, or locator in the Scene Browser and 
select Delete from the contextual menu.
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Step 3: Making complex edits to objects

ImageModeler allows you to make complex edits to the primitives and meshes in your 
project. You can create more complex models from simple polygon meshes, or create 
different shaped models that you can manipulate using a combination of the 
ImageModeler editing tools.

� Merge two or more objects or components. You create more complex objects from 
simple ones by merging the vertices, faces, or objects.

� Increase the number of faces in an object. ImageModeler has two options that 
allow you to increase the number of faces of an existing object. You can subdivide 
faces to increase the number of faces and vertices in an object to add more detail to 
your model and edit the new subdivide mesh by manipulating the object 
components to smooth the new mesh.

� Reshape objects. ImageModeler has two options that allow you to change the shape 
of existing objects and add more detail to your model. 
� Split faces by adding one or more edges that divide the face to create different shaped 

faces.
� Extrude one or more faces by protruding or projecting the face(s) along the image 

plane, for example, to create depth in a model.

Merging objects and components

Merging objects, or faces or vertices of objects, helps you create more complex objects 
from simple ones. For example, you can create the legs of a table and the tabletop 
separately, and then merge them to create one object that you can manipulate.
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Merging two or more objects
Merged objects are “grouped” rather than blending objects together to form a new 
shape. Merged objects maintain their existing shape. For example, the merged cylinder 
and sphere in the following image maintain their shapes, but they can be moved and 
manipulated together as one object.

� Select Scene > Merge Objects (Ctrl + M (Windows) or Command + M (Mac)).

After merging objects, you can close any holes that may exist in the object by creating 
a new face (see “Creating and adding faces” on page 126).

Merge two or more faces of the same object
By selecting two or several faces of an object, you can merge them to create a new face, 
for example, if you want to manipulate several faces at the same time.

� Select Scene > Merge Faces (or press “M”).

merging these 
faces...

...results in 
one new face
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After merging and manipulating faces, you can divide them again using the Split tool 
(see “Splitting faces” on page 153).

Glue two vertices of the same object
You can join, or glue, two vertices that have one missing adjacent face. For example, if 
you create two simple polygons, you can select a vertex on either one and glue them.

� Select Scene > Glue Vertices (or press “G”).
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In addition, you can change the shape of objects by deleting faces, selecting adjacent 
vertices, and “sewing” them together:

NOTE If you want to glue two vertices of different objects, you must first merge the 
objects.

Merging objects, faces, or vertices
To merge objects, faces, or vertices:

1 Use the Move and Rotate tools in the Modeling toolbar to position the objects, 
vertices, or faces that you want to merge (see “Moving objects and components” on 
page 138 and “Rotating objects and components” on page 139). 

You can align objects and faces with precision before you merge them (see  
“Snapping objects and components” on page 145).

2 Click Select in the Modeling toolbar and select all objects that you want to merge 
(see “Selecting objects and components” on page 131). The objects are highlighted.
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3 Check that the normals of the faces to merge are facing the same direction (see 
“Understanding face normals” on page 128). If not, invert the required faces (see 
“Inverting face normals” on page 129). 

4 Select Scene and one of the following:
� Merge Objects - ImageModeler merges the objects into a single, new one. The 

merged objects are listed as one mesh in the Scene Browser in the objects folder. 
� Merge Faces - ImageModeler merges the selected faces of an object to form a single 

face.
� Glue Vertices - ImageModeler merges the selected vertices of an object into a single 

one. Vertices must have a missing adjacent face before you can glue them. 

Increasing the number of faces in an object

In ImageModeler, you can increase the number of faces in an object by subdividing or 
triangulating faces or using the bevel tool to add more detail to your model. 

Subdividing an object
When you subdivide an object, you increase the number of faces in the object, 
allowing you to add more intricate detail to your model. 

You can subdivide a primitive along one plane using the Property Box (see “Changing 
the size and shape of objects numerically” on page 144) or create a more complex 
model by subdividing an edge or a face of an object, or the entire object. 

If you select:

� An object, all faces of the selected object are subdivided.
� A face, all selected faces are subdivided
� An edge, all selected edges are split at midpoint.
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To subdivide an object:

1 Select the object you want to subdivide. 
To find out how to select objects, see “Selecting objects and components” on 
page 131.

2 Select Scene > Subdivide (or press “S”).

Triangulating an object or a set of faces
You can also triangulate your model to add more faces to a mesh to make more 
intricate changes to it. Typically though, you would subdivide a mesh instead. 

The following figure shows a regular sphere and a triangulated sphere:

To triangulate an object or face(s):

1 Select the object or a face(s). 
For more information on selecting objects and components, see “Selecting objects 
and components” on page 131.

2 Select Scene > Triangulate (or press “T”).

Splitting faces

Split faces create different shaped faces that can add more detail to your model. When 
you split a face you add one or more edges that divide the face. You may want split a 
face to modify the shape or part of it. You can split the face starting from an edge, a 
vertex, or from the inside of a face and then make basic edits to modify shape of the 
new faces (see “Step 2: Making basic edits to objects” on page 131). 
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You can also make more complex face splits starting from the inside of a face. You may 
want to create a hole in a face to create, for example, a window or a door. You can split 
a face from the inside and either create a hole in the face or extrude it to add depth to 
the model.

To split a face:

1 Do one of the following:
� Select Scene > Split Face Tool.

� Select the Split Face tool . The pointer changes shape.
2 Position the pointer either on the face, at a vertex or on an edge, and place points 

by clicking the pointer to create a new face. 
You can snap the first point of the face to a vertex, an edge, or the inside of a face, 
depending on what you want to do:
Splitting faces starting from an edge
If the first click is point on an edge, then the end point must be either a vertex or a 
point on an edge on the same face. 



ImageModelerTM

User Guide

155

You can add intermediate points are allowed inside the face. For example:

Splitting faces starting from a vertex
If the first click is on a vertex, then the end point must be a vertex or a point on an 
edge of the same face. You can add intermediate points are allowed inside the face. 
For example:
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Splitting faces starting from the inside of a face
If the first click is a point inside a face, then the end point must be the same point. 
ImageModeler does not support faces with holes; when you validate the face, you 
create two new faces:

If you are creating a face starting from the inside of a face, position the pointer 
where you want to place the last point. Click and press Enter or double-click to 
validate the face.

NOTE If the Auto Repeat option is checked in the tool properties, when you finish 
splitting the face, you can continue to split the face from the last point or press Enter to 
validate the face. Otherwise, you must reselect the Split Face tool.

Creating a Round Mesh with the Bevel Tool

The bevel tool allows you to subdivide an edge and transform it into to a round mesh. 
The bevel size and the subdivision can be adjusted interactively.

1 Select the edge that you want bevel
2 Click the Bevel Tool and do the following:

� Drag the mouse to change the size of the bevel
� Use the “+” and “-” to add more subdivisions

TIP The bevel values can be set manually in the properties toolbar.
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Before beveling the front edge

After adding bevels to the mesh.
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Snapping to an object’s center points 

If the Center Snap option is checked in the tool properties, points appear in the 
object, defining the midpoint of the edges and faces. You can snap to these points:

Snapping to an object’s coordinate system
Activating the axis snapping allows you to create well-orientated splits that are parallel 
to the object coordinate system (see “Setting the world space” on page 50). 

For example, when creating doors or windows on a building, you can align them 
accurately with the general orientations (horizontal and vertical) of the building.
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NOTE Change the Tool color in the Colors page in the Preferences dialog to change the 
color of the points.

Extruding faces 

Extruding one or more faces by protruding or projecting the face(s) along the image 
plane creates depth and perspective in a model. You can extrude a face inside an object 
or outside an object.

To extrude one or more faces:

1 Do one of the following:
� Select Scene > Extrude Tool.

� Click the Extrude face tool .
2 Click the face(s) you want to extrude (they become highlighted).

3 Click one of the selected faces and drag the cursor to extrude the face either along 
the normal (up) or along the inverse normal (down). 

TIP While a face is still highlighted you can adjust the extrusion size. Double-clicking a 
different face will apply the extrusion tool to it instead.

extruded face 
along the 

inverse 

extruded face 
along the 
normal
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Extruding faces numerically
As an alternative to using the pointer to extrude face(s), you can enter the exact values 
for the size and the scale of the projection in the corresponding fields in the tool 
properties. 

To extrude a face numerically:

1 Select a face(s) that you want to extrude (see “Selecting objects and components” 
on page 131).

2 Do one of the following:
� Select Scene > Extrude Tool.

� Click the Extrude face tool .
3 Enter the exact size and scale values in the corresponding fields in the tool 

properties:
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Setting the 3D object display properties

As you create your model, visualizing it in different ways can help you work more 
accurately and efficiently. You can display your model differently in viewports. For 
example, you can show objects as wireframe in one viewport, semi-transparent in 
another, with sharpened edges in another, and textures in another. You can apply 
display settings to all viewports too. Changing the display of a model changes only the 
way it looks on the computer monitor to help you model more efficiently; it does not 
alter the texture of the object in the scene.

The display options are shown in the Display toolbar. To show the toolbar, select 
Window > Display Properties.

Viewing objects in the viewport 

Objects are displayed in the 3D Workspace by default. 

To toggle their display on/off, click on the View 3D Objects icon  in the Display 
toolbar. 

Choosing solid or wireframe shading

By default, ImageModeler displays objects at the highest level of complexity, fully 
shaded and smooth, to show the most accurate visual representation of objects in your 
scene. 
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The Solid shade option consumes the most computer-processing power. Depending 
on how complex your model is, what you want to see onscreen at any given time, and 
the task you are currently performing, you may prefer to display your model as 
Wireframe:

You will likely switch between the shade settings as you build and evaluate your model.

NOTE You can change the color of the wireframe in the Colors page in the Preferences 
dialog.

To change the shading of your model:

1 Select the viewport in which you want to change the object’s display. 

2 In the Display toolbar, click on either the Wireframe or Solid icon , 
depending on how you want to display the model.

3 To apply changes to all viewports, click  (Apply to All Views).

NOTE Until you have activated the Apply to All Views option, all changes in any viewport 
will be applied in all the others. Deactivating this option will make each viewport 
independent from the others.

solidwireframe
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Adjusting the shade transparency

By default, the smooth shading option is opaque; you cannot see through the object. If 
you want to see through the image, for example, to see details of the camera shot 
beneath it, adjust the transparency level to change the degree of opacity.

To adjust the transparency of smooth shaded models: 

1 Select the viewport in which you want to change the object’s transparency. 
2 In the Display toolbar, click on the Transparency checkbox to select the option 

and adjust the value in the corresponding field:

3 To apply changes to all viewports, click the Apply to All Views button.

Hiding back-facing polygons

By default, ImageModeler shows you only one side of a model: the one facing you. You 
can turn off backface culling, a process that shows all sides of a model; it’s as though 
you can see through it. While this can be helpful if want to visualize your model this 
way, selecting components nearest to you is sometimes difficult.

without 
backface culling

with backface 
culling
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To show or hide back-facing polygons: 

1 Select the viewport in which you want to change the object’s display. 

2 In the Display toolbar, click   (Backface Culling) to check (to hide) or 
uncheck (show) back-facing polygons.

3 To apply changes to all viewports, click  (Apply to All Views).

Smoothing jagged lines with anti-aliasing

Computers can display horizontal or vertical lines easily and accurately, but curves or 
diagonal lines often appear to have jagged edges. Anti-aliasing softens the line by 
changing slightly the color of nearby pixels, a process that tricks the human eye into 
seeing a smooth (or less jagged) line.

Turn Anti-aliasing on to see smooth edges. Turn it off to optimize performance 
(redrawing speed).

with
anti-aliasing

without
anti-aliasing
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To turn Anti-aliasing on or off: 

1 Select the viewport in which you want to change the object’s display. 
2 Select Edit > Preferences (Windows) or ImageModeler > Preferences (Mac) and 

click the Display tab.
3 Check or uncheck the Anti-aliasing box to activate or deactivate the option, 

respectively.

NOTE Preference settings are always applied to all views.

Smoothing and sharpening edges 

The smart edge display lets you sharpen or smoothen one or more selected edges. The 
smart edge display works in both the smooth and wireframe display shading (see 
“Choosing solid or wireframe shading” on page 161). The figure below shows a regular 
sphere (with wireframe shading) and one with a sharpened edge:

To show or hide edge styles: 
1 Select the viewport in which you want to change the object’s display. 

2 In the Display toolbar, click on the Smart Edge Display icon  to check (to 
hide) or uncheck (show) edges:

without smart 
edge display

with smart 
edge display

soft edges sharp edgesborders
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� Soft edges are drawn in stipple. The Sharp Angle Limit specified in the General 
tab of the Preferences panel defines soft edges. This angle controls the number of 
degrees used to set the angle over which an edge is automatically considered to be 
sharp. The default angle is 300.

� Sharp edges are drawn with a straight line. By default, sharp edges are those less 
than 300. 

� Border edges are drawn in bold if the edge belongs only to one face. In the previous 
image, one of the side faces of the cylinder is deleted in the right figure; thus, the 
borders of the missing face are drawn in bold, signifying that they belong only to one 
face.

3 To apply changes to all viewports, click the Apply to All Views button.

To set smart edge display:
1 Select the edge(s) you want to set (see “Selecting objects and components” on 

page 131).
2 Click Scene > Set Edge Style and select one of the following:

� Sharpen to sharpen the edges.
� Soften to soften the edges.
� Auto to match the Smart Edge Angle specified in the General tab of the 

Preferences panel. 
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Importing existing 3D objects

Typically you import a 3D object only to apply a texture to it, not to make further 
modifications. 

NOTE You can import the following file formats:

NOTE You get only the 3D information and not the 2D information of the formats.

To import an OBJ, a RZI file: 

1 Do one of the following:
� Select File > Import.

� Select Scene > Create Primitive Tool or click  (Add Primitive icon) and 
click Import in the toolbar.

The Import dialog opens in the Object Library folder.

TIP Right-click in the Scene Browser and select Import from the contextual menu to 
open the Import dialog.

Import formats Extension

Autodesk platforms *.obj

Autodesk® XML *.rzi
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2 Browse to select the file you want to import.
3 Click Open.
4 Choose whether you want to use the integration tool to precisely place the imported 

object, or whether you want ImageModeler to import it using default coordinates.

Using the Integration Tool

The Integration tool is dedicated to ease the integration of imported objects and 
scenes into calibrated projects. The tool is automatically activated when objects are 
imported into a project, but it can also be activated on a selected object or a selection 
of objects.

To use the Integration tool:

1 Import or select an object.
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The object appears in the Workspace and its vertices are highlighted when you 
move the pointer over the object.

2 Click  (the Integrate icon) in the Modeling toolbar (or select Scene > 
Integration 2D/3D)

3 Click a vertex and drag it to either a locator, another object’s vertex, an edge, or a 
face. A line appears between the source vertex and the destination:
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TIP Toggle the Dynamic mode to check integration before applying (see “Setting the 
Integration tool properties” on page 171).

4 Drag the next vertex drag it to either a locator, another object’s vertex, an edge, or a 
face:

5 Continue to click and drag the other vertices until you have placed the object in the 
required position:
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Using the Integration tool manipulators

The Object Manipulator is drawn in upper left corner of each viewport, to allow 
rotation, scale and translation of the object/scene to integrate.

The Object Manipulator changes the rotation and scale values of the imported object. 
However, these changes are purely visual to facilitate the selection of the source 
vertices and do not affect the resulting integration.

Setting the Integration tool properties

The Integration tool has properties in a toolbar that you can set to help integration of 
the imported object:

� Up Axis: This option sets the up axis of the imported object. For example, you 
should change the option if the object seems to be lying down on the screen to get it 
well oriented according to the local coordinate system of the calibrated project. 
Select from either Ox (X-up), Oy (Y-up), Oz (Z-up).

rotation manipulator

scale manipulator

translation manipulator
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� Dynamic: This option determines if the object moves when you drag the sources to 
their targets or if unselected, the option is static and the object stays on the same 
place on the viewport. Only links are drawn in the default mode.

� Apply: Applies the current placement.
� Reset: Removes all the placement links.



7

Texturing a Model





ImageModelerTM

User Guide

175

Texturing and the workflow

You apply a material to the surface of a model in a process called “texturing”. 
ImageModeler can extract a texture from a 2D image and apply it to a model. By default, 
projects have a single material with a default color and this material is automatically 
assigned to all faces. When you extract textures from photographs (or assign an RGB 
color), ImageModeler creates a new material and assigns it to the model’s faces. You can 
also assign a constant color to reduce the amount of data.

Texturing Memory Usage

ImageModeler has a texture memory manager that can support high definition images 
and panoramas by assigning more memory to their handling and display. These 
settings allow ImageModeler to:

� improve your productivity with a quicker refresh time when you change an image 
background

� give you better precision for the 3D model’s texture details, supporting many high 
definition images and panoramas

However, you may also need to change down some settings to better support your 
system’s graphics card or to increase your system performance when your project does 
have many high definition images.

To conserve memory usage and increase system performance:

1 Select Edit >Preferences > Display (Windows) or ImageModeler > Preferences > 
Display (Mac).

2 Conserve memory usage settings:
� Check texture compression (you need an OpenGL 1.2 card that supports 

compression)
� Uncheck antialiasing
� Deacrease the texture proxy size
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� Decrease image plane resolution (for example, 512 gives enough image quality 
without zooming the viewport)

� Define the maximum size of your texture cache (256 by default)

NOTE The Texture Memory Manager will automatically release the oldest created texture 
from memory if the global size exceeds the texture cache size.

The texturing workflow

After you have calibrated a project, you are ready to texture models that you have 
created or imported. Enter the Texturing mode by clicking the workflow tab to show 
the toolbar:

For more information about the toolbar, see “Working with the ImageModeler tools” 
on page 19.
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The main steps in the texturing workflow are: 

1 Create the mapping group(s) for each object. When default mapping groups are 
not consistent (due to topological modifications inside the mesh), you must 
generate a new mapping group by setting how the UV points in the mapping group 
will be projected on the 2D map for each object or face selection. 

2 Edit UV mapping (optional). You can more precisely define how textures will be 
projected on the 2D maps by editing the mapping groups with actions such as move, 
rotate, scale, flip, unfold, normalize, unpack and pack.

3 Extract textures. Deform or blend calibrated images to create textures.
4 Edit textures in an external 2D application (optional). Use an external editor 

(such as Photoshop) to edit textures.
In addition, you can optimize the size and number of textures, if necessary. You can 
reduce the texture size to downscale it from full resolution for Web applications or 
reduce the number of textures for easier editing (see “Optimizing the size and number 
of textures” on page 201).

Before texturing a model...

� Make sure that you have calibrated the cameras correctly (see “Evaluating the 
calibration in multi-image projects” on page 63).

� Your project must contain a 3D model, either that you have created or you have 
imported into the scene (see “Step 1: Creating objects” on page 109).
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Step 1: Create Mapping Groups

UV mapping

UV mapping defines the UV texture coordinates that typically connect to points, or 
vertices, in a 3D mesh to position a 2D image texture onto the mesh. Like virtual 
tacks, they pin an exact spot on a texture image to a point on an object’s surface. 

A mapping group represents the 2D development of a set of faces (usually connected) 
that belong to the same object (generally created by vertex projection). In 
ImageModeler, object mapping is composed of 1 to N mapping groups. Each mapping 
group is associated to a unique set of faces (from a single mesh) and a unique texture. 
As the mapping group defines the texture layout (and therefore some extraction 
parameters), you should carefully verify its accuracy before you begin the extraction 
process.

Mapping groups are located in the Mapping Group folder of the Scene Browser. There 
are three states for mapping groups:

� Black icon mapping groups represent textures not yet extracted
� Green icon mapping groups represent valid, extracted textures
� Red icon mapping groups represent textures that do not correspond to the mesh 

topology or UV placement.

NOTE Red mapping groups require a new projection to be applied to the object, and the 
texture should be re-extracted.
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The mapping group property page displays the associated mesh and material (if any). 
These can each be selected by clicking “>”. The properties page also indicates the UV 
density—and the density of the material determins the quantity of pixels per area for 
the texture. This is directly proportional to the size of the object and its projected area. 
The density keeps the proportion between textures, and ImageModeler calculates a UV 
density that can be used during the extraction process.

NOTE If distance units are set to “meters”, a density of 100 means that you have 100 pixels 
per meter.

Generating Mappings
1 In the Scene Browser, select either an Object or a Mapping Group
2 Do one of the following:

�  Select Mapping > Create UV Mapping
� Right-click either the Object or Mapping Group and choose UV Projection

3 Choose mapping projection:
� Planar projects the selection onto a plane—use this option for selections of faces (the 

faces should not be closed).
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� Cubical projects the selection onto a cube map—this option can be used for objects 
or faces.

� Cylindrical projects the selection onto a cylindrical map—there is no restriction for 
the use of this option

� Spherical projects the selection onto a spherical map—there is no restriction for the 
use of this option.

4 Choose the main axis of the projection:
� Y (local)
� Z (local)
� X (local)
� -Y (local)
� -Z (local)
� -X (local)
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Step 2: Editing a UV Mapping

1 Select a texture in the Scene Browser.
2 Do one of the following:

� Right-click in a viewport and select Switch to UV View.
� Press “\”

The UV View is displayed. The UV coordinates projection is shown in green:

TIP If you are working with a single image, the viewport splits into the 3D view and the UV 
Mapping view. If you are working with multiple images, you can have one instance of the UV 
View in one viewport, while displaying the 3D views in the others. Toggle the view by right-
clicking in a viewport and selecting Switch to UV View, or use the keyboard shortcut: \.
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TIP Use the mouse scroller to zoom in the UV map.

3 Navigate within the UV mapping view by right-clicking and choosing:
� Choose Fit in View option to size the map to the viewport.
� Zooom in the view according to the position of the cursor over the view
� Toggle the UV grid display

NOTE  The editing is applied in “real time” so that you can check its 3D position in the 
Workspace.

Transforming UV point-selections
The Transform Tool allows for translating, rotating and scaling UV points. To use this 
tool, do one of the following:

� Normalize—fits all UV point coordinates on the UV map [0.1].’
� Rotate—Rotate the whole UV map with dedicated values or 90°, 180° or 270°.
� Flip—Flip the shole UV map horizontally or vertically.
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Packing or Unpacking a Mapping Group
Use the pack/unpack option to either create a single texture map for an object (the 
mesh will be normalized according to the ratio of the UV density), or to break down 
the map into more manageable pieces.

1 Right-click an object in the Scene Browser
2 Select Unpack Mapping Group

Step 3: Extracting a texture
Texture extraction is automatic in ImageModeler. By default, the application chooses 
the textures to extract from the entire set of the calibrated images. However, some 
shots that were suitable for camera calibration may not be suitable for texture 
extraction. For example some images may be too light or too dark, or objects may 
occlude the object to texture on one or more images. 

How do you select shots to extract from?
You can specify which shots to include in the extraction process by:

� When you follow the extraction procedure, a dialog appears allowing you to select 
from a list of shots to choose which ones will be used in the extraction (see “Step 3: 
Extracting a texture” on page 183). 

� Right-click on a shot in the Scene Browser and select Use for Texture.
� If you never want a shot to be used to extract a texture, you can deselect the Use to 

Extract Textures option in the shot’s Property Box. The shot will not appear in the 
list of shots to extract from during the extraction process.
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Consider the following when selecting shots...
Regardless of when you specify which shots to include in the extraction process, you 
should consider the following:

� The more shots you use to extract textures, the better the result. Providing 
ImageModeler with as much texture information as possible produces more accurate 
and better quality textures in the final model. The more shots, though, the longer it 
takes for ImageModeler to extract the textures.

� A face must be shown in at least one image that you use to extract textures; 
otherwise no texture data can be computed. 

� Every face takes texturing information from all the selected images. The result is a 
blended texture that completely removes discontinuities.

Modeling and texture extraction tasks vary between single-shot and multi-shot 
projects. When you first load image(s) into ImageModeler to start your project, you 
choose either Single or Multiples. Each of these paths gives you different modeling and 
extraction tools.

Single-shot Projects

In a single-shot project, there is only one image (or panorama) that is providing the 
textures so the process is relatively simple. After selecting the objects you want to 
texture, the mapping step is completed and the remaining options for texture 
extraction are:

� Texture size—which can be defined by density value, or by a custom value or a 
percentage from the best extraction size of the original shot.

� Use Hidden Objects for Visibility—this option tells ImageModeler whether to extract 
“black area” where another object other than the extracted one is masking it.

NOTE Visibility is important extracting texture on a surface/mesh. The extraction process 
calculates for each point of view (shot or camera position) which parts of the surface/mesh 
are hidden by other objects of the scene.
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If “Use Hidden Objects for Visibility “ is used: All objects, even those that are hidden (see 
Hide Object in Edit menu) are used for texturing. If this option is not used: only objects that 
are visible are used for texturing.

Multiple-shot Projects

In a multi-shot project, you need to choose more options:

� Select the images you want to use
� Define the resolution of the texture size—define the density for each mapping group; 

the percentage of the size that can be extracted (depending on the size of the object); 
custom define fixed-width value for each texture extraction.
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When you extract a texture from the photographs, it is applied directly to the 3D 
model. For every mapping group linked to this object, the extraction process produces 
a texture file. You select an object or any mapping group in the Scene Browser and 
then run the extraction process (see “The texture extraction process” on page 189).

In some situations, objects may occlude the object to texture on one or more image 
used to extract the texture. You can select shots for extraction that do not contain the 
occlusion during the automatic texture extraction process without impacting the 
quality of the extraction (see also “Texture extraction of selected faces” on page 201). 
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For example, if a project contains two images:

If you do not have any images without objects masking the face you want to texture, 
you can touch up the texture in any paint program.

NOTE The quality of the input images determines the maximum quality you can obtain 
for the textures.

image 1 image 2

Selecting “image 1” 
and “image 2” for 
texture extraction 
results in a textured 
model containing a 
tree that masks part 
of the model:

Selecting only 
“image 2” for 
texture extraction, 
which does not 
contain the tree, 
results in a textured 
model without the 
occlusion:
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Setting Texture Extraction Preferences
1 The Default Texture Density defines a value in pixels per surface unit for extracted 

texture sizes. For example, if units are in centimeters and the default texture density 
is 5, each pixel in an extracted texture will represent 2mm (5 pixels for each 
centimeter).

2 The Texture Border defines how far in pixel units the UV projection will match to 
the border of the UV map.

3 The Pre-sort Texture Shot sorts the images displayed in the Extraction Texture 
Options window in order to show only images pertinent to texture extraction, and 
orders them based on their contribution to texture creation in the project. The 1st 
image in the list is the one which contributes the most to the texture extraction 
process for the project.
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The texture extraction process

To extract a texture:

1 Click on the Texturing tab in the workflow toolbar
2 Select one or more objects or mapping groups.
3 Do one of the following:

� Select Material > Extract Texture.

� Select the Extract textures icon  in the toolbar. 
The Texture Extraction Options dialog appears:

TIP You can prevent shots from appearing in this list by deselecting the Used for Texture 
Extraction option in the shot’s Property Box.
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4 All shots are selected by default. If necessary, select the shots from which you want 
to extract the texture by clicking on them. For example, deselect an image if it 
contains an occlusion that you do not want to include in the final model.

Click the Unselect All to deselect all images and Select All to reselect them.
5 Select an Texture Size Computed by:

� Best—percentage of best size which can be extracted, depending on the size of the 
object inside the images.

� Density—number of pixels per surface unit for each mapping group.
� Custom—fixed-width value for each texture extraction.

NOTE You can also reduce the size of a texture after extraction (see “Resizing textures” on 
page 204).

6 Select an Extraction Mode:
� Area Weighted—calculate the best image to use for each pixel in the texture based 

on the area of each image and contribution to the texture-creation process (same as 
the pre-sorting process for texture shots in Edit > Preferences > Texture (Windows) 
or ImageModeler > Preferences > Texture (Mac), see “Setting Texture Extraction 
Preferences” on page 188).

� Vertex Weighted—calculate which image to use for each vertex of the 3D model.
� All Shots—no calculation is made, all selected images are projected inside the texture.

7 Select a Blending Mode:
� Smart—calculates energy path inside the overlapping area of the extraction.
� Linear—uses gradient transparency mask
� PSD (manual)—saves all images which contribute to the texture process as a layer 

inside a PSD file and allows you to paint the mask for each layer for manual blending.

NOTE Generally Smart Blending offers the best result.

8 Click OK. 
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The new material appears in the Scene Browser with the object’s name plus the suffix 
_TX_#, where # is an incremental number assigned by ImageModeler to make the 
name unique. You can change the name of the material in the Properties Box. Use 
only numbers, letters, or the underscore character. All other characters are invalid.

Capturing Patterns

The Capture Pattern tool allows you to extract textures that can be applied on other 
objects—used for texture repetition or to compelte a part of an object where no texture 
extraction is possible.

1 Do one of the following:
� Select Material > Material Capture Tool.
� Click Capture Pattern in the Texture Toolbar.

A white plane appears in the 3D Workspace.

2 Click to place three corners of the Capture Pattern tool that define the area you want 
to capture.

3 Press Enter to validate the selection. The texture appears in the in the 3D Viewer in 
the bottom left corner of the 3D Workspace.

4 Place the cursor in the 3D Viewer and drag and drop the texture onto a surface.
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Texture file formats

When you save a project, all the textures are saved in a folder called 
“<projectname>_TX” in the same directory as the RZI project file. Texture names 
reflect the names of the materials they are linked to. For example, for a material called 
“mouth”, the assigned texture file could be 
“mouth_TX.png”. 

For ImageModeler projects, textures are saved as PNG files, but you can specify a 
different format when you export a texture (see “Export file formats” on page 214).

Toggling the display of textures

You can toggle the display of textures if the object is displayed in the Solid mode. No 
texturing is shown on wireframe models. 

To show or hide textures in the 3D Workspace: 

1 From the Display toolbar, click on the Textures icon  to check (to show) or 
uncheck (hide) textures.

2 To apply changes to all viewports, click the Apply to All Views button.
3 Go to preferences to specify how textures should be displayed by selecting Edit > 

Preferences > Display (Windows) or ImageModeler > Preferences > Display 
(Windows) and set the texture size to either 10%, 20%, 30%, 50%, 100% of the 
original size. 

NOTE This is only a display restriction; it does not change the real texture size. It is useful 
for working with large projects with large textures, so they can still work with fluid 
responses.
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Locating corresponding materials and faces

Sometimes, you may have difficulty locating a face and its corresponding material. 
ImageModeler allows you to either select the material in the Scene Browser and locate 
the corresponding faces in an object, or select faces of an object and locate the 
corresponding material in the Scene Browser.

If you want to find faces with the same material or assigned color by selecting a face:

1 Select a textured face in the 3D workspace.
2 Select Edit > Face Selection > Same Material (or right-click and choose Same 

Material).
The faces linked to the same material are highlighted.

If you want to find faces with the same material or assigned color by selecting a 
material:

1 In the Scene Browser, click a material or an assigned color. The material or color is 
highlighted. 

2 Select Material > Select Assigned Faces (or right-click and choose Select Linked 
Material). 

The faces linked to the selected material or color are highlighted.

TIP Right-click on a material in the Scene Browser and select Select Assigned Faces from 
the contextual menu.
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What can you do to improve your results?

� Model is not sufficiently detailed. You may need to improve your model if it does 
not provide enough detail for the texture extract process. For example, you want to 
model a box:

If you create a simple cube primitive surrounding the box (left images), you lose 
some information valuable for the texture extraction process (right images):

The simple cubic polygon does not provide enough detail to give good results in the 
texture extraction process. You should improve your model by editing the cube 
primitive to fit the shape of the box. For example, using the Extrude tool, you can 

cube primitive 
for modeling

model after 
texture extraction
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add detail to your model to better define the shape of the box (left images) and then 
re-extract the textures. 
Notice that the textured model (right images) contain no missing textures:

improved model improved texture

texture distorted by 
the unfolding, and 

hard to make further 
edition

good texture 
without unfolding
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You can reduce the number of faces in the texture extraction process (see “The 
texture extraction process” on page 189). Reducing the number of faces reduces the 
size of the patch, which may simplify it and reduce the number of unfolding 
artifacts. 

� The model contains occlusions or masks. Sometimes it may not be possible to 
shoot your images without occlusions. You can open an image editing software 
directly from ImageModeler, edit or touch up your texture. Then, you can reload the 
texture:

Alternatively, you can exclude images containing an occlusion from the texture 
extraction process (see “The texture extraction process” on page 189).

� The model contains non-textured zones. If you want to control a non-textured 
zone of the object, you can assign a constant color (see “Assigning a constant color to 
an object or a face” on page 197) or replace the missing texture by other ones:

� Textures have poor resolution. If the resolution of a texture is too low and the result 
appears pixelated, you can re-extract that texture with a better resolution.
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Step 4: Editing textures

After you have extracted textures for a model, ImageModeler allows you to select 
materials and edit them in an external 2D editor, and automatically reload them.

� Edit textures in an external graphics package. You may want to edit the textures if, 
for example, you need to reduce contrast or to fix blurry portions of the textures. 

� Assign a constant color to an object or face. If a model has a uniform shape or 
color and you want to reduce the amount of data, or you want to control a non-
textured zone of the object, you can assign a constant color to an object (see 
“Assigning a constant color to an object or a face” on page 197).

� Assign an image to an object or a face. You can apply an image to parts of a model 
that are not visible in the original images (see “Applying a texture without extraction” 
on page 198. 

� Assign a texture to an object or a face. Parts that are not visible in the original 
pictures can be textured with generic textures or duplicates of textures already 
extracted textures (see “Applying a texture without extraction” on page 198).

Assigning a constant color to an object or a face

If you do not want to assign a texture to an object, you can assign it a constant color. If 
the model has a uniform shape or color, you can assign a constant color to reduce the 
amount of data. Also, if a model has a non-textured zone, you can control that zone’s 
appearance by assigning a color to it.

To assign a constant color:

1 Select an object or a face(s) to which you want to assign a color (see also “Selecting 
objects and components” on page 131). The object or the face(s) is highlighted.

2 Do one of the following:
� Select Material > Assign Color.

� Click on the Assign Color icon . 
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The color palette opens. 
3 Choose a color from the Color dialog, and then click OK. 
The new material appears in the Scene Browser with the object’s name plus the suffix 
_Col_#, where # is an incremental number assigned by ImageModeler to make the 
name unique. 

To better keep track of materials, rename them to something meaningful, such as 
“MetalDoor1”.

TIP To change at (a later time) the color you assign, click the material in the Scene 
Browser to select it, and then click the Color parameter in the Property Box to open the 
Color settings.

Applying a texture without extraction

Sometimes it may not be possible to shoot your images without occlusions. 
ImageModeler allows you to use an existing texture extracted from another mapping 
group in the scene, or to import an image file and apply this as a texture of the selected 
object or face, using the existing mapping group.

Additionally, you can duplicate parts of already extracted textures that are listed in the 
Scene Browser onto other places, for example, a wall texture or parst of it can be 
reapplied to another wall.

To apply an image from the hard drive:

You can map an image from your hard drive onto an object or the selected faces of an 
object.

1 Select the objects or faces that you want to edit (see also “Selecting objects and 
components” on page 131). The object or the faces are highlighted.

2 Do one of the following:
� Select Material > Assign Image. 
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� Click on the Assign Image icon . 
The file browser opens.

3 Select an image to map and click OK.

NOTE Open the UV Editor to change the default mapping. 

To apply a texture from a hard drive file:

1 Select an object or a face(s) that you want to edit (see also “Selecting objects and 
components” on page 131). The object or the face(s) is highlighted.

2 Do one of the following:
� Select Material > Assign Texture. 

� Click on the Assign Texture icon . 
The Assign Texture dialog opens:

The dialog shows the list of existing materials and its corresponding thumbnail.
3 Select a texture from the list.
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4 Click the Share Texture Images checkbox if you want to assign the texture to 
several faces or objects.

5 Click the Open UV Editor checkbox if you want to change the default mapping.
6 Click OK.

To apply a texture directly from the Scene Browser:

1 Select an object or a face(s) that you want to edit (see also “Selecting objects and 
components” on page 131). The object or the face(s) is highlighted.

NOTE If you do not select any faces or objects, then the material is assigned to the face 
highlighted as you move the pointer over an object.

2 Select a material directly in the Scene Browser and drag and drop it onto the target 
face or faces. As the pointer moves over the target face, the face is highlighted.

For example, the texture on the left wall of the building is assigned also to the right 
wall:



ImageModelerTM

User Guide

201

NOTE The black area when textures are missing is minimized by the option Minimize 
Black Surface in Texture Map, which is checked by default in the Texture page of the 
Preferences dialog. 

Optimizing the size and number of textures

Texture extraction is automatic in ImageModeler. By default, the application chooses 
the textures to extract from either the entire set or a selection of the calibrated images. 
You can optimize the number of textures for easier and faster editing and to reduce the 
number of files for Web applications.

� Manually selecting and extracting faces of a model produces only one output file 
(see “Texture extraction of selected faces” on page 201).

� Increasing the number of faces in a group for extraction decreases the number of 
output textures (see “Defining how faces are grouped for extraction” on page 204).

� Reducing the size textures reduces the file size for Web applications (see “Resizing 
textures” on page 204). 

Texture extraction of selected faces 

Extracting textures for individual or sets of faces allows you to group textures for faces 
and produce one output file. 

Before extraction, consider the following: 

� To quickly extract textures, it is necessary to select a set of polygons that is almost 
planar and that do not overlap.

� Select faces that have at least one other edge in common with another face to form a 
connected patch of adjacent faces. In other words, do not select unconnected faces. 

� Select a patch of faces that have no hole in it when unfolding is checked (see 
“Understanding unfolding” on page 202).
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� Check that no other faces are selected behind your selection. Even if the camera 
cannot see some faces, they can still be selected if their normals face the camera (see 
“Hiding back-facing polygons” on page 163).

To extract a texture:
Select a face(s) by clicking on the corresponding icons in the toolbar (see also 
“Selecting objects and components” on page 131), then follow “The texture extraction 
process” on page 189.

NOTE Be sure not to select back faces (see “Hiding back-facing polygons” on page 163 for 
more details).

Understanding unfolding

By default, ImageModeler calculates an average plane when it extracts textures from 
the faces of an object. The application then “unfolds” the 3D geometry of the model 
onto this calculated plane to apply the texture, and then maps each face to one or more 
input images depending on the orientation of the face. Hidden surface detection and 
perspective correction techniques are applied.

When should you turn on/off unfolding?
For sharp-edged objects, such as buildings, the unfolded texture may be deformed. If 
this is the case, you can try turning off unfolding during the texture extraction process 
(see “The texture extraction process” on page 189).

For smooth objects, such as a human head, the unfolded texture is generally 
satisfactory. However, when making your selection for unfolding, you should try to 
group adjacent faces as much as possible.
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You should avoid the following selections when choosing faces to unfold:

� Selections containing “holes” (top left).
� Separate selections: keep one border (top right).
� Long and thin selections (bottom left). 
� Star-shaped selections (bottom right).
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Never select all the faces of a closed object, for example, a sphere, a cube, or a cylinder. 
ImageModeler is not able to construct one single texture for a closed object. 

Defining how faces are grouped for extraction

By default ImageModeler groups faces together for extraction such that two faces have 
normals that form an angle of less than 90°. You can decrease or increase this 
maximum angle. When you increase the angle, more faces are grouped and the 
number of textures decreases. 

To change the degrees per extraction:

1 Click Edit > Preferences (Windows) or ImageModeler > Preferences (Mac). Click 
the Texture tab.

2 Type the value in degrees in the Maximum Angle per Texture field. 

Resizing textures

You can reduce the texture to downscale it from full resolution, for example, to 
produce smaller files for Web applications. 

To resize the texture:

1 In the Scene Browser, click the material you want to resize. The material is 
selected. 

2 Select Material > Resize Texture or if you want to resize all textures, select 
Material > Resize All Textures. 

3 Specify the scale factor (a percentage of the current size).

NOTE You can also set the texture size when extracting materials (see “The texture 
extraction process” on page 189).
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Removing textured faces

Select the faces that you want to remove and click Edit > Face Selection > Remove 
Textured Faces.
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About Exporting from ImageModeler

The ImageModeler export feature allows you to export files in a number of popular 
formats, as well as allowing you to export only selected objects (in *.rzi and *.obj 
formats). 

ImageModeler 2009 has its own XML-based file format (*.rzi) that describes  all the 
elements that can be created in ImageModeler:

� 3D Objects
� cameras
� 2D points (markers)
� 3D points (locators)
� materials (colors and textures)
� mapping groups
� measures (distance and angles)
� calibration constraints (points, distance, planar, angular)

Backwards compatibility

ImageModeler 2009 will read ImageModeler v4.0 *.rzi files, VTour *.rzv files and 
MatchMover *.rzml files. However, note that ImageModeler cannot read movie files—
so MatchMover *.rzml file support is limited to image sequences only.

NOTE *.rzi files generated by ImageModeler 2009 are not fully supported  by ImageModeler 
v4 or VTour. There is no backwards compatibility because new elements have been 
introduced in the latest version.
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Project Versioning
The ImageModeler versioning feature lets you create versions of your project using the 
latest file name and adding the suffix “_v####” as the version number. This way you 
can still quickly save your projects, but you will be keeping the previous and historic 
versions as well.

To save your projects in versions:
� Select File > Save As Version or press Ctrl + Shift + S (Windows) Shift + Command 

+ S (Mac)
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Rendering a snapshot
The ImageModeler Snapshot option captures an active viewport and renders it as a 
JPG image file.

1 Select a viewport in the Workspace.
2 Select a viewpoint to render by using the pan, zoom, orbit, frame selected, frame 

all, look at selected options.
3 Do one of the following:

� Select File > Snap Shot.

� Click   (the Snap Shot icon) in the Export toolbar.
4 The Snap Shot dialog opens:

� Set the Output Image file name and destination.
� Set the Width and Height in pixels for the rendered image. The upper size limit is 

constrained by the size of the original input images.
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Exporting to other 3D packages

You can export ImageModeler markers, locators, cameras, 3D objects and mesh 
selections, or materials, or any combination of them. If you choose to export materials, 
you can also specify a texture file format. 

By default, when you export you create a RZI file, an ImageModeler XML file. 
However, ImageModeler supports several file formats and each export format supports 
several components which allows you to specify which ones to export. 

See “Export file formats” on page 214 for a summary of the export formats and 
components that you can export. 

To export an ImageModeler project:

1 Select the Export toolbar:

2 Click . 
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The Export dialog opens:

3 Browse to the directory where you want to save your file.
4 Enter a File Name.
5 From the Format drop-down list, select an export format.
6 Under Options, check the component(s) you want to export. If you choose 

Material, select also a Texture Format from the drop-down list.
7 Click OK.
ImageModeler exports your file.
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Export file formats

The following table summarizes which components are supported by the export 
formats:

Export format Extension Export...

Cameras Markers Locators 3D 
Models

Textures

RealDWG1 *.dwg * *

RealDWG 20101, 2 *.dwg * *

FBX *.fbx * * * *

Maya *.ma * * * *

OBJ *.obj * * *

XML *.rzi * * * * *

1 DWG export is not available on the Mac.
 2 Using Autodesk’s RealDWG 2010 technology.
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Blending – Combination of two or more images by adding them on a pixel-by-pixel 
basis.

Cubic – Projection that produces six images corresponding to the front, back, right, 
left, top, and bottom of the cube. 

Cylindrical – Projection that creates a cylinder, which accurately represents a single 
row panorama without distorting the top and bottom from the original image.

Distortion - The lens effect that causes straight lines close to the edge of a photograph 
appear curved.

Dolly - Dollying lets you move the camera back and forth.

Equalizing – Process of balancing the level of brightness between all the images. 

Film Back – Value that represents the size of your film.

Focal length - The distance between the front of the lens and the film back, the plate 
where the film is exposed. Focal lengths greater than 50 mm create a narrower angle of 
view; focal lengths less than 50 mm create a wider angle of view.

FOV – Field of view.

IFF – Maya® image file format.

Interlace – Division of video frames into halves (odd and even), or fields, increase the 
frame rate without increasing the needed bandwidth. 

JPG – JPEG file format.

Locator – a physical feature that can be easily identified in more than one image 
(preferably in all of the images in the project). Some objects have features that 
represent better targets than others. Buildings, for example, normally offer many good 
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reference points: corners, intersection of elements, and so on. A locator must have at 
least 2 reference markers in two images to be used in the calibration.

Marker – the reference points in each image used to describe a locator feature in the 
images.

Orbit - Orbiting around an object lets you “fly” all around the object to see it from any 
angle. On screen it looks as though you are tumbling the object, but you are not; you 
are the one who is moving.

Pan – Panning lets your view (the camera) move from side to side or up and down 
over an object. 

Parallax – Changes the perspective between two adjacent pictures caused by the 
camera position changing between shots.

PIC – Softimage® Pictures file format.

Pixels – Array of picture elements, usually consisting of red, green, and blue color 
values, each with five to eight bits of precision.

Planar – Projection that creates a flat map, perpendicular to the center image. 

PNG – Portable Network Graphics file format.

PPM – Portable Pixelmap file format.

Primitive – a simple or “primitive” 3D object, such as a cube or a cylinder or a sphere. 
Primitives can be combined with Boolean operations to create a more complex 3D 
objects.

Projection – Process of reducing three dimensions to two dimensions for display. It is 
the mapping of the visible part of a three-dimensional object onto a two-dimensional 
screen.
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QuickTime – Export format that renders a Cylindrical or Cubic QTVR projection, 
respectively, ready to be viewed in the QuickTime® Player.

Rendering – The process of creating a high-resolution panorama from the photos you 
have stitched.

Residual Value - the distance in pixels between the 2D marker placed in the image 
and the 3D locator constructed by ImageModeler and reprojected onto the image. 

Roll – Rotates the camera along the line of sight. If animated, a swaying effect is 
achieved. 

SGI – SGITM Image file format.

Spherical – Projection that creates a cube and represents an entire 360° × 180º 
panorama in a single image.

TGA – Truevision Targa file format.

TIFF – Tagged Image file format.

Triedron – A geometric marker that defines a right-angle 3D corner, starting from a 
point of origin and showing the X, Y and Z axes.

Vertex/Vertices – Tagged Image file format.

VRML – Export format that renders a cubic projection, ready to be viewed in the 
VRML viewer.

Zoom – Changes the field of view.
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Keyboard Shortcuts

Keyboard shortcuts are available all the time, regardless of the workflow stage you are 
in. The majority of the shortcuts in ImageModeler can be customized. To access the 
Shortcut Manager:

� Windows: select Edit > Preferences > Shortcuts (or press “P” and select Shortcuts)
� Mac:  ImageModeler > Preferences > Shortcuts

Navigation Shortcuts

NOTE In modeling mode using Windows, changing shots with Ctrl + wheel or Ctrl + arrow 
only cycles through calibrated cameras. In modeling mode on a Mac, changing shots with 
Command + wheel or Command + arrow only cycles through calibrated cameras. 

Action Windows shortcuts Mac shortcuts

Changing image: Cycle 
backward

Ctrl + left arrow Command + left arrow

Changing image: Cycle forward Ctrl + right arrow Command + right arrow

Dolly (only in 3D views) Ctrl + Alt + left-click Command + Option + left-
click

Orbit Alt + right-click Option + right-click

Pan Alt + left-click Option + left-click

Roll Shift + Alt + right-click Shift + Option + right-click

Zoom Mouse wheel or Ctrl + Alt + 
left-click

Mouse wheel or Command + 
Option + left-click

Zoom area Shift + Alt + left-click Shift + Option + left-click

Center the active view on the 
current point under the cursor

C key C key
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* The Thumbnail View is only visible when there is only one viewport showing.

Menu Shortcuts

NOTE If a shortcut is not listed, that particular menu item does not have a customizable 
shortcut.

File menu

Center all views on the current 
point under the cursor

C pressed twice C pressed twice

Zoom in on section under the 
cursor

Z key - Z pressed twice zooms 
back out again.

Z key - Z pressed twice zooms 
back out again.

Action Window shortcuts Mac shortcuts

New Ctrl+N Command + N

Open Ctrl+O Command + O

Save Ctrl+S Command + S

Save As Ctrl + Alt +S Option + Command + S

Save As Version Ctrl + Shift + S Shift + Command + S

Load Images Ctrl+L Command + L

Quit Alt+F4 See ImageModeler menu

Action Windows shortcuts Mac shortcuts



ImageModelerTM

User Guide

225

ImageModeler menu - Mac only

Edit menu

Selection menu

Action Window shortcuts Mac shortcuts

Preferences See Edit menu Command + ,

Quit ImageModeler See File menu Command + Q

Action Windows shortcuts Mac shortcuts

Undo Ctrl + Z Command + Z

Redo Ctrl + Y Command + Y

Hide or Show Ctrl + H Command + H

Show only selected Ctrl + Shift + H Command + Shift + H

Duplicate Ctrl + D Command + D

Delete Del Del

Preferences P See ImageModeler menu

Action Windows shortcuts Mac shortcuts

Selection Tool F2 F2

Select All Ctrl + A Command + A

Unselect All Ctrl + Shift + A Shift + Command + A

Selection Mode>

Objects F3 F3

Vertices F4 F4

Edges F5 F5
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Faces F6 F6

Mapping Groups F7 F7

Face Selection>

Increase Shift + Up Shift + Up

Decrease Shift + Down Shift + Down

Same Material Shift + M Shift + M

Remove Textured Faces Ctrl + T Command + T

Edge Selection>

Edge Loop L L

Selection Bookmark>

Store Selection 1 to 5 Ctrl + 1 to Ctrl + 5 Command + 1 to 5

Restore Selection 1 to 5 1 to 5 1 to 5

Action Windows shortcuts Mac shortcuts
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View menu

Camera menu

Action Windows shortcuts Mac shortcuts

View Bookmark>

Store View 1 to 5 Ctrl + 6 to Ctrl + 0 Command + 6 to 0

Restore View 1 to 5 6 to 0 6 to 0

Lock View Ctrl + K Command + K

Fit View = =

Look at Selected Home Home

Next Shot Ctrl + right arrow or Ctrl + 
mouse scroller

Command + right arrow or 
Command + mouse scroller

Previous Shot Crtl + left arrow or Ctrl + 
mouse scroller

Command + left arrow or 
Command + mouse scroller

Toggle UV View \ \

Action Windows shortcuts Mac shortcuts

Calibrate F9 Command + R
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Scene menu

Mapping menu

Materials menu

Action Windows shortcuts Mac shortcuts

Triangulate T T

Subdivide S S

Invert Face Normals I I

Merge Faces M M

Merge Objects Ctrl + M Command + M

Glue Vertices G G

Action Windows shortcuts Mac shortcuts

Create UV Mapping F10 Command + U

Unfold UVs U U

Transform Tool Y Y

Action Windows shortcuts Mac shortcuts

Extract Texture F11 Command + E
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Window menu

Help menu

Tool Dependent Shortcuts

Action Windows shortcuts Mac shortcuts

Layout>

Single view Spacebar Spacebar

Four views Spacebar Spacebar

Full Screen Ctrl + Shift + F Shift + Command + F

Action Windows shortcuts Mac shortcuts

Contents F1 F1

Windows shortcuts Mac shortcuts Action Tool

Esc Esc Exit the tool and activate 
the default tool of the 
working tab (generally 
Selection)

All

Deactivate the constraint 
selector

Constraints

Backspace Backspace Remove a 2D marker in a 
single view

Selection Marker, Create 
Marker, Move Marker

Apply local undo (one 
tool step back)

Create Face Split
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Enter Enter Apply current placement 
state

Integration

Apply current primitive 
placement and create it

Create Primitive

Close face from create 
points

Close face from create 
points

Apply current extrusion Extrude

Tab Tab Switch between Translate/
Rotate/Scale manipulators

Translate 
Rotate 
Scale

Switch active constraint to 
another

Create Face 
Split 
Create Primitive

Switch Dynamic mode 
on/off

Integration

Shift Shift Add to the selection Selection

Lock the active constraint Lock the active constraint

Ctrl Ctrl Remove from the 
selection

Selection

Avoid intersection 
between scene elements

Constraints

V V Activate constraint 
selector

Constraints

Z Z QuickZoom around 
mouse area

All Tools

Windows shortcuts Mac shortcuts Action Tool
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A A Activate Guiding Axis 
drawing

All tools with snapping 
constraints

R R Reset snapping 
constraints

All tools with snapping 
constraints

Windows shortcuts Mac shortcuts Action Tool
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About taking quality shots

The models you create can only be as good as the photos you take, and you cannot 
model or texture what you cannot see in the photos. Spend a little extra time to obtain 
quality shots that get good coverage of the subject. The following sections outline the 
main recommendations for taking photographs, lighting your scene, and choosing 
equipment.

Equipment recommendations

Choosing lenses

ImageModeler uses the focal length of the lens you use to take the photographs in the 
calibration process. While ImageModeler can use photographs captured with almost 
any type of lens, try to use the same lens to capture all the photographs of your subject. 
For example, if you use a lens that has a focal length of 50 mm, use it for the duration 
of the shoot. If you are using a zoom lens, select a zoom setting and do not change it. 
To compose shots, move the camera toward or away from the subject rather than using 
the lens to zoom in and out. 

Sometimes you must use lenses with different focal lengths. For example, to model a 
building you may need to capture some aerial shots using a 135 mm telephoto lens and 
some ground level shots using a 24 mm wide-angle lens. If you change lenses or zoom 
settings during the shoot, write down the lens used to capture each image.

Using digital vs. film cameras

Ideally, all the photographs of your subject should have the same brightness and color 
balance. This ensures that the model’s textures blend together to give a natural 
appearance. Digital cameras are somewhat easier to work with than film cameras in 
this respect because most digital cameras allow you to choose a white balance setting 
and either lock the exposure or set the exposure manually. If you are using a film 
camera, use the same film stock and scan all the film using the same scanner settings. 
If you use a lab to scan your images, request that the entire roll of film be scanned 
using the same brightness and color settings.



Appendix C

236

Lighting your scene

In general, diffuse lighting provides the best texture detail. Use direct lighting, 
however, if you know your final model will be displayed against a background that also 
contains directional lighting.

Diffuse vs. direct lighting

ImageModeler produces such realistic models in part because the photos, which make 
up the model’s textures, reveal the subject as it appeared in a real lighting 
environment. If part of your subject is cast in shadow then the resulting model will 
lack detail in the shaded regions and suggest a strong light source that may look 
unnatural when the final model is placed against a different background. Diffuse 
lighting reveals details and avoids harsh shadows.

If you are creating a model that will, for example, be placed into a movie sequence, 
light the subject to match the lighting in the movie. This is the same technique used by 
special effects artists when they light an actor standing in front of a blue screen. Direct 
lighting causes harsh shadows and hides details. Use it only when you know your 
model will be placed into a scene with similar lighting. The first image below uses 
direct lighting and the second image uses diffuse lighting.
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Using fixed source lighting and flash photography

Neither the subject nor the light source should change position in photographs. If the 
lighting changes or the subject moves, each image will have different shading. When 
images with conflicting shadows are used for texturing, the model will have an 
unnatural appearance. For this reason, do not use turntables or on-camera flashes. 
On-camera flashes produce hot spots that give the model an unrealistic appearance.

The image below shows the result of using an on-camera flash. See how the flash 
produces hot spots, eliminates detail, and gives the subject a very unnatural 
appearance.
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Recommendations for taking shots

The following sections outline the main recommendations for taking photographs for 
use in ImageModeler and describe what to avoid when taking your shots.

� Capture more shots than required
Consider capturing more images than required, rather than fewer. Discarding images 
that are not required is easier and less time-consuming than re-shooting the subject.

� Focus the camera on the subject
Sharp images produce visible detail, making it easier for you to create models that look 
more realistic. To obtain sharp images, focus the camera on the subject, not on the 
background. 

Make sure the entire subject is in focus, especially if the camera is positioned very 
close to the subject. Be aware that some auto-focus cameras focus on the surface 
nearest to the camera, leaving other surfaces out of focus. Prevent this by moving 
camera a little further away from the subject. 

� Avoid motion blur
Moving the camera causes motion blur. If the camera moves during the shot the image 
will appear blurred, even if the camera was properly focused. Motion blur is most 
likely to occur when taking handheld shots using a slow shutter speed of 1/60th, 1/30th, 
or 1/15th, for example. If you need to use a slow shutter speed, mount the camera on a 
tripod. 
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� Obtain adequate coverage of the subject
ImageModeler gets all of the depth information about an object from the different 
perspectives shown in the photographs. So, the photographs must capture the overall 
geometry of the subject in addition its surfaces. To photograph a box, for example, 
compose shots in which both the top and two sides of the box are visible in the same 
image. Do not photograph each side of the box separately because these images 
contain very little information about the subject’s spatial properties.

Make sure that you include your entire subject in each shot. For example, in the first 
image below. the top and the right side of the subject is cut from the shot. The second 
image is a better shot because it includes the entire subject.

� Avoid occlusions
Blocked areas (called occlusions) are areas that are hidden by another part of the 
subject. They most often occur when you photograph irregularly shaped objects. If 
part of the subject is blocked occluded, be sure to photograph the subject from 
another angle to capture the blocked region.

The image provides 
the necessary depth 

information.

The image provides
too little depth 
information.
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For example, in the image below, the top of the laptop blocks the keyboard. This 
subject needs also to be photographed from the opposite direction. (The newspaper 
was used to provide background features to aid in calibration.)

Similarly, in the following image, the building in the lower right of the first 
photograph blocks the subject: the building behind. You need to change the viewpoint 
of the camera to include the entire subject.

� Shoot from an appropriate distance 
Producing final models with high-quality, photo-realistic detail depends on the detail 
present in the original photographs. Position the camera close enough to the subject to 
capture the level of detail you need, but be far enough away from the subject to include 
some the subject’s background. 

The space surrounding the subject aids in the process of calibration, for example, if 
you are photographing a subject that has been placed on a table, include some of the 
table in the shot.
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In the following example, the camera is too far from the subject to capture any details 
in the first image. In the second image, the camera is close enough to capture detail 
and include some background. In the final shot, the camera is too close to the subject 
to be usable.

� Maintain a constant zoom
Try to maintain a constant zoom when shooting your subject. If you use a constant 
zoom, the focal length is more constrained than when you use a varied zoom and 
ImageModeler finds the focal length of the image more precisely. For example, in the 
first image below, the details are lost, and in the second image, there is too much detail. 

� Shoot scene volume information
Shooting scenes at an angle emphasizes the 3D volume of a scene much more precisely 
than shooting a “face-on” view. Shooting at a slight angle just above or below the plane 
parallel to the horizon gives details of zones normally hidden by a “flat” photograph. 
The first image below shows a bad angle of view; the photo is too “flat”. The second 
image is the preferable angle of view, which shows volume information.
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Tip: You can always add a “face-on” photograph, which is little use in the calibration 
step (although it can be calibrated), but which will certainly be useful for the texture 
extraction process. The middle image below shows a “Face-on” view for texture 
extraction. The left and right images below show angled views for use in the calibration 
process.

� Choose the lighting appropriately. 
Do not use shots with different lighting. If you do, ImageModeler will not be able to 
calibrate the scene correctly. The first image shows the correct lighting; the second 
image is too bright. 
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� Avoid varying color intensities
Do not use shots with different color intensities. If you do, ImageModeler will not be 
able to calibrate the scene correctly. The first image below shows the correct color 
balance; the second image has poor color balance.

� Do not use modified or artistic shots
Resist composing artistic shots; you can be creative when you model. Avoid choosing 
cropped images or images that have been modified because they might complicate the 
distortion correction and you risk displacing the principle point and changing the 
focal length of the image. 

For example, for ImageModeler to correctly perform the calibration process, you must 
not rotate photos in your graphics package. Take all photos using the same camera 
orientation.

� Avoid shooting reflecting surfaces
Using polarizing filters when shooting a scene can limit the effects of rays of the sun 
on a reflecting surface, such as a windowpane. 

Prefer shooting an outdoor scene in cloudy weather rather than in sunny weather 
because clouds hide the sun, remove the effects of reflection on surfaces like glass or 
metal, and also help avoiding pronounced shading differences in a shot. For texturing 
purposes, the more uniform the shading is in a scene, the better the texturing result 
will be.
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Further recommendations

Working with wide-angle lens and distortion

ImageModeler works with photographs taken using a wide-angle lens, if the focal is 
not too small (greater than 20 mm). Photographs taken with objectives with very short 
focal lengths are greatly distorted and result in errors during the calibration process. 
For scenes that do not permit a general view in one photograph, it is preferable to 
shoot several photos of a scene using a lens with a longer focal length and stitch the 
photos using Autodesk®’ Stitcher®. 

Initializing the scale of a scene 

In many cases, e.g. for architectural purposes, you may want to capture data at scale. 
When shooting your images, you can add information in the scene to help you set the 
reference scale in ImageModeler. For instance, placing a two-meter stick on the wall of 
a building will give you an accurate visual reference to perform distance measurements 
on the building within ImageModeler (see “Creating a new ruler to measure angles” on 
page 100). 
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