Introduction
Autodesk Vault Manufacturing (hence forth referred to as Vault Manufacturing) bridges the
gap between tracking CAD design tools and ERP (Engineering Resource Procurement)
systems with its ability to integrate with Microsoft Dynamics GP 10.0 (GP 10) without the use
of custom programming or third-party integration tools.
This white paper discusses the installation, configuration, testing, and basic use of GP 10 and
Vault Manufacturing.

Configurations
The key to integrating GP 10 with Vault Manufacturing is to set up communication between
the GP 10 server and the Vault Manufacturing server. This is done using Microsoft Message
Queuing (MSMQ). This document describes two tested configurations for using Vault
Manufacturing and GP 10.
The first configuration requires two different servers, one server for Vault Manufacturing and
a second server for GP 10. The second configuration uses the same server for both Vault
Manufacturing and GP 10. If Vault Manufacturing and GP 10 are configured on the same
server they should both have a separate SQL instance installed. The proceeding steps will
describe how to install, configure, and test a separate Vault Manufacturing Server and a
Separate GP 10 Server. If installing and configuring GP 10 and Vault Manufacturing on the
same server, disregard the indicated steps.
Note: It is highly recommend to use separate servers for Vault Manufacturing and GP 10.
The following components should be installed and configured in the order shown.
•

•

•
•

Installation
o Vault Manufacturing Server
 Vault Manufacturing Server Application
 Microsoft Message Queuing
o Microsoft Dynamics GP 10.0 Server
 Microsoft Dynamics GP 10.0 Server Application
 AEDMDwfWrapper
 Microsoft Message Queuing
 Dynamic Messaging Service (DMS)
Configuring
o GP 10 Server
 Changing Service User Accounts
 Adding Queues to MSMQ
o Vault Manufacturing Server
 Add GP 10 Queues to Vault Manufacturing
 Add Multiple ERP Systems to Vault Manufacturing
 Setting the Default ERP System
Testing the Connection
Vault Manufacturing Importing and Exporting

Installation
The first step in enabling the bridge between CAD design tools and ERP systems is to
establish item sharing between a GP 10 server and the Vault Manufacturing server. This
section describes how to install the components necessary to successfully integrate GP 10
and Vault Manufacturing.

Vault Manufacturing Server
The Vault Manufacturing server should be installed before installing or configuring the GP 10
server. Perform the following tasks in the order presented to ensure a successful installation.
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Vault Manufacturing Server Application
The Vault Manufacturing server application should be installed first on the server. For more
information on installing the Vault Manufacturing Server see the Autodesk Vault 2010
Implementation Guide.
Microsoft Message Queuing
Follow the steps in this section to install MSMQ. In a two server configuration MSMQ has to
be installed on the Vault Manufacturing server and requires no configuration.
1.
2.
3.
4.

From the Windows Start Menu select Settings > Control Panel.
From the Control Panel double-click Add or Remove Programs.
Select Add/Remove Windows Components.
Select Application Server and click Details.
Note: This item may already be checked if other Application Server options have
been previously loaded.

5. Check Message Queuing.

6. Click OK.
7. Click Next.

Microsoft Dynamics GP 10.0 Server
Use the following steps to install or configure an existing GP 10 server to share information
with Vault Manufacturing.
Microsoft Dynamics GP 10.0 Server Application
Confirm that GP 10.0 service pack 1 or higher is installed. If installing GP 10.0 for the first
time, make the following configuration changes during the installation. If the GP 10.0 SP1 or
higher is already installed, modify the existing configuration with the following changes.
1. Set GP 10.0 to use SQL Server and Windows Authentication mode.
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2. Install the Manufacturing feature and ensure that your company is registered with
those modules.
Note: After installing and registering the GP 10 Manufacturing modules, run GP 10 at
least once to ensure the Manufacturing modules have been activated.
AEDMDwfWrapper
If setting up a single server configuration, you can skip this section because installing the
Vault Manufacturing server already installed the correct AEDMDwfWrapper. If setting up a
two server configuration, use the following steps to install the AEDMDwfWrapper on the GP
10 server.
1. Download AEDMDwfWrapper-Installer.zip from
http://usa.autodesk.com/getdoc/id=DL5078224
2. Extract AEDMDwfWrapper-Installer.exe from AEDMDwfWrapper-Installer.zip and
copy it to the GP 10 server.
3. Double click AEDMDwfWrapper-Installer.exe and accept all of the defaults by
selecting next on all the installation screens.
4. Use Windows Explorer on the Vault Manufacturing Server to locate the file
AEDMDwfWrapper.dll under
installation folder\Server\Components on the Vault server
For example:
C:\Program Files\Autodesk\ADMS Manufacturing 2010\Server\Components\
5. Use Windows Explorer on the GP 10 server to locate AEDMDwfWrapper.dll under
C:\Program Files\Common Files\Autodesk Shared\
6. Copy the AEDMDwfWrapper.dll from the Vault Manufacturing Server and overwrite
the AEDMDwfWrapper.dll on the GP 10 server.
Microsoft Message Queuing
If configuring GP 10 and Vault Manufacturing on the same server, this step has previously
been completed. For step by step instructions on installing MSMQ on the GP 10 server see
the previous steps under Microsoft Message Queuing.
Note: MSMQ will be configured after DMS is installed.
Dynamic Messaging Service (DMS)
If MSMQ is installed, use the GP 10 media to install Dynamic Messaging Service (DMS) on
the GP 10 Server. The DMS install can be found under [GP10 Media]:\AdProd\DMS\. The
following steps describe how to install and configure DMS.
1. Run the Setup.exe.
2. Select Everyone when prompted to identify who will use this application.
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3. Enter the following application parameters:
a. Server Name – Enter the name of the Great Plains SQL server and SQL
instance name.
b. Authentication Method - Select ‘Use a specific user name and password’
c. User name – Enter the database SA name that can log into the Great Plains
SQL server.
d. Password – Enter the database SA password for the user name previously
entered.

4. Click the Test Connection button.
5. If the connection test passes click Next. If the test connection failed and all the
information provide in the dialog box, is correct, try launching GP 10 and rerunning
the test.
6. Change the queue names. Keep in mind queue names are case sensitive.
a. Incoming queue name – adsk_incoming
b. Outgoing queue name – adsk_outgoing
c. Dead-letter queue name – adsk_dead-letter

7. Click Next
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8. Enter the domain account name and password for the user account under which the
service will run.
Note: The user account entered in this step can be a temporary account. This user
can be changed to match the MSMQ service’s LogOn account after installation.
9. Click Next.
10. Enter the UNC paths for both the items exported from GP 10 and their associated
items. These locations should be shared paths to which the user account from the
previous step has access.

Note: It is highly recommended that both these folders are placed on the GP 10
server. The user accounts for the MSSQL$GP10 instance service, as well as the
DMS and MSMQ services all need Full access to these folders.
11.
12.
13.
14.

Click Finish.
From the Start Menu, select Control Panel > Administrative Tools > Services.
Scroll down to Messaging Service.
If Messaging Service is not started, right-click Messaging Service and select Start.

Note: The Message Queuing and Message Service need to run under the same user
account. For instruction on how to change the service user account see Changing
Service User Accounts.
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Configuration
After completing the installation of all the components on each server there are some
configurations that will need to be done before Vault Manufacturing and GP 10 can import
and export items.

GP 10 Server
The following section will describe how to configure the queues for MSMQ. Also included in
this section are steps to quickly change the user account for MSMQ and DMS.
Changing Service User Accounts
Use the following steps to change the user account for the DMS service to match the MSMQ
service’s RunAs account.
1. From the Start Menu, select Control Panel > Administrative Tools > Services.
2. Scroll down to Messaging Service.
3. Right-click Messaging Service and select Properties.

4. Click the Log On tab and enter the same NT account name and password as the
MSMQ service’s account.

.
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Adding Queues to MSMQ
GP 10 uses queues configured in MSMQ. The following steps describe the process to create
and configure the proper queues.
Note: No additional configuration is required for the MSMQ on the Vault Manufacturing
Server..
1. From the Start Menu, select Control Panel > Administrative Tools > Computer
Management.
2. Expand the branch Services and Applications.
3. Expand the branch Message Queuing.
4. Select Private Queues.

5. DMS automatically creates an outgoing queue named adsk_outgoing. If the other two
queues adsk_dead-letter and adsk_incoming were created, delete them by rightclicking the queue and selecting Delete.

6. Right-click Private Queues and select New > Private Queue.
7. Enter the same dead-letter queue name used in step 6 from the previous Installation
section Dynamic Messaging Service (DMS); the default name is adsk_dead-letter
Note: Queue names are case sensitive.
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8. When creating the adsk_incoming and adsk_dead-letter queues check the
Transactional option.

9.
10.
11.
12.
13.

Right click adsk_dead-letter and select Properties.
Select the Security tab.
Select ANONYMOUS LOGON.
Check Receive Message; this should automatically check Peek Message.
Ensure both Receive Message and Peek Message are checked and click OK.

14.
15.
16.
17.
18.

Repeat steps 8 – 13 for the adsk_incoming queue.
If installing GP 10 and Vault Manufacturing on the same server, skip steps 16-19.
From the Windows Start Menu select Run.
Enter regedit and click OK.
Go to
My Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSMQ
\Parameters\Security
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19. Enter a new DWORD name NewRemoteReadServerAllowNoneSecurityClient
and set its value to 1.
For more information on this registry change refer to the Microsoft article
http://technet2.microsoft.com/windowsserver/en/library/97efae9f-8657-43fa89de-e299b45dc7501033.mspx

Vault Manufacturing Server
The Vault Manufacturing server can be configured to use one or more ERP systems. The
following sections show the preferred ways to configure Vault Manufacturing for either one or
multiple ERP systems.
Add GP 10 Queues to Vault Manufacturing
Use the following steps to edit the Web.config for Vault Manufacturing server.
1.
2.
3.
4.

Locate the Web.config file under installation folder\Server\Web\Services
Open the Web.config using Windows Notepad.
From the Edit pull down menu select Find.
Enter MSMQ DWF and click Find Next. This action finds the MSMQ Settings
element.
5. Enter the server name of the GP 10 server and queue names used in step 5 of
“Installing Dynamic Messaging Service (DMS)

6. Save and exit the Web.config.
Add Multiple ERP Systems to Vault Manufacturing
Use the following steps to create multiple ERP systems
1.
2.
3.
4.

Locate the Web.config file under installation folder\Server\Web\Services
Open the Web.config using Windows Notepad.
From the Edit pull down menu select Find.
Enter MSMQ DWF and click Find Next. This should bring you to the MSMQ Settings
element.
5. Highlight the lines starting with <system name = “MSMQ DWF” ……. Including the
line </system>.

6. Copy the selected lines and paste the new copies below the selected existing lines
as shown.
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7. Change the system name to match the name you would like to see in the Vault
Manufacturing Item Export Wizard.
Note: All system names should be unique.

8. Change the machine name to the server name that the new ERP server.

9. Change the queue names to match the queue names configured in step 5 of the
installation section Dynamic Messaging Service (DMS).

10. Repeat steps 5 -9 to add additional ERP systems.
11. Save the Web.config file and exit Notepad.
Setting the Default ERP System
Use the following steps to change the default Item Export option in the Web.config.
1.
2.
3.
4.

Locate the Web.config file under installation folder\Server\Web\Services
Open the Web.config using Windows Notepad.
From the Edit pull down menu select Find.
Enter MSMQ DWF and click Find Next. This should bring you to the MSMQ Settings
element.
5. Locate the line marked <defaultsystem name = …..

6. Change the name to match the name of the intended default system.

7. Save the Web.config file and exit Notepad.
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Testing the Connection
In the Vault Manufacturing client, the connection between an ERP system and Vault
Manufacturing can be tested by providing the proper Machine Name and clicking the Test
Queue button.

The queues to be tested are defined in the Web.Config file. The following logic is used to
determine which queues will be tested in combination with the Machine Name entered in the
dialog box. If the conditions of a step are not met, the test will continue to the next step.
1. If the default system name matches a configured system name and that system is an
MSMQ type, then the queue names listed in this system’s configuration will be tested
in combination with the Machine Name from the ERP Administration dialog box.
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2. If a system name matches the out of the box system name “MSMQ DWF” and that
system is an MSMQ system, then the queue names listed in this system’s
configuration will be tested in combination with the Machine Name from the ERP
Administration dialog box.

3. All the systems defined in the Web.config are checked in the order they are listed.
The queue names of the first MSMQ system that is found will be tested in
combination with the Machine Name from the ERP Administration dialog box.

4. When attempting to launch the ERP Adminstration dialog box and no MSMQ system
is found, the following error is displayed.

Vault Manufacturing Importing and Exporting
Once the Vault Manufacturing integration for GP 10 has been installed and configured you
can use the Vault Manufacturing client to export and import items to and from GP 10.

Exporting From Vault Manufacturing
1. In the Navigation pane, select Item Master.
2. In the item master, select the released or obsolete items to export.
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3. From the File menu, select Export Items or right-click a selected item and then select
Export Items.
The selected item and any children are listed with their respective revision IDs in the
Export Wizard.
Note: Only items that are in a non-WIP state can be exported (i.e., released or
obsolete).
Items that are checked are exported. If you do not want to export an item that is
checked, turn off the check box next to that item.
4. Click Next.
6. In the Specify Target screen, select the MSMQ DWF system
Note: If you have more than one GP 10 system configured, select the appropriate
system name.
7. Click Export.
8. The View Results displays the result, including those items that were successfully
exported and those that were not.
o

Click Print to print the results.

o

Click Send to send the summary information by e-mail.

9. Click Finish.
Note: GP 10 does not allow item numbers longer than 30 characters.
When exporting a child item (i.e. item with no sub-items) from Vault Manufacturing, in order
for GP10 to consider it for import, you must export its parent item instead. See the following
example.

In order to import Item A.1.1 into GP10, Vault Manufacturing must export Item A.1 and Item
A.1.1. It is not necessary to export Item A when exporting Item A.1 from Vault Manufacturing
as the child item A.1.1 will be exported and thus Item A.1 would qualify for GP10 import
considerations.
When exporting items from Vault Manufacturing, all item information and associated
attachments are saved into one DWF file. If this DWF file is larger the 4MB, use one of the
following work arounds to allow GP_10 to successfully import the DWFs.
Set Vault Manufacturing to not include attachments.
1.
2.
3.
4.
5.

Locate the Web.config file under installation folder\Server\Web\Services
Open the Web.config using Windows Notepad.
From the Edit pull down menu select Find.
Enter “export includeAttachments”and click Find Next.
Change the value from true to false.
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Change GP 10’s maximum allowable DWF size. The size is set to 4MB by default.
1. From the start menu select Run
2. Enter regedit and click OK
3. Find the key HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft Dynamics
GP\Messaging Service\General\MaxDwfSize
Note: This file size should be specified in bytes.

Importing into Vault Manufacturing
Follow the steps in this section to import items exported from GP 10 into Vault Manufacturing.
1. From the File pull down menu select “Import Items…”
2. In the Import Wizard select “Other” as the source for importing items.
Note: Due to a limitation in the Microsoft GP 10 DMS, GP 10 item exports are not
exported to MSMQ in a manner which can be imported by selecting an MSMQ job.
For more information reguarding this topic contact Microdoft Dynamics Great Plains
support.
3. Click Next.
4. Select “Design Web Format (DWF).
5. Select the necessary revision scheme.

6. Browse to the folder where the GP 10 exported DWF was saved and select the DWF
to import.
Note: This folder is the DWF export folder which was set up in step 10 of Dynamic
Messaging Service (DMS).
7. Click Next.
8. Review the list of items for conflicts and select Import.
Note: Vault Manufacturing cannot import GP 10 items marked “Inactive” or have a GP 10
revision of “-“.
For more information see Importing Items in the Vault Manufacturing Help.
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Conclusion
Integrating Vault Manufacturing with a company’s ERP system allows design departments to
manage bills of material promoting earlier collaboration with outside departments. By
performing the steps in this document you can configure MSMQ and Vault Manufacturing to
share data with an out of the box Microsoft Dynamics GP 10.0 implementation.
Autodesk [and other products] are either registered trademarks or trademarks
of Autodesk, Inc., in the USA and/or other countries. All other brand names,
product names, or trademarks belong to their respective holders. Autodesk
reserves the right to alter product offerings and specifications at any time
without notice, and is not responsible for typographical or graphical errors that
may appear in this document.
© 2009 Autodesk, Inc. All rights reserved.
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