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What’s new in Subscription
Advantage Pack for
Autodesk Maya 2011

What'’s new

Welcome to What'’s New in Subscription Advantage Pack for Autodesk® Maya®
2011.

The Subscription Advantage Pack provides higher-level access to animation,
shading, and effects feature sets, freeing artists to focus on their creativity. From
lightweight, resolution-independent procedural textures; to joystick-driven
camera rigs that emulate real-world set-ups, the Subscription Advantage Pack
helps artists achieve the high-quality results required by today's demanding
consumers in less time.

Refer to the following sections for details on all the new features of this release.

Modeling

New updates and additions to the Maya marking menus now make selections
to popular modeling tools faster and easier. Improvements to the Detach
Component command now make it easier to detach selected edges.

B New modeling features on page 5



Animation

Maya now includes pre-rigged models of cars and planes and new custom
cameras from Craft Animations. You can use the rigs to quickly set up existing
models and use custom input devices.

B New animation features on page 7

Dynamics

Maya now includes a number of preset effects called Effects Assets. Building

on the Maya Asset framework and simulation toolsets, Effects Assets present
the most relevant attributes for an effect, making it easy to customize for your
scene. Effect assets are available in the Visor window.

ICE Flow for Maya plug-in is a one-click workflow solution that imports
Softimage ICE effects directly into Maya. ICE Flow for Maya lets you take
advantage of the ICE (Interactive Creative Environment) to create effects for
your Maya scenes.

B New dynamics features on page 11

Rendering

Choose from a library of up to 75 new substance procedural textures, and edit
or animate parameters to help achieve a vast range of looks. These new
substance textures are available for you to quickly create photorealistic
procedural textures using a library of organic, fabric, and material presets. You
can choose among substances such as concrete, pavement, stone tiles, painted
wood and so forth.

B New rendering features on page 25

What'’s new in Installation

Open Source libraries

Three open source libraries are available for use with Subscription Advantage
Pack:

m QT 4.5.3 - Maya’s whole Ul framework
B OpenAL 1.10.622 - audio framework

B libquicktime 1.1.3 - provides QuickTime support for the Sequencer

2 | Chapter T What's new in Subscription Advantage Pack for Autodesk Maya 2011



Maya stores the open source packages in a
open source code used with Maya 2011.zip file in the following location:

Windows
Support directory of the root directory of your installation folder.

Mac OS X
support folder inside the .dmg.

Linux
In the .tar.gz download under the support folder.

For the open source used for AdLM, links are available via Help > About Maya.

Installation directories

By default, the Subscription Advantage Pack is installed in the following
locations:

Windows
C:\Program Files\Autodesk\Maya 2011 Subscription Advantage Pack\

Mac OS X
/Applications/Autodesk/maya2011.5

Linux
/usr/autodesk/maya2011.5-x64/

NOTE You can have both Maya 2011 and Maya 2011 Subscription Advantage
Pack installed concurrently. Subscription Advantage Pack does not automatically
overwrite the Maya 2011 installation. Therefore, your pipelines may need to be
adjusted to find the correct installation directory for Subscription Advantage Pack.

What's new in Installation | 3






New modeling features

Marking menu updates and additions

The following table lists updates and additions to the Maya marking menus.

Marking menu Update/addition

Poly Edge B Flip/Spin Edge sub-menu added
B Detach Components added

B Connect Components added

Poly Face B Assign Invisible Faces added

B Connect Components added

Move, Rotate, B Soft Select toggle removed

and Select Tool B Object mode toggle added

Scale B Menu items reordered

B Axis sub-menu added, which includes options for
scaling axis.

B Normal Average, Object, World scaling added
B Soft Select toggle removed
B Object mode toggle added

Poly Vert Connect Components added




Marking menu Update/addition

UV Editor Comp M To Border removed
Convert B To UV Edge Loop added

Detach Component tool improvements

You now get better results when using the Detach Component command to
detach selected edges.

Improved result for Detach Component on selected edges
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New animation features

Craft Animations plug-in

Maya now includes pre-rigged models of two cars and two planes from Craft
Animations, as well as the following cameras:

B Craft SoftMotionCam

B Craft ObserverCam

B Craft MultiStateCam

B Craft HumanizerCam

Use these vehicle rigs to quickly set up your existing vehicle models for

animation, control the vehicles using custom input devices, and record keyframe
animation of the vehicle actions and your camera rigs.

For complete documentation on the Craft Animation rigs and cameras, use the
Help menu in the Craft Animation Director Studio plug-in window. For more
information on Craft Animation, see http://www.craftanimations.com.

Install the Craft Animations plug-in

Install the Craft Animations plug-in on Windows

» Run the Maya installation wizard and select the Craft Animations
component on the Select the Products to Install page.

Install the Craft Animations plug-in on Mac OS X

1 Double-click the Maya .dmg download package.


http://www.craftanimations.com

2
3

In the Finder window that opens, double-click the support folder.

In the Finder window that opens, double-click the Craft Animation . dmg,
then double-click Install.

Install the Craft Animations plug-in on Linux

1
2

Extract the Maya packages from the compressed file.

Navigate to the support folder and extract the craftdirectorstudio .tar.gz
file.

As a super user, navigate to the directory where you extracted the package.

Type ./install.bash.
This starts the Craft Animation plug-in installation.

Before using the Craft Animation plug-in for the first time, you need to load
the plug-In using the Plug-in Manager.

To load Craft Animations Director Studio plug-in

1

Start Maya.

2 Select Window > Settings/Preferences > Plug-in Manager. The Plug-in

Manager opens.

Locate Craft Animations and turn on Loaded.
To load Craft automatically every time you start Maya, turn on Auto load.

Click Close.
You can access the Craft Animations plug-in from the shelf by clicking

the DirectorStudio tab, then clicking the D] icon.

More Mocap Example files

The Visor window now includes additional motion capture example files that
you can use with the character animation retargeting tools.

To find the mocap examples, open the Visor (Window > General Editors >
Visor) and switch to the Mocap Examples tab.
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New dynamics features

Effects Assets

Overview

Effects Assets provides a number of preset effects that are organized as Maya
assets. Effect Assets are available in the Visor window and can be quickly
imported into your scene, applied to objects, then played and rendered with
little or no modification. Effects Assets include 3D fluid containers that emit
fluid and nParticles, nParticle emitters, and Maya fields that provide effects
including explosions, fire, smoke, and rain.

Effects Assets are advanced assets, which allow them to be parented to objects
outside the asset. For example, some assets, such as a fire asset, can be parented
to a polygon object or applied as a surface emitter. Depending on the effect,
selecting Effects Assets > Apply Effect from the nDynamics menu set either
parents the effect to an object, or applies it to a surface. Effects with Point or
Volume emitters are parented while Surface emitter are applied. Free-standing
effects, such as the Bomb.ma, do not need to be applied to objects in the scene.

n



Fire.ma

Effects Assets do not use asset templates or binding sets. For information about
Maya assets, see Assets in the Basics guide.

Modify an effects asset

The easiest way to modify an effect is to adjust the asset's published attributes.
These attributes provide control to the specific characteristics of the effect.
For example, the Fire asset has attributes that adjust flame density, speed, and
height as well as the amount of emitted sparks.

¥  Published Attributes

¥ FireControl

Fire Amount 500,000

NOTE You can access the attributes of the asset's internal nodes by expanding
the asset in the Outliner, then selecting the individual nodes. Be aware that
adjusting the internal node attributes may affect the way the Published Attributes
control your effect.
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Effects Assets and collision objects

For an effect that includes Nucleus objects, a Nucleus node is published to the
asset. To make the effects asset collide with an object, you can select Effects
Assets > Collide with Effect. This converts the selected object to a passive
collision object and assigns it the asset's Nucleus solver. If the object is already
associated with another Nucleus solver, selecting Collide with Effect re-assigns
the object to the asset's Nucleus solver.

To make objects collide with a fluid that is in the effect, you can select the
fluid object, which is an internal node in the asset, in the Outliner. You can
then make the fluid collide with objects as with normal fluids. See Make fluids
collide with geometry in the Fluid Effects guide.

Published nodes

Effects Assets are created with a number of nodes, such as fluid emitter, fluid
container, and Maya field nodes encapsulated in an advanced asset. Not all
encapsulated nodes are published to the asset. To see the nodes published to
the asset, expand the Published nodes section in the effects asset Attribute
Editor. For more information, see Assets in the Basics guide.

Nodes that are published to the asset use the following naming convention:

Published node name Node type Role in asset

childAnchor

not applicable Published when the node needs to be
parented to an object outside the asset.

selectionTransform transform Published to transform encapsulated

nodes of a freestanding effect.

nucleusSolver nucleus Solves Nucleus object interaction, includ-
ing passive collision objects outside the
asset.

targetFluid fluidShape Fluid container that is emitted into for

fluid emission, including surface from
objects outside the asset.

targetParticle

nParticleShape nParticle object that is emitted, includ-
ing surface from objects outside the as-
set.

Effects Assets | 13



Published node name Node type Role in asset

exampleFluidEmitter fluidemitter Fluid emitter when emitting from a
surface, including surfaces of objects
outside the asset.

exampleParticle Emitter ~ emitter nParticle emitter when emitting from a
surface, including surfaces of objects
outside the asset.

exampleParticle nParticleShape nParticle object when effect fills an ob-
ject with nParticles (Fill Object).

exampleNCloth nClothShape nCloth object used in the effect.

Importing and modifying Effects Assets

Import Effects Assets

You can import Effects Assets from the Visor window and apply them to
objects in your scene. You can then use asset’s published attributes to make

most required modifications to your effect.

NOTE If the Effects Assets menu item does not appear in the nDynamics menu
set, you need to restore the nDynamics menu set the default Maya settings.

Restore the nDynamics menu set to default by doing the following:

1 From the Status Line, select Customize.
2 In the Menu Set Editor, under Menu sets, select nDynamics.

3 Select Edit > Revert nDynamics to Default.

To import an effects asset

1 In the nDynamics menu set, select Effects Assets > Get Effects Asset.

The Visor appears with the Effects Assets tab selected.

NOTE If the Visor window does not display the Effects Assets tab, in the Visor

window, select Tabs > Revert to Default Tabs.
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2 Select the icon for the effects asset file you want to use and middle-drag
it into the scene.

Maya imports the effects asset into the scene and the asset object

identified by the assets icon appears in the Outliner.

NOTE Many of the assets contain descriptions of their contents, located in
the Notes sections of their Attribute Editor tabs. These descriptions can help
you better understand how the effects are applied.

Some assets can be parented to polygon objects that are outside the asset. You
can do this by applying the effect.

To apply an effect
1 Select the object you want to interact with the effect.

2 From the nDynamics menu set, select Effects Assets > Apply Effect.
The effects asset is now parented to the selected object.

NOTE You can import or reference a file containing an effects asset and use
it in your scene. After the effect is in the scene, you can apply it to objects
like other effects assets.

Modify an applied effect

Each effect asset has a number of published attributes that you can use to
modify the effect’s behavior.

1 In the Outliner, select the effects asset.

2 In the asset Attribute Editor, in the Published Attributes section, expand
channels.

The effect's published attributes are listed.

NOTE You can access the attributes of the asset's internal nodes by expanding
the asset in the Outliner, then selecting the individual nodes. Be aware that
adjusting the internal node attributes may affect the way the Published
Attributes control your effect.

Importing and modifying Effects Assets | 15



ICE Flow for Maya

ICE Flow for Maya lets you import Softimage ICE effects directly into Maya
scenes. Using ICE Flow for Maya, you can take advantage of the ICE (Interactive
Creative Environment) node-based dataflow structure to create a vast range
of effects for your Maya scenes, including point cloud fire and simulated
geometry deformations. To use ICE Flow for Maya, you must have Softimage
installed on your computer. For more information about ICE simulations, see
the Softimage
Wiki-http://softimage.wiki.softimage.com/index.php/Interoperability_with_Maya.

Scene files for ICE Flow must originate from Maya, include a single node
camera (other than the default camera), and at least one curve or polygon
object. Softimage uses the new camera as the current camera in the scene. The
polygon objects in the Maya scene can be used in ICE effects as surfaces for
particle emission, collision geometry, or base geometry for ICE-based
deformation effects. See Prepare your Maya scene for ICE Flow on page 20.

A Send as New Softimage Scene command sends objects selected in Maya to
Softimage along with any geometry caches. After you create an ICE particle
or ICE deformation effect, an Update Current Maya Scene command in
Softimage sends the effect back as a Maya nCache (particle effects) or geometry
cache file (deformation effects). See Using ICE Flow for Maya on page 19.
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Maya scene with camera
and geometry.

Send the camera and geometry to Softimage:
File > Send to Softimage > Send as New Softimage Scene.

Create an ICE particle or
deformation effect
using the Maya objects.

Send the effect to Maya:
File > Send to Maya > Update Current Maya Scene.

—— ICE effect appears in Maya.

Update existing objects or
add new ones.

Send updates back to Softimage:
File > Send to Softimage > Add to Current Softimage Scene.

For particle simulations, an nParticleShape, nucleus, and nCache nodes are
created when the ICE effect is first sent back to Maya. Note that a particle
emitter node is not created in Maya. This means that all particle
emission-related settings and updates must be made in Softimage.

ICE Flow for Maya | 17



Managing ICE Flow files

By default, Maya organizes the various files associated with ICE Flow for Maya
in an ICEFlow sub-folder located inside the set Maya projects folder. The Maya
projects folder includes the following ICE Flow-related files:

B Original Maya .mb scene file.
An .fbx version of objects selected in Maya.
An .mb.manifest version of the scene file.

A Softimage .mb.scn version of the scene.

Sequence of Maya .mc cache, nCache, and .xm/ cache description files of
the ICE effect.

You can specify the location where Maya copies ICE Flow file by accessing the
ICE Flow preferences in both Softimage and Maya.

¥  Extra Attributes

See Send to Softimage > Preferences on page 23.

Cached attributes

For particle simulations, Softimage caches the following Maya attributes:
Count

Particle ID

Per-particle color (rgbPP)

Per-particle opacity (opacityPP)

Particle velocity

Per-particle radius (radiusPP)

SimulatedFrameFraction
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NOTE There are Softimage ICE attributes in the cache that are not read by Maya.

You choose which Maya attributes Softimage includes in the cache. To do
this, in Softimage, select File > Send to Maya > Preferences. For more
information, see the Softimage
Wiki:http://softimage.wiki.softimage.com/index.php/Interoperability_with_Maya

Like other nCached particle simulations, you can modify per-particle, Color,
Opacity, and Radius before rendering with mental ray for Maya.

Using ICE Flow for Maya

When using ICE Flow for Maya, be aware of the following unsupported actions
and important notes.

Unsupported actions

Updates to object transform values and animation must be made in Maya,
then sent to Softimage to appear in the effect.

Maya subdivision objects are not supported in Softimage.

Any Softimage objects other than ICE tree nodes do not appear in the
Maya. For example primitives created in Softimage are not included in the
cached effect.

Properties, such as weight maps and vertex colors that are added in
Softimage, are not sent back to Maya. These properties are lost if the objects
are re-sent from Maya to Softimage.

Only Points, Spheres, and Rectangle (Sprites) particle Shapes (Particle
Render Types) work in both Softimage and Maya.

You can change the Particle Render Type in Maya, but the changes are not
transferred to Softimage.

Use of multiple shapes in Softimage will not transfer to Maya. Maya uses
the shape of the first particle for the Particle Render Type, as long as it is
a Point, Sphere, or Rectangle (sprite).

If you want to use scene objects as instanced shapes, you need to instance
the geometry in Maya after sending the effect back from Softimage. See
Instance geometry to particles in the Maya Dynamics guide.
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Important notes

Maya reads ICE particle and deformation effects as cached files, meaning
that the effect cannot be modified in Maya.
See nCaching in the Maya Dynamics and Effects guide.

Maya nodes or objects that are not recognized by the FBX file format appear
in Softimage scene as anchors. The anchors maintain transform values set
by Maya.

Changes to scene length and frame rate are not transferred between
applications. You must set the frame rate and scene length in Softimage
and the timeslider and frame rate in Maya.

For information about creating ICE particle and deformation effects, see the
Softimage Wikit:
http://softimage.wiki.softimage.com/index.php/Interoperability_with_Maya.

Prepare your Maya scene for ICE Flow

Prepare your Maya scene for ICE Flow by doing the following:

1

Set your Maya project and save the scene you want to use for your ICE
particle or deformation effect to the currently set project. All of the files
associated with the ICE Flow operation are copied to the currently set
Maya project folder.

Create a one node camera in your scene.

You must have a camera in addition to the Maya default camera in the
scene.

Create a least one polygon or curve object.
Set the Maya timeslider in the scene to the desired length of your

simulation.

Increasing the scene length in Softimage does not update the scene that
is sent back to Maya. You must set the scene length in both Maya and
Softimage.

If you want to use animated geometry in an ICE effect, ensure that you
have created a Maya geometry cache of the animation.

Sending objects to Softimage

After you have prepared your Maya scene for ICE Flow, you can send it to
Softimage, then create an ICE particle or deformation effect.
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In the Outliner, select camera and the polygon objects you want to use
in the ICE effect.

Select File > Send to Softimage > Send as New Scene.

NOTE If Send as New Scene does not appear in the File menu, you may need
to reload the ICE for Maya plug-in. See Load or unload Maya plug-ins in the
Basics guide.

Softimage starts with the new scene displaying the selected objects. Maya
and Softimage are now connected as indicated in both application status
bars.

Connected to Maya

Create your ICE particle or deformation effect in Softimage.

For information about ICE effects, see the Softimage Wiki:
http://softimage.wiki.softimage.com/index.php/Interoperability_with_Maya.
If you want to specify a location for the ICE Flow files, in Softimage, select
File > Send to Maya > Preferences.

Otherwise, the ICE Flow files are copied to the default location in the set
Maya projects folder.

In Softimage, select File > Send to Maya > Update Current Maya Scene
to send the ICE effect to Maya.

Maya loads the scene and an ICEFlowAttributes node appears in the
Outliner.

You can make changes to the objects in the scene or add new ones, then send
the scene back to Softimage to update the effect.

Updating, adding, or deleting objects

After sending your ICE effect back to Maya, you can modify objects or add
new ones to the scene. For example, you can change the location of collision
objects, and then re-send the scene to Softimage to update the ICE effect. If
you no longer want to use an object in an effect, you can delete it.

Be aware that there are limitations to the updates you can make to the scene
file before sending it back to Softimage. See Using ICE Flow for Maya on page
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To update an existing object

1 Save the changes you made to the Maya scene.

If you have made changes to an animated deformation, you need to
update the geometry cache.

2 To select the camera and the objects previously sent to Softimage, select
File > Send to Softimage > Select Previously Sent Objects.

3 Select File > Send to Softimage > Update Current Softimage Scene.
Softimage updates the current scene.

To add objects
1 Save the changes you made to the Maya scene.

2 In the Outliner, select the objects you added, then select File > Send to
Softimage > Add to Current Softimage Scene.

Maya selects the camera and previously sent geometry before sending
the scene to Softimage. Softimage updates the effect with the new objects.
To remove an object

» To remove objects that you no longer want in a scene, you must delete
each object separately in both the Maya and Softimage scene.

nDynamics menus

The following new menu items have been added to Maya nDynamics menu
set to support new features:

File > Send to Softimage

Send to Softimage > Send as New Softimage Scene

Launches Softimage (if it is not running), creates a new scene in Softimage,
and sends the selected camera and objects to the new scene.

If Softimage is already running, you are prompted to save to the current scene
or cancel. Selecting Cancel stops the send operation.
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Send to Softimage > Update Current Softimage Scene

Sends the ICE effect back to Softimage and includes updates made to the object
previously sent to Softimage.

If no objects are selected, you are prompted as to whether you want to re-send
the objects previously sent to Softimage.
Send to Softimage > Add to Current Softimage Scene

Sends the ICE effect back to Softimage and adds new objects that are selected.
Maya also selects the camera and updates to objects previously sent to
Softimage.

Send to Softimage > Select Previously Sent Objects

Selects the Maya objects that were previously sent to Softimage.

Send to Softimage > Preferences

Opens the ICEFlowAttributes node Attribute Editor. In the Extra Attributes
section, you can specify the location where Maya copies ICE Flow files, as well
as view ICE Flow related information.

NOTE If you have not sent the scene to Softimage, selecting Preferences creates
an empty ICEFlowAttributes node.

Effects Assets

Effects Assets > Apply Effect

Applies the effects asset to the selected object by parenting the asset to the
object.

Effects Assets > Collide with Effect

Converts the selected object to a passive collision object and assigns it the
Nucleus solver in the asset. If the object is already associated with an other
Nucleus solver, selecting Collide with Effect re-assigns the object to the asset's
Nucleus solver.

Effects Assets > Get Effects Asset

Opens the Visor with the Effects Assets tab selected. Effects Assets are Maya
.ma files of preset fluid and nParticles effects that are organized as Maya assets.
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Effects Assets can be quickly imported into your scene, applied to objects,
then played and rendered with little or no modification.
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New rendering features

Substance textures

Creating substance textures

You can use the Substance node to quickly create photorealistic procedural
textures using a library of organic, fabric, and material presets.

Creating a shading network using substance textures

1

Select Window > Settings/Preferences > Plug-in Manager and ensure that
the substance plug-in is loaded.

Select Renderer > High Quality Rendering in the panel menus for best
results.

Select Window > Rendering Editors > Hypershade to open the Hypershade
window.

Select Maya > 2D Textures > Substance.

Y substance

NOTE Do not use the Substance Output node, which is an intermediate node
that is created automatically by the Substance node.

In the Substance Attribute Editor, Substance File attribute, navigate to your
<Maya Directory>\substances folder and select a substance texture.

Click Create Shader Network.
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This creates a shading network with a Phong E material that, by default,
connects the Diffuse, Specular, and Normal substance outputs.

NOTE The Diffuse, Specular, and Normal substance outputs are marked with

green connect icons E to indicate that these output nodes have been
created and are connected to the material shader.

You can now apply this Phong E material to the objects in your scene.

Shading network created with Phong E material.
Diffuse, Specular, and Normal outputs are connected by default,
and their connect buttons appear in green.

7 Select the resolution for your substance output nodes.

8 Expand the Substance Normal Format section and select the format for
your normal map (if a Normal substance output is available for the
substance you have selected).

9 Expand the Extra Attributes section in the substance Attribute Editor and
tweak the attributes provided to customize the appearance of your shader.
Procedural controls are built into each substance so you can easily create
unique effects. Experiment with these sliders and view the changes in
real time in the Maya scene view.

You can tweak attributes such as Hue Shift to shift the global color range
of the texture, or Luminosity to control the brightness level, or Saturation
to control the level of color purity, or Depth to adjust the attenuation of
depth of the texture and so forth.

There are also other interesting effects such as Age. For example, with
Painted_Wood, increasing the age slider peels away the paint to reveal a
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more aged wood look, and with Modern_Concrete, increasing the age
slider reveals the rebar in the concrete. With Volcano_Rock, you can
tweak the Temperature, Lava and Lava Hue attributes to customize the
look of your volcano lava and so forth.

See Extra Attributes on page 31 for more information.

If you want to connect additional substance outputs to your shading
network, such as a Bump or Displacement map, click on the Connect

- icon beside the list of available substance outputs.

If the input of the material attribute is already occupied by another
substance output, for example Normal, then a warning message appears,
and the output is created but not connected. The substance output
connect icon appears orange. You can then delete the connected output
and re-attach a new output in its place.

Bump is created but not connected and its connect button
appears in orange.

TIP A grey connect icon (initial state) denotes that no S.ubstance Output
node has been created yet for this output map. An orange connect icon
denotes that an output node is created but not connected to another node.
A green connect icon denotes that the Substance Output node has been
created and is connected to another node.
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NOTE The Maya software renderer is not recommended for use with normal
maps. If you want to render unbaked substance textures using the Maya
software renderer, use bump maps instead of normal maps. Alternatively,
you can use mental ray rendering with baked normal maps.

NOTE Only a subset of the attributes in the place2dTexture node work with
substances in the viewport or the hardware renderer: Offset, Wrap U, Wrap V,
Rotate UV, and Repeat UV. The remaining attributes all work with substances when
rendered.

NOTE You can modify your choice of substance file and the shading network
connections are retained.

You can now use the shading network in the Maya viewport, and render it
using the Maya hardware renderer or software renderer.

If you want to export the shading network to a game engine, or to render it
in mental ray, you must export the images to disk.
Exporting images to disk

1 Click Export images to disk in the Substance Attribute Editor.

Using this feature, all Substance Output nodes connected to the Substance
node (including both outputs denoted by green and orange icons) are
baked onto disk.

The Substance Bake to Texture window appears.

2 Select your map resolution and image format.

NOTE mental ray for Maya does not support LZW compressed . tif files. To
work around this, add IMF_TIFF_COMPRESSION=none to your Maya . env file.

3 Select the Create shader network option to create a shading network with
connections to the texture files baked from the substance output maps.
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Shading network created for baked
substance material.

4 Click Export to write your file textures to disk.

Troubleshooting substance parameters are lost when
re-opening files on different platforms

If you include a substance file in your scene and customize its parameters,
then save the file and re-open it on a different platform, your substance
parameters may be lost when you re-enter the file path on the substance node.

To workaround this, open the .ma file in a text editor before opening it in
Maya, and search/replace the substance file paths to fit the platform that you
are going to work on.

For example, after you have saved a file in Windows and wish to re-open it
on the Magc, search for c: \Program Files\Autodesk\Maya 2011 Subscription
Advantage Pack\substances and replace it with
/Bpplications/Autodesk/maya2011.5/substances. This way, on file load, your
substance parameters should retain all animation and customization.

Substance node Attribute Editor

The following is a list of attributes in the Substance node.
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Substance Texture Attributes

Substance File Use this attribute to load a substance file (. sbsar file); can be
a full path filename or a relative filename. Substance files are located in the
<Maya Directory>\substances folder by default.

NOTE Search paths for relative filenames happen in the following order:

1 Using the MAYA_LOCATION environment variable. The plug-in searches
for a substance file in MAYA_LOCATION/substances (but not in
subfolders);

2 Using an optionVar named SBS_FILE_PATH, if it exists.

Substance graph A Substance graph is basically a substance. A graph may
contain several outputs combined to make a whole usable material that can
be connected directly to any kind of shader. Several substances can be present
in a substance file.

Reload Reloads the present substance file, this is used when updating a
substance file or when you want to reset all substance parameters of this graph.

Substance outputs After a substance file has been loaded, the possible
substance outputs appear in this list. May include Diffuse, Specular, Normal,
Bump, Displacement and so forth.

When you click on a connect button, it creates a material or gets the connected
material and creates the corresponding substance output node to this material
in the appropriate attribute. The color of the connect button indicates the
status of the output node.

A grey connect icon (initial state) denotes that no Substance Output node has
been created yet for this output map.

An orange connect icon denotes that an output node is created but not
connected to another node.

A green connect icon denotes that the Substance Output node has been created
and is connected to another node.

Normal This channel outputs a tangent-space normal map. It is mainly
intended to be connected to a bump2D node that is connected to the Bump
Mapping channel of your shader.

Height This map includes all the detail generated for the purposes of surface
displacement. It includes major surface distortions, as well as very small surface
details.

Displacement This map includes the low-frequency distortions of the Height
map. The Relief Balance parameter filters the amount of detail included from
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the Height map. It describes major surface displacements (such as dunes on
a sand surface).

Bump This map includes the high-frequency detail of the Height map. The
Relief Balance parameter filters the amount of detail included from the Height
map. It describes the fine details of the same surface (as the sand grains on
the sand surface).

Map width/Map height Select from resolutions between 32 to 2048.

Keep aspect ratio Disable this attribute to generate substance output maps
that are non-square textures. You can then move the Map width and Map
height sliders independently of each other.

Create Shader Network Click this to create a basic shading network with a
PhongE material. It connects the Diffuse, Specular, and Normal substance
outputs by default, and can connect to more outputs if available.

Export images to disk Select this option to bake textures of the output maps
you have created. Use this feature if you want to export your maps to an
external game engine or to render with the mental ray for Maya renderer.

Substance Normal Format
Normal map format Select among the list of normal map formats.

The default is the OpenGL file format.

OpenGL is the default Maya hardware rendering API used in the viewport.
This option allows users, and especially game developers, to export their assets
with their 3D engine format such as Direct3D, and so forth.

Right handed denotes using right handed coordinates.

Normalized in the range [0,1] means that a color value of 0 corresponds to 0
in the normal, and a color value of 255 corresponds to a value of 1 in the
normal. If not using normalized values, the normal map is between [-1,1],
where [-1,0] maps to the [0,128] color values and [0,1]maps to the [128,255]
color values.

Extra Attributes

NOTE Mathematical utility operations can be mapped onto substance parameters,
but visual effects like textures cannot.

Hue Shift Shifts the global color range of the texture.
Luminosity Adjusts the brightness level of the texture.
Saturation Adjusts the level of color purity of the texture.

Contrast Adjusts the gradations between the light and dark areas of the texture.
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RandomSeed Adjusts the random seed value of the generated texture and
allows you to quickly modify the base pattern of the texture.

Depth Adjusts the attenuation of depth of the texture.
Normal Adjusts the attenuation of the normals of the texture.
Emboss Adjusts the level of detail enhancement of the texture.

Angle Adjusts the angle of diffuse in relation to the level of Emboss applied
to the texture.

Relief Balance The Relief Balance parameter drives the way the Bump/Normal
and Displacement outputs behave.

The higher the value, the more detail is put in the Bump or Normal output
and the less in the Displacement output. The lower the value, the more detail
is put in the Displacement output and the less in the Bump/Normal output.
With the default value, the Displacement output is almost flat.

Using this attribute, you can filter the high frequency detail out of your
displacement map to limit the amount of tessellation in your displacement
rendering. The high frequency detail can then be handled by a normal map
instead.
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