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1 Autodesk Maya 8.5 Service 
Pack 1 release notes

The Autodesk Maya 8.5 Service Pack 1 release notes contain information on 
what’s new, what’s fixed and known limitations for this release. 

To find out more, see the following chapters:

• ”General release notes” on page 11

• ”Modeling release notes” on page 17

• ”Animation, Character Setup, and Deformers release notes” on page 21

• ”Dynamics and Effects release notes” on page 23

• ”Rendering and Render Setup release notes” on page 29

• ”Developer Resources release notes” on page 33
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2 General release notes

This chapter provides information about what’s new, what’s fixed and known 
limitations for the following:

• ”Basics” on page 11

• ”Mac OS X” on page 12

• ”Linux” on page 13

• ”File Referencing” on page 14

• ”MEL and Python” on page 14

• ”Licensing” on page 15

Basics What’s Fixed?

Constraints being lost when file saved
A problem with constraints being lost under certain File > Save conditions has 
been fixed. 

Importing scenes with objects that have the same name
An issue with objects being renamed when importing scenes with objects named 
the same as the file has been fixed. 

File names for image planes
A problem with certain file names for image planes being used on Linux has been 
fixed. 

Non-deletable nodes deleted when using container nodes
When working within the Hypergraph and Hypershade editors, non-deletable 
nodes (for example, default shading materials) are deleted whenever its container 
node is deleted. This has been fixed. 

Extended ASCII characters in node and attribute names 
and scene portability
Maya supports characters in the lower ASCII range (0-127) for node and attribute 
names. On some platforms, Maya allows these names to contain single-byte 
characters from the extended ASCII range (for example, Windows under the ISO-
8859-1 or Latin codepage, and Linux in a Latin locale such as en_US.iso88591). 
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These extended ASCII characters include letters with accents and other diacritical 
marks and digraphs (for example, é and ß), commonly found in such languages 
as French or German.

Scene files with node or attribute names containing characters outside the lower-
ASCII range may exhibit problems when moved between platforms.

In order to properly use these extended ASCII characters on Windows, you must 
first open the Regional and Language Options Control Panel, and ensure that the 
Advanced tab's language setting for non-Unicode programs is set to a Latin-
compatible language such as English, French, or German. Changing this language 
setting may require you to reboot your system.

In order to properly save or open scenes with these characters on Linux, you 
must set your LANG environment variable to a Latin-compatible locale before 
running Maya. Depending on your shell, the command to do so will look 
something like this:

export LANG=en_US.iso88591

Maya does not allow extended ASCII characters in node or attribute names on 
Mac OS X, or on Linux running under a multi-byte locale such as en_US.UTF-8.  
Opening a scene file with extended ASCII characters in an unsupported 
environment may result in data loss.

(Maya's user interface on Linux does not support Japanese or any other multi-
byte text.) 

Mac OS X What’s Fixed?

Serious problem with Maya 8.5 uninstaller
There is a serious bug in the uninstaller for Maya 8.5 that could potentially delete 
important files from your machine.

In rare cases where Maya was installed directly into the Applications folder 
(overriding the default location /Applications/Autodesk/Maya8.5), the Maya 
uninstaller will “clean up” the entire Applications folder while uninstalling 
Maya. This would result in the loss of the entire contents of that folder (including 
all other installed applications).

Before installing Maya 8.5 Service Pack 1, please check where you installed 
Maya 8.5. In the unlikely event that it was installed directly under the 
Applications folder (or anywhere else where you may be concerned about 
inadvertent deletion of other files), you can remove Maya 8.5 by manually 
deleting the following files and the Maya8.5 folder:

Command Line Tools Readme.rtf 
ExternalWebBrowser/ 
Fcheck.app 
Maya Terminal.term 
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Maya-OPA.opa 
Maya.app 
Public/ 
Uninstall Maya 8.5.uninst 
Docs/ 
Movies/ 
Autodesk/PCW/

This problem is resolved in Maya 8.5 Service Pack 1 and all subsequent 
releases. 

Save As defaults to .ma file format on Mac OS X
When using File > Save As on Mac OS X, the feature would default to the .ma file 
format regardless of what is specified for the File type option setting. This has 
been fixed. 

User preferences not respected when Maya launches
In Maya 8.5, default user preference files would automatically be created the first 
time Maya was launched even though user preferences from previous versions 
existed. The new default user preferences would be used instead of the existing 
ones. This problem has been fixed. 

Linux What’s Fixed?

Hotbox disappears when space bar is released on Linux 
version of Maya
The Hotbox disappears even when a mouse button is depressed whenever the 
space bar is released when using the Linux version of Maya. This makes it 
difficult to make selections from the Hotbox. This has been fixed. 

Middle mouse button paste on Linux
The middle mouse button paste functionality on Linux that lets you paste 
selections of text into the Script and Expression Editors was broken. This has 
been fixed.

Set Normal Angle option window too small on Linux
The Normals > Set Normal Angle option window appears too small and cannot be 
resized to a usable state. This has been fixed. 
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2 | General release notes
File Referencing > What’s Fixed?

File 
Referencing

What’s Fixed?

List Unknown Reference Edits
The List Unknown Reference Edits window would show all reference edits if the 
scene had no unknown reference edits. This has been fixed.

Reference edits for connected attributes 
Reference edits on connected attributes were not being saved properly. This has 
been fixed.]

Shader nodes with the same name and file referencing
When using the shared shading network feature for file references, light linking 
and materialInfo would not be merged properly when a referenced scene had 
shader nodes with the same name. This problem has been fixed. 

Referenced-in file with animation clips problems
Reference edits to the animationMapping attribute (on a character set node), 
when it has an animation clip, overwrite the computed values. This problem has 
been fixed. 

Per-face shading assignment on referenced instance
A problem where there was a loss of per-face shading assignment on referenced 
instances when unloading and reloading a reference or saving and re-opening the 
scene has been fixed. 

MEL and 
Python

What’s Fixed?

scriptEditorInfo -writeHistory 
A problem where scriptEditorInfo -writeHistory did not work properly has 
been fixed. 

Note scriptEditorInfo -writeHistory does not respect the 
suppression flags set in the Maya Script editor. If you want to set 
suppression flags, you have to set them using scriptEditorInfo; 
the check marks in the menus of the Script editor do not have an 
impact. 

The CommandWindow does allow you to set suppression flags that 
will be respected by the scriptEditorInfo command. 
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Python libraries on Linux
There was a problem with a few of the Python modules shipped with Maya 8.5 on 
Linux. Some of the Python modules were compiled to use the unicode type UCS2 
while the version of Python that shipped with Maya used UCS4. Those modules 
do not load in Maya. Those modules include: array, pyexpat, unicodedata, 
local, and tkinter. This problem has been fixed.

Python path
Maya was setting the PYTHONHOME environment variable, which was confusing 
external Python interpreters if they were launched from Maya (that is, launching 
using the Python os.system call or the MEL system call). This problem has been 
fixed; Maya no longer leaves this variable set. 

Python limitations

Missing Python modules from 64-bit systems
The following modules are not included in 64-bit distributions of Python (Windows 
and Linux):

audioop, imageop, rgbimg

For more information, see svn.python.org/projects/python/trunk/README.  

Licensing What’s Fixed?

Hardware locks (dongles) on 32-bit Linux operating 
systems
An issue with USB dongles not working properly on certain 32-bit Linux operating 
systems has been fixed. 

On SuSE 10.1, you may need to mount the USB hardware lock before installing 
the driver (that is, mount -t usbfs none /proc/bus/usb/ before running  
rpm -i aksusbd-suse-1.8.1-3.i386.rpm). If you do not want to mount the 
filesystem each time you reboot the system, you can add the following line to  
/etc/fstab after the /proc entry:

none     /proc/bus/usb      usbfs      default      0  0 
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3 Modeling release notes

This chapter provides information about what’s new, what’s fixed and known 
limitations for the following:

• ”Polygonal Modeling” on page 17

Polygonal 
Modeling

What’s New?
The following documentation has been updated based on recent bug fixes. This 
documentation will appear in the Maya Help in the next full version of Maya.

Edit Mesh > Add Divisions
Splits selected polygon components (edges or faces) into smaller components. 
Add Divisions is useful when you need to add detail to an existing polygon mesh 
in either a global or localized manner.

Polygon faces can be divided into three-sided (triangles) or four-sided 
(quadrangles) faces. Edges can be subdivided so that the number of sides on a 
face is increased. 

Edit Mesh > Add Divisions > 
Settings

Determines how the selected faces or edges get subdivided into smaller 
components. The Division of the components can occur in either an exponential 
or linear manner depending on the component type selected.

Exponentially Divides the selected faces recursively based on the 
Division levels setting. That is, the selected component 
is divided in half, then each half is further divided in half, 
and so on. The location for a division on a face is 
dependent on the number of border edges surrounding 
the face.

Linearly Divides the selected faces or edges into an absolute 
number of segments based on the Division levels 
setting. For polygon edges, Linear specifies the number 
of new vertices that get inserted on the selected edges.

Note The Exponential or Linear Controls that appear in the Add Divisions 
options window change depending on whether polygonal faces or 
edges are currently selected in the scene.
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3 | Modeling release notes
Polygonal Modeling > Edit Mesh > Add Divisions

Exponential Controls (for faces)

Division levels Specifies the number of divisions that occur for selected 
faces. The option can have a value ranging between one 
and four. The default value is one. A Division level of one 
divides a single face into four smaller faces when 
Exponentially is the selected Division method. If the 
Division level is set to two, a single face is subdivided 
into sixteen smaller faces.

Mode Turn quads on to subdivide faces into quads or turn 
triangles on to subdivide faces into triangles. These 
options are only available for faces.

Linear Controls (for faces)

Divisions in U, V When Linearly is the selected division method for faces, 
you can specify the number of divisions that occur along 
U and V for a polygon. For example, when the 
Subdivisions in U and V are set to three and two, the 
polygon face would be divided into six smaller faces.

Linear Controls (for edges)

Division levels When polygon edges are subdivided using the Linearly 
option, a subdivision level of one inserts a single vertex 
along the edge dividing it into two edges. When the 
subdivision level is set at two, two vertices are inserted 
along the edge to subdivide it into three smaller edges.

Minimum length Sets the minimum length of each sub-edge created. This 
option is only available for edges.

Worldspace When turned on, the specified Division value is the 
distance between vertices in world space. When turned 
off, the Divisions value is the distance between vertices 
in local space. This option is available for edges only.

Note The Add Divisions feature is driven from the pick mask, not the 
current selection. For instance, if you select a face, but the pick 
mask is set to Edge, Add Divisions will not work and if you open the 
option window, the option window for Edges displays. Also, if the 
pick mask is set to Vertex or UV, the Add Divisions option window 
will not open, since only faces and edges can be subdivided. To 
work around this, ensure that the pick mask corresponds to the 
selection.
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Edit Mesh > Collapse
The Collapse feature collapses edges on a component by component basis and 
then merges the associated vertices for each collapsed edge separately. 
Collapse also works on faces, but produces results that are more predictable 
when using edges. If you wish to collapse and merge a selection of faces you 
should first try Edit Mesh > Merge To Center. 

To merge a selection of edges separately

1 Select the edges you want to merge on a component by component basis.

2 Select Edit Mesh > Collapse.

Each edge is collapsed and its component vertices merged.

What’s Fixed?

Add Divisions option window displays incorrect settings
The Edit Mesh > Add Divisions option window incorrectly displays an Exponential 
setting whenever polygon edges are selected in versions 8.0 and 8.5. This has 
been fixed. 

Collapse feature in Edit Mesh menu
The Edit Mesh > Collapse feature is missing from the Edit Mesh drop-down menu 
in versions 8.0 and 8.5.This has been fixed.

Insert Edge Loop Tool on Subdiv Proxy object exits Maya
Using Edit Mesh > Insert Edge Loop Tool on a Subdiv Proxy object set to display 
in Full Mirror mode while the UV Texture Editor additionally displayed causes 
Maya to quit unexpectedly. This has been fixed.

Polygon reverse normal settings are reversed in option 
window
The Normals > Reverse options settings window has the Selected Faces and 
Selected Faces Then Extract options reversed. Selecting one option performs the 
others actions and vice versa. This has been fixed. 

Split Polygon Tool may fail when mesh is rotated or scaled
The Split Polygon Tool sometimes fails to split across multiple faces on a mesh if 
the mesh has been rotated or scaled. To workaround this issue, freeze 
transformations on the affected mesh then invoke the tool again. This has been 
fixed.
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3 | Modeling release notes
Polygonal Modeling > What’s Fixed?

Split Polygon Tool reverts positions of edit vertices
Vertices inserted and subsequently repositioned when using the Split Polygon 
Tool revert to the position of their creation when the split is executed or the tool 
exited. This has been fixed. 

Insert and Offset Edge Loop tools with reversed normals
The Insert and Offset Edge Loop Tools insert edge loops inconsistently when one 
or more of the face normals are reversed along the loop on the mesh. The new 
edge loop is either positioned inconsistently across the selected edge loop or 
causes Maya to exit unexpectedly depending on the situation. This has been 
fixed. 

Issues with undo and redo when using Move Tool with 
Reflection setting
Performing an undo and subsequently a redo when using the Move Tool with the 
Reflection setting turned on results in undesired translation and scale operations 
on the selected vertices on the mesh. This has been fixed.

Extrude works incorrectly after Convert Selection operation
The Extrude feature does not work correctly after a Convert Selection to Face 
operation from vertices has occurred. Instead the vertices are extruded if that 
was the current component selection mode. To workaround this issue, update the 
selection mode to Faces, then use Extrude. This has been fixed. 

Merge fails after Convert Selection operation
The Merge feature fails to execute correctly after a Convert Selection operation 
depending on the previous component selection type. To workaround this issue, 
update the selection mode to Edges, and then select Merge again. This has been 
fixed. 



Maya 8.5 Service Pack 1 Release Notes
21

4 Animation, Character Setup, 
and Deformers release notes

This chapter provides information about what’s new, what’s fixed and known 
limitations for the following:

• ”Animation” on page 21

• ”Character Setup” on page 21

• ”Deformers” on page 22

Animation What’s Fixed?

Scale curves appear in Graph Editor for unkeyed joints
The Graph Editor incorrectly showed Scale keyframes for joints whose child joints 
were keyed. This is now fixed. 

Character 
Setup

What’s Fixed?

Problem with curve influence object evaluation
The problem with the evaluation of curve influence objects that had the Use 
Components skinCluster attribute turned on is now fixed. 

Problem with influence objects with Use Components 
enabled
The problem with the smooth skinning deformation calculation for the case where 
some influence objects were set to Use Components and some were not is now 
fixed. 

Remove Unused Influences may cause skinning problems
The problem where removing unused influences could cause Maya to assign bad 
weights or crash is now fixed. 

Curve influence objects cause double transformations
The problem with the smooth skinning evaluation that caused a double transform 
when a curve influence object was parented to the skeleton is now fixed. 
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4 | Animation, Character Setup, and Deformers release notes
Deformers > What’s Fixed?

Deformers What’s Fixed?

Problems with Delete Non-Deformer History
• Delete Non-Deformer History did not properly maintain different weight values 

on coincident vertices. This is now fixed. 

• The problem that Delete Non-Deformer History had with weighting assignment 
near surface edges has now dramatically improved. 
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5 Dynamics and Effects release 
notes

This chapter provides information about what’s new, what’s fixed and known 
limitations for the following:

• ”nCloth” on page 23

• ”Fluid Effects” on page 27

• ”Hair” on page 27

nCloth What’s New

nCloth attribute presets
You can now easily create nCloth effects like burlap or chiffon with the new 
nCloth attribute presets. 

The nCloth attribute presets change the attribute settings of your nCloth objects 
to preset values so that you can quickly achieve the nCloth effects you are 
looking for rather than starting from the default settings.

The nCloth attribute presets are located in the Preset drop-down menu in the 
nClothShape Attribute Editor tab.

nCloth example files
New nCloth example files that contain nCloth effects like a zipper or a bag of 
marbles are now available in the Visor.

You can access the nCloth example files from nCloth > Get nCloth Examples in 
the nCloth menu set.

What’s Fixed?

Constrained CVs flip and become trapped on wrong side of 
surface
With nCloth constraints that have short Max Distances and low Strengths, 
constrained CVs would sometimes flip over to the wrong side of their surface and 
become trapped. This is now fixed. 

Simulation changes with Substeps
The overall character of nCloth behavior during playback changed when Substeps 
increased or decreased. This is now fixed. 
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nCloth > What’s Fixed?

Cross Links and Component Type ignored on file load
When an nCloth object’s Cross Links are turned off, or when it has a constraint 
with a Component Type of All or Borders and its scene is saved at an advance 
frame with respect to the nCloth start frame, then the nCloth object’s scene 
would load with the Cross Links and Component Type attributes ignored. This is 
now fixed. 

Volume conservation problems with air intake
Volume conservation was not working correctly when the motion of the nCloth 
object should have resulted in air intake. For example, it was difficult to get a 
parachute to puff out correctly. This is now fixed. 

Constraints do not use component Weights
Point to Surface and Slide on Surface constraints between two nCloth objects did 
not use component Weight and Strength correctly. This is now fixed. A component 
with a Weight of 0.0 now does not affect other components and a constraint link 
with a Strength of 0.0 now has no effect. 

Maya runs out of memory with large nCloth objects
Creating an nCloth or Passive object greater than six meters in any dimension 
would cause Maya to run out of memory and crash. This has been fixed. 

Wind Speed scaling incorrect
If you had a Nucleus solver with a non-zero Wind Speed, it would scale incorrectly 
if you changed its number of Substeps or if you changed its scene’s frame rate. 
This has been fixed. However, to get the same Wind Speed behavior as in Maya 
8.5, you need to multiply the Wind Speed by the number of frames per second 
and divide by the number of Substeps. 

nCloth does not evaluate when particle evaluation is 
disabled
Turning off particle evaluation (Modify > Evaluate Nodes > Particles) would turn 
off nCloth evaluation as well. This is now fixed. 

Unpredictable cacheBlend behavior
When an nCloth cache blend node couldn't find one of its caches, unpredictable 
behavior would result. This is now fixed. 

Transfer Cache To Input Mesh only works on one nCloth 
object at a time
The problem with Transfer Cache To Input Mesh not working with more than one 
nCloth object at a time is now fixed. 
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nCloth creation scripts do not return node names
The problem with the createNCloth, createNConstraint and 
makeCollideNCloth scripts not returning the names of the nCloth, 
dynamicConstraint or nRigid nodes they created is now fixed. 

Fields ignore nCloth Mass value
Non-Gravity dynamic Fields treated nCloth objects as if their Mass values were 
always 1.0. This is now fixed. 

Undesirable collisions with low Friction passive objects
Undesirable nCloth behavior would occur when nCloth objects collided with low 
Friction passive objects. This is now fixed. 

Rigidity prevents small nCloth object rotation
Small nCloth objects (smaller than approximately 0.2 cm in diameter) would have 
problems rotating when Rigidity is turned on. This is now fixed. 

No nCloth examples or presets
The nCloth attribute presets that were made available for download from 
The Area after Maya 8.5 shipped are now available directly from 8.5 SP1. There 
are also nCloth example scenes now available from the nCloth Visor tab. 

nCloth constraints with Bend crash Maya
Under some circumstances, setting a non-zero Bend value on an nCloth 
constraint would cause Maya to crash. This is now fixed. 

Shear Resistance doesn't work with Bend Resistance
The problem with Shear Resistance on an nCloth not working when its Bend 
Resistance was set to 0.0 is now fixed. 

Collisions fail with animated passive objects
The problem with the arbitrary failure of collisions with passive objects when the 
timescale is not 1.0 is now fixed. For cases where changing the timescale results 
in extremely fast moving objects, you may still need to increase substeps for 
better collisions. 

Constraint instability occurs with large frame number
Simulating at a large frame number introduces instability into the simulation. This 
is now fixed. 
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5 | Dynamics and Effects release notes
nCloth > Release Notes

Attract to Matching Mesh constraint Strength too low
The default constraint strength for Attract to Matching Mesh constraint has been 
increased to get a closer match when the constraint is first applied. The 
constraint strength can still be modified after creation to get a closer or looser 
attraction. 

nCloth object as skin influencer fails
Using an nCloth object as a smooth skin influence object would fail because 
multiple nodes with the same name would be generated when the nCloth 
influence object’s base node was created. This is now fixed. 

Release Notes

Unlimited license check in batch occurs when nCloth in 
scene is disabled
When nCloth or passive objects in your scene are disabled in batch mode, a 
Maya Unlimited license check for simulation still occurs.

For example, if you are working with a scene that has disabled nCloth or passive 
objects in it, and you are performing batch render tests on the non-effects 
components of your scene, Maya will still try to check for a Maya Unlimited 
license.

Workaround
Disable the nucleus node for your nCloth and passive objects, rather than 
disabling all your individual nCloth and passive objects. 

Unlimited license check in batch occurs when nCloth in 
scene is cached
When the nCloth objects in your scene are cached, and the scene is saved at a 
frame after the nCloth simulations’ start frames, then a Maya Unlimited license 
is used unnecessarily when batch rendering. 

Workaround
If your scene contains nCloth objects, make sure that the scene is saved at or 
before the start frame of your nCloth simulations. 

Maya hangs after nCloth topology edit
If you change the topology of a passive object by reducing the number of its 
vertices or faces, and you make this change at a frame after the start frame, 
Maya may hang if you resume playback after you make the change.
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Workaround
After changing the topology of a passive object, rewind to the start frame before 
resuming playback. 

Deleting constrained passive objects crashes Maya 
(Windows 64 only)
Maya crashes when you delete a passive object that has nCloth objects 
constrained to it. 

Workaround
First delete the passive object’s constraints, and then delete the passive object.

Fluid 
Effects

What’s Fixed?

Fluids cache licence error
When batch rendering a fluid with a segmented cache, a Maya Unlimited license 
was still checked for if one was available, and a run up still happened, resulting 
in much longer render times than expected. This is now fixed.

For fluids where the grids are set to Static, Maya Unlimited licenses are no longer 
used in batch, no runup occurs, and the solver is not used. To take advantage of 
this, after creating your segmented cache, set any grids that were Dynamic to 
Static. This will improve interactive playback of the segmented cache.

For fluids with only gradients and no grids, Maya Unlimited licenses are also no 
longer used in batch.

For fluids that only use expressions, plug-ins, or emitters to update, and they do 
not require a solver, set their solver type to None and their grids to Dynamic. This 
does not use a Maya Unlimited license, but still permits runup in batch. 

Hair What’s Fixed?

Problem with creating Hair caches in batch mode
The problem where you could not create Hair caches when in batch rendering 
mode is now fixed. 
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6 Rendering and Render Setup 
release notes

This chapter provides information about what’s new, what’s fixed and known 
limitations for the following:

• ”mental ray for Maya” on page 29

• ”Rendering” on page 32

mental ray 
for Maya

What’s New?

Improved mental ray for Maya export performance
We’ve improved the performance of mental ray for Maya’s export of JPEG files. 

What’s Fixed?

Maya batch renders multiple copies of render layers
Previously, scenes containing render layers with a single camera rendered with 
Maya’s batch renderer (Render > Batch Render), rendered the same layer images 
multiple times. This is now fixed. 

Embed letters mi in directories or filenames when using 
the -file flag
Previously, when using the command line renderer, there were problems with the 
-file flag when the letters mi were in the directory structure. This has now been 
fixed. 

Auto Memory Limit and extra memory of 64-bit systems
Previously, there were problems with the Auto Memory Limit option calculating a 
memory limit value that is too small. This could cause scenes to crash when 
rendering. This has been fixed. 

Camera background color and IBL node with primary 
visibility turned off
In previous versions of Maya, adding an IBL node to your scene with primary 
visibility turned off results in a black background regardless of your camera 
background color. This has been fixed. 
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mental ray for Maya > mental ray for Maya limitations

Lightlinking is obeyed when baking vertex color with IBL
In previous releases of Maya, lightlinking appeared to be ignored when vertex 
baking is used with IBL. This has now been fixed.  

Light linking with one mesh and multiple shaders
Previously, when your scene consists of one mesh and multiple shaders, light 
linking may not work properly. This has now been fixed. 

Exporting mi files with non-iff files on Linux platform
Previously, if you use mental ray rendering on the Linux platform, and you choose 
to save to a non-iff file, mental ray would overwrite your settings and default to 
the iff format. This has now been fixed. 

mental ray fur rendering with the Rasterizer and Full 
Motion Blur
Previously, mental ray did not render fur correctly when the Rasterizer was used 
and Motion Blur was set to Full. This has now been fixed. 

Batch rendering now respects MAYA_LICENSE environment 
variable
Previously, batch rendering with mental ray ignored the MAYA_LICENSE 
environment variable. In particular, if you set MAYA_LICENSE=Complete, the 
batch render would still check out an Unlimited license if one was available, and 
there will thus be one less Unlimited license available for the artists. This has 
now been fixed. 

mental ray now renders deformer animation for smooth 
proxies
Previously, when rendering with mental ray, deformer animation does not flow into 
smooth proxies. This has now been fixed. 

mental ray for Maya limitations

Rendering fur in mental ray with directional light produces 
artifacts 
Scenes with fur rendered by mental ray may appear with grid-like artifacts (vertical 
and horizontal lines), when: the Fur Shader is set to Hair Primitive (Fur > Fur 
Render Settings > mental ray for Maya Fur render settings); and the scene is lit 
by Directional light(s). 
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Workaround
1 Shut down Maya and mental ray standalone (if you are using it).

2 Set the following environment variable as indicated:

MI_HAIR_SPLITTING=0

For information on how to set environment variables, see:

www.autodesk.com/us/maya/docs/Maya85/DeveloperResources/
Setting_environment_variables_using_Mayaenv.html and  
www.autodesk.com/us/maya/docs/Maya85/DeveloperResources/
Setting_environment_variables_using_system_commands.html.

3 Start Maya and re-open your scene.

4 Re-render your scene. You can render from within Maya, or use mental ray 
standalone.

Incorrect bounding boxes reported for fur node
Maya reports incorrect (zero) bounding boxes for its FurFeedback nodes.

Workaround
Enable Show > Locators and the bounding boxes will be correct. 

Initial render in mental ray fails on Windows Vista
On the 32-bit Windows Vista operating system, the initial render in mental ray 
fails with a mi_openexer.dll error.

Workaround
Render for a second time. 

Firewall software interfering with network rendering
When performing mental ray network rendering, it is important to ensure that any 
firewall software is not interfering with the operation of your network rendering 
software. 

Notes • Using the MI_HAIR_SPLITTING environment variable requires 
significant memory. You may need to adjust your memory limit, 
especially on 64-bit systems (at least 3GB is recommended). 
You can explicitly set the memory limit in the mental ray Render 
Option window (Render > Render Current Frame > Memory). For 
more information, see http://www.autodesk.com/us/maya/
docs/Maya85/Rendering/Render__Render_Current_Frame.html.

• In addition, because this environment variable requires 
significant memory, you should only use it in specific cases, 
and otherwise disable it.
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Rendering > What’s Fixed?

mental ray satellite for Maya 8.5 Service Pack 1
If you are running mental ray Satellite with Maya, you must install a new version 
of Satellite with Maya 8.5 service pack 1.

Rendering What’s Fixed?

Objects hidden by display layer settings appear in High 
Quality render
Previously, objects on a hidden display layer, appeared in High Quality renders. 
This is now fixed. 

Unloading file references causes lighting information to 
disappear
Previously, unloading a file reference caused the lighting and/or light linking 
information to disappear from the shared shading group associated with the file 
reference. Now, when you unload a file reference the lighting and/or light linking 
information is maintained. 

Batch rendering with NURBS now working properly
Scenes that contained certain kinds of NURBS objects with control points were 
failing to batch render using mental ray and the software renderer. This has been 
fixed. 
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7 Developer Resources release 
notes

This chapter provides information about what’s new, what’s fixed and known 
limitations for the following:

• ”API” on page 33

API What’s New?

addNodeAddedToModelCallback
A new API callback method, MModelMessage::addNodeAddedToModelCallback 
has been added, to listen for nodes added to the model. 

What’s Fixed?

Wrong error message if plug-in fails to load
On Mac OS X, a wrong error message may have been written out if a plug-in failed 
to load. This has been fixed. 

Maya Python API: 
MAnimMessage.addAnimCurveEditedCallback
Previously, adding a callback in the Maya Python API caused Maya to crash. 
Support has been added for MAnimMessage callbacks for Python. 

Documentation update for certain API example shaders
The documentation for certain API example shaders has been updated to better 
reflect current usage. 

Multidimensional arrays in the Maya Python API
An issue where a method in the Maya Python API was unable to get and set 
multidimensional array information from MScriptUtil has been fixed. 

Problems compiling plug-in using gcc
An issue where users received error messages due to extra semicolons when 
trying to compile plug-ins using gcc with the -pedantic flag has been fixed. 
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API > What’s Fixed?

MString in callbacks using Python
An issue where MString rather than a Python string was being used when creating 
callback arguments has been fixed. 

MArgList::asString problems
An issue where using MArList::asString caused Maya to crash has been fixed. 

FBX: problems with MGlobal::deleteNode() 
An issue where using MGlobal::deleteNode() crashing on input has been fixed.  

MObjectHandle

A crash in the API when using MObjectHandle has been fixed. 

Custom transform nodes
An issue where custom transform nodes created via the API reacted differently to 
rotate pivot changes than regular transform nodes would has been fixed. 

MDataBlock
A memory leak in MDataBlock::context() has been fixed. 

MGlobal
A memory leak in the MGlobal::executeCommand() methods has been fixed.  


	1 Autodesk Maya 8.5 Service Pack 1 release notes
	2 General release notes
	Basics
	What’s Fixed?
	Constraints being lost when file saved
	Importing scenes with objects that have the same name
	File names for image planes
	Non-deletable nodes deleted when using container nodes
	Extended ASCII characters in node and attribute names and scene portability


	Mac OS X
	What’s Fixed?
	Serious problem with Maya 8.5 uninstaller
	Save As defaults to .ma file format on Mac OS X
	User preferences not respected when Maya launches


	Linux
	What’s Fixed?
	Hotbox disappears when space bar is released on Linux version of Maya
	Middle mouse button paste on Linux
	Set Normal Angle option window too small on Linux


	File Referencing
	What’s Fixed?
	List Unknown Reference Edits
	Reference edits for connected attributes
	Shader nodes with the same name and file referencing
	Referenced-in file with animation clips problems
	Per-face shading assignment on referenced instance


	MEL and Python
	What’s Fixed?
	scriptEditorInfo -writeHistory
	Python libraries on Linux
	Python path

	Python limitations
	Missing Python modules from 64-bit systems


	Licensing
	What’s Fixed?
	Hardware locks (dongles) on 32-bit Linux operating systems



	3 Modeling release notes
	Polygonal Modeling
	What’s New?
	Edit Mesh > Add Divisions
	Edit Mesh > Add Divisions > r

	Edit Mesh > Collapse
	What’s Fixed?
	Add Divisions option window displays incorrect settings
	Collapse feature in Edit Mesh menu
	Insert Edge Loop Tool on Subdiv Proxy object exits Maya
	Polygon reverse normal settings are reversed in option window
	Split Polygon Tool may fail when mesh is rotated or scaled
	Split Polygon Tool reverts positions of edit vertices
	Insert and Offset Edge Loop tools with reversed normals
	Issues with undo and redo when using Move Tool with Reflection setting
	Extrude works incorrectly after Convert Selection operation
	Merge fails after Convert Selection operation



	4 Animation, Character Setup, and Deformers release notes
	Animation
	What’s Fixed?
	Scale curves appear in Graph Editor for unkeyed joints


	Character Setup
	What’s Fixed?
	Problem with curve influence object evaluation
	Problem with influence objects with Use Components enabled
	Remove Unused Influences may cause skinning problems
	Curve influence objects cause double transformations


	Deformers
	What’s Fixed?
	Problems with Delete Non-Deformer History



	5 Dynamics and Effects release notes
	nCloth
	What’s New
	nCloth attribute presets
	nCloth example files

	What’s Fixed?
	Constrained CVs flip and become trapped on wrong side of surface
	Simulation changes with Substeps
	Cross Links and Component Type ignored on file load
	Volume conservation problems with air intake
	Constraints do not use component Weights
	Maya runs out of memory with large nCloth objects
	Wind Speed scaling incorrect
	nCloth does not evaluate when particle evaluation is disabled
	Unpredictable cacheBlend behavior
	Transfer Cache To Input Mesh only works on one nCloth object at a time
	nCloth creation scripts do not return node names
	Fields ignore nCloth Mass value
	Undesirable collisions with low Friction passive objects
	Rigidity prevents small nCloth object rotation
	No nCloth examples or presets
	nCloth constraints with Bend crash Maya
	Shear Resistance doesn't work with Bend Resistance
	Collisions fail with animated passive objects
	Constraint instability occurs with large frame number
	Attract to Matching Mesh constraint Strength too low
	nCloth object as skin influencer fails

	Release Notes
	Unlimited license check in batch occurs when nCloth in scene is disabled
	Unlimited license check in batch occurs when nCloth in scene is cached
	Maya hangs after nCloth topology edit
	Deleting constrained passive objects crashes Maya (Windows 64 only)


	Fluid Effects
	What’s Fixed?
	Fluids cache licence error


	Hair
	What’s Fixed?
	Problem with creating Hair caches in batch mode



	6 Rendering and Render Setup release notes
	mental ray for Maya
	What’s New?
	Improved mental ray for Maya export performance

	What’s Fixed?
	Maya batch renders multiple copies of render layers
	Embed letters mi in directories or filenames when using the -file flag
	Auto Memory Limit and extra memory of 64-bit systems
	Camera background color and IBL node with primary visibility turned off
	Lightlinking is obeyed when baking vertex color with IBL
	Light linking with one mesh and multiple shaders
	Exporting mi files with non-iff files on Linux platform
	mental ray fur rendering with the Rasterizer and Full Motion Blur
	Batch rendering now respects MAYA_LICENSE environment variable
	mental ray now renders deformer animation for smooth proxies

	mental ray for Maya limitations
	Rendering fur in mental ray with directional light produces artifacts
	Incorrect bounding boxes reported for fur node
	Initial render in mental ray fails on Windows Vista
	Firewall software interfering with network rendering
	mental ray satellite for Maya 8.5 Service Pack 1


	Rendering
	What’s Fixed?
	Objects hidden by display layer settings appear in High Quality render
	Unloading file references causes lighting information to disappear
	Batch rendering with NURBS now working properly



	7 Developer Resources release notes
	API
	What’s New?
	addNodeAddedToModelCallback

	What’s Fixed?
	Wrong error message if plug-in fails to load
	Maya Python API: MAnimMessage.addAnimCurveEditedCallback
	Documentation update for certain API example shaders
	Multidimensional arrays in the Maya Python API
	Problems compiling plug-in using gcc
	MString in callbacks using Python
	MArgList::asString problems
	FBX: problems with MGlobal::deleteNode()
	MObjectHandle
	A crash in the API when using MObjectHandle has been fixed.
	Custom transform nodes
	MDataBlock
	MGlobal




