
Maya Muscle Advanced
Techniques

The Maya Muscle Advanced Techniques tutorials assume that you have a basic familiarity
with the main tools and features of Maya, as well as basic Maya rigging knowledge. At the
end of the tutorials, you should have a good feel for how to use the Maya Muscle skin deformer
for your own characters and projects.

This chapter includes the following tutorials:

■ Rigging simple muscles on page 205

■ Rigging muscles on page 241

Rigging simple muscles

Introduction

The Muscle Builder example is designed to offer a basic overview of Maya Muscle
features as applied to cMuscleSpline-based muscles.
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This example shows you the basic workflow and features of Maya Muscle
Builder in six lessons:

■ Lesson 1: Setting up Basic Skin Deformation on page 206

■ Lesson 2: Painting Sticky Weights to Bones on page 213

■ Lesson 3: Setting up Simple Muscles on page 219

■ Lesson 4: Painting Sticky Weights to Simple Muscle on page 226

■ Lesson 5: Setting up Sliding Deformation on page 231

■ Lesson 6: Setting up Jiggle Deformation on page 237

Preparing for the Lessons

To ensure the lessons work as described, confirm that you have Maya Muscle
loaded. The Muscle menu displays in the main menu bar if Muscle is loaded.
If you need to load Muscle manually, see Load Maya Muscle on page 2.

http://www.autodesk.com/maya-advancedtechniques

It is recommended that you save your work periodically and at the end of
each section as you progress through this tutorial, however sample files of the
finished scene for each lesson are also included.

Lesson 1: Setting up Basic Skin Deformation

This lesson shows you how to set up an object to be deformed by the Muscle
deformer with bones and joints. In this lesson you will prepare a rig for basic
skin deformation and set initial weighting on your mesh.

NOTE If you already have an object with a Maya skinCluster applied, you can
easily convert it to use Muscle following a workflow similar to this lesson. See
Convert Maya skin to Maya Muscle on page 62 to learn how to convert a
skinCluster to the Muscle setup.
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Open the scene for the lesson

1 Load the tut_dragonLeg_basic_START.ma file.

This scene contains a basic polygon mesh of a leg, some joints with a
simple IK chain rig with animation on it, and some background lights.
You can use the Display Layer Editor to show and hide various parts of
this rig.

2 In the Display Layer Editor, turn off the "lyrSkin" and “lyrLIGHTS” layers
to hide the skin and view the underlying rig.

3 Scrub the timeline to view the animation.

You can see the basic IK rig setup as the leg moves back and forth over
time. In addition to the basic Maya joints, there are two polygon bone
objects for the hip blade and kneecap.

Set up muscles

Currently, there is no stable root joint for this rig. Rather than creating a Maya
joint as the root, and since you will be using the Muscle deformer for skinning,
you can create a capsule object to use as the root.

Capsules are like joints, except that they have a true size and thickness and
can be used by the Muscle skin deformer as both joints for Sticky weighting
and actual sliding effects. They effectively work as bones, and are faster than
polygon mesh bones.

To create and set up a capsule object

1 Select Muscle > Muscles/Bones > Make Capsule to create a capsule object.

A capsule object appears at the origin. A group called “grpMUSCLES” that
holds all created capsules and muscles is also created to aid in keeping
your rig hierarchy clean.

NOTE Since capsules are locators, you must have Show Locators turned on
the scene view’s Show menu in order to see them.

2 Select Muscle > Simple Muscles > Set Muscle Parameters to open the
Muscle Builder window.

The top of the Muscle Parameters tab allows you to edit basic attributes
for capsules, bones and muscles.
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NOTE You can also use the Attribute Editor or Channel Box to control Muscle
deformers and settings for any capsule, bone, or muscle.

3 In the Muscle Object Settings, adjust the capsule’s Length to a value of
4. If you wish, you can adjust the other muscle object settings.

4 Close the Muscle Builder window when you are finished editing the
parameters.

5 Move and rotate the capsule to a position beside the boneBlade shape as
shown in the following image. This is a good location for your root object.

Since only objects that have a cMuscleObject shape node can be connected
to the Muscle skin deformer for skinning, you need to convert all of the
joints and polygon bones.

Convert the joints to bones

Rather than manually creating a capsule by hand for each joint, Maya Muscle
provides an automatic way to convert joints to capsules so that they can be
directly connected. Converted joints function as both a regular Maya joint
and a Muscle capsule object.

1 Select all of the joints in the dragon leg rig.

2 Select Muscle > Muscles/Bones > Convert Surface to Muscle/Bone on page
129.
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Since you are converting joints and not a surface, a Joint to Capsule
Conversion window appears. You need to know which axis is running
down the length of the joints in your rig. The default for Maya is X.
However, on this rig a custom Joint Orient tool was used to get a cleaner
joint rotation axis. It is highly recommended you use this sort of tool to
set up your Orient a joint’s local axes manually before rigging.

3 Click Y-Axis , since the y-axis runs down the length of the joints in this
scene.

Each joint is also converted to also be a capsule object. Using the tools
learned so far, you can adjust the colors and lengths of the capsules.

Since you did not originally select the polygon bone objects when you
converted, you must also convert these mesh objects so that they also
can be connected into the Muscle deformer for skinning.

4 Select the kneecap and blade bone objects, then select Muscle >
Muscles/Bones > Convert Surface to Muscle/Bone.

The polygon mesh objects are properly converted and connected to a
new cMuscleObject shape node.
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While there is no visible change, this shape now exists and can be seen
in the Channel Box. You can also use the Muscle Builder dialog box to
turn on display of the shape and adjust colors or other features as well.
Make sure you leave the Strength setting at 1.0.

Now that you have a series of joints and polygon mesh objects that have been
converted to work with the Muscle skin deformer, you can apply the skin
deformer and connect the muscle objects.

Apply the Muscle skin deformer

For the Muscle skin deformer, only select the mesh you are applying the skin
to. You connect the bones and muscles afterwards.

To apply the Muscle skin deformer

1 Turn on the “lyrSkin” layer in the Display Layer Editor and select the
dragon leg skin mesh.

2 Select Muscle > Skin Setup > Apply Muscle System Skin Deformer.

As the deformer is applied, a dialog box appears to pre-calculate required
information for the Relax deformer in case you use it later.

When the process is complete, the dragon leg mesh looks the same, but
it now has the Muscle skin deformer applied. You can view the
cMuscleSystem1 node in the Channel Box.

At this point, animating the mesh will have no deformation effect, because
you have not yet connected or weighted any bones or muscles to the skin
mesh. In the next steps, you will connect all the capsules and bones.
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Connect the muscle objects

1 Go to frame 0 in the Time Slider to make sure the bones/capsules are in
their default base pose.

2 Select the following in the Outliner:

■ All of the capsule objects created in the previous lesson, including the
root capsule object and all the joints that you converted to capsules.

■ The two polygon bone objects (boneKneeCapRt and boneBlade).

■ The skin mesh (pSkinMesh).

3 Select Muscle > Muscle Objects > Connect selected Muscle Objects.

After a moment, all the bones are connected into the Muscle deformer.
At this point, scrubbing the timeline still does not produce any motion
on the skin mesh because you have not yet applied the default skin
weights.

Apply default weights

Applying default weights to bones and polygon mesh objects is similar to
weighting with the Maya skinCluster. The points on the skin will move when
the capsule/bone moves.

To apply default weights

1 Select the skin mesh (pSkinMesh).

TIP If the Muscle Paint tool is open, you can see the weights when the
operation is complete.
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2 Select Muscle > Weighting > Apply Default Weights.

The Default Weights tool appears. There are several options available,
depending on the selected Weight type. See Default Weights tool on page
161 for a detailed description.

3 Select Sticky from the Weight drop-down menu.

4 Set the Smooth value to 3. The Smooth value sets how many iterations
the smooth operation applies.

5 Click Apply Default Weights.

Now that you have applied default Sticky weights, scrubbing the timeline
shows the effect. The skin mesh moves when the bone capsules move.

This concludes the first lesson of the Simple Muscles tutorial. A completed
file for this lesson, tut_dragonLeg_basic_END.ma, can be found in the sample
files directory.

Beyond the Lesson

In this lesson you learned how to:

■ Create a capsule object

■ Convert joints to bone capsules

■ Apply the Muscle deformer to a skin mesh

■ Connect bone and capsule objects to a skin mesh

■ Apply default weights to a rig

Now you are ready to refine the default weighting on your dragon leg mesh
by painting weights with the Muscle Paint tool.
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Lesson 2: Painting Sticky Weights to Bones

In the next steps you will paint some weights on the mesh. The Muscle Paint
tool lets you paint capsule, bone, muscle, and other types of weights, as well
as set weights on points, much like a component editor.

Open the scene for the lesson

1 Load the previous scene you worked on or load the
tut_dragonLeg_paintBones_START.ma file.

This scene contains the dragon leg with connected bones and capsule
objects. The dragon leg mesh is set up with default Sticky weights applied
to the capsules for basic skin deformation.

You can use the Display Layer Editor to show and hide various parts of
this rig.

Paint weights

After you apply default weights to the bones and polygon mesh objects, you
can use the Muscle Paint tool to refine those weights. You can choose to raise
or lower the effect of the default weights by further painting weights on the
skin mesh.

1 Make sure the scene view shading is set to Smooth Shade All.

2 Select the skin mesh object (pSkinMesh) then select Muscle > Paint Muscle
Weights.

The Muscle Paint tool appears and the mesh displays in Paint mode, in
a black color.

The Muscle Paint tool provides many of the same basic features as the
artisan paint tools. See Muscle Paint tool on page 156 to learn more about
its specific attributes.

3 Select Sticky from the Weights drop-down menu.

4 Select "jntShoulder" in the Influence list and turn Replace on.
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5 In the “jntShoulder” or hip area of the dragon leg, paint weights to the
shoulder (hip) bone.

TIP You can press and hold down the "b" key while dragging in the scene
view to adjust the size of the brush.
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6 When you are finished painting weights, close the Muscle Paint tool and
scrub the timeline. The points on the skin move when the capsules and
bones move.

In the next steps, you set weights on specific points, rather than paint
them on the entire upper leg.

Set weights to specific points

1 Open the Muscle Paint tool and select the "jntLegUp" object in the
Influence list.

2 Turn off Paint mode in the Muscle Paint tool.

The painting features are now disabled in the Muscle Paint tool, and the
points of the skin mesh appear.

3 Select the specific points on the upper leg where you want to set weights.
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TIP Use the Lasso Tool for more precision when selecting points.

Notice that the Live Update option is on. This means as you drag the
Weight slider the weights update interactively. When Live Update is off,
you can set the weight value, but the weight does not change until you
click Set Weight/Flood.

When you have multiple points selected and Live Update is on, the
Weight slider automatically adjusts to show the average weight to the
current object for the selected points. For example if you select some
points where the mesh is black and where the mesh is red, the Weight
slider shows the average value of those points.

4 Use the Weight slider to drag the value to 0.5. Notice that the color turns
yellow to show this area has half the weight.

5 Continue dragging the slider up to 1.0. The selected points on the dragon
leg mesh are now weighted 100% to the upper leg bone.

Smooth weights

In the next steps, you will smooth the transition between the shoulder (hip)
and upper leg joint. To make sure weights don’t get re-normalized to other
bones, you can lock weights for them all.

1 Clear your selection, then turn Paint mode on in the Muscle Paint tool.
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NOTE It's important that you have no points selected when you turn Paint
mode back on. If you turn Paint mode on with some points selected, only
those points are paintable. When you turn Paint mode on with nothing
selected, the entire mesh becomes paintable again.

2 In the Influence list, select everything except for the jntShoulder and
jntLegUp bones, then right-click and select Enable Lock/Hold Weight on
highlighted items from the menu.

A HOLD marker appears next to each joint, meaning the current weights
for those items are locked and cannot be adjusted, even if you paint
around that item. You can now safely smooth weights between the
shoulder and upper leg only, since those are the only two joints currently
unlocked.

3 Select jntLegUp in the Influence list, and turn on Smooth.

4 Paint along the top edge of the upper leg a few times.

5 Scrub the timeline to see the smoother deformation between the shoulder
and upper leg.

6 Select all the items in the Influence list, right-click and select Disable
Lock/Hold Weight on highlighted items to continue painting on other
bones.
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7 Continue to paint and smooth weights to the joints/capsules for basic
rigid bone type skinning with the techniques you have learned in this
lesson. Leave the weights on the polygon knee cap and blade at zero, as
you can use those objects for Sliding effects in a later lesson.

When you are finished, you should have a basic skin setup with bones. You
can load the tut_dragonLeg_paintBones_END.ma file to see an example of
basic Sticky weights painted for bones.

Beyond the Lesson

In this lesson you learned how to:

■ Paint sticky weights to bones using the Muscle Paint tool

■ Apply weights to specific points on a mesh

■ Apply Smooth weights for better transition between weights

Painting Sticky weights to bones or capsules gives an effect similar to Maya
skinClusters. The main benefits of the Muscle skin deformer for this type of
work is both the color feedback, as well as the ability to use other features of
the deformer such as Sliding, Jiggle and so on as discussed in the following
lessons.

In general, it is recommended that you first paint weights to only the capsules
and bones on your mesh before working with muscles and Sticky weights.
This can help keep your weighting structured and organized.
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Lesson 3: Setting up Simple Muscles

In the previous lessons, you set up the Muscle deformer with only capsules
and bones. This gives you a good foundation to build your additional skinning
from. In this lesson you learn how to create muscles and set up muscle
deformation on your mesh.

Open the scene for the lesson

1 Load the previous file you worked on, or load the
tut_dragonLeg_muscles_START.ma.

This file has the dragon leg with all the muscles and bones connected
with default and basic Sticky weights applied to the capsules.

Create a simple muscle

While you can convert and rig any existing NURBS surface to be a muscle,
Maya Muscle provides a tool to easily build and set up muscles interactively.
In the next steps you use the Muscle Builder to create simple muscles.

To start, you build a muscle that stretches from the shoulder to the lower leg.

1 From the main menu, select Muscle > Simple Muscles > Muscle Builder.

The Muscle Builder appears.
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2 Using the Outliner, do the following to load the muscle Attach Objects:

■ Select the "jntShoulder" capsule and click  for Attach Obj 1.

■ Select the "jntLegLo" capsule and click  for Attach Obj 2.

These  buttons load the selected objects into the Attach Object
fields for you.

3 Click Build/Update.

A muscle shape is generated from the start Attach Object (Attach Obj 1)
to the end Attach Object (Attach Obj 2). You may want to change your
scene view to wireframe or X-ray mode while you work.

TIP You can click the Attach Obj 1 or Attach Obj 2 buttons to directly select
the attach locators and position them in the scene view.

For this tutorial, you can leave the parameters in the Build tab at their
default settings. If you wish, you can adjust the simple muscle settings.
See Build tab on page 146 to learn about the attributes of the Muscle Builder
Build tab.

NOTE If you scrub the timeline, the muscle stays attached but will not yet
squash or stretch properly because you have not yet set up deformation.

Once your muscle is generally placed and set, you can sculpt the muscle
shape into something more specific.

Sculpt the simple muscle shape

1 In the Muscle Builder, switch to the Cross Section tab.

This tab has three main sections. The list on the left shows you each cross
section of your muscle. Typically the first and last cross sections are
adjusted. There are two view panels showing you the view of all of your
muscle cross sections down the length and from the side.
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2 Select Curve 3 and Curve 5. Note that you can move them on the X- and
Z-axis in the view panel.

Selecting one or more items in the Cross Section curve list selects those
curves. You can then move them in the view panels here, or in the scene
view.

3 Click Edit Cross Section at the top of the tab.

The cross sections are now active for editing and the view panels
automatically switch to component mode so you can directly edit the
points of the cross section curves. Selecting other cross sections highlight
their points.

4 Continue editing the cross sections until you are happy with the shape
of the muscle.
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TIP You can pan in the view panels of the Muscle Builder. To easily re-center
the view panels, click the Cross Section tab again.

5 When you are finished, click Edit Cross Section again to turn off the
editing mode.

You are now finished sculpting your muscle. In the next steps you finish
the building process and rig the muscle to deform properly.

Finalize the simple muscle

1 In the Muscle Builder tool, switch to the Finalize tab.

This tab lets you choose how to deform and rig your muscle. For further
information about the attributes of the Finalize tab, see Finalize tab on
page 147.

2 Ensure the Muscle Spline Deformer is selected, and Num Controls is set
to.

NOTE This gives you three movers: one at the start, one at the middle, and
one at the end of the muscle.
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3 Click Convert to Muscle.

A warning dialog appears to notify you that this operation will finalize
the cross sections of this muscle. The dialog also lets you select the base
name of the muscle and created controls.

We recommend that you stick to a useful and readable naming scheme
so that you can easily select and weight the muscles in the Muscle Paint
tool later. For example, if you created a muscle located near the upper
leg, on the rear side in the center, you could name it "hamstringsCenter".

4 Enter a name and click OK.

After a moment, the muscle is rigged and a cMuscleObject shape node
is created. In wireframe mode, you can see three yellow box controls.
These controls can be animated and have Jiggle settings on them that
are created and constrained to the proper capsules.

5 Click the Muscle Parameters tab and scroll down.

This section lets you customize the deformers on the selected muscles.
You can also directly manipulate some of the controls in the Attribute
Editor or Channel Box.

To see the deformer attributes in the Channel Box, select the muscle
surface. Also, note that some settings for the cMuscleSplineDeformer
exist on the cMuscleSpline node and not on the deformer node.
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6 Scrub the timeline frame by frame to see the muscle squash and stretch.
When that is done once, you can jump to any frame, and adjust Muscle
Parameters at any point or time and the playback is still correct.

Adjust the squash and stretch

Before you set the muscle’s squash and stretch, it's a good idea to set the
minimum and maximum length of the muscle. By default, the muscle’s
minimum squash is set to half its original length, and its maximum stretch
is set to double its original length. When the muscle length changes to these
settings, you get the maximum amount of volume change.

To adjust the squash and stretch length settings

1 Make sure the scene view shading is set to Smooth Shade All and the
“lyrSkin” is turned off.

2 Leaving the Muscle Parameters tab of the Muscle Builder open, do the
following to define the Squash pose:

■ Select the "FootIKMover" control and raise the leg to a squashed
position.

■ Select the muscle surface.

■ In the Spline Length Settings section, click Set Current as Squash.
This sets the muscle’s minimum squash value to the current length.

3 Do the following to define the Stretch pose:

■ Select the "FootIKMover" and move it down so the leg is fully
extended.

■ Select the muscle surface.

■ In the Spline Length Settings section, click Set Current as Stretch.

Setting the minimum and maximum stretch length values cause the
squash/stretch settings to more directly affect the visual output, since
they are more closely related to the actual lengths the muscle is changing
by. This can also help stop stretching from losing volume too much. In
addition, this makes the Dampen On Squash and Dampen On Stretch
values work properly.

4 Adjust the Stretch Volume Presets as required.

Make sure you have the muscle surface selected so that changes you make
in the Muscle Builder affect the muscle. The stretch settings let you set
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the basic X- and Z-axis radial volume change for the start, middle and
end of the muscle.

If you are getting flipping when the muscle contracts, changing the
Up-Axis can fix this. When the muscle is bent, the aim values set how
the tips orient themselves.

TIP You can play the animation and adjust the settings while the animation
plays. Clicking a Stretch Volume preset automatically sets the values to one
of several preset values.

View the Jiggle parameters

For Jiggle on simple muscles, you have overall control from the start to the
middle to the end of the muscle. If you rig a muscle and create more than
three movers, you can also directly set specific Jiggle values on the yellow
movers. You can experiment to see the effect of the Jiggle Presets on page 151
located on the Muscle Parameters tab of the Muscle Builder window.

To view the Jiggle parameters

1 Play the animation.

2 As the animation plays, click each of the Jiggle Presets buttons to see the
effect.

Beyond the Lesson

In this lesson you learned how to:

■ Create a simple muscle using the Muscle Builder

■ Sculpt and finalize a simple muscle

■ Adjust muscle parameters
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Because you have rigged the muscle with the cMuscleSplineDeformer, you
can also do custom muscle shaping to get exact control over how the muscle
looks at various lengths. For further information on this and other information
on muscles and their parameters, see:

■ cMuscleSplineDeformer node on page 190

■ Set up a Muscle Spline deformer on page 35

As you build more muscles, note that in some cases, you may want muscles
and bones to penetrate. For example when using Shrink Wrap on page 197, it's
better to have a solid mass of muscles even if they penetrate than to have gaps
or spaces between them.

You can now go back to the Build tab, select new settings, and continue
building more muscles for your rig using the techniques you have learned. A
completed muscle rig for this lesson called tut_dragonLeg_muscles_END.ma.

Lesson 4: Painting Sticky Weights to Simple Muscle

In the previous lessons, you created muscles and bones and set skin weights
for the bone capsules. In this lesson, you add weights for simple muscles. This
is the same process as weighting for bones, except with muscle weights, the
mesh deforms not only when the muscle moves as a whole, but also when its
surface moves or jiggles. Since the skin mesh is effectively attached to the
muscle surface with Sticky weights, when the muscle jiggles or bulges, so does
the skin that is weighted to it. This step alone can give a high level of
additional realism and interest to your rigs.
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Just as you connected the bones in an earlier lesson, you first need to connect
the muscles to the Muscle skin deformer. Since they were created with the
Muscle Builder, they are already rigged with the cMuscleObject shape node
and can be immediately connected.

Load the tutorial file

1 Start with your file from the previous lesson, or load the
tut_dragonLeg_sticky_START.ma.

This file has the skin mesh weighted to the bone capsules, and the muscles
are set up and attached to the bones.

Visualize the Sticky Bind distance

Unlike weighting to bones, when weighting to muscles the skin mesh points
are bound to the surface of the muscle. Setting this operation up takes some
time, so when the muscles are first connected a "Sticky Bind" operation is
calculated from the skin to the muscle. In order to speed up this calculation,
only points within a certain distance from the center of the muscle are
calculated. For example, a muscle for a character’s left arm will typically does
need to be weighted to points on the characters right leg. Thus, only points
close enough to the muscle are calculated.

To control this, once you attempt to connect a simple muscle, a dialog box
appears asking you what distance to use. Typically, using the Auto-Calculate
value is sufficient, but there may be cases where you want to preview the effect
of this value. As an example, we can take a muscle and visualize the Sticky
Bind distance for it.

Any points within the Sticky Bind distance are calculated, and can be weighted
to the muscle properly. Any points outside this distance are ignored. Note
that this process is simply setting whether the point is allowed to be weighted,
it does not actually do any weighting. Any points outside the distance can
have weights set, but usually deform incorrectly. If you set the distance too
low, you can always go back and re-bind Sticky (even to the entire mesh) later.

1 Select a simple muscle in the rig. For example, select the simple muscle
located on the upper thigh.
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2 From the main menu, select Muscle > Muscle Objects > Visualize Sticky
Bind Distance for selected Muscle Objects.

A yellow visualization sphere appears around the selected muscle.

You can look at the sphere's radius to determine its distance and adjust
the radius to see how a larger or smaller value would work. The sphere
itself is just a temporary object and has no relevance to the muscle, other
than to visualize the distance.

3 Delete the sphere when you are finished.

Now you can connect the muscle surfaces to the skin.
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Connect muscle objects

1 Go to frame 0, and do the following:

■ Ensure the bones and muscles are in their default base pose.

■ Select all of the NURBS muscles and the skin mesh.

2 Select Muscle > Muscle Objects > Connect selected Muscle Objects.

Since you have one or more simple muscles selected, a dialog box appears
asking how you want to handle the Sticky Bind distance. For information
about the dialog box options see Sticky Bind Maximum Distance dialog
box on page 155.

3 For the purposes of this lesson, click Auto-Calculate.

Each muscle is connected to the Muscle skin deformer and set up to allow
for Sticky weights. When this process is complete, the muscle weights
can be painted the same as bone capsule weights.

Paint muscle weights

1 Select the skin mesh.
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2 From the main menu, select Muscle > Paint Muscle Weights.

The Muscle Paint tool displays. Just like when you painted the capsule
weights, you can use this tool to paint or set Sticky weights for the
muscles.

3 In the Weights drop-down menu, select Sticky.

4 Select a muscle in the Influence list.

5 A good way to paint muscle weight is to slowly add up weight from the
bones onto the muscle. To do this:

■ Set the Weight value to a small value, such as 0.1, and select Add as
the paint mode.

■ Paint weights for the muscle on the skin.

■ Scrub the timeline to see how the animation looks with this
deformation.

TIP You can also right-click the Weight slider to select from preset weights
in increments of 1/10th.

6 Continue to add weight for each muscle until you get deformation effects
you like. Notice how the skin moves along with the muscle surface as
the Sticky weights are added to the muscle.

7 Practice painting Sticky weights for other muscles or open the
tut_dragonLeg_sticky_END.ma file for a rig completed with Sticky weights
painted for bones and muscles. This file also has an adjusted animation
to display muscle deformation.
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TIP Don't worry about interpenetration of the muscles since typically you do
not render the muscles, only the skin. In the next lesson, you add Sliding
weights for the muscles and bones, which helps the skin push out from the
muscle if they intersect.

Beyond the Lesson

In this lesson you learned how to:

■ Visualize the sticky bind distance

■ Connect muscle objects

■ Paint muscle weights

Lesson 5: Setting up Sliding Deformation

You now have a working muscle rig for the leg mesh. The Muscle skin deformer
provides even more quality in the rigging with Sliding weights. This deformer
lets you use true muscle and bone sliding under the skin. Combined with the
Relax weights you can create in a later lesson, you can achieve very effective
skin pulling and sliding effects.

Load the tutorial file

1 Start with the last file you had from the previous section, or load the
tut_dragonLeg_sliding_START.ma.

This file has the leg properly skinned and weighted with bones and
muscles using Sticky Weights.

Enable Sliding deformation

1 Select the skin mesh, and in the Channel Box under INPUTS click the
cMuscleSystem1 node to display its attributes.
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Each main section of the deformer is broken down by label headings. For
now, use the ones listed under the SLIDING section. The Sliding deformer
can be turned on and off for faster interaction and playback.

2 Turn Enable Sliding on and leave quality as “Full”.

Later you can adjust the quality attribute as needed. See Sliding attributes
on page 196 for further information about the quality attribute.

Paint Sliding weights

Start by painting weights for the hip blade bone.

1 Select the skin mesh and select from the Muscle > Paint Muscle Weights
to bring up the Muscle Paint tool.

2 In the Weights drop-down menu, select Sliding.

232 | Chapter 10   Maya Muscle Advanced Techniques



3 Set the Weight slider to 1.0 and turn Replace on.

4 In the Influence list, select "boneBlade".

5 Paint around the area where the blade bone might push out.

TIP It's important to paint only the area around the bone for speed purposes,
and also so points on other parts of the mesh don't try to jump and be pushed
by the blade.

As you paint, you can see the Sliding deformation start to happen. Note
that the slide is not accurate because there is not enough detail in the
mesh relative to the bone. This is a good example where you may want
more skin detail for areas where smaller or thinner bones or muscles cause
the sliding.

Set a Fat offset

For areas where a muscle or bone often penetrates the skin during sliding, you
can set a Fat value to create an offset between the muscle or bone and the
skin.

The Fat attribute on the cMuscleObject shape node for each muscle or bone
object lets you adjust the offset from the skin to the muscle or bone during
sliding.

A good example is the MusHipBack muscle, since the skin often penetrates
the muscle on the back. The image below shows that muscle painted with
Sliding weights, and a fat offset on the muscle set to 0.55.
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To define an offset from the skin mesh to the bone blade

1 Select the bone blade object.

2 In the Attribute Editor, select the "cMuscleObject_boneBlade1" tab to
view the cMuscleObject shape node attributes for the bone blade.

3 Set the Fat value to 1.0.

The skin is now offset from the bone blade.

Notice that right now the Sliding only affects a few points and is somewhat
sharp. The muscle is also causing some self-penetration due to Sliding. We
can use another Sliding feature, called Direction weights to improve how the
slide occurs.
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Create a Direction node

1 Make sure nothing is selected, close the Muscle Paint tool, then select
Muscle > Direction > Make Muscle Direction.

By default, a vector type direction node is created at the origin. It has an
arrow that points in the direction the Sliding will attempt to work once
it is connected to the Muscle skin deformer.

In this case, since nothing was selected, a new cMuscleDirection shape
node is created.

TIP Since you may often want to have radial direction nodes created based
on the center line of your mesh, and since capsules are typically used for
bones that run down the centerline, you can easily convert any capsule to
also function as a cMuscleDirection node. Simply select the capsule, then
select Muscle > Direction > Make Muscle Direction. The capsule will be
converted to be both a capsule and a radial muscle direction simultaneously.
You can then connect the capsule to the deformer as a capsule muscle object
and/or a muscle direction and use it both ways.

2 In the Channel Box or Attribute Editor, set the cMuscleDirection node’s
Type attribute to radial.

This creates a radial-type push out along an axis. The Length and Falloff
Outer attributes control how far this axis goes.

Next, you connect the direction object to the Muscle deformer.

Connect the Direction node

1 Select the direction object and the skin mesh.

2 From the main menu, select Muscle > Direction > Connect selected Muscle
Directions.

The Direction object is connected, although there is no visible change
on the mesh because you have not yet painted Direction weights.
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3 Move the Direction object to align it with the rear hip muscle.

4 Parent it to the first hip muscle cube mover.

5 Set the Length attribute to 3.0.

Leave the Falloff Outer attribute set to 1.0, as it only changes the length
at the tips. The actual effect of the direction node comes only from
weighting. The Inner/Outer Falloff values are primarily for visual feedback
only.

Paint Direction weights

1 Select the skin mesh, then select Muscle > Paint Muscle Weights.

2 In the Muscle Paint tool, select Direction in the Weights drop-down
menu.

This lets you set and paint Direction weights for any connected direction
nodes.

3 Paint Direction weights in the same area where you painted Sliding from
the hip muscle.
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The Sliding direction is now corrected so that it is pushed out radially
from the center line of the muscle direction node. This corrects the
penetration problem.

4 Scrub the timeline to see the animation.

5 In the Channel Box under INPUTS, click the cMuscleSystem1 node.

6 Toggle the Enable Sliding option on and off to compare how the mesh
looks with Sliding enabled and disabled.

7 Continue to paint Sliding weights and create vector or radial direction
nodes as needed or open the tut_dragonLeg_sliding_END.ma.

Beyond the Lesson

In this lesson you learned how to:

■ Set up sliding deformation

■ Paint sliding weights

■ Set a fat offset

■ Adjust how the slide occurs by setting up a directional node

Lesson 6: Setting up Jiggle Deformation
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So far you have a working leg with flexing muscles. To provide even more
control, Maya Muscle lets you paint Jiggle weights per-point on your mesh.

The Jiggle deformation feature can be used even if you are not doing muscle
skinning. For example, you can simply paint and add weights for jiggling on
any moving object to get jiggle effects, even if the object is skinned with a
Maya skinCluster, or if it is not skinned at all.

Load the tutorial file

1 Load your file from the previous lesson, or load the
tut_dragonLeg_jiggle_START.ma.

This rig has a complete right leg of bones and muscles with Sticky and
Sliding weights applied.

Enable Jiggle deformation

Like other features, the Jiggle deformer can be turned on and off independently.
When Jiggle occurs, Jiggle collisions can also be enabled to help make sure
points do not move into bones and muscles that are sliding. Note that there
is no self-collision, this is simply sliding collision if the Sliding deformer also
enabled.

1 Select the skin mesh.

2 In the Attribute Editor, select the cMuscleSystem1 tab.

3 Turn on Enable Jiggle.

Paint Jiggle weights

1 Select the skin mesh.

2 Select Muscle > Paint Muscle Weights.

The Muscle Paint tool opens.

3 In the Muscle Paint tool, select Jiggle from the Weights drop-down menu.

4 Paint Jiggle weights in the middle center of the leg, as shown. (You may
paint weights on other areas of the skin mesh where you want to have
per-point skin jiggle.)
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5 Experiment with painting different areas of the mesh, and playblast your
animation to see the results. Typically, jiggle-related weights benefit from
a smoother falloff on the painting. Close the Muscle Paint tool when
finished.

NOTE You can review the other Jiggle attributes on the cMuscleSystem node
in the Channel Box or Attribute Editor. See Jiggle attributes on page 200 for
further detail about each attribute.

The basic leg rigging is now complete. A final file with Jiggle weights painted
can be found by loading the tut_dragonLeg_jiggle_END.ma.

Since the Jiggle calculations for per-point skin jiggle can use significant
machine resources, you can use Muscle’s per-point cache feature to provide
for faster animation playback or playback during operations like lighting or
rendering. In the next steps you cache each frame of animation internally on
the node in the Maya scene itself. This way you can cache playback, then
playback within Maya for faster speed and interaction.

Create a cache

1 Select the skin mesh object.

2 From the main menu, select Muscle > Caching > Create Cache.

The frame range is the current Time Slider range, and the cache data is
stored within the Maya scene. Leave the default options in the Generate
Cache dialog that appears.
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NOTE In this lesson you use node-based caching, however if you are planning
on using external file-based caching, you can set the path and base filename
using the Attribute Editor, or by selecting Muscle > Caching > Set Location
of Cache File from the main menu.

3 Make sure your skin mesh is still selected and click Generate Cache for
Selected Objects.

A progress dialog box appears as the timeline scrubs and the cache is
calculated.

Once the dragon leg animation is cached, you can easily have faster
playblasts, or change camera angles and playback to see how the
animation looks from different angles. Since the data is cached,
deformation is not really being calculated, making playback faster.

To playback the cached animation

1 Playback the animation.

Depending on the speed of your computer, the animation plays back in
near real-time. The cache attributes on the cMuscleSystem node (which
can be seen in the Channel Box or Attribute Editor) shows that the cache
is now set to read-node. This means it is now reading the point cache
rather than doing full calculations.

Attempting to change settings, such as turning Sliding deformation on
or off, or attempting to paint weights have no effect on the mesh, while
you are viewing the cached data.

To remove the cache

1 Select Muscle > Caching > Delete Node Cache and select which frames
to clear, or simply switch the cache attribute of the cMuscleSystem node
to disabled. This disables caching and returns to the normal calculation.

Beyond the Lesson

In this lesson you learned how to:

■ Set up jiggle deformation

■ Paint jiggle weights

■ Set up a per-point cache to facilitate faster playback and animation
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A completed file with node cache created can be found by loading the
tut_dragonLeg_cache_END.ma file.

Rigging muscles

Introduction

This Advanced Technique workflow is designed to offer a basic overview of
Maya Muscle features as applied to cMuscleSpline-based muscles. This example
shows you the basic workflow and features of the Maya Muscle Creator in
seven lessons:

■ Lesson 1: Create and set up a muscle object on page 242

■ Lesson 2: Set muscle pose states on page 244

■ Lesson 3: Editing Muscles on page 248

■ Lesson 4: Adjusting Muscle Length on page 252

■ Lesson 5: Sculpting Muscles on page 256

■ Lesson 6: Growing Muscles on page 260

■ Lesson 7: Mirroring Muscles on page 262

Preparing for the Lessons

To ensure the example works as described, confirm that you have Maya Muscle
loaded. The Muscle menu displays in the main menu bar if Muscle is loaded.
If you need to load Muscle manually, see Load Maya Muscle on page 2. It is
recommended that you save your work periodically and at the end of each
section as you progress through this tutorial, however sample files of the
finished scene for each example are also included.

http://www.autodesk.com/maya-advancedtechniques
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Lesson 1: Create and set up a muscle object

The quadruped rig is currently lacking a muscle structure. You will use the
Muscle Creator to add some of these missing muscles. The Muscle Creator lets
you not only create and mirror muscles, but also provide controls to sculpt
and shape them so they move in a realistic fashion. The following steps take
you through a workflow example of setting an initial muscle using the Muscle
Creator.

Open the scene for the example

1 Load the Sabertooth_Create_Muscle_Start.mb.

This scene contains a quadruped rig with capsulated joints. You can use the
DisplayLayer Editor to show and hide the skin of the model. Scrub the timeline
to view the existing walk cycle animation.

Create muscles

1 From the main menu, select Muscle > Muscles/Bones > Muscle Creator.

The Muscle Creator appears. The top half of the Create tab contains
controls that let you set the name of your muscle structure, the number
of controls/cross sections, the number of segments around your muscle,
and the joints to which the muscle is attached.
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2 In the Muscle Creator window, do the following:

■ Name the muscle: Mus_L_FrontLeg.

NOTE Naming your muscles properly helps you better identify them
within the hierarchy, such as isolating the left-sided muscles from the
right-sided muscles.

■ Set the Num. Controls / Cross Sections to 4.

■ Set the Num. Segments Around to 8.

3 Keeping the Muscle Creator window open, open the Outliner (Window
> Outliner) to select the following muscle Attach Objects:

■ In the Attribute Editor select the bn_L_F_Humerus01 capsule and click

the Attach Start  button.

■ In the Attribute Editor, select the bn_L_F_TiborRaiiMinor01 capsule

and click the Attach End  button.

The  buttons load the selected objects into the Attach Start and
Attach End fields for you.

4 In the Muscle Creator window, click Create Muscle.
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The new muscle is now attached to the joints you specified in Attach
Start and Attach End fields. To see the muscle clearly, you may want to
change your scene view to wireframe. The muscle is primarily comprised
of a NURBS surface, two attach points of each end of the muscle, and a
series of cross section controls.

Beyond the lesson

In this lesson you learned how to create a muscle attached to capsulated joints.
A completed file for this lesson, Sabertooth_Create_Muscle_End.mb. Now you
are ready to refine and edit the muscles of the sabertooth tiger by setting the
pose states and adjusting the locators at each end of the muscle.

Lesson 2: Set muscle pose states

This lesson shows you how to first set up the muscle’s pose states, then how
to refine its length and overall shape in each respective state.

Load the scene

1 Load the Sabertooth_Set_Muscle_Pose_Start.mb file.

This scene contains the sabertooth tiger with capsulated bones and a
front leg muscle.
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Setting Pose States

Although it is best to set the pose states before you begin sculpting your
muscles, you can edit them at any point in your creation process.

To set the pose states

1 Scrub the timeline to view how the leg muscle deforms throughout the
animation.

Notice the exaggerated deformation of the front leg muscle due to some
jiggling behavior. By default, all muscles contain a certain amount of
jiggle. In this case, you will remove this jiggle to better visualize the
muscle’s different pose states.

2 Select the front leg muscle.

3 Switch to the Front camera in the scene view and select the four outer
wireframe boxes along the length of the muscle surface.

These are the cross section controls that store the jiggle settings.
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4 In the Channel Box set the Jiggle attribute to 0.

Without jiggling, the muscle now behaves more realistically, which makes
it easier to set the three main pose states.

5 From the main menu, select Muscle > Muscles/Bones > Muscle Creator.

6 In the Muscle Creator, switch to the Edit tab.

The Edit tab contains controls that let you shape and fine tune your
muscle surfaces in the different pose states.

7 Set the timeline to frame 3, which best represents the front leg muscle
rest state.

8 In the Poses section of the Muscle Creator, click the Rest button.

Although you might not see a visual difference, the muscle’s rest state
has been set.

246 | Chapter 10   Maya Muscle Advanced Techniques



9 Scrub the Time Slider to frame 15.

Click Stretch. As a result of this state being set, the muscle surface thins
out.

At this point, the humerus and leg joints are almost parallel, indicating
a good muscle stretch.

10 Scrub the Time Slider to frame 7 and click Squash.

The muscle surface’s volume expands a little to compensate for its new
set state.

This is the point where the humerus is almost perpendicular to the leg
joints, indicating a good muscle squash.
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Now that you have removed the jiggle from the muscle to better set its pose
states, you can put the jiggle back in. You can now clearly see the front leg
muscle bulge and stretch as you scrub though the animation.

Beyond the Lesson

In this lesson you learned about setting your muscle’s pose states. A completed
file for this lesson, Sabertooth_Set_Muscle_State_End.mb. Now you are ready
to adjust the muscle’s attach points locators, as well as edit its length and
shape.

Lesson 3: Editing Muscles

Each muscle you create using the Muscle Creator is constrained to two separate
attach locators on each end. These locators are parented to the joints you
specified when you first created the muscle. You can move these locators to
better represent your muscle mass and shape. Here, you adjust them so that
the muscle surface wraps around the front leg.

NOTE You can reparent the muscles to different joints of your rig by reparenting
the muscle attach locators.
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Load the scene

1 Load the Sabertooth_Edit_Muscle_Locators_Start.mb.

This scene contains the sabertooth tiger with capsulated bones and a
front leg muscle, which has been set in all three pose states.

2 Select the front leg muscle.

3 In the Muscle Creator, switch to the Edit tab.

The lower part of the Edit tab lists all the different cross section controls
and attach points available for the selected muscle.

4 Locate the Attach Locs section and CTRL+Select locMus_L_FrontLeg_End1
and locMus_L_FrontLeg_End2.

This selects both end locators of your leg muscle.

5 Lower the position of these locators on the Y axis using the Move tool
until they are near the tiger’s ankle. Then move them on the z-axis until
they are in front of humerus joint.

Notice that the muscle surface stretches to compensate for the new
locators’ positions.
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6 Select locMus_L_FrontLeg_Start1 and move it close to the base of the
humerus joint, by the side of the leg facing outwards.

7 Select locMus_L_FrontLeg_Start2 and move it next to
locMus_L_FrontLeg_Start1.
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Notice that each cross section control along the muscle surface
individually rotates to compensate for the new locators’ positions.

8 Scrub through the animation to see how the muscle behaves based on
its new shape.

Beyond the Lesson

In this lesson you learned how to better shape your muscle by adjusting its
attach locators. A completed file for this lesson,
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Sabertooth_Edit_Muscle_Locators_End.mb, can be found in the sample
directory. Now you are ready to adjust the length and shape of the muscle
surface.

Lesson 4:Adjusting Muscle Length

A muscle created using the Muscle Creator has three built-in cross section
curve sets that you can edit: one for the default rest position, one for the
squash state, and another for the stretch state. You can directly edit these
curves in the scene view, or using the Muscle Creator window. The following
example shows you how to adjust the muscle for each of its poses.

Load the scene

1 Load the Sabertooth_Adjust_Muscle_Length_Start.mb file.

This scene contains the sabertooth tiger with capsulated bones, a front
leg muscle, and a neck muscle that has been set in all three pose states.

2 Scrub the timeline frame by frame to see the neck muscle squash and
stretch.

Notice that the neck muscle travels down from the cervical joints to the
humerus joint in a straight line, which causes the muscle surface to either
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stick out too much from the tiger’s body, or go through the shoulder
joints. This not only looks bad, but also affects how the muscle works.
To fix this, we’ll change the muscle’s center line for each of its pose states
so it follows the contours of the tiger’s body.

3 Select Muscle > Muscles/Bones > Muscle Creator from the main menu.

The Muscle Creator window opens.

4 Go to frame 0 in the Time Slider, which is the rest state set for the neck
muscle.

Select the neck muscle surface if it isn’t already.

5 Click the Edit tab in the Muscle Creator.

6 In the Attach Rest section, select AttachMidMus_L_Neck11.

This selects the first inner wireframe box at the top of the neck muscle,
which represents the attach point for the nearby cross section.

7 Using the Move tool, begin reshaping the top part of the neck muscle so
it goes around the cervical joint instead of going through it.
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8 Repeat the process with the remaining attach points until you’re satisfied
with the results. The muscle shape should be organic and follow the
tiger’s body.

Do not worry about adjusting these attach points too perfectly, as you
can come back later to tweak them some more.

9 Go to frame 5 in the Time Slider, which is the squash state set for the
neck muscle.

10 Adjust the center line for this state by first selecting the attach point from
the Attach Squash section of the Edit tab, and then reposition them using
the Move tool.
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11 Go to frame 17 in the Time Slider, which is the stretch state set for the
neck muscle.

Here you will notice that the muscle needs correction.

12 Select the attach points from the Attach Stretch section of the Edit tab,
and then reposition them using the Move tool so that the muscle goes
around the shoulder before ending at the humerus.

13 Scrub through the animation to view the changes you have made.
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Beyond the Lesson

In this lesson you have learned how to adjust the muscle’s length by altering
its center line. A completed file for this lesson,
Sabertooth_Adjust_Muscle_Length_End.mb. Now you are ready to sculpt the
muscle surface.

Lesson 5: Sculpting Muscles

After a muscle is created, you can edit its cross section curves to sculpt the
muscle into its shape you want. The Muscle Creator’s sculpting controls let
you choose which pose state and axis to edit, and provide sliders to help you
better adjust the muscle surface.

NOTE  Make sure you select the desired pose state before editing your muscle. If
multiple states are selected at once, changes you make on the muscle surface are
reflected in all selected states.

Open the scene for the lesson

1 Load the Sabertooth_Sculpt_Muscle_Start.mb file.

This scene contains the sabertooth tiger with capsulated bones, a front
leg muscle, and a neck muscle which has been set in all three pose states.

2 Select Muscle > Muscles/Bones > Muscle Creator from the main menu
bar to open the Muscle Creator.
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3 Click the Edit tab.

4 Select the neck muscle or select cMuscleSurfaceShapeMus_L_Neck1 in the
Attribute Editor.

The neck muscle in the current rest state needs to be thinner on its Z
axis.

5 In the Sculpting section, make sure only the Z axis and Rest parameters
are selected.

6 Drag the Sculpt slider halfway to the left, or until the muscle loses its
tube-shape and looks more like a flat strip.
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TIP  You can drag the Sculpt slider in repetition to increment the deformation
impact on your muscle mass.

Deselect the Z axis and select the X axis in the Rest parameter

7 Drag the Location slider to the left until it is under the St parameter.
Then, drag the Falloff slider to the left to roughly the same position.

This isolates the cross section curve at the top of the neck muscle that is
slightly curved inwards.

8 Drag the Sculpt slider to the right until the inward curvature disappears.

9 Scrub the animation to frame 17, which represents the neck muscle’s
stretch state as it is being pulled to its limit.
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NOTE Before you sculpt your muscle in a desired state, make sure you scrub
the timeline to a frame that best represent your muscle in that state.
Otherwise, you may not see the results of your deformations on your muscle
surface.

10 Drag the Location slider to the middle.

11 Drag the Falloff slider to the right. This sets the sculpting range at its
maximum, which means the entire muscle length is affected.
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12 Select the Z axis and St parameters.

13 Drag the Sculpt slider to the left until the entire muscle is thinner.

14 Scrub the Time Slider again to view your sculpting changes.

Beyond the Lesson

In this lesson you learned how to sculpt a muscle in different pose states. A
completed file for this lesson, Sabertooth_Sculpt_Muscle_End.mb. Now you
are ready to shape your muscle using the grow controls.

Lesson 6: Growing Muscles

The Muscle Creator gives you the advantage of sculpting muscles by growing
them. You select a muscle and have points “grow” outward to the model
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surface. This saves time because you are not manually editing the muscle
surface.

Open the scene

1 Load Sabertooth_Grow_Muscle_Start.mb.

This scene contains the sabertooth tiger with muscle applied to the neck
and leg joints. You will be growing the hind leg muscle in each pose state.

Growing muscle

1 Select Muscle > Muscles/Bones > Muscle Creator from the main menu.

2 In the Muscle Creator window, switch to the Edit tab.

3 Select the Sabertooth_Cat skin mesh.

4 In the Grow section of the Muscle Creator, click the Grow To Surface

 button to load the sabertooth mesh.

5 In the Time Slider, go to frame 0.

6 Select the bn_L_B_fibula01 joint.

7 Click the  button next to Main Bone to load it the length of the
muscle.

The Main Bone Tip field automatically populates the section with the
proper joints.

8 In Grow section set the Angle to 120.

By default, the growing occurs outwards from the centerline defined by
the Main Bone and Main Bone Tip bones you select. All points within
the Angle range specified in the Grow settings are grown.

9 Set the Fat to 0.

10 Make sure the hind leg muscle surface is selected, then click Grow Muscle.
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Depending on the values you have set in the %Rest/Sq/St fields, the
muscle cross sections grow out in their respective pose state to the surface
you selected as the Grow To Surface. The higher you set the %Rest/Sq/St
values, the more expansion the muscle takes outwards to the selected
skin mesh, and eventually grows past it.

NOTE  Contrary to the Sculpt slider, the %Rest/Sq/St sliders provide absolute
values. This means that if you want to grow your muscle by 25% increments,
you need to set the sliders to specific values.

Beyond the Lesson

In this lesson you learned how to grow a muscle using the controls from the
Edit tab in the Muscle Creator. A completed file for this example,
Sabertooth_Grow_Muscle_End.mb, can be found.

Lesson 7: Mirroring Muscles

The Muscle Creator lets you mirror muscles in your scene using their naming
convention as reference. You can mirror a selected muscle at any point in
your creation process.
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Open the scene

1 Load the Sabertooth_Mirror_Muscle_Start.mb file.

This scene contains the sabertooth tiger with muscle applied to the neck
and leg joints. Here, you first mirror the muscle from the front leg, then
the neck, and finally the hind leg.

Mirror Muscle

1 Select Muscle > Muscles/Bones > Muscle Creatorfrom the main menu.

2 Click the Create tab.
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3 In the Mirror section, select X as the Mirror Axis.

4 Enter _L in the Search field, and _R in the Replace field.

The muscle for each “side” of the mesh needs to be parented to joints
that follow a Left or Right naming convention.

TIP  You can also right-click the Search field and select from the available
naming conventions. This automatically fills in the Replace field.

5 Select the front leg muscle surface.

6 Click Mirror Muscle from Selection.

A new muscle is created on the right front leg based on the selected
muscle.
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7 (Optional) To mirror an additional muscle, select a muscle, then click
Mirror Muscle from Selection again.
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Beyond the lesson

In this lesson you learned how to mirror muscles from one side of the mesh
to the other. A completed file for this lesson,
Sabertooth_Mirror_Muscle_End.mb, can be found.
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