
Maya Muscle Advanced
Techniques

The Maya Muscle Advanced Techniques tutorials assume that you have a basic familiarity
with the main tools and features of Maya, as well as basic Maya rigging knowledge. At the
end of the tutorials, you should have a good feel for how to use the Maya Muscle skin deformer
for your own characters and projects.

This chapter includes the following tutorials:

■ Rigging simple muscles on page 197

■ Rigging muscles on page 232

Rigging simple muscles

Introduction
This tutorial is designed to illustrate the basic workflow of creating simple
muscles with the Maya Muscle Builder. The tutorial includes six lessons:

■ Lesson 1: Setting up basic skin deformation on page 198

■ Lesson 2: Painting Sticky weights to bones on page 205

■ Lesson 3: Setting up simple muscles on page 210

■ Lesson 4: Painting Sticky weights to simple muscle on page 218

■ Lesson 5: Setting up Sliding deformation on page 223

■ Lesson 6: Setting up Jiggle deformation on page 229
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Preparing for the lessons
To ensure the lessons work as described, confirm that you have Maya Muscle
loaded. The Muscle menu displays in the main menu bar if Muscle is loaded.
If you need to load Muscle manually, see Load Maya Muscle on page 2 in
the Maya Muscle guide.

If you have not already done so, download the Maya Muscle Advanced
Techniques Lesson Data from the following location:
www.autodesk.com/maya-advancedtechniques.

It is recommended that you save your work periodically and at the end of
each section as you progress through this tutorial, however sample files of the
finished scene for each lesson are also included.

Lesson 1: Setting up basic skin deformation
This lesson shows you how to set up an object to be deformed by the Muscle
deformer with bones and joints. You will prepare a rig for basic skin
deformation and set initial weighting on your mesh.

NOTE If you already have an object with a Maya skinCluster applied, you can
easily convert it to use Muscle following a workflow similar to this lesson. See
Convert Maya skin to Maya Muscle on page 63 in the Maya Muscle guide to learn
how to convert a skinCluster to the Muscle setup.

Open the scene for the lesson

1 Load the DragonLeg_Basic_Start.mb file.

This scene contains a basic polygon mesh of a leg, some joints with a
simple, animated IK rig, and some background lights.
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2 In the Display Layer Editor, turn off the lyrSkin and lyrLIGHTS layers to
hide the skin and view the underlying rig.

TIP Use the (Windows) Alt+b or (Mac OS X) Option+b hotkey to toggle the
background color in the scene view.

3 Scrub the timeline to view the animation.

You can see the basic IK rig setup as the leg moves back and forth over
time. In addition to the basic Maya joints, there are two polygon bone
objects for the hip blade and kneecap.

Set up muscles

Currently, there is no stable root joint for this rig. Rather than creating a Maya
joint as the root, and since you will be using the Muscle deformer for skinning,
you can create a capsule object to use as the root.

Capsules are like joints, except that they have a true size and thickness and
can be used by the Muscle skin deformer as both joints for Sticky weighting
and actual sliding effects. They effectively work as bones, and are faster than
polygon mesh bones.

To create and set up a capsule object

1 Select Muscle > Muscles/Bones > Make Capsule to create a capsule object.
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A capsule object appears at the origin. In the Outliner, you can see a
group called grpMUSCLES is added. This group holds all capsules and
muscles and is designed to keep your rig hierarchy clean.

NOTE Since capsules are locators, you must have Show Locators turned on
the scene view’s Show menu in order to see them.

2 Select Muscle > Simple Muscles > Set Muscle Parameters to open the
Muscle Builder window.

The top of the Muscle Parameters tab lets you edit basic attributes for
capsules, bones, and muscles. You can also use the Attribute Editor or
Channel Box to control these.

3 In the Muscle Object Settings, set the capsule Length to a value of 4, then
close the Muscle Builder window.

TIP You can also adjust the capsule color in the Muscle Object Settings.

4 Move and rotate the capsule to a position beside the boneBlade object
as shown. This is a good location for your root object.

Since only objects that have a cMuscleObject shape node can be connected
to the Muscle skin deformer for skinning, you need to convert all of the
joints and polygon bones to have this node.
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Convert the joints to bones

Rather than manually creating a capsule by hand for each joint, Maya Muscle
provides an automatic way to convert joints to capsules so that they can be
directly connected to the Muscle deformer. Converted joints function as both
a regular Maya joint and a Muscle capsule object.

1 Select all of the joints in the dragon leg rig.

TIP Use the filter field at the top of the Outliner window as a quick way to
isolate all of the leg joints. Enter jnt* to display only the leg joint objects,
which use that naming convention.

2 Select Muscle > Muscles/Bones > Convert Surface to Muscle/Bone.

Since you are converting joints and not a surface, the Joint to Capsule
Conversion window appears.

This window lets you set which axis runs down the length of the joints
in your rig. The default for Maya is X, but for this rig a custom Joint
Orient tool was used to get a clean joint rotation on the Y-axis. It is highly
recommended you use this sort of tool to set up your joints before rigging.

3 Click Y-Axis in the Joint to Capsule Conversion window.

Each joint is converted to be a capsule object and have the shape node.
You can adjust the color and length of capsules in the Muscle Parameters.

Lesson 1: Setting up basic skin deformation | 201



Next you will convert the rig’s polygon bone objects so they can be
connected into the Muscle deformer for skinning.

4 Select the kneecap and blade bone objects, then select Muscle >
Muscles/Bones > Convert Surface to Muscle/Bone.

The polygon mesh objects are converted and connected to a new
cMuscleObject shape node.

While there is no visible change in the scene, you can see the new shape
node in the Channel Box. You can also use the Muscle Builder window
to turn on display of the shape and adjust colors or other settings. Make
sure you leave the Strength setting at 1.0.

Now that you have a series of joints and polygon mesh objects converted to
work with the Muscle skin deformer, you can apply the skin deformer and
connect the muscle objects.
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Apply the Muscle skin deformer

In these steps, you select only the mesh where you want to apply the deformer.
You connect the bones and muscles afterwards.

To apply the Muscle skin deformer

1 Turn on the lyrSkin layer in the Display Layer Editor and select the dragon
leg skin mesh in the scene view.

2 Select Muscle > Skin Setup > Apply Muscle System Skin Deformer.

As the deformer is applied, a window appears to pre-calculate required
information for the Relax deformer in case you use it later.

When the process is complete, the dragon leg mesh looks the same, but
it now has the Muscle skin deformer applied. You can view the
cMuscleSystem node attributes in the Channel Box or Attribute Editor.

At this point, animating the mesh will have no deformation effect, because
you have not yet connected or weighted any bones or muscles to the skin
mesh. In the next steps, you connect all the capsules and bones.

Connect the muscle objects

1 Go to frame 0 and notice how the bones/capsules look in their default
base pose.

2 Select the following in the Outliner:

■ All of the capsule objects created in the previous lesson, including the
root capsule object (muscleCapsule1) and all the joints that you
converted to capsules.

■ The two polygon bone objects (boneKneeCapRt and boneBlade).

■ The skin mesh (pSkinMesh).
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3 Select Muscle > Muscle Objects > Connect selected Muscle Objects.

All the bones are connected into the Muscle deformer. At this point,
scrubbing the timeline still does not produce any motion on the skin
mesh because you have not yet applied the default skin weights.

Apply default weights

Applying default weights to bones and polygon mesh objects is similar to
weighting with the Maya skinCluster. The points on the skin will move when
the capsule/bone moves.

To apply default weights

1 Select the skin mesh (pSkinMesh).

TIP Open the Muscle Paint window now (Muscle > Paint Muscle Weights)
to view the mesh in Paint mode, so you can see the weights after you
complete the following steps.

2 Select Muscle > Weighting > Apply Default Weights.

3 In the Default Weights window that appears, select Sticky in the Weight
drop-down list, and set the Smooth value to 3.

The Smooth value sets how many iterations the smooth operation applies.

4 Click Apply Default Weights.

Now that you have applied default Sticky weights, scrubbing the timeline
shows the effect. The skin mesh moves when the capsules/bones move.
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This concludes the first lesson. You can find the completed file for this lesson,
DragonLeg_Basic_End.mb, in the Maya Muscle Advanced Techniques folder.

Beyond the Lesson

In this lesson you learned how to:

■ Create a capsule object

■ Convert joints to capsules/bones

■ Apply the Muscle deformer to a skin mesh

■ Connect bone and capsule objects to a skin mesh

■ Apply default weights to a rig

Now you are ready to refine the default weighting on your dragon leg mesh
by painting weights with the Muscle Paint window.

Lesson 2: Painting Sticky weights to bones
In the next steps you will paint weights on the mesh. The Muscle Paint window
lets you paint weights for capsules, bones, and muscles, as well as set weights
on points, much like the Component Editor.

Open the scene for the lesson

 ➤ Load the scene you worked on in the previous lesson or load the
DragonLeg_Paint_Start.mb file.

This scene contains the dragon leg with connected bones and capsule
objects. The dragon leg mesh is set up with default Sticky weights applied
to the capsules for basic skin deformation.

You can use the Display Layer Editor to show and hide various parts of
this rig.

Paint weights

After you apply default weights to the bones and polygon mesh objects, you
can use the Muscle Paint window to refine those weights, increasing or
decreasing the effect of the default weights.

1 In the scene view, select Shading > Smooth Shade All, if it is not already
on.
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2 Select the skin mesh object (pSkinMesh) then select Muscle > Paint Muscle
Weights.

The Muscle Paint window appears and the mesh appears in Paint mode,
in a black color.

The Muscle Paint window provides many of the same basic features as
the Artisan paint tools. See Muscle Paint window on page 149 in the Maya
Muscle guide to learn more about its specific attributes.

3 Set up the Muscle Paint window as follows:

■ Select Sticky from the Weights drop-down menu.

■ Select jntShoulder in the Influence list.

■ Turn on Replace.

4 In the dragon leg hip area, paint weights to the jntShoulder (hip) bone.

Wherever you paint, the default weights are replaced with the weight
value you are painting (by default, 1). You can adjust the Weight value
in the Muscle Paint window and continue painting.

TIP Press and hold the b key while dragging in the scene view to adjust the
size of the brush.
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5 When you are finished painting weights, close the Muscle Paint window.

6 Scrub the timeline to see how your painted weights affect the way the
skin deforms as the bones move.

In the next steps, you set weights on specific points, rather than painting
them on the entire upper leg.

Set weights to specific points

1 Open the Muscle Paint window and select jntLegUp in the Influence list.

2 Turn off Paint mode in the Muscle Paint window.

The painting features are now disabled in the Muscle Paint window, and
the points of the skin mesh appear.
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3 Select the specific points on the upper leg where you want to set weights.

TIP Use the Lasso Tool for more precision when selecting points.

Notice that the Live Update option is on. This means that as you drag
the Weight slider, the weights update interactively. When Live Update
is off, you can set the weight value, but the weight does not change until
you click Set Weight/Flood.

When you have multiple points selected and Live Update is on, the
Weight slider automatically adjusts to show the average weight to the
current object for the selected points. For example, if you select some
points where the mesh is black and some where the mesh is red, the
Weight slider shows the average value of those points.

4 Use the Weight slider to drag the value to 0.5. Notice that the color turns
yellow to show this area has half the weight.

5 Continue dragging the slider up to 1.0. The selected points on the dragon
leg mesh are now weighted 100% to the upper leg bone.

Smooth weights

In the next steps, you will smooth the transition between the shoulder (hip)
and upper leg joint. To make sure weights don’t get re-normalized to other
bones, you can lock weights.
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1 Clear your selection by clicking an empty area of the scene, then turn
Paint mode on in the Muscle Paint window.

NOTE It's important that you have no points selected when you turn Paint
mode back on. If you turn Paint mode on with some points selected, only
those points are paintable. When you turn Paint mode on with nothing
selected, the entire mesh becomes paintable again.

2 In the Influence list, select everything except for the jntShoulder and
jntLegUp bones, then right-click and select Enable Lock/Hold Weight on
highlighted items from the pop-up menu.

A HOLD marker appears next to each joint, meaning the current weights
for those items are locked and cannot be adjusted, even if you paint
around that item. You can now safely smooth weights between the
shoulder and upper leg only, since those are the only two joints currently
unlocked.

3 Select jntLegUp in the Influence list, and turn on Smooth.

4 Paint along the top edge of the upper leg a few times.

5 Scrub the timeline to see the smooth deformation between the shoulder
and upper leg.

6 Select all the items in the Influence list, right-click and select Disable
Lock/Hold Weight on highlighted items to continue painting on other
bones.

7 Continue to paint and smooth weights to the joints/capsules for basic
rigid bone skinning with the techniques you have learned in this lesson.
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Leave the weights on the polygon knee cap and blade at zero, as you will
use those objects for Sliding effects in a later lesson.

When you are finished, you have a basic skin setup with bones. You can find
the completed file for this lesson, DragonLeg_Paint_End.mb, in the Maya
Muscle Advanced Techniques folder.

Beyond the lesson

In this lesson you learned how to:

■ Paint sticky weights to bones using the Muscle Paint window

■ Apply weights to specific points on a mesh

■ Apply Smooth weights for better transition between weights

Painting Sticky weights to bones or capsules gives an effect similar to Maya
skinClusters. The other main features of using the Muscle skin deformer, such
as Sliding and Jiggle, are discussed in the following lessons.

In general, it is recommended that you first paint weights to only the capsules
and bones on your mesh before working with muscles and Sticky weights.
This can help keep your weighting structured and organized.

Lesson 3: Setting up simple muscles
In the previous lessons, you set up the Muscle deformer with only capsules
and bones. This gives you a good foundation to build your additional skinning
from. In this lesson you learn how to create simple muscles and set up muscle
deformation on your mesh.
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Open the scene for the lesson

1 Load the file you worked on in the previous lesson, or load the
DragonLeg_Muscles_Start.mb file.

This file has the dragon leg with all the muscles and bones connected
with default and basic Sticky weights applied to the capsules.

2 Do one of the following to change the skin mesh display so you can see
the underlying rig:

■ In the Display Layer Editor, turn off the lyrSkin layer to temporarily
hide the skin as you work on the muscle.

■ From the panel menus, select Shading > XRay.

Create a simple muscle

While you can convert and rig any existing NURBS surface to be a muscle,
Maya Muscle provides a tool to easily build and set up muscles interactively.
In the next steps you use the Muscle Builder to create simple muscles.

1 From the main menu, select Muscle > Simple Muscles > Muscle Builder.

The Muscle Builder window appears.

2 Using the Outliner window, do the following to load the muscle Attach
Objects in the Muscle Builder:

■ Select the jntShoulder capsule and click  for Attach Obj 1.

■ Select the jntLegLo capsule and click  for Attach Obj 2.

These  buttons load the selected objects into the Attach Object
fields for you.

3 Click Build/Update.

A muscle shape is generated from the start Attach Object (Attach Obj 1)
to the end Attach Object (Attach Obj 2). You may want to change your
scene view to wireframe or X-ray mode while you work.

TIP You can click the Attach Obj 1 or Attach Obj 2 buttons to directly select
the attach locators and position them in the scene view.

For this tutorial, you can leave the parameters in the Build tab at their
default settings. If you want, you can adjust the simple muscle settings.
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See Build tab on page 139 in the Maya Muscle guide to learn about the
attributes available.

NOTE If you scrub the timeline, the muscle stays attached but will not yet
squash or stretch properly because you have not yet set up deformation.

Once your muscle is generally placed and set, you can sculpt the muscle
shape into something more specific.

Sculpt the simple muscle shape

1 In the Muscle Builder, switch to the Cross Section tab.

This tab has three main sections. The list on the left shows you each cross
section of your muscle. Typically the first and last cross sections are
adjusted. There are two view panels showing you the view of all of your
muscle cross sections down the length and from the side.

2 Select Curve 3 and Curve 5 from the Cross Section list. Note that you can
move them on the X- and Z-axis in the view panel.

Selecting one or more items in the Cross Section curve list selects those
curves. You can then move them in the view panels here, or in the scene
view.

3 Click Edit Cross Section at the top of the tab.

The cross sections are now active for editing and the view panels
automatically switch to component mode so you can directly edit the
points of the cross section curves.
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4 Continue editing the cross sections until you are happy with the shape
of the muscle.

TIP You can pan in the view panels of the Muscle Builder. To easily re-center
the view panels, click the Cross Section tab again.

5 When you are finished, click the EDITING label at the top of the tab to
turn off the editing mode.

You are now finished sculpting your muscle. In the next steps you finish
the building process and rig the muscle to deform properly.

Finalize the simple muscle

1 In the Muscle Builder window, switch to the Finalize tab.

This tab lets you choose how to deform and rig your muscle. For further
information about the attributes of the Finalize tab, see Finalize tab on
page 141.

2 Ensure the Muscle Spline Deformer is selected, and Num Controls is set
to 3.

NOTE This gives you three movers: one at the start, one at the middle, and
one at the end of the muscle.

3 Click Convert to Muscle.
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A warning dialog box appears to notify you that this operation will finalize
the cross sections of this muscle. The dialog box also lets you select the
base name of the muscle and controls.

We recommend that you find a useful and readable naming scheme so
that you can easily select and weight the muscles in the Muscle Paint
window later. For example, if you create a muscle located near the upper
leg, on the rear side in the center, you could name it "hamstringCenter".

4 Enter a name and click OK.

The muscle is rigged and a cMuscleObject shape node is created. In
wireframe mode, you can see three yellow box controls. These controls
can be animated and have Jiggle settings on them that are created and
constrained to the proper capsules.

5 Switch to the Muscle Parameters tab and scroll down.

This section lets you customize the deformers on the selected muscles.
You can also directly manipulate some of the controls in the Attribute
Editor or Channel Box.

To see the deformer attributes in the Channel Box, select the muscle
surface.

6 Scrub the timeline frame by frame to see the muscle squash and stretch.
After you have done this once, you can jump to any frame and adjust
Muscle Parameters at any time and the playback is still correct.
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Adjust the squash and stretch

Before you set the muscle squash and stretch, it's a good idea to set the
minimum and maximum length of the muscle. By default, the muscle’s
minimum squash is set to half its original length, and its maximum stretch
is set to double its original length. When the muscle length changes to these
settings, you get the maximum amount of volume change.

To adjust the squash and stretch length settings

1 Set the scene view shading to Smooth Shade All and turn off the lyrSkin
layer in the Display Layer Editor.

2 Leaving the Muscle Parameters tab of the Muscle Builder open, do the
following to define the Squash pose:

■ Select the FootIKMover control and raise the leg to a squashed
position.

■ Select the muscle surface.

■ In the Spline Length Settings section of the Muscle Parameters tab,
click Set Current as Squash.

This sets the muscle’s minimum squash value to the current length.

3 Do the following to define the Stretch pose:

■ Select the FootIKMover control and move it down so the leg is fully
extended.

■ Select the muscle surface.

■ In the Spline Length Settings section, click Set Current as Stretch.

Lesson 3: Setting up simple muscles | 215



Setting the minimum and maximum stretch length values cause the
squash/stretch settings to more directly affect the visual output, since
they are more closely related to the actual lengths the muscle is changing
by. This can also help stop stretching from losing volume. In addition,
this makes the Dampen On Squash and Dampen On Stretch values work
properly.

4 Adjust the Stretch Volume Presets as required.

Make sure you have the muscle surface selected so that changes you make
in the Muscle Builder affect the muscle. The stretch settings let you set
the basic X- and Z-axis radial volume change for the start, middle and
end of the muscle.

If you are getting flipping when the muscle contracts, changing the
Up-Axis can fix this. When the muscle is bent, the aim values set how
the tips orient themselves.

TIP You can play the animation and adjust the settings while the animation
plays. Clicking a Stretch Volume preset automatically sets the values to one
of several preset values.

View the Jiggle parameters

For Jiggle on simple muscles, you have overall control from the start to the
middle to the end of the muscle. If you rig a muscle and create more than
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three movers, you can also directly set specific Jiggle values on the yellow
movers. You can experiment to see the effect of the Jiggle Presets located on
the Muscle Parameters tab of the Muscle Builder window.

To view the Jiggle parameters

1 Play the animation.

2 As the animation plays, click each of the Jiggle Presets buttons (Default,
Light, Medium, Heavy, and OFF) to see the effect each preset has on the
muscle.

Beyond the lesson

In this lesson you learned how to:

■ Create a simple muscle using the Muscle Builder

■ Sculpt and finalize a simple muscle

■ Adjust muscle parameters

Because you rigged the simple muscle with the cMuscleSplineDeformer, you
can also do custom muscle shaping to get exact control over how the muscle
looks at various lengths. For further information see cMuscleSplineDeformer
node on page 183 and Set up a Muscle Spline deformer on page 35 in the Maya
Muscle guide

As you build more simple muscles, note that in some cases, you may want
muscles and bones to penetrate. For example when using Shrink Wrap, it's
better to have a solid mass of muscles even if they penetrate than to have gaps
or spaces between them.

You can now go back to the Build tab, select new settings, and continue
building more muscles for your rig using the techniques you have learned. A
completed muscle rig for this lesson called DragonLeg_Muscles_End.mb.
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Lesson 4: Painting Sticky weights to simple muscle
In the previous lessons, you created muscles and bones and set skin weights
for the bone capsules. In this lesson, you add weights for simple muscles. This
is the same process as weighting for bones, except with muscle weights, the
mesh deforms not only when the muscle moves as a whole, but also when its
surface moves or jiggles. Since the skin mesh is effectively attached to the
muscle surface with Sticky weights, when the muscle jiggles or bulges, so does
the skin that is weighted to it. This step alone can give a high level of
additional realism and interest to your rigs.

Just as you connected the bones in an earlier lesson, you first need to connect
the muscles to the Muscle skin deformer. Since they were created with the
Muscle Builder, they are already rigged with the cMuscleObject shape node
and can be immediately connected.

Open the scene for the lesson

 ➤ Load the file you worked on in the previous lesson or load the
DragonLeg_Sticky_Start.mb file.

This file has the skin mesh weighted to the bone capsules, and the muscles
are set up and attached to the bones.

Visualize the Sticky Bind distance

Unlike weighting to bones, weighting to muscles binds the skin mesh points
to the muscle surface. When the muscles are first connected, a Sticky Bind
operation calculates the distance between skin and muscle. In order to speed
up this calculation, only points within a certain distance from the center of
the muscle are calculated. For example, a muscle for a character’s left arm
typically does not need to be weighted to points on the character’s right leg.
Sticky Bind ensures that only points close to the muscle are calculated.
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The Sticky Bind window appears as you connect simple muscles, letting you
control the distance. Typically, using the Auto-Calculate value is sufficient,
but you can also preview the effect of the value. This lesson shows you how
to visualize the Sticky Bind distance for a leg muscle.

Any points within the Sticky Bind distance are calculated, and can be weighted
to the muscle properly. Any points outside this distance are ignored. Note
that this process is simply setting whether the point is allowed to be weighted,
it does not actually do any weighting. Any points outside the distance can
have weights set, but usually deform incorrectly. If you set the distance too
low, you can always go back and re-bind Sticky (even to the entire mesh) later.

To visualize the Sticky Bind distance

1 Select the simple muscle located in the upper thigh (MusLegUpFront).

2 From the main menu, select Muscle > Muscle Objects > Visualize Sticky
Bind Distance for selected Muscle Objects.

A yellow visualization sphere appears around the selected muscle.
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The radius of the sphere helps you visualize the skin points affected with
this Sticky Bind distance.

3 In the Channel Box, click makeNurbSphere1 in the INPUTS list, then
adjust the sphere’s Radius value to see how a larger or smaller value would
work.

NOTE The sphere itself is just a temporary object and has no relevance to
the muscle, other than to help you visualize the distance.

4 Delete the sphere when you are finished.

Now you can connect the muscle surfaces to the skin.

Connect muscle objects

1 Go to frame 0, then select all of the NURBS muscles and the skin mesh.
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2 Select Muscle > Muscle Objects > Connect selected Muscle Objects.

The Sticky Bind Maximum Distance window appears. For more
information see Sticky Bind Maximum Distance window on page 149.

3 Click Auto-Calculate.

Each muscle is connected to the Muscle skin deformer and set up to allow
for Sticky weights. When this process is complete, you can paint muscle
weights the same way you painted bone/capsule weights.

Paint muscle weights

1 Select only the skin mesh.

2 From the main menu, select Muscle > Paint Muscle Weights.

The Muscle Paint window appears. Just like painting the capsule weights,
you can use this window to paint or set Sticky weights for the muscles.

3 In the Weights drop-down menu, select Sticky.

4 Select a muscle in the Influence list.

A good way to paint muscle weight is to slowly add up weight from the
bones onto the muscle.

5 To start painting muscle weights:

■ Set the Weight value to a small value, such as 0.1, and select Add as
the paint mode.

■ Paint weights for the muscle on the skin.
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■ Scrub the timeline to see how the animation looks with this
deformation.

TIP You can also right-click the Weight slider to select from preset weights
in increments of 1/10th.

6 Practice painting weights for each muscle until you get deformation
effects you like. Notice how the skin moves along with the muscle surface
as the Sticky weights are added to the muscle.

TIP Don't worry about interpenetration of the muscles since typically you do not
render the muscles, only the skin. In the next lesson, you add Sliding weights for
the muscles and bones, which helps the skin push out from the muscle if they
intersect.

You can find the completed file for this lesson, DragonLeg_sticky_End.mb, in
the Maya Muscle Advanced Techniques folder. This file also has an adjusted
animation to display muscle deformation.

Beyond the lesson

In this lesson you learned how to:

■ Visualize the Sticky Bind distance

■ Connect simple muscle objects to the Muscle skin deformer

■ Paint muscle weights
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Lesson 5: Setting up Sliding deformation
You now have a working muscle rig for the leg mesh. The Muscle skin deformer
provides even more quality in the rigging with Sliding weights. The Sliding
deformer lets you create muscle and bone sliding under the skin. Combined
with the Relax weights you will set in a later lesson, you can achieve very
effective skin pulling and sliding effects.

Open the scene for the lesson

 ➤ Load the file you worked on in the previous lesson or load the
DragonLeg_Sliding_Start.mb file.

This file has the leg properly skinned and weighted with bones and
muscles using Sticky weights.

Enable Sliding deformation

1 Select the skin mesh, and in the Channel Box under INPUTS click the
cMuscleSystem1 node to display its attributes.

Each main section of the deformer is broken down by label headings. For
now, use the ones listed under SLIDING. The Sliding deformer can be
turned on and off for faster interaction and playback.

2 Set Enable Sliding to on, and leave quality set to Full.

Later you can adjust the quality attribute as needed. See Sliding attributes
on page 188  in the Maya Muscle guide for further information.

Lesson 5: Setting up Sliding deformation | 223



Paint Sliding weights

Start by painting weights for the hip blade bone.

1 Select the skin mesh, then select Muscle > Paint Muscle Weights.

The Muscle Paint window appears.

2 In the Weights drop-down menu, select Sliding.

3 Set the Weight value to 1.0 and turn on Replace.

4 In the Influence list, select boneBlade.

5 Paint weights where the blade bone might push out.

TIP It's important to paint only the area around the bone for speed purposes,
and also so points on distant parts of the mesh aren’t affected by the blade
bone.

As you paint, you can see the Sliding deformation start to happen. Note
that the slide is not accurate because there is not enough detail in the
mesh relative to the bone. This is a good example of a situation where
you may want more skin detail for areas where smaller or thinner bones
or muscles cause the sliding.

Set a Fat offset

For areas where a muscle or bone often penetrates the skin when sliding, you
can set a Fat value to create an offset between the muscle or bone and the
skin. Each muscle or bone object has this Fat attribute on its cMuscleObject
shape node.
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A good example is the MusHipBack muscle, since the skin often penetrates
the muscle on the back. The image below shows that muscle painted with
Sliding weights, and a fat offset on the muscle set to 0.55.

To define an offset from the skin mesh to the bone blade

1 Select the bone blade object.

2 In the Attribute Editor, select the cMuscleObject_boneBlade1 tab to view
the cMuscleObject shape node attributes for the bone blade.

3 Set the Fat value to 1.0.

The skin is now offset from the bone blade.

Notice that right now the Sliding only affects a few points, is somewhat sharp,
and is causing some self penetration in the muscle. In the next steps, you will
use Direction weights to improve the sliding.
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Create a Direction node

1 Make sure nothing is selected, close the Muscle Paint window, then select
Muscle > Direction > Make Muscle Direction.

By default, a vector type direction node is created at the origin. It has an
arrow that points in the direction the Sliding will attempt to work once
it is connected to the Muscle skin deformer.

In this case, since nothing was selected, a new cMuscleDirection shape
node is created.

TIP Since you may often want to have radial direction nodes created based
on the center line of your mesh, and since capsules are typically used for
bones that run down the centerline, you can easily convert any capsule to
also function as a cMuscleDirection node. Simply select the capsule, then
select Muscle > Direction > Make Muscle Direction. The capsule will be
converted to be both a capsule and a radial muscle direction simultaneously.
You can then connect the capsule to the deformer as a capsule muscle object
and/or a muscle direction and use it both ways.

2 In the Channel Box or Attribute Editor, set the cMuscleDirection node’s
Type attribute to radial.

This creates a radial-type push out along an axis. The Length and Falloff
Outer attributes control how far this axis goes.

Next, you connect the direction object to the Muscle deformer.

Connect the Direction node

1 Select the direction object and the skin mesh.

2 From the main menu, select Muscle > Direction > Connect selected Muscle
Directions.

The Direction object is connected, although there is no visible change
on the mesh because you have not yet painted Direction weights.
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3 Move the Direction object to align it with the rear hip muscle.

4 Parent the Direction object to the first control of the back hip muscle by
middle-dragging cMuscleDirection1 onto iControlMusHipBack1 in the
Outliner.

5 Set the Length attribute of the Direction object to 3.0.
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Leave the Falloff Outer attribute set to 1.0, as it only changes the length
at the tips. The actual effect of the direction node comes only from
weighting. The Inner/Outer Falloff values are primarily for visual feedback.

Paint Direction weights

1 Select the skin mesh, then select Muscle > Paint Muscle Weights.

2 In the Muscle Paint window, select Direction in the Weights drop-down
menu.

This lets you set and paint Direction weights for any connected direction
nodes.

3 Paint Direction weights around the hip, in the same area where you
painted Sliding weights.

The Sliding direction is now corrected so that it pushes out radially from
the center line of the muscle direction node. This corrects the penetration
problem.

4 Scrub the timeline to see the animation.

5 In the Channel Box under INPUTS, click the cMuscleSystem1 node.

6 Toggle the Enable Sliding option on and off to compare how the mesh
looks with Sliding enabled and disabled.

7 Continue to paint weights and create direction nodes as needed, or open
DragonLeg_Sliding_End.mb to see a finished example.
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Beyond the lesson

In this lesson you learned how to:

■ Set up Sliding deformation

■ Paint Sliding weights

■ Set a Fat offset

■ Adjust how the slide occurs by setting up a directional node

Lesson 6: Setting up Jiggle deformation
So far you have a working leg with flexing muscles. To provide even more
control, Maya Muscle lets you paint Jiggle weights per-point on your mesh.

NOTE You can use the Jiggle deformer even if you are not doing muscle skinning.
For example, you can paint and add weights for jiggling on any moving object to
get jiggle effects, even if the object is skinned with a Maya skinCluster, or not
skinned at all.

Open the scene for the lesson

 ➤ Load the file you worked on in the previous lesson or load the
DragonLeg_Jiggle_Start.mb file.

This rig has a complete leg with bones and muscles, and with Sticky and
Sliding weights applied.

Enable Jiggle deformation

Like other features, the Jiggle deformer can be turned on and off independently.
When Jiggle occurs, Jiggle collisions can also be enabled to help make sure
points do not move into bones and muscles that are sliding. Note that there
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is no self-collision, this is simply sliding collision if the Sliding deformer is
also enabled.

1 Select the skin mesh.

2 In the Attribute Editor, select the cMuscleSystem1 tab.

3 Turn on Enable Jiggle.

Paint Jiggle weights

1 Select the skin mesh.

2 Select Muscle > Paint Muscle Weights.

The Muscle Paint window opens.

3 In the Muscle Paint window, select Jiggle from the Weights drop-down
menu.

4 Paint Jiggle weights in the middle center of the leg, as shown. (You can
paint weights on other areas of the skin mesh where you want to have
per-point skin jiggle.)

5 Experiment with painting different areas of the mesh, and playblast your
animation to see the results (Window > Playblast).

Typically, jiggle-related weights benefit from a smoother falloff on the
painting. Close the Muscle Paint window when finished.

NOTE You can review the other Jiggle attributes on the cMuscleSystem node
in the Channel Box or Attribute Editor. See Jiggle attributes on page 192 in
the Maya Muscle guide for more details about each attribute.
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The basic leg rigging is now complete. You can find the completed file for this
lesson, DragonLeg_Jiggle_End.mb, in the Maya Muscle Advanced Techniques
folder.

NOTE Since the Jiggle calculations for per-point skin jiggle can use significant
machine resources, you can use Muscle’s per-point cache feature to provide faster
animation playback during operations like lighting or rendering. In the next steps
you cache each frame of animation internally on the node in the Maya scene itself.
This way you can cache playback, then playback within Maya for faster speed and
interaction.

Create a cache

1 Select the skin mesh object.

2 From the main menu, select Muscle > Caching > Create Cache.

The frame range is the current Time Slider range, and the cache data is
stored within the Maya scene. Leave the default options in the Generate
Cache dialog that appears.

NOTE In this lesson you use node-based caching, however if you are planning
on using external file-based caching, you can set the path and base filename
using the Attribute Editor, or by selecting Muscle > Caching > Set Location
of Cache File from the main menu.

3 Make sure your skin mesh is still selected and click Generate Cache for
Selected Objects.

A progress window appears as the Time Slider scrubs and the cache is
calculated.

Once the dragon leg animation is cached, you can have faster playblasts,
or change camera angles and playback to see how the animation looks
from different angles. Since the data is cached, deformation is not really
being calculated, making playback faster.

4 Playback the animation.

Depending on the speed of your computer, the cached animation plays
back in near real-time. The cache attributes on the cMuscleSystem node
(which can be seen in the Channel Box or Attribute Editor) shows that
the cache is now set to read-node. This means it is now reading the point
cache rather than doing full calculations.
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NOTE While you are viewing the cached data, attempting to change settings
(such as turning Sliding deformation on or off, or attempting to paint weights)
will have no effect on the mesh.

To remove the cache

 ➤ Do one of the following:

■ Select Muscle > Caching > Delete Node Cache, then select which
frames to clear.

■ Switch the cache attribute of the cMuscleSystem node to disabled.
This disables caching and returns to the normal calculation.

Beyond the lesson

In this lesson you learned how to:

■ Set up Jiggle deformation

■ Paint Jiggle weights

■ Set up a per-point cache to facilitate faster playback

You can find the completed file for this lesson, DragonLeg_Cache_End.mb, in
the Maya Muscle Advanced Techniques folder.

Rigging muscles

Introduction
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This Advanced Technique tutorial shows you the basic workflow and features
of the Maya Muscle Creator in several lessons:

■ Lesson 1: Create and set up a muscle object on page 233

■ Lesson 2: Set muscle pose states on page 237

■ Lesson 3: Edit the muscle shape on page 239

■ Lesson 4: Adjusting muscle length on page 241

■ Lesson 5: Sculpting muscles on page 244

■ Lesson 6: Mirroring muscles on page 247

Preparing for the lessons
To ensure this tutorial works as described, confirm that you have Maya Muscle
loaded. The Muscle menu displays in the main menu bar if Muscle is loaded.
If you need to load Muscle manually, see Load Maya Muscle on page 2 in
the Maya Muscle guide.

If you have not already done so, download the Maya Muscle Advanced
Techniques Lesson Data from the following location:
www.autodesk.com/maya-advancedtechniques.

It is recommended that you save your work periodically and at the end of
each section as you progress through this tutorial, however sample files of the
finished scene for each example are also included.

Lesson 1: Create and set up a muscle object
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Open the scene for the lesson

1 Load the Sabertooth_Create_Start.mb file.

This scene contains a quadruped rig with its joints converted to have
capsules. You can use the Display Layer Editor to show and hide the skin
of the model.

TIP Use the (Windows) Alt+b or (Mac OS X) Option+b hotkey to toggle the
background color in the scene view.

2 Scrub the timeline and watch the walk cycle animation.

The quadruped rig is currently lacking a muscle structure. This lesson shows
you a workflow example using the Muscle Creator to add muscles. The Muscle
Creator lets you not only create and mirror muscles, but also provides controls
to sculpt and shape them so they move in a realistic fashion.

Create muscles

1 From the main menu, select Muscle > Muscles/Bones > Muscle Creator.

The Muscle Creator window appears. The top half of the Create tab
contains controls that let you set the name of your muscle, the number
of controls/cross sections, the number of segments around your muscle,
and the joints to which the muscle is attached.

2 In the Muscle Creator window, do the following:

■ Enter Mus_L_FrontLeg as the Muscle Name.

TIP Naming your muscles clearly helps you better identify them within
the hierarchy, for example by differentiating muscles from the character’s
right and left sides.

■ Set Num. Controls / Cross Sections to 4.

■ Set Num. Segments Around to 8.

3 Keeping the Muscle Creator window open, do the following to set the
muscle’s Attach objects:

■ Select the bn_L_F_Humerus01 capsule (in the scene view or Outliner)

then click the Attach Start  button in the Muscle Creator window.
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■ Select the bn_L_F_TiborRaiiMinor01 capsule and click the Attach End

 button.

The  buttons load the selected objects into the Attach Start and
Attach End fields for you.

4 Click Create Muscle.
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The new muscle is attached to the joints you specified in the Attach Start
and Attach End fields.

To see the muscle clearly, you may want to change your scene view to
wireframe. The muscle is primarily comprised of a NURBS surface, two
attach points at each end of the muscle, and a series of cross section
controls.

Beyond the lesson

In this lesson you learned how to create a muscle attached to two joints. You
can find the completed file for this lesson, Sabertooth_Create_End.mb, in the
Maya Muscle Advanced Techniques folder.

Now you are ready to refine and edit the muscles of the saber tooth tiger by
setting the pose states and adjusting the locators at each end of the muscle.
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Lesson 2: Set muscle pose states
This lesson shows you how to set up the muscle pose states.

Open the scene for the lesson

1 Load the Sabertooth_Set_Start.mb file.

This scene contains the saber tooth tiger with a front leg muscle.

2 Scrub the timeline to see how the leg muscle deforms throughout the
animation.

Notice the exaggerated deformation of the front leg muscle. By default,
all muscles contain a certain amount of jiggle, which is causing the
deformation. In the next steps, you will remove the default Jiggle so that
you can better visualize and set the muscle’s pose states.

Setting pose states

NOTE Although it is best to set the pose states before you begin sculpting your
muscles, you can edit them at any point in your muscle creation process.

To turn off the default Jiggle

1 Select the front leg muscle.

2 Switch to the Front camera in the scene view and select the four green
cross section controls along the length of the muscle surface.

These outer wireframe boxes store the Jiggle settings.

3 In the Channel Box, set the Jiggle attribute to 0.

4 Switch back to the Perspective view and scrub through the animation
again.
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The muscle deformation is much more natural. Without the default Jiggle
value, it is easier to set the three main pose states in the next steps.

To set the pose states

1 Select the front leg muscle.

2 From the main menu, select Muscle > Muscles/Bones > Muscle Creator.

3 In the Muscle Creator, switch to the Edit tab.

The Edit tab contains controls that let you shape and fine tune your
muscle surfaces in the different pose states.

4 Go to frame 3, where the front leg muscle is in a rest state.

5 In the Poses section of the Muscle Creator, click the Rest button.

This sets the muscle’s current pose as its rest state.

6 Go to frame 15 and click Stretch.

At this point, the humerus and leg joints are almost parallel, indicating
a good muscle stretch position.

The muscle surface thins out when the state is set.

7 Go to frame 7 and click Squash.
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This is the point where the humerus is almost perpendicular to the leg
joints, indicating a good muscle squash.

The muscle surface’s volume expands a little to compensate for its new
set state.

Now that you have set the pose states, you can clearly see the front leg muscle
bulge and stretch as you scrub through the animation.

Beyond the lesson

In this lesson you learned about setting muscle pose states. You can find the
completed file for this lesson, Sabertooth_Set_End.mb in the Maya Muscle
Advanced Techniques folder.

Now you are ready to adjust the muscle’s attach points locators, as well as edit
its length and shape.

Lesson 3: Edit the muscle shape
Each muscle you create using the Muscle Creator is constrained to two separate
attach locators on each end. These locators are parented to the joints you
specified when you first created the muscle. You can move these locators to
change the muscle shape. Here, you adjust them so that the muscle surface
wraps around the front leg.

NOTE You can re-parent the muscles to different joints of your rig by re-parenting
the muscle attach locators.

Open the scene for the lesson

 ➤ Load the file Sabertooth_Edit_Start.mb.

This scene contains the saber tooth tiger with a front leg muscle that has
all three pose states set.
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Adjust the position of muscle locators

To adjust the muscle locators

1 Select the front leg muscle.

2 Open the Muscle Creator and switch to the Edit tab.

The lower part of the Edit tab lists all the different cross section controls
and attach points available for the selected muscle.

3 In the Attach Locs section, Ctrl-select the two end locators of the leg
muscle: locMus_L_FrontLeg_End1 and locMus_L_FrontLeg_End2.

4 Using the Move tool, move the locators lower on the Y-axis until they
are near the ankle, then move them on the Z-axis until they are in front
of humerus joint.

Notice that the muscle surface stretches to compensate for the new locator
position.

5 Select locMus_L_FrontLeg_Start1 and move it close to the base of the
humerus joint, by the side of the leg facing outwards.
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6 Select locMus_L_FrontLeg_Start2 and move it next to
locMus_L_FrontLeg_Start1.

Notice that each cross section control along the muscle surface
individually rotates to compensate for the adjusted locator position.

7 Scrub through the animation to see how the muscle behaves based on
its new shape.

Beyond the lesson

In this lesson you learned how to shape your muscle by adjusting its attach
locators. You can find the completed file for this lesson,
Sabertooth_Edit_End.mb, in the Maya Muscle Advanced Techniques folder.

Now you are ready to adjust the length of the muscle surface.

Lesson 4: Adjusting muscle length
Muscles created with the Muscle Creator window have three built-in cross
section curve sets that you can edit: one for the default rest position, one for
the squash state, and another for the stretch state. You can directly edit these
curves in the scene view, or using the Muscle Creator window. The following
example shows you how to adjust the muscle length for each of these poses.
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Open the scene for the lesson

1 Load the Sabertooth_Length_Start.mb file.

This scene contains the saber tooth tiger with capsulated bones, a front
leg muscle, and a neck muscle that has been set in all three pose states.

2 Scrub frame by frame to see the neck muscle squash and stretch.

Notice that the neck muscle travels down from the cervical joints to the
humerus joint in a straight line, which causes the muscle surface to either
stick out too much from the tiger’s body, or go through the shoulder
joints. This not only looks unnatural, but it also affects how the muscle
works. In the next steps, you will fix this by changing the muscle’s center
line for each of its pose states so that it follows the contours of the tiger’s
body.

Adjust the muscle length

In the following steps, you will use the muscle locators to adjust the muscle
length for each of the pose states.

Adjust the rest locators

1 Select Muscle > Muscles/Bones > Muscle Creator from the main menu.

The Muscle Creator window opens.

2 Go to frame 0, where the neck muscle is in a rest state.

3 Select the neck muscle surface and switch to the Edit tab in the Muscle
Creator.

4 In the Attach Rest section, select AttachMidMus_L_Neck11.

This selects the first inner wireframe box at the top of the neck muscle,
which represents the attach point for the nearby cross section.
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5 Using the Move tool, adjust the position of the top part of the neck muscle
so it goes around (instead of through) the cervical joint.

6 Repeat the process with the remaining Attach Rest points until you’re
satisfied with the results.

The muscle shape should be organic and follow the tiger’s body. Don’t
worry about placing the attach points perfectly, as you can always tweak
them later.

Adjust the squash locators

1 Go to frame 5, where the neck muscle is in a squash state.

2 Adjust the center line for this state by selecting the attach points from
the Attach Squash section of the Edit tab, and then reposition them using
the Move tool.
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Adjust the stretch locators

1 Go to frame 17, where the neck muscle is in a stretch state.

2 Select the attach points from the Attach Stretch section of the Edit tab,
then reposition them using the Move tool so that the muscle goes around
the shoulder before ending at the humerus.

3 Scrub through the animation to view the effect of the changes you made.

Beyond the lesson

In this lesson you learned to adjust the muscle’s length by altering its center
line. You can find the completed file for this lesson,
Sabertooth_Length_End.mb, in the Maya Muscle Advanced Techniques folder.
Now you are ready to sculpt the muscle surface.

Lesson 5: Sculpting muscles
You can also edit a muscle’s cross section curves to sculpt the muscle into the
shape you want. The Muscle Creator sculpting controls let you choose which
pose state and axis to edit, and provide sliders to help you adjust the muscle
surface.

244 | Chapter 10   Maya Muscle Advanced Techniques



NOTE  Make sure you select the desired pose state before editing your muscle. If
multiple states are selected at once, changes you make on the muscle surface are
reflected in all selected states.

Open the scene for the lesson

 ➤ Load the Sabertooth_Sculpt_Start.mb file.

This scene contains the saber tooth tiger with capsulated bones, a front
leg muscle, and a neck muscle which has been set in all three pose states.

Sculpt muscles in each pose state

1 Open the Muscle Creator (Muscle > Muscles/Bones > Muscle Creator) and
switch to the Edit tab.

2 Select the neck muscle.

The neck muscle in the current rest state needs to be thinner on its Z-axis.

3 In the Sculpting section of the Muscle Creator, make sure only the Z axis
and Rest parameters are selected.

4 Drag the Sculpt slider to the left until the muscle loses its tube shape and
looks more like a flat strip.

5 Keep the Rest parameter selected, deselect the Z axis, and select the X
axis.
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6 Drag the Location slider to the left until it is under the St parameter and
drag the Falloff slider to roughly the same position.

This isolates the cross section curve at the top of the neck muscle that is
slightly curved inwards.

7 Drag the Sculpt slider to the right until the inward curvature disappears.

8 Go to frame 17, where the neck muscle’s stretch state is being pulled to
its limit.

NOTE Before you sculpt a muscle in a desired state, make sure you scrub to
a frame that best represents the muscle in that state. Otherwise, you may
not properly see the results of your deformations on your muscle surface.
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9 Drag the Location slider to the middle and drag the Falloff slider to the
right. This sets the sculpting range at its maximum, so the entire muscle
length is affected.

10 Select the Z axis and St parameters.

11 Drag the Sculpt slider to the left until the entire muscle is thinner.

12 Scrub the animation again to view your sculpting changes.

Beyond the lesson

In this lesson you learned how to sculpt a muscle in different pose states. You
can find the completed file for this lesson, Sabertooth_Sculpt_End.mb, in the
Maya Muscle Advanced Techniques folder.

Lesson 6: Mirroring muscles
The Muscle Creator lets you mirror muscles using their naming convention
as reference. You can mirror a selected muscle at any point in your creation
process.

Open the scene for the lesson

 ➤ Load the Sabertooth_Mirror_Start.mb file.

This scene contains the saber tooth tiger with muscle applied to the neck
and leg joints. You will mirror a muscle from one front leg to the other.
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Mirror muscle

1 Open the Muscle Creator window (Muscle > Muscles/Bones > Muscle
Creator) and switch to the Create tab.

2 In the Mirror section, select X as the Mirror Axis.

3 Enter _L in the Search field, and _R in the Replace field.

The muscle for each “side” of the mesh needs to be parented to joints
that follow a Left or Right naming convention.

TIP  You can also right-click the Search field and select from the available
naming conventions. This automatically fills in the Replace field.

4 Select the front leg muscle surface.

5 In the Muscle Creator window, click Mirror Muscle from Selection.

A new muscle is created on the right front leg based on the selected
muscle.
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6 (Optional) To mirror an additional muscle, select it and click Mirror
Muscle from Selection again.

Beyond the lesson

In this lesson you learned how to mirror muscles from one side of the mesh
to the other. You can find the completed file for this lesson,
Sabertooth_Mirror_End.mb, in the Maya Muscle Advanced Techniques folder.
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