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MotionBuilder Tutorials

This book includes a set of nine Autodesk MotionBuilder tutorials that provide a common
MotionBuilder workflow and also demonstrate how to use the more powerful keyframe and
character animation features.

The process of using MotionBuilder is shown in MotionBuilder workflow on page 3. The
actual tutorials are as follows:

■ Loading and characterizing character models on page 7

■ Creating and Customizing a Control rig on page 17

■ Creating a Character Extension on page 31

■ Creating a Walk Cycle on page 43

■ Retargeting Character Animation on page 59

■ Editing Character Animation on page 69

■ Creating a Loop on page 83

■ Manipulating Clips on page 99

■ 3ds Max-MotionBuilder Interoperability on page 111

NOTE Before you begin, ensure that the tutorial files have been installed. See Installing tutorial
files on page 1.

Installing tutorial files
Before you continue, ensure you have installed the tutorial files.

1
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Check if the MotionBuilder tutorial files are installed:

1 Launch MotionBuilder.

2 Close the Welcome to MotionBuilder screen.

3 Click the Asset Browser window.

NOTE If the Asset Browser window is not available, from the menu
bar, select Window > Asset Browser.

If the Tutorials folder displays in the Asset browser, go to step .

If there is no Tutorials folder displayed in the Asset Browser, go
to step .

4 Click the Tutorials folder to view its content.

The Tutorials folder contains the tutorial assets.

5 Obtain the MotionBuilder DVD, de-install MotionBuilder, and
re-install MotionBuilder from the DVD.

Installing the latest FBX Plug-ins
To facilitate transferring models and animation between different software
packages, Autodesk develops plug-ins for the following major 3D software
products:

■ 3ds max®

■ Maya®
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You can download the latest FBX Plug-ins here:
http://usa.autodesk.com/adsk/servlet/index?siteID=123112&id=6839916.

For information on how to install the FBX Plug-ins, and what the Plug-ins
support, consult the plug-in documentation.

MotionBuilder workflow
This section describes a common workflow that introduces the eight tutorials
provided to help you become familiar with the using MotionBuilder. For any
steps in the workflow that do not include a dedicated tutorial, you can find
more information in the MotionBuilder Help.

Although the tutorials introduced here assume you are using MotionBuilder
for a character animation project, this workflow can be easily adapted to any
animation project where MotionBuilder is used in conjunction with other 3D
modeling or rendering software.

The basic workflow for using MotionBuilder can be summarized as follows:

1 Install the necessary FBX Plug-ins so you can transfer your work from
other 3D software packages into and out of MotionBuilder.

For example, if you are using Maya for character modelling, you need to
install the Maya FBX Plug-in so that you can transfer the models you
create into MotionBuilder. See Installing the latest FBX Plug-ins on page
2.

2 Create a character model in your 3D modeling software of choice.

Before starting your animation project using MotionBuilder, there are a
few things you can do when modelling to make working with
MotionBuilder easier. Refer to Guidelines for creating a character model,
Bone naming conventions, and Choosing shapes to create in the
MotionBuilder Help for more information.

3 Export the character model from your modelling software package.

When you export your work from a modelling software package, the FBX
Plug-in you have installed lets you save your character model in the .fbx
file format. This format lets you load your models in MotionBuilder.

4 Start MotionBuilder and load your character model.

Once you load a model into MotionBuilder, you can set it up to be
animated using the MotionBuilder Character asset.

5 Add a Character asset for your character model and characterize it.
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The Character asset helps you to map out the structure of your character
model so that it can be animated in MotionBuilder. Once you have
completed this mapping process, you ‘activate’ the character model by
characterizing it. Characterizing lets MotionBuilder know that this
character model is ready to be animated.

All major character animation features in MotionBuilder, including
Control rigs and animating in the Story window, require a characterized
character.

The first tutorial, Loading and characterizing character models on page
7, shows how to create a Character asset and use it to map out your
character model’s structure.

6 Add a Control rig and customize it to fit your character animation needs.

Control rigs are an animation tool that make it easy to control and
position your character model. The second tutorial, Creating and
Customizing a Control rig on page 17, covers information on how to
customize a Control rig and how to add character animation features
such as floor contacts and Auxiliary pivots.

7 Add Character Extensions to support props or non-human body parts.

The third tutorial shows you how to augment your character with an
extra limb, in this case a ‘Servo arm’ with giant pincers attached to the
character’s right shoulder. See Creating a Character Extension on page
31.

8 Create your animation using different keyframing and character animation
features.

■ One efficient method of creating animation involves creating a set of
poses that can be pasted onto your character at various points over
time. The fourth tutorial shows how to use the Control rig and the
Pose Controls to create a walk cycle. See Creating a Walk Cycle on
page 43.

■ The seventh tutorial shows you an alternative method for creating a
walk cycle using clips in the Story window. See Creating a Loop on
page 83.

9 Edit and refine your animation.

The following tutorials show how to modify and edit animation:

■ The sixth tutorial, Editing Character Animation on page 69, shows
how to use layers to edit animation.
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■ The last tutorial, Manipulating Clips on page 99, shows how to
combine different animations using the Story window to create new
animations.

10 Retarget your animation between Character models.

Although not a necessary step in creating animation within
MotionBuilder, during animation projects, the Character model you are
using might change. Instead of re-creating the animation on the new
model, you can simply retarget the animation from your existing file.
The fifth tutorial shows how to transfer animation and Character
Extensions between character models. See Retargeting Character
Animation on page 59.

11 Plot your finished animation to your model’s skeleton.

Depending on the animation features that you are using to create your
character animation, plotting may consist of plotting from your Control
rig to your character model skeleton, or plotting the tracks in the Story
window to a single take.

Whatever method you use to animate, the finished result must be plotted
to the skeleton of your character model before you export it. See The
plotting process in the MotionBuilder Help for more information.

12 Save your plotted model as an .fbx file.

Your finished animations can also be exported for rendering in the
software of your choice using the appropriate FBX Plug-In.
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Loading and
characterizing character
models

This tutorial takes you through the steps necessary to bring your character models into
MotionBuilder and get them ready for animation.

Each character model brought into MotionBuilder has to be characterized before you can
create a Control rig, create poses, and use other animation tools. In order to characterize a
character model, you need to map out its structure.

The major steps of this tutorial include:

1 Prepare the scene on page 7

2 Complete the character map on page 9

3 Characterize the character model on page 14

Prepare the scene
In this step, you will prepare the MotionBuilder scene and open the files needed
to start this tutorial.

1 From the menu bar, select File > New, then select Layout > Editing.

MotionBuilder displays a new scene using the Editing layout. This layout
displays all the windows you need for your work in this tutorial.

2
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2 Select the Tutorials folder in the Asset browser, drag the mia_blue.fbx file
into the Viewer window, then select FBX Open > No Animation from the
contextual menu that appears.

Drag mia_blue.fbx into the Viewer window.

A model named Mia appears in the Viewer window.

Mia appears in the scene.

3 This character model was created in Maya, and the bones were named
according to the naming conventions found in MotionBuilder’s Mapping
list.

8 | Chapter 2   Loading and characterizing character models



Complete the character map
In this step, you define the structure of your character model for MotionBuilder
by completing the required nodes in the Mapping list. Character mapping
describes the character model for MotionBuilder, indicating what are the legs,
arms, and so on.

For the purposes of this tutorial, you will manually map out Mia’s structure.
You can also automatically map and characterize a character by dragging the
Character asset directly onto a character model.

1 From the Templates > Characters folder of the Asset browser, drag a
Character asset into an empty area of the scene.

Drag a Character asset from the Asset browser into the scene.

A Character asset is added in the Scene browser (A) and the Character
Settings open in the Navigator window (B).
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Navigator window A. A Character is added in the Scene browser. B. The Character
Settings display.

2 Switch to the Character Definition pane in the Character Settings and
expand the Base (required) group of nodes in the Mapping list (A).

Character Definition pane A. Base nodes

This group of nodes are required for MotionBuilder to recognize the
structure of your character model. If you had automatically characterized
this character, the Mapping list would be populated with the character’s
bone names.

3 In the Viewer window, switch to the Schematic view (Ctrl-W) and press
A to frame the hierarchy.

10 | Chapter 2   Loading and characterizing character models



Schematic view of Mia’s structure

The Schematic view makes it easier to select bones from the model’s
hierarchy because each bone is represented as a rectangular node.

4 In the Scene browser, activate the Lock option to lock the view of the
Character Definition pane.

Navigator window A. Scene browser B. Lock option

5 In the Schematic view, zoom in (Ctrl-drag) and select the Mia:LeftUpLeg
node.
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Select the LeftUpLeg node in the Schematic view.

NOTE When you know the exact name of the node you are looking for in
the Schematic view, you can press Shift-N to open the Find Model by Name
dialog box and do a quick search.

6 Alt-drag the LeftUpLeg node into the LeftUpLeg slot of the Mapping list.

Alt-drag Mia’s LeftUpLeg bone into the LeftUpLeg field.
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When you characterize this character, MotionBuilder recognizes that for
this skeleton the LeftUpLeg node is called “Mia:LeftUpLeg”.

7 Use the following checklist and figure as guides to map the rest of Mia’s
bones to the Base (required) nodes in the Mapping list.

MappedBoneSlot

Mia:HipsHips

xMia:LeftUpLegLeftUpLeg

Mia:LeftLegLeftLeg

Mia:LeftFootLeftFoot

Mia:RightUpLegRightUpLeg

Mia:RightLegRightLeg

Mia:RightFootRightFoot

Mia:SpineSpine

Mia:LeftArmLeftArm

Mia:LeftForeArmLeftForeArm

Mia:LeftHandLeftHand

Mia:RightArmRightArm

Mia:RightFore-
Arm

RightForeArm

Mia:RightHandRightHand

Mia:HeadHead
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Although Mia has many bones, you are only required to map the Base
group of fifteen for MotionBuilder characterization.

After you have completed the character mapping process for the Base
group, the Mapping list resembles the following figure:

All of Mia’s bones are mapped to the Base nodes in the Mapping
list and the character mapping is complete.

Characterize the character model
This step shows you how to characterize a model. The moment you characterize
a character model, MotionBuilder reads the structure you have outlined in
the Mapping list, taking the model’s current pose as the base for all future
poses and movement.

1 In the Character Definition pane, activate the Characterize option (A).

14 | Chapter 2   Loading and characterizing character models



Character Definition pane A. Activate the Characterize option.

2 In the Character dialog box that appears, click Biped (A), since the Mia
skeleton stands on two legs and makes contact with the floor using only
the feet.

A. Select Biped in the dialog box
that appears.

Generic offsets are calculated so that the character is compatible with
any source, the character is characterized, and MotionBuilder recognizes
its structure. The nodes in the Mapping list are gray and cannot be edited.

NOTE If you want to add more bones or edit the Mapping list later, you can
temporarily disable the Characterize option when your character is in a
T-stance.

3 In the Scene browser, right-click the Character asset, select Rename from
the contextual menu, and name the character “Mia” (A).
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Scene browser A.
Rename the Character
asset.

Your character is now fully characterized and ready to be animated.

Summary

In this tutorial, you loaded a character model, mapped out its structure, and
characterized it. In the next tutorial, Creating and Customizing a Control rig
on page 17, you will create and customize a Control rig for your characterized
character.
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Creating and
Customizing a Control
rig

This tutorial shows you how to create a Control rig and customize it for creating animation
in later tutorials. Control rigs are an animation tool that make it easy to control and position
your character model. After you have created, customized, and saved a Control rig, you can
reuse it for other models.

The major steps of this tutorial include:

1 Prepare the scene on page 17

2 Create a Control rig on page 18

3 Adjust the foot floor contact markers on page 21

4 Adjust the hand floor contact markers on page 25

5 Add Auxiliary pivots on page 26

Prepare the scene
In this step, you will prepare the MotionBuilder scene and open the files needed
to start this tutorial.

1 From the menu bar, select File > New, then select Layout > Editing.

MotionBuilder displays a new scene using the Editing layout. This layout
displays all the windows you need for your work in this tutorial.

3

17



2 Select the Tutorials folder in the Asset browser, drag the
mia_characterized.fbx file into the Viewer window, then select FBX Open
> No Animation from the contextual menu that appears. A model named
Mia appears in the Viewer.

Drag Mia_characterized from the Asset browser into the Viewer window.

Create a Control rig
In this step, you will create and prepare a Control rig for the Mia character.

1 Expand the Characters folder in the Scene browser and double-click the
Mia character (A).

The Character Settings for Mia appear in the Navigator window (B).

Navigator window A. Double-click Mia in the Scene browser B. The Character
Settings display.
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2 In the Character Settings, switch to the Character Definition pane (A)
and click Create in the Control Rig area (B).

Character Settings A. Switch to the Character Definition pane.
B. Click Create in the Control Rig area.

3 In the Create Control Rig dialog box that appears, select FK/IK (A).

Create Control Rig dialog box A.
Select the FK/IK option.

An FK/IK Control rig is created for the Mia Character.

4 In the Character Controls window, activate the Ctrl Rig In option. This
makes the Control rig the active motion source for the Mia character.

Character Controls A. Ctrl Rig
In option
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5 Click in the Viewer window, then press Ctrl-A until you are in X-Ray
display mode.

In X-Ray display mode, you can see the FK and IK effectors that make up
the Control rig. The blue and red IK effectors let you intuitively
manipulate the character using a setup that simulates how the human
body moves. The yellow FK effectors let you selectively fine-tune
individual body parts. If you plan to do any fine-tuning with your own
characters, create Control rigs with both FK and IK effectors.

6 In the Character Controls window, open the Show menu (A) and disable
the Skeleton option.

This hides the character’s skeleton so you can see the FK and IK Control
rig effectors clearly in the Viewer window (B).

A. Select the objects you want to display in the Show menu.
B. The Control rig displays on the Mia character.

7 Switch back to view the Character Settings pane (B).
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Character Settings pane A. Input Type menu B. Active
option

The Control rig is also shown as the active motion source by the Input
Type menu and the Active option in the Character Settings pane (A and
B).

Adjust the foot floor contact markers
In this step, you will adjust how the character’s feet touch the floor using the
floor contact markers.

The floor contact markers are the blue and green markers that appear around
the character’s hands and feet when you characterize your character model.
These markers create an invisible grid that determines where the character’s
feet come in contact with the floor.

When no floor object is defined in the Mapping list of the Character Definition
pane, the MotionBuilder grid is used as the floor. In this tutorial, the floor is
not defined.

1 In the Character Controls window, make sure Floor Contact is active in
the Show menu (A).
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Character Controls A. Show menu
> Floor Contact

The green and blue floor contact markers display around Mia’s hands
and feet.

Green and blue floor contact markers display around Mia’s hands and feet.

2 In the Viewer window, switch to Producer Right camera view (Ctrl-R)
and zoom in on Mia’s feet.
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Switch to Producer right and zoom in on
the feet.

3 Select one of the floor contact markers underneath Mia’s feet and translate
it, using the following guidelines and figure for the marker placement:

■ Align the middle marker where the toe bone starts (B).

■ Align the front marker with the toe of the model (A).

■ Align the rear marker with the heel of the model (C).

Placement of Mia’s foot floor contact markers A. Front marker B. Middle marker
C. Rear marker
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NOTE Moving one foot marker adjusts the other markers accordingly so
that when you adjust the green markers on Mia’s left foot, the blue
markers on the right foot are adjusted as well.

4 Switch to Producer Front view (Ctrl-F), zoom in on the feet (Ctrl-drag),
and translate the foot markers right or left to position them at the edges
of the feet as shown in the following figure.

Left and right position of the markers

5 In the Character Settings pane, expand Floor Contacts (A) and activate
the Feet Floor Contact option (B) to activate the floor contact for the feet.

Character Settings pane A. Floor Contacts group of
properties B. Feet Floor Contact option
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Adjust the hand floor contact markers
In this step, you will define the floor contact for the hands so that if Mia’s
hands touch the floor, they will react realistically.

1 In the Scene browser, double-click the Mia character to open the Character
Settings, if they are not already open.

2 In the Character Settings pane, expand Floor Contacts (A) if it is not
already expanded, and activate the Hands Floor Contact (B) and the
Fingers Floor Contact (C) options to activate the floor contact for the
hands and fingers.

Character Settings pane A. Floor Contacts B. Hands Floor
Contact C. Fingers Floor Contact

3 Expand the Hands Floor Contact Setup option and select Wrist from the
Hands Contact Type menu (A).

Character Setting pane A. Expand the Hands Floor Contact
Setup group B. Select Wrist as the Hands Contact Type.
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By default, the Hands Contact Type is set to “Normal”, which gives Mia
six hand floor contact markers. Changing this option to “Wrist” gives
each hand four floor contact markers for basic control.

4 Zoom in on one of Mia’s hands in the Viewer window. Use various camera
views, the following guidelines, and figure to place the hand floor contact
markers:

■ Align the rear hand markers with the wrist

■ Translate the rear markers lower on the Y-axis to align them with the
base of the palm

■ Align the front markers with the base of the fingers (not including
the thumb)

Placement of hand floor contact markers

Add Auxiliary pivots
In this step, you will create two Auxiliary pivots that give you additional
control over the IK system on Mia’s Control rig. These Auxiliary objects can
be used to create realistic rotation on Mia’s feet as she walks. They also make
it easier to rotate Mia’s feet while creating keyframe animation.

1 In the Character Controls window, right-click the Left Ankle cell and
select Create Aux Pivot from the contextual menu (A).
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Character Controls A.
Select Create Aux Pivot
from the Left Ankle
effector cell contextual
menu.

A new Auxiliary pivot is created for the left ankle IK effector (A). The
Auxiliary pivot displays on the left ankle cell in the Character Controls
window as a blue X (fig 14-7, B).

A. The Auxiliary pivot displays in the Viewer
window. B. A blue X represents the Auxiliary
pivot in the Character Controls.

By default, the foot effector is deselected when you create the Auxiliary
pivot, and the Auxiliary pivot is selected.

2 In the Viewer window, select Pivot from the Selection mode menu to
switch to Pivot Selection mode.
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Selection mode menu A. Select Pivot to switch to Pivot Selection mode.

3 Select the Auxiliary pivot you created, if it is not already selected, and
translate it until it is placed at the tip of Mia’s toes.

Place the Left Ankle Auxiliary pivot A. Front view B. Side view

NOTE You can use the Show menu in the Character Controls to hide the
Control rig effectors and floor contact markers as you place the Auxiliary
pivots.

4 Right-click the Left Ankle cell again and select Create Aux Pivot from the
contextual menu.
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Create a second Auxiliary
pivot on the left ankle.

A second Auxiliary pivot displays in the Viewer window.

5 Translate the second Auxiliary pivot to display at the heel of the foot.

Translate the Auxiliary pivot to display
at the heel.

Summary

During this tutorial, you created a Control rig, arranged the floor contact
markers on the character’s feet, then created two Auxiliary pivots to control
the rotation of the foot. In the next tutorial, Creating a Character Extension
on page 31, you will add a Character Extension to the Mia character.
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Creating a Character
Extension

This tutorial takes you through the steps necessary to create a Character Extension that lets
you control extra appendages for a character.

In this tutorial, you will load an additional limb for the Mia character, attach it to her using
a Character Extension, and define how it will be keyframed as part of her body.

The major steps of this tutorial include:

1 Prepare the scene on page 31

2 Connect the extra limb to the character on page 33

3 Create a Character Extension on page 37

Prepare the scene
In this step, you will prepare the MotionBuilder scene and open the files needed
to start this tutorial.

1 From the menu bar, select File > New, then select Layout > Editing.

MotionBuilder displays a new scene using the Editing layout. This layout
displays all the windows you need for your work in this tutorial.

2 Select the Tutorials folder in the Asset browser, drag mia_rigged.fbx into the
Viewer window, then select FBX Open > No Animation from the contextual
menu that appears. A characterized character named Mia appears in the
Viewer window.

4

31



Drag mia_rigged.fbx into the Viewer window.

3 Drag the servo.fbx file into the scene and select FBX Merge > No animation
from the contextual menu.

Drag servo.fbx into the Viewer window.

A Servo arm is loaded into the scene, positioned over her shoulder. In
the next steps, you will attach this arm to Mia as another limb.
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Connect the extra limb to the character
In this step you will create a Parent-Child relationship between the Servo arm
and Mia’s shoulder.

1 Switch to X-Ray display mode (Ctrl-A) in the Viewer window.

2 In the Character Controls window, select Mia as the current character
and activate the Skeleton option in the Show menu (A).

A. Activate Skeleton in the Character Controls Show menu. B. The
Skeleton displays on the Mia character.

This shows the character’s skeleton (B) and makes it easier to view and
select Mia’s shoulder bone.

3 Click in the Viewer window then do the following:

■ Press Ctrl-W to switch to the Schematic view.

■ Right-click in the Schematic view and select Auto-Arrange from the
contextual menu.

■ Press A to frame the hierarchies.

The Schematic view displays a hierarchy for Mia’s skeleton (A), her Control
rig (B), and a third hierarchy for the Servo arm (“ServoMaster”, C).
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Schematic view of hierarchies in the scene. A. Mia’s skeleton. B. Mia’s Control rig C.
The Servo arm

4 Zoom in on the Servo arm (ServoMaster) hierarchy at the right of the
view (C), and select the ServoMaster node.

Select the ServoMaster node in the
Schematic view.

5 Switch back to the Producer camera view (Ctrl-W) and zoom in on Mia’s
right shoulder. The ServoMaster node null is still selected.
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The ServoMaster null is selected in the
Viewer window.

6 Press P to activate Parenting mode, then drag the ServoMaster null to the
Mia:RightShoulder bone (A).

The bone is highlighted green as you parent the Servo arm. This parents
the Servo arm to the right shoulder bone (B).

A. Parenting the ServoMaster null to Mia’s right shoulder bone. B. After
parenting.

7 Switch to the Schematic view to verify that the Servo arm is a child of
the Mia:RightShoulder bone. When you have verified this, switch back
to the Producer Perspective view.
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Verify the parenting operation. A. Mia:RightShoulder bone B. Servo arm hierarchy

NOTE The Mia:RightShoulder node is found on the left side of the Schematic
view; right-click and select Auto arrange to clean up the hierarchy.

8 Make sure you are still in Parent mode and select the ServoControl effector
at the end of Mia’s Servo arm (A) and parent it onto Mia’s right shoulder
bone as well.

A. ServoControl effector B. Right shoulder bone.
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Create a Character Extension
In this step you will create a Character Extension that lets you connect the
Servo arm to the Mia character so that they can be controlled and keyframed
together.

1 In the Scene browser, expand Characters, right-click Mia, and select Create
Character Extension from the contextual menu (A).

Scene browser A. Create Character
Extension

2 Expand the new Character Extensions folder in the Scene browser and
view the Mia Extension (C).

Scene browser A. A
Character Extension is
added to the
character. B. A
Character Extensions
heading is added to
the Scene browser. C.
The Character
Extension is named for
the character.
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3 Alt-drag the ServoControl effector from the Viewer window onto the Mia
Extension and select Add to Mia Extension from the contextual menu
that appears.

A. Select the ServoControl effector. B. Alt-drag the
ServoControl effector onto the Mia Extension and select Add
to Mia Extension.

The Servo arm is defined as a Character Extension of Mia, and is
considered as a new “body part” of the character.

4 With the ServoControl effector still selected, open the Properties window.
The Properties window is on the right side of the interface, in one of the
Asset browser tabs.

Properties window
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5 Select the custom property Close_Open at the bottom of the list, and
drag its slider left and right. In the Viewer window, the pincer moves on
the Servo arm.

Slide the Close_Open property (B) to manipulate the Servo arm’s pincers
(A).

6 Alt-drag the Close_Open property over the Mia Extension (A) and select
Create 1 Property Reference from the contextual menu (B).

A. Alt-drag the Close_Open property to the Mia Extension. B. Select Create
1 Property Reference.
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7 Select the Mia Extension in the Scene browser in the Navigator window
(A), then activate the Lock option in the Properties window (B) so that
the Mia Extension properties stay open no matter what you select.

A. Select the Character Extension. B. Lock the Properties window.

8 Define Mia’s right shoulder bone as the Reference object for the Character
Extension by Alt-dragging the Mia:RightShoulder bone (A) into the
Reference Object field in the Properties window (B).

Drag Mia:RightShoulder (A) into the Reference object
field (B).

A Reference Object Change dialog box appears. Click Ok.

The Reference object for your Character Extension is used to calculate all
future positioning of the Extension, for example when the Character
Extension is included in a pose.
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9 You can also use the Include Part In Full Body option to define whether
you want the Character Extension to be keyed when you set keys in Full
Body Keying mode.

Summary

In this tutorial you added an extra limb to the Mia character by creating a
Character Extension. In the next tutorial, Creating a Walk Cycle on page 43,
you will animate the character and the Character Extension using the Pose
Controls.
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Creating a Walk Cycle

This tutorial guides you though the process of using poses to create a walk cycle.

The major steps of this tutorial include:

1 Prepare the scene on page 43

2 Create poses on page 44

3 Create animation with poses on page 50

4 Mirror poses on page 54

5 Play the animation on page 56

Prepare the scene
In this step, you will prepare the MotionBuilder scene and open the files needed
to start this tutorial.

1 From the menu bar, select File > New, then select Layout > Editing.

MotionBuilder displays a new 3D scene using the Editing layout. This layout
displays all the windows you need for your work in this tutorial.

2 Select the Tutorials folder in the Asset browser, drag the mia_servo.fbx file
into the Viewer window, then select FBX Open > No Animation from the
contextual menu that appears. A model named Mia appears in the Viewer.
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Drag the mia_servo.fbx file into the scene.

This character includes an extra “Servo arm” that is parented to the right
shoulder bone and added as a Character Extension.

Create poses
In this step, you will create several full body poses on your character, including
the Character Extension, that will be used in the following steps to create a
walk cycle.

1 In the Character Controls window, if she is not selected already, select
Mia in the Current Character menu (A).

Character Controls window
A. Current Character menu
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2 Ctrl-click to select the wrist and ankle effectors (A) and turn off all effector
pinning by disabling the T and R options in the Effector Pinning area
(B).

Character Controls window A. Select the Wrist and
Ankle effector cells. B. Disable the T and R pinning on
these effectors. C. Full Body Keying mode is active.

In this step, Full Body is the default keying mode (C). In Full Body Keying
mode, pasted poses are placed onto the character’s entire body, and
keyframes are placed on all effectors.

3 Select the Left Shoulder effector then press R to rotate the effector until
Mia’s left arm is in a more natural position at her side. Repeat for the
Right Shoulder and right arm.

Select the shoulder effectors, then rotate
the arms down to Mia’s sides.
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4 Select both wrist effectors and translate them upward on the Y-axis to
give the elbows a natural bend.

Select both wrist effectors and translate
them upward to create a natural bend in
the elbows.

5 Choose a camera view that lets you see a side view of the character. For
example you can press Ctrl-R to switch to the Producer Right camera
view.

Switch to Producer Right camera view.

NOTE As you work through on tutorial and manipulate the character, you
can switch the camera view at any time to get a better view.
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6 Create the first pose for the walk cycle by doing the following:

■ In the Character Controls, select the Right Hip effector then rotate
the right leg forward on the X-axis, as if Mia is stepping forward.

■ Select the Left Hip effector and rotate the left leg slightly backward
on the X-axis.

■ Select the Right Shoulder effector and rotate the right arm slightly
backward on the X-axis, then select the Left Shoulder rotate the left
arm forward as if Mia is naturally swinging her arms.

■ Select the Auxiliary pivots on Mia’s feet and rotate them until her feet
are positioned naturally.
In general, this pose should have Mia with her right leg beginning
the forward motion of a step.

The first pose for the walk cycle.

NOTE If your transformations cause Mia to float above the floor, select
the Hips effector and translate Mia downward at any time. The default
floor contact makes Mia’s feet interact naturally with the default floor.

7 In the Pose Controls window, click Create to add this pose to the Pose
browser (A), then right-click and rename the pose “Walk 01” (B). You
may need to expand the Poses folder to see the pose.
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Pose Controls A. Click
Create. B. Right-click and
rename the Pose “Walk
01.”

The position of the Character Extension is included with the position of
Mia’s body in this pose.

8 Create a second pose for the walk cycle by doing the following:

■ Position Mia’s legs and arms so that she looks similar to the following
figure. The right foot is forward and on the ground, and the left foot
is back to provide momentum.

■ Select the Mia_Ctrl:ServoControl effector, and translate the Servo arm
so it reaches in front of Mia.

■ With the Mia_Ctrl:ServoControl effector still selected, open the pincers
about half-way using the Close_Open property in the Properties
window (B).

A. The second pose for the walk cycle. B. Adjust the Close_Open
property to control the pincers.
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9 In the Pose Controls, click Create. Right-click and rename this pose as
Walk 02 (A).

Pose Controls A. Right-click
and rename the second
pose “Walk 02.”

10 Create the final pose for the walk cycle by doing the following:

■ Position Mia’s legs and arms so that her step appears similar to the
following figure.

■ Select the Mia:ServoControl effector and extend the Servo arm to
reach even further in front of Mia.

■ With the Mia:ServoControl still selected, use the Close_Open property
in the Properties window to open the pincers further (B).
In this pose, the left leg goes back, and the Servo arm goes forward,
completing one step for the first half of the walk cycle.

A. The third pose for the walk cycle. B. The Close_Open property.
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11 In the Pose Controls, click Create. Right-click and rename this pose as
Walk 03.

You now have three poses listed in the Scene browser.

The three poses you have
created are listed in the
Pose browser.

Create animation with poses
In this step, you will use the three poses you have created to create one half
of a walk cycle. By keyframing these poses at different frames, you will create
a short walking animation.

1 In the Character Controls window, deselect any effectors that are still
selected, and ensure that Full Body keying mode is selected (A).

Character Controls A. Full
Body Keying mode is
selected.
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2 In the Pose browser, double-click the Walk 01 pose to paste it on Mia.

Pose Controls A. Double-click the Walk 01 pose. B. The
Walk 01 pose is pasted on Mia.

By default, the Gravity, Translation, and Rotation options are active in
the Match area. This means that the translation and rotation of the pasted
pose match the translation and rotation of the selected effector on the
current character. The Gravity option ensures that the feet stay at the
original level of the pasted pose (normally floor level).

3 Select the Hips effector, then go to frame 0 in the Transport Controls.

A. Select the Hips effector. B. Go to frame 0.

4 In the Key Controls window select Layer 1 from the Layer menu (A), then
click Flat to set a Flat keyframe (B). You can also press Ctrl-K on the
keyboard to set a Flat keyframe.
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Key Controls A. Select
Layer 1. B. Click Flat.

5 In the Key Controls Warning dialog box that appears, activate the Don’t
Remind Me Again option (A), then click Set Multi Layer (B).

Key Controls Warning dialog box A.
Activate Don’t remind me again. B. Click
Set Multi Layer.

Selecting Set Multi Layer lets you set keyframes on the Mia:ServoControl
effector on many different layers, instead of only on the Base Layer.

The keyframe is placed on Layer 1 on the full body position of the
character, as indicated in the Key Controls window (A and B). The keying
mode reflects the selected option in the Keying Mode area of the Character
Controls window.

Key Controls A. Layer 1 is
selected. B. Full Body
keying mode is selected.

6 Go to frame 5 and do the following :

■ Double-click the Walk 02 pose to paste it on Mia.

■ Press Ctrl-K to set a Flat keyframe.
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Frame 5 A. Select the Walk 02 pose. B.
Paste the pose on Mia and set a Flat
keyframe.

7 Go to frame 10 and do the following:

■ Double-click the Walk 03 pose to paste it on Mia.

■ Press Ctrl-K to set a Flat keyframe.

Frame 10 A. Select the Walk 03 pose. B.
Paste the pose on Mia and set a Flat
keyframe.
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8 Drag the Timeline indicator through the animation to view the step you
have created.

The interpolation between the three keyframes creates the movement
for one step.

Mirror poses
In this step, you will mirror the three poses from the Pose browser to create
the second half of the walk cycle. By keyframing these mirrored poses after
the original poses, you will complete the short walking animation.

1 In the Match area of the Pose Controls window, activate the Mirror option
(A).

Pose Controls A. Activate
the Mirror option

2 Go to frame 15 and do the following:

■ Double-click the Walk 01 pose to mirror-paste it on Mia (A).
The Walk 01 pose is pasted and mirrored onto the character (B).
Because you mirror-pasted the pose, the left leg is now forward, and
the right leg is behind to continue the walk cycle on the other side.

■ Press Ctrl-K to set a Flat keyframe.
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Frame 15 A. Select the Walk 01 pose. B.
Paste it onto Mia and set a Flat keyframe.

3 Go to frame 20 and do the following:

■ Double-click the Walk 02 pose to mirror-paste it (A).

■ Press Ctrl-K to set a Flat keyframe.

Frame 20 A. Select the Walk 02 pose. B.
Paste it onto Mia and set a Flat keyframe.

4 Go to frame 25 and do the following:

■ Double-click the Walk 03 pose to mirror-paste it (A).
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■ Press Ctrl-K to set a Flat keyframe.

Frame 25 A. Select the Walk 03 pose. B.
Paste it onto Mia and set a Flat keyframe.

Your animation now consists of six keyframes. The first three keyframes
were mirrored onto the left side of the character, creating a complete
walking movement. To complete a full animation cycle, your take should
begin and end with the same position.

5 On the Action timeline, copy the keyframe at frame 0 to frame 30 by
C-dragging the keyframe from frame 0 to frame 30.

Copy the keyframe at frame 0.

The animation now begins and ends on the same position, creating a
complete cycle.

Play the animation

1 Click on the Action timeline, then press Ctrl-Shift-A to frame the
animation on the Action timeline to its full length of 30 frames.
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Press Ctrl-Shift-A to frame the animation you have created. A. Loop option

2 In the Transport Controls window, click Loop (A), then click Play.

As the animation plays, each loop shows a full walk cycle.

In your animation, the movement may be a bit choppy, and the feet may
slide on the floor. You can smooth your movement by adjusting the
animation’s function curves in the FCurves window.

Summary

During this tutorial, you created poses on a character, set keyframes of these
poses at different points, and quickly created a walk cycle. You can also save
poses in an .fbx file, which lets you reuse your poses at any time.

In the next tutorial, Retargeting Character Animation on page 59, you will
learn how to retarget animation and a Character Extension from one character
to another. You can also try Creating a Loop on page 83 if you want to learn
how to create a walk cycle using the Story window.
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Retargeting Character
Animation

This tutorial shows you how to retarget animation from one characterized character to another.
Since the source character includes a Character Extension and the target character does not,
you must also retarget the Character Extension.

The major steps of this tutorial include:

1 Prepare the scene on page 59

2 Save the character animation on page 61

3 Create a new scene on page 62

4 Load character animation on page 63

5 Play the animation on page 66

Prepare the scene
In this step, you will prepare the MotionBuilder scene and open the files needed
to start this tutorial.

1 From the menu bar, select File > New, then select Layout > Editing.

MotionBuilder displays a new scene using the Editing layout. This layout
displays all the windows you need for your work in this tutorial.

2 Select the Tutorials folder in the Asset browser, drag the
mia_fk_runstopturn.fbx file into the Viewer window, then select FBX Open
> All takes from the contextual menu that appears. A model named Mia
appears in the Viewer along with her “Servo arm” Character Extension.

6

59



A. Drag the mia_runstopturn.fbx file into the Viewer window. B. Mia
appears in the Viewer window.

3 In the Character Controls, select Mia in the Current Character menu (A).

Character Controls A. Select
Mia in the Current Character
menu.

4 In the Transport Controls, click Play view the animation on the Mia
character.

Transport Controls A. Play button
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Save the character animation
In these steps, you will save the character animation using the Save Character
Animation option. This prepares the animation to be easily loaded using the
Load Character Animation option.

1 In the Character Controls window, select Save Character Animation from
the File menu (A).

Character Controls A. Select File > Save
Character Animation.

2 Navigate to where you want to save the character animation, enter a file
name, and click Save.

Save File dialog box
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3 In the Save Character Animation Options dialog box that appears, make
sure that the Save Character Extensions option is activated, then click
Save.

Save Character Animation Options dialog box

The animation is saved as an .fbx file, including the Character Extension.

Create a new scene

1 Press Ctrl-N to create a new scene.

2 In the Save changes dialog box appears, click Don’t Save.

Save changes dialog box

3 From the Asset browser, drag the dancer.fbx file into the scene, and select
FBX Open > No animation.
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Drag the dancer.fbx file into the scene.

4 In the Character Controls, select Dancer in the Current Character menu.

Character Controls A.
Select Dancer as the
current character.

Load character animation

1 In the Character Controls window, select Load Character Animation from
the File menu.
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Character Controls A. Select File > Load
Character Animation

2 Navigate to select the .fbx file you saved earlier in this tutorial and click
Open.

Select the animation file you saved earlier.

3 In the Load Character Animation Options dialog box that appears, do
the following:

■ Select the Plot to Control Rig option in the Load Technique area (A).

■ Make sure the Replace Control Rig option in the Control Rig area is
activated (B).

■ Activate the Reset Control Rig’s Rotation DOF option (C).

■ Make sure the Copy Missing Character Extensions option is activated
in the Character Extensions area (D).

■ Click Open.
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Activate the following in the Load Character Animation
Options dialog box: A. Plot to Control Rig B. Replace
Control Rig C. Reset the Control Rig’s Rotation DOF D.
Copy Missing Character Extensions

Mia’s animation and her Control rig are loaded onto the Dancer character.
Because Mia’s Servo arm was parented to her right shoulder FK effector,
the Servo arm is attached in the same way to the Dancer character.

Mia’s animation and her Control rig are
loaded onto the Dancer character.
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Play the animation

1 Click Play in the Transport Controls (C) to play the animation and observe
how both the Servo arm and the animation are transferred onto the
Dancer character (A).

A. The Dancer runs, turns, and stops, using Mia’s animation. B. Dancer’s
Control rig is left in the middle of the scene. C. Play button

2 Notice that Dancer’s original Control rig is left in the middle of the scene
(B).

This happens because you selected Replace Control Rig in the Load
Character Animation Options dialog box. Dancer’s Control rig has been
replaced by Mia’s.

3 In the Scene browser, expand Control Rigs and right-click Control rig
(Dancer’s original Control rig) and select Delete to clean up the scene.

Scene browser A. Right-click Dancer’s
Control rig and select Delete.
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Summary

During this tutorial, you retargeted animation from one characterized character
to another. You also transferred the Character Extension from the source
character to the target character.

In the next tutorial, Editing Character Animation on page 69, you will learn
how to edit existing animation on a separate layer from your original
animation, then merge all layers together.
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Editing Character
Animation

This tutorial shows you how to modify existing animation by creating new layers of animation.
You will modify the animation, which is already plotted to the character’s Control rig, on
two separate layers, then combine the original animation and your modified animation.

The major steps of this tutorial include:

1 Prepare the scene on page 69

2 Modify the Character Extension animation on page 70

3 Modify the head animation on page 75

4 Plot the animation on page 80

5 Play the resulting take on page 81

Prepare the scene
In this step, you will prepare the MotionBuilder scene and open the files needed
to start this tutorial.

1 From the menu bar, select File > New, then select Layout > Editing.

MotionBuilder displays a new scene using the Editing layout. This layout
displays all the windows you need for your work in this tutorial.

2 Select the Tutorials folder in the Asset browser, drag the mia_runstopturn.fbx
file into the Viewer window (A), then select FBX Open > All Takes from
the contextual menu that appears. A model named Mia appears in the
Viewer (B).
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A. Drag the mia_runstopturn.fbx file into the Viewer. B. The Mia character
loads.

3 Click in the Viewer window, then press Ctrl-R twice to switch to Producer
Left camera. Zoom out to view the entire grid.

Select the Producer Left camera view and zoom out to view the whole animation.

Modify the Character Extension animation
In this step, you will create a new layer and modify the animation of the Servo
arm Character Extension.
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1 Play the entire take (Ctrl-Spacebar) to view all the motion, paying special
attention to the Servo arm.

Right now, the Servo arm bounces along in front of Mia, pointing towards
the red wire-frame effector. Although this effector is parented to Mia’s
shoulder, the effector moves enough to cause the Servo arm to jump
around while Mia runs.

2 Press Ctrl-Home to go back to the beginning of the take, then play it
again to frame 50.

Mia at frame 50.

3 In the Key Controls, select Layer 1 from the Layer menu (A).

Key Controls A. Select
Layer 1 from the Layer
menu.

This lets you set keyframes on a separate layer, while preserving the
original animation on the Base Layer.

4 Select the Mia:ServoControl effector (A) then click Zero in the Key
Controls to set a Zero keyframe (B).
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A. Select the Mia:ServoControl effector B. Set a Zero
keyframe.

5 In the Key Controls Warning dialog box that appears, activate the Don’t
Remind Me Again option (A), then click Set Multi Layer (B).

Key Controls Warning dialog box A.
Activate Don’t remind me again. B. Click
Set Multi Layer.

Selecting Set Multi Layer lets you set keyframes on the Mia:ServoControl
effector on many different layers, instead of only on the Base Layer.

6 With the Mia:ServoControl effector still selected, go to frame 150 and
set a Zero keyframe.
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Frame 150 A. Mia:ServoControl is still selected. B. Set
a Zero keyframe.

7 Go to frame 80.

At this frame, you are going to start modifying the animation so that Mia
raises her Servo arm.

Frame 80

8 Do the following:

■ Click in the Viewer window and press T to activate Translation mode.

■ At the bottom of the Viewer window, set the Translation XYZ values
to 190, -10, 20 (A).
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■ Set a keyframe (B).

Frame 80 A. Set the Translation values. B. Set a keyframe.

9 Go to frame 120 and do the following:

■ Set the Mia:ServoControl effector Translation XYZ values to 96, 24,
91 (A).

■ Set a keyframe (B).

Frame 120 A. Set the Translation XYZ values. B. Set a
keyframe.
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10 Go to frame 140 and do the following:

■ Set the Translation XYZ values to 112, -31, 12 (A).

■ Set a keyframe (B).

Frame 140 A. Set the Translation XYZ values. B. Set a
keyframe.

11 Play the animation.

Now, Mia’s Servo arm raises up as she runs.

Modify the head animation
In this step, you will use another layer to improve the animation by making
Mia turn her head as she runs, when she stops, and again just before she turns
around.

1 Go to frame 30.

At this frame, Mia’s head is pointed straight ahead in the direction she
is running. You will modify the motion so that Mia turns her head.

Modify the head animation | 75



Mia at frame 30.

2 In the Key Controls window, select New Layer from the Layer menu (A)
to create a new layer where you will modify the head animation.

Key Controls window A.
Layer menu > New Layer
option

A new layer called “Layer 2” is added.

3 In the Character Controls window, select the head effector (A), and switch
to Body Part keying mode (B).
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Character Controls window
A. Select the Head effector.
B. Switch to Body Part
keying mode.

You can use Body Part keying mode as you create animation on this layer,
since you only need to set keyframes on the head, not the entire body.

4 In the Key Controls, click Zero to set a zero keyframe (A).

Key Controls A. Zero
keyframe button

5 Go to frame 150 and set another Zero keyframe.
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Frame 150 A. Set a zero keyframe.

6 Go to frame 60 and do the following:

■ With the Head effector still selected, activate Rotation mode (click in
the Viewer window and press R).

■ Change the Rotation XYZ properties at the bottom of the Viewer
window to 35, 0, 2 (A).

■ Set a keyframe (B).

Frame 60 A. Set the XYZ Rotation properties. B. Set a
keyframe.
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7 Go to frame 90 and do the following:

■ Set the Rotation XYZ values to 42, 0, -5 (A).

■ Set a keyframe (B).

Frame 90 A. Adjust the Rotation values. B. Set a keyframe.

8 Go to frame 105 and do the following:

■ Set the Rotation XYZ values to 30, -5, 0 (A).

■ Set a keyframe (B).

Frame 105 A. Adjust the Rotation values. B. Set a keyframe.
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9 Deselect the Head effector, and play your animation.

Mia’s head turns as she runs.

Plot the animation
In this step, you will plot your animation data to combine the original data
with your new animations. Plotting merges all of the animation to the Base
Layer.

1 From the Edit menu in the Character Controls window, select Plot
Character (A). You can also use the Plot Character button in the Character
settings.

Character Controls window A.
Select Plot Character from the
Edit menu.

2 In the first Character dialog box that appears, click Skeleton (A), then
click Plot in the second Character dialog box that appears (B).
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Character plotting dialog boxes A. Click Skeleton. B. Click Plot.

All the animation data is transferred from the Control rig to the character’s
skeleton on the current take. You can see your plotted data in the FCurves
window as a series of function curves with numerous keyframes.

Play the resulting take
Play the take and observe your animation.

The animation of the Servo arm rising up and the head turning are merged
with the original animation of Mia running and turning around.

Summary

In this tutorial, you modified original animation by setting new keyframes
on two separate layers, then merged all the animation together in one take.
In the next tutorial, Creating a Loop on page 83, you will learn how to create
a walk cycle using the Story window.
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Creating a Loop

This tutorial guides you through the process of animating a character and creating a walk
cycle with the Story window.

The major steps of this tutorial are:

1 Prepare the scene on page 83

2 Create a Character track on page 84

3 Create poses on page 89

4 Matching clips on page 91

5 Processing the clips on page 94

6 Testing the walk cycle on page 96

Prepare the scene
In this step, you will prepare the MotionBuilder scene and open the files needed
to start this tutorial.

1 From the menu bar, select File > New, then select Layout > Story.

MotionBuilder displays a new 3D scene using the Story layout. This layout
displays all the windows you need for your work in this tutorial.

2 Select the Tutorials folder in the Asset browser, drag the mia_servo.fbx file
into the Viewer window (A), then select FBX Open > No Animation from
the contextual menu that appears.

A model named Mia appears in a T-stance in the Viewer (B)
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A. Drag mia_servo into the Viewer window. B. Mia appears in the
scene.

Create a Character track
In this step, you will create a Character track in the Story window, define the
character affected by the track, and add some animation.

1 In the Story window, right-click in the Action Track list (A) and select
Insert > Character Animation Track from the contextual menu.

Story window A. Action Track list
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A Character Animation track is added (A).

Story window A. Character track

2 Select Mia in the track’s Character menu (A).

Story window A. Select Mia in the Character menu.

3 Drag walkaround.fbx from the Asset browser to the Character track.
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Drag the walkaround.fbx file into the Character track.

4 Drag the clip so that it begins at frame 0. The clip should end at frame
98.

Drag the clip to frame 0 on the Character track.

NOTE You can Ctrl-drag to zoom and Shift-drag to pan in the Character
track.

5 Play the animation (Ctrl-Spacebar).
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At frame 0, the character’s right foot is in front and the left foot is in
back. At frame 98, Mia is turning. If you were to loop the animation at
this point, there would be a jump in the walk cycle.

6 Go to frame 40. At this frame, Mia’s right foot is flat on the ground and
her left foot is slightly lifted.

Change your camera view so you can see Mia from the front.

Mia at frame 40.

7 With the clip still selected, click the Razor button (A).

Story window A. Razor button

The clip is sliced in two at frame 40.
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The original clip is sliced in two.

8 Go to frame 75. At this frame, Mia is in almost the same pose as she was
at frame 40.

Mia at frame 75.

9 Select the second clip if it is not already selected, then click the Razor
button.

The second clip is sliced at frame 75, and you now have three clips.

Three clips in the Character track

10 Ctrl-click the first clip, so that the first and third clips are selected, then
press Delete, as you only need the middle clip.

11 Drag the remaining clip to start at frame 0.

The clip starts at frame 0 and ends at frame 35.
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Create poses

1 Go to frame 0 (Ctrl-Home).

2 In the Character Controls window, if she is not already selected, select
Mia from the Current Character menu (A), then select the Hips effector
(B).

Character Controls window
A. Select Mia from the
Current Character menu.
B. Select the Hips effector.

3 Switch to the Pose Controls pane in the Asset browser and click Create
(A) to create a pose. Expand the Poses folder to see the pose you created,
called “Mia Pose” by default (B).

Pose Controls window A.
Create button B. Mia Pose
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4 Go to frame 35 and do the following:

■ In the Story window, activate the Accept Keys option (A) in the
Character track. You can only paste poses on a track when the Animate
option is active.

Character track A. Activate the Accept Keys option.

■ Switch back to the Character Controls window, right-click the Right
Ankle effector (A) and select RightAnkleEffector from the menu that
appears.

Character Controls window
A. Right Ankle effector

■ In the Pose Controls window, click Paste (A).

Pose Controls window A.
Paste button
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A one-frame clip appears on the Character track at frame 35.

This clip contains the data of the pose you pasted. Now Mia starts and
stops walking with exactly the same pose.

Character track A. New clip at frame 35.

5 Jog (J-drag) through the animation very slowly. Though the animation
begins and ends with the same pose, there is a slight jump between the
clips. In the following steps, you will remove the jump.

Matching clips
In this step, you will match and blend the two clips to remove the jump in
the animation.

1 Click in an empty space below the track, and press A to zoom in on the
clips.

2 Select the second clip.

Character track A. Select the second clip.

3 Make sure the Right Ankle effector is still selected in the Character
Controls window (A).
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Character Controls window
A. Right Ankle effector

4 In the Story window, click the Match button (A).

Story window A. Match button

5 In the Match Options dialog box that appears, click OK (A).
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Match Options dialog box A. OK
button

6 With the second clip still selected, go to Window > Add Asset Settings.
Double-click the second clip to display the setting for the clip and set a
value of 29 in the In field (A) in the Asset Settings window.

Asset Settings window A. Set the In point to frame 29.

7 Enter value of 35 in the In field (A) in the Asset Settings window

8 The second clip now starts at frame 29, and cross-blends with the first
clip to end at frame 35. This blend creates a slightly smoother transition
between the clips.

Matching clips | 93



The second clip starts at frame 29 and ends at frame 35.

9 Play the animation. Mia walks, starting and ending with the same pose.

Processing the clips
In this step, you will process the two clips to save them as a single result clip.
Later, you will use this new clip to animate a different character.

1 Right-click on the Character track near the Character name and select
Frame Start/End from the contextual menu (A). The time range is resized
to fit the length of the clips.

Character track contextual menu A. Select the Frame Start/End option.

2 Right-click the Character track again and select Process Track/Subtracks
To New Clip from the contextual menu (A).
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Character track Contextual menu A. Select the Process Tracks/Subtracks
To New Clip option.

3 Click OK in the dialog box that appears.

Process Track and
Subtracks dialog box

4 In the Save Clip dialog box that appears, save your new clip as
mia_walk_cycle.fbx.

You will need the saved clip to complete this tutorial.
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Save Clip dialog box

In the Story window, a second Character track appears containing the
new mia_walk_cycle.fbx clip (A).

Story window A. New mia_walk_cycle.fbx clip

Testing the walk cycle
In this step, you will test the new walk cycle clip to see if it loops smoothly.

1 Make sure that the Loop/Scale option is set to Loop, as shown in (A).

Story window A. Loop/Scale option is set to Loop.
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2 Zoom out on the Character tracks, then stretch the end of the
mia_walk_cycle clip to frame 140 (A). The clip loops four times.

Character tracks A. Stretch the clip to frame 140.

3 Right-click any Character track and select Frame Start/End from the
contextual menu.

4 Click the first Character track’s Mute button (A) to disable the track.

Character tracks A. Click Mute.

5 Play the animation. Mia walks smoothly for 140 frames.

Summary

In this tutorial, you took a short clip of animation and turned it into a looping
walk cycle. In the next tutorial, Manipulating Clips on page 99, you will learn
how to edit character animation by modifying clips.
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Manipulating Clips

This tutorial guides you through the process of modifying character animation by manipulating
clips.

The major steps of this tutorial are:

1 Prepare the scene on page 99

2 Create a turn on page 101

3 Blend two clips on page 104

4 Add another clip on page 106

5 Match clips on page 107

Prepare the scene
In this step, you will prepare the MotionBuilder scene and open the files needed
to start this tutorial.

1 From the menu bar, select File > New, then select Layout > Story.

MotionBuilder displays a new scene using the Story layout. This layout
displays all the windows you need for your work in this tutorial.

2 Select the Tutorials folder in the Asset browser, drag the mia_story.fbx file
into the Viewer window (A), then select FBX Open > All Takes from the
contextual menu that appears.

A model named Mia appears in the Viewer window (B). In the Story
window, there is a track with a clip called Clip_Run_Loop. Mia is selected
in the track’s Character menu.
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A. Drag the mia_story.fbx file into the Viewer window. B. Mia appears in
the scene.

3 In the Story window, click on the Character track (A) and press A to frame
the clip.

Story window A. Character track with one clip

4 Play the animation (Ctrl-Spacebar). You may need to zoom out in the
Viewer window to see all of the animation.
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Create a turn
In this step, you will slice a clip in two, then rotate a ghost clip vector to make
Mia turn as she runs.

1 Go to frame 14.

At this frame, Mia’s left foot is flat on the ground.

Mia at frame 14.

2 Select the clip (B) and click the Razor button (A).

Story window A. Razor button B. Selected clip

The clip is sliced into two clips at frame 14 (A).
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Character track A. The clip is sliced in two at the current time.

3 Switch to the X-Ray display mode in the Viewer window, then make sure
the Ghost option in the Character track (A) is activated.

Character track A. Ghost option is active.

4 Go to frame 0 (Ctrl-Home).

When the Ghost option is active, ghosts display in the Viewer window.
Clip vector ghosts represent the start and end of each clip. For each clip,
there is one clip vector ghost that you can select and manipulate (B and
C).

Mia at frame 0. A. Model ghost B. First clip’s ghost clip vector C. Second clip’s
ghost clip vector.

5 In the Story window, select the second clip if it is not still selected (A).

The ghost clip vector of the selected clip is also selected in the Viewer
window.

Character track A. The second clip is still selected.
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6 Click in the Viewer window and press R. Rotation rings appear at one
end of the selected clip vector ghost (A).

If the rings do not appear at the same point of the clip vector as shown
in the following figure, double-click on the clip vector’s In point (B) to
select it.

A. Rotation rings B. Second ghost clip vector’s In point.

7 In the Viewer window, enter a value of -70 in the Rotation Y-axis field
(A). The clip vector turns to Mia’s right (B).

You can also rotate the clip vector manually by dragging the green
rotation ring.
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A. Enter a value of -70. B. The ghost clip vector is rotated.

8 J-drag in the Viewer window to jog through frames 10 to 20 slowly. The
Mia turns as she runs, but her foot jumps slightly at frame 14. You need
to blend the clips to remove the jump.

Blend two clips
In this step, you will blend two clips to remove a jump in animation that
occurs when Mia turns.

1 Make sure that the Loop option (A) is active in the Story window.
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Story window A. Loop/Scale option is set to Loop.

2 Select Window > Add Asset Settings from the MotionBuilder menubar,
and double-click the first clip to display its settings in the Asset Settings
window.

3 Set set a value of 19 in the Asset Settings Out field (A).

Asset Settings window A. Enter 19 in the Out field.

The first clip overlaps the second clip, creating a cross-blend (A).

Character track A. Cross-blend between the two clips.

4 Play the animation. There is no longer a jump at frame 14.
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Add another clip
In this step, you will add another clip to the Character track in the Story
window.

1 Ctrl-drag in an empty space beneath the Character track to zoom out
and make room next to the existing clips.

2 From the Tutorials folder in the Asset browser, drag the run_boom.fbx file
(fig 45-3, A) onto an empty part of the existing Character track, to the
right of the clips that are already there (fig 45-3, B).

A. Drag the file onto the track. B. The new clip

3 Drag the clip so that it begins at frame 46. It should rest against the end
of the second clip.

The new clip begins at frame 46.

4 Deselect the new clip, then right-click the Character track and select
Frame Start/End from the contextual menu.

5 Play the animation (Ctrl-Spacebar).
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Mia runs, turns, there is a jump in the animation, then Mia is thrown
forward as if propelled by an explosion.

Match clips
In this step, you will match the last clip to the previous clip to remove the
jump in the animation.

1 Go to frame 0.

2 In the Viewer window, switch to the Schematic view and select the
Mia:RightFoot node (A).

This node represents Mia’s right foot and will be used as the matching
object.

Schematic view A. Select the Mia:RightFoot node.

3 Switch back to the Producer Perspective camera view.

4 In the Story window, select the third clip (A), then click the Match
Options button (B).
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Story window A. Select the third clip. B. Match Options button

5 In the Match Options dialog box that appears, do the following:

■ Make sure that Mia:RightFoot is selected in the Match Object menu
(A).

■ Select To Previous Clip (B) and Between Previous Clip and Selected
Clip (C).
The Translation and Rotation options are already selected.

Match Options dialog box A.
Match Object menu B. To
Previous Clip option C. Between
Previous Clip and Selected Clip

6 Click OK.
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The last clip vector moves to match the previous clip.

7 Deselect Mia:RightFoot.

8 Play the animation.

Mia runs, turns, then is thrown forward. The jump in the animation is
gone.

Summary

In this tutorial, you sliced a clip of running animation in two and rotated one
clip vector ghost to make the character turn while running. Then you added
another clip with different animation and blended all three clips together in
one seamless animation sequence.
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3ds Max-MotionBuilder
Interoperability

The following set of tutorials shows you how to import a character created in 3ds Max to
MotionBuilder, add animation, and then export your work back to 3ds Max as a fully-editable
animated character.

NOTE A similar set of tutorials appear in the 3ds max documentation.

The major steps of this tutorial are:

1 Label 3ds Max biped skeletons for easy conversion in MotionBuilder.

2 Export a 3ds Max biped as an FBX file, then import to MotionBuilder.

3 Characterize skeletons in MotionBuilder for animation as a full FK/IK rig.

4 Use naming templates and scripts to quickly characterize skeletons.

5 Animate a character in MotionBuilder based on motion capture data.

6 Use keyframes to fine-tune character movement.

7 Export character animation as an FBX file from MotionBuilder, then import to 3ds Max.

8 Fine-tune character animation in 3ds Max.

Preparation for This Tutorial

This tutorial show you how to export characters in FBX format from 3ds Max to MotionBuilder.
In order to do so, you need to have the latest FBX driver installed on your machine.

■ In your browser, type www.autodesk.com/fbx and follow the download instructions. As
you do so, be sure to specify the folder location of your 3ds Max program.
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You can find all the files used for these tutorials in the Asset browser Tutorials folder. When
opening files in 3ds Max, you can locate them in C:\\Program Files\Autodesk\MotionBuilder
2009\Tutorials.

Importing 3ds Max scenes to MotionBuilder
This tutorial shows you how to take characters created in 3ds Max and prepare
them for import to MotionBuilder.

The major steps of this tutorial are:

1 Skeleton naming conventions on page 112

2 Create and rename a biped on page 118

3 Export a skeleton on page 120

4 Export a character on page 124

5 Importing a 3ds Max skeleton on page 129

Skeleton naming conventions

This step introduces you to 3ds Max skeleton bone hierarchy and naming
conventions, which are important to understand before exporting scenes to
MotionBuilder.

NOTE There are three different 3ds Max skeletons and each is exported to
MotionBuilder in a different way. These tutorials show you how to work with each
skeleton type.

To view the different 3ds Max skeleton naming conventions:

1 In 3ds Max, choose File > Open, navigate to the C:\\Program
Files\Autodesk\MotionBuilder 2009\Tutorials folder and open basics.max.

NOTE If your system units are set to anything other than Centimeters, a File
Load: Units Mismatch dialog box opens, prompting you to choose which
unit scale to use. Turn on Adopt the File Unit’s Scale and click OK.
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The scene contains, from left to right, a mesh character called MIA, and
three skeletons that can be used to drive the mesh.

Mesh and three skeletons

Skeleton A is made up of a conventional bone system. Skeletons B and
C are bipeds created automatically from the 3ds Max biped creation
option.

Before MotionBuilder recognizes a model as a character that can be
animated, its skeleton bones must be characterized. A model can be
characterized only if its bones are labeled in a specific way. You can
rename character bones in MotionBuilder, but it is a good idea to rename
them properly in 3ds Max wherever possible.

2 Region-select, then right-click Skeleton A and from the menu, choose
Isolate Selection.
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Skeleton created from a conventional bone system

3 On the main toolbar, click Select By Name.

4 On the Select From Scene dialog box, scroll down to view the skeleton
hierarchy and see how each bone is named.
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This is the naming convention that MotionBuilder recognizes. If you
name the skeleton bones this way, you can characterize them in
MotionBuilder.

5 Close the Select From Scene dialog box and click Exit Isolation Mode to
redisplay the scene.

Skeleton naming conventions | 115



6 Region-select, then right-click Skeleton B and from the menu, choose
Isolate Selection.

7 On the main toolbar, click Select By Name.

The Select From Scene dialog box opens, showing the bone hierarchy of
the Skeleton B and its identifying names. This naming convention, while
different to that used in Skeleton A, is also recognized by MotionBuilder
to convert skeletons for animation.

8 Repeat steps 5 to 7 to isolate Skeleton C and view its skeleton hierarchy.
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Even though the suffix of each bone in Skeleton C is identical to Skeleton
B, its prefix, MIA, is different and MotionBuilder cannot characterize the
bones automatically. You can still manually characterize, but it is easier
to use MotionBuilder’s automatic characterization. (Manual
characterization is covered in Manually mapping and characterizing a
character.)

The next step reviews how to create and rename a biped. If you already
know how to create and rename bipeds in 3ds Max, skip this and go to
the next lesson, Export a skeleton on page 120.
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Create and rename a biped

This procedure shows you how to create and rename a biped in 3ds Max.

To create and rename biped in 3ds Max:

1 Follow the steps in the previous lesson (Skeleton naming conventions
on page 112) to create a skeleton.

2 Exit isolation mode. On the Create panel, click Systems and on the Object
type rollout, click biped.

3 Click on any empty area in the viewport and drag to create the biped.
Continue dragging until you reach the desired body height.

The Create Biped rollout > Root Name box displays the name of the new
biped. This box is where you rename your biped, if needed.
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NOTE Each time you create a biped in a scene, its number increments by
one (e.g Bip01, Bip02, Bip03 and so on).

Renaming a biped after creating it

You can rename a biped any time after you create it with the
followingprocedure:

To rename a biped that already exists:

1 On the main toolbar, click Select Object, then select any bone on the
new biped.

The Name and Color rollout displays the bone’s name and its Bip prefix.

NOTE If the biped has any prefix other than Bip01, more effort is required
to characterize its bones in MotionBuilder.

2 Go to the Motion panel, expand Modes and Display, type BOB in the
Name box and press Enter.
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3 On the main toolbar, click Select By Name.

The Select From Scene dialog box opens, showing the bone hierarchy of
your biped. Each bone now displays the BOB prefix you specified in the
previous step.

The next step shows you how to export your scene to MotionBuilder.

Export a skeleton

This step shows you how to export 3ds Max scene data in FBX format to
MotionBuilder. You can export an entire scene, or only a portion of the scene
containing selected elements.

To Export skeleton A in FBX format:

1 In 3ds Max, open the basics.max scene file from the C:\\Program
Files\Autodesk\MotionBuilder 2009\Tutorials folder. If you are
continuing from the previous lesson, from the main menu, choose File
> Reset, do not save any changes, then reopen basics.max.

2 Region-select all of skeleton A.
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NOTE The skeleton has been positioned in a “T” pose, the stance used by
animators for skinning. Always place your characters in this position before
exporting to MotionBuilder. Also, orient skeletons in the minus Y axis direction.
(All bipeds created from the 3ds Max biped system are automatically oriented
this way.)

Export a skeleton | 121



Biped oriented a minus Y direction

3 From the main menu, choose File > Export Selected.

4 On the Select File To Export dialog box > File Name box, type
mybone-skeleton and click Save.

The file is automatically saved in FBX format to your project’s Export
folder and the FBX Exporter opens. Here, you specify how to convert the
3ds Max scene information.

NOTE For proper conversion, you must have the latest FBX plug-in installed.
Click the Check for Web Updates button in the lower left of the FBX Exporter
window to verify if you have the latest plug-ins. If you do not, the Check for
Web Updates button takes you to the Autodesk FBX web page where you
can download an update.
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5 On the FBX Export dialog box > Include rollout, disable Animation.

This option is only active when the scene you want to export has
animation.

6 Make sure Embed Media is also disabled.

If you were exporting a mesh with a character, the Embed Media option
would embed any texture maps associated with the character in the FBX
file. But since you are exporting a skeleton only, this option is not needed.

7 On the Axis Conversion rollout, make sure Up Axis displays the Y-up
option.

This setting assigns the exported character a Y-up axis, the orientation
used by objects in MotionBuilder. This setting is required since objects
created in 3ds Max use a Z-up orientation.
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8 Click OK to export skeleton A as an FBX file to your designated folder.

NOTE Typically, you would export a mesh, properly skinned onto a skeleton.

Now that your skeleton is prepared you can export it into MotionBuilder.

Export a character

This step shows you how to export a 3ds Max character to MotionBuilder.

To export the Pepe character:

1 From the 3ds Max main menu, choose File > Open.

2 Do not save your scene file when prompted, and from the Open File
dialog box, choose Pepe_biped.max from the C:\\Program
Files\Autodesk\MotionBuilder 2009\Tutorials folder.
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Scene consists of a biped skeleton inside a mesh

3 On the main toolbar, click Select By Name.
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The Select From Scene dialog box opens and shows the bone hierarchy
of the Pepe character. This hierarchy uses the naming convention
recognized by MotionBuilder.

4 Close the dialog box and on the main menu click Select And Move.

5 Select Pepe’s right foot bone and move it in any direction to see how the
skinning controls the character behavior.
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6 From the main menu, choose File > Export, and in the File Name box,
type Pepe_biped-Bip01.

TIP It is a good idea to add the Bip01suffix to remind you that the scene
contains a biped character whose bone names begin with Bip01.

7 On the FBX Exporter’s Include rollout, activate the Embed Media option
and click OK.
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The Pepe character is exported as an FBX file to the same folder as the
biped skeleton you saved earlier.

8 In the viewport, select any bone in the Pepe skeleton.

9 Go to the Motion panel > Biped rollout, expand the Modes And Display
group, and on the Name box, type PEPE.

10 On the main toolbar, click Select By Name.

The Select From Scene dialog box displays the modified names of the
character parts. Each bone is now identified by the PEPE prefix.

11 Export this modified scene as you did in step 6, but name the exported
file Pepe_biped-PEPE.

You will use this FBX file in the next lesson to learn how to import
custom-named characters into MotionBuilder.

12 Save your scene.
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Importing a 3ds Max skeleton

This lesson shows you how to import an FBX file to MotionBuilder.

Import a biped skeleton into MotionBuilder:

1 From the MotionBuilder main menu, choose File > FBX Plug-in Import.

2 In the Open File window, locate the C:\\Program
Files\Autodesk\MotionBuilder 2009\Tutorials folder, and open
bone-skeleton.fbx.

3 On the FBX Plug-in Importer, leave the default settings unchanged and
click Open.

A skeleton displays in the viewport
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4 Take a moment to try a few MotionBuilder navigation techniques:

■ Press Ctrl-Shift and drag to orbit around the scene.

■ Ctrl-drag to zoom in and out of the scene.

■ Shift-drag to pan the scene.

In the next step, you will characterize your skeleton.

Animating 3ds Max characters in
MotionBuilder

This tutorial takes you through the steps required to add animation to your
file in MotionBuilder.

The major steps of this tutorial are:

1 Characterizing your skeleton on page 130

2 Creating a naming template for a biped skeleton on page 136

3 Exporting a 3ds Max biped to MotionBuilder on page 142

4 Opening a 3ds Max biped in MotionBuilder on page 146

5 Extracting a naming template on page 153

6 Using the naming template to characterize a skeleton on page 155

7 Using a Python script to characterize a 3ds Max biped on page 159

8 Using motion capture data to animate a character in MotionBuilder on
page 163

9 Keyframing a character in MotionBuilder on page 167

Characterizing your skeleton

You must first characterize and assign a Control rig to the skeleton bones
before it can take on animation. Characterization is the the word for rigging
a skeleton in MotionBuilder.
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To characterize your skeleton:

1 Follow the steps in the previous lesson (Importing a 3ds Max skeleton
on page 129) to import a skeleton.

2 In the Asset browser, expand Templates > Characters.

3 Click and drag the Character asset on top of the skeleton.

4 Click Characterize.

5 Click Biped to indicate the type of rigging to apply to the character in
the Character dialog box.

The dialog box reminds you that the character must be in a “T” pose and
be facing in the positive Z axis (the equivalent of the negative Y axis that
you converted when exporting the .max file into FBX format).

6 From the Character Controls window, choose Edit > Control Rig Input.
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You must use this setting if you intend to keyframe your character.

7 On the Create Control Rig dialog box, click FK/IK.

FK/IK is the method commonly used to animate characters.

8 In the Character Controls window Active area, activate Ctrl Rig In.

This setting activates the Character Controls Character representation to
the left. The Character representation is an image of the biped skeleton
and contains all the effectors you need to animate its control rig.

Your character is now rigged and ready to receive animation.

Because your character bones were properly labeled, it took six steps to
successfully rig your character. In 3ds Max, rigging a character using
regular FK/IK constraints would have taken more effort.

9 On the Character representation, select the right wrist effector.
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10 Click in the Viewer window. Press T to translate (or move) the hand
down. As you move the hand, the arm extends, and the rest of the body
follows in a natural movement.
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NOTE If you have a skeleton that does not have the correct naming prefix, you
can use MotionBuilder’s 3ds Max Biped Template. This is covered in the following
section (Characterizing skeletons with other prefixes).

Characterizing skeletons with other prefixes

Sometimes you will need to characterize a skeleton in MotionBuilder that
does not have the correct naming prefix. See Skeleton naming conventions
on page 112.

MotionBuilder supplies a template for converting skeletons with different
naming prefixes.
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To use the naming template to characterize a biped skeleton with another
prefix:

1 From the MotionBuilder main menu, choose File > New. Do not save
changes to your existing file.

2 Select File > Fbx Plug-in Import.

3 On the Open File dialog box, locate the C:\\Program
Files\Autodesk\MotionBuilder 2009\Tutorials folder and double-click
Pepe_biped-PEPE.fbx. On the Fbx Plug-in Importer, leave the default settings
unchanged and click Open.

The Pepe character mesh displays in the Viewer window.

4 Make sure your mouse cursor is inside the Viewer window and press A
(Frame all) to center on the model.

5 Press Ctrl-A until the skeleton appears on the model in the Viewer
window.

6 In the Asset browser, drag the 3ds Max Biped Template on top of the
Pepe character skeleton in the Viewer window.

7 Click Characterize.

An error message displays, indicating that the characterization of the
bones could not be completed. This is because MotionBuilder does not
recognize the PEPE prefix that precedes each name in the Pepe character
bone system.

8 Click OK.

A list of all the bones MotionBuilder could not find on the character
displays.

9 Click Close, and in the Navigator window, select Characters. Double-click
on 3ds Max Biped Template.
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The mapping table lists all the bones MotionBuilder did not recognize
that were based on the 3ds Max naming template (e.g. Bip01 L Thigh) in
the right-hand column.

You can address this if you Alt-drag each bone from the character to the
respective Mapping List column row, but this is time-consuming. You
can create a new naming template that you can use for any new characters
you need to import to MotionBuilder.

You will learn how to do this in the next lesson, Creating a naming
template for a biped skeleton on page 136.

Creating a naming template for a biped skeleton

This step shows you how to use a naming template to characterize a 3ds Max
biped skeleton with a Bip01 prefix.

To create a naming template for a 3ds Max biped:

1 From the MotionBuilder main menu, choose File > New. Do not save
changes to your existing file.

2 Choose File > Fbx Plug-in Import.

3 On the Open File dialog box, navigate to the C:\\Program
Files\Autodesk\MotionBuilder 2009\Tutorials folder, highlight
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Pepe_biped-Bip01.fbx and click Open. Leave the default settings unchanged
in the FBX Importer, and click Open.

The Pepe character mesh displays in the Viewer window.

4 Make sure your cursor is inside the Viewer window and press A to frame
Pepe in the window.

TIP Pressing A is the equivalent of using the Zoom Extents tool in 3ds Max.
It zooms in to all visible objects in the Viewer window.

5 With your cursor still in the Viewer window, press Ctrl-A to see a skin-only
view. Press Ctrl-A once more to switch to X-ray mode.
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Pepe character in X-ray mode

X-Ray mode lets you view and select both the character mesh as well as
the bones, either individually or by region-selection.

6 From the Asset browser, drag a Character asset into the Viewer window
and release it on top of the skeleton.

7 Click Characterize.

An error message displays, indicating that the characterization of the
bones could not be completed. This is because MotionBuilder could not
recognize the names that identify the Pepe character bone system.
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8 Click OK.

All the bones MotionBuilder could not find on the character displays in
a list.

9 Click Close, then go to the Navigator window, and expand Characters.
Double-click Character.
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10 Click the Character Definition tab, if it is not already active, and from
the left-hand column, expand Base (required).

The Character Definition window mapping table shows all the skeleton
components whose mapping conversion was not recognized by the
MotionBuilder naming template.

11 Right-click the Character entry in the Navigator window, and click Delete.

12 From the Asset browser, click the 3ds Max Biped Template asset and drag
it on top of the Pepe character in the Viewer window.

The 3ds Max Biped Template asset is like the Character tool you used
earlier to characterize the bones of the model. But this template recognizes
bones of biped objects created in 3ds Max (bones that have Bip01 as a
prefix and a regular naming convention of a biped as a suffix).

13 Click Characterize, then Biped.

14 From the Character Controls window Edit menu, select Control Rig Input.
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15 On the Create Control Rig dialog box that appears, click FK/IK.

16 In the Character Controls window Active area, activate Ctrl Rig In.

17 Select Pepe’s right hand effector in the Character Controls Character
representation. Click in the Viewer window, press T, and translate (move)
Pepe’s hand.

The Pepe skeleton is fully rigged.

18 Go to the Navigator window, double-click on 3ds Max Biped Template,
and on the Character Definition window, expand Base (required).
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The Naming Template in the far right column shows how the 3ds Max
Biped Template tool has characterized the bones based on the 3ds Max
naming convention in the center column, rather than the default naming
convention, shown in the column on the far left.

Exporting a 3ds Max biped to MotionBuilder

This step shows you how to create a biped in 3ds Max for export to
MotionBuilder:

To create a biped in 3ds Max for export to MotionBuilder:

1 Open 3ds Max and from the main menu, choose File > New.

2 On the Create panel, click Systems.

3 On the Object type rollout, click Biped.

4 In the perspective viewport, click and drag to create a biped object.
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The size of the biped is not important.

5 On the Create Biped rollout > Root Name group, type MyBiped: as the
character name.
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Be sure to add the colon (:) after the biped name. This character instructs
MotionBuilder to ignore all characters that precede it, and creates a
template whose bone labels have no prefix.

If for any reason you forget to add the colon, you can add it later by going
to the Motion panel, expanding Modes and Display and adding the colon
in the Name box.

NOTE Because you are creating this biped to extract its naming information
only, you do not need to give it a T-pose or position it in a negative Y axis.

6 Go to the Motion panel > Biped rollout, select any bone in the biped,
and click Figure Mode.

7 In the Structure rollout > Body Type group > Neck Links spinner box,
type 10 and press Enter.
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Biped with 10 neck links

TIP Because MotionBuilder has ten neck link channels, it is good practice to
make them available when you create your biped.

8 On the Spine links box, type 10, in the Fingers box type 5, in the Finger
Links box type 3, in the Toes box type 5 and in the Toe Links box type
3, then press Enter.

9 Click Figure Mode again to exit the input mode and from the main menu,
choose File > Export.

10 On the Select File to Export dialog box > File Name box, type
biped_for_template and click Save.

11 On the FBX Exporter, click OK.
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Opening a 3ds Max biped in MotionBuilder

This step shows you how to import the biped in MotionBuilder and create a
naming template based on the character:

To import a 3ds Max biped into MotionBuilder:

1 In MotionBuilder, create a new scene. If you still have Pepe_biped-Bip01.fbx
open, do not save changes.

2 From the MotionBuilder main menu, choose File > FBX Plug-in Import.

3 On the Open File dialog box, choose the biped file you just created in
3ds Max, biped_for_template.fbx, click Open, then click open again on the
FBX Plug-in Importer. (You can also open biped_for_template.fbx from the
Asset browser Tutorials folder.)

4 Position your cursor anywhere in the Viewer window and press A to frame
all of the biped skeleton.
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These next steps show you how to create a naming template that you
can reuse later on to automate the skeleton characterization process.

5 In the Asset browser, expand Templates > Characters and drag the
Character asset into an empty area of the Viewer window.

6 On the Navigator panel, expand Characters and select Character.

7 Right-click, choose Rename, and type BIP_CS.
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This is the name of the template you are about to create for your biped.

8 On the Character Definition tab > Character group, expand Base (required)
if it is not already displayed.

The left column lists all bones required to form a complete skeleton.

9 In the Viewer window, select the biped’s left upper thigh and Alt-drag it
to the Mapping List column, next to the row called LeftUpLeg.
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Alt-drag skeleton left upper thigh to Mapping List

This maps the bone label created in 3ds Max to the naming convention
recognized by MotionBuilder.

10 Alt-drag the biped’s left calf from the Viewer window to the Mapping
List cell to the right of LeftLeg.
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11 Alt-drag the biped’s left foot from the Viewer window to the Mapping
List cell to the right of LeftFoot.

12 Repeat steps 9 to 11 for the biped’s right leg.

13 Click on an empty area in the Viewer window and press Ctrl-W to switch
to Schematic view.

It is often easier to locate bones in this view.

14 Press A to frame all of the nodes in the biped skeleton.

You can pan, zoom, and navigate the viewer using the same navigation
key combinations you tried earlier in Perspective view. See Importing a
3ds Max skeleton on page 129 for the list of common MotionBuilder
navigation shortcuts.

15 Locate the MyBiped:Spine node in the Schematic view.
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NOTE You can also select one or more nodes and press F (frame) to zoom
in on your selection.

16 Select the MyBiped: Spine node and Alt-drag it to the Mapping List cell
to the right of Spine.

17 Navigate the bone hierarchy until you locate the MyBiped: L UpperArm
node and Alt-drag it to the to the Mapping List cell to the right of LeftArm.

18 Repeat the previous step for the biped’s forearm and hand, then do the
same for the right arm, forearm and hand.

19 Locate the MyBiped: Head and Alt-drag it to the bottom of the Mapping
List, next to Head.

The bones you just mapped to the naming template are required to
successfully characterize a character skeleton. The bones you map in the
following steps are optional, but provide additional control of the
character.

20 On the Character group > left column, expand Spine and Alt-drag
MyBiped: Spine 1 to the Mapping List cell to the right of Spine1.
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21 Repeat the previous step for spine links 2 to 9.

22 On the Character group > left column, expand Neck and Alt-drag
MyBiped: Neck to the Mapping List cell to the right of Neck.

23 Repeat the previous step for neck links 2 to 9.

24 On the Character group > left column, expand Auxiliary and Alt-drag
MyBiped: L Clavicle to the Mapping List cell to the right of LeftShoulder.

25 Repeat the previous step for the right shoulder.

26 In the Schematic view, locate the MyBiped: node, at the top of the bone
hierarchy and Alt-drag it to the Base (required) Mapping List cell to the
right of Hips.
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If you are familiar with 3ds Max, you might expect to drag the MyBiped:
Pelvis node to the Hips entry instead. However, due to the way
MotionBuilder characterizes bones, the center of gravity is the node you
need to specify for hip bones of characters exported from 3ds Max.

This completes the base subset of bones required for characterization. In
the next step, you create a template from this file so you can use it to
characterize the bones of future skeletons.

Extracting a naming template

Once you have assigned the required bones in the previous step, you can now
extract the template so it you can use it to characterize the bones of future
skeletons.
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To extract a naming template:

1 Complete the naming template setup in Opening a 3ds Max biped in
MotionBuilder on page 146.

2 In the Character Definition window > Character group, click Extract
Naming Template, then click OK to clear the message box.

The names of the bones you dropped into the Mapping List column
transfer to the Naming Template column. Because you added the colon
(:) to the biped skeleton names, only the suffix is transferred. This is the
naming convention recognized by MotionBuilder.

NOTE The only bone not properly labeled is the hips. You must set the hips
manually each time you characterize a biped using this template.

3 Click Clear Mapping List and click OK.

You must clear the Mapping List column because this is where you drop
the bones of future skeletons to be characterized.

4 In the Navigator window Scene browser, highlight BIP_CS and from the
MotionBuilder main menu, choose File > Save Selection.

This saves the BIP_CS characterization template only, and not the biped
skeleton you used as its reference.

5 In the Save File dialog box, navigate to the C:\\Program
Files\Autodesk\MotionBuilder 2009\Tutorials folder and in the File name
box, type univ_bip_template_tutorial, click Save, then click Save again.
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Now you have a template that makes it much easier to characterize a
biped whose bones do not start with the prefix Bip01.

Using the naming template to characterize a
skeleton

This section shows you how to use the template created in the previous lesson
(Extracting a naming template on page 153) to characterize a skeleton.

To use the BIP_CS naming template to characterize the Pepe biped’s skeleton:

1 Click on an empty area in the Viewer window, press and Ctrl-E to return
to the Perspective view.

2 From the MotionBuilder main menu, select File > New. Do not save
changes to the existing file.

3 Choose File > Fbx Plug-in Import, navigate to the C:\\Program
Files\Autodesk\MotionBuilder 2009\Tutorials folder and open the file
called Pepe_biped-PEPE.fbx.

NOTE This file contains a biped with a PEPE prefix for each of its bones. You
cannot use MotionBuilder’s 3ds Max Biped template with this file, since it is
only for skeletons whose bones have Bip01 prefixes.

4 Zoom in to the Pepe character and press Ctrl-A until are in X-ray mode.

5 In the Asset browser, select the Tutorials folder, where you saved
univ_bip_template_tutorial, then right-click and choose Refresh Directory.

NOTE You can also use the univ_bip_template_tutorial file that already resides
in the Asset browser if you want.

6 Drag univ_bip_template from the Asset browser to an empty area of the
Viewer window and choose FBX Merge > No Animation.
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The BIP_CS template displays in the
navigator tab scene explorer, under
Characters.

7 Double-click BIP_CS to display the Naming Template at the far right.

8 Region-select the Pepe character to select all his bones, then Alt-drag him
to the Mapping List column.

Each bone suffix is matched to the suffixes of the Naming Template,
ready for characterization. The only step remaining is to manually specify
the hips, since they could not be provided in the Naming Template.

9 Click on an empty area of the Viewer window and press Ctrl-W to return
to the Schematic view.

10 Locate the Pepe character’s center of mass node, named PEPE, and Alt-drag
it to the Mapping List cell to the right of the Hips entry.

11 In the Character Definition window > Character group, activate the
Characterize option and click Biped.
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12 Press Ctrl-E to return to Perspective view.

13 From the Character Controls window > Character Controls tab > Edit
menu, select Control Rig Input.

14 In the Create Control Rig dialog box, click FK/IK.

15 In the Character Controls window Active area, activate Ctrl Rig In.

16 On the Character Controls window Character Representation, select
Pepe’s right wrist. Click anywhere in the Viewer window and press T to
translate (move) his hand.
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Fully-rigged Pepe character

The character is properly rigged, ready for keyframe animation.

Now, you can import any biped character created in 3ds Max with any
prefix name to MotionBuilder If you choose the univ_bip_template as the
characterization tool, characterization is automatic except that you must
manually specify the hip bone.

TIP You can also use a Python script to perform this task even faster, but it
is important to understand the template creation process in case you need
to perform the characterization manually. See Using a Python script to
characterize a 3ds Max biped on page 159.

17 Close the scene file and do not save your work.
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Using a Python script to characterize a 3ds Max
biped

You can use the univ_bip_template as a characterization tool for your 3ds Max
bipeds, but using a Python script automates the entire procure.

Import the Pepe biped using a Python script to characterize its skeleton:

1 From the MotionBuilder main menu, choose File > New.

2 Choose File > Fbx Plug-in Import and open the file called
Pepe_biped-PEPE.fbx.

3 With you mouse in the Viewer window, press A to frame the Pepe
character. Press Ctrl-A until you are in X-ray mode.

4 In the Asset browser, expand the MB-Interop folder.

5 Drag the BipedToCharacterV2 Python script icon from the Asset browser
Tutorials folder to an empty area in the Viewer window.
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6 From the menu that appears, choose Add to Scene.

7 Select the character’s center of mass.

8 In the Navigator window, expand Scripts, right-click BipedToCharacterV2
and select Execute.
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9 From the Character Controls window > Character Controls tab > Edit
menu, choose Control Rig Input.

10 On the Create Control Rig dialog box, click FK/IK.

11 On the Character Controls window > Active group, activate the Ctrl Rig
In option.

12 In the Character Representation, select Pepe’s right wrist. Click anywhere
in the Viewer window and press T to translate (or move) the hand.
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Fully-rigged Pepe character

Now that the script is executed, the character is properly rigged, ready
for animation. In the next lesson, Using motion capture data to animate
a character in MotionBuilder on page 163, you will learn how you can
animate your character.
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Using motion capture data to animate a character
in MotionBuilder

In MotionBuilder, you can animate characters by setting keyframes manually,
or using motion capture data. This lesson shows you how to retarget animation
to Pepe from one of the motion capture files that ship with MotionBuilder.

The following lesson (Keyframing a character in MotionBuilder on page 167)
shows you how to use key frame animation techniques to refine the motion
capture animation.

NOTE If you already know how to animate characters in MotionBuilder, you can
skip this lesson.

To animate the Pepe character using motion capture data

1 In MotionBuilder, from the main menu, choose File > New. If you are
continuing from the previous lesson, do not save your existing scene.

2 From the Asset Browser > Tutorials folder, drag the
Pepe_biped_characterized.fbx file into the Viewer window.

This file contains the Pepe character you worked on in the last few lessons,
but already characterized and saved in MotionBuilder, so he is ready to
receive animation.

3 Choose FBX Open > All Takes.

4 Click on an empty area in the viewport and press A to frame all and zoom
in on the Pepe character.

5 Press Ctrl-Shift to orbit until the right side of the character is in view.
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6 From the Asset Browser > MB_Interop folder, choose IceSlip and drag it
into an empty area of the the Viewer window.

7 Choose FBX Merge > IceSlip, and zoom out until the yellow skeleton that
represents the motion capture animation is visible.

NOTE If you do not see the yellow skeleton, place your cursor in the Viewer
window and press Ctrl-A until you are in X-ray mode.
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Pepe with skeleton containing motion capture information

8 On the Transport Controls, click Play to view the animation.

You will now assign this movement to the Pepe character. This task is
very easy to accomplish in MotionBuilder.

9 On the Character Controls > Current Character menu, make sure PEPE
is displayed in the character list.
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10 Choose Edit > Input > Skeleton2, which is the name of the yellow skeleton
that contains the motion capture animation.

11 Drag the Transport Controls timeline indicator (slider bar) to scrub the
animation. You can also hold down the J key and drag left or right in the
Viewer window.

The skeleton’s animation now drives the Pepe character.

12 Press Ctrl-A until only Pepe is visible, then go to frame 92 and zoom in
on the Pepe character.

13 If you look carefully, you that one of Pepe’s hands passes though his face.
Rotate the character and scrub the animation a few times if you cannot
see the problem.
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Unwanted hand movement inherited from motion capture

This behavior occurred because the animation that drives Pepe’s bone
movement is based on a skeleton that has a very different physiology.
For example, Pepe’s head, hands, and feet are much larger than the
skeleton, while his shoulders are much smaller.

14 Keep the file open so that in the next lesson, Keyframing a character in
MotionBuilder on page 167, you can use keyframe animation techniques
to correct Pepe’s hand movement.

Keyframing a character in MotionBuilder

In MotionBuilder, you can animate characters by setting keyframes manually.
This useful for creating original animation or making changes to motion
capture animation.

In this lesson, you will use key frame animation to refine motion capture
animation.

NOTE If you already know how to animate characters in MotionBuilder, you can
skip this lesson.
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To fine-tune Motion Capture animation with keyframing:

1 Apply the motion capture data to Pepe in the previous tutorial (Using
motion capture data to animate a character in MotionBuilder on page
163).

2 On the Character Controls Character Representation, click the left hand
effector, press T, and try to move Pepe’s hand in the Viewer window.

Nothing happens because Pepe’s animation is controlled by the skeleton,
not the Control rig. Before you can keyframe Pepe’s motion capture
animation, you must plot (or bake) the skeleton animation onto the Pepe
character Control rig.

3 In the Character Control window > Edit menu, select Plot Character.

4 On the Character dialog box, click Control rig. On the second Character
dialog box, leave the default values unchanged and click Plot.

You can now edit the Pepe character using his Control rig.

The Plot command creates a key at every frame at the base layer of the
animation track, making edits difficult. You must edit the keyframing
on a different layer.

5 On the Key Controls panel, click the Base Layer list and choose Layer 1.

The keyframes are hidden on the timeline, clearing your workspace.

6 Go to frame 80, which is the start of the problem hand movement. On
the Character Controls window Character Representation, click the right
wrist effector, then in the Key Controls, click Key.
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NOTE You can also set a key by placing your cursor anywhere in the Viewer
window and pressing K.

7 Go to frame 105, the end of the problem hand movement, and click Key
again.

All character movement before the first key and after the second key is
unchanged. Only the character movement between frames 80 to 105 will
be modified.

8 Go to frame 94, the mid point between the two keyframes you set.

9 In the viewport, press T, move the hand away from Pepe’s face on its X
and Z axes, and set another key.

Left hand moved away from character’s face

10 Press J, then drag back and forth to see how the hand reacts to the keys
you just created.
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11 Make any further adjustments to the hand movement as required. Make
sure to create a key after each adjustment.

12 Advance to the last frame of the animation and adjust your view until
you can see the right side of Pepe’s body.

Right hand too close to character head

13 Move Pepe’s hand away from his body and set a key.

14 Press R to use the rotation rings to modify the hand’s position until it
rests flat on the ground, then set another key.
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Rotation rings used to reposition right hand

15 Go to frame 114 and position the right hand farther away from the head
and set another key.

16 Play back the animation to see the result.

17 Make any further adjustments to the character body position.

When you are satisfied with the animation, proceed to the next lesson
(Baking animation for Export to 3ds Max on page 172). There, you will
save your work and prepare it for import back to 3ds Max.

Importing back to 3ds Max
This set of lessons shows you how to save your work and prepare it for import
back to 3ds Max.
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The major steps of this tutorial are:

1 Baking animation for Export to 3ds Max on page 172

2 Opening MotionBuilder files in 3ds Max on page 174

Baking animation for Export to 3ds Max

3ds Max does not read the Control rig information that defines character
animation in MotionBuilder. For 3ds Max to recognize this animation, you
need to plot, or “bake”, the keyframe data into the character’s skeleton.

To bake animation onto the Pepe character’s skeleton:

1 If you are not continuing from the previous lesson, from the Asset browser
> MB_Interop folder, open the Pepe_biped_characterized_unsaved.fbx file
from the Asset browser Tutorials folder.

2 On the Character Controls Edit menu, choose Plot Character.

3 On the Character dialog box, click Skeleton, then on the second Character
dialog box, leave the default values unchanged and click Plot.
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The character Control rig is deactivated, but the Pepe character retains
all animation information.

If you need to edit the character’s movement after its animation has been
plotted, simply go back to the Character Control panel > Character
Controls tab > Edit menu, and choose Plot Character > Control Rig again.
When you are done, repeat steps 2 to 3 to bake the animation back onto
the character skeleton.

NOTE When you save your file, you will have the animated Pepe character
in your scene, but the reference skeleton as well. If you want, you can delete
the skeleton from the scene, or select the Pepe character and save it to another
file for import to 3ds Max, but you don’t have to. You can just as easily strip
out the skeleton when you import to 3ds Max.
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4 From the MotionBuilder main menu, choose File > Save As, navigate to
the MB_Interop folder, then in the Save File dialog box, type
Pepe_biped_plotted and click Save.

Opening MotionBuilder files in 3ds Max

You can import the entire contents of scenes saved in MotionBuilder, or only
the elements whose names match those in your 3ds Max scene.

The animation you import from MotionBuilder is fully editable in 3ds Max.

To import the animated character to 3ds Max:

1 Open 3ds Max and from the main menu choose File > Open. If the scene
from the Creating Naming Templates lesson is still open, do not save
your work.

2 Open the scene file called Pepe_biped.max from C:\\Program
Files\Autodesk\MotionBuilder 2009\Tutorials.

3 On the main toolbar, click Select By Name.

The skeleton bones have the same PEPE prefix as the character you
exported to MotionBuilder.

4 Close the dialog box and from the main menu, choose File > Import.

5 On the Select File To Import dialog box, navigate to the C:\\Program
Files\Autodesk\MotionBuilder 2009\Tutorials folder and open
Pepe_biped-plotted.fbx.

6 On the FBX Import dialog box, scroll down to the Include rollout.

The File Content list displays Add And Update Scene Elements by default.
If left as is, this setting would import not only the Pepe character, but
the yellow reference skeleton as well.

7 From the File Content list, choose Update Scene Elements.
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This option updates only the scene elements in 3ds Max that share the
same name as those in the imported file. No new elements are imported.
If you were importing animation from MotionBuilder to a new 3ds Max
scene, you would instead choose the Add To Scene option.

8 Click OK, then OK again to clear the message that informs you that the
rotation limits of the characters in MotionBuilder and 3ds Max differ.

This disparity will not affect the animation.

9 Scrub the timeline to see how the MotionBuilder animation has been
baked into the Pepe character bones.
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Summary

In this series of lessons, you took a 3ds Max biped skeleton with a mesh called
Pepe and exported it to MotionBuilder as an FBX file. In MotionBuilder, you
characterized the biped bones using templates and scripts, and animated the
Pepe skeleton by plotting it to another skeleton.

Then, you baked the animation back to Pepe’s control rig, made a few
adjustments so that the motion better fit his cartoon-like character, and baked
the animation back into Pepe’s skeleton for export to 3ds Max.
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