Autodesk MotionBuilder 2012 Release Notes

This document describes known limitations, issues and fixes in Autodesk MotionBuilder 2012. It is
strongly recommended that you read this document before you install this release. For reference, you
should save this readme to your hard drive or print a copy.
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Additional Resources

For complete instructions about uninstalling and installing MotionBuilder 2012 see:
www.autodesk.com/motionbuilder-fag-2012-enu

For complete documentation and resources, see: www.autodesk.com/motionbuilder2012-

documentation

For hardware qualifications, see: www.autodesk.com/MotionBuilder2012-hardware

To report issues with this release, see: www.autodesk.com/MotionBuilder2012-support

For more resources, see: www.autodesk.com/MotionBuilder2012-learningpath

What’s New

This section briefly describes new features in this release. Please refer to the What’s New in the
MotionBuilder Help for more detailed descriptions: www.autodesk.com/motionbuilder2012-

documentation.

Time Code Property

A time code property has been added which allows users to associate time code to animation.

Dark Look and Qt Dockable Ul

MotionBuilder has adopted a dark look Ul. As well as the update of many icons, you now have the ability
to dock and float tool windows.

New Layouts

Preset layouts have been updated to the following: Editing, Scripting, and Preview.
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Custom Layouts Menu Options

New options have been added to the Layout menu relating to custom layouts. “Create custom” allows
you to save any new layout. Enable the “Auto-update Layout” if you wish to automatically save all
custom layout modifications.

New Marker Types

Additional types have been added to the properties list for markers. Users can choose to display a
marker as any of the following marker types: cube, hard or light cross, sphere, capsule, box, bone, circle,
square, or stick.

Use Image Sequence

An “Image Sequence” option has been added to the Video settings pane.

Visibility Inheritance

Visibility of a parent node can now be inherited by all children. A property has been added so that it can
be enabled for each object as needed. New objects created in MotionBuilder 2012 have this property
set on by default to help keep performance optimal.

Recording and Storing Vertex Animation/Point Cache

MotionBuilder now supports the recording and playback of point cache data on models. Point cache can
boost performance on animation intensive scenes or to transfer animation based on complex constraint
or physics set-ups into other applications using FBX.

A python sample script is provided for recording and playing back point cache animation on characters.
The script can be found here: Asset Browser > Scripts > Samples > PointCache > CharacterPointCache.py

New classes:

e FBPointCacheManager
e FBDeformer

e FBDeformerType

e FBPoint-CachefFile

Added to FBCharacter class:
e GetSkinModellist( FBModelList& pSkinModelList )
Added to FBModel class:

e NoFrustumCullingRequire()
e NoFrustumCullingRelease()
e  UseFrustumCulling()



Deformers:

o SkeletonDeformable
e BlendShapeDeformable
e ConstrainDeformable
e PointCacheDeformable

Nurbs Curves:
e Nurbs Curves from Maya are now supported in MotionBuilder

Stereo Camera Rig

A stereo camera is now available in Motionbuilder.
New classes: FBCameraStereo, FBCameraStereoType, FBStereoDisplayMode
Extended classes: FBVideoGrabOptions

Auto Key Type

Auto key type behavior has changed. To prevent overshooting or undershooting of fcurves caused by
the Bezier Auto and User interpolation, a new clamp functionality with ease in and ease out has been
added.

Update to HIK 4.5

The default character solver in MotionBuilder has been changed to HIK 4.5. HIK 3.6 and 4.0 have been
removed from this version.

New Characterization Tool

MotionBuilder has implemented the new HIK Characterization Tool. This tool gives users access to bone
mapping templates for HIK, Biped, and CAT skeletons, as well as mirroring functions, and instant
notification when a characterization process is incomplete.

New Character Controls

The Character Controls window has also been updated with a new look and some additional controls.

Vertex Color Display

Vertex color shading of models is now supported in MotionBuilder.
The following parameters have been changed in FBGeometry class:

e VertexInit(int pSize, bool pResize, bool pInitUV = true, bool pInitVertexColor = false)
e VertexAdd(FBVertex pVertex, FBNormal pNormal, FBUV pUV, FBColorF pVertexColor)



The following additions have been made to FBGeometry Class:

e VertexColorSet(FBColorF pColor, int plndex=-1)

e VertexColorSet(float pRed, float pGreen, float pBlue, float pAlpha, int pIndex=-1)
o VertexColorGet(int pIndex=-1)

e VertexColorMappingMode

e VertexColorReferenceMode

e GetVertexColorsindexArray(int& pOutArrayCount)

o GetVertexColorsDirectArray(int& pOutArrayCount)

A new sample has been created to demonstrate simple geometry creation and vertex color display
setting, and be found here: Asset Browser > Scripts > Samples > Geometry > VertexColor.py

Consistent F-Curve Editor

The f-curve editor has been improved to be more consistent with other Autodesk applications.

Frustum Culling

Frustum culling will prevent the rendering of anything outside the current camera viewport. This option
is turned on by default, but users can press CTRL+Shift+P to toggle the setting on and off. Press Shift+F
to display the frame and evaluation rates, and the on/off state of the Frustum Culling; all are listed in
the Evaluation line.

GPU Skinning

GPU skinning is now disabled by default on machines with 4 or more cores. Use the CTRL+Shift+D
shortcut to enable GPU skinning if required.

Profiling Tools

Profiling tools are available to allow users to monitor scene performance as well as pinpoint where
performance cost is highest.

Profiling is available for:

e Evaluation: Models, Constraints, Characters, Story Tracks,

e Devices: Device Input, DevicesNotify, Devices Output

e Rendering: Renderer, RenderPassGroup(Translucent, TranslucentZSort, Selected,
OtherPrimitive, Selectivelighting, etc), ShadeModelPass

e New classes: FBProfiler, FBProfileDutyCycle, FBProfileTimeEvent, FBProfileHelper

Synchronization of Animation with Physics

A new physics solver property has been added. Enable ForceAnimationSync when the computation of
the physics takes longer than animation. Note that this means animation will only play when physics is
live, and animation playback could be slower.



Live Video Input Capabilities

Configure a webcam on your system and launch MotionBuilder. The device appears in the Navigator >
Videos folder. Click Online and view and record live video directly inside MotionBuilder.

Up-Vector Settings Have Been Added to the Path Constraint

Path constraints now have an option to set an up-vector. Enable “Follow Path” option in the constraint
properties to access these options.

Real-Time Relation Constraint Filter

This filter applies a low-pass filter to incoming live data.

Audio Link to Take

You can now assign an audio file to a particular scene take. This option is located in the Audio Settings.

Displacement Box for Use in Relation Constraint with Devices

This box has been created to eliminate the dependency on display frame rates when using Relation
Constraints with Physics.

New Python Classes

The following new classes have been exposed in Python:

e FBOpticalGap

e FBModelOpticalAdvanced

e FBOpticalSegment

e FBRigidBody

e FBModelMarkerOptical

e FBPropertylListMarkerSegment
e FBPropertyListOpticalSegment
e FBPropertylistOpticalGap

e FBModelOpticalAdvanced

e FBPropertyEnumBase

Exposure of Simple Math Functions in Python

The following simple math functions have been exposed in Python:

e Matrix

e T,R,S to Matrix

e Matrixto T,R,S

e Local/Global conversions
e \Vector operations



e (Quaternion operations
e Vertex operations

e Rotation utilities

e Miscellaneous utilities

Extended Classes

The following classes have been extended:

e FBVector2d
e FBVector3d
e FBVector4dd
e FBSVector
e FBNormal

e FBVertex

e FBUV

e FBColor

e FBColorAndAlpha
e FBMatrix.

New Samples

The following new samples can be found in the Asset Browser > Scripts > Samples > Math:
MathUrtilities.py (shows the global functions for math)

Matrix.py (shows extended functions for FBMatrix)

Vectors.py (shows extended functions for Vectors)

Hybrid Motion Capture Device

The plotting requirement after plotting has been removed and users can now record both optical and
bone data simultaneously.

New function for FBAnimationNode

The following new function has been added:
e WriteGlobalData( double* Data,HFBEvaluatelnfo pEvaluatelnfo )

New Sample Projects

The following new sample projects have been added.

e A combination of optical and skeleton device template
e deviceopticalhybrid



e Server to provide test data
e Opticalhybriddevicetester

Exposure of TimeWarp

The functionality of the TimeWarp curve has been exposed in the SDK.
New class: FBTimeWarpManager

The following new sample can be found in the Asset Browser > Scripts > Samples > FCurve >
TimeWarp.py

Setting the Initial State of a Checkbox using FBTree

The class FBTreeNode has a new Boolean attribute: When checked it is used to change the state of
CheckBoxes created with FBTree.

GetVertexArrayDuplicationMap added to FBModel Class

To accelerate real-time rendering, MotionBuilder will pre-process the vertex data. Those control points
which have multiple attributes, such as normal, UV, etc., will be duplicated in order to have VBO (vertex
buffer object) alike format. This function will return the original vertex mapping IDs for those new
(duplicated) vertexes.

Distribution of Boost Library

A new chapter “Custom development with Open Reality & PYFBSDK"” has been added to SDK Help. This
topic focuses on exposing the Open Reality SDK to Python using a third party library called Boost.Python.
This allows users to add functionality to the ORSDK object and export that to Python.

A new sample has been added in the ORSDK: pyfbsdk_template.

New Python Sample for Merging Animation Layers

Merging animation layers is now exposed through both C++ and Python. It is demonstrated in the new
Python sample script MergeAnimationLayer.py

New Python Sample for FBClusterTransactions

Shows you how to access the cluster and cluster index while using the cluster transactions.

Python/SDK documentation

The Qt section has been revised with a detailed step-by-step tutorial. A new chapter "Custom
development with Open Reality & PYFBSDK" has been added. This topic focuses on exposing the Open
Reality SDK to Python using a third party library called Boost.Python.

Changes in Roll Bones Default Settings

Roll Bone Extraction settings in the Character properties have changed.



When no roll bones are present:

e Arm Roll Mode is set on and all Arm Roll sliders are at 100.
e LegRoll Mode is set off and all Leg Roll sliders are at 100.

When roll bones are present:
e Arm and Leg Roll Mode is set on and all Roll sliders are at 60.

Changes When Working with Additive Reference Mode

To reduce evaluation time and therefore increase frame rate, objects will not automatically be set to
animatable when loaded or imported in MotionBuilder. This saves the evaluation engine considerable
time because it is not forced to loop through each object’s transformation fcurves n times per second. A
substantial savings will be found with scenes containing larger numbers of static meshes.

Users will see similar behavior and will be able to key objects as usual. Additive rotation, however, will
require the user to manually set the rotation property to animatable in order to see values larger than
180.

New Clip Art Location

Clip Art files are now located in:

e C:\Autodesk\MotionBuilder 2012 64bit\Content\ClipArt
e C:\Autodesk\MotionBuilder 2012 32bit\Content\ClipArt

Samples folder has been moved inside the ClipArt folder.
New Characters
New characters have been added to the ClipArt\Characters folder.

Configuration Files Relocation

MotionBuilder configuration files are now written in a folder outside the Program File in order to be
more compatible with Vista and Windows 7. The new location is: C:\My Documents\MB.

MB_CONFIG_DIR

Use MB_CONFIG_DIR environment variable to override the default location of the MotionBuilder
configuration files.

MotionBuilder Help and SDK on Autodesk.com

Starting this release the MotionBuilder Help and SDK Help is being published to the Autodesk.com
website as browser-based help systems. By default, MotionBuilder 2012 will not include documentation
and learning materials with the software installation.



Instead, MotionBuilder calls the help and other resources from a web location to provide you with the
latest documentation available. This shift to publishing directly to the web means we can provide
regular updates and additions to content in an ongoing manner. This change also significantly reduces
the footprint of locally installed data to your machine and makes the install and uninstall of
MotionBuilder quicker.

View the MotionBuilder Help: www.autodesk.com/motionbuilder2012-documentation

View the MotionBuilder SDK Help: www.autodesk.com/motionbuilder-sdkdoc-2012-enu

What’s Fixed?

The following list contains bug numbers and corresponding descriptions for issues fixed in this release.

Bug Number \ Description

365168 Broken ORSDK and Python Samples

371719 Constraints folders lose settings on reload

366139 Voice device relation connections not automatically created

360198 Asset details no longer shows link to textures

351810 Cannot reset destinations in assign sources to destinations

313677 Import options not remembered

360428 Save selection discards skinning information

360417 Sphere maps cause instability

366553 Keying on reach properties when keying in body part mode

354748 Changes to Templates folder causes instability

305032 Align control rig has problems with HIK 4.5

375586 Control rig sync problems with HIK 4.5

304209 Instability caused by setting FBSpreadCell::Style to kFBCellStle View

310174 Selecting models from ORSDK is too slow when scene has more than 1000
models

371035 Property references not saved

376188 Custom Local View is not saved with scene

363335 Saving scenes with many takes causes instability

368194 Expression constraints lose connection to blend shapes after saving

366131 Merge Append of characters breaks connections with characters in Story

367556 Shader properties are not animated on subtracks with ‘insert current take’

367265 Full screen viewport tiles vertically instead of horizontally

360934 Hips translation in character definition is not saved

368611 Pop-up still requires user input for batch processes

361014 Crash with copy/paste of video track

379518 Cannot trim video on a track after a save/open - crash when deleting

361001 Cannot see video file when trying to open through Story > Insert Video File

379849 Story Video Track- Clips duplicated on Save/Re-open

378259 AMC import — Dummy bones lost on import

378257 AMC import — Motion not merged on import
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Bug Number ‘ Description

376527 ASF import — File>Import without AMC not possible

234683 Load Character Animation not supporting plotting for Skeletons
339057 HIK 4.5 rig effectors flip when manipulated with handles
378257 AMC import not merging motion on entire hierarchy — only on root
371311 PythonStartup folder not loading in correct order

342950 Bone size reset after merging .htr data on skeleton

344297 Drop down menu problems on dual monitor

360052 Handles manipulation broken on reload

358797 SaveSelected.py not saving in correct location

374761 Local custom view for properties not saved

377317 Global lighting fog colors reset when layouts change

377487 Macros with namespaces do not merge append correctly
362904 Extrapolate animation curves is not saving with file

360683 Tabs not working for pop-ups

360687 Python window always has focus for shortcuts

Feature Limitations and Notes

The following section describes limitations and other notes about this release.

Bug Number \ Description

359926 Video and audio not synched when recorded with Slave Audio to Video option

359464 Instability can occur when recording video input to a take

380182 CG Shader is not supported with stereo camera views

380331 Human limits not working with HIK 4.5

381784 Dynamic Lighting shader is not working with Transparency maps

382027 Override in animation layer has no effect until keyframe is created

380405 Namespace - Relation macro connection reference

380516 Namespace not maintained on animation layers

380818 FBX Export from Python tools menu creates unstable files when they contain
new features from 2012

374138 File > Append breaks relation macros with namespace

359588 MinSize not working in FBTool

378305 Image sequence does not support layer texture

380722 Drop down menus in Character Settings are offset using custom layout

378561 DeviceSyncAnimationNodeNotify only triggers if device is selected internally

380995 Cannot add elements to sets with animated visibility

381784 Dynamic lighting shader is not working with transparency maps

382027 Override in animation layers has no effect until a keyframe is created
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Notes

Recording Live Video

Certain camera drivers seem to cause problems while recording. We found removing the driver resolved
the issue.

Video recorded with some cameras will be compressed by default despite setting compression to None
in MotionBuilder. This could affect playback on 64 bit since Quicktime is not supported.

Vertices on a 3d Curve

Vertices cannot be selected until user selects the first vertex and offsets it slightly, and then all vertices
appear and can be manipulated normally.

Cannot Adding Elements to Sets with Animated Visibility

Scenes will have to be saved and reopened for visibility to be applied to new elements.

Image Sequence

Image Sequences are currently not embedded in scene files.

Path Constraints

Path constraints are not supported by FBX. Bake the animation onto the constrained object before
importing into other software.

Renaming Characters can remove definition

Character definition could be removed when creating characters if Character is renamed before locking
initial characterization.

Autodesk, Backburner, FBX, Maya, MotionBuilder, Mudbox, Softimage, and 3ds Max are registered trademarks or trademarks
of Autodesk, Inc., and/or its subsidiaries and/or affiliates in the USA and/or other countries. All other brand names, product
names, or trademarks belong to their respective holders. Autodesk reserves the right to alter product and services offerings,

and specifications and pricing at any time without notice, and is not responsible for typographical or graphical errors that may

appear in this document. ©2011 Autodesk, Inc. All rights reserved.
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