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チュートリアル

はじめに

注: この一連のチュートリアルでは、Autodesk MotionBuilder2012を使用してい
ることを想定しています。この一連のチュートリアルの一部では、2012シングル
ステップの相互運用性機能(3ds Max および Maya 2012 に含まれる「Send to」機
能など)を使用します。

3ds Max ソフトウェアのバージョン 2012 がない場合にこれらを実行するには、
MotionBuilderヘルプに説明されているレガシーワークフローを参照してくださ
い。これらのチュートリアルには、MotionBuilderドキュメントにあるレガシー
ワークフローの手順に誘導する注を付けています。

チュートリアル用のアセットは、MotionBuilder の Asset Browser の Tutorials
フォルダ(またはシステム上の MotionBuilder ディレクトリ内の Tutorialsフォル
ダ)にあります。

注: これらのタスクのチュートリアルでは Editing レイアウト([Layout] > [Editing])
を使用しますが、どのウィンドウも使用できない場合でも、MotionBuilderメ
ニューバー > [Window]メニューから選択することができます。Asset Browser に
Tutorialsフォルダが表示されない場合は、対応するディレクトリのパスをよく使
用するパスとして追加する必要があります。

注: チュートリアル用のアセット(サポートファイル)は、
http://www.autodesk.co.jp/motionbuilder-documentationからダウンロードできま
す。

1

1

http://www.autodesk.co.jp/motionbuilder-documentation


関連事項:

MotionBuilder のワークフロー (2ページ)

MotionBuilderのワークフロー
ここでは 9 つのチュートリアルでMotionBuilderソフトウェア製品の一般的な
ワークフローを説明します。これらのチュートリアルを活用して、MotionBuilder
に慣れてください。専用のチュートリアルがないチュートリアルの手順について

は、MotionBuilderヘルプを参照してください。

チュートリアルでは、キャラクタアニメーションプロジェクトのために

MotionBuilderを使用していることを前提にしていますが、このワークフロー
は、他の 3D モデリングやレンダリングソフトウェアと連動してMotionBuilder
を使用しているアニメーションプロジェクトであればどれにでも簡単に応用で

きます。

MotionBuilderを使用するための基本的なワークフローには次の 2つがありま
す。

■ Autodesk 相互運用性ワークフロー

■ 標準ワークフロー

合理化された相互運用性ワークフローを使用する Autodesk 2012ソフトウェア
を使用する場合には、Autodesk 相互運用性ワークフローを使用します。2012
以前のバージョンの 3ds Max および Maya を使用している場合、または Autodesk
FBX 形式にエクスポートする別の 3ds ソフトウェアパッケージを使用している
場合には、標準ワークフローを使用します。

Autodesk相互運用性ワークフロー

Maya および 3ds Max 2012 のいずれにも、MotionBuilderにモデルを自動的に
取り込むシングルステップの相互運用性機能があります。これらのパッケージの

2012 バージョンがない場合は、次の標準ワークフローを参照してください。

1 Mayaまたは 3ds Max 2012ソフトウェアにキャラクタモデルを作成しま
す。

MotionBuilderでアニメーションプロジェクトを開始する前に、モデリン
グの段階でいくつかのことに注意しておけば、その後のMotionBuilderで
のアニメーションプロジェクトの作業がスムーズになります。

2 |第 1章 チュートリアル



2 [File]メニューから[Send to MotionBuilder]を選択して、Mayaまたは 3ds
Maxからキャラクタモデルをエクスポートします。

MotionBuilder2012がインストールされている場合には、キャラクタモ
デルを起動してロードします。

3 モデルがMotionBuilderにロードされたら、3ds MaxまたはMotionBuilder
のキャラクタアセットをその上にドラッグしてアニメーション化する準備

をします。

キャラクタアセットを使用すると、キャラクタモデルの構造をマップ化

して、MotionBuilderでアニメーション化するのに役立ちます。このマッ
ピングプロセスを完了したら、キャラクタモデルをキャラクタライズし

て、アクティブ化します。キャラクタライズにより、このキャラクタモデ

ルをアニメーション化する準備が整ったことがMotionBuilderに伝えられ
ます。1 つ目のチュートリアルでは、キャラクタモデルを MotionBuilder
にインポートし、アニメーション化する準備を行う方法について説明しま

す。

「キャラクタモデルをロードし、キャラクタライズする (16ページ)」を
参照してください。

4 コントロールリグを追加し、キャラクタアニメーションでの必要に応じ

て、カスタマイズします。

コントロールリグはキャラクタモデルの制御や配置をしやすくするため

のアニメーションツールです。

2 つ目のチュートリアルでは、コントロールリグのカスタマイズ方法、お
よび床の接触や Auxiliary ピボットなどのキャラクタアニメーション機能
の追加方法について説明します。

「コントロールリグを作成し、カスタマイズする (19ページ)」を参照し
てください。

5 プロップ(小道具)や人間以外の身体部分をサポートするために、キャラク

タエクステンションを追加します。

3 つ目のチュートリアルでは、余分な手足を持つキャラクタを追加する方
法について説明します。この例では、キャラクタの右肩に、大きなハサミ

の付いた「サーボアーム」を追加します。

「キャラクタエクステンションを作成する (30ページ)」を参照してくだ
さい。
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6 いろいろなキーフレーム設定やキャラクタアニメーション機能を使用し

て、アニメーションを作成します。

■ アニメーションを作成するための効率的な手法の 1 つとして、いろい
ろな時点で、キャラクタにペーストできるポーズのセットを作成するこ

とができます。

4 つ目のチュートリアルでは、コントロールリグと Pose Control を使
用して、歩行サイクルを作成する方法を説明します。

「歩行サイクルを作成する (43ページ)」を参照してください。

■ 7 つ目のチュートリアルでは、Story ウィンドウでクリップを使用し
て、歩行サイクルを作成する方法について説明します。

「ループを作成する (84ページ)」を参照してください。

7 アニメーションを編集し、微調整します。

■ 6 つ目のチュートリアルでは、レイヤを使用して、アニメーションを編
集する方法について説明します。

「キャラクタアニメーションを編集する (71ページ)」を参照してくだ
さい。

■ 8 つ目のチュートリアルでは、Story ウィンドウを使用してアニメー
ションを結合する方法について説明します。

「クリップを操作する (99ページ)」を参照してください。

8 Characterモデル同士の間で、アニメーションをリターゲットします。

アニメーションプロジェクトの途中で、キャラクタモデルが変更される

こともあり得ます。MotionBuilderでのアニメーション作成に必須の手順
ではありませんが、新しいモデルでアニメーションを作成し直すのではな

く、単純に同じアニメーションを別のモデルに適用することも可能です。

5 つ目のチュートリアルでは、キャラクタモデルどうしの間で、アニメー
ションとキャラクタエクステンションを転送する方法について説明しま

す。

「キャラクタアニメーションをリターゲットする (60ページ)」を参照し
てください。

9 MotionBuilderで 3ds Maxキャラクタをアニメートした後、そのアニメー
ションを 3ds Maxで使用するには、3ds Maxシーンを MotionBuilderに
インポートし、MotionBuilderでアニメートした後、3ds Maxにアニメー
ションをインポートする必要があります。

最後のチュートリアルでは、MotionBuilderにアニメーションをインポー
トし、MotionBuilderでアニメートし、MotionBuilderからアニメーショ
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ンをエクスポートし、それを 3ds Max にインポートする主な手順について
説明します。

主なセクション、「3ds Max のスケルトン (113ページ)」、「3ds Max
Biped (121ページ)」、「3ds Max のキャラクタ(131ページ)」、「3ds Max
のキャラクタを MotionBuilder でアニメートする (142ページ)」を参照し
てください。

標準ワークフロー

Maya および 3ds Max 2012 のいずれにも、MotionBuilderにモデルを自動的に
取り込むワンステップの相互運用性機能があります。これらのパッケージの 2012
バージョンがない場合には、適切な Maya または 3ds Max FBX プラグインをイ
ンストールして、モデルをMotionBuilderに転送する必要があります。無償の
FBX プラグインはここからダウンロードできます。

別の 3D ソフトウェアパッケージを使用している場合には、ここからダウンロー
ドできる無償の FBX Converter を使用してファイルを FBX に変換することがで
きます。

1 3Dソフトウェアでキャラクタモデルを作成します。

MotionBuilderでアニメーションプロジェクトを開始する前に、モデリン
グの段階でいくつかのことに注意しておけば、その後のMotionBuilderで
のアニメーションプロジェクトの作業がスムーズになります。

2 モデリングソフトウェアパッケージからキャラクタモデルをエクスポー

トします。

モデリングソフトウェアパッケージから作品をエクスポートする場合、

インストールした FBX Plug-in により、キャラクタモデルを .fbxファイ
ルフォーマットで保存することができます。このフォーマットを使用すれ

ば、MotionBuilderにモデルをロードできます。

3 MotionBuilderを起動し、キャラクタモデルをロードします。

モデルをMotionBuilderにロードしたら、MotionBuilderキャラクタア
セットを使用して、このモデルがアニメートされるようにセットアップで

きます。

4 モデルがMotionBuilderにロードされたら、3ds MaxまたはMotionBuilder
のキャラクタアセットをその上にドラッグしてアニメーション化する準備

をします。

キャラクタアセットを使用すると、キャラクタモデルの構造をマップ化

して、MotionBuilderでアニメーション化するのに役立ちます。このマッ
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ピングプロセスを完了したら、キャラクタモデルをキャラクタライズし

て、アクティブ化します。キャラクタライズにより、このキャラクタモデ

ルをアニメーション化する準備が整ったことがMotionBuilderに伝えられ
ます。

5 キャラクタモデルにキャラクタアセットを追加し、キャラクタライズしま

す。

キャラクタアセットを使用すると、キャラクタモデルの構造をマップ化

して、MotionBuilderでアニメーション化するのに役立ちます。このマッ
ピングプロセスを完了したら、キャラクタモデルをキャラクタライズし

て、アクティブ化します。キャラクタライズにより、このキャラクタモデ

ルをアニメーション化する準備が整ったことがMotionBuilderに伝えられ
ます。コントロールリグや[Story]ウィンドウでのアニメートを含め、
MotionBuilderの主要なキャラクタアニメーション機能すべてで、キャラ
クタライズされたキャラクタが必要です。

最初のチュートリアルでは、Character アセットの作り方と、これを使用
して、キャラクタモデルの構造をマップ化する方法について説明します。

「キャラクタモデルをロードし、キャラクタライズする (8ページ)」を
参照してください。

6 コントロールリグを追加し、キャラクタアニメーションでの必要に応じ

て、カスタマイズします。

コントロールリグはキャラクタモデルの制御や配置をしやすくするため

のアニメーションツールです。

2 つ目のチュートリアルでは、コントロールリグのカスタマイズ方法、お
よび床の接触や Auxiliary ピボットなどのキャラクタアニメーション機能
の追加方法について説明します。

「コントロールリグを作成し、カスタマイズする (19ページ)」を参照し
てください。

7 プロップ(小道具)や人間以外の身体部分をサポートするために、キャラク

タエクステンションを追加します。

3 つ目のチュートリアルでは、余分な手足を持つキャラクタを追加する方
法について説明します。この例では、キャラクタの右肩に、大きなハサミ

の付いた「サーボアーム」を追加します。

「キャラクタエクステンションを作成する (30ページ)」を参照してくだ
さい。
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8 いろいろなキーフレーム設定やキャラクタアニメーション機能を使用し

て、アニメーションを作成します。

■ アニメーションを作成するための効率的な手法の 1 つとして、いろい
ろな時点で、キャラクタにペーストできるポーズのセットを作成するこ

とができます。

4 つ目のチュートリアルでは、コントロールリグと Pose Control を使
用して、歩行サイクルを作成する方法を説明します。

「歩行サイクルを作成する (43ページ)」を参照してください。

■ 7 つ目のチュートリアルでは、Story ウィンドウでクリップを使用し
て、歩行サイクルを作成する方法について説明します。

「ループを作成する (84ページ)」を参照してください。

9 アニメーションを編集し、微調整します。

■ 6 つ目のチュートリアルでは、レイヤを使用して、アニメーションを編
集する方法について説明します。

「キャラクタアニメーションを編集する (71ページ)」を参照してくだ
さい。

■ 8 つ目のチュートリアルでは、Story ウィンドウを使用してアニメー
ションを結合する方法について説明します。

「クリップを操作する (99ページ)」を参照してください。

10 Characterモデル同士の間で、アニメーションをリターゲットします。

アニメーションプロジェクトの途中で、キャラクタモデルが変更される

こともあり得ます。MotionBuilderでのアニメーション作成に必須の手順
ではありませんが、新しいモデルでアニメーションを作成し直すのではな

く、単純に同じアニメーションを別のモデルに適用することも可能です。

5 つ目のチュートリアルでは、キャラクタモデルどうしの間で、アニメー
ションとキャラクタエクステンションを転送する方法について説明しま

す。

「キャラクタアニメーションをリターゲットする (60ページ)」を参照し
てください。

11 完成したアニメーションをモデルのスケルトンにプロットします。

キャラクタアニメーションの作成に使用しているアニメーション機能に

よっては、コントロールリグからキャラクタモデルスケルトンへのプロッ

ト作業や、Story ウィンドウのトラックをシングルテイクにプロットする
作業が行われます。
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アニメーション化に使用される方法が何であれ、エクスポート前に、完成

した結果をキャラクタモデルのスケルトンにプロットする必要がありま

す。

12 プロットしたモデルを .fbxファイルとして保存します。
完成したアニメーションは、任意のソフトウェアでレンダリングできるよ

うに、適切な FBX Plug-In を使用してエクスポートすることもできます。

最新の FBX Plug-in は、http://www.autodesk.co.jp/fbxからダウンロードで
きます。

キャラクタモデルをロードし、キャラクタライ
ズする

このチュートリアルでは、キャラクタモデルをMotionBuilderに取り込み、ア
ニメーションにするための準備の手順について説明します。

コントロールリグを作成し、ポーズを作成し、その他のアニメーションツール

を使用するには、MotionBuilderに取り込んだキャラクタモデルをキャラクタ
ライズする必要があります。キャラクタモデルをキャラクタライズするには、

モデルの構造をマッピングする必要があります。

このチュートリアルで使用するアセット:

■ mia_blue.fbx

注: チュートリアル用のアセットは Asset Browser の Tutorialsフォルダ(または
システム上のMotionBuilderディレクトリ内のTutorialsフォルダ)にあります。

シーンを準備する

次の手順では、MotionBuilderシーンを準備し、このチュートリアルを開始す
るのに必要なファイルを開きます。

1 メニューバーから File > New を選択し、Layout > Editing を選択します
(Ctrl+Shift+3キー)。
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MotionBuilderは、Editing レイアウトを使用して新しい 3D シーンを表
示します。このレイアウトには、このチュートリアルで作業するのに必要

なすべてのウィンドウが表示されます。

2 Asset Browser で Tutorialsフォルダをクリックします。

3 mia_blueアセット(mia_blue.fbxファイル)を Asset Browser から Viewer
ウィンドウへドラッグし、FBX Open > No Animation を選択します(図を
参照)。

Viewer ウィンドウに、Mia という名前のモデルが T-スタンスで表示され
ます。
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T-スタンスの Mia

注:

このモデルは Maya で作成されたもので、ボーンにはMotionBuilderの
マッピングリストにある命名規則に従って名前が付けられています。

4 [File] > [Save As]を選択します。

Save File ダイアログボックスが表示されます。

5 ファイルを保存するディレクトリ(デフォルトのMotionBuilderTutorials
ディレクトリ以外のディレクトリ)に移動し、[Save]をクリックします。

Save Options ダイアログボックスが表示されます。

6 Save をクリックします。

デフォルトのMotionBuilderTutorialsデフォルト以外のデフォルトにファ
イルを保存することで、元の .fbxファイルが上書きされません。
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キャラクタマップを仕上げる

次の手順では、マッピングリスト内で必要なノードをマッピングして、

MotionBuilderのキャラクタモデルの構造を定義します。キャラクタマッピン
グは、MotionBuilderに対してキャラクタモデルを記述する作業で、何が足で
何が腕にあたるかといったことを指示していきます。

Character アセットを直接、キャラクタモデルにドラッグしてキャラクタのマッ
ピングとキャラクタライズを自動で処理することもできますが、このチュートリ

アルでは Mia の構造を手動でマッピングします。

1 Asset Browser の Templates > Charactersフォルダから、シーンの空の領
域に Characterアセットをドラッグします。

Characterアセットをシーンにドラッグします。

Character アセットが Scene Browser に追加され(A)、Navigator ウィンド
ウに Character Settings が表示されます(B)。
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Navigatorウィンドウ: A. Scene Browserのキャラクタ B. Character Settings

2 Character Settings で Character Definition ペインに切り替えて、マッピ
ングリストでノードの Base (required)グループを展開します(A)。

Character Definitionペイン: A. Baseノード

このノードグループは、MotionBuilderがキャラクタモデルの構造を認
識するための必須のグループです。キャラクタを自動的にキャラクタライ

ズしたとすると、マッピングリストにはキャラクタのボーン名が自動的に

入力されます。

3 Viewer ウィンドウで、Schematic ビューに切り替え(Ctrl+Wキー)、Aキー
を押して、階層をフレームします。
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Mia構造の Schematicビュー

Schematic ビューを使用すると、各ボーンが長方形のノードとして表され
るので、モデルの階層からボーンを選択しやすくなります。

4 Scene Browser で Lock オプションを有効にして、Character Definition
ペインのビューをロックします。こうすると、何を選択しても Character
Definition ペインが開いたままになります。

Navigatorウィンドウ: A. Scene Browser Lockオプションがオン

5 Schematic ビューで、ズームインとパンを行って Mia:LeftUpLegノード
を検索し、このノードを選択します。

[ビューアナビゲーション]ボタン: A. [移動]ボタン B. [ズーム]ボタン
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ヒント: [Viewer]ウィンドウでは、 [Ctrl]キーを押しながらドラッグして
ズームインしたり、[Shift]キーを押しながら移動(またはパン)することが
できます。

Mia:LeftUpLegノードが選択された状態

注: Schematic ビューで選択したいノードの正確な名前が分かっている場
合は、Shift+Nキーを押して Find Model by Name ダイアログボックス
を開き、ノードをすばやく検索できます。

6 Mia:LeftUpLegノードを Base (required)LeftUpLegのマッピングリスト
スロットへ、Altキーを押しながらドラッグします。

MotionBuilderの LeftUpLegにマッピングされた Miaの LeftUpLegノード
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このキャラクタをキャラクタライズすると、MotionBuilderは、このスケ
ルトンについては LeftUpLegノードを「Mia:LeftUpLeg」と呼ぶことを認
識します。

7 次のチェックリストと図をガイドとして使用し、残りの Mia ボーンを、
マッピングリストの Base (必須)ノードにマップします。

注:

Mia には多くのボーンがありますが、MotionBuilder のキャラクタライズ
では、15 個の Base グループをマップする必要があるだけです。

マップ済みスロットボーン

HipsMia:Hips

XLeftUpLegMia:LeftUpLeg

LeftLegMia:LeftLeg

LeftFootMia:LeftFoot

RightUpLegMia:RightUpLeg

RightLegMia:RightLeg

RightFootMia:RightFoot

SpineMia:Spine

LeftArmMia:LeftArm

LeftForeArmMia:LeftForeArm

LeftHandMia:LeftHand

RightArmMia:RightArm

RightForeArmMia:RightForeArm
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マップ済みスロットボーン

RightHandMia:RightHand

HeadMia:Head

Base グループのキャラクタマッピングが完了すると、マッピングリスト
は次の図のようになります。

Miaの Baseボーンをマッピングリストの Baseノードにマッピングした状態

これでキャラクタマッピングは完了です。

キャラクタモデルをキャラクタライズする

次の手順では、モデルをキャラクタライズする方法について説明します。キャラ

クタモデルをキャラクタライズすると、マッピングリストで定義した構造が
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MotionBuilderにより読み取られ、モデルの現在のポーズが以降のすべてのポー
ズと動きのベースになると解釈されます。

1 Character Definition ペインで、Characterize オプションを有効にします
(A)。

Character Definitionペイン: A. Characterizeオプション

2 表示される Character ダイアログボックスで Biped をクリックします(A)。
これは、Mia スケルトンが 2 本脚で立ち、足だけでフロア(床面)と接触す
るためです。

Characterダイアログボックス: A. Bipedオプション

キャラクタがすべてのソースと互換性を持ち、キャラクタがキャラクタラ

イズされ、MotionBuilder がその構造を認識するように汎用のオフセット
が計算されます。

マッピングリストのノードはグレーになり、編集できません。
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注:

後でボーンを追加したり、マッピングリストを編集したりする必要がある

場合は、キャラクタが T-スタンスであるときに、Characterize オプション
を一時的に無効にします。

3 Scene Browser で、Characterブランチを展開し、Character アセットを
右クリックし、コンテキストメニューから Rename を選択して、キャラ
クタに "Mia" という名前を付けます(A)。
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Scene Browser: A. Characterアセットに Miaという名前を付けます。

キャラクタは完全にキャラクタライズされ、アニメートする準備が整いま

した。

まとめ

このチュートリアルでは、キャラクタモデルをロードし、その構造をマップ化

して、キャラクタライズしました。

次のチュートリアル(「コントロールリグを作成し、カスタマイズする (19ペー
ジ)」)では、キャラクタライズしたキャラクタのコントロールリグを作成してカ

スタマイズします。

コントロールリグを作成し、カスタマイズする

このチュートリアルでは、コントロールリグを作成し、後のチュートリアルで

アニメーションを作成するために、このコントロールリグをカスタマイズする

方法について説明します。

コントロールリグはキャラクタモデルの制御や配置をしやすくするためのアニ

メーションツールです。コントロールリグは他のモデルに再利用することがで

きます。

このチュートリアルで使用するアセット:

■ mia_characterized.fbx
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注: チュートリアル用のアセットは Asset Browser の Tutorialsフォルダ(または
システム上のMotionBuilderディレクトリ内のTutorialsフォルダ)にあります。

シーンを準備する

次の手順では、MotionBuilderシーンを準備し、このチュートリアルを開始す
るのに必要なファイルを開きます。

1 メニューバーから File > New を選択し、Layout > Editing を選択します
(Ctrl+Shift+3キー)。

MotionBuilderは、Editing レイアウトを使用して新しい 3D シーンを表
示します。このレイアウトには、このチュートリアルで作業するのに必要

なすべてのウィンドウが表示されます。

2 Asset Browser で Tutorialsフォルダをクリックします。

3 mia_characterizedアセット(mia_characterized.fbxファイル)を Asset
Browser から Viewer ウィンドウへドラッグし(図を参照)、FBX Open > No
Animation を選択します。

T-スタンスの Mia

Viewer ウィンドウに Mia という名前のモデルが T-スタンスで表示されま
す。
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4 [File] > [Save As]を選択します。

Save File ダイアログボックスが表示されます。

5 ファイルを保存するディレクトリ(デフォルトのMotionBuilderTutorials
ディレクトリ以外のディレクトリ)に移動し、[Save]をクリックします。

Save Options ダイアログボックスが表示されます。

6 Save をクリックします。

デフォルトのMotionBuilderTutorialsデフォルト以外のデフォルトにファ
イルを保存することで、元の .fbxファイルが上書きされません。

コントロールリグを作成する

次の手順では、Mia キャラクタのコントロールリグを作成および準備します。

1 Scene Browser で Charactersブランチを展開し、Miaキャラクタをダブ
ルクリックします。

2 Character Definition ペイン(A)をクリックし、Control Rig 領域(B)で Create
をクリックします。

Character Definition: A.設定 B. Control Rig領域

3 表示された Create Control Rig ダイアログボックスで、FK/IK を選択しま
す(A)。

Create Control Rigダイアログボックス: A. FK/IKオプション

コントロールリグを作成し、カスタマイズする | 21



Mia キャラクタ用に FK/IK コントロールリグが作成されます。

4 Character Controls ウィンドウで Character Controls をクリックし、Ctrl
Rig In オプションをオンにします。これにより、コントロールリグが Mia
キャラクタのアクティブなモーションソースになります。

Character Controls: A. Ctrl Rig Inオプションがオンの状態

5 Viewer ウィンドウをクリックし、X-Ray 表示モードになるまで Ctrl+A
キーを押し続けます。

注:

表示モードは Viewer ウィンドウの左下に表示されます。

X-Ray 表示モードでは、コントロールリグを構成する FK エフェクタと IK
エフェクタを確認できます。

■ 青色と赤色の IK エフェクタでは、人間の体の動きをシミュレートする
設定を使用して、直感的にキャラクタを操作できます。
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■ 黄色の FK エフェクタでは、個々のボディパーツを選択して微調整で
きます。キャラクタの微調整を行う予定の場合は、FK エフェクタと IK
エフェクタの両方を使用してコントロールリグを作成します。

6 Navigator ウィンドウで Character Settings ペインに切り替えます(B)。

Character Settingsペイン: A. Input Typeメニュー B. Activeオプションがオンの
状態

コントロールリグは、Character Settings ペインの Input Type メニュー
および Active オプションでも、アクティブなモーションソースとして表
示されます(A および B)。

足のフロアコンタクトマーカを調整する

次の手順では、フロアコンタクトマーカを使用して、キャラクタの足がどのよ

うにフロア(床面)に接触するかを調整します。

フロアコンタクトマーカは、キャラクタモデルをキャラクタライズするとキャ

ラクタの手と足の周囲に表示される青色と緑色のマーカです。これらのマーカ

は、キャラクタの足がフロアと接触する場所を決める不可視のグリッドを作成し

ます。

緑と青のフロアコンタクトマーカが、Miaの両手と両足の周囲に表示されます。
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注: [Character Definition]ペインのマッピングリストでフロアオブジェクトが
定義されていない場合、MotionBuilderのグリッドが床として使用されます。
このチュートリアルでは、フロアは定義しません。

1 Viewer ウィンドウで View メニューをクリックし、Orthographic >
Producer Right を選択して(または Viewer 内でクリックし、Ctrl+Rキー
を押して)、Producer Right カメラビューに切り替えます。

2 Mia の足にズームインします(図を参照)。

3 Mia の足の下にあるフロアコンタクトマーカのいずれかをクリックしま
す。

4 Viewer ツールバーで Translate ボタンをクリック(Tキー)して Translate
モードをアクティブにします。

5 フロアコンタクトマーカを移動します。次の説明と図を参考にして、マー

カの位置を合わせてください。

■ 中部のマーカをつま先のボーンが始まる場所に位置合わせします(B)。

■ 前部のマーカをモデルのつま先に位置合わせします(A)。

■ 後部のマーカをモデルのかかとに位置合わせします(C)。

Miaの足とフロアコンタクトマーカ: A.前部のマーカ B.中部のマーカ C.後部
のマーカ
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注:

片方の足のマーカを移動すると、それに合わせてもう片足のマーカも

調整されます(つまり、Mia の左足の緑のマーカを調整すると、右足の
青のマーカも自動的に調整されます)。

6 Orthographic Producer Front ビューに切り替えて(Ctrl+Fキー)、両足に
ズームインして(Ctrl+ドラッグ)、足のマーカを左右に移動させて次の図
のように両足の端に配置します。

マーカの左および右の位置

7 Character Settings ペインで Floor Contacts (A)を展開し、Feet Floor
Contactオプション(B)をオンにします。

Character Settingsペイン A.プロパティの Floor Contactsグループ B. Feet Floor
Contactオプション
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手とフロアコンタクトマーカを調整する

ここでは、Mia の手がフロア(床)に触れたときにリアルに反応するように、手の
フロアコンタクトを定義します。

1 Scene Browser でMiaキャラクタをダブルクリックし、Character Settings
ペインをクリックして Character Settings を表示します。

2 Character Settings ペインで、Floor Contacts (A)が展開されていない場合
はこれを展開し、Hands Floor Contact (B)オプションと Fingers Floor
Contact (C)オプションをオンにして、手と指のフロアコンタクトを有効
にします。

Character Settingsペイン: A. Floor Contacts B. Hands Floor Contact C. Fingers
Floor Contact

3 Hands Floor Contact Setupを展開し、Hands Contact Typeメニュー(A)
をクリックして Wristを選択します。

Character Settingsペイン: A. Hands Contact Type B. Wrist
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デフォルトでは Hands Contact Typeは Normalに設定されており、手に
は 6 個のフロアコンタクトマーカが割り当てられます。このオプション
をWristに変更すると、それぞれの手に基本的な制御のための 4 個のフロ
アコンタクトマーカが提供されます。

4 Viewer ウィンドウで各種カメラビューを使用して、Mia の左右どちらか
の手にズームインします。

5 手の後部のマーカを手首に、前部のマーカを指(親指以外)の付け根に位置

合わせします。さらに、次の図に示すように、後部のマーカを Y 軸に沿っ
て下へ移動して、手のひらの付け根に位置合わせします。

Auxiliaryピボットを追加する
次の手順では、Mia のコントロールリグにある IK システムをさらに詳細に制御
できるようにする 2 つの Auxiliary ピボットを作成します。これらの Auxiliary
オブジェクトを使用して、Mia の歩行に伴い、Mia の足にリアルな回転を作成
できます。また、これらのオブジェクトを使用すると、キーフレームアニメー

ションの作成時に Mia の足を回転しやすくなります。

1 Character Controls ウィンドウで、Left Ankle セルを右クリックし、コン
テキストメニューから Create Aux Pivotを選択します(A)。
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Character Controls A. Left Ankleエフェクタセルのコンテキストメニューオプ
ション

左足首の IK エフェクタに Auxiliary ピボットが作成されます(A)。Auxiliary
ピボットは、Character Controls ウィンドウの Left Ankle セルでは X 印
で示されます(B)。

A. Viewerウィンドウの Auxiliaryピボット B. X印が Auxiliaryピボット

デフォルトでは、Auxiliary ピボットを作成すると、足のエフェクタは選択
解除され、Auxiliary ピボットが選択されます。Viewer ウィンドウで、
Pivot Selection モードが自動的に選択されます。
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Viewerウィンドウ A. Pivot Selectionモード

2 次の図のように作成した Auxiliary ピボットが選択されていない場合はこ
れを選択し、移動して Mia のつま先と重なる位置に配置します。

左足首の Auxiliaryピボット A.前面図 B.側面図

注:

Character Controls の Show メニューを使用して、Auxiliary ピボットを
配置するときにコントロールリグエフェクタとフロアコンタクトマーカ

を非表示にすることができます。

3 Left Ankle セルをもう一度右クリックし、コンテキストメニューから
Create Aux Pivotを選択します。
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左足首に Auxiliaryピボットを作成します。

Viewer ウィンドウに 2 つ目の Auxiliary ピボットが表示されます。

4 2 つ目の Auxiliary ピボットをかかとの位置に移動します(図を参照)。

まとめ

このチュートリアルでは、コントロールリグを作成し、キャラクタの足にフロ

アコンタクトマーカを配置してから、足の回転を制御するために 2 つの Auxiliary
ピボットを作成しました。

次のチュートリアル「キャラクタエクステンションを作成する (30ページ)」で
は、Mia キャラクタに Character Extension を追加します。

キャラクタエクステンションを作成する

このチュートリアルでは、キャラクタに追加された付属物を制御できるようにす

るためのキャラクタエクステンションの作成に必要な手順について説明します。
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ここでは、Mia キャラクタの腕をロードし、キャラクタエクステンションを使
用して腕を Mia にアタッチしたら、胴体に対応して動く腕のアニメーションを
定義します。

このチュートリアルで使用するアセット:

■ mia_rigged.fbx
■ servo.fbx

注: チュートリアル用のアセットは Asset Browser の Tutorialsフォルダ(または
システム上のMotionBuilderディレクトリ内の Tutorialsフォルダ)にあります。

シーンを準備する

以下の手順では、MotionBuilderシーンを準備し、このチュートリアルを開始
するのに必要なファイルを開きます。

1 メニューバーから File > New を選択し、Layout > Editing を選択します
(Ctrl+Shift+3キー)。

MotionBuilderは、Editing レイアウトを使用して新しいシーンを表示し
ます。このレイアウトには、このチュートリアルで作業するのに必要なす

べてのウィンドウが表示されます。

2 Asset Browser で Tutorialsフォルダをクリックします。

3 mia_riggedアセット(mia_rigged.fbxファイル)を Asset Browser から
Viewer ウィンドウへドラッグし、コンテキストメニューから FBX Open
> No Animation を選択します(図を参照)。
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キャラクタライズされた Miaが Viewerウィンドウに表示されます。

Viewer ウィンドウに Mia という名前のキャラクタライズ済みのモデルが
T-スタンスで表示されます。

4 Asset Browser の servoアセット(servo.fbxファイル)をシーンへドラッグ
し、コンテキストメニューから FBX Merge > No animation を選択しま
す。

サーボアームがシーンにロードされ、Mia の肩の上に配置されます。次の
手順では、もう 1 本の腕として、この腕を Mia にアタッチします。
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Miaとサーボアームがシーンにロードされた状態

5 [File] > [Save As]を選択します。

Save File ダイアログボックスが表示されます。

6 ファイルを保存するディレクトリ(デフォルトのMotionBuilderTutorials
ディレクトリ以外のディレクトリ)に移動し、[Save]をクリックします。

Save Options ダイアログボックスが表示されます。

7 Save をクリックします。

デフォルトのMotionBuilderTutorialsデフォルト以外のデフォルトにファ
イルを保存することで、元の .fbxファイルが上書きされません。

追加した腕をキャラクタに接続する

次の手順では、サーボアームと Mia の肩の間に親子関係を作成します。

1 Viewer ウィンドウを X-Ray 表示モードに切り替えます（Ctrl+Aキー）。

注: キーボードショートカット Ctrl+Aキーを押すと Normal モード、
Models Only モード、X-Ray モードが順に切り替わります。

2 [Character Controls]ウィンドウで、Mia が現在のキャラクタとして選択
されていることを確認します。
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3 Viewer ウィンドウをクリックして、次の操作を実行します。

■ Ctrl+Wキーを押して Schematic ビューに切り替えます。

■ Schematic ビュー内を右クリックし、コンテキストメニューから
Auto-Arrange を選択してから Arrange-All を選択します。

■ Aキーを押して、Schematic ビューにすべてのノードを表示します。

Schematic ビューには、Mia のスケルトンの階層(A)、コントロールリ
グ(B)、およびサーボアームの 3 番目の階層が表示されます
(「ServoMaster」、C)。

シーンの階層構造の Schematicビュー: A. Miaのスケルトン B. Miaのコント
ロールリグ C.サーボアーム

4 ビューの右側で、サーボアーム(ServoMaster)階層にズームインし(C)、
ServoMaster ノードを選択します。
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ServoMasterノードを選択

5 Producer カメラビューに切り替え(Ctrl+Wキー)、Mia の右肩にズームイ
ンします。ServoMaster ノードのヌルが依然として選択されています。

Viewerウィンドウで ServoMasterのヌルが選択されています。

6 [P]キーを押して Parent モードを有効にした後、ServoMaster のヌルを
Mia:RightShoulder ボーンにドラッグします(A)。

サーボアームに親子の関連付けを行うと、ボーンは緑色で強調表示されま

す。これにより、サーボアームは右肩ボーンの子になります(B)。
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A. ServoMasterのヌルを Miaの右肩ボーンの子に設定 B.親子関係が設定された状
態

7 Schematic ビューに切り替えて、サーボアームが Mia:RightShoulder ボー
ンの子になっていることを確認します。

Schematicビューで見た親子関係 A. Mia:RightShoulderボーン B.サーボアーム
階層

注:

Mia:RightShoulder ノードは Schematic ビューの左側に表示されます。必
要に応じて、右クリックして Auto Arrange を選択し、表示を整理します。

8 Producer Perspective ビューに切り替えます。

9 Mia のサーボアームの先端にある ServoControl エフェクタ(A)を選択し、
Parent モードで同様に Mia の右肩ボーンの子に設定します。
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A. ServoControlエフェクタ B.右肩ボーン

10 Schematic ビューに切り替えて、 ServoControl エフェクタが
Mia:RightShoulder ボーンの子になっていることを確認します。

Schematicビューで見た親子関係 A. Mia:RightShoulderボーン B. ServoControl
エフェクタ
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キャラクタエクステンションを作成する

ここでは、キャラクタエクステンションを作成してサーボアームを Mia キャラ
クタに接続することで、サーボアームと Mia キャラクタをまとめてコントロー
ルし、キーフレームを設定できるようにします。

1 Scene Browser で、Characters を展開し、Mia を右クリックして、コンテ
キストメニューから Create Character Extension を選択します(A)。

Scene Browser: A.[Create Character Extension]オプション

2 Scene Browser で Character Extensions フォルダを展開し、Mia Extension
を表示します(C)。
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Scene Browser: A. Miaキャラクタに追加されたキャラクタエクステンション B.
Scene Browserに追加された Character Extensions項目 C. Miaキャラクタにち
なんで名づけられたキャラクタエクステンション

3 Producer Perspective ビューに切り替えます。

4 Scene Browser で、[Viewer]ウィンドウの ServoControl エフェクタを[Alt]
キーを押しながら[Mia Extension]上にドラッグし、コンテキストメニュー
から[Add to Mia Extension]を選択します(次の図を参照)。
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A. ServoControlエフェクタ B. ServoControlエフェクタを Mia Extensionに追加
します。

サーボアームは Mia のキャラクタエクステンションとして定義され、キャ
ラクタの新しい「ボディパーツ」として認識されます。

5 ServoControl エフェクタを選択したままの状態で、Properties ウィンドウ
を開きます。

注:

[Properties]ウィンドウは、インタフェースの右側にある[Resources]ペイン
のタブの 1 つです。または、[Window] > [Add Property View]をクリック
して、ウィンドウを表示します。

Asset Browserの Propertiesウィンドウ
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6 緑色のカスタムプロパティ Close_Openを選択し、スライダを左右にド
ラッグします(図を参照)。

A. サーボアームが開きます。B.カスタムプロパティ Close_Open

Viewer ウィンドウでは、サーボアームのハサミが動きます。

7 Altキーを押しながら、Close_OpenプロパティをMia Extension上にド
ラッグし(A)、コンテキストメニューから Create 1 Property Reference
を選択します(B)。

A. Close_Openプロパティを Mia Extension上へドラッグします。B. Create 1
Property Referenceを選択します。

8 Scene Browser で Mia Extensionを選択し(A)、Properties ウィンドウの
Lock オプションを有効にして(B)、何を選択しても Mia Extensionのプロ
パティが開いたままになるようにします。
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A. Mia Extensionを選択します。B. Propertiesウィンドウの Lockオプションをオ
ンにします。

9 Altキーを押しながら、Mia:RightShoulder ボーンを Properties ウィンド
ウの Reference Object フィールドにドラッグして(A)、Mia の右肩ボーン
をキャラクタエクステンションのリファレンスオブジェクトとして定義し

ます(B)。

A. Mia:RightShoulder B. Mia:RightShoulderリファレンスオブジェクト

10 表示される Reference Object Change ダイアログボックスで OK をクリッ
クします。

キャラクタエクステンションのリファレンスオブジェクトは、たとえば

ポーズにキャラクタエクステンションが含まれている場合に、エクステン

ションの以降のすべての位置を計算するのに使用されます。
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注: また、[Properties]ウィンドウで[Add To Full Body]オプションを有
効にして、[Full Body]キー操作モードでキーを設定するときに、キャラク
タエクステンションをキー操作するかどうかを定義することもできます。

まとめ

このチュートリアルでは、キャラクタエクステンションを作成して、Mia キャ
ラクタに腕を追加しました。

次のチュートリアル、「歩行サイクルを作成する (43ページ)」では、Pose コン
トロールを使用して、このキャラクタとキャラクタエクステンションをアニメー

トします。

歩行サイクルを作成する

このチュートリアルでは、ポーズを使用して、歩行サイクルを作成する手順につ

いて説明します。

このチュートリアルで使用するアセット:

■ mia_servo.fbx

注: チュートリアル用のアセットは Asset Browser の Tutorialsフォルダ(または
システム上のMotionBuilderディレクトリ内のTutorialsフォルダ)にあります。

シーンを準備する

次の手順では、MotionBuilderシーンを準備し、このチュートリアルを開始す
るのに必要なファイルを開きます。

1 メニューバーから File > New を選択し、Layout > Editing を選択します
(Ctrl+Shift+3キー)。

MotionBuilderは、Editing レイアウトを使用して新しい 3D シーンを表
示します。このレイアウトには、このチュートリアルで作業するのに必要

なすべてのウィンドウが表示されます。

2 Asset Browser で Tutorialsフォルダをクリックします。
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3 mia_servoアセット(mia_servo.fbxファイル）を Viewer ウィンドウにド
ラッグして、表示されるコンテキストメニューから FBX Open > No
Animation を選択します。

以下の図のように、Mia (mia_servoアセット)という名前のモデルが
[Viewer]ウィンドウに表示されます。このキャラクタには、右肩のボーン
を親とし、Character Extension (キャラクタエクステンション)として追
加されている、「サーボアーム」が含まれています。

[Character Controls]ウィンドウで、Mia が現在のキャラクタとして[Current
Character]メニュー(A)に既定で表示されます。

A. [Character Controls]の[Current Character]メニュー
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4 [File] > [Save As]を選択します。

Save File ダイアログボックスが表示されます。

5 ファイルを保存するディレクトリ(デフォルトのMotionBuilderTutorials
ディレクトリ以外のディレクトリ)に移動し、[Save]をクリックします。

Save Options ダイアログボックスが表示されます。

6 Save をクリックします。

デフォルトのMotionBuilderTutorialsデフォルト以外のデフォルトにファ
イルを保存することで、元の .fbxファイルが上書きされません。

ポーズを作成する

この手順では、キャラクタエクステンションを含むキャラクタにいくつかのボ

ディ全体のポーズを作成して、歩行サイクルを作成します。

キャラクタの配置:

1 [Character Controls]ウィンドウで、各足首エフェクタの上のプラス記号
(+)をクリックして、両方の補助ピボットを展開します。これにより、Mia
の足首が移動(T)および回転(R)でピンされます。

プラス記号をクリックして、足首エフェクタ(A、B)を展開します。

2 [Ctrl]キーを押しながらクリックして、手首エフェクタと足首エフェク

タを選択します。
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エフェクタ: A手首エフェクタ B.足首エフェクタ

3 T および R エフェクタのピンオプションを無効にします。

[Effector Pinning]オプション: A. Tおよび Rエフェクタのピンが無効

注: 回転が確実に無効になるように、R(回転ピン)のオンとオフをもう一度
切り替えなければならない場合があります。

キャラクタ表現のどのエフェクタにも T または R がないことを確認しま
す。

4 前のスクリーンショットに示すように、Full Body キーイングモードが有
効になっていることを確認します。
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Full Body キーイングモードが有効になっている場合、ペーストしたポー
ズはキャラクタのボディ全体に配置され、キーフレームはすべてのエフェ

クタに配置されます。

5 [Character Controls]ウィンドウで、左肩エフェクタを選択します。

6 [Viewer]ウィンドウの上にカーソルを移動し、[R]キーを押して、Mia の
左腕が体の脇の、より自然な位置に来るまでエフェクタを回転させます。

注: [Viewer]ウィンドウのバックグラウンドカラーが変更され、次のスク
リーンショットでの可視性が向上します。

7 右肩エフェクタに対しても同じ操作を実行します。
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肩のエフェクタを使用して、Miaの腕を Z軸の下方向に回転

8 [Ctrl]キーを押しながら両方の手首エフェクタをクリックし、Y 軸上で上方
向に移動して、肘を自然に曲げます。

手首エフェクタを使用して手首を Y軸の上方向へ移動

9 [Viewer]ウィンドウの空の領域をクリックし、手首エフェクタを選択解除
して、キャラクタの側面が表示されるカメラビューを選択します。たとえ
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ば、Ctrl+Rキーを押すと、Producer Right カメラビューに切り替えるこ
とができます。

Producer Rightカメラビュー

注:

見やすいように、適宜カメラビューを切り替えてください。

歩行サイクルの最初のポーズの作成:

1 [Character Controls]ウィンドウで、右足首エフェクタを選択し、膝が曲が
るように、足を(Z 軸上の)前方向およびやや上方向に移動します。

2 左足首エフェクタを選択し、Mia が歩いているように見えるように、Mia
の両足が離れて両膝が曲がるまで、左足首エフェクタを後方にスライドさ

せます。

注: 足首エフェクタピボットを選択して、Mia の足首を曲げることができ
ます。

3 Mia が自然に腕を振っているように、右肩エフェクタを選択し、右腕を後
方にわずかに回転させます。次に、左肩を選択して、左腕を前方に回転さ

せます。
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4 ヒップエフェクタ <pic?> を選択し、Mia の歩幅が中程度になるように、
Mia のボディを上方向または下方向に移動します。座標変換の結果、Mia
がフロア(床面)から浮いてしまった場合はいつでも、ヒップエフェクタを

選択し、Mia を下方向に移動できます。デフォルトのフロアコントロール
マーカにより、Mia の足は自然にデフォルトのフロアに合わせて動作しま
す。

このポーズでは、Mia の右脚から前進歩行モーションが始まります(次の図
を参照)。

最初のポーズを作成できる状態

5 [Resources]ウィンドウで、[Pose Controls]タブをクリックし、[Create]

をクリックします。

[Pose]ブラウザにポーズが追加されます。

キャラクタエクステンションの位置は、このポーズの Mia のボディの位
置に含まれます。

6 [Pose]ブラウザで Posesフォルダを展開し、ポーズを表示します。

7 作成したポーズを右クリックし、Rename を選択して名前を「Walk 01」
に変更します(B)。
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Pose Controls: A.ポーズの作成 B. [Pose]ブラウザの「Walk 01」ポーズ

歩行サイクルの 2つ目のポーズの作成:

1 次の図のように見えるように、Mia の脚と腕を配置します。

■ 右足首エフェクタを選択し、Mia の足が地面に着くまで後下方にスラ
イドさせます。

■ 次に、勢いを出すために、左足首エフェクタを選択し、Mia の背後の
位置まで後方にスライドさせます。

■ ヒップエフェクタを調整し、Mia の膝を不自然でない程度に曲げます。

2 Mia:ServoControl エフェクタを選択し、Mia の正面に来るようにサーボ
アームを移動します。

3 Mia:ServoControl が選択されている状態で Asset Browser の Properties
タブをクリックし、Close_Open プロパティ(B)を使用してハサミを半分開
きます(次の図を参照)。

A.歩行サイクルの 2つ目のポーズ B. Close_Openプロパティで、ハサミを制御
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4 [Pose Controls]で[Create] をクリックし、このポーズに「Walk 02」
と名前を付けます(A)。

Pose Controls: A. 2つ目のポーズの名前を「Walk 02」に変更

歩行サイクルの 3つ目(最後)のポーズの作成:

1 次の図のように見えるように、Mia の脚と腕を配置します。

2 Mia:ServoControl エフェクタを選択し、サーボアームを、Mia の前方ま
で、さらに伸ばします。

3 Mia:ServoControl が選択されている状態で、Properties ウィンドウの
Close_Open プロパティを使用してハサミをさらに開きます(B)。

このポーズでは、左脚は後方に移動し、サーボアームは前方に移動しま

す。これにより、歩行サイクルの前半の 1 歩が完成します。

A.歩行サイクルの 3つ目のポーズ B. The Close_Openプロパティ

4 Pose Controls で Create をクリックし、このポーズに「Walk 03」と名前
を付けます。
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現在、シーンには、3 種類のポーズがあります。3 つのポーズが、Pose ブ
ラウザにリストされています。

歩行サイクルの 3つポーズを作成した状態

ポーズを使ってアニメーションを作成する

次の手順では、先ほど作成した 3 種類のポーズを使用して、歩行サイクルを半
分作成します。さまざまなフレームでこれらのポーズにキーフレームを設定し

て、短い歩行アニメーションを作成します。

1 Character Controls ウィンドウで選択されているエフェクタをすべて選択
解除し、Full Body キーイングモードが選択されていることを確認します
(A)。

Character Controls: A. Full Bodyキーイングモードが選択されています。
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2 Pose ブラウザで、「Walk 01」ポーズをダブルクリックして Mia にペー
ストします。

Pose Controls: A.歩行サイクルの最初のポーズB. Miaに「Walk 01」ポーズをペー
ストした状態

Pose Controls ウィンドウの Gravity、Translation、および Rotation オプ
ションは、デフォルトでアクティブに設定されています。つまり、ペース

トしたポーズの移動と回転は、カレントキャラクタの選択されたエフェク

タの移動および回転と一致します。Gravity オプションが有効なため、ペー
スト元のポーズのオリジナルレベルで足が静止します(通常は床面の高さ)。

3 ヒップエフェクタを選択してから、Transport Controls のフレーム 0 に
移動します。

A.ヒップのエフェクタを選択 B.カレントフレームは 0

4 [Key Controls]ウィンドウで、[Type]メニューから[Auto]を選択します。

5 [Layer]メニューから[AnimLayer1]を選択し(A)、[Flat]をクリックして、フ
ラットなキーフレームを設定します(B)。

注: Ctrl+Kキーを押してもフラットなキーフレームを設定できます。
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Key Controls A. AnimLayer1を選択 B. Flatキー

6 フレーム 4 に移動して、次の操作を実行します。

■ Walk 02 ポーズをダブルクリックして、Mia にペーストします。

■ Ctrlキーを押しながら Kキーを押して、(Flat)キーフレームを設定し
ます。

フレーム 4: A.歩行サイクルの 2つ目のポーズ B. Miaに[Walk 02]ポーズをペー
ストした状態

7 フレーム 8 に移動して、次の操作を実行します。

■ Walk 03 ポーズをダブルクリックして、Mia にペーストします。

■ Ctrlキーを押しながら Kキーを押して、(Flat)キーフレームを設定し
ます。

歩行サイクルを作成する | 55



フレーム 8: A.歩行サイクルの 3つ目のポーズ B. Miaに[Walk 03]ポーズをペー
ストした状態

8 アニメーション全体を通してタイムスライダインジケータをドラッグし、

ここで作成した 1 歩を確認します。

3 つのキーフレーム間の補間によって 1 歩の動きが作成されます。

ポーズをミラーリングする

次の手順では、Pose ブラウザから 3 つのポーズをミラーリングして、後半の歩
行サイクルを作成します。オリジナルのポーズの後にミラーリングしたポーズに

キーフレームを設定して、短い歩行アニメーションを完成させます。

1 [Pose Controls]ウィンドウで、[M (Mirror)]ボタンをオンにします(A)。
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Pose Controls: A. [Mirror]をオン

2 フレーム 12 に移動して、次の操作を実行します。

■ 「Walk 01」ポーズをダブルクリックします(A)。

「Walk 01」ポーズがミラーリングされ、キャラクタにペーストされま
す(Bポーズをミラーペーストしたので、左脚が前に、右脚が後ろにな
り、反対側の歩行サイクルが続けられます。

■ Ctrlキーを押しながら Kキーを押して、(Flat)キーフレームを設定し
ます。

フレーム 12: A.後半の歩行サイクルの最初のポーズ B. Miaに「Walk 01」ポー
ズをペーストした状態

3 フレーム 16 に移動して、次の操作を実行します。

■ 「Walk 02」ポーズをダブルクリックします(A)。
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「Walk 02」ポーズがミラーリングされ、キャラクタにペーストされま
す(B)。

■ Ctrlキーを押しながら Kキーを押して、(Flat)キーフレームを設定し
ます。

フレーム 16: A.後半の歩行サイクルの 2つ目のポーズ B. Miaに「Walk 02」
ポーズをペーストした状態

4 フレーム 20 に移動して、次の操作を実行します。

■ 「Walk 03」ポーズをダブルクリックします(A)。

「Walk 03」ポーズがミラーリングされ、キャラクタにペーストされま
す(B)。

■ Ctrlキーを押しながら Kキーを押して、(Flat)キーフレームを設定し
ます。
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フレーム 20: A.後半の歩行サイクルの 3つ目のポーズ B. Miaに「Walk 03」
ポーズをペーストした状態

アニメーションは 6 つのキーフレームから構成されます。最初の 3 つ
のキーフレームは、キャラクタの左側にミラーリングされて最後の 3
つのキーフレームに使用され、完全な歩行動作を作成します。完全なア

ニメーションサイクルを完成するには、テイクの始点と終点を同じに

する必要があります。

5 [Transport Controls]の[Action]タイムラインで、フレーム 0 のキーフレー
ムを選択し、[C]キーを押しながらキーフレームをフレーム 24 にドラッグ
します。

フレーム 0 のキーフレームがフレーム 24 にコピーされます。

これでアニメーションの開始と終了の位置が同じになり、サイクルが完成

します。
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アニメーションを再生する

1 [Transport Controls]ウィンドウで、[Action]タイムラインをクリックし、
[Ctrl]+[Shift ]+[A]キーを押して、[Action]タイムラインのアニメーショ
ンの 24 フレームすべてにフレームします。

2 Loop (A)、Play の順にクリックします。

アニメーションにフレーム A. Loopオプション

アニメーションを再生すると、各ループは完全な歩行サイクルを表示しま

す。

このアニメーションでは、動きがぎこちなく、足がフロア(床面)の上を滑

る場合があります。FCurves ウィンドウでアニメーションのファンクショ
ンカーブを調整すると、動きを滑らかにすることができます。

まとめ

このチュートリアルでは、キャラクタにポーズを作成し、作成したポーズのキー

フレームをさまざまなポイントに設定し、歩行サイクルを作成しました。

注:

Story ウィンドウを使用した歩行サイクルを作成したい場合は、ループを作成し
てください。

次のチュートリアル、「キャラクタアニメーションをリターゲットする(60ペー
ジ)」では、あるキャラクタから別のキャラクタへ、アニメーションやキャラク

タエクステンションのターゲットを再設定します。

キャラクタアニメーションをリターゲットする

このチュートリアルでは、キャラクタライズ済みのキャラクタから別のキャラク

タにアニメーションをリターゲットする手順を説明します。ソースキャラクタ

にはキャラクタエクステンションが含まれ、ターゲットキャラクタには含まれ

ないため、キャラクタエクステンションのリターゲッティングも必要です。
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このチュートリアルで使用するアセット:

■ mia_fk_runstopturn.fbx
■ Gremlin.fbx

注: チュートリアル用のアセットは Asset Browser の Tutorialsフォルダ(または
システム上のMotionBuilderディレクトリ内のTutorialsフォルダ)にあります。

シーンを準備する

次の手順では、MotionBuilderシーンを準備し、このチュートリアルを開始す
るのに必要なファイルを開きます。

1 メニューバーから File > New を選択し、Layout > Editing を選択します
(Ctrl+Shift+3キー)。

MotionBuilderは、Editing レイアウトを使用して新しい 3D シーンを表
示します。このレイアウトには、このチュートリアルで作業するのに必要

なすべてのウィンドウが表示されます。

2 Asset Browser で Tutorialsフォルダをクリックします。

3 図のように mia_fk_runstopturnアセット(mia_fk_runstopturn.fbxファ
イル)を Viewer ウィンドウにドラッグして、表示されるコンテキストメ
ニューから FBX Open > All Takes を選択します。

Mia という名前のモデルが、「サーボアーム」キャラクタエクステンショ
ンと一緒に Viewer に表示されます。
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Mia_fk_runstopturnアセットをシーンにドラッグ

4 [File] > [Save As]を選択します。

Save File ダイアログボックスが表示されます。

5 ファイルを保存するディレクトリ(デフォルトのMotionBuilderTutorials
ディレクトリ以外のディレクトリ)に移動し、[Save]をクリックします。

Save Options ダイアログボックスが表示されます。

6 Save をクリックします。

デフォルトのMotionBuilderTutorialsデフォルト以外のデフォルトにファ
イルを保存することで、元の .fbxファイルが上書きされません。

7 Transport Controls で、Play をクリックして(A) Mia キャラクタのアニメー
ションを確認します。

Transport Controls A. Playボタン
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キャラクタアニメーションを保存する

次の手順では、Save Character Animation オプションを使用してキャラクタア
ニメーションを保存します。これにより、[Load Character Animation]オプショ
ンを使用して Mia のアニメーションを別のキャラクタにインポートできます。

1 [Character Controls]メニューから、[File] > [Save Character Animation]
を選択します(A)。

[Character Controls]メニュー A. [Save Character Animation]オプション

2 キャラクタアニメーションを保存する場所に移動し、ファイル名を入力し

て、Save をクリックします。
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Save Fileダイアログボックス

3 表示される Save Character Animation Options ダイアログボックスで、
Save Control Rig オプションと Save Character Extensions をアクティブ
にして、Save をクリックします。
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Save Character Animation Optionsダイアログボックス

アニメーションとキャラクタエクステンションが .fbxファイルとして保
存されます。

シーンを作成する

次は、シーンを作成します。

1 Ctrl+Nキーを押してシーンを作成します。

2 表示される Save changes ダイアログボックスで Don’t Save をクリック
します。

Save changesダイアログボックス
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3 Asset Browser から Gremlinアセットをシーンにドラッグし、FBX Open
> No animation を選択します。

Gremlinをシーンにドラッグします。

キャラクタアニメーションをロードする

次に、前の手順で保存したキャラクタアニメーションをロードします。

1 Character Controls ウィンドウで、File > Load Character Animation を
選択します(A)。
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Character Controls: A. Load Character Animationオプション

2 このチュートリアルで先ほど保存した .fbxファイルに移動してこれを選択
し、Open をクリックします。

Load Character Animation Options ダイアログボックスが表示されます。

Load Character Animation Optionsダイアログボックス

3 選択する設定:

■ Load Technique 領域(A)で、Plot to Control Rig オプションをオンに
します。

■ Control Rig 領域で、Replace Control Rig オプション(B)をオンにしま
す。

■ Control Rig 領域で、Reset Control Rig’s Rotation DOF オプション(C)
をオンにします。
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■ Control Rig 領域で、Remove Constraint Reference オプション(D)が
オンになっていることを確認します。

■ Character Extensions 領域で、Process Animation オプション(E)をオ
ンにします。

■ Character Extensions 領域で、Copy Missing Character Extensions オ
プション(F)をオンにします。

Load Character Animation Optionsダイアログボックスでの設定

4 Open をクリックします。

Mia のアニメーション、コントロールリグ、キャラクタエクステンショ
ンが Gremlin キャラクタにロードされます。
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Miaのアニメーションとコントロールリグが Gremlinキャラクタにロードされま
す。

Mia のサーボアームは、右肩の FK エフェクタにペアレント化されている
ため、サーボアームは同じように Gremlin キャラクタにアタッチされま
す。
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アニメーションを再生する

結果のアニメーションを再生します。

1 Transport Controls の Play をクリックしてアニメーションを再生します
(A)。

A. Miaのアニメーションを使用する Gremlin B. Gremlinのコントロールリグ

サーボアームとアニメーションの両方がどのように Gremlin キャラクタ
上に転送されるかに注意してください(A)。Gremlin のオリジナルのコント
ロールリグがシーン中央に残されます(B)。これは、Load Character
Animation Options ダイアログボックスの Replace Control Rig を選択し
たため発生する現象です。Gremlin のコントロールリグが Mia のコント
ロールリグと置き換えられています。

2 Scene Browser で Control Rigs を展開し、コントロールリグ(Gremlin の
オリジナルのコントロールリグ)を右クリックして、Delete を選択しシー
ンをクリーンアップします。
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Scene Browser: A.コンテキストメニューの Deleteボタン

まとめ

このチュートリアルでは、あるキャラクタライズされたキャラクタから、別の

キャラクタにアニメーションをリターゲットして、ソースキャラクタからター

ゲットキャラクタにキャラクタエクステンションを転送しました。

次のチュートリアル「キャラクタアニメーションを編集する (71ページ)」で
は、オリジナルのアニメーションからレイヤ上のアニメーションを編集した後、

すべてのレイヤをマージします。

キャラクタアニメーションを編集する

このチュートリアルでは、アニメーションのレイヤを作成して、アニメーション

を変更する方法を説明します。キャラクタのコントロールリグにプロット済み

のアニメーションを 2 つの個別のレイヤで修正して、オリジナルのアニメーショ
ンと修正したアニメーションを結合します。

このチュートリアルで使用するアセット:

■ mia_runstopturn.fbx

注: チュートリアル用のアセットは Asset Browser の Tutorialsフォルダ(または
システム上のMotionBuilderディレクトリ内のTutorialsフォルダ)にあります。
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シーンを準備する

以下の手順では、MotionBuilderシーンを準備し、このチュートリアルを開始
するのに必要なファイルを開きます。

1 メニューバーから File > New を選択し、Layout > Editing を選択します
(Ctrl+Shift+3キー)。

MotionBuilderは、Editing レイアウトを使用して新しい 3D シーンを表
示します。このレイアウトには、このチュートリアルで作業するのに必要

なすべてのウィンドウが表示されます。

2 Asset Browser で Tutorialsフォルダをクリックします。

3 mia_runstopturnアセット(mia_runstopturn.fbxファイル）を Viewer
ウィンドウにドラッグして(A)、表示されるコンテキストメニューから FBX
Open > run_stop_turn180 を選択します。

Mia という名前のモデルが Viewer に表示されます(B)。

A. mia_runstopturnアセット B.シーンにロードされた Miaキャラクタ

4 [File] > [Save As]を選択します。

Save File ダイアログボックスが表示されます。

5 ファイルを保存するディレクトリ(デフォルトのMotionBuilderTutorials
ディレクトリ以外のディレクトリ)に移動し、[Save]をクリックします。

Save Options ダイアログボックスが表示されます。

6 Save をクリックします。
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デフォルトのMotionBuilderTutorialsデフォルト以外のデフォルトにファ
イルを保存することで、元の .fbxファイルが上書きされません。

7 Viewer ウィンドウ内をクリックし、Ctrl+Rを 2 回押して、Producer Left
カメラに切り替えます。ズームアウトして、グリッド全体を表示します。

Producer Leftカメラビュー

キャラクタエクステンションのアニメーショ

ンを変更する

次の手順では、アニメーションを作成して、サーボアームキャラクタエクステ

ンションのアニメーションを変更します。

1 テイク全体を再生して（Ctrl+スペースバー）、すべてのモーションを確
認します。サーボアームに特に注目してください。

現在、サーボアームは、赤いワイヤフレームエフェクタの方向を指しな

がら、Mia の前で細かい上下動を繰り返しています。このエフェクタは
Mia の肩にペアレント化されているので、Mia が走る動作につれてサーボ
アームが跳ねるように動きます。

2 Ctrl+Homeキーを押してテイクの先頭に戻り、もう一度フレーム 40 まで
再生します。
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フレーム 40での Mia

3 Key Controls でレイヤメニューから AnimLayer1 を選択します(A)。

Key Controls A. AnimLayer1を選択

これにより、BaseAnimation レイヤにオリジナルのアニメーションを保持
しつつ、アニメーションレイヤにキーフレームを設定できます。

4 Mia:ServoControl エフェクタを選択し(A)、[Key Controls]の[Zero]をク
リックしてフレーム 40 にゼロキーフレームを設定します(B)。
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フレーム 40 A. Mia:ServoControlエフェクタ B. [Zero]キーフレームボタン

5 Mia:ServoControl エフェクタを選択した状態のまま、フレーム 120 に移
動し、ゼロキーフレームを設定します。

フレーム 120 A. Mia:ServoControlエフェクタを選択 B. [Zero]キーフレームボタ
ン

6 フレーム 64 に移動します。
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このフレームで、Mia がサーボアームを上げるようにアニメーションを変
更します。

フレーム 64

7 次の操作を行います。

■ Viewer ウィンドウ内をクリックし、Tキーを押して Translation モー
ドをアクティブにします。

■ Viewer ウィンドウの下部分で、Translation XYZ の値を 200、-30、10
に設定します(A)。

■ キーフレームを設定します(B)。
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フレーム 64 A. Translation XYZ値を設定 B. [Key]ボタン

8 フレーム 96 に移動して、次の操作を実行します。

■ Mia:ServoControl エフェクタの Translation XYZ の値を 45、16、14
に設定します(A)。

■ キーフレームを設定します(B)。

フレーム 96 A. Translation XYZの値を設定 B. [Key]ボタン
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9 フレーム 104 に移動して、次の操作を実行します。

■ Translation XYZ の値を 35、-25、68 に設定します(A)。

■ キーフレームを設定します(B)。

フレーム 104 A. Translation XYZ値を設定 B. [Key]ボタン

10 アニメーションを再生します。

Mia が速度を緩めて振り返る際に、サーボアームを上げる動作になりまし
た。

頭部のアニメーションを変更する

次の手順では、別のレイヤを使用して、アニメーションを改善します。Mia が
走っている間、停止したときと振り向く直前に頭部が動くようにします。

1 フレーム 24 に移動します。

このフレームでは、Mia の頭部は走っている方向にまっすぐ向いていま
す。このモーションを変更して、Mia が頭部を動かすようにします。
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フレーム 24での Mia

2 Key Controls ウィンドウで、Layer メニューから New Layer を選択し(A)、
頭部のアニメーションを修正するためのレイヤを作成します。

Key Controlsウィンドウ A. Layerメニュー > New Layerオプション

「AnimLayer2」という名前のレイヤが追加されます。

3 Character Controls ウィンドウで頭部のエフェクタを選択し(A)、Body Part
キーイングモードに切り替えます(B)。
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[Character Controls]ウィンドウ A.頭部のエフェクタが選択されている B. Body
Partキーイングモードが選択されている

ボディ全体ではなく頭部だけにキーフレームを設定すれば良いため、この

レイヤでアニメーションを作成するときは、Body Part キーイングモード
を使用できます。

4 Key Controls で Zero をクリックしてゼロキーフレームを設定します(A)。

Key Controls A. Zero keyframeボタン

5 フレーム 120 に移動して、別のゼロキーフレームを設定します。
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フレーム 120 A. [Zero]キーフレームボタン

6 フレーム 48 に移動して、次の操作を実行します。

■ 頭部のエフェクタを選択したままの状態で、Rotation モードをアクティ
ブにします(Viewer ウィンドウ内でクリックして R を押します)。

■ Viewer ウィンドウの下部分で、Rotation XYZ の値を 35、0、2 に設定
します(A)。

■ キーフレームを設定します(B)。
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フレーム 48 A. Rotation XYZの値を設定 B. [Key]ボタン

7 フレーム 72 に移動して、次の操作を実行します。

■ Rotation XYZ の値を 42、0、-5 に設定します(A)。

■ キーフレームを設定します(B)。

フレーム 72 A. Rotation XYZの値を設定 B. [Key]ボタン
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8 フレーム 84 に移動して、次の操作を実行します。

■ Rotation XYZ の値を 30、-5、0 に設定します(A)。

■ キーフレームを設定します(B)。

フレーム 84 A. Rotation XYZの値を設定 B. [Key]ボタン

9 頭部のエフェクタを選択解除し、アニメーションを再生します。

Mia が走ると、頭部が動きます。

作成されたテイクを再生する

テイクを再生してアニメーションを確認します。

サーボアームを上げ、頭部を動かすアニメーションが、走って方向転換をする

Mia のオリジナルのアニメーションにマージされています。

まとめ

このチュートリアルでは、2 つの異なるレイヤ上にキーフレームを設定してオリ
ジナルのアニメーションを変更した後、アニメーションを 1 つのテイクにマー
ジしました。次のチュートリアル、「ループを作成する (84ページ)」では、
[Story]ウィンドウを使用した歩行サイクルの作成方法について学びます。
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ループを作成する

このチュートリアルでは、キャラクタをアニメートし、Story ウィンドウで歩行
サイクルを作成する手順について説明します。

このチュートリアルで使用するアセット:

■ mia_servo.fbx
■ walkaround.fbx

注: チュートリアル用のアセットは Asset Browser の Tutorialsフォルダ(または
システム上のMotionBuilderディレクトリ内のTutorialsフォルダ)にあります。

シーンを準備する

次の手順では、MotionBuilderシーンを準備し、このチュートリアルを開始す
るのに必要なファイルを開きます。

1 メニューバーから File > New を選択し、Layout > Story を選択します
(Ctrl+Shift+5キー)。

MotionBuilderは、Story レイアウトを使用して新しい 3D シーンを表示
します。このレイアウトには、このチュートリアルで作業するのに必要な

すべてのウィンドウが表示されます。

2 Asset Browser で Tutorialsフォルダをクリックします。

3 mia_servoアセット (mia_servo.fbxファイル) を Viewer ウィンドウにド
ラックして、次に FBX Open > No Animation を選択します。

mia_servoアセットが、Viewer ウィンドウに T-スタンスで表示されます。
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T-スタンスの Miaとサーボアーム

4 [File] > [Save As]を選択します。

Save File ダイアログボックスが表示されます。

5 ファイルを保存するディレクトリ(デフォルトのMotionBuilderTutorials
ディレクトリ以外のディレクトリ)に移動し、[Save]をクリックします。

Save Options ダイアログボックスが表示されます。

6 Save をクリックします。

デフォルトのMotionBuilderTutorialsデフォルト以外のデフォルトにファ
イルを保存することで、元の .fbxファイルが上書きされません。

キャラクタトラックを作成する

次の手順では、Story ウィンドウでキャラクタトラックを作成し、トラックが作
用するキャラクタを定義し、アニメーションを追加します。

1 Story ウィンドウで、Action Track リストを右クリックし(A)、コンテキス
トメニューから Insert > Character Animation Track を選択します。
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Storyウィンドウ A. Action Trackリスト

Character Animation トラックが追加されます(A)。

Storyウィンドウ A. キャラクタトラック

2 トラックの Character メニューで Mia を選択します(A)。

[Story]ウィンドウ A. [Character]メニューで Miaを選択します。

3 Asset Browser からキャラクタトラックに walkaround.fbxをドラッグし
ます。
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キャラクタトラックにドラッグされている walkaround.fbxアセット。

4 フレーム 0 から始まるようにクリップをドラッグします。クリップはフ
レーム 78 で終わらせる必要があります。

キャラクタトラックのフレーム 0にドラッグされるクリップ。

注:

キャラクタトラックで Ctrl キーを押しながらドラッグするとズームし、
Shift キーを押しながらドラッグするとパンします。

5 アニメーションを再生します(Ctrl+スペースバー)。

フレーム 0 では、キャラクタの右足が前、左足が後ろになっています。フ
レーム 78 で、Mia は進む方向を変えます。この時点でアニメーションを
ループすると、歩行サイクル内にジャンプが生じてしまいます。

6 フレーム 32 に移動します。このフレームでは、Mia の右足は地面に着地
していて、左足はわずかに持ち上がっています。

Mia を正面から確認するためカメラビューを変更します。
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フレーム 32での Mia。

7 クリップが選択されたままの状態で、Razor ボタンをクリックします(A)。

Storyウィンドウ A. Razorボタン

クリップはフレーム 32 で 2 つに切断されます。

オリジナルのクリップが 2つに切断されました。

8 フレーム 60 に移動します。このフレームでは、Mia はフレーム 32 とほぼ
同じポーズになっています。
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フレーム 60での Mia。

9 2 番目のクリップを選択していない場合はそれを選択し、Razor ボタンを
クリックします。

2 番目のクリップがフレーム 60 で切断され、クリップは 3 つになります。

キャラクタトラック内の 3つのクリップ

10 必要なのは中央のクリップだけなので、Ctrl キーを押しながら 1 番目のク
リップをクリックして 1 番目のクリップと 3 番目のクリップを選択した
後、Delete キーを押します。

11 フレーム 0 で始まるように残ったクリップをドラッグします。

クリップはフレーム 0で始まり、フレーム 28で終わります。
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ポーズを作成する

1 フレーム 0 に移動します(Ctrl+Home)。

2 Character Controls ウィンドウで、Current Character から Mia が選択さ
れていることを確認し(A)、ヒップエフェクタを選択します(B)。

[Character Controls]ウィンドウ A.[Current Character]メニューからMiaを選択し
ます。B.ヒップエフェクタが選択されています。

3 Asset Settings ウィンドウで、Pose Controls タブをクリックします。

4 Pose Controls で Create (A)をクリックし、Poses フォルダを展開して作成
したポーズを確認します。ポーズの名前はデフォルトで「Mia Pose」と
なっています(B)。
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Pose Controlsウィンドウ A. Createボタン B. Mia Pose

5 フレーム 28 に移動して、次の操作を実行します。

■ [Story]ウィンドウで、キャラクタトラックの[Accept Keys]オプション
をアクティブにします(A)。Animate オプションがアクティブの場合、
ポーズのトラックへのペーストしかできません。

キャラクタトラック A.[Animate]オプションをアクティブにします。

■ Character Controls ウィンドウで Right Ankle エフェクタ(A)を右ク
リックし、表示されるメニューから RightAnkleEffector を選択します。
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Character Controlsウィンドウ A. Right Ankleエフェクタ

■ Pose Controls ウィンドウで Paste をクリックします(A)。

Pose Controlsウィンドウ A. Pasteボタン

1 フレームのクリップがフレーム 28 のキャラクタトラックに表示されま
す。

このクリップには、ペーストしたポーズのデータが含まれます。Mia の歩
行開始と歩行終了のポーズがまったく同じになります。
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キャラクタトラック A.フレーム 28の新しいクリップ

6 ジョグ([J]キーを押しながらドラッグ)するか、[Ctrl]+左矢印キーと[Ctrl]+
右矢印キーを使用して、アニメーション内をフレームごとにゆっくり移動

します。アニメーションの始めと終わりは同じポーズですが、始めと終わ

りのクリップの間に小さなジャンプがあります。次の手順でジャンプを削

除します。

クリップをマッチさせる

次の手順では、2 つのクリップをマッチさせてブレンドし、アニメーション内の
ジャンプを削除します。

1 トラックの下の空いている部分をクリックし、A を押してクリップをズー
ムインします。

2 2 番目のクリップを選択します。

キャラクタトラック A. 2番目のクリップが選択されています。

3 Right Ankle エフェクタが Character Controls ウィンドウで選択されたま
まの状態であることを確認します(A)。
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Character Controlsウィンドウ A. Right Ankleエフェクタ

4 Story ウィンドウで Match Options ボタンをクリックします(A)。

Storyウィンドウ A. Match Optionsボタン

5 表示される Match Options ダイアログボックスで OK をクリックします
(A)。
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Match Optionsダイアログボックス A. OKボタン

6 MotionBuilder のメニューバーから[Window] > [Asset Settings]を選択
し、[Story]ウィンドウで 2 番目のクリップをダブルクリックして設定を表
示します。

7 [Asset Settings]で、[In]フィールド(A)の値を 23 に設定します。

[Asset Settings]ウィンドウ A. [In]ポイントがフレーム 29に設定されています。

8 [Asset Settings]ウィンドウの[Out]フィールドに値 29 を入力します。

9 2 番目のクリップはフレーム 23 で始まるようになり、フレーム 29 で終わ
るように 1 番目のクリップと相互にブレンドします。このブレンドによ
り、クリップ間の移行が少しだけ滑らかになります。
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2番目のクリップはフレーム 23で始まり、フレーム 29で終わります。

10 アニメーションを再生します。Mia が歩き、歩行開始とと歩行終了のポー
ズは同じになります。

クリップを処理する

次の手順では、2 つのクリップを処理して単一のクリップとして保存します。そ
の後、この新しいクリップを使用して、別のキャラクタをアニメートします。

1 キャラクタトラックのキャラクタ名の近くで右クリックし、コンテキスト

メニューから Frame Start/End を選択します(A)。 クリップの長さに合わ
せてタイムレンジのサイズが変更されます。

キャラクタトラックのコンテキストメニュー A.選択された[Frame Start/End]オプ
ション。

2 キャラクタトラックをもう一度右クリックし、コンテキストメニューか

ら Process Track/Subtracks To New Clip オプションを選択します(A)。
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キャラクタトラックのコンテキストメニュー A. Process Tracks/Subtracks To
New Clipオプション

3 表示される[Process Track and Subtrack]ダイアログで、[Process Rate]を
24 FPS に変更します。[OK]をクリックします。

Process Track and Subtracksダイアログボックス

4 表示される Save Clip ダイアログボックスで、新しいクリップを
mia_walk_cycle.fbxという名前で保存します。
このチュートリアルを完了するには、保存したクリップが必要になります。

ループを作成する | 97



Save Clipダイアログボックス

Story ウィンドウに、新しい mia_walk_cycle.fbxクリップを含む 2 番目
のキャラクタトラックが表示されます(A)。

Storyウィンドウ A.新しい mia_walk_cycle.fbxクリップ

歩行サイクルをテストする

次の手順では、新しい歩行サイクルクリップをテストして、滑らかにループす

るかどうかを確認します。

1 (A)のように、Loop/Scale オプションが Loop に設定されていることを確
認します。

Storyウィンドウ A. Loop/Scaleオプションは Loopに設定されています。

2 キャラクタトラックをズームアウトし、mia_walk_cycle クリップの最後
をフレーム 116 まで伸ばします(A)。クリップは 4 回ループされます。

98 |第 1章 チュートリアル



キャラクタトラック A.フレーム 116まで伸ばしたクリップ

3 任意のキャラクタトラックを右クリックし、コンテキストメニューから

Frame Start/End を選択します。

4 1 番目のキャラクタトラックの Mute ボタンをクリックし(A)、トラックを
無効にします。

キャラクタトラック A.ミュートを選択

5 アニメーションを再生します。Mia は、140 フレームの間、滑らかに歩行
します。

まとめ

このチュートリアルでは、短いアニメーションクリップから、ループする歩行

サイクルを作成しました。次のチュートリアル「クリップを操作する (99ペー
ジ)」では、クリップを修正することでキャラクタアニメーションを編集する方

法を学習します。

クリップを操作する

このチュートリアルでは、クリップを操作してキャラクタアニメーションを変

更するために必要な手順について説明します。

このチュートリアルで使用するアセット:

■ mia_story.fbx
■ run_boom.fbx
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注: チュートリアル用のアセットは Asset Browser の Tutorialsフォルダ(または
システム上のMotionBuilderディレクトリ内の Tutorialsフォルダ)にあります。

シーンを準備する

次の手順では、MotionBuilderシーンを準備し、このチュートリアルを開始す
るのに必要なファイルを開きます。

1 メニューバーから File > New を選択し、Layout > Editing を選択します
(Ctrl+Shift+3キー)。

MotionBuilderは、Editing レイアウトを使用して新しいシーンを表示し
ます。このレイアウトには、このチュートリアルで作業するのに必要なす

べてのウィンドウが表示されます。

2 Asset Browser で Tutorialsフォルダをクリックします。

3 mia_storyアセット(mia_story.fbxファイル)を Viewer ウィンドウにド
ラッグして(A)、次に FBX Open > All Takes を選択します。

Mia という名前のモデルが[Viewer]ウィンドウに表示され(B)、Mia はト
ラックの[Character]メニューで選択されています。

注: グリッドの端の Mia を表示するには、[Viewer]ウィンドウをズームア
ウトする必要がある場合があります。
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A. mia_storyアセット B.シーンにロードされた Miaモデル

Story ウィンドウには、クリップを含む、Clip_Run_Loop という名前のト
ラックがあります。

4 [File] > [Save As]を選択します。

Save File ダイアログボックスが表示されます。

5 ファイルを保存するディレクトリ(デフォルトのMotionBuilderTutorials
ディレクトリ以外のディレクトリ)に移動し、[Save]をクリックします。

Save Options ダイアログボックスが表示されます。

6 Save をクリックします。

デフォルトのMotionBuilderTutorialsデフォルト以外のデフォルトにファ
イルを保存することで、元の .fbxファイルが上書きされません。

7 Story ウィンドウで、Story ボタン(A)がまだオンになっていない場合は、
それを選択してから Character トラック (B)をクリックし、A キーを押し
てクリップをフレームします。
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Storyウィンドウ A. Storyボタンを選択します。B. Characterトラックに 1つのク
リップが表示されています。

8 アニメーションを再生します(Ctrl+スペースバー)。すべてのアニメーショ
ンを確認するには、Viewer ウィンドウでズームアウトする必要があるこ
とがあります。

方向転換を作成する

以下の手順では、クリップを 2 つに切断し、次にゴーストクリップベクトルを
回転して Mia を走らせながら方向転換させます。

1 フレーム 11 に移動します。

このフレームで、以下の図のように、Mia の左足は地面に着地していま
す。

フレーム 11での Mia
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2 [Story]ウィンドウで、次の図のようにクリップ(B)を選択し、[Razor]ボタン
(A)をクリックします。

Storyウィンドウ A. Razorボタン B.選択したクリップ

クリップがフレーム 11 で 2 つのクリップに切断されます(A)。

キャラクタトラック A.クリップがカレントタイムで 2つのクリップに切断されま
す。

3 次の図のように、[Viewer]ウィンドウで X-Ray 表示モードに切り替え、
キャラクタトラック(A)の[Show/Hide Ghost]オプションがアクティブに
なっていることを確認します(A)。

キャラクタトラック A. [Show/Hide Ghost]オプション

4 フレーム 0 に移動します(Ctrl+Home)。

[Show/Hide Ghost]オプションがアクティブな場合、次の図のように、
[Viewer]ウィンドウにゴーストが表示されます。

クリップベクトルゴーストは、各クリップの最初と最後を表します。ク

リップごとに、選択して操作できる 1 つのクリップベクトルゴーストが
あります(B および C)。
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フレーム 0での Mia A.モデルゴースト B. 1番目のクリップのゴーストクリップ
ベクトル C. 2番目のクリップのゴーストクリップベクトル

5 Story ウィンドウで、2 番目のクリップが選択されていない場合はそれを選
択します(A)。

キャラクタトラック A. 2番目のクリップは選択されています。

Viewer ウィンドウで、選択したクリップのゴーストクリップベクトルも
選択されます。

6 Viewer ウィンドウでクリックし、キーボードショートカット Rキーを押

します。

以下の図のように、選択したクリップベクトルゴーストの一端に回転リ

ングが表示されます。

クリップベクトルの同じポイントにリングが表示されない場合は、クリッ

プベクトルのインポイントをダブルクリックして選択します。

104 |第 1章 チュートリアル



A.回転リング B. 2番目のゴーストクリップベクトルの Inポイント

7 以下の図のように(A)、Viewer ウィンドウの Rotation Y-axis フィールドに
値 -70 を入力します。

クリップベクトルが Mia の右の方を向きます(B)。

ヒント:

緑色の回転リングをドラッグして、クリップベクトルを手動で回転するこ

ともできます。
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A. Rotation Y-axisフィールド B.ゴーストクリップベクトルが回転しています。

8 [Viewer]ウィンドウ内で Jキーを押しながらドラッグし、フレーム 8 から
16 までをゆっくりした速度でジョグします。

Mia は走らせながら方向転換しますが、フレーム 11 で Mia の足がわずか
にジャンプしています。このジャンプを削除するには、クリップをブレン

ドする必要があります。

2つのクリップをブレンドする
以下の手順では、2 つのクリップをブレンドして、Mia が方向転換するときに発
生するアニメーションのジャンプを削除します。

1 Story ウィンドウで Loop オプションがアクティブになっていることを確
認します(A)。
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Storyウィンドウ A. Loopに設定された Loop/Scaleオプション

2 ユーザインタフェースの右下にある Asset Settings ウィンドウ内で、1 つ
目のクリップをダブルクリックして設定を表示します。

3 [Asset Settings]で、[Out]フィールド(A)の値を 15 に設定します。

[Asset Settings]ウィンドウ A. 15に設定された[Out]フィールド

以下の図のように(A)、1 番目のクリップが 2 番目のクリップとオーバー
ラップし、相互にブレンドされます。

キャラクタトラック A.相互にブレンドされたクリップ

4 アニメーションを再生します。

フレーム 11 でのジャンプが解消されました。
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クリップを追加する

以下の手順では、Story ウィンドウのキャラクタトラックにクリップを追加しま
す。

1 キャラクタトラックの下の空白を Ctrlキーを押しながらドラッグしてか

ら、Shift キーを押しながらドラッグしてズームアウトし、クリップの横
に空間を作ります。

2 Asset Browser の Tutorialsフォルダから、クリップの右側のキャラクタ
トラックの空白の部分に run_boom.fbxファイルをドラッグします。

キャラクタトラックに追加された run_boom.fbxクリップ

3 フレーム 36 から始まるようにクリップをドラッグします。

注:

以下の図のように、2 番目のクリップの最後に揃えて配置する必要があり
ます。

新しいクリップはフレーム 36から始まります。

4 新しいクリップを選択解除し、次にキャラクタトラックを右クリックし、

コンテキストメニューから Frame Start/End を選択します。

5 アニメーションを再生します(Ctrl+スペースバー)。

Mia は、走って方向転換しますが、アニメーションにジャンプしてしまう
場所があるため、爆風を受けたかのように前方に投げ出されます。

108 |第 1章 チュートリアル



クリップをマッチさせる

以下の手順では、最後のクリップを前のクリップに一致させて、アニメーション

内のジャンプを削除します。

1 フレーム 0 に移動します。

2 Viewer ウィンドウで、Schematic ビューに切り替え、Mia:RightFoot ノー
ドを選択します(A)。

このノードは Mia の右足を表しており、マッチさせるオブジェクトとして
使用されます。

Schematicビュー A.選択された Mia:RightFootノード

3 Producer Perspective カメラビューに切り替えます。

4 Story ウィンドウで、3 番目のクリップを選択し(A)、Match Options ボタ
ンをクリックします(B)。

Storyウィンドウ A.選択された 3番目のクリップ B. Match Optionsボタン
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5 以下の図のように、表示される Match Options ダイアログボックスで、
選択されていない場合は Match Object メニュー(A)で Mia:RightFoot を選
択し、To Previous Clip (B)と Between Previous Clip and Selected Clip
(C)を選択します。

Match OptionsダイアログボックスA. Match Object B. Match Clip C. Match Time

Translation オプションと Rotation オプションはすでに選択されていま
す。

6 OK をクリックします。

最後のクリップベクトルが、前のクリップとマッチするように移動しま

す。

7 Mia:RightFoot を選択解除します(Shift+D キー)。

8 アニメーションを再生します。

Mia は走って方向転換し、前方に投げ出されます。アニメーションのジャ
ンプが解消されました。

まとめ

このチュートリアルでは、連続するアニメーションのクリップを 2 つに切断し、
1 つのクリップベクトルゴーストを回転してキャラクタを走らせながら方向転
換させました。さらに異なるアニメーションの別のクリップを追加し、3 つのク
リップをすべて、1 つのシームレスなアニメーションシーケンスへとブレンド
しました。

次のチュートリアル(「MotionBuilder に 3ds Max ファイルをインポートする (
111ページ)」)では、3ds Max のスケルトンとキャラクタをMotionBuilderにエ
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クスポートし、コントロールリグを追加し、スケルトンとキャラクタをキャラ

クタライズします。さらに、MotionBuilderでキャラクタをアニメートしてか
ら、キャラクタとアニメーションを 3ds Max にエクスポートします。

MotionBuilderに 3ds Maxファイルをインポー
トする

このチュートリアルでは、3ds Max で作成したキャラクタをMotionBuilderに
インポートし、完全に編集可能なアニメートされたキャラクタとして 3ds Max
にエクスポートするために必要な手順について説明します。

注:

このチュートリアルは、執筆時点での最新バージョンの 3ds Max、
MotionBuilder、3ds Max FBX プラグインを使用することを前提としています。

このチュートリアルでは、3ds Max で作成された次の 3 種類のアニメート可能
なスケルトンを FBX フォーマットでMotionBuilderにインポートしてアニメー
トする方法を説明します。

■ 3ds Max の標準的なボーンシステムのスケルトン

■ Biped システムのスケルトン

■ スケルトンがバインドされているスキンキャラクタ

各自のニーズに合ったシングルステップの相互運用性手順を選んでください。あ

るいは、MotionBuilderと 3ds Max の相互運用についてより深く学びたい方は、
すべてのチュートリアルを行うことをお勧めします。

このチュートリアルのセットでは、以下の方法について説明します。

■ 2 種類の 3ds Max スケルトンと 3ds Max キャラクタをエクスポートし、
MotionBuilderにインポートする

■ MotionBuilderでコントロールリグを追加して、スケルトンとキャラクタを
キャラクタライズする

■ MotionBuilderでキャラクタをアニメートし、3ds Max にインポートするた
めの準備を行う

Autodesk MotionBuilderの Time Format メニューのデフォルト設定は 24 フ
レーム/秒(fps)ですが、3ds Max のデフォルト設定は 30 fps です。出力のフレー
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ムレートをいつでも変更して、正しいフレーム数を出力してアニメーションの

再生速度を正しく維持することができます。

たとえば、30 フレーム/秒の NTSC フレームレートを使用してビデオ用の 90 フ
レームのアニメーションを作成すると、3 秒のアニメーションが完成します。後
で PAL ビデオに(25 フレーム/秒で)出力する必要がある場合は、PAL フレーム
レートに切り替えることができます。90 フレームは 75 フレームに自動的に変
換され、フレーム数が異なる同じ合計時間のアニメーションが生成されます。

NTSC フレームレートに戻して元の 90 フレームのアニメーションを復元するこ
とも可能です。

フレームレートは、アニメーションのデータを失うことなくいつでも切り替え

ることができます。ただし、Autodesk MotionBuilderは、最後のセッションの
設定を保持します。別のチュートリアルに進む場合は、このチュートリアルの終

了時に設定を 24 fps に戻してください。

このチュートリアルの準備をする

このチュートリアルを完成させるには、現在のバージョンの 3ds Max および
MotionBuilderがシステムにインストールされている必要があります。

3ds Max の最新バージョンをお持ちでない場合は、オートデスクの Web サイト
(http://www.autodesk.co.jp/3dsmax)からソフトウェアの体験版をダウンロードで
きます。

このチュートリアルは、必要な部分だけを行ってもかまいません。

このチュートリアルで使用するアセット:

■ skeletons.max
■ bone_skeleton.FBX
■ bone_skeleton_characterized.FBX
■ biped.FBX
■ Pepe.max
■ Pepe.FBX
■ Pepe_rigged.FBX
■ IceSlip.fbx
■ Pepe_Mocap.FBX
■ Pepe_keyanim.FBX
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■ Pepe_plotted.FBX
■ Pepe_plotted.max

チュートリアル用のアセットは、MotionBuilderの Asset Browser の Tutorials
フォルダ(またはシステム上のMotionBuilderディレクトリ内の Tutorialsフォ
ルダ)にあります。

3ds Maxのスケルトン
このチュートリアルでは、3ds Max の標準的なボーンシステムのスケルトン
データを FBX フォーマットでエクスポートし、MotionBuilderにインポートし
てキャラクタライズする(アニメートできる状態にする)方法を説明します。

このチュートリアルでは、次のアセットが必要です。

■ skeletons.max
■ bone_skeleton.FBX
■ bone_skeleton_characterized.FBX

3ds Maxのスケルトンを MotionBuilderでエクス
ポートおよびキャラクタライズする

次の手順では、従来の 3ds Max のボーンシステムのスケルトンをエクスポート
し、3ds Max の[Send To]機能を使用してアニメーションのためにMotionBuilder
でそれを開きます。

注: このチュートリアルでは、[Send To]メニューオプションを使用して、
MotionBuilderおよび 3ds Max 2012 のシングルステップの相互運用ワークフ
ローを使用します。これらの製品の 2012 バージョンがない場合は、
MotionBuilderドキュメントのトピック「3ds Max のスケルトンを
MotionBuilder にエクスポートする」を参照してください。

スケルトンを FBXフォーマットでエクスポートするには:

1 3ds Max を起動します。

2 アプリケーションメニューから[開く] > [開く]を選択します。
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3 [Open File]ダイアログボックスで、MotionBuilderのルートディレクト
リの Tutorialsフォルダに移動し、シーンファイル skeletons.maxを開き
ます。

注:

[ファイルのロード:単位の不一致]ダイアログボックスが表示された場合
は、[ファイルの単位スケールを採用しますか?]を選択して[OK]をクリック
します。

skeletons.maxファイルを開くと、2 つのスケルトンが表示されます。左
のスケルトン(A)は 3ds Max の標準的なボーンシステムで作成されたもの
で、右のスケルトン(B)は 3ds Max の Biped 作成オプションを使用して作
成されたものです。

2つの 3ds Maxスケルトン A. 3ds Maxの標準的なボーンシステムのスケルトン B.
3ds Maxの Bipedスケルトン

これらのスケルトンは T スタンスをとっています。アニメータは通常、こ
のポーズでスキニングを行います。

注:

キャラクタをMotionBuilderにエクスポートする前に、必ずキャラクタを
この T 字型のスタンスに配置する必要があります。

3ds Max の Biped 作成オプションで作成したスケルトンをエクスポートす
る方法については、「3ds Max で Biped を作成して MotionBuilder にエ
クスポートする (122ページ)」を参照してください。

4 Skeleton A 全体を領域選択します。
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Tスタンスで方向を指定された Biped

ボーンの名前がMotionBuilderの規則に従って設定されており、T スタン
スになっているので、スケルトンは完全にキャラクタライズされます。

MotionBuilderの命名規則については、MotionBuilderの[Help] >
[Animating Characters] > [Character setup] > [Skeletons] > [Bone naming
conventions]セクションを参照してください。

5 [Application]メニューから[Send to] > [Send to MotionBuilder] > [Send
as New Scene]を選択します。MotionBuilderが起動します。

注: 2012 バージョンのMotionBuilderおよび 3ds Max がない場合は、
[Send to]オプションにアクセスできません。MotionBuilder のドキュメン
トを参照してください。

6 FBX Plug-in Import Options ダイアログボックスで、デフォルトの設定
のまま Open をクリックします。

これで、3ds Max のボーンシステムのスケルトンがMotionBuilderにロー
ドされます。
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3ds Maxのスケルトンが Viewerウィンドウに表示されます。

スケルトンをキャラクタライズするには:

1 MotionBuilderの Asset Browser で[Templates] > [Characters]を展
開し、キャラクタアセットをスケルトンのいずれかのボーン上へド

ラッグします。

アセットをボーンにドラッグすると、ボーンがハイライト表示されま

す。

2 表示されるメニューで Characterize をクリックします。
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キャラクタが T-スタンスをとり、Z 軸の正の方向(3ds Max では Y 軸
の負の方向に相当。.maxファイルを FBX フォーマットでエクスポー
トした際に変換しました)を向いている必要があることを警告するダ

イアログボックスが表示されます。

3 表示される[Character]ダイアログボックスで[Biped]をクリックし
て、キャラクタに適用するリグのタイプを指定します。

[Character stance]ダイアログボックス

これで、スケルトンがキャラクタライズされました。つまり、アニ

メートできるコントロールリグを設定できるようになりました。

4 MotionBuilderのメニューバーで、[Window] > [Characterization
Tool]を選択します。[Characterization Tool]では、スケルトンに一
致させたコントロールリグに問題がないことを確認できます。

5 [Character Controls]メニューから[Source] > [Control Rig]を選択し
ます([Edit] > [Control rig]を選択することもできますが、リグをソー
スとして設定すると、スケルトンはシーン内のアクティブなキャラク

タになります)。
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[Character Controls]の[Source]メニュー

後でキャラクタにキーフレームを設定するためには、Control Rig
Input 設定を使用する必要があります。

Create Control Rig ダイアログボックスが表示されます。

6 FK/IK をクリックします。

FK と IK は、キャラクタをアニメートするときに一般的に使用され
る手法です。

7 [Character Controls]ウィンドウで[Ctrl Rig In]オプションがオンに
なっていない場合は、オンにします。
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Character Controls A. [Ctrl Rig In]オプションをオンにする

この操作により、コントロールリグがアクティブになり、Character
Controls のキャラクタ表示が有効になります。キャラクタ表示は、
Biped スケルトンを人間の形をしたイメージで表したものです。キャ
ラクタ表示には、コントロールリグのアニメートに使用できるすべ

てのエフェクタが表示されます。

IK/FKコントロールリグが設定されたスケルトン

これでキャラクタのリギングが完了し、アニメートできる状態になり

また。

8 [Full Body]オプションをオンにします。これにより、コントロール
リグ全体を使用してボディを移動できます。
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Character Controls A. [Full Body]をオンにする。

9 キャラクタ表示で、右手首のエフェクタを選択します。

キャラクタ表示 A.右手首のエフェクタを選択する

10 Viewer ウィンドウ内でクリックし、Tキーを押します。

座標変換ハンドルが表示されます。

11 次の図のように、手を下へ動かします。
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手を動かすと腕が伸び、それに合わせて体の他の部分も自然に動きま

す。これで、キャラクタライズしたスケルトンを変形することができ

るようになりました。

注: この手順の結果を確認したい場合は、
bone_skeleton_characterized.FBXファイルを開いてください。

3ds Maxの Biped
このチュートリアルでは、3ds Max で Biped システムを使用してスケルトンを
作成し、そのスケルトンをMotionBuilderでアニメートするためにエクスポー
トする方法を説明します。

このチュートリアルの結果のアセット:

■ biped.FBX

注: チュートリアル用のアセットは、MotionBuilderの Asset Browser のTutorials
フォルダ(またはシステム上のMotionBuilderディレクトリ内の Tutorialsフォ
ルダ)にあります。
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3ds Maxで Bipedを作成してエクスポートする

ここでは、3ds Max で Biped を作成し、MotionBuilder用にエクスポートする
方法を説明します。

注: このチュートリアルでは、[Send To]メニューオプションを使用して、
MotionBuilderおよび 3ds Max 2012 のシングルステップの相互運用ワークフ
ローを使用します。これらの製品の 2012 バージョンがない場合は、
MotionBuilderドキュメントのトピック「3ds Max Biped を MotionBuilder に
エクスポートする」を参照してください。

3ds Maxで Bipedを作成し、MotionBuilder用にエクスポートするには:

1 3ds Max を起動します。

2 アプリケーションメニューから[リセット]を選択してシーンと設定をクリ
アします。

3 [作成]パネルで[システム]を選択します。

[作成]パネルで[システム]が選択された状態

4 [オブジェクトタイプ]ロールアウトで[Biped]をクリックします。

5 パースペクティブビューポートをクリックしてドラッグし、Biped オブ
ジェクトを作成します。

注:

ここでは Biped のサイズは重要ではありません。
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3ds Maxの Bipedオブジェクト

6 [Motion]コマンドパネルを開きます。

7 Bip001 を選択したまま、[Motion]パネル > [Biped]ロールアウトに移動
し、[Figure Mode]をクリックします。

[フィギュアモード]が選択された状態

8 [Structure]ロールアウト > [Body Type]領域 > [Neck Links]スピナーボッ
クスに 4と入力します。
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首に 10個のリンクを持つ Biped

3ds Max Biped オブジェクトの首に 4 個のリンクが設定されました(次の
図を参照)。

首に 4個のリンクを持つ 3ds Max Bipedオブジェクト

9 [脊椎のリンク]スピナーボックスに 10、[指]スピナーボックスに 5、[指の
リンク]スピナーボックスに 3、[足の指]スピナーボックスに 5、[足の指の
リンク]スピナーボックスに 3と入力します。

10 [モーション]パネル > [Biped]ロールアウトに移動し、[フィギュアモード]
をもう一度クリックして入力モードを終了します。

11 [Application]メニューから[Send to] > [Send to MotionBuilder] > [Send
as New Scene]を選択します。MotionBuilderが起動します。
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注:  2012 バージョンのMotionBuilderおよび 3ds Max がない場合は、
[Send to]オプションにアクセスできません。MotionBuilder のドキュメン
トを参照してください。

12 MotionBuilderで、[Viewer]ウィンドウ内にカーソルを置き、Aキーを押

して Biped スケルトン全体をフレームします。

3ds Maxの Bipedスケルトンを MotionBuilderにインポートした状態

Biped が FBX ファイルとして保存されたので、次のチュートリアル(「3ds Max
の Biped を MotionBuilder にインポートしてキャラクタライズする (126ペー
ジ)」)ではそれを使用して、MotionBuilderでインポートとキャラクタライズを
行います。

注: この手順の結果を確認したい場合は、biped.FBXファイルを開いてくださ
い。
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3ds Maxの Bipedを MotionBuilderでキャラクタ
ライズする

次の手順では、前の手順(「3ds Max で Biped を作成してエクスポートする (122
ページ)」)で保存した 3ds Max の Biped (My_biped.FBX)を、MotionBuilderで
キャラクタライズします。Biped をキャラクタライズすると、Biped のボーンに
コントロールリグが割り当てられます。ここでのキャラクタライズは、

MotionBuilderが Biped スケルトンをリギングするプロセスで使用する名称で
もあります。

注: 前の手順を省略した場合は、システム上のMotionBuilderディレクトリ内
の Tutorialsフォルダにある biped.FBXファイルを使用してください。

3ds Max Bipedをキャラクタライズするには:

1 スケルトンの肩(Upperarm)ノードを選択し、[R]キーを押して Rotation
モードに入ります。スケルトンの腕を、グリッドと並行になるまで回転さ

せます。もう一方の肩も同様にします。

スケルトンの肩を回転させて T-スタンスにする。

スケルトンが T-スタンスになりました。

2 Asset Browser で Templates > Characters を展開し、3ds Max Biped
Template をスケルトンの上にドラッグします。
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Bipedスケルトンに 3ds Max Biped Templateアセットを適用します。

3ds Max Biped Template は、3ds Max で作成された Biped 専用のテンプ
レートです。3ds Max Biped の命名規則はそのままではMotionBuilderで
認識できないため、このテンプレートを使用する必要があります。

3 表示されるメニューで Characterize をクリックします。

これで、Biped スケルトンがキャラクタライズされました。

4 MotionBuilderのメニューバーで、[Window] > [Characterization Tool]
を選択します。[Characterization Tool]では、スケルトンに一致させたコ
ントロールリグに問題がないことを確認できます。

Characterization Toolに、キャラクタライズが正しいことが表示される。
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Characterization Tool は、キャラクタライズが正常な場合は緑色、潜在的
な問題が検出された場合は黄色、問題のあるスケルトンマッチングのエレ

メントが存在する場合は赤色を示します。

次の手順ではコントロールリグを追加して、この Biped スケルトンをアニ
メートできるようにします。

5 [Character Controls]ウィンドウで、[Source] > [Control Rig]を選択しま
す。

[Character Controls]の[Source]メニュー A. [Control Rig]

6 [Create Control Rig]ダイアログボックスで[FK/IK]をクリックします。

FK と IK は、キャラクタをアニメートするときに一般的に使用される手法
です。

7 Character Controls ウィンドウの Active 領域で、Ctrl Rig In をオンにし
ます(A)。

Ctrl Rig In をオンにすると、Character Controls ウィンドウのキャラクタ
表示が有効になります。また、Viewer ウィンドウには Biped のコントロー
ルリグエフェクタが表示されます(B)。
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A. Ctrl Rig Inをオンにします。B. Biped上にコントロールリグエフェクタが表示
されます。

キャラクタ表示は、Biped スケルトンを人間の形をしたイメージで表した
ものです。キャラクタ表示には、コントロールリグのアニメートに使用で

きるすべてのエフェクタが表示されます。これで Biped のリギングが完了
し、アニメートできる状態になりました。

8 キャラクタ表示で、右手首のエフェクタを選択します。

Character Controls A.右手首のエフェクタを選択する

9 [Full Body]オプションをオンにします。これにより、コントロールリグ全
体を使用してボディを移動できます。
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Character Controls A.[Full Body]オプション

10 Viewer ウィンドウ内でクリックし、Tキーを押します。

座標変換ハンドルが表示されます。

11 次の図のように、手を下へ動かします。

手を動かすと腕が伸び、それに合わせて体の他の部分も自然に動きます。

これで、キャラクタライズした 3ds Max の Biped をMotionBuilderで変
形およびアニメートすることができるようになりました。「3ds Max の
キャラクタを MotionBuilder でアニメートする (142ページ)」を参照して
ください。
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3ds Maxのキャラクタ
このチュートリアルでは、3ds Max で作成された、スケルトンがバインドされ
たスキンキャラクタを FBX ファイルフォーマットでエクスポートし、
MotionBuilderにインポートしてキャラクタライズする(アニメートできる状態
にする)方法を説明します。

エクスポートするキャラクタは、スケルトンにスキンとテクスチャを適用したも

のです。したがって、手順は 3ds Max のスケルトンや Biped スケルトンをエク
スポートするチュートリアルと似ています。

このチュートリアルで使用するアセット:

■ Pepe.max

このチュートリアルの結果のアセット:

■ Pepe.FBX
■ Pepe_rigged.FBX

注: チュートリアル用のアセットは、MotionBuilderの Asset Browser のTutorials
フォルダ(またはシステム上のMotionBuilderディレクトリ内の Tutorialsフォ
ルダ)にあります。

3ds Maxのキャラクタをエクスポートする

次の手順では、3ds Max キャラクタをMotionBuilderにエクスポートする方法
について説明します。

注: このチュートリアルでは、[Send To]メニューオプションを使用して、
MotionBuilderおよび 3ds Max 2012 のシングルステップの相互運用ワークフ
ローを使用します。これらの製品の 2012 バージョンがない場合は、
MotionBuilderドキュメントのトピック「3ds Max のキャラクタをエクスポー
トする (131ページ)」を参照してください。

3ds Maxのキャラクタ Pepeをエクスポートするには:

1 3ds Max を起動します。

MotionBuilderに 3ds Maxファイルをインポートする | 131



2 アプリケーションメニューから[リセット]を選択してシーンと設定をクリ
アします。

3 [開く]を選択し、MotionBuilderルートディレクトリ内の Tutorialsフォ
ルダにある Pepe.maxシーンファイルを開きます。
Pepe.maxシーンファイルが開き、メッシュで覆われた Biped スケルトン
が表示されます。

メッシュで覆われた 3ds Max Bipedスケルトン

4 [Application]メニューから[Send to] > [Send to MotionBuilder] > [Send
as New Scene]を選択します。
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注: 2012 バージョンのMotionBuilderおよび 3ds Max がない場合は、
[Send to]オプションにアクセスできません。MotionBuilder のドキュメン
トを参照してください。

5 MotionBuilderが起動し、キャラクタ Pepe が[Viewer]ウィンドウに表示
されます。

6 Viewer ウィンドウ内にカーソルを置き、Aキーを押してキャラクタ全体

をフレームします。

3ds Maxのキャラクタ Pepeを MotionBuilderにインポートした状態

キャラクタをキャラクタライズするには:

1 Viewer ウィンドウで、Ctrl+Aキーを何度か押して X-Ray モードに切り
替えます。

X-Ray モードでは、キャラクタのスキンの下にあるスケルトンも表示され
ます。

2 Asset Browser で Templates > Characters を展開し、3ds Max Biped
Template アセットをキャラクタ Pepe のスケルトンの上にドラッグしま
す。
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キャラクタPepeのスケルトンに 3ds Max Biped Templateアセットを適用します。

3ds Max Biped Template は、3ds Max で作成された Biped 専用のテンプ
レートです。3ds Max Biped の命名規則はそのままではMotionBuilder側
のキャラクタで認識できないため、このテンプレートを使用する必要があ

ります。

3 表示されるメニューで Characterize をクリックします。

4 MotionBuilderのメニューバーで、[Window] > [Characterization Tool]
を選択します。[Characterization Tool]では、スケルトンに一致させたコ
ントロールリグに問題がないことを確認できます。

Characterization Tool は、キャラクタライズが正常な場合は緑色、潜在的
な問題が検出された場合は黄色、問題のあるスケルトンマッチングのエレ

メントが存在する場合は赤色を示します。

5 [Character Controls]ウィンドウで、[Control Rig] > [Source Control Rig]
を選択します。
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Character Controls Editメニュー

Biped にキーフレームアニメーションを適用するためには、Control Rig
Input 設定を使用する必要があります。

6 Create Control Rig ダイアログボックスで FK/IK をクリックします。

FK と IK は、キャラクタをアニメートするときに一般的に使用される手法
です。

7 [Character Controls]ウィンドウで、[Source] > [Control Rig]を選択しま
す。

Biped 上にエフェクタが表示されます(次の図を参照)。

A. Ctrl Rig Inをオンに設定 B.キャラクタ上にエフェクタが表示される
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8 キャラクタ表示は人間の形であり、キャラクタのスケルトンを表すように

意図されています。キャラクタ表示では、Biped コントロールリグのアニ
メートに必要なすべてのエフェクタが表示されます。これで Biped のリギ
ングが完了し、アニメートできる状態になりました。

9 [Character Controls]で Full Body モードを選択します。Full Body モード
では、個々のボディパーツではなくリグ全体をコントロールできます。

10 キャラクタ表示で、右手首のエフェクタを選択します。

右手首のエフェクタが選択された状態

11 Viewer ウィンドウ内でクリックし、Tキーを押します。

座標変換ハンドルが表示されます。

12 次の図のように、手を下へ動かします。
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手を動かすと腕が伸び、それに合わせて体の他の部分も自然に動きます。

これで、モーションキャプチャやキーフレームアニメーションを使用し

てキャラクタをアニメートできる状態になりました。

13 既定のMotionBuilderTutorialsディレクトリ以外のディレクトリに移動
し、ファイルを My_Pepe_riggedとして保存します。

3ds MaxのキャラクタをMotionBuilderにインポー
トしてキャラクタライズする

次の手順では、前の手順(「3ds Max のキャラクタをエクスポートする(131ペー
ジ)」)で保存した My_Pepe.FBXファイルをMotionBuilderにインポートしま
す。キャラクタ Pepe は 3ds Max Biped で、メッシュとマテリアルだけででき
ているので、一部の手順は「3ds Max の Biped を MotionBuilder にインポート
してキャラクタライズする(126ページ)」と似ています。キャラクタをインポー
トしたら、キャラクタライズします。

注: 前の手順を省略した場合は、システム上のMotionBuilderディレクトリ内
の Tutorialsフォルダにある Pepe.FBXファイルを使用してください。

3ds Maxのキャラクタを MotionBuilderにインポートするには:

1 MotionBuilderを起動します。

2 MotionBuilderのメインメニューから[File] > [Open]を選択します。

3 [Open File]ダイアログボックスで、「3ds Max のキャラクタをエクスポー
トする (131ページ)」でエクスポートした My_Pepe.FBXファイルを選択
し、[Open]をクリックしてから、[Open Options]ダイアログボックスで
[Open]をクリックします。

注: または、MotionBuilderのルートディレクトリの Tutorialsフォルダ
にある、Pepe.FBXファイルをインポートしてもかまいません。

注: 元の .fbxファイルを上書きしないように、必ず既定の
MotionBuilderTutorialsディレクトリ以外のディレクトリに移動してから、
ファイルを保存してください。

キャラクタ Pepe がMotionBuilderの[Viewer]ウィンドウに表示されます。
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4 Viewer ウィンドウ内にカーソルを置き、Aキーを押してキャラクタ全体

をフレームします。

3ds Maxのキャラクタ Pepeを MotionBuilderにインポートした状態

キャラクタをキャラクタライズするには:

1 Viewer ウィンドウで、Ctrl+Aキーを何度か押して X-Ray モードに切り
替えます。

X-Ray モードでは、キャラクタのスキンの下にあるスケルトンも表示され
ます。

2 Asset Browser で Templates > Characters を展開し、3ds Max Biped
Template アセットをキャラクタ Pepe のスケルトンの上にドラッグしま
す。
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キャラクタPepeのスケルトンに 3ds Max Biped Templateアセットを適用します。

3ds Max Biped Template は、3ds Max で作成された Biped 専用のテンプ
レートです。3ds Max Biped の命名規則はそのままではMotionBuilder側
のキャラクタで認識できないため、このテンプレートを使用する必要があ

ります。

3 表示されるメニューで Characterize をクリックします。

4 [Character Controls]ウィンドウで、[Source] > [Control Rig]を選択しま
す。

Character Controls A. Control Rig
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Biped にキーフレームアニメーションを適用するためには、Control Rig
Input 設定を使用する必要があります。

5 [Create Control Rig]ダイアログボックスで[FK/IK]をクリックします。

[FK/IK]をクリックします。

FK と IK は、キャラクタをアニメートするときに一般的に使用される手法
です。

6 [Character Controls]ウィンドウの[Active]領域で、[Control Rig]がオンで
あることを確認します。

Biped 上にエフェクタが表示されます(次の図を参照)。

A. [Control Rig]をオンに設定 B.キャラクタ上にエフェクタが表示される

この操作により、コントロールリグがアクティブになり、Character
Controls のキャラクタ表示が有効になります。キャラクタ表示は、キャラ
クタのスケルトンを人間の形をしたイメージで表したものです。キャラク

タ表示には、コントロールリグのアニメートに使用できるすべてのエフェ

クタが表示されます。これで Biped のリギングが完了し、アニメートでき
る状態になりました。

7 [Character Controls]で Full Body モードが選択されていることを確認しま
す。
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Character Controls A. Full Bodyモード

Full Body モードを有効にすると、ボディパーツだけでなくリグ全体をコ
ントロールできます。

8 キャラクタ表示で、右手首のエフェクタを選択します。

右手首のエフェクタが選択された状態

9 Viewer ウィンドウ内でクリックし、Tキーを押します。

座標変換ハンドルが表示されます。

10 次の図のように、手を下へ動かします。
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手を動かすと腕が伸び、それに合わせて体の他の部分も自然に動きます。

これで、モーションキャプチャやキーフレームアニメーションを使用し

てキャラクタをアニメートできる状態になりました。

11 既定のMotionBuilderTutorialsディレクトリ以外のディレクトリに移動
し、ファイルを My_Pepe_riggedとして保存します。

注: このファイルを使用して、次のチュートリアルを行います(あるいは、システ
ム上のMotionBuilderルートディレクトリ内の Tutorialsフォルダにある
Pepe_rigged.FBXファイルを使用してもかまいません)。

「3ds Max のキャラクタを MotionBuilder でアニメートする(142ページ)」を参
照してください。

3ds MaxのキャラクタをMotionBuilderでア
ニメートする

MotionBuilderでキャラクタをアニメートするには 2 通りの方法があります。1
つは手動でキーフレームを設定する方法、もう 1 つはモーションキャプチャ
データを使用する方法です。このチュートリアルでは、3ds Max のキャラクタ
(131ページ)のセクションでインポートした 3ds Max キャラクタPepeをアニメー
トする方法を説明します。

前のセクション(「3ds Max のキャラクタを MotionBuilder にインポートして
キャラクタライズする (137ページ)」)の手順を省略した場合は、システム上の
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MotionBuilderルートディレクトリ内の Tutorialsフォルダにある
Pepe_rigged.FBXファイルを使用してください。

これらのアニメーションチュートリアルの最初の「モーションキャプチャデー

タを使用してキャラクタをアニメートする (144ページ)」では、MotionBuilder
に付属するモーションキャプチャファイルの 1 つを使用して Pepeをアニメー
トします。2 つ目のチュートリアルの「キーフレームを使用してキャラクタア
ニメーションを修正し、3ds Max にエクスポートする(149ページ)」では、キー
フレームを使用してアニメーションを修正し、編集したアニメーションを 3ds
Max に戻します。

注: MotionBuilderでキャラクタをアニメートする方法をご存知の方は、このセ
クションは省略してかまいません。

このチュートリアルで使用するアセット:

■ Pepe_rigged.FBX
■ Iceslip.fbx

このチュートリアルの結果のアセット:

■ Pepe_Mocap.FBX
■ Pepe_keyanim.FBX

注: チュートリアル用のアセットは、MotionBuilderの Asset Browser のTutorials
フォルダ(またはシステム上のMotionBuilderディレクトリ内の Tutorialsフォ
ルダ)にあります。

まだMotionBuilderを使い慣れていない方は、まずMotionBuilderのキーボー
ドショートカットを使用したMotionBuilderの操作を練習しましょう。

■ Ctrl+Shiftキーを押しながらドラッグしてシーンをオービットする

■ Ctrlキーを押しながらドラッグしてシーンをズームイン/アウトする

■ Shiftキーを押しながらドラッグしてシーンをパンする
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モーションキャプチャデータを使用してキャラク

タをアニメートする

次の手順では、MotionBuilderキーフレームアニメーションのテクニックを用
いてモーションキャプチャアニメーションを微調整する方法を学びます。

前のセクション(「3ds Max のキャラクタを MotionBuilder にインポートして
キャラクタライズする (137ページ)」)の手順を省略した場合は、システムの
TutorialsフォルダにあるMotionBuilderルートディレクトリの
Pepe_rigged.FBXファイル、または、MotionBuilderの[Asset Browser]の
Tutorialsフォルダにある Pepe_riggedアセットを使用できます。

モーションキャプチャデータを使用してキャラクタ Pepeをアニメートするに
は:

1 MotionBuilderを起動します。

2 [Asset Browser]の Tutorialsフォルダから、前のセクション(「3ds Max の
キャラクタを MotionBuilder にインポートしてキャラクタライズする(137
ページ)」)の手順で保存した My_Pepe_riggedアセット
(My_Pepe_rigged.FBXファイル)を[Viewer]ウィンドウにドラッグします。

注: 前のセクション(「3ds Max のキャラクタを MotionBuilder にインポー
トしてキャラクタライズする (137ページ)」)の手順を省略した場合は、
Pepe_riggedアセット(Pepe_rigged.fbxファイル)を[Viewer]ウィンドウ
にドラッグします。

注: 元の .fbxファイルを上書きしないように、必ず既定の
MotionBuilderTutorialsディレクトリ以外のディレクトリに移動してから、
ファイルを保存してください。

3 FBX Open > No Animation を選択します。

キャラクタ Pepe が Viewer ウィンドウに表示されます。
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ファイルのロード A. Asset Browserの Pepe_riggedアセット B.シーンに Pepe
がロードされる

4 Viewer ウィンドウの空の領域をクリックし、Aキーを押して全体をフレー
ムし、キャラクタ Pepeにズームインします。

5 Ctrl+Aキーを何度か押して X-Ray モードに切り替えると、Pepe のスケ
ルトンとコントロールリグが表示されます。

X-Rayモードで表示した Pepeのコントロールリグ

6 Ctrl+Shiftキーを押しながらドラッグしてシーンをオービットし、キャ
ラクタ Pepeの右側面を表示します。次の図を参考にしてください。
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Pepeをオービットします。

7 Asset Browser > Tutorialsフォルダで IceSlipアセット(IceSlip.fbxファイ
ル)を選択し、Viewer ウィンドウの空の領域にドラッグします。

8 FBX Merge > IceSlip を選択します。

Pepeのシーンにモーションキャプチャデータ(大きな黄色いスケルトン)
がマージされます。

9 黄色いスケルトンが表示されるまで、シーンをズームアウト(Ctrlキーを

押しながら左下へドラッグ)します。

Pepeと、モーションキャプチャデータを持つスケルトン

10 [Transport Controls]の右側にあるドロップダウンメニュー(B)から[30 fps]
を選択します。

11 [Transport Controls]の[Play]ボタン(A)をクリックして、黄色いスケルトン
の IceSlipのアニメーションを再生します。
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トランスポートコントロール A. [Play]ボタン B. 30 fpsが選択されている

12 [Character Controls]で、キャラクタリストに PEPE と表示されているこ
とを確認します。[Character Controls]メニューから、[Source] > [Skeleton2]
を選択します(「Skeleton2」は、モーションキャプチャアニメーションを
持つ黄色いスケルトンの名前です)。

Pepeはスケルトンの姿勢になります(次の図を参照)。
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13 Transport Controls のタイムラインインジケータをドラッグしてアニメー
ションをスクラブします。あるいは、Jキーを押しながら Viewer ウィン
ドウ内を左右にドラッグする方法もあります。

これで、スケルトンのアニメーションがキャラクタ Pepeを駆動するよう
になりました。

14 Pepe だけが表示されるようになるまでCtrl+Aキーを何度か押し、フレー
ム 92 に移動して Pepeにズームインします。

15 Ctrl+Shiftキーを押しながらドラッグして Pepeをオービットします。
注意して見ると、Pepe の片方の手が顔を貫通してしまっていることが分か
ります。

モーションキャプチャが原因で、手の動きに問題が生じている状態

16 問題の動きを確認できるまで、アニメーションを何度かスクラブしてみて

ください。

Pepe のボーンの動きをコントロールするアニメーションが、生理学的に
まったく異なるスケルトンをベースにしているためです。たとえば、Pepe
の頭や手足は黄色いスケルトンと比べるとかなり大きく、肩ははるかに小

さいことが分かります。

17 ファイルを My_Pepe_Mocap.fbxという名前で保存します。
次のチュートリアルでは、このファイルにキーフレームを追加して、Pepe
の手の動きを修正します。

注: また、次のチュートリアルでは、修正したキャラクタを 3ds Max へ再
度エクスポートする方法も紹介します。
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キーフレームを使用してキャラクタアニメーション

を修正し、3ds Maxにエクスポートする

MotionBuilderでは、キャラクタに手動でキーフレームを設定することでキャ
ラクタをアニメートできます。この方法は、オリジナルのアニメーションを作成

する場合や、モーションキャプチャアニメーションに修正を加えたい場合に役

立ちます。

次の手順では、キーフレームアニメーションを使用してモーションキャプチャ

アニメーションを微調整し、編集したアニメーションとキャラクタをエクスポー

トして 3ds Max に戻します。

MotionBuilderでキャラクタにキーフレームを設定する方法をご存知の方は、
手順 21 に進み、3ds Max にキャラクタをエクスポートできます。

注: このチュートリアルでは、[Send To]メニューオプションを使用して、
MotionBuilderおよび 3ds Max 2012 のシングルステップの相互運用ワークフ
ローを使用します。これらの製品の 2012 バージョンがない場合は、
MotionBuilderドキュメントを参照してください。

キーフレームを使用してモーションキャプチャアニメーションを微調整するに

は:

1 MotionBuilderで、前の手順(「モーションキャプチャデータを使用して
キャラクタをアニメートする(144ページ)」)の結果のMy_Pepe_Mocap.FBX
ファイルを開き、モーションキャプチャデータを Pepeに適用します。

注: 前の手順を省略した場合は、Pepe_Mocap.fbxファイルを開いてくだ
さい。

注: 元の .fbxファイルを上書きしないように、必ず既定の
MotionBuilderTutorialsディレクトリ以外のディレクトリに移動してから、
ファイルを保存してください。

Pepe だけが表示されるようになるまで、[Ctrl]+[A]キーを押します。

2 Character Controls のキャラクタ表示で、右手首のエフェクタをクリック
します。
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右手首のエフェクタが選択された状態

3 Viewer ウィンドウ内でクリックし、Tキーを押します。

座標変換ハンドルは表示されません。

4 Pepe の手を動かしてみてください。

手は動かないはずです。それは、Pepe のアニメーションは、コントロール
リグではなくスケルトンによってコントロールされているためです。Pepe
のモーションキャプチャアニメーションにキーフレームを設定するには、

まずスケルトンのアニメーションを Pepe のコントロールリグ上にプロッ
ト(ベイク)する必要があります。

5 [Character Controls]メニューで、[Bake (plot)] > [Bake (plot) To Rig]を選
択します。

Bake to Rig コマンドでは、アニメーショントラックのベースレイヤ(また
は BaseAnimation layer)で各フレームごとに 1 つずつキーが作成される
ため、編集がしづらくなります。(Pepeの手首のエフェクタを選択してい
る場合は、作成されたキーフレームが Transport Controls に表示されま
す)。
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Character Controlsウィンドウの Editメニューで Plot Characterを選択します。

これで、キャラクタ Pepeをコントロールリグを使って編集できるように
なりました。

6 Key Controls で Layer メニューをクリックし、AnimLayer1 を選択しま
す。

キーフレームを追加するために AnimLayer1を選択します。

アニメーションレイヤを選択すると、オリジナルのアニメーションを

BaseAnimation レイヤに保持したまま、アニメーションを編集できます。
AnimaLayer1 を選択すると、BaseAnimation レイヤに設定されているキー
フレームが非表示になり、AnimLayer1 レイヤに設定されているキーフレー
ムが表示されます(現時点では何も設定されていません)。

7 フレーム 80 (問題のある右手の動きが始まるタイミング)に移動します。
Character Controls ウィンドウのキャラクタ表示で右手首のエフェクタを
クリックした後、Key Controls で Key をクリックします。
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注: Kキーを押してキーフレームを設定することもできます。

8 フレーム 105 (問題の手の動きが終わるタイミング)に移動して、もう 1 つ
キーを設定します。

以降の手順を実行しても、最初のキーより前および 2 番目のキーの後は、
キャラクタの動きは何も変化しません。フレーム 80 からフレーム 105 ま
での動きだけを修正します。

9 フレーム 94 (設定した 2 つのキーフレームの中間)に移動します。

10 Viewer ウィンドウで Tキーを押し、Pepe の手を X 軸と Z 軸に沿って移
動して顔から遠ざけてから(次の図を参照)、キーを設定します。

Pepeの手を顔から遠ざけます。

11 Jキーを押しながら前後にドラッグして、キーを作成したことでキャラク

タの手がどのように反応するかを確認します。

12 必要に応じて、手の動きにさらに修正を加えます。調整するたびにキーを

作成するのを忘れないでください。

13 アニメーションの最後のフレームに移動し、Pepe の体の右側が表示される
ようにビューを調整します。
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キャラクタの右手が頭に近すぎます。

14 Pepe の手を体から離して、キーを設定します。

15 Rキーを押して、キー回転リングを使って手の位置を修正します。手が地

面と変更になったら、さらにキーを設定します。

注:

必要に応じてビューを調整して、Pepe の手が地面の高さと一致しているか
どうか確認してください。

回転リングを使って右手の位置を調整します。

16 アニメーションを再生して結果を確認します。

17 さらにキャラクタの体の位置を調整してから、ファイルを

My_Pepe_keyanim.fbxという名前で保存します。
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注:

この状態でファイルを保存すると、シーンにはキャラクタ Pepe のアニメー
ションと一緒に黄色いリファレンススケルトンも保存されます。必要であ

ればシーンからスケルトンを削除したり、キャラクタ Pepe だけを選択し
て別のファイルに保存し、そのファイルを 3ds Max にインポートすること
も可能です。ただし、3ds Max にインポートする際にスケルトンを削除す
る方が簡単です。

18 キャラクタ Pepe をドラッグして選択します。こうすることで、3ds Max
にエクスポートする際に黄色いスケルトンを除外することができます。

19 MotionBuilderメインメニューから、[File] > [Send To 3ds Max] > [Send
as New Scene]を選択します。

[File] > [Send to 3ds Max] > [Send as New Scene]

3ds Max が起動し、アニメートされたキャラクタ Pepe がビューポートに
ロードされます。

20 編集したMotionBuilderアニメーションを表示するには、[3ds Max
Animation Controls]で[Play]をクリックします。

3ds Maxで再生される Pepeのアニメーション
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まとめ

この一連のチュートリアルでは、3ds Max で作成された数種類のスケルトンを
扱い、MotionBuilderにエクスポートしました。MotionBuilderでは、ボーン
をキャラクタライズし、キャラクタをアニメートしました。

次に、モーションを仕上げるためのいくつかの調整を行い、キャラクタ Pepe を
エクスポートして 3ds Max に戻しました。
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