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Tutorials

Introduction
This book includes a set of nine Autodesk MotionBuilder tutorials—some of
which provide two types of workflows—and demonstrate how to use the more
powerful keyframe and character animation features.

IMPORTANT The tutorials were written and updated using the Autodesk
MotionBuilder version 2013, Autodesk Maya® version 2013, and Autodesk 3ds Max®

version 2013. If you do the tutorials using a version other than version 2013, the
results may differ.

NOTE The tutorial Importing 3ds Max Files into MotionBuilder use the Send To
single-step interoperability features. If you are using an earlier version than version
2012 of the software products, refer to the Note under each topic that directs you
to the appropriate topic in the MotionBuilder Help for legacy workflows so you can
successfully perform the tutorial procedures.

You can find the tutorial assets in the Autodesk MotionBuilder Asset browser’s
Tutorials folder as well as in the Tutorials folder located in the Autodesk
MotionBuilder directory on your system.

BEST PRACTICE Go to http://www.autodesk.com/motionbuilder2013-documentation
to download the latest version of the tutorials and tutorial assets (or support files).

To add a directory to be displayed in the Asset browser:

■ Refer to “Adding a favorite path” topic in the MotionBuilder Help under
"User’s Guide | MotionBuilder Interface | Asset browser topic.

1

1

http://www.autodesk.com/motionbuilder2013-documentation


This book includes the following tutorials:
■ Loading and Characterizing Character Models (page 8)

■ Creating and Customizing a Control Rig (page 19)

■ Creating a Character Extension (page 34)

■ Creating a Walk Cycle (page 45)

■ Retargeting Character Animation (page 65)

■ Editing Character Animation (page 77)

■ Creating a Loop (page 90)

■ Manipulating Clips (page 108)

■ Importing 3ds Max Files into MotionBuilder (page 119)

See also:

MotionBuilder workflow  (page 2)

MotionBuilder Workflows
There are two workflows you can use for completing the tutorials: the Autodesk
interoperability workflow and the generic workflow. The workflows enable
you to become familiar with the MotionBuilder software product and guide
you in choosing the most efficient workflow for your projects.

Use the Autodesk interoperability workflow when you are working on a project
that includes interoperability with MotionBuilder and Maya or MotionBuilder
and 3ds Max to streamline your process.

Use the generic workflow when you are using pre-2012 versions of Autodesk
3ds Max and Autodesk Maya, or when you are using another 3D software
package with MotionBuilder. See Generic workflow (page 5).

Although these tutorials assume you are using MotionBuilder for a character
animation project, the workflows can be easily adapted to any animation
project where MotionBuilder is used in conjunction with other 3D modeling
or rendering software.

Autodesk interoperability workflow

MotionBuilder has the Single-step interoperability feature that enables you to
send your model to Maya or 3ds Max via the File > Send To Maya and  File
> Send To 3ds Max menu options.

2 | Chapter 1   Tutorials



Maya and 3ds Max both have the Single-step interoperability feature that
enables you to send your model to MotionBuilder via the File > Send to
MotionBuilder menu option.

IMPORTANT The Single-step interoperability features are not available in the
Autodesk software versions prior to version 2012.

1 Create a character model in Maya or 3ds Max.

Before you start your animation project using MotionBuilder, there are
a few things you can do when modeling to facilitate your work in
MotionBuilder.

Refer to “Guidelines for creating a character model”, “Bone naming
conventions”, “Import and characterize a 3ds Max biped in
MotionBuilder”, and “Choosing shapes to create” in the MotionBuilder
Help.

2 Export the character model from Maya or 3ds Max via File >
Send to MotionBuilder..

If MotionBuilder2013 is installed, it launches and loads your character
model.

3 Once the model loads into MotionBuilder, set it up for
animation by dragging the 3ds Max or MotionBuilder
Character asset on top of it.

The Character asset helps you map the structure of your character model
so that it can be animated in MotionBuilder. Once you complete this
mapping process, you ‘activate’ the character model by characterizing
it. Characterizing lets MotionBuilder know that this character model is
ready to be animated. The first tutorial shows you how to import
character models into MotionBuilder and prepare them for animation.

See Characterize the character model (page 16).

4 Add a Control rig and customize it to fit your character
animation needs.

Control rigs are an animation tool that make it easy to control and
position your character model.

The second tutorial shows you how to customize a Control rig and add
character animation features such as floor contacts and Auxiliary pivots.

See Creating and Customizing a Control Rig (page 19).

5 Add Character Extensions to support props or non-human
body parts.

MotionBuilder Workflows | 3



The third tutorial shows you how to augment your character with an
extra limb, in this case a “Servo arm” with giant pincers attached to the
character’s right shoulder.

See Creating a Character Extension (page 34).

6 Create your animation using keyframing and character
animation features.
■ One efficient method of creating animation involves creating a set

of poses that can be pasted onto your character at various points over
time.

The fourth tutorial shows you how to use the Control rig and the
Pose Controls to create a walk cycle.

See Creating a Walk Cycle (page 45).

■ The seventh tutorial shows you an alternative method for creating a
walk cycle using clips in the Story window.

See Creating a Loop (page 90).

7 Edit and refine your animation.
■ The sixth tutorial shows you how to use layers to edit animation.

See Editing Character Animation (page 77).

■ The eighth tutorial shows you how to combine animations using the
Story window.

See Manipulating Clips (page 108).

8 Retarget your animation between Character models.

During animation projects, the Character model you use might change.
Although not a required step for creating animation within
MotionBuilder, instead of re-creating the animation on a new model,
you can simply apply the same animation to the desired model(s).

The fifth tutorial shows you how to transfer animation and Character
Extensions between character models.

See Retargeting Character Animation (page 65).

9 If you want to animate 3ds Max characters in MotionBuilder,
and then use that animation in 3ds Max, you need to import
your 3ds Max scene into MotionBuilder, animate in
MotionBuilder, then import your animation in 3ds Max.

This last tutorial shows you the major steps for importing animation
into MotionBuilder, animating in MotionBuilder, and exporting the
animation from MotionBuilder and importing it to 3ds Max.

4 | Chapter 1   Tutorials



See the following topics: 3ds Max skeletons (page 121), 3ds Max Bipeds
(page 133), 3ds Max Characters (page 146), and Animating a 3ds Max
Character in MotionBuilder (page 153).

Generic workflow

Maya and 3ds Max 2012 both have one-step interoperability features that
brings your model into MotionBuilder automatically. If you do not have the
2012 versions of these packages, you need to install the appropriate Maya or
3ds Max FBX Plug-in to transfer your models into MotionBuilder. Download
the free FBX plug-in http://www.autodesk.com/fbx.

If you are using another 3D software package, you can convert your file to
FBX using the free FBX Converter that you can download from ht-
tp://www.autodesk.com/fbx.

1 Create a character model in your 3D software.

Before you start your animation project using MotionBuilder, there are
a few things you can do when modeling to facilitate your work in
MotionBuilder.

Refer to “Guidelines for creating a character model”, “Bone naming
conventions”, “Import and characterize a 3ds Max biped in
MotionBuilder”, and “Choosing shapes to create” in the MotionBuilder
Help.

2 Export the character model from your modeling software
package.

When you export your work from a modeling software package, the FBX
Plug-in you installed lets you save your character model in the .fbx file
format. This format enables you to load your models in MotionBuilder.

3 Start MotionBuilder and load your character model.

Once you load a model into MotionBuilder, you can set it up to animate
it using the MotionBuilder Character asset.

4 Once the model loads into MotionBuilder, set it up for
animation by dragging the 3ds Max or MotionBuilder
Character asset on top of it.

The Character asset helps you map the structure of your character model
so that it can be animated in MotionBuilder. Once you complete this
mapping process, you ‘activate’ the character model by characterizing
it. Characterizing lets MotionBuilder know that this character model is
ready to be animated.

MotionBuilder Workflows | 5
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5 Add a Character asset to your character model and characterize
it.

The Character asset helps you map the structure of your character model
so that it can be animated in MotionBuilder. Once you complete this
mapping process, you ‘activate’ the character model by characterizing
it. Characterizing lets MotionBuilder know that this character model is
ready to be animated. All major character animation features in
MotionBuilder, including Control rigs and animating in the Story
window, require a characterized character.

The first tutorial shows you how to create a Character asset and use it
to map out your character model’s structure.

See Loading and Characterizing Character Models (page 8).

6 Add a Control rig and customize it to fit your character
animation needs.

Control rigs are an animation tool that make it easy to control and
position your character model.

The second tutorial shows you how to customize a Control rig and add
character animation features such as floor contacts and Auxiliary pivots.

See Creating and Customizing a Control Rig (page 19).

7 Add Character Extensions to support props or non-human
body parts.

The third tutorial shows you how to augment your character with an
extra limb, in this case a “Servo arm” with giant pincers attached to the
character’s right shoulder.

See Creating a Character Extension (page 34).

8 Create your animation using different keyframing and
character animation features.
■ One efficient method of creating animation involves creating a set

of poses that can be pasted onto your character at various points over
time.

The fourth tutorial shows you how to use the Control rig and the
Pose Controls to create a walk cycle.

See Creating a Walk Cycle (page 45).

■ The seventh tutorial shows you an alternative method for creating a
walk cycle using clips in the Story window.

See Creating a Loop (page 90).

9 Edit and refine your animation.
■ The sixth tutorial shows you how to use layers to edit animation.
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See Editing Character Animation (page 77).

■ The eighth tutorial shows you how to combine animations using the
Story window.

See Manipulating Clips (page 108).

10 Retarget your animation between Character models.

During animation projects, the Character model you use might change.
Although not a required step for creating animation within
MotionBuilder, instead of re-creating the animation on a new model,
you can simply apply the same animation to the desired model(s).

The fifth tutorial shows you how to transfer animation and Character
Extensions between character models.

See Retargeting Character Animation (page 65).

11 Plot your finished animation to your model’s skeleton.

Depending on the animation features you are using to create your
character animation, plotting may consist of plotting from your Control
rig to your character model skeleton, or plotting the tracks in the Story
window to a single take.

Whatever method you use to animate, the finished result must be plotted
to the skeleton of your character model before you export it.

See “The plotting process” topic in the MotionBuilder Help “Plotting
Animation” chapter.

12 Save your plotted model as an .fbx file.

Your finished animations can also be exported for rendering in the
software of your choice using the appropriate FBX Plug-In.

You can download the latest FBX Plug-ins from: ht-
tp://www.autodesk.com/fbx.

See also:

Installing the latest FBX Plug-ins  (page 7)

Installing the latest FBX Plug-ins
The Autodesk® FBX® technology is one of the most widely used and supported
platform-independent 3D data interchange solutions around. Universal 3D
asset exchange via Autodesk FBX helps to remove data compatibility barriers
and gives you the freedom to build an efficient pipeline for your projects.

Installing the latest FBX Plug-ins | 7
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Autodesk FBX fosters interoperability between several Autodesk products. The
MotionBuilder software product supports FBX natively, while the Autodesk
Maya and Autodesk 3ds Max software products include FBX plug-ins. In
addition, the Autodesk® Softimage® software product can read and write FBX
through the Autodesk® Crosswalk software initiative. Autodesk ® Mudbox ™

2010 software is the first Mudbox release to support FBX, streamlining common
workflows between Mudbox, Maya, 3ds Max, and MotionBuilder.

You can download the latest FBX Plug-ins and FBX Plug-ins documentation
from: http://www.autodesk.com/fbx.

Loading and Characterizing Character Models
This tutorial guides you through the procedures necessary to bring your
character models into MotionBuilder and get them ready for animation.

Each character model brought into MotionBuilder has to be characterized
before you can create a Control rig, create poses, and use other animation
tools. To characterize a character model, you need to map its structure.

This tutorial shows you how to:

■ Prepare the scene (page 9)

■ Complete the character map (page 11)

■ Characterize the character model (page 16)

The following asset is required for this tutorial:

■ mia_blue.fbx

NOTE The tutorial assets can be found in the Asset Browser under the Tutorials
folder and in the MotionBuilder directory on your system.

BEST PRACTICE To use the latest update of the tutorials and tutorial assets, go to
http://www.autodesk.com/motionbuilder2013-documentation and download the
tutorials and tutorial support files to your system. If you download the tutorial
support files to a location other than theMotionBuilder default location, remember
to add this location in the Asset browser so you can access the assets via the Asset
browser. See Adding a favorite path topic in the Help under MotionBuilder Interface
| Asset browser.
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Prepare the scene

In the following procedure, you prepare the MotionBuilder scene and open
the file needed to start this tutorial.

To prepare the scene:

1 From the menu bar, select File > New, then select Layout > Editing.

MotionBuilder displays a new 3D scene using the Editing layout. This
layout displays all the windows you need for your work in this tutorial.

2 Click the Tutorials folder in the Asset browser.

3 Drag the mia_blue asset (mia_blue.fbx file) from the Asset browser into
the Viewer window, then select FBX Open > <No Animation> as shown
in the following figure.

In the Viewer window, a model named Mia appears in the T-stance.

Loading and Characterizing Character Models | 9



Mia in the T-stance

NOTE This model was created in Maya, and the bones were named according
to the naming conventions in the MotionBuilder Mapping list.

4 Choose File > Save As.

The Save File window appears.

5 Navigate to a directory other than the default MotionBuilderTutorials
directory where you want to save the file and click Save.

The Save Options dialog box appears.

6 Click Save.

Choosing to save the file to a directory other than the default
MotionBuilderTutorials directory ensures you do not overwrite the
original .fbx file.
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Complete the character map

In the following procedure, you define the structure of your character model
for MotionBuilder by mapping the required nodes in the Mapping list.
Character mapping describes the character model for MotionBuilder, indicating
what are the legs, arms, and so on.

Although you can automatically map and characterize a character by dragging
the Character asset directly onto a character model, for the purpose of this
tutorial, you manually map out Mia’s structure.

To complete the character map:

1 From the Templates > Characters folder of the Asset browser, drag the
Character asset into an empty area of the scene.

Drag the Character asset into the scene

A Character asset is added in the Scene browser (A) and the Character
Settings are displayed in the Navigator window (B).
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Navigator window: A. Character in the Scene browser B. Character Settings

2 Switch to the Character Definition pane in the Character Settings and
expand the Base (required) group of nodes in the Mapping list (A).

Character Definition pane: A. Base nodes

This group of nodes is required for MotionBuilder to recognize the
structure of your character model. If you had automatically characterized
this character, the Mapping list would be populated with the character’s
bone names.

3 In the Viewer window, switch to the Schematic view (Ctrl-W) and press
A to frame the hierarchy.
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Schematic view of Mia’s structure

The Schematic view makes it easier to select bones from the model’s
hierarchy because each bone is represented as a rectangular node.

4 In the Scene browser, activate the Lock option to lock the view of the
Character Definition pane.

Navigator window: A. Scene browser Lock option activated

5 In the Schematic view, zoom in, pan to locate the Mia:LeftUpLeg node,
and select the node.

Viewer Navigation buttons: A. Travelling button B. Zoom button
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TIP You can use the keyboard shortcut Ctrl-drag to zoom in and the
keyboard shortcut Shift-drag to travel (or pan) in the Viewer window.

Mia:LeftUpLeg node selected

NOTE When you know the name of the node you are looking for, you can
press Shift-N to open the Find Model by Name dialog box and do a quick
search.

6 Alt-drag the Mia:LeftUpLeg node into the Base (required)LeftUpLeg
Mapping List slot.

Mia’s LeftUpLeg node mapped to MotionBuilder LeftUpLeg

When you characterize this character, MotionBuilder recognizes that for
this skeleton the LeftUpLeg node is called Mia:LeftUpLeg.
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7 Use the following checklist and figure as guides to map the rest of Mia’s
bones to the Base (required) nodes in the Mapping list.

NOTE  Although Mia has many bones, you are only required to map the
Base group of 15 for MotionBuilder characterization.

MappedSlotBone

HipsMia:Hips

xLeftUpLegMia:LeftUpLeg

LeftLegMia:LeftLeg

LeftFootMia:LeftFoot

RightUpLegMia:RightUpLeg

RightLegMia:RightLeg

RightFootMia:RightFoot

SpineMia:Spine

LeftArmMia:LeftArm

LeftForeArmMia:LeftForeArm

LeftHandMia:LeftHand

RightArmMia:RightArm

RightForeArmMia:RightForeArm

RightHandMia:RightHand

HeadMia:Head

Loading and Characterizing Character Models | 15



After completing the character mapping process for the Base group, the
Mapping list resembles the Mapping List shown in the following figure.

Mia’s base bones mapped to the Base nodes in the Mapping list

The Character mapping is now complete.

Characterize the character model

The following procedure shows you how to characterize a model. The moment
you characterize a character model, MotionBuilder reads the structure you
have outlined in the Mapping list, taking the model’s current pose as the base
for all future poses and movement.

To characterize the character model:

1 In the Character Definition pane, activate the Characterize option (A).
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Character Definition pane A. Characterize option

2 In the Character dialog box that appears, click Biped, since the Mia
skeleton stands on two legs and makes contact with the floor using only
the feet.

Biped option in the Character dialog box

Generic offsets are calculated so that the character is compatible with
any source, the character is characterized, and MotionBuilder recognizes
its structure.

The nodes in the Mapping list are gray and cannot be edited.
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NOTE If you want to add more bones or edit the Mapping list later, you can
temporarily disable the Characterize option when your character is in the
T-stance.

3 In the Scene browser, expand the Characters branch, right-click the
Character asset, select Rename from the contextual menu, and name
the character “Mia” (A).

Scene browser A. Character asset named Mia

Your character is now fully characterized and ready to be animated.
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Summary

In this tutorial, you loaded a character model, mapped out its structure, and
characterized it.

In the next tutorial, (Creating and Customizing a Control Rig (page 19)), you
create and customize a Control rig for your characterized character.

Creating and Customizing a Control Rig
This tutorial guides you through the procedures necessary to create a Control
rig and customize the Control rig to create animation in subsequent tutorials.

Control rigs are an animation tool that make it easy to control and position
your character model. You can re-purpose Control rigs for other models.

This tutorial shows you how to:

■ Prepare the scene (page 20)

■ Create a Control rig (page 21)

■ Adjust the foot floor contact markers (page 25)

■ Adjust the hand floor contact markers (page 28)

■ Add Auxiliary pivots (page 29)

The following asset is required for this tutorial:

■ mia_characterized.fbx

NOTE The tutorial assets can be found in the Asset Browser under the Tutorials
folder and in the MotionBuilder directory on your system.

BEST PRACTICE To use the latest update of the tutorials and tutorial assets, go to
http://www.autodesk.com/motionbuilder2013-documentation and download the
tutorials and tutorial support files to your system. If you download the tutorial
support files to a location other than theMotionBuilder default location, remember
to add this location in the Asset browser so you can access the assets via the Asset
browser. See Adding a favorite path topic in the Help under MotionBuilder Interface
| Asset browser.
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Prepare the scene

In the following procedure, you prepare the MotionBuilder scene and open
the file needed to start this tutorial.

To prepare the scene:

1 From the menu bar, select File > New, then select Layout > Editing.

MotionBuilder displays a new 3D scene using the Editing layout. This
layout displays all the windows you need for your work in this tutorial.

2 Click the Tutorials folder in the Asset browser.

3 Drag the mia_characterized asset (mia_characterized.fbx file) from the Asset
browser into the Viewer window as shown in the following figure, then
select FBX Open > <No Animation>.

A model named Mia appears in the Viewer window, in the T-stance.

Mia shown in the T-stance

4 Choose File > Save As.

The Save File window appears.

5 Navigate to a directory other than the default MotionBuilderTutorials
directory where you want to save the file and click Save.

The Save Options dialog box appears.

6 Click Save.
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Choosing to save the file to a directory other than the default
MotionBuilderTutorials directory ensures you do not overwrite the
original .fbx file.

Create a Control rig

In the following procedure, you create and prepare a Control rig for the Mia
character.

To create a Control rig:

1 In the Scene browser, expand the Characters branch and double-click
the Mia character to access the Character Definition pane.

2 In the Navigator window, click the Character Definition pane and in
the Control Rig area, click Create.

The Create Control Rig dialog box appears.

3 Click FK/IK.

Creating and Customizing a Control Rig | 21



An FK/IK Control rig is created for the Mia Character and is shown in
the Character Controls window as the (motion) source for the Mia
character in the Controls tab.
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4 Click in the Viewer window and press Ctrl-A until you are in X-Ray
display mode.
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NOTE  The display mode is shown at the bottom left of the Viewer window.
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In X-Ray display mode, you can see the FK and IK effectors that make
up the Control rig.
■ The blue and red IK effectors let you intuitively manipulate the

character using a setup that simulates how the human body moves.

■ The yellow FK effectors let you selectively fine-tune individual body
parts. If you plan to do any fine-tuning with your characters, create
Control rigs with both FK and IK effectors.

5 In the Navigator window, switch back to view the Character Settings
pane.

Character Settings pane A. Input Type menu B. Active option shown enabled

The Control rig is also shown as the active motion source by the Input
Type menu and the Active option in the Character Settings pane (A and
B).

Adjust the foot floor contact markers

In the following procedure, you adjust how the character’s feet touch the floor
using the floor contact markers.

The floor contact markers are the blue and green markers that appear around
the character’s hands and feet when you characterize your character model.
These markers create an invisible grid that determines where the character’s
feet come in contact with the floor.
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Green and blue floor contact markers displayed around Mia’s hands and feet

NOTE When no floor object is defined in the Mapping list of the Character
Definition pane, the MotionBuilder grid is used as the floor. In this tutorial, the
floor is not defined.

To adjust the foot floor contact markers:

1 In the Viewer window, click the View menu and select Orthographic >
Producer Right (or click in the Viewer and press Ctrl-R) to switch to
Producer Right camera view.

2 Zoom in on Mia’s feet as shown in the following figure.

3 Click one of the floor contact markers underneath Mia’s feet.

4 Click the Translate button in the Viewer toolbar (or press T) to activate
the Translate mode.

5 Translate the floor contact marker using the following guidelines and
figure for the marker placement:
■ Align the middle marker where the toe bone starts (B).

■ Align the front marker with the toe of the model (A).

■ Align the rear marker with the heel of the model (C).
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Mia’s foot floor contact markers A. Front marker B. Middle marker C. Rear
marker

NOTE Moving one foot marker adjusts the other markers accordingly so
that as you adjust the green markers on Mia’s left foot, the blue markers
on the right foot are also adjusted.

6 Switch to Orthographic Producer Front view (Ctrl-F), zoom in on the
feet (Ctrl-drag), and translate the foot markers right or left to position
them at the edges of the feet as shown in the following figure.

Left and right position of the markers

7 In the Character Settings pane, expand Floor Contacts (A) and activate
the Feet Floor Contact option (B).
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Character Settings pane A. Floor Contacts group of properties B. Feet Floor
Contact option

Adjust the hand floor contact markers

In the following procedure, you define the floor contact for the hands so that
when Mia’s hands touch the floor, it produces a realistic result.

To adjust the hand floor contact markers:

1 In the Scene browser, double-click the Mia character and click the
Character Settings pane to display the Character Settings.

2 In the Character Settings pane, expand Floor Contacts (A) if it is not
already expanded, and activate the Hands Floor Contact (B) and the Fingers
Floor Contact (C) options to activate the floor contact for the hands and
fingers.

Character Settings pane A. Floor Contacts B. Hands Floor Contact C. Fingers
Floor Contact
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3 Expand the Hands Floor Contact Setup option, click the Hands Contact
Type menu (A) and select Wrist.

Character Settings pane: A. Hands Contact Type B. Wrist Hands Contact Type

By default, the Hands Contact Type is set to Normal, which gives Mia six
hand floor contact markers. Changing this option to Wrist gives each
hand four floor contact markers for basic control.

4 Zoom in on one of Mia’s hands in the Viewer window using various
camera views.

5 Align the rear hand markers with the wrist and the front markers with
the base of the fingers (not including the thumb). Also translate the rear
markers lower on the Y-axis to align them with the base of the palm as
shown in the following figure.

Add Auxiliary pivots

In the following procedure, you create two Auxiliary pivots for additional
control over the IK system on Mia’s Control rig. These Auxiliary objects can
be used to create realistic rotation on Mia’s feet as she walks. They also make
it easier to rotate Mia’s feet while creating keyframe animation.
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To add Auxiliary pivots:

1 In the Character Controls window, right-click the Left Ankle cell and
select Create Aux Pivot from the contextual menu.
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An Auxiliary pivot is created for the left ankle IK effector (A). The
Auxiliary pivot displays on the left ankle cell in the Character Controls
window as an X (B).

A. Auxiliary pivot displayed in the Viewer window B. X represents the Auxiliary
pivot

By default, the foot effector is deselected when you create the Auxiliary
pivot, and the Auxiliary pivot is selected. In the Viewer window, the
Pivot Selection mode is automatically selected.

Viewer window A. Pivot Selection mode

2 Select the Auxiliary pivot you created, if it is not already selected, and
translate it until it is placed at the tip of Mia’s toes, as shown in the
following figure.
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Left Ankle Auxiliary pivot A. Front view B. Side view

NOTE You can use the  > Show/Hide menu in the Character Controls
window to hide the Floor Contact markers as you place the Auxiliary pivots.

3 Right-click the Left Ankle cell again and select Create Aux Pivot from the
contextual menu.

A second Auxiliary pivot displays in the Viewer window.

4 Translate the second Auxiliary pivot to display at the heel of the foot,
as shown in the following figure.

Summary

In this tutorial, you created a Control rig, arranged the floor contact markers
on the character’s feet, then created two Auxiliary pivots to control the rotation
of the foot.

In the next tutorial, (Creating a Character Extension (page 34)), you add a
Character Extension to the Mia character.
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Creating a Character Extension
This tutorial guides you through the procedures necessary to create a Character
Extension that enables you to control extra appendages for a character.

In this tutorial, you load a limb for the Mia character, attach it to Mia using
a Character Extension, and define its animation in relation to Mia’s body.

This tutorial shows you how to:

■ Prepare the scene (page 34)

■ Connect the extra limb to the character (page 36)

■ Create a Character Extension (page 40)

The following assets are required for this tutorial:

■ mia_rigged.fbx

■ servo.fbx

NOTE The tutorial assets can be found in the Asset Browser under the Tutorials
folder and in the MotionBuilder directory on your system.

BEST PRACTICE To use the latest update of the tutorials and tutorial assets, go to
http://www.autodesk.com/motionbuilder2013-documentation and download the
tutorials and tutorial support files to your system. If you download the tutorial
support files to a location other than theMotionBuilder default location, remember
to add this location in the Asset browser so you can access the assets via the Asset
browser. See Adding a favorite path topic in the Help under MotionBuilder Interface
| Asset browser.

Prepare the scene

In the following procedure, you prepare the MotionBuilder scene and open
the file needed to start this tutorial.

To prepare the scene:

1 From the menu bar, select File > New, then select Layout > Editing.

MotionBuilder displays a new 3D scene using the Editing layout. This
layout displays all the windows you need for your work in this tutorial.
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2 Click the Tutorials folder in the Asset browser.

3 Drag the mia_rigged asset (mia_rigged.fbx file) from the Asset browser into
the Viewer window, then select FBX Open > <No Animation> from the
contextual menu as shown in the following figure.

Characterized Mia appears in the Viewer window

The characterized Mia appears in the Viewer window in the T-stance.

4 From the Asset browser drag the servo asset (servo.fbx file) into the scene
and select FBX Merge > <No animation> from the contextual menu.

A Servo arm is loaded into the scene, positioned over Mia’s shoulder. In
the next procedure, you attach this arm to Mia as another limb.
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Mia and Servo arm loaded into the scene

5 Choose File > Save As.

The Save File window appears.

6 Navigate to a directory other than the default MotionBuilderTutorials
directory where you want to save the file and click Save.

The Save Options dialog box appears.

7 Click Save.

Choosing to save the file to a directory other than the default
MotionBuilderTutorials directory ensures you do not overwrite the
original .fbx file.

Connect the extra limb to the character

In the following procedure, you create a Parent-Child relationship between
the Servo arm and Mia’s shoulder.

To connect the extra limb to the character:

1 Switch to X-Ray display mode (Ctrl-A) in the Viewer window.

NOTE Toggle between Normal mode, Models Only mode, and X-Ray mode
using the keyboard shortcuts Ctrl-A.
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2 In the Character Controls window, make sure Mia is selected as the
current character.

3 Click in the Viewer window then do the following:
■ Press Ctrl-W to switch to the Schematic view.

■ Right-click in the Schematic view and select Auto-Arrange and then
Arrange-All from the contextual menu.

■ Press A to see all the nodes in the Schematic view.

The Schematic view displays a hierarchy for Mia’s skeleton (A), Mia’s
Control rig (B), and a third hierarchy for the Servo arm
(“ServoMaster”, C).

Schematic view of hierarchies in the scene A. Mia’s skeleton B. Mia’s Control
rig C. The Servo arm

4 Zoom in on the Servo arm (ServoMaster) hierarchy at the right of the
view (C) and select the ServoMaster node.
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ServoMaster node selected

5 Switch back to the Producer camera view (Ctrl-W) and zoom in on Mia’s
right shoulder. The ServoMaster node null is still selected.

The ServoMaster null is selected in the Viewer window

6 Press the P keyboard shortcut to activate Parenting mode, then drag the
ServoMaster null to the Mia:RightShoulder bone (A).

The bone is highlighted green as you parent the Servo arm. This parents
the Servo arm to the right shoulder bone (B).
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A. Parenting the ServoMaster null to Mia’s right shoulder bone B. After parenting

7 Switch to the Schematic view to verify that the Servo arm is a child of
the Mia:RightShoulder bone.

Schematic view showing parenting structure A. Mia:RightShoulder bone B. Servo
arm hierarchy

NOTE The Mia:RightShoulder node is found on the left side of the Schematic
view. If you have not already done so, right-click and select Auto arrange to
clean up the hierarchy.

8 Switch back to the Producer Perspective view.

9 Select the ServoControl effector at the end of Mia’s Servo arm (A), make
sure you are back in Parenting mode, and parent it to Mia’s right shoulder
bone as well.

Creating a Character Extension | 39



A. ServoControl effector B. Right shoulder bone

10 Switch to the Schematic view to verify that the ServoControl effector is
a child of the Mia:RightShoulder bone.

Schematic view showing parenting structure A. Mia:RightShoulder bone B.
ServoControl effector

Create a Character Extension

In the following procedure, you create a Character Extension to connect the
Servo arm to the Mia character so that they can be controlled and keyframed
together.
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To create a character extension:

1 In the Scene browser, expand Characters, right-click Mia, and select
Create Character Extension from the contextual menu (A).

Scene browser A. Create Character Extension option

2 Expand the Character Extensions folder in the Scene browser to see the
Mia Extension (C).

Scene browser A. Character Extension added to Mia character B. Character
Extensions heading added to the Scene browser C. Character Extension named
for the Mia character

3 Switch back to the Producer Perspective view.

Creating a Character Extension | 41



4 Alt-drag the ServoControl effector from the Viewer window onto the
Mia Extension in the scene browser and select Add to Mia Extension from
the contextual menu as shown in the following figure.

A. ServoControl effector B. ServoControl effector added to Mia Extension

The Servo arm is defined as a Character Extension of Mia, and is
considered as a new “body part” of the Mia character.

5 With the ServoControl effector still selected, open the Properties window.

NOTE The Properties window is a tab in the Resources pane, on the right
side of the interface. Alternatively, from the menu bar, click Window > Add
Property View to display the window.

Properties window
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6 Select the green custom property Close_Open and drag its slider left and
right as shown in the following figure.

A. Servo arm opens B. Custom property Close_Open

In the Viewer window, the pincer moves on the Servo arm.

7 Alt-drag the Close_Open property over the Mia Extension (A) and select
Create 1 Property Reference from the contextual menu (B).

A. Close_Open property dragged to Mia Extension B. Select Create 1 Property
Reference

8 Select the Mia Extension in the Scene browser (A), then activate the Lock
option in the Properties window (B) so that the Mia Extension properties
stay open no matter what you select.
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A. Mia Extension selected B. Lock option activated in the Properties window

9 Define Mia’s right shoulder bone as the Reference object for the Character
Extension by Alt-dragging the Mia:RightShoulder bone (A) into the
Reference Object field in the Properties window (B).

A. Mia:RightShoulder B. Mia:RightShoulder Reference Object

10 Click OK in the Reference Object Change dialog box that appears.

The Reference object for your Character Extension is used to calculate
all future positioning of the Extension, for example when the Character
Extension is included in a pose.

NOTE The Add To Full Body option in the Properties window is turned
on to define whether you want the Character Extension to be keyed when
you set keys in Full Body Keying mode.

See MotionBuilder Help > Animating Characters > Character setup >
Character Extensions > Character Extension properties.
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Summary

In this tutorial you added a limb to the Mia character by creating a Character
Extension.

In the next tutorial (Creating a Walk Cycle (page 45)), you animate the
character and the Character Extension using the Pose Controls.

Creating a Walk Cycle
This tutorial guides you through the procedures necessary for using poses to
create a walk cycle.

This tutorial shows you how to:

■ Prepare the scene (page 46)

■ Create poses  (page 48)

■ Create animation with poses (page 57)

■ Mirror poses (page 61)

■ Play the animation (page 64)

The following asset is required for this tutorial:

■ mia_servo.fbx

NOTE The tutorial assets can be found in the Asset Browser under the Tutorials
folder and in the MotionBuilder directory on your system.

BEST PRACTICE To use the latest update of the tutorials and tutorial assets, go to
http://www.autodesk.com/motionbuilder2013-documentation and download the
tutorials and tutorial support files to your system. If you download the tutorial
support files to a location other than theMotionBuilder default location, remember
to add this location in the Asset browser so you can access the assets via the Asset
browser. See Adding a favorite path topic in the Help under MotionBuilder Interface
| Asset browser.
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Prepare the scene

In the following procedure, you prepare the MotionBuilder scene and open
the files needed to start this tutorial.

1 From the menu bar, select File > New, then select Layout > Editing.

MotionBuilder displays a new 3D scene using the Editing layout. This
layout displays all the windows you need for your work in this tutorial.

2 Click the Tutorials folder in the Asset browser.

3 Drag the mia_servo asset (mia_servo.fbx file) into the Viewer window,
then select FBX Open > <No Animation> from the contextual menu that
appears.

A model named Mia (mia_servo asset) appears in the Viewer window as
shown in the following figure. This character includes a “Servo arm”
that is parented to the right shoulder bone and added as a Character
Extension.

In the Character Controls window, Mia is shown by default as the current
character in the Character menu (A).
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A.  Character Controls’ Character menu

4 Choose File > Save As.
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The Save File window appears.

5 Navigate to a directory other than the default MotionBuilderTutorials
directory where you want to save the file and click Save.

The Save Options dialog box appears.

6 Click Save.

Choosing to save the file to a directory other than the default
MotionBuilderTutorials directory ensures you do not overwrite the
original .fbx file.

Create poses

In the following procedures, you create several full body poses on your
character, including the Character Extension, to create a walk cycle.

Position the character:

1 In the Character Controls window, click the plus sign (+) above each
ankle effector to expand both auxiliary pivots. This way you can see
Mia's ankles are pinned in Translation (T) and Rotation (R).

Click the plus signs to expand the Ankle effectors (A, B)

2 Ctrl-click to select the wrist and ankle effectors.
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Effectors A Wrist effectors B. Ankle effectors

3 Disable the T and R Effector pinning options.
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Effector Pinning options A. T and R Effector pinning disabled
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NOTE You may have to toggle R (Rotation pinning) on and off once more
to ensure that rotation is disabled.

Make sure that there are no more T or Rs in any of the effectors on the
Character Representation.

4 Ensure the Full Body keying mode (  ) in the Character Controls
toolbar is enabled.

In the Full Body keying mode, pasted poses are placed onto the
character’s entire body, and keyframes are placed on all effectors.

5 In the Character Controls window, select the Left Shoulder effector.

6 Move the cursor over the Viewer window, press R, and rotate the effector
until Mia’s left arm is in a more natural position at her side.

7 Do the same for the Right Shoulder effector.

8 Ctrl+click both wrist effectors and translate them upward on the Y-axis
to give the elbows a natural bend.
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Wrists translated upward in Y-axis using the wrist effectors
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9 Click on an empty area of the Viewer window to deselect the wrist
effectors and choose a camera view that lets you see a side view of the
character. For example you can press Ctrl-R to switch to the Producer
Right camera view.

Producer Right camera view

NOTE You can switch the camera view at any time during the tutorial to
get a better view.

To create the first pose for the walk cycle:

1 In the Character controls window, select the right ankle effector and
move the foot forward (on the Z-axis) and upward slightly, so that the
knee bends.

2 Select the left ankle effector and slide it backward until Mia's feet are
apart and both knees are bent as if she is walking.

NOTE You can select the Ankle effector pivots to flex her foot.

3 Select the Right Shoulder effector and rotate the right arm slightly
backward, then select the Left Shoulder and rotate the left arm forward
as if Mia is naturally swinging her arms.

4 Select the Hips effector and translate Mia's body up or down so that she
appears to be in mid-stride. If your transformations cause Mia to float
above the floor, select the Hips effector and translate Mia downward at

Creating a Walk Cycle | 53



any time. The default floor contact makes Mia’s feet interact naturally
with the default floor.

This pose should have Mia with her right leg beginning the forward
motion of a step, as shown in the following figure.

First pose ready to create

5 In the Resources window, click the Pose Controls tab and click Create

 .

A pose is added to the Pose browser.

The position of the Character Extension is included with the position
of Mia’s body in this pose.

6 Expand the Poses folder in the Pose browser to see the pose.

7 Right-click the pose created and rename the pose “Walk 01” (B).

54 | Chapter 1   Tutorials



Pose Controls A. Create pose B. “Walk 01”pose in Pose browser

Create the second pose for the walk cycle:

1 Position Mia’s legs and arms so that she looks similar to the following
figure.
■ Select the right ankle effector and slide it back and down until her

foot is flat on the ground.

■ Then select the left ankle effector and slide it back until it is behind
her, to provide momentum.

■ Adjust the hips effector to bend her knees believably.

2 Select the Mia:ServoControl effector, and translate the Servo arm so it
reaches in front of Mia.

3 With the Mia:ServoControl effector still selected, click the Asset browser
Properties tab and use the Close_Open property (B) to open the pincers
about half-way as shown in the following figure.

A. Second pose for the walk cycle B. Close_Open property to control the pincers
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4 In the Pose Controls, click Create  and rename this pose as “Walk
02” (A).

Pose Controls A. Second pose renamed “Walk 02”

Create the third and final pose for the walk cycle:

1 Position Mia’s legs and arms so that her step appears similar to the
following figure.

2 Select the Mia:ServoControl effector and extend the Servo arm to reach
even further in front of Mia.

3 With the Mia:ServoControl still selected, open the pincers further using
the Close_Open property in the Properties window (B).

In this pose, the left leg goes back, and the Servo arm goes forward,
completing one step for the first half of the walk cycle.

A. Third pose for the walk cycle B. The Close_Open property

4 In the Pose Controls, click Create and then rename this pose “Walk 03”.

You now have three poses in the scene. The three poses are listed in the
Pose browser.
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Three poses created for the walk cycle

Create animation with poses

In the following procedure, you use the three poses you created to create one
half of a walk cycle. By keyframing these poses at different frames, you create
a short walking animation.

1 In the Character Controls window, deselect any effectors that may be
still selected and ensure that Full Body keying mode is selected (A).
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Character Controls A. Full Body Keying mode selected

2 In the Pose browser, double-click the “Walk 01” pose to paste it on Mia.
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Pose Controls: A. First pose for the walk cycle B. “Walk 01” pose pasted on Mia

By default, the Gravity, Translation, and Rotation options are active in
the Pose Controls window. This means that the translation and rotation
of the pasted pose match the translation and rotation of the selected
effector on the current character. The Gravity option ensures that the
feet stay at the original level of the pasted pose (normally floor level).

3 Select the Hips effector, then go to frame 0 in the Transport Controls.

A. Hips effector selected B. Current frame is 0

4 In the Key Controls window, select Auto in the Type menu.

5 Select AnimLayer1 from the Layer menu (A), then click Flat to set a Flat
keyframe (B).
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NOTE You can also press Ctrl-K to set a Flat keyframe.

Key Controls A. AnimLayer1 selected B. Flat key

6 Go to frame 4 and do the following:
■ Double-click the Walk 02 pose to paste it on Mia.

■ Press Ctrl-K to set a (Flat) keyframe.

Frame 4: A. Second pose for the walk cycle B. “Walk 02” pose pasted on Mia

7 Go to frame 8 and do the following:
■ Double-click the Walk 03 pose to paste it on Mia.

■ Press Ctrl-K to set a (Flat) keyframe.
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Frame 8: A.Third pose for the walk cycle B. “Walk 03” pose pasted on Mia

8 Drag the Timeline indicator through the animation to view the step you
created.

The interpolation between the three keyframes creates the movement
for one step.

Mirror poses

In the following procedure, you mirror the three poses from the Pose browser
to create the second half of the walk cycle. By keyframing these mirrored poses
after the original poses, you complete the short walking animation.

1 In the Pose Controls window, activate the M (Mirror) button (A) .

Pose Controls A. Mirror activated
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2 Go to frame 12 and do the following:
■ Double-click the “Walk 01” pose (A).

The “Walk 01” pose is pasted and mirrored onto the character (B).
Because you mirror-pasted the pose, the left leg is now forward, and
the right leg is behind to continue the walk cycle on the other side.

■ Press Ctrl-K to set a (Flat) keyframe.

Frame 12 A. First pose for the second half of the walk cycle B. “Walk 01”
pose pasted on Mia

3 Go to frame 16 and do the following:
■ Double-click the “Walk 02” pose (A).

The “Walk 02” pose is pasted and mirrored onto the character (B).

■ Press Ctrl-K to set a (Flat) keyframe.
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Frame 16 A. Second pose for the second half of the walk cycle B. “Walk 02”
pose pasted on Mia

4 Go to frame 20 and do the following:
■ Double-click the “Walk 03” pose (A).

The “Walk 03” pose is pasted and mirrored onto the character (B).

■ Press Ctrl-K to set a (Flat) keyframe.

Frame 20 A. Third pose for the second half of the walk cycle B.“Walk 03”
pose pasted on Mia
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Your animation now consists of six keyframes. The first three
keyframes were mirrored onto the left side of the character for the
last three keyframes, creating a complete walking movement. To
complete a full animation cycle, your take should begin and end with
the same position.

5 On the Action timeline in the Transport controls, select the keyframe at
frame 0 and C-drag the keyframe to frame 24.

The keyframe at frame 0 is copied to frame 24.

The animation now begins and ends on the same position, creating a
complete cycle.

Play the animation

1 in the Transport Controls window, click on the Action timeline and then
press Ctrl-Shift-A to frame the animation on the Action timeline to
its full length of 24 frames.

2 Click Loop (A), then click Play.

Animation framed A. Loop option

As the animation plays, each loop shows a full walk cycle.

In your animation, the movement may be a bit choppy, and the feet
may slide on the floor. You can smooth your movement by adjusting
the animation’s function curves in the FCurves window.

Summary

In this tutorial, you created poses on a character, set keyframes of these poses
at different points, and created a walk cycle.

NOTE You can also create a loop if you want to create a walk cycle using the Story
window.
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In the next tutorial, Retargeting Character Animation (page 65), you retarget
animation and a Character Extension from one character to another.

Retargeting Character Animation
This tutorial guides you through the procedures necessary to retarget animation
from one characterized character to another. Since the source character includes
a Character Extension and the target character does not, you must also retarget
the Character Extension.

This tutorial shows you how to:

■ Prepare the scene (page 66)

■ Save the character animation (page 67)

■ Create a scene (page 70)

■ Load character animation (page 71)

■ Play the animation (page 75)

The following assets are required for this tutorial:

■ mia_fk_runstopturn.fbx

■ Gremlin.fbx

NOTE The tutorial assets can be found in the Asset Browser under the Tutorials
folder and in the MotionBuilder directory on your system.

BEST PRACTICE To use the latest update of the tutorials and tutorial assets, go to
http://www.autodesk.com/motionbuilder2013-documentation and download the
tutorials and tutorial support files to your system. If you download the tutorial
support files to a location other than theMotionBuilder default location, remember
to add this location in the Asset browser so you can access the assets via the Asset
browser. See Adding a favorite path topic in the Help under MotionBuilder Interface
| Asset browser.
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Prepare the scene

In the following procedure, you prepare the MotionBuilder scene and open
the files needed to start this tutorial.

1 From the menu bar, select File > New, then select Layout > Editing.

MotionBuilder displays a new 3D scene using the Editing layout. This
layout displays all the windows you need for your work in this tutorial.

2 Click the Tutorials folder in the Asset browser.

3 Drag the mia_fk_runstopturn asset (mia_fk_runstopturn.fbx file) into the
Viewer window as shown in the following figure, then select FBX Open
> All takes from the contextual menu that appears.

A model named Mia appears in the Viewer along with her “Servo arm”
Character Extension.

Mia_fk_runstopturn asset dragged into the scene

4 Choose File > Save As.

The Save File window appears.

5 Navigate to a directory other than the default MotionBuilderTutorials
directory where you want to save the file and click Save.

The Save Options dialog box appears.

6 Click Save.
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Choosing to save the file to a directory other than the default
MotionBuilderTutorials directory ensures you do not overwrite the
original .fbx file.

7 In the Transport Controls, click Play (A) to view the animation on the
Mia character.

Transport Controls A. Play button

Save the character animation

In the following procedure, you save the character animation using the Save
Character Animation option. This lets you import Mia's animation to another
character using the Load Character Animation option.

1 From the Character Controls menu button, select File > Save Character
Animation.
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Character Controls menu A. Save Character Animation option
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2 Navigate to where you want to save the character animation, enter a file
name, and click Save.

Save File dialog box

3 In the Save Character Animation Options dialog box that appears,
activate the Save Control Rig option and the Save Character Extensions
option, then click Save.
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Save Character Animation Options dialog box

The animation and Character Extension are saved as an .fbx file.

Create a scene

In the following procedure, you create a scene.

1 Press Ctrl-N to create a scene.

2 In the Save changes dialog box appears, click Don’t Save.

Save changes dialog box

3 From the Asset browser, drag the Gremlin asset into the scene, and select
FBX Open > <No animation>.
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Gremlin asset dragged into the scene

Load character animation

In the following procedure, you load the character animation you saved earlier.

1 In the Character Controls window, select File > Load Character
Animation.
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Character Controls A. Load Character Animation option
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2 Navigate to select the .fbx file you saved earlier in this tutorial and click
Open.

The Load Character Animation Options dialog box appears.

3 Choose the following settings:
■ In the Load Technique area (A), select the Plot to Control Rig option.

■ In the Control Rig area, activate the Replace Control Rig option (B).

■ In the Control Rig area, activate the Reset Control Rig’s Rotation DOF
option (C).

■ In the Control Rig area, make sure the Remove Constraint Reference
option is activated (D).

■ In the Character Extensions area, activate the Process Animation
option (E).

■ In the Character Extensions area, activate the Copy Missing Character
Extensions option (F).
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Load Character Animation Options settings

4 Click Open.

Mia’s animation, Control rig, and character extension are loaded onto
the Gremlin character.
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Mia’s animation and Control rig loaded onto the Gremlin character

Because Mia’s Servo arm is parented to her right shoulder FK effector,
the Servo arm is attached in the same way to the Gremlin character.

Play the animation

Play the result animation.

1 Click Play in the Transport Controls (A) to play the animation.
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A. Gremlin using Mia’s animation B. Gremlin’s Control rig

Notice how both the Servo arm and the animation are transferred onto
the Gremlin character (A). The Gremlin’s original Control rig is left in
the middle of the scene (B). This happens because you selected Replace
Control Rig in the Load Character Animation Options dialog box.
Gremlin’s Control rig has been replaced by Mia’s.

2 In the Scene browser, expand Control Rigs and right-click Gremlin Rig
(Gremlin’s original Control rig) and select Delete to clean up the scene.

Scene browser: A. Contextual menu Delete option
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Summary

In this tutorial you retargeted animation from one characterized character to
another and you transferred the Character Extension from the source character
to the target character.

In the next tutorial, (Editing Character Animation (page 77)), you edit
animation on a layer from your original animation, then merge all layers.

Editing Character Animation
This tutorial guides you through the procedures necessary to modify animation
by creating animation layers. You modify the animation plotted to the
character’s Control rig on two layers, then combine the original animation
and your modified animation.

This tutorial shows you how to:

■ Prepare the scene (page 78)

■ Modify the Character Extension animation (page 79)

■ Modify the head animation (page 84)

■ Play the resulting take (page 89)

The following asset is required for this tutorial:

■ mia_runstopturn.fbx

NOTE The tutorial assets can be found in the Asset Browser under the Tutorials
folder and in the MotionBuilder directory on your system.

BEST PRACTICE To use the latest update of the tutorials and tutorial assets, go to
http://www.autodesk.com/motionbuilder2013-documentation and download the
tutorials and tutorial support files to your system. If you download the tutorial
support files to a location other than theMotionBuilder default location, remember
to add this location in the Asset browser so you can access the assets via the Asset
browser. See Adding a favorite path topic in the Help under MotionBuilder Interface
| Asset browser.
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Prepare the scene

In the following procedure, you prepare the MotionBuilder scene and open
the files needed to start this tutorial.

1 From the menu bar, select File > New, then select Layout > Editing.

MotionBuilder displays a new 3D scene using the Editing layout. This
layout displays all the windows you need for your work in this tutorial.

2 Click the Tutorials folder in the Asset browser.

3 Drag the mia_runstopturn asset (mia_runstopturn.fbx file) into the Viewer
window (A), then select FBX Open > run_stop_turn180 from the
contextual menu that appears.

A model named Mia appears in the Viewer (B).

A. mia_runstopturn asset B. Mia character loaded in scene

4 Choose File > Save As.

The Save File window appears.

5 Navigate to a directory other than the default MotionBuilderTutorials
directory where you want to save the file and click Save.

The Save Options dialog box appears.

6 Click Save.

Choosing to save the file to a directory other than the default
MotionBuilderTutorials directory ensures you do not overwrite the
original .fbx file.
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7 Click in the Viewer window, then press Ctrl-R twice to switch to
Producer Left camera. Zoom out to view the entire grid.

Producer Left camera view

Modify the Character Extension animation

In the following procedure, you create an animation layer and modify the
animation of the Servo arm Character Extension.

1 Play the entire take (Ctrl-Spacebar) to view all the motion, paying
special attention to the Servo arm.

Right now, the Servo arm bounces along in front of Mia, pointing towards
the red wire-frame effector. Although this effector is parented to Mia’s
shoulder, the effector moves enough to cause the Servo arm to jump
around while Mia runs.

2 Press Ctrl-Home to go back to the beginning of the take, then play it
again to frame 40.
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Mia at frame 40

3 In the Key Controls, select AnimLayer1 from the Layer menu (A).

Key Controls A. AnimLayer1 selected

This lets you set keyframes on an animation layer while preserving the
original animation on the BaseAnimation layer.

4 Select the Mia:ServoControl effector (A) then click Zero in the Key
Controls to set a Zero keyframe (B) at frame 40.
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Frame 40 A. Mia:ServoControl effector B. Zero keyframe button

5 With the Mia:ServoControl effector still selected, go to frame 120 and
set a Zero keyframe.

Frame 120 A. Mia:ServoControl is selected B. Zero keyframe button

6 Go to frame 64.

At this frame, you are going to start modifying the animation so that
Mia raises her Servo arm.
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Frame 64

7 Do the following:
■ Click in the Viewer window and press T to activate Translation mode.

■ At the bottom of the Viewer window, set the Translation XYZ values
to 200, -30, 10 (A).

■ Set a keyframe (B).

Frame 64 A. Translation XYZ values set B. Key button

8 Go to frame 96 and do the following:
■ Set the Mia:ServoControl effector Translation XYZ values to 45, 16,

14 (A).
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■ Set a keyframe (B).

Frame 96 A. Translation XYZ Values set B. Key button

9 Go to frame 104 and do the following:
■ Set the Translation XYZ values to 35, -25, 68 (A).

■ Set a keyframe (B).

Frame 104 A. Translation XYZ Values set B. Key button
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10 Play the animation.

Now, Mia’s Servo arm raises up as she slows and turns.

Modify the head animation

In the following procedure, you use another layer to improve the animation
by making Mia turn her head as she runs, when she stops, and again just
before she turns around.

1 Go to frame 24.

At this frame, Mia’s head is pointed straight ahead in the direction she
is running. You need to modify the motion so that Mia turns her head.

Mia at frame 24

2 In the Key Controls window, select New Layer from the Layer menu (A)
to create a layer to modify the head animation.

Key Controls window A. Layer menu > New Layer option

A layer called “AnimLayer2” is added.
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3 In the Character Controls window, select the head effector (A), and
switch to Body Part keying mode (B).
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Character Controls window A. Head effector selected B. Body Part keying mode
selected
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You can use Body Part keying mode as you create animation on this
layer, since you only need to set keyframes on the head, not the entire
body.

4 In the Key Controls, click Zero to set a zero keyframe (A).

Key Controls A. Zero keyframe button

5 Go to frame 120 and set another Zero keyframe.

Frame 120A. Zero keyframe button

6 Go to frame 48 and do the following:
■ With the Head effector still selected, activate Rotation mode (click

in the Viewer window and press R).

■ Change the Rotation XYZ properties at the bottom of the Viewer
window to 35, 0, 2 (A).

■ Set a keyframe (B).
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Frame 48 A. Rotation XYZ values set B. Key button

7 Go to frame 72 and do the following:
■ Set the Rotation XYZ values to 42, 0, -5 (A).

■ Set a keyframe (B).

Frame 72 A. Rotation XYZ values set B. Key button
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8 Go to frame 84 and do the following:
■ Set the Rotation XYZ values to 30, -5, 0 (A).

■ Set a keyframe (B).

Frame 84 A. Rotation XYZ values set B. Key button

9 Deselect the Head effector, and play your animation.

Mia’s head turns as she runs.

Play the resulting take

Play the take and observe your animation.

The animation of the Servo arm rising up and the head turning are merged
with the original animation of Mia running and turning around.

Summary

In this tutorial, you modified original animation by setting keyframes on two
layers. In the next tutorial, Creating a Loop (page 90), you learn how to create
a walk cycle using the Story window.
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Creating a Loop
This tutorial guides you through the procedures necessary to animate a
character and create a walk cycle using the Story window.

This tutorial shows you how to:

■ Prepare the scene (page 90)

■ Create a Character track (page 91)

■ Create poses (page 96)

■ Match clips (page 100)

■ Process the clips (page 104)

■ Test the walk cycle (page 107)

The following assets are required for this tutorial:

■ mia_servo.fbx

■ walkaround.fbx

NOTE The tutorial assets can be found in the Asset Browser under the Tutorials
folder and in the MotionBuilder directory on your system.

BEST PRACTICE To use the latest update of the tutorials and tutorial assets, go to
http://www.autodesk.com/motionbuilder2013-documentation and download the
tutorials and tutorial support files to your system. If you download the tutorial
support files to a location other than theMotionBuilder default location, remember
to add this location in the Asset browser so you can access the assets via the Asset
browser. See Adding a favorite path topic in the Help under MotionBuilder Interface
| Asset browser.

Prepare the scene

In the following procedure, you prepare the MotionBuilder scene and open
the files needed to start this tutorial.

1 From the menu bar, select File > New, then select Layout > Story (or press
Ctrl-Shift-5).

MotionBuilder displays a new 3D scene using the Story layout. This
layout displays all the windows you need for your work in this tutorial.
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2 Click the Tutorials folder in the Asset browser.

3 Drag the mia_servo asset (mia_servo.fbx file) into the Viewer window then
select FBX Open > No Animation.

The mia_servo asset appears in the Viewer window, in the T-stance.

Mia with servo shown in the T-stance

4 Choose File > Save As.

The Save File window appears.

5 Navigate to a directory other than the default MotionBuilderTutorials
directory where you want to save the file and click Save.

The Save Options dialog box appears.

6 Click Save.

Choosing to save the file to a directory other than the default
MotionBuilderTutorials directory ensures you do not overwrite the
original .fbx file.

Create a Character track

In the following procedure, you create a Character track in the Story window,
define the character affected by the track, and add some animation.

1 In the Story window, right-click in the Action Track list (A) and select
Insert > Character Animation Track from the contextual menu.
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Story window A. Action Track list

A Character Animation track is added (A).

Story window A. Character track

2 Select Mia in the track’s Character menu (A).

Story window A. Mia selected in the Character menu.

3 Drag walkaround.fbx from the Asset browser to the Character track.
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walkaround.fbx asset being dragged into the Character track.

4 Drag the clip so that it begins at frame 0. The clip should end at frame
78.

Clip dragged to frame 0 on the Character track .

NOTE

You can Ctrl-drag to zoom and Shift-drag to pan in the Character track.

5 Play the animation (Ctrl-Spacebar).

At frame 0, the character’s right foot is in front and the left foot is in
back. At frame 78, Mia is turning. If you were to loop the animation at
this point, there would be a jump in the walk cycle.

6 Go to frame 32. At this frame, Mia’s right foot is flat on the ground and
her left foot is slightly lifted.

Change your camera view so you can see Mia from the front.
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Mia at frame 32.

7 With the clip still selected, click the Razor button (A).

Story window A. Razor button

The clip is sliced in two at frame 32.

The original clip is sliced in two.

8 Go to frame 60. At this frame, Mia is in almost the same pose as she was
at frame 32.
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Mia at frame 60.

9 Select the second clip if it is not already selected, then click the Razor
button.

The second clip is sliced at frame 60, and you now have three clips.

Three clips in the Character track

10 Ctrl-click the first clip, so that the first and third clips are selected, then
press Delete, as you only need the middle clip.

11 Drag the remaining clip to start at frame 0.

The clip starts at frame 0 and ends at frame 28.
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Create poses

1 Go to frame 0 (Ctrl-Home).

2 In the Character Controls window, make sure Mia is selected in the
Current Character menu (A), then select the Hips effector (B).
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Character Controls window A. Hips effector selected

3 In the Asset Settings window, click the Pose Controls tab.
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4 In the Pose Controls, click Create (A), then expand the Poses folder to
see the pose you created, called “Mia Pose” by default (B).

Pose Controls window A. Create button B. Mia Pose

5 Go to frame 28 and do the following:
■ In the Story window, activate the Accept keys option (A) in the

Character track. You can only paste poses on a track when the
Animate option is active.

Character track A. Animate option activated.

■ In the Character Controls window, right-click the Right Ankle effector
(A) and select RightAnkleEffector from the menu that appears.
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■ In the Pose Controls window, click Paste (A).
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Pose Controls window A. Paste button

A one-frame clip appears on the Character track at frame 28.

This clip contains the data of the pose you pasted. Now Mia starts and
stops walking with exactly the same pose.

Character track A. New clip at frame 28.

6 Jog (J-drag) or use Ctrl-Left Arrow and Ctrl-Right Arrow to step
frame-by-frame through the animation very slowly. Though the
animation begins and ends with the same pose, there is a slight jump
between the clips. In the following procedure, you remove the jump.

Match clips

In the following procedure, you match and blend the two clips to remove the
jump in the animation.

1 Click in an empty space below the track, and press A to zoom in on the
clips.

2 Select the second clip.

Character track A. Second clip selected.
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3 Make sure the Right Ankle effector is still selected in the Character
Controls window (A).
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Character Controls window A. Right Ankle effector

4 In the Story window, click the Match Options button (A).
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Story window A. Match Options button

5 In the Match Options dialog box that appears, click OK (A).

Match Options dialog box A. OK button

6 Select Window > Asset Settings from the MotionBuilder menu bar, then
double-click the second clip in the Story window to display its settings.

7 In the Asset Settings, set a value of 23 in the In field (A).
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Asset Settings window A. In point set to frame 29.

8 Enter value of 29 in the Out field in the Asset Settings window.

9 The second clip now starts at frame 23, and cross-blends with the first
clip to end at frame 29. This blend creates a slightly smoother transition
between the clips.

The second clip starts at frame 23 and ends at frame 29.

10 Play the animation. Mia walks, starting and ending with the same pose.

Process the clips

In the following procedure, you process the two clips to save them as a single
result clip. Later, you use this new clip to animate a different character.

1 Right-click on the Character track near the Character name and select
Frame Start/End from the contextual menu (A). The time range is resized
to fit the length of the clips.
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Character track contextual menu A. Frame Start/End option selected.

2 Right-click the Character track again and select Process Track/Subtracks
To New Clip from the contextual menu (A).

Character track Contextual menu A. Process Tracks/Subtracks To New Clip option

3 In the Process Track and Subtrack dialog that appears, change the Process
Rate to 24 FPS. Click OK.
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Process Track and Subtracks dialog box

4 In the Save Clip dialog box that appears, save your new clip as
mia_walk_cycle.fbx.

You need the saved clip to complete this tutorial.

Save Clip dialog box

In the Story window, a second Character track appears containing the
new mia_walk_cycle.fbx clip (A).

Story window A. New mia_walk_cycle.fbx clip
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Test the walk cycle

In the following procedure, you test the new walk cycle clip to see if it loops
smoothly.

1 Make sure that the Loop/Scale option is set to Loop, as shown in (A).

Story window A. Loop/Scale option is set to Loop.

2 Zoom out on the Character tracks, then stretch the end of the
mia_walk_cycle clip to frame 116 (A). The clip loops four times.

Character tracks A. Clip stretched to frame 116.

3 Right-click any Character track and select Frame Start/End from the
contextual menu.

4 Click the first Character track’s Mute button (A) to disable the track.

Character tracks A. Mute selected

5 Play the animation. Mia walks smoothly for 140 frames.
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Summary

In this tutorial, you took a short clip of animation and turned it into a looping
walk cycle. In the next tutorial, Manipulating Clips (page 108), you learn how
to edit character animation by modifying clips.

Manipulating Clips
This tutorial guides you through the procedures necessary to modify character
animation by manipulating clips.

This tutorial shows you how to:

■ Prepare the scene (page 109)

■ Create a turn (page 110)

■ Blend two clips (page 114)

■ Add a clip (page 115)

■ Match clips (page 116)

The following assets are required for this tutorial:

■ mia_story.fbx

■ run_boom.fbx

NOTE The tutorial assets can be found in the Asset Browser under the Tutorials
folder and in the MotionBuilder directory on your system.

BEST PRACTICE To use the latest update of the tutorials and tutorial assets, go to
http://www.autodesk.com/motionbuilder2013-documentation and download the
tutorials and tutorial support files to your system. If you download the tutorial
support files to a location other than theMotionBuilder default location, remember
to add this location in the Asset browser so you can access the assets via the Asset
browser. See Adding a favorite path topic in the Help under MotionBuilder Interface
| Asset browser.
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Prepare the scene

In the following procedure, you prepare the MotionBuilder scene and open
the files needed to start this tutorial.

1 From the menu bar, select File > New, then select Layout > Editing (or
press Ctrl-Shift-3).

MotionBuilder displays a new scene using the Editing layout. This layout
displays all the windows you need for your work in this tutorial.

2 Click the Tutorials folder in the Asset browser.

3 Drag the mia_story asset (mia_story.fbx file) into the Viewer window (A),
then select FBX Open > All Takes.

A model named Mia appears in the Viewer window (B) and Mia is selected
in the track’s Character menu.

NOTE You may need to zoom out in the Viewer window to see Mia at the
far end of the grid.

A.  mia_story asset B. Mia model loaded in scene

In the Story window, there is a track with a clip called Clip_Run_Loop.

4 Choose File > Save As.

The Save File window appears.

5 Navigate to a directory other than the default MotionBuilderTutorials
directory where you want to save the file and click Save.

Manipulating Clips | 109



The Save Options dialog box appears.

6 Click Save.

Choosing to save the file to a directory other than the default
MotionBuilderTutorials directory ensures you do not overwrite the
original .fbx file.

7 In the Story window, activate the Story button (A) if it is not already
turned on, then click on the Character track (B) and press A to frame
the clip.

Story window A. Story button selected B. Character track showing one clip

8 Play the animation (Ctrl-Spacebar). You may need to zoom out in the
Viewer window to see all of the animation.

Create a turn

In the following procedure, you slice a clip in two, then rotate a ghost clip
vector to make Mia turn as she runs.

1 Go to frame 11.

At this frame, Mia’s left foot is flat on the ground as shown in the
following figure.
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Mia at frame 11.

2 In the Story window, select the clip (B), and click the Razor button (A)
as shown in the following figure.

Story window A. Razor button B. Selected clip

The clip is sliced into two clips at frame 11(A).

Character track A. Clip sliced in two at the current time

3 Switch to the X-Ray display mode in the Viewer window, then make
sure the Show/Hide Ghost option in the Character track (A) is activated
as shown in the following figure.
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Character track A. Show/Hide Ghost option

4 Go to frame 0 (Ctrl-Home).

When the Show/Hide Ghost option is active, the ghosts display in the
Viewer window as shown in the following figure.

The clip vector ghosts represent the start and end of each clip. For each
clip, there is one clip vector ghost that you can select and manipulate
(B and C).

Mia model at frame 0  A.  Model ghost B. First clip’s ghost clip vector C. Second
clip’s ghost clip vector

5 In the Story window, select the second clip if it is not still selected (A).

Character track A. The second clip is selected

The ghost clip vector of the selected clip is also selected in the Viewer
window.

6 Click in the Viewer window and press the keyboard shortcut R.

Rotation rings appear at one end of the selected clip vector ghost, as
shown in the following figure.

If the rings do not appear at the same point of the clip vector,
double-click the clip vector’s In point as shown to select it.
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A. Rotation rings B. Second ghost clip vector’s In point

7 In the Viewer window, enter a value of -70 in the Rotation Y-axis field
as shown in the following figure (A).

The clip vector turns to Mia’s right (B).

TIP

You can manually rotate the clip vector by dragging the green rotation
ring.
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A. Rotation Y-axis field B. Ghost clip vector is rotated

8 J-drag in the Viewer window to jog through frames 8 to 16 slowly.

Mia turns as she runs, but her foot jumps slightly at frame 11. You need
to blend the clips to remove the jump.

Blend two clips

In the following procedure, you blend two clips to remove a jump in animation
that occurs when Mia turns.

1 Make sure the Loop option (A) is active in the Story window.

Story window A. Loop/Scale option set to Loop
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2 Double-click the first clip to display its settings in the Asset Settings
window located at the bottom right of the user interface.

3 In the Asset Settings, set a value of 15 in the Out field (A).

Asset Settings window A. Out field set to 15

The first clip overlaps the second clip, creating a cross-blend as shown
in the following figure (A).

Character track A. Clip cross-blend

4 Play the animation.

There is no longer a jump at frame 11.

Add a clip

In the following procedure, you add a clip to the Character track in the Story
window.

1 Ctrl-drag and Shift-drag in an empty space beneath the Character track
to zoom out and make room next to the clips.

2 From the Tutorials folder in the Asset browser, drag the run_boom.fbx
file onto an empty part of the Character track, to the right of the clips,
as shown in the following figure.
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run_boom.fbx clip added to Character track

3 Drag the clip so that it begins at frame 36.

NOTE

It should rest against the end of the second clip, as shown in the
following figure.

New clip begins at frame 36

4 Deselect the new clip, then right-click the Character track and select
Frame Start/End from the contextual menu.

5 Play the animation (Ctrl-Spacebar).

Mia runs, turns, there is a jump in the animation, then Mia is thrown
forward as if propelled by an explosion.

Match clips

In the following procedure, you match the last clip to the previous clip to
remove the jump in the animation.

1 Go to frame 0.

2 In the Viewer window, switch to the Schematic view and select the
Mia:RightFoot node (A).

This node represents Mia’s right foot and will be used as the matching
object.
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Schematic view A. Mia:RightFoot node selected

3 Switch back to the Producer Perspective camera view.

4 In the Story window, select the third clip (A), then click the Match
Options button (B).

Story window A. Third clip selected B. Match Options button

5 In the Match Options dialog box that appears, if not selected, select the
Mia:RightFoot in the Match Object menu (A), and select To Previous
Clip (B) and Between Previous Clip and Selected Clip (C) as shown in
the following figure.
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Match Options dialog box A. Match Object B. Match Clip C. Match Time

The Translation and Rotation options are already selected.

6 Click OK.

The last clip vector moves to match the previous clip.

7 Deselect Mia:RightFoot (Shift-D).

8 Play the animation.

Mia runs, turns, then is thrown forward. The jump in the animation is
gone.

Summary

In this tutorial, you sliced a clip of running animation in two and rotated one
clip vector ghost to make the character turn while running. Then you added
another clip with different animation and blended all three clips together in
one seamless animation sequence.

In the next tutorial, (Importing 3ds Max Files into MotionBuilder (page 119)),
you export 3ds Max skeletons and a 3ds Max character into MotionBuilder,
add a Control rig, characterize the skeletons and Character, and animate the
character in MotionBuilder, and then export a Character and animation back
to 3ds Max.
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Importing 3ds Max Files into MotionBuilder
This tutorial shows you how to export a character created in 3ds Max, import
it to MotionBuilder, and then to export it back to 3ds Max as a fully-editable
animated character.

NOTE  This tutorial was written using the latest version of 3ds Max, MotionBuilder,
and 3ds Max FBX plug-ins software products available at the time.

The tutorial covers the following three kinds of animatable skeletons that
originate in 3ds Max. The tutorial also shows you how to bring these skeletons
into MotionBuilder for animation using the FBX format.
■ Conventional 3ds Max bone system skeletons

■ Biped system skeletons

■ Skinned characters with skeletons

You can single out the Send to 3ds Max procedure that addresses your needs
or complete the whole tutorial to get a well-rounded view of the interaction
between MotionBuilder and 3ds Max.

This set of tutorials shows you how to:

■ Export two kinds of 3ds Max skeletons and a 3ds Max character into
MotionBuilder

■ Add a Control rig and characterize the skeletons and character in
MotionBuilder

■ Animate the character in MotionBuilder and prepare it for import to 3ds
Max

Following are the major topics in this tutorial:
■ Requirements (page 120)

■ 3ds Max skeletons (page 121)

■ 3ds Max Bipeds (page 133)

■ 3ds Max Characters (page 146)

■ Animating a 3ds Max Character in MotionBuilder (page 153)
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NOTE  Although the procedures in this tutorial use the MotionBuilder keyboard
shortcuts, you can use 3ds Max keyboard shortcuts in MotionBuilder if you select
Settings > Keyboard Configuration > 3ds Max from the MotionBuilder menu bar.
See the MotionBuilder 3ds Max keyboard shortcuts in the Keyboard Shortcuts
chapter of the MotionBuilder Help.

NOTE MotionBuilder adopts the native frame rate used in files imported from
other software. In this tutorial, you import a skeleton from 3ds Max, and
MotionBuilder changes its default frame rate of 24 frames per second (FPS) to
match the frame rate of the 3ds Max file (30 FPS). When you finish this tutorial,
MotionBuilder will retain this new frame rate (30 FPS) as the default unless you
restore it to its native frame rate of 24 FPS.

For example, if you create a 90-frame animation for video, using an NTSC
frame rate of 30 frames per second, the result will be three seconds of
animation. If you later need to output to PAL video (at 25 frames per second),
you can switch to the PAL frame rate. The 90 frames are converted to 75, and
produce the same total animation time with a different number of frames.
You can later switch back to NTSC frame rate to restore the original 90 frames
of animation.

You can change the frame rate for your MotionBuilder output at any time,
outputting the correct number of frames to maintain the correct playback
speed for your animation, without losing animation data.

Requirements

To complete this tutorial, you need the current versions of 3ds Max, and
MotionBuilder installed on your system.

If you do not have the current version of 3ds Max, you can download a trial
version of the software product from the Autodesk web site at: ht-
tp://www.autodesk.com/3dsmax.

The following assets are required for this tutorial:

■ skeletons.max

■ bone_skeleton.FBX

■ bone_skeleton_characterized.FBX

■ biped.FBX

■ Pepe.max
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■ Pepe.FBX

■ Pepe_rigged.FBX

■ IceSlip.fbx

■ Pepe_Mocap.FBX

■ Pepe_keyanim.FBX

BEST PRACTICE To use the latest update of the tutorials and tutorial assets, go to
http://www.autodesk.com/motionbuilder2013-documentation and download the
tutorials and tutorial support files to your system. If you download the tutorial
support files to a location other than theMotionBuilder default location, remember
to add this location in the Asset browser so you can access the assets via the Asset
browser. See Adding a favorite path topic in the Help under MotionBuilder Interface
| Asset browser.

3ds Max skeletons

This tutorial shows you how to export a conventional 3ds Max bone system
skeleton data to FBX format, import to MotionBuilder, and then characterize
it so you can animate it.

The following assets are required for this tutorial:

■ skeletons.max

■ bone_skeleton.FBX

■ bone_skeleton_characterized.FBX

NOTE The tutorial assets can be found in the Asset Browser under the Tutorials
folder and in the MotionBuilder directory on your system.

BEST PRACTICE To use the latest update of the tutorials and tutorial assets, go to
http://www.autodesk.com/motionbuilder2013-documentation and download the
tutorials and tutorial support files to your system. If you download the tutorial
support files to a location other than theMotionBuilder default location, remember
to add this location in the Asset browser so you can access the assets via the Asset
browser. See Adding a favorite path topic in the Help under MotionBuilder Interface
| Asset browser.
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Export and characterize a 3ds Max skeleton in Motion-
Builder

In the following procedure, you export a conventional 3ds Max bone system
skeleton and use the 3ds Max Send To feature to open it in MotionBuilder for
animation.

NOTE This tutorial uses the MotionBuilder and 3ds Max single-step interoperability
workflows, using the Send to 3ds Max menu option. For legacy workflow, refer
to the topic Exporting 3ds Max skeletons to MotionBuilder in the MotionBuilder
Help.

To export a skeleton in FBX format:

1 Launch 3ds Max.

2 From the Application menu, select Open > Open.

3 In the Open File dialog box, navigate to the MotionBuilder root directory
and in the Tutorials folder, open the skeletons.max scene file.
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NOTE  If the File Load: Gamma & LUT Settings Mismatch dialog appears,
select Adopt the File’s Gamma and LUT Settings and click OK.

File Load: Gamma & LUT Settings Mismatch
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NOTE If the File Load: Units Mismatch dialog appears, select Adopt the File's
Unit Scale and click OK.

File Load: Units Mistmatch

The skeletons.max file opens, displaying two skeletons. Skeleton A is
created with the conventional 3ds Max bone system, and skeleton B is
created with the 3ds Max Biped creation option.

Two 3ds Max skeletons A. Conventional 3ds Max bone system skeleton B. 3ds
Max Biped skeleton

The skeletons are positioned in a “T” stance, the pose used by animators
for skinning.

NOTE  Always place your characters in the “T” stance before exporting to
MotionBuilder.
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To learn how to export skeletons created with the 3ds Max biped creation
option, see Create and export a 3ds Max biped (page 133).

4 Drag across all of Skeleton A to region-select it.

Biped oriented in a T-stance

The skeleton will characterize perfectly because its bones are named
according to MotionBuilder conventions, and is in a T-stance.

See MotionBuilder Help > Animating Characters > Character setup >
Skeletons > Bone naming conventions section.

5 From the Application menu, select Send to > Send to MotionBuilder >
Send as New Scene. MotionBuilder launches.

NOTE If you have a version earlier than version 2012 of MotionBuilder and
3ds Max, you do not have access to the Send to option. Refer to the
MotionBuilder Help.

The 3ds Max bone system skeleton loads into MotionBuilder.
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 3ds Max skeleton displayed in the Viewer
window

To characterize your skeleton:

1 In the MotionBuilder Asset browser, expand Templates > Characters and
drag the Character asset onto one of the skeleton bones.

The bone lights up when the asset makes contact with it.

2 Click Characterize in the menu that appears.

The following dialog box reminds you that the character must be in a
“T” stance and face in the positive Z axis (the equivalent of the negative
Y axis that you converted when exporting the .max file into the FBX file
format).
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3 Click Biped in the Character dialog box that appears to indicate the type
of rigging to apply to the character.

Character stance dialog box

The skeleton is now characterized, which means that it is ready to accept
a Control rig you can animate.

4  From the Character Controls window > Character
menu, select Character.

5 From the Character Controls window > Source menu, select Control Rig.

(You can also select  > Create > Control rig, but setting the rig as
a Source makes the skeleton an active character in the scene.)
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Character Controls Source menu
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You must use the Control Rig Input setting if you intend to keyframe
your character.

The Create Control Rig dialog box appears.

6 Click FK/IK.

FK/IK is the method commonly used to animate characters.

This setting activates the Control rig and the Character Controls
Character representation. The Character representation is an image of a
human form meant to represent the biped skeleton. It contains all the
effectors you need to animate the Control rig, as shown in the following
figure.

Skeleton with FK/IK Control rig

Your character is now rigged and ready to receive animation.

7 In the Character Controls toolbar, click the Full Body icon.
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Character controls A. Full Body icon

This lets you move the body using the entire Control rig.
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8 On the Character representation, select the Right Wrist effector.

Character representation A. Right Wrist effector selected

9 Click in the Viewer window and press T.

The transformation handles appear.

10 Translate (or move) the hand down as shown in the following figure.
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Notice as you move the hand, the arm extends and the rest of the body
follows in a natural movement. You can now transform the characterized
skeleton.

NOTE If you wish to see the result of this procedure, open the
bone_skeleton_characterized.FBX file.

3ds Max Bipeds

This tutorial shows you how to create and export biped skeletons created with
the 3ds Max Biped system to MotionBuilder for animation.

The following is the result asset for this tutorial:

■ biped.FBX

NOTE The tutorial assets can be found in the Asset Browser under the Tutorials
folder and in the MotionBuilder directory on your system.

BEST PRACTICE To use the latest update of the tutorials and tutorial assets, go to
http://www.autodesk.com/motionbuilder2013-documentation and download the
tutorials and tutorial support files to your system. If you download the tutorial
support files to a location other than theMotionBuilder default location, remember
to add this location in the Asset browser so you can access the assets via the Asset
browser. See Adding a favorite path topic in the Help under MotionBuilder Interface
| Asset browser.

Create and export a 3ds Max biped

In the following procedure you create a biped in 3ds Max for export to
MotionBuilder.

NOTE This tutorial uses the MotionBuilder and 3ds Max single-step interoperability
workflows, using the Send to 3ds Max menu option. For legacy workflow, refer
to the Exporting 3ds Max bipeds to MotionBuilder topic in the MotionBuilder Help.

To create a biped in 3ds Max for export to MotionBuilder:

1 Launch the 3ds Max software.

2 In the Application menu, choose Reset to clear the scene/settings.
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3 On the Create panel, select Systems.

Systems selected in Create panel

4 On the Object Type rollout, click Biped.

5 In the perspective viewport, click and drag to create a biped object.

NOTE  The size of the biped is not important.
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3ds Max biped object

6 Open the Motion command panel.

7 With Bip001 still selected, go to the Motion panel > Biped rollout and
click Figure Mode.

Figure Mode selected

8 In the Structure rollout > Body Type group > Neck Links spinner box,
enter 4.

Importing 3ds Max Files into MotionBuilder | 135



Biped with ten neck links

The 3ds Max biped object now has four neck links as shown in the
following figure.

3ds Max biped object with four neck links

9 In the Spine links spinner box, enter 10, in the Fingers spinner box, enter
5, in the Finger Links spinner box, enter 3, in the Toes spinner box, enter
5 and in the Toe Links spinner box, enter 3.

10 Go to the Motion panel > Biped rollout and click Figure Mode again to
exit the input mode.

11 From the Application menu, select Send to > Send to MotionBuilder >
Send as New Scene. MotionBuilder launches.

12 In MotionBuilder, position your cursor anywhere in the Viewer window
and press A to frame all of the biped skeleton.
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3ds Max biped skeleton imported in MotionBuilder

13 In the Select File To Export dialog box, navigate to a directory other than
the default MotionBuilderTutorials directory where you want to save the
file and name your file My_biped. Choose Autodesk (*FBX) as the file type,
and click Save.

NOTE

If you do not specify a location, the file is automatically saved in the
FBX file format to the 3ds Max Export folder.

Now that your biped is saved as an FBX file, you can use it in the next tutorial
(Characterize a 3ds Max biped in MotionBuilder (page 137)) to characterize it
in MotionBuilder.

NOTE If you wish to see the result of this procedure, open the biped.FBX file.

Characterize a 3ds Max biped in MotionBuilder

In the following procedure, you characterize in MotionBuilder the 3ds Max
biped (My_biped.FBX) you saved in the previous procedure (Create and export
a 3ds Max biped (page 133)). Characterization assigns a Control rig to the biped
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bones and is the name MotionBuilder uses for the process of rigging a biped
skeleton.

NOTE If you did not perform the previous procedure, use the biped.FBX file in
the Tutorials folder located in the MotionBuilder directory on your system.

To characterize your 3ds Max biped:

1 Select the a shoulder (Upperarm) node on the skeleton, press R to enter
Rotation mode and rotate the skeleton's arm until it is parallel with the
grid. Do the same with the other shoulder.

Rotate the skeleton's shoulders into a T-stance.

The skeleton is now in a T-stance.

2 In the Asset browser, expand Templates > Characters and drag the 3ds
Max Biped Template on top of the skeleton.

Applying the 3ds Max Biped Template asset to the biped skeleton
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The 3ds Max Biped template is specially designed for bipeds created in
3ds Max as they have a naming structure that MotionBuilder does not
recognize.

3 Click Characterize in the menu that appears.

The biped skeleton is now characterized.

4  In the Character Controls window, click the
Definition tab.
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Character representation shows that the characterization is correct
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The Character representation displays green if the characterization is
correct, yellow if potential problems are detected, and red if there is an
element of the skeleton matching that is incorrect.

The next step is to add a Control rig so you can animate it.

5  From the Character Controls window > Source
menu, select Control Rig.
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Character Controls Source menu

The Create Contril Rig dialog box appears.
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6 In the Create Control Rig dialog box, click FK/IK.

FK/IK is the method commonly used to animate characters.

The Control Rig setting activates the Character representation and
displays the Control rig effectors on the biped in the Viewer window
(B).

The Character representation is an image of a human form that represents
the biped skeleton. It contains all the effectors you need to animate its
Control rig. The biped is now rigged and ready to receive animation.

7 In the Character Controls toolbar, click the Full Body icon. This lets you
move the body using the entire Control rig.
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Character controls A.Full Body icon

8 On the Character representation, select the Right Wrist effector.
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Character representation A.Right Wrist effector selected

9 Click in the Viewer window and press T.

The transformation handles appear.

10 Translate (or move) the hand down as shown in the following figure.

Notice as you move the hand, the arm extends and the rest of the body
follows in a natural movement.

You can now transform and animate the characterized 3ds Max biped
in MotionBuilder. See Animating a 3ds Max Character in MotionBuilder
(page 153).
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3ds Max Characters

The following tutorial shows you how to export a character with a skeleton
created and skinned in 3ds Max to the FBX file format, import to
MotionBuilder, and then characterize it so you can animate it.

Since a character is a skeleton with skin and textures, the procedure is similar
to the procedure shown in the tutorials for exporting 3ds Max skeletons and
biped skeletons.

The following asset is required for this tutorial:

■ Pepe.max

The following assets are the result assets for this tutorial:

■ Pepe.FBX

■ Pepe_rigged.FBX

NOTE The tutorial assets can be found in the Asset Browser under the Tutorials
folder and in the MotionBuilder directory on your system.

BEST PRACTICE To use the latest update of the tutorials and tutorial assets, go to
http://www.autodesk.com/motionbuilder2013-documentation and download the
tutorials and tutorial support files to your system. If you download the tutorial
support files to a location other than theMotionBuilder default location, remember
to add this location in the Asset browser so you can access the assets via the Asset
browser. See Adding a favorite path topic in the Help under MotionBuilder Interface
| Asset browser.

Export a 3ds Max character

The following procedure shows you how to export a 3ds Max character to
MotionBuilder.

NOTE This tutorial uses the MotionBuilder and 3ds Max single-step interoperability
workflows, using the Send to 3ds Max  menu option. For the legacy workflow,
refer to the Export a 3ds Max character topic in the MotionBuilder Help.
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To export the 3ds Max Pepe character:

1 Launch the 3ds Max software.

2 In the Application menu, choose Reset to clear the scene/settings.

3 Select Open and open the Pepe.max scene file located in the
MotionBuilder root directory under the Tutorials folder.

The Pepe.max scene file opens, displaying a biped skeleton inside a mesh.

3ds Max biped skeleton inside a mesh

4 From the Application menu, select Send to > Send to MotionBuilder >
Send as New Scene.
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NOTE If you have a pre-2012 version of MotionBuilder and 3ds Max, you
do not have access to the Send to option. Refer to the MotionBuilder
documentation.

5 MotionBuilder launches and the Pepe character appears in the Viewer
window.

6 Position your cursor anywhere in the Viewer window and press A to
frame all of the character.

3ds Max Pepe character imported into MotionBuilder

7 Navigate to a directory other than the default MotionBuilderTutorials
directory and save the file as My_Pepe.

Characterize a 3ds Max Character in MotionBuilder

In the following procedure, you characterize the My_Pepe.FBX file you saved
in the previous procedure (Export a 3ds Max character (page 146)). The Pepe
character is a 3ds Max biped, with only a mesh and materials.

NOTE If you did not perform the previous procedure, you can use the Pepe.FBX
file in the Tutorials folder located in the MotionBuilder directory on your system.

To characterize your Character:

1 In the Viewer window, press Ctrl-A until you are in X-Ray mode.

X-Ray mode lets you see through the character skin to the skeleton
underneath.

2 In the Asset browser, expand Templates > Characters and drag the 3ds
Max Biped Template asset on top of the Pepe Character skeleton.
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3ds Max Biped Template asset applied to the Pepe Character skeleton

The 3ds Max Biped template is specially designed for bipeds created in
3ds Max as they have a different naming structure that the MotionBuilder
Character does not recognize automatically.

3 Click Characterize in the menu that appears.

4  From the Character Controls window > Source
menu, select Control Rig.
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You must use the Control Rig Input setting if you intend use keyframe
animation on your biped.
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5 In the Create Control Rig dialog box, click FK/IK.

Click FK/IK

FK/IK is the method commonly used to animate characters.

This setting activates the Control rig and the Character representation.
The Character representation is an image of a human form, meant to
represent the character’s skeleton. It contains all the effectors you need
to animate its Control rig. The biped is now rigged and ready to receive
animation.

The Control Rig effectors appear on the biped as shown in the following
figure.

6 Make sure that the Full Body mode (  ) is selected in the Character
Controls toolbar.

Activating Full Body mode lets you control the entire rig, not a body
part.

7 On the Character representation, select the Right Wrist effector.
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Right Wrist effector selected

8 Click in the Viewer window and press T.

The transformation handles display.

9 Translate (or move) the hand down as shown in the following figure.

Notice as you move the hand, the arm extends and the rest of the body
follows in a natural movement.

You can now animate your character with motion capture and key frame
animation.

10 Navigate to a directory other than the default MotionBuilderTutorials
directory and save the file as My_Pepe_rigged

NOTE You can use this file for the next tutorial or you can use the Pepe_rigged.FBX
file in the Tutorials folder located in the MotionBuilder root directory on your
system.

See Animating a 3ds Max Character in MotionBuilder (page 153).
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Animating a 3ds Max Character in MotionBuild-
er

You can animate characters in MotionBuilder two ways: by setting keyframes
manually, or using motion capture data. The following tutorials show you
how to animate the 3ds Max Pepe character you imported in the 3ds Max
Characters (page 146) section.

If you did not perform the previous procedures in section Import and charac-
terize a 3ds Max Character in MotionBuilder (page 148), you can use the
Pepe_rigged.FBX file in the Tutorials folder located in the MotionBuilder root
directory on your system.

In the first of these animation tutorials, Animate a character using motion
capture data (page 154), you animate Pepe by using one of the motion capture
files that ship with MotionBuilder. In the second tutorial, Modify character
animation with keyframes and export it to 3ds Max (page 160) you refine the
animation using keyframes and bring your edited animation back into 3ds
Max.

NOTE If you already know how to animate characters in MotionBuilder, you can
skip this section.

Following are the assets required for this tutorial:

■ Pepe_rigged.FBX

■ Iceslip.fbx

Following are the result assets for this tutorial:

■ Pepe_Mocap.FBX

■ Pepe_keyanim.FBX

NOTE The tutorial assets can be found in the Asset Browser under the Tutorials
folder and in the MotionBuilder directory on your system.
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BEST PRACTICE To use the latest update of the tutorials and tutorial assets, go to
http://www.autodesk.com/motionbuilder2013-documentation and download the
tutorials and tutorial support files to your system. If you download the tutorial
support files to a location other than theMotionBuilder default location, remember
to add this location in the Asset browser so you can access the assets via the Asset
browser. See Adding a favorite path topic in the Help under MotionBuilder Interface
| Asset browser.

If you are new to MotionBuilder, take a moment to try a few MotionBuilder
navigation techniques using the MotionBuilder keyboard shortcuts:
■ Press Ctrl-Shift and drag to orbit around the scene.

■ Ctrl-drag to zoom in and out of the scene.

■ Shift-drag to pan the scene.

Although the procedures in this tutorial use the MotionBuilder keyboard
shortcuts, you can elect to use the 3ds Max keyboard shortcuts.

See the 3ds Max keyboard shortcuts topic in the Keyboard Shortcuts chapter of
the MotionBuilder Help for a list of all the 3ds Max keyboard shortcuts.

Animate a character using motion capture data

The following procedure shows you how to use keyframe animation techniques
in MotionBuilder to refine the motion capture animation.

If you did not perform the previous procedures in section Characterize a 3ds
Max Character in MotionBuilder (page 148), you can use the Pepe_rigged.FBX
file in the MotionBuilder root directory in the Tutorials folder on your system
or the Pepe_rigged asset in the MotionBuilder Asset browser’s Tutorials folder.

To animate the Pepe character using motion capture data:

1 Launch the MotionBuilder software.

2 From the Asset browser’s Tutorials folder, drag the My_Pepe_rigged asset
(My_Pepe_rigged.FBX file) you saved in the previous procedures in section
Characterize a 3ds Max Character in MotionBuilder (page 148) into the
Viewer window .

NOTE If you did not perform the previous procedures in section Characterize
a 3ds Max Character in MotionBuilder (page 148), drag into the Viewer
window the Pepe_rigged asset (Pepe_rigged.fbx file) into the Viewer window.
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NOTE Remember to navigate to save the file to a directory other than the
default MotionBuilderTutorials directory, so that you do not override the
original .fbx file.

3 Select FBX Open > No Animation.

The Pepe character appears in the Viewer window.

Loading the file A. Pepe_rigged asset in Asset browser B. Pepe loaded in the
scene

4 Click on an empty area in the Viewer window and press A to frame all
and zoom in on the Pepe character.

5 Press Ctrl-A until you are in X-ray mode and can see Pepe’s skeleton
and Control rig.

Pepe’s Control rig shown in X-Ray mode

Importing 3ds Max Files into MotionBuilder | 155



6 Press Ctrl-Shift and drag to orbit until you can see the right side of
the Pepe character. Use the following image as a guideline.

Orbit around Pepe

7 From the Asset Browser’s Tutorials folder, select the IceSlip asset (IceSlip.fbx
file) and drag it into an empty area of the Viewer window.

8 Select FBX Merge > IceSlip.

A large yellow skeleton representing the motion capture animation now
joins Pepe in the scene.

9 Zoom out (Ctrl-drag down or left) until you can see the yellow skeleton.

Pepe with skeleton containing motion capture data

10 Choose 30 fps from the drop down menu (B) on the right side of the
Transport Controls.

11 In the Transport Controls, click Play (A) to view the yellow skeleton’s
IceSlip animation.
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Transport Controls A. Play button B. 30 fps selected

12  In the Character Controls, make sure PEPE is
displayed in the character list. From the Character Controls window >
Source menu, select Skeleton2, which is the name of the yellow skeleton
that contains the motion capture animation.

Importing 3ds Max Files into MotionBuilder | 157



Pepe assumes the skeleton’s stance as shown in the following figure.
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13 In the Transport Controls, drag the Timeline indicator (slider bar) to
scrub the animation. You can also hold down the J key and drag left or
right in the Viewer window.

The skeleton’s animation now drives the Pepe character.

14 Press Ctrl-A until only Pepe is visible, then go to frame 92 and zoom
in on the Pepe character.

15 Press Ctrl-Shift and drag to orbit Pepe.

If you look carefully, you will notice that one of Pepe’s hands passes
though his face.

Unwanted hand movement from the motion capture

16 Scrub the animation a few times if you cannot see the problem.

The animation that drives Pepe’s bone movement is based on a skeleton
that has a very different physiology. For example, Pepe’s head, hands,
and feet are much larger than the skeleton, while Pepe’s shoulders are
much smaller than the skeleton’s shoulder.
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17 Save the file as My_Pepe_Mocap.FBX.

You can use this file for the next tutorial where you add keyframes to
correct Pepe’s hand movement.

The next tutorial also shows you how to export the modified character
back to 3ds Max.

Modify character animation with keyframes and export
it to 3ds Max

In MotionBuilder, you can animate characters by setting keyframes manually.
This is useful for creating original animation or making changes to motion
capture animation.

In the following procedure, you use key frame animation to refine motion
capture animation and then export your edited animation and the character
back to 3ds Max.

If you already know how to keyframe characters in MotionBuilder, you can
skip to step 21 and export your character to 3ds Max.

NOTE This tutorial uses the MotionBuilder and 3ds Max single-step interoperability
workflows, using the Send to 3ds Max menu option. If you do not have the
2012 or 2013 versions of these products, refer to the MotionBuilder Help.

To fine-tune Motion Capture animation with keyframing:

1 In MotionBuilder, open your result My_Pepe_Mocap.FBX file from the
previous procedure (Animate a character using motion capture data (page
154)) to apply the motion capture data to Pepe.

NOTE If you did not complete the previous procedure, open the
Pepe_Mocap.FBX file.

NOTE Remember to navigate to save the file to a directory other than the
default MotionBuilderTutorials directory, so that you do not override the
original .fbx file.

Press Ctrl-A until only Pepe is visible.

2 On the Character Representation of the Character Controls, click the
Right Wrist effector.
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Right Wrist effector selected

3 Click in the Viewer window and press T.

The transformation handles do not display.

4 Try to move Pepe’s hand.

Nothing happens because Pepe’s animation is controlled by the skeleton,
not the Control rig. Before you can keyframe Pepe’s motion capture
animation, you must plot (or bake) the skeleton animation onto the
Pepe character Control rig.

5  From the Character Controls menu button, select
Bake (Plot) > Bake (plot) To Control Rig.
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The Bake (plot) to Control Rig command creates a key at every frame at
the base layer (or BaseAnimation layer) of the animation track, making
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edits difficult. (You can see these keyframes in the Transport controls if
you select Pepe’s wrist effector.)

You can now edit the Pepe character using Pepe’s Control rig.

6 In the Key Controls, click the Layer menu and select AnimLayer1.

AnimLayer1 selected for adding keyframes

Selecting another layer lets you edit the animation while preserving the
original animation on the BaseAnimation layer. When you select
AnimaLayer1, the timeline hides the keyframes on the BaseAnimation
layer and shows the keyframes set on AnimLayer1 (there are none at the
moment).

7 Go to frame 80, which is the start of the problematic right hand
movement. On the Character Controls window Character Representation,
click the Right Wrist effector, then in the Key Controls, click Key.

NOTE You can also set a key by pressing K.

8 Go to frame 105, the end of the problem hand movement, and set
another key.

As you take the following steps, all character movement before the first
key and after the second key will remain unchanged. Only the character
movement between frames 80 to 105 will be modified.

9 Go to frame 94, the mid point between the two keyframes you set.

10 In the Viewer window, press T, move the hand away from Pepe’s face
on its X and Z axes as shown in the following figure, then set another
key.
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Hand moved away from Pepe’s face

11 Press J, then drag back and forth to see how the hand reacts to the keys
you just created.

12 Make any further adjustments to the hand movement as required. Make
sure to create a key after each adjustment.

13 Advance to the last frame of the animation and adjust your view until
you can see the right side of Pepe’s body.

Right hand is too close to the character’s head

14 Move Pepe’s hand away from his body and set a key.

15 Press R to use the key rotation rings to modify the hand’s position until
it rests flat on the ground, then set another key.

NOTE You may need to change your view so you can see if Pepe’s hand is
flat on the ground.
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Rotation rings used to reposition right hand

16 Play back the animation to see the result.

17 Make any further adjustments to the character body position and save
your file as My_Pepe_keyanim.FBX.

NOTE When you save your file, the animated Pepe character in your scene
is saved, but so is the yellow reference skeleton. If you want, you can delete
the skeleton from the scene, or select the Pepe character and save it to
another file for import to 3ds Max.

18 Drag across the Pepe character to select him. This way you can exclude
the yellow skeleton when you export him to 3ds Max.

19 From the MotionBuilder main menu, select File > Send To 3ds Max >
Send as New Scene.

File >Send to 3ds Max > Send as New Scene

3ds Max launches and the animated Pepe Character loads in the
Viewport.

20 Click Play in the 3ds Max Animation Controls to view the edited
MotionBuilder animation.
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Pepe's animation played back in 3ds Max

Summary

In this series of tutorials, you took different skeletons created in 3ds Max and
exported them to MotionBuilder. In MotionBuilder, you characterized the
bones, and animated the character.

Then, you made a few adjustments to perfect the motion, and exported the
Pepe character back to 3ds Max.

166 | Chapter 1   Tutorials



Index

F

FBX plug-ins
installing 8

I

installing
FBX-plug-ins 8

167 | Index



168


	Autodesk® MotionBuilder® 2013 Tutorials
	Contents
	Tutorials
	Introduction
	MotionBuilder Workflows
	Installing the latest FBX Plug-ins
	Loading and Characterizing Character Models
	Prepare the scene
	Complete the character map
	Characterize the character model

	Creating and Customizing a Control Rig
	Prepare the scene
	Create a Control rig
	Adjust the foot floor contact markers
	Adjust the hand floor contact markers
	Add Auxiliary pivots

	Creating a Character Extension
	Prepare the scene
	Connect the extra limb to the character
	Create a Character Extension

	Creating a Walk Cycle
	Prepare the scene
	Create poses
	Create animation with poses
	Mirror poses
	Play the animation

	Retargeting Character Animation
	Prepare the scene
	Save the character animation
	Create a scene
	Load character animation
	Play the animation

	Editing Character Animation
	Prepare the scene
	Modify the Character Extension animation
	Modify the head animation
	Play the resulting take

	Creating a Loop
	Prepare the scene
	Create a Character track
	Create poses
	Match clips
	Process the clips
	Test the walk cycle

	Manipulating Clips
	Prepare the scene
	Create a turn
	Blend two clips
	Add a clip
	Match clips

	Importing 3ds Max Files into MotionBuilder
	Requirements
	3ds Max skeletons
	Export and characterize a 3ds Max skeleton in MotionBuilder

	3ds Max Bipeds
	Create and export a 3ds Max biped
	Characterize a 3ds Max biped in MotionBuilder

	3ds Max Characters
	Export a 3ds Max character
	Characterize a 3ds Max Character in MotionBuilder

	Animating a 3ds Max Character in MotionBuilder
	Animate a character using motion capture data
	Modify character animation with keyframes and export it to 3ds Max


	Index






