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New Features and En-
hancements

This book provides an overview of the new features and enhancements, and changes
to the workflows in this release of the software product.

Enhancements to the Character Controls
The unified Character Controls window help to perform multiple character
setup tasks. The following figure shows the Character Controls window, in
the default mode.

A. Character Controls menu button B. Start pane C. Character menu D. Source menu

Character menu

Lets you select from a list of characters in the scene, and displays the name of
the active character.

The options in this menu are:
■ --- None --- — Displays when there are no HumanIK characters in the scene.

NOTE Select this option to return to the Start pane.

1

1



■ Character — Sets the current character to the selected HumanIK character.
Characters are listed by name.

Source menu

The Source menu:
■ Provides feedback about the type of source driving a character. This menu

is available in the Character Controls window, regardless of the
HumanIK tool that is active.

■ Updates after various operations to reflect changes to the character state.
You can also set the source type of a character by manually selecting an
option from the drop-down list.

Start pane

Quickly begin the character setup process using the Start pane in the
Character Controls window. Whether you are defining a skeleton, creating
a HumanIK skeleton, or importing a motion capture example into a scene,
this pane is designed to guide you through the setup process.

When you load a character in MotionBuilder, the Character Controls
window appears as shown below:
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A. Name of the current character B. Character Controls toolbar C. Definition and
Controls tabs D. Skeleton representation E. Go to Right Hand view F. Go to Left Hand
view G. Go to Right Foot view H. Go to Left Foot view
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As you set up your character, the previously independent HumanIK tools
appear as tabs in the consolidated Character Controls, simplifying the
character set up process.

Each tab contains a different HumanIK tool. The Skeleton, Definition, and
Controls tabs appear when you select particular options from the Start pane,
Source menu, or the Character Controls menu button.

Character Controls menu button

Menus such as Create, Define, Edit, and Add to Selection are added for
better categorization of character controls.

Create >

Provides options to create an Actor or a Control Rig.

Actor Lets you create an Actor for mapping optical motion capture data to
be used as the Source for your defined character.

Control Rig Let you create a Control rig for the current character, with IK
and FK effectors based on the defined skeletal structure. The character must
have a valid skeleton definition before you create a Control rig.

Define >

Skeleton Lets you create a definition for a skeleton. This is required, to create
a Control Rig and/or retarget animation to and from the skeleton of a character.

Edit >

Lets you edit the parameters for the Actor, skeleton definition, and control
rig.
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Actor >

Lock  Locks the current position and rotation of the selected Actor and its
Marker set. You can also turn on this option from Resources window >
Properties > Actor properties.

IK Manip Manipulates the Actor using Inverse Kinematics. By default, this
checkbox is turned off to manipulate individual body segments on the Actor.

Symmetry Edit Simultaneously scales and translates the limbs of an Actor.
By default, this checkbox is turned on. Turn off this checkbox to independently
change the size or length of a limb.

Stance Pose Positions the Actor in its default stance position. You can use
this pose to reset and modify the position of the Actor. Stance Pose only
resets rotational offsets. These offsets remain, if you translate or scale the
model.

Collapse  Rejoins any detached limb segments of an Actor without resetting
the size or stance of the Actor. This may be necessary when adding position
offsets to an Actor or when translating source markers further than their
initial definition. Some limbs may detach to reach all the markers defined by
its Marker set.

Reset Size Resets the scale of the selected Actor to its default size. If a scaling
offset affects the position of a segment, then Reset Size resets the scale of
the Actor, but leaves the segment at its new location.

Find Size  Select this option when the Actor is in a T-stance to calculate and
size each segment of the Actor based on the selected Marker set and source
markers.

Reset Pivot Points  Returns all Actor pivot points to their original positions.

Reset All  Resets the Stance Pose, Collapse, and Reset Size options,
simultaneously. This option returns the Actor to its default stance position,
reconnects any detached limb segments, and resets the scale of the Actor to
the default size.

Edit Properties Displays the properties of current character in the Properties
window. The properties shown in the Properties window are the same as
the options in the Character Settings.

Switch To Actor Lets you switch between the current character and its Actor.
If you select Switch To Actor, then the Character Controls window
changes to the Actor tab. The Switch to Actor option is enabled in the
Character menu, only when the source of the current character is an Actor.
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Definition >

Lock Definition Locks the current setup of the skeleton, as it is mapped in
the Definition tab. The skeleton definition must be valid before it can be
locked.

Rename Lets you change the name of the HumanIK character.

Delete Deletes the current HumanIK character.

Skeleton Lock Sel Locks or unlocks the skeleton for selection. When this
option is active, you cannot select the skeleton.

Skeleton Lock Trs Lets you select the skeleton, but locks the position and
rotation so that you cannot transform it.

Edit Properties Displays the properties of current character in the Properties
window. The properties shown in the Properties window are the same as
the options in the Character Settings.

Reset Properties Resets the definition and/or solving properties of current
character back to their default values. Selecting Reset Properties creates the
same result as clicking the Reset All Properties button in the Navigator
window > Character Settings pane.

Mirror Matching Enables the mirror matching mode. When this option is
turned on, the Definition tab checks for a mirror match on the opposite
side of the body for every bone that you map. For example, if you map the
L_upperLeg bone, then the tool automatically checks the skeleton for an
R_upperLeg bone and automatically maps that bone if exists. By default, mirror
matching mode supports the following pairs of substrings:

Right sideLeft side

RightLeft

R (followed by a single space)L (followed by a single space)

R_L_

_R_L

6 | Chapter 1   New Features and Enhancements



If you use a different substring in your bone naming conventions to indicate

the left and right sides of the body, then select > Edit > Definition
> Configure Mirror Matching to add your own strings.

Configure Mirror Matching Displays the Mirror Configuration window,
which lets you add pairs of strings to the list that the Definition tab checks
for mirror matching bone names. If you use a different substring in your bone
naming conventions to indicate the left and right sides of the body, then
select this option to add your substrings.

Load Skeleton Definition Displays the Load Skeleton Definition window,
which lets you map bones by applying a naming template of your own. If
your current character is locked, then clicking this option displays a message
to unlock your character.

Save Skeleton Definition Displays the Save Skeleton Definition window
to save your skeleton details.

Switch to Actor Lets you switch between the current character and its Actor.
This option is enabled in the Character menu, only when the source of the
current character is an Actor. If you select this option, then the Character
Controls window changes to the Actor Controls window.

Controls >

Rig Look Lets you select what style of Control rig effectors to work with.

Rig Look A. Box B. Stick C. Wire

Stance Pose Resets the Control Rig to its default T-stance pose.

NOTE The Stance for a biped and quadruped character is different.

Retarget Rig  Copies keyframe animation from the Control rig of the character
selected as the Source to the Control rig of the current character. Selecting
this option displays the Retargeting Options dialog box. The options in
this dialog box lets you decide whether you want to allow added keyframes
during retargeting, and whether you want to copy the Character Extension
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animation. Turning on the Add Keyframes option is recommended, if you
are concerned with retargeting your original animation as precisely as possible.
While the retargeting process copies animation nearly exactly, slight
adjustments to the data are required to compensate for differences between
the source and target characters. If you can tolerate these slight changes and
you do not want any added keyframes, then disable the Add Keyframes
option.

Rename Renames the control rig for the current character.

Delete Deletes the control rig for the current character.

FK Lock Sel Lets you lock or unlock FK markers for a selection. When activated,
you cannot select the FK markers. Disable this option to select FK markers.

FK Lock Trs Locks or unlocks FK markers for transformation. When this option
is active, you cannot transform the FK markers, although you can still select
them.

Reach Override Determines the state of the effector pinning and how your
character behaves in conjunction with Pull values during manipulation. This
option is active by default, which means that each Pull value of effector is
ignored during character manipulation. You can only view your Pull settings
when you play the animation.

To view the effects of Pull while applying transformations to your character,
disable Reach Override. Effector pinning is also disabled since the behavior
of a character is based on each Pull values of effector rather than its effector
pinning.

Reach Override is only effective in Full Body or Body Part mode.

Stiffness Override Determines how a character behaves when it is manipulated
in relation to the Stiffness values.

Stiffness Override is active by default, which means that the character does
not use the Stiffness values during character manipulation. Stiffness settings
are only applied when you play your animation.

Stiffness Override is only effective when in the Full Body or Body Part
mode.
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Rig Connect >

Attach Rig Displays the Control rig(s) in a scene. Selecting a Control rig
displays the Attach Control Rig and Reset Control Rig Hierarchy dialog
boxes.
■ Select Yes to reset the Control rig hierarchy to the default structure. For

more information about the default rig, see the Control rig hierarchy topic
in the Help.

or

■ Select No to keep the current Control rig structure, including any
reparenting or customization created previously.

If the structure of the Control rig does not match the character, then the
effectors are created or disabled, as needed, to make the Control rig fit. For
example, if you connect a Control rig from a character that contains fingers
which do no fit, then the finger effectors are disabled. If the character had an
original Control rig, then it is detached and replaced with the new Control
rig. The original Control rig is still available and listed in the Scene browser,
but no longer connected to the character.

Load UI Configuration Displays the Select new configuration file
window. It lets you select a custom configuration file to be used as the new
default layout for the Controls tab.

Update UI Configuration Reloads the Controls tab configuration file. Use
this option to view the changes made to your configuration file, after it is
loaded using the Load UI Configuration command.

Add to Selection >

IK Adds all IK effectors to your selection.

FK Adds all FK effectors to your selection.

Skeleton Adds all joint objects to your selection.

Show/Hide >

The options in this menu lets you enable or disable the display of each
component of the selected character.

IK The IK rig is an Inverse Kinematics system that lets you transform the
character using IK effectors. Manipulating a character using this system moves
the body relative to its hierarchy, similar to the way a human body reacts.
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FK The FK rig is one-half of the Control rig. It is based on the original skeleton
of your model.

Skeleton Use the skeleton to define the nodes used by the character. The
Control rig is created based on the skeleton of your model.

Floor Contact  Lets you define how the feet, hands, fingers, and toes of a
character should react when they are in contact with the floor of your scene.

Finger Tips  Hides or displays the contact spheres used for the finger tips or
toes of a character.

Actor (All)  Five options let you hide or display the interface items related to
an Actor. These options are available only when your current Character or
Source is an Actor.

Actor Body Displays (default) or hides the body of an Actor. Disable this
option to hide the body of the Actor.

Actor Skeleton Displays a set of connecting lines representing the bones of
the Actor. To display only the bones, activate Actor Skeleton and disable
Actor Body.

Marker Set  Hides or displays the markers that belong to the defined Marker
set. This option displays as white markers around the body of the Actor.
Disable this option to hide the Marker set.

Source Markers Displays (default) or hides the markers containing motion
data. Disable this option to hide the source markers.  When the Marker set
and the Source markers are both active, the markers belonging to the Marker
set display inside the source markers by default.

Pivot Points Hides or displays the pivot points for the Actor. Disable this
option to hide the pivot point markers.  By default, the pivot points display
as orange crosses. To change the way pivot points display, use the Actor
Settings in the Properties window. You can also adjust the position of the
pivot points using the Body Part Pivots properties.

See the Character Controls menu button topic in the Help.

Definition tab

This tab provides a visual interface for mapping the structure of a skeleton.
This process results in a HumanIK Skeleton Definition, which is required to
create a Control Rig and/or retarget animation to and from the skeleton of
this character. This is what is referred to as a HumanIK defined character.
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Definition tab A. Toolbar B. Character and Name Match views C. Skeleton properties
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To create a skeleton definition, click  .

To map a bone, navigate from the:

■ Definition tab to your skeleton: Double-click a cell in the Character
view (cells turn blue when picked), then click the corresponding bone in
the scene.

or

■ Skeleton to the Definition tab: Select a bone, right-click the corresponding
cell in the Character view, and select Assign Selected Bone.

To change a mapped bone:

1 Right-click the cell and select Change Assigned Bone. , then

2 From the drop-down list, select from the listed bone names or type the
name of the bone you want to use instead.

3 Press Enter or click Ok.

To clear a mapped bone:

1 Right-click the cell in the Character view and select Clear Assigned
Bone.

The name of the selected bone appears in the drop-down list.

2 Press Enter or click OK.

To clear all mapped bones in the current view (full body, hands, feet, or spine
view):

1 Right-click anywhere in the view.

2 Select Clear All in View.

To clear all mapped bones for the current character:

1 Right-click anywhere in the view.

2 Select Clear All.
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To map mirror pairs of bones:

1 Select > Edit > Definition > Mirror Matching.

TIP Alternatively, click  in the Definition toolbar.

2 Select > Edit > Definition > Configure Mirror Matching
to open the Mirror Configuration window.

This window contains a list of all sub-string pairs currently configured
for mirror matching mode.

3 Click the + or - button to add or remove substrings, respectively.

See the Definition tab topic in the Help.

Definition tab toolbar

This toolbar provides a set of global controls for managing skeleton definitions
such as saving and loading skeleton definitions to and from files, locking the
current skeleton definition. It also offers controls for enabling and configuring
mirror matching mode, and for applying and saving mapping templates.

Creates a blank skeleton definition.

Locks and unlocks the current skeleton definition.

NOTE Locking the character definition automatically updates the
mapping list in the Character Definition pane.

Toggles mirror matching mode.

Displays the Load Skeleton Definition window for applying a
mapping template and mapping multiple bones automatically by
name.
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Displays the Save Skeleton Definition window for saving a
mapping template, which can be loaded at a later date.

Deletes the current skeleton definition.

See the Definition tab toolbar topic in the Help.

Character and Name Match views

You can use the Character and Name Match views to map the bones in
your character to their corresponding HumanIK nodes, and to view the
information about the current mappings. Both views offer the same controls
for mapping nodes, but display the nodes using different layouts.

Toggle between the views by right-clicking anywhere in the view and selecting
either the Character View or the Name Match View option from the
contextual menu.

Character view The main Character view lays out the HumanIK nodes in a
schematic arrangement that indicates the placement of each bone in a biped.
It provides a visual tool for mapping out the structure of your character, and
provides feedback on the status of the skeleton definition.

Character view A. Validation status B. To other views C. Required bones D. Roll bones
E. Reference

Hand, Foot, Spine, Shoulder, and Neck views You can switch to detailed
views of the hands, feet, spine, shoulders, and neck to map additional bones

14 | Chapter 1   New Features and Enhancements



for those body parts. Click  to switch views to a particular body part, or

 to return to the full Character view.

Different views of a character A. Hands B. Feet C. To Hands D. To Right Shoulder E.
To Neck view F. To Left Shoulder G. To Spine H. To Feet I. Right Shoulder J. Left
Shoulder K. Spine

Validation status A validation status indicator displays at the top-right of the
Character view.

Skeleton definition is valid.Valid

Refer to the Validation status error message field for

information on areas of the character that require

attention.

A yellow symbol can indicate that the position of a

mapped bone is not correct. For example, if you ro-

Warning

tate a roll bone so it does not point down the X-axis.

The Character view also updates to highlight which

bone is out of position.

The skeleton definition is not valid. Some required

bones may be missing, or multiple bones may be out

of position.

Not Valid
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Name Match view Displays all bones in a list, grouped according to their
related body part or IK effector. Use this view to get an overview of your
skeleton definition, and to view the names of the bones assigned to multiple
different nodes. You can map bones to the Name Match view using the same
methods as in the Character view.
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See the Character and Name Match views topic in the Help.
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Load Skeleton Definition and Save Skeleton Definition windows

Load Skeleton Definition window Lets you select a naming template to

automatically map multiple bones by name. To open this window, click 
in the Definition tab toolbar.

Template This drop-down list provides several common bone naming
conventions. Select the naming template you want to apply.
■ HIK — Use with skeletons created using the HumanIK naming

conventions.

■ CAT — Use with biped skeletons created using the Character Animation
Toolkit (CAT).

■ Biped — Use with biped skeletons created in 3ds Max Biped.

Or select <Browse> to select your own saved naming template.

Match Scope Select whether you want to match bones based on a prefix
convention, or match only selected bones.

Save Skeleton Definition window Lets you extract a naming template based
on the bone names in the current skeleton definition. To open this window,

click  in the Definition tab toolbar.

Template Name Enter a name for the template. This name is added to the
list of templates in the Load Skeleton Definition window.

Example Bone Lists the name of the first valid bone in the current character
hierarchy.

Prefix Enter any prefix string that you want to remove from the beginning
of all bone names to be added in the template. This is useful if the bone names
for the current character include a standard prefix meant to identify that
specific character.  For example, if you have the name of the character
appended to the start of each bone name. Entering that prefix automatically
removes the prefix from all bone names added to your template.

See the Definition tab toolbar topic in the Help for more information on the
Load Skeleton and Save Skeleton Definition windows.
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Controls tab

The Controls tab contains:
■ Controls toolbar

■ Character representation

■ HumanIK Controls
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Controls tab A. Toolbar B. Character representation C. HumanIK Controls

20 | Chapter 1   New Features and Enhancements



The following table provides a brief overview of tasks using the Controls tab.

Do thisTo...

Select Control Rig from the Source menuCreate a Control rig
or

Select > Create > Control Rig.

Select > Edit > Controls > Rig
Look, then select an effector style.

Change the appearance of rig effectors

Click  .

Change to Full Body keying and manipula-
tion mode

Click  .

Change to Body Part keying and manipula-
tion mode

Click  .

Display the skeleton of the character

Select another HumanIK defined character
by name from the Source menu.

Set the animation source for the current
character

Right-click an IK effector cell and select
Create Aux Effector or Create Aux
Pivot.

Create an auxiliary or pivot effector

Select the effector in the scene and press
the Delete key.

Remove an auxiliary or pivot effector

Select the corresponding IK effector cell,

then click  .

Pin an effector in Translation
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Do thisTo...

Select the corresponding IK effector cell,

then click  .

Pin an effector in Rotation

Click  .

Temporarily release all pinning

Select > Bake > Bake To Skelet-
on

Bake the active Source onto the current
Character

(or)

Select > Bake > Bake To Con-
trol Rig

Select > Edit > Definition > Edit
Properties.

Edit retargeting parameters in the Attrib-
ute Editor

See the Controls tab topic in the Help.

Controls toolbar

The toolbar in the Controls tab contains:
■ Show/Hide buttons

■ Manipulation and keying modes

■ Pinning

■ Other buttons
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Show/Hide

These icons let you toggle the display of FK effectors, IK effectors, and the
skeleton.

Shows or hides the character's IK effectors.Show/Hide
IK

Shows or hides the character's FK effectors.Show/Hide
FK

Shows or hides the character’s skeleton.Show/Hide
Skeleton

See the Controls tab toolbar topic in the Help.

Manipulation and keying modes

These icons let you set manipulation and keyframing modes for working with
the Control rig of the character. You can manipulate and set keyframes on
the entire body (Full Body) of the character, a part of the body (Body Part),
or only on the selected effector (Selection).

Sets the tool to Full Body keying and manipulation
mode, letting you select individual effectors to ma-

Full Body

nipulate the entire character. For example, translating
the wrist effector of a character in the Full Body
mode affects the whole body as it moves to reach
that effector.
Forcing a stance pose in this mode will force the en-
tire character into a stance pose and the character
will be offset relative to its reference node.

Sets the tool to Body Part mode, letting you manip-
ulate and set keys on a single body part, based on
the selected effector.
Forcing a stance pose in this mode will force the se-
lected body part(s) into a stance pose. If the hips are

Body Part

part of the selection, the character will be offset rel-
ative to its reference node.
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Sets the tool to Selection mode, letting you manip-
ulate and key only the selected effector(s).
In this mode, you can manipulate one effector
without solving the rest of the character, then use

Selection

the HumanIK controls to adjust how much the rest
of the character reaches for that effector.

The Character representation displays white highlighting on cells to show
which part of the character is active for manipulation and keying. For example,
in the Body Part manipulation mode, when you select a left wrist effector,
all left arm cells in the Character representation highlight in white.

Pinning

These icons let you activate, disable, or temporarily release pinning on effectors.

Pinning gives you more control over character manipulation, letting you
constrain specific effectors from moving or rotating as you make adjustments
to the rest of the character position. For example, you can pin the wrist in
rotation but let it move in translation, so that as you adjust the wrist position
or arm position, the wrist can move but does not twist.

When you create a HumanIK Control rig, IK effectors on the character’s feet
are pinned in translation and rotation by default.

Pinning feedback displays on each cell in the Character representation.

Pins and unpins the selected effector in translation.Pin Transla-
tion When pinned, the selected effector cannot be moved, and a T

displays on its corresponding cell in the Character representa-
tion.

Pins and unpins the selected effector in rotation.Pin Rota-
tion When pinned, the selected effector cannot be rotated, and an R

displays on its corresponding cell in the Character representa-
tion.

Temporarily releases all translation or rotation pinning for the
selected effector and effectors down the chain.

Release All
Pinning

See the Manipulation and keying modes topic in the Help.
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Stance Pose The Stance Pose icon (  ) resets the Control rig to its default
T-stance pose. Selecting this icon in the Full Body mode forces the entire
character into a stance pose and the position of the character if offset, relative
to its reference mode. In the Body Part mode, the selected body part(s) are
forced into a stance pose. If the hips are part of the selection, then the character
will be offset, relative to its reference node. Note that this feature does not
apply to the Selection mode.

TIP You can also force a stance pose by selecting > Edit > Controls >
Stance Pose.

Controls Character representation

Displays an image of a biped character and all the effectors you can use to
animate a HumanIK Control rig.

Once you create a Control rig for your skeleton definition, the Character
representation displays cells for each IK and FK effector in the rig. These cells
provide visual feedback on the pinning, IK blend, and IK pull defined for each
effector, and also let you create and select auxiliary effectors and pivot effectors.

IK cell status

Each IK cell of the Character representation updates to reflect the status of
the corresponding effector. The following tables describe the various states of
each cell.

Selection

Effector stateCell
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Selected

Not selected

Selected as part of the active keying group - Full Body or Body
Part.

Pinning

Effector stateCell

Pinned in translation

Pinned in rotation

Pinned in translation and rotation

Ik Blend and IK Pull

Effector stateCell

IK Blend T set to 1.00

IK Blend R set to 1.00

IK Blend T and IK Blend R set to 1.00
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Effector stateCell

IK Pull set to 1.00 (with IK Blend T and IK Blend R set
to 1.00)

IK Pull set to 0.50

Auxiliary and pivot effectors

Effector stateCell

Main effector has auxiliary effectors. Click the + icon to
view.

Main effector has pivot effectors. Click the + icon to view.

Auxiliary effector

Pivot effector

Body Part views

Arrow icons  next to the hands and feet in the Character representation
let you switch to zoomed in views where you can select individual effectors
within the character's hands and feet. Clicking on the hand or foot icon in
the upper right corner of each view toggles between the left and right body
part.

Hands
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Feet

See the Character representation topic in the Help.

HumanIK Controls

The IK Blend T and IK Blend R (previously called Reach) sliders in the
HumanIK Controls let you decide which solution (IK or FK) your skeleton
follows. When you set keyframes on the Control rig, both the IK and FK
solutions are keyed.

Streamlined window size

The image of a biped character in the Controls tab contains a new A-frame
layout, which makes this tab smaller than the Definition tab.

Stance pose on body parts

You can force a stance pose on selected body parts. The active manipulation
and keying mode determines how your Control rig reacts when you force a
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stance pose by selecting the quick access icon  or > Edit >
Controls > Stance Pose.

This is useful during the pose-to-pose character animation, when only specific
body parts need to be reset to create a character pose.

See the Blend and Pull controls topic in the Help.

Heads Up Display
A motion picture must not only contain 3D assets, but also additional
information to communicate various aspects involved within a scene or shot.
Heads Up Display (HUD) is useful to display the title, take name, frame rate,
scene name, and so on regarding a specific scene to the viewer.

The HUD is available as an asset in the Asset Browser > Templates >
Elements sub-directory.

Adding the HUD asset to the current camera or
a scene

You need to add the HUD asset in the Asset Browser to a camera or a scene.
Only then, you can add a HUD element to the HUD asset and display the
information in the element in the Viewer.
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To add a HUD asset to the active camera or the scene:

1 Drag the HUD asset from the Asset Browser to the Viewer window.

2 From the contextual menu, select Add to Current Camera or Add
to scene.
■ Add to Current Camera — Selecting this option adds one HUD

asset to the current camera and another HUD asset to the scene.
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The HUD asset added to the current camera acts as a parent to the
HUD asset added with it in the scene.
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■ Add to scene — Adds a HUD asset only to the scene. This HUD
asset does not have a parent in any camera.

NOTE You can add multiple HUD assets to a scene but only one HUD asset
to a camera.

If you try to add a second HUD asset to the current camera, then the
Replace Current Camera's HUD option appears in the contextual
menu.

Selecting this option replaces the HUD asset in the current camera, and
adds another HUD to the scene. In this case, the name of the replaced
and added HUD assets is HUD 1.

To add a HUD asset from the scene or a camera to another camera:

1 Drag a HUD asset from the scene or a camera onto the desired camera.

2 Click the Add to Camera contextual menu option.

To delete a HUD asset from the scene or a camera:

1 Right-click on the HUD asset in the scene or a camera.

2 From the contextual menu, select Delete.
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If the HUD asset in a camera is a parent of another HUD asset in the
scene and vice versa, then both the HUD assets are deleted.

TIP Clicking a HUD asset, in the scene or in a camera, highlights its parent
or child HUD asset. This helps to know whether a HUD asset that you want
to delete is independent or attached to another HUD asset.

To detach a HUD asset from a camera:

1 Right-click on the HUD asset in a camera.

2 From the contextual menu, select Detach HUD From
<camera_name>.

The <camera_name> displays the name of the camera to which the
HUD asset belongs.
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Selecting the Detach HUD From <camera_name> option detaches
the HUD asset only from the camera, even though it contains a child
HUD asset in the scene.

See the Adding the HUD asset to the current camera or a scene topic in the
Help.

Understanding HUD elements

There are 14 HUD elements, which you can add to a HUD asset to display
additional information (static and dynamic) regarding a scene in the Viewer.

Text that you enter in the Content prop-
erty text box. See the Properties of HUD
Element section.

Text

Image, image sequence, or a videoTexture

Vector graphic, which you can use as a
background or mask for static or dynamic
content.

Rectangle

Flash animation saved in the .swf file format.Flash

Record lightRecord Light

Texture HUD element When you import an image, image sequence, or a
video (File > Import Video), it appears under the Navigator window >
Textures folder.

To display a texture from the HUD Texture element in the Viewer:

1 Click the  button in the Texture property.

The Textures folder with all the imported textures appear.

2 Turn on the checkbox of a texture.

Alternatively, drag a texture from the Navigator > Textures folder and drop
it in the Viewer.
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Flash HUD element

To display a flash animation from the HUD Flash element in the Viewer:

1 Click the  button in the Flash File Path property.

The Open Directory window appears.

2 Select the flash animation (.swf format).

3 Click Open.

Record Light HUD element The record light let a stage operator know the
recording status of a scene. By default, the color of the record light is grey (

 ). However, the color changes to indicate the stages in recording.

What does it in-
dicate?

What button
should you click
in Transport Con-
trols to make it
appear?

Record Light Color

Ready to recordRecord

Green (  )

Recording is in pro-

gress

Play

Red (  )

Stopped recording,

and MotionBuilder

Stop

Red with a white, X mark (  )
is busy in the post-

recording process.

After the post-re-

cording process, the

record light turns

grey (returns to the

default state).
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The following table lists the dynamic HUD elements and the information they
display in the Viewer:

The current time of edit Timeline in frames or Timecode.EditTime

The current time of the edit Timeline in frames, by default.EditFrame

The current time of action Timeline in frames or TimeCode
(minimum value is 0 and maximum value is the length of
the scene).

ActionTime

The selected frame rate per second (fps). The fps lowers
with heavy scenes and raises with light scenes. The highest

SceneFrameRate

possible frame rate optimizes to experience smooth play-
back.

The name of current take. Value can be a number or string.TakeName

Name of the camera to which the HUD belongsCameraName

Focal length of the camera to which the HUD belongsCameraFocalLength

Name of the current sceneSceneName

The free memory in your system. Helps to determine
whether you can load heavy scenes or not.

FreeMemory

You can also add any property of an object (cube, character, stereo camera,
and so on) into a HUD element, and refer the value of the property in the
scene.

See the Understanding HUD elements topic in the Help.

Adding a HUD element to a HUD asset

You need to add a HUD element to the HUD asset in the current camera to
display the element information in the Viewer.
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To add a HUD element to the HUD asset in the current camera:

1 Select the HUD asset in the current camera.

2 From the right pane of the Navigator window, click New...

The Heads Up Display Entry dialog box appears.

The drop down list contains 14 HUD elements to select. By default, the
Text element is selected.

3 (Optional) Change the default name (HUD Element) in the Enter a
field name text box.

NOTE If you add more than one HUD element without changing the default
name, then the name for the second element is assigned as HUD Element
1, third element as HUD Element 2, and so on.

4 Click Create.

In the Navigator window, the HUD element appears under the HUD
asset in the current camera.

If the HUD asset in the current camera is a parent of a HUD asset in the
scene, then all the HUD elements added to the current camera also appear
under the child HUD asset in the scene.
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By following the above procedure, you can add multiple HUD elements to a
HUD asset to convey useful details regarding a scene.

For example:

NOTE You can also add and edit all the HUD element types using the Python SDK
and C++ ORSDK. See the MotionBuilderSDK Help.

See the Adding a HUD element to a HUD asset topic in the Help.
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HUD element properties

The properties of HUD element are useful to modify the appearance, position,
and size of the content it displays in the Viewer. When you click a HUD
element under a HUD asset, the element properties appear in the right pane
of the Navigator window.

The HUD element properties are organized into four categories.

Properties of a HUD element A. Display B. Position C. Scale D. Property References

■ Display — To modify the appearance of an element

■ Position — To change the position of an element in the scene

■ Scale — To increase or decrease the size of an element, along the X and
Y axis

■ Property References — Displays the property name, which is referred
by the HUD element to display the property value in the Viewer. For
example, to display the current take name, the TakeName HUD element
refers the value (Take 001) in the HUD.TakeName property.

NOTE  The Property References category appears only for the dynamic
HUD elements.
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The following tables explain each property within the Display, Position, and
Scale category:

DescriptionDisplay Properties

To control the visibility of a HUD element content in the
Viewer.
By default, this property is turned on for all HUD elements.

Visibility

Turn off the checkbox to hide the content in the Viewer.

To enter the text that you want to display.
For dynamic elements, enter text before or after the variable
%s or %d.

Content

To choose a font in which the text or dynamic content should
appear.
The default font is Arial.

Font

To increase or decrease the visibility of the HUD element con-
tent and change the font color.
The default color of the content is white.

Color RGB

To increase or decrease the visibility of the HUD element con-
tent background and change the background color.
Background for the content is visible, only if the value of A, in
this property, is more than 0.

Background Color

The dimensions of the background are directly proportional
to the scaling of the content.

The r, g, b, a sub-properties are functionally similar to the R,
G, B, and A color boxes in the Color RGB and Background
Color properties.

r, g, b, a

To forcefully change the format of a HUD element content
from Frames to Timecode.
This property is enabled only for the EditTime and Action-
Time HUD elements.

Force Display As Time-
code

Consider that you create a scene in MotionBuilder installed on the Microsoft
Windows operating system. The scene contains many HUD Text elements,
each using different font (Garamond, Helevtica, and so on). Save the scene,
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and then load it using MotionBuilder installed on the UNIX operating system.
If the UNIX operating system does not contain one or more fonts used in the
scene file, then the following Warning dialog box appears.

This dialog box lists the fonts that are unavailable and informs which font is
used, instead. At first, MotionBuilder checks for the availability of the (default)
Arial font. If the Arial font is not available, then it checks for the availability
of the following fonts in the given order and uses them if available:

1 Helevtica

2 Sans

3 FreeSans

If none of the four fonts (Arial, Helevtica, Sans, and FreeSans) are available,
then the first font that appears in the HUD Text element font list is used.

To change the HUD element content font color:
■ Click on the R, G, or B color box and drag the cursor

or

■ Double-click on any of the R, G, or B boxes and enter a value from 0.00
to 1.00 (default value is 1.00)

or

■ Click the  button to open the Color window and pick a color of
your choice. See the Color window topic in the Help.

NOTE Perform any one of the above actions to change the background color of
the HUD element content as well.

To increase or decrease the visibility level of the HUD element content:
■ Click on the A (Alpha) box and drag the cursor

or
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■ Double-click the A box and enter a value from 0.00 to 1.00 (default value
is 1.00).

DescriptionPosition Properties

To set the effective position for a HUD element content in the
Viewer. For example, if you want to display the content of a

Justification

HUD element at the center of the Viewer, then you need to
select Center from the Justification and Horizontal Dock
drop down lists..

To dock an element content horizontally to the left, center, or
right of the Viewer.
Docking is the global reference point, which is referred by the
Justification property.

Horizontal Dock

To dock an element content vertically to the bottom, center,
or top of the Viewer.

Vertical Dock

To change the horizontal position of the HUD element content,
relative to the docked and justified position.
Click on the property value and drag to change the position
of an element along X axis. You can also double-click the box
and enter a value.

X

To change the vertical position of the HUD element content,
relative to the docked and justified position.
Click on the property value and drag to change the position
of an element along Y axis. You can also double-click the box
and enter a value.

Y

To display the value of X and Y in percentage. X is the horizont-
al position of the HUD element as a percentage of the width
of the Viewer.
Turn off the checkbox to display the value in pixels.

Position by Percent

DescriptionScale Properties

To increase or decrease the width (horizontal scaling) of a HUD
element content or background.

Width
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DescriptionScale Properties

To increase or decrease the height (vertical scaling) of a HUD
element content or background.

Height

To scale the width and height of a HUD element content in
percentage. Deselect this checkbox to scale the element in
pixels.

Scale by Percent

To uniformly increase or decrease the width and height of a
HUD element content.

Scale Uniformly

To:Adjust Width to Fit Text

■ Maintain the size when you add or delete text

■ Disable the Width property

■ Disallow to deselect the Scale Uniformly property

See the HUD element properties topic in the Help.

Customizing HUD element properties

You can customize the HUD element properties by adding a property of
another asset or custom property. This helps to display more information
regarding a scene in the Viewer.

Adding an object property to the HUD element prop-
erties

You can customize the HUD element properties by adding a property of
another asset under the Resources > Asset Browser > Templates directory.

NOTE You cannot add the properties of command objects under the Resources
> Asset Browser > Templates > Commands directory, since they do not
appear in the Resources > Properties directory.
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Each property of an object is referred as object_name.property_name in the
Properties window. For example, the Field Of View property of the
stereoCamera object is referred as stereoCamera.Field Of View.

To add a property of another object to the HUD element properties:

1 From the Resources > Asset Browser > Templates > Elements
folder, drag and drop the stereoCamera object in the Viewer.

The stereo camera appears in the Viewer.

2 Create a Text HUD element called Camera FOV.

3 From the Text HUD element properties, change the value of Y property
to position of the text (Camera FOV) at the top of the stereo camera.

4 By pressing the Ctrl key, click the Camera FOV HUD element in the
Navigator window.

Both the properties of the Camera FOV HUD element and the
stereoCamera asset appear in the Resources > Properties window.
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5 Click the Field Of View property under the Resources > Properties
> stereoCamera properties, and then drag it and drop on the Camera
FOV HUD element properties.

The Create 1 Reference Property contextual menu option appears.

6 Click the contextual menu option to add the Field Of View property
to the Camera FOV HUD element properties. The value of the Field Of
View property appears in the Viewer.

Viewer and Resources windows A. Field Of View property B. Field Of View
property added to Camera FOV HUD element properties C. Field Of View property
value

When you adjust the value of the Field Of View property, the change in
value appears dynamically in the scene.

TIP Alternatively, drag an object property from the Resources > Properties
window and drop it on a HUD element in the Navigator window.
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When you save a scene (in .fbx format), all the added HUD elements and their
properties are also saved to reuse them in another scene.

Adding a custom property to the HUD element prop-
erties

You can customize the HUD element properties by adding a custom property
from the Property Editor > Custom Properties window. This helps to
display more information in the Viewer.

See the Custom Properties pane topic in the Help.

To add a custom property to the HUD element properties:

1 Click the Editor button in the right pane of the Navigator window.

The Property Editor window appears.

2 Click the Custom Properties tab.
■ The Add Property pane displays the custom properties.

■ The Destination pane displays all HUD elements that you added.

3 In the Add Property pane, select a custom property.

4 In the Destination pane, select a HUD element to which you want to
add the custom property.

5 Click Create Custom Properties of the selected type button .

In the following figure, the Number custom property is added to the
Duration HUD element.
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The Number custom property appears in the Duration HUD element
properties.
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See the Customizing HUD element properties topic in the Help.

Deleting a HUD element

You can delete a HUD element under a HUD asset in the Navigator window.
If you delete a HUD element, then all its properties are also deleted.

To delete a HUD element under a HUD asset in the Navigator window:

1 Select a HUD element in the Navigator window.

2 Right-click and select Delete from the contextual menu.

If you want to temporarily hide one or more HUD elements from the
Properties pane, right-click on the element(s) and select Remove Object.

See the Deleting a HUD element topic in the Help.
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Displaying HUD elements in the Profiling Cen-
ter

When you add HUD elements to a HUD asset, it is important to know the
impact of HUD elements on the MotionBuilder performance. This is possible
by viewing the performance metric of HUD and its elements in the Profiling
Center.

To view the HUD and its elements in the Profiling Center:

1 From the Window menu, select Profiling Center.

The Profiling Center window appears. By default, the Profiling
Center does not display the HUD and its elements in .

2 From the Profiling Display Settings pane >Display Details
drop-down list, select Rendering.

3 From the Profiling Display Settings pane >Profiling Mode
drop-down list, select Rendering Only.

4 Double-click the Profiling Display Settings pane >Evaluation
Depth text box, and enter 10 (the maximum value for evaluation depth).

Alternatively, increase the value of evaluation depth by clicking the left
or right mouse button and dragging towards right.

Profiling Center window A. Settings to display HUD and its elements B. HUD
and added element types

TIP Turn off the Frame Reference checkbox in the Profiling Display Settings
pane to view the performance impact in milliseconds (ms).
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See the Displaying HUD elements in the Profiling Center topic in the Help.

Legacy HUDs in the Display menu

In addition to the HUD elements in the Heads Up Display Entry dialog
box, there are six legacy elements in the Viewer > Display > Head-up
Display (HUD) menu.

NOTE  When you select a legacy HUD element from the Display menu, it displays
the intended information in the scene and does not appear under the HUD asset
in the Navigator window. Therefore, the HUD elements in the Display menu
do not contain any properties to position, scale, or change the font and their color.

For more information regarding:
■ Display Rate, Display Memory Usage, Display Time Code, and Display Safe

Area — see the Display menu topic in the Help

■ ViewCube — see the ViewCube topic in the Help

■ SteeringWheel — see the SteeringWheels topic in the Help

See the Legacy HUDs in the Display menu topic in the Help.

Selecting occluded textured geometric elements
via the Viewer window

Selecting textured geometric elements in a dense scene via the Viewer window
can be challenging and time consuming especially if the elements are occluded
by other elements. You can change the camera view or use the Navigator
window to access and select elements behind other elements but this workflow
may be quite inefficient particularly with large scenes.

This release optimized the selection of occluded textured geometric elements
by providing the following capabilities:
■ Selecting an occluded textured geometric element through alpha channels
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■ Selecting an occluded textured geometric element through alpha channels
and selection override color via the API

See the MotionBuilder SDK Help at: http://www.autodesk.com/motionbuilder-
sdkdoc-2013-enu.

■ Selecting an occluded textured geometric element through partially
transparent textures

■ Selecting an occluded textured geometric element by using a selection
override color

Keyboard shortcuts for selecting and displaying occluded textured geometric
elements in the Viewer window

The following table lists the keyboard shortcuts and User Interface (UI)
elements associated with the selection and display of occluded textured
geometric elements in the Viewer window. The keyboard shortcuts are
supported in all default and custom cameras.

NOTE All keyboard shortcuts associated with actions within the Viewer window
require the Viewer window to be in an active state.

State / Alternative to
Keyboard Shortcut

UI ElementKeyboard
Shortcut

Action

Enable the IDBufferPicking
property in the Renderer
Properties Resources.

Alt + Shift
+ A

To toggle the EZ
Selection button
on.

Disable the IDBufferPicking
property in the Renderer
Properties Resources.

Alt + Shift
+ A

To toggle the EZ
Selection button
off.

Enable the IDBufferDisplay
property in the Renderer
Properties Resources.

IDBufferDisplayShift + ATo display the
transparency
threshold of tex-
tures.

Adjust the value of the IDBuf-
ferPickingAlpha property

IDBufferPickin-
gAlpha

Shift + A +
scroll mouse
wheel

To define the
transparency
threshold of tex-
tures.

in the Renderer Properties
Resources.
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State / Alternative to
Keyboard Shortcut

UI ElementKeyboard
Shortcut

Action

Enable the SelectionOver-
ride property in the Renderer
Properties Resources.

SelectionOver-
ride

Alt + Shift
+ Q

To enable the se-
lection override
color for selecting
occluded geomet-
ric elements.

Disable the SelectionOver-
ride property in the Renderer
Properties Resources.

SelectionOver-
ride

Alt + Shift
+ Q

To disable the se-
lection override
color for selecting
occluded geomet-
ric elements.

Define the selection override
color in the SelectionOverri-

SelectionOverri-
deColor

NoneTo define the selec-
tion override color
for selecting oc- deColor property fields or
cluded geometric
elements.

button in the Renderer Prop-
erties Resources.

Adjust the value of the Selec-
tionOverrideTransparency

Selec-
tionOveride-
Transparency

NoneTo define the selec-
tion override color
transparency for
selecting occluded

property in the Renderer
Properties Resources.

geometric ele-
ments.

Define the selection override
color in the SelectionOverri-

NoneClick a geo-
metric ele-

To select and cycle
through textured

deColor property fields orment andgeometric ele-
button in the Renderer Prop-
erties Resources.

press Shift +
1 + scroll
mouse wheel

ments with a selec-
tion override col-
or.

Define the selection override
color in the SelectionOverri-

NoneClick a geo-
metric ele-

To cycle through
textured geomet-

deColor property fields orment andric elements with
button in the Renderer Prop-
erties Resources.

press Shift +
2 + scroll
mouse wheel

a selection over-
ride color and
hide the geomet-
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State / Alternative to
Keyboard Shortcut

UI ElementKeyboard
Shortcut

Action

ric elements in
front of the selec-
ted geometric ele-
ment.

Define the selection override
color in the SelectionOverri-

NoneClick a geo-
metric ele-

To hide textured
geometric ele-

deColor property fields orment andments with a selec-
button in the Renderer Prop-
erties Resources.

press Shift +
2

tion override color
in front of the se-
lected textured
geometric ele-
ment.

Define the selection override
color in the SelectionOverri-

NoneClick a geo-
metric ele-

To show only the
selected textured

deColor property fields orment andgeometric ele-
ment. button in the Renderer Prop-

erties Resources.
press Shift +
3

Define the selection override
color in the SelectionOverri-

NoneClick a geo-
metric ele-

To isolate the selec-
ted textured geo-

deColor property fields orment andmetric element
button in the Renderer Prop-
erties Resources.

press Shift +
3 + scroll
mouse wheel

with a selection
override color and
then scroll
through all the
geometric ele-
ment with a selec-
tion override color
(one by one).
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Selecting an occluded textured geometric ele-
ment through alpha channels

If you have a dense scene with many geometric elements and you need to
select a partially occluded geometric element in the background, you can
select an element in the background through the alpha channels of partially
transparent textured geometric elements in the foreground using the Easy

Selection button (  ) in the Viewer toolbar or its keyboard shortcut Alt
+ Shift + A, and a combination of other keyboard shortcuts to speed up the
selection process.

NOTE All keyboard shortcuts associated with actions within the Viewer window
require the Viewer window to be in an active state.

The following image shows partially transparent textured elements, all with
an alpha channel. The alpha channels are the sun-shape center of the geometric
elements.
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To select an occluded textured geometric element in the Viewer window
through an alpha channel:

1 In the Viewer toolbar, click the Easy Selection button (  ) or use
the keyboard shortcut Alt + Shift + A to toggle the Easy Selection

button on (  ).

2 In the Viewer window, click through the alpha channel of the textured
geometric element in the foreground that occludes the geometric element
behind it.
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The geometric element behind the geometric element in the foreground
is shown selected as its border is highlighted.
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To select an occluded textured geometric element in the Viewer window
through multiple alpha channels:

1 In the Viewer toolbar, click the Easy Selection button (  ) or use
the keyboard shortcut Alt + Shift + A to toggle the Easy Selection

button on (  ).

2 In the Viewer window, click through the alpha channels of the
geometric elements in the foreground that occlude the geometric element
in the background.
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The geometric element in the background is shown selected as its border
is highlighted.
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Selecting an occluded textured geometric ele-
ment through alpha channels and selection
override color via the API

You can select textured geometric elements through their alpha channels or
through a selection override color and transparency via an external device
such as a hand-held camera. This enables you to have the option to select
through alpha channels and specify the camera to use.

Refer to the MotionBuilder SDK Help at: http://www.autodesk.com/motionbuilder-
sdkdoc-2013-enu.

Selecting an occluded textured geometric ele-
ment through partially transparent textures

Similarly to selecting occluded geometric elements through alpha channels,
you can select a geometric element in the background through partially
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transparent textured geometric elements in the foreground by using the Easy

Selection button (  ) in the Viewer toolbar or its keyboard shortcut (Alt
+ Shift + A), and by specifying the textures' transparency threshold.

NOTE All keyboard shortcuts associated with actions within the Viewer window
require the Viewer window to be in an active state.

The following image shows partially transparent textured elements, all with
an alpha channel. The alpha channels are the sun-shape center of the geometric
elements.

IMPORTANT To use a texture's alpha channel and transparency, the geometric
element requires a shader (such as the Lighted shader) with its Transparency
setting type set to other than No Transparency.
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To display in the Viewer window the transparency threshold of textures via
the Viewer window:

1 In the Viewer toolbar, click the Easy Selection button (  ) or use
the keyboard shortcut Alt + Shift + A to toggle the Easy Selection

button on (  ).

2 Click anywhere in the Viewer window to make the Viewer window
active.

3 Press Shift + A.

The following figure shows the transparency threshold of textures for
all geometric elements in the scene.

To display in the Viewer window the transparency threshold of textures via
the PropertiesResources window:

1 In the Navigator window, expand System, expand Core, then click
Renderer.
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2 In the Resources window, click the Properties tab.

The Renderer's properties are displayed.
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Renderer's Property Resources

3 In the Renderer's Properties, enable  IDBufferDisplay.

To select an occluded geometric element in the Viewer window through a
geometric element's partially transparent texture:

IMPORTANT The geometric element that occludes the geometric element you
want to select requires a partially transparent texture and an alpha channel.

1 In the Viewer toolbar, click the Easy Selection button (  ) or use
the keyboard shortcut Alt + Shift + A to toggle the Easy Selection

button on (  ).

2 In the Viewer window, click a partially transparent textured geometric
element.

The following figure shows the foremost geometric element is selected.
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Selected elements are shown with a highlighted border.

3 Press Shift + A to display the textures' transparency threshold (enabling
the Renderer's IDBufferDisplay property).

The textures' transparency threshold value is shown in the Renderer's
IDBufferPickingAlpha property field. The following figure shows
the textures' transparency threshold is set to 0.50.
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IDBufferPickingAlpha property specifies the textures' transparency threshold

Setting the textures' transparency threshold to 0.50 means that 50% of
the textures' transparency is considered when selecting occluded
geometry. See the result in the following figure.
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4 Press Shift + A+ scroll the mouse wheel to change the texture's
transparency threshold value.

TIP You can adjust the textures' transparency threshold value (ID buffer) via
the Renderer's IDBufferPickingAlpha property field.

The following figure shows the textures' transparency threshold is set to
1, meaning 100% of the textures' transparency is considered when
selecting occluded geometry.
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Setting the textures' transparency threshold to 1 enables you to easily
select through any of the partially transparent geometry.

To access the IDBufferPickingAlpha property:

1 In the Navigator window, expand System, expand Core, then click
Renderer.
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2 In the Resources window, click the Properties tab.

The Renderer's properties are displayed.
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Renderer's Property Resources

Selecting an occluded textured geometric ele-
ment by using a selection override color

Similarly to selecting occluded geometric elements through alpha channels,
you can select a geometric element in the background through partially
transparent textured geometric elements in the foreground by using the Easy

Selection button (  ) in the Viewer toolbar or its keyboard shortcut (Alt
+ Shift + A), and by specifying the texture's selection override color. Setting
a selection override color uses the textures' diffuse channel for the color
override.

The following image shows partially transparent textured elements, all with
an alpha channel. The alpha channels are the sun-shape center of the geometric
elements.
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To select an occluded textured geometric element in the Viewer window by
using a selection override color:

IMPORTANT To select an occluded geometric using a selection override color,
the textured geometric element requires a shader (such as the Lighted shader)
with its Transparency setting type set to other than No Transparency.

1 In the Viewer toolbar, click the Easy Selection button (  ) or use
the keyboard shortcut Alt + Shift + A to toggle the Easy Selection

button on (  ).

2 In the Navigator window, expand System, expand Core, then click
Renderer.
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3 In the Resources window, click the Properties tab.

The Renderer's properties are displayed.
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Renderer's Property Resources

4 Click in an empty area in the Viewer window to make it active.

5 Press Alt + Shift + Q.

The Selection Override option is enabled. The Renderer's
SelectionOverride property is shown enabled.
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NOTE The IDBufferPickingAlpha value is 1.

6 (Optional) Press Shift + A.

The following figure shows the geometric elements available for selection
based on the defined textures' transparency threshold (
IDBufferPickingAlpha).
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TIP Drag a selection box in the Viewer window to see which geometric
elements can be selected based on the defined textures' transparency
threshold.

7 In the Renderer's properties, define the Selection Override color
properties by either:
■ dragging in the SelectionOverrideColorR, G, B fields or

double-clicking the R, G, B fields to enter values,

■ or by clicking the SelectionOverrideColorR, G, B button (  )
and picking a color in the Color window.

The SelectionOverrideColorR, G, B fields update.
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8 In the Renderer's properties, drag or double-click the
SelectionOverrideTransparency property to define the transparency
of the selection override color.

9 In the Viewer window, click a textured geometric element.

Setting a selection override color enables you to easily see which textured
geometric element is selected.

The following figure displays the selected geometry with the selection
override color defined in the Renderer's SelectionOverrideColor
property.
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If you are working in a dense scene containing geometric elements with
various subtle transparent textures, taking advantage of the Renderer's
SelectionOverrideColor property optimizes the selection process.

To select and cycle through textured geometric elements with a selection
override color:

1 In the Viewer toolbar, click the Easy Selection button (  ) or use
the keyboard shortcut Alt + Shift + A to toggle the Easy Selection

button on (  ).

2 In the Viewer window, click a textured geometric element.

3 Press Shift + 1 + scroll with the mouse wheel.

The textured geometric elements with a selection override color are
selected one by one using the Z buffer.
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To hide textured geometric elements with a selection override color in front
of the selected textured geometric element and then cycle through the
textured geometric elements (with a selection override color) in the back:

1 In the Viewer toolbar, click the Easy Selection button (  ) or use
the keyboard shortcut Alt + Shift + A to toggle the Easy Selection

button on (  ).

2 In the Viewer window, click a textured geometric element.

3 Press Shift + 2 + scroll with the mouse wheel.

The textured geometric elements in front of the selected geometric
element are hidden and the geometric elements in the back are selected
one by one using the Z buffer.

To hide textured geometric elements with a selection override color in front
of the selected textured geometric element:

1 In the Viewer toolbar, click the Easy Selection button (  ) or use
the keyboard shortcut Alt + Shift + A to toggle the Easy Selection

button on (  ).

2 In the Viewer window, click a textured geometric element and press
Shift + 2.

To show only the selected geometric element with a selection override color:

1 In the Viewer toolbar, click the Easy Selection button (  ) or use
the keyboard shortcut Alt + Shift + A to toggle the Easy Selection

button on (  ).

2 In the Viewer window, click a textured geometric element and press
Shift + 3.
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To isolate the selected textured geometric element with a selection override
color and then scroll through the geometric element with a selection override
color (one by one):

1 In the Viewer toolbar, click the Easy Selection button (  ) or use
the keyboard shortcut Alt + Shift + A to toggle the Easy Selection

button on (  ).

2 In the Viewer window, click a textured geometric element and press
Shift + 3 + scroll with the mouse wheel.

Temporary Pivot Shift
Sometimes the pivot of an object offsets, rather than being at the center point
of its bounding box. This prevents you from selecting the center of the object
and moving it to a different location. The Temporary Pivot Shift tool
helps to temporarily shift the pivot of an object, from the offset position, to
the center of its bounding box.

Temporarily shifting the pivot from original
location

This section provides an example to explain how to move the pivot of an
object from an offset position to its center, using the Temporary Pivot
Shift tool.

The following figure displays a parking lot scene in the Viewer window. The
scene displays a car, which is parked between the pillars B and C. Each pillar
in the scene is an object.
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Camera view of a parking lot scene in Viewer window A, B, C, D Pillars E. Temporary
Pivot Shift icon

In the following figure, the pivot of the pillar B is offset at some distance from
its center. The offset location of the pivot is not visible in the normal camera
view. To view the actual offset position, you need to rotate the scene until
you locate the pivot.

Parking lot scene rotated to locate the pivot of pillar C A. Pivot Mode B, C Pillars
between which the car is parked D. Offset location of the pivot of pillar C

In a virtual production environment, if the director want to immediately
reposition all the pillars (A, B, C, and D) on the scene, then it is time
consuming to rotate the scene, locate the offset position of each pillar, and
drag them to the center point of each pillar, before repositioning them.

To avoid this:

1 Select the object that you want to move.

2 From the Viewer window toolbar, click the Temporary Pivot Shift
icon.

The pivot moves from the offset position to the center of the bounding
box of the object, as shown in the following figure:
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Notice that the coordinates of temporary pivot and the line that connects the
offset location and the temporary shift to the bounding box center appears
dotted. This specifies that the shift from offset pivot location to the center of
an object is only temporary.

TIP Instead of clicking the Temporary Pivot Shift tool from the Viewer toolbar,
press the Alt+Shift+W keys to toggle between normal and temporary pivot
modes.

In the temporary pivot mode, selecting any object in the scene shifts the pivot
of the respective object, temporarily from its offset location to the center of
the bounding box. So you can select each pillar and move to the desired
location in the scene.

Parking lot scene A, B, C, D Pillars moved backward E. Temporary Pivot Shift tool
active

By default, the temporary pivot appears in the translation mode (T). You can
change to the rotation and scaling modes using the R and S keys, respectively.
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You can manipulate the translation, rotation, and scaling of pivots using the
properties listed in Resources window > Properties tab.

See the Transformation Pivots properties in the Help.

You can save a scene with the Alt+Shift+W keys enabled. When you reload
the scene, it contains the saved settings.

See the Temporarily shifting the pivot from original location topic in the Help.

Advanced Audio Engine
While shooting in a virtual production environment, audio helps the actor,
director, and editor to confirm that the visual scene is in sync with the story.
The advanced audio engine lets you add multiple audio tracks in the Story
window, and play them back. In a take-based approach, a take is considered
as the destination for an audio file to play. Therefore, you can assign only one
audio file to a take.

With the advanced audio engine, you can:
■ Stretch multiple audio tracks in time

■ Import 16-bit .WAV, .MP3, and .BWF file formats

NOTE You need to install Apple QuickTime player to import .MP3 files.

The Broadcast Wave Format (BWF) is based on the Microsoft WAVE audio
file format, to which the European Broadcasting Union (EBU) has added
a Broadcast Audio Extension chunk. In addition to the audio data, a BWF
file contains the metadata which is considered necessary for all broadcast
applications. This audio format enables seamless exchange of audio material
between different broadcast environments and between equipments based
on different computer platforms.

■ Export WAV files from MotionBuilder SDK.

See the MotionBuilder SDK Help.

NOTE You cannot export BWF files.

■ Choose left, right, or both channels to play the audio content

■ Lock audio speed when constraining the audio to a take

See the Advanced Audio topic in the Help.
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Verifying animation and audio sync in the Story
window

In a virtual production environment, you can use the Story window to create
character animation tracks and audio tracks. You can then insert clips to the
audio tracks and play the character animation and audio tracks together to
check whether the visual movements in the character animation match with
the audio. In the process, you can use various audio settings to achieve the
desired audio quality.

See the topics Creating character clips and Creating audio clips in the Help.

TIP Before creating animation and audio tracks, insert a folder using the Insert
option from the Story window contextual menu. A folder is useful to organize
the tracks.

See the Story contextual menu topic in the Help.

Adding audio clips from Navigator window

To add audio clips from the Navigator window to the Story window:

1 Load an audio file.

The audio file appears under the Audio asset in the Navigator window.

In the following figure, the imported audio file is assigned to Take 001.
If you import multiple audio files, then you need to assign individual
Takes for each file.

Navigator window A. Audio file B. Take to which the audio file is assigned to

2 From the Window menu, select Add Navigator.

A second Navigator window appears.
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3 In the first Navigator window, click the Story tab.

4 From the second Navigator window, click the audio file, drag, and drop
it on the Audio Track, which you already created in the Story window
of the first Navigator window.

Two Navigator windows A. First Navigator window B. Second Navigator window
C. Dragged and dropped audio clip D. Take name disappears after assigning the
clip to the track

See the Adding audio clips from the Navigator window topic in the Help.

See the topic for more information.

Understanding audio settings

The audio settings help to adjust the speed of the audio, select left, right, or
both channels, and so on. The audio settings appear in the Navigator window
and in the Resources window > Properties tab.

Advanced Audio Engine | 83



From the Audio Settings in the Navigator window, click:
■ Play — to hear audio content

■ Stop — to end the audio

The following table explains the audio settings in the Resources > Properties
tab.

NOTE The setting name mentioned within brackets is the corresponding name
that appears in the Audio Settings pane of the Navigator window.

DescriptionAudio Setting

Path from where the audio file is importedPath

Destination device to play the audio file.
Choose the destination device from the list of all the connected
audio devices.

Destination

The count of audio samples recorded in the source audio se-
quence, and the starting frame of the audio file. This informa-

Src In Point

tion is stored as a time stamp, only in the BWAV header files
and not in the WAV files.
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DescriptionAudio Setting

The last frame of the source audio file.Src End Point

The total number of frames included in the source audio file.

NOTE The Src In Point, Src End Point, and Src Duration are
the existed parameters when the source audio files was recor-
ded. So you cannot alter the data in these fields.

Src Duration

The frame from which the audio plays in the selected destina-
tion (output device such as speakers).

Dst In

The last frame of the audio file.Dst End

The total duration of the audio file.

NOTE Alter the Dst In, Dst End, and Dst Duration values
to specify the start and end time to play the audio file.

Dst Duration

Enables the shuttle mode. You can shuttle the audio, back and
forth, between the start and end frames in the time line.
To shuttle the audio, back and forth, press J and the left mouse
button simultaneously and move the mouse to the left or right

Scrubbing (Enable
Shuttle)

on the Timeline. This option helps to hear the audio by in-
creasing and decreasing the speed without manually changing
the value of Speed.

Specifies the number of bits of information recorded for each
audio sample. The depth of bit (8, 16, or 24) directly corres-
ponds to the resolution and quality of an audio sample.

Type (Bits)

Specifies the audio sample count per second.

NOTE Type and Rate values are part of the header information
of the audio file.

Rate (Hz)

Specifies whether the source audio is a mono (1.0) or stereo
(2.0) file.

Channels
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DescriptionAudio Setting

The Left or Right (mono) and Left+Right (dual) channels are
supported. If you select only the Right or Left channel, then

Use Channel

the graphical representation of the unselected channel appears
faded in the Navigator window.

Specifies from which location to pick and play the audio file.
You can choose Disk or Memory as the location to pick the
audio file.

Access Mode (Media
Access)

Specifies the current take to which the audio file is assigned
to. You can change the Take value, if there are many audio
files and want to assign each audio file to different Takes.

Take

Restricts from modifying the Dst In value.

NOTE Turning on this option, automatically turns on the Lock
Speed option.

Constrain Dst to Take

The location of the audio file.Relative Path

The velocity at which sound travels in a given medium under
specified conditions. Increase or decrease the audio speed ac-
cording to the slow or fast movements in your animation scene.
Using this option, you can adjust the audio speed from 0.01
to 10. This means, you can play the audio 100 times slower
or 10 times faster than the original speed (1.0).

Speed

See the topic for more information.

To get the relative path of the audio file:

1 From the File menu, select Save As.

The Save As window appears.

2 Specify a name for the file, and click Save.

The path where you saved the file with audio content appears in the
Relative Path field. You can use the relative path, later, to open the
file with the audio content.
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Retime Tool
In the FCurves toolbar, the Retime Tool lets you adjust the timing of key
movements in your animation to make them occur faster or slower. For
animators working in a pipeline with multiple Autodesk applications, similar
animation retiming tool is available in other applications including Maya,
3ds Max, and Softimage.

A common task in all stages of animation is changing the timing of a motion.
Performing tiny refinements to the timing of an animation is a repetitive and
time consuming task for an animator. Therefore, animators need:
■ A predictable method to manipulate key movements (slower or faster) in

an animation

■ High quality curves that do not require additional cleanup tasks

Retiming key movements in animation

To retime key movements in an animation, you can create retime markers in
the FCurves pane, then drag them to adjust the timing of key movements.

To create retime markers:

1 Select the object with animation.

2 In the FCurves editor, select the channels (T, R, or S).

3 In the FCurves toolbar, click  .

This activates the Retime mode in the FCurves editor.

FCurves editor A. Retime Tool C. T and R channels selected

4 Double-click on the FCurves pane to add retime markers around segments
of the animation curves you want to retime.
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NOTE Add a single marker to reposition the marker or to ripple all animation
out from a single point.

Single retime marker added A. Time bar (thin upper and lower part) to reposition
the marker B. Handle (thicker middle part) to retime animation

5 Add two or more markers to retime the time span between them.

For example, in the following figure, two markers are added at frames 5
and 20 to retime animation between them.

Retime markers A. Solid line between markers B. Delete icon

When there are multiple retime markers, a solid line displays between each
pair of markers. It indicates that dragging either marker affects any keys
between the first marker and the next. Dragging two retime markers further
apart slows the motion between them, and dragging them closer together
speeds it up.

To delete a retime marker, click the Delete icon or double-click anywhere on
the marker.

When you drag the marker, the timing of the animated object in the Timeline
of Transport Controls window and in the scene loaded in the Viewer
window is changed.

TIP To exit the retime mode, click  .
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TIP In the retime mode, press Shift+mouse drag to move the FCurves grid,
Ctrl+mouse scroll to zoom in and zoom out the view, and hold Shift and select
multiple retime markers.

Locking time span between two markers

You can lock the time span between two markers to move the segment in
time, without scaling or adjusting the shape of the curves within.

To lock the time span between two markers:

1 Right-click the solid line that appears between two markers.

2 From the contextual menu, select Lock.

Activating the Lock option disables the adjustment of FCurves within a
segment as you drag the retime markers.

Locking a segment of animation is useful when you want to retime multiple
keys together, without adjusting the shape of the curves. Once the segment
is locked, drag the markers to shift the entire segment to a new location in
time.

TIP To unlock a segment, right-click on the solid line and turn off the Lock option.
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Snapping markers on the nearest frame

When you drag a marker, you can choose to snap it on the nearest frame or
to maintain the last position of your movement. By default, all markers are
snapped on the nearest frame to each marker.

To disable snapping of markers to the nearest frame:

1 Right-click the solid line that appears between two markers.

2 From the contextual menu, deselect Snap All Retime Markers on
Frame.

If you disable snapping, then the marker appears on the same frame
where you created.

Inserting a key on a Retime marker

You can insert a key on all selected channels currently displaying under the
retime marker.

To insert a key on a marker:

1 Right-click anywhere on the marker.

2 Select Insert Key.

NOTE In the retime mode, you cannot edit any keys or FCurves.

TIP In the retime mode, press Ctrl+Z to undo your last 10 actions.

See the Retime Tool topic in the Help.

Using Video Out Window
You can invoke a non-interactive copy of the pane zero window. This copy
is useful to watch the current scene by placing the copy of pane zero window
on a secondary monitor and continue with other tasks in MotionBuilder.

To invoke a copy of the pane zero window:

1 From the Navigator window > Videos folder, double-click Video
Output 1.
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The video output settings appear on the right pane.

2 Click the Video Out Window button.

The Video Out Window appears with a blank screen, since it is in the
inactive mode.

NOTE Alternatively, invoke the Video Out Window from the Window
menu >Video Out.

3 Turn on the Online checkbox to activate the Video Out Window.

The Video Out Window displays exactly what is being displayed in
the Viewer.

MotionBuilder interface A. Video playing in the copy of pane zero window B.
Video playing in the Viewer C. Video Output 1 D. Video Out Window button E.
Online checkbox F. DrawMode property

By default, the Video and External Sync settings are disabled. These
settings are enabled, only if you use an Nvidia SDI Output card in
MotionBuilder.

IMPORTANT Using the Video Out Window may impact the scene frame rate.
Moreover, loading huge video files in the Video Out Window could impact
MotionBuilder performance.
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TIP To minimize the impact on frame rate, select Output only from the
Resources window > Properties tab > Video Output 1 > DrawMode property
drop-down list.

See the Using Video Out Window topic in the Help.

Summary Clip in Story Window
In the Story window, you can insert multiple tracks and add audio, animation,
or video clips to each track. You can insert a folder and group multiple tracks
within it. If there are many clips within a folder, then it is time consuming
to select and move each clip along the timeline. To avoid this, the Summary
Clips On/Off window in the Story toolbar allows you to display a summary
clip, as part of the folder track. By moving the summary clip, you can move
all the clips in a folder.

To display the summary clip, click the Summary Clips On/Off icon from
the Story toolbar. The summary clip appears at the top of all clips in the
folder.
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Story window A. Summary Clips On/Off icon B. Summary clip C. Folder D. Tracks and
clips within the folder

NOTE The length of the default summary clip is equal to the timeline of the longest
clip in the folder.

Using the summary clip, you can:
■ Drag all clips in a folder along the timeline.

■ Scale the summary clip in time. When you scale the summary clip, all the
clips within the folder also scale accordingly in time. To scale the summary

clip, click the Loop/Scale Clips icon (  ) in the Story toolbar

to turn on the scale mode (  ).

NOTE Currently, you can only scale all clips and cannot loop them.

■ Razor or cut up one or all clips, which lie along the current transport
control time, within the folder. To do this, select the summary clip and
move the timeline to the position where you want to razor the clip(s).
Click the Razor icon from the Story toolbar.
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Story window A. Razor icon B. Position of timeline where the clips are razored C.
Summary clip is not razored

NOTE The Razor tool cuts only the clips within a folder. It does not affect the
summary clip.

TIP Press Ctrl+Z to undo the actions performed in the Story window.

The name of summary clip is same as the name of the folder track. Right-click
on the folder track or the summary clip, and select Rename from the
contextual menu to rename both the folder track and summary clip. The name
of the summary clip is helpful to know the summary of a folder, when you
minimize the folder.

Story window A. Names of summary clip and folder are same B. Folder is minimized

If you delete the summary clip, then the folder and the clips within it are
deleted. To delete the summary clip, right-click on it and select Delete from
the contextual menu.

See the Adding a Summary clip for tracks topic in the Help.
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Selective Display of Tracks in Story Window
Consider the following scene that contains many characters. In the Story
window, notice that each character in the scene is represented by an animation
track and all tracks have similar names. If you want to manipulate the timing
of a character, then it is difficult to find the animation track for that particular
character in the Story window.
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Viewer window and Story window A. Play ground scene with many characters B.
Animation tracks with similar names C. Filter by selection tool
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Filtering by selection

The Filtering by selection (  ) tool displays only the animation tracks
that belong to the objects that you select in a scene.

To display tracks that belong to only the selected objects:

1 From the scene, select the object(s).

For example, in the following figure, an animation character is selected.

2 From the Story toolbar, click the Filter by selection icon.

Viewer window and Story window A. Selected character B. Animation track for
the selected character C. Filtering by selection icon D. Message to inform that
only the track for the selected object is displayed

According to your needs, manipulate the timing of the selected character.

NOTE When the Filtering by selection tool is active, the background
color of the Story window appears blue.

Selective Display of Tracks in Story Window | 97



Lock filtering by selection

If you want to perform additional tasks on the scene, such as inserting an
object, it is important to lock the view in the Story window. To achieve this,

click the Lock filtering by selection (  ) tool.

NOTE The Lock filtering by selection icon is enabled only if the Filtering by
selection icon is active.

Viewer window and Story window A. Lock filtering by selection icon is active B. Current
position of all characters are unchanged C. Position of the track for the already selected
character is unchanged in the Story timeline D. Object is added to the scene E. Story
window displaying the locked status

To unlock the characters and manipulate their timing, click the Filtering
by selection icon.

NOTE When the Lock filtering by selection tool is active, the Story window
background color appears yellow.

See the Displaying only the selected tracks topic in the Help.
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Track Recording Options in Story Window

The Story Tracks include a Track Recording options button (  ) with a

Recording Options menu (  ).

Click the Record Options menu (  ) to display the Animation Track
Recording options dialog.

Story window A. Record Options menu B. Recording Options menu

When you click the Recording options button (  ) in the Story window's
Animation Track, Character Track, or Camera Animation Track,
the Track Recording options window for that specific track displays. In
the Track Recording options window, the Always display checkbox is turned
on by default. If you turn this checkbox off, then in your next session, you
cannot invoke the Animation Track Recording options window by
clicking the Recording options button.

Animation Track Recording options window A. Always display checkbox turned on by
default
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Unlike the Track Recording options dialog, the Properties window includes
all the Track recording options.

See the Recording Story tracks to memory or disk topic in the Help.

Recording Story tracks to memory or disk
MotionBuilder enables you to view a live scene, record source data to memory,
and record source data to disk. The ability to record to disk becomes crucial
when dealing with very large scene files that can easily outgrow a system's
memory limit. Instead of storing the data into the memory buffer, you can
store the data in real time to disk and also choose to record discrete Animation
track, Character track, and Camera track clip files to disk.

Although the default recording of tracks is set to memory, the advantages of
recording to disk outweigh by far the recording to memory, especially if you
have large scene files and deal with motion capture data.

Before you start recording, make sure the Story recording, clips, and Track
preference settings are set to your needs.

To access the Story preference settings:

1 In the menu bar, select Settings > Preferences.

2 In the Preferences window, click the Story preference option.

The Story preference settings display.
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Story preferences

When you record data, you need to specify in the Story window:
■ the track(s) you want to record,

■ the track Recording options, and

■ whether you want to record to memory or to disk.

Recording Story Tracks via API

You can set a track's ability to record boolean value to true. You can enter a
value for the track or Story's Record to path, although the path must exist.

You can enter the clip naming convention using standard string formatting:
Python : Track.ClipNameConvention = %s_%s %(Track.Name,
Track.ClipNumber)

You can receive a callback after a clip is created.

Refer to the MotionBuilder SDK Help at: http://www.autodesk.com/motionbuilder-
sdkdoc-2013-enu.
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Story Folder and Story Track recording paths

Before you begin recording, you need to set the recording path for your Story
Folders and Tracks. The recording path needs to be defined for each track you
want to record with the exception of tracks within a Folder. For example, you
can set a path for a Folder in the Story window and have the Tracks within
that Folder point to the same path. You can also set a path for a Folder in the
Story window and another path for the Tracks within that Folder. This applies
also to nested Folders and Tracks. Complete lower-level paths overwrite
higher-level paths, while a hierarchy of incomplete paths is assembled to form
a complete path. This enables you to specify only the subfolder in the track,
while the folder contains the base path..

To set a recording path for a Story Folder:

1 In the Story window, double-click a Folder to display its properties in
the Resources window.

Story Folder shown selected

The Story Folders, unlike the Story Tracks, do not have a Recording

options (  ) and Recording Options menu (  ) that enable
you to define the recording path.

2 In the Resources window, in the Properties, expand the selected Folder
to display its contents.
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The recording paths for all Story Folders are set via the Property Resources
window.

3 Click  .

4 In the Open Directory window choose a path for recording and then
click OK.

The recording path is set and is now shown in the RecordClipPath
field.

Recording Story tracks to memory or disk | 103



To set a recording path for a Story Track:

NOTE You can set a Track's recording path via the Property Resources window
(as you would for the Story Folders) or via the Story Track's Recording options

(  ) or Recording Options menu (  ) in the Story window.

1 In the Story window, click the Story Track you want to record.

2 In the Story window, click the Story Track's Recording options ( 

), or Recording Options menu (  ) followed by the Recording

options menu  .

The selected Track's Recording options window displays.
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The properties shown in the Track's Recording option dialog are the
properties that can be animated and therefore recorded.

The default activated (  ) recording properties shown in the preceding
figure are the Translation and Rotation properties

3 Activate the properties you wish to record.

4 Click  .

5 In the Open Directory window choose a path for recording and then
click OK.

TIP You can also set the recording path by entering the path in the Recording
Path field and clicking OK.

Recording Story tracks to memory or disk | 105



Recording data to disk

Recording to disk enables you to (a) record many takes without stopping to
free up memory, (b) record in real time sessions, (c) efficiently aggregate
animation via mocap sources, and (d) open the recorded scene and continue
working on it as opposed to rebuilding the scene from scratch.

The data you want to capture may be what you see when you look through
a Director's camera (although sometimes, the Director doesn't want to shoot
cameras at the time the actors are recorded—he's just collecting animation
assets for later use).

For example, if you have a scene with motion capture data that shows a
Character driven by motion capture markers and a skeleton and marker data
driving a constrained camera (as shown in the top Viewer pane in the following
figure), you can record the motion capture data, however, what you really
want to record is the end result—the data recorded to the camera and the data
recorded to the retargeted character. In the following figure, the bottom Viewer
pane displays what you see through a Director's camera.
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When you record data to disk, you need to specify:
■ where you want the data to be recorded

BEST PRACTICE Define the same track recording path for all your tracks.

■ the token naming convention (ClipNameConvention)

The default naming convention is:

<Name>_<StartDate>_<StartTime>

Each take requires a unique name. You can customize tokens. You can add
the track name, the timecode, the start time, the end time, the take name,
and static text. The purpose of defining tokens for your recording tracks is to
optimize recording file management.
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You can use the following keys to define the naming convention for your
clips:
■ <Name> The current track Name property

■ <TakeName> The system's current take name

■ <StartTCValue> the TimeCode value using the timebase of the Transport
Controls rate

■ <StartFrameValue> the frame value according to the Transport Controls

■ <StartDate> the current day, YYYY-MM-DD as per international ISO 8601
standards

■ <StartTime> the current time, HHMMSS as per international ISO 8601
standards

You can also enter any alpha numeric string value (no special characters). If
you do not enter an iteration value to keep the clip name unique, new clips
overwrite current clips.

To record a Story Track to disk:

1 In the Story Controls, click the Record to memory/disk option if the

record option is set to memory (  ). If the Record to memory/disk

option is set to Record to disk (  ), proceed to the next step.

NOTE The default Record to memory/disk option is set to memory ( 
).

2 In the Story Controls, select the Track you want to record.

3 Set the path for the Track recording either via the Story window or the
Property Resources window.

Refer to the procedure To set a recording path for a Story Track (page
104) and to the procedure To set a recording path for a Story Folder (page
102).

4 In the Story window, click the selected Track's Recording options

button (  ).
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The contour of the selected Track's Recording options button ( 

) changes from grey to green (  ) once the recording path is set.

The Track's Recording options dialog displays the recording path and
any other changes you made to the track recording options.

5 In the Track Recording options dialog, click OK.

6 (Optional) To verify the Track's recording path, in the Property Resources
window, expand the Track and expand its Recording properties to view
its contents.

The RecordClipPath field displays the Track's recording path.

NOTE You can set Record via the Property Resources by enabling
RecordToTrack Recording property.
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7 In the Transport Controls, click Record (  ).

The Transport Controls Record button turns red (  ), showing

it is in a record state and the Record Mode button (  ) in the Story

window turns green (  ).

8 In the Transport Controls, click Play (  ) to start recording.

In the Story window, the Record Mode button is red (  ), indicating
data is being recorded.

When you record to disk, an .fbx file template containing the Track's
contents (such as bones) is created. When the recording is finished, the
.fbx file template and the recorded track's animation are merged in an
.fbx file.

NOTE The .fbx file templates are created as MotionBuilder cannot record
directly to FBX.

In the motion capture example used, even though you are not hooked
live to a motion capture system you are recording a live constraint. There
is no actual data on the retargeting character or camera. MotionBuilder
is writing this data on disk as it is being recorded.

The Story Tracks now represent the recorded data. The recorded data is
inserted in the 3D record Editorial timeline. If you manipulate the objects,
the animation is recorded.

Story tracks representing the recorded data
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The Tracks display the token naming convention you defined.

<Name> <StartTCValue> <StartFrameValue> <StartDate>
<StartTime> <TakeName>

9 In the Transport Controls, click Stop (  ).

NOTE You can stop, and resume your recording as often as you need to.

The Tracks in the Story window are now gray, meaning they are just a
representation of the tracks recorded to disk. The Tracks are in fact
unloaded.

If you prefer to have the recorded Tracks loaded as opposed to unloaded
after the recording, you need to change the Story recording preferences.

To reload into the Story window the Story Track recorded to disk:

■ In the Story window, right-click the Story Track you want to reload and
from the contextual menu, select Load/Unload > Load Clips.

The following figure shows one Story Track was selected to be reloaded.

The recorded Story Track is loaded into the Story window, enabling you
to edit the track. The Story Track is no longer gray, meaning it is loaded.
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NOTE Remember you can set recording preferences to have clips unloaded or
loaded after the recording finishes. Setting the clips to loaded once the recording
finishes enables you to use the clips as soon as they are loaded. Setting the clips
to unloaded while recording enables you to record one clip after another without
affecting recording performance.

See the Story preferences topic in the MotionBuilder Help.

To record a Track over the current clip:

1 In the Story window, set the start time for the new clip.

2 In the Transport Controls, click Record (  ).

The new clip overwrites the current clip but not necessarily from the
beginning to the end. The new clip overwrites the portion of the current
clip whose end time equals the start time of the new clip. The original
clip's data is still there. Only the representation of the original clip is
changed.

Recording data to memory

If you have small scene files, if you want to see the results of the recording
immediately, or if you do not need to concern yourself with memory, you
can opt to record to memory or to disk but loaded back into memory.
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The procedure for recording Story Tracks to memory is similar to the procedure
for recording Story Tracks to disk. Instead of selecting the Record to disk (

 ) option, you select the Record to memory option (  ).

To record a Track over the current clip:

1 In the Story window, set the start time for the new clip.

2 In the Transport Controls, click Record (  ).

The new clip overwrites the current clip but not necessarily from the
beginning g to the end. The new clip overwrites the portion of the current
clip whose end time equals the start time of the new clip.

This procedure is also valid also for Story Tracks recorded to disk.

To record Story Tracks to memory:

1 In the Story window, select the Track you wish to record.

Customizing Image Sequence Frame Rate in Video
Settings

When you import an image sequence in MotionBuilder, by default, it uses
the system frame rate (selected in the Transport Controls window) to play an
image sequence. If you change the frame rate in Transport Controls, then
the new frame rate takes effect for sequencing images as well.

In this release, the Use system frame rate option is available as a checkbox,
which is on by default. This option allows you to:
■ Choose other frame rates from the drop-down list

■ Enter your own frame rate

■ Use the same frame rate that you set in the Transport Controls window

NOTE The Use system frame rate option is active, only if you select the Image
sequence option. If you do not select this option, then the Use system frame
rate option is disabled and refers the frame rate in Transport Controls.

All the frame rates in the Transport Controls are also available in the
TimeMode drop-down list.
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To enter the frame rate at which you want to play the images in sequence:

1 Choose Custom from the TimeMode drop-down list.

The Custom Frame Rate dialog box appears.

2 Enter a frame rate of your choice in the Insert new frame rate text
box.

Transport Controls window and Video Settings tab A. Image sequence checkbox
B. Custom frame rate (10 fps) C. Frame rate in Transport Controls window

TIP Press the left or right mouse button and drag on this text box to decrease
or increase the frame rate.

TIP You can also choose Custom from the Resources window > Properties
tab > TimeMode drop-down list, and then enter a frame rate in the FrameRate
text box.

See the Customizing Frame Rate for playing images in sequence topic in the Help.
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Roll Bone Enhancements
In the previous releases of MotionBuilder, the user had limited control on the
behavior of Roll bones when rotating a limb of a character. This was a usability
issue with the HumanIK implementation in both Maya and MotionBuilder.
Moreover, the terminology used to refer properties and the manner in which
they were exposed caused confusion to the user.

The new HIK 4.5 Character Solver is now implemented in both Maya and
MotionBuilder. This Solver contains all the required Roll bone properties to
solve this usability issue. Now the properties are easy to use and allow a user
to decide which bone will be influenced to what degree, for a given limb. For
example, Forearm Roll will be influenced to 40% and Elbow at 0%.

The property names are also changed to be consistent in Maya and
MotionBuilder. The old Roll bone property names and their corresponding
new names are listed in the following table:

New Roll bone property nameOld Roll bone property name

Left Forearm RollLeftForeArmRollEx

Left Elbow RollLeft ForeArm Roll

Left Arm RollLeftArmRollEx

Left Shoulder RollLeft Arm Roll

Right Forearm RollRightForeArmRollEx

Right Elbow RollRightForeArm Roll

Right Arm RollRightArmRollEx

Right Shoulder RollRight Arm Roll

Left Leg RollLeftLegRollEx

Left Knee RollLeft Leg Roll
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New Roll bone property nameOld Roll bone property name

Left UpLeg RollLeftUpLegRollEx

Left Hip RollLeft UpLeg Roll

Right Leg RollRightLegRollEx

Right Knee RollRight Leg Roll

Right UpLeg RollRightUpLegRollEx

Right Hip RollRight UpLeg Roll

NOTE The new values do not include roll influence on the Elbows and Shoulder,
by default.

New Roll bone properties and their values

The new values do not include roll influence on the Elbows and Shoulder, by
default.

For the property values, the value of a Roll bone (Left Forearm Roll) cannot
be higher than the corresponding <parent> Roll value (Left Elbow Roll). You
cannot extract more on the Roll bone than on the corresponding Elbow, only
less. The same applies to the shoulder and Leg Roll values.

When Roll bones do not exist or not defined, the corresponding Roll bone
property will be disabled (non-editable), and the remaining Roll properties
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will be applied to the corresponding parent (Elbow, Shoulder, UpLeg, and
Knee).

The Roll amount is defined by the Roll Extraction Mode. The two extraction
modes are:
■ Relative — takes care of HIK-generated Roll amounts

■ Absolute — takes care of both user generated and HIK-generated Roll
amounts

See the Modifiers topic in the Help.
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Additional Changes

The following topics describe additional changes to this release of the MotionBuilder
software product.

Sharing Help Topics

This release of the MotionBuilder Help includes a Share  UI button at the
top right of the topic page enabling you to send a link to the Help topic via
your default e-mail application.

To share a Help topic:

1 In the Help, go to the topic page you want to share.

2 At the top right of the topic page, click  .

Your default e-mail application launches with an e-mail that includes the
topic subject and a link to the topic in the body of the e-mail.

Resolution-Independent Editing Layout
Unlike the Scripting layout, Preview layout, and custom layout, the Editing
layout remains consistent regardless of your screen's resolution. thus providing
a uniform editing layout experience on all systems.

See the Layouts topic in the Help.

2
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Profiling Center Window
From the Evaluation > Parallel Evaluation drop-down list, the:
■ Parallel Simple option is removed

■ Parallel Advanced option is renamed as Parallel

The Reset to Default button is removed, and the following three buttons are
added to provide more control on user settings:
■ Save User Settings

■ Reset User Settings

■ Restore Default Settings

See the Profiling Center window topic in the Help.

FCurves Window

The FCurves toolbar is added with the new Retime Tool (  ) icon. See
the Retime Tool topic in the Help.

The names of the following menus in the FCurves contextual menu are
changed from:
■ Display to View

■ Snap to Edit

■ Extrapolation to Pre/Post Extrapolation

Moreover,
■ the Cut, Copy, and Paste options are removed from the main menu.

■ two more sub-options, Copy and Paste, are added to the Edit menu.
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See the FCurves contextual menu topic in the Help.

Namespace Support for Story Tracks
In this release, you can add namespaces of object names to their corresponding
story tracks. To make this possible, the Add/Remove Namespace option
is added to the Story tool contextual menu. Clicking this contextual menu
option, displays the Add/Remove Namespace dialog box with all the
namespaces added to the scene objects.
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To add namespaces to story tracks:

1 From the Story tool, select one or more story tracks, right-click on them,
and select the Add/Remove Namespace contextual menu option.

The Add/Remove Namespace dialog box appears. By default, the
Add tab displays all the namespaces that are added to the object names.

2 From the Current Namespaces in Scene list box, select a namespace
and click Ok.

The namespace is prepended to the names of the selected story tracks.
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TIP Press Ctrl+Z to undo any namespace operation that you perform on
objects in the Navigator window and story tracks in the Story tool.

Notice that all the namespaces in objects are displayed in the Navigator
> Namespaces folder.

For replacing namespaces with another namespace and removing namespaces
from story tracks, follow the procedures in the Namespace topic in the Help.

Refreshing the Viewer Window
Consider that you are viewing an animation scene in the Viewer. When you
open another application, for example Windows Explorer, it opens up on top
of the Viewer. Now the Windows Explorer is the active window and the
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Viewer window is inactive. This stops playing the animation scene in the
Viewer, keeping it in an idle state. You need to bring back the focus on the
Viewer to make it active and resume the play.

In the virtual production environment, it is important that the Viewer gets
automatically refreshed when working with different applications. To achieve
this, turn on the Always refresh viewer checkbox in the Profiling Center
window. Turning on this checkbox keeps the Viewer window in an always
active state for that particular session only.

To turn on the Always refresh viewer checkbox permanently, click the
Save User Settings button in the Profiling Center. This saves the setting
to the MotionBuilder configuration.

Profiling Center A. Always refresh viewer checkbox B. Save User Settings button

See the Profiling Center window topic in the Help.

Video Settings
In the Video Settings window, the FPS static text box that displays system
frame rate is changed to Frame Rate drop-down list.

The Use system frame rate option is added. This option enables you to
choose a different frame rate, which is independent of what is set in the
Transport Controls window.
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A. User system frame rate check box B. Frame Rate drop-down list

See the Video settings topic in the Help.

Setting Network License Timeout
The License Timeout option enables you to define the duration a
MotionBuilder session can be idle before the network license is reclaimed by
the license server. You set the license timeout in the MotionBuilder Application
preference settings.

If you choose to set a time for the license timeout, the license is reclaimed by
the license server if MotionBuilder is idle on the computer for more than the
timed out period you define in the MotionBuilder Application preference
settings.
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Application preference settings for license timeout

See the Application preferences topic in the Help.

Python and OR SDK Sample Files
This release includes new Python and SDK sample files.

The following lists the new Python and SDK sample files shipped with the
software product.

Python Sample Files

■ HUD.py

■ TimecodeKeying.py

■ ImageSequenceFrameRateChange.py

■ SetPropertyStaticIfPossibleOption.py
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■ CreateProfilingEventsLog.py

■ MultiPatchGeometry.py

■ AudioRendering.py

■ NamespaceOperationsOnTrack.py

OR SDK Sample Files

■ ORDeviceTimeCode

■ ormaterial_template

■ ordevice_syncreference

FBX SDK Support
This release supports Autodesk FBX SDK version 2013 to align with other
Autodesk software products.

Broadcast Wave Format (BWF) File Support
This release supports the audio Broadcast Wave Format (BWF), a format for
audio data files in broadcasting.

DDS File Format Support
This release extends the support of DDS (DirectDraw Surface) (binary) file
format used for storing compressed textures to the GPU to DDS BC4, DDS
BC5, DDS ATI1, and DDS ATI2 files.

MotionBuilder now supports the ability to import DDS BC4, DDS BC5, DDS
ATI1, and DDS ATI2 files at full resolution.

You can load a .dds file as a texture to a material. See  "Adding a texture to a
material" in the MotionBuilder Help. You can use a .dds file as a background
or foreground texture.

You can also load a .dds file via File > Import Video and use it as a video file.
The following properties are now supported for the DDS file format:
■ ImageSequence

■ ImageSequenceOffset
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■ UseSystemFrameRate

■ MaxMipMapResolution

These properties are accessible via the Property Resources.

The maximum predefined resolution are: Full, 1, 2, 4, 8, 16, 32, 64, 128, 256,
512, 1K, 2K, 4K, 8K, and 16K.
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CgFX Support
This release supports an updated version of the CgFX library.

MotionBuilder now supports version 3 of the CgFX library, enabling you to
take advantage of the latest CgFX shader technology.

Unsupported Audio File Formats
Some audio file formats supported in the MotionBuilder 2012 release are not
supported in this release.

The following audio file formats are not supported in this release:
■ .mp2

■ .mpeg

■ .mpg

■ .mpg4

■ .sd2

■ .ulw

■ .vwf

For a list of supported file formats as audio assets, see the Loading audio files
topic in the Help.

Enhancements in Timecode
In this release, the Timecode frame rate precision error is fixed, more frame
rates are added, and the hours unit is displayed as two digits.

Timecode precision

In the previous release, the playback frame rates such as 23.976, 29.97, 72,
and so on were not precise over longer periods of time. The precision error in
these frame rates are fixed in this release. The new precision and rates can be
stored in FBX.

The new frame rates 48, 59.94, 60, 72, 96, and 1000 are added in all the Time
Format menus in MotionBuilder.
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For a list of Timecode frame rates, see the Transport Controls contextual menu
topic in the Help.

Timecode hour display

The Timecode hours is now displayed as two digits as per industry standard.
For example, 00:01:15.

Align Control Rig property
The Rig Align property in the previous release is replaced by the new Align
Control Rig property.

The Rig Align property has been replaced with the Align Control Rig property
in the Control Rig properties for a character. This change is to provide only
one property to solve the Control Rig alignment using the HIK 2013 Solver.
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