Open Light 2010 Object Enabler Readme

The Open Light 2010 Object Enabler makes objects created with the Open Light Extension come to life in 2010 releases of AutoCAD, AutoCAD Architecture, AutoCAD MEP, AutoCAD Electrical, AutoCAD Mechanical, AutoCAD Map 3D, Civil 3D, Civil, and Mechanical Desktop. This new release leverages ObjectDBX technology allowing object data created in Open Light 2010 to be accessed outside of AutoCAD Architecture with Open Light Extension.

Open Light Object Enabler is a freeware application distributed to Autodesk customers at no charge for the purpose of fully accessing Open Light objects in drawing files. Without this object enabler installed, you can share drawings using proxy graphics representations or the Export to AutoCAD command.

What do you want to do?
Known Issues with the Open Light 2010 Object Enabler


Known Issues with the Open Light 2010 Object Enabler

When externally referencing an OpenLight drawing into another file, you may not see the OpenLight objects. There are two options to correct this:

For users of AutoCAD Architecture 2010, AutoCAD MEP 2010, Civil 2010, or Civil 3D 2010, copy in and overwrite the necessary display configurations and sets from the drawing which contains the Open Light objects. An example of this would be to use the Display Manager command and import the 1:50 & 1:100 display configurations and the Plan 1:50 and Plan 1:100 display sets, overwriting the existing versions if present in the current drawing. Then set that display configuration to be current.

For all other users, get a template file from the creator of the OpenLight 2010 file and use that for externally referencing in all drawing files.