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10 On the Basics design bar, use the 
Text tool to add notes to the legend. 

 
11 Open the schedules sheet.  

 
Drag the legend onto it from the 
project browser. 

 
12 Save and close the project.   

Exercise 18G: Material Takeoffs 
A material takeoff is just a specialized form of a schedule. This exercise leads you through creating a material takeoff view for the walls. 
 
The exercise uses the same data set as the previous exercise but does not build on the information created in that exercise. 
 
 Create a Material Takeoff List   

1 On the File menu, click Open > 
Browse. Find the file i_Unit 18g – 
Start delivered with the workbook. 
Open the file. 
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2 On the View menu, click New > 
Material Takeoff. 

 

3 In the New Material Takeoff dialog 
box: 
• Under Category, select Walls.  
• Click OK.  
 

 

 

4 On the Field tab, add the fields shown 
in the illustration at right. 
 
Click the Filter tab. 
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5 
 

Leave Filter By set to None. 
 
Click the Sorting/Grouping tab. 

 

 

6 On the Sorting/Grouping tab: 
• Set Sort By to Material Name. 
• Select the Footer check box, and 

set to Title, Count, and Totals. 
• Select Blank Line for the sort 

criteria. 
• Clear the Itemize Every Instance 

check box. 

 

 

7 On the Formatting tab: 
• Select Material: Area. 
• Select the Calculate Totals check 

box. 
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8 Click OK. 

 

The materials schedule is now part of the 
project. On your own, add the cost field 
and add a calculated parameter that 
multiplies the area field times the cost field.
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Unit 19 
Theory: Time 

Revit Architecture: Phasing 
This unit explains how the time parameter is managed in Revit Architecture. 
 
1 Open file i_Unit 19 – Start.  

2 In the project browser, right-click 
Floor Plan Level 2. Click Duplicate. 
 
Rename the new view Level 2 – 
Demolition. 

 

 

3 In the Level 2 Demolition plan, open 
the view properties and change:  
• Phase to New Construction. 
• Phase Filter to Show All. 

To open View Properties you can right-click the 
view in the project browser and then click 
Properties, or right-click anywhere in the view 
and click View Properties on the shortcut 
menu. 
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4 Click OK to return to the drawing 
window. 

Note how the appearance of the existing 
components changes when the phase of the 
view is changed. 
 
The first thing you should notice is that views 
have a parameter called phase.  
 
Depending on the value of this parameter, all 
components created (or demolished) in this 
view, have their Created Phase set as the one 
the view belongs to. In this case, the walls and 
doors you demolish were created in the 
Existing Phase and are demolished in the New 
Construction Phase. 

5 Click one of the walls in the plan. 
Open its properties. 
 
Verify that Phase Created is set to 
Existing and Phase Demolished is 
set to None. 

 

For every object in the building model there is 
also a phasing property. For each object, Revit 
Architecture tracks the phase created and the 
phase demolished. As noted earlier, the phase 
created is read from the phase property of the 
view in which it is created. 

 Demolish Walls and Doors  

6 On the toolbar, click Demolish. Click 
the walls in the middle of the building 
(see image). 
 
 
 
Also click the wall dividing the 
bathroom area on the bottom left (see 
image). 

When you demolish a component, its display 
changes according to the phase filter assigned 
to the view. 
 
Phase filters are found in the view properties. 
 
The override of the display of the components 
is defined in the phase settings: Settings > 
Phases > Graphic Overrides tab. 
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7 Add new walls and doors as shown in 
image. You don’t need to be exact 
about positioning the components, but 
you should design a plan that makes 
sense. 

As you add the walls, verify that the height is 
set to Level 3. 

8 In the project browser, duplicate the 
Level 2 Demolitions plan view. 
Rename it to Level 2 – Complete. 

  

9 Open the view properties.  
 
Change the Phase Filter parameter to 
Show Complete. 
 
Click OK to exit the dialog box. 
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10 On the Room and Area design bar, 
click Room. Create (and rename) the 
rooms as shown in the image. 
 
For the WC to the left of the kitchen: 
Select the tag. 
On the options bar, select Leader. 
Click the drag symbol under the tag 
number. 
Drag tag to the desired position. 
 

 Create Schedules for the 
Phases 

  

11 In the project browser, under 
Schedules/Quantities, right-click the 
Schedule table Room Schedule – 
Existing. Click Duplicate. 
 
Rename it to Room Schedule – New 
Construction.  

 

12 In the project browser, right-click the 
new schedule. Click Properties. 

  

13 Change the Phase parameter to New 
Construction. 
 
Click OK to close the window. 

The schedule filters to the rooms created in the 
new construction. 
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14 In the project browser duplicate the 
3D view: 3D Existing Cropped and 
rename the new view 3D Demo 
Cropped. 
 
Open the new 3D view properties and 
change the Phase to New 
Construction. 
 
Click OK. 

 

15 Duplicate this 3D view. Name the new 
view 3D Complete Cropped. 
 
Open the new view’s properties. 
Change the Phase filter to Show 
Complete, and Phase to New 
Construction. 
 
Click OK. 

 

 

16 Set the existing sheet A101 Unnamed 
current. 
 
Drag the view Level 2 Demolition on 
the sheet. Position it in the middle, as 
shown in image. 
 

This sheet already has the original views 
placed on it: 
• 3D Existing Cropped.  
• Existing Room Schedule.  
• Level 2 (Floor Plan).  
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17 Drag onto the sheet the following 
views:  
• Level 2 – Complete.  
• 3D Demolition Cropped. 
• 3D Complete Cropped.  
• Room Schedule – New 

Construction.  
 
Position them as shown in image. 

The sheet is complete. 

 
Save your file if you want to keep it for reference. This data set looks like the data set for Unit 20. However the file i_Unit 20 – Start.rvt has added Design Options 
in place that are used in the exercise steps. 
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Unit 20 
Theory: Variation   

Revit Architecture: Options 
 
This unit guides you through the powerful Design Options feature. You start using a file that already contains a couple of design options. 
 
 Review Design Options   

1 Open file i_Unit 20 – Start. This file 
contains an option set with two 
different design options.  
 
Open Floor Plan views: 
Level 2 – Option 1 and Level 2 
Option 2. 
 
Tile windows to display both options. 

Note how tiling windows lets you visualize 
both—or more—options in different views. 
 
Both views represent the second floor of the 
building. All components are held in the 
building model. However, the interior walls of 
the floor, along with the stair and east wall, are 
held in Design Options. 

2 In Plan: Level 2 – Option 1, try to click 
the door of Office 212. 

 

When the project contains Design Options, the 
options bar displays a check box to allow 
selection of components that are part of the 
option set: 

 
This is just a check to keep you from 
inadvertently changing objects that are in a 
Design Option. 

 View the Options   

3 Right-click the toolbar, and verify that 
the Design Options toolbar is selected. 

 

In this file you have only one option set, but 
you can have as many as you want. Normally, 
an option set is a specific part of a building 
where you want to try different design 
alternatives. An option set can contain as 
many options as you want. 

4 Click the Design Options tool.  
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5 In the Design Options dialog box, 
select Option Set 1 – Standard, and 
click Edit Selected. 
 
Do not close the Design Options 
dialog box yet. 

The Now Editing window displays the active 
edited option. 
 
 

 When you edit an option, all 
components that are not part of the 
option are dimmed. 

With two options as in this case, you have 
three sets of objects: 
• Those in the main model. 
• Those in sets unique to each of the 

options. 
When you are editing an option, you can see 
and refer to objects in the main model, but by 
default you cannot edit them. 
 

6 In the Design Options dialog box: 
• Click Finish Editing. 
• Click Curtain Wall. 
• Click Edit Selected. 
• Click Close. 
•  
•  
 

The options bar displays a check box that 
allows selection of components that belong to 
the main model (not to an option set).  

 

7 Click Edit Option to end editing the 
curtain wall option. 

You return to standard Edit mode with neither 
option open. 

 Copy Elements Between Options You can copy and paste elements from one Design Option to 
another. 

 

8 Click Edit Option. On the list, select 
Options Set 1: Standard (Primary). 

 

This shortcut bypasses the Design Options 
dialog box.  
 
This tool is cyclical. If you click it again, you 
exit Edit mode (don’t do this yet). 



Revit Architecture Student Workbook Autodesk 
 

292 

9 Select the stairway on the east end of 
the building.  
 
On the Edit menu, click Copy to 
Clipboard. 

Copy to Clipboard and Paste Aligned (Same 
Place) constitute an easy way to replicate a 
situation among different options. 
 
You can also duplicate an option within an 
option set by selecting it in the Design Options 
dialog box and clicking Duplicate. 

10 On the Design Options toolbar, click 
Edit Option to finish editing the 
option. 

 
The Design Options toolbar allows for quick 
selection of the available Design Options. 

11 Click Edit Option again. From the list, 
select Option Set 1: Curtain Wall. 

 

12 On the Edit menu, click Paste Aligned 
> Current View. 

 
The stair now is part of this option. 

13 In the Level 2 Option 2 window, select 
the stair.  
 
On the options bar, click Edit. 

         

When editing stairs, you enter Sketch mode. 

14 Delete the boundary on the right edge 
of the landing. 
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15 Click the boundary tool on the design 
bar. 
 
On the options bar: 
• Click Draw. 
• On the options bar, set the 

template to the Arc tool. 
• Redraw the landing boundary with 

the arc by clicking the endpoint of 
the lines on either side of the 
staircase until you see the desired 
arc. 

 
Click Finish Sketch. 

       

 

16 Add walls and doors to complete the 
design, as shown in image. 

 

17 On the Basics design bar, click Room. 
 
Click in all the empty rooms in the 
option. After placing the tags, rename 
the rooms as shown in image. 
 
Make sure you are still editing the 
option before adding the rooms if 
you want the rooms to be part of the 
option.  
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18 On the Design Options toolbar, click 
Edit Option to finish editing the 
option. 
 

 

 

The two plan options are now complete. 

 Assign an Option to a View You have been working in two views that are both views of the 
second level. 

The only difference between these is a setting 
in the view properties assigning one option or 
the other. 

19 Open 3D View – Option 1.  By default, a view shows the option marked 
primary, in this case the standard option. 

20 In the project browser, right-click the 
3D view 1. Click Duplicate. 
 
Rename Copy of 3D View 1 to  
3D View - Option 2. 

  

21 Open the View Properties dialog box 
by right-clicking the view in the project 
browser and clicking Properties.  
 
Click the Edit button next to the 
Visibility/Graphics Overrides 
parameter. 

  

When there are design options in the project 
file, Revit Architecture adds a new tab in the 
visibility settings of the views.  
 
You can display any option in any desired 
view: plans, elevations, sections, and so forth. 

22 On the Design Options tab, select 
Curtain Wall from the list under Option 
Set 1. 

 

The list displays the available options for the 
option set. 
 
When the value is set to Automatic, the view 
displays the primary option but switches to 
show the one you are modifying when in Edit 
mode. 
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23 Click OK to close each dialog box and 
see the changes. 

 

 Assign an Option to a Schedule   

24 Create a duplicate schedule for the 
option: 
• In the project browser, duplicate 

the Schedules/Quantities: Room 
Schedule. 

• Rename the new schedule view 
Room Schedule – Curtain Wall 
Option. 

 

Schedules are views as plans and sections. 
They can display the desired design option to 
evaluate the different quantities or costs 
according to the option displayed. 

25 Assign the option to the new schedule 
view: 
• Right-click the Room Schedule – 

Curtain Wall option. Click 
Properties. 

• Click the Visibility/Graphics 
Overrides Edit button. 

• On the list, select Curtain Wall.  
• Click OK. 

   
Although access to this parameter is a bit different for the 
schedule than for the 3D view, the theory is the same. A 
schedule is just a text view of the building model. 

 
 

  

 

You now have two different room schedules. 
The rooms unique to each option are listed 
along with those that are common to both 
options such as the meeting room, WC, and 
Service. 

 Place Views of the Options on a   
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Sheet 

26 In the project browser, double-click the 
sheet A101 – Options Compared. 

  

27 In the project browser, drag Floor 
Plan – Level 2 Option 2 onto the 
sheet as shown in the image. 
 
Place the following views on the sheet, 
as shown in the image:  
• 3D view Option 2. 
• Door Schedule Curtain Wall 

Option. 
• Room Schedule – Curtain Wall 

Option. 

You have to turn on the crop region of the 3D 
view Option 2 and adjust the boundaries of the 
crop region to fit on the sheet.  

 Optional Exercise: Change 
Primary Option and Accept 
Primary 

When a decision about the option has been made and you are 
ready to continue with the project without Design Options, you 
set the Design Option you want to keep as the primary design 
option and then accept it. 

This deletes any items you have in the 
nonprimary option and deletes any views set to 
the nonprimary option. 

 Because the following steps delete the 
nonprimary elements and views, save 
your project if you want to keep your 
progress to this point. 

  

28 Open Floor Plan Level 2 – Option 2.   

29 On the Design Options toolbar, click 
Design Options. 

 

30 Select the Curtain Wall option. Click 
Make Primary.  

            

A warning may appear when accepting the 
primary option, depending on how walls are 
joined.  
 
You can normally ignore these warnings and 
proceed with the next step. 
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31 Select Option Set 1. 
 
Click Accept Primary. 

       

 

32 Click Yes when the dialog box opens. Because you are finished with the options 
process, accepting the primary option deletes 
all the elements that are stored in Option Set 
1: Standard option. 
 

33 Click Delete in the dialog box. 

 

Because you are deleting all the objects that 
are shown in these views, deleting the views 
makes sense. 
 
The other views, such as 3D View 1, as well as 
the schedules, are set to display, which 
automatically displays the primary option. 
These views are not deleted when you accept 
the primary option. 

34 The Design Options dialog box is now 
empty. 
 

After you click the Accept Primary button, all 
options disappear and the components in 
the primary option become part of the main 
model. 
 
Note that the sheet now displays the same 
information twice and the views display the 
same model. 
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