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Introduction

Welcome to the Revit Architecture 2010 Families Guide! Families are an integral part of working in Revit Architecture,
and key to creating custom content.

In this guide, you learn:

■ how to use families in your projects

■ concepts of parametric design and family creation

■ best practices to use when creating your own families

To better help you understand how to work with families, this guide contains conceptual explanations, hands-on tutorials,
and reference information.

Audience and Prerequisites

This guide is intended for the beginning, intermediate, and advanced Revit Architecture families user. Although any
sketching and 2D or 3D modeling experience is helpful to understand how to work with families, before you begin to
work with this guide, you should have a basic understanding of Revit Architecture. If you do not, it is recommended that
you use the tutorials included in the software. Access the tutorials by clicking Help ➤ Tutorials.

Training Files

The hands-on tutorials included in this guide use templates and family files that you download from
http://www.autodesk.com/revitarchitecture-familiesguide. Most of these files have an .rfa, .rte, or .rvt extension, and are extracted
by default to folders in C:\Documents and Settings\All Users\Application Data\Autodesk\RAC 2010Training Files
(Windows XP) or C:\Program Data\Autodesk\RAC 2010Training Files (Windows Vista).

1
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Understanding Revit
Architecture Families

All of the elements that you add to your Revit Architecture projects – from the structural members, walls, roofs, windows,
and doors that you use to assemble a building model to the callouts, fixtures, tags, and detail components that you use
to document it – are created with families.

By using predefined families and creating new ones in Revit Architecture, you can add both standard and custom elements
to your building models. Families also provide a level of control over elements that are similar in use and behavior, allowing
you to easily make design changes and manage your projects more efficiently.

What Are Families?
A family is a group of elements with a common set of properties, called parameters, and a related graphical
representation. Different elements belonging to a family may have different values for some or all of their
parameters, but the set of parameters (their names and meanings) is the same. These variations within the
family are called family types or types.

For example, the Furniture category includes families and family types that you can use to create different
pieces of furniture, like desks, chairs, and cabinets. Although these families serve different purposes and are
composed of different materials, they have a related use. Each type in the family has a related graphical
representation and an identical set of parameters, called the family type parameters.

When you create an element in a project with a specific family and family type, you create an instance of
the element. Each element instance has a set of properties, in which you can change some element parameters
independent of the family type parameters. These changes apply only to the instance of the element, the
single element in the project. If you make any changes to the family type parameters, the changes apply to
all element instances that you created with that type.

Example: Creating a Furniture Element with a Family and Type
When you create an element in a project, that element is organized within the project first by element
category, then by family, family type, and by instance. All 4 levels provide a different level of control of the
element in your project. The following example demonstrates how you can create and control a bookcase
in a project.

2

3



Determining the Element Category

All families that are in use or are available in your projects (and templates) are visible in the Project Browser
under Families, grouped by element category.

The category defines a top level of identification and behavior for the element. When you start the command
to create a piece of furniture , you automatically determine that the element will belong to the Furniture
category. The category sets the basic role of the element within the building model, determines which
elements it will interact with, and specifies that it will be included in any furniture schedules that you create.

Selecting the Family

By expanding the Furniture category, you can see that it includes a number of different families. All the
furniture that you create in this project (unless it is specialized or you load other families), will belong to
one of these families.

By itself, a family usually does not provide enough information to create a desired element in your project.
While the family narrows the definition of the element you are creating in terms of its basic characteristics
and graphic representation, it does not specify the size, material, or other specific characteristics of the
element. For this reason, families include family types.

Specifying the Family Type

Family types are variations on the kind of element the family represents, and are shown under the furniture
families shown below. For any of the types listed below, the family provides you with the kind of furniture
you want to create (a bookcase, cabinet, chair, or desk), while the family type specifies the dimensions,
material, and a few other characteristics of the element that you can create.
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Creating an Instance

To add any of the furniture types in the Bookcase family to a project, start the Component tool. The Type
Selector lists the available Bookcase family types in the project, listed first by family, then by name. You
select the type that you want, and add it to the project.

When you create an element in your project, you create what is called an instance of the family type. If you
create one bookcase element, you have one instance of the type in your project.

If you create four bookcases , you have four instances of the type in your project.

Example: Creating a Furniture Element with a Family and Type | 5



Making Modifications

After you create an element in your project, you can make a number of changes to it. If you select one or
more instances of the bookcase in the previous example, and then right-click and click Element Properties,
you display the Instance Properties of the bookcase or bookcases . This is a location where you can make a
number of changes to the element and its parameters.

Changing Instance Parameters

In the Instance Properties dialog, under Instance Parameters, scroll down to view the instance parameters
of the bookcase . You can change any of these values for the instance or instances of the bookcase that you

6 | Chapter 2   Understanding Revit Architecture Families



selected. The changes will not be applied to all the bookcases of that type, only the instance or instances of
the bookcase that you selected.

This family contains an instance parameter that determines whether or not the bookcase includes a door.
In the above illustration, this DoorIncluded parameter is selected. If you clear the DoorIncluded parameter
in the Instance Properties dialog for one of the bookcase instances, that bookcase will no longer display a
door.

Changing Type Parameters

In the Instance Properties dialog, click Edit Type to view the Type Parameters of the bookcase type.

These parameters are shared by all bookcases in the project of the same family type. Any changes that you
make to these parameters are applied to all bookcases of the same family type in the project, regardless of
whether or not you selected them.

Example: Creating a Furniture Element with a Family and Type | 7



Changing the Family or Family Type

You can also change the family type, or family and family type of the bookcase element in the Instance
Properties dialog.

To change the family, at the top of the dialog, for Family, select a new family. In this example, you could
change the bookcase family to one that creates a different style bookcase or you could change the bookcase
to a completely different piece of furniture, like a cabinet.

To change the family type, for Type, select a different type. After you exit the dialog, the instance or instances
that you selected will reflect any changes that you made to the family or family type.

Role of Families in Your Building Models
Now that you have seen the control that you have over elements that you create with families and family
types, you can imagine the flexibility that families, family types, and family parameters provide when
creating and documenting your building models. Families, family types, and type and instance parameters
allow for variation and change in the elements that you create, which is the basis of parametric modeling
in Revit Architecture.

In addition to making the changes that were demonstrated in the previous section, you can use families,
family types, and family parameters to:

■ Add family types to existing families.

■ Create your own family, and by adding family types, create a number of the same elements in a different
size or that feature a different material, without having to draw the component more than once.

■ Create family type parameters in a family that provide optional element geometry or material.

■ Control the visibility and detail level of an element in different types of drawing views.

All families can be two-dimensional, three-dimensional, or both, but not all families have to be parametric.
Elements created with families that do not need more than one size or type may remain non-parametric.

Wall, door, and window families are examples of 3D families, which display accordingly in isometric and
plan views. Annotation detail families are examples of 2D families that do not require 3D representations.
A furniture family is an example of a family that might need separate 3D and 2D representations: a 3D
representation to display in isometric views and a simplified 2D outline to display in a plan view.

NOTE Two- and three-dimensional content from other software packages that you import into Revit Architecture
is not parametric, unless you recreate it as such.

Different Kinds of Families
There are 3 kinds of families in Revit Architecture:

■ system families

■ loadable families

■ in-place families

Most elements that you create in your projects are system families or loadable families. Loadable families
can be combined to create nested and shared families. Non-standard or custom elements are created using
in-place families.
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System Families
System families create basic building elements such as walls, roofs, ceilings, floors, and other elements that
you would assemble on a construction site. System settings, which affect the project environment and
include types for levels, grids, drawing sheets, and viewports, are also system families.

System families are predefined in Revit Architecture. You do not load them into your projects from external
files, nor do you save them in locations external to the project. If you cannot find the system family type
that you need in a project, you can create a new one by changing the properties of an existing type, by
duplicating (copying) a family type and changing its properties, or by copying and pasting one from another
project. Any types that you modify are saved in your project.

For example, you may want to add a wood floor with a specific finish to a project. However, the only similar
floor family type features smaller joists and a different finish. You would duplicate the system family type
in your project, change its name to reflect the characteristics of the new floor, and edit its properties to
feature the new size and finish. System families usually do not require you to model any new geometry.

Because system families are predefined, they are the least customizable of the 3 kinds of families, but they
include more intelligent behavior than the other standard component families and in-place families. A wall
that you create in a project automatically resizes to accommodate windows and doors that you place in it.
There is no need to cut openings in the wall for the windows and doors before you place them.

Loadable Families
Loadable families are families used to create both building components and some annotation elements.
Loadable families create the building components that would usually be purchased, delivered, and installed
in and around a building, such as windows, doors, casework, fixtures, furniture, and planting. They also
include some annotation elements that are routinely customized, such as symbols and titleblocks.

Because of their highly customizable nature, loadable families are the families that you most commonly
create and modify in Revit Architecture. Unlike system families, loadable families are created in external .rfa
files and imported, or loaded, in your projects. For families that contain many types, you can create and use
type catalogs, which allow you to load only the types that you need for a project.

When you create a loadable family, you begin with a template that is supplied in the software and contains
information about the family that you are creating. You sketch the geometry of the family, create parameters
for the family, create the variations or family types that it includes, determine its visibility and detail level
in different views, and test it before using it to create elements in your projects.

Revit Architecture includes a library of content in which you can both access loadable families that are
supplied by the software and save the families that you create. You can also access loadable families from
various sources on the Web.

Nesting and Sharing Loadable Families

You can load instances of families in other families to create new families. By nesting existing families inside
other families, you can save yourself modelling time.

Depending on how you want instances of these families to act when you add them to your projects (as single
element or as individual elements), you can specify whether the nested families are shared or not shared.

In-Place Families
In-place elements are unique elements that you create when you need to create a unique component that
is specific to the current project. You can create in-place geometry so that it references other project geometry,
resizing or adjusting accordingly if the referenced geometry changes. Examples of in-place elements are:

■ battered or tapered walls
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■ unique or unusual geometry, such as a non-standard roof

■ a custom component that you do not plan to reuse

A custom information counter created as an in-place
family

■ geometry that must reference other geometry in your project

Wall caps created on a spiral staircase as in-place
families

■ a family that does not require multiple family types

In-place elements are created similarly to loadable families, but like system families, are not loaded from or
saved to external files. They are created in the context of the current project, and are not intended to be
used in other projects. They can be 2D or 3D, and by selecting a category in which to create them, can be
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included in schedules. Unlike system families and loadable families, however, you cannot duplicate in-place
family types to create multiple types.

Although it may seem easier to create all your components as in-place elements, the best practice is to use
them only when necessary. In-place elements can increase file size and degrade software performance.

Design Environment for Creating Families
The Family Editor is a graphical editing mode in Revit Architecture that lets you create and modify the
families to include in your project. When you start creating a family, you open a template to use in the
editor. The template can include multiple views, such as plans and elevations. The Family Editor has the
same look and feel as the project environment in Revit Architecture, but it features different tools.

A window family open in the Family Editor

The Family Editor is not a separate application. You access the Family Editor when you create or modify the
geometry of a loadable family or an in-place family.

Unlike system families, which are predefined, loadable and in-place families are always created in the Family
Editor. However, system families may contain loadable families that are modifiable in the Family Editor.
For example, wall system families may include profile component family geometry to create caps, moulding,
or reveals.
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Loadable Families
Overview

Loadable families are families used to create building components and annotation elements. Loadable families create the
building components that would usually be purchased, delivered, and installed in and around a building, such as windows,
doors, casework, fixtures, furniture, and planting. They also include some annotation elements that are routinely customized,
such as symbols and titleblocks.

Because of their highly customizable nature, loadable families are the families that you most commonly create and modify
in Revit Architecture. Unlike system families, loadable families are created in external .rfa files and are imported (loaded)
into projects. For families that contain many types, you can create and use type catalogs, which let you load only the
types that you need for a project.

When you create a loadable family, you begin with a template that is supplied in the software and contains information
about the family that you are creating. You sketch the geometry of the family, use parameters to establish relationships
between family components, create the variations or family types that it includes, and determine its visibility and detail
level in different views. When you finish the family, you test it in a sample project before using it to create elements in
your projects.

Revit Architecture includes a library of content in which you can both access families that are supplied by the software
and save the loadable families that you create. You can also access loadable families from manufacturers’ web sites and
from Autodesk® Seek.

Nesting and Sharing Loadable Families

You can load instances of families in other loadable families to create new families. By nesting existing families inside
other families, you can save yourself modelling time.

Depending on how you want instances of these families to act when you add them to your projects (as single element or
as individual elements), you can specify whether the nested families are shared or not shared.

Creating Loadable Families
Using Revit Architecture, you can create families for a project. The software provides many templates,
including those for doors, structural members, windows, furniture, and lighting fixtures, and lets you
graphically draw the new family. The templates contain much of the information that you need to start
creating the family and that Revit Architecture needs to place the family in projects.

3
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Understanding the Family Editor
The Family Editor is a graphical editing mode in Revit Architecture that allows you to create families to
include in your project. When you start creating a family, you open a template to use in the Family Editor.
The template can include multiple views, such as plan and elevation views. The Family Editor has the same
look and feel as the project environment in Revit Architecture, but features different tools located on a single
Create tab.

You can access the Family Editor by:

■ Opening or creating a new family (.rfa) file.

■ Selecting an element created by a loadable or an in-place family type, and then right-clicking and clicking
Edit Family.

Family Editor Tools

■ The Types tool (Create tab ➤ Family Properties panel ➤ Types) opens the Family Types dialog. You can
create new family types or new instance and type parameters. See Creating Family Types on page 31.

■ The Dimension tool (Detail tab ➤ Dimension panel) add permanent dimensions to the family, in addition
to ones that Revit Architecture automatically creates as you draw the geometry. This is important if you
wish to create different sizes of the family.

■ The Model Line tool (Create tab ➤ Model panel ➤ Model Line) lets you draw two-dimensional geometry
for when you do not need to show solid geometry. For example, you could draw door panels and
hardwareduct as 2D rather than use solid extrusions. Model lines are always visible in 3D views. You can
control their visibility in plan and elevation views by selecting the lines and clicking Modify Lines
tab ➤ Visibility panel ➤ Visibility Settings.

■ The Symbolic Line tool (Detail tab ➤ Detail panel ➤ Symbolic Line) lets you draw lines that are meant
for symbolic purposes only. For example, you might use symbolic lines in an elevation view to represent
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a door swing.  Symbolic lines are not part of the actual geometry of the family. Symbolic lines are visible
parallel to the view in which you draw them.
You can control symbolic line visibility on cut instances. Select the symbolic line, and click Modify Lines
tab ➤ Visibility panel ➤ Visibility Settings. In the Family element visibility settings dialog, select Show
only if instance is cut.

In this dialog, you can also control the visibility of lines based on the detail level of the view. For example,
if you select Coarse, the symbolic lines are visible when you load the family into a project and place it
in a view at the Coarse detail level.

TIP Use this dialog to control visibility of generic annotations loaded into model families. See Loading Generic
Annotations into Model Families on page 80.

■ The Opening tool (Create tab ➤ Model panel ➤ Opening) is available in host-based family templates
only (such as wall-based or ceiling-based families). You create an opening by sketching its shape to the
reference planes and then modifying its dimensions. After you create an opening, you can select it and
set it to display as transparent in 3D and/or elevation views when loaded into a project. You specify
transparency on the Options Bar.

NOTE The Opening tool is also available in the project environment.

■ The Reference Plane tool (Create tab ➤ Datum panel ➤ Reference Plane) creates a reference plane, which
is an infinite plane that serves as a guide for drawing lines and geometry.

■ The Reference Line tool (Create tab ➤ Datum panel ➤ Reference Line) creates a line similar to a reference
plane, but that has logical start and end points.

■ The Control tool (Create tab ➤ Control panel ➤ Control) lets you place arrows to rotate and mirror the
geometry of a family, after you add it to your design. The following arrow controls are available on the
Place Control tab ➤ Control Type panel (multiple selections are acceptable):

■ Single Vertical

■ Double Vertical

■ Single Horizontal

■ Double Horizontal

Revit Architecture rotates or mirrors the geometry about the origin. With 2 opposite-facing arrows, you
can mirror horizontally or vertically.

You can place the controls anywhere in the view. It is best to place them where it is obvious what they
control.

TIP Controls are useful when creating a door family. The double-horizontal control arrows change which side
the door is hinged. The double-vertical control arrows change the swing of the door from inside-out to
outside-in.

■ The Text tool (Detail tab ➤ Annotate panel ➤ Text) lets you add text notes to the family. This is typically
used in an annotation family.

■ The Model Text tool (Create tab ➤ Model panel ➤ Model Text) lets you add signage to a building or
letters to a wall.

■ The Section tool (View tab ➤ View Creation panel ➤ Section) lets you create a section view.

■ The Component tool (Create tab ➤ Model panel ➤ Component) selects the type of component to be
inserted into the Family Editor. After you select this tool, the Type Selector becomes active and you can
select a component.
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■ The Symbol tool (Detail tab ➤ Detail panel ➤ Symbol) lets you place 2D annotation drawing symbols.

■ The Detail Component tool (Detail tab ➤ Detail panel ➤ Detail Component) lets you place a detail
component.

■ The Masking Region tool (Detail tab ➤ Detail panel ➤ Masking Region) lets you apply a mask that will
obscure model elements when the family is used to create an element in a project. See Masking Regions
in the Revit Architecture 2010 Help.

■ The Solid tool (Create tab ➤ Forms panel ➤ Form) provides access to tools that let you create solid
geometry in the family.

■ The Void tool (Create tab ➤ Forms panel ➤ Void) provides access to tools that let you cut solid geometry
in the family.

■ The Label tool (Create tab ➤ Annotate panel ➤ Label) lets you place intelligent text in the family. This
text represents a family property. When the property value is specified, it will show up in the family.

NOTE This tool is available for annotation symbols only.

■ The Load into Project tool (Create tab ➤ Family Editor panel ➤ Load Into Project) lets you load a family
directly into any open project or family.

Creating a Loadable Family
Typically, the loadable families that you need to create are standard sizes and configurations of common
components and symbols used in a building design.

To create a loadable family, you define the geometry and size of the family using a family template that is
provided in Revit Architecture. You can then save the family as a separate Revit family file (.rfa file) and load
it into any project.

Depending on the complexity of the family, the creation process can be time-consuming. If you can identify
a family that is similar to the one you want to create, you can save time and effort by copying, renaming,
and modifying the existing family.

The topics in this section apply to the creation of model (3D) families, but some are relevant to 2D families,
including titleblocks, annotation symbols, and detail components.

Workflow: Creating a Loadable Family
For best results when creating a loadable family, follow the workflow below.

1 Before beginning family creation, plan the family.

See Planning a Loadable Family on page 17.

2 Create a new family file (.rfa) using the appropriate family template.

See Choosing a Family Template on page 18.

3 Define subcategories for the family to help control the visibility of the family geometry.

See Creating Family Subcategories on page 21.

4 Create the family skeleton, or framework:

■ Define the origin (the insertion point) of the family.
See Defining the Family Origin on page 23.

■ Lay out reference planes and reference lines to aid in sketching component geometry.
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See Laying Out Reference Planes on page 24 and Using Reference Lines on page 26.

■ Add dimensions to specify parametric relationships.
See Dimensioning Reference Planes on page 28.

■ Label dimensions to create type or instance parameters or 2D representation.
See Labeling Dimensions to Create Parameters on page 29.

■ Test, or flex, the framework.
See Flexing the Family Framework on page 29.

5 Define family type variations by specifying different parameters.

See Creating Family Types on page 31.

6 Add a single level of geometry in solids and voids, and constrain the geometry to reference
planes.

See Creating Family Geometry on page 32.

7 Flex the new model (types and hosts) to verify correct component behavior.

See Flexing the Family on page 31.

8 Repeat previous steps until the family geometry is complete.

9 Specify 2D and 3D geometry display characteristics with subcategory and entity visibility settings.

See Managing the Family Visibility and Detail Level on page 67.

10 Save the newly defined family, and then load it into a project for testing.

See Testing a Family in a Project on page 70.

11 For large families that include many types, create a type catalog.

See Creating a Type Catalog on page 84.

Planning a Loadable Family
If you consider this list of requirements before creating a family, you will have an easier time creating it.
Because there are bound to be changes as you create families, the Family Editor lets you make those changes
without having to start over.

■ Will the family need to accommodate multiple sizes?
For a window that is available in several preset sizes, or a bookshelf that can be built in any length, create
a standard component family. However, if you need to create a custom piece of furniture that only comes
in one configuration, you may want to create it as an in-place family, instead of a loadable family.

Size variability and the degree of complexity of the object determine whether you create a loadable family
or an in-place family.

■ How should the family display in different views?
The way the object should display in views determines the 3D and 2D geometry that you need to create,
as well as how to define the visibility settings. Determine whether the object should display in a plan
view, elevation view, and/or section views.

■ Does this family require a host?
For objects typically hosted by other components, such as a window or a lighting fixture, start with a
host-based template. How the family is hosted (or what it does or does not attach to) determines which
template file should be used to create the family.

■ How much detail should be modeled?
In some cases, you may not need 3D geometry. You may only need to use a 2D shape to represent the
family. Also, you may simplify the 3D geometry of the model to save time in creating the family. For
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example, less detail is required for a wall outlet that will only be seen in interior elevations from a distance
than for a door with raised panels and a sidelight that will be seen in an interior rendering.

■ What is the origin point of this family?
For example, the insertion point for a column family could be the center of the circular base. Determining
the appropriate insertion point will help you place the family in a project.

Choosing a Family Template
After you plan a family, your next step is to choose the template that you will base it on. When you create
a family, you are prompted to select a family template that corresponds to the type of element that the
family will create.

The template serves as a building block, containing the information that you need to start creating the
family and that Revit Architecture needs to place the family in projects.

Different Kinds of Family Templates
While most of the family templates are named according to the type of element family created from them,
there are a number of templates that include one of the following descriptors after the family name:

■ wall-based

■ ceiling-based

■ floor-based

■ roof-based

■ line-based

■ face-based

Wall-based, ceiling-based, floor-based, and roof-based templates are known as host-based templates. A
host-based family can be placed in a project only if an element of its host type is present.

Review the following template descriptions to determine which one best suits your needs.

Wall-based Templates

Use the wall-based templates to create components that will be inserted into walls. Some wall components
(such as doors and windows) can include openings, such that when you place the component on a wall, it
cuts an opening in the wall. Some examples of wall-based components include doors, windows, and lighting
fixtures. Each template includes a wall; the wall is necessary for showing how the component fits in or on
a wall.

Ceiling-based Templates

Use the ceiling-based templates to create components that will be inserted into ceilings. Some ceiling
components include openings, so that when you place the component on a ceiling, it cuts an opening in
the ceiling. Examples of ceiling-based families include sprinklers and recessed lighting fixtures.

Floor-based Template

Use the floor-based template for components that will be inserted into floors. Some floor components (such
as a heating register) include openings, so that when you place the component on a floor, it cuts an opening
in the floor.
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Roof-based Template

Use the roof-based template for components that will be inserted into roofs. Some roof components include
openings, so that when you place the component on a roof, it cuts an opening in the roof. Examples of
roof-based families include soffits and fans.

Standalone Template

Use the standalone template for components that are not host-dependent. A standalone component can be
placed anywhere in a model and can be dimensioned to other standalone or host-based components.
Examples of standalone families include columns, furniture, and appliances.

Line-based Template

Use the line-based templates to create detail and model families that use 2-pick placement.

Face-based Template

Use the face-based template to create work plane-based families that can modify their hosts. Families created
from the template can make complex cuts in hosts. Instances of these families can be placed on any surface,
regardless of its orientation. See Creating Work Plane-based and Face-based Families on page 82.

Creating a Family with a Template
To create a loadable family, you select a family template, and then name and save the family file. Name the
family so it adequately describes the element that it is intended to create. Later, when the family is complete
and you load it into a project, the family name displays in the Project Browser and the Type Selector.

Predefined imperial and metric component families are installed by default in library folders:

Windows XP: C:\Documents and Settings\All Users\Application Data\Autodesk\RAC 2010\Imperial Library
or Metric Library.

Windows Vista: C:\Program Data\Autodesk\RAC 2010\Imperial Library or Metric Library.

You can save families in the folders in these libraries, or you can save them to any local or network location.
After you create families, you can use the Copy and Paste commands in Microsoft® Windows Explorer to
move the families to different locations.

BEST PRACTICE  Do not save the family to a location where others can access it until you complete and test the
family.

To create a family with a template

1 Click  ➤ New ➤ Family.

NOTE If you are creating an annotation or titleblock family, click  ➤ New ➤ Annotation Symbol
or Title Block.

Depending on the current drawing units, the New Family - Select Template File dialog displays
the available imperial or metric family templates that are installed on your system in:

Windows XP: C:\Documents and Settings\All Users\Application Data\Autodesk\RAC
2010\Imperial Templates or Metric Templates.

Windows Vista: C:\Program Data\Autodesk\RAC 2010\Imperial Templates or Metric Templates.
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NOTE Depending on your software installation or office standards, the family templates may be
installed in another location, either locally or on a network. Contact your CAD Manager for more
information.

2 Optionally, to preview a template, select it.

The template preview image displays in the upper right corner of the dialog.

3 Select the family template that you want to use, and click Open.

The new family opens in the Family Editor. For most families, 2 or more dashed green lines
display. These are reference planes, or the working planes that you will use when you create the
family geometry.

If you are creating a host-based family, such as a window family, host geometry may also display.

4 In the Project Browser, notice the list of family views.

The family views vary depending on the type of family that you create. If necessary, you can
create additional views by duplicating and renaming existing views.

5 Click  ➤ Save As ➤ Family.
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6 In the Save dialog, navigate to the location in which you want to save the family, enter a name
for the family, and click Save.

BEST PRACTICE  Use title case for the family name.

Creating Family Subcategories
When you create a family, the template assigns it to a category that defines the default display of the family
(line weight, line color, line pattern, and material assignment of the family geometry) when the family is
loaded into a project. To assign different line weights, line colors, line patterns, and material assignments
to different geometric components of the family, you need to create subcategories within the category. Later,
when you create the family geometry, you assign the appropriate components to the subcategories.

For example, in a window family, you could assign the frame, sash, and mullions to one subcategory and
the glass to another. You could then assign different materials (wood and glass) to each subcategory to
achieve the following effect.

Revit Architecture features some predefined subcategories for different categories of families. Other families
have no subcategories, which means that you can define your own. The Object Styles dialog lists family
categories and subcategories. It also displays the line weight, line color, line pattern, and material assigned
to each category and subcategory.

TIP You can apply a drafting pattern to a family. When you create and define a subcategory to apply to the family,
you can specify its surface and cut pattern materials to have a drafting pattern. You cannot apply a model pattern
to a family. Only flat or cylindrical surfaces can have drafting patterns. See Fill Patterns in the Revit Architecture
2010 Help.

1 With the family open, click Manage tab ➤ Family Settings panel ➤ Settings drop-down ➤ Object
Styles.

2 On the Model Objects tab of the Object Styles dialog, under Category, select the family category.

3 Under Modify Subcategories, click New.
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4 In the New Subcategory dialog, for Name, enter a new name.

Revit Architecture automatically selects the appropriate category in the Subcategory of list.

5 Click OK.

Although you will not immediately create and assign the subcategory to the family geometry,
you can specify the line weight, line color, line pattern, and material for the subcategory.

6 Specify values for line weight, line color, line pattern, and material:

■ Click in the Projection and Cut fields for Line Weight, and select values from the lists.

■ Click the button in the Line Color field, and select a color from the Color dialog. If desired,
define a custom color.

■ Click in the Line Pattern field, and select a line pattern from the list. If desired, define a new
line pattern for the line display.

■ Click in the Material field, and specify a material, cut pattern, surface pattern, or render
appearance.
See Materials in the Revit Architecture 2010 Help.

7 To define additional subcategories, repeat steps 3 - 6.

8 Click OK.

Creating the Family Framework
After you plan a family, the next step is to create the family framework (skeleton). The framework is comprised
of lines and parameters in which you later create the family geometry. It also defines the origin (insertion
point) of elements that you create with the family.

To create the framework, you begin by defining the family origin. You then build the framework with
elements called reference planes and reference lines. Next you define family parameters. The parameters
that you define at this stage usually control the size (length, width, height) of the element, and let you add
family types.

A view of a furniture family framework

When the framework is complete, you test it by changing the parameter values and ensuring that the
reference planes resize. By creating solid frameworks from the information that you gather in your planning
stage before you create the family geometry, you ensure the stability of the families that you create.
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Defining the Family Origin
After you create a component family, define the family origin and pin (lock) it in place. Later, when you
create an element with the finished family, the family origin specifies the element insertion point.

The intersection of 2 reference planes in a view defines the origin of a family. You can control which reference
planes define the origin by selecting them and changing their properties. Many family templates create
families with predefined origins, but you may need to set the origin of some families. For example, an
accessible toilet family that creates toilet elements must always be placed a certain distance from an adjacent
wall to meet code. Therefore, the family origin would need to be located at the specified distance from the
wall.

To define the family origin

1 In the Family Editor, verify whether an origin has been defined for the family by selecting the
reference planes.

If a pin displays on 2 of the reference planes, the origin is defined for the family, and you can
skip the remaining steps.

2 Click Create tab ➤ Datum panel ➤ Reference Plane drop-down ➤  Draw Reference Plane.

3 Sketch the reference plane.

4 Select the reference plane.
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5 Click Modify Reference Planes tab ➤ Element panel ➤ Element Properties drop-down ➤ Instance
Properties.

6 In the Instance Properties dialog, under Other, select Defines Origin, and then click OK.

7 Create or open a family.

8 In a plan view, while pressing Ctrl, select both reference planes.

9 Click Multi-Select tab ➤ Modify panel ➤ Pin.

10 With the reference planes still selected, access their instance properties.

11 In the Instance Properties dialog, under Other, select Defines Origin.

The intersection of the reference planes now defines the origin/insertion point of the family.
By pinning the planes, you ensure that you do not accidentally move them, which would change
the family insertion point.

Laying Out Reference Planes
Before you create family geometry, you should sketch reference planes. You can then snap sketches and
geometry to the reference planes.

■ Position new reference planes so that they align with the major axes of the planned geometry.

■ Name each reference plane so that you can assign it to be the current work plane. The name lets you see
the reference plane so that you can select it to use as a work plane.

■ Specify the property for reference planes that lets you dimension to them when the family is placed in
a project.

A bookcase family created within a framework of reference planes

To lay out reference planes

1 Click Create tab ➤ Datum panel ➤ Reference Plane drop-down ➤ Draw Reference Plane.

2 Specify a start point and an end point for the reference plane.

3 Name the reference plane so that you can identify it in when you open other views:

■ Select the reference plane, and click Modify Reference Planes tab ➤ Element panel ➤ Element
Properties drop-down ➤ Instance Properties.

■ In the Instance Properties dialog, under Identity Data, for Name, enter a name for the reference
plane.

■ Click OK.

Defining Priorities for Reference Planes
Reference planes have a property called Is Reference. By setting this property or by defining a plane as an
origin, you specify that the reference plane can be dimensioned to when you place a family into a project.
For example, if you create a table family and want to dimension the edges of the table, create reference
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planes at the table's edges and set the Is Reference property for the reference planes. When you create
dimensions for the table, you can then select either the origin or the table's edges or both.

Is Reference also sets a reference point for dimensions when you use the Align tool. Specifying the Is Reference
parameter lets you select different lines of aligned components for dimensioning.

Available Is Reference values:

■ Not a reference

■ Strong reference (see Specifying Strong and Weak References on page 25.)

■ Weak reference (see Specifying Strong and Weak References on page 25.)

■ Left

■ Center (Left/Right)

■ Right

■ Front

■ Center (Front/Back)

■ Back

■ Bottom

■ Center (Elevation)

■ Top

If you create multiple families with the same Is Reference value for a particular reference plane, the dimensions
to that reference plane apply when you switch between family components.

For example, you create a table family and a chair family, and specify the left side reference plane property
value to Left for both of them. You place the table in a building and dimension it from the wall to the left
side of the table. If you replace the table with the chair, the dimension to the left side would remain to the
left side of the chair, because they both had a property value of Left.

Specifying Strong and Weak References
To dimension families placed in a project, you need to define family geometry references as either strong
or weak in the Family Editor.

A strong reference has the highest priority for dimensioning and snapping. For example, you create a window
family and place it into a project. As you are placing the family, temporary dimensions snap to any strong
references in the family. When you select the family in the project, temporary dimensions appear at the
strong references. If you place a permanent dimension, the strong references in the window geometry
highlight first. A strong reference has higher priority than a wall reference point (such as its centerline).

A weak reference has the lowest priority for dimensioning. When you place the family into the project and
dimension to it, you may need to press Tab to select a weak reference, as any strong references highlight
first.

NOTE You may also be able to zoom in to the model to highlight weak references, as elements in the model
appear farther apart as you zoom in.

This procedure changes references for selected line instances. It does not specify reference values for new
lines.
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1 Click Create tab ➤ Datum panel ➤ Reference Line (or Reference Plane), and sketch a line or
reference plane.

2 Select the line or plane, and click Modify <element> tab ➤ Element panel ➤ Element Properties
drop-down ➤ Instance Properties.

3 For reference line, in the Instance Properties dialog, for Is Reference, select Strong Reference.
For a reference plane, for Is Reference, select Strong Reference.

NOTE The default reference property for all reference planes and sketched lines is Weak Reference.

4 Click OK.

You can sketch lines and specify them as strong references. To create strong references for solid geometry,
such as extrusions, sketch reference planes and specify them as strong references. Then sketch the solid
geometry to the reference planes.

Using Reference Lines
You can use reference lines to create a parametric family framework to which elements of the family can
attach. For example, you would use reference lines to parametrically maintain the angular relationships
within a web, or use them to precisely control the angle of a door swing. Angular parameters applied to a
reference line also control the elements attached to its face.

A bookcase family featuring a door with a swing controlled by a
reference line
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Reference lines are annotation objects with their own category. When selected, they display dual faces.
When printing, their visibility is affected by the Hide ref/work planes option.

Straight reference lines provide 2 planes for you to sketch on, one that is parallel to the work plane of the
line and one that is perpendicular to that plane. Both planes go through the reference line. The planes
display when the reference line is selected or highlighted, or when you use the Work Plane tool. When
selecting a work plane, you can place the cursor over a reference line and press Tab to switch between the
2 faces. The plane in which the line was sketched always displays first. You can also create arc reference
lines, but they do not define planes.

Reference Line Behavior in the Project

After a family is loaded into a project, the behavior of reference lines is identical to that of reference planes.
Reference lines are not visible in a project and do not highlight when the family instance is selected. They
highlight and generate shape handles in the same contexts as reference planes currently do, depending on
their Reference property.

Selected reference in multiple views
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Controlling Angular Dimensions with Reference Lines
The preferred method to control the angular dimensions of a family is to apply a labelled angular dimension
to a reference line. Unlike reference planes (with infinite extents), a reference line has specific start and end
points and can be used to control the angular constraints within components .

Loaded door family with an angular dimensioned reference line

To add and dimension a reference line

1 In the drawing area (while in the Family Editor), add a reference line with the point of origin
located at the point of expected rotation.

2 Add an angular dimension referring to the reference line.

3 Label the dimension.

4 Click Family Properties panel ➤ Types.

5 In the Family Types dialog, change the angular value for the labelled dimension, and click Apply.

This is known as flexing the model. It is important to make sure the reference line adjusts as
expected before adding model geometry to it.

To add and align model geometry to a reference line

6 Set the current work plane to one of the faces of the reference line.

7 Add the model geometry that you intend to have controlled by the angular dimension.

8 Flex the model to make sure the design works as expected.

The geometry moves with the reference line as the angle changes.

Adding Parameters to the Family Framework
Although you have not yet created any family geometry, you can define the main parametric relationships
in the family. The parameters that you define at this stage usually control the size (length, width, height)
of the element. To create a parameter, you place dimensions between the reference planes of the framework
and then label them.

IMPORTANT Families in Revit Architecture are not parametric until you add labeled dimensions to them.

Dimensioning Reference Planes
The first step to creating family parameters is to place dimensions between the reference planes of the
framework to mark the parametric relationships that you intend to create. Dimensions alone do not create
the parameters; you must label them to create parameters.

1 Identify the reference planes that you want to dimension to create parameters.

2 Click Detail tab ➤ Dimension panel, and select a dimension type.

3 On the Options Bar, select an option for placing dimensions.

4 Place the dimensions between reference planes.

5 Continue to dimension reference planes until all the parametric relationships have been
dimensioned.
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TIP You may need to open different views in the family to create some of the dimensions.

Labeling Dimensions to Create Parameters
After you dimension the family framework, you label the dimensions to create parameters. For example, the
dimensions below have been labeled with length and width parameters.

If the parameters exist in the family, you can select any of them as a label. If not, you must create the
parameter, specifying its type and whether it is an instance or type parameter.

To label dimensions and create parameters

1 While in the Family Editor, right-click the dimension, and click Edit Label.

2 Select a parameter from the list, or choose <Add parameter...>, and create a parameter.

See Creating Parameters on page 58.

TIP You can add formulas to parameters. A simple example would be a width parameter that is
specified as twice the height of the object. See Using Formulas for Numerical Parameters on page
62.

Alternate procedure for labeling

1 While in the Family Editor, select the dimension value.

2 On the Options Bar, for Label, select a parameter, or create a parameter. See Creating Parameters
on page 58.

3 If desired, select Leader to create a leader line for the dimension.

Flexing the Family Framework
You can flex, or test, the parameters that you have applied to the family framework. To flex the framework,
you adjust the parameter values, making sure that the reference planes to which you applied the parameter
change accordingly. Flexing is a way to test the integrity of the parametric relationships. Flexing early and
often as you create families ensures the stability of the families.
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To flex the framework

1 Click Create tab ➤ Family Properties panel ➤ Types.

The Family Types dialog displays. Although you have not defined any family types yet, the
dialog lists the parameters that you created.

2 Reposition the Family Types dialog on the screen, so you can view the framework.

3 In the Family Types dialog, under Parameter, locate the parameters that you created previously,
and enter different values in each corresponding Value field.

4 Click Apply.

The family framework should adjust to reflect the updated parameter values.

5 Continue to flex the framework by specifying different parameter values.

The more extensively you test the parameters, the more likely you are to create a stable family.

6 When you finish flexing the framework, click OK.
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Creating Family Types
Using the Family Types tool, you can create many types (sizes) for a family. To do this, you need to have
labeled the dimensions and created the parameters that are going to vary.

A bookcase family that creates 4 different bookcase types (sizes)

Each family type has a set of properties (parameters) that includes the labeled dimensions and their values.
You can also add values for standard parameters of the family (such as Material, Model, Manufacturer, Type
Mark, and others).

To create family types

1 Click Create tab ➤ Family Properties panel ➤ Types.

2 In the Family Types dialog, under Family Types, click New.

3 Enter the family name, and click OK.

4 In the Family Types dialog, enter the values for the type parameters.

5 Click OK.

Flexing the Family
After you create family types, you can flex, or test, the family. To flex the family, you switch between different
family types, ensuring that the family adjusts properly. You can flex the family before and after you create
the family geometry. Flexing early and often as you create families ensures the stability of the families.

To flex the family

1 Click Create tab ➤ Family Properties panel ➤ Types.

2 Reposition the Family Types dialog on the screen, so you can view the family framework.
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3 At the top of the dialog, select a family type, and then click Apply.

The family should adjust to reflect the parameter values specified in the selected family type.

4 Continue to flex the family by selecting each type in the family.

5 When you finish flexing the family, click OK.

Creating Family Geometry
You can use both 2- and 3-dimensional geometry to create families. Create solid geometric shapes to represent
the element that the family is intended to create. Use 2D linework to add detail to solid geometry in certain
views or to create a symbolic plan representation of an element.

As you create the family geometry, you can specify the visibility, material, and an optional subcategory of
the geometry. These settings determine how and when the specific geometric components of the family
display.

To ensure the stability of each parametric family, build the family geometry incrementally, testing (flexing)
the parametric relationships in each increment.
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Creating Solid (3D) Geometry
To create solid family geometry, you use 3-dimensional solid and void forms. Solid forms are 3D shapes that
represent the solid geometry of a family.

Extrusion of a concrete
isolated foundation

Void forms are 3D shapes that you use to cut volume from solid forms, allowing you to create complex solid
forms. You can sketch void forms at the location where you want them to cut solid forms, or you can move
them after you create them and then use the Cut Geometry tool to perform the cut.

You can also use the Join Geometry tool to join solid geometry to create complex forms.
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The Family Editor provides you with tools that you can use to create solid and void forms. Access these tools
from the Create tab ➤ Forms panel by clicking Solid or Void. The tools offer 5 methods that you can use to
create both solid and void geometry: extrusions, blends, revolves, sweeps, and swept blends. Both sweeps
and swept blends use profiles swept along a path; to create profile families that you can load and use, see
Creating and Using Profile Families on page 49.

NOTE You can also create extrusions, blends, revolves, sweeps, and swept blends as mass families. See Conceptual
Design with Massing Studies in the Revit Architecture 2010 Help.

When you create geometry, you can determine how it displays in the family:

■ Specify the visibility and detail level of the geometry.
See Managing the Family Visibility and Detail Level on page 67.

■ Assign a material to the geometry.
See Material in the Revit Architecture 2010 Help.

■ Assign the geometry to a subcategory.
See Creating Family Subcategories on page 21 and Assigning Family Geometry to Subcategories on page
66.

Creating an Extrusion
A solid or void extrusion is the easiest form to create. You sketch a 2D profile of the form on a work plane,
and then extrude that profile perpendicular to the plane on which you sketched it.

Sample polygonal concrete
isolated foundation extrusion

Before you extrude the shape, you can specify its start and end points to increase or decrease the depth of
the form. By default, the extrusion start point is 0. The work plane does not need to be either the start or
end point of the extrusion – you only use it to sketch on and to set the extrusion direction.

The following procedure is a general method for creating a solid or void extrusion. Steps may vary depending
on your design intent.

To create a solid or void extrusion

1 In the Family Editor, on the Create tab ➤ Forms panel, do one of the following:

■ Click Solid drop-down ➤ Extrusion.

■ Click Void drop-down ➤ Extrusion.
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NOTE If necessary, set the work plane before you sketch the extrusion. Click Create tab ➤ Work
Plane panel ➤ Set.

2 Use the sketching tools to sketch the extrusion profile:

■ To create a single solid form, sketch a closed loop.

■ To create more than one form, sketch multiple, non-intersecting, closed loops.

3 To extrude the profile from the default start point of 0, on the Options Bar, for Depth, enter a
positive or negative extrusion depth.

This value changes the endpoint of the extrusion.

NOTE The extrusion depth is not retained after you create the extrusion. If you need to make multiple
extrusions with the same endpoint, sketch the extrusions, select them, and then apply the endpoint.

4 Specify the extrusion properties:

■ Click Create Extrusion tab ➤ Element panel ➤ Extrusion Properties.

■ To extrude the extrusion from a different start point, under Constraints, for Extrusion Start,
enter a new point.

■ To set the visibility of a solid extrusion, under Graphics, for Visibility/Graphics Overrides,
click Edit, and specify the visibility settings.

■ To apply a material to a solid extrusion by category, under Materials and Finishes, click in

the Material field, click  , and specify a material.

■ To assign a solid extrusion to a subcategory, under Identity Data, for Subcategory, select a
subcategory.

■ Click OK.

5 Click Create Extrusion Boundary tab ➤ Extrusion panel ➤ Finish Extrusion.

Revit Architecture completes the extrusion and returns you to the view in which you started
the extrusion.

6 To view the extrusion, open a 3D view.

7 To resize the extrusion in the 3D view, select it and use grips to edit it.

Editing an Extrusion
You can modify an extrusion after creating it.

To edit an extrusion

1 In the drawing area, select the extrusion.

2 If you are in the project environment:

a Click Modify <Element> tab ➤ Family panel ➤ Edit Family.

b Click Yes to open the family for editing.

c In the Family Editor, select the extrusion in the drawing area again.

3 Click Modify Extrusion tab ➤ Form panel ➤ Edit Extrusion.

4 If desired, modify the extrusion profile.
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5 To edit the extrusion properties, click Modify Extrusion > Edit Extrusion tab ➤ Element
panel ➤ Extrusion Properties, and change the visibility, material, or subcategory of the extrusion.

6 To change the extrusion to a solid or a void, under Identity Data, for Solid/Void, select Solid or
Void.

7 Click OK.

8 Click Finish Extrusion.

Creating a Blend
The Blend tool blends 2 profiles (boundaries) together. For example, if you sketch a large rectangle and a
smaller rectangle on top of it, Revit Architecture blends the 2 shapes together.

Sample base and top boundaries
for a blend.

Finished blend

NOTE If you want to dimension a solid blend after you create it, you can dimension from lines at the top of the
blend to lines at the base of the blend. You cannot dimension from lines at the base of the blend to lines at the
top of the blend.

To create a solid or void blend

1 In the Family Editor, on the Create tab ➤ Forms panel, do one of the following:

■ Click Solid drop-down ➤ Blend.

■ Click Void drop-down ➤ Blend.
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NOTE If necessary, set the work plane before you sketch the blend. Click Create tab ➤ Work Plane
panel ➤ Set.

2 On the Create Blend Base Boundary tab, use the sketching tools to sketch the base boundary of
the blend, for example sketch a square.

3 To specify the depth of the blend, do either of the following:

■ To specify a depth that is calculated from a default start point of 0, on the Options Bar, for
Depth, enter a value.

■ To specify a depth that is calculated from a start point other than 0, on the Create Blend
Base Boundary tab ➤ Element panel, click Blend Properties. Under Constraints, enter new
Second End and First End values.

NOTE If specified, Revit Architecture does not retain the end point value during creation of the
blend. If you need to make multiple blends with the same end point, first sketch the blends, then
select them, and then apply the end point.

4 When finished with the base boundary, on the Create Blend Base Boundary tab ➤ Mode panel,
click Edit Top.

5 On the Create Blend Top Boundary tab, sketch a boundary for the top of the blend, for example
another square.

6 If necessary, edit the vertex connections to control the amount of twist in the blend:

■ On the Create Blend Top Boundary tab, click Mode panel ➤ Edit Vertices.

■ Vertex points become available on one of the blend sketches.

The dotted lines with blue open-dot controls are suggested connections. Each control is a
switch between adding and removing connections.

■ To display the vertex points on the other blend sketch, on the Edit Vertices tab ➤ Vertex
Connect panel, click Controls on Base or Controls on Top (whichever option is currently
unselected).

■ Click a control, and the line becomes a solid connection. A filled blue control displays on
the connection.
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■ Click a solid control to remove a connection; the line reverts to a dashed line with an open
dot control.

■ As you click the controls, some possible edges disappear and other ones appear.

■ On the Vertex Connect panel, click Twist Right or Twist Left to twist the selected blend
boundary in a clockwise or counter-clockwise direction.

7 Specify the blend properties:

■ On the Element panel, click Blend Properties.

■ To set the visibility of a solid blend, under Graphics, for Visibility/Graphics Overrides, click
Edit, and specify the visibility settings.

■ To apply a material to a solid blend by category, under Materials and Finishes, click in the

Material field, click  , and specify a material.

■ To assign a solid blend to a subcategory, under Identity Data, for Subcategory, select a
subcategory.

■ Click OK.

8 On the Blend panel, click Finish Blend.

9 To view the blend, open a 3D view.

10 To resize the blend in the 3D view, select and use grips to edit it.

Editing a Blend
1 In the drawing area, select the blend.

2 If you are in the project environment:

a On the Modify <Element> tab ➤ Family panel, click Edit Family.

b Click Yes to open the family for editing.

c In the Family Editor, select the blend in the drawing area again.

3 On the Options Bar, enter a value in the Depth text box to change depth of the blend.

4 On the Modify Blend tab ➤ Edit Blend panel, select an editing option:

■ Click Edit Top to edit the top boundary of the blend.

■ Click Edit Base to edit the base boundary of the blend.
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5 To edit other blend properties, on the Edit Top Boundary tab or Edit Base Boundary tab, click
Element panel ➤ Blend Properties, and change the visibility, material, or subcategory of the
blend.

6 To change the blend to a solid or a void, under Identity Data, for Solid/Void, select Solid or
Void.

7 Click OK.

8 On the Edit Top Boundary tab or Edit Base Boundary tab, click Mode panel ➤ Edit Vertices, and
edit the blend vertices.

9 On the Blend panel ➤ click Finish Blend.

Creating a Revolve
A revolve is a form that you create by revolving a shape around an axis. You can revolve the shape in a circle
or any fraction of a circle. If the axis touches the revolve shape, the result is a solid.

Solid revolved geometry
created near axis

If you sketch away from the axis, the resulting geometry has a hole in it.

Revolved geometry created away
from axis

Use solid revolves to create family geometry like door and furniture knobs, columns, and dome roofs.

The following procedure is a general method for creating revolved geometry. Steps may vary depending on
your design intent.
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To create a solid or void revolve

1 In the Family Editor, on the Create tab ➤ Forms panel, do one of the following:

■ Click Solid drop-down ➤ Revolve.

■ Click Void drop-down ➤ Revolve.

NOTE If necessary, set the work plane before you sketch the revolve. Click Create tab ➤ Work Plane
panel ➤ Set.

2 Place an axis of revolution:

■ On the Create Revolve tab ➤ Draw panel, click Axis Line.

■ Specify the start and endpoint of the axis at the desired orientation.

3 Use the sketching tools to sketch a shape to revolve around the axis:

■ On the Create Revolve tab ➤ Draw panel, click Boundary Lines.

■ To create a single revolve, sketch a closed loop.

■ To create more than one revolve, sketch multiple, non-intersecting, closed loops.

IMPORTANT If the axis touches the revolve shape, the result is a solid. If the axis does not touch the
revolve shape, the revolve will have a hole in it.

4 Change the properties of the revolve:

■ On the Create Revolve tab ➤ Element panel, click Revolve Properties.

■ To change the start and end points of the geometry to revolve, enter a new Start and End
Angle.

■ To set the visibility of a solid revolve, under Graphics, for Visibility/Graphics Overrides, click
Edit.

■ To apply a material to a solid revolve by category, under Materials and Finishes, click in the

Material field, and click  to specify a material.

■ To assign a solid revolve to a subcategory, under Identity Data, for Subcategory, select a
subcategory.

■ Click OK.

5 On the Revolve panel, click Finish Revolve.

6 To view the revolve, open a 3D view.

7 To resize the revolve in the 3D view, select and use grips to edit it.

NOTE You cannot drag the start and end faces of a 360-degree revolve.

Editing a Revolve
1 In the drawing area, select the revolve.

2 If you are in the project environment:

a On the Modify <Element> tab ➤ Family panel, click Edit Family.

b Click Yes to open the family for editing.
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c In the Family Editor, select the revolve in the drawing area again.

3 On the Modify Revolve tab ➤ Edit panel ➤ click Edit Sketch.

4 If desired, modify the revolve sketch.

5 To edit other revolve properties, on the Edit Revolve tab ➤ Element panel, click Revolve
Properties, and change the start and end points, visibility, material, or subcategory.

6 To change the revolve to a solid or a void, under Identity Data, for Solid/Void, select Solid or
Void.

7 Click OK.

8 On the Revolve panel, click Finish Revolve.

Creating a Sweep
A sweep is a tool for creating families that requires you to sketch or apply a profile (shape) and extrude that
profile along a path. You might use a sweep to create moldings, railings, or simple pipes.

The following procedure is a general method for creating a sweep. Steps may vary depending on your design
intent.

To create a solid or void sweep

1 In the Family Editor, on the Create tab ➤ Forms panel, do one of the following.

■ Click Solid drop-down ➤ Sweep.

■ Click Void drop-down ➤ Sweep.

NOTE If necessary, set the work plane before you sketch the sweep. Click Create tab ➤ Work Plane
panel ➤ Set.

2 Specify the sweep path:

■ To sketch a new path for the sweep, on the Create Sweep tab ➤ Mode panel, click Sketch
Path.
The path can either be a single closed or single open path. You cannot have multiple paths.
The path can be a combination of straight lines and curves, and it need not be planar.

■ To select an existing line for the sweep, on the Create Sweep tab ➤ Mode panel, click Pick
Path.
You can select edges of other solid geometry, such as extrusions or blends, or you can pick
existing sketch lines. Watch the status bar to know what you are picking. This method of
picking automatically locks the sketch lines to the geometry you are picking and allows you
to sketch the path in multiple work planes, hence allowing for a 3D path.

3 Sketch or pick the path, and then on the Path panel, click Finish Path.

4 Load or sketch a profile:

■ To load a profile:

a Click Modify Profile tab ➤ Edit panel, and select a profile from the Profile list.
If the profile you need is not already loaded in the project, click Modify Profile tab ➤ Edit
panel ➤ Load Profile to load the profile.

b On the Options Bar, use the X, Y, Angle, and Flip options to adjust the position of the
profile.
Enter values for X and Y to specify the offset for the profile.
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Enter a value for Angle to specify the angle of the profile. The angle rotates the profile
around the profile origin. You can enter negative values to rotate in the opposite
direction.

Click Flip to flip the profile.

c Click Apply.

d Select the path, and zoom in to see the profile.

■ To sketch a profile:

a Click Modify Profile tab ➤ Edit panel, verify <By Sketch> is displayed, and then click
Edit Profile.

b If the Go To View dialog displays, select the view where you want to sketch the profile,
and click OK.
For example, if you sketched the path in a plan view, you would choose an elevation
view to sketch the profile. The profile sketch can be a single-closed loop or multiple
closed loops that do not intersect. Sketch the profile near the intersection of the profile
plane and the path.

c Sketch the profile. Profiles must be closed loops.

d On the Create Profile Sketch tab ➤ Profile panel, click Finish Profile.

5 Specify the sweep properties:

■ On the Create Sweep tab ➤ Element panel, click Sweep Properties.

■ To set the visibility of a solid sweep, under Graphics, for Visibility/Graphics Overrides, click
Edit, and specify the visibility settings.

■ To apply a material to a solid sweep by category, under Materials and Finishes, click in the

Material field, click  , and specify a material.

■ To assign a solid sweep to a subcategory, under Identity Data, for Subcategory, select a
subcategory.

■ Click OK.

6 On the Sweep panel, click Finish Sweep.

Creating a Segmented Sweep
Segmented sweeps are useful for creating mechanical duct work elbows. You create a segmented sweep by
setting 2 sweep parameters and sketching a path with arcs. The parameters affect only arcs in the path. The
minimum number of segments for a sweep is 2.

1 In the Family Editor, begin creating a sweep.

2 On Create Sweep tab ➤ Element panel, click Sweep Properties.

3 In the Instance Properties dialog, under Other, select the check box for Trajectory Segmentation.

4 Enter a value for Maximum Segment Angle. Valid values are between 0 and 360 degrees.

5 Sketch or pick a path with arcs.

6 Click Finish Path to complete the path.

7 Create a profile or use a pre-loaded profile.

8 On the Sweep panel, click Finish Sweep to complete the sketch of the sweep.
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Sample segmented sweep with 30 degree
Maximum Segment Angle.

TIP You can change a segmented sweep to a non-segmented sweep by clearing the check box for Trajectory
Segmentation.

Editing a Sweep
1 In the drawing area, select the sweep.

2 If you are in the project environment:

a On the Modify <Element> tab ➤ Family panel, click Edit Family.

b Click Yes to open the family for editing.

c In the Family Editor, select the sweep in the drawing area again.

3 On the Modify Sweep tab ➤ Form panel, click Edit Sweep.

4 To modify the sweep path:

■ On the Create Sweep tab ➤ Mode panel, click Sketch Path.

■ Use the tools on the Edit tab to modify the path.

■ On the Path panel, click Finish Path.

5 To modify the sweep profile:

■ On the Create Sweep tab ➤ Mode panel, click Select Profile.

■ On the Edit panel, use the tools that display to select a new sweep profile or change the
sweep profile location. You can edit the existing profile using the tools on the Modify Profile
tab.

6 To edit other sweep properties, on the Element panel, click Sweep Properties, and change the
visibility, material, segmentation, or subcategory of the sweep.

7 To change the sweep to a solid or a void, under Identity Data, for Solid/Void, select Solid or
Void.

8 Click OK.

9 On the Sweep panel, click Finish Sweep.
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Sweep Tips
When creating a sweep with a tangent arc in the path, be sure the profile is small enough to sweep around
the arc without the resulting geometry intersecting itself. An error occurs if the geometry intersects.

If you create a sweep path by using the Pick Path tool, you can drag the end points of the path lines as you
are sketching it.

Creating a Swept Blend
The Swept Blend tool allows you to create a blend that has 2 different profiles and then sweep it along a
path. The shape of a swept blend is determined by the 2D path you either sketch or pick and the 2 profiles
you either sketch or load.

The following procedure is a general method for creating a swept blend. Steps may vary depending on your
design intent.

To create a solid or void swept blend

1 In the Family Editor, on the Create tab ➤ Forms panel, do one of the following:

■ Click Solid drop-down ➤ Swept Blend.

■ Click Void drop-down ➤ Swept Blend.

2 Specify the path for the swept blend. Do one of the following on the Create Swept Blend
tab ➤ Mode panel:

■ Click Sketch Path to sketch a path for the swept blend.
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■ Click Pick Path to pick an existing line for the swept blend.

NOTE If necessary, set the work plane before you sketch or pick the path for the swept blend. Click
Create tab ➤ Work Plane panel ➤ Set.

3 Sketch or pick the path, and then on the Path panel, click Finish Path.

NOTE A swept blend path can only have one segment.

4 Load or sketch Profile 1.

The end point for Profile 1 on the swept blend path is highlighted.

■ To load a profile:

a Click Modify Profile tab ➤ Edit panel, and select a profile from the Profile drop-down.
If the profile you need is not already loaded in the project, click Load Profile to load
the profile.

b Zoom in to see the profile.

c Use the X, Y, Angle, and Flip options to adjust the position of the profile.
Enter values for X and Y to specify the offset for the profile.

Enter a value for Angle to specify the angle of the profile. The angle rotates the profile
around the profile origin. You can enter negative values to rotate in the opposite
direction.

Click Flip to flip the profile.

d Click Apply.
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■ To sketch a profile:

a On the Edit panel, verify that <By Sketch> is selected and click Edit Profile.

b If the Go To View dialog displays, select the view where you want to sketch the profile,
and click OK.

c Use the tools on the Create Profile tab to sketch the profile. Profiles must be closed
loops.

d On the Profile panel, click Finish Profile.

5 Click Swept Blend tab ➤ Mode panel ➤ Modify Profile 2.

6 Load or sketch Profile 2 using the steps above.

7 Optionally, edit the vertex connections. By editing vertex connections, you control the amount
of twist in the swept blend. You can edit vertex connections in plan or 3D views.

a On the Swept Blend tab ➤ Mode panel, click Edit Vertices.

b On the Edit Vertices tab ➤ Vertex Connect panel, select Controls on Base or Controls on
Top.

c In the drawing area, click the blue controls to move the vertex connections.

d On the Vertex Connect panel, click the Twist Right and Twist Left tools to twist the swept
blend.

8 Specify the swept blend properties:

■ On the Element panel, click Swept Blend Properties.

■ To set the visibility of a solid swept blend, under Graphics, for Visibility/Graphics Overrides,
click Edit, and specify the visibility settings.

■ To apply a material to a solid swept blend, under Materials and Finishes, click in the Material

field, click  , and specify a material.

■ To assign a solid swept blend to a subcategory, under Identity Data, for Subcategory, select
a subcategory.

■ Click OK.

9 When finished, click Swept Blend panel ➤ Finish Swept Blend.

Editing a Swept Blend
1 In the drawing area, select the swept blend.

2 If you are in the project environment:

a On the Modify Swept Blend tab ➤ Edit Swept Blend panel, click Edit Family.

b Click Yes to open the family for editing.

c In the Family Editor, select the swept blend in the drawing area again.

3 On the Modify Swept Blend tab ➤ Form panel, click Edit Swept Blend.

4 To edit the path:

a On the Create Swept Blend tab ➤ Mode panel, click Sketch Path.
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b Use the tools on the Sketch Path tab to modify the path, and click Path panel ➤ Finish
Path.

5 To edit the profiles:

a On the Swept Blend tab ➤ Mode panel, click Modify Profile 1 or Modify Profile 2.

b On the Edit panel, select a different loaded profile from the drop-down list, or select <By
Sketch> from the list to sketch a new profile.

c If you selected <By Sketch>, click Edit Profile on the Edit panel.

d Sketch the profile and then click Profile panel ➤ Finish Profile.

6 To edit other swept blend properties, click Swept Blend tab ➤ Element panel ➤ Swept Blend
Properties, and change the visibility, material, or subcategory of the sweep.

7 To change the swept blend to a solid or a void, under Identity Data, for Solid/Void, select Solid
or Void.

8 Click OK.

9 On the Swept Blend panel, click Finish Swept Blend.

Cut Geometry
With the Cut Geometry tool, you can pick and choose which geometry gets cut and which does not, regardless
of when you created the geometry.

NOTE While this tool and the UnCut Geometry tool are primarily for families, you can use them to embed curtain
walls.

1 In the Family Editor, create solid geometry; it can be a single primitive or some joined primitives.

2 Create a void through the solid geometry.

3 Create another solid geometry shape and join it to the existing geometry.
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4 Click Modify tab ➤ Edit Geometry panel ➤ Cut drop-down ➤ Cut Geometry and select the void
you created.

Notice the cursor changes shape.

5 Select the geometry you created in Step 3.

Revit Architecture cuts the selected geometry.
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Uncut Geometry
1 In the Family Editor, click Modify tab ➤ Edit Geometry panel ➤ Cut drop-down ➤ Uncut

Geometry.

2 Select the void.

3 Select the appropriate solid primitives that you do not want to cut.

NOTE If you select all geometry to not be cut, then the void appears at all times in the view.

Creating 2D Geometry
To create 2D family geometry, you use the Revit Architecture Model and Symbolic lines tools that are available
in the Family Editor.

The Model Line tool on the Create tab ➤ Model panel lets you sketch two-dimensional geometry for when
you do not need to show solid geometry. For example, you could sketch door panels and hardware as 2D
rather than sketch solid extrusions. Model lines are always visible in 3D views. You can control their visibility
in plan and elevation views by selecting the lines and clicking Modify Lines tab ➤ Visibility panel ➤ Visibility
Settings.

The Symbolic Line tool on the Detail tab ➤ Detail panel lets you sketch lines that are meant for symbolic
purposes only. For example, you might sketch symbolic lines in an elevation view to represent a door swing.
Symbolic lines are not part of the actual geometry of the family. Symbolic lines are visible parallel to the
view in which you sketch them.

You can control symbolic line visibility on cut instances. Select the symbolic line and click Modify Lines
tab ➤ Visibility panel ➤ Visibility Settings. Select Show only if instance is cut.

In the displayed dialog, you can also control the visibility of lines based on the detail level of the view. For
example, if you select Coarse, that means that when you load the family into a project and place it in a view
at the Coarse detail level, the symbolic lines are visible.

Creating and Using Profile Families
A profile family contains a 2-dimensional closed loop that you can load into a project and apply to certain
building elements. For example, you can sketch the profile loop for a railing and then use that shape on a
railing in your project.
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Rail profile

Stair rails with profile applied

Elements for which you can define profiles include wall sweeps, reveals, railings, mullions, stair treads, and
sweep profiles. When you define one profile family, you can reuse it multiple times on building elements
in the project. Loaded profiles display in the Project Browser under Families.

Create profile families using family templates supplied with Revit Architecture. These templates are Profile.rft,
Profile-Rail.rft, Profile-Reveal.rft, Profile-Stair Nosing.rft, and Wall Sweep Profile.rft.

Creating a Profile Family
To create a profile family, open a new family, and sketch a profile using lines, dimensions, and reference
planes. After you save the profile family, you can load it and apply it to solid geometry in the project.

This procedure describes creating a generic profile shape that is available to multiple building elements in
the project. Your specific building and design intentions may differ.

To create a profile

1 Click  ➤ New ➤ Family.
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2 In the New Family - Select Template File dialog, select a profile template, and click Open.

The Family Editor opens a plan view that includes 2 reference planes. There are no other views
available in which to sketch geometry.

3 If necessary, sketch reference planes for constraining the lines in the profile.

4 Click Create tab ➤ Detail panel ➤ Line, and sketch the profile loop.

For more information about the sketching tools, see Sketching in the Revit Architecture 2010
Help.

5 If necessary, click Create tab ➤ Detail panel ➤ Detail Component to place a detail component
into the profile family.

TIP You can change the sorting order of any detail components in the family by using the detail
component draw order tools. See Sorting Element Draw Order in the Revit Architecture 2010 Help.

6 To specify the detail at which the profile family displays in the project, select any of the lines
of the profile sketch, and click Modify Lines tab ➤ Visibility panel ➤ Visibility Settings.

7 Select the desired detail levels (Fine, Medium, or Coarse), and click OK.

TIP You can specify the detail level for detail components using the same methods.

Next, define the profile usage.

8 Click Family Properties panel ➤ Category and Parameters.

9 In the Family Category and Parameters dialog, under Family Parameters, for Profile Usage, click
in the Value field, and select the profile type.

For example, if you are creating a mullion profile, select Mullion.

TIP This setting ensures that only relevant profiles are listed when using profiles within a project. For
example, when selecting a mullion profile, stair nosing profiles do not display.

10 Click OK.

11 Add any dimensions required.

Sample profile sketch

12 Save the family.
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Loading a Profile Family into a Project
1 In a project file, click Insert tab ➤ Load from Library panel ➤ Load Family.

2 Navigate to the profile family file you created, select it, and click Open.

3 In the Project Browser, expand Families ➤ Profiles.

The family that you created and loaded displays and can be applied to building elements in the
project.

Using the Profile Family with a Building Element
This procedure provides an example of how to apply the profile to an element.

1 Click  ➤ New ➤ Family, select Profile-Rail.rft, and click Open.

2 Create a profile-rail family by sketching the shape you want for the rail.

Make sure that the sketched shape is a single closed loop of lines.

3 Save the family.

4 Open the project in which you want to use the new family.

5 Click Insert tab ➤ Load from Library panel ➤ Load Family, select the profile family that you
created, and click Open.

6 Click Home tab ➤ Circulation panel ➤ Stairs.

7 Sketch a run of stairs, and click Finish Stairs.

8 Click View tab ➤ Create panel ➤ 3D View drop-down ➤ Default 3D.

9 In the 3D view, select the default railing.

10 Click Modify Railings tab ➤ Element panel ➤ Element Properties drop-down ➤ Type Properties.

11 In the Type Properties dialog, under Construction, for Rail Structure, click Edit.

12 In the Edit Rails dialog, in the Profile column, click the current profile family name.

13 Select the name of the profile family you created, and click OK twice.

Revit Architecture applies the new profile shape to the railing.

Stair rails with new profile applied
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Host Sweep Profiles with Nested Detail Components
You can nest a detail component within a host sweep profile family (wall sweeps, roof fascia, gutters, and
slab edges) and use the visibility controls to specify when the detail component displays within a project.
When the sweep is cut in the project, the detail component displays depending on the visibility settings
you specified within the host sweep family file. You can also have multiple detail components display at
particular visibility levels for a specific view cut host sweep.

Example of curtain mullion with
nested detail component

TIP You can also import a detail, such as a DWG file, and apply the same visibility controls to it.

See also Nesting and Sharing Component Families on page 71.

To load a detail component

1 Open or create a host sweep family.

2 Click Create tab ➤ Detail panel ➤ Detail Component.

3 Click Yes to load a detail component family.

4 In the Load Family dialog, select a detail component family, and click Open.

To add the detail component to the host sweep

5 Click in the drawing area to add the detail component to the host sweep family.

6 If necessary, use alignments or dimensions to constrain the location of the detail component.

To specify detail component visibility

7 Select the nested detail component.

8 Click Modify Detail Items tab ➤ Visibility panel ➤ Visibility Settings.

9 In the Family element visibility settings dialog, specify the detail level (Coarse, Medium, and/or
Fine), and click OK.

After it is loaded in a project, the host sweep detail displays when cut and at the detail level you
specified.

Creating a Loadable Family | 53



Dimensioning Family Geometry
As you create the geometry of component families, you place dimensions to define the geometric relationships
that you want to control with parameters. By labeling the dimensions that you place, you create a parameter
that you can control.

To add dimensions, you can use the Dimension tools on the Family Editor Create tab, or you can turn on
automatic dimensions.

Automatic Sketch Dimensions
Revit Architecture creates automatic dimensions to help control your design intent. These automatic
dimensions are not displayed by default.

To turn them on, select Automatic Sketch Dimensions on the Annotation Categories tab of the
Visibility/Graphic Overrides dialog. You can then modify the dimensions or create your own dimensions
using the Dimension tools. You can also lock dimensions to keep a distance constant. This is useful if you
plan to have several sizes of the family and want to keep certain dimensions constant while the family
changes size.

Effects of Automatic Dimensions on Your Geometry

When automatic sketch dimensions constrain geometry to reference planes, you may see some unexpected
behavior in your project. The automatic sketch dimensions are Revit Architecture's way of solving how to
grow or shrink geometry based on changes in value of a family parameter.

For example, you have added a rectangular window to a fire door that has a labeled dimension for the width,
but you have not dimensioned the window.

You decide to change the width of the door, but you want the window width to stay the same. You expect
its position to remain unchanged; however, observe what happens when you increase the width of the door
using the Family Types tool.
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In this example, the window is constrained to the centerline of the door and the right side of the door panel,
both of which are represented by reference planes. The window's position remains fixed relative to those
reference planes.

In this example, the small extrusion is constrained to the centerline of the panel board and the right side
of the panel board, both of which are represented by reference planes. The small extrusion’s position remains
fixed relative to those reference planes.

To see the automatic sketch dimensions, edit the sketch of the window and turn on the visibility of the
dimensions. You will see how the vertical sketch lines of the window are dimensioned to the center and
right reference planes.

Image legend:

1 Auto sketch dimension to right reference plane.
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2 Auto sketch dimension to center reference plane.

To achieve the desired results, add locked dimensions. For example, you could add a locked dimension for
the width of the window and a locked dimension from the window to the right reference plane.

Visibility of Automatic Sketch Dimensions in the Family Editor
Automatic sketch dimensions are turned off by default. They display if there is at least one labeled dimension
in the family.

Notice in the following image that there is a dimension added to the geometry, but the dimension has no
label.

No automatic sketch dimensions are visible.

To turn on visibility of automatic sketch dimensions

1 While in sketch mode, click View tab ➤ Graphics panel ➤ Visibility and Appearance, or type
VG.

2 On the Annotation Categories tab of the Visibility/Graphic dialog, expand the Dimensions
category, and select Automatic Sketch Dimensions.

3 Click OK.

4 Place and label a dimension.

The automatic sketch dimensions display.
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Revit Architecture now knows where each line of this geometry exists with respect to reference planes or
other sketch lines.

As you add locked dimensions, they replace the automatic sketch dimensions, as shown.

Dimensioning with Families
Families in Revit Architecture are not parametric until you add labeled dimensions (parameters) to them.

Labeling dimensions
1 Highlight the dimension text.

2 Right-click the dimension, and click Edit Label.

3 Select a label name, or select <Add parameter...> and create a parameter.

Alternate procedure for labeling

1 Select the dimension text.

2 On the Options Bar, for Label, select a name, or create a new parameter.

3 If desired, select Leader to create a leader line for the dimension.
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Tips for Creating Family Dimensions
■ You cannot type text as a label when you select a dimension. You can only select from a list of family

parameters that are of the correct type, or you can create a new parameter.

■ Labeled dimensions become modifiable parameters for families. You can modify their values using the
Family Types dialog. When the family is loaded into a project, you can also modify the dimensions using
the Instance Properties dialog.

■ Values for labeled parameters can be calculated using formulas. You create the formulas in the Family
Types dialog. See Using Formulas for Numerical Parameters on page 62.

■ An array number can be a parameter for a family. After you create the array, you should select it and
then label it in order to create a parameter. You can then modify the parameter value and increase or
decrease the number of elements in the array. See Creating an Array in the Revit Architecture 2010 Help.

Adding Family Parameters
You can create instance or type parameters for any family type. By adding parameters, you gain control over
the information contained in each family instance or type. You can create dynamic family types for increased
flexibility within the model.

Example 1: A table with different finishes

Create a table family with 2 material parameters called Table Top Finish and Table Leg Finish. Assign materials
to the parameters and load the family into your project. Now you can change materials in the project: table
tops in 3 different finishes (Oak, Pine, and Beech) and table legs in 3 colors of paint (Teal, Navy Blue, and
Black). Rather than make 9 different family types to account for different combinations, you can make one
family type with instance parameters for the table top finish and for the table leg finish. This lets you alter
the appearance for each table instance within your model.

Example 2: A window with different paints

In this example, your customer wants to view different color paints on the installed window frames. Within
the window family, create a type parameter named Paint, and assign the parameter to the window frames.
Save the family and load it into the project. Create 2 new materials: Window Paint-White and Window
Paint-Brown. You can now apply either the white or brown paint to the Paint type parameter, and view the
changes to the entire model instantly.

Creating Parameters

To create parameters

1 In the Family Editor, on any tab, click Family Properties panel ➤ Types.

2 In the Family Types dialog, click New, and enter a name for the new type.

This creates a new family type that will be available in the Type Selector when you load it into
a project.

3 Under Parameters, click Add.

4 In the Parameter Properties dialog, under Parameter Type, select Family parameter.

5 Enter a name for the parameter.

6 Select a discipline.
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7 For Type of Parameter, select the appropriate parameter type.

DescriptionName

Completely customizable. Can be used to collect unique data.Text

A value that is always expressed as an integer.Integer

Used to collect miscellaneous numeric data. Can be defined by a formula. Can also
have real numbers.

Number

Can be used to establish the length of an element or subcomponent. Can be defined
by a formula.

Length

Can be used to establish the area of an element or subcomponent. Formulas can
be used in this field.

Area

Can be used to establish the length of an element or subcomponent. Formulas can
be used in this field.

Volume

Can be used to establish the angle of an element or subcomponent. Formulas can
be used in this field.

Angle

Can be used to create parameters that define slope.Slope

Can be used to create currency parameters.Currency

Provides web link to user defined URL.URL

Establishes parameters in which a specific material can be assigned.Material

Used most often for instance properties when the parameter is defined with either
a Yes or No.

Yes/No

Used with nested components and allows you to swap components after the family
is loaded into a project.

Family Type

8 For Group parameter under, select a value.

After the family is loaded into a project, this value determines which group header the parameter
displays under in the Instance Properties dialog.

9 Select either Instance or Type. This defines whether the parameter is an Instance or Type
parameter.

10 Click OK.

NOTE To assign a material to a family element, save the family and load it into a project. Place the
family in the project and select it. On the Family Properties panel, click Types and set a value for the
material parameter.

Modifying Family Parameters
In the Family Types dialog, select the desired parameter, and click Modify. You can rename the parameter
and change whether it is a type or instance parameter. You can also replace it with a shared parameter.
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Instance Parameters and Shape Handles
As you create families, you can specify labeled dimensions as instance parameters; the parameters are
modifiable when the family instance is placed in a project. Labeled dimensions specified as instance parameters
can also have shape handles that display when the family is loaded into a project.

Creating Instance Parameters
1 Sketch family geometry using Family Editor tools.

2 Create dimensions for the family geometry.

3 Label the dimensions. See Labeling Dimensions to Create Parameters on page 29.

4 Select the dimensions and, on the Options Bar, select Instance Parameter.

NOTE If you label dimensions by selecting a label on the Options Bar, you can select Instance
Parameter without re-selecting the dimensions.

5 Click Modify Dimension tab ➤ Family Properties panel ➤ Types.

In the Family Types dialog, notice the new instance parameter. The (default) label indicates the
value for the instance parameter when you place the family in a project. For example, if you
create an instance parameter called length with a default value of 3000 mm, the family instance
will have a length of 3000 mm when placed in a project.

6 Save changes and load the family into a project. Select an instance of the family and click
Element panel ➤ Element Properties drop-down ➤ Instance Properties.

Notice that the labeled dimensions display as parameters in the Instance Parameters pane of
the Instance Properties dialog. You can change the values in the dialog.

Adding Shape Handles to a Component Family
You can add shape handles to a component family that display when the family is loaded into a project.
The shape handles let you resize the component in the project, instead of creating multiple types in the
Family Editor. See Controls and Shape Handles in the Revit Architecture 2010 Help.

Example of a generic component in plan and 3D views with shape handles
added

To add shape handles to a component family, you must:

■ Add reference planes to the family.

■ Align the reference planes to the edge of the component where you want the shape handle to display.

■ Add a dimension to the reference planes.
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■ Label the dimension as an instance parameter.

■ Save the family and load it into a project. When you select the component, shape handles display where
the reference planes are aligned and dimensioned.

To add shape handles:

1 While in the Family Editor, add reference planes parallel to where you want the shape handles
to display.

In the following image, a generic component with a simple extrusion is shown in plan view.
Reference planes have been added parallel to the left and right edges.

2 Select each of the reference planes, and click Modify Reference Planes tab ➤ Element
panel ➤ Element Properties drop-down ➤ Instance Properties. Verify that the Is Reference
parameter is a value other than Not a Reference.

3 Align and lock the reference planes to the parallel edges of the component. When the family is
loaded into a project, the shape handles will display at this location.

Generic component family
with reference planes aligned
and locked to the extrusion
edges

4 Add a dimension between the reference planes that you aligned in the previous step.

5 Select the dimension.

6 On the Options Bar, for Label, select a label, or click Add Parameter and create a parameter for
the dimension.

See Adding Family Parameters on page 58.

7 On the Options Bar, select Instance Parameter.
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NOTE When adding a parameter, you can select Instance for the type in the Parameter Properties
dialog.

8 Save changes and load the family into a project.

After the family is loaded into a project, select the component. Shape handles display and allow you to resize
the family without the need for creating new sizes in the Family Editor.

Using Formulas for Numerical Parameters
Formulas allow you to create parameters that depend on other parameters for their values. A simple example
would be a width parameter set to equal twice the height of an object. In practice, formulas can be used in
many ways, both simple and sophisticated. Typical uses include embedding design relationships, relating a
number of instances to a variable length, and setting up angular relationships. For example, formulas can
be used to

■ Calculate area or volume of geometry

■ Create a clearance dimension parameter controlled by element size

■ Convert continuously variable values into integer values

■ Add shelves as the height of casework increases

■ Add diagonals in an open web joist as the length increases

Adding a Formula to a Parameter
1 In the Family Editor, lay out reference planes.

2 Add dimensions, as required.

3 Label the dimensions. See Labeling Dimensions to Create Parameters on page 29.

4 Add the geometry, and lock the geometry to the reference planes.

5 On the Family Properties panel, click Types.

6 In the Family Types dialog, in the Formula column next to the appropriate parameter, type the
formula for the parameter. For more information about entering formulas, see Valid Formula
Syntax and Abbreviations on page 62.

Valid Formula Syntax and Abbreviations
Formulas support the following arithmetic operations: addition, subtraction, multiplication, division,
exponentiation, logarithms, and square roots. Formulas also support the following trigonometric functions:
sine, cosine, tangent, arcsine, arccosine, and arctangent.

The valid formula abbreviations for arithmetic operations and trigonometric functions are

■ Addition— +

■ Subtraction— -

■ Multiplication—*

■ Division—/

■ Exponentiation—^: x^y, x raised to the power of y

■ Logarithm—log
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■ Square root—sqrt: sqrt(16)

■ Sine—sin

■ Cosine—cos

■ Tangent—tan

■ Arcsine—asin

■ Arccosine—acos

■ Arctangent—atan

■ e raised to an x power—exp

■ Absolute Value—abs

You can enter integers, decimals, and fractional values in formulas, using normal mathematical syntax, as
shown in the examples below:

■ Length = Height + Width + sqrt(Height*Width)

■ Length = Wall 1 (11000mm)+ Wall 2 (15000mm)

■ Area = Length (500mm) * Width (300mm)

■ Volume = Length (500mm) * Width (300mm) * Height (800 mm)

■ Width = 100m * cos(angle)

■ x = 2*abs(a) + abs(b/2)

■ ArrayNum = Length/Spacing

Parameter names in formulas are case sensitive. For example, if a parameter name begins with a capital letter,
such as Width, you must enter it in the formula with an initial capital letter. If you enter it in a formula
using lower-case letters instead, for example, width * 2, the software will not recognize the formula.

Conditional Statements in Formulas
You can use conditional statements in formulas to define actions in a family that depend on the state of
other parameters. With conditional statements, the software enters values for a parameter based on whether
a specified condition is satisfied. Conditional statements are useful in certain circumstances; however, they
make families more complex and should be used only when necessary.

For most type parameters, conditional statements are unnecessary because the type parameter itself is like
a conditional statement: If this is the type, then set this parameter to a specified value. Instance parameters
are a more productive place to use conditional statements, particularly when they are used to set a parameter
that does not vary continuously.

Syntax for Conditional Statements

A conditional statement uses this structure: IF (<condition>, <result-if-true>, <result-if-false>)

This means that the values entered for the parameter depend on whether the condition is satisfied (true) or
not satisfied (false). If the condition is true, the software returns the true value. If the condition is false, it
returns the false value.

Conditional statements can contain numeric values, numeric parameter names, and Yes/No parameters.
You can use the following comparisons in a condition: <, >, =. You can also use Boolean operators with a
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conditional statement: AND, OR, NOT. Currently, <= and >= are not implemented. To express such a
comparison, you can use a logical NOT. For example, a<=b can be entered as NOT(a>b).

The following are sample formulas that use conditional statements.

Simple IF: =IF (Length < 3000mm, 200mm, 300mm)

IF with a text parameter: =IF (Length > 35', “String1”, “String2”)

IF with logical AND: =IF ( AND (x = 1 , y = 2), 8 , 3 )

IF with logical OR: =IF ( OR ( A = 1 , B = 3 ) , 8 , 3 )

Embedded IF statements: =IF ( Length < 35' , 2' 6" , IF ( Length < 45' , 3' , IF ( Length < 55' , 5' , 8' ) ) )

IF with Yes/No condition: =Length > 40 (Note that both the condition and the results are implied.)

Examples of Conditional Statement Usage

Typical uses for conditional statements in formulas include calculating array values and controlling an
element’s visibility based on a parameter value. For example, you can use conditional statements to

■ Prevent an array parameter from taking a value less than 2.
In Revit Architecture, arrays can only have an integer value of 2 or greater. In some situations, it may be
useful to create a conditional formula that maintains an array parameter of 2 even if the calculated value
is 1 or 0. With such a formula, if the calculated array value is 2 or greater, the formula retains the value.
However, if the calculated value is 1 or 0, the formula changes the value to 2.

Formula: Array number = IF (Arrayparam < 2, 2, Arrayparam)

■ Make muntins visible only when the number of window lights is greater than 1.
For example, if you have a Lights parameter that you want to use to control the visibility of muntin
geometry, you can create a Yes/No parameter like MuntinVis, and assign it to the Visible parameter in
the Instance Properties dialog of the muntin geometry. Because the MuntinVis parameter is a Yes/No (or
Boolean) operation, both the condition (IF) and the results are implied. In this example, when the
condition is met (true), the MuntinVis parameter value is selected, and the muntin geometry is visible.
Conversely, when the condition is not met (false), the MuntinVis parameter is cleared, and the muntin
geometry is not visible.

Formula: MuntinVis = Lights > 1

Duplicating Parameterized Elements
When creating a component in the Family Editor, you often need to create identical elements that are
controlled by the same parameters, such as labelled dimensions or visibility parameters. For example, if you
create a window family with muntins controlled by a visibility parameter, you can create the first muntin,
apply the visibility parameter to it, and then copy, array, or mirror the muntin. The visibility parameter of
the original muntin is applied to the duplicated muntins.

If you copy, array, or group a parameterized element, the parameters that control that element are also
copied.

In the example shown below, a generic family was created with 2 extrusions. The bottoms of both extrusions
are aligned to the horizontal reference plane. The height of the large extrusion is controlled by the labelled
dimension H. The height of the smaller extrusion is controlled by the labelled dimension (H/2). In the
Family Types dialog, a formula was added to the (H/2) parameter to make it equal to Height/2. In addition,
a visibility parameter was created and applied to the smaller extrusion, which has a split and painted face.
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Elements controlled by parameters (labelled dimensions in this case)

Continuing with the example shown above, to create a series of elements identical to the sub-height element,
you can copy, array, or mirror the element, and the associated parameters are copied with it. In the image
below, you can see that the smaller element was arrayed and the labelled dimension, painted face, and
visibility parameters are applied to each arrayed element.

Array of parameterized elements

In the Family Types dialog, if the Height value in this example is changed from 6 to 8, notice that the arrayed
elements adjust to the new values.
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Arrayed elements adapt to changed parameter values

Assigning Family Geometry to Subcategories
You can assign different pieces of family geometry to subcategories within the family category. A subcategory
controls the line weight, line color, line pattern, and material of the geometry assigned to it, independent
of the family category settings. By assigning portions of the family geometry to different subcategories, you
can display the portions with different line weights, line colors, line patterns, and material assignments.

For example, in a window family, you could assign the frame, sash, and mullions faucet to one subcategory
and the glass tub basin to another. You could then assign different materials (wood and glass) to each
subcategory to achieve the following effect.
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If you haven’t created subcategories or the family does not contain them by default, you can create them
at any time. See Creating Family Subcategories on page 21.

To assign family geometry to a subcategory

1 In the Family Editor, select the family geometry that you want to assign to the subcategory.

2 Click Element panel ➤ Element Properties drop-down ➤ Instance Properties.

3 In the Instance Properties dialog, for Subcategory, select a subcategory.

4 Click OK.

Managing the Family Visibility and Detail Level
Visibility of a family determines in which view the family displays and what it looks like in that view.
Typically, when an element is created by a family, the geometry of the element will change, depending on
the current view. In a plan view, you may want to see a 2D representation of the element. In a 3D or elevation
view, you may want a fully detailed 3D representation of the element. You have the flexibility to display
different levels of geometry.

For example, you could create a door frame and use lines to represent it. Or you could extrude the door
frame, so it has a 3D representation.

Detail Level determines the visibility of elements at different levels of detail. For example, you might create
a door with certain embellishments. You then may decide that the embellishments should only appear at
a certain detail level.You control the detail level in a project view with the Detail Level option on the View
Control Bar.

You can set the visibility and detail level of any 2D and 3D geometry in the family before or after you create
it.

1 Do either of the following:

■ To set the visibility before you sketch the geometry, click the tool that you want to use to
create the geometry, and on the Visibility panel, click Visibility Settings.
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■ If you have already created the geometry, select it, and click Visibility Settings. The name of
the panel this tool appears on varies depending on the type of geometry selected.

2 In the Family Element Visibility Settings dialog, select the views in which you want the geometry
to display:

■ Plan/RCP

■ Front/Back

■ Left/Right

NOTE All geometry automatically displays in 3D views.

3 If desired, select When cut in Plan/RCP (if category permits).

If you select this option, the geometry appears cut if it is intersected by the cut plane of the
view. If the element is cut by a section view, it also shows if you select this option.

4 Select the detail levels at which you want the geometry to display in a project:

■ Coarse

■ Medium

■ Fine

Detail levels are dependent upon view scale.

NOTE The Family Element Visibility Settings dialog is different for families of profiles and detail
components. For these families, you can set only the detail level.

5 Click OK.

TIP You can set family elements to be visible or not visible in the project by associating the Visible
parameter of solid geometry tools with a family parameter for that element. The Visible parameter
is available for solid and void geometry tools (blends, sweeps, swept blends, revolves, and extrusions).
This lets you create one family type with optionally visible geometry on it. For example, you might
create a door and have a coat hook or kick plate on that door be optional. Note that the family
geometry still exists in the project, it is just invisible. For example, it may still be involved when you
join geometry in the project.

6 If you set the visibility before you created the geometry, create the geometry.

Cuttable and Non-Cuttable Family Categories
Revit Architecture families are either cuttable or non-cuttable. If a family is cuttable, the family displays as
cut when the cut plane (of a plan view) or the clipping plane (or sections and elevations) intersects that
family. If the family is non-cuttable, it displays in projection, regardless of whether it is intersected by the
cut plane.

You can determine if a family category is cuttable in the Object Styles dialog (click Manage tab ➤ Family
Settings panel ➤ Settings drop-down ➤ Object Styles). If the Line Weight Cut column is disabled, the category
is non-cuttable.
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Cuttable Families
If a family is cuttable, the family displays as cut when the cut plane of a view intersects that family in all
types of views.

In the Family Element Visibility Settings dialog, there is an option called When cut in Plan/RCP. This option
determines if family geometry is shown when the cut plane intersects that family. For example, in door
families, the geometry for plan swing is set to be shown when the door is cut in plan views and not shown
when the door is not cut.

This option is never made available and is never selected for non-cuttable families. For some cuttable families,
the option is made available, and you can select it. For other cuttable families, the option is never made
available, but it is always selected.

The following table lists cuttable families and whether the option is made available for that family.

NOTE Not Applicable means the category is a system family that cannot be made from a family template.

Option Made AvailableFamily Category

YesCasework

Not ApplicableCeilings

YesColumns

NoCurtain Wall Panels

YesDoors

Not ApplicableFloors

NoGeneric Models

Not ApplicableRoofs

YesSite

YesStructural Columns

YesStructural Foundations

YesStructural Framing

NoTopography

Not ApplicableWalls

YesWindows

Non-Cuttable Families
The following families are not cuttable and are always shown in projection in views:

■ Balusters
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■ Detail Items

■ Electrical Equipment

■ Electrical Fixtures

■ Entourage

■ Furniture

■ Furniture Systems

■ Lighting Fixtures

■ Mechanical Equipment

■ Parking

■ Planting

■ Plumbing Fixtures

■ Specialty Equipment

Adding a Website Link to a Family
You can add a website link to the Type or Instance properties of a family in both the Family Editor and in
the project environment. Selecting the URL opens the default web browser to the selected location. For
example, if you are creating a manufacturer-specific window family, you could add the URL and provide
the user with a direct link to the manufacturer's website.

Testing a Family in a Project
After you have finished a family, load it in at least one project, and create elements with the family types
to ensure it works correctly. Make sure you select a test project that contains any geometry with which the
family must interact. For example, if the family is a host-based family like a window, ensure that the test
project contains the host elements (walls).

BEST PRACTICE  Until you successfully test the family, do not save it in a library where it is accessible to others.

To test a family in a project

1 Open a test project.

NOTE Imperial and metric testing projects are available in the Training Files folder. Click 
 ➤ Open ➤ Project, click Training Files in the left pane of the Open dialog, and open Imperial or
Metric. Open Imperial_ Family_Testing_Template.rvt or Metric_Family_Testing_Template.rvt.

2 To load the family in the project, do either of the following:

■ In the family, click Create tab ➤ Family Editor panel ➤ Load into Project.

■ In the project, click Insert tab ➤ Load from Library panel ➤ Load Family, navigate to the
location of the family, select it, and click Open.

3 In the project, click the Home tab, and then click the appropriate tool to begin creating an
element from one of the new family types.

4 On the Element panel, select a type from the Type Selector drop-down.
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5 Add the element to the project.

If the element is host-based, place it in a host element.

6 In the current view, test the element:

■ On the View Control Bar, change the Detail Level and/or Model Graphics style to ensure
that visibility settings work correctly.

■ Change the scale to resize the element.

■ Click View tab ➤ Graphics panel ➤ Visibility & Graphics, and change the visibility for the
element by category and, if applicable, by subcategories.

■ Select the element, right-click, and click Element Properties.

■ In the Instance Properties dialog, change any of the instance parameters, and click OK to
view and verify the changes.

■ If the family contains multiple types, select the element, and on the Modify <element>
tab ➤ Element panel, select a different family type from the Type Selector drop-down.

7 Open additional project views, and repeat step 6.

8 If the family contains more than one type, repeat steps 3-6 to test other types in the family.

9 If you find any errors in the family, edit the family, and retest it in a project.

10 When you finish testing the family, save it in the imperial or metric Revit Architecture library
or in another location of your choice.

Advanced Loadable Family Techniques
After you understand the basics of creating parametric families, there are more complex techniques that you
can use when you create families:

■ Nesting and sharing families to combine the geometry of 2 or more families

■ Linking family parameters

■ Creating face- and workplane-based families

Nesting and Sharing Component Families
You can nest (insert) families within other families to create new families that contain the combined family
geometry.

For example, rather than model a combination window family from scratch, you can create the
combination-window family below by loading the Double Hung and Instance - Fixed families into a new
window family. Place the fixed window instance in the center with a double hung window on each side.
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Whether you share families before you nest them determines the behavior of the nested geometry in elements
that you create with the family.

■ If you nest a family that is not shared, components created by the nested family act with the rest of the
element as a single unit. You cannot select (edit), tag, or schedule the components separately.
In the sample window family shown above, an instance of the nested and unshared family would have
only one window tag and would schedule as a single unit, as shown below.

■ If you nest a shared family, you can select, tag, and schedule the components separately.
In an instance of the shared window family, the 3 windows would tag and schedule separately, even
though the nested family would behave has a single component within the building model.

Nesting Restrictions

There are certain restrictions regarding the type of families that you can load and nest in other families:

■ Only annotation families can be loaded into other annotations.

■ Only detail families and generic annotations can be loaded into details.

■ Model families, details, generic annotations, section heads, level heads, and grid heads can be loaded
into model families.

Nesting Families with Interchangeable Components

By applying a family type parameter to a nested component, you can create families with interchangeable
subcomponents. After you load and create an element with the nested family, you can swap components
at any time.

Creating a Family with Nested Components
To nest families in another family, create or open a host (base) family, and then load and insert instances
of one or more family types into it. The base family can be a new (empty) family or an existing family.
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To create a family with nested components

1 Create or open a family into which you want to nest a family.

2 In the Family Editor, click Insert tab ➤ Load from Library panel ➤ Load Family.

3 Select any families that you want to nest, and click Open.

4 Click Home tab ➤ Build panel ➤ Family drop-down ➤ Place a Family.

5 On the Type Selector panel drop-down, choose the component type that you want to nest.

6 Click in the drawing area to place the nested component in the family.

7 If necessary, repeat steps 4-6 to nest components in the family.

8 Save the family.

Creating a Family with Nested and Shared Components
To create a family with nested and shared components, share the families before you nest them in a host
family. The host family does not need to be a shared family.

When you create a nested family of shared components, the first decision you need to make is in what
category the host family will belong. This decision has many downstream implications for tagging, scheduling,
and ODBC information, as described in the example below.

A ganged window unit is created as a nested and shared family. In this case, the large center window was
used as the host family and the 2 side windows were nested as shared families. This window is intended to
be built on-site using the subcomponents that are purchased as separate units by the builder. The family
was saved as Triple_window.rfa.

Nested windows

When the ganged unit shown above is loaded into a project, tagged, and scheduled, the result is as follows:
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Nested and shared families loaded into a project

Notice that each window is tagged and scheduled separately. However, notice the ganged window name,
Triple _window, is listed with the subcomponents. This window also represents the main window of the 3
window set.

In the example shown below, the same triple window family was created, but with a new window family
used as the host family and both the fixed window and the double-hung windows loaded as shared families.
Notice the difference in the tagging and scheduling.

Ganged window family started as a new family

74 | Chapter 3   Loadable Families Overview



In the example shown above, notice the host family schedules with each of the 3 subcomponent windows.
If this is not your design intent, you should follow the previous example, where one of the subcomponents
is the host family.

To share a family before nesting it

1 Open a family to be shared, and click Manage tab ➤ Family Properties panel ➤ Category and
Parameters.

IMPORTANT Annotation, profile, and in-place families cannot be shared families.

2 In the Family Category and Parameters dialog, under Family Parameters, select Shared.

Although you can set most families as shared families, it only becomes relevant when the family
is nested into another family and loaded into a project.

3 Click OK.

4 Save and close the family.

To nest shared families in a host family

1 Open the host family or start a new family.

2 Open the families that you want to nest, and share them.

3 Load and place a nested component within the host family.

4 Repeat this process for each nested component.

5 Save the family.

Loading Families with Shared Components into a Project
You load families that contain nested components or nested and shared components into a project using
the same methods as any other family. When you load a family comprised of nested components or nested
and shared components into a project, the following rules apply:

■ The host family, along with all nested and shared components, is loaded into the project. Each nested
component is available within the Project Browser under its respective family category.

■ A nested family can exist within a project and be shared by more than one host family.

■ When loading shared families, if a version of one of the families already exists within the project, you
have the option to use the version from the project or from the family you are loading.

IMPORTANT After a shared family is loaded into a project, you cannot reload an unshared version of the same
family and overwrite it. You must delete the family and reload it.

To load families with shared components into a project

1 Open the project into which you want to load the family.

2 Click Insert tab ➤ Load from Library panel ➤ Load Family.

3 In the Load Family dialog, select the family to load, and click Open.

4 Add instances of the family to your projects.

Working with Shared Components in a Project
A family that contains nested and shared families works as any other family within a project. However, you
can press Tab to toggle to the nested and shared components.

Advanced Loadable Family Techniques | 75



Selecting sub-instances of a shared family

If you select a nested instance, you can do the following:

■ Click Modify <Element> tab ➤ Element panel ➤ Element Properties drop-down ➤ Instance Properties.
In the Instance Properties dialog, modify some parameters, such as Mark and Comments.

■ Modify type properties. When you do this, all instances of that type also update to reflect the changes.

If you select a nested instance, you cannot do the following:

■ Select and delete a nested instance.

■ Mirror, copy, move, or array a nested instance.
If you do this, the entire host family adapts, not just the nested instance.

■ Modify the position, the size, or shape of a nested instance.

Scheduling Shared Components
To create a schedule containing shared families, you use the same method as any other schedule. See Schedule
Views in the Revit Architecture 2010 Help.

When you nest and share families, you can schedule shared families as individual instances. A family
comprised of shared and nested families allows each instance of a nested family to schedule separately.
Within the schedule, you can renumber each instance of a nested family.
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Family comprised of 2 shared window families loaded into a project

If a nested family contains multiple categories, each instance of a nested family displays in its respective
schedule and all components will display on a multi-category schedule.

In contrast, in a family where no nested families are shared, instances of the nested families schedule only
as one instance.

Creating a Nested Family with Interchangeable Components
You can create families that feature interchangeable nested components when added to your projects. To
control the type of family within a nested family, you create a family type parameter that can be either an
instance or type parameter. After you label a nested component as a family type parameter, subsequently
loaded families of the same type automatically become interchangeable without any further work.

For example, if you add 2 transoms to a door family, you have to position only one of the transoms, label
it as a family type parameter, and then the other transom becomes part of the list of available transoms. If
you load 5 more transom types, they are all available for selection.
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Door family with multiple nested transoms assigned to a family
type parameter

If you need the nested family components to tag and schedule individually, make sure each family that you
load into the host family is shared.

1 Open a family or start a new one.

2 Load the components that you want to nest within the family. For example, if you are in a door
family, load several transom types.

3 Click Create tab ➤ Model panel ➤ Component, and select an element from the Type Selector
drop-down.

4 Click in the drawing area to place the first component at its desired location.

NOTE In the door family example, you would also want to tie the width of the transoms to the width
of the door. Depending on your specific circumstances, you may want to consider a similar action.
This ensures that as components swap, they remain in the same position and the same size.

5 Select the nested component.

6 On the Options Bar, for Label, select Add Parameter.

NOTE When adding a parameter in the Family Types dialog, click Add Parameter, select Family Type
as the Category, and select the category from the Select Category dialog. When you add the parameter
using the Options Bar, the parameter is automatically assigned to Family Type and the respective
family category is assigned.

7 In the Parameter Properties dialog, under Parameter Type, select Family Parameter.

8 Under Parameter Data, enter a name for the parameter, and select either Instance or Type
parameter.

9 Select a value for Group parameter under.

This designates under which heading the parameter displays in the Instance (or Type) Properties
dialog.

10 Click OK.

11 Save the file and load it into a project.

12 Add the component to the building model, select it, and click Modify <element> tab ➤ Element
panel ➤ Element Properties drop-down ➤ Instance (or Type) Properties.

13 Locate the family type parameter, and select a different component from the list.
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Controlling the Visibility of Families with Nested and Shared Components
You can control the visibility of nested family instances in the host family. See Managing the Family Visibility
and Detail Level on page 67.

1 In the host family, select the nested family.

2 Click Modify <element> tab ➤ Visibility panel ➤ Visibility Settings.

3 In the Family Element Visibility Settings dialog, specify the View Specific Display and Detail
Level settings.

NOTE In nested families, you cannot specify the visibility option for When cut in Plan/RCP.

4 Click OK.

Linking Family Parameters
By linking family parameters, you can control the parameters of families nested inside host families from
within a project view. You can control either instance or type parameters.

To link parameters, they have to be the same type. For example, link a text parameter in the host family to
a text parameter in the nested family.

You can link a host-family parameter to more than one nested-family parameter of the same type. Also, you
can link this parameter to multiple nested families.

Creating Family Parameter Links
1 Create a family with instance parameters or type parameters of the available types.

2 Save the family and load it into a host family.

3 With the new family open, click Create tab ➤ Model panel ➤ Component drop-down ➤ Place
a Component, and place as many instances of the loaded family as desired.

4 Click Manage tab ➤ Family Properties panel ➤ Types.

5 In the Family Types dialog, under Parameters, click Add.

6 Follow the steps for creating a new parameter of the same type as the parameter you want to
control in the nested family.

7 Click OK to close the Family Types dialog.

8 Select an instance of the loaded family in the host family, and click Modify <Element>
tab ➤ Element panel ➤ Element Properties drop-down ➤ Instance Properties or Type Properties.

For instance properties and type properties, there is a column that has an equal sign (=) in the
column heading. Gray buttons next to certain parameters indicate that they can be linked to
other parameters.

9 Click the button next to a parameter that is of the same type as the one you created in Step 6.

For example, if you created a text parameter, you must select a text parameter here.

10 In the dialog that appears, select the parameter you created in Step 6 to associate it with the
current parameter, and click OK.

NOTE When you associate 2 parameters, an equal sign appears on the button: 

11 Click OK to close properties dialog.

12 Continue creating the host family, and save it.
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13 Load the family into a project, and place a few instances of it.

14 Select an instance of the family and click Modify <Element> tab ➤ Element panel ➤ Element
Properties drop-down ➤ Instance Properties or Type Properties.

15 Locate the type or instance property you created.

16 Set it to the desired value and click OK.

The nested family changes according to the value you entered.

Creating Parameter Links for Model Text
If you place model text into a family, it acts like a nested family. You can create parameters in the host
family to control the text and depth of the model text in the project.

To control text

1 To place some model text in the host family, click Create tab ➤ Model panel ➤ Model Text, and
then type the text in the Edit Text dialog.

2 On any tab, click Family Properties panel ➤ Types and add a family parameter that is of type
text. This will be the parameter that controls the text of the model text in the project.

3 In the Family Types dialog, enter some text in the Value field for the new parameter. For example,
if you created a parameter called Mtext, you might enter default.

NOTE Do not leave the Value field empty. If you do, Revit Architecture issues a warning.

4 Click OK.

5 Select an instance of model text in the family, and click Modify Model Text tab ➤ Element
panel ➤ Element Properties drop-down ➤ Instance Properties.

6 In the Instance Properties dialog, for Text, click  .

7 In the Associate Family Parameter dialog, select the parameter you created to link to the model
text parameter.

8 Click OK twice.

9 Continue creating the host family and save it.

10 Load that family into a project and place a few instances of it.

11 Select an instance of the family and click Modify <element> tab ➤ Element panel ➤ Element
Properties drop-down ➤ Instance Properties.

12 Edit the model text parameter.

The model text updates to the new value. If you created an instance parameter, just the one
instance changes. If you created a type parameter, all current and future instances of the model
text change.

To control depth

Controlling model text depth is similar to controlling text, except that you create a family parameter that
is of type length. Follow the above procedure to link parameters for model text depth.

Loading Generic Annotations into Model Families
You can nest generic annotation families inside host model families, so that the annotations appear in the
project. This is useful if you want to include a label with a model family and display that label in the project.
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Generic annotations hosted by model families scale with the view when they are loaded into the project.
When you place these generic annotations on a sheet, they display at the same size, regardless of view scale.
For example, a 3/32'' text label in a model family always prints at that size on a sheet, even if that label
appears on the sheet in a view with a 1/8" = 1'0" scale or a view with a 1/4'' = 1'0'' scale.

You can also control the visibility of generic annotations in the project separately from the host model
family.

Adding a Generic Annotation
You can create a generic annotation family or load one from the available annotation families in the Revit
Architecture library. This procedure uses an existing annotation family.

NOTE Though this procedure uses specific family files, the steps are common to any generic annotation you may
want to add to a model family.

1 Click  ➤ Open ➤ Family.

2 Open the microwave.rfa family from the Specialty Equipment\Domestic  folder in the Imperial
library. The microwave from the Metric library is in the same folder and is called
M_microwave.rfa.

3 Click Insert tab ➤ Load From Library panel ➤ Load Family.

4 Navigate to the Annotations folder, select Label Annotation 3-32.rfa, and click Open. .

5 Open a floor plan view in the microwave.rfa file.

You can place a generic annotation in plan only.

6 Click Detail tab ➤ Detail panel ➤ Symbol, and place an instance of the label at the intersection
of the 2 reference planes in the center of the microwave.

Label snapping to intersection of
reference planes

Next you associate this label with a parameter in the host family.

7 Click Place Symbol tab ➤ Family Properties panel ➤ Types.

8 In the Family Types dialog, under Parameters, click Add.

9 In the Parameter Properties dialog, under Parameter Type, select Family parameter.

10 Under Parameter Data, for Name, type Label.

11 For Type of Parameter, select Text.

This parameter will be stored by type.

12 Click OK twice.

13 Select the label instance you placed on the microwave, and click Modify Generic Annotations
tab ➤ Element panel ➤ Element Properties drop-down ➤ Type Properties.

Advanced Loadable Family Techniques | 81



14 Locate the Label parameter.

15 In the row for the Label parameter, click the button under the equal sign (=) column.

16 In the Associate Family Parameter dialog, select the parameter Label. This is the parameter you
created in steps 6-10.

17 Click OK twice.

18 If desired, you can set at which detail level the label appears in a project. Access the instance
properties for the annotation. Next to the Visibility/Graphics Overrides instance parameter,
click Edit, and then select coarse, medium, or fine. If you leave a particular detail level unselected,
the label will not show in a project view set at that detail level.

19 Save the microwave.rfa  family and load it into your project.

20 Open a plan view, and click Home tab ➤ Build panel ➤ Component.

21 Select the microwave from the Type Selector drop-down, and place an instance in the project.

22 Select the microwave, and click Modify Specialty Equipment tab ➤ Element panel ➤ Element
Properties drop-down ➤ Type Properties.

23 In the Type Properties dialog, for Label, enter MW.

24 Click OK.

The microwave displays with the specified label in the view.

25 If desired, change the detail level of the view to change the visibility of the label.

See Managing the Family Visibility and Detail Level on page 67.

NOTE  You can also change the visibility of the label by turning off Generic Annotations on the
Annotation Categories tab of the Visibility/Graphics dialog.

Creating Work Plane-based and Face-based Families
You can create a family that is hosted by the active work plane. This can be very useful both in a project
environment and within a nested family, when it’s necessary for a nested sub-component to reside on a
particular plane. You can make any non-hosted family a work plane-based family. For example, a generic
component, a furniture component, and a site component can all be work plane-based families because they
are not required to be hosted by another component. Doors and windows cannot be work plane-based
because they are wall-hosted components.
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Example of generic component family nesting a work plane-based component. On the
left, the work plane is selected; on the right, the work plane-based component was
added.

Another way to create components that can be placed with any orientation is to use face-based families. A
face-based family must be created from the Generic Model face based.rft template. A face-based component
can be placed on any surface, including walls, floors, roofs, stairs, reference planes, and other components.
If the family contains a void that cuts the host, the component will cut its host, only if the host is a wall,
floor, roof, or ceiling. When a component with a void is placed on any other host, it will not cut.

Creating a Work Plane-based Family
1 Open or create a non-hosted family.

NOTE Only non-hosted components can become work plane-based families. Doors and windows,
for instance, are hosted by walls and cannot become work plane-based components.

2 In the Family Editor, on any tab, click Family Properties panel ➤ Category and Parameters.

3 In the Family Category and Parameters dialog, under Family Parameters, select Work Plane-Based.

4 Click OK.

NOTE You can make a family both work plane-based and always vertical. Examples of both are shown
below.

In the nested family below, the rectangular extrusion is a work plane-based component.
On the left, the extrusion is work plane-based but not always vertical. On the right,
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the same extrusion was reloaded into the family after designating it work plane-based
and always vertical.

Creating Vertical Families
The option to create vertical or non-vertical families pertains only to families hosted by walls, floors, ceilings,
roofs, and site surfaces. You can specify a family component, such as  a tree or a chandelier, to Always
Vertical; after it is loaded into a project, the component remains vertical regardless of the slope of the host.
In the case of a car or park bench, you can specify the Always Vertical option to No, which lets the car and
the park bench adapt to the slope of the host.

NOTE The Always Vertical parameter does not apply to families created in non host-based templates.

Example of Vertical and Non-Vertical Families; 3 trees are set to Always
Vertical, 2 trees are not.

To set the Always Vertical parameter for a family

1 In the Family Editor, on any tab, click Family Properties panel ➤ Category and Parameters.

2 In the Family Category and Parameters dialog, under Family Parameters, select Always Vertical.

3 Click OK.

Creating a Type Catalog
A type catalog is an external text file (TXT) that contains the parameters and their values that create the
different types in a specific family.
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Following is a sample type catalog TXT file:

,Manufacturer##other##,Length##length##centimeters,Width##length##centi

meters,Height##length##centimeters

MA36x30,Revit,36.5,2.75,30

MA40x24,Revit,40.5,3.25,24

When loading the corresponding family, you would see the following type catalog:

HeightWidthLengthManufac-
turer

Type

30cm2.75cm36.5cmRevitMA36x30

24cm3.25cm40.5cmRevitMA40x24

There are several ways to create a comma-delimited .txt file. You can type it in a text editor such as Notepad,
or you can use database or spreadsheet software to automate the process.

You can export your project to a database using ODBC, and then download the element type tables in
comma-delimited format. See Exporting to ODBC in the Revit Architecture 2010 Help.

As you create the type catalog, follow these rules:

■ Save the type catalog file name with a .txt extension; the file must have the same name and same directory
path as the Revit Architecture family (for example, Doors/door.rfa and Doors/door.txt).

■ Use the left column to list types.

■ Use the top row of the file for parameter declaration. Format is columnname##type##unit.

■ Use decimals.

■ Parameter names are case sensitive.

■ You can use single or double quotes. If you are using double quotes, you need to enter "" for Revit
Architecture to understand it as double quotes.

■ Valid unit types are length, area, volume, angle, force, and linear force.

■ Valid units: Valid units and suffixes:

■ For length: inches ("), feet ('), millimeters (mm), centimeters (cm), or meters (m)

■ For area: square_feet (SF), square_inches (in2), square_meters (m2), square_centimeters (cm2),
square_millimeters (mm2), acres, or hectares

■ For volume: cubic_yards (CY), cubic_feet (CF), cubic_inches (in3), cubic_centimeters (cm3),
cubic_millimeters (mm3), liters (L), gallons (gal)

■ For angle: decimal_degrees (°), minutes ('), seconds (")

■ For force: newtons (N), decanewtons (daN), kilonewtons (kN), meganewtons (MN), kips (kip),
kilograms_force (kgf), tonnes_force (Tf), and pounds (P)

■ For linear force: newtons_per_meter (N/m), decanewtons_per_meter (daN/m), kilonewtons_per_meter
(kN/m), meganewtons_per_meter (MN/m), kips_per_foot (kip/ft), kilograms_force_per_meter (kgf/m),
tonnes_force_per_meter (Tf/m), pounds_per_foot (P/ft)

■ For electrical_luminous_flux: lumens

■ You can enter a value for parameters of type Family Type. To declare the Family Type parameter in the
parameter declaration, you would enter column-name##other##. The column name is the same as the
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Family Type parameter name. In the type catalog file, enter values as Family Name : Family Type. Be sure
there are spaces before and after the colon. For example, a family file called Chair-Executive.rfa with a
type called Big Boss would be entered as Chair-Executive : Big Boss. If the family file has only one type
and it is the same name as the family, you do not need to include the Family Name.

■ Revit Architecture applies project unit settings to type catalogs when you load a family.

Deleting Unused Families and Types
You can delete families or unused family types from your projects and templates using either of 2 methods:
you can select and delete the families and types in the Project Browser, or you can run the Purge Unused
tool.

Select and delete families and types when you have only a few families or types that you need to delete. Use
the Purge Unused tool when you need to “clean up” your projects. Removing all of the unused families and
types usually decreases the project file size.

Method 1: Selecting and deleting families and types in the Project Browser

1 In the Project Browser, expand Families.

2 Expand the category that contains the family or type that you want to delete.

3 If you want to delete a family type, expand the family.

4 Select the family or type that you want to delete.

TIP To select more than one family or type, press and hold Ctrl while selecting.

5 Do either of the following:

■ Right-click, and click Delete.

■ Press Delete.

The family or type is deleted from the project or template.

If you are deleting a family or type from a project, and there is one or more instances of a type
in the project, a warning displays.

6 In the alert dialog:

■ Click OK to delete any instances of the type.

■ Click Cancel, change the type, and repeat the previous step.

Method 2: Using the Purge Unused command

7 Click Manage tab ➤ Project Settings panel ➤ Purge Unused.

The Purge unused dialog lists all of the families and family types that you can unload from the
project, including system and in-place families. By default, all unused families are selected for
purging.

IMPORTANT If the project is workset-enabled, all worksets must be open to use this command.

8 Do either of the following:

■ To purge all unused family types, click OK.

■ To purge only the types that you select, click Check None, expand the families and subfamilies
that contain the types that you want to purge, select the types, and click OK.
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Revit Architecture Families
Tutorials
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Working with System
Families

In this tutorial, you create a number of system family types for the design of a small log cabin. System families exist only
in the Revit Architecture project environment, and cannot be loaded or created externally, like loadable families.

Exterior 3D view of the cabin

System families are predefined in Revit Architecture, and although you cannot create system families, you can create
system family types. To create system family types, you duplicate (copy) types that are in a project, rename them, and
change their properties.

In this tutorial, you create a custom wall type that displays stacked logs and cladding on both the interior and exterior
layers of the cabin walls, a stacked wall type with a concrete stem wall, a custom floor type, and a roof type.

4
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Custom walls and floor in an interior rendered view

After you create the system family types, you learn how to use them in other projects, by copying or transferring them.

Skills used in this tutorial:

■ Duplicating system families to create system family types

■ Creating and applying materials to families

■ Creating custom wall, roof, and floor types

■ Transferring system family types between projects

Creating Custom Wall Materials
In this exercise, you create 2 materials for the custom system family wall type that you create in the next
exercise. You create the materials by duplicating (copying) existing materials, and then renaming and
modifying the properties of the duplicated materials.

The first material that you create is an insulation material used between the exterior and interior wall layers.
You define a granular fill pattern for the insulation material used in a detailed display.
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Insulation (gray) in a section view of an exterior cabin wall

The second material that you create is a wood log material that you apply later in this tutorial to the interior
and exterior wood layers of the custom wall. In this exercise, you create the new material, add a wood color,
and apply surface and cut patterns to the material to ensure a wood cladding effect when you display the
cabin walls in model and section views.

Wood material applied to the exterior wall layers
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Wood material applied to the interior wall layers

You begin this exercise by creating a project in which you create the materials. In the next exercise, you use
the same project to create the custom wall family type.

Create a custom wall project

1 Click  ➤ New ➤ Project.

2 In the New Project dialog:

■ Under Create new, verify that Project is selected.

■ Under Template file, verify that the second option is selected, and click Browse.

3 In the Choose Template dialog:

■ In the left pane, click Training Files.

■ Open Imperial\Templates, select default.rte, and click Open.

4 Click OK.

5 Save the project:

■ Click  ➤ Save As ➤ Project.

■ In the Save As dialog, navigate to the desired location, and enter a file name.

■ Click Save.

Next, create the insulation material to use in the walls of the cabin. You select an existing
insulation material, copy it, and then modify it as necessary to create the new material.

Duplicate and modify an existing material to create the insulation

6 Click Manage tab ➤ Project Settings panel ➤ Materials.

The Materials dialog displays a list of all the available materials in the project.
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7 In the left pane of the Materials dialog:

■ Select Insulation / Thermal Barriers - Semi-rigid insulation.

■ Click  (Duplicate).

8 In the Duplicate Revit Material dialog:

■ For Name, enter Insulation/Thermal Barriers - Proprietary, Log Wall.

■ Click OK.

The real-world insulation is a granular material, so you want the insulation material to display
with a granular pattern in section views. Next, you assign a granular fill pattern to the cut pattern
of the Proprietary Insulation material.

9 In the right pane of the Materials dialog, on the Graphics tab, under Cut Pattern, click  .

10 In the Fill Patterns dialog:

■ Under Pattern Type, verify that Drafting is selected.

■ Under Name, select Sand - Dense.
Drafting patterns, like this Sand pattern, depict materials in symbolic form. The density of
drafting patterns is fixed with respect to the drawing sheet on which an associated element
is placed.

■ Click OK.

Next, you create a log material to assign to the exterior walls of the cabin.

Create the log material

11 In the Materials dialog, with the Proprietary Insulation material selected, click  .

12 In the Duplicate Revit Material dialog:

■ For Name, enter Finishes - Exterior - Proprietary, Log.

■ Click OK.
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Next, assign a realistic wood color and render appearance to the Proprietary Finish material.

13 In the Materials dialog, on the Render Appearance tab, click Replace.

14 In the Render Appearance Library dialog, enter Wood Walnut.

15 Select Wood Walnut Stained Light No Gloss, and click OK.

Now that you have assigned a wood color, you create and add a surface pattern to the material
to produce a wood effect when it is applied to the custom wall type.

16 In the Materials dialog, click the Graphics tab, and select Use Render Appearance for Shading.

17 Under Surface Pattern, click  .

18 In the Fill Patterns dialog:

■ Under Pattern Type, select Model.
Model patterns represent the actual appearance of an element on a building, such as brick
coursing or, in this case, wood cladding. Model patterns are fixed with respect to the model,
meaning that they scale as the model scales.

■ Click New.

19 In the Add Surface Pattern dialog:

■ For Name, enter 8'' Parallel.

■ Under Simple, for Line angle, enter 0.

■ For Line spacing 1, enter 8".

■ Verify that Parallel Lines is selected.

20 Click OK twice.

Next, you add a cut pattern to the log material so that when you apply the material, the affected
walls display realistically when cut.

21 In the Materials dialog, under Cut Pattern, click  .

22 In the Fill Patterns dialog:

■ Under Pattern Type, verify that Drafting is selected.

■ Under Name, select Wood 2.

23 Click OK twice.

In the next exercise, you assign both materials to a custom wall type. When you view the wall
type in shaded or section views, the materials produce a realistic view of the walls.

24 On the Quick Access toolbar, click  (Save), but do not close the project.

25 Proceed to the next exercise, Creating a Custom Wall Type on page 94.

Creating a Custom Wall Type
In this exercise, you duplicate (copy) a system family wall type to create a custom system family wall type
for the cabin walls. After you duplicate the wall type, you modify the wall assembly, assigning the materials
that you created in the previous exercise to the different wall layers.

You begin by creating a wall from an existing system family type, and then note the changes to the wall
instance as you duplicate and modify the wall type.
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Initial wall type - plan
view

Custom wall type - plan view

The custom cabin wall type features exterior and interior layers that display the Proprietary Finish material,
while the middle layer displays the Proprietary Insulation material. In plan view (shown above), the wood
and insulation patterns display for each wall layer. In a 3D view, the model pattern assigned to the exterior
layer of the wall displays, creating the wood cladding.

Custom wall type
- 3D view

View the wall families in the current project

1 In the Project Browser, expand Families ➤ Walls.

There are 3 wall system families in Revit Architecture: Basic Wall, Curtain Wall, and Stacked
Wall.

2 Expand Basic Wall.

The list of available Basic Wall types displays. You can modify the properties of any of the
existing types or duplicate, rename, and modify them to create new types.
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Add a wall with an existing type to the project

3 Under Basic Wall, select Exterior - Brick on CMU, and drag it to the drawing area.

NOTE The exact wall type selection is not important. When creating a system family type, it is the
best practice to select a system family type that is similar to the one that you want to create.

4 Add a 3' wall:

■ Select a wall start point.

■ Move the cursor 3' to the right, and click to complete the wall.

■ Click Place Wall tab ➤ Selection panel ➤ Modify.

View the wall in greater detail

5 Zoom in to the wall.

6 Click View tab ➤ Graphics panel ➤ Thin Lines.

7 On the View Control Bar:

■ Click Detail Level ➤ Fine.

■ Click Model Graphics Style ➤ Shading with Edges.
All the separate wall layers display with appropriate materials, such as the diagonal hatch
for the brick layer. In the next steps, you duplicate the wall type, and then modify the wall
layers to create a new wall type.

Duplicate and modify the wall type to create a new wall type

8 Select the wall, and click Modify Walls tab ➤ Element panel ➤ Element Properties
drop-down ➤ Type Properties.

9 In the Type Properties dialog, click Duplicate.

10 In the Name dialog, enter Exterior - Log and Cladding, and click OK.

11 In the Type Properties dialog, under Construction, for Structure, click Edit.
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12 In the Edit Assembly dialog, under Layers, view the current wall layers.

A number of the layers that display are not needed in the new wall type. Notice that the dialog
lists the wall layers in numerical order, from the exterior to the interior of the wall.

13 Delete the extra wall layers, leaving one each of the following layers, as shown:

■ Exterior Finish

■ Thermal/Air

■ Structure
You do not need to keep interior finish layers. To delete a layer, select the layer number, and
click Delete.

14 Add new materials and parameters to the remaining wall layers:

■ For layer 1, Finish 1[4], click in the Material field, and click  .

■ In the Materials dialog, under Name, select Finishes - Exterior - Proprietary, Log, and click
OK.

■ Click in the Thickness field, and enter 1-3/4''.

■ Clear Wraps.

■ For layer 4, Structure [1], use the same method to specify the Material as the proprietary log
exterior and the Thickness as 3 3/4''.

■ For layer 2, Thermal/Air Layer [3], specify the Material as Insulation/Thermal Barriers -
Proprietary, Log Wall, and the Thickness as 4''.
The Layers list now features only the layers that you need for the custom wall.
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15 Click OK twice.

16 Press Esc.

The wall in the project now features the new wall type. Wood and insulation patterns show in
plan for each wall component.

View the wall in 3D

17 Click View tab ➤ Create panel ➤ 3D View drop-down ➤ Default 3D.

18 On the View Control Bar, click Model Graphics Style ➤ Shading with Edges.

The proprietary finish material displays the 8" parallel line surface pattern on the exterior of the
wall. For most design situations, this surface pattern is an adequate representation of the stacked
logs. You could model the wall components rather than applying a finish material, although
this would increase both file regeneration time and project size.

If you require an accurate 3D model, you can add 3D features to the wall layers. In the next
exercise, you add angled recesses that represent the stacked logs and cladding to both the exterior
and interior of the wall.

19 Save the project, but do not close it.

98 | Chapter 4   Working with System Families



20 Proceed to the next exercise, Creating a Custom Stacked Wall Type on page 99.

Creating a Custom Stacked Wall Type
In this exercise, you create a stacked wall by stacking 2 existing wall family types, including the Exterior -
Log and Cladding wall type that you created in a previous exercise.

Stacked
wall in
section
view

You begin by duplicating an existing wall type to create a new stacked wall type. You then stack the Exterior
- Log and Cladding wall type on top of a foundation wall within the new stacked wall type. You use offset
options to define the vertical relationship between both wall types.

Add a stacked wall with an existing type to the project

1 In the Project Browser, under Floor Plans, double-click Level 1.

2 In the Project Browser, expand Families ➤ Walls ➤ Stacked Wall.

3 Drag Exterior - Brick over CMU w Metal Stud into the drawing area.

4 Add a 3' wall:

■ Select a wall start point.

■ Move the cursor 3' to the right, and click to complete the wall.

■ Click Place Wall tab ➤ Selection panel ➤ Modify.
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Create a new stacked wall

5 Select the wall, and click Modify Stacked Walls tab ➤ Element panel ➤ Element Properties
drop-down ➤ Type Properties.

6 In the Type Properties dialog:

■ Click Duplicate.

■ In the Name dialog, enter Exterior - Log and Cladding on Concrete.

■ Click OK.

■ At the bottom of the dialog, verify that Preview is selected.
A preview image of the current stacked wall type displays.

■ Under Construction, for Structure, click Edit.

7 In the Edit Assembly dialog, under Types:

■ For Type 1, click the Name field, and select Exterior - Log and Cladding.

■ For Type 2, click the Name field, and select Foundation - 12'' Concrete.

8 In the left pane, zoom to examine the wall junction.

9 In the Edit Assembly dialog, for Offset, select Wall Centerline.
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10 Click OK twice, and then press Esc.

11 Save the project, but do not close it.

NOTE You can use the same method to create other system family types, such as floors and roofs.

12 Proceed to the next exercise, Transferring System Families Between Projects on page 101.

Transferring System Families Between Projects
In this exercise, you learn 2 methods of transferring system family types from one project to another.

Using the first method, you copy a single wall type from one project and paste it into another, where you
apply it to a wall. Use this method when you need to transfer only a few specific types from project to project.

Using the second method, you copy all the wall types from one project to another using the Transfer Project
Standards command. The command transfers all object types, so use this method when you have a number
of system family types and other project-related settings to transfer between projects.

Method 1: Copy and paste a single system family type

1 Open the project in which you’ll paste the family type:

■ Click  ➤ Open ➤ Project.

■ In the left pane of the Open dialog, click Training Files.

■ Select Common\cabin.rvt, and click Open.

2 Copy a family type:

■ Click View tab ➤ Windows panel ➤ Switch Windows drop-down, and select your project.

■ In the Project Browser, under Families, expand Walls ➤ Basic Wall.

■ Select Exterior - Log and Cladding, right-click, and click Copy to Clipboard.

TIP To select multiple family types, press and hold Ctrl, and then select the family types that you
want to copy.
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3 Paste the Log and Cladding type in the cabin project:

■ Using the method learned previously, switch to the cabin project.

■ In the Project Browser, double-click Floor Plans ➤ 02 Entry to make it the active view.

■ Click Modify tab ➤ Clipboard panel ➤ Paste.
The system family type is added to the project.

■ In the Project Browser, expand Families ➤ Walls ➤ Basic Wall, and confirm that Exterior -
Log and Cladding displays in the list of Basic Wall types.

4 Assign the new wall type to the exterior walls in the cabin project:

■ In the Project Browser, under 3D Views, double-click {3D}.

■ Move the cursor over an exterior wall, press Tab until the chain of walls is selected, and then
click to select the chain.

■ Click Modify Walls tab ➤ Element panel, and select Basic Wall : Exterior - Log and Cladding
from the Type Selector drop-down.

■ Press Esc.
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5 Confirm that the proprietary finish material assigned to the copied family type is available in
the project:

■ Click Manage tab ➤ Project Settings panel ➤ Materials.

■ In the left pane of the Materials dialog, verify that Finishes - Exterior - Proprietary, Log
material displays in the materials list.

■ Click Cancel.

6 Close cabin.rvt without saving it, but leave your project open.

Method 2: Use the Transfer Project Standards command to copy system family types

7 With your project still open, create another project:

■ Click  ➤ New ➤ Project.

■ In the New Project dialog, under Create new, verify that Project is selected.

■ Under Template file, verify that the second option is selected, and click Browse.

■ In the Choose Template dialog, navigate to Training Files\Imperial\Templates.

■ Select default.rte, and click Open.

■ In the New Project dialog, click OK.

8 Save the project:

■ Click  ➤ Save As ➤ Project.

■ In the Save As dialog, navigate to the desired location.

■ For File Name, enter transfer_project.

■ Click Save.

9 View the Basic Wall family types in the transfer standards project:

■ In the Project Browser, confirm that Exterior - Log and Cladding does not display under
Families ➤ Walls ➤ Basic Wall.
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■ Expand Walls ➤ Stacked Wall to confirm that Exterior - Log and Cladding on Concrete does
not display.

10 Transfer the wall type:

■ Click in the drawing area.

■ In transfer_project.rvt, click Manage tab ➤ Project Settings panel ➤ Transfer Project Standards.

■ In the Select Items To Copy dialog, for Copy from, select your project.

■ Click Check None.

■ In the list of items to copy, select Floor Types, Roof Types, and Wall Types.

■ Click OK.

■ If the Duplicate Types dialog displays, click Overwrite.

■ In the Project Browser, under Families ➤ Walls ➤ Basic Wall, confirm that Exterior - Log and
Cladding now displays.

■ Confirm that the stacked wall type you created displays as well.

11 Save and close both projects.
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Creating Detail Component
Families

In this tutorial, you learn how to create detail component families and nest them in other families.

You begin the tutorial by creating a window sill detail component family from an existing DWG detail.

Complete Revit Architecture sill detail

After you create the sill detail, you combine it with an existing head detail and create a full window detail component
family by sketching additional detail geometry.

5
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Full window detail

When the full window detail component family is complete, you nest it in a window family. You specify visibility options
to display the detail component only in cut views and in fine detail. Then, by adding a window type from the new window
family to a project, you test the visibility of the detail component.

Section view of
the window
displaying the
detail
component in
fine detail

Skills used in this tutorial include:

■ Importing a DWG file to create new detail component families

■ Implementing best practices when importing geometry
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■ Nesting detail components within other families

■ Testing the family in a project

Creating a Window Sill Detail Component Family from a DWG
In this exercise, you create a window sill detail by importing an existing detail drawn in DWG format.

Complete Revit Architecture sill detail

You begin by creating a new detail component family into which you import the existing detail. All the
DWG objects (including any blocks or external references) are imported as a single Revit Architecture element
called an import symbol. When the DWG is imported, the DWG layers create object styles in the import
symbol.

After you import the DWG detail, you explode the import symbol and convert its components to Revit
Architecture objects. You then remove the unused object styles created from the import of the DWG layers
from the new family.

Create a detail component family

1 Click  ➤ New ➤ Family.

2 In the left pane of the New Family - Select Template dialog, click Training Files, and open
Imperial\Templates\Detail Component.rft.

The new family opens in the Family Editor.

3 Save the detail component family:

■ Click  ➤ Save As ➤ Family.

■ In the Save As dialog, for File name, enter Window_Sill, and click Save.
The new family is saved as an RFA file.

Import a detail from a DWG file

4 On the navigation bar, click Zoom drop-down ➤ Zoom All to Fit.
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5 Click Insert tab ➤  Import panel ➤ Import CAD.

6 In the Import CAD Formats dialog:

■ Navigate to Training Files\Imperial.

■ Select Wood_Window_Details_Sill.dwg.
A preview image of the detail displays on the right side of the dialog.

■ For Colors, select Preserve.
Later, you replace the AutoCAD colored linework with Revit lines.

■ Verify the following:

■ For Layers, All is selected.

■ For Import units, Auto-Detect is selected.

■ For Positioning, Auto - Center to Center is selected.

■ For Place at, Ref. Level is selected.

■ Orient to View is selected.

■ Click Open.
The DWG detail is imported into the family as a single import symbol. It is the correct size
(life-size). Later, you change the scale, which does not affect the detail size (full-size), but
lets you manage the display of lineweights and the size of dimensions.
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7 Select the detail, and in the Type Selector, notice the detail is identified as an import symbol.

Next, you change the scale of the family to an appropriate detail scale to manage the text and
dimension size. Later in this exercise, you assign individual components of the detail to different
object styles to vary their lineweight. The correct scale will help you select and assign object
styles. If the thickness of the lines obscures their position, the screen display of the linework
can be turned on or off by clicking View tab ➤ Graphics panel ➤ Thin Lines.

Change the current scale and resize the reference planes

8 On the View Control Bar, click the current scale, and click 3''=1'-0''. Because no text is placed in
the detail, the selected scale is only of interest for managing the thickness of linework as you
draft.

NOTE In Revit Architecture,you can set values for the width of linework for a particular scale by
assigning a lineweight number (1-16) to a line width. Click Manage tab ➤ Family Settings
panel ➤ Settings drop-down ➤ Line Weights.

9 Resize the reference planes:

■ Select the horizontal reference plane.
The reference plane displays as blue and its label, Center (Front/Back), also displays.

■ Select the right endpoint of the reference plane, and drag it toward the detail. Size the
reference planes so they extend beyond the overall size of the detail.

■ Repeat for the other end of the horizontal reference plane and for the vertical reference
plane.
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■ On the navigation bar, click Zoom drop-down ➤ Zoom All to Fit.

Next, you position the detail so that the intended insertion point of the detail aligns with the
intersection (0,0) of the reference planes. When you later insert the detail in a view, the reference
plane intersection defines its origin. When you place a detail, the cursor position is attached to
the detail origin.

Align the imported detail with the reference planes

10 Click Modify tab ➤ Edit panel ➤ Align.

11 Select the Center (Front/Back) reference plane.

12 Select the lower horizontal edge of the sill, as shown.
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13 Select the Center (Left/Right) reference plane.

14 Select the right edge of the wall fastener plate, as shown.

The detail now aligns with both reference planes. In this case, you aligned the components with
the reference planes to move them to the correct location.

Next, you explode the detail to convert it to objects.

Explode the detail

15 On the Selection panel, click Modify.

16 Move the cursor over the detail until a frame displays around the detail, and select the detail.

In the next step, you fully explode the import symbol into lines and curves
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NOTE This detail does not contain either blocks or xrefs, but if you import a DWG that does contain
them, using the Partial Explode option will explode the import symbol into separate nested import
symbols created by any blocks and xrefs.

17 Click Modify Imports in Families tab ➤ Import Instance panel ➤ Explode drop-down ➤ Full
Explode.

18 A warning dialog displays, notifying you that some of the lines in the detail may be slightly off
axis.

This could cause problems if you want to add geometry to the detail. Because you do not need
to add geometry to the detail, close the warning dialog without making changes.

19 Select a line in the detail.

20 In the Type Selector, notice that an AutoCAD layer name displays.

When you exploded the detail import symbol, the layer names and properties imported with
the DWG are still in use as Revit Architecture object styles. Although not required, it is a best
practice to convert the detail elements to Revit Architecture object styles and remove the
AutoCAD object styles with the DWG layer names.

Filter and convert elements to use similar Revit Architecture object styles

21 Using a window selection, select the detail.

22 On the Status bar, click  (Filter Selection).

In the Filter dialog, a list of lines displays; the 3 object styles were created by the layers A-Detl-Hvy,
A-Detl-Lgt, and A-Detl-Med.

23 Filter lines with the A-Dtl-Heavy style:

■ In the Filter dialog, click Check None.

■ Select Lines (A-Detl-Hvy).

■ Click OK.
The lines from the A-Detl-Hvy layer highlight in blue.
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24 In the Type Selector, select Heavy Lines.

25 Press Esc.

The lines that used the A-Detl-Hvy object style display as thick black lines.

26 Using the same method, filter and convert the remaining lines to use the Light Lines and Medium
Lines object styles.
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Next, you remove the unused object styles from the family. Deleting these from the family
before saving and using the family in a project is not required, but is a best practice. If you do
not delete unused styles, they can degrade the performance of projects into which you add the
detail component family.

Remove unused object styles from the family

27 Click Manage tab ➤ Family Settings panel ➤ Settings drop-down ➤ Object Styles.

28 In the Object Styles dialog, on the Model Objects tab:

■ Under Category ➤  Detail Items, select A-Detl-Hvy.

■ At the bottom right of the dialog, under Modify Subcategories, click Delete.

■ In the Delete Subcategory dialog, click Yes.

■ Using the same method, remove the A-Detl-Lgt and A-Detl-Med object styles.

TIP Multiple selection of object styles is not available in this dialog. Because deleting each style
can be a time-consuming process, it is a best practice to ensure that DWG files contain no extra
layers before you import them to Revit Architecture.

Next, you perform the same process on the Imported Objects tab.

29 Click the Imported Objects tab:

■ Under Category  ➤ Imports in Families, select 0.

■ At the bottom right of the dialog, under Modify Subcategories, click Delete.

■ In the Delete Subcategory dialog, click Yes.

■ Using the same method, repeat for A-Detl-Hvy, A-Detl-Lgt, A-Detl-Med, and Defpoints.

30 Click OK.

You imported and converted a DWG detail, which is now ready to be inserted in detail views
in your Revit Architecture projects.

31 Save and close the new detail component family.

32 Proceed to the next exercise, Creating a Full Window Detail Component Family on page 115.
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Creating a Full Window Detail Component Family
In this exercise, you create a detail component for the full window by combining the sill detail that you
created previously with an existing head detail, and then sketching the remaining window geometry. You
add reference planes and a parameter to the full window detail that allow you to specify the overall height
of the window, while allowing for some required space between the window and the rough opening.

Full window detail

When complete, you can use the full window detail component as an adjustable standalone detail, or you
can nest it into a window family for inclusion in a wall section, as demonstrated in the final exercise in this
tutorial.

Create a detail component family

1 Click  ➤ New ➤ Family.

2 In the left pane of the New Family - Select Template dialog, click Training Files, and open
Imperial\Templates\Detail Component.rft.

The new family file opens in the Family Editor.

3 Save the detail component family:

■ Click  ➤ Save As ➤ Family.

■ In the Save As dialog, for File name, enter Wood_Window_Detail, and click Save.
The new family is saved as an RFA file.

View and pin the template reference planes

4 In the Project Browser, under Floor Plans, verify Ref. Level is the current view.

Next, to ensure proper parametric relationships, you pin the reference planes. This is a best
practice that is implemented before you create family geometry. Pinning the reference planes
ensures that they cannot be accidentally moved.
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5 Pin the reference planes:

■ While pressing Ctrl, select both reference planes.

■ Click Multi-Select tab ➤ Modify panel ➤ Pin.

Change the scale to an appropriate detail scale

6 On the View Control Bar, click the current scale, and click 1 1/2''=1'-0''.

Add a reference plane for the window height

7 Click Create tab ➤ Datum panel ➤ Reference Plane drop-down ➤ Draw Reference Plane.

8 To specify the reference plane start point, click 1'-6'' above the left endpoint of the Center
(Front/Back) reference plane.
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9 Move the cursor to the right, and specify the endpoint directly above the end point of the
existing reference plane.

Dimension the horizontal reference planes

10 Click Create tab ➤ Dimension panel ➤ Aligned.

11 Select the Center (Front/Back) reference plane, and then select the new reference plane.

12 Click above the dimension to place it.

Creating a Full Window Detail Component Family | 117



13 On the Selection panel, click Modify.

Label the dimension to create a Height parameter

14 Select the dimension that you just placed.

15 On the Options Bar, for Label, select Add parameter.

16 In the Parameter Properties dialog:

■ Under Parameter Data, for Name, enter Height.

■ For Group parameter under, select Dimensions.

■ Click OK.
Do not lock the parameter, as you want to be able to adjust the height of the window.

■ Press Esc.
The new Height parameter displays.

Next, you add 2 horizontal reference planes that you will use to align the window head and
window sill at a specific distance from the rough opening. This distance is normally specified
by the window manufacturer.

Add 2 reference planes to align both detail components

17 Zoom to the right of the reference plane intersections.

18 Click Create tab ➤ Datum panel ➤ Reference Plane drop-down ➤ Pick Existing Line/Edge.
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19 On the Options Bar, for Offset, enter 1/4''.

This is the clearance between the window and the rough opening.

20 Place the cursor on the upper horizontal reference plane, move it slightly downward, and click
to place the reference plane.

21 Place the cursor on the lower horizontal reference plane, move it slightly upward, and click to
place the reference plane.

22 Press Esc.

23 Dimension and constrain the upper reference planes to each other:

■ Zoom to the upper horizontal reference planes.

■ Click Create tab ➤ Dimension panel ➤ Aligned.

■ Select the upper horizontal reference plane.

■ Select the lower horizontal reference plane.

■ Click below the dimension to place it.

■ Click  to lock the alignment.

24 Using the same method, dimension and lock the 2 bottom reference planes.

Next, you load the window head and window sill detail components into the Wood Window
Detail family, and position them on the 2 inner reference planes.

Add the window head and window sill detail components

25 Load the window head component in the project:

■ Click Create tab ➤ Detail panel ➤ Detail Component.

■ In the alert dialog, click Yes to load a Detail Items family into the project.

■ In the left pane of the Open dialog, click Training Files.

■ Open Imperial\Families\Detail Components, and select Window_Head.rfa.

■ Click Open.
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26 Add the window head to the drawing area:

■ In the Type Selector, verify Window Head is selected.

■ Click to specify a placement point below the upper horizontal reference planes.
Alignment with the reference planes is not necessary at this point. You use the Align command
later to align the head and sill with the reference planes.

■ Press Esc.

27 Load the window sill component:

■ Click Create tab ➤ Detail panel ➤ Detail Component.

■ Click Place Detail Component tab ➤ Detail panel ➤ Load Family.

■ In the left pane of the Load Family dialog, click Training Files.

■ Open Imperial\Families\Detail Components, and select Window_Sill.rfa.

■ Click Open.

28 Add the window sill:

■ In the Type Selector, verify Window Sill is selected.

■ Locate the sill above the lower horizontal reference planes but below the window head, and
click to place it.
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■ On the Selection panel, click Modify.

29 Align the window head with the reference planes:

■ Click Modify tab ➤ Edit panel ➤ Align.

■ Select the Center (Left/Right) reference plane.

■ Select the top window head component on the right face of the wall fastener plate, as shown.

■ Click  to lock the alignment.

■ Select the lower horizontal reference plane that displays above the window head.

■ Select the top edge of the window head component.

■ Click  to lock the alignment.

30 Align the window sill with the reference planes:

■ Select the Center (Left/Right) reference plane, which represents the face of a wall.

■ Select the right edge of the sill wall fastener plate, and click  .

■ Select the upper of the 2 lower horizontal reference planes that display below the window
sill.

■ Select the bottom edge of the sill detail component, and click  .
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31 On the Selection panel, click Modify.

Next, you test (flex) the detail component family to ensure that the window head is constrained
to the reference planes. When you adjust the value of the height parameter, the window head
will move up or down.

Flex the family

32 Click Manage tab ➤ Family Properties panel ➤ Types.

33 In the Family Types dialog:

■ Under Dimensions, for Height, enter 1'.

■ Click Apply.
The window head repositions in relation to the lower horizontal reference plane.

■ Under Dimensions, for Height, enter 2'.

■ Click Apply, and click OK.
The window head and sill are now in position and are constrained to reference planes in the
detail component family. In the remainder of the tutorial, you add detail lines to the tutorial
to complete the full window representation. You begin by adding reference planes that you
use to connect the window head and sill details.
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Add reference planes below the head and above the sill

34 Click Create tab ➤ Datum panel ➤ Reference Plane drop-down ➤ Draw Reference Plane.

35 Sketch 2 reference planes as shown, beginning at the endpoint of the line on the far left of each
component.

Dimension and constrain the reference planes at the window head

36 Click Create tab ➤ Dimension panel ➤ Aligned.

37 Dimension the window head reference plane and the upper of the 2 new horizontal reference
planes, as shown, and lock the alignment.
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Next, you add 6 lines with endpoints that are constrained to the reference planes. You sketch
one line and constrain it, and then you copy it so you don’t have to constrain each line.

Create the first line

38 Add the first line:

■ Click Create tab ➤ Detail panel ➤ Line.

■ In the Type Selector, select Light Lines.

■ While pressing Shift, select a start point on the top horizontal reference plane.
Pressing Shift constrains you to drawing only vertical or horizontal lines.

■ Select the parallel point on the bottom reference plane.

■ On the Selection panel, click Modify.

Copy the line to create another line

39 Place copies of the line using endpoints so that you have 6 connecting lines:

■ Select the line that you just drew.

■ Click Modify Lines tab ➤ Modify panel ➤ Copy.
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■ Click the upper end point on the original line to specify the move start point.

■ Move the cursor to the left, and click the end of the upper vertical line, as shown.

The vertical lines on the head and sill are connected by the copied line. There are 5 additional
sets of vertical lines to connect.

■ Press Esc.

40 Repeat until all 6 sets of vertical lines connect.
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41 Select and delete the original line. The connecting lines will stretch between the 2 details when
the height is adjusted.

42 Zoom out so you can see the full window detail and the Height parameter.

Next, test the family by changing the value of the Height parameter. If all the constraints are
working properly, the window detail will resize vertically as the value of the Height parameter
changes.

Flex the Height parameter

43 Click Create tab ➤ Family Properties panel ➤ Types.

44 In the Family Types dialog:

■ Under Dimensions, for Height, enter 1'.

■ Click Apply.
The window detail resizes to reflect the new vertical height.
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■ Under Dimensions, for Height, enter 1'6''.

■ Click Apply.
The window detail resizes to reflect the new vertical height.

■ Click OK.

45 Save the detail component family, but do not close it.

In the next exercise, you nest (insert) the full window detail component into a window family.

46 Proceed to the next exercise, Adding the Full Window Detail Component to a Window Family
on page 128.
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Adding the Full Window Detail Component to a Window Family
In this exercise, you nest the window detail component family in a window family to create a new window
family. You then set the visibility of the detail component in the window family to display only in cut views
and at a fine detail level.

After you create the new family, you open an art gallery project and replace a gallery window with one that
features the new window family type. You cut a section through the window and wall, change the window
type, and then change the detail level in the view to display the window detail.

Section view and fine
detail with no nested
window detail family.

Section view
and fine detail
with a nested
window detail
family.
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Open the window family in which to nest the detail component family

1 With the Wood_Window_Detail family open, click  ➤ Open ➤ Family.

2 In the left pane of the Open dialog, click Training Files, and open Imperial\Families\Windows.

3 Select Casement_with_Trim.rfa, and click Open.

Load the detail component in the window family

4 Click View tab ➤ Windows panel ➤ Switch Windows drop-down ➤ Wood_Window_Detail.rfa
- Floor Plan: Ref. Level.

5 Click Create tab ➤ Family Editor panel ➤ Load into Project.

6 If the Load into Projects dialog displays, select Casement_with_Trim.rfa, and click OK.

The Casement_with_Trim family opens.

Add the detail component to the left elevation view of the window

7 In the Project Browser, expand Views ➤ Elevations (Elevation 1), and double-click Left.

8 Zoom in to the middle of the window.
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9 In the Project Browser, expand Families ➤ Detail Items ➤  Wood_Window_Detail.

10 Drag the Wood_Window_Detail into the view.

11 In the Work Plane dialog:

■ Under Specify a new Work Plane, select Name, and select Reference Plane:Left.

■ Click OK.

12 In the drawing area, click to place the detail component to the right of the window.

Exact placement is not necessary, as you align and position the detail in the following steps.

13 On the Selection panel, click Modify.

Align and position the detail

14 On the View Control Bar, click the current scale, and click 11/2'' = 1'-0''.

15 Zoom in to the bottom of the detail.

16 Align and lock the detail component to the sill reference plane:

■ Click Modify tab ➤ Edit panel ➤ Align.
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■ Select the Sill reference plane.

■ Select the reference line below the bottom edge of the sill detail.

NOTE Make sure that you select the reference line below the bottom of the sill, and not the
bottom edge graphic. There is a tolerance gap so that the window can be easily fitted into the
rough opening.

■ Click  .

17 Align and lock the detail component to the window offset plane:

■ Select the window offset reference plane (second vertical reference plane from the left).

■ Select the right edge of the sill wall fastener plate.
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■ Click  .

18 On the Selection panel, click Modify.

Link the detail component Height parameter to the window family height

19 Select the detail component, and click Modify Detail Items tab ➤ Element panel ➤ Element
Properties drop-down ➤ Type Properties.

20 In the Type Properties dialog:

■ Under Dimensions, for Height, click  .

■ In the Associate Family Parameter dialog, select Height.

21 Click OK twice.

22 Press Esc.

Flex the family

23 Click Modify tab ➤ Family Properties panel ➤ Types.

24 In the Family Types dialog:

■ For Name, select 36'' x 24''.

132 | Chapter 5   Creating Detail Component Families



■ Click Apply.
The window and detail component resize.

■ Click OK.

Set the visibility so that the detail component displays in fine detail only

25 Select the detail component, and click Modify Detail Items tab ➤ Visibility panel ➤ Visibility
Settings.

26 In the Family element visibility settings dialog:

■ Under Symbolic Element Visibility, select Show only if Instance is cut.
The full window detail will show in a section view.

■ Under Detail Levels, clear Coarse and Medium.
The embedded full window detail now shows only in fine detail.

■ Verify that Fine is selected.

■ Click OK.

Turn off detail component geometry in 3D views

27 In the Project Browser, under 3D Views, double-click View 1.

28 On the navigation bar, click  (Basic View Object Wheel).

29 Use the Orbit tool to spin the window until it displays as shown.
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30 Press Esc.

31 Select the detail component geometry, including the window detail.

32 Click Multi-Select tab ➤ Filter panel ➤ Filter.

33 Clear Other to remove the window detail from the selection.

34 Click OK.

35 Click Multi-Select tab ➤ Form panel ➤ Visibility Settings.

36 In the Family Element Visibility Settings dialog, under Detail Levels, clear Fine.

The window model geometry will not be seen in a fine detail view.

37 Click OK.

38 Press Esc.

Save the new window family for use in multiple projects

39 Click  ➤ Save As ➤ Family.

40 In the Save As dialog, navigate to Imperial\Families\Windows, and save the window family as
Casement_with_Trim_and_Details.rfa, but do not close it.
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Load the new window family into the art gallery project

41 Open the art gallery project:

■ Click  ➤ Open ➤ Project.

■ In the left pane of the Open dialog, click the Training Files icon.

■ Navigate to the Imperial folder, select i_art_gallery.rvt, and click Open.

42 Minimize the art gallery project, but do not close it.

43 In the Casement_with_Trim_and_Details family, click Modify tab ➤ Family Editor panel ➤ Load
into Project.

44 In the Load into Projects dialog, select i_art_gallery.rvt, and click OK.

The art gallery project displays as the current project.

Create a section view that cuts through the right exterior wall of the art gallery

45 In the Project Browser, under Floor Plans, double-click Level 1.

46 Click View tab ➤ Create panel ➤ Section.

47 In the Type Selector, verify that Section: Building Section displays.

48 Draw a section line through the right exterior wall at a window location:

■ Specify a point inside a window.

■ Move the cursor to the right (outside the window), and specify an endpoint for the section
line.
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Open the new section view and view the window

49 In the Project Browser, under Sections, double-click Section 1.

50 Zoom in to the window, and select it.

The current window type displays in the Type Selector.

Replace the window with a Casement_with_Trim_and_Details window type

51 With the window still selected, in the Type Selector, under Casement_with_Trim_and_Details,
select 36'' x 48''.

52 On the View Control Bar, select Detail Level: Fine.

53 Zoom in to the window and view the nested detail component.
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54 Save and close all open drawings.
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Creating a Door Family

In this tutorial, you create a custom door family based on the definition of a flush exterior door. After you create the door
panel extrusion and the vision light, you create door types based on size and then assign parameters.

You also learn how to constrain the door design by adding labelled dimensions (parameters) to specify values for the door
width, height, and thickness.

Skills used in this lesson:

■ Creating symbolic lines for the plan view of the door

■ Adding parameters to control door dimensions and swing angle

■ Creating solid geometry with extrusions

■ Assigning materials to geometry

■ Defining family types for door sizes

Drawing the Door Plan View Components
In this exercise, you draw the plan view components for the new door family. You use symbolic lines for
the door panel and swing because symbolic lines are only seen parallel to the view in which they are created.

6

139



When you draw the lines in the plan view, they are only seen in plan. The door type has a variable height,
width, thickness, and swing angle.

Create a family based on the default door template

1 Click  ➤ New ➤ Family.

2 In the left pane of the New Family - Select Template File dialog, click Training Files, and open
Imperial\Templates\Door.rft.

The reference planes that display are part of the default door template, and represent the door
opening profile. The door opening is aligned and locked to the reference planes. Labelled
dimensions, part of the door properties, are also displayed.

3 Click  ➤ Save As ➤ Family.

4 In the left pane of the Save As dialog, click Training Files, and save the file as
Imperial\Families\Training Door.rfa.

Draw plan view representation for the door panel

5 Click Detail tab ➤ Detail panel ➤ Symbolic Line.

These lines are only seen in the plan view.

6 On the Element panel, in the Type Selector, select Plan Swing [cut].

This is the line type that controls the look of the line.

7 On the Draw panel, click  (Rectangle).

8 Starting at the door hinge point on the upper right corner of the door opening, sketch a rectangle
for the door panel, approximately as shown:
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9 On the Selection panel, click Modify.

Rotate the symbolic geometry

Because you want the door family to have an adjustable swing, you rotate the symbolic geometry so it is at
an angle to the wall. You then dimension and label the angle relationship of the symbolic door panel and
the wall.

10 Select the symbolic lines that you just sketched.

11 Click Modify Lines tab ➤ Modify panel ➤ Rotate.

12 Click the center of rotation icon and drag it down to the hinge point, where the door panel
geometry connects to the wall.
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13 Select a point vertically above the door panel (symbolic rectangle) as the start of the rotation.

14 Move the cursor to the left, type 45, and press Enter.

The geometry is at a 45 degree angle to the wall.
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Dimension the swing angle of the door.

15 Click Detail tab ➤ Dimension panel ➤ Angular.

16 Select the long exterior sketch line, select the reference plane on the exterior face of the wall,
and select a point to the left of the angle to place the angular dimension.

You just created a hinge point and angle for the exterior line of the door sketch. The hinge point
(origin) of the angle is the top right corner of the door opening.

Dimension the thickness and width of the door panel

17 Click Place Dimensions tab ➤ Dimension panel ➤ Aligned.

18 Click on each of the short lines of the sketch and place the door length dimension to the right
of the door.

19 Click on each of the long lines and place the door thickness dimension clear of the door end.

The dimension values are not important at this time; you change them in later steps.

20 On the Selection panel, click Modify to exit the command.

Label the dimensions

21 Select the angle dimension, and on the Options Bar, for Label, select <Add parameter>.

22 In the Parameter Properties dialog, for Name, type Swing Angle, select Instance, and click OK.

The instance option allows you to specify different door swings for each instance of the same
door type in a project.
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23 Select the long left sketch line, select the thickness dimension, type 1-3/4'', and press Enter.

24 Press Esc.

25 Select the thickness dimension, and on the Options Bar, for Label, select Thickness.

26 Using the same method, assign the Width parameter to the width dimension.
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Flex the door family

27 Click Detail tab ➤ Family Properties panel ➤ Types.

You change the thickness, width, and swing angle to test that the geometry is responding as
expected.

28 In the Family Types dialog:

■ Under Dimensions, for Thickness, enter 2''.

■ For Width, enter 3’.

■ Under Other, for Swing Angle, enter 60.

■ Click Apply.

29 In the Family Types dialog, specify the following:

■ Under Dimensions, for Thickness, enter 1.75''.

■ For Width, enter 2'6''.

■ Under Other, for Swing Angle, enter 45.

■ Click Apply, and click OK.

Add the arc for the plan door swing

30 Click Detail tab ➤ Detail panel ➤ Symbolic Line.

31 In the Type Selector, select Plan Swing [projection].

32 Click Place Symbolic Lines tab ➤ Draw panel ➤  (Center-ends Arc).

When drawing an arc from center and end points, you first specify the arc center, and then you
specify each end point.

33 Select the hinge point for the arc center point.

34 Select the upper right endpoint of the door panel for the arc start point.

35 Select the upper left corner of the door opening for the arc endpoint.

In the following image, the arc is selected so you can see the arc center and each end point.
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36 On the Selection panel, click Modify.

37 On the Quick Access toolbar, click  (Save).

38 Proceed to the next exercise, Creating the Door Panel Solid Geometry on page 146.

Creating the Door Panel Solid Geometry
In this exercise, you use extrusions to create the solid geometry for the door panel and the vision light.

Create an extrusion for the door panel

1 In the Project Browser, expand Elevations, and double-click Exterior.

2 Click Create tab ➤ Forms panel ➤ Solid drop-down ➤ Extrusion.

3 Click Create tab ➤ Work Plane panel ➤ Set.

4 In the Work Plane dialog, for Name, select Reference Plane: Exterior, and click OK.

5 On the Options Bar, for Depth, type 1.75”, and press Enter.

6 Click Create Extrusion tab ➤ Draw panel ➤  (Rectangle).

7 Sketch a rectangle within the door opening (for the door panel).

A best practice is to sketch the lines away from the final placement, and then use the Align tool
to align them to reference planes. This practice ensures that Revit Architecture does not make
automatic and perhaps unwanted constraints.
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8 Click Create Extrusion tab ➤ Edit panel ➤ Align.

9 Align and lock each of the sketch lines, one at a time, to the reference planes, as shown:

10 On the Selection panel, click Modify.

Sketch a void inside the door panel for the vision light

11 Click Create Extrusion tab ➤ Draw panel ➤  (Rectangle).

12 Sketch a small rectangle inside the top part of the door panel, and on the Selection panel, click
Modify.

A closed sketch within the first closed sketch is interpreted as a void. A third sketch within the
void be interpreted as solid.

Dimension the sketch to adjust the size of the inner rectangle

13 Click Create Extrusion tab ➤ Annotate panel ➤ Dimension drop-down ➤ Aligned Dimension.

14 Dimension the sketch:

■ Add 2 dimensions to locate the inner sketch 6” from the outer sketch top-right corner.

■ Add 2 dimensions to size the void 8”x24”.

■ Adjust the inner rectangle to the dimensions by clicking on the sketch lines and editing the
temporary dimensions.
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■ Lock the dimensions because the void is to be at the same location and size in all door types.

15 Click Create Extrusion tab ➤ Extrusion panel ➤ Finish Extrusion.

16 Select the extrusion, and click Modify Extrusion tab ➤ Element panel ➤ Element Properties
drop-down ➤ Instance Properties.
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17 In the Instance Properties dialog, under Identity Data, for Subcategory, select Panel, and click
OK.

Assigning the extrusion to a subcategory ensures that materials and display properties can be
controlled after you load the family into a project.

Create an extrusion for the glass vision light in the door

18 Click Create tab ➤ Forms panel ➤ Solid drop-down ➤ Extrusion.

19 Click Create Extrusion tab ➤ Element panel ➤ Extrusion Properties.

20 Specify options in the Instance Properties dialog:

■ Under Constraints, for Extrusion Start, enter 1/2''.
This positions the beginning of the glass away from the door face, which is on the Exterior
reference plane.

■ For Extrusion End, enter 1''.

■ Under Identity Data, for Subcategory, select Glass.

■ Click OK.

21 Click Create Extrusion tab ➤ Draw panel ➤  (Rectangle).

22 Select diagonally opposite corners of the vision light void in the door panel.

23 Click the 4 lock icons to constrain the boundary.

Because the model is simple with no overlapping reference planes or multiple overlapping solid
faces, you can constrain boundaries to faces.

NOTE The door family should be flexed to ensure that constraints work; you do this in later steps.
Following the best practice recommendation, you could edit the sketch, constrain the void sketch
with locked dimensions from the reference planes, and flex the model to check the results match
your design intent. For complex models, constraining to reference planes is safer and is best practice.
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24 Click Create Extrusion tab ➤ Extrusion panel ➤ Finish Extrusion.

25 On the Quick Access toolbar, click  (3D View).

26 Drag the Frame Projection labels away from the door for a cleaner view.

27 On the View Control Bar, click Model Graphics Style ➤ Shading with Edges.
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Modify the visibility of the extrusions

28 While pressing Ctrl, select the glass extrusion and the panel extrusion.

29 Click Multi-Select tab ➤ Form panel ➤ Visibility Settings.

30 In the Family Element Visibility Settings dialog, clear Plan/RCP, and When cut in Plan/RCP (if
category permits), and click OK.

The symbolic lines will show in plan view, but the 3D geometry won’t display. This reduces the
regeneration time required to show the door in plan view, where only the symbolic lines display.

NOTE You can confirm the visibility settings in a project only. The 3D geometry remains visible in
the Family Editor so that you can select and edit it.

31 On the Quick Access toolbar, click  (Save).

32 Proceed to the next exercise, Assigning Materials to the Door Components on page 151.

Assigning Materials to the Door Components
In this exercise, you assign materials to the door panel and the trim. This material designation controls how
the door displays in shaded and rendered views.

Create a material based on the existing red oak material

1 In the Project Browser, under Floor Plans, double-click Ref. Level.

2 Click Manage tab ➤ Family Settings panel ➤ Materials.

3 In the Materials dialog, click  (Duplicate).

4 In the Duplicate Revit Material dialog, for Name, type Oak Door, and click OK.

5 On the Render Appearance tab, click Replace.

6 In the Render Appearance Library dialog, navigate to Wood Oak Red Stained Dark Low Gloss,
and click OK.

7 On the Graphics tab, under Shading, select Use Render Appearance for Shading.

8 Click OK.

Assigning Materials to the Door Components | 151



Assign the Oak Door material to the door panel

9 Select the door panel extrusion.

10 Click Modify Panel tab ➤ Element panel ➤ Element Properties drop-down ➤ Instance Properties.

11 In the Instance Properties dialog, under Materials and Finishes, for Material, click <By Category>,
and click  .

12 In the Materials dialog, select Oak Door.

13 Click OK twice.

The door panel is assigned the new Oak Door material. You replaced By Category, which allows
material to be assigned to the door panel within a project, with a material applied directly to
the door.

14 Press Esc.

Assign the Oak Door material to the door trim

15 Using the same method, apply the Oak Door material to the interior door trim and to the exterior
door trim (frame/mullion extrusions).

The door frame is assigned the new Oak Door material.

View the new door

16 In the Project Browser, under Views (all) ➤ 3D Views, double-click {3D}.

17 Zoom in to a door corner.
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Flex the door model

18 Zoom out to view the entire door.

Next, you flex the door family to ensure that it properly adjusts to changes.

19 Click Manage tab ➤ Family Properties panel ➤ Types.

Move the dialog to the side so that you can see the door family. This allows you to apply changes
in the dialog and see how the new door reacts.

20 In the Family Types dialog:

■ Under Dimensions, for Height, enter 8' 0''.

■ For Width, enter 4' 6''.

■ Under Other, for Frame Width, enter 0' 6''.

■ Click Apply.

Notice the door geometry adapts to the new dimension values.

21 Return the door parameters to their original values:

■ Under Dimensions, for Height, enter 7' 0''.
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■ For Width, enter 2' 6''.

■ Under Other, for Frame Width, enter 0' 3''.

■ Click Apply, and click OK.

22 On the Quick Access toolbar, click  (Save).

23 Proceed to the next exercise, Defining New Door Types on page 154.

Defining New Door Types
In this exercise, you define new door types for the door family.

Define new door types with various heights and widths

1 Click Manage tab ➤ Family Properties panel ➤ Types.

2 In the Family Types dialog, under Family Types, click New.

3 In the Name dialog, for Name, type 32''x80'', and click OK.

4 In the Family Types dialog:

■ Under Dimensions, for Height, enter 6' 8''.

■ For Width, enter 2' 8''.

■ Click Apply.

Define the second new door type.

5 Under Family Types, click New.

6 In the Name dialog, for Name, type 36''x84'', and click OK.

7 In the Family Types dialog:

■ Under Dimensions, for Height, enter 7' 0''.

■ For Width, enter 3' 0''.

■ Click Apply.

Define the third new door type.

8 Under Family Types, click New.

9 In the Name dialog, for Name, type 48''x90'', and click OK.

10 In the Family Types dialog:

■ Under Dimensions, for Height, enter 7' 6''.

■ For Width, enter 4' 0''.

■ Click Apply, and click OK.

You now have 3 new door types defined within the door family.

11 On the Quick Access toolbar, click  (Save).

Load the door family into a project

12 Click  ➤ New ➤ Project.

13 In the New Project dialog, click OK.

14 Click Home tab ➤ Build panel ➤ Door.
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15 Click Place Door tab ➤ Model panel ➤ Load Family.

16 In the Load Family dialog, navigate to the location where you saved Training Door.rfa, select
it, and click Open.

Place new door types in the project

17 Click Home tab ➤ Build panel ➤ Wall drop-down ➤ Wall.

Use the default wall selection in the Type Selector.

18 Drawing from right to left, draw a horizontal wall segment 30' long.

You draw from right to left so that the exterior of the wall is the bottom face.

19 Click Place Wall tab ➤ Selection panel ➤ Modify.

20 On the Quick Access toolbar, click  (3D View).

21 On the View Control Bar, click Model Graphics Style ➤ Shading with Edges.

22 Click Home tab ➤ Build panel ➤ Door.

23 In the Type Selector, under Training Door, select 32''x80''.

24 Add the door to the wall by clicking on the bottom edge of the closer face (exterior), as shown.
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25 In the Type Selector, under Training Door, select 36''x84''.

26 Add this door to the center of the wall, as shown.

27 In the Type Selector, under Training Door, select 48''x90''.

28 Add the third door type to the right side of the wall, as shown.

29 Close all files with or without saving.

You now have 3 new flush exterior doors based on the new door family model.
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Creating a Bookcase
(Furniture) Family

In this tutorial, you create a bookcase family that contains 3 different types (sizes) of bookcases. The bookcase family is
designed so that you can change the overall dimensions of the bookcase and its components. The bookcase also has
options to assign materials and to include or remove the door.

Creating the New Bookcase Family
In this exercise, you use the Furniture family template to create the bookcase family, an RFT file. Revit
Architecture provides family templates, like this Furniture family template, for you to use to create your
own families. These templates are named according to the type of family that you want to create.

NOTE To ensure all users access the same template file for this tutorial, you create the bookcase family from the
Furniture template in the Training Files folder. When creating your own families, use the templates that Revit
Architecture provides in C:\Documents and Settings\All Users\Application Data\RAC 2010\Imperial Templates.

Create a new family with the Furniture template

1 Click  ➤ New ➤ Family.

2 In the left pane of the New Family - Select Template File dialog, click Training Files, and open
Imperial/Templates/Furniture.rft.

7
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A new family file opens and 2 dashed green lines, called reference planes, display. You will use
these reference planes (and additional ones that you create) to position and constrain the family
geometry that you create later in this tutorial. Although visible in the family, the reference
planes do not display when you load and add the finished family to a project.

Save and name the family

3 Click  ➤ Save As ➤ Family.

4 In the Save As dialog, for File name, enter Bookcase, and click Save.

This name forms the first part of the family name. When you load the finished family into a
project later in the tutorial, it displays by this name in the Type Selector.

5 Proceed to the next exercise, Creating the Family Skeleton on page 158.

Creating the Family Skeleton
In this exercise, you create a skeletal framework of reference planes that represent the front, back, left, right,
and top of the bookcase. Later in this tutorial, you create the solid forms that represent the bookcase geometry,
and constrain them to the appropriate reference planes.

Training File

■ Continue to use the family that you used in the previous exercise, Bookcase.rfa, or open training file
Imperial\Families\Furniture\Bookcase_00.rfa.

■ If you are using the supplied training file, click  ➤ Save As ➤ Family.

■ In the left pane of the Save As dialog, click Training Files, and save the file as
Imperial\Families\Furniture\Bookcase.rfa.

View the reference planes provided by the template

1 On the navigation bar, click Zoom drop-down ➤ Zoom All To Fit.

The 2 reference planes provide the starting point for the bookcase skeleton:

■ The family origin is at the intersection of the pinned reference planes.
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Later in this tutorial, when you add a finished bookcase to a project, the bookcase insertion
point corresponds to this intersection point.

■ The horizontal plane is the plane along which you will sketch the back panel of the bookcase.

■ The vertical plane marks the center of the bookcase.

Next, make sure the reference planes are locked to their current positions, ensuring that you do
not inadvertently move them as you create the family geometry.

2 Verify each reference plane is pinned in position:

■ Select the vertical reference plane.
A blue pushpin displays on the reference plane, indicating that it has been locked in place
with the Pin tool.

TIP To pin reference planes and other elements, select the element, and on the Modify panel,

click Pin. To unpin an element, select the element, and in the drawing area, click  .

■ Select the horizontal reference plane.
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This reference plane is also pinned in place. Notice that a label displays the reference plane
name at its right endpoint. Because you want the insertion point to be at the back of the
bookcase along this plane, you want to rename the reference plane.

Relabel the Center Front/Back reference plane

3 With the Center Front/Back reference plane selected, click Modify Reference Planes tab ➤ Element
panel ➤ Element Properties drop-down ➤ Instance Properties.

4 In the Instance Properties dialog:

■ Under Identity Data, for Name, enter Back.

■ Under Other, for Is Reference, select Back.

■ Click OK.
The new label displays on the reference plane.

Next, you add and label the following reference planes to complete the family skeleton:

■ A Left reference plane that you will use to position the left bookcase panel.

■ A Right reference plane that you will use to position the right bookcase panel.
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■ A Front reference plane that you will use to position bookcase geometry relative to the front
face of the bookcase.

■ A Top reference plane that you will use to control the height of the bookcase.

Create the Left, Right, and Front reference planes

5 Click Create tab ➤ Datum panel ➤ Reference Plane drop-down ➤ Draw Reference Plane.

6 Sketch 2 parallel reference planes, one on either side of the vertical center plane, and a horizontal
one below the Back reference plane.

Precise placement of the planes is not necessary, as you control their locations in the next
exercise.

7 Press Esc twice.

8 Select the left reference plane, and on the Element panel, click Element Properties.

9 In the Instance Properties dialog:

■ Under Identity Data, for Name, enter Left.

■ Under Other, for Is Reference, select Left.

■ Click OK.

Later, you will move your drafting plane or work plane onto a named reference plane.

10 Using the same method, specify the Name and Is Reference values for the remaining vertical
plane and the horizontal plane as Right and Front, respectively.

Create a Top reference plane

11 In the Project Browser, under Elevations (Elevation1), double-click Front.

12 Click Create tab ➤ Datum panel ➤ Reference Plane drop-down ➤ Draw Reference Plane.

13 Sketch a horizontal reference plane above the existing horizontal reference plane.

Precise placement of the plane is not necessary, as you control its location in the next exercise.
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14 Press Esc twice.

15 Select the reference plane that you just sketched, and open the Instance Properties dialog.

16 Using the method learned previously, specify the Name and Is Reference values as Top.

17 Proceed to the next exercise, Creating Family Parameters and Types on page 162.

Creating Family Parameters and Types
In this exercise, you add parameters and types to the bookcase family to determine the 3 different size
bookcases that you want the family to create.

You begin by dimensioning the reference planes of the family skeleton to control the width, height, and
length of the bookcase family. After you place the dimensions, you add a named parameter to each dimension.
The parameters will allow the width, height, and length of the bookcase geometry to vary depending on
the values that you assign them.

After you create the parameters, you add 3 bookcase types that contain the width, height, and length
parameters to the bookcase family. By assigning different values to these parameters in each type, each
family type will create a different size bookcase.

Training File

■ Continue to use the family that you used in the previous exercise, Bookcase.rfa, or open training file
Imperial\Families\Furniture\Bookcase_01.rfa.

■ If you are using the supplied training file, click  ➤ Save As ➤ Family.

■ In the left pane of the Save As dialog, click Training Files, and save the file as
Imperial\Families\Furniture\Bookcase.rfa.

Dimension the reference planes

1 In the Project Browser, under Floor Plans, double-click Ref. Level.
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2 Dimension the Left and Right reference planes:

■ Click Detail tab ➤ Dimension panel ➤ Aligned.

■ Select the Left reference plane.

■ Select the Right reference plane.

■ Move the cursor above the reference planes, and click to the right of the dimension to place
it.
The dimension values are not important at this point.

3 Using the same method, dimension the Front and Back reference planes, and place the dimension
to the left.
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4 Dimension the Left, Center Left/Right, and Right vertical reference planes.

5 Click the  symbol.

The symbol, called an equality constraint, displays without a slash, indicating that both
dimension segments are equal. The Left and Right reference planes are equidistant from the
Center Left/Right reference plane, even if the overall dimension changes.
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6 Dimension the Top and Bottom reference planes:

■ In the Project Browser, under Elevations, double-click Front.

■ Click Detail tab ➤ Dimension panel ➤ Aligned.

■ Move the cursor over the Bottom reference plane and Ref. Level level line.

■ Press Tab until the reference plane highlights, and select it.
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■ Select the Top reference plane, and place the dimension on the left.

Create family parameters

7 Create a height parameter for the dimension that you just placed:

■ On the Selection panel, click Modify.

■ Select the dimension, and on the Options Bar, for Label, select <Add parameter>.

■ In the Parameter Properties dialog, under Parameter Data, for Name, enter height, and click
OK.

8 Add a length parameter to the top horizontal dimension:

■ In the Project Browser, under Floor Plans, double-click Ref. Level.

■ Select the top horizontal dimension, and on the Options Bar, for Label, select <Add
parameter>.

■ In the Parameter Properties dialog, under Parameter Data, for Name, enter length, and click
OK.
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9 Using the same method, add a parameter named width to the vertical dimension.

Organize the parameters

10 Click Modify Dimensions tab ➤ Family Properties panel ➤ Types.

In the Parameter list, notice that the width, height, and length parameters display under Other.

11 Regroup the parameters:

■ In the Family Types dialog, under Other, select width.

■ On the right side of the dialog, under Parameters, click Modify.

■ In the Parameter Properties dialog, under Parameter Data, for Group parameter under, select
Dimensions, and click OK.

12 Using the same method, group the length and height parameters under Dimensions.

Next, test the family by assigning new dimension values to the width, length, and height
parameters. After you apply new dimension values, the reference planes should resize accordingly,
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an indication that your family is working properly. Testing a family in this manner is called
''flexing the family.''

Flex the family

13 In the Family Types dialog:

■ Under Dimensions, for width, enter 1'6''.

■ For length, enter 6'.

■ For height, enter 4', click Apply, and do not close the dialog.
The reference planes resize to the dimensions that you entered.

Next, create 3 bookcase types, or sizes, in the family. To create the bookcase type names, you
use a length by width by height naming convention. Later in the tutorial, when the completed
family is loaded into a project, the different sizes display in the Type Selector with this naming
convention.

Create 3 bookcase types (sizes)

14 Create a 72x18x48 bookcase:

■ In the Family Types dialog, under Family Types, click New.

■ In the Name dialog, enter 72x18x48, and click OK.

15 Create a 60x18x60 bookcase:

■ Under Family Types, click New.

■ In the Name dialog, enter 60x18x60, and click OK.

■ In the Family Types dialog, under Dimensions, for width, verify a value of 1'6''.

■ For length, enter 5'.

■ For height, enter 5'.

■ Click Apply.
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16 Create a 36x12x36 bookcase:

■ Under Family Types, click New.

■ In the Name dialog, enter 36x12x36, and click OK.

■ In the Family Types dialog, under Dimensions, for width, enter 1'.

■ For length, enter 3'.

■ For height, enter 3'.

■ Click Apply.

Flex (test) the family

17 In the Family Types dialog, for Name, select 72x18x48, and click OK.
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18 Proceed to the next exercise, Creating Panels on page 170.

Creating Panels
In this exercise, you create 2 side panels and a back panel for the bookcase family.

To create the panels, you use alignment constraints to locate edges of the panel sketches and a length
parameter to size the embedded sketches for panels (solid forms).

Training File

■ Continue to use the family that you used in the previous exercise, Bookcase.rfa, or open training file
Imperial\Families\Furniture\Bookcase_02.rfa.

■ If you are using the supplied training file, click  ➤ Save As ➤ Family.

■ In the left pane of the Save As dialog, click Training Files, and save the file as
Imperial\Families\Furniture\Bookcase.rfa.
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Create side panels

1 In the Project Browser, verify Views ➤ Floor Plans ➤ Ref. Level is the current view.

2 Sketch the panels between the horizontal reference planes:

■ Click Create tab ➤ Forms panel ➤ Solid drop-down ➤ Extrusion.

■ On the Draw panel, click  (Rectangle).

■ Sketch 2 rectangles as shown.
Since both panels will have the same height when extruded, you can create them with one
sketch. Sketches can have multiple closed shapes.

3 Align and constrain (lock) the left panel to the reference planes:

■ Click Create Extrusion tab ➤ Edit panel ➤ Align.

■ Select the Left reference plane.

■ Select the left edge of the sketch.

■ Click  .

■ Using the same method, align and constrain the top line of the panel sketch to the Back
reference plane.

4 Align and constrain the bottom line of the sketch to the Front reference plane.

5 Using the same method, align and constrain the right panel sketch to the Right, Back, and Front
reference planes.
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Three sides of each panel are constrained to the reference planes.

Next, use a dimension to establish the thickness of the panels.

Create and apply a panel_thickness parameter

6 Dimension the thickness of the side panels:

■ Click Create Extrusion tab ➤ Annotate panel ➤ Dimension drop-down ➤ Aligned Dimension.

■ Select the Left reference plane.

■ Select the right edge of the left panel sketch, move the cursor above the sketch, and click to
place the dimension.

■ Select the Right reference plane.

■ Select the left edge of the right panel sketch, and place the dimension.
Family dimensions can be edited in the Family Editor, but not in a project. You want to be
able to set panel thickness for each bookcase family type. For any dimension value that you
want editable in a project, use a length parameter. Length parameters can be given a
meaningful name, can be used to store values, and can establish relationships between the
components of the family.

7 Create and apply a panel_thickness parameter to the left panel:

■ On the Selection panel, click Modify.

■ On the left panel sketch, select the dimension.

■ On the Options Bar, for Label, select <Add parameter>.

■ In the Parameter Properties dialog, under Parameter Data, for Name, enter panel_thickness.
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■ Click OK.

8 Apply the panel_thickness parameter to the right panel dimension:

■ On the right panel sketch, select the dimension.

■ On the Options Bar, for Label, select panel_thickness.

9 In the Project Browser, under Elevations, double-click Front.

10 On the Extrusion panel, click Finish Extrusion.

You will use the Top reference plane to modify the panel height.
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11 Align and constrain the tops of the panels to the Top reference plane:

■ Select one of the panels (solid forms).
The panels were created with 2 sketches as 1 extrusion, so they behave as one object.

■ Drag the top grip that displays on the Center Left/Right reference plane to the Top reference

plane, and click  .

12 On the Quick Access toolbar, click  (3D View).

The panel_thickness parameter used, by default, the dimension value but you can now specify
values for the bookcase panels.

TIP If the displayed line width makes the panels hard to see, click View tab ➤ Graphics panel ➤ Thin
Lines.
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13 On the Family Properties panel, click Types.

14 In the Family Types dialog, under Other, for panel_thickness, enter 3/4''.

15 Click OK.

Create a back panel

16 Sketch the back panel clear of the reference lines and solid faces:

■ In the Project Browser, under Floor Plans, double-click Ref. Level.

■ Click Create tab ➤ Forms panel ➤ Solid drop-down ➤ Extrusion.

■ On the Draw panel, click  (Rectangle).

■ Sketch a horizontal back panel as shown.
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17 Align and constrain the top line of the panel sketch to the Back reference plane:

■ Click Create Extrusion tab ➤ Edit panel ➤ Align.

■ Select the Back reference plane.

■ Select the top horizontal line of the panel sketch.

■ Click  .

18 Align and constrain the left side of the sketch to the inside face of the left panel.

BEST PRACTICE  Use dimensions from reference planes to avoid confusion when geometry is complex.
You could locate the sketch with a dimension and apply the panel_thickness parameter. In this case
the geometry is not complex, and you will verify by flexing the model that alignment with the inside
face of the panel works. If, in a complex family, alignment with a face fails, then you have the option
of dimensions from the reference plane.

19 Align and constrain the right side of the sketch to the inside face of the right panel.
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Apply the panel_thickness parameter

20 Add a dimension:

■ Click Create Extrusion tab ➤ Annotate panel ➤ Dimension drop-down ➤ Aligned Dimension.

■ On the right side of the panel sketch, place a dimension between the Back reference plane
and the bottom horizontal line of the sketch.

■ On the Selection panel, click Modify.

■ Select the dimension that you just placed, and on the Options Bar, for Label, select
panel_thickness.
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21 On the Extrusion panel, click Finish Extrusion.

You can move dimensions by dragging the dimension line. You can also change the scale to
adjust their size. They do not display in a project. Place and size them so they do not obscure
solid forms as you continue to develop the family.

22 Align and constrain the Top reference plane and the top of the back panel:

■ In the Project Browser, under Elevations, double-click Front.

■ Click Modify tab ➤ Edit panel ➤ Align.

■ Select the Top reference plane.

■ Click the top edge of the extruded panel.

■ Click  .

View and flex the family

23 On the Quick Access toolbar, click  (3D View).
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24 Flex the family:

■ On the Family Properties panel, click Types.

■ In the Family Types dialog, for Name, select 36x12x36.

■ Under Other, for panel_thickness, enter 3/4''.

■ Click Apply.

25 Flex:

■ For Name, select 60x18x60, and click Apply.

■ Under Other, for panel-thickness, enter 3/4''.

■ Click Apply, and click OK.
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26 Proceed to the next exercise, Creating the Base Plate on page 180.

Creating the Base Plate
In this exercise, you create the base plate of the bookcase. You learn how to reference a parameter to the
extrusion properties of a solid form, creating the thickness of the base plate.

Training File

■ Continue to use the family that you used in the previous exercise, Bookcase.rfa, or open training file
Imperial\Families\Furniture\Bookcase_03.rfa.

■ If you are using the supplied training file, click  ➤ Save As ➤ Family.

■ In the left pane of the Save As dialog, click Training Files, and save the file as
Imperial\Families\Furniture\Bookcase.rfa.

Sketch a reference plane for the top of the base plate

1 In the Project Browser, under Floor Plans, double-click Ref. Level.

2 On the Family Properties panel, click Types.
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3 In the Family Types dialog, for Name, select 72x18x48, and click OK.

4 In the Project Browser, under Elevations, double-click Front.

5 Sketch a horizontal reference plane above the Ref. Level:

■ Click Create tab ➤ Datum panel ➤ Reference Plane drop-down ➤ Draw Reference Plane.

■ Draw a horizontal plane 4'' above the existing Ref. Level, and name it Base Plate.

Create and apply a base_height parameter

6 Place a dimension between the horizontal reference planes:

■ Click Detail tab ➤ Dimension panel ➤ Aligned.

■ Move the cursor over the Ref. Level line and reference plane at the base of the bookcase.

■ Press Tab until the reference plane highlights, and select it.

■ Select the Base Plate reference plane, and place the dimension to the left of the reference
planes.
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7 Create a type parameter:

■ On the Selection panel, click Modify.

■ Select the dimension.

■ On the Options Bar, for Label, select <Add parameter>.

■ In the Parameter Properties dialog, under Parameter Data, for Name, enter base_height.

■ Verify that Type is selected.
You create the parameter as a type parameter so that each family type can have a different
value if desired.

■ Click OK.

Set a base_height value for all 3 bookcase types

8 On the Family Properties panel, click Types.

9 In the Family Types dialog:

■ Under Name, select 60x18x60.

■ Under Other, for base_height, enter 4''.

■ Click Apply.

■ Using the same method, change the base_height to 4'' for the 36x12x36 bookcase.

■ Under Name, select 72x18x48, and click OK.

Create the base plate

10 Sketch and constrain the base plate:

■ Click Create tab ➤ Forms panel ➤ Solid drop-down ➤ Extrusion.

■ Click Create tab ➤ Work Plane panel ➤ Set.

■ In the Work Plane dialog, under Specify a new Work Plane, for Name, select Reference Plane:
Front, and click OK.

■ Click Create Extrusion tab ➤ Draw panel ➤  (Rectangle).

■ Sketch a rectangle between the reference planes.
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■ On the Edit panel, click Align.

■ Align and constrain the top of the base plate sketch with the Base Plate reference plane.

■ Align and constrain the bottom of the sketch with the bottom reference plane.

■ Align and constrain the left side of the sketch to the inside of the left panel.
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■ Align and constrain the right side of the sketch to the inside of the right panel.

■ On the Extrusion panel, click Finish Extrusion.

11 In the Project Browser, under Floor Plans, double-click Ref. Level.

12 Move and constrain the base plate extrusion:

■ Select the base plate to display its shape handles (grips).

■ Drag the front face (bottom grip) to the Front reference plane, and lock it.
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■ Drag the back face so that it is approximately 2'' from the front face.

13 Add a parameter for base thickness:

■ On the Family Properties panel, click Types.

■ In the Family Types dialog, under Parameters, click Add.

■ In the Parameter Properties dialog, under Parameter Data, for Name, enter base_thickness.

■ For Type of Parameter, select Length.

■ Click OK.

14 In the Family Types dialog, under Other, for base_thickness, enter 1-1/2'', and click OK.

15 Add the base_thickness parameter to the base plate (solid form):

■ Select the base plate, and on the Element panel, click Element Properties.
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■ In the Instance Properties dialog, under Constraints, for Extrusion End, click  .

■ In the Associate Family Parameter dialog, select base_thickness.

16 Click OK twice.

Specify a base_thickness value for all 3 bookcase types

17 On the Family Properties panel, click Types.

18 In the Family Types dialog:

■ Under Name, select 60x18x60.

■ Under Other, for base_thickness, enter 1-1/2''.

■ Click Apply.

■ Using the same method, change the base_thickness to 1-1/2'' for the remaining bookcase
types.

■ Under Name, select 72x18x48.

■ Click OK.

19 On the Quick Access toolbar, click  (3D View).

20 On the View Control Bar, click Model Graphics Style ➤ Shading with Edges.

21 Proceed to the next exercise, Adding a Top Shelf on page 186.

Adding a Top Shelf
In this exercise, you create a top shelf with a downturn. A side view is appropriate for drafting the most
representative shape of the top.
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Training File

■ Continue to use the family that you used in the previous exercise, Bookcase.rfa, or open training file
Imperial\Families\Furniture\Bookcase_04.rfa.

■ If you are using the supplied training file, click  ➤ Save As ➤ Family.

■ In the left pane of the Save As dialog, click Training Files, and save the file as
Imperial\Families\Furniture\Bookcase.rfa.

Sketch the top shelf

1 In the Project Browser, under Elevations, double-click Left.
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2 Click Create tab ➤ Forms panel ➤ Solid drop-down ➤ Extrusion.

3 Click Create tab ➤ Work Plane panel ➤ Set.

4 In the Work Plane dialog, under Specify a new Work Plane, for Name, select Reference Plane:
Left.

5 Click OK.

6 On the View Control Bar, click the current scale, and click 3''=1'-0''.

7 Click Create Extrusion tab ➤ Draw panel, and verify that  (Line) is selected.

8 On the Options Bar, verify that Chain is selected.

9 Sketch a reverse L-shaped closed extrusion clear of all reference planes.

10 Add an arc to the sketch:

■ On the Options Bar, clear Chain.

■ On the Draw panel, click  (Fillet Arc).

■ Select the adjacent edges of the top right corner of the sketch, and click to create the arc.

■ Select the radius value, and enter 3/4''.

■ Click Create Extrusion tab ➤ Edit panel ➤ Align.
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■ Select the inside face of the back panel, and select the left edge of the sketch.

■ Lock the alignment.

■ Select the Front reference plane, and select the right face of the sketch.

■ Lock the alignment.

■ Click Create Extrusion tab ➤ Annotate panel ➤ Dimension drop-down ➤ Aligned Dimension,
and place 2 dimensions as shown.
Be sure to dimension the thickness of the downturn from the Front reference plane.

■ On the Selection panel, click Modify.

■ While pressing Ctrl, select both dimensions.

■ On the Options Bar, for Label, select panel_thickness.
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■ Click Create Extrusion tab ➤ Annotate panel ➤ Dimension drop-down ➤ Aligned Dimension.

■ Place dimensions to locate the top of the sketch 2'' from the Top reference plane, and to
locate the bottom of the downturn 3'' below the underside of the top of the sketch.
To edit dimensions, select the dimensioned sketch line, select the dimension value, and
enter the modified value.

11 On the Extrusion panel, click Finish Extrusion.
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12 In the Project Browser, under Floor Plans, double-click Ref. Level.

The extrusion begins on the Left reference plane, but is not constrained. The sketch will always
move with the reference plane, but you can adjust the start and end of extrusions. You can edit
extrusion properties or use the face arrow grips.

Select the top solid form and constrain the edges to the inside of the side panels

13 Select the extrusion.

In order to make it easier to align the extrusion edges to the panels, you first move the edges
clear of the panels.
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14 Select the grip on the right side of the extrusion, and drag it toward the Center (Left/Right)
reference plane.

15 Repeat for the left grip until the solid form displays as shown.

16 Align and lock both ends of the extrusion to the inside of the side panels:

■ Click Modify tab ➤ Edit panel ➤ Align.

■ Select the inside face of the left panel.

■ Select the left side of the extrusion, and lock the alignment.
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■ Select the inside face of the right panel.

■ Select the right side of the extrusion, and lock the alignment.

17 On the Quick Access toolbar, click  (3D View).

18 On the View Control Bar, click Model Graphics Style ➤ Shading with Edges.

Flex the family

19 On the Family Properties panel, click Types.

20 In the Family Types dialog, for Name, select 60x18x60.

21 Click Apply.

22 Repeat for 36x12x36 and 72x18x48.

Adding a Top Shelf | 193



23 Click OK.

24 Proceed to the next exercise, Changing the Shape of the Side Panels on page 194.

Changing the Shape of the Side Panels
In this exercise, you change the shape of the bookcase side panels from rectangular to rounded. To accomplish
this, you edit the panel sketches. In anticipation of future changes, you created the sketches in the Ref. Level
view so that the side panels could be given a rounded face.

Training File

■ Continue to use the family that you used in the previous exercise, Bookcase.rfa, or open training file
Imperial\Families\Furniture\Bookcase_05.rfa.

■ If you are using the supplied training file, click  ➤ Save As ➤ Family.

■ In the left pane of the Save As dialog, click Training Files, and save the file as
Imperial\Families\Furniture\Bookcase.rfa.

Modify the left panel

1 In the Project Browser, under Floor Plans, double-click Ref. Level.

2 Select the left panel, and click Modify Extrusion tab ➤ Form panel ➤ Edit Extrusion.

3 Select the left vertical line of the panel sketch, and press Delete.
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4 Replace the deleted line with a rounded panel:

■ On the Draw panel, click  (Start-End-Radius Arc).

■ In the location where you deleted the panel line, select the top endpoint.

■ Select the bottom endpoint.

■ Click to place the arc.

■ Modify the arc dimension to 2'.

5 On the Selection panel, click Modify.

6 Select the arc, and on the Draw panel, click Properties.

7 In the Instance Properties dialog, under Graphics, select Center Mark Visible, and click OK.

Displaying the center mark allows you to dimension to the center of the circle.

8 Click Modify Extrusion>Edit Extrusion tab ➤ Annotate panel ➤ Dimension drop-down ➤ Aligned
Dimension.

9 Dimension the Left reference plane and the center of the circle.

This ensures that the arc center will stay at a fixed distance from the Left reference plane.
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Modify the right panel

10 Using the same method, create a rounded panel on the right side of the bookcase.

11 Click Finish Extrusion.

12 On the Quick Access toolbar, click  (3D View).

13 Proceed to the next exercise, Creating and Assigning Subcategories on page 197.
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Creating and Assigning Subcategories
In this exercise, you add a number of subcategories to the bookcase family so you can assign materials to its
individual components, such as the shelves, door, base plate, panels, and top. After you create the
subcategories, you assign each piece of the bookcase geometry to one of the subcategories.

Later in this tutorial, you apply different materials to each subcategory, allowing you to vary the materials
that you apply to each component of the bookcase.

Training File

■ Continue to use the family that you used in the previous exercise, Bookcase.rfa, or open training file
Imperial\Families\Furniture\Bookcase_06.rfa.

■ If you are using the supplied training file, click  ➤ Save As ➤ Family.

■ In the left pane of the Save As dialog, click Training Files, and save the file as
Imperial\Families\Furniture\Bookcase.rfa.

Create subcategories in the Furniture category

1 Click Manage tab ➤ Family Settings panel ➤ Settings drop-down ➤ Object Styles.

The Object Styles dialog displays. In the next steps, you add subcategories under the main
Furniture category. Later in this tutorial, you will use this dialog to specify default materials for
each subcategory that you create.

2 In the Object Styles dialog, on the Model Objects tab, under Category, select Furniture.

3 Under Modify Subcategories, click New.

4 In the New Subcategory dialog, for Name, enter Base, and click OK.

5 Using the same method, create additional subcategories:

■ Top

■ Panels

■ Shelves

■ Door

6 When you finish creating subcategories, click OK.

Assign solid forms to the corresponding subcategories

7 While pressing Ctrl, select the side and back panels of the bookcase.
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8 On the Element panel, click Element Properties drop-down ➤ Instance Properties.

9 In the Instance Properties dialog, under Identity Data, for Subcategory, select Panels, and click
OK.

10 Press Esc.

11 Using the same method, assign the corresponding subcategory to the top and the base of the
bookcase.

Although you created Door and Shelves categories, you have not created the door and shelf
geometry. You will create and assign them in subsequent exercises.

12 Proceed to the next exercise, Adding Shelves on page 198.

Adding Shelves
In this exercise, you add 3 shelves to the bookcase family. You create the shelves by sketching multiple
closed loops. You then apply parameters to control the shelf spacing.

Training File

■ Continue to use the family that you used in the previous exercise, Bookcase.rfa, or open training file
Imperial\Families\Furniture\Bookcase_07.rfa.

■ If you are using the supplied training file, click  ➤ Save As ➤ Family.
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■ In the left pane of the Save As dialog, click Training Files, and save the file as
Imperial\Families\Furniture\Bookcase.rfa.

Sketch the shelves

1 In the Project Browser, under Elevations, double-click Front.

2 Click Create tab ➤ Forms panel ➤ Solid drop-down ➤ Extrusion.

3 On the Draw panel, click  (Rectangle).

4 Draw 3 stepped rectangles as shown.

5 Align and lock the left edges:

■ On the Edit panel, click Align.

■ Select the left edge of the bottom rectangle, and then the left edge of the rectangle above.

■ Lock the alignment.

■ Select the left edge of the bottom rectangle, and then the left edge of the top rectangle.

■ Lock the alignment.

6 Repeat the process for the right edges of the rectangles.
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7 Align and lock the bottom shelf edges with the inside face of the side panels:

■ On the Edit panel, click Align.

■ Select the reference plane at the top of the base, select the bottom edge of the lowest rectangle,
and lock the alignment.

Apply the panel_thickness parameter to the shelves

8 On the Annotate panel, click Dimension drop-down ➤ Aligned Dimension.

9 Place individual dimensions (not a string) as shown to control shelf thickness and spacing.
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10 On the Selection panel, click Modify.

11 Select the dimensions controlling the thickness of the shelf sketches, and apply the
panel_thickness parameter.

Create and apply maximum and minimum shelf spacing parameters

12 Select the dimension between the bottom and middle shelves.

13 On the Options Bar, for Label, click <Add parameter>.

14 In the Parameter Properties dialog, under Parameter Name, enter shelf_maximum_spacing, and
click OK.

15 Press Esc.

16 Select the dimension between the middle and top shelves, and create a shelf_minimum_spacing
parameter.
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17 On the Element panel, click Extrusion Properties.

18 In the Instance Properties dialog:

■ Under Constraints, for Extrusion End, enter 1'.
This is a temporary value as you will later constrain the shelves to the back panel.

■ Click OK.

Finish the shelves

19 On the Extrusion panel, click Finish Extrusion.

20 In the Project Browser, under Floor Plans, double-click Ref. Level.

21 Select the shelf.

22 Drag and lock the sides of the shelf to the inside faces of the side panels.

23 Drag the top grip up and lock the edge of the shelf to the inside of the back panel.

24 On the Quick Access toolbar, click  (3D View).
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Flex the family

25 On the Family Properties panel, click Types.

26 In the Family Types dialog, for Name, verify 72x18x48 is selected.

27 Under Other, for shelf_minimum_spacing, enter 6''.

28 For shelf_maximum_spacing, enter 1'.

29 Click Apply.

30 For Name, select 60x18x60.

31 Under Other, for shelf_minimum_spacing, enter 6''.

Shelf spacing can be specified with default values for each family type.

32 For shelf_maximum_spacing, enter 1'.

33 Click Apply.
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34 For Name, select 36x12x36.

35 Under Other, for shelf_minimum_spacing, enter 4''.

36 For shelf_maximum_spacing, enter 4''.

37 Click Apply.

38 For Name, select 72x18x48, and click OK.

Assign the Shelves subcategory

39 Select the shelves, and on the Element panel, click Element Properties.

40 In the Instance Properties dialog, under Identity Data, for Subcategory, select Shelves.

41 Click OK.

42 Proceed to the next exercise, Adding an Enclosure Panel on page 204.

Adding an Enclosure Panel
In this exercise, you add a vertical enclosure panel to the top shelf of the bookcase.
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In the next exercise, you create a door to complete the enclosure.

Training File

■ Continue to use the family that you used in the previous exercise, Bookcase.rfa, or open training file
Imperial\Families\Furniture\Bookcase_08.rfa.

■ If you are using the supplied training file, click  ➤ Save As ➤ Family.

■ In the left pane of the Save As dialog, click Training Files, and save the file as
Imperial\Families\Furniture\Bookcase.rfa.

Create a reference plane for the vertical enclosure panel

1 In the Project Browser, under Elevations, double-click Front.
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2 Click Create tab ➤ Datum panel ➤ Reference Plane drop-down ➤ Draw Reference Plane.

3 Sketch a vertical reference plane between the left and center planes.

4 Press Esc twice.

5 Select the reference plane, and on the Element panel, click Element Properties.

6 In the Instance Properties dialog, under Identity Data, for Name, enter Enclosure.

7 Click OK.

Create a parameter to control the enclosure length

8 Click Detail tab ➤ Dimension panel ➤ Aligned.
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9 Select the Left reference plane.

10 Select the Enclosure reference plane.

11 Click to place the dimension.

12 On the Selection panel, click Modify.

13 Select the dimension you just placed, and on the Options Bar, for Label, select <Add parameter>.

14 In the Parameter Properties dialog, under Parameter Data, for Name, enter enclosure_length,
and click OK.

15 On the Family Properties panel, click Types.

16 In the Family Types dialog, under Other, for enclosure_length, enter 2', and click Apply.

17 Apply the same value for enclosure_length to all the family types.

18 For Name, select 72x18x48, and click OK.
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Sketch the enclosure panel

19 Click Create tab ➤ Forms panel ➤ Solid drop-down ➤ Extrusion.

20 On the Draw panel, click  (Rectangle).

21 Draw the sketch clear of reference planes.

22 On the Edit panel, click Align.

23 Select the Enclosure reference plane.

24 Select the left edge of the rectangle, and lock the alignment.
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25 Select the underside of the bookcase top.

26 Select the top of the rectangle, and lock the alignment.

27 Select the top face of the top shelf.

28 Select the bottom line of the rectangle, and lock the alignment.
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29 Dimension between the Enclosure reference plane and the right edge of the rectangle:

■ On the Annotate panel, click Dimension drop-down ➤ Aligned Dimension.

■ Select the Enclosure reference plane.

■ Select the right edge of the sketch.

■ Click to place the dimension.

Add the panel_thickness parameter

30 On the Selection panel, click Modify.
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31 Select the dimension that you just placed.

32 On the Options Bar, for Label, select panel_thickness.

33 On the Extrusion panel, click Finish Extrusion.

Align the panel

34 In the Project Browser, under Floor Plans, double-click Ref. Level.
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35 Select the panel.

36 Drag the top grip to align with the inside face of the back panel and lock the alignment.

37 Drag the bottom grip to align with the inside face of the top shelf.

38 On the Quick Access toolbar, click  (3D View).

39 Assign a subcategory to the panel:

■ Select the panel, and on the Element panel, click Element Properties.

■ In the Instance Properties dialog, under Identity Data, for Subcategory, select Panels, and
click OK.
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■ Press Esc.

40 Proceed to the next exercise, Adding a Door on page 213.

Adding a Door
In this exercise, you add a door with a circular opening and a glass panel that adjusts to fit the enclosure.
The same parameter that positions the vertical panel controls the door width.

Training File

■ Continue to use the family that you used in the previous exercise, Bookcase.rfa, or open training file
Imperial\Families\Furniture\Bookcase_09.rfa.

■ If you are using the supplied training file, click  ➤ Save As ➤ Family.

■ In the left pane of the Save As dialog, click Training Files, and save the file as
Imperial\Families\Furniture\Bookcase.rfa.

Use concentric rectangles to create the door

1 In the Project Browser, under Elevations, double-click Front.

2 Click Create tab ➤ Forms panel ➤ Solid drop-down ➤ Extrusion.

3 Click Create tab ➤ Work Plane panel ➤ Set.

4 In the Work Plane dialog, under Specify a new Work Plane, verify that Name and Reference
Plane: Front are selected.

5 Click OK.

6 Click Create Extrusion tab ➤ Draw panel ➤  (Rectangle).

7 Sketch 2 concentric rectangles as shown.

The inner sketch will be interpreted as a void by the software.
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8 On the Selection panel, click Modify.

9 On the Edit panel, click Align.

10 Align and lock the 4 edges of the outer sketch:

■ Align and lock the left edge to the inside of the side panel.

■ Align the top edge to the bottom of the downturn (top shelf).

■ Align the right edge to the outside face of the vertical panel.

■ Align the bottom edge to the top face of the shelf.

11 On the View Control Bar, click the current scale, and select 3''=1'-0''.

12 Dimension the door sketch to locate the opening:

■ Click Create Extrusion tab ➤ Annotate panel ➤ Dimension drop-down ➤ Aligned Dimension.

■ Move the cursor over one of the lines of the outer sketch, press Tab until it highlights, and
select it.

■ Move the cursor to the parallel line of the inner sketch, select the line, and click to place the
dimension.

■ Using the same method, dimension the remaining sketch lines.
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13 On the Selection panel, click Modify.

14 Select the inner sketch lines individually and adjust each offset distance to 3''.

15 On the Element panel, click Extrusion Properties.

16 In the Instance Properties dialog, under Constraints, for Extrusion End, click  .

17 In the Associate Family Parameter dialog, under Existing family parameters of compatible type,
select panel_thickness.

18 Click OK twice.

19 On the Extrusion panel, click Finish Extrusion.
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Draw a solid form for the door glass

20 Click Create tab ➤ Forms panel ➤ Solid drop-down ➤ Extrusion.

21 Click Create tab ➤ Work Plane panel ➤ Set.

22 In the Work Plane dialog, under Specify a new Work Plane, verify that Name and Reference
Plane: Front are selected.

23 Click OK.

24 Click Create Extrusion tab ➤ Draw panel ➤  (Rectangle).

25 Sketch a rectangle directly on top of the rectangle that represents the void (the inner rectangle
sketch).

26 Lock each line.

Because you sketched the rectangle on top of the other, alignment between the rectangles is
assumed. This is a fast way to align elements. It is only applicable where there are not multiple
superimposed faces or reference planes.

27 With the glass sketch still selected, on the Element panel, click Extrusion Properties.

28 In the Instance Properties dialog:

■ Under Constraints, for Extrusion End, enter 1/2''.

■ For Extrusion Start, enter 1/4''.

■ Click OK.

29 On the Extrusion panel, click Finish Extrusion.

30 In the Project Browser, under Floor Plans, double-click Ref. Level.

31 Confirm that the glass displays as shown.

You can edit the extrusion properties if the beginning and end of the extrusion need to be
adjusted.
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32 On the Quick Access toolbar, click  (3D View).

The glass now displays as a solid form. Later in this tutorial, you will apply a glass material to
the form.

33 Assign a subcategory to the door:

■ Select the door, and on the Element panel, click Element Properties.

■ In the Instance Properties dialog, under Identity Data, for Subcategory, select Door, and click
OK.

■ Press Esc.

Create a circular opening

34 In the Project Browser, under Elevations, double-click Front.

35 On the Design Bar:

■ Click Create tab ➤ Forms panel ➤ Void drop-down ➤ Extrusion.

■ Click Create tab ➤ Work Plane panel ➤ Set.

36 In the Work Plane dialog, under Specify a new Work Plane, verify that Name and Reference
Plane: Front are selected.
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37 Click OK.

38 Click Create Void Extrusion tab ➤ Draw panel ➤  (Circle).

39 Sketch a circle with a 1'' radius at the top right corner of the door.

40 On the Selection panel, click Modify.

41 Select the circle, and on the Draw panel, click Properties.

42 In the Instance Properties dialog, under Graphics, select Center Mark Visible, and click OK.

43 Click Annotate panel ➤ Dimension drop-down ➤ Aligned Dimension.

44 Add 2 dimensions and position the center of the circle 1-1/4'' from the top edges of the glass
opening.

45 On the Element panel, click Extrusion Properties.

46 In the Instance Properties dialog:

■ Under Constraints, for Extrusion End, enter 1''.

■ For Extrusion Start, enter 0.
You use a value greater than the thickness of the door.

■ Click OK.
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47 On the Extrusion panel, click Finish Extrusion.

Verify that you created a solid void extrusion that starts on the Front reference plane and ends
beyond the door.

48 On the Quick Access toolbar, click  (3D View).

49 Proceed to the next exercise, Managing Visibility on page 220.
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Managing Visibility
In this exercise, you specify the visibility of the bookcase family in different views. When you add bookcase
instances to plan views, you want to make sure that a 2D symbolic linework representation of the bookcase
displays, and not a hidden line representation of the more complex 3D bookcase. By specifying the appropriate
visibility settings in each view, you reduce the regeneration time of the bookcase element in your projects.

Training File

■ Continue to use the family that you used in the previous exercise, Bookcase.rfa, or open training file
Imperial\Families\Furniture\Bookcase_10.rfa.

■ If you are using the supplied training file, click  ➤ Save As ➤ Family.

■ In the left pane of the Save As dialog, click Training Files, and save the file as
Imperial\Families\Furniture\Bookcase.rfa.

Create symbolic lines for detail levels

1 In the Project Browser, under Floor Plans, double-click Ref. Level.

2 Click Detail tab ➤ Detail panel ➤ Symbolic Line.

3 On the Options Bar, clear Chain if it is selected.

4 On the Draw panel, click  (Start-End-Radius Arc).

5 Using the Line and Arc tools, create a closed sketch as shown, clear of the existing bookcase
geometry.

6 On the Selection panel, click Modify.

7 Click Modify tab ➤ Edit panel ➤ Align.

8 Align the sketch in the following order:

■ Align the top of the sketch to the Back reference plane.

■ Align both arcs to the arced side faces.

■ Align the bottom line to the Front reference plane.
The order in which you align the sketch geometry is important because you need to establish
the relationships between the connected sides of the sketch.

9 On the Selection panel, click Modify, and select all of the bookcase geometry, including the
sketch that you just aligned.

10 On the Filter panel, click Filter.

11 In the Filter dialog, click Check None.

12 Select Lines (Furniture), and click OK.
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13 On the Visibility panel, click Visibility Settings.

14 In the Family element visibility settings dialog, under Detail Levels, verify that Coarse, Medium,
and Fine are selected, and click OK.

The outline symbolic linework will display at all detail levels.

15 Click Detail tab ➤ Detail panel ➤ Symbolic Line.

16 Draw and constrain a symbolic line on the inside face of the back panel and on the inside face
of both side panels.

NOTE A red selection color is used for clarity in the image.

17 While pressing Ctrl, select the 3 lines.

18 On the Visibility panel, click Visibility Settings.

19 In the Family element visibility settings dialog, under Detail Levels, clear Coarse.

The additional 3 symbolic lines will display in the Medium and Fine detail levels. You still need
to ensure that the 3D geometry does not show in plan views where it could increase regeneration
time.

20 Click OK.

21 On the Quick Access toolbar, click  (3D View).

22 Select all of the 3D geometry.

The symbolic lines only display parallel to the view in which they were drawn, so they are not
available for selection in the 3D view.

23 On the Form panel, click Visibility Settings.

24 In the Family Element Visibility Settings dialog:

■ Under View Specific Display, clear Plan/RCP.

NOTE Furniture families can not be cut in Plan/RCP. Families such as windows or doors would
have this option.

■ Click OK.
The 3D model will not display in plan views. This only becomes clear to you when you see
the family in a project.

25 Press Esc.

26 Open the i_art_gallery.rvt project, and open the Level 1 floor plan.
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27 Click View tab ➤ Windows panel ➤ Switch Windows drop-down ➤ Bookcase.rfa.

28 On the Family Editor panel, click Load into Project.

The Place Component tab is active in the project and the bookcase component is selected.

29 Place the bookcase, and test its display in coarse, medium, and 3D views.

The symbolic linework shown in plan views does not hide a pattern on a floor, so you must also
add a masking region to the bookcase family. You want the model to display as shown when
viewed at medium or fine detail on a floor with a material pattern.

30 Proceed to the next exercise, Adding a Masking Region on page 222.

Adding a Masking Region
In this exercise, you create a masking region to ensure that the bookcase hides any floor materials on which
it is placed in a plan view.

Training File

■ Continue to use the family that you used in the previous exercise, Bookcase.rfa, or open training file
Imperial\Families\Furniture\Bookcase_11.rfa.

■ If you are using the supplied training file, click  ➤ Save As ➤ Family.

■ In the left pane of the Save As dialog, click Training Files, and save the file as
Imperial\Families\Furniture\Bookcase.rfa.

Create a masking region

1 In the Project Browser, under Floor Plans, double-click Ref. Level.

2 Select all the bookcase geometry.

3 On the Filter panel, click Filter.

4 In the Filter dialog, click Check None.

5 Select Lines (Furniture), and click OK.

NOTE A red selection color is used for clarity in the image.
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6 On the View Control Bar, click Click Temporary Hide/Isolate ➤ Hide Category.

This removes the lines from the view so you can more easily align the masking region to the
geometry.

7 Click Detail tab ➤ Detail panel ➤ Masking Region.

8 On the Draw panel, click  (Start-End-Radius Arc) to create a closed sketch as shown, clear of
the existing geometry.

Align and constrain the masking region

9 On the Edit panel, click Align.

10 Align and lock the masking region:

■ Align the top line to the Back reference plane.

■ Align both arcs to the arced side faces.

■ Align the bottom line to the Front reference plane.

11 On the Masking Region panel, click Finish Region.

12 On the View Control Bar, click Click Temporary Hide/Isolate ➤ Reset Temporary Hide/Isolate.

13 Proceed to the next exercise, Creating and Assigning Materials on page 223.

Creating and Assigning Materials
In this exercise, you create and apply materials to the components of the bookcase family: the base plate,
the door, the glass panel in the door, the panels, the shelves, and the bookcase top. To apply materials to
these different components, you apply them directly and by family subcategory.

You begin by applying a glass material to the panel in the bookcase door. This panel is intended to be glass
and is unlikely to change, so you apply it directly to the Material parameter of the panel in its Element
Properties.
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Glass material applied to the bookcase door

Next, you decide to apply a different material to each of the remaining components of the bookcase. When
you create bookcases with the finished family, you also want to be able to apply a different material to each
component and update all instances of the bookcase to reflect the material change.

To accomplish this, you apply different materials to each of the family subcategories: Base, Door, Panels,
Shelves, and Top. Changing the material that is applied to the Shelves subcategory will change the shelf
material of all bookcases that you create with the Bookcase family.

You can also create material parameters within a family to provide a list of alternate materials. The material
can be unique within the bookcase. Material parameters are covered in the next exercise.

Training File

■ Continue to use the family that you used in the previous exercise, Bookcase.rfa, or open training file
Imperial\Families\Furniture\Bookcase_12.rfa.

■ If you are using the supplied training file, click  ➤ Save As ➤ Family.

■ In the left pane of the Save As dialog, click Training Files, and save the file as
Imperial\Families\Furniture\Bookcase.rfa.

Apply a glass material to the bookcase door

1 If necessary, on the Quick Access toolbar, click  (3D View), and zoom in to the door.

2 Select the solid form that represents the door glass.
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3 On the Element panel, click Element Properties.

4 In the Instance Properties dialog, under Materials and Finishes, for Material, click in the Value

field, and click  .

5 In the Materials dialog, under Materials, select Glass.

6 In the right pane, on the Graphics tab, review the Shading settings.

The Glass material has a blue color and a Transparency value of 75%.

7 Click OK twice.

8 Press Esc.

The bookcase door glass displays as both blue and transparent in the project.

After you apply a material in the Element Properties, you can only change it in the Family Editor.
You cannot change it in an instance of the family in a project.

TIP When creating proprietary furniture families, use this method to apply all the necessary furniture
materials. The materials display in projects as designed and are not easily modified.
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Create new materials for the bookcase

9 Click Manage tab ➤ Family Settings panel ➤ Materials.

10 In the Materials dialog, under Materials, select Default.

11 At the bottom left of the dialog, click  (Duplicate).

12 In the Duplicate Revit Material dialog, for Name, enter Bookcase_Base, and click OK.

The new material displays in the Materials list.

TIP Use a material naming convention like this one to group family materials under a common prefix
(in this example, Bookcase). Materials applied to family components are loaded into a project with
the family.

13 Using the same method, create the following bookcase materials by duplicating the Bookcase_Base
material (keep the Materials dialog open when you’re finished creating materials):

■ Bookcase_Top

■ Bookcase_Panels

■ Bookcase_Shelves

■ Bookcase_Door

Next, assign display properties and render appearances to each of the materials that you just
created. Later, when you apply the material to a family component, the display properties
determine the component color in shaded views. The render appearance determines the display
of the component when it is rendered.

Specify the material display properties and render appearances

14 In the Materials dialog, under Materials, select Bookcase_Base.

15 On the Graphics tab, under Shading, click the color swatch.

16 In the Color dialog, select a brown color for the bookcase base, and click OK.

This is usually similar in color to the render material and is useful in visually differentiating
material assignments.

17 In the Materials dialog, click the Render Appearance tab.

18 Under Render Appearance Based On, click Replace.

19 In the Render Appearance Library, for Class, select Paint.

20 Select the Paint Brindle Glossy render appearance.

21 Click OK.

22 Using the same method, assign the following colors and render appearances to the other bookcase
materials:

Render AppearanceColorMaterial

Paint Light Red GlossyRedBookcase_Door

Paint Dark Cadet Blue GlossyBlue-greenBookcase_Panels

Wood Birch Natural Medium GlossLight brownBookcase_Shelves

Paint Brindle GlossyMedium brownBookcase_Top
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NOTE When you assign the Wood Birch Natural Medium Gloss render appearance to the shelves,
notice that it contains a bitmap image to depict the wood grain. Materials with bitmap images like
this one are visible only when you render an element in a project to which the material is applied.

23 Click OK.

Next, apply the Bookcase materials to the corresponding family subcategories in order to apply
them to the family components.

Apply the bookcase materials to the Furniture subcategories

24 Click Manage tab ➤ Family Settings panel ➤ Settings drop-down ➤ Object Styles.

25 In the Object Styles dialog, on the Model Objects tab, under Category ➤ Furniture, select Base.

26 For Base, click in the Material field, and click  .

27 In the Materials dialog, under Materials, select Bookcase_Base, and click OK.

28 Using the same method, assign the remaining bookcase materials to the corresponding
subcategories:

MaterialSubcategory

Bookcase_DoorDoor

Bookcase_PanelsPanels

Bookcase_ShelvesShelves

Bookcase_TopTop

29 Click OK.

The bookcase family displays with the colors that you assigned to it.

30 Proceed to the next exercise, Creating a Material Parameter on page 227.

Creating a Material Parameter
In this exercise, you add a material parameter to the bookcase family. When you add bookcases to a project,
this parameter gives you the option to change the door material for a single bookcase or for each type of
bookcase that you create, independent of the material that is applied to the bookcase door by family
subcategory.
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Training File

■ Continue to use the family that you used in the previous exercise, Bookcase.rfa, or open training file
Imperial\Families\Furniture\Bookcase_13.rfa.

■ If you are using the supplied training file, click  ➤ Save As ➤ Family.

■ In the left pane of the Save As dialog, click Training Files, and save the file as
Imperial\Families\Furniture\Bookcase.rfa.

Add a material parameter to the Bookcase family

1 On the Family Properties panel, click Types.

2 In the Family Types dialog, under Parameters, click Add.

3 In the Parameter Type dialog:

■ Under Parameters, for Name, enter door_finish.

■ Under Group Parameter under, select Materials and Finishes.

■ Under Type of Parameter, select Material.

■ Select Instance.
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By creating this parameter as an instance parameter, you will be able to choose different
door finishes for each instance of the bookcase family that you place in a project.

4 Click OK twice.

Apply the door_finish parameter to the door

5 Select the door, and on the Element panel, click Element Properties.

6 In the Instance Properties dialog:

■ Under Materials and Finishes, for Material, click  .

■ In the Associate Family Parameters dialog, for Existing family parameters of compatible type,
select door_finish.

7 Click OK twice.

8 Save the bookcase family.

Load the bookcase family into a new project

9 Click  ➤ New ➤ Project.

10 Name and save the new project, but do not close it.

11 Open Bookcase.rfa, and on the Family Editor panel, click Load into Project.

The new project displays.

Place 3 instances of the bookcase family

12 In the Type Selector, select a bookcase type, and place 3 bookcases of the same type in the
project.

13 On the Selection panel, click Modify.

14 On the Quick Access toolbar, click  (3D View).

All 3 bookcases have materials applied to their components by family subcategory.

15 On the View Control Bar, click Model Graphics Style ➤ Shading with Edges.
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Vary the material applied to the bookcase doors

16 Select the middle bookcase.

17 On the Element panel, click Element Properties.

18 In the Instance Properties dialog:

■ Under Materials and Finishes, for door_finish, click in the Value field, and click  .

■ In the Materials dialog, under Materials, select Bookcase_Top.
The same material applied to the top of the bookcase will be applied to the door.

19 Click OK twice.

20 Select the third bookcase.

21 Using the same method, apply the Bookcase_Shelves material to the door_finish parameter.
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22 Proceed to the next exercise, Controlling the Door Visibility on page 232.
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Controlling the Door Visibility
In this exercise, you add a visibility parameter to the bookcase family that lets you control whether a bookcase
that you place in a project includes the glass panel door. The parameter controls the visibility of both the
door and glass for each instance of the bookcase.

When you create the parameter, you name it door_included so that its function is obvious. The parameter
offers a yes/no selection when you view the properties of the bookcase door and glass. You choose yes to
display the door and glass, or no to turn their visibility off.

Training File

■ Continue to use the family that you used in the previous exercise, Bookcase.rfa, or open training file
Imperial\Families\Furniture\Bookcase_14.rfa.

■ If you are using the supplied training file, click  ➤ Save As ➤ Family.

■ In the left pane of the Save As dialog, click Training Files, and save the file as
Imperial\Families\Furniture\Bookcase.rfa.

Add a parameter to control the door visibility

1 If necessary, click View tab ➤ Windows panel ➤ Switch Windows drop-down ➤ bookcase.rfa

2 On the Family Properties panel, click Types.

3 In the Family Types dialog:

■ Under Parameters, click Add.

■ In the Parameter Properties dialog, under Parameter Data, for Name, enter door_included.

■ Under Group parameter under, select Materials and Finishes.

■ Under Type of Parameter, select Yes/No.
The parameter will have a yes/no option for visibility.

■ Select Instance so that even with multiple instances of the same bookcase, you can decide
which display with doors.
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4 Click OK twice.

Associate the parameter with the door and the door glass

5 In the drawing area, select the bookcase door.

6 On the Element panel, click Element Properties.

7 In the Instance Properties dialog:

■ Under Graphics, for Visible, in the = column, click  .

■ In the Associate Family Parameter dialog, under Existing family parameters of compatible
type, select door_included.

8 Click OK twice.

9 Using the same method, associate the door_included parameter with the door glass.

Add bookcases to a project

10 Click  ➤ New ➤ Project.

11 Name and save the new project, but do not close it.

12 Open Bookcase.rfa, and on the Family Editor panel, click Load into Project.

The new project displays.

13 In the Type Selector, select Bookcase: 72x18x48, and add a bookcase to the project.

14 Using the same method, add a 60x18x60 and a 36x12x36 bookcase to the project.

15 On the Selection panel, click Modify.

Test the visibility of the door and glass in the project

16 On the Quick Access toolbar, click  (3D View).
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17 Select the 60x18x60 bookcase.

18 On the Modify panel, click Copy.

19 Click the lower-left endpoint of the bookcase, drag the cursor forward, and click to create a copy.

20 With the copy of the bookcase selected, on the Element panel, click Element Properties.

21 In the Instance Properties dialog:

■ Under Materials and Finishes, clear door_included.

■ Click OK.
The bookcase door and glass no longer display in the copy of the bookcase.

22 Proceed to the next exercise, Creating a Type Catalog on page 235.
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Creating a Type Catalog
In this exercise, you create a type catalog for the Bookcase family. A type catalog is a dialog that displays
when you load a family into a project. It lists all the types in the family, allowing you to select and load
only the types that the current project requires.

Bookcase family type catalog

To create a type catalog, you create an external text file that contains the parameters and parameter values
that create the different types in the family. You place this file in the location of the family file. When you
load the family, the type catalog displays.

Type catalogs are most useful with large families, such as steel sections, that contain many types. Selecting
and loading only the types that you need for a project helps keep the project file size smaller.

BEST PRACTICE  Create type catalogs for families that contain 6 or more types.

Training File

■ Continue to use the family that you used in the previous exercise, Bookcase.rfa, or open training file
Imperial\Families\Furniture\Bookcase_15.rfa.

■ If you are using the supplied training file, click  ➤ Save As ➤ Family.

■ In the left pane of the Save As dialog, click Training Files, and save the file as
Imperial\Families\Furniture\Bookcase.rfa.

Create a new type catalog file

1 Open Microsoft® Notepad.

NOTE Although you use Notepad to create the type catalog in this exercise, you can use any available
text editor.

2 Click File menu ➤ Save As.

3 Save the file as Bookcase.txt in the same location that you saved Bookcase.rfa.

The type catalog must have the same name as the family.

Enter first line of the type catalog file

4 On the first line in the text file, enter:

,length##length##inches

5 On the same line, at the end of the previous text, enter:

,width##length##inches

6 On the same line, at the end of the previous text, enter:
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,height##length##inches

The first line should now read:

,length##length##inches,width##length##inches,height##length##inches

Enter the second line of the type catalog file

7 Specify the name and dimensions of the first type:

36x12x36,36,12,36

The family type name will display as 36x12x36, and the values that are delimited by commas
display in the same order as they are in the first line of the file.

8 Add the 2 remaining types on separate lines:

60x18x60,60,18,60

72x18x48,72,18,48

Your completed type catalog should look like this:

9 Save and close the type catalog.

Load bookcase types into a project with the type catalog

10 Open i_art_gallery.rvt, and open the Level 1 floor plan.

11 Click Home tab ➤ Build panel ➤ Component drop-down ➤ Place a Component.

12 On the Model panel, click Load Family.

13 In the Open dialog, under Look in, navigate to the location where you saved Bookcase.rfa, select
it, and click Open.

The type catalog displays, listing the 3 bookcase types.

14 In the Specify Types dialog, under Types, select 36x12x36, and click OK.

15 In the Type Selector, notice that only the single type that you selected was loaded into the
project.

16 Add a 36x12x36 bookcase to the art gallery project.
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Creating a Complex
Window Family
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Creating a Complex
Window Family

In this tutorial, you create a complex window family from a basic template. The window is defined to be used in a cavity
wall, with wall components that wrap to the window frame on both the interior and exterior of the wall. The window is
composed of 2 window types: an operable casement window (width defined by the user) and a fixed window.

In addition to creating the 3D geometry, you add symbolic lines to the family so that it displays cleanly in plan and
elevation views.

8
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Casement swing display in
elevation

Casement swing display in plan

Finally, you nest standard sill families into the window to be displayed and scheduled.

Creating a Complex Wall Opening
In this lesson, you open a file based on a window template and create a complex opening for the window.
You delete the existing opening in the wall, and create a new opening by cutting the wall with a series of
voids. You use a series of voids rather than a single sketch because the void sizes are different values.
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Complex wall opening with interior and exterior wrap

Skills used in this lesson:

■ Creating void geometry

■ Using the Cut Geometry tool

■ Adding parameters to control wrap values, where wall components will overlap, and the depth of the
window frame.

■ Adding family types for window sizes

■ Testing the family in a project

■ Modifying properties to define wall closure and wrap options

Creating a Void to Cut the Exterior Wall Face
In this exercise, you create a void extrusion to cut an opening in the exterior wall face.

Open the family file

1 Click  ➤ Open ➤ Family.

2 In the left pane of the Open dialog, click Training Files, and open
Imperial\Families\Windows\Complex_Window_Start.rfa.

3 Click  ➤ Save As ➤ Family.

4 In the left pane of the Save As dialog, click Training Files, and save the file as
Imperial\Families\Complex_Window.rfa.
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Modify the size of the host wall

5 In the drawing area, select the wall, and on the Element panel, click Element Properties
drop-down ➤ Type Properties.

You alter the size of the host wall in the family template because this family will be used in a
cavity wall, which is typically thicker than a standard wall. By making the host wall in the
template thicker, it will also provide more room to create the reference planes needed when
you make the complex opening.

6 In the Type Properties dialog, under Construction, for Structure, click Edit.

7 In the Edit Assembly dialog, for Layer 2, click in the Thickness field, and enter 12''.

8 Click OK twice.

9 Press Esc.

10 Select the bottom middle sketch line (opening cut).

NOTE Press Tab to highlight the opening cut if you are having trouble selecting it.

11 Press Delete.

Because you are creating a more complex opening, the existing opening in the template can be
deleted. You replace this opening with a series of voids.

12 On the View Control Bar, click the scale value, and select 1 1/2'' = 1'0''.

Increase the scale to resize the dimension text and make it more readable as you work on the
window area.

Add reference planes to define voids for complex geometry

13 Click Create tab ➤ Datum panel ➤ Reference Plane drop-down ➤ Draw Reference Plane.

14 Sketch a horizontal reference plane just above the Center (Front/Back) horizontal reference
plane.

15 Press Esc twice.

16 Select the new reference plane, and on the Element panel, click Element Properties
drop-down ➤ Instance Properties.
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17 In the Instance Properties dialog, under Identify Data, for Name, enter Ext Wrap Depth, and
click OK.

When you name the reference planes, it is easier to dimension and align to them when the
family is placed in a project.

18 Press Esc.

19 Sketch 2 vertical reference planes, 1 to the left and 1 to the right of Center (Left/Right), as shown:

20 Press Esc twice.

21 Name the new reference planes Ext Wrap Left and Ext Wrap Right, accordingly.

Create a void extrusion

22 Click Create tab ➤ Forms panel ➤ Void drop-down ➤ Extrusion.

23 Click Create tab ➤ Work Plane panel ➤ Set.

24 In the Work Plane dialog, for Name, select Reference Plane: Sill.

The void sketch will be drawn starting at sill height.

25 Click OK.

26 Click Create Void Extrusion tab ➤ Draw panel ➤  (Rectangle).

27 On the Options Bar, verify that the Depth is 1'.

28 Sketch a rectangle, and align/lock it to the reference planes:

NOTE Sketching the geometry above the wall, rather than inside it, makes it easier to align the
geometry and ensures that hidden constraints are not created.

■ Sketch a rectangle above the wall between the inner vertical reference planes, as shown:

■ On the Edit panel, click Align.
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■ Select the Ext Wrap Depth reference plane.

■ Select the bottom sketch line, and click  .

■ Select the Ext Wall Face reference plane, select the top sketch line, and click  .

■ Select the Ext Wrap Left reference plane, select the left sketch line, and click  .

■ Select the Ext Wrap Right reference plane, select the right sketch line, and click  .

29 On the Extrusion panel, click Finish Extrusion.
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Dimension reference planes

30 Dimension the vertical reference planes:

■ Click Detail tab ➤ Dimension panel ➤ Aligned.

■ Dimension the 2 left reference planes, and dimension the 2 right reference planes.

■ On the Selection panel, click Modify.

■ Modify the dimensions if necessary, so that they are both 3''.

TIP When modifying dimensions, select the line that is to move when the dimension changes (in
this case, the inner reference planes).
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Add an overhang parameter

31 Select the left dimension, and on the Options Bar, for Label, select <Add parameter>.

32 In the Parameter Properties dialog, for Name, enter Ext. Wrap Overhang, for Group parameter
under, select Construction, and click OK.

This parameter describes how far the exterior wall wrap will overhang on the window frame.

33 Select the right dimension, and on the Options Bar, for Label, select Ext. Wrap Overhang.

34 In the Project Browser, expand Elevations, and double-click Exterior.

NOTE Click View tab ➤ Graphics panel ➤ Thin Lines to view the extrusion with thin lines.

35 Add a reference plane and assign the Ext. Wrap Overhang parameter to the window head:

■ Click Create tab ➤ Datum panel ➤ Reference Plane drop-down ➤ Draw Reference Plane.

■ Sketch a horizontal reference plane 3'' below the Head reference plane, and name it Ext Wrap
Top.
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■ Click Detail tab ➤ Dimension panel ➤ Aligned.

■ Dimension the top 2 reference planes.

■ Select the dimension, and on the Options Bar, for Label, select Ext. Wrap Overhang.

Creating a Void to Cut the Exterior Wall Face | 247



NOTE In this example, the same parameter is used for the head wrap and jamb for simplicity. Another
parameter could be created and assigned to define a different width at the head and jambs.

Cut the void from the host wall

36 Click Modify tab ➤ Edit panel ➤ Align.

37 Select the Ext Wrap Top reference plane, select the top line of the cut extrusion, and click 
.

38 In the Project Browser, under Floor Plans, double-click Ref. Level.

39 Click Modify tab ➤ Edit Geometry panel ➤ Cut drop-down ➤ Cut Geometry.

40 Select the extrusion, select the wall, and on the Selection panel, click Modify.

Add depth parameter

41 Click Detail tab ➤ Dimension panel ➤ Aligned.

42 Dimension the Ext Wall Face and Ext Wrap Depth reference planes, and click Modify.

The dimension value is not important.

43 Select the dimension, and on the Options Bar, for Label, select <Add parameter>.

44 In the Parameter Properties dialog, for Name, enter Ext. Wrap Depth, for Group parameter under,
select Construction, and click OK.

Create family types and flex the model geometry

45 In the Project Browser, under Elevations, double-click Exterior.
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46 On the Family Properties panel, click Types.

You should flex the family after you add each level of geometry. To make it easy to flex the
family, you add family types with different dimensions. You then apply the types and observe
the geometry.

47 Move the Family Types dialog so you can see the drawing area as you apply new types.

48 In the Family Types dialog, under Family Types, click New.

49 In the Name dialog, enter 4’0” H x 3’0” W_1’6” Casement, and click OK.

50 In the Family Types dialog, under Family types, click New.

51 In the Name dialog, enter 4’0” H x 5’0” W_1’6” Casement, and click OK.

52 Under Dimensions, for Height, enter 4' 0'', for Width, enter 5', and click Apply.

53 Using the same method, add a third family type, and name it 5’6” H x 6’0” W_2’0” Casement.

54 Under Dimensions, for Height, enter 5' 6'', for Width, enter 6', click Apply.

55 For Name, select 4’0” H x 3’0” W_1’6” Casement, and click OK.

56 Click  ➤ Save.

57 Proceed to the next exercise, Creating a Void for the Frame Geometry on page 249.

Creating a Void for the Frame Geometry
In this exercise, you create a solid void in the complex opening for the window frame geometry.

Add a reference plane

1 In the Project Browser, under Floor Plans, double-click Ref. Level.

2 Click Create tab ➤ Datum panel ➤ Reference Plane drop-down ➤ Draw Reference Plane.

3 Sketch a reference plane 3'' below the Center (Front/Back) reference plane, and name it Int Wrap
Depth.

This reference plane between the interior face of the wall and the center reference plane is used
to create the remaining 2 voids for the opening.

4 Click Detail tab ➤ Dimension panel ➤ Aligned.

5 Dimension the Int Wrap Depth and the Ext Wrap Depth reference planes.

The dimension value is not important.
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6 Select the dimension, and on the Options Bar, for Label, click <Add parameter>.

7 In the Parameter Properties dialog, for Name, enter Frame Depth, for Group parameter under,
select Construction, and click OK.

Create a void

8 Click Create tab ➤ Forms panel ➤ Void drop-down ➤ Extrusion.

9 On the Draw panel, click  (Rectangle).

10 Sketch a rectangle below the wall, approximately as shown:

11 On the Edit panel, click Align.

12 Select the Left reference plane, select the left sketch line, and click  to lock the alignment.

13 Select the Right reference plane, select the right sketch line, and lock the alignment.
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14 Select the Ext Wrap Depth reference plane, select the top sketch line, and lock the alignment.

15 Select the Int Wrap Depth reference plane, select the bottom sketch line, and lock the alignment.

16 On the Extrusion panel, click Finish Extrusion.

17 In the Project Browser, under Elevations, double-click Exterior.
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18 Click Modify tab ➤ Edit panel ➤ Align.

19 Select the Head reference plane, select the top of the cut extrusion, and lock the alignment.

20 Using the method you learned previously, open the Family Types dialog, and apply the family
types to flex the geometry.

Cut the void from the host wall

21 In the Project Browser, under Floor Plans, double-click Ref. Level.

22 Click Modify tab ➤ Edit Geometry panel ➤ Cut drop-down ➤ Cut Geometry.

23 Select the void, select the wall, and click Modify.
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24 Click  ➤ Save.

25 Proceed to the next exercise, Creating a Void to Cut the Interior Wall Face on page 253.

Creating a Void to Cut the Interior Wall Face
In this exercise, you create a third void for the complex opening to cut the interior face of the wall. You
place reference planes for the wrap on the interior face of the wall. These reference planes will be constrained
to assume the thickness of the interior finish material. The overhang value could be defined with a parameter,
but to simplify this exercise, it will be a constrained dimension.

Add reference planes to define the void

1 Click Create tab ➤ Datum panel ➤ Reference Plane drop-down ➤ Pick Existing Line/Edge.

2 On the Options Bar, for Offset, enter 1/2”, and press Enter.

3 Select the Right reference plane so that the new reference plane is positioned toward the center
of the window.

4 Select the Left reference plane so that the new reference plane is positioned toward the center
of the window.

5 Name the new reference planes Int Wrap Left and Int Wrap Right, accordingly.

6 Click Detail tab ➤ Dimension panel ➤ Aligned.

7 Dimension the left 2 reference planes, and lock the dimension.
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8 Dimension the right 2 reference planes, and lock the dimension.

Create the third void

9 Click Create tab ➤ Forms panel ➤ Void drop-down ➤ Extrusion.

10 On the Draw panel, click  (Rectangle).

11 Sketch a rectangle below the wall, approximately as shown:
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12 Align and lock the sketch lines:

■ On the Edit panel, click Align.

■ Select the Int Wrap Left reference plane, select the left sketch line, and lock the alignment.

■ Select the Int Wrap Right reference plane, select the right sketch line, and lock the alignment.

■ Select the Int Wrap Depth reference plane, select the top sketch line, and lock the alignment.

Creating a Void to Cut the Interior Wall Face | 255



■ Select the Int Wall Face reference plane, select the bottom sketch line, and lock the alignment.

13 On the Extrusion panel, click Finish Extrusion.

Create a reference plane at the window head

14 In the Project Browser, under Elevations, double-click Exterior.

15 Zoom in to the upper left corner of the window opening.
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16 Click Create tab ➤ Datum panel ➤ Reference Plane drop-down ➤ Pick Existing Line/Edge.

17 On the Options Bar, for Offset, enter 1/2'', and press Enter.

18 Select the Head reference plane so that the new reference plane is offset below it, and name the
reference plane Int Wrap Top.

19 Click Detail tab ➤ Dimension panel ➤ Aligned.

20 Dimension the 2 horizontal reference planes, as shown:

21 Lock the dimension.

22 Zoom out, and click Modify tab ➤ Edit panel ➤ Align.

23 Select the Int Wrap Top reference plane, select the top of the cut extrusion, and lock the
alignment.
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Cut the void from the host wall

24 In the Project Browser, under Floor Plans, double-click Ref. Level.

25 Click Modify tab ➤ Edit Geometry panel ➤ Cut drop-down ➤ Cut Geometry.

26 Select the cut extrusion, select the wall, and then click Modify.

27 On the Quick Access toolbar, click  (3D View).

28 Using the method you learned previously, open the Family Types dialog, and apply the family
types to flex the geometry.

29 Click  ➤ Save.

30 Proceed to the next exercise, Testing the Window Family on page 259.
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Testing the Window Family
In this exercise, you load the complex window family into a project, place the window component in a
cavity wall, and test the family.

Load and place the family in a project

1 Click  ➤ New ➤ Project.

2 In the New Project dialog, click OK to use the default template.

3 Click Home tab ➤ Build panel ➤ Wall drop-down ➤ Wall.

You draw a test wall to host the window.

4 In the Type Selector, select Basic Wall : Exterior - Brick on Mtl. Stud.

This is a cavity wall type.

5 Sketching from left to right, sketch a 24' horizontal wall in the center of the drawing area.

The exterior of the wall is the top edge.

6 On the Selection panel, click Modify.

7 Click View tab ➤ Windows panel ➤ Switch Windows drop-down ➤ Complex_Window.rfa - 3D
View: {3D}.

8 On the Family Editor panel, click Load into Project.

The complex window is loaded into the test project.

9 In the Type Selector, select Complex_Window : 4'0" H x 5'0" W_1'6" Casement.

10 Click the wall on the top edge (exterior) to place the window.

11 Click Modify.

Change the detail level and scale

12 On the View Control bar, click Detail Level ➤ Fine.

13 On the View Control Bar, for Scale, select 1 1/2'' = 1'-0''.

Adjust wrap depth

14 In the Drawing Area, select the window.
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15 On the Element panel, click Element Properties drop-down ➤ Type Properties.

16 In the Type Properties dialog, under Construction, for Ext. Wrap Depth, enter 6 5/8''.

17 Click OK.

You adjust the depth of the exterior wrap so it accounts for the depth of the exterior material
and the cavity, in this case 6 5/8''.

18 Press Esc.

The opening appears correct, except the wall materials are not wrapping the window opening.
Next, you open the window family to make changes to correct this issue.

Specify the Wall Closure property in the window family

19 Click View tab ➤ Windows panel ➤ Switch Windows drop-down ➤ Complex_Window.rfa -
Floor Plan: Ref. Level.

20 Select the Ext Wrap Depth reference plane.

21 On the Element panel, click Element Properties.

22 Under Other, for Is Reference, select Not a Reference.

23 Under Construction, select Wall Closure, and click OK.

You modify reference plane properties to define the stop point for the wrap.

24 Repeat the previous steps for the Int Wrap Depth reference plane.

25 On the Family Properties panel, click Types.

26 In the Family Types dialog, under Construction, for Wall Closure, select Both.

Specifying the value Both for wall closure allows both sides to close as intended.

27 Repeat the previous step for each of the other 2 family types.

28 For Name, verify that 4'0''H x 5'0''W_1'6''Casement is selected, and click OK.

Reload the window family and test

29 On the Family Editor panel, click Load into Project.

30 In the Family Already Exists dialog, click Overwrite the existing version and its parameter values.

31 Select the wall, and on the Element panel, click Element Properties drop-down ➤ Type Properties.

32 In the Type Properties dialog, under Construction, for Wrapping at Inserts, select Both.

33 Click OK.

34 Press Esc.

Now the brick is wrapping on the exterior and the gypsum board is wrapping on the interior
face.
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35 Click  ➤ Save.

36 In the left pane of the Save As dialog, click Training Files, and save the project as
Imperial\i_complex_window.rvt.

37 Proceed to the next lesson, Creating the Window Geometry on page 263.
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Creating the Window
Geometry

Creating the Window Geometry
Now that the opening is complete, you are ready to add the window geometry. First, you create an adjustable
center post between the fixed window and the casement windows. Next, you add the window frame, window
sash, and glass geometry. After the 3D geometry is complete, you add symbolic lines to the window family
for plan and elevation views.

Skills used in this lesson:

■ Creating solid geometry, including extrusions and sweeps

■ Setting the work plane for sketching geometry

■ Specifying subcategories for solid geometry display

9
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■ Creating symbolic lines for casement swing in plan and elevation views

■ Using a reference line to constrain to an angle

■ Adding a flip control to determine the position of a casement window

Creating the Center Post Geometry
In this exercise, you create an adjustable center post between the fixed and the casement windows. You
associate the post with the casement window so that when that window width changes, the post location
changes. The post also has an adjustable width parameter.

Training File

Continue to use the family that you used in the previous exercise, Complex_Window.rfa, or open training
file Imperial\Families\Windows\Complex_Window_01.rfa.

Rename family file

1 If you are using the supplied training file, click  ➤ Save As ➤ Family.

2 In the left pane of the Save As dialog, click Training Files, and save the file as
Imperial\Families\Complex_Window.rfa.

Create reference planes to define the edges of the post

3 In the Project Browser, under Floor Plans, double-click Ref. level.

4 Add 3 reference planes:

■ Click Create tab ➤ Datum panel ➤ Reference Plane drop-down ➤ Draw Reference Plane.

■ Sketch 3 vertical reference planes to the left of the Center (Left/Right) reference plane, as
shown:

■ Press Esc twice.

5 Starting from left to right, name the new reference planes:

■ Post Left
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■ Post Center

■ Post Right

6 Dimension the reference planes to establish a center for the post:

■ Click Detail tab ➤ Dimension panel ➤ Aligned.

■ Dimension the 3 post reference planes, and click EQ.
The EQ toggle establishes a center point for the post.

■ Dimension the Post Left and Post Right reference planes, and on the Selection panel, click
Modify.

Assign parameters for the post

7 Assign a parameter to the post width:

■ Select the last dimension you added, and on the Options Bar, for Label, select <Add
parameter>.

■ In the Parameter Properties dialog, for Name, enter Post Width.

■ For Group parameter under, select Construction.

■ Click OK.

8 Click Detail tab ➤ Dimension panel ➤ Aligned.

9 Select the Left reference plane of the window, select the Post Center reference plane, and click
to place the dimension.
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10 On the Selection panel, click Modify.

11 Select the dimension, and on the Options Bar, for Label, select <Add parameter>.

You assign a parameter to establish a location for the post center line. In order to control the
parameter parametrically, you add a formula based on the post width and the casement window
width.

12 In the Parameter Properties dialog, for Name, enter Post Location, for Group parameter under,
select Construction, and click OK.

13 On the Family Properties panel, click Types.

14 In the Family Types dialog, under Parameters, click Add.

15 Create a new parameter to establish the casement window width:

■ In the Parameter Properties dialog, for Name, enter Casement Width.

■ For Group parameter under, select Dimensions.

■ For Type of Parameter, select Length.

■ Click OK.

16 In the Family Types dialog:

■ For Name, verify 4'0''H x 5'0''W_1'6''Casement.

■ Under Dimensions, for Casement Width, enter 1'6''.

■ Under Construction, for Post Width, enter 3''.

■ Click Apply.
You specify the casement width to match the width in the type name.

17 In the Formula field for Post Location, enter Casement Width + (Post Width/2).

18 Define values for the other window types, and flex the family:

■ For Name, select 4'0''H x 3'0''W_1'6''Casement.
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■ Under Dimensions, for Casement Width, enter 1'6''.

■ Under Construction, for Post Width, enter 3''.

■ For Name, select 5'6''H x 6'0''W_2'0''Casement.

■ For Casement Width, enter 2'.

■ For Post Width, enter 4'', click Apply, and click OK.

Add reference planes for the center post geometry

19 Zoom in to the area for the center post.

20 Click Create tab ➤ Datum panel ➤ Reference Plane drop-down ➤ Draw Reference Plane.

You create and constrain reference planes to establish the front and back edges of the center
post. The post should extend 1/4'' from the face of the frame on both sides.

21 Sketch a short horizontal reference plane above the Ext Wrap Depth reference plane, as shown,
and name the plane Ext Post Face.

22 Sketch a short horizontal reference plane below the Int Wrap Depth reference plane, as shown,
and name the plane Int Post Face.

23 Dimension and constrain the new reference planes 1/4'' from the Ext Wrap Depth and Int Wrap
Depth reference planes.
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24 Using the method you learned previously, open the Family Types dialog, and apply the family
types to flex the geometry.

Create the center post geometry

25 Click Create tab ➤ Forms panel ➤ Solid drop-down ➤ Extrusion.

26 On the Draw panel, click  (Rectangle).

27 Sketch a rectangle for the post within the reference planes, as shown:

28 If the display of the lines is too thick, click View tab ➤ Graphics panel ➤ Thin Lines.

29 Click Create Extrusion tab ➤ Edit panel ➤ Align.

30 Align and lock the sketch as shown:
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31 On the Extrusion panel, click Finish Extrusion.

32 In the Project Browser, under Elevations, double-click Exterior.

33 Click Modify tab ➤ Edit panel ➤ Align.

34 Select the Head reference plane, select the top of the post extrusion, and click the lock icon to
constrain the alignment.

35 On the Selection panel, click Modify.

36 Click  ➤ Save.

37 Proceed to the next exercise, Creating the Window Frame Geometry on page 270.
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Creating the Window Frame Geometry
In this exercise, you create solid sweeps for the window frames. You align the path and sweep edges to the
reference planes, ensuring that the family flexes as intended.

Sketch the path for the frame sweep

1 If necessary, in the Project Browser, under Elevations, double-click Exterior.

2 Click Create tab ➤ Forms panel ➤ Solid drop-down ➤ Sweep.

3 On the Mode panel, click Sketch Path.

4 Click Create tab ➤ Work Plane panel ➤ Set.

5 In the Work Plane dialog, for Name, verify that Reference Plane: Center (Front/Back) is selected.

6 Click OK.

7 Click Sweep>Sketch Path tab ➤ Draw panel ➤  (Rectangle).

NOTE When sketching the path for a sweep, the profile icon will appear on the first segment of the
path drawn.

8 Starting in the lower left corner and moving to the upper right corner, sketch a rectangle to the
right of the center post, as shown. This ensures that the profile location is at the bottom of the
sketch.

9 Align and constrain the path to the reference planes defining the second opening:

■ On the Edit panel, click Align.

■ Align and lock the sketch to reference planes, as shown:
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10 On the Path panel, click Finish Path.

Sketch the profile for the frame sweep

11 Click Sweep tab ➤ Mode panel ➤ Select Profile.

12 Click Modify Profile tab ➤ Edit panel ➤ Edit Profile.

13 In the Go To View dialog, with Elevation: Left selected, click Open View.

14 On the Draw panel, click  (Rectangle).

15 Sketch a small rectangle in the bottom of the window frame, as shown:
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16 On the Edit panel, click Align.

17 Select the Sill reference plane, select the bottom of the profile, and lock the alignment.

18 Align and lock the sides of the profile to the Ext Wrap Depth and Int Wrap Depth reference
planes.

19 On the Selection panel, click Modify.

20 Select the top of the profile, click the dimension, enter 2'', and press Enter.

Adjusting the profile creates a 2'' frame.

21 On the Profile panel, click Finish Profile.

22 On the Sweep panel, click Finish Sweep.

23 On the Quick Access toolbar, click  (3D View).
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Create the second frame

24 Using the method you just learned, create the frame on the other side of the post:

■ Open the Exterior elevation view, and sketch a 2D path for the solid sweep.

■ Align and constrain the path to the opening reference planes.
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■ Sketch a profile for the frame sweep.

■ Align and constrain the profile to reference planes.

■ Specify 2'' for the final edge of the profile.

■ Finish the profile and sweep, and view the window in 3D.
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Specify the wrap overhangs and the frame width

25 On the Family Properties panel, click Types.

26 For Name, verify 5'6''H x 6'0''W_2'0''Casement is selected.

27 In the Family Types dialog:

■ Under Construction, for Frame Depth, enter 6''.

■ Under Other, for Ext. Wrap Overhang, enter 1''.

■ Click Apply.

28 For Name, select 4'0''H x 5'0''W_1'6''Casement, for Frame Depth, enter 4'', for Ext. Wrap Overhang,
enter 3/4'', and click Apply.
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29 For Name, select 5'6''H x 6'0''W_2'0''Casement, click Apply, and click OK.

30 Click  ➤ Save.

31 Proceed to the next exercise, Creating the Window Sash and Glass Geometry on page 276.

Creating the Window Sash and Glass Geometry
In this exercise, you create solid extrusions for the window sash and glass geometry. You also specify
subcategories for the solid geometry to control the display of the glass and frame/mullion components.

Add a reference plane for the glass

1 In the Project Browser, under Floor Plans, double-click Ref. Level.

2 Click Create tab ➤ Datum panel ➤ Reference Plane drop-down ➤ Draw Reference Plane.

To make it easier to create the sash and glass portions of the window, you add a reference plane
to establish a center axis for the glass. The position of this axis is constrained to the exterior
face of the window frame.

3 Sketch a horizontal reference plane below the Ext Wrap Depth reference plane, and name the
plane Glass Axis.

You provide a name for the reference plane so that it can be selected as a work plane in later
steps.
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4 Zoom in to the right side of the wall.

5 Click Detail tab ➤ Dimension panel ➤ Aligned.

6 Dimension and constrain the Glass Axis reference plane:

■ Select the Glass Axis reference plane, select the Ext Wrap Depth reference plane, and click
to place the dimension.

■ On the Selection panel, click Modify.

■ Select the Glass Axis reference plane, select the dimension, enter 2'', and press Enter.

■ Press Esc.

■ Select the dimension, and click the lock icon.

Create the geometry for the left sash

7 In the Project Browser, under Elevations, double-click Exterior.

8 Click Create tab ➤ Forms panel ➤ Solid drop-down ➤ Extrusion.

9 Click Create tab ➤ Work Plane panel ➤ Set.

10 In the Work Plane dialog, for Specify a new Work Plane, select Reference Plane : Glass Axis, and
click OK.

11 Click Create Extrusion tab ➤ Draw panel ➤  (Rectangle).

12 Sketch a rectangle within the left frame for the sash extrusion.
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13 On the Edit panel, click Align.

14 Align and lock the sketch lines to the interior face of the window frame, as shown:

15 On the Draw panel, click  .

16 On the Options Bar, for Offset, enter -2''.

17 Click the lower left endpoint of the sash sketch, and click the upper right endpoint to create
the second closed loop.

NOTE When the second loop is created, relationships are established to the first loop. These
relationships are based on how Revit Architecture determines design intent. Often, these relationships
are correct, but the relationships may have to be more explicitly defined using dimensions or
parameters.
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18 On the Element panel, click Extrusion Properties.

You specify the extrusion properties to extend on both sides of the glass axis (the current work
plane).

19 In the Instance Properties dialog:

■ Under Constraints, for Extrusion End, enter -3/4''.

■ For Extrusion Start, enter 3/4''.

■ Click OK.

20 On the Extrusion panel, click Finish Extrusion.

21 On the Quick Access toolbar, click  (3D View).

Create geometry for the right sash

22 Open the Exterior elevation view and, using the method you just learned, add a sash to the
other side of the window:

■ In the Exterior elevation view, sketch the shape of the sash extrusion.
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■ Align and lock the extrusion to the interior face of the window frame.

■ Create the second closed loop sketch for the sash, offset -1'' from the first sketch.
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■ Specify extrusion properties, finish the sketch, and view the window in 3D.

23 Open the Family Types dialog, and flex the model to test geometry behavior.

Create a solid extrusion for the window glass

24 In the Project Browser, under Elevations, double-click Exterior.

25 Click Create tab ➤ Forms panel ➤ Solid drop-down ➤ Extrusion.

26 Click Create tab ➤ Work Plane panel ➤ Set.

27 In the Work Plane dialog, for Specify a new Work Plane, verify that Name and Reference Plane
: Glass Axis are selected, and click OK.

28 Click Create Extrusion tab ➤ Draw panel ➤  (Rectangle), and sketch 2 rectangles, one for
each pane of glass, as shown:
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29 On the Edit panel, click Align.

30 Align and lock the extrusions to the sash faces, as shown:

31 On the Element panel, click Extrusion Properties.

32 In the Instance Properties dialog, for Extrusion End, enter -1/4'', and for Extrusion Start, enter
1/4'', and click OK.

This method establishes the glass thickness without additional reference planes.

33 On the Extrusion panel, click Finish Extrusion.

34 On the Quick Access toolbar, click  (3D View).

35 Open the Family Types dialog, and flex the model to test geometry behavior.

Specify subcategories for geometry

36 Select the glass, and on the Element panel, click Element Properties.
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Specify the subcategories for the solid geometry created in the previous steps. This gives you
control over the display of these items when you load them into a project.

37 In the Instance Properties dialog, under Identity Data, for Subcategory, select Glass, and click
OK.

38 Press Esc.

39 While pressing Ctrl, select the window frame, both sashes, and the post geometry, and on the
Element panel, click Element Properties.

40 In the Instance Properties dialog, under Identity Data, for Subcategory, select Frame/Mullion,
and click OK.

41 Press Esc.

42 On the View Control Bar, click Model Graphics Style ➤ Shading with Edges.
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43 Click  ➤ Save.

44 Proceed to the next exercise, Adding Symbolic Lines on page 284.

Adding Symbolic Lines
The window geometry is complete. Next, you add symbolic lines to the window family to represent the
casement swing in plan and elevation views. You also turn off the visibility of the glass and replace it with
a single symbolic line, so that the window displays cleanly in plan view. When the extrusion for the glass
is visible, it creates a double line that is too heavy for the graphic standards.

Training File

Continue to use the family that you used in the previous exercise, Complex Window.rfa, or open training
file Imperial\Families\Windows\Complex_Window_02.rfa.

Rename family file

1 If you are using the supplied training file, click  ➤ Save As ➤ Family.

2 In the left pane of the Save As dialog, click Training Files, and save the file as
Imperial\Families\Complex_Window.rfa.

Turn off visibility of the glass in plan views

3 In the Project Browser, under Floor Plans, double-click Ref. Level.

4 Select the glass, and on the Form panel, click Visibility Settings.
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5 In the Family Element Visibility Settings dialog, clear Plan/RCP and When cut in Plan/RCP (if
category permits).

6 Click OK.

Add symbolic lines to represent the glass in plan view

7 Click Detail tab ➤ Detail panel ➤ Symbolic Line.

8 In the Type Selector, select Glass [cut].

9 Zoom in to the left glass element.

10 Sketch a line along the Glass Axis reference plane to represent the glass:

■ Select the midpoint of the sash on the right.

■ Select the midpoint of the sash on the left.

11 Press Esc twice.

12 Select the left endpoint of the symbolic line, and click the lock icon to constrain the line to the
sash.

13 Using the same method, constrain the right endpoint of the symbolic line.

The line is constrained to the sash and the glass axis.

14 Using the same method, add and constrain a symbolic line to the glass on the other side of the
post.
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Add a reference plane to control the reference line

15 Click Create tab ➤ Datum panel ➤ Reference Plane drop-down ➤ Draw Reference Plane.

16 Sketch a vertical reference plane on the left side of the opening, close to the inner face of the
frame.

17 Click Detail tab ➤ Dimension panel ➤ Aligned.

18 Dimension the Left reference plane and the new reference plane.

19 On the Selection panel, click Modify.

20 Click on the new reference plane, select the dimension you just placed, enter 2”, and press Enter.

The dimension now matches the frame width. The hinge point of the window swing symbol
will be at the intersection of the glass line and the reference plane on the inside face of the
frame.

NOTE It is best practice to dimension from reference planes and reference lines to control placement
of geometry. The symbolic lines for the window are drafted on a reference line so that you can control
the angle of the opening.

21 Press Esc, select the dimension, and click the lock icon.

Add a reference line for the window swing

22 Click Create tab ➤ Datum panel ➤ Reference Line drop-down ➤ Draw by Line.

You use a reference line to establish the position of the symbolic line (at a 45-degree angle to
the window). Because a reference line has endpoints (unlike a reference plane that extends
''infinitely'' in all directions), it can be used to create a parametric relationship using an angle.

23 Click to select the midpoint of the left edge of the glass frame.

24 Move the cursor up and to the right at a 45-degree angle, and click to select the endpoint.

The length is not important.
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25 Press Esc twice.

26 Select the left endpoint of the reference line, and click the lock icon below the left endpoint.

27 Click Detail tab ➤ Dimension panel ➤ Aligned.

28 Using TAB, select each endpoint of the reference line, and place the dimension.

29 Click Modify, and select the dimension.

30 On the Options Bar, for Label, click <Add parameter>.

You add a parameter to control the length of the swing line.

31 In the Parameter Properties dialog, for Name, enter Swing Width, and click OK.
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32 Dimension and constrain the angle of the reference line:

■ Click Detail tab ➤ Dimension panel ➤ Angular.

■ Select the reference line, select the Glass Axis reference plane, and click to place the dimension.

33 On the Selection panel, click Modify.

34 Select the angle dimension and on the Options Bar, for Label, select <Add parameter).

35 In the Parameter Properties dialog, for Name, enter Swing Angle, and click OK.
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Add a formula to control the swing width

36 On the Family Properties panel, click Types.

37 In the Family Types dialog, under Other, for Swing Width Formula, enter Casement Width - 4'',
and click Apply.

The length of the symbolic line should be as long as the sash portion of the window. The 4"
measurement is the width of the frame (both sides) that you drew in previous steps.

38 For Swing Angle, enter 30, and click Apply.

This is to confirm the reference line moves as anticipated around the hinge.

39 For Swing Angle, enter 45, and click Apply.

40 Under Name, select 4'0''H x 5'0''W_1'6''Casement, and click Apply.

41 Under Name, select 5'6''H x 6'0''W_2'0''Casement, click Apply, and click OK.

Add a symbolic line for the swing width

42 Click Detail tab ➤ Detail panel ➤ Symbolic Line.

43 In the Type Selector, select Elevation Swing [cut].

This is a dashed line type.

44 Sketch a symbolic line using the endpoints of the reference line.

45 Click Modify.

46 Select an endpoint on the symbolic line, and click the lock icon adjacent to the swing width to
constrain the length to the reference line.

47 Press Esc.

Add an arc for the symbolic swing display

48 Click Detail tab ➤ Detail panel ➤ Symbolic Line.

49 On the Draw panel, click  (Center-ends Arc).

50 Click the lower endpoint of the symbolic line, click the upper endpoint, click the midpoint of
the frame, and click the lock icon to constrain the end to the glass line.
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51 On the Selection panel, click Modify.

52 Using the method you learned previously, open the Family Types dialog, and apply the family
types to flex the geometry.

Add swing lines to the elevation of the window

53 In the Project Browser, under Elevations, double-click Exterior.

54 Click Create tab ➤ Datum panel ➤ Reference Plane drop-down ➤ Draw Reference Plane.

55 Sketch a horizontal reference plane through the middle of the window.

56 Click Detail tab ➤ Dimension panel ➤ Aligned.

57 Dimension the Head reference plane, the new reference plane, and the Sill reference plane, and
click EQ.
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58 Click Detail tab ➤ Detail panel ➤ Symbolic Line, and on the Options Bar, select Chain.

59 In the Type Selector, select Elevation Swing [projection].

60 Zoom in to the right glass pane.

61 Sketch the symbolic lines:

■ Select the upper left corner of the glass.

■ Move the cursor down and to the right, and select the midpoint at the intersection of the
glass and the center reference plane.

■ Move the cursor down and to the left, and select the lower left corner of the glass.

■ On the Selection panel, click Modify.

Flex the window family

62 On the Family Properties panel, click Types.

63 In the Family Types dialog, for Name, select 4'0''H x 5'0''W_1'6''Casement, and click Apply.

64 For Name, select 5'6''H x 6'0''W_2'0''Casement, click Apply, and click OK.

Add a horizontal flip control

65 In the Project Browser, under Floor Plans, double-click Ref. Level.

66 Click Create tab ➤ Control panel ➤ Control.
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67 On the Control Type panel, click Double Horizontal.

You add a horizontal flip control so the casement window can be positioned on the left or right
side.

68 Click above the right area of the window to add the flip control.

69 Click  ➤ Save.

Load the window into a project

70 Click  ➤ Open ➤ Project.

71 In the left pane of the Open dialog, click Training Files, and open
Imperial\i_complex_window.rvt.

72 Click View tab ➤ Windows panel ➤ Switch Windows drop-down ➤ Complex_Window.rfa -
Elevation : Exterior.

73 On the Family Editor panel, click Load into Project.

74 In the Family Already Exists dialog, click Overwrite the existing version and its parameter values.

75 Select the window, and click  (Flip the instance hand) to change the position of the casement
window.

76 On the Quick Access toolbar, click  (3D View).
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77 Click  ➤ Save.

78 Proceed to the next lesson, Nesting Sill Families into the Window Family on page 295.
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Nesting Sill Families into
the Window Family

Nesting Sill Families into the Window Family
You can import families into other families, which nests them. You can then model parts of the nested
family separately from the main family model. Using family type parameters in the main family, you can
switch between imported families of the same category.

In this lesson, you import window sill families into the window family and associate parameters of the
nested families to the main family.

Creating Sill Families
There are 2 window sill families available in the training folders. In this exercise, you open the families and
explore how they are designed.

Open the Concrete Sill family

1 Close all open projects or families.

2 Click  ➤ Open ➤ Family.

3 In the left pane of the Open dialog, click Training Files, navigate to
Imperial\Families\Windows\Concrete Sill.rfa, and click Open.

4 In the Project Browser, under Floor Plans, double-click Ref. Level.

The concrete sill family consists of a solid extrusion, a Width type parameter, a Depth instance
parameter, and a fixed dimension for the sill overhang. The Back and Center (Left/Right) reference
planes define the origin of the family. The sills are not defined as work plane-based.

10
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5 In the Project Browser, under Elevations, double-click Left.

The elevation view shows reference planes with fixed dimensions. The sketch lines of the
extrusion are locked to all exterior reference planes. The Bottom reference plane defines the
origin of the family.

6 In the Project Browser, under 3D views, double-click View 1.
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7 Select the solid geometry, and on the Element panel, click Element Properties
drop-down ➤ Instance Properties.

The sill is placed on a subcategory Window Sill, has a fixed material Window Sill Concrete
assigned, and is visible only in detail level Fine.

8 In the Instance Properties dialog, click Cancel.

9 On the Family Properties panel, click Category and Parameters.

10 In the Family Category and Parameters dialog, under Family Category, notice that Windows is
selected.

11 Under Family Parameters, select Work Plane-Based.

Unlike a window which is level-based, it is helpful to be able to place the sill on a sill reference
plane.

12 Click OK.

Open the Metal Sill family

13 Save and close the concrete sill file.

14 Click  ➤ Open ➤ Family.

15 In the left pane of the Open dialog, click Training Files, navigate to
Imperial\Families\Windows\Metal Sill.rfa, and click Open.

16 Select the solid geometry, and on the Element panel, click Element Properties.

The sill is placed on a subcategory Window Sill, has a fixed material Window Sill Metal assigned,
and is visible only in detail level Fine. Parameters, Reference Planes, and Origins are as in the
concrete sill family.

17 In the Instance Properties dialog, click Cancel.

18 On the Family Properties panel, click Category and Parameters.

19 In the Family Category and Parameters dialog, under Family Category, notice that Windows is
selected.

20 Under Family Parameters, select Work Plane-Based.

21 Click OK.

Both sill families were created with the Generic Model family template and changed to a window
family. The category of a family can be changed by clicking Family Properties panel ➤ Category
and Parameters.

22 Click  ➤ Save.
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Loading Sill Families into the Window Family
Families opened in the Family Editor can be loaded directly into other families. In this exercise, you open
the main family first, and then load families into the complex window family you created.

Training File

Continue to use the family that you used in a previous exercise, Complex_Window.rfa, or open training file
Imperial\Families\Windows\Complex_Window_03.rfa.

Rename family file

1 If you are using the supplied training file, click  ➤ Save As ➤ Family.

2 In the left pane of the Save As dialog, click Training Files, and save the file as
Imperial\Families\Complex_Window.rfa.

Load the concrete sill

3 Click  ➤ Open ➤ Family.

4 In the Open dialog, navigate to Imperial\Families\Windows\Concrete Sill.rfa, and click Open.

5 On the Family Editor panel, click Load into Project.

6 If the Load into Projects dialog displays, select Complex_Window.rfa, and verify that Metal
Sill.rfa is cleared.

7 Click OK.

The concrete sill family is now loaded into the Window family.

Load the metal sill

8 Click View tab ➤ Windows panel ➤ Switch Window drop-down ➤ Metal Sill.rfa -3D View:
View1.

9 Load the sill family into the Window family.

10 Click View tab ➤ Windows panel ➤ Tile.

11 Close Metal Sill.rfa and Concrete Sill.rfa.

12 Maximize Complex_Window.rfa.
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As both sill families have been defined as Window families, they appear in the Project Browser
under Families ➤ Windows.

Associate the Width parameter to nested families

13 In the Project Browser, under Families ➤ Windows ➤ Concrete Sill, double-click Concrete Sill.

14 In the Type Properties dialog, for Dimensions ➤ Length, click  .

15 In the Associate Family Parameter dialog, select Width.

The sill length needs to be equivalent to the exterior width of the window family.

16 Click OK twice.

17 Using the same method, associate the Length parameter of the Metal Sill family.

The Length type parameter of the nested families now has the same value as the Width parameter
of the window family.

Placing the Sill Family
In this exercise, you place the concrete sill in the Complex Window project, aligning it to reference planes
in both plan and elevation views.

Place the family

1 In the Project Browser, under Floor Plans, double-click Ref. Level.

2 On the View Control Bar, click Detail Level ➤ Fine.

3 In the Project Browser, expand Families ➤ Windows ➤ Concrete Sill.

4 Drag Concrete Sill into the drawing area.

5 On the Placement panel, click Place on Work Plane.

6 On the Options Bar, for Placement Plane, select Reference Plane: Sill

7 Click to place the sill above the window.

8 On the Selection panel, click Modify.

Associate an instance parameter

9 Select the solid geometry of the concrete sill, and on the Element panel, click Element Properties.

10 In the Instance Properties dialog, for Dimensions ➤ Width, click  .

11 In the Associate Family Parameter dialog, select Ext. Wrap Depth.

12 Click OK twice.
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The Width instance parameter of the nested sill family now has the same value as the Ext. Wrap
Depth parameter of the window family.

The sill needs to be positioned and aligned in plan and elevation views.

Align the sill

13 Click Modify tab ➤ Edit panel ➤ Align.

14 Select the Center (Left/Right) reference plane of the window family, select the hidden Center
(Left/Right) reference plane of the Sill family, and lock the alignment.

15 Using the same method, align the lower horizontal edge of the sill to the Ext. Wrap Depth
reference plane (2nd from the top), and lock the alignment.

16 In the Project Browser, under Elevations, double-click Left.

17 On the View Control Bar, click Detail Level ➤ Fine.

18 Click Modify tab ➤ Edit panel ➤ Align.

19 Select the Sill reference plane of the window family, align the bottom edge of the sill family,
and lock the alignment.

20 In the Project Browser, under 3D Views, double-click View 1.

21 On the View Control Bar, click Model Graphics Style ➤ Shading with Edges.

22 On the View Control Bar, click Detail Level ➤ Fine.
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The sill is placed in the desired position.

TIP If the sill does not display, on the navigation bar, click  and use the Orbit tool to spin the
wall.

Creating a Shared Parameter
In order to switch the sill from concrete to metal on an instance level, you add a Sill Type parameter.

To display the custom parameter in a schedule, you must define the parameter as shared. If the family is
then loaded into a project, the parameter appears as an available field on the Fields tab of the Schedule
Properties dialog.

NOTE You could create a family parameter to control the sill type when the window family is used in a project;
however, family parameters are not available for scheduling. If you wish to include a parameter in a schedule, it
must be defined as a shared parameter.

Create the shared parameter

1 Click Manage tab ➤ Family Settings panel ➤ Shared Parameters.

2 In the Edit Shared Parameters dialog, click Create.

3 In the left pane of the Create Shared Parameter File dialog, click Training Files.

4 Under File name, enter Training Shared Parameter, and click Save.

5 In the Edit Shared Parameters dialog, under Groups, click New.

6 In the New Parameter Group dialog, for Name, enter Windows, and click OK.

7 In the Edit Shared Parameters dialog, under Parameters, click New.

8 In the Parameter Properties dialog:

■ For Name, enter Sill Type.

■ Under Type of Parameter, select <Family Type>.

Creating a Shared Parameter | 301



9 In the Select Category dialog, select Windows.

10 Click OK 3 times.

Add the parameter to a family

11 On the Family Properties panel, click Types.

12 In the Family Types dialog, under Parameters, click Add.

13 In the Parameter Properties dialog, under Parameter Type, select Shared parameter, and click
Select.

14 In the Shared Parameters dialog, verify that Sill Type is selected, and click OK.

Note that the last created Shared Parameter file has been automatically opened.

15 In the Parameter Properties dialog, for Group parameter under, select Construction, and select
Instance.

16 Click OK twice.

Associate the parameter to geometry

17 In the drawing area, select the Concrete Sill family.

18 On the Options Bar, for Label, select Sill Type.

Testing Nested Families
You can test the correct behavior of the nested families directly in the window family.

1 On the Family Properties panel, click Types.

2 In the Family Types dialog, for Construction ➤ Sill Type (default), select Metal Sill.

3 Click Apply.

The metal sill replaces the concrete sill.

4 Click OK.

Testing the Family in a Project Environment
Finally, you test the window in the project environment, and create a window schedule.
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Test windows and sills

1 Click  ➤ Open ➤ Project.

2 Navigate to the location of i_complex_window.rvt that you saved previously, and open the
project.

3 Click View tab ➤ Windows panel ➤ Switch Windows drop-down ➤ Complex_Window.rfa -3D
View: View 1.

4 On the Family Editor panel, click Load into Project.

5 In the Family Already Exists dialog, click Overwrite the existing version and its parameter values.

6 Click Home tab ➤ Build panel ➤ Window.

7 In the Type Selector, select Complex_Window : 4'0''H x 5'0''W_1'6''Casement, and place the
window in the wall to the left of the existing window.

8 On the Selection panel, click Modify.

9 On the View Control Bar, click Model Graphics Style ➤ Shading with Edges.

10 In the View Control Bar, click Detail Level ➤ Fine.

TIP If the sill does not display, on the navigation bar, click  and use the Orbit tool to spin the
wall.

11 Select the window you just added, and on the Element panel, click Element Properties.

12 In the Instance Properties dialog, for Construction ➤ Sill Type, select a new sill type, and click
OK.

Note that the window sill has changed.

Create a window schedule

13 Click View tab ➤ Create panel ➤ Schedules drop-down ➤ Schedule/Quantities.

14 In the New Schedule dialog:

■ Under Category, select Windows.

■ Under Name, enter Window Schedule with Sills.

■ Click OK.

15 In the Schedule Properties dialog, add the fields Mark, Width, Height, and Sill Type to the
Scheduled fields list, and click OK.

Sill Type is now displayed in the schedule table.
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16 Save and close all project files.
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